DynUnionHelper (Java Platform SE 8 )

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class DynUnionHelper

  • java.lang.Object
    • org.omg.DynamicAny.DynUnionHelper

  • public abstract class DynUnionHelper
extends Object
    DynUnion objects support the manipulation of IDL unions. A union can have only two valid current positions:
    • zero, which denotes the discriminator
    • one, which denotes the active member
    The component_count value for a union depends on the current discriminator: it is 2 for a union whose discriminator indicates a named member, and 1 otherwise.

    • Constructor Summary

      Constructors
      Constructor and Description
      DynUnionHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static DynUnion | extract(Any a)
      static String | id()
      static void | insert(Any a, DynUnion that)
      static DynUnion | narrow(Object obj)
      static DynUnion | read(InputStream istream)
      static TypeCode | type()
      static DynUnion | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, DynUnion value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • DynUnionHelper

        public DynUnionHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          DynUnion that)

      • extract

        public static DynUnion extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static DynUnion read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         DynUnion value)

      • narrow

        public static DynUnion narrow(Object obj)

      • unchecked_narrow

        public static DynUnion unchecked_narrow(Object obj)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature
For further API reference and developer documentation, see Java SE Documentation. That documentation contains more detailed, developer-targeted descriptions, with conceptual overviews, definitions of terms, workarounds, and working code examples.


DynUnionOperations (Java Platform SE 8 )

  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynUnionOperations

  • All Superinterfaces:
    DynAnyOperations
    All Known Subinterfaces:
    DynUnion
    All Known Implementing Classes:
    _DynUnionStub

    public interface DynUnionOperations
extends DynAnyOperations
    DynUnion objects support the manipulation of IDL unions. A union can have only two valid current positions:
    • zero, which denotes the discriminator
    • one, which denotes the active member
    The component_count value for a union depends on the current discriminator: it is 2 for a union whose discriminator indicates a named member, and 1 otherwise.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      TCKind discriminator_kind()
      Returns the TCKind value of the discriminators TypeCode.
      DynAny get_discriminator()
      Returns the current discriminator value.
      boolean has_no_active_member()
      Returns true if the union has no active member, that is, the unions value consists solely of its discriminator because the discriminator has a value that is not listed as an explicit case label.
      TCKind member_kind()
      Returns the TCKind value of the currently active members TypeCode.
      String member_name()
      Returns the name of the currently active member.
      DynAny member()
      Returns the currently active member.
      void set_discriminator(DynAny d)
      Sets the discriminator of the DynUnion to the specified value.
      void set_to_default_member()
      Sets the discriminator to a value that is consistent with the value of the default case of a union.
      void set_to_no_active_member()
      Sets the discriminator to a value that does not correspond to any of the unions case labels.

      • Methods inherited from interface org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

    • Method Detail

      • get_discriminator

        DynAny get_discriminator()
        Returns the current discriminator value.

      • set_discriminator

        void set_discriminator(DynAny d)
                throws TypeMismatch
        Sets the discriminator of the DynUnion to the specified value. Setting the discriminator to a value that is consistent with the currently active union member does not affect the currently active member. Setting the discriminator to a value that is inconsistent with the currently active member deactivates the member and activates the member that is consistent with the new discriminator value (if there is a member for that value) by initializing the member to its default value. Setting the discriminator of a union sets the current position to 0 if the discriminator value indicates a non-existent union member (has_no_active_member returns true in this case). Otherwise, if the discriminator value indicates a named union member, the current position is set to 1 (has_no_active_member returns false and component_count returns 2 in this case).
        Throws:
        TypeMismatch - if the TypeCode of the parameter is not equivalent to the TypeCode of the union's discriminator

      • set_to_default_member

        void set_to_default_member()
                    throws TypeMismatch
        Sets the discriminator to a value that is consistent with the value of the default case of a union. It sets the current position to zero and causes component_count to return 2.
        Throws:
        TypeMismatch - if the union does not have an explicit default case

      • set_to_no_active_member

        void set_to_no_active_member()
                      throws TypeMismatch
        Sets the discriminator to a value that does not correspond to any of the unions case labels. It sets the current position to zero and causes component_count to return 1.
        Throws:
        TypeMismatch - if the union has an explicit default case or if it uses the entire range of discriminator values for explicit case labels

      • has_no_active_member

        boolean has_no_active_member()
        Returns true if the union has no active member, that is, the unions value consists solely of its discriminator because the discriminator has a value that is not listed as an explicit case label. Calling this operation on a union that has a default case returns false. Calling this operation on a union that uses the entire range of discriminator values for explicit case labels returns false.

      • discriminator_kind

        TCKind discriminator_kind()
        Returns the TCKind value of the discriminators TypeCode.

      • member_kind

        TCKind member_kind()
            throws InvalidValue
        Returns the TCKind value of the currently active members TypeCode.
        Throws:
        InvalidValue - if the union does not have a currently active member

      • member

        DynAny member()
       throws InvalidValue
        Returns the currently active member. Note that the returned reference remains valid only for as long as the currently active member does not change. Using the returned reference beyond the life time of the currently active member raises OBJECT_NOT_EXIST.
        Throws:
        InvalidValue - if the union has no active member

      • member_name

        String member_name()
            throws InvalidValue
        Returns the name of the currently active member. If the unions TypeCode does not contain a member name for the currently active member, the operation returns an empty string.
        Throws:
        InvalidValue - if the union has no active member
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method

Submit a bug or feature


DynValue (Java Platform SE 8 )

  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynValue

  • All Superinterfaces:
    DynAny, DynAnyOperations, DynValueCommon, DynValueCommonOperations, DynValueOperations, IDLEntity, Object, Serializable
    All Known Implementing Classes:
    _DynValueStub

    public interface DynValue
extends DynValueOperations, DynValueCommon, IDLEntity
    DynValue objects support the manipulation of IDL non-boxed value types. The DynValue interface can represent both null and non-null value types. For a DynValue representing a non-null value type, the DynValue's components comprise the public and private members of the value type, including those inherited from concrete base value types, in the order of definition. A DynValue representing a null value type has no components and a current position of -1.

    Warning: Indiscriminantly changing the contents of private value type members can cause the value type implementation to break by violating internal constraints. Access to private members is provided to support such activities as ORB bridging and debugging and should not be used to arbitrarily violate the encapsulation of the value type.

    • Method Summary

      • Methods inherited from interface org.omg.DynamicAny.DynValueOperations

        current_member_kind, current_member_name, get_members_as_dyn_any, get_members, set_members_as_dyn_any, set_members

      • Methods inherited from interface org.omg.DynamicAny.DynValueCommonOperations

        is_null, set_to_null, set_to_value

      • Methods inherited from interface org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DynValueBox (Java Platform SE 8 )

Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynValueBox

  • All Superinterfaces:
    DynAny, DynAnyOperations, DynValueBoxOperations, DynValueCommon, DynValueCommonOperations, IDLEntity, Object, Serializable

    public interface DynValueBox
extends DynValueBoxOperations, DynValueCommon, IDLEntity
    DynValueBox objects support the manipulation of IDL boxed value types. The DynValueBox interface can represent both null and non-null value types. For a DynValueBox representing a non-null value type, the DynValueBox has a single component of the boxed type. A DynValueBox representing a null value type has no components and a current position of -1.

    • Method Summary

      • Methods inherited from interface org.omg.DynamicAny.DynValueBoxOperations

        get_boxed_value_as_dyn_any, get_boxed_value, set_boxed_value_as_dyn_any, set_boxed_value

      • Methods inherited from interface org.omg.DynamicAny.DynValueCommonOperations

        is_null, set_to_null, set_to_value

      • Methods inherited from interface org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DynValueBoxOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynValueBoxOperations

  • All Superinterfaces:
    DynAnyOperations, DynValueCommonOperations
    All Known Subinterfaces:
    DynValueBox

    public interface DynValueBoxOperations
extends DynValueCommonOperations
    DynValueBox objects support the manipulation of IDL boxed value types. The DynValueBox interface can represent both null and non-null value types. For a DynValueBox representing a non-null value type, the DynValueBox has a single component of the boxed type. A DynValueBox representing a null value type has no components and a current position of -1.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      DynAny get_boxed_value_as_dyn_any()
      Returns the boxed value as a DynAny.
      Any get_boxed_value()
      Returns the boxed value as an Any.
      void set_boxed_value_as_dyn_any(DynAny boxed)
      Replaces the boxed value with the value contained in the parameter.
      void set_boxed_value(Any boxed)
      Replaces the boxed value with the specified value.

      • Methods inherited from interface org.omg.DynamicAny.DynValueCommonOperations

        is_null, set_to_null, set_to_value

      • Methods inherited from interface org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

    • Method Detail

      • get_boxed_value

        Any get_boxed_value()
             throws InvalidValue
        Returns the boxed value as an Any.
        Throws:
        InvalidValue - if this object represents a null value box type

      • set_boxed_value

        void set_boxed_value(Any boxed)
              throws TypeMismatch
        Replaces the boxed value with the specified value. If the DynBoxedValue represents a null valuetype, it is converted to a non-null value.
        Throws:
        TypeMismatch - if this object represents a non-null value box type and the type of the parameter is not matching the current boxed value type.

      • get_boxed_value_as_dyn_any

        DynAny get_boxed_value_as_dyn_any()
                           throws InvalidValue
        Returns the boxed value as a DynAny.
        Throws:
        InvalidValue - if this object represents a null value box type

      • set_boxed_value_as_dyn_any

        void set_boxed_value_as_dyn_any(DynAny boxed)
                         throws TypeMismatch
        Replaces the boxed value with the value contained in the parameter. If the DynBoxedValue represents a null valuetype, it is converted to a non-null value.
        Throws:
        TypeMismatch - if this object represents a non-null value box type and the type of the parameter is not matching the current boxed value type.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DynValueCommon (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynValueCommon

  • All Superinterfaces:
    DynAny, DynAnyOperations, DynValueCommonOperations, IDLEntity, Object, Serializable
    All Known Subinterfaces:
    DynValue, DynValueBox
    All Known Implementing Classes:
    _DynValueStub

    public interface DynValueCommon
extends DynValueCommonOperations, DynAny, IDLEntity
    DynValueCommon provides operations supported by both the DynValue and DynValueBox interfaces.

    • Method Summary

      • Methods inherited from interface org.omg.DynamicAny.DynValueCommonOperations

        is_null, set_to_null, set_to_value

      • Methods inherited from interface org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DynValueCommonOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynValueCommonOperations

  • All Superinterfaces:
    DynAnyOperations
    All Known Subinterfaces:
    DynValue, DynValueBox, DynValueBoxOperations, DynValueCommon, DynValueOperations
    All Known Implementing Classes:
    _DynValueStub

    public interface DynValueCommonOperations
extends DynAnyOperations
    DynValueCommon provides operations supported by both the DynValue and DynValueBox interfaces.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      boolean is_null()
      Returns true if the DynValueCommon represents a null value type.
      void set_to_null()
      Changes the representation of a DynValueCommon to a null value type.
      void set_to_value()
      Replaces a null value type with a newly constructed value.

      • Methods inherited from interface org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

    • Method Detail

      • is_null

        boolean is_null()
        Returns true if the DynValueCommon represents a null value type.

      • set_to_null

        void set_to_null()
        Changes the representation of a DynValueCommon to a null value type.

      • set_to_value

        void set_to_value()
        Replaces a null value type with a newly constructed value. Its components are initialized to default values as in DynAnyFactory.create_dyn_any_from_type_code. If the DynValueCommon represents a non-null value type, then this operation has no effect.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DynValueHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class DynValueHelper

  • java.lang.Object
    • org.omg.DynamicAny.DynValueHelper

  • public abstract class DynValueHelper
extends Object
    DynValue objects support the manipulation of IDL non-boxed value types. The DynValue interface can represent both null and non-null value types. For a DynValue representing a non-null value type, the DynValue's components comprise the public and private members of the value type, including those inherited from concrete base value types, in the order of definition. A DynValue representing a null value type has no components and a current position of -1.

    Warning: Indiscriminantly changing the contents of private value type members can cause the value type implementation to break by violating internal constraints. Access to private members is provided to support such activities as ORB bridging and debugging and should not be used to arbitrarily violate the encapsulation of the value type.

    • Constructor Summary

      Constructors
      Constructor and Description
      DynValueHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static DynValue | extract(Any a)
      static String | id()
      static void | insert(Any a, DynValue that)
      static DynValue | narrow(Object obj)
      static DynValue | read(InputStream istream)
      static TypeCode | type()
      static DynValue | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, DynValue value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • DynValueHelper

        public DynValueHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          DynValue that)

      • extract

        public static DynValue extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static DynValue read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         DynValue value)

      • narrow

        public static DynValue narrow(Object obj)

      • unchecked_narrow

        public static DynValue unchecked_narrow(Object obj)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DynValueOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Interface DynValueOperations

  • All Superinterfaces:
    DynAnyOperations, DynValueCommonOperations
    All Known Subinterfaces:
    DynValue
    All Known Implementing Classes:
    _DynValueStub

    public interface DynValueOperations
extends DynValueCommonOperations
    DynValue objects support the manipulation of IDL non-boxed value types. The DynValue interface can represent both null and non-null value types. For a DynValue representing a non-null value type, the DynValue's components comprise the public and private members of the value type, including those inherited from concrete base value types, in the order of definition. A DynValue representing a null value type has no components and a current position of -1.

    Warning: Indiscriminantly changing the contents of private value type members can cause the value type implementation to break by violating internal constraints. Access to private members is provided to support such activities as ORB bridging and debugging and should not be used to arbitrarily violate the encapsulation of the value type.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      TCKind current_member_kind()
      Returns the TCKind associated with the member at the current position.
      String current_member_name()
      Returns the name of the member at the current position.
      NameDynAnyPair[] get_members_as_dyn_any()
      Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the value type.
      NameValuePair[] get_members()
      Returns a sequence of NameValuePairs describing the name and the value of each member in the value type.
      void set_members_as_dyn_any(NameDynAnyPair[] value)
      Initializes the value type's members from a sequence of NameDynAnyPairs.
      void set_members(NameValuePair[] value)
      Initializes the value type's members from a sequence of NameValuePairs.

      • Methods inherited from interface org.omg.DynamicAny.DynValueCommonOperations

        is_null, set_to_null, set_to_value

      • Methods inherited from interface org.omg.DynamicAny.DynAnyOperations

        assign, component_count, copy, current_component, destroy, equal, from_any, get_any, get_boolean, get_char, get_double, get_dyn_any, get_float, get_long, get_longlong, get_octet, get_reference, get_short, get_string, get_typecode, get_ulong, get_ulonglong, get_ushort, get_val, get_wchar, get_wstring, insert_any, insert_boolean, insert_char, insert_double, insert_dyn_any, insert_float, insert_long, insert_longlong, insert_octet, insert_reference, insert_short, insert_string, insert_typecode, insert_ulong, insert_ulonglong, insert_ushort, insert_val, insert_wchar, insert_wstring, next, rewind, seek, to_any, type

    • Method Detail

      • current_member_name

        String current_member_name()
                    throws TypeMismatch,
                           InvalidValue
        Returns the name of the member at the current position. This operation may return an empty string since the TypeCode of the value being manipulated may not contain the names of members.
        Throws:
        TypeMismatch - if the DynValue represents a null value type.
        InvalidValue - if the current position does not indicate a member

      • current_member_kind

        TCKind current_member_kind()
                    throws TypeMismatch,
                           InvalidValue
        Returns the TCKind associated with the member at the current position.
        Throws:
        TypeMismatch - if the DynValue represents a null value type.
        InvalidValue - if the current position does not indicate a member

      • get_members

        NameValuePair[] get_members()
                     throws InvalidValue
        Returns a sequence of NameValuePairs describing the name and the value of each member in the value type. The sequence contains members in the same order as the declaration order of members as indicated by the DynValue's TypeCode. The current position is not affected. The member names in the returned sequence will be empty strings if the DynValue's TypeCode does not contain member names.
        Throws:
        InvalidValue - if this object represents a null value type

      • set_members

        void set_members(NameValuePair[] value)
          throws TypeMismatch,
                 InvalidValue
        Initializes the value type's members from a sequence of NameValuePairs. The operation sets the current position to zero if the passed sequences has non-zero length. Otherwise, if an empty sequence is passed, the current position is set to -1. A null value type can be initialized to a non-null value type using this method.

        Members must appear in the NameValuePairs in the order in which they appear in the IDL specification of the value type as indicated by the DynValue's TypeCode or they must be empty strings. The operation makes no attempt to assign member values based on member names.

        Throws:
        TypeMismatch - if the member names supplied in the passed sequence do not match the corresponding member name in the DynValue's TypeCode and they are not empty strings
        InvalidValue - if the passed sequence has a number of elements that disagrees with the number of members as indicated by the DynValue's TypeCode

      • get_members_as_dyn_any

        NameDynAnyPair[] get_members_as_dyn_any()
                                 throws InvalidValue
        Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the value type. The sequence contains members in the same order as the declaration order of members as indicated by the DynValue's TypeCode. The current position is not affected. The member names in the returned sequence will be empty strings if the DynValue's TypeCode does not contain member names.
        Throws:
        InvalidValue - if this object represents a null value type

      • set_members_as_dyn_any

        void set_members_as_dyn_any(NameDynAnyPair[] value)
                     throws TypeMismatch,
                            InvalidValue
        Initializes the value type's members from a sequence of NameDynAnyPairs. The operation sets the current position to zero if the passed sequences has non-zero length. Otherwise, if an empty sequence is passed, the current position is set to -1. A null value type can be initialized to a non-null value type using this method.

        Members must appear in the NameDynAnyPairs in the order in which they appear in the IDL specification of the value type as indicated by the DynValue's TypeCode or they must be empty strings. The operation makes no attempt to assign member values based on member names.

        Throws:
        TypeMismatch - if the member names supplied in the passed sequence do not match the corresponding member name in the DynValue's TypeCode and they are not empty strings
        InvalidValue - if the passed sequence has a number of elements that disagrees with the number of members as indicated by the DynValue's TypeCode
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FieldNameHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class FieldNameHelper

  • java.lang.Object
    • org.omg.DynamicAny.FieldNameHelper

  • public abstract class FieldNameHelper
extends Object
    org/omg/DynamicAny/FieldNameHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/DynamicAny/DynamicAny.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      FieldNameHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static String | extract(Any a)
      static String | id()
      static void | insert(Any a, String that)
      static String | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, String value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • FieldNameHelper

        public FieldNameHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          String that)

      • extract

        public static String extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         String value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NameDynAnyPair (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class NameDynAnyPair

  • java.lang.Object
    • org.omg.DynamicAny.NameDynAnyPair
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class NameDynAnyPair
extends Object
implements IDLEntity
    org/omg/DynamicAny/NameDynAnyPair.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/DynamicAny/DynamicAny.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      String id
      The name associated with the DynAny.
      DynAny value
      The DynAny value associated with the name.

    • Constructor Summary

      Constructors
      Constructor and Description
      NameDynAnyPair()
      NameDynAnyPair(String _id, DynAny _value)

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • id

        public String id
        The name associated with the DynAny.

      • value

        public DynAny value
        The DynAny value associated with the name.

    • Constructor Detail

      • NameDynAnyPair

        public NameDynAnyPair()

      • NameDynAnyPair

        public NameDynAnyPair(String _id,
                      DynAny _value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NameDynAnyPairHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class NameDynAnyPairHelper

  • java.lang.Object
    • org.omg.DynamicAny.NameDynAnyPairHelper

  • public abstract class NameDynAnyPairHelper
extends Object
    org/omg/DynamicAny/NameDynAnyPairHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/DynamicAny/DynamicAny.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      NameDynAnyPairHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static NameDynAnyPair | extract(Any a)
      static String | id()
      static void | insert(Any a, NameDynAnyPair that)
      static NameDynAnyPair | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, NameDynAnyPair value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • NameDynAnyPairHelper

        public NameDynAnyPairHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          NameDynAnyPair that)

      • extract

        public static NameDynAnyPair extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static NameDynAnyPair read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         NameDynAnyPair value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NameDynAnyPairSeqHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class NameDynAnyPairSeqHelper

  • java.lang.Object
    • org.omg.DynamicAny.NameDynAnyPairSeqHelper

  • public abstract class NameDynAnyPairSeqHelper
extends Object
    org/omg/DynamicAny/NameDynAnyPairSeqHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/DynamicAny/DynamicAny.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      NameDynAnyPairSeqHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static NameDynAnyPair[] | extract(Any a)
      static String | id()
      static void | insert(Any a, NameDynAnyPair[] that)
      static NameDynAnyPair[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, NameDynAnyPair[] value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • NameDynAnyPairSeqHelper

        public NameDynAnyPairSeqHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          NameDynAnyPair[] that)

      • extract

        public static NameDynAnyPair[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static NameDynAnyPair[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         NameDynAnyPair[] value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NameValuePair (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class NameValuePair

  • java.lang.Object
    • org.omg.DynamicAny.NameValuePair
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class NameValuePair
extends Object
implements IDLEntity
    org/omg/DynamicAny/NameValuePair.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/DynamicAny/DynamicAny.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      String id
      The name associated with the Any.
      Any value
      The Any value associated with the name.

    • Constructor Summary

      Constructors
      Constructor and Description
      NameValuePair()
      NameValuePair(String _id, Any _value)

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • id

        public String id
        The name associated with the Any.

      • value

        public Any value
        The Any value associated with the name.

    • Constructor Detail

      • NameValuePair

        public NameValuePair()

      • NameValuePair

        public NameValuePair(String _id,
                     Any _value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NameValuePairHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class NameValuePairHelper

  • java.lang.Object
    • org.omg.DynamicAny.NameValuePairHelper

  • public abstract class NameValuePairHelper
extends Object
    org/omg/DynamicAny/NameValuePairHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/DynamicAny/DynamicAny.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      NameValuePairHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static NameValuePair | extract(Any a)
      static String | id()
      static void | insert(Any a, NameValuePair that)
      static NameValuePair | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, NameValuePair value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • NameValuePairHelper

        public NameValuePairHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          NameValuePair that)

      • extract

        public static NameValuePair extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static NameValuePair read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         NameValuePair value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NameValuePairSeqHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class NameValuePairSeqHelper

  • java.lang.Object
    • org.omg.DynamicAny.NameValuePairSeqHelper

  • public abstract class NameValuePairSeqHelper
extends Object
    org/omg/DynamicAny/NameValuePairSeqHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/DynamicAny/DynamicAny.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      NameValuePairSeqHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static NameValuePair[] | extract(Any a)
      static String | id()
      static void | insert(Any a, NameValuePair[] that)
      static NameValuePair[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, NameValuePair[] value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • NameValuePairSeqHelper

        public NameValuePairSeqHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          NameValuePair[] that)

      • extract

        public static NameValuePair[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static NameValuePair[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         NameValuePair[] value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


org.omg.DynamicAny (Java Platform SE 8 )

org.omg.DynamicAny

Interfaces

  • DynAny
  • DynAnyFactory
  • DynAnyFactoryOperations
  • DynAnyOperations
  • DynArray
  • DynArrayOperations
  • DynEnum
  • DynEnumOperations
  • DynFixed
  • DynFixedOperations
  • DynSequence
  • DynSequenceOperations
  • DynStruct
  • DynStructOperations
  • DynUnion
  • DynUnionOperations
  • DynValue
  • DynValueBox
  • DynValueBoxOperations
  • DynValueCommon
  • DynValueCommonOperations
  • DynValueOperations

Classes

  • _DynAnyFactoryStub
  • _DynAnyStub
  • _DynArrayStub
  • _DynEnumStub
  • _DynFixedStub
  • _DynSequenceStub
  • _DynStructStub
  • _DynUnionStub
  • _DynValueStub
  • AnySeqHelper
  • DynAnyFactoryHelper
  • DynAnyHelper
  • DynAnySeqHelper
  • DynArrayHelper
  • DynEnumHelper
  • DynFixedHelper
  • DynSequenceHelper
  • DynStructHelper
  • DynUnionHelper
  • DynValueHelper
  • FieldNameHelper
  • NameDynAnyPair
  • NameDynAnyPairHelper
  • NameDynAnyPairSeqHelper
  • NameValuePair
  • NameValuePairHelper
  • NameValuePairSeqHelper


org.omg.DynamicAny (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.DynamicAny

Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

See: Description

  • Interface Summary
    Interface Description
    DynAny
    Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
    DynAnyFactory
    DynAny objects can be created by invoking operations on the DynAnyFactory object.
    DynAnyFactoryOperations
    DynAny objects can be created by invoking operations on the DynAnyFactory object.
    DynAnyOperations
    Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
    DynArray
    DynArray objects support the manipulation of IDL arrays.
    DynArrayOperations
    DynArray objects support the manipulation of IDL arrays.
    DynEnum
    DynEnum objects support the manipulation of IDL enumerated values.
    DynEnumOperations
    DynEnum objects support the manipulation of IDL enumerated values.
    DynFixed
    DynFixed objects support the manipulation of IDL fixed values.
    DynFixedOperations
    DynFixed objects support the manipulation of IDL fixed values.
    DynSequence
    DynSequence objects support the manipulation of IDL sequences.
    DynSequenceOperations
    DynSequence objects support the manipulation of IDL sequences.
    DynStruct
    DynStruct objects support the manipulation of IDL struct and exception values.
    DynStructOperations
    DynStruct objects support the manipulation of IDL struct and exception values.
    DynUnion
    DynUnion objects support the manipulation of IDL unions.
    DynUnionOperations
    DynUnion objects support the manipulation of IDL unions.
    DynValue
    DynValue objects support the manipulation of IDL non-boxed value types.
    DynValueBox
    DynValueBox objects support the manipulation of IDL boxed value types.
    DynValueBoxOperations
    DynValueBox objects support the manipulation of IDL boxed value types.
    DynValueCommon
    DynValueCommon provides operations supported by both the DynValue and DynValueBox interfaces.
    DynValueCommonOperations
    DynValueCommon provides operations supported by both the DynValue and DynValueBox interfaces.
    DynValueOperations
    DynValue objects support the manipulation of IDL non-boxed value types.
  • Class Summary
    Class Description
    _DynAnyFactoryStub
    DynAny objects can be created by invoking operations on the DynAnyFactory object.
    _DynAnyStub
    Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
    _DynArrayStub
    DynArray objects support the manipulation of IDL arrays.
    _DynEnumStub
    DynEnum objects support the manipulation of IDL enumerated values.
    _DynFixedStub
    DynFixed objects support the manipulation of IDL fixed values.
    _DynSequenceStub
    DynSequence objects support the manipulation of IDL sequences.
    _DynStructStub
    DynStruct objects support the manipulation of IDL struct and exception values.
    _DynUnionStub
    DynUnion objects support the manipulation of IDL unions.
    _DynValueStub
    DynValue objects support the manipulation of IDL non-boxed value types.
    AnySeqHelper
    org/omg/DynamicAny/AnySeqHelper.java .
    DynAnyFactoryHelper
    DynAny objects can be created by invoking operations on the DynAnyFactory object.
    DynAnyHelper
    Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
    DynAnySeqHelper
    org/omg/DynamicAny/DynAnySeqHelper.java .
    DynArrayHelper
    DynArray objects support the manipulation of IDL arrays.
    DynEnumHelper
    DynEnum objects support the manipulation of IDL enumerated values.
    DynFixedHelper
    DynFixed objects support the manipulation of IDL fixed values.
    DynSequenceHelper
    DynSequence objects support the manipulation of IDL sequences.
    DynStructHelper
    DynStruct objects support the manipulation of IDL struct and exception values.
    DynUnionHelper
    DynUnion objects support the manipulation of IDL unions.
    DynValueHelper
    DynValue objects support the manipulation of IDL non-boxed value types.
    FieldNameHelper
    org/omg/DynamicAny/FieldNameHelper.java .
    NameDynAnyPair
    org/omg/DynamicAny/NameDynAnyPair.java .
    NameDynAnyPairHelper
    org/omg/DynamicAny/NameDynAnyPairHelper.java .
    NameDynAnyPairSeqHelper
    org/omg/DynamicAny/NameDynAnyPairSeqHelper.java .
    NameValuePair
    org/omg/DynamicAny/NameValuePair.java .
    NameValuePairHelper
    org/omg/DynamicAny/NameValuePairHelper.java .
    NameValuePairSeqHelper
    org/omg/DynamicAny/NameValuePairSeqHelper.java .

Package org.omg.DynamicAny Description

Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.

An any can be passed to a program that doesn't have any static information for the type of the any (code generated for the type by an IDL compiler has not been compiled with the object implementation). As a result, the object receiving the any does not have a portable method of using it.

DynAnys enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value. This is especially helpful for writing powerful generic servers (bridges, event channels supporting filtering). Similarly, this facility enables the construction of an any at runtime, without having static knowledge of its type. This is especially helpful for writing generic clients (bridges, browsers, debuggers, user interface tools).

Any values can be dynamically interpreted (traversed) and constructed through DynAny objects. A DynAny object is associated with a data value which corresponds to a copy of the value inserted into an Any. A DynAny object may be viewed as an ordered collection of component DynAnys. For DynAnys representing a basic type, such as long, or a type without components, such as an empty exception, the ordered collection of components is empty.

Each DynAny object maintains the notion of a current position into its collection of component DynAnys. The current position is identified by an index value that runs from 0 to n-1, where n is the number of components. The special index value -1 indicates a current position that points nowhere. For values that cannot have a current position (such as an empty exception), the index value is fixed at -1. If a DynAny is initialized with a value that has components, the index is initialized to 0. After creation of an uninitialized DynAny (that is, a DynAny that has no value but a TypeCode that permits components), the current position depends on the type of value represented by the DynAny. (The current position is set to 0 or -1, depending on whether the new DynAny gets default values for its components.)

The iteration operations rewind, seek, and next can be used to change the current position and the current_component operation returns the component at the current position. The component_count operation returns the number of components of a DynAny. Collectively, these operations enable iteration over the components of a DynAny, for example, to (recursively) examine its contents.

A constructed DynAny object is a DynAny object associated with a constructed type. There is a different interface, inheriting from the DynAny interface, associated with each kind of constructed type in IDL (fixed, enum, struct, sequence, union, array, exception, and value type). A constructed DynAny object exports operations that enable the creation of new DynAny objects, each of them associated with a component of the constructed data value. As an example, a DynStruct is associated with a struct value. This means that the DynStruct may be seen as owning an ordered collection of components, one for each structure member. The DynStruct object exports operations that enable the creation of new DynAny objects, each of them associated with a member of the struct.

If a DynAny object has been obtained from another (constructed) DynAny object, such as a DynAny representing a structure member that was created from a DynStruct, the member DynAny is logically contained in the DynStruct. Calling an insert or get operation leaves the current position unchanged. Destroying a top-level DynAny object (one that was not obtained as a component of another DynAny) also destroys any component DynAny objects obtained from it. Destroying a non-top level DynAny object does nothing. Invoking operations on a destroyed top-level DynAny or any of its descendants raises OBJECT_NOT_EXIST. If the programmer wants to destroy a DynAny object but still wants to manipulate some component of the data value associated with it, then he or she should first create a DynAny for the component and, after that, make a copy of the created DynAny object.

The behavior of DynAny objects has been defined in order to enable efficient implementations in terms of allocated memory space and speed of access. DynAny objects are intended to be used for traversing values extracted from anys or constructing values of anys at runtime. Their use for other purposes is not recommended.

Handling DynAny objects

Insert and get operations are necessary to handle basic DynAny objects but are also helpful to handle constructed DynAny objects. Inserting a basic data type value into a constructed DynAny object implies initializing the current component of the constructed data value associated with the DynAny object. For example, invoking insert_boolean on a DynStruct implies inserting a boolean data value at the current position of the associated struct data value. A type is consistent for inserting or extracting a value if its TypeCode is equivalent to the TypeCode contained in the DynAny or, if the DynAny has components, is equivalent to the TypeCode of the DynAny at the current position.

Basic operations include:

  • insert_boolean, get_boolean
  • insert_char, get_char
  • insert_short, get_short
  • insert_ushort, get_ushort
  • insert_long, get_long
  • insert_ulong, get_ulong
  • insert_double, get_double
  • insert_string, get_string
  • insert_reference, get_reference
  • insert_typecode, get_typecode
  • insert_longlong, get_longlong
  • insert_ulonglong, get_ulonglong
  • insert_longdouble, get_longdouble
  • insert_wchar, get_wchar
  • insert_wstring, get_wstring
  • insert_any, get_any
  • insert_dyn_any, get_dyn_any
  • insert_val, get_val
  • insert_octet, get_octet
  • insert_float, get_float
  • get_value
  • get_as_string
  • get_as_ulong
  • get_members
  • get_members_as_dyn_any
  • get_discriminator
  • get_length
  • get_elements
  • get_elements_as_dyn_any
  • get_boxed_value
  • get_boxed_value_as_dyn_any

DynAny and DynAnyFactory objects are intended to be local to the process in which they are created and used. This means that references to DynAny and DynAnyFactory objects cannot be exported to other processes, or externalized with ORB.object_to_string(). If any attempt is made to do so, the offending operation will raise a MARSHAL system exception. Since their interfaces are specified in IDL, DynAny objects export operations defined in the standard org.omg.CORBA.Object interface. However, any attempt to invoke operations exported through the Object interface may raise the standard NO_IMPLEMENT exception. An attempt to use a DynAny object with the DII may raise the NO_IMPLEMENT exception.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

Since:
1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes


org.omg.DynamicAny Class Hierarchy (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.DynamicAny

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.DynamicAny.AnySeqHelper
    • org.omg.DynamicAny.DynAnyFactoryHelper
    • org.omg.DynamicAny.DynAnyHelper
    • org.omg.DynamicAny.DynAnySeqHelper
    • org.omg.DynamicAny.DynArrayHelper
    • org.omg.DynamicAny.DynEnumHelper
    • org.omg.DynamicAny.DynFixedHelper
    • org.omg.DynamicAny.DynSequenceHelper
    • org.omg.DynamicAny.DynStructHelper
    • org.omg.DynamicAny.DynUnionHelper
    • org.omg.DynamicAny.DynValueHelper
    • org.omg.DynamicAny.FieldNameHelper
    • org.omg.DynamicAny.NameDynAnyPair (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.NameDynAnyPairHelper
    • org.omg.DynamicAny.NameDynAnyPairSeqHelper
    • org.omg.DynamicAny.NameValuePair (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.NameValuePairHelper
    • org.omg.DynamicAny.NameValuePairSeqHelper
    • org.omg.CORBA.portable.ObjectImpl (implements org.omg.CORBA.Object)
      • org.omg.DynamicAny._DynAnyFactoryStub (implements org.omg.DynamicAny.DynAnyFactory)
      • org.omg.DynamicAny._DynAnyStub (implements org.omg.DynamicAny.DynAny)
      • org.omg.DynamicAny._DynArrayStub (implements org.omg.DynamicAny.DynArray)
      • org.omg.DynamicAny._DynEnumStub (implements org.omg.DynamicAny.DynEnum)
      • org.omg.DynamicAny._DynFixedStub (implements org.omg.DynamicAny.DynFixed)
      • org.omg.DynamicAny._DynSequenceStub (implements org.omg.DynamicAny.DynSequence)
      • org.omg.DynamicAny._DynStructStub (implements org.omg.DynamicAny.DynStruct)
      • org.omg.DynamicAny._DynUnionStub (implements org.omg.DynamicAny.DynUnion)
      • org.omg.DynamicAny._DynValueStub (implements org.omg.DynamicAny.DynValue)

Interface Hierarchy

  • org.omg.DynamicAny.DynAnyFactoryOperations
    • org.omg.DynamicAny.DynAnyFactory (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.DynamicAny.DynAnyOperations
    • org.omg.DynamicAny.DynAny (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.DynamicAny.DynArray (also extends org.omg.DynamicAny.DynArrayOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynEnum (also extends org.omg.DynamicAny.DynEnumOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynFixed (also extends org.omg.DynamicAny.DynFixedOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynSequence (also extends org.omg.DynamicAny.DynSequenceOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynStruct (also extends org.omg.DynamicAny.DynStructOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynUnion (also extends org.omg.DynamicAny.DynUnionOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueCommon (also extends org.omg.DynamicAny.DynValueCommonOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynArrayOperations
      • org.omg.DynamicAny.DynArray (also extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynEnumOperations
      • org.omg.DynamicAny.DynEnum (also extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynFixedOperations
      • org.omg.DynamicAny.DynFixed (also extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynSequenceOperations
      • org.omg.DynamicAny.DynSequence (also extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynStructOperations
      • org.omg.DynamicAny.DynStruct (also extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynUnionOperations
      • org.omg.DynamicAny.DynUnion (also extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynValueCommonOperations
      • org.omg.DynamicAny.DynValueBoxOperations
        • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueCommon (also extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueOperations
        • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
  • org.omg.CORBA.Object
    • org.omg.DynamicAny.DynAny (also extends org.omg.DynamicAny.DynAnyOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynArray (also extends org.omg.DynamicAny.DynArrayOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynEnum (also extends org.omg.DynamicAny.DynEnumOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynFixed (also extends org.omg.DynamicAny.DynFixedOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynSequence (also extends org.omg.DynamicAny.DynSequenceOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynStruct (also extends org.omg.DynamicAny.DynStructOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynUnion (also extends org.omg.DynamicAny.DynUnionOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueCommon (also extends org.omg.DynamicAny.DynValueCommonOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynAnyFactory (also extends org.omg.DynamicAny.DynAnyFactoryOperations, org.omg.CORBA.portable.IDLEntity)
  • java.io.Serializable
    • org.omg.CORBA.portable.IDLEntity
      • org.omg.DynamicAny.DynAny (also extends org.omg.DynamicAny.DynAnyOperations, org.omg.CORBA.Object)
        • org.omg.DynamicAny.DynArray (also extends org.omg.DynamicAny.DynArrayOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynEnum (also extends org.omg.DynamicAny.DynEnumOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynFixed (also extends org.omg.DynamicAny.DynFixedOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynSequence (also extends org.omg.DynamicAny.DynSequenceOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynStruct (also extends org.omg.DynamicAny.DynStructOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynUnion (also extends org.omg.DynamicAny.DynUnionOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueCommon (also extends org.omg.DynamicAny.DynValueCommonOperations, org.omg.CORBA.portable.IDLEntity)
          • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
          • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynAnyFactory (also extends org.omg.DynamicAny.DynAnyFactoryOperations, org.omg.CORBA.Object)
      • org.omg.DynamicAny.DynArray (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynArrayOperations)
      • org.omg.DynamicAny.DynEnum (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynEnumOperations)
      • org.omg.DynamicAny.DynFixed (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynFixedOperations)
      • org.omg.DynamicAny.DynSequence (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynSequenceOperations)
      • org.omg.DynamicAny.DynStruct (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynStructOperations)
      • org.omg.DynamicAny.DynUnion (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynUnionOperations)
      • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueCommon, org.omg.DynamicAny.DynValueOperations)
      • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.DynamicAny.DynValueCommon)
      • org.omg.DynamicAny.DynValueCommon (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynValueCommonOperations)
        • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package org.omg.DynamicAny (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.DynamicAny

  • Packages that use org.omg.DynamicAny
    Package Description
    org.omg.DynamicAny
    Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.
  • Classes in org.omg.DynamicAny used by org.omg.DynamicAny
    Class and Description
    DynAny
    Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
    DynAnyFactory
    DynAny objects can be created by invoking operations on the DynAnyFactory object.
    DynAnyFactoryOperations
    DynAny objects can be created by invoking operations on the DynAnyFactory object.
    DynAnyOperations
    Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
    DynArray
    DynArray objects support the manipulation of IDL arrays.
    DynArrayOperations
    DynArray objects support the manipulation of IDL arrays.
    DynEnum
    DynEnum objects support the manipulation of IDL enumerated values.
    DynEnumOperations
    DynEnum objects support the manipulation of IDL enumerated values.
    DynFixed
    DynFixed objects support the manipulation of IDL fixed values.
    DynFixedOperations
    DynFixed objects support the manipulation of IDL fixed values.
    DynSequence
    DynSequence objects support the manipulation of IDL sequences.
    DynSequenceOperations
    DynSequence objects support the manipulation of IDL sequences.
    DynStruct
    DynStruct objects support the manipulation of IDL struct and exception values.
    DynStructOperations
    DynStruct objects support the manipulation of IDL struct and exception values.
    DynUnion
    DynUnion objects support the manipulation of IDL unions.
    DynUnionOperations
    DynUnion objects support the manipulation of IDL unions.
    DynValue
    DynValue objects support the manipulation of IDL non-boxed value types.
    DynValueBoxOperations
    DynValueBox objects support the manipulation of IDL boxed value types.
    DynValueCommon
    DynValueCommon provides operations supported by both the DynValue and DynValueBox interfaces.
    DynValueCommonOperations
    DynValueCommon provides operations supported by both the DynValue and DynValueBox interfaces.
    DynValueOperations
    DynValue objects support the manipulation of IDL non-boxed value types.
    NameDynAnyPair
    org/omg/DynamicAny/NameDynAnyPair.java .
    NameValuePair
    org/omg/DynamicAny/NameValuePair.java .
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


_DynAnyFactoryStub (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class _DynAnyFactoryStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.DynamicAny._DynAnyFactoryStub
  • All Implemented Interfaces:
    Serializable, Object, IDLEntity, DynAnyFactory, DynAnyFactoryOperations

    public class _DynAnyFactoryStub
extends ObjectImpl
implements DynAnyFactory
    DynAny objects can be created by invoking operations on the DynAnyFactory object. Generally there are only two ways to create a DynAny object:
    • invoking an operation on an existing DynAny object
    • invoking an operation on a DynAnyFactory object
    A constructed DynAny object supports operations that enable the creation of new DynAny objects encapsulating access to the value of some constituent. DynAny objects also support the copy operation for creating new DynAny objects. A reference to the DynAnyFactory object is obtained by calling ORB.resolve_initial_references() with the identifier parameter set to the string constant "DynAnyFactory".

    Dynamic interpretation of an any usually involves creating a DynAny object using create_dyn_any() as the first step. Depending on the type of the any, the resulting DynAny object reference can be narrowed to a DynFixed, DynStruct, DynSequence, DynArray, DynUnion, DynEnum, or DynValue object reference.

    Dynamic creation of an any involves creating a DynAny object using create_dyn_any_from_type_code(), passing the TypeCode associated with the value to be created. The returned reference is narrowed to one of the complex types, such as DynStruct, if appropriate. Then, the value can be initialized by means of invoking operations on the resulting object. Finally, the to_any operation can be invoked to create an any value from the constructed DynAny.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static Class | _opsClass

    • Constructor Summary

      Constructors
      Constructor and Description
      _DynAnyFactoryStub()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      DynAny create_dyn_any_from_type_code(TypeCode type)
      Creates a DynAny from a TypeCode.
      DynAny create_dyn_any(Any value)
      Creates a new DynAny object from an any value.

      • Methods inherited from class org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • Field Detail

      • _opsClass

        public static final Class _opsClass

    • Constructor Detail

      • _DynAnyFactoryStub

        public _DynAnyFactoryStub()

    • Method Detail

      • create_dyn_any

        public DynAny create_dyn_any(Any value)
                      throws InconsistentTypeCode
        Creates a new DynAny object from an any value. A copy of the TypeCode associated with the any value is assigned to the resulting DynAny object. The value associated with the DynAny object is a copy of the value in the original any. The current position of the created DynAny is set to zero if the passed value has components, to -1 otherwise
        Specified by:
        create_dyn_any in interface DynAnyFactoryOperations
        Throws:
        InconsistentTypeCode - if value has a TypeCode with a TCKind of tk_Principal, tk_native, or tk_abstract_interface

      • create_dyn_any_from_type_code

        public DynAny create_dyn_any_from_type_code(TypeCode type)
                                     throws InconsistentTypeCode
        Creates a DynAny from a TypeCode. Depending on the TypeCode, the created object may be of type DynAny, or one of its derived types, such as DynStruct. The returned reference can be narrowed to the derived type. In all cases, a DynAny constructed from a TypeCode has an initial default value. The default values of basic types are:
        • false for boolean
        • zero for numeric types
        • zero for types octet, char, and wchar
        • the empty string for string and wstring
        • null for object references
        • a type code with a TCKind value of tk_null for type codes
        • for any values, an any containing a type code with a TCKind value of tk_null type and no value
        For complex types, creation of the corresponding DynAny assigns a default value as follows:
        • For DynSequence it sets the current position to -1 and creates an empty sequence.
        • For DynEnum it sets the current position to -1 and sets the value of the enumerator to the first enumerator value indicated by the TypeCode.
        • For DynFixed it sets the current position to -1 and sets the value zero.
        • For DynStruct it sets the current position to -1 for empty exceptions and to zero for all other TypeCodes. The members (if any) are (recursively) initialized to their default values.
        • For DynArray sets the current position to zero and (recursively) initializes elements to their default value.
        • For DynUnion sets the current position to zero. The discriminator value is set to a value consistent with the first named member of the union. That member is activated and (recursively) initialized to its default value.
        • For DynValue and DynValueBox it initializes to a null value.
        Specified by:
        create_dyn_any_from_type_code in interface DynAnyFactoryOperations
        Throws:
        InconsistentTypeCode

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        Specified by:
        _ids in class ObjectImpl
        Returns:
        the array of all repository identifiers supported by this ObjectImpl instance
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


_DynAnyStub (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class _DynAnyStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.DynamicAny._DynAnyStub
  • All Implemented Interfaces:
    Serializable, Object, IDLEntity, DynAny, DynAnyOperations

    public class _DynAnyStub
extends ObjectImpl
implements DynAny
    Any values can be dynamically interpreted (traversed) and constructed through DynAny objects. A DynAny object is associated with a data value which corresponds to a copy of the value inserted into an any.

    A DynAny object may be viewed as an ordered collection of component DynAnys. For DynAnys representing a basic type, such as long, or a type without components, such as an empty exception, the ordered collection of components is empty. Each DynAny object maintains the notion of a current position into its collection of component DynAnys. The current position is identified by an index value that runs from 0 to n-1, where n is the number of components. The special index value -1 indicates a current position that points nowhere. For values that cannot have a current position (such as an empty exception), the index value is fixed at -1. If a DynAny is initialized with a value that has components, the index is initialized to 0. After creation of an uninitialized DynAny (that is, a DynAny that has no value but a TypeCode that permits components), the current position depends on the type of value represented by the DynAny. (The current position is set to 0 or -1, depending on whether the new DynAny gets default values for its components.)

    The iteration operations rewind, seek, and next can be used to change the current position and the current_component operation returns the component at the current position. The component_count operation returns the number of components of a DynAny. Collectively, these operations enable iteration over the components of a DynAny, for example, to (recursively) examine its contents.

    A constructed DynAny object is a DynAny object associated with a constructed type. There is a different interface, inheriting from the DynAny interface, associated with each kind of constructed type in IDL (fixed, enum, struct, sequence, union, array, exception, and value type).

    A constructed DynAny object exports operations that enable the creation of new DynAny objects, each of them associated with a component of the constructed data value. As an example, a DynStruct is associated with a struct value. This means that the DynStruct may be seen as owning an ordered collection of components, one for each structure member. The DynStruct object exports operations that enable the creation of new DynAny objects, each of them associated with a member of the struct.

    If a DynAny object has been obtained from another (constructed) DynAny object, such as a DynAny representing a structure member that was created from a DynStruct, the member DynAny is logically contained in the DynStruct. Calling an insert or get operation leaves the current position unchanged. Destroying a top-level DynAny object (one that was not obtained as a component of another DynAny) also destroys any component DynAny objects obtained from it. Destroying a non-top level DynAny object does nothing. Invoking operations on a destroyed top-level DynAny or any of its descendants raises OBJECT_NOT_EXIST. If the programmer wants to destroy a DynAny object but still wants to manipulate some component of the data value associated with it, then he or she should first create a DynAny for the component and, after that, make a copy of the created DynAny object.

    The behavior of DynAny objects has been defined in order to enable efficient implementations in terms of allocated memory space and speed of access. DynAny objects are intended to be used for traversing values extracted from anys or constructing values of anys at runtime. Their use for other purposes is not recommended.

    Insert and get operations are necessary to handle basic DynAny objects but are also helpful to handle constructed DynAny objects. Inserting a basic data type value into a constructed DynAny object implies initializing the current component of the constructed data value associated with the DynAny object. For example, invoking insert_boolean on a DynStruct implies inserting a boolean data value at the current position of the associated struct data value. A type is consistent for inserting or extracting a value if its TypeCode is equivalent to the TypeCode contained in the DynAny or, if the DynAny has components, is equivalent to the TypeCode of the DynAny at the current position.

    DynAny and DynAnyFactory objects are intended to be local to the process in which they are created and used. This means that references to DynAny and DynAnyFactory objects cannot be exported to other processes, or externalized with ORB.object_to_string(). If any attempt is made to do so, the offending operation will raise a MARSHAL system exception. Since their interfaces are specified in IDL, DynAny objects export operations defined in the standard org.omg.CORBA.Object interface. However, any attempt to invoke operations exported through the Object interface may raise the standard NO_IMPLEMENT exception. An attempt to use a DynAny object with the DII may raise the NO_IMPLEMENT exception.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static Class | _opsClass

    • Constructor Summary

      Constructors
      Constructor and Description
      _DynAnyStub()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      int component_count()
      Returns the number of components of a DynAny.
      DynAny copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny current_component()
      Returns the DynAny for the component at the current position.
      void destroy()
      Destroys a DynAny object.
      boolean equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      void from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      Any get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      boolean get_boolean()
      Extracts the boolean value from this DynAny.
      char get_char()
      Extracts the char value from this DynAny.
      double get_double()
      Extracts the double value from this DynAny.
      DynAny get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      float get_float()
      Extracts the float value from this DynAny.
      int get_long()
      Extracts the integer value from this DynAny.
      long get_longlong()
      Extracts the long value from this DynAny.
      byte get_octet()
      Extracts the byte value from this DynAny.
      Object get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      short get_short()
      Extracts the short value from this DynAny.
      String get_string()
      Extracts the string value from this DynAny.
      TypeCode get_typecode()
      Extracts the TypeCode object from this DynAny.
      int get_ulong()
      Extracts the integer value from this DynAny.
      long get_ulonglong()
      Extracts the long value from this DynAny.
      short get_ushort()
      Extracts the short value from this DynAny.
      Serializable get_val()
      Extracts a Serializable object from this DynAny.
      char get_wchar()
      Extracts the long value from this DynAny.
      String get_wstring()
      Extracts the string value from this DynAny.
      void insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void insert_char(char value)
      Inserts a char value into the DynAny.
      void insert_double(double value)
      Inserts a double value into the DynAny.
      void insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void insert_float(float value)
      Inserts a float value into the DynAny.
      void insert_long(int value)
      Inserts an integer value into the DynAny.
      void insert_longlong(long value)
      Inserts a long value into the DynAny.
      void insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void insert_short(short value)
      Inserts a short value into the DynAny.
      void insert_string(String value)
      Inserts a string value into the DynAny.
      void insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void insert_ushort(short value)
      Inserts a short value into the DynAny.
      void insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void insert_wchar(char value)
      Inserts a char value into the DynAny.
      void insert_wstring(String value)
      Inserts a string value into the DynAny.
      boolean next()
      Advances the current position to the next component.
      void rewind()
      Is equivalent to seek(0).
      boolean seek(int index)
      Sets the current position to index.
      Any to_any()
      Creates an any value from a DynAny object.
      TypeCode type()
      Returns the TypeCode associated with this DynAny object.

      • Methods inherited from class org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • Field Detail

      • _opsClass

        public static final Class _opsClass

    • Constructor Detail

      • _DynAnyStub

        public _DynAnyStub()

    • Method Detail

      • type

        public TypeCode type()
        Returns the TypeCode associated with this DynAny object. A DynAny object is created with a TypeCode value assigned to it. This TypeCode value determines the type of the value handled through the DynAny object. Note that the TypeCode associated with a DynAny object is initialized at the time the DynAny is created and cannot be changed during lifetime of the DynAny object.
        Specified by:
        type in interface DynAnyOperations
        Returns:
        The TypeCode associated with this DynAny object

      • assign

        public void assign(DynAny dyn_any)
            throws TypeMismatch
        Initializes the value associated with a DynAny object with the value associated with another DynAny object. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        Specified by:
        assign in interface DynAnyOperations
        Parameters:
        dyn_any -
        Throws:
        TypeMismatch - if the type of the passed DynAny is not equivalent to the type of target DynAny

      • from_any

        public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
        Initializes the value associated with a DynAny object with the value contained in an any. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        Specified by:
        from_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the type of the passed Any is not equivalent to the type of target DynAny
        InvalidValue - if the passed Any does not contain a legal value (such as a null string)

      • to_any

        public Any to_any()
        Creates an any value from a DynAny object. A copy of the TypeCode associated with the DynAny object is assigned to the resulting any. The value associated with the DynAny object is copied into the any.
        Specified by:
        to_any in interface DynAnyOperations
        Returns:
        a new Any object with the same value and TypeCode

      • equal

        public boolean equal(DynAny dyn_any)
        Compares two DynAny values for equality. Two DynAny values are equal if their TypeCodes are equivalent and, recursively, all component DynAnys have equal values. The current position of the two DynAnys being compared has no effect on the result of equal.
        Specified by:
        equal in interface DynAnyOperations
        Returns:
        true of the DynAnys are equal, false otherwise

      • destroy

        public void destroy()
        Destroys a DynAny object. This operation frees any resources used to represent the data value associated with a DynAny object. It must be invoked on references obtained from one of the creation operations on the ORB interface or on a reference returned by DynAny.copy() to avoid resource leaks. Invoking destroy on component DynAny objects (for example, on objects returned by the current_component operation) does nothing. Destruction of a DynAny object implies destruction of all DynAny objects obtained from it. That is, references to components of a destroyed DynAny become invalid. Invocations on such references raise OBJECT_NOT_EXIST. It is possible to manipulate a component of a DynAny beyond the life time of the DynAny from which the component was obtained by making a copy of the component with the copy operation before destroying the DynAny from which the component was obtained.
        Specified by:
        destroy in interface DynAnyOperations

      • copy

        public DynAny copy()
        Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked. The operation is polymorphic, that is, invoking it on one of the types derived from DynAny, such as DynStruct, creates the derived type but returns its reference as the DynAny base type.
        Specified by:
        copy in interface DynAnyOperations
        Returns:
        a deep copy of the DynAny object

      • insert_boolean

        public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a boolean value into the DynAny.
        Specified by:
        insert_boolean in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_octet

        public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a byte value into the DynAny. The IDL octet data type is mapped to the Java byte data type.
        Specified by:
        insert_octet in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_char

        public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts a char value into the DynAny.
        Specified by:
        insert_char in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_short

        public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a short value into the DynAny.
        Specified by:
        insert_short in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ushort

        public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a short value into the DynAny. The IDL ushort data type is mapped to the Java short data type.
        Specified by:
        insert_ushort in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_long

        public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts an integer value into the DynAny. The IDL long data type is mapped to the Java int data type.
        Specified by:
        insert_long in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulong

        public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts an integer value into the DynAny. The IDL ulong data type is mapped to the Java int data type.
        Specified by:
        insert_ulong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_float

        public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a float value into the DynAny.
        Specified by:
        insert_float in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_double

        public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a double value into the DynAny.
        Specified by:
        insert_double in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_string

        public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        Specified by:
        insert_string in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_reference

        public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a reference to a CORBA object into the DynAny.
        Specified by:
        insert_reference in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_typecode

        public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a TypeCode object into the DynAny.
        Specified by:
        insert_typecode in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_longlong

        public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a long value into the DynAny. The IDL long long data type is mapped to the Java long data type.
        Specified by:
        insert_longlong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulonglong

        public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a long value into the DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        Specified by:
        insert_ulonglong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wchar

        public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a char value into the DynAny. The IDL wchar data type is mapped to the Java char data type.
        Specified by:
        insert_wchar in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wstring

        public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        Specified by:
        insert_wstring in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch

      • insert_any

        public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
        Inserts an Any value into the Any represented by this DynAny.
        Specified by:
        insert_any in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_dyn_any

        public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
        Specified by:
        insert_dyn_any in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_val

        public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
        Inserts a reference to a Serializable object into this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        Specified by:
        insert_val in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • get_boolean

        public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
        Extracts the boolean value from this DynAny.
        Specified by:
        get_boolean in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_octet

        public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
        Extracts the byte value from this DynAny. The IDL octet data type is mapped to the Java byte data type.
        Specified by:
        get_octet in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_char

        public char get_char()
              throws TypeMismatch,
                     InvalidValue
        Extracts the char value from this DynAny.
        Specified by:
        get_char in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_short

        public short get_short()
                throws TypeMismatch,
                       InvalidValue
        Extracts the short value from this DynAny.
        Specified by:
        get_short in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ushort

        public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
        Extracts the short value from this DynAny. The IDL ushort data type is mapped to the Java short data type.
        Specified by:
        get_ushort in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_long

        public int get_long()
             throws TypeMismatch,
                    InvalidValue
        Extracts the integer value from this DynAny. The IDL long data type is mapped to the Java int data type.
        Specified by:
        get_long in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulong

        public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
        Extracts the integer value from this DynAny. The IDL ulong data type is mapped to the Java int data type.
        Specified by:
        get_ulong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_float

        public float get_float()
                throws TypeMismatch,
                       InvalidValue
        Extracts the float value from this DynAny.
        Specified by:
        get_float in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_double

        public double get_double()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the double value from this DynAny.
        Specified by:
        get_double in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_string

        public String get_string()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        Specified by:
        get_string in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_reference

        public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
        Extracts the reference to a CORBA Object from this DynAny.
        Specified by:
        get_reference in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_typecode

        public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
        Extracts the TypeCode object from this DynAny.
        Specified by:
        get_typecode in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_longlong

        public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the long value from this DynAny. The IDL long long data type is mapped to the Java long data type.
        Specified by:
        get_longlong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulonglong

        public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the long value from this DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        Specified by:
        get_ulonglong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wchar

        public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
        Extracts the long value from this DynAny. The IDL wchar data type is mapped to the Java char data type.
        Specified by:
        get_wchar in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wstring

        public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        Specified by:
        get_wstring in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue

      • get_any

        public Any get_any()
            throws TypeMismatch,
                   InvalidValue
        Extracts an Any value contained in the Any represented by this DynAny.
        Specified by:
        get_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_dyn_any

        public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
        Specified by:
        get_dyn_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_val

        public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
        Extracts a Serializable object from this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        Specified by:
        get_val in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • seek

        public boolean seek(int index)
        Sets the current position to index. The current position is indexed 0 to n-1, that is, index zero corresponds to the first component. The operation returns true if the resulting current position indicates a component of the DynAny and false if index indicates a position that does not correspond to a component. Calling seek with a negative index is legal. It sets the current position to -1 to indicate no component and returns false. Passing a non-negative index value for a DynAny that does not have a component at the corresponding position sets the current position to -1 and returns false.
        Specified by:
        seek in interface DynAnyOperations

      • rewind

        public void rewind()
        Is equivalent to seek(0).
        Specified by:
        rewind in interface DynAnyOperations

      • next

        public boolean next()
        Advances the current position to the next component. The operation returns true while the resulting current position indicates a component, false otherwise. A false return value leaves the current position at -1. Invoking next on a DynAny without components leaves the current position at -1 and returns false.
        Specified by:
        next in interface DynAnyOperations

      • component_count

        public int component_count()
        Returns the number of components of a DynAny. For a DynAny without components, it returns zero. The operation only counts the components at the top level. For example, if component_count is invoked on a DynStruct with a single member, the return value is 1, irrespective of the type of the member.
        • For sequences, the operation returns the current number of elements.
        • For structures, exceptions, and value types, the operation returns the number of members.
        • For arrays, the operation returns the number of elements.
        • For unions, the operation returns 2 if the discriminator indicates that a named member is active, otherwise, it returns 1.
        • For DynFixed and DynEnum, the operation returns zero.
        Specified by:
        component_count in interface DynAnyOperations

      • current_component

        public DynAny current_component()
                         throws TypeMismatch
        Returns the DynAny for the component at the current position. It does not advance the current position, so repeated calls to current_component without an intervening call to rewind, next, or seek return the same component. The returned DynAny object reference can be used to get/set the value of the current component. If the current component represents a complex type, the returned reference can be narrowed based on the TypeCode to get the interface corresponding to the to the complex type. Calling current_component on a DynAny that cannot have components, such as a DynEnum or an empty exception, raises TypeMismatch. Calling current_component on a DynAny whose current position is -1 returns a nil reference. The iteration operations, together with current_component, can be used to dynamically compose an any value. After creating a dynamic any, such as a DynStruct, current_component and next can be used to initialize all the components of the value. Once the dynamic value is completely initialized, to_any creates the corresponding any value.
        Specified by:
        current_component in interface DynAnyOperations
        Throws:
        TypeMismatch - If called on a DynAny that cannot have components, such as a DynEnum or an empty exception

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        Specified by:
        _ids in class ObjectImpl
        Returns:
        the array of all repository identifiers supported by this ObjectImpl instance
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


_DynArrayStub (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class _DynArrayStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.DynamicAny._DynArrayStub
  • All Implemented Interfaces:
    Serializable, Object, IDLEntity, DynAny, DynAnyOperations, DynArray, DynArrayOperations

    public class _DynArrayStub
extends ObjectImpl
implements DynArray
    DynArray objects support the manipulation of IDL arrays. Note that the dimension of the array is contained in the TypeCode which is accessible through the type attribute. It can also be obtained by calling the component_count operation.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static Class | _opsClass

    • Constructor Summary

      Constructors
      Constructor and Description
      _DynArrayStub()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      int component_count()
      Returns the number of components of a DynAny.
      DynAny copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny current_component()
      Returns the DynAny for the component at the current position.
      void destroy()
      Destroys a DynAny object.
      boolean equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      void from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      Any get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      boolean get_boolean()
      Extracts the boolean value from this DynAny.
      char get_char()
      Extracts the char value from this DynAny.
      double get_double()
      Extracts the double value from this DynAny.
      DynAny get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny[] get_elements_as_dyn_any()
      Returns the elements of the DynArray as DynAnys.
      Any[] get_elements()
      Returns the elements of the DynArray.
      float get_float()
      Extracts the float value from this DynAny.
      int get_long()
      Extracts the integer value from this DynAny.
      long get_longlong()
      Extracts the long value from this DynAny.
      byte get_octet()
      Extracts the byte value from this DynAny.
      Object get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      short get_short()
      Extracts the short value from this DynAny.
      String get_string()
      Extracts the string value from this DynAny.
      TypeCode get_typecode()
      Extracts the TypeCode object from this DynAny.
      int get_ulong()
      Extracts the integer value from this DynAny.
      long get_ulonglong()
      Extracts the long value from this DynAny.
      short get_ushort()
      Extracts the short value from this DynAny.
      Serializable get_val()
      Extracts a Serializable object from this DynAny.
      char get_wchar()
      Extracts the long value from this DynAny.
      String get_wstring()
      Extracts the string value from this DynAny.
      void insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void insert_char(char value)
      Inserts a char value into the DynAny.
      void insert_double(double value)
      Inserts a double value into the DynAny.
      void insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void insert_float(float value)
      Inserts a float value into the DynAny.
      void insert_long(int value)
      Inserts an integer value into the DynAny.
      void insert_longlong(long value)
      Inserts a long value into the DynAny.
      void insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void insert_short(short value)
      Inserts a short value into the DynAny.
      void insert_string(String value)
      Inserts a string value into the DynAny.
      void insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void insert_ushort(short value)
      Inserts a short value into the DynAny.
      void insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void insert_wchar(char value)
      Inserts a char value into the DynAny.
      void insert_wstring(String value)
      Inserts a string value into the DynAny.
      boolean next()
      Advances the current position to the next component.
      void rewind()
      Is equivalent to seek(0).
      boolean seek(int index)
      Sets the current position to index.
      void set_elements_as_dyn_any(DynAny[] value)
      Sets the DynArray to contain the passed elements.
      void set_elements(Any[] value)
      Sets the DynArray to contain the passed elements.
      Any to_any()
      Creates an any value from a DynAny object.
      TypeCode type()
      Returns the TypeCode associated with this DynAny object.

      • Methods inherited from class org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • Field Detail

      • _opsClass

        public static final Class _opsClass

    • Constructor Detail

      • _DynArrayStub

        public _DynArrayStub()

    • Method Detail

      • get_elements

        public Any[] get_elements()
        Returns the elements of the DynArray.
        Specified by:
        get_elements in interface DynArrayOperations

      • set_elements

        public void set_elements(Any[] value)
                  throws TypeMismatch,
                         InvalidValue
        Sets the DynArray to contain the passed elements.
        Specified by:
        set_elements in interface DynArrayOperations
        Throws:
        TypeMismatch - if one or more elements have a type that is inconsistent with the DynArrays TypeCode
        InvalidValue - if the sequence does not contain the same number of elements as the array dimension

      • get_elements_as_dyn_any

        public DynAny[] get_elements_as_dyn_any()
        Returns the elements of the DynArray as DynAnys.
        Specified by:
        get_elements_as_dyn_any in interface DynArrayOperations

      • set_elements_as_dyn_any

        public void set_elements_as_dyn_any(DynAny[] value)
                             throws TypeMismatch,
                                    InvalidValue
        Sets the DynArray to contain the passed elements.
        Specified by:
        set_elements_as_dyn_any in interface DynArrayOperations
        Throws:
        TypeMismatch - if one or more elements have a type that is inconsistent with the DynArrays TypeCode
        InvalidValue - if the sequence does not contain the same number of elements as the array dimension

      • type

        public TypeCode type()
        Returns the TypeCode associated with this DynAny object. A DynAny object is created with a TypeCode value assigned to it. This TypeCode value determines the type of the value handled through the DynAny object. Note that the TypeCode associated with a DynAny object is initialized at the time the DynAny is created and cannot be changed during lifetime of the DynAny object.
        Specified by:
        type in interface DynAnyOperations
        Returns:
        The TypeCode associated with this DynAny object

      • assign

        public void assign(DynAny dyn_any)
            throws TypeMismatch
        Initializes the value associated with a DynAny object with the value associated with another DynAny object. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        Specified by:
        assign in interface DynAnyOperations
        Parameters:
        dyn_any -
        Throws:
        TypeMismatch - if the type of the passed DynAny is not equivalent to the type of target DynAny

      • from_any

        public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
        Initializes the value associated with a DynAny object with the value contained in an any. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        Specified by:
        from_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the type of the passed Any is not equivalent to the type of target DynAny
        InvalidValue - if the passed Any does not contain a legal value (such as a null string)

      • to_any

        public Any to_any()
        Creates an any value from a DynAny object. A copy of the TypeCode associated with the DynAny object is assigned to the resulting any. The value associated with the DynAny object is copied into the any.
        Specified by:
        to_any in interface DynAnyOperations
        Returns:
        a new Any object with the same value and TypeCode

      • equal

        public boolean equal(DynAny dyn_any)
        Compares two DynAny values for equality. Two DynAny values are equal if their TypeCodes are equivalent and, recursively, all component DynAnys have equal values. The current position of the two DynAnys being compared has no effect on the result of equal.
        Specified by:
        equal in interface DynAnyOperations
        Returns:
        true of the DynAnys are equal, false otherwise

      • destroy

        public void destroy()
        Destroys a DynAny object. This operation frees any resources used to represent the data value associated with a DynAny object. It must be invoked on references obtained from one of the creation operations on the ORB interface or on a reference returned by DynAny.copy() to avoid resource leaks. Invoking destroy on component DynAny objects (for example, on objects returned by the current_component operation) does nothing. Destruction of a DynAny object implies destruction of all DynAny objects obtained from it. That is, references to components of a destroyed DynAny become invalid. Invocations on such references raise OBJECT_NOT_EXIST. It is possible to manipulate a component of a DynAny beyond the life time of the DynAny from which the component was obtained by making a copy of the component with the copy operation before destroying the DynAny from which the component was obtained.
        Specified by:
        destroy in interface DynAnyOperations

      • copy

        public DynAny copy()
        Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked. The operation is polymorphic, that is, invoking it on one of the types derived from DynAny, such as DynStruct, creates the derived type but returns its reference as the DynAny base type.
        Specified by:
        copy in interface DynAnyOperations
        Returns:
        a deep copy of the DynAny object

      • insert_boolean

        public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a boolean value into the DynAny.
        Specified by:
        insert_boolean in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_octet

        public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a byte value into the DynAny. The IDL octet data type is mapped to the Java byte data type.
        Specified by:
        insert_octet in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_char

        public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts a char value into the DynAny.
        Specified by:
        insert_char in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_short

        public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a short value into the DynAny.
        Specified by:
        insert_short in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ushort

        public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a short value into the DynAny. The IDL ushort data type is mapped to the Java short data type.
        Specified by:
        insert_ushort in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_long

        public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts an integer value into the DynAny. The IDL long data type is mapped to the Java int data type.
        Specified by:
        insert_long in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulong

        public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts an integer value into the DynAny. The IDL ulong data type is mapped to the Java int data type.
        Specified by:
        insert_ulong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_float

        public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a float value into the DynAny.
        Specified by:
        insert_float in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_double

        public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a double value into the DynAny.
        Specified by:
        insert_double in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_string

        public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        Specified by:
        insert_string in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_reference

        public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a reference to a CORBA object into the DynAny.
        Specified by:
        insert_reference in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_typecode

        public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a TypeCode object into the DynAny.
        Specified by:
        insert_typecode in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_longlong

        public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a long value into the DynAny. The IDL long long data type is mapped to the Java long data type.
        Specified by:
        insert_longlong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulonglong

        public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a long value into the DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        Specified by:
        insert_ulonglong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wchar

        public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a char value into the DynAny. The IDL wchar data type is mapped to the Java char data type.
        Specified by:
        insert_wchar in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wstring

        public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        Specified by:
        insert_wstring in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch

      • insert_any

        public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
        Inserts an Any value into the Any represented by this DynAny.
        Specified by:
        insert_any in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_dyn_any

        public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
        Specified by:
        insert_dyn_any in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_val

        public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
        Inserts a reference to a Serializable object into this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        Specified by:
        insert_val in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • get_boolean

        public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
        Extracts the boolean value from this DynAny.
        Specified by:
        get_boolean in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_octet

        public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
        Extracts the byte value from this DynAny. The IDL octet data type is mapped to the Java byte data type.
        Specified by:
        get_octet in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_char

        public char get_char()
              throws TypeMismatch,
                     InvalidValue
        Extracts the char value from this DynAny.
        Specified by:
        get_char in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_short

        public short get_short()
                throws TypeMismatch,
                       InvalidValue
        Extracts the short value from this DynAny.
        Specified by:
        get_short in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ushort

        public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
        Extracts the short value from this DynAny. The IDL ushort data type is mapped to the Java short data type.
        Specified by:
        get_ushort in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_long

        public int get_long()
             throws TypeMismatch,
                    InvalidValue
        Extracts the integer value from this DynAny. The IDL long data type is mapped to the Java int data type.
        Specified by:
        get_long in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulong

        public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
        Extracts the integer value from this DynAny. The IDL ulong data type is mapped to the Java int data type.
        Specified by:
        get_ulong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_float

        public float get_float()
                throws TypeMismatch,
                       InvalidValue
        Extracts the float value from this DynAny.
        Specified by:
        get_float in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_double

        public double get_double()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the double value from this DynAny.
        Specified by:
        get_double in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_string

        public String get_string()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        Specified by:
        get_string in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_reference

        public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
        Extracts the reference to a CORBA Object from this DynAny.
        Specified by:
        get_reference in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_typecode

        public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
        Extracts the TypeCode object from this DynAny.
        Specified by:
        get_typecode in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_longlong

        public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the long value from this DynAny. The IDL long long data type is mapped to the Java long data type.
        Specified by:
        get_longlong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulonglong

        public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the long value from this DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        Specified by:
        get_ulonglong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wchar

        public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
        Extracts the long value from this DynAny. The IDL wchar data type is mapped to the Java char data type.
        Specified by:
        get_wchar in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wstring

        public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        Specified by:
        get_wstring in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue

      • get_any

        public Any get_any()
            throws TypeMismatch,
                   InvalidValue
        Extracts an Any value contained in the Any represented by this DynAny.
        Specified by:
        get_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_dyn_any

        public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
        Specified by:
        get_dyn_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_val

        public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
        Extracts a Serializable object from this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        Specified by:
        get_val in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • seek

        public boolean seek(int index)
        Sets the current position to index. The current position is indexed 0 to n-1, that is, index zero corresponds to the first component. The operation returns true if the resulting current position indicates a component of the DynAny and false if index indicates a position that does not correspond to a component. Calling seek with a negative index is legal. It sets the current position to -1 to indicate no component and returns false. Passing a non-negative index value for a DynAny that does not have a component at the corresponding position sets the current position to -1 and returns false.
        Specified by:
        seek in interface DynAnyOperations

      • rewind

        public void rewind()
        Is equivalent to seek(0).
        Specified by:
        rewind in interface DynAnyOperations

      • next

        public boolean next()
        Advances the current position to the next component. The operation returns true while the resulting current position indicates a component, false otherwise. A false return value leaves the current position at -1. Invoking next on a DynAny without components leaves the current position at -1 and returns false.
        Specified by:
        next in interface DynAnyOperations

      • component_count

        public int component_count()
        Returns the number of components of a DynAny. For a DynAny without components, it returns zero. The operation only counts the components at the top level. For example, if component_count is invoked on a DynStruct with a single member, the return value is 1, irrespective of the type of the member.
        • For sequences, the operation returns the current number of elements.
        • For structures, exceptions, and value types, the operation returns the number of members.
        • For arrays, the operation returns the number of elements.
        • For unions, the operation returns 2 if the discriminator indicates that a named member is active, otherwise, it returns 1.
        • For DynFixed and DynEnum, the operation returns zero.
        Specified by:
        component_count in interface DynAnyOperations

      • current_component

        public DynAny current_component()
                         throws TypeMismatch
        Returns the DynAny for the component at the current position. It does not advance the current position, so repeated calls to current_component without an intervening call to rewind, next, or seek return the same component. The returned DynAny object reference can be used to get/set the value of the current component. If the current component represents a complex type, the returned reference can be narrowed based on the TypeCode to get the interface corresponding to the to the complex type. Calling current_component on a DynAny that cannot have components, such as a DynEnum or an empty exception, raises TypeMismatch. Calling current_component on a DynAny whose current position is -1 returns a nil reference. The iteration operations, together with current_component, can be used to dynamically compose an any value. After creating a dynamic any, such as a DynStruct, current_component and next can be used to initialize all the components of the value. Once the dynamic value is completely initialized, to_any creates the corresponding any value.
        Specified by:
        current_component in interface DynAnyOperations
        Throws:
        TypeMismatch - If called on a DynAny that cannot have components, such as a DynEnum or an empty exception

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        Specified by:
        _ids in class ObjectImpl
        Returns:
        the array of all repository identifiers supported by this ObjectImpl instance
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


_DynEnumStub (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class _DynEnumStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.DynamicAny._DynEnumStub
  • All Implemented Interfaces:
    Serializable, Object, IDLEntity, DynAny, DynAnyOperations, DynEnum, DynEnumOperations

    public class _DynEnumStub
extends ObjectImpl
implements DynEnum
    DynEnum objects support the manipulation of IDL enumerated values. The current position of a DynEnum is always -1.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static Class | _opsClass

    • Constructor Summary

      Constructors
      Constructor and Description
      _DynEnumStub()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      int component_count()
      Returns the number of components of a DynAny.
      DynAny copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny current_component()
      Returns the DynAny for the component at the current position.
      void destroy()
      Destroys a DynAny object.
      boolean equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      void from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      Any get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      String get_as_string()
      Returns the value of the DynEnum as an IDL identifier.
      int get_as_ulong()
      Returns the value of the DynEnum as the enumerated value's ordinal value.
      boolean get_boolean()
      Extracts the boolean value from this DynAny.
      char get_char()
      Extracts the char value from this DynAny.
      double get_double()
      Extracts the double value from this DynAny.
      DynAny get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      float get_float()
      Extracts the float value from this DynAny.
      int get_long()
      Extracts the integer value from this DynAny.
      long get_longlong()
      Extracts the long value from this DynAny.
      byte get_octet()
      Extracts the byte value from this DynAny.
      Object get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      short get_short()
      Extracts the short value from this DynAny.
      String get_string()
      Extracts the string value from this DynAny.
      TypeCode get_typecode()
      Extracts the TypeCode object from this DynAny.
      int get_ulong()
      Extracts the integer value from this DynAny.
      long get_ulonglong()
      Extracts the long value from this DynAny.
      short get_ushort()
      Extracts the short value from this DynAny.
      Serializable get_val()
      Extracts a Serializable object from this DynAny.
      char get_wchar()
      Extracts the long value from this DynAny.
      String get_wstring()
      Extracts the string value from this DynAny.
      void insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void insert_char(char value)
      Inserts a char value into the DynAny.
      void insert_double(double value)
      Inserts a double value into the DynAny.
      void insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void insert_float(float value)
      Inserts a float value into the DynAny.
      void insert_long(int value)
      Inserts an integer value into the DynAny.
      void insert_longlong(long value)
      Inserts a long value into the DynAny.
      void insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void insert_short(short value)
      Inserts a short value into the DynAny.
      void insert_string(String value)
      Inserts a string value into the DynAny.
      void insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void insert_ushort(short value)
      Inserts a short value into the DynAny.
      void insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void insert_wchar(char value)
      Inserts a char value into the DynAny.
      void insert_wstring(String value)
      Inserts a string value into the DynAny.
      boolean next()
      Advances the current position to the next component.
      void rewind()
      Is equivalent to seek(0).
      boolean seek(int index)
      Sets the current position to index.
      void set_as_string(String value)
      Sets the value of the DynEnum to the enumerated value whose IDL identifier is passed in the value parameter.
      void set_as_ulong(int value)
      Sets the value of the DynEnum as the enumerated value's ordinal value.
      Any to_any()
      Creates an any value from a DynAny object.
      TypeCode type()
      Returns the TypeCode associated with this DynAny object.

      • Methods inherited from class org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • Field Detail

      • _opsClass

        public static final Class _opsClass

    • Constructor Detail

      • _DynEnumStub

        public _DynEnumStub()

    • Method Detail

      • get_as_string

        public String get_as_string()
        Returns the value of the DynEnum as an IDL identifier.
        Specified by:
        get_as_string in interface DynEnumOperations

      • set_as_string

        public void set_as_string(String value)
                   throws InvalidValue
        Sets the value of the DynEnum to the enumerated value whose IDL identifier is passed in the value parameter.
        Specified by:
        set_as_string in interface DynEnumOperations
        Throws:
        InvalidValue - If value contains a string that is not a valid IDL identifier for the corresponding enumerated type

      • get_as_ulong

        public int get_as_ulong()
        Returns the value of the DynEnum as the enumerated value's ordinal value. Enumerators have ordinal values 0 to n-1, as they appear from left to right in the corresponding IDL definition.
        Specified by:
        get_as_ulong in interface DynEnumOperations

      • set_as_ulong

        public void set_as_ulong(int value)
                  throws InvalidValue
        Sets the value of the DynEnum as the enumerated value's ordinal value.
        Specified by:
        set_as_ulong in interface DynEnumOperations
        Throws:
        InvalidValue - If value contains a value that is outside the range of ordinal values for the corresponding enumerated type

      • type

        public TypeCode type()
        Returns the TypeCode associated with this DynAny object. A DynAny object is created with a TypeCode value assigned to it. This TypeCode value determines the type of the value handled through the DynAny object. Note that the TypeCode associated with a DynAny object is initialized at the time the DynAny is created and cannot be changed during lifetime of the DynAny object.
        Specified by:
        type in interface DynAnyOperations
        Returns:
        The TypeCode associated with this DynAny object

      • assign

        public void assign(DynAny dyn_any)
            throws TypeMismatch
        Initializes the value associated with a DynAny object with the value associated with another DynAny object. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        Specified by:
        assign in interface DynAnyOperations
        Parameters:
        dyn_any -
        Throws:
        TypeMismatch - if the type of the passed DynAny is not equivalent to the type of target DynAny

      • from_any

        public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
        Initializes the value associated with a DynAny object with the value contained in an any. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        Specified by:
        from_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the type of the passed Any is not equivalent to the type of target DynAny
        InvalidValue - if the passed Any does not contain a legal value (such as a null string)

      • to_any

        public Any to_any()
        Creates an any value from a DynAny object. A copy of the TypeCode associated with the DynAny object is assigned to the resulting any. The value associated with the DynAny object is copied into the any.
        Specified by:
        to_any in interface DynAnyOperations
        Returns:
        a new Any object with the same value and TypeCode

      • equal

        public boolean equal(DynAny dyn_any)
        Compares two DynAny values for equality. Two DynAny values are equal if their TypeCodes are equivalent and, recursively, all component DynAnys have equal values. The current position of the two DynAnys being compared has no effect on the result of equal.
        Specified by:
        equal in interface DynAnyOperations
        Returns:
        true of the DynAnys are equal, false otherwise

      • destroy

        public void destroy()
        Destroys a DynAny object. This operation frees any resources used to represent the data value associated with a DynAny object. It must be invoked on references obtained from one of the creation operations on the ORB interface or on a reference returned by DynAny.copy() to avoid resource leaks. Invoking destroy on component DynAny objects (for example, on objects returned by the current_component operation) does nothing. Destruction of a DynAny object implies destruction of all DynAny objects obtained from it. That is, references to components of a destroyed DynAny become invalid. Invocations on such references raise OBJECT_NOT_EXIST. It is possible to manipulate a component of a DynAny beyond the life time of the DynAny from which the component was obtained by making a copy of the component with the copy operation before destroying the DynAny from which the component was obtained.
        Specified by:
        destroy in interface DynAnyOperations

      • copy

        public DynAny copy()
        Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked. The operation is polymorphic, that is, invoking it on one of the types derived from DynAny, such as DynStruct, creates the derived type but returns its reference as the DynAny base type.
        Specified by:
        copy in interface DynAnyOperations
        Returns:
        a deep copy of the DynAny object

      • insert_boolean

        public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a boolean value into the DynAny.
        Specified by:
        insert_boolean in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_octet

        public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a byte value into the DynAny. The IDL octet data type is mapped to the Java byte data type.
        Specified by:
        insert_octet in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_char

        public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts a char value into the DynAny.
        Specified by:
        insert_char in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_short

        public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a short value into the DynAny.
        Specified by:
        insert_short in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ushort

        public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a short value into the DynAny. The IDL ushort data type is mapped to the Java short data type.
        Specified by:
        insert_ushort in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_long

        public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts an integer value into the DynAny. The IDL long data type is mapped to the Java int data type.
        Specified by:
        insert_long in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulong

        public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts an integer value into the DynAny. The IDL ulong data type is mapped to the Java int data type.
        Specified by:
        insert_ulong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_float

        public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a float value into the DynAny.
        Specified by:
        insert_float in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_double

        public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a double value into the DynAny.
        Specified by:
        insert_double in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_string

        public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        Specified by:
        insert_string in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_reference

        public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a reference to a CORBA object into the DynAny.
        Specified by:
        insert_reference in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_typecode

        public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a TypeCode object into the DynAny.
        Specified by:
        insert_typecode in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_longlong

        public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a long value into the DynAny. The IDL long long data type is mapped to the Java long data type.
        Specified by:
        insert_longlong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulonglong

        public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a long value into the DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        Specified by:
        insert_ulonglong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wchar

        public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a char value into the DynAny. The IDL wchar data type is mapped to the Java char data type.
        Specified by:
        insert_wchar in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wstring

        public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        Specified by:
        insert_wstring in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch

      • insert_any

        public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
        Inserts an Any value into the Any represented by this DynAny.
        Specified by:
        insert_any in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_dyn_any

        public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
        Specified by:
        insert_dyn_any in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_val

        public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
        Inserts a reference to a Serializable object into this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        Specified by:
        insert_val in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • get_boolean

        public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
        Extracts the boolean value from this DynAny.
        Specified by:
        get_boolean in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_octet

        public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
        Extracts the byte value from this DynAny. The IDL octet data type is mapped to the Java byte data type.
        Specified by:
        get_octet in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_char

        public char get_char()
              throws TypeMismatch,
                     InvalidValue
        Extracts the char value from this DynAny.
        Specified by:
        get_char in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_short

        public short get_short()
                throws TypeMismatch,
                       InvalidValue
        Extracts the short value from this DynAny.
        Specified by:
        get_short in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ushort

        public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
        Extracts the short value from this DynAny. The IDL ushort data type is mapped to the Java short data type.
        Specified by:
        get_ushort in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_long

        public int get_long()
             throws TypeMismatch,
                    InvalidValue
        Extracts the integer value from this DynAny. The IDL long data type is mapped to the Java int data type.
        Specified by:
        get_long in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulong

        public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
        Extracts the integer value from this DynAny. The IDL ulong data type is mapped to the Java int data type.
        Specified by:
        get_ulong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_float

        public float get_float()
                throws TypeMismatch,
                       InvalidValue
        Extracts the float value from this DynAny.
        Specified by:
        get_float in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_double

        public double get_double()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the double value from this DynAny.
        Specified by:
        get_double in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_string

        public String get_string()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        Specified by:
        get_string in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_reference

        public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
        Extracts the reference to a CORBA Object from this DynAny.
        Specified by:
        get_reference in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_typecode

        public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
        Extracts the TypeCode object from this DynAny.
        Specified by:
        get_typecode in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_longlong

        public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the long value from this DynAny. The IDL long long data type is mapped to the Java long data type.
        Specified by:
        get_longlong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulonglong

        public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the long value from this DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        Specified by:
        get_ulonglong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wchar

        public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
        Extracts the long value from this DynAny. The IDL wchar data type is mapped to the Java char data type.
        Specified by:
        get_wchar in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wstring

        public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        Specified by:
        get_wstring in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue

      • get_any

        public Any get_any()
            throws TypeMismatch,
                   InvalidValue
        Extracts an Any value contained in the Any represented by this DynAny.
        Specified by:
        get_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_dyn_any

        public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
        Specified by:
        get_dyn_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_val

        public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
        Extracts a Serializable object from this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        Specified by:
        get_val in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • seek

        public boolean seek(int index)
        Sets the current position to index. The current position is indexed 0 to n-1, that is, index zero corresponds to the first component. The operation returns true if the resulting current position indicates a component of the DynAny and false if index indicates a position that does not correspond to a component. Calling seek with a negative index is legal. It sets the current position to -1 to indicate no component and returns false. Passing a non-negative index value for a DynAny that does not have a component at the corresponding position sets the current position to -1 and returns false.
        Specified by:
        seek in interface DynAnyOperations

      • rewind

        public void rewind()
        Is equivalent to seek(0).
        Specified by:
        rewind in interface DynAnyOperations

      • next

        public boolean next()
        Advances the current position to the next component. The operation returns true while the resulting current position indicates a component, false otherwise. A false return value leaves the current position at -1. Invoking next on a DynAny without components leaves the current position at -1 and returns false.
        Specified by:
        next in interface DynAnyOperations

      • component_count

        public int component_count()
        Returns the number of components of a DynAny. For a DynAny without components, it returns zero. The operation only counts the components at the top level. For example, if component_count is invoked on a DynStruct with a single member, the return value is 1, irrespective of the type of the member.
        • For sequences, the operation returns the current number of elements.
        • For structures, exceptions, and value types, the operation returns the number of members.
        • For arrays, the operation returns the number of elements.
        • For unions, the operation returns 2 if the discriminator indicates that a named member is active, otherwise, it returns 1.
        • For DynFixed and DynEnum, the operation returns zero.
        Specified by:
        component_count in interface DynAnyOperations

      • current_component

        public DynAny current_component()
                         throws TypeMismatch
        Returns the DynAny for the component at the current position. It does not advance the current position, so repeated calls to current_component without an intervening call to rewind, next, or seek return the same component. The returned DynAny object reference can be used to get/set the value of the current component. If the current component represents a complex type, the returned reference can be narrowed based on the TypeCode to get the interface corresponding to the to the complex type. Calling current_component on a DynAny that cannot have components, such as a DynEnum or an empty exception, raises TypeMismatch. Calling current_component on a DynAny whose current position is -1 returns a nil reference. The iteration operations, together with current_component, can be used to dynamically compose an any value. After creating a dynamic any, such as a DynStruct, current_component and next can be used to initialize all the components of the value. Once the dynamic value is completely initialized, to_any creates the corresponding any value.
        Specified by:
        current_component in interface DynAnyOperations
        Throws:
        TypeMismatch - If called on a DynAny that cannot have components, such as a DynEnum or an empty exception

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        Specified by:
        _ids in class ObjectImpl
        Returns:
        the array of all repository identifiers supported by this ObjectImpl instance
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


_DynFixedStub (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class _DynFixedStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.DynamicAny._DynFixedStub
  • All Implemented Interfaces:
    Serializable, Object, IDLEntity, DynAny, DynAnyOperations, DynFixed, DynFixedOperations

    public class _DynFixedStub
extends ObjectImpl
implements DynFixed
    DynFixed objects support the manipulation of IDL fixed values. Because IDL does not have a generic type that can represent fixed types with arbitrary number of digits and arbitrary scale, the operations use the IDL string type.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static Class | _opsClass

    • Constructor Summary

      Constructors
      Constructor and Description
      _DynFixedStub()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      int component_count()
      Returns the number of components of a DynAny.
      DynAny copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny current_component()
      Returns the DynAny for the component at the current position.
      void destroy()
      Destroys a DynAny object.
      boolean equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      void from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      Any get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      boolean get_boolean()
      Extracts the boolean value from this DynAny.
      char get_char()
      Extracts the char value from this DynAny.
      double get_double()
      Extracts the double value from this DynAny.
      DynAny get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      float get_float()
      Extracts the float value from this DynAny.
      int get_long()
      Extracts the integer value from this DynAny.
      long get_longlong()
      Extracts the long value from this DynAny.
      byte get_octet()
      Extracts the byte value from this DynAny.
      Object get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      short get_short()
      Extracts the short value from this DynAny.
      String get_string()
      Extracts the string value from this DynAny.
      TypeCode get_typecode()
      Extracts the TypeCode object from this DynAny.
      int get_ulong()
      Extracts the integer value from this DynAny.
      long get_ulonglong()
      Extracts the long value from this DynAny.
      short get_ushort()
      Extracts the short value from this DynAny.
      Serializable get_val()
      Extracts a Serializable object from this DynAny.
      String get_value()
      Returns the value of a DynFixed.
      char get_wchar()
      Extracts the long value from this DynAny.
      String get_wstring()
      Extracts the string value from this DynAny.
      void insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void insert_char(char value)
      Inserts a char value into the DynAny.
      void insert_double(double value)
      Inserts a double value into the DynAny.
      void insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void insert_float(float value)
      Inserts a float value into the DynAny.
      void insert_long(int value)
      Inserts an integer value into the DynAny.
      void insert_longlong(long value)
      Inserts a long value into the DynAny.
      void insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void insert_short(short value)
      Inserts a short value into the DynAny.
      void insert_string(String value)
      Inserts a string value into the DynAny.
      void insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void insert_ushort(short value)
      Inserts a short value into the DynAny.
      void insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void insert_wchar(char value)
      Inserts a char value into the DynAny.
      void insert_wstring(String value)
      Inserts a string value into the DynAny.
      boolean next()
      Advances the current position to the next component.
      void rewind()
      Is equivalent to seek(0).
      boolean seek(int index)
      Sets the current position to index.
      boolean set_value(String val)
      Sets the value of the DynFixed.
      Any to_any()
      Creates an any value from a DynAny object.
      TypeCode type()
      Returns the TypeCode associated with this DynAny object.

      • Methods inherited from class org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • Field Detail

      • _opsClass

        public static final Class _opsClass

    • Constructor Detail

      • _DynFixedStub

        public _DynFixedStub()

    • Method Detail

      • get_value

        public String get_value()
        Returns the value of a DynFixed.
        Specified by:
        get_value in interface DynFixedOperations

      • set_value

        public boolean set_value(String val)
                  throws TypeMismatch,
                         InvalidValue
        Sets the value of the DynFixed. The val string must contain a fixed string constant in the same format as used for IDL fixed-point literals. However, the trailing d or D is optional. The return value is true if val can be represented as the DynFixed without loss of precision. If val has more fractional digits than can be represented in the DynFixed, fractional digits are truncated and the return value is false.
        Specified by:
        set_value in interface DynFixedOperations
        Throws:
        TypeMismatch - If val does not contain a valid fixed-point literal or contains extraneous characters other than leading or trailing white space
        InvalidValue - If val contains a value whose scale exceeds that of the DynFixed or is not initialized

      • type

        public TypeCode type()
        Returns the TypeCode associated with this DynAny object. A DynAny object is created with a TypeCode value assigned to it. This TypeCode value determines the type of the value handled through the DynAny object. Note that the TypeCode associated with a DynAny object is initialized at the time the DynAny is created and cannot be changed during lifetime of the DynAny object.
        Specified by:
        type in interface DynAnyOperations
        Returns:
        The TypeCode associated with this DynAny object

      • assign

        public void assign(DynAny dyn_any)
            throws TypeMismatch
        Initializes the value associated with a DynAny object with the value associated with another DynAny object. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        Specified by:
        assign in interface DynAnyOperations
        Parameters:
        dyn_any -
        Throws:
        TypeMismatch - if the type of the passed DynAny is not equivalent to the type of target DynAny

      • from_any

        public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
        Initializes the value associated with a DynAny object with the value contained in an any. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        Specified by:
        from_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the type of the passed Any is not equivalent to the type of target DynAny
        InvalidValue - if the passed Any does not contain a legal value (such as a null string)

      • to_any

        public Any to_any()
        Creates an any value from a DynAny object. A copy of the TypeCode associated with the DynAny object is assigned to the resulting any. The value associated with the DynAny object is copied into the any.
        Specified by:
        to_any in interface DynAnyOperations
        Returns:
        a new Any object with the same value and TypeCode

      • equal

        public boolean equal(DynAny dyn_any)
        Compares two DynAny values for equality. Two DynAny values are equal if their TypeCodes are equivalent and, recursively, all component DynAnys have equal values. The current position of the two DynAnys being compared has no effect on the result of equal.
        Specified by:
        equal in interface DynAnyOperations
        Returns:
        true of the DynAnys are equal, false otherwise

      • destroy

        public void destroy()
        Destroys a DynAny object. This operation frees any resources used to represent the data value associated with a DynAny object. It must be invoked on references obtained from one of the creation operations on the ORB interface or on a reference returned by DynAny.copy() to avoid resource leaks. Invoking destroy on component DynAny objects (for example, on objects returned by the current_component operation) does nothing. Destruction of a DynAny object implies destruction of all DynAny objects obtained from it. That is, references to components of a destroyed DynAny become invalid. Invocations on such references raise OBJECT_NOT_EXIST. It is possible to manipulate a component of a DynAny beyond the life time of the DynAny from which the component was obtained by making a copy of the component with the copy operation before destroying the DynAny from which the component was obtained.
        Specified by:
        destroy in interface DynAnyOperations

      • copy

        public DynAny copy()
        Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked. The operation is polymorphic, that is, invoking it on one of the types derived from DynAny, such as DynStruct, creates the derived type but returns its reference as the DynAny base type.
        Specified by:
        copy in interface DynAnyOperations
        Returns:
        a deep copy of the DynAny object

      • insert_boolean

        public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a boolean value into the DynAny.
        Specified by:
        insert_boolean in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_octet

        public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a byte value into the DynAny. The IDL octet data type is mapped to the Java byte data type.
        Specified by:
        insert_octet in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_char

        public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts a char value into the DynAny.
        Specified by:
        insert_char in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_short

        public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a short value into the DynAny.
        Specified by:
        insert_short in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ushort

        public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a short value into the DynAny. The IDL ushort data type is mapped to the Java short data type.
        Specified by:
        insert_ushort in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_long

        public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts an integer value into the DynAny. The IDL long data type is mapped to the Java int data type.
        Specified by:
        insert_long in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulong

        public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts an integer value into the DynAny. The IDL ulong data type is mapped to the Java int data type.
        Specified by:
        insert_ulong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_float

        public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a float value into the DynAny.
        Specified by:
        insert_float in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_double

        public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a double value into the DynAny.
        Specified by:
        insert_double in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_string

        public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        Specified by:
        insert_string in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_reference

        public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a reference to a CORBA object into the DynAny.
        Specified by:
        insert_reference in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_typecode

        public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a TypeCode object into the DynAny.
        Specified by:
        insert_typecode in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_longlong

        public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a long value into the DynAny. The IDL long long data type is mapped to the Java long data type.
        Specified by:
        insert_longlong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulonglong

        public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a long value into the DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        Specified by:
        insert_ulonglong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wchar

        public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a char value into the DynAny. The IDL wchar data type is mapped to the Java char data type.
        Specified by:
        insert_wchar in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wstring

        public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        Specified by:
        insert_wstring in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch

      • insert_any

        public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
        Inserts an Any value into the Any represented by this DynAny.
        Specified by:
        insert_any in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_dyn_any

        public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
        Specified by:
        insert_dyn_any in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_val

        public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
        Inserts a reference to a Serializable object into this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        Specified by:
        insert_val in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • get_boolean

        public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
        Extracts the boolean value from this DynAny.
        Specified by:
        get_boolean in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_octet

        public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
        Extracts the byte value from this DynAny. The IDL octet data type is mapped to the Java byte data type.
        Specified by:
        get_octet in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_char

        public char get_char()
              throws TypeMismatch,
                     InvalidValue
        Extracts the char value from this DynAny.
        Specified by:
        get_char in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_short

        public short get_short()
                throws TypeMismatch,
                       InvalidValue
        Extracts the short value from this DynAny.
        Specified by:
        get_short in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ushort

        public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
        Extracts the short value from this DynAny. The IDL ushort data type is mapped to the Java short data type.
        Specified by:
        get_ushort in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_long

        public int get_long()
             throws TypeMismatch,
                    InvalidValue
        Extracts the integer value from this DynAny. The IDL long data type is mapped to the Java int data type.
        Specified by:
        get_long in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulong

        public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
        Extracts the integer value from this DynAny. The IDL ulong data type is mapped to the Java int data type.
        Specified by:
        get_ulong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_float

        public float get_float()
                throws TypeMismatch,
                       InvalidValue
        Extracts the float value from this DynAny.
        Specified by:
        get_float in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_double

        public double get_double()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the double value from this DynAny.
        Specified by:
        get_double in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_string

        public String get_string()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        Specified by:
        get_string in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_reference

        public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
        Extracts the reference to a CORBA Object from this DynAny.
        Specified by:
        get_reference in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_typecode

        public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
        Extracts the TypeCode object from this DynAny.
        Specified by:
        get_typecode in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_longlong

        public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the long value from this DynAny. The IDL long long data type is mapped to the Java long data type.
        Specified by:
        get_longlong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulonglong

        public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the long value from this DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        Specified by:
        get_ulonglong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wchar

        public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
        Extracts the long value from this DynAny. The IDL wchar data type is mapped to the Java char data type.
        Specified by:
        get_wchar in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wstring

        public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        Specified by:
        get_wstring in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue

      • get_any

        public Any get_any()
            throws TypeMismatch,
                   InvalidValue
        Extracts an Any value contained in the Any represented by this DynAny.
        Specified by:
        get_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_dyn_any

        public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
        Specified by:
        get_dyn_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_val

        public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
        Extracts a Serializable object from this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        Specified by:
        get_val in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • seek

        public boolean seek(int index)
        Sets the current position to index. The current position is indexed 0 to n-1, that is, index zero corresponds to the first component. The operation returns true if the resulting current position indicates a component of the DynAny and false if index indicates a position that does not correspond to a component. Calling seek with a negative index is legal. It sets the current position to -1 to indicate no component and returns false. Passing a non-negative index value for a DynAny that does not have a component at the corresponding position sets the current position to -1 and returns false.
        Specified by:
        seek in interface DynAnyOperations

      • rewind

        public void rewind()
        Is equivalent to seek(0).
        Specified by:
        rewind in interface DynAnyOperations

      • next

        public boolean next()
        Advances the current position to the next component. The operation returns true while the resulting current position indicates a component, false otherwise. A false return value leaves the current position at -1. Invoking next on a DynAny without components leaves the current position at -1 and returns false.
        Specified by:
        next in interface DynAnyOperations

      • component_count

        public int component_count()
        Returns the number of components of a DynAny. For a DynAny without components, it returns zero. The operation only counts the components at the top level. For example, if component_count is invoked on a DynStruct with a single member, the return value is 1, irrespective of the type of the member.
        • For sequences, the operation returns the current number of elements.
        • For structures, exceptions, and value types, the operation returns the number of members.
        • For arrays, the operation returns the number of elements.
        • For unions, the operation returns 2 if the discriminator indicates that a named member is active, otherwise, it returns 1.
        • For DynFixed and DynEnum, the operation returns zero.
        Specified by:
        component_count in interface DynAnyOperations

      • current_component

        public DynAny current_component()
                         throws TypeMismatch
        Returns the DynAny for the component at the current position. It does not advance the current position, so repeated calls to current_component without an intervening call to rewind, next, or seek return the same component. The returned DynAny object reference can be used to get/set the value of the current component. If the current component represents a complex type, the returned reference can be narrowed based on the TypeCode to get the interface corresponding to the to the complex type. Calling current_component on a DynAny that cannot have components, such as a DynEnum or an empty exception, raises TypeMismatch. Calling current_component on a DynAny whose current position is -1 returns a nil reference. The iteration operations, together with current_component, can be used to dynamically compose an any value. After creating a dynamic any, such as a DynStruct, current_component and next can be used to initialize all the components of the value. Once the dynamic value is completely initialized, to_any creates the corresponding any value.
        Specified by:
        current_component in interface DynAnyOperations
        Throws:
        TypeMismatch - If called on a DynAny that cannot have components, such as a DynEnum or an empty exception

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        Specified by:
        _ids in class ObjectImpl
        Returns:
        the array of all repository identifiers supported by this ObjectImpl instance
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


_DynSequenceStub (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class _DynSequenceStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.DynamicAny._DynSequenceStub
  • All Implemented Interfaces:
    Serializable, Object, IDLEntity, DynAny, DynAnyOperations, DynSequence, DynSequenceOperations

    public class _DynSequenceStub
extends ObjectImpl
implements DynSequence
    DynSequence objects support the manipulation of IDL sequences.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static Class | _opsClass

    • Constructor Summary

      Constructors
      Constructor and Description
      _DynSequenceStub()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      int component_count()
      Returns the number of components of a DynAny.
      DynAny copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny current_component()
      Returns the DynAny for the component at the current position.
      void destroy()
      Destroys a DynAny object.
      boolean equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      void from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      Any get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      boolean get_boolean()
      Extracts the boolean value from this DynAny.
      char get_char()
      Extracts the char value from this DynAny.
      double get_double()
      Extracts the double value from this DynAny.
      DynAny get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      DynAny[] get_elements_as_dyn_any()
      Returns the DynAnys representing the elements of the sequence.
      Any[] get_elements()
      Returns the elements of the sequence.
      float get_float()
      Extracts the float value from this DynAny.
      int get_length()
      Returns the current length of the sequence.
      int get_long()
      Extracts the integer value from this DynAny.
      long get_longlong()
      Extracts the long value from this DynAny.
      byte get_octet()
      Extracts the byte value from this DynAny.
      Object get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      short get_short()
      Extracts the short value from this DynAny.
      String get_string()
      Extracts the string value from this DynAny.
      TypeCode get_typecode()
      Extracts the TypeCode object from this DynAny.
      int get_ulong()
      Extracts the integer value from this DynAny.
      long get_ulonglong()
      Extracts the long value from this DynAny.
      short get_ushort()
      Extracts the short value from this DynAny.
      Serializable get_val()
      Extracts a Serializable object from this DynAny.
      char get_wchar()
      Extracts the long value from this DynAny.
      String get_wstring()
      Extracts the string value from this DynAny.
      void insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void insert_char(char value)
      Inserts a char value into the DynAny.
      void insert_double(double value)
      Inserts a double value into the DynAny.
      void insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void insert_float(float value)
      Inserts a float value into the DynAny.
      void insert_long(int value)
      Inserts an integer value into the DynAny.
      void insert_longlong(long value)
      Inserts a long value into the DynAny.
      void insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void insert_short(short value)
      Inserts a short value into the DynAny.
      void insert_string(String value)
      Inserts a string value into the DynAny.
      void insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void insert_ushort(short value)
      Inserts a short value into the DynAny.
      void insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void insert_wchar(char value)
      Inserts a char value into the DynAny.
      void insert_wstring(String value)
      Inserts a string value into the DynAny.
      boolean next()
      Advances the current position to the next component.
      void rewind()
      Is equivalent to seek(0).
      boolean seek(int index)
      Sets the current position to index.
      void set_elements_as_dyn_any(DynAny[] value)
      Sets the elements of a sequence using DynAnys.
      void set_elements(Any[] value)
      Sets the elements of a sequence.
      void set_length(int len)
      Sets the length of the sequence.
      Any to_any()
      Creates an any value from a DynAny object.
      TypeCode type()
      Returns the TypeCode associated with this DynAny object.

      • Methods inherited from class org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • Field Detail

      • _opsClass

        public static final Class _opsClass

    • Constructor Detail

      • _DynSequenceStub

        public _DynSequenceStub()

    • Method Detail

      • get_length

        public int get_length()
        Returns the current length of the sequence.
        Specified by:
        get_length in interface DynSequenceOperations

      • set_length

        public void set_length(int len)
                throws InvalidValue
        Sets the length of the sequence. Increasing the length of a sequence adds new elements at the tail without affecting the values of already existing elements. Newly added elements are default-initialized. Increasing the length of a sequence sets the current position to the first newly-added element if the previous current position was -1. Otherwise, if the previous current position was not -1, the current position is not affected. Decreasing the length of a sequence removes elements from the tail without affecting the value of those elements that remain. The new current position after decreasing the length of a sequence is determined as follows:
        • If the length of the sequence is set to zero, the current position is set to -1.
        • If the current position is -1 before decreasing the length, it remains at -1.
        • If the current position indicates a valid element and that element is not removed when the length is decreased, the current position remains unaffected.
        • If the current position indicates a valid element and that element is removed, the current position is set to -1.
        Specified by:
        set_length in interface DynSequenceOperations
        Throws:
        InvalidValue - if this is a bounded sequence and len is larger than the bound

      • get_elements

        public Any[] get_elements()
        Returns the elements of the sequence.
        Specified by:
        get_elements in interface DynSequenceOperations

      • set_elements

        public void set_elements(Any[] value)
                  throws TypeMismatch,
                         InvalidValue
        Sets the elements of a sequence. The length of the DynSequence is set to the length of value. The current position is set to zero if value has non-zero length and to -1 if value is a zero-length sequence.
        Specified by:
        set_elements in interface DynSequenceOperations
        Throws:
        TypeMismatch - if value contains one or more elements whose TypeCode is not equivalent to the element TypeCode of the DynSequence
        InvalidValue - if the length of value exceeds the bound of a bounded sequence

      • get_elements_as_dyn_any

        public DynAny[] get_elements_as_dyn_any()
        Returns the DynAnys representing the elements of the sequence.
        Specified by:
        get_elements_as_dyn_any in interface DynSequenceOperations

      • set_elements_as_dyn_any

        public void set_elements_as_dyn_any(DynAny[] value)
                             throws TypeMismatch,
                                    InvalidValue
        Sets the elements of a sequence using DynAnys. The length of the DynSequence is set to the length of value. The current position is set to zero if value has non-zero length and to -1 if value is a zero-length sequence.
        Specified by:
        set_elements_as_dyn_any in interface DynSequenceOperations
        Throws:
        TypeMismatch - if value contains one or more elements whose TypeCode is not equivalent to the element TypeCode of the DynSequence
        InvalidValue - if the length of value exceeds the bound of a bounded sequence

      • type

        public TypeCode type()
        Returns the TypeCode associated with this DynAny object. A DynAny object is created with a TypeCode value assigned to it. This TypeCode value determines the type of the value handled through the DynAny object. Note that the TypeCode associated with a DynAny object is initialized at the time the DynAny is created and cannot be changed during lifetime of the DynAny object.
        Specified by:
        type in interface DynAnyOperations
        Returns:
        The TypeCode associated with this DynAny object

      • assign

        public void assign(DynAny dyn_any)
            throws TypeMismatch
        Initializes the value associated with a DynAny object with the value associated with another DynAny object. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        Specified by:
        assign in interface DynAnyOperations
        Parameters:
        dyn_any -
        Throws:
        TypeMismatch - if the type of the passed DynAny is not equivalent to the type of target DynAny

      • from_any

        public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
        Initializes the value associated with a DynAny object with the value contained in an any. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        Specified by:
        from_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the type of the passed Any is not equivalent to the type of target DynAny
        InvalidValue - if the passed Any does not contain a legal value (such as a null string)

      • to_any

        public Any to_any()
        Creates an any value from a DynAny object. A copy of the TypeCode associated with the DynAny object is assigned to the resulting any. The value associated with the DynAny object is copied into the any.
        Specified by:
        to_any in interface DynAnyOperations
        Returns:
        a new Any object with the same value and TypeCode

      • equal

        public boolean equal(DynAny dyn_any)
        Compares two DynAny values for equality. Two DynAny values are equal if their TypeCodes are equivalent and, recursively, all component DynAnys have equal values. The current position of the two DynAnys being compared has no effect on the result of equal.
        Specified by:
        equal in interface DynAnyOperations
        Returns:
        true of the DynAnys are equal, false otherwise

      • destroy

        public void destroy()
        Destroys a DynAny object. This operation frees any resources used to represent the data value associated with a DynAny object. It must be invoked on references obtained from one of the creation operations on the ORB interface or on a reference returned by DynAny.copy() to avoid resource leaks. Invoking destroy on component DynAny objects (for example, on objects returned by the current_component operation) does nothing. Destruction of a DynAny object implies destruction of all DynAny objects obtained from it. That is, references to components of a destroyed DynAny become invalid. Invocations on such references raise OBJECT_NOT_EXIST. It is possible to manipulate a component of a DynAny beyond the life time of the DynAny from which the component was obtained by making a copy of the component with the copy operation before destroying the DynAny from which the component was obtained.
        Specified by:
        destroy in interface DynAnyOperations

      • copy

        public DynAny copy()
        Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked. The operation is polymorphic, that is, invoking it on one of the types derived from DynAny, such as DynStruct, creates the derived type but returns its reference as the DynAny base type.
        Specified by:
        copy in interface DynAnyOperations
        Returns:
        a deep copy of the DynAny object

      • insert_boolean

        public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a boolean value into the DynAny.
        Specified by:
        insert_boolean in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_octet

        public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a byte value into the DynAny. The IDL octet data type is mapped to the Java byte data type.
        Specified by:
        insert_octet in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_char

        public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts a char value into the DynAny.
        Specified by:
        insert_char in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_short

        public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a short value into the DynAny.
        Specified by:
        insert_short in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ushort

        public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a short value into the DynAny. The IDL ushort data type is mapped to the Java short data type.
        Specified by:
        insert_ushort in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_long

        public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts an integer value into the DynAny. The IDL long data type is mapped to the Java int data type.
        Specified by:
        insert_long in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulong

        public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts an integer value into the DynAny. The IDL ulong data type is mapped to the Java int data type.
        Specified by:
        insert_ulong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_float

        public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a float value into the DynAny.
        Specified by:
        insert_float in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_double

        public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a double value into the DynAny.
        Specified by:
        insert_double in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_string

        public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        Specified by:
        insert_string in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_reference

        public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a reference to a CORBA object into the DynAny.
        Specified by:
        insert_reference in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_typecode

        public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a TypeCode object into the DynAny.
        Specified by:
        insert_typecode in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_longlong

        public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a long value into the DynAny. The IDL long long data type is mapped to the Java long data type.
        Specified by:
        insert_longlong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulonglong

        public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a long value into the DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        Specified by:
        insert_ulonglong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wchar

        public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a char value into the DynAny. The IDL wchar data type is mapped to the Java char data type.
        Specified by:
        insert_wchar in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wstring

        public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        Specified by:
        insert_wstring in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch

      • insert_any

        public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
        Inserts an Any value into the Any represented by this DynAny.
        Specified by:
        insert_any in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_dyn_any

        public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
        Specified by:
        insert_dyn_any in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_val

        public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
        Inserts a reference to a Serializable object into this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        Specified by:
        insert_val in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • get_boolean

        public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
        Extracts the boolean value from this DynAny.
        Specified by:
        get_boolean in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_octet

        public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
        Extracts the byte value from this DynAny. The IDL octet data type is mapped to the Java byte data type.
        Specified by:
        get_octet in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_char

        public char get_char()
              throws TypeMismatch,
                     InvalidValue
        Extracts the char value from this DynAny.
        Specified by:
        get_char in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_short

        public short get_short()
                throws TypeMismatch,
                       InvalidValue
        Extracts the short value from this DynAny.
        Specified by:
        get_short in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ushort

        public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
        Extracts the short value from this DynAny. The IDL ushort data type is mapped to the Java short data type.
        Specified by:
        get_ushort in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_long

        public int get_long()
             throws TypeMismatch,
                    InvalidValue
        Extracts the integer value from this DynAny. The IDL long data type is mapped to the Java int data type.
        Specified by:
        get_long in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulong

        public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
        Extracts the integer value from this DynAny. The IDL ulong data type is mapped to the Java int data type.
        Specified by:
        get_ulong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_float

        public float get_float()
                throws TypeMismatch,
                       InvalidValue
        Extracts the float value from this DynAny.
        Specified by:
        get_float in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_double

        public double get_double()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the double value from this DynAny.
        Specified by:
        get_double in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_string

        public String get_string()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        Specified by:
        get_string in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_reference

        public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
        Extracts the reference to a CORBA Object from this DynAny.
        Specified by:
        get_reference in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_typecode

        public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
        Extracts the TypeCode object from this DynAny.
        Specified by:
        get_typecode in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_longlong

        public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the long value from this DynAny. The IDL long long data type is mapped to the Java long data type.
        Specified by:
        get_longlong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulonglong

        public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the long value from this DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        Specified by:
        get_ulonglong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wchar

        public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
        Extracts the long value from this DynAny. The IDL wchar data type is mapped to the Java char data type.
        Specified by:
        get_wchar in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wstring

        public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        Specified by:
        get_wstring in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue

      • get_any

        public Any get_any()
            throws TypeMismatch,
                   InvalidValue
        Extracts an Any value contained in the Any represented by this DynAny.
        Specified by:
        get_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_dyn_any

        public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
        Specified by:
        get_dyn_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_val

        public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
        Extracts a Serializable object from this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        Specified by:
        get_val in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • seek

        public boolean seek(int index)
        Sets the current position to index. The current position is indexed 0 to n-1, that is, index zero corresponds to the first component. The operation returns true if the resulting current position indicates a component of the DynAny and false if index indicates a position that does not correspond to a component. Calling seek with a negative index is legal. It sets the current position to -1 to indicate no component and returns false. Passing a non-negative index value for a DynAny that does not have a component at the corresponding position sets the current position to -1 and returns false.
        Specified by:
        seek in interface DynAnyOperations

      • rewind

        public void rewind()
        Is equivalent to seek(0).
        Specified by:
        rewind in interface DynAnyOperations

      • next

        public boolean next()
        Advances the current position to the next component. The operation returns true while the resulting current position indicates a component, false otherwise. A false return value leaves the current position at -1. Invoking next on a DynAny without components leaves the current position at -1 and returns false.
        Specified by:
        next in interface DynAnyOperations

      • component_count

        public int component_count()
        Returns the number of components of a DynAny. For a DynAny without components, it returns zero. The operation only counts the components at the top level. For example, if component_count is invoked on a DynStruct with a single member, the return value is 1, irrespective of the type of the member.
        • For sequences, the operation returns the current number of elements.
        • For structures, exceptions, and value types, the operation returns the number of members.
        • For arrays, the operation returns the number of elements.
        • For unions, the operation returns 2 if the discriminator indicates that a named member is active, otherwise, it returns 1.
        • For DynFixed and DynEnum, the operation returns zero.
        Specified by:
        component_count in interface DynAnyOperations

      • current_component

        public DynAny current_component()
                         throws TypeMismatch
        Returns the DynAny for the component at the current position. It does not advance the current position, so repeated calls to current_component without an intervening call to rewind, next, or seek return the same component. The returned DynAny object reference can be used to get/set the value of the current component. If the current component represents a complex type, the returned reference can be narrowed based on the TypeCode to get the interface corresponding to the to the complex type. Calling current_component on a DynAny that cannot have components, such as a DynEnum or an empty exception, raises TypeMismatch. Calling current_component on a DynAny whose current position is -1 returns a nil reference. The iteration operations, together with current_component, can be used to dynamically compose an any value. After creating a dynamic any, such as a DynStruct, current_component and next can be used to initialize all the components of the value. Once the dynamic value is completely initialized, to_any creates the corresponding any value.
        Specified by:
        current_component in interface DynAnyOperations
        Throws:
        TypeMismatch - If called on a DynAny that cannot have components, such as a DynEnum or an empty exception

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        Specified by:
        _ids in class ObjectImpl
        Returns:
        the array of all repository identifiers supported by this ObjectImpl instance
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


_DynStructStub (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class _DynStructStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.DynamicAny._DynStructStub
  • All Implemented Interfaces:
    Serializable, Object, IDLEntity, DynAny, DynAnyOperations, DynStruct, DynStructOperations

    public class _DynStructStub
extends ObjectImpl
implements DynStruct
    DynStruct objects support the manipulation of IDL struct and exception values. Members of the exceptions are handled in the same way as members of a struct.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static Class | _opsClass

    • Constructor Summary

      Constructors
      Constructor and Description
      _DynStructStub()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      int component_count()
      Returns the number of components of a DynAny.
      DynAny copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny current_component()
      Returns the DynAny for the component at the current position.
      TCKind current_member_kind()
      Returns the TCKind associated with the member at the current position.
      String current_member_name()
      Returns the name of the member at the current position.
      void destroy()
      Destroys a DynAny object.
      boolean equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      void from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      Any get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      boolean get_boolean()
      Extracts the boolean value from this DynAny.
      char get_char()
      Extracts the char value from this DynAny.
      double get_double()
      Extracts the double value from this DynAny.
      DynAny get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      float get_float()
      Extracts the float value from this DynAny.
      int get_long()
      Extracts the integer value from this DynAny.
      long get_longlong()
      Extracts the long value from this DynAny.
      NameDynAnyPair[] get_members_as_dyn_any()
      Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the struct associated with a DynStruct object.
      NameValuePair[] get_members()
      Returns a sequence of NameValuePairs describing the name and the value of each member in the struct associated with a DynStruct object.
      byte get_octet()
      Extracts the byte value from this DynAny.
      Object get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      short get_short()
      Extracts the short value from this DynAny.
      String get_string()
      Extracts the string value from this DynAny.
      TypeCode get_typecode()
      Extracts the TypeCode object from this DynAny.
      int get_ulong()
      Extracts the integer value from this DynAny.
      long get_ulonglong()
      Extracts the long value from this DynAny.
      short get_ushort()
      Extracts the short value from this DynAny.
      Serializable get_val()
      Extracts a Serializable object from this DynAny.
      char get_wchar()
      Extracts the long value from this DynAny.
      String get_wstring()
      Extracts the string value from this DynAny.
      void insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void insert_char(char value)
      Inserts a char value into the DynAny.
      void insert_double(double value)
      Inserts a double value into the DynAny.
      void insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void insert_float(float value)
      Inserts a float value into the DynAny.
      void insert_long(int value)
      Inserts an integer value into the DynAny.
      void insert_longlong(long value)
      Inserts a long value into the DynAny.
      void insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void insert_short(short value)
      Inserts a short value into the DynAny.
      void insert_string(String value)
      Inserts a string value into the DynAny.
      void insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void insert_ushort(short value)
      Inserts a short value into the DynAny.
      void insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void insert_wchar(char value)
      Inserts a char value into the DynAny.
      void insert_wstring(String value)
      Inserts a string value into the DynAny.
      boolean next()
      Advances the current position to the next component.
      void rewind()
      Is equivalent to seek(0).
      boolean seek(int index)
      Sets the current position to index.
      void set_members_as_dyn_any(NameDynAnyPair[] value)
      Initializes the struct data value associated with a DynStruct object from a sequence of NameDynAnyPairs.
      void set_members(NameValuePair[] value)
      Initializes the struct data value associated with a DynStruct object from a sequence of NameValuePairs.
      Any to_any()
      Creates an any value from a DynAny object.
      TypeCode type()
      Returns the TypeCode associated with this DynAny object.

      • Methods inherited from class org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • Field Detail

      • _opsClass

        public static final Class _opsClass

    • Constructor Detail

      • _DynStructStub

        public _DynStructStub()

    • Method Detail

      • current_member_name

        public String current_member_name()
                           throws TypeMismatch,
                                  InvalidValue
        Returns the name of the member at the current position. This operation may return an empty string since the TypeCode of the value being manipulated may not contain the names of members.
        Specified by:
        current_member_name in interface DynStructOperations
        Throws:
        TypeMismatch - if the DynStruct represents an empty exception.
        InvalidValue - if the current position does not indicate a member

      • current_member_kind

        public TCKind current_member_kind()
                           throws TypeMismatch,
                                  InvalidValue
        Returns the TCKind associated with the member at the current position.
        Specified by:
        current_member_kind in interface DynStructOperations
        Throws:
        TypeMismatch - if the DynStruct represents an empty exception.
        InvalidValue - if the current position does not indicate a member

      • get_members

        public NameValuePair[] get_members()
        Returns a sequence of NameValuePairs describing the name and the value of each member in the struct associated with a DynStruct object. The sequence contains members in the same order as the declaration order of members as indicated by the DynStruct's TypeCode. The current position is not affected. The member names in the returned sequence will be empty strings if the DynStruct's TypeCode does not contain member names.
        Specified by:
        get_members in interface DynStructOperations

      • set_members

        public void set_members(NameValuePair[] value)
                 throws TypeMismatch,
                        InvalidValue
        Initializes the struct data value associated with a DynStruct object from a sequence of NameValuePairs. The operation sets the current position to zero if the passed sequences has non-zero length. Otherwise, if an empty sequence is passed, the current position is set to -1.

        Members must appear in the NameValuePairs in the order in which they appear in the IDL specification of the struct as indicated by the DynStruct's TypeCode or they must be empty strings. The operation makes no attempt to assign member values based on member names.

        Specified by:
        set_members in interface DynStructOperations
        Throws:
        TypeMismatch - if the member names supplied in the passed sequence do not match the corresponding member name in the DynStruct's TypeCode and they are not empty strings
        InvalidValue - if the passed sequence has a number of elements that disagrees with the number of members as indicated by the DynStruct's TypeCode

      • get_members_as_dyn_any

        public NameDynAnyPair[] get_members_as_dyn_any()
        Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the struct associated with a DynStruct object. The sequence contains members in the same order as the declaration order of members as indicated by the DynStruct's TypeCode. The current position is not affected. The member names in the returned sequence will be empty strings if the DynStruct's TypeCode does not contain member names.
        Specified by:
        get_members_as_dyn_any in interface DynStructOperations

      • set_members_as_dyn_any

        public void set_members_as_dyn_any(NameDynAnyPair[] value)
                            throws TypeMismatch,
                                   InvalidValue
        Initializes the struct data value associated with a DynStruct object from a sequence of NameDynAnyPairs. The operation sets the current position to zero if the passed sequences has non-zero length. Otherwise, if an empty sequence is passed, the current position is set to -1.

        Members must appear in the NameDynAnyPairs in the order in which they appear in the IDL specification of the struct as indicated by the DynStruct's TypeCode or they must be empty strings. The operation makes no attempt to assign member values based on member names.

        Specified by:
        set_members_as_dyn_any in interface DynStructOperations
        Throws:
        TypeMismatch - if the member names supplied in the passed sequence do not match the corresponding member name in the DynStruct's TypeCode and they are not empty strings
        InvalidValue - if the passed sequence has a number of elements that disagrees with the number of members as indicated by the DynStruct's TypeCode

      • type

        public TypeCode type()
        Returns the TypeCode associated with this DynAny object. A DynAny object is created with a TypeCode value assigned to it. This TypeCode value determines the type of the value handled through the DynAny object. Note that the TypeCode associated with a DynAny object is initialized at the time the DynAny is created and cannot be changed during lifetime of the DynAny object.
        Specified by:
        type in interface DynAnyOperations
        Returns:
        The TypeCode associated with this DynAny object

      • assign

        public void assign(DynAny dyn_any)
            throws TypeMismatch
        Initializes the value associated with a DynAny object with the value associated with another DynAny object. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        Specified by:
        assign in interface DynAnyOperations
        Parameters:
        dyn_any -
        Throws:
        TypeMismatch - if the type of the passed DynAny is not equivalent to the type of target DynAny

      • from_any

        public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
        Initializes the value associated with a DynAny object with the value contained in an any. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        Specified by:
        from_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the type of the passed Any is not equivalent to the type of target DynAny
        InvalidValue - if the passed Any does not contain a legal value (such as a null string)

      • to_any

        public Any to_any()
        Creates an any value from a DynAny object. A copy of the TypeCode associated with the DynAny object is assigned to the resulting any. The value associated with the DynAny object is copied into the any.
        Specified by:
        to_any in interface DynAnyOperations
        Returns:
        a new Any object with the same value and TypeCode

      • equal

        public boolean equal(DynAny dyn_any)
        Compares two DynAny values for equality. Two DynAny values are equal if their TypeCodes are equivalent and, recursively, all component DynAnys have equal values. The current position of the two DynAnys being compared has no effect on the result of equal.
        Specified by:
        equal in interface DynAnyOperations
        Returns:
        true of the DynAnys are equal, false otherwise

      • destroy

        public void destroy()
        Destroys a DynAny object. This operation frees any resources used to represent the data value associated with a DynAny object. It must be invoked on references obtained from one of the creation operations on the ORB interface or on a reference returned by DynAny.copy() to avoid resource leaks. Invoking destroy on component DynAny objects (for example, on objects returned by the current_component operation) does nothing. Destruction of a DynAny object implies destruction of all DynAny objects obtained from it. That is, references to components of a destroyed DynAny become invalid. Invocations on such references raise OBJECT_NOT_EXIST. It is possible to manipulate a component of a DynAny beyond the life time of the DynAny from which the component was obtained by making a copy of the component with the copy operation before destroying the DynAny from which the component was obtained.
        Specified by:
        destroy in interface DynAnyOperations

      • copy

        public DynAny copy()
        Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked. The operation is polymorphic, that is, invoking it on one of the types derived from DynAny, such as DynStruct, creates the derived type but returns its reference as the DynAny base type.
        Specified by:
        copy in interface DynAnyOperations
        Returns:
        a deep copy of the DynAny object

      • insert_boolean

        public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a boolean value into the DynAny.
        Specified by:
        insert_boolean in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_octet

        public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a byte value into the DynAny. The IDL octet data type is mapped to the Java byte data type.
        Specified by:
        insert_octet in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_char

        public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts a char value into the DynAny.
        Specified by:
        insert_char in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_short

        public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a short value into the DynAny.
        Specified by:
        insert_short in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ushort

        public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a short value into the DynAny. The IDL ushort data type is mapped to the Java short data type.
        Specified by:
        insert_ushort in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_long

        public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts an integer value into the DynAny. The IDL long data type is mapped to the Java int data type.
        Specified by:
        insert_long in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulong

        public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts an integer value into the DynAny. The IDL ulong data type is mapped to the Java int data type.
        Specified by:
        insert_ulong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_float

        public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a float value into the DynAny.
        Specified by:
        insert_float in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_double

        public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a double value into the DynAny.
        Specified by:
        insert_double in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_string

        public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        Specified by:
        insert_string in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_reference

        public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a reference to a CORBA object into the DynAny.
        Specified by:
        insert_reference in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_typecode

        public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a TypeCode object into the DynAny.
        Specified by:
        insert_typecode in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_longlong

        public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a long value into the DynAny. The IDL long long data type is mapped to the Java long data type.
        Specified by:
        insert_longlong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulonglong

        public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a long value into the DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        Specified by:
        insert_ulonglong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wchar

        public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a char value into the DynAny. The IDL wchar data type is mapped to the Java char data type.
        Specified by:
        insert_wchar in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wstring

        public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        Specified by:
        insert_wstring in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch

      • insert_any

        public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
        Inserts an Any value into the Any represented by this DynAny.
        Specified by:
        insert_any in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_dyn_any

        public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
        Specified by:
        insert_dyn_any in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_val

        public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
        Inserts a reference to a Serializable object into this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        Specified by:
        insert_val in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • get_boolean

        public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
        Extracts the boolean value from this DynAny.
        Specified by:
        get_boolean in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_octet

        public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
        Extracts the byte value from this DynAny. The IDL octet data type is mapped to the Java byte data type.
        Specified by:
        get_octet in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_char

        public char get_char()
              throws TypeMismatch,
                     InvalidValue
        Extracts the char value from this DynAny.
        Specified by:
        get_char in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_short

        public short get_short()
                throws TypeMismatch,
                       InvalidValue
        Extracts the short value from this DynAny.
        Specified by:
        get_short in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ushort

        public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
        Extracts the short value from this DynAny. The IDL ushort data type is mapped to the Java short data type.
        Specified by:
        get_ushort in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_long

        public int get_long()
             throws TypeMismatch,
                    InvalidValue
        Extracts the integer value from this DynAny. The IDL long data type is mapped to the Java int data type.
        Specified by:
        get_long in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulong

        public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
        Extracts the integer value from this DynAny. The IDL ulong data type is mapped to the Java int data type.
        Specified by:
        get_ulong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_float

        public float get_float()
                throws TypeMismatch,
                       InvalidValue
        Extracts the float value from this DynAny.
        Specified by:
        get_float in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_double

        public double get_double()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the double value from this DynAny.
        Specified by:
        get_double in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_string

        public String get_string()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        Specified by:
        get_string in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_reference

        public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
        Extracts the reference to a CORBA Object from this DynAny.
        Specified by:
        get_reference in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_typecode

        public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
        Extracts the TypeCode object from this DynAny.
        Specified by:
        get_typecode in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_longlong

        public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the long value from this DynAny. The IDL long long data type is mapped to the Java long data type.
        Specified by:
        get_longlong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulonglong

        public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the long value from this DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        Specified by:
        get_ulonglong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wchar

        public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
        Extracts the long value from this DynAny. The IDL wchar data type is mapped to the Java char data type.
        Specified by:
        get_wchar in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wstring

        public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        Specified by:
        get_wstring in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue

      • get_any

        public Any get_any()
            throws TypeMismatch,
                   InvalidValue
        Extracts an Any value contained in the Any represented by this DynAny.
        Specified by:
        get_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_dyn_any

        public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
        Specified by:
        get_dyn_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_val

        public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
        Extracts a Serializable object from this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        Specified by:
        get_val in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • seek

        public boolean seek(int index)
        Sets the current position to index. The current position is indexed 0 to n-1, that is, index zero corresponds to the first component. The operation returns true if the resulting current position indicates a component of the DynAny and false if index indicates a position that does not correspond to a component. Calling seek with a negative index is legal. It sets the current position to -1 to indicate no component and returns false. Passing a non-negative index value for a DynAny that does not have a component at the corresponding position sets the current position to -1 and returns false.
        Specified by:
        seek in interface DynAnyOperations

      • rewind

        public void rewind()
        Is equivalent to seek(0).
        Specified by:
        rewind in interface DynAnyOperations

      • next

        public boolean next()
        Advances the current position to the next component. The operation returns true while the resulting current position indicates a component, false otherwise. A false return value leaves the current position at -1. Invoking next on a DynAny without components leaves the current position at -1 and returns false.
        Specified by:
        next in interface DynAnyOperations

      • component_count

        public int component_count()
        Returns the number of components of a DynAny. For a DynAny without components, it returns zero. The operation only counts the components at the top level. For example, if component_count is invoked on a DynStruct with a single member, the return value is 1, irrespective of the type of the member.
        • For sequences, the operation returns the current number of elements.
        • For structures, exceptions, and value types, the operation returns the number of members.
        • For arrays, the operation returns the number of elements.
        • For unions, the operation returns 2 if the discriminator indicates that a named member is active, otherwise, it returns 1.
        • For DynFixed and DynEnum, the operation returns zero.
        Specified by:
        component_count in interface DynAnyOperations

      • current_component

        public DynAny current_component()
                         throws TypeMismatch
        Returns the DynAny for the component at the current position. It does not advance the current position, so repeated calls to current_component without an intervening call to rewind, next, or seek return the same component. The returned DynAny object reference can be used to get/set the value of the current component. If the current component represents a complex type, the returned reference can be narrowed based on the TypeCode to get the interface corresponding to the to the complex type. Calling current_component on a DynAny that cannot have components, such as a DynEnum or an empty exception, raises TypeMismatch. Calling current_component on a DynAny whose current position is -1 returns a nil reference. The iteration operations, together with current_component, can be used to dynamically compose an any value. After creating a dynamic any, such as a DynStruct, current_component and next can be used to initialize all the components of the value. Once the dynamic value is completely initialized, to_any creates the corresponding any value.
        Specified by:
        current_component in interface DynAnyOperations
        Throws:
        TypeMismatch - If called on a DynAny that cannot have components, such as a DynEnum or an empty exception

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        Specified by:
        _ids in class ObjectImpl
        Returns:
        the array of all repository identifiers supported by this ObjectImpl instance
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


_DynUnionStub (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class _DynUnionStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.DynamicAny._DynUnionStub
  • All Implemented Interfaces:
    Serializable, Object, IDLEntity, DynAny, DynAnyOperations, DynUnion, DynUnionOperations

    public class _DynUnionStub
extends ObjectImpl
implements DynUnion
    DynUnion objects support the manipulation of IDL unions. A union can have only two valid current positions:
    • zero, which denotes the discriminator
    • one, which denotes the active member
    The component_count value for a union depends on the current discriminator: it is 2 for a union whose discriminator indicates a named member, and 1 otherwise.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static Class | _opsClass

    • Constructor Summary

      Constructors
      Constructor and Description
      _DynUnionStub()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      int component_count()
      Returns the number of components of a DynAny.
      DynAny copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny current_component()
      Returns the DynAny for the component at the current position.
      void destroy()
      Destroys a DynAny object.
      TCKind discriminator_kind()
      Returns the TCKind value of the discriminators TypeCode.
      boolean equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      void from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      Any get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      boolean get_boolean()
      Extracts the boolean value from this DynAny.
      char get_char()
      Extracts the char value from this DynAny.
      DynAny get_discriminator()
      Returns the current discriminator value.
      double get_double()
      Extracts the double value from this DynAny.
      DynAny get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      float get_float()
      Extracts the float value from this DynAny.
      int get_long()
      Extracts the integer value from this DynAny.
      long get_longlong()
      Extracts the long value from this DynAny.
      byte get_octet()
      Extracts the byte value from this DynAny.
      Object get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      short get_short()
      Extracts the short value from this DynAny.
      String get_string()
      Extracts the string value from this DynAny.
      TypeCode get_typecode()
      Extracts the TypeCode object from this DynAny.
      int get_ulong()
      Extracts the integer value from this DynAny.
      long get_ulonglong()
      Extracts the long value from this DynAny.
      short get_ushort()
      Extracts the short value from this DynAny.
      Serializable get_val()
      Extracts a Serializable object from this DynAny.
      char get_wchar()
      Extracts the long value from this DynAny.
      String get_wstring()
      Extracts the string value from this DynAny.
      boolean has_no_active_member()
      Returns true if the union has no active member, that is, the unions value consists solely of its discriminator because the discriminator has a value that is not listed as an explicit case label.
      void insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void insert_char(char value)
      Inserts a char value into the DynAny.
      void insert_double(double value)
      Inserts a double value into the DynAny.
      void insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void insert_float(float value)
      Inserts a float value into the DynAny.
      void insert_long(int value)
      Inserts an integer value into the DynAny.
      void insert_longlong(long value)
      Inserts a long value into the DynAny.
      void insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void insert_short(short value)
      Inserts a short value into the DynAny.
      void insert_string(String value)
      Inserts a string value into the DynAny.
      void insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void insert_ushort(short value)
      Inserts a short value into the DynAny.
      void insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void insert_wchar(char value)
      Inserts a char value into the DynAny.
      void insert_wstring(String value)
      Inserts a string value into the DynAny.
      TCKind member_kind()
      Returns the TCKind value of the currently active members TypeCode.
      String member_name()
      Returns the name of the currently active member.
      DynAny member()
      Returns the currently active member.
      boolean next()
      Advances the current position to the next component.
      void rewind()
      Is equivalent to seek(0).
      boolean seek(int index)
      Sets the current position to index.
      void set_discriminator(DynAny d)
      Sets the discriminator of the DynUnion to the specified value.
      void set_to_default_member()
      Sets the discriminator to a value that is consistent with the value of the default case of a union.
      void set_to_no_active_member()
      Sets the discriminator to a value that does not correspond to any of the unions case labels.
      Any to_any()
      Creates an any value from a DynAny object.
      TypeCode type()
      Returns the TypeCode associated with this DynAny object.

      • Methods inherited from class org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • Field Detail

      • _opsClass

        public static final Class _opsClass

    • Constructor Detail

      • _DynUnionStub

        public _DynUnionStub()

    • Method Detail

      • get_discriminator

        public DynAny get_discriminator()
        Returns the current discriminator value.
        Specified by:
        get_discriminator in interface DynUnionOperations

      • set_discriminator

        public void set_discriminator(DynAny d)
                       throws TypeMismatch
        Sets the discriminator of the DynUnion to the specified value. Setting the discriminator to a value that is consistent with the currently active union member does not affect the currently active member. Setting the discriminator to a value that is inconsistent with the currently active member deactivates the member and activates the member that is consistent with the new discriminator value (if there is a member for that value) by initializing the member to its default value. Setting the discriminator of a union sets the current position to 0 if the discriminator value indicates a non-existent union member (has_no_active_member returns true in this case). Otherwise, if the discriminator value indicates a named union member, the current position is set to 1 (has_no_active_member returns false and component_count returns 2 in this case).
        Specified by:
        set_discriminator in interface DynUnionOperations
        Throws:
        TypeMismatch - if the TypeCode of the parameter is not equivalent to the TypeCode of the union's discriminator

      • set_to_default_member

        public void set_to_default_member()
                           throws TypeMismatch
        Sets the discriminator to a value that is consistent with the value of the default case of a union. It sets the current position to zero and causes component_count to return 2.
        Specified by:
        set_to_default_member in interface DynUnionOperations
        Throws:
        TypeMismatch - if the union does not have an explicit default case

      • set_to_no_active_member

        public void set_to_no_active_member()
                             throws TypeMismatch
        Sets the discriminator to a value that does not correspond to any of the unions case labels. It sets the current position to zero and causes component_count to return 1.
        Specified by:
        set_to_no_active_member in interface DynUnionOperations
        Throws:
        TypeMismatch - if the union has an explicit default case or if it uses the entire range of discriminator values for explicit case labels

      • has_no_active_member

        public boolean has_no_active_member()
        Returns true if the union has no active member, that is, the unions value consists solely of its discriminator because the discriminator has a value that is not listed as an explicit case label. Calling this operation on a union that has a default case returns false. Calling this operation on a union that uses the entire range of discriminator values for explicit case labels returns false.
        Specified by:
        has_no_active_member in interface DynUnionOperations

      • discriminator_kind

        public TCKind discriminator_kind()
        Returns the TCKind value of the discriminators TypeCode.
        Specified by:
        discriminator_kind in interface DynUnionOperations

      • member_kind

        public TCKind member_kind()
                   throws InvalidValue
        Returns the TCKind value of the currently active members TypeCode.
        Specified by:
        member_kind in interface DynUnionOperations
        Throws:
        InvalidValue - if the union does not have a currently active member

      • member

        public DynAny member()
              throws InvalidValue
        Returns the currently active member. Note that the returned reference remains valid only for as long as the currently active member does not change. Using the returned reference beyond the life time of the currently active member raises OBJECT_NOT_EXIST.
        Specified by:
        member in interface DynUnionOperations
        Throws:
        InvalidValue - if the union has no active member

      • member_name

        public String member_name()
                   throws InvalidValue
        Returns the name of the currently active member. If the unions TypeCode does not contain a member name for the currently active member, the operation returns an empty string.
        Specified by:
        member_name in interface DynUnionOperations
        Throws:
        InvalidValue - if the union has no active member

      • type

        public TypeCode type()
        Returns the TypeCode associated with this DynAny object. A DynAny object is created with a TypeCode value assigned to it. This TypeCode value determines the type of the value handled through the DynAny object. Note that the TypeCode associated with a DynAny object is initialized at the time the DynAny is created and cannot be changed during lifetime of the DynAny object.
        Specified by:
        type in interface DynAnyOperations
        Returns:
        The TypeCode associated with this DynAny object

      • assign

        public void assign(DynAny dyn_any)
            throws TypeMismatch
        Initializes the value associated with a DynAny object with the value associated with another DynAny object. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        Specified by:
        assign in interface DynAnyOperations
        Parameters:
        dyn_any -
        Throws:
        TypeMismatch - if the type of the passed DynAny is not equivalent to the type of target DynAny

      • from_any

        public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
        Initializes the value associated with a DynAny object with the value contained in an any. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        Specified by:
        from_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the type of the passed Any is not equivalent to the type of target DynAny
        InvalidValue - if the passed Any does not contain a legal value (such as a null string)

      • to_any

        public Any to_any()
        Creates an any value from a DynAny object. A copy of the TypeCode associated with the DynAny object is assigned to the resulting any. The value associated with the DynAny object is copied into the any.
        Specified by:
        to_any in interface DynAnyOperations
        Returns:
        a new Any object with the same value and TypeCode

      • equal

        public boolean equal(DynAny dyn_any)
        Compares two DynAny values for equality. Two DynAny values are equal if their TypeCodes are equivalent and, recursively, all component DynAnys have equal values. The current position of the two DynAnys being compared has no effect on the result of equal.
        Specified by:
        equal in interface DynAnyOperations
        Returns:
        true of the DynAnys are equal, false otherwise

      • destroy

        public void destroy()
        Destroys a DynAny object. This operation frees any resources used to represent the data value associated with a DynAny object. It must be invoked on references obtained from one of the creation operations on the ORB interface or on a reference returned by DynAny.copy() to avoid resource leaks. Invoking destroy on component DynAny objects (for example, on objects returned by the current_component operation) does nothing. Destruction of a DynAny object implies destruction of all DynAny objects obtained from it. That is, references to components of a destroyed DynAny become invalid. Invocations on such references raise OBJECT_NOT_EXIST. It is possible to manipulate a component of a DynAny beyond the life time of the DynAny from which the component was obtained by making a copy of the component with the copy operation before destroying the DynAny from which the component was obtained.
        Specified by:
        destroy in interface DynAnyOperations

      • copy

        public DynAny copy()
        Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked. The operation is polymorphic, that is, invoking it on one of the types derived from DynAny, such as DynStruct, creates the derived type but returns its reference as the DynAny base type.
        Specified by:
        copy in interface DynAnyOperations
        Returns:
        a deep copy of the DynAny object

      • insert_boolean

        public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a boolean value into the DynAny.
        Specified by:
        insert_boolean in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_octet

        public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a byte value into the DynAny. The IDL octet data type is mapped to the Java byte data type.
        Specified by:
        insert_octet in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_char

        public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts a char value into the DynAny.
        Specified by:
        insert_char in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_short

        public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a short value into the DynAny.
        Specified by:
        insert_short in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ushort

        public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a short value into the DynAny. The IDL ushort data type is mapped to the Java short data type.
        Specified by:
        insert_ushort in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_long

        public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts an integer value into the DynAny. The IDL long data type is mapped to the Java int data type.
        Specified by:
        insert_long in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulong

        public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts an integer value into the DynAny. The IDL ulong data type is mapped to the Java int data type.
        Specified by:
        insert_ulong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_float

        public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a float value into the DynAny.
        Specified by:
        insert_float in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_double

        public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a double value into the DynAny.
        Specified by:
        insert_double in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_string

        public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        Specified by:
        insert_string in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_reference

        public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a reference to a CORBA object into the DynAny.
        Specified by:
        insert_reference in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_typecode

        public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a TypeCode object into the DynAny.
        Specified by:
        insert_typecode in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_longlong

        public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a long value into the DynAny. The IDL long long data type is mapped to the Java long data type.
        Specified by:
        insert_longlong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulonglong

        public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a long value into the DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        Specified by:
        insert_ulonglong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wchar

        public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a char value into the DynAny. The IDL wchar data type is mapped to the Java char data type.
        Specified by:
        insert_wchar in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wstring

        public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        Specified by:
        insert_wstring in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch

      • insert_any

        public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
        Inserts an Any value into the Any represented by this DynAny.
        Specified by:
        insert_any in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_dyn_any

        public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
        Specified by:
        insert_dyn_any in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_val

        public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
        Inserts a reference to a Serializable object into this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        Specified by:
        insert_val in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • get_boolean

        public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
        Extracts the boolean value from this DynAny.
        Specified by:
        get_boolean in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_octet

        public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
        Extracts the byte value from this DynAny. The IDL octet data type is mapped to the Java byte data type.
        Specified by:
        get_octet in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_char

        public char get_char()
              throws TypeMismatch,
                     InvalidValue
        Extracts the char value from this DynAny.
        Specified by:
        get_char in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_short

        public short get_short()
                throws TypeMismatch,
                       InvalidValue
        Extracts the short value from this DynAny.
        Specified by:
        get_short in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ushort

        public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
        Extracts the short value from this DynAny. The IDL ushort data type is mapped to the Java short data type.
        Specified by:
        get_ushort in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_long

        public int get_long()
             throws TypeMismatch,
                    InvalidValue
        Extracts the integer value from this DynAny. The IDL long data type is mapped to the Java int data type.
        Specified by:
        get_long in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulong

        public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
        Extracts the integer value from this DynAny. The IDL ulong data type is mapped to the Java int data type.
        Specified by:
        get_ulong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_float

        public float get_float()
                throws TypeMismatch,
                       InvalidValue
        Extracts the float value from this DynAny.
        Specified by:
        get_float in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_double

        public double get_double()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the double value from this DynAny.
        Specified by:
        get_double in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_string

        public String get_string()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        Specified by:
        get_string in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_reference

        public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
        Extracts the reference to a CORBA Object from this DynAny.
        Specified by:
        get_reference in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_typecode

        public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
        Extracts the TypeCode object from this DynAny.
        Specified by:
        get_typecode in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_longlong

        public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the long value from this DynAny. The IDL long long data type is mapped to the Java long data type.
        Specified by:
        get_longlong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulonglong

        public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the long value from this DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        Specified by:
        get_ulonglong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wchar

        public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
        Extracts the long value from this DynAny. The IDL wchar data type is mapped to the Java char data type.
        Specified by:
        get_wchar in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wstring

        public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        Specified by:
        get_wstring in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue

      • get_any

        public Any get_any()
            throws TypeMismatch,
                   InvalidValue
        Extracts an Any value contained in the Any represented by this DynAny.
        Specified by:
        get_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_dyn_any

        public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
        Specified by:
        get_dyn_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_val

        public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
        Extracts a Serializable object from this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        Specified by:
        get_val in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • seek

        public boolean seek(int index)
        Sets the current position to index. The current position is indexed 0 to n-1, that is, index zero corresponds to the first component. The operation returns true if the resulting current position indicates a component of the DynAny and false if index indicates a position that does not correspond to a component. Calling seek with a negative index is legal. It sets the current position to -1 to indicate no component and returns false. Passing a non-negative index value for a DynAny that does not have a component at the corresponding position sets the current position to -1 and returns false.
        Specified by:
        seek in interface DynAnyOperations

      • rewind

        public void rewind()
        Is equivalent to seek(0).
        Specified by:
        rewind in interface DynAnyOperations

      • next

        public boolean next()
        Advances the current position to the next component. The operation returns true while the resulting current position indicates a component, false otherwise. A false return value leaves the current position at -1. Invoking next on a DynAny without components leaves the current position at -1 and returns false.
        Specified by:
        next in interface DynAnyOperations

      • component_count

        public int component_count()
        Returns the number of components of a DynAny. For a DynAny without components, it returns zero. The operation only counts the components at the top level. For example, if component_count is invoked on a DynStruct with a single member, the return value is 1, irrespective of the type of the member.
        • For sequences, the operation returns the current number of elements.
        • For structures, exceptions, and value types, the operation returns the number of members.
        • For arrays, the operation returns the number of elements.
        • For unions, the operation returns 2 if the discriminator indicates that a named member is active, otherwise, it returns 1.
        • For DynFixed and DynEnum, the operation returns zero.
        Specified by:
        component_count in interface DynAnyOperations

      • current_component

        public DynAny current_component()
                         throws TypeMismatch
        Returns the DynAny for the component at the current position. It does not advance the current position, so repeated calls to current_component without an intervening call to rewind, next, or seek return the same component. The returned DynAny object reference can be used to get/set the value of the current component. If the current component represents a complex type, the returned reference can be narrowed based on the TypeCode to get the interface corresponding to the to the complex type. Calling current_component on a DynAny that cannot have components, such as a DynEnum or an empty exception, raises TypeMismatch. Calling current_component on a DynAny whose current position is -1 returns a nil reference. The iteration operations, together with current_component, can be used to dynamically compose an any value. After creating a dynamic any, such as a DynStruct, current_component and next can be used to initialize all the components of the value. Once the dynamic value is completely initialized, to_any creates the corresponding any value.
        Specified by:
        current_component in interface DynAnyOperations
        Throws:
        TypeMismatch - If called on a DynAny that cannot have components, such as a DynEnum or an empty exception

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        Specified by:
        _ids in class ObjectImpl
        Returns:
        the array of all repository identifiers supported by this ObjectImpl instance
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


_DynValueStub (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.DynamicAny

Class _DynValueStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.DynamicAny._DynValueStub
  • All Implemented Interfaces:
    Serializable, Object, IDLEntity, DynAny, DynAnyOperations, DynValue, DynValueCommon, DynValueCommonOperations, DynValueOperations

    public class _DynValueStub
extends ObjectImpl
implements DynValue
    DynValue objects support the manipulation of IDL non-boxed value types. The DynValue interface can represent both null and non-null value types. For a DynValue representing a non-null value type, the DynValue's components comprise the public and private members of the value type, including those inherited from concrete base value types, in the order of definition. A DynValue representing a null value type has no components and a current position of -1.

    Warning: Indiscriminantly changing the contents of private value type members can cause the value type implementation to break by violating internal constraints. Access to private members is provided to support such activities as ORB bridging and debugging and should not be used to arbitrarily violate the encapsulation of the value type.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static Class | _opsClass

    • Constructor Summary

      Constructors
      Constructor and Description
      _DynValueStub()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void assign(DynAny dyn_any)
      Initializes the value associated with a DynAny object with the value associated with another DynAny object.
      int component_count()
      Returns the number of components of a DynAny.
      DynAny copy()
      Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
      DynAny current_component()
      Returns the DynAny for the component at the current position.
      TCKind current_member_kind()
      Returns the TCKind associated with the member at the current position.
      String current_member_name()
      Returns the name of the member at the current position.
      void destroy()
      Destroys a DynAny object.
      boolean equal(DynAny dyn_any)
      Compares two DynAny values for equality.
      void from_any(Any value)
      Initializes the value associated with a DynAny object with the value contained in an any.
      Any get_any()
      Extracts an Any value contained in the Any represented by this DynAny.
      boolean get_boolean()
      Extracts the boolean value from this DynAny.
      char get_char()
      Extracts the char value from this DynAny.
      double get_double()
      Extracts the double value from this DynAny.
      DynAny get_dyn_any()
      Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
      float get_float()
      Extracts the float value from this DynAny.
      int get_long()
      Extracts the integer value from this DynAny.
      long get_longlong()
      Extracts the long value from this DynAny.
      NameDynAnyPair[] get_members_as_dyn_any()
      Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the value type.
      NameValuePair[] get_members()
      Returns a sequence of NameValuePairs describing the name and the value of each member in the value type.
      byte get_octet()
      Extracts the byte value from this DynAny.
      Object get_reference()
      Extracts the reference to a CORBA Object from this DynAny.
      short get_short()
      Extracts the short value from this DynAny.
      String get_string()
      Extracts the string value from this DynAny.
      TypeCode get_typecode()
      Extracts the TypeCode object from this DynAny.
      int get_ulong()
      Extracts the integer value from this DynAny.
      long get_ulonglong()
      Extracts the long value from this DynAny.
      short get_ushort()
      Extracts the short value from this DynAny.
      Serializable get_val()
      Extracts a Serializable object from this DynAny.
      char get_wchar()
      Extracts the long value from this DynAny.
      String get_wstring()
      Extracts the string value from this DynAny.
      void insert_any(Any value)
      Inserts an Any value into the Any represented by this DynAny.
      void insert_boolean(boolean value)
      Inserts a boolean value into the DynAny.
      void insert_char(char value)
      Inserts a char value into the DynAny.
      void insert_double(double value)
      Inserts a double value into the DynAny.
      void insert_dyn_any(DynAny value)
      Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
      void insert_float(float value)
      Inserts a float value into the DynAny.
      void insert_long(int value)
      Inserts an integer value into the DynAny.
      void insert_longlong(long value)
      Inserts a long value into the DynAny.
      void insert_octet(byte value)
      Inserts a byte value into the DynAny.
      void insert_reference(Object value)
      Inserts a reference to a CORBA object into the DynAny.
      void insert_short(short value)
      Inserts a short value into the DynAny.
      void insert_string(String value)
      Inserts a string value into the DynAny.
      void insert_typecode(TypeCode value)
      Inserts a TypeCode object into the DynAny.
      void insert_ulong(int value)
      Inserts an integer value into the DynAny.
      void insert_ulonglong(long value)
      Inserts a long value into the DynAny.
      void insert_ushort(short value)
      Inserts a short value into the DynAny.
      void insert_val(Serializable value)
      Inserts a reference to a Serializable object into this DynAny.
      void insert_wchar(char value)
      Inserts a char value into the DynAny.
      void insert_wstring(String value)
      Inserts a string value into the DynAny.
      boolean is_null()
      Returns true if the DynValueCommon represents a null value type.
      boolean next()
      Advances the current position to the next component.
      void rewind()
      Is equivalent to seek(0).
      boolean seek(int index)
      Sets the current position to index.
      void set_members_as_dyn_any(NameDynAnyPair[] value)
      Initializes the value type's members from a sequence of NameDynAnyPairs.
      void set_members(NameValuePair[] value)
      Initializes the value type's members from a sequence of NameValuePairs.
      void set_to_null()
      Changes the representation of a DynValueCommon to a null value type.
      void set_to_value()
      Replaces a null value type with a newly constructed value.
      Any to_any()
      Creates an any value from a DynAny object.
      TypeCode type()
      Returns the TypeCode associated with this DynAny object.

      • Methods inherited from class org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • Field Detail

      • _opsClass

        public static final Class _opsClass

    • Constructor Detail

      • _DynValueStub

        public _DynValueStub()

    • Method Detail

      • current_member_name

        public String current_member_name()
                           throws TypeMismatch,
                                  InvalidValue
        Returns the name of the member at the current position. This operation may return an empty string since the TypeCode of the value being manipulated may not contain the names of members.
        Specified by:
        current_member_name in interface DynValueOperations
        Throws:
        TypeMismatch - if the DynValue represents a null value type.
        InvalidValue - if the current position does not indicate a member

      • current_member_kind

        public TCKind current_member_kind()
                           throws TypeMismatch,
                                  InvalidValue
        Returns the TCKind associated with the member at the current position.
        Specified by:
        current_member_kind in interface DynValueOperations
        Throws:
        TypeMismatch - if the DynValue represents a null value type.
        InvalidValue - if the current position does not indicate a member

      • get_members

        public NameValuePair[] get_members()
                            throws InvalidValue
        Returns a sequence of NameValuePairs describing the name and the value of each member in the value type. The sequence contains members in the same order as the declaration order of members as indicated by the DynValue's TypeCode. The current position is not affected. The member names in the returned sequence will be empty strings if the DynValue's TypeCode does not contain member names.
        Specified by:
        get_members in interface DynValueOperations
        Throws:
        InvalidValue - if this object represents a null value type

      • set_members

        public void set_members(NameValuePair[] value)
                 throws TypeMismatch,
                        InvalidValue
        Initializes the value type's members from a sequence of NameValuePairs. The operation sets the current position to zero if the passed sequences has non-zero length. Otherwise, if an empty sequence is passed, the current position is set to -1. A null value type can be initialized to a non-null value type using this method.

        Members must appear in the NameValuePairs in the order in which they appear in the IDL specification of the value type as indicated by the DynValue's TypeCode or they must be empty strings. The operation makes no attempt to assign member values based on member names.

        Specified by:
        set_members in interface DynValueOperations
        Throws:
        TypeMismatch - if the member names supplied in the passed sequence do not match the corresponding member name in the DynValue's TypeCode and they are not empty strings
        InvalidValue - if the passed sequence has a number of elements that disagrees with the number of members as indicated by the DynValue's TypeCode

      • get_members_as_dyn_any

        public NameDynAnyPair[] get_members_as_dyn_any()
                                        throws InvalidValue
        Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the value type. The sequence contains members in the same order as the declaration order of members as indicated by the DynValue's TypeCode. The current position is not affected. The member names in the returned sequence will be empty strings if the DynValue's TypeCode does not contain member names.
        Specified by:
        get_members_as_dyn_any in interface DynValueOperations
        Throws:
        InvalidValue - if this object represents a null value type

      • set_members_as_dyn_any

        public void set_members_as_dyn_any(NameDynAnyPair[] value)
                            throws TypeMismatch,
                                   InvalidValue
        Initializes the value type's members from a sequence of NameDynAnyPairs. The operation sets the current position to zero if the passed sequences has non-zero length. Otherwise, if an empty sequence is passed, the current position is set to -1. A null value type can be initialized to a non-null value type using this method.

        Members must appear in the NameDynAnyPairs in the order in which they appear in the IDL specification of the value type as indicated by the DynValue's TypeCode or they must be empty strings. The operation makes no attempt to assign member values based on member names.

        Specified by:
        set_members_as_dyn_any in interface DynValueOperations
        Throws:
        TypeMismatch - if the member names supplied in the passed sequence do not match the corresponding member name in the DynValue's TypeCode and they are not empty strings
        InvalidValue - if the passed sequence has a number of elements that disagrees with the number of members as indicated by the DynValue's TypeCode

      • is_null

        public boolean is_null()
        Returns true if the DynValueCommon represents a null value type.
        Specified by:
        is_null in interface DynValueCommonOperations

      • set_to_null

        public void set_to_null()
        Changes the representation of a DynValueCommon to a null value type.
        Specified by:
        set_to_null in interface DynValueCommonOperations

      • set_to_value

        public void set_to_value()
        Replaces a null value type with a newly constructed value. Its components are initialized to default values as in DynAnyFactory.create_dyn_any_from_type_code. If the DynValueCommon represents a non-null value type, then this operation has no effect.
        Specified by:
        set_to_value in interface DynValueCommonOperations

      • type

        public TypeCode type()
        Returns the TypeCode associated with this DynAny object. A DynAny object is created with a TypeCode value assigned to it. This TypeCode value determines the type of the value handled through the DynAny object. Note that the TypeCode associated with a DynAny object is initialized at the time the DynAny is created and cannot be changed during lifetime of the DynAny object.
        Specified by:
        type in interface DynAnyOperations
        Returns:
        The TypeCode associated with this DynAny object

      • assign

        public void assign(DynAny dyn_any)
            throws TypeMismatch
        Initializes the value associated with a DynAny object with the value associated with another DynAny object. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        Specified by:
        assign in interface DynAnyOperations
        Parameters:
        dyn_any -
        Throws:
        TypeMismatch - if the type of the passed DynAny is not equivalent to the type of target DynAny

      • from_any

        public void from_any(Any value)
              throws TypeMismatch,
                     InvalidValue
        Initializes the value associated with a DynAny object with the value contained in an any. The current position of the target DynAny is set to zero for values that have components and to -1 for values that do not have components.
        Specified by:
        from_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the type of the passed Any is not equivalent to the type of target DynAny
        InvalidValue - if the passed Any does not contain a legal value (such as a null string)

      • to_any

        public Any to_any()
        Creates an any value from a DynAny object. A copy of the TypeCode associated with the DynAny object is assigned to the resulting any. The value associated with the DynAny object is copied into the any.
        Specified by:
        to_any in interface DynAnyOperations
        Returns:
        a new Any object with the same value and TypeCode

      • equal

        public boolean equal(DynAny dyn_any)
        Compares two DynAny values for equality. Two DynAny values are equal if their TypeCodes are equivalent and, recursively, all component DynAnys have equal values. The current position of the two DynAnys being compared has no effect on the result of equal.
        Specified by:
        equal in interface DynAnyOperations
        Returns:
        true of the DynAnys are equal, false otherwise

      • destroy

        public void destroy()
        Destroys a DynAny object. This operation frees any resources used to represent the data value associated with a DynAny object. It must be invoked on references obtained from one of the creation operations on the ORB interface or on a reference returned by DynAny.copy() to avoid resource leaks. Invoking destroy on component DynAny objects (for example, on objects returned by the current_component operation) does nothing. Destruction of a DynAny object implies destruction of all DynAny objects obtained from it. That is, references to components of a destroyed DynAny become invalid. Invocations on such references raise OBJECT_NOT_EXIST. It is possible to manipulate a component of a DynAny beyond the life time of the DynAny from which the component was obtained by making a copy of the component with the copy operation before destroying the DynAny from which the component was obtained.
        Specified by:
        destroy in interface DynAnyOperations

      • copy

        public DynAny copy()
        Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked. The operation is polymorphic, that is, invoking it on one of the types derived from DynAny, such as DynStruct, creates the derived type but returns its reference as the DynAny base type.
        Specified by:
        copy in interface DynAnyOperations
        Returns:
        a deep copy of the DynAny object

      • insert_boolean

        public void insert_boolean(boolean value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a boolean value into the DynAny.
        Specified by:
        insert_boolean in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_octet

        public void insert_octet(byte value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a byte value into the DynAny. The IDL octet data type is mapped to the Java byte data type.
        Specified by:
        insert_octet in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_char

        public void insert_char(char value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts a char value into the DynAny.
        Specified by:
        insert_char in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_short

        public void insert_short(short value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a short value into the DynAny.
        Specified by:
        insert_short in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ushort

        public void insert_ushort(short value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a short value into the DynAny. The IDL ushort data type is mapped to the Java short data type.
        Specified by:
        insert_ushort in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_long

        public void insert_long(int value)
                 throws TypeMismatch,
                        InvalidValue
        Inserts an integer value into the DynAny. The IDL long data type is mapped to the Java int data type.
        Specified by:
        insert_long in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulong

        public void insert_ulong(int value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts an integer value into the DynAny. The IDL ulong data type is mapped to the Java int data type.
        Specified by:
        insert_ulong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_float

        public void insert_float(float value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a float value into the DynAny.
        Specified by:
        insert_float in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_double

        public void insert_double(double value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a double value into the DynAny.
        Specified by:
        insert_double in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_string

        public void insert_string(String value)
                   throws TypeMismatch,
                          InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        Specified by:
        insert_string in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_reference

        public void insert_reference(Object value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a reference to a CORBA object into the DynAny.
        Specified by:
        insert_reference in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_typecode

        public void insert_typecode(TypeCode value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a TypeCode object into the DynAny.
        Specified by:
        insert_typecode in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_longlong

        public void insert_longlong(long value)
                     throws TypeMismatch,
                            InvalidValue
        Inserts a long value into the DynAny. The IDL long long data type is mapped to the Java long data type.
        Specified by:
        insert_longlong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_ulonglong

        public void insert_ulonglong(long value)
                      throws TypeMismatch,
                             InvalidValue
        Inserts a long value into the DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        Specified by:
        insert_ulonglong in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wchar

        public void insert_wchar(char value)
                  throws TypeMismatch,
                         InvalidValue
        Inserts a char value into the DynAny. The IDL wchar data type is mapped to the Java char data type.
        Specified by:
        insert_wchar in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_wstring

        public void insert_wstring(String value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts a string value into the DynAny. Both bounded and unbounded strings are inserted using this method.
        Specified by:
        insert_wstring in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        InvalidValue - if the string inserted is longer than the bound of a bounded string
        TypeMismatch

      • insert_any

        public void insert_any(Any value)
                throws TypeMismatch,
                       InvalidValue
        Inserts an Any value into the Any represented by this DynAny.
        Specified by:
        insert_any in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_dyn_any

        public void insert_dyn_any(DynAny value)
                    throws TypeMismatch,
                           InvalidValue
        Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
        Specified by:
        insert_dyn_any in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • insert_val

        public void insert_val(Serializable value)
                throws TypeMismatch,
                       InvalidValue
        Inserts a reference to a Serializable object into this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        Specified by:
        insert_val in interface DynAnyOperations
        Throws:
        InvalidValue - if this DynAny has components but has a current position of -1
        TypeMismatch - if called on a DynAny whose current component itself has components

      • get_boolean

        public boolean get_boolean()
                    throws TypeMismatch,
                           InvalidValue
        Extracts the boolean value from this DynAny.
        Specified by:
        get_boolean in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_octet

        public byte get_octet()
               throws TypeMismatch,
                      InvalidValue
        Extracts the byte value from this DynAny. The IDL octet data type is mapped to the Java byte data type.
        Specified by:
        get_octet in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_char

        public char get_char()
              throws TypeMismatch,
                     InvalidValue
        Extracts the char value from this DynAny.
        Specified by:
        get_char in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_short

        public short get_short()
                throws TypeMismatch,
                       InvalidValue
        Extracts the short value from this DynAny.
        Specified by:
        get_short in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ushort

        public short get_ushort()
                 throws TypeMismatch,
                        InvalidValue
        Extracts the short value from this DynAny. The IDL ushort data type is mapped to the Java short data type.
        Specified by:
        get_ushort in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_long

        public int get_long()
             throws TypeMismatch,
                    InvalidValue
        Extracts the integer value from this DynAny. The IDL long data type is mapped to the Java int data type.
        Specified by:
        get_long in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulong

        public int get_ulong()
              throws TypeMismatch,
                     InvalidValue
        Extracts the integer value from this DynAny. The IDL ulong data type is mapped to the Java int data type.
        Specified by:
        get_ulong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_float

        public float get_float()
                throws TypeMismatch,
                       InvalidValue
        Extracts the float value from this DynAny.
        Specified by:
        get_float in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_double

        public double get_double()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the double value from this DynAny.
        Specified by:
        get_double in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_string

        public String get_string()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        Specified by:
        get_string in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_reference

        public Object get_reference()
                     throws TypeMismatch,
                            InvalidValue
        Extracts the reference to a CORBA Object from this DynAny.
        Specified by:
        get_reference in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_typecode

        public TypeCode get_typecode()
                      throws TypeMismatch,
                             InvalidValue
        Extracts the TypeCode object from this DynAny.
        Specified by:
        get_typecode in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_longlong

        public long get_longlong()
                  throws TypeMismatch,
                         InvalidValue
        Extracts the long value from this DynAny. The IDL long long data type is mapped to the Java long data type.
        Specified by:
        get_longlong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_ulonglong

        public long get_ulonglong()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the long value from this DynAny. The IDL unsigned long long data type is mapped to the Java long data type.
        Specified by:
        get_ulonglong in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wchar

        public char get_wchar()
               throws TypeMismatch,
                      InvalidValue
        Extracts the long value from this DynAny. The IDL wchar data type is mapped to the Java char data type.
        Specified by:
        get_wchar in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_wstring

        public String get_wstring()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the string value from this DynAny. Both bounded and unbounded strings are extracted using this method.
        Specified by:
        get_wstring in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue

      • get_any

        public Any get_any()
            throws TypeMismatch,
                   InvalidValue
        Extracts an Any value contained in the Any represented by this DynAny.
        Specified by:
        get_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_dyn_any

        public DynAny get_dyn_any()
                   throws TypeMismatch,
                          InvalidValue
        Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.
        Specified by:
        get_dyn_any in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • get_val

        public Serializable get_val()
                     throws TypeMismatch,
                            InvalidValue
        Extracts a Serializable object from this DynAny. The IDL ValueBase type is mapped to the Java Serializable type.
        Specified by:
        get_val in interface DynAnyOperations
        Throws:
        TypeMismatch - if the accessed component in the DynAny is of a type that is not equivalent to the requested type.
        TypeMismatch - if called on a DynAny whose current component itself has components
        InvalidValue - if this DynAny has components but has a current position of -1

      • seek

        public boolean seek(int index)
        Sets the current position to index. The current position is indexed 0 to n-1, that is, index zero corresponds to the first component. The operation returns true if the resulting current position indicates a component of the DynAny and false if index indicates a position that does not correspond to a component. Calling seek with a negative index is legal. It sets the current position to -1 to indicate no component and returns false. Passing a non-negative index value for a DynAny that does not have a component at the corresponding position sets the current position to -1 and returns false.
        Specified by:
        seek in interface DynAnyOperations

      • rewind

        public void rewind()
        Is equivalent to seek(0).
        Specified by:
        rewind in interface DynAnyOperations

      • next

        public boolean next()
        Advances the current position to the next component. The operation returns true while the resulting current position indicates a component, false otherwise. A false return value leaves the current position at -1. Invoking next on a DynAny without components leaves the current position at -1 and returns false.
        Specified by:
        next in interface DynAnyOperations

      • component_count

        public int component_count()
        Returns the number of components of a DynAny. For a DynAny without components, it returns zero. The operation only counts the components at the top level. For example, if component_count is invoked on a DynStruct with a single member, the return value is 1, irrespective of the type of the member.
        • For sequences, the operation returns the current number of elements.
        • For structures, exceptions, and value types, the operation returns the number of members.
        • For arrays, the operation returns the number of elements.
        • For unions, the operation returns 2 if the discriminator indicates that a named member is active, otherwise, it returns 1.
        • For DynFixed and DynEnum, the operation returns zero.
        Specified by:
        component_count in interface DynAnyOperations

      • current_component

        public DynAny current_component()
                         throws TypeMismatch
        Returns the DynAny for the component at the current position. It does not advance the current position, so repeated calls to current_component without an intervening call to rewind, next, or seek return the same component. The returned DynAny object reference can be used to get/set the value of the current component. If the current component represents a complex type, the returned reference can be narrowed based on the TypeCode to get the interface corresponding to the to the complex type. Calling current_component on a DynAny that cannot have components, such as a DynEnum or an empty exception, raises TypeMismatch. Calling current_component on a DynAny whose current position is -1 returns a nil reference. The iteration operations, together with current_component, can be used to dynamically compose an any value. After creating a dynamic any, such as a DynStruct, current_component and next can be used to initialize all the components of the value. Once the dynamic value is completely initialized, to_any creates the corresponding any value.
        Specified by:
        current_component in interface DynAnyOperations
        Throws:
        TypeMismatch - If called on a DynAny that cannot have components, such as a DynEnum or an empty exception

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        Specified by:
        _ids in class ObjectImpl
        Returns:
        the array of all repository identifiers supported by this ObjectImpl instance
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Interface org.omg.IOP.Codec (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.IOP.Codec

  • Packages that use Codec
    Package Description
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.

    • Uses of Codec in org.omg.IOP

      Methods in org.omg.IOP that return Codec
      Modifier and Type Method and Description
      Codec CodecFactoryOperations.create_codec(Encoding enc)
      Create a Codec of the given encoding.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.IOP.CodecFactory (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.IOP.CodecFactory

  • Packages that use CodecFactory
    Package Description
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of CodecFactory in org.omg.IOP

      Methods in org.omg.IOP that return CodecFactory
      Modifier and Type | Method and Description
      static CodecFactory | CodecFactoryHelper.extract(Any a)
      static CodecFactory | CodecFactoryHelper.narrow(Object obj)
      static CodecFactory | CodecFactoryHelper.read(InputStream istream)
      static CodecFactory | CodecFactoryHelper.unchecked_narrow(Object obj)
      Methods in org.omg.IOP with parameters of type CodecFactory
      Modifier and Type | Method and Description
      static void | CodecFactoryHelper.insert(Any a, CodecFactory that)
      static void | CodecFactoryHelper.write(OutputStream ostream, CodecFactory value)

    • Uses of CodecFactory in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor that return CodecFactory
      Modifier and Type Method and Description
      CodecFactory ORBInitInfoOperations.codec_factory()
      Returns the IOP.CodecFactory.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.IOP.CodecFactoryHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.CodecFactoryHelper

No usage of org.omg.IOP.CodecFactoryHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.IOP.CodecFactoryOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.IOP.CodecFactoryOperations

  • Packages that use CodecFactoryOperations
    Package Description
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.

    • Uses of CodecFactoryOperations in org.omg.IOP

      Subinterfaces of CodecFactoryOperations in org.omg.IOP
      Modifier and Type Interface and Description
      interface  CodecFactory
      Codecs are obtained from the CodecFactory.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.IOP.CodecOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.IOP.CodecOperations

  • Packages that use CodecOperations
    Package Description
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.

    • Uses of CodecOperations in org.omg.IOP

      Subinterfaces of CodecOperations in org.omg.IOP
      Modifier and Type Interface and Description
      interface  Codec
      The formats of IOR components and service context data used by ORB services are often defined as CDR encapsulations encoding instances of IDL defined data types.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.IOP.CodeSets (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.IOP.CodeSets

No usage of org.omg.IOP.CodeSets
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.IOP.ComponentIdHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.ComponentIdHelper

No usage of org.omg.IOP.ComponentIdHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.IOP.Encoding (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.Encoding

  • Packages that use Encoding
    Package Description
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.

    • Uses of Encoding in org.omg.IOP

      Methods in org.omg.IOP with parameters of type Encoding
      Modifier and Type Method and Description
      Codec CodecFactoryOperations.create_codec(Encoding enc)
      Create a Codec of the given encoding.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.IOP.ENCODING_CDR_ENCAPS (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.IOP.ENCODING_CDR_ENCAPS

No usage of org.omg.IOP.ENCODING_CDR_ENCAPS
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.IOP.ExceptionDetailMessage (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.IOP.ExceptionDetailMessage

No usage of org.omg.IOP.ExceptionDetailMessage
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.IOP.IOR (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.IOR

  • Packages that use IOR
    Package Description
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.

    • Uses of IOR in org.omg.IOP

      Fields in org.omg.IOP declared as IOR
      Modifier and Type | Field and Description
      IOR | IORHolder.value
      Methods in org.omg.IOP that return IOR
      Modifier and Type | Method and Description
      static IOR | IORHelper.extract(Any a)
      static IOR | IORHelper.read(InputStream istream)
      Methods in org.omg.IOP with parameters of type IOR
      Modifier and Type | Method and Description
      static void | IORHelper.insert(Any a, IOR that)
      static void | IORHelper.write(OutputStream ostream, IOR value)
      Constructors in org.omg.IOP with parameters of type IOR
      Constructor and Description
      IORHolder(IOR initialValue)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.IOP.IORHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.IORHelper

No usage of org.omg.IOP.IORHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.IOP.IORHolder (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.IORHolder

No usage of org.omg.IOP.IORHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.IOP.MultipleComponentProfileHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.MultipleComponentProfileHelper

No usage of org.omg.IOP.MultipleComponentProfileHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.IOP.MultipleComponentProfileHolder (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.MultipleComponentProfileHolder

No usage of org.omg.IOP.MultipleComponentProfileHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.IOP.ProfileIdHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.ProfileIdHelper

No usage of org.omg.IOP.ProfileIdHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.IOP.RMICustomMaxStreamFormat (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.IOP.RMICustomMaxStreamFormat

No usage of org.omg.IOP.RMICustomMaxStreamFormat
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.IOP.ServiceContext (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.ServiceContext

  • Packages that use ServiceContext
    Package Description
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ServiceContext in org.omg.IOP

      Fields in org.omg.IOP declared as ServiceContext
      Modifier and Type | Field and Description
      ServiceContext | ServiceContextHolder.value
      ServiceContext[] | ServiceContextListHolder.value
      Methods in org.omg.IOP that return ServiceContext
      Modifier and Type | Method and Description
      static ServiceContext[] | ServiceContextListHelper.extract(Any a)
      static ServiceContext | ServiceContextHelper.extract(Any a)
      static ServiceContext[] | ServiceContextListHelper.read(InputStream istream)
      static ServiceContext | ServiceContextHelper.read(InputStream istream)
      Methods in org.omg.IOP with parameters of type ServiceContext
      Modifier and Type | Method and Description
      static void | ServiceContextHelper.insert(Any a, ServiceContext that)
      static void | ServiceContextListHelper.insert(Any a, ServiceContext[] that)
      static void | ServiceContextHelper.write(OutputStream ostream, ServiceContext value)
      static void | ServiceContextListHelper.write(OutputStream ostream, ServiceContext[] value)
      Constructors in org.omg.IOP with parameters of type ServiceContext
      Constructor and Description
      ServiceContextHolder(ServiceContext initialValue)
      ServiceContextListHolder(ServiceContext[] initialValue)

    • Uses of ServiceContext in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor that return ServiceContext
      Modifier and Type Method and Description
      ServiceContext RequestInfoOperations.get_reply_service_context(int id)
      Returns a copy of the service context with the given ID that is associated with the reply.
      ServiceContext RequestInfoOperations.get_request_service_context(int id)
      Returns a copy of the service context with the given ID that is associated with the request.
      Methods in org.omg.PortableInterceptor with parameters of type ServiceContext
      Modifier and Type Method and Description
      void ServerRequestInfoOperations.add_reply_service_context(ServiceContext service_context, boolean replace)
      Allows Interceptors to add service contexts to the request.
      void ClientRequestInfoOperations.add_request_service_context(ServiceContext service_context, boolean replace)
      Allows Interceptors to add service contexts to the request.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.IOP.ServiceContextHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.ServiceContextHelper

No usage of org.omg.IOP.ServiceContextHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.IOP.ServiceContextHolder (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.ServiceContextHolder

No usage of org.omg.IOP.ServiceContextHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.IOP.ServiceContextListHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.ServiceContextListHelper

No usage of org.omg.IOP.ServiceContextListHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.IOP.ServiceContextListHolder (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.ServiceContextListHolder

No usage of org.omg.IOP.ServiceContextListHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.IOP.ServiceIdHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.ServiceIdHelper

No usage of org.omg.IOP.ServiceIdHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.IOP.TaggedComponent (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.TaggedComponent

  • Packages that use TaggedComponent
    Package Description
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of TaggedComponent in org.omg.IOP

      Fields in org.omg.IOP declared as TaggedComponent
      Modifier and Type | Field and Description
      TaggedComponent | TaggedComponentHolder.value
      TaggedComponent[] | MultipleComponentProfileHolder.value
      Methods in org.omg.IOP that return TaggedComponent
      Modifier and Type | Method and Description
      static TaggedComponent | TaggedComponentHelper.extract(Any a)
      static TaggedComponent[] | MultipleComponentProfileHelper.extract(Any a)
      static TaggedComponent | TaggedComponentHelper.read(InputStream istream)
      static TaggedComponent[] | MultipleComponentProfileHelper.read(InputStream istream)
      Methods in org.omg.IOP with parameters of type TaggedComponent
      Modifier and Type | Method and Description
      static void | TaggedComponentHelper.insert(Any a, TaggedComponent that)
      static void | MultipleComponentProfileHelper.insert(Any a, TaggedComponent[] that)
      static void | TaggedComponentHelper.write(OutputStream ostream, TaggedComponent value)
      static void | MultipleComponentProfileHelper.write(OutputStream ostream, TaggedComponent[] value)
      Constructors in org.omg.IOP with parameters of type TaggedComponent
      Constructor and Description
      MultipleComponentProfileHolder(TaggedComponent[] initialValue)
      TaggedComponentHolder(TaggedComponent initialValue)

    • Uses of TaggedComponent in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor that return TaggedComponent
      Modifier and Type Method and Description
      TaggedComponent ClientRequestInfoOperations.get_effective_component(int id)
      Returns the IOP.TaggedComponent with the given ID from the profile selected for this request.
      TaggedComponent[] ClientRequestInfoOperations.get_effective_components(int id)
      Returns an array of all tagged components with the given ID from the profile selected for this request.
      Methods in org.omg.PortableInterceptor with parameters of type TaggedComponent
      Modifier and Type Method and Description
      void IORInfoOperations.add_ior_component_to_profile(TaggedComponent tagged_component, int profile_id)
      A portable ORB service implementation calls add_ior_component_to_profile from its implementation of establish_components to add a tagged component to the set which will be included when constructing IORs.
      void IORInfoOperations.add_ior_component(TaggedComponent tagged_component)
      A portable ORB service implementation calls add_ior_component from its implementation of establish_components to add a tagged component to the set which will be included when constructing IORs.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.IOP.TaggedComponentHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.TaggedComponentHelper

No usage of org.omg.IOP.TaggedComponentHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.IOP.TaggedComponentHolder (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.TaggedComponentHolder

No usage of org.omg.IOP.TaggedComponentHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.IOP.TaggedProfile (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.TaggedProfile

  • Packages that use TaggedProfile
    Package Description
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of TaggedProfile in org.omg.IOP

      Fields in org.omg.IOP declared as TaggedProfile
      Modifier and Type | Field and Description
      TaggedProfile[] IOR.profiles
      An array of tagged profiles associated with this object reference.
      TaggedProfile | TaggedProfileHolder.value
      Methods in org.omg.IOP that return TaggedProfile
      Modifier and Type | Method and Description
      static TaggedProfile | TaggedProfileHelper.extract(Any a)
      static TaggedProfile | TaggedProfileHelper.read(InputStream istream)
      Methods in org.omg.IOP with parameters of type TaggedProfile
      Modifier and Type | Method and Description
      static void | TaggedProfileHelper.insert(Any a, TaggedProfile that)
      static void | TaggedProfileHelper.write(OutputStream ostream, TaggedProfile value)
      Constructors in org.omg.IOP with parameters of type TaggedProfile
      Constructor and Description
      IOR(String _type_id, TaggedProfile[] _profiles)
      TaggedProfileHolder(TaggedProfile initialValue)

    • Uses of TaggedProfile in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor that return TaggedProfile
      Modifier and Type Method and Description
      TaggedProfile ClientRequestInfoOperations.effective_profile()
      Returns the profile that will be used to send the request.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.IOP.TaggedProfileHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.TaggedProfileHelper

No usage of org.omg.IOP.TaggedProfileHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.IOP.TaggedProfileHolder (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.TaggedProfileHolder

No usage of org.omg.IOP.TaggedProfileHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.IOP.TAG_ALTERNATE_IIOP_ADDRESS (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.IOP.TAG_ALTERNATE_IIOP_ADDRESS

No usage of org.omg.IOP.TAG_ALTERNATE_IIOP_ADDRESS
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.IOP.TAG_CODE_SETS (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.IOP.TAG_CODE_SETS

No usage of org.omg.IOP.TAG_CODE_SETS
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.IOP.TAG_INTERNET_IOP (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.IOP.TAG_INTERNET_IOP

No usage of org.omg.IOP.TAG_INTERNET_IOP
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.IOP.TAG_JAVA_CODEBASE (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.IOP.TAG_JAVA_CODEBASE

No usage of org.omg.IOP.TAG_JAVA_CODEBASE
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.IOP.TAG_MULTIPLE_COMPONENTS (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.IOP.TAG_MULTIPLE_COMPONENTS

No usage of org.omg.IOP.TAG_MULTIPLE_COMPONENTS
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.IOP.TAG_ORB_TYPE (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.IOP.TAG_ORB_TYPE

No usage of org.omg.IOP.TAG_ORB_TYPE
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.IOP.TAG_POLICIES (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.IOP.TAG_POLICIES

No usage of org.omg.IOP.TAG_POLICIES
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.IOP.TAG_RMI_CUSTOM_MAX_STREAM_FORMAT (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.IOP.TAG_RMI_CUSTOM_MAX_STREAM_FORMAT

No usage of org.omg.IOP.TAG_RMI_CUSTOM_MAX_STREAM_FORMAT
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.IOP.TransactionService (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.IOP.TransactionService

No usage of org.omg.IOP.TransactionService
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Codec (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Interface Codec

  • All Superinterfaces:
    CodecOperations, IDLEntity, Object, Serializable

    public interface Codec
extends CodecOperations, Object, IDLEntity
    The formats of IOR components and service context data used by ORB services are often defined as CDR encapsulations encoding instances of IDL defined data types. The Codec provides a mechanism to transfer these components between their IDL data types and their CDR encapsulation representations.

    A Codec is obtained from the CodecFactory. The CodecFactory is obtained through a call to ORB.resolve_initial_references( "CodecFactory" ).

    • Method Summary

      • Methods inherited from interface org.omg.IOP.CodecOperations

        decode_value, decode, encode_value, encode

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CodecFactory (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Interface CodecFactory

  • All Superinterfaces:
    CodecFactoryOperations, IDLEntity, Object, Serializable

    public interface CodecFactory
extends CodecFactoryOperations, Object, IDLEntity
    Codecs are obtained from the CodecFactory. The CodecFactory is obtained through a call to ORB.resolve_initial_references( "CodecFactory" ).

    • Method Summary

      • Methods inherited from interface org.omg.IOP.CodecFactoryOperations

        create_codec

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CodecFactoryHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class CodecFactoryHelper

  • java.lang.Object
    • org.omg.IOP.CodecFactoryHelper

  • public abstract class CodecFactoryHelper
extends Object
    Codecs are obtained from the CodecFactory. The CodecFactory is obtained through a call to ORB.resolve_initial_references( "CodecFactory" ).

    • Constructor Summary

      Constructors
      Constructor and Description
      CodecFactoryHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static CodecFactory | extract(Any a)
      static String | id()
      static void | insert(Any a, CodecFactory that)
      static CodecFactory | narrow(Object obj)
      static CodecFactory | read(InputStream istream)
      static TypeCode | type()
      static CodecFactory | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, CodecFactory value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • CodecFactoryHelper

        public CodecFactoryHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          CodecFactory that)

      • extract

        public static CodecFactory extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static CodecFactory read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         CodecFactory value)

      • narrow

        public static CodecFactory narrow(Object obj)

      • unchecked_narrow

        public static CodecFactory unchecked_narrow(Object obj)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CodecFactoryOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Interface CodecFactoryOperations

  • All Known Subinterfaces:
    CodecFactory

    public interface CodecFactoryOperations
    Codecs are obtained from the CodecFactory. The CodecFactory is obtained through a call to ORB.resolve_initial_references( "CodecFactory" ).

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Codec create_codec(Encoding enc)
      Create a Codec of the given encoding.

    • Method Detail

      • create_codec

        Codec create_codec(Encoding enc)
            throws UnknownEncoding
        Create a Codec of the given encoding.

        Parameters:
        enc - The encoding for which to create a Codec.
        Returns:
        A Codec obtained with the given encoding.
        Throws:
        UnknownEncoding - thrown if this factory cannot create a Codec of the given encoding.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Class org.omg.IOP.CodecFactoryPackage.UnknownEncoding (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.CodecFactoryPackage.UnknownEncoding

  • Packages that use UnknownEncoding
    Package Description
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.IOP.CodecFactoryPackage
    This package contains the exceptions specified in the IOP::CodeFactory interface (as part of the Portable Interceptors spec).

    • Uses of UnknownEncoding in org.omg.IOP

      Methods in org.omg.IOP that throw UnknownEncoding
      Modifier and Type Method and Description
      Codec CodecFactoryOperations.create_codec(Encoding enc)
      Create a Codec of the given encoding.

    • Uses of UnknownEncoding in org.omg.IOP.CodecFactoryPackage

      Methods in org.omg.IOP.CodecFactoryPackage that return UnknownEncoding
      Modifier and Type | Method and Description
      static UnknownEncoding | UnknownEncodingHelper.extract(Any a)
      static UnknownEncoding | UnknownEncodingHelper.read(InputStream istream)
      Methods in org.omg.IOP.CodecFactoryPackage with parameters of type UnknownEncoding
      Modifier and Type | Method and Description
      static void | UnknownEncodingHelper.insert(Any a, UnknownEncoding that)
      static void | UnknownEncodingHelper.write(OutputStream ostream, UnknownEncoding value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper

No usage of org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


org.omg.IOP.CodecFactoryPackage (Java Platform SE 8 )

org.omg.IOP.CodecFactoryPackage

Classes

  • UnknownEncodingHelper

Exceptions

  • UnknownEncoding


org.omg.IOP.CodecFactoryPackage (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.IOP.CodecFactoryPackage

This package contains the exceptions specified in the IOP::CodeFactory interface (as part of the Portable Interceptors spec).

See: Description

  • Class Summary
    Class Description
    UnknownEncodingHelper
    org/omg/IOP/CodecFactoryPackage/UnknownEncodingHelper.java .
  • Exception Summary
    Exception Description
    UnknownEncoding
    org/omg/IOP/CodecFactoryPackage/UnknownEncoding.java .

Package org.omg.IOP.CodecFactoryPackage Description

This package contains the exceptions specified in the IOP::CodeFactory interface (as part of the Portable Interceptors spec).

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java SE 6.

Since:
1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames


org.omg.IOP.CodecFactoryPackage Class Hierarchy (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.IOP.CodecFactoryPackage

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.IOP.CodecFactoryPackage.UnknownEncoding
    • org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package org.omg.IOP.CodecFactoryPackage (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.IOP.CodecFactoryPackage

  • Packages that use org.omg.IOP.CodecFactoryPackage
    Package Description
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.IOP.CodecFactoryPackage
    This package contains the exceptions specified in the IOP::CodeFactory interface (as part of the Portable Interceptors spec).
  • Classes in org.omg.IOP.CodecFactoryPackage used by org.omg.IOP
    Class and Description
    UnknownEncoding
    org/omg/IOP/CodecFactoryPackage/UnknownEncoding.java .
  • Classes in org.omg.IOP.CodecFactoryPackage used by org.omg.IOP.CodecFactoryPackage
    Class and Description
    UnknownEncoding
    org/omg/IOP/CodecFactoryPackage/UnknownEncoding.java .
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


UnknownEncoding (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP.CodecFactoryPackage

Class UnknownEncoding

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.IOP.CodecFactoryPackage.UnknownEncoding
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class UnknownEncoding
extends UserException
    org/omg/IOP/CodecFactoryPackage/UnknownEncoding.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      UnknownEncoding()
      UnknownEncoding(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • UnknownEncoding

        public UnknownEncoding()

      • UnknownEncoding

        public UnknownEncoding(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UnknownEncodingHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP.CodecFactoryPackage

Class UnknownEncodingHelper

  • java.lang.Object
    • org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper

  • public abstract class UnknownEncodingHelper
extends Object
    org/omg/IOP/CodecFactoryPackage/UnknownEncodingHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      UnknownEncodingHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static UnknownEncoding | extract(Any a)
      static String | id()
      static void | insert(Any a, UnknownEncoding that)
      static UnknownEncoding | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, UnknownEncoding value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • UnknownEncodingHelper

        public UnknownEncodingHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          UnknownEncoding that)

      • extract

        public static UnknownEncoding extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static UnknownEncoding read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         UnknownEncoding value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CodecOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Interface CodecOperations

  • All Known Subinterfaces:
    Codec

    public interface CodecOperations
    The formats of IOR components and service context data used by ORB services are often defined as CDR encapsulations encoding instances of IDL defined data types. The Codec provides a mechanism to transfer these components between their IDL data types and their CDR encapsulation representations.

    A Codec is obtained from the CodecFactory. The CodecFactory is obtained through a call to ORB.resolve_initial_references( "CodecFactory" ).

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Any decode_value(byte[] data, TypeCode tc)
      Decodes the given byte array into an Any based on the given TypeCode and the encoding format effective for this Codec.
      Any decode(byte[] data)
      Decodes the given byte array into an Any based on the encoding format effective for this Codec.
      byte[] encode_value(Any data)
      Converts the given any into a byte array based on the encoding format effective for this Codec.
      byte[] encode(Any data)
      Converts the given any into a byte array based on the encoding format effective for this Codec.

    • Method Detail

      • encode

        byte[] encode(Any data)
       throws InvalidTypeForEncoding
        Converts the given any into a byte array based on the encoding format effective for this Codec.
        Parameters:
        data - The data, in the form of an any, to be encoded into a byte array.
        Returns:
        A byte array containing the encoded Any. This byte array contains both the TypeCode and the data of the type.
        Throws:
        InvalidTypeForEncoding - thrown if the type is not valid for the encoding format effective for this Codec.

      • decode

        Any decode(byte[] data)
    throws FormatMismatch
        Decodes the given byte array into an Any based on the encoding format effective for this Codec.
        Parameters:
        data - The data, in the form of a byte array, to be decoded into an Any.
        Returns:
        An Any containing the data from the decoded byte array.
        Throws:
        FormatMismatch - is thrown if the byte array cannot be decoded into an Any.

      • encode_value

        byte[] encode_value(Any data)
             throws InvalidTypeForEncoding
        Converts the given any into a byte array based on the encoding format effective for this Codec. Only the data from the Any is encoded, not the TypeCode.
        Parameters:
        data - The data, in the form of an Any, to be encoded into a byte array.
        Returns:
        A byte array containing the data from the encoded any.
        Throws:
        InvalidTypeForEncoding - thrown if the type is not valid for the encoding format effective for this Codec.

      • decode_value

        Any decode_value(byte[] data,
                 TypeCode tc)
          throws FormatMismatch,
                 TypeMismatch
        Decodes the given byte array into an Any based on the given TypeCode and the encoding format effective for this Codec.
        Parameters:
        data - The data, in the form of a byte array, to be decoded into an Any.
        tc - The TypeCode to be used to decode the data.
        Returns:
        An Any containing the data from the decoded byte array.
        Throws:
        FormatMismatch - thrown if the byte array cannot be decoded into an Any.
        TypeMismatch
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Class org.omg.IOP.CodecPackage.FormatMismatch (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.CodecPackage.FormatMismatch

  • Packages that use FormatMismatch
    Package Description
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.IOP.CodecPackage
    This package is generated from the IOP::Codec IDL interface definition.

    • Uses of FormatMismatch in org.omg.IOP

      Methods in org.omg.IOP that throw FormatMismatch
      Modifier and Type Method and Description
      Any CodecOperations.decode_value(byte[] data, TypeCode tc)
      Decodes the given byte array into an Any based on the given TypeCode and the encoding format effective for this Codec.
      Any CodecOperations.decode(byte[] data)
      Decodes the given byte array into an Any based on the encoding format effective for this Codec.

    • Uses of FormatMismatch in org.omg.IOP.CodecPackage

      Methods in org.omg.IOP.CodecPackage that return FormatMismatch
      Modifier and Type | Method and Description
      static FormatMismatch | FormatMismatchHelper.extract(Any a)
      static FormatMismatch | FormatMismatchHelper.read(InputStream istream)
      Methods in org.omg.IOP.CodecPackage with parameters of type FormatMismatch
      Modifier and Type | Method and Description
      static void | FormatMismatchHelper.insert(Any a, FormatMismatch that)
      static void | FormatMismatchHelper.write(OutputStream ostream, FormatMismatch value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.IOP.CodecPackage.FormatMismatchHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.CodecPackage.FormatMismatchHelper

No usage of org.omg.IOP.CodecPackage.FormatMismatchHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.IOP.CodecPackage.InvalidTypeForEncoding (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.CodecPackage.InvalidTypeForEncoding

  • Packages that use InvalidTypeForEncoding
    Package Description
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.IOP.CodecPackage
    This package is generated from the IOP::Codec IDL interface definition.

    • Uses of InvalidTypeForEncoding in org.omg.IOP

      Methods in org.omg.IOP that throw InvalidTypeForEncoding
      Modifier and Type Method and Description
      byte[] CodecOperations.encode_value(Any data)
      Converts the given any into a byte array based on the encoding format effective for this Codec.
      byte[] CodecOperations.encode(Any data)
      Converts the given any into a byte array based on the encoding format effective for this Codec.

    • Uses of InvalidTypeForEncoding in org.omg.IOP.CodecPackage

      Methods in org.omg.IOP.CodecPackage that return InvalidTypeForEncoding
      Modifier and Type | Method and Description
      static InvalidTypeForEncoding | InvalidTypeForEncodingHelper.extract(Any a)
      static InvalidTypeForEncoding | InvalidTypeForEncodingHelper.read(InputStream istream)
      Methods in org.omg.IOP.CodecPackage with parameters of type InvalidTypeForEncoding
      Modifier and Type | Method and Description
      static void | InvalidTypeForEncodingHelper.insert(Any a, InvalidTypeForEncoding that)
      static void | InvalidTypeForEncodingHelper.write(OutputStream ostream, InvalidTypeForEncoding value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper

No usage of org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.IOP.CodecPackage.TypeMismatch (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.CodecPackage.TypeMismatch

  • Packages that use TypeMismatch
    Package Description
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.IOP.CodecPackage
    This package is generated from the IOP::Codec IDL interface definition.

    • Uses of TypeMismatch in org.omg.IOP

      Methods in org.omg.IOP that throw TypeMismatch
      Modifier and Type Method and Description
      Any CodecOperations.decode_value(byte[] data, TypeCode tc)
      Decodes the given byte array into an Any based on the given TypeCode and the encoding format effective for this Codec.

    • Uses of TypeMismatch in org.omg.IOP.CodecPackage

      Methods in org.omg.IOP.CodecPackage that return TypeMismatch
      Modifier and Type | Method and Description
      static TypeMismatch | TypeMismatchHelper.extract(Any a)
      static TypeMismatch | TypeMismatchHelper.read(InputStream istream)
      Methods in org.omg.IOP.CodecPackage with parameters of type TypeMismatch
      Modifier and Type | Method and Description
      static void | TypeMismatchHelper.insert(Any a, TypeMismatch that)
      static void | TypeMismatchHelper.write(OutputStream ostream, TypeMismatch value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.IOP.CodecPackage.TypeMismatchHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.IOP.CodecPackage.TypeMismatchHelper

No usage of org.omg.IOP.CodecPackage.TypeMismatchHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


FormatMismatch (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP.CodecPackage

Class FormatMismatch

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.IOP.CodecPackage.FormatMismatch
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class FormatMismatch
extends UserException
    org/omg/IOP/CodecPackage/FormatMismatch.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      FormatMismatch()
      FormatMismatch(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • FormatMismatch

        public FormatMismatch()

      • FormatMismatch

        public FormatMismatch(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


FormatMismatchHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP.CodecPackage

Class FormatMismatchHelper

  • java.lang.Object
    • org.omg.IOP.CodecPackage.FormatMismatchHelper

  • public abstract class FormatMismatchHelper
extends Object
    org/omg/IOP/CodecPackage/FormatMismatchHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      FormatMismatchHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static FormatMismatch | extract(Any a)
      static String | id()
      static void | insert(Any a, FormatMismatch that)
      static FormatMismatch | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, FormatMismatch value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • FormatMismatchHelper

        public FormatMismatchHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          FormatMismatch that)

      • extract

        public static FormatMismatch extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static FormatMismatch read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         FormatMismatch value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


InvalidTypeForEncoding (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP.CodecPackage

Class InvalidTypeForEncoding

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.IOP.CodecPackage.InvalidTypeForEncoding
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class InvalidTypeForEncoding
extends UserException
    org/omg/IOP/CodecPackage/InvalidTypeForEncoding.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      InvalidTypeForEncoding()
      InvalidTypeForEncoding(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • InvalidTypeForEncoding

        public InvalidTypeForEncoding()

      • InvalidTypeForEncoding

        public InvalidTypeForEncoding(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


InvalidTypeForEncodingHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP.CodecPackage

Class InvalidTypeForEncodingHelper

  • java.lang.Object
    • org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper

  • public abstract class InvalidTypeForEncodingHelper
extends Object
    org/omg/IOP/CodecPackage/InvalidTypeForEncodingHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      InvalidTypeForEncodingHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static InvalidTypeForEncoding | extract(Any a)
      static String | id()
      static void | insert(Any a, InvalidTypeForEncoding that)
      static InvalidTypeForEncoding | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, InvalidTypeForEncoding value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • InvalidTypeForEncodingHelper

        public InvalidTypeForEncodingHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          InvalidTypeForEncoding that)

      • extract

        public static InvalidTypeForEncoding extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static InvalidTypeForEncoding read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         InvalidTypeForEncoding value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


org.omg.IOP.CodecPackage (Java Platform SE 8 )

org.omg.IOP.CodecPackage

Classes

  • FormatMismatchHelper
  • InvalidTypeForEncodingHelper
  • TypeMismatchHelper

Exceptions

  • FormatMismatch
  • InvalidTypeForEncoding
  • TypeMismatch


org.omg.IOP.CodecPackage (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.IOP.CodecPackage

This package is generated from the IOP::Codec IDL interface definition.

See: Description

  • Class Summary
    Class Description
    FormatMismatchHelper
    org/omg/IOP/CodecPackage/FormatMismatchHelper.java .
    InvalidTypeForEncodingHelper
    org/omg/IOP/CodecPackage/InvalidTypeForEncodingHelper.java .
    TypeMismatchHelper
    org/omg/IOP/CodecPackage/TypeMismatchHelper.java .
  • Exception Summary
    Exception Description
    FormatMismatch
    org/omg/IOP/CodecPackage/FormatMismatch.java .
    InvalidTypeForEncoding
    org/omg/IOP/CodecPackage/InvalidTypeForEncoding.java .
    TypeMismatch
    org/omg/IOP/CodecPackage/TypeMismatch.java .

Package org.omg.IOP.CodecPackage Description

This package is generated from the IOP::Codec IDL interface definition. It contains the Java representations of the IDL exceptions specified in IOP::Codec (as part of the Portable Interceptors specification). Please refer to that OMG specification for further details.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

Since:
1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames


org.omg.IOP.CodecPackage Class Hierarchy (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.IOP.CodecPackage

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.IOP.CodecPackage.FormatMismatchHelper
    • org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.IOP.CodecPackage.FormatMismatch
          • org.omg.IOP.CodecPackage.InvalidTypeForEncoding
          • org.omg.IOP.CodecPackage.TypeMismatch
    • org.omg.IOP.CodecPackage.TypeMismatchHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package org.omg.IOP.CodecPackage (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.IOP.CodecPackage

  • Packages that use org.omg.IOP.CodecPackage
    Package Description
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.IOP.CodecPackage
    This package is generated from the IOP::Codec IDL interface definition.
  • Classes in org.omg.IOP.CodecPackage used by org.omg.IOP
    Class and Description
    FormatMismatch
    org/omg/IOP/CodecPackage/FormatMismatch.java .
    InvalidTypeForEncoding
    org/omg/IOP/CodecPackage/InvalidTypeForEncoding.java .
    TypeMismatch
    org/omg/IOP/CodecPackage/TypeMismatch.java .
  • Classes in org.omg.IOP.CodecPackage used by org.omg.IOP.CodecPackage
    Class and Description
    FormatMismatch
    org/omg/IOP/CodecPackage/FormatMismatch.java .
    InvalidTypeForEncoding
    org/omg/IOP/CodecPackage/InvalidTypeForEncoding.java .
    TypeMismatch
    org/omg/IOP/CodecPackage/TypeMismatch.java .
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


TypeMismatch (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP.CodecPackage

Class TypeMismatch

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.IOP.CodecPackage.TypeMismatch
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class TypeMismatch
extends UserException
    org/omg/IOP/CodecPackage/TypeMismatch.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      TypeMismatch()
      TypeMismatch(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • TypeMismatch

        public TypeMismatch()

      • TypeMismatch

        public TypeMismatch(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TypeMismatchHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP.CodecPackage

Class TypeMismatchHelper

  • java.lang.Object
    • org.omg.IOP.CodecPackage.TypeMismatchHelper

  • public abstract class TypeMismatchHelper
extends Object
    org/omg/IOP/CodecPackage/TypeMismatchHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      TypeMismatchHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static TypeMismatch | extract(Any a)
      static String | id()
      static void | insert(Any a, TypeMismatch that)
      static TypeMismatch | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, TypeMismatch value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • TypeMismatchHelper

        public TypeMismatchHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          TypeMismatch that)

      • extract

        public static TypeMismatch extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static TypeMismatch read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         TypeMismatch value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CodeSets (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Interface CodeSets

  • public interface CodeSets
    org/omg/IOP/CodeSets.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      Identifies a CDR encapsulation of the CONV_FRAME.CodeSetContext defined in Section 13.10.2.5, "GIOP Code Set Service Context," on page 13-43.

    • Field Detail

      • value

        static final int value
        Identifies a CDR encapsulation of the CONV_FRAME.CodeSetContext defined in Section 13.10.2.5, "GIOP Code Set Service Context," on page 13-43.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ComponentIdHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class ComponentIdHelper

  • java.lang.Object
    • org.omg.IOP.ComponentIdHelper

  • public abstract class ComponentIdHelper
extends Object
    Standard way of representing multicomponent profiles. This would be encapsulated in a TaggedProfile.

    • Constructor Summary

      Constructors
      Constructor and Description
      ComponentIdHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static int | extract(Any a)
      static String | id()
      static void | insert(Any a, int that)
      static int | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, int value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ComponentIdHelper

        public ComponentIdHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          int that)

      • extract

        public static int extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static int read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         int value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Encoding (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class Encoding

  • java.lang.Object
    • org.omg.IOP.Encoding
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class Encoding
extends Object
implements IDLEntity
    org/omg/IOP/Encoding.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      short format
      The encoding format.
      byte major_version
      The major version of this Encoding format.
      byte minor_version
      The minor version of this Encoding format.

    • Constructor Summary

      Constructors
      Constructor and Description
      Encoding()
      Encoding(short _format, byte _major_version, byte _minor_version)

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • format

        public short format
        The encoding format.

      • major_version

        public byte major_version
        The major version of this Encoding format.

      • minor_version

        public byte minor_version
        The minor version of this Encoding format.

    • Constructor Detail

      • Encoding

        public Encoding()

      • Encoding

        public Encoding(short _format,
                byte _major_version,
                byte _minor_version)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ENCODING_CDR_ENCAPS (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Interface ENCODING_CDR_ENCAPS

  • public interface ENCODING_CDR_ENCAPS
    org/omg/IOP/ENCODING_CDR_ENCAPS.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short value
      The CDR Encapsulation encoding.

    • Field Detail

      • value

        static final short value
        The CDR Encapsulation encoding.
        See Also:
        CodecFactory, Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ExceptionDetailMessage (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Interface ExceptionDetailMessage

  • public interface ExceptionDetailMessage
    org/omg/IOP/ExceptionDetailMessage.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      CORBA formal/02-06-01: 13.7.1: ExceptionDetailMessage identifies a CDR encapsulation of a wstring, encoded using GIOP 1.2 with a TCS-W of UTF-16.

    • Field Detail

      • value

        static final int value
        CORBA formal/02-06-01: 13.7.1: ExceptionDetailMessage identifies a CDR encapsulation of a wstring, encoded using GIOP 1.2 with a TCS-W of UTF-16. This service context may be sent on Reply messages with a reply_status of SYSTEM_EXCEPTION or USER_EXCEPTION. The usage of this service context is defined by language mappings.

        IDL/Java: ptc/02-01-22: 1.15.2: When a System Exception is marshaled, its GIOP Reply message shall include an associated ExceptionDetailMessage service context. The callee's stack trace is often very valuable debugging information but may contain sensitive or unwanted information. The wstring within the service context will therefore contain additional information relating to the exception, for example the result of calling either printStackTrace(PrintWriter) or getMessage() on the exception. When unmarshaling a System Exception on the client side, the wstring from any ExceptionDetailMessage service context shall become the Java error message in the unmarshaled exception object.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


IOR (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class IOR

  • java.lang.Object
    • org.omg.IOP.IOR
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class IOR
extends Object
implements IDLEntity
    org/omg/IOP/IOR.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      TaggedProfile[] profiles
      An array of tagged profiles associated with this object reference.
      String type_id
      The type id, represented as a String.

    • Constructor Summary

      Constructors
      Constructor and Description
      IOR()
      IOR(String _type_id, TaggedProfile[] _profiles)

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • type_id

        public String type_id
        The type id, represented as a String.

      • profiles

        public TaggedProfile[] profiles
        An array of tagged profiles associated with this object reference.

    • Constructor Detail

      • IOR

        public IOR()

      • IOR

        public IOR(String _type_id,
           TaggedProfile[] _profiles)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


IORHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class IORHelper

  • java.lang.Object
    • org.omg.IOP.IORHelper

  • public abstract class IORHelper
extends Object
    org/omg/IOP/IORHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      IORHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static IOR | extract(Any a)
      static String | id()
      static void | insert(Any a, IOR that)
      static IOR | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, IOR value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • IORHelper

        public IORHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          IOR that)

      • extract

        public static IOR extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static IOR read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         IOR value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


IORHolder (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class IORHolder

  • java.lang.Object
    • org.omg.IOP.IORHolder
  • All Implemented Interfaces:
    Streamable

    public final class IORHolder
extends Object
implements Streamable
    org/omg/IOP/IORHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      IOR value

    • Constructor Summary

      Constructors
      Constructor and Description
      IORHolder()
      IORHolder(IOR initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public IOR value

    • Constructor Detail

      • IORHolder

        public IORHolder()

      • IORHolder

        public IORHolder(IOR initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MultipleComponentProfileHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class MultipleComponentProfileHelper

  • java.lang.Object
    • org.omg.IOP.MultipleComponentProfileHelper

  • public abstract class MultipleComponentProfileHelper
extends Object
    An array of tagged components, forming a multiple component profile.

    • Constructor Summary

      Constructors
      Constructor and Description
      MultipleComponentProfileHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static TaggedComponent[] | extract(Any a)
      static String | id()
      static void | insert(Any a, TaggedComponent[] that)
      static TaggedComponent[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, TaggedComponent[] value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • MultipleComponentProfileHelper

        public MultipleComponentProfileHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          TaggedComponent[] that)

      • extract

        public static TaggedComponent[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static TaggedComponent[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         TaggedComponent[] value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MultipleComponentProfileHolder (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class MultipleComponentProfileHolder

  • java.lang.Object
    • org.omg.IOP.MultipleComponentProfileHolder
  • All Implemented Interfaces:
    Streamable

    public final class MultipleComponentProfileHolder
extends Object
implements Streamable
    An array of tagged components, forming a multiple component profile.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      TaggedComponent[] value

    • Constructor Summary

      Constructors
      Constructor and Description
      MultipleComponentProfileHolder()
      MultipleComponentProfileHolder(TaggedComponent[] initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public TaggedComponent[] value

    • Constructor Detail

      • MultipleComponentProfileHolder

        public MultipleComponentProfileHolder()

      • MultipleComponentProfileHolder

        public MultipleComponentProfileHolder(TaggedComponent[] initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


org.omg.IOP (Java Platform SE 8 )

org.omg.IOP

Interfaces

  • Codec
  • CodecFactory
  • CodecFactoryOperations
  • CodecOperations
  • CodeSets
  • ENCODING_CDR_ENCAPS
  • ExceptionDetailMessage
  • RMICustomMaxStreamFormat
  • TAG_ALTERNATE_IIOP_ADDRESS
  • TAG_CODE_SETS
  • TAG_INTERNET_IOP
  • TAG_JAVA_CODEBASE
  • TAG_MULTIPLE_COMPONENTS
  • TAG_ORB_TYPE
  • TAG_POLICIES
  • TAG_RMI_CUSTOM_MAX_STREAM_FORMAT
  • TransactionService

Classes

  • CodecFactoryHelper
  • ComponentIdHelper
  • Encoding
  • IOR
  • IORHelper
  • IORHolder
  • MultipleComponentProfileHelper
  • MultipleComponentProfileHolder
  • ProfileIdHelper
  • ServiceContext
  • ServiceContextHelper
  • ServiceContextHolder
  • ServiceContextListHelper
  • ServiceContextListHolder
  • ServiceIdHelper
  • TaggedComponent
  • TaggedComponentHelper
  • TaggedComponentHolder
  • TaggedProfile
  • TaggedProfileHelper
  • TaggedProfileHolder


org.omg.IOP (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.IOP

This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.

See: Description

  • Interface Summary
    Interface Description
    Codec
    The formats of IOR components and service context data used by ORB services are often defined as CDR encapsulations encoding instances of IDL defined data types.
    CodecFactory
    Codecs are obtained from the CodecFactory.
    CodecFactoryOperations
    Codecs are obtained from the CodecFactory.
    CodecOperations
    The formats of IOR components and service context data used by ORB services are often defined as CDR encapsulations encoding instances of IDL defined data types.
    CodeSets
    org/omg/IOP/CodeSets.java .
    ENCODING_CDR_ENCAPS
    org/omg/IOP/ENCODING_CDR_ENCAPS.java .
    ExceptionDetailMessage
    org/omg/IOP/ExceptionDetailMessage.java .
    RMICustomMaxStreamFormat
    org/omg/IOP/RMICustomMaxStreamFormat.java .
    TAG_ALTERNATE_IIOP_ADDRESS
    org/omg/IOP/TAG_ALTERNATE_IIOP_ADDRESS.java .
    TAG_CODE_SETS
    org/omg/IOP/TAG_CODE_SETS.java .
    TAG_INTERNET_IOP
    org/omg/IOP/TAG_INTERNET_IOP.java .
    TAG_JAVA_CODEBASE
    org/omg/IOP/TAG_JAVA_CODEBASE.java .
    TAG_MULTIPLE_COMPONENTS
    org/omg/IOP/TAG_MULTIPLE_COMPONENTS.java .
    TAG_ORB_TYPE
    org/omg/IOP/TAG_ORB_TYPE.java .
    TAG_POLICIES
    org/omg/IOP/TAG_POLICIES.java .
    TAG_RMI_CUSTOM_MAX_STREAM_FORMAT
    org/omg/IOP/TAG_RMI_CUSTOM_MAX_STREAM_FORMAT.java .
    TransactionService
    org/omg/IOP/TransactionService.java .
  • Class Summary
    Class Description
    CodecFactoryHelper
    Codecs are obtained from the CodecFactory.
    ComponentIdHelper
    Standard way of representing multicomponent profiles.
    Encoding
    org/omg/IOP/Encoding.java .
    IOR
    org/omg/IOP/IOR.java .
    IORHelper
    org/omg/IOP/IORHelper.java .
    IORHolder
    org/omg/IOP/IORHolder.java .
    MultipleComponentProfileHelper
    An array of tagged components, forming a multiple component profile.
    MultipleComponentProfileHolder
    An array of tagged components, forming a multiple component profile.
    ProfileIdHelper
    Profile ID
    ServiceContext
    org/omg/IOP/ServiceContext.java .
    ServiceContextHelper
    org/omg/IOP/ServiceContextHelper.java .
    ServiceContextHolder
    org/omg/IOP/ServiceContextHolder.java .
    ServiceContextListHelper
    An array of service contexts, forming a service context list.
    ServiceContextListHolder
    An array of service contexts, forming a service context list.
    ServiceIdHelper
    A service id, represented as an int
    TaggedComponent
    org/omg/IOP/TaggedComponent.java .
    TaggedComponentHelper
    org/omg/IOP/TaggedComponentHelper.java .
    TaggedComponentHolder
    org/omg/IOP/TaggedComponentHolder.java .
    TaggedProfile
    org/omg/IOP/TaggedProfile.java .
    TaggedProfileHelper
    org/omg/IOP/TaggedProfileHelper.java .
    TaggedProfileHolder
    org/omg/IOP/TaggedProfileHolder.java .

Package org.omg.IOP Description

This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6. Please refer to that OMG specification for further details.

Please note that we do not provide all parts of the IOP module from the specification. We only provide those parts that are referenced as return values or parameter types in public APIs, most notably, Portable Interceptors.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

Since:
1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames


org.omg.IOP Class Hierarchy (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.IOP

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.IOP.CodecFactoryHelper
    • org.omg.IOP.ComponentIdHelper
    • org.omg.IOP.Encoding (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.IOR (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.IORHelper
    • org.omg.IOP.IORHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.IOP.MultipleComponentProfileHelper
    • org.omg.IOP.MultipleComponentProfileHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.IOP.ProfileIdHelper
    • org.omg.IOP.ServiceContext (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.ServiceContextHelper
    • org.omg.IOP.ServiceContextHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.IOP.ServiceContextListHelper
    • org.omg.IOP.ServiceContextListHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.IOP.ServiceIdHelper
    • org.omg.IOP.TaggedComponent (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.TaggedComponentHelper
    • org.omg.IOP.TaggedComponentHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.IOP.TaggedProfile (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.TaggedProfileHelper
    • org.omg.IOP.TaggedProfileHolder (implements org.omg.CORBA.portable.Streamable)

Interface Hierarchy

  • org.omg.IOP.CodecFactoryOperations
    • org.omg.IOP.CodecFactory (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.IOP.CodecOperations
    • org.omg.IOP.Codec (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.IOP.CodeSets
  • org.omg.IOP.ENCODING_CDR_ENCAPS
  • org.omg.IOP.ExceptionDetailMessage
  • org.omg.CORBA.Object
    • org.omg.IOP.Codec (also extends org.omg.IOP.CodecOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.CodecFactory (also extends org.omg.IOP.CodecFactoryOperations, org.omg.CORBA.portable.IDLEntity)
  • org.omg.IOP.RMICustomMaxStreamFormat
  • java.io.Serializable
    • org.omg.CORBA.portable.IDLEntity
      • org.omg.IOP.Codec (also extends org.omg.IOP.CodecOperations, org.omg.CORBA.Object)
      • org.omg.IOP.CodecFactory (also extends org.omg.IOP.CodecFactoryOperations, org.omg.CORBA.Object)
  • org.omg.IOP.TAG_ALTERNATE_IIOP_ADDRESS
  • org.omg.IOP.TAG_CODE_SETS
  • org.omg.IOP.TAG_INTERNET_IOP
  • org.omg.IOP.TAG_JAVA_CODEBASE
  • org.omg.IOP.TAG_MULTIPLE_COMPONENTS
  • org.omg.IOP.TAG_ORB_TYPE
  • org.omg.IOP.TAG_POLICIES
  • org.omg.IOP.TAG_RMI_CUSTOM_MAX_STREAM_FORMAT
  • org.omg.IOP.TransactionService
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package org.omg.IOP (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.IOP

  • Packages that use org.omg.IOP
    Package Description
    org.omg.IOP
    This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
  • Classes in org.omg.IOP used by org.omg.IOP
    Class and Description
    Codec
    The formats of IOR components and service context data used by ORB services are often defined as CDR encapsulations encoding instances of IDL defined data types.
    CodecFactory
    Codecs are obtained from the CodecFactory.
    CodecFactoryOperations
    Codecs are obtained from the CodecFactory.
    CodecOperations
    The formats of IOR components and service context data used by ORB services are often defined as CDR encapsulations encoding instances of IDL defined data types.
    Encoding
    org/omg/IOP/Encoding.java .
    IOR
    org/omg/IOP/IOR.java .
    ServiceContext
    org/omg/IOP/ServiceContext.java .
    TaggedComponent
    org/omg/IOP/TaggedComponent.java .
    TaggedProfile
    org/omg/IOP/TaggedProfile.java .
  • Classes in org.omg.IOP used by org.omg.PortableInterceptor
    Class and Description
    CodecFactory
    Codecs are obtained from the CodecFactory.
    ServiceContext
    org/omg/IOP/ServiceContext.java .
    TaggedComponent
    org/omg/IOP/TaggedComponent.java .
    TaggedProfile
    org/omg/IOP/TaggedProfile.java .
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


ProfileIdHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class ProfileIdHelper

  • java.lang.Object
    • org.omg.IOP.ProfileIdHelper

  • public abstract class ProfileIdHelper
extends Object
    Profile ID

    • Constructor Summary

      Constructors
      Constructor and Description
      ProfileIdHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static int | extract(Any a)
      static String | id()
      static void | insert(Any a, int that)
      static int | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, int value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ProfileIdHelper

        public ProfileIdHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          int that)

      • extract

        public static int extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static int read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         int value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


RMICustomMaxStreamFormat (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Interface RMICustomMaxStreamFormat

  • public interface RMICustomMaxStreamFormat
    org/omg/IOP/RMICustomMaxStreamFormat.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      Identifies a CDR encapsulation of the RMICustomMaxStreamFormat service context which contains a single byte specifying the client's maximum RMI-IIOP stream format version.

    • Field Detail

      • value

        static final int value
        Identifies a CDR encapsulation of the RMICustomMaxStreamFormat service context which contains a single byte specifying the client's maximum RMI-IIOP stream format version. See Java to IDL ptc/02-01-12 1.4.12.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServiceContext (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class ServiceContext

  • java.lang.Object
    • org.omg.IOP.ServiceContext
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class ServiceContext
extends Object
implements IDLEntity
    org/omg/IOP/ServiceContext.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      byte[] context_data
      The data associated with this service context
      int context_id
      The service context id

    • Constructor Summary

      Constructors
      Constructor and Description
      ServiceContext()
      ServiceContext(int _context_id, byte[] _context_data)

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • context_id

        public int context_id
        The service context id

      • context_data

        public byte[] context_data
        The data associated with this service context

    • Constructor Detail

      • ServiceContext

        public ServiceContext()

      • ServiceContext

        public ServiceContext(int _context_id,
                      byte[] _context_data)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServiceContextHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class ServiceContextHelper

  • java.lang.Object
    • org.omg.IOP.ServiceContextHelper

  • public abstract class ServiceContextHelper
extends Object
    org/omg/IOP/ServiceContextHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      ServiceContextHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static ServiceContext | extract(Any a)
      static String | id()
      static void | insert(Any a, ServiceContext that)
      static ServiceContext | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, ServiceContext value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ServiceContextHelper

        public ServiceContextHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          ServiceContext that)

      • extract

        public static ServiceContext extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ServiceContext read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         ServiceContext value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServiceContextHolder (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class ServiceContextHolder

  • java.lang.Object
    • org.omg.IOP.ServiceContextHolder
  • All Implemented Interfaces:
    Streamable

    public final class ServiceContextHolder
extends Object
implements Streamable
    org/omg/IOP/ServiceContextHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      ServiceContext value

    • Constructor Summary

      Constructors
      Constructor and Description
      ServiceContextHolder()
      ServiceContextHolder(ServiceContext initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public ServiceContext value

    • Constructor Detail

      • ServiceContextHolder

        public ServiceContextHolder()

      • ServiceContextHolder

        public ServiceContextHolder(ServiceContext initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServiceContextListHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class ServiceContextListHelper

  • java.lang.Object
    • org.omg.IOP.ServiceContextListHelper

  • public abstract class ServiceContextListHelper
extends Object
    An array of service contexts, forming a service context list.

    • Constructor Summary

      Constructors
      Constructor and Description
      ServiceContextListHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static ServiceContext[] | extract(Any a)
      static String | id()
      static void | insert(Any a, ServiceContext[] that)
      static ServiceContext[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, ServiceContext[] value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ServiceContextListHelper

        public ServiceContextListHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          ServiceContext[] that)

      • extract

        public static ServiceContext[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ServiceContext[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         ServiceContext[] value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServiceContextListHolder (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class ServiceContextListHolder

  • java.lang.Object
    • org.omg.IOP.ServiceContextListHolder
  • All Implemented Interfaces:
    Streamable

    public final class ServiceContextListHolder
extends Object
implements Streamable
    An array of service contexts, forming a service context list.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      ServiceContext[] value

    • Constructor Summary

      Constructors
      Constructor and Description
      ServiceContextListHolder()
      ServiceContextListHolder(ServiceContext[] initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public ServiceContext[] value

    • Constructor Detail

      • ServiceContextListHolder

        public ServiceContextListHolder()

      • ServiceContextListHolder

        public ServiceContextListHolder(ServiceContext[] initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServiceIdHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class ServiceIdHelper

  • java.lang.Object
    • org.omg.IOP.ServiceIdHelper

  • public abstract class ServiceIdHelper
extends Object
    A service id, represented as an int

    • Constructor Summary

      Constructors
      Constructor and Description
      ServiceIdHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static int | extract(Any a)
      static String | id()
      static void | insert(Any a, int that)
      static int | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, int value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ServiceIdHelper

        public ServiceIdHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          int that)

      • extract

        public static int extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static int read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         int value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TaggedComponent (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class TaggedComponent

  • java.lang.Object
    • org.omg.IOP.TaggedComponent
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class TaggedComponent
extends Object
implements IDLEntity
    org/omg/IOP/TaggedComponent.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      byte[] component_data
      The component data associated with the component id.
      int tag
      The tag, represented as a component id.

    • Constructor Summary

      Constructors
      Constructor and Description
      TaggedComponent()
      TaggedComponent(int _tag, byte[] _component_data)

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • tag

        public int tag
        The tag, represented as a component id.

      • component_data

        public byte[] component_data
        The component data associated with the component id.

    • Constructor Detail

      • TaggedComponent

        public TaggedComponent()

      • TaggedComponent

        public TaggedComponent(int _tag,
                       byte[] _component_data)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TaggedComponentHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class TaggedComponentHelper

  • java.lang.Object
    • org.omg.IOP.TaggedComponentHelper

  • public abstract class TaggedComponentHelper
extends Object
    org/omg/IOP/TaggedComponentHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      TaggedComponentHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static TaggedComponent | extract(Any a)
      static String | id()
      static void | insert(Any a, TaggedComponent that)
      static TaggedComponent | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, TaggedComponent value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • TaggedComponentHelper

        public TaggedComponentHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          TaggedComponent that)

      • extract

        public static TaggedComponent extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static TaggedComponent read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         TaggedComponent value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TaggedComponentHolder (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class TaggedComponentHolder

  • java.lang.Object
    • org.omg.IOP.TaggedComponentHolder
  • All Implemented Interfaces:
    Streamable

    public final class TaggedComponentHolder
extends Object
implements Streamable
    org/omg/IOP/TaggedComponentHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      TaggedComponent value

    • Constructor Summary

      Constructors
      Constructor and Description
      TaggedComponentHolder()
      TaggedComponentHolder(TaggedComponent initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public TaggedComponent value

    • Constructor Detail

      • TaggedComponentHolder

        public TaggedComponentHolder()

      • TaggedComponentHolder

        public TaggedComponentHolder(TaggedComponent initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TaggedProfile (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class TaggedProfile

  • java.lang.Object
    • org.omg.IOP.TaggedProfile
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class TaggedProfile
extends Object
implements IDLEntity
    org/omg/IOP/TaggedProfile.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      byte[] profile_data
      The associated profile data.
      int tag
      The tag, represented as a profile id.

    • Constructor Summary

      Constructors
      Constructor and Description
      TaggedProfile()
      TaggedProfile(int _tag, byte[] _profile_data)

    • Method Summary

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • tag

        public int tag
        The tag, represented as a profile id.

      • profile_data

        public byte[] profile_data
        The associated profile data.

    • Constructor Detail

      • TaggedProfile

        public TaggedProfile()

      • TaggedProfile

        public TaggedProfile(int _tag,
                     byte[] _profile_data)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TaggedProfileHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class TaggedProfileHelper

  • java.lang.Object
    • org.omg.IOP.TaggedProfileHelper

  • public abstract class TaggedProfileHelper
extends Object
    org/omg/IOP/TaggedProfileHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      TaggedProfileHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static TaggedProfile | extract(Any a)
      static String | id()
      static void | insert(Any a, TaggedProfile that)
      static TaggedProfile | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, TaggedProfile value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • TaggedProfileHelper

        public TaggedProfileHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          TaggedProfile that)

      • extract

        public static TaggedProfile extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static TaggedProfile read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         TaggedProfile value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TaggedProfileHolder (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Class TaggedProfileHolder

  • java.lang.Object
    • org.omg.IOP.TaggedProfileHolder
  • All Implemented Interfaces:
    Streamable

    public final class TaggedProfileHolder
extends Object
implements Streamable
    org/omg/IOP/TaggedProfileHolder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      TaggedProfile value

    • Constructor Summary

      Constructors
      Constructor and Description
      TaggedProfileHolder()
      TaggedProfileHolder(TaggedProfile initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public TaggedProfile value

    • Constructor Detail

      • TaggedProfileHolder

        public TaggedProfileHolder()

      • TaggedProfileHolder

        public TaggedProfileHolder(TaggedProfile initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TAG_ALTERNATE_IIOP_ADDRESS (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Interface TAG_ALTERNATE_IIOP_ADDRESS

  • public interface TAG_ALTERNATE_IIOP_ADDRESS
    org/omg/IOP/TAG_ALTERNATE_IIOP_ADDRESS.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      In cases where the same object key is used for more than one internet location, the following standard IOR Component is defined for support in IIOP version 1.2.

    • Field Detail

      • value

        static final int value
        In cases where the same object key is used for more than one internet location, the following standard IOR Component is defined for support in IIOP version 1.2.

        The TAG_ALTERNATE_IIOP_ADDRESS component has an associated value of type:

             struct {
         string HostID,
         short Port
     };
        encoded as a CDR encapsulation.

        Zero or more instances of the TAG_ALTERNATE_IIOP_ADDRESS component type may be included in a version 1.2 TAG_INTERNET_IOP Profile. Each of these alternative addresses may be used by the client orb, in addition to the host and port address expressed in the body of the Profile. In cases where one or more TAG_ALTERNATE_IIOP_ADDRESS components are present in a TAG_INTERNET_IOP Profile, no order of use is prescribed by Version 1.2 of IIOP.

        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TAG_CODE_SETS (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Interface TAG_CODE_SETS

  • public interface TAG_CODE_SETS
    org/omg/IOP/TAG_CODE_SETS.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      The code set component of the IOR multi-component profile structure contains: server's native char code set and conversion code sets, and server's native wchar code set and conversion code sets. Both char and wchar conversion code sets are listed in order of preference.

    • Field Detail

      • value

        static final int value
        The code set component of the IOR multi-component profile structure contains:
        • server's native char code set and conversion code sets, and
        • server's native wchar code set and conversion code sets.
        Both char and wchar conversion code sets are listed in order of preference.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TAG_INTERNET_IOP (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Interface TAG_INTERNET_IOP

  • public interface TAG_INTERNET_IOP
    org/omg/IOP/TAG_INTERNET_IOP.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      Identifies profiles that support the Internet Inter-ORB Protocol.

    • Field Detail

      • value

        static final int value
        Identifies profiles that support the Internet Inter-ORB Protocol. The ProfileBody of this profile contains a CDR encapsulation of a structure containing addressing and object identification information used by IIOP. Version 1.1 of the TAG_INTERNET_IOP profile also includes an array of TaggedComponent objects that can contain additional information supporting optional IIOP features, ORB services such as security, and future protocol extensions.

        Protocols other than IIOP (such as ESIOPs and other GIOPs) can share profile information (such as object identity or security information) with IIOP by encoding their additional profile information as components in the TAG_INTERNET_IOP profile. All TAG_INTERNET_IOP profiles support IIOP, regardless of whether they also support additional protocols. Interoperable ORBs are not required to create or understand any other profile, nor are they required to create or understand any of the components defined for other protocols that might share the TAG_INTERNET_IOP profile with IIOP.

        The profile_data for the TAG_INTERNET_IOP profile is a CDR encapsulation of the IIOP.ProfileBody_1_1 type.

        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TAG_JAVA_CODEBASE (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Interface TAG_JAVA_CODEBASE

  • public interface TAG_JAVA_CODEBASE
    org/omg/IOP/TAG_JAVA_CODEBASE.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      Class downloading is supported for stubs, ties, values, and value helpers.

    • Field Detail

      • value

        static final int value
        Class downloading is supported for stubs, ties, values, and value helpers. The specification allows transmission of codebase information on the wire for stubs and ties, and enables usage of pre-existing ClassLoaders when relevant.

        For values and value helpers, the codebase is transmitted after the value tag. For stubs and ties, the codebase is transmitted as the TaggedComponent TAG_JAVA_CODEBASE in the IOR profile, where the component_data is a CDR encapsulation of the codebase written as an IDL string. The codebase is a space-separated list of one or more URLs.

        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TAG_MULTIPLE_COMPONENTS (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Interface TAG_MULTIPLE_COMPONENTS

  • public interface TAG_MULTIPLE_COMPONENTS
    org/omg/IOP/TAG_MULTIPLE_COMPONENTS.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      Indicates that the value encapsulated is of type MultipleComponentProfile.

    • Field Detail

      • value

        static final int value
        Indicates that the value encapsulated is of type MultipleComponentProfile. In this case, the profile consists of a list of protocol components, the use of which must be specified by the protocol using this profile. This profile may be used to carry IOR components.

        The profile_data for the TAG_MULTIPLE_COMPONENTS profile is a CDR encapsulation of the MultipleComponentProfile type shown above.

        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TAG_ORB_TYPE (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Interface TAG_ORB_TYPE

  • public interface TAG_ORB_TYPE
    org/omg/IOP/TAG_ORB_TYPE.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      It is often useful in the real world to be able to identify the particular kind of ORB an object reference is coming from, to work around problems with that particular ORB, or exploit shared efficiencies.

    • Field Detail

      • value

        static final int value
        It is often useful in the real world to be able to identify the particular kind of ORB an object reference is coming from, to work around problems with that particular ORB, or exploit shared efficiencies.

        The TAG_ORB_TYPE component has an associated value of type unsigned long (Java long), encoded as a CDR encapsulation, designating an ORB type ID allocated by the OMG for the ORB type of the originating ORB. Anyone may register any ORB types by submitting a short (one-paragraph) description of the ORB type to the OMG, and will receive a new ORB type ID in return. A list of ORB type descriptions and values will be made available on the OMG web server.

        The TAG_ORB_TYPE component can appear at most once in any IOR profile. For profiles supporting IIOP 1.1 or greater, it is optionally present.

        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TAG_POLICIES (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Interface TAG_POLICIES

  • public interface TAG_POLICIES
    org/omg/IOP/TAG_POLICIES.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      A profile component containing the sequence of QoS policies exported with the object reference by an object adapter.

    • Field Detail

      • value

        static final int value
        A profile component containing the sequence of QoS policies exported with the object reference by an object adapter.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TAG_RMI_CUSTOM_MAX_STREAM_FORMAT (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Interface TAG_RMI_CUSTOM_MAX_STREAM_FORMAT

  • public interface TAG_RMI_CUSTOM_MAX_STREAM_FORMAT
    org/omg/IOP/TAG_RMI_CUSTOM_MAX_STREAM_FORMAT.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      RMI-IIOP has multiple stream format versions.

    • Field Detail

      • value

        static final int value
        RMI-IIOP has multiple stream format versions. A server can specify its maximum version by including the TAG_RMI_CUSTOM_MAX_STREAM_FORMAT tagged component or rely on the default of version 1 for GIOP 1.2 and less and version 2 for GIOP 1.3 and higher. See Java to IDL ptc/02-01-12 1.4.11.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TransactionService (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.IOP

Interface TransactionService

  • public interface TransactionService
    org/omg/IOP/TransactionService.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/IOP.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      Identifies a CDR encapsulation of the CosTSInteroperation.PropogationContext defined in CORBAservices: Common Object Services Specifications.

    • Field Detail

      • value

        static final int value
        Identifies a CDR encapsulation of the CosTSInteroperation.PropogationContext defined in CORBAservices: Common Object Services Specifications.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Class org.omg.Messaging.SyncScopeHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.Messaging.SyncScopeHelper

No usage of org.omg.Messaging.SyncScopeHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.Messaging.SYNC_WITH_TRANSPORT (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.Messaging.SYNC_WITH_TRANSPORT

No usage of org.omg.Messaging.SYNC_WITH_TRANSPORT
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


org.omg.Messaging (Java Platform SE 8 )

org.omg.Messaging

Interfaces

  • SYNC_WITH_TRANSPORT

Classes

  • SyncScopeHelper


org.omg.Messaging (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.Messaging

This package contains the Messaging module specified in the OMG CORBA Messaging specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07.

See: Description

  • Interface Summary
    Interface Description
    SYNC_WITH_TRANSPORT
    org/omg/Messaging/SYNC_WITH_TRANSPORT.java .
  • Class Summary
    Class Description
    SyncScopeHelper
    Synchronization scope

Package org.omg.Messaging Description

This package contains the Messaging module specified in the OMG CORBA Messaging specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07. Please refer to that OMG specification for further details.

Please note that we do not provide all parts of the Messaging module from the specification. We only provide those parts that are referenced as return values or parameter types in public APIs, most notably, Portable Interceptors.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

Since:
1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames


org.omg.Messaging Class Hierarchy (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.Messaging

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.Messaging.SyncScopeHelper

Interface Hierarchy

  • org.omg.Messaging.SYNC_WITH_TRANSPORT
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package org.omg.Messaging (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.Messaging

No usage of org.omg.Messaging
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


SyncScopeHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.Messaging

Class SyncScopeHelper

  • java.lang.Object
    • org.omg.Messaging.SyncScopeHelper

  • public abstract class SyncScopeHelper
extends Object
    Synchronization scope

    • Constructor Summary

      Constructors
      Constructor and Description
      SyncScopeHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static short | extract(Any a)
      static String | id()
      static void | insert(Any a, short that)
      static short | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, short value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • SyncScopeHelper

        public SyncScopeHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          short that)

      • extract

        public static short extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static short read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         short value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SYNC_WITH_TRANSPORT (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.Messaging

Interface SYNC_WITH_TRANSPORT

  • public interface SYNC_WITH_TRANSPORT
    org/omg/Messaging/SYNC_WITH_TRANSPORT.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/Messaging.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short value
      Constant, defined in the Messaging spec, to define how far the request shall progress before control is returned to the client.

    • Field Detail

      • value

        static final short value
        Constant, defined in the Messaging spec, to define how far the request shall progress before control is returned to the client.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ACTIVE (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface ACTIVE

  • public interface ACTIVE
    org/omg/PortableInterceptor/ACTIVE.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short value
      Object adapter state that indicates normal request processing.

    • Field Detail

      • value

        static final short value
        Object adapter state that indicates normal request processing.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AdapterManagerIdHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Class AdapterManagerIdHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.AdapterManagerIdHelper

  • public abstract class AdapterManagerIdHelper
extends Object
    Adapter manager identifier. Every object adapter has an adapter manager, indicated in this API only through the ID. A group of object adapter instances may share the same adapter manager, in which case state transitions reported for the adapter manager are observed by all object adapters with the same adapter manager ID.

    • Constructor Summary

      Constructors
      Constructor and Description
      AdapterManagerIdHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static int | extract(Any a)
      static String | id()
      static void | insert(Any a, int that)
      static int | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, int value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AdapterManagerIdHelper

        public AdapterManagerIdHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          int that)

      • extract

        public static int extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static int read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         int value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AdapterNameHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Class AdapterNameHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.AdapterNameHelper

  • public abstract class AdapterNameHelper
extends Object
    The name of an object adapter. This is unique only within the scope of the ORB that created the object adapter.

    • Constructor Summary

      Constructors
      Constructor and Description
      AdapterNameHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static String[] | extract(Any a)
      static String | id()
      static void | insert(Any a, String[] that)
      static String[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, String[] value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AdapterNameHelper

        public AdapterNameHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          String[] that)

      • extract

        public static String[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         String[] value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AdapterStateHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Class AdapterStateHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.AdapterStateHelper

  • public abstract class AdapterStateHelper
extends Object
    Type of object adapter state. State changes are reported either to the object adapter or to the adapter manager.

    • Constructor Summary

      Constructors
      Constructor and Description
      AdapterStateHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static short | extract(Any a)
      static String | id()
      static void | insert(Any a, short that)
      static short | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, short value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AdapterStateHelper

        public AdapterStateHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          short that)

      • extract

        public static short extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static short read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         short value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Interface org.omg.PortableInterceptor.ACTIVE (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.ACTIVE

No usage of org.omg.PortableInterceptor.ACTIVE
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableInterceptor.AdapterManagerIdHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.AdapterManagerIdHelper

No usage of org.omg.PortableInterceptor.AdapterManagerIdHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableInterceptor.AdapterNameHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.AdapterNameHelper

No usage of org.omg.PortableInterceptor.AdapterNameHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableInterceptor.AdapterStateHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.AdapterStateHelper

No usage of org.omg.PortableInterceptor.AdapterStateHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableInterceptor.ClientRequestInfo (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.ClientRequestInfo

  • Packages that use ClientRequestInfo
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ClientRequestInfo in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor with parameters of type ClientRequestInfo
      Modifier and Type Method and Description
      void ClientRequestInterceptorOperations.receive_exception(ClientRequestInfo ri)
      Indicates to the interceptor that an exception occurred.
      void ClientRequestInterceptorOperations.receive_other(ClientRequestInfo ri)
      Allows an Interceptor to query the information available when a request results in something other than a normal reply or an exception.
      void ClientRequestInterceptorOperations.receive_reply(ClientRequestInfo ri)
      Allows an Interceptor to query the information on a reply after it is returned from the server and before control is returned to the client.
      void ClientRequestInterceptorOperations.send_poll(ClientRequestInfo ri)
      Allows an Interceptor to query information during a Time-Independent Invocation (TII) polling get reply sequence.
      void ClientRequestInterceptorOperations.send_request(ClientRequestInfo ri)
      Allows an Interceptor to query request information and modify the service context before the request is sent to the server.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableInterceptor.ClientRequestInfoOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.ClientRequestInfoOperations

  • Packages that use ClientRequestInfoOperations
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ClientRequestInfoOperations in org.omg.PortableInterceptor

      Subinterfaces of ClientRequestInfoOperations in org.omg.PortableInterceptor
      Modifier and Type Interface and Description
      interface  ClientRequestInfo
      Request Information, accessible to client-side request interceptors.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableInterceptor.ClientRequestInterceptor (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.ClientRequestInterceptor

  • Packages that use ClientRequestInterceptor
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ClientRequestInterceptor in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor with parameters of type ClientRequestInterceptor
      Modifier and Type Method and Description
      void ORBInitInfoOperations.add_client_request_interceptor(ClientRequestInterceptor interceptor)
      Used to add a client-side request Interceptor to the list of client-side request Interceptors.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableInterceptor.ClientRequestInterceptorOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.ClientRequestInterceptorOperations

  • Packages that use ClientRequestInterceptorOperations
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ClientRequestInterceptorOperations in org.omg.PortableInterceptor

      Subinterfaces of ClientRequestInterceptorOperations in org.omg.PortableInterceptor
      Modifier and Type Interface and Description
      interface  ClientRequestInterceptor
      Client-side request interceptor.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableInterceptor.Current (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.Current

  • Packages that use Current
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of Current in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor that return Current
      Modifier and Type | Method and Description
      static Current | CurrentHelper.extract(Any a)
      static Current | CurrentHelper.narrow(Object obj)
      static Current | CurrentHelper.read(InputStream istream)
      static Current | CurrentHelper.unchecked_narrow(Object obj)
      Methods in org.omg.PortableInterceptor with parameters of type Current
      Modifier and Type | Method and Description
      static void | CurrentHelper.insert(Any a, Current that)
      static void | CurrentHelper.write(OutputStream ostream, Current value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableInterceptor.CurrentHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.CurrentHelper

No usage of org.omg.PortableInterceptor.CurrentHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableInterceptor.CurrentOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.CurrentOperations

  • Packages that use CurrentOperations
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of CurrentOperations in org.omg.PortableInterceptor

      Subinterfaces of CurrentOperations in org.omg.PortableInterceptor
      Modifier and Type Interface and Description
      interface  Current
      Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableInterceptor.DISCARDING (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.DISCARDING

No usage of org.omg.PortableInterceptor.DISCARDING
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableInterceptor.ForwardRequest (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.ForwardRequest

  • Packages that use ForwardRequest
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ForwardRequest in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor that return ForwardRequest
      Modifier and Type | Method and Description
      static ForwardRequest | ForwardRequestHelper.extract(Any a)
      static ForwardRequest | ForwardRequestHelper.read(InputStream istream)
      Methods in org.omg.PortableInterceptor with parameters of type ForwardRequest
      Modifier and Type | Method and Description
      static void | ForwardRequestHelper.insert(Any a, ForwardRequest that)
      static void | ForwardRequestHelper.write(OutputStream ostream, ForwardRequest value)
      Methods in org.omg.PortableInterceptor that throw ForwardRequest
      Modifier and Type Method and Description
      void ClientRequestInterceptorOperations.receive_exception(ClientRequestInfo ri)
      Indicates to the interceptor that an exception occurred.
      void ClientRequestInterceptorOperations.receive_other(ClientRequestInfo ri)
      Allows an Interceptor to query the information available when a request results in something other than a normal reply or an exception.
      void ServerRequestInterceptorOperations.receive_request_service_contexts(ServerRequestInfo ri)
      Allows the interceptor to process service context information.
      void ServerRequestInterceptorOperations.receive_request(ServerRequestInfo ri)
      Allows an Interceptor to query request information after all the information, including operation parameters, are available.
      void ServerRequestInterceptorOperations.send_exception(ServerRequestInfo ri)
      Allows an Interceptor to query the exception information and modify the reply service context before the exception is thrown to the client.
      void ServerRequestInterceptorOperations.send_other(ServerRequestInfo ri)
      Allows an Interceptor to query the information available when a request results in something other than a normal reply or an exception.
      void ClientRequestInterceptorOperations.send_request(ClientRequestInfo ri)
      Allows an Interceptor to query request information and modify the service context before the request is sent to the server.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableInterceptor.ForwardRequestHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.ForwardRequestHelper

No usage of org.omg.PortableInterceptor.ForwardRequestHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableInterceptor.HOLDING (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.HOLDING

No usage of org.omg.PortableInterceptor.HOLDING
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableInterceptor.INACTIVE (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.INACTIVE

No usage of org.omg.PortableInterceptor.INACTIVE
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableInterceptor.Interceptor (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.Interceptor

  • Packages that use Interceptor
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of Interceptor in org.omg.PortableInterceptor

      Subinterfaces of Interceptor in org.omg.PortableInterceptor
      Modifier and Type Interface and Description
      interface  ClientRequestInterceptor
      Client-side request interceptor.
      interface  IORInterceptor
      Interceptor used to establish tagged components in the profiles within an IOR.
      interface  IORInterceptor_3_0
      org/omg/PortableInterceptor/IORInterceptor_3_0.java .
      interface  ServerRequestInterceptor
      Server-side request interceptor.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableInterceptor.InterceptorOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.InterceptorOperations

  • Packages that use InterceptorOperations
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of InterceptorOperations in org.omg.PortableInterceptor

      Subinterfaces of InterceptorOperations in org.omg.PortableInterceptor
      Modifier and Type Interface and Description
      interface  ClientRequestInterceptor
      Client-side request interceptor.
      interface  ClientRequestInterceptorOperations
      Client-side request interceptor.
      interface  Interceptor
      All Portable Interceptors implement Interceptor.
      interface  IORInterceptor
      Interceptor used to establish tagged components in the profiles within an IOR.
      interface  IORInterceptor_3_0
      org/omg/PortableInterceptor/IORInterceptor_3_0.java .
      interface  IORInterceptor_3_0Operations
      org/omg/PortableInterceptor/IORInterceptor_3_0Operations.java .
      interface  IORInterceptorOperations
      Interceptor used to establish tagged components in the profiles within an IOR.
      interface  ServerRequestInterceptor
      Server-side request interceptor.
      interface  ServerRequestInterceptorOperations
      Server-side request interceptor.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableInterceptor.InvalidSlot (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.InvalidSlot

  • Packages that use InvalidSlot
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of InvalidSlot in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor that return InvalidSlot
      Modifier and Type | Method and Description
      static InvalidSlot | InvalidSlotHelper.extract(Any a)
      static InvalidSlot | InvalidSlotHelper.read(InputStream istream)
      Methods in org.omg.PortableInterceptor with parameters of type InvalidSlot
      Modifier and Type | Method and Description
      static void | InvalidSlotHelper.insert(Any a, InvalidSlot that)
      static void | InvalidSlotHelper.write(OutputStream ostream, InvalidSlot value)
      Methods in org.omg.PortableInterceptor that throw InvalidSlot
      Modifier and Type Method and Description
      Any CurrentOperations.get_slot(int id)
      Retrieves the slot data the application set in PICurrent via get_slot.
      Any RequestInfoOperations.get_slot(int id)
      Returns the data from the given slot of the PortableInterceptor.Current that is in the scope of the request.
      void CurrentOperations.set_slot(int id, Any data)
      Sets data in a slot.
      void ServerRequestInfoOperations.set_slot(int id, Any data)
      Allows an Interceptor to set a slot in the PortableInterceptor.Current that is in the scope of the request.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableInterceptor.InvalidSlotHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.InvalidSlotHelper

No usage of org.omg.PortableInterceptor.InvalidSlotHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableInterceptor.IORInfo (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.IORInfo

  • Packages that use IORInfo
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of IORInfo in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor with parameters of type IORInfo
      Modifier and Type Method and Description
      void IORInterceptor_3_0Operations.components_established(IORInfo info)
      The components_established method is invoked on all registered IORInterceptor_3_0 instances after establish_components has been invoked on all registered IORInterceptor instances.
      void IORInterceptorOperations.establish_components(IORInfo info)
      A server side ORB calls the establish_components operation on all registered IORInterceptor instances when it is assembling the list of components that will be included in the profile or profiles of an object reference.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableInterceptor.IORInfoOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.IORInfoOperations

  • Packages that use IORInfoOperations
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of IORInfoOperations in org.omg.PortableInterceptor

      Subinterfaces of IORInfoOperations in org.omg.PortableInterceptor
      Modifier and Type Interface and Description
      interface  IORInfo
      Provides the server-side ORB service with access to the applicable policies during IOR construction and the ability to add components.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableInterceptor.IORInterceptor (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.IORInterceptor

  • Packages that use IORInterceptor
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of IORInterceptor in org.omg.PortableInterceptor

      Subinterfaces of IORInterceptor in org.omg.PortableInterceptor
      Modifier and Type Interface and Description
      interface  IORInterceptor_3_0
      org/omg/PortableInterceptor/IORInterceptor_3_0.java .
      Methods in org.omg.PortableInterceptor with parameters of type IORInterceptor
      Modifier and Type Method and Description
      void ORBInitInfoOperations.add_ior_interceptor(IORInterceptor interceptor)
      Used to add an IOR Interceptor to the list of IOR Interceptors.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableInterceptor.IORInterceptorOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.IORInterceptorOperations

  • Packages that use IORInterceptorOperations
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of IORInterceptorOperations in org.omg.PortableInterceptor

      Subinterfaces of IORInterceptorOperations in org.omg.PortableInterceptor
      Modifier and Type Interface and Description
      interface  IORInterceptor
      Interceptor used to establish tagged components in the profiles within an IOR.
      interface  IORInterceptor_3_0
      org/omg/PortableInterceptor/IORInterceptor_3_0.java .
      interface  IORInterceptor_3_0Operations
      org/omg/PortableInterceptor/IORInterceptor_3_0Operations.java .
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableInterceptor.IORInterceptor_3_0 (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.IORInterceptor_3_0

  • Packages that use IORInterceptor_3_0
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of IORInterceptor_3_0 in org.omg.PortableInterceptor

      Fields in org.omg.PortableInterceptor declared as IORInterceptor_3_0
      Modifier and Type | Field and Description
      IORInterceptor_3_0 | IORInterceptor_3_0Holder.value
      Methods in org.omg.PortableInterceptor that return IORInterceptor_3_0
      Modifier and Type | Method and Description
      static IORInterceptor_3_0 | IORInterceptor_3_0Helper.extract(Any a)
      static IORInterceptor_3_0 | IORInterceptor_3_0Helper.narrow(Object obj)
      static IORInterceptor_3_0 | IORInterceptor_3_0Helper.read(InputStream istream)
      static IORInterceptor_3_0 | IORInterceptor_3_0Helper.unchecked_narrow(Object obj)
      Methods in org.omg.PortableInterceptor with parameters of type IORInterceptor_3_0
      Modifier and Type | Method and Description
      static void | IORInterceptor_3_0Helper.insert(Any a, IORInterceptor_3_0 that)
      static void | IORInterceptor_3_0Helper.write(OutputStream ostream, IORInterceptor_3_0 value)
      Constructors in org.omg.PortableInterceptor with parameters of type IORInterceptor_3_0
      Constructor and Description
      IORInterceptor_3_0Holder(IORInterceptor_3_0 initialValue)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableInterceptor.IORInterceptor_3_0Helper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.IORInterceptor_3_0Helper

No usage of org.omg.PortableInterceptor.IORInterceptor_3_0Helper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableInterceptor.IORInterceptor_3_0Holder (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.IORInterceptor_3_0Holder

No usage of org.omg.PortableInterceptor.IORInterceptor_3_0Holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableInterceptor.IORInterceptor_3_0Operations (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.IORInterceptor_3_0Operations

  • Packages that use IORInterceptor_3_0Operations
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of IORInterceptor_3_0Operations in org.omg.PortableInterceptor

      Subinterfaces of IORInterceptor_3_0Operations in org.omg.PortableInterceptor
      Modifier and Type Interface and Description
      interface  IORInterceptor_3_0
      org/omg/PortableInterceptor/IORInterceptor_3_0.java .
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableInterceptor.LOCATION_FORWARD (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.LOCATION_FORWARD

No usage of org.omg.PortableInterceptor.LOCATION_FORWARD
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableInterceptor.NON_EXISTENT (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.NON_EXISTENT

No usage of org.omg.PortableInterceptor.NON_EXISTENT
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableInterceptor.ObjectIdHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.ObjectIdHelper

No usage of org.omg.PortableInterceptor.ObjectIdHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableInterceptor.ObjectReferenceFactory (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.ObjectReferenceFactory

  • Packages that use ObjectReferenceFactory
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ObjectReferenceFactory in org.omg.PortableInterceptor

      Subinterfaces of ObjectReferenceFactory in org.omg.PortableInterceptor
      Modifier and Type Interface and Description
      interface  ObjectReferenceTemplate
      The object reference template.
      Fields in org.omg.PortableInterceptor declared as ObjectReferenceFactory
      Modifier and Type | Field and Description
      ObjectReferenceFactory | ObjectReferenceFactoryHolder.value
      Methods in org.omg.PortableInterceptor that return ObjectReferenceFactory
      Modifier and Type | Method and Description
      ObjectReferenceFactory IORInfoOperations.current_factory()
      On read, returns the current factory that will be used to create object references for the object adapter that was just created and is running IOR interceptors.
      static ObjectReferenceFactory | ObjectReferenceFactoryHelper.extract(Any a)
      static ObjectReferenceFactory | ObjectReferenceFactoryHelper.read(InputStream istream)
      Methods in org.omg.PortableInterceptor with parameters of type ObjectReferenceFactory
      Modifier and Type | Method and Description
      void IORInfoOperations.current_factory(ObjectReferenceFactory newCurrent_factory)
      On read, returns the current factory that will be used to create object references for the object adapter that was just created and is running IOR interceptors.
      static void | ObjectReferenceFactoryHelper.insert(Any a, ObjectReferenceFactory that)
      static void | ObjectReferenceFactoryHelper.write(OutputStream ostream, ObjectReferenceFactory value)
      Constructors in org.omg.PortableInterceptor with parameters of type ObjectReferenceFactory
      Constructor and Description
      ObjectReferenceFactoryHolder(ObjectReferenceFactory initialValue)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableInterceptor.ObjectReferenceFactoryHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.ObjectReferenceFactoryHelper

No usage of org.omg.PortableInterceptor.ObjectReferenceFactoryHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableInterceptor.ObjectReferenceFactoryHolder (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.ObjectReferenceFactoryHolder

No usage of org.omg.PortableInterceptor.ObjectReferenceFactoryHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableInterceptor.ObjectReferenceTemplate (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.ObjectReferenceTemplate

  • Packages that use ObjectReferenceTemplate
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ObjectReferenceTemplate in org.omg.PortableInterceptor

      Fields in org.omg.PortableInterceptor declared as ObjectReferenceTemplate
      Modifier and Type | Field and Description
      ObjectReferenceTemplate | ObjectReferenceTemplateHolder.value
      ObjectReferenceTemplate[] | ObjectReferenceTemplateSeqHolder.value
      Methods in org.omg.PortableInterceptor that return ObjectReferenceTemplate
      Modifier and Type | Method and Description
      ObjectReferenceTemplate IORInfoOperations.adapter_template()
      Return the object reference template of the object adapter that was just created and is running IOR interceptors.
      static ObjectReferenceTemplate | ObjectReferenceTemplateHelper.extract(Any a)
      static ObjectReferenceTemplate[] | ObjectReferenceTemplateSeqHelper.extract(Any a)
      static ObjectReferenceTemplate | ObjectReferenceTemplateHelper.read(InputStream istream)
      static ObjectReferenceTemplate[] | ObjectReferenceTemplateSeqHelper.read(InputStream istream)
      Methods in org.omg.PortableInterceptor with parameters of type ObjectReferenceTemplate
      Modifier and Type | Method and Description
      void IORInterceptor_3_0Operations.adapter_state_changed(ObjectReferenceTemplate[] templates, short state)
      Called whenever the state of an object adapter changes, and the state change is not caused by an adapter manager.
      static void | ObjectReferenceTemplateHelper.insert(Any a, ObjectReferenceTemplate that)
      static void | ObjectReferenceTemplateSeqHelper.insert(Any a, ObjectReferenceTemplate[] that)
      static void | ObjectReferenceTemplateHelper.write(OutputStream ostream, ObjectReferenceTemplate value)
      static void | ObjectReferenceTemplateSeqHelper.write(OutputStream ostream, ObjectReferenceTemplate[] value)
      Constructors in org.omg.PortableInterceptor with parameters of type ObjectReferenceTemplate
      Constructor and Description
      ObjectReferenceTemplateHolder(ObjectReferenceTemplate initialValue)
      ObjectReferenceTemplateSeqHolder(ObjectReferenceTemplate[] initialValue)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableInterceptor.ObjectReferenceTemplateHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.ObjectReferenceTemplateHelper

No usage of org.omg.PortableInterceptor.ObjectReferenceTemplateHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableInterceptor.ObjectReferenceTemplateHolder (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.ObjectReferenceTemplateHolder

No usage of org.omg.PortableInterceptor.ObjectReferenceTemplateHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper

No usage of org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder

No usage of org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableInterceptor.ORBIdHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.ORBIdHelper

No usage of org.omg.PortableInterceptor.ORBIdHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableInterceptor.ORBInitializer (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.ORBInitializer

No usage of org.omg.PortableInterceptor.ORBInitializer
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableInterceptor.ORBInitializerOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.ORBInitializerOperations

  • Packages that use ORBInitializerOperations
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ORBInitializerOperations in org.omg.PortableInterceptor

      Subinterfaces of ORBInitializerOperations in org.omg.PortableInterceptor
      Modifier and Type Interface and Description
      interface  ORBInitializer
      Facilitates interceptor registration and ORB initialization.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableInterceptor.ORBInitInfo (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.ORBInitInfo

  • Packages that use ORBInitInfo
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ORBInitInfo in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor with parameters of type ORBInitInfo
      Modifier and Type Method and Description
      void ORBInitializerOperations.post_init(ORBInitInfo info)
      Called during ORB initialization.
      void ORBInitializerOperations.pre_init(ORBInitInfo info)
      Called during ORB initialization.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableInterceptor.ORBInitInfoOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.ORBInitInfoOperations

  • Packages that use ORBInitInfoOperations
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ORBInitInfoOperations in org.omg.PortableInterceptor

      Subinterfaces of ORBInitInfoOperations in org.omg.PortableInterceptor
      Modifier and Type Interface and Description
      interface  ORBInitInfo
      Passed to each ORBInitializer, allowing it to to register interceptors and perform other duties while the ORB is initializing.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableInterceptor.PolicyFactory (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.PolicyFactory

  • Packages that use PolicyFactory
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of PolicyFactory in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor with parameters of type PolicyFactory
      Modifier and Type Method and Description
      void ORBInitInfoOperations.register_policy_factory(int type, PolicyFactory policy_factory)
      Registers a PolicyFactory for the given PolicyType.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableInterceptor.PolicyFactoryOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.PolicyFactoryOperations

  • Packages that use PolicyFactoryOperations
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of PolicyFactoryOperations in org.omg.PortableInterceptor

      Subinterfaces of PolicyFactoryOperations in org.omg.PortableInterceptor
      Modifier and Type Interface and Description
      interface  PolicyFactory
      Enables policy types to be constructed using CORBA.ORB.create_policy.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableInterceptor.RequestInfo (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.RequestInfo

  • Packages that use RequestInfo
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of RequestInfo in org.omg.PortableInterceptor

      Subinterfaces of RequestInfo in org.omg.PortableInterceptor
      Modifier and Type Interface and Description
      interface  ClientRequestInfo
      Request Information, accessible to client-side request interceptors.
      interface  ServerRequestInfo
      Request Information, accessible to server-side request interceptors.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableInterceptor.RequestInfoOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.RequestInfoOperations

  • Packages that use RequestInfoOperations
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of RequestInfoOperations in org.omg.PortableInterceptor

      Subinterfaces of RequestInfoOperations in org.omg.PortableInterceptor
      Modifier and Type Interface and Description
      interface  ClientRequestInfo
      Request Information, accessible to client-side request interceptors.
      interface  ClientRequestInfoOperations
      Request Information, accessible to client-side request interceptors.
      interface  RequestInfo
      Request Information, accessible to Interceptors.
      interface  ServerRequestInfo
      Request Information, accessible to server-side request interceptors.
      interface  ServerRequestInfoOperations
      Request Information, accessible to server-side request interceptors.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableInterceptor.ServerIdHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.ServerIdHelper

No usage of org.omg.PortableInterceptor.ServerIdHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableInterceptor.ServerRequestInfo (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.ServerRequestInfo

  • Packages that use ServerRequestInfo
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ServerRequestInfo in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor with parameters of type ServerRequestInfo
      Modifier and Type Method and Description
      void ServerRequestInterceptorOperations.receive_request_service_contexts(ServerRequestInfo ri)
      Allows the interceptor to process service context information.
      void ServerRequestInterceptorOperations.receive_request(ServerRequestInfo ri)
      Allows an Interceptor to query request information after all the information, including operation parameters, are available.
      void ServerRequestInterceptorOperations.send_exception(ServerRequestInfo ri)
      Allows an Interceptor to query the exception information and modify the reply service context before the exception is thrown to the client.
      void ServerRequestInterceptorOperations.send_other(ServerRequestInfo ri)
      Allows an Interceptor to query the information available when a request results in something other than a normal reply or an exception.
      void ServerRequestInterceptorOperations.send_reply(ServerRequestInfo ri)
      Allows an Interceptor to query reply information and modify the reply service context after the target operation has been invoked and before the reply is returned to the client.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableInterceptor.ServerRequestInfoOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.ServerRequestInfoOperations

  • Packages that use ServerRequestInfoOperations
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ServerRequestInfoOperations in org.omg.PortableInterceptor

      Subinterfaces of ServerRequestInfoOperations in org.omg.PortableInterceptor
      Modifier and Type Interface and Description
      interface  ServerRequestInfo
      Request Information, accessible to server-side request interceptors.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableInterceptor.ServerRequestInterceptor (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.ServerRequestInterceptor

  • Packages that use ServerRequestInterceptor
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ServerRequestInterceptor in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor with parameters of type ServerRequestInterceptor
      Modifier and Type Method and Description
      void ORBInitInfoOperations.add_server_request_interceptor(ServerRequestInterceptor interceptor)
      Used to add a server-side request Interceptor to the list of server-side request Interceptors.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableInterceptor.ServerRequestInterceptorOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.ServerRequestInterceptorOperations

  • Packages that use ServerRequestInterceptorOperations
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

    • Uses of ServerRequestInterceptorOperations in org.omg.PortableInterceptor

      Subinterfaces of ServerRequestInterceptorOperations in org.omg.PortableInterceptor
      Modifier and Type Interface and Description
      interface  ServerRequestInterceptor
      Server-side request interceptor.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableInterceptor.SUCCESSFUL (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.SUCCESSFUL

No usage of org.omg.PortableInterceptor.SUCCESSFUL
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableInterceptor.SYSTEM_EXCEPTION (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.SYSTEM_EXCEPTION

No usage of org.omg.PortableInterceptor.SYSTEM_EXCEPTION
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableInterceptor.TRANSPORT_RETRY (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.TRANSPORT_RETRY

No usage of org.omg.PortableInterceptor.TRANSPORT_RETRY
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableInterceptor.UNKNOWN (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.UNKNOWN

No usage of org.omg.PortableInterceptor.UNKNOWN
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableInterceptor.USER_EXCEPTION (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableInterceptor.USER_EXCEPTION

No usage of org.omg.PortableInterceptor.USER_EXCEPTION
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


ClientRequestInfo (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface ClientRequestInfo

  • All Superinterfaces:
    ClientRequestInfoOperations, IDLEntity, Object, RequestInfo, RequestInfoOperations, Serializable

    public interface ClientRequestInfo
extends ClientRequestInfoOperations, RequestInfo, IDLEntity
    Request Information, accessible to client-side request interceptors.

    Some attributes and operations on ClientRequestInfo are not valid at all interception points. The following table shows the validity of each attribute or operation. If it is not valid, attempting to access it will result in a BAD_INV_ORDER being thrown with a standard minor code of 14.

    send_request send_poll receive_reply receive_exception receive_other
    Inherited from RequestInfo:

    request_id

             yes yes yes yes yes

    operation

             yes yes yes yes yes

    arguments

             yes1 no yes no no

    exceptions

             yes no yes yes yes

    contexts

             yes no yes yes yes

    operation_context

             yes no yes yes yes

    result

             no no yes no no

    response_expected

             yes yes yes yes yes

    sync_scope

             yes no yes yes yes

    reply_status

             no no yes yes yes

    forward_reference

             no no no no yes2

    get_slot

             yes yes yes yes yes

    get_request_service_context

             yes no yes yes yes

    get_reply_service_context

             no no yes yes yes
    ClientRequestInfo-specific:

    target

             yes yes yes yes yes

    effective_target

             yes yes yes yes yes

    effective_profile

             yes yes yes yes yes

    received_exception

             no no no yes no

    received_exception_id

             no no no yes no

    get_effective_component

             yes no yes yes yes

    get_effective_components

             yes no yes yes yes

    get_request_policy

             yes no yes yes yes

    add_request_service_context

             yes no no no no
    1. When ClientRequestInfo is passed to send_request, there is an entry in the list for every argument, whether in, inout, or out. But only the in and inout arguments will be available.
    2. If the reply_status atribute is not LOCATION_FORWARD, accessing this attribute will throw BAD_INV_ORDER with a standard minor code of 14.
    See Also:
    ClientRequestInterceptor

    • Method Summary

      • Methods inherited from interface org.omg.PortableInterceptor.ClientRequestInfoOperations

        add_request_service_context, effective_profile, effective_target, get_effective_component, get_effective_components, get_request_policy, received_exception_id, received_exception, target

      • Methods inherited from interface org.omg.PortableInterceptor.RequestInfoOperations

        arguments, contexts, exceptions, forward_reference, get_reply_service_context, get_request_service_context, get_slot, operation_context, operation, reply_status, request_id, response_expected, result, sync_scope

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ClientRequestInfoOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface ClientRequestInfoOperations

  • All Superinterfaces:
    RequestInfoOperations
    All Known Subinterfaces:
    ClientRequestInfo

    public interface ClientRequestInfoOperations
extends RequestInfoOperations
    Request Information, accessible to client-side request interceptors.

    Some attributes and operations on ClientRequestInfo are not valid at all interception points. The following table shows the validity of each attribute or operation. If it is not valid, attempting to access it will result in a BAD_INV_ORDER being thrown with a standard minor code of 14.

    send_request send_poll receive_reply receive_exception receive_other
    Inherited from RequestInfo:

    request_id

             yes yes yes yes yes

    operation

             yes yes yes yes yes

    arguments

             yes1 no yes no no

    exceptions

             yes no yes yes yes

    contexts

             yes no yes yes yes

    operation_context

             yes no yes yes yes

    result

             no no yes no no

    response_expected

             yes yes yes yes yes

    sync_scope

             yes no yes yes yes

    reply_status

             no no yes yes yes

    forward_reference

             no no no no yes2

    get_slot

             yes yes yes yes yes

    get_request_service_context

             yes no yes yes yes

    get_reply_service_context

             no no yes yes yes
    ClientRequestInfo-specific:

    target

             yes yes yes yes yes

    effective_target

             yes yes yes yes yes

    effective_profile

             yes yes yes yes yes

    received_exception

             no no no yes no

    received_exception_id

             no no no yes no

    get_effective_component

             yes no yes yes yes

    get_effective_components

             yes no yes yes yes

    get_request_policy

             yes no yes yes yes

    add_request_service_context

             yes no no no no
    1. When ClientRequestInfo is passed to send_request, there is an entry in the list for every argument, whether in, inout, or out. But only the in and inout arguments will be available.
    2. If the reply_status atribute is not LOCATION_FORWARD, accessing this attribute will throw BAD_INV_ORDER with a standard minor code of 14.
    See Also:
    ClientRequestInterceptor

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void add_request_service_context(ServiceContext service_context, boolean replace)
      Allows Interceptors to add service contexts to the request.
      TaggedProfile effective_profile()
      Returns the profile that will be used to send the request.
      Object effective_target()
      Returns the actual object on which the operation will be invoked.
      TaggedComponent get_effective_component(int id)
      Returns the IOP.TaggedComponent with the given ID from the profile selected for this request.
      TaggedComponent[] get_effective_components(int id)
      Returns an array of all tagged components with the given ID from the profile selected for this request.
      Policy get_request_policy(int type)
      Returns the given policy in effect for this operation.
      String received_exception_id()
      Returns the repository id of the exception to be returned to the client.
      Any received_exception()
      Returns an any which contains the exception to be returned to the client.
      Object target()
      Returns the object which the client called to perform the operation.

      • Methods inherited from interface org.omg.PortableInterceptor.RequestInfoOperations

        arguments, contexts, exceptions, forward_reference, get_reply_service_context, get_request_service_context, get_slot, operation_context, operation, reply_status, request_id, response_expected, result, sync_scope

    • Method Detail

      • target

        Object target()
        Returns the object which the client called to perform the operation.
        See Also:
        effective_target()

      • effective_target

        Object effective_target()
        Returns the actual object on which the operation will be invoked. If the reply_status is LOCATION_FORWARD, then on subsequent requests, effective_target will contain the forwarded IOR while target will remain unchanged.
        See Also:
        target()

      • effective_profile

        TaggedProfile effective_profile()
        Returns the profile that will be used to send the request. If a location forward has occurred for this operation's object and that object's profile changed accordingly, then this profile will be that located profile.

      • received_exception

        Any received_exception()
        Returns an any which contains the exception to be returned to the client.

        If the exception is a user exception which cannot be inserted into an any (e.g., it is unknown or the bindings don t provide the TypeCode), then this attribute will be an any containing the system exception UNKNOWN with a standard minor code of 1. However, the repository id of the exception is available in the received_exception_id attribute.

        See Also:
        received_exception_id()

      • received_exception_id

        String received_exception_id()
        Returns the repository id of the exception to be returned to the client.
        See Also:
        received_exception(), PortableInterceptor package comments for limitations / unimplemented features

      • get_effective_component

        TaggedComponent get_effective_component(int id)
        Returns the IOP.TaggedComponent with the given ID from the profile selected for this request.

        If there is more than one component for a given component ID, it is undefined which component this operation returns. If there is more than one component for a given component ID, get_effective_components should be called instead.

        Parameters:
        id - The component id of the component which is to be returned.
        Returns:
        The IOP.TaggedComponent obtained with the given identifier.
        Throws:
        BAD_PARAM - thrown, with a standard minor code of 28, if no component exists for the given component ID.
        See Also:
        get_effective_components(int)

      • get_effective_components

        TaggedComponent[] get_effective_components(int id)
        Returns an array of all tagged components with the given ID from the profile selected for this request.
        Parameters:
        id - The component id of the components which are to be returned.
        Returns:
        An array of TaggedComponent objects, each of which contains the given identifier.
        Throws:
        BAD_PARAM - thrown, with a standard minor code of 28, if no component exists for the given component ID.
        See Also:
        get_effective_component(int)

      • get_request_policy

        Policy get_request_policy(int type)
        Returns the given policy in effect for this operation.
        Parameters:
        type - The policy type which specifies the policy to be returned.
        Returns:
        The CORBA.Policy obtained with the given type.
        Throws:
        INV_POLICY - thrown, with a standard minor code of 1, if the policy type is not valid either because the specified type is not supported by this ORB or because a policy object of that type is not associated with this Object
        See Also:
        PortableInterceptor package comments for limitations / unimplemented features

      • add_request_service_context

        void add_request_service_context(ServiceContext service_context,
                                 boolean replace)
        Allows Interceptors to add service contexts to the request.

        There is no declaration of the order of the service contexts. They may or may not appear in the order that they are added.

        Parameters:
        service_context - The IOP.ServiceContext to be added to the request.
        replace - Indicates the behavior of this operation when a service context already exists with the given ID. If false, then BAD_INV_ORDER with a standard minor code of 15 is thrown. If true, then the existing service context is replaced by the new one.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ClientRequestInterceptor (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface ClientRequestInterceptor

  • All Superinterfaces:
    ClientRequestInterceptorOperations, IDLEntity, Interceptor, InterceptorOperations, Object, Serializable

    public interface ClientRequestInterceptor
extends ClientRequestInterceptorOperations, Interceptor, IDLEntity
    Client-side request interceptor.

    A request Interceptor is designed to intercept the flow of a request/reply sequence through the ORB at specific points so that services can query the request information and manipulate the service contexts which are propagated between clients and servers. The primary use of request Interceptors is to enable ORB services to transfer context information between clients and servers. There are two types of request Interceptors: client-side and server-side.

    To write a client-side Interceptor, implement the ClientRequestInterceptor interface.

    See Also:
    ClientRequestInfo

    • Method Summary

      • Methods inherited from interface org.omg.PortableInterceptor.ClientRequestInterceptorOperations

        receive_exception, receive_other, receive_reply, send_poll, send_request

      • Methods inherited from interface org.omg.PortableInterceptor.InterceptorOperations

        destroy, name

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ClientRequestInterceptorOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface ClientRequestInterceptorOperations

  • All Superinterfaces:
    InterceptorOperations
    All Known Subinterfaces:
    ClientRequestInterceptor

    public interface ClientRequestInterceptorOperations
extends InterceptorOperations
    Client-side request interceptor.

    A request Interceptor is designed to intercept the flow of a request/reply sequence through the ORB at specific points so that services can query the request information and manipulate the service contexts which are propagated between clients and servers. The primary use of request Interceptors is to enable ORB services to transfer context information between clients and servers. There are two types of request Interceptors: client-side and server-side.

    To write a client-side Interceptor, implement the ClientRequestInterceptor interface.

    See Also:
    ClientRequestInfo

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void receive_exception(ClientRequestInfo ri)
      Indicates to the interceptor that an exception occurred.
      void receive_other(ClientRequestInfo ri)
      Allows an Interceptor to query the information available when a request results in something other than a normal reply or an exception.
      void receive_reply(ClientRequestInfo ri)
      Allows an Interceptor to query the information on a reply after it is returned from the server and before control is returned to the client.
      void send_poll(ClientRequestInfo ri)
      Allows an Interceptor to query information during a Time-Independent Invocation (TII) polling get reply sequence.
      void send_request(ClientRequestInfo ri)
      Allows an Interceptor to query request information and modify the service context before the request is sent to the server.

      • Methods inherited from interface org.omg.PortableInterceptor.InterceptorOperations

        destroy, name

    • Method Detail

      • send_request

        void send_request(ClientRequestInfo ri)
           throws ForwardRequest
        Allows an Interceptor to query request information and modify the service context before the request is sent to the server.

        This interception point may throw a system exception. If it does, no other Interceptors' send_request operations are called. Those Interceptors on the Flow Stack are popped and their receive_exception interception points are called. This interception point may also throw a ForwardRequest exception. If an Interceptor throws this exception, no other Interceptors' send_request operations are called. Those Interceptors on the Flow Stack are popped and their receive_other interception points are called.

        Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. The completion_status shall be COMPLETED_NO.

        Parameters:
        ri - Information about the current request being intercepted.
        Throws:
        ForwardRequest - If thrown, indicates to the ORB that a retry of the request should occur with the new object given in the exception.

      • send_poll

        void send_poll(ClientRequestInfo ri)
        Allows an Interceptor to query information during a Time-Independent Invocation (TII) polling get reply sequence.

        With TII, an application may poll for a response to a request sent previously by the polling client or some other client. This poll is reported to Interceptors through the send_poll interception point and the response is returned through the receive_reply or receive_exception interception points. If the response is not available before the poll time-out expires, the system exception TIMEOUT is thrown and receive_exception is called with this exception.

        This interception point may throw a system exception. If it does, no other Interceptors' send_poll operations are called. Those Interceptors on the Flow Stack are popped and their receive_exception interception points are called.

        Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. The completion_status shall be COMPLETED_NO.

        Parameters:
        ri - Information about the current request being intercepted.
        Throws:
        TIMEOUT - thrown if the response is not available before the poll time-out expires

      • receive_reply

        void receive_reply(ClientRequestInfo ri)
        Allows an Interceptor to query the information on a reply after it is returned from the server and before control is returned to the client.

        This interception point may throw a system exception. If it does, no other Interceptors' receive_reply operations are called. The remaining Interceptors in the Flow Stack shall have their receive_exception interception point called.

        Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. The completion_status shall be COMPLETED_YES.

        Parameters:
        ri - Information about the current request being intercepted.

      • receive_exception

        void receive_exception(ClientRequestInfo ri)
                throws ForwardRequest
        Indicates to the interceptor that an exception occurred. Allows an Interceptor to query the exception's information before it is thrown to the client.

        This interception point may throw a system exception. This has the effect of changing the exception which successive Interceptors popped from the Flow Stack receive on their calls to receive_exception. The exception thrown to the client will be the last exception thrown by an Interceptor, or the original exception if no Interceptor changes the exception.

        This interception point may also throw a ForwardRequest exception. If an Interceptor throws this exception, no other Interceptors' receive_exception operations are called. The remaining Interceptors in the Flow Stack are popped and have their receive_other interception point called.

        If the completion_status of the exception is not COMPLETED_NO, then it is inappropriate for this interception point to throw a ForwardRequest exception. The request s at-most-once semantics would be lost.

        Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. If the original exception is a system exception, the completion_status of the new exception shall be the same as on the original. If the original exception is a user exception, then the completion_status of the new exception shall be COMPLETED_YES.

        Under some conditions, depending on what policies are in effect, an exception (such as COMM_FAILURE) may result in a retry of the request. While this retry is a new request with respect to Interceptors, there is one point of correlation between the original request and the retry: because control has not returned to the client, the PortableInterceptor.Current for both the original request and the retrying request is the same.

        Parameters:
        ri - Information about the current request being intercepted.
        Throws:
        ForwardRequest - If thrown, indicates to the ORB that a retry of the request should occur with the new object given in the exception.

      • receive_other

        void receive_other(ClientRequestInfo ri)
            throws ForwardRequest
        Allows an Interceptor to query the information available when a request results in something other than a normal reply or an exception. For example, a request could result in a retry (e.g., a GIOP Reply with a LOCATION_FORWARD status was received); or on asynchronous calls, the reply does not immediately follow the request, but control shall return to the client and an ending interception point shall be called.

        For retries, depending on the policies in effect, a new request may or may not follow when a retry has been indicated. If a new request does follow, while this request is a new request, with respect to Interceptors, there is one point of correlation between the original request and the retry: because control has not returned to the client, the request scoped PortableInterceptor.Current for both the original request and the retrying request is the same.

        This interception point may throw a system exception. If it does, no other Interceptors' receive_other operations are called. The remaining Interceptors in the Flow Stack are popped and have their receive_exception interception point called.

        This interception point may also throw a ForwardRequest exception. If an Interceptor throws this exception, successive Interceptors' receive_other operations are called with the new information provided by the ForwardRequest exception.

        Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. The completion_status shall be COMPLETED_NO. If the target invocation had completed, this interception point would not be called.

        Parameters:
        ri - Information about the current request being intercepted.
        Throws:
        ForwardRequest - If thrown, indicates to the ORB that a retry of the request should occur with the new object given in the exception.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Current (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface Current

  • All Superinterfaces:
    Current, CurrentOperations, IDLEntity, Object, Serializable

    public interface Current
extends CurrentOperations, Current, IDLEntity
    Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context. Each service which wishes to use PICurrent reserves a slot or slots at initialization time and uses those slots during the processing of requests and replies.

    Before an invocation is made, PICurrent is obtained via a call to ORB.resolve_initial_references( "PICurrent" ). From within the interception points, the data on PICurrent that has moved from the thread scope to the request scope is available via the get_slot operation on the RequestInfo object. A PICurrent can still be obtained via resolve_initial_references, but that is the Interceptor's thread scope PICurrent.

    • Method Summary

      • Methods inherited from interface org.omg.PortableInterceptor.CurrentOperations

        get_slot, set_slot

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CurrentHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Class CurrentHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.CurrentHelper

  • public abstract class CurrentHelper
extends Object
    Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context. Each service which wishes to use PICurrent reserves a slot or slots at initialization time and uses those slots during the processing of requests and replies.

    Before an invocation is made, PICurrent is obtained via a call to ORB.resolve_initial_references( "PICurrent" ). From within the interception points, the data on PICurrent that has moved from the thread scope to the request scope is available via the get_slot operation on the RequestInfo object. A PICurrent can still be obtained via resolve_initial_references, but that is the Interceptor's thread scope PICurrent.

    • Constructor Summary

      Constructors
      Constructor and Description
      CurrentHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static Current | extract(Any a)
      static String | id()
      static void | insert(Any a, Current that)
      static Current | narrow(Object obj)
      static Current | read(InputStream istream)
      static TypeCode | type()
      static Current | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, Current value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • CurrentHelper

        public CurrentHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          Current that)

      • extract

        public static Current extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static Current read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         Current value)

      • narrow

        public static Current narrow(Object obj)

      • unchecked_narrow

        public static Current unchecked_narrow(Object obj)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CurrentOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface CurrentOperations

  • All Superinterfaces:
    CurrentOperations
    All Known Subinterfaces:
    Current

    public interface CurrentOperations
extends CurrentOperations
    Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context. Each service which wishes to use PICurrent reserves a slot or slots at initialization time and uses those slots during the processing of requests and replies.

    Before an invocation is made, PICurrent is obtained via a call to ORB.resolve_initial_references( "PICurrent" ). From within the interception points, the data on PICurrent that has moved from the thread scope to the request scope is available via the get_slot operation on the RequestInfo object. A PICurrent can still be obtained via resolve_initial_references, but that is the Interceptor's thread scope PICurrent.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Any get_slot(int id)
      Retrieves the slot data the application set in PICurrent via get_slot.
      void set_slot(int id, Any data)
      Sets data in a slot.

    • Method Detail

      • get_slot

        Any get_slot(int id)
      throws InvalidSlot
        Retrieves the slot data the application set in PICurrent via get_slot. The data is in the form of an Any.

        If the given slot has not been set, an Any containing a type code with a TCKind value of tk_null and no value is returned.

        Parameters:
        id - The SlotId of the slot from which the data will be returned.
        Returns:
        The data, in the form of an Any, of the given slot identifier.
        Throws:
        InvalidSlot - thrown if get_slot is called on a slot that has not been allocated.
        BAD_INV_ORDER - thrown if get_slot is called from within an ORB initializer

      • set_slot

        void set_slot(int id,
              Any data)
       throws InvalidSlot
        Sets data in a slot. The data is in the form of an Any. If data already exists in that slot, it is overridden.
        Parameters:
        id - The SlotId of the slot to which the data will be set.
        data - The data, in the form of an Any, which will be set to the identified slot.
        Throws:
        InvalidSlot - thrown if set_slot is called on a slot that has not been allocated.
        BAD_INV_ORDER - thrown if set_slot is called from within an ORB initializer.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DISCARDING (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface DISCARDING

  • public interface DISCARDING
    org/omg/PortableInterceptor/DISCARDING.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short value
      Object adapter state that causes all requests to be discarded.

    • Field Detail

      • value

        static final short value
        Object adapter state that causes all requests to be discarded.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ForwardRequest (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Class ForwardRequest

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableInterceptor.ForwardRequest
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class ForwardRequest
extends UserException
    org/omg/PortableInterceptor/ForwardRequest.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      Object forward
      The new object to forward the request to.

    • Constructor Summary

      Constructors
      Constructor and Description
      ForwardRequest()
      ForwardRequest(Object _forward)
      ForwardRequest(String $reason, Object _forward)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • forward

        public Object forward
        The new object to forward the request to.

    • Constructor Detail

      • ForwardRequest

        public ForwardRequest()

      • ForwardRequest

        public ForwardRequest(Object _forward)

      • ForwardRequest

        public ForwardRequest(String $reason,
                      Object _forward)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ForwardRequestHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Class ForwardRequestHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.ForwardRequestHelper

  • public abstract class ForwardRequestHelper
extends Object
    org/omg/PortableInterceptor/ForwardRequestHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      ForwardRequestHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static ForwardRequest | extract(Any a)
      static String | id()
      static void | insert(Any a, ForwardRequest that)
      static ForwardRequest | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, ForwardRequest value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ForwardRequestHelper

        public ForwardRequestHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          ForwardRequest that)

      • extract

        public static ForwardRequest extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ForwardRequest read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         ForwardRequest value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


HOLDING (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface HOLDING

  • public interface HOLDING
    org/omg/PortableInterceptor/HOLDING.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short value
      Object adapter state that holds requests temporarily until the state is changed.

    • Field Detail

      • value

        static final short value
        Object adapter state that holds requests temporarily until the state is changed.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


INACTIVE (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface INACTIVE

  • public interface INACTIVE
    org/omg/PortableInterceptor/INACTIVE.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short value
      Object adapter state that causes all requests to be discarded.

    • Field Detail

      • value

        static final short value
        Object adapter state that causes all requests to be discarded. This state indicates that the adapter is shutting down.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Interceptor (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface Interceptor

  • All Superinterfaces:
    IDLEntity, InterceptorOperations, Object, Serializable
    All Known Subinterfaces:
    ClientRequestInterceptor, IORInterceptor, IORInterceptor_3_0, ServerRequestInterceptor

    public interface Interceptor
extends InterceptorOperations, Object, IDLEntity
    All Portable Interceptors implement Interceptor.

    • Method Summary

      • Methods inherited from interface org.omg.PortableInterceptor.InterceptorOperations

        destroy, name

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


InterceptorOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface InterceptorOperations

  • All Known Subinterfaces:
    ClientRequestInterceptor, ClientRequestInterceptorOperations, Interceptor, IORInterceptor, IORInterceptor_3_0, IORInterceptor_3_0Operations, IORInterceptorOperations, ServerRequestInterceptor, ServerRequestInterceptorOperations

    public interface InterceptorOperations
    All Portable Interceptors implement Interceptor.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void destroy()
      Provides an opportunity to destroy this interceptor.
      String name()
      Returns the name of the interceptor.

    • Method Detail

      • name

        String name()
        Returns the name of the interceptor.

        Each Interceptor may have a name that may be used administratively to order the lists of Interceptors. Only one Interceptor of a given name can be registered with the ORB for each Interceptor type. An Interceptor may be anonymous, i.e., have an empty string as the name attribute. Any number of anonymous Interceptors may be registered with the ORB.

        Returns:
        the name of the interceptor.

      • destroy

        void destroy()
        Provides an opportunity to destroy this interceptor. The destroy method is called during ORB.destroy. When an application calls ORB.destroy, the ORB:
        1. waits for all requests in progress to complete
        2. calls the Interceptor.destroy operation for each interceptor
        3. completes destruction of the ORB
        Method invocations from within Interceptor.destroy on object references for objects implemented on the ORB being destroyed result in undefined behavior. However, method invocations on objects implemented on an ORB other than the one being destroyed are permitted. (This means that the ORB being destroyed is still capable of acting as a client, but not as a server.)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


InvalidSlot (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Class InvalidSlot

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableInterceptor.InvalidSlot
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class InvalidSlot
extends UserException
    org/omg/PortableInterceptor/InvalidSlot.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      InvalidSlot()
      InvalidSlot(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • InvalidSlot

        public InvalidSlot()

      • InvalidSlot

        public InvalidSlot(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


InvalidSlotHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Class InvalidSlotHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.InvalidSlotHelper

  • public abstract class InvalidSlotHelper
extends Object
    org/omg/PortableInterceptor/InvalidSlotHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      InvalidSlotHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static InvalidSlot | extract(Any a)
      static String | id()
      static void | insert(Any a, InvalidSlot that)
      static InvalidSlot | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, InvalidSlot value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • InvalidSlotHelper

        public InvalidSlotHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          InvalidSlot that)

      • extract

        public static InvalidSlot extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static InvalidSlot read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         InvalidSlot value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


IORInfo (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface IORInfo

  • All Superinterfaces:
    IDLEntity, IORInfoOperations, Object, Serializable

    public interface IORInfo
extends IORInfoOperations, Object, IDLEntity
    Provides the server-side ORB service with access to the applicable policies during IOR construction and the ability to add components. The ORB passes an instance of its implementation of this interface as a parameter to IORInterceptor.establish_components.
    See Also:
    IORInterceptor

    • Method Summary

      • Methods inherited from interface org.omg.PortableInterceptor.IORInfoOperations

        adapter_template, add_ior_component_to_profile, add_ior_component, current_factory, current_factory, get_effective_policy, manager_id, state

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


IORInfoOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface IORInfoOperations

  • All Known Subinterfaces:
    IORInfo

    public interface IORInfoOperations
    Provides the server-side ORB service with access to the applicable policies during IOR construction and the ability to add components. The ORB passes an instance of its implementation of this interface as a parameter to IORInterceptor.establish_components.
    See Also:
    IORInterceptor

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      ObjectReferenceTemplate adapter_template()
      Return the object reference template of the object adapter that was just created and is running IOR interceptors.
      void add_ior_component_to_profile(TaggedComponent tagged_component, int profile_id)
      A portable ORB service implementation calls add_ior_component_to_profile from its implementation of establish_components to add a tagged component to the set which will be included when constructing IORs.
      void add_ior_component(TaggedComponent tagged_component)
      A portable ORB service implementation calls add_ior_component from its implementation of establish_components to add a tagged component to the set which will be included when constructing IORs.
      ObjectReferenceFactory current_factory()
      On read, returns the current factory that will be used to create object references for the object adapter that was just created and is running IOR interceptors.
      void current_factory(ObjectReferenceFactory newCurrent_factory)
      On read, returns the current factory that will be used to create object references for the object adapter that was just created and is running IOR interceptors.
      Policy get_effective_policy(int type)
      Allows an ORB service implementation to determine what server side policy of a particular type is in effect for an IOR being constructed.
      int manager_id()
      Return the adapter manager id of the object adapter that was just created and is running IOR interceptors.
      short state()
      Return the adapter state of the object adapter that was just created and is running IOR interceptors.

    • Method Detail

      • get_effective_policy

        Policy get_effective_policy(int type)
        Allows an ORB service implementation to determine what server side policy of a particular type is in effect for an IOR being constructed. When the IOR being constructed is for an object implemented using a POA, all Policy objects passed to the PortableServer.POA.create_POA call that created that POA are accessable via get_effective_policy.

        If a policy for the given type is not known to the ORB, then this operation will throw INV_POLICY with a standard minor code of 2.

        Parameters:
        type - an int specifying the type of policy to return.
        Returns:
        The effective CORBA.Policy object of the requested type. If the given policy type is known, but no policy of that type is in effect, then this operation will return a nil object reference.

      • add_ior_component

        void add_ior_component(TaggedComponent tagged_component)
        A portable ORB service implementation calls add_ior_component from its implementation of establish_components to add a tagged component to the set which will be included when constructing IORs. The components in this set will be included in all profiles.

        Any number of components may exist with the same component ID.

        Parameters:
        tagged_component - The IOP.TaggedComponent to add.

      • add_ior_component_to_profile

        void add_ior_component_to_profile(TaggedComponent tagged_component,
                                  int profile_id)
        A portable ORB service implementation calls add_ior_component_to_profile from its implementation of establish_components to add a tagged component to the set which will be included when constructing IORs. The components in this set will be included in the specified profile.

        Any number of components may exist with the same component ID.

        Parameters:
        tagged_component - The IOP.TaggedComponent to add.
        profile_id - The profile id of the profile to which this component will be added.
        Throws:
        BAD_PARAM - thrown, with a standard minor code of 29, if the given profile ID does not define a known profile or it is impossible to add components to that profile.

      • manager_id

        int manager_id()
        Return the adapter manager id of the object adapter that was just created and is running IOR interceptors.

      • state

        short state()
        Return the adapter state of the object adapter that was just created and is running IOR interceptors.

      • adapter_template

        ObjectReferenceTemplate adapter_template()
        Return the object reference template of the object adapter that was just created and is running IOR interceptors.

      • current_factory

        ObjectReferenceFactory current_factory()
        On read, returns the current factory that will be used to create object references for the object adapter that was just created and is running IOR interceptors. By default, this factory is the same as the value of the adapter_template attribute. The current_factory may also be set to another object reference template inside an IORInterceptor_3_0.

      • current_factory

        void current_factory(ObjectReferenceFactory newCurrent_factory)
        On read, returns the current factory that will be used to create object references for the object adapter that was just created and is running IOR interceptors. By default, this factory is the same as the value of the adapter_template attribute. The current_factory may also be set to another object reference template inside an IORInterceptor_3_0.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


IORInterceptor (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface IORInterceptor

  • All Superinterfaces:
    IDLEntity, Interceptor, InterceptorOperations, IORInterceptorOperations, Object, Serializable
    All Known Subinterfaces:
    IORInterceptor_3_0

    public interface IORInterceptor
extends IORInterceptorOperations, Interceptor, IDLEntity
    Interceptor used to establish tagged components in the profiles within an IOR.

    In some cases, a portable ORB service implementation may need to add information describing the server's or object's ORB service related capabilities to object references in order to enable the ORB service implementation in the client to function properly.

    This is supported through the IORInterceptor and IORInfo interfaces.

    See Also:
    IORInfo

    • Method Summary

      • Methods inherited from interface org.omg.PortableInterceptor.IORInterceptorOperations

        establish_components

      • Methods inherited from interface org.omg.PortableInterceptor.InterceptorOperations

        destroy, name

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


IORInterceptorOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface IORInterceptorOperations

  • All Superinterfaces:
    InterceptorOperations
    All Known Subinterfaces:
    IORInterceptor, IORInterceptor_3_0, IORInterceptor_3_0Operations

    public interface IORInterceptorOperations
extends InterceptorOperations
    Interceptor used to establish tagged components in the profiles within an IOR.

    In some cases, a portable ORB service implementation may need to add information describing the server's or object's ORB service related capabilities to object references in order to enable the ORB service implementation in the client to function properly.

    This is supported through the IORInterceptor and IORInfo interfaces.

    See Also:
    IORInfo

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void establish_components(IORInfo info)
      A server side ORB calls the establish_components operation on all registered IORInterceptor instances when it is assembling the list of components that will be included in the profile or profiles of an object reference.

      • Methods inherited from interface org.omg.PortableInterceptor.InterceptorOperations

        destroy, name

    • Method Detail

      • establish_components

        void establish_components(IORInfo info)
        A server side ORB calls the establish_components operation on all registered IORInterceptor instances when it is assembling the list of components that will be included in the profile or profiles of an object reference. This operation is not necessarily called for each individual object reference. In the case of the POA, this operation is called each time POA::create_POA is called. In any case, establish_components is guaranteed to be called at least once for each distinct set of server policies.

        An implementation of establish_components must not throw exceptions. If it does, the ORB shall ignore the exception and proceed to call the next IOR Interceptor's establish_components operation.

        Parameters:
        info - The IORInfo instance used by the ORB service to query applicable policies and add components to be included in the generated IORs.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


IORInterceptor_3_0 (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface IORInterceptor_3_0

  • All Superinterfaces:
    IDLEntity, Interceptor, InterceptorOperations, IORInterceptor, IORInterceptor_3_0Operations, IORInterceptorOperations, Object, Serializable

    public interface IORInterceptor_3_0
extends IORInterceptor_3_0Operations, IORInterceptor, IDLEntity
    org/omg/PortableInterceptor/IORInterceptor_3_0.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Method Summary

      • Methods inherited from interface org.omg.PortableInterceptor.IORInterceptor_3_0Operations

        adapter_manager_state_changed, adapter_state_changed, components_established

      • Methods inherited from interface org.omg.PortableInterceptor.IORInterceptorOperations

        establish_components

      • Methods inherited from interface org.omg.PortableInterceptor.InterceptorOperations

        destroy, name

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


IORInterceptor_3_0Helper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Class IORInterceptor_3_0Helper

  • java.lang.Object
    • org.omg.PortableInterceptor.IORInterceptor_3_0Helper

  • public abstract class IORInterceptor_3_0Helper
extends Object
    org/omg/PortableInterceptor/IORInterceptor_3_0Helper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      IORInterceptor_3_0Helper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static IORInterceptor_3_0 | extract(Any a)
      static String | id()
      static void | insert(Any a, IORInterceptor_3_0 that)
      static IORInterceptor_3_0 | narrow(Object obj)
      static IORInterceptor_3_0 | read(InputStream istream)
      static TypeCode | type()
      static IORInterceptor_3_0 | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, IORInterceptor_3_0 value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • IORInterceptor_3_0Helper

        public IORInterceptor_3_0Helper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          IORInterceptor_3_0 that)

      • extract

        public static IORInterceptor_3_0 extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static IORInterceptor_3_0 read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         IORInterceptor_3_0 value)

      • narrow

        public static IORInterceptor_3_0 narrow(Object obj)

      • unchecked_narrow

        public static IORInterceptor_3_0 unchecked_narrow(Object obj)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


IORInterceptor_3_0Holder (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Class IORInterceptor_3_0Holder

  • java.lang.Object
    • org.omg.PortableInterceptor.IORInterceptor_3_0Holder
  • All Implemented Interfaces:
    Streamable

    public final class IORInterceptor_3_0Holder
extends Object
implements Streamable
    org/omg/PortableInterceptor/IORInterceptor_3_0Holder.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      IORInterceptor_3_0 value

    • Constructor Summary

      Constructors
      Constructor and Description
      IORInterceptor_3_0Holder()
      IORInterceptor_3_0Holder(IORInterceptor_3_0 initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public IORInterceptor_3_0 value

    • Constructor Detail

      • IORInterceptor_3_0Holder

        public IORInterceptor_3_0Holder()

      • IORInterceptor_3_0Holder

        public IORInterceptor_3_0Holder(IORInterceptor_3_0 initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


IORInterceptor_3_0Operations (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface IORInterceptor_3_0Operations

  • All Superinterfaces:
    InterceptorOperations, IORInterceptorOperations
    All Known Subinterfaces:
    IORInterceptor_3_0

    public interface IORInterceptor_3_0Operations
extends IORInterceptorOperations
    org/omg/PortableInterceptor/IORInterceptor_3_0Operations.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void adapter_manager_state_changed(int id, short state)
      Called whenever the state of an adapter manager changes.
      void adapter_state_changed(ObjectReferenceTemplate[] templates, short state)
      Called whenever the state of an object adapter changes, and the state change is not caused by an adapter manager.
      void components_established(IORInfo info)
      The components_established method is invoked on all registered IORInterceptor_3_0 instances after establish_components has been invoked on all registered IORInterceptor instances.

      • Methods inherited from interface org.omg.PortableInterceptor.IORInterceptorOperations

        establish_components

      • Methods inherited from interface org.omg.PortableInterceptor.InterceptorOperations

        destroy, name

    • Method Detail

      • components_established

        void components_established(IORInfo info)
        The components_established method is invoked on all registered IORInterceptor_3_0 instances after establish_components has been invoked on all registered IORInterceptor instances. The adapter_template is available in info during this call. The current_factory may be get or set in info during this call.

        Any exception thrown from this method is handled by the Object Adapter that called this interceptor. In the case of the POA, an exception results in a OBJ_ADAPTER exception with an OMG standard minor code of 6.

        Parameters:
        info - The IORInfo for the object adapter being created.

      • adapter_manager_state_changed

        void adapter_manager_state_changed(int id,
                                   short state)
        Called whenever the state of an adapter manager changes. For the POA, that is the POAManager. If the state change is reported through adapter_manager_state_changed, it is not reported through adapter_state_changed.
        Parameters:
        id - the adapter manager id of the adapter manager that changed state
        state - the new state of the adapter manager

      • adapter_state_changed

        void adapter_state_changed(ObjectReferenceTemplate[] templates,
                           short state)
        Called whenever the state of an object adapter changes, and the state change is not caused by an adapter manager. Such changes are reported to all registered IORInterceptor_3_0 instances.
        Parameters:
        templates - the sequence of ObjectReferenceTemplate instances on which this state change occurred.
        state - the new AdapterState shared by all of the templates.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


LOCATION_FORWARD (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface LOCATION_FORWARD

  • public interface LOCATION_FORWARD
    org/omg/PortableInterceptor/LOCATION_FORWARD.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short value
      Indicates a LocationForward reply status.

    • Field Detail

      • value

        static final short value
        Indicates a LocationForward reply status. One possible value for RequestInfo.reply_status.
        See Also:
        RequestInfoOperations.reply_status(), SUCCESSFUL, SYSTEM_EXCEPTION, USER_EXCEPTION, TRANSPORT_RETRY, Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NON_EXISTENT (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface NON_EXISTENT

  • public interface NON_EXISTENT
    org/omg/PortableInterceptor/NON_EXISTENT.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short value
      Object adapter state indicating that the adapter has been destroyed.

    • Field Detail

      • value

        static final short value
        Object adapter state indicating that the adapter has been destroyed.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ObjectIdHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Class ObjectIdHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.ObjectIdHelper

  • public abstract class ObjectIdHelper
extends Object
    Type of an object id. This provides the identity of a particular object that was created by an object adapter.

    • Constructor Summary

      Constructors
      Constructor and Description
      ObjectIdHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static byte[] | extract(Any a)
      static String | id()
      static void | insert(Any a, byte[] that)
      static byte[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, byte[] value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ObjectIdHelper

        public ObjectIdHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          byte[] that)

      • extract

        public static byte[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static byte[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         byte[] value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ObjectReferenceFactory (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface ObjectReferenceFactory

  • All Superinterfaces:
    IDLEntity, Serializable, ValueBase
    All Known Subinterfaces:
    ObjectReferenceTemplate

    public interface ObjectReferenceFactory
extends ValueBase
    The object reference factory. This provides the capability of creating an object reference.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Object make_object(String repositoryId, byte[] object_id)
      make_object creates a CORBA object reference according to the data in this template, with the given repository ID and object ID.

      • Methods inherited from interface org.omg.CORBA.portable.ValueBase

        _truncatable_ids

    • Method Detail

      • make_object

        Object make_object(String repositoryId,
                   byte[] object_id)
        make_object creates a CORBA object reference according to the data in this template, with the given repository ID and object ID.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ObjectReferenceFactoryHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Class ObjectReferenceFactoryHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.ObjectReferenceFactoryHelper

  • public abstract class ObjectReferenceFactoryHelper
extends Object
    The object reference factory. This provides the capability of creating an object reference.

    • Constructor Summary

      Constructors
      Constructor and Description
      ObjectReferenceFactoryHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static ObjectReferenceFactory | extract(Any a)
      static String | id()
      static void | insert(Any a, ObjectReferenceFactory that)
      static ObjectReferenceFactory | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, ObjectReferenceFactory value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ObjectReferenceFactoryHelper

        public ObjectReferenceFactoryHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          ObjectReferenceFactory that)

      • extract

        public static ObjectReferenceFactory extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ObjectReferenceFactory read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         ObjectReferenceFactory value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ObjectReferenceFactoryHolder (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Class ObjectReferenceFactoryHolder

  • java.lang.Object
    • org.omg.PortableInterceptor.ObjectReferenceFactoryHolder
  • All Implemented Interfaces:
    Streamable

    public final class ObjectReferenceFactoryHolder
extends Object
implements Streamable
    The object reference factory. This provides the capability of creating an object reference.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      ObjectReferenceFactory value

    • Constructor Summary

      Constructors
      Constructor and Description
      ObjectReferenceFactoryHolder()
      ObjectReferenceFactoryHolder(ObjectReferenceFactory initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public ObjectReferenceFactory value

    • Constructor Detail

      • ObjectReferenceFactoryHolder

        public ObjectReferenceFactoryHolder()

      • ObjectReferenceFactoryHolder

        public ObjectReferenceFactoryHolder(ObjectReferenceFactory initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ObjectReferenceTemplate (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface ObjectReferenceTemplate

  • All Superinterfaces:
    IDLEntity, ObjectReferenceFactory, Serializable, ValueBase

    public interface ObjectReferenceTemplate
extends ObjectReferenceFactory
    The object reference template. An instance of this must exist for each object adapter created in an ORB. The server_id, orb_id, and adapter_name attributes uniquely identify this template within the scope of an IMR. Note that adapter_id is similarly unique within the same scope, but it is opaque, and less useful in many cases.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String[] adapter_name()
      String orb_id()
      String server_id()

      • Methods inherited from interface org.omg.PortableInterceptor.ObjectReferenceFactory

        make_object

      • Methods inherited from interface org.omg.CORBA.portable.ValueBase

        _truncatable_ids

    • Method Detail

      • server_id

        String server_id()

      • orb_id

        String orb_id()

      • adapter_name

        String[] adapter_name()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ObjectReferenceTemplateHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Class ObjectReferenceTemplateHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.ObjectReferenceTemplateHelper

  • public abstract class ObjectReferenceTemplateHelper
extends Object
    The object reference template. An instance of this must exist for each object adapter created in an ORB. The server_id, orb_id, and adapter_name attributes uniquely identify this template within the scope of an IMR. Note that adapter_id is similarly unique within the same scope, but it is opaque, and less useful in many cases.

    • Constructor Summary

      Constructors
      Constructor and Description
      ObjectReferenceTemplateHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static ObjectReferenceTemplate | extract(Any a)
      static String | id()
      static void | insert(Any a, ObjectReferenceTemplate that)
      static ObjectReferenceTemplate | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, ObjectReferenceTemplate value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ObjectReferenceTemplateHelper

        public ObjectReferenceTemplateHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          ObjectReferenceTemplate that)

      • extract

        public static ObjectReferenceTemplate extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ObjectReferenceTemplate read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         ObjectReferenceTemplate value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ObjectReferenceTemplateHolder (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Class ObjectReferenceTemplateHolder

  • java.lang.Object
    • org.omg.PortableInterceptor.ObjectReferenceTemplateHolder
  • All Implemented Interfaces:
    Streamable

    public final class ObjectReferenceTemplateHolder
extends Object
implements Streamable
    The object reference template. An instance of this must exist for each object adapter created in an ORB. The server_id, orb_id, and adapter_name attributes uniquely identify this template within the scope of an IMR. Note that adapter_id is similarly unique within the same scope, but it is opaque, and less useful in many cases.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      ObjectReferenceTemplate value

    • Constructor Summary

      Constructors
      Constructor and Description
      ObjectReferenceTemplateHolder()
      ObjectReferenceTemplateHolder(ObjectReferenceTemplate initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public ObjectReferenceTemplate value

    • Constructor Detail

      • ObjectReferenceTemplateHolder

        public ObjectReferenceTemplateHolder()

      • ObjectReferenceTemplateHolder

        public ObjectReferenceTemplateHolder(ObjectReferenceTemplate initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ObjectReferenceTemplateSeqHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Class ObjectReferenceTemplateSeqHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper

  • public abstract class ObjectReferenceTemplateSeqHelper
extends Object
    Sequence of object reference templates is used for reporting state changes that do not occur on the adapter manager.

    • Constructor Summary

      Constructors
      Constructor and Description
      ObjectReferenceTemplateSeqHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static ObjectReferenceTemplate[] | extract(Any a)
      static String | id()
      static void | insert(Any a, ObjectReferenceTemplate[] that)
      static ObjectReferenceTemplate[] | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, ObjectReferenceTemplate[] value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ObjectReferenceTemplateSeqHelper

        public ObjectReferenceTemplateSeqHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          ObjectReferenceTemplate[] that)

      • extract

        public static ObjectReferenceTemplate[] extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ObjectReferenceTemplate[] read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         ObjectReferenceTemplate[] value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ObjectReferenceTemplateSeqHolder (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Class ObjectReferenceTemplateSeqHolder

  • java.lang.Object
    • org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder
  • All Implemented Interfaces:
    Streamable

    public final class ObjectReferenceTemplateSeqHolder
extends Object
implements Streamable
    Sequence of object reference templates is used for reporting state changes that do not occur on the adapter manager.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      ObjectReferenceTemplate[] value

    • Constructor Summary

      Constructors
      Constructor and Description
      ObjectReferenceTemplateSeqHolder()
      ObjectReferenceTemplateSeqHolder(ObjectReferenceTemplate[] initialValue)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream i)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream o)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public ObjectReferenceTemplate[] value

    • Constructor Detail

      • ObjectReferenceTemplateSeqHolder

        public ObjectReferenceTemplateSeqHolder()

      • ObjectReferenceTemplateSeqHolder

        public ObjectReferenceTemplateSeqHolder(ObjectReferenceTemplate[] initialValue)

    • Method Detail

      • _read

        public void _read(InputStream i)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        i - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream o)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        o - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ORBIdHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Class ORBIdHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.ORBIdHelper

  • public abstract class ORBIdHelper
extends Object
    org/omg/PortableInterceptor/ORBIdHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      ORBIdHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static String | extract(Any a)
      static String | id()
      static void | insert(Any a, String that)
      static String | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, String value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ORBIdHelper

        public ORBIdHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          String that)

      • extract

        public static String extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         String value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ORBInitializer (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface ORBInitializer

  • All Superinterfaces:
    IDLEntity, Object, ORBInitializerOperations, Serializable

    public interface ORBInitializer
extends ORBInitializerOperations, Object, IDLEntity
    Facilitates interceptor registration and ORB initialization.

    Interceptors are intended to be a means by which ORB services gain access to ORB processing, effectively becoming part of the ORB. Since Interceptors are part of the ORB, when ORB.init returns an ORB, the Interceptors shall have been registered. Interceptors cannot be registered on an ORB after it has been returned by a call to ORB.init.

    An Interceptor is registered by registering an associated ORBInitializer object which implements the ORBInitializer interface. When an ORB is initializing, it shall call each registered ORBInitializer, passing it an ORBInitInfo object which is used to register its Interceptor.

    Registering ORB Initializers in Java

    ORBInitializers are registered via Java ORB properties.

    The property names are of the form:

    org.omg.PortableInterceptor.ORBInitializerClass.<Service>
    where <Service> is the string name of a class which implements
    org.omg.PortableInterceptor.ORBInitializer
    To avoid name collisions, the reverse DNS name convention should be used. For example, if company X has three initializers, it could define the following properties:
    • org.omg.PortableInterceptor.ORBInitializerClass.com.x.Init1
    • org.omg.PortableInterceptor.ORBInitializerClass.com.x.Init2
    • org.omg.PortableInterceptor.ORBInitializerClass.com.x.Init3
    During ORB.init, these ORB properties which begin with org.omg.PortableInterceptor.ORBInitializerClass shall be collected, the <Service> portion of each property shall be extracted, an object shall be instantiated with the <Service> string as its class name, and the pre_init and post_init methods shall be called on that object. If there are any exceptions, the ORB shall ignore them and proceed.

    Example

    A client-side logging service written by company X, for example, may have the following ORBInitializer implementation:

     package com.x.logging;

 import org.omg.PortableInterceptor.Interceptor;
 import org.omg.PortableInterceptor.ORBInitializer;
 import org.omg.PortableInterceptor.ORBInitInfo;

 public class LoggingService implements ORBInitializer {
     void pre_init( ORBInitInfo info ) {
         // Instantiate the Logging Service s Interceptor.
         Interceptor interceptor = new LoggingInterceptor();

         // Register the Logging Service s Interceptor.
         info.add_client_request_interceptor( interceptor );
     }

     void post_init( ORBInitInfo info ) {
         // This service does not need two init points.
     }
 }
    To run a program called MyApp using this logging service, the user could type:
    java -Dorg.omg.PortableInterceptor.ORBInitializerClass.com.x.Logging.LoggingService MyApp

    Notes about Registering Interceptors

    Request Interceptors are registered on a per-ORB basis.

    To achieve virtual per-object Interceptors, query the policies on the target from within the interception points to determine whether they should do any work.

    To achieve virtual per-POA Interceptors, instantiate each POA with a different ORB. While Interceptors may be ordered administratively, there is no concept of order with respect to the registration of Interceptors. Request Interceptors are concerned with service contexts. Service contexts have no order, so there is no purpose for request Interceptors to have an order. IOR Interceptors are concerned with tagged components. Tagged components also have no order, so there is no purpose for IOR Interceptors to have an order.

    Registration code should avoid using the ORB (i.e., calling ORB.init with the provided orb_id). Since registration occurs during ORB initialization, results of invocations on this ORB while it is in this state are undefined.

    See Also:
    ORBInitInfo

    • Method Summary

      • Methods inherited from interface org.omg.PortableInterceptor.ORBInitializerOperations

        post_init, pre_init

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ORBInitializerOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface ORBInitializerOperations

  • All Known Subinterfaces:
    ORBInitializer

    public interface ORBInitializerOperations
    Facilitates interceptor registration and ORB initialization.

    Interceptors are intended to be a means by which ORB services gain access to ORB processing, effectively becoming part of the ORB. Since Interceptors are part of the ORB, when ORB.init returns an ORB, the Interceptors shall have been registered. Interceptors cannot be registered on an ORB after it has been returned by a call to ORB.init.

    An Interceptor is registered by registering an associated ORBInitializer object which implements the ORBInitializer interface. When an ORB is initializing, it shall call each registered ORBInitializer, passing it an ORBInitInfo object which is used to register its Interceptor.

    Registering ORB Initializers in Java

    ORBInitializers are registered via Java ORB properties.

    The property names are of the form:

    org.omg.PortableInterceptor.ORBInitializerClass.<Service>
    where <Service> is the string name of a class which implements
    org.omg.PortableInterceptor.ORBInitializer
    To avoid name collisions, the reverse DNS name convention should be used. For example, if company X has three initializers, it could define the following properties:
    • org.omg.PortableInterceptor.ORBInitializerClass.com.x.Init1
    • org.omg.PortableInterceptor.ORBInitializerClass.com.x.Init2
    • org.omg.PortableInterceptor.ORBInitializerClass.com.x.Init3
    During ORB.init, these ORB properties which begin with org.omg.PortableInterceptor.ORBInitializerClass shall be collected, the <Service> portion of each property shall be extracted, an object shall be instantiated with the <Service> string as its class name, and the pre_init and post_init methods shall be called on that object. If there are any exceptions, the ORB shall ignore them and proceed.

    Example

    A client-side logging service written by company X, for example, may have the following ORBInitializer implementation:

     package com.x.logging;

 import org.omg.PortableInterceptor.Interceptor;
 import org.omg.PortableInterceptor.ORBInitializer;
 import org.omg.PortableInterceptor.ORBInitInfo;

 public class LoggingService implements ORBInitializer {
     void pre_init( ORBInitInfo info ) {
         // Instantiate the Logging Service s Interceptor.
         Interceptor interceptor = new LoggingInterceptor();

         // Register the Logging Service s Interceptor.
         info.add_client_request_interceptor( interceptor );
     }

     void post_init( ORBInitInfo info ) {
         // This service does not need two init points.
     }
 }
    To run a program called MyApp using this logging service, the user could type:
    java -Dorg.omg.PortableInterceptor.ORBInitializerClass.com.x.Logging.LoggingService MyApp

    Notes about Registering Interceptors

    Request Interceptors are registered on a per-ORB basis.

    To achieve virtual per-object Interceptors, query the policies on the target from within the interception points to determine whether they should do any work.

    To achieve virtual per-POA Interceptors, instantiate each POA with a different ORB. While Interceptors may be ordered administratively, there is no concept of order with respect to the registration of Interceptors. Request Interceptors are concerned with service contexts. Service contexts have no order, so there is no purpose for request Interceptors to have an order. IOR Interceptors are concerned with tagged components. Tagged components also have no order, so there is no purpose for IOR Interceptors to have an order.

    Registration code should avoid using the ORB (i.e., calling ORB.init with the provided orb_id). Since registration occurs during ORB initialization, results of invocations on this ORB while it is in this state are undefined.

    See Also:
    ORBInitInfo

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void post_init(ORBInitInfo info)
      Called during ORB initialization.
      void pre_init(ORBInitInfo info)
      Called during ORB initialization.

    • Method Detail

      • pre_init

        void pre_init(ORBInitInfo info)
        Called during ORB initialization. If it is expected that initial services registered by an interceptor will be used by other interceptors, then those initial services shall be registered at this point via calls to ORBInitInfo.register_initial_reference.
        Parameters:
        info - provides initialization attributes and operations by which Interceptors can be registered.

      • post_init

        void post_init(ORBInitInfo info)
        Called during ORB initialization. If a service must resolve initial references as part of its initialization, it can assume that all initial references will be available at this point.

        Calling the post_init operations is not the final task of ORB initialization. The final task, following the post_init calls, is attaching the lists of registered interceptors to the ORB. Therefore, the ORB does not contain the interceptors during calls to post_init. If an ORB-mediated call is made from within post_init, no request interceptors will be invoked on that call. Likewise, if an operation is performed which causes an IOR to be created, no IOR interceptors will be invoked.

        Parameters:
        info - provides initialization attributes and operations by which Interceptors can be registered.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ORBInitInfo (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface ORBInitInfo

  • All Superinterfaces:
    IDLEntity, Object, ORBInitInfoOperations, Serializable

    public interface ORBInitInfo
extends ORBInitInfoOperations, Object, IDLEntity
    Passed to each ORBInitializer, allowing it to to register interceptors and perform other duties while the ORB is initializing.

    The ORBInitInfo object is only valid during ORB.init. If a service keeps a reference to its ORBInitInfo object and tries to use it after ORB.init returns, the object no longer exists and an OBJECT_NOT_EXIST exception shall be thrown.

    See Also:
    ORBInitializer

    • Method Summary

      • Methods inherited from interface org.omg.PortableInterceptor.ORBInitInfoOperations

        add_client_request_interceptor, add_ior_interceptor, add_server_request_interceptor, allocate_slot_id, arguments, codec_factory, orb_id, register_initial_reference, register_policy_factory, resolve_initial_references

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ORBInitInfoOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface ORBInitInfoOperations

  • All Known Subinterfaces:
    ORBInitInfo

    public interface ORBInitInfoOperations
    Passed to each ORBInitializer, allowing it to to register interceptors and perform other duties while the ORB is initializing.

    The ORBInitInfo object is only valid during ORB.init. If a service keeps a reference to its ORBInitInfo object and tries to use it after ORB.init returns, the object no longer exists and an OBJECT_NOT_EXIST exception shall be thrown.

    See Also:
    ORBInitializer

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void add_client_request_interceptor(ClientRequestInterceptor interceptor)
      Used to add a client-side request Interceptor to the list of client-side request Interceptors.
      void add_ior_interceptor(IORInterceptor interceptor)
      Used to add an IOR Interceptor to the list of IOR Interceptors.
      void add_server_request_interceptor(ServerRequestInterceptor interceptor)
      Used to add a server-side request Interceptor to the list of server-side request Interceptors.
      int allocate_slot_id()
      Called to allocate a slot on PortableInterceptor.Current.
      String[] arguments()
      Returns the arguments passed to ORB.init.
      CodecFactory codec_factory()
      Returns the IOP.CodecFactory.
      String orb_id()
      Returns the ID of the ORB being initialized.
      void register_initial_reference(String id, Object obj)
      Identical to ORB.register_initial_reference.
      void register_policy_factory(int type, PolicyFactory policy_factory)
      Registers a PolicyFactory for the given PolicyType.
      Object resolve_initial_references(String id)
      Identical to ORB.resolve_initial_references.

    • Method Detail

      • arguments

        String[] arguments()
        Returns the arguments passed to ORB.init. They may or may not contain the ORB's arguments.

      • orb_id

        String orb_id()
        Returns the ID of the ORB being initialized.

      • codec_factory

        CodecFactory codec_factory()
        Returns the IOP.CodecFactory. The CodecFactory is normally obtained via a call to ORB.resolve_initial_references( "CodecFactory" ), but since the ORB is not yet available and Interceptors, particularly when processing service contexts, will require a Codec, a means of obtaining a Codec is necessary during ORB initialization.

      • register_initial_reference

        void register_initial_reference(String id,
                                Object obj)
                         throws InvalidName
        Identical to ORB.register_initial_reference. This same functionality exists here because the ORB, not yet fully initialized, is not yet available but initial references may need to be registered as part of Interceptor registration. The only difference is that the version of this operation on the ORB uses PIDL (CORBA.ORB.ObjectId) and (CORBA.ORB.InvalidName) whereas the version in this interface uses IDL defined in this interface; the semantics are identical.
        Throws:
        InvalidName

      • resolve_initial_references

        Object resolve_initial_references(String id)
                           throws InvalidName
        Identical to ORB.resolve_initial_references. This same functionality exists here because the ORB, not yet fully initialized, is not yet available but initial references may be required from the ORB as part of Interceptor registration. The only difference is that the version of this operation on the ORB uses PIDL (CORBA::ORB::ObjectId and CORBA::ORB::InvalidName) whereas the version in this interface uses IDL defined in this interface; the semantics are identical.

        This operation is only valid during post_init.

        Throws:
        InvalidName

      • add_client_request_interceptor

        void add_client_request_interceptor(ClientRequestInterceptor interceptor)
                             throws DuplicateName
        Used to add a client-side request Interceptor to the list of client-side request Interceptors.
        Parameters:
        interceptor - The ClientRequestInterceptor to be added.
        Throws:
        DuplicateName - thrown if a client-side request Interceptor has already been registered with this Interceptor's name.

      • add_server_request_interceptor

        void add_server_request_interceptor(ServerRequestInterceptor interceptor)
                             throws DuplicateName
        Used to add a server-side request Interceptor to the list of server-side request Interceptors.
        Parameters:
        interceptor - The ServerRequestInterceptor to be added.
        Throws:
        DuplicateName - thrown if a server-side request Interceptor has already been registered with this Interceptor's name

      • add_ior_interceptor

        void add_ior_interceptor(IORInterceptor interceptor)
                  throws DuplicateName
        Used to add an IOR Interceptor to the list of IOR Interceptors.
        Parameters:
        interceptor - The IORInterceptor to be added.
        Throws:
        DuplicateName - thrown if an IOR Interceptor has already been registered with this Interceptor's name.

      • allocate_slot_id

        int allocate_slot_id()
        Called to allocate a slot on PortableInterceptor.Current.

        Note that while slot id's can be allocated within an ORB initializer, the slots themselves cannot be initialized.

        Returns:
        The index to the slot which has been allocated.
        Throws:
        BAD_INV_ORDER - thrown, with a standard minor code of 14, if set_slot or get_slot is called on the PICurrent within an ORB initializer.
        See Also:
        Current

      • register_policy_factory

        void register_policy_factory(int type,
                             PolicyFactory policy_factory)
        Registers a PolicyFactory for the given PolicyType.
        Parameters:
        type - The policy type that the given PolicyFactory serves.
        policy_factory - The factory for the given policy type.
        Throws:
        BAD_INV_ORDER - thrown, with a standard minor code of 16, if a PolicyFactory already exists for the given PolicyType.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Class org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateName (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateName

  • Packages that use DuplicateName
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
    org.omg.PortableInterceptor.ORBInitInfoPackage
    This package contains the exceptions and typedefs from the ORBInitInfo local interface of the PortableInterceptor module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.7.2.

    • Uses of DuplicateName in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor that throw DuplicateName
      Modifier and Type Method and Description
      void ORBInitInfoOperations.add_client_request_interceptor(ClientRequestInterceptor interceptor)
      Used to add a client-side request Interceptor to the list of client-side request Interceptors.
      void ORBInitInfoOperations.add_ior_interceptor(IORInterceptor interceptor)
      Used to add an IOR Interceptor to the list of IOR Interceptors.
      void ORBInitInfoOperations.add_server_request_interceptor(ServerRequestInterceptor interceptor)
      Used to add a server-side request Interceptor to the list of server-side request Interceptors.

    • Uses of DuplicateName in org.omg.PortableInterceptor.ORBInitInfoPackage

      Methods in org.omg.PortableInterceptor.ORBInitInfoPackage that return DuplicateName
      Modifier and Type | Method and Description
      static DuplicateName | DuplicateNameHelper.extract(Any a)
      static DuplicateName | DuplicateNameHelper.read(InputStream istream)
      Methods in org.omg.PortableInterceptor.ORBInitInfoPackage with parameters of type DuplicateName
      Modifier and Type | Method and Description
      static void | DuplicateNameHelper.insert(Any a, DuplicateName that)
      static void | DuplicateNameHelper.write(OutputStream ostream, DuplicateName value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper

No usage of org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidName (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidName

  • Packages that use InvalidName
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
    org.omg.PortableInterceptor.ORBInitInfoPackage
    This package contains the exceptions and typedefs from the ORBInitInfo local interface of the PortableInterceptor module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.7.2.

    • Uses of InvalidName in org.omg.PortableInterceptor

      Methods in org.omg.PortableInterceptor that throw InvalidName
      Modifier and Type Method and Description
      void ORBInitInfoOperations.register_initial_reference(String id, Object obj)
      Identical to ORB.register_initial_reference.
      Object ORBInitInfoOperations.resolve_initial_references(String id)
      Identical to ORB.resolve_initial_references.

    • Uses of InvalidName in org.omg.PortableInterceptor.ORBInitInfoPackage

      Methods in org.omg.PortableInterceptor.ORBInitInfoPackage that return InvalidName
      Modifier and Type | Method and Description
      static InvalidName | InvalidNameHelper.extract(Any a)
      static InvalidName | InvalidNameHelper.read(InputStream istream)
      Methods in org.omg.PortableInterceptor.ORBInitInfoPackage with parameters of type InvalidName
      Modifier and Type | Method and Description
      static void | InvalidNameHelper.insert(Any a, InvalidName that)
      static void | InvalidNameHelper.write(OutputStream ostream, InvalidName value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper

No usage of org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper

No usage of org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


DuplicateName (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor.ORBInitInfoPackage

Class DuplicateName

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateName
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class DuplicateName
extends UserException
    org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateName.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      String name
      The name for which there was already an interceptor registered.

    • Constructor Summary

      Constructors
      Constructor and Description
      DuplicateName()
      DuplicateName(String _name)
      DuplicateName(String $reason, String _name)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • name

        public String name
        The name for which there was already an interceptor registered.

    • Constructor Detail

      • DuplicateName

        public DuplicateName()

      • DuplicateName

        public DuplicateName(String _name)

      • DuplicateName

        public DuplicateName(String $reason,
                     String _name)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DuplicateNameHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor.ORBInitInfoPackage

Class DuplicateNameHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper

  • public abstract class DuplicateNameHelper
extends Object
    org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateNameHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      DuplicateNameHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static DuplicateName | extract(Any a)
      static String | id()
      static void | insert(Any a, DuplicateName that)
      static DuplicateName | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, DuplicateName value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • DuplicateNameHelper

        public DuplicateNameHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          DuplicateName that)

      • extract

        public static DuplicateName extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static DuplicateName read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         DuplicateName value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


InvalidName (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor.ORBInitInfoPackage

Class InvalidName

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidName
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class InvalidName
extends UserException
    org/omg/PortableInterceptor/ORBInitInfoPackage/InvalidName.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      InvalidName()
      InvalidName(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • InvalidName

        public InvalidName()

      • InvalidName

        public InvalidName(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


InvalidNameHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor.ORBInitInfoPackage

Class InvalidNameHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper

  • public abstract class InvalidNameHelper
extends Object
    org/omg/PortableInterceptor/ORBInitInfoPackage/InvalidNameHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      InvalidNameHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static InvalidName | extract(Any a)
      static String | id()
      static void | insert(Any a, InvalidName that)
      static InvalidName | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, InvalidName value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • InvalidNameHelper

        public InvalidNameHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          InvalidName that)

      • extract

        public static InvalidName extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static InvalidName read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         InvalidName value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ObjectIdHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor.ORBInitInfoPackage

Class ObjectIdHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper

  • public abstract class ObjectIdHelper
extends Object
    Object id, represented as a String

    • Constructor Summary

      Constructors
      Constructor and Description
      ObjectIdHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static String | extract(Any a)
      static String | id()
      static void | insert(Any a, String that)
      static String | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, String value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ObjectIdHelper

        public ObjectIdHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          String that)

      • extract

        public static String extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         String value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


org.omg.PortableInterceptor.ORBInitInfoPackage (Java Platform SE 8 )

org.omg.PortableInterceptor.ORBInitInfoPackage

Classes

  • DuplicateNameHelper
  • InvalidNameHelper
  • ObjectIdHelper

Exceptions

  • DuplicateName
  • InvalidName


org.omg.PortableInterceptor.ORBInitInfoPackage (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.PortableInterceptor.ORBInitInfoPackage

This package contains the exceptions and typedefs from the ORBInitInfo local interface of the PortableInterceptor module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.7.2.

See: Description

  • Class Summary
    Class Description
    DuplicateNameHelper
    org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateNameHelper.java .
    InvalidNameHelper
    org/omg/PortableInterceptor/ORBInitInfoPackage/InvalidNameHelper.java .
    ObjectIdHelper
    Object id, represented as a String
  • Exception Summary
    Exception Description
    DuplicateName
    org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateName.java .
    InvalidName
    org/omg/PortableInterceptor/ORBInitInfoPackage/InvalidName.java .

Package org.omg.PortableInterceptor.ORBInitInfoPackage Description

This package contains the exceptions and typedefs from the ORBInitInfo local interface of the PortableInterceptor module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.7.2. Please refer to that OMG specification for further details.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java SE 6.

Since:
1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames


org.omg.PortableInterceptor.ORBInitInfoPackage Class Hierarchy (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.PortableInterceptor.ORBInitInfoPackage

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper
    • org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper
    • org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateName
          • org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidName
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package org.omg.PortableInterceptor.ORBInitInfoPackage (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.PortableInterceptor.ORBInitInfoPackage

  • Packages that use org.omg.PortableInterceptor.ORBInitInfoPackage
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
    org.omg.PortableInterceptor.ORBInitInfoPackage
    This package contains the exceptions and typedefs from the ORBInitInfo local interface of the PortableInterceptor module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.7.2.
  • Classes in org.omg.PortableInterceptor.ORBInitInfoPackage used by org.omg.PortableInterceptor
    Class and Description
    DuplicateName
    org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateName.java .
    InvalidName
    org/omg/PortableInterceptor/ORBInitInfoPackage/InvalidName.java .
  • Classes in org.omg.PortableInterceptor.ORBInitInfoPackage used by org.omg.PortableInterceptor.ORBInitInfoPackage
    Class and Description
    DuplicateName
    org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateName.java .
    InvalidName
    org/omg/PortableInterceptor/ORBInitInfoPackage/InvalidName.java .
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


org.omg.PortableInterceptor (Java Platform SE 8 )

org.omg.PortableInterceptor

Interfaces

  • ACTIVE
  • ClientRequestInfo
  • ClientRequestInfoOperations
  • ClientRequestInterceptor
  • ClientRequestInterceptorOperations
  • Current
  • CurrentOperations
  • DISCARDING
  • HOLDING
  • INACTIVE
  • Interceptor
  • InterceptorOperations
  • IORInfo
  • IORInfoOperations
  • IORInterceptor
  • IORInterceptor_3_0
  • IORInterceptor_3_0Operations
  • IORInterceptorOperations
  • LOCATION_FORWARD
  • NON_EXISTENT
  • ObjectReferenceFactory
  • ObjectReferenceTemplate
  • ORBInitializer
  • ORBInitializerOperations
  • ORBInitInfo
  • ORBInitInfoOperations
  • PolicyFactory
  • PolicyFactoryOperations
  • RequestInfo
  • RequestInfoOperations
  • ServerRequestInfo
  • ServerRequestInfoOperations
  • ServerRequestInterceptor
  • ServerRequestInterceptorOperations
  • SUCCESSFUL
  • SYSTEM_EXCEPTION
  • TRANSPORT_RETRY
  • UNKNOWN
  • USER_EXCEPTION

Classes

  • AdapterManagerIdHelper
  • AdapterNameHelper
  • AdapterStateHelper
  • CurrentHelper
  • ForwardRequestHelper
  • InvalidSlotHelper
  • IORInterceptor_3_0Helper
  • IORInterceptor_3_0Holder
  • ObjectIdHelper
  • ObjectReferenceFactoryHelper
  • ObjectReferenceFactoryHolder
  • ObjectReferenceTemplateHelper
  • ObjectReferenceTemplateHolder
  • ObjectReferenceTemplateSeqHelper
  • ObjectReferenceTemplateSeqHolder
  • ORBIdHelper
  • ServerIdHelper

Exceptions

  • ForwardRequest
  • InvalidSlot


org.omg.PortableInterceptor (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.PortableInterceptor

Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

See: Description

  • Interface Summary
    Interface Description
    ACTIVE
    org/omg/PortableInterceptor/ACTIVE.java .
    ClientRequestInfo
    Request Information, accessible to client-side request interceptors.
    ClientRequestInfoOperations
    Request Information, accessible to client-side request interceptors.
    ClientRequestInterceptor
    Client-side request interceptor.
    ClientRequestInterceptorOperations
    Client-side request interceptor.
    Current
    Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context.
    CurrentOperations
    Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context.
    DISCARDING
    org/omg/PortableInterceptor/DISCARDING.java .
    HOLDING
    org/omg/PortableInterceptor/HOLDING.java .
    INACTIVE
    org/omg/PortableInterceptor/INACTIVE.java .
    Interceptor
    All Portable Interceptors implement Interceptor.
    InterceptorOperations
    All Portable Interceptors implement Interceptor.
    IORInfo
    Provides the server-side ORB service with access to the applicable policies during IOR construction and the ability to add components.
    IORInfoOperations
    Provides the server-side ORB service with access to the applicable policies during IOR construction and the ability to add components.
    IORInterceptor
    Interceptor used to establish tagged components in the profiles within an IOR.
    IORInterceptor_3_0
    org/omg/PortableInterceptor/IORInterceptor_3_0.java .
    IORInterceptor_3_0Operations
    org/omg/PortableInterceptor/IORInterceptor_3_0Operations.java .
    IORInterceptorOperations
    Interceptor used to establish tagged components in the profiles within an IOR.
    LOCATION_FORWARD
    org/omg/PortableInterceptor/LOCATION_FORWARD.java .
    NON_EXISTENT
    org/omg/PortableInterceptor/NON_EXISTENT.java .
    ObjectReferenceFactory
    The object reference factory.
    ObjectReferenceTemplate
    The object reference template.
    ORBInitializer
    Facilitates interceptor registration and ORB initialization.
    ORBInitializerOperations
    Facilitates interceptor registration and ORB initialization.
    ORBInitInfo
    Passed to each ORBInitializer, allowing it to to register interceptors and perform other duties while the ORB is initializing.
    ORBInitInfoOperations
    Passed to each ORBInitializer, allowing it to to register interceptors and perform other duties while the ORB is initializing.
    PolicyFactory
    Enables policy types to be constructed using CORBA.ORB.create_policy.
    PolicyFactoryOperations
    Enables policy types to be constructed using CORBA.ORB.create_policy.
    RequestInfo
    Request Information, accessible to Interceptors.
    RequestInfoOperations
    Request Information, accessible to Interceptors.
    ServerRequestInfo
    Request Information, accessible to server-side request interceptors.
    ServerRequestInfoOperations
    Request Information, accessible to server-side request interceptors.
    ServerRequestInterceptor
    Server-side request interceptor.
    ServerRequestInterceptorOperations
    Server-side request interceptor.
    SUCCESSFUL
    org/omg/PortableInterceptor/SUCCESSFUL.java .
    SYSTEM_EXCEPTION
    org/omg/PortableInterceptor/SYSTEM_EXCEPTION.java .
    TRANSPORT_RETRY
    org/omg/PortableInterceptor/TRANSPORT_RETRY.java .
    UNKNOWN
    org/omg/PortableInterceptor/UNKNOWN.java .
    USER_EXCEPTION
    org/omg/PortableInterceptor/USER_EXCEPTION.java .
  • Class Summary
    Class Description
    AdapterManagerIdHelper
    Adapter manager identifier.
    AdapterNameHelper
    The name of an object adapter.
    AdapterStateHelper
    Type of object adapter state.
    CurrentHelper
    Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context.
    ForwardRequestHelper
    org/omg/PortableInterceptor/ForwardRequestHelper.java .
    InvalidSlotHelper
    org/omg/PortableInterceptor/InvalidSlotHelper.java .
    IORInterceptor_3_0Helper
    org/omg/PortableInterceptor/IORInterceptor_3_0Helper.java .
    IORInterceptor_3_0Holder
    org/omg/PortableInterceptor/IORInterceptor_3_0Holder.java .
    ObjectIdHelper
    Type of an object id.
    ObjectReferenceFactoryHelper
    The object reference factory.
    ObjectReferenceFactoryHolder
    The object reference factory.
    ObjectReferenceTemplateHelper
    The object reference template.
    ObjectReferenceTemplateHolder
    The object reference template.
    ObjectReferenceTemplateSeqHelper
    Sequence of object reference templates is used for reporting state changes that do not occur on the adapter manager.
    ObjectReferenceTemplateSeqHolder
    Sequence of object reference templates is used for reporting state changes that do not occur on the adapter manager.
    ORBIdHelper
    org/omg/PortableInterceptor/ORBIdHelper.java .
    ServerIdHelper
    org/omg/PortableInterceptor/ServerIdHelper.java .
  • Exception Summary
    Exception Description
    ForwardRequest
    org/omg/PortableInterceptor/ForwardRequest.java .
    InvalidSlot
    org/omg/PortableInterceptor/InvalidSlot.java .

Package org.omg.PortableInterceptor Description

Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.

Interceptor Types

There are currently three types of interceptors that can be registered:
  • IORInterceptor - Used to establish tagged components in the profiles within an IOR.
  • ClientRequestInterceptor - Intercepts the flow of a request/reply sequence through the ORB on the client side.
  • ServerRequestInterceptor - Intercepts the flow of a request/reply sequence through the ORB on the server side.
See the javadocs for class ORBInitializer for how to go about registering interceptors.

Known limitations / unimplemented methods in package org.omg.PortableInterceptor

  • RequestInfo
    • sync_scope(): Always returns SYNC_WITH_TRANSPORT
    • arguments(): Only supported for DII/DSI calls
    • exceptions(): Only supported for DII calls on client side. Not supported on server-side.
    • contexts(): Only supported for DII calls on client side. Not supported on server-side since our ORB does not send contexts.
    • operation_context(): Only supported for DII calls on client side. Not supported on server-side since ORB does not send contexts.
    • result(): Only supported for DII/DSI calls
  • ClientRequestInfo
    • received_exception_id(): Always returns null in the DII case
    • get_request_policy(int type): Not implemented.
  • ServerRequestInfo
    • sending_exception(): Does not support user exceptions on the server side in non-DSI case.

Package Specification

For a precise list of supported sections of official OMG specifications with which the Java[tm] Platform, Standard Edition 6 complies, see Official Specifications for CORBA support in Java SE 6.

Since:
1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames


org.omg.PortableInterceptor Class Hierarchy (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.PortableInterceptor

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.PortableInterceptor.AdapterManagerIdHelper
    • org.omg.PortableInterceptor.AdapterNameHelper
    • org.omg.PortableInterceptor.AdapterStateHelper
    • org.omg.PortableInterceptor.CurrentHelper
    • org.omg.PortableInterceptor.ForwardRequestHelper
    • org.omg.PortableInterceptor.InvalidSlotHelper
    • org.omg.PortableInterceptor.IORInterceptor_3_0Helper
    • org.omg.PortableInterceptor.IORInterceptor_3_0Holder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.PortableInterceptor.ObjectIdHelper
    • org.omg.PortableInterceptor.ObjectReferenceFactoryHelper
    • org.omg.PortableInterceptor.ObjectReferenceFactoryHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.PortableInterceptor.ObjectReferenceTemplateHelper
    • org.omg.PortableInterceptor.ObjectReferenceTemplateHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper
    • org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.PortableInterceptor.ORBIdHelper
    • org.omg.PortableInterceptor.ServerIdHelper
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.PortableInterceptor.ForwardRequest
          • org.omg.PortableInterceptor.InvalidSlot

Interface Hierarchy

  • org.omg.PortableInterceptor.ACTIVE
  • org.omg.CORBA.CurrentOperations
    • org.omg.CORBA.Current (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableInterceptor.Current (also extends org.omg.PortableInterceptor.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableInterceptor.CurrentOperations
      • org.omg.PortableInterceptor.Current (also extends org.omg.CORBA.Current, org.omg.CORBA.portable.IDLEntity)
  • org.omg.PortableInterceptor.DISCARDING
  • org.omg.PortableInterceptor.HOLDING
  • org.omg.PortableInterceptor.INACTIVE
  • org.omg.PortableInterceptor.InterceptorOperations
    • org.omg.PortableInterceptor.ClientRequestInterceptorOperations
      • org.omg.PortableInterceptor.ClientRequestInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor)
    • org.omg.PortableInterceptor.Interceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableInterceptor.ClientRequestInterceptor (also extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.IORInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptorOperations)
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.ServerRequestInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
    • org.omg.PortableInterceptor.IORInterceptorOperations
      • org.omg.PortableInterceptor.IORInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor)
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.IORInterceptor_3_0Operations
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor)
    • org.omg.PortableInterceptor.ServerRequestInterceptorOperations
      • org.omg.PortableInterceptor.ServerRequestInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor)
  • org.omg.PortableInterceptor.IORInfoOperations
    • org.omg.PortableInterceptor.IORInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.PortableInterceptor.LOCATION_FORWARD
  • org.omg.PortableInterceptor.NON_EXISTENT
  • org.omg.CORBA.Object
    • org.omg.CORBA.Current (also extends org.omg.CORBA.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.Current (also extends org.omg.PortableInterceptor.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableInterceptor.Interceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.InterceptorOperations)
      • org.omg.PortableInterceptor.ClientRequestInterceptor (also extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.IORInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptorOperations)
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.ServerRequestInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
    • org.omg.PortableInterceptor.IORInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInfoOperations)
    • org.omg.PortableInterceptor.ORBInitializer (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ORBInitializerOperations)
    • org.omg.PortableInterceptor.ORBInitInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ORBInitInfoOperations)
    • org.omg.PortableInterceptor.PolicyFactory (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.PolicyFactoryOperations)
    • org.omg.PortableInterceptor.RequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfoOperations)
      • org.omg.PortableInterceptor.ClientRequestInfo (also extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.ServerRequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInfoOperations)
  • org.omg.PortableInterceptor.ORBInitializerOperations
    • org.omg.PortableInterceptor.ORBInitializer (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.PortableInterceptor.ORBInitInfoOperations
    • org.omg.PortableInterceptor.ORBInitInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.PortableInterceptor.PolicyFactoryOperations
    • org.omg.PortableInterceptor.PolicyFactory (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.PortableInterceptor.RequestInfoOperations
    • org.omg.PortableInterceptor.ClientRequestInfoOperations
      • org.omg.PortableInterceptor.ClientRequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfo)
    • org.omg.PortableInterceptor.RequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableInterceptor.ClientRequestInfo (also extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.ServerRequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInfoOperations)
    • org.omg.PortableInterceptor.ServerRequestInfoOperations
      • org.omg.PortableInterceptor.ServerRequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfo)
  • java.io.Serializable
    • org.omg.CORBA.portable.IDLEntity
      • org.omg.PortableInterceptor.ClientRequestInfo (also extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.PortableInterceptor.RequestInfo)
      • org.omg.PortableInterceptor.ClientRequestInterceptor (also extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.PortableInterceptor.Interceptor)
      • org.omg.CORBA.Current (also extends org.omg.CORBA.CurrentOperations, org.omg.CORBA.Object)
        • org.omg.PortableInterceptor.Current (also extends org.omg.PortableInterceptor.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.Current (also extends org.omg.CORBA.Current, org.omg.PortableInterceptor.CurrentOperations)
      • org.omg.PortableInterceptor.Interceptor (also extends org.omg.PortableInterceptor.InterceptorOperations, org.omg.CORBA.Object)
        • org.omg.PortableInterceptor.ClientRequestInterceptor (also extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.PortableInterceptor.IORInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptorOperations)
          • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
        • org.omg.PortableInterceptor.ServerRequestInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
      • org.omg.PortableInterceptor.IORInfo (also extends org.omg.PortableInterceptor.IORInfoOperations, org.omg.CORBA.Object)
      • org.omg.PortableInterceptor.IORInterceptor (also extends org.omg.PortableInterceptor.Interceptor, org.omg.PortableInterceptor.IORInterceptorOperations)
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.PortableInterceptor.IORInterceptor, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.ORBInitializer (also extends org.omg.CORBA.Object, org.omg.PortableInterceptor.ORBInitializerOperations)
      • org.omg.PortableInterceptor.ORBInitInfo (also extends org.omg.CORBA.Object, org.omg.PortableInterceptor.ORBInitInfoOperations)
      • org.omg.PortableInterceptor.PolicyFactory (also extends org.omg.CORBA.Object, org.omg.PortableInterceptor.PolicyFactoryOperations)
      • org.omg.PortableInterceptor.RequestInfo (also extends org.omg.CORBA.Object, org.omg.PortableInterceptor.RequestInfoOperations)
        • org.omg.PortableInterceptor.ClientRequestInfo (also extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.PortableInterceptor.ServerRequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInfoOperations)
      • org.omg.PortableInterceptor.ServerRequestInfo (also extends org.omg.PortableInterceptor.RequestInfo, org.omg.PortableInterceptor.ServerRequestInfoOperations)
      • org.omg.PortableInterceptor.ServerRequestInterceptor (also extends org.omg.PortableInterceptor.Interceptor, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
      • org.omg.CORBA.portable.ValueBase
        • org.omg.PortableInterceptor.ObjectReferenceFactory
          • org.omg.PortableInterceptor.ObjectReferenceTemplate
  • org.omg.PortableInterceptor.SUCCESSFUL
  • org.omg.PortableInterceptor.SYSTEM_EXCEPTION
  • org.omg.PortableInterceptor.TRANSPORT_RETRY
  • org.omg.PortableInterceptor.UNKNOWN
  • org.omg.PortableInterceptor.USER_EXCEPTION
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package org.omg.PortableInterceptor (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.PortableInterceptor

  • Packages that use org.omg.PortableInterceptor
    Package Description
    org.omg.PortableInterceptor
    Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
  • Classes in org.omg.PortableInterceptor used by org.omg.PortableInterceptor
    Class and Description
    ClientRequestInfo
    Request Information, accessible to client-side request interceptors.
    ClientRequestInfoOperations
    Request Information, accessible to client-side request interceptors.
    ClientRequestInterceptor
    Client-side request interceptor.
    ClientRequestInterceptorOperations
    Client-side request interceptor.
    Current
    Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context.
    CurrentOperations
    Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context.
    ForwardRequest
    org/omg/PortableInterceptor/ForwardRequest.java .
    Interceptor
    All Portable Interceptors implement Interceptor.
    InterceptorOperations
    All Portable Interceptors implement Interceptor.
    InvalidSlot
    org/omg/PortableInterceptor/InvalidSlot.java .
    IORInfo
    Provides the server-side ORB service with access to the applicable policies during IOR construction and the ability to add components.
    IORInfoOperations
    Provides the server-side ORB service with access to the applicable policies during IOR construction and the ability to add components.
    IORInterceptor
    Interceptor used to establish tagged components in the profiles within an IOR.
    IORInterceptor_3_0
    org/omg/PortableInterceptor/IORInterceptor_3_0.java .
    IORInterceptor_3_0Operations
    org/omg/PortableInterceptor/IORInterceptor_3_0Operations.java .
    IORInterceptorOperations
    Interceptor used to establish tagged components in the profiles within an IOR.
    ObjectReferenceFactory
    The object reference factory.
    ObjectReferenceTemplate
    The object reference template.
    ORBInitializerOperations
    Facilitates interceptor registration and ORB initialization.
    ORBInitInfo
    Passed to each ORBInitializer, allowing it to to register interceptors and perform other duties while the ORB is initializing.
    ORBInitInfoOperations
    Passed to each ORBInitializer, allowing it to to register interceptors and perform other duties while the ORB is initializing.
    PolicyFactory
    Enables policy types to be constructed using CORBA.ORB.create_policy.
    PolicyFactoryOperations
    Enables policy types to be constructed using CORBA.ORB.create_policy.
    RequestInfo
    Request Information, accessible to Interceptors.
    RequestInfoOperations
    Request Information, accessible to Interceptors.
    ServerRequestInfo
    Request Information, accessible to server-side request interceptors.
    ServerRequestInfoOperations
    Request Information, accessible to server-side request interceptors.
    ServerRequestInterceptor
    Server-side request interceptor.
    ServerRequestInterceptorOperations
    Server-side request interceptor.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


PolicyFactory (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface PolicyFactory

  • All Superinterfaces:
    IDLEntity, Object, PolicyFactoryOperations, Serializable

    public interface PolicyFactory
extends PolicyFactoryOperations, Object, IDLEntity
    Enables policy types to be constructed using CORBA.ORB.create_policy.

    A portable ORB service implementation registers an instance of the PolicyFactory interface during ORB initialization in order to enable its policy types to be constructed using CORBA.ORB.create_policy. The POA is required to preserve any policy which is registered with ORBInitInfo in this manner.

    See Also:
    ORBInitInfoOperations.register_policy_factory(int, org.omg.PortableInterceptor.PolicyFactory)

    • Method Summary

      • Methods inherited from interface org.omg.PortableInterceptor.PolicyFactoryOperations

        create_policy

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


PolicyFactoryOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface PolicyFactoryOperations

  • All Known Subinterfaces:
    PolicyFactory

    public interface PolicyFactoryOperations
    Enables policy types to be constructed using CORBA.ORB.create_policy.

    A portable ORB service implementation registers an instance of the PolicyFactory interface during ORB initialization in order to enable its policy types to be constructed using CORBA.ORB.create_policy. The POA is required to preserve any policy which is registered with ORBInitInfo in this manner.

    See Also:
    ORBInitInfoOperations.register_policy_factory(int, org.omg.PortableInterceptor.PolicyFactory)

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Policy create_policy(int type, Any value)
      Returns an instance of the appropriate interface derived from CORBA.Policy whose value corresponds to the specified any.

    • Method Detail

      • create_policy

        Policy create_policy(int type,
                     Any value)
              throws PolicyError
        Returns an instance of the appropriate interface derived from CORBA.Policy whose value corresponds to the specified any.

        The ORB calls create_policy on a registered PolicyFactory instance when CORBA.ORB.create_policy is called for the PolicyType under which the PolicyFactory has been registered. The create_policy operation then returns an instance of the appropriate interface derived from CORBA.Policy whose value corresponds to the specified any. If it cannot, it shall throw an exception as described for CORBA.ORB.create_policy.

        Parameters:
        type - An int specifying the type of policy being created.
        value - An any containing data with which to construct the CORBA.Policy.
        Returns:
        A CORBA.Policy object of the specified type and value.
        Throws:
        PolicyError
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


RequestInfo (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface RequestInfo

  • All Superinterfaces:
    IDLEntity, Object, RequestInfoOperations, Serializable
    All Known Subinterfaces:
    ClientRequestInfo, ServerRequestInfo

    public interface RequestInfo
extends RequestInfoOperations, Object, IDLEntity
    Request Information, accessible to Interceptors.

    Each interception point is given an object through which the Interceptor can access request information. Client-side and server-side interception points are concerned with different information, so there are two information objects: ClientRequestInfo is passed to the client-side interception points and ServerRequestInfo is passed to the server-side interception points. But there is information that is common to both, so they both inherit from a common interface: RequestInfo.

    See Also:
    ClientRequestInfo, ServerRequestInfo

    • Method Summary

      • Methods inherited from interface org.omg.PortableInterceptor.RequestInfoOperations

        arguments, contexts, exceptions, forward_reference, get_reply_service_context, get_request_service_context, get_slot, operation_context, operation, reply_status, request_id, response_expected, result, sync_scope

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


RequestInfoOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface RequestInfoOperations

  • All Known Subinterfaces:
    ClientRequestInfo, ClientRequestInfoOperations, RequestInfo, ServerRequestInfo, ServerRequestInfoOperations

    public interface RequestInfoOperations
    Request Information, accessible to Interceptors.

    Each interception point is given an object through which the Interceptor can access request information. Client-side and server-side interception points are concerned with different information, so there are two information objects: ClientRequestInfo is passed to the client-side interception points and ServerRequestInfo is passed to the server-side interception points. But there is information that is common to both, so they both inherit from a common interface: RequestInfo.

    See Also:
    ClientRequestInfo, ServerRequestInfo

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Parameter[] arguments()
      Returns an array of Parameter objects, containing the arguments on the operation being invoked.
      String[] contexts()
      Returns an array of String objects describing the contexts that may be passed on this operation invocation.
      TypeCode[] exceptions()
      Returns an array of TypeCode objects describing the TypeCodes of the user exceptions that this operation invocation may throw.
      Object forward_reference()
      Contains the object to which the request will be forwarded, if the reply_status attribute is LOCATION_FORWARD.
      ServiceContext get_reply_service_context(int id)
      Returns a copy of the service context with the given ID that is associated with the reply.
      ServiceContext get_request_service_context(int id)
      Returns a copy of the service context with the given ID that is associated with the request.
      Any get_slot(int id)
      Returns the data from the given slot of the PortableInterceptor.Current that is in the scope of the request.
      String[] operation_context()
      Returns an array of String objects containing the contexts being sent on the request.
      String operation()
      Returns the name of the operation being invoked.
      short reply_status()
      Describes the state of the result of the operation invocation.
      int request_id()
      Returns an id that uniquely identifies an active request/reply sequence.
      boolean response_expected()
      Indicates whether a response is expected.
      Any result()
      Returns an any containing the result of the operation invocation.
      short sync_scope()
      Defines how far the request shall progress before control is returned to the client.

    • Method Detail

      • request_id

        int request_id()
        Returns an id that uniquely identifies an active request/reply sequence. Once a request/reply sequence is concluded this ID may be reused. Note that this id is not the same as the GIOP request_id. If GIOP is the transport mechanism used, then these IDs may very well be the same, but this is not guaranteed nor required.

      • operation

        String operation()
        Returns the name of the operation being invoked.

      • arguments

        Parameter[] arguments()
        Returns an array of Parameter objects, containing the arguments on the operation being invoked. If there are no arguments, this attribute will be a zero length array.

        Not all environments provide access to the arguments. With the Java portable bindings, for example, the arguments are not available. In these environments, when this attribute is accessed, NO_RESOURCES will be thrown with a standard minor code of 1.

        Note: Arguments are available for DSI/DII calls.

        Throws:
        NO_RESOURCES - thrown if arguments are not available.
        See Also:
        PortableInterceptor package comments for limitations / unimplemented features

      • exceptions

        TypeCode[] exceptions()
        Returns an array of TypeCode objects describing the TypeCodes of the user exceptions that this operation invocation may throw. If there are no user exceptions, this will return a zero length array.

        Not all environments provide access to the exception list. With the Java portable bindings, for example, the exception list is not available. In these environments, when this attribute is accessed, NO_RESOURCES will be thrown with a standard minor code of 1.

        Note: Exceptions are available for DSI/DII calls.

        Throws:
        NO_RESOURCES - thrown if exceptions are not available.
        See Also:
        PortableInterceptor package comments for limitations / unimplemented features

      • contexts

        String[] contexts()
        Returns an array of String objects describing the contexts that may be passed on this operation invocation. If there are no contexts, this will return a zero length array.

        Not all environments provide access to the context list. With the Java portable bindings, for example, the context list is not available. In these environments, when this attribute is accessed, NO_RESOURCES will be thrown with a standard minor code of 1.

        Note: Contexts are available for DSI/DII calls.

        Throws:
        NO_RESOURCES - thrown if contexts are not available.
        See Also:
        PortableInterceptor package comments for limitations / unimplemented features

      • operation_context

        String[] operation_context()
        Returns an array of String objects containing the contexts being sent on the request.

        Not all environments provide access to the context. With the Java portable bindings, for example, the context is not available. In these environments, when this attribute is accessed, NO_RESOURCES will be thrown with standard minor code of 1.

        Note: operation_context is available for DSI/DII calls.

        Throws:
        NO_RESOURCES - thrown if operation context is not available.
        See Also:
        PortableInterceptor package comments for limitations / unimplemented features

      • result

        Any result()
        Returns an any containing the result of the operation invocation. If the operation return type is void, this attribute will be an any containing a type code with a TCKind value of tk_void and no value.

        Not all environments provide access to the result. With the Java portable bindings, for example, the result is not available. In these environments, when this attribute is accessed, NO_RESOURCES will be thrown with a standard minor code of 1.

        Note: Result is available for DSI/DII calls.

        Throws:
        NO_RESOURCES - thrown if result is not available.
        See Also:
        PortableInterceptor package comments for limitations / unimplemented features

      • response_expected

        boolean response_expected()
        Indicates whether a response is expected.

        On the client, a reply is not returned when response_expected is false, so receive_reply cannot be called. receive_other is called unless an exception occurs, in which case receive_exception is called.

        On the client, within send_poll, this attribute is true.

      • sync_scope

        short sync_scope()
        Defines how far the request shall progress before control is returned to the client. This is defined in the Messaging specification, and is pertinent only when response_expected is false. If response_expected is true, the value of sync_scope is undefined. This attribute may have one of the following values:
        • Messaging.SYNC_NONE
        • Messaging.SYNC_WITH_TRANSPORT
        • Messaging.SYNC_WITH_SERVER
        • Messaging.SYNC_WITH_TARGET
        On the server, for all scopes, a reply will be created from the return of the target operation call, but the reply will not return to the client. Although it does not return to the client, it does occur, so the normal server-side interception points are followed (i.e., receive_request_service_contexts, receive_request, send_reply or send_exception).

        For SYNC_WITH_SERVER and SYNC_WITH_TARGET, the server does send an empty reply back to the client before the target is invoked. This reply is not intercepted by server-side Interceptors.

        See Also:
        PortableInterceptor package comments for limitations / unimplemented features

      • reply_status

        short reply_status()
        Describes the state of the result of the operation invocation. The return value can be one of the following:
        • PortableInterceptor.SUCCESSFUL
        • PortableInterceptor.SYSTEM_EXCEPTION
        • PortableInterceptor.USER_EXCEPTION
        • PortableInterceptor.LOCATION_FORWARD
        • PortableInterceptor.TRANSPORT_RETRY
        On the client:
        • Within the receive_reply interception point, this will only return SUCCESSFUL
          • .
        • Within the receive_exception interception point, this will be either SYSTEM_EXCEPTION or USER_EXCEPTION.
        • Within the receive_other interception point, this will be any of: SUCCESSFUL, LOCATION_FORWARD, or TRANSPORT_RETRY. SUCCESSFUL means an asynchronous request returned successfully. LOCATION_FORWARD means that a reply came back with LOCATION_FORWARD as its status. TRANSPORT_RETRY means that the transport mechanism indicated a retry - a GIOP reply with a status of NEEDS_ADDRESSING_MODE, for instance.
        On the server:
        • Within the send_reply interception point, this will only be SUCCESSFUL.
        • Within the send_exception interception point, this will be either SYSTEM_EXCEPTION or USER_EXCEPTION.
        • Within the send_other interception point, this attribute will be any of: SUCCESSFUL, or LOCATION_FORWARD. SUCCESSFUL means an asynchronous request returned successfully. LOCATION_FORWARD means that a reply came back with LOCATION_FORWARD as its status.
        See Also:
        SUCCESSFUL, SYSTEM_EXCEPTION, USER_EXCEPTION, LOCATION_FORWARD, TRANSPORT_RETRY

      • forward_reference

        Object forward_reference()
        Contains the object to which the request will be forwarded, if the reply_status attribute is LOCATION_FORWARD. It is indeterminate whether a forwarded request will actually occur.

      • get_slot

        Any get_slot(int id)
      throws InvalidSlot
        Returns the data from the given slot of the PortableInterceptor.Current that is in the scope of the request.

        If the given slot has not been set, then an any containing a type code with a TCKind value of tk_null is returned.

        Parameters:
        id - The SlotId of the slot which is to be returned.
        Returns:
        The slot data, in the form of an any, obtained with the given identifier.
        Throws:
        InvalidSlot - thrown if the ID does not define an allocated slot.
        See Also:
        Current

      • get_request_service_context

        ServiceContext get_request_service_context(int id)
        Returns a copy of the service context with the given ID that is associated with the request.

        Parameters:
        id - The IOP.ServiceId of the service context which is to be returned.
        Returns:
        The IOP.ServiceContext obtained with the given identifier.
        Throws:
        BAD_PARAM - thrown with a standard minor code of 26, if the request's service context does not contain an entry for that ID.

      • get_reply_service_context

        ServiceContext get_reply_service_context(int id)
        Returns a copy of the service context with the given ID that is associated with the reply.
        Parameters:
        id - The IOP.ServiceId of the service context which is to be returned.
        Returns:
        The IOP.ServiceContext obtained with the given identifier.
        Throws:
        BAD_PARAM - thrown with a standard minor code of 26 if the request's service context does not contain an entry for that ID.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServerIdHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Class ServerIdHelper

  • java.lang.Object
    • org.omg.PortableInterceptor.ServerIdHelper

  • public abstract class ServerIdHelper
extends Object
    org/omg/PortableInterceptor/ServerIdHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      ServerIdHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static String | extract(Any a)
      static String | id()
      static void | insert(Any a, String that)
      static String | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, String value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ServerIdHelper

        public ServerIdHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          String that)

      • extract

        public static String extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static String read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         String value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServerRequestInfo (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface ServerRequestInfo

  • All Superinterfaces:
    IDLEntity, Object, RequestInfo, RequestInfoOperations, Serializable, ServerRequestInfoOperations

    public interface ServerRequestInfo
extends ServerRequestInfoOperations, RequestInfo, IDLEntity
    Request Information, accessible to server-side request interceptors.

    Some attributes and operations on ServerRequestInfo are not valid at all interception points. The following table shows the validity of each attribute or operation. If it is not valid, attempting to access it will result in a BAD_INV_ORDER being thrown with a standard minor code of 14.

    receive_request_
    service_contexts     		receive_request send_reply send_exception send_other
    Inherited from RequestInfo:

    request_id

             yes yes yes yes yes

    operation

             yes yes yes yes yes

    arguments

             no yes1 yes no2 no2

    exceptions

             no yes yes yes yes

    contexts

             no yes yes yes yes

    operation_context

             no yes yes no no

    result

             no no yes no no

    response_expected

             yes yes yes yes yes

    sync_scope

             yes yes yes yes yes
    request_id | yes | yes | yes | yes | yes
    operation | yes | yes | yes | yes | yes
    arguments | no | yes1 | yes | no2 | no2
    exceptions | no | yes | yes | yes | yes
    contexts | no | yes | yes | yes | yes
    operation_context | no | yes | yes | no | no
    result | no | no | yes | no | no
    response_expected | yes | yes | yes | yes | yes
    sync_scope | yes | yes | yes | yes | yes
    reply_status | no | no | yes | yes | yes
    forward_reference | no | no | no | no | yes2
    get_slot | yes | yes | yes | yes | yes
    get_request_service_context | yes | no | yes | yes | yes
    get_reply_service_context | no | no | yes | yes | yes
    ServerRequestInfo-specific:
    sending_exception | no | no | no | yes | no
    object_id | no | yes | yes | yes3 | yes3
    adapter_id | no | yes | yes | yes3 | yes3
    server_id | no | yes | yes | yes | yes
    orb_id | no | yes | yes | yes | yes
    adapter_name | no | yes | yes | yes | yes
    target_most_derived_interface | no | yes | no4 | no4 | no4
    get_server_policy | yes | yes | yes | yes | yes
    set_slot | yes | yes | yes | yes | yes
    target_is_a | no | yes | no4 | no4 | no4
    add_reply_service_context | yes | yes | yes | yes | yes
    1. When ServerRequestInfo is passed to receive_request, there is an entry in the list for every argument, whether in, inout, or out. But only the in and inout arguments will be available.
    2. If the reply_status attribute is not LOCATION_FORWARD, accessing this attribute will throw BAD_INV_ORDER with a standard minor code of 14.
    3. If the servant locator caused a location forward, or thrown an exception, this attribute/operation may not be available in this interception point. NO_RESOURCES with a standard minor code of 1 will be thrown if it is not available.
    4. The operation is not available in this interception point because the necessary information requires access to the target object's servant, which may no longer be available to the ORB. For example, if the object's adapter is a POA that uses a ServantLocator, then the ORB invokes the interception point after it calls ServantLocator.postinvoke()
      5. .
    See Also:
    ServerRequestInterceptor

    • Method Summary

      • Methods inherited from interface org.omg.PortableInterceptor.ServerRequestInfoOperations

        adapter_id, adapter_name, add_reply_service_context, get_server_policy, object_id, orb_id, sending_exception, server_id, set_slot, target_is_a, target_most_derived_interface

      • Methods inherited from interface org.omg.PortableInterceptor.RequestInfoOperations

        arguments, contexts, exceptions, forward_reference, get_reply_service_context, get_request_service_context, get_slot, operation_context, operation, reply_status, request_id, response_expected, result, sync_scope

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServerRequestInfoOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface ServerRequestInfoOperations

  • All Superinterfaces:
    RequestInfoOperations
    All Known Subinterfaces:
    ServerRequestInfo

    public interface ServerRequestInfoOperations
extends RequestInfoOperations
    Request Information, accessible to server-side request interceptors.

    Some attributes and operations on ServerRequestInfo are not valid at all interception points. The following table shows the validity of each attribute or operation. If it is not valid, attempting to access it will result in a BAD_INV_ORDER being thrown with a standard minor code of 14.

    receive_request_
    service_contexts     		receive_request send_reply send_exception send_other
    Inherited from RequestInfo:

    request_id

             yes yes yes yes yes

    operation

             yes yes yes yes yes

    arguments

             no yes1 yes no2 no2

    exceptions

             no yes yes yes yes

    contexts

             no yes yes yes yes

    operation_context

             no yes yes no no

    result

             no no yes no no

    response_expected

             yes yes yes yes yes

    sync_scope

             yes yes yes yes yes
    request_id | yes | yes | yes | yes | yes
    operation | yes | yes | yes | yes | yes
    arguments | no | yes1 | yes | no2 | no2
    exceptions | no | yes | yes | yes | yes
    contexts | no | yes | yes | yes | yes
    operation_context | no | yes | yes | no | no
    result | no | no | yes | no | no
    response_expected | yes | yes | yes | yes | yes
    sync_scope | yes | yes | yes | yes | yes
    reply_status | no | no | yes | yes | yes
    forward_reference | no | no | no | no | yes2
    get_slot | yes | yes | yes | yes | yes
    get_request_service_context | yes | no | yes | yes | yes
    get_reply_service_context | no | no | yes | yes | yes
    ServerRequestInfo-specific:
    sending_exception | no | no | no | yes | no
    object_id | no | yes | yes | yes3 | yes3
    adapter_id | no | yes | yes | yes3 | yes3
    server_id | no | yes | yes | yes | yes
    orb_id | no | yes | yes | yes | yes
    adapter_name | no | yes | yes | yes | yes
    target_most_derived_interface | no | yes | no4 | no4 | no4
    get_server_policy | yes | yes | yes | yes | yes
    set_slot | yes | yes | yes | yes | yes
    target_is_a | no | yes | no4 | no4 | no4
    add_reply_service_context | yes | yes | yes | yes | yes
    1. When ServerRequestInfo is passed to receive_request, there is an entry in the list for every argument, whether in, inout, or out. But only the in and inout arguments will be available.
    2. If the reply_status attribute is not LOCATION_FORWARD, accessing this attribute will throw BAD_INV_ORDER with a standard minor code of 14.
    3. If the servant locator caused a location forward, or thrown an exception, this attribute/operation may not be available in this interception point. NO_RESOURCES with a standard minor code of 1 will be thrown if it is not available.
    4. The operation is not available in this interception point because the necessary information requires access to the target object's servant, which may no longer be available to the ORB. For example, if the object's adapter is a POA that uses a ServantLocator, then the ORB invokes the interception point after it calls ServantLocator.postinvoke()
      5. .
    See Also:
    ServerRequestInterceptor

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      byte[] adapter_id()
      Returns the opaque identifier for the object adapter.
      String[] adapter_name()
      Returns the sequence of strings that identifies the object adapter instance that is handling this request.
      void add_reply_service_context(ServiceContext service_context, boolean replace)
      Allows Interceptors to add service contexts to the request.
      Policy get_server_policy(int type)
      Returns the policy in effect for this operation for the given policy type.
      byte[] object_id()
      Returns the opaque object_id describing the target of the operation invocation.
      String orb_id()
      Returns the ID that was used to create the ORB.
      Any sending_exception()
      Returns an any which contains the exception to be returned to the client.
      String server_id()
      Returns the server ID that was specified on ORB::init using the -ORBServerId argument.
      void set_slot(int id, Any data)
      Allows an Interceptor to set a slot in the PortableInterceptor.Current that is in the scope of the request.
      boolean target_is_a(String id)
      Returns true if the servant is the given repository id, false if it is not.
      String target_most_derived_interface()
      Returns the repository id for the most derived interface of the servant.

      • Methods inherited from interface org.omg.PortableInterceptor.RequestInfoOperations

        arguments, contexts, exceptions, forward_reference, get_reply_service_context, get_request_service_context, get_slot, operation_context, operation, reply_status, request_id, response_expected, result, sync_scope

    • Method Detail

      • sending_exception

        Any sending_exception()
        Returns an any which contains the exception to be returned to the client.

        If the exception is a user exception which cannot be inserted into an any (e.g., it is unknown or the bindings don't provide the TypeCode), then this attribute will be an any containing the system exception UNKNOWN with a standard minor code of 1.

        See Also:
        PortableInterceptor package comments for limitations / unimplemented features

      • object_id

        byte[] object_id()
        Returns the opaque object_id describing the target of the operation invocation.

      • adapter_id

        byte[] adapter_id()
        Returns the opaque identifier for the object adapter.

      • server_id

        String server_id()
        Returns the server ID that was specified on ORB::init using the -ORBServerId argument.

      • orb_id

        String orb_id()
        Returns the ID that was used to create the ORB.

      • adapter_name

        String[] adapter_name()
        Returns the sequence of strings that identifies the object adapter instance that is handling this request.

      • target_most_derived_interface

        String target_most_derived_interface()
        Returns the repository id for the most derived interface of the servant.

      • get_server_policy

        Policy get_server_policy(int type)
        Returns the policy in effect for this operation for the given policy type. The returned CORBA.Policy object shall only be a policy whose type was registered via register_policy_factory.
        Parameters:
        type - The CORBA.PolicyType which specifies the policy to be returned.
        Returns:
        The CORBA.Policy obtained with the given policy type.
        Throws:
        INV_POLICY - thrown, with a standard minor code of 2, if a policy for the given type was not registered via register_policy_factory.
        See Also:
        ORBInitInfoOperations.register_policy_factory(int, org.omg.PortableInterceptor.PolicyFactory)

      • set_slot

        void set_slot(int id,
              Any data)
       throws InvalidSlot
        Allows an Interceptor to set a slot in the PortableInterceptor.Current that is in the scope of the request. If data already exists in that slot, it will be overwritten.
        Parameters:
        id - The id of the slot.
        data - The data, in the form of an any, to store in that slot.
        Throws:
        InvalidSlot - thrown if the ID does not define an allocated slot.
        See Also:
        Current

      • target_is_a

        boolean target_is_a(String id)
        Returns true if the servant is the given repository id, false if it is not.
        Parameters:
        id - The caller wants to know if the servant is this repository id.
        Returns:
        Is the servant the given RepositoryId?

      • add_reply_service_context

        void add_reply_service_context(ServiceContext service_context,
                               boolean replace)
        Allows Interceptors to add service contexts to the request.

        There is no declaration of the order of the service contexts. They may or may not appear in the order that they are added.

        Parameters:
        service_context - The IOP.ServiceContext to add to the reply.
        replace - Indicates the behavior of this operation when a service context already exists with the given ID. If false, then BAD_INV_ORDER with a standard minor code of 15 is thrown. If true, then the existing service context is replaced by the new one.
        Throws:
        BAD_INV_ORDER - thrown, with a standard minor code of 15, if replace is false and a service context already exists with the given ID.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServerRequestInterceptor (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface ServerRequestInterceptor

  • All Superinterfaces:
    IDLEntity, Interceptor, InterceptorOperations, Object, Serializable, ServerRequestInterceptorOperations

    public interface ServerRequestInterceptor
extends ServerRequestInterceptorOperations, Interceptor, IDLEntity
    Server-side request interceptor.

    A request Interceptor is designed to intercept the flow of a request/reply sequence through the ORB at specific points so that services can query the request information and manipulate the service contexts which are propagated between clients and servers. The primary use of request Interceptors is to enable ORB services to transfer context information between clients and servers. There are two types of request Interceptors: client-side and server-side.

    To write a server-side Interceptor, implement the ServerRequestInterceptor interface.

    See Also:
    ServerRequestInfo

    • Method Summary

      • Methods inherited from interface org.omg.PortableInterceptor.ServerRequestInterceptorOperations

        receive_request_service_contexts, receive_request, send_exception, send_other, send_reply

      • Methods inherited from interface org.omg.PortableInterceptor.InterceptorOperations

        destroy, name

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServerRequestInterceptorOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface ServerRequestInterceptorOperations

  • All Superinterfaces:
    InterceptorOperations
    All Known Subinterfaces:
    ServerRequestInterceptor

    public interface ServerRequestInterceptorOperations
extends InterceptorOperations
    Server-side request interceptor.

    A request Interceptor is designed to intercept the flow of a request/reply sequence through the ORB at specific points so that services can query the request information and manipulate the service contexts which are propagated between clients and servers. The primary use of request Interceptors is to enable ORB services to transfer context information between clients and servers. There are two types of request Interceptors: client-side and server-side.

    To write a server-side Interceptor, implement the ServerRequestInterceptor interface.

    See Also:
    ServerRequestInfo

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void receive_request_service_contexts(ServerRequestInfo ri)
      Allows the interceptor to process service context information.
      void receive_request(ServerRequestInfo ri)
      Allows an Interceptor to query request information after all the information, including operation parameters, are available.
      void send_exception(ServerRequestInfo ri)
      Allows an Interceptor to query the exception information and modify the reply service context before the exception is thrown to the client.
      void send_other(ServerRequestInfo ri)
      Allows an Interceptor to query the information available when a request results in something other than a normal reply or an exception.
      void send_reply(ServerRequestInfo ri)
      Allows an Interceptor to query reply information and modify the reply service context after the target operation has been invoked and before the reply is returned to the client.

      • Methods inherited from interface org.omg.PortableInterceptor.InterceptorOperations

        destroy, name

    • Method Detail

      • receive_request_service_contexts

        void receive_request_service_contexts(ServerRequestInfo ri)
                               throws ForwardRequest
        Allows the interceptor to process service context information.

        At this interception point, Interceptors must get their service context information from the incoming request transfer it to PortableInterceptor.Current's slots.

        This interception point is called before the servant manager is called. Operation parameters are not yet available at this point. This interception point may or may not execute in the same thread as the target invocation.

        This interception point may throw a system exception. If it does, no other Interceptors' receive_request_service_contexts operations are called. Those Interceptors on the Flow Stack are popped and their send_exception interception points are called.

        This interception point may also throw a ForwardRequest exception. If an Interceptor throws this exception, no other Interceptors' receive_request_service_contexts operations are called. Those Interceptors on the Flow Stack are popped and their send_other interception points are called.

        Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. The completion_status shall be COMPLETED_NO.

        Parameters:
        ri - Information about the current request being intercepted.
        Throws:
        ForwardRequest - If thrown, indicates to the ORB that a retry of the request should occur with the new object given in the exception.

      • receive_request

        void receive_request(ServerRequestInfo ri)
              throws ForwardRequest
        Allows an Interceptor to query request information after all the information, including operation parameters, are available. This interception point shall execute in the same thread as the target invocation.

        In the DSI model, since the parameters are first available when the user code calls arguments, receive_request is called from within arguments. It is possible that arguments is not called in the DSI model. The target may call set_exception before calling arguments. The ORB shall guarantee that receive_request is called once, either through arguments or through set_exception. If it is called through set_exception, requesting the arguments will result in NO_RESOURCES being thrown with a standard minor code of 1.

        This interception point may throw a system exception. If it does, no other Interceptors' receive_request operations are called. Those Interceptors on the Flow Stack are popped and their send_exception interception points are called.

        This interception point may also throw a ForwardRequest exception. If an Interceptor throws this exception, no other Interceptors' receive_request operations are called. Those Interceptors on the Flow Stack are popped and their send_other interception points are called.

        Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. The completion_status shall be COMPLETED_NO.

        Parameters:
        ri - Information about the current request being intercepted.
        Throws:
        ForwardRequest - If thrown, indicates to the ORB that a retry of the request should occur with the new object given in the exception.

      • send_reply

        void send_reply(ServerRequestInfo ri)
        Allows an Interceptor to query reply information and modify the reply service context after the target operation has been invoked and before the reply is returned to the client. This interception point shall execute in the same thread as the target invocation.

        This interception point may throw a system exception. If it does, no other Interceptors' send_reply operations are called. The remaining Interceptors in the Flow Stack shall have their send_exception interception point called.

        Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. The completion_status shall be COMPLETED_YES.

        Parameters:
        ri - Information about the current request being intercepted.

      • send_exception

        void send_exception(ServerRequestInfo ri)
             throws ForwardRequest
        Allows an Interceptor to query the exception information and modify the reply service context before the exception is thrown to the client. When an exception occurs, this interception point is called. This interception point shall execute in the same thread as the target invocation.

        This interception point may throw a system exception. This has the effect of changing the exception which successive Interceptors popped from the Flow Stack receive on their calls to send_exception. The exception thrown to the client will be the last exception thrown by an Interceptor, or the original exception if no Interceptor changes the exception.

        This interception point may also throw a ForwardRequest exception. If an Interceptor throws this exception, no other Interceptors' send_exception operations are called. The remaining Interceptors in the Flow Stack shall have their send_other interception points called.

        If the completion_status of the exception is not COMPLETED_NO, then it is inappropriate for this interception point to throw a ForwardRequest exception. The request's at-most-once semantics would be lost.

        Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. If the original exception is a system exception, the completion_status of the new exception shall be the same as on the original. If the original exception is a user exception, then the completion_status of the new exception shall be COMPLETED_YES.

        Parameters:
        ri - Information about the current request being intercepted.
        Throws:
        ForwardRequest - If thrown, indicates to the ORB that a retry of the request should occur with the new object given in the exception.

      • send_other

        void send_other(ServerRequestInfo ri)
         throws ForwardRequest
        Allows an Interceptor to query the information available when a request results in something other than a normal reply or an exception. For example, a request could result in a retry (e.g., a GIOP Reply with a LOCATION_FORWARD status was received). This interception point shall execute in the same thread as the target invocation.

        This interception point may throw a system exception. If it does, no other Interceptors' send_other operations are called. The remaining Interceptors in the Flow Stack shall have their send_exception interception points called.

        This interception point may also throw a ForwardRequest exception. If an Interceptor throws this exception, successive Interceptors' send_other operations are called with the new information provided by the ForwardRequest exception.

        Compliant Interceptors shall properly follow completion_status semantics if they throw a system exception from this interception point. The completion_status shall be COMPLETED_NO.

        Parameters:
        ri - Information about the current request being intercepted.
        Throws:
        ForwardRequest - If thrown, indicates to the ORB that a retry of the request should occur with the new object given in the exception.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SUCCESSFUL (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface SUCCESSFUL

  • public interface SUCCESSFUL
    org/omg/PortableInterceptor/SUCCESSFUL.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short value
      Indicates a successful Reply Status.

    • Field Detail

      • value

        static final short value
        Indicates a successful Reply Status. One possible value for RequestInfo.reply_status.
        See Also:
        RequestInfoOperations.reply_status(), SYSTEM_EXCEPTION, USER_EXCEPTION, LOCATION_FORWARD, TRANSPORT_RETRY, Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SYSTEM_EXCEPTION (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface SYSTEM_EXCEPTION

  • public interface SYSTEM_EXCEPTION
    org/omg/PortableInterceptor/SYSTEM_EXCEPTION.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short value
      Indicates a SystemException reply status.

    • Field Detail

      • value

        static final short value
        Indicates a SystemException reply status. One possible value for RequestInfo.reply_status.
        See Also:
        RequestInfoOperations.reply_status(), SUCCESSFUL, USER_EXCEPTION, LOCATION_FORWARD, TRANSPORT_RETRY, Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TRANSPORT_RETRY (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface TRANSPORT_RETRY

  • public interface TRANSPORT_RETRY
    org/omg/PortableInterceptor/TRANSPORT_RETRY.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short value
      Indicates a Transport Retry reply status.

    • Field Detail

      • value

        static final short value
        Indicates a Transport Retry reply status. One possible value for RequestInfo.reply_status.
        See Also:
        RequestInfoOperations.reply_status(), SUCCESSFUL, SYSTEM_EXCEPTION, USER_EXCEPTION, LOCATION_FORWARD, Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UNKNOWN (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface UNKNOWN

  • public interface UNKNOWN
    org/omg/PortableInterceptor/UNKNOWN.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short value
      XXX

    • Field Detail

      • value

        static final short value
        XXX
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


USER_EXCEPTION (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableInterceptor

Interface USER_EXCEPTION

  • public interface USER_EXCEPTION
    org/omg/PortableInterceptor/USER_EXCEPTION.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableInterceptor/Interceptors.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short value
      Indicates a UserException reply status.

    • Field Detail

      • value

        static final short value
        Indicates a UserException reply status. One possible value for RequestInfo.reply_status.
        See Also:
        RequestInfoOperations.reply_status(), SUCCESSFUL, SYSTEM_EXCEPTION, LOCATION_FORWARD, TRANSPORT_RETRY, Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AdapterActivator (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface AdapterActivator

  • All Superinterfaces:
    AdapterActivatorOperations, IDLEntity, Object, Serializable

    public interface AdapterActivator
extends AdapterActivatorOperations, Object, IDLEntity
    An adapter activator supplies a POA with the ability to create child POAs on demand, as a side-effect of receiving a request that names the child POA (or one of its children), or when find_POA is called with an activate parameter value of TRUE.

    • Method Summary

      • Methods inherited from interface org.omg.PortableServer.AdapterActivatorOperations

        unknown_adapter

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AdapterActivatorOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface AdapterActivatorOperations

  • All Known Subinterfaces:
    AdapterActivator

    public interface AdapterActivatorOperations
    An adapter activator supplies a POA with the ability to create child POAs on demand, as a side-effect of receiving a request that names the child POA (or one of its children), or when find_POA is called with an activate parameter value of TRUE.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      boolean unknown_adapter(POA parent, String name)
      This operation is invoked when the ORB receives a request for an object reference that identifies a target POA that does not exist.

    • Method Detail

      • unknown_adapter

        boolean unknown_adapter(POA parent,
                        String name)
        This operation is invoked when the ORB receives a request for an object reference that identifies a target POA that does not exist. The ORB invokes this operation once for each POA that must be created in order for the target POA to exist.
        Parameters:
        parent - indicates the parent POA for the POA that needs to be created.
        name - identifies the name of the POA relative to the parent.
        Returns:
        returns TRUE if the POA was created or FALSE otherwise.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Interface org.omg.PortableServer.AdapterActivator (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.AdapterActivator

  • Packages that use AdapterActivator
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of AdapterActivator in org.omg.PortableServer

      Methods in org.omg.PortableServer that return AdapterActivator
      Modifier and Type Method and Description
      AdapterActivator POAOperations.the_activator()
      This attribute identifies the adapter activator associated with the POA.
      Methods in org.omg.PortableServer with parameters of type AdapterActivator
      Modifier and Type Method and Description
      void POAOperations.the_activator(AdapterActivator newThe_activator)
      This attribute identifies the adapter activator associated with the POA.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableServer.AdapterActivatorOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.AdapterActivatorOperations

  • Packages that use AdapterActivatorOperations
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of AdapterActivatorOperations in org.omg.PortableServer

      Subinterfaces of AdapterActivatorOperations in org.omg.PortableServer
      Modifier and Type Interface and Description
      interface  AdapterActivator
      An adapter activator supplies a POA with the ability to create child POAs on demand, as a side-effect of receiving a request that names the child POA (or one of its children), or when find_POA is called with an activate parameter value of TRUE.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableServer.Current (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.Current

  • Packages that use Current
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of Current in org.omg.PortableServer

      Methods in org.omg.PortableServer that return Current
      Modifier and Type | Method and Description
      static Current | CurrentHelper.extract(Any a)
      static Current | CurrentHelper.narrow(Object obj)
      static Current | CurrentHelper.read(InputStream istream)
      Methods in org.omg.PortableServer with parameters of type Current
      Modifier and Type | Method and Description
      static void | CurrentHelper.insert(Any a, Current that)
      static void | CurrentHelper.write(OutputStream ostream, Current value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.CurrentHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.CurrentHelper

No usage of org.omg.PortableServer.CurrentHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableServer.CurrentOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.CurrentOperations

  • Packages that use CurrentOperations
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of CurrentOperations in org.omg.PortableServer

      Subinterfaces of CurrentOperations in org.omg.PortableServer
      Modifier and Type Interface and Description
      interface  Current
      The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.DynamicImplementation (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.DynamicImplementation

No usage of org.omg.PortableServer.DynamicImplementation
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.ForwardRequest (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.ForwardRequest

  • Packages that use ForwardRequest
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ForwardRequest in org.omg.PortableServer

      Methods in org.omg.PortableServer that return ForwardRequest
      Modifier and Type | Method and Description
      static ForwardRequest | ForwardRequestHelper.extract(Any a)
      static ForwardRequest | ForwardRequestHelper.read(InputStream istream)
      Methods in org.omg.PortableServer with parameters of type ForwardRequest
      Modifier and Type | Method and Description
      static void | ForwardRequestHelper.insert(Any a, ForwardRequest that)
      static void | ForwardRequestHelper.write(OutputStream ostream, ForwardRequest value)
      Methods in org.omg.PortableServer that throw ForwardRequest
      Modifier and Type Method and Description
      Servant _ServantActivatorStub.incarnate(byte[] oid, POA adapter)
      This operation is invoked by the POA whenever the POA receives a request for an object that is not currently active, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
      Servant ServantActivatorOperations.incarnate(byte[] oid, POA adapter)
      This operation is invoked by the POA whenever the POA receives a request for an object that is not currently active, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
      Servant ServantLocatorOperations.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie)
      This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.
      Servant _ServantLocatorStub.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie)
      This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.ForwardRequestHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.ForwardRequestHelper

No usage of org.omg.PortableServer.ForwardRequestHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableServer.IdAssignmentPolicy (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.IdAssignmentPolicy

  • Packages that use IdAssignmentPolicy
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of IdAssignmentPolicy in org.omg.PortableServer

      Methods in org.omg.PortableServer that return IdAssignmentPolicy
      Modifier and Type Method and Description
      IdAssignmentPolicy POAOperations.create_id_assignment_policy(IdAssignmentPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableServer.IdAssignmentPolicyOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.IdAssignmentPolicyOperations

  • Packages that use IdAssignmentPolicyOperations
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of IdAssignmentPolicyOperations in org.omg.PortableServer

      Subinterfaces of IdAssignmentPolicyOperations in org.omg.PortableServer
      Modifier and Type Interface and Description
      interface  IdAssignmentPolicy
      IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.IdAssignmentPolicyValue (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.IdAssignmentPolicyValue

  • Packages that use IdAssignmentPolicyValue
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of IdAssignmentPolicyValue in org.omg.PortableServer

      Fields in org.omg.PortableServer declared as IdAssignmentPolicyValue
      Modifier and Type | Field and Description
      static IdAssignmentPolicyValue | IdAssignmentPolicyValue.SYSTEM_ID
      static IdAssignmentPolicyValue | IdAssignmentPolicyValue.USER_ID
      Methods in org.omg.PortableServer that return IdAssignmentPolicyValue
      Modifier and Type | Method and Description
      static IdAssignmentPolicyValue | IdAssignmentPolicyValue.from_int(int value)
      IdAssignmentPolicyValue IdAssignmentPolicyOperations.value()
      specifies the policy value
      Methods in org.omg.PortableServer with parameters of type IdAssignmentPolicyValue
      Modifier and Type Method and Description
      IdAssignmentPolicy POAOperations.create_id_assignment_policy(IdAssignmentPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableServer.IdUniquenessPolicy (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.IdUniquenessPolicy

  • Packages that use IdUniquenessPolicy
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of IdUniquenessPolicy in org.omg.PortableServer

      Methods in org.omg.PortableServer that return IdUniquenessPolicy
      Modifier and Type Method and Description
      IdUniquenessPolicy POAOperations.create_id_uniqueness_policy(IdUniquenessPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableServer.IdUniquenessPolicyOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.IdUniquenessPolicyOperations

  • Packages that use IdUniquenessPolicyOperations
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of IdUniquenessPolicyOperations in org.omg.PortableServer

      Subinterfaces of IdUniquenessPolicyOperations in org.omg.PortableServer
      Modifier and Type Interface and Description
      interface  IdUniquenessPolicy
      The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.IdUniquenessPolicyValue (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.IdUniquenessPolicyValue

  • Packages that use IdUniquenessPolicyValue
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of IdUniquenessPolicyValue in org.omg.PortableServer

      Fields in org.omg.PortableServer declared as IdUniquenessPolicyValue
      Modifier and Type | Field and Description
      static IdUniquenessPolicyValue | IdUniquenessPolicyValue.MULTIPLE_ID
      static IdUniquenessPolicyValue | IdUniquenessPolicyValue.UNIQUE_ID
      Methods in org.omg.PortableServer that return IdUniquenessPolicyValue
      Modifier and Type | Method and Description
      static IdUniquenessPolicyValue | IdUniquenessPolicyValue.from_int(int value)
      IdUniquenessPolicyValue IdUniquenessPolicyOperations.value()
      specifies the policy value
      Methods in org.omg.PortableServer with parameters of type IdUniquenessPolicyValue
      Modifier and Type Method and Description
      IdUniquenessPolicy POAOperations.create_id_uniqueness_policy(IdUniquenessPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableServer.ID_ASSIGNMENT_POLICY_ID (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.ID_ASSIGNMENT_POLICY_ID

No usage of org.omg.PortableServer.ID_ASSIGNMENT_POLICY_ID
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableServer.ID_UNIQUENESS_POLICY_ID (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.ID_UNIQUENESS_POLICY_ID

No usage of org.omg.PortableServer.ID_UNIQUENESS_POLICY_ID
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableServer.ImplicitActivationPolicy (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.ImplicitActivationPolicy

  • Packages that use ImplicitActivationPolicy
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ImplicitActivationPolicy in org.omg.PortableServer

      Methods in org.omg.PortableServer that return ImplicitActivationPolicy
      Modifier and Type Method and Description
      ImplicitActivationPolicy POAOperations.create_implicit_activation_policy(ImplicitActivationPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableServer.ImplicitActivationPolicyOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.ImplicitActivationPolicyOperations

  • Packages that use ImplicitActivationPolicyOperations
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ImplicitActivationPolicyOperations in org.omg.PortableServer

      Subinterfaces of ImplicitActivationPolicyOperations in org.omg.PortableServer
      Modifier and Type Interface and Description
      interface  ImplicitActivationPolicy
      This policy specifies whether implicit activation of servants is supported in the created POA.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.ImplicitActivationPolicyValue (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.ImplicitActivationPolicyValue

  • Packages that use ImplicitActivationPolicyValue
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ImplicitActivationPolicyValue in org.omg.PortableServer

      Fields in org.omg.PortableServer declared as ImplicitActivationPolicyValue
      Modifier and Type | Field and Description
      static ImplicitActivationPolicyValue | ImplicitActivationPolicyValue.IMPLICIT_ACTIVATION
      static ImplicitActivationPolicyValue | ImplicitActivationPolicyValue.NO_IMPLICIT_ACTIVATION
      Methods in org.omg.PortableServer that return ImplicitActivationPolicyValue
      Modifier and Type | Method and Description
      static ImplicitActivationPolicyValue | ImplicitActivationPolicyValue.from_int(int value)
      ImplicitActivationPolicyValue ImplicitActivationPolicyOperations.value()
      specifies the policy value
      Methods in org.omg.PortableServer with parameters of type ImplicitActivationPolicyValue
      Modifier and Type Method and Description
      ImplicitActivationPolicy POAOperations.create_implicit_activation_policy(ImplicitActivationPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableServer.IMPLICIT_ACTIVATION_POLICY_ID (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.IMPLICIT_ACTIVATION_POLICY_ID

No usage of org.omg.PortableServer.IMPLICIT_ACTIVATION_POLICY_ID
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableServer.LifespanPolicy (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.LifespanPolicy

  • Packages that use LifespanPolicy
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of LifespanPolicy in org.omg.PortableServer

      Methods in org.omg.PortableServer that return LifespanPolicy
      Modifier and Type Method and Description
      LifespanPolicy POAOperations.create_lifespan_policy(LifespanPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableServer.LifespanPolicyOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.LifespanPolicyOperations

  • Packages that use LifespanPolicyOperations
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of LifespanPolicyOperations in org.omg.PortableServer

      Subinterfaces of LifespanPolicyOperations in org.omg.PortableServer
      Modifier and Type Interface and Description
      interface  LifespanPolicy
      The LifespanPolicy specifies the lifespan of the objects implemented in the created POA.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.LifespanPolicyValue (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.LifespanPolicyValue

  • Packages that use LifespanPolicyValue
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of LifespanPolicyValue in org.omg.PortableServer

      Fields in org.omg.PortableServer declared as LifespanPolicyValue
      Modifier and Type | Field and Description
      static LifespanPolicyValue | LifespanPolicyValue.PERSISTENT
      static LifespanPolicyValue | LifespanPolicyValue.TRANSIENT
      Methods in org.omg.PortableServer that return LifespanPolicyValue
      Modifier and Type | Method and Description
      static LifespanPolicyValue | LifespanPolicyValue.from_int(int value)
      LifespanPolicyValue LifespanPolicyOperations.value()
      specifies the policy value
      Methods in org.omg.PortableServer with parameters of type LifespanPolicyValue
      Modifier and Type Method and Description
      LifespanPolicy POAOperations.create_lifespan_policy(LifespanPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableServer.LIFESPAN_POLICY_ID (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.LIFESPAN_POLICY_ID

No usage of org.omg.PortableServer.LIFESPAN_POLICY_ID
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableServer.POA (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.POA

  • Packages that use POA
    Package Description
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.portable
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of POA in org.omg.CosNaming

      Methods in org.omg.CosNaming with parameters of type POA
      Modifier and Type | Method and Description
      String[] | NamingContextPOA._all_interfaces(POA poa, byte[] objectId)
      String[] | BindingIteratorPOA._all_interfaces(POA poa, byte[] objectId)
      String[] | NamingContextExtPOA._all_interfaces(POA poa, byte[] objectId)

    • Uses of POA in org.omg.PortableServer

      Methods in org.omg.PortableServer that return POA
      Modifier and Type | Method and Description
      POA Servant._default_POA()
      Returns the root POA from the ORB instance associated with the servant.
      POA Servant._poa()
      Allows easy execution of common methods, equivalent to PortableServer::Current:get_POA.
      POA POAOperations.create_POA(String adapter_name, POAManager a_POAManager, Policy[] policies)
      This operation creates a new POA as a child of the target POA.
      static POA | POAHelper.extract(Any a)
      POA POAOperations.find_POA(String adapter_name, boolean activate_it)
      If the target POA is the parent of a child POA with the specified name (relative to the target POA), that child POA is returned.
      POA CurrentOperations.get_POA()
      Returns reference to the POA implementing the object in whose context it is called.
      static POA | POAHelper.narrow(Object obj)
      static POA | POAHelper.read(InputStream istream)
      POA[] POAOperations.the_children()
      This attribute identifies the current set of all child POAs of the POA.
      POA POAOperations.the_parent()
      This attribute identifies the parent of the POA.
      Methods in org.omg.PortableServer with parameters of type POA
      Modifier and Type | Method and Description
      String[] | ServantLocatorPOA._all_interfaces(POA poa, byte[] objectId)
      String[] | ServantActivatorPOA._all_interfaces(POA poa, byte[] objectId)
      abstract String[] Servant._all_interfaces(POA poa, byte[] objectId)
      Used by the ORB to obtain complete type information from the servant.
      void _ServantActivatorStub.etherealize(byte[] oid, POA adapter, Servant serv, boolean cleanup_in_progress, boolean remaining_activations)
      This operation is invoked whenever a servant for an object is deactivated, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
      void ServantActivatorOperations.etherealize(byte[] oid, POA adapter, Servant serv, boolean cleanup_in_progress, boolean remaining_activations)
      This operation is invoked whenever a servant for an object is deactivated, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
      Servant _ServantActivatorStub.incarnate(byte[] oid, POA adapter)
      This operation is invoked by the POA whenever the POA receives a request for an object that is not currently active, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
      Servant ServantActivatorOperations.incarnate(byte[] oid, POA adapter)
      This operation is invoked by the POA whenever the POA receives a request for an object that is not currently active, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
      static void | POAHelper.insert(Any a, POA that)
      void ServantLocatorOperations.postinvoke(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant)
      This operation is invoked whenener a servant completes a request.
      void _ServantLocatorStub.postinvoke(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant)
      This operation is invoked whenener a servant completes a request.
      Servant ServantLocatorOperations.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie)
      This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.
      Servant _ServantLocatorStub.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie)
      This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.
      boolean AdapterActivatorOperations.unknown_adapter(POA parent, String name)
      This operation is invoked when the ORB receives a request for an object reference that identifies a target POA that does not exist.
      static void | POAHelper.write(OutputStream ostream, POA value)

    • Uses of POA in org.omg.PortableServer.portable

      Methods in org.omg.PortableServer.portable that return POA
      Modifier and Type Method and Description
      POA Delegate.default_POA(Servant Self)
      The default behavior of this function is to return the root POA from the ORB instance associated with the servant.
      POA Delegate.poa(Servant Self)
      The method _poa() is equivalent to calling PortableServer::Current:get_POA.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.POAHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAHelper

No usage of org.omg.PortableServer.POAHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableServer.POAManager (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.POAManager

  • Packages that use POAManager
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of POAManager in org.omg.PortableServer

      Methods in org.omg.PortableServer that return POAManager
      Modifier and Type Method and Description
      POAManager POAOperations.the_POAManager()
      This attribute identifies the POA manager associated with the POA.
      Methods in org.omg.PortableServer with parameters of type POAManager
      Modifier and Type Method and Description
      POA POAOperations.create_POA(String adapter_name, POAManager a_POAManager, Policy[] policies)
      This operation creates a new POA as a child of the target POA.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableServer.POAManagerOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.POAManagerOperations

  • Packages that use POAManagerOperations
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of POAManagerOperations in org.omg.PortableServer

      Subinterfaces of POAManagerOperations in org.omg.PortableServer
      Modifier and Type Interface and Description
      interface  POAManager
      Each POA object has an associated POAManager object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableServer.POAOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.POAOperations

  • Packages that use POAOperations
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of POAOperations in org.omg.PortableServer

      Subinterfaces of POAOperations in org.omg.PortableServer
      Modifier and Type Interface and Description
      interface  POA
      A POA object manages the implementation of a collection of objects.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableServer.RequestProcessingPolicy (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.RequestProcessingPolicy

  • Packages that use RequestProcessingPolicy
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of RequestProcessingPolicy in org.omg.PortableServer

      Methods in org.omg.PortableServer that return RequestProcessingPolicy
      Modifier and Type Method and Description
      RequestProcessingPolicy POAOperations.create_request_processing_policy(RequestProcessingPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableServer.RequestProcessingPolicyOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.RequestProcessingPolicyOperations

  • Packages that use RequestProcessingPolicyOperations
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of RequestProcessingPolicyOperations in org.omg.PortableServer

      Subinterfaces of RequestProcessingPolicyOperations in org.omg.PortableServer
      Modifier and Type Interface and Description
      interface  RequestProcessingPolicy
      This policy specifies how requests are processed by the created POA.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.RequestProcessingPolicyValue (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.RequestProcessingPolicyValue

  • Packages that use RequestProcessingPolicyValue
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of RequestProcessingPolicyValue in org.omg.PortableServer

      Fields in org.omg.PortableServer declared as RequestProcessingPolicyValue
      Modifier and Type | Field and Description
      static RequestProcessingPolicyValue | RequestProcessingPolicyValue.USE_ACTIVE_OBJECT_MAP_ONLY
      static RequestProcessingPolicyValue | RequestProcessingPolicyValue.USE_DEFAULT_SERVANT
      static RequestProcessingPolicyValue | RequestProcessingPolicyValue.USE_SERVANT_MANAGER
      Methods in org.omg.PortableServer that return RequestProcessingPolicyValue
      Modifier and Type | Method and Description
      static RequestProcessingPolicyValue | RequestProcessingPolicyValue.from_int(int value)
      RequestProcessingPolicyValue RequestProcessingPolicyOperations.value()
      specifies the policy value
      Methods in org.omg.PortableServer with parameters of type RequestProcessingPolicyValue
      Modifier and Type Method and Description
      RequestProcessingPolicy POAOperations.create_request_processing_policy(RequestProcessingPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableServer.REQUEST_PROCESSING_POLICY_ID (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.REQUEST_PROCESSING_POLICY_ID

No usage of org.omg.PortableServer.REQUEST_PROCESSING_POLICY_ID
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.Servant (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.Servant

  • Packages that use Servant
    Package Description
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.portable
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of Servant in org.omg.CosNaming

      Subclasses of Servant in org.omg.CosNaming
      Modifier and Type Class and Description
      class  BindingIteratorPOA
      The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
      class  NamingContextExtPOA
      NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
      class  NamingContextPOA
      A naming context is an object that contains a set of name bindings in which each name is unique.

    • Uses of Servant in org.omg.PortableServer

      Subclasses of Servant in org.omg.PortableServer
      Modifier and Type Class and Description
      class  DynamicImplementation
      Allows dynamic handling of object invocations.
      class  ServantActivatorPOA
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      class  ServantLocatorPOA
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
      Methods in org.omg.PortableServer that return Servant
      Modifier and Type Method and Description
      Servant POAOperations.get_servant()
      This operation returns the default servant associated with the POA.
      Servant POAOperations.id_to_servant(byte[] oid)
      If the POA has the RETAIN policy and the specified ObjectId is in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map.
      Servant _ServantActivatorStub.incarnate(byte[] oid, POA adapter)
      This operation is invoked by the POA whenever the POA receives a request for an object that is not currently active, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
      Servant ServantActivatorOperations.incarnate(byte[] oid, POA adapter)
      This operation is invoked by the POA whenever the POA receives a request for an object that is not currently active, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
      Servant ServantLocatorOperations.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie)
      This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.
      Servant _ServantLocatorStub.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie)
      This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.
      Servant POAOperations.reference_to_servant(Object reference)
      If the POA has the RETAIN policy and the specified object is present in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map.
      Methods in org.omg.PortableServer with parameters of type Servant
      Modifier and Type Method and Description
      void POAOperations.activate_object_with_id(byte[] id, Servant p_servant)
      This operation enters an association between the specified Object Id and the specified servant in the Active Object Map.
      byte[] POAOperations.activate_object(Servant p_servant)
      This operation generates an Object Id and enters the Object Id and the specified servant in the Active Object Map.
      void _ServantActivatorStub.etherealize(byte[] oid, POA adapter, Servant serv, boolean cleanup_in_progress, boolean remaining_activations)
      This operation is invoked whenever a servant for an object is deactivated, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
      void ServantActivatorOperations.etherealize(byte[] oid, POA adapter, Servant serv, boolean cleanup_in_progress, boolean remaining_activations)
      This operation is invoked whenever a servant for an object is deactivated, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
      void ServantLocatorOperations.postinvoke(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant)
      This operation is invoked whenener a servant completes a request.
      void _ServantLocatorStub.postinvoke(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant)
      This operation is invoked whenener a servant completes a request.
      byte[] POAOperations.servant_to_id(Servant p_servant)
      This operation has four possible behaviors.
      Object POAOperations.servant_to_reference(Servant p_servant)
      This operation requires the RETAIN policy and either the UNIQUE_ID or IMPLICIT_ACTIVATION policies if invoked outside the context of an operation dispatched by this POA.
      void POAOperations.set_servant(Servant p_servant)
      This operation registers the specified servant with the POA as the default servant.

    • Uses of Servant in org.omg.PortableServer.portable

      Methods in org.omg.PortableServer.portable with parameters of type Servant
      Modifier and Type Method and Description
      POA Delegate.default_POA(Servant Self)
      The default behavior of this function is to return the root POA from the ORB instance associated with the servant.
      Object Delegate.get_interface_def(Servant self)
      This operation returns an object in the Interface Repository which provides type information that may be useful to a program.
      boolean Delegate.is_a(Servant Self, String Repository_Id)
      This method checks to see if the specified repid is present on the list returned by _all_interfaces() or is the repository id for the generic CORBA Object.
      boolean Delegate.non_existent(Servant Self)
      This operation is used to check for the existence of the Object.
      byte[] Delegate.object_id(Servant Self)
      The method _object_id() is equivalent to calling PortableServer::Current::get_object_id.
      ORB Delegate.orb(Servant Self)
      Convenience method that returns the instance of the ORB currently associated with the Servant.
      POA Delegate.poa(Servant Self)
      The method _poa() is equivalent to calling PortableServer::Current:get_POA.
      Object Delegate.this_object(Servant Self)
      This allows the servant to obtain the object reference for the target CORBA Object it is incarnating for that request.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableServer.ServantActivator (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.ServantActivator

  • Packages that use ServantActivator
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ServantActivator in org.omg.PortableServer

      Classes in org.omg.PortableServer that implement ServantActivator
      Modifier and Type Class and Description
      class  _ServantActivatorStub
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      Methods in org.omg.PortableServer that return ServantActivator
      Modifier and Type | Method and Description
      ServantActivator | ServantActivatorPOA._this()
      ServantActivator | ServantActivatorPOA._this(ORB orb)
      static ServantActivator | ServantActivatorHelper.extract(Any a)
      static ServantActivator | ServantActivatorHelper.narrow(Object obj)
      static ServantActivator | ServantActivatorHelper.read(InputStream istream)
      static ServantActivator | ServantActivatorHelper.unchecked_narrow(Object obj)
      Methods in org.omg.PortableServer with parameters of type ServantActivator
      Modifier and Type | Method and Description
      static void | ServantActivatorHelper.insert(Any a, ServantActivator that)
      static void | ServantActivatorHelper.write(OutputStream ostream, ServantActivator value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.ServantActivatorHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.ServantActivatorHelper

No usage of org.omg.PortableServer.ServantActivatorHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableServer.ServantActivatorOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.ServantActivatorOperations

  • Packages that use ServantActivatorOperations
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ServantActivatorOperations in org.omg.PortableServer

      Subinterfaces of ServantActivatorOperations in org.omg.PortableServer
      Modifier and Type Interface and Description
      interface  ServantActivator
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      Classes in org.omg.PortableServer that implement ServantActivatorOperations
      Modifier and Type Class and Description
      class  _ServantActivatorStub
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      class  ServantActivatorPOA
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.ServantActivatorPOA (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.ServantActivatorPOA

No usage of org.omg.PortableServer.ServantActivatorPOA
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableServer.ServantLocator (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.ServantLocator

  • Packages that use ServantLocator
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ServantLocator in org.omg.PortableServer

      Classes in org.omg.PortableServer that implement ServantLocator
      Modifier and Type Class and Description
      class  _ServantLocatorStub
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
      Methods in org.omg.PortableServer that return ServantLocator
      Modifier and Type | Method and Description
      ServantLocator | ServantLocatorPOA._this()
      ServantLocator | ServantLocatorPOA._this(ORB orb)
      static ServantLocator | ServantLocatorHelper.extract(Any a)
      static ServantLocator | ServantLocatorHelper.narrow(Object obj)
      static ServantLocator | ServantLocatorHelper.read(InputStream istream)
      static ServantLocator | ServantLocatorHelper.unchecked_narrow(Object obj)
      Methods in org.omg.PortableServer with parameters of type ServantLocator
      Modifier and Type | Method and Description
      static void | ServantLocatorHelper.insert(Any a, ServantLocator that)
      static void | ServantLocatorHelper.write(OutputStream ostream, ServantLocator value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.ServantLocatorHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.ServantLocatorHelper

No usage of org.omg.PortableServer.ServantLocatorHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableServer.ServantLocatorOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.ServantLocatorOperations

  • Packages that use ServantLocatorOperations
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ServantLocatorOperations in org.omg.PortableServer

      Subinterfaces of ServantLocatorOperations in org.omg.PortableServer
      Modifier and Type Interface and Description
      interface  ServantLocator
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
      Classes in org.omg.PortableServer that implement ServantLocatorOperations
      Modifier and Type Class and Description
      class  _ServantLocatorStub
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
      class  ServantLocatorPOA
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.ServantLocatorPOA (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.ServantLocatorPOA

No usage of org.omg.PortableServer.ServantLocatorPOA
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableServer.ServantManager (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.ServantManager

  • Packages that use ServantManager
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ServantManager in org.omg.PortableServer

      Subinterfaces of ServantManager in org.omg.PortableServer
      Modifier and Type Interface and Description
      interface  ServantActivator
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      interface  ServantLocator
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
      Classes in org.omg.PortableServer that implement ServantManager
      Modifier and Type Class and Description
      class  _ServantActivatorStub
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      class  _ServantLocatorStub
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
      Methods in org.omg.PortableServer that return ServantManager
      Modifier and Type Method and Description
      ServantManager POAOperations.get_servant_manager()
      If the ServantRetentionPolicy of the POA is RETAIN, then the ServantManager argument (imgr) shall support the ServantActivator interface.
      Methods in org.omg.PortableServer with parameters of type ServantManager
      Modifier and Type Method and Description
      void POAOperations.set_servant_manager(ServantManager imgr)
      This operation sets the default servant manager associated with the POA.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableServer.ServantManagerOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.ServantManagerOperations

  • Packages that use ServantManagerOperations
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ServantManagerOperations in org.omg.PortableServer

      Subinterfaces of ServantManagerOperations in org.omg.PortableServer
      Modifier and Type Interface and Description
      interface  ServantActivator
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      interface  ServantActivatorOperations
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      interface  ServantLocator
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
      interface  ServantLocatorOperations
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
      interface  ServantManager
      A servant manager supplies a POA with the ability to activate objects on demand when the POA receives a request targeted at an inactive object.
      Classes in org.omg.PortableServer that implement ServantManagerOperations
      Modifier and Type Class and Description
      class  _ServantActivatorStub
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      class  _ServantLocatorStub
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
      class  ServantActivatorPOA
      When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
      class  ServantLocatorPOA
      When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableServer.ServantRetentionPolicy (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.ServantRetentionPolicy

  • Packages that use ServantRetentionPolicy
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ServantRetentionPolicy in org.omg.PortableServer

      Methods in org.omg.PortableServer that return ServantRetentionPolicy
      Modifier and Type Method and Description
      ServantRetentionPolicy POAOperations.create_servant_retention_policy(ServantRetentionPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableServer.ServantRetentionPolicyOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.ServantRetentionPolicyOperations

  • Packages that use ServantRetentionPolicyOperations
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ServantRetentionPolicyOperations in org.omg.PortableServer

      Subinterfaces of ServantRetentionPolicyOperations in org.omg.PortableServer
      Modifier and Type Interface and Description
      interface  ServantRetentionPolicy
      This policy specifies whether the created POA retains active servants in an Active Object Map.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.ServantRetentionPolicyValue (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.ServantRetentionPolicyValue

  • Packages that use ServantRetentionPolicyValue
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ServantRetentionPolicyValue in org.omg.PortableServer

      Fields in org.omg.PortableServer declared as ServantRetentionPolicyValue
      Modifier and Type | Field and Description
      static ServantRetentionPolicyValue | ServantRetentionPolicyValue.NON_RETAIN
      static ServantRetentionPolicyValue | ServantRetentionPolicyValue.RETAIN
      Methods in org.omg.PortableServer that return ServantRetentionPolicyValue
      Modifier and Type | Method and Description
      static ServantRetentionPolicyValue | ServantRetentionPolicyValue.from_int(int value)
      ServantRetentionPolicyValue ServantRetentionPolicyOperations.value()
      specifies the policy value
      Methods in org.omg.PortableServer with parameters of type ServantRetentionPolicyValue
      Modifier and Type Method and Description
      ServantRetentionPolicy POAOperations.create_servant_retention_policy(ServantRetentionPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableServer.SERVANT_RETENTION_POLICY_ID (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.SERVANT_RETENTION_POLICY_ID

No usage of org.omg.PortableServer.SERVANT_RETENTION_POLICY_ID
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableServer.ThreadPolicy (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.ThreadPolicy

  • Packages that use ThreadPolicy
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ThreadPolicy in org.omg.PortableServer

      Methods in org.omg.PortableServer that return ThreadPolicy
      Modifier and Type Method and Description
      ThreadPolicy POAOperations.create_thread_policy(ThreadPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableServer.ThreadPolicyOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.ThreadPolicyOperations

  • Packages that use ThreadPolicyOperations
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ThreadPolicyOperations in org.omg.PortableServer

      Subinterfaces of ThreadPolicyOperations in org.omg.PortableServer
      Modifier and Type Interface and Description
      interface  ThreadPolicy
      The ThreadPolicy specifies the threading model used with the created POA.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.ThreadPolicyValue (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.ThreadPolicyValue

  • Packages that use ThreadPolicyValue
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of ThreadPolicyValue in org.omg.PortableServer

      Fields in org.omg.PortableServer declared as ThreadPolicyValue
      Modifier and Type | Field and Description
      static ThreadPolicyValue | ThreadPolicyValue.ORB_CTRL_MODEL
      static ThreadPolicyValue | ThreadPolicyValue.SINGLE_THREAD_MODEL
      Methods in org.omg.PortableServer that return ThreadPolicyValue
      Modifier and Type | Method and Description
      static ThreadPolicyValue | ThreadPolicyValue.from_int(int value)
      ThreadPolicyValue ThreadPolicyOperations.value()
      specifies the policy value
      Methods in org.omg.PortableServer with parameters of type ThreadPolicyValue
      Modifier and Type Method and Description
      ThreadPolicy POAOperations.create_thread_policy(ThreadPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.PortableServer.THREAD_POLICY_ID (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.THREAD_POLICY_ID

No usage of org.omg.PortableServer.THREAD_POLICY_ID
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer._ServantActivatorStub (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer._ServantActivatorStub

No usage of org.omg.PortableServer._ServantActivatorStub
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer._ServantLocatorStub (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer._ServantLocatorStub

No usage of org.omg.PortableServer._ServantLocatorStub
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Current (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface Current

  • All Superinterfaces:
    Current, CurrentOperations, IDLEntity, Object, Serializable

    public interface Current
extends CurrentOperations, Current, IDLEntity
    The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked. The Current interface is provided to support servants that implement multiple objects, but can be used within the context of POA-dispatched method invocations on any servant. To provide location transparency, ORBs are required to support use of Current in the context of both locally and remotely invoked operations. An instance of Current can be obtained by the application by issuing the CORBA::ORB::resolve_initial_references("POACurrent") operation. Thereafter, it can be used within the context of a method dispatched by the POA to obtain the POA and ObjectId that identify the object on which that operation was invoked.

    • Method Summary

      • Methods inherited from interface org.omg.PortableServer.CurrentOperations

        get_object_id, get_POA

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CurrentHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Class CurrentHelper

  • java.lang.Object
    • org.omg.PortableServer.CurrentHelper

  • public abstract class CurrentHelper
extends Object
    The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked. The Current interface is provided to support servants that implement multiple objects, but can be used within the context of POA-dispatched method invocations on any servant. To provide location transparency, ORBs are required to support use of Current in the context of both locally and remotely invoked operations. An instance of Current can be obtained by the application by issuing the CORBA::ORB::resolve_initial_references("POACurrent") operation. Thereafter, it can be used within the context of a method dispatched by the POA to obtain the POA and ObjectId that identify the object on which that operation was invoked.

    • Constructor Summary

      Constructors
      Constructor and Description
      CurrentHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static Current | extract(Any a)
      static String | id()
      static void | insert(Any a, Current that)
      static Current | narrow(Object obj)
      static Current | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, Current value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • CurrentHelper

        public CurrentHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          Current that)

      • extract

        public static Current extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static Current read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         Current value)

      • narrow

        public static Current narrow(Object obj)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CurrentOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface CurrentOperations

  • All Superinterfaces:
    CurrentOperations
    All Known Subinterfaces:
    Current

    public interface CurrentOperations
extends CurrentOperations
    The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked. The Current interface is provided to support servants that implement multiple objects, but can be used within the context of POA-dispatched method invocations on any servant. To provide location transparency, ORBs are required to support use of Current in the context of both locally and remotely invoked operations. An instance of Current can be obtained by the application by issuing the CORBA::ORB::resolve_initial_references("POACurrent") operation. Thereafter, it can be used within the context of a method dispatched by the POA to obtain the POA and ObjectId that identify the object on which that operation was invoked.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      byte[] get_object_id()
      Returns the ObjectId identifying the object in whose context it is called.
      POA get_POA()
      Returns reference to the POA implementing the object in whose context it is called.

    • Method Detail

      • get_POA

        POA get_POA()
     throws NoContext
        Returns reference to the POA implementing the object in whose context it is called.
        Returns:
        The poa implementing the object
        Throws:
        NoContext - is raised when the operation is outside the context of a POA-dispatched operation

      • get_object_id

        byte[] get_object_id()
              throws NoContext
        Returns the ObjectId identifying the object in whose context it is called.
        Returns:
        the ObjectId of the object
        Throws:
        NoContext - is raised when the operation is called outside the context of a POA-dispatched operation.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Class org.omg.PortableServer.CurrentPackage.NoContext (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.CurrentPackage.NoContext

  • Packages that use NoContext
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.CurrentPackage
    Provides method implementations with access to the identity of the object on which the method was invoked.

    • Uses of NoContext in org.omg.PortableServer

      Methods in org.omg.PortableServer that throw NoContext
      Modifier and Type Method and Description
      byte[] CurrentOperations.get_object_id()
      Returns the ObjectId identifying the object in whose context it is called.
      POA CurrentOperations.get_POA()
      Returns reference to the POA implementing the object in whose context it is called.

    • Uses of NoContext in org.omg.PortableServer.CurrentPackage

      Methods in org.omg.PortableServer.CurrentPackage that return NoContext
      Modifier and Type | Method and Description
      static NoContext | NoContextHelper.extract(Any a)
      static NoContext | NoContextHelper.read(InputStream istream)
      Methods in org.omg.PortableServer.CurrentPackage with parameters of type NoContext
      Modifier and Type | Method and Description
      static void | NoContextHelper.insert(Any a, NoContext that)
      static void | NoContextHelper.write(OutputStream ostream, NoContext value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.CurrentPackage.NoContextHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.CurrentPackage.NoContextHelper

No usage of org.omg.PortableServer.CurrentPackage.NoContextHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


NoContext (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.CurrentPackage

Class NoContext

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.CurrentPackage.NoContext
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class NoContext
extends UserException
    org/omg/PortableServer/CurrentPackage/NoContext.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableServer/poa.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      NoContext()
      NoContext(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • NoContext

        public NoContext()

      • NoContext

        public NoContext(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NoContextHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.CurrentPackage

Class NoContextHelper

  • java.lang.Object
    • org.omg.PortableServer.CurrentPackage.NoContextHelper

  • public abstract class NoContextHelper
extends Object
    org/omg/PortableServer/CurrentPackage/NoContextHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableServer/poa.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      NoContextHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static NoContext | extract(Any a)
      static String | id()
      static void | insert(Any a, NoContext that)
      static NoContext | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, NoContext value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • NoContextHelper

        public NoContextHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          NoContext that)

      • extract

        public static NoContext extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static NoContext read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         NoContext value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


org.omg.PortableServer.CurrentPackage (Java Platform SE 8 )

org.omg.PortableServer.CurrentPackage

Classes

  • NoContextHelper

Exceptions

  • NoContext


org.omg.PortableServer.CurrentPackage (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.PortableServer.CurrentPackage

Provides method implementations with access to the identity of the object on which the method was invoked.

See: Description

  • Class Summary
    Class Description
    NoContextHelper
    org/omg/PortableServer/CurrentPackage/NoContextHelper.java .
  • Exception Summary
    Exception Description
    NoContext
    org/omg/PortableServer/CurrentPackage/NoContext.java .

Package org.omg.PortableServer.CurrentPackage Description

Provides method implementations with access to the identity of the object on which the method was invoked. The Current package supports servants that implement multiple objects, but can be used within the context of POA-dispatched method invocations on any servant. To provide location transparency, ORBs are required to support use of Current in the context of both locally and remotely invoked operations. An instance of Current can be obtained by the application by issuing the CORBA::ORB::resolve_initial_references("POACurrent") operation. Thereafter, it can be used within the context of a method dispatched by the POA to obtain the POA and ObjectId that identify the object on which that operation was invoked.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

Since:
1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames


org.omg.PortableServer.CurrentPackage Class Hierarchy (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.PortableServer.CurrentPackage

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.PortableServer.CurrentPackage.NoContextHelper
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.PortableServer.CurrentPackage.NoContext
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package org.omg.PortableServer.CurrentPackage (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.PortableServer.CurrentPackage

  • Packages that use org.omg.PortableServer.CurrentPackage
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.CurrentPackage
    Provides method implementations with access to the identity of the object on which the method was invoked.
  • Classes in org.omg.PortableServer.CurrentPackage used by org.omg.PortableServer
    Class and Description
    NoContext
    org/omg/PortableServer/CurrentPackage/NoContext.java .
  • Classes in org.omg.PortableServer.CurrentPackage used by org.omg.PortableServer.CurrentPackage
    Class and Description
    NoContext
    org/omg/PortableServer/CurrentPackage/NoContext.java .
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


DynamicImplementation (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Class DynamicImplementation

  • java.lang.Object
    • org.omg.PortableServer.Servant
      • org.omg.PortableServer.DynamicImplementation

  • public abstract class DynamicImplementation
extends Servant
    Allows dynamic handling of object invocations. POA-based DSI servants inherit from the standard DynamicImplementation class, this class inherits from the Servant class. Based on IDL to Java spec. CORBA V 2.3.1 ptc/00-01-08.pdf.

    • Constructor Summary

      Constructors
      Constructor and Description
      DynamicImplementation()

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      abstract void invoke(ServerRequest request)
      Receives requests issued to any CORBA object incarnated by the DSI servant and performs the processing necessary to execute the request.

      • Methods inherited from class org.omg.PortableServer.Servant

        _all_interfaces, _default_POA, _get_delegate, _get_interface_def, _is_a, _non_existent, _object_id, _orb, _poa, _set_delegate, _this_object, _this_object

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • DynamicImplementation

        public DynamicImplementation()

    • Method Detail

      • invoke

        public abstract void invoke(ServerRequest request)
        Receives requests issued to any CORBA object incarnated by the DSI servant and performs the processing necessary to execute the request.
        Parameters:
        request - the request issued to the CORBA object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ForwardRequest (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Class ForwardRequest

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.ForwardRequest
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class ForwardRequest
extends UserException
    org/omg/PortableServer/ForwardRequest.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableServer/poa.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      Object forward_reference

    • Constructor Summary

      Constructors
      Constructor and Description
      ForwardRequest()
      ForwardRequest(Object _forward_reference)
      ForwardRequest(String $reason, Object _forward_reference)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • forward_reference

        public Object forward_reference

    • Constructor Detail

      • ForwardRequest

        public ForwardRequest()

      • ForwardRequest

        public ForwardRequest(Object _forward_reference)

      • ForwardRequest

        public ForwardRequest(String $reason,
                      Object _forward_reference)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ForwardRequestHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Class ForwardRequestHelper

  • java.lang.Object
    • org.omg.PortableServer.ForwardRequestHelper

  • public abstract class ForwardRequestHelper
extends Object
    org/omg/PortableServer/ForwardRequestHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableServer/poa.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      ForwardRequestHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static ForwardRequest | extract(Any a)
      static String | id()
      static void | insert(Any a, ForwardRequest that)
      static ForwardRequest | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, ForwardRequest value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ForwardRequestHelper

        public ForwardRequestHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          ForwardRequest that)

      • extract

        public static ForwardRequest extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ForwardRequest read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         ForwardRequest value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


IdAssignmentPolicy (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface IdAssignmentPolicy

  • All Superinterfaces:
    IdAssignmentPolicyOperations, IDLEntity, Object, Policy, PolicyOperations, Serializable

    public interface IdAssignmentPolicy
extends IdAssignmentPolicyOperations, Policy, IDLEntity
    IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB. The default is SYSTEM_ID.

    • Method Summary

      • Methods inherited from interface org.omg.PortableServer.IdAssignmentPolicyOperations

        value

      • Methods inherited from interface org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


IdAssignmentPolicyOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface IdAssignmentPolicyOperations

  • All Superinterfaces:
    PolicyOperations
    All Known Subinterfaces:
    IdAssignmentPolicy

    public interface IdAssignmentPolicyOperations
extends PolicyOperations
    IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB. The default is SYSTEM_ID.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      IdAssignmentPolicyValue value()
      specifies the policy value

      • Methods inherited from interface org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

    • Method Detail

      • value

        IdAssignmentPolicyValue value()
        specifies the policy value
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


IdAssignmentPolicyValue (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Class IdAssignmentPolicyValue

  • java.lang.Object
    • org.omg.PortableServer.IdAssignmentPolicyValue
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public class IdAssignmentPolicyValue
extends Object
implements IDLEntity
    The IdAssignmentPolicyValue can have the following values. USER_ID - Objects created with that POA are assigned Object Ids only by the application. SYSTEM_ID - Objects created with that POA are assigned Object Ids only by the POA. If the POA also has the PERSISTENT policy, assigned Object Ids must be unique across all instantiations of the same POA.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static int | _SYSTEM_ID
      static int | _USER_ID
      static IdAssignmentPolicyValue | SYSTEM_ID
      static IdAssignmentPolicyValue | USER_ID

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | IdAssignmentPolicyValue(int value)

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      static IdAssignmentPolicyValue | from_int(int value)
      int | value()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • _USER_ID

        public static final int _USER_ID
        See Also:
        Constant Field Values

      • USER_ID

        public static final IdAssignmentPolicyValue USER_ID

      • _SYSTEM_ID

        public static final int _SYSTEM_ID
        See Also:
        Constant Field Values

      • SYSTEM_ID

        public static final IdAssignmentPolicyValue SYSTEM_ID

    • Constructor Detail

      • IdAssignmentPolicyValue

        protected IdAssignmentPolicyValue(int value)

    • Method Detail

      • value

        public int value()

      • from_int

        public static IdAssignmentPolicyValue from_int(int value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


IdUniquenessPolicy (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface IdUniquenessPolicy

  • All Superinterfaces:
    IDLEntity, IdUniquenessPolicyOperations, Object, Policy, PolicyOperations, Serializable

    public interface IdUniquenessPolicy
extends IdUniquenessPolicyOperations, Policy, IDLEntity
    The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities. The default is UNIQUE_ID.

    • Method Summary

      • Methods inherited from interface org.omg.PortableServer.IdUniquenessPolicyOperations

        value

      • Methods inherited from interface org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


IdUniquenessPolicyOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface IdUniquenessPolicyOperations

  • All Superinterfaces:
    PolicyOperations
    All Known Subinterfaces:
    IdUniquenessPolicy

    public interface IdUniquenessPolicyOperations
extends PolicyOperations
    The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities. The default is UNIQUE_ID.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      IdUniquenessPolicyValue value()
      specifies the policy value

      • Methods inherited from interface org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

    • Method Detail

      • value

        IdUniquenessPolicyValue value()
        specifies the policy value
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


IdUniquenessPolicyValue (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Class IdUniquenessPolicyValue

  • java.lang.Object
    • org.omg.PortableServer.IdUniquenessPolicyValue
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public class IdUniquenessPolicyValue
extends Object
implements IDLEntity
    IdUniquenessPolicyValue can have the following values. UNIQUE_ID - Servants activated with that POA support exactly one Object Id. MULTIPLE_ID - a servant activated with that POA may support one or more Object Ids.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static int | _MULTIPLE_ID
      static int | _UNIQUE_ID
      static IdUniquenessPolicyValue | MULTIPLE_ID
      static IdUniquenessPolicyValue | UNIQUE_ID

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | IdUniquenessPolicyValue(int value)

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      static IdUniquenessPolicyValue | from_int(int value)
      int | value()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • _UNIQUE_ID

        public static final int _UNIQUE_ID
        See Also:
        Constant Field Values

      • UNIQUE_ID

        public static final IdUniquenessPolicyValue UNIQUE_ID

      • _MULTIPLE_ID

        public static final int _MULTIPLE_ID
        See Also:
        Constant Field Values

      • MULTIPLE_ID

        public static final IdUniquenessPolicyValue MULTIPLE_ID

    • Constructor Detail

      • IdUniquenessPolicyValue

        protected IdUniquenessPolicyValue(int value)

    • Method Detail

      • value

        public int value()

      • from_int

        public static IdUniquenessPolicyValue from_int(int value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ID_ASSIGNMENT_POLICY_ID (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface ID_ASSIGNMENT_POLICY_ID

  • public interface ID_ASSIGNMENT_POLICY_ID
    org/omg/PortableServer/ID_ASSIGNMENT_POLICY_ID.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableServer/poa.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      The value representing ID_ASSIGNMENT_POLICY_ID.

    • Field Detail

      • value

        static final int value
        The value representing ID_ASSIGNMENT_POLICY_ID.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ID_UNIQUENESS_POLICY_ID (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface ID_UNIQUENESS_POLICY_ID

  • public interface ID_UNIQUENESS_POLICY_ID
    org/omg/PortableServer/ID_UNIQUENESS_POLICY_ID.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableServer/poa.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      The value representing ID_UNIQUENESS_POLICY_ID.

    • Field Detail

      • value

        static final int value
        The value representing ID_UNIQUENESS_POLICY_ID.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ImplicitActivationPolicy (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface ImplicitActivationPolicy

  • All Superinterfaces:
    IDLEntity, ImplicitActivationPolicyOperations, Object, Policy, PolicyOperations, Serializable

    public interface ImplicitActivationPolicy
extends ImplicitActivationPolicyOperations, Policy, IDLEntity
    This policy specifies whether implicit activation of servants is supported in the created POA.

    • Method Summary

      • Methods inherited from interface org.omg.PortableServer.ImplicitActivationPolicyOperations

        value

      • Methods inherited from interface org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ImplicitActivationPolicyOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface ImplicitActivationPolicyOperations

  • All Superinterfaces:
    PolicyOperations
    All Known Subinterfaces:
    ImplicitActivationPolicy

    public interface ImplicitActivationPolicyOperations
extends PolicyOperations
    This policy specifies whether implicit activation of servants is supported in the created POA.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      ImplicitActivationPolicyValue value()
      specifies the policy value

      • Methods inherited from interface org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

    • Method Detail

      • value

        ImplicitActivationPolicyValue value()
        specifies the policy value
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ImplicitActivationPolicyValue (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Class ImplicitActivationPolicyValue

  • java.lang.Object
    • org.omg.PortableServer.ImplicitActivationPolicyValue
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public class ImplicitActivationPolicyValue
extends Object
implements IDLEntity
    ImplicitActivationPolicyValue has the following semantics. IMPLICIT_ACTIVATION to indicate implicit activation of servants. This requires SYSTEM_ID and RETAIN policies to be set. NO_IMPLICIT_ACTIVATION to indicate no implicit servant activation.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static int | _IMPLICIT_ACTIVATION
      static int | _NO_IMPLICIT_ACTIVATION
      static ImplicitActivationPolicyValue | IMPLICIT_ACTIVATION
      static ImplicitActivationPolicyValue | NO_IMPLICIT_ACTIVATION

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | ImplicitActivationPolicyValue(int value)

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      static ImplicitActivationPolicyValue | from_int(int value)
      int | value()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • _IMPLICIT_ACTIVATION

        public static final int _IMPLICIT_ACTIVATION
        See Also:
        Constant Field Values

      • IMPLICIT_ACTIVATION

        public static final ImplicitActivationPolicyValue IMPLICIT_ACTIVATION

      • _NO_IMPLICIT_ACTIVATION

        public static final int _NO_IMPLICIT_ACTIVATION
        See Also:
        Constant Field Values

      • NO_IMPLICIT_ACTIVATION

        public static final ImplicitActivationPolicyValue NO_IMPLICIT_ACTIVATION

    • Constructor Detail

      • ImplicitActivationPolicyValue

        protected ImplicitActivationPolicyValue(int value)

    • Method Detail

      • value

        public int value()

      • from_int

        public static ImplicitActivationPolicyValue from_int(int value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


IMPLICIT_ACTIVATION_POLICY_ID (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface IMPLICIT_ACTIVATION_POLICY_ID

  • public interface IMPLICIT_ACTIVATION_POLICY_ID
    org/omg/PortableServer/IMPLICIT_ACTIVATION_POLICY_ID.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableServer/poa.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      The value representing IMPLICIT_ACTIVATION_POLICY_ID.

    • Field Detail

      • value

        static final int value
        The value representing IMPLICIT_ACTIVATION_POLICY_ID.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


LifespanPolicy (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface LifespanPolicy

  • All Superinterfaces:
    IDLEntity, LifespanPolicyOperations, Object, Policy, PolicyOperations, Serializable

    public interface LifespanPolicy
extends LifespanPolicyOperations, Policy, IDLEntity
    The LifespanPolicy specifies the lifespan of the objects implemented in the created POA. The default is TRANSIENT.

    • Method Summary

      • Methods inherited from interface org.omg.PortableServer.LifespanPolicyOperations

        value

      • Methods inherited from interface org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


LifespanPolicyOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface LifespanPolicyOperations

  • All Superinterfaces:
    PolicyOperations
    All Known Subinterfaces:
    LifespanPolicy

    public interface LifespanPolicyOperations
extends PolicyOperations
    The LifespanPolicy specifies the lifespan of the objects implemented in the created POA. The default is TRANSIENT.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      LifespanPolicyValue value()
      specifies the policy value

      • Methods inherited from interface org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

    • Method Detail

      • value

        LifespanPolicyValue value()
        specifies the policy value
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


LifespanPolicyValue (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Class LifespanPolicyValue

  • java.lang.Object
    • org.omg.PortableServer.LifespanPolicyValue
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public class LifespanPolicyValue
extends Object
implements IDLEntity
    The LifespanPolicyValue can have the following values. TRANSIENT - The objects implemented in the POA cannot outlive the POA instance in which they are first created. PERSISTENT - The objects implemented in the POA can outlive the process in which they are first created.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static int | _PERSISTENT
      static int | _TRANSIENT
      static LifespanPolicyValue | PERSISTENT
      static LifespanPolicyValue | TRANSIENT

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | LifespanPolicyValue(int value)

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      static LifespanPolicyValue | from_int(int value)
      int | value()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • _TRANSIENT

        public static final int _TRANSIENT
        See Also:
        Constant Field Values

      • TRANSIENT

        public static final LifespanPolicyValue TRANSIENT

      • _PERSISTENT

        public static final int _PERSISTENT
        See Also:
        Constant Field Values

      • PERSISTENT

        public static final LifespanPolicyValue PERSISTENT

    • Constructor Detail

      • LifespanPolicyValue

        protected LifespanPolicyValue(int value)

    • Method Detail

      • value

        public int value()

      • from_int

        public static LifespanPolicyValue from_int(int value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


LIFESPAN_POLICY_ID (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface LIFESPAN_POLICY_ID

  • public interface LIFESPAN_POLICY_ID
    org/omg/PortableServer/LIFESPAN_POLICY_ID.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableServer/poa.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      The value representing LIFESPAN_POLICY_ID.

    • Field Detail

      • value

        static final int value
        The value representing LIFESPAN_POLICY_ID.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


org.omg.PortableServer (Java Platform SE 8 )

org.omg.PortableServer

Interfaces

  • AdapterActivator
  • AdapterActivatorOperations
  • Current
  • CurrentOperations
  • ID_ASSIGNMENT_POLICY_ID
  • ID_UNIQUENESS_POLICY_ID
  • IdAssignmentPolicy
  • IdAssignmentPolicyOperations
  • IdUniquenessPolicy
  • IdUniquenessPolicyOperations
  • IMPLICIT_ACTIVATION_POLICY_ID
  • ImplicitActivationPolicy
  • ImplicitActivationPolicyOperations
  • LIFESPAN_POLICY_ID
  • LifespanPolicy
  • LifespanPolicyOperations
  • POA
  • POAManager
  • POAManagerOperations
  • POAOperations
  • REQUEST_PROCESSING_POLICY_ID
  • RequestProcessingPolicy
  • RequestProcessingPolicyOperations
  • SERVANT_RETENTION_POLICY_ID
  • ServantActivator
  • ServantActivatorOperations
  • ServantLocator
  • ServantLocatorOperations
  • ServantManager
  • ServantManagerOperations
  • ServantRetentionPolicy
  • ServantRetentionPolicyOperations
  • THREAD_POLICY_ID
  • ThreadPolicy
  • ThreadPolicyOperations

Classes

  • _ServantActivatorStub
  • _ServantLocatorStub
  • CurrentHelper
  • DynamicImplementation
  • ForwardRequestHelper
  • IdAssignmentPolicyValue
  • IdUniquenessPolicyValue
  • ImplicitActivationPolicyValue
  • LifespanPolicyValue
  • POAHelper
  • RequestProcessingPolicyValue
  • Servant
  • ServantActivatorHelper
  • ServantActivatorPOA
  • ServantLocatorHelper
  • ServantLocatorPOA
  • ServantRetentionPolicyValue
  • ThreadPolicyValue

Exceptions

  • ForwardRequest


org.omg.PortableServer (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.PortableServer

Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

See: Description

  • Interface Summary
    Interface Description
    AdapterActivator
    An adapter activator supplies a POA with the ability to create child POAs on demand, as a side-effect of receiving a request that names the child POA (or one of its children), or when find_POA is called with an activate parameter value of TRUE.
    AdapterActivatorOperations
    An adapter activator supplies a POA with the ability to create child POAs on demand, as a side-effect of receiving a request that names the child POA (or one of its children), or when find_POA is called with an activate parameter value of TRUE.
    Current
    The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked.
    CurrentOperations
    The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked.
    ID_ASSIGNMENT_POLICY_ID
    org/omg/PortableServer/ID_ASSIGNMENT_POLICY_ID.java .
    ID_UNIQUENESS_POLICY_ID
    org/omg/PortableServer/ID_UNIQUENESS_POLICY_ID.java .
    IdAssignmentPolicy
    IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB.
    IdAssignmentPolicyOperations
    IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB.
    IdUniquenessPolicy
    The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities.
    IdUniquenessPolicyOperations
    The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities.
    IMPLICIT_ACTIVATION_POLICY_ID
    org/omg/PortableServer/IMPLICIT_ACTIVATION_POLICY_ID.java .
    ImplicitActivationPolicy
    This policy specifies whether implicit activation of servants is supported in the created POA.
    ImplicitActivationPolicyOperations
    This policy specifies whether implicit activation of servants is supported in the created POA.
    LIFESPAN_POLICY_ID
    org/omg/PortableServer/LIFESPAN_POLICY_ID.java .
    LifespanPolicy
    The LifespanPolicy specifies the lifespan of the objects implemented in the created POA.
    LifespanPolicyOperations
    The LifespanPolicy specifies the lifespan of the objects implemented in the created POA.
    POA
    A POA object manages the implementation of a collection of objects.
    POAManager
    Each POA object has an associated POAManager object.
    POAManagerOperations
    Each POA object has an associated POAManager object.
    POAOperations
    A POA object manages the implementation of a collection of objects.
    REQUEST_PROCESSING_POLICY_ID
    org/omg/PortableServer/REQUEST_PROCESSING_POLICY_ID.java .
    RequestProcessingPolicy
    This policy specifies how requests are processed by the created POA.
    RequestProcessingPolicyOperations
    This policy specifies how requests are processed by the created POA.
    SERVANT_RETENTION_POLICY_ID
    org/omg/PortableServer/SERVANT_RETENTION_POLICY_ID.java .
    ServantActivator
    When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
    ServantActivatorOperations
    When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
    ServantLocator
    When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
    ServantLocatorOperations
    When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
    ServantManager
    A servant manager supplies a POA with the ability to activate objects on demand when the POA receives a request targeted at an inactive object.
    ServantManagerOperations
    A servant manager supplies a POA with the ability to activate objects on demand when the POA receives a request targeted at an inactive object.
    ServantRetentionPolicy
    This policy specifies whether the created POA retains active servants in an Active Object Map.
    ServantRetentionPolicyOperations
    This policy specifies whether the created POA retains active servants in an Active Object Map.
    THREAD_POLICY_ID
    org/omg/PortableServer/THREAD_POLICY_ID.java .
    ThreadPolicy
    The ThreadPolicy specifies the threading model used with the created POA.
    ThreadPolicyOperations
    The ThreadPolicy specifies the threading model used with the created POA.
  • Class Summary
    Class Description
    _ServantActivatorStub
    When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
    _ServantLocatorStub
    When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
    CurrentHelper
    The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked.
    DynamicImplementation
    Allows dynamic handling of object invocations.
    ForwardRequestHelper
    org/omg/PortableServer/ForwardRequestHelper.java .
    IdAssignmentPolicyValue
    The IdAssignmentPolicyValue can have the following values.
    IdUniquenessPolicyValue
    IdUniquenessPolicyValue can have the following values.
    ImplicitActivationPolicyValue
    ImplicitActivationPolicyValue has the following semantics.
    LifespanPolicyValue
    The LifespanPolicyValue can have the following values.
    POAHelper
    A POA object manages the implementation of a collection of objects.
    RequestProcessingPolicyValue
    The RequestProcessingPolicyValue can have the following values.
    Servant
    Defines the native Servant type.
    ServantActivatorHelper
    When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
    ServantActivatorPOA
    When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
    ServantLocatorHelper
    When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
    ServantLocatorPOA
    When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
    ServantRetentionPolicyValue
    ServantRetentionPolicyValue can have the following values.
    ThreadPolicyValue
    The ThreadPolicyValue can have the following values.
  • Exception Summary
    Exception Description
    ForwardRequest
    org/omg/PortableServer/ForwardRequest.java .

Package org.omg.PortableServer Description

Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

In Java, Portable Object Adaptor (POA)-based Dynamic Skeleton Interface (DSI) servants inherit from the standard DynamicImplementation class, which inherits from the Servant class. The native Servant type is defined by the PortableServer module for the POA. In Java, the Servant type is mapped to the Java org.omg.PortableServer.Servant class. It serves as the base class for all POA servant implementations and provides a number of methods that may be invoked by the application programmer, as well as methods which are invoked by the POA itself and may be overridden by the user to control aspects of servant behavior.

Package Specification

For a precise list of supported sections of official OMG specifications with which the Java[tm] Platform, Standard Edition 6 complies, see Official Specifications for CORBA support in Java[tm] SE 6.

POA-related Interfaces

The PortableServer module defines the following POA-related interfaces:

  • POA
  • POAManager
  • ServantManager
  • ServantActivator
  • ServantLocator
  • AdapterActivator
  • ThreadPolicy
  • LifespanPolicy
  • IdUniquenessPolicy
  • IdAssignmentPolicy
  • ImplicitActivationPolicy
  • ServantRetentionPolicy
  • RequestProcessingPolicy
  • Current

In addition, the POA defines the Servant native type.

Operations classes

Each of the interfaces listed above has an associated Operations interface. The Operations interface is generated by the idlj compiler and contains the method signatures for methods defined in its associated interface. The Operations interface can be accessed by both the client and the server, while its associated interface can only be called by the client.

Value Classes

Classes ending in the suffix PolicyValue provide the values used for the create_POA call, which sets the policy for the POA. See the sample code below for a demonstration. PolicyValue files include the following:

  • IdAssignmentPolicyValue
  • IdUniquenessPolicyValue
  • ImplicitActivationPolicyValue
  • LifespanPolicyValue
  • RequestProcessingPolicyValue
  • ServantRetentionPolicyValue
  • ThreadPolicyValue

Helper Classes

Helper classes, which are generated for all user-defined types in an OMG IDL interface, supply static methods needed to manipulate those types. There is only one method in a helper class that an application programmer uses: the narrow method. Only Java interfaces mapped from IDL interfaces will have a helper class that includes a narrow method, so in the PortableServer package, only the following classes have a narrow method:

  • ForwardRequestHelper
  • ServantActivatorHelper
  • ServantLocatorHelper

POA Classes

POA classes are used to implement the ServantActivator or ServantLocator.

Exceptions

The ForwardRequest exception indicates to the ORB that it is responsible for delivering the current request and subsequent ForwardRequest requests to the object denoted in the forward_reference member of the exception.

Interfaces Implemented by the Application Programmer

Most of what PortableServer does is transparent to the user. The result is that programmers will use only a few of the interfaces mentioned above. The remaining interfaces will be provided by the ORB implementation. The interfaces of interest to application programmers are the following:

  • AdapterActivator

    Adapter activators are associated with POAs. An adapter activator supplies a POA with the ability to create child POAs on demand, as a side-effect of receiving a request that names the child POA (or one of its children), or when find_POA is called with an activate parameter value of TRUE. An application server that creates all its needed POAs at the beginning of execution does not need to use or provide an adapter activator; it is necessary only for the case in which POAs need to be created during request processing.

  • ServantLocator

    When the POA has the NON_RETAIN policy, it uses servant managers that are ServantLocators.

  • ServantActivator

    When the POA has the RETAIN policy, it uses servant managers that are ServantActivators.

Package org.omg.PortableServer.ServantLocatorPackage

This package supplies a CookieHolder class for passing the Cookie type as an out parameter. The CookieHolder class follows exactly the same pattern as the other holder classes for basic types.

Related Documentation

For an overview of Java IDL, please see:

  • Java IDL home page.

    Example Code

    Example Server Code

    import javax.naming.InitialContext;
import javax.naming.Context;
import javax.rmi.PortableRemoteObject ;
import com.sun.corba.se.impl.poa.POAORB;
import org.omg.PortableServer.*;
import java.util.*;
import org.omg.CORBA.*;
import javax.rmi.CORBA.Stub;
import javax.rmi.CORBA.Util;

public class HelloServer {
    public HelloServer(String[] args) {
        try {
            Properties p = System.getProperties();
         //   p.put("org.omg.CORBA.ORBClass", "com.sun.corba.ee.internal.POA.POAORB");
            ORB orb = ORB.init( args, p );

            POA rootPOA = (POA)orb.resolve_initial_references("RootPOA");

            Policy[] tpolicy = new Policy[3];
            tpolicy[0] = rootPOA.create_lifespan_policy(
                LifespanPolicyValue.TRANSIENT );
            tpolicy[1] = rootPOA.create_request_processing_policy(
                RequestProcessingPolicyValue.USE_ACTIVE_OBJECT_MAP_ONLY );
            tpolicy[2] = rootPOA.create_servant_retention_policy(
                ServantRetentionPolicyValue.RETAIN);
            POA tpoa = rootPOA.create_POA("MyTransientPOA", null, tpolicy);

            String  ObjectId = "MyObjectId";
            byte[] oid = ObjectId.getBytes();

            org.omg.CORBA.Object obj = tpoa.create_reference_with_id(oid,
                new _HelloImpl_Tie()._all_interfaces(tpoa, oid)[0]);
            HelloInterface helloRef = (HelloInterface)PortableRemoteObject.narrow(
                obj, HelloInterface.class );

            Context initialNamingContext = new InitialContext();
            initialNamingContext.rebind("HelloService", helloRef);
            System.out.println("Hello Server: Ready...");
            orb.run();
         } catch (Exception e) {
            System.out.println("Trouble: " + e);
            e.printStackTrace();
         }
     }

     public static void main(String args[]) {
         new HelloServer( args );
     }
}

    • Since:
    1.4
    Skip navigation links
    • Overview
    • Package
    • Class
    • Use
    • Tree
    • Deprecated
    • Index
    • Help
    Java™ Platform
    Standard Ed. 8
    • Prev Package
    • Next Package
    • Frames
    • No Frames


org.omg.PortableServer Class Hierarchy (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.PortableServer

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.PortableServer.CurrentHelper
    • org.omg.PortableServer.ForwardRequestHelper
    • org.omg.PortableServer.IdAssignmentPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.IdUniquenessPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.ImplicitActivationPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.LifespanPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.portable.ObjectImpl (implements org.omg.CORBA.Object)
      • org.omg.PortableServer._ServantActivatorStub (implements org.omg.PortableServer.ServantActivator)
      • org.omg.PortableServer._ServantLocatorStub (implements org.omg.PortableServer.ServantLocator)
    • org.omg.PortableServer.POAHelper
    • org.omg.PortableServer.RequestProcessingPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.Servant
      • org.omg.PortableServer.DynamicImplementation
      • org.omg.PortableServer.ServantActivatorPOA (implements org.omg.CORBA.portable.InvokeHandler, org.omg.PortableServer.ServantActivatorOperations)
      • org.omg.PortableServer.ServantLocatorPOA (implements org.omg.CORBA.portable.InvokeHandler, org.omg.PortableServer.ServantLocatorOperations)
    • org.omg.PortableServer.ServantActivatorHelper
    • org.omg.PortableServer.ServantLocatorHelper
    • org.omg.PortableServer.ServantRetentionPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.ThreadPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.PortableServer.ForwardRequest

Interface Hierarchy

  • org.omg.PortableServer.AdapterActivatorOperations
    • org.omg.PortableServer.AdapterActivator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.CORBA.CurrentOperations
    • org.omg.CORBA.Current (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableServer.Current (also extends org.omg.PortableServer.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.CurrentOperations
      • org.omg.PortableServer.Current (also extends org.omg.CORBA.Current, org.omg.CORBA.portable.IDLEntity)
  • org.omg.PortableServer.ID_ASSIGNMENT_POLICY_ID
  • org.omg.PortableServer.ID_UNIQUENESS_POLICY_ID
  • org.omg.PortableServer.IMPLICIT_ACTIVATION_POLICY_ID
  • org.omg.PortableServer.LIFESPAN_POLICY_ID
  • org.omg.CORBA.Object
    • org.omg.PortableServer.AdapterActivator (also extends org.omg.PortableServer.AdapterActivatorOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.Current (also extends org.omg.CORBA.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableServer.Current (also extends org.omg.PortableServer.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.POA (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.POAOperations)
    • org.omg.PortableServer.POAManager (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.POAManagerOperations)
    • org.omg.CORBA.Policy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.PolicyOperations)
      • org.omg.PortableServer.IdAssignmentPolicy (also extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableServer.IdUniquenessPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.IdUniquenessPolicyOperations)
      • org.omg.PortableServer.ImplicitActivationPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ImplicitActivationPolicyOperations)
      • org.omg.PortableServer.LifespanPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.LifespanPolicyOperations)
      • org.omg.PortableServer.RequestProcessingPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.RequestProcessingPolicyOperations)
      • org.omg.PortableServer.ServantRetentionPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantRetentionPolicyOperations)
      • org.omg.PortableServer.ThreadPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ThreadPolicyOperations)
    • org.omg.PortableServer.ServantManager (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantManagerOperations)
      • org.omg.PortableServer.ServantActivator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantActivatorOperations)
      • org.omg.PortableServer.ServantLocator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantLocatorOperations)
  • org.omg.PortableServer.POAManagerOperations
    • org.omg.PortableServer.POAManager (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.PortableServer.POAOperations
    • org.omg.PortableServer.POA (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.CORBA.PolicyOperations
    • org.omg.PortableServer.IdAssignmentPolicyOperations
      • org.omg.PortableServer.IdAssignmentPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.PortableServer.IdUniquenessPolicyOperations
      • org.omg.PortableServer.IdUniquenessPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.PortableServer.ImplicitActivationPolicyOperations
      • org.omg.PortableServer.ImplicitActivationPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.PortableServer.LifespanPolicyOperations
      • org.omg.PortableServer.LifespanPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.CORBA.Policy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableServer.IdAssignmentPolicy (also extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableServer.IdUniquenessPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.IdUniquenessPolicyOperations)
      • org.omg.PortableServer.ImplicitActivationPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ImplicitActivationPolicyOperations)
      • org.omg.PortableServer.LifespanPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.LifespanPolicyOperations)
      • org.omg.PortableServer.RequestProcessingPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.RequestProcessingPolicyOperations)
      • org.omg.PortableServer.ServantRetentionPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantRetentionPolicyOperations)
      • org.omg.PortableServer.ThreadPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ThreadPolicyOperations)
    • org.omg.PortableServer.RequestProcessingPolicyOperations
      • org.omg.PortableServer.RequestProcessingPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.PortableServer.ServantRetentionPolicyOperations
      • org.omg.PortableServer.ServantRetentionPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.PortableServer.ThreadPolicyOperations
      • org.omg.PortableServer.ThreadPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
  • org.omg.PortableServer.REQUEST_PROCESSING_POLICY_ID
  • java.io.Serializable
    • org.omg.CORBA.portable.IDLEntity
      • org.omg.PortableServer.AdapterActivator (also extends org.omg.PortableServer.AdapterActivatorOperations, org.omg.CORBA.Object)
      • org.omg.CORBA.Current (also extends org.omg.CORBA.CurrentOperations, org.omg.CORBA.Object)
        • org.omg.PortableServer.Current (also extends org.omg.PortableServer.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableServer.Current (also extends org.omg.CORBA.Current, org.omg.PortableServer.CurrentOperations)
      • org.omg.PortableServer.IdAssignmentPolicy (also extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.Policy)
      • org.omg.PortableServer.IdUniquenessPolicy (also extends org.omg.PortableServer.IdUniquenessPolicyOperations, org.omg.CORBA.Policy)
      • org.omg.PortableServer.ImplicitActivationPolicy (also extends org.omg.PortableServer.ImplicitActivationPolicyOperations, org.omg.CORBA.Policy)
      • org.omg.PortableServer.LifespanPolicy (also extends org.omg.PortableServer.LifespanPolicyOperations, org.omg.CORBA.Policy)
      • org.omg.PortableServer.POA (also extends org.omg.CORBA.Object, org.omg.PortableServer.POAOperations)
      • org.omg.PortableServer.POAManager (also extends org.omg.CORBA.Object, org.omg.PortableServer.POAManagerOperations)
      • org.omg.CORBA.Policy (also extends org.omg.CORBA.Object, org.omg.CORBA.PolicyOperations)
        • org.omg.PortableServer.IdAssignmentPolicy (also extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.PortableServer.IdUniquenessPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.IdUniquenessPolicyOperations)
        • org.omg.PortableServer.ImplicitActivationPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ImplicitActivationPolicyOperations)
        • org.omg.PortableServer.LifespanPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.LifespanPolicyOperations)
        • org.omg.PortableServer.RequestProcessingPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.RequestProcessingPolicyOperations)
        • org.omg.PortableServer.ServantRetentionPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantRetentionPolicyOperations)
        • org.omg.PortableServer.ThreadPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ThreadPolicyOperations)
      • org.omg.PortableServer.RequestProcessingPolicy (also extends org.omg.CORBA.Policy, org.omg.PortableServer.RequestProcessingPolicyOperations)
      • org.omg.PortableServer.ServantActivator (also extends org.omg.PortableServer.ServantActivatorOperations, org.omg.PortableServer.ServantManager)
      • org.omg.PortableServer.ServantLocator (also extends org.omg.PortableServer.ServantLocatorOperations, org.omg.PortableServer.ServantManager)
      • org.omg.PortableServer.ServantManager (also extends org.omg.CORBA.Object, org.omg.PortableServer.ServantManagerOperations)
        • org.omg.PortableServer.ServantActivator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantActivatorOperations)
        • org.omg.PortableServer.ServantLocator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantLocatorOperations)
      • org.omg.PortableServer.ServantRetentionPolicy (also extends org.omg.CORBA.Policy, org.omg.PortableServer.ServantRetentionPolicyOperations)
      • org.omg.PortableServer.ThreadPolicy (also extends org.omg.CORBA.Policy, org.omg.PortableServer.ThreadPolicyOperations)
  • org.omg.PortableServer.SERVANT_RETENTION_POLICY_ID
  • org.omg.PortableServer.ServantManagerOperations
    • org.omg.PortableServer.ServantActivatorOperations
      • org.omg.PortableServer.ServantActivator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantManager)
    • org.omg.PortableServer.ServantLocatorOperations
      • org.omg.PortableServer.ServantLocator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantManager)
    • org.omg.PortableServer.ServantManager (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableServer.ServantActivator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantActivatorOperations)
      • org.omg.PortableServer.ServantLocator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantLocatorOperations)
  • org.omg.PortableServer.THREAD_POLICY_ID
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package org.omg.PortableServer (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.PortableServer

  • Packages that use org.omg.PortableServer
    Package Description
    org.omg.CosNaming
    Provides a naming service for Java IDL.
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.portable
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
  • Classes in org.omg.PortableServer used by org.omg.CosNaming
    Class and Description
    POA
    A POA object manages the implementation of a collection of objects.
    Servant
    Defines the native Servant type.
  • Classes in org.omg.PortableServer used by org.omg.PortableServer
    Class and Description
    AdapterActivator
    An adapter activator supplies a POA with the ability to create child POAs on demand, as a side-effect of receiving a request that names the child POA (or one of its children), or when find_POA is called with an activate parameter value of TRUE.
    AdapterActivatorOperations
    An adapter activator supplies a POA with the ability to create child POAs on demand, as a side-effect of receiving a request that names the child POA (or one of its children), or when find_POA is called with an activate parameter value of TRUE.
    Current
    The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked.
    CurrentOperations
    The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked.
    ForwardRequest
    org/omg/PortableServer/ForwardRequest.java .
    IdAssignmentPolicy
    IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB.
    IdAssignmentPolicyOperations
    IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB.
    IdAssignmentPolicyValue
    The IdAssignmentPolicyValue can have the following values.
    IdUniquenessPolicy
    The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities.
    IdUniquenessPolicyOperations
    The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities.
    IdUniquenessPolicyValue
    IdUniquenessPolicyValue can have the following values.
    ImplicitActivationPolicy
    This policy specifies whether implicit activation of servants is supported in the created POA.
    ImplicitActivationPolicyOperations
    This policy specifies whether implicit activation of servants is supported in the created POA.
    ImplicitActivationPolicyValue
    ImplicitActivationPolicyValue has the following semantics.
    LifespanPolicy
    The LifespanPolicy specifies the lifespan of the objects implemented in the created POA.
    LifespanPolicyOperations
    The LifespanPolicy specifies the lifespan of the objects implemented in the created POA.
    LifespanPolicyValue
    The LifespanPolicyValue can have the following values.
    POA
    A POA object manages the implementation of a collection of objects.
    POAManager
    Each POA object has an associated POAManager object.
    POAManagerOperations
    Each POA object has an associated POAManager object.
    POAOperations
    A POA object manages the implementation of a collection of objects.
    RequestProcessingPolicy
    This policy specifies how requests are processed by the created POA.
    RequestProcessingPolicyOperations
    This policy specifies how requests are processed by the created POA.
    RequestProcessingPolicyValue
    The RequestProcessingPolicyValue can have the following values.
    Servant
    Defines the native Servant type.
    ServantActivator
    When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
    ServantActivatorOperations
    When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
    ServantLocator
    When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
    ServantLocatorOperations
    When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
    ServantManager
    A servant manager supplies a POA with the ability to activate objects on demand when the POA receives a request targeted at an inactive object.
    ServantManagerOperations
    A servant manager supplies a POA with the ability to activate objects on demand when the POA receives a request targeted at an inactive object.
    ServantRetentionPolicy
    This policy specifies whether the created POA retains active servants in an Active Object Map.
    ServantRetentionPolicyOperations
    This policy specifies whether the created POA retains active servants in an Active Object Map.
    ServantRetentionPolicyValue
    ServantRetentionPolicyValue can have the following values.
    ThreadPolicy
    The ThreadPolicy specifies the threading model used with the created POA.
    ThreadPolicyOperations
    The ThreadPolicy specifies the threading model used with the created POA.
    ThreadPolicyValue
    The ThreadPolicyValue can have the following values.
  • Classes in org.omg.PortableServer used by org.omg.PortableServer.portable
    Class and Description
    POA
    A POA object manages the implementation of a collection of objects.
    Servant
    Defines the native Servant type.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


POA (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface POA

  • All Superinterfaces:
    IDLEntity, Object, POAOperations, Serializable

    public interface POA
extends POAOperations, Object, IDLEntity
    A POA object manages the implementation of a collection of objects. The POA supports a name space for the objects, which are identified by Object Ids. A POA also provides a name space for POAs. A POA is created as a child of an existing POA, which forms a hierarchy starting with the root POA. A POA object must not be exported to other processes, or externalized with ORB::object_to_string.

    • Method Summary

      • Methods inherited from interface org.omg.PortableServer.POAOperations

        activate_object_with_id, activate_object, create_id_assignment_policy, create_id_uniqueness_policy, create_implicit_activation_policy, create_lifespan_policy, create_POA, create_reference_with_id, create_reference, create_request_processing_policy, create_servant_retention_policy, create_thread_policy, deactivate_object, destroy, find_POA, get_servant_manager, get_servant, id_to_reference, id_to_servant, id, reference_to_id, reference_to_servant, servant_to_id, servant_to_reference, set_servant_manager, set_servant, the_activator, the_activator, the_children, the_name, the_parent, the_POAManager

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


POAHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Class POAHelper

  • java.lang.Object
    • org.omg.PortableServer.POAHelper

  • public abstract class POAHelper
extends Object
    A POA object manages the implementation of a collection of objects. The POA supports a name space for the objects, which are identified by Object Ids. A POA also provides a name space for POAs. A POA is created as a child of an existing POA, which forms a hierarchy starting with the root POA. A POA object must not be exported to other processes, or externalized with ORB::object_to_string.

    • Constructor Summary

      Constructors
      Constructor and Description
      POAHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static POA | extract(Any a)
      static String | id()
      static void | insert(Any a, POA that)
      static POA | narrow(Object obj)
      static POA | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, POA value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • POAHelper

        public POAHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          POA that)

      • extract

        public static POA extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static POA read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         POA value)

      • narrow

        public static POA narrow(Object obj)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


POAManager (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface POAManager

  • All Superinterfaces:
    IDLEntity, Object, POAManagerOperations, Serializable

    public interface POAManager
extends POAManagerOperations, Object, IDLEntity
    Each POA object has an associated POAManager object. A POA manager may be associated with one or more POA objects. A POA manager encapsulates the processing state of the POAs it is associated with.

    • Method Summary

      • Methods inherited from interface org.omg.PortableServer.POAManagerOperations

        activate, deactivate, discard_requests, get_state, hold_requests

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


POAManagerOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface POAManagerOperations

  • All Known Subinterfaces:
    POAManager

    public interface POAManagerOperations
    Each POA object has an associated POAManager object. A POA manager may be associated with one or more POA objects. A POA manager encapsulates the processing state of the POAs it is associated with.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void activate()
      This operation changes the state of the POA manager to active, causing associated POAs to start processing requests.
      void deactivate(boolean etherealize_objects, boolean wait_for_completion)
      This operation changes the state of the POA manager to inactive, causing associated POAs to reject the requests that have not begun executing as well as as any new requests.
      void discard_requests(boolean wait_for_completion)
      This operation changes the state of the POA manager to discarding.
      State get_state()
      This operation returns the state of the POA manager.
      void hold_requests(boolean wait_for_completion)
      This operation changes the state of the POA manager to holding, causing associated POAs to queue incoming requests.

    • Method Detail

      • activate

        void activate()
       throws AdapterInactive
        This operation changes the state of the POA manager to active, causing associated POAs to start processing requests.
        Throws:
        AdapterInactive - is raised if the operation is invoked on the POAManager in inactive state.

      • hold_requests

        void hold_requests(boolean wait_for_completion)
            throws AdapterInactive
        This operation changes the state of the POA manager to holding, causing associated POAs to queue incoming requests.
        Parameters:
        wait_for_completion - if FALSE, the operation returns immediately after changing state. If TRUE, it waits for all active requests to complete.
        Throws:
        AdapterInactive - is raised if the operation is invoked on the POAManager in inactive state.

      • discard_requests

        void discard_requests(boolean wait_for_completion)
               throws AdapterInactive
        This operation changes the state of the POA manager to discarding. This causes associated POAs to discard incoming requests.
        Parameters:
        wait_for_completion - if FALSE, the operation returns immediately after changing state. If TRUE, it waits for all active requests to complete.
        Throws:
        AdapterInactive - is raised if the operation is invoked on the POAManager in inactive state.

      • deactivate

        void deactivate(boolean etherealize_objects,
                boolean wait_for_completion)
         throws AdapterInactive
        This operation changes the state of the POA manager to inactive, causing associated POAs to reject the requests that have not begun executing as well as as any new requests.
        Parameters:
        etherealize_objects - a flag to indicate whether to invoke the etherealize operation of the associated servant manager for all active objects.
        wait_for_completion - if FALSE, the operation returns immediately after changing state. If TRUE, it waits for all active requests to complete.
        Throws:
        AdapterInactive - is raised if the operation is invoked on the POAManager in inactive state.

      • get_state

        State get_state()
        This operation returns the state of the POA manager.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AdapterInactive (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAManagerPackage

Class AdapterInactive

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.POAManagerPackage.AdapterInactive
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class AdapterInactive
extends UserException
    org/omg/PortableServer/POAManagerPackage/AdapterInactive.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableServer/poa.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      AdapterInactive()
      AdapterInactive(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • AdapterInactive

        public AdapterInactive()

      • AdapterInactive

        public AdapterInactive(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AdapterInactiveHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAManagerPackage

Class AdapterInactiveHelper

  • java.lang.Object
    • org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper

  • public abstract class AdapterInactiveHelper
extends Object
    org/omg/PortableServer/POAManagerPackage/AdapterInactiveHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableServer/poa.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      AdapterInactiveHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static AdapterInactive | extract(Any a)
      static String | id()
      static void | insert(Any a, AdapterInactive that)
      static AdapterInactive | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, AdapterInactive value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AdapterInactiveHelper

        public AdapterInactiveHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          AdapterInactive that)

      • extract

        public static AdapterInactive extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static AdapterInactive read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         AdapterInactive value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Class org.omg.PortableServer.POAManagerPackage.AdapterInactive (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAManagerPackage.AdapterInactive

  • Packages that use AdapterInactive
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAManagerPackage
    Encapsulates the processing state of the POAs it is associated with.

    • Uses of AdapterInactive in org.omg.PortableServer

      Methods in org.omg.PortableServer that throw AdapterInactive
      Modifier and Type Method and Description
      void POAManagerOperations.activate()
      This operation changes the state of the POA manager to active, causing associated POAs to start processing requests.
      void POAManagerOperations.deactivate(boolean etherealize_objects, boolean wait_for_completion)
      This operation changes the state of the POA manager to inactive, causing associated POAs to reject the requests that have not begun executing as well as as any new requests.
      void POAManagerOperations.discard_requests(boolean wait_for_completion)
      This operation changes the state of the POA manager to discarding.
      void POAManagerOperations.hold_requests(boolean wait_for_completion)
      This operation changes the state of the POA manager to holding, causing associated POAs to queue incoming requests.

    • Uses of AdapterInactive in org.omg.PortableServer.POAManagerPackage

      Methods in org.omg.PortableServer.POAManagerPackage that return AdapterInactive
      Modifier and Type | Method and Description
      static AdapterInactive | AdapterInactiveHelper.extract(Any a)
      static AdapterInactive | AdapterInactiveHelper.read(InputStream istream)
      Methods in org.omg.PortableServer.POAManagerPackage with parameters of type AdapterInactive
      Modifier and Type | Method and Description
      static void | AdapterInactiveHelper.insert(Any a, AdapterInactive that)
      static void | AdapterInactiveHelper.write(OutputStream ostream, AdapterInactive value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper

No usage of org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.POAManagerPackage.State (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAManagerPackage.State

  • Packages that use State
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAManagerPackage
    Encapsulates the processing state of the POAs it is associated with.

    • Uses of State in org.omg.PortableServer

      Methods in org.omg.PortableServer that return State
      Modifier and Type Method and Description
      State POAManagerOperations.get_state()
      This operation returns the state of the POA manager.

    • Uses of State in org.omg.PortableServer.POAManagerPackage

      Fields in org.omg.PortableServer.POAManagerPackage declared as State
      Modifier and Type | Field and Description
      static State | State.ACTIVE
      static State | State.DISCARDING
      static State | State.HOLDING
      static State | State.INACTIVE
      Methods in org.omg.PortableServer.POAManagerPackage that return State
      Modifier and Type | Method and Description
      static State | State.from_int(int value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


org.omg.PortableServer.POAManagerPackage (Java Platform SE 8 )

org.omg.PortableServer.POAManagerPackage

Classes

  • AdapterInactiveHelper
  • State

Exceptions

  • AdapterInactive


org.omg.PortableServer.POAManagerPackage (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.PortableServer.POAManagerPackage

Encapsulates the processing state of the POAs it is associated with.

See: Description

  • Class Summary
    Class Description
    AdapterInactiveHelper
    org/omg/PortableServer/POAManagerPackage/AdapterInactiveHelper.java .
    State
    Specifies the states for the POAManager
  • Exception Summary
    Exception Description
    AdapterInactive
    org/omg/PortableServer/POAManagerPackage/AdapterInactive.java .

Package org.omg.PortableServer.POAManagerPackage Description

Encapsulates the processing state of the POAs it is associated with. Each POA object has an associated POAManager object. A POA manager may be associated with one or more POA objects.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

Since:
1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames


org.omg.PortableServer.POAManagerPackage Class Hierarchy (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.PortableServer.POAManagerPackage

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper
    • org.omg.PortableServer.POAManagerPackage.State (implements org.omg.CORBA.portable.IDLEntity)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.PortableServer.POAManagerPackage.AdapterInactive
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package org.omg.PortableServer.POAManagerPackage (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.PortableServer.POAManagerPackage

  • Packages that use org.omg.PortableServer.POAManagerPackage
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAManagerPackage
    Encapsulates the processing state of the POAs it is associated with.
  • Classes in org.omg.PortableServer.POAManagerPackage used by org.omg.PortableServer
    Class and Description
    AdapterInactive
    org/omg/PortableServer/POAManagerPackage/AdapterInactive.java .
    State
    Specifies the states for the POAManager
  • Classes in org.omg.PortableServer.POAManagerPackage used by org.omg.PortableServer.POAManagerPackage
    Class and Description
    AdapterInactive
    org/omg/PortableServer/POAManagerPackage/AdapterInactive.java .
    State
    Specifies the states for the POAManager
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


State (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAManagerPackage

Class State

  • java.lang.Object
    • org.omg.PortableServer.POAManagerPackage.State
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public class State
extends Object
implements IDLEntity
    Specifies the states for the POAManager

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static int | _ACTIVE
      static int | _DISCARDING
      static int | _HOLDING
      static int | _INACTIVE
      static State | ACTIVE
      static State | DISCARDING
      static State | HOLDING
      static State | INACTIVE

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | State(int value)

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      static State | from_int(int value)
      int | value()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • _HOLDING

        public static final int _HOLDING
        See Also:
        Constant Field Values

      • HOLDING

        public static final State HOLDING

      • _ACTIVE

        public static final int _ACTIVE
        See Also:
        Constant Field Values

      • ACTIVE

        public static final State ACTIVE

      • _DISCARDING

        public static final int _DISCARDING
        See Also:
        Constant Field Values

      • DISCARDING

        public static final State DISCARDING

      • _INACTIVE

        public static final int _INACTIVE
        See Also:
        Constant Field Values

      • INACTIVE

        public static final State INACTIVE

    • Constructor Detail

      • State

        protected State(int value)

    • Method Detail

      • value

        public int value()

      • from_int

        public static State from_int(int value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


POAOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface POAOperations

  • All Known Subinterfaces:
    POA

    public interface POAOperations
    A POA object manages the implementation of a collection of objects. The POA supports a name space for the objects, which are identified by Object Ids. A POA also provides a name space for POAs. A POA is created as a child of an existing POA, which forms a hierarchy starting with the root POA. A POA object must not be exported to other processes, or externalized with ORB::object_to_string.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void activate_object_with_id(byte[] id, Servant p_servant)
      This operation enters an association between the specified Object Id and the specified servant in the Active Object Map.
      byte[] activate_object(Servant p_servant)
      This operation generates an Object Id and enters the Object Id and the specified servant in the Active Object Map.
      IdAssignmentPolicy create_id_assignment_policy(IdAssignmentPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
      IdUniquenessPolicy create_id_uniqueness_policy(IdUniquenessPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
      ImplicitActivationPolicy create_implicit_activation_policy(ImplicitActivationPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
      LifespanPolicy create_lifespan_policy(LifespanPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
      POA create_POA(String adapter_name, POAManager a_POAManager, Policy[] policies)
      This operation creates a new POA as a child of the target POA.
      Object create_reference_with_id(byte[] oid, String intf)
      This operation creates an object reference that encapsulates the specified Object Id and interface repository Id values.
      Object create_reference(String intf)
      This operation creates an object reference that encapsulates a POA-generated Object Id value and the specified interface repository id.
      RequestProcessingPolicy create_request_processing_policy(RequestProcessingPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
      ServantRetentionPolicy create_servant_retention_policy(ServantRetentionPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
      ThreadPolicy create_thread_policy(ThreadPolicyValue value)
      These operations each return a reference to a policy object with the specified value.
      void deactivate_object(byte[] oid)
      This operation causes the ObjectId specified in the oid parameter to be deactivated.
      void destroy(boolean etherealize_objects, boolean wait_for_completion)
      This operation destroys the POA and all descendant POAs.
      POA find_POA(String adapter_name, boolean activate_it)
      If the target POA is the parent of a child POA with the specified name (relative to the target POA), that child POA is returned.
      ServantManager get_servant_manager()
      If the ServantRetentionPolicy of the POA is RETAIN, then the ServantManager argument (imgr) shall support the ServantActivator interface.
      Servant get_servant()
      This operation returns the default servant associated with the POA.
      Object id_to_reference(byte[] oid)
      If an object with the specified Object Id value is currently active, a reference encapsulating the information used to activate the object is returned.
      Servant id_to_servant(byte[] oid)
      If the POA has the RETAIN policy and the specified ObjectId is in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map.
      byte[] id()
      This returns the unique id of the POA in the process in which it is created.
      byte[] reference_to_id(Object reference)
      This operation returns the Object Id value encapsulated by the specified reference.
      Servant reference_to_servant(Object reference)
      If the POA has the RETAIN policy and the specified object is present in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map.
      byte[] servant_to_id(Servant p_servant)
      This operation has four possible behaviors.
      Object servant_to_reference(Servant p_servant)
      This operation requires the RETAIN policy and either the UNIQUE_ID or IMPLICIT_ACTIVATION policies if invoked outside the context of an operation dispatched by this POA.
      void set_servant_manager(ServantManager imgr)
      This operation sets the default servant manager associated with the POA.
      void set_servant(Servant p_servant)
      This operation registers the specified servant with the POA as the default servant.
      AdapterActivator the_activator()
      This attribute identifies the adapter activator associated with the POA.
      void the_activator(AdapterActivator newThe_activator)
      This attribute identifies the adapter activator associated with the POA.
      POA[] the_children()
      This attribute identifies the current set of all child POAs of the POA.
      String the_name()
      This attribute identifies the POA relative to its parent.
      POA the_parent()
      This attribute identifies the parent of the POA.
      POAManager the_POAManager()
      This attribute identifies the POA manager associated with the POA.

    • Method Detail

      • create_POA

        POA create_POA(String adapter_name,
               POAManager a_POAManager,
               Policy[] policies)
        throws AdapterAlreadyExists,
               InvalidPolicy
        This operation creates a new POA as a child of the target POA.
        Parameters:
        adapter_name - identifies the new POA with respect to other POAs with the same parent POA.
        a_POAManager - specifies the POA Manager to be associated with the new POA.
        policies - specifies policy objects to be associated with the POA to control its behavior.
        Throws:
        AdapterAlreadyExists - specifies that the target POA already has a child POA with the specified name.
        InvalidPolicy - is raised if any of the policy objects are not valid for the ORB, or are in conflict, or require an administrative action that has not been performed.

      • find_POA

        POA find_POA(String adapter_name,
             boolean activate_it)
      throws AdapterNonExistent
        If the target POA is the parent of a child POA with the specified name (relative to the target POA), that child POA is returned.
        Parameters:
        adapter_name - POA name to be found.
        activate_it - if a POA with the specified name does not exist and the value of the activate_it parameter is TRUE, the target POA's AdapterActivator, if one exists, is invoked.
        Returns:
        POA if one exists or is activated by the AdapterActivator.
        Throws:
        AdapterNonExistent

      • destroy

        void destroy(boolean etherealize_objects,
             boolean wait_for_completion)
        This operation destroys the POA and all descendant POAs. All descendant POAs are destroyed (recursively) before the destruction of the containing POA. The POA so destroyed (that is, the POA with its name) may be re-created later in the same process.
        Parameters:
        etherealize_objects - flag to indicate whether etherealize operation on servant manager needs to be called.
        wait_for_completion - flag to indicate whether POA and its children need to wait for active requests and the etherealization to complete.

      • create_thread_policy

        ThreadPolicy create_thread_policy(ThreadPolicyValue value)
        These operations each return a reference to a policy object with the specified value.
        Parameters:
        value - policy type
        Returns:
        ThreadPolcy Object

      • create_lifespan_policy

        LifespanPolicy create_lifespan_policy(LifespanPolicyValue value)
        These operations each return a reference to a policy object with the specified value.
        Parameters:
        value - policy type
        Returns:
        LifespanPolicy Object.

      • create_id_uniqueness_policy

        IdUniquenessPolicy create_id_uniqueness_policy(IdUniquenessPolicyValue value)
        These operations each return a reference to a policy object with the specified value.
        Parameters:
        value - policy type
        Returns:
        IdUniquenessPolicy Object.

      • create_id_assignment_policy

        IdAssignmentPolicy create_id_assignment_policy(IdAssignmentPolicyValue value)
        These operations each return a reference to a policy object with the specified value.
        Parameters:
        value - policy type
        Returns:
        IdAssignmentPolicy Object.

      • create_implicit_activation_policy

        ImplicitActivationPolicy create_implicit_activation_policy(ImplicitActivationPolicyValue value)
        These operations each return a reference to a policy object with the specified value.
        Parameters:
        value - policy type
        Returns:
        ImplicitActivationPolicy Object.

      • create_servant_retention_policy

        ServantRetentionPolicy create_servant_retention_policy(ServantRetentionPolicyValue value)
        These operations each return a reference to a policy object with the specified value.
        Parameters:
        value - policy type
        Returns:
        ServantRetentionPolicy Object.

      • create_request_processing_policy

        RequestProcessingPolicy create_request_processing_policy(RequestProcessingPolicyValue value)
        These operations each return a reference to a policy object with the specified value.
        Parameters:
        value - policy type
        Returns:
        RequestProcessingPolicy Object.

      • the_name

        String the_name()
        This attribute identifies the POA relative to its parent. This name is assigned when the POA is created.

      • the_parent

        POA the_parent()
        This attribute identifies the parent of the POA. The parent of the root POA is null.

      • the_children

        POA[] the_children()
        This attribute identifies the current set of all child POAs of the POA. The set of child POAs includes only the POA's immediate children, and not their descendants.

      • the_POAManager

        POAManager the_POAManager()
        This attribute identifies the POA manager associated with the POA.

      • the_activator

        AdapterActivator the_activator()
        This attribute identifies the adapter activator associated with the POA.

      • the_activator

        void the_activator(AdapterActivator newThe_activator)
        This attribute identifies the adapter activator associated with the POA.

      • get_servant_manager

        ServantManager get_servant_manager()
                            throws WrongPolicy
        If the ServantRetentionPolicy of the POA is RETAIN, then the ServantManager argument (imgr) shall support the ServantActivator interface. For a NON_RETAIN policy, the ServantManager shall support the ServantLocator interface. If the argument is nil, or does not support the required interface, then the OBJ_ADAPTER exception is raised.
        Returns:
        ServantManager associated with a POA or null if none exists.
        Throws:
        WrongPolicy - raised if the USE_SERVANT_MANAGER policy is not specified.

      • set_servant_manager

        void set_servant_manager(ServantManager imgr)
                  throws WrongPolicy
        This operation sets the default servant manager associated with the POA. This operation may only be invoked once after a POA has been created. Attempting to set the servant manager after one has already been set will result in the BAD_INV_ORDER exception being raised.
        Parameters:
        imgr - servant manager to be used as a default.
        Throws:
        WrongPolicy - raised if the USE_SERVANT_MANAGER policy is not specified.

      • get_servant

        Servant get_servant()
             throws NoServant,
                    WrongPolicy
        This operation returns the default servant associated with the POA.
        Returns:
        p_servant default servant associated with a POA.
        Throws:
        NoServant - raised if no default servant is associated with the POA.
        WrongPolicy - raised if the USE_DEFAULT_SERVANT policy is not specified.

      • set_servant

        void set_servant(Servant p_servant)
          throws WrongPolicy
        This operation registers the specified servant with the POA as the default servant. This servant will be used for all requests for which no servant is found in the Active Object Map.
        Parameters:
        p_servant - servant to be used as a default.
        Throws:
        WrongPolicy - raised if the USE_DEFAULT_SERVANT policy is not specified.

      • activate_object

        byte[] activate_object(Servant p_servant)
                throws ServantAlreadyActive,
                       WrongPolicy
        This operation generates an Object Id and enters the Object Id and the specified servant in the Active Object Map.
        Parameters:
        p_servant - servant to be associated with an object to be activated.
        Returns:
        POA generated object id.
        Throws:
        ServantAlreadyActive - is raised if the POA has UNIQUE_ID policy and servant is is already in the Active Object Map.
        WrongPolicy - raised if the SYSTEM_ID and RETAIN policies are not specified.

      • activate_object_with_id

        void activate_object_with_id(byte[] id,
                             Servant p_servant)
                      throws ServantAlreadyActive,
                             ObjectAlreadyActive,
                             WrongPolicy
        This operation enters an association between the specified Object Id and the specified servant in the Active Object Map.
        Parameters:
        id - object id for the object to be activated.
        p_servant - servant to be associated with the object.
        Throws:
        ServantAlreadyActive - raised if the POA has the UNIQUE_ID policy and the servant is already in the Active Object Map.
        ObjectAlreadyActive - raised if the object is already active in the POA.
        WrongPolicy - raised if the RETAIN policy is is not specified.

      • deactivate_object

        void deactivate_object(byte[] oid)
                throws ObjectNotActive,
                       WrongPolicy
        This operation causes the ObjectId specified in the oid parameter to be deactivated. An ObjectId which has been deactivated continues to process requests until there are no active requests for that ObjectId. A deactivated ObjectId is removed from the Active Object Map when all requests executing for that ObjectId have completed.
        Parameters:
        oid - Object Id for the object to be deactivated.
        Throws:
        ObjectNotActive - if the object with the specified oid is not in the Active Object Map.
        WrongPolicy - raised if the RETAIN policy is is not specified.

      • create_reference

        Object create_reference(String intf)
                 throws WrongPolicy
        This operation creates an object reference that encapsulates a POA-generated Object Id value and the specified interface repository id.
        Parameters:
        intf - rep id for creating an object reference.
        Returns:
        object reference created using intf.
        Throws:
        WrongPolicy - if SYSTEM_ID policy is not specified.

      • create_reference_with_id

        Object create_reference_with_id(byte[] oid,
                                String intf)
        This operation creates an object reference that encapsulates the specified Object Id and interface repository Id values. It does not cause an activation to take place. The resulting reference may be passed to clients, so that subsequent requests on those references will cause the object to be activated if necessary, or the default servant used, depending on the applicable policies.
        Parameters:
        oid - object id for creating an objref
        intf - rep id for creating an objref
        Returns:
        object reference created using oid and intf
        Throws:
        BAD_PARAM - is raised if the POA has the SYSTEM_ID policy and it detects that the Object Id value was not generated by the system or for this POA.

      • servant_to_id

        byte[] servant_to_id(Servant p_servant)
              throws ServantNotActive,
                     WrongPolicy
        This operation has four possible behaviors. 1. If the POA has the UNIQUE_ID policy and the specified servant is active, the Object Id associated with that servant is returned. 2. If the POA has the IMPLICIT_ACTIVATION policy and either the POA has the MULTIPLE_ID policy or the specified servant is not active, the servant is activated using a POA-generated Object Id and the Interface Id associated with the servant, and that Object Id is returned. 3. If the POA has the USE_DEFAULT_SERVANT policy, the servant specified is the default servant, and the operation is being invoked in the context of executing a request on the default servant, then the ObjectId associated with the current invocation is returned. 4. Otherwise, the ServantNotActive exception is raised.
        Parameters:
        p_servant - servant for which the object disi returned.
        Returns:
        object id associated with the servant.
        Throws:
        ServantNotActive - if the above rules and policy combination is not met.
        WrongPolicy - if the USE_DEFAULT_SERVANT policy or a combination of the RETAIN policy and either the UNIQUE_ID or IMPLICIT_ACTIVATION policies are not present.

      • servant_to_reference

        Object servant_to_reference(Servant p_servant)
                     throws ServantNotActive,
                            WrongPolicy
        This operation requires the RETAIN policy and either the UNIQUE_ID or IMPLICIT_ACTIVATION policies if invoked outside the context of an operation dispatched by this POA. It has four possible behaviors. 1. If the POA has both the RETAIN and the UNIQUE_ID policy and the specified servant is active, an object reference encapsulating the information used to activate the servant is returned. 2. If the POA has both the RETAIN and the IMPLICIT_ACTIVATION policy and either the POA has the MULTIPLE_ID policy or the specified servant is not active, the servant is activated using a POA-generated Object Id and the Interface Id associated with the servant, and a corresponding object reference is returned. 3. If the operation was invoked in the context of executing a request on the specified servant, the reference associated with the current invocation is returned. 4. Otherwise, the ServantNotActive exception is raised.
        Parameters:
        p_servant - servant for which the object reference needs to be obtained.
        Returns:
        object reference associated with the servant.
        Throws:
        WrongPolicy - if the operation is not invoked in the context of executing a request on the specified servant and the required policies are not present.
        ServantNotActive - if the above specified policies and rules are not met.

      • reference_to_servant

        Servant reference_to_servant(Object reference)
                      throws ObjectNotActive,
                             WrongPolicy,
                             WrongAdapter
        If the POA has the RETAIN policy and the specified object is present in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map. Otherwise, if the POA has the USE_DEFAULT_SERVANT policy and a default servant has been registered with the POA, this operation returns the default servant. If the object reference was not created by this POA, the WrongAdapter exception is raised. (OMG Issue on inconsistency with the POA.IDL.
        Parameters:
        reference - object reference for which the servant is returned.
        Returns:
        servant associated with the reference.
        Throws:
        WrongPolicy - if neither the RETAIN policy or the USE_DEFAULT_SERVANT policy is present.
        ObjectNotActive - if the servant is not present in the Active Object Map (for RETAIN) or no default servant is registered (for USE_DEFAULT_POLICY).
        WrongAdapter - if reference was not created by this POA instance.

      • reference_to_id

        byte[] reference_to_id(Object reference)
                throws WrongAdapter,
                       WrongPolicy
        This operation returns the Object Id value encapsulated by the specified reference. This operation is valid only if the reference was created by the POA on which the operation is being performed. The object denoted by the reference does not have to be active for this operation to succeed.
        Parameters:
        reference - the object reference from which the object id needs to be returned.
        Returns:
        object id encapsulated in the reference.
        Throws:
        WrongAdapter - if the reference was not created by the POA specified in the reference.
        WrongPolicy - declared to allow future extensions.

      • id_to_servant

        Servant id_to_servant(byte[] oid)
               throws ObjectNotActive,
                      WrongPolicy
        If the POA has the RETAIN policy and the specified ObjectId is in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map. Otherwise, if the POA has the USE_DEFAULT_SERVANT policy and a default servant has been registered with the POA, this operation returns the default servant.
        Parameters:
        oid - object id for the which the servant is returned.
        Returns:
        servant associated with oid.
        Throws:
        ObjectNotActive - is raised if ObjectId is is not in the Active Object Map (for RETAIN policy), or no default servant is registered (for USE_DEFAULT_SERVANT policy).
        WrongPolicy - is raised if the RETAIN policy or the USE_DEFAULT_SERVANT policy is not present.

      • id_to_reference

        Object id_to_reference(byte[] oid)
                throws ObjectNotActive,
                       WrongPolicy
        If an object with the specified Object Id value is currently active, a reference encapsulating the information used to activate the object is returned.
        Parameters:
        oid - id of the object for which the reference is returned.
        Returns:
        the object reference
        Throws:
        ObjectNotActive - if the Object Id value is not active in the POA.
        WrongPolicy - if the RETAIN policy is not present.

      • id

        byte[] id()
        This returns the unique id of the POA in the process in which it is created. It is for use by portable interceptors.

        This id is guaranteed unique for the life span of the POA in the process. For persistent POAs, this means that if a POA is created in the same path with the same name as another POA, these POAs are identical and, therefore, have the same id. For transient POAs, each POA is unique.

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AdapterAlreadyExists (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class AdapterAlreadyExists

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.POAPackage.AdapterAlreadyExists
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class AdapterAlreadyExists
extends UserException
    org/omg/PortableServer/POAPackage/AdapterAlreadyExists.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableServer/poa.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      AdapterAlreadyExists()
      AdapterAlreadyExists(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • AdapterAlreadyExists

        public AdapterAlreadyExists()

      • AdapterAlreadyExists

        public AdapterAlreadyExists(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AdapterAlreadyExistsHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class AdapterAlreadyExistsHelper

  • java.lang.Object
    • org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper

  • public abstract class AdapterAlreadyExistsHelper
extends Object
    org/omg/PortableServer/POAPackage/AdapterAlreadyExistsHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableServer/poa.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      AdapterAlreadyExistsHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static AdapterAlreadyExists | extract(Any a)
      static String | id()
      static void | insert(Any a, AdapterAlreadyExists that)
      static AdapterAlreadyExists | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, AdapterAlreadyExists value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AdapterAlreadyExistsHelper

        public AdapterAlreadyExistsHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          AdapterAlreadyExists that)

      • extract

        public static AdapterAlreadyExists extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static AdapterAlreadyExists read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         AdapterAlreadyExists value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AdapterNonExistent (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class AdapterNonExistent

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.POAPackage.AdapterNonExistent
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class AdapterNonExistent
extends UserException
    org/omg/PortableServer/POAPackage/AdapterNonExistent.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableServer/poa.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      AdapterNonExistent()
      AdapterNonExistent(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • AdapterNonExistent

        public AdapterNonExistent()

      • AdapterNonExistent

        public AdapterNonExistent(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AdapterNonExistentHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class AdapterNonExistentHelper

  • java.lang.Object
    • org.omg.PortableServer.POAPackage.AdapterNonExistentHelper

  • public abstract class AdapterNonExistentHelper
extends Object
    org/omg/PortableServer/POAPackage/AdapterNonExistentHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableServer/poa.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      AdapterNonExistentHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static AdapterNonExistent | extract(Any a)
      static String | id()
      static void | insert(Any a, AdapterNonExistent that)
      static AdapterNonExistent | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, AdapterNonExistent value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AdapterNonExistentHelper

        public AdapterNonExistentHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          AdapterNonExistent that)

      • extract

        public static AdapterNonExistent extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static AdapterNonExistent read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         AdapterNonExistent value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Class org.omg.PortableServer.POAPackage.AdapterAlreadyExists (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.AdapterAlreadyExists

  • Packages that use AdapterAlreadyExists
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.

    • Uses of AdapterAlreadyExists in org.omg.PortableServer

      Methods in org.omg.PortableServer that throw AdapterAlreadyExists
      Modifier and Type Method and Description
      POA POAOperations.create_POA(String adapter_name, POAManager a_POAManager, Policy[] policies)
      This operation creates a new POA as a child of the target POA.

    • Uses of AdapterAlreadyExists in org.omg.PortableServer.POAPackage

      Methods in org.omg.PortableServer.POAPackage that return AdapterAlreadyExists
      Modifier and Type | Method and Description
      static AdapterAlreadyExists | AdapterAlreadyExistsHelper.extract(Any a)
      static AdapterAlreadyExists | AdapterAlreadyExistsHelper.read(InputStream istream)
      Methods in org.omg.PortableServer.POAPackage with parameters of type AdapterAlreadyExists
      Modifier and Type | Method and Description
      static void | AdapterAlreadyExistsHelper.insert(Any a, AdapterAlreadyExists that)
      static void | AdapterAlreadyExistsHelper.write(OutputStream ostream, AdapterAlreadyExists value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper

No usage of org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.POAPackage.AdapterNonExistent (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.AdapterNonExistent

  • Packages that use AdapterNonExistent
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.

    • Uses of AdapterNonExistent in org.omg.PortableServer

      Methods in org.omg.PortableServer that throw AdapterNonExistent
      Modifier and Type Method and Description
      POA POAOperations.find_POA(String adapter_name, boolean activate_it)
      If the target POA is the parent of a child POA with the specified name (relative to the target POA), that child POA is returned.

    • Uses of AdapterNonExistent in org.omg.PortableServer.POAPackage

      Methods in org.omg.PortableServer.POAPackage that return AdapterNonExistent
      Modifier and Type | Method and Description
      static AdapterNonExistent | AdapterNonExistentHelper.extract(Any a)
      static AdapterNonExistent | AdapterNonExistentHelper.read(InputStream istream)
      Methods in org.omg.PortableServer.POAPackage with parameters of type AdapterNonExistent
      Modifier and Type | Method and Description
      static void | AdapterNonExistentHelper.insert(Any a, AdapterNonExistent that)
      static void | AdapterNonExistentHelper.write(OutputStream ostream, AdapterNonExistent value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.POAPackage.AdapterNonExistentHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.AdapterNonExistentHelper

No usage of org.omg.PortableServer.POAPackage.AdapterNonExistentHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.POAPackage.InvalidPolicy (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.InvalidPolicy

  • Packages that use InvalidPolicy
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.

    • Uses of InvalidPolicy in org.omg.PortableServer

      Methods in org.omg.PortableServer that throw InvalidPolicy
      Modifier and Type Method and Description
      POA POAOperations.create_POA(String adapter_name, POAManager a_POAManager, Policy[] policies)
      This operation creates a new POA as a child of the target POA.

    • Uses of InvalidPolicy in org.omg.PortableServer.POAPackage

      Methods in org.omg.PortableServer.POAPackage that return InvalidPolicy
      Modifier and Type | Method and Description
      static InvalidPolicy | InvalidPolicyHelper.extract(Any a)
      static InvalidPolicy | InvalidPolicyHelper.read(InputStream istream)
      Methods in org.omg.PortableServer.POAPackage with parameters of type InvalidPolicy
      Modifier and Type | Method and Description
      static void | InvalidPolicyHelper.insert(Any a, InvalidPolicy that)
      static void | InvalidPolicyHelper.write(OutputStream ostream, InvalidPolicy value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.POAPackage.InvalidPolicyHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.InvalidPolicyHelper

No usage of org.omg.PortableServer.POAPackage.InvalidPolicyHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.POAPackage.NoServant (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.NoServant

  • Packages that use NoServant
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.

    • Uses of NoServant in org.omg.PortableServer

      Methods in org.omg.PortableServer that throw NoServant
      Modifier and Type Method and Description
      Servant POAOperations.get_servant()
      This operation returns the default servant associated with the POA.

    • Uses of NoServant in org.omg.PortableServer.POAPackage

      Methods in org.omg.PortableServer.POAPackage that return NoServant
      Modifier and Type | Method and Description
      static NoServant | NoServantHelper.extract(Any a)
      static NoServant | NoServantHelper.read(InputStream istream)
      Methods in org.omg.PortableServer.POAPackage with parameters of type NoServant
      Modifier and Type | Method and Description
      static void | NoServantHelper.insert(Any a, NoServant that)
      static void | NoServantHelper.write(OutputStream ostream, NoServant value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.POAPackage.NoServantHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.NoServantHelper

No usage of org.omg.PortableServer.POAPackage.NoServantHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.POAPackage.ObjectAlreadyActive (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.ObjectAlreadyActive

  • Packages that use ObjectAlreadyActive
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.

    • Uses of ObjectAlreadyActive in org.omg.PortableServer

      Methods in org.omg.PortableServer that throw ObjectAlreadyActive
      Modifier and Type Method and Description
      void POAOperations.activate_object_with_id(byte[] id, Servant p_servant)
      This operation enters an association between the specified Object Id and the specified servant in the Active Object Map.

    • Uses of ObjectAlreadyActive in org.omg.PortableServer.POAPackage

      Methods in org.omg.PortableServer.POAPackage that return ObjectAlreadyActive
      Modifier and Type | Method and Description
      static ObjectAlreadyActive | ObjectAlreadyActiveHelper.extract(Any a)
      static ObjectAlreadyActive | ObjectAlreadyActiveHelper.read(InputStream istream)
      Methods in org.omg.PortableServer.POAPackage with parameters of type ObjectAlreadyActive
      Modifier and Type | Method and Description
      static void | ObjectAlreadyActiveHelper.insert(Any a, ObjectAlreadyActive that)
      static void | ObjectAlreadyActiveHelper.write(OutputStream ostream, ObjectAlreadyActive value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper

No usage of org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.POAPackage.ObjectNotActive (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.ObjectNotActive

  • Packages that use ObjectNotActive
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.

    • Uses of ObjectNotActive in org.omg.PortableServer

      Methods in org.omg.PortableServer that throw ObjectNotActive
      Modifier and Type Method and Description
      void POAOperations.deactivate_object(byte[] oid)
      This operation causes the ObjectId specified in the oid parameter to be deactivated.
      Object POAOperations.id_to_reference(byte[] oid)
      If an object with the specified Object Id value is currently active, a reference encapsulating the information used to activate the object is returned.
      Servant POAOperations.id_to_servant(byte[] oid)
      If the POA has the RETAIN policy and the specified ObjectId is in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map.
      Servant POAOperations.reference_to_servant(Object reference)
      If the POA has the RETAIN policy and the specified object is present in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map.

    • Uses of ObjectNotActive in org.omg.PortableServer.POAPackage

      Methods in org.omg.PortableServer.POAPackage that return ObjectNotActive
      Modifier and Type | Method and Description
      static ObjectNotActive | ObjectNotActiveHelper.extract(Any a)
      static ObjectNotActive | ObjectNotActiveHelper.read(InputStream istream)
      Methods in org.omg.PortableServer.POAPackage with parameters of type ObjectNotActive
      Modifier and Type | Method and Description
      static void | ObjectNotActiveHelper.insert(Any a, ObjectNotActive that)
      static void | ObjectNotActiveHelper.write(OutputStream ostream, ObjectNotActive value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.POAPackage.ObjectNotActiveHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.ObjectNotActiveHelper

No usage of org.omg.PortableServer.POAPackage.ObjectNotActiveHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.POAPackage.ServantAlreadyActive (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.ServantAlreadyActive

  • Packages that use ServantAlreadyActive
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.

    • Uses of ServantAlreadyActive in org.omg.PortableServer

      Methods in org.omg.PortableServer that throw ServantAlreadyActive
      Modifier and Type Method and Description
      void POAOperations.activate_object_with_id(byte[] id, Servant p_servant)
      This operation enters an association between the specified Object Id and the specified servant in the Active Object Map.
      byte[] POAOperations.activate_object(Servant p_servant)
      This operation generates an Object Id and enters the Object Id and the specified servant in the Active Object Map.

    • Uses of ServantAlreadyActive in org.omg.PortableServer.POAPackage

      Methods in org.omg.PortableServer.POAPackage that return ServantAlreadyActive
      Modifier and Type | Method and Description
      static ServantAlreadyActive | ServantAlreadyActiveHelper.extract(Any a)
      static ServantAlreadyActive | ServantAlreadyActiveHelper.read(InputStream istream)
      Methods in org.omg.PortableServer.POAPackage with parameters of type ServantAlreadyActive
      Modifier and Type | Method and Description
      static void | ServantAlreadyActiveHelper.insert(Any a, ServantAlreadyActive that)
      static void | ServantAlreadyActiveHelper.write(OutputStream ostream, ServantAlreadyActive value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper

No usage of org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.POAPackage.ServantNotActive (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.ServantNotActive

  • Packages that use ServantNotActive
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.

    • Uses of ServantNotActive in org.omg.PortableServer

      Methods in org.omg.PortableServer that throw ServantNotActive
      Modifier and Type Method and Description
      byte[] POAOperations.servant_to_id(Servant p_servant)
      This operation has four possible behaviors.
      Object POAOperations.servant_to_reference(Servant p_servant)
      This operation requires the RETAIN policy and either the UNIQUE_ID or IMPLICIT_ACTIVATION policies if invoked outside the context of an operation dispatched by this POA.

    • Uses of ServantNotActive in org.omg.PortableServer.POAPackage

      Methods in org.omg.PortableServer.POAPackage that return ServantNotActive
      Modifier and Type | Method and Description
      static ServantNotActive | ServantNotActiveHelper.extract(Any a)
      static ServantNotActive | ServantNotActiveHelper.read(InputStream istream)
      Methods in org.omg.PortableServer.POAPackage with parameters of type ServantNotActive
      Modifier and Type | Method and Description
      static void | ServantNotActiveHelper.insert(Any a, ServantNotActive that)
      static void | ServantNotActiveHelper.write(OutputStream ostream, ServantNotActive value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.POAPackage.ServantNotActiveHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.ServantNotActiveHelper

No usage of org.omg.PortableServer.POAPackage.ServantNotActiveHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.POAPackage.WrongAdapter (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.WrongAdapter

  • Packages that use WrongAdapter
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.

    • Uses of WrongAdapter in org.omg.PortableServer

      Methods in org.omg.PortableServer that throw WrongAdapter
      Modifier and Type Method and Description
      byte[] POAOperations.reference_to_id(Object reference)
      This operation returns the Object Id value encapsulated by the specified reference.
      Servant POAOperations.reference_to_servant(Object reference)
      If the POA has the RETAIN policy and the specified object is present in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map.

    • Uses of WrongAdapter in org.omg.PortableServer.POAPackage

      Methods in org.omg.PortableServer.POAPackage that return WrongAdapter
      Modifier and Type | Method and Description
      static WrongAdapter | WrongAdapterHelper.extract(Any a)
      static WrongAdapter | WrongAdapterHelper.read(InputStream istream)
      Methods in org.omg.PortableServer.POAPackage with parameters of type WrongAdapter
      Modifier and Type | Method and Description
      static void | WrongAdapterHelper.insert(Any a, WrongAdapter that)
      static void | WrongAdapterHelper.write(OutputStream ostream, WrongAdapter value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.POAPackage.WrongAdapterHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.WrongAdapterHelper

No usage of org.omg.PortableServer.POAPackage.WrongAdapterHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.POAPackage.WrongPolicy (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.WrongPolicy

  • Packages that use WrongPolicy
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.

    • Uses of WrongPolicy in org.omg.PortableServer

      Methods in org.omg.PortableServer that throw WrongPolicy
      Modifier and Type Method and Description
      void POAOperations.activate_object_with_id(byte[] id, Servant p_servant)
      This operation enters an association between the specified Object Id and the specified servant in the Active Object Map.
      byte[] POAOperations.activate_object(Servant p_servant)
      This operation generates an Object Id and enters the Object Id and the specified servant in the Active Object Map.
      Object POAOperations.create_reference(String intf)
      This operation creates an object reference that encapsulates a POA-generated Object Id value and the specified interface repository id.
      void POAOperations.deactivate_object(byte[] oid)
      This operation causes the ObjectId specified in the oid parameter to be deactivated.
      ServantManager POAOperations.get_servant_manager()
      If the ServantRetentionPolicy of the POA is RETAIN, then the ServantManager argument (imgr) shall support the ServantActivator interface.
      Servant POAOperations.get_servant()
      This operation returns the default servant associated with the POA.
      Object POAOperations.id_to_reference(byte[] oid)
      If an object with the specified Object Id value is currently active, a reference encapsulating the information used to activate the object is returned.
      Servant POAOperations.id_to_servant(byte[] oid)
      If the POA has the RETAIN policy and the specified ObjectId is in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map.
      byte[] POAOperations.reference_to_id(Object reference)
      This operation returns the Object Id value encapsulated by the specified reference.
      Servant POAOperations.reference_to_servant(Object reference)
      If the POA has the RETAIN policy and the specified object is present in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map.
      byte[] POAOperations.servant_to_id(Servant p_servant)
      This operation has four possible behaviors.
      Object POAOperations.servant_to_reference(Servant p_servant)
      This operation requires the RETAIN policy and either the UNIQUE_ID or IMPLICIT_ACTIVATION policies if invoked outside the context of an operation dispatched by this POA.
      void POAOperations.set_servant_manager(ServantManager imgr)
      This operation sets the default servant manager associated with the POA.
      void POAOperations.set_servant(Servant p_servant)
      This operation registers the specified servant with the POA as the default servant.

    • Uses of WrongPolicy in org.omg.PortableServer.POAPackage

      Methods in org.omg.PortableServer.POAPackage that return WrongPolicy
      Modifier and Type | Method and Description
      static WrongPolicy | WrongPolicyHelper.extract(Any a)
      static WrongPolicy | WrongPolicyHelper.read(InputStream istream)
      Methods in org.omg.PortableServer.POAPackage with parameters of type WrongPolicy
      Modifier and Type | Method and Description
      static void | WrongPolicyHelper.insert(Any a, WrongPolicy that)
      static void | WrongPolicyHelper.write(OutputStream ostream, WrongPolicy value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.omg.PortableServer.POAPackage.WrongPolicyHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.POAPackage.WrongPolicyHelper

No usage of org.omg.PortableServer.POAPackage.WrongPolicyHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


InvalidPolicy (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class InvalidPolicy

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.POAPackage.InvalidPolicy
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class InvalidPolicy
extends UserException
    org/omg/PortableServer/POAPackage/InvalidPolicy.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableServer/poa.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      short | index

    • Constructor Summary

      Constructors
      Constructor and Description
      InvalidPolicy()
      InvalidPolicy(short _index)
      InvalidPolicy(String $reason, short _index)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • index

        public short index

    • Constructor Detail

      • InvalidPolicy

        public InvalidPolicy()

      • InvalidPolicy

        public InvalidPolicy(short _index)

      • InvalidPolicy

        public InvalidPolicy(String $reason,
                     short _index)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


InvalidPolicyHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class InvalidPolicyHelper

  • java.lang.Object
    • org.omg.PortableServer.POAPackage.InvalidPolicyHelper

  • public abstract class InvalidPolicyHelper
extends Object
    org/omg/PortableServer/POAPackage/InvalidPolicyHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableServer/poa.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      InvalidPolicyHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static InvalidPolicy | extract(Any a)
      static String | id()
      static void | insert(Any a, InvalidPolicy that)
      static InvalidPolicy | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, InvalidPolicy value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • InvalidPolicyHelper

        public InvalidPolicyHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          InvalidPolicy that)

      • extract

        public static InvalidPolicy extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static InvalidPolicy read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         InvalidPolicy value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NoServant (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class NoServant

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.POAPackage.NoServant
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class NoServant
extends UserException
    org/omg/PortableServer/POAPackage/NoServant.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableServer/poa.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      NoServant()
      NoServant(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • NoServant

        public NoServant()

      • NoServant

        public NoServant(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NoServantHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class NoServantHelper

  • java.lang.Object
    • org.omg.PortableServer.POAPackage.NoServantHelper

  • public abstract class NoServantHelper
extends Object
    org/omg/PortableServer/POAPackage/NoServantHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableServer/poa.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      NoServantHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static NoServant | extract(Any a)
      static String | id()
      static void | insert(Any a, NoServant that)
      static NoServant | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, NoServant value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • NoServantHelper

        public NoServantHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          NoServant that)

      • extract

        public static NoServant extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static NoServant read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         NoServant value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ObjectAlreadyActive (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class ObjectAlreadyActive

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.POAPackage.ObjectAlreadyActive
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class ObjectAlreadyActive
extends UserException
    org/omg/PortableServer/POAPackage/ObjectAlreadyActive.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableServer/poa.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      ObjectAlreadyActive()
      ObjectAlreadyActive(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ObjectAlreadyActive

        public ObjectAlreadyActive()

      • ObjectAlreadyActive

        public ObjectAlreadyActive(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ObjectAlreadyActiveHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class ObjectAlreadyActiveHelper

  • java.lang.Object
    • org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper

  • public abstract class ObjectAlreadyActiveHelper
extends Object
    org/omg/PortableServer/POAPackage/ObjectAlreadyActiveHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableServer/poa.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      ObjectAlreadyActiveHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static ObjectAlreadyActive | extract(Any a)
      static String | id()
      static void | insert(Any a, ObjectAlreadyActive that)
      static ObjectAlreadyActive | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, ObjectAlreadyActive value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ObjectAlreadyActiveHelper

        public ObjectAlreadyActiveHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          ObjectAlreadyActive that)

      • extract

        public static ObjectAlreadyActive extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ObjectAlreadyActive read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         ObjectAlreadyActive value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ObjectNotActive (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class ObjectNotActive

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.POAPackage.ObjectNotActive
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class ObjectNotActive
extends UserException
    org/omg/PortableServer/POAPackage/ObjectNotActive.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableServer/poa.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      ObjectNotActive()
      ObjectNotActive(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ObjectNotActive

        public ObjectNotActive()

      • ObjectNotActive

        public ObjectNotActive(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ObjectNotActiveHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class ObjectNotActiveHelper

  • java.lang.Object
    • org.omg.PortableServer.POAPackage.ObjectNotActiveHelper

  • public abstract class ObjectNotActiveHelper
extends Object
    org/omg/PortableServer/POAPackage/ObjectNotActiveHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableServer/poa.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      ObjectNotActiveHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static ObjectNotActive | extract(Any a)
      static String | id()
      static void | insert(Any a, ObjectNotActive that)
      static ObjectNotActive | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, ObjectNotActive value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ObjectNotActiveHelper

        public ObjectNotActiveHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          ObjectNotActive that)

      • extract

        public static ObjectNotActive extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ObjectNotActive read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         ObjectNotActive value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


org.omg.PortableServer.POAPackage (Java Platform SE 8 )

org.omg.PortableServer.POAPackage

Classes

  • AdapterAlreadyExistsHelper
  • AdapterNonExistentHelper
  • InvalidPolicyHelper
  • NoServantHelper
  • ObjectAlreadyActiveHelper
  • ObjectNotActiveHelper
  • ServantAlreadyActiveHelper
  • ServantNotActiveHelper
  • WrongAdapterHelper
  • WrongPolicyHelper

Exceptions

  • AdapterAlreadyExists
  • AdapterNonExistent
  • InvalidPolicy
  • NoServant
  • ObjectAlreadyActive
  • ObjectNotActive
  • ServantAlreadyActive
  • ServantNotActive
  • WrongAdapter
  • WrongPolicy


org.omg.PortableServer.POAPackage (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.PortableServer.POAPackage

Allows programmers to construct object implementations that are portable between different ORB products.

See: Description

  • Class Summary
    Class Description
    AdapterAlreadyExistsHelper
    org/omg/PortableServer/POAPackage/AdapterAlreadyExistsHelper.java .
    AdapterNonExistentHelper
    org/omg/PortableServer/POAPackage/AdapterNonExistentHelper.java .
    InvalidPolicyHelper
    org/omg/PortableServer/POAPackage/InvalidPolicyHelper.java .
    NoServantHelper
    org/omg/PortableServer/POAPackage/NoServantHelper.java .
    ObjectAlreadyActiveHelper
    org/omg/PortableServer/POAPackage/ObjectAlreadyActiveHelper.java .
    ObjectNotActiveHelper
    org/omg/PortableServer/POAPackage/ObjectNotActiveHelper.java .
    ServantAlreadyActiveHelper
    org/omg/PortableServer/POAPackage/ServantAlreadyActiveHelper.java .
    ServantNotActiveHelper
    org/omg/PortableServer/POAPackage/ServantNotActiveHelper.java .
    WrongAdapterHelper
    org/omg/PortableServer/POAPackage/WrongAdapterHelper.java .
    WrongPolicyHelper
    org/omg/PortableServer/POAPackage/WrongPolicyHelper.java .
  • Exception Summary
    Exception Description
    AdapterAlreadyExists
    org/omg/PortableServer/POAPackage/AdapterAlreadyExists.java .
    AdapterNonExistent
    org/omg/PortableServer/POAPackage/AdapterNonExistent.java .
    InvalidPolicy
    org/omg/PortableServer/POAPackage/InvalidPolicy.java .
    NoServant
    org/omg/PortableServer/POAPackage/NoServant.java .
    ObjectAlreadyActive
    org/omg/PortableServer/POAPackage/ObjectAlreadyActive.java .
    ObjectNotActive
    org/omg/PortableServer/POAPackage/ObjectNotActive.java .
    ServantAlreadyActive
    org/omg/PortableServer/POAPackage/ServantAlreadyActive.java .
    ServantNotActive
    org/omg/PortableServer/POAPackage/ServantNotActive.java .
    WrongAdapter
    org/omg/PortableServer/POAPackage/WrongAdapter.java .
    WrongPolicy
    org/omg/PortableServer/POAPackage/WrongPolicy.java .

Package org.omg.PortableServer.POAPackage Description

Allows programmers to construct object implementations that are portable between different ORB products.

The Portable Object Adaptor (POA) is designed to meet the following goals:

  • Allow programmers to construct object implementations that are portable between different ORB products.
  • Provide support for objects with persistent identities.
  • Provide support for transparent activation of objects.
  • Allow a single servant to support multiple object identities simultaneously.

Given an interface My defined in My.idl, the file MyPOA.java is generated by the idlj compiler. You must provide the implementation for My and it must inherit from MyPOA.

MyPOA.java is a stream-based skeleton that extends org.omg.PortableServer.Servant and implements the InvokeHandler interface and the operations interface associated with the IDL interface the skeleton implements.

The PortableServer module for the Portable Object Adapter (POA) defines the native Servant type. In the Java programming language, the Servant type is mapped to the Java org.omg.PortableServer.Servant class. It serves as the base class for all POA servant implementations and provides a number of methods that may be invoked by the application programmer, as well as methods which are invoked by the POA itself and may be overridden by the user to control aspects of servant behavior.

All Mapping corresponds to the Chapter 11 of CORBA V2.3.1 specified by OMG document formal/99-10-07.pdf. The exception to this is the id attribute, which is added in ptc/00-08-06, section 11.3.8.26.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6, ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

Since:
1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames


org.omg.PortableServer.POAPackage Class Hierarchy (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.PortableServer.POAPackage

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper
    • org.omg.PortableServer.POAPackage.AdapterNonExistentHelper
    • org.omg.PortableServer.POAPackage.InvalidPolicyHelper
    • org.omg.PortableServer.POAPackage.NoServantHelper
    • org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper
    • org.omg.PortableServer.POAPackage.ObjectNotActiveHelper
    • org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper
    • org.omg.PortableServer.POAPackage.ServantNotActiveHelper
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.PortableServer.POAPackage.AdapterAlreadyExists
          • org.omg.PortableServer.POAPackage.AdapterNonExistent
          • org.omg.PortableServer.POAPackage.InvalidPolicy
          • org.omg.PortableServer.POAPackage.NoServant
          • org.omg.PortableServer.POAPackage.ObjectAlreadyActive
          • org.omg.PortableServer.POAPackage.ObjectNotActive
          • org.omg.PortableServer.POAPackage.ServantAlreadyActive
          • org.omg.PortableServer.POAPackage.ServantNotActive
          • org.omg.PortableServer.POAPackage.WrongAdapter
          • org.omg.PortableServer.POAPackage.WrongPolicy
    • org.omg.PortableServer.POAPackage.WrongAdapterHelper
    • org.omg.PortableServer.POAPackage.WrongPolicyHelper
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package org.omg.PortableServer.POAPackage (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.PortableServer.POAPackage

  • Packages that use org.omg.PortableServer.POAPackage
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
    org.omg.PortableServer.POAPackage
    Allows programmers to construct object implementations that are portable between different ORB products.
  • Classes in org.omg.PortableServer.POAPackage used by org.omg.PortableServer
    Class and Description
    AdapterAlreadyExists
    org/omg/PortableServer/POAPackage/AdapterAlreadyExists.java .
    AdapterNonExistent
    org/omg/PortableServer/POAPackage/AdapterNonExistent.java .
    InvalidPolicy
    org/omg/PortableServer/POAPackage/InvalidPolicy.java .
    NoServant
    org/omg/PortableServer/POAPackage/NoServant.java .
    ObjectAlreadyActive
    org/omg/PortableServer/POAPackage/ObjectAlreadyActive.java .
    ObjectNotActive
    org/omg/PortableServer/POAPackage/ObjectNotActive.java .
    ServantAlreadyActive
    org/omg/PortableServer/POAPackage/ServantAlreadyActive.java .
    ServantNotActive
    org/omg/PortableServer/POAPackage/ServantNotActive.java .
    WrongAdapter
    org/omg/PortableServer/POAPackage/WrongAdapter.java .
    WrongPolicy
    org/omg/PortableServer/POAPackage/WrongPolicy.java .
  • Classes in org.omg.PortableServer.POAPackage used by org.omg.PortableServer.POAPackage
    Class and Description
    AdapterAlreadyExists
    org/omg/PortableServer/POAPackage/AdapterAlreadyExists.java .
    AdapterNonExistent
    org/omg/PortableServer/POAPackage/AdapterNonExistent.java .
    InvalidPolicy
    org/omg/PortableServer/POAPackage/InvalidPolicy.java .
    NoServant
    org/omg/PortableServer/POAPackage/NoServant.java .
    ObjectAlreadyActive
    org/omg/PortableServer/POAPackage/ObjectAlreadyActive.java .
    ObjectNotActive
    org/omg/PortableServer/POAPackage/ObjectNotActive.java .
    ServantAlreadyActive
    org/omg/PortableServer/POAPackage/ServantAlreadyActive.java .
    ServantNotActive
    org/omg/PortableServer/POAPackage/ServantNotActive.java .
    WrongAdapter
    org/omg/PortableServer/POAPackage/WrongAdapter.java .
    WrongPolicy
    org/omg/PortableServer/POAPackage/WrongPolicy.java .
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


ServantAlreadyActive (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class ServantAlreadyActive

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.POAPackage.ServantAlreadyActive
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class ServantAlreadyActive
extends UserException
    org/omg/PortableServer/POAPackage/ServantAlreadyActive.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableServer/poa.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      ServantAlreadyActive()
      ServantAlreadyActive(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ServantAlreadyActive

        public ServantAlreadyActive()

      • ServantAlreadyActive

        public ServantAlreadyActive(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServantAlreadyActiveHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class ServantAlreadyActiveHelper

  • java.lang.Object
    • org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper

  • public abstract class ServantAlreadyActiveHelper
extends Object
    org/omg/PortableServer/POAPackage/ServantAlreadyActiveHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableServer/poa.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      ServantAlreadyActiveHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static ServantAlreadyActive | extract(Any a)
      static String | id()
      static void | insert(Any a, ServantAlreadyActive that)
      static ServantAlreadyActive | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, ServantAlreadyActive value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ServantAlreadyActiveHelper

        public ServantAlreadyActiveHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          ServantAlreadyActive that)

      • extract

        public static ServantAlreadyActive extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ServantAlreadyActive read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         ServantAlreadyActive value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServantNotActive (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class ServantNotActive

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.POAPackage.ServantNotActive
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class ServantNotActive
extends UserException
    org/omg/PortableServer/POAPackage/ServantNotActive.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableServer/poa.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      ServantNotActive()
      ServantNotActive(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • ServantNotActive

        public ServantNotActive()

      • ServantNotActive

        public ServantNotActive(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServantNotActiveHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class ServantNotActiveHelper

  • java.lang.Object
    • org.omg.PortableServer.POAPackage.ServantNotActiveHelper

  • public abstract class ServantNotActiveHelper
extends Object
    org/omg/PortableServer/POAPackage/ServantNotActiveHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableServer/poa.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      ServantNotActiveHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static ServantNotActive | extract(Any a)
      static String | id()
      static void | insert(Any a, ServantNotActive that)
      static ServantNotActive | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, ServantNotActive value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ServantNotActiveHelper

        public ServantNotActiveHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          ServantNotActive that)

      • extract

        public static ServantNotActive extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ServantNotActive read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         ServantNotActive value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


WrongAdapter (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class WrongAdapter

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.POAPackage.WrongAdapter
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class WrongAdapter
extends UserException
    org/omg/PortableServer/POAPackage/WrongAdapter.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableServer/poa.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      WrongAdapter()
      WrongAdapter(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • WrongAdapter

        public WrongAdapter()

      • WrongAdapter

        public WrongAdapter(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


WrongAdapterHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class WrongAdapterHelper

  • java.lang.Object
    • org.omg.PortableServer.POAPackage.WrongAdapterHelper

  • public abstract class WrongAdapterHelper
extends Object
    org/omg/PortableServer/POAPackage/WrongAdapterHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableServer/poa.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      WrongAdapterHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static WrongAdapter | extract(Any a)
      static String | id()
      static void | insert(Any a, WrongAdapter that)
      static WrongAdapter | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, WrongAdapter value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • WrongAdapterHelper

        public WrongAdapterHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          WrongAdapter that)

      • extract

        public static WrongAdapter extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static WrongAdapter read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         WrongAdapter value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


WrongPolicy (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class WrongPolicy

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.omg.CORBA.UserException
          • org.omg.PortableServer.POAPackage.WrongPolicy
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public final class WrongPolicy
extends UserException
    org/omg/PortableServer/POAPackage/WrongPolicy.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableServer/poa.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      WrongPolicy()
      WrongPolicy(String $reason)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • WrongPolicy

        public WrongPolicy()

      • WrongPolicy

        public WrongPolicy(String $reason)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


WrongPolicyHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.POAPackage

Class WrongPolicyHelper

  • java.lang.Object
    • org.omg.PortableServer.POAPackage.WrongPolicyHelper

  • public abstract class WrongPolicyHelper
extends Object
    org/omg/PortableServer/POAPackage/WrongPolicyHelper.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableServer/poa.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Constructor Summary

      Constructors
      Constructor and Description
      WrongPolicyHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static WrongPolicy | extract(Any a)
      static String | id()
      static void | insert(Any a, WrongPolicy that)
      static WrongPolicy | read(InputStream istream)
      static TypeCode | type()
      static void | write(OutputStream ostream, WrongPolicy value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • WrongPolicyHelper

        public WrongPolicyHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          WrongPolicy that)

      • extract

        public static WrongPolicy extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static WrongPolicy read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         WrongPolicy value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Interface org.omg.PortableServer.portable.Delegate (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.PortableServer.portable.Delegate

  • Packages that use Delegate
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of Delegate in org.omg.PortableServer

      Methods in org.omg.PortableServer that return Delegate
      Modifier and Type Method and Description
      Delegate Servant._get_delegate()
      Gets the ORB vendor-specific implementation of PortableServer::Servant.
      Methods in org.omg.PortableServer with parameters of type Delegate
      Modifier and Type Method and Description
      void Servant._set_delegate(Delegate delegate)
      Supports the Java ORB portability interfaces by providing a method for classes that support ORB portability through delegation to set their delegate.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Delegate (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.portable

Interface Delegate

  • public interface Delegate
    The portability package contains interfaces and classes that are designed for and intended to be used by ORB implementor. It exposes the publicly defined APIs that are used to connect stubs and skeletons to the ORB. The Delegate interface provides the ORB vendor specific implementation of PortableServer::Servant. Conformant to spec CORBA V2.3.1, ptc/00-01-08.pdf

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      POA default_POA(Servant Self)
      The default behavior of this function is to return the root POA from the ORB instance associated with the servant.
      Object get_interface_def(Servant self)
      This operation returns an object in the Interface Repository which provides type information that may be useful to a program.
      boolean is_a(Servant Self, String Repository_Id)
      This method checks to see if the specified repid is present on the list returned by _all_interfaces() or is the repository id for the generic CORBA Object.
      boolean non_existent(Servant Self)
      This operation is used to check for the existence of the Object.
      byte[] object_id(Servant Self)
      The method _object_id() is equivalent to calling PortableServer::Current::get_object_id.
      ORB orb(Servant Self)
      Convenience method that returns the instance of the ORB currently associated with the Servant.
      POA poa(Servant Self)
      The method _poa() is equivalent to calling PortableServer::Current:get_POA.
      Object this_object(Servant Self)
      This allows the servant to obtain the object reference for the target CORBA Object it is incarnating for that request.

    • Method Detail

      • orb

        ORB orb(Servant Self)
        Convenience method that returns the instance of the ORB currently associated with the Servant.
        Parameters:
        Self - the servant.
        Returns:
        ORB associated with the Servant.

      • this_object

        Object this_object(Servant Self)
        This allows the servant to obtain the object reference for the target CORBA Object it is incarnating for that request.
        Parameters:
        Self - the servant.
        Returns:
        Object reference associated with the request.

      • poa

        POA poa(Servant Self)
        The method _poa() is equivalent to calling PortableServer::Current:get_POA.
        Parameters:
        Self - the servant.
        Returns:
        POA associated with the servant.

      • object_id

        byte[] object_id(Servant Self)
        The method _object_id() is equivalent to calling PortableServer::Current::get_object_id.
        Parameters:
        Self - the servant.
        Returns:
        ObjectId associated with this servant.

      • default_POA

        POA default_POA(Servant Self)
        The default behavior of this function is to return the root POA from the ORB instance associated with the servant.
        Parameters:
        Self - the servant.
        Returns:
        POA associated with the servant class.

      • is_a

        boolean is_a(Servant Self,
             String Repository_Id)
        This method checks to see if the specified repid is present on the list returned by _all_interfaces() or is the repository id for the generic CORBA Object.
        Parameters:
        Self - the servant.
        Repository_Id - the repository_id to be checked in the repository list or against the id of generic CORBA object.
        Returns:
        boolean indicating whether the specified repid is in the list or is same as that got generic CORBA object.

      • non_existent

        boolean non_existent(Servant Self)
        This operation is used to check for the existence of the Object.
        Parameters:
        Self - the servant.
        Returns:
        boolean true to indicate that object does not exist, and false otherwise.

      • get_interface_def

        Object get_interface_def(Servant self)
        This operation returns an object in the Interface Repository which provides type information that may be useful to a program.
        Parameters:
        self - the servant.
        Returns:
        type information corresponding to the object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


org.omg.PortableServer.portable (Java Platform SE 8 )

org.omg.PortableServer.portable

Interfaces

  • Delegate


org.omg.PortableServer.portable (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.PortableServer.portable

Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

See: Description

  • Interface Summary
    Interface Description
    Delegate
    The portability package contains interfaces and classes that are designed for and intended to be used by ORB implementor.

Package org.omg.PortableServer.portable Description

Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

The portable package contains interfaces and classes that are designed for and intended to be used by an ORB implementor. It exposes the publicly defined APIs that are used to connect stubs and skeletons to the ORB. The Delegate interface provides the ORB-vendor-specific implementation of PortableServer::Servant. This package conforms CORBA Specification V2.3.1, ptc/00-01-08.

Since:
1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames


org.omg.PortableServer.portable Class Hierarchy (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.PortableServer.portable

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • org.omg.PortableServer.portable.Delegate
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package org.omg.PortableServer.portable (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.PortableServer.portable

  • Packages that use org.omg.PortableServer.portable
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
  • Classes in org.omg.PortableServer.portable used by org.omg.PortableServer
    Class and Description
    Delegate
    The portability package contains interfaces and classes that are designed for and intended to be used by ORB implementor.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


RequestProcessingPolicy (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface RequestProcessingPolicy

  • All Superinterfaces:
    IDLEntity, Object, Policy, PolicyOperations, RequestProcessingPolicyOperations, Serializable

    public interface RequestProcessingPolicy
extends RequestProcessingPolicyOperations, Policy, IDLEntity
    This policy specifies how requests are processed by the created POA. The default is USE_ACTIVE_OBJECT_MAP_ONLY.

    • Method Summary

      • Methods inherited from interface org.omg.PortableServer.RequestProcessingPolicyOperations

        value

      • Methods inherited from interface org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


RequestProcessingPolicyOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface RequestProcessingPolicyOperations

  • All Superinterfaces:
    PolicyOperations
    All Known Subinterfaces:
    RequestProcessingPolicy

    public interface RequestProcessingPolicyOperations
extends PolicyOperations
    This policy specifies how requests are processed by the created POA. The default is USE_ACTIVE_OBJECT_MAP_ONLY.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      RequestProcessingPolicyValue value()
      specifies the policy value

      • Methods inherited from interface org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

    • Method Detail

      • value

        RequestProcessingPolicyValue value()
        specifies the policy value
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


RequestProcessingPolicyValue (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Class RequestProcessingPolicyValue

  • java.lang.Object
    • org.omg.PortableServer.RequestProcessingPolicyValue
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public class RequestProcessingPolicyValue
extends Object
implements IDLEntity
    The RequestProcessingPolicyValue can have the following values. USE_ACTIVE_OBJECT_MAP_ONLY - If the Object Id is not found in the Active Object Map, an OBJECT_NOT_EXIST exception is returned to the client. The RETAIN policy is also required. USE_DEFAULT_SERVANT - If the Object Id is not found in the Active Object Map or the NON_RETAIN policy is present, and a default servant has been registered with the POA using the set_servant operation, the request is dispatched to the default servant. USE_SERVANT_MANAGER - If the Object Id is not found in the Active Object Map or the NON_RETAIN policy is present, and a servant manager has been registered with the POA using the set_servant_manager operation, the servant manager is given the opportunity to locate a servant or raise an exception.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static int | _USE_ACTIVE_OBJECT_MAP_ONLY
      static int | _USE_DEFAULT_SERVANT
      static int | _USE_SERVANT_MANAGER
      static RequestProcessingPolicyValue | USE_ACTIVE_OBJECT_MAP_ONLY
      static RequestProcessingPolicyValue | USE_DEFAULT_SERVANT
      static RequestProcessingPolicyValue | USE_SERVANT_MANAGER

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | RequestProcessingPolicyValue(int value)

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      static RequestProcessingPolicyValue | from_int(int value)
      int | value()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • _USE_ACTIVE_OBJECT_MAP_ONLY

        public static final int _USE_ACTIVE_OBJECT_MAP_ONLY
        See Also:
        Constant Field Values

      • USE_ACTIVE_OBJECT_MAP_ONLY

        public static final RequestProcessingPolicyValue USE_ACTIVE_OBJECT_MAP_ONLY

      • _USE_DEFAULT_SERVANT

        public static final int _USE_DEFAULT_SERVANT
        See Also:
        Constant Field Values

      • USE_DEFAULT_SERVANT

        public static final RequestProcessingPolicyValue USE_DEFAULT_SERVANT

      • _USE_SERVANT_MANAGER

        public static final int _USE_SERVANT_MANAGER
        See Also:
        Constant Field Values

      • USE_SERVANT_MANAGER

        public static final RequestProcessingPolicyValue USE_SERVANT_MANAGER

    • Constructor Detail

      • RequestProcessingPolicyValue

        protected RequestProcessingPolicyValue(int value)

    • Method Detail

      • value

        public int value()

      • from_int

        public static RequestProcessingPolicyValue from_int(int value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


REQUEST_PROCESSING_POLICY_ID (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface REQUEST_PROCESSING_POLICY_ID

  • public interface REQUEST_PROCESSING_POLICY_ID
    org/omg/PortableServer/REQUEST_PROCESSING_POLICY_ID.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableServer/poa.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      The value representing REQUEST_PROCESSING_POLICY_ID.

    • Field Detail

      • value

        static final int value
        The value representing REQUEST_PROCESSING_POLICY_ID.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Servant (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Class Servant

  • java.lang.Object
    • org.omg.PortableServer.Servant
  • Direct Known Subclasses:
    BindingIteratorPOA, DynamicImplementation, NamingContextExtPOA, NamingContextPOA, ServantActivatorPOA, ServantLocatorPOA

    public abstract class Servant
extends Object
    Defines the native Servant type. In Java, the Servant type is mapped to the Java org.omg.PortableServer.Servant class. It serves as the base class for all POA servant implementations and provides a number of methods that may be invoked by the application programmer, as well as methods which are invoked by the POA itself and may be overridden by the user to control aspects of servant behavior. Based on IDL to Java spec. (CORBA V2.3.1) ptc/00-01-08.pdf.

    • Constructor Summary

      Constructors
      Constructor and Description
      Servant()

    • Method Summary

      All Methods Instance Methods Abstract Methods Concrete Methods
      Modifier and Type Method and Description
      abstract String[] _all_interfaces(POA poa, byte[] objectId)
      Used by the ORB to obtain complete type information from the servant.
      POA _default_POA()
      Returns the root POA from the ORB instance associated with the servant.
      Delegate _get_delegate()
      Gets the ORB vendor-specific implementation of PortableServer::Servant.
      Object _get_interface_def()
      Returns an InterfaceDef object as a CORBA::Object that defines the runtime type of the CORBA::Object implemented by the Servant.
      boolean _is_a(String repository_id)
      Checks to see if the specified repository_id is present on the list returned by _all_interfaces() or is the repository_id for the generic CORBA Object.
      boolean _non_existent()
      Checks for the existence of an Object.
      byte[] _object_id()
      Allows easy execution of common methods, equivalent to calling PortableServer::Current::get_object_id.
      ORB _orb()
      Returns the instance of the ORB currently associated with the Servant (convenience method).
      POA _poa()
      Allows easy execution of common methods, equivalent to PortableServer::Current:get_POA.
      void _set_delegate(Delegate delegate)
      Supports the Java ORB portability interfaces by providing a method for classes that support ORB portability through delegation to set their delegate.
      Object _this_object()
      Allows the servant to obtain the object reference for the target CORBA object it is incarnating for that request.
      Object _this_object(ORB orb)
      Allows the servant to obtain the object reference for the target CORBA Object it is incarnating for that request.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • Servant

        public Servant()

    • Method Detail

      • _get_delegate

        public final Delegate _get_delegate()
        Gets the ORB vendor-specific implementation of PortableServer::Servant.
        Returns:
        _delegate the ORB vendor-specific implementation of PortableServer::Servant.

      • _set_delegate

        public final void _set_delegate(Delegate delegate)
        Supports the Java ORB portability interfaces by providing a method for classes that support ORB portability through delegation to set their delegate.
        Parameters:
        delegate - ORB vendor-specific implementation of the PortableServer::Servant.

      • _this_object

        public final Object _this_object()
        Allows the servant to obtain the object reference for the target CORBA object it is incarnating for that request.
        Returns:
        this_object Object reference associated with the request.

      • _this_object

        public final Object _this_object(ORB orb)
        Allows the servant to obtain the object reference for the target CORBA Object it is incarnating for that request.
        Parameters:
        orb - ORB with which the servant is associated.
        Returns:
        _this_object reference associated with the request.

      • _orb

        public final ORB _orb()
        Returns the instance of the ORB currently associated with the Servant (convenience method).
        Returns:
        orb the instance of the ORB currently associated with the Servant.

      • _poa

        public final POA _poa()
        Allows easy execution of common methods, equivalent to PortableServer::Current:get_POA.
        Returns:
        poa POA associated with the servant.

      • _object_id

        public final byte[] _object_id()
        Allows easy execution of common methods, equivalent to calling PortableServer::Current::get_object_id.
        Returns:
        object_id the Object ID associated with this servant.

      • _default_POA

        public POA _default_POA()
        Returns the root POA from the ORB instance associated with the servant. Subclasses may override this method to return a different POA.
        Returns:
        default_POA the POA associated with the Servant.

      • _is_a

        public boolean _is_a(String repository_id)
        Checks to see if the specified repository_id is present on the list returned by _all_interfaces() or is the repository_id for the generic CORBA Object.
        Parameters:
        repository_id - the repository_id to be checked in the repository list or against the id of generic CORBA objects.
        Returns:
        is_a boolean indicating whether the specified repository_id is in the repository list or is same as a generic CORBA object.

      • _non_existent

        public boolean _non_existent()
        Checks for the existence of an Object. The Servant provides a default implementation of _non_existent() that can be overridden by derived servants.
        Returns:
        non_existent true if that object does not exist, false otherwise.

      • _get_interface_def

        public Object _get_interface_def()
        Returns an InterfaceDef object as a CORBA::Object that defines the runtime type of the CORBA::Object implemented by the Servant. The invoker of _get_interface_def must narrow the result to an InterfaceDef in order to use it.

        This default implementation of _get_interface_def() can be overridden by derived servants if the default behavior is not adequate. As defined in the CORBA 2.3.1 specification, section 11.3.1, the default behavior of _get_interface_def() is to use the most derived interface of a static servant or the most derived interface retrieved from a dynamic servant to obtain the InterfaceDef. This behavior must be supported by the Delegate that implements the Servant.

        Returns:
        get_interface_def an InterfaceDef object as a CORBA::Object that defines the runtime type of the CORBA::Object implemented by the Servant.

      • _all_interfaces

        public abstract String[] _all_interfaces(POA poa,
                                         byte[] objectId)
        Used by the ORB to obtain complete type information from the servant.
        Parameters:
        poa - POA with which the servant is associated.
        objectId - is the id corresponding to the object associated with this servant.
        Returns:
        list of type information for the object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServantActivator (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface ServantActivator

  • All Superinterfaces:
    IDLEntity, Object, Serializable, ServantActivatorOperations, ServantManager, ServantManagerOperations
    All Known Implementing Classes:
    _ServantActivatorStub

    public interface ServantActivator
extends ServantActivatorOperations, ServantManager, IDLEntity
    When the POA has the RETAIN policy it uses servant managers that are ServantActivators.

    • Method Summary

      • Methods inherited from interface org.omg.PortableServer.ServantActivatorOperations

        etherealize, incarnate

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServantActivatorHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Class ServantActivatorHelper

  • java.lang.Object
    • org.omg.PortableServer.ServantActivatorHelper

  • public abstract class ServantActivatorHelper
extends Object
    When the POA has the RETAIN policy it uses servant managers that are ServantActivators.

    • Constructor Summary

      Constructors
      Constructor and Description
      ServantActivatorHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static ServantActivator | extract(Any a)
      static String | id()
      static void | insert(Any a, ServantActivator that)
      static ServantActivator | narrow(Object obj)
      static ServantActivator | read(InputStream istream)
      static TypeCode | type()
      static ServantActivator | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, ServantActivator value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ServantActivatorHelper

        public ServantActivatorHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          ServantActivator that)

      • extract

        public static ServantActivator extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ServantActivator read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         ServantActivator value)

      • narrow

        public static ServantActivator narrow(Object obj)

      • unchecked_narrow

        public static ServantActivator unchecked_narrow(Object obj)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServantActivatorOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface ServantActivatorOperations

  • All Superinterfaces:
    ServantManagerOperations
    All Known Subinterfaces:
    ServantActivator
    All Known Implementing Classes:
    _ServantActivatorStub, ServantActivatorPOA

    public interface ServantActivatorOperations
extends ServantManagerOperations
    When the POA has the RETAIN policy it uses servant managers that are ServantActivators.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void etherealize(byte[] oid, POA adapter, Servant serv, boolean cleanup_in_progress, boolean remaining_activations)
      This operation is invoked whenever a servant for an object is deactivated, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
      Servant incarnate(byte[] oid, POA adapter)
      This operation is invoked by the POA whenever the POA receives a request for an object that is not currently active, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.

    • Method Detail

      • incarnate

        Servant incarnate(byte[] oid,
                  POA adapter)
           throws ForwardRequest
        This operation is invoked by the POA whenever the POA receives a request for an object that is not currently active, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
        Parameters:
        oid - object Id associated with the object on the request was made.
        adapter - object reference for the POA in which the object is being activated.
        Returns:
        Servant corresponding to oid is created or located by the user supplied servant manager.
        Throws:
        ForwardRequest - to indicate to the ORB that it is responsible for delivering the current request and subsequent requests to the object denoted in the forward_reference member of the exception.

      • etherealize

        void etherealize(byte[] oid,
                 POA adapter,
                 Servant serv,
                 boolean cleanup_in_progress,
                 boolean remaining_activations)
        This operation is invoked whenever a servant for an object is deactivated, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
        Parameters:
        oid - object Id associated with the object being deactivated.
        adapter - object reference for the POA in which the object was active.
        serv - contains reference to the servant associated with the object being deactivated.
        cleanup_in_progress - if TRUE indicates that destroy or deactivate is called with etherealize_objects param of TRUE. FALSE indicates that etherealize was called due to other reasons.
        remaining_activations - indicates whether the Servant Manager can destroy a servant. If set to TRUE, the Servant Manager should wait until all invocations in progress have completed.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServantActivatorPOA (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Class ServantActivatorPOA

  • java.lang.Object
    • org.omg.PortableServer.Servant
      • org.omg.PortableServer.ServantActivatorPOA
  • All Implemented Interfaces:
    InvokeHandler, ServantActivatorOperations, ServantManagerOperations

    public abstract class ServantActivatorPOA
extends Servant
implements ServantActivatorOperations, InvokeHandler
    When the POA has the RETAIN policy it uses servant managers that are ServantActivators.

    • Constructor Summary

      Constructors
      Constructor and Description
      ServantActivatorPOA()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      String[] _all_interfaces(POA poa, byte[] objectId)
      Used by the ORB to obtain complete type information from the servant.
      OutputStream _invoke(String $method, InputStream in, ResponseHandler $rh)
      Invoked by the ORB to dispatch a request to the servant.
      ServantActivator _this()
      ServantActivator | _this(ORB orb)

      • Methods inherited from class org.omg.PortableServer.Servant

        _default_POA, _get_delegate, _get_interface_def, _is_a, _non_existent, _object_id, _orb, _poa, _set_delegate, _this_object, _this_object

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface org.omg.PortableServer.ServantActivatorOperations

        etherealize, incarnate

    • Constructor Detail

      • ServantActivatorPOA

        public ServantActivatorPOA()

    • Method Detail

      • _invoke

        public OutputStream _invoke(String $method,
                            InputStream in,
                            ResponseHandler $rh)
        Description copied from interface: InvokeHandler
        Invoked by the ORB to dispatch a request to the servant. ORB passes the method name, an InputStream containing the marshalled arguments, and a ResponseHandler which the servant uses to construct a proper reply. Only CORBA SystemException may be thrown by this method. The method must return an OutputStream created by the ResponseHandler which contains the marshalled reply. A servant must not retain a reference to the ResponseHandler beyond the lifetime of a method invocation. Servant behaviour is defined as follows:

        1. Determine correct method, and unmarshal parameters from InputStream.

        2. Invoke method implementation.

        3. If no user exception, create a normal reply using ResponseHandler.

        4. If user exception occurred, create exception reply using ResponseHandler.

        5. Marshal reply into OutputStream returned by ResponseHandler.

        6. Return OutputStream to ORB.

        Specified by:
        _invoke in interface InvokeHandler
        Parameters:
        $method - The method name.
        in - The InputStream containing the marshalled arguments.
        $rh - The ResponseHandler which the servant uses to construct a proper reply
        Returns:
        The OutputStream created by the ResponseHandler which contains the marshalled reply

      • _all_interfaces

        public String[] _all_interfaces(POA poa,
                                byte[] objectId)
        Description copied from class: Servant
        Used by the ORB to obtain complete type information from the servant.
        Specified by:
        _all_interfaces in class Servant
        Parameters:
        poa - POA with which the servant is associated.
        objectId - is the id corresponding to the object associated with this servant.
        Returns:
        list of type information for the object.

      • _this

        public ServantActivator _this()

      • _this

        public ServantActivator _this(ORB orb)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServantLocator (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface ServantLocator

  • All Superinterfaces:
    IDLEntity, Object, Serializable, ServantLocatorOperations, ServantManager, ServantManagerOperations
    All Known Implementing Classes:
    _ServantLocatorStub

    public interface ServantLocator
extends ServantLocatorOperations, ServantManager, IDLEntity
    When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators. Because the POA knows that the servant returned by this servant manager will be used only for a single request, it can supply extra information to the servant manager's operations and the servant manager's pair of operations may be able to cooperate to do something different than a ServantActivator. When the POA uses the ServantLocator interface, immediately after performing the operation invocation on the servant returned by preinvoke, the POA will invoke postinvoke on the servant manager, passing the ObjectId value and the Servant value as parameters (among others). This feature may be used to force every request for objects associated with a POA to be mediated by the servant manager.

    • Method Summary

      • Methods inherited from interface org.omg.PortableServer.ServantLocatorOperations

        postinvoke, preinvoke

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServantLocatorHelper (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Class ServantLocatorHelper

  • java.lang.Object
    • org.omg.PortableServer.ServantLocatorHelper

  • public abstract class ServantLocatorHelper
extends Object
    When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators. Because the POA knows that the servant returned by this servant manager will be used only for a single request, it can supply extra information to the servant manager's operations and the servant manager's pair of operations may be able to cooperate to do something different than a ServantActivator. When the POA uses the ServantLocator interface, immediately after performing the operation invocation on the servant returned by preinvoke, the POA will invoke postinvoke on the servant manager, passing the ObjectId value and the Servant value as parameters (among others). This feature may be used to force every request for objects associated with a POA to be mediated by the servant manager.

    • Constructor Summary

      Constructors
      Constructor and Description
      ServantLocatorHelper()

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type | Method and Description
      static ServantLocator | extract(Any a)
      static String | id()
      static void | insert(Any a, ServantLocator that)
      static ServantLocator | narrow(Object obj)
      static ServantLocator | read(InputStream istream)
      static TypeCode | type()
      static ServantLocator | unchecked_narrow(Object obj)
      static void | write(OutputStream ostream, ServantLocator value)

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ServantLocatorHelper

        public ServantLocatorHelper()

    • Method Detail

      • insert

        public static void insert(Any a,
                          ServantLocator that)

      • extract

        public static ServantLocator extract(Any a)

      • type

        public static TypeCode type()

      • id

        public static String id()

      • read

        public static ServantLocator read(InputStream istream)

      • write

        public static void write(OutputStream ostream,
                         ServantLocator value)

      • narrow

        public static ServantLocator narrow(Object obj)

      • unchecked_narrow

        public static ServantLocator unchecked_narrow(Object obj)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServantLocatorOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface ServantLocatorOperations

  • All Superinterfaces:
    ServantManagerOperations
    All Known Subinterfaces:
    ServantLocator
    All Known Implementing Classes:
    _ServantLocatorStub, ServantLocatorPOA

    public interface ServantLocatorOperations
extends ServantManagerOperations
    When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators. Because the POA knows that the servant returned by this servant manager will be used only for a single request, it can supply extra information to the servant manager's operations and the servant manager's pair of operations may be able to cooperate to do something different than a ServantActivator. When the POA uses the ServantLocator interface, immediately after performing the operation invocation on the servant returned by preinvoke, the POA will invoke postinvoke on the servant manager, passing the ObjectId value and the Servant value as parameters (among others). This feature may be used to force every request for objects associated with a POA to be mediated by the servant manager.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void postinvoke(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant)
      This operation is invoked whenener a servant completes a request.
      Servant preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie)
      This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.

    • Method Detail

      • preinvoke

        Servant preinvoke(byte[] oid,
                  POA adapter,
                  String operation,
                  CookieHolder the_cookie)
           throws ForwardRequest
        This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.
        Parameters:
        oid - the object id associated with object on which the request was made.
        adapter - the reference for POA in which the object is being activated.
        operation - the operation name.
        the_cookie - an opaque value that can be set by the servant manager to be used during postinvoke.
        Returns:
        Servant used to process incoming request.
        Throws:
        ForwardRequest - to indicate to the ORB that it is responsible for delivering the current request and subsequent requests to the object denoted in the forward_reference member of the exception.

      • postinvoke

        void postinvoke(byte[] oid,
                POA adapter,
                String operation,
                Object the_cookie,
                Servant the_servant)
        This operation is invoked whenener a servant completes a request.
        Parameters:
        oid - the object id ssociated with object on which the request was made.
        adapter - the reference for POA in which the object was active.
        the_cookie - an opaque value that contains the data set by preinvoke.
        the_servant - reference to the servant that is associated with the object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Class org.omg.PortableServer.ServantLocatorPackage.CookieHolder (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.PortableServer.ServantLocatorPackage.CookieHolder

  • Packages that use CookieHolder
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.

    • Uses of CookieHolder in org.omg.PortableServer

      Methods in org.omg.PortableServer with parameters of type CookieHolder
      Modifier and Type Method and Description
      Servant ServantLocatorOperations.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie)
      This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.
      Servant _ServantLocatorStub.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie)
      This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


CookieHolder (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer.ServantLocatorPackage

Class CookieHolder

  • java.lang.Object
    • org.omg.PortableServer.ServantLocatorPackage.CookieHolder
  • All Implemented Interfaces:
    Streamable

    public final class CookieHolder
extends Object
implements Streamable
    The native type PortableServer::ServantLocator::Cookie is mapped to java.lang.Object. A CookieHolder class is provided for passing the Cookie type as an out parameter. The CookieHolder class follows exactly the same pattern as the other holder classes for basic types.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      Object value

    • Constructor Summary

      Constructors
      Constructor and Description
      CookieHolder()
      CookieHolder(Object initial)

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void _read(InputStream is)
      Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
      TypeCode _type()
      Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
      void _write(OutputStream os)
      Marshals to ostream the value in the value field of the Holder.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • value

        public Object value

    • Constructor Detail

      • CookieHolder

        public CookieHolder()

      • CookieHolder

        public CookieHolder(Object initial)

    • Method Detail

      • _read

        public void _read(InputStream is)
        Description copied from interface: Streamable
        Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
        Specified by:
        _read in interface Streamable
        Parameters:
        is - the InputStream that represents the CDR data from the wire.

      • _write

        public void _write(OutputStream os)
        Description copied from interface: Streamable
        Marshals to ostream the value in the value field of the Holder.
        Specified by:
        _write in interface Streamable
        Parameters:
        os - the CDR OutputStream

      • _type

        public TypeCode _type()
        Description copied from interface: Streamable
        Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
        Specified by:
        _type in interface Streamable
        Returns:
        the TypeCode object for the value held in the holder
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


org.omg.PortableServer.ServantLocatorPackage (Java Platform SE 8 )

org.omg.PortableServer.ServantLocatorPackage

Classes

  • CookieHolder


org.omg.PortableServer.ServantLocatorPackage (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.PortableServer.ServantLocatorPackage

Provides classes and interfaces for locating the servant.

See: Description

  • Class Summary
    Class Description
    CookieHolder
    The native type PortableServer::ServantLocator::Cookie is mapped to java.lang.Object.

Package org.omg.PortableServer.ServantLocatorPackage Description

Provides classes and interfaces for locating the servant.

This package supplies a CookieHolder class for passing the Cookie type as an out parameter. The CookieHolder class follows exactly the same pattern as the other holder classes for basic types.

Package Specification

For a precise list of supported sections of official OMG specifications with which the Java[tm] Platform, Standard Edition 6 complies, see Official Specifications for CORBA support in Java[tm] SE 6.

Since:
1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames


org.omg.PortableServer.ServantLocatorPackage Class Hierarchy (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.PortableServer.ServantLocatorPackage

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.PortableServer.ServantLocatorPackage.CookieHolder (implements org.omg.CORBA.portable.Streamable)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package org.omg.PortableServer.ServantLocatorPackage (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.PortableServer.ServantLocatorPackage

  • Packages that use org.omg.PortableServer.ServantLocatorPackage
    Package Description
    org.omg.PortableServer
    Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
  • Classes in org.omg.PortableServer.ServantLocatorPackage used by org.omg.PortableServer
    Class and Description
    CookieHolder
    The native type PortableServer::ServantLocator::Cookie is mapped to java.lang.Object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


ServantLocatorPOA (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Class ServantLocatorPOA

  • java.lang.Object
    • org.omg.PortableServer.Servant
      • org.omg.PortableServer.ServantLocatorPOA
  • All Implemented Interfaces:
    InvokeHandler, ServantLocatorOperations, ServantManagerOperations

    public abstract class ServantLocatorPOA
extends Servant
implements ServantLocatorOperations, InvokeHandler
    When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators. Because the POA knows that the servant returned by this servant manager will be used only for a single request, it can supply extra information to the servant manager's operations and the servant manager's pair of operations may be able to cooperate to do something different than a ServantActivator. When the POA uses the ServantLocator interface, immediately after performing the operation invocation on the servant returned by preinvoke, the POA will invoke postinvoke on the servant manager, passing the ObjectId value and the Servant value as parameters (among others). This feature may be used to force every request for objects associated with a POA to be mediated by the servant manager.

    • Constructor Summary

      Constructors
      Constructor and Description
      ServantLocatorPOA()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      String[] _all_interfaces(POA poa, byte[] objectId)
      Used by the ORB to obtain complete type information from the servant.
      OutputStream _invoke(String $method, InputStream in, ResponseHandler $rh)
      Invoked by the ORB to dispatch a request to the servant.
      ServantLocator _this()
      ServantLocator | _this(ORB orb)

      • Methods inherited from class org.omg.PortableServer.Servant

        _default_POA, _get_delegate, _get_interface_def, _is_a, _non_existent, _object_id, _orb, _poa, _set_delegate, _this_object, _this_object

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface org.omg.PortableServer.ServantLocatorOperations

        postinvoke, preinvoke

    • Constructor Detail

      • ServantLocatorPOA

        public ServantLocatorPOA()

    • Method Detail

      • _invoke

        public OutputStream _invoke(String $method,
                            InputStream in,
                            ResponseHandler $rh)
        Description copied from interface: InvokeHandler
        Invoked by the ORB to dispatch a request to the servant. ORB passes the method name, an InputStream containing the marshalled arguments, and a ResponseHandler which the servant uses to construct a proper reply. Only CORBA SystemException may be thrown by this method. The method must return an OutputStream created by the ResponseHandler which contains the marshalled reply. A servant must not retain a reference to the ResponseHandler beyond the lifetime of a method invocation. Servant behaviour is defined as follows:

        1. Determine correct method, and unmarshal parameters from InputStream.

        2. Invoke method implementation.

        3. If no user exception, create a normal reply using ResponseHandler.

        4. If user exception occurred, create exception reply using ResponseHandler.

        5. Marshal reply into OutputStream returned by ResponseHandler.

        6. Return OutputStream to ORB.

        Specified by:
        _invoke in interface InvokeHandler
        Parameters:
        $method - The method name.
        in - The InputStream containing the marshalled arguments.
        $rh - The ResponseHandler which the servant uses to construct a proper reply
        Returns:
        The OutputStream created by the ResponseHandler which contains the marshalled reply

      • _all_interfaces

        public String[] _all_interfaces(POA poa,
                                byte[] objectId)
        Description copied from class: Servant
        Used by the ORB to obtain complete type information from the servant.
        Specified by:
        _all_interfaces in class Servant
        Parameters:
        poa - POA with which the servant is associated.
        objectId - is the id corresponding to the object associated with this servant.
        Returns:
        list of type information for the object.

      • _this

        public ServantLocator _this()

      • _this

        public ServantLocator _this(ORB orb)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServantManager (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface ServantManager

  • All Superinterfaces:
    IDLEntity, Object, Serializable, ServantManagerOperations
    All Known Subinterfaces:
    ServantActivator, ServantLocator
    All Known Implementing Classes:
    _ServantActivatorStub, _ServantLocatorStub

    public interface ServantManager
extends ServantManagerOperations, Object, IDLEntity
    A servant manager supplies a POA with the ability to activate objects on demand when the POA receives a request targeted at an inactive object. A servant manager is registered with a POA as a callback object, to be invoked by the POA when necessary. ServantManagers can either be ServantActivators or ServantLocators. A ServantManager object must be local to the process containing the POA objects it is registered with.

    • Method Summary

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServantManagerOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface ServantManagerOperations

  • All Known Subinterfaces:
    ServantActivator, ServantActivatorOperations, ServantLocator, ServantLocatorOperations, ServantManager
    All Known Implementing Classes:
    _ServantActivatorStub, _ServantLocatorStub, ServantActivatorPOA, ServantLocatorPOA

    public interface ServantManagerOperations
    A servant manager supplies a POA with the ability to activate objects on demand when the POA receives a request targeted at an inactive object. A servant manager is registered with a POA as a callback object, to be invoked by the POA when necessary. ServantManagers can either be ServantActivators or ServantLocators. A ServantManager object must be local to the process containing the POA objects it is registered with.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServantRetentionPolicy (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface ServantRetentionPolicy

  • All Superinterfaces:
    IDLEntity, Object, Policy, PolicyOperations, Serializable, ServantRetentionPolicyOperations

    public interface ServantRetentionPolicy
extends ServantRetentionPolicyOperations, Policy, IDLEntity
    This policy specifies whether the created POA retains active servants in an Active Object Map.

    • Method Summary

      • Methods inherited from interface org.omg.PortableServer.ServantRetentionPolicyOperations

        value

      • Methods inherited from interface org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServantRetentionPolicyOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface ServantRetentionPolicyOperations

  • All Superinterfaces:
    PolicyOperations
    All Known Subinterfaces:
    ServantRetentionPolicy

    public interface ServantRetentionPolicyOperations
extends PolicyOperations
    This policy specifies whether the created POA retains active servants in an Active Object Map.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      ServantRetentionPolicyValue value()
      specifies the policy value

      • Methods inherited from interface org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

    • Method Detail

      • value

        ServantRetentionPolicyValue value()
        specifies the policy value
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ServantRetentionPolicyValue (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Class ServantRetentionPolicyValue

  • java.lang.Object
    • org.omg.PortableServer.ServantRetentionPolicyValue
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public class ServantRetentionPolicyValue
extends Object
implements IDLEntity
    ServantRetentionPolicyValue can have the following values. RETAIN - to indicate that the POA will retain active servants in its Active Object Map. NON_RETAIN - to indicate Servants are not retained by the POA. If no ServantRetentionPolicy is specified at POA creation, the default is RETAIN.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static int | _NON_RETAIN
      static int | _RETAIN
      static ServantRetentionPolicyValue | NON_RETAIN
      static ServantRetentionPolicyValue | RETAIN

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | ServantRetentionPolicyValue(int value)

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      static ServantRetentionPolicyValue | from_int(int value)
      int | value()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • _RETAIN

        public static final int _RETAIN
        See Also:
        Constant Field Values

      • RETAIN

        public static final ServantRetentionPolicyValue RETAIN

      • _NON_RETAIN

        public static final int _NON_RETAIN
        See Also:
        Constant Field Values

      • NON_RETAIN

        public static final ServantRetentionPolicyValue NON_RETAIN

    • Constructor Detail

      • ServantRetentionPolicyValue

        protected ServantRetentionPolicyValue(int value)

    • Method Detail

      • value

        public int value()

      • from_int

        public static ServantRetentionPolicyValue from_int(int value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SERVANT_RETENTION_POLICY_ID (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface SERVANT_RETENTION_POLICY_ID

  • public interface SERVANT_RETENTION_POLICY_ID
    org/omg/PortableServer/SERVANT_RETENTION_POLICY_ID.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableServer/poa.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      The value representing SERVANT_RETENTION_POLICY_ID.

    • Field Detail

      • value

        static final int value
        The value representing SERVANT_RETENTION_POLICY_ID.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ThreadPolicy (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface ThreadPolicy

  • All Superinterfaces:
    IDLEntity, Object, Policy, PolicyOperations, Serializable, ThreadPolicyOperations

    public interface ThreadPolicy
extends ThreadPolicyOperations, Policy, IDLEntity
    The ThreadPolicy specifies the threading model used with the created POA. The default is ORB_CTRL_MODEL.

    • Method Summary

      • Methods inherited from interface org.omg.PortableServer.ThreadPolicyOperations

        value

      • Methods inherited from interface org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ThreadPolicyOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface ThreadPolicyOperations

  • All Superinterfaces:
    PolicyOperations
    All Known Subinterfaces:
    ThreadPolicy

    public interface ThreadPolicyOperations
extends PolicyOperations
    The ThreadPolicy specifies the threading model used with the created POA. The default is ORB_CTRL_MODEL.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      ThreadPolicyValue value()
      specifies the policy value

      • Methods inherited from interface org.omg.CORBA.PolicyOperations

        copy, destroy, policy_type

    • Method Detail

      • value

        ThreadPolicyValue value()
        specifies the policy value
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ThreadPolicyValue (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Class ThreadPolicyValue

  • java.lang.Object
    • org.omg.PortableServer.ThreadPolicyValue
  • All Implemented Interfaces:
    Serializable, IDLEntity

    public class ThreadPolicyValue
extends Object
implements IDLEntity
    The ThreadPolicyValue can have the following values. ORB_CTRL_MODEL - The ORB is responsible for assigning requests for an ORB- controlled POA to threads. SINGLE_THREAD_MODEL - Requests for a single-threaded POA are processed sequentially.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static int | _ORB_CTRL_MODEL
      static int | _SINGLE_THREAD_MODEL
      static ThreadPolicyValue | ORB_CTRL_MODEL
      static ThreadPolicyValue | SINGLE_THREAD_MODEL

    • Constructor Summary

      Constructors
      Modifier | Constructor and Description
      protected | ThreadPolicyValue(int value)

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type | Method and Description
      static ThreadPolicyValue | from_int(int value)
      int | value()

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • _ORB_CTRL_MODEL

        public static final int _ORB_CTRL_MODEL
        See Also:
        Constant Field Values

      • ORB_CTRL_MODEL

        public static final ThreadPolicyValue ORB_CTRL_MODEL

      • _SINGLE_THREAD_MODEL

        public static final int _SINGLE_THREAD_MODEL
        See Also:
        Constant Field Values

      • SINGLE_THREAD_MODEL

        public static final ThreadPolicyValue SINGLE_THREAD_MODEL

    • Constructor Detail

      • ThreadPolicyValue

        protected ThreadPolicyValue(int value)

    • Method Detail

      • value

        public int value()

      • from_int

        public static ThreadPolicyValue from_int(int value)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


THREAD_POLICY_ID (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Interface THREAD_POLICY_ID

  • public interface THREAD_POLICY_ID
    org/omg/PortableServer/THREAD_POLICY_ID.java . Generated by the IDL-to-Java compiler (portable), version "3.2" from /HUDSON/workspace/8-2-build-linux-amd64/jdk8u5/2488/corba/src/share/classes/org/omg/PortableServer/poa.idl Tuesday, March 18, 2014 12:30:01 AM PDT

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int value
      The value representing THREAD_POLICY_ID.

    • Field Detail

      • value

        static final int value
        The value representing THREAD_POLICY_ID.
        See Also:
        Constant Field Values
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


_ServantActivatorStub (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Class _ServantActivatorStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.PortableServer._ServantActivatorStub
  • All Implemented Interfaces:
    Serializable, Object, IDLEntity, ServantActivator, ServantActivatorOperations, ServantManager, ServantManagerOperations

    public class _ServantActivatorStub
extends ObjectImpl
implements ServantActivator
    When the POA has the RETAIN policy it uses servant managers that are ServantActivators.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static Class | _opsClass

    • Constructor Summary

      Constructors
      Constructor and Description
      _ServantActivatorStub()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void etherealize(byte[] oid, POA adapter, Servant serv, boolean cleanup_in_progress, boolean remaining_activations)
      This operation is invoked whenever a servant for an object is deactivated, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
      Servant incarnate(byte[] oid, POA adapter)
      This operation is invoked by the POA whenever the POA receives a request for an object that is not currently active, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.

      • Methods inherited from class org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • Field Detail

      • _opsClass

        public static final Class _opsClass

    • Constructor Detail

      • _ServantActivatorStub

        public _ServantActivatorStub()

    • Method Detail

      • incarnate

        public Servant incarnate(byte[] oid,
                         POA adapter)
                  throws ForwardRequest
        This operation is invoked by the POA whenever the POA receives a request for an object that is not currently active, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
        Specified by:
        incarnate in interface ServantActivatorOperations
        Parameters:
        oid - object Id associated with the object on the request was made.
        adapter - object reference for the POA in which the object is being activated.
        Returns:
        Servant corresponding to oid is created or located by the user supplied servant manager.
        Throws:
        ForwardRequest - to indicate to the ORB that it is responsible for delivering the current request and subsequent requests to the object denoted in the forward_reference member of the exception.

      • etherealize

        public void etherealize(byte[] oid,
                        POA adapter,
                        Servant serv,
                        boolean cleanup_in_progress,
                        boolean remaining_activations)
        This operation is invoked whenever a servant for an object is deactivated, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
        Specified by:
        etherealize in interface ServantActivatorOperations
        Parameters:
        oid - object Id associated with the object being deactivated.
        adapter - object reference for the POA in which the object was active.
        serv - contains reference to the servant associated with the object being deactivated.
        cleanup_in_progress - if TRUE indicates that destroy or deactivate is called with etherealize_objects param of TRUE. FALSE indicates that etherealize was called due to other reasons.
        remaining_activations - indicates whether the Servant Manager can destroy a servant. If set to TRUE, the Servant Manager should wait until all invocations in progress have completed.

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        Specified by:
        _ids in class ObjectImpl
        Returns:
        the array of all repository identifiers supported by this ObjectImpl instance
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


_ServantLocatorStub (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.PortableServer

Class _ServantLocatorStub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.PortableServer._ServantLocatorStub
  • All Implemented Interfaces:
    Serializable, Object, IDLEntity, ServantLocator, ServantLocatorOperations, ServantManager, ServantManagerOperations

    public class _ServantLocatorStub
extends ObjectImpl
implements ServantLocator
    When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators. Because the POA knows that the servant returned by this servant manager will be used only for a single request, it can supply extra information to the servant manager's operations and the servant manager's pair of operations may be able to cooperate to do something different than a ServantActivator. When the POA uses the ServantLocator interface, immediately after performing the operation invocation on the servant returned by preinvoke, the POA will invoke postinvoke on the servant manager, passing the ObjectId value and the Servant value as parameters (among others). This feature may be used to force every request for objects associated with a POA to be mediated by the servant manager.

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      static Class | _opsClass

    • Constructor Summary

      Constructors
      Constructor and Description
      _ServantLocatorStub()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String[] _ids()
      Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
      void postinvoke(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant)
      This operation is invoked whenener a servant completes a request.
      Servant preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie)
      This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.

      • Methods inherited from class org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override, equals, hashCode, toString

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override

    • Field Detail

      • _opsClass

        public static final Class _opsClass

    • Constructor Detail

      • _ServantLocatorStub

        public _ServantLocatorStub()

    • Method Detail

      • preinvoke

        public Servant preinvoke(byte[] oid,
                         POA adapter,
                         String operation,
                         CookieHolder the_cookie)
                  throws ForwardRequest
        This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.
        Specified by:
        preinvoke in interface ServantLocatorOperations
        Parameters:
        oid - the object id associated with object on which the request was made.
        adapter - the reference for POA in which the object is being activated.
        operation - the operation name.
        the_cookie - an opaque value that can be set by the servant manager to be used during postinvoke.
        Returns:
        Servant used to process incoming request.
        Throws:
        ForwardRequest - to indicate to the ORB that it is responsible for delivering the current request and subsequent requests to the object denoted in the forward_reference member of the exception.

      • postinvoke

        public void postinvoke(byte[] oid,
                       POA adapter,
                       String operation,
                       Object the_cookie,
                       Servant the_servant)
        This operation is invoked whenener a servant completes a request.
        Specified by:
        postinvoke in interface ServantLocatorOperations
        Parameters:
        oid - the object id ssociated with object on which the request was made.
        adapter - the reference for POA in which the object was active.
        the_cookie - an opaque value that contains the data set by preinvoke.
        the_servant - reference to the servant that is associated with the object.

      • _ids

        public String[] _ids()
        Description copied from class: ObjectImpl
        Retrieves a string array containing the repository identifiers supported by this ObjectImpl object. For example, for a stub, this method returns information about all the interfaces supported by the stub.
        Specified by:
        _ids in class ObjectImpl
        Returns:
        the array of all repository identifiers supported by this ObjectImpl instance
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Interface org.omg.SendingContext.RunTime (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.SendingContext.RunTime

  • Packages that use RunTime
    Package Description
    javax.rmi.CORBA
    Contains portability APIs for RMI-IIOP.

    • Uses of RunTime in javax.rmi.CORBA

      Methods in javax.rmi.CORBA that return RunTime
      Modifier and Type Method and Description
      RunTime ValueHandler.getRunTimeCodeBase()
      Returns the CodeBase for this ValueHandler.
      Methods in javax.rmi.CORBA with parameters of type RunTime
      Modifier and Type Method and Description
      Serializable ValueHandler.readValue(InputStream in, int offset, Class clz, String repositoryID, RunTime sender)
      Reads a value from the stream using Java semantics.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.omg.SendingContext.RunTimeOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.omg.SendingContext.RunTimeOperations

  • Packages that use RunTimeOperations
    Package Description
    org.omg.SendingContext
    Provides support for the marshalling of value types.

    • Uses of RunTimeOperations in org.omg.SendingContext

      Subinterfaces of RunTimeOperations in org.omg.SendingContext
      Modifier and Type Interface and Description
      interface  RunTime
      Defines the base class that represents the Sending Context of a request.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


org.omg.SendingContext (Java Platform SE 8 )

org.omg.SendingContext

Interfaces

  • RunTime
  • RunTimeOperations


org.omg.SendingContext (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.SendingContext

Provides support for the marshalling of value types.

See: Description

  • Interface Summary
    Interface Description
    RunTime
    Defines the base class that represents the Sending Context of a request.
    RunTimeOperations
    Defines operations on the base class that represents the Sending Context of a request.

Package org.omg.SendingContext Description

Provides support for the marshalling of value types. Value type marshalling may require access to an implementation of the value type or to meta information about the value type. This information is passed between the sending context and the receiving context using a particular service context containing an instance of the SendingContext.RunTime interface.

A sending context may be either the client side or the server side of an invocation, depending on which contains a value type. The sending context is the client side of an invocation if the request contains a value type. It is the server side if the reply contains a value type. The other party in the communication is the receiving context.

The service context marshalled for SendingContext consists of an encapsulated IOR for the SendingContext.RunTime interface. RunTime is just a marker interface defined to allow extensibility in the future. There is currently only one subinterface of RunTime defined: the SendingContext.CodeBase interface. The interface CodeBase defines operations to obtain code URLs and meta-information about a value type received from the sending context.

Note that these classes are currently defined in the com.sun.org.omg.SendingContext package rather than in the package org.omg.SendingContext. This has been done to avoid including large parts of the interface repository in the JDK core, since the interface repository is still evolving in response to the needs of the CORBA Components work.

Package Specification

For a precise list of supported sections of official specifications with which the Java[tm] Platform, Standard Edition 6 ORB complies, see Official Specifications for CORBA support in Java[tm] SE 6.

Since:
1.3
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames


org.omg.SendingContext Class Hierarchy (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.SendingContext

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • org.omg.CORBA.Object
    • org.omg.SendingContext.RunTime (also extends org.omg.CORBA.portable.IDLEntity, org.omg.SendingContext.RunTimeOperations)
  • org.omg.SendingContext.RunTimeOperations
    • org.omg.SendingContext.RunTime (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • java.io.Serializable
    • org.omg.CORBA.portable.IDLEntity
      • org.omg.SendingContext.RunTime (also extends org.omg.CORBA.Object, org.omg.SendingContext.RunTimeOperations)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package org.omg.SendingContext (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.SendingContext

  • Packages that use org.omg.SendingContext
    Package Description
    javax.rmi.CORBA
    Contains portability APIs for RMI-IIOP.
    org.omg.SendingContext
    Provides support for the marshalling of value types.
  • Classes in org.omg.SendingContext used by javax.rmi.CORBA
    Class and Description
    RunTime
    Defines the base class that represents the Sending Context of a request.
  • Classes in org.omg.SendingContext used by org.omg.SendingContext
    Class and Description
    RunTimeOperations
    Defines operations on the base class that represents the Sending Context of a request.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


RunTime (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.SendingContext

Interface RunTime

  • All Superinterfaces:
    IDLEntity, Object, RunTimeOperations, Serializable

    public interface RunTime
extends RunTimeOperations, Object, IDLEntity
    Defines the base class that represents the Sending Context of a request. The sending context provides access to information about the runtime environment of the originator of a GIOP message. For example, when a value type is marshalled on a GIOP Request message, the receiver of the value type may need to ask the sender about the CodeBase for the implementation of the value type.

    • Method Summary

      • Methods inherited from interface org.omg.CORBA.Object

        _create_request, _create_request, _duplicate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _is_a, _is_equivalent, _non_existent, _release, _request, _set_policy_override
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


RunTimeOperations (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.SendingContext

Interface RunTimeOperations

  • All Known Subinterfaces:
    RunTime

    public interface RunTimeOperations
    Defines operations on the base class that represents the Sending Context of a request. The sending context provides access to information about the runtime environment of the originator of a GIOP message. For example, when a value type is marshalled on a GIOP Request message, the receiver of the value type may need to ask the sender about the CodeBase for the implementation of the value type.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Class org.omg.stub.java.rmi._Remote_Stub (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.omg.stub.java.rmi._Remote_Stub

No usage of org.omg.stub.java.rmi._Remote_Stub
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


org.omg.stub.java.rmi (Java Platform SE 8 )

org.omg.stub.java.rmi

Classes

  • _Remote_Stub


org.omg.stub.java.rmi (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.omg.stub.java.rmi

Contains RMI-IIOP Stubs for the Remote types that occur in the java.rmi package.

See: Description

  • Class Summary
    Class Description
    _Remote_Stub
    This class provides the Stub for the Remote Type.

Package org.omg.stub.java.rmi Description

Contains RMI-IIOP Stubs for the Remote types that occur in the java.rmi package.

Since:
1.3
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames


org.omg.stub.java.rmi Class Hierarchy (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.omg.stub.java.rmi

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl (implements org.omg.CORBA.Object)
      • org.omg.CORBA_2_3.portable.ObjectImpl
        • javax.rmi.CORBA.Stub (implements java.io.Serializable)
          • org.omg.stub.java.rmi._Remote_Stub (implements java.rmi.Remote)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package org.omg.stub.java.rmi (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.omg.stub.java.rmi

No usage of org.omg.stub.java.rmi
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


_Remote_Stub (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
org.omg.stub.java.rmi

Class _Remote_Stub

  • java.lang.Object
    • org.omg.CORBA.portable.ObjectImpl
      • org.omg.CORBA_2_3.portable.ObjectImpl
        • javax.rmi.CORBA.Stub
          • org.omg.stub.java.rmi._Remote_Stub
  • All Implemented Interfaces:
    Serializable, Remote, Object

    public final class _Remote_Stub
extends Stub
implements Remote
    This class provides the Stub for the Remote Type. The class is generated by the rmic compiler, and is still under works at OMG. It's contents are subject to change without notice as the specification evolves.

    • Constructor Summary

      Constructors
      Constructor and Description
      _Remote_Stub()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String[] _ids()
      Returns an array of repository ids that an object implements.

      • Methods inherited from class javax.rmi.CORBA.Stub

        connect, equals, hashCode, toString

      • Methods inherited from class org.omg.CORBA_2_3.portable.ObjectImpl

        _get_codebase

      • Methods inherited from class org.omg.CORBA.portable.ObjectImpl

        _create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override

      • Methods inherited from class java.lang.Object

        clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • _Remote_Stub

        public _Remote_Stub()

    • Method Detail

      • _ids

        public String[] _ids()
        Returns an array of repository ids that an object implements. The string at index zero represents the most derived interface. The last id, for the generic CORBA object is (i.e., IDL:omg.org/CORBA/Object:1.0") is implied and not present.
        Specified by:
        _ids in class ObjectImpl
        Returns:
        an array of repository ids that an object implements.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Attr (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface Attr

  • All Superinterfaces:
    Node

    public interface Attr
extends Node
    The Attr interface represents an attribute in an Element object. Typically the allowable values for the attribute are defined in a schema associated with the document.

    Attr objects inherit the Node interface, but since they are not actually child nodes of the element they describe, the DOM does not consider them part of the document tree. Thus, the Node attributes parentNode, previousSibling, and nextSibling have a null value for Attr objects. The DOM takes the view that attributes are properties of elements rather than having a separate identity from the elements they are associated with; this should make it more efficient to implement such features as default attributes associated with all elements of a given type. Furthermore, Attr nodes may not be immediate children of a DocumentFragment. However, they can be associated with Element nodes contained within a DocumentFragment. In short, users and implementors of the DOM need to be aware that Attr nodes have some things in common with other objects inheriting the Node interface, but they also are quite distinct.

    The attribute's effective value is determined as follows: if this attribute has been explicitly assigned any value, that value is the attribute's effective value; otherwise, if there is a declaration for this attribute, and that declaration includes a default value, then that default value is the attribute's effective value; otherwise, the attribute does not exist on this element in the structure model until it has been explicitly added. Note that the Node.nodeValue attribute on the Attr instance can also be used to retrieve the string version of the attribute's value(s).

    If the attribute was not explicitly given a value in the instance document but has a default value provided by the schema associated with the document, an attribute node will be created with specified set to false. Removing attribute nodes for which a default value is defined in the schema generates a new attribute node with the default value and specified set to false. If validation occurred while invoking Document.normalizeDocument(), attribute nodes with specified equals to false are recomputed according to the default attribute values provided by the schema. If no default value is associate with this attribute in the schema, the attribute node is discarded.

    In XML, where the value of an attribute can contain entity references, the child nodes of the Attr node may be either Text or EntityReference nodes (when these are in use; see the description of EntityReference for discussion).

    The DOM Core represents all attribute values as simple strings, even if the DTD or schema associated with the document declares them of some specific type such as tokenized.

    The way attribute value normalization is performed by the DOM implementation depends on how much the implementation knows about the schema in use. Typically, the value and nodeValue attributes of an Attr node initially returns the normalized value given by the parser. It is also the case after Document.normalizeDocument() is called (assuming the right options have been set). But this may not be the case after mutation, independently of whether the mutation is performed by setting the string value directly or by changing the Attr child nodes. In particular, this is true when character references are involved, given that they are not represented in the DOM and they impact attribute value normalization. On the other hand, if the implementation knows about the schema in use when the attribute value is changed, and it is of a different type than CDATA, it may normalize it again at that time. This is especially true of specialized DOM implementations, such as SVG DOM implementations, which store attribute values in an internal form different from a string.

    The following table gives some examples of the relations between the attribute value in the original document (parsed attribute), the value as exposed in the DOM, and the serialization of the value:

    Examples Parsed attribute value Initial Attr.value Serialized attribute value
    Character reference
    "x&#178;=5"

    "x�=5"

    "x&#178;=5"
    Built-in character entity
    "y&lt;6"

    "y<6"

    "y&lt;6"
    Literal newline between
     "x=5&#10;y=6"

    "x=5 y=6"

    "x=5&#10;y=6"
    Normalized newline between
    "x=5
 y=6"

    "x=5 y=6"

    "x=5 y=6"
    Entity e with literal newline
     <!ENTITY e '...&#10;...'> [...]> "x=5&e;y=6"
             Dependent on Implementation and Load Options Dependent on Implementation and Load/Save Options

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getName()
      Returns the name of this attribute.
      Element getOwnerElement()
      The Element node this attribute is attached to or null if this attribute is not in use.
      TypeInfo getSchemaTypeInfo()
      The type information associated with this attribute.
      boolean getSpecified()
      True if this attribute was explicitly given a value in the instance document, false otherwise.
      String getValue()
      On retrieval, the value of the attribute is returned as a string.
      boolean isId()
      Returns whether this attribute is known to be of type ID (i.e.
      void setValue(String value)
      On retrieval, the value of the attribute is returned as a string.

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • Method Detail

      • getName

        String getName()
        Returns the name of this attribute. If Node.localName is different from null, this attribute is a qualified name.

      • getSpecified

        boolean getSpecified()
        True if this attribute was explicitly given a value in the instance document, false otherwise. If the application changed the value of this attribute node (even if it ends up having the same value as the default value) then it is set to true. The implementation may handle attributes with default values from other schemas similarly but applications should use Document.normalizeDocument() to guarantee this information is up-to-date.

      • getValue

        String getValue()
        On retrieval, the value of the attribute is returned as a string. Character and general entity references are replaced with their values. See also the method getAttribute on the Element interface.
        On setting, this creates a Text node with the unparsed contents of the string, i.e. any characters that an XML processor would recognize as markup are instead treated as literal text. See also the method Element.setAttribute().
        Some specialized implementations, such as some [SVG 1.1] implementations, may do normalization automatically, even after mutation; in such case, the value on retrieval may differ from the value on setting.

      • setValue

        void setValue(String value)
       throws DOMException
        On retrieval, the value of the attribute is returned as a string. Character and general entity references are replaced with their values. See also the method getAttribute on the Element interface.
        On setting, this creates a Text node with the unparsed contents of the string, i.e. any characters that an XML processor would recognize as markup are instead treated as literal text. See also the method Element.setAttribute().
        Some specialized implementations, such as some [SVG 1.1] implementations, may do normalization automatically, even after mutation; in such case, the value on retrieval may differ from the value on setting.
        Throws:
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised when the node is readonly.

      • getOwnerElement

        Element getOwnerElement()
        The Element node this attribute is attached to or null if this attribute is not in use.
        Since:
        DOM Level 2

      • getSchemaTypeInfo

        TypeInfo getSchemaTypeInfo()
        The type information associated with this attribute. While the type information contained in this attribute is guarantee to be correct after loading the document or invoking Document.normalizeDocument(), schemaTypeInfo may not be reliable if the node was moved.
        Since:
        DOM Level 3

      • isId

        boolean isId()
        Returns whether this attribute is known to be of type ID (i.e. to contain an identifier for its owner element) or not. When it is and its value is unique, the ownerElement of this attribute can be retrieved using the method Document.getElementById . The implementation could use several ways to determine if an attribute node is known to contain an identifier:
        • If validation occurred using an XML Schema [XML Schema Part 1] while loading the document or while invoking Document.normalizeDocument(), the post-schema-validation infoset contributions (PSVI contributions) values are used to determine if this attribute is a schema-determined ID attribute using the schema-determined ID definition in [XPointer] .
        • If validation occurred using a DTD while loading the document or while invoking Document.normalizeDocument(), the infoset [type definition] value is used to determine if this attribute is a DTD-determined ID attribute using the DTD-determined ID definition in [XPointer] .
        • from the use of the methods Element.setIdAttribute(), Element.setIdAttributeNS(), or Element.setIdAttributeNode(), i.e. it is an user-determined ID attribute;

          Note: XPointer framework (see section 3.2 in [XPointer] ) consider the DOM user-determined ID attribute as being part of the XPointer externally-determined ID definition.

        • using mechanisms that are outside the scope of this specification, it is then an externally-determined ID attribute. This includes using schema languages different from XML schema and DTD.

        If validation occurred while invoking Document.normalizeDocument(), all user-determined ID attributes are reset and all attribute nodes ID information are then reevaluated in accordance to the schema used. As a consequence, if the Attr.schemaTypeInfo attribute contains an ID type, isId will always return true.
        Since:
        DOM Level 3
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Class org.w3c.dom.bootstrap.DOMImplementationRegistry (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.w3c.dom.bootstrap.DOMImplementationRegistry

  • Packages that use DOMImplementationRegistry
    Package Description
    org.w3c.dom.bootstrap

    • Uses of DOMImplementationRegistry in org.w3c.dom.bootstrap

      Methods in org.w3c.dom.bootstrap that return DOMImplementationRegistry
      Modifier and Type Method and Description
      static DOMImplementationRegistry DOMImplementationRegistry.newInstance()
      Obtain a new instance of a DOMImplementationRegistry.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


compact2 - org.w3c.dom.bootstrap (Java Platform SE 8 )

compact2 - org.w3c.dom.bootstrap

Classes

  • DOMImplementationRegistry


org.w3c.dom.bootstrap (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact2

Package org.w3c.dom.bootstrap

  • Class Summary
    Class Description
    DOMImplementationRegistry
    A factory that enables applications to obtain instances of DOMImplementation.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames


compact3 - org.w3c.dom.bootstrap (Java Platform SE 8 )

compact3 - org.w3c.dom.bootstrap

Classes

  • DOMImplementationRegistry


org.w3c.dom.bootstrap (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package org.w3c.dom.bootstrap

  • Class Summary
    Class Description
    DOMImplementationRegistry
    A factory that enables applications to obtain instances of DOMImplementation.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames


DOMImplementationRegistry (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.bootstrap

Class DOMImplementationRegistry

  • java.lang.Object
    • org.w3c.dom.bootstrap.DOMImplementationRegistry

  • public final class DOMImplementationRegistry
extends Object
    A factory that enables applications to obtain instances of DOMImplementation.

    Example:

      // get an instance of the DOMImplementation registry
  DOMImplementationRegistry registry =
       DOMImplementationRegistry.newInstance();
  // get a DOM implementation the Level 3 XML module
  DOMImplementation domImpl =
       registry.getDOMImplementation("XML 3.0");

    This provides an application with an implementation-independent starting point. DOM implementations may modify this class to meet new security standards or to provide *additional* fallbacks for the list of DOMImplementationSources.

    Since:
    DOM Level 3
    See Also:
    DOMImplementation, DOMImplementationSource

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String PROPERTY
      The system property to specify the DOMImplementationSource class names.

    • Method Summary

      All Methods Static Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void addSource(DOMImplementationSource s)
      Register an implementation.
      DOMImplementation getDOMImplementation(String features)
      Return the first implementation that has the desired features, or null if none is found.
      DOMImplementationList getDOMImplementationList(String features)
      Return a list of implementations that support the desired features.
      static DOMImplementationRegistry newInstance()
      Obtain a new instance of a DOMImplementationRegistry.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • PROPERTY

        public static final String PROPERTY
        The system property to specify the DOMImplementationSource class names.
        See Also:
        Constant Field Values

    • Method Detail

      • newInstance

        public static DOMImplementationRegistry newInstance()
                                             throws ClassNotFoundException,
                                                    InstantiationException,
                                                    IllegalAccessException,
                                                    ClassCastException
        Obtain a new instance of a DOMImplementationRegistry. The DOMImplementationRegistry is initialized by the application or the implementation, depending on the context, by first checking the value of the Java system property org.w3c.dom.DOMImplementationSourceList and the service provider whose contents are at "META_INF/services/org.w3c.dom.DOMImplementationSourceList". The value of this property is a white-space separated list of names of availables classes implementing the DOMImplementationSource interface. Each class listed in the class name list is instantiated and any exceptions encountered are thrown to the application.
        Returns:
        an initialized instance of DOMImplementationRegistry
        Throws:
        ClassNotFoundException - If any specified class can not be found
        InstantiationException - If any specified class is an interface or abstract class
        IllegalAccessException - If the default constructor of a specified class is not accessible
        ClassCastException - If any specified class does not implement DOMImplementationSource

      • getDOMImplementation

        public DOMImplementation getDOMImplementation(String features)
        Return the first implementation that has the desired features, or null if none is found.
        Parameters:
        features - A string that specifies which features are required. This is a space separated list in which each feature is specified by its name optionally followed by a space and a version number. This is something like: "XML 1.0 Traversal +Events 2.0"
        Returns:
        An implementation that has the desired features, or null if none found.

      • getDOMImplementationList

        public DOMImplementationList getDOMImplementationList(String features)
        Return a list of implementations that support the desired features.
        Parameters:
        features - A string that specifies which features are required. This is a space separated list in which each feature is specified by its name optionally followed by a space and a version number. This is something like: "XML 1.0 Traversal +Events 2.0"
        Returns:
        A list of DOMImplementations that support the desired features.

      • addSource

        public void addSource(DOMImplementationSource s)
        Register an implementation.
        Parameters:
        s - The source to be registered, may not be null
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


org.w3c.dom.bootstrap (Java Platform SE 8 )

org.w3c.dom.bootstrap

Classes

  • DOMImplementationRegistry


org.w3c.dom.bootstrap (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.w3c.dom.bootstrap

  • Class Summary
    Class Description
    DOMImplementationRegistry
    A factory that enables applications to obtain instances of DOMImplementation.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames


org.w3c.dom.bootstrap Class Hierarchy (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.w3c.dom.bootstrap

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.w3c.dom.bootstrap.DOMImplementationRegistry
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package org.w3c.dom.bootstrap (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.w3c.dom.bootstrap

  • Packages that use org.w3c.dom.bootstrap
    Package Description
    org.w3c.dom.bootstrap
  • Classes in org.w3c.dom.bootstrap used by org.w3c.dom.bootstrap
    Class and Description
    DOMImplementationRegistry
    A factory that enables applications to obtain instances of DOMImplementation.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


CDATASection (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface CDATASection

  • All Superinterfaces:
    CharacterData, Node, Text

    public interface CDATASection
extends Text
    CDATA sections are used to escape blocks of text containing characters that would otherwise be regarded as markup. The only delimiter that is recognized in a CDATA section is the "]]>" string that ends the CDATA section. CDATA sections cannot be nested. Their primary purpose is for including material such as XML fragments, without needing to escape all the delimiters.

    The CharacterData.data attribute holds the text that is contained by the CDATA section. Note that this may contain characters that need to be escaped outside of CDATA sections and that, depending on the character encoding ("charset") chosen for serialization, it may be impossible to write out some characters as part of a CDATA section.

    The CDATASection interface inherits from the CharacterData interface through the Text interface. Adjacent CDATASection nodes are not merged by use of the normalize method of the Node interface.

    No lexical check is done on the content of a CDATA section and it is therefore possible to have the character sequence "]]>" in the content, which is illegal in a CDATA section per section 2.7 of [XML 1.0]. The presence of this character sequence must generate a fatal error during serialization or the cdata section must be splitted before the serialization (see also the parameter "split-cdata-sections" in the DOMConfiguration interface).

    Note: Because no markup is recognized within a CDATASection, character numeric references cannot be used as an escape mechanism when serializing. Therefore, action needs to be taken when serializing a CDATASection with a character encoding where some of the contained characters cannot be represented. Failure to do so would not produce well-formed XML.

    Note: One potential solution in the serialization process is to end the CDATA section before the character, output the character using a character reference or entity reference, and open a new CDATA section for any further characters in the text node. Note, however, that some code conversion libraries at the time of writing do not return an error or exception when a character is missing from the encoding, making the task of ensuring that data is not corrupted on serialization more difficult.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      • Methods inherited from interface org.w3c.dom.Text

        getWholeText, isElementContentWhitespace, replaceWholeText, splitText

      • Methods inherited from interface org.w3c.dom.CharacterData

        appendData, deleteData, getData, getLength, insertData, replaceData, setData, substringData

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


CharacterData (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface CharacterData

  • All Superinterfaces:
    Node
    All Known Subinterfaces:
    CDATASection, Comment, Text, Text

    public interface CharacterData
extends Node
    The CharacterData interface extends Node with a set of attributes and methods for accessing character data in the DOM. For clarity this set is defined here rather than on each object that uses these attributes and methods. No DOM objects correspond directly to CharacterData, though Text and others do inherit the interface from it. All offsets in this interface start from 0.

    As explained in the DOMString interface, text strings in the DOM are represented in UTF-16, i.e. as a sequence of 16-bit units. In the following, the term 16-bit units is used whenever necessary to indicate that indexing on CharacterData is done in 16-bit units.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void appendData(String arg)
      Append the string to the end of the character data of the node.
      void deleteData(int offset, int count)
      Remove a range of 16-bit units from the node.
      String getData()
      The character data of the node that implements this interface.
      int getLength()
      The number of 16-bit units that are available through data and the substringData method below.
      void insertData(int offset, String arg)
      Insert a string at the specified 16-bit unit offset.
      void replaceData(int offset, int count, String arg)
      Replace the characters starting at the specified 16-bit unit offset with the specified string.
      void setData(String data)
      The character data of the node that implements this interface.
      String substringData(int offset, int count)
      Extracts a range of data from the node.

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • Method Detail

      • getData

        String getData()
        throws DOMException
        The character data of the node that implements this interface. The DOM implementation may not put arbitrary limits on the amount of data that may be stored in a CharacterData node. However, implementation limits may mean that the entirety of a node's data may not fit into a single DOMString. In such cases, the user may call substringData to retrieve the data in appropriately sized pieces.
        Throws:
        DOMException - DOMSTRING_SIZE_ERR: Raised when it would return more characters than fit in a DOMString variable on the implementation platform.

      • setData

        void setData(String data)
      throws DOMException
        The character data of the node that implements this interface. The DOM implementation may not put arbitrary limits on the amount of data that may be stored in a CharacterData node. However, implementation limits may mean that the entirety of a node's data may not fit into a single DOMString. In such cases, the user may call substringData to retrieve the data in appropriately sized pieces.
        Throws:
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised when the node is readonly.

      • getLength

        int getLength()
        The number of 16-bit units that are available through data and the substringData method below. This may have the value zero, i.e., CharacterData nodes may be empty.

      • substringData

        String substringData(int offset,
                     int count)
              throws DOMException
        Extracts a range of data from the node.
        Parameters:
        offset - Start offset of substring to extract.
        count - The number of 16-bit units to extract.
        Returns:
        The specified substring. If the sum of offset and count exceeds the length, then all 16-bit units to the end of the data are returned.
        Throws:
        DOMException - INDEX_SIZE_ERR: Raised if the specified offset is negative or greater than the number of 16-bit units in data, or if the specified count is negative.
        DOMSTRING_SIZE_ERR: Raised if the specified range of text does not fit into a DOMString.

      • appendData

        void appendData(String arg)
         throws DOMException
        Append the string to the end of the character data of the node. Upon success, data provides access to the concatenation of data and the DOMString specified.
        Parameters:
        arg - The DOMString to append.
        Throws:
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.

      • insertData

        void insertData(int offset,
                String arg)
         throws DOMException
        Insert a string at the specified 16-bit unit offset.
        Parameters:
        offset - The character offset at which to insert.
        arg - The DOMString to insert.
        Throws:
        DOMException - INDEX_SIZE_ERR: Raised if the specified offset is negative or greater than the number of 16-bit units in data.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.

      • deleteData

        void deleteData(int offset,
                int count)
         throws DOMException
        Remove a range of 16-bit units from the node. Upon success, data and length reflect the change.
        Parameters:
        offset - The offset from which to start removing.
        count - The number of 16-bit units to delete. If the sum of offset and count exceeds length then all 16-bit units from offset to the end of the data are deleted.
        Throws:
        DOMException - INDEX_SIZE_ERR: Raised if the specified offset is negative or greater than the number of 16-bit units in data, or if the specified count is negative.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.

      • replaceData

        void replaceData(int offset,
                 int count,
                 String arg)
          throws DOMException
        Replace the characters starting at the specified 16-bit unit offset with the specified string.
        Parameters:
        offset - The offset from which to start replacing.
        count - The number of 16-bit units to replace. If the sum of offset and count exceeds length, then all 16-bit units to the end of the data are replaced; (i.e., the effect is the same as a remove method call with the same range, followed by an append method invocation).
        arg - The DOMString with which the range must be replaced.
        Throws:
        DOMException - INDEX_SIZE_ERR: Raised if the specified offset is negative or greater than the number of 16-bit units in data, or if the specified count is negative.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Interface org.w3c.dom.Attr (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.Attr

  • Packages that use Attr
    Package Description
    javax.imageio.metadata
    A package of the Java Image I/O API dealing with reading and writing metadata.
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.

    • Uses of Attr in javax.imageio.metadata

      Methods in javax.imageio.metadata that return Attr
      Modifier and Type | Method and Description
      Attr | IIOMetadataNode.getAttributeNode(String name)
      Attr IIOMetadataNode.getAttributeNodeNS(String namespaceURI, String localName)
      Equivalent to getAttributeNode(localName).
      Attr | IIOMetadataNode.removeAttributeNode(Attr oldAttr)
      Attr | IIOMetadataNode.setAttributeNode(Attr newAttr)
      Attr IIOMetadataNode.setAttributeNodeNS(Attr newAttr)
      Equivalent to setAttributeNode(newAttr).
      Methods in javax.imageio.metadata with parameters of type Attr
      Modifier and Type | Method and Description
      Attr | IIOMetadataNode.removeAttributeNode(Attr oldAttr)
      Attr | IIOMetadataNode.setAttributeNode(Attr newAttr)
      Attr IIOMetadataNode.setAttributeNodeNS(Attr newAttr)
      Equivalent to setAttributeNode(newAttr).
      void IIOMetadataNode.setIdAttributeNode(Attr idAttr, boolean isId)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.

    • Uses of Attr in org.w3c.dom

      Methods in org.w3c.dom that return Attr
      Modifier and Type Method and Description
      Attr Document.createAttribute(String name)
      Creates an Attr of the given name.
      Attr Document.createAttributeNS(String namespaceURI, String qualifiedName)
      Creates an attribute of the given qualified name and namespace URI.
      Attr Element.getAttributeNode(String name)
      Retrieves an attribute node by name.
      Attr Element.getAttributeNodeNS(String namespaceURI, String localName)
      Retrieves an Attr node by local name and namespace URI.
      Attr Element.removeAttributeNode(Attr oldAttr)
      Removes the specified attribute node.
      Attr Element.setAttributeNode(Attr newAttr)
      Adds a new attribute node.
      Attr Element.setAttributeNodeNS(Attr newAttr)
      Adds a new attribute.
      Methods in org.w3c.dom with parameters of type Attr
      Modifier and Type Method and Description
      Attr Element.removeAttributeNode(Attr oldAttr)
      Removes the specified attribute node.
      Attr Element.setAttributeNode(Attr newAttr)
      Adds a new attribute node.
      Attr Element.setAttributeNodeNS(Attr newAttr)
      Adds a new attribute.
      void Element.setIdAttributeNode(Attr idAttr, boolean isId)
      If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute .
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.CDATASection (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.CDATASection

  • Packages that use CDATASection
    Package Description
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.

    • Uses of CDATASection in org.w3c.dom

      Methods in org.w3c.dom that return CDATASection
      Modifier and Type Method and Description
      CDATASection Document.createCDATASection(String data)
      Creates a CDATASection node whose value is the specified string.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.CharacterData (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.CharacterData

  • Packages that use CharacterData
    Package Description
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.

    • Uses of CharacterData in org.w3c.dom

      Subinterfaces of CharacterData in org.w3c.dom
      Modifier and Type Interface and Description
      interface  CDATASection
      CDATA sections are used to escape blocks of text containing characters that would otherwise be regarded as markup.
      interface  Comment
      This interface inherits from CharacterData and represents the content of a comment, i.e., all the characters between the starting ' <!--' and ending '-->'.
      interface  Text
      The Text interface inherits from CharacterData and represents the textual content (termed character data in XML) of an Element or Attr.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.Comment (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.Comment

  • Packages that use Comment
    Package Description
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.

    • Uses of Comment in org.w3c.dom

      Methods in org.w3c.dom that return Comment
      Modifier and Type Method and Description
      Comment Document.createComment(String data)
      Creates a Comment node given the specified string.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.Document (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.Document

  • Packages that use Document
    Package Description
    javax.imageio.metadata
    A package of the Java Image I/O API dealing with reading and writing metadata.
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.
    org.w3c.dom.ls

    • Uses of Document in javax.imageio.metadata

      Methods in javax.imageio.metadata that return Document
      Modifier and Type Method and Description
      Document IIOMetadataNode.getOwnerDocument()
      Returns null, since IIOMetadataNodes do not belong to any Document.

    • Uses of Document in javax.xml.parsers

      Methods in javax.xml.parsers that return Document
      Modifier and Type Method and Description
      abstract Document DocumentBuilder.newDocument()
      Obtain a new instance of a DOM Document object to build a DOM tree with.
      Document DocumentBuilder.parse(File f)
      Parse the content of the given file as an XML document and return a new DOM Document object.
      abstract Document DocumentBuilder.parse(InputSource is)
      Parse the content of the given input source as an XML document and return a new DOM Document object.
      Document DocumentBuilder.parse(InputStream is)
      Parse the content of the given InputStream as an XML document and return a new DOM Document object.
      Document DocumentBuilder.parse(InputStream is, String systemId)
      Parse the content of the given InputStream as an XML document and return a new DOM Document object.
      Document DocumentBuilder.parse(String uri)
      Parse the content of the given URI as an XML document and return a new DOM Document object.

    • Uses of Document in javax.xml.soap

      Classes in javax.xml.soap that implement Document
      Modifier and Type Class and Description
      class  SOAPPart
      The container for the SOAP-specific portion of a SOAPMessage object.
      Methods in javax.xml.soap that return Document
      Modifier and Type Method and Description
      Document SOAPBody.extractContentAsDocument()
      Creates a new DOM Document and sets the first child of this SOAPBody as it's document element.
      Methods in javax.xml.soap with parameters of type Document
      Modifier and Type Method and Description
      SOAPBodyElement SOAPBody.addDocument(Document document)
      Adds the root node of the DOM Document to this SOAPBody object.

    • Uses of Document in org.w3c.dom

      Methods in org.w3c.dom that return Document
      Modifier and Type Method and Description
      Document DOMImplementation.createDocument(String namespaceURI, String qualifiedName, DocumentType doctype)
      Creates a DOM Document object of the specified type with its document element.
      Document Node.getOwnerDocument()
      The Document object associated with this node.

    • Uses of Document in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that return Document
      Modifier and Type Method and Description
      Document LSLoadEvent.getNewDocument()
      The document that finished loading.
      Document LSParser.parse(LSInput input)
      Parse an XML document from a resource identified by a LSInput.
      Document LSParser.parseURI(String uri)
      Parse an XML document from a location identified by a URI reference [IETF RFC 2396].
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.DocumentFragment (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.DocumentFragment

  • Packages that use DocumentFragment
    Package Description
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.

    • Uses of DocumentFragment in org.w3c.dom

      Methods in org.w3c.dom that return DocumentFragment
      Modifier and Type Method and Description
      DocumentFragment Document.createDocumentFragment()
      Creates an empty DocumentFragment object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.DocumentType (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.DocumentType

  • Packages that use DocumentType
    Package Description
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.

    • Uses of DocumentType in org.w3c.dom

      Methods in org.w3c.dom that return DocumentType
      Modifier and Type Method and Description
      DocumentType DOMImplementation.createDocumentType(String qualifiedName, String publicId, String systemId)
      Creates an empty DocumentType node.
      DocumentType Document.getDoctype()
      The Document Type Declaration (see DocumentType) associated with this document.
      Methods in org.w3c.dom with parameters of type DocumentType
      Modifier and Type Method and Description
      Document DOMImplementation.createDocument(String namespaceURI, String qualifiedName, DocumentType doctype)
      Creates a DOM Document object of the specified type with its document element.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.DOMConfiguration (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.DOMConfiguration

  • Packages that use DOMConfiguration
    Package Description
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.
    org.w3c.dom.ls

    • Uses of DOMConfiguration in org.w3c.dom

      Methods in org.w3c.dom that return DOMConfiguration
      Modifier and Type Method and Description
      DOMConfiguration Document.getDomConfig()
      The configuration used when Document.normalizeDocument() is invoked.

    • Uses of DOMConfiguration in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that return DOMConfiguration
      Modifier and Type Method and Description
      DOMConfiguration LSSerializer.getDomConfig()
      The DOMConfiguration object used by the LSSerializer when serializing a DOM node.
      DOMConfiguration LSParser.getDomConfig()
      The DOMConfiguration object used when parsing an input source.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.DOMError (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.DOMError

  • Packages that use DOMError
    Package Description
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.

    • Uses of DOMError in org.w3c.dom

      Methods in org.w3c.dom with parameters of type DOMError
      Modifier and Type Method and Description
      boolean DOMErrorHandler.handleError(DOMError error)
      This method is called on the error handler when an error occurs.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.DOMErrorHandler (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.DOMErrorHandler

No usage of org.w3c.dom.DOMErrorHandler
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.w3c.dom.DOMException (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.w3c.dom.DOMException

  • Packages that use DOMException
    Package Description
    javax.imageio.metadata
    A package of the Java Image I/O API dealing with reading and writing metadata.
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.
    org.w3c.dom.events
    org.w3c.dom.ls

    • Uses of DOMException in javax.imageio.metadata

      Methods in javax.imageio.metadata that throw DOMException
      Modifier and Type | Method and Description
      short IIOMetadataNode.compareDocumentPosition(Node other)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      String IIOMetadataNode.getBaseURI()
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      Object IIOMetadataNode.getFeature(String feature, String version)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      String IIOMetadataNode.getNamespaceURI()
      Returns null, since namespaces are not supported.
      TypeInfo IIOMetadataNode.getSchemaTypeInfo()
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      String IIOMetadataNode.getTextContent()
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      Object IIOMetadataNode.getUserData(String key)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      boolean IIOMetadataNode.isDefaultNamespace(String namespaceURI)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      boolean IIOMetadataNode.isEqualNode(Node node)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      boolean IIOMetadataNode.isSameNode(Node node)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      String IIOMetadataNode.lookupNamespaceURI(String prefix)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      String IIOMetadataNode.lookupPrefix(String namespaceURI)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      Attr | IIOMetadataNode.setAttributeNode(Attr newAttr)
      void IIOMetadataNode.setIdAttribute(String name, boolean isId)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      void IIOMetadataNode.setIdAttributeNode(Attr idAttr, boolean isId)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      void IIOMetadataNode.setIdAttributeNS(String namespaceURI, String localName, boolean isId)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      void IIOMetadataNode.setTextContent(String textContent)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      Object IIOMetadataNode.setUserData(String key, Object data, UserDataHandler handler)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.

    • Uses of DOMException in org.w3c.dom

      Methods in org.w3c.dom that throw DOMException
      Modifier and Type Method and Description
      Node Document.adoptNode(Node source)
      Attempts to adopt a node from another document to this document.
      Node Node.appendChild(Node newChild)
      Adds the node newChild to the end of the list of children of this node.
      void CharacterData.appendData(String arg)
      Append the string to the end of the character data of the node.
      short Node.compareDocumentPosition(Node other)
      Compares the reference node, i.e.
      Attr Document.createAttribute(String name)
      Creates an Attr of the given name.
      Attr Document.createAttributeNS(String namespaceURI, String qualifiedName)
      Creates an attribute of the given qualified name and namespace URI.
      CDATASection Document.createCDATASection(String data)
      Creates a CDATASection node whose value is the specified string.
      Document DOMImplementation.createDocument(String namespaceURI, String qualifiedName, DocumentType doctype)
      Creates a DOM Document object of the specified type with its document element.
      DocumentType DOMImplementation.createDocumentType(String qualifiedName, String publicId, String systemId)
      Creates an empty DocumentType node.
      Element Document.createElement(String tagName)
      Creates an element of the type specified.
      Element Document.createElementNS(String namespaceURI, String qualifiedName)
      Creates an element of the given qualified name and namespace URI.
      EntityReference Document.createEntityReference(String name)
      Creates an EntityReference object.
      ProcessingInstruction Document.createProcessingInstruction(String target, String data)
      Creates a ProcessingInstruction node given the specified name and data strings.
      void CharacterData.deleteData(int offset, int count)
      Remove a range of 16-bit units from the node.
      Attr Element.getAttributeNodeNS(String namespaceURI, String localName)
      Retrieves an Attr node by local name and namespace URI.
      String Element.getAttributeNS(String namespaceURI, String localName)
      Retrieves an attribute value by local name and namespace URI.
      String CharacterData.getData()
      The character data of the node that implements this interface.
      NodeList Element.getElementsByTagNameNS(String namespaceURI, String localName)
      Returns a NodeList of all the descendant Elements with a given local name and namespace URI in document order.
      Node NamedNodeMap.getNamedItemNS(String namespaceURI, String localName)
      Retrieves a node specified by local name and namespace URI.
      String Node.getNodeValue()
      The value of this node, depending on its type; see the table above.
      Object DOMConfiguration.getParameter(String name)
      Return the value of a parameter if known.
      String Node.getTextContent()
      This attribute returns the text content of this node and its descendants.
      boolean Element.hasAttributeNS(String namespaceURI, String localName)
      Returns true when an attribute with a given local name and namespace URI is specified on this element or has a default value, false otherwise.
      Node Document.importNode(Node importedNode, boolean deep)
      Imports a node from another document to this document, without altering or removing the source node from the original document; this method creates a new copy of the source node.
      Node Node.insertBefore(Node newChild, Node refChild)
      Inserts the node newChild before the existing child node refChild.
      void CharacterData.insertData(int offset, String arg)
      Insert a string at the specified 16-bit unit offset.
      void Element.removeAttribute(String name)
      Removes an attribute by name.
      Attr Element.removeAttributeNode(Attr oldAttr)
      Removes the specified attribute node.
      void Element.removeAttributeNS(String namespaceURI, String localName)
      Removes an attribute by local name and namespace URI.
      Node Node.removeChild(Node oldChild)
      Removes the child node indicated by oldChild from the list of children, and returns it.
      Node NamedNodeMap.removeNamedItem(String name)
      Removes a node specified by name.
      Node NamedNodeMap.removeNamedItemNS(String namespaceURI, String localName)
      Removes a node specified by local name and namespace URI.
      Node Document.renameNode(Node n, String namespaceURI, String qualifiedName)
      Rename an existing node of type ELEMENT_NODE or ATTRIBUTE_NODE.
      Node Node.replaceChild(Node newChild, Node oldChild)
      Replaces the child node oldChild with newChild in the list of children, and returns the oldChild node.
      void CharacterData.replaceData(int offset, int count, String arg)
      Replace the characters starting at the specified 16-bit unit offset with the specified string.
      Text Text.replaceWholeText(String content)
      Replaces the text of the current node and all logically-adjacent text nodes with the specified text.
      void Element.setAttribute(String name, String value)
      Adds a new attribute.
      Attr Element.setAttributeNode(Attr newAttr)
      Adds a new attribute node.
      Attr Element.setAttributeNodeNS(Attr newAttr)
      Adds a new attribute.
      void Element.setAttributeNS(String namespaceURI, String qualifiedName, String value)
      Adds a new attribute.
      void CharacterData.setData(String data)
      The character data of the node that implements this interface.
      void ProcessingInstruction.setData(String data)
      The content of this processing instruction.
      void Element.setIdAttribute(String name, boolean isId)
      If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute .
      void Element.setIdAttributeNode(Attr idAttr, boolean isId)
      If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute .
      void Element.setIdAttributeNS(String namespaceURI, String localName, boolean isId)
      If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute .
      Node NamedNodeMap.setNamedItem(Node arg)
      Adds a node using its nodeName attribute.
      Node NamedNodeMap.setNamedItemNS(Node arg)
      Adds a node using its namespaceURI and localName.
      void Node.setNodeValue(String nodeValue)
      The value of this node, depending on its type; see the table above.
      void DOMConfiguration.setParameter(String name, Object value)
      Set the value of a parameter.
      void Node.setPrefix(String prefix)
      The namespace prefix of this node, or null if it is unspecified.
      void Node.setTextContent(String textContent)
      This attribute returns the text content of this node and its descendants.
      void Attr.setValue(String value)
      On retrieval, the value of the attribute is returned as a string.
      void Document.setXmlStandalone(boolean xmlStandalone)
      An attribute specifying, as part of the XML declaration, whether this document is standalone.
      void Document.setXmlVersion(String xmlVersion)
      An attribute specifying, as part of the XML declaration, the version number of this document.
      Text Text.splitText(int offset)
      Breaks this node into two nodes at the specified offset, keeping both in the tree as siblings.
      String CharacterData.substringData(int offset, int count)
      Extracts a range of data from the node.

    • Uses of DOMException in org.w3c.dom.events

      Methods in org.w3c.dom.events that throw DOMException
      Modifier and Type | Method and Description
      Event | DocumentEvent.createEvent(String eventType)

    • Uses of DOMException in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that throw DOMException
      Modifier and Type Method and Description
      LSParser DOMImplementationLS.createLSParser(short mode, String schemaType)
      Create a new LSParser.
      Document LSParser.parse(LSInput input)
      Parse an XML document from a resource identified by a LSInput.
      Document LSParser.parseURI(String uri)
      Parse an XML document from a location identified by a URI reference [IETF RFC 2396].
      Node LSParser.parseWithContext(LSInput input, Node contextArg, short action)
      Parse an XML fragment from a resource identified by a LSInput and insert the content into an existing document at the position specified with the context and action arguments.
      String LSSerializer.writeToString(Node nodeArg)
      Serialize the specified node as described above in the general description of the LSSerializer interface.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.DOMImplementation (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.DOMImplementation

  • Packages that use DOMImplementation
    Package Description
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.
    org.w3c.dom.bootstrap

    • Uses of DOMImplementation in javax.xml.parsers

      Methods in javax.xml.parsers that return DOMImplementation
      Modifier and Type Method and Description
      abstract DOMImplementation DocumentBuilder.getDOMImplementation()
      Obtain an instance of a DOMImplementation object.

    • Uses of DOMImplementation in org.w3c.dom

      Methods in org.w3c.dom that return DOMImplementation
      Modifier and Type Method and Description
      DOMImplementation DOMImplementationSource.getDOMImplementation(String features)
      A method to request the first DOM implementation that supports the specified features.
      DOMImplementation Document.getImplementation()
      The DOMImplementation object that handles this document.
      DOMImplementation DOMImplementationList.item(int index)
      Returns the indexth item in the collection.

    • Uses of DOMImplementation in org.w3c.dom.bootstrap

      Methods in org.w3c.dom.bootstrap that return DOMImplementation
      Modifier and Type Method and Description
      DOMImplementation DOMImplementationRegistry.getDOMImplementation(String features)
      Return the first implementation that has the desired features, or null if none is found.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.DOMImplementationList (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.DOMImplementationList

  • Packages that use DOMImplementationList
    Package Description
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.
    org.w3c.dom.bootstrap

    • Uses of DOMImplementationList in org.w3c.dom

      Methods in org.w3c.dom that return DOMImplementationList
      Modifier and Type Method and Description
      DOMImplementationList DOMImplementationSource.getDOMImplementationList(String features)
      A method to request a list of DOM implementations that support the specified features and versions, as specified in .

    • Uses of DOMImplementationList in org.w3c.dom.bootstrap

      Methods in org.w3c.dom.bootstrap that return DOMImplementationList
      Modifier and Type Method and Description
      DOMImplementationList DOMImplementationRegistry.getDOMImplementationList(String features)
      Return a list of implementations that support the desired features.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.DOMImplementationSource (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.DOMImplementationSource

  • Packages that use DOMImplementationSource
    Package Description
    org.w3c.dom.bootstrap

    • Uses of DOMImplementationSource in org.w3c.dom.bootstrap

      Methods in org.w3c.dom.bootstrap with parameters of type DOMImplementationSource
      Modifier and Type Method and Description
      void DOMImplementationRegistry.addSource(DOMImplementationSource s)
      Register an implementation.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.DOMLocator (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.DOMLocator

  • Packages that use DOMLocator
    Package Description
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.

    • Uses of DOMLocator in org.w3c.dom

      Methods in org.w3c.dom that return DOMLocator
      Modifier and Type Method and Description
      DOMLocator DOMError.getLocation()
      The location of the error.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.DOMStringList (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.DOMStringList

  • Packages that use DOMStringList
    Package Description
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.

    • Uses of DOMStringList in org.w3c.dom

      Methods in org.w3c.dom that return DOMStringList
      Modifier and Type Method and Description
      DOMStringList DOMConfiguration.getParameterNames()
      The list of the parameters supported by this DOMConfiguration object and for which at least one value can be set by the application.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.Element (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.Element

  • Packages that use Element
    Package Description
    javax.imageio.metadata
    A package of the Java Image I/O API dealing with reading and writing metadata.
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.
    javax.xml.crypto.dom
    DOM-specific classes for the javax.xml.crypto package.
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.
    org.w3c.dom.ls

    • Uses of Element in javax.imageio.metadata

      Classes in javax.imageio.metadata that implement Element
      Modifier and Type Class and Description
      class  IIOMetadataNode
      A class representing a node in a meta-data tree, which implements the org.w3c.dom.Element interface and additionally allows for the storage of non-textual objects via the getUserObject and setUserObject methods.

    • Uses of Element in javax.xml.bind.annotation

      Methods in javax.xml.bind.annotation that return Element
      Modifier and Type | Method and Description
      Element | W3CDomHandler.getElement(DOMResult r)
      Methods in javax.xml.bind.annotation with parameters of type Element
      Modifier and Type | Method and Description
      Source | W3CDomHandler.marshal(Element element, ValidationEventHandler errorHandler)

    • Uses of Element in javax.xml.crypto.dom

      Methods in javax.xml.crypto.dom that return Element
      Modifier and Type Method and Description
      Element DOMCryptoContext.getElementById(String idValue)
      Returns the Element with the specified ID attribute value.
      Methods in javax.xml.crypto.dom with parameters of type Element
      Modifier and Type Method and Description
      void DOMCryptoContext.setIdAttributeNS(Element element, String namespaceURI, String localName)
      Registers the element's attribute specified by the namespace URI and local name to be of type ID.

    • Uses of Element in javax.xml.soap

      Subinterfaces of Element in javax.xml.soap
      Modifier and Type Interface and Description
      interface  Detail
      A container for DetailEntry objects.
      interface  DetailEntry
      The content for a Detail object, giving details for a SOAPFault object.
      interface  SOAPBody
      An object that represents the contents of the SOAP body element in a SOAP message.
      interface  SOAPBodyElement
      A SOAPBodyElement object represents the contents in a SOAPBody object.
      interface  SOAPElement
      An object representing an element of a SOAP message that is allowed but not specifically prescribed by a SOAP specification.
      interface  SOAPEnvelope
      The container for the SOAPHeader and SOAPBody portions of a SOAPPart object.
      interface  SOAPFault
      An element in the SOAPBody object that contains error and/or status information.
      interface  SOAPFaultElement
      A representation of the contents in a SOAPFault object.
      interface  SOAPHeader
      A representation of the SOAP header element.
      interface  SOAPHeaderElement
      An object representing the contents in the SOAP header part of the SOAP envelope.
      Methods in javax.xml.soap with parameters of type Element
      Modifier and Type Method and Description
      SOAPElement SOAPFactory.createElement(Element domElement)
      Creates a SOAPElement object from an existing DOM Element.

    • Uses of Element in javax.xml.ws

      Methods in javax.xml.ws with parameters of type Element
      Modifier and Type Method and Description
      <T extends EndpointReference>
      T             		WebServiceContext.getEndpointReference(Class<T> clazz, Element... referenceParameters)
      Returns the EndpointReference associated with this endpoint.
      abstract <T extends EndpointReference>
      T             		Endpoint.getEndpointReference(Class<T> clazz, Element... referenceParameters)
      Returns the EndpointReference associated with this Endpoint instance.
      EndpointReference WebServiceContext.getEndpointReference(Element... referenceParameters)
      Returns the EndpointReference for this endpoint.
      abstract EndpointReference Endpoint.getEndpointReference(Element... referenceParameters)
      Returns the EndpointReference associated with this Endpoint instance.

    • Uses of Element in javax.xml.ws.spi

      Method parameters in javax.xml.ws.spi with type arguments of type Element
      Modifier and Type Method and Description
      abstract W3CEndpointReference Provider.createW3CEndpointReference(String address, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters)
      Factory method to create a W3CEndpointReference.
      abstract W3CEndpointReference Provider.createW3CEndpointReference(String address, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters)
      Factory method to create a W3CEndpointReference.
      W3CEndpointReference Provider.createW3CEndpointReference(String address, QName interfaceName, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters, List<Element> elements, Map<QName,String> attributes)
      Factory method to create a W3CEndpointReference.
      W3CEndpointReference Provider.createW3CEndpointReference(String address, QName interfaceName, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters, List<Element> elements, Map<QName,String> attributes)
      Factory method to create a W3CEndpointReference.
      W3CEndpointReference Provider.createW3CEndpointReference(String address, QName interfaceName, QName serviceName, QName portName, List<Element> metadata, String wsdlDocumentLocation, List<Element> referenceParameters, List<Element> elements, Map<QName,String> attributes)
      Factory method to create a W3CEndpointReference.

    • Uses of Element in javax.xml.ws.wsaddressing

      Methods in javax.xml.ws.wsaddressing with parameters of type Element
      Modifier and Type Method and Description
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.element(Element element)
      Adds an extension element to the W3CEndpointReference instance's wsa:EndpointReference element.
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.metadata(Element metadataElement)
      Adds the metadataElement to the W3CEndpointReference instance's wsa:Metadata element.
      W3CEndpointReferenceBuilder W3CEndpointReferenceBuilder.referenceParameter(Element referenceParameter)
      Adds the referenceParameter to the W3CEndpointReference instance wsa:ReferenceParameters element.

    • Uses of Element in org.w3c.dom

      Methods in org.w3c.dom that return Element
      Modifier and Type Method and Description
      Element Document.createElement(String tagName)
      Creates an element of the type specified.
      Element Document.createElementNS(String namespaceURI, String qualifiedName)
      Creates an element of the given qualified name and namespace URI.
      Element Document.getDocumentElement()
      This is a convenience attribute that allows direct access to the child node that is the document element of the document.
      Element Document.getElementById(String elementId)
      Returns the Element that has an ID attribute with the given value.
      Element Attr.getOwnerElement()
      The Element node this attribute is attached to or null if this attribute is not in use.

    • Uses of Element in org.w3c.dom.ls

      Methods in org.w3c.dom.ls with parameters of type Element
      Modifier and Type Method and Description
      short LSParserFilter.startElement(Element elementArg)
      The parser will call this method after each Element start tag has been scanned, but before the remainder of the Element is processed.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.Entity (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.Entity

No usage of org.w3c.dom.Entity
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.EntityReference (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.EntityReference

  • Packages that use EntityReference
    Package Description
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.

    • Uses of EntityReference in org.w3c.dom

      Methods in org.w3c.dom that return EntityReference
      Modifier and Type Method and Description
      EntityReference Document.createEntityReference(String name)
      Creates an EntityReference object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.NamedNodeMap (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.NamedNodeMap

  • Packages that use NamedNodeMap
    Package Description
    javax.imageio.metadata
    A package of the Java Image I/O API dealing with reading and writing metadata.
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.

    • Uses of NamedNodeMap in javax.imageio.metadata

      Methods in javax.imageio.metadata that return NamedNodeMap
      Modifier and Type Method and Description
      NamedNodeMap IIOMetadataNode.getAttributes()
      Returns a NamedNodeMap containing the attributes of this node.

    • Uses of NamedNodeMap in org.w3c.dom

      Methods in org.w3c.dom that return NamedNodeMap
      Modifier and Type Method and Description
      NamedNodeMap Node.getAttributes()
      A NamedNodeMap containing the attributes of this node (if it is an Element) or null otherwise.
      NamedNodeMap DocumentType.getEntities()
      A NamedNodeMap containing the general entities, both external and internal, declared in the DTD.
      NamedNodeMap DocumentType.getNotations()
      A NamedNodeMap containing the notations declared in the DTD.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.NameList (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.NameList

No usage of org.w3c.dom.NameList
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.Node (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.Node

  • Packages that use Node
    Package Description
    javax.imageio.metadata
    A package of the Java Image I/O API dealing with reading and writing metadata.
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.crypto.dom
    DOM-specific classes for the javax.xml.crypto package.
    javax.xml.crypto.dsig.dom
    DOM-specific classes for the javax.xml.crypto.dsig package.
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    javax.xml.transform.dom
    This package implements DOM-specific transformation APIs.
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.
    org.w3c.dom.events
    org.w3c.dom.ls

    • Uses of Node in javax.imageio.metadata

      Classes in javax.imageio.metadata that implement Node
      Modifier and Type Class and Description
      class  IIOMetadataNode
      A class representing a node in a meta-data tree, which implements the org.w3c.dom.Element interface and additionally allows for the storage of non-textual objects via the getUserObject and setUserObject methods.
      Fields in javax.imageio.metadata declared as Node
      Modifier and Type Field and Description
      protected Node IIOInvalidTreeException.offendingNode
      The Node that led to the parsing error, or null.
      Methods in javax.imageio.metadata that return Node
      Modifier and Type | Method and Description
      Node IIOMetadataNode.appendChild(Node newChild)
      Adds the node newChild to the end of the list of children of this node.
      Node IIOMetadataNode.cloneNode(boolean deep)
      Returns a duplicate of this node.
      abstract Node IIOMetadata.getAsTree(String formatName)
      Returns an XML DOM Node object that represents the root of a tree of metadata contained within this object according to the conventions defined by a given metadata format.
      Node IIOMetadataNode.getFirstChild()
      Returns the first child of this node, or null if the node has no children.
      Node IIOMetadataNode.getLastChild()
      Returns the last child of this node, or null if the node has no children.
      Node IIOMetadataNode.getNextSibling()
      Returns the next sibling of this node, or null if the node has no next sibling.
      Node IIOInvalidTreeException.getOffendingNode()
      Returns the Node that caused the error in parsing.
      Node IIOMetadataNode.getParentNode()
      Returns the parent of this node.
      Node IIOMetadataNode.getPreviousSibling()
      Returns the previous sibling of this node, or null if this node has no previous sibling.
      Node IIOMetadataNode.insertBefore(Node newChild, Node refChild)
      Inserts the node newChild before the existing child node refChild.
      Node | IIOMetadataNode.item(int index)
      Node IIOMetadataNode.removeChild(Node oldChild)
      Removes the child node indicated by oldChild from the list of children, and returns it.
      Node IIOMetadataNode.replaceChild(Node newChild, Node oldChild)
      Replaces the child node oldChild with newChild in the list of children, and returns the oldChild node.
      Methods in javax.imageio.metadata with parameters of type Node
      Modifier and Type Method and Description
      Node IIOMetadataNode.appendChild(Node newChild)
      Adds the node newChild to the end of the list of children of this node.
      short IIOMetadataNode.compareDocumentPosition(Node other)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      Node IIOMetadataNode.insertBefore(Node newChild, Node refChild)
      Inserts the node newChild before the existing child node refChild.
      boolean IIOMetadataNode.isEqualNode(Node node)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      boolean IIOMetadataNode.isSameNode(Node node)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
      abstract void IIOMetadata.mergeTree(String formatName, Node root)
      Alters the internal state of this IIOMetadata object from a tree of XML DOM Nodes whose syntax is defined by the given metadata format.
      Node IIOMetadataNode.removeChild(Node oldChild)
      Removes the child node indicated by oldChild from the list of children, and returns it.
      Node IIOMetadataNode.replaceChild(Node newChild, Node oldChild)
      Replaces the child node oldChild with newChild in the list of children, and returns the oldChild node.
      void IIOMetadata.setFromTree(String formatName, Node root)
      Sets the internal state of this IIOMetadata object from a tree of XML DOM Nodes whose syntax is defined by the given metadata format.
      Constructors in javax.imageio.metadata with parameters of type Node
      Constructor and Description
      IIOInvalidTreeException(String message, Node offendingNode)
      Constructs an IIOInvalidTreeException with a message string and a reference to the Node that caused the parsing error.
      IIOInvalidTreeException(String message, Throwable cause, Node offendingNode)
      Constructs an IIOInvalidTreeException with a message string, a reference to an exception that caused this exception, and a reference to the Node that caused the parsing error.

    • Uses of Node in javax.xml.bind

      Methods in javax.xml.bind that return Node
      Modifier and Type Method and Description
      Node ValidationEventLocator.getNode()
      Return a reference to the DOM Node if available
      Node Marshaller.getNode(Object contentTree)
      Get a DOM tree view of the content tree(Optional).
      Methods in javax.xml.bind that return types with arguments of type Node
      Modifier and Type Method and Description
      Binder<Node> JAXBContext.createBinder()
      Creates a Binder for W3C DOM.
      Methods in javax.xml.bind with parameters of type Node
      Modifier and Type Method and Description
      void Marshaller.marshal(Object jaxbElement, Node node)
      Marshal the content tree rooted at jaxbElement into a DOM tree.
      Object Unmarshaller.unmarshal(Node node)
      Unmarshal global XML data from the specified DOM tree and return the resulting content tree.
      <T> JAXBElement<T> Unmarshaller.unmarshal(Node node, Class<T> declaredType)
      Unmarshal XML data by JAXB mapped declaredType and return the resulting content tree.

    • Uses of Node in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers that return Node
      Modifier and Type | Method and Description
      Node | ValidationEventLocatorImpl.getNode()
      Node AbstractMarshallerImpl.getNode(Object obj)
      By default, the getNode method is unsupported and throw an UnsupportedOperationException.
      Methods in javax.xml.bind.helpers with parameters of type Node
      Modifier and Type | Method and Description
      void | AbstractMarshallerImpl.marshal(Object obj, Node node)
      void ValidationEventLocatorImpl.setNode(Node _node)
      Set the Node field on this event locator.
      <T> JAXBElement<T> | AbstractUnmarshallerImpl.unmarshal(Node node, Class<T> expectedType)
      Constructors in javax.xml.bind.helpers with parameters of type Node
      Constructor and Description
      ValidationEventLocatorImpl(Node _node)
      Constructs an object that points to a DOM Node.

    • Uses of Node in javax.xml.crypto.dom

      Methods in javax.xml.crypto.dom that return Node
      Modifier and Type Method and Description
      Node DOMURIReference.getHere()
      Returns the here node.
      Node DOMStructure.getNode()
      Returns the node contained in this DOMStructure.
      Constructors in javax.xml.crypto.dom with parameters of type Node
      Constructor and Description
      DOMStructure(Node node)
      Creates a DOMStructure containing the specified node.

    • Uses of Node in javax.xml.crypto.dsig.dom

      Methods in javax.xml.crypto.dsig.dom that return Node
      Modifier and Type Method and Description
      Node DOMSignContext.getNextSibling()
      Returns the nextSibling node.
      Node DOMValidateContext.getNode()
      Returns the node.
      Node DOMSignContext.getParent()
      Returns the parent node.
      Methods in javax.xml.crypto.dsig.dom with parameters of type Node
      Modifier and Type Method and Description
      void DOMSignContext.setNextSibling(Node nextSibling)
      Sets the next sibling node.
      void DOMValidateContext.setNode(Node node)
      Sets the node.
      void DOMSignContext.setParent(Node parent)
      Sets the parent node.
      Constructors in javax.xml.crypto.dsig.dom with parameters of type Node
      Constructor and Description
      DOMSignContext(Key signingKey, Node parent)
      Creates a DOMSignContext with the specified signing key and parent node.
      DOMSignContext(Key signingKey, Node parent, Node nextSibling)
      Creates a DOMSignContext with the specified signing key, parent and next sibling nodes.
      DOMSignContext(KeySelector ks, Node parent)
      Creates a DOMSignContext with the specified key selector and parent node.
      DOMSignContext(KeySelector ks, Node parent, Node nextSibling)
      Creates a DOMSignContext with the specified key selector, parent and next sibling nodes.
      DOMValidateContext(Key validatingKey, Node node)
      Creates a DOMValidateContext containing the specified key and node.
      DOMValidateContext(KeySelector ks, Node node)
      Creates a DOMValidateContext containing the specified key selector and node.

    • Uses of Node in javax.xml.soap

      Subinterfaces of Node in javax.xml.soap
      Modifier and Type Interface and Description
      interface  Detail
      A container for DetailEntry objects.
      interface  DetailEntry
      The content for a Detail object, giving details for a SOAPFault object.
      interface  Node
      A representation of a node (element) in an XML document.
      interface  SOAPBody
      An object that represents the contents of the SOAP body element in a SOAP message.
      interface  SOAPBodyElement
      A SOAPBodyElement object represents the contents in a SOAPBody object.
      interface  SOAPElement
      An object representing an element of a SOAP message that is allowed but not specifically prescribed by a SOAP specification.
      interface  SOAPEnvelope
      The container for the SOAPHeader and SOAPBody portions of a SOAPPart object.
      interface  SOAPFault
      An element in the SOAPBody object that contains error and/or status information.
      interface  SOAPFaultElement
      A representation of the contents in a SOAPFault object.
      interface  SOAPHeader
      A representation of the SOAP header element.
      interface  SOAPHeaderElement
      An object representing the contents in the SOAP header part of the SOAP envelope.
      Classes in javax.xml.soap that implement Node
      Modifier and Type Class and Description
      class  SOAPPart
      The container for the SOAP-specific portion of a SOAPMessage object.

    • Uses of Node in javax.xml.transform.dom

      Methods in javax.xml.transform.dom that return Node
      Modifier and Type Method and Description
      Node DOMResult.getNextSibling()
      Get the child node before which the result nodes will be inserted.
      Node DOMSource.getNode()
      Get the node that represents a Source DOM tree.
      Node DOMResult.getNode()
      Get the node that will contain the result DOM tree.
      Node DOMLocator.getOriginatingNode()
      Return the node where the event occurred.
      Methods in javax.xml.transform.dom with parameters of type Node
      Modifier and Type Method and Description
      void DOMResult.setNextSibling(Node nextSibling)
      Set the child node before which the result nodes will be inserted.
      void DOMSource.setNode(Node node)
      Set the node that will represents a Source DOM tree.
      void DOMResult.setNode(Node node)
      Set the node that will contain the result DOM tree.
      Constructors in javax.xml.transform.dom with parameters of type Node
      Constructor and Description
      DOMResult(Node node)
      Use a DOM node to create a new output target.
      DOMResult(Node node, Node nextSibling)
      Use a DOM node to create a new output target specifying the child node where the result nodes should be inserted before.
      DOMResult(Node node, Node nextSibling, String systemId)
      Use a DOM node to create a new output target specifying the child node where the result nodes should be inserted before and the specified System ID.
      DOMResult(Node node, String systemId)
      Use a DOM node to create a new output target with the specified System ID.
      DOMSource(Node n)
      Create a new input source with a DOM node.
      DOMSource(Node node, String systemID)
      Create a new input source with a DOM node, and with the system ID also passed in as the base URI.

    • Uses of Node in org.w3c.dom

      Subinterfaces of Node in org.w3c.dom
      Modifier and Type Interface and Description
      interface  Attr
      The Attr interface represents an attribute in an Element object.
      interface  CDATASection
      CDATA sections are used to escape blocks of text containing characters that would otherwise be regarded as markup.
      interface  CharacterData
      The CharacterData interface extends Node with a set of attributes and methods for accessing character data in the DOM.
      interface  Comment
      This interface inherits from CharacterData and represents the content of a comment, i.e., all the characters between the starting ' <!--' and ending '-->'.
      interface  Document
      The Document interface represents the entire HTML or XML document.
      interface  DocumentFragment
      DocumentFragment is a "lightweight" or "minimal" Document object.
      interface  DocumentType
      Each Document has a doctype attribute whose value is either null or a DocumentType object.
      interface  Element
      The Element interface represents an element in an HTML or XML document.
      interface  Entity
      This interface represents a known entity, either parsed or unparsed, in an XML document.
      interface  EntityReference
      EntityReference nodes may be used to represent an entity reference in the tree.
      interface  Notation
      This interface represents a notation declared in the DTD.
      interface  ProcessingInstruction
      The ProcessingInstruction interface represents a "processing instruction", used in XML as a way to keep processor-specific information in the text of the document.
      interface  Text
      The Text interface inherits from CharacterData and represents the textual content (termed character data in XML) of an Element or Attr.
      Methods in org.w3c.dom that return Node
      Modifier and Type Method and Description
      Node Document.adoptNode(Node source)
      Attempts to adopt a node from another document to this document.
      Node Node.appendChild(Node newChild)
      Adds the node newChild to the end of the list of children of this node.
      Node Node.cloneNode(boolean deep)
      Returns a duplicate of this node, i.e., serves as a generic copy constructor for nodes.
      Node Node.getFirstChild()
      The first child of this node.
      Node Node.getLastChild()
      The last child of this node.
      Node NamedNodeMap.getNamedItem(String name)
      Retrieves a node specified by name.
      Node NamedNodeMap.getNamedItemNS(String namespaceURI, String localName)
      Retrieves a node specified by local name and namespace URI.
      Node Node.getNextSibling()
      The node immediately following this node.
      Node Node.getParentNode()
      The parent of this node.
      Node Node.getPreviousSibling()
      The node immediately preceding this node.
      Node DOMLocator.getRelatedNode()
      The node this locator is pointing to, or null if no node is available.
      Node Document.importNode(Node importedNode, boolean deep)
      Imports a node from another document to this document, without altering or removing the source node from the original document; this method creates a new copy of the source node.
      Node Node.insertBefore(Node newChild, Node refChild)
      Inserts the node newChild before the existing child node refChild.
      Node NamedNodeMap.item(int index)
      Returns the indexth item in the map.
      Node NodeList.item(int index)
      Returns the indexth item in the collection.
      Node Node.removeChild(Node oldChild)
      Removes the child node indicated by oldChild from the list of children, and returns it.
      Node NamedNodeMap.removeNamedItem(String name)
      Removes a node specified by name.
      Node NamedNodeMap.removeNamedItemNS(String namespaceURI, String localName)
      Removes a node specified by local name and namespace URI.
      Node Document.renameNode(Node n, String namespaceURI, String qualifiedName)
      Rename an existing node of type ELEMENT_NODE or ATTRIBUTE_NODE.
      Node Node.replaceChild(Node newChild, Node oldChild)
      Replaces the child node oldChild with newChild in the list of children, and returns the oldChild node.
      Node NamedNodeMap.setNamedItem(Node arg)
      Adds a node using its nodeName attribute.
      Node NamedNodeMap.setNamedItemNS(Node arg)
      Adds a node using its namespaceURI and localName.
      Methods in org.w3c.dom with parameters of type Node
      Modifier and Type Method and Description
      Node Document.adoptNode(Node source)
      Attempts to adopt a node from another document to this document.
      Node Node.appendChild(Node newChild)
      Adds the node newChild to the end of the list of children of this node.
      short Node.compareDocumentPosition(Node other)
      Compares the reference node, i.e.
      void UserDataHandler.handle(short operation, String key, Object data, Node src, Node dst)
      This method is called whenever the node for which this handler is registered is imported or cloned.
      Node Document.importNode(Node importedNode, boolean deep)
      Imports a node from another document to this document, without altering or removing the source node from the original document; this method creates a new copy of the source node.
      Node Node.insertBefore(Node newChild, Node refChild)
      Inserts the node newChild before the existing child node refChild.
      boolean Node.isEqualNode(Node arg)
      Tests whether two nodes are equal.
      boolean Node.isSameNode(Node other)
      Returns whether this node is the same node as the given one.
      Node Node.removeChild(Node oldChild)
      Removes the child node indicated by oldChild from the list of children, and returns it.
      Node Document.renameNode(Node n, String namespaceURI, String qualifiedName)
      Rename an existing node of type ELEMENT_NODE or ATTRIBUTE_NODE.
      Node Node.replaceChild(Node newChild, Node oldChild)
      Replaces the child node oldChild with newChild in the list of children, and returns the oldChild node.
      Node NamedNodeMap.setNamedItem(Node arg)
      Adds a node using its nodeName attribute.
      Node NamedNodeMap.setNamedItemNS(Node arg)
      Adds a node using its namespaceURI and localName.

    • Uses of Node in org.w3c.dom.events

      Methods in org.w3c.dom.events that return Node
      Modifier and Type Method and Description
      Node MutationEvent.getRelatedNode()
      relatedNode is used to identify a secondary node related to a mutation event.
      Methods in org.w3c.dom.events with parameters of type Node
      Modifier and Type Method and Description
      void MutationEvent.initMutationEvent(String typeArg, boolean canBubbleArg, boolean cancelableArg, Node relatedNodeArg, String prevValueArg, String newValueArg, String attrNameArg, short attrChangeArg)
      The initMutationEvent method is used to initialize the value of a MutationEvent created through the DocumentEvent interface.

    • Uses of Node in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that return Node
      Modifier and Type Method and Description
      Node LSParser.parseWithContext(LSInput input, Node contextArg, short action)
      Parse an XML fragment from a resource identified by a LSInput and insert the content into an existing document at the position specified with the context and action arguments.
      Methods in org.w3c.dom.ls with parameters of type Node
      Modifier and Type Method and Description
      short LSParserFilter.acceptNode(Node nodeArg)
      This method will be called by the parser at the completion of the parsing of each node.
      Node LSParser.parseWithContext(LSInput input, Node contextArg, short action)
      Parse an XML fragment from a resource identified by a LSInput and insert the content into an existing document at the position specified with the context and action arguments.
      boolean LSSerializer.write(Node nodeArg, LSOutput destination)
      Serialize the specified node as described above in the general description of the LSSerializer interface.
      String LSSerializer.writeToString(Node nodeArg)
      Serialize the specified node as described above in the general description of the LSSerializer interface.
      boolean LSSerializer.writeToURI(Node nodeArg, String uri)
      A convenience method that acts as if LSSerializer.write was called with a LSOutput with no encoding specified and LSOutput.systemId set to the uri argument.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.NodeList (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.NodeList

  • Packages that use NodeList
    Package Description
    javax.imageio.metadata
    A package of the Java Image I/O API dealing with reading and writing metadata.
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.

    • Uses of NodeList in javax.imageio.metadata

      Classes in javax.imageio.metadata that implement NodeList
      Modifier and Type Class and Description
      class  IIOMetadataNode
      A class representing a node in a meta-data tree, which implements the org.w3c.dom.Element interface and additionally allows for the storage of non-textual objects via the getUserObject and setUserObject methods.
      Methods in javax.imageio.metadata that return NodeList
      Modifier and Type | Method and Description
      NodeList IIOMetadataNode.getChildNodes()
      Returns a NodeList that contains all children of this node.
      NodeList | IIOMetadataNode.getElementsByTagName(String name)
      NodeList IIOMetadataNode.getElementsByTagNameNS(String namespaceURI, String localName)
      Equivalent to getElementsByTagName(localName).

    • Uses of NodeList in org.w3c.dom

      Methods in org.w3c.dom that return NodeList
      Modifier and Type Method and Description
      NodeList Node.getChildNodes()
      A NodeList that contains all children of this node.
      NodeList Element.getElementsByTagName(String name)
      Returns a NodeList of all descendant Elements with a given tag name, in document order.
      NodeList Document.getElementsByTagName(String tagname)
      Returns a NodeList of all the Elements in document order with a given tag name and are contained in the document.
      NodeList Element.getElementsByTagNameNS(String namespaceURI, String localName)
      Returns a NodeList of all the descendant Elements with a given local name and namespace URI in document order.
      NodeList Document.getElementsByTagNameNS(String namespaceURI, String localName)
      Returns a NodeList of all the Elements with a given local name and namespace URI in document order.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.Notation (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.Notation

No usage of org.w3c.dom.Notation
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.ProcessingInstruction (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.ProcessingInstruction

  • Packages that use ProcessingInstruction
    Package Description
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.

    • Uses of ProcessingInstruction in org.w3c.dom

      Methods in org.w3c.dom that return ProcessingInstruction
      Modifier and Type Method and Description
      ProcessingInstruction Document.createProcessingInstruction(String target, String data)
      Creates a ProcessingInstruction node given the specified name and data strings.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.Text (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.Text

  • Packages that use Text
    Package Description
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.

    • Uses of Text in javax.xml.soap

      Subinterfaces of Text in javax.xml.soap
      Modifier and Type Interface and Description
      interface  Text
      A representation of a node whose value is text.

    • Uses of Text in org.w3c.dom

      Subinterfaces of Text in org.w3c.dom
      Modifier and Type Interface and Description
      interface  CDATASection
      CDATA sections are used to escape blocks of text containing characters that would otherwise be regarded as markup.
      Methods in org.w3c.dom that return Text
      Modifier and Type Method and Description
      Text Document.createTextNode(String data)
      Creates a Text node given the specified string.
      Text Text.replaceWholeText(String content)
      Replaces the text of the current node and all logically-adjacent text nodes with the specified text.
      Text Text.splitText(int offset)
      Breaks this node into two nodes at the specified offset, keeping both in the tree as siblings.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.TypeInfo (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.TypeInfo

  • Packages that use TypeInfo
    Package Description
    javax.imageio.metadata
    A package of the Java Image I/O API dealing with reading and writing metadata.
    javax.xml.validation
    This package provides an API for validation of XML documents.
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.

    • Uses of TypeInfo in javax.imageio.metadata

      Methods in javax.imageio.metadata that return TypeInfo
      Modifier and Type Method and Description
      TypeInfo IIOMetadataNode.getSchemaTypeInfo()
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.

    • Uses of TypeInfo in javax.xml.validation

      Methods in javax.xml.validation that return TypeInfo
      Modifier and Type Method and Description
      abstract TypeInfo TypeInfoProvider.getAttributeTypeInfo(int index)
      Returns the immutable TypeInfo object for the specified attribute of the current element.
      abstract TypeInfo TypeInfoProvider.getElementTypeInfo()
      Returns the immutable TypeInfo object for the current element.

    • Uses of TypeInfo in org.w3c.dom

      Methods in org.w3c.dom that return TypeInfo
      Modifier and Type Method and Description
      TypeInfo Element.getSchemaTypeInfo()
      The type information associated with this element.
      TypeInfo Attr.getSchemaTypeInfo()
      The type information associated with this attribute.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.UserDataHandler (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.UserDataHandler

  • Packages that use UserDataHandler
    Package Description
    javax.imageio.metadata
    A package of the Java Image I/O API dealing with reading and writing metadata.
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.

    • Uses of UserDataHandler in javax.imageio.metadata

      Methods in javax.imageio.metadata with parameters of type UserDataHandler
      Modifier and Type Method and Description
      Object IIOMetadataNode.setUserData(String key, Object data, UserDataHandler handler)
      This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.

    • Uses of UserDataHandler in org.w3c.dom

      Methods in org.w3c.dom with parameters of type UserDataHandler
      Modifier and Type Method and Description
      Object Node.setUserData(String key, Object data, UserDataHandler handler)
      Associate an object to a key on this node.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Comment (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface Comment

  • All Superinterfaces:
    CharacterData, Node

    public interface Comment
extends CharacterData
    This interface inherits from CharacterData and represents the content of a comment, i.e., all the characters between the starting ' <!--' and ending '-->'. Note that this is the definition of a comment in XML, and, in practice, HTML, although some HTML tools may implement the full SGML comment structure.

    No lexical check is done on the content of a comment and it is therefore possible to have the character sequence "--" (double-hyphen) in the content, which is illegal in a comment per section 2.5 of [XML 1.0]. The presence of this character sequence must generate a fatal error during serialization.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      • Methods inherited from interface org.w3c.dom.CharacterData

        appendData, deleteData, getData, getLength, insertData, replaceData, setData, substringData

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


compact2 - org.w3c.dom (Java Platform SE 8 )

compact2 - org.w3c.dom

Interfaces

  • Attr
  • CDATASection
  • CharacterData
  • Comment
  • Document
  • DocumentFragment
  • DocumentType
  • DOMConfiguration
  • DOMError
  • DOMErrorHandler
  • DOMImplementation
  • DOMImplementationList
  • DOMImplementationSource
  • DOMLocator
  • DOMStringList
  • Element
  • Entity
  • EntityReference
  • NamedNodeMap
  • NameList
  • Node
  • NodeList
  • Notation
  • ProcessingInstruction
  • Text
  • TypeInfo
  • UserDataHandler

Exceptions

  • DOMException


org.w3c.dom (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact2

Package org.w3c.dom

Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.

See: Description

  • Interface Summary
    Interface Description
    Attr
    The Attr interface represents an attribute in an Element object.
    CDATASection
    CDATA sections are used to escape blocks of text containing characters that would otherwise be regarded as markup.
    CharacterData
    The CharacterData interface extends Node with a set of attributes and methods for accessing character data in the DOM.
    Comment
    This interface inherits from CharacterData and represents the content of a comment, i.e., all the characters between the starting ' <!--' and ending '-->'.
    Document
    The Document interface represents the entire HTML or XML document.
    DocumentFragment
    DocumentFragment is a "lightweight" or "minimal" Document object.
    DocumentType
    Each Document has a doctype attribute whose value is either null or a DocumentType object.
    DOMConfiguration
    The DOMConfiguration interface represents the configuration of a document and maintains a table of recognized parameters.
    DOMError
    DOMError is an interface that describes an error.
    DOMErrorHandler
    DOMErrorHandler is a callback interface that the DOM implementation can call when reporting errors that happens while processing XML data, or when doing some other processing (e.g.
    DOMImplementation
    The DOMImplementation interface provides a number of methods for performing operations that are independent of any particular instance of the document object model.
    DOMImplementationList
    The DOMImplementationList interface provides the abstraction of an ordered collection of DOM implementations, without defining or constraining how this collection is implemented.
    DOMImplementationSource
    This interface permits a DOM implementer to supply one or more implementations, based upon requested features and versions, as specified in DOM Features.
    DOMLocator
    DOMLocator is an interface that describes a location (e.g.
    DOMStringList
    The DOMStringList interface provides the abstraction of an ordered collection of DOMString values, without defining or constraining how this collection is implemented.
    Element
    The Element interface represents an element in an HTML or XML document.
    Entity
    This interface represents a known entity, either parsed or unparsed, in an XML document.
    EntityReference
    EntityReference nodes may be used to represent an entity reference in the tree.
    NamedNodeMap
    Objects implementing the NamedNodeMap interface are used to represent collections of nodes that can be accessed by name.
    NameList
    The NameList interface provides the abstraction of an ordered collection of parallel pairs of name and namespace values (which could be null values), without defining or constraining how this collection is implemented.
    Node
    The Node interface is the primary datatype for the entire Document Object Model.
    NodeList
    The NodeList interface provides the abstraction of an ordered collection of nodes, without defining or constraining how this collection is implemented.
    Notation
    This interface represents a notation declared in the DTD.
    ProcessingInstruction
    The ProcessingInstruction interface represents a "processing instruction", used in XML as a way to keep processor-specific information in the text of the document.
    Text
    The Text interface inherits from CharacterData and represents the textual content (termed character data in XML) of an Element or Attr.
    TypeInfo
    The TypeInfo interface represents a type referenced from Element or Attr nodes, specified in the schemas associated with the document.
    UserDataHandler
    When associating an object to a key on a node using Node.setUserData() the application can provide a handler that gets called when the node the object is associated to is being cloned, imported, or renamed.
  • Exception Summary
    Exception Description
    DOMException
    DOM operations only raise exceptions in "exceptional" circumstances, i.e., when an operation is impossible to perform (either for logical reasons, because data is lost, or because the implementation has become unstable).

Package org.w3c.dom Description

Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing. The Document Object Model Level 2 Core API allows programs to dynamically access and update the content and structure of documents. See the specification for more information.
Since:
JDK1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames


compact3 - org.w3c.dom (Java Platform SE 8 )

compact3 - org.w3c.dom

Interfaces

  • Attr
  • CDATASection
  • CharacterData
  • Comment
  • Document
  • DocumentFragment
  • DocumentType
  • DOMConfiguration
  • DOMError
  • DOMErrorHandler
  • DOMImplementation
  • DOMImplementationList
  • DOMImplementationSource
  • DOMLocator
  • DOMStringList
  • Element
  • Entity
  • EntityReference
  • NamedNodeMap
  • NameList
  • Node
  • NodeList
  • Notation
  • ProcessingInstruction
  • Text
  • TypeInfo
  • UserDataHandler

Exceptions

  • DOMException


org.w3c.dom (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package org.w3c.dom

Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.

See: Description

  • Interface Summary
    Interface Description
    Attr
    The Attr interface represents an attribute in an Element object.
    CDATASection
    CDATA sections are used to escape blocks of text containing characters that would otherwise be regarded as markup.
    CharacterData
    The CharacterData interface extends Node with a set of attributes and methods for accessing character data in the DOM.
    Comment
    This interface inherits from CharacterData and represents the content of a comment, i.e., all the characters between the starting ' <!--' and ending '-->'.
    Document
    The Document interface represents the entire HTML or XML document.
    DocumentFragment
    DocumentFragment is a "lightweight" or "minimal" Document object.
    DocumentType
    Each Document has a doctype attribute whose value is either null or a DocumentType object.
    DOMConfiguration
    The DOMConfiguration interface represents the configuration of a document and maintains a table of recognized parameters.
    DOMError
    DOMError is an interface that describes an error.
    DOMErrorHandler
    DOMErrorHandler is a callback interface that the DOM implementation can call when reporting errors that happens while processing XML data, or when doing some other processing (e.g.
    DOMImplementation
    The DOMImplementation interface provides a number of methods for performing operations that are independent of any particular instance of the document object model.
    DOMImplementationList
    The DOMImplementationList interface provides the abstraction of an ordered collection of DOM implementations, without defining or constraining how this collection is implemented.
    DOMImplementationSource
    This interface permits a DOM implementer to supply one or more implementations, based upon requested features and versions, as specified in DOM Features.
    DOMLocator
    DOMLocator is an interface that describes a location (e.g.
    DOMStringList
    The DOMStringList interface provides the abstraction of an ordered collection of DOMString values, without defining or constraining how this collection is implemented.
    Element
    The Element interface represents an element in an HTML or XML document.
    Entity
    This interface represents a known entity, either parsed or unparsed, in an XML document.
    EntityReference
    EntityReference nodes may be used to represent an entity reference in the tree.
    NamedNodeMap
    Objects implementing the NamedNodeMap interface are used to represent collections of nodes that can be accessed by name.
    NameList
    The NameList interface provides the abstraction of an ordered collection of parallel pairs of name and namespace values (which could be null values), without defining or constraining how this collection is implemented.
    Node
    The Node interface is the primary datatype for the entire Document Object Model.
    NodeList
    The NodeList interface provides the abstraction of an ordered collection of nodes, without defining or constraining how this collection is implemented.
    Notation
    This interface represents a notation declared in the DTD.
    ProcessingInstruction
    The ProcessingInstruction interface represents a "processing instruction", used in XML as a way to keep processor-specific information in the text of the document.
    Text
    The Text interface inherits from CharacterData and represents the textual content (termed character data in XML) of an Element or Attr.
    TypeInfo
    The TypeInfo interface represents a type referenced from Element or Attr nodes, specified in the schemas associated with the document.
    UserDataHandler
    When associating an object to a key on a node using Node.setUserData() the application can provide a handler that gets called when the node the object is associated to is being cloned, imported, or renamed.
  • Exception Summary
    Exception Description
    DOMException
    DOM operations only raise exceptions in "exceptional" circumstances, i.e., when an operation is impossible to perform (either for logical reasons, because data is lost, or because the implementation has become unstable).

Package org.w3c.dom Description

Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing. The Document Object Model Level 2 Core API allows programs to dynamically access and update the content and structure of documents. See the specification for more information.
Since:
JDK1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames


Document (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface Document

  • All Superinterfaces:
    Node
    All Known Implementing Classes:
    SOAPPart

    public interface Document
extends Node
    The Document interface represents the entire HTML or XML document. Conceptually, it is the root of the document tree, and provides the primary access to the document's data.

    Since elements, text nodes, comments, processing instructions, etc. cannot exist outside the context of a Document, the Document interface also contains the factory methods needed to create these objects. The Node objects created have a ownerDocument attribute which associates them with the Document within whose context they were created.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Node adoptNode(Node source)
      Attempts to adopt a node from another document to this document.
      Attr createAttribute(String name)
      Creates an Attr of the given name.
      Attr createAttributeNS(String namespaceURI, String qualifiedName)
      Creates an attribute of the given qualified name and namespace URI.
      CDATASection createCDATASection(String data)
      Creates a CDATASection node whose value is the specified string.
      Comment createComment(String data)
      Creates a Comment node given the specified string.
      DocumentFragment createDocumentFragment()
      Creates an empty DocumentFragment object.
      Element createElement(String tagName)
      Creates an element of the type specified.
      Element createElementNS(String namespaceURI, String qualifiedName)
      Creates an element of the given qualified name and namespace URI.
      EntityReference createEntityReference(String name)
      Creates an EntityReference object.
      ProcessingInstruction createProcessingInstruction(String target, String data)
      Creates a ProcessingInstruction node given the specified name and data strings.
      Text createTextNode(String data)
      Creates a Text node given the specified string.
      DocumentType getDoctype()
      The Document Type Declaration (see DocumentType) associated with this document.
      Element getDocumentElement()
      This is a convenience attribute that allows direct access to the child node that is the document element of the document.
      String getDocumentURI()
      The location of the document or null if undefined or if the Document was created using DOMImplementation.createDocument.
      DOMConfiguration getDomConfig()
      The configuration used when Document.normalizeDocument() is invoked.
      Element getElementById(String elementId)
      Returns the Element that has an ID attribute with the given value.
      NodeList getElementsByTagName(String tagname)
      Returns a NodeList of all the Elements in document order with a given tag name and are contained in the document.
      NodeList getElementsByTagNameNS(String namespaceURI, String localName)
      Returns a NodeList of all the Elements with a given local name and namespace URI in document order.
      DOMImplementation getImplementation()
      The DOMImplementation object that handles this document.
      String getInputEncoding()
      An attribute specifying the encoding used for this document at the time of the parsing.
      boolean getStrictErrorChecking()
      An attribute specifying whether error checking is enforced or not.
      String getXmlEncoding()
      An attribute specifying, as part of the XML declaration, the encoding of this document.
      boolean getXmlStandalone()
      An attribute specifying, as part of the XML declaration, whether this document is standalone.
      String getXmlVersion()
      An attribute specifying, as part of the XML declaration, the version number of this document.
      Node importNode(Node importedNode, boolean deep)
      Imports a node from another document to this document, without altering or removing the source node from the original document; this method creates a new copy of the source node.
      void normalizeDocument()
      This method acts as if the document was going through a save and load cycle, putting the document in a "normal" form.
      Node renameNode(Node n, String namespaceURI, String qualifiedName)
      Rename an existing node of type ELEMENT_NODE or ATTRIBUTE_NODE.
      void setDocumentURI(String documentURI)
      The location of the document or null if undefined or if the Document was created using DOMImplementation.createDocument.
      void setStrictErrorChecking(boolean strictErrorChecking)
      An attribute specifying whether error checking is enforced or not.
      void setXmlStandalone(boolean xmlStandalone)
      An attribute specifying, as part of the XML declaration, whether this document is standalone.
      void setXmlVersion(String xmlVersion)
      An attribute specifying, as part of the XML declaration, the version number of this document.

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • Method Detail

      • getDoctype

        DocumentType getDoctype()
        The Document Type Declaration (see DocumentType) associated with this document. For XML documents without a document type declaration this returns null. For HTML documents, a DocumentType object may be returned, independently of the presence or absence of document type declaration in the HTML document.
        This provides direct access to the DocumentType node, child node of this Document. This node can be set at document creation time and later changed through the use of child nodes manipulation methods, such as Node.insertBefore, or Node.replaceChild. Note, however, that while some implementations may instantiate different types of Document objects supporting additional features than the "Core", such as "HTML" [DOM Level 2 HTML] , based on the DocumentType specified at creation time, changing it afterwards is very unlikely to result in a change of the features supported.
        Since:
        DOM Level 3

      • getImplementation

        DOMImplementation getImplementation()
        The DOMImplementation object that handles this document. A DOM application may use objects from multiple implementations.

      • getDocumentElement

        Element getDocumentElement()
        This is a convenience attribute that allows direct access to the child node that is the document element of the document.

      • createElement

        Element createElement(String tagName)
               throws DOMException
        Creates an element of the type specified. Note that the instance returned implements the Element interface, so attributes can be specified directly on the returned object.
        In addition, if there are known attributes with default values, Attr nodes representing them are automatically created and attached to the element.
        To create an element with a qualified name and namespace URI, use the createElementNS method.
        Parameters:
        tagName - The name of the element type to instantiate. For XML, this is case-sensitive, otherwise it depends on the case-sensitivity of the markup language in use. In that case, the name is mapped to the canonical form of that markup by the DOM implementation.
        Returns:
        A new Element object with the nodeName attribute set to tagName, and localName, prefix, and namespaceURI set to null.
        Throws:
        DOMException - INVALID_CHARACTER_ERR: Raised if the specified name is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute.

      • createDocumentFragment

        DocumentFragment createDocumentFragment()
        Creates an empty DocumentFragment object.
        Returns:
        A new DocumentFragment.

      • createTextNode

        Text createTextNode(String data)
        Creates a Text node given the specified string.
        Parameters:
        data - The data for the node.
        Returns:
        The new Text object.

      • createComment

        Comment createComment(String data)
        Creates a Comment node given the specified string.
        Parameters:
        data - The data for the node.
        Returns:
        The new Comment object.

      • createCDATASection

        CDATASection createCDATASection(String data)
                         throws DOMException
        Creates a CDATASection node whose value is the specified string.
        Parameters:
        data - The data for the CDATASection contents.
        Returns:
        The new CDATASection object.
        Throws:
        DOMException - NOT_SUPPORTED_ERR: Raised if this document is an HTML document.

      • createProcessingInstruction

        ProcessingInstruction createProcessingInstruction(String target,
                                                  String data)
                                           throws DOMException
        Creates a ProcessingInstruction node given the specified name and data strings.
        Parameters:
        target - The target part of the processing instruction.Unlike Document.createElementNS or Document.createAttributeNS, no namespace well-formed checking is done on the target name. Applications should invoke Document.normalizeDocument() with the parameter " namespaces" set to true in order to ensure that the target name is namespace well-formed.
        data - The data for the node.
        Returns:
        The new ProcessingInstruction object.
        Throws:
        DOMException - INVALID_CHARACTER_ERR: Raised if the specified target is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute.
        NOT_SUPPORTED_ERR: Raised if this document is an HTML document.

      • createAttribute

        Attr createAttribute(String name)
              throws DOMException
        Creates an Attr of the given name. Note that the Attr instance can then be set on an Element using the setAttributeNode method.
        To create an attribute with a qualified name and namespace URI, use the createAttributeNS method.
        Parameters:
        name - The name of the attribute.
        Returns:
        A new Attr object with the nodeName attribute set to name, and localName, prefix, and namespaceURI set to null. The value of the attribute is the empty string.
        Throws:
        DOMException - INVALID_CHARACTER_ERR: Raised if the specified name is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute.

      • createEntityReference

        EntityReference createEntityReference(String name)
                               throws DOMException
        Creates an EntityReference object. In addition, if the referenced entity is known, the child list of the EntityReference node is made the same as that of the corresponding Entity node.

        Note: If any descendant of the Entity node has an unbound namespace prefix, the corresponding descendant of the created EntityReference node is also unbound; (its namespaceURI is null). The DOM Level 2 and 3 do not support any mechanism to resolve namespace prefixes in this case.

        Parameters:
        name - The name of the entity to reference.Unlike Document.createElementNS or Document.createAttributeNS, no namespace well-formed checking is done on the entity name. Applications should invoke Document.normalizeDocument() with the parameter " namespaces" set to true in order to ensure that the entity name is namespace well-formed.
        Returns:
        The new EntityReference object.
        Throws:
        DOMException - INVALID_CHARACTER_ERR: Raised if the specified name is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute.
        NOT_SUPPORTED_ERR: Raised if this document is an HTML document.

      • getElementsByTagName

        NodeList getElementsByTagName(String tagname)
        Returns a NodeList of all the Elements in document order with a given tag name and are contained in the document.
        Parameters:
        tagname - The name of the tag to match on. The special value "*" matches all tags. For XML, the tagname parameter is case-sensitive, otherwise it depends on the case-sensitivity of the markup language in use.
        Returns:
        A new NodeList object containing all the matched Elements.

      • importNode

        Node importNode(Node importedNode,
                boolean deep)
         throws DOMException
        Imports a node from another document to this document, without altering or removing the source node from the original document; this method creates a new copy of the source node. The returned node has no parent; (parentNode is null).
        For all nodes, importing a node creates a node object owned by the importing document, with attribute values identical to the source node's nodeName and nodeType, plus the attributes related to namespaces (prefix, localName, and namespaceURI). As in the cloneNode operation, the source node is not altered. User data associated to the imported node is not carried over. However, if any UserDataHandlers has been specified along with the associated data these handlers will be called with the appropriate parameters before this method returns.
        Additional information is copied as appropriate to the nodeType, attempting to mirror the behavior expected if a fragment of XML or HTML source was copied from one document to another, recognizing that the two documents may have different DTDs in the XML case. The following list describes the specifics for each type of node.
        ATTRIBUTE_NODE
        The ownerElement attribute is set to null and the specified flag is set to true on the generated Attr. The descendants of the source Attr are recursively imported and the resulting nodes reassembled to form the corresponding subtree. Note that the deep parameter has no effect on Attr nodes; they always carry their children with them when imported.
        DOCUMENT_FRAGMENT_NODE
        If the deep option was set to true, the descendants of the source DocumentFragment are recursively imported and the resulting nodes reassembled under the imported DocumentFragment to form the corresponding subtree. Otherwise, this simply generates an empty DocumentFragment.
        DOCUMENT_NODE
        Document nodes cannot be imported.
        DOCUMENT_TYPE_NODE
        DocumentType nodes cannot be imported.
        ELEMENT_NODE
        Specified attribute nodes of the source element are imported, and the generated Attr nodes are attached to the generated Element. Default attributes are not copied, though if the document being imported into defines default attributes for this element name, those are assigned. If the importNode deep parameter was set to true, the descendants of the source element are recursively imported and the resulting nodes reassembled to form the corresponding subtree.
        ENTITY_NODE
        Entity nodes can be imported, however in the current release of the DOM the DocumentType is readonly. Ability to add these imported nodes to a DocumentType will be considered for addition to a future release of the DOM.On import, the publicId, systemId, and notationName attributes are copied. If a deep import is requested, the descendants of the the source Entity are recursively imported and the resulting nodes reassembled to form the corresponding subtree.
        ENTITY_REFERENCE_NODE
        Only the EntityReference itself is copied, even if a deep import is requested, since the source and destination documents might have defined the entity differently. If the document being imported into provides a definition for this entity name, its value is assigned.
        NOTATION_NODE
        Notation nodes can be imported, however in the current release of the DOM the DocumentType is readonly. Ability to add these imported nodes to a DocumentType will be considered for addition to a future release of the DOM.On import, the publicId and systemId attributes are copied. Note that the deep parameter has no effect on this type of nodes since they cannot have any children.
        PROCESSING_INSTRUCTION_NODE
        The imported node copies its target and data values from those of the source node.Note that the deep parameter has no effect on this type of nodes since they cannot have any children.
        TEXT_NODE, CDATA_SECTION_NODE, COMMENT_NODE
        These three types of nodes inheriting from CharacterData copy their data and length attributes from those of the source node.Note that the deep parameter has no effect on these types of nodes since they cannot have any children.
        Parameters:
        importedNode - The node to import.
        deep - If true, recursively import the subtree under the specified node; if false, import only the node itself, as explained above. This has no effect on nodes that cannot have any children, and on Attr, and EntityReference nodes.
        Returns:
        The imported node that belongs to this Document.
        Throws:
        DOMException - NOT_SUPPORTED_ERR: Raised if the type of node being imported is not supported.
        INVALID_CHARACTER_ERR: Raised if one of the imported names is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute. This may happen when importing an XML 1.1 [XML 1.1] element into an XML 1.0 document, for instance.
        Since:
        DOM Level 2

      • createElementNS

        Element createElementNS(String namespaceURI,
                        String qualifiedName)
                 throws DOMException
        Creates an element of the given qualified name and namespace URI.
        Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.
        Parameters:
        namespaceURI - The namespace URI of the element to create.
        qualifiedName - The qualified name of the element type to instantiate.
        Returns:
        A new Element object with the following attributes:
        Attribute | Value
        Node.nodeName | qualifiedName
        Node.namespaceURI | namespaceURI
        Node.prefix | prefix, extracted from qualifiedName, or null if there is no prefix
        Node.localName | local name, extracted from qualifiedName
        Element.tagName | qualifiedName
        Throws:
        DOMException - INVALID_CHARACTER_ERR: Raised if the specified qualifiedName is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute.
        NAMESPACE_ERR: Raised if the qualifiedName is a malformed qualified name, if the qualifiedName has a prefix and the namespaceURI is null, or if the qualifiedName has a prefix that is "xml" and the namespaceURI is different from " http://www.w3.org/XML/1998/namespace" [XML Namespaces] , or if the qualifiedName or its prefix is "xmlns" and the namespaceURI is different from "http://www.w3.org/2000/xmlns/", or if the namespaceURI is "http://www.w3.org/2000/xmlns/" and neither the qualifiedName nor its prefix is "xmlns".
        NOT_SUPPORTED_ERR: Always thrown if the current document does not support the "XML" feature, since namespaces were defined by XML.
        Since:
        DOM Level 2

      • createAttributeNS

        Attr createAttributeNS(String namespaceURI,
                       String qualifiedName)
                throws DOMException
        Creates an attribute of the given qualified name and namespace URI.
        Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.
        Parameters:
        namespaceURI - The namespace URI of the attribute to create.
        qualifiedName - The qualified name of the attribute to instantiate.
        Returns:
        A new Attr object with the following attributes:
        Attribute | Value
        Node.nodeName | qualifiedName
        Node.namespaceURI | namespaceURI
        Node.prefix | prefix, extracted from qualifiedName, or null if there is no prefix
        Node.localName | local name, extracted from qualifiedName
        Attr.name | qualifiedName
        Node.nodeValue | the empty string
        Throws:
        DOMException - INVALID_CHARACTER_ERR: Raised if the specified qualifiedName is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute.
        NAMESPACE_ERR: Raised if the qualifiedName is a malformed qualified name, if the qualifiedName has a prefix and the namespaceURI is null, if the qualifiedName has a prefix that is "xml" and the namespaceURI is different from " http://www.w3.org/XML/1998/namespace", if the qualifiedName or its prefix is "xmlns" and the namespaceURI is different from "http://www.w3.org/2000/xmlns/", or if the namespaceURI is "http://www.w3.org/2000/xmlns/" and neither the qualifiedName nor its prefix is "xmlns".
        NOT_SUPPORTED_ERR: Always thrown if the current document does not support the "XML" feature, since namespaces were defined by XML.
        Since:
        DOM Level 2

      • getElementsByTagNameNS

        NodeList getElementsByTagNameNS(String namespaceURI,
                                String localName)
        Returns a NodeList of all the Elements with a given local name and namespace URI in document order.
        Parameters:
        namespaceURI - The namespace URI of the elements to match on. The special value "*" matches all namespaces.
        localName - The local name of the elements to match on. The special value "*" matches all local names.
        Returns:
        A new NodeList object containing all the matched Elements.
        Since:
        DOM Level 2

      • getElementById

        Element getElementById(String elementId)
        Returns the Element that has an ID attribute with the given value. If no such element exists, this returns null . If more than one element has an ID attribute with that value, what is returned is undefined.
        The DOM implementation is expected to use the attribute Attr.isId to determine if an attribute is of type ID.

        Note: Attributes with the name "ID" or "id" are not of type ID unless so defined.

        Parameters:
        elementId - The unique id value for an element.
        Returns:
        The matching element or null if there is none.
        Since:
        DOM Level 2

      • getInputEncoding

        String getInputEncoding()
        An attribute specifying the encoding used for this document at the time of the parsing. This is null when it is not known, such as when the Document was created in memory.
        Since:
        DOM Level 3

      • getXmlEncoding

        String getXmlEncoding()
        An attribute specifying, as part of the XML declaration, the encoding of this document. This is null when unspecified or when it is not known, such as when the Document was created in memory.
        Since:
        DOM Level 3

      • getXmlStandalone

        boolean getXmlStandalone()
        An attribute specifying, as part of the XML declaration, whether this document is standalone. This is false when unspecified.

        Note: No verification is done on the value when setting this attribute. Applications should use Document.normalizeDocument() with the "validate" parameter to verify if the value matches the validity constraint for standalone document declaration as defined in [XML 1.0].

        Since:
        DOM Level 3

      • setXmlStandalone

        void setXmlStandalone(boolean xmlStandalone)
               throws DOMException
        An attribute specifying, as part of the XML declaration, whether this document is standalone. This is false when unspecified.

        Note: No verification is done on the value when setting this attribute. Applications should use Document.normalizeDocument() with the "validate" parameter to verify if the value matches the validity constraint for standalone document declaration as defined in [XML 1.0].

        Throws:
        DOMException - NOT_SUPPORTED_ERR: Raised if this document does not support the "XML" feature.
        Since:
        DOM Level 3

      • getXmlVersion

        String getXmlVersion()
        An attribute specifying, as part of the XML declaration, the version number of this document. If there is no declaration and if this document supports the "XML" feature, the value is "1.0". If this document does not support the "XML" feature, the value is always null. Changing this attribute will affect methods that check for invalid characters in XML names. Application should invoke Document.normalizeDocument() in order to check for invalid characters in the Nodes that are already part of this Document.
        DOM applications may use the DOMImplementation.hasFeature(feature, version) method with parameter values "XMLVersion" and "1.0" (respectively) to determine if an implementation supports [XML 1.0]. DOM applications may use the same method with parameter values "XMLVersion" and "1.1" (respectively) to determine if an implementation supports [XML 1.1]. In both cases, in order to support XML, an implementation must also support the "XML" feature defined in this specification. Document objects supporting a version of the "XMLVersion" feature must not raise a NOT_SUPPORTED_ERR exception for the same version number when using Document.xmlVersion.
        Since:
        DOM Level 3

      • setXmlVersion

        void setXmlVersion(String xmlVersion)
            throws DOMException
        An attribute specifying, as part of the XML declaration, the version number of this document. If there is no declaration and if this document supports the "XML" feature, the value is "1.0". If this document does not support the "XML" feature, the value is always null. Changing this attribute will affect methods that check for invalid characters in XML names. Application should invoke Document.normalizeDocument() in order to check for invalid characters in the Nodes that are already part of this Document.
        DOM applications may use the DOMImplementation.hasFeature(feature, version) method with parameter values "XMLVersion" and "1.0" (respectively) to determine if an implementation supports [XML 1.0]. DOM applications may use the same method with parameter values "XMLVersion" and "1.1" (respectively) to determine if an implementation supports [XML 1.1]. In both cases, in order to support XML, an implementation must also support the "XML" feature defined in this specification. Document objects supporting a version of the "XMLVersion" feature must not raise a NOT_SUPPORTED_ERR exception for the same version number when using Document.xmlVersion.
        Throws:
        DOMException - NOT_SUPPORTED_ERR: Raised if the version is set to a value that is not supported by this Document or if this document does not support the "XML" feature.
        Since:
        DOM Level 3

      • getStrictErrorChecking

        boolean getStrictErrorChecking()
        An attribute specifying whether error checking is enforced or not. When set to false, the implementation is free to not test every possible error case normally defined on DOM operations, and not raise any DOMException on DOM operations or report errors while using Document.normalizeDocument(). In case of error, the behavior is undefined. This attribute is true by default.
        Since:
        DOM Level 3

      • setStrictErrorChecking

        void setStrictErrorChecking(boolean strictErrorChecking)
        An attribute specifying whether error checking is enforced or not. When set to false, the implementation is free to not test every possible error case normally defined on DOM operations, and not raise any DOMException on DOM operations or report errors while using Document.normalizeDocument(). In case of error, the behavior is undefined. This attribute is true by default.
        Since:
        DOM Level 3

      • getDocumentURI

        String getDocumentURI()
        The location of the document or null if undefined or if the Document was created using DOMImplementation.createDocument. No lexical checking is performed when setting this attribute; this could result in a null value returned when using Node.baseURI .
        Beware that when the Document supports the feature "HTML" [DOM Level 2 HTML] , the href attribute of the HTML BASE element takes precedence over this attribute when computing Node.baseURI.
        Since:
        DOM Level 3

      • setDocumentURI

        void setDocumentURI(String documentURI)
        The location of the document or null if undefined or if the Document was created using DOMImplementation.createDocument. No lexical checking is performed when setting this attribute; this could result in a null value returned when using Node.baseURI .
        Beware that when the Document supports the feature "HTML" [DOM Level 2 HTML] , the href attribute of the HTML BASE element takes precedence over this attribute when computing Node.baseURI.
        Since:
        DOM Level 3

      • adoptNode

        Node adoptNode(Node source)
        throws DOMException
        Attempts to adopt a node from another document to this document. If supported, it changes the ownerDocument of the source node, its children, as well as the attached attribute nodes if there are any. If the source node has a parent it is first removed from the child list of its parent. This effectively allows moving a subtree from one document to another (unlike importNode() which create a copy of the source node instead of moving it). When it fails, applications should use Document.importNode() instead. Note that if the adopted node is already part of this document (i.e. the source and target document are the same), this method still has the effect of removing the source node from the child list of its parent, if any. The following list describes the specifics for each type of node.
        ATTRIBUTE_NODE
        The ownerElement attribute is set to null and the specified flag is set to true on the adopted Attr. The descendants of the source Attr are recursively adopted.
        DOCUMENT_FRAGMENT_NODE
        The descendants of the source node are recursively adopted.
        DOCUMENT_NODE
        Document nodes cannot be adopted.
        DOCUMENT_TYPE_NODE
        DocumentType nodes cannot be adopted.
        ELEMENT_NODE
        Specified attribute nodes of the source element are adopted. Default attributes are discarded, though if the document being adopted into defines default attributes for this element name, those are assigned. The descendants of the source element are recursively adopted.
        ENTITY_NODE
        Entity nodes cannot be adopted.
        ENTITY_REFERENCE_NODE
        Only the EntityReference node itself is adopted, the descendants are discarded, since the source and destination documents might have defined the entity differently. If the document being imported into provides a definition for this entity name, its value is assigned.
        NOTATION_NODE
        Notation nodes cannot be adopted.
        PROCESSING_INSTRUCTION_NODE, TEXT_NODE, CDATA_SECTION_NODE, COMMENT_NODE
        These nodes can all be adopted. No specifics.

        Note: Since it does not create new nodes unlike the Document.importNode() method, this method does not raise an INVALID_CHARACTER_ERR exception, and applications should use the Document.normalizeDocument() method to check if an imported name is not an XML name according to the XML version in use.

        Parameters:
        source - The node to move into this document.
        Returns:
        The adopted node, or null if this operation fails, such as when the source node comes from a different implementation.
        Throws:
        DOMException - NOT_SUPPORTED_ERR: Raised if the source node is of type DOCUMENT, DOCUMENT_TYPE.
        NO_MODIFICATION_ALLOWED_ERR: Raised when the source node is readonly.
        Since:
        DOM Level 3

      • getDomConfig

        DOMConfiguration getDomConfig()
        The configuration used when Document.normalizeDocument() is invoked.
        Since:
        DOM Level 3

      • normalizeDocument

        void normalizeDocument()
        This method acts as if the document was going through a save and load cycle, putting the document in a "normal" form. As a consequence, this method updates the replacement tree of EntityReference nodes and normalizes Text nodes, as defined in the method Node.normalize().
        Otherwise, the actual result depends on the features being set on the Document.domConfig object and governing what operations actually take place. Noticeably this method could also make the document namespace well-formed according to the algorithm described in , check the character normalization, remove the CDATASection nodes, etc. See DOMConfiguration for details.
        // Keep in the document
 the information defined // in the XML Information Set (Java example)
 DOMConfiguration docConfig = myDocument.getDomConfig();
 docConfig.setParameter("infoset", Boolean.TRUE);
 myDocument.normalizeDocument();

        Mutation events, when supported, are generated to reflect the changes occurring on the document.
        If errors occur during the invocation of this method, such as an attempt to update a read-only node or a Node.nodeName contains an invalid character according to the XML version in use, errors or warnings (DOMError.SEVERITY_ERROR or DOMError.SEVERITY_WARNING) will be reported using the DOMErrorHandler object associated with the "error-handler " parameter. Note this method might also report fatal errors ( DOMError.SEVERITY_FATAL_ERROR) if an implementation cannot recover from an error.
        Since:
        DOM Level 3

      • renameNode

        Node renameNode(Node n,
                String namespaceURI,
                String qualifiedName)
         throws DOMException
        Rename an existing node of type ELEMENT_NODE or ATTRIBUTE_NODE.
        When possible this simply changes the name of the given node, otherwise this creates a new node with the specified name and replaces the existing node with the new node as described below.
        If simply changing the name of the given node is not possible, the following operations are performed: a new node is created, any registered event listener is registered on the new node, any user data attached to the old node is removed from that node, the old node is removed from its parent if it has one, the children are moved to the new node, if the renamed node is an Element its attributes are moved to the new node, the new node is inserted at the position the old node used to have in its parent's child nodes list if it has one, the user data that was attached to the old node is attached to the new node.
        When the node being renamed is an Element only the specified attributes are moved, default attributes originated from the DTD are updated according to the new element name. In addition, the implementation may update default attributes from other schemas. Applications should use Document.normalizeDocument() to guarantee these attributes are up-to-date.
        When the node being renamed is an Attr that is attached to an Element, the node is first removed from the Element attributes map. Then, once renamed, either by modifying the existing node or creating a new one as described above, it is put back.
        In addition,
        • a user data event NODE_RENAMED is fired,
        • when the implementation supports the feature "MutationNameEvents", each mutation operation involved in this method fires the appropriate event, and in the end the event { http://www.w3.org/2001/xml-events, DOMElementNameChanged} or { http://www.w3.org/2001/xml-events, DOMAttributeNameChanged} is fired.
        Parameters:
        n - The node to rename.
        namespaceURI - The new namespace URI.
        qualifiedName - The new qualified name.
        Returns:
        The renamed node. This is either the specified node or the new node that was created to replace the specified node.
        Throws:
        DOMException - NOT_SUPPORTED_ERR: Raised when the type of the specified node is neither ELEMENT_NODE nor ATTRIBUTE_NODE, or if the implementation does not support the renaming of the document element.
        INVALID_CHARACTER_ERR: Raised if the new qualified name is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute.
        WRONG_DOCUMENT_ERR: Raised when the specified node was created from a different document than this document.
        NAMESPACE_ERR: Raised if the qualifiedName is a malformed qualified name, if the qualifiedName has a prefix and the namespaceURI is null, or if the qualifiedName has a prefix that is "xml" and the namespaceURI is different from " http://www.w3.org/XML/1998/namespace" [XML Namespaces] . Also raised, when the node being renamed is an attribute, if the qualifiedName, or its prefix, is "xmlns" and the namespaceURI is different from "http://www.w3.org/2000/xmlns/".
        Since:
        DOM Level 3
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DocumentFragment (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface DocumentFragment

  • All Superinterfaces:
    Node

    public interface DocumentFragment
extends Node
    DocumentFragment is a "lightweight" or "minimal" Document object. It is very common to want to be able to extract a portion of a document's tree or to create a new fragment of a document. Imagine implementing a user command like cut or rearranging a document by moving fragments around. It is desirable to have an object which can hold such fragments and it is quite natural to use a Node for this purpose. While it is true that a Document object could fulfill this role, a Document object can potentially be a heavyweight object, depending on the underlying implementation. What is really needed for this is a very lightweight object. DocumentFragment is such an object.

    Furthermore, various operations -- such as inserting nodes as children of another Node -- may take DocumentFragment objects as arguments; this results in all the child nodes of the DocumentFragment being moved to the child list of this node.

    The children of a DocumentFragment node are zero or more nodes representing the tops of any sub-trees defining the structure of the document. DocumentFragment nodes do not need to be well-formed XML documents (although they do need to follow the rules imposed upon well-formed XML parsed entities, which can have multiple top nodes). For example, a DocumentFragment might have only one child and that child node could be a Text node. Such a structure model represents neither an HTML document nor a well-formed XML document.

    When a DocumentFragment is inserted into a Document (or indeed any other Node that may take children) the children of the DocumentFragment and not the DocumentFragment itself are inserted into the Node. This makes the DocumentFragment very useful when the user wishes to create nodes that are siblings; the DocumentFragment acts as the parent of these nodes so that the user can use the standard methods from the Node interface, such as Node.insertBefore and Node.appendChild.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DocumentType (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface DocumentType

  • All Superinterfaces:
    Node

    public interface DocumentType
extends Node
    Each Document has a doctype attribute whose value is either null or a DocumentType object. The DocumentType interface in the DOM Core provides an interface to the list of entities that are defined for the document, and little else because the effect of namespaces and the various XML schema efforts on DTD representation are not clearly understood as of this writing.

    DOM Level 3 doesn't support editing DocumentType nodes. DocumentType nodes are read-only.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      NamedNodeMap getEntities()
      A NamedNodeMap containing the general entities, both external and internal, declared in the DTD.
      String getInternalSubset()
      The internal subset as a string, or null if there is none.
      String getName()
      The name of DTD; i.e., the name immediately following the DOCTYPE keyword.
      NamedNodeMap getNotations()
      A NamedNodeMap containing the notations declared in the DTD.
      String getPublicId()
      The public identifier of the external subset.
      String getSystemId()
      The system identifier of the external subset.

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • Method Detail

      • getName

        String getName()
        The name of DTD; i.e., the name immediately following the DOCTYPE keyword.

      • getEntities

        NamedNodeMap getEntities()
        A NamedNodeMap containing the general entities, both external and internal, declared in the DTD. Parameter entities are not contained. Duplicates are discarded. For example in:
        <!DOCTYPE
 ex SYSTEM "ex.dtd" [ <!ENTITY foo "foo"> <!ENTITY bar
 "bar"> <!ENTITY bar "bar2"> <!ENTITY % baz "baz">
 ]> <ex/>
        the interface provides access to foo and the first declaration of bar but not the second declaration of bar or baz. Every node in this map also implements the Entity interface.
        The DOM Level 2 does not support editing entities, therefore entities cannot be altered in any way.

      • getNotations

        NamedNodeMap getNotations()
        A NamedNodeMap containing the notations declared in the DTD. Duplicates are discarded. Every node in this map also implements the Notation interface.
        The DOM Level 2 does not support editing notations, therefore notations cannot be altered in any way.

      • getPublicId

        String getPublicId()
        The public identifier of the external subset.
        Since:
        DOM Level 2

      • getSystemId

        String getSystemId()
        The system identifier of the external subset. This may be an absolute URI or not.
        Since:
        DOM Level 2

      • getInternalSubset

        String getInternalSubset()
        The internal subset as a string, or null if there is none. This is does not contain the delimiting square brackets.

        Note: The actual content returned depends on how much information is available to the implementation. This may vary depending on various parameters, including the XML processor used to build the document.

        Since:
        DOM Level 2
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DOMConfiguration (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface DOMConfiguration

  • public interface DOMConfiguration
    The DOMConfiguration interface represents the configuration of a document and maintains a table of recognized parameters. Using the configuration, it is possible to change Document.normalizeDocument() behavior, such as replacing the CDATASection nodes with Text nodes or specifying the type of the schema that must be used when the validation of the Document is requested. DOMConfiguration objects are also used in [DOM Level 3 Load and Save] in the DOMParser and DOMSerializer interfaces.

    The parameter names used by the DOMConfiguration object are defined throughout the DOM Level 3 specifications. Names are case-insensitive. To avoid possible conflicts, as a convention, names referring to parameters defined outside the DOM specification should be made unique. Because parameters are exposed as properties in names are recommended to follow the section 5.16 Identifiers of [Unicode] with the addition of the character '-' (HYPHEN-MINUS) but it is not enforced by the DOM implementation. DOM Level 3 Core Implementations are required to recognize all parameters defined in this specification. Some parameter values may also be required to be supported by the implementation. Refer to the definition of the parameter to know if a value must be supported or not.

    Note: Parameters are similar to features and properties used in SAX2 [SAX].

    The following list of parameters defined in the DOM:

    "canonical-form"
    true
    [optional] Canonicalize the document according to the rules specified in [Canonical XML], such as removing the DocumentType node (if any) from the tree, or removing superfluous namespace declarations from each element. Note that this is limited to what can be represented in the DOM; in particular, there is no way to specify the order of the attributes in the DOM. In addition, Setting this parameter to true will also set the state of the parameters listed below. Later changes to the state of one of those parameters will revert "canonical-form" back to false. Parameters set to false: "entities", " normalize-characters", "cdata-sections". Parameters set to true: "namespaces", "namespace-declarations", "well-formed", "element-content-whitespace". Other parameters are not changed unless explicitly specified in the description of the parameters.
    false
    [required] (default)Do not canonicalize the document.
    "cdata-sections"
    true
    [required] (default)Keep CDATASection nodes in the document.
    false
    [required]Transform CDATASection nodes in the document into Text nodes. The new Text node is then combined with any adjacent Text node.
    "check-character-normalization"
    true
    [optional] Check if the characters in the document are fully normalized, as defined in appendix B of [XML 1.1]. When a sequence of characters is encountered that fails normalization checking, an error with the DOMError.type equals to "check-character-normalization-failure" is issued.
    false
    [required] (default)Do not check if characters are normalized.
    "comments"
    true
    [required] (default)Keep Comment nodes in the document.
    false
    [required]Discard Comment nodes in the document.
    "datatype-normalization"
    true
    [optional] Expose schema normalized values in the tree, such as XML Schema normalized values in the case of XML Schema. Since this parameter requires to have schema information, the "validate" parameter will also be set to true. Having this parameter activated when "validate" is false has no effect and no schema-normalization will happen.

    Note: Since the document contains the result of the XML 1.0 processing, this parameter does not apply to attribute value normalization as defined in section 3.3.3 of [XML 1.0] and is only meant for schema languages other than Document Type Definition (DTD).

    false
    [required] (default) Do not perform schema normalization on the tree.
    "element-content-whitespace"
    true
    [required] (default)Keep all whitespaces in the document.
    false
    [optional] Discard all Text nodes that contain whitespaces in element content, as described in [element content whitespace]. The implementation is expected to use the attribute Text.isElementContentWhitespace to determine if a Text node should be discarded or not.
    "entities"
    true
    [required] (default)Keep EntityReference nodes in the document.
    false
    [required] Remove all EntityReference nodes from the document, putting the entity expansions directly in their place. Text nodes are normalized, as defined in Node.normalize. Only unexpanded entity references are kept in the document.

    Note: This parameter does not affect Entity nodes.

    "error-handler"
    [required] Contains a DOMErrorHandler object. If an error is encountered in the document, the implementation will call back the DOMErrorHandler registered using this parameter. The implementation may provide a default DOMErrorHandler object. When called, DOMError.relatedData will contain the closest node to where the error occurred. If the implementation is unable to determine the node where the error occurs, DOMError.relatedData will contain the Document node. Mutations to the document from within an error handler will result in implementation dependent behavior.
    "infoset"
    true
    [required]Keep in the document the information defined in the XML Information Set [XML Information Set] .This forces the following parameters to false: " validate-if-schema", "entities", "datatype-normalization", "cdata-sections ".This forces the following parameters to true: " namespace-declarations", "well-formed", "element-content-whitespace", " comments", "namespaces".Other parameters are not changed unless explicitly specified in the description of the parameters. Note that querying this parameter with getParameter returns true only if the individual parameters specified above are appropriately set.
    false
    Setting infoset to false has no effect.
    "namespaces"
    true
    [required] (default) Perform the namespace processing as defined in .
    false
    [optional] Do not perform the namespace processing.
    "namespace-declarations"
    This parameter has no effect if the parameter "namespaces" is set to false.
    true
    [required] (default) Include namespace declaration attributes, specified or defaulted from the schema, in the document. See also the sections "Declaring Namespaces" in [XML Namespaces] and [XML Namespaces 1.1] .
    false
    [required]Discard all namespace declaration attributes. The namespace prefixes ( Node.prefix) are retained even if this parameter is set to false.
    "normalize-characters"
    true
    [optional] Fully normalized the characters in the document as defined in appendix B of [XML 1.1].
    false
    [required] (default)Do not perform character normalization.
    "schema-location"
    [optional] Represent a DOMString object containing a list of URIs, separated by whitespaces (characters matching the nonterminal production S defined in section 2.3 [XML 1.0]), that represents the schemas against which validation should occur, i.e. the current schema. The types of schemas referenced in this list must match the type specified with schema-type, otherwise the behavior of an implementation is undefined. The schemas specified using this property take precedence to the schema information specified in the document itself. For namespace aware schema, if a schema specified using this property and a schema specified in the document instance (i.e. using the schemaLocation attribute) in a schema document (i.e. using schema import mechanisms) share the same targetNamespace, the schema specified by the user using this property will be used. If two schemas specified using this property share the same targetNamespace or have no namespace, the behavior is implementation dependent. If no location has been provided, this parameter is null.

    Note: The "schema-location" parameter is ignored unless the "schema-type" parameter value is set. It is strongly recommended that Document.documentURI will be set so that an implementation can successfully resolve any external entities referenced.

    "schema-type"
    [optional] Represent a DOMString object containing an absolute URI and representing the type of the schema language used to validate a document against. Note that no lexical checking is done on the absolute URI. If this parameter is not set, a default value may be provided by the implementation, based on the schema languages supported and on the schema language used at load time. If no value is provided, this parameter is null.

    Note: For XML Schema [XML Schema Part 1] , applications must use the value "http://www.w3.org/2001/XMLSchema". For XML DTD [XML 1.0], applications must use the value "http://www.w3.org/TR/REC-xml". Other schema languages are outside the scope of the W3C and therefore should recommend an absolute URI in order to use this method.

    "split-cdata-sections"
    true
    [required] (default)Split CDATA sections containing the CDATA section termination marker ']]>'. When a CDATA section is split a warning is issued with a DOMError.type equals to "cdata-sections-splitted" and DOMError.relatedData equals to the first CDATASection node in document order resulting from the split.
    false
    [required]Signal an error if a CDATASection contains an unrepresentable character.
    "validate"
    true
    [optional] Require the validation against a schema (i.e. XML schema, DTD, any other type or representation of schema) of the document as it is being normalized as defined by [XML 1.0]. If validation errors are found, or no schema was found, the error handler is notified. Schema-normalized values will not be exposed according to the schema in used unless the parameter "datatype-normalization" is true. This parameter will reevaluate:
    • Attribute nodes with Attr.specified equals to false, as specified in the description of the Attr interface;
    • The value of the attribute Text.isElementContentWhitespace for all Text nodes;
    • The value of the attribute Attr.isId for all Attr nodes;
    • The attributes Element.schemaTypeInfo and Attr.schemaTypeInfo.

    Note: "validate-if-schema" and "validate" are mutually exclusive, setting one of them to true will set the other one to false. Applications should also consider setting the parameter "well-formed" to true, which is the default for that option, when validating the document.

    false
    [required] (default) Do not accomplish schema processing, including the internal subset processing. Default attribute values information are kept. Note that validation might still happen if "validate-if-schema" is true .
    "validate-if-schema"
    true
    [optional]Enable validation only if a declaration for the document element can be found in a schema (independently of where it is found, i.e. XML schema, DTD, or any other type or representation of schema). If validation is enabled, this parameter has the same behavior as the parameter "validate" set to true.

    Note: "validate-if-schema" and "validate" are mutually exclusive, setting one of them to true will set the other one to false.

    false
    [required] (default) No schema processing should be performed if the document has a schema, including internal subset processing. Default attribute values information are kept. Note that validation must still happen if "validate " is true.
    "well-formed"
    true
    [required] (default) Check if all nodes are XML well formed according to the XML version in use in Document.xmlVersion:
    • check if the attribute Node.nodeName contains invalid characters according to its node type and generate a DOMError of type "wf-invalid-character-in-node-name", with a DOMError.SEVERITY_ERROR severity, if necessary;
    • check if the text content inside Attr, Element, Comment, Text, CDATASection nodes for invalid characters and generate a DOMError of type "wf-invalid-character", with a DOMError.SEVERITY_ERROR severity, if necessary;
    • check if the data inside ProcessingInstruction nodes for invalid characters and generate a DOMError of type "wf-invalid-character", with a DOMError.SEVERITY_ERROR severity, if necessary;
    false
    [optional] Do not check for XML well-formedness.

    The resolution of the system identifiers associated with entities is done using Document.documentURI. However, when the feature "LS" defined in [DOM Level 3 Load and Save] is supported by the DOM implementation, the parameter "resource-resolver" can also be used on DOMConfiguration objects attached to Document nodes. If this parameter is set, Document.normalizeDocument() will invoke the resource resolver instead of using Document.documentURI.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    Since:
    DOM Level 3

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      boolean canSetParameter(String name, Object value)
      Check if setting a parameter to a specific value is supported.
      Object getParameter(String name)
      Return the value of a parameter if known.
      DOMStringList getParameterNames()
      The list of the parameters supported by this DOMConfiguration object and for which at least one value can be set by the application.
      void setParameter(String name, Object value)
      Set the value of a parameter.

    • Method Detail

      • setParameter

        void setParameter(String name,
                  Object value)
           throws DOMException
        Set the value of a parameter.
        Parameters:
        name - The name of the parameter to set.
        value - The new value or null if the user wishes to unset the parameter. While the type of the value parameter is defined as DOMUserData, the object type must match the type defined by the definition of the parameter. For example, if the parameter is "error-handler", the value must be of type DOMErrorHandler.
        Throws:
        DOMException - NOT_FOUND_ERR: Raised when the parameter name is not recognized.
        NOT_SUPPORTED_ERR: Raised when the parameter name is recognized but the requested value cannot be set.
        TYPE_MISMATCH_ERR: Raised if the value type for this parameter name is incompatible with the expected value type.

      • getParameter

        Object getParameter(String name)
             throws DOMException
        Return the value of a parameter if known.
        Parameters:
        name - The name of the parameter.
        Returns:
        The current object associated with the specified parameter or null if no object has been associated or if the parameter is not supported.
        Throws:
        DOMException - NOT_FOUND_ERR: Raised when the parameter name is not recognized.

      • canSetParameter

        boolean canSetParameter(String name,
                        Object value)
        Check if setting a parameter to a specific value is supported.
        Parameters:
        name - The name of the parameter to check.
        value - An object. if null, the returned value is true.
        Returns:
        true if the parameter could be successfully set to the specified value, or false if the parameter is not recognized or the requested value is not supported. This does not change the current value of the parameter itself.

      • getParameterNames

        DOMStringList getParameterNames()
        The list of the parameters supported by this DOMConfiguration object and for which at least one value can be set by the application. Note that this list can also contain parameter names defined outside this specification.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DOMError (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface DOMError

  • public interface DOMError
    DOMError is an interface that describes an error.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    Since:
    DOM Level 3

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short SEVERITY_ERROR
      The severity of the error described by the DOMError is error.
      static short SEVERITY_FATAL_ERROR
      The severity of the error described by the DOMError is fatal error.
      static short SEVERITY_WARNING
      The severity of the error described by the DOMError is warning.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      DOMLocator getLocation()
      The location of the error.
      String getMessage()
      An implementation specific string describing the error that occurred.
      Object getRelatedData()
      The related DOMError.type dependent data if any.
      Object getRelatedException()
      The related platform dependent exception if any.
      short getSeverity()
      The severity of the error, either SEVERITY_WARNING, SEVERITY_ERROR, or SEVERITY_FATAL_ERROR.
      String getType()
      A DOMString indicating which related data is expected in relatedData.

    • Field Detail

      • SEVERITY_WARNING

        static final short SEVERITY_WARNING
        The severity of the error described by the DOMError is warning. A SEVERITY_WARNING will not cause the processing to stop, unless DOMErrorHandler.handleError() returns false.
        See Also:
        Constant Field Values

      • SEVERITY_ERROR

        static final short SEVERITY_ERROR
        The severity of the error described by the DOMError is error. A SEVERITY_ERROR may not cause the processing to stop if the error can be recovered, unless DOMErrorHandler.handleError() returns false.
        See Also:
        Constant Field Values

      • SEVERITY_FATAL_ERROR

        static final short SEVERITY_FATAL_ERROR
        The severity of the error described by the DOMError is fatal error. A SEVERITY_FATAL_ERROR will cause the normal processing to stop. The return value of DOMErrorHandler.handleError() is ignored unless the implementation chooses to continue, in which case the behavior becomes undefined.
        See Also:
        Constant Field Values

    • Method Detail

      • getSeverity

        short getSeverity()
        The severity of the error, either SEVERITY_WARNING, SEVERITY_ERROR, or SEVERITY_FATAL_ERROR.

      • getMessage

        String getMessage()
        An implementation specific string describing the error that occurred.

      • getType

        String getType()
        A DOMString indicating which related data is expected in relatedData. Users should refer to the specification of the error in order to find its DOMString type and relatedData definitions if any.

        Note: As an example, Document.normalizeDocument() does generate warnings when the "split-cdata-sections" parameter is in use. Therefore, the method generates a SEVERITY_WARNING with type "cdata-sections-splitted" and the first CDATASection node in document order resulting from the split is returned by the relatedData attribute.

      • getRelatedException

        Object getRelatedException()
        The related platform dependent exception if any.

      • getRelatedData

        Object getRelatedData()
        The related DOMError.type dependent data if any.

      • getLocation

        DOMLocator getLocation()
        The location of the error.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DOMErrorHandler (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface DOMErrorHandler

  • public interface DOMErrorHandler
    DOMErrorHandler is a callback interface that the DOM implementation can call when reporting errors that happens while processing XML data, or when doing some other processing (e.g. validating a document). A DOMErrorHandler object can be attached to a Document using the "error-handler" on the DOMConfiguration interface. If more than one error needs to be reported during an operation, the sequence and numbers of the errors passed to the error handler are implementation dependent.

    The application that is using the DOM implementation is expected to implement this interface.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    Since:
    DOM Level 3

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      boolean handleError(DOMError error)
      This method is called on the error handler when an error occurs.

    • Method Detail

      • handleError

        boolean handleError(DOMError error)
        This method is called on the error handler when an error occurs.
        If an exception is thrown from this method, it is considered to be equivalent of returning true.
        Parameters:
        error - The error object that describes the error. This object may be reused by the DOM implementation across multiple calls to the handleError method.
        Returns:
        If the handleError method returns false, the DOM implementation should stop the current processing when possible. If the method returns true, the processing may continue depending on DOMError.severity.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DOMException (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Class DOMException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.w3c.dom.DOMException
  • All Implemented Interfaces:
    Serializable

    public class DOMException
extends RuntimeException
    DOM operations only raise exceptions in "exceptional" circumstances, i.e., when an operation is impossible to perform (either for logical reasons, because data is lost, or because the implementation has become unstable). In general, DOM methods return specific error values in ordinary processing situations, such as out-of-bound errors when using NodeList.

    Implementations should raise other exceptions under other circumstances. For example, implementations should raise an implementation-dependent exception if a null argument is passed when null was not expected.

    Some languages and object systems do not support the concept of exceptions. For such systems, error conditions may be indicated using native error reporting mechanisms. For some bindings, for example, methods may return error codes similar to those listed in the corresponding method descriptions.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    See Also:
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      short | code
      static short DOMSTRING_SIZE_ERR
      If the specified range of text does not fit into a DOMString.
      static short HIERARCHY_REQUEST_ERR
      If any Node is inserted somewhere it doesn't belong.
      static short INDEX_SIZE_ERR
      If index or size is negative, or greater than the allowed value.
      static short INUSE_ATTRIBUTE_ERR
      If an attempt is made to add an attribute that is already in use elsewhere.
      static short INVALID_ACCESS_ERR
      If a parameter or an operation is not supported by the underlying object.
      static short INVALID_CHARACTER_ERR
      If an invalid or illegal character is specified, such as in an XML name.
      static short INVALID_MODIFICATION_ERR
      If an attempt is made to modify the type of the underlying object.
      static short INVALID_STATE_ERR
      If an attempt is made to use an object that is not, or is no longer, usable.
      static short NAMESPACE_ERR
      If an attempt is made to create or change an object in a way which is incorrect with regard to namespaces.
      static short NO_DATA_ALLOWED_ERR
      If data is specified for a Node which does not support data.
      static short NO_MODIFICATION_ALLOWED_ERR
      If an attempt is made to modify an object where modifications are not allowed.
      static short NOT_FOUND_ERR
      If an attempt is made to reference a Node in a context where it does not exist.
      static short NOT_SUPPORTED_ERR
      If the implementation does not support the requested type of object or operation.
      static short SYNTAX_ERR
      If an invalid or illegal string is specified.
      static short TYPE_MISMATCH_ERR
      If the type of an object is incompatible with the expected type of the parameter associated to the object.
      static short VALIDATION_ERR
      If a call to a method such as insertBefore or removeChild would make the Node invalid with respect to "partial validity", this exception would be raised and the operation would not be done.
      static short WRONG_DOCUMENT_ERR
      If a Node is used in a different document than the one that created it (that doesn't support it).

    • Constructor Summary

      Constructors
      Constructor and Description
      DOMException(short code, String message)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • code

        public short code

      • INDEX_SIZE_ERR

        public static final short INDEX_SIZE_ERR
        If index or size is negative, or greater than the allowed value.
        See Also:
        Constant Field Values

      • DOMSTRING_SIZE_ERR

        public static final short DOMSTRING_SIZE_ERR
        If the specified range of text does not fit into a DOMString.
        See Also:
        Constant Field Values

      • HIERARCHY_REQUEST_ERR

        public static final short HIERARCHY_REQUEST_ERR
        If any Node is inserted somewhere it doesn't belong.
        See Also:
        Constant Field Values

      • WRONG_DOCUMENT_ERR

        public static final short WRONG_DOCUMENT_ERR
        If a Node is used in a different document than the one that created it (that doesn't support it).
        See Also:
        Constant Field Values

      • INVALID_CHARACTER_ERR

        public static final short INVALID_CHARACTER_ERR
        If an invalid or illegal character is specified, such as in an XML name.
        See Also:
        Constant Field Values

      • NO_DATA_ALLOWED_ERR

        public static final short NO_DATA_ALLOWED_ERR
        If data is specified for a Node which does not support data.
        See Also:
        Constant Field Values

      • NO_MODIFICATION_ALLOWED_ERR

        public static final short NO_MODIFICATION_ALLOWED_ERR
        If an attempt is made to modify an object where modifications are not allowed.
        See Also:
        Constant Field Values

      • NOT_FOUND_ERR

        public static final short NOT_FOUND_ERR
        If an attempt is made to reference a Node in a context where it does not exist.
        See Also:
        Constant Field Values

      • NOT_SUPPORTED_ERR

        public static final short NOT_SUPPORTED_ERR
        If the implementation does not support the requested type of object or operation.
        See Also:
        Constant Field Values

      • INUSE_ATTRIBUTE_ERR

        public static final short INUSE_ATTRIBUTE_ERR
        If an attempt is made to add an attribute that is already in use elsewhere.
        See Also:
        Constant Field Values

      • INVALID_STATE_ERR

        public static final short INVALID_STATE_ERR
        If an attempt is made to use an object that is not, or is no longer, usable.
        Since:
        DOM Level 2
        See Also:
        Constant Field Values

      • SYNTAX_ERR

        public static final short SYNTAX_ERR
        If an invalid or illegal string is specified.
        Since:
        DOM Level 2
        See Also:
        Constant Field Values

      • INVALID_MODIFICATION_ERR

        public static final short INVALID_MODIFICATION_ERR
        If an attempt is made to modify the type of the underlying object.
        Since:
        DOM Level 2
        See Also:
        Constant Field Values

      • NAMESPACE_ERR

        public static final short NAMESPACE_ERR
        If an attempt is made to create or change an object in a way which is incorrect with regard to namespaces.
        Since:
        DOM Level 2
        See Also:
        Constant Field Values

      • INVALID_ACCESS_ERR

        public static final short INVALID_ACCESS_ERR
        If a parameter or an operation is not supported by the underlying object.
        Since:
        DOM Level 2
        See Also:
        Constant Field Values

      • VALIDATION_ERR

        public static final short VALIDATION_ERR
        If a call to a method such as insertBefore or removeChild would make the Node invalid with respect to "partial validity", this exception would be raised and the operation would not be done. This code is used in [DOM Level 3 Validation] . Refer to this specification for further information.
        Since:
        DOM Level 3
        See Also:
        Constant Field Values

      • TYPE_MISMATCH_ERR

        public static final short TYPE_MISMATCH_ERR
        If the type of an object is incompatible with the expected type of the parameter associated to the object.
        Since:
        DOM Level 3
        See Also:
        Constant Field Values

    • Constructor Detail

      • DOMException

        public DOMException(short code,
                    String message)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DOMImplementation (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface DOMImplementation

  • public interface DOMImplementation
    The DOMImplementation interface provides a number of methods for performing operations that are independent of any particular instance of the document object model.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Document createDocument(String namespaceURI, String qualifiedName, DocumentType doctype)
      Creates a DOM Document object of the specified type with its document element.
      DocumentType createDocumentType(String qualifiedName, String publicId, String systemId)
      Creates an empty DocumentType node.
      Object getFeature(String feature, String version)
      This method returns a specialized object which implements the specialized APIs of the specified feature and version, as specified in DOM Features.
      boolean hasFeature(String feature, String version)
      Test if the DOM implementation implements a specific feature and version, as specified in DOM Features.

    • Method Detail

      • hasFeature

        boolean hasFeature(String feature,
                   String version)
        Test if the DOM implementation implements a specific feature and version, as specified in DOM Features.
        Parameters:
        feature - The name of the feature to test.
        version - This is the version number of the feature to test.
        Returns:
        true if the feature is implemented in the specified version, false otherwise.

      • createDocumentType

        DocumentType createDocumentType(String qualifiedName,
                                String publicId,
                                String systemId)
                         throws DOMException
        Creates an empty DocumentType node. Entity declarations and notations are not made available. Entity reference expansions and default attribute additions do not occur..
        Parameters:
        qualifiedName - The qualified name of the document type to be created.
        publicId - The external subset public identifier.
        systemId - The external subset system identifier.
        Returns:
        A new DocumentType node with Node.ownerDocument set to null.
        Throws:
        DOMException - INVALID_CHARACTER_ERR: Raised if the specified qualified name is not an XML name according to [XML 1.0].
        NAMESPACE_ERR: Raised if the qualifiedName is malformed.
        NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
        Since:
        DOM Level 2

      • createDocument

        Document createDocument(String namespaceURI,
                        String qualifiedName,
                        DocumentType doctype)
                 throws DOMException
        Creates a DOM Document object of the specified type with its document element.
        Note that based on the DocumentType given to create the document, the implementation may instantiate specialized Document objects that support additional features than the "Core", such as "HTML" [DOM Level 2 HTML] . On the other hand, setting the DocumentType after the document was created makes this very unlikely to happen. Alternatively, specialized Document creation methods, such as createHTMLDocument [DOM Level 2 HTML] , can be used to obtain specific types of Document objects.
        Parameters:
        namespaceURI - The namespace URI of the document element to create or null.
        qualifiedName - The qualified name of the document element to be created or null.
        doctype - The type of document to be created or null. When doctype is not null, its Node.ownerDocument attribute is set to the document being created.
        Returns:
        A new Document object with its document element. If the NamespaceURI, qualifiedName, and doctype are null, the returned Document is empty with no document element.
        Throws:
        DOMException - INVALID_CHARACTER_ERR: Raised if the specified qualified name is not an XML name according to [XML 1.0].
        NAMESPACE_ERR: Raised if the qualifiedName is malformed, if the qualifiedName has a prefix and the namespaceURI is null, or if the qualifiedName is null and the namespaceURI is different from null, or if the qualifiedName has a prefix that is "xml" and the namespaceURI is different from " http://www.w3.org/XML/1998/namespace" [XML Namespaces] , or if the DOM implementation does not support the "XML" feature but a non-null namespace URI was provided, since namespaces were defined by XML.
        WRONG_DOCUMENT_ERR: Raised if doctype has already been used with a different document or was created from a different implementation.
        NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
        Since:
        DOM Level 2

      • getFeature

        Object getFeature(String feature,
                  String version)
        This method returns a specialized object which implements the specialized APIs of the specified feature and version, as specified in DOM Features. The specialized object may also be obtained by using binding-specific casting methods but is not necessarily expected to, as discussed in . This method also allow the implementation to provide specialized objects which do not support the DOMImplementation interface.
        Parameters:
        feature - The name of the feature requested. Note that any plus sign "+" prepended to the name of the feature will be ignored since it is not significant in the context of this method.
        version - This is the version number of the feature to test.
        Returns:
        Returns an object which implements the specialized APIs of the specified feature and version, if any, or null if there is no object which implements interfaces associated with that feature. If the DOMObject returned by this method implements the DOMImplementation interface, it must delegate to the primary core DOMImplementation and not return results inconsistent with the primary core DOMImplementation such as hasFeature, getFeature, etc.
        Since:
        DOM Level 3
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DOMImplementationList (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface DOMImplementationList

  • public interface DOMImplementationList
    The DOMImplementationList interface provides the abstraction of an ordered collection of DOM implementations, without defining or constraining how this collection is implemented. The items in the DOMImplementationList are accessible via an integral index, starting from 0.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    Since:
    DOM Level 3

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      int getLength()
      The number of DOMImplementations in the list.
      DOMImplementation item(int index)
      Returns the indexth item in the collection.

    • Method Detail

      • item

        DOMImplementation item(int index)
        Returns the indexth item in the collection. If index is greater than or equal to the number of DOMImplementations in the list, this returns null.
        Parameters:
        index - Index into the collection.
        Returns:
        The DOMImplementation at the index th position in the DOMImplementationList, or null if that is not a valid index.

      • getLength

        int getLength()
        The number of DOMImplementations in the list. The range of valid child node indices is 0 to length-1 inclusive.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DOMImplementationSource (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface DOMImplementationSource

  • public interface DOMImplementationSource
    This interface permits a DOM implementer to supply one or more implementations, based upon requested features and versions, as specified in DOM Features. Each implemented DOMImplementationSource object is listed in the binding-specific list of available sources so that its DOMImplementation objects are made available.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    Since:
    DOM Level 3

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      DOMImplementation getDOMImplementation(String features)
      A method to request the first DOM implementation that supports the specified features.
      DOMImplementationList getDOMImplementationList(String features)
      A method to request a list of DOM implementations that support the specified features and versions, as specified in .

    • Method Detail

      • getDOMImplementation

        DOMImplementation getDOMImplementation(String features)
        A method to request the first DOM implementation that supports the specified features.
        Parameters:
        features - A string that specifies which features and versions are required. This is a space separated list in which each feature is specified by its name optionally followed by a space and a version number. This method returns the first item of the list returned by getDOMImplementationList. As an example, the string "XML 3.0 Traversal +Events 2.0" will request a DOM implementation that supports the module "XML" for its 3.0 version, a module that support of the "Traversal" module for any version, and the module "Events" for its 2.0 version. The module "Events" must be accessible using the method Node.getFeature() and DOMImplementation.getFeature().
        Returns:
        The first DOM implementation that support the desired features, or null if this source has none.

      • getDOMImplementationList

        DOMImplementationList getDOMImplementationList(String features)
        A method to request a list of DOM implementations that support the specified features and versions, as specified in .
        Parameters:
        features - A string that specifies which features and versions are required. This is a space separated list in which each feature is specified by its name optionally followed by a space and a version number. This is something like: "XML 3.0 Traversal +Events 2.0"
        Returns:
        A list of DOM implementations that support the desired features.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DOMLocator (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface DOMLocator

  • public interface DOMLocator
    DOMLocator is an interface that describes a location (e.g. where an error occurred).

    See also the Document Object Model (DOM) Level 3 Core Specification.

    Since:
    DOM Level 3

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      int getByteOffset()
      The byte offset into the input source this locator is pointing to or -1 if there is no byte offset available.
      int getColumnNumber()
      The column number this locator is pointing to, or -1 if there is no column number available.
      int getLineNumber()
      The line number this locator is pointing to, or -1 if there is no column number available.
      Node getRelatedNode()
      The node this locator is pointing to, or null if no node is available.
      String getUri()
      The URI this locator is pointing to, or null if no URI is available.
      int getUtf16Offset()
      The UTF-16, as defined in [Unicode] and Amendment 1 of [ISO/IEC 10646], offset into the input source this locator is pointing to or -1 if there is no UTF-16 offset available.

    • Method Detail

      • getLineNumber

        int getLineNumber()
        The line number this locator is pointing to, or -1 if there is no column number available.

      • getColumnNumber

        int getColumnNumber()
        The column number this locator is pointing to, or -1 if there is no column number available.

      • getByteOffset

        int getByteOffset()
        The byte offset into the input source this locator is pointing to or -1 if there is no byte offset available.

      • getUtf16Offset

        int getUtf16Offset()
        The UTF-16, as defined in [Unicode] and Amendment 1 of [ISO/IEC 10646], offset into the input source this locator is pointing to or -1 if there is no UTF-16 offset available.

      • getRelatedNode

        Node getRelatedNode()
        The node this locator is pointing to, or null if no node is available.

      • getUri

        String getUri()
        The URI this locator is pointing to, or null if no URI is available.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DOMStringList (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface DOMStringList

  • public interface DOMStringList
    The DOMStringList interface provides the abstraction of an ordered collection of DOMString values, without defining or constraining how this collection is implemented. The items in the DOMStringList are accessible via an integral index, starting from 0.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    Since:
    DOM Level 3

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      boolean contains(String str)
      Test if a string is part of this DOMStringList.
      int getLength()
      The number of DOMStrings in the list.
      String item(int index)
      Returns the indexth item in the collection.

    • Method Detail

      • item

        String item(int index)
        Returns the indexth item in the collection. If index is greater than or equal to the number of DOMStrings in the list, this returns null.
        Parameters:
        index - Index into the collection.
        Returns:
        The DOMString at the indexth position in the DOMStringList, or null if that is not a valid index.

      • getLength

        int getLength()
        The number of DOMStrings in the list. The range of valid child node indices is 0 to length-1 inclusive.

      • contains

        boolean contains(String str)
        Test if a string is part of this DOMStringList.
        Parameters:
        str - The string to look for.
        Returns:
        true if the string has been found, false otherwise.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Element (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface Element

  • All Superinterfaces:
    Node
    All Known Subinterfaces:
    Detail, DetailEntry, SOAPBody, SOAPBodyElement, SOAPElement, SOAPEnvelope, SOAPFault, SOAPFaultElement, SOAPHeader, SOAPHeaderElement
    All Known Implementing Classes:
    IIOMetadataNode

    public interface Element
extends Node
    The Element interface represents an element in an HTML or XML document. Elements may have attributes associated with them; since the Element interface inherits from Node, the generic Node interface attribute attributes may be used to retrieve the set of all attributes for an element. There are methods on the Element interface to retrieve either an Attr object by name or an attribute value by name. In XML, where an attribute value may contain entity references, an Attr object should be retrieved to examine the possibly fairly complex sub-tree representing the attribute value. On the other hand, in HTML, where all attributes have simple string values, methods to directly access an attribute value can safely be used as a convenience.

    Note: In DOM Level 2, the method normalize is inherited from the Node interface where it was moved.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getAttribute(String name)
      Retrieves an attribute value by name.
      Attr getAttributeNode(String name)
      Retrieves an attribute node by name.
      Attr getAttributeNodeNS(String namespaceURI, String localName)
      Retrieves an Attr node by local name and namespace URI.
      String getAttributeNS(String namespaceURI, String localName)
      Retrieves an attribute value by local name and namespace URI.
      NodeList getElementsByTagName(String name)
      Returns a NodeList of all descendant Elements with a given tag name, in document order.
      NodeList getElementsByTagNameNS(String namespaceURI, String localName)
      Returns a NodeList of all the descendant Elements with a given local name and namespace URI in document order.
      TypeInfo getSchemaTypeInfo()
      The type information associated with this element.
      String getTagName()
      The name of the element.
      boolean hasAttribute(String name)
      Returns true when an attribute with a given name is specified on this element or has a default value, false otherwise.
      boolean hasAttributeNS(String namespaceURI, String localName)
      Returns true when an attribute with a given local name and namespace URI is specified on this element or has a default value, false otherwise.
      void removeAttribute(String name)
      Removes an attribute by name.
      Attr removeAttributeNode(Attr oldAttr)
      Removes the specified attribute node.
      void removeAttributeNS(String namespaceURI, String localName)
      Removes an attribute by local name and namespace URI.
      void setAttribute(String name, String value)
      Adds a new attribute.
      Attr setAttributeNode(Attr newAttr)
      Adds a new attribute node.
      Attr setAttributeNodeNS(Attr newAttr)
      Adds a new attribute.
      void setAttributeNS(String namespaceURI, String qualifiedName, String value)
      Adds a new attribute.
      void setIdAttribute(String name, boolean isId)
      If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute .
      void setIdAttributeNode(Attr idAttr, boolean isId)
      If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute .
      void setIdAttributeNS(String namespaceURI, String localName, boolean isId)
      If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute .

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • Method Detail

      • getTagName

        String getTagName()
        The name of the element. If Node.localName is different from null, this attribute is a qualified name. For example, in:
         <elementExample id="demo"> ...
 </elementExample> ,
        tagName has the value "elementExample". Note that this is case-preserving in XML, as are all of the operations of the DOM. The HTML DOM returns the tagName of an HTML element in the canonical uppercase form, regardless of the case in the source HTML document.

      • getAttribute

        String getAttribute(String name)
        Retrieves an attribute value by name.
        Parameters:
        name - The name of the attribute to retrieve.
        Returns:
        The Attr value as a string, or the empty string if that attribute does not have a specified or default value.

      • setAttribute

        void setAttribute(String name,
                  String value)
           throws DOMException
        Adds a new attribute. If an attribute with that name is already present in the element, its value is changed to be that of the value parameter. This value is a simple string; it is not parsed as it is being set. So any markup (such as syntax to be recognized as an entity reference) is treated as literal text, and needs to be appropriately escaped by the implementation when it is written out. In order to assign an attribute value that contains entity references, the user must create an Attr node plus any Text and EntityReference nodes, build the appropriate subtree, and use setAttributeNode to assign it as the value of an attribute.
        To set an attribute with a qualified name and namespace URI, use the setAttributeNS method.
        Parameters:
        name - The name of the attribute to create or alter.
        value - Value to set in string form.
        Throws:
        DOMException - INVALID_CHARACTER_ERR: Raised if the specified name is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.

      • removeAttribute

        void removeAttribute(String name)
              throws DOMException
        Removes an attribute by name. If a default value for the removed attribute is defined in the DTD, a new attribute immediately appears with the default value as well as the corresponding namespace URI, local name, and prefix when applicable. The implementation may handle default values from other schemas similarly but applications should use Document.normalizeDocument() to guarantee this information is up-to-date.
        If no attribute with this name is found, this method has no effect.
        To remove an attribute by local name and namespace URI, use the removeAttributeNS method.
        Parameters:
        name - The name of the attribute to remove.
        Throws:
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.

      • getAttributeNode

        Attr getAttributeNode(String name)
        Retrieves an attribute node by name.
        To retrieve an attribute node by qualified name and namespace URI, use the getAttributeNodeNS method.
        Parameters:
        name - The name (nodeName) of the attribute to retrieve.
        Returns:
        The Attr node with the specified name ( nodeName) or null if there is no such attribute.

      • setAttributeNode

        Attr setAttributeNode(Attr newAttr)
               throws DOMException
        Adds a new attribute node. If an attribute with that name ( nodeName) is already present in the element, it is replaced by the new one. Replacing an attribute node by itself has no effect.
        To add a new attribute node with a qualified name and namespace URI, use the setAttributeNodeNS method.
        Parameters:
        newAttr - The Attr node to add to the attribute list.
        Returns:
        If the newAttr attribute replaces an existing attribute, the replaced Attr node is returned, otherwise null is returned.
        Throws:
        DOMException - WRONG_DOCUMENT_ERR: Raised if newAttr was created from a different document than the one that created the element.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
        INUSE_ATTRIBUTE_ERR: Raised if newAttr is already an attribute of another Element object. The DOM user must explicitly clone Attr nodes to re-use them in other elements.

      • removeAttributeNode

        Attr removeAttributeNode(Attr oldAttr)
                  throws DOMException
        Removes the specified attribute node. If a default value for the removed Attr node is defined in the DTD, a new node immediately appears with the default value as well as the corresponding namespace URI, local name, and prefix when applicable. The implementation may handle default values from other schemas similarly but applications should use Document.normalizeDocument() to guarantee this information is up-to-date.
        Parameters:
        oldAttr - The Attr node to remove from the attribute list.
        Returns:
        The Attr node that was removed.
        Throws:
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
        NOT_FOUND_ERR: Raised if oldAttr is not an attribute of the element.

      • getElementsByTagName

        NodeList getElementsByTagName(String name)
        Returns a NodeList of all descendant Elements with a given tag name, in document order.
        Parameters:
        name - The name of the tag to match on. The special value "*" matches all tags.
        Returns:
        A list of matching Element nodes.

      • getAttributeNS

        String getAttributeNS(String namespaceURI,
                      String localName)
               throws DOMException
        Retrieves an attribute value by local name and namespace URI.
        Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.
        Parameters:
        namespaceURI - The namespace URI of the attribute to retrieve.
        localName - The local name of the attribute to retrieve.
        Returns:
        The Attr value as a string, or the empty string if that attribute does not have a specified or default value.
        Throws:
        DOMException - NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
        Since:
        DOM Level 2

      • setAttributeNS

        void setAttributeNS(String namespaceURI,
                    String qualifiedName,
                    String value)
             throws DOMException
        Adds a new attribute. If an attribute with the same local name and namespace URI is already present on the element, its prefix is changed to be the prefix part of the qualifiedName, and its value is changed to be the value parameter. This value is a simple string; it is not parsed as it is being set. So any markup (such as syntax to be recognized as an entity reference) is treated as literal text, and needs to be appropriately escaped by the implementation when it is written out. In order to assign an attribute value that contains entity references, the user must create an Attr node plus any Text and EntityReference nodes, build the appropriate subtree, and use setAttributeNodeNS or setAttributeNode to assign it as the value of an attribute.
        Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.
        Parameters:
        namespaceURI - The namespace URI of the attribute to create or alter.
        qualifiedName - The qualified name of the attribute to create or alter.
        value - The value to set in string form.
        Throws:
        DOMException - INVALID_CHARACTER_ERR: Raised if the specified qualified name is not an XML name according to the XML version in use specified in the Document.xmlVersion attribute.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
        NAMESPACE_ERR: Raised if the qualifiedName is malformed per the Namespaces in XML specification, if the qualifiedName has a prefix and the namespaceURI is null, if the qualifiedName has a prefix that is "xml" and the namespaceURI is different from " http://www.w3.org/XML/1998/namespace", if the qualifiedName or its prefix is "xmlns" and the namespaceURI is different from "http://www.w3.org/2000/xmlns/", or if the namespaceURI is "http://www.w3.org/2000/xmlns/" and neither the qualifiedName nor its prefix is "xmlns".
        NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
        Since:
        DOM Level 2

      • removeAttributeNS

        void removeAttributeNS(String namespaceURI,
                       String localName)
                throws DOMException
        Removes an attribute by local name and namespace URI. If a default value for the removed attribute is defined in the DTD, a new attribute immediately appears with the default value as well as the corresponding namespace URI, local name, and prefix when applicable. The implementation may handle default values from other schemas similarly but applications should use Document.normalizeDocument() to guarantee this information is up-to-date.
        If no attribute with this local name and namespace URI is found, this method has no effect.
        Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.
        Parameters:
        namespaceURI - The namespace URI of the attribute to remove.
        localName - The local name of the attribute to remove.
        Throws:
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
        NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
        Since:
        DOM Level 2

      • getAttributeNodeNS

        Attr getAttributeNodeNS(String namespaceURI,
                        String localName)
                 throws DOMException
        Retrieves an Attr node by local name and namespace URI.
        Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.
        Parameters:
        namespaceURI - The namespace URI of the attribute to retrieve.
        localName - The local name of the attribute to retrieve.
        Returns:
        The Attr node with the specified attribute local name and namespace URI or null if there is no such attribute.
        Throws:
        DOMException - NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
        Since:
        DOM Level 2

      • setAttributeNodeNS

        Attr setAttributeNodeNS(Attr newAttr)
                 throws DOMException
        Adds a new attribute. If an attribute with that local name and that namespace URI is already present in the element, it is replaced by the new one. Replacing an attribute node by itself has no effect.
        Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.
        Parameters:
        newAttr - The Attr node to add to the attribute list.
        Returns:
        If the newAttr attribute replaces an existing attribute with the same local name and namespace URI, the replaced Attr node is returned, otherwise null is returned.
        Throws:
        DOMException - WRONG_DOCUMENT_ERR: Raised if newAttr was created from a different document than the one that created the element.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
        INUSE_ATTRIBUTE_ERR: Raised if newAttr is already an attribute of another Element object. The DOM user must explicitly clone Attr nodes to re-use them in other elements.
        NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
        Since:
        DOM Level 2

      • getElementsByTagNameNS

        NodeList getElementsByTagNameNS(String namespaceURI,
                                String localName)
                         throws DOMException
        Returns a NodeList of all the descendant Elements with a given local name and namespace URI in document order.
        Parameters:
        namespaceURI - The namespace URI of the elements to match on. The special value "*" matches all namespaces.
        localName - The local name of the elements to match on. The special value "*" matches all local names.
        Returns:
        A new NodeList object containing all the matched Elements.
        Throws:
        DOMException - NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
        Since:
        DOM Level 2

      • hasAttribute

        boolean hasAttribute(String name)
        Returns true when an attribute with a given name is specified on this element or has a default value, false otherwise.
        Parameters:
        name - The name of the attribute to look for.
        Returns:
        true if an attribute with the given name is specified on this element or has a default value, false otherwise.
        Since:
        DOM Level 2

      • hasAttributeNS

        boolean hasAttributeNS(String namespaceURI,
                       String localName)
                throws DOMException
        Returns true when an attribute with a given local name and namespace URI is specified on this element or has a default value, false otherwise.
        Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.
        Parameters:
        namespaceURI - The namespace URI of the attribute to look for.
        localName - The local name of the attribute to look for.
        Returns:
        true if an attribute with the given local name and namespace URI is specified or has a default value on this element, false otherwise.
        Throws:
        DOMException - NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
        Since:
        DOM Level 2

      • getSchemaTypeInfo

        TypeInfo getSchemaTypeInfo()
        The type information associated with this element.
        Since:
        DOM Level 3

      • setIdAttribute

        void setIdAttribute(String name,
                    boolean isId)
             throws DOMException
        If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute . This affects the value of Attr.isId and the behavior of Document.getElementById, but does not change any schema that may be in use, in particular this does not affect the Attr.schemaTypeInfo of the specified Attr node. Use the value false for the parameter isId to undeclare an attribute for being a user-determined ID attribute.
        To specify an attribute by local name and namespace URI, use the setIdAttributeNS method.
        Parameters:
        name - The name of the attribute.
        isId - Whether the attribute is a of type ID.
        Throws:
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
        NOT_FOUND_ERR: Raised if the specified node is not an attribute of this element.
        Since:
        DOM Level 3

      • setIdAttributeNS

        void setIdAttributeNS(String namespaceURI,
                      String localName,
                      boolean isId)
               throws DOMException
        If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute . This affects the value of Attr.isId and the behavior of Document.getElementById, but does not change any schema that may be in use, in particular this does not affect the Attr.schemaTypeInfo of the specified Attr node. Use the value false for the parameter isId to undeclare an attribute for being a user-determined ID attribute.
        Parameters:
        namespaceURI - The namespace URI of the attribute.
        localName - The local name of the attribute.
        isId - Whether the attribute is a of type ID.
        Throws:
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
        NOT_FOUND_ERR: Raised if the specified node is not an attribute of this element.
        Since:
        DOM Level 3

      • setIdAttributeNode

        void setIdAttributeNode(Attr idAttr,
                        boolean isId)
                 throws DOMException
        If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute . This affects the value of Attr.isId and the behavior of Document.getElementById, but does not change any schema that may be in use, in particular this does not affect the Attr.schemaTypeInfo of the specified Attr node. Use the value false for the parameter isId to undeclare an attribute for being a user-determined ID attribute.
        Parameters:
        idAttr - The attribute node.
        isId - Whether the attribute is a of type ID.
        Throws:
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
        NOT_FOUND_ERR: Raised if the specified node is not an attribute of this element.
        Since:
        DOM Level 3
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Entity (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface Entity

  • All Superinterfaces:
    Node

    public interface Entity
extends Node
    This interface represents a known entity, either parsed or unparsed, in an XML document. Note that this models the entity itself not the entity declaration.

    The nodeName attribute that is inherited from Node contains the name of the entity.

    An XML processor may choose to completely expand entities before the structure model is passed to the DOM; in this case there will be no EntityReference nodes in the document tree.

    XML does not mandate that a non-validating XML processor read and process entity declarations made in the external subset or declared in parameter entities. This means that parsed entities declared in the external subset need not be expanded by some classes of applications, and that the replacement text of the entity may not be available. When the replacement text is available, the corresponding Entity node's child list represents the structure of that replacement value. Otherwise, the child list is empty.

    DOM Level 3 does not support editing Entity nodes; if a user wants to make changes to the contents of an Entity, every related EntityReference node has to be replaced in the structure model by a clone of the Entity's contents, and then the desired changes must be made to each of those clones instead. Entity nodes and all their descendants are readonly.

    An Entity node does not have any parent.

    Note: If the entity contains an unbound namespace prefix, the namespaceURI of the corresponding node in the Entity node subtree is null. The same is true for EntityReference nodes that refer to this entity, when they are created using the createEntityReference method of the Document interface.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getInputEncoding()
      An attribute specifying the encoding used for this entity at the time of parsing, when it is an external parsed entity.
      String getNotationName()
      For unparsed entities, the name of the notation for the entity.
      String getPublicId()
      The public identifier associated with the entity if specified, and null otherwise.
      String getSystemId()
      The system identifier associated with the entity if specified, and null otherwise.
      String getXmlEncoding()
      An attribute specifying, as part of the text declaration, the encoding of this entity, when it is an external parsed entity.
      String getXmlVersion()
      An attribute specifying, as part of the text declaration, the version number of this entity, when it is an external parsed entity.

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • Method Detail

      • getPublicId

        String getPublicId()
        The public identifier associated with the entity if specified, and null otherwise.

      • getSystemId

        String getSystemId()
        The system identifier associated with the entity if specified, and null otherwise. This may be an absolute URI or not.

      • getNotationName

        String getNotationName()
        For unparsed entities, the name of the notation for the entity. For parsed entities, this is null.

      • getInputEncoding

        String getInputEncoding()
        An attribute specifying the encoding used for this entity at the time of parsing, when it is an external parsed entity. This is null if it an entity from the internal subset or if it is not known.
        Since:
        DOM Level 3

      • getXmlEncoding

        String getXmlEncoding()
        An attribute specifying, as part of the text declaration, the encoding of this entity, when it is an external parsed entity. This is null otherwise.
        Since:
        DOM Level 3

      • getXmlVersion

        String getXmlVersion()
        An attribute specifying, as part of the text declaration, the version number of this entity, when it is an external parsed entity. This is null otherwise.
        Since:
        DOM Level 3
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EntityReference (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface EntityReference

  • All Superinterfaces:
    Node

    public interface EntityReference
extends Node
    EntityReference nodes may be used to represent an entity reference in the tree. Note that character references and references to predefined entities are considered to be expanded by the HTML or XML processor so that characters are represented by their Unicode equivalent rather than by an entity reference. Moreover, the XML processor may completely expand references to entities while building the Document, instead of providing EntityReference nodes. If it does provide such nodes, then for an EntityReference node that represents a reference to a known entity an Entity exists, and the subtree of the EntityReference node is a copy of the Entity node subtree. However, the latter may not be true when an entity contains an unbound namespace prefix. In such a case, because the namespace prefix resolution depends on where the entity reference is, the descendants of the EntityReference node may be bound to different namespace URIs. When an EntityReference node represents a reference to an unknown entity, the node has no children and its replacement value, when used by Attr.value for example, is empty.

    As for Entity nodes, EntityReference nodes and all their descendants are readonly.

    Note: EntityReference nodes may cause element content and attribute value normalization problems when, such as in XML 1.0 and XML Schema, the normalization is performed after entity reference are expanded.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Interface org.w3c.dom.events.DocumentEvent (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.events.DocumentEvent

No usage of org.w3c.dom.events.DocumentEvent
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.events.Event (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.events.Event

  • Packages that use Event
    Package Description
    org.w3c.dom.events
    org.w3c.dom.ls

    • Uses of Event in org.w3c.dom.events

      Subinterfaces of Event in org.w3c.dom.events
      Modifier and Type Interface and Description
      interface  MouseEvent
      The MouseEvent interface provides specific contextual information associated with Mouse events.
      interface  MutationEvent
      The MutationEvent interface provides specific contextual information associated with Mutation events.
      interface  UIEvent
      The UIEvent interface provides specific contextual information associated with User Interface events.
      Methods in org.w3c.dom.events that return Event
      Modifier and Type | Method and Description
      Event | DocumentEvent.createEvent(String eventType)
      Methods in org.w3c.dom.events with parameters of type Event
      Modifier and Type Method and Description
      boolean EventTarget.dispatchEvent(Event evt)
      This method allows the dispatch of events into the implementations event model.
      void EventListener.handleEvent(Event evt)
      This method is called whenever an event occurs of the type for which the EventListener interface was registered.

    • Uses of Event in org.w3c.dom.ls

      Subinterfaces of Event in org.w3c.dom.ls
      Modifier and Type Interface and Description
      interface  LSLoadEvent
      This interface represents a load event object that signals the completion of a document load.
      interface  LSProgressEvent
      This interface represents a progress event object that notifies the application about progress as a document is parsed.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.w3c.dom.events.EventException (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.w3c.dom.events.EventException

  • Packages that use EventException
    Package Description
    org.w3c.dom.events

    • Uses of EventException in org.w3c.dom.events

      Methods in org.w3c.dom.events that throw EventException
      Modifier and Type Method and Description
      boolean EventTarget.dispatchEvent(Event evt)
      This method allows the dispatch of events into the implementations event model.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.events.EventListener (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.events.EventListener

  • Packages that use EventListener
    Package Description
    org.w3c.dom.events

    • Uses of EventListener in org.w3c.dom.events

      Methods in org.w3c.dom.events with parameters of type EventListener
      Modifier and Type Method and Description
      void EventTarget.addEventListener(String type, EventListener listener, boolean useCapture)
      This method allows the registration of event listeners on the event target.
      void EventTarget.removeEventListener(String type, EventListener listener, boolean useCapture)
      This method allows the removal of event listeners from the event target.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.events.EventTarget (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.events.EventTarget

  • Packages that use EventTarget
    Package Description
    org.w3c.dom.events

    • Uses of EventTarget in org.w3c.dom.events

      Methods in org.w3c.dom.events that return EventTarget
      Modifier and Type Method and Description
      EventTarget Event.getCurrentTarget()
      Used to indicate the EventTarget whose EventListeners are currently being processed.
      EventTarget MouseEvent.getRelatedTarget()
      Used to identify a secondary EventTarget related to a UI event.
      EventTarget Event.getTarget()
      Used to indicate the EventTarget to which the event was originally dispatched.
      Methods in org.w3c.dom.events with parameters of type EventTarget
      Modifier and Type Method and Description
      void MouseEvent.initMouseEvent(String typeArg, boolean canBubbleArg, boolean cancelableArg, AbstractView viewArg, int detailArg, int screenXArg, int screenYArg, int clientXArg, int clientYArg, boolean ctrlKeyArg, boolean altKeyArg, boolean shiftKeyArg, boolean metaKeyArg, short buttonArg, EventTarget relatedTargetArg)
      The initMouseEvent method is used to initialize the value of a MouseEvent created through the DocumentEvent interface.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.events.MouseEvent (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.events.MouseEvent

No usage of org.w3c.dom.events.MouseEvent
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.events.MutationEvent (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.events.MutationEvent

No usage of org.w3c.dom.events.MutationEvent
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.events.UIEvent (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.events.UIEvent

  • Packages that use UIEvent
    Package Description
    org.w3c.dom.events

    • Uses of UIEvent in org.w3c.dom.events

      Subinterfaces of UIEvent in org.w3c.dom.events
      Modifier and Type Interface and Description
      interface  MouseEvent
      The MouseEvent interface provides specific contextual information associated with Mouse events.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


compact2 - org.w3c.dom.events (Java Platform SE 8 )

compact2 - org.w3c.dom.events

Interfaces

  • DocumentEvent
  • Event
  • EventListener
  • EventTarget
  • MouseEvent
  • MutationEvent
  • UIEvent

Exceptions

  • EventException


org.w3c.dom.events (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact2

Package org.w3c.dom.events

  • Interface Summary
    Interface Description
    DocumentEvent
    The DocumentEvent interface provides a mechanism by which the user can create an Event of a type supported by the implementation.
    Event
    The Event interface is used to provide contextual information about an event to the handler processing the event.
    EventListener
    The EventListener interface is the primary method for handling events.
    EventTarget
    The EventTarget interface is implemented by all Nodes in an implementation which supports the DOM Event Model.
    MouseEvent
    The MouseEvent interface provides specific contextual information associated with Mouse events.
    MutationEvent
    The MutationEvent interface provides specific contextual information associated with Mutation events.
    UIEvent
    The UIEvent interface provides specific contextual information associated with User Interface events.
  • Exception Summary
    Exception Description
    EventException
    Event operations may throw an EventException as specified in their method descriptions.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames


compact3 - org.w3c.dom.events (Java Platform SE 8 )

compact3 - org.w3c.dom.events

Interfaces

  • DocumentEvent
  • Event
  • EventListener
  • EventTarget
  • MouseEvent
  • MutationEvent
  • UIEvent

Exceptions

  • EventException


org.w3c.dom.events (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package org.w3c.dom.events

  • Interface Summary
    Interface Description
    DocumentEvent
    The DocumentEvent interface provides a mechanism by which the user can create an Event of a type supported by the implementation.
    Event
    The Event interface is used to provide contextual information about an event to the handler processing the event.
    EventListener
    The EventListener interface is the primary method for handling events.
    EventTarget
    The EventTarget interface is implemented by all Nodes in an implementation which supports the DOM Event Model.
    MouseEvent
    The MouseEvent interface provides specific contextual information associated with Mouse events.
    MutationEvent
    The MutationEvent interface provides specific contextual information associated with Mutation events.
    UIEvent
    The UIEvent interface provides specific contextual information associated with User Interface events.
  • Exception Summary
    Exception Description
    EventException
    Event operations may throw an EventException as specified in their method descriptions.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames


DocumentEvent (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.events

Interface DocumentEvent

  • public interface DocumentEvent
    The DocumentEvent interface provides a mechanism by which the user can create an Event of a type supported by the implementation. It is expected that the DocumentEvent interface will be implemented on the same object which implements the Document interface in an implementation which supports the Event model.

    See also the Document Object Model (DOM) Level 2 Events Specification.

    Since:
    DOM Level 2

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type | Method and Description
      Event | createEvent(String eventType)

    • Method Detail

      • createEvent

        Event createEvent(String eventType)
           throws DOMException
        Parameters:
        eventType - The eventType parameter specifies the type of Event interface to be created. If the Event interface specified is supported by the implementation this method will return a new Event of the interface type requested. If the Event is to be dispatched via the dispatchEvent method the appropriate event init method must be called after creation in order to initialize the Event's values. As an example, a user wishing to synthesize some kind of UIEvent would call createEvent with the parameter "UIEvents". The initUIEvent method could then be called on the newly created UIEvent to set the specific type of UIEvent to be dispatched and set its context information.The createEvent method is used in creating Events when it is either inconvenient or unnecessary for the user to create an Event themselves. In cases where the implementation provided Event is insufficient, users may supply their own Event implementations for use with the dispatchEvent method.
        Returns:
        The newly created Event
        Throws:
        DOMException - NOT_SUPPORTED_ERR: Raised if the implementation does not support the type of Event interface requested
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Event (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.events

Interface Event

  • All Known Subinterfaces:
    LSLoadEvent, LSProgressEvent, MouseEvent, MutationEvent, UIEvent

    public interface Event
    The Event interface is used to provide contextual information about an event to the handler processing the event. An object which implements the Event interface is generally passed as the first parameter to an event handler. More specific context information is passed to event handlers by deriving additional interfaces from Event which contain information directly relating to the type of event they accompany. These derived interfaces are also implemented by the object passed to the event listener.

    See also the Document Object Model (DOM) Level 2 Events Specification.

    Since:
    DOM Level 2

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short AT_TARGET
      The event is currently being evaluated at the target EventTarget.
      static short BUBBLING_PHASE
      The current event phase is the bubbling phase.
      static short CAPTURING_PHASE
      The current event phase is the capturing phase.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      boolean getBubbles()
      Used to indicate whether or not an event is a bubbling event.
      boolean getCancelable()
      Used to indicate whether or not an event can have its default action prevented.
      EventTarget getCurrentTarget()
      Used to indicate the EventTarget whose EventListeners are currently being processed.
      short getEventPhase()
      Used to indicate which phase of event flow is currently being evaluated.
      EventTarget getTarget()
      Used to indicate the EventTarget to which the event was originally dispatched.
      long getTimeStamp()
      Used to specify the time (in milliseconds relative to the epoch) at which the event was created.
      String getType()
      The name of the event (case-insensitive).
      void initEvent(String eventTypeArg, boolean canBubbleArg, boolean cancelableArg)
      The initEvent method is used to initialize the value of an Event created through the DocumentEvent interface.
      void preventDefault()
      If an event is cancelable, the preventDefault method is used to signify that the event is to be canceled, meaning any default action normally taken by the implementation as a result of the event will not occur.
      void stopPropagation()
      The stopPropagation method is used prevent further propagation of an event during event flow.

    • Field Detail

      • CAPTURING_PHASE

        static final short CAPTURING_PHASE
        The current event phase is the capturing phase.
        See Also:
        Constant Field Values

      • AT_TARGET

        static final short AT_TARGET
        The event is currently being evaluated at the target EventTarget.
        See Also:
        Constant Field Values

      • BUBBLING_PHASE

        static final short BUBBLING_PHASE
        The current event phase is the bubbling phase.
        See Also:
        Constant Field Values

    • Method Detail

      • getType

        String getType()
        The name of the event (case-insensitive). The name must be an XML name.

      • getTarget

        EventTarget getTarget()
        Used to indicate the EventTarget to which the event was originally dispatched.

      • getCurrentTarget

        EventTarget getCurrentTarget()
        Used to indicate the EventTarget whose EventListeners are currently being processed. This is particularly useful during capturing and bubbling.

      • getEventPhase

        short getEventPhase()
        Used to indicate which phase of event flow is currently being evaluated.

      • getBubbles

        boolean getBubbles()
        Used to indicate whether or not an event is a bubbling event. If the event can bubble the value is true, else the value is false.

      • getCancelable

        boolean getCancelable()
        Used to indicate whether or not an event can have its default action prevented. If the default action can be prevented the value is true, else the value is false.

      • getTimeStamp

        long getTimeStamp()
        Used to specify the time (in milliseconds relative to the epoch) at which the event was created. Due to the fact that some systems may not provide this information the value of timeStamp may be not available for all events. When not available, a value of 0 will be returned. Examples of epoch time are the time of the system start or 0:0:0 UTC 1st January 1970.

      • stopPropagation

        void stopPropagation()
        The stopPropagation method is used prevent further propagation of an event during event flow. If this method is called by any EventListener the event will cease propagating through the tree. The event will complete dispatch to all listeners on the current EventTarget before event flow stops. This method may be used during any stage of event flow.

      • preventDefault

        void preventDefault()
        If an event is cancelable, the preventDefault method is used to signify that the event is to be canceled, meaning any default action normally taken by the implementation as a result of the event will not occur. If, during any stage of event flow, the preventDefault method is called the event is canceled. Any default action associated with the event will not occur. Calling this method for a non-cancelable event has no effect. Once preventDefault has been called it will remain in effect throughout the remainder of the event's propagation. This method may be used during any stage of event flow.

      • initEvent

        void initEvent(String eventTypeArg,
               boolean canBubbleArg,
               boolean cancelableArg)
        The initEvent method is used to initialize the value of an Event created through the DocumentEvent interface. This method may only be called before the Event has been dispatched via the dispatchEvent method, though it may be called multiple times during that phase if necessary. If called multiple times the final invocation takes precedence. If called from a subclass of Event interface only the values specified in the initEvent method are modified, all other attributes are left unchanged.
        Parameters:
        eventTypeArg - Specifies the event type. This type may be any event type currently defined in this specification or a new event type.. The string must be an XML name. Any new event type must not begin with any upper, lower, or mixed case version of the string "DOM". This prefix is reserved for future DOM event sets. It is also strongly recommended that third parties adding their own events use their own prefix to avoid confusion and lessen the probability of conflicts with other new events.
        canBubbleArg - Specifies whether or not the event can bubble.
        cancelableArg - Specifies whether or not the event's default action can be prevented.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EventException (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.events

Class EventException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.w3c.dom.events.EventException
  • All Implemented Interfaces:
    Serializable

    public class EventException
extends RuntimeException
    Event operations may throw an EventException as specified in their method descriptions.

    See also the Document Object Model (DOM) Level 2 Events Specification.

    Since:
    DOM Level 2
    See Also:
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      short | code
      static short UNSPECIFIED_EVENT_TYPE_ERR
      If the Event's type was not specified by initializing the event before the method was called.

    • Constructor Summary

      Constructors
      Constructor and Description
      EventException(short code, String message)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • code

        public short code

      • UNSPECIFIED_EVENT_TYPE_ERR

        public static final short UNSPECIFIED_EVENT_TYPE_ERR
        If the Event's type was not specified by initializing the event before the method was called. Specification of the Event's type as null or an empty string will also trigger this exception.
        See Also:
        Constant Field Values

    • Constructor Detail

      • EventException

        public EventException(short code,
                      String message)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EventListener (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.events

Interface EventListener

  • public interface EventListener
    The EventListener interface is the primary method for handling events. Users implement the EventListener interface and register their listener on an EventTarget using the AddEventListener method. The users should also remove their EventListener from its EventTarget after they have completed using the listener.

    When a Node is copied using the cloneNode method the EventListeners attached to the source Node are not attached to the copied Node. If the user wishes the same EventListeners to be added to the newly created copy the user must add them manually.

    See also the Document Object Model (DOM) Level 2 Events Specification.

    Since:
    DOM Level 2

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void handleEvent(Event evt)
      This method is called whenever an event occurs of the type for which the EventListener interface was registered.

    • Method Detail

      • handleEvent

        void handleEvent(Event evt)
        This method is called whenever an event occurs of the type for which the EventListener interface was registered.
        Parameters:
        evt - The Event contains contextual information about the event. It also contains the stopPropagation and preventDefault methods which are used in determining the event's flow and default action.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EventTarget (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.events

Interface EventTarget

  • public interface EventTarget
    The EventTarget interface is implemented by all Nodes in an implementation which supports the DOM Event Model. Therefore, this interface can be obtained by using binding-specific casting methods on an instance of the Node interface. The interface allows registration and removal of EventListeners on an EventTarget and dispatch of events to that EventTarget.

    See also the Document Object Model (DOM) Level 2 Events Specification.

    Since:
    DOM Level 2

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void addEventListener(String type, EventListener listener, boolean useCapture)
      This method allows the registration of event listeners on the event target.
      boolean dispatchEvent(Event evt)
      This method allows the dispatch of events into the implementations event model.
      void removeEventListener(String type, EventListener listener, boolean useCapture)
      This method allows the removal of event listeners from the event target.

    • Method Detail

      • addEventListener

        void addEventListener(String type,
                      EventListener listener,
                      boolean useCapture)
        This method allows the registration of event listeners on the event target. If an EventListener is added to an EventTarget while it is processing an event, it will not be triggered by the current actions but may be triggered during a later stage of event flow, such as the bubbling phase.
        If multiple identical EventListeners are registered on the same EventTarget with the same parameters the duplicate instances are discarded. They do not cause the EventListener to be called twice and since they are discarded they do not need to be removed with the removeEventListener method.
        Parameters:
        type - The event type for which the user is registering
        listener - The listener parameter takes an interface implemented by the user which contains the methods to be called when the event occurs.
        useCapture - If true, useCapture indicates that the user wishes to initiate capture. After initiating capture, all events of the specified type will be dispatched to the registered EventListener before being dispatched to any EventTargets beneath them in the tree. Events which are bubbling upward through the tree will not trigger an EventListener designated to use capture.

      • removeEventListener

        void removeEventListener(String type,
                         EventListener listener,
                         boolean useCapture)
        This method allows the removal of event listeners from the event target. If an EventListener is removed from an EventTarget while it is processing an event, it will not be triggered by the current actions. EventListeners can never be invoked after being removed.
        Calling removeEventListener with arguments which do not identify any currently registered EventListener on the EventTarget has no effect.
        Parameters:
        type - Specifies the event type of the EventListener being removed.
        listener - The EventListener parameter indicates the EventListener to be removed.
        useCapture - Specifies whether the EventListener being removed was registered as a capturing listener or not. If a listener was registered twice, one with capture and one without, each must be removed separately. Removal of a capturing listener does not affect a non-capturing version of the same listener, and vice versa.

      • dispatchEvent

        boolean dispatchEvent(Event evt)
               throws EventException
        This method allows the dispatch of events into the implementations event model. Events dispatched in this manner will have the same capturing and bubbling behavior as events dispatched directly by the implementation. The target of the event is the EventTarget on which dispatchEvent is called.
        Parameters:
        evt - Specifies the event type, behavior, and contextual information to be used in processing the event.
        Returns:
        The return value of dispatchEvent indicates whether any of the listeners which handled the event called preventDefault. If preventDefault was called the value is false, else the value is true.
        Throws:
        EventException - UNSPECIFIED_EVENT_TYPE_ERR: Raised if the Event's type was not specified by initializing the event before dispatchEvent was called. Specification of the Event's type as null or an empty string will also trigger this exception.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MouseEvent (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.events

Interface MouseEvent

  • All Superinterfaces:
    Event, UIEvent

    public interface MouseEvent
extends UIEvent
    The MouseEvent interface provides specific contextual information associated with Mouse events.

    The detail attribute inherited from UIEvent indicates the number of times a mouse button has been pressed and released over the same screen location during a user action. The attribute value is 1 when the user begins this action and increments by 1 for each full sequence of pressing and releasing. If the user moves the mouse between the mousedown and mouseup the value will be set to 0, indicating that no click is occurring.

    In the case of nested elements mouse events are always targeted at the most deeply nested element. Ancestors of the targeted element may use bubbling to obtain notification of mouse events which occur within its descendent elements.

    See also the Document Object Model (DOM) Level 2 Events Specification.

    Since:
    DOM Level 2

    • Field Summary

      • Fields inherited from interface org.w3c.dom.events.Event

        AT_TARGET, BUBBLING_PHASE, CAPTURING_PHASE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      boolean getAltKey()
      Used to indicate whether the 'alt' key was depressed during the firing of the event.
      short getButton()
      During mouse events caused by the depression or release of a mouse button, button is used to indicate which mouse button changed state.
      int getClientX()
      The horizontal coordinate at which the event occurred relative to the DOM implementation's client area.
      int getClientY()
      The vertical coordinate at which the event occurred relative to the DOM implementation's client area.
      boolean getCtrlKey()
      Used to indicate whether the 'ctrl' key was depressed during the firing of the event.
      boolean getMetaKey()
      Used to indicate whether the 'meta' key was depressed during the firing of the event.
      EventTarget getRelatedTarget()
      Used to identify a secondary EventTarget related to a UI event.
      int getScreenX()
      The horizontal coordinate at which the event occurred relative to the origin of the screen coordinate system.
      int getScreenY()
      The vertical coordinate at which the event occurred relative to the origin of the screen coordinate system.
      boolean getShiftKey()
      Used to indicate whether the 'shift' key was depressed during the firing of the event.
      void initMouseEvent(String typeArg, boolean canBubbleArg, boolean cancelableArg, AbstractView viewArg, int detailArg, int screenXArg, int screenYArg, int clientXArg, int clientYArg, boolean ctrlKeyArg, boolean altKeyArg, boolean shiftKeyArg, boolean metaKeyArg, short buttonArg, EventTarget relatedTargetArg)
      The initMouseEvent method is used to initialize the value of a MouseEvent created through the DocumentEvent interface.

      • Methods inherited from interface org.w3c.dom.events.UIEvent

        getDetail, getView, initUIEvent

      • Methods inherited from interface org.w3c.dom.events.Event

        getBubbles, getCancelable, getCurrentTarget, getEventPhase, getTarget, getTimeStamp, getType, initEvent, preventDefault, stopPropagation

    • Method Detail

      • getScreenX

        int getScreenX()
        The horizontal coordinate at which the event occurred relative to the origin of the screen coordinate system.

      • getScreenY

        int getScreenY()
        The vertical coordinate at which the event occurred relative to the origin of the screen coordinate system.

      • getClientX

        int getClientX()
        The horizontal coordinate at which the event occurred relative to the DOM implementation's client area.

      • getClientY

        int getClientY()
        The vertical coordinate at which the event occurred relative to the DOM implementation's client area.

      • getCtrlKey

        boolean getCtrlKey()
        Used to indicate whether the 'ctrl' key was depressed during the firing of the event.

      • getShiftKey

        boolean getShiftKey()
        Used to indicate whether the 'shift' key was depressed during the firing of the event.

      • getAltKey

        boolean getAltKey()
        Used to indicate whether the 'alt' key was depressed during the firing of the event. On some platforms this key may map to an alternative key name.

      • getMetaKey

        boolean getMetaKey()
        Used to indicate whether the 'meta' key was depressed during the firing of the event. On some platforms this key may map to an alternative key name.

      • getButton

        short getButton()
        During mouse events caused by the depression or release of a mouse button, button is used to indicate which mouse button changed state. The values for button range from zero to indicate the left button of the mouse, one to indicate the middle button if present, and two to indicate the right button. For mice configured for left handed use in which the button actions are reversed the values are instead read from right to left.

      • getRelatedTarget

        EventTarget getRelatedTarget()
        Used to identify a secondary EventTarget related to a UI event. Currently this attribute is used with the mouseover event to indicate the EventTarget which the pointing device exited and with the mouseout event to indicate the EventTarget which the pointing device entered.

      • initMouseEvent

        void initMouseEvent(String typeArg,
                    boolean canBubbleArg,
                    boolean cancelableArg,
                    AbstractView viewArg,
                    int detailArg,
                    int screenXArg,
                    int screenYArg,
                    int clientXArg,
                    int clientYArg,
                    boolean ctrlKeyArg,
                    boolean altKeyArg,
                    boolean shiftKeyArg,
                    boolean metaKeyArg,
                    short buttonArg,
                    EventTarget relatedTargetArg)
        The initMouseEvent method is used to initialize the value of a MouseEvent created through the DocumentEvent interface. This method may only be called before the MouseEvent has been dispatched via the dispatchEvent method, though it may be called multiple times during that phase if necessary. If called multiple times, the final invocation takes precedence.
        Parameters:
        typeArg - Specifies the event type.
        canBubbleArg - Specifies whether or not the event can bubble.
        cancelableArg - Specifies whether or not the event's default action can be prevented.
        viewArg - Specifies the Event's AbstractView.
        detailArg - Specifies the Event's mouse click count.
        screenXArg - Specifies the Event's screen x coordinate
        screenYArg - Specifies the Event's screen y coordinate
        clientXArg - Specifies the Event's client x coordinate
        clientYArg - Specifies the Event's client y coordinate
        ctrlKeyArg - Specifies whether or not control key was depressed during the Event.
        altKeyArg - Specifies whether or not alt key was depressed during the Event.
        shiftKeyArg - Specifies whether or not shift key was depressed during the Event.
        metaKeyArg - Specifies whether or not meta key was depressed during the Event.
        buttonArg - Specifies the Event's mouse button.
        relatedTargetArg - Specifies the Event's related EventTarget.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


MutationEvent (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.events

Interface MutationEvent

  • All Superinterfaces:
    Event

    public interface MutationEvent
extends Event
    The MutationEvent interface provides specific contextual information associated with Mutation events.

    See also the Document Object Model (DOM) Level 2 Events Specification.

    Since:
    DOM Level 2

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short ADDITION
      The Attr was just added.
      static short MODIFICATION
      The Attr was modified in place.
      static short REMOVAL
      The Attr was just removed.

      • Fields inherited from interface org.w3c.dom.events.Event

        AT_TARGET, BUBBLING_PHASE, CAPTURING_PHASE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      short getAttrChange()
      attrChange indicates the type of change which triggered the DOMAttrModified event.
      String getAttrName()
      attrName indicates the name of the changed Attr node in a DOMAttrModified event.
      String getNewValue()
      newValue indicates the new value of the Attr node in DOMAttrModified events, and of the CharacterData node in DOMCharacterDataModified events.
      String getPrevValue()
      prevValue indicates the previous value of the Attr node in DOMAttrModified events, and of the CharacterData node in DOMCharacterDataModified events.
      Node getRelatedNode()
      relatedNode is used to identify a secondary node related to a mutation event.
      void initMutationEvent(String typeArg, boolean canBubbleArg, boolean cancelableArg, Node relatedNodeArg, String prevValueArg, String newValueArg, String attrNameArg, short attrChangeArg)
      The initMutationEvent method is used to initialize the value of a MutationEvent created through the DocumentEvent interface.

      • Methods inherited from interface org.w3c.dom.events.Event

        getBubbles, getCancelable, getCurrentTarget, getEventPhase, getTarget, getTimeStamp, getType, initEvent, preventDefault, stopPropagation

    • Field Detail

      • MODIFICATION

        static final short MODIFICATION
        The Attr was modified in place.
        See Also:
        Constant Field Values

      • ADDITION

        static final short ADDITION
        The Attr was just added.
        See Also:
        Constant Field Values

      • REMOVAL

        static final short REMOVAL
        The Attr was just removed.
        See Also:
        Constant Field Values

    • Method Detail

      • getRelatedNode

        Node getRelatedNode()
        relatedNode is used to identify a secondary node related to a mutation event. For example, if a mutation event is dispatched to a node indicating that its parent has changed, the relatedNode is the changed parent. If an event is instead dispatched to a subtree indicating a node was changed within it, the relatedNode is the changed node. In the case of the DOMAttrModified event it indicates the Attr node which was modified, added, or removed.

      • getPrevValue

        String getPrevValue()
        prevValue indicates the previous value of the Attr node in DOMAttrModified events, and of the CharacterData node in DOMCharacterDataModified events.

      • getNewValue

        String getNewValue()
        newValue indicates the new value of the Attr node in DOMAttrModified events, and of the CharacterData node in DOMCharacterDataModified events.

      • getAttrName

        String getAttrName()
        attrName indicates the name of the changed Attr node in a DOMAttrModified event.

      • getAttrChange

        short getAttrChange()
        attrChange indicates the type of change which triggered the DOMAttrModified event. The values can be MODIFICATION , ADDITION, or REMOVAL.

      • initMutationEvent

        void initMutationEvent(String typeArg,
                       boolean canBubbleArg,
                       boolean cancelableArg,
                       Node relatedNodeArg,
                       String prevValueArg,
                       String newValueArg,
                       String attrNameArg,
                       short attrChangeArg)
        The initMutationEvent method is used to initialize the value of a MutationEvent created through the DocumentEvent interface. This method may only be called before the MutationEvent has been dispatched via the dispatchEvent method, though it may be called multiple times during that phase if necessary. If called multiple times, the final invocation takes precedence.
        Parameters:
        typeArg - Specifies the event type.
        canBubbleArg - Specifies whether or not the event can bubble.
        cancelableArg - Specifies whether or not the event's default action can be prevented.
        relatedNodeArg - Specifies the Event's related Node.
        prevValueArg - Specifies the Event's prevValue attribute. This value may be null.
        newValueArg - Specifies the Event's newValue attribute. This value may be null.
        attrNameArg - Specifies the Event's attrName attribute. This value may be null.
        attrChangeArg - Specifies the Event's attrChange attribute
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


org.w3c.dom.events (Java Platform SE 8 )

org.w3c.dom.events

Interfaces

  • DocumentEvent
  • Event
  • EventListener
  • EventTarget
  • MouseEvent
  • MutationEvent
  • UIEvent

Exceptions

  • EventException


org.w3c.dom.events (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.w3c.dom.events

  • Interface Summary
    Interface Description
    DocumentEvent
    The DocumentEvent interface provides a mechanism by which the user can create an Event of a type supported by the implementation.
    Event
    The Event interface is used to provide contextual information about an event to the handler processing the event.
    EventListener
    The EventListener interface is the primary method for handling events.
    EventTarget
    The EventTarget interface is implemented by all Nodes in an implementation which supports the DOM Event Model.
    MouseEvent
    The MouseEvent interface provides specific contextual information associated with Mouse events.
    MutationEvent
    The MutationEvent interface provides specific contextual information associated with Mutation events.
    UIEvent
    The UIEvent interface provides specific contextual information associated with User Interface events.
  • Exception Summary
    Exception Description
    EventException
    Event operations may throw an EventException as specified in their method descriptions.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames


org.w3c.dom.events Class Hierarchy (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.w3c.dom.events

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.w3c.dom.events.EventException

Interface Hierarchy

  • org.w3c.dom.events.DocumentEvent
  • org.w3c.dom.events.Event
    • org.w3c.dom.events.MutationEvent
    • org.w3c.dom.events.UIEvent
      • org.w3c.dom.events.MouseEvent
  • org.w3c.dom.events.EventListener
  • org.w3c.dom.events.EventTarget
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package org.w3c.dom.events (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.w3c.dom.events

  • Packages that use org.w3c.dom.events
    Package Description
    org.w3c.dom.events
    org.w3c.dom.ls
  • Classes in org.w3c.dom.events used by org.w3c.dom.events
    Class and Description
    Event
    The Event interface is used to provide contextual information about an event to the handler processing the event.
    EventException
    Event operations may throw an EventException as specified in their method descriptions.
    EventListener
    The EventListener interface is the primary method for handling events.
    EventTarget
    The EventTarget interface is implemented by all Nodes in an implementation which supports the DOM Event Model.
    UIEvent
    The UIEvent interface provides specific contextual information associated with User Interface events.
  • Classes in org.w3c.dom.events used by org.w3c.dom.ls
    Class and Description
    Event
    The Event interface is used to provide contextual information about an event to the handler processing the event.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


UIEvent (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.events

Interface UIEvent

  • All Superinterfaces:
    Event
    All Known Subinterfaces:
    MouseEvent

    public interface UIEvent
extends Event
    The UIEvent interface provides specific contextual information associated with User Interface events.

    See also the Document Object Model (DOM) Level 2 Events Specification.

    Since:
    DOM Level 2

    • Field Summary

      • Fields inherited from interface org.w3c.dom.events.Event

        AT_TARGET, BUBBLING_PHASE, CAPTURING_PHASE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      int getDetail()
      Specifies some detail information about the Event, depending on the type of event.
      AbstractView getView()
      The view attribute identifies the AbstractView from which the event was generated.
      void initUIEvent(String typeArg, boolean canBubbleArg, boolean cancelableArg, AbstractView viewArg, int detailArg)
      The initUIEvent method is used to initialize the value of a UIEvent created through the DocumentEvent interface.

      • Methods inherited from interface org.w3c.dom.events.Event

        getBubbles, getCancelable, getCurrentTarget, getEventPhase, getTarget, getTimeStamp, getType, initEvent, preventDefault, stopPropagation

    • Method Detail

      • getView

        AbstractView getView()
        The view attribute identifies the AbstractView from which the event was generated.

      • getDetail

        int getDetail()
        Specifies some detail information about the Event, depending on the type of event.

      • initUIEvent

        void initUIEvent(String typeArg,
                 boolean canBubbleArg,
                 boolean cancelableArg,
                 AbstractView viewArg,
                 int detailArg)
        The initUIEvent method is used to initialize the value of a UIEvent created through the DocumentEvent interface. This method may only be called before the UIEvent has been dispatched via the dispatchEvent method, though it may be called multiple times during that phase if necessary. If called multiple times, the final invocation takes precedence.
        Parameters:
        typeArg - Specifies the event type.
        canBubbleArg - Specifies whether or not the event can bubble.
        cancelableArg - Specifies whether or not the event's default action can be prevented.
        viewArg - Specifies the Event's AbstractView.
        detailArg - Specifies the Event's detail.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Interface org.w3c.dom.ls.DOMImplementationLS (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.ls.DOMImplementationLS

No usage of org.w3c.dom.ls.DOMImplementationLS
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.w3c.dom.ls.LSException (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.w3c.dom.ls.LSException

  • Packages that use LSException
    Package Description
    org.w3c.dom.ls

    • Uses of LSException in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that throw LSException
      Modifier and Type Method and Description
      Document LSParser.parse(LSInput input)
      Parse an XML document from a resource identified by a LSInput.
      Document LSParser.parseURI(String uri)
      Parse an XML document from a location identified by a URI reference [IETF RFC 2396].
      Node LSParser.parseWithContext(LSInput input, Node contextArg, short action)
      Parse an XML fragment from a resource identified by a LSInput and insert the content into an existing document at the position specified with the context and action arguments.
      boolean LSSerializer.write(Node nodeArg, LSOutput destination)
      Serialize the specified node as described above in the general description of the LSSerializer interface.
      String LSSerializer.writeToString(Node nodeArg)
      Serialize the specified node as described above in the general description of the LSSerializer interface.
      boolean LSSerializer.writeToURI(Node nodeArg, String uri)
      A convenience method that acts as if LSSerializer.write was called with a LSOutput with no encoding specified and LSOutput.systemId set to the uri argument.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.ls.LSInput (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.ls.LSInput

  • Packages that use LSInput
    Package Description
    org.w3c.dom.ls

    • Uses of LSInput in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that return LSInput
      Modifier and Type Method and Description
      LSInput DOMImplementationLS.createLSInput()
      Create a new empty input source object where LSInput.characterStream, LSInput.byteStream , LSInput.stringData LSInput.systemId, LSInput.publicId, LSInput.baseURI, and LSInput.encoding are null, and LSInput.certifiedText is false.
      LSInput LSLoadEvent.getInput()
      The input source that was parsed.
      LSInput LSProgressEvent.getInput()
      The input source that is being parsed.
      LSInput LSResourceResolver.resolveResource(String type, String namespaceURI, String publicId, String systemId, String baseURI)
      Allow the application to resolve external resources.
      Methods in org.w3c.dom.ls with parameters of type LSInput
      Modifier and Type Method and Description
      Document LSParser.parse(LSInput input)
      Parse an XML document from a resource identified by a LSInput.
      Node LSParser.parseWithContext(LSInput input, Node contextArg, short action)
      Parse an XML fragment from a resource identified by a LSInput and insert the content into an existing document at the position specified with the context and action arguments.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.ls.LSLoadEvent (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.ls.LSLoadEvent

No usage of org.w3c.dom.ls.LSLoadEvent
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.ls.LSOutput (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.ls.LSOutput

  • Packages that use LSOutput
    Package Description
    org.w3c.dom.ls

    • Uses of LSOutput in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that return LSOutput
      Modifier and Type Method and Description
      LSOutput DOMImplementationLS.createLSOutput()
      Create a new empty output destination object where LSOutput.characterStream, LSOutput.byteStream, LSOutput.systemId, LSOutput.encoding are null.
      Methods in org.w3c.dom.ls with parameters of type LSOutput
      Modifier and Type Method and Description
      boolean LSSerializer.write(Node nodeArg, LSOutput destination)
      Serialize the specified node as described above in the general description of the LSSerializer interface.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.ls.LSParser (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.ls.LSParser

  • Packages that use LSParser
    Package Description
    org.w3c.dom.ls

    • Uses of LSParser in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that return LSParser
      Modifier and Type Method and Description
      LSParser DOMImplementationLS.createLSParser(short mode, String schemaType)
      Create a new LSParser.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.ls.LSParserFilter (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.ls.LSParserFilter

  • Packages that use LSParserFilter
    Package Description
    org.w3c.dom.ls

    • Uses of LSParserFilter in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that return LSParserFilter
      Modifier and Type Method and Description
      LSParserFilter LSParser.getFilter()
      When a filter is provided, the implementation will call out to the filter as it is constructing the DOM tree structure.
      Methods in org.w3c.dom.ls with parameters of type LSParserFilter
      Modifier and Type Method and Description
      void LSParser.setFilter(LSParserFilter filter)
      When a filter is provided, the implementation will call out to the filter as it is constructing the DOM tree structure.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.ls.LSProgressEvent (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.ls.LSProgressEvent

No usage of org.w3c.dom.ls.LSProgressEvent
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.ls.LSResourceResolver (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.ls.LSResourceResolver

  • Packages that use LSResourceResolver
    Package Description
    javax.xml.validation
    This package provides an API for validation of XML documents.

    • Uses of LSResourceResolver in javax.xml.validation

      Methods in javax.xml.validation that return LSResourceResolver
      Modifier and Type Method and Description
      abstract LSResourceResolver ValidatorHandler.getResourceResolver()
      Gets the current LSResourceResolver set to this ValidatorHandler.
      abstract LSResourceResolver Validator.getResourceResolver()
      Gets the current LSResourceResolver set to this Validator.
      abstract LSResourceResolver SchemaFactory.getResourceResolver()
      Gets the current LSResourceResolver set to this SchemaFactory.
      Methods in javax.xml.validation with parameters of type LSResourceResolver
      Modifier and Type Method and Description
      abstract void ValidatorHandler.setResourceResolver(LSResourceResolver resourceResolver)
      Sets the LSResourceResolver to customize resource resolution while in a validation episode.
      abstract void Validator.setResourceResolver(LSResourceResolver resourceResolver)
      Sets the LSResourceResolver to customize resource resolution while in a validation episode.
      abstract void SchemaFactory.setResourceResolver(LSResourceResolver resourceResolver)
      Sets the LSResourceResolver to customize resource resolution when parsing schemas.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.ls.LSSerializer (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.ls.LSSerializer

  • Packages that use LSSerializer
    Package Description
    org.w3c.dom.ls

    • Uses of LSSerializer in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that return LSSerializer
      Modifier and Type Method and Description
      LSSerializer DOMImplementationLS.createLSSerializer()
      Create a new LSSerializer object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.ls.LSSerializerFilter (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.ls.LSSerializerFilter

  • Packages that use LSSerializerFilter
    Package Description
    org.w3c.dom.ls

    • Uses of LSSerializerFilter in org.w3c.dom.ls

      Methods in org.w3c.dom.ls that return LSSerializerFilter
      Modifier and Type Method and Description
      LSSerializerFilter LSSerializer.getFilter()
      When the application provides a filter, the serializer will call out to the filter before serializing each Node.
      Methods in org.w3c.dom.ls with parameters of type LSSerializerFilter
      Modifier and Type Method and Description
      void LSSerializer.setFilter(LSSerializerFilter filter)
      When the application provides a filter, the serializer will call out to the filter before serializing each Node.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


compact2 - org.w3c.dom.ls (Java Platform SE 8 )

compact2 - org.w3c.dom.ls

Interfaces

  • DOMImplementationLS
  • LSInput
  • LSLoadEvent
  • LSOutput
  • LSParser
  • LSParserFilter
  • LSProgressEvent
  • LSResourceResolver
  • LSSerializer
  • LSSerializerFilter

Exceptions

  • LSException


org.w3c.dom.ls (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact2

Package org.w3c.dom.ls

  • Interface Summary
    Interface Description
    DOMImplementationLS
    DOMImplementationLS contains the factory methods for creating Load and Save objects.
    LSInput
    This interface represents an input source for data.
    LSLoadEvent
    This interface represents a load event object that signals the completion of a document load.
    LSOutput
    This interface represents an output destination for data.
    LSParser
    An interface to an object that is able to build, or augment, a DOM tree from various input sources.
    LSParserFilter
    LSParserFilters provide applications the ability to examine nodes as they are being constructed while parsing.
    LSProgressEvent
    This interface represents a progress event object that notifies the application about progress as a document is parsed.
    LSResourceResolver
    LSResourceResolver provides a way for applications to redirect references to external resources.
    LSSerializer
    A LSSerializer provides an API for serializing (writing) a DOM document out into XML.
    LSSerializerFilter
    LSSerializerFilters provide applications the ability to examine nodes as they are being serialized and decide what nodes should be serialized or not.
  • Exception Summary
    Exception Description
    LSException
    Parser or write operations may throw an LSException if the processing is stopped.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames


compact3 - org.w3c.dom.ls (Java Platform SE 8 )

compact3 - org.w3c.dom.ls

Interfaces

  • DOMImplementationLS
  • LSInput
  • LSLoadEvent
  • LSOutput
  • LSParser
  • LSParserFilter
  • LSProgressEvent
  • LSResourceResolver
  • LSSerializer
  • LSSerializerFilter

Exceptions

  • LSException


org.w3c.dom.ls (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package org.w3c.dom.ls

  • Interface Summary
    Interface Description
    DOMImplementationLS
    DOMImplementationLS contains the factory methods for creating Load and Save objects.
    LSInput
    This interface represents an input source for data.
    LSLoadEvent
    This interface represents a load event object that signals the completion of a document load.
    LSOutput
    This interface represents an output destination for data.
    LSParser
    An interface to an object that is able to build, or augment, a DOM tree from various input sources.
    LSParserFilter
    LSParserFilters provide applications the ability to examine nodes as they are being constructed while parsing.
    LSProgressEvent
    This interface represents a progress event object that notifies the application about progress as a document is parsed.
    LSResourceResolver
    LSResourceResolver provides a way for applications to redirect references to external resources.
    LSSerializer
    A LSSerializer provides an API for serializing (writing) a DOM document out into XML.
    LSSerializerFilter
    LSSerializerFilters provide applications the ability to examine nodes as they are being serialized and decide what nodes should be serialized or not.
  • Exception Summary
    Exception Description
    LSException
    Parser or write operations may throw an LSException if the processing is stopped.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames


DOMImplementationLS (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.ls

Interface DOMImplementationLS

  • public interface DOMImplementationLS
    DOMImplementationLS contains the factory methods for creating Load and Save objects.

    The expectation is that an instance of the DOMImplementationLS interface can be obtained by using binding-specific casting methods on an instance of the DOMImplementation interface or, if the Document supports the feature "Core" version "3.0" defined in [DOM Level 3 Core] , by using the method DOMImplementation.getFeature with parameter values "LS" (or "LS-Async") and "3.0" (respectively).

    See also the Document Object Model (DOM) Level 3 Load and Save Specification.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short MODE_ASYNCHRONOUS
      Create an asynchronous LSParser.
      static short MODE_SYNCHRONOUS
      Create a synchronous LSParser.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      LSInput createLSInput()
      Create a new empty input source object where LSInput.characterStream, LSInput.byteStream , LSInput.stringData LSInput.systemId, LSInput.publicId, LSInput.baseURI, and LSInput.encoding are null, and LSInput.certifiedText is false.
      LSOutput createLSOutput()
      Create a new empty output destination object where LSOutput.characterStream, LSOutput.byteStream, LSOutput.systemId, LSOutput.encoding are null.
      LSParser createLSParser(short mode, String schemaType)
      Create a new LSParser.
      LSSerializer createLSSerializer()
      Create a new LSSerializer object.

    • Field Detail

      • MODE_SYNCHRONOUS

        static final short MODE_SYNCHRONOUS
        Create a synchronous LSParser.
        See Also:
        Constant Field Values

      • MODE_ASYNCHRONOUS

        static final short MODE_ASYNCHRONOUS
        Create an asynchronous LSParser.
        See Also:
        Constant Field Values

    • Method Detail

      • createLSParser

        LSParser createLSParser(short mode,
                        String schemaType)
                 throws DOMException
        Create a new LSParser. The newly constructed parser may then be configured by means of its DOMConfiguration object, and used to parse documents by means of its parse method.
        Parameters:
        mode - The mode argument is either MODE_SYNCHRONOUS or MODE_ASYNCHRONOUS, if mode is MODE_SYNCHRONOUS then the LSParser that is created will operate in synchronous mode, if it's MODE_ASYNCHRONOUS then the LSParser that is created will operate in asynchronous mode.
        schemaType - An absolute URI representing the type of the schema language used during the load of a Document using the newly created LSParser. Note that no lexical checking is done on the absolute URI. In order to create a LSParser for any kind of schema types (i.e. the LSParser will be free to use any schema found), use the value null.

        Note: For W3C XML Schema [XML Schema Part 1] , applications must use the value "http://www.w3.org/2001/XMLSchema". For XML DTD [XML 1.0], applications must use the value "http://www.w3.org/TR/REC-xml". Other Schema languages are outside the scope of the W3C and therefore should recommend an absolute URI in order to use this method.

        Returns:
        The newly created LSParser object. This LSParser is either synchronous or asynchronous depending on the value of the mode argument.

        Note: By default, the newly created LSParser does not contain a DOMErrorHandler, i.e. the value of the " error-handler" configuration parameter is null. However, implementations may provide a default error handler at creation time. In that case, the initial value of the "error-handler" configuration parameter on the new LSParser object contains a reference to the default error handler.

        Throws:
        DOMException - NOT_SUPPORTED_ERR: Raised if the requested mode or schema type is not supported.

      • createLSSerializer

        LSSerializer createLSSerializer()
        Create a new LSSerializer object.
        Returns:
        The newly created LSSerializer object.

        Note: By default, the newly created LSSerializer has no DOMErrorHandler, i.e. the value of the "error-handler" configuration parameter is null. However, implementations may provide a default error handler at creation time. In that case, the initial value of the "error-handler" configuration parameter on the new LSSerializer object contains a reference to the default error handler.

      • createLSInput

        LSInput createLSInput()
        Create a new empty input source object where LSInput.characterStream, LSInput.byteStream , LSInput.stringData LSInput.systemId, LSInput.publicId, LSInput.baseURI, and LSInput.encoding are null, and LSInput.certifiedText is false.
        Returns:
        The newly created input object.

      • createLSOutput

        LSOutput createLSOutput()
        Create a new empty output destination object where LSOutput.characterStream, LSOutput.byteStream, LSOutput.systemId, LSOutput.encoding are null.
        Returns:
        The newly created output object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


LSException (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.ls

Class LSException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.w3c.dom.ls.LSException
  • All Implemented Interfaces:
    Serializable

    public class LSException
extends RuntimeException
    Parser or write operations may throw an LSException if the processing is stopped. The processing can be stopped due to a DOMError with a severity of DOMError.SEVERITY_FATAL_ERROR or a non recovered DOMError.SEVERITY_ERROR, or if DOMErrorHandler.handleError() returned false.

    Note: As suggested in the definition of the constants in the DOMError interface, a DOM implementation may choose to continue after a fatal error, but the resulting DOM tree is then implementation dependent.

    See also the Document Object Model (DOM) Level 3 Load and Save Specification.

    See Also:
    Serialized Form

    • Field Summary

      Fields
      Modifier and Type | Field and Description
      short | code
      static short PARSE_ERR
      If an attempt was made to load a document, or an XML Fragment, using LSParser and the processing has been stopped.
      static short SERIALIZE_ERR
      If an attempt was made to serialize a Node using LSSerializer and the processing has been stopped.

    • Constructor Summary

      Constructors
      Constructor and Description
      LSException(short code, String message)

    • Method Summary

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Field Detail

      • code

        public short code

      • PARSE_ERR

        public static final short PARSE_ERR
        If an attempt was made to load a document, or an XML Fragment, using LSParser and the processing has been stopped.
        See Also:
        Constant Field Values

      • SERIALIZE_ERR

        public static final short SERIALIZE_ERR
        If an attempt was made to serialize a Node using LSSerializer and the processing has been stopped.
        See Also:
        Constant Field Values

    • Constructor Detail

      • LSException

        public LSException(short code,
                   String message)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


LSInput (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.ls

Interface LSInput

  • public interface LSInput
    This interface represents an input source for data.

    This interface allows an application to encapsulate information about an input source in a single object, which may include a public identifier, a system identifier, a byte stream (possibly with a specified encoding), a base URI, and/or a character stream.

    The exact definitions of a byte stream and a character stream are binding dependent.

    The application is expected to provide objects that implement this interface whenever such objects are needed. The application can either provide its own objects that implement this interface, or it can use the generic factory method DOMImplementationLS.createLSInput() to create objects that implement this interface.

    The LSParser will use the LSInput object to determine how to read data. The LSParser will look at the different inputs specified in the LSInput in the following order to know which one to read from, the first one that is not null and not an empty string will be used:

    1. LSInput.characterStream
    2. LSInput.byteStream
    3. LSInput.stringData
    4. LSInput.systemId
    5. LSInput.publicId

    If all inputs are null, the LSParser will report a DOMError with its DOMError.type set to "no-input-specified" and its DOMError.severity set to DOMError.SEVERITY_FATAL_ERROR.

    LSInput objects belong to the application. The DOM implementation will never modify them (though it may make copies and modify the copies, if necessary).

    See also the Document Object Model (DOM) Level 3 Load and Save Specification.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getBaseURI()
      The base URI to be used (see section 5.1.4 in [IETF RFC 2396]) for resolving a relative systemId to an absolute URI.
      InputStream getByteStream()
      An attribute of a language and binding dependent type that represents a stream of bytes.
      boolean getCertifiedText()
      If set to true, assume that the input is certified (see section 2.13 in [XML 1.1]) when parsing [XML 1.1].
      Reader getCharacterStream()
      An attribute of a language and binding dependent type that represents a stream of 16-bit units.
      String getEncoding()
      The character encoding, if known.
      String getPublicId()
      The public identifier for this input source.
      String getStringData()
      String data to parse.
      String getSystemId()
      The system identifier, a URI reference [IETF RFC 2396], for this input source.
      void setBaseURI(String baseURI)
      The base URI to be used (see section 5.1.4 in [IETF RFC 2396]) for resolving a relative systemId to an absolute URI.
      void setByteStream(InputStream byteStream)
      An attribute of a language and binding dependent type that represents a stream of bytes.
      void setCertifiedText(boolean certifiedText)
      If set to true, assume that the input is certified (see section 2.13 in [XML 1.1]) when parsing [XML 1.1].
      void setCharacterStream(Reader characterStream)
      An attribute of a language and binding dependent type that represents a stream of 16-bit units.
      void setEncoding(String encoding)
      The character encoding, if known.
      void setPublicId(String publicId)
      The public identifier for this input source.
      void setStringData(String stringData)
      String data to parse.
      void setSystemId(String systemId)
      The system identifier, a URI reference [IETF RFC 2396], for this input source.

    • Method Detail

      • getCharacterStream

        Reader getCharacterStream()
        An attribute of a language and binding dependent type that represents a stream of 16-bit units. The application must encode the stream using UTF-16 (defined in [Unicode] and in [ISO/IEC 10646]). It is not a requirement to have an XML declaration when using character streams. If an XML declaration is present, the value of the encoding attribute will be ignored.

      • setCharacterStream

        void setCharacterStream(Reader characterStream)
        An attribute of a language and binding dependent type that represents a stream of 16-bit units. The application must encode the stream using UTF-16 (defined in [Unicode] and in [ISO/IEC 10646]). It is not a requirement to have an XML declaration when using character streams. If an XML declaration is present, the value of the encoding attribute will be ignored.

      • getByteStream

        InputStream getByteStream()
        An attribute of a language and binding dependent type that represents a stream of bytes.
        If the application knows the character encoding of the byte stream, it should set the encoding attribute. Setting the encoding in this way will override any encoding specified in an XML declaration in the data.

      • setByteStream

        void setByteStream(InputStream byteStream)
        An attribute of a language and binding dependent type that represents a stream of bytes.
        If the application knows the character encoding of the byte stream, it should set the encoding attribute. Setting the encoding in this way will override any encoding specified in an XML declaration in the data.

      • getStringData

        String getStringData()
        String data to parse. If provided, this will always be treated as a sequence of 16-bit units (UTF-16 encoded characters). It is not a requirement to have an XML declaration when using stringData. If an XML declaration is present, the value of the encoding attribute will be ignored.

      • setStringData

        void setStringData(String stringData)
        String data to parse. If provided, this will always be treated as a sequence of 16-bit units (UTF-16 encoded characters). It is not a requirement to have an XML declaration when using stringData. If an XML declaration is present, the value of the encoding attribute will be ignored.

      • getSystemId

        String getSystemId()
        The system identifier, a URI reference [IETF RFC 2396], for this input source. The system identifier is optional if there is a byte stream, a character stream, or string data. It is still useful to provide one, since the application will use it to resolve any relative URIs and can include it in error messages and warnings. (The LSParser will only attempt to fetch the resource identified by the URI reference if there is no other input available in the input source.)
        If the application knows the character encoding of the object pointed to by the system identifier, it can set the encoding using the encoding attribute.
        If the specified system ID is a relative URI reference (see section 5 in [IETF RFC 2396]), the DOM implementation will attempt to resolve the relative URI with the baseURI as the base, if that fails, the behavior is implementation dependent.

      • setSystemId

        void setSystemId(String systemId)
        The system identifier, a URI reference [IETF RFC 2396], for this input source. The system identifier is optional if there is a byte stream, a character stream, or string data. It is still useful to provide one, since the application will use it to resolve any relative URIs and can include it in error messages and warnings. (The LSParser will only attempt to fetch the resource identified by the URI reference if there is no other input available in the input source.)
        If the application knows the character encoding of the object pointed to by the system identifier, it can set the encoding using the encoding attribute.
        If the specified system ID is a relative URI reference (see section 5 in [IETF RFC 2396]), the DOM implementation will attempt to resolve the relative URI with the baseURI as the base, if that fails, the behavior is implementation dependent.

      • getPublicId

        String getPublicId()
        The public identifier for this input source. This may be mapped to an input source using an implementation dependent mechanism (such as catalogues or other mappings). The public identifier, if specified, may also be reported as part of the location information when errors are reported.

      • setPublicId

        void setPublicId(String publicId)
        The public identifier for this input source. This may be mapped to an input source using an implementation dependent mechanism (such as catalogues or other mappings). The public identifier, if specified, may also be reported as part of the location information when errors are reported.

      • getBaseURI

        String getBaseURI()
        The base URI to be used (see section 5.1.4 in [IETF RFC 2396]) for resolving a relative systemId to an absolute URI.
        If, when used, the base URI is itself a relative URI, an empty string, or null, the behavior is implementation dependent.

      • setBaseURI

        void setBaseURI(String baseURI)
        The base URI to be used (see section 5.1.4 in [IETF RFC 2396]) for resolving a relative systemId to an absolute URI.
        If, when used, the base URI is itself a relative URI, an empty string, or null, the behavior is implementation dependent.

      • getEncoding

        String getEncoding()
        The character encoding, if known. The encoding must be a string acceptable for an XML encoding declaration ([XML 1.0] section 4.3.3 "Character Encoding in Entities").
        This attribute has no effect when the application provides a character stream or string data. For other sources of input, an encoding specified by means of this attribute will override any encoding specified in the XML declaration or the Text declaration, or an encoding obtained from a higher level protocol, such as HTTP [IETF RFC 2616].

      • setEncoding

        void setEncoding(String encoding)
        The character encoding, if known. The encoding must be a string acceptable for an XML encoding declaration ([XML 1.0] section 4.3.3 "Character Encoding in Entities").
        This attribute has no effect when the application provides a character stream or string data. For other sources of input, an encoding specified by means of this attribute will override any encoding specified in the XML declaration or the Text declaration, or an encoding obtained from a higher level protocol, such as HTTP [IETF RFC 2616].

      • getCertifiedText

        boolean getCertifiedText()
        If set to true, assume that the input is certified (see section 2.13 in [XML 1.1]) when parsing [XML 1.1].

      • setCertifiedText

        void setCertifiedText(boolean certifiedText)
        If set to true, assume that the input is certified (see section 2.13 in [XML 1.1]) when parsing [XML 1.1].
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


LSLoadEvent (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.ls

Interface LSLoadEvent

  • All Superinterfaces:
    Event

    public interface LSLoadEvent
extends Event
    This interface represents a load event object that signals the completion of a document load.

    See also the Document Object Model (DOM) Level 3 Load and Save Specification.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.events.Event

        AT_TARGET, BUBBLING_PHASE, CAPTURING_PHASE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      LSInput getInput()
      The input source that was parsed.
      Document getNewDocument()
      The document that finished loading.

      • Methods inherited from interface org.w3c.dom.events.Event

        getBubbles, getCancelable, getCurrentTarget, getEventPhase, getTarget, getTimeStamp, getType, initEvent, preventDefault, stopPropagation

    • Method Detail

      • getNewDocument

        Document getNewDocument()
        The document that finished loading.

      • getInput

        LSInput getInput()
        The input source that was parsed.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


LSOutput (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.ls

Interface LSOutput

  • public interface LSOutput
    This interface represents an output destination for data.

    This interface allows an application to encapsulate information about an output destination in a single object, which may include a URI, a byte stream (possibly with a specified encoding), a base URI, and/or a character stream.

    The exact definitions of a byte stream and a character stream are binding dependent.

    The application is expected to provide objects that implement this interface whenever such objects are needed. The application can either provide its own objects that implement this interface, or it can use the generic factory method DOMImplementationLS.createLSOutput() to create objects that implement this interface.

    The LSSerializer will use the LSOutput object to determine where to serialize the output to. The LSSerializer will look at the different outputs specified in the LSOutput in the following order to know which one to output to, the first one that is not null and not an empty string will be used:

    1. LSOutput.characterStream
    2. LSOutput.byteStream
    3. LSOutput.systemId

    LSOutput objects belong to the application. The DOM implementation will never modify them (though it may make copies and modify the copies, if necessary).

    See also the Document Object Model (DOM) Level 3 Load and Save Specification.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      OutputStream getByteStream()
      An attribute of a language and binding dependent type that represents a writable stream of bytes.
      Writer getCharacterStream()
      An attribute of a language and binding dependent type that represents a writable stream to which 16-bit units can be output.
      String getEncoding()
      The character encoding to use for the output.
      String getSystemId()
      The system identifier, a URI reference [IETF RFC 2396], for this output destination.
      void setByteStream(OutputStream byteStream)
      An attribute of a language and binding dependent type that represents a writable stream of bytes.
      void setCharacterStream(Writer characterStream)
      An attribute of a language and binding dependent type that represents a writable stream to which 16-bit units can be output.
      void setEncoding(String encoding)
      The character encoding to use for the output.
      void setSystemId(String systemId)
      The system identifier, a URI reference [IETF RFC 2396], for this output destination.

    • Method Detail

      • getCharacterStream

        Writer getCharacterStream()
        An attribute of a language and binding dependent type that represents a writable stream to which 16-bit units can be output.

      • setCharacterStream

        void setCharacterStream(Writer characterStream)
        An attribute of a language and binding dependent type that represents a writable stream to which 16-bit units can be output.

      • getByteStream

        OutputStream getByteStream()
        An attribute of a language and binding dependent type that represents a writable stream of bytes.

      • setByteStream

        void setByteStream(OutputStream byteStream)
        An attribute of a language and binding dependent type that represents a writable stream of bytes.

      • getSystemId

        String getSystemId()
        The system identifier, a URI reference [IETF RFC 2396], for this output destination.
        If the system ID is a relative URI reference (see section 5 in [IETF RFC 2396]), the behavior is implementation dependent.

      • setSystemId

        void setSystemId(String systemId)
        The system identifier, a URI reference [IETF RFC 2396], for this output destination.
        If the system ID is a relative URI reference (see section 5 in [IETF RFC 2396]), the behavior is implementation dependent.

      • getEncoding

        String getEncoding()
        The character encoding to use for the output. The encoding must be a string acceptable for an XML encoding declaration ([XML 1.0] section 4.3.3 "Character Encoding in Entities"), it is recommended that character encodings registered (as charsets) with the Internet Assigned Numbers Authority [IANA-CHARSETS] should be referred to using their registered names.

      • setEncoding

        void setEncoding(String encoding)
        The character encoding to use for the output. The encoding must be a string acceptable for an XML encoding declaration ([XML 1.0] section 4.3.3 "Character Encoding in Entities"), it is recommended that character encodings registered (as charsets) with the Internet Assigned Numbers Authority [IANA-CHARSETS] should be referred to using their registered names.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


LSParser (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.ls

Interface LSParser

  • public interface LSParser
    An interface to an object that is able to build, or augment, a DOM tree from various input sources.

    LSParser provides an API for parsing XML and building the corresponding DOM document structure. A LSParser instance can be obtained by invoking the DOMImplementationLS.createLSParser() method.

    As specified in [DOM Level 3 Core] , when a document is first made available via the LSParser:

    • there will never be two adjacent nodes of type NODE_TEXT, and there will never be empty text nodes.
    • it is expected that the value and nodeValue attributes of an Attr node initially return the XML 1.0 normalized value. However, if the parameters " validate-if-schema" and " datatype-normalization" are set to true, depending on the attribute normalization used, the attribute values may differ from the ones obtained by the XML 1.0 attribute normalization. If the parameters " datatype-normalization" is set to false, the XML 1.0 attribute normalization is guaranteed to occur, and if the attributes list does not contain namespace declarations, the attributes attribute on Element node represents the property [attributes] defined in [XML Information Set] .

    Asynchronous LSParser objects are expected to also implement the events::EventTarget interface so that event listeners can be registered on asynchronous LSParser objects.

    Events supported by asynchronous LSParser objects are:

    load
    The LSParser finishes to load the document. See also the definition of the LSLoadEvent interface.
    progress
    The LSParser signals progress as data is parsed. This specification does not attempt to define exactly when progress events should be dispatched. That is intentionally left as implementation-dependent. Here is one example of how an application might dispatch progress events: Once the parser starts receiving data, a progress event is dispatched to indicate that the parsing starts. From there on, a progress event is dispatched for every 4096 bytes of data that is received and processed. This is only one example, though, and implementations can choose to dispatch progress events at any time while parsing, or not dispatch them at all. See also the definition of the LSProgressEvent interface.

    Note: All events defined in this specification use the namespace URI "http://www.w3.org/2002/DOMLS".

    While parsing an input source, errors are reported to the application through the error handler (LSParser.domConfig's " error-handler" parameter). This specification does in no way try to define all possible errors that can occur while parsing XML, or any other markup, but some common error cases are defined. The types (DOMError.type) of errors and warnings defined by this specification are:

    "check-character-normalization-failure" [error]
    Raised if the parameter " check-character-normalization" is set to true and a string is encountered that fails normalization checking.
    "doctype-not-allowed" [fatal]
    Raised if the configuration parameter "disallow-doctype" is set to true and a doctype is encountered.
    "no-input-specified" [fatal]
    Raised when loading a document and no input is specified in the LSInput object.
    "pi-base-uri-not-preserved" [warning]
    Raised if a processing instruction is encountered in a location where the base URI of the processing instruction can not be preserved. One example of a case where this warning will be raised is if the configuration parameter " entities" is set to false and the following XML file is parsed:
     <!DOCTYPE root [ <!ENTITY e SYSTEM 'subdir/myentity.ent' ]>
 <root> &e; </root>
    And subdir/myentity.ent contains:
    <one> <two/> </one> <?pi 3.14159?>
 <more/>
    "unbound-prefix-in-entity" [warning]
    An implementation dependent warning that may be raised if the configuration parameter " namespaces" is set to true and an unbound namespace prefix is encountered in an entity's replacement text. Raising this warning is not enforced since some existing parsers may not recognize unbound namespace prefixes in the replacement text of entities.
    "unknown-character-denormalization" [fatal]
    Raised if the configuration parameter "ignore-unknown-character-denormalizations" is set to false and a character is encountered for which the processor cannot determine the normalization properties.
    "unsupported-encoding" [fatal]
    Raised if an unsupported encoding is encountered.
    "unsupported-media-type" [fatal]
    Raised if the configuration parameter "supported-media-types-only" is set to true and an unsupported media type is encountered.

    In addition to raising the defined errors and warnings, implementations are expected to raise implementation specific errors and warnings for any other error and warning cases such as IO errors (file not found, permission denied,...), XML well-formedness errors, and so on.

    See also the Document Object Model (DOM) Level 3 Load and Save Specification.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short ACTION_APPEND_AS_CHILDREN
      Append the result of the parse operation as children of the context node.
      static short ACTION_INSERT_AFTER
      Insert the result of the parse operation as the immediately following sibling of the context node.
      static short ACTION_INSERT_BEFORE
      Insert the result of the parse operation as the immediately preceding sibling of the context node.
      static short ACTION_REPLACE
      Replace the context node with the result of the parse operation.
      static short ACTION_REPLACE_CHILDREN
      Replace all the children of the context node with the result of the parse operation.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void abort()
      Abort the loading of the document that is currently being loaded by the LSParser.
      boolean getAsync()
      true if the LSParser is asynchronous, false if it is synchronous.
      boolean getBusy()
      true if the LSParser is currently busy loading a document, otherwise false.
      DOMConfiguration getDomConfig()
      The DOMConfiguration object used when parsing an input source.
      LSParserFilter getFilter()
      When a filter is provided, the implementation will call out to the filter as it is constructing the DOM tree structure.
      Document parse(LSInput input)
      Parse an XML document from a resource identified by a LSInput.
      Document parseURI(String uri)
      Parse an XML document from a location identified by a URI reference [IETF RFC 2396].
      Node parseWithContext(LSInput input, Node contextArg, short action)
      Parse an XML fragment from a resource identified by a LSInput and insert the content into an existing document at the position specified with the context and action arguments.
      void setFilter(LSParserFilter filter)
      When a filter is provided, the implementation will call out to the filter as it is constructing the DOM tree structure.

    • Field Detail

      • ACTION_APPEND_AS_CHILDREN

        static final short ACTION_APPEND_AS_CHILDREN
        Append the result of the parse operation as children of the context node. For this action to work, the context node must be an Element or a DocumentFragment.
        See Also:
        Constant Field Values

      • ACTION_REPLACE_CHILDREN

        static final short ACTION_REPLACE_CHILDREN
        Replace all the children of the context node with the result of the parse operation. For this action to work, the context node must be an Element, a Document, or a DocumentFragment.
        See Also:
        Constant Field Values

      • ACTION_INSERT_BEFORE

        static final short ACTION_INSERT_BEFORE
        Insert the result of the parse operation as the immediately preceding sibling of the context node. For this action to work the context node's parent must be an Element or a DocumentFragment.
        See Also:
        Constant Field Values

      • ACTION_INSERT_AFTER

        static final short ACTION_INSERT_AFTER
        Insert the result of the parse operation as the immediately following sibling of the context node. For this action to work the context node's parent must be an Element or a DocumentFragment.
        See Also:
        Constant Field Values

      • ACTION_REPLACE

        static final short ACTION_REPLACE
        Replace the context node with the result of the parse operation. For this action to work, the context node must have a parent, and the parent must be an Element or a DocumentFragment.
        See Also:
        Constant Field Values

    • Method Detail

      • getDomConfig

        DOMConfiguration getDomConfig()
        The DOMConfiguration object used when parsing an input source. This DOMConfiguration is specific to the parse operation. No parameter values from this DOMConfiguration object are passed automatically to the DOMConfiguration object on the Document that is created, or used, by the parse operation. The DOM application is responsible for passing any needed parameter values from this DOMConfiguration object to the DOMConfiguration object referenced by the Document object.
        In addition to the parameters recognized in on the DOMConfiguration interface defined in [DOM Level 3 Core] , the DOMConfiguration objects for LSParser add or modify the following parameters:
        "charset-overrides-xml-encoding"
        true
        [optional] (default) If a higher level protocol such as HTTP [IETF RFC 2616] provides an indication of the character encoding of the input stream being processed, that will override any encoding specified in the XML declaration or the Text declaration (see also section 4.3.3, "Character Encoding in Entities", in [XML 1.0]). Explicitly setting an encoding in the LSInput overrides any encoding from the protocol.
        false
        [required] The parser ignores any character set encoding information from higher-level protocols.
        "disallow-doctype"
        true
        [optional] Throw a fatal "doctype-not-allowed" error if a doctype node is found while parsing the document. This is useful when dealing with things like SOAP envelopes where doctype nodes are not allowed.
        false
        [required] (default) Allow doctype nodes in the document.
        "ignore-unknown-character-denormalizations"
        true
        [required] (default) If, while verifying full normalization when [XML 1.1] is supported, a processor encounters characters for which it cannot determine the normalization properties, then the processor will ignore any possible denormalizations caused by these characters. This parameter is ignored for [XML 1.0].
        false
        [optional] Report an fatal "unknown-character-denormalization" error if a character is encountered for which the processor cannot determine the normalization properties.
        "infoset"
        See the definition of DOMConfiguration for a description of this parameter. Unlike in [DOM Level 3 Core] , this parameter will default to true for LSParser.
        "namespaces"
        true
        [required] (default) Perform the namespace processing as defined in [XML Namespaces] and [XML Namespaces 1.1] .
        false
        [optional] Do not perform the namespace processing.
        "resource-resolver"
        [required] A reference to a LSResourceResolver object, or null. If the value of this parameter is not null when an external resource (such as an external XML entity or an XML schema location) is encountered, the implementation will request that the LSResourceResolver referenced in this parameter resolves the resource.
        "supported-media-types-only"
        true
        [optional] Check that the media type of the parsed resource is a supported media type. If an unsupported media type is encountered, a fatal error of type "unsupported-media-type" will be raised. The media types defined in [IETF RFC 3023] must always be accepted.
        false
        [required] (default) Accept any media type.
        "validate"
        See the definition of DOMConfiguration for a description of this parameter. Unlike in [DOM Level 3 Core] , the processing of the internal subset is always accomplished, even if this parameter is set to false.
        "validate-if-schema"
        See the definition of DOMConfiguration for a description of this parameter. Unlike in [DOM Level 3 Core] , the processing of the internal subset is always accomplished, even if this parameter is set to false.
        "well-formed"
        See the definition of DOMConfiguration for a description of this parameter. Unlike in [DOM Level 3 Core] , this parameter cannot be set to false.

      • getFilter

        LSParserFilter getFilter()
        When a filter is provided, the implementation will call out to the filter as it is constructing the DOM tree structure. The filter can choose to remove elements from the document being constructed, or to terminate the parsing early.
        The filter is invoked after the operations requested by the DOMConfiguration parameters have been applied. For example, if " validate" is set to true, the validation is done before invoking the filter.

      • setFilter

        void setFilter(LSParserFilter filter)
        When a filter is provided, the implementation will call out to the filter as it is constructing the DOM tree structure. The filter can choose to remove elements from the document being constructed, or to terminate the parsing early.
        The filter is invoked after the operations requested by the DOMConfiguration parameters have been applied. For example, if " validate" is set to true, the validation is done before invoking the filter.

      • getAsync

        boolean getAsync()
        true if the LSParser is asynchronous, false if it is synchronous.

      • getBusy

        boolean getBusy()
        true if the LSParser is currently busy loading a document, otherwise false.

      • parse

        Document parse(LSInput input)
        throws DOMException,
               LSException
        Parse an XML document from a resource identified by a LSInput.
        Parameters:
        input - The LSInput from which the source of the document is to be read.
        Returns:
        If the LSParser is a synchronous LSParser, the newly created and populated Document is returned. If the LSParser is asynchronous, null is returned since the document object may not yet be constructed when this method returns.
        Throws:
        DOMException - INVALID_STATE_ERR: Raised if the LSParser's LSParser.busy attribute is true.
        LSException - PARSE_ERR: Raised if the LSParser was unable to load the XML document. DOM applications should attach a DOMErrorHandler using the parameter " error-handler" if they wish to get details on the error.

      • parseURI

        Document parseURI(String uri)
           throws DOMException,
                  LSException
        Parse an XML document from a location identified by a URI reference [IETF RFC 2396]. If the URI contains a fragment identifier (see section 4.1 in [IETF RFC 2396]), the behavior is not defined by this specification, future versions of this specification may define the behavior.
        Parameters:
        uri - The location of the XML document to be read.
        Returns:
        If the LSParser is a synchronous LSParser, the newly created and populated Document is returned, or null if an error occured. If the LSParser is asynchronous, null is returned since the document object may not yet be constructed when this method returns.
        Throws:
        DOMException - INVALID_STATE_ERR: Raised if the LSParser.busy attribute is true.
        LSException - PARSE_ERR: Raised if the LSParser was unable to load the XML document. DOM applications should attach a DOMErrorHandler using the parameter " error-handler" if they wish to get details on the error.

      • parseWithContext

        Node parseWithContext(LSInput input,
                      Node contextArg,
                      short action)
               throws DOMException,
                      LSException
        Parse an XML fragment from a resource identified by a LSInput and insert the content into an existing document at the position specified with the context and action arguments. When parsing the input stream, the context node (or its parent, depending on where the result will be inserted) is used for resolving unbound namespace prefixes. The context node's ownerDocument node (or the node itself if the node of type DOCUMENT_NODE) is used to resolve default attributes and entity references.
        As the new data is inserted into the document, at least one mutation event is fired per new immediate child or sibling of the context node.
        If the context node is a Document node and the action is ACTION_REPLACE_CHILDREN, then the document that is passed as the context node will be changed such that its xmlEncoding, documentURI, xmlVersion, inputEncoding, xmlStandalone, and all other such attributes are set to what they would be set to if the input source was parsed using LSParser.parse().
        This method is always synchronous, even if the LSParser is asynchronous (LSParser.async is true).
        If an error occurs while parsing, the caller is notified through the ErrorHandler instance associated with the " error-handler" parameter of the DOMConfiguration.
        When calling parseWithContext, the values of the following configuration parameters will be ignored and their default values will always be used instead: " validate", " validate-if-schema", and " element-content-whitespace". Other parameters will be treated normally, and the parser is expected to call the LSParserFilter just as if a whole document was parsed.
        Parameters:
        input - The LSInput from which the source document is to be read. The source document must be an XML fragment, i.e. anything except a complete XML document (except in the case where the context node of type DOCUMENT_NODE, and the action is ACTION_REPLACE_CHILDREN), a DOCTYPE (internal subset), entity declaration(s), notation declaration(s), or XML or text declaration(s).
        contextArg - The node that is used as the context for the data that is being parsed. This node must be a Document node, a DocumentFragment node, or a node of a type that is allowed as a child of an Element node, e.g. it cannot be an Attribute node.
        action - This parameter describes which action should be taken between the new set of nodes being inserted and the existing children of the context node. The set of possible actions is defined in ACTION_TYPES above.
        Returns:
        Return the node that is the result of the parse operation. If the result is more than one top-level node, the first one is returned.
        Throws:
        DOMException - HIERARCHY_REQUEST_ERR: Raised if the content cannot replace, be inserted before, after, or as a child of the context node (see also Node.insertBefore or Node.replaceChild in [DOM Level 3 Core] ).
        NOT_SUPPORTED_ERR: Raised if the LSParser doesn't support this method, or if the context node is of type Document and the DOM implementation doesn't support the replacement of the DocumentType child or Element child.
        NO_MODIFICATION_ALLOWED_ERR: Raised if the context node is a read only node and the content is being appended to its child list, or if the parent node of the context node is read only node and the content is being inserted in its child list.
        INVALID_STATE_ERR: Raised if the LSParser.busy attribute is true.
        LSException - PARSE_ERR: Raised if the LSParser was unable to load the XML fragment. DOM applications should attach a DOMErrorHandler using the parameter " error-handler" if they wish to get details on the error.

      • abort

        void abort()
        Abort the loading of the document that is currently being loaded by the LSParser. If the LSParser is currently not busy, a call to this method does nothing.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


LSParserFilter (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.ls

Interface LSParserFilter

  • public interface LSParserFilter
    LSParserFilters provide applications the ability to examine nodes as they are being constructed while parsing. As each node is examined, it may be modified or removed, or the entire parse may be terminated early.

    At the time any of the filter methods are called by the parser, the owner Document and DOMImplementation objects exist and are accessible. The document element is never passed to the LSParserFilter methods, i.e. it is not possible to filter out the document element. Document, DocumentType, Notation, Entity, and Attr nodes are never passed to the acceptNode method on the filter. The child nodes of an EntityReference node are passed to the filter if the parameter " entities" is set to false. Note that, as described by the parameter " entities", unexpanded entity reference nodes are never discarded and are always passed to the filter.

    All validity checking while parsing a document occurs on the source document as it appears on the input stream, not on the DOM document as it is built in memory. With filters, the document in memory may be a subset of the document on the stream, and its validity may have been affected by the filtering.

    All default attributes must be present on elements when the elements are passed to the filter methods. All other default content must be passed to the filter methods.

    DOM applications must not raise exceptions in a filter. The effect of throwing exceptions from a filter is DOM implementation dependent.

    See also the Document Object Model (DOM) Level 3 Load and Save Specification.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short FILTER_ACCEPT
      Accept the node.
      static short FILTER_INTERRUPT
      Interrupt the normal processing of the document.
      static short FILTER_REJECT
      Reject the node and its children.
      static short FILTER_SKIP
      Skip this single node.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      short acceptNode(Node nodeArg)
      This method will be called by the parser at the completion of the parsing of each node.
      int getWhatToShow()
      Tells the LSParser what types of nodes to show to the method LSParserFilter.acceptNode.
      short startElement(Element elementArg)
      The parser will call this method after each Element start tag has been scanned, but before the remainder of the Element is processed.

    • Field Detail

      • FILTER_ACCEPT

        static final short FILTER_ACCEPT
        Accept the node.
        See Also:
        Constant Field Values

      • FILTER_REJECT

        static final short FILTER_REJECT
        Reject the node and its children.
        See Also:
        Constant Field Values

      • FILTER_SKIP

        static final short FILTER_SKIP
        Skip this single node. The children of this node will still be considered.
        See Also:
        Constant Field Values

      • FILTER_INTERRUPT

        static final short FILTER_INTERRUPT
        Interrupt the normal processing of the document.
        See Also:
        Constant Field Values

    • Method Detail

      • startElement

        short startElement(Element elementArg)
        The parser will call this method after each Element start tag has been scanned, but before the remainder of the Element is processed. The intent is to allow the element, including any children, to be efficiently skipped. Note that only element nodes are passed to the startElement function.
        The element node passed to startElement for filtering will include all of the Element's attributes, but none of the children nodes. The Element may not yet be in place in the document being constructed (it may not have a parent node.)
        A startElement filter function may access or change the attributes for the Element. Changing Namespace declarations will have no effect on namespace resolution by the parser.
        For efficiency, the Element node passed to the filter may not be the same one as is actually placed in the tree if the node is accepted. And the actual node (node object identity) may be reused during the process of reading in and filtering a document.
        Parameters:
        elementArg - The newly encountered element. At the time this method is called, the element is incomplete - it will have its attributes, but no children.
        Returns:
        • FILTER_ACCEPT if the Element should be included in the DOM document being built.
        • FILTER_REJECT if the Element and all of its children should be rejected.
        • FILTER_SKIP if the Element should be skipped. All of its children are inserted in place of the skipped Element node.
        • FILTER_INTERRUPT if the filter wants to stop the processing of the document. Interrupting the processing of the document does no longer guarantee that the resulting DOM tree is XML well-formed. The Element is rejected.
        Returning any other values will result in unspecified behavior.

      • acceptNode

        short acceptNode(Node nodeArg)
        This method will be called by the parser at the completion of the parsing of each node. The node and all of its descendants will exist and be complete. The parent node will also exist, although it may be incomplete, i.e. it may have additional children that have not yet been parsed. Attribute nodes are never passed to this function.
        From within this method, the new node may be freely modified - children may be added or removed, text nodes modified, etc. The state of the rest of the document outside this node is not defined, and the affect of any attempt to navigate to, or to modify any other part of the document is undefined.
        For validating parsers, the checks are made on the original document, before any modification by the filter. No validity checks are made on any document modifications made by the filter.
        If this new node is rejected, the parser might reuse the new node and any of its descendants.
        Parameters:
        nodeArg - The newly constructed element. At the time this method is called, the element is complete - it has all of its children (and their children, recursively) and attributes, and is attached as a child to its parent.
        Returns:
        • FILTER_ACCEPT if this Node should be included in the DOM document being built.
        • FILTER_REJECT if the Node and all of its children should be rejected.
        • FILTER_SKIP if the Node should be skipped and the Node should be replaced by all the children of the Node.
        • FILTER_INTERRUPT if the filter wants to stop the processing of the document. Interrupting the processing of the document does no longer guarantee that the resulting DOM tree is XML well-formed. The Node is accepted and will be the last completely parsed node.

      • getWhatToShow

        int getWhatToShow()
        Tells the LSParser what types of nodes to show to the method LSParserFilter.acceptNode. If a node is not shown to the filter using this attribute, it is automatically included in the DOM document being built. See NodeFilter for definition of the constants. The constants SHOW_ATTRIBUTE , SHOW_DOCUMENT, SHOW_DOCUMENT_TYPE, SHOW_NOTATION, SHOW_ENTITY, and SHOW_DOCUMENT_FRAGMENT are meaningless here. Those nodes will never be passed to LSParserFilter.acceptNode.
        The constants used here are defined in [DOM Level 2 Traversal and Range] .
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


LSProgressEvent (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.ls

Interface LSProgressEvent

  • All Superinterfaces:
    Event

    public interface LSProgressEvent
extends Event
    This interface represents a progress event object that notifies the application about progress as a document is parsed. It extends the Event interface defined in [DOM Level 3 Events] .

    The units used for the attributes position and totalSize are not specified and can be implementation and input dependent.

    See also the Document Object Model (DOM) Level 3 Load and Save Specification.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.events.Event

        AT_TARGET, BUBBLING_PHASE, CAPTURING_PHASE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      LSInput getInput()
      The input source that is being parsed.
      int getPosition()
      The current position in the input source, including all external entities and other resources that have been read.
      int getTotalSize()
      The total size of the document including all external resources, this number might change as a document is being parsed if references to more external resources are seen.

      • Methods inherited from interface org.w3c.dom.events.Event

        getBubbles, getCancelable, getCurrentTarget, getEventPhase, getTarget, getTimeStamp, getType, initEvent, preventDefault, stopPropagation

    • Method Detail

      • getInput

        LSInput getInput()
        The input source that is being parsed.

      • getPosition

        int getPosition()
        The current position in the input source, including all external entities and other resources that have been read.

      • getTotalSize

        int getTotalSize()
        The total size of the document including all external resources, this number might change as a document is being parsed if references to more external resources are seen. A value of 0 is returned if the total size cannot be determined or estimated.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


LSResourceResolver (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.ls

Interface LSResourceResolver

  • public interface LSResourceResolver
    LSResourceResolver provides a way for applications to redirect references to external resources.

    Applications needing to implement custom handling for external resources can implement this interface and register their implementation by setting the "resource-resolver" parameter of DOMConfiguration objects attached to LSParser and LSSerializer. It can also be register on DOMConfiguration objects attached to Document if the "LS" feature is supported.

    The LSParser will then allow the application to intercept any external entities, including the external DTD subset and external parameter entities, before including them. The top-level document entity is never passed to the resolveResource method.

    Many DOM applications will not need to implement this interface, but it will be especially useful for applications that build XML documents from databases or other specialized input sources, or for applications that use URNs.

    Note: LSResourceResolver is based on the SAX2 [SAX] EntityResolver interface.

    See also the Document Object Model (DOM) Level 3 Load and Save Specification.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      LSInput resolveResource(String type, String namespaceURI, String publicId, String systemId, String baseURI)
      Allow the application to resolve external resources.

    • Method Detail

      • resolveResource

        LSInput resolveResource(String type,
                        String namespaceURI,
                        String publicId,
                        String systemId,
                        String baseURI)
        Allow the application to resolve external resources.
        The LSParser will call this method before opening any external resource, including the external DTD subset, external entities referenced within the DTD, and external entities referenced within the document element (however, the top-level document entity is not passed to this method). The application may then request that the LSParser resolve the external resource itself, that it use an alternative URI, or that it use an entirely different input source.
        Application writers can use this method to redirect external system identifiers to secure and/or local URI, to look up public identifiers in a catalogue, or to read an entity from a database or other input source (including, for example, a dialog box).
        Parameters:
        type - The type of the resource being resolved. For XML [XML 1.0] resources (i.e. entities), applications must use the value "http://www.w3.org/TR/REC-xml". For XML Schema [XML Schema Part 1] , applications must use the value "http://www.w3.org/2001/XMLSchema". Other types of resources are outside the scope of this specification and therefore should recommend an absolute URI in order to use this method.
        namespaceURI - The namespace of the resource being resolved, e.g. the target namespace of the XML Schema [XML Schema Part 1] when resolving XML Schema resources.
        publicId - The public identifier of the external entity being referenced, or null if no public identifier was supplied or if the resource is not an entity.
        systemId - The system identifier, a URI reference [IETF RFC 2396], of the external resource being referenced, or null if no system identifier was supplied.
        baseURI - The absolute base URI of the resource being parsed, or null if there is no base URI.
        Returns:
        A LSInput object describing the new input source, or null to request that the parser open a regular URI connection to the resource.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


LSSerializer (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.ls

Interface LSSerializer

  • public interface LSSerializer
    A LSSerializer provides an API for serializing (writing) a DOM document out into XML. The XML data is written to a string or an output stream. Any changes or fixups made during the serialization affect only the serialized data. The Document object and its children are never altered by the serialization operation.

    During serialization of XML data, namespace fixup is done as defined in [DOM Level 3 Core] , Appendix B. [DOM Level 2 Core] allows empty strings as a real namespace URI. If the namespaceURI of a Node is empty string, the serialization will treat them as null, ignoring the prefix if any.

    LSSerializer accepts any node type for serialization. For nodes of type Document or Entity, well-formed XML will be created when possible (well-formedness is guaranteed if the document or entity comes from a parse operation and is unchanged since it was created). The serialized output for these node types is either as a XML document or an External XML Entity, respectively, and is acceptable input for an XML parser. For all other types of nodes the serialized form is implementation dependent.

    Within a Document, DocumentFragment, or Entity being serialized, Nodes are processed as follows

    • Document nodes are written, including the XML declaration (unless the parameter "xml-declaration" is set to false) and a DTD subset, if one exists in the DOM. Writing a Document node serializes the entire document.
    • Entity nodes, when written directly by LSSerializer.write, outputs the entity expansion but no namespace fixup is done. The resulting output will be valid as an external entity.
    • If the parameter " entities" is set to true, EntityReference nodes are serialized as an entity reference of the form " &entityName;" in the output. Child nodes (the expansion) of the entity reference are ignored. If the parameter " entities" is set to false, only the children of the entity reference are serialized. EntityReference nodes with no children (no corresponding Entity node or the corresponding Entity nodes have no children) are always serialized.
    • CDATAsections containing content characters that cannot be represented in the specified output encoding are handled according to the " split-cdata-sections" parameter. If the parameter is set to true, CDATAsections are split, and the unrepresentable characters are serialized as numeric character references in ordinary content. The exact position and number of splits is not specified. If the parameter is set to false, unrepresentable characters in a CDATAsection are reported as "wf-invalid-character" errors if the parameter " well-formed" is set to true. The error is not recoverable - there is no mechanism for supplying alternative characters and continuing with the serialization.
    • DocumentFragment nodes are serialized by serializing the children of the document fragment in the order they appear in the document fragment.
    • All other node types (Element, Text, etc.) are serialized to their corresponding XML source form.

    Note: The serialization of a Node does not always generate a well-formed XML document, i.e. a LSParser might throw fatal errors when parsing the resulting serialization.

    Within the character data of a document (outside of markup), any characters that cannot be represented directly are replaced with character references. Occurrences of '<' and '&' are replaced by the predefined entities &lt; and &amp;. The other predefined entities (&gt;, &apos;, and &quot;) might not be used, except where needed (e.g. using &gt; in cases such as ']]>'). Any characters that cannot be represented directly in the output character encoding are serialized as numeric character references (and since character encoding standards commonly use hexadecimal representations of characters, using the hexadecimal representation when serializing character references is encouraged).

    To allow attribute values to contain both single and double quotes, the apostrophe or single-quote character (') may be represented as "&apos;", and the double-quote character (") as "&quot;". New line characters and other characters that cannot be represented directly in attribute values in the output character encoding are serialized as a numeric character reference.

    Within markup, but outside of attributes, any occurrence of a character that cannot be represented in the output character encoding is reported as a DOMError fatal error. An example would be serializing the element <LaCa馻da/> with encoding="us-ascii". This will result with a generation of a DOMError "wf-invalid-character-in-node-name" (as proposed in " well-formed").

    When requested by setting the parameter " normalize-characters" on LSSerializer to true, character normalization is performed according to the definition of fully normalized characters included in appendix E of [XML 1.1] on all data to be serialized, both markup and character data. The character normalization process affects only the data as it is being written; it does not alter the DOM's view of the document after serialization has completed.

    Implementations are required to support the encodings "UTF-8", "UTF-16", "UTF-16BE", and "UTF-16LE" to guarantee that data is serializable in all encodings that are required to be supported by all XML parsers. When the encoding is UTF-8, whether or not a byte order mark is serialized, or if the output is big-endian or little-endian, is implementation dependent. When the encoding is UTF-16, whether or not the output is big-endian or little-endian is implementation dependent, but a Byte Order Mark must be generated for non-character outputs, such as LSOutput.byteStream or LSOutput.systemId. If the Byte Order Mark is not generated, a "byte-order-mark-needed" warning is reported. When the encoding is UTF-16LE or UTF-16BE, the output is big-endian (UTF-16BE) or little-endian (UTF-16LE) and the Byte Order Mark is not be generated. In all cases, the encoding declaration, if generated, will correspond to the encoding used during the serialization (e.g. encoding="UTF-16" will appear if UTF-16 was requested).

    Namespaces are fixed up during serialization, the serialization process will verify that namespace declarations, namespace prefixes and the namespace URI associated with elements and attributes are consistent. If inconsistencies are found, the serialized form of the document will be altered to remove them. The method used for doing the namespace fixup while serializing a document is the algorithm defined in Appendix B.1, "Namespace normalization", of [DOM Level 3 Core] .

    While serializing a document, the parameter "discard-default-content" controls whether or not non-specified data is serialized.

    While serializing, errors and warnings are reported to the application through the error handler (LSSerializer.domConfig's " error-handler" parameter). This specification does in no way try to define all possible errors and warnings that can occur while serializing a DOM node, but some common error and warning cases are defined. The types ( DOMError.type) of errors and warnings defined by this specification are:

    "no-output-specified" [fatal]
    Raised when writing to a LSOutput if no output is specified in the LSOutput.
    "unbound-prefix-in-entity-reference" [fatal]
    Raised if the configuration parameter " namespaces" is set to true and an entity whose replacement text contains unbound namespace prefixes is referenced in a location where there are no bindings for the namespace prefixes.
    "unsupported-encoding" [fatal]
    Raised if an unsupported encoding is encountered.

    In addition to raising the defined errors and warnings, implementations are expected to raise implementation specific errors and warnings for any other error and warning cases such as IO errors (file not found, permission denied,...) and so on.

    See also the Document Object Model (DOM) Level 3 Load and Save Specification.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      DOMConfiguration getDomConfig()
      The DOMConfiguration object used by the LSSerializer when serializing a DOM node.
      LSSerializerFilter getFilter()
      When the application provides a filter, the serializer will call out to the filter before serializing each Node.
      String getNewLine()
      The end-of-line sequence of characters to be used in the XML being written out.
      void setFilter(LSSerializerFilter filter)
      When the application provides a filter, the serializer will call out to the filter before serializing each Node.
      void setNewLine(String newLine)
      The end-of-line sequence of characters to be used in the XML being written out.
      boolean write(Node nodeArg, LSOutput destination)
      Serialize the specified node as described above in the general description of the LSSerializer interface.
      String writeToString(Node nodeArg)
      Serialize the specified node as described above in the general description of the LSSerializer interface.
      boolean writeToURI(Node nodeArg, String uri)
      A convenience method that acts as if LSSerializer.write was called with a LSOutput with no encoding specified and LSOutput.systemId set to the uri argument.

    • Method Detail

      • getDomConfig

        DOMConfiguration getDomConfig()
        The DOMConfiguration object used by the LSSerializer when serializing a DOM node.
        In addition to the parameters recognized by the DOMConfiguration interface defined in [DOM Level 3 Core] , the DOMConfiguration objects for LSSerializer adds, or modifies, the following parameters:
        "canonical-form"
        true
        [optional] Writes the document according to the rules specified in [Canonical XML]. In addition to the behavior described in " canonical-form" [DOM Level 3 Core] , setting this parameter to true will set the parameters "format-pretty-print", "discard-default-content", and "xml-declaration ", to false. Setting one of those parameters to true will set this parameter to false. Serializing an XML 1.1 document when "canonical-form" is true will generate a fatal error.
        false
        [required] (default) Do not canonicalize the output.
        "discard-default-content"
        true
        [required] (default) Use the Attr.specified attribute to decide what attributes should be discarded. Note that some implementations might use whatever information available to the implementation (i.e. XML schema, DTD, the Attr.specified attribute, and so on) to determine what attributes and content to discard if this parameter is set to true.
        false
        [required]Keep all attributes and all content.
        "format-pretty-print"
        true
        [optional] Formatting the output by adding whitespace to produce a pretty-printed, indented, human-readable form. The exact form of the transformations is not specified by this specification. Pretty-printing changes the content of the document and may affect the validity of the document, validating implementations should preserve validity.
        false
        [required] (default) Don't pretty-print the result.
        "ignore-unknown-character-denormalizations"
        true
        [required] (default) If, while verifying full normalization when [XML 1.1] is supported, a character is encountered for which the normalization properties cannot be determined, then raise a "unknown-character-denormalization" warning (instead of raising an error, if this parameter is not set) and ignore any possible denormalizations caused by these characters.
        false
        [optional] Report a fatal error if a character is encountered for which the processor cannot determine the normalization properties.
        "normalize-characters"
        This parameter is equivalent to the one defined by DOMConfiguration in [DOM Level 3 Core] . Unlike in the Core, the default value for this parameter is true. While DOM implementations are not required to support fully normalizing the characters in the document according to appendix E of [XML 1.1], this parameter must be activated by default if supported.
        "xml-declaration"
        true
        [required] (default) If a Document, Element, or Entity node is serialized, the XML declaration, or text declaration, should be included. The version (Document.xmlVersion if the document is a Level 3 document and the version is non-null, otherwise use the value "1.0"), and the output encoding (see LSSerializer.write for details on how to find the output encoding) are specified in the serialized XML declaration.
        false
        [required] Do not serialize the XML and text declarations. Report a "xml-declaration-needed" warning if this will cause problems (i.e. the serialized data is of an XML version other than [XML 1.0], or an encoding would be needed to be able to re-parse the serialized data).

      • getNewLine

        String getNewLine()
        The end-of-line sequence of characters to be used in the XML being written out. Any string is supported, but XML treats only a certain set of characters sequence as end-of-line (See section 2.11, "End-of-Line Handling" in [XML 1.0], if the serialized content is XML 1.0 or section 2.11, "End-of-Line Handling" in [XML 1.1], if the serialized content is XML 1.1). Using other character sequences than the recommended ones can result in a document that is either not serializable or not well-formed).
        On retrieval, the default value of this attribute is the implementation specific default end-of-line sequence. DOM implementations should choose the default to match the usual convention for text files in the environment being used. Implementations must choose a default sequence that matches one of those allowed by XML 1.0 or XML 1.1, depending on the serialized content. Setting this attribute to null will reset its value to the default value.

      • setNewLine

        void setNewLine(String newLine)
        The end-of-line sequence of characters to be used in the XML being written out. Any string is supported, but XML treats only a certain set of characters sequence as end-of-line (See section 2.11, "End-of-Line Handling" in [XML 1.0], if the serialized content is XML 1.0 or section 2.11, "End-of-Line Handling" in [XML 1.1], if the serialized content is XML 1.1). Using other character sequences than the recommended ones can result in a document that is either not serializable or not well-formed).
        On retrieval, the default value of this attribute is the implementation specific default end-of-line sequence. DOM implementations should choose the default to match the usual convention for text files in the environment being used. Implementations must choose a default sequence that matches one of those allowed by XML 1.0 or XML 1.1, depending on the serialized content. Setting this attribute to null will reset its value to the default value.

      • getFilter

        LSSerializerFilter getFilter()
        When the application provides a filter, the serializer will call out to the filter before serializing each Node. The filter implementation can choose to remove the node from the stream or to terminate the serialization early.
        The filter is invoked after the operations requested by the DOMConfiguration parameters have been applied. For example, CDATA sections won't be passed to the filter if " cdata-sections" is set to false.

      • setFilter

        void setFilter(LSSerializerFilter filter)
        When the application provides a filter, the serializer will call out to the filter before serializing each Node. The filter implementation can choose to remove the node from the stream or to terminate the serialization early.
        The filter is invoked after the operations requested by the DOMConfiguration parameters have been applied. For example, CDATA sections won't be passed to the filter if " cdata-sections" is set to false.

      • write

        boolean write(Node nodeArg,
              LSOutput destination)
       throws LSException
        Serialize the specified node as described above in the general description of the LSSerializer interface. The output is written to the supplied LSOutput.
        When writing to a LSOutput, the encoding is found by looking at the encoding information that is reachable through the LSOutput and the item to be written (or its owner document) in this order:
        1. LSOutput.encoding,
        2. Document.inputEncoding,
        3. Document.xmlEncoding.

        If no encoding is reachable through the above properties, a default encoding of "UTF-8" will be used. If the specified encoding is not supported an "unsupported-encoding" fatal error is raised.
        If no output is specified in the LSOutput, a "no-output-specified" fatal error is raised.
        The implementation is responsible of associating the appropriate media type with the serialized data.
        When writing to a HTTP URI, a HTTP PUT is performed. When writing to other types of URIs, the mechanism for writing the data to the URI is implementation dependent.
        Parameters:
        nodeArg - The node to serialize.
        destination - The destination for the serialized DOM.
        Returns:
        Returns true if node was successfully serialized. Return false in case the normal processing stopped but the implementation kept serializing the document; the result of the serialization being implementation dependent then.
        Throws:
        LSException - SERIALIZE_ERR: Raised if the LSSerializer was unable to serialize the node. DOM applications should attach a DOMErrorHandler using the parameter " error-handler" if they wish to get details on the error.

      • writeToURI

        boolean writeToURI(Node nodeArg,
                   String uri)
            throws LSException
        A convenience method that acts as if LSSerializer.write was called with a LSOutput with no encoding specified and LSOutput.systemId set to the uri argument.
        Parameters:
        nodeArg - The node to serialize.
        uri - The URI to write to.
        Returns:
        Returns true if node was successfully serialized. Return false in case the normal processing stopped but the implementation kept serializing the document; the result of the serialization being implementation dependent then.
        Throws:
        LSException - SERIALIZE_ERR: Raised if the LSSerializer was unable to serialize the node. DOM applications should attach a DOMErrorHandler using the parameter " error-handler" if they wish to get details on the error.

      • writeToString

        String writeToString(Node nodeArg)
              throws DOMException,
                     LSException
        Serialize the specified node as described above in the general description of the LSSerializer interface. The output is written to a DOMString that is returned to the caller. The encoding used is the encoding of the DOMString type, i.e. UTF-16. Note that no Byte Order Mark is generated in a DOMString object.
        Parameters:
        nodeArg - The node to serialize.
        Returns:
        Returns the serialized data.
        Throws:
        DOMException - DOMSTRING_SIZE_ERR: Raised if the resulting string is too long to fit in a DOMString.
        LSException - SERIALIZE_ERR: Raised if the LSSerializer was unable to serialize the node. DOM applications should attach a DOMErrorHandler using the parameter " error-handler" if they wish to get details on the error.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


LSSerializerFilter (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.ls

Interface LSSerializerFilter

  • All Superinterfaces:
    org.w3c.dom.traversal.NodeFilter

    public interface LSSerializerFilter
extends org.w3c.dom.traversal.NodeFilter
    LSSerializerFilters provide applications the ability to examine nodes as they are being serialized and decide what nodes should be serialized or not. The LSSerializerFilter interface is based on the NodeFilter interface defined in [DOM Level 2 Traversal and Range] .

    Document, DocumentType, DocumentFragment, Notation, Entity , and children of Attr nodes are not passed to the filter. The child nodes of an EntityReference node are only passed to the filter if the EntityReference node is skipped by the method LSParserFilter.acceptNode().

    When serializing an Element, the element is passed to the filter before any of its attributes are passed to the filter. Namespace declaration attributes, and default attributes (except in the case when " discard-default-content" is set to false), are never passed to the filter.

    The result of any attempt to modify a node passed to a LSSerializerFilter is implementation dependent.

    DOM applications must not raise exceptions in a filter. The effect of throwing exceptions from a filter is DOM implementation dependent.

    For efficiency, a node passed to the filter may not be the same as the one that is actually in the tree. And the actual node (node object identity) may be reused during the process of filtering and serializing a document.

    See also the Document Object Model (DOM) Level 3 Load and Save Specification.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.traversal.NodeFilter

        FILTER_ACCEPT, FILTER_REJECT, FILTER_SKIP, SHOW_ALL, SHOW_ATTRIBUTE, SHOW_CDATA_SECTION, SHOW_COMMENT, SHOW_DOCUMENT, SHOW_DOCUMENT_FRAGMENT, SHOW_DOCUMENT_TYPE, SHOW_ELEMENT, SHOW_ENTITY, SHOW_ENTITY_REFERENCE, SHOW_NOTATION, SHOW_PROCESSING_INSTRUCTION, SHOW_TEXT

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      int getWhatToShow()
      Tells the LSSerializer what types of nodes to show to the filter.

      • Methods inherited from interface org.w3c.dom.traversal.NodeFilter

        acceptNode

    • Method Detail

      • getWhatToShow

        int getWhatToShow()
        Tells the LSSerializer what types of nodes to show to the filter. If a node is not shown to the filter using this attribute, it is automatically serialized. See NodeFilter for definition of the constants. The constants SHOW_DOCUMENT , SHOW_DOCUMENT_TYPE, SHOW_DOCUMENT_FRAGMENT , SHOW_NOTATION, and SHOW_ENTITY are meaningless here, such nodes will never be passed to a LSSerializerFilter.
        Unlike [DOM Level 2 Traversal and Range] , the SHOW_ATTRIBUTE constant indicates that the Attr nodes are shown and passed to the filter.
        The constants used here are defined in [DOM Level 2 Traversal and Range] .
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


org.w3c.dom.ls (Java Platform SE 8 )

org.w3c.dom.ls

Interfaces

  • DOMImplementationLS
  • LSInput
  • LSLoadEvent
  • LSOutput
  • LSParser
  • LSParserFilter
  • LSProgressEvent
  • LSResourceResolver
  • LSSerializer
  • LSSerializerFilter

Exceptions

  • LSException


org.w3c.dom.ls (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.w3c.dom.ls

  • Interface Summary
    Interface Description
    DOMImplementationLS
    DOMImplementationLS contains the factory methods for creating Load and Save objects.
    LSInput
    This interface represents an input source for data.
    LSLoadEvent
    This interface represents a load event object that signals the completion of a document load.
    LSOutput
    This interface represents an output destination for data.
    LSParser
    An interface to an object that is able to build, or augment, a DOM tree from various input sources.
    LSParserFilter
    LSParserFilters provide applications the ability to examine nodes as they are being constructed while parsing.
    LSProgressEvent
    This interface represents a progress event object that notifies the application about progress as a document is parsed.
    LSResourceResolver
    LSResourceResolver provides a way for applications to redirect references to external resources.
    LSSerializer
    A LSSerializer provides an API for serializing (writing) a DOM document out into XML.
    LSSerializerFilter
    LSSerializerFilters provide applications the ability to examine nodes as they are being serialized and decide what nodes should be serialized or not.
  • Exception Summary
    Exception Description
    LSException
    Parser or write operations may throw an LSException if the processing is stopped.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames


org.w3c.dom.ls Class Hierarchy (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.w3c.dom.ls

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.w3c.dom.ls.LSException

Interface Hierarchy

  • org.w3c.dom.ls.DOMImplementationLS
  • org.w3c.dom.events.Event
    • org.w3c.dom.ls.LSLoadEvent
    • org.w3c.dom.ls.LSProgressEvent
  • org.w3c.dom.ls.LSInput
  • org.w3c.dom.ls.LSOutput
  • org.w3c.dom.ls.LSParser
  • org.w3c.dom.ls.LSParserFilter
  • org.w3c.dom.ls.LSResourceResolver
  • org.w3c.dom.ls.LSSerializer
  • org.w3c.dom.traversal.NodeFilter
    • org.w3c.dom.ls.LSSerializerFilter
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package org.w3c.dom.ls (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.w3c.dom.ls

  • Packages that use org.w3c.dom.ls
    Package Description
    javax.xml.validation
    This package provides an API for validation of XML documents.
    org.w3c.dom.ls
  • Classes in org.w3c.dom.ls used by javax.xml.validation
    Class and Description
    LSResourceResolver
    LSResourceResolver provides a way for applications to redirect references to external resources.
  • Classes in org.w3c.dom.ls used by org.w3c.dom.ls
    Class and Description
    LSException
    Parser or write operations may throw an LSException if the processing is stopped.
    LSInput
    This interface represents an input source for data.
    LSOutput
    This interface represents an output destination for data.
    LSParser
    An interface to an object that is able to build, or augment, a DOM tree from various input sources.
    LSParserFilter
    LSParserFilters provide applications the ability to examine nodes as they are being constructed while parsing.
    LSSerializer
    A LSSerializer provides an API for serializing (writing) a DOM document out into XML.
    LSSerializerFilter
    LSSerializerFilters provide applications the ability to examine nodes as they are being serialized and decide what nodes should be serialized or not.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


NamedNodeMap (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface NamedNodeMap

  • public interface NamedNodeMap
    Objects implementing the NamedNodeMap interface are used to represent collections of nodes that can be accessed by name. Note that NamedNodeMap does not inherit from NodeList; NamedNodeMaps are not maintained in any particular order. Objects contained in an object implementing NamedNodeMap may also be accessed by an ordinal index, but this is simply to allow convenient enumeration of the contents of a NamedNodeMap, and does not imply that the DOM specifies an order to these Nodes.

    NamedNodeMap objects in the DOM are live.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      int getLength()
      The number of nodes in this map.
      Node getNamedItem(String name)
      Retrieves a node specified by name.
      Node getNamedItemNS(String namespaceURI, String localName)
      Retrieves a node specified by local name and namespace URI.
      Node item(int index)
      Returns the indexth item in the map.
      Node removeNamedItem(String name)
      Removes a node specified by name.
      Node removeNamedItemNS(String namespaceURI, String localName)
      Removes a node specified by local name and namespace URI.
      Node setNamedItem(Node arg)
      Adds a node using its nodeName attribute.
      Node setNamedItemNS(Node arg)
      Adds a node using its namespaceURI and localName.

    • Method Detail

      • getNamedItem

        Node getNamedItem(String name)
        Retrieves a node specified by name.
        Parameters:
        name - The nodeName of a node to retrieve.
        Returns:
        A Node (of any type) with the specified nodeName, or null if it does not identify any node in this map.

      • setNamedItem

        Node setNamedItem(Node arg)
           throws DOMException
        Adds a node using its nodeName attribute. If a node with that name is already present in this map, it is replaced by the new one. Replacing a node by itself has no effect.
        As the nodeName attribute is used to derive the name which the node must be stored under, multiple nodes of certain types (those that have a "special" string value) cannot be stored as the names would clash. This is seen as preferable to allowing nodes to be aliased.
        Parameters:
        arg - A node to store in this map. The node will later be accessible using the value of its nodeName attribute.
        Returns:
        If the new Node replaces an existing node the replaced Node is returned, otherwise null is returned.
        Throws:
        DOMException - WRONG_DOCUMENT_ERR: Raised if arg was created from a different document than the one that created this map.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this map is readonly.
        INUSE_ATTRIBUTE_ERR: Raised if arg is an Attr that is already an attribute of another Element object. The DOM user must explicitly clone Attr nodes to re-use them in other elements.
        HIERARCHY_REQUEST_ERR: Raised if an attempt is made to add a node doesn't belong in this NamedNodeMap. Examples would include trying to insert something other than an Attr node into an Element's map of attributes, or a non-Entity node into the DocumentType's map of Entities.

      • removeNamedItem

        Node removeNamedItem(String name)
              throws DOMException
        Removes a node specified by name. When this map contains the attributes attached to an element, if the removed attribute is known to have a default value, an attribute immediately appears containing the default value as well as the corresponding namespace URI, local name, and prefix when applicable.
        Parameters:
        name - The nodeName of the node to remove.
        Returns:
        The node removed from this map if a node with such a name exists.
        Throws:
        DOMException - NOT_FOUND_ERR: Raised if there is no node named name in this map.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this map is readonly.

      • item

        Node item(int index)
        Returns the indexth item in the map. If index is greater than or equal to the number of nodes in this map, this returns null.
        Parameters:
        index - Index into this map.
        Returns:
        The node at the indexth position in the map, or null if that is not a valid index.

      • getLength

        int getLength()
        The number of nodes in this map. The range of valid child node indices is 0 to length-1 inclusive.

      • getNamedItemNS

        Node getNamedItemNS(String namespaceURI,
                    String localName)
             throws DOMException
        Retrieves a node specified by local name and namespace URI.
        Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.
        Parameters:
        namespaceURI - The namespace URI of the node to retrieve.
        localName - The local name of the node to retrieve.
        Returns:
        A Node (of any type) with the specified local name and namespace URI, or null if they do not identify any node in this map.
        Throws:
        DOMException - NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
        Since:
        DOM Level 2

      • setNamedItemNS

        Node setNamedItemNS(Node arg)
             throws DOMException
        Adds a node using its namespaceURI and localName. If a node with that namespace URI and that local name is already present in this map, it is replaced by the new one. Replacing a node by itself has no effect.
        Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.
        Parameters:
        arg - A node to store in this map. The node will later be accessible using the value of its namespaceURI and localName attributes.
        Returns:
        If the new Node replaces an existing node the replaced Node is returned, otherwise null is returned.
        Throws:
        DOMException - WRONG_DOCUMENT_ERR: Raised if arg was created from a different document than the one that created this map.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this map is readonly.
        INUSE_ATTRIBUTE_ERR: Raised if arg is an Attr that is already an attribute of another Element object. The DOM user must explicitly clone Attr nodes to re-use them in other elements.
        HIERARCHY_REQUEST_ERR: Raised if an attempt is made to add a node doesn't belong in this NamedNodeMap. Examples would include trying to insert something other than an Attr node into an Element's map of attributes, or a non-Entity node into the DocumentType's map of Entities.
        NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
        Since:
        DOM Level 2

      • removeNamedItemNS

        Node removeNamedItemNS(String namespaceURI,
                       String localName)
                throws DOMException
        Removes a node specified by local name and namespace URI. A removed attribute may be known to have a default value when this map contains the attributes attached to an element, as returned by the attributes attribute of the Node interface. If so, an attribute immediately appears containing the default value as well as the corresponding namespace URI, local name, and prefix when applicable.
        Per [XML Namespaces] , applications must use the value null as the namespaceURI parameter for methods if they wish to have no namespace.
        Parameters:
        namespaceURI - The namespace URI of the node to remove.
        localName - The local name of the node to remove.
        Returns:
        The node removed from this map if a node with such a local name and namespace URI exists.
        Throws:
        DOMException - NOT_FOUND_ERR: Raised if there is no node with the specified namespaceURI and localName in this map.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this map is readonly.
        NOT_SUPPORTED_ERR: May be raised if the implementation does not support the feature "XML" and the language exposed through the Document does not support XML Namespaces (such as [HTML 4.01]).
        Since:
        DOM Level 2
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NameList (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface NameList

  • public interface NameList
    The NameList interface provides the abstraction of an ordered collection of parallel pairs of name and namespace values (which could be null values), without defining or constraining how this collection is implemented. The items in the NameList are accessible via an integral index, starting from 0.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    Since:
    DOM Level 3

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      boolean contains(String str)
      Test if a name is part of this NameList.
      boolean containsNS(String namespaceURI, String name)
      Test if the pair namespaceURI/name is part of this NameList.
      int getLength()
      The number of pairs (name and namespaceURI) in the list.
      String getName(int index)
      Returns the indexth name item in the collection.
      String getNamespaceURI(int index)
      Returns the indexth namespaceURI item in the collection.

    • Method Detail

      • getName

        String getName(int index)
        Returns the indexth name item in the collection.
        Parameters:
        index - Index into the collection.
        Returns:
        The name at the indexth position in the NameList, or null if there is no name for the specified index or if the index is out of range.

      • getNamespaceURI

        String getNamespaceURI(int index)
        Returns the indexth namespaceURI item in the collection.
        Parameters:
        index - Index into the collection.
        Returns:
        The namespace URI at the indexth position in the NameList, or null if there is no name for the specified index or if the index is out of range.

      • getLength

        int getLength()
        The number of pairs (name and namespaceURI) in the list. The range of valid child node indices is 0 to length-1 inclusive.

      • contains

        boolean contains(String str)
        Test if a name is part of this NameList.
        Parameters:
        str - The name to look for.
        Returns:
        true if the name has been found, false otherwise.

      • containsNS

        boolean containsNS(String namespaceURI,
                   String name)
        Test if the pair namespaceURI/name is part of this NameList.
        Parameters:
        namespaceURI - The namespace URI to look for.
        name - The name to look for.
        Returns:
        true if the pair namespaceURI/name has been found, false otherwise.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Node (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface Node

  • All Known Subinterfaces:
    Attr, CDATASection, CharacterData, Comment, Detail, DetailEntry, Document, DocumentFragment, DocumentType, Element, Entity, EntityReference, Node, Notation, ProcessingInstruction, SOAPBody, SOAPBodyElement, SOAPElement, SOAPEnvelope, SOAPFault, SOAPFaultElement, SOAPHeader, SOAPHeaderElement, Text, Text
    All Known Implementing Classes:
    IIOMetadataNode, SOAPPart

    public interface Node
    The Node interface is the primary datatype for the entire Document Object Model. It represents a single node in the document tree. While all objects implementing the Node interface expose methods for dealing with children, not all objects implementing the Node interface may have children. For example, Text nodes may not have children, and adding children to such nodes results in a DOMException being raised.

    The attributes nodeName, nodeValue and attributes are included as a mechanism to get at node information without casting down to the specific derived interface. In cases where there is no obvious mapping of these attributes for a specific nodeType (e.g., nodeValue for an Element or attributes for a Comment ), this returns null. Note that the specialized interfaces may contain additional and more convenient mechanisms to get and set the relevant information.

    The values of nodeName, nodeValue, and attributes vary according to the node type as follows:

    Interface | nodeName | nodeValue | attributes
    Attr | same as Attr.name | same as Attr.value | null
    CDATASection | "#cdata-section" | same as CharacterData.data, the content of the CDATA Section | null
    Comment | "#comment" | same as CharacterData.data, the content of the comment | null
    Document | "#document" | null | null
    DocumentFragment | "#document-fragment" | null | null
    DocumentType | same as DocumentType.name | null | null
    Element | same as Element.tagName | null | NamedNodeMap
    Entity | entity name | null | null
    EntityReference | name of entity referenced | null | null
    Notation | notation name | null | null
    ProcessingInstruction | same as ProcessingInstruction.target | same as ProcessingInstruction.data | null
    Text | "#text" | same as CharacterData.data, the content of the text node | null

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short ATTRIBUTE_NODE
      The node is an Attr.
      static short CDATA_SECTION_NODE
      The node is a CDATASection.
      static short COMMENT_NODE
      The node is a Comment.
      static short DOCUMENT_FRAGMENT_NODE
      The node is a DocumentFragment.
      static short DOCUMENT_NODE
      The node is a Document.
      static short DOCUMENT_POSITION_CONTAINED_BY
      The node is contained by the reference node.
      static short DOCUMENT_POSITION_CONTAINS
      The node contains the reference node.
      static short DOCUMENT_POSITION_DISCONNECTED
      The two nodes are disconnected.
      static short DOCUMENT_POSITION_FOLLOWING
      The node follows the reference node.
      static short DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC
      The determination of preceding versus following is implementation-specific.
      static short DOCUMENT_POSITION_PRECEDING
      The second node precedes the reference node.
      static short DOCUMENT_TYPE_NODE
      The node is a DocumentType.
      static short ELEMENT_NODE
      The node is an Element.
      static short ENTITY_NODE
      The node is an Entity.
      static short ENTITY_REFERENCE_NODE
      The node is an EntityReference.
      static short NOTATION_NODE
      The node is a Notation.
      static short PROCESSING_INSTRUCTION_NODE
      The node is a ProcessingInstruction.
      static short TEXT_NODE
      The node is a Text node.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      Node appendChild(Node newChild)
      Adds the node newChild to the end of the list of children of this node.
      Node cloneNode(boolean deep)
      Returns a duplicate of this node, i.e., serves as a generic copy constructor for nodes.
      short compareDocumentPosition(Node other)
      Compares the reference node, i.e.
      NamedNodeMap getAttributes()
      A NamedNodeMap containing the attributes of this node (if it is an Element) or null otherwise.
      String getBaseURI()
      The absolute base URI of this node or null if the implementation wasn't able to obtain an absolute URI.
      NodeList getChildNodes()
      A NodeList that contains all children of this node.
      Object getFeature(String feature, String version)
      This method returns a specialized object which implements the specialized APIs of the specified feature and version, as specified in .
      Node getFirstChild()
      The first child of this node.
      Node getLastChild()
      The last child of this node.
      String getLocalName()
      Returns the local part of the qualified name of this node.
      String getNamespaceURI()
      The namespace URI of this node, or null if it is unspecified (see ).
      Node getNextSibling()
      The node immediately following this node.
      String getNodeName()
      The name of this node, depending on its type; see the table above.
      short getNodeType()
      A code representing the type of the underlying object, as defined above.
      String getNodeValue()
      The value of this node, depending on its type; see the table above.
      Document getOwnerDocument()
      The Document object associated with this node.
      Node getParentNode()
      The parent of this node.
      String getPrefix()
      The namespace prefix of this node, or null if it is unspecified.
      Node getPreviousSibling()
      The node immediately preceding this node.
      String getTextContent()
      This attribute returns the text content of this node and its descendants.
      Object getUserData(String key)
      Retrieves the object associated to a key on a this node.
      boolean hasAttributes()
      Returns whether this node (if it is an element) has any attributes.
      boolean hasChildNodes()
      Returns whether this node has any children.
      Node insertBefore(Node newChild, Node refChild)
      Inserts the node newChild before the existing child node refChild.
      boolean isDefaultNamespace(String namespaceURI)
      This method checks if the specified namespaceURI is the default namespace or not.
      boolean isEqualNode(Node arg)
      Tests whether two nodes are equal.
      boolean isSameNode(Node other)
      Returns whether this node is the same node as the given one.
      boolean isSupported(String feature, String version)
      Tests whether the DOM implementation implements a specific feature and that feature is supported by this node, as specified in .
      String lookupNamespaceURI(String prefix)
      Look up the namespace URI associated to the given prefix, starting from this node.
      String lookupPrefix(String namespaceURI)
      Look up the prefix associated to the given namespace URI, starting from this node.
      void normalize()
      Puts all Text nodes in the full depth of the sub-tree underneath this Node, including attribute nodes, into a "normal" form where only structure (e.g., elements, comments, processing instructions, CDATA sections, and entity references) separates Text nodes, i.e., there are neither adjacent Text nodes nor empty Text nodes.
      Node removeChild(Node oldChild)
      Removes the child node indicated by oldChild from the list of children, and returns it.
      Node replaceChild(Node newChild, Node oldChild)
      Replaces the child node oldChild with newChild in the list of children, and returns the oldChild node.
      void setNodeValue(String nodeValue)
      The value of this node, depending on its type; see the table above.
      void setPrefix(String prefix)
      The namespace prefix of this node, or null if it is unspecified.
      void setTextContent(String textContent)
      This attribute returns the text content of this node and its descendants.
      Object setUserData(String key, Object data, UserDataHandler handler)
      Associate an object to a key on this node.

    • Field Detail

      • ELEMENT_NODE

        static final short ELEMENT_NODE
        The node is an Element.
        See Also:
        Constant Field Values

      • ATTRIBUTE_NODE

        static final short ATTRIBUTE_NODE
        The node is an Attr.
        See Also:
        Constant Field Values

      • TEXT_NODE

        static final short TEXT_NODE
        The node is a Text node.
        See Also:
        Constant Field Values

      • CDATA_SECTION_NODE

        static final short CDATA_SECTION_NODE
        The node is a CDATASection.
        See Also:
        Constant Field Values

      • ENTITY_REFERENCE_NODE

        static final short ENTITY_REFERENCE_NODE
        The node is an EntityReference.
        See Also:
        Constant Field Values

      • ENTITY_NODE

        static final short ENTITY_NODE
        The node is an Entity.
        See Also:
        Constant Field Values

      • PROCESSING_INSTRUCTION_NODE

        static final short PROCESSING_INSTRUCTION_NODE
        The node is a ProcessingInstruction.
        See Also:
        Constant Field Values

      • COMMENT_NODE

        static final short COMMENT_NODE
        The node is a Comment.
        See Also:
        Constant Field Values

      • DOCUMENT_NODE

        static final short DOCUMENT_NODE
        The node is a Document.
        See Also:
        Constant Field Values

      • DOCUMENT_TYPE_NODE

        static final short DOCUMENT_TYPE_NODE
        The node is a DocumentType.
        See Also:
        Constant Field Values

      • DOCUMENT_FRAGMENT_NODE

        static final short DOCUMENT_FRAGMENT_NODE
        The node is a DocumentFragment.
        See Also:
        Constant Field Values

      • NOTATION_NODE

        static final short NOTATION_NODE
        The node is a Notation.
        See Also:
        Constant Field Values

      • DOCUMENT_POSITION_DISCONNECTED

        static final short DOCUMENT_POSITION_DISCONNECTED
        The two nodes are disconnected. Order between disconnected nodes is always implementation-specific.
        See Also:
        Constant Field Values

      • DOCUMENT_POSITION_PRECEDING

        static final short DOCUMENT_POSITION_PRECEDING
        The second node precedes the reference node.
        See Also:
        Constant Field Values

      • DOCUMENT_POSITION_FOLLOWING

        static final short DOCUMENT_POSITION_FOLLOWING
        The node follows the reference node.
        See Also:
        Constant Field Values

      • DOCUMENT_POSITION_CONTAINS

        static final short DOCUMENT_POSITION_CONTAINS
        The node contains the reference node. A node which contains is always preceding, too.
        See Also:
        Constant Field Values

      • DOCUMENT_POSITION_CONTAINED_BY

        static final short DOCUMENT_POSITION_CONTAINED_BY
        The node is contained by the reference node. A node which is contained is always following, too.
        See Also:
        Constant Field Values

      • DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC

        static final short DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC
        The determination of preceding versus following is implementation-specific.
        See Also:
        Constant Field Values

    • Method Detail

      • getNodeName

        String getNodeName()
        The name of this node, depending on its type; see the table above.

      • getNodeValue

        String getNodeValue()
             throws DOMException
        The value of this node, depending on its type; see the table above. When it is defined to be null, setting it has no effect, including if the node is read-only.
        Throws:
        DOMException - DOMSTRING_SIZE_ERR: Raised when it would return more characters than fit in a DOMString variable on the implementation platform.

      • setNodeValue

        void setNodeValue(String nodeValue)
           throws DOMException
        The value of this node, depending on its type; see the table above. When it is defined to be null, setting it has no effect, including if the node is read-only.
        Throws:
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised when the node is readonly and if it is not defined to be null.

      • getNodeType

        short getNodeType()
        A code representing the type of the underlying object, as defined above.

      • getParentNode

        Node getParentNode()
        The parent of this node. All nodes, except Attr, Document, DocumentFragment, Entity, and Notation may have a parent. However, if a node has just been created and not yet added to the tree, or if it has been removed from the tree, this is null.

      • getChildNodes

        NodeList getChildNodes()
        A NodeList that contains all children of this node. If there are no children, this is a NodeList containing no nodes.

      • getFirstChild

        Node getFirstChild()
        The first child of this node. If there is no such node, this returns null.

      • getLastChild

        Node getLastChild()
        The last child of this node. If there is no such node, this returns null.

      • getPreviousSibling

        Node getPreviousSibling()
        The node immediately preceding this node. If there is no such node, this returns null.

      • getNextSibling

        Node getNextSibling()
        The node immediately following this node. If there is no such node, this returns null.

      • getAttributes

        NamedNodeMap getAttributes()
        A NamedNodeMap containing the attributes of this node (if it is an Element) or null otherwise.

      • getOwnerDocument

        Document getOwnerDocument()
        The Document object associated with this node. This is also the Document object used to create new nodes. When this node is a Document or a DocumentType which is not used with any Document yet, this is null.
        Since:
        DOM Level 2

      • insertBefore

        Node insertBefore(Node newChild,
                  Node refChild)
           throws DOMException
        Inserts the node newChild before the existing child node refChild. If refChild is null, insert newChild at the end of the list of children.
        If newChild is a DocumentFragment object, all of its children are inserted, in the same order, before refChild. If the newChild is already in the tree, it is first removed.

        Note: Inserting a node before itself is implementation dependent.

        Parameters:
        newChild - The node to insert.
        refChild - The reference node, i.e., the node before which the new node must be inserted.
        Returns:
        The node being inserted.
        Throws:
        DOMException - HIERARCHY_REQUEST_ERR: Raised if this node is of a type that does not allow children of the type of the newChild node, or if the node to insert is one of this node's ancestors or this node itself, or if this node is of type Document and the DOM application attempts to insert a second DocumentType or Element node.
        WRONG_DOCUMENT_ERR: Raised if newChild was created from a different document than the one that created this node.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly or if the parent of the node being inserted is readonly.
        NOT_FOUND_ERR: Raised if refChild is not a child of this node.
        NOT_SUPPORTED_ERR: if this node is of type Document, this exception might be raised if the DOM implementation doesn't support the insertion of a DocumentType or Element node.
        Since:
        DOM Level 3

      • replaceChild

        Node replaceChild(Node newChild,
                  Node oldChild)
           throws DOMException
        Replaces the child node oldChild with newChild in the list of children, and returns the oldChild node.
        If newChild is a DocumentFragment object, oldChild is replaced by all of the DocumentFragment children, which are inserted in the same order. If the newChild is already in the tree, it is first removed.

        Note: Replacing a node with itself is implementation dependent.

        Parameters:
        newChild - The new node to put in the child list.
        oldChild - The node being replaced in the list.
        Returns:
        The node replaced.
        Throws:
        DOMException - HIERARCHY_REQUEST_ERR: Raised if this node is of a type that does not allow children of the type of the newChild node, or if the node to put in is one of this node's ancestors or this node itself, or if this node is of type Document and the result of the replacement operation would add a second DocumentType or Element on the Document node.
        WRONG_DOCUMENT_ERR: Raised if newChild was created from a different document than the one that created this node.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this node or the parent of the new node is readonly.
        NOT_FOUND_ERR: Raised if oldChild is not a child of this node.
        NOT_SUPPORTED_ERR: if this node is of type Document, this exception might be raised if the DOM implementation doesn't support the replacement of the DocumentType child or Element child.
        Since:
        DOM Level 3

      • removeChild

        Node removeChild(Node oldChild)
          throws DOMException
        Removes the child node indicated by oldChild from the list of children, and returns it.
        Parameters:
        oldChild - The node being removed.
        Returns:
        The node removed.
        Throws:
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
        NOT_FOUND_ERR: Raised if oldChild is not a child of this node.
        NOT_SUPPORTED_ERR: if this node is of type Document, this exception might be raised if the DOM implementation doesn't support the removal of the DocumentType child or the Element child.
        Since:
        DOM Level 3

      • appendChild

        Node appendChild(Node newChild)
          throws DOMException
        Adds the node newChild to the end of the list of children of this node. If the newChild is already in the tree, it is first removed.
        Parameters:
        newChild - The node to add.If it is a DocumentFragment object, the entire contents of the document fragment are moved into the child list of this node
        Returns:
        The node added.
        Throws:
        DOMException - HIERARCHY_REQUEST_ERR: Raised if this node is of a type that does not allow children of the type of the newChild node, or if the node to append is one of this node's ancestors or this node itself, or if this node is of type Document and the DOM application attempts to append a second DocumentType or Element node.
        WRONG_DOCUMENT_ERR: Raised if newChild was created from a different document than the one that created this node.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly or if the previous parent of the node being inserted is readonly.
        NOT_SUPPORTED_ERR: if the newChild node is a child of the Document node, this exception might be raised if the DOM implementation doesn't support the removal of the DocumentType child or Element child.
        Since:
        DOM Level 3

      • hasChildNodes

        boolean hasChildNodes()
        Returns whether this node has any children.
        Returns:
        Returns true if this node has any children, false otherwise.

      • cloneNode

        Node cloneNode(boolean deep)
        Returns a duplicate of this node, i.e., serves as a generic copy constructor for nodes. The duplicate node has no parent ( parentNode is null) and no user data. User data associated to the imported node is not carried over. However, if any UserDataHandlers has been specified along with the associated data these handlers will be called with the appropriate parameters before this method returns.
        Cloning an Element copies all attributes and their values, including those generated by the XML processor to represent defaulted attributes, but this method does not copy any children it contains unless it is a deep clone. This includes text contained in an the Element since the text is contained in a child Text node. Cloning an Attr directly, as opposed to be cloned as part of an Element cloning operation, returns a specified attribute (specified is true). Cloning an Attr always clones its children, since they represent its value, no matter whether this is a deep clone or not. Cloning an EntityReference automatically constructs its subtree if a corresponding Entity is available, no matter whether this is a deep clone or not. Cloning any other type of node simply returns a copy of this node.
        Note that cloning an immutable subtree results in a mutable copy, but the children of an EntityReference clone are readonly . In addition, clones of unspecified Attr nodes are specified. And, cloning Document, DocumentType, Entity, and Notation nodes is implementation dependent.
        Parameters:
        deep - If true, recursively clone the subtree under the specified node; if false, clone only the node itself (and its attributes, if it is an Element).
        Returns:
        The duplicate node.

      • normalize

        void normalize()
        Puts all Text nodes in the full depth of the sub-tree underneath this Node, including attribute nodes, into a "normal" form where only structure (e.g., elements, comments, processing instructions, CDATA sections, and entity references) separates Text nodes, i.e., there are neither adjacent Text nodes nor empty Text nodes. This can be used to ensure that the DOM view of a document is the same as if it were saved and re-loaded, and is useful when operations (such as XPointer [XPointer] lookups) that depend on a particular document tree structure are to be used. If the parameter "normalize-characters" of the DOMConfiguration object attached to the Node.ownerDocument is true, this method will also fully normalize the characters of the Text nodes.

        Note: In cases where the document contains CDATASections, the normalize operation alone may not be sufficient, since XPointers do not differentiate between Text nodes and CDATASection nodes.

        Since:
        DOM Level 3

      • isSupported

        boolean isSupported(String feature,
                    String version)
        Tests whether the DOM implementation implements a specific feature and that feature is supported by this node, as specified in .
        Parameters:
        feature - The name of the feature to test.
        version - This is the version number of the feature to test.
        Returns:
        Returns true if the specified feature is supported on this node, false otherwise.
        Since:
        DOM Level 2

      • getNamespaceURI

        String getNamespaceURI()
        The namespace URI of this node, or null if it is unspecified (see ).
        This is not a computed value that is the result of a namespace lookup based on an examination of the namespace declarations in scope. It is merely the namespace URI given at creation time.
        For nodes of any type other than ELEMENT_NODE and ATTRIBUTE_NODE and nodes created with a DOM Level 1 method, such as Document.createElement(), this is always null.

        Note: Per the Namespaces in XML Specification [XML Namespaces] an attribute does not inherit its namespace from the element it is attached to. If an attribute is not explicitly given a namespace, it simply has no namespace.

        Since:
        DOM Level 2

      • getPrefix

        String getPrefix()
        The namespace prefix of this node, or null if it is unspecified. When it is defined to be null, setting it has no effect, including if the node is read-only.
        Note that setting this attribute, when permitted, changes the nodeName attribute, which holds the qualified name, as well as the tagName and name attributes of the Element and Attr interfaces, when applicable.
        Setting the prefix to null makes it unspecified, setting it to an empty string is implementation dependent.
        Note also that changing the prefix of an attribute that is known to have a default value, does not make a new attribute with the default value and the original prefix appear, since the namespaceURI and localName do not change.
        For nodes of any type other than ELEMENT_NODE and ATTRIBUTE_NODE and nodes created with a DOM Level 1 method, such as createElement from the Document interface, this is always null.
        Since:
        DOM Level 2

      • setPrefix

        void setPrefix(String prefix)
        throws DOMException
        The namespace prefix of this node, or null if it is unspecified. When it is defined to be null, setting it has no effect, including if the node is read-only.
        Note that setting this attribute, when permitted, changes the nodeName attribute, which holds the qualified name, as well as the tagName and name attributes of the Element and Attr interfaces, when applicable.
        Setting the prefix to null makes it unspecified, setting it to an empty string is implementation dependent.
        Note also that changing the prefix of an attribute that is known to have a default value, does not make a new attribute with the default value and the original prefix appear, since the namespaceURI and localName do not change.
        For nodes of any type other than ELEMENT_NODE and ATTRIBUTE_NODE and nodes created with a DOM Level 1 method, such as createElement from the Document interface, this is always null.
        Throws:
        DOMException - INVALID_CHARACTER_ERR: Raised if the specified prefix contains an illegal character according to the XML version in use specified in the Document.xmlVersion attribute.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.
        NAMESPACE_ERR: Raised if the specified prefix is malformed per the Namespaces in XML specification, if the namespaceURI of this node is null, if the specified prefix is "xml" and the namespaceURI of this node is different from " http://www.w3.org/XML/1998/namespace", if this node is an attribute and the specified prefix is "xmlns" and the namespaceURI of this node is different from "http://www.w3.org/2000/xmlns/", or if this node is an attribute and the qualifiedName of this node is "xmlns" [XML Namespaces] .
        Since:
        DOM Level 2

      • getLocalName

        String getLocalName()
        Returns the local part of the qualified name of this node.
        For nodes of any type other than ELEMENT_NODE and ATTRIBUTE_NODE and nodes created with a DOM Level 1 method, such as Document.createElement(), this is always null.
        Since:
        DOM Level 2

      • hasAttributes

        boolean hasAttributes()
        Returns whether this node (if it is an element) has any attributes.
        Returns:
        Returns true if this node has any attributes, false otherwise.
        Since:
        DOM Level 2

      • getBaseURI

        String getBaseURI()
        The absolute base URI of this node or null if the implementation wasn't able to obtain an absolute URI. This value is computed as described in . However, when the Document supports the feature "HTML" [DOM Level 2 HTML] , the base URI is computed using first the value of the href attribute of the HTML BASE element if any, and the value of the documentURI attribute from the Document interface otherwise.
        Since:
        DOM Level 3

      • compareDocumentPosition

        short compareDocumentPosition(Node other)
                       throws DOMException
        Compares the reference node, i.e. the node on which this method is being called, with a node, i.e. the one passed as a parameter, with regard to their position in the document and according to the document order.
        Parameters:
        other - The node to compare against the reference node.
        Returns:
        Returns how the node is positioned relatively to the reference node.
        Throws:
        DOMException - NOT_SUPPORTED_ERR: when the compared nodes are from different DOM implementations that do not coordinate to return consistent implementation-specific results.
        Since:
        DOM Level 3

      • getTextContent

        String getTextContent()
               throws DOMException
        This attribute returns the text content of this node and its descendants. When it is defined to be null, setting it has no effect. On setting, any possible children this node may have are removed and, if it the new string is not empty or null, replaced by a single Text node containing the string this attribute is set to.
        On getting, no serialization is performed, the returned string does not contain any markup. No whitespace normalization is performed and the returned string does not contain the white spaces in element content (see the attribute Text.isElementContentWhitespace). Similarly, on setting, no parsing is performed either, the input string is taken as pure textual content.
        The string returned is made of the text content of this node depending on its type, as defined below:
        Node type | Content
        ELEMENT_NODE, ATTRIBUTE_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, DOCUMENT_FRAGMENT_NODE | concatenation of the textContent attribute value of every child node, excluding COMMENT_NODE and PROCESSING_INSTRUCTION_NODE nodes. This is the empty string if the node has no children.
        TEXT_NODE, CDATA_SECTION_NODE, COMMENT_NODE, PROCESSING_INSTRUCTION_NODE | nodeValue
        DOCUMENT_NODE, DOCUMENT_TYPE_NODE, NOTATION_NODE | null
        Throws:
        DOMException - DOMSTRING_SIZE_ERR: Raised when it would return more characters than fit in a DOMString variable on the implementation platform.
        Since:
        DOM Level 3

      • setTextContent

        void setTextContent(String textContent)
             throws DOMException
        This attribute returns the text content of this node and its descendants. When it is defined to be null, setting it has no effect. On setting, any possible children this node may have are removed and, if it the new string is not empty or null, replaced by a single Text node containing the string this attribute is set to.
        On getting, no serialization is performed, the returned string does not contain any markup. No whitespace normalization is performed and the returned string does not contain the white spaces in element content (see the attribute Text.isElementContentWhitespace). Similarly, on setting, no parsing is performed either, the input string is taken as pure textual content.
        The string returned is made of the text content of this node depending on its type, as defined below:
        Node type | Content
        ELEMENT_NODE, ATTRIBUTE_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, DOCUMENT_FRAGMENT_NODE | concatenation of the textContent attribute value of every child node, excluding COMMENT_NODE and PROCESSING_INSTRUCTION_NODE nodes. This is the empty string if the node has no children.
        TEXT_NODE, CDATA_SECTION_NODE, COMMENT_NODE, PROCESSING_INSTRUCTION_NODE | nodeValue
        DOCUMENT_NODE, DOCUMENT_TYPE_NODE, NOTATION_NODE | null
        Throws:
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised when the node is readonly.
        Since:
        DOM Level 3

      • isSameNode

        boolean isSameNode(Node other)
        Returns whether this node is the same node as the given one.
        This method provides a way to determine whether two Node references returned by the implementation reference the same object. When two Node references are references to the same object, even if through a proxy, the references may be used completely interchangeably, such that all attributes have the same values and calling the same DOM method on either reference always has exactly the same effect.
        Parameters:
        other - The node to test against.
        Returns:
        Returns true if the nodes are the same, false otherwise.
        Since:
        DOM Level 3

      • lookupPrefix

        String lookupPrefix(String namespaceURI)
        Look up the prefix associated to the given namespace URI, starting from this node. The default namespace declarations are ignored by this method.
        See for details on the algorithm used by this method.
        Parameters:
        namespaceURI - The namespace URI to look for.
        Returns:
        Returns an associated namespace prefix if found or null if none is found. If more than one prefix are associated to the namespace prefix, the returned namespace prefix is implementation dependent.
        Since:
        DOM Level 3

      • isDefaultNamespace

        boolean isDefaultNamespace(String namespaceURI)
        This method checks if the specified namespaceURI is the default namespace or not.
        Parameters:
        namespaceURI - The namespace URI to look for.
        Returns:
        Returns true if the specified namespaceURI is the default namespace, false otherwise.
        Since:
        DOM Level 3

      • lookupNamespaceURI

        String lookupNamespaceURI(String prefix)
        Look up the namespace URI associated to the given prefix, starting from this node.
        See for details on the algorithm used by this method.
        Parameters:
        prefix - The prefix to look for. If this parameter is null, the method will return the default namespace URI if any.
        Returns:
        Returns the associated namespace URI or null if none is found.
        Since:
        DOM Level 3

      • isEqualNode

        boolean isEqualNode(Node arg)
        Tests whether two nodes are equal.
        This method tests for equality of nodes, not sameness (i.e., whether the two nodes are references to the same object) which can be tested with Node.isSameNode(). All nodes that are the same will also be equal, though the reverse may not be true.
        Two nodes are equal if and only if the following conditions are satisfied:
        • The two nodes are of the same type.
        • The following string attributes are equal: nodeName, localName, namespaceURI, prefix, nodeValue . This is: they are both null, or they have the same length and are character for character identical.
        • The attributes NamedNodeMaps are equal. This is: they are both null, or they have the same length and for each node that exists in one map there is a node that exists in the other map and is equal, although not necessarily at the same index.
        • The childNodes NodeLists are equal. This is: they are both null, or they have the same length and contain equal nodes at the same index. Note that normalization can affect equality; to avoid this, nodes should be normalized before being compared.

        For two DocumentType nodes to be equal, the following conditions must also be satisfied:
        • The following string attributes are equal: publicId, systemId, internalSubset.
        • The entities NamedNodeMaps are equal.
        • The notations NamedNodeMaps are equal.

        On the other hand, the following do not affect equality: the ownerDocument, baseURI, and parentNode attributes, the specified attribute for Attr nodes, the schemaTypeInfo attribute for Attr and Element nodes, the Text.isElementContentWhitespace attribute for Text nodes, as well as any user data or event listeners registered on the nodes.

        Note: As a general rule, anything not mentioned in the description above is not significant in consideration of equality checking. Note that future versions of this specification may take into account more attributes and implementations conform to this specification are expected to be updated accordingly.

        Parameters:
        arg - The node to compare equality with.
        Returns:
        Returns true if the nodes are equal, false otherwise.
        Since:
        DOM Level 3

      • getFeature

        Object getFeature(String feature,
                  String version)
        This method returns a specialized object which implements the specialized APIs of the specified feature and version, as specified in . The specialized object may also be obtained by using binding-specific casting methods but is not necessarily expected to, as discussed in . This method also allow the implementation to provide specialized objects which do not support the Node interface.
        Parameters:
        feature - The name of the feature requested. Note that any plus sign "+" prepended to the name of the feature will be ignored since it is not significant in the context of this method.
        version - This is the version number of the feature to test.
        Returns:
        Returns an object which implements the specialized APIs of the specified feature and version, if any, or null if there is no object which implements interfaces associated with that feature. If the DOMObject returned by this method implements the Node interface, it must delegate to the primary core Node and not return results inconsistent with the primary core Node such as attributes, childNodes, etc.
        Since:
        DOM Level 3

      • setUserData

        Object setUserData(String key,
                   Object data,
                   UserDataHandler handler)
        Associate an object to a key on this node. The object can later be retrieved from this node by calling getUserData with the same key.
        Parameters:
        key - The key to associate the object to.
        data - The object to associate to the given key, or null to remove any existing association to that key.
        handler - The handler to associate to that key, or null.
        Returns:
        Returns the DOMUserData previously associated to the given key on this node, or null if there was none.
        Since:
        DOM Level 3

      • getUserData

        Object getUserData(String key)
        Retrieves the object associated to a key on a this node. The object must first have been set to this node by calling setUserData with the same key.
        Parameters:
        key - The key the object is associated to.
        Returns:
        Returns the DOMUserData associated to the given key on this node, or null if there was none.
        Since:
        DOM Level 3
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NodeList (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface NodeList

  • All Known Implementing Classes:
    IIOMetadataNode

    public interface NodeList
    The NodeList interface provides the abstraction of an ordered collection of nodes, without defining or constraining how this collection is implemented. NodeList objects in the DOM are live.

    The items in the NodeList are accessible via an integral index, starting from 0.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      int getLength()
      The number of nodes in the list.
      Node item(int index)
      Returns the indexth item in the collection.

    • Method Detail

      • item

        Node item(int index)
        Returns the indexth item in the collection. If index is greater than or equal to the number of nodes in the list, this returns null.
        Parameters:
        index - Index into the collection.
        Returns:
        The node at the indexth position in the NodeList, or null if that is not a valid index.

      • getLength

        int getLength()
        The number of nodes in the list. The range of valid child node indices is 0 to length-1 inclusive.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Notation (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface Notation

  • All Superinterfaces:
    Node

    public interface Notation
extends Node
    This interface represents a notation declared in the DTD. A notation either declares, by name, the format of an unparsed entity (see section 4.7 of the XML 1.0 specification [XML 1.0]), or is used for formal declaration of processing instruction targets (see section 2.6 of the XML 1.0 specification [XML 1.0]). The nodeName attribute inherited from Node is set to the declared name of the notation.

    The DOM Core does not support editing Notation nodes; they are therefore readonly.

    A Notation node does not have any parent.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getPublicId()
      The public identifier of this notation.
      String getSystemId()
      The system identifier of this notation.

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • Method Detail

      • getPublicId

        String getPublicId()
        The public identifier of this notation. If the public identifier was not specified, this is null.

      • getSystemId

        String getSystemId()
        The system identifier of this notation. If the system identifier was not specified, this is null. This may be an absolute URI or not.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


org.w3c.dom (Java Platform SE 8 )

org.w3c.dom

Interfaces

  • Attr
  • CDATASection
  • CharacterData
  • Comment
  • Document
  • DocumentFragment
  • DocumentType
  • DOMConfiguration
  • DOMError
  • DOMErrorHandler
  • DOMImplementation
  • DOMImplementationList
  • DOMImplementationSource
  • DOMLocator
  • DOMStringList
  • Element
  • Entity
  • EntityReference
  • NamedNodeMap
  • NameList
  • Node
  • NodeList
  • Notation
  • ProcessingInstruction
  • Text
  • TypeInfo
  • UserDataHandler

Exceptions

  • DOMException


org.w3c.dom (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.w3c.dom

Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.

See: Description

  • Interface Summary
    Interface Description
    Attr
    The Attr interface represents an attribute in an Element object.
    CDATASection
    CDATA sections are used to escape blocks of text containing characters that would otherwise be regarded as markup.
    CharacterData
    The CharacterData interface extends Node with a set of attributes and methods for accessing character data in the DOM.
    Comment
    This interface inherits from CharacterData and represents the content of a comment, i.e., all the characters between the starting ' <!--' and ending '-->'.
    Document
    The Document interface represents the entire HTML or XML document.
    DocumentFragment
    DocumentFragment is a "lightweight" or "minimal" Document object.
    DocumentType
    Each Document has a doctype attribute whose value is either null or a DocumentType object.
    DOMConfiguration
    The DOMConfiguration interface represents the configuration of a document and maintains a table of recognized parameters.
    DOMError
    DOMError is an interface that describes an error.
    DOMErrorHandler
    DOMErrorHandler is a callback interface that the DOM implementation can call when reporting errors that happens while processing XML data, or when doing some other processing (e.g.
    DOMImplementation
    The DOMImplementation interface provides a number of methods for performing operations that are independent of any particular instance of the document object model.
    DOMImplementationList
    The DOMImplementationList interface provides the abstraction of an ordered collection of DOM implementations, without defining or constraining how this collection is implemented.
    DOMImplementationSource
    This interface permits a DOM implementer to supply one or more implementations, based upon requested features and versions, as specified in DOM Features.
    DOMLocator
    DOMLocator is an interface that describes a location (e.g.
    DOMStringList
    The DOMStringList interface provides the abstraction of an ordered collection of DOMString values, without defining or constraining how this collection is implemented.
    Element
    The Element interface represents an element in an HTML or XML document.
    Entity
    This interface represents a known entity, either parsed or unparsed, in an XML document.
    EntityReference
    EntityReference nodes may be used to represent an entity reference in the tree.
    NamedNodeMap
    Objects implementing the NamedNodeMap interface are used to represent collections of nodes that can be accessed by name.
    NameList
    The NameList interface provides the abstraction of an ordered collection of parallel pairs of name and namespace values (which could be null values), without defining or constraining how this collection is implemented.
    Node
    The Node interface is the primary datatype for the entire Document Object Model.
    NodeList
    The NodeList interface provides the abstraction of an ordered collection of nodes, without defining or constraining how this collection is implemented.
    Notation
    This interface represents a notation declared in the DTD.
    ProcessingInstruction
    The ProcessingInstruction interface represents a "processing instruction", used in XML as a way to keep processor-specific information in the text of the document.
    Text
    The Text interface inherits from CharacterData and represents the textual content (termed character data in XML) of an Element or Attr.
    TypeInfo
    The TypeInfo interface represents a type referenced from Element or Attr nodes, specified in the schemas associated with the document.
    UserDataHandler
    When associating an object to a key on a node using Node.setUserData() the application can provide a handler that gets called when the node the object is associated to is being cloned, imported, or renamed.
  • Exception Summary
    Exception Description
    DOMException
    DOM operations only raise exceptions in "exceptional" circumstances, i.e., when an operation is impossible to perform (either for logical reasons, because data is lost, or because the implementation has become unstable).

Package org.w3c.dom Description

Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing. The Document Object Model Level 2 Core API allows programs to dynamically access and update the content and structure of documents. See the specification for more information.
Since:
JDK1.4
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames


org.w3c.dom Class Hierarchy (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.w3c.dom

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • org.w3c.dom.DOMException

Interface Hierarchy

  • org.w3c.dom.DOMConfiguration
  • org.w3c.dom.DOMError
  • org.w3c.dom.DOMErrorHandler
  • org.w3c.dom.DOMImplementation
  • org.w3c.dom.DOMImplementationList
  • org.w3c.dom.DOMImplementationSource
  • org.w3c.dom.DOMLocator
  • org.w3c.dom.DOMStringList
  • org.w3c.dom.NamedNodeMap
  • org.w3c.dom.NameList
  • org.w3c.dom.Node
    • org.w3c.dom.Attr
    • org.w3c.dom.CharacterData
      • org.w3c.dom.Comment
      • org.w3c.dom.Text
        • org.w3c.dom.CDATASection
    • org.w3c.dom.Document
    • org.w3c.dom.DocumentFragment
    • org.w3c.dom.DocumentType
    • org.w3c.dom.Element
    • org.w3c.dom.Entity
    • org.w3c.dom.EntityReference
    • org.w3c.dom.Notation
    • org.w3c.dom.ProcessingInstruction
  • org.w3c.dom.NodeList
  • org.w3c.dom.TypeInfo
  • org.w3c.dom.UserDataHandler
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package org.w3c.dom (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.w3c.dom

  • Packages that use org.w3c.dom
    Package Description
    javax.imageio.metadata
    A package of the Java Image I/O API dealing with reading and writing metadata.
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.annotation
    Defines annotations for customizing Java program elements to XML Schema mapping.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.crypto.dom
    DOM-specific classes for the javax.xml.crypto package.
    javax.xml.crypto.dsig.dom
    DOM-specific classes for the javax.xml.crypto.dsig package.
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    javax.xml.soap
    Provides the API for creating and building SOAP messages.
    javax.xml.transform.dom
    This package implements DOM-specific transformation APIs.
    javax.xml.validation
    This package provides an API for validation of XML documents.
    javax.xml.ws
    This package contains the core JAX-WS APIs.
    javax.xml.ws.spi
    This package defines SPIs for JAX-WS.
    javax.xml.ws.wsaddressing
    This package defines APIs related to WS-Addressing.
    org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.
    org.w3c.dom.bootstrap
    org.w3c.dom.events
    org.w3c.dom.ls
  • Classes in org.w3c.dom used by javax.imageio.metadata
    Class and Description
    Attr
    The Attr interface represents an attribute in an Element object.
    Document
    The Document interface represents the entire HTML or XML document.
    DOMException
    DOM operations only raise exceptions in "exceptional" circumstances, i.e., when an operation is impossible to perform (either for logical reasons, because data is lost, or because the implementation has become unstable).
    Element
    The Element interface represents an element in an HTML or XML document.
    NamedNodeMap
    Objects implementing the NamedNodeMap interface are used to represent collections of nodes that can be accessed by name.
    Node
    The Node interface is the primary datatype for the entire Document Object Model.
    NodeList
    The NodeList interface provides the abstraction of an ordered collection of nodes, without defining or constraining how this collection is implemented.
    TypeInfo
    The TypeInfo interface represents a type referenced from Element or Attr nodes, specified in the schemas associated with the document.
    UserDataHandler
    When associating an object to a key on a node using Node.setUserData() the application can provide a handler that gets called when the node the object is associated to is being cloned, imported, or renamed.
  • Classes in org.w3c.dom used by javax.xml.bind
    Class and Description
    Node
    The Node interface is the primary datatype for the entire Document Object Model.
  • Classes in org.w3c.dom used by javax.xml.bind.annotation
    Class and Description
    Element
    The Element interface represents an element in an HTML or XML document.
  • Classes in org.w3c.dom used by javax.xml.bind.helpers
    Class and Description
    Node
    The Node interface is the primary datatype for the entire Document Object Model.
  • Classes in org.w3c.dom used by javax.xml.crypto.dom
    Class and Description
    Element
    The Element interface represents an element in an HTML or XML document.
    Node
    The Node interface is the primary datatype for the entire Document Object Model.
  • Classes in org.w3c.dom used by javax.xml.crypto.dsig.dom
    Class and Description
    Node
    The Node interface is the primary datatype for the entire Document Object Model.
  • Classes in org.w3c.dom used by javax.xml.parsers
    Class and Description
    Document
    The Document interface represents the entire HTML or XML document.
    DOMImplementation
    The DOMImplementation interface provides a number of methods for performing operations that are independent of any particular instance of the document object model.
  • Classes in org.w3c.dom used by javax.xml.soap
    Class and Description
    Document
    The Document interface represents the entire HTML or XML document.
    Element
    The Element interface represents an element in an HTML or XML document.
    Node
    The Node interface is the primary datatype for the entire Document Object Model.
    Text
    The Text interface inherits from CharacterData and represents the textual content (termed character data in XML) of an Element or Attr.
  • Classes in org.w3c.dom used by javax.xml.transform.dom
    Class and Description
    Node
    The Node interface is the primary datatype for the entire Document Object Model.
  • Classes in org.w3c.dom used by javax.xml.validation
    Class and Description
    TypeInfo
    The TypeInfo interface represents a type referenced from Element or Attr nodes, specified in the schemas associated with the document.
  • Classes in org.w3c.dom used by javax.xml.ws
    Class and Description
    Element
    The Element interface represents an element in an HTML or XML document.
  • Classes in org.w3c.dom used by javax.xml.ws.spi
    Class and Description
    Element
    The Element interface represents an element in an HTML or XML document.
  • Classes in org.w3c.dom used by javax.xml.ws.wsaddressing
    Class and Description
    Element
    The Element interface represents an element in an HTML or XML document.
  • Classes in org.w3c.dom used by org.w3c.dom
    Class and Description
    Attr
    The Attr interface represents an attribute in an Element object.
    CDATASection
    CDATA sections are used to escape blocks of text containing characters that would otherwise be regarded as markup.
    CharacterData
    The CharacterData interface extends Node with a set of attributes and methods for accessing character data in the DOM.
    Comment
    This interface inherits from CharacterData and represents the content of a comment, i.e., all the characters between the starting ' <!--' and ending '-->'.
    Document
    The Document interface represents the entire HTML or XML document.
    DocumentFragment
    DocumentFragment is a "lightweight" or "minimal" Document object.
    DocumentType
    Each Document has a doctype attribute whose value is either null or a DocumentType object.
    DOMConfiguration
    The DOMConfiguration interface represents the configuration of a document and maintains a table of recognized parameters.
    DOMError
    DOMError is an interface that describes an error.
    DOMException
    DOM operations only raise exceptions in "exceptional" circumstances, i.e., when an operation is impossible to perform (either for logical reasons, because data is lost, or because the implementation has become unstable).
    DOMImplementation
    The DOMImplementation interface provides a number of methods for performing operations that are independent of any particular instance of the document object model.
    DOMImplementationList
    The DOMImplementationList interface provides the abstraction of an ordered collection of DOM implementations, without defining or constraining how this collection is implemented.
    DOMLocator
    DOMLocator is an interface that describes a location (e.g.
    DOMStringList
    The DOMStringList interface provides the abstraction of an ordered collection of DOMString values, without defining or constraining how this collection is implemented.
    Element
    The Element interface represents an element in an HTML or XML document.
    EntityReference
    EntityReference nodes may be used to represent an entity reference in the tree.
    NamedNodeMap
    Objects implementing the NamedNodeMap interface are used to represent collections of nodes that can be accessed by name.
    Node
    The Node interface is the primary datatype for the entire Document Object Model.
    NodeList
    The NodeList interface provides the abstraction of an ordered collection of nodes, without defining or constraining how this collection is implemented.
    ProcessingInstruction
    The ProcessingInstruction interface represents a "processing instruction", used in XML as a way to keep processor-specific information in the text of the document.
    Text
    The Text interface inherits from CharacterData and represents the textual content (termed character data in XML) of an Element or Attr.
    TypeInfo
    The TypeInfo interface represents a type referenced from Element or Attr nodes, specified in the schemas associated with the document.
    UserDataHandler
    When associating an object to a key on a node using Node.setUserData() the application can provide a handler that gets called when the node the object is associated to is being cloned, imported, or renamed.
  • Classes in org.w3c.dom used by org.w3c.dom.bootstrap
    Class and Description
    DOMImplementation
    The DOMImplementation interface provides a number of methods for performing operations that are independent of any particular instance of the document object model.
    DOMImplementationList
    The DOMImplementationList interface provides the abstraction of an ordered collection of DOM implementations, without defining or constraining how this collection is implemented.
    DOMImplementationSource
    This interface permits a DOM implementer to supply one or more implementations, based upon requested features and versions, as specified in DOM Features.
  • Classes in org.w3c.dom used by org.w3c.dom.events
    Class and Description
    DOMException
    DOM operations only raise exceptions in "exceptional" circumstances, i.e., when an operation is impossible to perform (either for logical reasons, because data is lost, or because the implementation has become unstable).
    Node
    The Node interface is the primary datatype for the entire Document Object Model.
  • Classes in org.w3c.dom used by org.w3c.dom.ls
    Class and Description
    Document
    The Document interface represents the entire HTML or XML document.
    DOMConfiguration
    The DOMConfiguration interface represents the configuration of a document and maintains a table of recognized parameters.
    DOMException
    DOM operations only raise exceptions in "exceptional" circumstances, i.e., when an operation is impossible to perform (either for logical reasons, because data is lost, or because the implementation has become unstable).
    Element
    The Element interface represents an element in an HTML or XML document.
    Node
    The Node interface is the primary datatype for the entire Document Object Model.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


ProcessingInstruction (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface ProcessingInstruction

  • All Superinterfaces:
    Node

    public interface ProcessingInstruction
extends Node
    The ProcessingInstruction interface represents a "processing instruction", used in XML as a way to keep processor-specific information in the text of the document.

    No lexical check is done on the content of a processing instruction and it is therefore possible to have the character sequence "?>" in the content, which is illegal a processing instruction per section 2.6 of [XML 1.0]. The presence of this character sequence must generate a fatal error during serialization.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getData()
      The content of this processing instruction.
      String getTarget()
      The target of this processing instruction.
      void setData(String data)
      The content of this processing instruction.

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • Method Detail

      • getTarget

        String getTarget()
        The target of this processing instruction. XML defines this as being the first token following the markup that begins the processing instruction.

      • getData

        String getData()
        The content of this processing instruction. This is from the first non white space character after the target to the character immediately preceding the ?>.

      • setData

        void setData(String data)
      throws DOMException
        The content of this processing instruction. This is from the first non white space character after the target to the character immediately preceding the ?>.
        Throws:
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised when the node is readonly.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Text (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface Text

  • All Superinterfaces:
    CharacterData, Node
    All Known Subinterfaces:
    CDATASection, Text

    public interface Text
extends CharacterData
    The Text interface inherits from CharacterData and represents the textual content (termed character data in XML) of an Element or Attr. If there is no markup inside an element's content, the text is contained in a single object implementing the Text interface that is the only child of the element. If there is markup, it is parsed into the information items (elements, comments, etc.) and Text nodes that form the list of children of the element.

    When a document is first made available via the DOM, there is only one Text node for each block of text. Users may create adjacent Text nodes that represent the contents of a given element without any intervening markup, but should be aware that there is no way to represent the separations between these nodes in XML or HTML, so they will not (in general) persist between DOM editing sessions. The Node.normalize() method merges any such adjacent Text objects into a single node for each block of text.

    No lexical check is done on the content of a Text node and, depending on its position in the document, some characters must be escaped during serialization using character references; e.g. the characters "<&" if the textual content is part of an element or of an attribute, the character sequence "]]>" when part of an element, the quotation mark character " or the apostrophe character ' when part of an attribute.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    • Field Summary

      • Fields inherited from interface org.w3c.dom.Node

        ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getWholeText()
      Returns all text of Text nodes logically-adjacent text nodes to this node, concatenated in document order.
      boolean isElementContentWhitespace()
      Returns whether this text node contains element content whitespace, often abusively called "ignorable whitespace".
      Text replaceWholeText(String content)
      Replaces the text of the current node and all logically-adjacent text nodes with the specified text.
      Text splitText(int offset)
      Breaks this node into two nodes at the specified offset, keeping both in the tree as siblings.

      • Methods inherited from interface org.w3c.dom.CharacterData

        appendData, deleteData, getData, getLength, insertData, replaceData, setData, substringData

      • Methods inherited from interface org.w3c.dom.Node

        appendChild, cloneNode, compareDocumentPosition, getAttributes, getBaseURI, getChildNodes, getFeature, getFirstChild, getLastChild, getLocalName, getNamespaceURI, getNextSibling, getNodeName, getNodeType, getNodeValue, getOwnerDocument, getParentNode, getPrefix, getPreviousSibling, getTextContent, getUserData, hasAttributes, hasChildNodes, insertBefore, isDefaultNamespace, isEqualNode, isSameNode, isSupported, lookupNamespaceURI, lookupPrefix, normalize, removeChild, replaceChild, setNodeValue, setPrefix, setTextContent, setUserData

    • Method Detail

      • splitText

        Text splitText(int offset)
        throws DOMException
        Breaks this node into two nodes at the specified offset, keeping both in the tree as siblings. After being split, this node will contain all the content up to the offset point. A new node of the same type, which contains all the content at and after the offset point, is returned. If the original node had a parent node, the new node is inserted as the next sibling of the original node. When the offset is equal to the length of this node, the new node has no data.
        Parameters:
        offset - The 16-bit unit offset at which to split, starting from 0.
        Returns:
        The new node, of the same type as this node.
        Throws:
        DOMException - INDEX_SIZE_ERR: Raised if the specified offset is negative or greater than the number of 16-bit units in data.
        NO_MODIFICATION_ALLOWED_ERR: Raised if this node is readonly.

      • isElementContentWhitespace

        boolean isElementContentWhitespace()
        Returns whether this text node contains element content whitespace, often abusively called "ignorable whitespace". The text node is determined to contain whitespace in element content during the load of the document or if validation occurs while using Document.normalizeDocument().
        Since:
        DOM Level 3

      • getWholeText

        String getWholeText()
        Returns all text of Text nodes logically-adjacent text nodes to this node, concatenated in document order.
        For instance, in the example below wholeText on the Text node that contains "bar" returns "barfoo", while on the Text node that contains "foo" it returns "barfoo".
                             +-----+
                     | <p> |
                     +-----+
                       /\
                      /  \
               /-----\    +-------+
               | bar |    | &ent; |
               \-----/    +-------+
                              |
                              |
                           /-----\
                           | foo |
                           \-----/
        Figure: barTextNode.wholeText value is "barfoo"
        Since:
        DOM Level 3

      • replaceWholeText

        Text replaceWholeText(String content)
               throws DOMException
        Replaces the text of the current node and all logically-adjacent text nodes with the specified text. All logically-adjacent text nodes are removed including the current node unless it was the recipient of the replacement text.

        This method returns the node which received the replacement text. The returned node is:

        • null, when the replacement text is the empty string;
        • the current node, except when the current node is read-only;
        • a new Text node of the same type ( Text or CDATASection) as the current node inserted at the location of the replacement.

        For instance, in the above example calling replaceWholeText on the Text node that contains "bar" with "yo" in argument results in the following:

                             +-----+
                     | <p> |
                     +-----+
                        |
                        |
                     /-----\
                     | yo  |
                     \-----/
        Figure: barTextNode.replaceWholeText("yo") modifies the textual content of barTextNode with "yo"

        Where the nodes to be removed are read-only descendants of an EntityReference, the EntityReference must be removed instead of the read-only nodes. If any EntityReference to be removed has descendants that are not EntityReference, Text, or CDATASection nodes, the replaceWholeText method must fail before performing any modification of the document, raising a DOMException with the code NO_MODIFICATION_ALLOWED_ERR.

        For instance, in the example below calling replaceWholeText on the Text node that contains "bar" fails, because the EntityReference node "ent" contains an Element node which cannot be removed.

        Parameters:
        content - The content of the replacing Text node.
        Returns:
        The Text node created with the specified content.
        Throws:
        DOMException - NO_MODIFICATION_ALLOWED_ERR: Raised if one of the Text nodes being replaced is readonly.
        Since:
        DOM Level 3
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


TypeInfo (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface TypeInfo

  • public interface TypeInfo
    The TypeInfo interface represents a type referenced from Element or Attr nodes, specified in the schemas associated with the document. The type is a pair of a namespace URI and name properties, and depends on the document's schema.

    If the document's schema is an XML DTD [XML 1.0], the values are computed as follows:

    • If this type is referenced from an Attr node, typeNamespace is "http://www.w3.org/TR/REC-xml" and typeName represents the [attribute type] property in the [XML Information Set] . If there is no declaration for the attribute, typeNamespace and typeName are null.
    • If this type is referenced from an Element node, typeNamespace and typeName are null.

    If the document's schema is an XML Schema [XML Schema Part 1] , the values are computed as follows using the post-schema-validation infoset contributions (also called PSVI contributions):

    • If the [validity] property exists AND is "invalid" or "notKnown": the {target namespace} and {name} properties of the declared type if available, otherwise null.

      Note: At the time of writing, the XML Schema specification does not require exposing the declared type. Thus, DOM implementations might choose not to provide type information if validity is not valid.

    • If the [validity] property exists and is "valid":
      1. If [member type definition] exists:
        1. If {name} is not absent, then expose {name} and {target namespace} properties of the [member type definition] property;
        2. Otherwise, expose the namespace and local name of the corresponding anonymous type name.
      2. If the [type definition] property exists:
        1. If {name} is not absent, then expose {name} and {target namespace} properties of the [type definition] property;
        2. Otherwise, expose the namespace and local name of the corresponding anonymous type name.
      3. If the [member type definition anonymous] exists:
        1. If it is false, then expose [member type definition name] and [member type definition namespace] properties;
        2. Otherwise, expose the namespace and local name of the corresponding anonymous type name.
      4. If the [type definition anonymous] exists:
        1. If it is false, then expose [type definition name] and [type definition namespace] properties;
        2. Otherwise, expose the namespace and local name of the corresponding anonymous type name.

    Note: Other schema languages are outside the scope of the W3C and therefore should define how to represent their type systems using TypeInfo.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    Since:
    DOM Level 3

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static int DERIVATION_EXTENSION
      If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the derivation by extension.
      static int DERIVATION_LIST
      If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the list.
      static int DERIVATION_RESTRICTION
      If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the derivation by restriction if complex types are involved, or a restriction if simple types are involved.
      static int DERIVATION_UNION
      If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the union if simple types are involved.

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getTypeName()
      The name of a type declared for the associated element or attribute, or null if unknown.
      String getTypeNamespace()
      The namespace of the type declared for the associated element or attribute or null if the element does not have declaration or if no namespace information is available.
      boolean isDerivedFrom(String typeNamespaceArg, String typeNameArg, int derivationMethod)
      This method returns if there is a derivation between the reference type definition, i.e.

    • Field Detail

      • DERIVATION_RESTRICTION

        static final int DERIVATION_RESTRICTION
        If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the derivation by restriction if complex types are involved, or a restriction if simple types are involved.
        The reference type definition is derived by restriction from the other type definition if the other type definition is the same as the reference type definition, or if the other type definition can be reached recursively following the {base type definition} property from the reference type definition, and all the derivation methods involved are restriction.
        See Also:
        Constant Field Values

      • DERIVATION_EXTENSION

        static final int DERIVATION_EXTENSION
        If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the derivation by extension.
        The reference type definition is derived by extension from the other type definition if the other type definition can be reached recursively following the {base type definition} property from the reference type definition, and at least one of the derivation methods involved is an extension.
        See Also:
        Constant Field Values

      • DERIVATION_UNION

        static final int DERIVATION_UNION
        If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the union if simple types are involved.
        The reference type definition is derived by union from the other type definition if there exists two type definitions T1 and T2 such as the reference type definition is derived from T1 by DERIVATION_RESTRICTION or DERIVATION_EXTENSION, T2 is derived from the other type definition by DERIVATION_RESTRICTION, T1 has {variety} union, and one of the {member type definitions} is T2. Note that T1 could be the same as the reference type definition, and T2 could be the same as the other type definition.
        See Also:
        Constant Field Values

      • DERIVATION_LIST

        static final int DERIVATION_LIST
        If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the list.
        The reference type definition is derived by list from the other type definition if there exists two type definitions T1 and T2 such as the reference type definition is derived from T1 by DERIVATION_RESTRICTION or DERIVATION_EXTENSION, T2 is derived from the other type definition by DERIVATION_RESTRICTION, T1 has {variety} list, and T2 is the {item type definition}. Note that T1 could be the same as the reference type definition, and T2 could be the same as the other type definition.
        See Also:
        Constant Field Values

    • Method Detail

      • getTypeName

        String getTypeName()
        The name of a type declared for the associated element or attribute, or null if unknown.

      • getTypeNamespace

        String getTypeNamespace()
        The namespace of the type declared for the associated element or attribute or null if the element does not have declaration or if no namespace information is available.

      • isDerivedFrom

        boolean isDerivedFrom(String typeNamespaceArg,
                      String typeNameArg,
                      int derivationMethod)
        This method returns if there is a derivation between the reference type definition, i.e. the TypeInfo on which the method is being called, and the other type definition, i.e. the one passed as parameters.
        Parameters:
        typeNamespaceArg - the namespace of the other type definition.
        typeNameArg - the name of the other type definition.
        derivationMethod - the type of derivation and conditions applied between two types, as described in the list of constants provided in this interface.
        Returns:
        If the document's schema is a DTD or no schema is associated with the document, this method will always return false . If the document's schema is an XML Schema, the method will return true if the reference type definition is derived from the other type definition according to the derivation parameter. If the value of the parameter is 0 (no bit is set to 1 for the derivationMethod parameter), the method will return true if the other type definition can be reached by recursing any combination of {base type definition}, {item type definition}, or {member type definitions} from the reference type definition.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


UserDataHandler (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom

Interface UserDataHandler

  • public interface UserDataHandler
    When associating an object to a key on a node using Node.setUserData() the application can provide a handler that gets called when the node the object is associated to is being cloned, imported, or renamed. This can be used by the application to implement various behaviors regarding the data it associates to the DOM nodes. This interface defines that handler.

    See also the Document Object Model (DOM) Level 3 Core Specification.

    Since:
    DOM Level 3

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static short NODE_ADOPTED
      The node is adopted, using Document.adoptNode().
      static short NODE_CLONED
      The node is cloned, using Node.cloneNode().
      static short NODE_DELETED
      The node is deleted.
      static short NODE_IMPORTED
      The node is imported, using Document.importNode().
      static short NODE_RENAMED
      The node is renamed, using Document.renameNode().

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void handle(short operation, String key, Object data, Node src, Node dst)
      This method is called whenever the node for which this handler is registered is imported or cloned.

    • Field Detail

      • NODE_CLONED

        static final short NODE_CLONED
        The node is cloned, using Node.cloneNode().
        See Also:
        Constant Field Values

      • NODE_IMPORTED

        static final short NODE_IMPORTED
        The node is imported, using Document.importNode().
        See Also:
        Constant Field Values

      • NODE_DELETED

        static final short NODE_DELETED
        The node is deleted.

        Note: This may not be supported or may not be reliable in certain environments, such as Java, where the implementation has no real control over when objects are actually deleted.

        See Also:
        Constant Field Values

      • NODE_RENAMED

        static final short NODE_RENAMED
        The node is renamed, using Document.renameNode().
        See Also:
        Constant Field Values

      • NODE_ADOPTED

        static final short NODE_ADOPTED
        The node is adopted, using Document.adoptNode().
        See Also:
        Constant Field Values

    • Method Detail

      • handle

        void handle(short operation,
            String key,
            Object data,
            Node src,
            Node dst)
        This method is called whenever the node for which this handler is registered is imported or cloned.
        DOM applications must not raise exceptions in a UserDataHandler. The effect of throwing exceptions from the handler is DOM implementation dependent.
        Parameters:
        operation - Specifies the type of operation that is being performed on the node.
        key - Specifies the key for which this handler is being called.
        data - Specifies the data for which this handler is being called.
        src - Specifies the node being cloned, adopted, imported, or renamed. This is null when the node is being deleted.
        dst - Specifies the node newly created if any, or null.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AbstractView (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.views

Interface AbstractView

  • public interface AbstractView
    A base interface that all views shall derive from.

    See also the Document Object Model (DOM) Level 2 Views Specification.

    Since:
    DOM Level 2

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      DocumentView getDocument()
      The source DocumentView of which this is an AbstractView.

    • Method Detail

      • getDocument

        DocumentView getDocument()
        The source DocumentView of which this is an AbstractView.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Interface org.w3c.dom.views.AbstractView (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.views.AbstractView

  • Packages that use AbstractView
    Package Description
    org.w3c.dom.events
    org.w3c.dom.views

    • Uses of AbstractView in org.w3c.dom.events

      Methods in org.w3c.dom.events that return AbstractView
      Modifier and Type Method and Description
      AbstractView UIEvent.getView()
      The view attribute identifies the AbstractView from which the event was generated.
      Methods in org.w3c.dom.events with parameters of type AbstractView
      Modifier and Type Method and Description
      void MouseEvent.initMouseEvent(String typeArg, boolean canBubbleArg, boolean cancelableArg, AbstractView viewArg, int detailArg, int screenXArg, int screenYArg, int clientXArg, int clientYArg, boolean ctrlKeyArg, boolean altKeyArg, boolean shiftKeyArg, boolean metaKeyArg, short buttonArg, EventTarget relatedTargetArg)
      The initMouseEvent method is used to initialize the value of a MouseEvent created through the DocumentEvent interface.
      void UIEvent.initUIEvent(String typeArg, boolean canBubbleArg, boolean cancelableArg, AbstractView viewArg, int detailArg)
      The initUIEvent method is used to initialize the value of a UIEvent created through the DocumentEvent interface.

    • Uses of AbstractView in org.w3c.dom.views

      Methods in org.w3c.dom.views that return AbstractView
      Modifier and Type Method and Description
      AbstractView DocumentView.getDefaultView()
      The default AbstractView for this Document, or null if none available.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.w3c.dom.views.DocumentView (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.w3c.dom.views.DocumentView

  • Packages that use DocumentView
    Package Description
    org.w3c.dom.views

    • Uses of DocumentView in org.w3c.dom.views

      Methods in org.w3c.dom.views that return DocumentView
      Modifier and Type Method and Description
      DocumentView AbstractView.getDocument()
      The source DocumentView of which this is an AbstractView.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


compact2 - org.w3c.dom.views (Java Platform SE 8 )

compact2 - org.w3c.dom.views

Interfaces

  • AbstractView
  • DocumentView


org.w3c.dom.views (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact2

Package org.w3c.dom.views

  • Interface Summary
    Interface Description
    AbstractView
    A base interface that all views shall derive from.
    DocumentView
    The DocumentView interface is implemented by Document objects in DOM implementations supporting DOM Views.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames


compact3 - org.w3c.dom.views (Java Platform SE 8 )

compact3 - org.w3c.dom.views

Interfaces

  • AbstractView
  • DocumentView


org.w3c.dom.views (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package org.w3c.dom.views

  • Interface Summary
    Interface Description
    AbstractView
    A base interface that all views shall derive from.
    DocumentView
    The DocumentView interface is implemented by Document objects in DOM implementations supporting DOM Views.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames


DocumentView (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.w3c.dom.views

Interface DocumentView

  • public interface DocumentView
    The DocumentView interface is implemented by Document objects in DOM implementations supporting DOM Views. It provides an attribute to retrieve the default view of a document.

    See also the Document Object Model (DOM) Level 2 Views Specification.

    Since:
    DOM Level 2

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      AbstractView getDefaultView()
      The default AbstractView for this Document, or null if none available.

    • Method Detail

      • getDefaultView

        AbstractView getDefaultView()
        The default AbstractView for this Document, or null if none available.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


org.w3c.dom.views (Java Platform SE 8 )

org.w3c.dom.views

Interfaces

  • AbstractView
  • DocumentView


org.w3c.dom.views (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.w3c.dom.views

  • Interface Summary
    Interface Description
    AbstractView
    A base interface that all views shall derive from.
    DocumentView
    The DocumentView interface is implemented by Document objects in DOM implementations supporting DOM Views.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames


org.w3c.dom.views Class Hierarchy (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.w3c.dom.views

Package Hierarchies:
  • All Packages

Interface Hierarchy

  • org.w3c.dom.views.AbstractView
  • org.w3c.dom.views.DocumentView
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package org.w3c.dom.views (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.w3c.dom.views

  • Packages that use org.w3c.dom.views
    Package Description
    org.w3c.dom.events
    org.w3c.dom.views
  • Classes in org.w3c.dom.views used by org.w3c.dom.events
    Class and Description
    AbstractView
    A base interface that all views shall derive from.
  • Classes in org.w3c.dom.views used by org.w3c.dom.views
    Class and Description
    AbstractView
    A base interface that all views shall derive from.
    DocumentView
    The DocumentView interface is implemented by Document objects in DOM implementations supporting DOM Views.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


AttributeList (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax

Interface AttributeList

  • All Known Implementing Classes:
    AttributeListImpl
    Deprecated.
    This interface has been replaced by the SAX2 Attributes interface, which includes Namespace support.

    public interface AttributeList
    Interface for an element's attribute specifications.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This is the original SAX1 interface for reporting an element's attributes. Unlike the new Attributes interface, it does not support Namespace-related information.

    When an attribute list is supplied as part of a startElement event, the list will return valid results only during the scope of the event; once the event handler returns control to the parser, the attribute list is invalid. To save a persistent copy of the attribute list, use the SAX1 AttributeListImpl helper class.

    An attribute list includes only attributes that have been specified or defaulted: #IMPLIED attributes will not be included.

    There are two ways for the SAX application to obtain information from the AttributeList. First, it can iterate through the entire list:

     public void startElement (String name, AttributeList atts) {
   for (int i = 0; i < atts.getLength(); i++) {
     String name = atts.getName(i);
     String type = atts.getType(i);
     String value = atts.getValue(i);
     [...]
   }
 }

    (Note that the result of getLength() will be zero if there are no attributes.)

    As an alternative, the application can request the value or type of specific attributes:

     public void startElement (String name, AttributeList atts) {
   String identifier = atts.getValue("id");
   String label = atts.getValue("label");
   [...]
 }
    Since:
    SAX 1.0
    See Also:
    startElement, AttributeListImpl

    • Method Summary

      All Methods Instance Methods Abstract Methods Deprecated Methods
      Modifier and Type Method and Description
      int getLength()
      Deprecated.
      Return the number of attributes in this list.
      String getName(int i)
      Deprecated.
      Return the name of an attribute in this list (by position).
      String getType(int i)
      Deprecated.
      Return the type of an attribute in the list (by position).
      String getType(String name)
      Deprecated.
      Return the type of an attribute in the list (by name).
      String getValue(int i)
      Deprecated.
      Return the value of an attribute in the list (by position).
      String getValue(String name)
      Deprecated.
      Return the value of an attribute in the list (by name).

    • Method Detail

      • getLength

        int getLength()
        Deprecated.
        Return the number of attributes in this list.

        The SAX parser may provide attributes in any arbitrary order, regardless of the order in which they were declared or specified. The number of attributes may be zero.

        Returns:
        The number of attributes in the list.

      • getName

        String getName(int i)
        Deprecated.
        Return the name of an attribute in this list (by position).

        The names must be unique: the SAX parser shall not include the same attribute twice. Attributes without values (those declared #IMPLIED without a value specified in the start tag) will be omitted from the list.

        If the attribute name has a namespace prefix, the prefix will still be attached.

        Parameters:
        i - The index of the attribute in the list (starting at 0).
        Returns:
        The name of the indexed attribute, or null if the index is out of range.
        See Also:
        getLength()

      • getType

        String getType(int i)
        Deprecated.
        Return the type of an attribute in the list (by position).

        The attribute type is one of the strings "CDATA", "ID", "IDREF", "IDREFS", "NMTOKEN", "NMTOKENS", "ENTITY", "ENTITIES", or "NOTATION" (always in upper case).

        If the parser has not read a declaration for the attribute, or if the parser does not report attribute types, then it must return the value "CDATA" as stated in the XML 1.0 Recommentation (clause 3.3.3, "Attribute-Value Normalization").

        For an enumerated attribute that is not a notation, the parser will report the type as "NMTOKEN".

        Parameters:
        i - The index of the attribute in the list (starting at 0).
        Returns:
        The attribute type as a string, or null if the index is out of range.
        See Also:
        getLength(), getType(java.lang.String)

      • getValue

        String getValue(int i)
        Deprecated.
        Return the value of an attribute in the list (by position).

        If the attribute value is a list of tokens (IDREFS, ENTITIES, or NMTOKENS), the tokens will be concatenated into a single string separated by whitespace.

        Parameters:
        i - The index of the attribute in the list (starting at 0).
        Returns:
        The attribute value as a string, or null if the index is out of range.
        See Also:
        getLength(), getValue(java.lang.String)

      • getType

        String getType(String name)
        Deprecated.
        Return the type of an attribute in the list (by name).

        The return value is the same as the return value for getType(int).

        If the attribute name has a namespace prefix in the document, the application must include the prefix here.

        Parameters:
        name - The name of the attribute.
        Returns:
        The attribute type as a string, or null if no such attribute exists.
        See Also:
        getType(int)

      • getValue

        String getValue(String name)
        Deprecated.
        Return the value of an attribute in the list (by name).

        The return value is the same as the return value for getValue(int).

        If the attribute name has a namespace prefix in the document, the application must include the prefix here.

        Parameters:
        name - the name of the attribute to return
        Returns:
        The attribute value as a string, or null if no such attribute exists.
        See Also:
        getValue(int)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Attributes (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax

Interface Attributes

  • All Known Subinterfaces:
    Attributes2
    All Known Implementing Classes:
    Attributes2Impl, AttributesImpl

    public interface Attributes
    Interface for a list of XML attributes.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This interface allows access to a list of attributes in three different ways:

    1. by attribute index;
    2. by Namespace-qualified name; or
    3. by qualified (prefixed) name.

    The list will not contain attributes that were declared #IMPLIED but not specified in the start tag. It will also not contain attributes used as Namespace declarations (xmlns*) unless the http://xml.org/sax/features/namespace-prefixes feature is set to true (it is false by default). Because SAX2 conforms to the original "Namespaces in XML" recommendation, it normally does not give namespace declaration attributes a namespace URI.

    Some SAX2 parsers may support using an optional feature flag (http://xml.org/sax/features/xmlns-uris) to request that those attributes be given URIs, conforming to a later backwards-incompatible revision of that recommendation. (The attribute's "local name" will be the prefix, or "xmlns" when defining a default element namespace.) For portability, handler code should always resolve that conflict, rather than requiring parsers that can change the setting of that feature flag.

    If the namespace-prefixes feature (see above) is false, access by qualified name may not be available; if the http://xml.org/sax/features/namespaces feature is false, access by Namespace-qualified names may not be available.

    This interface replaces the now-deprecated SAX1 AttributeList interface, which does not contain Namespace support. In addition to Namespace support, it adds the getIndex methods (below).

    The order of attributes in the list is unspecified, and will vary from implementation to implementation.

    Since:
    SAX 2.0
    See Also:
    AttributesImpl, DeclHandler.attributeDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String)

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      int getIndex(String qName)
      Look up the index of an attribute by XML qualified (prefixed) name.
      int getIndex(String uri, String localName)
      Look up the index of an attribute by Namespace name.
      int getLength()
      Return the number of attributes in the list.
      String getLocalName(int index)
      Look up an attribute's local name by index.
      String getQName(int index)
      Look up an attribute's XML qualified (prefixed) name by index.
      String getType(int index)
      Look up an attribute's type by index.
      String getType(String qName)
      Look up an attribute's type by XML qualified (prefixed) name.
      String getType(String uri, String localName)
      Look up an attribute's type by Namespace name.
      String getURI(int index)
      Look up an attribute's Namespace URI by index.
      String getValue(int index)
      Look up an attribute's value by index.
      String getValue(String qName)
      Look up an attribute's value by XML qualified (prefixed) name.
      String getValue(String uri, String localName)
      Look up an attribute's value by Namespace name.

    • Method Detail

      • getLength

        int getLength()
        Return the number of attributes in the list.

        Once you know the number of attributes, you can iterate through the list.

        Returns:
        The number of attributes in the list.
        See Also:
        getURI(int), getLocalName(int), getQName(int), getType(int), getValue(int)

      • getURI

        String getURI(int index)
        Look up an attribute's Namespace URI by index.
        Parameters:
        index - The attribute index (zero-based).
        Returns:
        The Namespace URI, or the empty string if none is available, or null if the index is out of range.
        See Also:
        getLength()

      • getLocalName

        String getLocalName(int index)
        Look up an attribute's local name by index.
        Parameters:
        index - The attribute index (zero-based).
        Returns:
        The local name, or the empty string if Namespace processing is not being performed, or null if the index is out of range.
        See Also:
        getLength()

      • getQName

        String getQName(int index)
        Look up an attribute's XML qualified (prefixed) name by index.
        Parameters:
        index - The attribute index (zero-based).
        Returns:
        The XML qualified name, or the empty string if none is available, or null if the index is out of range.
        See Also:
        getLength()

      • getType

        String getType(int index)
        Look up an attribute's type by index.

        The attribute type is one of the strings "CDATA", "ID", "IDREF", "IDREFS", "NMTOKEN", "NMTOKENS", "ENTITY", "ENTITIES", or "NOTATION" (always in upper case).

        If the parser has not read a declaration for the attribute, or if the parser does not report attribute types, then it must return the value "CDATA" as stated in the XML 1.0 Recommendation (clause 3.3.3, "Attribute-Value Normalization").

        For an enumerated attribute that is not a notation, the parser will report the type as "NMTOKEN".

        Parameters:
        index - The attribute index (zero-based).
        Returns:
        The attribute's type as a string, or null if the index is out of range.
        See Also:
        getLength()

      • getValue

        String getValue(int index)
        Look up an attribute's value by index.

        If the attribute value is a list of tokens (IDREFS, ENTITIES, or NMTOKENS), the tokens will be concatenated into a single string with each token separated by a single space.

        Parameters:
        index - The attribute index (zero-based).
        Returns:
        The attribute's value as a string, or null if the index is out of range.
        See Also:
        getLength()

      • getIndex

        int getIndex(String uri,
             String localName)
        Look up the index of an attribute by Namespace name.
        Parameters:
        uri - The Namespace URI, or the empty string if the name has no Namespace URI.
        localName - The attribute's local name.
        Returns:
        The index of the attribute, or -1 if it does not appear in the list.

      • getIndex

        int getIndex(String qName)
        Look up the index of an attribute by XML qualified (prefixed) name.
        Parameters:
        qName - The qualified (prefixed) name.
        Returns:
        The index of the attribute, or -1 if it does not appear in the list.

      • getType

        String getType(String uri,
               String localName)
        Look up an attribute's type by Namespace name.

        See getType(int) for a description of the possible types.

        Parameters:
        uri - The Namespace URI, or the empty String if the name has no Namespace URI.
        localName - The local name of the attribute.
        Returns:
        The attribute type as a string, or null if the attribute is not in the list or if Namespace processing is not being performed.

      • getType

        String getType(String qName)
        Look up an attribute's type by XML qualified (prefixed) name.

        See getType(int) for a description of the possible types.

        Parameters:
        qName - The XML qualified name.
        Returns:
        The attribute type as a string, or null if the attribute is not in the list or if qualified names are not available.

      • getValue

        String getValue(String uri,
                String localName)
        Look up an attribute's value by Namespace name.

        See getValue(int) for a description of the possible values.

        Parameters:
        uri - The Namespace URI, or the empty String if the name has no Namespace URI.
        localName - The local name of the attribute.
        Returns:
        The attribute value as a string, or null if the attribute is not in the list.

      • getValue

        String getValue(String qName)
        Look up an attribute's value by XML qualified (prefixed) name.

        See getValue(int) for a description of the possible values.

        Parameters:
        qName - The XML qualified name.
        Returns:
        The attribute value as a string, or null if the attribute is not in the list or if qualified names are not available.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Interface org.xml.sax.AttributeList (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.xml.sax.AttributeList

  • Packages that use AttributeList
    Package Description
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of AttributeList in org.xml.sax

      Methods in org.xml.sax with parameters of type AttributeList
      Modifier and Type Method and Description
      void HandlerBase.startElement(String name, AttributeList attributes)
      Deprecated.
      Receive notification of the start of an element.
      void DocumentHandler.startElement(String name, AttributeList atts)
      Deprecated.
      Receive notification of the beginning of an element.

    • Uses of AttributeList in org.xml.sax.helpers

      Classes in org.xml.sax.helpers that implement AttributeList
      Modifier and Type Class and Description
      class  AttributeListImpl
      Deprecated.
      This class implements a deprecated interface, AttributeList; that interface has been replaced by Attributes, which is implemented in the AttributesImpl helper class.
      Methods in org.xml.sax.helpers with parameters of type AttributeList
      Modifier and Type Method and Description
      void AttributeListImpl.setAttributeList(AttributeList atts)
      Deprecated.
      Set the attribute list, discarding previous contents.
      void ParserAdapter.startElement(String qName, AttributeList qAtts)
      Adapter implementation method; do not call.
      Constructors in org.xml.sax.helpers with parameters of type AttributeList
      Constructor and Description
      AttributeListImpl(AttributeList atts)
      Deprecated.
      Construct a persistent copy of an existing attribute list.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.xml.sax.Attributes (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.xml.sax.Attributes

  • Packages that use Attributes
    Package Description
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of Attributes in org.xml.sax

      Methods in org.xml.sax with parameters of type Attributes
      Modifier and Type Method and Description
      void ContentHandler.startElement(String uri, String localName, String qName, Attributes atts)
      Receive notification of the beginning of an element.

    • Uses of Attributes in org.xml.sax.ext

      Subinterfaces of Attributes in org.xml.sax.ext
      Modifier and Type Interface and Description
      interface  Attributes2
      SAX2 extension to augment the per-attribute information provided though Attributes.
      Classes in org.xml.sax.ext that implement Attributes
      Modifier and Type Class and Description
      class  Attributes2Impl
      SAX2 extension helper for additional Attributes information, implementing the Attributes2 interface.
      Methods in org.xml.sax.ext with parameters of type Attributes
      Modifier and Type Method and Description
      void Attributes2Impl.setAttributes(Attributes atts)
      Copy an entire Attributes object.
      Constructors in org.xml.sax.ext with parameters of type Attributes
      Constructor and Description
      Attributes2Impl(Attributes atts)
      Copy an existing Attributes or Attributes2 object.

    • Uses of Attributes in org.xml.sax.helpers

      Classes in org.xml.sax.helpers that implement Attributes
      Modifier and Type Class and Description
      class  AttributesImpl
      Default implementation of the Attributes interface.
      Methods in org.xml.sax.helpers with parameters of type Attributes
      Modifier and Type Method and Description
      void AttributesImpl.setAttributes(Attributes atts)
      Copy an entire Attributes object.
      void XMLFilterImpl.startElement(String uri, String localName, String qName, Attributes atts)
      Filter a start element event.
      void DefaultHandler.startElement(String uri, String localName, String qName, Attributes attributes)
      Receive notification of the start of an element.
      void XMLReaderAdapter.startElement(String uri, String localName, String qName, Attributes atts)
      Adapt a SAX2 start element event.
      Constructors in org.xml.sax.helpers with parameters of type Attributes
      Constructor and Description
      AttributesImpl(Attributes atts)
      Copy an existing Attributes object.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.xml.sax.ContentHandler (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.xml.sax.ContentHandler

  • Packages that use ContentHandler
    Package Description
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.
    javax.xml.validation
    This package provides an API for validation of XML documents.
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of ContentHandler in javax.xml.bind

      Subinterfaces of ContentHandler in javax.xml.bind
      Modifier and Type Interface and Description
      interface  UnmarshallerHandler
      Unmarshaller implemented as SAX ContentHandler.
      Methods in javax.xml.bind with parameters of type ContentHandler
      Modifier and Type Method and Description
      void Marshaller.marshal(Object jaxbElement, ContentHandler handler)
      Marshal the content tree rooted at jaxbElement into SAX2 events.

    • Uses of ContentHandler in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers with parameters of type ContentHandler
      Modifier and Type | Method and Description
      void | AbstractMarshallerImpl.marshal(Object obj, ContentHandler handler)

    • Uses of ContentHandler in javax.xml.transform.sax

      Subinterfaces of ContentHandler in javax.xml.transform.sax
      Modifier and Type Interface and Description
      interface  TemplatesHandler
      A SAX ContentHandler that may be used to process SAX parse events (parsing transformation instructions) into a Templates object.
      interface  TransformerHandler
      A TransformerHandler listens for SAX ContentHandler parse events and transforms them to a Result.
      Methods in javax.xml.transform.sax that return ContentHandler
      Modifier and Type Method and Description
      ContentHandler SAXResult.getHandler()
      Get the ContentHandler that is the Result.
      Methods in javax.xml.transform.sax with parameters of type ContentHandler
      Modifier and Type Method and Description
      void SAXResult.setHandler(ContentHandler handler)
      Set the target to be a SAX2 ContentHandler.
      Constructors in javax.xml.transform.sax with parameters of type ContentHandler
      Constructor and Description
      SAXResult(ContentHandler handler)
      Create a SAXResult that targets a SAX2 ContentHandler.

    • Uses of ContentHandler in javax.xml.validation

      Classes in javax.xml.validation that implement ContentHandler
      Modifier and Type Class and Description
      class  ValidatorHandler
      Streaming validator that works on SAX stream.
      Methods in javax.xml.validation that return ContentHandler
      Modifier and Type Method and Description
      abstract ContentHandler ValidatorHandler.getContentHandler()
      Gets the ContentHandler which receives the augmented validation result.
      Methods in javax.xml.validation with parameters of type ContentHandler
      Modifier and Type Method and Description
      abstract void ValidatorHandler.setContentHandler(ContentHandler receiver)
      Sets the ContentHandler which receives the augmented validation result.

    • Uses of ContentHandler in org.xml.sax

      Methods in org.xml.sax that return ContentHandler
      Modifier and Type Method and Description
      ContentHandler XMLReader.getContentHandler()
      Return the current content handler.
      Methods in org.xml.sax with parameters of type ContentHandler
      Modifier and Type Method and Description
      void XMLReader.setContentHandler(ContentHandler handler)
      Allow an application to register a content event handler.

    • Uses of ContentHandler in org.xml.sax.ext

      Classes in org.xml.sax.ext that implement ContentHandler
      Modifier and Type Class and Description
      class  DefaultHandler2
      This class extends the SAX2 base handler class to support the SAX2 LexicalHandler, DeclHandler, and EntityResolver2 extensions.

    • Uses of ContentHandler in org.xml.sax.helpers

      Classes in org.xml.sax.helpers that implement ContentHandler
      Modifier and Type Class and Description
      class  DefaultHandler
      Default base class for SAX2 event handlers.
      class  XMLFilterImpl
      Base class for deriving an XML filter.
      class  XMLReaderAdapter
      Adapt a SAX2 XMLReader as a SAX1 Parser.
      Methods in org.xml.sax.helpers that return ContentHandler
      Modifier and Type Method and Description
      ContentHandler ParserAdapter.getContentHandler()
      Return the current content handler.
      ContentHandler XMLFilterImpl.getContentHandler()
      Get the content event handler.
      Methods in org.xml.sax.helpers with parameters of type ContentHandler
      Modifier and Type Method and Description
      void ParserAdapter.setContentHandler(ContentHandler handler)
      Set the content handler.
      void XMLFilterImpl.setContentHandler(ContentHandler handler)
      Set the content event handler.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.xml.sax.DocumentHandler (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.xml.sax.DocumentHandler

  • Packages that use DocumentHandler
    Package Description
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of DocumentHandler in org.xml.sax

      Classes in org.xml.sax that implement DocumentHandler
      Modifier and Type Class and Description
      class  HandlerBase
      Deprecated.
      This class works with the deprecated DocumentHandler interface. It has been replaced by the SAX2 DefaultHandler class.
      Methods in org.xml.sax with parameters of type DocumentHandler
      Modifier and Type Method and Description
      void Parser.setDocumentHandler(DocumentHandler handler)
      Deprecated.
      Allow an application to register a document event handler.

    • Uses of DocumentHandler in org.xml.sax.helpers

      Classes in org.xml.sax.helpers that implement DocumentHandler
      Modifier and Type Class and Description
      class  ParserAdapter
      Adapt a SAX1 Parser as a SAX2 XMLReader.
      Methods in org.xml.sax.helpers with parameters of type DocumentHandler
      Modifier and Type Method and Description
      void XMLReaderAdapter.setDocumentHandler(DocumentHandler handler)
      Register the SAX1 document event handler.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.xml.sax.DTDHandler (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.xml.sax.DTDHandler

  • Packages that use DTDHandler
    Package Description
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of DTDHandler in javax.xml.transform.sax

      Subinterfaces of DTDHandler in javax.xml.transform.sax
      Modifier and Type Interface and Description
      interface  TransformerHandler
      A TransformerHandler listens for SAX ContentHandler parse events and transforms them to a Result.

    • Uses of DTDHandler in org.xml.sax

      Classes in org.xml.sax that implement DTDHandler
      Modifier and Type Class and Description
      class  HandlerBase
      Deprecated.
      This class works with the deprecated DocumentHandler interface. It has been replaced by the SAX2 DefaultHandler class.
      Methods in org.xml.sax that return DTDHandler
      Modifier and Type Method and Description
      DTDHandler XMLReader.getDTDHandler()
      Return the current DTD handler.
      Methods in org.xml.sax with parameters of type DTDHandler
      Modifier and Type Method and Description
      void XMLReader.setDTDHandler(DTDHandler handler)
      Allow an application to register a DTD event handler.
      void Parser.setDTDHandler(DTDHandler handler)
      Deprecated.
      Allow an application to register a DTD event handler.

    • Uses of DTDHandler in org.xml.sax.ext

      Classes in org.xml.sax.ext that implement DTDHandler
      Modifier and Type Class and Description
      class  DefaultHandler2
      This class extends the SAX2 base handler class to support the SAX2 LexicalHandler, DeclHandler, and EntityResolver2 extensions.

    • Uses of DTDHandler in org.xml.sax.helpers

      Classes in org.xml.sax.helpers that implement DTDHandler
      Modifier and Type Class and Description
      class  DefaultHandler
      Default base class for SAX2 event handlers.
      class  XMLFilterImpl
      Base class for deriving an XML filter.
      Methods in org.xml.sax.helpers that return DTDHandler
      Modifier and Type Method and Description
      DTDHandler ParserAdapter.getDTDHandler()
      Return the current DTD handler.
      DTDHandler XMLFilterImpl.getDTDHandler()
      Get the current DTD event handler.
      Methods in org.xml.sax.helpers with parameters of type DTDHandler
      Modifier and Type Method and Description
      void ParserAdapter.setDTDHandler(DTDHandler handler)
      Set the DTD handler.
      void XMLFilterImpl.setDTDHandler(DTDHandler handler)
      Set the DTD event handler.
      void XMLReaderAdapter.setDTDHandler(DTDHandler handler)
      Register the DTD event handler.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.xml.sax.EntityResolver (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.xml.sax.EntityResolver

  • Packages that use EntityResolver
    Package Description
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of EntityResolver in javax.xml.parsers

      Methods in javax.xml.parsers with parameters of type EntityResolver
      Modifier and Type Method and Description
      abstract void DocumentBuilder.setEntityResolver(EntityResolver er)
      Specify the EntityResolver to be used to resolve entities present in the XML document to be parsed.

    • Uses of EntityResolver in org.xml.sax

      Classes in org.xml.sax that implement EntityResolver
      Modifier and Type Class and Description
      class  HandlerBase
      Deprecated.
      This class works with the deprecated DocumentHandler interface. It has been replaced by the SAX2 DefaultHandler class.
      Methods in org.xml.sax that return EntityResolver
      Modifier and Type Method and Description
      EntityResolver XMLReader.getEntityResolver()
      Return the current entity resolver.
      Methods in org.xml.sax with parameters of type EntityResolver
      Modifier and Type Method and Description
      void XMLReader.setEntityResolver(EntityResolver resolver)
      Allow an application to register an entity resolver.
      void Parser.setEntityResolver(EntityResolver resolver)
      Deprecated.
      Allow an application to register a custom entity resolver.

    • Uses of EntityResolver in org.xml.sax.ext

      Subinterfaces of EntityResolver in org.xml.sax.ext
      Modifier and Type Interface and Description
      interface  EntityResolver2
      Extended interface for mapping external entity references to input sources, or providing a missing external subset.
      Classes in org.xml.sax.ext that implement EntityResolver
      Modifier and Type Class and Description
      class  DefaultHandler2
      This class extends the SAX2 base handler class to support the SAX2 LexicalHandler, DeclHandler, and EntityResolver2 extensions.

    • Uses of EntityResolver in org.xml.sax.helpers

      Classes in org.xml.sax.helpers that implement EntityResolver
      Modifier and Type Class and Description
      class  DefaultHandler
      Default base class for SAX2 event handlers.
      class  XMLFilterImpl
      Base class for deriving an XML filter.
      Methods in org.xml.sax.helpers that return EntityResolver
      Modifier and Type Method and Description
      EntityResolver ParserAdapter.getEntityResolver()
      Return the current entity resolver.
      EntityResolver XMLFilterImpl.getEntityResolver()
      Get the current entity resolver.
      Methods in org.xml.sax.helpers with parameters of type EntityResolver
      Modifier and Type Method and Description
      void ParserAdapter.setEntityResolver(EntityResolver resolver)
      Set the entity resolver.
      void XMLFilterImpl.setEntityResolver(EntityResolver resolver)
      Set the entity resolver.
      void XMLReaderAdapter.setEntityResolver(EntityResolver resolver)
      Register the entity resolver.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.xml.sax.ErrorHandler (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.xml.sax.ErrorHandler

  • Packages that use ErrorHandler
    Package Description
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    javax.xml.validation
    This package provides an API for validation of XML documents.
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of ErrorHandler in javax.xml.parsers

      Methods in javax.xml.parsers with parameters of type ErrorHandler
      Modifier and Type Method and Description
      abstract void DocumentBuilder.setErrorHandler(ErrorHandler eh)
      Specify the ErrorHandler to be used by the parser.

    • Uses of ErrorHandler in javax.xml.validation

      Methods in javax.xml.validation that return ErrorHandler
      Modifier and Type Method and Description
      abstract ErrorHandler ValidatorHandler.getErrorHandler()
      Gets the current ErrorHandler set to this ValidatorHandler.
      abstract ErrorHandler Validator.getErrorHandler()
      Gets the current ErrorHandler set to this Validator.
      abstract ErrorHandler SchemaFactory.getErrorHandler()
      Gets the current ErrorHandler set to this SchemaFactory.
      Methods in javax.xml.validation with parameters of type ErrorHandler
      Modifier and Type Method and Description
      abstract void ValidatorHandler.setErrorHandler(ErrorHandler errorHandler)
      Sets the ErrorHandler to receive errors encountered during the validation.
      abstract void Validator.setErrorHandler(ErrorHandler errorHandler)
      Sets the ErrorHandler to receive errors encountered during the validate method invocation.
      abstract void SchemaFactory.setErrorHandler(ErrorHandler errorHandler)
      Sets the ErrorHandler to receive errors encountered during the newSchema method invocation.

    • Uses of ErrorHandler in org.xml.sax

      Classes in org.xml.sax that implement ErrorHandler
      Modifier and Type Class and Description
      class  HandlerBase
      Deprecated.
      This class works with the deprecated DocumentHandler interface. It has been replaced by the SAX2 DefaultHandler class.
      Methods in org.xml.sax that return ErrorHandler
      Modifier and Type Method and Description
      ErrorHandler XMLReader.getErrorHandler()
      Return the current error handler.
      Methods in org.xml.sax with parameters of type ErrorHandler
      Modifier and Type Method and Description
      void XMLReader.setErrorHandler(ErrorHandler handler)
      Allow an application to register an error event handler.
      void Parser.setErrorHandler(ErrorHandler handler)
      Deprecated.
      Allow an application to register an error event handler.

    • Uses of ErrorHandler in org.xml.sax.ext

      Classes in org.xml.sax.ext that implement ErrorHandler
      Modifier and Type Class and Description
      class  DefaultHandler2
      This class extends the SAX2 base handler class to support the SAX2 LexicalHandler, DeclHandler, and EntityResolver2 extensions.

    • Uses of ErrorHandler in org.xml.sax.helpers

      Classes in org.xml.sax.helpers that implement ErrorHandler
      Modifier and Type Class and Description
      class  DefaultHandler
      Default base class for SAX2 event handlers.
      class  XMLFilterImpl
      Base class for deriving an XML filter.
      Methods in org.xml.sax.helpers that return ErrorHandler
      Modifier and Type Method and Description
      ErrorHandler ParserAdapter.getErrorHandler()
      Return the current error handler.
      ErrorHandler XMLFilterImpl.getErrorHandler()
      Get the current error event handler.
      Methods in org.xml.sax.helpers with parameters of type ErrorHandler
      Modifier and Type Method and Description
      void ParserAdapter.setErrorHandler(ErrorHandler handler)
      Set the error handler.
      void XMLFilterImpl.setErrorHandler(ErrorHandler handler)
      Set the error event handler.
      void XMLReaderAdapter.setErrorHandler(ErrorHandler handler)
      Register the error event handler.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.xml.sax.HandlerBase (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.xml.sax.HandlerBase

  • Packages that use HandlerBase
    Package Description
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.

    • Uses of HandlerBase in javax.xml.parsers

      Methods in javax.xml.parsers with parameters of type HandlerBase
      Modifier and Type Method and Description
      void SAXParser.parse(File f, HandlerBase hb)
      Parse the content of the file specified as XML using the specified HandlerBase.
      void SAXParser.parse(InputSource is, HandlerBase hb)
      Parse the content given InputSource as XML using the specified HandlerBase.
      void SAXParser.parse(InputStream is, HandlerBase hb)
      Parse the content of the given InputStream instance as XML using the specified HandlerBase.
      void SAXParser.parse(InputStream is, HandlerBase hb, String systemId)
      Parse the content of the given InputStream instance as XML using the specified HandlerBase.
      void SAXParser.parse(String uri, HandlerBase hb)
      Parse the content described by the giving Uniform Resource Identifier (URI) as XML using the specified HandlerBase.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.xml.sax.InputSource (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.xml.sax.InputSource

  • Packages that use InputSource
    Package Description
    java.beans
    Contains classes related to developing beans -- components based on the JavaBeans™ architecture.
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.
    javax.xml.xpath
    This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of InputSource in java.beans

      Constructors in java.beans with parameters of type InputSource
      Constructor and Description
      XMLDecoder(InputSource is)
      Creates a new decoder to parse XML archives created by the XMLEncoder class.

    • Uses of InputSource in javax.xml.bind

      Methods in javax.xml.bind with parameters of type InputSource
      Modifier and Type Method and Description
      Object Unmarshaller.unmarshal(InputSource source)
      Unmarshal XML data from the specified SAX InputSource and return the resulting content tree.

    • Uses of InputSource in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers with parameters of type InputSource
      Modifier and Type | Method and Description
      Object | AbstractUnmarshallerImpl.unmarshal(InputSource source)
      protected abstract Object AbstractUnmarshallerImpl.unmarshal(XMLReader reader, InputSource source)
      Unmarshals an object by using the specified XMLReader and the InputSource.

    • Uses of InputSource in javax.xml.parsers

      Methods in javax.xml.parsers with parameters of type InputSource
      Modifier and Type Method and Description
      abstract Document DocumentBuilder.parse(InputSource is)
      Parse the content of the given input source as an XML document and return a new DOM Document object.
      void SAXParser.parse(InputSource is, DefaultHandler dh)
      Parse the content given InputSource as XML using the specified DefaultHandler.
      void SAXParser.parse(InputSource is, HandlerBase hb)
      Parse the content given InputSource as XML using the specified HandlerBase.

    • Uses of InputSource in javax.xml.transform.sax

      Methods in javax.xml.transform.sax that return InputSource
      Modifier and Type Method and Description
      InputSource SAXSource.getInputSource()
      Get the SAX InputSource to be used for the Source.
      static InputSource SAXSource.sourceToInputSource(Source source)
      Attempt to obtain a SAX InputSource object from a Source object.
      Methods in javax.xml.transform.sax with parameters of type InputSource
      Modifier and Type Method and Description
      void SAXSource.setInputSource(InputSource inputSource)
      Set the SAX InputSource to be used for the Source.
      Constructors in javax.xml.transform.sax with parameters of type InputSource
      Constructor and Description
      SAXSource(InputSource inputSource)
      Create a SAXSource, using a SAX InputSource.
      SAXSource(XMLReader reader, InputSource inputSource)
      Create a SAXSource, using an XMLReader and a SAX InputSource.

    • Uses of InputSource in javax.xml.xpath

      Methods in javax.xml.xpath with parameters of type InputSource
      Modifier and Type Method and Description
      String XPathExpression.evaluate(InputSource source)
      Evaluate the compiled XPath expression in the context of the specified InputSource and return the result as a String.
      Object XPathExpression.evaluate(InputSource source, QName returnType)
      Evaluate the compiled XPath expression in the context of the specified InputSource and return the result as the specified type.
      String XPath.evaluate(String expression, InputSource source)
      Evaluate an XPath expression in the context of the specified InputSource and return the result as a String.
      Object XPath.evaluate(String expression, InputSource source, QName returnType)
      Evaluate an XPath expression in the context of the specified InputSource and return the result as the specified type.

    • Uses of InputSource in org.xml.sax

      Methods in org.xml.sax that return InputSource
      Modifier and Type Method and Description
      InputSource HandlerBase.resolveEntity(String publicId, String systemId)
      Deprecated.
      Resolve an external entity.
      InputSource EntityResolver.resolveEntity(String publicId, String systemId)
      Allow the application to resolve external entities.
      Methods in org.xml.sax with parameters of type InputSource
      Modifier and Type Method and Description
      void XMLReader.parse(InputSource input)
      Parse an XML document.
      void Parser.parse(InputSource source)
      Deprecated.
      Parse an XML document.

    • Uses of InputSource in org.xml.sax.ext

      Methods in org.xml.sax.ext that return InputSource
      Modifier and Type Method and Description
      InputSource DefaultHandler2.getExternalSubset(String name, String baseURI)
      Tells the parser that if no external subset has been declared in the document text, none should be used.
      InputSource EntityResolver2.getExternalSubset(String name, String baseURI)
      Allows applications to provide an external subset for documents that don't explicitly define one.
      InputSource DefaultHandler2.resolveEntity(String publicId, String systemId)
      Invokes EntityResolver2.resolveEntity() with null entity name and base URI.
      InputSource DefaultHandler2.resolveEntity(String name, String publicId, String baseURI, String systemId)
      Tells the parser to resolve the systemId against the baseURI and read the entity text from that resulting absolute URI.
      InputSource EntityResolver2.resolveEntity(String name, String publicId, String baseURI, String systemId)
      Allows applications to map references to external entities into input sources, or tell the parser it should use conventional URI resolution.

    • Uses of InputSource in org.xml.sax.helpers

      Methods in org.xml.sax.helpers that return InputSource
      Modifier and Type Method and Description
      InputSource XMLFilterImpl.resolveEntity(String publicId, String systemId)
      Filter an external entity resolution.
      InputSource DefaultHandler.resolveEntity(String publicId, String systemId)
      Resolve an external entity.
      Methods in org.xml.sax.helpers with parameters of type InputSource
      Modifier and Type Method and Description
      void ParserAdapter.parse(InputSource input)
      Parse an XML document.
      void XMLFilterImpl.parse(InputSource input)
      Parse a document.
      void XMLReaderAdapter.parse(InputSource input)
      Parse the document.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.xml.sax.Locator (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.xml.sax.Locator

  • Packages that use Locator
    Package Description
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of Locator in javax.xml.bind.helpers

      Constructors in javax.xml.bind.helpers with parameters of type Locator
      Constructor and Description
      ValidationEventLocatorImpl(Locator loc)
      Constructs an object from an org.xml.sax.Locator.

    • Uses of Locator in org.xml.sax

      Methods in org.xml.sax with parameters of type Locator
      Modifier and Type Method and Description
      void HandlerBase.setDocumentLocator(Locator locator)
      Deprecated.
      Receive a Locator object for document events.
      void ContentHandler.setDocumentLocator(Locator locator)
      Receive an object for locating the origin of SAX document events.
      void DocumentHandler.setDocumentLocator(Locator locator)
      Deprecated.
      Receive an object for locating the origin of SAX document events.
      Constructors in org.xml.sax with parameters of type Locator
      Constructor and Description
      SAXParseException(String message, Locator locator)
      Create a new SAXParseException from a message and a Locator.
      SAXParseException(String message, Locator locator, Exception e)
      Wrap an existing exception in a SAXParseException.

    • Uses of Locator in org.xml.sax.ext

      Subinterfaces of Locator in org.xml.sax.ext
      Modifier and Type Interface and Description
      interface  Locator2
      SAX2 extension to augment the entity information provided though a Locator.
      Classes in org.xml.sax.ext that implement Locator
      Modifier and Type Class and Description
      class  Locator2Impl
      SAX2 extension helper for holding additional Entity information, implementing the Locator2 interface.
      Constructors in org.xml.sax.ext with parameters of type Locator
      Constructor and Description
      Locator2Impl(Locator locator)
      Copy an existing Locator or Locator2 object.

    • Uses of Locator in org.xml.sax.helpers

      Classes in org.xml.sax.helpers that implement Locator
      Modifier and Type Class and Description
      class  LocatorImpl
      Provide an optional convenience implementation of Locator.
      Methods in org.xml.sax.helpers with parameters of type Locator
      Modifier and Type Method and Description
      void ParserAdapter.setDocumentLocator(Locator locator)
      Adapter implementation method; do not call.
      void XMLFilterImpl.setDocumentLocator(Locator locator)
      Filter a new document locator event.
      void DefaultHandler.setDocumentLocator(Locator locator)
      Receive a Locator object for document events.
      void XMLReaderAdapter.setDocumentLocator(Locator locator)
      Set a document locator.
      Constructors in org.xml.sax.helpers with parameters of type Locator
      Constructor and Description
      LocatorImpl(Locator locator)
      Copy constructor.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.xml.sax.Parser (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.xml.sax.Parser

  • Packages that use Parser
    Package Description
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of Parser in javax.xml.parsers

      Methods in javax.xml.parsers that return Parser
      Modifier and Type Method and Description
      abstract Parser SAXParser.getParser()
      Returns the SAX parser that is encapsultated by the implementation of this class.

    • Uses of Parser in org.xml.sax.helpers

      Classes in org.xml.sax.helpers that implement Parser
      Modifier and Type Class and Description
      class  XMLReaderAdapter
      Adapt a SAX2 XMLReader as a SAX1 Parser.
      Methods in org.xml.sax.helpers that return Parser
      Modifier and Type Method and Description
      static Parser ParserFactory.makeParser()
      Deprecated.
      Create a new SAX parser using the `org.xml.sax.parser' system property.
      static Parser ParserFactory.makeParser(String className)
      Deprecated.
      Create a new SAX parser object using the class name provided.
      Constructors in org.xml.sax.helpers with parameters of type Parser
      Constructor and Description
      ParserAdapter(Parser parser)
      Construct a new parser adapter.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.xml.sax.SAXException (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.xml.sax.SAXException

  • Packages that use SAXException
    Package Description
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    javax.xml.validation
    This package provides an API for validation of XML documents.
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of SAXException in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers with parameters of type SAXException
      Modifier and Type Method and Description
      protected UnmarshalException AbstractUnmarshallerImpl.createUnmarshalException(SAXException e)
      Creates an UnmarshalException from a SAXException.

    • Uses of SAXException in javax.xml.parsers

      Methods in javax.xml.parsers that throw SAXException
      Modifier and Type Method and Description
      abstract Parser SAXParser.getParser()
      Returns the SAX parser that is encapsultated by the implementation of this class.
      abstract XMLReader SAXParser.getXMLReader()
      Returns the XMLReader that is encapsulated by the implementation of this class.
      abstract SAXParser SAXParserFactory.newSAXParser()
      Creates a new instance of a SAXParser using the currently configured factory parameters.
      Document DocumentBuilder.parse(File f)
      Parse the content of the given file as an XML document and return a new DOM Document object.
      void SAXParser.parse(File f, DefaultHandler dh)
      Parse the content of the file specified as XML using the specified DefaultHandler.
      void SAXParser.parse(File f, HandlerBase hb)
      Parse the content of the file specified as XML using the specified HandlerBase.
      abstract Document DocumentBuilder.parse(InputSource is)
      Parse the content of the given input source as an XML document and return a new DOM Document object.
      void SAXParser.parse(InputSource is, DefaultHandler dh)
      Parse the content given InputSource as XML using the specified DefaultHandler.
      void SAXParser.parse(InputSource is, HandlerBase hb)
      Parse the content given InputSource as XML using the specified HandlerBase.
      Document DocumentBuilder.parse(InputStream is)
      Parse the content of the given InputStream as an XML document and return a new DOM Document object.
      void SAXParser.parse(InputStream is, DefaultHandler dh)
      Parse the content of the given InputStream instance as XML using the specified DefaultHandler.
      void SAXParser.parse(InputStream is, DefaultHandler dh, String systemId)
      Parse the content of the given InputStream instance as XML using the specified DefaultHandler.
      void SAXParser.parse(InputStream is, HandlerBase hb)
      Parse the content of the given InputStream instance as XML using the specified HandlerBase.
      void SAXParser.parse(InputStream is, HandlerBase hb, String systemId)
      Parse the content of the given InputStream instance as XML using the specified HandlerBase.
      Document DocumentBuilder.parse(InputStream is, String systemId)
      Parse the content of the given InputStream as an XML document and return a new DOM Document object.
      Document DocumentBuilder.parse(String uri)
      Parse the content of the given URI as an XML document and return a new DOM Document object.
      void SAXParser.parse(String uri, DefaultHandler dh)
      Parse the content described by the giving Uniform Resource Identifier (URI) as XML using the specified DefaultHandler.
      void SAXParser.parse(String uri, HandlerBase hb)
      Parse the content described by the giving Uniform Resource Identifier (URI) as XML using the specified HandlerBase.

    • Uses of SAXException in javax.xml.validation

      Methods in javax.xml.validation that throw SAXException
      Modifier and Type Method and Description
      abstract Schema SchemaFactory.newSchema()
      Creates a special Schema object.
      Schema SchemaFactory.newSchema(File schema)
      Parses the specified File as a schema and returns it as a Schema.
      Schema SchemaFactory.newSchema(Source schema)
      Parses the specified source as a schema and returns it as a schema.
      abstract Schema SchemaFactory.newSchema(Source[] schemas)
      Parses the specified source(s) as a schema and returns it as a schema.
      Schema SchemaFactory.newSchema(URL schema)
      Parses the specified URL as a schema and returns it as a Schema.
      void Validator.validate(Source source)
      Validates the specified input.
      abstract void Validator.validate(Source source, Result result)
      Validates the specified input and send the augmented validation result to the specified output.

    • Uses of SAXException in org.xml.sax

      Subclasses of SAXException in org.xml.sax
      Modifier and Type Class and Description
      class  SAXNotRecognizedException
      Exception class for an unrecognized identifier.
      class  SAXNotSupportedException
      Exception class for an unsupported operation.
      class  SAXParseException
      Encapsulate an XML parse error or warning.
      Methods in org.xml.sax that throw SAXException
      Modifier and Type Method and Description
      void HandlerBase.characters(char[] ch, int start, int length)
      Deprecated.
      Receive notification of character data inside an element.
      void ContentHandler.characters(char[] ch, int start, int length)
      Receive notification of character data.
      void DocumentHandler.characters(char[] ch, int start, int length)
      Deprecated.
      Receive notification of character data.
      void HandlerBase.endDocument()
      Deprecated.
      Receive notification of the end of the document.
      void ContentHandler.endDocument()
      Receive notification of the end of a document.
      void DocumentHandler.endDocument()
      Deprecated.
      Receive notification of the end of a document.
      void HandlerBase.endElement(String name)
      Deprecated.
      Receive notification of the end of an element.
      void DocumentHandler.endElement(String name)
      Deprecated.
      Receive notification of the end of an element.
      void ContentHandler.endElement(String uri, String localName, String qName)
      Receive notification of the end of an element.
      void ContentHandler.endPrefixMapping(String prefix)
      End the scope of a prefix-URI mapping.
      void HandlerBase.error(SAXParseException e)
      Deprecated.
      Receive notification of a recoverable parser error.
      void ErrorHandler.error(SAXParseException exception)
      Receive notification of a recoverable error.
      void HandlerBase.fatalError(SAXParseException e)
      Deprecated.
      Report a fatal XML parsing error.
      void ErrorHandler.fatalError(SAXParseException exception)
      Receive notification of a non-recoverable error.
      void HandlerBase.ignorableWhitespace(char[] ch, int start, int length)
      Deprecated.
      Receive notification of ignorable whitespace in element content.
      void ContentHandler.ignorableWhitespace(char[] ch, int start, int length)
      Receive notification of ignorable whitespace in element content.
      void DocumentHandler.ignorableWhitespace(char[] ch, int start, int length)
      Deprecated.
      Receive notification of ignorable whitespace in element content.
      void DTDHandler.notationDecl(String name, String publicId, String systemId)
      Receive notification of a notation declaration event.
      void XMLReader.parse(InputSource input)
      Parse an XML document.
      void Parser.parse(InputSource source)
      Deprecated.
      Parse an XML document.
      void XMLReader.parse(String systemId)
      Parse an XML document from a system identifier (URI).
      void Parser.parse(String systemId)
      Deprecated.
      Parse an XML document from a system identifier (URI).
      void HandlerBase.processingInstruction(String target, String data)
      Deprecated.
      Receive notification of a processing instruction.
      void ContentHandler.processingInstruction(String target, String data)
      Receive notification of a processing instruction.
      void DocumentHandler.processingInstruction(String target, String data)
      Deprecated.
      Receive notification of a processing instruction.
      InputSource HandlerBase.resolveEntity(String publicId, String systemId)
      Deprecated.
      Resolve an external entity.
      InputSource EntityResolver.resolveEntity(String publicId, String systemId)
      Allow the application to resolve external entities.
      void Parser.setLocale(Locale locale)
      Deprecated.
      Allow an application to request a locale for errors and warnings.
      void ContentHandler.skippedEntity(String name)
      Receive notification of a skipped entity.
      void HandlerBase.startDocument()
      Deprecated.
      Receive notification of the beginning of the document.
      void ContentHandler.startDocument()
      Receive notification of the beginning of a document.
      void DocumentHandler.startDocument()
      Deprecated.
      Receive notification of the beginning of a document.
      void HandlerBase.startElement(String name, AttributeList attributes)
      Deprecated.
      Receive notification of the start of an element.
      void DocumentHandler.startElement(String name, AttributeList atts)
      Deprecated.
      Receive notification of the beginning of an element.
      void ContentHandler.startElement(String uri, String localName, String qName, Attributes atts)
      Receive notification of the beginning of an element.
      void ContentHandler.startPrefixMapping(String prefix, String uri)
      Begin the scope of a prefix-URI Namespace mapping.
      void DTDHandler.unparsedEntityDecl(String name, String publicId, String systemId, String notationName)
      Receive notification of an unparsed entity declaration event.
      void HandlerBase.warning(SAXParseException e)
      Deprecated.
      Receive notification of a parser warning.
      void ErrorHandler.warning(SAXParseException exception)
      Receive notification of a warning.

    • Uses of SAXException in org.xml.sax.ext

      Methods in org.xml.sax.ext that throw SAXException
      Modifier and Type | Method and Description
      void DeclHandler.attributeDecl(String eName, String aName, String type, String mode, String value)
      Report an attribute type declaration.
      void | DefaultHandler2.attributeDecl(String eName, String aName, String type, String mode, String value)
      void | DefaultHandler2.comment(char[] ch, int start, int length)
      void LexicalHandler.comment(char[] ch, int start, int length)
      Report an XML comment anywhere in the document.
      void DeclHandler.elementDecl(String name, String model)
      Report an element type declaration.
      void | DefaultHandler2.elementDecl(String name, String model)
      void | DefaultHandler2.endCDATA()
      void LexicalHandler.endCDATA()
      Report the end of a CDATA section.
      void | DefaultHandler2.endDTD()
      void LexicalHandler.endDTD()
      Report the end of DTD declarations.
      void | DefaultHandler2.endEntity(String name)
      void LexicalHandler.endEntity(String name)
      Report the end of an entity.
      void DeclHandler.externalEntityDecl(String name, String publicId, String systemId)
      Report a parsed external entity declaration.
      void | DefaultHandler2.externalEntityDecl(String name, String publicId, String systemId)
      InputSource DefaultHandler2.getExternalSubset(String name, String baseURI)
      Tells the parser that if no external subset has been declared in the document text, none should be used.
      InputSource EntityResolver2.getExternalSubset(String name, String baseURI)
      Allows applications to provide an external subset for documents that don't explicitly define one.
      void DeclHandler.internalEntityDecl(String name, String value)
      Report an internal entity declaration.
      void | DefaultHandler2.internalEntityDecl(String name, String value)
      InputSource DefaultHandler2.resolveEntity(String publicId, String systemId)
      Invokes EntityResolver2.resolveEntity() with null entity name and base URI.
      InputSource DefaultHandler2.resolveEntity(String name, String publicId, String baseURI, String systemId)
      Tells the parser to resolve the systemId against the baseURI and read the entity text from that resulting absolute URI.
      InputSource EntityResolver2.resolveEntity(String name, String publicId, String baseURI, String systemId)
      Allows applications to map references to external entities into input sources, or tell the parser it should use conventional URI resolution.
      void | DefaultHandler2.startCDATA()
      void LexicalHandler.startCDATA()
      Report the start of a CDATA section.
      void | DefaultHandler2.startDTD(String name, String publicId, String systemId)
      void LexicalHandler.startDTD(String name, String publicId, String systemId)
      Report the start of DTD declarations, if any.
      void | DefaultHandler2.startEntity(String name)
      void LexicalHandler.startEntity(String name)
      Report the beginning of some internal and external XML entities.

    • Uses of SAXException in org.xml.sax.helpers

      Methods in org.xml.sax.helpers that throw SAXException
      Modifier and Type Method and Description
      void ParserAdapter.characters(char[] ch, int start, int length)
      Adapter implementation method; do not call.
      void XMLFilterImpl.characters(char[] ch, int start, int length)
      Filter a character data event.
      void DefaultHandler.characters(char[] ch, int start, int length)
      Receive notification of character data inside an element.
      void XMLReaderAdapter.characters(char[] ch, int start, int length)
      Adapt a SAX2 characters event.
      static XMLReader XMLReaderFactory.createXMLReader()
      Attempt to create an XMLReader from system defaults.
      static XMLReader XMLReaderFactory.createXMLReader(String className)
      Attempt to create an XML reader from a class name.
      void ParserAdapter.endDocument()
      Adapter implementation method; do not call.
      void XMLFilterImpl.endDocument()
      Filter an end document event.
      void DefaultHandler.endDocument()
      Receive notification of the end of the document.
      void XMLReaderAdapter.endDocument()
      End document event.
      void ParserAdapter.endElement(String qName)
      Adapter implementation method; do not call.
      void XMLFilterImpl.endElement(String uri, String localName, String qName)
      Filter an end element event.
      void DefaultHandler.endElement(String uri, String localName, String qName)
      Receive notification of the end of an element.
      void XMLReaderAdapter.endElement(String uri, String localName, String qName)
      Adapt a SAX2 end element event.
      void XMLFilterImpl.endPrefixMapping(String prefix)
      Filter an end Namespace prefix mapping event.
      void DefaultHandler.endPrefixMapping(String prefix)
      Receive notification of the end of a Namespace mapping.
      void XMLFilterImpl.error(SAXParseException e)
      Filter an error event.
      void DefaultHandler.error(SAXParseException e)
      Receive notification of a recoverable parser error.
      void XMLFilterImpl.fatalError(SAXParseException e)
      Filter a fatal error event.
      void DefaultHandler.fatalError(SAXParseException e)
      Report a fatal XML parsing error.
      void ParserAdapter.ignorableWhitespace(char[] ch, int start, int length)
      Adapter implementation method; do not call.
      void XMLFilterImpl.ignorableWhitespace(char[] ch, int start, int length)
      Filter an ignorable whitespace event.
      void DefaultHandler.ignorableWhitespace(char[] ch, int start, int length)
      Receive notification of ignorable whitespace in element content.
      void XMLReaderAdapter.ignorableWhitespace(char[] ch, int start, int length)
      Adapt a SAX2 ignorable whitespace event.
      void XMLFilterImpl.notationDecl(String name, String publicId, String systemId)
      Filter a notation declaration event.
      void DefaultHandler.notationDecl(String name, String publicId, String systemId)
      Receive notification of a notation declaration.
      void ParserAdapter.parse(InputSource input)
      Parse an XML document.
      void XMLFilterImpl.parse(InputSource input)
      Parse a document.
      void XMLReaderAdapter.parse(InputSource input)
      Parse the document.
      void ParserAdapter.parse(String systemId)
      Parse an XML document.
      void XMLFilterImpl.parse(String systemId)
      Parse a document.
      void XMLReaderAdapter.parse(String systemId)
      Parse the document.
      void ParserAdapter.processingInstruction(String target, String data)
      Adapter implementation method; do not call.
      void XMLFilterImpl.processingInstruction(String target, String data)
      Filter a processing instruction event.
      void DefaultHandler.processingInstruction(String target, String data)
      Receive notification of a processing instruction.
      void XMLReaderAdapter.processingInstruction(String target, String data)
      Adapt a SAX2 processing instruction event.
      InputSource XMLFilterImpl.resolveEntity(String publicId, String systemId)
      Filter an external entity resolution.
      InputSource DefaultHandler.resolveEntity(String publicId, String systemId)
      Resolve an external entity.
      void XMLReaderAdapter.setLocale(Locale locale)
      Set the locale for error reporting.
      void XMLFilterImpl.skippedEntity(String name)
      Filter a skipped entity event.
      void DefaultHandler.skippedEntity(String name)
      Receive notification of a skipped entity.
      void XMLReaderAdapter.skippedEntity(String name)
      Adapt a SAX2 skipped entity event.
      void ParserAdapter.startDocument()
      Adapter implementation method; do not call.
      void XMLFilterImpl.startDocument()
      Filter a start document event.
      void DefaultHandler.startDocument()
      Receive notification of the beginning of the document.
      void XMLReaderAdapter.startDocument()
      Start document event.
      void ParserAdapter.startElement(String qName, AttributeList qAtts)
      Adapter implementation method; do not call.
      void XMLFilterImpl.startElement(String uri, String localName, String qName, Attributes atts)
      Filter a start element event.
      void DefaultHandler.startElement(String uri, String localName, String qName, Attributes attributes)
      Receive notification of the start of an element.
      void XMLReaderAdapter.startElement(String uri, String localName, String qName, Attributes atts)
      Adapt a SAX2 start element event.
      void XMLFilterImpl.startPrefixMapping(String prefix, String uri)
      Filter a start Namespace prefix mapping event.
      void DefaultHandler.startPrefixMapping(String prefix, String uri)
      Receive notification of the start of a Namespace mapping.
      void XMLFilterImpl.unparsedEntityDecl(String name, String publicId, String systemId, String notationName)
      Filter an unparsed entity declaration event.
      void DefaultHandler.unparsedEntityDecl(String name, String publicId, String systemId, String notationName)
      Receive notification of an unparsed entity declaration.
      void XMLFilterImpl.warning(SAXParseException e)
      Filter a warning event.
      void DefaultHandler.warning(SAXParseException e)
      Receive notification of a parser warning.
      Constructors in org.xml.sax.helpers that throw SAXException
      Constructor and Description
      ParserAdapter()
      Construct a new parser adapter.
      XMLReaderAdapter()
      Create a new adapter.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.xml.sax.SAXNotRecognizedException (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.xml.sax.SAXNotRecognizedException

  • Packages that use SAXNotRecognizedException
    Package Description
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    javax.xml.validation
    This package provides an API for validation of XML documents.
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of SAXNotRecognizedException in javax.xml.parsers

      Methods in javax.xml.parsers that throw SAXNotRecognizedException
      Modifier and Type Method and Description
      abstract boolean SAXParserFactory.getFeature(String name)
      Returns the particular property requested for in the underlying implementation of org.xml.sax.XMLReader.
      abstract Object SAXParser.getProperty(String name)
      Returns the particular property requested for in the underlying implementation of XMLReader.
      abstract void SAXParserFactory.setFeature(String name, boolean value)
      Sets the particular feature in the underlying implementation of org.xml.sax.XMLReader.
      abstract void SAXParser.setProperty(String name, Object value)
      Sets the particular property in the underlying implementation of XMLReader.

    • Uses of SAXNotRecognizedException in javax.xml.validation

      Methods in javax.xml.validation that throw SAXNotRecognizedException
      Modifier and Type Method and Description
      boolean ValidatorHandler.getFeature(String name)
      Look up the value of a feature flag.
      boolean Validator.getFeature(String name)
      Look up the value of a feature flag.
      boolean SchemaFactory.getFeature(String name)
      Look up the value of a feature flag.
      Object ValidatorHandler.getProperty(String name)
      Look up the value of a property.
      Object Validator.getProperty(String name)
      Look up the value of a property.
      Object SchemaFactory.getProperty(String name)
      Look up the value of a property.
      void ValidatorHandler.setFeature(String name, boolean value)
      Set a feature for this ValidatorHandler.
      void Validator.setFeature(String name, boolean value)
      Set the value of a feature flag.
      void SchemaFactory.setFeature(String name, boolean value)
      Set a feature for this SchemaFactory, Schemas created by this factory, and by extension, Validators and ValidatorHandlers created by those Schemas.
      void ValidatorHandler.setProperty(String name, Object object)
      Set the value of a property.
      void Validator.setProperty(String name, Object object)
      Set the value of a property.
      void SchemaFactory.setProperty(String name, Object object)
      Set the value of a property.

    • Uses of SAXNotRecognizedException in org.xml.sax

      Methods in org.xml.sax that throw SAXNotRecognizedException
      Modifier and Type Method and Description
      boolean XMLReader.getFeature(String name)
      Look up the value of a feature flag.
      Object XMLReader.getProperty(String name)
      Look up the value of a property.
      void XMLReader.setFeature(String name, boolean value)
      Set the value of a feature flag.
      void XMLReader.setProperty(String name, Object value)
      Set the value of a property.

    • Uses of SAXNotRecognizedException in org.xml.sax.helpers

      Methods in org.xml.sax.helpers that throw SAXNotRecognizedException
      Modifier and Type Method and Description
      boolean ParserAdapter.getFeature(String name)
      Check a parser feature flag.
      boolean XMLFilterImpl.getFeature(String name)
      Look up the value of a feature.
      Object ParserAdapter.getProperty(String name)
      Get a parser property.
      Object XMLFilterImpl.getProperty(String name)
      Look up the value of a property.
      void ParserAdapter.setFeature(String name, boolean value)
      Set a feature flag for the parser.
      void XMLFilterImpl.setFeature(String name, boolean value)
      Set the value of a feature.
      void ParserAdapter.setProperty(String name, Object value)
      Set a parser property.
      void XMLFilterImpl.setProperty(String name, Object value)
      Set the value of a property.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.xml.sax.SAXNotSupportedException (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.xml.sax.SAXNotSupportedException

  • Packages that use SAXNotSupportedException
    Package Description
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    javax.xml.validation
    This package provides an API for validation of XML documents.
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of SAXNotSupportedException in javax.xml.parsers

      Methods in javax.xml.parsers that throw SAXNotSupportedException
      Modifier and Type Method and Description
      abstract boolean SAXParserFactory.getFeature(String name)
      Returns the particular property requested for in the underlying implementation of org.xml.sax.XMLReader.
      abstract Object SAXParser.getProperty(String name)
      Returns the particular property requested for in the underlying implementation of XMLReader.
      abstract void SAXParserFactory.setFeature(String name, boolean value)
      Sets the particular feature in the underlying implementation of org.xml.sax.XMLReader.
      abstract void SAXParser.setProperty(String name, Object value)
      Sets the particular property in the underlying implementation of XMLReader.

    • Uses of SAXNotSupportedException in javax.xml.validation

      Methods in javax.xml.validation that throw SAXNotSupportedException
      Modifier and Type Method and Description
      boolean ValidatorHandler.getFeature(String name)
      Look up the value of a feature flag.
      boolean Validator.getFeature(String name)
      Look up the value of a feature flag.
      boolean SchemaFactory.getFeature(String name)
      Look up the value of a feature flag.
      Object ValidatorHandler.getProperty(String name)
      Look up the value of a property.
      Object Validator.getProperty(String name)
      Look up the value of a property.
      Object SchemaFactory.getProperty(String name)
      Look up the value of a property.
      void ValidatorHandler.setFeature(String name, boolean value)
      Set a feature for this ValidatorHandler.
      void Validator.setFeature(String name, boolean value)
      Set the value of a feature flag.
      void SchemaFactory.setFeature(String name, boolean value)
      Set a feature for this SchemaFactory, Schemas created by this factory, and by extension, Validators and ValidatorHandlers created by those Schemas.
      void ValidatorHandler.setProperty(String name, Object object)
      Set the value of a property.
      void Validator.setProperty(String name, Object object)
      Set the value of a property.
      void SchemaFactory.setProperty(String name, Object object)
      Set the value of a property.

    • Uses of SAXNotSupportedException in org.xml.sax

      Methods in org.xml.sax that throw SAXNotSupportedException
      Modifier and Type Method and Description
      boolean XMLReader.getFeature(String name)
      Look up the value of a feature flag.
      Object XMLReader.getProperty(String name)
      Look up the value of a property.
      void XMLReader.setFeature(String name, boolean value)
      Set the value of a feature flag.
      void XMLReader.setProperty(String name, Object value)
      Set the value of a property.

    • Uses of SAXNotSupportedException in org.xml.sax.helpers

      Methods in org.xml.sax.helpers that throw SAXNotSupportedException
      Modifier and Type Method and Description
      boolean ParserAdapter.getFeature(String name)
      Check a parser feature flag.
      boolean XMLFilterImpl.getFeature(String name)
      Look up the value of a feature.
      Object ParserAdapter.getProperty(String name)
      Get a parser property.
      Object XMLFilterImpl.getProperty(String name)
      Look up the value of a property.
      void ParserAdapter.setFeature(String name, boolean value)
      Set a feature flag for the parser.
      void XMLFilterImpl.setFeature(String name, boolean value)
      Set the value of a feature.
      void ParserAdapter.setProperty(String name, Object value)
      Set a parser property.
      void XMLFilterImpl.setProperty(String name, Object value)
      Set the value of a property.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.xml.sax.SAXParseException (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.xml.sax.SAXParseException

  • Packages that use SAXParseException
    Package Description
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of SAXParseException in javax.xml.bind.helpers

      Constructors in javax.xml.bind.helpers with parameters of type SAXParseException
      Constructor and Description
      ValidationEventLocatorImpl(SAXParseException e)
      Constructs an object from the location information of a SAXParseException.

    • Uses of SAXParseException in org.xml.sax

      Methods in org.xml.sax with parameters of type SAXParseException
      Modifier and Type Method and Description
      void HandlerBase.error(SAXParseException e)
      Deprecated.
      Receive notification of a recoverable parser error.
      void ErrorHandler.error(SAXParseException exception)
      Receive notification of a recoverable error.
      void HandlerBase.fatalError(SAXParseException e)
      Deprecated.
      Report a fatal XML parsing error.
      void ErrorHandler.fatalError(SAXParseException exception)
      Receive notification of a non-recoverable error.
      void HandlerBase.warning(SAXParseException e)
      Deprecated.
      Receive notification of a parser warning.
      void ErrorHandler.warning(SAXParseException exception)
      Receive notification of a warning.

    • Uses of SAXParseException in org.xml.sax.helpers

      Methods in org.xml.sax.helpers with parameters of type SAXParseException
      Modifier and Type Method and Description
      void XMLFilterImpl.error(SAXParseException e)
      Filter an error event.
      void DefaultHandler.error(SAXParseException e)
      Receive notification of a recoverable parser error.
      void XMLFilterImpl.fatalError(SAXParseException e)
      Filter a fatal error event.
      void DefaultHandler.fatalError(SAXParseException e)
      Report a fatal XML parsing error.
      void XMLFilterImpl.warning(SAXParseException e)
      Filter a warning event.
      void DefaultHandler.warning(SAXParseException e)
      Receive notification of a parser warning.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.xml.sax.XMLFilter (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.xml.sax.XMLFilter

  • Packages that use XMLFilter
    Package Description
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of XMLFilter in javax.xml.transform.sax

      Methods in javax.xml.transform.sax that return XMLFilter
      Modifier and Type Method and Description
      abstract XMLFilter SAXTransformerFactory.newXMLFilter(Source src)
      Create an XMLFilter that uses the given Source as the transformation instructions.
      abstract XMLFilter SAXTransformerFactory.newXMLFilter(Templates templates)
      Create an XMLFilter, based on the Templates argument..

    • Uses of XMLFilter in org.xml.sax.helpers

      Classes in org.xml.sax.helpers that implement XMLFilter
      Modifier and Type Class and Description
      class  XMLFilterImpl
      Base class for deriving an XML filter.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.xml.sax.XMLReader (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.xml.sax.XMLReader

  • Packages that use XMLReader
    Package Description
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.

    • Uses of XMLReader in javax.xml.bind.helpers

      Methods in javax.xml.bind.helpers that return XMLReader
      Modifier and Type Method and Description
      protected XMLReader AbstractUnmarshallerImpl.getXMLReader()
      Obtains a configured XMLReader.
      Methods in javax.xml.bind.helpers with parameters of type XMLReader
      Modifier and Type Method and Description
      protected abstract Object AbstractUnmarshallerImpl.unmarshal(XMLReader reader, InputSource source)
      Unmarshals an object by using the specified XMLReader and the InputSource.

    • Uses of XMLReader in javax.xml.parsers

      Methods in javax.xml.parsers that return XMLReader
      Modifier and Type Method and Description
      abstract XMLReader SAXParser.getXMLReader()
      Returns the XMLReader that is encapsulated by the implementation of this class.

    • Uses of XMLReader in javax.xml.transform.sax

      Methods in javax.xml.transform.sax that return XMLReader
      Modifier and Type Method and Description
      XMLReader SAXSource.getXMLReader()
      Get the XMLReader to be used for the Source.
      Methods in javax.xml.transform.sax with parameters of type XMLReader
      Modifier and Type Method and Description
      void SAXSource.setXMLReader(XMLReader reader)
      Set the XMLReader to be used for the Source.
      Constructors in javax.xml.transform.sax with parameters of type XMLReader
      Constructor and Description
      SAXSource(XMLReader reader, InputSource inputSource)
      Create a SAXSource, using an XMLReader and a SAX InputSource.

    • Uses of XMLReader in org.xml.sax

      Subinterfaces of XMLReader in org.xml.sax
      Modifier and Type Interface and Description
      interface  XMLFilter
      Interface for an XML filter.
      Methods in org.xml.sax that return XMLReader
      Modifier and Type Method and Description
      XMLReader XMLFilter.getParent()
      Get the parent reader.
      Methods in org.xml.sax with parameters of type XMLReader
      Modifier and Type Method and Description
      void XMLFilter.setParent(XMLReader parent)
      Set the parent reader.

    • Uses of XMLReader in org.xml.sax.helpers

      Classes in org.xml.sax.helpers that implement XMLReader
      Modifier and Type Class and Description
      class  ParserAdapter
      Adapt a SAX1 Parser as a SAX2 XMLReader.
      class  XMLFilterImpl
      Base class for deriving an XML filter.
      Methods in org.xml.sax.helpers that return XMLReader
      Modifier and Type Method and Description
      static XMLReader XMLReaderFactory.createXMLReader()
      Attempt to create an XMLReader from system defaults.
      static XMLReader XMLReaderFactory.createXMLReader(String className)
      Attempt to create an XML reader from a class name.
      XMLReader XMLFilterImpl.getParent()
      Get the parent reader.
      Methods in org.xml.sax.helpers with parameters of type XMLReader
      Modifier and Type Method and Description
      void XMLFilterImpl.setParent(XMLReader parent)
      Set the parent reader.
      Constructors in org.xml.sax.helpers with parameters of type XMLReader
      Constructor and Description
      XMLFilterImpl(XMLReader parent)
      Construct an XML filter with the specified parent.
      XMLReaderAdapter(XMLReader xmlReader)
      Create a new adapter.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


compact2 - org.xml.sax (Java Platform SE 8 )

compact2 - org.xml.sax

Interfaces

  • AttributeList
  • Attributes
  • ContentHandler
  • DocumentHandler
  • DTDHandler
  • EntityResolver
  • ErrorHandler
  • Locator
  • Parser
  • XMLFilter
  • XMLReader

Classes

  • HandlerBase
  • InputSource

Exceptions

  • SAXException
  • SAXNotRecognizedException
  • SAXNotSupportedException
  • SAXParseException


org.xml.sax (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact2

Package org.xml.sax

This package provides the core SAX APIs.

See: Description

  • Interface Summary
    Interface Description
    AttributeList Deprecated
    This interface has been replaced by the SAX2 Attributes interface, which includes Namespace support.
    Attributes
    Interface for a list of XML attributes.
    ContentHandler
    Receive notification of the logical content of a document.
    DocumentHandler Deprecated
    This interface has been replaced by the SAX2 ContentHandler interface, which includes Namespace support.
    DTDHandler
    Receive notification of basic DTD-related events.
    EntityResolver
    Basic interface for resolving entities.
    ErrorHandler
    Basic interface for SAX error handlers.
    Locator
    Interface for associating a SAX event with a document location.
    Parser Deprecated
    This interface has been replaced by the SAX2 XMLReader interface, which includes Namespace support.
    XMLFilter
    Interface for an XML filter.
    XMLReader
    Interface for reading an XML document using callbacks.
  • Class Summary
    Class Description
    HandlerBase Deprecated
    This class works with the deprecated DocumentHandler interface.
    InputSource
    A single input source for an XML entity.
  • Exception Summary
    Exception Description
    SAXException
    Encapsulate a general SAX error or warning.
    SAXNotRecognizedException
    Exception class for an unrecognized identifier.
    SAXNotSupportedException
    Exception class for an unsupported operation.
    SAXParseException
    Encapsulate an XML parse error or warning.

Package org.xml.sax Description

This package provides the core SAX APIs. Some SAX1 APIs are deprecated to encourage integration of namespace-awareness into designs of new applications and into maintenance of existing infrastructure.

See http://www.saxproject.org for more information about SAX.

SAX2 Standard Feature Flags

One of the essential characteristics of SAX2 is that it added feature flags which can be used to examine and perhaps modify parser modes, in particular modes such as validation. Since features are identified by (absolute) URIs, anyone can define such features. Currently defined standard feature URIs have the prefix http://xml.org/sax/features/ before an identifier such as validation. Turn features on or off using setFeature. Those standard identifiers are:

Feature ID | Access | Default | Description
external-general-entities | read/write | unspecified | Reports whether this parser processes external general entities; always true if validating.
external-parameter-entities | read/write | unspecified | Reports whether this parser processes external parameter entities; always true if validating.
is-standalone | (parsing) read-only, (not parsing) none | not applicable | May be examined only during a parse, after the startDocument() callback has been completed; read-only. The value is true if the document specified standalone="yes" in its XML declaration, and otherwise is false.
lexical-handler/parameter-entities | read/write | unspecified | A value of "true" indicates that the LexicalHandler will report the beginning and end of parameter entities.
namespaces | read/write | true | A value of "true" indicates namespace URIs and unprefixed local names for element and attribute names will be available.
namespace-prefixes | read/write | false | A value of "true" indicates that XML qualified names (with prefixes) and attributes (including xmlns* attributes) will be available.
resolve-dtd-uris read/write true A value of "true" indicates that system IDs in declarations will be absolutized (relative to their base URIs) before reporting. (That is the default behavior for all SAX2 XML parsers.) A value of "false" indicates those IDs will not be absolutized; parsers will provide the base URI from Locator.getSystemId(). This applies to system IDs passed in
  • DTDHandler.notationDecl(),
  • DTDHandler.unparsedEntityDecl(), and
  • DeclHandler.externalEntityDecl().
It does not apply to EntityResolver.resolveEntity(), which is not used to report declarations, or to LexicalHandler.startDTD(), which already provides the non-absolutized URI.
string-interning | read/write | unspecified | Has a value of "true" if all XML names (for elements, prefixes, attributes, entities, notations, and local names), as well as Namespace URIs, will have been interned using java.lang.String.intern. This supports fast testing of equality/inequality against string constants, rather than forcing slower calls to String.equals().
unicode-normalization-checking | read/write | false | Controls whether the parser reports Unicode normalization errors as described in section 2.13 and Appendix B of the XML 1.1 Recommendation. If true, Unicode normalization errors are reported using the ErrorHandler.error() callback. Such errors are not fatal in themselves (though, obviously, other Unicode-related encoding errors may be).
use-attributes2 | read-only | not applicable | Returns "true" if the Attributes objects passed by this parser in ContentHandler.startElement() implement the org.xml.sax.ext.Attributes2 interface. That interface exposes additional DTD-related information, such as whether the attribute was specified in the source text rather than defaulted.
use-locator2 | read-only | not applicable | Returns "true" if the Locator objects passed by this parser in ContentHandler.setDocumentLocator() implement the org.xml.sax.ext.Locator2 interface. That interface exposes additional entity information, such as the character encoding and XML version used.
use-entity-resolver2 | read/write | true | Returns "true" if, when setEntityResolver is given an object implementing the org.xml.sax.ext.EntityResolver2 interface, those new methods will be used. Returns "false" to indicate that those methods will not be used.
validation | read/write | unspecified | Controls whether the parser is reporting all validity errors; if true, all external entities will be read.
xmlns-uris | read/write | false | Controls whether, when the namespace-prefixes feature is set, the parser treats namespace declaration attributes as being in the http://www.w3.org/2000/xmlns/ namespace. By default, SAX2 conforms to the original "Namespaces in XML" Recommendation, which explicitly states that such attributes are not in any namespace. Setting this optional flag to "true" makes the SAX2 events conform to a later backwards-incompatible revision of that recommendation, placing those attributes in a namespace.
xml-1.1 | read-only | not applicable | Returns "true" if the parser supports both XML 1.1 and XML 1.0. Returns "false" if the parser supports only XML 1.0.

Support for the default values of the namespaces and namespace-prefixes properties is required. Support for any other feature flags is entirely optional.

For default values not specified by SAX2, each XMLReader implementation specifies its default, or may choose not to expose the feature flag. Unless otherwise specified here, implementations may support changing current values of these standard feature flags, but not while parsing.

SAX2 Standard Handler and Property IDs

For parser interface characteristics that are described as objects, a separate namespace is defined. The objects in this namespace are again identified by URI, and the standard property URIs have the prefix http://xml.org/sax/properties/ before an identifier such as lexical-handler or dom-node. Manage those properties using setProperty(). Those identifiers are:

Property ID | Description
declaration-handler | Used to see most DTD declarations except those treated as lexical ("document element name is ...") or which are mandatory for all SAX parsers (DTDHandler). The Object must implement org.xml.sax.ext.DeclHandler.
document-xml-version | May be examined only during a parse, after the startDocument() callback has been completed; read-only. This property is a literal string describing the actual XML version of the document, such as "1.0" or "1.1".
dom-node | For "DOM Walker" style parsers, which ignore their parser.parse() parameters, this is used to specify the DOM (sub)tree being walked by the parser. The Object must implement the org.w3c.dom.Node interface.
lexical-handler | Used to see some syntax events that are essential in some applications: comments, CDATA delimiters, selected general entity inclusions, and the start and end of the DTD (and declaration of document element name). The Object must implement org.xml.sax.ext.LexicalHandler.
xml-string | Readable only during a parser callback, this exposes a TBS chunk of characters responsible for the current event.

All of these standard properties are optional; XMLReader implementations need not support them.

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames


compact3 - org.xml.sax (Java Platform SE 8 )

compact3 - org.xml.sax

Interfaces

  • AttributeList
  • Attributes
  • ContentHandler
  • DocumentHandler
  • DTDHandler
  • EntityResolver
  • ErrorHandler
  • Locator
  • Parser
  • XMLFilter
  • XMLReader

Classes

  • HandlerBase
  • InputSource

Exceptions

  • SAXException
  • SAXNotRecognizedException
  • SAXNotSupportedException
  • SAXParseException


org.xml.sax (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package org.xml.sax

This package provides the core SAX APIs.

See: Description

  • Interface Summary
    Interface Description
    AttributeList Deprecated
    This interface has been replaced by the SAX2 Attributes interface, which includes Namespace support.
    Attributes
    Interface for a list of XML attributes.
    ContentHandler
    Receive notification of the logical content of a document.
    DocumentHandler Deprecated
    This interface has been replaced by the SAX2 ContentHandler interface, which includes Namespace support.
    DTDHandler
    Receive notification of basic DTD-related events.
    EntityResolver
    Basic interface for resolving entities.
    ErrorHandler
    Basic interface for SAX error handlers.
    Locator
    Interface for associating a SAX event with a document location.
    Parser Deprecated
    This interface has been replaced by the SAX2 XMLReader interface, which includes Namespace support.
    XMLFilter
    Interface for an XML filter.
    XMLReader
    Interface for reading an XML document using callbacks.
  • Class Summary
    Class Description
    HandlerBase Deprecated
    This class works with the deprecated DocumentHandler interface.
    InputSource
    A single input source for an XML entity.
  • Exception Summary
    Exception Description
    SAXException
    Encapsulate a general SAX error or warning.
    SAXNotRecognizedException
    Exception class for an unrecognized identifier.
    SAXNotSupportedException
    Exception class for an unsupported operation.
    SAXParseException
    Encapsulate an XML parse error or warning.

Package org.xml.sax Description

This package provides the core SAX APIs. Some SAX1 APIs are deprecated to encourage integration of namespace-awareness into designs of new applications and into maintenance of existing infrastructure.

See http://www.saxproject.org for more information about SAX.

SAX2 Standard Feature Flags

One of the essential characteristics of SAX2 is that it added feature flags which can be used to examine and perhaps modify parser modes, in particular modes such as validation. Since features are identified by (absolute) URIs, anyone can define such features. Currently defined standard feature URIs have the prefix http://xml.org/sax/features/ before an identifier such as validation. Turn features on or off using setFeature. Those standard identifiers are:

Feature ID | Access | Default | Description
external-general-entities | read/write | unspecified | Reports whether this parser processes external general entities; always true if validating.
external-parameter-entities | read/write | unspecified | Reports whether this parser processes external parameter entities; always true if validating.
is-standalone | (parsing) read-only, (not parsing) none | not applicable | May be examined only during a parse, after the startDocument() callback has been completed; read-only. The value is true if the document specified standalone="yes" in its XML declaration, and otherwise is false.
lexical-handler/parameter-entities | read/write | unspecified | A value of "true" indicates that the LexicalHandler will report the beginning and end of parameter entities.
namespaces | read/write | true | A value of "true" indicates namespace URIs and unprefixed local names for element and attribute names will be available.
namespace-prefixes | read/write | false | A value of "true" indicates that XML qualified names (with prefixes) and attributes (including xmlns* attributes) will be available.
resolve-dtd-uris read/write true A value of "true" indicates that system IDs in declarations will be absolutized (relative to their base URIs) before reporting. (That is the default behavior for all SAX2 XML parsers.) A value of "false" indicates those IDs will not be absolutized; parsers will provide the base URI from Locator.getSystemId(). This applies to system IDs passed in
  • DTDHandler.notationDecl(),
  • DTDHandler.unparsedEntityDecl(), and
  • DeclHandler.externalEntityDecl().
It does not apply to EntityResolver.resolveEntity(), which is not used to report declarations, or to LexicalHandler.startDTD(), which already provides the non-absolutized URI.
string-interning | read/write | unspecified | Has a value of "true" if all XML names (for elements, prefixes, attributes, entities, notations, and local names), as well as Namespace URIs, will have been interned using java.lang.String.intern. This supports fast testing of equality/inequality against string constants, rather than forcing slower calls to String.equals().
unicode-normalization-checking | read/write | false | Controls whether the parser reports Unicode normalization errors as described in section 2.13 and Appendix B of the XML 1.1 Recommendation. If true, Unicode normalization errors are reported using the ErrorHandler.error() callback. Such errors are not fatal in themselves (though, obviously, other Unicode-related encoding errors may be).
use-attributes2 | read-only | not applicable | Returns "true" if the Attributes objects passed by this parser in ContentHandler.startElement() implement the org.xml.sax.ext.Attributes2 interface. That interface exposes additional DTD-related information, such as whether the attribute was specified in the source text rather than defaulted.
use-locator2 | read-only | not applicable | Returns "true" if the Locator objects passed by this parser in ContentHandler.setDocumentLocator() implement the org.xml.sax.ext.Locator2 interface. That interface exposes additional entity information, such as the character encoding and XML version used.
use-entity-resolver2 | read/write | true | Returns "true" if, when setEntityResolver is given an object implementing the org.xml.sax.ext.EntityResolver2 interface, those new methods will be used. Returns "false" to indicate that those methods will not be used.
validation | read/write | unspecified | Controls whether the parser is reporting all validity errors; if true, all external entities will be read.
xmlns-uris | read/write | false | Controls whether, when the namespace-prefixes feature is set, the parser treats namespace declaration attributes as being in the http://www.w3.org/2000/xmlns/ namespace. By default, SAX2 conforms to the original "Namespaces in XML" Recommendation, which explicitly states that such attributes are not in any namespace. Setting this optional flag to "true" makes the SAX2 events conform to a later backwards-incompatible revision of that recommendation, placing those attributes in a namespace.
xml-1.1 | read-only | not applicable | Returns "true" if the parser supports both XML 1.1 and XML 1.0. Returns "false" if the parser supports only XML 1.0.

Support for the default values of the namespaces and namespace-prefixes properties is required. Support for any other feature flags is entirely optional.

For default values not specified by SAX2, each XMLReader implementation specifies its default, or may choose not to expose the feature flag. Unless otherwise specified here, implementations may support changing current values of these standard feature flags, but not while parsing.

SAX2 Standard Handler and Property IDs

For parser interface characteristics that are described as objects, a separate namespace is defined. The objects in this namespace are again identified by URI, and the standard property URIs have the prefix http://xml.org/sax/properties/ before an identifier such as lexical-handler or dom-node. Manage those properties using setProperty(). Those identifiers are:

Property ID | Description
declaration-handler | Used to see most DTD declarations except those treated as lexical ("document element name is ...") or which are mandatory for all SAX parsers (DTDHandler). The Object must implement org.xml.sax.ext.DeclHandler.
document-xml-version | May be examined only during a parse, after the startDocument() callback has been completed; read-only. This property is a literal string describing the actual XML version of the document, such as "1.0" or "1.1".
dom-node | For "DOM Walker" style parsers, which ignore their parser.parse() parameters, this is used to specify the DOM (sub)tree being walked by the parser. The Object must implement the org.w3c.dom.Node interface.
lexical-handler | Used to see some syntax events that are essential in some applications: comments, CDATA delimiters, selected general entity inclusions, and the start and end of the DTD (and declaration of document element name). The Object must implement org.xml.sax.ext.LexicalHandler.
xml-string | Readable only during a parser callback, this exposes a TBS chunk of characters responsible for the current event.

All of these standard properties are optional; XMLReader implementations need not support them.

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames


ContentHandler (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax

Interface ContentHandler

  • All Known Subinterfaces:
    TemplatesHandler, TransformerHandler, UnmarshallerHandler
    All Known Implementing Classes:
    DefaultHandler, DefaultHandler2, ValidatorHandler, XMLFilterImpl, XMLReaderAdapter

    public interface ContentHandler
    Receive notification of the logical content of a document.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This is the main interface that most SAX applications implement: if the application needs to be informed of basic parsing events, it implements this interface and registers an instance with the SAX parser using the setContentHandler method. The parser uses the instance to report basic document-related events like the start and end of elements and character data.

    The order of events in this interface is very important, and mirrors the order of information in the document itself. For example, all of an element's content (character data, processing instructions, and/or subelements) will appear, in order, between the startElement event and the corresponding endElement event.

    This interface is similar to the now-deprecated SAX 1.0 DocumentHandler interface, but it adds support for Namespaces and for reporting skipped entities (in non-validating XML processors).

    Implementors should note that there is also a ContentHandler class in the java.net package; that means that it's probably a bad idea to do

    import java.net.*;
 import org.xml.sax.*;

    In fact, "import ...*" is usually a sign of sloppy programming anyway, so the user should consider this a feature rather than a bug.

    Since:
    SAX 2.0
    See Also:
    XMLReader, DTDHandler, ErrorHandler

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void characters(char[] ch, int start, int length)
      Receive notification of character data.
      void endDocument()
      Receive notification of the end of a document.
      void endElement(String uri, String localName, String qName)
      Receive notification of the end of an element.
      void endPrefixMapping(String prefix)
      End the scope of a prefix-URI mapping.
      void ignorableWhitespace(char[] ch, int start, int length)
      Receive notification of ignorable whitespace in element content.
      void processingInstruction(String target, String data)
      Receive notification of a processing instruction.
      void setDocumentLocator(Locator locator)
      Receive an object for locating the origin of SAX document events.
      void skippedEntity(String name)
      Receive notification of a skipped entity.
      void startDocument()
      Receive notification of the beginning of a document.
      void startElement(String uri, String localName, String qName, Attributes atts)
      Receive notification of the beginning of an element.
      void startPrefixMapping(String prefix, String uri)
      Begin the scope of a prefix-URI Namespace mapping.

    • Method Detail

      • setDocumentLocator

        void setDocumentLocator(Locator locator)
        Receive an object for locating the origin of SAX document events.

        SAX parsers are strongly encouraged (though not absolutely required) to supply a locator: if it does so, it must supply the locator to the application by invoking this method before invoking any of the other methods in the ContentHandler interface.

        The locator allows the application to determine the end position of any document-related event, even if the parser is not reporting an error. Typically, the application will use this information for reporting its own errors (such as character content that does not match an application's business rules). The information returned by the locator is probably not sufficient for use with a search engine.

        Note that the locator will return correct information only during the invocation SAX event callbacks after startDocument returns and before endDocument is called. The application should not attempt to use it at any other time.

        Parameters:
        locator - an object that can return the location of any SAX document event
        See Also:
        Locator

      • startDocument

        void startDocument()
            throws SAXException
        Receive notification of the beginning of a document.

        The SAX parser will invoke this method only once, before any other event callbacks (except for setDocumentLocator).

        Throws:
        SAXException - any SAX exception, possibly wrapping another exception
        See Also:
        endDocument()

      • endDocument

        void endDocument()
          throws SAXException
        Receive notification of the end of a document.

        There is an apparent contradiction between the documentation for this method and the documentation for ErrorHandler.fatalError(org.xml.sax.SAXParseException). Until this ambiguity is resolved in a future major release, clients should make no assumptions about whether endDocument() will or will not be invoked when the parser has reported a fatalError() or thrown an exception.

        The SAX parser will invoke this method only once, and it will be the last method invoked during the parse. The parser shall not invoke this method until it has either abandoned parsing (because of an unrecoverable error) or reached the end of input.

        Throws:
        SAXException - any SAX exception, possibly wrapping another exception
        See Also:
        startDocument()

      • startPrefixMapping

        void startPrefixMapping(String prefix,
                        String uri)
                 throws SAXException
        Begin the scope of a prefix-URI Namespace mapping.

        The information from this event is not necessary for normal Namespace processing: the SAX XML reader will automatically replace prefixes for element and attribute names when the http://xml.org/sax/features/namespaces feature is true (the default).

        There are cases, however, when applications need to use prefixes in character data or in attribute values, where they cannot safely be expanded automatically; the start/endPrefixMapping event supplies the information to the application to expand prefixes in those contexts itself, if necessary.

        Note that start/endPrefixMapping events are not guaranteed to be properly nested relative to each other: all startPrefixMapping events will occur immediately before the corresponding startElement event, and all endPrefixMapping events will occur immediately after the corresponding endElement event, but their order is not otherwise guaranteed.

        There should never be start/endPrefixMapping events for the "xml" prefix, since it is predeclared and immutable.

        Parameters:
        prefix - the Namespace prefix being declared. An empty string is used for the default element namespace, which has no prefix.
        uri - the Namespace URI the prefix is mapped to
        Throws:
        SAXException - the client may throw an exception during processing
        See Also:
        endPrefixMapping(java.lang.String), startElement(java.lang.String, java.lang.String, java.lang.String, org.xml.sax.Attributes)

      • endPrefixMapping

        void endPrefixMapping(String prefix)
               throws SAXException
        End the scope of a prefix-URI mapping.

        See startPrefixMapping for details. These events will always occur immediately after the corresponding endElement event, but the order of endPrefixMapping events is not otherwise guaranteed.

        Parameters:
        prefix - the prefix that was being mapped. This is the empty string when a default mapping scope ends.
        Throws:
        SAXException - the client may throw an exception during processing
        See Also:
        startPrefixMapping(java.lang.String, java.lang.String), endElement(java.lang.String, java.lang.String, java.lang.String)

      • startElement

        void startElement(String uri,
                  String localName,
                  String qName,
                  Attributes atts)
           throws SAXException
        Receive notification of the beginning of an element.

        The Parser will invoke this method at the beginning of every element in the XML document; there will be a corresponding endElement event for every startElement event (even when the element is empty). All of the element's content will be reported, in order, before the corresponding endElement event.

        This event allows up to three name components for each element:

        1. the Namespace URI;
        2. the local name; and
        3. the qualified (prefixed) name.

        Any or all of these may be provided, depending on the values of the http://xml.org/sax/features/namespaces and the http://xml.org/sax/features/namespace-prefixes properties:

        • the Namespace URI and local name are required when the namespaces property is true (the default), and are optional when the namespaces property is false (if one is specified, both must be);
        • the qualified name is required when the namespace-prefixes property is true, and is optional when the namespace-prefixes property is false (the default).

        Note that the attribute list provided will contain only attributes with explicit values (specified or defaulted): #IMPLIED attributes will be omitted. The attribute list will contain attributes used for Namespace declarations (xmlns* attributes) only if the http://xml.org/sax/features/namespace-prefixes property is true (it is false by default, and support for a true value is optional).

        Like characters(), attribute values may have characters that need more than one char value.

        Parameters:
        uri - the Namespace URI, or the empty string if the element has no Namespace URI or if Namespace processing is not being performed
        localName - the local name (without prefix), or the empty string if Namespace processing is not being performed
        qName - the qualified name (with prefix), or the empty string if qualified names are not available
        atts - the attributes attached to the element. If there are no attributes, it shall be an empty Attributes object. The value of this object after startElement returns is undefined
        Throws:
        SAXException - any SAX exception, possibly wrapping another exception
        See Also:
        endElement(java.lang.String, java.lang.String, java.lang.String), Attributes, AttributesImpl

      • endElement

        void endElement(String uri,
                String localName,
                String qName)
         throws SAXException
        Receive notification of the end of an element.

        The SAX parser will invoke this method at the end of every element in the XML document; there will be a corresponding startElement event for every endElement event (even when the element is empty).

        For information on the names, see startElement.

        Parameters:
        uri - the Namespace URI, or the empty string if the element has no Namespace URI or if Namespace processing is not being performed
        localName - the local name (without prefix), or the empty string if Namespace processing is not being performed
        qName - the qualified XML name (with prefix), or the empty string if qualified names are not available
        Throws:
        SAXException - any SAX exception, possibly wrapping another exception

      • characters

        void characters(char[] ch,
                int start,
                int length)
         throws SAXException
        Receive notification of character data.

        The Parser will call this method to report each chunk of character data. SAX parsers may return all contiguous character data in a single chunk, or they may split it into several chunks; however, all of the characters in any single event must come from the same external entity so that the Locator provides useful information.

        The application must not attempt to read from the array outside of the specified range.

        Individual characters may consist of more than one Java char value. There are two important cases where this happens, because characters can't be represented in just sixteen bits. In one case, characters are represented in a Surrogate Pair, using two special Unicode values. Such characters are in the so-called "Astral Planes", with a code point above U+FFFF. A second case involves composite characters, such as a base character combining with one or more accent characters.

        Your code should not assume that algorithms using char-at-a-time idioms will be working in character units; in some cases they will split characters. This is relevant wherever XML permits arbitrary characters, such as attribute values, processing instruction data, and comments as well as in data reported from this method. It's also generally relevant whenever Java code manipulates internationalized text; the issue isn't unique to XML.

        Note that some parsers will report whitespace in element content using the ignorableWhitespace method rather than this one (validating parsers must do so).

        Parameters:
        ch - the characters from the XML document
        start - the start position in the array
        length - the number of characters to read from the array
        Throws:
        SAXException - any SAX exception, possibly wrapping another exception
        See Also:
        ignorableWhitespace(char[], int, int), Locator

      • ignorableWhitespace

        void ignorableWhitespace(char[] ch,
                         int start,
                         int length)
                  throws SAXException
        Receive notification of ignorable whitespace in element content.

        Validating Parsers must use this method to report each chunk of whitespace in element content (see the W3C XML 1.0 recommendation, section 2.10): non-validating parsers may also use this method if they are capable of parsing and using content models.

        SAX parsers may return all contiguous whitespace in a single chunk, or they may split it into several chunks; however, all of the characters in any single event must come from the same external entity, so that the Locator provides useful information.

        The application must not attempt to read from the array outside of the specified range.

        Parameters:
        ch - the characters from the XML document
        start - the start position in the array
        length - the number of characters to read from the array
        Throws:
        SAXException - any SAX exception, possibly wrapping another exception
        See Also:
        characters(char[], int, int)

      • processingInstruction

        void processingInstruction(String target,
                           String data)
                    throws SAXException
        Receive notification of a processing instruction.

        The Parser will invoke this method once for each processing instruction found: note that processing instructions may occur before or after the main document element.

        A SAX parser must never report an XML declaration (XML 1.0, section 2.8) or a text declaration (XML 1.0, section 4.3.1) using this method.

        Like characters(), processing instruction data may have characters that need more than one char value.

        Parameters:
        target - the processing instruction target
        data - the processing instruction data, or null if none was supplied. The data does not include any whitespace separating it from the target
        Throws:
        SAXException - any SAX exception, possibly wrapping another exception

      • skippedEntity

        void skippedEntity(String name)
            throws SAXException
        Receive notification of a skipped entity. This is not called for entity references within markup constructs such as element start tags or markup declarations. (The XML recommendation requires reporting skipped external entities. SAX also reports internal entity expansion/non-expansion, except within markup constructs.)

        The Parser will invoke this method each time the entity is skipped. Non-validating processors may skip entities if they have not seen the declarations (because, for example, the entity was declared in an external DTD subset). All processors may skip external entities, depending on the values of the http://xml.org/sax/features/external-general-entities and the http://xml.org/sax/features/external-parameter-entities properties.

        Parameters:
        name - the name of the skipped entity. If it is a parameter entity, the name will begin with '%', and if it is the external DTD subset, it will be the string "[dtd]"
        Throws:
        SAXException - any SAX exception, possibly wrapping another exception
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DocumentHandler (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax

Interface DocumentHandler

  • All Known Implementing Classes:
    HandlerBase, ParserAdapter
    Deprecated.
    This interface has been replaced by the SAX2 ContentHandler interface, which includes Namespace support.

    public interface DocumentHandler
    Receive notification of general document events.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This was the main event-handling interface for SAX1; in SAX2, it has been replaced by ContentHandler, which provides Namespace support and reporting of skipped entities. This interface is included in SAX2 only to support legacy SAX1 applications.

    The order of events in this interface is very important, and mirrors the order of information in the document itself. For example, all of an element's content (character data, processing instructions, and/or subelements) will appear, in order, between the startElement event and the corresponding endElement event.

    Application writers who do not want to implement the entire interface can derive a class from HandlerBase, which implements the default functionality; parser writers can instantiate HandlerBase to obtain a default handler. The application can find the location of any document event using the Locator interface supplied by the Parser through the setDocumentLocator method.

    Since:
    SAX 1.0
    See Also:
    Parser.setDocumentHandler(org.xml.sax.DocumentHandler), Locator, HandlerBase

    • Method Summary

      All Methods Instance Methods Abstract Methods Deprecated Methods
      Modifier and Type Method and Description
      void characters(char[] ch, int start, int length)
      Deprecated.
      Receive notification of character data.
      void endDocument()
      Deprecated.
      Receive notification of the end of a document.
      void endElement(String name)
      Deprecated.
      Receive notification of the end of an element.
      void ignorableWhitespace(char[] ch, int start, int length)
      Deprecated.
      Receive notification of ignorable whitespace in element content.
      void processingInstruction(String target, String data)
      Deprecated.
      Receive notification of a processing instruction.
      void setDocumentLocator(Locator locator)
      Deprecated.
      Receive an object for locating the origin of SAX document events.
      void startDocument()
      Deprecated.
      Receive notification of the beginning of a document.
      void startElement(String name, AttributeList atts)
      Deprecated.
      Receive notification of the beginning of an element.

    • Method Detail

      • setDocumentLocator

        void setDocumentLocator(Locator locator)
        Deprecated.
        Receive an object for locating the origin of SAX document events.

        SAX parsers are strongly encouraged (though not absolutely required) to supply a locator: if it does so, it must supply the locator to the application by invoking this method before invoking any of the other methods in the DocumentHandler interface.

        The locator allows the application to determine the end position of any document-related event, even if the parser is not reporting an error. Typically, the application will use this information for reporting its own errors (such as character content that does not match an application's business rules). The information returned by the locator is probably not sufficient for use with a search engine.

        Note that the locator will return correct information only during the invocation of the events in this interface. The application should not attempt to use it at any other time.

        Parameters:
        locator - An object that can return the location of any SAX document event.
        See Also:
        Locator

      • startDocument

        void startDocument()
            throws SAXException
        Deprecated.
        Receive notification of the beginning of a document.

        The SAX parser will invoke this method only once, before any other methods in this interface or in DTDHandler (except for setDocumentLocator).

        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.

      • endDocument

        void endDocument()
          throws SAXException
        Deprecated.
        Receive notification of the end of a document.

        The SAX parser will invoke this method only once, and it will be the last method invoked during the parse. The parser shall not invoke this method until it has either abandoned parsing (because of an unrecoverable error) or reached the end of input.

        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.

      • startElement

        void startElement(String name,
                  AttributeList atts)
           throws SAXException
        Deprecated.
        Receive notification of the beginning of an element.

        The Parser will invoke this method at the beginning of every element in the XML document; there will be a corresponding endElement() event for every startElement() event (even when the element is empty). All of the element's content will be reported, in order, before the corresponding endElement() event.

        If the element name has a namespace prefix, the prefix will still be attached. Note that the attribute list provided will contain only attributes with explicit values (specified or defaulted): #IMPLIED attributes will be omitted.

        Parameters:
        name - The element type name.
        atts - The attributes attached to the element, if any.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        endElement(java.lang.String), AttributeList

      • endElement

        void endElement(String name)
         throws SAXException
        Deprecated.
        Receive notification of the end of an element.

        The SAX parser will invoke this method at the end of every element in the XML document; there will be a corresponding startElement() event for every endElement() event (even when the element is empty).

        If the element name has a namespace prefix, the prefix will still be attached to the name.

        Parameters:
        name - The element type name
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.

      • characters

        void characters(char[] ch,
                int start,
                int length)
         throws SAXException
        Deprecated.
        Receive notification of character data.

        The Parser will call this method to report each chunk of character data. SAX parsers may return all contiguous character data in a single chunk, or they may split it into several chunks; however, all of the characters in any single event must come from the same external entity, so that the Locator provides useful information.

        The application must not attempt to read from the array outside of the specified range.

        Note that some parsers will report whitespace using the ignorableWhitespace() method rather than this one (validating parsers must do so).

        Parameters:
        ch - The characters from the XML document.
        start - The start position in the array.
        length - The number of characters to read from the array.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        ignorableWhitespace(char[], int, int), Locator

      • ignorableWhitespace

        void ignorableWhitespace(char[] ch,
                         int start,
                         int length)
                  throws SAXException
        Deprecated.
        Receive notification of ignorable whitespace in element content.

        Validating Parsers must use this method to report each chunk of ignorable whitespace (see the W3C XML 1.0 recommendation, section 2.10): non-validating parsers may also use this method if they are capable of parsing and using content models.

        SAX parsers may return all contiguous whitespace in a single chunk, or they may split it into several chunks; however, all of the characters in any single event must come from the same external entity, so that the Locator provides useful information.

        The application must not attempt to read from the array outside of the specified range.

        Parameters:
        ch - The characters from the XML document.
        start - The start position in the array.
        length - The number of characters to read from the array.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        characters(char[], int, int)

      • processingInstruction

        void processingInstruction(String target,
                           String data)
                    throws SAXException
        Deprecated.
        Receive notification of a processing instruction.

        The Parser will invoke this method once for each processing instruction found: note that processing instructions may occur before or after the main document element.

        A SAX parser should never report an XML declaration (XML 1.0, section 2.8) or a text declaration (XML 1.0, section 4.3.1) using this method.

        Parameters:
        target - The processing instruction target.
        data - The processing instruction data, or null if none was supplied.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DTDHandler (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax

Interface DTDHandler

  • All Known Subinterfaces:
    TransformerHandler
    All Known Implementing Classes:
    DefaultHandler, DefaultHandler2, HandlerBase, XMLFilterImpl

    public interface DTDHandler
    Receive notification of basic DTD-related events.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    If a SAX application needs information about notations and unparsed entities, then the application implements this interface and registers an instance with the SAX parser using the parser's setDTDHandler method. The parser uses the instance to report notation and unparsed entity declarations to the application.

    Note that this interface includes only those DTD events that the XML recommendation requires processors to report: notation and unparsed entity declarations.

    The SAX parser may report these events in any order, regardless of the order in which the notations and unparsed entities were declared; however, all DTD events must be reported after the document handler's startDocument event, and before the first startElement event. (If the LexicalHandler is used, these events must also be reported before the endDTD event.)

    It is up to the application to store the information for future use (perhaps in a hash table or object tree). If the application encounters attributes of type "NOTATION", "ENTITY", or "ENTITIES", it can use the information that it obtained through this interface to find the entity and/or notation corresponding with the attribute value.

    Since:
    SAX 1.0
    See Also:
    XMLReader.setDTDHandler(org.xml.sax.DTDHandler)

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void notationDecl(String name, String publicId, String systemId)
      Receive notification of a notation declaration event.
      void unparsedEntityDecl(String name, String publicId, String systemId, String notationName)
      Receive notification of an unparsed entity declaration event.

    • Method Detail

      • notationDecl

        void notationDecl(String name,
                  String publicId,
                  String systemId)
           throws SAXException
        Receive notification of a notation declaration event.

        It is up to the application to record the notation for later reference, if necessary; notations may appear as attribute values and in unparsed entity declarations, and are sometime used with processing instruction target names.

        At least one of publicId and systemId must be non-null. If a system identifier is present, and it is a URL, the SAX parser must resolve it fully before passing it to the application through this event.

        There is no guarantee that the notation declaration will be reported before any unparsed entities that use it.

        Parameters:
        name - The notation name.
        publicId - The notation's public identifier, or null if none was given.
        systemId - The notation's system identifier, or null if none was given.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String), Attributes

      • unparsedEntityDecl

        void unparsedEntityDecl(String name,
                        String publicId,
                        String systemId,
                        String notationName)
                 throws SAXException
        Receive notification of an unparsed entity declaration event.

        Note that the notation name corresponds to a notation reported by the notationDecl event. It is up to the application to record the entity for later reference, if necessary; unparsed entities may appear as attribute values.

        If the system identifier is a URL, the parser must resolve it fully before passing it to the application.

        Parameters:
        name - The unparsed entity's name.
        publicId - The entity's public identifier, or null if none was given.
        systemId - The entity's system identifier.
        notationName - The name of the associated notation.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        notationDecl(java.lang.String, java.lang.String, java.lang.String), Attributes
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EntityResolver (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax

Interface EntityResolver

  • All Known Subinterfaces:
    EntityResolver2
    All Known Implementing Classes:
    DefaultHandler, DefaultHandler2, HandlerBase, XMLFilterImpl

    public interface EntityResolver
    Basic interface for resolving entities.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    If a SAX application needs to implement customized handling for external entities, it must implement this interface and register an instance with the SAX driver using the setEntityResolver method.

    The XML reader will then allow the application to intercept any external entities (including the external DTD subset and external parameter entities, if any) before including them.

    Many SAX applications will not need to implement this interface, but it will be especially useful for applications that build XML documents from databases or other specialised input sources, or for applications that use URI types other than URLs.

    The following resolver would provide the application with a special character stream for the entity with the system identifier "http://www.myhost.com/today":

     import org.xml.sax.EntityResolver;
 import org.xml.sax.InputSource;

 public class MyResolver implements EntityResolver {
   public InputSource resolveEntity (String publicId, String systemId)
   {
     if (systemId.equals("http://www.myhost.com/today")) {
              // return a special input source
       MyReader reader = new MyReader();
       return new InputSource(reader);
     } else {
              // use the default behaviour
       return null;
     }
   }
 }

    The application can also use this interface to redirect system identifiers to local URIs or to look up replacements in a catalog (possibly by using the public identifier).

    Since:
    SAX 1.0
    See Also:
    XMLReader.setEntityResolver(org.xml.sax.EntityResolver), InputSource

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      InputSource resolveEntity(String publicId, String systemId)
      Allow the application to resolve external entities.

    • Method Detail

      • resolveEntity

        InputSource resolveEntity(String publicId,
                          String systemId)
                   throws SAXException,
                          IOException
        Allow the application to resolve external entities.

        The parser will call this method before opening any external entity except the top-level document entity. Such entities include the external DTD subset and external parameter entities referenced within the DTD (in either case, only if the parser reads external parameter entities), and external general entities referenced within the document element (if the parser reads external general entities). The application may request that the parser locate the entity itself, that it use an alternative URI, or that it use data provided by the application (as a character or byte input stream).

        Application writers can use this method to redirect external system identifiers to secure and/or local URIs, to look up public identifiers in a catalogue, or to read an entity from a database or other input source (including, for example, a dialog box). Neither XML nor SAX specifies a preferred policy for using public or system IDs to resolve resources. However, SAX specifies how to interpret any InputSource returned by this method, and that if none is returned, then the system ID will be dereferenced as a URL.

        If the system identifier is a URL, the SAX parser must resolve it fully before reporting it to the application.

        Parameters:
        publicId - The public identifier of the external entity being referenced, or null if none was supplied.
        systemId - The system identifier of the external entity being referenced.
        Returns:
        An InputSource object describing the new input source, or null to request that the parser open a regular URI connection to the system identifier.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        IOException - A Java-specific IO exception, possibly the result of creating a new InputStream or Reader for the InputSource.
        See Also:
        InputSource
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ErrorHandler (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax

Interface ErrorHandler

  • All Known Implementing Classes:
    DefaultHandler, DefaultHandler2, HandlerBase, XMLFilterImpl

    public interface ErrorHandler
    Basic interface for SAX error handlers.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    If a SAX application needs to implement customized error handling, it must implement this interface and then register an instance with the XML reader using the setErrorHandler method. The parser will then report all errors and warnings through this interface.

    WARNING: If an application does not register an ErrorHandler, XML parsing errors will go unreported, except that SAXParseExceptions will be thrown for fatal errors. In order to detect validity errors, an ErrorHandler that does something with error() calls must be registered.

    For XML processing errors, a SAX driver must use this interface in preference to throwing an exception: it is up to the application to decide whether to throw an exception for different types of errors and warnings. Note, however, that there is no requirement that the parser continue to report additional errors after a call to fatalError. In other words, a SAX driver class may throw an exception after reporting any fatalError. Also parsers may throw appropriate exceptions for non-XML errors. For example, XMLReader.parse() would throw an IOException for errors accessing entities or the document.

    Since:
    SAX 1.0
    See Also:
    XMLReader.setErrorHandler(org.xml.sax.ErrorHandler), SAXParseException

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void error(SAXParseException exception)
      Receive notification of a recoverable error.
      void fatalError(SAXParseException exception)
      Receive notification of a non-recoverable error.
      void warning(SAXParseException exception)
      Receive notification of a warning.

    • Method Detail

      • warning

        void warning(SAXParseException exception)
      throws SAXException
        Receive notification of a warning.

        SAX parsers will use this method to report conditions that are not errors or fatal errors as defined by the XML recommendation. The default behaviour is to take no action.

        The SAX parser must continue to provide normal parsing events after invoking this method: it should still be possible for the application to process the document through to the end.

        Filters may use this method to report other, non-XML warnings as well.

        Parameters:
        exception - The warning information encapsulated in a SAX parse exception.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        SAXParseException

      • error

        void error(SAXParseException exception)
    throws SAXException
        Receive notification of a recoverable error.

        This corresponds to the definition of "error" in section 1.2 of the W3C XML 1.0 Recommendation. For example, a validating parser would use this callback to report the violation of a validity constraint. The default behaviour is to take no action.

        The SAX parser must continue to provide normal parsing events after invoking this method: it should still be possible for the application to process the document through to the end. If the application cannot do so, then the parser should report a fatal error even if the XML recommendation does not require it to do so.

        Filters may use this method to report other, non-XML errors as well.

        Parameters:
        exception - The error information encapsulated in a SAX parse exception.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        SAXParseException

      • fatalError

        void fatalError(SAXParseException exception)
         throws SAXException
        Receive notification of a non-recoverable error.

        There is an apparent contradiction between the documentation for this method and the documentation for ContentHandler.endDocument(). Until this ambiguity is resolved in a future major release, clients should make no assumptions about whether endDocument() will or will not be invoked when the parser has reported a fatalError() or thrown an exception.

        This corresponds to the definition of "fatal error" in section 1.2 of the W3C XML 1.0 Recommendation. For example, a parser would use this callback to report the violation of a well-formedness constraint.

        The application must assume that the document is unusable after the parser has invoked this method, and should continue (if at all) only for the sake of collecting additional error messages: in fact, SAX parsers are free to stop reporting any other events once this method has been invoked.

        Parameters:
        exception - The error information encapsulated in a SAX parse exception.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        SAXParseException
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Attributes2 (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax.ext

Interface Attributes2

  • All Superinterfaces:
    Attributes
    All Known Implementing Classes:
    Attributes2Impl

    public interface Attributes2
extends Attributes
    SAX2 extension to augment the per-attribute information provided though Attributes. If an implementation supports this extension, the attributes provided in ContentHandler.startElement() will implement this interface, and the http://xml.org/sax/features/use-attributes2 feature flag will have the value true.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY.

    XMLReader implementations are not required to support this information, and it is not part of core-only SAX2 distributions.

    Note that if an attribute was defaulted (!isSpecified()) it will of necessity also have been declared (isDeclared()) in the DTD. Similarly if an attribute's type is anything except CDATA, then it must have been declared.

    Since:
    SAX 2.0 (extensions 1.1 alpha)

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      boolean isDeclared(int index)
      Returns false unless the attribute was declared in the DTD.
      boolean isDeclared(String qName)
      Returns false unless the attribute was declared in the DTD.
      boolean isDeclared(String uri, String localName)
      Returns false unless the attribute was declared in the DTD.
      boolean isSpecified(int index)
      Returns true unless the attribute value was provided by DTD defaulting.
      boolean isSpecified(String qName)
      Returns true unless the attribute value was provided by DTD defaulting.
      boolean isSpecified(String uri, String localName)
      Returns true unless the attribute value was provided by DTD defaulting.

      • Methods inherited from interface org.xml.sax.Attributes

        getIndex, getIndex, getLength, getLocalName, getQName, getType, getType, getType, getURI, getValue, getValue, getValue

    • Method Detail

      • isDeclared

        boolean isDeclared(int index)
        Returns false unless the attribute was declared in the DTD. This helps distinguish two kinds of attributes that SAX reports as CDATA: ones that were declared (and hence are usually valid), and those that were not (and which are never valid).
        Parameters:
        index - The attribute index (zero-based).
        Returns:
        true if the attribute was declared in the DTD, false otherwise.
        Throws:
        ArrayIndexOutOfBoundsException - When the supplied index does not identify an attribute.

      • isDeclared

        boolean isDeclared(String qName)
        Returns false unless the attribute was declared in the DTD. This helps distinguish two kinds of attributes that SAX reports as CDATA: ones that were declared (and hence are usually valid), and those that were not (and which are never valid).
        Parameters:
        qName - The XML qualified (prefixed) name.
        Returns:
        true if the attribute was declared in the DTD, false otherwise.
        Throws:
        IllegalArgumentException - When the supplied name does not identify an attribute.

      • isDeclared

        boolean isDeclared(String uri,
                   String localName)
        Returns false unless the attribute was declared in the DTD. This helps distinguish two kinds of attributes that SAX reports as CDATA: ones that were declared (and hence are usually valid), and those that were not (and which are never valid).

        Remember that since DTDs do not "understand" namespaces, the namespace URI associated with an attribute may not have come from the DTD. The declaration will have applied to the attribute's qName.

        Parameters:
        uri - The Namespace URI, or the empty string if the name has no Namespace URI.
        localName - The attribute's local name.
        Returns:
        true if the attribute was declared in the DTD, false otherwise.
        Throws:
        IllegalArgumentException - When the supplied names do not identify an attribute.

      • isSpecified

        boolean isSpecified(int index)
        Returns true unless the attribute value was provided by DTD defaulting.
        Parameters:
        index - The attribute index (zero-based).
        Returns:
        true if the value was found in the XML text, false if the value was provided by DTD defaulting.
        Throws:
        ArrayIndexOutOfBoundsException - When the supplied index does not identify an attribute.

      • isSpecified

        boolean isSpecified(String uri,
                    String localName)
        Returns true unless the attribute value was provided by DTD defaulting.

        Remember that since DTDs do not "understand" namespaces, the namespace URI associated with an attribute may not have come from the DTD. The declaration will have applied to the attribute's qName.

        Parameters:
        uri - The Namespace URI, or the empty string if the name has no Namespace URI.
        localName - The attribute's local name.
        Returns:
        true if the value was found in the XML text, false if the value was provided by DTD defaulting.
        Throws:
        IllegalArgumentException - When the supplied names do not identify an attribute.

      • isSpecified

        boolean isSpecified(String qName)
        Returns true unless the attribute value was provided by DTD defaulting.
        Parameters:
        qName - The XML qualified (prefixed) name.
        Returns:
        true if the value was found in the XML text, false if the value was provided by DTD defaulting.
        Throws:
        IllegalArgumentException - When the supplied name does not identify an attribute.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Attributes2Impl (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax.ext

Class Attributes2Impl

  • java.lang.Object
    • org.xml.sax.helpers.AttributesImpl
      • org.xml.sax.ext.Attributes2Impl
  • All Implemented Interfaces:
    Attributes, Attributes2

    public class Attributes2Impl
extends AttributesImpl
implements Attributes2
    SAX2 extension helper for additional Attributes information, implementing the Attributes2 interface.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY.

    This is not part of core-only SAX2 distributions.

    The specified flag for each attribute will always be true, unless it has been set to false in the copy constructor or using setSpecified(int, boolean). Similarly, the declared flag for each attribute will always be false, except for defaulted attributes (specified is false), non-CDATA attributes, or when it is set to true using setDeclared(int, boolean). If you change an attribute's type by hand, you may need to modify its declared flag to match.

    Since:
    SAX 2.0 (extensions 1.1 alpha)

    • Constructor Summary

      Constructors
      Constructor and Description
      Attributes2Impl()
      Construct a new, empty Attributes2Impl object.
      Attributes2Impl(Attributes atts)
      Copy an existing Attributes or Attributes2 object.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void addAttribute(String uri, String localName, String qName, String type, String value)
      Add an attribute to the end of the list, setting its "specified" flag to true.
      boolean isDeclared(int index)
      Returns the current value of the attribute's "declared" flag.
      boolean isDeclared(String qName)
      Returns the current value of the attribute's "declared" flag.
      boolean isDeclared(String uri, String localName)
      Returns the current value of the attribute's "declared" flag.
      boolean isSpecified(int index)
      Returns the current value of an attribute's "specified" flag.
      boolean isSpecified(String qName)
      Returns the current value of an attribute's "specified" flag.
      boolean isSpecified(String uri, String localName)
      Returns the current value of an attribute's "specified" flag.
      void removeAttribute(int index)
      Remove an attribute from the list.
      void setAttributes(Attributes atts)
      Copy an entire Attributes object.
      void setDeclared(int index, boolean value)
      Assign a value to the "declared" flag of a specific attribute.
      void setSpecified(int index, boolean value)
      Assign a value to the "specified" flag of a specific attribute.

      • Methods inherited from class org.xml.sax.helpers.AttributesImpl

        clear, getIndex, getIndex, getLength, getLocalName, getQName, getType, getType, getType, getURI, getValue, getValue, getValue, setAttribute, setLocalName, setQName, setType, setURI, setValue

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface org.xml.sax.Attributes

        getIndex, getIndex, getLength, getLocalName, getQName, getType, getType, getType, getURI, getValue, getValue, getValue

    • Constructor Detail

      • Attributes2Impl

        public Attributes2Impl()
        Construct a new, empty Attributes2Impl object.

      • Attributes2Impl

        public Attributes2Impl(Attributes atts)
        Copy an existing Attributes or Attributes2 object. If the object implements Attributes2, values of the specified and declared flags for each attribute are copied. Otherwise the flag values are defaulted to assume no DTD was used, unless there is evidence to the contrary (such as attributes with type other than CDATA, which must have been declared).

        This constructor is especially useful inside a startElement event.

        Parameters:
        atts - The existing Attributes object.

    • Method Detail

      • isDeclared

        public boolean isDeclared(int index)
        Returns the current value of the attribute's "declared" flag.
        Specified by:
        isDeclared in interface Attributes2
        Parameters:
        index - The attribute index (zero-based).
        Returns:
        true if the attribute was declared in the DTD, false otherwise.

      • isDeclared

        public boolean isDeclared(String uri,
                          String localName)
        Returns the current value of the attribute's "declared" flag.
        Specified by:
        isDeclared in interface Attributes2
        Parameters:
        uri - The Namespace URI, or the empty string if the name has no Namespace URI.
        localName - The attribute's local name.
        Returns:
        true if the attribute was declared in the DTD, false otherwise.

      • isDeclared

        public boolean isDeclared(String qName)
        Returns the current value of the attribute's "declared" flag.
        Specified by:
        isDeclared in interface Attributes2
        Parameters:
        qName - The XML qualified (prefixed) name.
        Returns:
        true if the attribute was declared in the DTD, false otherwise.

      • isSpecified

        public boolean isSpecified(int index)
        Returns the current value of an attribute's "specified" flag.
        Specified by:
        isSpecified in interface Attributes2
        Parameters:
        index - The attribute index (zero-based).
        Returns:
        current flag value
        Throws:
        ArrayIndexOutOfBoundsException - When the supplied index does not identify an attribute.

      • isSpecified

        public boolean isSpecified(String uri,
                           String localName)
        Returns the current value of an attribute's "specified" flag.
        Specified by:
        isSpecified in interface Attributes2
        Parameters:
        uri - The Namespace URI, or the empty string if the name has no Namespace URI.
        localName - The attribute's local name.
        Returns:
        current flag value
        Throws:
        IllegalArgumentException - When the supplied names do not identify an attribute.

      • isSpecified

        public boolean isSpecified(String qName)
        Returns the current value of an attribute's "specified" flag.
        Specified by:
        isSpecified in interface Attributes2
        Parameters:
        qName - The XML qualified (prefixed) name.
        Returns:
        current flag value
        Throws:
        IllegalArgumentException - When the supplied name does not identify an attribute.

      • setAttributes

        public void setAttributes(Attributes atts)
        Copy an entire Attributes object. The "specified" flags are assigned as true, and "declared" flags as false (except when an attribute's type is not CDATA), unless the object is an Attributes2 object. In that case those flag values are all copied.
        Overrides:
        setAttributes in class AttributesImpl
        Parameters:
        atts - The attributes to copy.
        See Also:
        AttributesImpl.setAttributes(org.xml.sax.Attributes)

      • addAttribute

        public void addAttribute(String uri,
                         String localName,
                         String qName,
                         String type,
                         String value)
        Add an attribute to the end of the list, setting its "specified" flag to true. To set that flag's value to false, use setSpecified(int, boolean).

        Unless the attribute type is CDATA, this attribute is marked as being declared in the DTD. To set that flag's value to true for CDATA attributes, use setDeclared(int, boolean).

        Overrides:
        addAttribute in class AttributesImpl
        Parameters:
        uri - The Namespace URI, or the empty string if none is available or Namespace processing is not being performed.
        localName - The local name, or the empty string if Namespace processing is not being performed.
        qName - The qualified (prefixed) name, or the empty string if qualified names are not available.
        type - The attribute type as a string.
        value - The attribute value.
        See Also:
        AttributesImpl.addAttribute(java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String)

      • removeAttribute

        public void removeAttribute(int index)
        Description copied from class: AttributesImpl
        Remove an attribute from the list.
        Overrides:
        removeAttribute in class AttributesImpl
        Parameters:
        index - The index of the attribute (zero-based).

      • setDeclared

        public void setDeclared(int index,
                        boolean value)
        Assign a value to the "declared" flag of a specific attribute. This is normally needed only for attributes of type CDATA, including attributes whose type is changed to or from CDATA.
        Parameters:
        index - The index of the attribute (zero-based).
        value - The desired flag value.
        Throws:
        ArrayIndexOutOfBoundsException - When the supplied index does not identify an attribute.
        See Also:
        AttributesImpl.setType(int, java.lang.String)

      • setSpecified

        public void setSpecified(int index,
                         boolean value)
        Assign a value to the "specified" flag of a specific attribute. This is the only way this flag can be cleared, except clearing by initialization with the copy constructor.
        Parameters:
        index - The index of the attribute (zero-based).
        value - The desired flag value.
        Throws:
        ArrayIndexOutOfBoundsException - When the supplied index does not identify an attribute.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Interface org.xml.sax.ext.Attributes2 (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.xml.sax.ext.Attributes2

  • Packages that use Attributes2
    Package Description
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

    • Uses of Attributes2 in org.xml.sax.ext

      Classes in org.xml.sax.ext that implement Attributes2
      Modifier and Type Class and Description
      class  Attributes2Impl
      SAX2 extension helper for additional Attributes information, implementing the Attributes2 interface.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.xml.sax.ext.Attributes2Impl (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.xml.sax.ext.Attributes2Impl

No usage of org.xml.sax.ext.Attributes2Impl
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.xml.sax.ext.DeclHandler (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.xml.sax.ext.DeclHandler

  • Packages that use DeclHandler
    Package Description
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

    • Uses of DeclHandler in org.xml.sax.ext

      Classes in org.xml.sax.ext that implement DeclHandler
      Modifier and Type Class and Description
      class  DefaultHandler2
      This class extends the SAX2 base handler class to support the SAX2 LexicalHandler, DeclHandler, and EntityResolver2 extensions.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.xml.sax.ext.DefaultHandler2 (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.xml.sax.ext.DefaultHandler2

No usage of org.xml.sax.ext.DefaultHandler2
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.xml.sax.ext.EntityResolver2 (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.xml.sax.ext.EntityResolver2

  • Packages that use EntityResolver2
    Package Description
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

    • Uses of EntityResolver2 in org.xml.sax.ext

      Classes in org.xml.sax.ext that implement EntityResolver2
      Modifier and Type Class and Description
      class  DefaultHandler2
      This class extends the SAX2 base handler class to support the SAX2 LexicalHandler, DeclHandler, and EntityResolver2 extensions.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.xml.sax.ext.LexicalHandler (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.xml.sax.ext.LexicalHandler

  • Packages that use LexicalHandler
    Package Description
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

    • Uses of LexicalHandler in javax.xml.transform.sax

      Subinterfaces of LexicalHandler in javax.xml.transform.sax
      Modifier and Type Interface and Description
      interface  TransformerHandler
      A TransformerHandler listens for SAX ContentHandler parse events and transforms them to a Result.
      Methods in javax.xml.transform.sax that return LexicalHandler
      Modifier and Type Method and Description
      LexicalHandler SAXResult.getLexicalHandler()
      Get a SAX2 LexicalHandler for the output.
      Methods in javax.xml.transform.sax with parameters of type LexicalHandler
      Modifier and Type Method and Description
      void SAXResult.setLexicalHandler(LexicalHandler handler)
      Set the SAX2 LexicalHandler for the output.

    • Uses of LexicalHandler in org.xml.sax.ext

      Classes in org.xml.sax.ext that implement LexicalHandler
      Modifier and Type Class and Description
      class  DefaultHandler2
      This class extends the SAX2 base handler class to support the SAX2 LexicalHandler, DeclHandler, and EntityResolver2 extensions.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Interface org.xml.sax.ext.Locator2 (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Interface
org.xml.sax.ext.Locator2

  • Packages that use Locator2
    Package Description
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

    • Uses of Locator2 in org.xml.sax.ext

      Classes in org.xml.sax.ext that implement Locator2
      Modifier and Type Class and Description
      class  Locator2Impl
      SAX2 extension helper for holding additional Entity information, implementing the Locator2 interface.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.xml.sax.ext.Locator2Impl (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.xml.sax.ext.Locator2Impl

No usage of org.xml.sax.ext.Locator2Impl
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


compact2 - org.xml.sax.ext (Java Platform SE 8 )

compact2 - org.xml.sax.ext

Interfaces

  • Attributes2
  • DeclHandler
  • EntityResolver2
  • LexicalHandler
  • Locator2

Classes

  • Attributes2Impl
  • DefaultHandler2
  • Locator2Impl


org.xml.sax.ext (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact2

Package org.xml.sax.ext

This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

See: Description

  • Interface Summary
    Interface Description
    Attributes2
    SAX2 extension to augment the per-attribute information provided though Attributes.
    DeclHandler
    SAX2 extension handler for DTD declaration events.
    EntityResolver2
    Extended interface for mapping external entity references to input sources, or providing a missing external subset.
    LexicalHandler
    SAX2 extension handler for lexical events.
    Locator2
    SAX2 extension to augment the entity information provided though a Locator.
  • Class Summary
    Class Description
    Attributes2Impl
    SAX2 extension helper for additional Attributes information, implementing the Attributes2 interface.
    DefaultHandler2
    This class extends the SAX2 base handler class to support the SAX2 LexicalHandler, DeclHandler, and EntityResolver2 extensions.
    Locator2Impl
    SAX2 extension helper for holding additional Entity information, implementing the Locator2 interface.

Package org.xml.sax.ext Description

This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

See http://www.saxproject.org for more information about SAX.

This package is independent of the SAX2 core, though the functionality exposed generally needs to be implemented within a parser core. That independence has several consequences:

  • SAX2 drivers are not required to recognize these handlers.
  • You cannot assume that the class files will be present in every SAX2 installation.
  • This package may be updated independently of SAX2 (i.e. new handlers and classes may be added without updating SAX2 itself).
  • The new handlers are not implemented by the SAX2 org.xml.sax.helpers.DefaultHandler or org.xml.sax.helpers.XMLFilterImpl classes. You can subclass these if you need such behavior, or use the helper classes found here.
  • The handlers need to be registered differently than core SAX2 handlers.

This package, SAX2-ext, is a standardized extension to SAX2. It is designed both to allow SAX parsers to pass certain types of information to applications, and to serve as a simple model for other SAX2 parser extension packages. Not all such extension packages should need to be recognized directly by parsers, however. As an example, most validation systems can be cleanly layered on top of parsers supporting the standardized SAX2 interfaces.

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames


compact3 - org.xml.sax.ext (Java Platform SE 8 )

compact3 - org.xml.sax.ext

Interfaces

  • Attributes2
  • DeclHandler
  • EntityResolver2
  • LexicalHandler
  • Locator2

Classes

  • Attributes2Impl
  • DefaultHandler2
  • Locator2Impl


org.xml.sax.ext (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package org.xml.sax.ext

This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

See: Description

  • Interface Summary
    Interface Description
    Attributes2
    SAX2 extension to augment the per-attribute information provided though Attributes.
    DeclHandler
    SAX2 extension handler for DTD declaration events.
    EntityResolver2
    Extended interface for mapping external entity references to input sources, or providing a missing external subset.
    LexicalHandler
    SAX2 extension handler for lexical events.
    Locator2
    SAX2 extension to augment the entity information provided though a Locator.
  • Class Summary
    Class Description
    Attributes2Impl
    SAX2 extension helper for additional Attributes information, implementing the Attributes2 interface.
    DefaultHandler2
    This class extends the SAX2 base handler class to support the SAX2 LexicalHandler, DeclHandler, and EntityResolver2 extensions.
    Locator2Impl
    SAX2 extension helper for holding additional Entity information, implementing the Locator2 interface.

Package org.xml.sax.ext Description

This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

See http://www.saxproject.org for more information about SAX.

This package is independent of the SAX2 core, though the functionality exposed generally needs to be implemented within a parser core. That independence has several consequences:

  • SAX2 drivers are not required to recognize these handlers.
  • You cannot assume that the class files will be present in every SAX2 installation.
  • This package may be updated independently of SAX2 (i.e. new handlers and classes may be added without updating SAX2 itself).
  • The new handlers are not implemented by the SAX2 org.xml.sax.helpers.DefaultHandler or org.xml.sax.helpers.XMLFilterImpl classes. You can subclass these if you need such behavior, or use the helper classes found here.
  • The handlers need to be registered differently than core SAX2 handlers.

This package, SAX2-ext, is a standardized extension to SAX2. It is designed both to allow SAX parsers to pass certain types of information to applications, and to serve as a simple model for other SAX2 parser extension packages. Not all such extension packages should need to be recognized directly by parsers, however. As an example, most validation systems can be cleanly layered on top of parsers supporting the standardized SAX2 interfaces.

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames


DeclHandler (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax.ext

Interface DeclHandler

  • All Known Implementing Classes:
    DefaultHandler2

    public interface DeclHandler
    SAX2 extension handler for DTD declaration events.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This is an optional extension handler for SAX2 to provide more complete information about DTD declarations in an XML document. XML readers are not required to recognize this handler, and it is not part of core-only SAX2 distributions.

    Note that data-related DTD declarations (unparsed entities and notations) are already reported through the DTDHandler interface.

    If you are using the declaration handler together with a lexical handler, all of the events will occur between the startDTD and the endDTD events.

    To set the DeclHandler for an XML reader, use the setProperty method with the property name http://xml.org/sax/properties/declaration-handler and an object implementing this interface (or null) as the value. If the reader does not report declaration events, it will throw a SAXNotRecognizedException when you attempt to register the handler.

    Since:
    SAX 2.0 (extensions 1.0)

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void attributeDecl(String eName, String aName, String type, String mode, String value)
      Report an attribute type declaration.
      void elementDecl(String name, String model)
      Report an element type declaration.
      void externalEntityDecl(String name, String publicId, String systemId)
      Report a parsed external entity declaration.
      void internalEntityDecl(String name, String value)
      Report an internal entity declaration.

    • Method Detail

      • elementDecl

        void elementDecl(String name,
                 String model)
          throws SAXException
        Report an element type declaration.

        The content model will consist of the string "EMPTY", the string "ANY", or a parenthesised group, optionally followed by an occurrence indicator. The model will be normalized so that all parameter entities are fully resolved and all whitespace is removed,and will include the enclosing parentheses. Other normalization (such as removing redundant parentheses or simplifying occurrence indicators) is at the discretion of the parser.

        Parameters:
        name - The element type name.
        model - The content model as a normalized string.
        Throws:
        SAXException - The application may raise an exception.

      • attributeDecl

        void attributeDecl(String eName,
                   String aName,
                   String type,
                   String mode,
                   String value)
            throws SAXException
        Report an attribute type declaration.

        Only the effective (first) declaration for an attribute will be reported. The type will be one of the strings "CDATA", "ID", "IDREF", "IDREFS", "NMTOKEN", "NMTOKENS", "ENTITY", "ENTITIES", a parenthesized token group with the separator "|" and all whitespace removed, or the word "NOTATION" followed by a space followed by a parenthesized token group with all whitespace removed.

        The value will be the value as reported to applications, appropriately normalized and with entity and character references expanded.

        Parameters:
        eName - The name of the associated element.
        aName - The name of the attribute.
        type - A string representing the attribute type.
        mode - A string representing the attribute defaulting mode ("#IMPLIED", "#REQUIRED", or "#FIXED") or null if none of these applies.
        value - A string representing the attribute's default value, or null if there is none.
        Throws:
        SAXException - The application may raise an exception.

      • internalEntityDecl

        void internalEntityDecl(String name,
                        String value)
                 throws SAXException
        Report an internal entity declaration.

        Only the effective (first) declaration for each entity will be reported. All parameter entities in the value will be expanded, but general entities will not.

        Parameters:
        name - The name of the entity. If it is a parameter entity, the name will begin with '%'.
        value - The replacement text of the entity.
        Throws:
        SAXException - The application may raise an exception.
        See Also:
        externalEntityDecl(java.lang.String, java.lang.String, java.lang.String), DTDHandler.unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String)

      • externalEntityDecl

        void externalEntityDecl(String name,
                        String publicId,
                        String systemId)
                 throws SAXException
        Report a parsed external entity declaration.

        Only the effective (first) declaration for each entity will be reported.

        If the system identifier is a URL, the parser must resolve it fully before passing it to the application.

        Parameters:
        name - The name of the entity. If it is a parameter entity, the name will begin with '%'.
        publicId - The entity's public identifier, or null if none was given.
        systemId - The entity's system identifier.
        Throws:
        SAXException - The application may raise an exception.
        See Also:
        internalEntityDecl(java.lang.String, java.lang.String), DTDHandler.unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


DefaultHandler2 (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax.ext

Class DefaultHandler2

  • java.lang.Object
    • org.xml.sax.helpers.DefaultHandler
      • org.xml.sax.ext.DefaultHandler2
  • All Implemented Interfaces:
    ContentHandler, DTDHandler, EntityResolver, ErrorHandler, DeclHandler, EntityResolver2, LexicalHandler

    public class DefaultHandler2
extends DefaultHandler
implements LexicalHandler, DeclHandler, EntityResolver2
    This class extends the SAX2 base handler class to support the SAX2 LexicalHandler, DeclHandler, and EntityResolver2 extensions. Except for overriding the original SAX1 resolveEntity() method the added handler methods just return. Subclassers may override everything on a method-by-method basis.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY.

    Note: this class might yet learn that the ContentHandler.setDocumentLocator() call might be passed a Locator2 object, and that the ContentHandler.startElement() call might be passed a Attributes2 object.

    Since:
    SAX 2.0 (extensions 1.1 alpha)

    • Constructor Summary

      Constructors
      Constructor and Description
      DefaultHandler2()
      Constructs a handler which ignores all parsing events.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void attributeDecl(String eName, String aName, String type, String mode, String value)
      Report an attribute type declaration.
      void comment(char[] ch, int start, int length)
      Report an XML comment anywhere in the document.
      void elementDecl(String name, String model)
      Report an element type declaration.
      void endCDATA()
      Report the end of a CDATA section.
      void endDTD()
      Report the end of DTD declarations.
      void endEntity(String name)
      Report the end of an entity.
      void externalEntityDecl(String name, String publicId, String systemId)
      Report a parsed external entity declaration.
      InputSource getExternalSubset(String name, String baseURI)
      Tells the parser that if no external subset has been declared in the document text, none should be used.
      void internalEntityDecl(String name, String value)
      Report an internal entity declaration.
      InputSource resolveEntity(String publicId, String systemId)
      Invokes EntityResolver2.resolveEntity() with null entity name and base URI.
      InputSource resolveEntity(String name, String publicId, String baseURI, String systemId)
      Tells the parser to resolve the systemId against the baseURI and read the entity text from that resulting absolute URI.
      void startCDATA()
      Report the start of a CDATA section.
      void startDTD(String name, String publicId, String systemId)
      Report the start of DTD declarations, if any.
      void startEntity(String name)
      Report the beginning of some internal and external XML entities.

      • Methods inherited from class org.xml.sax.helpers.DefaultHandler

        characters, endDocument, endElement, endPrefixMapping, error, fatalError, ignorableWhitespace, notationDecl, processingInstruction, setDocumentLocator, skippedEntity, startDocument, startElement, startPrefixMapping, unparsedEntityDecl, warning

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • DefaultHandler2

        public DefaultHandler2()
        Constructs a handler which ignores all parsing events.

    • Method Detail

      • startCDATA

        public void startCDATA()
                throws SAXException
        Description copied from interface: LexicalHandler
        Report the start of a CDATA section.

        The contents of the CDATA section will be reported through the regular characters event; this event is intended only to report the boundary.

        Specified by:
        startCDATA in interface LexicalHandler
        Throws:
        SAXException - The application may raise an exception.
        See Also:
        LexicalHandler.endCDATA()

      • endCDATA

        public void endCDATA()
              throws SAXException
        Description copied from interface: LexicalHandler
        Report the end of a CDATA section.
        Specified by:
        endCDATA in interface LexicalHandler
        Throws:
        SAXException - The application may raise an exception.
        See Also:
        LexicalHandler.startCDATA()

      • startDTD

        public void startDTD(String name,
                     String publicId,
                     String systemId)
              throws SAXException
        Description copied from interface: LexicalHandler
        Report the start of DTD declarations, if any.

        This method is intended to report the beginning of the DOCTYPE declaration; if the document has no DOCTYPE declaration, this method will not be invoked.

        All declarations reported through DTDHandler or DeclHandler events must appear between the startDTD and endDTD events. Declarations are assumed to belong to the internal DTD subset unless they appear between startEntity and endEntity events. Comments and processing instructions from the DTD should also be reported between the startDTD and endDTD events, in their original order of (logical) occurrence; they are not required to appear in their correct locations relative to DTDHandler or DeclHandler events, however.

        Note that the start/endDTD events will appear within the start/endDocument events from ContentHandler and before the first startElement event.

        Specified by:
        startDTD in interface LexicalHandler
        Parameters:
        name - The document type name.
        publicId - The declared public identifier for the external DTD subset, or null if none was declared.
        systemId - The declared system identifier for the external DTD subset, or null if none was declared. (Note that this is not resolved against the document base URI.)
        Throws:
        SAXException - The application may raise an exception.
        See Also:
        LexicalHandler.endDTD(), LexicalHandler.startEntity(java.lang.String)

      • endDTD

        public void endDTD()
            throws SAXException
        Description copied from interface: LexicalHandler
        Report the end of DTD declarations.

        This method is intended to report the end of the DOCTYPE declaration; if the document has no DOCTYPE declaration, this method will not be invoked.

        Specified by:
        endDTD in interface LexicalHandler
        Throws:
        SAXException - The application may raise an exception.
        See Also:
        LexicalHandler.startDTD(java.lang.String, java.lang.String, java.lang.String)

      • startEntity

        public void startEntity(String name)
                 throws SAXException
        Description copied from interface: LexicalHandler
        Report the beginning of some internal and external XML entities.

        The reporting of parameter entities (including the external DTD subset) is optional, and SAX2 drivers that report LexicalHandler events may not implement it; you can use the http://xml.org/sax/features/lexical-handler/parameter-entities feature to query or control the reporting of parameter entities.

        General entities are reported with their regular names, parameter entities have '%' prepended to their names, and the external DTD subset has the pseudo-entity name "[dtd]".

        When a SAX2 driver is providing these events, all other events must be properly nested within start/end entity events. There is no additional requirement that events from DeclHandler or DTDHandler be properly ordered.

        Note that skipped entities will be reported through the skippedEntity event, which is part of the ContentHandler interface.

        Because of the streaming event model that SAX uses, some entity boundaries cannot be reported under any circumstances:

        • general entities within attribute values
        • parameter entities within declarations

        These will be silently expanded, with no indication of where the original entity boundaries were.

        Note also that the boundaries of character references (which are not really entities anyway) are not reported.

        All start/endEntity events must be properly nested.

        Specified by:
        startEntity in interface LexicalHandler
        Parameters:
        name - The name of the entity. If it is a parameter entity, the name will begin with '%', and if it is the external DTD subset, it will be "[dtd]".
        Throws:
        SAXException - The application may raise an exception.
        See Also:
        LexicalHandler.endEntity(java.lang.String),
DeclHandler.internalEntityDecl(java.lang.String, java.lang.String),
DeclHandler.externalEntityDecl(java.lang.String, java.lang.String, java.lang.String)

      • endEntity

        public void endEntity(String name)
               throws SAXException
        Description copied from interface: LexicalHandler
        Report the end of an entity.
        Specified by:
        endEntity in interface LexicalHandler
        Parameters:
        name - The name of the entity that is ending.
        Throws:
        SAXException - The application may raise an exception.
        See Also:
        LexicalHandler.startEntity(java.lang.String)

      • comment

        public void comment(char[] ch,
                    int start,
                    int length)
             throws SAXException
        Description copied from interface: LexicalHandler
        Report an XML comment anywhere in the document.

        This callback will be used for comments inside or outside the document element, including comments in the external DTD subset (if read). Comments in the DTD must be properly nested inside start/endDTD and start/endEntity events (if used).

        Specified by:
        comment in interface LexicalHandler
        Parameters:
        ch - An array holding the characters in the comment.
        start - The starting position in the array.
        length - The number of characters to use from the array.
        Throws:
        SAXException - The application may raise an exception.

      • attributeDecl

        public void attributeDecl(String eName,
                          String aName,
                          String type,
                          String mode,
                          String value)
                   throws SAXException
        Description copied from interface: DeclHandler
        Report an attribute type declaration.

        Only the effective (first) declaration for an attribute will be reported. The type will be one of the strings "CDATA", "ID", "IDREF", "IDREFS", "NMTOKEN", "NMTOKENS", "ENTITY", "ENTITIES", a parenthesized token group with the separator "|" and all whitespace removed, or the word "NOTATION" followed by a space followed by a parenthesized token group with all whitespace removed.

        The value will be the value as reported to applications, appropriately normalized and with entity and character references expanded.

        Specified by:
        attributeDecl in interface DeclHandler
        Parameters:
        eName - The name of the associated element.
        aName - The name of the attribute.
        type - A string representing the attribute type.
        mode - A string representing the attribute defaulting mode ("#IMPLIED", "#REQUIRED", or "#FIXED") or null if none of these applies.
        value - A string representing the attribute's default value, or null if there is none.
        Throws:
        SAXException - The application may raise an exception.

      • elementDecl

        public void elementDecl(String name,
                        String model)
                 throws SAXException
        Description copied from interface: DeclHandler
        Report an element type declaration.

        The content model will consist of the string "EMPTY", the string "ANY", or a parenthesised group, optionally followed by an occurrence indicator. The model will be normalized so that all parameter entities are fully resolved and all whitespace is removed,and will include the enclosing parentheses. Other normalization (such as removing redundant parentheses or simplifying occurrence indicators) is at the discretion of the parser.

        Specified by:
        elementDecl in interface DeclHandler
        Parameters:
        name - The element type name.
        model - The content model as a normalized string.
        Throws:
        SAXException - The application may raise an exception.

      • externalEntityDecl

        public void externalEntityDecl(String name,
                               String publicId,
                               String systemId)
                        throws SAXException
        Description copied from interface: DeclHandler
        Report a parsed external entity declaration.

        Only the effective (first) declaration for each entity will be reported.

        If the system identifier is a URL, the parser must resolve it fully before passing it to the application.

        Specified by:
        externalEntityDecl in interface DeclHandler
        Parameters:
        name - The name of the entity. If it is a parameter entity, the name will begin with '%'.
        publicId - The entity's public identifier, or null if none was given.
        systemId - The entity's system identifier.
        Throws:
        SAXException - The application may raise an exception.
        See Also:
        DeclHandler.internalEntityDecl(java.lang.String, java.lang.String), DTDHandler.unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String)

      • internalEntityDecl

        public void internalEntityDecl(String name,
                               String value)
                        throws SAXException
        Description copied from interface: DeclHandler
        Report an internal entity declaration.

        Only the effective (first) declaration for each entity will be reported. All parameter entities in the value will be expanded, but general entities will not.

        Specified by:
        internalEntityDecl in interface DeclHandler
        Parameters:
        name - The name of the entity. If it is a parameter entity, the name will begin with '%'.
        value - The replacement text of the entity.
        Throws:
        SAXException - The application may raise an exception.
        See Also:
        DeclHandler.externalEntityDecl(java.lang.String, java.lang.String, java.lang.String), DTDHandler.unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String)

      • getExternalSubset

        public InputSource getExternalSubset(String name,
                                     String baseURI)
                              throws SAXException,
                                     IOException
        Tells the parser that if no external subset has been declared in the document text, none should be used.
        Specified by:
        getExternalSubset in interface EntityResolver2
        Parameters:
        name - Identifies the document root element. This name comes from a DOCTYPE declaration (where available) or from the actual root element.
        baseURI - The document's base URI, serving as an additional hint for selecting the external subset. This is always an absolute URI, unless it is null because the XMLReader was given an InputSource without one.
        Returns:
        An InputSource object describing the new external subset to be used by the parser, or null to indicate that no external subset is provided.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        IOException - Probably indicating a failure to create a new InputStream or Reader, or an illegal URL.

      • resolveEntity

        public InputSource resolveEntity(String name,
                                 String publicId,
                                 String baseURI,
                                 String systemId)
                          throws SAXException,
                                 IOException
        Tells the parser to resolve the systemId against the baseURI and read the entity text from that resulting absolute URI. Note that because the older DefaultHandler.resolveEntity(), method is overridden to call this one, this method may sometimes be invoked with null name and baseURI, and with the systemId already absolutized.
        Specified by:
        resolveEntity in interface EntityResolver2
        Parameters:
        name - Identifies the external entity being resolved. Either "[dtd]" for the external subset, or a name starting with "%" to indicate a parameter entity, or else the name of a general entity. This is never null when invoked by a SAX2 parser.
        publicId - The public identifier of the external entity being referenced (normalized as required by the XML specification), or null if none was supplied.
        baseURI - The URI with respect to which relative systemIDs are interpreted. This is always an absolute URI, unless it is null (likely because the XMLReader was given an InputSource without one). This URI is defined by the XML specification to be the one associated with the "<" starting the relevant declaration.
        systemId - The system identifier of the external entity being referenced; either a relative or absolute URI. This is never null when invoked by a SAX2 parser; only declared entities, and any external subset, are resolved by such parsers.
        Returns:
        An InputSource object describing the new input source to be used by the parser. Returning null directs the parser to resolve the system ID against the base URI and open a connection to resulting URI.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        IOException - Probably indicating a failure to create a new InputStream or Reader, or an illegal URL.

      • resolveEntity

        public InputSource resolveEntity(String publicId,
                                 String systemId)
                          throws SAXException,
                                 IOException
        Invokes EntityResolver2.resolveEntity() with null entity name and base URI. You only need to override that method to use this class.
        Specified by:
        resolveEntity in interface EntityResolver
        Overrides:
        resolveEntity in class DefaultHandler
        Parameters:
        publicId - The public identifier, or null if none is available.
        systemId - The system identifier provided in the XML document.
        Returns:
        The new input source, or null to require the default behaviour.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        IOException - A Java-specific IO exception, possibly the result of creating a new InputStream or Reader for the InputSource.
        See Also:
        EntityResolver.resolveEntity(java.lang.String, java.lang.String)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


EntityResolver2 (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax.ext

Interface EntityResolver2

  • All Superinterfaces:
    EntityResolver
    All Known Implementing Classes:
    DefaultHandler2

    public interface EntityResolver2
extends EntityResolver
    Extended interface for mapping external entity references to input sources, or providing a missing external subset. The XMLReader.setEntityResolver() method is used to provide implementations of this interface to parsers. When a parser uses the methods in this interface, the EntityResolver2.resolveEntity() method (in this interface) is used instead of the older (SAX 1.0) EntityResolver.resolveEntity() method.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY.

    If a SAX application requires the customized handling which this interface defines for external entities, it must ensure that it uses an XMLReader with the http://xml.org/sax/features/use-entity-resolver2 feature flag set to true (which is its default value when the feature is recognized). If that flag is unrecognized, or its value is false, or the resolver does not implement this interface, then only the EntityResolver method will be used.

    That supports three categories of application that modify entity resolution. Old Style applications won't know about this interface; they will provide an EntityResolver. Transitional Mode provide an EntityResolver2 and automatically get the benefit of its methods in any systems (parsers or other tools) supporting it, due to polymorphism. Both Old Style and Transitional Mode applications will work with any SAX2 parser. New style applications will fail to run except on SAX2 parsers that support this particular feature. They will insist that feature flag have a value of "true", and the EntityResolver2 implementation they provide might throw an exception if the original SAX 1.0 style entity resolution method is invoked.

    Since:
    SAX 2.0 (extensions 1.1 alpha)
    See Also:
    XMLReader.setEntityResolver(org.xml.sax.EntityResolver)

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      InputSource getExternalSubset(String name, String baseURI)
      Allows applications to provide an external subset for documents that don't explicitly define one.
      InputSource resolveEntity(String name, String publicId, String baseURI, String systemId)
      Allows applications to map references to external entities into input sources, or tell the parser it should use conventional URI resolution.

      • Methods inherited from interface org.xml.sax.EntityResolver

        resolveEntity

    • Method Detail

      • getExternalSubset

        InputSource getExternalSubset(String name,
                              String baseURI)
                       throws SAXException,
                              IOException
        Allows applications to provide an external subset for documents that don't explicitly define one. Documents with DOCTYPE declarations that omit an external subset can thus augment the declarations available for validation, entity processing, and attribute processing (normalization, defaulting, and reporting types including ID). This augmentation is reported through the startDTD() method as if the document text had originally included the external subset; this callback is made before any internal subset data or errors are reported.

        This method can also be used with documents that have no DOCTYPE declaration. When the root element is encountered, but no DOCTYPE declaration has been seen, this method is invoked. If it returns a value for the external subset, that root element is declared to be the root element, giving the effect of splicing a DOCTYPE declaration at the end the prolog of a document that could not otherwise be valid. The sequence of parser callbacks in that case logically resembles this:

         ... comments and PIs from the prolog (as usual)
 startDTD ("rootName", source.getPublicId (), source.getSystemId ());
 startEntity ("[dtd]");
 ... declarations, comments, and PIs from the external subset
 endEntity ("[dtd]");
 endDTD ();
 ... then the rest of the document (as usual)
 startElement (..., "rootName", ...);

        Note that the InputSource gets no further resolution. Implementations of this method may wish to invoke resolveEntity() to gain benefits such as use of local caches of DTD entities. Also, this method will never be used by a (non-validating) processor that is not including external parameter entities.

        Uses for this method include facilitating data validation when interoperating with XML processors that would always require undesirable network accesses for external entities, or which for other reasons adopt a "no DTDs" policy. Non-validation motives include forcing documents to include DTDs so that attributes are handled consistently. For example, an XPath processor needs to know which attibutes have type "ID" before it can process a widely used type of reference.

        Warning: Returning an external subset modifies the input document. By providing definitions for general entities, it can make a malformed document appear to be well formed.

        Parameters:
        name - Identifies the document root element. This name comes from a DOCTYPE declaration (where available) or from the actual root element.
        baseURI - The document's base URI, serving as an additional hint for selecting the external subset. This is always an absolute URI, unless it is null because the XMLReader was given an InputSource without one.
        Returns:
        An InputSource object describing the new external subset to be used by the parser, or null to indicate that no external subset is provided.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        IOException - Probably indicating a failure to create a new InputStream or Reader, or an illegal URL.

      • resolveEntity

        InputSource resolveEntity(String name,
                          String publicId,
                          String baseURI,
                          String systemId)
                   throws SAXException,
                          IOException
        Allows applications to map references to external entities into input sources, or tell the parser it should use conventional URI resolution. This method is only called for external entities which have been properly declared. This method provides more flexibility than the EntityResolver interface, supporting implementations of more complex catalogue schemes such as the one defined by the OASIS XML Catalogs specification.

        Parsers configured to use this resolver method will call it to determine the input source to use for any external entity being included because of a reference in the XML text. That excludes the document entity, and any external entity returned by getExternalSubset(). When a (non-validating) processor is configured not to include a class of entities (parameter or general) through use of feature flags, this method is not invoked for such entities.

        Note that the entity naming scheme used here is the same one used in the LexicalHandler, or in the ContentHandler.skippedEntity() method.

        Parameters:
        name - Identifies the external entity being resolved. Either "[dtd]" for the external subset, or a name starting with "%" to indicate a parameter entity, or else the name of a general entity. This is never null when invoked by a SAX2 parser.
        publicId - The public identifier of the external entity being referenced (normalized as required by the XML specification), or null if none was supplied.
        baseURI - The URI with respect to which relative systemIDs are interpreted. This is always an absolute URI, unless it is null (likely because the XMLReader was given an InputSource without one). This URI is defined by the XML specification to be the one associated with the "<" starting the relevant declaration.
        systemId - The system identifier of the external entity being referenced; either a relative or absolute URI. This is never null when invoked by a SAX2 parser; only declared entities, and any external subset, are resolved by such parsers.
        Returns:
        An InputSource object describing the new input source to be used by the parser. Returning null directs the parser to resolve the system ID against the base URI and open a connection to resulting URI.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        IOException - Probably indicating a failure to create a new InputStream or Reader, or an illegal URL.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


LexicalHandler (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax.ext

Interface LexicalHandler

  • All Known Subinterfaces:
    TransformerHandler
    All Known Implementing Classes:
    DefaultHandler2

    public interface LexicalHandler
    SAX2 extension handler for lexical events.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This is an optional extension handler for SAX2 to provide lexical information about an XML document, such as comments and CDATA section boundaries. XML readers are not required to recognize this handler, and it is not part of core-only SAX2 distributions.

    The events in the lexical handler apply to the entire document, not just to the document element, and all lexical handler events must appear between the content handler's startDocument and endDocument events.

    To set the LexicalHandler for an XML reader, use the setProperty method with the property name http://xml.org/sax/properties/lexical-handler and an object implementing this interface (or null) as the value. If the reader does not report lexical events, it will throw a SAXNotRecognizedException when you attempt to register the handler.

    Since:
    SAX 2.0 (extensions 1.0)

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      void comment(char[] ch, int start, int length)
      Report an XML comment anywhere in the document.
      void endCDATA()
      Report the end of a CDATA section.
      void endDTD()
      Report the end of DTD declarations.
      void endEntity(String name)
      Report the end of an entity.
      void startCDATA()
      Report the start of a CDATA section.
      void startDTD(String name, String publicId, String systemId)
      Report the start of DTD declarations, if any.
      void startEntity(String name)
      Report the beginning of some internal and external XML entities.

    • Method Detail

      • startDTD

        void startDTD(String name,
              String publicId,
              String systemId)
       throws SAXException
        Report the start of DTD declarations, if any.

        This method is intended to report the beginning of the DOCTYPE declaration; if the document has no DOCTYPE declaration, this method will not be invoked.

        All declarations reported through DTDHandler or DeclHandler events must appear between the startDTD and endDTD events. Declarations are assumed to belong to the internal DTD subset unless they appear between startEntity and endEntity events. Comments and processing instructions from the DTD should also be reported between the startDTD and endDTD events, in their original order of (logical) occurrence; they are not required to appear in their correct locations relative to DTDHandler or DeclHandler events, however.

        Note that the start/endDTD events will appear within the start/endDocument events from ContentHandler and before the first startElement event.

        Parameters:
        name - The document type name.
        publicId - The declared public identifier for the external DTD subset, or null if none was declared.
        systemId - The declared system identifier for the external DTD subset, or null if none was declared. (Note that this is not resolved against the document base URI.)
        Throws:
        SAXException - The application may raise an exception.
        See Also:
        endDTD(), startEntity(java.lang.String)

      • endDTD

        void endDTD()
     throws SAXException
        Report the end of DTD declarations.

        This method is intended to report the end of the DOCTYPE declaration; if the document has no DOCTYPE declaration, this method will not be invoked.

        Throws:
        SAXException - The application may raise an exception.
        See Also:
        startDTD(java.lang.String, java.lang.String, java.lang.String)

      • startEntity

        void startEntity(String name)
          throws SAXException
        Report the beginning of some internal and external XML entities.

        The reporting of parameter entities (including the external DTD subset) is optional, and SAX2 drivers that report LexicalHandler events may not implement it; you can use the http://xml.org/sax/features/lexical-handler/parameter-entities feature to query or control the reporting of parameter entities.

        General entities are reported with their regular names, parameter entities have '%' prepended to their names, and the external DTD subset has the pseudo-entity name "[dtd]".

        When a SAX2 driver is providing these events, all other events must be properly nested within start/end entity events. There is no additional requirement that events from DeclHandler or DTDHandler be properly ordered.

        Note that skipped entities will be reported through the skippedEntity event, which is part of the ContentHandler interface.

        Because of the streaming event model that SAX uses, some entity boundaries cannot be reported under any circumstances:

        • general entities within attribute values
        • parameter entities within declarations

        These will be silently expanded, with no indication of where the original entity boundaries were.

        Note also that the boundaries of character references (which are not really entities anyway) are not reported.

        All start/endEntity events must be properly nested.

        Parameters:
        name - The name of the entity. If it is a parameter entity, the name will begin with '%', and if it is the external DTD subset, it will be "[dtd]".
        Throws:
        SAXException - The application may raise an exception.
        See Also:
        endEntity(java.lang.String),
DeclHandler.internalEntityDecl(java.lang.String, java.lang.String),
DeclHandler.externalEntityDecl(java.lang.String, java.lang.String, java.lang.String)

      • endEntity

        void endEntity(String name)
        throws SAXException
        Report the end of an entity.
        Parameters:
        name - The name of the entity that is ending.
        Throws:
        SAXException - The application may raise an exception.
        See Also:
        startEntity(java.lang.String)

      • startCDATA

        void startCDATA()
         throws SAXException
        Report the start of a CDATA section.

        The contents of the CDATA section will be reported through the regular characters event; this event is intended only to report the boundary.

        Throws:
        SAXException - The application may raise an exception.
        See Also:
        endCDATA()

      • endCDATA

        void endCDATA()
       throws SAXException
        Report the end of a CDATA section.
        Throws:
        SAXException - The application may raise an exception.
        See Also:
        startCDATA()

      • comment

        void comment(char[] ch,
             int start,
             int length)
      throws SAXException
        Report an XML comment anywhere in the document.

        This callback will be used for comments inside or outside the document element, including comments in the external DTD subset (if read). Comments in the DTD must be properly nested inside start/endDTD and start/endEntity events (if used).

        Parameters:
        ch - An array holding the characters in the comment.
        start - The starting position in the array.
        length - The number of characters to use from the array.
        Throws:
        SAXException - The application may raise an exception.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Locator2 (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax.ext

Interface Locator2

  • All Superinterfaces:
    Locator
    All Known Implementing Classes:
    Locator2Impl

    public interface Locator2
extends Locator
    SAX2 extension to augment the entity information provided though a Locator. If an implementation supports this extension, the Locator provided in ContentHandler.setDocumentLocator() will implement this interface, and the http://xml.org/sax/features/use-locator2 feature flag will have the value true.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY.

    XMLReader implementations are not required to support this information, and it is not part of core-only SAX2 distributions.

    Since:
    SAX 2.0 (extensions 1.1 alpha)

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      String getEncoding()
      Returns the name of the character encoding for the entity.
      String getXMLVersion()
      Returns the version of XML used for the entity.

      • Methods inherited from interface org.xml.sax.Locator

        getColumnNumber, getLineNumber, getPublicId, getSystemId

    • Method Detail

      • getXMLVersion

        String getXMLVersion()
        Returns the version of XML used for the entity. This will normally be the identifier from the current entity's <?xml version='...' ...?> declaration, or be defaulted by the parser.
        Returns:
        Identifier for the XML version being used to interpret the entity's text, or null if that information is not yet available in the current parsing state.

      • getEncoding

        String getEncoding()
        Returns the name of the character encoding for the entity. If the encoding was declared externally (for example, in a MIME Content-Type header), that will be the name returned. Else if there was an <?xml ...encoding='...'?> declaration at the start of the document, that encoding name will be returned. Otherwise the encoding will been inferred (normally to be UTF-8, or some UTF-16 variant), and that inferred name will be returned.

        When an InputSource is used to provide an entity's character stream, this method returns the encoding provided in that input stream.

        Note that some recent W3C specifications require that text in some encodings be normalized, using Unicode Normalization Form C, before processing. Such normalization must be performed by applications, and would normally be triggered based on the value returned by this method.

        Encoding names may be those used by the underlying JVM, and comparisons should be case-insensitive.

        Returns:
        Name of the character encoding being used to interpret * the entity's text, or null if this was not provided for a * character stream passed through an InputSource or is otherwise not yet available in the current parsing state.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Locator2Impl (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax.ext

Class Locator2Impl

  • java.lang.Object
    • org.xml.sax.helpers.LocatorImpl
      • org.xml.sax.ext.Locator2Impl
  • All Implemented Interfaces:
    Locator2, Locator

    public class Locator2Impl
extends LocatorImpl
implements Locator2
    SAX2 extension helper for holding additional Entity information, implementing the Locator2 interface.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY.

    This is not part of core-only SAX2 distributions.

    Since:
    SAX 2.0.2

    • Constructor Summary

      Constructors
      Constructor and Description
      Locator2Impl()
      Construct a new, empty Locator2Impl object.
      Locator2Impl(Locator locator)
      Copy an existing Locator or Locator2 object.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      String getEncoding()
      Returns the current value of the encoding property.
      String getXMLVersion()
      Returns the current value of the version property.
      void setEncoding(String encoding)
      Assigns the current value of the encoding property.
      void setXMLVersion(String version)
      Assigns the current value of the version property.

      • Methods inherited from class org.xml.sax.helpers.LocatorImpl

        getColumnNumber, getLineNumber, getPublicId, getSystemId, setColumnNumber, setLineNumber, setPublicId, setSystemId

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

      • Methods inherited from interface org.xml.sax.Locator

        getColumnNumber, getLineNumber, getPublicId, getSystemId

    • Constructor Detail

      • Locator2Impl

        public Locator2Impl()
        Construct a new, empty Locator2Impl object. This will not normally be useful, since the main purpose of this class is to make a snapshot of an existing Locator.

      • Locator2Impl

        public Locator2Impl(Locator locator)
        Copy an existing Locator or Locator2 object. If the object implements Locator2, values of the encoding and versionstrings are copied, otherwise they set to null.
        Parameters:
        locator - The existing Locator object.

    • Method Detail

      • getXMLVersion

        public String getXMLVersion()
        Returns the current value of the version property.
        Specified by:
        getXMLVersion in interface Locator2
        Returns:
        Identifier for the XML version being used to interpret the entity's text, or null if that information is not yet available in the current parsing state.
        See Also:
        setXMLVersion(java.lang.String)

      • getEncoding

        public String getEncoding()
        Returns the current value of the encoding property.
        Specified by:
        getEncoding in interface Locator2
        Returns:
        Name of the character encoding being used to interpret * the entity's text, or null if this was not provided for a * character stream passed through an InputSource or is otherwise not yet available in the current parsing state.
        See Also:
        setEncoding(java.lang.String)

      • setXMLVersion

        public void setXMLVersion(String version)
        Assigns the current value of the version property.
        Parameters:
        version - the new "version" value
        See Also:
        getXMLVersion()

      • setEncoding

        public void setEncoding(String encoding)
        Assigns the current value of the encoding property.
        Parameters:
        encoding - the new "encoding" value
        See Also:
        getEncoding()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


org.xml.sax.ext (Java Platform SE 8 )

org.xml.sax.ext

Interfaces

  • Attributes2
  • DeclHandler
  • EntityResolver2
  • LexicalHandler
  • Locator2

Classes

  • Attributes2Impl
  • DefaultHandler2
  • Locator2Impl


org.xml.sax.ext (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.xml.sax.ext

This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

See: Description

  • Interface Summary
    Interface Description
    Attributes2
    SAX2 extension to augment the per-attribute information provided though Attributes.
    DeclHandler
    SAX2 extension handler for DTD declaration events.
    EntityResolver2
    Extended interface for mapping external entity references to input sources, or providing a missing external subset.
    LexicalHandler
    SAX2 extension handler for lexical events.
    Locator2
    SAX2 extension to augment the entity information provided though a Locator.
  • Class Summary
    Class Description
    Attributes2Impl
    SAX2 extension helper for additional Attributes information, implementing the Attributes2 interface.
    DefaultHandler2
    This class extends the SAX2 base handler class to support the SAX2 LexicalHandler, DeclHandler, and EntityResolver2 extensions.
    Locator2Impl
    SAX2 extension helper for holding additional Entity information, implementing the Locator2 interface.

Package org.xml.sax.ext Description

This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

See http://www.saxproject.org for more information about SAX.

This package is independent of the SAX2 core, though the functionality exposed generally needs to be implemented within a parser core. That independence has several consequences:

  • SAX2 drivers are not required to recognize these handlers.
  • You cannot assume that the class files will be present in every SAX2 installation.
  • This package may be updated independently of SAX2 (i.e. new handlers and classes may be added without updating SAX2 itself).
  • The new handlers are not implemented by the SAX2 org.xml.sax.helpers.DefaultHandler or org.xml.sax.helpers.XMLFilterImpl classes. You can subclass these if you need such behavior, or use the helper classes found here.
  • The handlers need to be registered differently than core SAX2 handlers.

This package, SAX2-ext, is a standardized extension to SAX2. It is designed both to allow SAX parsers to pass certain types of information to applications, and to serve as a simple model for other SAX2 parser extension packages. Not all such extension packages should need to be recognized directly by parsers, however. As an example, most validation systems can be cleanly layered on top of parsers supporting the standardized SAX2 interfaces.

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames


org.xml.sax.ext Class Hierarchy (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.xml.sax.ext

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.xml.sax.helpers.AttributesImpl (implements org.xml.sax.Attributes)
      • org.xml.sax.ext.Attributes2Impl (implements org.xml.sax.ext.Attributes2)
    • org.xml.sax.helpers.DefaultHandler (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
      • org.xml.sax.ext.DefaultHandler2 (implements org.xml.sax.ext.DeclHandler, org.xml.sax.ext.EntityResolver2, org.xml.sax.ext.LexicalHandler)
    • org.xml.sax.helpers.LocatorImpl (implements org.xml.sax.Locator)
      • org.xml.sax.ext.Locator2Impl (implements org.xml.sax.ext.Locator2)

Interface Hierarchy

  • org.xml.sax.Attributes
    • org.xml.sax.ext.Attributes2
  • org.xml.sax.ext.DeclHandler
  • org.xml.sax.EntityResolver
    • org.xml.sax.ext.EntityResolver2
  • org.xml.sax.ext.LexicalHandler
  • org.xml.sax.Locator
    • org.xml.sax.ext.Locator2
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package org.xml.sax.ext (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.xml.sax.ext

  • Packages that use org.xml.sax.ext
    Package Description
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.
  • Classes in org.xml.sax.ext used by javax.xml.transform.sax
    Class and Description
    LexicalHandler
    SAX2 extension handler for lexical events.
  • Classes in org.xml.sax.ext used by org.xml.sax.ext
    Class and Description
    Attributes2
    SAX2 extension to augment the per-attribute information provided though Attributes.
    DeclHandler
    SAX2 extension handler for DTD declaration events.
    EntityResolver2
    Extended interface for mapping external entity references to input sources, or providing a missing external subset.
    LexicalHandler
    SAX2 extension handler for lexical events.
    Locator2
    SAX2 extension to augment the entity information provided though a Locator.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


HandlerBase (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax

Class HandlerBase

  • java.lang.Object
    • org.xml.sax.HandlerBase
  • All Implemented Interfaces:
    DocumentHandler, DTDHandler, EntityResolver, ErrorHandler
    Deprecated.
    This class works with the deprecated DocumentHandler interface. It has been replaced by the SAX2 DefaultHandler class.

    public class HandlerBase
extends Object
implements EntityResolver, DTDHandler, DocumentHandler, ErrorHandler
    Default base class for handlers.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This class implements the default behaviour for four SAX1 interfaces: EntityResolver, DTDHandler, DocumentHandler, and ErrorHandler. It is now obsolete, but is included in SAX2 to support legacy SAX1 applications. SAX2 applications should use the DefaultHandler class instead.

    Application writers can extend this class when they need to implement only part of an interface; parser writers can instantiate this class to provide default handlers when the application has not supplied its own.

    Note that the use of this class is optional.

    Since:
    SAX 1.0
    See Also:
    EntityResolver, DTDHandler, DocumentHandler, ErrorHandler

    • Constructor Summary

      Constructors
      Constructor and Description
      HandlerBase()
      Deprecated.

    • Method Summary

      All Methods Instance Methods Concrete Methods Deprecated Methods
      Modifier and Type Method and Description
      void characters(char[] ch, int start, int length)
      Deprecated.
      Receive notification of character data inside an element.
      void endDocument()
      Deprecated.
      Receive notification of the end of the document.
      void endElement(String name)
      Deprecated.
      Receive notification of the end of an element.
      void error(SAXParseException e)
      Deprecated.
      Receive notification of a recoverable parser error.
      void fatalError(SAXParseException e)
      Deprecated.
      Report a fatal XML parsing error.
      void ignorableWhitespace(char[] ch, int start, int length)
      Deprecated.
      Receive notification of ignorable whitespace in element content.
      void notationDecl(String name, String publicId, String systemId)
      Deprecated.
      Receive notification of a notation declaration.
      void processingInstruction(String target, String data)
      Deprecated.
      Receive notification of a processing instruction.
      InputSource resolveEntity(String publicId, String systemId)
      Deprecated.
      Resolve an external entity.
      void setDocumentLocator(Locator locator)
      Deprecated.
      Receive a Locator object for document events.
      void startDocument()
      Deprecated.
      Receive notification of the beginning of the document.
      void startElement(String name, AttributeList attributes)
      Deprecated.
      Receive notification of the start of an element.
      void unparsedEntityDecl(String name, String publicId, String systemId, String notationName)
      Deprecated.
      Receive notification of an unparsed entity declaration.
      void warning(SAXParseException e)
      Deprecated.
      Receive notification of a parser warning.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • HandlerBase

        public HandlerBase()
        Deprecated.

    • Method Detail

      • resolveEntity

        public InputSource resolveEntity(String publicId,
                                 String systemId)
                          throws SAXException
        Deprecated.
        Resolve an external entity.

        Always return null, so that the parser will use the system identifier provided in the XML document. This method implements the SAX default behaviour: application writers can override it in a subclass to do special translations such as catalog lookups or URI redirection.

        Specified by:
        resolveEntity in interface EntityResolver
        Parameters:
        publicId - The public identifer, or null if none is available.
        systemId - The system identifier provided in the XML document.
        Returns:
        The new input source, or null to require the default behaviour.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        EntityResolver.resolveEntity(java.lang.String, java.lang.String)

      • notationDecl

        public void notationDecl(String name,
                         String publicId,
                         String systemId)
        Deprecated.
        Receive notification of a notation declaration.

        By default, do nothing. Application writers may override this method in a subclass if they wish to keep track of the notations declared in a document.

        Specified by:
        notationDecl in interface DTDHandler
        Parameters:
        name - The notation name.
        publicId - The notation public identifier, or null if not available.
        systemId - The notation system identifier.
        See Also:
        DTDHandler.notationDecl(java.lang.String, java.lang.String, java.lang.String)

      • unparsedEntityDecl

        public void unparsedEntityDecl(String name,
                               String publicId,
                               String systemId,
                               String notationName)
        Deprecated.
        Receive notification of an unparsed entity declaration.

        By default, do nothing. Application writers may override this method in a subclass to keep track of the unparsed entities declared in a document.

        Specified by:
        unparsedEntityDecl in interface DTDHandler
        Parameters:
        name - The entity name.
        publicId - The entity public identifier, or null if not available.
        systemId - The entity system identifier.
        notationName - The name of the associated notation.
        See Also:
        DTDHandler.unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String)

      • setDocumentLocator

        public void setDocumentLocator(Locator locator)
        Deprecated.
        Receive a Locator object for document events.

        By default, do nothing. Application writers may override this method in a subclass if they wish to store the locator for use with other document events.

        Specified by:
        setDocumentLocator in interface DocumentHandler
        Parameters:
        locator - A locator for all SAX document events.
        See Also:
        DocumentHandler.setDocumentLocator(org.xml.sax.Locator), Locator

      • startDocument

        public void startDocument()
                   throws SAXException
        Deprecated.
        Receive notification of the beginning of the document.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions at the beginning of a document (such as allocating the root node of a tree or creating an output file).

        Specified by:
        startDocument in interface DocumentHandler
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        DocumentHandler.startDocument()

      • endDocument

        public void endDocument()
                 throws SAXException
        Deprecated.
        Receive notification of the end of the document.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions at the end of a document (such as finalising a tree or closing an output file).

        Specified by:
        endDocument in interface DocumentHandler
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        DocumentHandler.endDocument()

      • startElement

        public void startElement(String name,
                         AttributeList attributes)
                  throws SAXException
        Deprecated.
        Receive notification of the start of an element.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions at the start of each element (such as allocating a new tree node or writing output to a file).

        Specified by:
        startElement in interface DocumentHandler
        Parameters:
        name - The element type name.
        attributes - The specified or defaulted attributes.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        DocumentHandler.startElement(java.lang.String, org.xml.sax.AttributeList)

      • endElement

        public void endElement(String name)
                throws SAXException
        Deprecated.
        Receive notification of the end of an element.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions at the end of each element (such as finalising a tree node or writing output to a file).

        Specified by:
        endElement in interface DocumentHandler
        Parameters:
        name - the element name
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        DocumentHandler.endElement(java.lang.String)

      • characters

        public void characters(char[] ch,
                       int start,
                       int length)
                throws SAXException
        Deprecated.
        Receive notification of character data inside an element.

        By default, do nothing. Application writers may override this method to take specific actions for each chunk of character data (such as adding the data to a node or buffer, or printing it to a file).

        Specified by:
        characters in interface DocumentHandler
        Parameters:
        ch - The characters.
        start - The start position in the character array.
        length - The number of characters to use from the character array.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        DocumentHandler.characters(char[], int, int)

      • ignorableWhitespace

        public void ignorableWhitespace(char[] ch,
                                int start,
                                int length)
                         throws SAXException
        Deprecated.
        Receive notification of ignorable whitespace in element content.

        By default, do nothing. Application writers may override this method to take specific actions for each chunk of ignorable whitespace (such as adding data to a node or buffer, or printing it to a file).

        Specified by:
        ignorableWhitespace in interface DocumentHandler
        Parameters:
        ch - The whitespace characters.
        start - The start position in the character array.
        length - The number of characters to use from the character array.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        DocumentHandler.ignorableWhitespace(char[], int, int)

      • processingInstruction

        public void processingInstruction(String target,
                                  String data)
                           throws SAXException
        Deprecated.
        Receive notification of a processing instruction.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions for each processing instruction, such as setting status variables or invoking other methods.

        Specified by:
        processingInstruction in interface DocumentHandler
        Parameters:
        target - The processing instruction target.
        data - The processing instruction data, or null if none is supplied.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        DocumentHandler.processingInstruction(java.lang.String, java.lang.String)

      • warning

        public void warning(SAXParseException e)
             throws SAXException
        Deprecated.
        Receive notification of a parser warning.

        The default implementation does nothing. Application writers may override this method in a subclass to take specific actions for each warning, such as inserting the message in a log file or printing it to the console.

        Specified by:
        warning in interface ErrorHandler
        Parameters:
        e - The warning information encoded as an exception.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        ErrorHandler.warning(org.xml.sax.SAXParseException), SAXParseException

      • error

        public void error(SAXParseException e)
           throws SAXException
        Deprecated.
        Receive notification of a recoverable parser error.

        The default implementation does nothing. Application writers may override this method in a subclass to take specific actions for each error, such as inserting the message in a log file or printing it to the console.

        Specified by:
        error in interface ErrorHandler
        Parameters:
        e - The warning information encoded as an exception.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        ErrorHandler.warning(org.xml.sax.SAXParseException), SAXParseException

      • fatalError

        public void fatalError(SAXParseException e)
                throws SAXException
        Deprecated.
        Report a fatal XML parsing error.

        The default implementation throws a SAXParseException. Application writers may override this method in a subclass if they need to take specific actions for each fatal error (such as collecting all of the errors into a single report): in any case, the application must stop all regular processing when this method is invoked, since the document is no longer reliable, and the parser may no longer report parsing events.

        Specified by:
        fatalError in interface ErrorHandler
        Parameters:
        e - The error information encoded as an exception.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        ErrorHandler.fatalError(org.xml.sax.SAXParseException), SAXParseException
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AttributeListImpl (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax.helpers

Class AttributeListImpl

  • java.lang.Object
    • org.xml.sax.helpers.AttributeListImpl
  • All Implemented Interfaces:
    AttributeList
    Deprecated.
    This class implements a deprecated interface, AttributeList; that interface has been replaced by Attributes, which is implemented in the AttributesImpl helper class.

    public class AttributeListImpl
extends Object
implements AttributeList
    Default implementation for AttributeList.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    AttributeList implements the deprecated SAX1 AttributeList interface, and has been replaced by the new SAX2 AttributesImpl interface.

    This class provides a convenience implementation of the SAX AttributeList interface. This implementation is useful both for SAX parser writers, who can use it to provide attributes to the application, and for SAX application writers, who can use it to create a persistent copy of an element's attribute specifications:

     private AttributeList myatts;

 public void startElement (String name, AttributeList atts)
 {
              // create a persistent copy of the attribute list
              // for use outside this method
   myatts = new AttributeListImpl(atts);
   [...]
 }

    Please note that SAX parsers are not required to use this class to provide an implementation of AttributeList; it is supplied only as an optional convenience. In particular, parser writers are encouraged to invent more efficient implementations.

    Since:
    SAX 1.0
    See Also:
    AttributeList, DocumentHandler.startElement(java.lang.String, org.xml.sax.AttributeList)

    • Constructor Summary

      Constructors
      Constructor and Description
      AttributeListImpl()
      Deprecated.
      Create an empty attribute list.
      AttributeListImpl(AttributeList atts)
      Deprecated.
      Construct a persistent copy of an existing attribute list.

    • Method Summary

      All Methods Instance Methods Concrete Methods Deprecated Methods
      Modifier and Type Method and Description
      void addAttribute(String name, String type, String value)
      Deprecated.
      Add an attribute to an attribute list.
      void clear()
      Deprecated.
      Clear the attribute list.
      int getLength()
      Deprecated.
      Return the number of attributes in the list.
      String getName(int i)
      Deprecated.
      Get the name of an attribute (by position).
      String getType(int i)
      Deprecated.
      Get the type of an attribute (by position).
      String getType(String name)
      Deprecated.
      Get the type of an attribute (by name).
      String getValue(int i)
      Deprecated.
      Get the value of an attribute (by position).
      String getValue(String name)
      Deprecated.
      Get the value of an attribute (by name).
      void removeAttribute(String name)
      Deprecated.
      Remove an attribute from the list.
      void setAttributeList(AttributeList atts)
      Deprecated.
      Set the attribute list, discarding previous contents.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AttributeListImpl

        public AttributeListImpl()
        Deprecated.
        Create an empty attribute list.

        This constructor is most useful for parser writers, who will use it to create a single, reusable attribute list that can be reset with the clear method between elements.

        See Also:
        addAttribute(java.lang.String, java.lang.String, java.lang.String), clear()

      • AttributeListImpl

        public AttributeListImpl(AttributeList atts)
        Deprecated.
        Construct a persistent copy of an existing attribute list.

        This constructor is most useful for application writers, who will use it to create a persistent copy of an existing attribute list.

        Parameters:
        atts - The attribute list to copy
        See Also:
        DocumentHandler.startElement(java.lang.String, org.xml.sax.AttributeList)

    • Method Detail

      • setAttributeList

        public void setAttributeList(AttributeList atts)
        Deprecated.
        Set the attribute list, discarding previous contents.

        This method allows an application writer to reuse an attribute list easily.

        Parameters:
        atts - The attribute list to copy.

      • addAttribute

        public void addAttribute(String name,
                         String type,
                         String value)
        Deprecated.
        Add an attribute to an attribute list.

        This method is provided for SAX parser writers, to allow them to build up an attribute list incrementally before delivering it to the application.

        Parameters:
        name - The attribute name.
        type - The attribute type ("NMTOKEN" for an enumeration).
        value - The attribute value (must not be null).
        See Also:
        removeAttribute(java.lang.String), DocumentHandler.startElement(java.lang.String, org.xml.sax.AttributeList)

      • removeAttribute

        public void removeAttribute(String name)
        Deprecated.
        Remove an attribute from the list.

        SAX application writers can use this method to filter an attribute out of an AttributeList. Note that invoking this method will change the length of the attribute list and some of the attribute's indices.

        If the requested attribute is not in the list, this is a no-op.

        Parameters:
        name - The attribute name.
        See Also:
        addAttribute(java.lang.String, java.lang.String, java.lang.String)

      • clear

        public void clear()
        Deprecated.
        Clear the attribute list.

        SAX parser writers can use this method to reset the attribute list between DocumentHandler.startElement events. Normally, it will make sense to reuse the same AttributeListImpl object rather than allocating a new one each time.

        See Also:
        DocumentHandler.startElement(java.lang.String, org.xml.sax.AttributeList)

      • getLength

        public int getLength()
        Deprecated.
        Return the number of attributes in the list.
        Specified by:
        getLength in interface AttributeList
        Returns:
        The number of attributes in the list.
        See Also:
        AttributeList.getLength()

      • getName

        public String getName(int i)
        Deprecated.
        Get the name of an attribute (by position).
        Specified by:
        getName in interface AttributeList
        Parameters:
        i - The position of the attribute in the list.
        Returns:
        The attribute name as a string, or null if there is no attribute at that position.
        See Also:
        AttributeList.getName(int)

      • getType

        public String getType(int i)
        Deprecated.
        Get the type of an attribute (by position).
        Specified by:
        getType in interface AttributeList
        Parameters:
        i - The position of the attribute in the list.
        Returns:
        The attribute type as a string ("NMTOKEN" for an enumeration, and "CDATA" if no declaration was read), or null if there is no attribute at that position.
        See Also:
        AttributeList.getType(int)

      • getValue

        public String getValue(int i)
        Deprecated.
        Get the value of an attribute (by position).
        Specified by:
        getValue in interface AttributeList
        Parameters:
        i - The position of the attribute in the list.
        Returns:
        The attribute value as a string, or null if there is no attribute at that position.
        See Also:
        AttributeList.getValue(int)

      • getType

        public String getType(String name)
        Deprecated.
        Get the type of an attribute (by name).
        Specified by:
        getType in interface AttributeList
        Parameters:
        name - The attribute name.
        Returns:
        The attribute type as a string ("NMTOKEN" for an enumeration, and "CDATA" if no declaration was read).
        See Also:
        AttributeList.getType(java.lang.String)

      • getValue

        public String getValue(String name)
        Deprecated.
        Get the value of an attribute (by name).
        Specified by:
        getValue in interface AttributeList
        Parameters:
        name - The attribute name.
        Returns:
        The attribute value as a string, or null if no such attribute exists.
        See Also:
        AttributeList.getValue(java.lang.String)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


AttributesImpl (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax.helpers

Class AttributesImpl

  • java.lang.Object
    • org.xml.sax.helpers.AttributesImpl
  • All Implemented Interfaces:
    Attributes
    Direct Known Subclasses:
    Attributes2Impl

    public class AttributesImpl
extends Object
implements Attributes
    Default implementation of the Attributes interface.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This class provides a default implementation of the SAX2 Attributes interface, with the addition of manipulators so that the list can be modified or reused.

    There are two typical uses of this class:

    1. to take a persistent snapshot of an Attributes object in a startElement event; or
    2. to construct or modify an Attributes object in a SAX2 driver or filter.

    This class replaces the now-deprecated SAX1 AttributeListImpl class; in addition to supporting the updated Attributes interface rather than the deprecated AttributeList interface, it also includes a much more efficient implementation using a single array rather than a set of Vectors.

    Since:
    SAX 2.0

    • Constructor Summary

      Constructors
      Constructor and Description
      AttributesImpl()
      Construct a new, empty AttributesImpl object.
      AttributesImpl(Attributes atts)
      Copy an existing Attributes object.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void addAttribute(String uri, String localName, String qName, String type, String value)
      Add an attribute to the end of the list.
      void clear()
      Clear the attribute list for reuse.
      int getIndex(String qName)
      Look up an attribute's index by qualified (prefixed) name.
      int getIndex(String uri, String localName)
      Look up an attribute's index by Namespace name.
      int getLength()
      Return the number of attributes in the list.
      String getLocalName(int index)
      Return an attribute's local name.
      String getQName(int index)
      Return an attribute's qualified (prefixed) name.
      String getType(int index)
      Return an attribute's type by index.
      String getType(String qName)
      Look up an attribute's type by qualified (prefixed) name.
      String getType(String uri, String localName)
      Look up an attribute's type by Namespace-qualified name.
      String getURI(int index)
      Return an attribute's Namespace URI.
      String getValue(int index)
      Return an attribute's value by index.
      String getValue(String qName)
      Look up an attribute's value by qualified (prefixed) name.
      String getValue(String uri, String localName)
      Look up an attribute's value by Namespace-qualified name.
      void removeAttribute(int index)
      Remove an attribute from the list.
      void setAttribute(int index, String uri, String localName, String qName, String type, String value)
      Set an attribute in the list.
      void setAttributes(Attributes atts)
      Copy an entire Attributes object.
      void setLocalName(int index, String localName)
      Set the local name of a specific attribute.
      void setQName(int index, String qName)
      Set the qualified name of a specific attribute.
      void setType(int index, String type)
      Set the type of a specific attribute.
      void setURI(int index, String uri)
      Set the Namespace URI of a specific attribute.
      void setValue(int index, String value)
      Set the value of a specific attribute.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • AttributesImpl

        public AttributesImpl()
        Construct a new, empty AttributesImpl object.

      • AttributesImpl

        public AttributesImpl(Attributes atts)
        Copy an existing Attributes object.

        This constructor is especially useful inside a startElement event.

        Parameters:
        atts - The existing Attributes object.

    • Method Detail

      • getLength

        public int getLength()
        Return the number of attributes in the list.
        Specified by:
        getLength in interface Attributes
        Returns:
        The number of attributes in the list.
        See Also:
        Attributes.getLength()

      • getURI

        public String getURI(int index)
        Return an attribute's Namespace URI.
        Specified by:
        getURI in interface Attributes
        Parameters:
        index - The attribute's index (zero-based).
        Returns:
        The Namespace URI, the empty string if none is available, or null if the index is out of range.
        See Also:
        Attributes.getURI(int)

      • getLocalName

        public String getLocalName(int index)
        Return an attribute's local name.
        Specified by:
        getLocalName in interface Attributes
        Parameters:
        index - The attribute's index (zero-based).
        Returns:
        The attribute's local name, the empty string if none is available, or null if the index if out of range.
        See Also:
        Attributes.getLocalName(int)

      • getQName

        public String getQName(int index)
        Return an attribute's qualified (prefixed) name.
        Specified by:
        getQName in interface Attributes
        Parameters:
        index - The attribute's index (zero-based).
        Returns:
        The attribute's qualified name, the empty string if none is available, or null if the index is out of bounds.
        See Also:
        Attributes.getQName(int)

      • getType

        public String getType(int index)
        Return an attribute's type by index.
        Specified by:
        getType in interface Attributes
        Parameters:
        index - The attribute's index (zero-based).
        Returns:
        The attribute's type, "CDATA" if the type is unknown, or null if the index is out of bounds.
        See Also:
        Attributes.getType(int)

      • getValue

        public String getValue(int index)
        Return an attribute's value by index.
        Specified by:
        getValue in interface Attributes
        Parameters:
        index - The attribute's index (zero-based).
        Returns:
        The attribute's value or null if the index is out of bounds.
        See Also:
        Attributes.getValue(int)

      • getIndex

        public int getIndex(String uri,
                    String localName)
        Look up an attribute's index by Namespace name.

        In many cases, it will be more efficient to look up the name once and use the index query methods rather than using the name query methods repeatedly.

        Specified by:
        getIndex in interface Attributes
        Parameters:
        uri - The attribute's Namespace URI, or the empty string if none is available.
        localName - The attribute's local name.
        Returns:
        The attribute's index, or -1 if none matches.
        See Also:
        Attributes.getIndex(java.lang.String,java.lang.String)

      • getIndex

        public int getIndex(String qName)
        Look up an attribute's index by qualified (prefixed) name.
        Specified by:
        getIndex in interface Attributes
        Parameters:
        qName - The qualified name.
        Returns:
        The attribute's index, or -1 if none matches.
        See Also:
        Attributes.getIndex(java.lang.String)

      • getType

        public String getType(String uri,
                      String localName)
        Look up an attribute's type by Namespace-qualified name.
        Specified by:
        getType in interface Attributes
        Parameters:
        uri - The Namespace URI, or the empty string for a name with no explicit Namespace URI.
        localName - The local name.
        Returns:
        The attribute's type, or null if there is no matching attribute.
        See Also:
        Attributes.getType(java.lang.String,java.lang.String)

      • getType

        public String getType(String qName)
        Look up an attribute's type by qualified (prefixed) name.
        Specified by:
        getType in interface Attributes
        Parameters:
        qName - The qualified name.
        Returns:
        The attribute's type, or null if there is no matching attribute.
        See Also:
        Attributes.getType(java.lang.String)

      • getValue

        public String getValue(String uri,
                       String localName)
        Look up an attribute's value by Namespace-qualified name.
        Specified by:
        getValue in interface Attributes
        Parameters:
        uri - The Namespace URI, or the empty string for a name with no explicit Namespace URI.
        localName - The local name.
        Returns:
        The attribute's value, or null if there is no matching attribute.
        See Also:
        Attributes.getValue(java.lang.String,java.lang.String)

      • getValue

        public String getValue(String qName)
        Look up an attribute's value by qualified (prefixed) name.
        Specified by:
        getValue in interface Attributes
        Parameters:
        qName - The qualified name.
        Returns:
        The attribute's value, or null if there is no matching attribute.
        See Also:
        Attributes.getValue(java.lang.String)

      • clear

        public void clear()
        Clear the attribute list for reuse.

        Note that little memory is freed by this call: the current array is kept so it can be reused.

      • setAttributes

        public void setAttributes(Attributes atts)
        Copy an entire Attributes object.

        It may be more efficient to reuse an existing object rather than constantly allocating new ones.

        Parameters:
        atts - The attributes to copy.

      • addAttribute

        public void addAttribute(String uri,
                         String localName,
                         String qName,
                         String type,
                         String value)
        Add an attribute to the end of the list.

        For the sake of speed, this method does no checking to see if the attribute is already in the list: that is the responsibility of the application.

        Parameters:
        uri - The Namespace URI, or the empty string if none is available or Namespace processing is not being performed.
        localName - The local name, or the empty string if Namespace processing is not being performed.
        qName - The qualified (prefixed) name, or the empty string if qualified names are not available.
        type - The attribute type as a string.
        value - The attribute value.

      • setAttribute

        public void setAttribute(int index,
                         String uri,
                         String localName,
                         String qName,
                         String type,
                         String value)
        Set an attribute in the list.

        For the sake of speed, this method does no checking for name conflicts or well-formedness: such checks are the responsibility of the application.

        Parameters:
        index - The index of the attribute (zero-based).
        uri - The Namespace URI, or the empty string if none is available or Namespace processing is not being performed.
        localName - The local name, or the empty string if Namespace processing is not being performed.
        qName - The qualified name, or the empty string if qualified names are not available.
        type - The attribute type as a string.
        value - The attribute value.
        Throws:
        ArrayIndexOutOfBoundsException - When the supplied index does not point to an attribute in the list.

      • removeAttribute

        public void removeAttribute(int index)
        Remove an attribute from the list.
        Parameters:
        index - The index of the attribute (zero-based).
        Throws:
        ArrayIndexOutOfBoundsException - When the supplied index does not point to an attribute in the list.

      • setURI

        public void setURI(int index,
                   String uri)
        Set the Namespace URI of a specific attribute.
        Parameters:
        index - The index of the attribute (zero-based).
        uri - The attribute's Namespace URI, or the empty string for none.
        Throws:
        ArrayIndexOutOfBoundsException - When the supplied index does not point to an attribute in the list.

      • setLocalName

        public void setLocalName(int index,
                         String localName)
        Set the local name of a specific attribute.
        Parameters:
        index - The index of the attribute (zero-based).
        localName - The attribute's local name, or the empty string for none.
        Throws:
        ArrayIndexOutOfBoundsException - When the supplied index does not point to an attribute in the list.

      • setQName

        public void setQName(int index,
                     String qName)
        Set the qualified name of a specific attribute.
        Parameters:
        index - The index of the attribute (zero-based).
        qName - The attribute's qualified name, or the empty string for none.
        Throws:
        ArrayIndexOutOfBoundsException - When the supplied index does not point to an attribute in the list.

      • setType

        public void setType(int index,
                    String type)
        Set the type of a specific attribute.
        Parameters:
        index - The index of the attribute (zero-based).
        type - The attribute's type.
        Throws:
        ArrayIndexOutOfBoundsException - When the supplied index does not point to an attribute in the list.

      • setValue

        public void setValue(int index,
                     String value)
        Set the value of a specific attribute.
        Parameters:
        index - The index of the attribute (zero-based).
        value - The attribute's value.
        Throws:
        ArrayIndexOutOfBoundsException - When the supplied index does not point to an attribute in the list.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Uses of Class org.xml.sax.helpers.AttributeListImpl (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.xml.sax.helpers.AttributeListImpl

No usage of org.xml.sax.helpers.AttributeListImpl
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.xml.sax.helpers.AttributesImpl (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.xml.sax.helpers.AttributesImpl

  • Packages that use AttributesImpl
    Package Description
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

    • Uses of AttributesImpl in org.xml.sax.ext

      Subclasses of AttributesImpl in org.xml.sax.ext
      Modifier and Type Class and Description
      class  Attributes2Impl
      SAX2 extension helper for additional Attributes information, implementing the Attributes2 interface.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.xml.sax.helpers.DefaultHandler (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.xml.sax.helpers.DefaultHandler

  • Packages that use DefaultHandler
    Package Description
    java.beans
    Contains classes related to developing beans -- components based on the JavaBeans™ architecture.
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

    • Uses of DefaultHandler in java.beans

      Methods in java.beans that return DefaultHandler
      Modifier and Type Method and Description
      static DefaultHandler XMLDecoder.createHandler(Object owner, ExceptionListener el, ClassLoader cl)
      Creates a new handler for SAX parser that can be used to parse embedded XML archives created by the XMLEncoder class.

    • Uses of DefaultHandler in javax.xml.parsers

      Methods in javax.xml.parsers with parameters of type DefaultHandler
      Modifier and Type Method and Description
      void SAXParser.parse(File f, DefaultHandler dh)
      Parse the content of the file specified as XML using the specified DefaultHandler.
      void SAXParser.parse(InputSource is, DefaultHandler dh)
      Parse the content given InputSource as XML using the specified DefaultHandler.
      void SAXParser.parse(InputStream is, DefaultHandler dh)
      Parse the content of the given InputStream instance as XML using the specified DefaultHandler.
      void SAXParser.parse(InputStream is, DefaultHandler dh, String systemId)
      Parse the content of the given InputStream instance as XML using the specified DefaultHandler.
      void SAXParser.parse(String uri, DefaultHandler dh)
      Parse the content described by the giving Uniform Resource Identifier (URI) as XML using the specified DefaultHandler.

    • Uses of DefaultHandler in org.xml.sax.ext

      Subclasses of DefaultHandler in org.xml.sax.ext
      Modifier and Type Class and Description
      class  DefaultHandler2
      This class extends the SAX2 base handler class to support the SAX2 LexicalHandler, DeclHandler, and EntityResolver2 extensions.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.xml.sax.helpers.LocatorImpl (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.xml.sax.helpers.LocatorImpl

  • Packages that use LocatorImpl
    Package Description
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.

    • Uses of LocatorImpl in org.xml.sax.ext

      Subclasses of LocatorImpl in org.xml.sax.ext
      Modifier and Type Class and Description
      class  Locator2Impl
      SAX2 extension helper for holding additional Entity information, implementing the Locator2 interface.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.xml.sax.helpers.NamespaceSupport (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.xml.sax.helpers.NamespaceSupport

No usage of org.xml.sax.helpers.NamespaceSupport
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.xml.sax.helpers.ParserAdapter (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.xml.sax.helpers.ParserAdapter

No usage of org.xml.sax.helpers.ParserAdapter
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.xml.sax.helpers.ParserFactory (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.xml.sax.helpers.ParserFactory

No usage of org.xml.sax.helpers.ParserFactory
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.xml.sax.helpers.XMLFilterImpl (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.xml.sax.helpers.XMLFilterImpl

No usage of org.xml.sax.helpers.XMLFilterImpl
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.xml.sax.helpers.XMLReaderAdapter (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.xml.sax.helpers.XMLReaderAdapter

No usage of org.xml.sax.helpers.XMLReaderAdapter
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Class org.xml.sax.helpers.XMLReaderFactory (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Class
org.xml.sax.helpers.XMLReaderFactory

No usage of org.xml.sax.helpers.XMLReaderFactory
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


compact2 - org.xml.sax.helpers (Java Platform SE 8 )

compact2 - org.xml.sax.helpers

Classes

  • AttributeListImpl
  • AttributesImpl
  • DefaultHandler
  • LocatorImpl
  • NamespaceSupport
  • ParserAdapter
  • ParserFactory
  • XMLFilterImpl
  • XMLReaderAdapter
  • XMLReaderFactory


org.xml.sax.helpers (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact2

Package org.xml.sax.helpers

This package contains "helper" classes, including support for bootstrapping SAX-based applications.

See: Description

  • Class Summary
    Class Description
    AttributeListImpl Deprecated
    This class implements a deprecated interface, AttributeList; that interface has been replaced by Attributes, which is implemented in the AttributesImpl helper class.
    AttributesImpl
    Default implementation of the Attributes interface.
    DefaultHandler
    Default base class for SAX2 event handlers.
    LocatorImpl
    Provide an optional convenience implementation of Locator.
    NamespaceSupport
    Encapsulate Namespace logic for use by applications using SAX, or internally by SAX drivers.
    ParserAdapter
    Adapt a SAX1 Parser as a SAX2 XMLReader.
    ParserFactory Deprecated
    This class works with the deprecated Parser interface.
    XMLFilterImpl
    Base class for deriving an XML filter.
    XMLReaderAdapter
    Adapt a SAX2 XMLReader as a SAX1 Parser.
    XMLReaderFactory
    Factory for creating an XML reader.

Package org.xml.sax.helpers Description

This package contains "helper" classes, including support for bootstrapping SAX-based applications.

See http://www.saxproject.org for more information about SAX.

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames


compact3 - org.xml.sax.helpers (Java Platform SE 8 )

compact3 - org.xml.sax.helpers

Classes

  • AttributeListImpl
  • AttributesImpl
  • DefaultHandler
  • LocatorImpl
  • NamespaceSupport
  • ParserAdapter
  • ParserFactory
  • XMLFilterImpl
  • XMLReaderAdapter
  • XMLReaderFactory


org.xml.sax.helpers (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes
compact3

Package org.xml.sax.helpers

This package contains "helper" classes, including support for bootstrapping SAX-based applications.

See: Description

  • Class Summary
    Class Description
    AttributeListImpl Deprecated
    This class implements a deprecated interface, AttributeList; that interface has been replaced by Attributes, which is implemented in the AttributesImpl helper class.
    AttributesImpl
    Default implementation of the Attributes interface.
    DefaultHandler
    Default base class for SAX2 event handlers.
    LocatorImpl
    Provide an optional convenience implementation of Locator.
    NamespaceSupport
    Encapsulate Namespace logic for use by applications using SAX, or internally by SAX drivers.
    ParserAdapter
    Adapt a SAX1 Parser as a SAX2 XMLReader.
    ParserFactory Deprecated
    This class works with the deprecated Parser interface.
    XMLFilterImpl
    Base class for deriving an XML filter.
    XMLReaderAdapter
    Adapt a SAX2 XMLReader as a SAX1 Parser.
    XMLReaderFactory
    Factory for creating an XML reader.

Package org.xml.sax.helpers Description

This package contains "helper" classes, including support for bootstrapping SAX-based applications.

See http://www.saxproject.org for more information about SAX.

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames


DefaultHandler (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax.helpers

Class DefaultHandler

  • java.lang.Object
    • org.xml.sax.helpers.DefaultHandler
  • All Implemented Interfaces:
    ContentHandler, DTDHandler, EntityResolver, ErrorHandler
    Direct Known Subclasses:
    DefaultHandler2

    public class DefaultHandler
extends Object
implements EntityResolver, DTDHandler, ContentHandler, ErrorHandler
    Default base class for SAX2 event handlers.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This class is available as a convenience base class for SAX2 applications: it provides default implementations for all of the callbacks in the four core SAX2 handler classes:

    • EntityResolver
    • DTDHandler
    • ContentHandler
    • ErrorHandler

    Application writers can extend this class when they need to implement only part of an interface; parser writers can instantiate this class to provide default handlers when the application has not supplied its own.

    This class replaces the deprecated SAX1 HandlerBase class.

    Since:
    SAX 2.0
    See Also:
    EntityResolver, DTDHandler, ContentHandler, ErrorHandler

    • Constructor Summary

      Constructors
      Constructor and Description
      DefaultHandler()

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void characters(char[] ch, int start, int length)
      Receive notification of character data inside an element.
      void endDocument()
      Receive notification of the end of the document.
      void endElement(String uri, String localName, String qName)
      Receive notification of the end of an element.
      void endPrefixMapping(String prefix)
      Receive notification of the end of a Namespace mapping.
      void error(SAXParseException e)
      Receive notification of a recoverable parser error.
      void fatalError(SAXParseException e)
      Report a fatal XML parsing error.
      void ignorableWhitespace(char[] ch, int start, int length)
      Receive notification of ignorable whitespace in element content.
      void notationDecl(String name, String publicId, String systemId)
      Receive notification of a notation declaration.
      void processingInstruction(String target, String data)
      Receive notification of a processing instruction.
      InputSource resolveEntity(String publicId, String systemId)
      Resolve an external entity.
      void setDocumentLocator(Locator locator)
      Receive a Locator object for document events.
      void skippedEntity(String name)
      Receive notification of a skipped entity.
      void startDocument()
      Receive notification of the beginning of the document.
      void startElement(String uri, String localName, String qName, Attributes attributes)
      Receive notification of the start of an element.
      void startPrefixMapping(String prefix, String uri)
      Receive notification of the start of a Namespace mapping.
      void unparsedEntityDecl(String name, String publicId, String systemId, String notationName)
      Receive notification of an unparsed entity declaration.
      void warning(SAXParseException e)
      Receive notification of a parser warning.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • DefaultHandler

        public DefaultHandler()

    • Method Detail

      • resolveEntity

        public InputSource resolveEntity(String publicId,
                                 String systemId)
                          throws IOException,
                                 SAXException
        Resolve an external entity.

        Always return null, so that the parser will use the system identifier provided in the XML document. This method implements the SAX default behaviour: application writers can override it in a subclass to do special translations such as catalog lookups or URI redirection.

        Specified by:
        resolveEntity in interface EntityResolver
        Parameters:
        publicId - The public identifier, or null if none is available.
        systemId - The system identifier provided in the XML document.
        Returns:
        The new input source, or null to require the default behaviour.
        Throws:
        IOException - If there is an error setting up the new input source.
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        EntityResolver.resolveEntity(java.lang.String, java.lang.String)

      • notationDecl

        public void notationDecl(String name,
                         String publicId,
                         String systemId)
                  throws SAXException
        Receive notification of a notation declaration.

        By default, do nothing. Application writers may override this method in a subclass if they wish to keep track of the notations declared in a document.

        Specified by:
        notationDecl in interface DTDHandler
        Parameters:
        name - The notation name.
        publicId - The notation public identifier, or null if not available.
        systemId - The notation system identifier.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        DTDHandler.notationDecl(java.lang.String, java.lang.String, java.lang.String)

      • unparsedEntityDecl

        public void unparsedEntityDecl(String name,
                               String publicId,
                               String systemId,
                               String notationName)
                        throws SAXException
        Receive notification of an unparsed entity declaration.

        By default, do nothing. Application writers may override this method in a subclass to keep track of the unparsed entities declared in a document.

        Specified by:
        unparsedEntityDecl in interface DTDHandler
        Parameters:
        name - The entity name.
        publicId - The entity public identifier, or null if not available.
        systemId - The entity system identifier.
        notationName - The name of the associated notation.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        DTDHandler.unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String)

      • setDocumentLocator

        public void setDocumentLocator(Locator locator)
        Receive a Locator object for document events.

        By default, do nothing. Application writers may override this method in a subclass if they wish to store the locator for use with other document events.

        Specified by:
        setDocumentLocator in interface ContentHandler
        Parameters:
        locator - A locator for all SAX document events.
        See Also:
        ContentHandler.setDocumentLocator(org.xml.sax.Locator), Locator

      • startDocument

        public void startDocument()
                   throws SAXException
        Receive notification of the beginning of the document.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions at the beginning of a document (such as allocating the root node of a tree or creating an output file).

        Specified by:
        startDocument in interface ContentHandler
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        ContentHandler.startDocument()

      • endDocument

        public void endDocument()
                 throws SAXException
        Receive notification of the end of the document.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions at the end of a document (such as finalising a tree or closing an output file).

        Specified by:
        endDocument in interface ContentHandler
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        ContentHandler.endDocument()

      • startPrefixMapping

        public void startPrefixMapping(String prefix,
                               String uri)
                        throws SAXException
        Receive notification of the start of a Namespace mapping.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions at the start of each Namespace prefix scope (such as storing the prefix mapping).

        Specified by:
        startPrefixMapping in interface ContentHandler
        Parameters:
        prefix - The Namespace prefix being declared.
        uri - The Namespace URI mapped to the prefix.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        ContentHandler.startPrefixMapping(java.lang.String, java.lang.String)

      • endPrefixMapping

        public void endPrefixMapping(String prefix)
                      throws SAXException
        Receive notification of the end of a Namespace mapping.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions at the end of each prefix mapping.

        Specified by:
        endPrefixMapping in interface ContentHandler
        Parameters:
        prefix - The Namespace prefix being declared.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        ContentHandler.endPrefixMapping(java.lang.String)

      • startElement

        public void startElement(String uri,
                         String localName,
                         String qName,
                         Attributes attributes)
                  throws SAXException
        Receive notification of the start of an element.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions at the start of each element (such as allocating a new tree node or writing output to a file).

        Specified by:
        startElement in interface ContentHandler
        Parameters:
        uri - The Namespace URI, or the empty string if the element has no Namespace URI or if Namespace processing is not being performed.
        localName - The local name (without prefix), or the empty string if Namespace processing is not being performed.
        qName - The qualified name (with prefix), or the empty string if qualified names are not available.
        attributes - The attributes attached to the element. If there are no attributes, it shall be an empty Attributes object.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        ContentHandler.startElement(java.lang.String, java.lang.String, java.lang.String, org.xml.sax.Attributes)

      • endElement

        public void endElement(String uri,
                       String localName,
                       String qName)
                throws SAXException
        Receive notification of the end of an element.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions at the end of each element (such as finalising a tree node or writing output to a file).

        Specified by:
        endElement in interface ContentHandler
        Parameters:
        uri - The Namespace URI, or the empty string if the element has no Namespace URI or if Namespace processing is not being performed.
        localName - The local name (without prefix), or the empty string if Namespace processing is not being performed.
        qName - The qualified name (with prefix), or the empty string if qualified names are not available.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        ContentHandler.endElement(java.lang.String, java.lang.String, java.lang.String)

      • characters

        public void characters(char[] ch,
                       int start,
                       int length)
                throws SAXException
        Receive notification of character data inside an element.

        By default, do nothing. Application writers may override this method to take specific actions for each chunk of character data (such as adding the data to a node or buffer, or printing it to a file).

        Specified by:
        characters in interface ContentHandler
        Parameters:
        ch - The characters.
        start - The start position in the character array.
        length - The number of characters to use from the character array.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        ContentHandler.characters(char[], int, int)

      • ignorableWhitespace

        public void ignorableWhitespace(char[] ch,
                                int start,
                                int length)
                         throws SAXException
        Receive notification of ignorable whitespace in element content.

        By default, do nothing. Application writers may override this method to take specific actions for each chunk of ignorable whitespace (such as adding data to a node or buffer, or printing it to a file).

        Specified by:
        ignorableWhitespace in interface ContentHandler
        Parameters:
        ch - The whitespace characters.
        start - The start position in the character array.
        length - The number of characters to use from the character array.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        ContentHandler.ignorableWhitespace(char[], int, int)

      • processingInstruction

        public void processingInstruction(String target,
                                  String data)
                           throws SAXException
        Receive notification of a processing instruction.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions for each processing instruction, such as setting status variables or invoking other methods.

        Specified by:
        processingInstruction in interface ContentHandler
        Parameters:
        target - The processing instruction target.
        data - The processing instruction data, or null if none is supplied.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        ContentHandler.processingInstruction(java.lang.String, java.lang.String)

      • skippedEntity

        public void skippedEntity(String name)
                   throws SAXException
        Receive notification of a skipped entity.

        By default, do nothing. Application writers may override this method in a subclass to take specific actions for each processing instruction, such as setting status variables or invoking other methods.

        Specified by:
        skippedEntity in interface ContentHandler
        Parameters:
        name - The name of the skipped entity.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        ContentHandler.processingInstruction(java.lang.String, java.lang.String)

      • warning

        public void warning(SAXParseException e)
             throws SAXException
        Receive notification of a parser warning.

        The default implementation does nothing. Application writers may override this method in a subclass to take specific actions for each warning, such as inserting the message in a log file or printing it to the console.

        Specified by:
        warning in interface ErrorHandler
        Parameters:
        e - The warning information encoded as an exception.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        ErrorHandler.warning(org.xml.sax.SAXParseException), SAXParseException

      • error

        public void error(SAXParseException e)
           throws SAXException
        Receive notification of a recoverable parser error.

        The default implementation does nothing. Application writers may override this method in a subclass to take specific actions for each error, such as inserting the message in a log file or printing it to the console.

        Specified by:
        error in interface ErrorHandler
        Parameters:
        e - The error information encoded as an exception.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        ErrorHandler.warning(org.xml.sax.SAXParseException), SAXParseException

      • fatalError

        public void fatalError(SAXParseException e)
                throws SAXException
        Report a fatal XML parsing error.

        The default implementation throws a SAXParseException. Application writers may override this method in a subclass if they need to take specific actions for each fatal error (such as collecting all of the errors into a single report): in any case, the application must stop all regular processing when this method is invoked, since the document is no longer reliable, and the parser may no longer report parsing events.

        Specified by:
        fatalError in interface ErrorHandler
        Parameters:
        e - The error information encoded as an exception.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        See Also:
        ErrorHandler.fatalError(org.xml.sax.SAXParseException), SAXParseException
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


LocatorImpl (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax.helpers

Class LocatorImpl

  • java.lang.Object
    • org.xml.sax.helpers.LocatorImpl
  • All Implemented Interfaces:
    Locator
    Direct Known Subclasses:
    Locator2Impl

    public class LocatorImpl
extends Object
implements Locator
    Provide an optional convenience implementation of Locator.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This class is available mainly for application writers, who can use it to make a persistent snapshot of a locator at any point during a document parse:

     Locator locator;
 Locator startloc;

 public void setLocator (Locator locator)
 {
         // note the locator
   this.locator = locator;
 }

 public void startDocument ()
 {
         // save the location of the start of the document
         // for future use.
   Locator startloc = new LocatorImpl(locator);
 }

    Normally, parser writers will not use this class, since it is more efficient to provide location information only when requested, rather than constantly updating a Locator object.

    Since:
    SAX 1.0
    See Also:
    Locator

    • Constructor Summary

      Constructors
      Constructor and Description
      LocatorImpl()
      Zero-argument constructor.
      LocatorImpl(Locator locator)
      Copy constructor.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      int getColumnNumber()
      Return the saved column number (1-based).
      int getLineNumber()
      Return the saved line number (1-based).
      String getPublicId()
      Return the saved public identifier.
      String getSystemId()
      Return the saved system identifier.
      void setColumnNumber(int columnNumber)
      Set the column number for this locator (1-based).
      void setLineNumber(int lineNumber)
      Set the line number for this locator (1-based).
      void setPublicId(String publicId)
      Set the public identifier for this locator.
      void setSystemId(String systemId)
      Set the system identifier for this locator.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • LocatorImpl

        public LocatorImpl()
        Zero-argument constructor.

        This will not normally be useful, since the main purpose of this class is to make a snapshot of an existing Locator.

      • LocatorImpl

        public LocatorImpl(Locator locator)
        Copy constructor.

        Create a persistent copy of the current state of a locator. When the original locator changes, this copy will still keep the original values (and it can be used outside the scope of DocumentHandler methods).

        Parameters:
        locator - The locator to copy.

    • Method Detail

      • getPublicId

        public String getPublicId()
        Return the saved public identifier.
        Specified by:
        getPublicId in interface Locator
        Returns:
        The public identifier as a string, or null if none is available.
        See Also:
        Locator.getPublicId(), setPublicId(java.lang.String)

      • getSystemId

        public String getSystemId()
        Return the saved system identifier.
        Specified by:
        getSystemId in interface Locator
        Returns:
        The system identifier as a string, or null if none is available.
        See Also:
        Locator.getSystemId(), setSystemId(java.lang.String)

      • getLineNumber

        public int getLineNumber()
        Return the saved line number (1-based).
        Specified by:
        getLineNumber in interface Locator
        Returns:
        The line number as an integer, or -1 if none is available.
        See Also:
        Locator.getLineNumber(), setLineNumber(int)

      • getColumnNumber

        public int getColumnNumber()
        Return the saved column number (1-based).
        Specified by:
        getColumnNumber in interface Locator
        Returns:
        The column number as an integer, or -1 if none is available.
        See Also:
        Locator.getColumnNumber(), setColumnNumber(int)

      • setPublicId

        public void setPublicId(String publicId)
        Set the public identifier for this locator.
        Parameters:
        publicId - The new public identifier, or null if none is available.
        See Also:
        getPublicId()

      • setSystemId

        public void setSystemId(String systemId)
        Set the system identifier for this locator.
        Parameters:
        systemId - The new system identifier, or null if none is available.
        See Also:
        getSystemId()

      • setLineNumber

        public void setLineNumber(int lineNumber)
        Set the line number for this locator (1-based).
        Parameters:
        lineNumber - The line number, or -1 if none is available.
        See Also:
        getLineNumber()

      • setColumnNumber

        public void setColumnNumber(int columnNumber)
        Set the column number for this locator (1-based).
        Parameters:
        columnNumber - The column number, or -1 if none is available.
        See Also:
        getColumnNumber()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


NamespaceSupport (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax.helpers

Class NamespaceSupport

  • java.lang.Object
    • org.xml.sax.helpers.NamespaceSupport

  • public class NamespaceSupport
extends Object
    Encapsulate Namespace logic for use by applications using SAX, or internally by SAX drivers.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This class encapsulates the logic of Namespace processing: it tracks the declarations currently in force for each context and automatically processes qualified XML names into their Namespace parts; it can also be used in reverse for generating XML qnames from Namespaces.

    Namespace support objects are reusable, but the reset method must be invoked between each session.

    Here is a simple session:

     String parts[] = new String[3];
 NamespaceSupport support = new NamespaceSupport();

 support.pushContext();
 support.declarePrefix("", "http://www.w3.org/1999/xhtml");
 support.declarePrefix("dc", "http://www.purl.org/dc#");

 parts = support.processName("p", parts, false);
 System.out.println("Namespace URI: " + parts[0]);
 System.out.println("Local name: " + parts[1]);
 System.out.println("Raw name: " + parts[2]);

 parts = support.processName("dc:title", parts, false);
 System.out.println("Namespace URI: " + parts[0]);
 System.out.println("Local name: " + parts[1]);
 System.out.println("Raw name: " + parts[2]);

 support.popContext();

    Note that this class is optimized for the use case where most elements do not contain Namespace declarations: if the same prefix/URI mapping is repeated for each context (for example), this class will be somewhat less efficient.

    Although SAX drivers (parsers) may choose to use this class to implement namespace handling, they are not required to do so. Applications must track namespace information themselves if they want to use namespace information.

    Since:
    SAX 2.0

    • Field Summary

      Fields
      Modifier and Type Field and Description
      static String NSDECL
      The namespace declaration URI as a constant.
      static String XMLNS
      The XML Namespace URI as a constant.

    • Constructor Summary

      Constructors
      Constructor and Description
      NamespaceSupport()
      Create a new Namespace support object.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      boolean declarePrefix(String prefix, String uri)
      Declare a Namespace prefix.
      Enumeration getDeclaredPrefixes()
      Return an enumeration of all prefixes declared in this context.
      String getPrefix(String uri)
      Return one of the prefixes mapped to a Namespace URI.
      Enumeration getPrefixes()
      Return an enumeration of all prefixes whose declarations are active in the current context.
      Enumeration getPrefixes(String uri)
      Return an enumeration of all prefixes for a given URI whose declarations are active in the current context.
      String getURI(String prefix)
      Look up a prefix and get the currently-mapped Namespace URI.
      boolean isNamespaceDeclUris()
      Returns true if namespace declaration attributes are placed into a namespace.
      void popContext()
      Revert to the previous Namespace context.
      String[] processName(String qName, String[] parts, boolean isAttribute)
      Process a raw XML qualified name, after all declarations in the current context have been handled by declarePrefix().
      void pushContext()
      Start a new Namespace context.
      void reset()
      Reset this Namespace support object for reuse.
      void setNamespaceDeclUris(boolean value)
      Controls whether namespace declaration attributes are placed into the NSDECL namespace by processName().

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Field Detail

      • XMLNS

        public static final String XMLNS
        The XML Namespace URI as a constant. The value is http://www.w3.org/XML/1998/namespace as defined in the "Namespaces in XML" * recommendation.

        This is the Namespace URI that is automatically mapped to the "xml" prefix.

        See Also:
        Constant Field Values

      • NSDECL

        public static final String NSDECL
        The namespace declaration URI as a constant. The value is http://www.w3.org/xmlns/2000/, as defined in a backwards-incompatible erratum to the "Namespaces in XML" recommendation. Because that erratum postdated SAX2, SAX2 defaults to the original recommendation, and does not normally use this URI.

        This is the Namespace URI that is optionally applied to xmlns and xmlns:* attributes, which are used to declare namespaces.

        Since:
        SAX 2.1alpha
        See Also:
        setNamespaceDeclUris(boolean), isNamespaceDeclUris(), Constant Field Values

    • Constructor Detail

      • NamespaceSupport

        public NamespaceSupport()
        Create a new Namespace support object.

    • Method Detail

      • reset

        public void reset()
        Reset this Namespace support object for reuse.

        It is necessary to invoke this method before reusing the Namespace support object for a new session. If namespace declaration URIs are to be supported, that flag must also be set to a non-default value.

        See Also:
        setNamespaceDeclUris(boolean)

      • pushContext

        public void pushContext()
        Start a new Namespace context. The new context will automatically inherit the declarations of its parent context, but it will also keep track of which declarations were made within this context.

        Event callback code should start a new context once per element. This means being ready to call this in either of two places. For elements that don't include namespace declarations, the ContentHandler.startElement() callback is the right place. For elements with such a declaration, it'd done in the first ContentHandler.startPrefixMapping() callback. A boolean flag can be used to track whether a context has been started yet. When either of those methods is called, it checks the flag to see if a new context needs to be started. If so, it starts the context and sets the flag. After ContentHandler.startElement() does that, it always clears the flag.

        Normally, SAX drivers would push a new context at the beginning of each XML element. Then they perform a first pass over the attributes to process all namespace declarations, making ContentHandler.startPrefixMapping() callbacks. Then a second pass is made, to determine the namespace-qualified names for all attributes and for the element name. Finally all the information for the ContentHandler.startElement() callback is available, so it can then be made.

        The Namespace support object always starts with a base context already in force: in this context, only the "xml" prefix is declared.

        See Also:
        ContentHandler, popContext()

      • popContext

        public void popContext()
        Revert to the previous Namespace context.

        Normally, you should pop the context at the end of each XML element. After popping the context, all Namespace prefix mappings that were previously in force are restored.

        You must not attempt to declare additional Namespace prefixes after popping a context, unless you push another context first.

        See Also:
        pushContext()

      • declarePrefix

        public boolean declarePrefix(String prefix,
                             String uri)
        Declare a Namespace prefix. All prefixes must be declared before they are referenced. For example, a SAX driver (parser) would scan an element's attributes in two passes: first for namespace declarations, then a second pass using processName() to interpret prefixes against (potentially redefined) prefixes.

        This method declares a prefix in the current Namespace context; the prefix will remain in force until this context is popped, unless it is shadowed in a descendant context.

        To declare the default element Namespace, use the empty string as the prefix.

        Note that there is an asymmetry in this library: getPrefix will not return the "" prefix, even if you have declared a default element namespace. To check for a default namespace, you have to look it up explicitly using getURI. This asymmetry exists to make it easier to look up prefixes for attribute names, where the default prefix is not allowed.

        Parameters:
        prefix - The prefix to declare, or the empty string to indicate the default element namespace. This may never have the value "xml" or "xmlns".
        uri - The Namespace URI to associate with the prefix.
        Returns:
        true if the prefix was legal, false otherwise
        See Also:
        processName(java.lang.String, java.lang.String[], boolean),
getURI(java.lang.String),
getPrefix(java.lang.String)

      • processName

        public String[] processName(String qName,
                            String[] parts,
                            boolean isAttribute)
        Process a raw XML qualified name, after all declarations in the current context have been handled by declarePrefix().

        This method processes a raw XML qualified name in the current context by removing the prefix and looking it up among the prefixes currently declared. The return value will be the array supplied by the caller, filled in as follows:

        parts[0]
        The Namespace URI, or an empty string if none is in use.
        parts[1]
        The local name (without prefix).
        parts[2]
        The original raw name.

        All of the strings in the array will be internalized. If the raw name has a prefix that has not been declared, then the return value will be null.

        Note that attribute names are processed differently than element names: an unprefixed element name will receive the default Namespace (if any), while an unprefixed attribute name will not.

        Parameters:
        qName - The XML qualified name to be processed.
        parts - An array supplied by the caller, capable of holding at least three members.
        isAttribute - A flag indicating whether this is an attribute name (true) or an element name (false).
        Returns:
        The supplied array holding three internalized strings representing the Namespace URI (or empty string), the local name, and the XML qualified name; or null if there is an undeclared prefix.
        See Also:
        declarePrefix(java.lang.String, java.lang.String), String.intern()

      • getURI

        public String getURI(String prefix)
        Look up a prefix and get the currently-mapped Namespace URI.

        This method looks up the prefix in the current context. Use the empty string ("") for the default Namespace.

        Parameters:
        prefix - The prefix to look up.
        Returns:
        The associated Namespace URI, or null if the prefix is undeclared in this context.
        See Also:
        getPrefix(java.lang.String), getPrefixes()

      • getPrefixes

        public Enumeration getPrefixes()
        Return an enumeration of all prefixes whose declarations are active in the current context. This includes declarations from parent contexts that have not been overridden.

        Note: if there is a default prefix, it will not be returned in this enumeration; check for the default prefix using the getURI with an argument of "".

        Returns:
        An enumeration of prefixes (never empty).
        See Also:
        getDeclaredPrefixes(), getURI(java.lang.String)

      • getPrefix

        public String getPrefix(String uri)
        Return one of the prefixes mapped to a Namespace URI.

        If more than one prefix is currently mapped to the same URI, this method will make an arbitrary selection; if you want all of the prefixes, use the getPrefixes() method instead.

        Note: this will never return the empty (default) prefix; to check for a default prefix, use the getURI method with an argument of "".

        Parameters:
        uri - the namespace URI
        Returns:
        one of the prefixes currently mapped to the URI supplied, or null if none is mapped or if the URI is assigned to the default namespace
        See Also:
        getPrefixes(java.lang.String), getURI(java.lang.String)

      • getPrefixes

        public Enumeration getPrefixes(String uri)
        Return an enumeration of all prefixes for a given URI whose declarations are active in the current context. This includes declarations from parent contexts that have not been overridden.

        This method returns prefixes mapped to a specific Namespace URI. The xml: prefix will be included. If you want only one prefix that's mapped to the Namespace URI, and you don't care which one you get, use the getPrefix method instead.

        Note: the empty (default) prefix is never included in this enumeration; to check for the presence of a default Namespace, use the getURI method with an argument of "".

        Parameters:
        uri - The Namespace URI.
        Returns:
        An enumeration of prefixes (never empty).
        See Also:
        getPrefix(java.lang.String),
getDeclaredPrefixes(),
getURI(java.lang.String)

      • getDeclaredPrefixes

        public Enumeration getDeclaredPrefixes()
        Return an enumeration of all prefixes declared in this context.

        The empty (default) prefix will be included in this enumeration; note that this behaviour differs from that of getPrefix(java.lang.String) and getPrefixes().

        Returns:
        An enumeration of all prefixes declared in this context.
        See Also:
        getPrefixes(), getURI(java.lang.String)

      • setNamespaceDeclUris

        public void setNamespaceDeclUris(boolean value)
        Controls whether namespace declaration attributes are placed into the NSDECL namespace by processName(). This may only be changed before any contexts have been pushed.
        Throws:
        IllegalStateException - when attempting to set this after any context has been pushed.
        Since:
        SAX 2.1alpha

      • isNamespaceDeclUris

        public boolean isNamespaceDeclUris()
        Returns true if namespace declaration attributes are placed into a namespace. This behavior is not the default.
        Since:
        SAX 2.1alpha
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


org.xml.sax.helpers (Java Platform SE 8 )

org.xml.sax.helpers

Classes

  • AttributeListImpl
  • AttributesImpl
  • DefaultHandler
  • LocatorImpl
  • NamespaceSupport
  • ParserAdapter
  • ParserFactory
  • XMLFilterImpl
  • XMLReaderAdapter
  • XMLReaderFactory


org.xml.sax.helpers (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.xml.sax.helpers

This package contains "helper" classes, including support for bootstrapping SAX-based applications.

See: Description

  • Class Summary
    Class Description
    AttributeListImpl Deprecated
    This class implements a deprecated interface, AttributeList; that interface has been replaced by Attributes, which is implemented in the AttributesImpl helper class.
    AttributesImpl
    Default implementation of the Attributes interface.
    DefaultHandler
    Default base class for SAX2 event handlers.
    LocatorImpl
    Provide an optional convenience implementation of Locator.
    NamespaceSupport
    Encapsulate Namespace logic for use by applications using SAX, or internally by SAX drivers.
    ParserAdapter
    Adapt a SAX1 Parser as a SAX2 XMLReader.
    ParserFactory Deprecated
    This class works with the deprecated Parser interface.
    XMLFilterImpl
    Base class for deriving an XML filter.
    XMLReaderAdapter
    Adapt a SAX2 XMLReader as a SAX1 Parser.
    XMLReaderFactory
    Factory for creating an XML reader.

Package org.xml.sax.helpers Description

This package contains "helper" classes, including support for bootstrapping SAX-based applications.

See http://www.saxproject.org for more information about SAX.

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames


org.xml.sax.helpers Class Hierarchy (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.xml.sax.helpers

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.xml.sax.helpers.AttributeListImpl (implements org.xml.sax.AttributeList)
    • org.xml.sax.helpers.AttributesImpl (implements org.xml.sax.Attributes)
    • org.xml.sax.helpers.DefaultHandler (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
    • org.xml.sax.helpers.LocatorImpl (implements org.xml.sax.Locator)
    • org.xml.sax.helpers.NamespaceSupport
    • org.xml.sax.helpers.ParserAdapter (implements org.xml.sax.DocumentHandler, org.xml.sax.XMLReader)
    • org.xml.sax.helpers.ParserFactory
    • org.xml.sax.helpers.XMLFilterImpl (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler, org.xml.sax.XMLFilter)
    • org.xml.sax.helpers.XMLReaderAdapter (implements org.xml.sax.ContentHandler, org.xml.sax.Parser)
    • org.xml.sax.helpers.XMLReaderFactory
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package org.xml.sax.helpers (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.xml.sax.helpers

  • Packages that use org.xml.sax.helpers
    Package Description
    java.beans
    Contains classes related to developing beans -- components based on the JavaBeans™ architecture.
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.
  • Classes in org.xml.sax.helpers used by java.beans
    Class and Description
    DefaultHandler
    Default base class for SAX2 event handlers.
  • Classes in org.xml.sax.helpers used by javax.xml.parsers
    Class and Description
    DefaultHandler
    Default base class for SAX2 event handlers.
  • Classes in org.xml.sax.helpers used by org.xml.sax.ext
    Class and Description
    AttributesImpl
    Default implementation of the Attributes interface.
    DefaultHandler
    Default base class for SAX2 event handlers.
    LocatorImpl
    Provide an optional convenience implementation of Locator.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


ParserAdapter (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax.helpers

Class ParserAdapter

  • java.lang.Object
    • org.xml.sax.helpers.ParserAdapter
  • All Implemented Interfaces:
    DocumentHandler, XMLReader

    public class ParserAdapter
extends Object
implements XMLReader, DocumentHandler
    Adapt a SAX1 Parser as a SAX2 XMLReader.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This class wraps a SAX1 Parser and makes it act as a SAX2 XMLReader, with feature, property, and Namespace support. Note that it is not possible to report skippedEntity events, since SAX1 does not make that information available.

    This adapter does not test for duplicate Namespace-qualified attribute names.

    Since:
    SAX 2.0
    Version:
    2.0.1 (sax2r2)
    See Also:
    XMLReaderAdapter, XMLReader, Parser

    • Constructor Summary

      Constructors
      Constructor and Description
      ParserAdapter()
      Construct a new parser adapter.
      ParserAdapter(Parser parser)
      Construct a new parser adapter.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void characters(char[] ch, int start, int length)
      Adapter implementation method; do not call.
      void endDocument()
      Adapter implementation method; do not call.
      void endElement(String qName)
      Adapter implementation method; do not call.
      ContentHandler getContentHandler()
      Return the current content handler.
      DTDHandler getDTDHandler()
      Return the current DTD handler.
      EntityResolver getEntityResolver()
      Return the current entity resolver.
      ErrorHandler getErrorHandler()
      Return the current error handler.
      boolean getFeature(String name)
      Check a parser feature flag.
      Object getProperty(String name)
      Get a parser property.
      void ignorableWhitespace(char[] ch, int start, int length)
      Adapter implementation method; do not call.
      void parse(InputSource input)
      Parse an XML document.
      void parse(String systemId)
      Parse an XML document.
      void processingInstruction(String target, String data)
      Adapter implementation method; do not call.
      void setContentHandler(ContentHandler handler)
      Set the content handler.
      void setDocumentLocator(Locator locator)
      Adapter implementation method; do not call.
      void setDTDHandler(DTDHandler handler)
      Set the DTD handler.
      void setEntityResolver(EntityResolver resolver)
      Set the entity resolver.
      void setErrorHandler(ErrorHandler handler)
      Set the error handler.
      void setFeature(String name, boolean value)
      Set a feature flag for the parser.
      void setProperty(String name, Object value)
      Set a parser property.
      void startDocument()
      Adapter implementation method; do not call.
      void startElement(String qName, AttributeList qAtts)
      Adapter implementation method; do not call.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • ParserAdapter

        public ParserAdapter()
              throws SAXException
        Construct a new parser adapter.

        Use the "org.xml.sax.parser" property to locate the embedded SAX1 driver.

        Throws:
        SAXException - If the embedded driver cannot be instantiated or if the org.xml.sax.parser property is not specified.

      • ParserAdapter

        public ParserAdapter(Parser parser)
        Construct a new parser adapter.

        Note that the embedded parser cannot be changed once the adapter is created; to embed a different parser, allocate a new ParserAdapter.

        Parameters:
        parser - The SAX1 parser to embed.
        Throws:
        NullPointerException - If the parser parameter is null.

    • Method Detail

      • setFeature

        public void setFeature(String name,
                       boolean value)
                throws SAXNotRecognizedException,
                       SAXNotSupportedException
        Set a feature flag for the parser.

        The only features recognized are namespaces and namespace-prefixes.

        Specified by:
        setFeature in interface XMLReader
        Parameters:
        name - The feature name, as a complete URI.
        value - The requested feature value.
        Throws:
        SAXNotRecognizedException - If the feature can't be assigned or retrieved.
        SAXNotSupportedException - If the feature can't be assigned that value.
        See Also:
        XMLReader.setFeature(java.lang.String, boolean)

      • getFeature

        public boolean getFeature(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
        Check a parser feature flag.

        The only features recognized are namespaces and namespace-prefixes.

        Specified by:
        getFeature in interface XMLReader
        Parameters:
        name - The feature name, as a complete URI.
        Returns:
        The current feature value.
        Throws:
        SAXNotRecognizedException - If the feature value can't be assigned or retrieved.
        SAXNotSupportedException - If the feature is not currently readable.
        See Also:
        XMLReader.setFeature(java.lang.String, boolean)

      • setProperty

        public void setProperty(String name,
                        Object value)
                 throws SAXNotRecognizedException,
                        SAXNotSupportedException
        Set a parser property.

        No properties are currently recognized.

        Specified by:
        setProperty in interface XMLReader
        Parameters:
        name - The property name.
        value - The property value.
        Throws:
        SAXNotRecognizedException - If the property value can't be assigned or retrieved.
        SAXNotSupportedException - If the property can't be assigned that value.
        See Also:
        XMLReader.setProperty(java.lang.String, java.lang.Object)

      • getProperty

        public Object getProperty(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
        Get a parser property.

        No properties are currently recognized.

        Specified by:
        getProperty in interface XMLReader
        Parameters:
        name - The property name.
        Returns:
        The property value.
        Throws:
        SAXNotRecognizedException - If the property value can't be assigned or retrieved.
        SAXNotSupportedException - If the property value is not currently readable.
        See Also:
        XMLReader.getProperty(java.lang.String)

      • setEntityResolver

        public void setEntityResolver(EntityResolver resolver)
        Set the entity resolver.
        Specified by:
        setEntityResolver in interface XMLReader
        Parameters:
        resolver - The new entity resolver.
        See Also:
        XMLReader.setEntityResolver(org.xml.sax.EntityResolver)

      • getEntityResolver

        public EntityResolver getEntityResolver()
        Return the current entity resolver.
        Specified by:
        getEntityResolver in interface XMLReader
        Returns:
        The current entity resolver, or null if none was supplied.
        See Also:
        XMLReader.getEntityResolver()

      • setDTDHandler

        public void setDTDHandler(DTDHandler handler)
        Set the DTD handler.
        Specified by:
        setDTDHandler in interface XMLReader
        Parameters:
        handler - the new DTD handler
        See Also:
        XMLReader.setEntityResolver(org.xml.sax.EntityResolver)

      • getDTDHandler

        public DTDHandler getDTDHandler()
        Return the current DTD handler.
        Specified by:
        getDTDHandler in interface XMLReader
        Returns:
        the current DTD handler, or null if none was supplied
        See Also:
        XMLReader.getEntityResolver()

      • setContentHandler

        public void setContentHandler(ContentHandler handler)
        Set the content handler.
        Specified by:
        setContentHandler in interface XMLReader
        Parameters:
        handler - the new content handler
        See Also:
        XMLReader.setEntityResolver(org.xml.sax.EntityResolver)

      • getContentHandler

        public ContentHandler getContentHandler()
        Return the current content handler.
        Specified by:
        getContentHandler in interface XMLReader
        Returns:
        The current content handler, or null if none was supplied.
        See Also:
        XMLReader.getEntityResolver()

      • setErrorHandler

        public void setErrorHandler(ErrorHandler handler)
        Set the error handler.
        Specified by:
        setErrorHandler in interface XMLReader
        Parameters:
        handler - The new error handler.
        See Also:
        XMLReader.setEntityResolver(org.xml.sax.EntityResolver)

      • getErrorHandler

        public ErrorHandler getErrorHandler()
        Return the current error handler.
        Specified by:
        getErrorHandler in interface XMLReader
        Returns:
        The current error handler, or null if none was supplied.
        See Also:
        XMLReader.getEntityResolver()

      • parse

        public void parse(String systemId)
           throws IOException,
                  SAXException
        Parse an XML document.
        Specified by:
        parse in interface XMLReader
        Parameters:
        systemId - The absolute URL of the document.
        Throws:
        IOException - If there is a problem reading the raw content of the document.
        SAXException - If there is a problem processing the document.
        See Also:
        parse(org.xml.sax.InputSource), Parser.parse(java.lang.String)

      • parse

        public void parse(InputSource input)
           throws IOException,
                  SAXException
        Parse an XML document.
        Specified by:
        parse in interface XMLReader
        Parameters:
        input - An input source for the document.
        Throws:
        IOException - If there is a problem reading the raw content of the document.
        SAXException - If there is a problem processing the document.
        See Also:
        parse(java.lang.String), Parser.parse(org.xml.sax.InputSource)

      • setDocumentLocator

        public void setDocumentLocator(Locator locator)
        Adapter implementation method; do not call. Adapt a SAX1 document locator event.
        Specified by:
        setDocumentLocator in interface DocumentHandler
        Parameters:
        locator - A document locator.
        See Also:
        ContentHandler.setDocumentLocator(org.xml.sax.Locator)

      • startDocument

        public void startDocument()
                   throws SAXException
        Adapter implementation method; do not call. Adapt a SAX1 start document event.
        Specified by:
        startDocument in interface DocumentHandler
        Throws:
        SAXException - The client may raise a processing exception.
        See Also:
        DocumentHandler.startDocument()

      • endDocument

        public void endDocument()
                 throws SAXException
        Adapter implementation method; do not call. Adapt a SAX1 end document event.
        Specified by:
        endDocument in interface DocumentHandler
        Throws:
        SAXException - The client may raise a processing exception.
        See Also:
        DocumentHandler.endDocument()

      • startElement

        public void startElement(String qName,
                         AttributeList qAtts)
                  throws SAXException
        Adapter implementation method; do not call. Adapt a SAX1 startElement event.

        If necessary, perform Namespace processing.

        Specified by:
        startElement in interface DocumentHandler
        Parameters:
        qName - The qualified (prefixed) name.
        qAtts - The XML attribute list (with qnames).
        Throws:
        SAXException - The client may raise a processing exception.
        See Also:
        DocumentHandler.endElement(java.lang.String), AttributeList

      • endElement

        public void endElement(String qName)
                throws SAXException
        Adapter implementation method; do not call. Adapt a SAX1 end element event.
        Specified by:
        endElement in interface DocumentHandler
        Parameters:
        qName - The qualified (prefixed) name.
        Throws:
        SAXException - The client may raise a processing exception.
        See Also:
        DocumentHandler.endElement(java.lang.String)

      • characters

        public void characters(char[] ch,
                       int start,
                       int length)
                throws SAXException
        Adapter implementation method; do not call. Adapt a SAX1 characters event.
        Specified by:
        characters in interface DocumentHandler
        Parameters:
        ch - An array of characters.
        start - The starting position in the array.
        length - The number of characters to use.
        Throws:
        SAXException - The client may raise a processing exception.
        See Also:
        DocumentHandler.characters(char[], int, int)

      • ignorableWhitespace

        public void ignorableWhitespace(char[] ch,
                                int start,
                                int length)
                         throws SAXException
        Adapter implementation method; do not call. Adapt a SAX1 ignorable whitespace event.
        Specified by:
        ignorableWhitespace in interface DocumentHandler
        Parameters:
        ch - An array of characters.
        start - The starting position in the array.
        length - The number of characters to use.
        Throws:
        SAXException - The client may raise a processing exception.
        See Also:
        DocumentHandler.ignorableWhitespace(char[], int, int)

      • processingInstruction

        public void processingInstruction(String target,
                                  String data)
                           throws SAXException
        Adapter implementation method; do not call. Adapt a SAX1 processing instruction event.
        Specified by:
        processingInstruction in interface DocumentHandler
        Parameters:
        target - The processing instruction target.
        data - The remainder of the processing instruction
        Throws:
        SAXException - The client may raise a processing exception.
        See Also:
        DocumentHandler.processingInstruction(java.lang.String, java.lang.String)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


ParserFactory (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax.helpers

Class ParserFactory

  • java.lang.Object
    • org.xml.sax.helpers.ParserFactory
  • Deprecated.
    This class works with the deprecated Parser interface.

    public class ParserFactory
extends Object
    Java-specific class for dynamically loading SAX parsers.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    Note: This class is designed to work with the now-deprecated SAX1 Parser class. SAX2 applications should use XMLReaderFactory instead.

    ParserFactory is not part of the platform-independent definition of SAX; it is an additional convenience class designed specifically for Java XML application writers. SAX applications can use the static methods in this class to allocate a SAX parser dynamically at run-time based either on the value of the `org.xml.sax.parser' system property or on a string containing the class name.

    Note that the application still requires an XML parser that implements SAX1.

    Since:
    SAX 1.0
    Version:
    2.0.1 (sax2r2)

    • Method Summary

      All Methods Static Methods Concrete Methods Deprecated Methods
      Modifier and Type Method and Description
      static Parser makeParser()
      Deprecated.
      Create a new SAX parser using the `org.xml.sax.parser' system property.
      static Parser makeParser(String className)
      Deprecated.
      Create a new SAX parser object using the class name provided.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Method Detail

      • makeParser

        public static Parser makeParser()
                         throws ClassNotFoundException,
                                IllegalAccessException,
                                InstantiationException,
                                NullPointerException,
                                ClassCastException
        Deprecated.
        Create a new SAX parser using the `org.xml.sax.parser' system property.

        The named class must exist and must implement the Parser interface.

        Throws:
        NullPointerException - There is no value for the `org.xml.sax.parser' system property.
        ClassNotFoundException - The SAX parser class was not found (check your CLASSPATH).
        IllegalAccessException - The SAX parser class was found, but you do not have permission to load it.
        InstantiationException - The SAX parser class was found but could not be instantiated.
        ClassCastException - The SAX parser class was found and instantiated, but does not implement org.xml.sax.Parser.
        See Also:
        makeParser(java.lang.String), Parser

      • makeParser

        public static Parser makeParser(String className)
                         throws ClassNotFoundException,
                                IllegalAccessException,
                                InstantiationException,
                                ClassCastException
        Deprecated.
        Create a new SAX parser object using the class name provided.

        The named class must exist and must implement the Parser interface.

        Parameters:
        className - A string containing the name of the SAX parser class.
        Throws:
        ClassNotFoundException - The SAX parser class was not found (check your CLASSPATH).
        IllegalAccessException - The SAX parser class was found, but you do not have permission to load it.
        InstantiationException - The SAX parser class was found but could not be instantiated.
        ClassCastException - The SAX parser class was found and instantiated, but does not implement org.xml.sax.Parser.
        See Also:
        makeParser(), Parser
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


XMLFilterImpl (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax.helpers

Class XMLFilterImpl

  • java.lang.Object
    • org.xml.sax.helpers.XMLFilterImpl
  • All Implemented Interfaces:
    ContentHandler, DTDHandler, EntityResolver, ErrorHandler, XMLFilter, XMLReader

    public class XMLFilterImpl
extends Object
implements XMLFilter, EntityResolver, DTDHandler, ContentHandler, ErrorHandler
    Base class for deriving an XML filter.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This class is designed to sit between an XMLReader and the client application's event handlers. By default, it does nothing but pass requests up to the reader and events on to the handlers unmodified, but subclasses can override specific methods to modify the event stream or the configuration requests as they pass through.

    Since:
    SAX 2.0
    See Also:
    XMLFilter, XMLReader, EntityResolver, DTDHandler, ContentHandler, ErrorHandler

    • Constructor Summary

      Constructors
      Constructor and Description
      XMLFilterImpl()
      Construct an empty XML filter, with no parent.
      XMLFilterImpl(XMLReader parent)
      Construct an XML filter with the specified parent.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void characters(char[] ch, int start, int length)
      Filter a character data event.
      void endDocument()
      Filter an end document event.
      void endElement(String uri, String localName, String qName)
      Filter an end element event.
      void endPrefixMapping(String prefix)
      Filter an end Namespace prefix mapping event.
      void error(SAXParseException e)
      Filter an error event.
      void fatalError(SAXParseException e)
      Filter a fatal error event.
      ContentHandler getContentHandler()
      Get the content event handler.
      DTDHandler getDTDHandler()
      Get the current DTD event handler.
      EntityResolver getEntityResolver()
      Get the current entity resolver.
      ErrorHandler getErrorHandler()
      Get the current error event handler.
      boolean getFeature(String name)
      Look up the value of a feature.
      XMLReader getParent()
      Get the parent reader.
      Object getProperty(String name)
      Look up the value of a property.
      void ignorableWhitespace(char[] ch, int start, int length)
      Filter an ignorable whitespace event.
      void notationDecl(String name, String publicId, String systemId)
      Filter a notation declaration event.
      void parse(InputSource input)
      Parse a document.
      void parse(String systemId)
      Parse a document.
      void processingInstruction(String target, String data)
      Filter a processing instruction event.
      InputSource resolveEntity(String publicId, String systemId)
      Filter an external entity resolution.
      void setContentHandler(ContentHandler handler)
      Set the content event handler.
      void setDocumentLocator(Locator locator)
      Filter a new document locator event.
      void setDTDHandler(DTDHandler handler)
      Set the DTD event handler.
      void setEntityResolver(EntityResolver resolver)
      Set the entity resolver.
      void setErrorHandler(ErrorHandler handler)
      Set the error event handler.
      void setFeature(String name, boolean value)
      Set the value of a feature.
      void setParent(XMLReader parent)
      Set the parent reader.
      void setProperty(String name, Object value)
      Set the value of a property.
      void skippedEntity(String name)
      Filter a skipped entity event.
      void startDocument()
      Filter a start document event.
      void startElement(String uri, String localName, String qName, Attributes atts)
      Filter a start element event.
      void startPrefixMapping(String prefix, String uri)
      Filter a start Namespace prefix mapping event.
      void unparsedEntityDecl(String name, String publicId, String systemId, String notationName)
      Filter an unparsed entity declaration event.
      void warning(SAXParseException e)
      Filter a warning event.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • XMLFilterImpl

        public XMLFilterImpl()
        Construct an empty XML filter, with no parent.

        This filter will have no parent: you must assign a parent before you start a parse or do any configuration with setFeature or setProperty, unless you use this as a pure event consumer rather than as an XMLReader.

        See Also:
        XMLReader.setFeature(java.lang.String, boolean),
XMLReader.setProperty(java.lang.String, java.lang.Object),
setParent(org.xml.sax.XMLReader)

      • XMLFilterImpl

        public XMLFilterImpl(XMLReader parent)
        Construct an XML filter with the specified parent.
        See Also:
        setParent(org.xml.sax.XMLReader), getParent()

    • Method Detail

      • setParent

        public void setParent(XMLReader parent)
        Set the parent reader.

        This is the XMLReader from which this filter will obtain its events and to which it will pass its configuration requests. The parent may itself be another filter.

        If there is no parent reader set, any attempt to parse or to set or get a feature or property will fail.

        Specified by:
        setParent in interface XMLFilter
        Parameters:
        parent - The parent XML reader.
        See Also:
        getParent()

      • getParent

        public XMLReader getParent()
        Get the parent reader.
        Specified by:
        getParent in interface XMLFilter
        Returns:
        The parent XML reader, or null if none is set.
        See Also:
        setParent(org.xml.sax.XMLReader)

      • setFeature

        public void setFeature(String name,
                       boolean value)
                throws SAXNotRecognizedException,
                       SAXNotSupportedException
        Set the value of a feature.

        This will always fail if the parent is null.

        Specified by:
        setFeature in interface XMLReader
        Parameters:
        name - The feature name.
        value - The requested feature value.
        Throws:
        SAXNotRecognizedException - If the feature value can't be assigned or retrieved from the parent.
        SAXNotSupportedException - When the parent recognizes the feature name but cannot set the requested value.
        See Also:
        XMLReader.getFeature(java.lang.String)

      • getFeature

        public boolean getFeature(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
        Look up the value of a feature.

        This will always fail if the parent is null.

        Specified by:
        getFeature in interface XMLReader
        Parameters:
        name - The feature name.
        Returns:
        The current value of the feature.
        Throws:
        SAXNotRecognizedException - If the feature value can't be assigned or retrieved from the parent.
        SAXNotSupportedException - When the parent recognizes the feature name but cannot determine its value at this time.
        See Also:
        XMLReader.setFeature(java.lang.String, boolean)

      • setProperty

        public void setProperty(String name,
                        Object value)
                 throws SAXNotRecognizedException,
                        SAXNotSupportedException
        Set the value of a property.

        This will always fail if the parent is null.

        Specified by:
        setProperty in interface XMLReader
        Parameters:
        name - The property name.
        value - The requested property value.
        Throws:
        SAXNotRecognizedException - If the property value can't be assigned or retrieved from the parent.
        SAXNotSupportedException - When the parent recognizes the property name but cannot set the requested value.

      • getProperty

        public Object getProperty(String name)
                   throws SAXNotRecognizedException,
                          SAXNotSupportedException
        Look up the value of a property.
        Specified by:
        getProperty in interface XMLReader
        Parameters:
        name - The property name.
        Returns:
        The current value of the property.
        Throws:
        SAXNotRecognizedException - If the property value can't be assigned or retrieved from the parent.
        SAXNotSupportedException - When the parent recognizes the property name but cannot determine its value at this time.
        See Also:
        XMLReader.setProperty(java.lang.String, java.lang.Object)

      • setEntityResolver

        public void setEntityResolver(EntityResolver resolver)
        Set the entity resolver.
        Specified by:
        setEntityResolver in interface XMLReader
        Parameters:
        resolver - The new entity resolver.
        See Also:
        XMLReader.getEntityResolver()

      • getEntityResolver

        public EntityResolver getEntityResolver()
        Get the current entity resolver.
        Specified by:
        getEntityResolver in interface XMLReader
        Returns:
        The current entity resolver, or null if none was set.
        See Also:
        XMLReader.setEntityResolver(org.xml.sax.EntityResolver)

      • setDTDHandler

        public void setDTDHandler(DTDHandler handler)
        Set the DTD event handler.
        Specified by:
        setDTDHandler in interface XMLReader
        Parameters:
        handler - the new DTD handler
        See Also:
        XMLReader.getDTDHandler()

      • getDTDHandler

        public DTDHandler getDTDHandler()
        Get the current DTD event handler.
        Specified by:
        getDTDHandler in interface XMLReader
        Returns:
        The current DTD handler, or null if none was set.
        See Also:
        XMLReader.setDTDHandler(org.xml.sax.DTDHandler)

      • setContentHandler

        public void setContentHandler(ContentHandler handler)
        Set the content event handler.
        Specified by:
        setContentHandler in interface XMLReader
        Parameters:
        handler - the new content handler
        See Also:
        XMLReader.getContentHandler()

      • getContentHandler

        public ContentHandler getContentHandler()
        Get the content event handler.
        Specified by:
        getContentHandler in interface XMLReader
        Returns:
        The current content handler, or null if none was set.
        See Also:
        XMLReader.setContentHandler(org.xml.sax.ContentHandler)

      • setErrorHandler

        public void setErrorHandler(ErrorHandler handler)
        Set the error event handler.
        Specified by:
        setErrorHandler in interface XMLReader
        Parameters:
        handler - the new error handler
        See Also:
        XMLReader.getErrorHandler()

      • getErrorHandler

        public ErrorHandler getErrorHandler()
        Get the current error event handler.
        Specified by:
        getErrorHandler in interface XMLReader
        Returns:
        The current error handler, or null if none was set.
        See Also:
        XMLReader.setErrorHandler(org.xml.sax.ErrorHandler)

      • parse

        public void parse(InputSource input)
           throws SAXException,
                  IOException
        Parse a document.
        Specified by:
        parse in interface XMLReader
        Parameters:
        input - The input source for the document entity.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        IOException - An IO exception from the parser, possibly from a byte stream or character stream supplied by the application.
        See Also:
        InputSource,
XMLReader.parse(java.lang.String),
XMLReader.setEntityResolver(org.xml.sax.EntityResolver),
XMLReader.setDTDHandler(org.xml.sax.DTDHandler),
XMLReader.setContentHandler(org.xml.sax.ContentHandler),
XMLReader.setErrorHandler(org.xml.sax.ErrorHandler)

      • parse

        public void parse(String systemId)
           throws SAXException,
                  IOException
        Parse a document.
        Specified by:
        parse in interface XMLReader
        Parameters:
        systemId - The system identifier as a fully-qualified URI.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        IOException - An IO exception from the parser, possibly from a byte stream or character stream supplied by the application.
        See Also:
        XMLReader.parse(org.xml.sax.InputSource)

      • resolveEntity

        public InputSource resolveEntity(String publicId,
                                 String systemId)
                          throws SAXException,
                                 IOException
        Filter an external entity resolution.
        Specified by:
        resolveEntity in interface EntityResolver
        Parameters:
        publicId - The entity's public identifier, or null.
        systemId - The entity's system identifier.
        Returns:
        A new InputSource or null for the default.
        Throws:
        SAXException - The client may throw an exception during processing.
        IOException - The client may throw an I/O-related exception while obtaining the new InputSource.
        See Also:
        InputSource

      • notationDecl

        public void notationDecl(String name,
                         String publicId,
                         String systemId)
                  throws SAXException
        Filter a notation declaration event.
        Specified by:
        notationDecl in interface DTDHandler
        Parameters:
        name - The notation name.
        publicId - The notation's public identifier, or null.
        systemId - The notation's system identifier, or null.
        Throws:
        SAXException - The client may throw an exception during processing.
        See Also:
        DTDHandler.unparsedEntityDecl(java.lang.String, java.lang.String, java.lang.String, java.lang.String), Attributes

      • unparsedEntityDecl

        public void unparsedEntityDecl(String name,
                               String publicId,
                               String systemId,
                               String notationName)
                        throws SAXException
        Filter an unparsed entity declaration event.
        Specified by:
        unparsedEntityDecl in interface DTDHandler
        Parameters:
        name - The entity name.
        publicId - The entity's public identifier, or null.
        systemId - The entity's system identifier, or null.
        notationName - The name of the associated notation.
        Throws:
        SAXException - The client may throw an exception during processing.
        See Also:
        DTDHandler.notationDecl(java.lang.String, java.lang.String, java.lang.String), Attributes

      • setDocumentLocator

        public void setDocumentLocator(Locator locator)
        Filter a new document locator event.
        Specified by:
        setDocumentLocator in interface ContentHandler
        Parameters:
        locator - The document locator.
        See Also:
        Locator

      • startDocument

        public void startDocument()
                   throws SAXException
        Filter a start document event.
        Specified by:
        startDocument in interface ContentHandler
        Throws:
        SAXException - The client may throw an exception during processing.
        See Also:
        ContentHandler.endDocument()

      • endDocument

        public void endDocument()
                 throws SAXException
        Filter an end document event.
        Specified by:
        endDocument in interface ContentHandler
        Throws:
        SAXException - The client may throw an exception during processing.
        See Also:
        ContentHandler.startDocument()

      • startPrefixMapping

        public void startPrefixMapping(String prefix,
                               String uri)
                        throws SAXException
        Filter a start Namespace prefix mapping event.
        Specified by:
        startPrefixMapping in interface ContentHandler
        Parameters:
        prefix - The Namespace prefix.
        uri - The Namespace URI.
        Throws:
        SAXException - The client may throw an exception during processing.
        See Also:
        ContentHandler.endPrefixMapping(java.lang.String), ContentHandler.startElement(java.lang.String, java.lang.String, java.lang.String, org.xml.sax.Attributes)

      • endPrefixMapping

        public void endPrefixMapping(String prefix)
                      throws SAXException
        Filter an end Namespace prefix mapping event.
        Specified by:
        endPrefixMapping in interface ContentHandler
        Parameters:
        prefix - The Namespace prefix.
        Throws:
        SAXException - The client may throw an exception during processing.
        See Also:
        ContentHandler.startPrefixMapping(java.lang.String, java.lang.String), ContentHandler.endElement(java.lang.String, java.lang.String, java.lang.String)

      • startElement

        public void startElement(String uri,
                         String localName,
                         String qName,
                         Attributes atts)
                  throws SAXException
        Filter a start element event.
        Specified by:
        startElement in interface ContentHandler
        Parameters:
        uri - The element's Namespace URI, or the empty string.
        localName - The element's local name, or the empty string.
        qName - The element's qualified (prefixed) name, or the empty string.
        atts - The element's attributes.
        Throws:
        SAXException - The client may throw an exception during processing.
        See Also:
        ContentHandler.endElement(java.lang.String, java.lang.String, java.lang.String), Attributes, AttributesImpl

      • endElement

        public void endElement(String uri,
                       String localName,
                       String qName)
                throws SAXException
        Filter an end element event.
        Specified by:
        endElement in interface ContentHandler
        Parameters:
        uri - The element's Namespace URI, or the empty string.
        localName - The element's local name, or the empty string.
        qName - The element's qualified (prefixed) name, or the empty string.
        Throws:
        SAXException - The client may throw an exception during processing.

      • characters

        public void characters(char[] ch,
                       int start,
                       int length)
                throws SAXException
        Filter a character data event.
        Specified by:
        characters in interface ContentHandler
        Parameters:
        ch - An array of characters.
        start - The starting position in the array.
        length - The number of characters to use from the array.
        Throws:
        SAXException - The client may throw an exception during processing.
        See Also:
        ContentHandler.ignorableWhitespace(char[], int, int), Locator

      • ignorableWhitespace

        public void ignorableWhitespace(char[] ch,
                                int start,
                                int length)
                         throws SAXException
        Filter an ignorable whitespace event.
        Specified by:
        ignorableWhitespace in interface ContentHandler
        Parameters:
        ch - An array of characters.
        start - The starting position in the array.
        length - The number of characters to use from the array.
        Throws:
        SAXException - The client may throw an exception during processing.
        See Also:
        ContentHandler.characters(char[], int, int)

      • processingInstruction

        public void processingInstruction(String target,
                                  String data)
                           throws SAXException
        Filter a processing instruction event.
        Specified by:
        processingInstruction in interface ContentHandler
        Parameters:
        target - The processing instruction target.
        data - The text following the target.
        Throws:
        SAXException - The client may throw an exception during processing.

      • skippedEntity

        public void skippedEntity(String name)
                   throws SAXException
        Filter a skipped entity event.
        Specified by:
        skippedEntity in interface ContentHandler
        Parameters:
        name - The name of the skipped entity.
        Throws:
        SAXException - The client may throw an exception during processing.

      • warning

        public void warning(SAXParseException e)
             throws SAXException
        Filter a warning event.
        Specified by:
        warning in interface ErrorHandler
        Parameters:
        e - The warning as an exception.
        Throws:
        SAXException - The client may throw an exception during processing.
        See Also:
        SAXParseException

      • error

        public void error(SAXParseException e)
           throws SAXException
        Filter an error event.
        Specified by:
        error in interface ErrorHandler
        Parameters:
        e - The error as an exception.
        Throws:
        SAXException - The client may throw an exception during processing.
        See Also:
        SAXParseException

      • fatalError

        public void fatalError(SAXParseException e)
                throws SAXException
        Filter a fatal error event.
        Specified by:
        fatalError in interface ErrorHandler
        Parameters:
        e - The error as an exception.
        Throws:
        SAXException - The client may throw an exception during processing.
        See Also:
        SAXParseException
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


XMLReaderAdapter (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax.helpers

Class XMLReaderAdapter

  • java.lang.Object
    • org.xml.sax.helpers.XMLReaderAdapter
  • All Implemented Interfaces:
    ContentHandler, Parser

    public class XMLReaderAdapter
extends Object
implements Parser, ContentHandler
    Adapt a SAX2 XMLReader as a SAX1 Parser.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This class wraps a SAX2 XMLReader and makes it act as a SAX1 Parser. The XMLReader must support a true value for the http://xml.org/sax/features/namespace-prefixes property or parsing will fail with a SAXException; if the XMLReader supports a false value for the http://xml.org/sax/features/namespaces property, that will also be used to improve efficiency.

    Since:
    SAX 2.0
    See Also:
    Parser, XMLReader

    • Constructor Summary

      Constructors
      Constructor and Description
      XMLReaderAdapter()
      Create a new adapter.
      XMLReaderAdapter(XMLReader xmlReader)
      Create a new adapter.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      void characters(char[] ch, int start, int length)
      Adapt a SAX2 characters event.
      void endDocument()
      End document event.
      void endElement(String uri, String localName, String qName)
      Adapt a SAX2 end element event.
      void endPrefixMapping(String prefix)
      Adapt a SAX2 end prefix mapping event.
      void ignorableWhitespace(char[] ch, int start, int length)
      Adapt a SAX2 ignorable whitespace event.
      void parse(InputSource input)
      Parse the document.
      void parse(String systemId)
      Parse the document.
      void processingInstruction(String target, String data)
      Adapt a SAX2 processing instruction event.
      void setDocumentHandler(DocumentHandler handler)
      Register the SAX1 document event handler.
      void setDocumentLocator(Locator locator)
      Set a document locator.
      void setDTDHandler(DTDHandler handler)
      Register the DTD event handler.
      void setEntityResolver(EntityResolver resolver)
      Register the entity resolver.
      void setErrorHandler(ErrorHandler handler)
      Register the error event handler.
      void setLocale(Locale locale)
      Set the locale for error reporting.
      void skippedEntity(String name)
      Adapt a SAX2 skipped entity event.
      void startDocument()
      Start document event.
      void startElement(String uri, String localName, String qName, Attributes atts)
      Adapt a SAX2 start element event.
      void startPrefixMapping(String prefix, String uri)
      Adapt a SAX2 start prefix mapping event.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • XMLReaderAdapter

        public XMLReaderAdapter()
                 throws SAXException
        Create a new adapter.

        Use the "org.xml.sax.driver" property to locate the SAX2 driver to embed.

        Throws:
        SAXException - If the embedded driver cannot be instantiated or if the org.xml.sax.driver property is not specified.

      • XMLReaderAdapter

        public XMLReaderAdapter(XMLReader xmlReader)
        Create a new adapter.

        Create a new adapter, wrapped around a SAX2 XMLReader. The adapter will make the XMLReader act like a SAX1 Parser.

        Parameters:
        xmlReader - The SAX2 XMLReader to wrap.
        Throws:
        NullPointerException - If the argument is null.

    • Method Detail

      • setLocale

        public void setLocale(Locale locale)
               throws SAXException
        Set the locale for error reporting.

        This is not supported in SAX2, and will always throw an exception.

        Specified by:
        setLocale in interface Parser
        Parameters:
        locale - the locale for error reporting.
        Throws:
        SAXException - Thrown unless overridden.
        See Also:
        Parser.setLocale(java.util.Locale)

      • setEntityResolver

        public void setEntityResolver(EntityResolver resolver)
        Register the entity resolver.
        Specified by:
        setEntityResolver in interface Parser
        Parameters:
        resolver - The new resolver.
        See Also:
        Parser.setEntityResolver(org.xml.sax.EntityResolver)

      • setDTDHandler

        public void setDTDHandler(DTDHandler handler)
        Register the DTD event handler.
        Specified by:
        setDTDHandler in interface Parser
        Parameters:
        handler - The new DTD event handler.
        See Also:
        Parser.setDTDHandler(org.xml.sax.DTDHandler)

      • setDocumentHandler

        public void setDocumentHandler(DocumentHandler handler)
        Register the SAX1 document event handler.

        Note that the SAX1 document handler has no Namespace support.

        Specified by:
        setDocumentHandler in interface Parser
        Parameters:
        handler - The new SAX1 document event handler.
        See Also:
        Parser.setDocumentHandler(org.xml.sax.DocumentHandler)

      • setErrorHandler

        public void setErrorHandler(ErrorHandler handler)
        Register the error event handler.
        Specified by:
        setErrorHandler in interface Parser
        Parameters:
        handler - The new error event handler.
        See Also:
        Parser.setErrorHandler(org.xml.sax.ErrorHandler)

      • parse

        public void parse(String systemId)
           throws IOException,
                  SAXException
        Parse the document.

        This method will throw an exception if the embedded XMLReader does not support the http://xml.org/sax/features/namespace-prefixes property.

        Specified by:
        parse in interface Parser
        Parameters:
        systemId - The absolute URL of the document.
        Throws:
        IOException - If there is a problem reading the raw content of the document.
        SAXException - If there is a problem processing the document.
        See Also:
        parse(org.xml.sax.InputSource), Parser.parse(java.lang.String)

      • parse

        public void parse(InputSource input)
           throws IOException,
                  SAXException
        Parse the document.

        This method will throw an exception if the embedded XMLReader does not support the http://xml.org/sax/features/namespace-prefixes property.

        Specified by:
        parse in interface Parser
        Parameters:
        input - An input source for the document.
        Throws:
        IOException - If there is a problem reading the raw content of the document.
        SAXException - If there is a problem processing the document.
        See Also:
        parse(java.lang.String), Parser.parse(org.xml.sax.InputSource)

      • setDocumentLocator

        public void setDocumentLocator(Locator locator)
        Set a document locator.
        Specified by:
        setDocumentLocator in interface ContentHandler
        Parameters:
        locator - The document locator.
        See Also:
        ContentHandler.setDocumentLocator(org.xml.sax.Locator)

      • startDocument

        public void startDocument()
                   throws SAXException
        Start document event.
        Specified by:
        startDocument in interface ContentHandler
        Throws:
        SAXException - The client may raise a processing exception.
        See Also:
        ContentHandler.startDocument()

      • endDocument

        public void endDocument()
                 throws SAXException
        End document event.
        Specified by:
        endDocument in interface ContentHandler
        Throws:
        SAXException - The client may raise a processing exception.
        See Also:
        ContentHandler.endDocument()

      • startPrefixMapping

        public void startPrefixMapping(String prefix,
                               String uri)
        Adapt a SAX2 start prefix mapping event.
        Specified by:
        startPrefixMapping in interface ContentHandler
        Parameters:
        prefix - The prefix being mapped.
        uri - The Namespace URI being mapped to.
        See Also:
        ContentHandler.startPrefixMapping(java.lang.String, java.lang.String)

      • endPrefixMapping

        public void endPrefixMapping(String prefix)
        Adapt a SAX2 end prefix mapping event.
        Specified by:
        endPrefixMapping in interface ContentHandler
        Parameters:
        prefix - The prefix being mapped.
        See Also:
        ContentHandler.endPrefixMapping(java.lang.String)

      • startElement

        public void startElement(String uri,
                         String localName,
                         String qName,
                         Attributes atts)
                  throws SAXException
        Adapt a SAX2 start element event.
        Specified by:
        startElement in interface ContentHandler
        Parameters:
        uri - The Namespace URI.
        localName - The Namespace local name.
        qName - The qualified (prefixed) name.
        atts - The SAX2 attributes.
        Throws:
        SAXException - The client may raise a processing exception.
        See Also:
        ContentHandler.endDocument()

      • endElement

        public void endElement(String uri,
                       String localName,
                       String qName)
                throws SAXException
        Adapt a SAX2 end element event.
        Specified by:
        endElement in interface ContentHandler
        Parameters:
        uri - The Namespace URI.
        localName - The Namespace local name.
        qName - The qualified (prefixed) name.
        Throws:
        SAXException - The client may raise a processing exception.
        See Also:
        ContentHandler.endElement(java.lang.String, java.lang.String, java.lang.String)

      • characters

        public void characters(char[] ch,
                       int start,
                       int length)
                throws SAXException
        Adapt a SAX2 characters event.
        Specified by:
        characters in interface ContentHandler
        Parameters:
        ch - An array of characters.
        start - The starting position in the array.
        length - The number of characters to use.
        Throws:
        SAXException - The client may raise a processing exception.
        See Also:
        ContentHandler.characters(char[], int, int)

      • ignorableWhitespace

        public void ignorableWhitespace(char[] ch,
                                int start,
                                int length)
                         throws SAXException
        Adapt a SAX2 ignorable whitespace event.
        Specified by:
        ignorableWhitespace in interface ContentHandler
        Parameters:
        ch - An array of characters.
        start - The starting position in the array.
        length - The number of characters to use.
        Throws:
        SAXException - The client may raise a processing exception.
        See Also:
        ContentHandler.ignorableWhitespace(char[], int, int)

      • processingInstruction

        public void processingInstruction(String target,
                                  String data)
                           throws SAXException
        Adapt a SAX2 processing instruction event.
        Specified by:
        processingInstruction in interface ContentHandler
        Parameters:
        target - The processing instruction target.
        data - The remainder of the processing instruction
        Throws:
        SAXException - The client may raise a processing exception.
        See Also:
        ContentHandler.processingInstruction(java.lang.String, java.lang.String)

      • skippedEntity

        public void skippedEntity(String name)
                   throws SAXException
        Adapt a SAX2 skipped entity event.
        Specified by:
        skippedEntity in interface ContentHandler
        Parameters:
        name - The name of the skipped entity.
        Throws:
        SAXException - Throwable by subclasses.
        See Also:
        ContentHandler.skippedEntity(java.lang.String)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


XMLReaderFactory (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax.helpers

Class XMLReaderFactory

  • java.lang.Object
    • org.xml.sax.helpers.XMLReaderFactory

  • public final class XMLReaderFactory
extends Object
    Factory for creating an XML reader.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This class contains static methods for creating an XML reader from an explicit class name, or based on runtime defaults:

     try {
   XMLReader myReader = XMLReaderFactory.createXMLReader();
 } catch (SAXException e) {
   System.err.println(e.getMessage());
 }

    Note to Distributions bundled with parsers: You should modify the implementation of the no-arguments createXMLReader to handle cases where the external configuration mechanisms aren't set up. That method should do its best to return a parser when one is in the class path, even when nothing bound its class name to org.xml.sax.driver so those configuration mechanisms would see it.

    Since:
    SAX 2.0
    Version:
    2.0.1 (sax2r2)

    • Method Summary

      All Methods Static Methods Concrete Methods
      Modifier and Type Method and Description
      static XMLReader createXMLReader()
      Attempt to create an XMLReader from system defaults.
      static XMLReader createXMLReader(String className)
      Attempt to create an XML reader from a class name.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Method Detail

      • createXMLReader

        public static XMLReader createXMLReader()
                                 throws SAXException
        Attempt to create an XMLReader from system defaults. In environments which can support it, the name of the XMLReader class is determined by trying each these options in order, and using the first one which succeeds:

        • If the system property org.xml.sax.driver has a value, that is used as an XMLReader class name.
        • The JAR "Services API" is used to look for a class name in the META-INF/services/org.xml.sax.driver file in jarfiles available to the runtime.
        • SAX parser distributions are strongly encouraged to provide a default XMLReader class name that will take effect only when previous options (on this list) are not successful.
        • Finally, if ParserFactory.makeParser() can return a system default SAX1 parser, that parser is wrapped in a ParserAdapter. (This is a migration aid for SAX1 environments, where the org.xml.sax.parser system property will often be usable.)

        In environments such as small embedded systems, which can not support that flexibility, other mechanisms to determine the default may be used.

        Note that many Java environments allow system properties to be initialized on a command line. This means that in most cases setting a good value for that property ensures that calls to this method will succeed, except when security policies intervene. This will also maximize application portability to older SAX environments, with less robust implementations of this method.

        Returns:
        A new XMLReader.
        Throws:
        SAXException - If no default XMLReader class can be identified and instantiated.
        See Also:
        createXMLReader(java.lang.String)

      • createXMLReader

        public static XMLReader createXMLReader(String className)
                                 throws SAXException
        Attempt to create an XML reader from a class name.

        Given a class name, this method attempts to load and instantiate the class as an XML reader.

        Note that this method will not be usable in environments where the caller (perhaps an applet) is not permitted to load classes dynamically.

        Returns:
        A new XML reader.
        Throws:
        SAXException - If the class cannot be loaded, instantiated, and cast to XMLReader.
        See Also:
        createXMLReader()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


InputSource (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax

Class InputSource

  • java.lang.Object
    • org.xml.sax.InputSource

  • public class InputSource
extends Object
    A single input source for an XML entity.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This class allows a SAX application to encapsulate information about an input source in a single object, which may include a public identifier, a system identifier, a byte stream (possibly with a specified encoding), and/or a character stream.

    There are two places that the application can deliver an input source to the parser: as the argument to the Parser.parse method, or as the return value of the EntityResolver.resolveEntity method.

    The SAX parser will use the InputSource object to determine how to read XML input. If there is a character stream available, the parser will read that stream directly, disregarding any text encoding declaration found in that stream. If there is no character stream, but there is a byte stream, the parser will use that byte stream, using the encoding specified in the InputSource or else (if no encoding is specified) autodetecting the character encoding using an algorithm such as the one in the XML specification. If neither a character stream nor a byte stream is available, the parser will attempt to open a URI connection to the resource identified by the system identifier.

    An InputSource object belongs to the application: the SAX parser shall never modify it in any way (it may modify a copy if necessary). However, standard processing of both byte and character streams is to close them on as part of end-of-parse cleanup, so applications should not attempt to re-use such streams after they have been handed to a parser.

    Since:
    SAX 1.0
    See Also:
    XMLReader.parse(org.xml.sax.InputSource), EntityResolver.resolveEntity(java.lang.String, java.lang.String), InputStream, Reader

    • Constructor Summary

      Constructors
      Constructor and Description
      InputSource()
      Zero-argument default constructor.
      InputSource(InputStream byteStream)
      Create a new input source with a byte stream.
      InputSource(Reader characterStream)
      Create a new input source with a character stream.
      InputSource(String systemId)
      Create a new input source with a system identifier.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      InputStream getByteStream()
      Get the byte stream for this input source.
      Reader getCharacterStream()
      Get the character stream for this input source.
      String getEncoding()
      Get the character encoding for a byte stream or URI.
      String getPublicId()
      Get the public identifier for this input source.
      String getSystemId()
      Get the system identifier for this input source.
      void setByteStream(InputStream byteStream)
      Set the byte stream for this input source.
      void setCharacterStream(Reader characterStream)
      Set the character stream for this input source.
      void setEncoding(String encoding)
      Set the character encoding, if known.
      void setPublicId(String publicId)
      Set the public identifier for this input source.
      void setSystemId(String systemId)
      Set the system identifier for this input source.

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

    • Constructor Detail

      • InputSource

        public InputSource()
        Zero-argument default constructor.
        See Also:
        setPublicId(java.lang.String),
setSystemId(java.lang.String),
setByteStream(java.io.InputStream),
setCharacterStream(java.io.Reader),
setEncoding(java.lang.String)

      • InputSource

        public InputSource(String systemId)
        Create a new input source with a system identifier.

        Applications may use setPublicId to include a public identifier as well, or setEncoding to specify the character encoding, if known.

        If the system identifier is a URL, it must be fully resolved (it may not be a relative URL).

        Parameters:
        systemId - The system identifier (URI).
        See Also:
        setPublicId(java.lang.String),
setSystemId(java.lang.String),
setByteStream(java.io.InputStream),
setEncoding(java.lang.String),
setCharacterStream(java.io.Reader)

      • InputSource

        public InputSource(InputStream byteStream)
        Create a new input source with a byte stream.

        Application writers should use setSystemId() to provide a base for resolving relative URIs, may use setPublicId to include a public identifier, and may use setEncoding to specify the object's character encoding.

        Parameters:
        byteStream - The raw byte stream containing the document.
        See Also:
        setPublicId(java.lang.String),
setSystemId(java.lang.String),
setEncoding(java.lang.String),
setByteStream(java.io.InputStream),
setCharacterStream(java.io.Reader)

      • InputSource

        public InputSource(Reader characterStream)
        Create a new input source with a character stream.

        Application writers should use setSystemId() to provide a base for resolving relative URIs, and may use setPublicId to include a public identifier.

        The character stream shall not include a byte order mark.

        See Also:
        setPublicId(java.lang.String),
setSystemId(java.lang.String),
setByteStream(java.io.InputStream),
setCharacterStream(java.io.Reader)

    • Method Detail

      • setPublicId

        public void setPublicId(String publicId)
        Set the public identifier for this input source.

        The public identifier is always optional: if the application writer includes one, it will be provided as part of the location information.

        Parameters:
        publicId - The public identifier as a string.
        See Also:
        getPublicId(),
Locator.getPublicId(),
SAXParseException.getPublicId()

      • getPublicId

        public String getPublicId()
        Get the public identifier for this input source.
        Returns:
        The public identifier, or null if none was supplied.
        See Also:
        setPublicId(java.lang.String)

      • setSystemId

        public void setSystemId(String systemId)
        Set the system identifier for this input source.

        The system identifier is optional if there is a byte stream or a character stream, but it is still useful to provide one, since the application can use it to resolve relative URIs and can include it in error messages and warnings (the parser will attempt to open a connection to the URI only if there is no byte stream or character stream specified).

        If the application knows the character encoding of the object pointed to by the system identifier, it can register the encoding using the setEncoding method.

        If the system identifier is a URL, it must be fully resolved (it may not be a relative URL).

        Parameters:
        systemId - The system identifier as a string.
        See Also:
        setEncoding(java.lang.String),
getSystemId(),
Locator.getSystemId(),
SAXParseException.getSystemId()

      • getSystemId

        public String getSystemId()
        Get the system identifier for this input source.

        The getEncoding method will return the character encoding of the object pointed to, or null if unknown.

        If the system ID is a URL, it will be fully resolved.

        Returns:
        The system identifier, or null if none was supplied.
        See Also:
        setSystemId(java.lang.String), getEncoding()

      • setByteStream

        public void setByteStream(InputStream byteStream)
        Set the byte stream for this input source.

        The SAX parser will ignore this if there is also a character stream specified, but it will use a byte stream in preference to opening a URI connection itself.

        If the application knows the character encoding of the byte stream, it should set it with the setEncoding method.

        Parameters:
        byteStream - A byte stream containing an XML document or other entity.
        See Also:
        setEncoding(java.lang.String),
getByteStream(),
getEncoding(),
InputStream

      • getByteStream

        public InputStream getByteStream()
        Get the byte stream for this input source.

        The getEncoding method will return the character encoding for this byte stream, or null if unknown.

        Returns:
        The byte stream, or null if none was supplied.
        See Also:
        getEncoding(), setByteStream(java.io.InputStream)

      • setEncoding

        public void setEncoding(String encoding)
        Set the character encoding, if known.

        The encoding must be a string acceptable for an XML encoding declaration (see section 4.3.3 of the XML 1.0 recommendation).

        This method has no effect when the application provides a character stream.

        Parameters:
        encoding - A string describing the character encoding.
        See Also:
        setSystemId(java.lang.String),
setByteStream(java.io.InputStream),
getEncoding()

      • getEncoding

        public String getEncoding()
        Get the character encoding for a byte stream or URI. This value will be ignored when the application provides a character stream.
        Returns:
        The encoding, or null if none was supplied.
        See Also:
        setByteStream(java.io.InputStream),
getSystemId(),
getByteStream()

      • setCharacterStream

        public void setCharacterStream(Reader characterStream)
        Set the character stream for this input source.

        If there is a character stream specified, the SAX parser will ignore any byte stream and will not attempt to open a URI connection to the system identifier.

        Parameters:
        characterStream - The character stream containing the XML document or other entity.
        See Also:
        getCharacterStream(), Reader

      • getCharacterStream

        public Reader getCharacterStream()
        Get the character stream for this input source.
        Returns:
        The character stream, or null if none was supplied.
        See Also:
        setCharacterStream(java.io.Reader)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Locator (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax

Interface Locator

  • All Known Subinterfaces:
    Locator2
    All Known Implementing Classes:
    Locator2Impl, LocatorImpl

    public interface Locator
    Interface for associating a SAX event with a document location.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    If a SAX parser provides location information to the SAX application, it does so by implementing this interface and then passing an instance to the application using the content handler's setDocumentLocator method. The application can use the object to obtain the location of any other SAX event in the XML source document.

    Note that the results returned by the object will be valid only during the scope of each callback method: the application will receive unpredictable results if it attempts to use the locator at any other time, or after parsing completes.

    SAX parsers are not required to supply a locator, but they are very strongly encouraged to do so. If the parser supplies a locator, it must do so before reporting any other document events. If no locator has been set by the time the application receives the startDocument event, the application should assume that a locator is not available.

    Since:
    SAX 1.0
    See Also:
    ContentHandler.setDocumentLocator(org.xml.sax.Locator)

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      int getColumnNumber()
      Return the column number where the current document event ends.
      int getLineNumber()
      Return the line number where the current document event ends.
      String getPublicId()
      Return the public identifier for the current document event.
      String getSystemId()
      Return the system identifier for the current document event.

    • Method Detail

      • getPublicId

        String getPublicId()
        Return the public identifier for the current document event.

        The return value is the public identifier of the document entity or of the external parsed entity in which the markup triggering the event appears.

        Returns:
        A string containing the public identifier, or null if none is available.
        See Also:
        getSystemId()

      • getSystemId

        String getSystemId()
        Return the system identifier for the current document event.

        The return value is the system identifier of the document entity or of the external parsed entity in which the markup triggering the event appears.

        If the system identifier is a URL, the parser must resolve it fully before passing it to the application. For example, a file name must always be provided as a file:... URL, and other kinds of relative URI are also resolved against their bases.

        Returns:
        A string containing the system identifier, or null if none is available.
        See Also:
        getPublicId()

      • getLineNumber

        int getLineNumber()
        Return the line number where the current document event ends. Lines are delimited by line ends, which are defined in the XML specification.

        Warning: The return value from the method is intended only as an approximation for the sake of diagnostics; it is not intended to provide sufficient information to edit the character content of the original XML document. In some cases, these "line" numbers match what would be displayed as columns, and in others they may not match the source text due to internal entity expansion.

        The return value is an approximation of the line number in the document entity or external parsed entity where the markup triggering the event appears.

        If possible, the SAX driver should provide the line position of the first character after the text associated with the document event. The first line is line 1.

        Returns:
        The line number, or -1 if none is available.
        See Also:
        getColumnNumber()

      • getColumnNumber

        int getColumnNumber()
        Return the column number where the current document event ends. This is one-based number of Java char values since the last line end.

        Warning: The return value from the method is intended only as an approximation for the sake of diagnostics; it is not intended to provide sufficient information to edit the character content of the original XML document. For example, when lines contain combining character sequences, wide characters, surrogate pairs, or bi-directional text, the value may not correspond to the column in a text editor's display.

        The return value is an approximation of the column number in the document entity or external parsed entity where the markup triggering the event appears.

        If possible, the SAX driver should provide the line position of the first character after the text associated with the document event. The first column in each line is column 1.

        Returns:
        The column number, or -1 if none is available.
        See Also:
        getLineNumber()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


org.xml.sax (Java Platform SE 8 )

org.xml.sax

Interfaces

  • AttributeList
  • Attributes
  • ContentHandler
  • DocumentHandler
  • DTDHandler
  • EntityResolver
  • ErrorHandler
  • Locator
  • Parser
  • XMLFilter
  • XMLReader

Classes

  • HandlerBase
  • InputSource

Exceptions

  • SAXException
  • SAXNotRecognizedException
  • SAXNotSupportedException
  • SAXParseException


org.xml.sax (Java Platform SE 8 )

Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames
  • All Classes

Package org.xml.sax

This package provides the core SAX APIs.

See: Description

  • Interface Summary
    Interface Description
    AttributeList Deprecated
    This interface has been replaced by the SAX2 Attributes interface, which includes Namespace support.
    Attributes
    Interface for a list of XML attributes.
    ContentHandler
    Receive notification of the logical content of a document.
    DocumentHandler Deprecated
    This interface has been replaced by the SAX2 ContentHandler interface, which includes Namespace support.
    DTDHandler
    Receive notification of basic DTD-related events.
    EntityResolver
    Basic interface for resolving entities.
    ErrorHandler
    Basic interface for SAX error handlers.
    Locator
    Interface for associating a SAX event with a document location.
    Parser Deprecated
    This interface has been replaced by the SAX2 XMLReader interface, which includes Namespace support.
    XMLFilter
    Interface for an XML filter.
    XMLReader
    Interface for reading an XML document using callbacks.
  • Class Summary
    Class Description
    HandlerBase Deprecated
    This class works with the deprecated DocumentHandler interface.
    InputSource
    A single input source for an XML entity.
  • Exception Summary
    Exception Description
    SAXException
    Encapsulate a general SAX error or warning.
    SAXNotRecognizedException
    Exception class for an unrecognized identifier.
    SAXNotSupportedException
    Exception class for an unsupported operation.
    SAXParseException
    Encapsulate an XML parse error or warning.

Package org.xml.sax Description

This package provides the core SAX APIs. Some SAX1 APIs are deprecated to encourage integration of namespace-awareness into designs of new applications and into maintenance of existing infrastructure.

See http://www.saxproject.org for more information about SAX.

SAX2 Standard Feature Flags

One of the essential characteristics of SAX2 is that it added feature flags which can be used to examine and perhaps modify parser modes, in particular modes such as validation. Since features are identified by (absolute) URIs, anyone can define such features. Currently defined standard feature URIs have the prefix http://xml.org/sax/features/ before an identifier such as validation. Turn features on or off using setFeature. Those standard identifiers are:

Feature ID | Access | Default | Description
external-general-entities | read/write | unspecified | Reports whether this parser processes external general entities; always true if validating.
external-parameter-entities | read/write | unspecified | Reports whether this parser processes external parameter entities; always true if validating.
is-standalone | (parsing) read-only, (not parsing) none | not applicable | May be examined only during a parse, after the startDocument() callback has been completed; read-only. The value is true if the document specified standalone="yes" in its XML declaration, and otherwise is false.
lexical-handler/parameter-entities | read/write | unspecified | A value of "true" indicates that the LexicalHandler will report the beginning and end of parameter entities.
namespaces | read/write | true | A value of "true" indicates namespace URIs and unprefixed local names for element and attribute names will be available.
namespace-prefixes | read/write | false | A value of "true" indicates that XML qualified names (with prefixes) and attributes (including xmlns* attributes) will be available.
resolve-dtd-uris read/write true A value of "true" indicates that system IDs in declarations will be absolutized (relative to their base URIs) before reporting. (That is the default behavior for all SAX2 XML parsers.) A value of "false" indicates those IDs will not be absolutized; parsers will provide the base URI from Locator.getSystemId(). This applies to system IDs passed in
  • DTDHandler.notationDecl(),
  • DTDHandler.unparsedEntityDecl(), and
  • DeclHandler.externalEntityDecl().
It does not apply to EntityResolver.resolveEntity(), which is not used to report declarations, or to LexicalHandler.startDTD(), which already provides the non-absolutized URI.
string-interning | read/write | unspecified | Has a value of "true" if all XML names (for elements, prefixes, attributes, entities, notations, and local names), as well as Namespace URIs, will have been interned using java.lang.String.intern. This supports fast testing of equality/inequality against string constants, rather than forcing slower calls to String.equals().
unicode-normalization-checking | read/write | false | Controls whether the parser reports Unicode normalization errors as described in section 2.13 and Appendix B of the XML 1.1 Recommendation. If true, Unicode normalization errors are reported using the ErrorHandler.error() callback. Such errors are not fatal in themselves (though, obviously, other Unicode-related encoding errors may be).
use-attributes2 | read-only | not applicable | Returns "true" if the Attributes objects passed by this parser in ContentHandler.startElement() implement the org.xml.sax.ext.Attributes2 interface. That interface exposes additional DTD-related information, such as whether the attribute was specified in the source text rather than defaulted.
use-locator2 | read-only | not applicable | Returns "true" if the Locator objects passed by this parser in ContentHandler.setDocumentLocator() implement the org.xml.sax.ext.Locator2 interface. That interface exposes additional entity information, such as the character encoding and XML version used.
use-entity-resolver2 | read/write | true | Returns "true" if, when setEntityResolver is given an object implementing the org.xml.sax.ext.EntityResolver2 interface, those new methods will be used. Returns "false" to indicate that those methods will not be used.
validation | read/write | unspecified | Controls whether the parser is reporting all validity errors; if true, all external entities will be read.
xmlns-uris | read/write | false | Controls whether, when the namespace-prefixes feature is set, the parser treats namespace declaration attributes as being in the http://www.w3.org/2000/xmlns/ namespace. By default, SAX2 conforms to the original "Namespaces in XML" Recommendation, which explicitly states that such attributes are not in any namespace. Setting this optional flag to "true" makes the SAX2 events conform to a later backwards-incompatible revision of that recommendation, placing those attributes in a namespace.
xml-1.1 | read-only | not applicable | Returns "true" if the parser supports both XML 1.1 and XML 1.0. Returns "false" if the parser supports only XML 1.0.

Support for the default values of the namespaces and namespace-prefixes properties is required. Support for any other feature flags is entirely optional.

For default values not specified by SAX2, each XMLReader implementation specifies its default, or may choose not to expose the feature flag. Unless otherwise specified here, implementations may support changing current values of these standard feature flags, but not while parsing.

SAX2 Standard Handler and Property IDs

For parser interface characteristics that are described as objects, a separate namespace is defined. The objects in this namespace are again identified by URI, and the standard property URIs have the prefix http://xml.org/sax/properties/ before an identifier such as lexical-handler or dom-node. Manage those properties using setProperty(). Those identifiers are:

Property ID | Description
declaration-handler | Used to see most DTD declarations except those treated as lexical ("document element name is ...") or which are mandatory for all SAX parsers (DTDHandler). The Object must implement org.xml.sax.ext.DeclHandler.
document-xml-version | May be examined only during a parse, after the startDocument() callback has been completed; read-only. This property is a literal string describing the actual XML version of the document, such as "1.0" or "1.1".
dom-node | For "DOM Walker" style parsers, which ignore their parser.parse() parameters, this is used to specify the DOM (sub)tree being walked by the parser. The Object must implement the org.w3c.dom.Node interface.
lexical-handler | Used to see some syntax events that are essential in some applications: comments, CDATA delimiters, selected general entity inclusions, and the start and end of the DTD (and declaration of document element name). The Object must implement org.xml.sax.ext.LexicalHandler.
xml-string | Readable only during a parser callback, this exposes a TBS chunk of characters responsible for the current event.

All of these standard properties are optional; XMLReader implementations need not support them.

Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Package
  • Next Package
  • Frames
  • No Frames


org.xml.sax Class Hierarchy (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For Package org.xml.sax

Package Hierarchies:
  • All Packages

Class Hierarchy

  • java.lang.Object
    • org.xml.sax.HandlerBase (implements org.xml.sax.DocumentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
    • org.xml.sax.InputSource
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • org.xml.sax.SAXException
          • org.xml.sax.SAXNotRecognizedException
          • org.xml.sax.SAXNotSupportedException
          • org.xml.sax.SAXParseException

Interface Hierarchy

  • org.xml.sax.AttributeList
  • org.xml.sax.Attributes
  • org.xml.sax.ContentHandler
  • org.xml.sax.DocumentHandler
  • org.xml.sax.DTDHandler
  • org.xml.sax.EntityResolver
  • org.xml.sax.ErrorHandler
  • org.xml.sax.Locator
  • org.xml.sax.Parser
  • org.xml.sax.XMLReader
    • org.xml.sax.XMLFilter
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Uses of Package org.xml.sax (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Uses of Package
org.xml.sax

  • Packages that use org.xml.sax
    Package Description
    java.beans
    Contains classes related to developing beans -- components based on the JavaBeans™ architecture.
    javax.xml.bind
    Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
    javax.xml.bind.helpers
    JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
    javax.xml.parsers
    Provides classes allowing the processing of XML documents.
    javax.xml.transform.sax
    This package implements SAX2-specific transformation APIs.
    javax.xml.validation
    This package provides an API for validation of XML documents.
    javax.xml.xpath
    This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.
    org.xml.sax
    This package provides the core SAX APIs.
    org.xml.sax.ext
    This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.
    org.xml.sax.helpers
    This package contains "helper" classes, including support for bootstrapping SAX-based applications.
  • Classes in org.xml.sax used by java.beans
    Class and Description
    InputSource
    A single input source for an XML entity.
  • Classes in org.xml.sax used by javax.xml.bind
    Class and Description
    ContentHandler
    Receive notification of the logical content of a document.
    InputSource
    A single input source for an XML entity.
  • Classes in org.xml.sax used by javax.xml.bind.helpers
    Class and Description
    ContentHandler
    Receive notification of the logical content of a document.
    InputSource
    A single input source for an XML entity.
    Locator
    Interface for associating a SAX event with a document location.
    SAXException
    Encapsulate a general SAX error or warning.
    SAXParseException
    Encapsulate an XML parse error or warning.
    XMLReader
    Interface for reading an XML document using callbacks.
  • Classes in org.xml.sax used by javax.xml.parsers
    Class and Description
    EntityResolver
    Basic interface for resolving entities.
    ErrorHandler
    Basic interface for SAX error handlers.
    HandlerBase
    Deprecated.
    This class works with the deprecated DocumentHandler interface. It has been replaced by the SAX2 DefaultHandler class.
    InputSource
    A single input source for an XML entity.
    Parser
    Deprecated.
    This interface has been replaced by the SAX2 XMLReader interface, which includes Namespace support.
    SAXException
    Encapsulate a general SAX error or warning.
    SAXNotRecognizedException
    Exception class for an unrecognized identifier.
    SAXNotSupportedException
    Exception class for an unsupported operation.
    XMLReader
    Interface for reading an XML document using callbacks.
  • Classes in org.xml.sax used by javax.xml.transform.sax
    Class and Description
    ContentHandler
    Receive notification of the logical content of a document.
    DTDHandler
    Receive notification of basic DTD-related events.
    InputSource
    A single input source for an XML entity.
    XMLFilter
    Interface for an XML filter.
    XMLReader
    Interface for reading an XML document using callbacks.
  • Classes in org.xml.sax used by javax.xml.validation
    Class and Description
    ContentHandler
    Receive notification of the logical content of a document.
    ErrorHandler
    Basic interface for SAX error handlers.
    SAXException
    Encapsulate a general SAX error or warning.
    SAXNotRecognizedException
    Exception class for an unrecognized identifier.
    SAXNotSupportedException
    Exception class for an unsupported operation.
  • Classes in org.xml.sax used by javax.xml.xpath
    Class and Description
    InputSource
    A single input source for an XML entity.
  • Classes in org.xml.sax used by org.xml.sax
    Class and Description
    AttributeList
    Deprecated.
    This interface has been replaced by the SAX2 Attributes interface, which includes Namespace support.
    Attributes
    Interface for a list of XML attributes.
    ContentHandler
    Receive notification of the logical content of a document.
    DocumentHandler
    Deprecated.
    This interface has been replaced by the SAX2 ContentHandler interface, which includes Namespace support.
    DTDHandler
    Receive notification of basic DTD-related events.
    EntityResolver
    Basic interface for resolving entities.
    ErrorHandler
    Basic interface for SAX error handlers.
    InputSource
    A single input source for an XML entity.
    Locator
    Interface for associating a SAX event with a document location.
    SAXException
    Encapsulate a general SAX error or warning.
    SAXNotRecognizedException
    Exception class for an unrecognized identifier.
    SAXNotSupportedException
    Exception class for an unsupported operation.
    SAXParseException
    Encapsulate an XML parse error or warning.
    XMLReader
    Interface for reading an XML document using callbacks.
  • Classes in org.xml.sax used by org.xml.sax.ext
    Class and Description
    Attributes
    Interface for a list of XML attributes.
    ContentHandler
    Receive notification of the logical content of a document.
    DTDHandler
    Receive notification of basic DTD-related events.
    EntityResolver
    Basic interface for resolving entities.
    ErrorHandler
    Basic interface for SAX error handlers.
    InputSource
    A single input source for an XML entity.
    Locator
    Interface for associating a SAX event with a document location.
    SAXException
    Encapsulate a general SAX error or warning.
  • Classes in org.xml.sax used by org.xml.sax.helpers
    Class and Description
    AttributeList
    Deprecated.
    This interface has been replaced by the SAX2 Attributes interface, which includes Namespace support.
    Attributes
    Interface for a list of XML attributes.
    ContentHandler
    Receive notification of the logical content of a document.
    DocumentHandler
    Deprecated.
    This interface has been replaced by the SAX2 ContentHandler interface, which includes Namespace support.
    DTDHandler
    Receive notification of basic DTD-related events.
    EntityResolver
    Basic interface for resolving entities.
    ErrorHandler
    Basic interface for SAX error handlers.
    InputSource
    A single input source for an XML entity.
    Locator
    Interface for associating a SAX event with a document location.
    Parser
    Deprecated.
    This interface has been replaced by the SAX2 XMLReader interface, which includes Namespace support.
    SAXException
    Encapsulate a general SAX error or warning.
    SAXNotRecognizedException
    Exception class for an unrecognized identifier.
    SAXNotSupportedException
    Exception class for an unsupported operation.
    SAXParseException
    Encapsulate an XML parse error or warning.
    XMLFilter
    Interface for an XML filter.
    XMLReader
    Interface for reading an XML document using callbacks.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Parser (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax

Interface Parser

  • All Known Implementing Classes:
    XMLReaderAdapter
    Deprecated.
    This interface has been replaced by the SAX2 XMLReader interface, which includes Namespace support.

    public interface Parser
    Basic interface for SAX (Simple API for XML) parsers.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This was the main event supplier interface for SAX1; it has been replaced in SAX2 by XMLReader, which includes Namespace support and sophisticated configurability and extensibility.

    All SAX1 parsers must implement this basic interface: it allows applications to register handlers for different types of events and to initiate a parse from a URI, or a character stream.

    All SAX1 parsers must also implement a zero-argument constructor (though other constructors are also allowed).

    SAX1 parsers are reusable but not re-entrant: the application may reuse a parser object (possibly with a different input source) once the first parse has completed successfully, but it may not invoke the parse() methods recursively within a parse.

    Since:
    SAX 1.0
    See Also:
    EntityResolver, DTDHandler, DocumentHandler, ErrorHandler, HandlerBase, InputSource

    • Method Summary

      All Methods Instance Methods Abstract Methods Deprecated Methods
      Modifier and Type Method and Description
      void parse(InputSource source)
      Deprecated.
      Parse an XML document.
      void parse(String systemId)
      Deprecated.
      Parse an XML document from a system identifier (URI).
      void setDocumentHandler(DocumentHandler handler)
      Deprecated.
      Allow an application to register a document event handler.
      void setDTDHandler(DTDHandler handler)
      Deprecated.
      Allow an application to register a DTD event handler.
      void setEntityResolver(EntityResolver resolver)
      Deprecated.
      Allow an application to register a custom entity resolver.
      void setErrorHandler(ErrorHandler handler)
      Deprecated.
      Allow an application to register an error event handler.
      void setLocale(Locale locale)
      Deprecated.
      Allow an application to request a locale for errors and warnings.

    • Method Detail

      • setLocale

        void setLocale(Locale locale)
        throws SAXException
        Deprecated.
        Allow an application to request a locale for errors and warnings.

        SAX parsers are not required to provide localisation for errors and warnings; if they cannot support the requested locale, however, they must throw a SAX exception. Applications may not request a locale change in the middle of a parse.

        Parameters:
        locale - A Java Locale object.
        Throws:
        SAXException - Throws an exception (using the previous or default locale) if the requested locale is not supported.
        See Also:
        SAXException, SAXParseException

      • setEntityResolver

        void setEntityResolver(EntityResolver resolver)
        Deprecated.
        Allow an application to register a custom entity resolver.

        If the application does not register an entity resolver, the SAX parser will resolve system identifiers and open connections to entities itself (this is the default behaviour implemented in HandlerBase).

        Applications may register a new or different entity resolver in the middle of a parse, and the SAX parser must begin using the new resolver immediately.

        Parameters:
        resolver - The object for resolving entities.
        See Also:
        EntityResolver, HandlerBase

      • setDTDHandler

        void setDTDHandler(DTDHandler handler)
        Deprecated.
        Allow an application to register a DTD event handler.

        If the application does not register a DTD handler, all DTD events reported by the SAX parser will be silently ignored (this is the default behaviour implemented by HandlerBase).

        Applications may register a new or different handler in the middle of a parse, and the SAX parser must begin using the new handler immediately.

        Parameters:
        handler - The DTD handler.
        See Also:
        DTDHandler, HandlerBase

      • setDocumentHandler

        void setDocumentHandler(DocumentHandler handler)
        Deprecated.
        Allow an application to register a document event handler.

        If the application does not register a document handler, all document events reported by the SAX parser will be silently ignored (this is the default behaviour implemented by HandlerBase).

        Applications may register a new or different handler in the middle of a parse, and the SAX parser must begin using the new handler immediately.

        Parameters:
        handler - The document handler.
        See Also:
        DocumentHandler, HandlerBase

      • setErrorHandler

        void setErrorHandler(ErrorHandler handler)
        Deprecated.
        Allow an application to register an error event handler.

        If the application does not register an error event handler, all error events reported by the SAX parser will be silently ignored, except for fatalError, which will throw a SAXException (this is the default behaviour implemented by HandlerBase).

        Applications may register a new or different handler in the middle of a parse, and the SAX parser must begin using the new handler immediately.

        Parameters:
        handler - The error handler.
        See Also:
        ErrorHandler, SAXException, HandlerBase

      • parse

        void parse(InputSource source)
    throws SAXException,
           IOException
        Deprecated.
        Parse an XML document.

        The application can use this method to instruct the SAX parser to begin parsing an XML document from any valid input source (a character stream, a byte stream, or a URI).

        Applications may not invoke this method while a parse is in progress (they should create a new Parser instead for each additional XML document). Once a parse is complete, an application may reuse the same Parser object, possibly with a different input source.

        Parameters:
        source - The input source for the top-level of the XML document.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        IOException - An IO exception from the parser, possibly from a byte stream or character stream supplied by the application.
        See Also:
        InputSource,
parse(java.lang.String),
setEntityResolver(org.xml.sax.EntityResolver),
setDTDHandler(org.xml.sax.DTDHandler),
setDocumentHandler(org.xml.sax.DocumentHandler),
setErrorHandler(org.xml.sax.ErrorHandler)

      • parse

        void parse(String systemId)
    throws SAXException,
           IOException
        Deprecated.
        Parse an XML document from a system identifier (URI).

        This method is a shortcut for the common case of reading a document from a system identifier. It is the exact equivalent of the following:

         parse(new InputSource(systemId));

        If the system identifier is a URL, it must be fully resolved by the application before it is passed to the parser.

        Parameters:
        systemId - The system identifier (URI).
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        IOException - An IO exception from the parser, possibly from a byte stream or character stream supplied by the application.
        See Also:
        parse(org.xml.sax.InputSource)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SAXException (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax

Class SAXException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.xml.sax.SAXException
  • All Implemented Interfaces:
    Serializable
    Direct Known Subclasses:
    SAXNotRecognizedException, SAXNotSupportedException, SAXParseException

    public class SAXException
extends Exception
    Encapsulate a general SAX error or warning.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This class can contain basic error or warning information from either the XML parser or the application: a parser writer or application writer can subclass it to provide additional functionality. SAX handlers may throw this exception or any exception subclassed from it.

    If the application needs to pass through other types of exceptions, it must wrap those exceptions in a SAXException or an exception derived from a SAXException.

    If the parser or application needs to include information about a specific location in an XML document, it should use the SAXParseException subclass.

    Since:
    SAX 1.0
    Version:
    2.0.1 (sax2r2)
    See Also:
    SAXParseException, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      SAXException()
      Create a new SAXException.
      SAXException(Exception e)
      Create a new SAXException wrapping an existing exception.
      SAXException(String message)
      Create a new SAXException.
      SAXException(String message, Exception e)
      Create a new SAXException from an existing exception.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      Throwable getCause()
      Return the cause of the exception
      Exception getException()
      Return the embedded exception, if any.
      String getMessage()
      Return a detail message for this exception.
      String toString()
      Override toString to pick up any embedded exception.

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • SAXException

        public SAXException()
        Create a new SAXException.

      • SAXException

        public SAXException(String message)
        Create a new SAXException.
        Parameters:
        message - The error or warning message.

      • SAXException

        public SAXException(Exception e)
        Create a new SAXException wrapping an existing exception.

        The existing exception will be embedded in the new one, and its message will become the default message for the SAXException.

        Parameters:
        e - The exception to be wrapped in a SAXException.

      • SAXException

        public SAXException(String message,
                    Exception e)
        Create a new SAXException from an existing exception.

        The existing exception will be embedded in the new one, but the new exception will have its own message.

        Parameters:
        message - The detail message.
        e - The exception to be wrapped in a SAXException.

    • Method Detail

      • getMessage

        public String getMessage()
        Return a detail message for this exception.

        If there is an embedded exception, and if the SAXException has no detail message of its own, this method will return the detail message from the embedded exception.

        Overrides:
        getMessage in class Throwable
        Returns:
        The error or warning message.

      • getException

        public Exception getException()
        Return the embedded exception, if any.
        Returns:
        The embedded exception, or null if there is none.

      • getCause

        public Throwable getCause()
        Return the cause of the exception
        Overrides:
        getCause in class Throwable
        Returns:
        Return the cause of the exception

      • toString

        public String toString()
        Override toString to pick up any embedded exception.
        Overrides:
        toString in class Throwable
        Returns:
        A string representation of this exception.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SAXNotRecognizedException (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax

Class SAXNotRecognizedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.xml.sax.SAXException
          • org.xml.sax.SAXNotRecognizedException
  • All Implemented Interfaces:
    Serializable

    public class SAXNotRecognizedException
extends SAXException
    Exception class for an unrecognized identifier.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    An XMLReader will throw this exception when it finds an unrecognized feature or property identifier; SAX applications and extensions may use this class for other, similar purposes.

    Since:
    SAX 2.0
    See Also:
    SAXNotSupportedException, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      SAXNotRecognizedException()
      Default constructor.
      SAXNotRecognizedException(String message)
      Construct a new exception with the given message.

    • Method Summary

      • Methods inherited from class org.xml.sax.SAXException

        getCause, getException, getMessage, toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • SAXNotRecognizedException

        public SAXNotRecognizedException()
        Default constructor.

      • SAXNotRecognizedException

        public SAXNotRecognizedException(String message)
        Construct a new exception with the given message.
        Parameters:
        message - The text message of the exception.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SAXNotSupportedException (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax

Class SAXNotSupportedException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.xml.sax.SAXException
          • org.xml.sax.SAXNotSupportedException
  • All Implemented Interfaces:
    Serializable

    public class SAXNotSupportedException
extends SAXException
    Exception class for an unsupported operation.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    An XMLReader will throw this exception when it recognizes a feature or property identifier, but cannot perform the requested operation (setting a state or value). Other SAX2 applications and extensions may use this class for similar purposes.

    Since:
    SAX 2.0
    See Also:
    SAXNotRecognizedException, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      SAXNotSupportedException()
      Construct a new exception with no message.
      SAXNotSupportedException(String message)
      Construct a new exception with the given message.

    • Method Summary

      • Methods inherited from class org.xml.sax.SAXException

        getCause, getException, getMessage, toString

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • SAXNotSupportedException

        public SAXNotSupportedException()
        Construct a new exception with no message.

      • SAXNotSupportedException

        public SAXNotSupportedException(String message)
        Construct a new exception with the given message.
        Parameters:
        message - The text message of the exception.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


SAXParseException (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax

Class SAXParseException

  • java.lang.Object
    • java.lang.Throwable
      • java.lang.Exception
        • org.xml.sax.SAXException
          • org.xml.sax.SAXParseException
  • All Implemented Interfaces:
    Serializable

    public class SAXParseException
extends SAXException
    Encapsulate an XML parse error or warning.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    This exception may include information for locating the error in the original XML document, as if it came from a Locator object. Note that although the application will receive a SAXParseException as the argument to the handlers in the ErrorHandler interface, the application is not actually required to throw the exception; instead, it can simply read the information in it and take a different action.

    Since this exception is a subclass of SAXException, it inherits the ability to wrap another exception.

    Since:
    SAX 1.0
    Version:
    2.0.1 (sax2r2)
    See Also:
    SAXException, Locator, ErrorHandler, Serialized Form

    • Constructor Summary

      Constructors
      Constructor and Description
      SAXParseException(String message, Locator locator)
      Create a new SAXParseException from a message and a Locator.
      SAXParseException(String message, Locator locator, Exception e)
      Wrap an existing exception in a SAXParseException.
      SAXParseException(String message, String publicId, String systemId, int lineNumber, int columnNumber)
      Create a new SAXParseException.
      SAXParseException(String message, String publicId, String systemId, int lineNumber, int columnNumber, Exception e)
      Create a new SAXParseException with an embedded exception.

    • Method Summary

      All Methods Instance Methods Concrete Methods
      Modifier and Type Method and Description
      int getColumnNumber()
      The column number of the end of the text where the exception occurred.
      int getLineNumber()
      The line number of the end of the text where the exception occurred.
      String getPublicId()
      Get the public identifier of the entity where the exception occurred.
      String getSystemId()
      Get the system identifier of the entity where the exception occurred.
      String toString()
      Override toString to provide more detailed error message.

      • Methods inherited from class org.xml.sax.SAXException

        getCause, getException, getMessage

      • Methods inherited from class java.lang.Throwable

        addSuppressed, fillInStackTrace, getLocalizedMessage, getStackTrace, getSuppressed, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace

      • Methods inherited from class java.lang.Object

        clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

    • Constructor Detail

      • SAXParseException

        public SAXParseException(String message,
                         Locator locator)
        Create a new SAXParseException from a message and a Locator.

        This constructor is especially useful when an application is creating its own exception from within a ContentHandler callback.

        Parameters:
        message - The error or warning message.
        locator - The locator object for the error or warning (may be null).
        See Also:
        Locator

      • SAXParseException

        public SAXParseException(String message,
                         Locator locator,
                         Exception e)
        Wrap an existing exception in a SAXParseException.

        This constructor is especially useful when an application is creating its own exception from within a ContentHandler callback, and needs to wrap an existing exception that is not a subclass of SAXException.

        Parameters:
        message - The error or warning message, or null to use the message from the embedded exception.
        locator - The locator object for the error or warning (may be null).
        e - Any exception.
        See Also:
        Locator

      • SAXParseException

        public SAXParseException(String message,
                         String publicId,
                         String systemId,
                         int lineNumber,
                         int columnNumber)
        Create a new SAXParseException.

        This constructor is most useful for parser writers.

        All parameters except the message are as if they were provided by a Locator. For example, if the system identifier is a URL (including relative filename), the caller must resolve it fully before creating the exception.

        Parameters:
        message - The error or warning message.
        publicId - The public identifier of the entity that generated the error or warning.
        systemId - The system identifier of the entity that generated the error or warning.
        lineNumber - The line number of the end of the text that caused the error or warning.
        columnNumber - The column number of the end of the text that cause the error or warning.

      • SAXParseException

        public SAXParseException(String message,
                         String publicId,
                         String systemId,
                         int lineNumber,
                         int columnNumber,
                         Exception e)
        Create a new SAXParseException with an embedded exception.

        This constructor is most useful for parser writers who need to wrap an exception that is not a subclass of SAXException.

        All parameters except the message and exception are as if they were provided by a Locator. For example, if the system identifier is a URL (including relative filename), the caller must resolve it fully before creating the exception.

        Parameters:
        message - The error or warning message, or null to use the message from the embedded exception.
        publicId - The public identifier of the entity that generated the error or warning.
        systemId - The system identifier of the entity that generated the error or warning.
        lineNumber - The line number of the end of the text that caused the error or warning.
        columnNumber - The column number of the end of the text that cause the error or warning.
        e - Another exception to embed in this one.

    • Method Detail

      • getPublicId

        public String getPublicId()
        Get the public identifier of the entity where the exception occurred.
        Returns:
        A string containing the public identifier, or null if none is available.
        See Also:
        Locator.getPublicId()

      • getSystemId

        public String getSystemId()
        Get the system identifier of the entity where the exception occurred.

        If the system identifier is a URL, it will have been resolved fully.

        Returns:
        A string containing the system identifier, or null if none is available.
        See Also:
        Locator.getSystemId()

      • getLineNumber

        public int getLineNumber()
        The line number of the end of the text where the exception occurred.

        The first line is line 1.

        Returns:
        An integer representing the line number, or -1 if none is available.
        See Also:
        Locator.getLineNumber()

      • getColumnNumber

        public int getColumnNumber()
        The column number of the end of the text where the exception occurred.

        The first column in a line is position 1.

        Returns:
        An integer representing the column number, or -1 if none is available.
        See Also:
        Locator.getColumnNumber()

      • toString

        public String toString()
        Override toString to provide more detailed error message.
        Overrides:
        toString in class SAXException
        Returns:
        A string representation of this exception.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


XMLFilter (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax

Interface XMLFilter

  • All Superinterfaces:
    XMLReader
    All Known Implementing Classes:
    XMLFilterImpl

    public interface XMLFilter
extends XMLReader
    Interface for an XML filter.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    An XML filter is like an XML reader, except that it obtains its events from another XML reader rather than a primary source like an XML document or database. Filters can modify a stream of events as they pass on to the final application.

    The XMLFilterImpl helper class provides a convenient base for creating SAX2 filters, by passing on all EntityResolver, DTDHandler, ContentHandler and ErrorHandler events automatically.

    Since:
    SAX 2.0
    See Also:
    XMLFilterImpl

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      XMLReader getParent()
      Get the parent reader.
      void setParent(XMLReader parent)
      Set the parent reader.

      • Methods inherited from interface org.xml.sax.XMLReader

        getContentHandler, getDTDHandler, getEntityResolver, getErrorHandler, getFeature, getProperty, parse, parse, setContentHandler, setDTDHandler, setEntityResolver, setErrorHandler, setFeature, setProperty

    • Method Detail

      • setParent

        void setParent(XMLReader parent)
        Set the parent reader.

        This method allows the application to link the filter to a parent reader (which may be another filter). The argument may not be null.

        Parameters:
        parent - The parent reader.

      • getParent

        XMLReader getParent()
        Get the parent reader.

        This method allows the application to query the parent reader (which may be another filter). It is generally a bad idea to perform any operations on the parent reader directly: they should all pass through this filter.

        Returns:
        The parent filter, or null if none has been set.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


XMLReader (Java Platform SE 8 )

Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method
compact2, compact3
org.xml.sax

Interface XMLReader

  • All Known Subinterfaces:
    XMLFilter
    All Known Implementing Classes:
    ParserAdapter, XMLFilterImpl

    public interface XMLReader
    Interface for reading an XML document using callbacks.
    This module, both source code and documentation, is in the Public Domain, and comes with NO WARRANTY. See http://www.saxproject.org for further information.

    Note: despite its name, this interface does not extend the standard Java Reader interface, because reading XML is a fundamentally different activity than reading character data.

    XMLReader is the interface that an XML parser's SAX2 driver must implement. This interface allows an application to set and query features and properties in the parser, to register event handlers for document processing, and to initiate a document parse.

    All SAX interfaces are assumed to be synchronous: the parse methods must not return until parsing is complete, and readers must wait for an event-handler callback to return before reporting the next event.

    This interface replaces the (now deprecated) SAX 1.0 Parser interface. The XMLReader interface contains two important enhancements over the old Parser interface (as well as some minor ones):

    1. it adds a standard way to query and set features and properties; and
    2. it adds Namespace support, which is required for many higher-level XML standards.

    There are adapters available to convert a SAX1 Parser to a SAX2 XMLReader and vice-versa.

    Since:
    SAX 2.0
    See Also:
    XMLFilter, ParserAdapter, XMLReaderAdapter

    • Method Summary

      All Methods Instance Methods Abstract Methods
      Modifier and Type Method and Description
      ContentHandler getContentHandler()
      Return the current content handler.
      DTDHandler getDTDHandler()
      Return the current DTD handler.
      EntityResolver getEntityResolver()
      Return the current entity resolver.
      ErrorHandler getErrorHandler()
      Return the current error handler.
      boolean getFeature(String name)
      Look up the value of a feature flag.
      Object getProperty(String name)
      Look up the value of a property.
      void parse(InputSource input)
      Parse an XML document.
      void parse(String systemId)
      Parse an XML document from a system identifier (URI).
      void setContentHandler(ContentHandler handler)
      Allow an application to register a content event handler.
      void setDTDHandler(DTDHandler handler)
      Allow an application to register a DTD event handler.
      void setEntityResolver(EntityResolver resolver)
      Allow an application to register an entity resolver.
      void setErrorHandler(ErrorHandler handler)
      Allow an application to register an error event handler.
      void setFeature(String name, boolean value)
      Set the value of a feature flag.
      void setProperty(String name, Object value)
      Set the value of a property.

    • Method Detail

      • getFeature

        boolean getFeature(String name)
            throws SAXNotRecognizedException,
                   SAXNotSupportedException
        Look up the value of a feature flag.

        The feature name is any fully-qualified URI. It is possible for an XMLReader to recognize a feature name but temporarily be unable to return its value. Some feature values may be available only in specific contexts, such as before, during, or after a parse. Also, some feature values may not be programmatically accessible. (In the case of an adapter for SAX1 Parser, there is no implementation-independent way to expose whether the underlying parser is performing validation, expanding external entities, and so forth.)

        All XMLReaders are required to recognize the http://xml.org/sax/features/namespaces and the http://xml.org/sax/features/namespace-prefixes feature names.

        Typical usage is something like this:

         XMLReader r = new MySAXDriver();

                         // try to activate validation
 try {
   r.setFeature("http://xml.org/sax/features/validation", true);
 } catch (SAXException e) {
   System.err.println("Cannot activate validation.");
 }

                         // register event handlers
 r.setContentHandler(new MyContentHandler());
 r.setErrorHandler(new MyErrorHandler());

                         // parse the first document
 try {
   r.parse("http://www.foo.com/mydoc.xml");
 } catch (IOException e) {
   System.err.println("I/O exception reading XML document");
 } catch (SAXException e) {
   System.err.println("XML exception reading document.");
 }

        Implementors are free (and encouraged) to invent their own features, using names built on their own URIs.

        Parameters:
        name - The feature name, which is a fully-qualified URI.
        Returns:
        The current value of the feature (true or false).
        Throws:
        SAXNotRecognizedException - If the feature value can't be assigned or retrieved.
        SAXNotSupportedException - When the XMLReader recognizes the feature name but cannot determine its value at this time.
        See Also:
        setFeature(java.lang.String, boolean)

      • setFeature

        void setFeature(String name,
                boolean value)
         throws SAXNotRecognizedException,
                SAXNotSupportedException
        Set the value of a feature flag.

        The feature name is any fully-qualified URI. It is possible for an XMLReader to expose a feature value but to be unable to change the current value. Some feature values may be immutable or mutable only in specific contexts, such as before, during, or after a parse.

        All XMLReaders are required to support setting http://xml.org/sax/features/namespaces to true and http://xml.org/sax/features/namespace-prefixes to false.

        Parameters:
        name - The feature name, which is a fully-qualified URI.
        value - The requested value of the feature (true or false).
        Throws:
        SAXNotRecognizedException - If the feature value can't be assigned or retrieved.
        SAXNotSupportedException - When the XMLReader recognizes the feature name but cannot set the requested value.
        See Also:
        getFeature(java.lang.String)

      • getProperty

        Object getProperty(String name)
            throws SAXNotRecognizedException,
                   SAXNotSupportedException
        Look up the value of a property.

        The property name is any fully-qualified URI. It is possible for an XMLReader to recognize a property name but temporarily be unable to return its value. Some property values may be available only in specific contexts, such as before, during, or after a parse.

        XMLReaders are not required to recognize any specific property names, though an initial core set is documented for SAX2.

        Implementors are free (and encouraged) to invent their own properties, using names built on their own URIs.

        Parameters:
        name - The property name, which is a fully-qualified URI.
        Returns:
        The current value of the property.
        Throws:
        SAXNotRecognizedException - If the property value can't be assigned or retrieved.
        SAXNotSupportedException - When the XMLReader recognizes the property name but cannot determine its value at this time.
        See Also:
        setProperty(java.lang.String, java.lang.Object)

      • setProperty

        void setProperty(String name,
                 Object value)
          throws SAXNotRecognizedException,
                 SAXNotSupportedException
        Set the value of a property.

        The property name is any fully-qualified URI. It is possible for an XMLReader to recognize a property name but to be unable to change the current value. Some property values may be immutable or mutable only in specific contexts, such as before, during, or after a parse.

        XMLReaders are not required to recognize setting any specific property names, though a core set is defined by SAX2.

        This method is also the standard mechanism for setting extended handlers.

        Parameters:
        name - The property name, which is a fully-qualified URI.
        value - The requested value for the property.
        Throws:
        SAXNotRecognizedException - If the property value can't be assigned or retrieved.
        SAXNotSupportedException - When the XMLReader recognizes the property name but cannot set the requested value.

      • setEntityResolver

        void setEntityResolver(EntityResolver resolver)
        Allow an application to register an entity resolver.

        If the application does not register an entity resolver, the XMLReader will perform its own default resolution.

        Applications may register a new or different resolver in the middle of a parse, and the SAX parser must begin using the new resolver immediately.

        Parameters:
        resolver - The entity resolver.
        See Also:
        getEntityResolver()

      • getEntityResolver

        EntityResolver getEntityResolver()
        Return the current entity resolver.
        Returns:
        The current entity resolver, or null if none has been registered.
        See Also:
        setEntityResolver(org.xml.sax.EntityResolver)

      • setDTDHandler

        void setDTDHandler(DTDHandler handler)
        Allow an application to register a DTD event handler.

        If the application does not register a DTD handler, all DTD events reported by the SAX parser will be silently ignored.

        Applications may register a new or different handler in the middle of a parse, and the SAX parser must begin using the new handler immediately.

        Parameters:
        handler - The DTD handler.
        See Also:
        getDTDHandler()

      • getDTDHandler

        DTDHandler getDTDHandler()
        Return the current DTD handler.
        Returns:
        The current DTD handler, or null if none has been registered.
        See Also:
        setDTDHandler(org.xml.sax.DTDHandler)

      • setContentHandler

        void setContentHandler(ContentHandler handler)
        Allow an application to register a content event handler.

        If the application does not register a content handler, all content events reported by the SAX parser will be silently ignored.

        Applications may register a new or different handler in the middle of a parse, and the SAX parser must begin using the new handler immediately.

        Parameters:
        handler - The content handler.
        See Also:
        getContentHandler()

      • getContentHandler

        ContentHandler getContentHandler()
        Return the current content handler.
        Returns:
        The current content handler, or null if none has been registered.
        See Also:
        setContentHandler(org.xml.sax.ContentHandler)

      • setErrorHandler

        void setErrorHandler(ErrorHandler handler)
        Allow an application to register an error event handler.

        If the application does not register an error handler, all error events reported by the SAX parser will be silently ignored; however, normal processing may not continue. It is highly recommended that all SAX applications implement an error handler to avoid unexpected bugs.

        Applications may register a new or different handler in the middle of a parse, and the SAX parser must begin using the new handler immediately.

        Parameters:
        handler - The error handler.
        See Also:
        getErrorHandler()

      • getErrorHandler

        ErrorHandler getErrorHandler()
        Return the current error handler.
        Returns:
        The current error handler, or null if none has been registered.
        See Also:
        setErrorHandler(org.xml.sax.ErrorHandler)

      • parse

        void parse(InputSource input)
    throws IOException,
           SAXException
        Parse an XML document.

        The application can use this method to instruct the XML reader to begin parsing an XML document from any valid input source (a character stream, a byte stream, or a URI).

        Applications may not invoke this method while a parse is in progress (they should create a new XMLReader instead for each nested XML document). Once a parse is complete, an application may reuse the same XMLReader object, possibly with a different input source. Configuration of the XMLReader object (such as handler bindings and values established for feature flags and properties) is unchanged by completion of a parse, unless the definition of that aspect of the configuration explicitly specifies other behavior. (For example, feature flags or properties exposing characteristics of the document being parsed.)

        During the parse, the XMLReader will provide information about the XML document through the registered event handlers.

        This method is synchronous: it will not return until parsing has ended. If a client application wants to terminate parsing early, it should throw an exception.

        Parameters:
        input - The input source for the top-level of the XML document.
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        IOException - An IO exception from the parser, possibly from a byte stream or character stream supplied by the application.
        See Also:
        InputSource,
parse(java.lang.String),
setEntityResolver(org.xml.sax.EntityResolver),
setDTDHandler(org.xml.sax.DTDHandler),
setContentHandler(org.xml.sax.ContentHandler),
setErrorHandler(org.xml.sax.ErrorHandler)

      • parse

        void parse(String systemId)
    throws IOException,
           SAXException
        Parse an XML document from a system identifier (URI).

        This method is a shortcut for the common case of reading a document from a system identifier. It is the exact equivalent of the following:

         parse(new InputSource(systemId));

        If the system identifier is a URL, it must be fully resolved by the application before it is passed to the parser.

        Parameters:
        systemId - The system identifier (URI).
        Throws:
        SAXException - Any SAX exception, possibly wrapping another exception.
        IOException - An IO exception from the parser, possibly from a byte stream or character stream supplied by the application.
        See Also:
        parse(org.xml.sax.InputSource)
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Class
  • Next Class
  • Frames
  • No Frames
  • All Classes
  • Summary:
  • Nested |
  • Field |
  • Constr |
  • Method
  • Detail:
  • Field |
  • Constr |
  • Method


Overview List (Java Platform SE 8 )

Standard Ed. 8

All ClassesAll Profiles

Packages

  • java.applet
  • java.awt
  • java.awt.color
  • java.awt.datatransfer
  • java.awt.dnd
  • java.awt.event
  • java.awt.font
  • java.awt.geom
  • java.awt.im
  • java.awt.im.spi
  • java.awt.image
  • java.awt.image.renderable
  • java.awt.print
  • java.beans
  • java.beans.beancontext
  • java.io
  • java.lang
  • java.lang.annotation
  • java.lang.instrument
  • java.lang.invoke
  • java.lang.management
  • java.lang.ref
  • java.lang.reflect
  • java.math
  • java.net
  • java.nio
  • java.nio.channels
  • java.nio.channels.spi
  • java.nio.charset
  • java.nio.charset.spi
  • java.nio.file
  • java.nio.file.attribute
  • java.nio.file.spi
  • java.rmi
  • java.rmi.activation
  • java.rmi.dgc
  • java.rmi.registry
  • java.rmi.server
  • java.security
  • java.security.acl
  • java.security.cert
  • java.security.interfaces
  • java.security.spec
  • java.sql
  • java.text
  • java.text.spi
  • java.time
  • java.time.chrono
  • java.time.format
  • java.time.temporal
  • java.time.zone
  • java.util
  • java.util.concurrent
  • java.util.concurrent.atomic
  • java.util.concurrent.locks
  • java.util.function
  • java.util.jar
  • java.util.logging
  • java.util.prefs
  • java.util.regex
  • java.util.spi
  • java.util.stream
  • java.util.zip
  • javax.accessibility
  • javax.activation
  • javax.activity
  • javax.annotation
  • javax.annotation.processing
  • javax.crypto
  • javax.crypto.interfaces
  • javax.crypto.spec
  • javax.imageio
  • javax.imageio.event
  • javax.imageio.metadata
  • javax.imageio.plugins.bmp
  • javax.imageio.plugins.jpeg
  • javax.imageio.spi
  • javax.imageio.stream
  • javax.jws
  • javax.jws.soap
  • javax.lang.model
  • javax.lang.model.element
  • javax.lang.model.type
  • javax.lang.model.util
  • javax.management
  • javax.management.loading
  • javax.management.modelmbean
  • javax.management.monitor
  • javax.management.openmbean
  • javax.management.relation
  • javax.management.remote
  • javax.management.remote.rmi
  • javax.management.timer
  • javax.naming
  • javax.naming.directory
  • javax.naming.event
  • javax.naming.ldap
  • javax.naming.spi
  • javax.net
  • javax.net.ssl
  • javax.print
  • javax.print.attribute
  • javax.print.attribute.standard
  • javax.print.event
  • javax.rmi
  • javax.rmi.CORBA
  • javax.rmi.ssl
  • javax.script
  • javax.security.auth
  • javax.security.auth.callback
  • javax.security.auth.kerberos
  • javax.security.auth.login
  • javax.security.auth.spi
  • javax.security.auth.x500
  • javax.security.cert
  • javax.security.sasl
  • javax.sound.midi
  • javax.sound.midi.spi
  • javax.sound.sampled
  • javax.sound.sampled.spi
  • javax.sql
  • javax.sql.rowset
  • javax.sql.rowset.serial
  • javax.sql.rowset.spi
  • javax.swing
  • javax.swing.border
  • javax.swing.colorchooser
  • javax.swing.event
  • javax.swing.filechooser
  • javax.swing.plaf
  • javax.swing.plaf.basic
  • javax.swing.plaf.metal
  • javax.swing.plaf.multi
  • javax.swing.plaf.nimbus
  • javax.swing.plaf.synth
  • javax.swing.table
  • javax.swing.text
  • javax.swing.text.html
  • javax.swing.text.html.parser
  • javax.swing.text.rtf
  • javax.swing.tree
  • javax.swing.undo
  • javax.tools
  • javax.transaction
  • javax.transaction.xa
  • javax.xml
  • javax.xml.bind
  • javax.xml.bind.annotation
  • javax.xml.bind.annotation.adapters
  • javax.xml.bind.attachment
  • javax.xml.bind.helpers
  • javax.xml.bind.util
  • javax.xml.crypto
  • javax.xml.crypto.dom
  • javax.xml.crypto.dsig
  • javax.xml.crypto.dsig.dom
  • javax.xml.crypto.dsig.keyinfo
  • javax.xml.crypto.dsig.spec
  • javax.xml.datatype
  • javax.xml.namespace
  • javax.xml.parsers
  • javax.xml.soap
  • javax.xml.stream
  • javax.xml.stream.events
  • javax.xml.stream.util
  • javax.xml.transform
  • javax.xml.transform.dom
  • javax.xml.transform.sax
  • javax.xml.transform.stax
  • javax.xml.transform.stream
  • javax.xml.validation
  • javax.xml.ws
  • javax.xml.ws.handler
  • javax.xml.ws.handler.soap
  • javax.xml.ws.http
  • javax.xml.ws.soap
  • javax.xml.ws.spi
  • javax.xml.ws.spi.http
  • javax.xml.ws.wsaddressing
  • javax.xml.xpath
  • org.ietf.jgss
  • org.omg.CORBA
  • org.omg.CORBA_2_3
  • org.omg.CORBA_2_3.portable
  • org.omg.CORBA.DynAnyPackage
  • org.omg.CORBA.ORBPackage
  • org.omg.CORBA.portable
  • org.omg.CORBA.TypeCodePackage
  • org.omg.CosNaming
  • org.omg.CosNaming.NamingContextExtPackage
  • org.omg.CosNaming.NamingContextPackage
  • org.omg.Dynamic
  • org.omg.DynamicAny
  • org.omg.DynamicAny.DynAnyFactoryPackage
  • org.omg.DynamicAny.DynAnyPackage
  • org.omg.IOP
  • org.omg.IOP.CodecFactoryPackage
  • org.omg.IOP.CodecPackage
  • org.omg.Messaging
  • org.omg.PortableInterceptor
  • org.omg.PortableInterceptor.ORBInitInfoPackage
  • org.omg.PortableServer
  • org.omg.PortableServer.CurrentPackage
  • org.omg.PortableServer.POAManagerPackage
  • org.omg.PortableServer.POAPackage
  • org.omg.PortableServer.portable
  • org.omg.PortableServer.ServantLocatorPackage
  • org.omg.SendingContext
  • org.omg.stub.java.rmi
  • org.w3c.dom
  • org.w3c.dom.bootstrap
  • org.w3c.dom.events
  • org.w3c.dom.ls
  • org.w3c.dom.views
  • org.xml.sax
  • org.xml.sax.ext
  • org.xml.sax.helpers


Overview (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Java™ Platform, Standard Edition 8
API Specification

This document is the API specification for the Java™ Platform, Standard Edition.

See: Description

Profiles

  • compact1
  • compact2
  • compact3
Packages
Package | Description
java.applet | Provides the classes necessary to create an applet and the classes an applet uses to communicate with its applet context.
java.awt | Contains all of the classes for creating user interfaces and for painting graphics and images.
java.awt.color | Provides classes for color spaces.
java.awt.datatransfer | Provides interfaces and classes for transferring data between and within applications.
java.awt.dnd | Drag and Drop is a direct manipulation gesture found in many Graphical User Interface systems that provides a mechanism to transfer information between two entities logically associated with presentation elements in the GUI.
java.awt.event | Provides interfaces and classes for dealing with different types of events fired by AWT components.
java.awt.font | Provides classes and interface relating to fonts.
java.awt.geom | Provides the Java 2D classes for defining and performing operations on objects related to two-dimensional geometry.
java.awt.im | Provides classes and interfaces for the input method framework.
java.awt.im.spi | Provides interfaces that enable the development of input methods that can be used with any Java runtime environment.
java.awt.image | Provides classes for creating and modifying images.
java.awt.image.renderable | Provides classes and interfaces for producing rendering-independent images.
java.awt.print | Provides classes and interfaces for a general printing API.
java.beans | Contains classes related to developing beans -- components based on the JavaBeans™ architecture.
java.beans.beancontext | Provides classes and interfaces relating to bean context.
java.io | Provides for system input and output through data streams, serialization and the file system.
java.lang | Provides classes that are fundamental to the design of the Java programming language.
java.lang.annotation | Provides library support for the Java programming language annotation facility.
java.lang.instrument | Provides services that allow Java programming language agents to instrument programs running on the JVM.
java.lang.invoke | The java.lang.invoke package contains dynamic language support provided directly by the Java core class libraries and virtual machine.
java.lang.management | Provides the management interfaces for monitoring and management of the Java virtual machine and other components in the Java runtime.
java.lang.ref | Provides reference-object classes, which support a limited degree of interaction with the garbage collector.
java.lang.reflect | Provides classes and interfaces for obtaining reflective information about classes and objects.
java.math | Provides classes for performing arbitrary-precision integer arithmetic (BigInteger) and arbitrary-precision decimal arithmetic (BigDecimal).
java.net | Provides the classes for implementing networking applications.
java.nio | Defines buffers, which are containers for data, and provides an overview of the other NIO packages.
java.nio.channels | Defines channels, which represent connections to entities that are capable of performing I/O operations, such as files and sockets; defines selectors, for multiplexed, non-blocking I/O operations.
java.nio.channels.spi | Service-provider classes for the java.nio.channels package.
java.nio.charset | Defines charsets, decoders, and encoders, for translating between bytes and Unicode characters.
java.nio.charset.spi | Service-provider classes for the java.nio.charset package.
java.nio.file | Defines interfaces and classes for the Java virtual machine to access files, file attributes, and file systems.
java.nio.file.attribute | Interfaces and classes providing access to file and file system attributes.
java.nio.file.spi | Service-provider classes for the java.nio.file package.
java.rmi | Provides the RMI package.
java.rmi.activation | Provides support for RMI Object Activation.
java.rmi.dgc | Provides classes and interface for RMI distributed garbage-collection (DGC).
java.rmi.registry | Provides a class and two interfaces for the RMI registry.
java.rmi.server | Provides classes and interfaces for supporting the server side of RMI.
java.security | Provides the classes and interfaces for the security framework.
java.security.acl | The classes and interfaces in this package have been superseded by classes in the java.security package.
java.security.cert | Provides classes and interfaces for parsing and managing certificates, certificate revocation lists (CRLs), and certification paths.
java.security.interfaces | Provides interfaces for generating RSA (Rivest, Shamir and Adleman AsymmetricCipher algorithm) keys as defined in the RSA Laboratory Technical Note PKCS#1, and DSA (Digital Signature Algorithm) keys as defined in NIST's FIPS-186.
java.security.spec | Provides classes and interfaces for key specifications and algorithm parameter specifications.
java.sql | Provides the API for accessing and processing data stored in a data source (usually a relational database) using the JavaTM programming language.
java.text | Provides classes and interfaces for handling text, dates, numbers, and messages in a manner independent of natural languages.
java.text.spi | Service provider classes for the classes in the java.text package.
java.time | The main API for dates, times, instants, and durations.
java.time.chrono | Generic API for calendar systems other than the default ISO.
java.time.format | Provides classes to print and parse dates and times.
java.time.temporal | Access to date and time using fields and units, and date time adjusters.
java.time.zone | Support for time-zones and their rules.
java.util | Contains the collections framework, legacy collection classes, event model, date and time facilities, internationalization, and miscellaneous utility classes (a string tokenizer, a random-number generator, and a bit array).
java.util.concurrent | Utility classes commonly useful in concurrent programming.
java.util.concurrent.atomic | A small toolkit of classes that support lock-free thread-safe programming on single variables.
java.util.concurrent.locks | Interfaces and classes providing a framework for locking and waiting for conditions that is distinct from built-in synchronization and monitors.
java.util.function | Functional interfaces provide target types for lambda expressions and method references.
java.util.jar | Provides classes for reading and writing the JAR (Java ARchive) file format, which is based on the standard ZIP file format with an optional manifest file.
java.util.logging | Provides the classes and interfaces of the JavaTM 2 platform's core logging facilities.
java.util.prefs | This package allows applications to store and retrieve user and system preference and configuration data.
java.util.regex | Classes for matching character sequences against patterns specified by regular expressions.
java.util.spi | Service provider classes for the classes in the java.util package.
java.util.stream | Classes to support functional-style operations on streams of elements, such as map-reduce transformations on collections.
java.util.zip | Provides classes for reading and writing the standard ZIP and GZIP file formats.
javax.accessibility | Defines a contract between user-interface components and an assistive technology that provides access to those components.
javax.activation |
javax.activity | Contains Activity service related exceptions thrown by the ORB machinery during unmarshalling.
javax.annotation |
javax.annotation.processing | Facilities for declaring annotation processors and for allowing annotation processors to communicate with an annotation processing tool environment.
javax.crypto | Provides the classes and interfaces for cryptographic operations.
javax.crypto.interfaces | Provides interfaces for Diffie-Hellman keys as defined in RSA Laboratories' PKCS #3.
javax.crypto.spec | Provides classes and interfaces for key specifications and algorithm parameter specifications.
javax.imageio | The main package of the Java Image I/O API.
javax.imageio.event | A package of the Java Image I/O API dealing with synchronous notification of events during the reading and writing of images.
javax.imageio.metadata | A package of the Java Image I/O API dealing with reading and writing metadata.
javax.imageio.plugins.bmp | Package containing the public classes used by the built-in BMP plug-in.
javax.imageio.plugins.jpeg | Classes supporting the built-in JPEG plug-in.
javax.imageio.spi | A package of the Java Image I/O API containing the plug-in interfaces for readers, writers, transcoders, and streams, and a runtime registry.
javax.imageio.stream | A package of the Java Image I/O API dealing with low-level I/O from files and streams.
javax.jws |
javax.jws.soap |
javax.lang.model | Classes and hierarchies of packages used to model the Java programming language.
javax.lang.model.element | Interfaces used to model elements of the Java programming language.
javax.lang.model.type | Interfaces used to model Java programming language types.
javax.lang.model.util | Utilities to assist in the processing of program elements and types.
javax.management | Provides the core classes for the Java Management Extensions.
javax.management.loading | Provides the classes which implement advanced dynamic loading.
javax.management.modelmbean | Provides the definition of the ModelMBean classes.
javax.management.monitor | Provides the definition of the monitor classes.
javax.management.openmbean | Provides the open data types and Open MBean descriptor classes.
javax.management.relation | Provides the definition of the Relation Service.
javax.management.remote | Interfaces for remote access to JMX MBean servers.
javax.management.remote.rmi | The RMI connector is a connector for the JMX Remote API that uses RMI to transmit client requests to a remote MBean server.
javax.management.timer | Provides the definition of the Timer MBean.
javax.naming | Provides the classes and interfaces for accessing naming services.
javax.naming.directory | Extends the javax.naming package to provide functionality for accessing directory services.
javax.naming.event | Provides support for event notification when accessing naming and directory services.
javax.naming.ldap | Provides support for LDAPv3 extended operations and controls.
javax.naming.spi |
javax.net | Provides classes for networking applications.
javax.net.ssl | Provides classes for the secure socket package.
javax.print | Provides the principal classes and interfaces for the JavaTM Print Service API.
javax.print.attribute | Provides classes and interfaces that describe the types of JavaTM Print Service attributes and how they can be collected into attribute sets.
javax.print.attribute.standard | Package javax.print.attribute.standard contains classes for specific printing attributes.
javax.print.event | Package javax.print.event contains event classes and listener interfaces.
javax.rmi | Contains user APIs for RMI-IIOP.
javax.rmi.CORBA | Contains portability APIs for RMI-IIOP.
javax.rmi.ssl | Provides implementations of RMIClientSocketFactory and RMIServerSocketFactory over the Secure Sockets Layer (SSL) or Transport Layer Security (TLS) protocols.
javax.script | The scripting API consists of interfaces and classes that define Java TM Scripting Engines and provides a framework for their use in Java applications.
javax.security.auth | This package provides a framework for authentication and authorization.
javax.security.auth.callback | This package provides the classes necessary for services to interact with applications in order to retrieve information (authentication data including usernames or passwords, for example) or to display information (error and warning messages, for example).
javax.security.auth.kerberos | This package contains utility classes related to the Kerberos network authentication protocol.
javax.security.auth.login | This package provides a pluggable authentication framework.
javax.security.auth.spi | This package provides the interface to be used for implementing pluggable authentication modules.
javax.security.auth.x500 | This package contains the classes that should be used to store X500 Principal and X500 Private Credentials in a Subject.
javax.security.cert | Provides classes for public key certificates.
javax.security.sasl | Contains class and interfaces for supporting SASL.
javax.sound.midi | Provides interfaces and classes for I/O, sequencing, and synthesis of MIDI (Musical Instrument Digital Interface) data.
javax.sound.midi.spi | Supplies interfaces for service providers to implement when offering new MIDI devices, MIDI file readers and writers, or sound bank readers.
javax.sound.sampled | Provides interfaces and classes for capture, processing, and playback of sampled audio data.
javax.sound.sampled.spi | Supplies abstract classes for service providers to subclass when offering new audio devices, sound file readers and writers, or audio format converters.
javax.sql | Provides the API for server side data source access and processing from the JavaTM programming language.
javax.sql.rowset | Standard interfaces and base classes for JDBC RowSet implementations.
javax.sql.rowset.serial | Provides utility classes to allow serializable mappings between SQL types and data types in the Java programming language.
javax.sql.rowset.spi | The standard classes and interfaces that a third party vendor has to use in its implementation of a synchronization provider.
javax.swing | Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
javax.swing.border | Provides classes and interface for drawing specialized borders around a Swing component.
javax.swing.colorchooser | Contains classes and interfaces used by the JColorChooser component.
javax.swing.event | Provides for events fired by Swing components.
javax.swing.filechooser | Contains classes and interfaces used by the JFileChooser component.
javax.swing.plaf | Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.
javax.swing.plaf.basic | Provides user interface objects built according to the Basic look and feel.
javax.swing.plaf.metal | Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
javax.swing.plaf.multi | Provides user interface objects that combine two or more look and feels.
javax.swing.plaf.nimbus | Provides user interface objects built according to the cross-platform Nimbus look and feel.
javax.swing.plaf.synth | Synth is a skinnable look and feel in which all painting is delegated.
javax.swing.table | Provides classes and interfaces for dealing with javax.swing.JTable.
javax.swing.text | Provides classes and interfaces that deal with editable and noneditable text components.
javax.swing.text.html | Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.
javax.swing.text.html.parser | Provides the default HTML parser, along with support classes.
javax.swing.text.rtf | Provides a class (RTFEditorKit) for creating Rich-Text-Format text editors.
javax.swing.tree | Provides classes and interfaces for dealing with javax.swing.JTree.
javax.swing.undo | Allows developers to provide support for undo/redo in applications such as text editors.
javax.tools | Provides interfaces for tools which can be invoked from a program, for example, compilers.
javax.transaction | Contains three exceptions thrown by the ORB machinery during unmarshalling.
javax.transaction.xa | Provides the API that defines the contract between the transaction manager and the resource manager, which allows the transaction manager to enlist and delist resource objects (supplied by the resource manager driver) in JTA transactions.
javax.xml |
javax.xml.bind | Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
javax.xml.bind.annotation | Defines annotations for customizing Java program elements to XML Schema mapping.
javax.xml.bind.annotation.adapters | XmlAdapter and its spec-defined sub-classes to allow arbitrary Java classes to be used with JAXB.
javax.xml.bind.attachment | This package is implemented by a MIME-based package processor that enables the interpretation and creation of optimized binary data within an MIME-based package format.
javax.xml.bind.helpers | JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
javax.xml.bind.util | Useful client utility classes.
javax.xml.crypto | Common classes for XML cryptography.
javax.xml.crypto.dom | DOM-specific classes for the javax.xml.crypto package.
javax.xml.crypto.dsig | Classes for generating and validating XML digital signatures.
javax.xml.crypto.dsig.dom | DOM-specific classes for the javax.xml.crypto.dsig package.
javax.xml.crypto.dsig.keyinfo | Classes for parsing and processing KeyInfo elements and structures.
javax.xml.crypto.dsig.spec | Parameter classes for XML digital signatures.
javax.xml.datatype | XML/Java Type Mappings.
javax.xml.namespace | XML Namespace processing.
javax.xml.parsers | Provides classes allowing the processing of XML documents.
javax.xml.soap | Provides the API for creating and building SOAP messages.
javax.xml.stream |
javax.xml.stream.events |
javax.xml.stream.util |
javax.xml.transform | This package defines the generic APIs for processing transformation instructions, and performing a transformation from source to result.
javax.xml.transform.dom | This package implements DOM-specific transformation APIs.
javax.xml.transform.sax | This package implements SAX2-specific transformation APIs.
javax.xml.transform.stax | Provides for StAX-specific transformation APIs.
javax.xml.transform.stream | This package implements stream- and URI- specific transformation APIs.
javax.xml.validation | This package provides an API for validation of XML documents.
javax.xml.ws | This package contains the core JAX-WS APIs.
javax.xml.ws.handler | This package defines APIs for message handlers.
javax.xml.ws.handler.soap | This package defines APIs for SOAP message handlers.
javax.xml.ws.http | This package defines APIs specific to the HTTP binding.
javax.xml.ws.soap | This package defines APIs specific to the SOAP binding.
javax.xml.ws.spi | This package defines SPIs for JAX-WS.
javax.xml.ws.spi.http | Provides HTTP SPI that is used for portable deployment of JAX-WS web services in containers(for e.g.
javax.xml.ws.wsaddressing | This package defines APIs related to WS-Addressing.
javax.xml.xpath | This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.
org.ietf.jgss | This package presents a framework that allows application developers to make use of security services like authentication, data integrity and data confidentiality from a variety of underlying security mechanisms like Kerberos, using a unified API.
org.omg.CORBA | Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
org.omg.CORBA_2_3 | The CORBA_2_3 package defines additions to existing CORBA interfaces in the Java[tm] Standard Edition 6. These changes occurred in recent revisions to the CORBA API defined by the OMG. The new methods were added to interfaces derived from the corresponding interfaces in the CORBA package. This provides backward compatibility and avoids breaking the JCK tests.
org.omg.CORBA_2_3.portable | Provides methods for the input and output of value types, and contains other updates to the org/omg/CORBA/portable package.
org.omg.CORBA.DynAnyPackage | Provides the exceptions used with the DynAny interface (InvalidValue, Invalid, InvalidSeq, and TypeMismatch).
org.omg.CORBA.ORBPackage | Provides the exception InvalidName, which is thrown by the method ORB.resolve_initial_references and the exception InconsistentTypeCode, which is thrown by the Dynamic Any creation methods in the ORB class.
org.omg.CORBA.portable | Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.
org.omg.CORBA.TypeCodePackage | Provides the user-defined exceptions BadKind and Bounds, which are thrown by methods in in the class TypeCode.
org.omg.CosNaming | Provides a naming service for Java IDL.
org.omg.CosNaming.NamingContextExtPackage | This package contains the following classes, which are used in org.omg.CosNaming.NamingContextExt:
org.omg.CosNaming.NamingContextPackage | This package contains Exception classes for the org.omg.CosNaming package.
org.omg.Dynamic | This package contains the Dynamic module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.9.
org.omg.DynamicAny | Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.
org.omg.DynamicAny.DynAnyFactoryPackage | This package contains classes and exceptions from the DynAnyFactory interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.2.
org.omg.DynamicAny.DynAnyPackage | This package contains classes and exceptions from the DynAny interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.
org.omg.IOP | This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
org.omg.IOP.CodecFactoryPackage | This package contains the exceptions specified in the IOP::CodeFactory interface (as part of the Portable Interceptors spec).
org.omg.IOP.CodecPackage | This package is generated from the IOP::Codec IDL interface definition.
org.omg.Messaging | This package contains the Messaging module specified in the OMG CORBA Messaging specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07.
org.omg.PortableInterceptor | Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
org.omg.PortableInterceptor.ORBInitInfoPackage | This package contains the exceptions and typedefs from the ORBInitInfo local interface of the PortableInterceptor module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.7.2.
org.omg.PortableServer | Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
org.omg.PortableServer.CurrentPackage | Provides method implementations with access to the identity of the object on which the method was invoked.
org.omg.PortableServer.POAManagerPackage | Encapsulates the processing state of the POAs it is associated with.
org.omg.PortableServer.POAPackage | Allows programmers to construct object implementations that are portable between different ORB products.
org.omg.PortableServer.portable | Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
org.omg.PortableServer.ServantLocatorPackage | Provides classes and interfaces for locating the servant.
org.omg.SendingContext | Provides support for the marshalling of value types.
org.omg.stub.java.rmi | Contains RMI-IIOP Stubs for the Remote types that occur in the java.rmi package.
org.w3c.dom | Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.
org.w3c.dom.bootstrap |
org.w3c.dom.events |
org.w3c.dom.ls |
org.w3c.dom.views |
org.xml.sax | This package provides the core SAX APIs.
org.xml.sax.ext | This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.
org.xml.sax.helpers | This package contains "helper" classes, including support for bootstrapping SAX-based applications.
This document is the API specification for the Java™ Platform, Standard Edition.
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Class Hierarchy (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Hierarchy For All Packages

Package Hierarchies:
  • java.applet,
  • java.awt,
  • java.awt.color,
  • java.awt.datatransfer,
  • java.awt.dnd,
  • java.awt.event,
  • java.awt.font,
  • java.awt.geom,
  • java.awt.im,
  • java.awt.im.spi,
  • java.awt.image,
  • java.awt.image.renderable,
  • java.awt.print,
  • java.beans,
  • java.beans.beancontext,
  • java.io,
  • java.lang,
  • java.lang.annotation,
  • java.lang.instrument,
  • java.lang.invoke,
  • java.lang.management,
  • java.lang.ref,
  • java.lang.reflect,
  • java.math,
  • java.net,
  • java.nio,
  • java.nio.channels,
  • java.nio.channels.spi,
  • java.nio.charset,
  • java.nio.charset.spi,
  • java.nio.file,
  • java.nio.file.attribute,
  • java.nio.file.spi,
  • java.rmi,
  • java.rmi.activation,
  • java.rmi.dgc,
  • java.rmi.registry,
  • java.rmi.server,
  • java.security,
  • java.security.acl,
  • java.security.cert,
  • java.security.interfaces,
  • java.security.spec,
  • java.sql,
  • java.text,
  • java.text.spi,
  • java.time,
  • java.time.chrono,
  • java.time.format,
  • java.time.temporal,
  • java.time.zone,
  • java.util,
  • java.util.concurrent,
  • java.util.concurrent.atomic,
  • java.util.concurrent.locks,
  • java.util.function,
  • java.util.jar,
  • java.util.logging,
  • java.util.prefs,
  • java.util.regex,
  • java.util.spi,
  • java.util.stream,
  • java.util.zip,
  • javax.accessibility,
  • javax.activation,
  • javax.activity,
  • javax.annotation,
  • javax.annotation.processing,
  • javax.crypto,
  • javax.crypto.interfaces,
  • javax.crypto.spec,
  • javax.imageio,
  • javax.imageio.event,
  • javax.imageio.metadata,
  • javax.imageio.plugins.bmp,
  • javax.imageio.plugins.jpeg,
  • javax.imageio.spi,
  • javax.imageio.stream,
  • javax.jws,
  • javax.jws.soap,
  • javax.lang.model,
  • javax.lang.model.element,
  • javax.lang.model.type,
  • javax.lang.model.util,
  • javax.management,
  • javax.management.loading,
  • javax.management.modelmbean,
  • javax.management.monitor,
  • javax.management.openmbean,
  • javax.management.relation,
  • javax.management.remote,
  • javax.management.remote.rmi,
  • javax.management.timer,
  • javax.naming,
  • javax.naming.directory,
  • javax.naming.event,
  • javax.naming.ldap,
  • javax.naming.spi,
  • javax.net,
  • javax.net.ssl,
  • javax.print,
  • javax.print.attribute,
  • javax.print.attribute.standard,
  • javax.print.event,
  • javax.rmi,
  • javax.rmi.CORBA,
  • javax.rmi.ssl,
  • javax.script,
  • javax.security.auth,
  • javax.security.auth.callback,
  • javax.security.auth.kerberos,
  • javax.security.auth.login,
  • javax.security.auth.spi,
  • javax.security.auth.x500,
  • javax.security.cert,
  • javax.security.sasl,
  • javax.sound.midi,
  • javax.sound.midi.spi,
  • javax.sound.sampled,
  • javax.sound.sampled.spi,
  • javax.sql,
  • javax.sql.rowset,
  • javax.sql.rowset.serial,
  • javax.sql.rowset.spi,
  • javax.swing,
  • javax.swing.border,
  • javax.swing.colorchooser,
  • javax.swing.event,
  • javax.swing.filechooser,
  • javax.swing.plaf,
  • javax.swing.plaf.basic,
  • javax.swing.plaf.metal,
  • javax.swing.plaf.multi,
  • javax.swing.plaf.nimbus,
  • javax.swing.plaf.synth,
  • javax.swing.table,
  • javax.swing.text,
  • javax.swing.text.html,
  • javax.swing.text.html.parser,
  • javax.swing.text.rtf,
  • javax.swing.tree,
  • javax.swing.undo,
  • javax.tools,
  • javax.transaction,
  • javax.transaction.xa,
  • javax.xml,
  • javax.xml.bind,
  • javax.xml.bind.annotation,
  • javax.xml.bind.annotation.adapters,
  • javax.xml.bind.attachment,
  • javax.xml.bind.helpers,
  • javax.xml.bind.util,
  • javax.xml.crypto,
  • javax.xml.crypto.dom,
  • javax.xml.crypto.dsig,
  • javax.xml.crypto.dsig.dom,
  • javax.xml.crypto.dsig.keyinfo,
  • javax.xml.crypto.dsig.spec,
  • javax.xml.datatype,
  • javax.xml.namespace,
  • javax.xml.parsers,
  • javax.xml.soap,
  • javax.xml.stream,
  • javax.xml.stream.events,
  • javax.xml.stream.util,
  • javax.xml.transform,
  • javax.xml.transform.dom,
  • javax.xml.transform.sax,
  • javax.xml.transform.stax,
  • javax.xml.transform.stream,
  • javax.xml.validation,
  • javax.xml.ws,
  • javax.xml.ws.handler,
  • javax.xml.ws.handler.soap,
  • javax.xml.ws.http,
  • javax.xml.ws.soap,
  • javax.xml.ws.spi,
  • javax.xml.ws.spi.http,
  • javax.xml.ws.wsaddressing,
  • javax.xml.xpath,
  • org.ietf.jgss,
  • org.omg.CORBA,
  • org.omg.CORBA_2_3,
  • org.omg.CORBA_2_3.portable,
  • org.omg.CORBA.DynAnyPackage,
  • org.omg.CORBA.ORBPackage,
  • org.omg.CORBA.portable,
  • org.omg.CORBA.TypeCodePackage,
  • org.omg.CosNaming,
  • org.omg.CosNaming.NamingContextExtPackage,
  • org.omg.CosNaming.NamingContextPackage,
  • org.omg.Dynamic,
  • org.omg.DynamicAny,
  • org.omg.DynamicAny.DynAnyFactoryPackage,
  • org.omg.DynamicAny.DynAnyPackage,
  • org.omg.IOP,
  • org.omg.IOP.CodecFactoryPackage,
  • org.omg.IOP.CodecPackage,
  • org.omg.Messaging,
  • org.omg.PortableInterceptor,
  • org.omg.PortableInterceptor.ORBInitInfoPackage,
  • org.omg.PortableServer,
  • org.omg.PortableServer.CurrentPackage,
  • org.omg.PortableServer.POAManagerPackage,
  • org.omg.PortableServer.POAPackage,
  • org.omg.PortableServer.portable,
  • org.omg.PortableServer.ServantLocatorPackage,
  • org.omg.SendingContext,
  • org.omg.stub.java.rmi,
  • org.w3c.dom,
  • org.w3c.dom.bootstrap,
  • org.w3c.dom.events,
  • org.w3c.dom.ls,
  • org.w3c.dom.views,
  • org.xml.sax,
  • org.xml.sax.ext,
  • org.xml.sax.helpers

Class Hierarchy

  • java.lang.Object
    • javax.swing.AbstractAction (implements javax.swing.Action, java.lang.Cloneable, java.io.Serializable)
      • javax.swing.plaf.basic.BasicDesktopPaneUI.CloseAction
      • javax.swing.plaf.basic.BasicDesktopPaneUI.MaximizeAction
      • javax.swing.plaf.basic.BasicDesktopPaneUI.MinimizeAction
      • javax.swing.plaf.basic.BasicDesktopPaneUI.NavigateAction
      • javax.swing.plaf.basic.BasicDesktopPaneUI.OpenAction
      • javax.swing.plaf.basic.BasicFileChooserUI.ApproveSelectionAction
      • javax.swing.plaf.basic.BasicFileChooserUI.CancelSelectionAction
      • javax.swing.plaf.basic.BasicFileChooserUI.ChangeToParentDirectoryAction
      • javax.swing.plaf.basic.BasicFileChooserUI.GoHomeAction
      • javax.swing.plaf.basic.BasicFileChooserUI.NewFolderAction
      • javax.swing.plaf.basic.BasicFileChooserUI.UpdateAction
      • javax.swing.plaf.basic.BasicInternalFrameTitlePane.CloseAction
      • javax.swing.plaf.basic.BasicInternalFrameTitlePane.IconifyAction
      • javax.swing.plaf.basic.BasicInternalFrameTitlePane.MaximizeAction
      • javax.swing.plaf.basic.BasicInternalFrameTitlePane.MoveAction
      • javax.swing.plaf.basic.BasicInternalFrameTitlePane.RestoreAction
      • javax.swing.plaf.basic.BasicInternalFrameTitlePane.SizeAction
      • javax.swing.plaf.basic.BasicSliderUI.ActionScroller
      • javax.swing.plaf.basic.BasicTreeUI.TreeCancelEditingAction
      • javax.swing.plaf.basic.BasicTreeUI.TreeHomeAction
      • javax.swing.plaf.basic.BasicTreeUI.TreeIncrementAction
      • javax.swing.plaf.basic.BasicTreeUI.TreePageAction
      • javax.swing.plaf.basic.BasicTreeUI.TreeToggleAction
      • javax.swing.plaf.basic.BasicTreeUI.TreeTraverseAction
      • javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxAction
      • javax.swing.text.TextAction
        • javax.swing.text.DefaultEditorKit.BeepAction
        • javax.swing.text.DefaultEditorKit.CopyAction
        • javax.swing.text.DefaultEditorKit.CutAction
        • javax.swing.text.DefaultEditorKit.DefaultKeyTypedAction
        • javax.swing.text.DefaultEditorKit.InsertBreakAction
        • javax.swing.text.DefaultEditorKit.InsertContentAction
        • javax.swing.text.DefaultEditorKit.InsertTabAction
        • javax.swing.text.DefaultEditorKit.PasteAction
        • javax.swing.text.StyledEditorKit.StyledTextAction
          • javax.swing.text.html.HTMLEditorKit.HTMLTextAction
            • javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction
          • javax.swing.text.StyledEditorKit.AlignmentAction
          • javax.swing.text.StyledEditorKit.BoldAction
          • javax.swing.text.StyledEditorKit.FontFamilyAction
          • javax.swing.text.StyledEditorKit.FontSizeAction
          • javax.swing.text.StyledEditorKit.ForegroundAction
          • javax.swing.text.StyledEditorKit.ItalicAction
          • javax.swing.text.StyledEditorKit.UnderlineAction
    • javax.lang.model.util.AbstractAnnotationValueVisitor6<R,P> (implements javax.lang.model.element.AnnotationValueVisitor<R,P>)
      • javax.lang.model.util.AbstractAnnotationValueVisitor7<R,P>
        • javax.lang.model.util.AbstractAnnotationValueVisitor8<R,P>
      • javax.lang.model.util.SimpleAnnotationValueVisitor6<R,P>
        • javax.lang.model.util.SimpleAnnotationValueVisitor7<R,P>
          • javax.lang.model.util.SimpleAnnotationValueVisitor8<R,P>
    • javax.swing.border.AbstractBorder (implements javax.swing.border.Border, java.io.Serializable)
      • javax.swing.plaf.basic.BasicBorders.ButtonBorder (implements javax.swing.plaf.UIResource)
        • javax.swing.plaf.basic.BasicBorders.RadioButtonBorder
        • javax.swing.plaf.basic.BasicBorders.RolloverButtonBorder
        • javax.swing.plaf.basic.BasicBorders.ToggleButtonBorder
      • javax.swing.plaf.basic.BasicBorders.FieldBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.basic.BasicBorders.MarginBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.basic.BasicBorders.MenuBarBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.border.BevelBorder
        • javax.swing.plaf.BorderUIResource.BevelBorderUIResource (implements javax.swing.plaf.UIResource)
        • javax.swing.border.SoftBevelBorder
      • javax.swing.border.CompoundBorder
        • javax.swing.plaf.BorderUIResource.CompoundBorderUIResource (implements javax.swing.plaf.UIResource)
      • javax.swing.border.EmptyBorder (implements java.io.Serializable)
        • javax.swing.plaf.BorderUIResource.EmptyBorderUIResource (implements javax.swing.plaf.UIResource)
        • javax.swing.border.MatteBorder
          • javax.swing.plaf.BorderUIResource.MatteBorderUIResource (implements javax.swing.plaf.UIResource)
      • javax.swing.border.EtchedBorder
        • javax.swing.plaf.BorderUIResource.EtchedBorderUIResource (implements javax.swing.plaf.UIResource)
      • javax.swing.border.LineBorder
        • javax.swing.plaf.BorderUIResource.LineBorderUIResource (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalBorders.ButtonBorder (implements javax.swing.plaf.UIResource)
        • javax.swing.plaf.metal.MetalBorders.RolloverButtonBorder
        • javax.swing.plaf.metal.MetalBorders.ToggleButtonBorder
      • javax.swing.plaf.metal.MetalBorders.Flush3DBorder (implements javax.swing.plaf.UIResource)
        • javax.swing.plaf.metal.MetalBorders.TextFieldBorder
      • javax.swing.plaf.metal.MetalBorders.InternalFrameBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalBorders.MenuBarBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalBorders.MenuItemBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalBorders.OptionDialogBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalBorders.PaletteBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalBorders.PopupMenuBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalBorders.ScrollPaneBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalBorders.TableHeaderBorder
      • javax.swing.plaf.metal.MetalBorders.ToolBarBorder (implements javax.swing.SwingConstants, javax.swing.plaf.UIResource)
      • javax.swing.border.StrokeBorder
      • javax.swing.border.TitledBorder
        • javax.swing.plaf.BorderUIResource.TitledBorderUIResource (implements javax.swing.plaf.UIResource)
    • javax.swing.AbstractButton.ButtonChangeListener (implements javax.swing.event.ChangeListener, java.io.Serializable)
    • javax.swing.AbstractCellEditor (implements javax.swing.CellEditor, java.io.Serializable)
      • javax.swing.DefaultCellEditor (implements javax.swing.table.TableCellEditor, javax.swing.tree.TreeCellEditor)
    • java.time.chrono.AbstractChronology (implements java.time.chrono.Chronology)
      • java.time.chrono.HijrahChronology (implements java.io.Serializable)
      • java.time.chrono.IsoChronology (implements java.io.Serializable)
      • java.time.chrono.JapaneseChronology (implements java.io.Serializable)
      • java.time.chrono.MinguoChronology (implements java.io.Serializable)
      • java.time.chrono.ThaiBuddhistChronology (implements java.io.Serializable)
    • java.util.AbstractCollection<E> (implements java.util.Collection<E>)
      • java.util.AbstractList<E> (implements java.util.List<E>)
        • java.util.AbstractSequentialList<E>
          • java.util.LinkedList<E> (implements java.lang.Cloneable, java.util.Deque<E>, java.util.List<E>, java.io.Serializable)
        • java.util.ArrayList<E> (implements java.lang.Cloneable, java.util.List<E>, java.util.RandomAccess, java.io.Serializable)
          • javax.management.AttributeList
          • javax.management.relation.RoleList
          • javax.management.relation.RoleUnresolvedList
        • java.util.Vector<E> (implements java.lang.Cloneable, java.util.List<E>, java.util.RandomAccess, java.io.Serializable)
          • java.util.Stack<E>
      • java.util.AbstractQueue<E> (implements java.util.Queue<E>)
        • java.util.concurrent.ArrayBlockingQueue<E> (implements java.util.concurrent.BlockingQueue<E>, java.io.Serializable)
        • java.util.concurrent.ConcurrentLinkedQueue<E> (implements java.util.Queue<E>, java.io.Serializable)
        • java.util.concurrent.DelayQueue<E> (implements java.util.concurrent.BlockingQueue<E>)
        • java.util.concurrent.LinkedBlockingDeque<E> (implements java.util.concurrent.BlockingDeque<E>, java.io.Serializable)
        • java.util.concurrent.LinkedBlockingQueue<E> (implements java.util.concurrent.BlockingQueue<E>, java.io.Serializable)
        • java.util.concurrent.LinkedTransferQueue<E> (implements java.io.Serializable, java.util.concurrent.TransferQueue<E>)
        • java.util.concurrent.PriorityBlockingQueue<E> (implements java.util.concurrent.BlockingQueue<E>, java.io.Serializable)
        • java.util.PriorityQueue<E> (implements java.io.Serializable)
        • java.util.concurrent.SynchronousQueue<E> (implements java.util.concurrent.BlockingQueue<E>, java.io.Serializable)
      • java.util.AbstractSet<E> (implements java.util.Set<E>)
        • java.util.concurrent.ConcurrentSkipListSet<E> (implements java.lang.Cloneable, java.util.NavigableSet<E>, java.io.Serializable)
        • java.util.concurrent.CopyOnWriteArraySet<E> (implements java.io.Serializable)
        • java.util.EnumSet<E> (implements java.lang.Cloneable, java.io.Serializable)
        • java.util.HashSet<E> (implements java.lang.Cloneable, java.io.Serializable, java.util.Set<E>)
          • javax.print.attribute.standard.JobStateReasons (implements javax.print.attribute.PrintJobAttribute)
          • java.util.LinkedHashSet<E> (implements java.lang.Cloneable, java.io.Serializable, java.util.Set<E>)
        • java.util.TreeSet<E> (implements java.lang.Cloneable, java.util.NavigableSet<E>, java.io.Serializable)
      • java.util.ArrayDeque<E> (implements java.lang.Cloneable, java.util.Deque<E>, java.io.Serializable)
      • java.util.concurrent.ConcurrentLinkedDeque<E> (implements java.util.Deque<E>, java.io.Serializable)
    • javax.swing.text.AbstractDocument (implements javax.swing.text.Document, java.io.Serializable)
      • javax.swing.text.DefaultStyledDocument (implements javax.swing.text.StyledDocument)
        • javax.swing.text.html.HTMLDocument
      • javax.swing.text.PlainDocument
    • javax.swing.text.AbstractDocument.AbstractElement (implements javax.swing.text.Element, javax.swing.text.MutableAttributeSet, java.io.Serializable, javax.swing.tree.TreeNode)
      • javax.swing.text.AbstractDocument.BranchElement
        • javax.swing.text.DefaultStyledDocument.SectionElement
        • javax.swing.text.html.HTMLDocument.BlockElement
      • javax.swing.text.AbstractDocument.LeafElement
        • javax.swing.text.html.HTMLDocument.RunElement
    • javax.lang.model.util.AbstractElementVisitor6<R,P> (implements javax.lang.model.element.ElementVisitor<R,P>)
      • javax.lang.model.util.AbstractElementVisitor7<R,P>
        • javax.lang.model.util.AbstractElementVisitor8<R,P>
      • javax.lang.model.util.ElementScanner6<R,P>
        • javax.lang.model.util.ElementScanner7<R,P>
          • javax.lang.model.util.ElementScanner8<R,P>
      • javax.lang.model.util.SimpleElementVisitor6<R,P>
        • javax.lang.model.util.ElementKindVisitor6<R,P>
          • javax.lang.model.util.ElementKindVisitor7<R,P>
            • javax.lang.model.util.ElementKindVisitor8<R,P>
        • javax.lang.model.util.SimpleElementVisitor7<R,P>
          • javax.lang.model.util.SimpleElementVisitor8<R,P>
    • java.util.concurrent.AbstractExecutorService (implements java.util.concurrent.ExecutorService)
      • java.util.concurrent.ForkJoinPool
      • java.util.concurrent.ThreadPoolExecutor
        • java.util.concurrent.ScheduledThreadPoolExecutor (implements java.util.concurrent.ScheduledExecutorService)
    • java.nio.channels.spi.AbstractInterruptibleChannel (implements java.nio.channels.Channel, java.nio.channels.InterruptibleChannel)
      • java.nio.channels.FileChannel (implements java.nio.channels.GatheringByteChannel, java.nio.channels.ScatteringByteChannel, java.nio.channels.SeekableByteChannel)
      • java.nio.channels.SelectableChannel (implements java.nio.channels.Channel)
        • java.nio.channels.spi.AbstractSelectableChannel
          • java.nio.channels.DatagramChannel (implements java.nio.channels.ByteChannel, java.nio.channels.GatheringByteChannel, java.nio.channels.MulticastChannel, java.nio.channels.ScatteringByteChannel)
          • java.nio.channels.Pipe.SinkChannel (implements java.nio.channels.GatheringByteChannel, java.nio.channels.WritableByteChannel)
          • java.nio.channels.Pipe.SourceChannel (implements java.nio.channels.ReadableByteChannel, java.nio.channels.ScatteringByteChannel)
          • java.nio.channels.ServerSocketChannel (implements java.nio.channels.NetworkChannel)
          • java.nio.channels.SocketChannel (implements java.nio.channels.ByteChannel, java.nio.channels.GatheringByteChannel, java.nio.channels.NetworkChannel, java.nio.channels.ScatteringByteChannel)
    • javax.swing.tree.AbstractLayoutCache (implements javax.swing.tree.RowMapper)
      • javax.swing.tree.FixedHeightLayoutCache
      • javax.swing.tree.VariableHeightLayoutCache
    • javax.swing.tree.AbstractLayoutCache.NodeDimensions
      • javax.swing.plaf.basic.BasicTreeUI.NodeDimensionsHandler
    • javax.swing.AbstractListModel<E> (implements javax.swing.ListModel<E>, java.io.Serializable)
      • javax.swing.plaf.basic.BasicDirectoryModel (implements java.beans.PropertyChangeListener)
      • javax.swing.DefaultComboBoxModel<E> (implements javax.swing.MutableComboBoxModel<E>, java.io.Serializable)
      • javax.swing.DefaultListModel<E>
      • javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxModel (implements javax.swing.ComboBoxModel<E>)
      • javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxModel (implements javax.swing.ComboBoxModel<E>, java.beans.PropertyChangeListener)
    • java.util.AbstractMap<K,V> (implements java.util.Map<K,V>)
      • java.util.concurrent.ConcurrentHashMap<K,V> (implements java.util.concurrent.ConcurrentMap<K,V>, java.io.Serializable)
      • java.util.concurrent.ConcurrentSkipListMap<K,V> (implements java.lang.Cloneable, java.util.concurrent.ConcurrentNavigableMap<K,V>, java.io.Serializable)
      • java.util.EnumMap<K,V> (implements java.lang.Cloneable, java.io.Serializable)
      • java.util.HashMap<K,V> (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable)
        • java.util.LinkedHashMap<K,V> (implements java.util.Map<K,V>)
        • javax.print.attribute.standard.PrinterStateReasons (implements javax.print.attribute.PrintServiceAttribute)
      • java.util.IdentityHashMap<K,V> (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable)
      • java.util.TreeMap<K,V> (implements java.lang.Cloneable, java.util.NavigableMap<K,V>, java.io.Serializable)
      • java.util.WeakHashMap<K,V> (implements java.util.Map<K,V>)
    • java.util.AbstractMap.SimpleEntry<K,V> (implements java.util.Map.Entry<K,V>, java.io.Serializable)
    • java.util.AbstractMap.SimpleImmutableEntry<K,V> (implements java.util.Map.Entry<K,V>, java.io.Serializable)
    • javax.xml.bind.helpers.AbstractMarshallerImpl (implements javax.xml.bind.Marshaller)
    • java.util.concurrent.locks.AbstractOwnableSynchronizer (implements java.io.Serializable)
      • java.util.concurrent.locks.AbstractQueuedLongSynchronizer (implements java.io.Serializable)
      • java.util.concurrent.locks.AbstractQueuedSynchronizer (implements java.io.Serializable)
    • javax.annotation.processing.AbstractProcessor (implements javax.annotation.processing.Processor)
    • java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject (implements java.util.concurrent.locks.Condition, java.io.Serializable)
    • java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject (implements java.util.concurrent.locks.Condition, java.io.Serializable)
    • javax.swing.plaf.nimbus.AbstractRegionPainter (implements javax.swing.Painter<T>)
    • javax.swing.plaf.nimbus.AbstractRegionPainter.PaintContext
    • javax.script.AbstractScriptEngine (implements javax.script.ScriptEngine)
    • javax.swing.AbstractSpinnerModel (implements java.io.Serializable, javax.swing.SpinnerModel)
      • javax.swing.SpinnerDateModel (implements java.io.Serializable)
      • javax.swing.SpinnerListModel (implements java.io.Serializable)
      • javax.swing.SpinnerNumberModel (implements java.io.Serializable)
    • javax.swing.table.AbstractTableModel (implements java.io.Serializable, javax.swing.table.TableModel)
      • javax.swing.table.DefaultTableModel (implements java.io.Serializable)
    • javax.lang.model.util.AbstractTypeVisitor6<R,P> (implements javax.lang.model.type.TypeVisitor<R,P>)
      • javax.lang.model.util.AbstractTypeVisitor7<R,P>
        • javax.lang.model.util.AbstractTypeVisitor8<R,P>
      • javax.lang.model.util.SimpleTypeVisitor6<R,P>
        • javax.lang.model.util.SimpleTypeVisitor7<R,P>
          • javax.lang.model.util.SimpleTypeVisitor8<R,P>
        • javax.lang.model.util.TypeKindVisitor6<R,P>
          • javax.lang.model.util.TypeKindVisitor7<R,P>
            • javax.lang.model.util.TypeKindVisitor8<R,P>
    • javax.swing.undo.AbstractUndoableEdit (implements java.io.Serializable, javax.swing.undo.UndoableEdit)
      • javax.swing.text.AbstractDocument.ElementEdit (implements javax.swing.event.DocumentEvent.ElementChange)
      • javax.swing.undo.CompoundEdit
        • javax.swing.text.AbstractDocument.DefaultDocumentEvent (implements javax.swing.event.DocumentEvent)
        • javax.swing.undo.UndoManager (implements javax.swing.event.UndoableEditListener)
      • javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit
      • javax.swing.undo.StateEdit
    • javax.xml.bind.helpers.AbstractUnmarshallerImpl (implements javax.xml.bind.Unmarshaller)
    • javax.swing.text.AbstractWriter
      • javax.swing.text.html.HTMLWriter
      • javax.swing.text.html.MinimalHTMLWriter
    • java.security.AccessControlContext
    • java.security.AccessController
    • javax.accessibility.AccessibleAttributeSequence
    • javax.accessibility.AccessibleBundle
      • javax.accessibility.AccessibleRelation
      • javax.accessibility.AccessibleRole
      • javax.accessibility.AccessibleState
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent (implements javax.accessibility.AccessibleComponent, java.io.Serializable)
        • javax.swing.Box.Filler.AccessibleBoxFiller
        • java.awt.Button.AccessibleAWTButton (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleValue)
        • java.awt.Canvas.AccessibleAWTCanvas
        • java.awt.Checkbox.AccessibleAWTCheckbox (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleValue, java.awt.event.ItemListener)
        • java.awt.Choice.AccessibleAWTChoice (implements javax.accessibility.AccessibleAction)
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.Box.AccessibleBox
          • javax.swing.CellRendererPane.AccessibleCellRendererPane
          • javax.swing.JComponent.AccessibleJComponent (implements javax.accessibility.AccessibleExtendedComponent)
            • javax.swing.AbstractButton.AccessibleAbstractButton (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleExtendedComponent, javax.accessibility.AccessibleText, javax.accessibility.AccessibleValue)
              • javax.swing.JButton.AccessibleJButton
              • javax.swing.JMenuItem.AccessibleJMenuItem (implements javax.swing.event.ChangeListener)
                • javax.swing.JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem
                • javax.swing.JMenu.AccessibleJMenu (implements javax.accessibility.AccessibleSelection)
                • javax.swing.JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem
              • javax.swing.JToggleButton.AccessibleJToggleButton (implements java.awt.event.ItemListener)
                • javax.swing.JCheckBox.AccessibleJCheckBox
                • javax.swing.JRadioButton.AccessibleJRadioButton
            • javax.swing.JColorChooser.AccessibleJColorChooser
            • javax.swing.JComboBox.AccessibleJComboBox (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleSelection)
            • javax.swing.JDesktopPane.AccessibleJDesktopPane
            • javax.swing.JFileChooser.AccessibleJFileChooser
            • javax.swing.JInternalFrame.AccessibleJInternalFrame (implements javax.accessibility.AccessibleValue)
            • javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon (implements javax.accessibility.AccessibleValue)
            • javax.swing.JLabel.AccessibleJLabel (implements javax.accessibility.AccessibleExtendedComponent, javax.accessibility.AccessibleText)
            • javax.swing.JLayeredPane.AccessibleJLayeredPane
            • javax.swing.JList.AccessibleJList (implements javax.accessibility.AccessibleSelection, javax.swing.event.ListDataListener, javax.swing.event.ListSelectionListener, java.beans.PropertyChangeListener)
            • javax.swing.JMenuBar.AccessibleJMenuBar (implements javax.accessibility.AccessibleSelection)
            • javax.swing.JOptionPane.AccessibleJOptionPane
            • javax.swing.JPanel.AccessibleJPanel
            • javax.swing.JPopupMenu.AccessibleJPopupMenu (implements java.beans.PropertyChangeListener)
            • javax.swing.JProgressBar.AccessibleJProgressBar (implements javax.accessibility.AccessibleValue)
            • javax.swing.JRootPane.AccessibleJRootPane
            • javax.swing.JScrollBar.AccessibleJScrollBar (implements javax.accessibility.AccessibleValue)
            • javax.swing.JScrollPane.AccessibleJScrollPane (implements javax.swing.event.ChangeListener, java.beans.PropertyChangeListener)
            • javax.swing.JSeparator.AccessibleJSeparator
            • javax.swing.JSlider.AccessibleJSlider (implements javax.accessibility.AccessibleValue)
            • javax.swing.JSpinner.AccessibleJSpinner (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleEditableText, javax.accessibility.AccessibleText, javax.accessibility.AccessibleValue, javax.swing.event.ChangeListener)
            • javax.swing.JSplitPane.AccessibleJSplitPane (implements javax.accessibility.AccessibleValue)
            • javax.swing.JTabbedPane.AccessibleJTabbedPane (implements javax.accessibility.AccessibleSelection, javax.swing.event.ChangeListener)
            • javax.swing.JTable.AccessibleJTable (implements javax.accessibility.AccessibleExtendedTable, javax.accessibility.AccessibleSelection, javax.swing.event.CellEditorListener, javax.swing.event.ListSelectionListener, java.beans.PropertyChangeListener, javax.swing.event.TableColumnModelListener, javax.swing.event.TableModelListener)
            • javax.swing.table.JTableHeader.AccessibleJTableHeader
            • javax.swing.text.JTextComponent.AccessibleJTextComponent (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleEditableText, javax.accessibility.AccessibleExtendedText, javax.accessibility.AccessibleText, javax.swing.event.CaretListener, javax.swing.event.DocumentListener)
              • javax.swing.JEditorPane.AccessibleJEditorPane
                • javax.swing.JEditorPane.AccessibleJEditorPaneHTML
                • javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport (implements javax.accessibility.AccessibleHypertext)
              • javax.swing.JTextArea.AccessibleJTextArea
              • javax.swing.JTextField.AccessibleJTextField
                • javax.swing.JPasswordField.AccessibleJPasswordField
            • javax.swing.JToolBar.AccessibleJToolBar
            • javax.swing.JToolTip.AccessibleJToolTip
            • javax.swing.JTree.AccessibleJTree (implements javax.accessibility.AccessibleSelection, javax.swing.event.TreeExpansionListener, javax.swing.event.TreeModelListener, javax.swing.event.TreeSelectionListener)
            • javax.swing.JViewport.AccessibleJViewport
          • java.awt.Panel.AccessibleAWTPanel
            • java.applet.Applet.AccessibleApplet
              • javax.swing.JApplet.AccessibleJApplet
          • java.awt.ScrollPane.AccessibleAWTScrollPane
          • java.awt.Window.AccessibleAWTWindow
            • java.awt.Dialog.AccessibleAWTDialog
              • javax.swing.JDialog.AccessibleJDialog
            • java.awt.Frame.AccessibleAWTFrame
              • javax.swing.JFrame.AccessibleJFrame
            • javax.swing.JWindow.AccessibleJWindow
        • java.awt.Label.AccessibleAWTLabel
        • java.awt.List.AccessibleAWTList (implements javax.accessibility.AccessibleSelection, java.awt.event.ActionListener, java.awt.event.ItemListener)
        • java.awt.List.AccessibleAWTList.AccessibleAWTListChild (implements javax.accessibility.Accessible)
        • java.awt.Scrollbar.AccessibleAWTScrollBar (implements javax.accessibility.AccessibleValue)
        • java.awt.TextComponent.AccessibleAWTTextComponent (implements javax.accessibility.AccessibleText, java.awt.event.TextListener)
          • java.awt.TextArea.AccessibleAWTTextArea
          • java.awt.TextField.AccessibleAWTTextField
      • javax.swing.ImageIcon.AccessibleImageIcon (implements javax.accessibility.AccessibleIcon, java.io.Serializable)
      • javax.swing.JList.AccessibleJList.AccessibleJListChild (implements javax.accessibility.Accessible, javax.accessibility.AccessibleComponent)
      • javax.swing.JTable.AccessibleJTable.AccessibleJTableCell (implements javax.accessibility.Accessible, javax.accessibility.AccessibleComponent)
      • javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry (implements javax.accessibility.Accessible, javax.accessibility.AccessibleComponent)
      • javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode (implements javax.accessibility.Accessible, javax.accessibility.AccessibleAction, javax.accessibility.AccessibleComponent, javax.accessibility.AccessibleSelection)
      • java.awt.MenuComponent.AccessibleAWTMenuComponent (implements javax.accessibility.AccessibleComponent, javax.accessibility.AccessibleSelection, java.io.Serializable)
        • java.awt.MenuBar.AccessibleAWTMenuBar
        • java.awt.MenuItem.AccessibleAWTMenuItem (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleValue)
          • java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleValue)
          • java.awt.Menu.AccessibleAWTMenu
            • java.awt.PopupMenu.AccessibleAWTPopupMenu
      • javax.swing.ProgressMonitor.AccessibleProgressMonitor (implements javax.accessibility.AccessibleText, javax.swing.event.ChangeListener, java.beans.PropertyChangeListener)
    • javax.accessibility.AccessibleHyperlink (implements javax.accessibility.AccessibleAction)
      • javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink
    • java.lang.reflect.AccessibleObject (implements java.lang.reflect.AnnotatedElement)
      • java.lang.reflect.Executable (implements java.lang.reflect.GenericDeclaration, java.lang.reflect.Member)
        • java.lang.reflect.Constructor<T>
        • java.lang.reflect.Method
      • java.lang.reflect.Field (implements java.lang.reflect.Member)
    • javax.accessibility.AccessibleRelationSet
    • javax.accessibility.AccessibleStateSet
    • javax.accessibility.AccessibleTextSequence
    • java.nio.file.attribute.AclEntry
    • java.nio.file.attribute.AclEntry.Builder
    • javax.swing.ActionMap (implements java.io.Serializable)
      • javax.swing.plaf.ActionMapUIResource (implements javax.swing.plaf.UIResource)
    • java.rmi.activation.ActivationDesc (implements java.io.Serializable)
    • java.rmi.activation.ActivationGroupDesc (implements java.io.Serializable)
    • java.rmi.activation.ActivationGroupDesc.CommandEnvironment (implements java.io.Serializable)
    • java.rmi.activation.ActivationGroupID (implements java.io.Serializable)
    • java.rmi.activation.ActivationID (implements java.io.Serializable)
    • org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper
    • org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper
    • org.omg.PortableInterceptor.AdapterManagerIdHelper
    • org.omg.PortableInterceptor.AdapterNameHelper
    • org.omg.PortableServer.POAPackage.AdapterNonExistentHelper
    • org.omg.PortableInterceptor.AdapterStateHelper
    • org.omg.CosNaming.NamingContextExtPackage.AddressHelper
    • java.util.zip.Adler32 (implements java.util.zip.Checksum)
    • java.awt.geom.AffineTransform (implements java.lang.Cloneable, java.io.Serializable)
    • java.awt.image.AffineTransformOp (implements java.awt.image.BufferedImageOp, java.awt.image.RasterOp)
    • java.security.AlgorithmParameterGenerator
    • java.security.AlgorithmParameterGeneratorSpi
    • java.security.AlgorithmParameters
    • java.security.AlgorithmParametersSpi
    • java.awt.AlphaComposite (implements java.awt.Composite)
    • org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper
    • org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder (implements org.omg.CORBA.portable.Streamable)
    • java.text.Annotation
    • org.omg.CORBA.Any (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.AnyHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.AnySeqHelper
    • org.omg.DynamicAny.AnySeqHelper
    • org.omg.CORBA.AnySeqHolder (implements org.omg.CORBA.portable.Streamable)
    • javax.security.auth.login.AppConfigurationEntry
    • javax.security.auth.login.AppConfigurationEntry.LoginModuleControlFlag
    • java.awt.geom.Area (implements java.lang.Cloneable, java.awt.Shape)
    • java.lang.reflect.Array
    • java.util.Arrays
    • javax.swing.text.AsyncBoxView.ChildLocator
    • javax.swing.text.AsyncBoxView.ChildState (implements java.lang.Runnable)
    • java.nio.channels.AsynchronousChannelGroup
    • java.nio.channels.spi.AsynchronousChannelProvider
    • java.nio.channels.AsynchronousFileChannel (implements java.nio.channels.AsynchronousChannel)
    • java.nio.channels.AsynchronousServerSocketChannel (implements java.nio.channels.AsynchronousChannel, java.nio.channels.NetworkChannel)
    • java.nio.channels.AsynchronousSocketChannel (implements java.nio.channels.AsynchronousByteChannel, java.nio.channels.NetworkChannel)
    • java.util.concurrent.atomic.AtomicBoolean (implements java.io.Serializable)
    • java.util.concurrent.atomic.AtomicIntegerArray (implements java.io.Serializable)
    • java.util.concurrent.atomic.AtomicIntegerFieldUpdater<T>
    • java.util.concurrent.atomic.AtomicLongArray (implements java.io.Serializable)
    • java.util.concurrent.atomic.AtomicLongFieldUpdater<T>
    • java.util.concurrent.atomic.AtomicMarkableReference<V>
    • java.util.concurrent.atomic.AtomicReference<V> (implements java.io.Serializable)
    • java.util.concurrent.atomic.AtomicReferenceArray<E> (implements java.io.Serializable)
    • java.util.concurrent.atomic.AtomicReferenceFieldUpdater<T,V>
    • java.util.concurrent.atomic.AtomicStampedReference<V>
    • javax.xml.bind.attachment.AttachmentMarshaller
    • javax.xml.soap.AttachmentPart
    • javax.xml.bind.attachment.AttachmentUnmarshaller
    • javax.management.Attribute (implements java.io.Serializable)
    • javax.management.AttributeChangeNotificationFilter (implements javax.management.NotificationFilter)
    • java.text.AttributedCharacterIterator.Attribute (implements java.io.Serializable)
      • java.text.Format.Field
        • java.text.DateFormat.Field
        • java.text.MessageFormat.Field
        • java.text.NumberFormat.Field
      • java.awt.font.TextAttribute
    • java.text.AttributedString
    • javax.swing.text.html.parser.AttributeList (implements javax.swing.text.html.parser.DTDConstants, java.io.Serializable)
    • org.xml.sax.helpers.AttributeListImpl (implements org.xml.sax.AttributeList)
    • java.util.jar.Attributes (implements java.lang.Cloneable, java.util.Map<K,V>)
    • java.util.jar.Attributes.Name
    • javax.print.attribute.AttributeSetUtilities
    • org.xml.sax.helpers.AttributesImpl (implements org.xml.sax.Attributes)
      • org.xml.sax.ext.Attributes2Impl (implements org.xml.sax.ext.Attributes2)
    • javax.management.AttributeValueExp (implements javax.management.ValueExp)
    • javax.sound.sampled.AudioFileFormat
    • javax.sound.sampled.AudioFileFormat.Type
    • javax.sound.sampled.spi.AudioFileReader
    • javax.sound.sampled.spi.AudioFileWriter
    • javax.sound.sampled.AudioFormat
    • javax.sound.sampled.AudioFormat.Encoding
    • javax.sound.sampled.AudioSystem
    • java.net.Authenticator
    • javax.security.sasl.AuthorizeCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
    • java.awt.AWTEventMulticaster (implements java.awt.event.ActionListener, java.awt.event.AdjustmentListener, java.awt.event.ComponentListener, java.awt.event.ContainerListener, java.awt.event.FocusListener, java.awt.event.HierarchyBoundsListener, java.awt.event.HierarchyListener, java.awt.event.InputMethodListener, java.awt.event.ItemListener, java.awt.event.KeyListener, java.awt.event.MouseListener, java.awt.event.MouseMotionListener, java.awt.event.MouseWheelListener, java.awt.event.TextListener, java.awt.event.WindowFocusListener, java.awt.event.WindowListener, java.awt.event.WindowStateListener)
    • java.awt.AWTKeyStroke (implements java.io.Serializable)
      • javax.swing.KeyStroke
    • java.awt.image.BandCombineOp (implements java.awt.image.RasterOp)
    • java.util.Base64
    • java.util.Base64.Decoder
    • java.util.Base64.Encoder
    • javax.sql.rowset.BaseRowSet (implements java.lang.Cloneable, java.io.Serializable)
    • javax.naming.directory.BasicAttribute (implements javax.naming.directory.Attribute)
    • javax.naming.directory.BasicAttributes (implements javax.naming.directory.Attributes)
    • javax.swing.plaf.basic.BasicBorders
    • javax.swing.plaf.basic.BasicBorders.SplitPaneBorder (implements javax.swing.border.Border, javax.swing.plaf.UIResource)
    • javax.swing.plaf.basic.BasicButtonListener (implements javax.swing.event.ChangeListener, java.awt.event.FocusListener, java.awt.event.MouseListener, java.awt.event.MouseMotionListener, java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicColorChooserUI.PropertyHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicComboBoxEditor (implements javax.swing.ComboBoxEditor, java.awt.event.FocusListener)
      • javax.swing.plaf.basic.BasicComboBoxEditor.UIResource (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalComboBoxEditor
        • javax.swing.plaf.metal.MetalComboBoxEditor.UIResource (implements javax.swing.plaf.UIResource)
    • javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager (implements java.awt.LayoutManager)
      • javax.swing.plaf.metal.MetalComboBoxUI.MetalComboBoxLayoutManager
    • javax.swing.plaf.basic.BasicComboBoxUI.FocusHandler (implements java.awt.event.FocusListener)
    • javax.swing.plaf.basic.BasicComboBoxUI.ItemHandler (implements java.awt.event.ItemListener)
    • javax.swing.plaf.basic.BasicComboBoxUI.ListDataHandler (implements javax.swing.event.ListDataListener)
    • javax.swing.plaf.basic.BasicComboBoxUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
      • javax.swing.plaf.metal.MetalComboBoxUI.MetalPropertyChangeListener
    • javax.swing.plaf.basic.BasicComboPopup.ItemHandler (implements java.awt.event.ItemListener)
    • javax.swing.plaf.basic.BasicComboPopup.ListDataHandler (implements javax.swing.event.ListDataListener)
    • javax.swing.plaf.basic.BasicComboPopup.ListSelectionHandler (implements javax.swing.event.ListSelectionListener)
    • javax.swing.plaf.basic.BasicComboPopup.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.naming.ldap.BasicControl (implements javax.naming.ldap.Control)
      • javax.naming.ldap.ManageReferralControl
      • javax.naming.ldap.PagedResultsControl
      • javax.naming.ldap.PagedResultsResponseControl
      • javax.naming.ldap.SortControl
      • javax.naming.ldap.SortResponseControl
    • javax.swing.plaf.basic.BasicFileChooserUI.SelectionListener (implements javax.swing.event.ListSelectionListener)
    • javax.swing.plaf.basic.BasicGraphicsUtils
    • javax.swing.plaf.basic.BasicHTML
    • javax.swing.plaf.basic.BasicIconFactory (implements java.io.Serializable)
    • javax.swing.plaf.basic.BasicInternalFrameTitlePane.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicInternalFrameTitlePane.TitlePaneLayout (implements java.awt.LayoutManager)
    • javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener (implements javax.swing.event.InternalFrameListener)
    • javax.swing.plaf.basic.BasicInternalFrameUI.ComponentHandler (implements java.awt.event.ComponentListener)
    • javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher (implements javax.swing.event.MouseInputListener)
    • javax.swing.plaf.basic.BasicInternalFrameUI.InternalFrameLayout (implements java.awt.LayoutManager)
    • javax.swing.plaf.basic.BasicInternalFrameUI.InternalFramePropertyChangeListener (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicListUI.FocusHandler (implements java.awt.event.FocusListener)
    • javax.swing.plaf.basic.BasicListUI.ListDataHandler (implements javax.swing.event.ListDataListener)
    • javax.swing.plaf.basic.BasicListUI.ListSelectionHandler (implements javax.swing.event.ListSelectionListener)
    • javax.swing.plaf.basic.BasicListUI.MouseInputHandler (implements javax.swing.event.MouseInputListener)
    • javax.swing.plaf.basic.BasicListUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler (implements javax.swing.event.MouseInputListener)
    • javax.swing.plaf.basic.BasicMenuUI.ChangeHandler (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler (implements javax.swing.event.MouseInputListener)
    • javax.swing.plaf.basic.BasicOptionPaneUI.ButtonActionListener (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout (implements java.awt.LayoutManager)
    • javax.swing.plaf.basic.BasicOptionPaneUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicProgressBarUI.ChangeHandler (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicScrollBarUI.ModelListener (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicScrollBarUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicScrollBarUI.ScrollListener (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicScrollPaneUI.HSBChangeListener (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicScrollPaneUI.MouseWheelHandler (implements java.awt.event.MouseWheelListener)
    • javax.swing.plaf.basic.BasicScrollPaneUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicScrollPaneUI.ViewportChangeHandler (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicScrollPaneUI.VSBChangeListener (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicSliderUI.ChangeHandler (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicSliderUI.FocusHandler (implements java.awt.event.FocusListener)
    • javax.swing.plaf.basic.BasicSliderUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
      • javax.swing.plaf.metal.MetalSliderUI.MetalPropertyListener
    • javax.swing.plaf.basic.BasicSliderUI.ScrollListener (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicSplitPaneDivider.DividerLayout (implements java.awt.LayoutManager)
    • javax.swing.plaf.basic.BasicSplitPaneDivider.DragController
      • javax.swing.plaf.basic.BasicSplitPaneDivider.VerticalDragController
    • javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager (implements java.awt.LayoutManager2)
      • javax.swing.plaf.basic.BasicSplitPaneUI.BasicVerticalLayoutManager
    • javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardDownRightHandler (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardEndHandler (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardHomeHandler (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardResizeToggleHandler (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardUpLeftHandler (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicSplitPaneUI.PropertyHandler (implements java.beans.PropertyChangeListener)
    • java.awt.BasicStroke (implements java.awt.Stroke)
    • javax.swing.plaf.basic.BasicTabbedPaneUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout (implements java.awt.LayoutManager)
      • javax.swing.plaf.metal.MetalTabbedPaneUI.TabbedPaneLayout
    • javax.swing.plaf.basic.BasicTabbedPaneUI.TabSelectionHandler (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler (implements javax.swing.event.MouseInputListener)
    • javax.swing.plaf.basic.BasicTableUI.FocusHandler (implements java.awt.event.FocusListener)
    • javax.swing.plaf.basic.BasicTableUI.KeyHandler (implements java.awt.event.KeyListener)
    • javax.swing.plaf.basic.BasicTableUI.MouseInputHandler (implements javax.swing.event.MouseInputListener)
    • javax.swing.plaf.basic.BasicToolBarUI.DockingListener (implements javax.swing.event.MouseInputListener)
      • javax.swing.plaf.metal.MetalToolBarUI.MetalDockingListener
    • javax.swing.plaf.basic.BasicToolBarUI.PropertyListener (implements java.beans.PropertyChangeListener)
      • javax.swing.plaf.metal.MetalToolBarUI.MetalRolloverListener
    • javax.swing.plaf.basic.BasicToolBarUI.ToolBarContListener (implements java.awt.event.ContainerListener)
      • javax.swing.plaf.metal.MetalToolBarUI.MetalContainerListener
    • javax.swing.plaf.basic.BasicToolBarUI.ToolBarFocusListener (implements java.awt.event.FocusListener)
    • javax.swing.plaf.basic.BasicTreeUI.CellEditorHandler (implements javax.swing.event.CellEditorListener)
    • javax.swing.plaf.basic.BasicTreeUI.FocusHandler (implements java.awt.event.FocusListener)
    • javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler (implements javax.swing.event.MouseInputListener)
    • javax.swing.plaf.basic.BasicTreeUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicTreeUI.SelectionModelPropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicTreeUI.TreeExpansionHandler (implements javax.swing.event.TreeExpansionListener)
    • javax.swing.plaf.basic.BasicTreeUI.TreeModelHandler (implements javax.swing.event.TreeModelListener)
    • javax.swing.plaf.basic.BasicTreeUI.TreeSelectionHandler (implements javax.swing.event.TreeSelectionListener)
    • java.beans.beancontext.BeanContextChildSupport (implements java.beans.beancontext.BeanContextChild, java.beans.beancontext.BeanContextServicesListener, java.io.Serializable)
      • java.beans.beancontext.BeanContextSupport (implements java.beans.beancontext.BeanContext, java.beans.PropertyChangeListener, java.io.Serializable, java.beans.VetoableChangeListener)
        • java.beans.beancontext.BeanContextServicesSupport (implements java.beans.beancontext.BeanContextServices)
    • java.beans.beancontext.BeanContextServicesSupport.BCSSProxyServiceProvider (implements java.beans.beancontext.BeanContextServiceProvider, java.beans.beancontext.BeanContextServiceRevokedListener)
    • java.beans.beancontext.BeanContextServicesSupport.BCSSServiceProvider (implements java.io.Serializable)
    • java.beans.beancontext.BeanContextSupport.BCSChild (implements java.io.Serializable)
      • java.beans.beancontext.BeanContextServicesSupport.BCSSChild
    • java.beans.beancontext.BeanContextSupport.BCSIterator (implements java.util.Iterator<E>)
    • java.beans.Beans
    • java.text.Bidi
    • javax.xml.bind.Binder<XmlNode>
    • org.omg.CosNaming.Binding (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CosNaming.BindingHelper
    • org.omg.CosNaming.BindingHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.BindingIteratorHelper
    • org.omg.CosNaming.BindingIteratorHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.BindingListHelper
    • org.omg.CosNaming.BindingListHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.BindingType (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CosNaming.BindingTypeHelper
    • org.omg.CosNaming.BindingTypeHolder (implements org.omg.CORBA.portable.Streamable)
    • java.util.BitSet (implements java.lang.Cloneable, java.io.Serializable)
    • java.awt.print.Book (implements java.awt.print.Pageable)
    • java.lang.Boolean (implements java.lang.Comparable<T>, java.io.Serializable)
    • org.omg.CORBA.BooleanHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.BooleanSeqHelper
    • org.omg.CORBA.BooleanSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • javax.swing.BorderFactory
    • java.awt.BorderLayout (implements java.awt.LayoutManager2, java.io.Serializable)
    • javax.swing.plaf.BorderUIResource (implements javax.swing.border.Border, java.io.Serializable, javax.swing.plaf.UIResource)
    • javax.swing.BoxLayout (implements java.awt.LayoutManager2, java.io.Serializable)
      • javax.swing.plaf.basic.DefaultMenuLayout (implements javax.swing.plaf.UIResource)
    • java.text.BreakIterator (implements java.lang.Cloneable)
    • java.nio.Buffer
      • java.nio.ByteBuffer (implements java.lang.Comparable<T>)
        • java.nio.MappedByteBuffer
      • java.nio.CharBuffer (implements java.lang.Appendable, java.lang.CharSequence, java.lang.Comparable<T>, java.lang.Readable)
      • java.nio.DoubleBuffer (implements java.lang.Comparable<T>)
      • java.nio.FloatBuffer (implements java.lang.Comparable<T>)
      • java.nio.IntBuffer (implements java.lang.Comparable<T>)
      • java.nio.LongBuffer (implements java.lang.Comparable<T>)
      • java.nio.ShortBuffer (implements java.lang.Comparable<T>)
    • java.awt.BufferCapabilities (implements java.lang.Cloneable)
    • java.awt.BufferCapabilities.FlipContents
    • java.awt.image.BufferStrategy
      • java.awt.Component.BltBufferStrategy
      • java.awt.Component.FlipBufferStrategy
    • javax.swing.ButtonGroup (implements java.io.Serializable)
    • org.omg.CORBA.ByteHolder (implements org.omg.CORBA.portable.Streamable)
    • java.nio.ByteOrder
    • java.net.CacheRequest
    • java.net.CacheResponse
      • java.net.SecureCacheResponse
    • java.util.Calendar (implements java.lang.Cloneable, java.lang.Comparable<T>, java.io.Serializable)
      • java.util.GregorianCalendar
    • java.util.Calendar.Builder
    • java.lang.invoke.CallSite
      • java.lang.invoke.ConstantCallSite
      • java.lang.invoke.MutableCallSite
      • java.lang.invoke.VolatileCallSite
    • org.omg.CosNaming.NamingContextPackage.CannotProceedHelper
    • org.omg.CosNaming.NamingContextPackage.CannotProceedHolder (implements org.omg.CORBA.portable.Streamable)
    • java.awt.CardLayout (implements java.awt.LayoutManager2, java.io.Serializable)
    • java.security.cert.Certificate (implements java.io.Serializable)
      • java.security.cert.X509Certificate (implements java.security.cert.X509Extension)
    • javax.security.cert.Certificate
      • javax.security.cert.X509Certificate
    • java.security.cert.Certificate.CertificateRep (implements java.io.Serializable)
    • java.security.cert.CertificateFactory
    • java.security.cert.CertificateFactorySpi
    • java.security.cert.CertPath (implements java.io.Serializable)
    • java.security.cert.CertPath.CertPathRep (implements java.io.Serializable)
    • java.security.cert.CertPathBuilder
    • java.security.cert.CertPathBuilderSpi
    • javax.net.ssl.CertPathTrustManagerParameters (implements javax.net.ssl.ManagerFactoryParameters)
    • java.security.cert.CertPathValidator
    • java.security.cert.CertPathValidatorSpi
    • java.security.cert.CertStore
    • java.security.cert.CertStoreSpi
    • org.ietf.jgss.ChannelBinding
    • java.nio.channels.Channels
    • java.lang.Character (implements java.lang.Comparable<T>, java.io.Serializable)
    • java.lang.Character.Subset
      • java.lang.Character.UnicodeBlock
      • java.awt.im.InputSubset
    • org.omg.CORBA.CharHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.CharSeqHelper
    • org.omg.CORBA.CharSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • java.nio.charset.Charset (implements java.lang.Comparable<T>)
    • java.nio.charset.CharsetDecoder
    • java.nio.charset.CharsetEncoder
    • java.nio.charset.spi.CharsetProvider
    • java.awt.CheckboxGroup (implements java.io.Serializable)
    • javax.security.auth.callback.ChoiceCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
      • javax.security.sasl.RealmChoiceCallback
    • javax.crypto.Cipher
      • javax.crypto.NullCipher
    • javax.crypto.CipherSpi
    • java.lang.Class<T> (implements java.lang.reflect.AnnotatedElement, java.lang.reflect.GenericDeclaration, java.io.Serializable, java.lang.reflect.Type)
    • java.lang.instrument.ClassDefinition
    • javax.rmi.CORBA.ClassDesc (implements java.io.Serializable)
    • java.lang.ClassLoader
      • java.security.SecureClassLoader
        • java.net.URLClassLoader (implements java.io.Closeable)
          • javax.management.loading.MLet (implements java.io.Externalizable, javax.management.MBeanRegistration, javax.management.loading.MLetMBean)
            • javax.management.loading.PrivateMLet (implements javax.management.loading.PrivateClassLoader)
    • java.lang.ClassValue<T>
    • java.awt.datatransfer.Clipboard
    • java.time.Clock
    • org.omg.IOP.CodecFactoryHelper
    • java.nio.charset.CoderResult
    • java.security.CodeSigner (implements java.io.Serializable)
    • java.security.CodeSource (implements java.io.Serializable)
    • java.nio.charset.CodingErrorAction
    • java.text.CollationElementIterator
    • java.text.CollationKey (implements java.lang.Comparable<T>)
    • java.text.Collator (implements java.lang.Cloneable, java.util.Comparator<T>)
      • java.text.RuleBasedCollator
    • java.security.cert.CollectionCertStoreParameters (implements java.security.cert.CertStoreParameters)
    • java.util.Collections
    • java.util.stream.Collectors
    • java.awt.Color (implements java.awt.Paint, java.io.Serializable)
      • javax.swing.plaf.ColorUIResource (implements javax.swing.plaf.UIResource)
      • java.awt.SystemColor (implements java.io.Serializable)
    • javax.swing.colorchooser.ColorChooserComponentFactory
    • java.awt.image.ColorConvertOp (implements java.awt.image.BufferedImageOp, java.awt.image.RasterOp)
    • java.awt.image.ColorModel (implements java.awt.Transparency)
      • java.awt.image.ComponentColorModel
      • java.awt.image.IndexColorModel
      • java.awt.image.PackedColorModel
        • java.awt.image.DirectColorModel
    • java.awt.color.ColorSpace (implements java.io.Serializable)
      • java.awt.color.ICC_ColorSpace
    • javax.swing.plaf.synth.ColorType
    • javax.activation.CommandInfo
    • javax.activation.CommandMap
      • javax.activation.MailcapCommandMap
    • javax.script.CompiledScript
    • java.lang.Compiler
    • java.util.concurrent.CompletableFuture<T> (implements java.util.concurrent.CompletionStage<T>, java.util.concurrent.Future<V>)
    • javax.annotation.processing.Completions
    • org.omg.CORBA.CompletionStatus (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.CompletionStatusHelper
    • java.awt.Component (implements java.awt.image.ImageObserver, java.awt.MenuContainer, java.io.Serializable)
      • java.awt.Button (implements javax.accessibility.Accessible)
      • java.awt.Canvas (implements javax.accessibility.Accessible)
      • java.awt.Checkbox (implements javax.accessibility.Accessible, java.awt.ItemSelectable)
      • java.awt.Choice (implements javax.accessibility.Accessible, java.awt.ItemSelectable)
      • java.awt.Container
        • javax.swing.plaf.basic.BasicSplitPaneDivider (implements java.beans.PropertyChangeListener)
        • javax.swing.CellRendererPane (implements javax.accessibility.Accessible)
        • javax.swing.tree.DefaultTreeCellEditor.EditorContainer
        • javax.swing.JComponent (implements java.io.Serializable)
          • javax.swing.AbstractButton (implements java.awt.ItemSelectable, javax.swing.SwingConstants)
            • javax.swing.JButton (implements javax.accessibility.Accessible)
              • javax.swing.plaf.basic.BasicArrowButton (implements javax.swing.SwingConstants)
                • javax.swing.plaf.metal.MetalScrollButton
              • javax.swing.plaf.metal.MetalComboBoxButton
            • javax.swing.JMenuItem (implements javax.accessibility.Accessible, javax.swing.MenuElement)
              • javax.swing.JCheckBoxMenuItem (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
              • javax.swing.JMenu (implements javax.accessibility.Accessible, javax.swing.MenuElement)
              • javax.swing.JRadioButtonMenuItem (implements javax.accessibility.Accessible)
            • javax.swing.JToggleButton (implements javax.accessibility.Accessible)
              • javax.swing.JCheckBox (implements javax.accessibility.Accessible)
              • javax.swing.JRadioButton (implements javax.accessibility.Accessible)
          • javax.swing.plaf.basic.BasicInternalFrameTitlePane
            • javax.swing.plaf.metal.MetalInternalFrameTitlePane
          • javax.swing.Box (implements javax.accessibility.Accessible)
          • javax.swing.Box.Filler (implements javax.accessibility.Accessible)
          • javax.swing.JColorChooser (implements javax.accessibility.Accessible)
          • javax.swing.JComboBox<E> (implements javax.accessibility.Accessible, java.awt.event.ActionListener, java.awt.ItemSelectable, javax.swing.event.ListDataListener)
          • javax.swing.JFileChooser (implements javax.accessibility.Accessible)
          • javax.swing.JInternalFrame (implements javax.accessibility.Accessible, javax.swing.RootPaneContainer, javax.swing.WindowConstants)
          • javax.swing.JInternalFrame.JDesktopIcon (implements javax.accessibility.Accessible)
          • javax.swing.JLabel (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
            • javax.swing.plaf.basic.BasicComboBoxRenderer (implements javax.swing.ListCellRenderer<E>, java.io.Serializable)
              • javax.swing.plaf.basic.BasicComboBoxRenderer.UIResource (implements javax.swing.plaf.UIResource)
            • javax.swing.DefaultListCellRenderer (implements javax.swing.ListCellRenderer<E>, java.io.Serializable)
              • javax.swing.DefaultListCellRenderer.UIResource (implements javax.swing.plaf.UIResource)
              • javax.swing.plaf.metal.MetalFileChooserUI.FileRenderer
              • javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxRenderer
            • javax.swing.table.DefaultTableCellRenderer (implements java.io.Serializable, javax.swing.table.TableCellRenderer)
              • javax.swing.table.DefaultTableCellRenderer.UIResource (implements javax.swing.plaf.UIResource)
            • javax.swing.tree.DefaultTreeCellRenderer (implements javax.swing.tree.TreeCellRenderer)
          • javax.swing.JLayer<V> (implements javax.accessibility.Accessible, java.beans.PropertyChangeListener, javax.swing.Scrollable)
          • javax.swing.JLayeredPane (implements javax.accessibility.Accessible)
            • javax.swing.JDesktopPane (implements javax.accessibility.Accessible)
          • javax.swing.JList<E> (implements javax.accessibility.Accessible, javax.swing.Scrollable)
          • javax.swing.JMenuBar (implements javax.accessibility.Accessible, javax.swing.MenuElement)
            • javax.swing.plaf.basic.BasicInternalFrameTitlePane.SystemMenuBar
          • javax.swing.JOptionPane (implements javax.accessibility.Accessible)
          • javax.swing.JPanel (implements javax.accessibility.Accessible)
            • javax.swing.colorchooser.AbstractColorChooserPanel
            • javax.swing.JSpinner.DefaultEditor (implements javax.swing.event.ChangeListener, java.awt.LayoutManager, java.beans.PropertyChangeListener)
              • javax.swing.JSpinner.DateEditor
              • javax.swing.JSpinner.ListEditor
              • javax.swing.JSpinner.NumberEditor
          • javax.swing.JPopupMenu (implements javax.accessibility.Accessible, javax.swing.MenuElement)
            • javax.swing.plaf.basic.BasicComboPopup (implements javax.swing.plaf.basic.ComboPopup)
              • javax.swing.plaf.metal.MetalComboBoxUI.MetalComboPopup
          • javax.swing.JProgressBar (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
          • javax.swing.JRootPane (implements javax.accessibility.Accessible)
          • javax.swing.JScrollBar (implements javax.accessibility.Accessible, java.awt.Adjustable)
            • javax.swing.JScrollPane.ScrollBar (implements javax.swing.plaf.UIResource)
          • javax.swing.JScrollPane (implements javax.accessibility.Accessible, javax.swing.ScrollPaneConstants)
          • javax.swing.JSeparator (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
            • javax.swing.JPopupMenu.Separator
            • javax.swing.JToolBar.Separator
          • javax.swing.JSlider (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
          • javax.swing.JSpinner (implements javax.accessibility.Accessible)
          • javax.swing.JSplitPane (implements javax.accessibility.Accessible)
          • javax.swing.JTabbedPane (implements javax.accessibility.Accessible, java.io.Serializable, javax.swing.SwingConstants)
          • javax.swing.JTable (implements javax.accessibility.Accessible, javax.swing.event.CellEditorListener, javax.swing.event.ListSelectionListener, javax.swing.event.RowSorterListener, javax.swing.Scrollable, javax.swing.event.TableColumnModelListener, javax.swing.event.TableModelListener)
          • javax.swing.table.JTableHeader (implements javax.accessibility.Accessible, javax.swing.event.TableColumnModelListener)
          • javax.swing.text.JTextComponent (implements javax.accessibility.Accessible, javax.swing.Scrollable)
            • javax.swing.JEditorPane
              • javax.swing.JTextPane
            • javax.swing.JTextArea
            • javax.swing.JTextField (implements javax.swing.SwingConstants)
              • javax.swing.tree.DefaultTreeCellEditor.DefaultTextField
              • javax.swing.JFormattedTextField
              • javax.swing.JPasswordField
          • javax.swing.JToolBar (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
          • javax.swing.JToolTip (implements javax.accessibility.Accessible)
          • javax.swing.JTree (implements javax.accessibility.Accessible, javax.swing.Scrollable)
          • javax.swing.JViewport (implements javax.accessibility.Accessible)
        • java.awt.Panel (implements javax.accessibility.Accessible)
          • java.applet.Applet
            • javax.swing.JApplet (implements javax.accessibility.Accessible, javax.swing.RootPaneContainer)
        • java.awt.ScrollPane (implements javax.accessibility.Accessible)
        • java.awt.Window (implements javax.accessibility.Accessible)
          • javax.swing.plaf.basic.BasicToolBarUI.DragWindow
          • java.awt.Dialog
            • java.awt.FileDialog
            • javax.swing.JDialog (implements javax.accessibility.Accessible, javax.swing.RootPaneContainer, javax.swing.WindowConstants)
          • java.awt.Frame (implements java.awt.MenuContainer)
            • javax.swing.JFrame (implements javax.accessibility.Accessible, javax.swing.RootPaneContainer, javax.swing.WindowConstants)
          • javax.swing.JWindow (implements javax.accessibility.Accessible, javax.swing.RootPaneContainer)
      • java.awt.Label (implements javax.accessibility.Accessible)
      • java.awt.List (implements javax.accessibility.Accessible, java.awt.ItemSelectable)
      • java.awt.Scrollbar (implements javax.accessibility.Accessible, java.awt.Adjustable)
      • java.awt.TextComponent (implements javax.accessibility.Accessible)
        • java.awt.TextArea
        • java.awt.TextField
    • java.awt.Component.AccessibleAWTComponent.AccessibleAWTComponentHandler (implements java.awt.event.ComponentListener)
    • java.awt.Component.AccessibleAWTComponent.AccessibleAWTFocusHandler (implements java.awt.event.FocusListener)
    • java.awt.event.ComponentAdapter (implements java.awt.event.ComponentListener)
      • javax.swing.plaf.basic.BasicSliderUI.ComponentHandler
      • javax.swing.plaf.basic.BasicTreeUI.ComponentHandler (implements java.awt.event.ActionListener)
      • javax.swing.JViewport.ViewListener (implements java.io.Serializable)
    • org.omg.IOP.ComponentIdHelper
    • java.awt.ComponentOrientation (implements java.io.Serializable)
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ButtonUI
        • javax.swing.plaf.basic.BasicButtonUI
          • javax.swing.plaf.basic.BasicToggleButtonUI
            • javax.swing.plaf.basic.BasicRadioButtonUI
              • javax.swing.plaf.basic.BasicCheckBoxUI
              • javax.swing.plaf.metal.MetalRadioButtonUI
                • javax.swing.plaf.metal.MetalCheckBoxUI
            • javax.swing.plaf.metal.MetalToggleButtonUI
          • javax.swing.plaf.metal.MetalButtonUI
          • javax.swing.plaf.synth.SynthButtonUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
            • javax.swing.plaf.synth.SynthToggleButtonUI
              • javax.swing.plaf.synth.SynthRadioButtonUI
                • javax.swing.plaf.synth.SynthCheckBoxUI
        • javax.swing.plaf.MenuItemUI
          • javax.swing.plaf.basic.BasicMenuItemUI
            • javax.swing.plaf.basic.BasicCheckBoxMenuItemUI
            • javax.swing.plaf.basic.BasicMenuUI
              • javax.swing.plaf.synth.SynthMenuUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
            • javax.swing.plaf.basic.BasicRadioButtonMenuItemUI
            • javax.swing.plaf.synth.SynthMenuItemUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
              • javax.swing.plaf.synth.SynthCheckBoxMenuItemUI
              • javax.swing.plaf.synth.SynthRadioButtonMenuItemUI
          • javax.swing.plaf.multi.MultiMenuItemUI
        • javax.swing.plaf.multi.MultiButtonUI
      • javax.swing.plaf.ColorChooserUI
        • javax.swing.plaf.basic.BasicColorChooserUI
          • javax.swing.plaf.synth.SynthColorChooserUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
        • javax.swing.plaf.multi.MultiColorChooserUI
      • javax.swing.plaf.ComboBoxUI
        • javax.swing.plaf.basic.BasicComboBoxUI
          • javax.swing.plaf.metal.MetalComboBoxUI
          • javax.swing.plaf.synth.SynthComboBoxUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
        • javax.swing.plaf.multi.MultiComboBoxUI
      • javax.swing.plaf.DesktopIconUI
        • javax.swing.plaf.basic.BasicDesktopIconUI
          • javax.swing.plaf.metal.MetalDesktopIconUI
          • javax.swing.plaf.synth.SynthDesktopIconUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
        • javax.swing.plaf.multi.MultiDesktopIconUI
      • javax.swing.plaf.DesktopPaneUI
        • javax.swing.plaf.basic.BasicDesktopPaneUI
          • javax.swing.plaf.synth.SynthDesktopPaneUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
        • javax.swing.plaf.multi.MultiDesktopPaneUI
      • javax.swing.plaf.FileChooserUI
        • javax.swing.plaf.basic.BasicFileChooserUI
          • javax.swing.plaf.metal.MetalFileChooserUI
        • javax.swing.plaf.multi.MultiFileChooserUI
      • javax.swing.plaf.InternalFrameUI
        • javax.swing.plaf.basic.BasicInternalFrameUI
          • javax.swing.plaf.metal.MetalInternalFrameUI
          • javax.swing.plaf.synth.SynthInternalFrameUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
        • javax.swing.plaf.multi.MultiInternalFrameUI
      • javax.swing.plaf.LabelUI
        • javax.swing.plaf.basic.BasicLabelUI (implements java.beans.PropertyChangeListener)
          • javax.swing.plaf.metal.MetalLabelUI
          • javax.swing.plaf.synth.SynthLabelUI (implements javax.swing.plaf.synth.SynthUI)
        • javax.swing.plaf.multi.MultiLabelUI
      • javax.swing.plaf.LayerUI<V> (implements java.io.Serializable)
      • javax.swing.plaf.ListUI
        • javax.swing.plaf.basic.BasicListUI
          • javax.swing.plaf.synth.SynthListUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
        • javax.swing.plaf.multi.MultiListUI
      • javax.swing.plaf.MenuBarUI
        • javax.swing.plaf.basic.BasicMenuBarUI
          • javax.swing.plaf.metal.MetalMenuBarUI
          • javax.swing.plaf.synth.SynthMenuBarUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
        • javax.swing.plaf.multi.MultiMenuBarUI
      • javax.swing.plaf.OptionPaneUI
        • javax.swing.plaf.basic.BasicOptionPaneUI
          • javax.swing.plaf.synth.SynthOptionPaneUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
        • javax.swing.plaf.multi.MultiOptionPaneUI
      • javax.swing.plaf.PanelUI
        • javax.swing.plaf.basic.BasicPanelUI
          • javax.swing.plaf.synth.SynthPanelUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
        • javax.swing.plaf.multi.MultiPanelUI
      • javax.swing.plaf.PopupMenuUI
        • javax.swing.plaf.basic.BasicPopupMenuUI
          • javax.swing.plaf.synth.SynthPopupMenuUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
        • javax.swing.plaf.multi.MultiPopupMenuUI
      • javax.swing.plaf.ProgressBarUI
        • javax.swing.plaf.basic.BasicProgressBarUI
          • javax.swing.plaf.metal.MetalProgressBarUI
          • javax.swing.plaf.synth.SynthProgressBarUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
        • javax.swing.plaf.multi.MultiProgressBarUI
      • javax.swing.plaf.RootPaneUI
        • javax.swing.plaf.basic.BasicRootPaneUI (implements java.beans.PropertyChangeListener)
          • javax.swing.plaf.metal.MetalRootPaneUI
          • javax.swing.plaf.synth.SynthRootPaneUI (implements javax.swing.plaf.synth.SynthUI)
        • javax.swing.plaf.multi.MultiRootPaneUI
      • javax.swing.plaf.ScrollBarUI
        • javax.swing.plaf.basic.BasicScrollBarUI (implements java.awt.LayoutManager, javax.swing.SwingConstants)
          • javax.swing.plaf.metal.MetalScrollBarUI
          • javax.swing.plaf.synth.SynthScrollBarUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
        • javax.swing.plaf.multi.MultiScrollBarUI
      • javax.swing.plaf.ScrollPaneUI
        • javax.swing.plaf.basic.BasicScrollPaneUI (implements javax.swing.ScrollPaneConstants)
          • javax.swing.plaf.metal.MetalScrollPaneUI
          • javax.swing.plaf.synth.SynthScrollPaneUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
        • javax.swing.plaf.multi.MultiScrollPaneUI
      • javax.swing.plaf.SeparatorUI
        • javax.swing.plaf.basic.BasicSeparatorUI
          • javax.swing.plaf.basic.BasicPopupMenuSeparatorUI
          • javax.swing.plaf.basic.BasicToolBarSeparatorUI
          • javax.swing.plaf.metal.MetalSeparatorUI
            • javax.swing.plaf.metal.MetalPopupMenuSeparatorUI
        • javax.swing.plaf.multi.MultiSeparatorUI
        • javax.swing.plaf.synth.SynthSeparatorUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
      • javax.swing.plaf.SliderUI
        • javax.swing.plaf.basic.BasicSliderUI
          • javax.swing.plaf.metal.MetalSliderUI
          • javax.swing.plaf.synth.SynthSliderUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
        • javax.swing.plaf.multi.MultiSliderUI
      • javax.swing.plaf.SpinnerUI
        • javax.swing.plaf.basic.BasicSpinnerUI
          • javax.swing.plaf.synth.SynthSpinnerUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
        • javax.swing.plaf.multi.MultiSpinnerUI
      • javax.swing.plaf.SplitPaneUI
        • javax.swing.plaf.basic.BasicSplitPaneUI
          • javax.swing.plaf.metal.MetalSplitPaneUI
          • javax.swing.plaf.synth.SynthSplitPaneUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
        • javax.swing.plaf.multi.MultiSplitPaneUI
      • javax.swing.plaf.TabbedPaneUI
        • javax.swing.plaf.basic.BasicTabbedPaneUI (implements javax.swing.SwingConstants)
          • javax.swing.plaf.metal.MetalTabbedPaneUI
          • javax.swing.plaf.synth.SynthTabbedPaneUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
        • javax.swing.plaf.multi.MultiTabbedPaneUI
      • javax.swing.plaf.TableHeaderUI
        • javax.swing.plaf.basic.BasicTableHeaderUI
          • javax.swing.plaf.synth.SynthTableHeaderUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
        • javax.swing.plaf.multi.MultiTableHeaderUI
      • javax.swing.plaf.TableUI
        • javax.swing.plaf.basic.BasicTableUI
          • javax.swing.plaf.synth.SynthTableUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
        • javax.swing.plaf.multi.MultiTableUI
      • javax.swing.plaf.TextUI
        • javax.swing.plaf.basic.BasicTextUI (implements javax.swing.text.ViewFactory)
          • javax.swing.plaf.basic.BasicEditorPaneUI
            • javax.swing.plaf.basic.BasicTextPaneUI
            • javax.swing.plaf.synth.SynthEditorPaneUI (implements javax.swing.plaf.synth.SynthUI)
              • javax.swing.plaf.synth.SynthTextPaneUI
          • javax.swing.plaf.basic.BasicTextAreaUI
            • javax.swing.plaf.synth.SynthTextAreaUI (implements javax.swing.plaf.synth.SynthUI)
          • javax.swing.plaf.basic.BasicTextFieldUI
            • javax.swing.plaf.basic.BasicFormattedTextFieldUI
            • javax.swing.plaf.basic.BasicPasswordFieldUI
            • javax.swing.plaf.metal.MetalTextFieldUI
            • javax.swing.plaf.synth.SynthTextFieldUI (implements javax.swing.plaf.synth.SynthUI)
              • javax.swing.plaf.synth.SynthFormattedTextFieldUI
              • javax.swing.plaf.synth.SynthPasswordFieldUI
          • javax.swing.text.DefaultTextUI
        • javax.swing.plaf.multi.MultiTextUI
      • javax.swing.plaf.ToolBarUI
        • javax.swing.plaf.basic.BasicToolBarUI (implements javax.swing.SwingConstants)
          • javax.swing.plaf.metal.MetalToolBarUI
          • javax.swing.plaf.synth.SynthToolBarUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
        • javax.swing.plaf.multi.MultiToolBarUI
      • javax.swing.plaf.ToolTipUI
        • javax.swing.plaf.basic.BasicToolTipUI
          • javax.swing.plaf.metal.MetalToolTipUI
          • javax.swing.plaf.synth.SynthToolTipUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
        • javax.swing.plaf.multi.MultiToolTipUI
      • javax.swing.plaf.TreeUI
        • javax.swing.plaf.basic.BasicTreeUI
          • javax.swing.plaf.metal.MetalTreeUI
          • javax.swing.plaf.synth.SynthTreeUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
        • javax.swing.plaf.multi.MultiTreeUI
      • javax.swing.plaf.ViewportUI
        • javax.swing.plaf.basic.BasicViewportUI
        • javax.swing.plaf.multi.MultiViewportUI
        • javax.swing.plaf.synth.SynthViewportUI (implements java.beans.PropertyChangeListener, javax.swing.plaf.synth.SynthUI)
    • javax.management.openmbean.CompositeDataInvocationHandler (implements java.lang.reflect.InvocationHandler)
    • javax.management.openmbean.CompositeDataSupport (implements javax.management.openmbean.CompositeData, java.io.Serializable)
    • javax.naming.CompositeName (implements javax.naming.Name)
    • javax.naming.CompoundName (implements javax.naming.Name)
    • java.util.concurrent.ConcurrentHashMap.KeySetView<K,V> (implements java.io.Serializable, java.util.Set<E>)
    • javax.security.auth.login.Configuration
    • javax.security.auth.login.ConfigurationSpi
    • javax.security.auth.callback.ConfirmationCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
    • java.io.Console (implements java.io.Flushable)
    • java.awt.Container.AccessibleAWTContainer.AccessibleContainerHandler (implements java.awt.event.ContainerListener)
    • java.awt.event.ContainerAdapter (implements java.awt.event.ContainerListener)
    • java.net.ContentHandler
    • javax.swing.text.html.parser.ContentModel (implements java.io.Serializable)
    • org.omg.CORBA.Context
    • org.omg.CORBA.ContextList
    • javax.sound.sampled.Control
      • javax.sound.sampled.BooleanControl
      • javax.sound.sampled.CompoundControl
      • javax.sound.sampled.EnumControl
      • javax.sound.sampled.FloatControl
    • javax.sound.sampled.Control.Type
      • javax.sound.sampled.BooleanControl.Type
      • javax.sound.sampled.CompoundControl.Type
      • javax.sound.sampled.EnumControl.Type
      • javax.sound.sampled.FloatControl.Type
    • javax.naming.ldap.ControlFactory
    • java.awt.image.ConvolveOp (implements java.awt.image.BufferedImageOp, java.awt.image.RasterOp)
    • java.net.CookieHandler
      • java.net.CookieManager
    • org.omg.PortableServer.ServantLocatorPackage.CookieHolder (implements org.omg.CORBA.portable.Streamable)
    • java.util.concurrent.CopyOnWriteArrayList<E> (implements java.lang.Cloneable, java.util.List<E>, java.util.RandomAccess, java.io.Serializable)
    • java.util.concurrent.CountDownLatch
    • java.util.zip.CRC32 (implements java.util.zip.Checksum)
    • java.security.cert.CRL
      • java.security.cert.X509CRL (implements java.security.cert.X509Extension)
    • javax.swing.text.html.CSS (implements java.io.Serializable)
    • javax.swing.text.html.CSS.Attribute
    • java.awt.geom.CubicCurve2D (implements java.lang.Cloneable, java.awt.Shape)
      • java.awt.geom.CubicCurve2D.Double (implements java.io.Serializable)
      • java.awt.geom.CubicCurve2D.Float (implements java.io.Serializable)
    • java.util.Currency (implements java.io.Serializable)
    • org.omg.CORBA.CurrentHelper
    • org.omg.PortableServer.CurrentHelper
    • org.omg.PortableInterceptor.CurrentHelper
    • org.omg.CORBA.CurrentHolder (implements org.omg.CORBA.portable.Streamable)
    • java.awt.Cursor (implements java.io.Serializable)
    • java.util.concurrent.CyclicBarrier
    • java.awt.image.DataBuffer
      • java.awt.image.DataBufferByte
      • java.awt.image.DataBufferDouble
      • java.awt.image.DataBufferFloat
      • java.awt.image.DataBufferInt
      • java.awt.image.DataBufferShort
      • java.awt.image.DataBufferUShort
    • java.awt.datatransfer.DataFlavor (implements java.lang.Cloneable, java.io.Externalizable)
      • javax.activation.ActivationDataFlavor
    • java.net.DatagramPacket
    • java.net.DatagramSocket (implements java.io.Closeable)
      • java.net.MulticastSocket
    • java.net.DatagramSocketImpl (implements java.net.SocketOptions)
    • javax.activation.DataHandler (implements java.awt.datatransfer.Transferable)
    • javax.xml.datatype.DatatypeConstants
    • javax.xml.datatype.DatatypeConstants.Field
    • javax.xml.bind.DatatypeConverter
    • javax.xml.datatype.DatatypeFactory
    • java.util.Date (implements java.lang.Cloneable, java.lang.Comparable<T>, java.io.Serializable)
      • java.sql.Date
      • java.sql.Time
      • java.sql.Timestamp
    • java.text.DateFormatSymbols (implements java.lang.Cloneable, java.io.Serializable)
    • java.time.format.DateTimeFormatter
    • java.time.format.DateTimeFormatterBuilder
    • javax.print.attribute.DateTimeSyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.DateTimeAtCompleted (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.DateTimeAtCreation (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.DateTimeAtProcessing (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.JobHoldUntil (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
    • java.text.DecimalFormatSymbols (implements java.lang.Cloneable, java.io.Serializable)
    • java.time.format.DecimalStyle
    • javax.swing.DefaultBoundedRangeModel (implements javax.swing.BoundedRangeModel, java.io.Serializable)
    • javax.swing.DefaultButtonModel (implements javax.swing.ButtonModel, java.io.Serializable)
      • javax.swing.JToggleButton.ToggleButtonModel
    • javax.swing.DefaultCellEditor.EditorDelegate (implements java.awt.event.ActionListener, java.awt.event.ItemListener, java.io.Serializable)
    • javax.swing.colorchooser.DefaultColorSelectionModel (implements javax.swing.colorchooser.ColorSelectionModel, java.io.Serializable)
    • javax.swing.DefaultDesktopManager (implements javax.swing.DesktopManager, java.io.Serializable)
    • org.xml.sax.helpers.DefaultHandler (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
      • org.xml.sax.ext.DefaultHandler2 (implements org.xml.sax.ext.DeclHandler, org.xml.sax.ext.EntityResolver2, org.xml.sax.ext.LexicalHandler)
    • javax.swing.DefaultListSelectionModel (implements java.lang.Cloneable, javax.swing.ListSelectionModel, java.io.Serializable)
    • javax.management.DefaultLoaderRepository
    • javax.management.loading.DefaultLoaderRepository
    • javax.swing.tree.DefaultMutableTreeNode (implements java.lang.Cloneable, javax.swing.tree.MutableTreeNode, java.io.Serializable)
      • javax.swing.JTree.DynamicUtilTreeNode
    • javax.swing.DefaultRowSorter.ModelWrapper<M,I>
    • javax.swing.DefaultSingleSelectionModel (implements java.io.Serializable, javax.swing.SingleSelectionModel)
    • javax.swing.text.DefaultStyledDocument.ElementBuffer (implements java.io.Serializable)
    • javax.swing.text.DefaultStyledDocument.ElementSpec
    • javax.swing.table.DefaultTableColumnModel (implements javax.swing.event.ListSelectionListener, java.beans.PropertyChangeListener, java.io.Serializable, javax.swing.table.TableColumnModel)
    • javax.swing.tree.DefaultTreeCellEditor (implements java.awt.event.ActionListener, javax.swing.tree.TreeCellEditor, javax.swing.event.TreeSelectionListener)
    • javax.swing.tree.DefaultTreeModel (implements java.io.Serializable, javax.swing.tree.TreeModel)
    • javax.swing.tree.DefaultTreeSelectionModel (implements java.lang.Cloneable, java.io.Serializable, javax.swing.tree.TreeSelectionModel)
      • javax.swing.JTree.EmptySelectionModel
    • javax.xml.bind.helpers.DefaultValidationEventHandler (implements javax.xml.bind.ValidationEventHandler)
    • org.omg.CORBA.DefinitionKind (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DefinitionKindHelper
    • java.util.zip.Deflater
    • org.omg.CORBA.portable.Delegate
      • org.omg.CORBA_2_3.portable.Delegate
    • javax.management.modelmbean.DescriptorSupport (implements javax.management.Descriptor)
    • javax.crypto.spec.DESedeKeySpec (implements java.security.spec.KeySpec)
    • javax.crypto.spec.DESKeySpec (implements java.security.spec.KeySpec)
    • java.awt.Desktop
    • javax.crypto.spec.DHGenParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • javax.crypto.spec.DHParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • javax.crypto.spec.DHPrivateKeySpec (implements java.security.spec.KeySpec)
    • javax.crypto.spec.DHPublicKeySpec (implements java.security.spec.KeySpec)
    • javax.tools.DiagnosticCollector<S> (implements javax.tools.DiagnosticListener<S>)
    • java.util.Dictionary<K,V>
      • java.util.Hashtable<K,V> (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable)
        • java.util.Properties
          • java.security.Provider
            • java.security.AuthProvider
        • javax.swing.UIDefaults
    • java.awt.geom.Dimension2D (implements java.lang.Cloneable)
      • java.awt.Dimension (implements java.io.Serializable)
        • javax.swing.plaf.DimensionUIResource (implements javax.swing.plaf.UIResource)
    • javax.naming.spi.DirStateFactory.Result
    • java.awt.DisplayMode
    • java.awt.dnd.DnDConstants
    • javax.print.DocFlavor (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.DocFlavor.BYTE_ARRAY
      • javax.print.DocFlavor.CHAR_ARRAY
      • javax.print.DocFlavor.INPUT_STREAM
      • javax.print.DocFlavor.READER
      • javax.print.DocFlavor.SERVICE_FORMATTED
      • javax.print.DocFlavor.STRING
      • javax.print.DocFlavor.URL
    • javax.xml.parsers.DocumentBuilder
    • javax.xml.parsers.DocumentBuilderFactory
    • javax.swing.event.DocumentEvent.EventType
    • javax.swing.text.DocumentFilter
    • javax.swing.text.DocumentFilter.FilterBypass
    • java.security.DomainLoadStoreParameter (implements java.security.KeyStore.LoadStoreParameter)
    • javax.xml.crypto.dom.DOMCryptoContext (implements javax.xml.crypto.XMLCryptoContext)
      • javax.xml.crypto.dsig.dom.DOMSignContext (implements javax.xml.crypto.dsig.XMLSignContext)
      • javax.xml.crypto.dsig.dom.DOMValidateContext (implements javax.xml.crypto.dsig.XMLValidateContext)
    • org.w3c.dom.bootstrap.DOMImplementationRegistry
    • javax.xml.transform.dom.DOMResult (implements javax.xml.transform.Result)
      • javax.xml.soap.SAAJResult
    • javax.xml.transform.dom.DOMSource (implements javax.xml.transform.Source)
    • javax.xml.crypto.dom.DOMStructure (implements javax.xml.crypto.XMLStructure)
    • org.omg.CORBA.DoubleHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.DoubleSeqHelper
    • org.omg.CORBA.DoubleSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • java.util.DoubleSummaryStatistics (implements java.util.function.DoubleConsumer)
    • java.awt.dnd.DragGestureRecognizer (implements java.io.Serializable)
      • java.awt.dnd.MouseDragGestureRecognizer (implements java.awt.event.MouseListener, java.awt.event.MouseMotionListener)
    • java.awt.dnd.DragSource (implements java.io.Serializable)
    • java.awt.dnd.DragSourceAdapter (implements java.awt.dnd.DragSourceListener, java.awt.dnd.DragSourceMotionListener)
    • java.awt.dnd.DragSourceContext (implements java.awt.dnd.DragSourceListener, java.awt.dnd.DragSourceMotionListener, java.io.Serializable)
    • java.sql.DriverManager
    • java.sql.DriverPropertyInfo
    • java.awt.dnd.DropTarget (implements java.awt.dnd.DropTargetListener, java.io.Serializable)
    • java.awt.dnd.DropTarget.DropTargetAutoScroller (implements java.awt.event.ActionListener)
    • java.awt.dnd.DropTargetAdapter (implements java.awt.dnd.DropTargetListener)
    • java.awt.dnd.DropTargetContext (implements java.io.Serializable)
    • java.awt.dnd.DropTargetContext.TransferableProxy (implements java.awt.datatransfer.Transferable)
    • java.security.spec.DSAGenParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • java.security.spec.DSAParameterSpec (implements java.security.spec.AlgorithmParameterSpec, java.security.interfaces.DSAParams)
    • java.security.spec.DSAPrivateKeySpec (implements java.security.spec.KeySpec)
    • java.security.spec.DSAPublicKeySpec (implements java.security.spec.KeySpec)
    • javax.swing.text.html.parser.DTD (implements javax.swing.text.html.parser.DTDConstants)
    • org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper
    • java.time.Duration (implements java.lang.Comparable<T>, java.io.Serializable, java.time.temporal.TemporalAmount)
    • javax.xml.datatype.Duration
    • org.omg.DynamicAny.DynAnyFactoryHelper
    • org.omg.DynamicAny.DynAnyHelper
    • org.omg.DynamicAny.DynAnySeqHelper
    • org.omg.DynamicAny.DynArrayHelper
    • org.omg.DynamicAny.DynEnumHelper
    • org.omg.DynamicAny.DynFixedHelper
    • org.omg.DynamicAny.DynSequenceHelper
    • org.omg.DynamicAny.DynStructHelper
    • org.omg.DynamicAny.DynUnionHelper
    • org.omg.DynamicAny.DynValueHelper
    • java.security.spec.ECFieldF2m (implements java.security.spec.ECField)
    • java.security.spec.ECFieldFp (implements java.security.spec.ECField)
    • java.security.spec.ECGenParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • java.security.spec.ECParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • java.security.spec.ECPoint
    • java.security.spec.ECPrivateKeySpec (implements java.security.spec.KeySpec)
    • java.security.spec.ECPublicKeySpec (implements java.security.spec.KeySpec)
    • javax.swing.text.EditorKit (implements java.lang.Cloneable, java.io.Serializable)
      • javax.swing.text.DefaultEditorKit
        • javax.swing.text.StyledEditorKit
          • javax.swing.text.html.HTMLEditorKit (implements javax.accessibility.Accessible)
          • javax.swing.text.rtf.RTFEditorKit
    • javax.swing.text.html.parser.Element (implements javax.swing.text.html.parser.DTDConstants, java.io.Serializable)
    • javax.lang.model.util.ElementFilter
    • javax.swing.text.ElementIterator (implements java.lang.Cloneable)
    • java.security.spec.EllipticCurve
    • java.security.spec.EncodedKeySpec (implements java.security.spec.KeySpec)
      • java.security.spec.PKCS8EncodedKeySpec
      • java.security.spec.X509EncodedKeySpec
    • java.beans.Encoder
      • java.beans.XMLEncoder (implements java.lang.AutoCloseable)
    • org.omg.IOP.Encoding (implements org.omg.CORBA.portable.IDLEntity)
    • javax.crypto.EncryptedPrivateKeyInfo
    • javax.xml.ws.Endpoint
    • javax.xml.ws.EndpointContext
    • javax.xml.ws.EndpointReference
      • javax.xml.ws.wsaddressing.W3CEndpointReference
    • javax.swing.text.html.parser.Entity (implements javax.swing.text.html.parser.DTDConstants)
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
    • javax.print.attribute.EnumSyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.Chromaticity (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.ColorSupported (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.Compression (implements javax.print.attribute.DocAttribute)
      • javax.print.attribute.standard.DialogTypeSelection (implements javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.Fidelity (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.Finishings (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobSheets (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobState (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.JobStateReason (implements javax.print.attribute.Attribute)
      • javax.print.attribute.standard.Media (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
        • javax.print.attribute.standard.MediaName (implements javax.print.attribute.Attribute)
        • javax.print.attribute.standard.MediaSizeName
        • javax.print.attribute.standard.MediaTray (implements javax.print.attribute.Attribute)
      • javax.print.attribute.standard.MultipleDocumentHandling (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.OrientationRequested (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.PDLOverrideSupported (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PresentationDirection (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.PrinterIsAcceptingJobs (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterState (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterStateReason (implements javax.print.attribute.Attribute)
      • javax.print.attribute.standard.PrintQuality (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.ReferenceUriSchemesSupported (implements javax.print.attribute.Attribute)
      • javax.print.attribute.standard.Severity (implements javax.print.attribute.Attribute)
      • javax.print.attribute.standard.SheetCollate (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.Sides (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
    • org.omg.CORBA.Environment
    • java.util.logging.ErrorManager
    • java.awt.Event (implements java.io.Serializable)
    • java.beans.EventHandler (implements java.lang.reflect.InvocationHandler)
    • javax.swing.event.EventListenerList (implements java.io.Serializable)
    • java.util.EventListenerProxy<T> (implements java.util.EventListener)
      • java.awt.event.AWTEventListenerProxy (implements java.awt.event.AWTEventListener)
      • java.beans.PropertyChangeListenerProxy (implements java.beans.PropertyChangeListener)
      • java.beans.VetoableChangeListenerProxy (implements java.beans.VetoableChangeListener)
    • java.util.EventObject (implements java.io.Serializable)
      • java.awt.AWTEvent
        • java.awt.event.ActionEvent
        • java.awt.event.AdjustmentEvent
        • javax.swing.event.AncestorEvent
        • java.awt.event.ComponentEvent
          • java.awt.event.ContainerEvent
          • java.awt.event.FocusEvent
          • java.awt.event.InputEvent
            • java.awt.event.KeyEvent
              • javax.swing.event.MenuKeyEvent
            • java.awt.event.MouseEvent
              • javax.swing.event.MenuDragMouseEvent
              • java.awt.event.MouseWheelEvent
          • java.awt.event.PaintEvent
          • java.awt.event.WindowEvent
        • java.awt.event.HierarchyEvent
        • java.awt.event.InputMethodEvent
        • javax.swing.event.InternalFrameEvent
        • java.awt.event.InvocationEvent (implements java.awt.ActiveEvent)
        • java.awt.event.ItemEvent
        • java.awt.event.TextEvent
      • java.beans.beancontext.BeanContextEvent
        • java.beans.beancontext.BeanContextMembershipEvent
        • java.beans.beancontext.BeanContextServiceAvailableEvent
        • java.beans.beancontext.BeanContextServiceRevokedEvent
      • javax.swing.event.CaretEvent
      • javax.swing.event.ChangeEvent
      • javax.sql.ConnectionEvent
      • java.awt.dnd.DragGestureEvent
      • java.awt.dnd.DragSourceEvent
        • java.awt.dnd.DragSourceDragEvent
        • java.awt.dnd.DragSourceDropEvent
      • java.awt.dnd.DropTargetEvent
        • java.awt.dnd.DropTargetDragEvent
        • java.awt.dnd.DropTargetDropEvent
      • java.awt.datatransfer.FlavorEvent
      • javax.net.ssl.HandshakeCompletedEvent
      • javax.swing.event.HyperlinkEvent
        • javax.swing.text.html.HTMLFrameHyperlinkEvent
          • javax.swing.text.html.FormSubmitEvent
      • javax.sound.sampled.LineEvent
      • javax.swing.event.ListDataEvent
      • javax.swing.event.ListSelectionEvent
      • javax.swing.event.MenuEvent
      • javax.naming.event.NamingEvent
      • javax.naming.event.NamingExceptionEvent
      • java.util.prefs.NodeChangeEvent
      • javax.management.Notification
        • javax.management.AttributeChangeNotification
        • javax.management.remote.JMXConnectionNotification
        • javax.management.MBeanServerNotification
        • javax.management.monitor.MonitorNotification
        • javax.management.relation.RelationNotification
        • javax.management.timer.TimerNotification
      • javax.swing.event.PopupMenuEvent
      • java.util.prefs.PreferenceChangeEvent
      • javax.print.event.PrintEvent
        • javax.print.event.PrintJobAttributeEvent
        • javax.print.event.PrintJobEvent
        • javax.print.event.PrintServiceAttributeEvent
      • java.beans.PropertyChangeEvent
        • java.beans.IndexedPropertyChangeEvent
      • javax.sql.RowSetEvent
      • javax.swing.event.RowSorterEvent
      • javax.net.ssl.SSLSessionBindingEvent
      • javax.sql.StatementEvent
      • javax.swing.event.TableColumnModelEvent
      • javax.swing.event.TableModelEvent
      • javax.swing.event.TreeExpansionEvent
      • javax.swing.event.TreeModelEvent
      • javax.swing.event.TreeSelectionEvent
      • javax.swing.event.UndoableEditEvent
      • javax.naming.ldap.UnsolicitedNotificationEvent
    • java.awt.EventQueue
    • javax.xml.stream.util.EventReaderDelegate (implements javax.xml.stream.XMLEventReader)
    • javax.xml.crypto.dsig.spec.ExcC14NParameterSpec (implements javax.xml.crypto.dsig.spec.C14NMethodParameterSpec)
    • org.omg.CORBA.ExceptionList
    • java.util.concurrent.Exchanger<V>
    • java.util.concurrent.ExecutorCompletionService<V> (implements java.util.concurrent.CompletionService<V>)
    • java.util.concurrent.Executors
    • javax.crypto.ExemptionMechanism
    • javax.crypto.ExemptionMechanismSpi
    • javax.net.ssl.ExtendedSSLSession (implements javax.net.ssl.SSLSession)
    • java.beans.FeatureDescriptor
      • java.beans.BeanDescriptor
      • java.beans.EventSetDescriptor
      • java.beans.MethodDescriptor
      • java.beans.ParameterDescriptor
      • java.beans.PropertyDescriptor
        • java.beans.IndexedPropertyDescriptor
    • org.omg.CORBA.FieldNameHelper
    • org.omg.DynamicAny.FieldNameHelper
    • java.text.FieldPosition
    • java.io.File (implements java.lang.Comparable<T>, java.io.Serializable)
    • java.nio.channels.FileChannel.MapMode
    • javax.activation.FileDataSource (implements javax.activation.DataSource)
    • java.io.FileDescriptor
    • javax.swing.filechooser.FileFilter
      • javax.swing.plaf.basic.BasicFileChooserUI.AcceptAllFileFilter
      • javax.swing.filechooser.FileNameExtensionFilter
    • java.nio.channels.FileLock (implements java.lang.AutoCloseable)
    • java.nio.file.Files
    • java.nio.file.FileStore
    • java.nio.file.FileSystem (implements java.io.Closeable)
    • java.nio.file.spi.FileSystemProvider
    • java.nio.file.FileSystems
    • javax.swing.filechooser.FileSystemView
    • java.nio.file.attribute.FileTime (implements java.lang.Comparable<T>)
    • java.nio.file.spi.FileTypeDetector
    • javax.activation.FileTypeMap
      • javax.activation.MimetypesFileTypeMap
    • javax.swing.filechooser.FileView
      • javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView
    • java.awt.image.FilteredImageSource (implements java.awt.image.ImageProducer)
    • org.omg.CORBA.FixedHolder (implements org.omg.CORBA.portable.Streamable)
    • java.awt.geom.FlatteningPathIterator (implements java.awt.geom.PathIterator)
    • org.omg.CORBA.FloatHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.FloatSeqHelper
    • org.omg.CORBA.FloatSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • java.awt.FlowLayout (implements java.awt.LayoutManager, java.io.Serializable)
    • javax.swing.text.FlowView.FlowStrategy
    • java.awt.event.FocusAdapter (implements java.awt.event.FocusListener)
      • javax.swing.plaf.basic.BasicSplitPaneUI.FocusHandler
      • javax.swing.plaf.basic.BasicTabbedPaneUI.FocusHandler
    • java.awt.FocusTraversalPolicy
      • java.awt.ContainerOrderFocusTraversalPolicy (implements java.io.Serializable)
        • java.awt.DefaultFocusTraversalPolicy
      • javax.swing.InternalFrameFocusTraversalPolicy
        • javax.swing.SortingFocusTraversalPolicy
          • javax.swing.LayoutFocusTraversalPolicy (implements java.io.Serializable)
    • java.awt.Font (implements java.io.Serializable)
      • javax.swing.plaf.FontUIResource (implements javax.swing.plaf.UIResource)
    • java.awt.FontMetrics (implements java.io.Serializable)
    • java.awt.font.FontRenderContext
    • java.util.concurrent.ForkJoinTask<V> (implements java.util.concurrent.Future<V>, java.io.Serializable)
      • java.util.concurrent.CountedCompleter<T>
      • java.util.concurrent.RecursiveAction
      • java.util.concurrent.RecursiveTask<V>
    • java.text.Format (implements java.lang.Cloneable, java.io.Serializable)
      • java.text.DateFormat
        • java.text.SimpleDateFormat
      • java.text.MessageFormat
      • java.text.NumberFormat
        • java.text.ChoiceFormat
        • java.text.DecimalFormat
    • javax.sound.sampled.spi.FormatConversionProvider
    • org.omg.IOP.CodecPackage.FormatMismatchHelper
    • java.util.FormattableFlags
    • java.util.Formatter (implements java.io.Closeable, java.io.Flushable)
    • java.util.logging.Formatter
      • java.util.logging.SimpleFormatter
      • java.util.logging.XMLFormatter
    • javax.tools.ForwardingFileObject<F> (implements javax.tools.FileObject)
      • javax.tools.ForwardingJavaFileObject<F> (implements javax.tools.JavaFileObject)
    • javax.tools.ForwardingJavaFileManager<M> (implements javax.tools.JavaFileManager)
    • org.omg.PortableServer.ForwardRequestHelper
    • org.omg.PortableInterceptor.ForwardRequestHelper
    • java.util.concurrent.FutureTask<V> (implements java.util.concurrent.RunnableFuture<V>)
    • javax.swing.text.GapContent (implements javax.swing.text.AbstractDocument.Content, java.io.Serializable)
    • javax.crypto.spec.GCMParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • java.awt.font.GlyphJustificationInfo
    • java.awt.font.GlyphMetrics
    • java.awt.font.GlyphVector (implements java.lang.Cloneable)
    • javax.swing.text.GlyphView.GlyphPainter
    • java.awt.GradientPaint (implements java.awt.Paint)
    • java.awt.font.GraphicAttribute
      • java.awt.font.ImageGraphicAttribute
      • java.awt.font.ShapeGraphicAttribute
    • java.awt.Graphics
      • javax.swing.DebugGraphics
      • java.awt.Graphics2D
    • java.awt.GraphicsConfigTemplate (implements java.io.Serializable)
    • java.awt.GraphicsConfiguration
    • java.awt.GraphicsDevice
    • java.awt.GraphicsEnvironment
    • java.awt.GridBagConstraints (implements java.lang.Cloneable, java.io.Serializable)
    • java.awt.GridBagLayout (implements java.awt.LayoutManager2, java.io.Serializable)
    • java.awt.GridBagLayoutInfo (implements java.io.Serializable)
    • java.awt.GridLayout (implements java.awt.LayoutManager, java.io.Serializable)
    • javax.swing.GroupLayout (implements java.awt.LayoutManager2)
    • javax.swing.GroupLayout.Group
      • javax.swing.GroupLayout.ParallelGroup
      • javax.swing.GroupLayout.SequentialGroup
    • org.ietf.jgss.GSSManager
    • java.security.GuardedObject (implements java.io.Serializable)
    • java.util.logging.Handler
      • java.util.logging.MemoryHandler
      • java.util.logging.StreamHandler
        • java.util.logging.ConsoleHandler
        • java.util.logging.FileHandler
        • java.util.logging.SocketHandler
    • org.xml.sax.HandlerBase (implements org.xml.sax.DocumentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
    • javax.print.attribute.HashAttributeSet (implements javax.print.attribute.AttributeSet, java.io.Serializable)
      • javax.print.attribute.HashDocAttributeSet (implements javax.print.attribute.DocAttributeSet, java.io.Serializable)
      • javax.print.attribute.HashPrintJobAttributeSet (implements javax.print.attribute.PrintJobAttributeSet, java.io.Serializable)
      • javax.print.attribute.HashPrintRequestAttributeSet (implements javax.print.attribute.PrintRequestAttributeSet, java.io.Serializable)
      • javax.print.attribute.HashPrintServiceAttributeSet (implements javax.print.attribute.PrintServiceAttributeSet, java.io.Serializable)
    • java.awt.event.HierarchyBoundsAdapter (implements java.awt.event.HierarchyBoundsListener)
    • java.time.chrono.HijrahDate (implements java.time.chrono.ChronoLocalDate, java.io.Serializable)
    • javax.xml.crypto.dsig.spec.HMACParameterSpec (implements javax.xml.crypto.dsig.spec.SignatureMethodParameterSpec)
    • javax.xml.ws.Holder<T> (implements java.io.Serializable)
    • javax.swing.text.html.HTML
    • javax.swing.text.html.HTML.Attribute
    • javax.swing.text.html.HTML.Tag
      • javax.swing.text.html.HTML.UnknownTag (implements java.io.Serializable)
    • javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
      • javax.swing.text.html.HTMLDocument.HTMLReader.BlockAction
        • javax.swing.text.html.HTMLDocument.HTMLReader.ParagraphAction
        • javax.swing.text.html.HTMLDocument.HTMLReader.PreAction
      • javax.swing.text.html.HTMLDocument.HTMLReader.CharacterAction
      • javax.swing.text.html.HTMLDocument.HTMLReader.HiddenAction
      • javax.swing.text.html.HTMLDocument.HTMLReader.IsindexAction
      • javax.swing.text.html.HTMLDocument.HTMLReader.SpecialAction
        • javax.swing.text.html.HTMLDocument.HTMLReader.FormAction
    • javax.swing.text.html.HTMLDocument.Iterator
    • javax.swing.text.html.HTMLEditorKit.HTMLFactory (implements javax.swing.text.ViewFactory)
    • javax.swing.text.html.HTMLEditorKit.Parser
      • javax.swing.text.html.parser.ParserDelegator (implements java.io.Serializable)
    • javax.swing.text.html.HTMLEditorKit.ParserCallback
      • javax.swing.text.html.HTMLDocument.HTMLReader
    • javax.xml.ws.spi.http.HttpContext
    • java.net.HttpCookie (implements java.lang.Cloneable)
    • javax.xml.ws.spi.http.HttpExchange
    • javax.xml.ws.spi.http.HttpHandler
    • javax.swing.event.HyperlinkEvent.EventType
    • java.awt.color.ICC_Profile (implements java.io.Serializable)
      • java.awt.color.ICC_ProfileGray
      • java.awt.color.ICC_ProfileRGB
    • javax.swing.plaf.IconUIResource (implements javax.swing.Icon, java.io.Serializable, javax.swing.plaf.UIResource)
    • org.omg.PortableServer.IdAssignmentPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.IdentifierHelper
    • java.security.Identity (implements java.security.Principal, java.io.Serializable)
      • java.security.IdentityScope
      • java.security.Signer
    • org.omg.CORBA.IDLTypeHelper
    • java.net.IDN
    • org.omg.PortableServer.IdUniquenessPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • javax.imageio.stream.IIOByteBuffer
    • javax.imageio.IIOImage
    • javax.imageio.metadata.IIOMetadata
    • javax.imageio.metadata.IIOMetadataFormatImpl (implements javax.imageio.metadata.IIOMetadataFormat)
    • javax.imageio.metadata.IIOMetadataNode (implements org.w3c.dom.Element, org.w3c.dom.NodeList)
    • javax.imageio.IIOParam
      • javax.imageio.ImageReadParam
        • javax.imageio.plugins.jpeg.JPEGImageReadParam
      • javax.imageio.ImageWriteParam
        • javax.imageio.plugins.bmp.BMPImageWriteParam
        • javax.imageio.plugins.jpeg.JPEGImageWriteParam
    • javax.imageio.spi.IIOServiceProvider (implements javax.imageio.spi.RegisterableService)
      • javax.imageio.spi.ImageInputStreamSpi
      • javax.imageio.spi.ImageOutputStreamSpi
      • javax.imageio.spi.ImageReaderWriterSpi
        • javax.imageio.spi.ImageReaderSpi
        • javax.imageio.spi.ImageWriterSpi
      • javax.imageio.spi.ImageTranscoderSpi
    • java.awt.Image
      • java.awt.image.BufferedImage (implements java.awt.Transparency, java.awt.image.WritableRenderedImage)
      • java.awt.image.VolatileImage (implements java.awt.Transparency)
    • java.awt.ImageCapabilities (implements java.lang.Cloneable)
    • java.awt.image.ImageFilter (implements java.lang.Cloneable, java.awt.image.ImageConsumer)
      • java.awt.image.BufferedImageFilter (implements java.lang.Cloneable)
      • java.awt.image.CropImageFilter
      • java.awt.image.ReplicateScaleFilter
        • java.awt.image.AreaAveragingScaleFilter
      • java.awt.image.RGBImageFilter
        • javax.swing.GrayFilter
    • javax.swing.ImageIcon (implements javax.accessibility.Accessible, javax.swing.Icon, java.io.Serializable)
    • javax.imageio.stream.ImageInputStreamImpl (implements javax.imageio.stream.ImageInputStream)
      • javax.imageio.stream.FileCacheImageInputStream
      • javax.imageio.stream.FileImageInputStream
      • javax.imageio.stream.ImageOutputStreamImpl (implements javax.imageio.stream.ImageOutputStream)
        • javax.imageio.stream.FileCacheImageOutputStream
        • javax.imageio.stream.FileImageOutputStream
        • javax.imageio.stream.MemoryCacheImageOutputStream
      • javax.imageio.stream.MemoryCacheImageInputStream
    • javax.imageio.ImageIO
    • javax.imageio.ImageReader
    • javax.imageio.ImageTypeSpecifier
    • javax.imageio.ImageWriter (implements javax.imageio.ImageTranscoder)
    • javax.management.ImmutableDescriptor (implements javax.management.Descriptor)
    • org.omg.PortableServer.ImplicitActivationPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper
    • java.net.InetAddress (implements java.io.Serializable)
      • java.net.Inet4Address
      • java.net.Inet6Address
    • java.util.zip.Inflater
    • javax.naming.InitialContext (implements javax.naming.Context)
      • javax.naming.directory.InitialDirContext (implements javax.naming.directory.DirContext)
        • javax.naming.ldap.InitialLdapContext (implements javax.naming.ldap.LdapContext)
    • java.awt.im.InputContext
    • javax.swing.InputMap (implements java.io.Serializable)
      • javax.swing.ComponentInputMap
        • javax.swing.plaf.ComponentInputMapUIResource (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.InputMapUIResource (implements javax.swing.plaf.UIResource)
    • java.awt.im.InputMethodHighlight
    • org.xml.sax.InputSource
    • java.io.InputStream (implements java.io.Closeable)
      • javax.sound.sampled.AudioInputStream
      • java.io.ByteArrayInputStream
      • java.io.FileInputStream
      • java.io.FilterInputStream
        • java.io.BufferedInputStream
        • java.util.zip.CheckedInputStream
        • javax.crypto.CipherInputStream
        • java.io.DataInputStream (implements java.io.DataInput)
        • java.util.zip.DeflaterInputStream
        • java.security.DigestInputStream
        • java.util.zip.InflaterInputStream
          • java.util.zip.GZIPInputStream
          • java.util.zip.ZipInputStream
            • java.util.jar.JarInputStream
        • java.io.LineNumberInputStream
        • javax.swing.ProgressMonitorInputStream
        • java.io.PushbackInputStream
      • org.omg.CORBA.portable.InputStream
        • org.omg.CORBA_2_3.portable.InputStream
      • java.io.ObjectInputStream (implements java.io.ObjectInput, java.io.ObjectStreamConstants)
      • java.io.PipedInputStream
      • java.io.SequenceInputStream
      • java.io.StringBufferInputStream
    • javax.swing.InputVerifier
    • java.awt.Insets (implements java.lang.Cloneable, java.io.Serializable)
      • javax.swing.plaf.InsetsUIResource (implements javax.swing.plaf.UIResource)
    • java.time.Instant (implements java.lang.Comparable<T>, java.io.Serializable, java.time.temporal.Temporal, java.time.temporal.TemporalAdjuster)
    • javax.print.attribute.IntegerSyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.Copies (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobImpressions (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobImpressionsCompleted (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.JobKOctets (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobKOctetsProcessed (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.JobMediaSheets (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobMediaSheetsCompleted (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.JobPriority (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobPrioritySupported (implements javax.print.attribute.SupportedValuesAttribute)
      • javax.print.attribute.standard.NumberOfDocuments (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.NumberOfInterveningJobs (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.NumberUp (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.PagesPerMinute (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PagesPerMinuteColor (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.QueuedJobCount (implements javax.print.attribute.PrintServiceAttribute)
    • java.net.InterfaceAddress
    • javax.swing.event.InternalFrameAdapter (implements javax.swing.event.InternalFrameListener)
    • org.omg.CORBA.IntHolder (implements org.omg.CORBA.portable.Streamable)
    • java.beans.Introspector
    • java.util.IntSummaryStatistics (implements java.util.function.IntConsumer)
    • org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper
    • org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NamingContextPackage.InvalidNameHelper
    • org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper
    • org.omg.CosNaming.NamingContextPackage.InvalidNameHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.PortableServer.POAPackage.InvalidPolicyHelper
    • org.omg.PortableInterceptor.InvalidSlotHelper
    • org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper
    • org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper
    • javax.xml.ws.spi.Invoker
    • org.omg.IOP.IOR (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.IORHelper
    • org.omg.IOP.IORHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.PortableInterceptor.IORInterceptor_3_0Helper
    • org.omg.PortableInterceptor.IORInterceptor_3_0Holder (implements org.omg.CORBA.portable.Streamable)
    • java.time.temporal.IsoFields
    • org.omg.CosNaming.IstringHelper
    • javax.crypto.spec.IvParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • java.time.chrono.JapaneseDate (implements java.time.chrono.ChronoLocalDate, java.io.Serializable)
    • java.time.chrono.JapaneseEra (implements java.time.chrono.Era, java.io.Serializable)
    • javax.xml.bind.JAXB
    • javax.xml.bind.JAXBContext
    • javax.xml.bind.JAXBElement<T> (implements java.io.Serializable)
    • javax.xml.bind.JAXBElement.GlobalScope
    • javax.xml.bind.JAXBIntrospector
    • javax.swing.JComponent.AccessibleJComponent.AccessibleContainerHandler (implements java.awt.event.ContainerListener)
    • javax.swing.JComponent.AccessibleJComponent.AccessibleFocusHandler (implements java.awt.event.FocusListener)
    • javax.swing.JFormattedTextField.AbstractFormatter (implements java.io.Serializable)
      • javax.swing.text.DefaultFormatter (implements java.lang.Cloneable, java.io.Serializable)
        • javax.swing.text.InternationalFormatter
          • javax.swing.text.DateFormatter
          • javax.swing.text.NumberFormatter
        • javax.swing.text.MaskFormatter
    • javax.swing.JFormattedTextField.AbstractFormatterFactory
      • javax.swing.text.DefaultFormatterFactory (implements java.io.Serializable)
    • javax.management.JMX
    • javax.management.remote.JMXConnectorFactory
    • javax.management.remote.JMXConnectorServerFactory
    • javax.management.remote.JMXPrincipal (implements java.security.Principal, java.io.Serializable)
    • javax.management.remote.JMXServiceURL (implements java.io.Serializable)
    • java.awt.JobAttributes (implements java.lang.Cloneable)
    • java.awt.JobAttributes.DefaultSelectionType
    • java.awt.JobAttributes.DestinationType
    • java.awt.JobAttributes.DialogType
    • java.awt.JobAttributes.MultipleDocumentHandlingType
    • java.awt.JobAttributes.SidesType
    • javax.imageio.plugins.jpeg.JPEGHuffmanTable
    • javax.imageio.plugins.jpeg.JPEGQTable
    • javax.swing.JRootPane.RootLayout (implements java.awt.LayoutManager2, java.io.Serializable)
    • javax.swing.JTabbedPane.ModelListener (implements javax.swing.event.ChangeListener, java.io.Serializable)
    • javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange (implements javax.accessibility.AccessibleTableModelChange)
    • javax.swing.text.JTextComponent.KeyBinding
    • javax.swing.JTree.TreeModelHandler (implements javax.swing.event.TreeModelListener)
    • javax.swing.JTree.TreeSelectionRedirector (implements java.io.Serializable, javax.swing.event.TreeSelectionListener)
    • java.time.temporal.JulianFields
    • javax.security.auth.kerberos.KerberosKey (implements javax.security.auth.Destroyable, javax.crypto.SecretKey)
    • javax.security.auth.kerberos.KerberosPrincipal (implements java.security.Principal, java.io.Serializable)
    • javax.security.auth.kerberos.KerberosTicket (implements javax.security.auth.Destroyable, javax.security.auth.Refreshable, java.io.Serializable)
    • java.awt.image.Kernel (implements java.lang.Cloneable)
    • java.awt.event.KeyAdapter (implements java.awt.event.KeyListener)
      • javax.swing.plaf.basic.BasicComboBoxUI.KeyHandler
      • javax.swing.plaf.basic.BasicComboPopup.InvocationKeyHandler
      • javax.swing.plaf.basic.BasicTreeUI.KeyHandler
    • javax.crypto.KeyAgreement
    • javax.crypto.KeyAgreementSpi
    • java.awt.KeyboardFocusManager (implements java.awt.KeyEventDispatcher, java.awt.KeyEventPostProcessor)
      • java.awt.DefaultKeyboardFocusManager
        • javax.swing.FocusManager
          • javax.swing.DefaultFocusManager
    • java.security.KeyFactory
    • java.security.KeyFactorySpi
    • javax.crypto.KeyGenerator
    • javax.crypto.KeyGeneratorSpi
    • javax.xml.crypto.dsig.keyinfo.KeyInfoFactory
    • javax.net.ssl.KeyManagerFactory
    • javax.net.ssl.KeyManagerFactorySpi
    • java.security.KeyPair (implements java.io.Serializable)
    • java.security.KeyPairGeneratorSpi
      • java.security.KeyPairGenerator
    • java.security.KeyRep (implements java.io.Serializable)
    • javax.xml.crypto.KeySelector
    • javax.xml.crypto.KeySelector.Purpose
    • java.security.KeyStore
    • java.security.KeyStore.Builder
    • java.security.KeyStore.CallbackHandlerProtection (implements java.security.KeyStore.ProtectionParameter)
    • java.security.KeyStore.PasswordProtection (implements javax.security.auth.Destroyable, java.security.KeyStore.ProtectionParameter)
    • java.security.KeyStore.PrivateKeyEntry (implements java.security.KeyStore.Entry)
    • java.security.KeyStore.SecretKeyEntry (implements java.security.KeyStore.Entry)
    • java.security.KeyStore.TrustedCertificateEntry (implements java.security.KeyStore.Entry)
    • javax.net.ssl.KeyStoreBuilderParameters (implements javax.net.ssl.ManagerFactoryParameters)
    • java.security.KeyStoreSpi
    • javax.security.auth.kerberos.KeyTab
    • java.lang.invoke.LambdaMetafactory
    • javax.security.auth.callback.LanguageCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
    • javax.swing.text.LayeredHighlighter (implements javax.swing.text.Highlighter)
      • javax.swing.text.DefaultHighlighter
        • javax.swing.plaf.basic.BasicTextUI.BasicHighlighter (implements javax.swing.plaf.UIResource)
    • javax.swing.text.LayeredHighlighter.LayerPainter (implements javax.swing.text.Highlighter.HighlightPainter)
      • javax.swing.text.DefaultHighlighter.DefaultHighlightPainter
    • java.awt.font.LayoutPath
    • javax.swing.text.LayoutQueue
    • javax.swing.LayoutStyle
    • java.security.cert.LDAPCertStoreParameters (implements java.security.cert.CertStoreParameters)
    • javax.naming.ldap.LdapName (implements javax.naming.Name)
    • java.rmi.dgc.Lease (implements java.io.Serializable)
    • java.util.logging.Level (implements java.io.Serializable)
    • org.omg.PortableServer.LifespanPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • javax.sound.sampled.Line.Info
      • javax.sound.sampled.DataLine.Info
      • javax.sound.sampled.Port.Info
    • java.awt.geom.Line2D (implements java.lang.Cloneable, java.awt.Shape)
      • java.awt.geom.Line2D.Double (implements java.io.Serializable)
      • java.awt.geom.Line2D.Float (implements java.io.Serializable)
    • java.awt.font.LineBreakMeasurer
    • javax.sound.sampled.LineEvent.Type
    • java.awt.font.LineMetrics
    • java.time.LocalDate (implements java.time.chrono.ChronoLocalDate, java.io.Serializable, java.time.temporal.Temporal, java.time.temporal.TemporalAdjuster)
    • java.time.LocalDateTime (implements java.time.chrono.ChronoLocalDateTime<D>, java.io.Serializable, java.time.temporal.Temporal, java.time.temporal.TemporalAdjuster)
    • java.util.Locale (implements java.lang.Cloneable, java.io.Serializable)
    • java.util.Locale.Builder
    • java.util.Locale.LanguageRange
    • java.util.spi.LocaleServiceProvider
      • java.text.spi.BreakIteratorProvider
      • java.util.spi.CalendarDataProvider
      • java.util.spi.CalendarNameProvider
      • java.text.spi.CollatorProvider
      • java.util.spi.CurrencyNameProvider
      • java.text.spi.DateFormatProvider
      • java.text.spi.DateFormatSymbolsProvider
      • java.text.spi.DecimalFormatSymbolsProvider
      • java.util.spi.LocaleNameProvider
      • java.text.spi.NumberFormatProvider
      • java.util.spi.TimeZoneNameProvider
    • org.omg.CORBA.LocalObject (implements org.omg.CORBA.Object)
    • java.time.LocalTime (implements java.lang.Comparable<T>, java.io.Serializable, java.time.temporal.Temporal, java.time.temporal.TemporalAdjuster)
    • java.rmi.registry.LocateRegistry
    • org.xml.sax.helpers.LocatorImpl (implements org.xml.sax.Locator)
      • org.xml.sax.ext.Locator2Impl (implements org.xml.sax.ext.Locator2)
    • java.lang.management.LockInfo
      • java.lang.management.MonitorInfo
    • java.util.concurrent.locks.LockSupport
    • java.util.logging.Logger
    • javax.security.auth.login.LoginContext
    • java.util.logging.LogManager
    • java.util.logging.LogRecord (implements java.io.Serializable)
    • org.omg.CORBA.LongHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.LongLongSeqHelper
    • org.omg.CORBA.LongLongSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.LongSeqHelper
    • org.omg.CORBA.LongSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • java.util.LongSummaryStatistics (implements java.util.function.IntConsumer, java.util.function.LongConsumer)
    • javax.swing.LookAndFeel
      • javax.swing.plaf.basic.BasicLookAndFeel (implements java.io.Serializable)
        • javax.swing.plaf.metal.MetalLookAndFeel
        • javax.swing.plaf.synth.SynthLookAndFeel
          • javax.swing.plaf.nimbus.NimbusLookAndFeel
      • javax.swing.plaf.multi.MultiLookAndFeel
    • java.awt.image.LookupOp (implements java.awt.image.BufferedImageOp, java.awt.image.RasterOp)
    • java.awt.image.LookupTable
      • java.awt.image.ByteLookupTable
      • java.awt.image.ShortLookupTable
    • javax.crypto.Mac (implements java.lang.Cloneable)
    • javax.crypto.MacSpi
    • java.lang.management.ManagementFactory
    • java.util.jar.Manifest (implements java.lang.Cloneable)
    • java.rmi.MarshalledObject<T> (implements java.io.Serializable)
    • javax.xml.bind.Marshaller.Listener
    • java.util.regex.Matcher (implements java.util.regex.MatchResult)
    • java.lang.Math
    • java.math.MathContext (implements java.io.Serializable)
    • javax.management.MBeanFeatureInfo (implements javax.management.DescriptorRead, java.io.Serializable)
      • javax.management.MBeanAttributeInfo (implements java.lang.Cloneable)
        • javax.management.modelmbean.ModelMBeanAttributeInfo (implements javax.management.DescriptorAccess)
        • javax.management.openmbean.OpenMBeanAttributeInfoSupport (implements javax.management.openmbean.OpenMBeanAttributeInfo)
      • javax.management.MBeanConstructorInfo (implements java.lang.Cloneable)
        • javax.management.modelmbean.ModelMBeanConstructorInfo (implements javax.management.DescriptorAccess)
        • javax.management.openmbean.OpenMBeanConstructorInfoSupport (implements javax.management.openmbean.OpenMBeanConstructorInfo)
      • javax.management.MBeanNotificationInfo (implements java.lang.Cloneable)
        • javax.management.modelmbean.ModelMBeanNotificationInfo (implements javax.management.DescriptorAccess)
      • javax.management.MBeanOperationInfo (implements java.lang.Cloneable)
        • javax.management.modelmbean.ModelMBeanOperationInfo (implements javax.management.DescriptorAccess)
        • javax.management.openmbean.OpenMBeanOperationInfoSupport (implements javax.management.openmbean.OpenMBeanOperationInfo)
      • javax.management.MBeanParameterInfo (implements java.lang.Cloneable)
        • javax.management.openmbean.OpenMBeanParameterInfoSupport (implements javax.management.openmbean.OpenMBeanParameterInfo)
    • javax.management.MBeanInfo (implements java.lang.Cloneable, javax.management.DescriptorRead, java.io.Serializable)
      • javax.management.modelmbean.ModelMBeanInfoSupport (implements javax.management.modelmbean.ModelMBeanInfo)
      • javax.management.openmbean.OpenMBeanInfoSupport (implements javax.management.openmbean.OpenMBeanInfo)
    • javax.management.MBeanServerBuilder
    • javax.management.MBeanServerDelegate (implements javax.management.MBeanServerDelegateMBean, javax.management.NotificationEmitter)
    • javax.management.MBeanServerFactory
    • javax.management.MBeanServerInvocationHandler (implements java.lang.reflect.InvocationHandler)
    • javax.print.attribute.standard.MediaPrintableArea (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
    • javax.print.attribute.standard.MediaSize.Engineering
    • javax.print.attribute.standard.MediaSize.ISO
    • javax.print.attribute.standard.MediaSize.JIS
    • javax.print.attribute.standard.MediaSize.NA
    • javax.print.attribute.standard.MediaSize.Other
    • java.awt.MediaTracker (implements java.io.Serializable)
    • java.nio.channels.MembershipKey
    • java.awt.image.MemoryImageSource (implements java.awt.image.ImageProducer)
    • java.lang.management.MemoryNotificationInfo
    • java.lang.management.MemoryUsage
    • java.awt.MenuComponent (implements java.io.Serializable)
      • java.awt.MenuBar (implements javax.accessibility.Accessible, java.awt.MenuContainer)
      • java.awt.MenuItem (implements javax.accessibility.Accessible)
        • java.awt.CheckboxMenuItem (implements javax.accessibility.Accessible, java.awt.ItemSelectable)
        • java.awt.Menu (implements javax.accessibility.Accessible, java.awt.MenuContainer)
          • java.awt.PopupMenu
    • javax.swing.MenuSelectionManager
    • java.awt.MenuShortcut (implements java.io.Serializable)
    • java.security.MessageDigestSpi
      • java.security.MessageDigest
    • javax.xml.soap.MessageFactory
    • org.ietf.jgss.MessageProp
    • javax.swing.plaf.metal.MetalBorders
    • javax.swing.plaf.metal.MetalCheckBoxIcon (implements javax.swing.Icon, java.io.Serializable, javax.swing.plaf.UIResource)
    • javax.swing.plaf.metal.MetalComboBoxIcon (implements javax.swing.Icon, java.io.Serializable)
    • javax.swing.plaf.metal.MetalIconFactory (implements java.io.Serializable)
    • javax.swing.plaf.metal.MetalIconFactory.FileIcon16 (implements javax.swing.Icon, java.io.Serializable)
      • javax.swing.plaf.metal.MetalIconFactory.TreeLeafIcon
    • javax.swing.plaf.metal.MetalIconFactory.FolderIcon16 (implements javax.swing.Icon, java.io.Serializable)
      • javax.swing.plaf.metal.MetalIconFactory.TreeFolderIcon
    • javax.swing.plaf.metal.MetalIconFactory.PaletteCloseIcon (implements javax.swing.Icon, java.io.Serializable, javax.swing.plaf.UIResource)
    • javax.swing.plaf.metal.MetalIconFactory.TreeControlIcon (implements javax.swing.Icon, java.io.Serializable)
    • javax.swing.plaf.metal.MetalTheme
      • javax.swing.plaf.metal.DefaultMetalTheme
        • javax.swing.plaf.metal.OceanTheme
    • java.lang.invoke.MethodHandle
    • java.lang.invoke.MethodHandleProxies
    • java.lang.invoke.MethodHandles
    • java.lang.invoke.MethodHandles.Lookup
    • java.lang.invoke.MethodType (implements java.io.Serializable)
    • java.security.spec.MGF1ParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • javax.sound.midi.MidiDevice.Info
    • javax.sound.midi.spi.MidiDeviceProvider
    • javax.sound.midi.MidiEvent
    • javax.sound.midi.MidiFileFormat
    • javax.sound.midi.spi.MidiFileReader
    • javax.sound.midi.spi.MidiFileWriter
    • javax.sound.midi.MidiMessage (implements java.lang.Cloneable)
      • javax.sound.midi.MetaMessage
      • javax.sound.midi.ShortMessage
      • javax.sound.midi.SysexMessage
    • javax.sound.midi.MidiSystem
    • javax.xml.soap.MimeHeader
    • javax.xml.soap.MimeHeaders
    • javax.activation.MimeType (implements java.io.Externalizable)
    • javax.activation.MimeTypeParameterList
    • java.time.chrono.MinguoDate (implements java.time.chrono.ChronoLocalDate, java.io.Serializable)
    • javax.sound.sampled.Mixer.Info
    • javax.sound.sampled.spi.MixerProvider
    • javax.management.loading.MLetContent
    • javax.naming.directory.ModificationItem (implements java.io.Serializable)
    • java.lang.reflect.Modifier
    • java.time.MonthDay (implements java.lang.Comparable<T>, java.io.Serializable, java.time.temporal.TemporalAccessor, java.time.temporal.TemporalAdjuster)
    • java.awt.event.MouseAdapter (implements java.awt.event.MouseListener, java.awt.event.MouseMotionListener, java.awt.event.MouseWheelListener)
      • javax.swing.plaf.basic.BasicComboPopup.InvocationMouseHandler
      • javax.swing.plaf.basic.BasicComboPopup.ListMouseHandler
      • javax.swing.plaf.basic.BasicFileChooserUI.DoubleClickListener
      • javax.swing.plaf.basic.BasicScrollBarUI.ArrowButtonListener
      • javax.swing.plaf.basic.BasicScrollBarUI.TrackListener (implements java.awt.event.MouseMotionListener)
      • javax.swing.plaf.basic.BasicSplitPaneDivider.MouseHandler (implements java.awt.event.MouseMotionListener)
      • javax.swing.plaf.basic.BasicTabbedPaneUI.MouseHandler
      • javax.swing.plaf.basic.BasicTreeUI.MouseHandler (implements java.awt.event.MouseMotionListener)
      • javax.swing.text.html.FormView.MouseEventListener
      • javax.swing.text.html.HTMLEditorKit.LinkController (implements java.awt.event.MouseMotionListener, java.io.Serializable)
      • javax.swing.plaf.metal.MetalFileChooserUI.SingleClickListener
      • javax.swing.event.MouseInputAdapter (implements javax.swing.event.MouseInputListener)
        • javax.swing.plaf.basic.BasicDesktopIconUI.MouseInputHandler
        • javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener (implements javax.swing.SwingConstants)
        • javax.swing.plaf.basic.BasicSliderUI.TrackListener
      • javax.swing.ToolTipManager (implements java.awt.event.MouseMotionListener)
    • java.awt.MouseInfo
    • java.awt.event.MouseMotionAdapter (implements java.awt.event.MouseMotionListener)
      • javax.swing.plaf.basic.BasicComboPopup.InvocationMouseMotionHandler
      • javax.swing.plaf.basic.BasicComboPopup.ListMouseMotionHandler
    • org.omg.IOP.MultipleComponentProfileHelper
    • org.omg.IOP.MultipleComponentProfileHolder (implements org.omg.CORBA.portable.Streamable)
    • java.awt.MultipleGradientPaint (implements java.awt.Paint)
      • java.awt.LinearGradientPaint
      • java.awt.RadialGradientPaint
    • javax.security.auth.callback.NameCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
    • javax.naming.NameClassPair (implements java.io.Serializable)
      • javax.naming.Binding
        • javax.naming.directory.SearchResult
    • org.omg.CosNaming.NameComponent (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CosNaming.NameComponentHelper
    • org.omg.CosNaming.NameComponentHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.NamedValue
    • org.omg.DynamicAny.NameDynAnyPair (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.NameDynAnyPairHelper
    • org.omg.DynamicAny.NameDynAnyPairSeqHelper
    • org.omg.CosNaming.NameHelper
    • org.omg.CosNaming.NameHolder (implements org.omg.CORBA.portable.Streamable)
    • org.xml.sax.helpers.NamespaceSupport
    • org.omg.CORBA.NameValuePair (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.NameValuePair (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.NameValuePairHelper
    • org.omg.DynamicAny.NameValuePairHelper
    • org.omg.DynamicAny.NameValuePairSeqHelper
    • java.rmi.Naming
    • org.omg.CosNaming.NamingContextExtHelper
    • org.omg.CosNaming.NamingContextExtHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NamingContextHelper
    • org.omg.CosNaming.NamingContextHolder (implements org.omg.CORBA.portable.Streamable)
    • javax.naming.spi.NamingManager
      • javax.naming.spi.DirectoryManager
    • javax.swing.text.NavigationFilter
    • javax.swing.text.NavigationFilter.FilterBypass
    • java.net.NetworkInterface
    • org.omg.PortableServer.CurrentPackage.NoContextHelper
    • java.text.Normalizer
    • org.omg.PortableServer.POAPackage.NoServantHelper
    • org.omg.CosNaming.NamingContextPackage.NotEmptyHelper
    • org.omg.CosNaming.NamingContextPackage.NotEmptyHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NamingContextPackage.NotFoundHelper
    • org.omg.CosNaming.NamingContextPackage.NotFoundHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NamingContextPackage.NotFoundReason (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper
    • org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder (implements org.omg.CORBA.portable.Streamable)
    • javax.management.NotificationBroadcasterSupport (implements javax.management.NotificationEmitter)
      • javax.management.remote.JMXConnectorServer (implements javax.management.remote.JMXAddressable, javax.management.remote.JMXConnectorServerMBean, javax.management.MBeanRegistration)
        • javax.management.remote.rmi.RMIConnectorServer
      • javax.management.monitor.Monitor (implements javax.management.MBeanRegistration, javax.management.monitor.MonitorMBean)
        • javax.management.monitor.CounterMonitor (implements javax.management.monitor.CounterMonitorMBean)
        • javax.management.monitor.GaugeMonitor (implements javax.management.monitor.GaugeMonitorMBean)
        • javax.management.monitor.StringMonitor (implements javax.management.monitor.StringMonitorMBean)
      • javax.management.relation.RelationService (implements javax.management.MBeanRegistration, javax.management.NotificationListener, javax.management.relation.RelationServiceMBean)
      • javax.management.timer.Timer (implements javax.management.MBeanRegistration, javax.management.timer.TimerMBean)
    • javax.management.NotificationFilterSupport (implements javax.management.NotificationFilter)
      • javax.management.relation.MBeanServerNotificationFilter
    • javax.management.remote.NotificationResult (implements java.io.Serializable)
    • java.lang.Number (implements java.io.Serializable)
      • java.util.concurrent.atomic.AtomicInteger (implements java.io.Serializable)
      • java.util.concurrent.atomic.AtomicLong (implements java.io.Serializable)
      • java.math.BigDecimal (implements java.lang.Comparable<T>)
      • java.math.BigInteger (implements java.lang.Comparable<T>)
      • java.lang.Byte (implements java.lang.Comparable<T>)
      • java.lang.Double (implements java.lang.Comparable<T>)
      • java.util.concurrent.atomic.DoubleAccumulator (implements java.io.Serializable)
      • java.util.concurrent.atomic.DoubleAdder (implements java.io.Serializable)
      • java.lang.Float (implements java.lang.Comparable<T>)
      • java.lang.Integer (implements java.lang.Comparable<T>)
      • java.lang.Long (implements java.lang.Comparable<T>)
      • java.util.concurrent.atomic.LongAccumulator (implements java.io.Serializable)
      • java.util.concurrent.atomic.LongAdder (implements java.io.Serializable)
      • java.lang.Short (implements java.lang.Comparable<T>)
    • java.awt.font.NumericShaper (implements java.io.Serializable)
    • org.omg.CORBA.NVList
    • javax.crypto.spec.OAEPParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper
    • org.omg.CORBA.ObjectHelper
    • org.omg.CORBA.ObjectHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.PortableInterceptor.ObjectIdHelper
    • org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper
    • org.omg.CORBA.portable.ObjectImpl (implements org.omg.CORBA.Object)
      • org.omg.CosNaming._BindingIteratorStub (implements org.omg.CosNaming.BindingIterator)
      • org.omg.DynamicAny._DynAnyFactoryStub (implements org.omg.DynamicAny.DynAnyFactory)
      • org.omg.DynamicAny._DynAnyStub (implements org.omg.DynamicAny.DynAny)
      • org.omg.DynamicAny._DynArrayStub (implements org.omg.DynamicAny.DynArray)
      • org.omg.DynamicAny._DynEnumStub (implements org.omg.DynamicAny.DynEnum)
      • org.omg.DynamicAny._DynFixedStub (implements org.omg.DynamicAny.DynFixed)
      • org.omg.DynamicAny._DynSequenceStub (implements org.omg.DynamicAny.DynSequence)
      • org.omg.DynamicAny._DynStructStub (implements org.omg.DynamicAny.DynStruct)
      • org.omg.DynamicAny._DynUnionStub (implements org.omg.DynamicAny.DynUnion)
      • org.omg.DynamicAny._DynValueStub (implements org.omg.DynamicAny.DynValue)
      • org.omg.CORBA._IDLTypeStub (implements org.omg.CORBA.IDLType)
      • org.omg.CosNaming._NamingContextExtStub (implements org.omg.CosNaming.NamingContextExt)
      • org.omg.CosNaming._NamingContextStub (implements org.omg.CosNaming.NamingContext)
      • org.omg.CORBA._PolicyStub (implements org.omg.CORBA.Policy)
      • org.omg.PortableServer._ServantActivatorStub (implements org.omg.PortableServer.ServantActivator)
      • org.omg.PortableServer._ServantLocatorStub (implements org.omg.PortableServer.ServantLocator)
      • org.omg.CORBA.DynamicImplementation
        • org.omg.CosNaming._BindingIteratorImplBase (implements org.omg.CosNaming.BindingIterator)
        • org.omg.CosNaming._NamingContextImplBase (implements org.omg.CosNaming.NamingContext)
      • org.omg.CORBA_2_3.portable.ObjectImpl
        • javax.rmi.CORBA.Stub (implements java.io.Serializable)
          • org.omg.stub.java.rmi._Remote_Stub (implements java.rmi.Remote)
    • java.io.ObjectInputStream.GetField
    • javax.management.ObjectInstance (implements java.io.Serializable)
    • javax.management.ObjectName (implements java.lang.Comparable<T>, javax.management.QueryExp)
    • org.omg.PortableServer.POAPackage.ObjectNotActiveHelper
    • java.io.ObjectOutputStream.PutField
    • org.omg.PortableInterceptor.ObjectReferenceFactoryHelper
    • org.omg.PortableInterceptor.ObjectReferenceFactoryHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.PortableInterceptor.ObjectReferenceTemplateHelper
    • org.omg.PortableInterceptor.ObjectReferenceTemplateHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper
    • org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • java.util.Objects
    • java.io.ObjectStreamClass (implements java.io.Serializable)
    • java.io.ObjectStreamField (implements java.lang.Comparable<T>)
    • java.rmi.server.ObjID (implements java.io.Serializable)
    • java.util.Observable
    • org.omg.CORBA.OctetSeqHelper
    • org.omg.CORBA.OctetSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • javax.xml.crypto.OctetStreamData (implements javax.xml.crypto.Data)
    • java.time.OffsetDateTime (implements java.lang.Comparable<T>, java.io.Serializable, java.time.temporal.Temporal, java.time.temporal.TemporalAdjuster)
    • java.time.OffsetTime (implements java.lang.Comparable<T>, java.io.Serializable, java.time.temporal.Temporal, java.time.temporal.TemporalAdjuster)
    • org.ietf.jgss.Oid
    • javax.management.openmbean.OpenType<T> (implements java.io.Serializable)
      • javax.management.openmbean.ArrayType<T>
      • javax.management.openmbean.CompositeType
      • javax.management.openmbean.SimpleType<T>
      • javax.management.openmbean.TabularType
    • java.rmi.server.Operation
    • javax.swing.text.html.Option (implements java.io.Serializable)
    • java.util.Optional<T>
    • java.util.OptionalDouble
    • java.util.OptionalInt
    • java.util.OptionalLong
    • org.omg.CORBA.ORB
      • org.omg.CORBA_2_3.ORB
    • org.omg.PortableInterceptor.ORBIdHelper
    • javax.xml.transform.OutputKeys
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • java.io.ByteArrayOutputStream
      • java.io.FileOutputStream
      • java.io.FilterOutputStream
        • java.io.BufferedOutputStream
        • java.util.zip.CheckedOutputStream
        • javax.crypto.CipherOutputStream
        • java.io.DataOutputStream (implements java.io.DataOutput)
        • java.util.zip.DeflaterOutputStream
          • java.util.zip.GZIPOutputStream
          • java.util.zip.ZipOutputStream
            • java.util.jar.JarOutputStream
        • java.security.DigestOutputStream
        • java.util.zip.InflaterOutputStream
        • java.io.PrintStream (implements java.lang.Appendable, java.io.Closeable)
          • java.rmi.server.LogStream
      • java.io.ObjectOutputStream (implements java.io.ObjectOutput, java.io.ObjectStreamConstants)
      • org.omg.CORBA.portable.OutputStream
        • org.omg.CORBA_2_3.portable.OutputStream
      • java.io.PipedOutputStream
    • javax.swing.OverlayLayout (implements java.awt.LayoutManager2, java.io.Serializable)
    • java.util.jar.Pack200
    • java.lang.Package (implements java.lang.reflect.AnnotatedElement)
    • java.awt.PageAttributes (implements java.lang.Cloneable)
    • java.awt.PageAttributes.ColorType
    • java.awt.PageAttributes.MediaType
    • java.awt.PageAttributes.OrientationRequestedType
    • java.awt.PageAttributes.OriginType
    • java.awt.PageAttributes.PrintQualityType
    • java.awt.print.PageFormat (implements java.lang.Cloneable)
    • java.awt.print.Paper (implements java.lang.Cloneable)
    • java.lang.reflect.Parameter (implements java.lang.reflect.AnnotatedElement)
    • org.omg.Dynamic.Parameter (implements org.omg.CORBA.portable.IDLEntity)
    • java.awt.image.renderable.ParameterBlock (implements java.lang.Cloneable, java.io.Serializable)
    • org.omg.CORBA.ParameterMode (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.ParameterModeHelper
    • org.omg.CORBA.ParameterModeHolder (implements org.omg.CORBA.portable.Streamable)
    • java.text.ParsePosition
    • javax.swing.text.html.parser.Parser (implements javax.swing.text.html.parser.DTDConstants)
      • javax.swing.text.html.parser.DocumentParser
    • org.xml.sax.helpers.ParserAdapter (implements org.xml.sax.DocumentHandler, org.xml.sax.XMLReader)
    • org.xml.sax.helpers.ParserFactory
    • java.net.PasswordAuthentication
    • javax.security.auth.callback.PasswordCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
    • javax.sound.midi.Patch
    • java.awt.geom.Path2D (implements java.lang.Cloneable, java.awt.Shape)
      • java.awt.geom.Path2D.Double (implements java.io.Serializable)
      • java.awt.geom.Path2D.Float (implements java.io.Serializable)
        • java.awt.geom.GeneralPath
    • java.nio.file.Paths
    • java.util.regex.Pattern (implements java.io.Serializable)
    • javax.crypto.spec.PBEKeySpec (implements java.security.spec.KeySpec)
    • javax.crypto.spec.PBEParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • java.time.Period (implements java.time.chrono.ChronoPeriod, java.io.Serializable)
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.AllPermission
      • java.security.BasicPermission (implements java.io.Serializable)
        • javax.sound.sampled.AudioPermission
        • javax.security.auth.AuthPermission
        • java.awt.AWTPermission
        • javax.security.auth.kerberos.DelegationPermission (implements java.io.Serializable)
        • javax.xml.bind.JAXBPermission
        • java.nio.file.LinkPermission
        • java.util.logging.LoggingPermission
        • java.lang.management.ManagementPermission
        • javax.management.MBeanServerPermission
        • javax.management.MBeanTrustPermission
        • java.net.NetPermission
        • java.util.PropertyPermission
        • java.lang.reflect.ReflectPermission
        • java.lang.RuntimePermission
        • java.security.SecurityPermission
        • java.io.SerializablePermission
        • java.sql.SQLPermission
        • javax.net.ssl.SSLPermission
        • javax.management.remote.SubjectDelegationPermission
        • javax.xml.ws.WebServicePermission
      • java.io.FilePermission (implements java.io.Serializable)
      • javax.management.MBeanPermission
      • javax.security.auth.PrivateCredentialPermission
      • javax.security.auth.kerberos.ServicePermission (implements java.io.Serializable)
      • java.net.SocketPermission (implements java.io.Serializable)
      • java.security.UnresolvedPermission (implements java.io.Serializable)
      • java.net.URLPermission
    • java.security.PermissionCollection (implements java.io.Serializable)
      • java.security.Permissions (implements java.io.Serializable)
    • java.beans.PersistenceDelegate
      • java.beans.DefaultPersistenceDelegate
    • java.util.concurrent.Phaser
    • java.nio.channels.Pipe
    • java.awt.image.PixelGrabber (implements java.awt.image.ImageConsumer)
    • java.security.PKCS12Attribute (implements java.security.KeyStore.Entry.Attribute)
    • java.security.cert.PKIXCertPathChecker (implements java.security.cert.CertPathChecker, java.lang.Cloneable)
      • java.security.cert.PKIXRevocationChecker
    • java.security.cert.PKIXCertPathValidatorResult (implements java.security.cert.CertPathValidatorResult)
      • java.security.cert.PKIXCertPathBuilderResult (implements java.security.cert.CertPathBuilderResult)
    • java.security.cert.PKIXParameters (implements java.security.cert.CertPathParameters)
      • java.security.cert.PKIXBuilderParameters
    • org.omg.PortableServer.POAHelper
    • java.awt.geom.Point2D (implements java.lang.Cloneable)
      • java.awt.Point (implements java.io.Serializable)
      • java.awt.geom.Point2D.Double (implements java.io.Serializable)
      • java.awt.geom.Point2D.Float (implements java.io.Serializable)
    • java.awt.PointerInfo
    • java.security.Policy
    • javax.security.auth.Policy
    • org.omg.CORBA.PolicyErrorCodeHelper
    • org.omg.CORBA.PolicyErrorHelper
    • org.omg.CORBA.PolicyErrorHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.PolicyHelper
    • org.omg.CORBA.PolicyHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.PolicyListHelper
    • org.omg.CORBA.PolicyListHolder (implements org.omg.CORBA.portable.Streamable)
    • java.security.cert.PolicyQualifierInfo
    • java.security.PolicySpi
    • org.omg.CORBA.PolicyTypeHelper
    • java.awt.Polygon (implements java.io.Serializable, java.awt.Shape)
    • javax.swing.Popup
    • javax.swing.PopupFactory
    • javax.rmi.PortableRemoteObject
    • javax.swing.text.Position.Bias
    • java.nio.file.attribute.PosixFilePermissions
    • java.util.prefs.Preferences
      • java.util.prefs.AbstractPreferences
    • org.omg.CORBA.Principal
    • org.omg.CORBA.PrincipalHolder (implements org.omg.CORBA.portable.Streamable)
    • java.awt.print.PrinterJob
    • java.awt.PrintJob
    • javax.print.event.PrintJobAdapter (implements javax.print.event.PrintJobListener)
    • javax.print.PrintServiceLookup
    • java.lang.Process
    • java.lang.ProcessBuilder
    • java.lang.ProcessBuilder.Redirect
    • org.omg.IOP.ProfileIdHelper
    • javax.swing.ProgressMonitor (implements javax.accessibility.Accessible)
    • java.beans.PropertyChangeSupport (implements java.io.Serializable)
      • javax.swing.event.SwingPropertyChangeSupport
    • java.beans.PropertyEditorManager
    • java.beans.PropertyEditorSupport (implements java.beans.PropertyEditor)
    • java.security.ProtectionDomain
    • javax.xml.ws.spi.Provider
    • java.security.Provider.Service
    • java.lang.reflect.Proxy (implements java.io.Serializable)
    • java.net.Proxy
    • java.net.ProxySelector
    • javax.crypto.spec.PSource
      • javax.crypto.spec.PSource.PSpecified
    • java.security.spec.PSSParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • javax.xml.namespace.QName (implements java.io.Serializable)
    • java.awt.geom.QuadCurve2D (implements java.lang.Cloneable, java.awt.Shape)
      • java.awt.geom.QuadCurve2D.Double (implements java.io.Serializable)
      • java.awt.geom.QuadCurve2D.Float (implements java.io.Serializable)
    • javax.management.Query
    • javax.management.QueryEval (implements java.io.Serializable)
    • java.util.Random (implements java.io.Serializable)
      • java.security.SecureRandom
      • java.util.concurrent.ThreadLocalRandom
    • java.io.RandomAccessFile (implements java.io.Closeable, java.io.DataInput, java.io.DataOutput)
    • java.awt.image.Raster
      • java.awt.image.WritableRaster
    • javax.crypto.spec.RC2ParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • javax.crypto.spec.RC5ParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • javax.naming.ldap.Rdn (implements java.lang.Comparable<T>, java.io.Serializable)
    • java.io.Reader (implements java.io.Closeable, java.lang.Readable)
      • java.io.BufferedReader
        • java.io.LineNumberReader
      • java.io.CharArrayReader
      • java.io.FilterReader
        • java.io.PushbackReader
      • java.io.InputStreamReader
        • java.io.FileReader
      • java.io.PipedReader
      • java.io.StringReader
    • java.awt.geom.RectangularShape (implements java.lang.Cloneable, java.awt.Shape)
      • java.awt.geom.Arc2D
        • java.awt.geom.Arc2D.Double (implements java.io.Serializable)
        • java.awt.geom.Arc2D.Float (implements java.io.Serializable)
      • java.awt.geom.Ellipse2D
        • java.awt.geom.Ellipse2D.Double (implements java.io.Serializable)
        • java.awt.geom.Ellipse2D.Float (implements java.io.Serializable)
      • java.awt.geom.Rectangle2D
        • java.awt.Rectangle (implements java.io.Serializable, java.awt.Shape)
          • javax.swing.text.DefaultCaret (implements javax.swing.text.Caret, java.awt.event.FocusListener, java.awt.event.MouseListener, java.awt.event.MouseMotionListener)
            • javax.swing.plaf.basic.BasicTextUI.BasicCaret (implements javax.swing.plaf.UIResource)
        • java.awt.geom.Rectangle2D.Double (implements java.io.Serializable)
        • java.awt.geom.Rectangle2D.Float (implements java.io.Serializable)
      • java.awt.geom.RoundRectangle2D
        • java.awt.geom.RoundRectangle2D.Double (implements java.io.Serializable)
        • java.awt.geom.RoundRectangle2D.Float (implements java.io.Serializable)
    • java.util.concurrent.locks.ReentrantLock (implements java.util.concurrent.locks.Lock, java.io.Serializable)
    • java.util.concurrent.locks.ReentrantReadWriteLock (implements java.util.concurrent.locks.ReadWriteLock, java.io.Serializable)
    • java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock (implements java.util.concurrent.locks.Lock, java.io.Serializable)
    • java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock (implements java.util.concurrent.locks.Lock, java.io.Serializable)
    • javax.naming.RefAddr (implements java.io.Serializable)
      • javax.naming.BinaryRefAddr
      • javax.naming.StringRefAddr
    • java.lang.ref.Reference<T>
      • java.lang.ref.PhantomReference<T>
      • java.lang.ref.SoftReference<T>
      • java.lang.ref.WeakReference<T>
    • javax.naming.Reference (implements java.lang.Cloneable, java.io.Serializable)
      • javax.naming.LinkRef
    • java.lang.ref.ReferenceQueue<T>
    • javax.swing.plaf.synth.Region
    • javax.management.relation.RelationSupport (implements javax.management.MBeanRegistration, javax.management.relation.RelationSupportMBean)
    • javax.management.relation.RelationTypeSupport (implements javax.management.relation.RelationType)
    • java.rmi.server.RemoteObject (implements java.rmi.Remote, java.io.Serializable)
      • java.rmi.server.RemoteObjectInvocationHandler (implements java.lang.reflect.InvocationHandler)
      • java.rmi.server.RemoteServer
        • java.rmi.activation.Activatable
        • java.rmi.server.UnicastRemoteObject
          • java.rmi.activation.ActivationGroup (implements java.rmi.activation.ActivationInstantiator)
      • java.rmi.server.RemoteStub
        • java.rmi.activation.ActivationGroup_Stub (implements java.rmi.activation.ActivationInstantiator, java.rmi.Remote)
        • javax.management.remote.rmi.RMIConnectionImpl_Stub (implements javax.management.remote.rmi.RMIConnection)
        • javax.management.remote.rmi.RMIServerImpl_Stub (implements javax.management.remote.rmi.RMIServer)
    • java.awt.image.renderable.RenderableImageOp (implements java.awt.image.renderable.RenderableImage)
    • java.awt.image.renderable.RenderableImageProducer (implements java.awt.image.ImageProducer, java.lang.Runnable)
    • java.awt.image.renderable.RenderContext (implements java.lang.Cloneable)
    • java.awt.RenderingHints (implements java.lang.Cloneable, java.util.Map<K,V>)
    • java.awt.RenderingHints.Key
    • javax.swing.RepaintManager
    • org.omg.CORBA.RepositoryIdHelper
    • org.omg.CORBA.Request
    • org.omg.PortableServer.RequestProcessingPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • javax.management.modelmbean.RequiredModelMBean (implements javax.management.MBeanRegistration, javax.management.modelmbean.ModelMBean, javax.management.NotificationEmitter)
    • java.awt.image.RescaleOp (implements java.awt.image.BufferedImageOp, java.awt.image.RasterOp)
    • javax.print.attribute.ResolutionSyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.PrinterResolution (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
    • javax.naming.spi.ResolveResult (implements java.io.Serializable)
    • java.util.ResourceBundle
      • java.util.ListResourceBundle
        • javax.accessibility.AccessibleResourceBundle
      • java.util.PropertyResourceBundle
    • java.util.ResourceBundle.Control
    • java.net.ResponseCache
    • javax.sound.sampled.ReverbType
    • java.rmi.server.RMIClassLoader
    • java.rmi.server.RMIClassLoaderSpi
    • javax.management.remote.rmi.RMIConnectionImpl (implements javax.management.remote.rmi.RMIConnection, java.rmi.server.Unreferenced)
    • javax.management.remote.rmi.RMIConnector (implements javax.management.remote.JMXAddressable, javax.management.remote.JMXConnector, java.io.Serializable)
    • javax.management.remote.rmi.RMIServerImpl (implements java.io.Closeable, javax.management.remote.rmi.RMIServer)
      • javax.management.remote.rmi.RMIIIOPServerImpl
      • javax.management.remote.rmi.RMIJRMPServerImpl
    • java.rmi.server.RMISocketFactory (implements java.rmi.server.RMIClientSocketFactory, java.rmi.server.RMIServerSocketFactory)
    • java.awt.Robot
    • javax.management.relation.Role (implements java.io.Serializable)
    • javax.management.relation.RoleInfo (implements java.io.Serializable)
    • javax.management.relation.RoleResult (implements java.io.Serializable)
    • javax.management.relation.RoleStatus
    • javax.management.relation.RoleUnresolved (implements java.io.Serializable)
    • javax.swing.RowFilter<M,I>
    • javax.swing.RowFilter.Entry<M,I>
    • javax.sql.rowset.RowSetMetaDataImpl (implements javax.sql.RowSetMetaData, java.io.Serializable)
    • javax.sql.rowset.RowSetProvider
    • javax.swing.RowSorter<M>
      • javax.swing.DefaultRowSorter<M,I>
        • javax.swing.table.TableRowSorter<M>
    • javax.swing.RowSorter.SortKey
    • java.security.spec.RSAKeyGenParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • java.security.spec.RSAOtherPrimeInfo
    • java.security.spec.RSAPrivateKeySpec (implements java.security.spec.KeySpec)
      • java.security.spec.RSAMultiPrimePrivateCrtKeySpec
      • java.security.spec.RSAPrivateCrtKeySpec
    • java.security.spec.RSAPublicKeySpec (implements java.security.spec.KeySpec)
    • java.lang.Runtime
    • javax.xml.soap.SAAJMetaFactory
    • java.awt.image.SampleModel
      • java.awt.image.ComponentSampleModel
        • java.awt.image.BandedSampleModel
        • java.awt.image.PixelInterleavedSampleModel
      • java.awt.image.MultiPixelPackedSampleModel
      • java.awt.image.SinglePixelPackedSampleModel
    • javax.security.sasl.Sasl
    • javax.xml.parsers.SAXParser
    • javax.xml.parsers.SAXParserFactory
    • javax.xml.transform.sax.SAXResult (implements javax.xml.transform.Result)
      • javax.xml.bind.util.JAXBResult
    • javax.xml.transform.sax.SAXSource (implements javax.xml.transform.Source)
      • javax.xml.bind.util.JAXBSource
    • java.util.Scanner (implements java.io.Closeable, java.util.Iterator<E>)
    • javax.xml.validation.Schema
    • javax.xml.validation.SchemaFactory
    • javax.xml.validation.SchemaFactoryLoader
    • javax.xml.bind.SchemaOutputResolver
    • javax.script.ScriptEngineManager
    • java.awt.ScrollPaneAdjustable (implements java.awt.Adjustable, java.io.Serializable)
    • javax.swing.ScrollPaneLayout (implements java.awt.LayoutManager, javax.swing.ScrollPaneConstants, java.io.Serializable)
      • javax.swing.ScrollPaneLayout.UIResource (implements javax.swing.plaf.UIResource)
    • javax.crypto.SealedObject (implements java.io.Serializable)
    • javax.naming.directory.SearchControls (implements java.io.Serializable)
    • javax.crypto.SecretKeyFactory
    • javax.crypto.SecretKeyFactorySpi
    • javax.crypto.spec.SecretKeySpec (implements java.security.spec.KeySpec, javax.crypto.SecretKey)
    • java.security.SecureRandomSpi (implements java.io.Serializable)
    • java.security.Security
    • java.lang.SecurityManager
      • java.rmi.RMISecurityManager
    • javax.swing.text.Segment (implements java.text.CharacterIterator, java.lang.CharSequence, java.lang.Cloneable)
    • java.nio.channels.SelectionKey
      • java.nio.channels.spi.AbstractSelectionKey
    • java.nio.channels.Selector (implements java.io.Closeable)
      • java.nio.channels.spi.AbstractSelector
    • java.nio.channels.spi.SelectorProvider
    • java.util.concurrent.Semaphore (implements java.io.Serializable)
    • javax.sound.midi.Sequence
    • javax.sound.midi.Sequencer.SyncMode
    • javax.sql.rowset.serial.SerialArray (implements java.sql.Array, java.lang.Cloneable, java.io.Serializable)
    • javax.sql.rowset.serial.SerialBlob (implements java.sql.Blob, java.lang.Cloneable, java.io.Serializable)
    • javax.sql.rowset.serial.SerialClob (implements java.sql.Clob, java.lang.Cloneable, java.io.Serializable)
    • javax.sql.rowset.serial.SerialDatalink (implements java.lang.Cloneable, java.io.Serializable)
    • java.lang.invoke.SerializedLambda (implements java.io.Serializable)
    • javax.sql.rowset.serial.SerialJavaObject (implements java.lang.Cloneable, java.io.Serializable)
    • javax.sql.rowset.serial.SerialRef (implements java.lang.Cloneable, java.sql.Ref, java.io.Serializable)
    • javax.sql.rowset.serial.SerialStruct (implements java.lang.Cloneable, java.io.Serializable, java.sql.Struct)
    • org.omg.PortableServer.Servant
      • org.omg.CosNaming.BindingIteratorPOA (implements org.omg.CosNaming.BindingIteratorOperations, org.omg.CORBA.portable.InvokeHandler)
      • org.omg.PortableServer.DynamicImplementation
      • org.omg.CosNaming.NamingContextExtPOA (implements org.omg.CORBA.portable.InvokeHandler, org.omg.CosNaming.NamingContextExtOperations)
      • org.omg.CosNaming.NamingContextPOA (implements org.omg.CORBA.portable.InvokeHandler, org.omg.CosNaming.NamingContextOperations)
      • org.omg.PortableServer.ServantActivatorPOA (implements org.omg.CORBA.portable.InvokeHandler, org.omg.PortableServer.ServantActivatorOperations)
      • org.omg.PortableServer.ServantLocatorPOA (implements org.omg.CORBA.portable.InvokeHandler, org.omg.PortableServer.ServantLocatorOperations)
    • org.omg.PortableServer.ServantActivatorHelper
    • org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper
    • org.omg.PortableServer.ServantLocatorHelper
    • org.omg.PortableServer.POAPackage.ServantNotActiveHelper
    • org.omg.CORBA.portable.ServantObject
    • org.omg.PortableServer.ServantRetentionPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableInterceptor.ServerIdHelper
    • org.omg.CORBA.ServerRequest
    • java.net.ServerSocket (implements java.io.Closeable)
      • javax.net.ssl.SSLServerSocket
    • javax.net.ServerSocketFactory
      • javax.net.ssl.SSLServerSocketFactory
    • javax.xml.ws.Service
    • org.omg.IOP.ServiceContext (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.ServiceContextHelper
    • org.omg.IOP.ServiceContextHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.IOP.ServiceContextListHelper
    • org.omg.IOP.ServiceContextListHolder (implements org.omg.CORBA.portable.Streamable)
    • javax.xml.ws.spi.ServiceDelegate
    • org.omg.CORBA.ServiceDetail (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.ServiceDetailHelper
    • org.omg.IOP.ServiceIdHelper
    • org.omg.CORBA.ServiceInformation (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.ServiceInformationHelper
    • org.omg.CORBA.ServiceInformationHolder (implements org.omg.CORBA.portable.Streamable)
    • java.util.ServiceLoader<S> (implements java.lang.Iterable<T>)
    • javax.imageio.spi.ServiceRegistry
      • javax.imageio.spi.IIORegistry
    • javax.print.ServiceUI
    • javax.print.ServiceUIFactory
    • javax.print.attribute.SetOfIntegerSyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.CopiesSupported (implements javax.print.attribute.SupportedValuesAttribute)
      • javax.print.attribute.standard.JobImpressionsSupported (implements javax.print.attribute.SupportedValuesAttribute)
      • javax.print.attribute.standard.JobKOctetsSupported (implements javax.print.attribute.SupportedValuesAttribute)
      • javax.print.attribute.standard.JobMediaSheetsSupported (implements javax.print.attribute.SupportedValuesAttribute)
      • javax.print.attribute.standard.NumberUpSupported (implements javax.print.attribute.SupportedValuesAttribute)
      • javax.print.attribute.standard.PageRanges (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
    • org.omg.CORBA.SetOverrideType (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.SetOverrideTypeHelper
    • org.omg.CORBA.ShortHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.ShortSeqHelper
    • org.omg.CORBA.ShortSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • java.security.SignatureSpi
      • java.security.Signature
    • java.security.SignedObject (implements java.io.Serializable)
    • javax.swing.text.SimpleAttributeSet (implements java.lang.Cloneable, javax.swing.text.MutableAttributeSet, java.io.Serializable)
    • java.beans.SimpleBeanInfo (implements java.beans.BeanInfo)
    • javax.script.SimpleBindings (implements javax.script.Bindings)
    • javax.print.SimpleDoc (implements javax.print.Doc)
    • java.nio.file.SimpleFileVisitor<T> (implements java.nio.file.FileVisitor<T>)
    • javax.tools.SimpleJavaFileObject (implements javax.tools.JavaFileObject)
    • javax.script.SimpleScriptContext (implements javax.script.ScriptContext)
    • javax.print.attribute.Size2DSyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.MediaSize (implements javax.print.attribute.Attribute)
    • javax.swing.SizeRequirements (implements java.io.Serializable)
    • javax.swing.SizeSequence
    • javax.net.ssl.SNIMatcher
    • javax.net.ssl.SNIServerName
      • javax.net.ssl.SNIHostName
    • javax.xml.soap.SOAPConnection
    • javax.xml.soap.SOAPConnectionFactory
    • javax.xml.soap.SOAPElementFactory
    • javax.xml.soap.SOAPFactory
    • javax.xml.soap.SOAPMessage
    • javax.xml.soap.SOAPPart (implements org.w3c.dom.Document, javax.xml.soap.Node)
    • java.net.Socket (implements java.io.Closeable)
      • javax.net.ssl.SSLSocket
    • java.net.SocketAddress (implements java.io.Serializable)
      • java.net.InetSocketAddress
    • javax.net.SocketFactory
      • javax.net.ssl.SSLSocketFactory
    • java.net.SocketImpl (implements java.net.SocketOptions)
    • javax.naming.ldap.SortKey
    • javax.sound.midi.spi.SoundbankReader
    • javax.sound.midi.SoundbankResource
      • javax.sound.midi.Instrument
    • java.awt.SplashScreen
    • java.util.Spliterators
    • java.util.Spliterators.AbstractDoubleSpliterator (implements java.util.Spliterator.OfDouble)
    • java.util.Spliterators.AbstractIntSpliterator (implements java.util.Spliterator.OfInt)
    • java.util.Spliterators.AbstractLongSpliterator (implements java.util.Spliterator.OfLong)
    • java.util.Spliterators.AbstractSpliterator<T> (implements java.util.Spliterator<T>)
    • java.util.SplittableRandom
    • javax.swing.Spring
    • javax.swing.SpringLayout (implements java.awt.LayoutManager2)
    • javax.swing.SpringLayout.Constraints
    • javax.sql.rowset.serial.SQLInputImpl (implements java.sql.SQLInput)
    • javax.sql.rowset.serial.SQLOutputImpl (implements java.sql.SQLOutput)
    • javax.net.ssl.SSLContext
    • javax.net.ssl.SSLContextSpi
    • javax.net.ssl.SSLEngine
    • javax.net.ssl.SSLEngineResult
    • javax.net.ssl.SSLParameters
    • javax.rmi.ssl.SslRMIClientSocketFactory (implements java.rmi.server.RMIClientSocketFactory, java.io.Serializable)
    • javax.rmi.ssl.SslRMIServerSocketFactory (implements java.rmi.server.RMIServerSocketFactory)
    • java.lang.StackTraceElement (implements java.io.Serializable)
    • java.util.concurrent.locks.StampedLock (implements java.io.Serializable)
    • java.nio.charset.StandardCharsets
    • javax.net.ssl.StandardConstants
    • javax.management.StandardMBean (implements javax.management.DynamicMBean, javax.management.MBeanRegistration)
      • javax.management.StandardEmitterMBean (implements javax.management.NotificationEmitter)
    • java.net.StandardSocketOptions
    • java.nio.file.StandardWatchEventKinds
    • javax.naming.ldap.StartTlsRequest (implements javax.naming.ldap.ExtendedRequest)
    • javax.naming.ldap.StartTlsResponse (implements javax.naming.ldap.ExtendedResponse)
    • javax.swing.plaf.nimbus.State<T>
    • org.omg.PortableServer.POAManagerPackage.State (implements org.omg.CORBA.portable.IDLEntity)
    • java.beans.Statement
      • java.beans.Expression
    • javax.xml.transform.stax.StAXResult (implements javax.xml.transform.Result)
    • javax.xml.transform.stax.StAXSource (implements javax.xml.transform.Source)
    • javax.print.StreamPrintService (implements javax.print.PrintService)
    • javax.print.StreamPrintServiceFactory
    • javax.xml.stream.util.StreamReaderDelegate (implements javax.xml.stream.XMLStreamReader)
    • javax.xml.transform.stream.StreamResult (implements javax.xml.transform.Result)
    • javax.xml.transform.stream.StreamSource (implements javax.xml.transform.Source)
    • java.util.stream.StreamSupport
    • java.io.StreamTokenizer
    • java.lang.StrictMath
    • java.lang.String (implements java.lang.CharSequence, java.lang.Comparable<T>, java.io.Serializable)
    • java.lang.StringBuffer (implements java.lang.CharSequence, java.io.Serializable)
    • java.lang.StringBuilder (implements java.lang.CharSequence, java.io.Serializable)
    • java.text.StringCharacterIterator (implements java.text.CharacterIterator)
    • javax.swing.text.StringContent (implements javax.swing.text.AbstractDocument.Content, java.io.Serializable)
    • org.omg.CORBA.StringHolder (implements org.omg.CORBA.portable.Streamable)
    • java.util.StringJoiner
    • org.omg.CosNaming.NamingContextExtPackage.StringNameHelper
    • java.awt.datatransfer.StringSelection (implements java.awt.datatransfer.ClipboardOwner, java.awt.datatransfer.Transferable)
    • org.omg.CORBA.StringSeqHelper
    • org.omg.CORBA.StringSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • java.util.StringTokenizer (implements java.util.Enumeration<E>)
    • javax.management.StringValueExp (implements javax.management.ValueExp)
    • org.omg.CORBA.StringValueHelper (implements org.omg.CORBA.portable.BoxedValueHelper)
    • org.omg.CORBA.StructMember (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.StructMemberHelper
    • javax.swing.text.StyleConstants
      • javax.swing.text.StyleConstants.CharacterConstants (implements javax.swing.text.AttributeSet.CharacterAttribute)
      • javax.swing.text.StyleConstants.ColorConstants (implements javax.swing.text.AttributeSet.CharacterAttribute, javax.swing.text.AttributeSet.ColorAttribute)
      • javax.swing.text.StyleConstants.FontConstants (implements javax.swing.text.AttributeSet.CharacterAttribute, javax.swing.text.AttributeSet.FontAttribute)
      • javax.swing.text.StyleConstants.ParagraphConstants (implements javax.swing.text.AttributeSet.ParagraphAttribute)
    • javax.swing.text.StyleContext (implements javax.swing.text.AbstractDocument.AttributeContext, java.io.Serializable)
      • javax.swing.text.html.StyleSheet
    • javax.swing.text.StyleContext.NamedStyle (implements java.io.Serializable, javax.swing.text.Style)
    • javax.swing.text.StyleContext.SmallAttributeSet (implements javax.swing.text.AttributeSet)
    • javax.swing.text.html.StyleSheet.BoxPainter (implements java.io.Serializable)
    • javax.swing.text.html.StyleSheet.ListPainter (implements java.io.Serializable)
    • javax.security.auth.Subject (implements java.io.Serializable)
    • javax.security.auth.SubjectDomainCombiner (implements java.security.DomainCombiner)
    • javax.swing.SwingUtilities (implements javax.swing.SwingConstants)
    • javax.swing.SwingWorker<T,V> (implements java.util.concurrent.RunnableFuture<V>)
    • java.lang.invoke.SwitchPoint
    • javax.sql.rowset.spi.SyncFactory
    • javax.sql.rowset.spi.SyncProvider
    • org.omg.Messaging.SyncScopeHelper
    • javax.swing.plaf.synth.SynthContext
    • javax.swing.plaf.synth.SynthGraphicsUtils
    • javax.swing.plaf.synth.SynthPainter
    • javax.swing.plaf.synth.SynthStyle
      • javax.swing.plaf.nimbus.NimbusStyle
    • javax.swing.plaf.synth.SynthStyleFactory
    • java.lang.System
    • java.awt.datatransfer.SystemFlavorMap (implements java.awt.datatransfer.FlavorMap, java.awt.datatransfer.FlavorTable)
    • java.awt.SystemTray
    • javax.swing.table.TableColumn (implements java.io.Serializable)
    • javax.swing.table.TableStringConverter
    • javax.swing.text.TabSet (implements java.io.Serializable)
    • javax.swing.text.TabStop (implements java.io.Serializable)
    • javax.management.openmbean.TabularDataSupport (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable, javax.management.openmbean.TabularData)
    • javax.swing.text.html.parser.TagElement
    • org.omg.IOP.TaggedComponent (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.TaggedComponentHelper
    • org.omg.IOP.TaggedComponentHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.IOP.TaggedProfile (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.TaggedProfileHelper
    • org.omg.IOP.TaggedProfileHolder (implements org.omg.CORBA.portable.Streamable)
    • javax.management.remote.TargetedNotification (implements java.io.Serializable)
    • org.omg.CORBA.TCKind
    • java.time.temporal.TemporalAdjusters
    • java.time.temporal.TemporalQueries
    • java.awt.font.TextHitInfo
    • javax.security.auth.callback.TextInputCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
      • javax.security.sasl.RealmCallback
    • java.awt.font.TextLayout (implements java.lang.Cloneable)
    • java.awt.font.TextLayout.CaretPolicy
    • java.awt.font.TextMeasurer (implements java.lang.Cloneable)
    • javax.security.auth.callback.TextOutputCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
    • javax.print.attribute.TextSyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.DocumentName (implements javax.print.attribute.DocAttribute)
      • javax.print.attribute.standard.JobMessageFromOperator (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.JobName (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobOriginatingUserName (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.OutputDeviceAssigned (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.PrinterInfo (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterLocation (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterMakeAndModel (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterMessageFromOperator (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterName (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.RequestingUserName (implements javax.print.attribute.PrintRequestAttribute)
    • java.awt.TexturePaint (implements java.awt.Paint)
    • java.time.chrono.ThaiBuddhistDate (implements java.time.chrono.ChronoLocalDate, java.io.Serializable)
    • java.lang.Thread (implements java.lang.Runnable)
      • java.util.concurrent.ForkJoinWorkerThread
    • java.lang.ThreadGroup (implements java.lang.Thread.UncaughtExceptionHandler)
    • java.lang.management.ThreadInfo
    • java.lang.ThreadLocal<T>
      • java.lang.InheritableThreadLocal<T>
    • org.omg.PortableServer.ThreadPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • java.util.concurrent.ThreadPoolExecutor.AbortPolicy (implements java.util.concurrent.RejectedExecutionHandler)
    • java.util.concurrent.ThreadPoolExecutor.CallerRunsPolicy (implements java.util.concurrent.RejectedExecutionHandler)
    • java.util.concurrent.ThreadPoolExecutor.DiscardOldestPolicy (implements java.util.concurrent.RejectedExecutionHandler)
    • java.util.concurrent.ThreadPoolExecutor.DiscardPolicy (implements java.util.concurrent.RejectedExecutionHandler)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Error
        • java.lang.annotation.AnnotationFormatError
        • java.lang.AssertionError
        • java.awt.AWTError
        • java.nio.charset.CoderMalfunctionError
        • javax.xml.parsers.FactoryConfigurationError
        • javax.xml.stream.FactoryConfigurationError
        • java.io.IOError
        • java.lang.LinkageError
          • java.lang.BootstrapMethodError
          • java.lang.ClassCircularityError
          • java.lang.ClassFormatError
            • java.lang.reflect.GenericSignatureFormatError
            • java.lang.UnsupportedClassVersionError
          • java.lang.ExceptionInInitializerError
          • java.lang.IncompatibleClassChangeError
            • java.lang.AbstractMethodError
            • java.lang.IllegalAccessError
            • java.lang.InstantiationError
            • java.lang.NoSuchFieldError
            • java.lang.NoSuchMethodError
          • java.lang.NoClassDefFoundError
          • java.lang.UnsatisfiedLinkError
          • java.lang.VerifyError
        • javax.xml.validation.SchemaFactoryConfigurationError
        • java.util.ServiceConfigurationError
        • java.lang.ThreadDeath
        • javax.xml.transform.TransformerFactoryConfigurationError
        • java.lang.VirtualMachineError
          • java.lang.InternalError
            • java.util.zip.ZipError
          • java.lang.OutOfMemoryError
          • java.lang.StackOverflowError
          • java.lang.UnknownError
      • java.lang.Exception
        • java.security.acl.AclNotFoundException
        • java.rmi.activation.ActivationException
          • java.rmi.activation.UnknownGroupException
          • java.rmi.activation.UnknownObjectException
        • java.rmi.AlreadyBoundException
        • org.omg.CORBA.portable.ApplicationException
        • java.awt.AWTException
        • java.util.prefs.BackingStoreException
        • javax.management.BadAttributeValueExpException
        • javax.management.BadBinaryOpValueExpException
        • javax.swing.text.BadLocationException
        • javax.management.BadStringOperationException
        • java.util.concurrent.BrokenBarrierException
        • javax.security.cert.CertificateException
          • javax.security.cert.CertificateEncodingException
          • javax.security.cert.CertificateExpiredException
          • javax.security.cert.CertificateNotYetValidException
          • javax.security.cert.CertificateParsingException
        • java.lang.CloneNotSupportedException
          • java.rmi.server.ServerCloneException
        • java.util.zip.DataFormatException
        • javax.xml.datatype.DatatypeConfigurationException
        • javax.security.auth.DestroyFailedException
        • java.util.concurrent.ExecutionException
        • javax.swing.tree.ExpandVetoException
        • java.awt.FontFormatException
        • java.security.GeneralSecurityException
          • javax.crypto.BadPaddingException
            • javax.crypto.AEADBadTagException
          • java.security.cert.CertificateException
            • java.security.cert.CertificateEncodingException
            • java.security.cert.CertificateExpiredException
            • java.security.cert.CertificateNotYetValidException
            • java.security.cert.CertificateParsingException
            • java.security.cert.CertificateRevokedException
          • java.security.cert.CertPathBuilderException
          • java.security.cert.CertPathValidatorException
          • java.security.cert.CertStoreException
          • java.security.cert.CRLException
          • java.security.DigestException
          • javax.crypto.ExemptionMechanismException
          • javax.crypto.IllegalBlockSizeException
          • java.security.InvalidAlgorithmParameterException
          • java.security.spec.InvalidKeySpecException
          • java.security.spec.InvalidParameterSpecException
          • java.security.KeyException
            • java.security.InvalidKeyException
            • java.security.KeyManagementException
          • java.security.KeyStoreException
          • javax.security.auth.login.LoginException
            • javax.security.auth.login.AccountException
              • javax.security.auth.login.AccountExpiredException
              • javax.security.auth.login.AccountLockedException
              • javax.security.auth.login.AccountNotFoundException
            • javax.security.auth.login.CredentialException
              • javax.security.auth.login.CredentialExpiredException
              • javax.security.auth.login.CredentialNotFoundException
            • javax.security.auth.login.FailedLoginException
          • java.security.NoSuchAlgorithmException
          • javax.crypto.NoSuchPaddingException
          • java.security.NoSuchProviderException
          • javax.crypto.ShortBufferException
          • java.security.SignatureException
          • java.security.UnrecoverableEntryException
            • java.security.UnrecoverableKeyException
        • org.ietf.jgss.GSSException
        • java.lang.instrument.IllegalClassFormatException
        • java.lang.InterruptedException
        • java.beans.IntrospectionException
        • javax.management.InvalidApplicationException
        • javax.sound.midi.InvalidMidiDataException
        • java.util.prefs.InvalidPreferencesFormatException
        • javax.management.modelmbean.InvalidTargetObjectTypeException
        • java.io.IOException
          • javax.swing.text.ChangedCharSetException
          • java.nio.charset.CharacterCodingException
            • java.nio.charset.MalformedInputException
            • java.nio.charset.UnmappableCharacterException
          • java.io.CharConversionException
          • java.nio.channels.ClosedChannelException
            • java.nio.channels.AsynchronousCloseException
              • java.nio.channels.ClosedByInterruptException
          • java.io.EOFException
          • java.nio.channels.FileLockInterruptionException
          • java.io.FileNotFoundException
          • javax.annotation.processing.FilerException
          • java.nio.file.FileSystemException
            • java.nio.file.AccessDeniedException
            • java.nio.file.AtomicMoveNotSupportedException
            • java.nio.file.DirectoryNotEmptyException
            • java.nio.file.FileAlreadyExistsException
            • java.nio.file.FileSystemLoopException
            • java.nio.file.NoSuchFileException
            • java.nio.file.NotDirectoryException
            • java.nio.file.NotLinkException
          • java.net.HttpRetryException
          • javax.imageio.IIOException
            • javax.imageio.metadata.IIOInvalidTreeException
          • java.nio.channels.InterruptedByTimeoutException
          • java.io.InterruptedIOException
            • java.net.SocketTimeoutException
          • java.util.InvalidPropertiesFormatException
          • javax.management.remote.JMXProviderException
          • javax.management.remote.JMXServerErrorException
          • java.net.MalformedURLException
          • java.io.ObjectStreamException
            • java.io.InvalidClassException
            • java.io.InvalidObjectException
            • java.io.NotActiveException
            • java.io.NotSerializableException
            • java.io.OptionalDataException
            • java.io.StreamCorruptedException
            • java.io.WriteAbortedException
          • java.net.ProtocolException
          • java.rmi.RemoteException
            • java.rmi.AccessException
            • java.rmi.activation.ActivateFailedException
            • javax.activity.ActivityCompletedException
            • javax.activity.ActivityRequiredException
            • java.rmi.ConnectException
            • java.rmi.ConnectIOException
            • java.rmi.server.ExportException
              • java.rmi.server.SocketSecurityException
            • javax.activity.InvalidActivityException
            • javax.transaction.InvalidTransactionException
            • java.rmi.MarshalException
            • java.rmi.NoSuchObjectException
            • java.rmi.ServerError
            • java.rmi.ServerException
            • java.rmi.ServerRuntimeException
            • java.rmi.server.SkeletonMismatchException
            • java.rmi.server.SkeletonNotFoundException
            • java.rmi.StubNotFoundException
            • javax.transaction.TransactionRequiredException
            • javax.transaction.TransactionRolledbackException
            • java.rmi.UnexpectedException
            • java.rmi.UnknownHostException
            • java.rmi.UnmarshalException
          • javax.security.sasl.SaslException
            • javax.security.sasl.AuthenticationException
          • java.net.SocketException
            • java.net.BindException
            • java.net.ConnectException
            • java.net.NoRouteToHostException
            • java.net.PortUnreachableException
          • javax.net.ssl.SSLException
            • javax.net.ssl.SSLHandshakeException
            • javax.net.ssl.SSLKeyException
            • javax.net.ssl.SSLPeerUnverifiedException
            • javax.net.ssl.SSLProtocolException
          • java.io.SyncFailedException
          • java.net.UnknownHostException
          • java.net.UnknownServiceException
          • javax.activation.UnsupportedDataTypeException
          • java.io.UnsupportedEncodingException
          • java.nio.file.attribute.UserPrincipalNotFoundException
          • java.io.UTFDataFormatException
          • java.util.zip.ZipException
            • java.util.jar.JarException
        • javax.xml.bind.JAXBException
          • javax.xml.bind.MarshalException
          • javax.xml.bind.PropertyException
          • javax.xml.bind.UnmarshalException
          • javax.xml.bind.ValidationException
        • javax.management.JMException
          • javax.management.MBeanException
            • javax.management.MBeanRegistrationException
          • javax.management.openmbean.OpenDataException
          • javax.management.OperationsException
            • javax.management.AttributeNotFoundException
            • javax.management.InstanceAlreadyExistsException
            • javax.management.InstanceNotFoundException
            • javax.management.IntrospectionException
            • javax.management.InvalidAttributeValueException
            • javax.management.ListenerNotFoundException
            • javax.management.MalformedObjectNameException
            • javax.management.NotCompliantMBeanException
            • javax.management.ServiceNotFoundException
          • javax.management.ReflectionException
          • javax.management.relation.RelationException
            • javax.management.relation.InvalidRelationIdException
            • javax.management.relation.InvalidRelationServiceException
            • javax.management.relation.InvalidRelationTypeException
            • javax.management.relation.InvalidRoleInfoException
            • javax.management.relation.InvalidRoleValueException
            • javax.management.relation.RelationNotFoundException
            • javax.management.relation.RelationServiceNotRegisteredException
            • javax.management.relation.RelationTypeNotFoundException
            • javax.management.relation.RoleInfoNotFoundException
            • javax.management.relation.RoleNotFoundException
        • javax.xml.crypto.KeySelectorException
        • java.lang.invoke.LambdaConversionException
        • java.security.acl.LastOwnerException
        • javax.sound.sampled.LineUnavailableException
        • javax.xml.crypto.MarshalException
        • javax.sound.midi.MidiUnavailableException
        • java.awt.datatransfer.MimeTypeParseException
        • javax.activation.MimeTypeParseException
        • javax.naming.NamingException
          • javax.naming.directory.AttributeInUseException
          • javax.naming.directory.AttributeModificationException
          • javax.naming.CannotProceedException
          • javax.naming.CommunicationException
          • javax.naming.ConfigurationException
          • javax.naming.ContextNotEmptyException
          • javax.naming.InsufficientResourcesException
          • javax.naming.InterruptedNamingException
          • javax.naming.directory.InvalidAttributeIdentifierException
          • javax.naming.directory.InvalidAttributesException
          • javax.naming.directory.InvalidAttributeValueException
          • javax.naming.InvalidNameException
          • javax.naming.directory.InvalidSearchControlsException
          • javax.naming.directory.InvalidSearchFilterException
          • javax.naming.LimitExceededException
            • javax.naming.SizeLimitExceededException
            • javax.naming.TimeLimitExceededException
          • javax.naming.LinkException
            • javax.naming.LinkLoopException
            • javax.naming.MalformedLinkException
          • javax.naming.NameAlreadyBoundException
          • javax.naming.NameNotFoundException
          • javax.naming.NamingSecurityException
            • javax.naming.AuthenticationException
            • javax.naming.AuthenticationNotSupportedException
            • javax.naming.NoPermissionException
          • javax.naming.NoInitialContextException
          • javax.naming.directory.NoSuchAttributeException
          • javax.naming.NotContextException
          • javax.naming.OperationNotSupportedException
          • javax.naming.PartialResultException
          • javax.naming.ReferralException
            • javax.naming.ldap.LdapReferralException
          • javax.naming.directory.SchemaViolationException
          • javax.naming.ServiceUnavailableException
        • java.awt.geom.NoninvertibleTransformException
        • java.rmi.NotBoundException
        • java.security.acl.NotOwnerException
        • java.text.ParseException
        • javax.xml.parsers.ParserConfigurationException
        • java.awt.print.PrinterException
          • java.awt.print.PrinterAbortException
          • java.awt.print.PrinterIOException
        • javax.print.PrintException
        • java.security.PrivilegedActionException
        • java.beans.PropertyVetoException
        • java.lang.ReflectiveOperationException
          • java.lang.ClassNotFoundException
          • java.lang.IllegalAccessException
          • java.lang.InstantiationException
          • java.lang.reflect.InvocationTargetException
          • java.lang.NoSuchFieldException
          • java.lang.NoSuchMethodException
        • javax.security.auth.RefreshFailedException
        • org.omg.CORBA.portable.RemarshalException
        • java.lang.RuntimeException
          • java.lang.annotation.AnnotationTypeMismatchException
          • java.lang.ArithmeticException
          • java.lang.ArrayStoreException
          • java.nio.BufferOverflowException
          • java.nio.BufferUnderflowException
          • javax.swing.undo.CannotRedoException
          • javax.swing.undo.CannotUndoException
          • java.lang.ClassCastException
          • java.awt.color.CMMException
          • java.util.concurrent.CompletionException
          • java.util.ConcurrentModificationException
            • java.nio.file.DirectoryIteratorException
          • javax.xml.bind.DataBindingException
          • java.time.DateTimeException
            • java.time.format.DateTimeParseException
            • java.time.temporal.UnsupportedTemporalTypeException
            • java.time.zone.ZoneRulesException
          • org.w3c.dom.DOMException
          • java.util.EmptyStackException
          • java.lang.EnumConstantNotPresentException
          • org.w3c.dom.events.EventException
          • java.nio.file.FileSystemAlreadyExistsException
          • java.nio.file.FileSystemNotFoundException
          • java.lang.IllegalArgumentException
            • java.nio.channels.IllegalChannelGroupException
            • java.nio.charset.IllegalCharsetNameException
            • java.util.IllegalFormatException
              • java.util.DuplicateFormatFlagsException
              • java.util.FormatFlagsConversionMismatchException
              • java.util.IllegalFormatCodePointException
              • java.util.IllegalFormatConversionException
              • java.util.IllegalFormatFlagsException
              • java.util.IllegalFormatPrecisionException
              • java.util.IllegalFormatWidthException
              • java.util.MissingFormatArgumentException
              • java.util.MissingFormatWidthException
              • java.util.UnknownFormatConversionException
              • java.util.UnknownFormatFlagsException
            • java.nio.channels.IllegalSelectorException
            • java.lang.IllegalThreadStateException
            • javax.management.openmbean.InvalidKeyException
            • javax.management.openmbean.InvalidOpenTypeException
            • java.security.InvalidParameterException
            • java.nio.file.InvalidPathException
            • javax.management.openmbean.KeyAlreadyExistsException
            • java.lang.NumberFormatException
            • java.util.regex.PatternSyntaxException
            • java.nio.file.ProviderMismatchException
            • java.nio.channels.UnresolvedAddressException
            • java.nio.channels.UnsupportedAddressTypeException
            • java.nio.charset.UnsupportedCharsetException
          • java.lang.IllegalMonitorStateException
          • java.awt.geom.IllegalPathStateException
          • java.lang.IllegalStateException
            • java.nio.channels.AcceptPendingException
            • java.nio.channels.AlreadyBoundException
            • java.nio.channels.AlreadyConnectedException
            • java.util.concurrent.CancellationException
            • java.nio.channels.CancelledKeyException
            • java.nio.file.ClosedDirectoryStreamException
            • java.nio.file.ClosedFileSystemException
            • java.nio.channels.ClosedSelectorException
            • java.nio.file.ClosedWatchServiceException
            • java.nio.channels.ConnectionPendingException
            • java.util.FormatterClosedException
            • java.nio.channels.IllegalBlockingModeException
            • java.awt.IllegalComponentStateException
            • java.awt.dnd.InvalidDnDOperationException
            • java.nio.InvalidMarkException
            • java.nio.channels.NoConnectionPendingException
            • java.nio.channels.NonReadableChannelException
            • java.nio.channels.NonWritableChannelException
            • java.nio.channels.NotYetBoundException
            • java.nio.channels.NotYetConnectedException
            • java.nio.channels.OverlappingFileLockException
            • java.nio.channels.ReadPendingException
            • java.nio.channels.ShutdownChannelGroupException
            • java.nio.channels.WritePendingException
          • java.util.IllformedLocaleException
          • java.awt.image.ImagingOpException
          • java.lang.annotation.IncompleteAnnotationException
          • java.lang.IndexOutOfBoundsException
            • java.lang.ArrayIndexOutOfBoundsException
            • java.lang.StringIndexOutOfBoundsException
          • javax.management.JMRuntimeException
            • javax.management.monitor.MonitorSettingException
            • javax.management.RuntimeErrorException
            • javax.management.RuntimeMBeanException
            • javax.management.RuntimeOperationsException
          • org.w3c.dom.ls.LSException
          • java.lang.reflect.MalformedParameterizedTypeException
          • java.lang.reflect.MalformedParametersException
          • javax.lang.model.type.MirroredTypesException
            • javax.lang.model.type.MirroredTypeException
          • java.util.MissingResourceException
          • java.lang.NegativeArraySizeException
          • java.util.NoSuchElementException
            • java.util.InputMismatchException
          • javax.xml.crypto.NoSuchMechanismException
          • java.lang.NullPointerException
          • java.awt.color.ProfileDataException
          • java.security.ProviderException
          • java.nio.file.ProviderNotFoundException
          • java.awt.image.RasterFormatException
          • java.util.concurrent.RejectedExecutionException
          • java.lang.SecurityException
            • java.security.AccessControlException
            • java.rmi.RMISecurityException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.ACTIVITY_COMPLETED
            • org.omg.CORBA.ACTIVITY_REQUIRED
            • org.omg.CORBA.BAD_CONTEXT
            • org.omg.CORBA.BAD_INV_ORDER
            • org.omg.CORBA.BAD_OPERATION
            • org.omg.CORBA.BAD_PARAM
            • org.omg.CORBA.BAD_QOS
            • org.omg.CORBA.BAD_TYPECODE
            • org.omg.CORBA.CODESET_INCOMPATIBLE
            • org.omg.CORBA.COMM_FAILURE
            • org.omg.CORBA.DATA_CONVERSION
            • org.omg.CORBA.FREE_MEM
            • org.omg.CORBA.IMP_LIMIT
            • org.omg.CORBA.portable.IndirectionException
            • org.omg.CORBA.INITIALIZE
            • org.omg.CORBA.INTERNAL
            • org.omg.CORBA.INTF_REPOS
            • org.omg.CORBA.INV_FLAG
            • org.omg.CORBA.INV_IDENT
            • org.omg.CORBA.INV_OBJREF
            • org.omg.CORBA.INV_POLICY
            • org.omg.CORBA.INVALID_ACTIVITY
            • org.omg.CORBA.INVALID_TRANSACTION
            • org.omg.CORBA.MARSHAL
            • org.omg.CORBA.NO_IMPLEMENT
            • org.omg.CORBA.NO_MEMORY
            • org.omg.CORBA.NO_PERMISSION
            • org.omg.CORBA.NO_RESOURCES
            • org.omg.CORBA.NO_RESPONSE
            • org.omg.CORBA.OBJ_ADAPTER
            • org.omg.CORBA.OBJECT_NOT_EXIST
            • org.omg.CORBA.PERSIST_STORE
            • org.omg.CORBA.REBIND
            • org.omg.CORBA.TIMEOUT
            • org.omg.CORBA.TRANSACTION_MODE
            • org.omg.CORBA.TRANSACTION_REQUIRED
            • org.omg.CORBA.TRANSACTION_ROLLEDBACK
            • org.omg.CORBA.TRANSACTION_UNAVAILABLE
            • org.omg.CORBA.TRANSIENT
            • org.omg.CORBA.UNKNOWN
            • org.omg.CORBA.portable.UnknownException
          • javax.xml.bind.TypeConstraintException
          • java.lang.TypeNotPresentException
          • java.io.UncheckedIOException
          • java.lang.reflect.UndeclaredThrowableException
          • javax.lang.model.UnknownEntityException
            • javax.lang.model.element.UnknownAnnotationValueException
            • javax.lang.model.element.UnknownElementException
            • javax.lang.model.type.UnknownTypeException
          • javax.print.attribute.UnmodifiableSetException
          • java.lang.UnsupportedOperationException
            • java.awt.HeadlessException
            • java.nio.ReadOnlyBufferException
            • java.nio.file.ReadOnlyFileSystemException
          • javax.xml.ws.WebServiceException
            • javax.xml.ws.ProtocolException
              • javax.xml.ws.http.HTTPException
              • javax.xml.ws.soap.SOAPFaultException
          • java.lang.invoke.WrongMethodTypeException
        • org.xml.sax.SAXException
          • org.xml.sax.SAXNotRecognizedException
          • org.xml.sax.SAXNotSupportedException
          • org.xml.sax.SAXParseException
        • javax.script.ScriptException
        • java.rmi.server.ServerNotActiveException
        • javax.xml.soap.SOAPException
        • java.sql.SQLException (implements java.lang.Iterable<T>)
          • java.sql.BatchUpdateException
          • javax.sql.rowset.RowSetWarning
          • javax.sql.rowset.serial.SerialException
          • java.sql.SQLClientInfoException
          • java.sql.SQLNonTransientException
            • java.sql.SQLDataException
            • java.sql.SQLFeatureNotSupportedException
            • java.sql.SQLIntegrityConstraintViolationException
            • java.sql.SQLInvalidAuthorizationSpecException
            • java.sql.SQLNonTransientConnectionException
            • java.sql.SQLSyntaxErrorException
          • java.sql.SQLRecoverableException
          • java.sql.SQLTransientException
            • java.sql.SQLTimeoutException
            • java.sql.SQLTransactionRollbackException
            • java.sql.SQLTransientConnectionException
          • java.sql.SQLWarning
            • java.sql.DataTruncation
          • javax.sql.rowset.spi.SyncFactoryException
          • javax.sql.rowset.spi.SyncProviderException
        • java.util.concurrent.TimeoutException
        • java.util.TooManyListenersException
        • javax.xml.transform.TransformerException
          • javax.xml.transform.TransformerConfigurationException
        • javax.xml.crypto.dsig.TransformException
        • java.lang.instrument.UnmodifiableClassException
        • javax.sound.sampled.UnsupportedAudioFileException
        • javax.security.auth.callback.UnsupportedCallbackException
        • java.awt.datatransfer.UnsupportedFlavorException
        • javax.swing.UnsupportedLookAndFeelException
        • javax.xml.crypto.URIReferenceException
        • java.net.URISyntaxException
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.PortableServer.POAPackage.AdapterAlreadyExists
          • org.omg.PortableServer.POAManagerPackage.AdapterInactive
          • org.omg.PortableServer.POAPackage.AdapterNonExistent
          • org.omg.CosNaming.NamingContextPackage.AlreadyBound
          • org.omg.CORBA.TypeCodePackage.BadKind
          • org.omg.CORBA.Bounds
          • org.omg.CORBA.TypeCodePackage.Bounds
          • org.omg.CosNaming.NamingContextPackage.CannotProceed
          • org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateName
          • org.omg.IOP.CodecPackage.FormatMismatch
          • org.omg.PortableServer.ForwardRequest
          • org.omg.PortableInterceptor.ForwardRequest
          • org.omg.CORBA.ORBPackage.InconsistentTypeCode
          • org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCode
          • org.omg.CORBA.DynAnyPackage.Invalid
          • org.omg.CosNaming.NamingContextExtPackage.InvalidAddress
          • org.omg.CORBA.ORBPackage.InvalidName
          • org.omg.CosNaming.NamingContextPackage.InvalidName
          • org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidName
          • org.omg.PortableServer.POAPackage.InvalidPolicy
          • org.omg.CORBA.DynAnyPackage.InvalidSeq
          • org.omg.PortableInterceptor.InvalidSlot
          • org.omg.IOP.CodecPackage.InvalidTypeForEncoding
          • org.omg.CORBA.DynAnyPackage.InvalidValue
          • org.omg.DynamicAny.DynAnyPackage.InvalidValue
          • org.omg.PortableServer.CurrentPackage.NoContext
          • org.omg.PortableServer.POAPackage.NoServant
          • org.omg.CosNaming.NamingContextPackage.NotEmpty
          • org.omg.CosNaming.NamingContextPackage.NotFound
          • org.omg.PortableServer.POAPackage.ObjectAlreadyActive
          • org.omg.PortableServer.POAPackage.ObjectNotActive
          • org.omg.CORBA.PolicyError
          • org.omg.PortableServer.POAPackage.ServantAlreadyActive
          • org.omg.PortableServer.POAPackage.ServantNotActive
          • org.omg.CORBA.DynAnyPackage.TypeMismatch
          • org.omg.IOP.CodecPackage.TypeMismatch
          • org.omg.DynamicAny.DynAnyPackage.TypeMismatch
          • org.omg.IOP.CodecFactoryPackage.UnknownEncoding
          • org.omg.CORBA.UnknownUserException
          • org.omg.PortableServer.POAPackage.WrongAdapter
          • org.omg.PortableServer.POAPackage.WrongPolicy
          • org.omg.CORBA.WrongTransaction
        • javax.transaction.xa.XAException
        • javax.management.modelmbean.XMLParseException
        • javax.xml.crypto.dsig.XMLSignatureException
        • javax.xml.stream.XMLStreamException
        • javax.xml.xpath.XPathException
          • javax.xml.xpath.XPathExpressionException
            • javax.xml.xpath.XPathFunctionException
          • javax.xml.xpath.XPathFactoryConfigurationException
    • java.util.Timer
    • javax.swing.Timer (implements java.io.Serializable)
    • java.util.TimerTask (implements java.lang.Runnable)
    • java.security.Timestamp (implements java.io.Serializable)
    • java.util.TimeZone (implements java.lang.Cloneable, java.io.Serializable)
      • java.util.SimpleTimeZone
    • java.awt.Toolkit
    • javax.tools.ToolProvider
    • javax.swing.ToolTipManager.insideTimerAction (implements java.awt.event.ActionListener)
    • javax.swing.ToolTipManager.outsideTimerAction (implements java.awt.event.ActionListener)
    • javax.swing.ToolTipManager.stillInsideTimerAction (implements java.awt.event.ActionListener)
    • javax.sound.midi.Track
    • javax.swing.TransferHandler (implements java.io.Serializable)
    • javax.swing.TransferHandler.DropLocation
      • javax.swing.JList.DropLocation
      • javax.swing.JTable.DropLocation
      • javax.swing.text.JTextComponent.DropLocation
      • javax.swing.JTree.DropLocation
    • javax.swing.TransferHandler.TransferSupport
    • java.awt.font.TransformAttribute (implements java.io.Serializable)
    • javax.xml.transform.Transformer
    • javax.xml.transform.TransformerFactory
      • javax.xml.transform.sax.SAXTransformerFactory
    • javax.xml.crypto.dsig.TransformService (implements javax.xml.crypto.dsig.Transform)
    • java.awt.TrayIcon
    • javax.swing.tree.TreePath (implements java.io.Serializable)
    • java.security.cert.TrustAnchor
    • javax.net.ssl.TrustManagerFactory
    • javax.net.ssl.TrustManagerFactorySpi
    • org.omg.CORBA.TypeCode (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.TypeCodeHolder (implements org.omg.CORBA.portable.Streamable)
    • javax.xml.validation.TypeInfoProvider
    • org.omg.IOP.CodecPackage.TypeMismatchHelper
    • org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper
    • java.sql.Types
    • java.rmi.server.UID (implements java.io.Serializable)
    • javax.swing.UIDefaults.LazyInputMap (implements javax.swing.UIDefaults.LazyValue)
    • javax.swing.UIDefaults.ProxyLazyValue (implements javax.swing.UIDefaults.LazyValue)
    • javax.swing.UIManager (implements java.io.Serializable)
    • javax.swing.UIManager.LookAndFeelInfo
    • org.omg.CORBA.ULongLongSeqHelper
    • org.omg.CORBA.ULongLongSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.ULongSeqHelper
    • org.omg.CORBA.ULongSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • javax.swing.undo.UndoableEditSupport
    • org.omg.CORBA.UnionMember (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.UnionMemberHelper
    • org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper
    • org.omg.CORBA.UnknownUserExceptionHelper
    • org.omg.CORBA.UnknownUserExceptionHolder (implements org.omg.CORBA.portable.Streamable)
    • javax.xml.bind.Unmarshaller.Listener
    • java.net.URI (implements java.lang.Comparable<T>, java.io.Serializable)
    • java.security.URIParameter (implements javax.security.auth.login.Configuration.Parameters, java.security.Policy.Parameters)
    • javax.print.attribute.URISyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.Destination (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.PrinterMoreInfo (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterMoreInfoManufacturer (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterURI (implements javax.print.attribute.PrintServiceAttribute)
    • java.net.URL (implements java.io.Serializable)
    • java.net.URLConnection
      • java.net.HttpURLConnection
        • javax.net.ssl.HttpsURLConnection
      • java.net.JarURLConnection
    • javax.activation.URLDataSource (implements javax.activation.DataSource)
    • java.net.URLDecoder
    • java.net.URLEncoder
    • java.net.URLStreamHandler
    • org.omg.CosNaming.NamingContextExtPackage.URLStringHelper
    • java.nio.file.attribute.UserPrincipalLookupService
    • org.omg.CORBA.UShortSeqHelper
    • org.omg.CORBA.UShortSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • javax.rmi.CORBA.Util
    • javax.swing.text.Utilities
    • java.util.UUID (implements java.lang.Comparable<T>, java.io.Serializable)
    • javax.xml.bind.util.ValidationEventCollector (implements javax.xml.bind.ValidationEventHandler)
    • javax.xml.bind.helpers.ValidationEventImpl (implements javax.xml.bind.ValidationEvent)
      • javax.xml.bind.helpers.NotIdentifiableEventImpl (implements javax.xml.bind.NotIdentifiableEvent)
      • javax.xml.bind.helpers.ParseConversionEventImpl (implements javax.xml.bind.ParseConversionEvent)
      • javax.xml.bind.helpers.PrintConversionEventImpl (implements javax.xml.bind.PrintConversionEvent)
    • javax.xml.bind.helpers.ValidationEventLocatorImpl (implements javax.xml.bind.ValidationEventLocator)
    • javax.xml.validation.Validator
    • javax.xml.validation.ValidatorHandler (implements org.xml.sax.ContentHandler)
    • org.omg.CORBA.ValueBaseHelper
    • org.omg.CORBA.ValueBaseHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.ValueMember (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.ValueMemberHelper
    • java.time.temporal.ValueRange (implements java.io.Serializable)
    • org.omg.CORBA.VersionSpecHelper
    • java.beans.VetoableChangeSupport (implements java.io.Serializable)
    • javax.swing.text.View (implements javax.swing.SwingConstants)
      • javax.swing.text.AsyncBoxView
      • javax.swing.text.ComponentView
        • javax.swing.text.html.FormView (implements java.awt.event.ActionListener)
        • javax.swing.text.html.ObjectView
      • javax.swing.text.CompositeView
        • javax.swing.text.BoxView
          • javax.swing.text.html.BlockView
            • javax.swing.text.html.ListView
          • javax.swing.text.FlowView
            • javax.swing.text.ParagraphView (implements javax.swing.text.TabExpander)
              • javax.swing.text.html.ParagraphView
          • javax.swing.text.TableView
          • javax.swing.text.TableView.TableCell
          • javax.swing.text.TableView.TableRow
          • javax.swing.text.WrappedPlainView (implements javax.swing.text.TabExpander)
          • javax.swing.text.ZoneView
      • javax.swing.text.GlyphView (implements java.lang.Cloneable, javax.swing.text.TabableView)
        • javax.swing.text.LabelView (implements javax.swing.text.TabableView)
          • javax.swing.text.html.InlineView
      • javax.swing.text.IconView
      • javax.swing.text.html.ImageView
      • javax.swing.text.PlainView (implements javax.swing.text.TabExpander)
        • javax.swing.text.FieldView
          • javax.swing.text.PasswordView
    • javax.swing.ViewportLayout (implements java.awt.LayoutManager, java.io.Serializable)
    • org.omg.CORBA.VisibilityHelper
    • java.rmi.dgc.VMID (implements java.io.Serializable)
    • javax.sound.midi.VoiceStatus
    • java.lang.Void
    • javax.xml.bind.annotation.W3CDomHandler (implements javax.xml.bind.annotation.DomHandler<ElementT,ResultT>)
    • javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder
    • org.omg.CORBA.WCharSeqHelper
    • org.omg.CORBA.WCharSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • javax.xml.ws.WebServiceFeature
      • javax.xml.ws.soap.AddressingFeature
      • javax.xml.ws.soap.MTOMFeature
      • javax.xml.ws.RespectBindingFeature
    • java.time.temporal.WeekFields (implements java.io.Serializable)
    • java.awt.event.WindowAdapter (implements java.awt.event.WindowFocusListener, java.awt.event.WindowListener, java.awt.event.WindowStateListener)
      • javax.swing.plaf.basic.BasicToolBarUI.FrameListener
      • javax.swing.JMenu.WinListener (implements java.io.Serializable)
    • java.io.Writer (implements java.lang.Appendable, java.io.Closeable, java.io.Flushable)
      • java.io.BufferedWriter
      • java.io.CharArrayWriter
      • java.io.FilterWriter
      • java.io.OutputStreamWriter
        • java.io.FileWriter
      • java.io.PipedWriter
      • java.io.PrintWriter
      • java.io.StringWriter
    • org.omg.PortableServer.POAPackage.WrongAdapterHelper
    • org.omg.PortableServer.POAPackage.WrongPolicyHelper
    • org.omg.CORBA.WrongTransactionHelper
    • org.omg.CORBA.WrongTransactionHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.WStringSeqHelper
    • org.omg.CORBA.WStringSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.WStringValueHelper (implements org.omg.CORBA.portable.BoxedValueHelper)
    • javax.security.auth.x500.X500Principal (implements java.security.Principal, java.io.Serializable)
    • javax.security.auth.x500.X500PrivateCredential (implements javax.security.auth.Destroyable)
    • java.security.cert.X509CertSelector (implements java.security.cert.CertSelector)
    • java.security.cert.X509CRLEntry (implements java.security.cert.X509Extension)
    • java.security.cert.X509CRLSelector (implements java.security.cert.CRLSelector)
    • javax.net.ssl.X509ExtendedKeyManager (implements javax.net.ssl.X509KeyManager)
    • javax.net.ssl.X509ExtendedTrustManager (implements javax.net.ssl.X509TrustManager)
    • javax.xml.bind.annotation.adapters.XmlAdapter<ValueType,BoundType>
      • javax.xml.bind.annotation.adapters.CollapsedStringAdapter
      • javax.xml.bind.annotation.adapters.HexBinaryAdapter
      • javax.xml.bind.annotation.adapters.NormalizedStringAdapter
    • javax.xml.XMLConstants
    • java.beans.XMLDecoder (implements java.lang.AutoCloseable)
    • javax.xml.bind.annotation.XmlElement.DEFAULT
    • javax.xml.bind.annotation.XmlElementDecl.GLOBAL
    • javax.xml.bind.annotation.XmlElementRef.DEFAULT
    • javax.xml.stream.XMLEventFactory
    • org.xml.sax.helpers.XMLFilterImpl (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler, org.xml.sax.XMLFilter)
    • javax.xml.datatype.XMLGregorianCalendar (implements java.lang.Cloneable)
    • javax.xml.stream.XMLInputFactory
    • javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT
    • javax.xml.stream.XMLOutputFactory
    • org.xml.sax.helpers.XMLReaderAdapter (implements org.xml.sax.ContentHandler, org.xml.sax.Parser)
    • org.xml.sax.helpers.XMLReaderFactory
    • javax.xml.bind.annotation.XmlSchemaType.DEFAULT
    • javax.xml.crypto.dsig.XMLSignatureFactory
    • javax.xml.bind.annotation.XmlType.DEFAULT
    • javax.xml.xpath.XPathConstants
    • javax.xml.xpath.XPathFactory
    • javax.xml.crypto.dsig.spec.XPathFilter2ParameterSpec (implements javax.xml.crypto.dsig.spec.TransformParameterSpec)
    • javax.xml.crypto.dsig.spec.XPathFilterParameterSpec (implements javax.xml.crypto.dsig.spec.TransformParameterSpec)
    • javax.xml.crypto.dsig.spec.XPathType
    • javax.xml.crypto.dsig.spec.XPathType.Filter
    • javax.xml.crypto.dsig.spec.XSLTTransformParameterSpec (implements javax.xml.crypto.dsig.spec.TransformParameterSpec)
    • java.time.Year (implements java.lang.Comparable<T>, java.io.Serializable, java.time.temporal.Temporal, java.time.temporal.TemporalAdjuster)
    • java.time.YearMonth (implements java.lang.Comparable<T>, java.io.Serializable, java.time.temporal.Temporal, java.time.temporal.TemporalAdjuster)
    • java.util.zip.ZipEntry (implements java.lang.Cloneable)
      • java.util.jar.JarEntry
    • java.util.zip.ZipFile (implements java.io.Closeable)
      • java.util.jar.JarFile
    • java.time.ZonedDateTime (implements java.time.chrono.ChronoZonedDateTime<D>, java.io.Serializable, java.time.temporal.Temporal)
    • java.time.ZoneId (implements java.io.Serializable)
      • java.time.ZoneOffset (implements java.lang.Comparable<T>, java.io.Serializable, java.time.temporal.TemporalAccessor, java.time.temporal.TemporalAdjuster)
    • java.time.zone.ZoneOffsetTransition (implements java.lang.Comparable<T>, java.io.Serializable)
    • java.time.zone.ZoneOffsetTransitionRule (implements java.io.Serializable)
    • java.time.zone.ZoneRules (implements java.io.Serializable)
    • java.time.zone.ZoneRulesProvider

Interface Hierarchy

  • javax.swing.text.AbstractDocument.AttributeContext
  • javax.swing.text.AbstractDocument.Content
  • org.w3c.dom.views.AbstractView
  • javax.accessibility.Accessible
  • javax.accessibility.AccessibleAction
  • javax.accessibility.AccessibleComponent
    • javax.accessibility.AccessibleExtendedComponent
  • javax.accessibility.AccessibleExtendedText
  • javax.accessibility.AccessibleIcon
  • javax.accessibility.AccessibleKeyBinding
  • javax.accessibility.AccessibleSelection
  • javax.accessibility.AccessibleStreamable
  • javax.accessibility.AccessibleTable
    • javax.accessibility.AccessibleExtendedTable
  • javax.accessibility.AccessibleTableModelChange
  • javax.accessibility.AccessibleText
    • javax.accessibility.AccessibleEditableText
    • javax.accessibility.AccessibleHypertext
  • javax.accessibility.AccessibleValue
  • org.omg.PortableInterceptor.ACTIVE
  • java.awt.ActiveEvent
  • org.omg.PortableServer.AdapterActivatorOperations
    • org.omg.PortableServer.AdapterActivator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • java.awt.Adjustable
  • java.security.AlgorithmConstraints
  • javax.xml.crypto.AlgorithmMethod
    • javax.xml.crypto.dsig.CanonicalizationMethod
    • javax.xml.crypto.dsig.DigestMethod (also extends javax.xml.crypto.XMLStructure)
    • javax.xml.crypto.dsig.SignatureMethod (also extends javax.xml.crypto.XMLStructure)
    • javax.xml.crypto.dsig.Transform (also extends javax.xml.crypto.XMLStructure)
      • javax.xml.crypto.dsig.CanonicalizationMethod
  • java.security.spec.AlgorithmParameterSpec
    • javax.xml.crypto.dsig.spec.C14NMethodParameterSpec
    • javax.xml.crypto.dsig.spec.DigestMethodParameterSpec
    • javax.xml.crypto.dsig.spec.SignatureMethodParameterSpec
    • javax.xml.crypto.dsig.spec.TransformParameterSpec
      • javax.xml.crypto.dsig.spec.C14NMethodParameterSpec
  • javax.lang.model.AnnotatedConstruct
    • javax.lang.model.type.ArrayType
    • javax.lang.model.type.DeclaredType
      • javax.lang.model.type.ErrorType
    • javax.lang.model.element.Element
      • javax.lang.model.element.ExecutableElement (also extends javax.lang.model.element.Parameterizable)
      • javax.lang.model.element.PackageElement (also extends javax.lang.model.element.QualifiedNameable)
      • javax.lang.model.element.Parameterizable
        • javax.lang.model.element.ExecutableElement (also extends javax.lang.model.element.Element)
        • javax.lang.model.element.TypeElement (also extends javax.lang.model.element.Element, javax.lang.model.element.QualifiedNameable)
      • javax.lang.model.element.QualifiedNameable
        • javax.lang.model.element.PackageElement (also extends javax.lang.model.element.Element)
        • javax.lang.model.element.TypeElement (also extends javax.lang.model.element.Element, javax.lang.model.element.Parameterizable)
      • javax.lang.model.element.TypeElement (also extends javax.lang.model.element.Parameterizable, javax.lang.model.element.QualifiedNameable)
      • javax.lang.model.element.TypeParameterElement
      • javax.lang.model.element.VariableElement
    • javax.lang.model.type.ErrorType
    • javax.lang.model.element.ExecutableElement (also extends javax.lang.model.element.Element, javax.lang.model.element.Parameterizable)
    • javax.lang.model.type.ExecutableType
    • javax.lang.model.type.IntersectionType
    • javax.lang.model.type.NoType
    • javax.lang.model.type.NullType
    • javax.lang.model.element.PackageElement (also extends javax.lang.model.element.Element, javax.lang.model.element.QualifiedNameable)
    • javax.lang.model.element.Parameterizable
      • javax.lang.model.element.ExecutableElement (also extends javax.lang.model.element.Element)
      • javax.lang.model.element.TypeElement (also extends javax.lang.model.element.Element, javax.lang.model.element.QualifiedNameable)
    • javax.lang.model.type.PrimitiveType
    • javax.lang.model.element.QualifiedNameable
      • javax.lang.model.element.PackageElement (also extends javax.lang.model.element.Element)
      • javax.lang.model.element.TypeElement (also extends javax.lang.model.element.Element, javax.lang.model.element.Parameterizable)
    • javax.lang.model.type.ReferenceType
      • javax.lang.model.type.ArrayType
      • javax.lang.model.type.DeclaredType
        • javax.lang.model.type.ErrorType
      • javax.lang.model.type.ErrorType
      • javax.lang.model.type.NullType
      • javax.lang.model.type.TypeVariable
    • javax.lang.model.element.TypeElement (also extends javax.lang.model.element.Element, javax.lang.model.element.Parameterizable, javax.lang.model.element.QualifiedNameable)
    • javax.lang.model.type.TypeMirror
      • javax.lang.model.type.ArrayType
      • javax.lang.model.type.DeclaredType
        • javax.lang.model.type.ErrorType
      • javax.lang.model.type.ErrorType
      • javax.lang.model.type.ExecutableType
      • javax.lang.model.type.IntersectionType
      • javax.lang.model.type.NoType
      • javax.lang.model.type.NullType
      • javax.lang.model.type.PrimitiveType
      • javax.lang.model.type.ReferenceType
        • javax.lang.model.type.ArrayType
        • javax.lang.model.type.DeclaredType
          • javax.lang.model.type.ErrorType
        • javax.lang.model.type.ErrorType
        • javax.lang.model.type.NullType
        • javax.lang.model.type.TypeVariable
      • javax.lang.model.type.TypeVariable
      • javax.lang.model.type.UnionType
      • javax.lang.model.type.WildcardType
    • javax.lang.model.element.TypeParameterElement
    • javax.lang.model.type.TypeVariable
    • javax.lang.model.type.UnionType
    • javax.lang.model.element.VariableElement
    • javax.lang.model.type.WildcardType
  • java.lang.reflect.AnnotatedElement
    • java.lang.reflect.AnnotatedArrayType
    • java.lang.reflect.AnnotatedParameterizedType
    • java.lang.reflect.AnnotatedType
      • java.lang.reflect.AnnotatedArrayType
      • java.lang.reflect.AnnotatedParameterizedType
      • java.lang.reflect.AnnotatedTypeVariable
      • java.lang.reflect.AnnotatedWildcardType
    • java.lang.reflect.AnnotatedTypeVariable
    • java.lang.reflect.AnnotatedWildcardType
    • java.lang.reflect.GenericDeclaration
    • java.lang.reflect.TypeVariable<D> (also extends java.lang.reflect.Type)
  • java.lang.annotation.Annotation
  • javax.lang.model.element.AnnotationMirror
  • javax.lang.model.element.AnnotationValue
  • javax.lang.model.element.AnnotationValueVisitor<R,P>
  • java.lang.Appendable
  • java.applet.AppletContext
  • java.beans.AppletInitializer
  • java.applet.AppletStub
  • org.omg.CORBA.ARG_IN
  • org.omg.CORBA.ARG_INOUT
  • org.omg.CORBA.ARG_OUT
  • java.sql.Array
  • javax.xml.ws.AsyncHandler<T>
  • javax.print.AttributeException
  • org.xml.sax.AttributeList
  • org.xml.sax.Attributes
    • org.xml.sax.ext.Attributes2
  • javax.print.attribute.AttributeSet
    • javax.print.attribute.DocAttributeSet
    • javax.print.attribute.PrintJobAttributeSet
    • javax.print.attribute.PrintRequestAttributeSet
    • javax.print.attribute.PrintServiceAttributeSet
  • javax.swing.text.AttributeSet
    • javax.swing.text.MutableAttributeSet
      • javax.swing.text.Style
    • javax.swing.text.Style
  • javax.swing.text.AttributeSet.CharacterAttribute
  • javax.swing.text.AttributeSet.ColorAttribute
  • javax.swing.text.AttributeSet.FontAttribute
  • javax.swing.text.AttributeSet.ParagraphAttribute
  • java.nio.file.attribute.AttributeView
    • java.nio.file.attribute.AclFileAttributeView
    • java.nio.file.attribute.BasicFileAttributeView
      • java.nio.file.attribute.DosFileAttributeView
      • java.nio.file.attribute.PosixFileAttributeView (also extends java.nio.file.attribute.FileOwnerAttributeView)
    • java.nio.file.attribute.DosFileAttributeView
    • java.nio.file.attribute.FileAttributeView
      • java.nio.file.attribute.AclFileAttributeView
      • java.nio.file.attribute.BasicFileAttributeView
        • java.nio.file.attribute.DosFileAttributeView
        • java.nio.file.attribute.PosixFileAttributeView (also extends java.nio.file.attribute.FileOwnerAttributeView)
      • java.nio.file.attribute.DosFileAttributeView
      • java.nio.file.attribute.FileOwnerAttributeView
        • java.nio.file.attribute.AclFileAttributeView
        • java.nio.file.attribute.PosixFileAttributeView (also extends java.nio.file.attribute.BasicFileAttributeView)
      • java.nio.file.attribute.PosixFileAttributeView (also extends java.nio.file.attribute.BasicFileAttributeView, java.nio.file.attribute.FileOwnerAttributeView)
      • java.nio.file.attribute.UserDefinedFileAttributeView
    • java.nio.file.attribute.FileOwnerAttributeView
      • java.nio.file.attribute.AclFileAttributeView
      • java.nio.file.attribute.PosixFileAttributeView (also extends java.nio.file.attribute.BasicFileAttributeView)
    • java.nio.file.attribute.FileStoreAttributeView
    • java.nio.file.attribute.PosixFileAttributeView (also extends java.nio.file.attribute.BasicFileAttributeView, java.nio.file.attribute.FileOwnerAttributeView)
    • java.nio.file.attribute.UserDefinedFileAttributeView
  • java.applet.AudioClip
  • java.lang.AutoCloseable
    • java.nio.channels.AsynchronousByteChannel
    • java.nio.channels.AsynchronousChannel
      • java.nio.channels.AsynchronousByteChannel
    • java.util.stream.BaseStream<T,S>
      • java.util.stream.DoubleStream
      • java.util.stream.IntStream
      • java.util.stream.LongStream
      • java.util.stream.Stream<T>
    • java.nio.channels.ByteChannel (also extends java.nio.channels.ReadableByteChannel, java.nio.channels.WritableByteChannel)
      • java.nio.channels.SeekableByteChannel
    • javax.sql.rowset.CachedRowSet (also extends javax.sql.rowset.Joinable, javax.sql.RowSet)
      • javax.sql.rowset.FilteredRowSet
      • javax.sql.rowset.JoinRowSet
      • javax.sql.rowset.WebRowSet
        • javax.sql.rowset.FilteredRowSet
        • javax.sql.rowset.JoinRowSet
    • java.sql.CallableStatement
    • java.nio.channels.Channel
      • java.nio.channels.AsynchronousByteChannel
      • java.nio.channels.AsynchronousChannel
        • java.nio.channels.AsynchronousByteChannel
      • java.nio.channels.ByteChannel (also extends java.nio.channels.ReadableByteChannel, java.nio.channels.WritableByteChannel)
        • java.nio.channels.SeekableByteChannel
      • java.nio.channels.GatheringByteChannel
      • java.nio.channels.InterruptibleChannel
      • java.nio.channels.MulticastChannel
      • java.nio.channels.NetworkChannel
        • java.nio.channels.MulticastChannel
      • java.nio.channels.ReadableByteChannel
        • java.nio.channels.ByteChannel (also extends java.nio.channels.WritableByteChannel)
          • java.nio.channels.SeekableByteChannel
        • java.nio.channels.ScatteringByteChannel
        • java.nio.channels.SeekableByteChannel
      • java.nio.channels.ScatteringByteChannel
      • java.nio.channels.SeekableByteChannel
      • java.nio.channels.WritableByteChannel
        • java.nio.channels.ByteChannel (also extends java.nio.channels.ReadableByteChannel)
          • java.nio.channels.SeekableByteChannel
        • java.nio.channels.GatheringByteChannel
        • java.nio.channels.SeekableByteChannel
    • javax.sound.sampled.Clip
    • java.io.Closeable
      • java.nio.channels.AsynchronousByteChannel
      • java.nio.channels.AsynchronousChannel
        • java.nio.channels.AsynchronousByteChannel
      • java.nio.channels.ByteChannel (also extends java.nio.channels.ReadableByteChannel, java.nio.channels.WritableByteChannel)
        • java.nio.channels.SeekableByteChannel
      • java.nio.channels.Channel
        • java.nio.channels.AsynchronousByteChannel
        • java.nio.channels.AsynchronousChannel
          • java.nio.channels.AsynchronousByteChannel
        • java.nio.channels.ByteChannel (also extends java.nio.channels.ReadableByteChannel, java.nio.channels.WritableByteChannel)
          • java.nio.channels.SeekableByteChannel
        • java.nio.channels.GatheringByteChannel
        • java.nio.channels.InterruptibleChannel
        • java.nio.channels.MulticastChannel
        • java.nio.channels.NetworkChannel
          • java.nio.channels.MulticastChannel
        • java.nio.channels.ReadableByteChannel
          • java.nio.channels.ByteChannel (also extends java.nio.channels.WritableByteChannel)
            • java.nio.channels.SeekableByteChannel
          • java.nio.channels.ScatteringByteChannel
          • java.nio.channels.SeekableByteChannel
        • java.nio.channels.ScatteringByteChannel
        • java.nio.channels.SeekableByteChannel
        • java.nio.channels.WritableByteChannel
          • java.nio.channels.ByteChannel (also extends java.nio.channels.ReadableByteChannel)
            • java.nio.channels.SeekableByteChannel
          • java.nio.channels.GatheringByteChannel
          • java.nio.channels.SeekableByteChannel
      • java.nio.file.DirectoryStream<T> (also extends java.lang.Iterable<T>)
        • java.nio.file.SecureDirectoryStream<T>
      • java.nio.channels.GatheringByteChannel
      • javax.imageio.stream.ImageInputStream (also extends java.io.DataInput)
        • javax.imageio.stream.ImageOutputStream (also extends java.io.DataOutput)
      • javax.imageio.stream.ImageOutputStream (also extends java.io.DataOutput, javax.imageio.stream.ImageInputStream)
      • java.nio.channels.InterruptibleChannel
      • javax.tools.JavaFileManager (also extends java.io.Flushable, javax.tools.OptionChecker)
        • javax.tools.StandardJavaFileManager
      • javax.management.remote.JMXConnector
      • java.nio.channels.MulticastChannel
      • java.nio.channels.NetworkChannel
        • java.nio.channels.MulticastChannel
      • java.nio.channels.ReadableByteChannel
        • java.nio.channels.ByteChannel (also extends java.nio.channels.WritableByteChannel)
          • java.nio.channels.SeekableByteChannel
        • java.nio.channels.ScatteringByteChannel
        • java.nio.channels.SeekableByteChannel
      • javax.management.remote.rmi.RMIConnection (also extends java.rmi.Remote)
      • java.nio.channels.ScatteringByteChannel
      • java.nio.file.SecureDirectoryStream<T>
      • java.nio.channels.SeekableByteChannel
      • javax.tools.StandardJavaFileManager
      • java.nio.file.WatchService
      • java.nio.channels.WritableByteChannel
        • java.nio.channels.ByteChannel (also extends java.nio.channels.ReadableByteChannel)
          • java.nio.channels.SeekableByteChannel
        • java.nio.channels.GatheringByteChannel
        • java.nio.channels.SeekableByteChannel
    • java.sql.Connection (also extends java.sql.Wrapper)
    • javax.sound.sampled.DataLine
      • javax.sound.sampled.Clip
      • javax.sound.sampled.SourceDataLine
      • javax.sound.sampled.TargetDataLine
    • java.nio.file.DirectoryStream<T> (also extends java.io.Closeable, java.lang.Iterable<T>)
      • java.nio.file.SecureDirectoryStream<T>
    • java.util.stream.DoubleStream
    • javax.sql.rowset.FilteredRowSet
    • java.nio.channels.GatheringByteChannel
    • javax.imageio.stream.ImageInputStream (also extends java.io.Closeable, java.io.DataInput)
      • javax.imageio.stream.ImageOutputStream (also extends java.io.DataOutput)
    • javax.imageio.stream.ImageOutputStream (also extends java.io.DataOutput, javax.imageio.stream.ImageInputStream)
    • java.nio.channels.InterruptibleChannel
    • java.util.stream.IntStream
    • javax.tools.JavaFileManager (also extends java.io.Closeable, java.io.Flushable, javax.tools.OptionChecker)
      • javax.tools.StandardJavaFileManager
    • javax.sql.rowset.JdbcRowSet (also extends javax.sql.rowset.Joinable, javax.sql.RowSet)
    • javax.management.remote.JMXConnector
    • javax.sql.rowset.JoinRowSet
    • javax.sound.sampled.Line
      • javax.sound.sampled.Clip
      • javax.sound.sampled.DataLine
        • javax.sound.sampled.Clip
        • javax.sound.sampled.SourceDataLine
        • javax.sound.sampled.TargetDataLine
      • javax.sound.sampled.Mixer
      • javax.sound.sampled.Port
      • javax.sound.sampled.SourceDataLine
      • javax.sound.sampled.TargetDataLine
    • java.util.stream.LongStream
    • javax.sound.midi.MidiDevice
      • javax.sound.midi.Sequencer
      • javax.sound.midi.Synthesizer
    • javax.sound.midi.MidiDeviceReceiver
    • javax.sound.midi.MidiDeviceTransmitter
    • javax.sound.sampled.Mixer
    • java.nio.channels.MulticastChannel
    • java.nio.channels.NetworkChannel
      • java.nio.channels.MulticastChannel
    • java.io.ObjectInput (also extends java.io.DataInput)
    • java.io.ObjectOutput (also extends java.io.DataOutput)
    • javax.sound.sampled.Port
    • java.sql.PreparedStatement
      • java.sql.CallableStatement
    • java.nio.channels.ReadableByteChannel
      • java.nio.channels.ByteChannel (also extends java.nio.channels.WritableByteChannel)
        • java.nio.channels.SeekableByteChannel
      • java.nio.channels.ScatteringByteChannel
      • java.nio.channels.SeekableByteChannel
    • javax.sound.midi.Receiver
      • javax.sound.midi.MidiDeviceReceiver
    • java.sql.ResultSet (also extends java.sql.Wrapper)
      • javax.sql.rowset.CachedRowSet (also extends javax.sql.rowset.Joinable, javax.sql.RowSet)
        • javax.sql.rowset.FilteredRowSet
        • javax.sql.rowset.JoinRowSet
        • javax.sql.rowset.WebRowSet
          • javax.sql.rowset.FilteredRowSet
          • javax.sql.rowset.JoinRowSet
      • javax.sql.rowset.FilteredRowSet
      • javax.sql.rowset.JdbcRowSet (also extends javax.sql.rowset.Joinable, javax.sql.RowSet)
      • javax.sql.rowset.JoinRowSet
      • javax.sql.RowSet
        • javax.sql.rowset.CachedRowSet (also extends javax.sql.rowset.Joinable)
          • javax.sql.rowset.FilteredRowSet
          • javax.sql.rowset.JoinRowSet
          • javax.sql.rowset.WebRowSet
            • javax.sql.rowset.FilteredRowSet
            • javax.sql.rowset.JoinRowSet
        • javax.sql.rowset.FilteredRowSet
        • javax.sql.rowset.JdbcRowSet (also extends javax.sql.rowset.Joinable)
        • javax.sql.rowset.JoinRowSet
        • javax.sql.rowset.spi.SyncResolver
        • javax.sql.rowset.WebRowSet
          • javax.sql.rowset.FilteredRowSet
          • javax.sql.rowset.JoinRowSet
      • javax.sql.rowset.spi.SyncResolver
      • javax.sql.rowset.WebRowSet
        • javax.sql.rowset.FilteredRowSet
        • javax.sql.rowset.JoinRowSet
    • javax.management.remote.rmi.RMIConnection (also extends java.io.Closeable, java.rmi.Remote)
    • javax.sql.RowSet
      • javax.sql.rowset.CachedRowSet (also extends javax.sql.rowset.Joinable)
        • javax.sql.rowset.FilteredRowSet
        • javax.sql.rowset.JoinRowSet
        • javax.sql.rowset.WebRowSet
          • javax.sql.rowset.FilteredRowSet
          • javax.sql.rowset.JoinRowSet
      • javax.sql.rowset.FilteredRowSet
      • javax.sql.rowset.JdbcRowSet (also extends javax.sql.rowset.Joinable)
      • javax.sql.rowset.JoinRowSet
      • javax.sql.rowset.spi.SyncResolver
      • javax.sql.rowset.WebRowSet
        • javax.sql.rowset.FilteredRowSet
        • javax.sql.rowset.JoinRowSet
    • java.nio.channels.ScatteringByteChannel
    • java.nio.file.SecureDirectoryStream<T>
    • java.nio.channels.SeekableByteChannel
    • javax.sound.midi.Sequencer
    • javax.sound.sampled.SourceDataLine
    • javax.tools.StandardJavaFileManager
    • java.sql.Statement (also extends java.sql.Wrapper)
      • java.sql.CallableStatement
      • java.sql.PreparedStatement
        • java.sql.CallableStatement
    • java.util.stream.Stream<T>
    • javax.sql.rowset.spi.SyncResolver
    • javax.sound.midi.Synthesizer
    • javax.sound.sampled.TargetDataLine
    • javax.sound.midi.Transmitter
      • javax.sound.midi.MidiDeviceTransmitter
    • java.nio.file.WatchService
    • javax.sql.rowset.WebRowSet
      • javax.sql.rowset.FilteredRowSet
      • javax.sql.rowset.JoinRowSet
    • java.nio.channels.WritableByteChannel
      • java.nio.channels.ByteChannel (also extends java.nio.channels.ReadableByteChannel)
        • java.nio.channels.SeekableByteChannel
      • java.nio.channels.GatheringByteChannel
      • java.nio.channels.SeekableByteChannel
  • java.awt.dnd.Autoscroll
  • org.omg.CORBA.BAD_POLICY
  • org.omg.CORBA.BAD_POLICY_TYPE
  • org.omg.CORBA.BAD_POLICY_VALUE
  • java.nio.file.attribute.BasicFileAttributes
    • java.nio.file.attribute.DosFileAttributes
    • java.nio.file.attribute.PosixFileAttributes
  • java.beans.beancontext.BeanContextChild
    • java.beans.beancontext.BeanContext (also extends java.util.Collection<E>, java.beans.DesignMode, java.beans.Visibility)
      • java.beans.beancontext.BeanContextServices (also extends java.beans.beancontext.BeanContextServicesListener)
    • java.beans.beancontext.BeanContextServices (also extends java.beans.beancontext.BeanContext, java.beans.beancontext.BeanContextServicesListener)
  • java.beans.beancontext.BeanContextChildComponentProxy
  • java.beans.beancontext.BeanContextContainerProxy
  • java.beans.beancontext.BeanContextProxy
  • java.beans.beancontext.BeanContextServiceProvider
  • java.beans.BeanInfo
    • java.beans.beancontext.BeanContextServiceProviderBeanInfo
  • java.util.function.BiConsumer<T,U>
  • java.util.function.BiFunction<T,U,R>
    • java.util.function.BinaryOperator<T>
  • javax.xml.ws.Binding
    • javax.xml.ws.http.HTTPBinding
    • javax.xml.ws.soap.SOAPBinding
  • org.omg.CosNaming.BindingIteratorOperations
    • org.omg.CosNaming.BindingIterator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • javax.xml.ws.BindingProvider
    • javax.xml.ws.Dispatch<T>
  • java.util.function.BiPredicate<T,U>
  • java.sql.Blob
  • java.util.function.BooleanSupplier
  • javax.swing.border.Border
  • javax.swing.BoundedRangeModel
  • org.omg.CORBA.portable.BoxedValueHelper
  • java.awt.image.BufferedImageOp
  • java.util.concurrent.Callable<V>
    • javax.tools.DocumentationTool.DocumentationTask
    • javax.tools.JavaCompiler.CompilationTask
  • javax.security.auth.callback.Callback
  • javax.security.auth.callback.CallbackHandler
  • javax.swing.text.Caret
  • javax.swing.CellEditor
    • javax.swing.table.TableCellEditor
    • javax.swing.tree.TreeCellEditor
  • java.security.Certificate
  • java.security.cert.CertPathChecker
  • java.lang.CharSequence
    • javax.lang.model.element.Name
  • java.util.zip.Checksum
  • java.lang.instrument.ClassFileTransformer
  • javax.management.loading.ClassLoaderRepository
  • java.awt.datatransfer.ClipboardOwner
  • java.sql.Clob
    • java.sql.NClob
  • java.lang.Cloneable
    • java.security.acl.AclEntry
    • javax.naming.directory.Attribute (also extends java.io.Serializable)
    • java.text.AttributedCharacterIterator
    • javax.naming.directory.Attributes (also extends java.io.Serializable)
    • java.security.cert.CertPathBuilderResult
    • java.security.cert.CertPathParameters
    • java.security.cert.CertPathValidatorResult
    • java.security.cert.CertSelector
    • java.security.cert.CertStoreParameters
    • java.text.CharacterIterator
      • java.text.AttributedCharacterIterator
    • java.security.cert.CRLSelector
    • javax.management.Descriptor (also extends java.io.Serializable)
    • org.ietf.jgss.GSSCredential
    • javax.naming.Name (also extends java.lang.Comparable<T>, java.io.Serializable)
  • org.omg.IOP.CodecFactoryOperations
    • org.omg.IOP.CodecFactory (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.IOP.CodecOperations
    • org.omg.IOP.Codec (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.IOP.CodeSets
  • java.util.stream.Collector<T,A,R>
  • javax.swing.colorchooser.ColorSelectionModel
  • javax.swing.ComboBoxEditor
  • javax.swing.plaf.basic.ComboPopup
  • javax.activation.CommandObject
  • javax.sql.CommonDataSource
    • javax.sql.ConnectionPoolDataSource
    • javax.sql.DataSource (also extends java.sql.Wrapper)
    • javax.sql.XADataSource
  • java.lang.Comparable<T>
    • java.time.chrono.ChronoLocalDate (also extends java.time.temporal.Temporal, java.time.temporal.TemporalAdjuster)
    • java.time.chrono.ChronoLocalDateTime<D> (also extends java.time.temporal.Temporal, java.time.temporal.TemporalAdjuster)
    • java.time.chrono.Chronology
    • java.time.chrono.ChronoZonedDateTime<D> (also extends java.time.temporal.Temporal)
    • java.util.concurrent.Delayed
      • java.util.concurrent.RunnableScheduledFuture<V> (also extends java.util.concurrent.RunnableFuture<V>, java.util.concurrent.ScheduledFuture<V>)
      • java.util.concurrent.ScheduledFuture<V> (also extends java.util.concurrent.Future<V>)
        • java.util.concurrent.RunnableScheduledFuture<V> (also extends java.util.concurrent.RunnableFuture<V>)
    • javax.naming.Name (also extends java.lang.Cloneable, java.io.Serializable)
    • java.nio.file.Path (also extends java.lang.Iterable<T>, java.nio.file.Watchable)
    • java.util.concurrent.RunnableScheduledFuture<V> (also extends java.util.concurrent.RunnableFuture<V>, java.util.concurrent.ScheduledFuture<V>)
    • java.util.concurrent.ScheduledFuture<V> (also extends java.util.concurrent.Delayed, java.util.concurrent.Future<V>)
      • java.util.concurrent.RunnableScheduledFuture<V> (also extends java.util.concurrent.RunnableFuture<V>)
  • java.util.Comparator<T>
  • javax.script.Compilable
  • java.util.concurrent.CompletableFuture.AsynchronousCompletionTask
  • javax.annotation.processing.Completion
  • java.nio.channels.CompletionHandler<V,A>
  • java.util.concurrent.CompletionService<V>
  • java.util.concurrent.CompletionStage<T>
  • java.awt.Composite
  • java.awt.CompositeContext
  • javax.management.openmbean.CompositeData
  • javax.management.openmbean.CompositeDataView
  • java.util.concurrent.locks.Condition
  • javax.security.auth.login.Configuration.Parameters
  • java.util.function.Consumer<T>
    • java.util.stream.Stream.Builder<T>
  • org.xml.sax.ContentHandler
    • javax.xml.transform.sax.TemplatesHandler
    • javax.xml.transform.sax.TransformerHandler (also extends org.xml.sax.DTDHandler, org.xml.sax.ext.LexicalHandler)
    • javax.xml.bind.UnmarshallerHandler
  • java.net.ContentHandlerFactory
  • javax.naming.Context
    • javax.naming.directory.DirContext
      • javax.naming.event.EventDirContext (also extends javax.naming.event.EventContext)
      • javax.naming.ldap.LdapContext
    • javax.naming.event.EventContext
      • javax.naming.event.EventDirContext (also extends javax.naming.directory.DirContext)
    • javax.naming.event.EventDirContext (also extends javax.naming.directory.DirContext, javax.naming.event.EventContext)
    • javax.naming.ldap.LdapContext
  • java.net.CookiePolicy
  • java.net.CookieStore
  • java.nio.file.CopyOption
  • org.omg.CORBA.CTX_RESTRICT_SCOPE
  • org.omg.CORBA.CurrentOperations
    • org.omg.CORBA.Current (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableServer.Current (also extends org.omg.PortableServer.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.Current (also extends org.omg.PortableInterceptor.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.Current (also extends org.omg.CORBA.Current, org.omg.PortableServer.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableInterceptor.Current (also extends org.omg.CORBA.Current, org.omg.PortableInterceptor.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.CurrentOperations
      • org.omg.PortableServer.Current (also extends org.omg.CORBA.Current, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableInterceptor.CurrentOperations
      • org.omg.PortableInterceptor.Current (also extends org.omg.CORBA.Current, org.omg.CORBA.portable.IDLEntity)
  • java.beans.Customizer
  • org.omg.CORBA.CustomMarshal
    • org.omg.CORBA.portable.CustomValue (also extends org.omg.CORBA.portable.ValueBase)
  • javax.xml.crypto.Data
    • javax.xml.crypto.NodeSetData
  • javax.activation.DataContentHandler
  • javax.activation.DataContentHandlerFactory
  • java.net.DatagramSocketImplFactory
  • java.io.DataInput
    • javax.imageio.stream.ImageInputStream (also extends java.io.Closeable)
      • javax.imageio.stream.ImageOutputStream (also extends java.io.DataOutput)
    • javax.imageio.stream.ImageOutputStream (also extends java.io.DataOutput, javax.imageio.stream.ImageInputStream)
    • java.io.ObjectInput (also extends java.lang.AutoCloseable)
  • java.io.DataOutput
    • javax.imageio.stream.ImageOutputStream (also extends javax.imageio.stream.ImageInputStream)
    • java.io.ObjectOutput (also extends java.lang.AutoCloseable)
  • javax.activation.DataSource
  • javax.xml.bind.DatatypeConverterInterface
  • org.xml.sax.ext.DeclHandler
  • org.omg.PortableServer.portable.Delegate
  • javax.management.DescriptorRead
    • javax.management.DescriptorAccess
  • java.beans.DesignMode
    • java.beans.beancontext.BeanContext (also extends java.beans.beancontext.BeanContextChild, java.util.Collection<E>, java.beans.Visibility)
      • java.beans.beancontext.BeanContextServices (also extends java.beans.beancontext.BeanContextServicesListener)
    • java.beans.beancontext.BeanContextServices (also extends java.beans.beancontext.BeanContext, java.beans.beancontext.BeanContextServicesListener)
  • javax.swing.DesktopManager
  • javax.security.auth.Destroyable
    • javax.crypto.interfaces.DHPrivateKey (also extends javax.crypto.interfaces.DHKey, java.security.PrivateKey)
    • java.security.interfaces.DSAPrivateKey (also extends java.security.interfaces.DSAKey, java.security.PrivateKey)
    • java.security.interfaces.ECPrivateKey (also extends java.security.interfaces.ECKey, java.security.PrivateKey)
    • javax.crypto.interfaces.PBEKey
    • java.security.PrivateKey (also extends java.security.Key)
      • javax.crypto.interfaces.DHPrivateKey (also extends javax.crypto.interfaces.DHKey)
      • java.security.interfaces.DSAPrivateKey (also extends java.security.interfaces.DSAKey)
      • java.security.interfaces.ECPrivateKey (also extends java.security.interfaces.ECKey)
      • java.security.interfaces.RSAMultiPrimePrivateCrtKey
      • java.security.interfaces.RSAPrivateCrtKey
      • java.security.interfaces.RSAPrivateKey (also extends java.security.interfaces.RSAKey)
        • java.security.interfaces.RSAMultiPrimePrivateCrtKey
        • java.security.interfaces.RSAPrivateCrtKey
    • java.security.interfaces.RSAMultiPrimePrivateCrtKey
    • java.security.interfaces.RSAPrivateCrtKey
    • java.security.interfaces.RSAPrivateKey (also extends java.security.PrivateKey, java.security.interfaces.RSAKey)
      • java.security.interfaces.RSAMultiPrimePrivateCrtKey
      • java.security.interfaces.RSAPrivateCrtKey
    • javax.crypto.SecretKey (also extends java.security.Key)
      • javax.crypto.interfaces.PBEKey
  • javax.crypto.interfaces.DHKey
    • javax.crypto.interfaces.DHPrivateKey (also extends java.security.PrivateKey)
    • javax.crypto.interfaces.DHPublicKey (also extends java.security.PublicKey)
  • javax.tools.Diagnostic<S>
  • javax.tools.DiagnosticListener<S>
  • java.nio.file.DirectoryStream.Filter<T>
  • org.omg.PortableInterceptor.DISCARDING
  • javax.print.Doc
  • javax.print.DocPrintJob
    • javax.print.CancelablePrintJob
    • javax.print.MultiDocPrintJob
  • javax.swing.text.Document
    • javax.swing.text.StyledDocument
  • javax.swing.event.DocumentEvent
  • org.w3c.dom.events.DocumentEvent
  • javax.swing.event.DocumentEvent.ElementChange
  • org.xml.sax.DocumentHandler
  • org.w3c.dom.views.DocumentView
  • java.security.DomainCombiner
  • org.omg.CORBA.DomainManagerOperations
    • org.omg.CORBA.DomainManager (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.w3c.dom.DOMConfiguration
  • org.w3c.dom.DOMError
  • org.w3c.dom.DOMErrorHandler
  • javax.xml.bind.annotation.DomHandler<ElementT,ResultT>
  • org.w3c.dom.DOMImplementation
  • org.w3c.dom.DOMImplementationList
  • org.w3c.dom.ls.DOMImplementationLS
  • org.w3c.dom.DOMImplementationSource
  • org.w3c.dom.DOMLocator
  • org.w3c.dom.DOMStringList
  • java.util.function.DoubleBinaryOperator
  • java.util.function.DoubleConsumer
    • java.util.stream.DoubleStream.Builder
  • java.util.function.DoubleFunction<R>
  • java.util.function.DoublePredicate
  • java.util.function.DoubleSupplier
  • java.util.function.DoubleToIntFunction
  • java.util.function.DoubleToLongFunction
  • java.util.function.DoubleUnaryOperator
  • java.sql.Driver
  • java.sql.DriverAction
  • java.security.interfaces.DSAKey
    • java.security.interfaces.DSAPrivateKey (also extends java.security.PrivateKey)
    • java.security.interfaces.DSAPublicKey (also extends java.security.PublicKey)
  • java.security.interfaces.DSAKeyPairGenerator
  • java.security.interfaces.DSAParams
  • javax.swing.text.html.parser.DTDConstants
  • org.xml.sax.DTDHandler
    • javax.xml.transform.sax.TransformerHandler (also extends org.xml.sax.ContentHandler, org.xml.sax.ext.LexicalHandler)
  • javax.management.DynamicMBean
    • javax.management.modelmbean.ModelMBean (also extends javax.management.modelmbean.ModelMBeanNotificationBroadcaster, javax.management.PersistentMBean)
  • org.omg.DynamicAny.DynAnyFactoryOperations
    • org.omg.DynamicAny.DynAnyFactory (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.DynamicAny.DynAnyOperations
    • org.omg.DynamicAny.DynAny (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.DynamicAny.DynArray (also extends org.omg.DynamicAny.DynArrayOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynEnum (also extends org.omg.DynamicAny.DynEnumOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynFixed (also extends org.omg.DynamicAny.DynFixedOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynSequence (also extends org.omg.DynamicAny.DynSequenceOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynStruct (also extends org.omg.DynamicAny.DynStructOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynUnion (also extends org.omg.DynamicAny.DynUnionOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueCommon, org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueCommon (also extends org.omg.DynamicAny.DynValueCommonOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynArray (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynArrayOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynArrayOperations
      • org.omg.DynamicAny.DynArray (also extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynEnum (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynEnumOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynEnumOperations
      • org.omg.DynamicAny.DynEnum (also extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynFixed (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynFixedOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynFixedOperations
      • org.omg.DynamicAny.DynFixed (also extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynSequence (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynSequenceOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynSequenceOperations
      • org.omg.DynamicAny.DynSequence (also extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynStruct (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynStructOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynStructOperations
      • org.omg.DynamicAny.DynStruct (also extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynUnion (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynUnionOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynUnionOperations
      • org.omg.DynamicAny.DynUnion (also extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueCommon, org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynValueBoxOperations
      • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynValueCommon (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynValueCommonOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynValueCommonOperations
      • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueCommon, org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueBoxOperations
        • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueCommon (also extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueOperations
        • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynValueOperations
      • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
  • java.security.spec.ECField
  • java.security.interfaces.ECKey
    • java.security.interfaces.ECPrivateKey (also extends java.security.PrivateKey)
    • java.security.interfaces.ECPublicKey (also extends java.security.PublicKey)
  • javax.swing.text.Element
  • javax.xml.bind.Element
  • javax.lang.model.util.Elements
  • javax.lang.model.element.ElementVisitor<R,P>
  • org.omg.IOP.ENCODING_CDR_ENCAPS
  • org.xml.sax.EntityResolver
    • org.xml.sax.ext.EntityResolver2
  • java.util.Enumeration<E>
    • javax.naming.NamingEnumeration<T>
  • org.xml.sax.ErrorHandler
  • javax.xml.transform.ErrorListener
  • org.w3c.dom.events.Event
    • org.w3c.dom.ls.LSLoadEvent
    • org.w3c.dom.ls.LSProgressEvent
    • org.w3c.dom.events.MouseEvent
    • org.w3c.dom.events.MutationEvent
    • org.w3c.dom.events.UIEvent
      • org.w3c.dom.events.MouseEvent
  • javax.xml.stream.EventFilter
  • java.util.EventListener
    • javax.swing.Action
    • java.awt.event.ActionListener
      • javax.swing.Action
    • java.awt.event.AdjustmentListener
    • javax.swing.event.AncestorListener
    • java.awt.event.AWTEventListener
    • java.beans.beancontext.BeanContextMembershipListener
    • java.beans.beancontext.BeanContextServiceRevokedListener
      • java.beans.beancontext.BeanContextServices (also extends java.beans.beancontext.BeanContext, java.beans.beancontext.BeanContextServicesListener)
      • java.beans.beancontext.BeanContextServicesListener
        • java.beans.beancontext.BeanContextServices (also extends java.beans.beancontext.BeanContext)
    • java.beans.beancontext.BeanContextServices (also extends java.beans.beancontext.BeanContext, java.beans.beancontext.BeanContextServicesListener)
    • java.beans.beancontext.BeanContextServicesListener
      • java.beans.beancontext.BeanContextServices (also extends java.beans.beancontext.BeanContext)
    • javax.swing.event.CaretListener
    • javax.swing.event.CellEditorListener
    • javax.swing.event.ChangeListener
    • java.awt.event.ComponentListener
    • javax.sql.ConnectionEventListener
    • java.awt.event.ContainerListener
    • javax.sound.midi.ControllerEventListener
    • javax.swing.event.DocumentListener
    • java.awt.dnd.DragGestureListener
    • java.awt.dnd.DragSourceListener
    • java.awt.dnd.DragSourceMotionListener
    • java.awt.dnd.DropTargetListener
    • java.awt.datatransfer.FlavorListener
    • java.awt.event.FocusListener
    • javax.net.ssl.HandshakeCompletedListener
    • java.awt.event.HierarchyBoundsListener
    • java.awt.event.HierarchyListener
    • javax.swing.event.HyperlinkListener
    • javax.imageio.event.IIOReadProgressListener
    • javax.imageio.event.IIOReadUpdateListener
    • javax.imageio.event.IIOReadWarningListener
    • javax.imageio.event.IIOWriteProgressListener
    • javax.imageio.event.IIOWriteWarningListener
    • java.awt.event.InputMethodListener
    • javax.swing.event.InternalFrameListener
    • java.awt.event.ItemListener
    • java.awt.event.KeyListener
    • javax.sound.sampled.LineListener
    • javax.swing.event.ListDataListener
    • javax.swing.event.ListSelectionListener
    • javax.swing.event.MenuDragMouseListener
    • javax.swing.event.MenuKeyListener
    • javax.swing.event.MenuListener
    • javax.sound.midi.MetaEventListener
    • javax.swing.event.MouseInputListener (also extends java.awt.event.MouseListener, java.awt.event.MouseMotionListener)
    • java.awt.event.MouseListener
      • javax.swing.event.MouseInputListener (also extends java.awt.event.MouseMotionListener)
    • java.awt.event.MouseMotionListener
      • javax.swing.event.MouseInputListener (also extends java.awt.event.MouseListener)
    • java.awt.event.MouseWheelListener
    • javax.naming.event.NamespaceChangeListener
    • javax.naming.event.NamingListener
      • javax.naming.event.NamespaceChangeListener
      • javax.naming.event.ObjectChangeListener
      • javax.naming.ldap.UnsolicitedNotificationListener
    • java.util.prefs.NodeChangeListener
    • javax.management.NotificationListener
    • javax.naming.event.ObjectChangeListener
    • javax.swing.event.PopupMenuListener
    • java.util.prefs.PreferenceChangeListener
    • java.beans.PropertyChangeListener
    • javax.sql.RowSetListener
    • javax.swing.event.RowSorterListener
    • javax.net.ssl.SSLSessionBindingListener
    • javax.sql.StatementEventListener
    • javax.swing.event.TableColumnModelListener
    • javax.swing.event.TableModelListener
    • java.awt.event.TextListener
    • javax.swing.event.TreeExpansionListener
    • javax.swing.event.TreeModelListener
    • javax.swing.event.TreeSelectionListener
    • javax.swing.event.TreeWillExpandListener
    • javax.swing.event.UndoableEditListener
    • javax.naming.ldap.UnsolicitedNotificationListener
    • java.beans.VetoableChangeListener
    • java.awt.event.WindowFocusListener
    • java.awt.event.WindowListener
    • java.awt.event.WindowStateListener
  • org.w3c.dom.events.EventListener
  • org.w3c.dom.events.EventTarget
  • org.omg.IOP.ExceptionDetailMessage
  • java.beans.ExceptionListener
  • java.util.concurrent.Executor
    • java.util.concurrent.ExecutorService
      • java.util.concurrent.ScheduledExecutorService
    • java.util.concurrent.ScheduledExecutorService
  • java.security.cert.Extension
  • java.nio.file.attribute.FileAttribute<T>
  • java.io.FileFilter
  • java.io.FilenameFilter
  • java.net.FileNameMap
  • javax.tools.FileObject
    • javax.tools.JavaFileObject
  • javax.annotation.processing.Filer
  • java.nio.file.FileVisitor<T>
  • java.util.logging.Filter
  • javax.print.FlavorException
  • java.awt.datatransfer.FlavorMap
    • java.awt.datatransfer.FlavorTable
  • java.io.Flushable
    • javax.tools.JavaFileManager (also extends java.io.Closeable, javax.tools.OptionChecker)
      • javax.tools.StandardJavaFileManager
    • javax.tools.StandardJavaFileManager
  • java.util.concurrent.ForkJoinPool.ForkJoinWorkerThreadFactory
  • java.util.concurrent.ForkJoinPool.ManagedBlocker
  • java.util.Formattable
  • java.util.function.Function<T,R>
    • java.util.function.UnaryOperator<T>
  • java.util.concurrent.Future<V>
    • javax.xml.ws.Response<T>
    • java.util.concurrent.RunnableFuture<V> (also extends java.lang.Runnable)
      • java.util.concurrent.RunnableScheduledFuture<V> (also extends java.util.concurrent.ScheduledFuture<V>)
    • java.util.concurrent.RunnableScheduledFuture<V> (also extends java.util.concurrent.RunnableFuture<V>, java.util.concurrent.ScheduledFuture<V>)
    • java.util.concurrent.ScheduledFuture<V> (also extends java.util.concurrent.Delayed)
      • java.util.concurrent.RunnableScheduledFuture<V> (also extends java.util.concurrent.RunnableFuture<V>)
  • org.ietf.jgss.GSSContext
  • org.ietf.jgss.GSSName
  • java.security.Guard
  • javax.xml.ws.handler.Handler<C>
    • javax.xml.ws.handler.LogicalHandler<C>
    • javax.xml.ws.handler.soap.SOAPHandler<T>
  • javax.xml.ws.handler.HandlerResolver
  • javax.naming.ldap.HasControls
    • javax.naming.ldap.UnsolicitedNotification (also extends javax.naming.ldap.ExtendedResponse)
  • javax.swing.text.Highlighter
  • javax.swing.text.Highlighter.Highlight
  • javax.swing.text.Highlighter.HighlightPainter
  • org.omg.PortableInterceptor.HOLDING
  • javax.net.ssl.HostnameVerifier
  • javax.swing.Icon
  • org.omg.PortableServer.ID_ASSIGNMENT_POLICY_ID
  • org.omg.PortableServer.ID_UNIQUENESS_POLICY_ID
  • javax.imageio.metadata.IIOMetadataController
  • javax.imageio.metadata.IIOMetadataFormat
  • javax.imageio.IIOParamController
  • java.awt.image.ImageConsumer
  • java.awt.image.ImageObserver
  • java.awt.image.ImageProducer
  • javax.imageio.ImageTranscoder
  • org.omg.PortableServer.IMPLICIT_ACTIVATION_POLICY_ID
  • org.omg.PortableInterceptor.INACTIVE
  • javax.naming.spi.InitialContextFactory
  • javax.naming.spi.InitialContextFactoryBuilder
  • java.awt.im.spi.InputMethod
  • java.awt.im.spi.InputMethodDescriptor
  • java.awt.im.InputMethodRequests
    • java.awt.im.spi.InputMethodContext
  • java.lang.instrument.Instrumentation
  • java.util.function.IntBinaryOperator
  • java.util.function.IntConsumer
    • java.util.stream.IntStream.Builder
  • org.omg.PortableInterceptor.InterceptorOperations
    • org.omg.PortableInterceptor.ClientRequestInterceptor (also extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor)
    • org.omg.PortableInterceptor.ClientRequestInterceptorOperations
      • org.omg.PortableInterceptor.ClientRequestInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor)
    • org.omg.PortableInterceptor.Interceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableInterceptor.ClientRequestInterceptor (also extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.IORInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptorOperations)
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.ServerRequestInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
    • org.omg.PortableInterceptor.IORInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor, org.omg.PortableInterceptor.IORInterceptorOperations)
      • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
    • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
    • org.omg.PortableInterceptor.IORInterceptor_3_0Operations
      • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor)
    • org.omg.PortableInterceptor.IORInterceptorOperations
      • org.omg.PortableInterceptor.IORInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor)
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.IORInterceptor_3_0Operations
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor)
    • org.omg.PortableInterceptor.ServerRequestInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
    • org.omg.PortableInterceptor.ServerRequestInterceptorOperations
      • org.omg.PortableInterceptor.ServerRequestInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor)
  • java.util.function.IntFunction<R>
  • java.util.function.IntPredicate
  • java.util.function.IntSupplier
  • java.util.function.IntToDoubleFunction
  • java.util.function.IntToLongFunction
  • java.util.function.IntUnaryOperator
  • javax.script.Invocable
  • java.lang.reflect.InvocationHandler
  • org.omg.CORBA.portable.InvokeHandler
    • javax.rmi.CORBA.Tie
  • org.omg.PortableInterceptor.IORInfoOperations
    • org.omg.PortableInterceptor.IORInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.CORBA.IRObjectOperations
    • org.omg.CORBA.IDLType (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IDLTypeOperations, org.omg.CORBA.IRObject)
    • org.omg.CORBA.IDLTypeOperations
      • org.omg.CORBA.IDLType (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IRObject)
    • org.omg.CORBA.IRObject (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.CORBA.IDLType (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IDLTypeOperations)
  • java.awt.ItemSelectable
    • javax.swing.ButtonModel
  • java.lang.Iterable<T>
    • java.beans.beancontext.BeanContext (also extends java.beans.beancontext.BeanContextChild, java.util.Collection<E>, java.beans.DesignMode, java.beans.Visibility)
      • java.beans.beancontext.BeanContextServices (also extends java.beans.beancontext.BeanContextServicesListener)
    • java.beans.beancontext.BeanContextServices (also extends java.beans.beancontext.BeanContext, java.beans.beancontext.BeanContextServicesListener)
    • java.util.concurrent.BlockingDeque<E> (also extends java.util.concurrent.BlockingQueue<E>, java.util.Deque<E>)
    • java.util.concurrent.BlockingQueue<E>
      • java.util.concurrent.BlockingDeque<E> (also extends java.util.Deque<E>)
      • java.util.concurrent.TransferQueue<E>
    • java.util.Collection<E>
      • java.beans.beancontext.BeanContext (also extends java.beans.beancontext.BeanContextChild, java.beans.DesignMode, java.beans.Visibility)
        • java.beans.beancontext.BeanContextServices (also extends java.beans.beancontext.BeanContextServicesListener)
      • java.beans.beancontext.BeanContextServices (also extends java.beans.beancontext.BeanContext, java.beans.beancontext.BeanContextServicesListener)
      • java.util.concurrent.BlockingDeque<E> (also extends java.util.concurrent.BlockingQueue<E>, java.util.Deque<E>)
      • java.util.concurrent.BlockingQueue<E>
        • java.util.concurrent.BlockingDeque<E> (also extends java.util.Deque<E>)
        • java.util.concurrent.TransferQueue<E>
      • java.util.Deque<E>
        • java.util.concurrent.BlockingDeque<E> (also extends java.util.concurrent.BlockingQueue<E>)
      • java.util.List<E>
      • java.util.NavigableSet<E>
      • java.util.Queue<E>
        • java.util.concurrent.BlockingDeque<E> (also extends java.util.concurrent.BlockingQueue<E>, java.util.Deque<E>)
        • java.util.concurrent.BlockingQueue<E>
          • java.util.concurrent.BlockingDeque<E> (also extends java.util.Deque<E>)
          • java.util.concurrent.TransferQueue<E>
        • java.util.Deque<E>
          • java.util.concurrent.BlockingDeque<E> (also extends java.util.concurrent.BlockingQueue<E>)
        • java.util.concurrent.TransferQueue<E>
      • java.util.Set<E>
        • java.util.NavigableSet<E>
        • java.util.SortedSet<E>
          • java.util.NavigableSet<E>
      • java.util.SortedSet<E>
        • java.util.NavigableSet<E>
      • java.util.concurrent.TransferQueue<E>
    • java.util.Deque<E>
      • java.util.concurrent.BlockingDeque<E> (also extends java.util.concurrent.BlockingQueue<E>)
    • java.nio.file.DirectoryStream<T> (also extends java.io.Closeable)
      • java.nio.file.SecureDirectoryStream<T>
    • java.util.List<E>
    • java.util.NavigableSet<E>
    • java.nio.file.Path (also extends java.lang.Comparable<T>, java.nio.file.Watchable)
    • java.util.Queue<E>
      • java.util.concurrent.BlockingDeque<E> (also extends java.util.concurrent.BlockingQueue<E>, java.util.Deque<E>)
      • java.util.concurrent.BlockingQueue<E>
        • java.util.concurrent.BlockingDeque<E> (also extends java.util.Deque<E>)
        • java.util.concurrent.TransferQueue<E>
      • java.util.Deque<E>
        • java.util.concurrent.BlockingDeque<E> (also extends java.util.concurrent.BlockingQueue<E>)
      • java.util.concurrent.TransferQueue<E>
    • java.nio.file.SecureDirectoryStream<T>
    • java.util.Set<E>
      • java.util.NavigableSet<E>
      • java.util.SortedSet<E>
        • java.util.NavigableSet<E>
    • java.util.SortedSet<E>
      • java.util.NavigableSet<E>
    • java.util.concurrent.TransferQueue<E>
  • java.util.Iterator<E>
    • java.util.ListIterator<E>
    • java.util.PrimitiveIterator<T,T_CONS>
      • java.util.PrimitiveIterator.OfDouble
      • java.util.PrimitiveIterator.OfInt
      • java.util.PrimitiveIterator.OfLong
    • java.util.PrimitiveIterator.OfDouble
    • java.util.PrimitiveIterator.OfInt
    • java.util.PrimitiveIterator.OfLong
    • javax.xml.stream.XMLEventReader
  • javax.tools.JavaFileManager.Location
  • javax.swing.JComboBox.KeySelectionManager
  • javax.management.remote.JMXAddressable
  • javax.management.remote.JMXAuthenticator
  • javax.management.remote.JMXConnectorProvider
  • javax.management.remote.JMXConnectorServerMBean
  • javax.management.remote.JMXConnectorServerProvider
  • javax.sql.rowset.Joinable
    • javax.sql.rowset.CachedRowSet (also extends javax.sql.RowSet)
      • javax.sql.rowset.FilteredRowSet
      • javax.sql.rowset.JoinRowSet
      • javax.sql.rowset.WebRowSet
        • javax.sql.rowset.FilteredRowSet
        • javax.sql.rowset.JoinRowSet
    • javax.sql.rowset.FilteredRowSet
    • javax.sql.rowset.JdbcRowSet (also extends javax.sql.RowSet)
    • javax.sql.rowset.JoinRowSet
    • javax.sql.rowset.WebRowSet
      • javax.sql.rowset.FilteredRowSet
      • javax.sql.rowset.JoinRowSet
  • java.awt.KeyEventDispatcher
  • java.awt.KeyEventPostProcessor
  • javax.net.ssl.KeyManager
    • javax.net.ssl.X509KeyManager
  • javax.swing.text.Keymap
  • javax.xml.crypto.KeySelectorResult
  • java.security.spec.KeySpec
  • java.security.KeyStore.Entry
  • java.security.KeyStore.Entry.Attribute
  • java.security.KeyStore.LoadStoreParameter
  • java.security.KeyStore.ProtectionParameter
  • java.awt.LayoutManager
    • java.awt.LayoutManager2
  • org.xml.sax.ext.LexicalHandler
    • javax.xml.transform.sax.TransformerHandler (also extends org.xml.sax.ContentHandler, org.xml.sax.DTDHandler)
  • org.omg.PortableServer.LIFESPAN_POLICY_ID
  • javax.swing.ListCellRenderer<E>
  • javax.swing.ListModel<E>
    • javax.swing.ComboBoxModel<E>
      • javax.swing.MutableComboBoxModel<E>
    • javax.swing.MutableComboBoxModel<E>
  • javax.swing.ListSelectionModel
  • java.rmi.server.LoaderHandler
  • javax.xml.stream.Location
  • org.omg.PortableInterceptor.LOCATION_FORWARD
  • org.xml.sax.Locator
    • org.xml.sax.ext.Locator2
  • java.util.concurrent.locks.Lock
  • java.util.logging.LoggingMXBean
  • javax.xml.ws.LogicalMessage
  • javax.security.auth.spi.LoginModule
  • java.util.function.LongBinaryOperator
  • java.util.function.LongConsumer
    • java.util.stream.LongStream.Builder
  • java.util.function.LongFunction<R>
  • java.util.function.LongPredicate
  • java.util.function.LongSupplier
  • java.util.function.LongToDoubleFunction
  • java.util.function.LongToIntFunction
  • java.util.function.LongUnaryOperator
  • org.w3c.dom.ls.LSInput
  • org.w3c.dom.ls.LSOutput
  • org.w3c.dom.ls.LSParser
  • org.w3c.dom.ls.LSParserFilter
  • org.w3c.dom.ls.LSResourceResolver
  • org.w3c.dom.ls.LSSerializer
  • javax.net.ssl.ManagerFactoryParameters
  • java.util.Map<K,V>
    • javax.script.Bindings
    • java.util.concurrent.ConcurrentMap<K,V>
      • java.util.concurrent.ConcurrentNavigableMap<K,V> (also extends java.util.NavigableMap<K,V>)
    • java.util.concurrent.ConcurrentNavigableMap<K,V> (also extends java.util.concurrent.ConcurrentMap<K,V>, java.util.NavigableMap<K,V>)
    • javax.xml.ws.handler.LogicalMessageContext
    • javax.xml.ws.handler.MessageContext
      • javax.xml.ws.handler.LogicalMessageContext
      • javax.xml.ws.handler.soap.SOAPMessageContext
    • java.util.NavigableMap<K,V>
      • java.util.concurrent.ConcurrentNavigableMap<K,V> (also extends java.util.concurrent.ConcurrentMap<K,V>)
    • javax.xml.ws.handler.soap.SOAPMessageContext
    • java.util.SortedMap<K,V>
      • java.util.concurrent.ConcurrentNavigableMap<K,V> (also extends java.util.concurrent.ConcurrentMap<K,V>, java.util.NavigableMap<K,V>)
      • java.util.NavigableMap<K,V>
        • java.util.concurrent.ConcurrentNavigableMap<K,V> (also extends java.util.concurrent.ConcurrentMap<K,V>)
  • java.util.Map.Entry<K,V>
  • javax.xml.bind.Marshaller
  • java.util.regex.MatchResult
  • javax.management.MBeanRegistration
  • javax.management.MBeanServerConnection
    • javax.management.MBeanServer
      • javax.management.remote.MBeanServerForwarder
    • javax.management.remote.MBeanServerForwarder
  • javax.management.MBeanServerDelegateMBean
  • java.lang.reflect.Member
  • java.awt.MenuContainer
  • javax.swing.MenuElement
  • javax.annotation.processing.Messager
  • java.lang.invoke.MethodHandleInfo
  • javax.sound.midi.MidiChannel
  • javax.management.loading.MLetMBean
  • javax.management.modelmbean.ModelMBeanInfo
  • javax.management.monitor.MonitorMBean
    • javax.management.monitor.CounterMonitorMBean
    • javax.management.monitor.GaugeMonitorMBean
    • javax.management.monitor.StringMonitorMBean
  • javax.print.MultiDoc
  • java.awt.font.MultipleMaster
  • javax.xml.soap.Name
  • org.w3c.dom.NamedNodeMap
  • org.w3c.dom.NameList
  • javax.naming.NameParser
  • javax.xml.namespace.NamespaceContext
  • org.omg.CosNaming.NamingContextOperations
    • org.omg.CosNaming.NamingContext (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.CosNaming.NamingContextExt (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContextExtOperations)
    • org.omg.CosNaming.NamingContextExt (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContext, org.omg.CosNaming.NamingContextExtOperations)
    • org.omg.CosNaming.NamingContextExtOperations
      • org.omg.CosNaming.NamingContextExt (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContext)
  • org.w3c.dom.Node
    • org.w3c.dom.Attr
    • org.w3c.dom.CDATASection
    • org.w3c.dom.CharacterData
      • org.w3c.dom.CDATASection
      • org.w3c.dom.Comment
      • org.w3c.dom.Text
        • org.w3c.dom.CDATASection
        • javax.xml.soap.Text (also extends javax.xml.soap.Node)
      • javax.xml.soap.Text (also extends javax.xml.soap.Node, org.w3c.dom.Text)
    • org.w3c.dom.Comment
    • javax.xml.soap.Detail
    • javax.xml.soap.DetailEntry
    • org.w3c.dom.Document
    • org.w3c.dom.DocumentFragment
    • org.w3c.dom.DocumentType
    • org.w3c.dom.Element
      • javax.xml.soap.Detail
      • javax.xml.soap.DetailEntry
      • javax.xml.soap.SOAPBody
      • javax.xml.soap.SOAPBodyElement
        • javax.xml.soap.SOAPFault
      • javax.xml.soap.SOAPElement (also extends javax.xml.soap.Node)
        • javax.xml.soap.Detail
        • javax.xml.soap.DetailEntry
        • javax.xml.soap.SOAPBody
        • javax.xml.soap.SOAPBodyElement
          • javax.xml.soap.SOAPFault
        • javax.xml.soap.SOAPEnvelope
        • javax.xml.soap.SOAPFault
        • javax.xml.soap.SOAPFaultElement
          • javax.xml.soap.Detail
        • javax.xml.soap.SOAPHeader
        • javax.xml.soap.SOAPHeaderElement
      • javax.xml.soap.SOAPEnvelope
      • javax.xml.soap.SOAPFault
      • javax.xml.soap.SOAPFaultElement
        • javax.xml.soap.Detail
      • javax.xml.soap.SOAPHeader
      • javax.xml.soap.SOAPHeaderElement
    • org.w3c.dom.Entity
    • org.w3c.dom.EntityReference
    • javax.xml.soap.Node
      • javax.xml.soap.Detail
      • javax.xml.soap.DetailEntry
      • javax.xml.soap.SOAPBody
      • javax.xml.soap.SOAPBodyElement
        • javax.xml.soap.SOAPFault
      • javax.xml.soap.SOAPElement (also extends org.w3c.dom.Element)
        • javax.xml.soap.Detail
        • javax.xml.soap.DetailEntry
        • javax.xml.soap.SOAPBody
        • javax.xml.soap.SOAPBodyElement
          • javax.xml.soap.SOAPFault
        • javax.xml.soap.SOAPEnvelope
        • javax.xml.soap.SOAPFault
        • javax.xml.soap.SOAPFaultElement
          • javax.xml.soap.Detail
        • javax.xml.soap.SOAPHeader
        • javax.xml.soap.SOAPHeaderElement
      • javax.xml.soap.SOAPEnvelope
      • javax.xml.soap.SOAPFault
      • javax.xml.soap.SOAPFaultElement
        • javax.xml.soap.Detail
      • javax.xml.soap.SOAPHeader
      • javax.xml.soap.SOAPHeaderElement
      • javax.xml.soap.Text (also extends org.w3c.dom.Text)
    • org.w3c.dom.Notation
    • org.w3c.dom.ProcessingInstruction
    • javax.xml.soap.SOAPBody
    • javax.xml.soap.SOAPBodyElement
      • javax.xml.soap.SOAPFault
    • javax.xml.soap.SOAPElement (also extends org.w3c.dom.Element, javax.xml.soap.Node)
      • javax.xml.soap.Detail
      • javax.xml.soap.DetailEntry
      • javax.xml.soap.SOAPBody
      • javax.xml.soap.SOAPBodyElement
        • javax.xml.soap.SOAPFault
      • javax.xml.soap.SOAPEnvelope
      • javax.xml.soap.SOAPFault
      • javax.xml.soap.SOAPFaultElement
        • javax.xml.soap.Detail
      • javax.xml.soap.SOAPHeader
      • javax.xml.soap.SOAPHeaderElement
    • javax.xml.soap.SOAPEnvelope
    • javax.xml.soap.SOAPFault
    • javax.xml.soap.SOAPFaultElement
      • javax.xml.soap.Detail
    • javax.xml.soap.SOAPHeader
    • javax.xml.soap.SOAPHeaderElement
    • org.w3c.dom.Text
      • org.w3c.dom.CDATASection
      • javax.xml.soap.Text (also extends javax.xml.soap.Node)
    • javax.xml.soap.Text (also extends javax.xml.soap.Node, org.w3c.dom.Text)
  • org.w3c.dom.traversal.NodeFilter
    • org.w3c.dom.ls.LSSerializerFilter
  • org.w3c.dom.NodeList
  • org.omg.PortableInterceptor.NON_EXISTENT
  • javax.management.NotificationBroadcaster
    • javax.management.modelmbean.ModelMBean (also extends javax.management.DynamicMBean, javax.management.modelmbean.ModelMBeanNotificationBroadcaster, javax.management.PersistentMBean)
    • javax.management.modelmbean.ModelMBeanNotificationBroadcaster
      • javax.management.modelmbean.ModelMBean (also extends javax.management.DynamicMBean, javax.management.PersistentMBean)
    • javax.management.NotificationEmitter
  • java.util.function.ObjDoubleConsumer<T>
  • org.omg.CORBA.Object
    • org.omg.PortableServer.AdapterActivator (also extends org.omg.PortableServer.AdapterActivatorOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CosNaming.BindingIterator (also extends org.omg.CosNaming.BindingIteratorOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableInterceptor.ClientRequestInfo (also extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfo)
    • org.omg.PortableInterceptor.ClientRequestInterceptor (also extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor)
    • org.omg.IOP.Codec (also extends org.omg.IOP.CodecOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.CodecFactory (also extends org.omg.IOP.CodecFactoryOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.Current (also extends org.omg.CORBA.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableServer.Current (also extends org.omg.PortableServer.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.Current (also extends org.omg.PortableInterceptor.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.Current (also extends org.omg.CORBA.Current, org.omg.PortableServer.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableInterceptor.Current (also extends org.omg.CORBA.Current, org.omg.PortableInterceptor.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DomainManager (also extends org.omg.CORBA.DomainManagerOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DynAny
      • org.omg.CORBA.DynArray (also extends org.omg.CORBA.Object)
      • org.omg.CORBA.DynEnum (also extends org.omg.CORBA.Object)
      • org.omg.CORBA.DynFixed (also extends org.omg.CORBA.Object)
      • org.omg.CORBA.DynSequence (also extends org.omg.CORBA.Object)
      • org.omg.CORBA.DynStruct (also extends org.omg.CORBA.Object)
      • org.omg.CORBA.DynUnion (also extends org.omg.CORBA.Object)
      • org.omg.CORBA.DynValue (also extends org.omg.CORBA.Object)
    • org.omg.DynamicAny.DynAny (also extends org.omg.DynamicAny.DynAnyOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynArray (also extends org.omg.DynamicAny.DynArrayOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynEnum (also extends org.omg.DynamicAny.DynEnumOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynFixed (also extends org.omg.DynamicAny.DynFixedOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynSequence (also extends org.omg.DynamicAny.DynSequenceOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynStruct (also extends org.omg.DynamicAny.DynStructOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynUnion (also extends org.omg.DynamicAny.DynUnionOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueCommon, org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueCommon (also extends org.omg.DynamicAny.DynValueCommonOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynAnyFactory (also extends org.omg.DynamicAny.DynAnyFactoryOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DynArray (also extends org.omg.CORBA.DynAny)
    • org.omg.DynamicAny.DynArray (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynArrayOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DynEnum (also extends org.omg.CORBA.DynAny)
    • org.omg.DynamicAny.DynEnum (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynEnumOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DynFixed (also extends org.omg.CORBA.DynAny)
    • org.omg.DynamicAny.DynFixed (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynFixedOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DynSequence (also extends org.omg.CORBA.DynAny)
    • org.omg.DynamicAny.DynSequence (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynSequenceOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DynStruct (also extends org.omg.CORBA.DynAny)
    • org.omg.DynamicAny.DynStruct (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynStructOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DynUnion (also extends org.omg.CORBA.DynAny)
    • org.omg.DynamicAny.DynUnion (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynUnionOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DynValue (also extends org.omg.CORBA.DynAny)
    • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueCommon, org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynValueCommon (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynValueCommonOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.IdAssignmentPolicy (also extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.CORBA.IDLType (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IDLTypeOperations, org.omg.CORBA.IRObject)
    • org.omg.PortableServer.IdUniquenessPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.IdUniquenessPolicyOperations, org.omg.CORBA.Policy)
    • org.omg.PortableServer.ImplicitActivationPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ImplicitActivationPolicyOperations, org.omg.CORBA.Policy)
    • org.omg.PortableInterceptor.Interceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.InterceptorOperations)
      • org.omg.PortableInterceptor.ClientRequestInterceptor (also extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.IORInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptorOperations)
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.ServerRequestInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
    • org.omg.PortableInterceptor.IORInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInfoOperations)
    • org.omg.PortableInterceptor.IORInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor, org.omg.PortableInterceptor.IORInterceptorOperations)
      • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
    • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
    • org.omg.CORBA.IRObject (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IRObjectOperations)
      • org.omg.CORBA.IDLType (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IDLTypeOperations)
    • org.omg.PortableServer.LifespanPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.LifespanPolicyOperations, org.omg.CORBA.Policy)
    • org.omg.CosNaming.NamingContext (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContextOperations)
      • org.omg.CosNaming.NamingContextExt (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContextExtOperations)
    • org.omg.CosNaming.NamingContextExt (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContext, org.omg.CosNaming.NamingContextExtOperations)
    • org.omg.PortableInterceptor.ORBInitializer (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ORBInitializerOperations)
    • org.omg.PortableInterceptor.ORBInitInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ORBInitInfoOperations)
    • org.omg.PortableServer.POA (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.POAOperations)
    • org.omg.PortableServer.POAManager (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.POAManagerOperations)
    • org.omg.CORBA.Policy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.PolicyOperations)
      • org.omg.PortableServer.IdAssignmentPolicy (also extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableServer.IdUniquenessPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.IdUniquenessPolicyOperations)
      • org.omg.PortableServer.ImplicitActivationPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ImplicitActivationPolicyOperations)
      • org.omg.PortableServer.LifespanPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.LifespanPolicyOperations)
      • org.omg.PortableServer.RequestProcessingPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.RequestProcessingPolicyOperations)
      • org.omg.PortableServer.ServantRetentionPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantRetentionPolicyOperations)
      • org.omg.PortableServer.ThreadPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ThreadPolicyOperations)
    • org.omg.PortableInterceptor.PolicyFactory (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.PolicyFactoryOperations)
    • org.omg.PortableInterceptor.RequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfoOperations)
      • org.omg.PortableInterceptor.ClientRequestInfo (also extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.ServerRequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInfoOperations)
    • org.omg.PortableServer.RequestProcessingPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy, org.omg.PortableServer.RequestProcessingPolicyOperations)
    • org.omg.SendingContext.RunTime (also extends org.omg.CORBA.portable.IDLEntity, org.omg.SendingContext.RunTimeOperations)
    • org.omg.PortableServer.ServantActivator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantActivatorOperations, org.omg.PortableServer.ServantManager)
    • org.omg.PortableServer.ServantLocator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantLocatorOperations, org.omg.PortableServer.ServantManager)
    • org.omg.PortableServer.ServantManager (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantManagerOperations)
      • org.omg.PortableServer.ServantActivator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantActivatorOperations)
      • org.omg.PortableServer.ServantLocator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantLocatorOperations)
    • org.omg.PortableServer.ServantRetentionPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy, org.omg.PortableServer.ServantRetentionPolicyOperations)
    • org.omg.PortableInterceptor.ServerRequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfo, org.omg.PortableInterceptor.ServerRequestInfoOperations)
    • org.omg.PortableInterceptor.ServerRequestInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
    • org.omg.PortableServer.ThreadPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy, org.omg.PortableServer.ThreadPolicyOperations)
  • javax.naming.spi.ObjectFactory
    • javax.naming.spi.DirObjectFactory
  • javax.naming.spi.ObjectFactoryBuilder
  • java.io.ObjectInputValidation
  • java.io.ObjectStreamConstants
  • java.util.function.ObjIntConsumer<T>
  • java.util.function.ObjLongConsumer<T>
  • java.util.Observer
  • org.omg.CORBA.OMGVMCID
  • javax.management.openmbean.OpenMBeanConstructorInfo
  • javax.management.openmbean.OpenMBeanInfo
  • javax.management.openmbean.OpenMBeanOperationInfo
  • javax.management.openmbean.OpenMBeanParameterInfo
    • javax.management.openmbean.OpenMBeanAttributeInfo
  • java.nio.file.OpenOption
  • java.awt.font.OpenType
  • javax.tools.OptionChecker
    • javax.tools.DocumentationTool (also extends javax.tools.Tool)
    • javax.tools.JavaCompiler (also extends javax.tools.Tool)
    • javax.tools.JavaFileManager (also extends java.io.Closeable, java.io.Flushable)
      • javax.tools.StandardJavaFileManager
    • javax.tools.StandardJavaFileManager
  • org.omg.PortableInterceptor.ORBInitializerOperations
    • org.omg.PortableInterceptor.ORBInitializer (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.PortableInterceptor.ORBInitInfoOperations
    • org.omg.PortableInterceptor.ORBInitInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • java.security.acl.Owner
    • java.security.acl.Acl
  • java.util.jar.Pack200.Packer
  • java.util.jar.Pack200.Unpacker
  • java.awt.print.Pageable
  • java.awt.PaintContext
  • javax.swing.Painter<T>
  • org.xml.sax.Parser
  • java.awt.geom.PathIterator
  • java.nio.file.PathMatcher
  • java.security.acl.Permission
  • javax.management.PersistentMBean
    • javax.management.modelmbean.ModelMBean (also extends javax.management.DynamicMBean, javax.management.modelmbean.ModelMBeanNotificationBroadcaster)
  • java.lang.management.PlatformManagedObject
    • java.lang.management.BufferPoolMXBean
    • java.lang.management.ClassLoadingMXBean
    • java.lang.management.CompilationMXBean
    • java.lang.management.GarbageCollectorMXBean
    • java.lang.management.MemoryManagerMXBean
      • java.lang.management.GarbageCollectorMXBean
    • java.lang.management.MemoryMXBean
    • java.lang.management.MemoryPoolMXBean
    • java.lang.management.OperatingSystemMXBean
    • java.lang.management.PlatformLoggingMXBean
    • java.lang.management.RuntimeMXBean
    • java.lang.management.ThreadMXBean
  • org.omg.PortableServer.POAManagerOperations
    • org.omg.PortableServer.POAManager (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.PortableServer.POAOperations
    • org.omg.PortableServer.POA (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • java.security.Policy.Parameters
  • org.omg.PortableInterceptor.PolicyFactoryOperations
    • org.omg.PortableInterceptor.PolicyFactory (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • java.security.cert.PolicyNode
  • org.omg.CORBA.PolicyOperations
    • org.omg.PortableServer.IdAssignmentPolicy (also extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.PortableServer.IdAssignmentPolicyOperations
      • org.omg.PortableServer.IdAssignmentPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.PortableServer.IdUniquenessPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.IdUniquenessPolicyOperations, org.omg.CORBA.Policy)
    • org.omg.PortableServer.IdUniquenessPolicyOperations
      • org.omg.PortableServer.IdUniquenessPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.PortableServer.ImplicitActivationPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ImplicitActivationPolicyOperations, org.omg.CORBA.Policy)
    • org.omg.PortableServer.ImplicitActivationPolicyOperations
      • org.omg.PortableServer.ImplicitActivationPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.PortableServer.LifespanPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.LifespanPolicyOperations, org.omg.CORBA.Policy)
    • org.omg.PortableServer.LifespanPolicyOperations
      • org.omg.PortableServer.LifespanPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.CORBA.Policy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableServer.IdAssignmentPolicy (also extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableServer.IdUniquenessPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.IdUniquenessPolicyOperations)
      • org.omg.PortableServer.ImplicitActivationPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ImplicitActivationPolicyOperations)
      • org.omg.PortableServer.LifespanPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.LifespanPolicyOperations)
      • org.omg.PortableServer.RequestProcessingPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.RequestProcessingPolicyOperations)
      • org.omg.PortableServer.ServantRetentionPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantRetentionPolicyOperations)
      • org.omg.PortableServer.ThreadPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ThreadPolicyOperations)
    • org.omg.PortableServer.RequestProcessingPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy, org.omg.PortableServer.RequestProcessingPolicyOperations)
    • org.omg.PortableServer.RequestProcessingPolicyOperations
      • org.omg.PortableServer.RequestProcessingPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.PortableServer.ServantRetentionPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy, org.omg.PortableServer.ServantRetentionPolicyOperations)
    • org.omg.PortableServer.ServantRetentionPolicyOperations
      • org.omg.PortableServer.ServantRetentionPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.PortableServer.ThreadPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy, org.omg.PortableServer.ThreadPolicyOperations)
    • org.omg.PortableServer.ThreadPolicyOperations
      • org.omg.PortableServer.ThreadPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
  • javax.sql.PooledConnection
    • javax.sql.XAConnection
  • javax.rmi.CORBA.PortableRemoteObjectDelegate
  • javax.xml.ws.handler.PortInfo
  • javax.swing.text.Position
  • java.util.function.Predicate<T>
  • javax.sql.rowset.Predicate
  • java.util.prefs.PreferencesFactory
  • java.security.Principal
    • java.security.acl.Group
    • java.nio.file.attribute.GroupPrincipal
    • java.nio.file.attribute.UserPrincipal
      • java.nio.file.attribute.GroupPrincipal
  • java.awt.print.Printable
  • java.awt.print.PrinterGraphics
  • java.awt.PrintGraphics
  • javax.print.event.PrintJobAttributeListener
  • javax.print.event.PrintJobListener
  • javax.print.PrintService
    • javax.print.MultiDocPrintService
  • javax.print.event.PrintServiceAttributeListener
  • org.omg.CORBA.PRIVATE_MEMBER
  • javax.management.loading.PrivateClassLoader
  • java.security.PrivilegedAction<T>
  • java.security.PrivilegedExceptionAction<T>
  • javax.annotation.processing.ProcessingEnvironment
  • javax.annotation.processing.Processor
  • java.beans.PropertyEditor
  • java.net.ProtocolFamily
  • javax.xml.ws.Provider<T>
  • org.omg.CORBA.PUBLIC_MEMBER
  • java.util.RandomAccess
  • java.awt.image.RasterOp
  • java.lang.Readable
  • java.util.concurrent.locks.ReadWriteLock
  • java.sql.Ref
  • javax.naming.Referenceable
  • javax.security.auth.Refreshable
  • javax.imageio.spi.RegisterableService
  • java.rmi.registry.RegistryHandler
  • java.util.concurrent.RejectedExecutionHandler
  • javax.management.relation.Relation
    • javax.management.relation.RelationSupportMBean
  • javax.management.relation.RelationServiceMBean
  • java.rmi.Remote
    • java.rmi.activation.ActivationInstantiator
    • java.rmi.activation.ActivationMonitor
    • java.rmi.activation.ActivationSystem
    • java.rmi.activation.Activator
    • java.rmi.dgc.DGC
    • java.rmi.registry.Registry
    • javax.management.remote.rmi.RMIConnection (also extends java.io.Closeable)
    • javax.management.remote.rmi.RMIServer
  • java.rmi.server.RemoteCall
  • java.awt.image.renderable.RenderableImage
  • java.awt.image.RenderedImage
    • java.awt.image.WritableRenderedImage
  • java.awt.image.renderable.RenderedImageFactory
    • java.awt.image.renderable.ContextualRenderedImageFactory
  • javax.swing.Renderer
  • org.omg.PortableServer.REQUEST_PROCESSING_POLICY_ID
  • org.omg.PortableInterceptor.RequestInfoOperations
    • org.omg.PortableInterceptor.ClientRequestInfo (also extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfo)
    • org.omg.PortableInterceptor.ClientRequestInfoOperations
      • org.omg.PortableInterceptor.ClientRequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfo)
    • org.omg.PortableInterceptor.RequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableInterceptor.ClientRequestInfo (also extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.ServerRequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInfoOperations)
    • org.omg.PortableInterceptor.ServerRequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfo, org.omg.PortableInterceptor.ServerRequestInfoOperations)
    • org.omg.PortableInterceptor.ServerRequestInfoOperations
      • org.omg.PortableInterceptor.ServerRequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfo)
  • javax.naming.spi.Resolver
  • java.util.spi.ResourceBundleControlProvider
  • org.omg.CORBA.portable.ResponseHandler
  • javax.xml.transform.Result
  • java.rmi.server.RMIClientSocketFactory
  • org.omg.IOP.RMICustomMaxStreamFormat
  • java.rmi.server.RMIFailureHandler
  • java.rmi.server.RMIServerSocketFactory
  • javax.swing.RootPaneContainer
  • javax.annotation.processing.RoundEnvironment
  • java.sql.RowId
  • javax.swing.tree.RowMapper
  • javax.sql.rowset.RowSetFactory
  • javax.sql.RowSetInternal
  • javax.sql.RowSetReader
    • javax.sql.rowset.spi.XmlReader
  • javax.sql.RowSetWriter
    • javax.sql.rowset.spi.TransactionalWriter
    • javax.sql.rowset.spi.XmlWriter
  • java.security.interfaces.RSAKey
    • java.security.interfaces.RSAMultiPrimePrivateCrtKey
    • java.security.interfaces.RSAPrivateCrtKey
    • java.security.interfaces.RSAPrivateKey (also extends java.security.PrivateKey)
      • java.security.interfaces.RSAMultiPrimePrivateCrtKey
      • java.security.interfaces.RSAPrivateCrtKey
    • java.security.interfaces.RSAPublicKey (also extends java.security.PublicKey)
  • java.lang.Runnable
    • java.util.concurrent.RunnableFuture<V> (also extends java.util.concurrent.Future<V>)
      • java.util.concurrent.RunnableScheduledFuture<V> (also extends java.util.concurrent.ScheduledFuture<V>)
    • java.util.concurrent.RunnableScheduledFuture<V> (also extends java.util.concurrent.RunnableFuture<V>, java.util.concurrent.ScheduledFuture<V>)
  • org.omg.SendingContext.RunTimeOperations
    • org.omg.SendingContext.RunTime (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • javax.security.sasl.SaslClient
  • javax.security.sasl.SaslClientFactory
  • javax.security.sasl.SaslServer
  • javax.security.sasl.SaslServerFactory
  • java.sql.Savepoint
  • javax.script.ScriptContext
  • javax.script.ScriptEngine
  • javax.script.ScriptEngineFactory
  • javax.swing.Scrollable
  • javax.swing.ScrollPaneConstants
  • java.awt.SecondaryLoop
  • java.io.Serializable
    • org.omg.PortableServer.AdapterActivator (also extends org.omg.PortableServer.AdapterActivatorOperations, org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
    • javax.naming.directory.Attribute (also extends java.lang.Cloneable)
    • javax.print.attribute.Attribute
      • javax.print.attribute.DocAttribute
      • javax.print.attribute.PrintJobAttribute
      • javax.print.attribute.PrintRequestAttribute
      • javax.print.attribute.PrintServiceAttribute
      • javax.print.attribute.SupportedValuesAttribute
    • javax.naming.directory.Attributes (also extends java.lang.Cloneable)
    • org.omg.CosNaming.BindingIterator (also extends org.omg.CosNaming.BindingIteratorOperations, org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
    • java.security.cert.CertPathValidatorException.Reason
    • org.omg.PortableInterceptor.ClientRequestInfo (also extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfo)
    • org.omg.PortableInterceptor.ClientRequestInterceptor (also extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor)
    • org.omg.IOP.Codec (also extends org.omg.IOP.CodecOperations, org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
    • org.omg.IOP.CodecFactory (also extends org.omg.IOP.CodecFactoryOperations, org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
    • javax.naming.ldap.Control
    • org.omg.CORBA.Current (also extends org.omg.CORBA.CurrentOperations, org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableServer.Current (also extends org.omg.PortableServer.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.Current (also extends org.omg.PortableInterceptor.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.Current (also extends org.omg.CORBA.Current, org.omg.PortableServer.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableInterceptor.Current (also extends org.omg.CORBA.Current, org.omg.PortableInterceptor.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.portable.CustomValue (also extends org.omg.CORBA.CustomMarshal, org.omg.CORBA.portable.ValueBase)
    • org.omg.CORBA.DataInputStream
    • org.omg.CORBA.DataOutputStream
    • javax.management.Descriptor (also extends java.lang.Cloneable)
    • javax.crypto.interfaces.DHPrivateKey (also extends javax.crypto.interfaces.DHKey, java.security.PrivateKey)
    • javax.crypto.interfaces.DHPublicKey (also extends javax.crypto.interfaces.DHKey, java.security.PublicKey)
    • javax.print.attribute.DocAttribute
    • org.omg.CORBA.DomainManager (also extends org.omg.CORBA.DomainManagerOperations, org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
    • java.security.interfaces.DSAPrivateKey (also extends java.security.interfaces.DSAKey, java.security.PrivateKey)
    • java.security.interfaces.DSAPublicKey (also extends java.security.interfaces.DSAKey, java.security.PublicKey)
    • org.omg.DynamicAny.DynAny (also extends org.omg.DynamicAny.DynAnyOperations, org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.DynamicAny.DynArray (also extends org.omg.DynamicAny.DynArrayOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynEnum (also extends org.omg.DynamicAny.DynEnumOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynFixed (also extends org.omg.DynamicAny.DynFixedOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynSequence (also extends org.omg.DynamicAny.DynSequenceOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynStruct (also extends org.omg.DynamicAny.DynStructOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynUnion (also extends org.omg.DynamicAny.DynUnionOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueCommon, org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueCommon (also extends org.omg.DynamicAny.DynValueCommonOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynAnyFactory (also extends org.omg.DynamicAny.DynAnyFactoryOperations, org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
    • org.omg.DynamicAny.DynArray (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynArrayOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynEnum (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynEnumOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynFixed (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynFixedOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynSequence (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynSequenceOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynStruct (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynStructOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynUnion (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynUnionOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueCommon, org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynValueCommon (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynValueCommonOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
    • java.security.interfaces.ECPrivateKey (also extends java.security.interfaces.ECKey, java.security.PrivateKey)
    • java.security.interfaces.ECPublicKey (also extends java.security.interfaces.ECKey, java.security.PublicKey)
    • javax.naming.ldap.ExtendedRequest
    • javax.naming.ldap.ExtendedResponse
      • javax.naming.ldap.UnsolicitedNotification (also extends javax.naming.ldap.HasControls)
    • java.io.Externalizable
      • java.rmi.server.RemoteRef
        • java.rmi.server.ServerRef
      • java.rmi.server.ServerRef
    • org.omg.PortableServer.IdAssignmentPolicy (also extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.CORBA.portable.IDLEntity
      • org.omg.PortableServer.AdapterActivator (also extends org.omg.PortableServer.AdapterActivatorOperations, org.omg.CORBA.Object)
      • org.omg.CosNaming.BindingIterator (also extends org.omg.CosNaming.BindingIteratorOperations, org.omg.CORBA.Object)
      • org.omg.PortableInterceptor.ClientRequestInfo (also extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.PortableInterceptor.RequestInfo)
      • org.omg.PortableInterceptor.ClientRequestInterceptor (also extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.PortableInterceptor.Interceptor)
      • org.omg.IOP.Codec (also extends org.omg.IOP.CodecOperations, org.omg.CORBA.Object)
      • org.omg.IOP.CodecFactory (also extends org.omg.IOP.CodecFactoryOperations, org.omg.CORBA.Object)
      • org.omg.CORBA.Current (also extends org.omg.CORBA.CurrentOperations, org.omg.CORBA.Object)
        • org.omg.PortableServer.Current (also extends org.omg.PortableServer.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.PortableInterceptor.Current (also extends org.omg.PortableInterceptor.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableServer.Current (also extends org.omg.CORBA.Current, org.omg.PortableServer.CurrentOperations)
      • org.omg.PortableInterceptor.Current (also extends org.omg.CORBA.Current, org.omg.PortableInterceptor.CurrentOperations)
      • org.omg.CORBA.portable.CustomValue (also extends org.omg.CORBA.CustomMarshal, org.omg.CORBA.portable.ValueBase)
      • org.omg.CORBA.DataInputStream
      • org.omg.CORBA.DataOutputStream
      • org.omg.CORBA.DomainManager (also extends org.omg.CORBA.DomainManagerOperations, org.omg.CORBA.Object)
      • org.omg.DynamicAny.DynAny (also extends org.omg.DynamicAny.DynAnyOperations, org.omg.CORBA.Object)
        • org.omg.DynamicAny.DynArray (also extends org.omg.DynamicAny.DynArrayOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynEnum (also extends org.omg.DynamicAny.DynEnumOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynFixed (also extends org.omg.DynamicAny.DynFixedOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynSequence (also extends org.omg.DynamicAny.DynSequenceOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynStruct (also extends org.omg.DynamicAny.DynStructOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynUnion (also extends org.omg.DynamicAny.DynUnionOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueCommon, org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueCommon (also extends org.omg.DynamicAny.DynValueCommonOperations, org.omg.CORBA.portable.IDLEntity)
          • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
          • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynAnyFactory (also extends org.omg.DynamicAny.DynAnyFactoryOperations, org.omg.CORBA.Object)
      • org.omg.DynamicAny.DynArray (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynArrayOperations)
      • org.omg.DynamicAny.DynEnum (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynEnumOperations)
      • org.omg.DynamicAny.DynFixed (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynFixedOperations)
      • org.omg.DynamicAny.DynSequence (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynSequenceOperations)
      • org.omg.DynamicAny.DynStruct (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynStructOperations)
      • org.omg.DynamicAny.DynUnion (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynUnionOperations)
      • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueCommon, org.omg.DynamicAny.DynValueOperations)
      • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.DynamicAny.DynValueCommon)
      • org.omg.DynamicAny.DynValueCommon (also extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynValueCommonOperations)
        • org.omg.DynamicAny.DynValue (also extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueBox (also extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableServer.IdAssignmentPolicy (also extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.Policy)
      • org.omg.CORBA.IDLType (also extends org.omg.CORBA.IDLTypeOperations, org.omg.CORBA.IRObject)
      • org.omg.PortableServer.IdUniquenessPolicy (also extends org.omg.PortableServer.IdUniquenessPolicyOperations, org.omg.CORBA.Policy)
      • org.omg.PortableServer.ImplicitActivationPolicy (also extends org.omg.PortableServer.ImplicitActivationPolicyOperations, org.omg.CORBA.Policy)
      • org.omg.PortableInterceptor.Interceptor (also extends org.omg.PortableInterceptor.InterceptorOperations, org.omg.CORBA.Object)
        • org.omg.PortableInterceptor.ClientRequestInterceptor (also extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.PortableInterceptor.IORInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptorOperations)
          • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
        • org.omg.PortableInterceptor.ServerRequestInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
      • org.omg.PortableInterceptor.IORInfo (also extends org.omg.PortableInterceptor.IORInfoOperations, org.omg.CORBA.Object)
      • org.omg.PortableInterceptor.IORInterceptor (also extends org.omg.PortableInterceptor.Interceptor, org.omg.PortableInterceptor.IORInterceptorOperations)
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.PortableInterceptor.IORInterceptor, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.CORBA.IRObject (also extends org.omg.CORBA.IRObjectOperations, org.omg.CORBA.Object)
        • org.omg.CORBA.IDLType (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IDLTypeOperations)
      • org.omg.PortableServer.LifespanPolicy (also extends org.omg.PortableServer.LifespanPolicyOperations, org.omg.CORBA.Policy)
      • org.omg.CosNaming.NamingContext (also extends org.omg.CosNaming.NamingContextOperations, org.omg.CORBA.Object)
        • org.omg.CosNaming.NamingContextExt (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContextExtOperations)
      • org.omg.CosNaming.NamingContextExt (also extends org.omg.CosNaming.NamingContext, org.omg.CosNaming.NamingContextExtOperations)
      • org.omg.PortableInterceptor.ObjectReferenceFactory
        • org.omg.PortableInterceptor.ObjectReferenceTemplate
      • org.omg.PortableInterceptor.ObjectReferenceTemplate
      • org.omg.PortableInterceptor.ORBInitializer (also extends org.omg.CORBA.Object, org.omg.PortableInterceptor.ORBInitializerOperations)
      • org.omg.PortableInterceptor.ORBInitInfo (also extends org.omg.CORBA.Object, org.omg.PortableInterceptor.ORBInitInfoOperations)
      • org.omg.PortableServer.POA (also extends org.omg.CORBA.Object, org.omg.PortableServer.POAOperations)
      • org.omg.PortableServer.POAManager (also extends org.omg.CORBA.Object, org.omg.PortableServer.POAManagerOperations)
      • org.omg.CORBA.Policy (also extends org.omg.CORBA.Object, org.omg.CORBA.PolicyOperations)
        • org.omg.PortableServer.IdAssignmentPolicy (also extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.PortableServer.IdUniquenessPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.IdUniquenessPolicyOperations)
        • org.omg.PortableServer.ImplicitActivationPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ImplicitActivationPolicyOperations)
        • org.omg.PortableServer.LifespanPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.LifespanPolicyOperations)
        • org.omg.PortableServer.RequestProcessingPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.RequestProcessingPolicyOperations)
        • org.omg.PortableServer.ServantRetentionPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantRetentionPolicyOperations)
        • org.omg.PortableServer.ThreadPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ThreadPolicyOperations)
      • org.omg.PortableInterceptor.PolicyFactory (also extends org.omg.CORBA.Object, org.omg.PortableInterceptor.PolicyFactoryOperations)
      • org.omg.PortableInterceptor.RequestInfo (also extends org.omg.CORBA.Object, org.omg.PortableInterceptor.RequestInfoOperations)
        • org.omg.PortableInterceptor.ClientRequestInfo (also extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.PortableInterceptor.ServerRequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInfoOperations)
      • org.omg.PortableServer.RequestProcessingPolicy (also extends org.omg.CORBA.Policy, org.omg.PortableServer.RequestProcessingPolicyOperations)
      • org.omg.SendingContext.RunTime (also extends org.omg.CORBA.Object, org.omg.SendingContext.RunTimeOperations)
      • org.omg.PortableServer.ServantActivator (also extends org.omg.PortableServer.ServantActivatorOperations, org.omg.PortableServer.ServantManager)
      • org.omg.PortableServer.ServantLocator (also extends org.omg.PortableServer.ServantLocatorOperations, org.omg.PortableServer.ServantManager)
      • org.omg.PortableServer.ServantManager (also extends org.omg.CORBA.Object, org.omg.PortableServer.ServantManagerOperations)
        • org.omg.PortableServer.ServantActivator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantActivatorOperations)
        • org.omg.PortableServer.ServantLocator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantLocatorOperations)
      • org.omg.PortableServer.ServantRetentionPolicy (also extends org.omg.CORBA.Policy, org.omg.PortableServer.ServantRetentionPolicyOperations)
      • org.omg.PortableInterceptor.ServerRequestInfo (also extends org.omg.PortableInterceptor.RequestInfo, org.omg.PortableInterceptor.ServerRequestInfoOperations)
      • org.omg.PortableInterceptor.ServerRequestInterceptor (also extends org.omg.PortableInterceptor.Interceptor, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
      • org.omg.CORBA.portable.StreamableValue (also extends org.omg.CORBA.portable.Streamable, org.omg.CORBA.portable.ValueBase)
      • org.omg.PortableServer.ThreadPolicy (also extends org.omg.CORBA.Policy, org.omg.PortableServer.ThreadPolicyOperations)
      • org.omg.CORBA.portable.ValueBase
        • org.omg.CORBA.portable.CustomValue (also extends org.omg.CORBA.CustomMarshal)
        • org.omg.CORBA.DataInputStream
        • org.omg.CORBA.DataOutputStream
        • org.omg.PortableInterceptor.ObjectReferenceFactory
          • org.omg.PortableInterceptor.ObjectReferenceTemplate
        • org.omg.PortableInterceptor.ObjectReferenceTemplate
        • org.omg.CORBA.portable.StreamableValue (also extends org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.IDLType (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IDLTypeOperations, org.omg.CORBA.IRObject)
    • org.omg.PortableServer.IdUniquenessPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.IdUniquenessPolicyOperations, org.omg.CORBA.Policy)
    • org.omg.PortableServer.ImplicitActivationPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ImplicitActivationPolicyOperations, org.omg.CORBA.Policy)
    • org.omg.PortableInterceptor.Interceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.InterceptorOperations, org.omg.CORBA.Object)
      • org.omg.PortableInterceptor.ClientRequestInterceptor (also extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.IORInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptorOperations)
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.ServerRequestInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
    • org.omg.PortableInterceptor.IORInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInfoOperations, org.omg.CORBA.Object)
    • org.omg.PortableInterceptor.IORInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor, org.omg.PortableInterceptor.IORInterceptorOperations)
      • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
    • org.omg.PortableInterceptor.IORInterceptor_3_0 (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
    • org.omg.CORBA.IRObject (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IRObjectOperations, org.omg.CORBA.Object)
      • org.omg.CORBA.IDLType (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IDLTypeOperations)
    • java.security.Key
      • javax.crypto.interfaces.DHPrivateKey (also extends javax.crypto.interfaces.DHKey, java.security.PrivateKey)
      • javax.crypto.interfaces.DHPublicKey (also extends javax.crypto.interfaces.DHKey, java.security.PublicKey)
      • java.security.interfaces.DSAPrivateKey (also extends java.security.interfaces.DSAKey, java.security.PrivateKey)
      • java.security.interfaces.DSAPublicKey (also extends java.security.interfaces.DSAKey, java.security.PublicKey)
      • java.security.interfaces.ECPrivateKey (also extends java.security.interfaces.ECKey, java.security.PrivateKey)
      • java.security.interfaces.ECPublicKey (also extends java.security.interfaces.ECKey, java.security.PublicKey)
      • javax.crypto.interfaces.PBEKey
      • java.security.PrivateKey (also extends javax.security.auth.Destroyable)
        • javax.crypto.interfaces.DHPrivateKey (also extends javax.crypto.interfaces.DHKey)
        • java.security.interfaces.DSAPrivateKey (also extends java.security.interfaces.DSAKey)
        • java.security.interfaces.ECPrivateKey (also extends java.security.interfaces.ECKey)
        • java.security.interfaces.RSAMultiPrimePrivateCrtKey
        • java.security.interfaces.RSAPrivateCrtKey
        • java.security.interfaces.RSAPrivateKey (also extends java.security.interfaces.RSAKey)
          • java.security.interfaces.RSAMultiPrimePrivateCrtKey
          • java.security.interfaces.RSAPrivateCrtKey
      • java.security.PublicKey
        • javax.crypto.interfaces.DHPublicKey (also extends javax.crypto.interfaces.DHKey)
        • java.security.interfaces.DSAPublicKey (also extends java.security.interfaces.DSAKey)
        • java.security.interfaces.ECPublicKey (also extends java.security.interfaces.ECKey)
        • java.security.interfaces.RSAPublicKey (also extends java.security.interfaces.RSAKey)
      • java.security.interfaces.RSAMultiPrimePrivateCrtKey
      • java.security.interfaces.RSAPrivateCrtKey
      • java.security.interfaces.RSAPrivateKey (also extends java.security.PrivateKey, java.security.interfaces.RSAKey)
        • java.security.interfaces.RSAMultiPrimePrivateCrtKey
        • java.security.interfaces.RSAPrivateCrtKey
      • java.security.interfaces.RSAPublicKey (also extends java.security.PublicKey, java.security.interfaces.RSAKey)
      • javax.crypto.SecretKey (also extends javax.security.auth.Destroyable)
        • javax.crypto.interfaces.PBEKey
    • org.omg.PortableServer.LifespanPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.LifespanPolicyOperations, org.omg.CORBA.Policy)
    • javax.naming.Name (also extends java.lang.Cloneable, java.lang.Comparable<T>)
    • org.omg.CosNaming.NamingContext (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContextOperations, org.omg.CORBA.Object)
      • org.omg.CosNaming.NamingContextExt (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContextExtOperations)
    • org.omg.CosNaming.NamingContextExt (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContext, org.omg.CosNaming.NamingContextExtOperations)
    • javax.management.NotificationFilter
    • org.omg.PortableInterceptor.ObjectReferenceFactory
      • org.omg.PortableInterceptor.ObjectReferenceTemplate
    • org.omg.PortableInterceptor.ObjectReferenceTemplate
    • org.omg.PortableInterceptor.ORBInitializer (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object, org.omg.PortableInterceptor.ORBInitializerOperations)
    • org.omg.PortableInterceptor.ORBInitInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object, org.omg.PortableInterceptor.ORBInitInfoOperations)
    • javax.crypto.interfaces.PBEKey
    • org.omg.PortableServer.POA (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object, org.omg.PortableServer.POAOperations)
    • org.omg.PortableServer.POAManager (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object, org.omg.PortableServer.POAManagerOperations)
    • org.omg.CORBA.Policy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object, org.omg.CORBA.PolicyOperations)
      • org.omg.PortableServer.IdAssignmentPolicy (also extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableServer.IdUniquenessPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.IdUniquenessPolicyOperations)
      • org.omg.PortableServer.ImplicitActivationPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ImplicitActivationPolicyOperations)
      • org.omg.PortableServer.LifespanPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.LifespanPolicyOperations)
      • org.omg.PortableServer.RequestProcessingPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.RequestProcessingPolicyOperations)
      • org.omg.PortableServer.ServantRetentionPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantRetentionPolicyOperations)
      • org.omg.PortableServer.ThreadPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ThreadPolicyOperations)
    • org.omg.PortableInterceptor.PolicyFactory (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object, org.omg.PortableInterceptor.PolicyFactoryOperations)
    • javax.print.attribute.PrintJobAttribute
    • javax.print.attribute.PrintRequestAttribute
    • javax.print.attribute.PrintServiceAttribute
    • java.security.PrivateKey (also extends javax.security.auth.Destroyable, java.security.Key)
      • javax.crypto.interfaces.DHPrivateKey (also extends javax.crypto.interfaces.DHKey)
      • java.security.interfaces.DSAPrivateKey (also extends java.security.interfaces.DSAKey)
      • java.security.interfaces.ECPrivateKey (also extends java.security.interfaces.ECKey)
      • java.security.interfaces.RSAMultiPrimePrivateCrtKey
      • java.security.interfaces.RSAPrivateCrtKey
      • java.security.interfaces.RSAPrivateKey (also extends java.security.interfaces.RSAKey)
        • java.security.interfaces.RSAMultiPrimePrivateCrtKey
        • java.security.interfaces.RSAPrivateCrtKey
    • java.security.PublicKey
      • javax.crypto.interfaces.DHPublicKey (also extends javax.crypto.interfaces.DHKey)
      • java.security.interfaces.DSAPublicKey (also extends java.security.interfaces.DSAKey)
      • java.security.interfaces.ECPublicKey (also extends java.security.interfaces.ECKey)
      • java.security.interfaces.RSAPublicKey (also extends java.security.interfaces.RSAKey)
    • javax.management.QueryExp
    • javax.management.relation.RelationType
    • java.rmi.server.RemoteRef
      • java.rmi.server.ServerRef
    • org.omg.PortableInterceptor.RequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object, org.omg.PortableInterceptor.RequestInfoOperations)
      • org.omg.PortableInterceptor.ClientRequestInfo (also extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.ServerRequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInfoOperations)
    • org.omg.PortableServer.RequestProcessingPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy, org.omg.PortableServer.RequestProcessingPolicyOperations)
    • java.security.interfaces.RSAMultiPrimePrivateCrtKey
    • java.security.interfaces.RSAPrivateCrtKey
    • java.security.interfaces.RSAPrivateKey (also extends java.security.PrivateKey, java.security.interfaces.RSAKey)
      • java.security.interfaces.RSAMultiPrimePrivateCrtKey
      • java.security.interfaces.RSAPrivateCrtKey
    • java.security.interfaces.RSAPublicKey (also extends java.security.PublicKey, java.security.interfaces.RSAKey)
    • org.omg.SendingContext.RunTime (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object, org.omg.SendingContext.RunTimeOperations)
    • javax.crypto.SecretKey (also extends javax.security.auth.Destroyable, java.security.Key)
      • javax.crypto.interfaces.PBEKey
    • org.omg.PortableServer.ServantActivator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantActivatorOperations, org.omg.PortableServer.ServantManager)
    • org.omg.PortableServer.ServantLocator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantLocatorOperations, org.omg.PortableServer.ServantManager)
    • org.omg.PortableServer.ServantManager (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object, org.omg.PortableServer.ServantManagerOperations)
      • org.omg.PortableServer.ServantActivator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantActivatorOperations)
      • org.omg.PortableServer.ServantLocator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantLocatorOperations)
    • org.omg.PortableServer.ServantRetentionPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy, org.omg.PortableServer.ServantRetentionPolicyOperations)
    • java.rmi.server.ServerRef
    • org.omg.PortableInterceptor.ServerRequestInfo (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfo, org.omg.PortableInterceptor.ServerRequestInfoOperations)
    • org.omg.PortableInterceptor.ServerRequestInterceptor (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
    • org.omg.CORBA.portable.StreamableValue (also extends org.omg.CORBA.portable.Streamable, org.omg.CORBA.portable.ValueBase)
    • javax.print.attribute.SupportedValuesAttribute
    • org.omg.PortableServer.ThreadPolicy (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy, org.omg.PortableServer.ThreadPolicyOperations)
    • javax.naming.ldap.UnsolicitedNotification (also extends javax.naming.ldap.ExtendedResponse, javax.naming.ldap.HasControls)
    • org.omg.CORBA.portable.ValueBase
      • org.omg.CORBA.portable.CustomValue (also extends org.omg.CORBA.CustomMarshal)
      • org.omg.CORBA.DataInputStream
      • org.omg.CORBA.DataOutputStream
      • org.omg.PortableInterceptor.ObjectReferenceFactory
        • org.omg.PortableInterceptor.ObjectReferenceTemplate
      • org.omg.PortableInterceptor.ObjectReferenceTemplate
      • org.omg.CORBA.portable.StreamableValue (also extends org.omg.CORBA.portable.Streamable)
    • javax.management.ValueExp
  • org.omg.PortableServer.SERVANT_RETENTION_POLICY_ID
  • org.omg.PortableServer.ServantManagerOperations
    • org.omg.PortableServer.ServantActivator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantActivatorOperations, org.omg.PortableServer.ServantManager)
    • org.omg.PortableServer.ServantActivatorOperations
      • org.omg.PortableServer.ServantActivator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantManager)
    • org.omg.PortableServer.ServantLocator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantLocatorOperations, org.omg.PortableServer.ServantManager)
    • org.omg.PortableServer.ServantLocatorOperations
      • org.omg.PortableServer.ServantLocator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantManager)
    • org.omg.PortableServer.ServantManager (also extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableServer.ServantActivator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantActivatorOperations)
      • org.omg.PortableServer.ServantLocator (also extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantLocatorOperations)
  • javax.imageio.spi.ServiceRegistry.Filter
  • java.awt.Shape
  • javax.swing.SingleSelectionModel
  • java.rmi.server.Skeleton
  • javax.xml.soap.SOAPConstants
  • java.net.SocketImplFactory
  • java.net.SocketOption<T>
  • java.net.SocketOptions
  • javax.sound.midi.Soundbank
  • javax.xml.transform.Source
  • javax.xml.transform.SourceLocator
    • javax.xml.transform.dom.DOMLocator
  • javax.swing.SpinnerModel
  • java.util.Spliterator<T>
    • java.util.Spliterator.OfDouble
    • java.util.Spliterator.OfInt
    • java.util.Spliterator.OfLong
    • java.util.Spliterator.OfPrimitive<T,T_CONS,T_SPLITR>
      • java.util.Spliterator.OfDouble
      • java.util.Spliterator.OfInt
      • java.util.Spliterator.OfLong
  • java.sql.SQLData
  • java.sql.SQLInput
  • java.sql.SQLOutput
  • java.sql.SQLType
  • java.sql.SQLXML
  • javax.net.ssl.SSLSession
  • javax.net.ssl.SSLSessionContext
  • javax.swing.undo.StateEditable
  • javax.naming.spi.StateFactory
    • javax.naming.spi.DirStateFactory
  • org.omg.CORBA.portable.Streamable
    • org.omg.CORBA.portable.StreamableValue (also extends org.omg.CORBA.portable.ValueBase)
  • javax.xml.stream.StreamFilter
  • java.awt.Stroke
  • java.sql.Struct
  • javax.rmi.CORBA.StubDelegate
  • org.omg.PortableInterceptor.SUCCESSFUL
  • java.util.function.Supplier<T>
  • javax.swing.SwingConstants
  • org.omg.Messaging.SYNC_WITH_TRANSPORT
  • javax.swing.plaf.synth.SynthConstants
    • javax.swing.plaf.synth.SynthUI
  • org.omg.PortableInterceptor.SYSTEM_EXCEPTION
  • javax.swing.text.TabableView
  • javax.swing.text.TabExpander
  • javax.swing.table.TableCellRenderer
  • javax.swing.table.TableColumnModel
  • javax.swing.table.TableModel
  • javax.management.openmbean.TabularData
  • org.omg.IOP.TAG_ALTERNATE_IIOP_ADDRESS
  • org.omg.IOP.TAG_CODE_SETS
  • org.omg.IOP.TAG_INTERNET_IOP
  • org.omg.IOP.TAG_JAVA_CODEBASE
  • org.omg.IOP.TAG_MULTIPLE_COMPONENTS
  • org.omg.IOP.TAG_ORB_TYPE
  • org.omg.IOP.TAG_POLICIES
  • org.omg.IOP.TAG_RMI_CUSTOM_MAX_STREAM_FORMAT
  • javax.xml.transform.Templates
  • java.time.temporal.TemporalAccessor
    • java.time.chrono.ChronoLocalDate (also extends java.lang.Comparable<T>, java.time.temporal.Temporal, java.time.temporal.TemporalAdjuster)
    • java.time.chrono.ChronoLocalDateTime<D> (also extends java.lang.Comparable<T>, java.time.temporal.Temporal, java.time.temporal.TemporalAdjuster)
    • java.time.chrono.ChronoZonedDateTime<D> (also extends java.lang.Comparable<T>, java.time.temporal.Temporal)
    • java.time.chrono.Era (also extends java.time.temporal.TemporalAdjuster)
    • java.time.temporal.Temporal
      • java.time.chrono.ChronoLocalDate (also extends java.lang.Comparable<T>, java.time.temporal.TemporalAdjuster)
      • java.time.chrono.ChronoLocalDateTime<D> (also extends java.lang.Comparable<T>, java.time.temporal.TemporalAdjuster)
      • java.time.chrono.ChronoZonedDateTime<D> (also extends java.lang.Comparable<T>)
  • java.time.temporal.TemporalAdjuster
    • java.time.chrono.ChronoLocalDate (also extends java.lang.Comparable<T>, java.time.temporal.Temporal)
    • java.time.chrono.ChronoLocalDateTime<D> (also extends java.lang.Comparable<T>, java.time.temporal.Temporal)
    • java.time.chrono.Era (also extends java.time.temporal.TemporalAccessor)
  • java.time.temporal.TemporalAmount
    • java.time.chrono.ChronoPeriod
  • java.time.temporal.TemporalField
  • java.time.temporal.TemporalQuery<R>
  • java.time.temporal.TemporalUnit
  • org.omg.PortableServer.THREAD_POLICY_ID
  • java.lang.Thread.UncaughtExceptionHandler
  • java.util.concurrent.ThreadFactory
  • java.awt.image.TileObserver
  • javax.management.timer.TimerMBean
  • java.util.function.ToDoubleBiFunction<T,U>
  • java.util.function.ToDoubleFunction<T>
  • java.util.function.ToIntBiFunction<T,U>
  • java.util.function.ToIntFunction<T>
  • java.util.function.ToLongBiFunction<T,U>
  • java.util.function.ToLongFunction<T>
  • javax.tools.Tool
    • javax.tools.DocumentationTool (also extends javax.tools.OptionChecker)
    • javax.tools.JavaCompiler (also extends javax.tools.OptionChecker)
  • org.omg.IOP.TransactionService
  • java.awt.datatransfer.Transferable
  • java.awt.Transparency
    • java.awt.Paint
  • org.omg.PortableInterceptor.TRANSPORT_RETRY
  • javax.swing.tree.TreeCellRenderer
  • javax.swing.tree.TreeModel
  • javax.swing.tree.TreeNode
    • javax.swing.tree.MutableTreeNode
  • javax.swing.tree.TreeSelectionModel
  • javax.net.ssl.TrustManager
    • javax.net.ssl.X509TrustManager
  • java.lang.reflect.Type
    • java.lang.reflect.GenericArrayType
    • java.lang.reflect.ParameterizedType
    • java.lang.reflect.TypeVariable<D> (also extends java.lang.reflect.AnnotatedElement)
    • java.lang.reflect.WildcardType
  • org.w3c.dom.TypeInfo
  • javax.lang.model.util.Types
  • javax.lang.model.type.TypeVisitor<R,P>
  • javax.swing.UIDefaults.ActiveValue
  • javax.swing.UIDefaults.LazyValue
  • javax.swing.plaf.UIResource
  • javax.swing.undo.UndoableEdit
  • org.omg.PortableInterceptor.UNKNOWN
  • javax.xml.bind.Unmarshaller
  • java.rmi.server.Unreferenced
  • org.omg.CORBA.UNSUPPORTED_POLICY
  • org.omg.CORBA.UNSUPPORTED_POLICY_VALUE
  • javax.xml.crypto.URIDereferencer
  • javax.print.URIException
  • javax.xml.crypto.URIReference
    • javax.xml.crypto.dom.DOMURIReference
    • javax.xml.crypto.dsig.Reference (also extends javax.xml.crypto.XMLStructure)
    • javax.xml.crypto.dsig.keyinfo.RetrievalMethod (also extends javax.xml.crypto.XMLStructure)
  • javax.xml.transform.URIResolver
  • java.net.URLStreamHandlerFactory
  • org.omg.PortableInterceptor.USER_EXCEPTION
  • org.w3c.dom.UserDataHandler
  • javax.rmi.CORBA.UtilDelegate
  • javax.xml.bind.ValidationEvent
    • javax.xml.bind.NotIdentifiableEvent
    • javax.xml.bind.ParseConversionEvent
    • javax.xml.bind.PrintConversionEvent
  • javax.xml.bind.ValidationEventHandler
  • javax.xml.bind.ValidationEventLocator
  • javax.xml.bind.Validator
  • org.omg.CORBA.portable.ValueFactory
  • javax.rmi.CORBA.ValueHandler
    • javax.rmi.CORBA.ValueHandlerMultiFormat
  • org.omg.CORBA.portable.ValueInputStream
  • org.omg.CORBA.portable.ValueOutputStream
  • javax.swing.text.ViewFactory
  • java.beans.Visibility
    • java.beans.beancontext.BeanContext (also extends java.beans.beancontext.BeanContextChild, java.util.Collection<E>, java.beans.DesignMode)
      • java.beans.beancontext.BeanContextServices (also extends java.beans.beancontext.BeanContextServicesListener)
    • java.beans.beancontext.BeanContextServices (also extends java.beans.beancontext.BeanContext, java.beans.beancontext.BeanContextServicesListener)
  • org.omg.CORBA.VM_ABSTRACT
  • org.omg.CORBA.VM_CUSTOM
  • org.omg.CORBA.VM_NONE
  • org.omg.CORBA.VM_TRUNCATABLE
  • java.nio.file.Watchable
    • java.nio.file.Path (also extends java.lang.Comparable<T>, java.lang.Iterable<T>)
  • java.nio.file.WatchEvent<T>
  • java.nio.file.WatchEvent.Kind<T>
  • java.nio.file.WatchEvent.Modifier
  • java.nio.file.WatchKey
  • javax.xml.ws.WebServiceContext
  • javax.swing.WindowConstants
  • java.sql.Wrapper
    • javax.sql.rowset.CachedRowSet (also extends javax.sql.rowset.Joinable, javax.sql.RowSet)
      • javax.sql.rowset.FilteredRowSet
      • javax.sql.rowset.JoinRowSet
      • javax.sql.rowset.WebRowSet
        • javax.sql.rowset.FilteredRowSet
        • javax.sql.rowset.JoinRowSet
    • java.sql.CallableStatement
    • java.sql.Connection (also extends java.lang.AutoCloseable)
    • java.sql.DatabaseMetaData
    • javax.sql.DataSource (also extends javax.sql.CommonDataSource)
    • javax.sql.rowset.FilteredRowSet
    • javax.sql.rowset.JdbcRowSet (also extends javax.sql.rowset.Joinable, javax.sql.RowSet)
    • javax.sql.rowset.JoinRowSet
    • java.sql.ParameterMetaData
    • java.sql.PreparedStatement
      • java.sql.CallableStatement
    • java.sql.ResultSet (also extends java.lang.AutoCloseable)
      • javax.sql.rowset.CachedRowSet (also extends javax.sql.rowset.Joinable, javax.sql.RowSet)
        • javax.sql.rowset.FilteredRowSet
        • javax.sql.rowset.JoinRowSet
        • javax.sql.rowset.WebRowSet
          • javax.sql.rowset.FilteredRowSet
          • javax.sql.rowset.JoinRowSet
      • javax.sql.rowset.FilteredRowSet
      • javax.sql.rowset.JdbcRowSet (also extends javax.sql.rowset.Joinable, javax.sql.RowSet)
      • javax.sql.rowset.JoinRowSet
      • javax.sql.RowSet
        • javax.sql.rowset.CachedRowSet (also extends javax.sql.rowset.Joinable)
          • javax.sql.rowset.FilteredRowSet
          • javax.sql.rowset.JoinRowSet
          • javax.sql.rowset.WebRowSet
            • javax.sql.rowset.FilteredRowSet
            • javax.sql.rowset.JoinRowSet
        • javax.sql.rowset.FilteredRowSet
        • javax.sql.rowset.JdbcRowSet (also extends javax.sql.rowset.Joinable)
        • javax.sql.rowset.JoinRowSet
        • javax.sql.rowset.spi.SyncResolver
        • javax.sql.rowset.WebRowSet
          • javax.sql.rowset.FilteredRowSet
          • javax.sql.rowset.JoinRowSet
      • javax.sql.rowset.spi.SyncResolver
      • javax.sql.rowset.WebRowSet
        • javax.sql.rowset.FilteredRowSet
        • javax.sql.rowset.JoinRowSet
    • java.sql.ResultSetMetaData
      • javax.sql.RowSetMetaData
    • javax.sql.RowSet
      • javax.sql.rowset.CachedRowSet (also extends javax.sql.rowset.Joinable)
        • javax.sql.rowset.FilteredRowSet
        • javax.sql.rowset.JoinRowSet
        • javax.sql.rowset.WebRowSet
          • javax.sql.rowset.FilteredRowSet
          • javax.sql.rowset.JoinRowSet
      • javax.sql.rowset.FilteredRowSet
      • javax.sql.rowset.JdbcRowSet (also extends javax.sql.rowset.Joinable)
      • javax.sql.rowset.JoinRowSet
      • javax.sql.rowset.spi.SyncResolver
      • javax.sql.rowset.WebRowSet
        • javax.sql.rowset.FilteredRowSet
        • javax.sql.rowset.JoinRowSet
    • javax.sql.RowSetMetaData
    • java.sql.Statement (also extends java.lang.AutoCloseable)
      • java.sql.CallableStatement
      • java.sql.PreparedStatement
        • java.sql.CallableStatement
    • javax.sql.rowset.spi.SyncResolver
    • javax.sql.rowset.WebRowSet
      • javax.sql.rowset.FilteredRowSet
      • javax.sql.rowset.JoinRowSet
  • java.security.cert.X509Extension
  • javax.transaction.xa.XAResource
  • javax.transaction.xa.Xid
  • javax.xml.crypto.XMLCryptoContext
    • javax.xml.crypto.dsig.XMLSignContext
    • javax.xml.crypto.dsig.XMLValidateContext
  • javax.xml.stream.util.XMLEventAllocator
  • javax.xml.stream.util.XMLEventConsumer
    • javax.xml.stream.XMLEventWriter
  • org.xml.sax.XMLReader
    • org.xml.sax.XMLFilter
  • javax.xml.stream.XMLReporter
  • javax.xml.stream.XMLResolver
  • javax.xml.stream.XMLStreamConstants
    • javax.xml.stream.events.Attribute
      • javax.xml.stream.events.Namespace
    • javax.xml.stream.events.Characters
    • javax.xml.stream.events.Comment
    • javax.xml.stream.events.DTD
    • javax.xml.stream.events.EndDocument
    • javax.xml.stream.events.EndElement
    • javax.xml.stream.events.EntityDeclaration
    • javax.xml.stream.events.EntityReference
    • javax.xml.stream.events.Namespace
    • javax.xml.stream.events.NotationDeclaration
    • javax.xml.stream.events.ProcessingInstruction
    • javax.xml.stream.events.StartDocument
    • javax.xml.stream.events.StartElement
    • javax.xml.stream.events.XMLEvent
      • javax.xml.stream.events.Attribute
        • javax.xml.stream.events.Namespace
      • javax.xml.stream.events.Characters
      • javax.xml.stream.events.Comment
      • javax.xml.stream.events.DTD
      • javax.xml.stream.events.EndDocument
      • javax.xml.stream.events.EndElement
      • javax.xml.stream.events.EntityDeclaration
      • javax.xml.stream.events.EntityReference
      • javax.xml.stream.events.Namespace
      • javax.xml.stream.events.NotationDeclaration
      • javax.xml.stream.events.ProcessingInstruction
      • javax.xml.stream.events.StartDocument
      • javax.xml.stream.events.StartElement
    • javax.xml.stream.XMLStreamReader
  • javax.xml.stream.XMLStreamWriter
  • javax.xml.crypto.XMLStructure
    • javax.xml.crypto.dsig.CanonicalizationMethod
    • javax.xml.crypto.dsig.DigestMethod (also extends javax.xml.crypto.AlgorithmMethod)
    • javax.xml.crypto.dsig.keyinfo.KeyInfo
    • javax.xml.crypto.dsig.keyinfo.KeyName
    • javax.xml.crypto.dsig.keyinfo.KeyValue
    • javax.xml.crypto.dsig.Manifest
    • javax.xml.crypto.dsig.keyinfo.PGPData
    • javax.xml.crypto.dsig.Reference (also extends javax.xml.crypto.URIReference)
    • javax.xml.crypto.dsig.keyinfo.RetrievalMethod (also extends javax.xml.crypto.URIReference)
    • javax.xml.crypto.dsig.SignatureMethod (also extends javax.xml.crypto.AlgorithmMethod)
    • javax.xml.crypto.dsig.SignatureProperties
    • javax.xml.crypto.dsig.SignatureProperty
    • javax.xml.crypto.dsig.SignedInfo
    • javax.xml.crypto.dsig.Transform (also extends javax.xml.crypto.AlgorithmMethod)
      • javax.xml.crypto.dsig.CanonicalizationMethod
    • javax.xml.crypto.dsig.keyinfo.X509Data
    • javax.xml.crypto.dsig.keyinfo.X509IssuerSerial
    • javax.xml.crypto.dsig.XMLObject
    • javax.xml.crypto.dsig.XMLSignature
    • javax.xml.crypto.dsig.XMLSignature.SignatureValue
  • javax.xml.xpath.XPath
  • javax.xml.xpath.XPathExpression
  • javax.xml.xpath.XPathFunction
  • javax.xml.xpath.XPathFunctionResolver
  • javax.xml.xpath.XPathVariableResolver

Annotation Type Hierarchy

  • java.beans.Transient (implements java.lang.annotation.Annotation)
  • java.beans.ConstructorProperties (implements java.lang.annotation.Annotation)
  • java.lang.SuppressWarnings (implements java.lang.annotation.Annotation)
  • java.lang.Override (implements java.lang.annotation.Annotation)
  • java.lang.SafeVarargs (implements java.lang.annotation.Annotation)
  • java.lang.Deprecated (implements java.lang.annotation.Annotation)
  • java.lang.FunctionalInterface (implements java.lang.annotation.Annotation)
  • java.lang.annotation.Native (implements java.lang.annotation.Annotation)
  • java.lang.annotation.Retention (implements java.lang.annotation.Annotation)
  • java.lang.annotation.Target (implements java.lang.annotation.Annotation)
  • java.lang.annotation.Repeatable (implements java.lang.annotation.Annotation)
  • java.lang.annotation.Inherited (implements java.lang.annotation.Annotation)
  • java.lang.annotation.Documented (implements java.lang.annotation.Annotation)
  • javax.annotation.Resource (implements java.lang.annotation.Annotation)
  • javax.annotation.PreDestroy (implements java.lang.annotation.Annotation)
  • javax.annotation.Generated (implements java.lang.annotation.Annotation)
  • javax.annotation.PostConstruct (implements java.lang.annotation.Annotation)
  • javax.annotation.Resources (implements java.lang.annotation.Annotation)
  • javax.annotation.processing.SupportedSourceVersion (implements java.lang.annotation.Annotation)
  • javax.annotation.processing.SupportedAnnotationTypes (implements java.lang.annotation.Annotation)
  • javax.annotation.processing.SupportedOptions (implements java.lang.annotation.Annotation)
  • javax.jws.WebResult (implements java.lang.annotation.Annotation)
  • javax.jws.WebMethod (implements java.lang.annotation.Annotation)
  • javax.jws.WebService (implements java.lang.annotation.Annotation)
  • javax.jws.WebParam (implements java.lang.annotation.Annotation)
  • javax.jws.HandlerChain (implements java.lang.annotation.Annotation)
  • javax.jws.Oneway (implements java.lang.annotation.Annotation)
  • javax.jws.soap.SOAPMessageHandler (implements java.lang.annotation.Annotation)
  • javax.jws.soap.InitParam (implements java.lang.annotation.Annotation)
  • javax.jws.soap.SOAPBinding (implements java.lang.annotation.Annotation)
  • javax.jws.soap.SOAPMessageHandlers (implements java.lang.annotation.Annotation)
  • javax.management.MXBean (implements java.lang.annotation.Annotation)
  • javax.management.DescriptorKey (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAccessorType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementRefs (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlMixed (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAccessorOrder (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAttribute (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlNs (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAnyAttribute (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlList (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementWrapper (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlSchema (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlID (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlIDREF (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlEnumValue (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementDecl (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlMimeType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAttachmentRef (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementRef (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAnyElement (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlSchemaType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlRootElement (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlValue (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElements (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlInlineBinaryData (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlEnum (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlTransient (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlSeeAlso (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlRegistry (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlSchemaTypes (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElement (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.adapters.XmlJavaTypeAdapters (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebServiceClient (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebEndpoint (implements java.lang.annotation.Annotation)
  • javax.xml.ws.BindingType (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebServiceProvider (implements java.lang.annotation.Annotation)
  • javax.xml.ws.RespectBinding (implements java.lang.annotation.Annotation)
  • javax.xml.ws.ServiceMode (implements java.lang.annotation.Annotation)
  • javax.xml.ws.Action (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebServiceRef (implements java.lang.annotation.Annotation)
  • javax.xml.ws.FaultAction (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebServiceRefs (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebFault (implements java.lang.annotation.Annotation)
  • javax.xml.ws.ResponseWrapper (implements java.lang.annotation.Annotation)
  • javax.xml.ws.RequestWrapper (implements java.lang.annotation.Annotation)
  • javax.xml.ws.soap.MTOM (implements java.lang.annotation.Annotation)
  • javax.xml.ws.soap.Addressing (implements java.lang.annotation.Annotation)
  • javax.xml.ws.spi.WebServiceFeatureAnnotation (implements java.lang.annotation.Annotation)

Enum Hierarchy

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.awt.Dialog.ModalityType
      • java.awt.Dialog.ModalExclusionType
      • java.awt.GraphicsDevice.WindowTranslucency
      • java.awt.MultipleGradientPaint.CycleMethod
      • java.awt.MultipleGradientPaint.ColorSpaceType
      • java.awt.Window.Type
      • java.awt.TrayIcon.MessageType
      • java.awt.Component.BaselineResizeBehavior
      • java.awt.Desktop.Action
      • java.awt.font.NumericShaper.Range
      • java.lang.Thread.State
      • java.lang.Character.UnicodeScript
      • java.lang.ProcessBuilder.Redirect.Type
      • java.lang.annotation.RetentionPolicy
      • java.lang.annotation.ElementType
      • java.lang.management.MemoryType
      • java.math.RoundingMode
      • java.net.Authenticator.RequestorType
      • java.net.StandardProtocolFamily (implements java.net.ProtocolFamily)
      • java.net.Proxy.Type
      • java.nio.file.AccessMode
      • java.nio.file.LinkOption (implements java.nio.file.CopyOption, java.nio.file.OpenOption)
      • java.nio.file.StandardCopyOption (implements java.nio.file.CopyOption)
      • java.nio.file.StandardOpenOption (implements java.nio.file.OpenOption)
      • java.nio.file.FileVisitOption
      • java.nio.file.FileVisitResult
      • java.nio.file.attribute.AclEntryFlag
      • java.nio.file.attribute.AclEntryType
      • java.nio.file.attribute.AclEntryPermission
      • java.nio.file.attribute.PosixFilePermission
      • java.security.CryptoPrimitive
      • java.security.KeyRep.Type
      • java.security.cert.CRLReason
      • java.security.cert.PKIXReason (implements java.security.cert.CertPathValidatorException.Reason)
      • java.security.cert.CertPathValidatorException.BasicReason (implements java.security.cert.CertPathValidatorException.Reason)
      • java.security.cert.PKIXRevocationChecker.Option
      • java.sql.ClientInfoStatus
      • java.sql.PseudoColumnUsage
      • java.sql.JDBCType (implements java.sql.SQLType)
      • java.sql.RowIdLifetime
      • java.text.Normalizer.Form
      • java.time.DayOfWeek (implements java.time.temporal.TemporalAccessor, java.time.temporal.TemporalAdjuster)
      • java.time.Month (implements java.time.temporal.TemporalAccessor, java.time.temporal.TemporalAdjuster)
      • java.time.chrono.IsoEra (implements java.time.chrono.Era)
      • java.time.chrono.MinguoEra (implements java.time.chrono.Era)
      • java.time.chrono.HijrahEra (implements java.time.chrono.Era)
      • java.time.chrono.ThaiBuddhistEra (implements java.time.chrono.Era)
      • java.time.format.ResolverStyle
      • java.time.format.TextStyle
      • java.time.format.SignStyle
      • java.time.format.FormatStyle
      • java.time.temporal.ChronoField (implements java.time.temporal.TemporalField)
      • java.time.temporal.ChronoUnit (implements java.time.temporal.TemporalUnit)
      • java.time.zone.ZoneOffsetTransitionRule.TimeDefinition
      • java.util.Formatter.BigDecimalLayoutForm
      • java.util.Locale.Category
      • java.util.Locale.FilteringMode
      • java.util.concurrent.TimeUnit
      • java.util.stream.Collector.Characteristics
      • javax.annotation.Resource.AuthenticationType
      • javax.jws.WebParam.Mode
      • javax.jws.soap.SOAPBinding.Style
      • javax.jws.soap.SOAPBinding.Use
      • javax.jws.soap.SOAPBinding.ParameterStyle
      • javax.lang.model.SourceVersion
      • javax.lang.model.element.Modifier
      • javax.lang.model.element.NestingKind
      • javax.lang.model.element.ElementKind
      • javax.lang.model.type.TypeKind
      • javax.net.ssl.SSLEngineResult.Status
      • javax.net.ssl.SSLEngineResult.HandshakeStatus
      • javax.swing.DropMode
      • javax.swing.SwingWorker.StateValue
      • javax.swing.RowFilter.ComparisonType
      • javax.swing.LayoutStyle.ComponentPlacement
      • javax.swing.SortOrder
      • javax.swing.JTable.PrintMode
      • javax.swing.GroupLayout.Alignment
      • javax.swing.event.RowSorterEvent.Type
      • javax.swing.text.html.FormSubmitEvent.MethodType
      • javax.swing.plaf.nimbus.AbstractRegionPainter.PaintContext.CacheMode
      • javax.tools.DocumentationTool.Location (implements javax.tools.JavaFileManager.Location)
      • javax.tools.JavaFileObject.Kind
      • javax.tools.StandardLocation (implements javax.tools.JavaFileManager.Location)
      • javax.tools.Diagnostic.Kind
      • javax.xml.bind.annotation.XmlAccessType
      • javax.xml.bind.annotation.XmlNsForm
      • javax.xml.bind.annotation.XmlAccessOrder
      • javax.xml.ws.Service.Mode
      • javax.xml.ws.handler.MessageContext.Scope
      • javax.xml.ws.soap.AddressingFeature.Responses
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


Overview List (Java Platform SE 8 )

Standard Ed. 8

All ClassesAll Packages

Profiles

  • compact1
  • compact2
  • compact3


Serialized Form (Java Platform SE 8 )

Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames
  • All Classes

Serialized Form

  • Package java.applet

    • Class java.applet.Applet extends Panel implements Serializable

      serialVersionUID:
      -5836846270535785031L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
          Read an applet from an object input stream.
          Throws:
          HeadlessException - if GraphicsEnvironment.isHeadless() returns true
          ClassNotFoundException
          IOException
          Since:
          1.4
          See Also:
          GraphicsEnvironment.isHeadless()

      • Serialized Fields

        • accessibleContext

          AccessibleContext accessibleContext

    • Class java.applet.Applet.AccessibleApplet extends Panel.AccessibleAWTPanel implements Serializable

      serialVersionUID:
      8127374778187708896L

  • Package java.awt

    • Class java.awt.AWTError extends Error implements Serializable

      serialVersionUID:
      -1819846354050686206L

    • Class java.awt.AWTEvent extends EventObject implements Serializable

      serialVersionUID:
      -1825314779160409405L

      • Serialized Fields

        • bdata

          byte[] bdata

        • id

          int id
          The event's id.
          See Also:
          AWTEvent.getID(), AWTEvent.AWTEvent(java.lang.Object, int)

        • consumed

          boolean consumed
          Controls whether or not the event is sent back down to the peer once the source has processed it - false means it's sent to the peer; true means it's not. Semantic events always have a 'true' value since they were generated by the peer in response to a low-level event.
          See Also:
          AWTEvent.consume(), AWTEvent.isConsumed()

    • Class java.awt.AWTException extends Exception implements Serializable

      serialVersionUID:
      -1900414231151323879L

    • Class java.awt.AWTKeyStroke extends Object implements Serializable

      serialVersionUID:
      -6430539691155161871L

      • Serialization Methods

        • readResolve

          protected Object readResolve()
                      throws ObjectStreamException
          Returns a cached instance of AWTKeyStroke (or a subclass of AWTKeyStroke) which is equal to this instance.
          Throws:
          ObjectStreamException

      • Serialized Fields

        • keyChar

          char keyChar

        • keyCode

          int keyCode

        • modifiers

          int modifiers

        • onKeyRelease

          boolean onKeyRelease

    • Class java.awt.AWTPermission extends BasicPermission implements Serializable

      serialVersionUID:
      8890392402588814465L

    • Class java.awt.BorderLayout extends Object implements Serializable

      serialVersionUID:
      -8658291919501921765L

      • Serialized Fields

        • hgap

          int hgap
          Constructs a border layout with the horizontal gaps between components. The horizontal gap is specified by hgap.
          See Also:
          BorderLayout.getHgap(), BorderLayout.setHgap(int)

        • vgap

          int vgap
          Constructs a border layout with the vertical gaps between components. The vertical gap is specified by vgap.
          See Also:
          BorderLayout.getVgap(), BorderLayout.setVgap(int)

        • north

          Component north
          Constant to specify components location to be the north portion of the border layout.
          See Also:
          BorderLayout.getChild(String, boolean),
BorderLayout.addLayoutComponent(java.awt.Component, java.lang.Object),
BorderLayout.getLayoutAlignmentX(java.awt.Container),
BorderLayout.getLayoutAlignmentY(java.awt.Container),
BorderLayout.removeLayoutComponent(java.awt.Component)

        • west

          Component west
          Constant to specify components location to be the west portion of the border layout.
          See Also:
          BorderLayout.getChild(String, boolean),
BorderLayout.addLayoutComponent(java.awt.Component, java.lang.Object),
BorderLayout.getLayoutAlignmentX(java.awt.Container),
BorderLayout.getLayoutAlignmentY(java.awt.Container),
BorderLayout.removeLayoutComponent(java.awt.Component)

        • east

          Component east
          Constant to specify components location to be the east portion of the border layout.
          See Also:
          BorderLayout.getChild(String, boolean),
BorderLayout.addLayoutComponent(java.awt.Component, java.lang.Object),
BorderLayout.getLayoutAlignmentX(java.awt.Container),
BorderLayout.getLayoutAlignmentY(java.awt.Container),
BorderLayout.removeLayoutComponent(java.awt.Component)

        • south

          Component south
          Constant to specify components location to be the south portion of the border layout.
          See Also:
          BorderLayout.getChild(String, boolean),
BorderLayout.addLayoutComponent(java.awt.Component, java.lang.Object),
BorderLayout.getLayoutAlignmentX(java.awt.Container),
BorderLayout.getLayoutAlignmentY(java.awt.Container),
BorderLayout.removeLayoutComponent(java.awt.Component)

        • center

          Component center
          Constant to specify components location to be the center portion of the border layout.
          See Also:
          BorderLayout.getChild(String, boolean),
BorderLayout.addLayoutComponent(java.awt.Component, java.lang.Object),
BorderLayout.getLayoutAlignmentX(java.awt.Container),
BorderLayout.getLayoutAlignmentY(java.awt.Container),
BorderLayout.removeLayoutComponent(java.awt.Component)

        • firstLine

          Component firstLine
          A relative positioning constant, that can be used instead of north, south, east, west or center. mixing the two types of constants can lead to unpredictable results. If you use both types, the relative constants will take precedence. For example, if you add components using both the NORTH and BEFORE_FIRST_LINE constants in a container whose orientation is LEFT_TO_RIGHT, only the BEFORE_FIRST_LINE will be layed out. This will be the same for lastLine, firstItem, lastItem.

        • lastLine

          Component lastLine
          A relative positioning constant, that can be used instead of north, south, east, west or center. Please read Description for firstLine.

        • firstItem

          Component firstItem
          A relative positioning constant, that can be used instead of north, south, east, west or center. Please read Description for firstLine.

        • lastItem

          Component lastItem
          A relative positioning constant, that can be used instead of north, south, east, west or center. Please read Description for firstLine.

    • Class java.awt.Button extends Component implements Serializable

      serialVersionUID:
      -8774683716313001058L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
          Reads the ObjectInputStream and if it isn't null adds a listener to receive action events fired by the button. Unrecognized keys or values will be ignored.
          Throws:
          HeadlessException - if GraphicsEnvironment.isHeadless returns true
          ClassNotFoundException
          IOException
          See Also:
          Button.removeActionListener(ActionListener),
Button.addActionListener(ActionListener),
GraphicsEnvironment.isHeadless(),
Button.writeObject(ObjectOutputStream)

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Writes default serializable fields to stream. Writes a list of serializable ActionListeners as optional data. The non-serializable ActionListeners are detected and no attempt is made to serialize them.
          Serial Data:
          null terminated sequence of 0 or more pairs: the pair consists of a String and an Object; the String indicates the type of object and is one of the following: actionListenerK indicating an ActionListener object
          Throws:
          IOException
          See Also:
          AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Component.actionListenerK, Button.readObject(ObjectInputStream)

      • Serialized Fields

        • label

          String label
          The button's label. This value may be null.
          See Also:
          Button.getLabel(), Button.setLabel(String)

        • actionCommand

          String actionCommand
          The action to be performed once a button has been pressed. This value may be null.
          See Also:
          Button.getActionCommand(), Button.setActionCommand(String)

        • buttonSerializedDataVersion

          int buttonSerializedDataVersion

    • Class java.awt.Button.AccessibleAWTButton extends Component.AccessibleAWTComponent implements Serializable

      serialVersionUID:
      -5932203980244017102L

    • Class java.awt.Canvas extends Component implements Serializable

      serialVersionUID:
      -2284879212465893870L

    • Class java.awt.Canvas.AccessibleAWTCanvas extends Component.AccessibleAWTComponent implements Serializable

      serialVersionUID:
      -6325592262103146699L

    • Class java.awt.CardLayout extends Object implements Serializable

      serialVersionUID:
      -4328196481005934313L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
          Reads serializable fields from stream.
          Throws:
          ClassNotFoundException
          IOException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Writes serializable fields to stream.
          Throws:
          IOException

      • Serialized Fields

        • currentCard

          int currentCard

        • hgap

          int hgap

        • tab

          Hashtable<K,V> tab
          deprectated, for forward compatibility only

        • vector

          Vector<E> vector

        • vgap

          int vgap

    • Class java.awt.Checkbox extends Component implements Serializable

      serialVersionUID:
      7270714317450821763L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
          Reads the ObjectInputStream and if it isn't null adds a listener to receive item events fired by the Checkbox. Unrecognized keys or values will be ignored.
          Throws:
          HeadlessException - if GraphicsEnvironment.isHeadless returns true
          ClassNotFoundException
          IOException
          See Also:
          Checkbox.removeItemListener(ItemListener),
Checkbox.addItemListener(ItemListener),
GraphicsEnvironment.isHeadless(),
Checkbox.writeObject(ObjectOutputStream)

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Writes default serializable fields to stream. Writes a list of serializable ItemListeners as optional data. The non-serializable ItemListeners are detected and no attempt is made to serialize them.
          Serial Data:
          null terminated sequence of 0 or more pairs; the pair consists of a String and an Object; the String indicates the type of object and is one of the following: itemListenerK indicating an ItemListener object
          Throws:
          IOException
          See Also:
          AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Component.itemListenerK, Checkbox.readObject(ObjectInputStream)

      • Serialized Fields

        • label

          String label
          The label of the Checkbox. This field can be null.
          See Also:
          Checkbox.getLabel(), Checkbox.setLabel(String)

        • state

          boolean state
          The state of the Checkbox.
          See Also:
          Checkbox.getState(), Checkbox.setState(boolean)

        • group

          CheckboxGroup group
          The check box group. This field can be null indicating that the checkbox is not a group checkbox.
          See Also:
          Checkbox.getCheckboxGroup(), Checkbox.setCheckboxGroup(CheckboxGroup)

        • checkboxSerializedDataVersion

          int checkboxSerializedDataVersion

    • Class java.awt.Checkbox.AccessibleAWTCheckbox extends Component.AccessibleAWTComponent implements Serializable

      serialVersionUID:
      7881579233144754107L

    • Class java.awt.CheckboxGroup extends Object implements Serializable

      serialVersionUID:
      3729780091441768983L

      • Serialized Fields

        • selectedCheckbox

          Checkbox selectedCheckbox
          The current choice.
          See Also:
          CheckboxGroup.getCurrent(), CheckboxGroup.setCurrent(Checkbox)

    • Class java.awt.CheckboxMenuItem extends MenuItem implements Serializable

      serialVersionUID:
      6190621106981774043L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
          Throws:
          ClassNotFoundException
          IOException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Writes default serializable fields to stream. Writes a list of serializable ItemListeners as optional data. The non-serializable ItemListeners are detected and no attempt is made to serialize them.
          Serial Data:
          null terminated sequence of 0 or more pairs; the pair consists of a String and an Object; the String indicates the type of object and is one of the following: itemListenerK indicating an ItemListener object
          Throws:
          IOException
          See Also:
          AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Component.itemListenerK, CheckboxMenuItem.readObject(ObjectInputStream)

      • Serialized Fields

        • state

          boolean state
          The state of a checkbox menu item
          See Also:
          CheckboxMenuItem.getState(), CheckboxMenuItem.setState(boolean)

        • checkboxMenuItemSerializedDataVersion

          int checkboxMenuItemSerializedDataVersion

    • Class java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem extends MenuItem.AccessibleAWTMenuItem implements Serializable

      serialVersionUID:
      -1122642964303476L

    • Class java.awt.Choice extends Component implements Serializable

      serialVersionUID:
      -4075310674757313071L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
          Reads the ObjectInputStream and if it isn't null adds a listener to receive item events fired by the Choice item. Unrecognized keys or values will be ignored.
          Throws:
          HeadlessException - if GraphicsEnvironment.isHeadless returns true
          ClassNotFoundException
          IOException
          See Also:
          Choice.removeItemListener(ItemListener),
Choice.addItemListener(ItemListener),
GraphicsEnvironment.isHeadless(),
Choice.writeObject(ObjectOutputStream)

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Writes default serializable fields to stream. Writes a list of serializable ItemListeners as optional data. The non-serializable ItemListeners are detected and no attempt is made to serialize them.
          Serial Data:
          null terminated sequence of 0 or more pairs; the pair consists of a String and an Object; the String indicates the type of object and is one of the following: itemListenerK indicating an ItemListener object
          Throws:
          IOException
          See Also:
          AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Component.itemListenerK, Choice.readObject(ObjectInputStream)

      • Serialized Fields

        • pItems

          Vector<E> pItems
          The items for the Choice. This can be a null value.
          See Also:
          Choice.add(String),
Choice.addItem(String),
Choice.getItem(int),
Choice.getItemCount(),
Choice.insert(String, int),
Choice.remove(String)

        • selectedIndex

          int selectedIndex
          The index of the current choice for this Choice or -1 if nothing is selected.
          See Also:
          Choice.getSelectedItem(), Choice.select(int)

        • choiceSerializedDataVersion

          int choiceSerializedDataVersion

    • Class java.awt.Choice.AccessibleAWTChoice extends Component.AccessibleAWTComponent implements Serializable

      serialVersionUID:
      7175603582428509322L

    • Class java.awt.Color extends Object implements Serializable

      serialVersionUID:
      118526816881161077L

      • Serialized Fields

        • value

          int value
          The color value.
          See Also:
          Color.getRGB()

        • frgbvalue

          float[] frgbvalue
          The color value in the default sRGB ColorSpace as float components (no alpha). If null after object construction, this must be an sRGB color constructed with 8-bit precision, so compute from the int color value.
          See Also:
          Color.getRGBColorComponents(float[]), Color.getRGBComponents(float[])

        • fvalue

          float[] fvalue
          The color value in the native ColorSpace as float components (no alpha). If null after object construction, this must be an sRGB color constructed with 8-bit precision, so compute from the int color value.
          See Also:
          Color.getRGBColorComponents(float[]), Color.getRGBComponents(float[])

        • falpha

          float falpha
          The alpha value as a float component. If frgbvalue is null, this is not valid data, so compute from the int color value.
          See Also:
          Color.getRGBComponents(float[]), Color.getComponents(float[])

        • cs

          ColorSpace cs
          The ColorSpace. If null, then it's default is sRGB.
          See Also:
          Color.getColor(java.lang.String),
Color.getColorSpace(),
Color.getColorComponents(float[])

    • Class java.awt.Component extends Object implements Serializable

      serialVersionUID:
      -7644114512714619750L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
          Reads the ObjectInputStream and if it isn't null adds a listener to receive a variety of events fired by the component. Unrecognized keys or values will be ignored.
          Throws:
          ClassNotFoundException
          IOException
          See Also:
          Component.writeObject(ObjectOutputStream)

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Writes default serializable fields to stream. Writes a variety of serializable listeners as optional data. The non-serializable listeners are detected and no attempt is made to serialize them.
          Serial Data:
          null terminated sequence of 0 or more pairs; the pair consists of a String and an Object; the String indicates the type of object and is one of the following (as of 1.4): componentListenerK indicating an ComponentListener object; focusListenerK indicating an FocusListener object; keyListenerK indicating an KeyListener object; mouseListenerK indicating an MouseListener object; mouseMotionListenerK indicating an MouseMotionListener object; inputMethodListenerK indicating an InputMethodListener object; hierarchyListenerK indicating an HierarchyListener object; hierarchyBoundsListenerK indicating an HierarchyBoundsListener object; mouseWheelListenerK indicating an MouseWheelListener object, an optional ComponentOrientation (after inputMethodListener, as of 1.2)
          Throws:
          IOException
          See Also:
          AWTEventMulticaster.save(java.io.ObjectOutputStream, java.lang.String, java.util.EventListener), Component.componentListenerK, Component.focusListenerK, Component.keyListenerK, Component.mouseListenerK, Component.mouseMotionListenerK, Component.inputMethodListenerK, Component.hierarchyListenerK, Component.hierarchyBoundsListenerK, Component.mouseWheelListenerK, Component.readObject(ObjectInputStream)

      • Serialized Fields

        • x

          int x
          The x position of the component in the parent's coordinate system.
          See Also:
          Component.getLocation()

        • y

          int y
          The y position of the component in the parent's coordinate system.
          See Also:
          Component.getLocation()

        • width

          int width
          The width of the component.
          See Also:
          Component.getSize()

        • height

          int height
          The height of the component.
          See Also:
          Component.getSize()

        • foreground

          Color foreground
          The foreground color for this component. foreground can be null.
          See Also:
          Component.getForeground(), Component.setForeground(java.awt.Color)

        • background

          Color background
          The background color for this component. background can be null.
          See Also:
          Component.getBackground(), Component.setBackground(java.awt.Color)

        • font

          Font font
          The font used by this component. The font can be null.
          See Also:
          Component.getFont(), Component.setFont(java.awt.Font)

        • peerFont

          Font peerFont
          The font which the peer is currently using. (null if no peer exists.)

        • cursor

          Cursor cursor
          The cursor displayed when pointer is over this component. This value can be null.
          See Also:
          Component.getCursor(), Component.setCursor(java.awt.Cursor)

        • locale

          Locale locale
          The locale for the component.
          See Also:
          Component.getLocale(), Component.setLocale(java.util.Locale)

        • ignoreRepaint

          boolean ignoreRepaint
          True when the object should ignore all repaint events.
          Since:
          1.4
          See Also:
          Component.setIgnoreRepaint(boolean), Component.getIgnoreRepaint()

        • visible

          boolean visible
          True when the object is visible. An object that is not visible is not drawn on the screen.
          See Also:
          Component.isVisible(), Component.setVisible(boolean)

        • enabled

          boolean enabled
          True when the object is enabled. An object that is not enabled does not interact with the user.
          See Also:
          Component.isEnabled(), Component.setEnabled(boolean)

        • valid

          boolean valid
          True when the object is valid. An invalid object needs to be layed out. This flag is set to false when the object size is changed.
          See Also:
          Component.isValid(),
Component.validate(),
Component.invalidate()

        • dropTarget

          DropTarget dropTarget
          The DropTarget associated with this component.
          Since:
          1.2
          See Also:
          Component.setDropTarget(java.awt.dnd.DropTarget), Component.getDropTarget()

        • popups

          Vector<E> popups
          See Also:
          Component.add(java.awt.PopupMenu)

        • name

          String name
          A component's name. This field can be null.
          See Also:
          Component.getName(), Component.setName(String)

        • nameExplicitlySet

          boolean nameExplicitlySet
          A bool to determine whether the name has been set explicitly. nameExplicitlySet will be false if the name has not been set and true if it has.
          See Also:
          Component.getName(), Component.setName(String)

        • focusable

          boolean focusable
          Indicates whether this Component can be focused.
          Since:
          1.4
          See Also:
          Component.setFocusable(boolean), Component.isFocusable()

        • isFocusTraversableOverridden

          int isFocusTraversableOverridden
          Tracks whether this Component is relying on default focus travesability.
          Since:
          1.4

        • focusTraversalKeys

          Set<E>[] focusTraversalKeys
          The focus traversal keys. These keys will generate focus traversal behavior for Components for which focus traversal keys are enabled. If a value of null is specified for a traversal key, this Component inherits that traversal key from its parent. If all ancestors of this Component have null specified for that traversal key, then the current KeyboardFocusManager's default traversal key is used.
          Since:
          1.4
          See Also:
          Component.setFocusTraversalKeys(int, java.util.Set<? extends java.awt.AWTKeyStroke>), Component.getFocusTraversalKeys(int)

        • focusTraversalKeysEnabled

          boolean focusTraversalKeysEnabled
          Indicates whether focus traversal keys are enabled for this Component. Components for which focus traversal keys are disabled receive key events for focus traversal keys. Components for which focus traversal keys are enabled do not see these events; instead, the events are automatically converted to traversal operations.
          Since:
          1.4
          See Also:
          Component.setFocusTraversalKeysEnabled(boolean), Component.getFocusTraversalKeysEnabled()

        • minSize

          Dimension minSize
          Minimum size. (This field perhaps should have been transient).

        • minSizeSet

          boolean minSizeSet
          Whether or not setMinimumSize has been invoked with a non-null value.

        • prefSize

          Dimension prefSize
          Preferred size. (This field perhaps should have been transient).

        • prefSizeSet

          boolean prefSizeSet
          Whether or not setPreferredSize has been invoked with a non-null value.

        • maxSize

          Dimension maxSize
          Maximum size

        • maxSizeSet

          boolean maxSizeSet
          Whether or not setMaximumSize has been invoked with a non-null value.

        • newEventsOnly

          boolean newEventsOnly
          newEventsOnly will be true if the event is one of the event types enabled for the component. It will then allow for normal processing to continue. If it is false the event is passed to the component's parent and up the ancestor tree until the event has been consumed.
          See Also:
          Component.dispatchEvent(java.awt.AWTEvent)

        • eventMask

          long eventMask
          The eventMask is ONLY set by subclasses via enableEvents. The mask should NOT be set when listeners are registered so that we can distinguish the difference between when listeners request events and subclasses request them. One bit is used to indicate whether input methods are enabled; this bit is set by enableInputMethods and is on by default.
          See Also:
          Component.enableInputMethods(boolean), AWTEvent

        • changeSupport

          PropertyChangeSupport changeSupport
          If any PropertyChangeListeners have been registered, the changeSupport field describes them.
          Since:
          1.2
          See Also:
          Component.addPropertyChangeListener(java.beans.PropertyChangeListener),
Component.removePropertyChangeListener(java.beans.PropertyChangeListener),
Component.firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

        • isPacked

          boolean isPacked

        • boundsOp

          int boundsOp
          Pseudoparameter for direct Geometry API (setLocation, setBounds setSize to signal setBounds what's changing. Should be used under TreeLock. This is only needed due to the inability to change the cross-calling order of public and deprecated methods.

        • autoFocusTransferOnDisposal

          boolean autoFocusTransferOnDisposal

        • componentSerializedDataVersion

          int componentSerializedDataVersion
          Component Serialized Data Version.

        • accessibleContext

          AccessibleContext accessibleContext
          The AccessibleContext associated with this Component.

    • Class java.awt.Component.AccessibleAWTComponent extends AccessibleContext implements Serializable

      serialVersionUID:
      642321655757800191L

      • Serialized Fields

        • accessibleAWTComponentHandler

          ComponentListener accessibleAWTComponentHandler

        • accessibleAWTFocusHandler

          FocusListener accessibleAWTFocusHandler

    • Class java.awt.ComponentOrientation extends Object implements Serializable

      serialVersionUID:
      -4113291392143563828L

      • Serialized Fields

        • orientation

          int orientation

    • Class java.awt.Container extends Component implements Serializable

      serialVersionUID:
      4613797578919906343L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
          Deserializes this Container from the specified ObjectInputStream.
          • Reads default serializable fields from the stream.
          • Reads a list of serializable ContainerListener(s) as optional data. If the list is null, no Listeners are installed.
          • Reads this Container's FocusTraversalPolicy, which may be null, as optional data.
          Throws:
          ClassNotFoundException
          IOException
          See Also:
          Container.addContainerListener(java.awt.event.ContainerListener), Container.writeObject(ObjectOutputStream)

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Serializes this Container to the specified ObjectOutputStream.
          • Writes default serializable fields to the stream.
          • Writes a list of serializable ContainerListener(s) as optional data. The non-serializable ContainerListner(s) are detected and no attempt is made to serialize them.
          • Write this Container's FocusTraversalPolicy if and only if it is Serializable; otherwise, null is written.
          Serial Data:
          null terminated sequence of 0 or more pairs; the pair consists of a String and Object; the String indicates the type of object and is one of the following: containerListenerK indicating an ContainerListener object; the Container's FocusTraversalPolicy, or null
          Throws:
          IOException
          See Also:
          AWTEventMulticaster.save(java.io.ObjectOutputStream, java.lang.String, java.util.EventListener), Component.containerListenerK, Container.readObject(ObjectInputStream)

      • Serialized Fields

        • component

          Component[] component
          The components in this container.

        • containerSerializedDataVersion

          int containerSerializedDataVersion
          Container Serial Data Version.

        • dispatcher

          java.awt.LightweightDispatcher dispatcher
          Event router for lightweight components. If this container is native, this dispatcher takes care of forwarding and retargeting the events to lightweight components contained (if any).

        • focusCycleRoot

          boolean focusCycleRoot
          Indicates whether this Component is the root of a focus traversal cycle. Once focus enters a traversal cycle, typically it cannot leave it via focus traversal unless one of the up- or down-cycle keys is pressed. Normal traversal is limited to this Container, and all of this Container's descendants that are not descendants of inferior focus cycle roots.

        • focusTraversalPolicyProvider

          boolean focusTraversalPolicyProvider
          Stores the value of focusTraversalPolicyProvider property.

        • layoutMgr

          LayoutManager layoutMgr
          Layout manager for this container.

        • maxSize

          Dimension maxSize
          Maximum size of this Container.

        • ncomponents

          int ncomponents
          The number of components in this container. This value can be null.

    • Class java.awt.Container.AccessibleAWTContainer extends Component.AccessibleAWTComponent implements Serializable

      serialVersionUID:
      5081320404842566097L

      • Serialized Fields

        • accessibleContainerHandler

          ContainerListener accessibleContainerHandler

    • Class java.awt.ContainerOrderFocusTraversalPolicy extends FocusTraversalPolicy implements Serializable

      serialVersionUID:
      486933713763926351L

      • Serialized Fields

        • FORWARD_TRAVERSAL

          int FORWARD_TRAVERSAL

        • BACKWARD_TRAVERSAL

          int BACKWARD_TRAVERSAL

        • implicitDownCycleTraversal

          boolean implicitDownCycleTraversal

    • Class java.awt.Cursor extends Object implements Serializable

      serialVersionUID:
      8028237497568985504L

      • Serialized Fields

        • type

          int type
          The chosen cursor type initially set to the DEFAULT_CURSOR.
          See Also:
          Cursor.getType()

        • name

          String name
          The user-visible name of the cursor.
          See Also:
          Cursor.getName()

    • Class java.awt.DefaultFocusTraversalPolicy extends ContainerOrderFocusTraversalPolicy implements Serializable

      serialVersionUID:
      8876966522510157497L

    • Class java.awt.Dialog extends Window implements Serializable

      serialVersionUID:
      5920926903803293709L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
          Throws:
          ClassNotFoundException
          IOException
          HeadlessException

      • Serialized Fields

        • resizable

          boolean resizable
          A dialog's resizable property. Will be true if the Dialog is to be resizable, otherwise it will be false.
          See Also:
          Dialog.setResizable(boolean)

        • undecorated

          boolean undecorated
          This field indicates whether the dialog is undecorated. This property can only be changed while the dialog is not displayable. undecorated will be true if the dialog is undecorated, otherwise it will be false.
          Since:
          1.4
          See Also:
          Dialog.setUndecorated(boolean),
Dialog.isUndecorated(),
Component.isDisplayable()

        • modal

          boolean modal
          True if this dialog is modal, false is the dialog is modeless. A modal dialog blocks user input to some application top-level windows. This field is kept only for backwards compatibility. Use the ModalityType enum instead.
          See Also:
          Dialog.isModal(), Dialog.setModal(boolean), Dialog.getModalityType(), Dialog.setModalityType(java.awt.Dialog.ModalityType), Dialog.ModalityType, Dialog.ModalityType.MODELESS, Dialog.DEFAULT_MODALITY_TYPE

        • modalityType

          Dialog.ModalityType modalityType
          Modality type of this dialog. If the dialog's modality type is not ModalityType.MODELESS, it blocks all user input to some application top-level windows.
          Since:
          1.6
          See Also:
          Dialog.ModalityType, Dialog.getModalityType(), Dialog.setModalityType(java.awt.Dialog.ModalityType)

        • title

          String title
          Specifies the title of the Dialog. This field can be null.
          See Also:
          Dialog.getTitle(), Dialog.setTitle(String)

    • Class java.awt.Dialog.AccessibleAWTDialog extends Window.AccessibleAWTWindow implements Serializable

      serialVersionUID:
      4837230331833941201L

    • Class java.awt.Dimension extends Dimension2D implements Serializable

      serialVersionUID:
      4723952579491349524L

      • Serialized Fields

        • width

          int width
          The width dimension; negative values can be used.
          Since:
          1.0
          See Also:
          Dimension.getSize(), Dimension.setSize(double, double)

        • height

          int height
          The height dimension; negative values can be used.
          Since:
          1.0
          See Also:
          Dimension.getSize(), Dimension.setSize(double, double)

    • Class java.awt.Event extends Object implements Serializable

      serialVersionUID:
      5488922509400504703L

      • Serialized Fields

        • target

          Object target
          The target component. This indicates the component over which the event occurred or with which the event is associated. This object has been replaced by AWTEvent.getSource()
          See Also:
          EventObject.getSource()

        • when

          long when
          The time stamp. Replaced by InputEvent.getWhen().
          See Also:
          InputEvent.getWhen()

        • id

          int id
          Indicates which type of event the event is, and which other Event variables are relevant for the event. This has been replaced by AWTEvent.getID()
          See Also:
          AWTEvent.getID()

        • x

          int x
          The x coordinate of the event. Replaced by MouseEvent.getX()
          See Also:
          MouseEvent.getX()

        • y

          int y
          The y coordinate of the event. Replaced by MouseEvent.getY()
          See Also:
          MouseEvent.getY()

        • key

          int key
          The key code of the key that was pressed in a keyboard event. This has been replaced by KeyEvent.getKeyCode()
          See Also:
          KeyEvent.getKeyCode()

        • modifiers

          int modifiers
          The state of the modifier keys. This is replaced with InputEvent.getModifiers() In java 1.1 MouseEvent and KeyEvent are subclasses of InputEvent.
          See Also:
          InputEvent.getModifiers()

        • clickCount

          int clickCount
          For MOUSE_DOWN events, this field indicates the number of consecutive clicks. For other events, its value is 0. This field has been replaced by MouseEvent.getClickCount().
          See Also:
          MouseEvent.getClickCount()

        • arg

          Object arg
          An arbitrary argument of the event. The value of this field depends on the type of event. arg has been replaced by event specific property.

        • evt

          Event evt
          The next event. This field is set when putting events into a linked list. This has been replaced by EventQueue.
          See Also:
          EventQueue

        • consumed

          boolean consumed
          This field controls whether or not the event is sent back down to the peer once the target has processed it - false means it's sent to the peer, true means it's not.
          See Also:
          Event.isConsumed()

    • Class java.awt.FileDialog extends Dialog implements Serializable

      serialVersionUID:
      5035145889651310422L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
          Reads the ObjectInputStream and performs a backwards compatibility check by converting either a dir or a file equal to an empty string to null.
          Throws:
          ClassNotFoundException
          IOException

      • Serialized Fields

        • mode

          int mode

        • dir

          String dir

        • file

          String file

        • files

          File[] files
          Contains the File instances for all the files that the user selects.
          Since:
          1.7
          See Also:
          FileDialog.getFiles()

        • multipleMode

          boolean multipleMode
          Represents whether the file dialog allows the multiple file selection.
          Since:
          1.7
          See Also:
          FileDialog.setMultipleMode(boolean), FileDialog.isMultipleMode()

        • filter

          FilenameFilter filter

    • Class java.awt.FlowLayout extends Object implements Serializable

      serialVersionUID:
      -7262534875583282631L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream stream)
                 throws IOException,
                        ClassNotFoundException
          Reads this object out of a serialization stream, handling objects written by older versions of the class that didn't contain all of the fields we use now..
          Throws:
          IOException
          ClassNotFoundException

      • Serialized Fields

        • align

          int align
          align is the property that determines how each row distributes empty space. It can be one of the following values:
          • LEFT
          • RIGHT
          • CENTER
          See Also:
          FlowLayout.getAlignment(), FlowLayout.setAlignment(int)

        • newAlign

          int newAlign
          newAlign is the property that determines how each row distributes empty space for the Java 2 platform, v1.2 and greater. It can be one of the following three values:
          • LEFT
          • RIGHT
          • CENTER
          • LEADING
          • TRAILING
          Since:
          1.2
          See Also:
          FlowLayout.getAlignment(), FlowLayout.setAlignment(int)

        • hgap

          int hgap
          The flow layout manager allows a seperation of components with gaps. The horizontal gap will specify the space between components and between the components and the borders of the Container.
          See Also:
          FlowLayout.getHgap(), FlowLayout.setHgap(int)

        • vgap

          int vgap
          The flow layout manager allows a seperation of components with gaps. The vertical gap will specify the space between rows and between the the rows and the borders of the Container.
          See Also:
          FlowLayout.getHgap(), FlowLayout.setHgap(int)

        • alignOnBaseline

          boolean alignOnBaseline
          If true, components will be aligned on their baseline.

        • serialVersionOnStream

          int serialVersionOnStream
          This represent the currentSerialVersion which is bein used. It will be one of two values : 0 versions before Java 2 platform v1.2.. 1 versions after Java 2 platform v1.2..
          Since:
          1.2

    • Class java.awt.Font extends Object implements Serializable

      serialVersionUID:
      -4206021311591459213L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
          Reads the ObjectInputStream. Unrecognized keys or values will be ignored.
          Throws:
          ClassNotFoundException
          IOException
          See Also:
          Font.writeObject(java.io.ObjectOutputStream)

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws ClassNotFoundException,
                         IOException
          Writes default serializable fields to a stream.
          Throws:
          ClassNotFoundException
          IOException
          See Also:
          AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Font.readObject(java.io.ObjectInputStream)

      • Serialized Fields

        • fRequestedAttributes

          Hashtable<K,V> fRequestedAttributes
          This is now only used during serialization. Typically it is null.
          See Also:
          Font.getAttributes()

        • name

          String name
          The logical name of this Font, as passed to the constructor.
          Since:
          JDK1.0
          See Also:
          Font.getName()

        • style

          int style
          The style of this Font, as passed to the constructor. This style can be PLAIN, BOLD, ITALIC, or BOLD+ITALIC.
          Since:
          JDK1.0
          See Also:
          Font.getStyle()

        • size

          int size
          The point size of this Font, rounded to integer.
          Since:
          JDK1.0
          See Also:
          Font.getSize()

        • pointSize

          float pointSize
          The point size of this Font in float.
          See Also:
          Font.getSize(), Font.getSize2D()

        • fontSerializedDataVersion

          int fontSerializedDataVersion
          The Font Serializable Data Form.

    • Class java.awt.FontFormatException extends Exception implements Serializable

      serialVersionUID:
      -4481290147811361272L

    • Class java.awt.FontMetrics extends Object implements Serializable

      serialVersionUID:
      1681126225205050147L

      • Serialized Fields

        • font

          Font font
          The actual Font from which the font metrics are created. This cannot be null.
          See Also:
          FontMetrics.getFont()

    • Class java.awt.Frame extends Window implements Serializable

      serialVersionUID:
      2673458971256075116L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
          Reads the ObjectInputStream. Tries to read an icon Image, which is optional data available as of 1.4. If an icon Image is not available, but anything other than an EOF is detected, an OptionalDataException will be thrown. Unrecognized keys or values will be ignored.
          Throws:
          OptionalDataException - if an icon Image is not available, but anything other than an EOF is detected
          HeadlessException - if GraphicsEnvironment.isHeadless returns true
          ClassNotFoundException
          IOException
          See Also:
          GraphicsEnvironment.isHeadless(),
Image,
Frame.getIconImage(),
Frame.setIconImage(Image),
Frame.writeObject(ObjectOutputStream)

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Writes default serializable fields to stream. Writes an optional serializable icon Image, which is available as of 1.4.
          Serial Data:
          an optional icon Image
          Throws:
          IOException
          See Also:
          Image,
Frame.getIconImage(),
Frame.setIconImage(Image),
Frame.readObject(ObjectInputStream)

      • Serialized Fields

        • maximizedBounds

          Rectangle maximizedBounds
          Maximized bounds for this frame.
          Since:
          1.4
          See Also:
          Frame.setMaximizedBounds(Rectangle), Frame.getMaximizedBounds()

        • title

          String title
          This is the title of the frame. It can be changed at any time. title can be null and if this is the case the title = "".
          See Also:
          Frame.getTitle(), Frame.setTitle(String)

        • menuBar

          MenuBar menuBar
          The frames menubar. If menuBar = null the frame will not have a menubar.
          See Also:
          Frame.getMenuBar(), Frame.setMenuBar(MenuBar)

        • resizable

          boolean resizable
          This field indicates whether the frame is resizable. This property can be changed at any time. resizable will be true if the frame is resizable, otherwise it will be false.
          See Also:
          Frame.isResizable()

        • undecorated

          boolean undecorated
          This field indicates whether the frame is undecorated. This property can only be changed while the frame is not displayable. undecorated will be true if the frame is undecorated, otherwise it will be false.
          Since:
          1.4
          See Also:
          Frame.setUndecorated(boolean),
Frame.isUndecorated(),
Component.isDisplayable()

        • mbManagement

          boolean mbManagement
          mbManagement is only used by the Motif implementation.

        • state

          int state

        • ownedWindows

          Vector<E> ownedWindows

        • frameSerializedDataVersion

          int frameSerializedDataVersion
          Frame's Serialized Data Version.

    • Class java.awt.Frame.AccessibleAWTFrame extends Window.AccessibleAWTWindow implements Serializable

      serialVersionUID:
      -6172960752956030250L

    • Class java.awt.GraphicsConfigTemplate extends Object implements Serializable

      serialVersionUID:
      -8061369279557787079L

    • Class java.awt.GridBagConstraints extends Object implements Serializable

      serialVersionUID:
      -1000070633030801713L

      • Serialized Fields

        • gridx

          int gridx
          Specifies the cell containing the leading edge of the component's display area, where the first cell in a row has gridx=0. The leading edge of a component's display area is its left edge for a horizontal, left-to-right container and its right edge for a horizontal, right-to-left container. The value RELATIVE specifies that the component be placed immediately following the component that was added to the container just before this component was added.

          The default value is RELATIVE. gridx should be a non-negative value.

          See Also:
          GridBagConstraints.clone(), GridBagConstraints.gridy, ComponentOrientation

        • gridy

          int gridy
          Specifies the cell at the top of the component's display area, where the topmost cell has gridy=0. The value RELATIVE specifies that the component be placed just below the component that was added to the container just before this component was added.

          The default value is RELATIVE. gridy should be a non-negative value.

          See Also:
          GridBagConstraints.clone(), GridBagConstraints.gridx

        • gridwidth

          int gridwidth
          Specifies the number of cells in a row for the component's display area.

          Use REMAINDER to specify that the component's display area will be from gridx to the last cell in the row. Use RELATIVE to specify that the component's display area will be from gridx to the next to the last one in its row.

          gridwidth should be non-negative and the default value is 1.

          See Also:
          GridBagConstraints.clone(), GridBagConstraints.gridheight

        • gridheight

          int gridheight
          Specifies the number of cells in a column for the component's display area.

          Use REMAINDER to specify that the component's display area will be from gridy to the last cell in the column. Use RELATIVE to specify that the component's display area will be from gridy to the next to the last one in its column.

          gridheight should be a non-negative value and the default value is 1.

          See Also:
          GridBagConstraints.clone(), GridBagConstraints.gridwidth

        • weightx

          double weightx
          Specifies how to distribute extra horizontal space.

          The grid bag layout manager calculates the weight of a column to be the maximum weightx of all the components in a column. If the resulting layout is smaller horizontally than the area it needs to fill, the extra space is distributed to each column in proportion to its weight. A column that has a weight of zero receives no extra space.

          If all the weights are zero, all the extra space appears between the grids of the cell and the left and right edges.

          The default value of this field is 0. weightx should be a non-negative value.

          See Also:
          GridBagConstraints.clone(), GridBagConstraints.weighty

        • weighty

          double weighty
          Specifies how to distribute extra vertical space.

          The grid bag layout manager calculates the weight of a row to be the maximum weighty of all the components in a row. If the resulting layout is smaller vertically than the area it needs to fill, the extra space is distributed to each row in proportion to its weight. A row that has a weight of zero receives no extra space.

          If all the weights are zero, all the extra space appears between the grids of the cell and the top and bottom edges.

          The default value of this field is 0. weighty should be a non-negative value.

          See Also:
          GridBagConstraints.clone(), GridBagConstraints.weightx

        • anchor

          int anchor
          This field is used when the component is smaller than its display area. It determines where, within the display area, to place the component.

          There are three kinds of possible values: orientation relative, baseline relative and absolute. Orientation relative values are interpreted relative to the container's component orientation property, baseline relative values are interpreted relative to the baseline and absolute values are not. The absolute values are: CENTER, NORTH, NORTHEAST, EAST, SOUTHEAST, SOUTH, SOUTHWEST, WEST, and NORTHWEST. The orientation relative values are: PAGE_START, PAGE_END, LINE_START, LINE_END, FIRST_LINE_START, FIRST_LINE_END, LAST_LINE_START and LAST_LINE_END. The baseline relative values are: BASELINE, BASELINE_LEADING, BASELINE_TRAILING, ABOVE_BASELINE, ABOVE_BASELINE_LEADING, ABOVE_BASELINE_TRAILING, BELOW_BASELINE, BELOW_BASELINE_LEADING, and BELOW_BASELINE_TRAILING. The default value is CENTER.

          See Also:
          GridBagConstraints.clone(), ComponentOrientation

        • fill

          int fill
          This field is used when the component's display area is larger than the component's requested size. It determines whether to resize the component, and if so, how.

          The following values are valid for fill:

          • NONE: Do not resize the component.
          • HORIZONTAL: Make the component wide enough to fill its display area horizontally, but do not change its height.
          • VERTICAL: Make the component tall enough to fill its display area vertically, but do not change its width.
          • BOTH: Make the component fill its display area entirely.

          The default value is NONE.

          See Also:
          GridBagConstraints.clone()

        • insets

          Insets insets
          This field specifies the external padding of the component, the minimum amount of space between the component and the edges of its display area.

          The default value is new Insets(0, 0, 0, 0).

          See Also:
          GridBagConstraints.clone()

        • ipadx

          int ipadx
          This field specifies the internal padding of the component, how much space to add to the minimum width of the component. The width of the component is at least its minimum width plus ipadx pixels.

          The default value is 0.

          See Also:
          GridBagConstraints.clone(), GridBagConstraints.ipady

        • ipady

          int ipady
          This field specifies the internal padding, that is, how much space to add to the minimum height of the component. The height of the component is at least its minimum height plus ipady pixels.

          The default value is 0.

          See Also:
          GridBagConstraints.clone(), GridBagConstraints.ipadx

        • tempX

          int tempX
          Temporary place holder for the x coordinate.

        • tempY

          int tempY
          Temporary place holder for the y coordinate.

        • tempWidth

          int tempWidth
          Temporary place holder for the Width of the component.

        • tempHeight

          int tempHeight
          Temporary place holder for the Height of the component.

        • minWidth

          int minWidth
          The minimum width of the component. It is used to calculate ipady, where the default will be 0.
          See Also:
          GridBagConstraints.ipady

        • minHeight

          int minHeight
          The minimum height of the component. It is used to calculate ipadx, where the default will be 0.
          See Also:
          GridBagConstraints.ipadx

    • Class java.awt.GridBagLayout extends Object implements Serializable

      serialVersionUID:
      8838754796412211005L

      • Serialized Fields

        • comptable

          Hashtable<K,V> comptable
          This hashtable maintains the association between a component and its gridbag constraints. The Keys in comptable are the components and the values are the instances of GridBagConstraints.
          See Also:
          GridBagConstraints

        • defaultConstraints

          GridBagConstraints defaultConstraints
          This field holds a gridbag constraints instance containing the default values, so if a component does not have gridbag constraints associated with it, then the component will be assigned a copy of the defaultConstraints.
          See Also:
          GridBagLayout.getConstraints(Component),
GridBagLayout.setConstraints(Component, GridBagConstraints),
GridBagLayout.lookupConstraints(Component)

        • layoutInfo

          GridBagLayoutInfo layoutInfo
          This field holds the layout information for the gridbag. The information in this field is based on the most recent validation of the gridbag. If layoutInfo is null this indicates that there are no components in the gridbag or if there are components, they have not yet been validated.
          See Also:
          GridBagLayout.getLayoutInfo(Container, int)

        • columnWidths

          int[] columnWidths
          This field holds the overrides to the column minimum width. If this field is non-null the values are applied to the gridbag after all of the minimum columns widths have been calculated. If columnWidths has more elements than the number of columns, columns are added to the gridbag to match the number of elements in columnWidth.
          See Also:
          GridBagLayout.getLayoutDimensions()

        • rowHeights

          int[] rowHeights
          This field holds the overrides to the row minimum heights. If this field is non-null the values are applied to the gridbag after all of the minimum row heights have been calculated. If rowHeights has more elements than the number of rows, rows are added to the gridbag to match the number of elements in rowHeights.
          See Also:
          GridBagLayout.getLayoutDimensions()

        • columnWeights

          double[] columnWeights
          This field holds the overrides to the column weights. If this field is non-null the values are applied to the gridbag after all of the columns weights have been calculated. If columnWeights[i] > weight for column i, then column i is assigned the weight in columnWeights[i]. If columnWeights has more elements than the number of columns, the excess elements are ignored - they do not cause more columns to be created.

        • rowWeights

          double[] rowWeights
          This field holds the overrides to the row weights. If this field is non-null the values are applied to the gridbag after all of the rows weights have been calculated. If rowWeights[i] > weight for row i, then row i is assigned the weight in rowWeights[i]. If rowWeights has more elements than the number of rows, the excess elements are ignored - they do not cause more rows to be created.

        • componentAdjusting

          Component componentAdjusting
          The component being positioned. This is set before calling into adjustForGravity.

    • Class java.awt.GridBagLayoutInfo extends Object implements Serializable

      serialVersionUID:
      -4899416460737170217L

      • Serialized Fields

        • width

          int width

        • height

          int height

        • startx

          int startx

        • starty

          int starty

        • minWidth

          int[] minWidth

        • minHeight

          int[] minHeight

        • weightX

          double[] weightX

        • weightY

          double[] weightY

        • hasBaseline

          boolean hasBaseline

        • baselineType

          short[] baselineType

        • maxAscent

          int[] maxAscent

        • maxDescent

          int[] maxDescent

    • Class java.awt.GridLayout extends Object implements Serializable

      serialVersionUID:
      -7411804673224730901L

      • Serialized Fields

        • hgap

          int hgap
          This is the horizontal gap (in pixels) which specifies the space between columns. They can be changed at any time. This should be a non-negative integer.
          See Also:
          GridLayout.getHgap(), GridLayout.setHgap(int)

        • vgap

          int vgap
          This is the vertical gap (in pixels) which specifies the space between rows. They can be changed at any time. This should be a non negative integer.
          See Also:
          GridLayout.getVgap(), GridLayout.setVgap(int)

        • rows

          int rows
          This is the number of rows specified for the grid. The number of rows can be changed at any time. This should be a non negative integer, where '0' means 'any number' meaning that the number of Rows in that dimension depends on the other dimension.
          See Also:
          GridLayout.getRows(), GridLayout.setRows(int)

        • cols

          int cols
          This is the number of columns specified for the grid. The number of columns can be changed at any time. This should be a non negative integer, where '0' means 'any number' meaning that the number of Columns in that dimension depends on the other dimension.
          See Also:
          GridLayout.getColumns(), GridLayout.setColumns(int)

    • Class java.awt.HeadlessException extends UnsupportedOperationException implements Serializable

      serialVersionUID:
      167183644944358563L

    • Class java.awt.IllegalComponentStateException extends IllegalStateException implements Serializable

      serialVersionUID:
      -1889339587208144238L

    • Class java.awt.Insets extends Object implements Serializable

      serialVersionUID:
      -2272572637695466749L

      • Serialized Fields

        • top

          int top
          The inset from the top. This value is added to the Top of the rectangle to yield a new location for the Top.
          See Also:
          Insets.clone()

        • left

          int left
          The inset from the left. This value is added to the Left of the rectangle to yield a new location for the Left edge.
          See Also:
          Insets.clone()

        • bottom

          int bottom
          The inset from the bottom. This value is subtracted from the Bottom of the rectangle to yield a new location for the Bottom.
          See Also:
          Insets.clone()

        • right

          int right
          The inset from the right. This value is subtracted from the Right of the rectangle to yield a new location for the Right edge.
          See Also:
          Insets.clone()

    • Class java.awt.Label extends Component implements Serializable

      serialVersionUID:
      3094126758329070636L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
          Read a label from an object input stream.
          Throws:
          HeadlessException - if GraphicsEnvironment.isHeadless() returns true
          ClassNotFoundException
          IOException
          Since:
          1.4
          See Also:
          GraphicsEnvironment.isHeadless()

      • Serialized Fields

        • text

          String text
          The text of this label. This text can be modified by the program but never by the user.
          See Also:
          Label.getText(), Label.setText(String)

        • alignment

          int alignment
          The label's alignment. The default alignment is set to be left justified.
          See Also:
          Label.getAlignment(), Label.setAlignment(int)

    • Class java.awt.Label.AccessibleAWTLabel extends Component.AccessibleAWTComponent implements Serializable

      serialVersionUID:
      -3568967560160480438L

    • Class java.awt.List extends Component implements Serializable

      serialVersionUID:
      -3304312411574666869L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
          Reads the ObjectInputStream and if it isn't null adds a listener to receive both item events and action events (as specified by the key stored in the stream) fired by the List. Unrecognized keys or values will be ignored.
          Throws:
          HeadlessException - if GraphicsEnvironment.isHeadless returns true
          ClassNotFoundException
          IOException
          See Also:
          List.removeItemListener(ItemListener),
List.addItemListener(ItemListener),
GraphicsEnvironment.isHeadless(),
List.writeObject(ObjectOutputStream)

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Writes default serializable fields to stream. Writes a list of serializable ItemListeners and ActionListeners as optional data. The non-serializable listeners are detected and no attempt is made to serialize them.
          Serial Data:
          null terminated sequence of 0 or more pairs; the pair consists of a String and an Object; the String indicates the type of object and is one of the following: itemListenerK indicating an ItemListener object; actionListenerK indicating an ActionListener object
          Throws:
          IOException
          See Also:
          AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Component.itemListenerK, Component.actionListenerK, List.readObject(ObjectInputStream)

      • Serialized Fields

        • items

          Vector<E> items
          A vector created to contain items which will become part of the List Component.
          See Also:
          List.addItem(String), List.getItem(int)

        • rows

          int rows
          This field will represent the number of visible rows in the List Component. It is specified only once, and that is when the list component is actually created. It will never change.
          See Also:
          List.getRows()

        • multipleMode

          boolean multipleMode
          multipleMode is a variable that will be set to true if a list component is to be set to multiple selection mode, that is where the user can select more than one item in a list at one time. multipleMode will be set to false if the list component is set to single selection, that is where the user can only select one item on the list at any one time.
          See Also:
          List.isMultipleMode(), List.setMultipleMode(boolean)

        • selected

          int[] selected
          selected is an array that will contain the indices of items that have been selected.
          See Also:
          List.getSelectedIndexes(), List.getSelectedIndex()

        • visibleIndex

          int visibleIndex
          This variable contains the value that will be used when trying to make a particular list item visible.
          See Also:
          List.makeVisible(int)

        • listSerializedDataVersion

          int listSerializedDataVersion
          The List component's Serialized Data Version.

    • Class java.awt.List.AccessibleAWTList extends Component.AccessibleAWTComponent implements Serializable

      serialVersionUID:
      7924617370136012829L

    • Class java.awt.List.AccessibleAWTList.AccessibleAWTListChild extends Component.AccessibleAWTComponent implements Serializable

      serialVersionUID:
      4412022926028300317L

      • Serialized Fields

        • parent

          List parent

        • indexInParent

          int indexInParent

    • Class java.awt.MediaTracker extends Object implements Serializable

      serialVersionUID:
      -483174189758638095L

      • Serialized Fields

        • target

          Component target
          A given Component that will be tracked by a media tracker where the image will eventually be drawn.
          See Also:
          MediaTracker.MediaTracker(Component)

        • head

          java.awt.MediaEntry head
          The head of the list of Images that is being tracked by the MediaTracker.
          See Also:
          MediaTracker.addImage(Image, int), MediaTracker.removeImage(Image)

    • Class java.awt.Menu extends MenuItem implements Serializable

      serialVersionUID:
      -8809584163345499784L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException,
                        HeadlessException
          Reads the ObjectInputStream. Unrecognized keys or values will be ignored.
          Throws:
          HeadlessException - if GraphicsEnvironment.isHeadless returns true
          IOException
          ClassNotFoundException
          See Also:
          GraphicsEnvironment.isHeadless(), Menu.writeObject(ObjectOutputStream)

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Writes default serializable fields to stream.
          Throws:
          IOException
          See Also:
          AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Menu.readObject(ObjectInputStream)

      • Serialized Fields

        • items

          Vector<E> items
          A vector of the items that will be part of the Menu.
          See Also:
          Menu.countItems()

        • tearOff

          boolean tearOff
          This field indicates whether the menu has the tear of property or not. It will be set to true if the menu has the tear off property and it will be set to false if it does not. A torn off menu can be deleted by a user when it is no longer needed.
          See Also:
          Menu.isTearOff()

        • isHelpMenu

          boolean isHelpMenu
          This field will be set to true if the Menu in question is actually a help menu. Otherwise it will be set to false.

        • menuSerializedDataVersion

          int menuSerializedDataVersion
          The menu serialized Data Version.

    • Class java.awt.Menu.AccessibleAWTMenu extends MenuItem.AccessibleAWTMenuItem implements Serializable

      serialVersionUID:
      5228160894980069094L

    • Class java.awt.MenuBar extends MenuComponent implements Serializable

      serialVersionUID:
      -4930327919388951260L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
          Reads the ObjectInputStream. Unrecognized keys or values will be ignored.
          Throws:
          HeadlessException - if GraphicsEnvironment.isHeadless returns true
          ClassNotFoundException
          IOException
          See Also:
          GraphicsEnvironment.isHeadless(), MenuBar.writeObject(java.io.ObjectOutputStream)

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws ClassNotFoundException,
                         IOException
          Writes default serializable fields to stream.
          Throws:
          ClassNotFoundException
          IOException
          See Also:
          AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), MenuBar.readObject(java.io.ObjectInputStream)

      • Serialized Fields

        • menus

          Vector<E> menus
          This field represents a vector of the actual menus that will be part of the MenuBar.
          See Also:
          MenuBar.countMenus()

        • helpMenu

          Menu helpMenu
          This menu is a special menu dedicated to help. The one thing to note about this menu is that on some platforms it appears at the right edge of the menubar.
          See Also:
          MenuBar.getHelpMenu(), MenuBar.setHelpMenu(Menu)

        • menuBarSerializedDataVersion

          int menuBarSerializedDataVersion
          The MenuBar's serialized data version.

    • Class java.awt.MenuBar.AccessibleAWTMenuBar extends MenuComponent.AccessibleAWTMenuComponent implements Serializable

      serialVersionUID:
      -8577604491830083815L

    • Class java.awt.MenuComponent extends Object implements Serializable

      serialVersionUID:
      -4536902356223894379L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
          Reads the menu component from an object input stream.
          Throws:
          HeadlessException - if GraphicsEnvironment.isHeadless returns true
          ClassNotFoundException
          IOException
          See Also:
          GraphicsEnvironment.isHeadless()

      • Serialized Fields

        • font

          Font font
          The menu component's font. This value can be null at which point a default will be used. This defaults to null.
          See Also:
          MenuComponent.setFont(Font), MenuComponent.getFont()

        • name

          String name
          The menu component's name, which defaults to null.
          See Also:
          MenuComponent.getName(), MenuComponent.setName(String)

        • nameExplicitlySet

          boolean nameExplicitlySet
          A variable to indicate whether a name is explicitly set. If true the name will be set explicitly. This defaults to false.
          See Also:
          MenuComponent.setName(String)

        • newEventsOnly

          boolean newEventsOnly
          Defaults to false.
          See Also:
          MenuComponent.dispatchEvent(AWTEvent)

        • accessibleContext

          AccessibleContext accessibleContext

    • Class java.awt.MenuComponent.AccessibleAWTMenuComponent extends AccessibleContext implements Serializable

      serialVersionUID:
      -4269533416223798698L

    • Class java.awt.MenuItem extends MenuComponent implements Serializable

      serialVersionUID:
      -21757335363267194L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
          Reads the ObjectInputStream and if it isn't null adds a listener to receive action events fired by the Menu Item. Unrecognized keys or values will be ignored.
          Throws:
          HeadlessException - if GraphicsEnvironment.isHeadless returns true
          ClassNotFoundException
          IOException
          See Also:
          MenuItem.removeActionListener(ActionListener),
MenuItem.addActionListener(ActionListener),
MenuItem.writeObject(ObjectOutputStream)

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Writes default serializable fields to stream. Writes a list of serializable ActionListeners as optional data. The non-serializable listeners are detected and no attempt is made to serialize them.
          Serial Data:
          null terminated sequence of 0 or more pairs; the pair consists of a String and an Object; the String indicates the type of object and is one of the following: actionListenerK indicating an ActionListener object
          Throws:
          IOException
          See Also:
          AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), MenuItem.readObject(ObjectInputStream)

      • Serialized Fields

        • enabled

          boolean enabled
          A value to indicate whether a menu item is enabled or not. If it is enabled, enabled will be set to true. Else enabled will be set to false.
          See Also:
          MenuItem.isEnabled(), MenuItem.setEnabled(boolean)

        • label

          String label
          label is the label of a menu item. It can be any string.
          See Also:
          MenuItem.getLabel(), MenuItem.setLabel(String)

        • actionCommand

          String actionCommand
          This field indicates the command tha has been issued by a particular menu item. By default the actionCommand is the label of the menu item, unless it has been set using setActionCommand.
          See Also:
          MenuItem.setActionCommand(String), MenuItem.getActionCommand()

        • eventMask

          long eventMask
          The eventMask is ONLY set by subclasses via enableEvents. The mask should NOT be set when listeners are registered so that we can distinguish the difference between when listeners request events and subclasses request them.

        • shortcut

          MenuShortcut shortcut
          A sequence of key stokes that ia associated with a menu item. Note :in 1.1.2 you must use setActionCommand() on a menu item in order for its shortcut to work.
          See Also:
          MenuItem.getShortcut(),
MenuItem.setShortcut(MenuShortcut),
MenuItem.deleteShortcut()

        • menuItemSerializedDataVersion

          int menuItemSerializedDataVersion
          Menu item serialized data version.

    • Class java.awt.MenuItem.AccessibleAWTMenuItem extends MenuComponent.AccessibleAWTMenuComponent implements Serializable

      serialVersionUID:
      -217847831945965825L

    • Class java.awt.MenuShortcut extends Object implements Serializable

      serialVersionUID:
      143448358473180225L

      • Serialized Fields

        • key

          int key
          The virtual keycode for the menu shortcut. This is the keycode with which the menu shortcut will be created. Note that it is a virtual keycode, not a character, e.g. KeyEvent.VK_A, not 'a'. Note: in 1.1.x you must use setActionCommand() on a menu item in order for its shortcut to work, otherwise it will fire a null action command.
          Since:
          JDK1.1
          See Also:
          MenuShortcut.getKey(), MenuShortcut.usesShiftModifier(), KeyEvent

        • usesShift

          boolean usesShift
          Indicates whether the shft key was pressed. If true, the shift key was pressed. If false, the shift key was not pressed
          Since:
          JDK1.1
          See Also:
          MenuShortcut.usesShiftModifier()

    • Class java.awt.Panel extends Container implements Serializable

      serialVersionUID:
      -2728009084054400034L

    • Class java.awt.Panel.AccessibleAWTPanel extends Container.AccessibleAWTContainer implements Serializable

      serialVersionUID:
      -6409552226660031050L

    • Class java.awt.Point extends Point2D implements Serializable

      serialVersionUID:
      -5276940640259749850L

      • Serialized Fields

        • x

          int x
          The X coordinate of this Point. If no X coordinate is set it will default to 0.
          Since:
          1.0
          See Also:
          Point.getLocation(), Point.move(int, int)

        • y

          int y
          The Y coordinate of this Point. If no Y coordinate is set it will default to 0.
          Since:
          1.0
          See Also:
          Point.getLocation(), Point.move(int, int)

    • Class java.awt.Polygon extends Object implements Serializable

      serialVersionUID:
      -6460061437900069969L

      • Serialized Fields

        • npoints

          int npoints
          The total number of points. The value of npoints represents the number of valid points in this Polygon and might be less than the number of elements in xpoints or ypoints. This value can be NULL.
          Since:
          1.0
          See Also:
          Polygon.addPoint(int, int)

        • xpoints

          int[] xpoints
          The array of X coordinates. The number of elements in this array might be more than the number of X coordinates in this Polygon. The extra elements allow new points to be added to this Polygon without re-creating this array. The value of npoints is equal to the number of valid points in this Polygon.
          Since:
          1.0
          See Also:
          Polygon.addPoint(int, int)

        • ypoints

          int[] ypoints
          The array of Y coordinates. The number of elements in this array might be more than the number of Y coordinates in this Polygon. The extra elements allow new points to be added to this Polygon without re-creating this array. The value of npoints is equal to the number of valid points in this Polygon.
          Since:
          1.0
          See Also:
          Polygon.addPoint(int, int)

        • bounds

          Rectangle bounds
          The bounds of this Polygon. This value can be null.
          Since:
          1.0
          See Also:
          Polygon.getBoundingBox(), Polygon.getBounds()

    • Class java.awt.PopupMenu extends Menu implements Serializable

      serialVersionUID:
      -4620452533522760060L

    • Class java.awt.PopupMenu.AccessibleAWTPopupMenu extends Menu.AccessibleAWTMenu implements Serializable

      serialVersionUID:
      -4282044795947239955L

    • Class java.awt.Rectangle extends Rectangle2D implements Serializable

      serialVersionUID:
      -4345857070255674764L

      • Serialized Fields

        • x

          int x
          The X coordinate of the upper-left corner of the Rectangle.
          Since:
          1.0
          See Also:
          Rectangle.setLocation(int, int), Rectangle.getLocation()

        • y

          int y
          The Y coordinate of the upper-left corner of the Rectangle.
          Since:
          1.0
          See Also:
          Rectangle.setLocation(int, int), Rectangle.getLocation()

        • width

          int width
          The width of the Rectangle.
          Since:
          1.0
          See Also:
          Rectangle.setSize(int, int), Rectangle.getSize()

        • height

          int height
          The height of the Rectangle.
          Since:
          1.0
          See Also:
          Rectangle.setSize(int, int), Rectangle.getSize()

    • Class java.awt.Scrollbar extends Component implements Serializable

      serialVersionUID:
      8451667562882310543L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
          Reads the ObjectInputStream and if it isn't null adds a listener to receive adjustment events fired by the Scrollbar. Unrecognized keys or values will be ignored.
          Throws:
          HeadlessException - if GraphicsEnvironment.isHeadless returns true
          ClassNotFoundException
          IOException
          See Also:
          GraphicsEnvironment.isHeadless(), Scrollbar.writeObject(ObjectOutputStream)

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Writes default serializable fields to stream. Writes a list of serializable AdjustmentListeners as optional data. The non-serializable listeners are detected and no attempt is made to serialize them.
          Serial Data:
          null terminated sequence of 0 or more pairs; the pair consists of a String and an Object; the String indicates the type of object and is one of the following: adjustmentListenerK indicating an AdjustmentListener object
          Throws:
          IOException
          See Also:
          AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Component.adjustmentListenerK, Scrollbar.readObject(ObjectInputStream)

      • Serialized Fields

        • value

          int value
          The value of the Scrollbar. This property must be greater than or equal to minimum and less than or equal to maximum - visibleAmount
          See Also:
          Scrollbar.getValue(), Scrollbar.setValue(int)

        • maximum

          int maximum
          The maximum value of the Scrollbar. This value must be greater than the minimum value.
          See Also:
          Scrollbar.getMaximum(), Scrollbar.setMaximum(int)

        • minimum

          int minimum
          The minimum value of the Scrollbar. This value must be less than the maximum value.
          See Also:
          Scrollbar.getMinimum(), Scrollbar.setMinimum(int)

        • visibleAmount

          int visibleAmount
          The size of the Scrollbar's bubble. When a scroll bar is used to select a range of values, the visibleAmount represents the size of this range. Depending on platform, this may be visually indicated by the size of the bubble.
          See Also:
          Scrollbar.getVisibleAmount(), Scrollbar.setVisibleAmount(int)

        • orientation

          int orientation
          The Scrollbar's orientation--being either horizontal or vertical. This value should be specified when the scrollbar is created.
          orientation can be either : VERTICAL or HORIZONTAL only.
          See Also:
          Scrollbar.getOrientation(), Scrollbar.setOrientation(int)

        • lineIncrement

          int lineIncrement
          The amount by which the scrollbar value will change when going up or down by a line. This value must be greater than zero.
          See Also:
          Scrollbar.getLineIncrement(), Scrollbar.setLineIncrement(int)

        • pageIncrement

          int pageIncrement
          The amount by which the scrollbar value will change when going up or down by a page. This value must be greater than zero.
          See Also:
          Scrollbar.getPageIncrement(), Scrollbar.setPageIncrement(int)

        • scrollbarSerializedDataVersion

          int scrollbarSerializedDataVersion
          The scroll bar's serialized Data Version.

    • Class java.awt.Scrollbar.AccessibleAWTScrollBar extends Component.AccessibleAWTComponent implements Serializable

      serialVersionUID:
      -344337268523697807L

    • Class java.awt.ScrollPane extends Container implements Serializable

      serialVersionUID:
      7956609840827222915L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
          Reads default serializable fields to stream.
          Throws:
          HeadlessException - if GraphicsEnvironment.isHeadless() returns true
          ClassNotFoundException
          IOException
          See Also:
          GraphicsEnvironment.isHeadless()

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Writes default serializable fields to stream.
          Throws:
          IOException

      • Serialized Fields

        • scrollbarDisplayPolicy

          int scrollbarDisplayPolicy
          There are 3 ways in which a scroll bar can be displayed. This integer will represent one of these 3 displays - (SCROLLBARS_ALWAYS, SCROLLBARS_AS_NEEDED, SCROLLBARS_NEVER)
          See Also:
          ScrollPane.getScrollbarDisplayPolicy()

        • vAdjustable

          ScrollPaneAdjustable vAdjustable
          An adjustable vertical scrollbar. It is important to note that you must NOT call 3 Adjustable methods, namely: setMinimum(), setMaximum(), setVisibleAmount().
          See Also:
          ScrollPane.getVAdjustable()

        • hAdjustable

          ScrollPaneAdjustable hAdjustable
          An adjustable horizontal scrollbar. It is important to note that you must NOT call 3 Adjustable methods, namely: setMinimum(), setMaximum(), setVisibleAmount().
          See Also:
          ScrollPane.getHAdjustable()

        • wheelScrollingEnabled

          boolean wheelScrollingEnabled
          Indicates whether or not scrolling should take place when a MouseWheelEvent is received.
          Since:
          1.4

    • Class java.awt.ScrollPane.AccessibleAWTScrollPane extends Container.AccessibleAWTContainer implements Serializable

      serialVersionUID:
      6100703663886637L

    • Class java.awt.ScrollPaneAdjustable extends Object implements Serializable

      serialVersionUID:
      -3359745691033257079L

      • Serialized Fields

        • sp

          ScrollPane sp
          The ScrollPane this object is a scrollbar of.

        • orientation

          int orientation
          Orientation of this scrollbar.
          See Also:
          ScrollPaneAdjustable.getOrientation(), Adjustable.HORIZONTAL, Adjustable.VERTICAL

        • value

          int value
          The value of this scrollbar. value should be greater than minimum and less than maximum
          See Also:
          ScrollPaneAdjustable.getValue(), ScrollPaneAdjustable.setValue(int)

        • minimum

          int minimum
          The minimum value of this scrollbar. This value can only be set by the ScrollPane.

          ATTN: In current implementation minimum is always 0. This field can only be altered via setSpan method and ScrollPane always calls that method with 0 for the minimum. getMinimum method always returns 0 without checking this field.

          See Also:
          ScrollPaneAdjustable.getMinimum(), ScrollPaneAdjustable.setSpan(int, int, int)

        • maximum

          int maximum
          The maximum value of this scrollbar. This value can only be set by the ScrollPane.
          See Also:
          ScrollPaneAdjustable.getMaximum(), ScrollPaneAdjustable.setSpan(int, int, int)

        • visibleAmount

          int visibleAmount
          The size of the visible portion of this scrollbar. This value can only be set by the ScrollPane.
          See Also:
          ScrollPaneAdjustable.getVisibleAmount(), ScrollPaneAdjustable.setSpan(int, int, int)

        • unitIncrement

          int unitIncrement
          The amount by which the scrollbar value will change when going up or down by a line. This value should be a non negative integer.
          See Also:
          ScrollPaneAdjustable.getUnitIncrement(), ScrollPaneAdjustable.setUnitIncrement(int)

        • blockIncrement

          int blockIncrement
          The amount by which the scrollbar value will change when going up or down by a page. This value should be a non negative integer.
          See Also:
          ScrollPaneAdjustable.getBlockIncrement(), ScrollPaneAdjustable.setBlockIncrement(int)

        • adjustmentListener

          AdjustmentListener adjustmentListener

    • Class java.awt.SystemColor extends Color implements Serializable

      serialVersionUID:
      4503142729533789064L

      • Serialization Methods

        • readResolve

          private Object readResolve()
          The design of the SystemColor class assumes that the SystemColor object instances stored in the static final fields above are the only instances that can be used by developers. This method helps maintain those limits on instantiation by using the index stored in the value field of the serialized form of the object to replace the serialized object with the equivalent static object constant field of SystemColor. See the SystemColor.writeReplace() method for more information on the serialized form of these objects.

        • writeReplace

          private Object writeReplace()
                     throws ObjectStreamException
          Returns a specialized version of the SystemColor object for writing to the serialized stream.
          Serial Data:
          The value field of a serialized SystemColor object contains the array index of the system color instead of the rgb data for the system color. This index is used by the SystemColor.readResolve() method to resolve the deserialized objects back to the original static constant versions to ensure unique instances of each SystemColor object.
          Throws:
          ObjectStreamException

    • Class java.awt.TextArea extends TextComponent implements Serializable

      serialVersionUID:
      3692302836626095722L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
          Read the ObjectInputStream.
          Throws:
          HeadlessException - if GraphicsEnvironment.isHeadless() returns true
          ClassNotFoundException
          IOException
          See Also:
          GraphicsEnvironment.isHeadless()

      • Serialized Fields

        • rows

          int rows
          The number of rows in the TextArea. This parameter will determine the text area's height. Guaranteed to be non-negative.
          See Also:
          TextArea.getRows(), TextArea.setRows(int)

        • columns

          int columns
          The number of columns in the TextArea. A column is an approximate average character width that is platform-dependent. This parameter will determine the text area's width. Guaranteed to be non-negative.
          See Also:
          TextArea.setColumns(int), TextArea.getColumns()

        • scrollbarVisibility

          int scrollbarVisibility
          Determines which scrollbars are created for the
 text area. It can be one of four values :
 SCROLLBARS_BOTH = both scrollbars.
SCROLLBARS_HORIZONTAL_ONLY = Horizontal bar only.
SCROLLBARS_VERTICAL_ONLY = Vertical bar only.
SCROLLBARS_NONE = No scrollbars.
          See Also:
          TextArea.getScrollbarVisibility()

        • textAreaSerializedDataVersion

          int textAreaSerializedDataVersion
          The textArea Serialized Data Version.

    • Class java.awt.TextArea.AccessibleAWTTextArea extends TextComponent.AccessibleAWTTextComponent implements Serializable

      serialVersionUID:
      3472827823632144419L

    • Class java.awt.TextComponent extends Component implements Serializable

      serialVersionUID:
      -2214773872412987419L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
          Read the ObjectInputStream, and if it isn't null, add a listener to receive text events fired by the TextComponent. Unrecognized keys or values will be ignored.
          Throws:
          HeadlessException - if GraphicsEnvironment.isHeadless() returns true
          ClassNotFoundException
          IOException
          See Also:
          TextComponent.removeTextListener(java.awt.event.TextListener),
TextComponent.addTextListener(java.awt.event.TextListener),
GraphicsEnvironment.isHeadless()

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Writes default serializable fields to stream. Writes a list of serializable TextListener(s) as optional data. The non-serializable TextListener(s) are detected and no attempt is made to serialize them.
          Serial Data:
          Null terminated sequence of zero or more pairs. A pair consists of a String and Object. The String indicates the type of object and is one of the following : textListenerK indicating and TextListener object.
          Throws:
          IOException
          See Also:
          AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Component.textListenerK

      • Serialized Fields

        • text

          String text
          The value of the text. A null value is the same as "".
          See Also:
          TextComponent.setText(String), TextComponent.getText()

        • editable

          boolean editable
          A boolean indicating whether or not this TextComponent is editable. It will be true if the text component is editable and false if not.
          See Also:
          TextComponent.isEditable()

        • selectionStart

          int selectionStart
          The selection refers to the selected text, and the selectionStart is the start position of the selected text.
          See Also:
          TextComponent.getSelectionStart(), TextComponent.setSelectionStart(int)

        • selectionEnd

          int selectionEnd
          The selection refers to the selected text, and the selectionEnd is the end position of the selected text.
          See Also:
          TextComponent.getSelectionEnd(), TextComponent.setSelectionEnd(int)

        • backgroundSetByClientCode

          boolean backgroundSetByClientCode

        • textComponentSerializedDataVersion

          int textComponentSerializedDataVersion
          The textComponent SerializedDataVersion.

        • checkForEnableIM

          boolean checkForEnableIM

    • Class java.awt.TextComponent.AccessibleAWTTextComponent extends Component.AccessibleAWTComponent implements Serializable

      serialVersionUID:
      3631432373506317811L

    • Class java.awt.TextField extends TextComponent implements Serializable

      serialVersionUID:
      -2966288784432217853L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
          Read the ObjectInputStream and if it isn't null, add a listener to receive action events fired by the TextField. Unrecognized keys or values will be ignored.
          Throws:
          HeadlessException - if GraphicsEnvironment.isHeadless() returns true
          ClassNotFoundException
          IOException
          See Also:
          TextField.removeActionListener(ActionListener),
TextField.addActionListener(ActionListener),
GraphicsEnvironment.isHeadless()

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Writes default serializable fields to stream. Writes a list of serializable ActionListener(s) as optional data. The non-serializable ActionListener(s) are detected and no attempt is made to serialize them.
          Serial Data:
          Null terminated sequence of zero or more pairs. A pair consists of a String and Object. The String indicates the type of object and is one of the following : ActionListenerK indicating and ActionListener object.
          Throws:
          IOException
          See Also:
          AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Component.actionListenerK

      • Serialized Fields

        • columns

          int columns
          The number of columns in the text field. A column is an approximate average character width that is platform-dependent. Guaranteed to be non-negative.
          See Also:
          TextField.setColumns(int), TextField.getColumns()

        • echoChar

          char echoChar
          The echo character, which is used when the user wishes to disguise the characters typed into the text field. The disguises are removed if echoChar = 0.
          See Also:
          TextField.getEchoChar(),
TextField.setEchoChar(char),
TextField.echoCharIsSet()

        • textFieldSerializedDataVersion

          int textFieldSerializedDataVersion
          The textField Serialized Data Version.

    • Class java.awt.TextField.AccessibleAWTTextField extends TextComponent.AccessibleAWTTextComponent implements Serializable

      serialVersionUID:
      6219164359235943158L

    • Class java.awt.Window extends Container implements Serializable

      serialVersionUID:
      4497834738069338734L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
          Reads the ObjectInputStream and an optional list of listeners to receive various events fired by the component; also reads a list of (possibly null) child windows. Unrecognized keys or values will be ignored.
          Throws:
          HeadlessException - if GraphicsEnvironment.isHeadless returns true
          ClassNotFoundException
          IOException
          See Also:
          GraphicsEnvironment.isHeadless(), Window.writeObject(java.io.ObjectOutputStream)

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Writes default serializable fields to stream. Writes a list of serializable WindowListeners and WindowFocusListeners as optional data. Writes a list of child windows as optional data. Writes a list of icon images as optional data
          Serial Data:
          null terminated sequence of 0 or more pairs; the pair consists of a String and Object; the String indicates the type of object and is one of the following: windowListenerK indicating a WindowListener object; windowFocusWindowK indicating a WindowFocusListener object; ownedWindowK indicating a child Window object
          Throws:
          IOException
          See Also:
          AWTEventMulticaster.save(java.io.ObjectOutputStream, java.lang.String, java.util.EventListener), Component.windowListenerK, Component.windowFocusListenerK, Component.ownedWindowK, Window.readObject(ObjectInputStream)

      • Serialized Fields

        • warningString

          String warningString
          This represents the warning message that is to be displayed in a non secure window. ie : a window that has a security manager installed that denies AWTPermission("showWindowWithoutWarningBanner"). This message can be displayed anywhere in the window.
          See Also:
          Window.getWarningString()

        • syncLWRequests

          boolean syncLWRequests

        • state

          int state
          An Integer value representing the Window State.
          Since:
          1.2
          See Also:
          Window.show()

        • alwaysOnTop

          boolean alwaysOnTop
          A boolean value representing Window always-on-top state
          Since:
          1.5
          See Also:
          Window.setAlwaysOnTop(boolean), Window.isAlwaysOnTop()

        • modalExclusionType

          Dialog.ModalExclusionType modalExclusionType
          Since:
          1.6
          See Also:
          Dialog.ModalExclusionType, Window.getModalExclusionType(), Window.setModalExclusionType(java.awt.Dialog.ModalExclusionType)

        • focusMgr

          java.awt.FocusManager focusMgr
          Unused. Maintained for serialization backward-compatibility.
          Since:
          1.2

        • focusableWindowState

          boolean focusableWindowState
          Indicates whether this Window can become the focused Window.
          Since:
          1.4
          See Also:
          Window.getFocusableWindowState(), Window.setFocusableWindowState(boolean)

        • autoRequestFocus

          boolean autoRequestFocus
          Indicates whether this window should receive focus on subsequently being shown (with a call to setVisible(true)), or being moved to the front (with a call to toFront()).
          Since:
          1.7
          See Also:
          Window.setAutoRequestFocus(boolean), Window.isAutoRequestFocus()

        • opacity

          float opacity
          The opacity level of the window
          Since:
          1.7
          See Also:
          Window.setOpacity(float), Window.getOpacity()

        • shape

          Shape shape
          The shape assigned to this window. This field is set to null if no shape is set (rectangular window).
          Since:
          1.7
          See Also:
          Window.getShape(), Window.setShape(Shape)

        • type

          Window.Type type
          Window type. Synchronization: ObjectLock

        • windowSerializedDataVersion

          int windowSerializedDataVersion
          The window serialized data version.

        • locationByPlatform

          boolean locationByPlatform

    • Class java.awt.Window.AccessibleAWTWindow extends Container.AccessibleAWTContainer implements Serializable

      serialVersionUID:
      4215068635060671780L

  • Package java.awt.color

    • Class java.awt.color.CMMException extends RuntimeException implements Serializable

    • Class java.awt.color.ColorSpace extends Object implements Serializable

      serialVersionUID:
      -409452704308689724L

      • Serialized Fields

        • type

          int type

        • numComponents

          int numComponents

    • Class java.awt.color.ICC_ColorSpace extends ColorSpace implements Serializable

      serialVersionUID:
      3455889114070431483L

      • Serialized Fields

        • thisProfile

          ICC_Profile thisProfile

        • minVal

          float[] minVal

        • maxVal

          float[] maxVal

        • diffMinMax

          float[] diffMinMax

        • invDiffMinMax

          float[] invDiffMinMax

        • needScaleInit

          boolean needScaleInit

    • Class java.awt.color.ICC_Profile extends Object implements Serializable

      serialVersionUID:
      -3938515861990936766L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Reads default serializable fields from the stream. Reads from the stream a string and an array of bytes as additional data.
          Serial Data:
          The String is the name of one of CS_* constants defined in the ColorSpace class if the profile object is a profile for a predefined color space (for example "CS_sRGB"). The string is null otherwise.

          The byte[] array is the profile data for the profile. It will usually be null for the predefined profiles.

          If the string is recognized as a constant name for predefined color space the object will be resolved into profile obtained with getInstance(int cspace) and the profile data are ignored. Otherwise the object will be resolved into profile obtained with getInstance(byte[] data).

          Throws:
          IOException - thrown by ObjectInputStream.
          ClassNotFoundException - thrown by ObjectInputStream.
          See Also:
          ICC_Profile.readResolve(),
ICC_Profile.getInstance(int),
ICC_Profile.getInstance(byte[])

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Writes default serializable fields to the stream. Writes a string and an array of bytes to the stream as additional data.
          Serial Data:
          The String is the name of one of CS_* constants defined in the ColorSpace class if the profile object is a profile for a predefined color space (for example "CS_sRGB"). The string is null otherwise.

          The byte[] array is the profile data for the profile. For predefined color spaces null is written instead of the profile data. If in the future versions of Java API new predefined color spaces will be added, future versions of this class may choose to write for new predefined color spaces not only the color space name, but the profile data as well so that older versions could still deserialize the object.

          Throws:
          IOException - thrown by ObjectInputStream.

        • readResolve

          protected Object readResolve()
                      throws ObjectStreamException
          Resolves instances being deserialized into instances registered with CMM.
          Throws:
          ObjectStreamException - never thrown, but mandated by the serialization spec.
          Since:
          1.3

      • Serialized Fields

        • iccProfileSerializedDataVersion

          int iccProfileSerializedDataVersion
          Version of the format of additional serialized data in the stream. Version 1 corresponds to Java 2 Platform, v1.3.
          Since:
          1.3

    • Class java.awt.color.ICC_ProfileGray extends ICC_Profile implements Serializable

      serialVersionUID:
      -1124721290732002649L

    • Class java.awt.color.ICC_ProfileRGB extends ICC_Profile implements Serializable

      serialVersionUID:
      8505067385152579334L

    • Class java.awt.color.ProfileDataException extends RuntimeException implements Serializable

  • Package java.awt.datatransfer

    • Class java.awt.datatransfer.DataFlavor extends Object implements Serializable

      serialVersionUID:
      8367026044764648243L

      • Serialization Methods

        • readExternal

          public void readExternal(ObjectInput is)
                  throws IOException,
                         ClassNotFoundException
          Restores this DataFlavor from a Serialized state.
          Throws:
          IOException - if I/O errors occur
          ClassNotFoundException - If the class for an object being restored cannot be found.

        • writeExternal

          public void writeExternal(ObjectOutput os)
                   throws IOException
          Serializes this DataFlavor.
          Throws:
          IOException - Includes any I/O exceptions that may occur

    • Class java.awt.datatransfer.FlavorEvent extends EventObject implements Serializable

    • Class java.awt.datatransfer.UnsupportedFlavorException extends Exception implements Serializable

      serialVersionUID:
      5383814944251665601L

  • Package java.awt.dnd

    • Class java.awt.dnd.DragGestureEvent extends EventObject implements Serializable

      serialVersionUID:
      9080172649166731306L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
          Deserializes this DragGestureEvent. This method first performs default deserialization for all non-transient fields. An attempt is then made to deserialize this object's List of gesture events as well. This is first attempted by deserializing the field events, because, in releases prior to 1.4, a non-transient field of this name stored the List of gesture events. If this fails, the next object in the stream is used instead. If the resulting List is null, this object's List of gesture events is set to an empty List.
          Throws:
          ClassNotFoundException
          IOException
          Since:
          1.4

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Serializes this DragGestureEvent. Performs default serialization and then writes out this object's List of gesture events if and only if the List can be serialized. If not, null is written instead. In this case, a DragGestureEvent created from the resulting deserialized stream will contain an empty List of gesture events.
          Serial Data:
          The default serializable fields, in alphabetical order, followed by either a List instance, or null.
          Throws:
          IOException
          Since:
          1.4

      • Serialized Fields

        • dragSource

          DragSource dragSource
          The DragSource associated with this DragGestureEvent.

        • component

          Component component
          The Component associated with this DragGestureEvent.

        • origin

          Point origin
          The origin of the drag.

        • action

          int action
          The user's preferred action.

    • Class java.awt.dnd.DragGestureRecognizer extends Object implements Serializable

      serialVersionUID:
      8996673345831063337L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
          Deserializes this DragGestureRecognizer. This method first performs default deserialization for all non-transient fields. This object's DragGestureListener is then deserialized as well by using the next object in the stream.
          Throws:
          ClassNotFoundException
          IOException
          Since:
          1.4

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Serializes this DragGestureRecognizer. This method first performs default serialization. Then, this object's DragGestureListener is written out if and only if it can be serialized. If not, null is written instead.
          Serial Data:
          The default serializable fields, in alphabetical order, followed by either a DragGestureListener, or null.
          Throws:
          IOException
          Since:
          1.4

      • Serialized Fields

        • dragSource

          DragSource dragSource
          The DragSource associated with this DragGestureRecognizer.

        • component

          Component component
          The Component associated with this DragGestureRecognizer.

        • sourceActions

          int sourceActions
          An int representing the type(s) of action(s) used in this Drag and Drop operation.

        • events

          ArrayList<E> events
          The list of events (in order) that the DragGestureRecognizer "recognized" as a "gesture" that triggers a drag.

    • Class java.awt.dnd.DragSource extends Object implements Serializable

      serialVersionUID:
      6236096958971414066L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
          Deserializes this DragSource. This method first performs default deserialization. Next, this object's FlavorMap is deserialized by using the next object in the stream. If the resulting FlavorMap is null, this object's FlavorMap is set to the default FlavorMap for this thread's ClassLoader. Next, this object's listeners are deserialized by reading a null-terminated sequence of 0 or more key/value pairs from the stream:
          • If a key object is a String equal to dragSourceListenerK, a DragSourceListener is deserialized using the corresponding value object and added to this DragSource.
          • If a key object is a String equal to dragSourceMotionListenerK, a DragSourceMotionListener is deserialized using the corresponding value object and added to this DragSource.
          • Otherwise, the key/value pair is skipped.
          Throws:
          ClassNotFoundException
          IOException
          Since:
          1.4
          See Also:
          SystemFlavorMap.getDefaultFlavorMap()

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Serializes this DragSource. This method first performs default serialization. Next, it writes out this object's FlavorMap if and only if it can be serialized. If not, null is written instead. Next, it writes out Serializable listeners registered with this object. Listeners are written in a null-terminated sequence of 0 or more pairs. The pair consists of a String and an Object; the String indicates the type of the Object and is one of the following:
          • dragSourceListenerK indicating a DragSourceListener object;
          • dragSourceMotionListenerK indicating a DragSourceMotionListener object.
          Serial Data:
          Either a FlavorMap instance, or null, followed by a null-terminated sequence of 0 or more pairs; the pair consists of a String and an Object; the String indicates the type of the Object and is one of the following:
          • dragSourceListenerK indicating a DragSourceListener object;
          • dragSourceMotionListenerK indicating a DragSourceMotionListener object.
          .
          Throws:
          IOException
          Since:
          1.4

    • Class java.awt.dnd.DragSourceContext extends Object implements Serializable

      serialVersionUID:
      -115407898692194719L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
          Deserializes this DragSourceContext. This method first performs default deserialization for all non-transient fields. This object's Transferable and DragSourceListener are then deserialized as well by using the next two objects in the stream. If the resulting Transferable is null, this object's Transferable is set to a dummy Transferable which supports no DataFlavors.
          Throws:
          ClassNotFoundException
          IOException
          Since:
          1.4

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Serializes this DragSourceContext. This method first performs default serialization. Next, this object's Transferable is written out if and only if it can be serialized. If not, null is written instead. In this case, a DragSourceContext created from the resulting deserialized stream will contain a dummy Transferable which supports no DataFlavors. Finally, this object's DragSourceListener is written out if and only if it can be serialized. If not, null is written instead.
          Serial Data:
          The default serializable fields, in alphabetical order, followed by either a Transferable instance, or null, followed by either a DragSourceListener instance, or null.
          Throws:
          IOException
          Since:
          1.4

      • Serialized Fields

        • trigger

          DragGestureEvent trigger
          The event which triggered the start of the drag.

        • cursor

          Cursor cursor
          The current drag cursor.

        • useCustomCursor

          boolean useCustomCursor
          true if the custom drag cursor is used instead of the default one.

        • sourceActions

          int sourceActions
          A bitwise mask of DnDConstants that represents the set of drop actions supported by the drag source for the drag operation associated with this DragSourceContext.

    • Class java.awt.dnd.DragSourceDragEvent extends DragSourceEvent implements Serializable

      serialVersionUID:
      481346297933902471L

      • Serialized Fields

        • targetActions

          int targetActions
          The target drop action.

        • dropAction

          int dropAction
          The user drop action.

        • gestureModifiers

          int gestureModifiers
          The state of the input device modifiers associated with the user gesture.

        • invalidModifiers

          boolean invalidModifiers
          Indicates whether the gestureModifiers are invalid.

    • Class java.awt.dnd.DragSourceDropEvent extends DragSourceEvent implements Serializable

      serialVersionUID:
      -5571321229470821891L

      • Serialized Fields

        • dropSuccess

          boolean dropSuccess
          true if the drop was successful.

        • dropAction

          int dropAction
          The drop action.

    • Class java.awt.dnd.DragSourceEvent extends EventObject implements Serializable

      serialVersionUID:
      -763287114604032641L

      • Serialized Fields

        • locationSpecified

          boolean locationSpecified
          The boolean indicating whether the cursor location is specified for this event.

        • x

          int x
          The horizontal coordinate for the cursor location at the moment this event occurred if the cursor location is specified for this event; otherwise zero.

        • y

          int y
          The vertical coordinate for the cursor location at the moment this event occurred if the cursor location is specified for this event; otherwise zero.

    • Class java.awt.dnd.DropTarget extends Object implements Serializable

      serialVersionUID:
      -6283860791671019047L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
          Deserializes this DropTarget. This method first performs default deserialization for all non-transient fields. An attempt is then made to deserialize this object's DropTargetListener as well. This is first attempted by deserializing the field dtListener, because, in releases prior to 1.4, a non-transient field of this name stored the DropTargetListener. If this fails, the next object in the stream is used instead.
          Throws:
          ClassNotFoundException
          IOException
          Since:
          1.4

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Serializes this DropTarget. Performs default serialization, and then writes out this object's DropTargetListener if and only if it can be serialized. If not, null is written instead.
          Serial Data:
          The default serializable fields, in alphabetical order, followed by either a DropTargetListener instance, or null.
          Throws:
          IOException
          Since:
          1.4

      • Serialized Fields

        • dropTargetContext

          DropTargetContext dropTargetContext
          The DropTargetContext associated with this DropTarget.

        • component

          Component component
          The Component associated with this DropTarget.

        • actions

          int actions
          Default permissible actions supported by this DropTarget.
          See Also:
          DropTarget.setDefaultActions(int), DropTarget.getDefaultActions()

        • active

          boolean active
          true if the DropTarget is accepting Drag & Drop operations.

    • Class java.awt.dnd.DropTargetContext extends Object implements Serializable

      serialVersionUID:
      -634158968993743371L

      • Serialized Fields

        • dropTarget

          DropTarget dropTarget
          The DropTarget associated with this DropTargetContext.

    • Class java.awt.dnd.DropTargetDragEvent extends DropTargetEvent implements Serializable

      serialVersionUID:
      -8422265619058953682L

      • Serialized Fields

        • location

          Point location
          The location of the drag cursor's hotspot in Component coordinates.

        • actions

          int actions
          The source drop actions.

        • dropAction

          int dropAction
          The user drop action.

    • Class java.awt.dnd.DropTargetDropEvent extends DropTargetEvent implements Serializable

      serialVersionUID:
      -1721911170440459322L

      • Serialized Fields

        • location

          Point location
          The location of the drag cursor's hotspot in Component coordinates.

        • actions

          int actions
          The source drop actions.

        • dropAction

          int dropAction
          The user drop action.

        • isLocalTx

          boolean isLocalTx
          true if the source is in the same JVM as the target.

    • Class java.awt.dnd.DropTargetEvent extends EventObject implements Serializable

      serialVersionUID:
      2821229066521922993L

      • Serialized Fields

        • context

          DropTargetContext context
          The DropTargetContext associated with this DropTargetEvent.

    • Class java.awt.dnd.InvalidDnDOperationException extends IllegalStateException implements Serializable

      serialVersionUID:
      -6062568741193956678L

    • Class java.awt.dnd.MouseDragGestureRecognizer extends DragGestureRecognizer implements Serializable

      serialVersionUID:
      6220099344182281120L

  • Package java.awt.event

    • Class java.awt.event.ActionEvent extends AWTEvent implements Serializable

      serialVersionUID:
      -7671078796273832149L

      • Serialized Fields

        • actionCommand

          String actionCommand
          The nonlocalized string that gives more details of what actually caused the event. This information is very specific to the component that fired it.
          See Also:
          ActionEvent.getActionCommand()

        • when

          long when
          Timestamp of when this event occurred. Because an ActionEvent is a high- level, semantic event, the timestamp is typically the same as an underlying InputEvent.
          See Also:
          ActionEvent.getWhen()

        • modifiers

          int modifiers
          This represents the key modifier that was selected, and is used to determine the state of the selected key. If no modifier has been selected it will default to zero.
          See Also:
          ActionEvent.getModifiers()

    • Class java.awt.event.AdjustmentEvent extends AWTEvent implements Serializable

      serialVersionUID:
      5700290645205279921L

      • Serialized Fields

        • adjustable

          Adjustable adjustable
          The adjustable object that fired the event.
          See Also:
          AdjustmentEvent.getAdjustable()

        • value

          int value
          value will contain the new value of the adjustable object. This value will always be in a range associated adjustable object.
          See Also:
          AdjustmentEvent.getValue()

        • adjustmentType

          int adjustmentType
          The adjustmentType describes how the adjustable object value has changed. This value can be increased/decreased by a block or unit amount where the block is associated with page increments/decrements, and a unit is associated with line increments/decrements.
          See Also:
          AdjustmentEvent.getAdjustmentType()

        • isAdjusting

          boolean isAdjusting
          The isAdjusting is true if the event is one of the series of multiple adjustment events.
          Since:
          1.4
          See Also:
          AdjustmentEvent.getValueIsAdjusting()

    • Class java.awt.event.ComponentEvent extends AWTEvent implements Serializable

      serialVersionUID:
      8101406823902992965L

    • Class java.awt.event.ContainerEvent extends ComponentEvent implements Serializable

      serialVersionUID:
      -4114942250539772041L

      • Serialized Fields

        • child

          Component child
          The non-null component that is being added or removed from the Container.
          See Also:
          ContainerEvent.getChild()

    • Class java.awt.event.FocusEvent extends ComponentEvent implements Serializable

      serialVersionUID:
      523753786457416396L

      • Serialized Fields

        • temporary

          boolean temporary
          A focus event can have two different levels, permanent and temporary. It will be set to true if some operation takes away the focus temporarily and intends on getting it back once the event is completed. Otherwise it will be set to false.
          See Also:
          FocusEvent.isTemporary()

    • Class java.awt.event.HierarchyEvent extends AWTEvent implements Serializable

      serialVersionUID:
      -5337576970038043990L

      • Serialized Fields

        • changed

          Component changed

        • changedParent

          Container changedParent

        • changeFlags

          long changeFlags

    • Class java.awt.event.InputEvent extends ComponentEvent implements Serializable

      serialVersionUID:
      -2482525981698309786L

      • Serialized Fields

        • when

          long when
          The input event's Time stamp in UTC format. The time stamp indicates when the input event was created.
          See Also:
          InputEvent.getWhen()

        • modifiers

          int modifiers
          The state of the modifier mask at the time the input event was fired.
          See Also:
          InputEvent.getModifiers(), InputEvent.getModifiersEx(), KeyEvent, MouseEvent

    • Class java.awt.event.InputMethodEvent extends AWTEvent implements Serializable

      serialVersionUID:
      4727190874778922661L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
          Initializes the when field if it is not present in the object input stream. In that case, the field will be initialized by invoking EventQueue.getMostRecentEventTime().
          Throws:
          ClassNotFoundException
          IOException

      • Serialized Fields

        • when

          long when
          The time stamp that indicates when the event was created.
          Since:
          1.4
          See Also:
          InputMethodEvent.getWhen()

    • Class java.awt.event.InvocationEvent extends AWTEvent implements Serializable

      serialVersionUID:
      436056344909459450L

      • Serialized Fields

        • runnable

          Runnable runnable
          The Runnable whose run() method will be called.

        • notifier

          Object notifier
          The (potentially null) Object whose notifyAll() method will be called immediately after the Runnable.run() method has returned or thrown an exception or after the event was disposed.
          See Also:
          InvocationEvent.isDispatched()

        • listener

          Runnable listener
          The (potentially null) Runnable whose run() method will be called immediately after the event was dispatched or disposed.
          Since:
          1.8
          See Also:
          InvocationEvent.isDispatched()

        • dispatched

          boolean dispatched
          Indicates whether the run() method of the runnable was executed or not.
          Since:
          1.7
          See Also:
          InvocationEvent.isDispatched()

        • catchExceptions

          boolean catchExceptions
          Set to true if dispatch() catches Throwable and stores it in the exception instance variable. If false, Throwables are propagated up to the EventDispatchThread's dispatch loop.

        • exception

          Exception exception
          The (potentially null) Exception thrown during execution of the Runnable.run() method. This variable will also be null if a particular instance does not catch exceptions.

        • throwable

          Throwable throwable
          The (potentially null) Throwable thrown during execution of the Runnable.run() method. This variable will also be null if a particular instance does not catch exceptions.

        • when

          long when
          The timestamp of when this event occurred.
          See Also:
          InvocationEvent.getWhen()

    • Class java.awt.event.ItemEvent extends AWTEvent implements Serializable

      serialVersionUID:
      -608708132447206933L

      • Serialized Fields

        • item

          Object item
          The item whose selection state has changed.
          See Also:
          ItemEvent.getItem()

        • stateChange

          int stateChange
          stateChange indicates whether the item was selected or deselected.
          See Also:
          ItemEvent.getStateChange()

    • Class java.awt.event.KeyEvent extends InputEvent implements Serializable

      serialVersionUID:
      -2352130953028126954L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Sets new modifiers by the old ones. The key modifiers override overlaping mouse modifiers.
          Throws:
          IOException
          ClassNotFoundException

      • Serialized Fields

        • isProxyActive

          boolean isProxyActive
          Stores the state of native event dispatching system - true, if when the event was created event proxying mechanism was active - false, if it was inactive Used in Component.dispatchEventImpl to correctly dispatch events when proxy is active

        • keyCode

          int keyCode
          The unique value assigned to each of the keys on the keyboard. There is a common set of key codes that can be fired by most keyboards. The symbolic name for a key code should be used rather than the code value itself.
          See Also:
          KeyEvent.getKeyCode(), KeyEvent.setKeyCode(int)

        • keyChar

          char keyChar
          keyChar is a valid unicode character that is fired by a key or a key combination on a keyboard.
          See Also:
          KeyEvent.getKeyChar(), KeyEvent.setKeyChar(char)

        • keyLocation

          int keyLocation
          The location of the key on the keyboard. Some keys occur more than once on a keyboard, e.g. the left and right shift keys. Additionally, some keys occur on the numeric keypad. This variable is used to distinguish such keys. The only legal values are KEY_LOCATION_UNKNOWN, KEY_LOCATION_STANDARD, KEY_LOCATION_LEFT, KEY_LOCATION_RIGHT, and KEY_LOCATION_NUMPAD.
          See Also:
          KeyEvent.getKeyLocation()

        • originalSource

          Component originalSource
          The original event source. Event source can be changed during processing, but in some cases we need to be able to obtain original source.

    • Class java.awt.event.MouseEvent extends InputEvent implements Serializable

      serialVersionUID:
      -991214153494842848L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Sets new modifiers by the old ones.
          Throws:
          IOException
          ClassNotFoundException

      • Serialized Fields

        • x

          int x
          The mouse event's x coordinate. The x value is relative to the component that fired the event.
          See Also:
          MouseEvent.getX()

        • y

          int y
          The mouse event's y coordinate. The y value is relative to the component that fired the event.
          See Also:
          MouseEvent.getY()

        • xAbs

          int xAbs
          The mouse event's x absolute coordinate. In a virtual device multi-screen environment in which the desktop area could span multiple physical screen devices, this coordinate is relative to the virtual coordinate system. Otherwise, this coordinate is relative to the coordinate system associated with the Component's GraphicsConfiguration.

        • yAbs

          int yAbs
          The mouse event's y absolute coordinate. In a virtual device multi-screen environment in which the desktop area could span multiple physical screen devices, this coordinate is relative to the virtual coordinate system. Otherwise, this coordinate is relative to the coordinate system associated with the Component's GraphicsConfiguration.

        • clickCount

          int clickCount
          Indicates the number of quick consecutive clicks of a mouse button. clickCount will be valid for only three mouse events :
          MOUSE_CLICKED, MOUSE_PRESSED and MOUSE_RELEASED. For the above, the clickCount will be at least 1. For all other events the count will be 0.
          See Also:
          MouseEvent.getClickCount()

        • button

          int button
          Indicates which, if any, of the mouse buttons has changed state. The valid values are ranged from 0 to the value returned by the MouseInfo.getNumberOfButtons() method. This range already includes constants NOBUTTON, BUTTON1, BUTTON2, and BUTTON3 if these buttons are present. So it is allowed to use these constants too. For example, for a mouse with two buttons this field may contain the following values:
          • 0 (NOBUTTON)
          • 1 (BUTTON1)
          • 2 (BUTTON2)
          If a mouse has 5 buttons, this field may contain the following values:
          • 0 (NOBUTTON)
          • 1 (BUTTON1)
          • 2 (BUTTON2)
          • 3 (BUTTON3)
          • 4
          • 5
          If support for extended mouse buttons is Toolkit.areExtraMouseButtonsEnabled() disabled by Java then the field may not contain the value larger than BUTTON3.
          See Also:
          MouseEvent.getButton(), Toolkit.areExtraMouseButtonsEnabled()

        • popupTrigger

          boolean popupTrigger
          A property used to indicate whether a Popup Menu should appear with a certain gestures. If popupTrigger = false, no popup menu should appear. If it is true then a popup menu should appear.
          See Also:
          PopupMenu, MouseEvent.isPopupTrigger()

    • Class java.awt.event.MouseWheelEvent extends MouseEvent implements Serializable

      serialVersionUID:
      6459879390515399677L

      • Serialized Fields

        • scrollType

          int scrollType
          Indicates what sort of scrolling should take place in response to this event, based on platform settings. Legal values are:
          • WHEEL_UNIT_SCROLL
          • WHEEL_BLOCK_SCROLL
          See Also:
          MouseWheelEvent.getScrollType()

        • scrollAmount

          int scrollAmount
          Only valid for scrollType WHEEL_UNIT_SCROLL. Indicates number of units that should be scrolled per click of mouse wheel rotation, based on platform settings.
          See Also:
          MouseWheelEvent.getScrollAmount(), MouseWheelEvent.getScrollType()

        • wheelRotation

          int wheelRotation
          Indicates how far the mouse wheel was rotated.
          See Also:
          MouseWheelEvent.getWheelRotation()

        • preciseWheelRotation

          double preciseWheelRotation
          Indicates how far the mouse wheel was rotated.
          See Also:
          MouseWheelEvent.getPreciseWheelRotation()

    • Class java.awt.event.PaintEvent extends ComponentEvent implements Serializable

      serialVersionUID:
      1267492026433337593L

      • Serialized Fields

        • updateRect

          Rectangle updateRect
          This is the rectangle that represents the area on the source component that requires a repaint. This rectangle should be non null.
          See Also:
          Rectangle, PaintEvent.setUpdateRect(Rectangle), PaintEvent.getUpdateRect()

    • Class java.awt.event.TextEvent extends AWTEvent implements Serializable

      serialVersionUID:
      6269902291250941179L

    • Class java.awt.event.WindowEvent extends ComponentEvent implements Serializable

      serialVersionUID:
      -1567959133147912127L

      • Serialized Fields

        • oldState

          int oldState
          TBS

        • newState

          int newState

  • Package java.awt.font

    • Class java.awt.font.NumericShaper extends Object implements Serializable

      serialVersionUID:
      -8022764705923730308L

      • Serialization Methods

        • writeObject

          private void writeObject(ObjectOutputStream stream)
                  throws IOException
          Converts the NumericShaper.Range enum-based parameters, if any, to the bit mask-based counterparts and writes this object to the stream. Any enum constants that have no bit mask-based counterparts are ignored in the conversion.
          Throws:
          IOException - if an I/O error occurs while writing to stream
          Since:
          1.7

      • Serialized Fields

        • key

          int key
          index of context for contextual shaping - values range from 0 to 18

        • mask

          int mask
          flag indicating whether to shape contextually (high bit) and which digit ranges to shape (bits 0-18)

        • shapingRange

          NumericShaper.Range shapingRange
          The context Range for contextual shaping or the Range for non-contextual shaping. null for the bit mask-based API.
          Since:
          1.7

    • Class java.awt.font.TextAttribute extends AttributedCharacterIterator.Attribute implements Serializable

      serialVersionUID:
      7744112784117861702L

      • Serialization Methods

        • readResolve

          protected Object readResolve()
                      throws InvalidObjectException
          Resolves instances being deserialized to the predefined constants.
          Throws:
          InvalidObjectException - if the object to resolve is not an instance of Attribute

    • Class java.awt.font.TransformAttribute extends Object implements Serializable

      serialVersionUID:
      3356247357827709530L

      • Serialization Methods

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws ClassNotFoundException,
                         IOException
          Throws:
          ClassNotFoundException
          IOException

        • readResolve

          private Object readResolve()
                    throws ObjectStreamException
          Throws:
          ObjectStreamException

      • Serialized Fields

        • transform

          AffineTransform transform
          The AffineTransform for this TransformAttribute, or null if AffineTransform is the identity transform.

  • Package java.awt.geom

    • Class java.awt.geom.AffineTransform extends Object implements Serializable

      serialVersionUID:
      1330973210523860834L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
          Throws:
          ClassNotFoundException
          IOException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws ClassNotFoundException,
                         IOException
          Throws:
          ClassNotFoundException
          IOException

      • Serialized Fields

        • m00

          double m00
          The X coordinate scaling element of the 3x3 affine transformation matrix.

        • m10

          double m10
          The Y coordinate shearing element of the 3x3 affine transformation matrix.

        • m01

          double m01
          The X coordinate shearing element of the 3x3 affine transformation matrix.

        • m11

          double m11
          The Y coordinate scaling element of the 3x3 affine transformation matrix.

        • m02

          double m02
          The X coordinate of the translation element of the 3x3 affine transformation matrix.

        • m12

          double m12
          The Y coordinate of the translation element of the 3x3 affine transformation matrix.

    • Class java.awt.geom.Arc2D.Double extends Arc2D implements Serializable

      serialVersionUID:
      728264085846882001L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
          Reads the default serializable fields from the ObjectInputStream followed by a byte indicating the arc type of this Arc2D instance.
          Serial Data:
          1. The default serializable fields.
          2. followed by a byte indicating the arc type Arc2D.OPEN, Arc2D.CHORD, or Arc2D.PIE.
          Throws:
          ClassNotFoundException
          IOException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Writes the default serializable fields to the ObjectOutputStream followed by a byte indicating the arc type of this Arc2D instance.
          Serial Data:
          1. The default serializable fields.
          2. followed by a byte indicating the arc type Arc2D.OPEN, Arc2D.CHORD, or Arc2D.PIE.
          Throws:
          IOException

      • Serialized Fields

        • x

          double x
          The X coordinate of the upper-left corner of the framing rectangle of the arc.
          Since:
          1.2

        • y

          double y
          The Y coordinate of the upper-left corner of the framing rectangle of the arc.
          Since:
          1.2

        • width

          double width
          The overall width of the full ellipse of which this arc is a partial section (not considering the angular extents).
          Since:
          1.2

        • height

          double height
          The overall height of the full ellipse of which this arc is a partial section (not considering the angular extents).
          Since:
          1.2

        • start

          double start
          The starting angle of the arc in degrees.
          Since:
          1.2

        • extent

          double extent
          The angular extent of the arc in degrees.
          Since:
          1.2

    • Class java.awt.geom.Arc2D.Float extends Arc2D implements Serializable

      serialVersionUID:
      9130893014586380278L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
          Reads the default serializable fields from the ObjectInputStream followed by a byte indicating the arc type of this Arc2D instance.
          Serial Data:
          1. The default serializable fields.
          2. followed by a byte indicating the arc type Arc2D.OPEN, Arc2D.CHORD, or Arc2D.PIE.
          Throws:
          ClassNotFoundException
          IOException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Writes the default serializable fields to the ObjectOutputStream followed by a byte indicating the arc type of this Arc2D instance.
          Serial Data:
          1. The default serializable fields.
          2. followed by a byte indicating the arc type Arc2D.OPEN, Arc2D.CHORD, or Arc2D.PIE.
          Throws:
          IOException

      • Serialized Fields

        • x

          float x
          The X coordinate of the upper-left corner of the framing rectangle of the arc.
          Since:
          1.2

        • y

          float y
          The Y coordinate of the upper-left corner of the framing rectangle of the arc.
          Since:
          1.2

        • width

          float width
          The overall width of the full ellipse of which this arc is a partial section (not considering the angular extents).
          Since:
          1.2

        • height

          float height
          The overall height of the full ellipse of which this arc is a partial section (not considering the angular extents).
          Since:
          1.2

        • start

          float start
          The starting angle of the arc in degrees.
          Since:
          1.2

        • extent

          float extent
          The angular extent of the arc in degrees.
          Since:
          1.2

    • Class java.awt.geom.CubicCurve2D.Double extends CubicCurve2D implements Serializable

      serialVersionUID:
      -4202960122839707295L

      • Serialized Fields

        • x1

          double x1
          The X coordinate of the start point of the cubic curve segment.
          Since:
          1.2

        • y1

          double y1
          The Y coordinate of the start point of the cubic curve segment.
          Since:
          1.2

        • ctrlx1

          double ctrlx1
          The X coordinate of the first control point of the cubic curve segment.
          Since:
          1.2

        • ctrly1

          double ctrly1
          The Y coordinate of the first control point of the cubic curve segment.
          Since:
          1.2

        • ctrlx2

          double ctrlx2
          The X coordinate of the second control point of the cubic curve segment.
          Since:
          1.2

        • ctrly2

          double ctrly2
          The Y coordinate of the second control point of the cubic curve segment.
          Since:
          1.2

        • x2

          double x2
          The X coordinate of the end point of the cubic curve segment.
          Since:
          1.2

        • y2

          double y2
          The Y coordinate of the end point of the cubic curve segment.
          Since:
          1.2

    • Class java.awt.geom.CubicCurve2D.Float extends CubicCurve2D implements Serializable

      serialVersionUID:
      -1272015596714244385L

      • Serialized Fields

        • x1

          float x1
          The X coordinate of the start point of the cubic curve segment.
          Since:
          1.2

        • y1

          float y1
          The Y coordinate of the start point of the cubic curve segment.
          Since:
          1.2

        • ctrlx1

          float ctrlx1
          The X coordinate of the first control point of the cubic curve segment.
          Since:
          1.2

        • ctrly1

          float ctrly1
          The Y coordinate of the first control point of the cubic curve segment.
          Since:
          1.2

        • ctrlx2

          float ctrlx2
          The X coordinate of the second control point of the cubic curve segment.
          Since:
          1.2

        • ctrly2

          float ctrly2
          The Y coordinate of the second control point of the cubic curve segment.
          Since:
          1.2

        • x2

          float x2
          The X coordinate of the end point of the cubic curve segment.
          Since:
          1.2

        • y2

          float y2
          The Y coordinate of the end point of the cubic curve segment.
          Since:
          1.2

    • Class java.awt.geom.Ellipse2D.Double extends Ellipse2D implements Serializable

      serialVersionUID:
      5555464816372320683L

      • Serialized Fields

        • x

          double x
          The X coordinate of the upper-left corner of the framing rectangle of this Ellipse2D.
          Since:
          1.2

        • y

          double y
          The Y coordinate of the upper-left corner of the framing rectangle of this Ellipse2D.
          Since:
          1.2

        • width

          double width
          The overall width of this Ellipse2D.
          Since:
          1.2

        • height

          double height
          The overall height of the Ellipse2D.
          Since:
          1.2

    • Class java.awt.geom.Ellipse2D.Float extends Ellipse2D implements Serializable

      serialVersionUID:
      -6633761252372475977L

      • Serialized Fields

        • x

          float x
          The X coordinate of the upper-left corner of the framing rectangle of this Ellipse2D.
          Since:
          1.2

        • y

          float y
          The Y coordinate of the upper-left corner of the framing rectangle of this Ellipse2D.
          Since:
          1.2

        • width

          float width
          The overall width of this Ellipse2D.
          Since:
          1.2

        • height

          float height
          The overall height of this Ellipse2D.
          Since:
          1.2

    • Class java.awt.geom.GeneralPath extends Path2D.Float implements Serializable

      serialVersionUID:
      -8327096662768731142L

    • Class java.awt.geom.IllegalPathStateException extends RuntimeException implements Serializable

    • Class java.awt.geom.Line2D.Double extends Line2D implements Serializable

      serialVersionUID:
      7979627399746467499L

      • Serialized Fields

        • x1

          double x1
          The X coordinate of the start point of the line segment.
          Since:
          1.2

        • y1

          double y1
          The Y coordinate of the start point of the line segment.
          Since:
          1.2

        • x2

          double x2
          The X coordinate of the end point of the line segment.
          Since:
          1.2

        • y2

          double y2
          The Y coordinate of the end point of the line segment.
          Since:
          1.2

    • Class java.awt.geom.Line2D.Float extends Line2D implements Serializable

      serialVersionUID:
      6161772511649436349L

      • Serialized Fields

        • x1

          float x1
          The X coordinate of the start point of the line segment.
          Since:
          1.2

        • y1

          float y1
          The Y coordinate of the start point of the line segment.
          Since:
          1.2

        • x2

          float x2
          The X coordinate of the end point of the line segment.
          Since:
          1.2

        • y2

          float y2
          The Y coordinate of the end point of the line segment.
          Since:
          1.2

    • Class java.awt.geom.NoninvertibleTransformException extends Exception implements Serializable

    • Class java.awt.geom.Path2D.Double extends Path2D implements Serializable

      serialVersionUID:
      1826762518450014216L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
          Reads the default serializable fields from the ObjectInputStream followed by an explicit serialization of the path segments stored in this path.

          There are no default serializable fields as of 1.6.

          The serial data for this object is described in the writeObject method.

          Throws:
          ClassNotFoundException
          IOException
          Since:
          1.6

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Writes the default serializable fields to the ObjectOutputStream followed by an explicit serialization of the path segments stored in this path.
          Serial Data:
          1. The default serializable fields. There are no default serializable fields as of 1.6.
          2. followed by a byte indicating the storage type of the original object as a hint (SERIAL_STORAGE_DBL_ARRAY)
          3. followed by an integer indicating the number of path segments to follow (NP) or -1 to indicate an unknown number of path segments follows
          4. followed by an integer indicating the total number of coordinates to follow (NC) or -1 to indicate an unknown number of coordinates follows (NC should always be even since coordinates always appear in pairs representing an x,y pair)
          5. followed by a byte indicating the winding rule (WIND_EVEN_ODD or WIND_NON_ZERO)
          6. followed by NP (or unlimited if NP < 0) sets of values consisting of a single byte indicating a path segment type followed by one or more pairs of float or double values representing the coordinates of the path segment
          7. followed by a byte indicating the end of the path (SERIAL_PATH_END).

          The following byte value constants are used in the serialized form of Path2D objects:

          Constant Name | Byte Value | Followed by | Description
          SERIAL_STORAGE_FLT_ARRAY | 0x30 | A hint that the original Path2D object stored the coordinates in a Java array of floats.
          SERIAL_STORAGE_DBL_ARRAY | 0x31 | A hint that the original Path2D object stored the coordinates in a Java array of doubles.
          SERIAL_SEG_FLT_MOVETO | 0x40 | 2 floats | A moveTo path segment follows.
          SERIAL_SEG_FLT_LINETO | 0x41 | 2 floats | A lineTo path segment follows.
          SERIAL_SEG_FLT_QUADTO | 0x42 | 4 floats | A quadTo path segment follows.
          SERIAL_SEG_FLT_CUBICTO | 0x43 | 6 floats | A curveTo path segment follows.
          SERIAL_SEG_DBL_MOVETO | 0x50 | 2 doubles | A moveTo path segment follows.
          SERIAL_SEG_DBL_LINETO | 0x51 | 2 doubles | A lineTo path segment follows.
          SERIAL_SEG_DBL_QUADTO | 0x52 | 4 doubles | A curveTo path segment follows.
          SERIAL_SEG_DBL_CUBICTO | 0x53 | 6 doubles | A curveTo path segment follows.
          SERIAL_SEG_CLOSE | 0x60 | A closePath path segment.
          SERIAL_PATH_END | 0x61 | There are no more path segments following.
          Throws:
          IOException
          Since:
          1.6

    • Class java.awt.geom.Path2D.Float extends Path2D implements Serializable

      serialVersionUID:
      6990832515060788886L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
          Reads the default serializable fields from the ObjectInputStream followed by an explicit serialization of the path segments stored in this path.

          There are no default serializable fields as of 1.6.

          The serial data for this object is described in the writeObject method.

          Throws:
          ClassNotFoundException
          IOException
          Since:
          1.6

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Writes the default serializable fields to the ObjectOutputStream followed by an explicit serialization of the path segments stored in this path.
          Serial Data:
          1. The default serializable fields. There are no default serializable fields as of 1.6.
          2. followed by a byte indicating the storage type of the original object as a hint (SERIAL_STORAGE_FLT_ARRAY)
          3. followed by an integer indicating the number of path segments to follow (NP) or -1 to indicate an unknown number of path segments follows
          4. followed by an integer indicating the total number of coordinates to follow (NC) or -1 to indicate an unknown number of coordinates follows (NC should always be even since coordinates always appear in pairs representing an x,y pair)
          5. followed by a byte indicating the winding rule (WIND_EVEN_ODD or WIND_NON_ZERO)
          6. followed by NP (or unlimited if NP < 0) sets of values consisting of a single byte indicating a path segment type followed by one or more pairs of float or double values representing the coordinates of the path segment
          7. followed by a byte indicating the end of the path (SERIAL_PATH_END).

          The following byte value constants are used in the serialized form of Path2D objects:

          Constant Name | Byte Value | Followed by | Description
          SERIAL_STORAGE_FLT_ARRAY | 0x30 | A hint that the original Path2D object stored the coordinates in a Java array of floats.
          SERIAL_STORAGE_DBL_ARRAY | 0x31 | A hint that the original Path2D object stored the coordinates in a Java array of doubles.
          SERIAL_SEG_FLT_MOVETO | 0x40 | 2 floats | A moveTo path segment follows.
          SERIAL_SEG_FLT_LINETO | 0x41 | 2 floats | A lineTo path segment follows.
          SERIAL_SEG_FLT_QUADTO | 0x42 | 4 floats | A quadTo path segment follows.
          SERIAL_SEG_FLT_CUBICTO | 0x43 | 6 floats | A curveTo path segment follows.
          SERIAL_SEG_DBL_MOVETO | 0x50 | 2 doubles | A moveTo path segment follows.
          SERIAL_SEG_DBL_LINETO | 0x51 | 2 doubles | A lineTo path segment follows.
          SERIAL_SEG_DBL_QUADTO | 0x52 | 4 doubles | A curveTo path segment follows.
          SERIAL_SEG_DBL_CUBICTO | 0x53 | 6 doubles | A curveTo path segment follows.
          SERIAL_SEG_CLOSE | 0x60 | A closePath path segment.
          SERIAL_PATH_END | 0x61 | There are no more path segments following.
          Throws:
          IOException
          Since:
          1.6

    • Class java.awt.geom.Point2D.Double extends Point2D implements Serializable

      serialVersionUID:
      6150783262733311327L

      • Serialized Fields

        • x

          double x
          The X coordinate of this Point2D.
          Since:
          1.2

        • y

          double y
          The Y coordinate of this Point2D.
          Since:
          1.2

    • Class java.awt.geom.Point2D.Float extends Point2D implements Serializable

      serialVersionUID:
      -2870572449815403710L

      • Serialized Fields

        • x

          float x
          The X coordinate of this Point2D.
          Since:
          1.2

        • y

          float y
          The Y coordinate of this Point2D.
          Since:
          1.2

    • Class java.awt.geom.QuadCurve2D.Double extends QuadCurve2D implements Serializable

      serialVersionUID:
      4217149928428559721L

      • Serialized Fields

        • x1

          double x1
          The X coordinate of the start point of the quadratic curve segment.
          Since:
          1.2

        • y1

          double y1
          The Y coordinate of the start point of the quadratic curve segment.
          Since:
          1.2

        • ctrlx

          double ctrlx
          The X coordinate of the control point of the quadratic curve segment.
          Since:
          1.2

        • ctrly

          double ctrly
          The Y coordinate of the control point of the quadratic curve segment.
          Since:
          1.2

        • x2

          double x2
          The X coordinate of the end point of the quadratic curve segment.
          Since:
          1.2

        • y2

          double y2
          The Y coordinate of the end point of the quadratic curve segment.
          Since:
          1.2

    • Class java.awt.geom.QuadCurve2D.Float extends QuadCurve2D implements Serializable

      serialVersionUID:
      -8511188402130719609L

      • Serialized Fields

        • x1

          float x1
          The X coordinate of the start point of the quadratic curve segment.
          Since:
          1.2

        • y1

          float y1
          The Y coordinate of the start point of the quadratic curve segment.
          Since:
          1.2

        • ctrlx

          float ctrlx
          The X coordinate of the control point of the quadratic curve segment.
          Since:
          1.2

        • ctrly

          float ctrly
          The Y coordinate of the control point of the quadratic curve segment.
          Since:
          1.2

        • x2

          float x2
          The X coordinate of the end point of the quadratic curve segment.
          Since:
          1.2

        • y2

          float y2
          The Y coordinate of the end point of the quadratic curve segment.
          Since:
          1.2

    • Class java.awt.geom.Rectangle2D.Double extends Rectangle2D implements Serializable

      serialVersionUID:
      7771313791441850493L

      • Serialized Fields

        • x

          double x
          The X coordinate of this Rectangle2D.
          Since:
          1.2

        • y

          double y
          The Y coordinate of this Rectangle2D.
          Since:
          1.2

        • width

          double width
          The width of this Rectangle2D.
          Since:
          1.2

        • height

          double height
          The height of this Rectangle2D.
          Since:
          1.2

    • Class java.awt.geom.Rectangle2D.Float extends Rectangle2D implements Serializable

      serialVersionUID:
      3798716824173675777L

      • Serialized Fields

        • x

          float x
          The X coordinate of this Rectangle2D.
          Since:
          1.2

        • y

          float y
          The Y coordinate of this Rectangle2D.
          Since:
          1.2

        • width

          float width
          The width of this Rectangle2D.
          Since:
          1.2

        • height

          float height
          The height of this Rectangle2D.
          Since:
          1.2

    • Class java.awt.geom.RoundRectangle2D.Double extends RoundRectangle2D implements Serializable

      serialVersionUID:
      1048939333485206117L

      • Serialized Fields

        • x

          double x
          The X coordinate of this RoundRectangle2D.
          Since:
          1.2

        • y

          double y
          The Y coordinate of this RoundRectangle2D.
          Since:
          1.2

        • width

          double width
          The width of this RoundRectangle2D.
          Since:
          1.2

        • height

          double height
          The height of this RoundRectangle2D.
          Since:
          1.2

        • arcwidth

          double arcwidth
          The width of the arc that rounds off the corners.
          Since:
          1.2

        • archeight

          double archeight
          The height of the arc that rounds off the corners.
          Since:
          1.2

    • Class java.awt.geom.RoundRectangle2D.Float extends RoundRectangle2D implements Serializable

      serialVersionUID:
      -3423150618393866922L

      • Serialized Fields

        • x

          float x
          The X coordinate of this RoundRectangle2D.
          Since:
          1.2

        • y

          float y
          The Y coordinate of this RoundRectangle2D.
          Since:
          1.2

        • width

          float width
          The width of this RoundRectangle2D.
          Since:
          1.2

        • height

          float height
          The height of this RoundRectangle2D.
          Since:
          1.2

        • arcwidth

          float arcwidth
          The width of the arc that rounds off the corners.
          Since:
          1.2

        • archeight

          float archeight
          The height of the arc that rounds off the corners.
          Since:
          1.2

  • Package java.awt.image

    • Class java.awt.image.ImagingOpException extends RuntimeException implements Serializable

    • Class java.awt.image.RasterFormatException extends RuntimeException implements Serializable

  • Package java.awt.image.renderable

    • Class java.awt.image.renderable.ParameterBlock extends Object implements Serializable

      • Serialized Fields

        • sources

          Vector<E> sources
          A Vector of sources, stored as arbitrary Objects.

        • parameters

          Vector<E> parameters
          A Vector of non-source parameters, stored as arbitrary Objects.

  • Package java.awt.print

    • Class java.awt.print.PrinterAbortException extends PrinterException implements Serializable

    • Class java.awt.print.PrinterException extends Exception implements Serializable

    • Class java.awt.print.PrinterIOException extends PrinterException implements Serializable

      serialVersionUID:
      5850870712125932846L

      • Serialized Fields

        • mException

          IOException mException
          The IO error that terminated the print job.

  • Package java.beans

    • Class java.beans.IndexedPropertyChangeEvent extends PropertyChangeEvent implements Serializable

      serialVersionUID:
      -320227448495806870L

      • Serialized Fields

        • index

          int index

    • Class java.beans.IntrospectionException extends Exception implements Serializable

      serialVersionUID:
      -3728150539969542619L

    • Class java.beans.PropertyChangeEvent extends EventObject implements Serializable

      serialVersionUID:
      7042693688939648123L

      • Serialized Fields

        • propertyName

          String propertyName
          name of the property that changed. May be null, if not known.

        • newValue

          Object newValue
          New value for property. May be null if not known.

        • oldValue

          Object oldValue
          Previous value for property. May be null if not known.

        • propagationId

          Object propagationId
          Propagation ID. May be null.
          See Also:
          PropertyChangeEvent.getPropagationId()

    • Class java.beans.PropertyChangeSupport extends Object implements Serializable

      serialVersionUID:
      6401253773779951803L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
          Throws:
          ClassNotFoundException
          IOException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Serial Data:
          Null terminated list of PropertyChangeListeners.

          At serialization time we skip non-serializable listeners and only serialize the serializable listeners.

          Throws:
          IOException

      • Serialized Fields

        • children

          Hashtable<K,V> children

        • propertyChangeSupportSerializedDataVersion

          int propertyChangeSupportSerializedDataVersion

        • source

          Object source
          The object to be provided as the "source" for any generated events.

    • Class java.beans.PropertyVetoException extends Exception implements Serializable

      serialVersionUID:
      129596057694162164L

      • Serialized Fields

        • evt

          PropertyChangeEvent evt
          A PropertyChangeEvent describing the vetoed change.

    • Class java.beans.VetoableChangeSupport extends Object implements Serializable

      serialVersionUID:
      -5090210921595982017L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
          Throws:
          ClassNotFoundException
          IOException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Serial Data:
          Null terminated list of VetoableChangeListeners.

          At serialization time we skip non-serializable listeners and only serialize the serializable listeners.

          Throws:
          IOException

      • Serialized Fields

        • children

          Hashtable<K,V> children

        • source

          Object source
          The object to be provided as the "source" for any generated events.

        • vetoableChangeSupportSerializedDataVersion

          int vetoableChangeSupportSerializedDataVersion

  • Package java.beans.beancontext

    • Class java.beans.beancontext.BeanContextChildSupport extends Object implements Serializable

      serialVersionUID:
      6328947014421475877L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
          Restore a persistent object, must wait for subsequent setBeanContext() to fully restore any resources obtained from the new nesting BeanContext
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream oos)
                  throws IOException
          Write the persistence state of the object.
          Throws:
          IOException

      • Serialized Fields

        • beanContextChildPeer

          BeanContextChild beanContextChildPeer
          The BeanContext in which this BeanContextChild is nested.

        • pcSupport

          PropertyChangeSupport pcSupport
          The PropertyChangeSupport associated with this BeanContextChildSupport.

        • vcSupport

          VetoableChangeSupport vcSupport
          The VetoableChangeSupport associated with this BeanContextChildSupport.

    • Class java.beans.beancontext.BeanContextEvent extends EventObject implements Serializable

      serialVersionUID:
      7267998073569045052L

      • Serialized Fields

        • propagatedFrom

          BeanContext propagatedFrom
          The BeanContext from which this event was propagated

    • Class java.beans.beancontext.BeanContextMembershipEvent extends BeanContextEvent implements Serializable

      serialVersionUID:
      3499346510334590959L

      • Serialized Fields

        • children

          Collection<E> children
          The list of children affected by this event notification.

    • Class java.beans.beancontext.BeanContextServiceAvailableEvent extends BeanContextEvent implements Serializable

      serialVersionUID:
      -5333985775656400778L

      • Serialized Fields

        • serviceClass

          Class<T> serviceClass
          A Class reference to the newly available service

    • Class java.beans.beancontext.BeanContextServiceRevokedEvent extends BeanContextEvent implements Serializable

      serialVersionUID:
      -1295543154724961754L

      • Serialized Fields

        • serviceClass

          Class<T> serviceClass
          A Class reference to the service that is being revoked.

        • invalidateRefs

          boolean invalidateRefs

    • Class java.beans.beancontext.BeanContextServicesSupport extends BeanContextSupport implements Serializable

      serialVersionUID:
      -8494482757288719206L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
          deserialize the instance
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream oos)
                  throws IOException
          serialize the instance
          Throws:
          IOException

    • Class java.beans.beancontext.BeanContextServicesSupport.BCSSChild extends BeanContextSupport.BCSChild implements Serializable

      serialVersionUID:
      -3263851306889194873L

    • Class java.beans.beancontext.BeanContextServicesSupport.BCSSServiceProvider extends Object implements Serializable

      serialVersionUID:
      861278251667444782L

      • Serialized Fields

        • serviceProvider

          BeanContextServiceProvider serviceProvider
          The service provider.

    • Class java.beans.beancontext.BeanContextSupport extends BeanContextChildSupport implements Serializable

      serialVersionUID:
      -4879613978649577204L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
          deserialize contents ... if this instance has a distinct peer the children are *not* serialized here, the peer's readObject() must call readChildren() after deserializing this instance.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream oos)
                  throws IOException,
                         ClassNotFoundException
          Serialize the BeanContextSupport, if this instance has a distinct peer (that is this object is acting as a delegate for another) then the children of this instance are not serialized here due to a 'chicken and egg' problem that occurs on deserialization of the children at the same time as this instance. Therefore in situations where there is a distinct peer to this instance it should always call writeObject() followed by writeChildren() and readObject() followed by readChildren().
          Throws:
          IOException
          ClassNotFoundException

      • Serialized Fields

        • serializable

          int serializable

        • locale

          Locale locale
          The current locale of this BeanContext.

        • okToUseGui

          boolean okToUseGui
          A boolean indicating if this instance may now render a GUI.

        • designTime

          boolean designTime
          A boolean indicating whether or not this object is currently in design time mode.

    • Class java.beans.beancontext.BeanContextSupport.BCSChild extends Object implements Serializable

      serialVersionUID:
      -5815286101609939109L

      • Serialized Fields

        • child

          Object child

        • proxyPeer

          Object proxyPeer

  • Package java.io

    • Class java.io.CharConversionException extends IOException implements Serializable

      serialVersionUID:
      -8680016352018427031L

    • Class java.io.EOFException extends IOException implements Serializable

      serialVersionUID:
      6433858223774886977L

    • Class java.io.File extends Object implements Serializable

      serialVersionUID:
      301077366599181567L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          readObject is called to restore this filename. The original separator character is read. If it is different than the separator character on this system, then the old separator is replaced by the local separator.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          WriteObject is called to save this filename. The separator character is saved also so it can be replaced in case the path is reconstituted on a different host type.

          Serial Data:
          Default fields followed by separator character.
          Throws:
          IOException

      • Serialized Fields

        • path

          String path
          This abstract pathname's normalized pathname string. A normalized pathname string uses the default name-separator character and does not contain any duplicate or redundant separators.

    • Class java.io.FileNotFoundException extends IOException implements Serializable

      serialVersionUID:
      -897856973823710492L

    • Class java.io.FilePermissionCollection extends PermissionCollection implements Serializable

      serialVersionUID:
      2202956749081564585L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream out)
                  throws IOException
          Serial Data:
          "permissions" field (a Vector containing the FilePermissions).
          Throws:
          IOException

      • Serialized Fields

        • permissions

          Vector<E> permissions
          A list of FilePermission objects.

    • Class java.io.InterruptedIOException extends IOException implements Serializable

      serialVersionUID:
      4020568460727500567L

      • Serialized Fields

        • bytesTransferred

          int bytesTransferred
          Reports how many bytes had been transferred as part of the I/O operation before it was interrupted.

    • Class java.io.InvalidClassException extends ObjectStreamException implements Serializable

      serialVersionUID:
      -4333316296251054416L

      • Serialized Fields

        • classname

          String classname
          Name of the invalid class.
          Name of the invalid class.

    • Class java.io.InvalidObjectException extends ObjectStreamException implements Serializable

      serialVersionUID:
      3233174318281839583L

    • Class java.io.IOError extends Error implements Serializable

      serialVersionUID:
      67100927991680413L

    • Class java.io.IOException extends Exception implements Serializable

      serialVersionUID:
      7818375828146090155L

    • Class java.io.NotActiveException extends ObjectStreamException implements Serializable

      serialVersionUID:
      -3893467273049808895L

    • Class java.io.NotSerializableException extends ObjectStreamException implements Serializable

      serialVersionUID:
      2906642554793891381L

    • Class java.io.ObjectStreamClass extends Object implements Serializable

      serialVersionUID:
      -6120832682080437368L

    • Class java.io.ObjectStreamException extends IOException implements Serializable

      serialVersionUID:
      7260898174833392607L

    • Class java.io.OptionalDataException extends ObjectStreamException implements Serializable

      serialVersionUID:
      -8011121865681257820L

      • Serialized Fields

        • length

          int length
          The number of bytes of primitive data available to be read in the current buffer.

        • eof

          boolean eof
          True if there is no more data in the buffered part of the stream.

    • Class java.io.SerializablePermission extends BasicPermission implements Serializable

      serialVersionUID:
      8537212141160296410L

      • Serialized Fields

        • actions

          String actions

    • Class java.io.StreamCorruptedException extends ObjectStreamException implements Serializable

      serialVersionUID:
      8983558202217591746L

    • Class java.io.SyncFailedException extends IOException implements Serializable

      serialVersionUID:
      -2353342684412443330L

    • Class java.io.UncheckedIOException extends RuntimeException implements Serializable

      serialVersionUID:
      -8134305061645241065L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Called to read the object from a stream.
          Throws:
          InvalidObjectException - if the object is invalid or has a cause that is not an IOException
          IOException
          ClassNotFoundException

    • Class java.io.UnsupportedEncodingException extends IOException implements Serializable

      serialVersionUID:
      -4274276298326136670L

    • Class java.io.UTFDataFormatException extends IOException implements Serializable

      serialVersionUID:
      420743449228280612L

    • Class java.io.WriteAbortedException extends ObjectStreamException implements Serializable

      serialVersionUID:
      -3326426625597282442L

      • Serialized Fields

        • detail

          Exception detail
          Exception that was caught while writing the ObjectStream.

          This field predates the general-purpose exception chaining facility. The Throwable.getCause() method is now the preferred means of obtaining this information.

  • Package java.lang

    • Class java.lang.AbstractMethodError extends IncompatibleClassChangeError implements Serializable

      serialVersionUID:
      -1654391082989018462L

    • Class java.lang.ArithmeticException extends RuntimeException implements Serializable

      serialVersionUID:
      2256477558314496007L

    • Class java.lang.ArrayIndexOutOfBoundsException extends IndexOutOfBoundsException implements Serializable

      serialVersionUID:
      -5116101128118950844L

    • Class java.lang.ArrayStoreException extends RuntimeException implements Serializable

      serialVersionUID:
      -4522193890499838241L

    • Class java.lang.AssertionError extends Error implements Serializable

      serialVersionUID:
      -5013299493970297370L

    • Class java.lang.Boolean extends Object implements Serializable

      serialVersionUID:
      -3665804199014368530L

      • Serialized Fields

        • value

          boolean value
          The value of the Boolean.

    • Class java.lang.BootstrapMethodError extends LinkageError implements Serializable

      serialVersionUID:
      292L

    • Class java.lang.Byte extends Number implements Serializable

      serialVersionUID:
      -7183698231559129828L

      • Serialized Fields

        • value

          byte value
          The value of the Byte.

    • Class java.lang.Character extends Object implements Serializable

      serialVersionUID:
      3786198910865385080L

      • Serialized Fields

        • value

          char value
          The value of the Character.

    • Class java.lang.Class extends Object implements Serializable

      serialVersionUID:
      3206093459760846163L

      • Serialization Overview

        • Class Class is special cased within the Serialization Stream Protocol. A Class instance is written initially into an ObjectOutputStream in the following format:
                 TC_CLASS ClassDescriptor
      A ClassDescriptor is a special cased serialization of
      a  java.io.ObjectStreamClass instance.
          A new handle is generated for the initial time the class descriptor is written into the stream. Future references to the class descriptor are written as references to the initial class descriptor instance.
          See Also:
          ObjectStreamClass

    • Class java.lang.ClassCastException extends RuntimeException implements Serializable

      serialVersionUID:
      -9223365651070458532L

    • Class java.lang.ClassCircularityError extends LinkageError implements Serializable

      serialVersionUID:
      1054362542914539689L

    • Class java.lang.ClassFormatError extends LinkageError implements Serializable

      serialVersionUID:
      -8420114879011949195L

    • Class java.lang.ClassNotFoundException extends ReflectiveOperationException implements Serializable

      serialVersionUID:
      9176873029745254542L

      • Serialized Fields

        • ex

          Throwable ex
          This field holds the exception ex if the ClassNotFoundException(String s, Throwable ex) constructor was used to instantiate the object
          Since:
          1.2

    • Class java.lang.CloneNotSupportedException extends Exception implements Serializable

      serialVersionUID:
      5195511250079656443L

    • Class java.lang.Double extends Number implements Serializable

      serialVersionUID:
      -9172774392245257468L

      • Serialized Fields

        • value

          double value
          The value of the Double.

    • Class java.lang.Enum extends Object implements Serializable

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          prevent default deserialization
          Throws:
          IOException
          ClassNotFoundException

        • readObjectNoData

          private void readObjectNoData()
                       throws ObjectStreamException
          Throws:
          ObjectStreamException

      • Serialized Fields

        • name

          String name
          The name of this enum constant, as declared in the enum declaration. Most programmers should use the Enum.toString() method rather than accessing this field.

        • ordinal

          int ordinal
          The ordinal of this enumeration constant (its position in the enum declaration, where the initial constant is assigned an ordinal of zero). Most programmers will have no use for this field. It is designed for use by sophisticated enum-based data structures, such as EnumSet and EnumMap.

    • Class java.lang.EnumConstantNotPresentException extends RuntimeException implements Serializable

      serialVersionUID:
      -6046998521960521108L

      • Serialized Fields

        • enumType

          Class<T> enumType
          The type of the missing enum constant.

        • constantName

          String constantName
          The name of the missing enum constant.

    • Class java.lang.Error extends Throwable implements Serializable

      serialVersionUID:
      4980196508277280342L

    • Class java.lang.Exception extends Throwable implements Serializable

      serialVersionUID:
      -3387516993124229948L

    • Class java.lang.ExceptionInInitializerError extends LinkageError implements Serializable

      serialVersionUID:
      1521711792217232256L

      • Serialized Fields

        • exception

          Throwable exception
          This field holds the exception if the ExceptionInInitializerError(Throwable thrown) constructor was used to instantiate the object

    • Class java.lang.Float extends Number implements Serializable

      serialVersionUID:
      -2671257302660747028L

      • Serialized Fields

        • value

          float value
          The value of the Float.

    • Class java.lang.IllegalAccessError extends IncompatibleClassChangeError implements Serializable

      serialVersionUID:
      -8988904074992417891L

    • Class java.lang.IllegalAccessException extends ReflectiveOperationException implements Serializable

      serialVersionUID:
      6616958222490762034L

    • Class java.lang.IllegalArgumentException extends RuntimeException implements Serializable

      serialVersionUID:
      -5365630128856068164L

    • Class java.lang.IllegalMonitorStateException extends RuntimeException implements Serializable

      serialVersionUID:
      3713306369498869069L

    • Class java.lang.IllegalStateException extends RuntimeException implements Serializable

      serialVersionUID:
      -1848914673093119416L

    • Class java.lang.IllegalThreadStateException extends IllegalArgumentException implements Serializable

      serialVersionUID:
      -7626246362397460174L

    • Class java.lang.IncompatibleClassChangeError extends LinkageError implements Serializable

      serialVersionUID:
      -4914975503642802119L

    • Class java.lang.IndexOutOfBoundsException extends RuntimeException implements Serializable

      serialVersionUID:
      234122996006267687L

    • Class java.lang.InstantiationError extends IncompatibleClassChangeError implements Serializable

      serialVersionUID:
      -4885810657349421204L

    • Class java.lang.InstantiationException extends ReflectiveOperationException implements Serializable

      serialVersionUID:
      -8441929162975509110L

    • Class java.lang.Integer extends Number implements Serializable

      serialVersionUID:
      1360826667806852920L

      • Serialized Fields

        • value

          int value
          The value of the Integer.

    • Class java.lang.InternalError extends VirtualMachineError implements Serializable

      serialVersionUID:
      -9062593416125562365L

    • Class java.lang.InterruptedException extends Exception implements Serializable

      serialVersionUID:
      6700697376100628473L

    • Class java.lang.LinkageError extends Error implements Serializable

      serialVersionUID:
      3579600108157160122L

    • Class java.lang.Long extends Number implements Serializable

      serialVersionUID:
      4290774380558885855L

      • Serialized Fields

        • value

          long value
          The value of the Long.

    • Class java.lang.NegativeArraySizeException extends RuntimeException implements Serializable

      serialVersionUID:
      -8960118058596991861L

    • Class java.lang.NoClassDefFoundError extends LinkageError implements Serializable

      serialVersionUID:
      9095859863287012458L

    • Class java.lang.NoSuchFieldError extends IncompatibleClassChangeError implements Serializable

      serialVersionUID:
      -3456430195886129035L

    • Class java.lang.NoSuchFieldException extends ReflectiveOperationException implements Serializable

      serialVersionUID:
      -6143714805279938260L

    • Class java.lang.NoSuchMethodError extends IncompatibleClassChangeError implements Serializable

      serialVersionUID:
      -3765521442372831335L

    • Class java.lang.NoSuchMethodException extends ReflectiveOperationException implements Serializable

      serialVersionUID:
      5034388446362600923L

    • Class java.lang.NullPointerException extends RuntimeException implements Serializable

      serialVersionUID:
      5162710183389028792L

    • Class java.lang.Number extends Object implements Serializable

      serialVersionUID:
      -8742448824652078965L

    • Class java.lang.NumberFormatException extends IllegalArgumentException implements Serializable

      serialVersionUID:
      -2848938806368998894L

    • Class java.lang.OutOfMemoryError extends VirtualMachineError implements Serializable

      serialVersionUID:
      8228564086184010517L

    • Class java.lang.ReflectiveOperationException extends Exception implements Serializable

      serialVersionUID:
      123456789L

    • Class java.lang.RuntimeException extends Exception implements Serializable

      serialVersionUID:
      -7034897190745766939L

    • Class java.lang.RuntimePermission extends BasicPermission implements Serializable

      serialVersionUID:
      7399184964622342223L

    • Class java.lang.SecurityException extends RuntimeException implements Serializable

      serialVersionUID:
      6878364983674394167L

    • Class java.lang.Short extends Number implements Serializable

      serialVersionUID:
      7515723908773894738L

      • Serialized Fields

        • value

          short value
          The value of the Short.

    • Class java.lang.StackOverflowError extends VirtualMachineError implements Serializable

      serialVersionUID:
      8609175038441759607L

    • Class java.lang.StackTraceElement extends Object implements Serializable

      serialVersionUID:
      6992337162326171013L

      • Serialized Fields

        • declaringClass

          String declaringClass

        • methodName

          String methodName

        • fileName

          String fileName

        • lineNumber

          int lineNumber

    • Class java.lang.String extends Object implements Serializable

      serialVersionUID:
      -6849794470754667710L

      • Serialization Overview

        • Class String is special cased within the Serialization Stream Protocol. A String instance is written into an ObjectOutputStream according to Object Serialization Specification, Section 6.2, "Stream Elements"

    • Class java.lang.StringBuffer extends java.lang.AbstractStringBuilder implements Serializable

      serialVersionUID:
      3388685877147921107L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          readObject is called to restore the state of the StringBuffer from a stream.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          readObject is called to restore the state of the StringBuffer from a stream.
          Throws:
          IOException

      • Serialization Overview

        • Serializable fields for StringBuffer.

      • Serialized Fields

        • count

          int count
          The number of characters in this StringBuffer.

        • shared

          boolean shared
          A flag indicating whether the backing array is shared. The value is ignored upon deserialization.

        • value

          char[] value
          The backing character array of this StringBuffer.

    • Class java.lang.StringBuilder extends java.lang.AbstractStringBuilder implements Serializable

      serialVersionUID:
      4383685877147921099L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          readObject is called to restore the state of the StringBuffer from a stream.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Save the state of the StringBuilder instance to a stream (that is, serialize it).
          Serial Data:
          the number of characters currently stored in the string builder (int), followed by the characters in the string builder (char[]). The length of the char array may be greater than the number of characters currently stored in the string builder, in which case extra characters are ignored.
          Throws:
          IOException

    • Class java.lang.StringIndexOutOfBoundsException extends IndexOutOfBoundsException implements Serializable

      serialVersionUID:
      -6762910422159637258L

    • Class java.lang.ThreadDeath extends Error implements Serializable

      serialVersionUID:
      -4417128565033088268L

    • Class java.lang.Throwable extends Object implements Serializable

      serialVersionUID:
      -3042686055658047285L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Reads a Throwable from a stream, enforcing well-formedness constraints on fields. Null entries and self-pointers are not allowed in the list of suppressedExceptions. Null entries are not allowed for stack trace elements. A null stack trace in the serial form results in a zero-length stack element array. A single-element stack trace whose entry is equal to new StackTraceElement("", "", null, Integer.MIN_VALUE) results in a null stackTrace field. Note that there are no constraints on the value the cause field can hold; both null and this are valid values for the field.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Write a Throwable object to a stream. A null stack trace field is represented in the serial form as a one-element array whose element is equal to new StackTraceElement("", "", null, Integer.MIN_VALUE).
          Throws:
          IOException

      • Serialized Fields

        • detailMessage

          String detailMessage
          Specific details about the Throwable. For example, for FileNotFoundException, this contains the name of the file that could not be found.

        • cause

          Throwable cause
          The throwable that caused this throwable to get thrown, or null if this throwable was not caused by another throwable, or if the causative throwable is unknown. If this field is equal to this throwable itself, it indicates that the cause of this throwable has not yet been initialized.
          Since:
          1.4

        • stackTrace

          StackTraceElement[] stackTrace
          The stack trace, as returned by Throwable.getStackTrace(). The field is initialized to a zero-length array. A null value of this field indicates subsequent calls to Throwable.setStackTrace(StackTraceElement[]) and Throwable.fillInStackTrace() will be be no-ops.
          Since:
          1.4

        • suppressedExceptions

          List<E> suppressedExceptions
          The list of suppressed exceptions, as returned by Throwable.getSuppressed(). The list is initialized to a zero-element unmodifiable sentinel list. When a serialized Throwable is read in, if the suppressedExceptions field points to a zero-element list, the field is reset to the sentinel value.
          Since:
          1.7

    • Class java.lang.TypeNotPresentException extends RuntimeException implements Serializable

      serialVersionUID:
      -5101214195716534496L

      • Serialized Fields

        • typeName

          String typeName

    • Class java.lang.UnknownError extends VirtualMachineError implements Serializable

      serialVersionUID:
      2524784860676771849L

    • Class java.lang.UnsatisfiedLinkError extends LinkageError implements Serializable

      serialVersionUID:
      -4019343241616879428L

    • Class java.lang.UnsupportedClassVersionError extends ClassFormatError implements Serializable

      serialVersionUID:
      -7123279212883497373L

    • Class java.lang.UnsupportedOperationException extends RuntimeException implements Serializable

      serialVersionUID:
      -1242599979055084673L

    • Class java.lang.VerifyError extends LinkageError implements Serializable

      serialVersionUID:
      7001962396098498785L

    • Class java.lang.VirtualMachineError extends Error implements Serializable

      serialVersionUID:
      4161983926571568670L

  • Package java.lang.annotation

    • Class java.lang.annotation.AnnotationFormatError extends Error implements Serializable

      serialVersionUID:
      -4256701562333669892L

    • Class java.lang.annotation.AnnotationTypeMismatchException extends RuntimeException implements Serializable

      serialVersionUID:
      8125925355765570191L

      • Serialized Fields

        • element

          Method element
          The Method object for the annotation element.

        • foundType

          String foundType
          The (erroneous) type of data found in the annotation. This string may, but is not required to, contain the value as well. The exact format of the string is unspecified.

    • Class java.lang.annotation.IncompleteAnnotationException extends RuntimeException implements Serializable

      serialVersionUID:
      8445097402741811912L

      • Serialized Fields

        • annotationType

          Class<T> annotationType

        • elementName

          String elementName

  • Package java.lang.instrument

    • Class java.lang.instrument.IllegalClassFormatException extends Exception implements Serializable

      serialVersionUID:
      -3841736710924794009L

    • Class java.lang.instrument.UnmodifiableClassException extends Exception implements Serializable

      serialVersionUID:
      1716652643585309178L

  • Package java.lang.invoke

    • Class java.lang.invoke.LambdaConversionException extends Exception implements Serializable

      serialVersionUID:
      300L

    • Class java.lang.invoke.MethodType extends Object implements Serializable

      serialVersionUID:
      292L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Reconstitute the MethodType instance from a stream (that is, deserialize it). This instance is a scratch object with bogus final fields. It provides the parameters to the factory method called by readResolve. After that call it is discarded.
          Throws:
          IOException - if there is a problem reading the object
          ClassNotFoundException - if one of the component classes cannot be resolved
          See Also:
          MethodType.MethodType(),
MethodType.readResolve(),
MethodType.writeObject(java.io.ObjectOutputStream)

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Save the MethodType instance to a stream.
          Serial Data:
          For portability, the serialized format does not refer to named fields. Instead, the return type and parameter type arrays are written directly from the writeObject method, using two calls to s.writeObject as follows:

s.writeObject(this.returnType());
s.writeObject(this.parameterArray());

          The deserialized field values are checked as if they were provided to the factory method methodType. For example, null values, or void parameter types, will lead to exceptions during deserialization.

          Throws:
          IOException - if there is a problem writing the object

        • readResolve

          private Object readResolve()
          Resolves and initializes a MethodType object after serialization.

      • Serialization Overview

        • There are no serializable fields for MethodType.

    • Class java.lang.invoke.SerializedLambda extends Object implements Serializable

      serialVersionUID:
      8025925345765570181L

      • Serialization Methods

        • readResolve

          private Object readResolve()
                    throws ReflectiveOperationException
          Throws:
          ReflectiveOperationException

      • Serialized Fields

        • capturingClass

          Class<T> capturingClass

        • functionalInterfaceClass

          String functionalInterfaceClass

        • functionalInterfaceMethodName

          String functionalInterfaceMethodName

        • functionalInterfaceMethodSignature

          String functionalInterfaceMethodSignature

        • implClass

          String implClass

        • implMethodName

          String implMethodName

        • implMethodSignature

          String implMethodSignature

        • implMethodKind

          int implMethodKind

        • instantiatedMethodType

          String instantiatedMethodType

        • capturedArgs

          Object[] capturedArgs

    • Class java.lang.invoke.WrongMethodTypeException extends RuntimeException implements Serializable

      serialVersionUID:
      292L

  • Package java.lang.management

    • Class java.lang.management.ManagementPermission extends BasicPermission implements Serializable

      serialVersionUID:
      1897496590799378737L

  • Package java.lang.reflect

    • Class java.lang.reflect.GenericSignatureFormatError extends ClassFormatError implements Serializable

      serialVersionUID:
      6709919147137911034L

    • Class java.lang.reflect.InvocationTargetException extends ReflectiveOperationException implements Serializable

      serialVersionUID:
      4085088731926701167L

      • Serialized Fields

        • target

          Throwable target
          This field holds the target if the InvocationTargetException(Throwable target) constructor was used to instantiate the object

    • Class java.lang.reflect.MalformedParameterizedTypeException extends RuntimeException implements Serializable

      serialVersionUID:
      -5696557788586220964L

    • Class java.lang.reflect.MalformedParametersException extends RuntimeException implements Serializable

      serialVersionUID:
      20130919L

    • Class java.lang.reflect.Proxy extends Object implements Serializable

      serialVersionUID:
      -2222568056686623797L

      • Serialized Fields

        • h

          InvocationHandler h
          the invocation handler for this proxy instance.

    • Class java.lang.reflect.ReflectPermission extends BasicPermission implements Serializable

      serialVersionUID:
      7412737110241507485L

    • Class java.lang.reflect.UndeclaredThrowableException extends RuntimeException implements Serializable

      serialVersionUID:
      330127114055056639L

      • Serialized Fields

        • undeclaredThrowable

          Throwable undeclaredThrowable
          the undeclared checked exception that was thrown

  • Package java.math

    • Class java.math.BigDecimal extends Number implements Serializable

      serialVersionUID:
      6108874887143696463L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Reconstitute the BigDecimal instance from a stream (that is, deserialize it).
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Serialize this BigDecimal to the stream in question
          Throws:
          IOException

      • Serialized Fields

        • intVal

          BigInteger intVal
          The unscaled value of this BigDecimal, as returned by BigDecimal.unscaledValue().
          See Also:
          BigDecimal.unscaledValue()

        • scale

          int scale
          The scale of this BigDecimal, as returned by BigDecimal.scale.
          See Also:
          BigDecimal.scale

    • Class java.math.BigInteger extends Number implements Serializable

      serialVersionUID:
      -8287574255936472291L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Reconstitute the BigInteger instance from a stream (that is, deserialize it). The magnitude is read in as an array of bytes for historical reasons, but it is converted to an array of ints and the byte array is discarded. Note: The current convention is to initialize the cache fields, bitCount, bitLength and lowestSetBit, to 0 rather than some other marker value. Therefore, no explicit action to set these fields needs to be taken in readObject because those fields already have a 0 value be default since defaultReadObject is not being used.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Save the BigInteger instance to a stream. The magnitude of a BigInteger is serialized as a byte array for historical reasons.
          Serial Data:
          two necessary fields are written as well as obsolete fields for compatibility with older versions.
          Throws:
          IOException

      • Serialization Overview

        • Serializable fields for BigInteger.

      • Serialized Fields

        • bitCount

          int bitCount
          number of bits in this BigInteger

        • bitLength

          int bitLength
          the number of bits in the minimal two's-complement representation of this BigInteger

        • lowestSetBit

          int lowestSetBit
          lowest set bit in the twos complement representation

        • magnitude

          int[] magnitude
          magnitude array of this BigInteger.

        • signum

          int signum
          signum of this BigInteger.

    • Class java.math.MathContext extends Object implements Serializable

      serialVersionUID:
      5579720004786848255L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Reconstitute the MathContext instance from a stream (that is, deserialize it).
          Throws:
          IOException
          ClassNotFoundException

      • Serialized Fields

        • precision

          int precision
          The number of digits to be used for an operation. A value of 0 indicates that unlimited precision (as many digits as are required) will be used. Note that leading zeros (in the coefficient of a number) are never significant.

          precision will always be non-negative.

        • roundingMode

          RoundingMode roundingMode
          The rounding algorithm to be used for an operation.
          See Also:
          RoundingMode

  • Package java.net

    • Class java.net.BindException extends SocketException implements Serializable

      serialVersionUID:
      -5945005768251722951L

    • Class java.net.ConnectException extends SocketException implements Serializable

      serialVersionUID:
      3831404271622369215L

    • Class java.net.HttpRetryException extends IOException implements Serializable

      serialVersionUID:
      -9186022286469111381L

      • Serialized Fields

        • responseCode

          int responseCode

        • location

          String location

    • Class java.net.Inet4Address extends InetAddress implements Serializable

      serialVersionUID:
      3286316764910316507L

      • Serialization Methods

        • writeReplace

          private Object writeReplace()
                     throws ObjectStreamException
          Replaces the object to be serialized with an InetAddress object.
          Throws:
          ObjectStreamException - if a new object replacing this object could not be created

    • Class java.net.Inet6Address extends InetAddress implements Serializable

      serialVersionUID:
      6880410070516793377L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          restore the state of this object from stream including the scope information, only if the scoped interface name is valid on this system
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          default behavior is overridden in order to write the scope_ifname field as a String, rather than a NetworkInterface which is not serializable
          Throws:
          IOException

      • Serialized Fields

        • ifname

          String ifname

        • ipaddress

          byte[] ipaddress

        • scope_id

          int scope_id

        • scope_id_set

          boolean scope_id_set

        • scope_ifname_set

          boolean scope_ifname_set

    • Class java.net.InetAddress extends Object implements Serializable

      serialVersionUID:
      3286316764910316507L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Throws:
          IOException

        • readResolve

          private Object readResolve()
                    throws ObjectStreamException
          Replaces the de-serialized object with an Inet4Address object.
          Throws:
          ObjectStreamException - if a new object replacing this object could not be created

        • readObjectNoData

          private void readObjectNoData(ObjectInputStream s)
                       throws IOException,
                              ClassNotFoundException
          Throws:
          IOException
          ClassNotFoundException

      • Serialized Fields

        • address

          int address

        • family

          int family

        • hostName

          String hostName

    • Class java.net.InetSocketAddress extends SocketAddress implements Serializable

      serialVersionUID:
      5076001401234631237L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream out)
                  throws IOException
          Throws:
          IOException

        • readObjectNoData

          private void readObjectNoData()
                       throws ObjectStreamException
          Throws:
          ObjectStreamException

      • Serialized Fields

        • addr

          InetAddress addr

        • hostname

          String hostname

        • port

          int port

    • Class java.net.MalformedURLException extends IOException implements Serializable

      serialVersionUID:
      -182787522200415866L

    • Class java.net.NetPermission extends BasicPermission implements Serializable

      serialVersionUID:
      -8343910153355041693L

    • Class java.net.NoRouteToHostException extends SocketException implements Serializable

      serialVersionUID:
      -1897550894873493790L

    • Class java.net.PortUnreachableException extends SocketException implements Serializable

      serialVersionUID:
      8462541992376507323L

    • Class java.net.ProtocolException extends IOException implements Serializable

      serialVersionUID:
      -6098449442062388080L

    • Class java.net.SocketAddress extends Object implements Serializable

      serialVersionUID:
      5215720748342549866L

    • Class java.net.SocketException extends IOException implements Serializable

      serialVersionUID:
      -5935874303556886934L

    • Class java.net.SocketPermissionCollection extends PermissionCollection implements Serializable

      serialVersionUID:
      2787186408602843674L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream out)
                  throws IOException
          Serial Data:
          "permissions" field (a Vector containing the SocketPermissions).
          Throws:
          IOException

      • Serialized Fields

        • permissions

          Vector<E> permissions
          A list of the SocketPermissions for this set.

    • Class java.net.SocketTimeoutException extends InterruptedIOException implements Serializable

      serialVersionUID:
      -8846654841826352300L

    • Class java.net.UnknownHostException extends IOException implements Serializable

      serialVersionUID:
      -4639126076052875403L

    • Class java.net.UnknownServiceException extends IOException implements Serializable

      serialVersionUID:
      -4169033248853639508L

    • Class java.net.URI extends Object implements Serializable

      serialVersionUID:
      -6052424284110960213L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream is)
                 throws ClassNotFoundException,
                        IOException
          Reconstitutes a URI from the given serial stream.

          The ObjectInputStream.defaultReadObject() method is invoked to read the value of the string field. The result is then parsed in the usual way.

          Throws:
          ClassNotFoundException
          IOException

        • writeObject

          private void writeObject(ObjectOutputStream os)
                  throws IOException
          Saves the content of this URI to the given serial stream.

          The only serializable field of a URI instance is its string field. That field is given a value, if it does not have one already, and then the ObjectOutputStream.defaultWriteObject() method of the given object-output stream is invoked.

          Throws:
          IOException

      • Serialized Fields

        • string

          String string
          The string form of this URI.

    • Class java.net.URISyntaxException extends Exception implements Serializable

      serialVersionUID:
      2137979680897488891L

      • Serialized Fields

        • input

          String input

        • index

          int index

    • Class java.net.URL extends Object implements Serializable

      serialVersionUID:
      -7627629688361524110L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          readObject is called to restore the state of the URL from the stream. It reads the components of the URL and finds the local stream handler.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          WriteObject is called to save the state of the URL to an ObjectOutputStream. The handler is not saved since it is specific to this system.
          Serial Data:
          the default write object value. When read back in, the reader must ensure that calling getURLStreamHandler with the protocol variable returns a valid URLStreamHandler and throw an IOException if it does not.
          Throws:
          IOException

      • Serialized Fields

        • protocol

          String protocol
          The protocol to use (ftp, http, nntp, ... etc.) .

        • host

          String host
          The host name to connect to.

        • port

          int port
          The protocol port to connect to.

        • file

          String file
          The specified file name on that host. file is defined as path[?query]

        • authority

          String authority
          The authority part of this URL.

        • ref

          String ref
          # reference.

        • hashCode

          int hashCode

    • Class java.net.URLPermission extends Permission implements Serializable

      serialVersionUID:
      -2702463814894478682L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          restore the state of this object from stream
          Throws:
          IOException
          ClassNotFoundException

      • Serialized Fields

        • actions

          String actions

  • Package java.nio

    • Class java.nio.BufferOverflowException extends RuntimeException implements Serializable

      serialVersionUID:
      -5484897634319144535L

    • Class java.nio.BufferUnderflowException extends RuntimeException implements Serializable

      serialVersionUID:
      -1713313658691622206L

    • Class java.nio.InvalidMarkException extends IllegalStateException implements Serializable

      serialVersionUID:
      1698329710438510774L

    • Class java.nio.ReadOnlyBufferException extends UnsupportedOperationException implements Serializable

      serialVersionUID:
      -1210063976496234090L

  • Package java.nio.channels

    • Class java.nio.channels.AcceptPendingException extends IllegalStateException implements Serializable

      serialVersionUID:
      2721339977965416421L

    • Class java.nio.channels.AlreadyBoundException extends IllegalStateException implements Serializable

      serialVersionUID:
      6796072983322737592L

    • Class java.nio.channels.AlreadyConnectedException extends IllegalStateException implements Serializable

      serialVersionUID:
      -7331895245053773357L

    • Class java.nio.channels.AsynchronousCloseException extends ClosedChannelException implements Serializable

      serialVersionUID:
      6891178312432313966L

    • Class java.nio.channels.CancelledKeyException extends IllegalStateException implements Serializable

      serialVersionUID:
      -8438032138028814268L

    • Class java.nio.channels.ClosedByInterruptException extends AsynchronousCloseException implements Serializable

      serialVersionUID:
      -4488191543534286750L

    • Class java.nio.channels.ClosedChannelException extends IOException implements Serializable

      serialVersionUID:
      882777185433553857L

    • Class java.nio.channels.ClosedSelectorException extends IllegalStateException implements Serializable

      serialVersionUID:
      6466297122317847835L

    • Class java.nio.channels.ConnectionPendingException extends IllegalStateException implements Serializable

      serialVersionUID:
      2008393366501760879L

    • Class java.nio.channels.FileLockInterruptionException extends IOException implements Serializable

      serialVersionUID:
      7104080643653532383L

    • Class java.nio.channels.IllegalBlockingModeException extends IllegalStateException implements Serializable

      serialVersionUID:
      -3335774961855590474L

    • Class java.nio.channels.IllegalChannelGroupException extends IllegalArgumentException implements Serializable

      serialVersionUID:
      -2495041211157744253L

    • Class java.nio.channels.IllegalSelectorException extends IllegalArgumentException implements Serializable

      serialVersionUID:
      -8406323347253320987L

    • Class java.nio.channels.InterruptedByTimeoutException extends IOException implements Serializable

      serialVersionUID:
      -4268008601014042947L

    • Class java.nio.channels.NoConnectionPendingException extends IllegalStateException implements Serializable

      serialVersionUID:
      -8296561183633134743L

    • Class java.nio.channels.NonReadableChannelException extends IllegalStateException implements Serializable

      serialVersionUID:
      -3200915679294993514L

    • Class java.nio.channels.NonWritableChannelException extends IllegalStateException implements Serializable

      serialVersionUID:
      -7071230488279011621L

    • Class java.nio.channels.NotYetBoundException extends IllegalStateException implements Serializable

      serialVersionUID:
      4640999303950202242L

    • Class java.nio.channels.NotYetConnectedException extends IllegalStateException implements Serializable

      serialVersionUID:
      4697316551909513464L

    • Class java.nio.channels.OverlappingFileLockException extends IllegalStateException implements Serializable

      serialVersionUID:
      2047812138163068433L

    • Class java.nio.channels.ReadPendingException extends IllegalStateException implements Serializable

      serialVersionUID:
      1986315242191227217L

    • Class java.nio.channels.ShutdownChannelGroupException extends IllegalStateException implements Serializable

      serialVersionUID:
      -3903801676350154157L

    • Class java.nio.channels.UnresolvedAddressException extends IllegalArgumentException implements Serializable

      serialVersionUID:
      6136959093620794148L

    • Class java.nio.channels.UnsupportedAddressTypeException extends IllegalArgumentException implements Serializable

      serialVersionUID:
      -2964323842829700493L

    • Class java.nio.channels.WritePendingException extends IllegalStateException implements Serializable

      serialVersionUID:
      7031871839266032276L

  • Package java.nio.charset

    • Class java.nio.charset.CharacterCodingException extends IOException implements Serializable

      serialVersionUID:
      8421532232154627783L

    • Class java.nio.charset.CoderMalfunctionError extends Error implements Serializable

      serialVersionUID:
      -1151412348057794301L

    • Class java.nio.charset.IllegalCharsetNameException extends IllegalArgumentException implements Serializable

      serialVersionUID:
      1457525358470002989L

      • Serialized Fields

        • charsetName

          String charsetName

    • Class java.nio.charset.MalformedInputException extends CharacterCodingException implements Serializable

      serialVersionUID:
      -3438823399834806194L

      • Serialized Fields

        • inputLength

          int inputLength

    • Class java.nio.charset.UnmappableCharacterException extends CharacterCodingException implements Serializable

      serialVersionUID:
      -7026962371537706123L

      • Serialized Fields

        • inputLength

          int inputLength

    • Class java.nio.charset.UnsupportedCharsetException extends IllegalArgumentException implements Serializable

      serialVersionUID:
      1490765524727386367L

      • Serialized Fields

        • charsetName

          String charsetName

  • Package java.nio.file

    • Class java.nio.file.AccessDeniedException extends FileSystemException implements Serializable

      serialVersionUID:
      4943049599949219617L

    • Class java.nio.file.AtomicMoveNotSupportedException extends FileSystemException implements Serializable

      serialVersionUID:
      5402760225333135579L

    • Class java.nio.file.ClosedDirectoryStreamException extends IllegalStateException implements Serializable

      serialVersionUID:
      4228386650900895400L

    • Class java.nio.file.ClosedFileSystemException extends IllegalStateException implements Serializable

      serialVersionUID:
      -8158336077256193488L

    • Class java.nio.file.ClosedWatchServiceException extends IllegalStateException implements Serializable

      serialVersionUID:
      1853336266231677732L

    • Class java.nio.file.DirectoryIteratorException extends ConcurrentModificationException implements Serializable

      serialVersionUID:
      -6012699886086212874L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Called to read the object from a stream.
          Throws:
          InvalidObjectException - if the object is invalid or has a cause that is not an IOException
          IOException
          ClassNotFoundException

    • Class java.nio.file.DirectoryNotEmptyException extends FileSystemException implements Serializable

      serialVersionUID:
      3056667871802779003L

    • Class java.nio.file.FileAlreadyExistsException extends FileSystemException implements Serializable

      serialVersionUID:
      7579540934498831181L

    • Class java.nio.file.FileSystemAlreadyExistsException extends RuntimeException implements Serializable

      serialVersionUID:
      -5438419127181131148L

    • Class java.nio.file.FileSystemException extends IOException implements Serializable

      serialVersionUID:
      -3055425747967319812L

      • Serialized Fields

        • file

          String file

        • other

          String other

    • Class java.nio.file.FileSystemLoopException extends FileSystemException implements Serializable

      serialVersionUID:
      4843039591949217617L

    • Class java.nio.file.FileSystemNotFoundException extends RuntimeException implements Serializable

      serialVersionUID:
      7999581764446402397L

    • Class java.nio.file.InvalidPathException extends IllegalArgumentException implements Serializable

      serialVersionUID:
      4355821422286746137L

      • Serialized Fields

        • input

          String input

        • index

          int index

    • Class java.nio.file.LinkPermission extends BasicPermission implements Serializable

      serialVersionUID:
      -1441492453772213220L

    • Class java.nio.file.NoSuchFileException extends FileSystemException implements Serializable

      serialVersionUID:
      -1390291775875351931L

    • Class java.nio.file.NotDirectoryException extends FileSystemException implements Serializable

      serialVersionUID:
      -9011457427178200199L

    • Class java.nio.file.NotLinkException extends FileSystemException implements Serializable

      serialVersionUID:
      -388655596416518021L

    • Class java.nio.file.ProviderMismatchException extends IllegalArgumentException implements Serializable

      serialVersionUID:
      4990847485741612530L

    • Class java.nio.file.ProviderNotFoundException extends RuntimeException implements Serializable

      serialVersionUID:
      -1880012509822920354L

    • Class java.nio.file.ReadOnlyFileSystemException extends UnsupportedOperationException implements Serializable

      serialVersionUID:
      -6822409595617487197L

  • Package java.nio.file.attribute

    • Class java.nio.file.attribute.UserPrincipalNotFoundException extends IOException implements Serializable

      serialVersionUID:
      -5369283889045833024L

      • Serialized Fields

        • name

          String name

  • Package java.rmi

    • Class java.rmi.AccessException extends RemoteException implements Serializable

      serialVersionUID:
      6314925228044966088L

    • Class java.rmi.AlreadyBoundException extends Exception implements Serializable

      serialVersionUID:
      9218657361741657110L

    • Class java.rmi.ConnectException extends RemoteException implements Serializable

      serialVersionUID:
      4863550261346652506L

    • Class java.rmi.ConnectIOException extends RemoteException implements Serializable

      serialVersionUID:
      -8087809532704668744L

    • Class java.rmi.MarshalException extends RemoteException implements Serializable

      serialVersionUID:
      6223554758134037936L

    • Class java.rmi.MarshalledObject extends Object implements Serializable

      serialVersionUID:
      8988374069173025854L

      • Serialized Fields

        • objBytes

          byte[] objBytes
          Bytes of serialized representation. If objBytes is null then the object marshalled was a null reference.

        • locBytes

          byte[] locBytes
          Bytes of location annotations, which are ignored by equals. If locBytes is null, there were no non-null annotations during marshalling.

        • hash

          int hash
          Stored hash code of contained object.
          See Also:
          MarshalledObject.hashCode()

    • Class java.rmi.NoSuchObjectException extends RemoteException implements Serializable

      serialVersionUID:
      6619395951570472985L

    • Class java.rmi.NotBoundException extends Exception implements Serializable

      serialVersionUID:
      -1857741824849069317L

    • Class java.rmi.RemoteException extends IOException implements Serializable

      serialVersionUID:
      -5148567311918794206L

      • Serialized Fields

        • detail

          Throwable detail
          The cause of the remote exception.

          This field predates the general-purpose exception chaining facility. The Throwable.getCause() method is now the preferred means of obtaining this information.

    • Class java.rmi.RMISecurityException extends SecurityException implements Serializable

      serialVersionUID:
      -8433406075740433514L

    • Class java.rmi.ServerError extends RemoteException implements Serializable

      serialVersionUID:
      8455284893909696482L

    • Class java.rmi.ServerException extends RemoteException implements Serializable

      serialVersionUID:
      -4775845313121906682L

    • Class java.rmi.ServerRuntimeException extends RemoteException implements Serializable

      serialVersionUID:
      7054464920481467219L

    • Class java.rmi.StubNotFoundException extends RemoteException implements Serializable

      serialVersionUID:
      -7088199405468872373L

    • Class java.rmi.UnexpectedException extends RemoteException implements Serializable

      serialVersionUID:
      1800467484195073863L

    • Class java.rmi.UnknownHostException extends RemoteException implements Serializable

      serialVersionUID:
      -8152710247442114228L

    • Class java.rmi.UnmarshalException extends RemoteException implements Serializable

      serialVersionUID:
      594380845140740218L

  • Package java.rmi.activation

    • Class java.rmi.activation.ActivateFailedException extends RemoteException implements Serializable

      serialVersionUID:
      4863550261346652506L

    • Class java.rmi.activation.ActivationDesc extends Object implements Serializable

      serialVersionUID:
      7455834104417690957L

      • Serialized Fields

        • groupID

          ActivationGroupID groupID
          the group's identifier

        • className

          String className
          the object's class name

        • location

          String location
          the object's code location

        • data

          MarshalledObject<T> data
          the object's initialization data

        • restart

          boolean restart
          indicates whether the object should be restarted

    • Class java.rmi.activation.ActivationException extends Exception implements Serializable

      serialVersionUID:
      -4320118837291406071L

      • Serialized Fields

        • detail

          Throwable detail
          The cause of the activation exception.

          This field predates the general-purpose exception chaining facility. The Throwable.getCause() method is now the preferred means of obtaining this information.

    • Class java.rmi.activation.ActivationGroup extends UnicastRemoteObject implements Serializable

      serialVersionUID:
      -7696947875314805420L

      • Serialized Fields

        • groupID

          ActivationGroupID groupID
          the group's identifier

        • monitor

          ActivationMonitor monitor
          the group's monitor

        • incarnation

          long incarnation
          the group's incarnation number

    • Class java.rmi.activation.ActivationGroup_Stub extends RemoteStub implements Serializable

    • Class java.rmi.activation.ActivationGroupDesc extends Object implements Serializable

      serialVersionUID:
      -4936225423168276595L

      • Serialized Fields

        • className

          String className
          The group's fully package qualified class name.

        • location

          String location
          The location from where to load the group's class.

        • data

          MarshalledObject<T> data
          The group's initialization data.

        • env

          ActivationGroupDesc.CommandEnvironment env
          The controlling options for executing the VM in another process.

        • props

          Properties props
          A properties map which will override those set by default in the subprocess environment.

    • Class java.rmi.activation.ActivationGroupDesc.CommandEnvironment extends Object implements Serializable

      serialVersionUID:
      6165754737887770191L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          readObject for custom serialization.

          This method reads this object's serialized form for this class as follows:

          This method first invokes defaultReadObject on the specified object input stream, and if options is null, then options is set to a zero-length array of String.

          Throws:
          IOException
          ClassNotFoundException

      • Serialized Fields

        • command

          String command

        • options

          String[] options

    • Class java.rmi.activation.ActivationGroupID extends Object implements Serializable

      serialVersionUID:
      -1648432278909740833L

      • Serialized Fields

        • system

          ActivationSystem system
          The group's activation system.

        • uid

          UID uid
          The group's unique id.

    • Class java.rmi.activation.ActivationID extends Object implements Serializable

      serialVersionUID:
      -4608673054848209235L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          readObject for custom serialization.

          This method reads this object's serialized form for this class as follows:

          The readObject method is invoked on in to read this object's unique identifier (a UID instance).

          Next, the readUTF method is invoked on in to read the external ref type name of the RemoteRef instance for this object's activator. Next, the RemoteRef instance is created of an implementation-specific class corresponding to the external ref type name (returned by readUTF), and the readExternal method is invoked on that RemoteRef instance to read the external form corresponding to the external ref type name.

          Note: If the external ref type name is "UnicastRef", "UnicastServerRef", "UnicastRef2", "UnicastServerRef2", or "ActivatableRef", a corresponding implementation-specific class must be found, and its readExternal method must read the serial data for that external ref type name as specified to be written in the serialData documentation for this class. If the external ref type name is any other string (of non-zero length), a ClassNotFoundException will be thrown, unless the implementation provides an implementation-specific class corresponding to that external ref type name, in which case the RemoteRef will be an instance of that implementation-specific class.

          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream out)
                  throws IOException,
                         ClassNotFoundException
          writeObject for custom serialization.

          This method writes this object's serialized form for this class as follows:

          The writeObject method is invoked on out passing this object's unique identifier (a UID instance) as the argument.

          Next, the getRefClass method is invoked on the activator's RemoteRef instance to obtain its external ref type name. Next, the writeUTF method is invoked on out with the value returned by getRefClass, and then the writeExternal method is invoked on the RemoteRef instance passing out as the argument.

          Serial Data:
          The serialized data for this class comprises a java.rmi.server.UID (written with ObjectOutput.writeObject) followed by the external ref type name of the activator's RemoteRef instance (a string written with ObjectOutput.writeUTF), followed by the external form of the RemoteRef instance as written by its writeExternal method.

          The external ref type name of the RemoteRef instance is determined using the definitions of external ref type names specified in the RemoteObject writeObject method serialData specification. Similarly, the data written by the writeExternal method and read by the readExternal method of RemoteRef implementation classes corresponding to each of the defined external ref type names is specified in the RemoteObject writeObject method serialData specification.

          Throws:
          IOException
          ClassNotFoundException

    • Class java.rmi.activation.UnknownGroupException extends ActivationException implements Serializable

      serialVersionUID:
      7056094974750002460L

    • Class java.rmi.activation.UnknownObjectException extends ActivationException implements Serializable

      serialVersionUID:
      3425547551622251430L

  • Package java.rmi.dgc

    • Class java.rmi.dgc.Lease extends Object implements Serializable

      serialVersionUID:
      -5713411624328831948L

      • Serialized Fields

        • vmid

          VMID vmid
          Virtual Machine ID with which this Lease is associated.
          See Also:
          Lease.getVMID()

        • value

          long value
          Duration of this lease.
          See Also:
          Lease.getValue()

    • Class java.rmi.dgc.VMID extends Object implements Serializable

      serialVersionUID:
      -538642295484486218L

      • Serialized Fields

        • addr

          byte[] addr
          array of bytes uniquely identifying host created on

        • uid

          UID uid
          unique identifier with respect to host created on

  • Package java.rmi.server

    • Class java.rmi.server.ExportException extends RemoteException implements Serializable

      serialVersionUID:
      -9155485338494060170L

    • Class java.rmi.server.ObjID extends Object implements Serializable

      serialVersionUID:
      -6386392263968365220L

      • Serialized Fields

        • objNum

          long objNum
          object number
          See Also:
          ObjID.hashCode()

        • space

          UID space
          address space identifier (unique to host over time)

    • Class java.rmi.server.RemoteObject extends Object implements Serializable

      serialVersionUID:
      -3215090123894869218L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          readObject for custom serialization.

          This method reads this object's serialized form for this class as follows:

          The readUTF method is invoked on in to read the external ref type name for the RemoteRef instance to be filled in to this object's ref field. If the string returned by readUTF has length zero, the readObject method is invoked on in, and than the value returned by readObject is cast to RemoteRef and this object's ref field is set to that value. Otherwise, this object's ref field is set to a RemoteRef instance that is created of an implementation-specific class corresponding to the external ref type name returned by readUTF, and then the readExternal method is invoked on this object's ref field.

          If the external ref type name is "UnicastRef", "UnicastServerRef", "UnicastRef2", "UnicastServerRef2", or "ActivatableRef", a corresponding implementation-specific class must be found, and its readExternal method must read the serial data for that external ref type name as specified to be written in the serialData documentation for this class. If the external ref type name is any other string (of non-zero length), a ClassNotFoundException will be thrown, unless the implementation provides an implementation-specific class corresponding to that external ref type name, in which case this object's ref field will be set to an instance of that implementation-specific class.

          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream out)
                  throws IOException,
                         ClassNotFoundException
          writeObject for custom serialization.

          This method writes this object's serialized form for this class as follows:

          The getRefClass method is invoked on this object's ref field to obtain its external ref type name. If the value returned by getRefClass was a non-null string of length greater than zero, the writeUTF method is invoked on out with the value returned by getRefClass, and then the writeExternal method is invoked on this object's ref field passing out as the argument; otherwise, the writeUTF method is invoked on out with a zero-length string (""), and then the writeObject method is invoked on out passing this object's ref field as the argument.

          Serial Data:
          The serialized data for this class comprises a string (written with ObjectOutput.writeUTF) that is either the external ref type name of the contained RemoteRef instance (the ref field) or a zero-length string, followed by either the external form of the ref field as written by its writeExternal method if the string was of non-zero length, or the serialized form of the ref field as written by passing it to the serialization stream's writeObject if the string was of zero length.

          If this object is an instance of RemoteStub or RemoteObjectInvocationHandler that was returned from any of the UnicastRemoteObject.exportObject methods and custom socket factories are not used, the external ref type name is "UnicastRef". If this object is an instance of RemoteStub or RemoteObjectInvocationHandler that was returned from any of the UnicastRemoteObject.exportObject methods and custom socket factories are used, the external ref type name is "UnicastRef2". If this object is an instance of RemoteStub or RemoteObjectInvocationHandler that was returned from any of the java.rmi.activation.Activatable.exportObject methods, the external ref type name is "ActivatableRef". If this object is an instance of RemoteStub or RemoteObjectInvocationHandler that was returned from the RemoteObject.toStub method (and the argument passed to toStub was not itself a RemoteStub), the external ref type name is a function of how the remote object passed to toStub was exported, as described above. If this object is an instance of RemoteStub or RemoteObjectInvocationHandler that was originally created via deserialization, the external ref type name is the same as that which was read when this object was deserialized.

          If this object is an instance of java.rmi.server.UnicastRemoteObject that does not use custom socket factories, the external ref type name is "UnicastServerRef". If this object is an instance of UnicastRemoteObject that does use custom socket factories, the external ref type name is "UnicastServerRef2".

          Following is the data that must be written by the writeExternal method and read by the readExternal method of RemoteRef implementation classes that correspond to the each of the defined external ref type names:

          For "UnicastRef":

          • the hostname of the referenced remote object, written by DataOutput.writeUTF(String)
          • the port of the referenced remote object, written by DataOutput.writeInt(int)
          • the data written as a result of calling {link java.rmi.server.ObjID#write(java.io.ObjectOutput)} on the ObjID instance contained in the reference
          • the boolean value false, written by DataOutput.writeBoolean(boolean)

          For "UnicastRef2" with a null client socket factory:

          • the byte value 0x00 (indicating null client socket factory), written by DataOutput.writeByte(int)
          • the hostname of the referenced remote object, written by DataOutput.writeUTF(String)
          • the port of the referenced remote object, written by DataOutput.writeInt(int)
          • the data written as a result of calling {link java.rmi.server.ObjID#write(java.io.ObjectOutput)} on the ObjID instance contained in the reference
          • the boolean value false, written by DataOutput.writeBoolean(boolean)

          For "UnicastRef2" with a non-null client socket factory:

          • the byte value 0x01 (indicating non-null client socket factory), written by DataOutput.writeByte(int)
          • the hostname of the referenced remote object, written by DataOutput.writeUTF(String)
          • the port of the referenced remote object, written by DataOutput.writeInt(int)
          • a client socket factory (object of type java.rmi.server.RMIClientSocketFactory), written by passing it to an invocation of writeObject on the stream instance
          • the data written as a result of calling {link java.rmi.server.ObjID#write(java.io.ObjectOutput)} on the ObjID instance contained in the reference
          • the boolean value false, written by DataOutput.writeBoolean(boolean)

          For "ActivatableRef" with a null nested remote reference:

          • an instance of java.rmi.activation.ActivationID, written by passing it to an invocation of writeObject on the stream instance
          • a zero-length string (""), written by DataOutput.writeUTF(String)

          For "ActivatableRef" with a non-null nested remote reference:

          • an instance of java.rmi.activation.ActivationID, written by passing it to an invocation of writeObject on the stream instance
          • the external ref type name of the nested remote reference, which must be "UnicastRef2", written by DataOutput.writeUTF(String)
          • the external form of the nested remote reference, written by invoking its writeExternal method with the stream instance (see the description of the external form for "UnicastRef2" above)

          For "UnicastServerRef" and "UnicastServerRef2", no data is written by the writeExternal method or read by the readExternal method.

          Throws:
          IOException
          ClassNotFoundException

    • Class java.rmi.server.RemoteObjectInvocationHandler extends RemoteObject implements Serializable

      serialVersionUID:
      2L

      • Serialization Methods

        • readObjectNoData

          private void readObjectNoData()
                       throws InvalidObjectException
          Throws:
          InvalidObjectException - unconditionally

    • Class java.rmi.server.RemoteServer extends RemoteObject implements Serializable

      serialVersionUID:
      -4100238210092549637L

    • Class java.rmi.server.RemoteStub extends RemoteObject implements Serializable

      serialVersionUID:
      -1585587260594494182L

    • Class java.rmi.server.ServerCloneException extends CloneNotSupportedException implements Serializable

      serialVersionUID:
      6617456357664815945L

      • Serialized Fields

        • detail

          Exception detail
          The cause of the exception.

          This field predates the general-purpose exception chaining facility. The Throwable.getCause() method is now the preferred means of obtaining this information.

    • Class java.rmi.server.ServerNotActiveException extends Exception implements Serializable

      serialVersionUID:
      4687940720827538231L

    • Class java.rmi.server.SkeletonMismatchException extends RemoteException implements Serializable

      serialVersionUID:
      -7780460454818859281L

    • Class java.rmi.server.SkeletonNotFoundException extends RemoteException implements Serializable

      serialVersionUID:
      -7860299673822761231L

    • Class java.rmi.server.SocketSecurityException extends ExportException implements Serializable

      serialVersionUID:
      -7622072999407781979L

    • Class java.rmi.server.UID extends Object implements Serializable

      serialVersionUID:
      1086053664494604050L

      • Serialized Fields

        • unique

          int unique
          number that uniquely identifies the VM that this UID was generated in with respect to its host and at the given time

        • time

          long time
          a time (as returned by System.currentTimeMillis()) at which the VM that this UID was generated in was alive

        • count

          short count
          16-bit number to distinguish UID instances created in the same VM with the same time value

    • Class java.rmi.server.UnicastRemoteObject extends RemoteServer implements Serializable

      serialVersionUID:
      4974527148936298033L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          Re-export the remote object when it is deserialized.
          Throws:
          IOException
          ClassNotFoundException

      • Serialized Fields

        • port

          int port
          port number on which to export object

        • csf

          RMIClientSocketFactory csf
          client-side socket factory (if any)

        • ssf

          RMIServerSocketFactory ssf
          server-side socket factory (if any) to use when exporting object

  • Package java.security

    • Class java.security.AccessControlException extends SecurityException implements Serializable

      serialVersionUID:
      5138225684096988535L

      • Serialized Fields

        • perm

          Permission perm

    • Class java.security.AllPermissionCollection extends PermissionCollection implements Serializable

      serialVersionUID:
      -4023755556366636806L

      • Serialized Fields

        • all_allowed

          boolean all_allowed

    • Class java.security.AuthProvider extends Provider implements Serializable

      serialVersionUID:
      4197859053084546461L

    • Class java.security.BasicPermission extends Permission implements Serializable

      serialVersionUID:
      6279438298436773498L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          readObject is called to restore the state of the BasicPermission from a stream.
          Throws:
          IOException
          ClassNotFoundException

    • Class java.security.BasicPermissionCollection extends PermissionCollection implements Serializable

      serialVersionUID:
      739301742472979399L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          readObject is called to restore the state of the BasicPermissionCollection from a stream.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream out)
                  throws IOException
          Serial Data:
          Default fields.
          Throws:
          IOException

      • Serialized Fields

        • all_allowed

          boolean all_allowed
          This is set to {@code true} if this BasicPermissionCollection contains a BasicPermission with '*' as its permission name.

        • permClass

          Class<T> permClass
          The class to which all BasicPermissions in this BasicPermissionCollection belongs.

        • permissions

          Hashtable<K,V> permissions
          The BasicPermissions in this BasicPermissionCollection. All BasicPermissions in the collection must belong to the same class. The Hashtable is indexed by the BasicPermission name; the value of the Hashtable entry is the permission.

    • Class java.security.CodeSigner extends Object implements Serializable

      serialVersionUID:
      6819288105193937581L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
          Throws:
          IOException
          ClassNotFoundException

      • Serialized Fields

        • signerCertPath

          CertPath signerCertPath
          The signer's certificate path.

        • timestamp

          Timestamp timestamp

    • Class java.security.CodeSource extends Object implements Serializable

      serialVersionUID:
      4977541819976013951L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
          Restores this object from a stream (i.e., deserializes it).
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream oos)
                  throws IOException
          Writes this object out to a stream (i.e., serializes it).
          Serial Data:
          An initial URL is followed by an int indicating the number of certificates to follow (a value of "zero" denotes that there are no certificates associated with this object). Each certificate is written out starting with a String denoting the certificate type, followed by an int specifying the length of the certificate encoding, followed by the certificate encoding itself which is written out as an array of bytes. Finally, if any code signers are present then the array of code signers is serialized and written out too.
          Throws:
          IOException

      • Serialized Fields

        • location

          URL location
          The code location.

    • Class java.security.DigestException extends GeneralSecurityException implements Serializable

      serialVersionUID:
      5821450303093652515L

    • Class java.security.GeneralSecurityException extends Exception implements Serializable

      serialVersionUID:
      894798122053539237L

    • Class java.security.GuardedObject extends Object implements Serializable

      serialVersionUID:
      -5240450096227834308L

      • Serialization Methods

        • writeObject

          private void writeObject(ObjectOutputStream oos)
                  throws IOException
          Writes this object out to a stream (i.e., serializes it). We check the guard if there is one.
          Throws:
          IOException

      • Serialized Fields

        • object

          Object object

        • guard

          Guard guard

    • Class java.security.Identity extends Object implements Serializable

      serialVersionUID:
      3609922007826600659L

      • Serialized Fields

        • name

          String name
          Deprecated.
          The name for this identity.

        • publicKey

          PublicKey publicKey
          Deprecated.
          The public key for this identity.

        • info

          String info
          Deprecated.
          Generic, descriptive information about the identity.

        • scope

          IdentityScope scope
          Deprecated.
          The scope of the identity.

        • certificates

          Vector<E> certificates
          Deprecated.
          The certificates for this identity.

    • Class java.security.IdentityScope extends Identity implements Serializable

      serialVersionUID:
      -2337346281189773310L

    • Class java.security.InvalidAlgorithmParameterException extends GeneralSecurityException implements Serializable

      serialVersionUID:
      2864672297499471472L

    • Class java.security.InvalidKeyException extends KeyException implements Serializable

      serialVersionUID:
      5698479920593359816L

    • Class java.security.InvalidParameterException extends IllegalArgumentException implements Serializable

      serialVersionUID:
      -857968536935667808L

    • Class java.security.KeyException extends GeneralSecurityException implements Serializable

      serialVersionUID:
      -7483676942812432108L

    • Class java.security.KeyManagementException extends KeyException implements Serializable

      serialVersionUID:
      947674216157062695L

    • Class java.security.KeyPair extends Object implements Serializable

      serialVersionUID:
      -7565189502268009837L

      • Serialized Fields

        • privateKey

          PrivateKey privateKey

        • publicKey

          PublicKey publicKey

    • Class java.security.KeyRep extends Object implements Serializable

      serialVersionUID:
      -4757683898830641853L

      • Serialization Methods

        • readResolve

          protected Object readResolve()
                      throws ObjectStreamException
          Resolve the Key object.

          This method supports three Type/format combinations:

          • Type.SECRET/"RAW" - returns a SecretKeySpec object constructed using encoded key bytes and algorithm
          • Type.PUBLIC/"X.509" - gets a KeyFactory instance for the key algorithm, constructs an X509EncodedKeySpec with the encoded key bytes, and generates a public key from the spec
          • Type.PRIVATE/"PKCS#8" - gets a KeyFactory instance for the key algorithm, constructs a PKCS8EncodedKeySpec with the encoded key bytes, and generates a private key from the spec

          Throws:
          ObjectStreamException - if the Type/format combination is unrecognized, if the algorithm, key format, or encoded key bytes are unrecognized/invalid, of if the resolution of the key fails for any reason

      • Serialized Fields

        • type

          KeyRep.Type type
          Either one of Type.SECRET, Type.PUBLIC, or Type.PRIVATE

        • algorithm

          String algorithm
          The Key algorithm

        • format

          String format
          The Key encoding format

        • encoded

          byte[] encoded
          The encoded Key bytes

    • Class java.security.KeyStoreException extends GeneralSecurityException implements Serializable

      serialVersionUID:
      -1119353179322377262L

    • Class java.security.NoSuchAlgorithmException extends GeneralSecurityException implements Serializable

      serialVersionUID:
      -7443947487218346562L

    • Class java.security.NoSuchProviderException extends GeneralSecurityException implements Serializable

      serialVersionUID:
      8488111756688534474L

    • Class java.security.Permission extends Object implements Serializable

      serialVersionUID:
      -5636570222231596674L

      • Serialized Fields

        • name

          String name

    • Class java.security.PermissionCollection extends Object implements Serializable

      serialVersionUID:
      -6727011328946861783L

      • Serialized Fields

        • readOnly

          boolean readOnly

    • Class java.security.PermissionsHash extends PermissionCollection implements Serializable

      serialVersionUID:
      -8491988220802933440L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream out)
                  throws IOException
          Serial Data:
          Default fields.
          Throws:
          IOException

      • Serialized Fields

        • perms

          Hashtable<K,V> perms
          A table of the Permissions (both key and value are same).

    • Class java.security.PrivilegedActionException extends Exception implements Serializable

      serialVersionUID:
      4724086851538908602L

      • Serialized Fields

        • exception

          Exception exception

    • Class java.security.Provider extends Properties implements Serializable

      serialVersionUID:
      -4298000515446427739L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          Throws:
          IOException
          ClassNotFoundException

      • Serialized Fields

        • name

          String name
          The provider name.

        • info

          String info
          A description of the provider and its services.

        • version

          double version
          The provider version number.

    • Class java.security.ProviderException extends RuntimeException implements Serializable

      serialVersionUID:
      5256023526693665674L

    • Class java.security.SecureRandom extends Random implements Serializable

      serialVersionUID:
      4940670005562187L

      • Serialized Fields

        • provider

          Provider provider
          The provider.
          Since:
          1.2

        • secureRandomSpi

          SecureRandomSpi secureRandomSpi
          The provider implementation.
          Since:
          1.2

        • algorithm

          String algorithm

        • state

          byte[] state

        • digest

          MessageDigest digest

        • randomBytes

          byte[] randomBytes
          We know that the MessageDigest class does not implement java.io.Serializable. However, since this field is no longer used, it will always be NULL and won't affect the serialization of the SecureRandom class itself.

        • randomBytesUsed

          int randomBytesUsed

        • counter

          long counter

    • Class java.security.SecureRandomSpi extends Object implements Serializable

      serialVersionUID:
      -2991854161009191830L

    • Class java.security.SecurityPermission extends BasicPermission implements Serializable

      serialVersionUID:
      5236109936224050470L

    • Class java.security.SignatureException extends GeneralSecurityException implements Serializable

      serialVersionUID:
      7509989324975124438L

    • Class java.security.SignedObject extends Object implements Serializable

      serialVersionUID:
      720502720485447167L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          readObject is called to restore the state of the SignedObject from a stream.
          Throws:
          IOException
          ClassNotFoundException

      • Serialized Fields

        • content

          byte[] content

        • signature

          byte[] signature

        • thealgorithm

          String thealgorithm

    • Class java.security.Signer extends Identity implements Serializable

      serialVersionUID:
      -1763464102261361480L

      • Serialized Fields

        • privateKey

          PrivateKey privateKey
          Deprecated.
          The signer's private key.

    • Class java.security.Timestamp extends Object implements Serializable

      serialVersionUID:
      -5502683707821851294L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
          Throws:
          IOException
          ClassNotFoundException

      • Serialized Fields

        • timestamp

          Date timestamp
          The timestamp's date and time

        • signerCertPath

          CertPath signerCertPath
          The TSA's certificate path.

    • Class java.security.UnrecoverableEntryException extends GeneralSecurityException implements Serializable

      serialVersionUID:
      -4527142945246286535L

    • Class java.security.UnrecoverableKeyException extends UnrecoverableEntryException implements Serializable

      serialVersionUID:
      7275063078190151277L

    • Class java.security.UnresolvedPermission extends Permission implements Serializable

      serialVersionUID:
      -4821973115467008846L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
          Restores this object from a stream (i.e., deserializes it).
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream oos)
                  throws IOException
          Writes this object out to a stream (i.e., serializes it).
          Serial Data:
          An initial String denoting the type is followed by a String denoting the name is followed by a String denoting the actions is followed by an int indicating the number of certificates to follow (a value of "zero" denotes that there are no certificates associated with this object). Each certificate is written out starting with a String denoting the certificate type, followed by an int specifying the length of the certificate encoding, followed by the certificate encoding itself which is written out as an array of bytes.
          Throws:
          IOException

      • Serialized Fields

        • type

          String type
          The class name of the Permission class that will be created when this unresolved permission is resolved.

        • name

          String name
          The permission name.

        • actions

          String actions
          The actions of the permission.

    • Class java.security.UnresolvedPermissionCollection extends PermissionCollection implements Serializable

      serialVersionUID:
      -7176153071733132400L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream out)
                  throws IOException
          Serial Data:
          Default field.
          Throws:
          IOException

      • Serialized Fields

        • permissions

          Hashtable<K,V> permissions
          A table of the UnresolvedPermissions keyed on type, value is Vector of permissions

  • Package java.security.acl

    • Class java.security.acl.AclNotFoundException extends Exception implements Serializable

      serialVersionUID:
      5684295034092681791L

    • Class java.security.acl.LastOwnerException extends Exception implements Serializable

      serialVersionUID:
      -5141997548211140359L

    • Class java.security.acl.NotOwnerException extends Exception implements Serializable

      serialVersionUID:
      -5555597911163362399L

  • Package java.security.cert

    • Class java.security.cert.Certificate extends Object implements Serializable

      serialVersionUID:
      -3585440601605666277L

      • Serialization Methods

        • writeReplace

          protected Object writeReplace()
                       throws ObjectStreamException
          Replace the Certificate to be serialized.
          Throws:
          ObjectStreamException - if a new object representing this Certificate could not be created
          Since:
          1.3

      • Serialized Fields

        • type

          String type

        • hash

          int hash
          Cache the hash code for the certiticate

    • Class java.security.cert.Certificate.CertificateRep extends Object implements Serializable

      serialVersionUID:
      -8563758940495660020L

      • Serialization Methods

        • readResolve

          protected Object readResolve()
                      throws ObjectStreamException
          Resolve the Certificate Object.

          Throws:
          ObjectStreamException - if the Certificate could not be resolved

      • Serialized Fields

        • type

          String type

        • data

          byte[] data

    • Class java.security.cert.CertificateEncodingException extends CertificateException implements Serializable

      serialVersionUID:
      6219492851589449162L

    • Class java.security.cert.CertificateException extends GeneralSecurityException implements Serializable

      serialVersionUID:
      3192535253797119798L

    • Class java.security.cert.CertificateExpiredException extends CertificateException implements Serializable

      serialVersionUID:
      9071001339691533771L

    • Class java.security.cert.CertificateNotYetValidException extends CertificateException implements Serializable

      serialVersionUID:
      4355919900041064702L

    • Class java.security.cert.CertificateParsingException extends CertificateException implements Serializable

      serialVersionUID:
      -7989222416793322029L

    • Class java.security.cert.CertificateRevokedException extends CertificateException implements Serializable

      serialVersionUID:
      7839996631571608627L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
          Deserialize the CertificateRevokedException instance.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream oos)
                  throws IOException
          Serialize this CertificateRevokedException instance.
          Serial Data:
          the size of the extensions map (int), followed by all of the extensions in the map, in no particular order. For each extension, the following data is emitted: the OID String (Object), the criticality flag (boolean), the length of the encoded extension value byte array (int), and the encoded extension value bytes.
          Throws:
          IOException

      • Serialized Fields

        • revocationDate

          Date revocationDate
          the date on which the certificate was revoked

        • reason

          CRLReason reason
          the revocation reason

        • authority

          X500Principal authority
          the X500Principal that represents the name of the authority that signed the certificate's revocation status information

    • Class java.security.cert.CertPath extends Object implements Serializable

      serialVersionUID:
      6068470306649138683L

      • Serialization Methods

        • writeReplace

          protected Object writeReplace()
                       throws ObjectStreamException
          Replaces the CertPath to be serialized with a CertPathRep object.
          Throws:
          ObjectStreamException - if a CertPathRep object representing this certification path could not be created

      • Serialized Fields

        • type

          String type

    • Class java.security.cert.CertPath.CertPathRep extends Object implements Serializable

      serialVersionUID:
      3015633072427920915L

      • Serialization Methods

        • readResolve

          protected Object readResolve()
                      throws ObjectStreamException
          Returns a CertPath constructed from the type and data.
          Throws:
          ObjectStreamException - if a CertPath could not be constructed

      • Serialized Fields

        • type

          String type
          The Certificate type

        • data

          byte[] data
          The encoded form of the cert path

    • Class java.security.cert.CertPathBuilderException extends GeneralSecurityException implements Serializable

      serialVersionUID:
      5316471420178794402L

    • Class java.security.cert.CertPathValidatorException extends GeneralSecurityException implements Serializable

      serialVersionUID:
      -3083180014971893139L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream stream)
                 throws ClassNotFoundException,
                        IOException
          Throws:
          ClassNotFoundException
          IOException

      • Serialized Fields

        • index

          int index
          the index of the certificate in the certification path that caused the exception to be thrown

        • certPath

          CertPath certPath
          the CertPath that was being validated when the exception was thrown

        • reason

          CertPathValidatorException.Reason reason
          the reason the validation failed

    • Class java.security.cert.CertStoreException extends GeneralSecurityException implements Serializable

      serialVersionUID:
      2395296107471573245L

    • Class java.security.cert.CRLException extends GeneralSecurityException implements Serializable

      serialVersionUID:
      -6694728944094197147L

    • Class java.security.cert.X509Certificate extends Certificate implements Serializable

      serialVersionUID:
      -2491127588187038216L

  • Package java.security.interfaces

  • Package java.security.spec

    • Class java.security.spec.InvalidKeySpecException extends GeneralSecurityException implements Serializable

      serialVersionUID:
      3546139293998810778L

    • Class java.security.spec.InvalidParameterSpecException extends GeneralSecurityException implements Serializable

      serialVersionUID:
      -970468769593399342L

  • Package java.sql

    • Class java.sql.BatchUpdateException extends SQLException implements Serializable

      serialVersionUID:
      5977529877145521757L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          readObject is called to restore the state of the BatchUpdateException from a stream.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException,
                         ClassNotFoundException
          writeObject is called to save the state of the BatchUpdateException to a stream.
          Throws:
          IOException
          ClassNotFoundException

      • Serialized Fields

        • updateCounts

          int[] updateCounts
          The array that describes the outcome of a batch execution.
          Since:
          1.2

        • longUpdateCounts

          long[] longUpdateCounts
          The array that describes the outcome of a batch execution.
          Since:
          1.8

    • Class java.sql.DataTruncation extends SQLWarning implements Serializable

      serialVersionUID:
      6464298989504059473L

      • Serialized Fields

        • index

          int index

        • parameter

          boolean parameter

        • read

          boolean read

        • dataSize

          int dataSize

        • transferSize

          int transferSize

    • Class java.sql.Date extends Date implements Serializable

      serialVersionUID:
      1511598038487230103L

    • Class java.sql.SQLClientInfoException extends SQLException implements Serializable

      serialVersionUID:
      -4319604256824655880L

      • Serialized Fields

        • failedProperties

          Map<K,V> failedProperties

    • Class java.sql.SQLDataException extends SQLNonTransientException implements Serializable

      serialVersionUID:
      -6889123282670549800L

    • Class java.sql.SQLException extends Exception implements Serializable

      serialVersionUID:
      2135244094396331484L

      • Serialized Fields

        • SQLState

          String SQLState

        • vendorCode

          int vendorCode

        • next

          SQLException next

    • Class java.sql.SQLFeatureNotSupportedException extends SQLNonTransientException implements Serializable

      serialVersionUID:
      -1026510870282316051L

    • Class java.sql.SQLIntegrityConstraintViolationException extends SQLNonTransientException implements Serializable

      serialVersionUID:
      8033405298774849169L

    • Class java.sql.SQLInvalidAuthorizationSpecException extends SQLNonTransientException implements Serializable

      serialVersionUID:
      -64105250450891498L

    • Class java.sql.SQLNonTransientConnectionException extends SQLNonTransientException implements Serializable

      serialVersionUID:
      -5852318857474782892L

    • Class java.sql.SQLNonTransientException extends SQLException implements Serializable

      serialVersionUID:
      -9104382843534716547L

    • Class java.sql.SQLPermission extends BasicPermission implements Serializable

      serialVersionUID:
      -1439323187199563495L

    • Class java.sql.SQLRecoverableException extends SQLException implements Serializable

      serialVersionUID:
      -4144386502923131579L

    • Class java.sql.SQLSyntaxErrorException extends SQLNonTransientException implements Serializable

      serialVersionUID:
      -1843832610477496053L

    • Class java.sql.SQLTimeoutException extends SQLTransientException implements Serializable

      serialVersionUID:
      -4487171280562520262L

    • Class java.sql.SQLTransactionRollbackException extends SQLTransientException implements Serializable

      serialVersionUID:
      5246680841170837229L

    • Class java.sql.SQLTransientConnectionException extends SQLTransientException implements Serializable

      serialVersionUID:
      -2520155553543391200L

    • Class java.sql.SQLTransientException extends SQLException implements Serializable

      serialVersionUID:
      -9042733978262274539L

    • Class java.sql.SQLWarning extends SQLException implements Serializable

      serialVersionUID:
      3917336774604784856L

    • Class java.sql.Time extends Date implements Serializable

      serialVersionUID:
      8397324403548013681L

    • Class java.sql.Timestamp extends Date implements Serializable

      serialVersionUID:
      2745179027874758501L

      • Serialized Fields

        • nanos

          int nanos

  • Package java.text

    • Class java.text.AttributedCharacterIterator.Attribute extends Object implements Serializable

      serialVersionUID:
      -9142742483513960612L

      • Serialization Methods

        • readResolve

          protected Object readResolve()
                      throws InvalidObjectException
          Resolves instances being deserialized to the predefined constants.
          Throws:
          InvalidObjectException - if the object to resolve is not an instance of Attribute

      • Serialized Fields

        • name

          String name
          The name of this Attribute. The name is used primarily by readResolve to look up the corresponding predefined instance when deserializing an instance.

    • Class java.text.ChoiceFormat extends NumberFormat implements Serializable

      serialVersionUID:
      1795184449645032964L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          After reading an object from the input stream, do a simple verification to maintain class invariants.
          Throws:
          InvalidObjectException - if the objects read from the stream is invalid.
          IOException
          ClassNotFoundException

      • Serialized Fields

        • choiceLimits

          double[] choiceLimits
          A list of lower bounds for the choices. The formatter will return choiceFormats[i] if the number being formatted is greater than or equal to choiceLimits[i] and less than choiceLimits[i+1].

        • choiceFormats

          String[] choiceFormats
          A list of choice strings. The formatter will return choiceFormats[i] if the number being formatted is greater than or equal to choiceLimits[i] and less than choiceLimits[i+1].

    • Class java.text.DateFormat extends Format implements Serializable

      serialVersionUID:
      7218322306649953788L

      • Serialized Fields

        • calendar

          Calendar calendar
          The Calendar instance used for calculating the date-time fields and the instant of time. This field is used for both formatting and parsing.

          Subclasses should initialize this field to a Calendar appropriate for the Locale associated with this DateFormat.

        • numberFormat

          NumberFormat numberFormat
          The number formatter that DateFormat uses to format numbers in dates and times. Subclasses should initialize this to a number format appropriate for the locale associated with this DateFormat.

    • Class java.text.DateFormat.Field extends Format.Field implements Serializable

      serialVersionUID:
      7441350119349544720L

      • Serialization Methods

        • readResolve

          protected Object readResolve()
                      throws InvalidObjectException
          Resolves instances being deserialized to the predefined constants.
          Throws:
          InvalidObjectException - if the constant could not be resolved.

      • Serialized Fields

        • calendarField

          int calendarField
          Calendar field.

    • Class java.text.DateFormatSymbols extends Object implements Serializable

      serialVersionUID:
      -5987973545549424702L

      • Serialization Methods

        • writeObject

          private void writeObject(ObjectOutputStream stream)
                  throws IOException
          Write out the default serializable data, after ensuring the zoneStrings field is initialized in order to make sure the backward compatibility.
          Throws:
          IOException
          Since:
          1.6

      • Serialized Fields

        • eras

          String[] eras
          Era strings. For example: "AD" and "BC". An array of 2 strings, indexed by Calendar.BC and Calendar.AD.

        • months

          String[] months
          Month strings. For example: "January", "February", etc. An array of 13 strings (some calendars have 13 months), indexed by Calendar.JANUARY, Calendar.FEBRUARY, etc.

        • shortMonths

          String[] shortMonths
          Short month strings. For example: "Jan", "Feb", etc. An array of 13 strings (some calendars have 13 months), indexed by Calendar.JANUARY, Calendar.FEBRUARY, etc.

        • weekdays

          String[] weekdays
          Weekday strings. For example: "Sunday", "Monday", etc. An array of 8 strings, indexed by Calendar.SUNDAY, Calendar.MONDAY, etc. The element weekdays[0] is ignored.

        • shortWeekdays

          String[] shortWeekdays
          Short weekday strings. For example: "Sun", "Mon", etc. An array of 8 strings, indexed by Calendar.SUNDAY, Calendar.MONDAY, etc. The element shortWeekdays[0] is ignored.

        • ampms

          String[] ampms
          AM and PM strings. For example: "AM" and "PM". An array of 2 strings, indexed by Calendar.AM and Calendar.PM.

        • zoneStrings

          String[][] zoneStrings
          Localized names of time zones in this locale. This is a two-dimensional array of strings of size n by m, where m is at least 5. Each of the n rows is an entry containing the localized names for a single TimeZone. Each such row contains (with i ranging from 0..n-1):
          • zoneStrings[i][0] - time zone ID
          • zoneStrings[i][1] - long name of zone in standard time
          • zoneStrings[i][2] - short name of zone in standard time
          • zoneStrings[i][3] - long name of zone in daylight saving time
          • zoneStrings[i][4] - short name of zone in daylight saving time
          The zone ID is not localized; it's one of the valid IDs of the TimeZone class that are not custom IDs. All other entries are localized names.
          See Also:
          TimeZone

        • localPatternChars

          String localPatternChars
          Localized date-time pattern characters. For example, a locale may wish to use 'u' rather than 'y' to represent years in its date format pattern strings. This string must be exactly 18 characters long, with the index of the characters described by DateFormat.ERA_FIELD, DateFormat.YEAR_FIELD, etc. Thus, if the string were "Xz...", then localized patterns would use 'X' for era and 'z' for year.

        • locale

          Locale locale
          The locale which is used for initializing this DateFormatSymbols object.
          Since:
          1.6

    • Class java.text.DecimalFormat extends NumberFormat implements Serializable

      serialVersionUID:
      864413376551465018L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream stream)
                 throws IOException,
                        ClassNotFoundException
          Reads the default serializable fields from the stream and performs validations and adjustments for older serialized versions. The validations and adjustments are:
          1. Verify that the superclass's digit count fields correctly reflect the limits imposed on formatting numbers other than BigInteger and BigDecimal objects. These limits are stored in the superclass for serialization compatibility with older versions, while the limits for BigInteger and BigDecimal objects are kept in this class. If, in the superclass, the minimum or maximum integer digit count is larger than DOUBLE_INTEGER_DIGITS or if the minimum or maximum fraction digit count is larger than DOUBLE_FRACTION_DIGITS, then the stream data is invalid and this method throws an InvalidObjectException.
          2. If serialVersionOnStream is less than 4, initialize roundingMode to RoundingMode.HALF_EVEN. This field is new with version 4.
          3. If serialVersionOnStream is less than 3, then call the setters for the minimum and maximum integer and fraction digits with the values of the corresponding superclass getters to initialize the fields in this class. The fields in this class are new with version 3.
          4. If serialVersionOnStream is less than 1, indicating that the stream was written by JDK 1.1, initialize useExponentialNotation to false, since it was not present in JDK 1.1.
          5. Set serialVersionOnStream to the maximum allowed value so that default serialization will work properly if this object is streamed out again.

          Stream versions older than 2 will not have the affix pattern variables posPrefixPattern etc. As a result, they will be initialized to null, which means the affix strings will be taken as literal values. This is exactly what we want, since that corresponds to the pre-version-2 behavior.

          Throws:
          IOException
          ClassNotFoundException

      • Serialized Fields

        • positivePrefix

          String positivePrefix
          The symbol used as a prefix when formatting positive numbers, e.g. "+".
          See Also:
          DecimalFormat.getPositivePrefix()

        • positiveSuffix

          String positiveSuffix
          The symbol used as a suffix when formatting positive numbers. This is often an empty string.
          See Also:
          DecimalFormat.getPositiveSuffix()

        • negativePrefix

          String negativePrefix
          The symbol used as a prefix when formatting negative numbers, e.g. "-".
          See Also:
          DecimalFormat.getNegativePrefix()

        • negativeSuffix

          String negativeSuffix
          The symbol used as a suffix when formatting negative numbers. This is often an empty string.
          See Also:
          DecimalFormat.getNegativeSuffix()

        • posPrefixPattern

          String posPrefixPattern
          The prefix pattern for non-negative numbers. This variable corresponds to positivePrefix.

          This pattern is expanded by the method expandAffix() to positivePrefix to update the latter to reflect changes in symbols. If this variable is null then positivePrefix is taken as a literal value that does not change when symbols changes. This variable is always null for DecimalFormat objects older than stream version 2 restored from stream.

          Since:
          1.3

        • posSuffixPattern

          String posSuffixPattern
          The suffix pattern for non-negative numbers. This variable corresponds to positiveSuffix. This variable is analogous to posPrefixPattern; see that variable for further documentation.
          Since:
          1.3

        • negPrefixPattern

          String negPrefixPattern
          The prefix pattern for negative numbers. This variable corresponds to negativePrefix. This variable is analogous to posPrefixPattern; see that variable for further documentation.
          Since:
          1.3

        • negSuffixPattern

          String negSuffixPattern
          The suffix pattern for negative numbers. This variable corresponds to negativeSuffix. This variable is analogous to posPrefixPattern; see that variable for further documentation.
          Since:
          1.3

        • multiplier

          int multiplier
          The multiplier for use in percent, per mille, etc.
          See Also:
          DecimalFormat.getMultiplier()

        • groupingSize

          byte groupingSize
          The number of digits between grouping separators in the integer portion of a number. Must be greater than 0 if NumberFormat.groupingUsed is true.
          See Also:
          DecimalFormat.getGroupingSize(), NumberFormat.isGroupingUsed()

        • decimalSeparatorAlwaysShown

          boolean decimalSeparatorAlwaysShown
          If true, forces the decimal separator to always appear in a formatted number, even if the fractional part of the number is zero.
          See Also:
          DecimalFormat.isDecimalSeparatorAlwaysShown()

        • parseBigDecimal

          boolean parseBigDecimal
          If true, parse returns BigDecimal wherever possible.
          Since:
          1.5
          See Also:
          DecimalFormat.isParseBigDecimal()

        • symbols

          DecimalFormatSymbols symbols
          The DecimalFormatSymbols object used by this format. It contains the symbols used to format numbers, e.g. the grouping separator, decimal separator, and so on.
          See Also:
          DecimalFormat.setDecimalFormatSymbols(java.text.DecimalFormatSymbols), DecimalFormatSymbols

        • useExponentialNotation

          boolean useExponentialNotation
          True to force the use of exponential (i.e. scientific) notation when formatting numbers.
          Since:
          1.2

        • minExponentDigits

          byte minExponentDigits
          The minimum number of digits used to display the exponent when a number is formatted in exponential notation. This field is ignored if useExponentialNotation is not true.
          Since:
          1.2

        • maximumIntegerDigits

          int maximumIntegerDigits
          The maximum number of digits allowed in the integer portion of a BigInteger or BigDecimal number. maximumIntegerDigits must be greater than or equal to minimumIntegerDigits.
          Since:
          1.5
          See Also:
          DecimalFormat.getMaximumIntegerDigits()

        • minimumIntegerDigits

          int minimumIntegerDigits
          The minimum number of digits allowed in the integer portion of a BigInteger or BigDecimal number. minimumIntegerDigits must be less than or equal to maximumIntegerDigits.
          Since:
          1.5
          See Also:
          DecimalFormat.getMinimumIntegerDigits()

        • maximumFractionDigits

          int maximumFractionDigits
          The maximum number of digits allowed in the fractional portion of a BigInteger or BigDecimal number. maximumFractionDigits must be greater than or equal to minimumFractionDigits.
          Since:
          1.5
          See Also:
          DecimalFormat.getMaximumFractionDigits()

        • minimumFractionDigits

          int minimumFractionDigits
          The minimum number of digits allowed in the fractional portion of a BigInteger or BigDecimal number. minimumFractionDigits must be less than or equal to maximumFractionDigits.
          Since:
          1.5
          See Also:
          DecimalFormat.getMinimumFractionDigits()

        • roundingMode

          RoundingMode roundingMode
          The RoundingMode used in this DecimalFormat.
          Since:
          1.6

        • serialVersionOnStream

          int serialVersionOnStream
          The internal serial version which says which version was written. Possible values are:
          • 0 (default): versions before the Java 2 platform v1.2
          • 1: version for 1.2, which includes the two new fields useExponentialNotation and minExponentDigits.
          • 2: version for 1.3 and later, which adds four new fields: posPrefixPattern, posSuffixPattern, negPrefixPattern, and negSuffixPattern.
          • 3: version for 1.5 and later, which adds five new fields: maximumIntegerDigits, minimumIntegerDigits, maximumFractionDigits, minimumFractionDigits, and parseBigDecimal.
          • 4: version for 1.6 and later, which adds one new field: roundingMode.
          Since:
          1.2

    • Class java.text.DecimalFormatSymbols extends Object implements Serializable

      serialVersionUID:
      5772796243397350300L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream stream)
                 throws IOException,
                        ClassNotFoundException
          Reads the default serializable fields, provides default values for objects in older serial versions, and initializes non-serializable fields. If serialVersionOnStream is less than 1, initializes monetarySeparator to be the same as decimalSeparator and exponential to be 'E'. If serialVersionOnStream is less than 2, initializes localeto the root locale, and initializes If serialVersionOnStream is less than 3, it initializes exponentialSeparator using exponential. Sets serialVersionOnStream back to the maximum allowed value so that default serialization will work properly if this object is streamed out again. Initializes the currency from the intlCurrencySymbol field.
          Throws:
          IOException
          ClassNotFoundException
          Since:
          JDK 1.1.6

      • Serialized Fields

        • zeroDigit

          char zeroDigit
          Character used for zero.
          See Also:
          DecimalFormatSymbols.getZeroDigit()

        • groupingSeparator

          char groupingSeparator
          Character used for thousands separator.
          See Also:
          DecimalFormatSymbols.getGroupingSeparator()

        • decimalSeparator

          char decimalSeparator
          Character used for decimal sign.
          See Also:
          DecimalFormatSymbols.getDecimalSeparator()

        • perMill

          char perMill
          Character used for per mille sign.
          See Also:
          DecimalFormatSymbols.getPerMill()

        • percent

          char percent
          Character used for percent sign.
          See Also:
          DecimalFormatSymbols.getPercent()

        • digit

          char digit
          Character used for a digit in a pattern.
          See Also:
          DecimalFormatSymbols.getDigit()

        • patternSeparator

          char patternSeparator
          Character used to separate positive and negative subpatterns in a pattern.
          See Also:
          DecimalFormatSymbols.getPatternSeparator()

        • infinity

          String infinity
          String used to represent infinity.
          See Also:
          DecimalFormatSymbols.getInfinity()

        • NaN

          String NaN
          String used to represent "not a number".
          See Also:
          DecimalFormatSymbols.getNaN()

        • minusSign

          char minusSign
          Character used to represent minus sign.
          See Also:
          DecimalFormatSymbols.getMinusSign()

        • currencySymbol

          String currencySymbol
          String denoting the local currency, e.g. "$".
          See Also:
          DecimalFormatSymbols.getCurrencySymbol()

        • intlCurrencySymbol

          String intlCurrencySymbol
          ISO 4217 currency code denoting the local currency, e.g. "USD".
          See Also:
          DecimalFormatSymbols.getInternationalCurrencySymbol()

        • monetarySeparator

          char monetarySeparator
          The decimal separator used when formatting currency values.
          Since:
          JDK 1.1.6
          See Also:
          DecimalFormatSymbols.getMonetaryDecimalSeparator()

        • exponential

          char exponential
          The character used to distinguish the exponent in a number formatted in exponential notation, e.g. 'E' for a number such as "1.23E45".

          Note that the public API provides no way to set this field, even though it is supported by the implementation and the stream format. The intent is that this will be added to the API in the future.

          Since:
          JDK 1.1.6

        • exponentialSeparator

          String exponentialSeparator
          The string used to separate the mantissa from the exponent. Examples: "x10^" for 1.23x10^4, "E" for 1.23E4.

          If both exponential and exponentialSeparator exist, this exponentialSeparator has the precedence.

          Since:
          1.6

        • locale

          Locale locale
          The locale of these currency format symbols.
          Since:
          1.4

        • serialVersionOnStream

          int serialVersionOnStream
          Describes the version of DecimalFormatSymbols present on the stream. Possible values are:
          • 0 (or uninitialized): versions prior to JDK 1.1.6.
          • 1: Versions written by JDK 1.1.6 or later, which include two new fields: monetarySeparator and exponential.
          • 2: Versions written by J2SE 1.4 or later, which include a new locale field.
          • 3: Versions written by J2SE 1.6 or later, which include a new exponentialSeparator field.
          When streaming out a DecimalFormatSymbols, the most recent format (corresponding to the highest allowable serialVersionOnStream) is always written.
          Since:
          JDK 1.1.6

    • Class java.text.Format extends Object implements Serializable

      serialVersionUID:
      -299282585814624189L

    • Class java.text.Format.Field extends AttributedCharacterIterator.Attribute implements Serializable

      serialVersionUID:
      276966692217360283L

    • Class java.text.MessageFormat extends Format implements Serializable

      serialVersionUID:
      6479157306784022952L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          After reading an object from the input stream, do a simple verification to maintain class invariants.
          Throws:
          InvalidObjectException - if the objects read from the stream is invalid.
          IOException
          ClassNotFoundException

      • Serialized Fields

        • locale

          Locale locale
          The locale to use for formatting numbers and dates.

        • pattern

          String pattern
          The string that the formatted values are to be plugged into. In other words, this is the pattern supplied on construction with all of the {} expressions taken out.

        • formats

          Format[] formats
          An array of formatters, which are used to format the arguments.

        • offsets

          int[] offsets
          The positions where the results of formatting each argument are to be inserted into the pattern.

        • argumentNumbers

          int[] argumentNumbers
          The argument numbers corresponding to each formatter. (The formatters are stored in the order they occur in the pattern, not in the order in which the arguments are specified.)

        • maxOffset

          int maxOffset
          One less than the number of entries in offsets. Can also be thought of as the index of the highest-numbered element in offsets that is being used. All of these arrays should have the same number of elements being used as offsets does, and so this variable suffices to tell us how many entries are in all of them.

    • Class java.text.MessageFormat.Field extends Format.Field implements Serializable

      serialVersionUID:
      7899943957617360810L

      • Serialization Methods

        • readResolve

          protected Object readResolve()
                      throws InvalidObjectException
          Resolves instances being deserialized to the predefined constants.
          Throws:
          InvalidObjectException - if the constant could not be resolved.

    • Class java.text.NumberFormat extends Format implements Serializable

      serialVersionUID:
      -2308460125733713944L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream stream)
                 throws IOException,
                        ClassNotFoundException
          First, read in the default serializable data. Then, if serialVersionOnStream is less than 1, indicating that the stream was written by JDK 1.1, set the int fields such as maximumIntegerDigits to be equal to the byte fields such as maxIntegerDigits, since the int fields were not present in JDK 1.1. Finally, set serialVersionOnStream back to the maximum allowed value so that default serialization will work properly if this object is streamed out again.

          If minimumIntegerDigits is greater than maximumIntegerDigits or minimumFractionDigits is greater than maximumFractionDigits, then the stream data is invalid and this method throws an InvalidObjectException. In addition, if any of these values is negative, then this method throws an InvalidObjectException.

          Throws:
          IOException
          ClassNotFoundException
          Since:
          1.2

        • writeObject

          private void writeObject(ObjectOutputStream stream)
                  throws IOException
          Write out the default serializable data, after first setting the byte fields such as maxIntegerDigits to be equal to the int fields such as maximumIntegerDigits (or to Byte.MAX_VALUE, whichever is smaller), for compatibility with the JDK 1.1 version of the stream format.
          Throws:
          IOException
          Since:
          1.2

      • Serialized Fields

        • groupingUsed

          boolean groupingUsed
          True if the grouping (i.e. thousands) separator is used when formatting and parsing numbers.
          See Also:
          NumberFormat.isGroupingUsed()

        • maxIntegerDigits

          byte maxIntegerDigits
          The maximum number of digits allowed in the integer portion of a number. maxIntegerDigits must be greater than or equal to minIntegerDigits.

          Note: This field exists only for serialization compatibility with JDK 1.1. In Java platform 2 v1.2 and higher, the new int field maximumIntegerDigits is used instead. When writing to a stream, maxIntegerDigits is set to maximumIntegerDigits or Byte.MAX_VALUE, whichever is smaller. When reading from a stream, this field is used only if serialVersionOnStream is less than 1.

          See Also:
          NumberFormat.getMaximumIntegerDigits()

        • minIntegerDigits

          byte minIntegerDigits
          The minimum number of digits allowed in the integer portion of a number. minimumIntegerDigits must be less than or equal to maximumIntegerDigits.

          Note: This field exists only for serialization compatibility with JDK 1.1. In Java platform 2 v1.2 and higher, the new int field minimumIntegerDigits is used instead. When writing to a stream, minIntegerDigits is set to minimumIntegerDigits or Byte.MAX_VALUE, whichever is smaller. When reading from a stream, this field is used only if serialVersionOnStream is less than 1.

          See Also:
          NumberFormat.getMinimumIntegerDigits()

        • maxFractionDigits

          byte maxFractionDigits
          The maximum number of digits allowed in the fractional portion of a number. maximumFractionDigits must be greater than or equal to minimumFractionDigits.

          Note: This field exists only for serialization compatibility with JDK 1.1. In Java platform 2 v1.2 and higher, the new int field maximumFractionDigits is used instead. When writing to a stream, maxFractionDigits is set to maximumFractionDigits or Byte.MAX_VALUE, whichever is smaller. When reading from a stream, this field is used only if serialVersionOnStream is less than 1.

          See Also:
          NumberFormat.getMaximumFractionDigits()

        • minFractionDigits

          byte minFractionDigits
          The minimum number of digits allowed in the fractional portion of a number. minimumFractionDigits must be less than or equal to maximumFractionDigits.

          Note: This field exists only for serialization compatibility with JDK 1.1. In Java platform 2 v1.2 and higher, the new int field minimumFractionDigits is used instead. When writing to a stream, minFractionDigits is set to minimumFractionDigits or Byte.MAX_VALUE, whichever is smaller. When reading from a stream, this field is used only if serialVersionOnStream is less than 1.

          See Also:
          NumberFormat.getMinimumFractionDigits()

        • parseIntegerOnly

          boolean parseIntegerOnly
          True if this format will parse numbers as integers only.
          See Also:
          NumberFormat.isParseIntegerOnly()

        • maximumIntegerDigits

          int maximumIntegerDigits
          The maximum number of digits allowed in the integer portion of a number. maximumIntegerDigits must be greater than or equal to minimumIntegerDigits.
          Since:
          1.2
          See Also:
          NumberFormat.getMaximumIntegerDigits()

        • minimumIntegerDigits

          int minimumIntegerDigits
          The minimum number of digits allowed in the integer portion of a number. minimumIntegerDigits must be less than or equal to maximumIntegerDigits.
          Since:
          1.2
          See Also:
          NumberFormat.getMinimumIntegerDigits()

        • maximumFractionDigits

          int maximumFractionDigits
          The maximum number of digits allowed in the fractional portion of a number. maximumFractionDigits must be greater than or equal to minimumFractionDigits.
          Since:
          1.2
          See Also:
          NumberFormat.getMaximumFractionDigits()

        • minimumFractionDigits

          int minimumFractionDigits
          The minimum number of digits allowed in the fractional portion of a number. minimumFractionDigits must be less than or equal to maximumFractionDigits.
          Since:
          1.2
          See Also:
          NumberFormat.getMinimumFractionDigits()

        • serialVersionOnStream

          int serialVersionOnStream
          Describes the version of NumberFormat present on the stream. Possible values are:
          • 0 (or uninitialized): the JDK 1.1 version of the stream format. In this version, the int fields such as maximumIntegerDigits were not present, and the byte fields such as maxIntegerDigits are used instead.
          • 1: the 1.2 version of the stream format. The values of the byte fields such as maxIntegerDigits are ignored, and the int fields such as maximumIntegerDigits are used instead.
          When streaming out a NumberFormat, the most recent format (corresponding to the highest allowable serialVersionOnStream) is always written.
          Since:
          1.2

    • Class java.text.NumberFormat.Field extends Format.Field implements Serializable

      serialVersionUID:
      7494728892700160890L

      • Serialization Methods

        • readResolve

          protected Object readResolve()
                      throws InvalidObjectException
          Resolves instances being deserialized to the predefined constants.
          Throws:
          InvalidObjectException - if the constant could not be resolved.

    • Class java.text.ParseException extends Exception implements Serializable

      serialVersionUID:
      2703218443322787634L

      • Serialized Fields

        • errorOffset

          int errorOffset
          The zero-based character offset into the string being parsed at which the error was found during parsing.

    • Class java.text.SimpleDateFormat extends DateFormat implements Serializable

      serialVersionUID:
      4774881970558875024L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream stream)
                 throws IOException,
                        ClassNotFoundException
          After reading an object from the input stream, the format pattern in the object is verified.

          Throws:
          InvalidObjectException - if the pattern is invalid
          IOException
          ClassNotFoundException

      • Serialized Fields

        • serialVersionOnStream

          int serialVersionOnStream
          The version of the serialized data on the stream. Possible values:
          • 0 or not present on stream: JDK 1.1.3. This version has no defaultCenturyStart on stream.
          • 1 JDK 1.1.4 or later. This version adds defaultCenturyStart.
          When streaming out this class, the most recent format and the highest allowable serialVersionOnStream is written.
          Since:
          JDK1.1.4

        • pattern

          String pattern
          The pattern string of this formatter. This is always a non-localized pattern. May not be null. See class documentation for details.

        • formatData

          DateFormatSymbols formatData
          The symbols used by this formatter for week names, month names, etc. May not be null.
          See Also:
          DateFormatSymbols

        • defaultCenturyStart

          Date defaultCenturyStart
          We map dates with two-digit years into the century starting at defaultCenturyStart, which may be any date. May not be null.
          Since:
          JDK1.1.4

        • locale

          Locale locale
          The Locale used to instantiate this SimpleDateFormat. The value may be null if this object has been created by an older SimpleDateFormat and deserialized.
          Since:
          1.6

  • Package java.time

    • Class java.time.DateTimeException extends RuntimeException implements Serializable

      serialVersionUID:
      -1632418723876261839L

    • Class java.time.Duration extends Object implements Serializable

      serialVersionUID:
      3078945930695997490L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws InvalidObjectException
          Defend against malicious streams.
          Throws:
          InvalidObjectException - always

        • writeReplace

          private Object writeReplace()
          Writes the object using a dedicated serialized form.
          Serial Data:
            out.writeByte(1);  // identifies a Duration
  out.writeLong(seconds);
  out.writeInt(nanos);

      • Serialized Fields

        • seconds

          long seconds
          The number of seconds in the duration.

        • nanos

          int nanos
          The number of nanoseconds in the duration, expressed as a fraction of the number of seconds. This is always positive, and never exceeds 999,999,999.

    • Class java.time.Instant extends Object implements Serializable

      serialVersionUID:
      -665713676816604388L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws InvalidObjectException
          Defend against malicious streams.
          Throws:
          InvalidObjectException - always

        • writeReplace

          private Object writeReplace()
          Writes the object using a dedicated serialized form.
          Serial Data:
            out.writeByte(2);  // identifies an Instant
  out.writeLong(seconds);
  out.writeInt(nanos);

      • Serialized Fields

        • seconds

          long seconds
          The number of seconds from the epoch of 1970-01-01T00:00:00Z.

        • nanos

          int nanos
          The number of nanoseconds, later along the time-line, from the seconds field. This is always positive, and never exceeds 999,999,999.

    • Class java.time.LocalDate extends Object implements Serializable

      serialVersionUID:
      2942565459149668126L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws InvalidObjectException
          Defend against malicious streams.
          Throws:
          InvalidObjectException - always

        • writeReplace

          private Object writeReplace()
          Writes the object using a dedicated serialized form.
          Serial Data:
            out.writeByte(3);  // identifies a LocalDate
  out.writeInt(year);
  out.writeByte(month);
  out.writeByte(day);

      • Serialized Fields

        • year

          int year
          The year.

        • month

          short month
          The month-of-year.

        • day

          short day
          The day-of-month.

    • Class java.time.LocalDateTime extends Object implements Serializable

      serialVersionUID:
      6207766400415563566L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws InvalidObjectException
          Defend against malicious streams.
          Throws:
          InvalidObjectException - always

        • writeReplace

          private Object writeReplace()
          Writes the object using a dedicated serialized form.
          Serial Data:
            out.writeByte(5);  // identifies a LocalDateTime
  // the date excluding the one byte header
  // the time excluding the one byte header

      • Serialized Fields

        • date

          LocalDate date
          The date part.

        • time

          LocalTime time
          The time part.

    • Class java.time.LocalTime extends Object implements Serializable

      serialVersionUID:
      6414437269572265201L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws InvalidObjectException
          Defend against malicious streams.
          Throws:
          InvalidObjectException - always

        • writeReplace

          private Object writeReplace()
          Writes the object using a dedicated serialized form.
          Serial Data:
          A twos-complement value indicates the remaining values are not in the stream and should be set to zero.
            out.writeByte(4);  // identifies a LocalTime
  if (nano == 0) {
    if (second == 0) {
      if (minute == 0) {
        out.writeByte(~hour);
      } else {
        out.writeByte(hour);
        out.writeByte(~minute);
      }
    } else {
      out.writeByte(hour);
      out.writeByte(minute);
      out.writeByte(~second);
    }
  } else {
    out.writeByte(hour);
    out.writeByte(minute);
    out.writeByte(second);
    out.writeInt(nano);
  }

      • Serialized Fields

        • hour

          byte hour
          The hour.

        • minute

          byte minute
          The minute.

        • second

          byte second
          The second.

        • nano

          int nano
          The nanosecond.

    • Class java.time.MonthDay extends Object implements Serializable

      serialVersionUID:
      -939150713474957432L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws InvalidObjectException
          Defend against malicious streams.
          Throws:
          InvalidObjectException - always

        • writeReplace

          private Object writeReplace()
          Writes the object using a dedicated serialized form.
          Serial Data:
            out.writeByte(13);  // identifies a MonthDay
  out.writeByte(month);
  out.writeByte(day);

      • Serialized Fields

        • month

          int month
          The month-of-year, not null.

        • day

          int day
          The day-of-month.

    • Class java.time.OffsetDateTime extends Object implements Serializable

      serialVersionUID:
      2287754244819255394L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws InvalidObjectException
          Defend against malicious streams.
          Throws:
          InvalidObjectException - always

        • writeReplace

          private Object writeReplace()
          Writes the object using a dedicated serialized form.
          Serial Data:
            out.writeByte(10);  // identifies an OffsetDateTime
  // the datetime excluding the one byte header
  // the offset excluding the one byte header

      • Serialized Fields

        • dateTime

          LocalDateTime dateTime
          The local date-time.

        • offset

          ZoneOffset offset
          The offset from UTC/Greenwich.

    • Class java.time.OffsetTime extends Object implements Serializable

      serialVersionUID:
      7264499704384272492L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws InvalidObjectException
          Defend against malicious streams.
          Throws:
          InvalidObjectException - always

        • writeReplace

          private Object writeReplace()
          Writes the object using a dedicated serialized form.
          Serial Data:
            out.writeByte(9);  // identifies an OffsetTime
  // the time excluding the one byte header
  // the offset excluding the one byte header

      • Serialized Fields

        • time

          LocalTime time
          The local date-time.

        • offset

          ZoneOffset offset
          The offset from UTC/Greenwich.

    • Class java.time.Period extends Object implements Serializable

      serialVersionUID:
      -3587258372562876L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws InvalidObjectException
          Defend against malicious streams.
          Throws:
          InvalidObjectException - always

        • writeReplace

          private Object writeReplace()
          Writes the object using a dedicated serialized form.
          Serial Data:
            out.writeByte(14);  // identifies a Period
  out.writeInt(years);
  out.writeInt(months);
  out.writeInt(days);

      • Serialized Fields

        • years

          int years
          The number of years.

        • months

          int months
          The number of months.

        • days

          int days
          The number of days.

    • Class java.time.Ser extends Object implements Serializable

      serialVersionUID:
      -7683839454370182990L

      • Serialization Methods

        • readExternal

          public void readExternal(ObjectInput in)
                  throws IOException,
                         ClassNotFoundException
          Implements the Externalizable interface to read the object.
          Serial Data:
          The streamed type and parameters defined by the type's writeReplace method are read and passed to the corresponding static factory for the type to create a new instance. That instance is returned as the de-serialized Ser object.
          • Duration - Duration.ofSeconds(seconds, nanos);
          • Instant - Instant.ofEpochSecond(seconds, nanos);
          • LocalDate - LocalDate.of(year, month, day);
          • LocalDateTime - LocalDateTime.of(date, time);
          • LocalTime - LocalTime.of(hour, minute, second, nano);
          • MonthDay - MonthDay.of(month, day);
          • OffsetTime - OffsetTime.of(time, offset);
          • OffsetDateTime - OffsetDateTime.of(dateTime, offset);
          • Period - Period.of(years, months, days);
          • Year - Year.of(year);
          • YearMonth - YearMonth.of(year, month);
          • ZonedDateTime - ZonedDateTime.ofLenient(dateTime, offset, zone);
          • ZoneId - ZoneId.of(id);
          • ZoneOffset - (offsetByte == 127 ? ZoneOffset.ofTotalSeconds(in.readInt()) : ZoneOffset.ofTotalSeconds(offsetByte * 900));
          Throws:
          IOException - if I/O errors occur
          ClassNotFoundException - If the class for an object being restored cannot be found.

        • writeExternal

          public void writeExternal(ObjectOutput out)
                   throws IOException
          Implements the Externalizable interface to write the object.
          Serial Data:
          Each serializable class is mapped to a type that is the first byte in the stream. Refer to each class writeReplace serialized form for the value of the type and sequence of values for the type.
          • Duration.writeReplace
          • Instant.writeReplace
          • LocalDate.writeReplace
          • LocalDateTime.writeReplace
          • LocalTime.writeReplace
          • MonthDay.writeReplace
          • OffsetTime.writeReplace
          • OffsetDateTime.writeReplace
          • Period.writeReplace
          • Year.writeReplace
          • YearMonth.writeReplace
          • ZoneId.writeReplace
          • ZoneOffset.writeReplace
          • ZonedDateTime.writeReplace
          Throws:
          IOException - Includes any I/O exceptions that may occur

    • Class java.time.Year extends Object implements Serializable

      serialVersionUID:
      -23038383694477807L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws InvalidObjectException
          Defend against malicious streams.
          Throws:
          InvalidObjectException - always

        • writeReplace

          private Object writeReplace()
          Writes the object using a dedicated serialized form.
          Serial Data:
            out.writeByte(11);  // identifies a Year
  out.writeInt(year);

      • Serialized Fields

        • year

          int year
          The year being represented.

    • Class java.time.YearMonth extends Object implements Serializable

      serialVersionUID:
      4183400860270640070L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws InvalidObjectException
          Defend against malicious streams.
          Throws:
          InvalidObjectException - always

        • writeReplace

          private Object writeReplace()
          Writes the object using a dedicated serialized form.
          Serial Data:
            out.writeByte(12);  // identifies a YearMonth
  out.writeInt(year);
  out.writeByte(month);

      • Serialized Fields

        • year

          int year
          The year.

        • month

          int month
          The month-of-year, not null.

    • Class java.time.ZonedDateTime extends Object implements Serializable

      serialVersionUID:
      -6260982410461394882L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws InvalidObjectException
          Defend against malicious streams.
          Throws:
          InvalidObjectException - always

        • writeReplace

          private Object writeReplace()
          Writes the object using a dedicated serialized form.
          Serial Data:
            out.writeByte(6);  // identifies a ZonedDateTime
  // the dateTime excluding the one byte header
  // the offset excluding the one byte header
  // the zone ID excluding the one byte header

      • Serialized Fields

        • dateTime

          LocalDateTime dateTime
          The local date-time.

        • offset

          ZoneOffset offset
          The offset from UTC/Greenwich.

        • zone

          ZoneId zone
          The time-zone.

    • Class java.time.ZoneId extends Object implements Serializable

      serialVersionUID:
      8352817235686L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws InvalidObjectException
          Defend against malicious streams.
          Throws:
          InvalidObjectException - always

        • writeReplace

          private Object writeReplace()
          Writes the object using a dedicated serialized form.
          Serial Data:
            out.writeByte(7);  // identifies a ZoneId (not ZoneOffset)
  out.writeUTF(getId());

          When read back in, the ZoneId will be created as though using ZoneId.of(String), but without any exception in the case where the ID has a valid format, but is not in the known set of region-based IDs.

    • Class java.time.ZoneOffset extends ZoneId implements Serializable

      serialVersionUID:
      2357656521762053153L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws InvalidObjectException
          Defend against malicious streams.
          Throws:
          InvalidObjectException - always

        • writeReplace

          private Object writeReplace()
          Writes the object using a dedicated serialized form.
          Serial Data:
            out.writeByte(8);                  // identifies a ZoneOffset
  int offsetByte = totalSeconds % 900 == 0 ? totalSeconds / 900 : 127;
  out.writeByte(offsetByte);
  if (offsetByte == 127) {
      out.writeInt(totalSeconds);
  }

      • Serialized Fields

        • totalSeconds

          int totalSeconds
          The total offset in seconds.

  • Package java.time.chrono

    • Class java.time.chrono.ChronoLocalDateTimeImpl extends Object implements Serializable

      serialVersionUID:
      4556003607393004514L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws InvalidObjectException
          Defend against malicious streams.
          Throws:
          InvalidObjectException - always

        • writeReplace

          private Object writeReplace()
          Writes the ChronoLocalDateTime using a dedicated serialized form.
          Serial Data:
            out.writeByte(2);              // identifies a ChronoLocalDateTime
  out.writeObject(toLocalDate());
  out.witeObject(toLocalTime());

    • Class java.time.chrono.ChronoZonedDateTimeImpl extends Object implements Serializable

      serialVersionUID:
      -5261813987200935591L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws InvalidObjectException
          Defend against malicious streams.
          Throws:
          InvalidObjectException - always

        • writeReplace

          private Object writeReplace()
          Writes the ChronoZonedDateTime using a dedicated serialized form.
          Serial Data:
            out.writeByte(3);                  // identifies a ChronoZonedDateTime
  out.writeObject(toLocalDateTime());
  out.writeObject(getOffset());
  out.writeObject(getZone());

    • Class java.time.chrono.HijrahChronology extends AbstractChronology implements Serializable

      serialVersionUID:
      3127340209035924785L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws InvalidObjectException
          Defend against malicious streams.
          Throws:
          InvalidObjectException - always

        • writeReplace

          Object writeReplace()
          Writes the Chronology using a dedicated serialized form.
          Serial Data:
            out.writeByte(1);     // identifies a Chronology
  out.writeUTF(getId());

    • Class java.time.chrono.HijrahDate extends java.time.chrono.ChronoLocalDateImpl<HijrahDate> implements Serializable

      serialVersionUID:
      -5207853542612002020L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws InvalidObjectException
          Defend against malicious streams.
          Throws:
          InvalidObjectException - always

        • writeReplace

          private Object writeReplace()
          Writes the object using a dedicated serialized form.
          Serial Data:
            out.writeByte(6);                 // identifies a HijrahDate
  out.writeObject(chrono);          // the HijrahChronology variant
  out.writeInt(get(YEAR));
  out.writeByte(get(MONTH_OF_YEAR));
  out.writeByte(get(DAY_OF_MONTH));

    • Class java.time.chrono.IsoChronology extends AbstractChronology implements Serializable

      serialVersionUID:
      -1440403870442975015L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws InvalidObjectException
          Defend against malicious streams.
          Throws:
          InvalidObjectException - always

        • writeReplace

          Object writeReplace()
          Writes the Chronology using a dedicated serialized form.
          Serial Data:
            out.writeByte(1);     // identifies a Chronology
  out.writeUTF(getId());

    • Class java.time.chrono.JapaneseChronology extends AbstractChronology implements Serializable

      serialVersionUID:
      459996390165777884L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws InvalidObjectException
          Defend against malicious streams.
          Throws:
          InvalidObjectException - always

        • writeReplace

          Object writeReplace()
          Writes the Chronology using a dedicated serialized form.
          Serial Data:
            out.writeByte(1);     // identifies a Chronology
  out.writeUTF(getId());

    • Class java.time.chrono.JapaneseDate extends java.time.chrono.ChronoLocalDateImpl<JapaneseDate> implements Serializable

      serialVersionUID:
      -305327627230580483L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws InvalidObjectException
          Defend against malicious streams.
          Throws:
          InvalidObjectException - always

        • writeReplace

          private Object writeReplace()
          Writes the object using a dedicated serialized form.
          Serial Data:
            out.writeByte(4);                 // identifies a JapaneseDate
  out.writeInt(get(YEAR));
  out.writeByte(get(MONTH_OF_YEAR));
  out.writeByte(get(DAY_OF_MONTH));

    • Class java.time.chrono.JapaneseEra extends Object implements Serializable

      serialVersionUID:
      1466499369062886794L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws InvalidObjectException
          Defend against malicious streams.
          Throws:
          InvalidObjectException - always

        • writeReplace

          private Object writeReplace()
          Writes the object using a dedicated serialized form.
          Serial Data:
            out.writeByte(5);        // identifies a JapaneseEra
  out.writeInt(getValue());

    • Class java.time.chrono.MinguoChronology extends AbstractChronology implements Serializable

      serialVersionUID:
      1039765215346859963L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws InvalidObjectException
          Defend against malicious streams.
          Throws:
          InvalidObjectException - always

        • writeReplace

          Object writeReplace()
          Writes the Chronology using a dedicated serialized form.
          Serial Data:
            out.writeByte(1);     // identifies a Chronology
  out.writeUTF(getId());

    • Class java.time.chrono.MinguoDate extends java.time.chrono.ChronoLocalDateImpl<MinguoDate> implements Serializable

      serialVersionUID:
      1300372329181994526L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws InvalidObjectException
          Defend against malicious streams.
          Throws:
          InvalidObjectException - always

        • writeReplace

          private Object writeReplace()
          Writes the object using a dedicated serialized form.
          Serial Data:
            out.writeByte(8);                 // identifies a MinguoDate
  out.writeInt(get(YEAR));
  out.writeByte(get(MONTH_OF_YEAR));
  out.writeByte(get(DAY_OF_MONTH));

    • Class java.time.chrono.Ser extends Object implements Serializable

      serialVersionUID:
      -6103370247208168577L

      • Serialization Methods

        • readExternal

          public void readExternal(ObjectInput in)
                  throws IOException,
                         ClassNotFoundException
          Implements the Externalizable interface to read the object.
          Serial Data:
          The streamed type and parameters defined by the type's writeReplace method are read and passed to the corresponding static factory for the type to create a new instance. That instance is returned as the de-serialized Ser object.
          • HijrahChronology - Chronology.of(id)
          • IsoChronology - Chronology.of(id)
          • JapaneseChronology - Chronology.of(id)
          • MinguoChronology - Chronology.of(id)
          • ThaiBuddhistChronology - Chronology.of(id)
          • ChronoLocalDateTime - date.atTime(time)
          • ChronoZonedDateTime - dateTime.atZone(offset).withZoneSameLocal(zone)
          • JapaneseDate - JapaneseChronology.INSTANCE.date(year, month, dayOfMonth)
          • JapaneseEra - JapaneseEra.of(eraValue)
          • HijrahDate - HijrahChronology chrono.date(year, month, dayOfMonth)
          • MinguoDate - MinguoChronology.INSTANCE.date(year, month, dayOfMonth)
          • ThaiBuddhistDate - ThaiBuddhistChronology.INSTANCE.date(year, month, dayOfMonth)
          Throws:
          IOException - if I/O errors occur
          ClassNotFoundException - If the class for an object being restored cannot be found.

        • writeExternal

          public void writeExternal(ObjectOutput out)
                   throws IOException
          Implements the Externalizable interface to write the object.
          Serial Data:
          Each serializable class is mapped to a type that is the first byte in the stream. Refer to each class writeReplace serialized form for the value of the type and sequence of values for the type.
          • HijrahChronology.writeReplace
          • IsoChronology.writeReplace
          • JapaneseChronology.writeReplace
          • MinguoChronology.writeReplace
          • ThaiBuddhistChronology.writeReplace
          • ChronoLocalDateTime.writeReplace
          • ChronoZonedDateTime.writeReplace
          • JapaneseDate.writeReplace
          • JapaneseEra.writeReplace
          • HijrahDate.writeReplace
          • MinguoDate.writeReplace
          • ThaiBuddhistDate.writeReplace
          Throws:
          IOException - Includes any I/O exceptions that may occur

    • Class java.time.chrono.ThaiBuddhistChronology extends AbstractChronology implements Serializable

      serialVersionUID:
      2775954514031616474L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws InvalidObjectException
          Defend against malicious streams.
          Throws:
          InvalidObjectException - always

        • writeReplace

          Object writeReplace()
          Writes the Chronology using a dedicated serialized form.
          Serial Data:
            out.writeByte(1);     // identifies a Chronology
  out.writeUTF(getId());

    • Class java.time.chrono.ThaiBuddhistDate extends java.time.chrono.ChronoLocalDateImpl<ThaiBuddhistDate> implements Serializable

      serialVersionUID:
      -8722293800195731463L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws InvalidObjectException
          Defend against malicious streams.
          Throws:
          InvalidObjectException - always

        • writeReplace

          private Object writeReplace()
          Writes the object using a dedicated serialized form.
          Serial Data:
            out.writeByte(10);                // identifies a ThaiBuddhistDate
  out.writeInt(get(YEAR));
  out.writeByte(get(MONTH_OF_YEAR));
  out.writeByte(get(DAY_OF_MONTH));

  • Package java.time.format

    • Class java.time.format.DateTimeParseException extends DateTimeException implements Serializable

      serialVersionUID:
      4304633501674722597L

      • Serialized Fields

        • parsedString

          String parsedString
          The text that was being parsed.

        • errorIndex

          int errorIndex
          The error index in the text.

  • Package java.time.temporal

    • Class java.time.temporal.UnsupportedTemporalTypeException extends DateTimeException implements Serializable

      serialVersionUID:
      -6158898438688206006L

    • Class java.time.temporal.ValueRange extends Object implements Serializable

      serialVersionUID:
      -7317881728594519368L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException,
                        InvalidObjectException
          Restore the state of an ValueRange from the stream. Check that the values are valid.
          Throws:
          InvalidObjectException - if the smallest minimum is greater than the smallest maximum, or the smallest maximum is greater than the largest maximum or the largest minimum is greater than the largest maximum
          IOException
          ClassNotFoundException

      • Serialized Fields

        • minSmallest

          long minSmallest
          The smallest minimum value.

        • minLargest

          long minLargest
          The largest minimum value.

        • maxSmallest

          long maxSmallest
          The smallest maximum value.

        • maxLargest

          long maxLargest
          The largest maximum value.

    • Class java.time.temporal.WeekFields extends Object implements Serializable

      serialVersionUID:
      -1177360819670808121L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException,
                        InvalidObjectException
          Restore the state of a WeekFields from the stream. Check that the values are valid.
          Throws:
          InvalidObjectException - if the serialized object has an invalid value for firstDayOfWeek or minimalDays.
          IOException
          ClassNotFoundException

        • readResolve

          private Object readResolve()
                    throws InvalidObjectException
          Return the singleton WeekFields associated with the firstDayOfWeek and minimalDays.
          Throws:
          InvalidObjectException - if the serialized object has invalid values for firstDayOfWeek or minimalDays.

      • Serialized Fields

        • firstDayOfWeek

          DayOfWeek firstDayOfWeek
          The first day-of-week.

        • minimalDays

          int minimalDays
          The minimal number of days in the first week.

  • Package java.time.zone

    • Class java.time.zone.Ser extends Object implements Serializable

      serialVersionUID:
      -8885321777449118786L

      • Serialization Methods

        • readExternal

          public void readExternal(ObjectInput in)
                  throws IOException,
                         ClassNotFoundException
          Implements the Externalizable interface to read the object.
          Serial Data:
          The streamed type and parameters defined by the type's writeReplace method are read and passed to the corresponding static factory for the type to create a new instance. That instance is returned as the de-serialized Ser object.
          • ZoneRules - ZoneRules.of(standardTransitions, standardOffsets, savingsInstantTransitions, wallOffsets, lastRules);
          • ZoneOffsetTransition - ZoneOffsetTransition of(LocalDateTime.ofEpochSecond(epochSecond), offsetBefore, offsetAfter);
          • ZoneOffsetTransitionRule - ZoneOffsetTransitionRule.of(month, dom, dow, time, timeEndOfDay, timeDefinition, standardOffset, offsetBefore, offsetAfter);
          Throws:
          IOException - if I/O errors occur
          ClassNotFoundException - If the class for an object being restored cannot be found.

        • writeExternal

          public void writeExternal(ObjectOutput out)
                   throws IOException
          Implements the Externalizable interface to write the object.
          Serial Data:
          Each serializable class is mapped to a type that is the first byte in the stream. Refer to each class writeReplace serialized form for the value of the type and sequence of values for the type.
          • ZoneRules.writeReplace
          • ZoneOffsetTransition.writeReplace
          • ZoneOffsetTransitionRule.writeReplace
          Throws:
          IOException - Includes any I/O exceptions that may occur

    • Class java.time.zone.ZoneOffsetTransition extends Object implements Serializable

      serialVersionUID:
      -6946044323557704546L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws InvalidObjectException
          Defend against malicious streams.
          Throws:
          InvalidObjectException - always

        • writeReplace

          private Object writeReplace()
          Writes the object using a dedicated serialized form.
          Serial Data:
          Refer to the serialized form of ZoneRules.writeReplace for the encoding of epoch seconds and offsets.
          out.writeByte(2);                // identifies a ZoneOffsetTransition
   out.writeEpochSec(toEpochSecond);
   out.writeOffset(offsetBefore);
   out.writeOffset(offsetAfter);

      • Serialized Fields

        • transition

          LocalDateTime transition
          The local transition date-time at the transition.

        • offsetBefore

          ZoneOffset offsetBefore
          The offset before transition.

        • offsetAfter

          ZoneOffset offsetAfter
          The offset after transition.

    • Class java.time.zone.ZoneOffsetTransitionRule extends Object implements Serializable

      serialVersionUID:
      6889046316657758795L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws InvalidObjectException
          Defend against malicious streams.
          Throws:
          InvalidObjectException - always

        • writeReplace

          private Object writeReplace()
          Writes the object using a dedicated serialized form.
          Serial Data:
          Refer to the serialized form of ZoneRules.writeReplace for the encoding of epoch seconds and offsets.
          out.writeByte(3);                // identifies a ZoneOffsetTransition
      final int timeSecs = (timeEndOfDay ? 86400 : time.toSecondOfDay());
      final int stdOffset = standardOffset.getTotalSeconds();
      final int beforeDiff = offsetBefore.getTotalSeconds() - stdOffset;
      final int afterDiff = offsetAfter.getTotalSeconds() - stdOffset;
      final int timeByte = (timeSecs % 3600 == 0 ? (timeEndOfDay ? 24 : time.getHour()) : 31);
      final int stdOffsetByte = (stdOffset % 900 == 0 ? stdOffset / 900 + 128 : 255);
      final int beforeByte = (beforeDiff == 0 || beforeDiff == 1800 || beforeDiff == 3600 ? beforeDiff / 1800 : 3);
      final int afterByte = (afterDiff == 0 || afterDiff == 1800 || afterDiff == 3600 ? afterDiff / 1800 : 3);
      final int dowByte = (dow == null ? 0 : dow.getValue());
      int b = (month.getValue() << 28) +          // 4 bits
              ((dom + 32) << 22) +                // 6 bits
              (dowByte << 19) +                   // 3 bits
              (timeByte << 14) +                  // 5 bits
              (timeDefinition.ordinal() << 12) +  // 2 bits
              (stdOffsetByte << 4) +              // 8 bits
              (beforeByte << 2) +                 // 2 bits
              afterByte;                          // 2 bits
      out.writeInt(b);
      if (timeByte == 31) {
          out.writeInt(timeSecs);
      }
      if (stdOffsetByte == 255) {
          out.writeInt(stdOffset);
      }
      if (beforeByte == 3) {
          out.writeInt(offsetBefore.getTotalSeconds());
      }
      if (afterByte == 3) {
          out.writeInt(offsetAfter.getTotalSeconds());
      }

      • Serialized Fields

        • month

          Month month
          The month of the month-day of the first day of the cutover week. The actual date will be adjusted by the dowChange field.

        • dom

          byte dom
          The day-of-month of the month-day of the cutover week. If positive, it is the start of the week where the cutover can occur. If negative, it represents the end of the week where cutover can occur. The value is the number of days from the end of the month, such that -1 is the last day of the month, -2 is the second to last day, and so on.

        • dow

          DayOfWeek dow
          The cutover day-of-week, null to retain the day-of-month.

        • time

          LocalTime time
          The cutover time in the 'before' offset.

        • timeEndOfDay

          boolean timeEndOfDay
          Whether the cutover time is midnight at the end of day.

        • timeDefinition

          ZoneOffsetTransitionRule.TimeDefinition timeDefinition
          The definition of how the local time should be interpreted.

        • standardOffset

          ZoneOffset standardOffset
          The standard offset at the cutover.

        • offsetBefore

          ZoneOffset offsetBefore
          The offset before the cutover.

        • offsetAfter

          ZoneOffset offsetAfter
          The offset after the cutover.

    • Class java.time.zone.ZoneRules extends Object implements Serializable

      serialVersionUID:
      3044319355680032515L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws InvalidObjectException
          Defend against malicious streams.
          Throws:
          InvalidObjectException - always

        • writeReplace

          private Object writeReplace()
          Writes the object using a dedicated serialized form.
          Serial Data:
          out.writeByte(1);  // identifies a ZoneRules
   out.writeInt(standardTransitions.length);
   for (long trans : standardTransitions) {
       Ser.writeEpochSec(trans, out);
   }
   for (ZoneOffset offset : standardOffsets) {
       Ser.writeOffset(offset, out);
   }
   out.writeInt(savingsInstantTransitions.length);
   for (long trans : savingsInstantTransitions) {
       Ser.writeEpochSec(trans, out);
   }
   for (ZoneOffset offset : wallOffsets) {
       Ser.writeOffset(offset, out);
   }
   out.writeByte(lastRules.length);
   for (ZoneOffsetTransitionRule rule : lastRules) {
       rule.writeExternal(out);
   }

          Epoch second values used for offsets are encoded in a variable length form to make the common cases put fewer bytes in the stream.

          static void writeEpochSec(long epochSec, DataOutput out) throws IOException {
     if (epochSec >= -4575744000L && epochSec < 10413792000L && epochSec % 900 == 0) {  // quarter hours between 1825 and 2300
         int store = (int) ((epochSec + 4575744000L) / 900);
         out.writeByte((store >>> 16) & 255);
         out.writeByte((store >>> 8) & 255);
         out.writeByte(store & 255);
      } else {
          out.writeByte(255);
          out.writeLong(epochSec);
      }
  }

          ZoneOffset values are encoded in a variable length form so the common cases put fewer bytes in the stream.

          static void writeOffset(ZoneOffset offset, DataOutput out) throws IOException {
     final int offsetSecs = offset.getTotalSeconds();
     int offsetByte = offsetSecs % 900 == 0 ? offsetSecs / 900 : 127;  // compress to -72 to +72
     out.writeByte(offsetByte);
     if (offsetByte == 127) {
         out.writeInt(offsetSecs);
     }
 }

      • Serialized Fields

        • standardTransitions

          long[] standardTransitions
          The transitions between standard offsets (epoch seconds), sorted.

        • standardOffsets

          ZoneOffset[] standardOffsets
          The standard offsets.

        • savingsInstantTransitions

          long[] savingsInstantTransitions
          The transitions between instants (epoch seconds), sorted.

        • savingsLocalTransitions

          LocalDateTime[] savingsLocalTransitions
          The transitions between local date-times, sorted. This is a paired array, where the first entry is the start of the transition and the second entry is the end of the transition.

        • wallOffsets

          ZoneOffset[] wallOffsets
          The wall offsets.

        • lastRules

          ZoneOffsetTransitionRule[] lastRules
          The last rule.

    • Class java.time.zone.ZoneRulesException extends DateTimeException implements Serializable

      serialVersionUID:
      -1632418723876261839L

  • Package java.util

    • Class java.util.AbstractMap.SimpleEntry extends Object implements Serializable

      serialVersionUID:
      -8499721149061103585L

      • Serialized Fields

        • key

          Object key

        • value

          Object value

    • Class java.util.AbstractMap.SimpleImmutableEntry extends Object implements Serializable

      serialVersionUID:
      7138329143949025153L

      • Serialized Fields

        • key

          Object key

        • value

          Object value

    • Class java.util.ArrayDeque extends AbstractCollection<E> implements Serializable

      serialVersionUID:
      2340985798034038923L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Reconstitutes this deque from a stream (that is, deserializes it).
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Saves this deque to a stream (that is, serializes it).
          Serial Data:
          The current size (int) of the deque, followed by all of its elements (each an object reference) in first-to-last order.
          Throws:
          IOException

    • Class java.util.ArrayList extends AbstractList<E> implements Serializable

      serialVersionUID:
      8683452581122892189L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Reconstitute the ArrayList instance from a stream (that is, deserialize it).
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Save the state of the ArrayList instance to a stream (that is, serialize it).
          Serial Data:
          The length of the array backing the ArrayList instance is emitted (int), followed by all of its elements (each an Object) in the proper order.
          Throws:
          IOException

      • Serialized Fields

        • size

          int size
          The size of the ArrayList (the number of elements it contains).

    • Class java.util.Arrays.ArrayList extends AbstractList<E> implements Serializable

      serialVersionUID:
      -2764017481108945198L

      • Serialized Fields

        • a

          Object[] a

    • Class java.util.BitSet extends Object implements Serializable

      serialVersionUID:
      7997698588986878753L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Reconstitute the BitSet instance from a stream (i.e., deserialize it).
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Save the state of the BitSet instance to a stream (i.e., serialize it).
          Throws:
          IOException

      • Serialized Fields

        • bits

          long[] bits
          The bits in this BitSet. The ith bit is stored in bits[i/64] at bit position i % 64 (where bit position 0 refers to the least significant bit and 63 refers to the most significant bit).

    • Class java.util.Calendar extends Object implements Serializable

      serialVersionUID:
      -1807547505821590642L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream stream)
                 throws IOException,
                        ClassNotFoundException
          Reconstitutes this object from a stream (i.e., deserialize it).
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream stream)
                  throws IOException
          Save the state of this object to a stream (i.e., serialize it). Ideally, Calendar would only write out its state data and the current time, and not write any field data out, such as fields[], isTimeSet, areFieldsSet, and isSet[]. nextStamp also should not be part of the persistent state. Unfortunately, this didn't happen before JDK 1.1 shipped. To be compatible with JDK 1.1, we will always have to write out the field values and state flags. However, nextStamp can be removed from the serialization stream; this will probably happen in the near future.
          Throws:
          IOException

      • Serialized Fields

        • fields

          int[] fields
          The calendar field values for the currently set time for this calendar. This is an array of FIELD_COUNT integers, with index values ERA through DST_OFFSET.

        • isSet

          boolean[] isSet
          The flags which tell if a specified calendar field for the calendar is set. A new object has no fields set. After the first call to a method which generates the fields, they all remain set after that. This is an array of FIELD_COUNT booleans, with index values ERA through DST_OFFSET.

        • time

          long time
          The currently set time for this calendar, expressed in milliseconds after January 1, 1970, 0:00:00 GMT.
          See Also:
          Calendar.isTimeSet

        • isTimeSet

          boolean isTimeSet
          True if then the value of time is valid. The time is made invalid by a change to an item of field[].
          See Also:
          Calendar.time

        • areFieldsSet

          boolean areFieldsSet
          True if fields[] are in sync with the currently set time. If false, then the next attempt to get the value of a field will force a recomputation of all fields from the current value of time.

        • lenient

          boolean lenient
          True if this calendar allows out-of-range field values during computation of time from fields[].
          See Also:
          Calendar.setLenient(boolean), Calendar.isLenient()

        • zone

          TimeZone zone
          The TimeZone used by this calendar. Calendar uses the time zone data to translate between locale and GMT time.

        • firstDayOfWeek

          int firstDayOfWeek
          The first day of the week, with possible values SUNDAY, MONDAY, etc. This is a locale-dependent value.

        • minimalDaysInFirstWeek

          int minimalDaysInFirstWeek
          The number of days required for the first week in a month or year, with possible values from 1 to 7. This is a locale-dependent value.

        • nextStamp

          int nextStamp
          The next available value for stamp[], an internal array. This actually should not be written out to the stream, and will probably be removed from the stream in the near future. In the meantime, a value of MINIMUM_USER_STAMP should be used.

        • serialVersionOnStream

          int serialVersionOnStream
          The version of the serialized data on the stream. Possible values:
          0 or not present on stream
          JDK 1.1.5 or earlier.
          1
          JDK 1.1.6 or later. Writes a correct 'time' value as well as compatible values for other fields. This is a transitional format.
          When streaming out this class, the most recent format and the highest allowable serialVersionOnStream is written.
          Since:
          JDK1.1.6

    • Class java.util.Collections.AsLIFOQueue extends AbstractQueue<E> implements Serializable

      serialVersionUID:
      1802017725587941708L

      • Serialized Fields

        • q

          Deque<E> q

    • Class java.util.Collections.CheckedCollection extends Object implements Serializable

      serialVersionUID:
      1578914078182001775L

      • Serialized Fields

        • c

          Collection<E> c

        • type

          Class<T> type

        • zeroLengthElementArray

          Object[] zeroLengthElementArray

    • Class java.util.Collections.CheckedList extends java.util.Collections.CheckedCollection<E> implements Serializable

      serialVersionUID:
      65247728283967356L

      • Serialized Fields

        • list

          List<E> list

    • Class java.util.Collections.CheckedMap extends Object implements Serializable

      serialVersionUID:
      5742860141034234728L

      • Serialized Fields

        • m

          Map<K,V> m

        • keyType

          Class<T> keyType

        • valueType

          Class<T> valueType

    • Class java.util.Collections.CheckedNavigableMap extends java.util.Collections.CheckedSortedMap<K,V> implements Serializable

      serialVersionUID:
      -4852462692372534096L

      • Serialized Fields

        • nm

          NavigableMap<K,V> nm

    • Class java.util.Collections.CheckedNavigableSet extends java.util.Collections.CheckedSortedSet<E> implements Serializable

      serialVersionUID:
      -5429120189805438922L

      • Serialized Fields

        • ns

          NavigableSet<E> ns

    • Class java.util.Collections.CheckedQueue extends java.util.Collections.CheckedCollection<E> implements Serializable

      serialVersionUID:
      1433151992604707767L

      • Serialized Fields

        • queue

          Queue<E> queue

    • Class java.util.Collections.CheckedRandomAccessList extends java.util.Collections.CheckedList<E> implements Serializable

      serialVersionUID:
      1638200125423088369L

    • Class java.util.Collections.CheckedSet extends java.util.Collections.CheckedCollection<E> implements Serializable

      serialVersionUID:
      4694047833775013803L

    • Class java.util.Collections.CheckedSortedMap extends java.util.Collections.CheckedMap<K,V> implements Serializable

      serialVersionUID:
      1599671320688067438L

      • Serialized Fields

        • sm

          SortedMap<K,V> sm

    • Class java.util.Collections.CheckedSortedSet extends java.util.Collections.CheckedSet<E> implements Serializable

      serialVersionUID:
      1599911165492914959L

      • Serialized Fields

        • ss

          SortedSet<E> ss

    • Class java.util.Collections.CopiesList extends AbstractList<E> implements Serializable

      serialVersionUID:
      2739099268398711800L

      • Serialized Fields

        • n

          int n

        • element

          Object element

    • Class java.util.Collections.EmptyList extends AbstractList<E> implements Serializable

      serialVersionUID:
      8842843931221139166L

      • Serialization Methods

        • readResolve

          private Object readResolve()

    • Class java.util.Collections.EmptyMap extends AbstractMap<K,V> implements Serializable

      serialVersionUID:
      6428348081105594320L

      • Serialization Methods

        • readResolve

          private Object readResolve()

    • Class java.util.Collections.EmptySet extends AbstractSet<E> implements Serializable

      serialVersionUID:
      1582296315990362920L

      • Serialization Methods

        • readResolve

          private Object readResolve()

    • Class java.util.Collections.ReverseComparator extends Object implements Serializable

      serialVersionUID:
      7207038068494060240L

      • Serialization Methods

        • readResolve

          private Object readResolve()

    • Class java.util.Collections.ReverseComparator2 extends Object implements Serializable

      serialVersionUID:
      4374092139857L

      • Serialized Fields

        • cmp

          Comparator<T> cmp
          The comparator specified in the static factory. This will never be null, as the static factory returns a ReverseComparator instance if its argument is null.

    • Class java.util.Collections.SetFromMap extends AbstractSet<E> implements Serializable

      serialVersionUID:
      2454657854757543876L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream stream)
                 throws IOException,
                        ClassNotFoundException
          Throws:
          IOException
          ClassNotFoundException

      • Serialized Fields

        • m

          Map<K,V> m

    • Class java.util.Collections.SingletonList extends AbstractList<E> implements Serializable

      serialVersionUID:
      3093736618740652951L

      • Serialized Fields

        • element

          Object element

    • Class java.util.Collections.SingletonMap extends AbstractMap<K,V> implements Serializable

      serialVersionUID:
      -6979724477215052911L

      • Serialized Fields

        • k

          Object k

        • v

          Object v

    • Class java.util.Collections.SingletonSet extends AbstractSet<E> implements Serializable

      serialVersionUID:
      3193687207550431679L

      • Serialized Fields

        • element

          Object element

    • Class java.util.Collections.SynchronizedCollection extends Object implements Serializable

      serialVersionUID:
      3053995032091335093L

      • Serialization Methods

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Throws:
          IOException

      • Serialized Fields

        • c

          Collection<E> c

        • mutex

          Object mutex

    • Class java.util.Collections.SynchronizedList extends java.util.Collections.SynchronizedCollection<E> implements Serializable

      serialVersionUID:
      -7754090372962971524L

      • Serialization Methods

        • readResolve

          private Object readResolve()
          SynchronizedRandomAccessList instances are serialized as SynchronizedList instances to allow them to be deserialized in pre-1.4 JREs (which do not have SynchronizedRandomAccessList). This method inverts the transformation. As a beneficial side-effect, it also grafts the RandomAccess marker onto SynchronizedList instances that were serialized in pre-1.4 JREs. Note: Unfortunately, SynchronizedRandomAccessList instances serialized in 1.4.1 and deserialized in 1.4 will become SynchronizedList instances, as this method was missing in 1.4.

      • Serialized Fields

        • list

          List<E> list

    • Class java.util.Collections.SynchronizedMap extends Object implements Serializable

      serialVersionUID:
      1978198479659022715L

      • Serialization Methods

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Throws:
          IOException

      • Serialized Fields

        • m

          Map<K,V> m

        • mutex

          Object mutex

    • Class java.util.Collections.SynchronizedNavigableMap extends java.util.Collections.SynchronizedSortedMap<K,V> implements Serializable

      serialVersionUID:
      699392247599746807L

      • Serialized Fields

        • nm

          NavigableMap<K,V> nm

    • Class java.util.Collections.SynchronizedNavigableSet extends java.util.Collections.SynchronizedSortedSet<E> implements Serializable

      serialVersionUID:
      -5505529816273629798L

      • Serialized Fields

        • ns

          NavigableSet<E> ns

    • Class java.util.Collections.SynchronizedRandomAccessList extends java.util.Collections.SynchronizedList<E> implements Serializable

      serialVersionUID:
      1530674583602358482L

      • Serialization Methods

        • writeReplace

          private Object writeReplace()
          Allows instances to be deserialized in pre-1.4 JREs (which do not have SynchronizedRandomAccessList). SynchronizedList has a readResolve method that inverts this transformation upon deserialization.

    • Class java.util.Collections.SynchronizedSet extends java.util.Collections.SynchronizedCollection<E> implements Serializable

      serialVersionUID:
      487447009682186044L

    • Class java.util.Collections.SynchronizedSortedMap extends java.util.Collections.SynchronizedMap<K,V> implements Serializable

      serialVersionUID:
      -8798146769416483793L

      • Serialized Fields

        • sm

          SortedMap<K,V> sm

    • Class java.util.Collections.SynchronizedSortedSet extends java.util.Collections.SynchronizedSet<E> implements Serializable

      serialVersionUID:
      8695801310862127406L

      • Serialized Fields

        • ss

          SortedSet<E> ss

    • Class java.util.Collections.UnmodifiableCollection extends Object implements Serializable

      serialVersionUID:
      1820017752578914078L

      • Serialized Fields

        • c

          Collection<E> c

    • Class java.util.Collections.UnmodifiableList extends java.util.Collections.UnmodifiableCollection<E> implements Serializable

      serialVersionUID:
      -283967356065247728L

      • Serialization Methods

        • readResolve

          private Object readResolve()
          UnmodifiableRandomAccessList instances are serialized as UnmodifiableList instances to allow them to be deserialized in pre-1.4 JREs (which do not have UnmodifiableRandomAccessList). This method inverts the transformation. As a beneficial side-effect, it also grafts the RandomAccess marker onto UnmodifiableList instances that were serialized in pre-1.4 JREs. Note: Unfortunately, UnmodifiableRandomAccessList instances serialized in 1.4.1 and deserialized in 1.4 will become UnmodifiableList instances, as this method was missing in 1.4.

      • Serialized Fields

        • list

          List<E> list

    • Class java.util.Collections.UnmodifiableMap extends Object implements Serializable

      serialVersionUID:
      -1034234728574286014L

      • Serialized Fields

        • m

          Map<K,V> m

    • Class java.util.Collections.UnmodifiableMap.UnmodifiableEntrySet extends java.util.Collections.UnmodifiableSet<Map.Entry<K,V>> implements Serializable

      serialVersionUID:
      7854390611657943733L

    • Class java.util.Collections.UnmodifiableNavigableMap extends java.util.Collections.UnmodifiableSortedMap<K,V> implements Serializable

      serialVersionUID:
      -4858195264774772197L

      • Serialized Fields

        • nm

          NavigableMap<K,V> nm
          The instance we wrap and protect.

    • Class java.util.Collections.UnmodifiableNavigableSet extends java.util.Collections.UnmodifiableSortedSet<E> implements Serializable

      serialVersionUID:
      -6027448201786391929L

      • Serialized Fields

        • ns

          NavigableSet<E> ns
          The instance we are protecting.

    • Class java.util.Collections.UnmodifiableRandomAccessList extends java.util.Collections.UnmodifiableList<E> implements Serializable

      serialVersionUID:
      -2542308836966382001L

      • Serialization Methods

        • writeReplace

          private Object writeReplace()
          Allows instances to be deserialized in pre-1.4 JREs (which do not have UnmodifiableRandomAccessList). UnmodifiableList has a readResolve method that inverts this transformation upon deserialization.

    • Class java.util.Collections.UnmodifiableSet extends java.util.Collections.UnmodifiableCollection<E> implements Serializable

      serialVersionUID:
      -9215047833775013803L

    • Class java.util.Collections.UnmodifiableSortedMap extends java.util.Collections.UnmodifiableMap<K,V> implements Serializable

      serialVersionUID:
      -8806743815996713206L

      • Serialized Fields

        • sm

          SortedMap<K,V> sm

    • Class java.util.Collections.UnmodifiableSortedSet extends java.util.Collections.UnmodifiableSet<E> implements Serializable

      serialVersionUID:
      -4929149591599911165L

      • Serialized Fields

        • ss

          SortedSet<E> ss

    • Class java.util.ConcurrentModificationException extends RuntimeException implements Serializable

      serialVersionUID:
      -3666751008965953603L

    • Class java.util.Currency extends Object implements Serializable

      serialVersionUID:
      -158308464356906721L

      • Serialization Methods

        • readResolve

          private Object readResolve()
          Resolves instances being deserialized to a single instance per currency.

      • Serialized Fields

        • currencyCode

          String currencyCode
          ISO 4217 currency code for this currency.

    • Class java.util.Date extends Object implements Serializable

      serialVersionUID:
      7523967970034938905L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Reconstitute this object from a stream (i.e., deserialize it).
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Save the state of this object to a stream (i.e., serialize it).
          Serial Data:
          The value returned by getTime() is emitted (long). This represents the offset from January 1, 1970, 00:00:00 GMT in milliseconds.
          Throws:
          IOException

    • Class java.util.DuplicateFormatFlagsException extends IllegalFormatException implements Serializable

      serialVersionUID:
      18890531L

      • Serialized Fields

        • flags

          String flags

    • Class java.util.EmptyStackException extends RuntimeException implements Serializable

      serialVersionUID:
      5084686378493302095L

    • Class java.util.EnumMap extends AbstractMap<K extends Enum<K>,V> implements Serializable

      serialVersionUID:
      458661240069192865L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Reconstitute the EnumMap instance from a stream (i.e., deserialize it).
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Save the state of the EnumMap instance to a stream (i.e., serialize it).
          Serial Data:
          The size of the enum map (the number of key-value mappings) is emitted (int), followed by the key (Object) and value (Object) for each key-value mapping represented by the enum map.
          Throws:
          IOException

      • Serialized Fields

        • keyType

          Class<T> keyType
          The Class object for the enum type of all the keys of this map.

    • Class java.util.EnumSet.SerializationProxy extends Object implements Serializable

      serialVersionUID:
      362491234563181265L

      • Serialization Methods

        • readResolve

          private Object readResolve()

      • Serialized Fields

        • elementType

          Class<T> elementType
          The element type of this enum set.

        • elements

          Enum<E extends Enum<E>>[] elements
          The elements contained in this enum set.

    • Class java.util.EventObject extends Object implements Serializable

      serialVersionUID:
      5516075349620653480L

    • Class java.util.FormatFlagsConversionMismatchException extends IllegalFormatException implements Serializable

      serialVersionUID:
      19120414L

      • Serialized Fields

        • f

          String f

        • c

          char c

    • Class java.util.FormatterClosedException extends IllegalStateException implements Serializable

      serialVersionUID:
      18111216L

    • Class java.util.GregorianCalendar extends Calendar implements Serializable

      serialVersionUID:
      -8125100834729963327L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream stream)
                 throws IOException,
                        ClassNotFoundException
          Updates internal state.
          Throws:
          IOException
          ClassNotFoundException

      • Serialized Fields

        • gregorianCutover

          long gregorianCutover
          The point at which the Gregorian calendar rules are used, measured in milliseconds from the standard epoch. Default is October 15, 1582 (Gregorian) 00:00:00 UTC or -12219292800000L. For this value, October 4, 1582 (Julian) is followed by October 15, 1582 (Gregorian). This corresponds to Julian day number 2299161.

    • Class java.util.HashMap extends AbstractMap<K,V> implements Serializable

      serialVersionUID:
      362498820763181265L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Reconstitute the HashMap instance from a stream (i.e., deserialize it).
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Save the state of the HashMap instance to a stream (i.e., serialize it).
          Serial Data:
          The capacity of the HashMap (the length of the bucket array) is emitted (int), followed by the size (an int, the number of key-value mappings), followed by the key (Object) and value (Object) for each key-value mapping. The key-value mappings are emitted in no particular order.
          Throws:
          IOException

      • Serialized Fields

        • threshold

          int threshold
          The next size value at which to resize (capacity * load factor).

        • loadFactor

          float loadFactor
          The load factor for the hash table.

    • Class java.util.HashSet extends AbstractSet<E> implements Serializable

      serialVersionUID:
      -5024744406713321676L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Reconstitute the HashSet instance from a stream (that is, deserialize it).
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Save the state of this HashSet instance to a stream (that is, serialize it).
          Serial Data:
          The capacity of the backing HashMap instance (int), and its load factor (float) are emitted, followed by the size of the set (the number of elements it contains) (int), followed by all of its elements (each an Object) in no particular order.
          Throws:
          IOException

    • Class java.util.Hashtable extends Dictionary<K,V> implements Serializable

      serialVersionUID:
      1421746759512286392L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Reconstitute the Hashtable from a stream (i.e., deserialize it).
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Save the state of the Hashtable to a stream (i.e., serialize it).
          Serial Data:
          The capacity of the Hashtable (the length of the bucket array) is emitted (int), followed by the size of the Hashtable (the number of key-value mappings), followed by the key (Object) and value (Object) for each key-value mapping represented by the Hashtable The key-value mappings are emitted in no particular order.
          Throws:
          IOException

      • Serialized Fields

        • threshold

          int threshold
          The table is rehashed when its size exceeds this threshold. (The value of this field is (int)(capacity * loadFactor).)

        • loadFactor

          float loadFactor
          The load factor for the hashtable.

    • Class java.util.IdentityHashMap extends AbstractMap<K,V> implements Serializable

      serialVersionUID:
      8188218128353913216L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Reconstitute the IdentityHashMap instance from a stream (i.e., deserialize it).
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Save the state of the IdentityHashMap instance to a stream (i.e., serialize it).
          Serial Data:
          The size of the HashMap (the number of key-value mappings) (int), followed by the key (Object) and value (Object) for each key-value mapping represented by the IdentityHashMap. The key-value mappings are emitted in no particular order.
          Throws:
          IOException

      • Serialized Fields

        • size

          int size
          The number of key-value mappings contained in this identity hash map.

    • Class java.util.IllegalFormatCodePointException extends IllegalFormatException implements Serializable

      serialVersionUID:
      19080630L

      • Serialized Fields

        • c

          int c

    • Class java.util.IllegalFormatConversionException extends IllegalFormatException implements Serializable

      serialVersionUID:
      17000126L

      • Serialized Fields

        • c

          char c

        • arg

          Class<T> arg

    • Class java.util.IllegalFormatException extends IllegalArgumentException implements Serializable

      serialVersionUID:
      18830826L

    • Class java.util.IllegalFormatFlagsException extends IllegalFormatException implements Serializable

      serialVersionUID:
      790824L

      • Serialized Fields

        • flags

          String flags

    • Class java.util.IllegalFormatPrecisionException extends IllegalFormatException implements Serializable

      serialVersionUID:
      18711008L

      • Serialized Fields

        • p

          int p

    • Class java.util.IllegalFormatWidthException extends IllegalFormatException implements Serializable

      serialVersionUID:
      16660902L

      • Serialized Fields

        • w

          int w

    • Class java.util.IllformedLocaleException extends RuntimeException implements Serializable

      serialVersionUID:
      -5245986824925681401L

      • Serialized Fields

        • _errIdx

          int _errIdx

    • Class java.util.InputMismatchException extends NoSuchElementException implements Serializable

      serialVersionUID:
      8811230760997066428L

    • Class java.util.LinkedHashMap extends HashMap<K,V> implements Serializable

      serialVersionUID:
      3801124242820219131L

      • Serialized Fields

        • accessOrder

          boolean accessOrder
          The iteration ordering method for this linked hash map: true for access-order, false for insertion-order.

    • Class java.util.LinkedHashSet extends HashSet<E> implements Serializable

      serialVersionUID:
      -2851667679971038690L

    • Class java.util.LinkedList extends AbstractSequentialList<E> implements Serializable

      serialVersionUID:
      876323262645176354L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Reconstitutes this LinkedList instance from a stream (that is, deserializes it).
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Saves the state of this LinkedList instance to a stream (that is, serializes it).
          Serial Data:
          The size of the list (the number of elements it contains) is emitted (int), followed by all of its elements (each an Object) in the proper order.
          Throws:
          IOException

    • Class java.util.Locale extends Object implements Serializable

      serialVersionUID:
      9149081749638150636L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          Deserializes this Locale.
          Throws:
          IOException
          ClassNotFoundException
          IllformedLocaleException
          Since:
          1.7

        • writeObject

          private void writeObject(ObjectOutputStream out)
                  throws IOException
          Serializes this Locale to the specified ObjectOutputStream.
          Throws:
          IOException
          Since:
          1.7

        • readResolve

          private Object readResolve()
                    throws ObjectStreamException
          Returns a cached Locale instance equivalent to the deserialized Locale. When serialized language, country and variant fields read from the object data stream are exactly "ja", "JP", "JP" or "th", "TH", "TH" and script/extensions fields are empty, this method supplies UNICODE_LOCALE_EXTENSION "ca"/"japanese" (calendar type is "japanese") or "nu"/"thai" (number script type is "thai"). See Special Cases for more information.
          Throws:
          ObjectStreamException

      • Serialized Fields

        • country

          String country
          country subtag in upper case. (See getCountry())

        • extensions

          String extensions
          canonical representation of extensions, that is, BCP47 extensions in alphabetical order followed by BCP47 private use subtags, all in lower case letters separated by HYPHEN-MINUS characters. (See getExtensionKeys(), getExtension(char))

        • hashcode

          int hashcode
          deprecated, for forward compatibility only

        • language

          String language
          language subtag in lower case. (See getLanguage())

        • script

          String script
          script subtag in title case (See getScript())

        • variant

          String variant
          variant subtags separated by LOWLINE characters. (See getVariant())

    • Class java.util.MissingFormatArgumentException extends IllegalFormatException implements Serializable

      serialVersionUID:
      19190115L

      • Serialized Fields

        • s

          String s

    • Class java.util.MissingFormatWidthException extends IllegalFormatException implements Serializable

      serialVersionUID:
      15560123L

      • Serialized Fields

        • s

          String s

    • Class java.util.MissingResourceException extends RuntimeException implements Serializable

      serialVersionUID:
      -4876345176062000401L

      • Serialized Fields

        • className

          String className
          The class name of the resource bundle requested by the user.

        • key

          String key
          The name of the specific resource requested by the user.

    • Class java.util.NoSuchElementException extends RuntimeException implements Serializable

      serialVersionUID:
      6769829250639411880L

    • Class java.util.PriorityQueue extends AbstractQueue<E> implements Serializable

      serialVersionUID:
      -7720805057305804111L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Reconstitutes the PriorityQueue instance from a stream (that is, deserializes it).
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Saves this queue to a stream (that is, serializes it).
          Serial Data:
          The length of the array backing the instance is emitted (int), followed by all of its elements (each an Object) in the proper order.
          Throws:
          IOException

      • Serialized Fields

        • size

          int size
          The number of elements in the priority queue.

        • comparator

          Comparator<T> comparator
          The comparator, or null if priority queue uses elements' natural ordering.

    • Class java.util.Properties extends Hashtable<Object,Object> implements Serializable

      serialVersionUID:
      4112578634029874840L

      • Serialized Fields

        • defaults

          Properties defaults
          A property list that contains default values for any keys not found in this property list.

    • Class java.util.PropertyPermissionCollection extends PermissionCollection implements Serializable

      serialVersionUID:
      7015263904581634791L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream out)
                  throws IOException
          Serial Data:
          Default fields.
          Throws:
          IOException

      • Serialized Fields

        • all_allowed

          boolean all_allowed
          boolean saying if "*" is in the collection.

        • permissions

          Hashtable<K,V> permissions
          A table of the PropertyPermissions.

    • Class java.util.Random extends Object implements Serializable

      serialVersionUID:
      3905348978240129619L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Reconstitute the Random instance from a stream (that is, deserialize it).
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Save the Random instance to a stream.
          Throws:
          IOException

      • Serialization Overview

        • Serializable fields for Random.

      • Serialized Fields

        • haveNextNextGaussian

          boolean haveNextNextGaussian
          nextNextGaussian is valid

        • nextNextGaussian

          double nextNextGaussian
          next Gaussian to be returned

        • seed

          long seed
          seed for random computations

    • Class java.util.ServiceConfigurationError extends Error implements Serializable

      serialVersionUID:
      74132770414881L

    • Class java.util.SimpleTimeZone extends TimeZone implements Serializable

      serialVersionUID:
      -403250971215465050L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream stream)
                 throws IOException,
                        ClassNotFoundException
          Reconstitute this object from a stream (i.e., deserialize it). We handle both JDK 1.1 binary formats and full formats with a packed byte array.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream stream)
                  throws IOException
          Save the state of this object to a stream (i.e., serialize it).
          Serial Data:
          We write out two formats, a JDK 1.1 compatible format, using DOW_IN_MONTH_MODE rules, in the required section, followed by the full rules, in packed format, in the optional section. The optional section will be ignored by JDK 1.1 code upon stream in.

          Contents of the optional section: The length of a byte array is emitted (int); this is 4 as of this release. The byte array of the given length is emitted. The contents of the byte array are the true values of the fields startDay, startDayOfWeek, endDay, and endDayOfWeek. The values of these fields in the required section are approximate values suited to the rule mode DOW_IN_MONTH_MODE, which is the only mode recognized by JDK 1.1.

          Throws:
          IOException

      • Serialized Fields

        • startMonth

          int startMonth
          The month in which daylight saving time starts. This value must be between Calendar.JANUARY and Calendar.DECEMBER inclusive. This value must not equal endMonth.

          If useDaylight is false, this value is ignored.

        • startDay

          int startDay
          This field has two possible interpretations:
          startMode == DOW_IN_MONTH
          startDay indicates the day of the month of startMonth on which daylight saving time starts, from 1 to 28, 30, or 31, depending on the startMonth.
          startMode != DOW_IN_MONTH
          startDay indicates which startDayOfWeek in the month startMonth daylight saving time starts on. For example, a value of +1 and a startDayOfWeek of Calendar.SUNDAY indicates the first Sunday of startMonth. Likewise, +2 would indicate the second Sunday, and -1 the last Sunday. A value of 0 is illegal.

          If useDaylight is false, this value is ignored.

        • startDayOfWeek

          int startDayOfWeek
          The day of the week on which daylight saving time starts. This value must be between Calendar.SUNDAY and Calendar.SATURDAY inclusive.

          If useDaylight is false or startMode == DAY_OF_MONTH, this value is ignored.

        • startTime

          int startTime
          The time in milliseconds after midnight at which daylight saving time starts. This value is expressed as wall time, standard time, or UTC time, depending on the setting of startTimeMode.

          If useDaylight is false, this value is ignored.

        • startTimeMode

          int startTimeMode
          The format of startTime, either WALL_TIME, STANDARD_TIME, or UTC_TIME.
          Since:
          1.3

        • endMonth

          int endMonth
          The month in which daylight saving time ends. This value must be between Calendar.JANUARY and Calendar.UNDECIMBER. This value must not equal startMonth.

          If useDaylight is false, this value is ignored.

        • endDay

          int endDay
          This field has two possible interpretations:
          endMode == DOW_IN_MONTH
          endDay indicates the day of the month of endMonth on which daylight saving time ends, from 1 to 28, 30, or 31, depending on the endMonth.
          endMode != DOW_IN_MONTH
          endDay indicates which endDayOfWeek in th month endMonth daylight saving time ends on. For example, a value of +1 and a endDayOfWeek of Calendar.SUNDAY indicates the first Sunday of endMonth. Likewise, +2 would indicate the second Sunday, and -1 the last Sunday. A value of 0 is illegal.

          If useDaylight is false, this value is ignored.

        • endDayOfWeek

          int endDayOfWeek
          The day of the week on which daylight saving time ends. This value must be between Calendar.SUNDAY and Calendar.SATURDAY inclusive.

          If useDaylight is false or endMode == DAY_OF_MONTH, this value is ignored.

        • endTime

          int endTime
          The time in milliseconds after midnight at which daylight saving time ends. This value is expressed as wall time, standard time, or UTC time, depending on the setting of endTimeMode.

          If useDaylight is false, this value is ignored.

        • endTimeMode

          int endTimeMode
          The format of endTime, either WALL_TIME, STANDARD_TIME, or UTC_TIME.
          Since:
          1.3

        • startYear

          int startYear
          The year in which daylight saving time is first observed. This is an AD value. If this value is less than 1 then daylight saving time is observed for all AD years.

          If useDaylight is false, this value is ignored.

        • rawOffset

          int rawOffset
          The offset in milliseconds between this zone and GMT. Negative offsets are to the west of Greenwich. To obtain local standard time, add the offset to GMT time. To obtain local wall time it may also be necessary to add dstSavings.

        • useDaylight

          boolean useDaylight
          A boolean value which is true if and only if this zone uses daylight saving time. If this value is false, several other fields are ignored.

        • monthLength

          byte[] monthLength
          This field was serialized in JDK 1.1, so we have to keep it that way to maintain serialization compatibility. However, there's no need to recreate the array each time we create a new time zone.
          An array of bytes containing the values {31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31}. This is ignored as of the Java 2 platform v1.2, however, it must be streamed out for compatibility with JDK 1.1.

        • startMode

          int startMode
          Variables specifying the mode of the start rule. Takes the following values:
          DOM_MODE
          Exact day of week; e.g., March 1.
          DOW_IN_MONTH_MODE
          Day of week in month; e.g., last Sunday in March.
          DOW_GE_DOM_MODE
          Day of week after day of month; e.g., Sunday on or after March 15.
          DOW_LE_DOM_MODE
          Day of week before day of month; e.g., Sunday on or before March 15.
          The setting of this field affects the interpretation of the startDay field.

          If useDaylight is false, this value is ignored.

          Since:
          1.1.4

        • endMode

          int endMode
          Variables specifying the mode of the end rule. Takes the following values:
          DOM_MODE
          Exact day of week; e.g., March 1.
          DOW_IN_MONTH_MODE
          Day of week in month; e.g., last Sunday in March.
          DOW_GE_DOM_MODE
          Day of week after day of month; e.g., Sunday on or after March 15.
          DOW_LE_DOM_MODE
          Day of week before day of month; e.g., Sunday on or before March 15.
          The setting of this field affects the interpretation of the endDay field.

          If useDaylight is false, this value is ignored.

          Since:
          1.1.4

        • dstSavings

          int dstSavings
          A positive value indicating the amount of time saved during DST in milliseconds. Typically one hour (3600000); sometimes 30 minutes (1800000).

          If useDaylight is false, this value is ignored.

          Since:
          1.1.4

        • serialVersionOnStream

          int serialVersionOnStream
          The version of the serialized data on the stream. Possible values:
          0 or not present on stream
          JDK 1.1.3 or earlier.
          1
          JDK 1.1.4 or later. Includes three new fields: startMode, endMode, and dstSavings.
          2
          JDK 1.3 or later. Includes two new fields: startTimeMode and endTimeMode.
          When streaming out this class, the most recent format and the highest allowable serialVersionOnStream is written.
          Since:
          1.1.4

    • Class java.util.Stack extends Vector<E> implements Serializable

      serialVersionUID:
      1224463164541339165L

    • Class java.util.TimeZone extends Object implements Serializable

      serialVersionUID:
      3581463369166924961L

      • Serialized Fields

        • ID

          String ID
          The string identifier of this TimeZone. This is a programmatic identifier used internally to look up TimeZone objects from the system table and also to map them to their localized display names. ID values are unique in the system table but may not be for dynamically created zones.

    • Class java.util.TooManyListenersException extends Exception implements Serializable

      serialVersionUID:
      5074640544770687831L

    • Class java.util.TreeMap extends AbstractMap<K,V> implements Serializable

      serialVersionUID:
      919286545866124006L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Reconstitute the TreeMap instance from a stream (i.e., deserialize it).
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Save the state of the TreeMap instance to a stream (i.e., serialize it).
          Serial Data:
          The size of the TreeMap (the number of key-value mappings) is emitted (int), followed by the key (Object) and value (Object) for each key-value mapping represented by the TreeMap. The key-value mappings are emitted in key-order (as determined by the TreeMap's Comparator, or by the keys' natural ordering if the TreeMap has no Comparator).
          Throws:
          IOException

      • Serialized Fields

        • comparator

          Comparator<T> comparator
          The comparator used to maintain order in this tree map, or null if it uses the natural ordering of its keys.

    • Class java.util.TreeMap.AscendingSubMap extends java.util.TreeMap.NavigableSubMap<K,V> implements Serializable

      serialVersionUID:
      912986545866124060L

    • Class java.util.TreeMap.DescendingSubMap extends java.util.TreeMap.NavigableSubMap<K,V> implements Serializable

      serialVersionUID:
      912986545866120460L

      • Serialized Fields

        • reverseComparator

          Comparator<T> reverseComparator

    • Class java.util.TreeMap.NavigableSubMap extends AbstractMap<K,V> implements Serializable

      serialVersionUID:
      -2102997345730753016L

      • Serialized Fields

        • m

          TreeMap<K,V> m
          The backing map.

        • lo

          Object lo
          Endpoints are represented as triples (fromStart, lo, loInclusive) and (toEnd, hi, hiInclusive). If fromStart is true, then the low (absolute) bound is the start of the backing map, and the other values are ignored. Otherwise, if loInclusive is true, lo is the inclusive bound, else lo is the exclusive bound. Similarly for the upper bound.

        • hi

          Object hi
          Endpoints are represented as triples (fromStart, lo, loInclusive) and (toEnd, hi, hiInclusive). If fromStart is true, then the low (absolute) bound is the start of the backing map, and the other values are ignored. Otherwise, if loInclusive is true, lo is the inclusive bound, else lo is the exclusive bound. Similarly for the upper bound.

        • fromStart

          boolean fromStart

        • toEnd

          boolean toEnd

        • loInclusive

          boolean loInclusive

        • hiInclusive

          boolean hiInclusive

    • Class java.util.TreeMap.SubMap extends AbstractMap<K,V> implements Serializable

      serialVersionUID:
      -6520786458950516097L

      • Serialization Methods

        • readResolve

          private Object readResolve()

      • Serialized Fields

        • fromStart

          boolean fromStart

        • toEnd

          boolean toEnd

        • fromKey

          Object fromKey

        • toKey

          Object toKey

    • Class java.util.TreeSet extends AbstractSet<E> implements Serializable

      serialVersionUID:
      -2479143000061671589L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Reconstitute the TreeSet instance from a stream (that is, deserialize it).
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Save the state of the TreeSet instance to a stream (that is, serialize it).
          Serial Data:
          Emits the comparator used to order this set, or null if it obeys its elements' natural ordering (Object), followed by the size of the set (the number of elements it contains) (int), followed by all of its elements (each an Object) in order (as determined by the set's Comparator, or by the elements' natural ordering if the set has no Comparator).
          Throws:
          IOException

    • Class java.util.UnknownFormatConversionException extends IllegalFormatException implements Serializable

      serialVersionUID:
      19060418L

      • Serialized Fields

        • s

          String s

    • Class java.util.UnknownFormatFlagsException extends IllegalFormatException implements Serializable

      serialVersionUID:
      19370506L

      • Serialized Fields

        • flags

          String flags

    • Class java.util.UUID extends Object implements Serializable

      serialVersionUID:
      -4856846361193249489L

      • Serialized Fields

        • mostSigBits

          long mostSigBits

        • leastSigBits

          long leastSigBits

    • Class java.util.Vector extends AbstractList<E> implements Serializable

      serialVersionUID:
      -2767605614048989439L

      • Serialization Methods

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Save the state of the Vector instance to a stream (that is, serialize it). This method performs synchronization to ensure the consistency of the serialized data.
          Throws:
          IOException

      • Serialized Fields

        • elementData

          Object[] elementData
          The array buffer into which the components of the vector are stored. The capacity of the vector is the length of this array buffer, and is at least large enough to contain all the vector's elements.

          Any array elements following the last element in the Vector are null.

        • elementCount

          int elementCount
          The number of valid components in this Vector object. Components elementData[0] through elementData[elementCount-1] are the actual items.

        • capacityIncrement

          int capacityIncrement
          The amount by which the capacity of the vector is automatically incremented when its size becomes greater than its capacity. If the capacity increment is less than or equal to zero, the capacity of the vector is doubled each time it needs to grow.

  • Package java.util.concurrent

    • Class java.util.concurrent.ArrayBlockingQueue extends AbstractQueue<E> implements Serializable

      serialVersionUID:
      -817911632652898426L

      • Serialized Fields

        • items

          Object[] items
          The queued items

        • takeIndex

          int takeIndex
          items index for next take, poll, peek or remove

        • putIndex

          int putIndex
          items index for next put, offer, or add

        • count

          int count
          Number of elements in the queue

        • lock

          ReentrantLock lock
          Main lock guarding all access

        • notEmpty

          Condition notEmpty
          Condition for waiting takes

        • notFull

          Condition notFull
          Condition for waiting puts

    • Class java.util.concurrent.BrokenBarrierException extends Exception implements Serializable

      serialVersionUID:
      7117394618823254244L

    • Class java.util.concurrent.CancellationException extends IllegalStateException implements Serializable

      serialVersionUID:
      -9202173006928992231L

    • Class java.util.concurrent.CompletionException extends RuntimeException implements Serializable

      serialVersionUID:
      7830266012832686185L

    • Class java.util.concurrent.ConcurrentHashMap extends AbstractMap<K,V> implements Serializable

      serialVersionUID:
      7249069246763182397L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Reconstitutes the instance from a stream (that is, deserializes it).
          Throws:
          ClassNotFoundException - if the class of a serialized object could not be found
          IOException - if an I/O error occurs

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Saves the state of the ConcurrentHashMap instance to a stream (i.e., serializes it).
          Serial Data:
          the key (Object) and value (Object) for each key-value mapping, followed by a null pair. The key-value mappings are emitted in no particular order.
          Throws:
          IOException - if an I/O error occurs

      • Serialization Overview

        • For serialization compatibility.

    • Class java.util.concurrent.ConcurrentHashMap.KeySetView extends java.util.concurrent.ConcurrentHashMap.CollectionView<K,V,K> implements Serializable

      serialVersionUID:
      7249069246763182397L

      • Serialized Fields

        • value

          Object value

    • Class java.util.concurrent.ConcurrentLinkedDeque extends AbstractCollection<E> implements Serializable

      serialVersionUID:
      876323262645176354L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Reconstitutes this deque from a stream (that is, deserializes it).
          Throws:
          ClassNotFoundException - if the class of a serialized object could not be found
          IOException - if an I/O error occurs

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Saves this deque to a stream (that is, serializes it).
          Serial Data:
          All of the elements (each an E) in the proper order, followed by a null
          Throws:
          IOException - if an I/O error occurs

    • Class java.util.concurrent.ConcurrentLinkedQueue extends AbstractQueue<E> implements Serializable

      serialVersionUID:
      196745693267521676L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Reconstitutes this queue from a stream (that is, deserializes it).
          Throws:
          ClassNotFoundException - if the class of a serialized object could not be found
          IOException - if an I/O error occurs

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Saves this queue to a stream (that is, serializes it).
          Serial Data:
          All of the elements (each an E) in the proper order, followed by a null
          Throws:
          IOException - if an I/O error occurs

    • Class java.util.concurrent.ConcurrentSkipListMap extends AbstractMap<K,V> implements Serializable

      serialVersionUID:
      -8627078645895051609L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Reconstitutes this map from a stream (that is, deserializes it).
          Throws:
          ClassNotFoundException - if the class of a serialized object could not be found
          IOException - if an I/O error occurs

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Saves this map to a stream (that is, serializes it).
          Serial Data:
          The key (Object) and value (Object) for each key-value mapping represented by the map, followed by null. The key-value mappings are emitted in key-order (as determined by the Comparator, or by the keys' natural ordering if no Comparator).
          Throws:
          IOException - if an I/O error occurs

      • Serialized Fields

        • comparator

          Comparator<T> comparator
          The comparator used to maintain order in this map, or null if using natural ordering. (Non-private to simplify access in nested classes.)

    • Class java.util.concurrent.ConcurrentSkipListMap.SubMap extends AbstractMap<K,V> implements Serializable

      serialVersionUID:
      -7647078645895051609L

      • Serialized Fields

        • m

          ConcurrentSkipListMap<K,V> m
          Underlying map

        • lo

          Object lo
          lower bound key, or null if from start

        • hi

          Object hi
          upper bound key, or null if to end

        • loInclusive

          boolean loInclusive
          inclusion flag for lo

        • hiInclusive

          boolean hiInclusive
          inclusion flag for hi

        • isDescending

          boolean isDescending
          direction

    • Class java.util.concurrent.ConcurrentSkipListSet extends AbstractSet<E> implements Serializable

      serialVersionUID:
      -2479143111061671589L

      • Serialized Fields

        • m

          ConcurrentNavigableMap<K,V> m
          The underlying map. Uses Boolean.TRUE as value for each element. This field is declared final for the sake of thread safety, which entails some ugliness in clone().

    • Class java.util.concurrent.CopyOnWriteArrayList extends Object implements Serializable

      serialVersionUID:
      8673264195747942595L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Reconstitutes this list from a stream (that is, deserializes it).
          Throws:
          ClassNotFoundException - if the class of a serialized object could not be found
          IOException - if an I/O error occurs

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Saves this list to a stream (that is, serializes it).
          Serial Data:
          The length of the array backing the list is emitted (int), followed by all of its elements (each an Object) in the proper order.
          Throws:
          IOException - if an I/O error occurs

    • Class java.util.concurrent.CopyOnWriteArraySet extends AbstractSet<E> implements Serializable

      serialVersionUID:
      5457747651344034263L

      • Serialized Fields

        • al

          CopyOnWriteArrayList<E> al

    • Class java.util.concurrent.CountedCompleter extends ForkJoinTask<T> implements Serializable

      serialVersionUID:
      5232453752276485070L

      • Serialized Fields

        • completer

          CountedCompleter<T> completer
          This task's completer, or null if none

        • pending

          int pending
          The number of pending tasks until completion

    • Class java.util.concurrent.ExecutionException extends Exception implements Serializable

      serialVersionUID:
      7830266012832686185L

    • Class java.util.concurrent.ForkJoinTask extends Object implements Serializable

      serialVersionUID:
      -7721805057305804111L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Reconstitutes this task from a stream (that is, deserializes it).
          Throws:
          ClassNotFoundException - if the class of a serialized object could not be found
          IOException - if an I/O error occurs

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Saves this task to a stream (that is, serializes it).
          Serial Data:
          the current run status and the exception thrown during execution, or null if none
          Throws:
          IOException - if an I/O error occurs

      • Serialized Fields

        • status

          int status
          The run status of this task

    • Class java.util.concurrent.LinkedBlockingDeque extends AbstractQueue<E> implements Serializable

      serialVersionUID:
      -387911632671998426L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Reconstitutes this deque from a stream (that is, deserializes it).
          Throws:
          ClassNotFoundException - if the class of a serialized object could not be found
          IOException - if an I/O error occurs

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Saves this deque to a stream (that is, serializes it).
          Serial Data:
          The capacity (int), followed by elements (each an Object) in the proper order, followed by a null
          Throws:
          IOException - if an I/O error occurs

      • Serialized Fields

        • capacity

          int capacity
          Maximum number of items in the deque

        • lock

          ReentrantLock lock
          Main lock guarding all access

        • notEmpty

          Condition notEmpty
          Condition for waiting takes

        • notFull

          Condition notFull
          Condition for waiting puts

    • Class java.util.concurrent.LinkedBlockingQueue extends AbstractQueue<E> implements Serializable

      serialVersionUID:
      -6903933977591709194L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Reconstitutes this queue from a stream (that is, deserializes it).
          Throws:
          ClassNotFoundException - if the class of a serialized object could not be found
          IOException - if an I/O error occurs

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Saves this queue to a stream (that is, serializes it).
          Serial Data:
          The capacity is emitted (int), followed by all of its elements (each an Object) in the proper order, followed by a null
          Throws:
          IOException - if an I/O error occurs

      • Serialized Fields

        • capacity

          int capacity
          The capacity bound, or Integer.MAX_VALUE if none

        • count

          AtomicInteger count
          Current number of elements

        • takeLock

          ReentrantLock takeLock
          Lock held by take, poll, etc

        • notEmpty

          Condition notEmpty
          Wait queue for waiting takes

        • putLock

          ReentrantLock putLock
          Lock held by put, offer, etc

        • notFull

          Condition notFull
          Wait queue for waiting puts

    • Class java.util.concurrent.LinkedTransferQueue extends AbstractQueue<E> implements Serializable

      serialVersionUID:
      -3223113410248163686L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Reconstitutes this queue from a stream (that is, deserializes it).
          Throws:
          ClassNotFoundException - if the class of a serialized object could not be found
          IOException - if an I/O error occurs

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Saves this queue to a stream (that is, serializes it).
          Serial Data:
          All of the elements (each an E) in the proper order, followed by a null
          Throws:
          IOException - if an I/O error occurs

    • Class java.util.concurrent.PriorityBlockingQueue extends AbstractQueue<E> implements Serializable

      serialVersionUID:
      5595510919245408276L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Reconstitutes this queue from a stream (that is, deserializes it).
          Throws:
          ClassNotFoundException - if the class of a serialized object could not be found
          IOException - if an I/O error occurs

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Saves this queue to a stream (that is, serializes it). For compatibility with previous version of this class, elements are first copied to a java.util.PriorityQueue, which is then serialized.
          Throws:
          IOException - if an I/O error occurs

      • Serialized Fields

        • lock

          ReentrantLock lock
          Lock used for all public operations

        • notEmpty

          Condition notEmpty
          Condition for blocking when empty

        • q

          PriorityQueue<E> q
          A plain PriorityQueue used only for serialization, to maintain compatibility with previous versions of this class. Non-null only during serialization/deserialization.

    • Class java.util.concurrent.RecursiveAction extends ForkJoinTask<Void> implements Serializable

      serialVersionUID:
      5232453952276485070L

    • Class java.util.concurrent.RecursiveTask extends ForkJoinTask<V> implements Serializable

      serialVersionUID:
      5232453952276485270L

      • Serialized Fields

        • result

          Object result
          The result of the computation.

    • Class java.util.concurrent.RejectedExecutionException extends RuntimeException implements Serializable

      serialVersionUID:
      -375805702767069545L

    • Class java.util.concurrent.Semaphore extends Object implements Serializable

      serialVersionUID:
      -3222578661600680210L

      • Serialized Fields

        • sync

          java.util.concurrent.Semaphore.Sync sync
          All mechanics via AbstractQueuedSynchronizer subclass

    • Class java.util.concurrent.SynchronousQueue extends AbstractQueue<E> implements Serializable

      serialVersionUID:
      -3223113410248163686L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Reconstitutes this queue from a stream (that is, deserializes it).
          Throws:
          ClassNotFoundException - if the class of a serialized object could not be found
          IOException - if an I/O error occurs

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Saves this queue to a stream (that is, serializes it).
          Throws:
          IOException - if an I/O error occurs

      • Serialized Fields

        • qlock

          ReentrantLock qlock

        • waitingProducers

          java.util.concurrent.SynchronousQueue.WaitQueue waitingProducers

        • waitingConsumers

          java.util.concurrent.SynchronousQueue.WaitQueue waitingConsumers

    • Class java.util.concurrent.ThreadLocalRandom extends Random implements Serializable

      serialVersionUID:
      -5851777807851030925L

      • Serialization Methods

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Saves the ThreadLocalRandom to a stream (that is, serializes it).
          Throws:
          IOException - if an I/O error occurs

        • readResolve

          private Object readResolve()
          Returns the current thread's ThreadLocalRandom.

      • Serialized Fields

        • initialized

          boolean initialized
          always true

        • rnd

          long rnd
          seed for random computations

    • Class java.util.concurrent.TimeoutException extends Exception implements Serializable

      serialVersionUID:
      1900926677490660714L

  • Package java.util.concurrent.atomic

    • Class java.util.concurrent.atomic.AtomicBoolean extends Object implements Serializable

      serialVersionUID:
      4654671469794556979L

      • Serialized Fields

        • value

          int value

    • Class java.util.concurrent.atomic.AtomicInteger extends Number implements Serializable

      serialVersionUID:
      6214790243416807050L

      • Serialized Fields

        • value

          int value

    • Class java.util.concurrent.atomic.AtomicIntegerArray extends Object implements Serializable

      serialVersionUID:
      2862133569453604235L

      • Serialized Fields

        • array

          int[] array

    • Class java.util.concurrent.atomic.AtomicLong extends Number implements Serializable

      serialVersionUID:
      1927816293512124184L

      • Serialized Fields

        • value

          long value

    • Class java.util.concurrent.atomic.AtomicLongArray extends Object implements Serializable

      serialVersionUID:
      -2308431214976778248L

      • Serialized Fields

        • array

          long[] array

    • Class java.util.concurrent.atomic.AtomicReference extends Object implements Serializable

      serialVersionUID:
      -1848883965231344442L

      • Serialized Fields

        • value

          Object value

    • Class java.util.concurrent.atomic.AtomicReferenceArray extends Object implements Serializable

      serialVersionUID:
      -6209656149925076980L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException,
                        InvalidObjectException
          Reconstitutes the instance from a stream (that is, deserializes it).
          Throws:
          IOException
          ClassNotFoundException
          InvalidObjectException

      • Serialized Fields

        • array

          Object[] array

    • Class java.util.concurrent.atomic.DoubleAccumulator extends java.util.concurrent.atomic.Striped64 implements Serializable

      serialVersionUID:
      7249069246863182397L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws InvalidObjectException
          Throws:
          InvalidObjectException - always

        • writeReplace

          private Object writeReplace()
          Returns a SerializationProxy representing the state of this instance.

      • Serialized Fields

        • function

          DoubleBinaryOperator function

        • identity

          long identity

    • Class java.util.concurrent.atomic.DoubleAccumulator.SerializationProxy extends Object implements Serializable

      serialVersionUID:
      7249069246863182397L

      • Serialization Methods

        • readResolve

          private Object readResolve()
          Returns a DoubleAccumulator object with initial state held by this proxy.

      • Serialized Fields

        • value

          double value
          The current value returned by get().

        • function

          DoubleBinaryOperator function
          The function used for updates.

        • identity

          long identity
          The identity value

    • Class java.util.concurrent.atomic.DoubleAdder extends java.util.concurrent.atomic.Striped64 implements Serializable

      serialVersionUID:
      7249069246863182397L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws InvalidObjectException
          Throws:
          InvalidObjectException - always

        • writeReplace

          private Object writeReplace()
          Returns a SerializationProxy representing the state of this instance.

    • Class java.util.concurrent.atomic.DoubleAdder.SerializationProxy extends Object implements Serializable

      serialVersionUID:
      7249069246863182397L

      • Serialization Methods

        • readResolve

          private Object readResolve()
          Returns a DoubleAdder object with initial state held by this proxy.

      • Serialized Fields

        • value

          double value
          The current value returned by sum().

    • Class java.util.concurrent.atomic.LongAccumulator extends java.util.concurrent.atomic.Striped64 implements Serializable

      serialVersionUID:
      7249069246863182397L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws InvalidObjectException
          Throws:
          InvalidObjectException - always

        • writeReplace

          private Object writeReplace()
          Returns a SerializationProxy representing the state of this instance.

      • Serialized Fields

        • function

          LongBinaryOperator function

        • identity

          long identity

    • Class java.util.concurrent.atomic.LongAccumulator.SerializationProxy extends Object implements Serializable

      serialVersionUID:
      7249069246863182397L

      • Serialization Methods

        • readResolve

          private Object readResolve()
          Returns a LongAccumulator object with initial state held by this proxy.

      • Serialized Fields

        • value

          long value
          The current value returned by get().

        • function

          LongBinaryOperator function
          The function used for updates.

        • identity

          long identity
          The identity value

    • Class java.util.concurrent.atomic.LongAdder extends java.util.concurrent.atomic.Striped64 implements Serializable

      serialVersionUID:
      7249069246863182397L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws InvalidObjectException
          Throws:
          InvalidObjectException - always

        • writeReplace

          private Object writeReplace()
          Returns a SerializationProxy representing the state of this instance.

    • Class java.util.concurrent.atomic.LongAdder.SerializationProxy extends Object implements Serializable

      serialVersionUID:
      7249069246863182397L

      • Serialization Methods

        • readResolve

          private Object readResolve()
          Return a LongAdder object with initial state held by this proxy.

      • Serialized Fields

        • value

          long value
          The current value returned by sum().

  • Package java.util.concurrent.locks

    • Class java.util.concurrent.locks.AbstractOwnableSynchronizer extends Object implements Serializable

      serialVersionUID:
      3737899427754241961L

    • Class java.util.concurrent.locks.AbstractQueuedLongSynchronizer extends AbstractOwnableSynchronizer implements Serializable

      serialVersionUID:
      7373984972572414692L

      • Serialized Fields

        • state

          long state
          The synchronization state.

    • Class java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject extends Object implements Serializable

      serialVersionUID:
      1173984872572414699L

    • Class java.util.concurrent.locks.AbstractQueuedSynchronizer extends AbstractOwnableSynchronizer implements Serializable

      serialVersionUID:
      7373984972572414691L

      • Serialized Fields

        • state

          int state
          The synchronization state.

    • Class java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject extends Object implements Serializable

      serialVersionUID:
      1173984872572414699L

    • Class java.util.concurrent.locks.ReentrantLock extends Object implements Serializable

      serialVersionUID:
      7373984872572414699L

      • Serialized Fields

        • sync

          java.util.concurrent.locks.ReentrantLock.Sync sync
          Synchronizer providing all implementation mechanics

    • Class java.util.concurrent.locks.ReentrantReadWriteLock extends Object implements Serializable

      serialVersionUID:
      -6992448646407690164L

      • Serialized Fields

        • readerLock

          ReentrantReadWriteLock.ReadLock readerLock
          Inner class providing readlock

        • writerLock

          ReentrantReadWriteLock.WriteLock writerLock
          Inner class providing writelock

        • sync

          java.util.concurrent.locks.ReentrantReadWriteLock.Sync sync
          Performs all synchronization mechanics

    • Class java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock extends Object implements Serializable

      serialVersionUID:
      -5992448646407690164L

      • Serialized Fields

        • sync

          java.util.concurrent.locks.ReentrantReadWriteLock.Sync sync

    • Class java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock extends Object implements Serializable

      serialVersionUID:
      -4992448646407690164L

      • Serialized Fields

        • sync

          java.util.concurrent.locks.ReentrantReadWriteLock.Sync sync

    • Class java.util.concurrent.locks.StampedLock extends Object implements Serializable

      serialVersionUID:
      -6001602636862214147L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Throws:
          IOException
          ClassNotFoundException

  • Package java.util.jar

    • Class java.util.jar.JarException extends ZipException implements Serializable

      serialVersionUID:
      7159778400963954473L

  • Package java.util.logging

    • Class java.util.logging.Level extends Object implements Serializable

      serialVersionUID:
      -8176160795706313070L

      • Serialization Methods

        • readResolve

          private Object readResolve()

      • Serialized Fields

        • name

          String name
          The non-localized name of the level.

        • value

          int value
          The integer value of the level.

        • resourceBundleName

          String resourceBundleName
          The resource bundle name to be used in localizing the level name.

    • Class java.util.logging.LoggingPermission extends BasicPermission implements Serializable

      serialVersionUID:
      63564341580231582L

    • Class java.util.logging.LogRecord extends Object implements Serializable

      serialVersionUID:
      5372048053134512534L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream out)
                  throws IOException
          Serial Data:
          Default fields, followed by a two byte version number (major byte, followed by minor byte), followed by information on the log record parameter array. If there is no parameter array, then -1 is written. If there is a parameter array (possible of zero length) then the array length is written as an integer, followed by String values for each parameter. If a parameter is null, then a null String is written. Otherwise the output of Object.toString() is written.
          Throws:
          IOException

      • Serialized Fields

        • level

          Level level
          Logging message level

        • sequenceNumber

          long sequenceNumber
          Sequence number

        • sourceClassName

          String sourceClassName
          Class that issued logging call

        • sourceMethodName

          String sourceMethodName
          Method that issued logging call

        • message

          String message
          Non-localized raw message text

        • threadID

          int threadID
          Thread ID for thread that issued logging call.

        • millis

          long millis
          Event time in milliseconds since 1970

        • thrown

          Throwable thrown
          The Throwable (if any) associated with log message

        • loggerName

          String loggerName
          Name of the source Logger.

        • resourceBundleName

          String resourceBundleName
          Resource bundle name to localized log message.

  • Package java.util.prefs

    • Class java.util.prefs.BackingStoreException extends Exception implements Serializable

      serialVersionUID:
      859796500401108469L

    • Class java.util.prefs.InvalidPreferencesFormatException extends Exception implements Serializable

      serialVersionUID:
      -791715184232119669L

  • Package java.util.regex

    • Class java.util.regex.Pattern extends Object implements Serializable

      serialVersionUID:
      5073258162644648461L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Recompile the Pattern instance from a stream. The original pattern string is read in and the object tree is recompiled from it.
          Throws:
          IOException
          ClassNotFoundException

      • Serialized Fields

        • pattern

          String pattern
          The original regular-expression pattern string.

        • flags

          int flags
          The original pattern flags.

    • Class java.util.regex.PatternSyntaxException extends IllegalArgumentException implements Serializable

      serialVersionUID:
      -3864639126226059218L

      • Serialized Fields

        • desc

          String desc

        • pattern

          String pattern

        • index

          int index

  • Package java.util.zip

    • Class java.util.zip.DataFormatException extends Exception implements Serializable

      serialVersionUID:
      2219632870893641452L

    • Class java.util.zip.ZipError extends InternalError implements Serializable

      serialVersionUID:
      853973422266861979L

    • Class java.util.zip.ZipException extends IOException implements Serializable

      serialVersionUID:
      8000196834066748623L

  • Package javax.activation

    • Class javax.activation.ActivationDataFlavor extends DataFlavor implements Serializable

      • Serialization Methods

        • readExternal

          public void readExternal(ObjectInput is)
                  throws IOException,
                         ClassNotFoundException
          Restores this DataFlavor from a Serialized state.
          Throws:
          IOException - if I/O errors occur
          ClassNotFoundException - If the class for an object being restored cannot be found.

        • writeExternal

          public void writeExternal(ObjectOutput os)
                   throws IOException
          Serializes this DataFlavor.
          Throws:
          IOException - Includes any I/O exceptions that may occur

    • Class javax.activation.MimeType extends Object implements Serializable

      • Serialization Methods

        • readExternal

          public void readExternal(ObjectInput in)
                  throws IOException,
                         ClassNotFoundException
          The object implements the readExternal method to restore its contents by calling the methods of DataInput for primitive types and readObject for objects, strings and arrays. The readExternal method must read the values in the same sequence and with the same types as were written by writeExternal.
          Throws:
          ClassNotFoundException - If the class for an object being restored cannot be found.
          IOException - if I/O errors occur

        • writeExternal

          public void writeExternal(ObjectOutput out)
                   throws IOException
          The object implements the writeExternal method to save its contents by calling the methods of DataOutput for its primitive values or calling the writeObject method of ObjectOutput for objects, strings and arrays.
          Throws:
          IOException - Includes any I/O exceptions that may occur

    • Class javax.activation.MimeTypeParseException extends Exception implements Serializable

    • Class javax.activation.UnsupportedDataTypeException extends IOException implements Serializable

  • Package javax.activity

    • Class javax.activity.ActivityCompletedException extends RemoteException implements Serializable

    • Class javax.activity.ActivityRequiredException extends RemoteException implements Serializable

    • Class javax.activity.InvalidActivityException extends RemoteException implements Serializable

  • Package javax.annotation.processing

    • Class javax.annotation.processing.FilerException extends IOException implements Serializable

      serialVersionUID:
      8426423106453163293L

  • Package javax.crypto

    • Class javax.crypto.AEADBadTagException extends BadPaddingException implements Serializable

      serialVersionUID:
      -488059093241685509L

    • Class javax.crypto.BadPaddingException extends GeneralSecurityException implements Serializable

      serialVersionUID:
      -5315033893984728443L

    • Class javax.crypto.ExemptionMechanismException extends GeneralSecurityException implements Serializable

      serialVersionUID:
      1572699429277957109L

    • Class javax.crypto.IllegalBlockSizeException extends GeneralSecurityException implements Serializable

      serialVersionUID:
      -1965144811953540392L

    • Class javax.crypto.NoSuchPaddingException extends GeneralSecurityException implements Serializable

      serialVersionUID:
      -4572885201200175466L

    • Class javax.crypto.SealedObject extends Object implements Serializable

      serialVersionUID:
      4482838265551344752L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Restores the state of the SealedObject from a stream.
          Throws:
          NullPointerException - if s is null.
          IOException
          ClassNotFoundException

      • Serialized Fields

        • encryptedContent

          byte[] encryptedContent
          The serialized object contents in encrypted format.

        • sealAlg

          String sealAlg
          The algorithm that was used to seal this object.

        • paramsAlg

          String paramsAlg
          The algorithm of the parameters used.

        • encodedParams

          byte[] encodedParams
          The cryptographic parameters used by the sealing Cipher, encoded in the default format.

          That is, cipher.getParameters().getEncoded().

    • Class javax.crypto.ShortBufferException extends GeneralSecurityException implements Serializable

      serialVersionUID:
      8427718640832943747L

  • Package javax.crypto.interfaces

  • Package javax.crypto.spec

    • Class javax.crypto.spec.SecretKeySpec extends Object implements Serializable

      serialVersionUID:
      6577238317307289933L

      • Serialized Fields

        • key

          byte[] key
          The secret key.

        • algorithm

          String algorithm
          The name of the algorithm associated with this key.

  • Package javax.imageio

    • Class javax.imageio.IIOException extends IOException implements Serializable

  • Package javax.imageio.metadata

    • Class javax.imageio.metadata.IIOInvalidTreeException extends IIOException implements Serializable

      • Serialized Fields

        • offendingNode

          Node offendingNode
          The Node that led to the parsing error, or null.

  • Package javax.lang.model

    • Class javax.lang.model.UnknownEntityException extends RuntimeException implements Serializable

      serialVersionUID:
      269L

  • Package javax.lang.model.element

    • Class javax.lang.model.element.UnknownAnnotationValueException extends UnknownEntityException implements Serializable

      serialVersionUID:
      269L

    • Class javax.lang.model.element.UnknownElementException extends UnknownEntityException implements Serializable

      serialVersionUID:
      269L

  • Package javax.lang.model.type

    • Class javax.lang.model.type.MirroredTypeException extends MirroredTypesException implements Serializable

      serialVersionUID:
      269L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Explicitly set all transient fields.
          Throws:
          IOException
          ClassNotFoundException

    • Class javax.lang.model.type.MirroredTypesException extends RuntimeException implements Serializable

      serialVersionUID:
      269L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Explicitly set all transient fields.
          Throws:
          IOException
          ClassNotFoundException

    • Class javax.lang.model.type.UnknownTypeException extends UnknownEntityException implements Serializable

      serialVersionUID:
      269L

  • Package javax.management

    • Class javax.management.AndQueryExp extends QueryEval implements Serializable

      serialVersionUID:
      -1081892073854801359L

      • Serialized Fields

        • exp1

          QueryExp exp1
          The first QueryExp of the conjunction

        • exp2

          QueryExp exp2
          The second QueryExp of the conjunction

    • Class javax.management.Attribute extends Object implements Serializable

      serialVersionUID:
      2484220110589082382L

      • Serialized Fields

        • name

          String name
          Attribute name.

        • value

          Object value
          Attribute value

    • Class javax.management.AttributeChangeNotification extends Notification implements Serializable

      serialVersionUID:
      535176054565814134L

      • Serialized Fields

        • attributeName

          String attributeName
          The MBean attribute name.

        • attributeType

          String attributeType
          The MBean attribute type.

        • oldValue

          Object oldValue
          The MBean attribute old value.

        • newValue

          Object newValue
          The MBean attribute new value.

    • Class javax.management.AttributeChangeNotificationFilter extends Object implements Serializable

      serialVersionUID:
      -6347317584796410029L

      • Serialized Fields

        • enabledAttributes

          Vector<E> enabledAttributes
          Vector that contains the enabled attribute names. The default value is an empty vector.

    • Class javax.management.AttributeList extends ArrayList<Object> implements Serializable

      serialVersionUID:
      -4077085769279709076L

    • Class javax.management.AttributeNotFoundException extends OperationsException implements Serializable

      serialVersionUID:
      6511584241791106926L

    • Class javax.management.AttributeValueExp extends Object implements Serializable

      serialVersionUID:
      -7768025046539163385L

      • Serialized Fields

        • attr

          String attr
          The name of the attribute

    • Class javax.management.BadAttributeValueExpException extends Exception implements Serializable

      serialVersionUID:
      -3105272988410493376L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
          Throws:
          IOException
          ClassNotFoundException

      • Serialized Fields

        • val

          Object val
          A string representation of the attribute that originated this exception. for example, the string value can be the return of attribute.toString()

    • Class javax.management.BadBinaryOpValueExpException extends Exception implements Serializable

      serialVersionUID:
      5068475589449021227L

      • Serialized Fields

        • exp

          ValueExp exp
          the ValueExp that originated this exception

    • Class javax.management.BadStringOperationException extends Exception implements Serializable

      serialVersionUID:
      7802201238441662100L

      • Serialized Fields

        • op

          String op
          The description of the operation that originated this exception

    • Class javax.management.BetweenQueryExp extends QueryEval implements Serializable

      serialVersionUID:
      -2933597532866307444L

      • Serialized Fields

        • exp1

          ValueExp exp1
          The checked value

        • exp2

          ValueExp exp2
          The lower bound value

        • exp3

          ValueExp exp3
          The upper bound value

    • Class javax.management.BinaryOpValueExp extends QueryEval implements Serializable

      serialVersionUID:
      1216286847881456786L

      • Serialized Fields

        • op

          int op
          The operator

        • exp1

          ValueExp exp1
          The first value

        • exp2

          ValueExp exp2
          The second value

    • Class javax.management.BinaryRelQueryExp extends QueryEval implements Serializable

      serialVersionUID:
      -5690656271650491000L

      • Serialized Fields

        • relOp

          int relOp
          The operator

        • exp1

          ValueExp exp1
          The first value

        • exp2

          ValueExp exp2
          The second value

    • Class javax.management.BooleanValueExp extends QueryEval implements Serializable

      serialVersionUID:
      7754922052666594581L

      • Serialized Fields

        • val

          boolean val
          The boolean value

    • Class javax.management.ClassAttributeValueExp extends AttributeValueExp implements Serializable

      • Serialized Fields

        • attr

          String attr
          The name of the attribute

          The serialVersionUID of this class is -1081892073854801359L.

    • Class javax.management.ImmutableDescriptor extends Object implements Serializable

      serialVersionUID:
      8853308591080540165L

      • Serialization Methods

        • readResolve

          private Object readResolve()
                    throws InvalidObjectException
          This method can replace a deserialized instance of this class with another instance. For example, it might replace a deserialized empty ImmutableDescriptor with ImmutableDescriptor.EMPTY_DESCRIPTOR.
          Throws:
          InvalidObjectException - if the read object has invalid fields.

      • Serialized Fields

        • names

          String[] names
          The names of the fields in this ImmutableDescriptor with their original case. The names must be in alphabetical order as determined by String.CASE_INSENSITIVE_ORDER.

        • values

          Object[] values
          The values of the fields in this ImmutableDescriptor. The elements in this array match the corresponding elements in the names array.

    • Class javax.management.InQueryExp extends QueryEval implements Serializable

      serialVersionUID:
      -5801329450358952434L

      • Serialized Fields

        • val

          ValueExp val
          The ValueExp to be found

        • valueList

          ValueExp[] valueList
          The array of ValueExp to be searched

    • Class javax.management.InstanceAlreadyExistsException extends OperationsException implements Serializable

      serialVersionUID:
      8893743928912733931L

    • Class javax.management.InstanceNotFoundException extends OperationsException implements Serializable

      serialVersionUID:
      -882579438394773049L

    • Class javax.management.InstanceOfQueryExp extends QueryEval implements Serializable

      serialVersionUID:
      -1081892073854801359L

      • Serialized Fields

        • classNameValue

          StringValueExp classNameValue
          The StringValueExp returning the name of the class of which selected MBeans should be instances.

    • Class javax.management.IntrospectionException extends OperationsException implements Serializable

      serialVersionUID:
      1054516935875481725L

    • Class javax.management.InvalidApplicationException extends Exception implements Serializable

      serialVersionUID:
      -3048022274675537269L

      • Serialized Fields

        • val

          Object val
          The object representing the class of the MBean

    • Class javax.management.InvalidAttributeValueException extends OperationsException implements Serializable

      serialVersionUID:
      2164571879317142449L

    • Class javax.management.JMException extends Exception implements Serializable

      serialVersionUID:
      350520924977331825L

    • Class javax.management.JMRuntimeException extends RuntimeException implements Serializable

      serialVersionUID:
      6573344628407841861L

    • Class javax.management.ListenerNotFoundException extends OperationsException implements Serializable

      serialVersionUID:
      -7242605822448519061L

    • Class javax.management.MalformedObjectNameException extends OperationsException implements Serializable

      serialVersionUID:
      -572689714442915824L

    • Class javax.management.MatchQueryExp extends QueryEval implements Serializable

      serialVersionUID:
      -7156603696948215014L

      • Serialized Fields

        • exp

          AttributeValueExp exp
          The attribute value to be matched

        • pattern

          String pattern
          The pattern to be matched

    • Class javax.management.MBeanAttributeInfo extends MBeanFeatureInfo implements Serializable

      • Serialized Fields

        • attributeType

          String attributeType
          The actual attribute type.

        • isWrite

          boolean isWrite
          The attribute write right.

        • isRead

          boolean isRead
          The attribute read right.

        • is

          boolean is
          Indicates if this method is a "is"

    • Class javax.management.MBeanConstructorInfo extends MBeanFeatureInfo implements Serializable

      serialVersionUID:
      4433990064191844427L

      • Serialized Fields

        • signature

          MBeanParameterInfo[] signature
          The signature of the method, that is, the class names of the arguments.

    • Class javax.management.MBeanException extends JMException implements Serializable

      serialVersionUID:
      4066342430588744142L

      • Serialized Fields

        • exception

          Exception exception
          Encapsulated Exception

    • Class javax.management.MBeanFeatureInfo extends Object implements Serializable

      serialVersionUID:
      3952882688968447265L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          Deserializes an MBeanFeatureInfo from an ObjectInputStream.
          Serial Data:
          For compatibility reasons, an object of this class is deserialized as follows.

          The method defaultReadObject() is called first to deserialize the object except the field descriptor, which is not serialized in the default way. Then the method read() is called to read a byte, the field descriptor is deserialized according to the value of the byte value:

          • 1. The method readObject() is called twice to obtain the field names (a String[]) and the field values (a Object[]) of the descriptor. The two obtained values then are used to construct an ImmutableDescriptor instance for the field descriptor;
          • 0. The value for the field descriptor is obtained directly by calling the method readObject(). If the obtained value is null, the field descriptor is set to EMPTY_DESCRIPTOR;
          • -1. This means that there is no byte to read and that the object is from an earlier version of the JMX API. The field descriptor is set to EMPTY_DESCRIPTOR
          • Any other value. A StreamCorruptedException is thrown.
          Throws:
          IOException
          ClassNotFoundException
          Since:
          1.6

        • writeObject

          private void writeObject(ObjectOutputStream out)
                  throws IOException
          Serializes an MBeanFeatureInfo to an ObjectOutputStream.
          Serial Data:
          For compatibility reasons, an object of this class is serialized as follows.

          The method defaultWriteObject() is called first to serialize the object except the field descriptor which is declared as transient. The field descriptor is serialized as follows:

          • If descriptor is an instance of the class ImmutableDescriptor, the method write(int val) is called to write a byte with the value 1, then the method writeObject(Object obj) is called twice to serialize the field names and the field values of the descriptor, respectively as a String[] and an Object[];
          • Otherwise, the method write(int val) is called to write a byte with the value 0, then the method writeObject(Object obj) is called to serialize directly the field descriptor.
          Throws:
          IOException
          Since:
          1.6

      • Serialized Fields

        • name

          String name
          The name of the feature. It is recommended that subclasses call MBeanFeatureInfo.getName() rather than reading this field, and that they not change it.
          The name of the feature.

        • description

          String description
          The human-readable description of the feature. It is recommended that subclasses call MBeanFeatureInfo.getDescription() rather than reading this field, and that they not change it.
          The human-readable description of the feature.

    • Class javax.management.MBeanInfo extends Object implements Serializable

      serialVersionUID:
      -6451021435135161911L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          Deserializes an MBeanInfo from an ObjectInputStream.
          Serial Data:
          For compatibility reasons, an object of this class is deserialized as follows.

          The method defaultReadObject() is called first to deserialize the object except the field descriptor, which is not serialized in the default way. Then the method read() is called to read a byte, the field descriptor is deserialized according to the value of the byte value:

          • 1. The method readObject() is called twice to obtain the field names (a String[]) and the field values (a Object[]) of the descriptor. The two obtained values then are used to construct an ImmutableDescriptor instance for the field descriptor;
          • 0. The value for the field descriptor is obtained directly by calling the method readObject(). If the obtained value is null, the field descriptor is set to EMPTY_DESCRIPTOR;
          • -1. This means that there is no byte to read and that the object is from an earlier version of the JMX API. The field descriptor is set to EMPTY_DESCRIPTOR.
          • Any other value. A StreamCorruptedException is thrown.
          Throws:
          IOException
          ClassNotFoundException
          Since:
          1.6

        • writeObject

          private void writeObject(ObjectOutputStream out)
                  throws IOException
          Serializes an MBeanInfo to an ObjectOutputStream.
          Serial Data:
          For compatibility reasons, an object of this class is serialized as follows.

          The method defaultWriteObject() is called first to serialize the object except the field descriptor which is declared as transient. The field descriptor is serialized as follows:

          • If descriptor is an instance of the class ImmutableDescriptor, the method write(int val) is called to write a byte with the value 1, then the method writeObject(Object obj) is called twice to serialize the field names and the field values of the descriptor, respectively as a String[] and an Object[];
          • Otherwise, the method write(int val) is called to write a byte with the value 0, then the method writeObject(Object obj) is called to serialize the field descriptor directly.
          Throws:
          IOException
          Since:
          1.6

      • Serialized Fields

        • description

          String description
          The human readable description of the class.

        • className

          String className
          The MBean qualified name.

        • attributes

          MBeanAttributeInfo[] attributes
          The MBean attribute descriptors.

        • operations

          MBeanOperationInfo[] operations
          The MBean operation descriptors.

        • constructors

          MBeanConstructorInfo[] constructors
          The MBean constructor descriptors.

        • notifications

          MBeanNotificationInfo[] notifications
          The MBean notification descriptors.

    • Class javax.management.MBeanNotificationInfo extends MBeanFeatureInfo implements Serializable

      serialVersionUID:
      -3888371564530107064L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
          Throws:
          IOException
          ClassNotFoundException

      • Serialized Fields

        • types

          String[] types
          The different types of the notification.

    • Class javax.management.MBeanOperationInfo extends MBeanFeatureInfo implements Serializable

      serialVersionUID:
      -6178860474881375330L

      • Serialized Fields

        • type

          String type
          The method's return value.

        • signature

          MBeanParameterInfo[] signature
          The signature of the method, that is, the class names of the arguments.

        • impact

          int impact
          The impact of the method, one of INFO, ACTION, ACTION_INFO, UNKNOWN

    • Class javax.management.MBeanParameterInfo extends MBeanFeatureInfo implements Serializable

      serialVersionUID:
      7432616882776782338L

      • Serialized Fields

        • type

          String type
          The type or class name of the data.

    • Class javax.management.MBeanPermission extends Permission implements Serializable

      serialVersionUID:
      -2416928705275160661L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          Deserialize this object based on its name and actions.
          Throws:
          IOException
          ClassNotFoundException

      • Serialized Fields

        • actions

          String actions
          The actions string.

    • Class javax.management.MBeanRegistrationException extends MBeanException implements Serializable

      serialVersionUID:
      4482382455277067805L

    • Class javax.management.MBeanServerNotification extends Notification implements Serializable

      serialVersionUID:
      2876477500475969677L

      • Serialized Fields

        • objectName

          ObjectName objectName
          The object names of the MBeans concerned by this notification

    • Class javax.management.MBeanServerPermission extends BasicPermission implements Serializable

      serialVersionUID:
      -5661980843569388590L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          Throws:
          IOException
          ClassNotFoundException

    • Class javax.management.MBeanServerPermissionCollection extends PermissionCollection implements Serializable

      serialVersionUID:
      -5661980843569388590L

      • Serialized Fields

        • collectionPermission

          MBeanServerPermission collectionPermission
          Null if no permissions in collection, otherwise a single permission that is the union of all permissions that have been added.

    • Class javax.management.MBeanTrustPermission extends BasicPermission implements Serializable

      serialVersionUID:
      -2952178077029018140L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          Throws:
          IOException
          ClassNotFoundException

    • Class javax.management.NotCompliantMBeanException extends OperationsException implements Serializable

      serialVersionUID:
      5175579583207963577L

    • Class javax.management.Notification extends EventObject implements Serializable

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          Deserializes a Notification from an ObjectInputStream.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream out)
                  throws IOException
          Serializes a Notification to an ObjectOutputStream.
          Throws:
          IOException

      • Serialized Fields

        • message

          String message
          The notification message.

        • sequenceNumber

          long sequenceNumber
          The notification sequence number. A serial number which identify particular instance of notification in the context of the notification source.

        • source

          Object source
          The object on which the notification initially occurred.

        • timeStamp

          long timeStamp
          The notification timestamp. Indicating when the notification was generated

        • type

          String type
          The notification type. A string expressed in a dot notation similar to Java properties. An example of a notification type is network.alarm.router

        • userData

          Object userData
          The notification user data. Used for whatever other data the notification source wishes to communicate to its consumers

    • Class javax.management.NotificationFilterSupport extends Object implements Serializable

      serialVersionUID:
      6579080007561786969L

      • Serialized Fields

        • enabledTypes

          List<E> enabledTypes
          Vector that contains the enabled notification types. The default value is an empty vector.

    • Class javax.management.NotQueryExp extends QueryEval implements Serializable

      serialVersionUID:
      5269643775896723397L

      • Serialized Fields

        • exp

          QueryExp exp
          The negated QueryExp

    • Class javax.management.NumericValueExp extends QueryEval implements Serializable

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          Deserializes a NumericValueExp from an ObjectInputStream.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream out)
                  throws IOException
          Serializes a NumericValueExp to an ObjectOutputStream.
          Throws:
          IOException

      • Serialized Fields

        • val

          Number val
          The numeric value

          The serialVersionUID of this class is -4679739485102359104L.

    • Class javax.management.ObjectInstance extends Object implements Serializable

      serialVersionUID:
      -4099952623687795850L

      • Serialized Fields

        • name

          ObjectName name
          Object name.

        • className

          String className
          Class name.

    • Class javax.management.ObjectName extends Object implements Serializable

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          Deserializes an ObjectName from an ObjectInputStream.
          Serial Data:
          • In the current serial form (value of property jmx.serial.form differs from 1.0): the string "<domain>:<properties><wild>", where:
            • <domain> represents the domain part of the ObjectName
            • <properties> represents the list of properties, as returned by ObjectName.getKeyPropertyListString()
            • <wild> is empty if not isPropertyPattern, or is the character "*" if isPropertyPattern and <properties> is empty, or is ",*" if isPropertyPattern and <properties> is not empty.
            The intent is that this string could be supplied to the ObjectName.ObjectName(String) constructor to produce an equivalent ObjectName.
          • In the old serial form (value of property jmx.serial.form is 1.0): <domain> <propertyList> <propertyListString> <canonicalName> <pattern> <propertyPattern>, where:
            • <domain> represents the domain part of the ObjectName
            • <propertyList> is the Hashtable that contains all the pairs (key,value) for this ObjectName
            • <propertyListString> is the String representation of the list of properties in any order (not mandatorily a canonical representation)
            • <canonicalName> is the String containing this ObjectName's canonical name
            • <pattern> is a boolean which is true if this ObjectName contains a pattern
            • <propertyPattern> is a boolean which is true if this ObjectName contains a pattern in the list of properties
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream out)
                  throws IOException
          Serializes an ObjectName to an ObjectOutputStream.
          Serial Data:
          • In the current serial form (value of property jmx.serial.form differs from 1.0): the string "<domain>:<properties><wild>", where:
            • <domain> represents the domain part of the ObjectName
            • <properties> represents the list of properties, as returned by ObjectName.getKeyPropertyListString()
            • <wild> is empty if not isPropertyPattern, or is the character "*" if this isPropertyPattern and <properties> is empty, or is ",*" if isPropertyPattern and <properties> is not empty.
            The intent is that this string could be supplied to the ObjectName.ObjectName(String) constructor to produce an equivalent ObjectName.
          • In the old serial form (value of property jmx.serial.form is 1.0): <domain> <propertyList> <propertyListString> <canonicalName> <pattern> <propertyPattern>, where:
            • <domain> represents the domain part of the ObjectName
            • <propertyList> is the Hashtable that contains all the pairs (key,value) for this ObjectName
            • <propertyListString> is the String representation of the list of properties in any order (not mandatorily a canonical representation)
            • <canonicalName> is the String containing this ObjectName's canonical name
            • <pattern> is a boolean which is true if this ObjectName contains a pattern
            • <propertyPattern> is a boolean which is true if this ObjectName contains a pattern in the list of properties
          Throws:
          IOException

    • Class javax.management.OperationsException extends JMException implements Serializable

      serialVersionUID:
      -4967597595580536216L

    • Class javax.management.OrQueryExp extends QueryEval implements Serializable

      serialVersionUID:
      2962973084421716523L

      • Serialized Fields

        • exp1

          QueryExp exp1
          The left query expression

        • exp2

          QueryExp exp2
          The right query expression

    • Class javax.management.QualifiedAttributeValueExp extends AttributeValueExp implements Serializable

      serialVersionUID:
      8832517277410933254L

      • Serialized Fields

        • className

          String className
          The attribute class name

    • Class javax.management.QueryEval extends Object implements Serializable

      serialVersionUID:
      2675899265640874796L

    • Class javax.management.ReflectionException extends JMException implements Serializable

      serialVersionUID:
      9170809325636915553L

      • Serialized Fields

        • exception

          Exception exception
          The wrapped Exception

    • Class javax.management.RuntimeErrorException extends JMRuntimeException implements Serializable

      serialVersionUID:
      704338937753949796L

      • Serialized Fields

        • error

          Error error
          The encapsulated Error

    • Class javax.management.RuntimeMBeanException extends JMRuntimeException implements Serializable

      serialVersionUID:
      5274912751982730171L

      • Serialized Fields

        • runtimeException

          RuntimeException runtimeException
          The encapsulated RuntimeException

    • Class javax.management.RuntimeOperationsException extends JMRuntimeException implements Serializable

      serialVersionUID:
      -8408923047489133588L

      • Serialized Fields

        • runtimeException

          RuntimeException runtimeException
          The encapsulated RuntimeException

    • Class javax.management.ServiceNotFoundException extends OperationsException implements Serializable

      serialVersionUID:
      -3990675661956646827L

    • Class javax.management.StringValueExp extends Object implements Serializable

      serialVersionUID:
      -3256390509806284044L

      • Serialized Fields

        • val

          String val
          The string literal

  • Package javax.management.loading

    • Class javax.management.loading.MLet extends URLClassLoader implements Serializable

      serialVersionUID:
      3636148327800330130L

      • Serialization Methods

        • readExternal

          public void readExternal(ObjectInput in)
                  throws IOException,
                         ClassNotFoundException,
                         UnsupportedOperationException

          Restore this MLet's contents from the given ObjectInput. Not all implementations support this method. Those that do not throw UnsupportedOperationException. A subclass may override this method to support it or to change the format of the read data.

          The format of the read data is not specified, but if an implementation supports MLet.readExternal(java.io.ObjectInput) it must also support MLet.writeExternal(java.io.ObjectOutput) in such a way that what is written by the latter can be read by the former.

          Throws:
          IOException - if a problem occurred while reading.
          ClassNotFoundException - if the class for the object being restored cannot be found.
          UnsupportedOperationException - if this implementation does not support this operation.

        • writeExternal

          public void writeExternal(ObjectOutput out)
                   throws IOException,
                          UnsupportedOperationException

          Save this MLet's contents to the given ObjectOutput. Not all implementations support this method. Those that do not throw UnsupportedOperationException. A subclass may override this method to support it or to change the format of the written data.

          The format of the written data is not specified, but if an implementation supports MLet.writeExternal(java.io.ObjectOutput) it must also support MLet.readExternal(java.io.ObjectInput) in such a way that what is written by the former can be read by the latter.

          Throws:
          IOException - If a problem occurred while writing.
          UnsupportedOperationException - If this implementation does not support this operation.

    • Class javax.management.loading.PrivateMLet extends MLet implements Serializable

      serialVersionUID:
      2503458973393711979L

      • Serialization Methods

        • readExternal

          public void readExternal(ObjectInput in)
                  throws IOException,
                         ClassNotFoundException,
                         UnsupportedOperationException

          Restore this MLet's contents from the given ObjectInput. Not all implementations support this method. Those that do not throw UnsupportedOperationException. A subclass may override this method to support it or to change the format of the read data.

          The format of the read data is not specified, but if an implementation supports MLet.readExternal(java.io.ObjectInput) it must also support MLet.writeExternal(java.io.ObjectOutput) in such a way that what is written by the latter can be read by the former.

          Throws:
          IOException - if a problem occurred while reading.
          ClassNotFoundException - if the class for the object being restored cannot be found.
          UnsupportedOperationException - if this implementation does not support this operation.

        • writeExternal

          public void writeExternal(ObjectOutput out)
                   throws IOException,
                          UnsupportedOperationException

          Save this MLet's contents to the given ObjectOutput. Not all implementations support this method. Those that do not throw UnsupportedOperationException. A subclass may override this method to support it or to change the format of the written data.

          The format of the written data is not specified, but if an implementation supports MLet.writeExternal(java.io.ObjectOutput) it must also support MLet.readExternal(java.io.ObjectInput) in such a way that what is written by the former can be read by the latter.

          Throws:
          IOException - If a problem occurred while writing.
          UnsupportedOperationException - If this implementation does not support this operation.

  • Package javax.management.modelmbean

    • Class javax.management.modelmbean.DescriptorSupport extends Object implements Serializable

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          Deserializes a DescriptorSupport from an ObjectInputStream.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream out)
                  throws IOException
          Serializes a DescriptorSupport to an ObjectOutputStream.
          Throws:
          IOException

      • Serialized Fields

        • descriptor

          HashMap<K,V> descriptor
          The collection of fields representing this descriptor

    • Class javax.management.modelmbean.InvalidTargetObjectTypeException extends Exception implements Serializable

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          Deserializes an InvalidTargetObjectTypeException from an ObjectInputStream.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream out)
                  throws IOException
          Serializes an InvalidTargetObjectTypeException to an ObjectOutputStream.
          Throws:
          IOException

      • Serialized Fields

        • exception

          Exception exception
          Encapsulated {@link Exception}

    • Class javax.management.modelmbean.ModelMBeanAttributeInfo extends MBeanAttributeInfo implements Serializable

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          Deserializes a ModelMBeanAttributeInfo from an ObjectInputStream.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream out)
                  throws IOException
          Serializes a ModelMBeanAttributeInfo to an ObjectOutputStream.
          Throws:
          IOException

      • Serialized Fields

        • attrDescriptor

          Descriptor attrDescriptor
          The {@link Descriptor} containing the metadata corresponding to this attribute

    • Class javax.management.modelmbean.ModelMBeanConstructorInfo extends MBeanConstructorInfo implements Serializable

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          Deserializes a ModelMBeanConstructorInfo from an ObjectInputStream.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream out)
                  throws IOException
          Serializes a ModelMBeanConstructorInfo to an ObjectOutputStream.
          Throws:
          IOException

      • Serialized Fields

        • consDescriptor

          Descriptor consDescriptor
          The {@link Descriptor} containing the metadata for this instance

    • Class javax.management.modelmbean.ModelMBeanInfoSupport extends MBeanInfo implements Serializable

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          Deserializes a ModelMBeanInfoSupport from an ObjectInputStream.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream out)
                  throws IOException
          Serializes a ModelMBeanInfoSupport to an ObjectOutputStream.
          Throws:
          IOException

      • Serialized Fields

        • modelMBeanAttributes

          ModelMBeanAttributeInfo[] modelMBeanAttributes
          The array of {@link ModelMBeanAttributeInfo} objects which have descriptors

        • modelMBeanConstructors

          MBeanConstructorInfo[] modelMBeanConstructors
          The array of {@link ModelMBeanConstructorInfo} objects which have descriptors

        • modelMBeanDescriptor

          Descriptor modelMBeanDescriptor
          The descriptor containing MBean wide policy

        • modelMBeanNotifications

          MBeanNotificationInfo[] modelMBeanNotifications
          The array of {@link ModelMBeanNotificationInfo} objects which have descriptors

        • modelMBeanOperations

          MBeanOperationInfo[] modelMBeanOperations
          The array of {@link ModelMBeanOperationInfo} objects which have descriptors

    • Class javax.management.modelmbean.ModelMBeanNotificationInfo extends MBeanNotificationInfo implements Serializable

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          Deserializes a ModelMBeanNotificationInfo from an ObjectInputStream.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream out)
                  throws IOException
          Serializes a ModelMBeanNotificationInfo to an ObjectOutputStream.
          Throws:
          IOException

      • Serialized Fields

        • notificationDescriptor

          Descriptor notificationDescriptor
          The descriptor containing the appropriate metadata for this instance

    • Class javax.management.modelmbean.ModelMBeanOperationInfo extends MBeanOperationInfo implements Serializable

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          Deserializes a ModelMBeanOperationInfo from an ObjectInputStream.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream out)
                  throws IOException
          Serializes a ModelMBeanOperationInfo to an ObjectOutputStream.
          Throws:
          IOException

      • Serialized Fields

        • operationDescriptor

          Descriptor operationDescriptor
          The descriptor containing the appropriate metadata for this instance

    • Class javax.management.modelmbean.XMLParseException extends Exception implements Serializable

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          Deserializes an XMLParseException from an ObjectInputStream.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream out)
                  throws IOException
          Serializes an XMLParseException to an ObjectOutputStream.
          Throws:
          IOException

  • Package javax.management.monitor

    • Class javax.management.monitor.MonitorNotification extends Notification implements Serializable

      serialVersionUID:
      -4608189663661929204L

      • Serialized Fields

        • observedObject

          ObjectName observedObject
          Monitor notification observed object.

        • observedAttribute

          String observedAttribute
          Monitor notification observed attribute.

        • derivedGauge

          Object derivedGauge
          Monitor notification derived gauge.

        • trigger

          Object trigger
          Monitor notification release mechanism. This value is used to keep the threshold/string (depending on the monitor type) that triggered off this notification.

    • Class javax.management.monitor.MonitorSettingException extends JMRuntimeException implements Serializable

      serialVersionUID:
      -8807913418190202007L

  • Package javax.management.openmbean

    • Class javax.management.openmbean.ArrayType extends OpenType<T> implements Serializable

      serialVersionUID:
      720504429830309770L

      • Serialization Methods

        • readResolve

          private Object readResolve()
                    throws ObjectStreamException
          Replace/resolve the object read from the stream before it is returned to the caller.
          Serial Data:
          The new serial form of this class defines a new serializable boolean field primitiveArray. In order to guarantee the interoperability with previous versions of this class the new serial form must continue to refer to primitive wrapper types even when the ArrayType instance describes a primitive type array. So when primitiveArray is true the className, typeName and description serializable fields are converted into primitive types before the deserialized ArrayType instance is return to the caller. The elementType field always returns the SimpleType corresponding to the primitive wrapper type of the array's primitive type.

          Therefore the following serializable fields are deserialized as follows:

          • if primitiveArray is true the className field is deserialized by replacing the array's component primitive wrapper type by the corresponding array's component primitive type, e.g. "[[Ljava.lang.Integer;" will be deserialized as "[[I".
          • if primitiveArray is true the typeName field is deserialized by replacing the array's component primitive wrapper type by the corresponding array's component primitive type, e.g. "[[Ljava.lang.Integer;" will be deserialized as "[[I".
          • if primitiveArray is true the description field is deserialized by replacing the array's component primitive wrapper type by the corresponding array's component primitive type, e.g. "2-dimension array of java.lang.Integer" will be deserialized as "2-dimension array of int".
          Throws:
          ObjectStreamException
          Since:
          1.6

        • writeReplace

          private Object writeReplace()
                     throws ObjectStreamException
          Nominate a replacement for this object in the stream before the object is written.
          Serial Data:
          The new serial form of this class defines a new serializable boolean field primitiveArray. In order to guarantee the interoperability with previous versions of this class the new serial form must continue to refer to primitive wrapper types even when the ArrayType instance describes a primitive type array. So when primitiveArray is true the className, typeName and description serializable fields are converted into wrapper types before the serialized ArrayType instance is written to the stream. The elementType field always returns the SimpleType corresponding to the primitive wrapper type of the array's primitive type.

          Therefore the following serializable fields are serialized as follows:

          • if primitiveArray is true the className field is serialized by replacing the array's component primitive type by the corresponding array's component primitive wrapper type, e.g. "[[I" will be serialized as "[[Ljava.lang.Integer;".
          • if primitiveArray is true the typeName field is serialized by replacing the array's component primitive type by the corresponding array's component primitive wrapper type, e.g. "[[I" will be serialized as "[[Ljava.lang.Integer;".
          • if primitiveArray is true the description field is serialized by replacing the array's component primitive type by the corresponding array's component primitive wrapper type, e.g. "2-dimension array of int" will be serialized as "2-dimension array of java.lang.Integer".
          Throws:
          ObjectStreamException
          Since:
          1.6

      • Serialized Fields

        • dimension

          int dimension
          The dimension of arrays described by this ArrayType instance.

        • elementType

          OpenType<T> elementType
          The open type of element values contained in the arrays described by this ArrayType instance.

        • primitiveArray

          boolean primitiveArray
          This flag indicates whether this ArrayType describes a primitive array.
          Since:
          1.6

    • Class javax.management.openmbean.CompositeDataSupport extends Object implements Serializable

      serialVersionUID:
      8003518976613702244L

      • Serialized Fields

        • contents

          SortedMap<K,V> contents
          Internal representation of the mapping of item names to their respective values. A SortedMap is used for faster retrieval of elements.

        • compositeType

          CompositeType compositeType
          The composite type of this composite data instance.

    • Class javax.management.openmbean.CompositeType extends OpenType<CompositeData> implements Serializable

      serialVersionUID:
      -5366242454346948798L

      • Serialized Fields

        • nameToDescription

          TreeMap<K,V> nameToDescription
          Sorted mapping of the item names to their descriptions

        • nameToType

          TreeMap<K,V> nameToType
          Sorted mapping of the item names to their open types

    • Class javax.management.openmbean.InvalidKeyException extends IllegalArgumentException implements Serializable

      serialVersionUID:
      4224269443946322062L

    • Class javax.management.openmbean.InvalidOpenTypeException extends IllegalArgumentException implements Serializable

      serialVersionUID:
      -2837312755412327534L

    • Class javax.management.openmbean.KeyAlreadyExistsException extends IllegalArgumentException implements Serializable

      serialVersionUID:
      1845183636745282866L

    • Class javax.management.openmbean.OpenDataException extends JMException implements Serializable

      serialVersionUID:
      8346311255433349870L

    • Class javax.management.openmbean.OpenMBeanAttributeInfoSupport extends MBeanAttributeInfo implements Serializable

      serialVersionUID:
      -4867215622149721849L

      • Serialization Methods

        • readResolve

          private Object readResolve()
          An object serialized in a version of the API before Descriptors were added to this class will have an empty or null Descriptor. For consistency with our behavior in this version, we must replace the object with one where the Descriptors reflect the same values of openType, defaultValue, etc.

      • Serialized Fields

        • openType

          OpenType<T> openType
          The open mbean attribute's open type

        • defaultValue

          Object defaultValue
          The open mbean attribute's default value

        • legalValues

          Set<E> legalValues
          The open mbean attribute's legal values. This Set is unmodifiable

        • minValue

          Comparable<T> minValue
          The open mbean attribute's min value

        • maxValue

          Comparable<T> maxValue
          The open mbean attribute's max value

    • Class javax.management.openmbean.OpenMBeanConstructorInfoSupport extends MBeanConstructorInfo implements Serializable

      serialVersionUID:
      -4400441579007477003L

    • Class javax.management.openmbean.OpenMBeanInfoSupport extends MBeanInfo implements Serializable

      serialVersionUID:
      4349395935420511492L

    • Class javax.management.openmbean.OpenMBeanOperationInfoSupport extends MBeanOperationInfo implements Serializable

      serialVersionUID:
      4996859732565369366L

      • Serialization Methods

        • readResolve

          private Object readResolve()
          An object serialized in a version of the API before Descriptors were added to this class will have an empty or null Descriptor. For consistency with our behavior in this version, we must replace the object with one where the Descriptors reflect the same value of returned openType.

      • Serialized Fields

        • returnOpenType

          OpenType<T> returnOpenType
          The open type of the values returned by the operation described by this OpenMBeanOperationInfo instance

    • Class javax.management.openmbean.OpenMBeanParameterInfoSupport extends MBeanParameterInfo implements Serializable

      serialVersionUID:
      -7235016873758443122L

      • Serialization Methods

        • readResolve

          private Object readResolve()
          An object serialized in a version of the API before Descriptors were added to this class will have an empty or null Descriptor. For consistency with our behavior in this version, we must replace the object with one where the Descriptors reflect the same values of openType, defaultValue, etc.

      • Serialized Fields

        • openType

          OpenType<T> openType
          The open mbean parameter's open type

        • defaultValue

          Object defaultValue
          The open mbean parameter's default value

        • legalValues

          Set<E> legalValues
          The open mbean parameter's legal values. This Set is unmodifiable

        • minValue

          Comparable<T> minValue
          The open mbean parameter's min value

        • maxValue

          Comparable<T> maxValue
          The open mbean parameter's max value

    • Class javax.management.openmbean.OpenType extends Object implements Serializable

      serialVersionUID:
      -9195195325186646468L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          Deserializes an OpenType from an ObjectInputStream.
          Throws:
          IOException
          ClassNotFoundException

      • Serialized Fields

        • className

          String className
          The fully qualified Java class name of open data values this type describes.

        • description

          String description
          The type description (should not be null or empty).

        • typeName

          String typeName
          The name given to this type (should not be null or empty).

    • Class javax.management.openmbean.SimpleType extends OpenType<T> implements Serializable

      serialVersionUID:
      2215577471957694503L

      • Serialization Methods

        • readResolve

          public Object readResolve()
                   throws ObjectStreamException
          Replace an object read from an ObjectInputStream with the unique instance for that value.
          Throws:
          ObjectStreamException - if the read object cannot be resolved.

    • Class javax.management.openmbean.TabularDataSupport extends Object implements Serializable

      serialVersionUID:
      5720150593236309827L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          Deserializes a TabularDataSupport from an ObjectInputStream.
          Throws:
          IOException
          ClassNotFoundException

      • Serialized Fields

        • dataMap

          Map<K,V> dataMap
          This tabular data instance's contents: a HashMap

        • tabularType

          TabularType tabularType
          This tabular data instance's tabular type

    • Class javax.management.openmbean.TabularType extends OpenType<TabularData> implements Serializable

      serialVersionUID:
      6554071860220659261L

      • Serialized Fields

        • rowType

          CompositeType rowType
          The composite type of rows

        • indexNames

          List<E> indexNames
          The items used to index each row element, kept in the order the user gave This is an unmodifiable ArrayList

  • Package javax.management.relation

    • Class javax.management.relation.InvalidRelationIdException extends RelationException implements Serializable

      serialVersionUID:
      -7115040321202754171L

    • Class javax.management.relation.InvalidRelationServiceException extends RelationException implements Serializable

      serialVersionUID:
      3400722103759507559L

    • Class javax.management.relation.InvalidRelationTypeException extends RelationException implements Serializable

      serialVersionUID:
      3007446608299169961L

    • Class javax.management.relation.InvalidRoleInfoException extends RelationException implements Serializable

      serialVersionUID:
      7517834705158932074L

    • Class javax.management.relation.InvalidRoleValueException extends RelationException implements Serializable

      serialVersionUID:
      -2066091747301983721L

    • Class javax.management.relation.MBeanServerNotificationFilter extends NotificationFilterSupport implements Serializable

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          Deserializes an MBeanServerNotificationFilter from an ObjectInputStream.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream out)
                  throws IOException
          Serializes an MBeanServerNotificationFilter to an ObjectOutputStream.
          Throws:
          IOException

      • Serialized Fields

        • deselectedNames

          List<E> deselectedNames
          List of {@link ObjectName}s with no interest
          • null means that all {@link ObjectName}s are implicitly deselected (check for explicit selections))
          • Empty vector means that no {@link ObjectName} is explicitly deselected

        • selectedNames

          List<E> selectedNames
          List of {@link ObjectName}s of interest
          • null means that all {@link ObjectName}s are implicitly selected (check for explicit deselections)
          • Empty vector means that no {@link ObjectName} is explicitly selected

    • Class javax.management.relation.RelationException extends JMException implements Serializable

      serialVersionUID:
      5434016005679159613L

    • Class javax.management.relation.RelationNotFoundException extends RelationException implements Serializable

      serialVersionUID:
      -3793951411158559116L

    • Class javax.management.relation.RelationNotification extends Notification implements Serializable

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          Deserializes a RelationNotification from an ObjectInputStream.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream out)
                  throws IOException
          Serializes a RelationNotification to an ObjectOutputStream.
          Throws:
          IOException

      • Serialized Fields

        • newRoleValue

          List<E> newRoleValue
          New role value ({@link ArrayList} of {@link ObjectName}s) (only for role update)

        • oldRoleValue

          List<E> oldRoleValue
          Old role value ({@link ArrayList} of {@link ObjectName}s) (only for role update)

        • relationId

          String relationId
          Relation identifier of created/removed/updated relation

        • relationObjName

          ObjectName relationObjName
          {@link ObjectName} of the relation MBean of created/removed/updated relation (only if the relation is represented by an MBean)

        • relationTypeName

          String relationTypeName
          Relation type name of created/removed/updated relation

        • roleName

          String roleName
          Name of updated role (only for role update)

        • unregisterMBeanList

          List<E> unregisterMBeanList
          List of {@link ObjectName}s of referenced MBeans to be unregistered due to relation removal

    • Class javax.management.relation.RelationServiceNotRegisteredException extends RelationException implements Serializable

      serialVersionUID:
      8454744887157122910L

    • Class javax.management.relation.RelationTypeNotFoundException extends RelationException implements Serializable

      serialVersionUID:
      1274155316284300752L

    • Class javax.management.relation.RelationTypeSupport extends Object implements Serializable

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          Deserializes a RelationTypeSupport from an ObjectInputStream.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream out)
                  throws IOException
          Serializes a RelationTypeSupport to an ObjectOutputStream.
          Throws:
          IOException

      • Serialized Fields

        • isInRelationService

          boolean isInRelationService
          Flag specifying whether the relation type has been declared in the Relation Service (so can no longer be updated)

        • roleName2InfoMap

          Map<K,V> roleName2InfoMap
          {@link Map} holding the mapping: <role name ({@link String})> -> <role info ({@link RoleInfo} object)>

        • typeName

          String typeName
          Relation type name

    • Class javax.management.relation.Role extends Object implements Serializable

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          Deserializes a Role from an ObjectInputStream.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream out)
                  throws IOException
          Serializes a Role to an ObjectOutputStream.
          Throws:
          IOException

      • Serialized Fields

        • name

          String name
          Role name

        • objectNameList

          List<E> objectNameList
          {@link List} of {@link ObjectName}s of referenced MBeans

    • Class javax.management.relation.RoleInfo extends Object implements Serializable

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          Deserializes a RoleInfo from an ObjectInputStream.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream out)
                  throws IOException
          Serializes a RoleInfo to an ObjectOutputStream.
          Throws:
          IOException

      • Serialized Fields

        • description

          String description
          Role description

        • isReadable

          boolean isReadable
          Read access mode: true if role is readable

        • isWritable

          boolean isWritable
          Write access mode: true if role is writable

        • maxDegree

          int maxDegree
          Maximum degree (i.e. maximum number of referenced MBeans in corresponding role)

        • minDegree

          int minDegree
          Minimum degree (i.e. minimum number of referenced MBeans in corresponding role)

        • name

          String name
          Role name

        • referencedMBeanClassName

          String referencedMBeanClassName
          Name of class of MBean(s) expected to be referenced in corresponding role

    • Class javax.management.relation.RoleInfoNotFoundException extends RelationException implements Serializable

      serialVersionUID:
      4394092234999959939L

    • Class javax.management.relation.RoleList extends ArrayList<Object> implements Serializable

      serialVersionUID:
      5568344346499649313L

    • Class javax.management.relation.RoleNotFoundException extends RelationException implements Serializable

      serialVersionUID:
      -2986406101364031481L

    • Class javax.management.relation.RoleResult extends Object implements Serializable

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          Deserializes a RoleResult from an ObjectInputStream.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream out)
                  throws IOException
          Serializes a RoleResult to an ObjectOutputStream.
          Throws:
          IOException

      • Serialized Fields

        • roleList

          RoleList roleList
          List of roles successfully accessed

        • unresolvedRoleList

          RoleUnresolvedList unresolvedRoleList
          List of roles unsuccessfully accessed

    • Class javax.management.relation.RoleUnresolved extends Object implements Serializable

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          Deserializes a RoleUnresolved from an ObjectInputStream.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream out)
                  throws IOException
          Serializes a RoleUnresolved to an ObjectOutputStream.
          Throws:
          IOException

      • Serialized Fields

        • problemType

          int problemType
          Problem type

        • roleName

          String roleName
          Role name

        • roleValue

          List<E> roleValue
          Role value ({@link List} of {@link ObjectName} objects)

    • Class javax.management.relation.RoleUnresolvedList extends ArrayList<Object> implements Serializable

      serialVersionUID:
      4054902803091433324L

  • Package javax.management.remote

    • Class javax.management.remote.JMXConnectionNotification extends Notification implements Serializable

      serialVersionUID:
      -2331308725952627538L

      • Serialized Fields

        • connectionId

          String connectionId
          The connection ID to which this notification pertains.
          See Also:
          JMXConnectionNotification.getConnectionId()

    • Class javax.management.remote.JMXPrincipal extends Object implements Serializable

      serialVersionUID:
      -4184480100214577411L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
          Throws:
          IOException
          ClassNotFoundException

      • Serialized Fields

        • name

          String name
          The JMX Remote API name for the identity represented by this JMXPrincipal object.
          See Also:
          JMXPrincipal.getName()

    • Class javax.management.remote.JMXProviderException extends IOException implements Serializable

      serialVersionUID:
      -3166703627550447198L

      • Serialized Fields

        • cause

          Throwable cause
          An exception that caused this exception to be thrown. This field may be null.
          See Also:
          JMXProviderException.getCause()

    • Class javax.management.remote.JMXServerErrorException extends IOException implements Serializable

      serialVersionUID:
      3996732239558744666L

      • Serialized Fields

        • cause

          Error cause
          An Error that caused this exception to be thrown.
          See Also:
          JMXServerErrorException.getCause()

    • Class javax.management.remote.JMXServiceURL extends Object implements Serializable

      serialVersionUID:
      8173364409860779292L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream inputStream)
                 throws IOException,
                        ClassNotFoundException
          Throws:
          IOException
          ClassNotFoundException

      • Serialized Fields

        • protocol

          String protocol
          The value returned by JMXServiceURL.getProtocol().

        • host

          String host
          The value returned by JMXServiceURL.getHost().

        • port

          int port
          The value returned by JMXServiceURL.getPort().

        • urlPath

          String urlPath
          The value returned by JMXServiceURL.getURLPath().

    • Class javax.management.remote.NotificationResult extends Object implements Serializable

      serialVersionUID:
      1191800228721395279L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
          Throws:
          IOException
          ClassNotFoundException

      • Serialized Fields

        • earliestSequenceNumber

          long earliestSequenceNumber

        • nextSequenceNumber

          long nextSequenceNumber

        • targetedNotifications

          TargetedNotification[] targetedNotifications

    • Class javax.management.remote.SubjectDelegationPermission extends BasicPermission implements Serializable

      serialVersionUID:
      1481618113008682343L

    • Class javax.management.remote.TargetedNotification extends Object implements Serializable

      serialVersionUID:
      7676132089779300926L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
          Throws:
          IOException
          ClassNotFoundException

      • Serialized Fields

        • notif

          Notification notif
          A notification to transmit to the other side.
          See Also:
          TargetedNotification.getNotification()

        • id

          Integer id
          The ID of the listener to which the notification is targeted.
          See Also:
          TargetedNotification.getListenerID()

  • Package javax.management.remote.rmi

    • Class javax.management.remote.rmi._RMIConnection_Stub extends Stub implements Serializable

    • Class javax.management.remote.rmi._RMIServer_Stub extends Stub implements Serializable

    • Class javax.management.remote.rmi.RMIConnectionImpl_Stub extends RemoteStub implements Serializable

      serialVersionUID:
      2L

    • Class javax.management.remote.rmi.RMIConnector extends Object implements Serializable

      serialVersionUID:
      817323035842634473L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Read RMIConnector fields from an ObjectInputStream. Calls s.defaultReadObject() and then initializes all transient variables that need initializing.
          Throws:
          InvalidObjectException - if none of rmiServer stub or jmxServiceURL are set.
          IOException
          ClassNotFoundException
          See Also:
          RMIConnector.RMIConnector(JMXServiceURL,Map), RMIConnector.RMIConnector(RMIServer,Map)

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Writes the RMIConnector fields to an ObjectOutputStream.

          Connects the underlying RMIServer stub to an ORB, if needed, before serializing it. This is done using the environment map that was provided to the constructor, if any, and as documented in javax.management.remote.rmi.

          This method then calls s.defaultWriteObject(). Usually, rmiServer is null if this object was constructed with a JMXServiceURL, and jmxServiceURL is null if this object is constructed with a RMIServer stub.

          Note that the environment Map is not serialized, since the objects it contains are assumed to be contextual and relevant only with respect to the local environment (class loader, ORB, etc...).

          After an RMIConnector is deserialized, it is assumed that the user will call RMIConnector.connect(Map), providing a new Map that can contain values which are contextually relevant to the new local environment.

          Since connection to the ORB is needed prior to serializing, and since the ORB to connect to is one of those contextual parameters, it is not recommended to re-serialize a just de-serialized object - as the de-serialized object has no map. Thus, when an RMIConnector object is needed for serialization or transmission to a remote application, it is recommended to obtain a new RMIConnector stub by calling RMIConnectorServer.toJMXConnector(Map).

          Throws:
          InvalidObjectException - if none of rmiServer stub or jmxServiceURL are set.
          IOException
          See Also:
          RMIConnector.RMIConnector(JMXServiceURL,Map), RMIConnector.RMIConnector(RMIServer,Map)

      • Serialized Fields

        • rmiServer

          RMIServer rmiServer
          The RMIServer stub of the RMI JMX Connector server to which this client connector is (or will be) connected. This field can be null when jmxServiceURL is not null. This includes the case where jmxServiceURL contains a serialized RMIServer stub. If both rmiServer and jmxServiceURL are null then serialization will fail.
          See Also:
          RMIConnector.RMIConnector(RMIServer,Map)

        • jmxServiceURL

          JMXServiceURL jmxServiceURL
          The JMXServiceURL of the RMI JMX Connector server to which this client connector will be connected. This field can be null when rmiServer is not null. If both rmiServer and jmxServiceURL are null then serialization will fail.
          See Also:
          RMIConnector.RMIConnector(JMXServiceURL,Map)

    • Class javax.management.remote.rmi.RMIServerImpl_Stub extends RemoteStub implements Serializable

      serialVersionUID:
      2L

  • Package javax.management.timer

    • Class javax.management.timer.TimerNotification extends Notification implements Serializable

      serialVersionUID:
      1798492029603825750L

      • Serialized Fields

        • notificationID

          Integer notificationID
          Timer notification identifier. This identifier is used to retrieve a timer notification from the timer list of notifications.

  • Package javax.naming

    • Class javax.naming.AuthenticationException extends NamingSecurityException implements Serializable

      serialVersionUID:
      3678497619904568096L

    • Class javax.naming.AuthenticationNotSupportedException extends NamingSecurityException implements Serializable

      serialVersionUID:
      -7149033933259492300L

    • Class javax.naming.BinaryRefAddr extends RefAddr implements Serializable

      serialVersionUID:
      -3415254970957330361L

      • Serialized Fields

        • buf

          byte[] buf
          Contains the bytes of the address. This field is initialized by the constructor and returned using getAddressBytes() and getAddressContents().

    • Class javax.naming.Binding extends NameClassPair implements Serializable

      serialVersionUID:
      8839217842691845890L

      • Serialized Fields

        • boundObj

          Object boundObj
          Contains this binding's object. It is initialized by the constructor and can be updated using setObject.
          See Also:
          Binding.getObject(), Binding.setObject(java.lang.Object)

    • Class javax.naming.CannotProceedException extends NamingException implements Serializable

      serialVersionUID:
      1219724816191576813L

      • Serialized Fields

        • remainingNewName

          Name remainingNewName
          Contains the remaining unresolved part of the second "name" argument to Context.rename(). This information necessary for continuing the Context.rename() operation.

          This field is initialized to null. It should not be manipulated directly: it should be accessed and updated using getRemainingName() and setRemainingName().

          See Also:
          CannotProceedException.getRemainingNewName(), CannotProceedException.setRemainingNewName(javax.naming.Name)

        • environment

          Hashtable<K,V> environment
          Contains the environment relevant for the Context or DirContext method that cannot proceed.

          This field is initialized to null. It should not be manipulated directly: it should be accessed and updated using getEnvironment() and setEnvironment().

          See Also:
          CannotProceedException.getEnvironment(), CannotProceedException.setEnvironment(java.util.Hashtable<?, ?>)

        • altName

          Name altName
          Contains the name of the resolved object, relative to the context altNameCtx. It is a composite name. If null, then no name is specified. See the javax.naming.spi.ObjectFactory.getObjectInstance method for details on how this is used.

          This field is initialized to null. It should not be manipulated directly: it should be accessed and updated using getAltName() and setAltName().

          See Also:
          CannotProceedException.getAltName(), CannotProceedException.setAltName(javax.naming.Name), CannotProceedException.altNameCtx, ObjectFactory.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable<?, ?>)

        • altNameCtx

          Context altNameCtx
          Contains the context relative to which altName is specified. If null, then the default initial context is implied. See the javax.naming.spi.ObjectFactory.getObjectInstance method for details on how this is used.

          This field is initialized to null. It should not be manipulated directly: it should be accessed and updated using getAltNameCtx() and setAltNameCtx().

          See Also:
          CannotProceedException.getAltNameCtx(), CannotProceedException.setAltNameCtx(javax.naming.Context), CannotProceedException.altName, ObjectFactory.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable<?, ?>)

    • Class javax.naming.CommunicationException extends NamingException implements Serializable

      serialVersionUID:
      3618507780299986611L

    • Class javax.naming.CompositeName extends Object implements Serializable

      serialVersionUID:
      1667768148915813118L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Overridden to avoid implementation dependency.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Overridden to avoid implementation dependency.
          Serial Data:
          The number of components (an int) followed by the individual components (each a String).
          Throws:
          IOException

    • Class javax.naming.CompoundName extends Object implements Serializable

      serialVersionUID:
      3513100557083972036L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Overridden to avoid implementation dependency.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Overridden to avoid implementation dependency.
          Serial Data:
          The syntax Properties, followed by the number of components (an int), and the individual components (each a String).
          Throws:
          IOException

    • Class javax.naming.ConfigurationException extends NamingException implements Serializable

      serialVersionUID:
      -2535156726228855704L

    • Class javax.naming.ContextNotEmptyException extends NamingException implements Serializable

      serialVersionUID:
      1090963683348219877L

    • Class javax.naming.InsufficientResourcesException extends NamingException implements Serializable

      serialVersionUID:
      6227672693037844532L

    • Class javax.naming.InterruptedNamingException extends NamingException implements Serializable

      serialVersionUID:
      6404516648893194728L

    • Class javax.naming.InvalidNameException extends NamingException implements Serializable

      serialVersionUID:
      -8370672380823801105L

    • Class javax.naming.LimitExceededException extends NamingException implements Serializable

      serialVersionUID:
      -776898738660207856L

    • Class javax.naming.LinkException extends NamingException implements Serializable

      serialVersionUID:
      -7967662604076777712L

      • Serialized Fields

        • linkResolvedName

          Name linkResolvedName
          Contains the part of the link that has been successfully resolved. It is a composite name and can be null. This field is initialized by the constructors. You should access and manipulate this field through its get and set methods.
          See Also:
          LinkException.getLinkResolvedName(), LinkException.setLinkResolvedName(javax.naming.Name)

        • linkResolvedObj

          Object linkResolvedObj
          Contains the object to which resolution of the part of the link was successful. Can be null. This field is initialized by the constructors. You should access and manipulate this field through its get and set methods.
          See Also:
          LinkException.getLinkResolvedObj(), LinkException.setLinkResolvedObj(java.lang.Object)

        • linkRemainingName

          Name linkRemainingName
          Contains the remaining link name that has not been resolved yet. It is a composite name and can be null. This field is initialized by the constructors. You should access and manipulate this field through its get and set methods.
          See Also:
          LinkException.getLinkRemainingName(), LinkException.setLinkRemainingName(javax.naming.Name)

        • linkExplanation

          String linkExplanation
          Contains the exception of why resolution of the link failed. Can be null. This field is initialized by the constructors. You should access and manipulate this field through its get and set methods.
          See Also:
          LinkException.getLinkExplanation(), LinkException.setLinkExplanation(java.lang.String)

    • Class javax.naming.LinkLoopException extends LinkException implements Serializable

      serialVersionUID:
      -3119189944325198009L

    • Class javax.naming.LinkRef extends Reference implements Serializable

      serialVersionUID:
      -5386290613498931298L

    • Class javax.naming.MalformedLinkException extends LinkException implements Serializable

      serialVersionUID:
      -3066740437737830242L

    • Class javax.naming.NameAlreadyBoundException extends NamingException implements Serializable

      serialVersionUID:
      -8491441000356780586L

    • Class javax.naming.NameClassPair extends Object implements Serializable

      serialVersionUID:
      5620776610160863339L

      • Serialized Fields

        • name

          String name
          Contains the name of this NameClassPair. It is initialized by the constructor and can be updated using setName().
          See Also:
          NameClassPair.getName(), NameClassPair.setName(java.lang.String)

        • className

          String className
          Contains the class name contained in this NameClassPair. It is initialized by the constructor and can be updated using setClassName().
          See Also:
          NameClassPair.getClassName(), NameClassPair.setClassName(java.lang.String)

        • fullName

          String fullName
          Contains the full name of this NameClassPair within its own namespace. It is initialized using setNameInNamespace()
          See Also:
          NameClassPair.getNameInNamespace(), NameClassPair.setNameInNamespace(java.lang.String)

        • isRel

          boolean isRel
          Records whether the name of this NameClassPair is relative to the target context. It is initialized by the constructor and can be updated using setRelative().
          See Also:
          NameClassPair.isRelative(),
NameClassPair.setRelative(boolean),
NameClassPair.getName(),
NameClassPair.setName(java.lang.String)

    • Class javax.naming.NameNotFoundException extends NamingException implements Serializable

      serialVersionUID:
      -8007156725367842053L

    • Class javax.naming.NamingException extends Exception implements Serializable

      serialVersionUID:
      -1299181962103167177L

      • Serialized Fields

        • resolvedName

          Name resolvedName
          Contains the part of the name that has been successfully resolved. It is a composite name and can be null. This field is initialized by the constructors. You should access and manipulate this field through its get and set methods.
          See Also:
          NamingException.getResolvedName(), NamingException.setResolvedName(javax.naming.Name)

        • resolvedObj

          Object resolvedObj
          Contains the object to which resolution of the part of the name was successful. Can be null. This field is initialized by the constructors. You should access and manipulate this field through its get and set methods.
          See Also:
          NamingException.getResolvedObj(), NamingException.setResolvedObj(java.lang.Object)

        • remainingName

          Name remainingName
          Contains the remaining name that has not been resolved yet. It is a composite name and can be null. This field is initialized by the constructors. You should access and manipulate this field through its get, set, "append" methods.
          See Also:
          NamingException.getRemainingName(),
NamingException.setRemainingName(javax.naming.Name),
NamingException.appendRemainingName(javax.naming.Name),
NamingException.appendRemainingComponent(java.lang.String)

        • rootException

          Throwable rootException
          Contains the original exception that caused this NamingException to be thrown. This field is set if there is additional information that could be obtained from the original exception, or if the original exception could not be mapped to a subclass of NamingException. Can be null.

          This field predates the general-purpose exception chaining facility. The NamingException.initCause(Throwable) and NamingException.getCause() methods are now the preferred means of accessing this information.

          See Also:
          NamingException.getRootCause(),
NamingException.setRootCause(Throwable),
NamingException.initCause(Throwable),
NamingException.getCause()

    • Class javax.naming.NamingSecurityException extends NamingException implements Serializable

      serialVersionUID:
      5855287647294685775L

    • Class javax.naming.NoInitialContextException extends NamingException implements Serializable

      serialVersionUID:
      -3413733186901258623L

    • Class javax.naming.NoPermissionException extends NamingSecurityException implements Serializable

      serialVersionUID:
      8395332708699751775L

    • Class javax.naming.NotContextException extends NamingException implements Serializable

      serialVersionUID:
      849752551644540417L

    • Class javax.naming.OperationNotSupportedException extends NamingException implements Serializable

      serialVersionUID:
      5493232822427682064L

    • Class javax.naming.PartialResultException extends NamingException implements Serializable

      serialVersionUID:
      2572144970049426786L

    • Class javax.naming.RefAddr extends Object implements Serializable

      serialVersionUID:
      -1468165120479154358L

      • Serialized Fields

        • addrType

          String addrType
          Contains the type of this address.

    • Class javax.naming.Reference extends Object implements Serializable

      serialVersionUID:
      -1673475790065791735L

      • Serialized Fields

        • className

          String className
          Contains the fully-qualified name of the class of the object to which this Reference refers.
          See Also:
          Class.getName()

        • addrs

          Vector<E> addrs
          Contains the addresses contained in this Reference. Initialized by constructor.

        • classFactory

          String classFactory
          Contains the name of the factory class for creating an instance of the object to which this Reference refers. Initialized to null.

        • classFactoryLocation

          String classFactoryLocation
          Contains the location of the factory class. Initialized to null.

    • Class javax.naming.ReferralException extends NamingException implements Serializable

      serialVersionUID:
      -2881363844695698876L

    • Class javax.naming.ServiceUnavailableException extends NamingException implements Serializable

      serialVersionUID:
      -4996964726566773444L

    • Class javax.naming.SizeLimitExceededException extends LimitExceededException implements Serializable

      serialVersionUID:
      7129289564879168579L

    • Class javax.naming.StringRefAddr extends RefAddr implements Serializable

      serialVersionUID:
      -8913762495138505527L

      • Serialized Fields

        • contents

          String contents
          Contains the contents of this address. Can be null.

    • Class javax.naming.TimeLimitExceededException extends LimitExceededException implements Serializable

      serialVersionUID:
      -3597009011385034696L

  • Package javax.naming.directory

    • Class javax.naming.directory.AttributeInUseException extends NamingException implements Serializable

      serialVersionUID:
      4437710305529322564L

    • Class javax.naming.directory.AttributeModificationException extends NamingException implements Serializable

      serialVersionUID:
      8060676069678710186L

      • Serialized Fields

        • unexecs

          ModificationItem[] unexecs
          Contains the possibly null list of unexecuted modifications.

    • Class javax.naming.directory.BasicAttribute extends Object implements Serializable

      serialVersionUID:
      6743528196119291326L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Overridden to avoid exposing implementation details.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Overridden to avoid exposing implementation details
          Serial Data:
          Default field (the attribute ID -- a String), followed by the number of values (an int), and the individual values.
          Throws:
          IOException

      • Serialized Fields

        • attrID

          String attrID
          Holds the attribute's id. It is initialized by the public constructor and cannot be null unless methods in BasicAttribute that use attrID have been overridden.

        • ordered

          boolean ordered
          A flag for recording whether this attribute's values are ordered.

    • Class javax.naming.directory.BasicAttributes extends Object implements Serializable

      serialVersionUID:
      4980164073184639448L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Overridden to avoid exposing implementation details.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Overridden to avoid exposing implementation details.
          Serial Data:
          Default field (ignoreCase flag -- a boolean), followed by the number of attributes in the set (an int), and then the individual Attribute objects.
          Throws:
          IOException

      • Serialized Fields

        • ignoreCase

          boolean ignoreCase
          Indicates whether case of attribute ids is ignored.

    • Class javax.naming.directory.InvalidAttributeIdentifierException extends NamingException implements Serializable

      serialVersionUID:
      -9036920266322999923L

    • Class javax.naming.directory.InvalidAttributesException extends NamingException implements Serializable

      serialVersionUID:
      2607612850539889765L

    • Class javax.naming.directory.InvalidAttributeValueException extends NamingException implements Serializable

      serialVersionUID:
      8720050295499275011L

    • Class javax.naming.directory.InvalidSearchControlsException extends NamingException implements Serializable

      serialVersionUID:
      -5124108943352665777L

    • Class javax.naming.directory.InvalidSearchFilterException extends NamingException implements Serializable

      serialVersionUID:
      2902700940682875441L

    • Class javax.naming.directory.ModificationItem extends Object implements Serializable

      serialVersionUID:
      7573258562534746850L

      • Serialized Fields

        • mod_op

          int mod_op
          Contains an integer identify the modification to be performed.

        • attr

          Attribute attr
          Contains the attribute identifying the attribute and/or its value to be applied for the modification.

    • Class javax.naming.directory.NoSuchAttributeException extends NamingException implements Serializable

      serialVersionUID:
      4836415647935888137L

    • Class javax.naming.directory.SchemaViolationException extends NamingException implements Serializable

      serialVersionUID:
      -3041762429525049663L

    • Class javax.naming.directory.SearchControls extends Object implements Serializable

      serialVersionUID:
      -2480540967773454797L

      • Serialized Fields

        • searchScope

          int searchScope
          Contains the scope with which to apply the search. One of ONELEVEL_SCOPE, OBJECT_SCOPE, or SUBTREE_SCOPE.

        • timeLimit

          int timeLimit
          Contains the milliseconds to wait before returning from search.

        • derefLink

          boolean derefLink
          Indicates whether JNDI links are dereferenced during search.

        • returnObj

          boolean returnObj
          Indicates whether object is returned in SearchResult.

        • countLimit

          long countLimit
          Contains the maximum number of SearchResults to return.

        • attributesToReturn

          String[] attributesToReturn
          Contains the list of attributes to be returned in SearchResult for each matching entry of search. null indicates that all attributes are to be returned.

    • Class javax.naming.directory.SearchResult extends Binding implements Serializable

      serialVersionUID:
      -9158063327699723172L

      • Serialized Fields

        • attrs

          Attributes attrs
          Contains the attributes returned with the object.

  • Package javax.naming.event

    • Class javax.naming.event.NamingEvent extends EventObject implements Serializable

      serialVersionUID:
      -7126752885365133499L

      • Serialized Fields

        • changeInfo

          Object changeInfo
          Contains information about the change that generated this event.

        • type

          int type
          Contains the type of this event.
          See Also:
          NamingEvent.OBJECT_ADDED, NamingEvent.OBJECT_REMOVED, NamingEvent.OBJECT_RENAMED, NamingEvent.OBJECT_CHANGED

        • oldBinding

          Binding oldBinding
          Contains information about the object before the change.

        • newBinding

          Binding newBinding
          Contains information about the object after the change.

    • Class javax.naming.event.NamingExceptionEvent extends EventObject implements Serializable

      serialVersionUID:
      -4877678086134736336L

      • Serialized Fields

        • exception

          NamingException exception
          Contains the exception that was thrown

  • Package javax.naming.ldap

    • Class javax.naming.ldap.BasicControl extends Object implements Serializable

      serialVersionUID:
      -4233907508771791687L

      • Serialized Fields

        • id

          String id
          The control's object identifier string.

        • criticality

          boolean criticality
          The control's criticality.

        • value

          byte[] value
          The control's ASN.1 BER encoded value.

    • Class javax.naming.ldap.LdapName extends Object implements Serializable

      serialVersionUID:
      -1595520034788997356L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Serializes only the unparsed DN, for compactness and to avoid any implementation dependency.
          Serial Data:
          The DN string
          Throws:
          IOException

    • Class javax.naming.ldap.LdapReferralException extends ReferralException implements Serializable

      serialVersionUID:
      -1668992791764950804L

    • Class javax.naming.ldap.ManageReferralControl extends BasicControl implements Serializable

      serialVersionUID:
      3017756160149982566L

    • Class javax.naming.ldap.PagedResultsControl extends BasicControl implements Serializable

      serialVersionUID:
      6684806685736844298L

    • Class javax.naming.ldap.PagedResultsResponseControl extends BasicControl implements Serializable

      serialVersionUID:
      -8819778744844514666L

      • Serialized Fields

        • resultSize

          int resultSize
          An estimate of the number of entries in the search result.

        • cookie

          byte[] cookie
          A server-generated cookie.

    • Class javax.naming.ldap.Rdn extends Object implements Serializable

      serialVersionUID:
      -5994465067210009656L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Serializes only the unparsed RDN, for compactness and to avoid any implementation dependency.
          Serial Data:
          The RDN string
          Throws:
          IOException

    • Class javax.naming.ldap.SortControl extends BasicControl implements Serializable

      serialVersionUID:
      -1965961680233330744L

    • Class javax.naming.ldap.SortResponseControl extends BasicControl implements Serializable

      serialVersionUID:
      5142939176006310877L

      • Serialized Fields

        • resultCode

          int resultCode
          The sort result code.

        • badAttrId

          String badAttrId
          The ID of the attribute that caused the sort to fail.

    • Class javax.naming.ldap.StartTlsRequest extends Object implements Serializable

      serialVersionUID:
      4441679576360753397L

    • Class javax.naming.ldap.StartTlsResponse extends Object implements Serializable

      serialVersionUID:
      8372842182579276418L

    • Class javax.naming.ldap.UnsolicitedNotificationEvent extends EventObject implements Serializable

      serialVersionUID:
      -2382603380799883705L

      • Serialized Fields

        • notice

          UnsolicitedNotification notice
          The notification that caused this event to be fired.

  • Package javax.naming.spi

    • Class javax.naming.spi.ResolveResult extends Object implements Serializable

      serialVersionUID:
      -4552108072002407559L

      • Serialized Fields

        • resolvedObj

          Object resolvedObj
          Field containing the Object that was resolved to successfully. It can be null only when constructed using a subclass. Constructors should always initialize this.

        • remainingName

          Name remainingName
          Field containing the remaining name yet to be resolved. It can be null only when constructed using a subclass. Constructors should always initialize this.

  • Package javax.net.ssl

    • Class javax.net.ssl.HandshakeCompletedEvent extends EventObject implements Serializable

      serialVersionUID:
      7914963744257769778L

    • Class javax.net.ssl.SSLException extends IOException implements Serializable

      serialVersionUID:
      4511006460650708967L

    • Class javax.net.ssl.SSLHandshakeException extends SSLException implements Serializable

      serialVersionUID:
      -5045881315018326890L

    • Class javax.net.ssl.SSLKeyException extends SSLException implements Serializable

      serialVersionUID:
      -8071664081941937874L

    • Class javax.net.ssl.SSLPeerUnverifiedException extends SSLException implements Serializable

      serialVersionUID:
      -8919512675000600547L

    • Class javax.net.ssl.SSLPermission extends BasicPermission implements Serializable

      serialVersionUID:
      -3456898025505876775L

    • Class javax.net.ssl.SSLProtocolException extends SSLException implements Serializable

      serialVersionUID:
      5445067063799134928L

    • Class javax.net.ssl.SSLSessionBindingEvent extends EventObject implements Serializable

      serialVersionUID:
      3989172637106345L

      • Serialized Fields

        • name

          String name
          The name to which the object is being bound or unbound

  • Package javax.print

    • Class javax.print.DocFlavor extends Object implements Serializable

      serialVersionUID:
      -4512080796965449721L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
          Reconstitute an instance from a stream (that is, deserialize it).
          Serial Data:
          The serialised form of a DocFlavor is the String naming the representation class followed by the String representing the canonical form of the mime type.
          Throws:
          ClassNotFoundException
          IOException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Write the instance to a stream (ie serialize the object).
          Throws:
          IOException

      • Serialized Fields

        • myClassName

          String myClassName
          Representation class name.

    • Class javax.print.DocFlavor.BYTE_ARRAY extends DocFlavor implements Serializable

      serialVersionUID:
      -9065578006593857475L

    • Class javax.print.DocFlavor.CHAR_ARRAY extends DocFlavor implements Serializable

      serialVersionUID:
      -8720590903724405128L

    • Class javax.print.DocFlavor.INPUT_STREAM extends DocFlavor implements Serializable

      serialVersionUID:
      -7045842700749194127L

    • Class javax.print.DocFlavor.READER extends DocFlavor implements Serializable

      serialVersionUID:
      7100295812579351567L

    • Class javax.print.DocFlavor.SERVICE_FORMATTED extends DocFlavor implements Serializable

      serialVersionUID:
      6181337766266637256L

    • Class javax.print.DocFlavor.STRING extends DocFlavor implements Serializable

      serialVersionUID:
      4414407504887034035L

    • Class javax.print.DocFlavor.URL extends DocFlavor implements Serializable

    • Class javax.print.PrintException extends Exception implements Serializable

  • Package javax.print.attribute

    • Class javax.print.attribute.AttributeSetUtilities.SynchronizedAttributeSet extends Object implements Serializable

      • Serialized Fields

        • attrset

          AttributeSet attrset

    • Class javax.print.attribute.AttributeSetUtilities.SynchronizedDocAttributeSet extends javax.print.attribute.AttributeSetUtilities.SynchronizedAttributeSet implements Serializable

    • Class javax.print.attribute.AttributeSetUtilities.SynchronizedPrintJobAttributeSet extends javax.print.attribute.AttributeSetUtilities.SynchronizedAttributeSet implements Serializable

    • Class javax.print.attribute.AttributeSetUtilities.SynchronizedPrintRequestAttributeSet extends javax.print.attribute.AttributeSetUtilities.SynchronizedAttributeSet implements Serializable

    • Class javax.print.attribute.AttributeSetUtilities.SynchronizedPrintServiceAttributeSet extends javax.print.attribute.AttributeSetUtilities.SynchronizedAttributeSet implements Serializable

    • Class javax.print.attribute.AttributeSetUtilities.UnmodifiableAttributeSet extends Object implements Serializable

      • Serialized Fields

        • attrset

          AttributeSet attrset

    • Class javax.print.attribute.AttributeSetUtilities.UnmodifiableDocAttributeSet extends javax.print.attribute.AttributeSetUtilities.UnmodifiableAttributeSet implements Serializable

    • Class javax.print.attribute.AttributeSetUtilities.UnmodifiablePrintJobAttributeSet extends javax.print.attribute.AttributeSetUtilities.UnmodifiableAttributeSet implements Serializable

    • Class javax.print.attribute.AttributeSetUtilities.UnmodifiablePrintRequestAttributeSet extends javax.print.attribute.AttributeSetUtilities.UnmodifiableAttributeSet implements Serializable

    • Class javax.print.attribute.AttributeSetUtilities.UnmodifiablePrintServiceAttributeSet extends javax.print.attribute.AttributeSetUtilities.UnmodifiableAttributeSet implements Serializable

    • Class javax.print.attribute.DateTimeSyntax extends Object implements Serializable

      serialVersionUID:
      -1400819079791208582L

      • Serialized Fields

        • value

          Date value
          This date-time attribute'sjava.util.Date value.

    • Class javax.print.attribute.EnumSyntax extends Object implements Serializable

      serialVersionUID:
      -2739521845085831642L

      • Serialization Methods

        • readResolve

          protected Object readResolve()
                      throws ObjectStreamException
          During object input, convert this deserialized enumeration instance to the proper enumeration value defined in the enumeration attribute class.
          Throws:
          ObjectStreamException - if the stream can't be deserialised
          InvalidObjectException - Thrown if the enumeration value table is null, this enumeration value's integer value does not correspond to an element in the enumeration value table, or the corresponding element in the enumeration value table is null. (Note: InvalidObjectException is a subclass of ObjectStreamException, which readResolve() is declared to throw.)

      • Serialized Fields

        • value

          int value
          This enumeration value's integer value.

    • Class javax.print.attribute.HashAttributeSet extends Object implements Serializable

      serialVersionUID:
      5311560590283707917L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
          Reconstitute an instance from a stream that is, deserialize it).
          Throws:
          ClassNotFoundException
          IOException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Write the instance to a stream (ie serialize the object)
          Serial Data:
          The serialized form of an attribute set explicitly writes the number of attributes in the set, and each of the attributes. This does not guarantee equality of serialized forms since the order in which the attributes are written is not defined.
          Throws:
          IOException

      • Serialized Fields

        • myInterface

          Class<T> myInterface
          The interface of which all members of this attribute set must be an instance. It is assumed to be interface Attribute or a subinterface thereof.

    • Class javax.print.attribute.HashDocAttributeSet extends HashAttributeSet implements Serializable

      serialVersionUID:
      -1128534486061432528L

    • Class javax.print.attribute.HashPrintJobAttributeSet extends HashAttributeSet implements Serializable

      serialVersionUID:
      -4204473656070350348L

    • Class javax.print.attribute.HashPrintRequestAttributeSet extends HashAttributeSet implements Serializable

      serialVersionUID:
      2364756266107751933L

    • Class javax.print.attribute.HashPrintServiceAttributeSet extends HashAttributeSet implements Serializable

      serialVersionUID:
      6642904616179203070L

    • Class javax.print.attribute.IntegerSyntax extends Object implements Serializable

      serialVersionUID:
      3644574816328081943L

      • Serialized Fields

        • value

          int value
          This integer attribute's integer value.

    • Class javax.print.attribute.ResolutionSyntax extends Object implements Serializable

      serialVersionUID:
      2706743076526672017L

      • Serialized Fields

        • crossFeedResolution

          int crossFeedResolution
          Cross feed direction resolution in units of dots per 100 inches (dphi).

        • feedResolution

          int feedResolution
          Feed direction resolution in units of dots per 100 inches (dphi).

    • Class javax.print.attribute.SetOfIntegerSyntax extends Object implements Serializable

      serialVersionUID:
      3666874174847632203L

      • Serialized Fields

        • members

          int[][] members
          This set's members in canonical array form.

    • Class javax.print.attribute.Size2DSyntax extends Object implements Serializable

      serialVersionUID:
      5584439964938660530L

      • Serialized Fields

        • x

          int x
          X dimension in units of micrometers (µm).

        • y

          int y
          Y dimension in units of micrometers (µm).

    • Class javax.print.attribute.TextSyntax extends Object implements Serializable

      serialVersionUID:
      -8130648736378144102L

      • Serialized Fields

        • value

          String value
          String value of this text attribute.

        • locale

          Locale locale
          Locale of this text attribute.

    • Class javax.print.attribute.UnmodifiableSetException extends RuntimeException implements Serializable

    • Class javax.print.attribute.URISyntax extends Object implements Serializable

      serialVersionUID:
      -7842661210486401678L

      • Serialized Fields

        • uri

          URI uri
          URI value of this URI attribute.

  • Package javax.print.attribute.standard

    • Class javax.print.attribute.standard.Chromaticity extends EnumSyntax implements Serializable

      serialVersionUID:
      4660543931355214012L

    • Class javax.print.attribute.standard.ColorSupported extends EnumSyntax implements Serializable

      serialVersionUID:
      -2700555589688535545L

    • Class javax.print.attribute.standard.Compression extends EnumSyntax implements Serializable

      serialVersionUID:
      -5716748913324997674L

    • Class javax.print.attribute.standard.Copies extends IntegerSyntax implements Serializable

      serialVersionUID:
      -6426631521680023833L

    • Class javax.print.attribute.standard.CopiesSupported extends SetOfIntegerSyntax implements Serializable

      serialVersionUID:
      6927711687034846001L

    • Class javax.print.attribute.standard.DateTimeAtCompleted extends DateTimeSyntax implements Serializable

      serialVersionUID:
      6497399708058490000L

    • Class javax.print.attribute.standard.DateTimeAtCreation extends DateTimeSyntax implements Serializable

      serialVersionUID:
      -2923732231056647903L

    • Class javax.print.attribute.standard.DateTimeAtProcessing extends DateTimeSyntax implements Serializable

      serialVersionUID:
      -3710068197278263244L

    • Class javax.print.attribute.standard.Destination extends URISyntax implements Serializable

      serialVersionUID:
      6776739171700415321L

    • Class javax.print.attribute.standard.DialogTypeSelection extends EnumSyntax implements Serializable

      serialVersionUID:
      7518682952133256029L

    • Class javax.print.attribute.standard.DocumentName extends TextSyntax implements Serializable

      serialVersionUID:
      7883105848533280430L

    • Class javax.print.attribute.standard.Fidelity extends EnumSyntax implements Serializable

      serialVersionUID:
      6320827847329172308L

    • Class javax.print.attribute.standard.Finishings extends EnumSyntax implements Serializable

      serialVersionUID:
      -627840419548391754L

    • Class javax.print.attribute.standard.JobHoldUntil extends DateTimeSyntax implements Serializable

      serialVersionUID:
      -1664471048860415024L

    • Class javax.print.attribute.standard.JobImpressions extends IntegerSyntax implements Serializable

      serialVersionUID:
      8225537206784322464L

    • Class javax.print.attribute.standard.JobImpressionsCompleted extends IntegerSyntax implements Serializable

      serialVersionUID:
      6722648442432393294L

    • Class javax.print.attribute.standard.JobImpressionsSupported extends SetOfIntegerSyntax implements Serializable

      serialVersionUID:
      -4887354803843173692L

    • Class javax.print.attribute.standard.JobKOctets extends IntegerSyntax implements Serializable

      serialVersionUID:
      -8959710146498202869L

    • Class javax.print.attribute.standard.JobKOctetsProcessed extends IntegerSyntax implements Serializable

      serialVersionUID:
      -6265238509657881806L

    • Class javax.print.attribute.standard.JobKOctetsSupported extends SetOfIntegerSyntax implements Serializable

      serialVersionUID:
      -2867871140549897443L

    • Class javax.print.attribute.standard.JobMediaSheets extends IntegerSyntax implements Serializable

      serialVersionUID:
      408871131531979741L

    • Class javax.print.attribute.standard.JobMediaSheetsCompleted extends IntegerSyntax implements Serializable

      serialVersionUID:
      1739595973810840475L

    • Class javax.print.attribute.standard.JobMediaSheetsSupported extends SetOfIntegerSyntax implements Serializable

      serialVersionUID:
      2953685470388672940L

    • Class javax.print.attribute.standard.JobMessageFromOperator extends TextSyntax implements Serializable

      serialVersionUID:
      -4620751846003142047L

    • Class javax.print.attribute.standard.JobName extends TextSyntax implements Serializable

      serialVersionUID:
      4660359192078689545L

    • Class javax.print.attribute.standard.JobOriginatingUserName extends TextSyntax implements Serializable

      serialVersionUID:
      -8052537926362933477L

    • Class javax.print.attribute.standard.JobPriority extends IntegerSyntax implements Serializable

      serialVersionUID:
      -4599900369040602769L

    • Class javax.print.attribute.standard.JobPrioritySupported extends IntegerSyntax implements Serializable

      serialVersionUID:
      2564840378013555894L

    • Class javax.print.attribute.standard.JobSheets extends EnumSyntax implements Serializable

      serialVersionUID:
      -4735258056132519759L

    • Class javax.print.attribute.standard.JobState extends EnumSyntax implements Serializable

      serialVersionUID:
      400465010094018920L

    • Class javax.print.attribute.standard.JobStateReason extends EnumSyntax implements Serializable

      serialVersionUID:
      -8765894420449009168L

    • Class javax.print.attribute.standard.JobStateReasons extends HashSet<JobStateReason> implements Serializable

      serialVersionUID:
      8849088261264331812L

    • Class javax.print.attribute.standard.Media extends EnumSyntax implements Serializable

      serialVersionUID:
      -2823970704630722439L

    • Class javax.print.attribute.standard.MediaName extends Media implements Serializable

      serialVersionUID:
      4653117714524155448L

    • Class javax.print.attribute.standard.MediaPrintableArea extends Object implements Serializable

      serialVersionUID:
      -1597171464050795793L

      • Serialized Fields

        • x

          int x

        • y

          int y

        • w

          int w

        • h

          int h

        • units

          int units

    • Class javax.print.attribute.standard.MediaSize extends Size2DSyntax implements Serializable

      serialVersionUID:
      -1967958664615414771L

      • Serialized Fields

        • mediaName

          MediaSizeName mediaName

    • Class javax.print.attribute.standard.MediaSizeName extends Media implements Serializable

      serialVersionUID:
      2778798329756942747L

    • Class javax.print.attribute.standard.MediaTray extends Media implements Serializable

      serialVersionUID:
      -982503611095214703L

    • Class javax.print.attribute.standard.MultipleDocumentHandling extends EnumSyntax implements Serializable

      serialVersionUID:
      8098326460746413466L

    • Class javax.print.attribute.standard.NumberOfDocuments extends IntegerSyntax implements Serializable

      serialVersionUID:
      7891881310684461097L

    • Class javax.print.attribute.standard.NumberOfInterveningJobs extends IntegerSyntax implements Serializable

      serialVersionUID:
      2568141124844982746L

    • Class javax.print.attribute.standard.NumberUp extends IntegerSyntax implements Serializable

      serialVersionUID:
      -3040436486786527811L

    • Class javax.print.attribute.standard.NumberUpSupported extends SetOfIntegerSyntax implements Serializable

      serialVersionUID:
      -1041573395759141805L

    • Class javax.print.attribute.standard.OrientationRequested extends EnumSyntax implements Serializable

      serialVersionUID:
      -4447437289862822276L

    • Class javax.print.attribute.standard.OutputDeviceAssigned extends TextSyntax implements Serializable

      serialVersionUID:
      5486733778854271081L

    • Class javax.print.attribute.standard.PageRanges extends SetOfIntegerSyntax implements Serializable

      serialVersionUID:
      8639895197656148392L

    • Class javax.print.attribute.standard.PagesPerMinute extends IntegerSyntax implements Serializable

      serialVersionUID:
      -6366403993072862015L

    • Class javax.print.attribute.standard.PagesPerMinuteColor extends IntegerSyntax implements Serializable

      serialVersionUID:
      1684993151687470944L

    • Class javax.print.attribute.standard.PDLOverrideSupported extends EnumSyntax implements Serializable

      serialVersionUID:
      -4393264467928463934L

    • Class javax.print.attribute.standard.PresentationDirection extends EnumSyntax implements Serializable

      serialVersionUID:
      8294728067230931780L

    • Class javax.print.attribute.standard.PrinterInfo extends TextSyntax implements Serializable

      serialVersionUID:
      7765280618777599727L

    • Class javax.print.attribute.standard.PrinterIsAcceptingJobs extends EnumSyntax implements Serializable

      serialVersionUID:
      -5052010680537678061L

    • Class javax.print.attribute.standard.PrinterLocation extends TextSyntax implements Serializable

      serialVersionUID:
      -1598610039865566337L

    • Class javax.print.attribute.standard.PrinterMakeAndModel extends TextSyntax implements Serializable

      serialVersionUID:
      4580461489499351411L

    • Class javax.print.attribute.standard.PrinterMessageFromOperator extends TextSyntax implements Serializable

      serialVersionUID:
      -4486871203218629318L

    • Class javax.print.attribute.standard.PrinterMoreInfo extends URISyntax implements Serializable

      serialVersionUID:
      4555850007675338574L

    • Class javax.print.attribute.standard.PrinterMoreInfoManufacturer extends URISyntax implements Serializable

      serialVersionUID:
      3323271346485076608L

    • Class javax.print.attribute.standard.PrinterName extends TextSyntax implements Serializable

      serialVersionUID:
      299740639137803127L

    • Class javax.print.attribute.standard.PrinterResolution extends ResolutionSyntax implements Serializable

      serialVersionUID:
      13090306561090558L

    • Class javax.print.attribute.standard.PrinterState extends EnumSyntax implements Serializable

      serialVersionUID:
      -649578618346507718L

    • Class javax.print.attribute.standard.PrinterStateReason extends EnumSyntax implements Serializable

      serialVersionUID:
      -1623720656201472593L

    • Class javax.print.attribute.standard.PrinterStateReasons extends HashMap<PrinterStateReason,Severity> implements Serializable

      serialVersionUID:
      -3731791085163619457L

    • Class javax.print.attribute.standard.PrinterURI extends URISyntax implements Serializable

      serialVersionUID:
      7923912792485606497L

    • Class javax.print.attribute.standard.PrintQuality extends EnumSyntax implements Serializable

      serialVersionUID:
      -3072341285225858365L

    • Class javax.print.attribute.standard.QueuedJobCount extends IntegerSyntax implements Serializable

      serialVersionUID:
      7499723077864047742L

    • Class javax.print.attribute.standard.ReferenceUriSchemesSupported extends EnumSyntax implements Serializable

      serialVersionUID:
      -8989076942813442805L

    • Class javax.print.attribute.standard.RequestingUserName extends TextSyntax implements Serializable

      serialVersionUID:
      -2683049894310331454L

    • Class javax.print.attribute.standard.Severity extends EnumSyntax implements Serializable

      serialVersionUID:
      8781881462717925380L

    • Class javax.print.attribute.standard.SheetCollate extends EnumSyntax implements Serializable

      serialVersionUID:
      7080587914259873003L

    • Class javax.print.attribute.standard.Sides extends EnumSyntax implements Serializable

      serialVersionUID:
      -6890309414893262822L

  • Package javax.print.event

    • Class javax.print.event.PrintEvent extends EventObject implements Serializable

      serialVersionUID:
      2286914924430763847L

    • Class javax.print.event.PrintJobAttributeEvent extends PrintEvent implements Serializable

      serialVersionUID:
      -6534469883874742101L

      • Serialized Fields

        • attributes

          PrintJobAttributeSet attributes

    • Class javax.print.event.PrintJobEvent extends PrintEvent implements Serializable

      serialVersionUID:
      -1711656903622072997L

      • Serialized Fields

        • reason

          int reason

    • Class javax.print.event.PrintServiceAttributeEvent extends PrintEvent implements Serializable

      serialVersionUID:
      -7565987018140326600L

      • Serialized Fields

        • attributes

          PrintServiceAttributeSet attributes

  • Package javax.rmi.CORBA

    • Class javax.rmi.CORBA.ClassDesc extends Object implements Serializable

      • Serialized Fields

        • repid

          String repid
          The class's RepositoryId.

        • codebase

          String codebase
          A space-separated list of codebase URLs.

    • Class javax.rmi.CORBA.Stub extends ObjectImpl implements Serializable

      serialVersionUID:
      1087775603798577179L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream stream)
                 throws IOException,
                        ClassNotFoundException
          Serialization method to restore the IOR state.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream stream)
                  throws IOException
          Serialization method to save the IOR state.
          Serial Data:
          The length of the IOR type ID (int), followed by the IOR type ID (byte array encoded using ISO8859-1), followed by the number of IOR profiles (int), followed by the IOR profiles. Each IOR profile is written as a profile tag (int), followed by the length of the profile data (int), followed by the profile data (byte array).
          Throws:
          IOException

  • Package javax.rmi.ssl

    • Class javax.rmi.ssl.SslRMIClientSocketFactory extends Object implements Serializable

      serialVersionUID:
      -8310631444933958385L

  • Package javax.script

    • Class javax.script.ScriptException extends Exception implements Serializable

      serialVersionUID:
      8265071037049225001L

      • Serialized Fields

        • fileName

          String fileName

        • lineNumber

          int lineNumber

        • columnNumber

          int columnNumber

  • Package javax.security.auth

    • Class javax.security.auth.AuthPermission extends BasicPermission implements Serializable

      serialVersionUID:
      5806031445061587174L

    • Class javax.security.auth.DestroyFailedException extends Exception implements Serializable

      serialVersionUID:
      -7790152857282749162L

    • Class javax.security.auth.PrivateCredentialPermission extends Permission implements Serializable

      serialVersionUID:
      5284372143517237068L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Reads this object from a stream (i.e., deserializes it)
          Throws:
          IOException
          ClassNotFoundException

      • Serialized Fields

        • credentialClass

          String credentialClass

        • principals

          Set<E> principals
          The Principals associated with this permission. The set contains elements of type, PrivateCredentialPermission.CredOwner.

        • testing

          boolean testing

    • Class javax.security.auth.PrivateCredentialPermission.CredOwner extends Object implements Serializable

      serialVersionUID:
      -5607449830436408266L

      • Serialized Fields

        • principalClass

          String principalClass

        • principalName

          String principalName

    • Class javax.security.auth.RefreshFailedException extends Exception implements Serializable

      serialVersionUID:
      5058444488565265840L

    • Class javax.security.auth.Subject extends Object implements Serializable

      serialVersionUID:
      -8308522755600156056L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Reads this object from a stream (i.e., deserializes it)
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream oos)
                  throws IOException
          Writes this object out to a stream (i.e., serializes it).
          Throws:
          IOException

      • Serialized Fields

        • principals

          Set<E> principals
          A Set that provides a view of all of this Subject's Principals

          Each element in this set is a java.security.Principal. The set is a Subject.SecureSet.

        • readOnly

          boolean readOnly
          Whether this Subject is read-only

    • Class javax.security.auth.Subject.SecureSet extends AbstractSet<E> implements Serializable

      serialVersionUID:
      7911754171111800359L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream oos)
                  throws IOException
          Writes this object out to a stream (i.e., serializes it).

          Serial Data:
          If this is a private credential set, a security check is performed to ensure that the caller has permission to access each credential in the set. If the security check passes, the set is serialized.
          Throws:
          IOException

      • Serialized Fields

        • elements

          LinkedList<E> elements
          The elements in this set.

        • this$0

          Subject this$0
          The outer Subject instance.

  • Package javax.security.auth.callback

    • Class javax.security.auth.callback.ChoiceCallback extends Object implements Serializable

      serialVersionUID:
      -3975664071579892167L

      • Serialized Fields

        • prompt

          String prompt
          Since:
          1.4

        • choices

          String[] choices
          the list of choices
          Since:
          1.4

        • defaultChoice

          int defaultChoice
          the choice to be used as the default choice
          Since:
          1.4

        • multipleSelectionsAllowed

          boolean multipleSelectionsAllowed
          whether multiple selections are allowed from the list of choices
          Since:
          1.4

        • selections

          int[] selections
          the selected choices, represented as indexes into the choices list.
          Since:
          1.4

    • Class javax.security.auth.callback.ConfirmationCallback extends Object implements Serializable

      serialVersionUID:
      -9095656433782481624L

      • Serialized Fields

        • prompt

          String prompt
          Since:
          1.4

        • messageType

          int messageType
          Since:
          1.4

        • optionType

          int optionType
          Since:
          1.4

        • defaultOption

          int defaultOption
          Since:
          1.4

        • options

          String[] options
          Since:
          1.4

        • selection

          int selection
          Since:
          1.4

    • Class javax.security.auth.callback.LanguageCallback extends Object implements Serializable

      serialVersionUID:
      2019050433478903213L

      • Serialized Fields

        • locale

          Locale locale
          Since:
          1.4

    • Class javax.security.auth.callback.NameCallback extends Object implements Serializable

      serialVersionUID:
      3770938795909392253L

      • Serialized Fields

        • prompt

          String prompt
          Since:
          1.4

        • defaultName

          String defaultName
          Since:
          1.4

        • inputName

          String inputName
          Since:
          1.4

    • Class javax.security.auth.callback.PasswordCallback extends Object implements Serializable

      serialVersionUID:
      2267422647454909926L

      • Serialized Fields

        • prompt

          String prompt
          Since:
          1.4

        • echoOn

          boolean echoOn
          Since:
          1.4

        • inputPassword

          char[] inputPassword
          Since:
          1.4

    • Class javax.security.auth.callback.TextInputCallback extends Object implements Serializable

      serialVersionUID:
      -8064222478852811804L

      • Serialized Fields

        • prompt

          String prompt
          Since:
          1.4

        • defaultText

          String defaultText
          Since:
          1.4

        • inputText

          String inputText
          Since:
          1.4

    • Class javax.security.auth.callback.TextOutputCallback extends Object implements Serializable

      serialVersionUID:
      1689502495511663102L

      • Serialized Fields

        • messageType

          int messageType
          Since:
          1.4

        • message

          String message
          Since:
          1.4

    • Class javax.security.auth.callback.UnsupportedCallbackException extends Exception implements Serializable

      serialVersionUID:
      -6873556327655666839L

      • Serialized Fields

        • callback

          Callback callback

  • Package javax.security.auth.kerberos

    • Class javax.security.auth.kerberos.DelegationPermission extends BasicPermission implements Serializable

      serialVersionUID:
      883133252142523922L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          readObject is called to restore the state of the DelegationPermission from a stream.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          WriteObject is called to save the state of the DelegationPermission to a stream. The actions are serialized, and the superclass takes care of the name.
          Throws:
          IOException

    • Class javax.security.auth.kerberos.KerberosKey extends Object implements Serializable

      serialVersionUID:
      -4625402278148246993L

      • Serialized Fields

        • principal

          KerberosPrincipal principal
          The principal that this secret key belongs to.

        • versionNum

          int versionNum
          the version number of this secret key

        • key

          javax.security.auth.kerberos.KeyImpl key
          KeyImpl is serialized by writing out the ASN1 Encoded bytes of the encryption key. The ASN1 encoding is defined in RFC4120 and as follows:
           EncryptionKey   ::= SEQUENCE {
           keytype   [0] Int32 -- actually encryption type --,
           keyvalue  [1] OCTET STRING
 }

    • Class javax.security.auth.kerberos.KerberosPrincipal extends Object implements Serializable

      serialVersionUID:
      -7374788026156829911L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
          Reads this object from a stream (i.e., deserializes it)
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream oos)
                  throws IOException
          Save the KerberosPrincipal object to a stream
          Serial Data:
          this KerberosPrincipal is serialized by writing out the PrincipalName and the realm in their DER-encoded form as specified in Section 5.2.2 of RFC4120.
          Throws:
          IOException

    • Class javax.security.auth.kerberos.KerberosTicket extends Object implements Serializable

      serialVersionUID:
      7395334370157380539L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          Throws:
          IOException
          ClassNotFoundException

      • Serialized Fields

        • asn1Encoding

          byte[] asn1Encoding
          ASN.1 DER Encoding of the Ticket as defined in the Kerberos Protocol Specification RFC4120.

        • sessionKey

          javax.security.auth.kerberos.KeyImpl sessionKey
          KeyImpl is serialized by writing out the ASN1 Encoded bytes of the encryption key. The ASN1 encoding is defined in RFC4120 and as follows:
           EncryptionKey   ::= SEQUENCE {
          keytype    [0] Int32 -- actually encryption type --,
          keyvalue   [1] OCTET STRING
 }

        • flags

          boolean[] flags
          Ticket Flags as defined in the Kerberos Protocol Specification RFC4120.

        • authTime

          Date authTime
          Time of initial authentication

        • startTime

          Date startTime
          Time after which the ticket is valid.

        • endTime

          Date endTime
          Time after which the ticket will not be honored. (its expiration time).

        • renewTill

          Date renewTill
          For renewable Tickets it indicates the maximum endtime that may be included in a renewal. It can be thought of as the absolute expiration time for the ticket, including all renewals. This field may be null for tickets that are not renewable.

        • client

          KerberosPrincipal client
          Client that owns the service ticket

        • server

          KerberosPrincipal server
          The service for which the ticket was issued.

        • clientAddresses

          InetAddress[] clientAddresses
          The addresses from where the ticket may be used by the client. This field may be null when the ticket is usable from any address.

    • Class javax.security.auth.kerberos.KeyImpl extends Object implements Serializable

      serialVersionUID:
      -7889313790214321193L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream ois)
                  throws IOException
          Serial Data:
          this KeyImpl is serialized by writing out the ASN1 Encoded bytes of the encryption key. The ASN1 encoding is defined in RFC4120 and as follows: EncryptionKey ::= SEQUENCE { keytype [0] Int32 -- actually encryption type --, keyvalue [1] OCTET STRING }
          Throws:
          IOException

    • Class javax.security.auth.kerberos.ServicePermission extends Permission implements Serializable

      serialVersionUID:
      -1227585031618624935L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          readObject is called to restore the state of the ServicePermission from a stream.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          WriteObject is called to save the state of the ServicePermission to a stream. The actions are serialized, and the superclass takes care of the name.
          Throws:
          IOException

      • Serialized Fields

        • actions

          String actions
          the actions string.

  • Package javax.security.auth.login

    • Class javax.security.auth.login.AccountException extends LoginException implements Serializable

      serialVersionUID:
      -2112878680072211787L

    • Class javax.security.auth.login.AccountExpiredException extends AccountException implements Serializable

      serialVersionUID:
      -6064064890162661560L

    • Class javax.security.auth.login.AccountLockedException extends AccountException implements Serializable

      serialVersionUID:
      8280345554014066334L

    • Class javax.security.auth.login.AccountNotFoundException extends AccountException implements Serializable

      serialVersionUID:
      1498349563916294614L

    • Class javax.security.auth.login.CredentialException extends LoginException implements Serializable

      serialVersionUID:
      -4772893876810601859L

    • Class javax.security.auth.login.CredentialExpiredException extends CredentialException implements Serializable

      serialVersionUID:
      -5344739593859737937L

    • Class javax.security.auth.login.CredentialNotFoundException extends CredentialException implements Serializable

      serialVersionUID:
      -7779934467214319475L

    • Class javax.security.auth.login.FailedLoginException extends LoginException implements Serializable

      serialVersionUID:
      802556922354616286L

    • Class javax.security.auth.login.LoginException extends GeneralSecurityException implements Serializable

      serialVersionUID:
      -4679091624035232488L

  • Package javax.security.auth.x500

    • Class javax.security.auth.x500.X500Principal extends Object implements Serializable

      serialVersionUID:
      -500463348111345721L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        NotActiveException,
                        ClassNotFoundException
          Reads this object from a stream (i.e., deserializes it).
          Throws:
          IOException
          NotActiveException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Save the X500Principal object to a stream.
          Serial Data:
          this X500Principal is serialized by writing out its DER-encoded form (the value of getEncoded is serialized).
          Throws:
          IOException

  • Package javax.security.cert

    • Class javax.security.cert.CertificateEncodingException extends CertificateException implements Serializable

      serialVersionUID:
      -8187642723048403470L

    • Class javax.security.cert.CertificateException extends Exception implements Serializable

      serialVersionUID:
      -5757213374030785290L

    • Class javax.security.cert.CertificateExpiredException extends CertificateException implements Serializable

      serialVersionUID:
      5091601212177261883L

    • Class javax.security.cert.CertificateNotYetValidException extends CertificateException implements Serializable

      serialVersionUID:
      -8976172474266822818L

    • Class javax.security.cert.CertificateParsingException extends CertificateException implements Serializable

      serialVersionUID:
      -8449352422951136229L

  • Package javax.security.sasl

    • Class javax.security.sasl.AuthenticationException extends SaslException implements Serializable

      serialVersionUID:
      -3579708765071815007L

    • Class javax.security.sasl.AuthorizeCallback extends Object implements Serializable

      serialVersionUID:
      -2353344186490470805L

      • Serialized Fields

        • authenticationID

          String authenticationID
          The (authenticated) authentication id to check.

        • authorizationID

          String authorizationID
          The authorization id to check.

        • authorizedID

          String authorizedID
          The id of the authorized entity. If null, the id of the authorized entity is authorizationID.

        • authorized

          boolean authorized
          A flag indicating whether the authentication id is allowed to act on behalf of the authorization id.

    • Class javax.security.sasl.RealmCallback extends TextInputCallback implements Serializable

      serialVersionUID:
      -4342673378785456908L

    • Class javax.security.sasl.RealmChoiceCallback extends ChoiceCallback implements Serializable

      serialVersionUID:
      -8588141348846281332L

    • Class javax.security.sasl.SaslException extends IOException implements Serializable

      serialVersionUID:
      4579784287983423626L

      • Serialized Fields

        • _exception

          Throwable _exception
          The possibly null root cause exception.

  • Package javax.sound.midi

    • Class javax.sound.midi.InvalidMidiDataException extends Exception implements Serializable

    • Class javax.sound.midi.MidiUnavailableException extends Exception implements Serializable

  • Package javax.sound.sampled

    • Class javax.sound.sampled.AudioPermission extends BasicPermission implements Serializable

    • Class javax.sound.sampled.LineUnavailableException extends Exception implements Serializable

    • Class javax.sound.sampled.UnsupportedAudioFileException extends Exception implements Serializable

  • Package javax.sql

    • Class javax.sql.ConnectionEvent extends EventObject implements Serializable

      serialVersionUID:
      -4843217645290030002L

      • Serialized Fields

        • ex

          SQLException ex
          The SQLException that the driver will throw to the application when an error occurs and the pooled connection is no longer usable.

    • Class javax.sql.RowSetEvent extends EventObject implements Serializable

      serialVersionUID:
      -1875450876546332005L

    • Class javax.sql.StatementEvent extends EventObject implements Serializable

      serialVersionUID:
      -8089573731826608315L

      • Serialized Fields

        • exception

          SQLException exception

        • statement

          PreparedStatement statement

  • Package javax.sql.rowset

    • Class javax.sql.rowset.BaseRowSet extends Object implements Serializable

      serialVersionUID:
      4886719666485113312L

      • Serialized Fields

        • binaryStream

          InputStream binaryStream
          The InputStream object that will be returned by the method getBinaryStream, which is specified in the ResultSet interface.

        • unicodeStream

          InputStream unicodeStream
          The InputStream object that will be returned by the method getUnicodeStream, which is specified in the ResultSet interface.

        • asciiStream

          InputStream asciiStream
          The InputStream object that will be returned by the method getAsciiStream, which is specified in the ResultSet interface.

        • charStream

          Reader charStream
          The Reader object that will be returned by the method getCharacterStream, which is specified in the ResultSet interface.

        • command

          String command
          The query that will be sent to the DBMS for execution when the method execute is called.

        • URL

          String URL
          The JDBC URL the reader, writer, or both supply to the method DriverManager.getConnection when the DriverManager is used to get a connection.

          The JDBC URL identifies the driver to be used to make the conndection. This URL can be found in the documentation supplied by the driver vendor.

        • dataSource

          String dataSource
          The logical name of the data source that the reader/writer should use in order to retrieve a DataSource object from a Java Directory and Naming Interface (JNDI) naming service.

        • rowSetType

          int rowSetType
          A constant indicating the type of this JDBC RowSet object. It must be one of the following ResultSet constants: TYPE_FORWARD_ONLY, TYPE_SCROLL_INSENSITIVE, or TYPE_SCROLL_SENSITIVE.

        • showDeleted

          boolean showDeleted
          A boolean indicating whether deleted rows are visible in this JDBC RowSet object .

        • queryTimeout

          int queryTimeout
          The maximum number of seconds the driver will wait for a command to execute. This limit applies while this JDBC RowSet object is connected to its data source, that is, while it is populating itself with data and while it is writing data back to the data source.

        • maxRows

          int maxRows
          The maximum number of rows the reader should read.

        • maxFieldSize

          int maxFieldSize
          The maximum field size the reader should read.

        • concurrency

          int concurrency
          A constant indicating the concurrency of this JDBC RowSet object. It must be one of the following ResultSet constants: CONCUR_READ_ONLY or CONCUR_UPDATABLE.

        • readOnly

          boolean readOnly
          A boolean indicating whether this JDBC RowSet object is read-only. true indicates that it is read-only; false that it is writable.

        • escapeProcessing

          boolean escapeProcessing
          A boolean indicating whether the reader for this JDBC RowSet object should perform escape processing. true means that escape processing is turned on; false that it is not. The default is true.

        • isolation

          int isolation
          A constant indicating the isolation level of the connection for this JDBC RowSet object . It must be one of the following Connection constants: TRANSACTION_NONE, TRANSACTION_READ_UNCOMMITTED, TRANSACTION_READ_COMMITTED, TRANSACTION_REPEATABLE_READ or TRANSACTION_SERIALIZABLE.

        • fetchDir

          int fetchDir
          A constant used as a hint to the driver that indicates the direction in which data from this JDBC RowSet object is going to be fetched. The following ResultSet constants are possible values: FETCH_FORWARD, FETCH_REVERSE, FETCH_UNKNOWN.

          Unused at this time.

        • fetchSize

          int fetchSize
          A hint to the driver that indicates the expected number of rows in this JDBC RowSet object .

          Unused at this time.

        • map

          Map<K,V> map
          The java.util.Map object that contains entries mapping SQL type names to classes in the Java programming language for the custom mapping of user-defined types.

        • listeners

          Vector<E> listeners
          A Vector object that holds the list of listeners that have registered with this RowSet object.

        • params

          Hashtable<K,V> params
          A Vector object that holds the parameters set for this RowSet object's current command.

    • Class javax.sql.rowset.RowSetMetaDataImpl extends Object implements Serializable

      serialVersionUID:
      6893806403181801867L

      • Serialized Fields

        • colCount

          int colCount
          The number of columns in the RowSet object that created this RowSetMetaDataImpl object.

        • colInfo

          javax.sql.rowset.RowSetMetaDataImpl.ColInfo[] colInfo
          An array of ColInfo objects used to store information about each column in the RowSet object for which this RowSetMetaDataImpl object was created. The first ColInfo object in this array contains information about the first column in the RowSet object, the second element contains information about the second column, and so on.

    • Class javax.sql.rowset.RowSetWarning extends SQLException implements Serializable

      serialVersionUID:
      6678332766434564774L

      • Serialized Fields

        • rwarning

          RowSetWarning rwarning
          RowSetWarning object handle.

  • Package javax.sql.rowset.serial

    • Class javax.sql.rowset.serial.SerialArray extends Object implements Serializable

      serialVersionUID:
      -8466174297270688520L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          readObject is called to restore the state of the SerialArray from a stream.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException,
                         ClassNotFoundException
          writeObject is called to save the state of the SerialArray to a stream.
          Throws:
          IOException
          ClassNotFoundException

      • Serialized Fields

        • elements

          Object[] elements
          A serialized array in which each element is an Object in the Java programming language that represents an element in the SQL ARRAY value.

        • baseType

          int baseType
          The SQL type of the elements in this SerialArray object. The type is expressed as one of the constants from the class java.sql.Types.

        • baseTypeName

          String baseTypeName
          The type name used by the DBMS for the elements in the SQL ARRAY value that this SerialArray object represents.

        • len

          int len
          The number of elements in this SerialArray object, which is also the number of elements in the SQL ARRAY value that this SerialArray object represents.

    • Class javax.sql.rowset.serial.SerialBlob extends Object implements Serializable

      serialVersionUID:
      -8144641928112860441L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          readObject is called to restore the state of the SerialBlob from a stream.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException,
                         ClassNotFoundException
          writeObject is called to save the state of the SerialBlob to a stream.
          Throws:
          IOException
          ClassNotFoundException

      • Serialized Fields

        • buf

          byte[] buf
          A serialized array of uninterpreted bytes representing the value of this SerialBlob object.

        • blob

          Blob blob
          The internal representation of the Blob object on which this SerialBlob object is based.

        • len

          long len
          The number of bytes in this SerialBlob object's array of bytes.

        • origLen

          long origLen
          The original number of bytes in this SerialBlob object's array of bytes when it was first established.

    • Class javax.sql.rowset.serial.SerialClob extends Object implements Serializable

      serialVersionUID:
      -1662519690087375313L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          readObject is called to restore the state of the SerialClob from a stream.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException,
                         ClassNotFoundException
          writeObject is called to save the state of the SerialClob to a stream.
          Throws:
          IOException
          ClassNotFoundException

      • Serialized Fields

        • buf

          char[] buf
          A serialized array of characters containing the data of the SQL CLOB value that this SerialClob object represents.

        • clob

          Clob clob
          Internal Clob representation if SerialClob is initialized with a Clob. Null if SerialClob is initialized with a char[].

        • len

          long len
          The length in characters of this SerialClob object's internal array of characters.

        • origLen

          long origLen
          The original length in characters of this SerialClob object's internal array of characters.

    • Class javax.sql.rowset.serial.SerialDatalink extends Object implements Serializable

      serialVersionUID:
      2826907821828733626L

      • Serialized Fields

        • url

          URL url
          The extracted URL field retrieved from the DATALINK field.

        • baseType

          int baseType
          The SQL type of the elements in this SerialDatalink object. The type is expressed as one of the contants from the class java.sql.Types.

        • baseTypeName

          String baseTypeName
          The type name used by the DBMS for the elements in the SQL DATALINK value that this SerialDatalink object represents.

    • Class javax.sql.rowset.serial.SerialException extends SQLException implements Serializable

      serialVersionUID:
      -489794565168592690L

    • Class javax.sql.rowset.serial.SerialJavaObject extends Object implements Serializable

      serialVersionUID:
      -1465795139032831023L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          readObject is called to restore the state of the SerialJavaObject from a stream.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          writeObject is called to save the state of the SerialJavaObject to a stream.
          Throws:
          IOException

      • Serialized Fields

        • obj

          Object obj
          Placeholder for object to be serialized.

        • chain

          Vector<E> chain
          A container for the warnings issued on this SerialJavaObject object. When there are multiple warnings, each warning is chained to the previous warning.

    • Class javax.sql.rowset.serial.SerialRef extends Object implements Serializable

      serialVersionUID:
      -4727123500609662274L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          readObject is called to restore the state of the SerialRef from a stream.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException,
                         ClassNotFoundException
          writeObject is called to save the state of the SerialRef to a stream.
          Throws:
          IOException
          ClassNotFoundException

      • Serialized Fields

        • baseTypeName

          String baseTypeName
          String containing the base type name.

        • object

          Object object
          This will store the type Ref as an Object.

        • reference

          Ref reference
          Private copy of the Ref reference.

    • Class javax.sql.rowset.serial.SerialStruct extends Object implements Serializable

      serialVersionUID:
      -8322445504027483372L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
          readObject is called to restore the state of the SerialStruct from a stream.
          Throws:
          IOException
          ClassNotFoundException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException,
                         ClassNotFoundException
          writeObject is called to save the state of the SerialStruct to a stream.
          Throws:
          IOException
          ClassNotFoundException

      • Serialized Fields

        • SQLTypeName

          String SQLTypeName
          The SQL type name for the structured type that this SerialStruct object represents. This is the name used in the SQL definition of the SQL structured type.

        • attribs

          Object[] attribs
          An array of Object instances in which each element is an attribute of the SQL structured type that this SerialStruct object represents. The attributes are ordered according to their order in the definition of the SQL structured type.

  • Package javax.sql.rowset.spi

    • Class javax.sql.rowset.spi.SyncFactoryException extends SQLException implements Serializable

      serialVersionUID:
      -4354595476433200352L

    • Class javax.sql.rowset.spi.SyncProviderException extends SQLException implements Serializable

      serialVersionUID:
      -939908523620640692L

      • Serialized Fields

        • syncResolver

          SyncResolver syncResolver
          The instance of javax.sql.rowset.spi.SyncResolver that this SyncProviderException object will return when its getSyncResolver method is called.

  • Package javax.transaction

    • Class javax.transaction.InvalidTransactionException extends RemoteException implements Serializable

    • Class javax.transaction.TransactionRequiredException extends RemoteException implements Serializable

    • Class javax.transaction.TransactionRolledbackException extends RemoteException implements Serializable

  • Package javax.transaction.xa

    • Class javax.transaction.xa.XAException extends Exception implements Serializable

      • Serialized Fields

        • errorCode

          int errorCode
          The error code with which to create the SystemException.
          The error code for the exception

  • Package javax.xml.bind

    • Class javax.xml.bind.DataBindingException extends RuntimeException implements Serializable

    • Class javax.xml.bind.JAXBElement extends Object implements Serializable

      serialVersionUID:
      1L

      • Serialized Fields

        • name

          QName name
          xml element tag name

        • declaredType

          Class<T> declaredType
          Java datatype binding for xml element declaration's type.

        • scope

          Class<T> scope
          Scope of xml element declaration representing this xml element instance. Can be one of the following values: - JAXBElement.GlobalScope for global xml element declaration. - local element declaration has a scope set to the Java class representation of complex type defintion containing xml element declaration.

        • value

          Object value
          xml element value. Represents content model and attributes of an xml element instance.

        • nil

          boolean nil
          true iff the xml element instance has xsi:nil="true".

    • Class javax.xml.bind.JAXBException extends Exception implements Serializable

      serialVersionUID:
      -5621384651494307979L

      • Serialized Fields

        • errorCode

          String errorCode
          Vendor specific error code

        • linkedException

          Throwable linkedException
          Exception reference

    • Class javax.xml.bind.JAXBPermission extends BasicPermission implements Serializable

      serialVersionUID:
      1L

    • Class javax.xml.bind.MarshalException extends JAXBException implements Serializable

    • Class javax.xml.bind.PropertyException extends JAXBException implements Serializable

    • Class javax.xml.bind.TypeConstraintException extends RuntimeException implements Serializable

      serialVersionUID:
      -3059799699420143848L

      • Serialized Fields

        • errorCode

          String errorCode
          Vendor specific error code

        • linkedException

          Throwable linkedException
          Exception reference

    • Class javax.xml.bind.UnmarshalException extends JAXBException implements Serializable

    • Class javax.xml.bind.ValidationException extends JAXBException implements Serializable

  • Package javax.xml.crypto

    • Class javax.xml.crypto.KeySelectorException extends Exception implements Serializable

      serialVersionUID:
      -7480033639322531109L

      • Serialized Fields

        • cause

          Throwable cause
          The throwable that caused this exception to get thrown, or null if this exception was not caused by another throwable or if the causative throwable is unknown.

    • Class javax.xml.crypto.MarshalException extends Exception implements Serializable

      serialVersionUID:
      -863185580332643547L

      • Serialized Fields

        • cause

          Throwable cause
          The throwable that caused this exception to get thrown, or null if this exception was not caused by another throwable or if the causative throwable is unknown.

    • Class javax.xml.crypto.NoSuchMechanismException extends RuntimeException implements Serializable

      serialVersionUID:
      4189669069570660166L

      • Serialized Fields

        • cause

          Throwable cause
          The throwable that caused this exception to get thrown, or null if this exception was not caused by another throwable or if the causative throwable is unknown.

    • Class javax.xml.crypto.URIReferenceException extends Exception implements Serializable

      serialVersionUID:
      7173469703932561419L

      • Serialized Fields

        • cause

          Throwable cause
          The throwable that caused this exception to get thrown, or null if this exception was not caused by another throwable or if the causative throwable is unknown.

        • uriReference

          URIReference uriReference

  • Package javax.xml.crypto.dsig

    • Class javax.xml.crypto.dsig.TransformException extends Exception implements Serializable

      serialVersionUID:
      5082634801360427800L

      • Serialized Fields

        • cause

          Throwable cause
          The throwable that caused this exception to get thrown, or null if this exception was not caused by another throwable or if the causative throwable is unknown.

    • Class javax.xml.crypto.dsig.XMLSignatureException extends Exception implements Serializable

      serialVersionUID:
      -3438102491013869995L

      • Serialized Fields

        • cause

          Throwable cause
          The throwable that caused this exception to get thrown, or null if this exception was not caused by another throwable or if the causative throwable is unknown.

  • Package javax.xml.datatype

    • Class javax.xml.datatype.DatatypeConfigurationException extends Exception implements Serializable

  • Package javax.xml.namespace

    • Class javax.xml.namespace.QName extends Object implements Serializable

      • Serialized Fields

        • namespaceURI

          String namespaceURI

          Namespace URI of this QName.

        • localPart

          String localPart

          local part of this QName.

        • prefix

          String prefix

          prefix of this QName.

  • Package javax.xml.parsers

    • Class javax.xml.parsers.FactoryConfigurationError extends Error implements Serializable

      serialVersionUID:
      -827108682472263355L

      • Serialized Fields

        • exception

          Exception exception
          Exception that represents the error.

    • Class javax.xml.parsers.ParserConfigurationException extends Exception implements Serializable

  • Package javax.xml.soap

    • Class javax.xml.soap.SOAPException extends Exception implements Serializable

      • Serialized Fields

        • cause

          Throwable cause

  • Package javax.xml.stream

    • Class javax.xml.stream.FactoryConfigurationError extends Error implements Serializable

      serialVersionUID:
      -2994412584589975744L

      • Serialized Fields

        • nested

          Exception nested

    • Class javax.xml.stream.XMLStreamException extends Exception implements Serializable

      • Serialized Fields

        • nested

          Throwable nested

        • location

          Location location

  • Package javax.xml.transform

    • Class javax.xml.transform.TransformerConfigurationException extends TransformerException implements Serializable

    • Class javax.xml.transform.TransformerException extends Exception implements Serializable

      • Serialized Fields

        • locator

          SourceLocator locator
          Field locator specifies where the error occured

        • containedException

          Throwable containedException
          Field containedException specifies a wrapped exception. May be null.

    • Class javax.xml.transform.TransformerFactoryConfigurationError extends Error implements Serializable

      serialVersionUID:
      -6527718720676281516L

      • Serialized Fields

        • exception

          Exception exception
          Exception for the TransformerFactoryConfigurationError.

  • Package javax.xml.validation

    • Class javax.xml.validation.SchemaFactoryConfigurationError extends Error implements Serializable

      serialVersionUID:
      3531438703147750126L

  • Package javax.xml.ws

    • Class javax.xml.ws.Holder extends Object implements Serializable

      serialVersionUID:
      2623699057546497185L

      • Serialized Fields

        • value

          Object value
          The value contained in the holder.

    • Class javax.xml.ws.ProtocolException extends WebServiceException implements Serializable

    • Class javax.xml.ws.WebServiceException extends RuntimeException implements Serializable

    • Class javax.xml.ws.WebServicePermission extends BasicPermission implements Serializable

      serialVersionUID:
      -146474640053770988L

  • Package javax.xml.ws.http

    • Class javax.xml.ws.http.HTTPException extends ProtocolException implements Serializable

      • Serialized Fields

        • statusCode

          int statusCode

  • Package javax.xml.ws.soap

    • Class javax.xml.ws.soap.SOAPFaultException extends ProtocolException implements Serializable

      • Serialized Fields

        • fault

          SOAPFault fault

  • Package javax.xml.xpath

    • Class javax.xml.xpath.XPathException extends Exception implements Serializable

      serialVersionUID:
      -1837080260374986980L

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
          Reads the "cause" field from the stream. And initializes the "cause" if it wasn't done before.
          Throws:
          IOException - thrown by ObjectInputStream
          ClassNotFoundException - thrown by ObjectInputStream

        • writeObject

          private void writeObject(ObjectOutputStream out)
                  throws IOException
          Writes "cause" field to the stream. The cause is got from the parent class.
          Throws:
          IOException - thrown by ObjectOutputStream

    • Class javax.xml.xpath.XPathExpressionException extends XPathException implements Serializable

      serialVersionUID:
      -1837080260374986980L

    • Class javax.xml.xpath.XPathFactoryConfigurationException extends XPathException implements Serializable

      serialVersionUID:
      -1837080260374986980L

    • Class javax.xml.xpath.XPathFunctionException extends XPathExpressionException implements Serializable

      serialVersionUID:
      -1837080260374986980L

  • Package org.ietf.jgss

    • Class org.ietf.jgss.GSSException extends Exception implements Serializable

      serialVersionUID:
      -2706218945227726672L

      • Serialized Fields

        • major

          int major
          The major code for this exception

        • minor

          int minor
          The minor code for this exception

        • minorMessage

          String minorMessage
          The text string for minor code

        • majorString

          String majorString
          Alternate text string for major code

  • Package org.omg.CosNaming

    • Class org.omg.CosNaming._BindingIteratorImplBase extends DynamicImplementation implements Serializable

    • Class org.omg.CosNaming._BindingIteratorStub extends ObjectImpl implements Serializable

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException
          Throws:
          IOException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Throws:
          IOException

    • Class org.omg.CosNaming._NamingContextExtStub extends ObjectImpl implements Serializable

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException
          Throws:
          IOException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Throws:
          IOException

    • Class org.omg.CosNaming._NamingContextImplBase extends DynamicImplementation implements Serializable

    • Class org.omg.CosNaming._NamingContextStub extends ObjectImpl implements Serializable

      • Serialization Methods

        • readObject

          private void readObject(ObjectInputStream s)
                 throws IOException
          Throws:
          IOException

        • writeObject

          private void writeObject(ObjectOutputStream s)
                  throws IOException
          Throws:
          IOException

    • Class org.omg.CosNaming.Binding extends Object implements Serializable

      • Serialized Fields

        • binding_name

          NameComponent[] binding_name

        • binding_type

          BindingType binding_type

    • Class org.omg.CosNaming.BindingType extends Object implements Serializable

      • Serialized Fields

        • __value

          int __value

    • Class org.omg.CosNaming.NameComponent extends Object implements Serializable

      • Serialized Fields

        • id

          String id

        • kind

          String kind

  • Package org.w3c.dom

    • Class org.w3c.dom.DOMException extends RuntimeException implements Serializable

      serialVersionUID:
      6627732366795969916L

      • Serialized Fields

        • code

          short code

  • Package org.w3c.dom.events

    • Class org.w3c.dom.events.EventException extends RuntimeException implements Serializable

      • Serialized Fields

        • code

          short code

  • Package org.w3c.dom.ls

    • Class org.w3c.dom.ls.LSException extends RuntimeException implements Serializable

      • Serialized Fields

        • code

          short code

  • Package org.xml.sax

    • Class org.xml.sax.SAXException extends Exception implements Serializable

      serialVersionUID:
      583241635256073760L

      • Serialized Fields

        • exception

          Exception exception
          The embedded exception if tunnelling, or null.

    • Class org.xml.sax.SAXNotRecognizedException extends SAXException implements Serializable

      serialVersionUID:
      5440506620509557213L

    • Class org.xml.sax.SAXNotSupportedException extends SAXException implements Serializable

      serialVersionUID:
      -1422818934641823846L

    • Class org.xml.sax.SAXParseException extends SAXException implements Serializable

      serialVersionUID:
      -5651165872476709336L

      • Serialized Fields

        • publicId

          String publicId
          The public identifier, or null.
          See Also:
          SAXParseException.getPublicId()

        • systemId

          String systemId
          The system identifier, or null.
          See Also:
          SAXParseException.getSystemId()

        • lineNumber

          int lineNumber
          The line number, or -1.
          See Also:
          SAXParseException.getLineNumber()

        • columnNumber

          int columnNumber
          The column number, or -1.
          See Also:
          SAXParseException.getColumnNumber()
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev
  • Next
  • Frames
  • No Frames


A-Index (Java Platform SE 8 )

Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames
  • All Classes
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

A

a - Variable in class java.awt.AWTEventMulticaster
A - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for Engineering A, 8 1/2 x 11 in.
A - Static variable in class javax.print.attribute.standard.MediaSize.Engineering
Specifies the engineering A size, 8.5 inch by 11 inch.
A - Static variable in class javax.print.attribute.standard.MediaSizeName
A size .
A - Static variable in class javax.swing.text.html.HTML.Tag
A0 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_A0.
A0 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO A0 size, 841 mm by 1189 mm.
A1 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_A1.
A1 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO A1 size, 594 mm by 841 mm.
A10 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_A10.
A10 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO A10 size, 26 mm by 37 mm.
A2 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_A2.
A2 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO A2 size, 420 mm by 594 mm.
A3 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_A3.
A3 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO A3 size, 297 mm by 420 mm.
A4 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_A4.
A4 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO A4 size, 210 mm by 297 mm.
A5 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_A5.
A5 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO A5 size, 148 mm by 210 mm.
A6 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_A6.
A6 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO A6 size, 105 mm by 148 mm.
A7 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_A7.
A7 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO A7 size, 74 mm by 105 mm.
A8 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_A8.
A8 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO A8 size, 52 mm by 74 mm.
A9 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_A9.
A9 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO A9 size, 37 mm by 52 mm.
ABORT - Static variable in interface java.awt.image.ImageObserver
This flag in the infoflags argument to imageUpdate indicates that an image which was being tracked asynchronously was aborted before production was complete.
abort() - Method in class java.net.CacheRequest
Aborts the attempt to cache the response.
abort(Executor) - Method in interface java.sql.Connection
Terminates an open connection.
abort() - Method in class javax.imageio.ImageReader
Requests that any current read operation be aborted.
abort() - Method in class javax.imageio.ImageWriter
Requests that any current write operation be aborted.
abort() - Method in interface javax.security.auth.spi.LoginModule
Method to abort the authentication process (phase 2).
abort() - Method in interface org.w3c.dom.ls.LSParser
Abort the loading of the document that is currently being loaded by the LSParser.
ABORTED - Static variable in class java.awt.MediaTracker
Flag indicating that the downloading of media was aborted.
ABORTED - Static variable in class javax.print.attribute.standard.JobState
The job has been aborted by the system (usually while the job was in the PROCESSING or PROCESSING_STOPPED state), the printer has completed aborting the job, and all job status attributes have reached their final values for the job.
ABORTED_BY_SYSTEM - Static variable in class javax.print.attribute.standard.JobStateReason
The job was aborted by the system.
abortGrabbing() - Method in class java.awt.image.PixelGrabber
Request the PixelGrabber to abort the image fetch.
AbortPolicy() - Constructor for class java.util.concurrent.ThreadPoolExecutor.AbortPolicy
Creates an AbortPolicy.
abortRequested() - Method in class javax.imageio.ImageReader
Returns true if a request to abort the current read operation has been made since the reader was instantiated or clearAbortRequest was called.
abortRequested() - Method in class javax.imageio.ImageWriter
Returns true if a request to abort the current write operation has been made since the writer was instantiated or clearAbortRequest was called.
ABOUT_UIROLE - Static variable in class javax.print.ServiceUIFactory
Denotes a UI which performs an informative "About" role.
ABOVE_BASELINE - Static variable in class java.awt.GridBagConstraints
Possible value for the anchor field.
ABOVE_BASELINE_LEADING - Static variable in class java.awt.GridBagConstraints
Possible value for the anchor field.
ABOVE_BASELINE_TRAILING - Static variable in class java.awt.GridBagConstraints
Possible value for the anchor field.
ABOVE_BOTTOM - Static variable in class javax.swing.border.TitledBorder
Position the title above the border's bottom line.
ABOVE_TOP - Static variable in class javax.swing.border.TitledBorder
Position the title above the border's top line.
abs(int) - Static method in class java.lang.Math
Returns the absolute value of an int value.
abs(long) - Static method in class java.lang.Math
Returns the absolute value of a long value.
abs(float) - Static method in class java.lang.Math
Returns the absolute value of a float value.
abs(double) - Static method in class java.lang.Math
Returns the absolute value of a double value.
abs(int) - Static method in class java.lang.StrictMath
Returns the absolute value of an int value.
abs(long) - Static method in class java.lang.StrictMath
Returns the absolute value of a long value.
abs(float) - Static method in class java.lang.StrictMath
Returns the absolute value of a float value.
abs(double) - Static method in class java.lang.StrictMath
Returns the absolute value of a double value.
abs() - Method in class java.math.BigDecimal
Returns a BigDecimal whose value is the absolute value of this BigDecimal, and whose scale is this.scale().
abs(MathContext) - Method in class java.math.BigDecimal
Returns a BigDecimal whose value is the absolute value of this BigDecimal, with rounding according to the context settings.
abs() - Method in class java.math.BigInteger
Returns a BigInteger whose value is the absolute value of this BigInteger.
abs() - Method in class java.time.Duration
Returns a copy of this duration with a positive length.
absolute(int) - Method in interface java.sql.ResultSet
Moves the cursor to the given row number in this ResultSet object.
absolutePath() - Method in class java.util.prefs.AbstractPreferences
Implements the absolutePath method as per the specification in Preferences.absolutePath().
absolutePath() - Method in class java.util.prefs.Preferences
Returns this preference node's absolute path name.
ABSTRACT - Static variable in class java.lang.reflect.Modifier
The int value representing the abstract modifier.
AbstractAction - Class in javax.swing
This class provides default implementations for the JFC Action interface.
AbstractAction() - Constructor for class javax.swing.AbstractAction
Creates an Action.
AbstractAction(String) - Constructor for class javax.swing.AbstractAction
Creates an Action with the specified name.
AbstractAction(String, Icon) - Constructor for class javax.swing.AbstractAction
Creates an Action with the specified name and small icon.
AbstractAnnotationValueVisitor6<R,P> - Class in javax.lang.model.util
A skeletal visitor for annotation values with default behavior appropriate for the RELEASE_6 source version.
AbstractAnnotationValueVisitor6() - Constructor for class javax.lang.model.util.AbstractAnnotationValueVisitor6
Constructor for concrete subclasses to call.
AbstractAnnotationValueVisitor7<R,P> - Class in javax.lang.model.util
A skeletal visitor for annotation values with default behavior appropriate for the RELEASE_7 source version.
AbstractAnnotationValueVisitor7() - Constructor for class javax.lang.model.util.AbstractAnnotationValueVisitor7
Constructor for concrete subclasses to call.
AbstractAnnotationValueVisitor8<R,P> - Class in javax.lang.model.util
A skeletal visitor for annotation values with default behavior appropriate for the RELEASE_8 source version.
AbstractAnnotationValueVisitor8() - Constructor for class javax.lang.model.util.AbstractAnnotationValueVisitor8
Constructor for concrete subclasses to call.
AbstractBorder - Class in javax.swing.border
A class that implements an empty border with no size.
AbstractBorder() - Constructor for class javax.swing.border.AbstractBorder
AbstractButton - Class in javax.swing
Defines common behaviors for buttons and menu items.
AbstractButton() - Constructor for class javax.swing.AbstractButton
AbstractButton.AccessibleAbstractButton - Class in javax.swing
This class implements accessibility support for the AbstractButton class.
AbstractButton.ButtonChangeListener - Class in javax.swing
Extends ChangeListener to be serializable.
AbstractCellEditor - Class in javax.swing
A base class for CellEditors, providing default implementations for the methods in the CellEditor interface except getCellEditorValue().
AbstractCellEditor() - Constructor for class javax.swing.AbstractCellEditor
AbstractChronology - Class in java.time.chrono
An abstract implementation of a calendar system, used to organize and identify dates.
AbstractChronology() - Constructor for class java.time.chrono.AbstractChronology
Creates an instance.
AbstractCollection<E> - Class in java.util
This class provides a skeletal implementation of the Collection interface, to minimize the effort required to implement this interface.
AbstractCollection() - Constructor for class java.util.AbstractCollection
Sole constructor.
AbstractColorChooserPanel - Class in javax.swing.colorchooser
This is the abstract superclass for color choosers.
AbstractColorChooserPanel() - Constructor for class javax.swing.colorchooser.AbstractColorChooserPanel
AbstractDocument - Class in javax.swing.text
An implementation of the document interface to serve as a basis for implementing various kinds of documents.
AbstractDocument(AbstractDocument.Content) - Constructor for class javax.swing.text.AbstractDocument
Constructs a new AbstractDocument, wrapped around some specified content storage mechanism.
AbstractDocument(AbstractDocument.Content, AbstractDocument.AttributeContext) - Constructor for class javax.swing.text.AbstractDocument
Constructs a new AbstractDocument, wrapped around some specified content storage mechanism.
AbstractDocument.AbstractElement - Class in javax.swing.text
Implements the abstract part of an element.
AbstractDocument.AttributeContext - Interface in javax.swing.text
An interface that can be used to allow MutableAttributeSet implementations to use pluggable attribute compression techniques.
AbstractDocument.BranchElement - Class in javax.swing.text
Implements a composite element that contains other elements.
AbstractDocument.Content - Interface in javax.swing.text
Interface to describe a sequence of character content that can be edited.
AbstractDocument.DefaultDocumentEvent - Class in javax.swing.text
Stores document changes as the document is being modified.
AbstractDocument.ElementEdit - Class in javax.swing.text
An implementation of ElementChange that can be added to the document event.
AbstractDocument.LeafElement - Class in javax.swing.text
Implements an element that directly represents content of some kind.
AbstractDoubleSpliterator(long, int) - Constructor for class java.util.Spliterators.AbstractDoubleSpliterator
Creates a spliterator reporting the given estimated size and characteristics.
AbstractElement(Element, AttributeSet) - Constructor for class javax.swing.text.AbstractDocument.AbstractElement
Creates a new AbstractElement.
AbstractElementVisitor6<R,P> - Class in javax.lang.model.util
A skeletal visitor of program elements with default behavior appropriate for the RELEASE_6 source version.
AbstractElementVisitor6() - Constructor for class javax.lang.model.util.AbstractElementVisitor6
Constructor for concrete subclasses to call.
AbstractElementVisitor7<R,P> - Class in javax.lang.model.util
A skeletal visitor of program elements with default behavior appropriate for the RELEASE_7 source version.
AbstractElementVisitor7() - Constructor for class javax.lang.model.util.AbstractElementVisitor7
Constructor for concrete subclasses to call.
AbstractElementVisitor8<R,P> - Class in javax.lang.model.util
A skeletal visitor of program elements with default behavior appropriate for the RELEASE_8 source version.
AbstractElementVisitor8() - Constructor for class javax.lang.model.util.AbstractElementVisitor8
Constructor for concrete subclasses to call.
AbstractExecutorService - Class in java.util.concurrent
Provides default implementations of ExecutorService execution methods.
AbstractExecutorService() - Constructor for class java.util.concurrent.AbstractExecutorService
AbstractFormatter() - Constructor for class javax.swing.JFormattedTextField.AbstractFormatter
AbstractFormatterFactory() - Constructor for class javax.swing.JFormattedTextField.AbstractFormatterFactory
AbstractInterruptibleChannel - Class in java.nio.channels.spi
Base implementation class for interruptible channels.
AbstractInterruptibleChannel() - Constructor for class java.nio.channels.spi.AbstractInterruptibleChannel
Initializes a new instance of this class.
AbstractIntSpliterator(long, int) - Constructor for class java.util.Spliterators.AbstractIntSpliterator
Creates a spliterator reporting the given estimated size and characteristics.
AbstractLayoutCache - Class in javax.swing.tree
Warning: Serialized objects of this class will not be compatible with future Swing releases.
AbstractLayoutCache() - Constructor for class javax.swing.tree.AbstractLayoutCache
AbstractLayoutCache.NodeDimensions - Class in javax.swing.tree
Used by AbstractLayoutCache to determine the size and x origin of a particular node.
AbstractList<E> - Class in java.util
This class provides a skeletal implementation of the List interface to minimize the effort required to implement this interface backed by a "random access" data store (such as an array).
AbstractList() - Constructor for class java.util.AbstractList
Sole constructor.
AbstractListModel<E> - Class in javax.swing
The abstract definition for the data model that provides a List with its contents.
AbstractListModel() - Constructor for class javax.swing.AbstractListModel
AbstractLongSpliterator(long, int) - Constructor for class java.util.Spliterators.AbstractLongSpliterator
Creates a spliterator reporting the given estimated size and characteristics.
AbstractMap<K,V> - Class in java.util
This class provides a skeletal implementation of the Map interface, to minimize the effort required to implement this interface.
AbstractMap() - Constructor for class java.util.AbstractMap
Sole constructor.
AbstractMap.SimpleEntry<K,V> - Class in java.util
An Entry maintaining a key and a value.
AbstractMap.SimpleImmutableEntry<K,V> - Class in java.util
An Entry maintaining an immutable key and value.
AbstractMarshallerImpl - Class in javax.xml.bind.helpers
Partial default Marshaller implementation.
AbstractMarshallerImpl() - Constructor for class javax.xml.bind.helpers.AbstractMarshallerImpl
AbstractMethodError - Error in java.lang
Thrown when an application tries to call an abstract method.
AbstractMethodError() - Constructor for error java.lang.AbstractMethodError
Constructs an AbstractMethodError with no detail message.
AbstractMethodError(String) - Constructor for error java.lang.AbstractMethodError
Constructs an AbstractMethodError with the specified detail message.
AbstractOwnableSynchronizer - Class in java.util.concurrent.locks
A synchronizer that may be exclusively owned by a thread.
AbstractOwnableSynchronizer() - Constructor for class java.util.concurrent.locks.AbstractOwnableSynchronizer
Empty constructor for use by subclasses.
AbstractPreferences - Class in java.util.prefs
This class provides a skeletal implementation of the Preferences class, greatly easing the task of implementing it.
AbstractPreferences(AbstractPreferences, String) - Constructor for class java.util.prefs.AbstractPreferences
Creates a preference node with the specified parent and the specified name relative to its parent.
AbstractProcessor - Class in javax.annotation.processing
An abstract annotation processor designed to be a convenient superclass for most concrete annotation processors.
AbstractProcessor() - Constructor for class javax.annotation.processing.AbstractProcessor
Constructor for subclasses to call.
AbstractQueue<E> - Class in java.util
This class provides skeletal implementations of some Queue operations.
AbstractQueue() - Constructor for class java.util.AbstractQueue
Constructor for use by subclasses.
AbstractQueuedLongSynchronizer - Class in java.util.concurrent.locks
A version of AbstractQueuedSynchronizer in which synchronization state is maintained as a long.
AbstractQueuedLongSynchronizer() - Constructor for class java.util.concurrent.locks.AbstractQueuedLongSynchronizer
Creates a new AbstractQueuedLongSynchronizer instance with initial synchronization state of zero.
AbstractQueuedLongSynchronizer.ConditionObject - Class in java.util.concurrent.locks
Condition implementation for a AbstractQueuedLongSynchronizer serving as the basis of a Lock implementation.
AbstractQueuedSynchronizer - Class in java.util.concurrent.locks
Provides a framework for implementing blocking locks and related synchronizers (semaphores, events, etc) that rely on first-in-first-out (FIFO) wait queues.
AbstractQueuedSynchronizer() - Constructor for class java.util.concurrent.locks.AbstractQueuedSynchronizer
Creates a new AbstractQueuedSynchronizer instance with initial synchronization state of zero.
AbstractQueuedSynchronizer.ConditionObject - Class in java.util.concurrent.locks
Condition implementation for a AbstractQueuedSynchronizer serving as the basis of a Lock implementation.
AbstractRegionPainter - Class in javax.swing.plaf.nimbus
Convenient base class for defining Painter instances for rendering a region or component in Nimbus.
AbstractRegionPainter() - Constructor for class javax.swing.plaf.nimbus.AbstractRegionPainter
Create a new AbstractRegionPainter
AbstractRegionPainter.PaintContext - Class in javax.swing.plaf.nimbus
A class encapsulating state useful when painting.
AbstractRegionPainter.PaintContext.CacheMode - Enum in javax.swing.plaf.nimbus
AbstractScriptEngine - Class in javax.script
Provides a standard implementation for several of the variants of the eval method.
AbstractScriptEngine() - Constructor for class javax.script.AbstractScriptEngine
Creates a new instance of AbstractScriptEngine using a SimpleScriptContext as its default ScriptContext.
AbstractScriptEngine(Bindings) - Constructor for class javax.script.AbstractScriptEngine
Creates a new instance using the specified Bindings as the ENGINE_SCOPE Bindings in the protected context field.
AbstractSelectableChannel - Class in java.nio.channels.spi
Base implementation class for selectable channels.
AbstractSelectableChannel(SelectorProvider) - Constructor for class java.nio.channels.spi.AbstractSelectableChannel
Initializes a new instance of this class.
AbstractSelectionKey - Class in java.nio.channels.spi
Base implementation class for selection keys.
AbstractSelectionKey() - Constructor for class java.nio.channels.spi.AbstractSelectionKey
Initializes a new instance of this class.
AbstractSelector - Class in java.nio.channels.spi
Base implementation class for selectors.
AbstractSelector(SelectorProvider) - Constructor for class java.nio.channels.spi.AbstractSelector
Initializes a new instance of this class.
AbstractSequentialList<E> - Class in java.util
This class provides a skeletal implementation of the List interface to minimize the effort required to implement this interface backed by a "sequential access" data store (such as a linked list).
AbstractSequentialList() - Constructor for class java.util.AbstractSequentialList
Sole constructor.
AbstractSet<E> - Class in java.util
This class provides a skeletal implementation of the Set interface to minimize the effort required to implement this interface.
AbstractSet() - Constructor for class java.util.AbstractSet
Sole constructor.
AbstractSpinnerModel - Class in javax.swing
This class provides the ChangeListener part of the SpinnerModel interface that should be suitable for most concrete SpinnerModel implementations.
AbstractSpinnerModel() - Constructor for class javax.swing.AbstractSpinnerModel
AbstractSpliterator(long, int) - Constructor for class java.util.Spliterators.AbstractSpliterator
Creates a spliterator reporting the given estimated size and additionalCharacteristics.
AbstractTableModel - Class in javax.swing.table
This abstract class provides default implementations for most of the methods in the TableModel interface.
AbstractTableModel() - Constructor for class javax.swing.table.AbstractTableModel
AbstractTypeVisitor6<R,P> - Class in javax.lang.model.util
A skeletal visitor of types with default behavior appropriate for the RELEASE_6 source version.
AbstractTypeVisitor6() - Constructor for class javax.lang.model.util.AbstractTypeVisitor6
Constructor for concrete subclasses to call.
AbstractTypeVisitor7<R,P> - Class in javax.lang.model.util
A skeletal visitor of types with default behavior appropriate for the RELEASE_7 source version.
AbstractTypeVisitor7() - Constructor for class javax.lang.model.util.AbstractTypeVisitor7
Constructor for concrete subclasses to call.
AbstractTypeVisitor8<R,P> - Class in javax.lang.model.util
A skeletal visitor of types with default behavior appropriate for the RELEASE_8 source version.
AbstractTypeVisitor8() - Constructor for class javax.lang.model.util.AbstractTypeVisitor8
Constructor for concrete subclasses to call.
AbstractUndoableEdit - Class in javax.swing.undo
An abstract implementation of UndoableEdit, implementing simple responses to all boolean methods in that interface.
AbstractUndoableEdit() - Constructor for class javax.swing.undo.AbstractUndoableEdit
Creates an AbstractUndoableEdit which defaults hasBeenDone and alive to true.
AbstractUnmarshallerImpl - Class in javax.xml.bind.helpers
Partial default Unmarshaller implementation.
AbstractUnmarshallerImpl() - Constructor for class javax.xml.bind.helpers.AbstractUnmarshallerImpl
AbstractView - Interface in org.w3c.dom.views
A base interface that all views shall derive from.
AbstractWriter - Class in javax.swing.text
AbstractWriter is an abstract class that actually does the work of writing out the element tree including the attributes.
AbstractWriter(Writer, Document) - Constructor for class javax.swing.text.AbstractWriter
Creates a new AbstractWriter.
AbstractWriter(Writer, Document, int, int) - Constructor for class javax.swing.text.AbstractWriter
Creates a new AbstractWriter.
AbstractWriter(Writer, Element) - Constructor for class javax.swing.text.AbstractWriter
Creates a new AbstractWriter.
AbstractWriter(Writer, Element, int, int) - Constructor for class javax.swing.text.AbstractWriter
Creates a new AbstractWriter.
accelerationPriority - Variable in class java.awt.Image
Priority for accelerating this image.
ACCELERATOR_KEY - Static variable in interface javax.swing.Action
The key used for storing a KeyStroke to be used as the accelerator for the action.
acceleratorDelimiter - Variable in class javax.swing.plaf.basic.BasicMenuItemUI
Accelerator delimiter string, such as '+' in 'Ctrl+C'.
acceleratorFont - Variable in class javax.swing.plaf.basic.BasicMenuItemUI
acceleratorForeground - Variable in class javax.swing.plaf.basic.BasicMenuItemUI
acceleratorSelectionForeground - Variable in class javax.swing.plaf.basic.BasicMenuItemUI
accept(Component) - Method in class java.awt.ContainerOrderFocusTraversalPolicy
Determines whether a Component is an acceptable choice as the new focus owner.
accept(Component) - Method in class java.awt.DefaultFocusTraversalPolicy
Determines whether a Component is an acceptable choice as the new focus owner.
accept(File) - Method in interface java.io.FileFilter
Tests whether or not the specified abstract pathname should be included in a pathname list.
accept(File, String) - Method in interface java.io.FilenameFilter
Tests if a specified file should be included in a file list.
accept() - Method in class java.net.ServerSocket
Listens for a connection to be made to this socket and accepts it.
accept(SocketImpl) - Method in class java.net.SocketImpl
Accepts a connection.
accept(A, CompletionHandler<AsynchronousSocketChannel, ? super A>) - Method in class java.nio.channels.AsynchronousServerSocketChannel
Accepts a connection.
accept() - Method in class java.nio.channels.AsynchronousServerSocketChannel
Accepts a connection.
accept() - Method in class java.nio.channels.ServerSocketChannel
Accepts a connection made to this channel's socket.
accept(T) - Method in interface java.nio.file.DirectoryStream.Filter
Decides if the given directory entry should be accepted or filtered.
accept(double) - Method in class java.util.DoubleSummaryStatistics
Records another value into the summary information.
accept(T, U) - Method in interface java.util.function.BiConsumer
Performs this operation on the given arguments.
accept(T) - Method in interface java.util.function.Consumer
Performs this operation on the given argument.
accept(double) - Method in interface java.util.function.DoubleConsumer
Performs this operation on the given argument.
accept(int) - Method in interface java.util.function.IntConsumer
Performs this operation on the given argument.
accept(long) - Method in interface java.util.function.LongConsumer
Performs this operation on the given argument.
accept(T, double) - Method in interface java.util.function.ObjDoubleConsumer
Performs this operation on the given arguments.
accept(T, int) - Method in interface java.util.function.ObjIntConsumer
Performs this operation on the given arguments.
accept(T, long) - Method in interface java.util.function.ObjLongConsumer
Performs this operation on the given arguments.
accept(int) - Method in class java.util.IntSummaryStatistics
Records a new value into the summary information
accept(int) - Method in class java.util.LongSummaryStatistics
Records a new int value into the summary information.
accept(long) - Method in class java.util.LongSummaryStatistics
Records a new long value into the summary information.
accept(double) - Method in interface java.util.stream.DoubleStream.Builder
Adds an element to the stream being built.
accept(int) - Method in interface java.util.stream.IntStream.Builder
Adds an element to the stream being built.
accept(long) - Method in interface java.util.stream.LongStream.Builder
Adds an element to the stream being built.
accept(T) - Method in interface java.util.stream.Stream.Builder
Adds an element to the stream being built.
accept(AnnotationValueVisitor<R, P>, P) - Method in interface javax.lang.model.element.AnnotationValue
Applies a visitor to this value.
accept(ElementVisitor<R, P>, P) - Method in interface javax.lang.model.element.Element
Applies a visitor to this element.
accept(TypeVisitor<R, P>, P) - Method in interface javax.lang.model.type.TypeMirror
Applies a visitor to this type.
accept(File) - Method in class javax.swing.filechooser.FileFilter
Whether the given file is accepted by this filter.
accept(File) - Method in class javax.swing.filechooser.FileNameExtensionFilter
Tests the specified file, returning true if the file is accepted, false otherwise.
accept(File) - Method in class javax.swing.JFileChooser
Returns true if the file should be displayed.
accept(Component) - Method in class javax.swing.LayoutFocusTraversalPolicy
Determines whether the specified Component is an acceptable choice as the new focus owner.
accept(File) - Method in class javax.swing.plaf.basic.BasicFileChooserUI.AcceptAllFileFilter
accept(Component) - Method in class javax.swing.SortingFocusTraversalPolicy
Determines whether a Component is an acceptable choice as the new focus owner.
accept(XMLEvent) - Method in interface javax.xml.stream.EventFilter
Tests whether this event is part of this stream.
accept(XMLStreamReader) - Method in interface javax.xml.stream.StreamFilter
Tests whether the current state is part of this stream.
ACCEPT_ALL - Static variable in interface java.net.CookiePolicy
One pre-defined policy which accepts all cookies.
ACCEPT_ALL_FILE_FILTER_USED_CHANGED_PROPERTY - Static variable in class javax.swing.JFileChooser
Identifies whether a the AcceptAllFileFilter is used or not.
ACCEPT_NONE - Static variable in interface java.net.CookiePolicy
One pre-defined policy which accepts no cookies.
ACCEPT_ONLY - Static variable in interface org.ietf.jgss.GSSCredential
Credential usage flag requesting that it be usable for context acceptance only.
ACCEPT_ORIGINAL_SERVER - Static variable in interface java.net.CookiePolicy
One pre-defined policy which only accepts cookies from original server.
AcceptAllFileFilter() - Constructor for class javax.swing.plaf.basic.BasicFileChooserUI.AcceptAllFileFilter
acceptChanges() - Method in interface javax.sql.rowset.CachedRowSet
Propagates row update, insert and delete changes made to this CachedRowSet object to the underlying data source.
acceptChanges(Connection) - Method in interface javax.sql.rowset.CachedRowSet
Propagates all row update, insert and delete changes to the data source backing this CachedRowSet object using the specified Connection object to establish a connection to the data source.
acceptDrag(int) - Method in class java.awt.dnd.DropTargetContext
accept the Drag.
acceptDrag(int) - Method in class java.awt.dnd.DropTargetDragEvent
Accepts the drag.
acceptDrop(int) - Method in class java.awt.dnd.DropTargetContext
called to signal that the drop is acceptable using the specified operation.
acceptDrop(int) - Method in class java.awt.dnd.DropTargetDropEvent
accept the drop, using the specified action.
acceptEither(CompletionStage<? extends T>, Consumer<? super T>) - Method in class java.util.concurrent.CompletableFuture
acceptEither(CompletionStage<? extends T>, Consumer<? super T>) - Method in interface java.util.concurrent.CompletionStage
Returns a new CompletionStage that, when either this or the other given stage complete normally, is executed with the corresponding result as argument to the supplied action.
acceptEitherAsync(CompletionStage<? extends T>, Consumer<? super T>) - Method in class java.util.concurrent.CompletableFuture
acceptEitherAsync(CompletionStage<? extends T>, Consumer<? super T>, Executor) - Method in class java.util.concurrent.CompletableFuture
acceptEitherAsync(CompletionStage<? extends T>, Consumer<? super T>) - Method in interface java.util.concurrent.CompletionStage
Returns a new CompletionStage that, when either this or the other given stage complete normally, is executed using this stage's default asynchronous execution facility, with the corresponding result as argument to the supplied action.
acceptEitherAsync(CompletionStage<? extends T>, Consumer<? super T>, Executor) - Method in interface java.util.concurrent.CompletionStage
Returns a new CompletionStage that, when either this or the other given stage complete normally, is executed using the supplied executor, with the corresponding result as argument to the supplied function.
ACCEPTING_JOBS - Static variable in class javax.print.attribute.standard.PrinterIsAcceptingJobs
The printer is currently accepting jobs.
acceptNode(Node) - Method in interface org.w3c.dom.ls.LSParserFilter
This method will be called by the parser at the completion of the parsing of each node.
AcceptPendingException - Exception in java.nio.channels
Unchecked exception thrown when an attempt is made to initiate an accept operation on a channel and a previous accept operation has not completed.
AcceptPendingException() - Constructor for exception java.nio.channels.AcceptPendingException
Constructs an instance of this class.
acceptSecContext(byte[], int, int) - Method in interface org.ietf.jgss.GSSContext
Called by the context acceptor upon receiving a token from the peer.
acceptSecContext(InputStream, OutputStream) - Method in interface org.ietf.jgss.GSSContext
Called by the context acceptor to process a token from the peer using streams.
acceptsURL(String) - Method in interface java.sql.Driver
Retrieves whether the driver thinks that it can open a connection to the given URL.
access - Variable in class org.omg.CORBA.ValueMember
The type of access (public, private) for the value member described by this ValueMember object.
ACCESS_EXTERNAL_DTD - Static variable in class javax.xml.XMLConstants
Property: accessExternalDTD
ACCESS_EXTERNAL_SCHEMA - Static variable in class javax.xml.XMLConstants
Property: accessExternalSchema
ACCESS_EXTERNAL_STYLESHEET - Static variable in class javax.xml.XMLConstants
Property: accessExternalStylesheet
AccessControlContext - Class in java.security
An AccessControlContext is used to make system resource access decisions based on the context it encapsulates.
AccessControlContext(ProtectionDomain[]) - Constructor for class java.security.AccessControlContext
Create an AccessControlContext with the given array of ProtectionDomains.
AccessControlContext(AccessControlContext, DomainCombiner) - Constructor for class java.security.AccessControlContext
Create a new AccessControlContext with the given AccessControlContext and DomainCombiner.
AccessControlException - Exception in java.security
This exception is thrown by the AccessController to indicate that a requested access (to a critical system resource such as the file system or the network) is denied.
AccessControlException(String) - Constructor for exception java.security.AccessControlException
Constructs an AccessControlException with the specified, detailed message.
AccessControlException(String, Permission) - Constructor for exception java.security.AccessControlException
Constructs an AccessControlException with the specified, detailed message, and the requested permission that caused the exception.
AccessController - Class in java.security
The AccessController class is used for access control operations and decisions.
AccessDeniedException - Exception in java.nio.file
Checked exception thrown when a file system operation is denied, typically due to a file permission or other access check.
AccessDeniedException(String) - Constructor for exception java.nio.file.AccessDeniedException
Constructs an instance of this class.
AccessDeniedException(String, String, String) - Constructor for exception java.nio.file.AccessDeniedException
Constructs an instance of this class.
AccessException - Exception in java.rmi
An AccessException is thrown by certain methods of the java.rmi.Naming class (specifically bind, rebind, and unbind) and methods of the java.rmi.activation.ActivationSystem interface to indicate that the caller does not have permission to perform the action requested by the method call.
AccessException(String) - Constructor for exception java.rmi.AccessException
Constructs an AccessException with the specified detail message.
AccessException(String, Exception) - Constructor for exception java.rmi.AccessException
Constructs an AccessException with the specified detail message and nested exception.
Accessible - Interface in javax.accessibility
Interface Accessible is the main interface for the accessibility package.
ACCESSIBLE_ACTION_PROPERTY - Static variable in class javax.accessibility.AccessibleContext
Constant used to indicate that the supported set of actions has changed.
ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY - Static variable in class javax.accessibility.AccessibleContext
Constant used to determine when the active descendant of a component has changed.
ACCESSIBLE_CARET_PROPERTY - Static variable in class javax.accessibility.AccessibleContext
Constant used to determine when the accessibleText caret has changed.
ACCESSIBLE_CHILD_PROPERTY - Static variable in class javax.accessibility.AccessibleContext
Constant used to determine when Accessible children are added/removed from the object.
ACCESSIBLE_COMPONENT_BOUNDS_CHANGED - Static variable in class javax.accessibility.AccessibleContext
PropertyChangeEvent which indicates that a change has occurred in a component's bounds.
ACCESSIBLE_DESCRIPTION_PROPERTY - Static variable in class javax.accessibility.AccessibleContext
Constant used to determine when the accessibleDescription property has changed.
ACCESSIBLE_HYPERTEXT_OFFSET - Static variable in class javax.accessibility.AccessibleContext
Constant used to indicate that a hypertext element has received focus.
ACCESSIBLE_INVALIDATE_CHILDREN - Static variable in class javax.accessibility.AccessibleContext
PropertyChangeEvent which indicates that a significant change has occurred to the children of a component like a tree or text.
ACCESSIBLE_NAME_PROPERTY - Static variable in class javax.accessibility.AccessibleContext
Constant used to determine when the accessibleName property has changed.
ACCESSIBLE_SELECTION_PROPERTY - Static variable in class javax.accessibility.AccessibleContext
Constant used to determine when the accessibleSelection has changed.
ACCESSIBLE_STATE_PROPERTY - Static variable in class javax.accessibility.AccessibleContext
Constant used to determine when the accessibleStateSet property has changed.
ACCESSIBLE_TABLE_CAPTION_CHANGED - Static variable in class javax.accessibility.AccessibleContext
Constant used to indicate that the table caption has changed The old value in the PropertyChangeEvent will be an Accessible representing the previous table caption and the new value will be an Accessible representing the new table caption.
ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED - Static variable in class javax.accessibility.AccessibleContext
Constant used to indicate that the column description has changed The old value in the PropertyChangeEvent will be null and the new value will be an Integer representing the column index.
ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED - Static variable in class javax.accessibility.AccessibleContext
Constant used to indicate that the column header has changed The old value in the PropertyChangeEvent will be null and the new value will be an AccessibleTableModelChange representing the header change.
ACCESSIBLE_TABLE_MODEL_CHANGED - Static variable in class javax.accessibility.AccessibleContext
Constant used to indicate that table data has changed.
ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED - Static variable in class javax.accessibility.AccessibleContext
Constant used to indicate that the row description has changed The old value in the PropertyChangeEvent will be null and the new value will be an Integer representing the row index.
ACCESSIBLE_TABLE_ROW_HEADER_CHANGED - Static variable in class javax.accessibility.AccessibleContext
Constant used to indicate that the row header has changed The old value in the PropertyChangeEvent will be null and the new value will be an AccessibleTableModelChange representing the header change.
ACCESSIBLE_TABLE_SUMMARY_CHANGED - Static variable in class javax.accessibility.AccessibleContext
Constant used to indicate that the table summary has changed The old value in the PropertyChangeEvent will be an Accessible representing the previous table summary and the new value will be an Accessible representing the new table summary.
ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED - Static variable in class javax.accessibility.AccessibleContext
PropertyChangeEvent which indicates that text attributes have changed.
ACCESSIBLE_TEXT_PROPERTY - Static variable in class javax.accessibility.AccessibleContext
PropertyChangeEvent which indicates that text has changed.
ACCESSIBLE_VALUE_PROPERTY - Static variable in class javax.accessibility.AccessibleContext
Constant used to determine when the accessibleValue property has changed.
ACCESSIBLE_VISIBLE_DATA_PROPERTY - Static variable in class javax.accessibility.AccessibleContext
Constant used to determine when the visual appearance of the object has changed.
AccessibleAbstractButton() - Constructor for class javax.swing.AbstractButton.AccessibleAbstractButton
AccessibleAction - Interface in javax.accessibility
The AccessibleAction interface should be supported by any object that can perform one or more actions.
AccessibleApplet() - Constructor for class java.applet.Applet.AccessibleApplet
AccessibleAttributeSequence - Class in javax.accessibility
This class collects together the span of text that share the same contiguous set of attributes, along with that set of attributes.
AccessibleAttributeSequence(int, int, AttributeSet) - Constructor for class javax.accessibility.AccessibleAttributeSequence
Constructs an AccessibleAttributeSequence with the given parameters.
AccessibleAWTButton() - Constructor for class java.awt.Button.AccessibleAWTButton
AccessibleAWTCanvas() - Constructor for class java.awt.Canvas.AccessibleAWTCanvas
AccessibleAWTCheckbox() - Constructor for class java.awt.Checkbox.AccessibleAWTCheckbox
AccessibleAWTCheckboxMenuItem() - Constructor for class java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem
AccessibleAWTChoice() - Constructor for class java.awt.Choice.AccessibleAWTChoice
AccessibleAWTComponent() - Constructor for class java.awt.Component.AccessibleAWTComponent
Though the class is abstract, this should be called by all sub-classes.
accessibleAWTComponentHandler - Variable in class java.awt.Component.AccessibleAWTComponent
AccessibleAWTComponentHandler() - Constructor for class java.awt.Component.AccessibleAWTComponent.AccessibleAWTComponentHandler
AccessibleAWTContainer() - Constructor for class java.awt.Container.AccessibleAWTContainer
AccessibleAWTDialog() - Constructor for class java.awt.Dialog.AccessibleAWTDialog
accessibleAWTFocusHandler - Variable in class java.awt.Component.AccessibleAWTComponent
AccessibleAWTFocusHandler() - Constructor for class java.awt.Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
AccessibleAWTFrame() - Constructor for class java.awt.Frame.AccessibleAWTFrame
AccessibleAWTLabel() - Constructor for class java.awt.Label.AccessibleAWTLabel
AccessibleAWTList() - Constructor for class java.awt.List.AccessibleAWTList
AccessibleAWTListChild(List, int) - Constructor for class java.awt.List.AccessibleAWTList.AccessibleAWTListChild
AccessibleAWTMenu() - Constructor for class java.awt.Menu.AccessibleAWTMenu
AccessibleAWTMenuBar() - Constructor for class java.awt.MenuBar.AccessibleAWTMenuBar
AccessibleAWTMenuComponent() - Constructor for class java.awt.MenuComponent.AccessibleAWTMenuComponent
Although the class is abstract, this should be called by all sub-classes.
AccessibleAWTMenuItem() - Constructor for class java.awt.MenuItem.AccessibleAWTMenuItem
AccessibleAWTPanel() - Constructor for class java.awt.Panel.AccessibleAWTPanel
AccessibleAWTPopupMenu() - Constructor for class java.awt.PopupMenu.AccessibleAWTPopupMenu
AccessibleAWTScrollBar() - Constructor for class java.awt.Scrollbar.AccessibleAWTScrollBar
AccessibleAWTScrollPane() - Constructor for class java.awt.ScrollPane.AccessibleAWTScrollPane
AccessibleAWTTextArea() - Constructor for class java.awt.TextArea.AccessibleAWTTextArea
AccessibleAWTTextComponent() - Constructor for class java.awt.TextComponent.AccessibleAWTTextComponent
Constructs an AccessibleAWTTextComponent.
AccessibleAWTTextField() - Constructor for class java.awt.TextField.AccessibleAWTTextField
AccessibleAWTWindow() - Constructor for class java.awt.Window.AccessibleAWTWindow
AccessibleBox() - Constructor for class javax.swing.Box.AccessibleBox
AccessibleBoxFiller() - Constructor for class javax.swing.Box.Filler.AccessibleBoxFiller
AccessibleBundle - Class in javax.accessibility
Base class used to maintain a strongly typed enumeration.
AccessibleBundle() - Constructor for class javax.accessibility.AccessibleBundle
Construct an AccessibleBundle.
AccessibleCellRendererPane() - Constructor for class javax.swing.CellRendererPane.AccessibleCellRendererPane
AccessibleComponent - Interface in javax.accessibility
The AccessibleComponent interface should be supported by any object that is rendered on the screen.
accessibleContainerHandler - Variable in class java.awt.Container.AccessibleAWTContainer
AccessibleContainerHandler() - Constructor for class java.awt.Container.AccessibleAWTContainer.AccessibleContainerHandler
AccessibleContainerHandler() - Constructor for class javax.swing.JComponent.AccessibleJComponent.AccessibleContainerHandler
accessibleContext - Variable in class java.awt.Component
The AccessibleContext associated with this Component.
AccessibleContext - Class in javax.accessibility
AccessibleContext represents the minimum information all accessible objects return.
AccessibleContext() - Constructor for class javax.accessibility.AccessibleContext
accessibleContext - Variable in class javax.swing.CellRendererPane
accessibleContext - Variable in class javax.swing.JApplet
accessibleContext - Variable in class javax.swing.JColorChooser
accessibleContext - Variable in class javax.swing.JDialog
accessibleContext - Variable in class javax.swing.JFileChooser
accessibleContext - Variable in class javax.swing.JFrame
The accessible context property.
accessibleContext - Variable in class javax.swing.JWindow
The accessible context property.
accessibleContext - Variable in class javax.swing.ProgressMonitor
The AccessibleContext for the ProgressMonitor
accessibleDescription - Variable in class javax.accessibility.AccessibleContext
A localized String containing the description of the object.
AccessibleEditableText - Interface in javax.accessibility
The AccessibleEditableText interface should be implemented by all classes that present editable textual information on the display.
AccessibleExtendedComponent - Interface in javax.accessibility
The AccessibleExtendedComponent interface should be supported by any object that is rendered on the screen.
AccessibleExtendedTable - Interface in javax.accessibility
Class AccessibleExtendedTable provides extended information about a user-interface component that presents data in a two-dimensional table format.
AccessibleExtendedText - Interface in javax.accessibility
The AccessibleExtendedText interface contains additional methods not provided by the AccessibleText interface Applications can determine if an object supports the AccessibleExtendedText interface by first obtaining its AccessibleContext (see Accessible) and then calling the AccessibleContext.getAccessibleText() method of AccessibleContext.
accessibleFocusHandler - Variable in class javax.swing.JComponent.AccessibleJComponent
Deprecated.
AccessibleFocusHandler() - Constructor for class javax.swing.JComponent.AccessibleJComponent.AccessibleFocusHandler
AccessibleHyperlink - Class in javax.accessibility
Encapsulation of a link, or set of links (e.g.
AccessibleHyperlink() - Constructor for class javax.accessibility.AccessibleHyperlink
AccessibleHypertext - Interface in javax.accessibility
The AccessibleHypertext class is the base class for all classes that present hypertext information on the display.
AccessibleIcon - Interface in javax.accessibility
The AccessibleIcon interface should be supported by any object that has an associated icon (e.g., buttons).
AccessibleImageIcon() - Constructor for class javax.swing.ImageIcon.AccessibleImageIcon
AccessibleJApplet() - Constructor for class javax.swing.JApplet.AccessibleJApplet
AccessibleJButton() - Constructor for class javax.swing.JButton.AccessibleJButton
AccessibleJCheckBox() - Constructor for class javax.swing.JCheckBox.AccessibleJCheckBox
AccessibleJCheckBoxMenuItem() - Constructor for class javax.swing.JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem
AccessibleJColorChooser() - Constructor for class javax.swing.JColorChooser.AccessibleJColorChooser
AccessibleJComboBox() - Constructor for class javax.swing.JComboBox.AccessibleJComboBox
Returns an AccessibleJComboBox instance
AccessibleJComponent() - Constructor for class javax.swing.JComponent.AccessibleJComponent
Though the class is abstract, this should be called by all sub-classes.
AccessibleJDesktopIcon() - Constructor for class javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon
AccessibleJDesktopPane() - Constructor for class javax.swing.JDesktopPane.AccessibleJDesktopPane
AccessibleJDialog() - Constructor for class javax.swing.JDialog.AccessibleJDialog
AccessibleJEditorPane() - Constructor for class javax.swing.JEditorPane.AccessibleJEditorPane
AccessibleJEditorPaneHTML() - Constructor for class javax.swing.JEditorPane.AccessibleJEditorPaneHTML
AccessibleJFileChooser() - Constructor for class javax.swing.JFileChooser.AccessibleJFileChooser
AccessibleJFrame() - Constructor for class javax.swing.JFrame.AccessibleJFrame
AccessibleJInternalFrame() - Constructor for class javax.swing.JInternalFrame.AccessibleJInternalFrame
AccessibleJLabel() - Constructor for class javax.swing.JLabel.AccessibleJLabel
AccessibleJLayeredPane() - Constructor for class javax.swing.JLayeredPane.AccessibleJLayeredPane
AccessibleJList() - Constructor for class javax.swing.JList.AccessibleJList
AccessibleJListChild(JList<E>, int) - Constructor for class javax.swing.JList.AccessibleJList.AccessibleJListChild
AccessibleJMenu() - Constructor for class javax.swing.JMenu.AccessibleJMenu
AccessibleJMenuBar() - Constructor for class javax.swing.JMenuBar.AccessibleJMenuBar
AccessibleJOptionPane() - Constructor for class javax.swing.JOptionPane.AccessibleJOptionPane
AccessibleJPanel() - Constructor for class javax.swing.JPanel.AccessibleJPanel
AccessibleJPasswordField() - Constructor for class javax.swing.JPasswordField.AccessibleJPasswordField
AccessibleJPopupMenu() - Constructor for class javax.swing.JPopupMenu.AccessibleJPopupMenu
AccessibleJPopupMenu constructor
AccessibleJProgressBar() - Constructor for class javax.swing.JProgressBar.AccessibleJProgressBar
AccessibleJRadioButton() - Constructor for class javax.swing.JRadioButton.AccessibleJRadioButton
AccessibleJRadioButtonMenuItem() - Constructor for class javax.swing.JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem
AccessibleJRootPane() - Constructor for class javax.swing.JRootPane.AccessibleJRootPane
AccessibleJScrollBar() - Constructor for class javax.swing.JScrollBar.AccessibleJScrollBar
AccessibleJScrollPane() - Constructor for class javax.swing.JScrollPane.AccessibleJScrollPane
AccessibleJScrollPane constructor
AccessibleJSeparator() - Constructor for class javax.swing.JSeparator.AccessibleJSeparator
AccessibleJSlider() - Constructor for class javax.swing.JSlider.AccessibleJSlider
AccessibleJSpinner() - Constructor for class javax.swing.JSpinner.AccessibleJSpinner
AccessibleJSpinner constructor
AccessibleJSplitPane() - Constructor for class javax.swing.JSplitPane.AccessibleJSplitPane
AccessibleJTabbedPane() - Constructor for class javax.swing.JTabbedPane.AccessibleJTabbedPane
Constructs an AccessibleJTabbedPane
AccessibleJTable() - Constructor for class javax.swing.JTable.AccessibleJTable
AccessibleJTable constructor
AccessibleJTableCell(JTable, int, int, int) - Constructor for class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell
Constructs an AccessibleJTableHeaderEntry.
AccessibleJTableHeader() - Constructor for class javax.swing.table.JTableHeader.AccessibleJTableHeader
AccessibleJTableHeaderEntry(int, JTableHeader, JTable) - Constructor for class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
Constructs an AccessiblJTableHeaaderEntry
AccessibleJTableModelChange(int, int, int, int, int) - Constructor for class javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange
AccessibleJTextArea() - Constructor for class javax.swing.JTextArea.AccessibleJTextArea
AccessibleJTextComponent() - Constructor for class javax.swing.text.JTextComponent.AccessibleJTextComponent
Constructs an AccessibleJTextComponent.
AccessibleJTextField() - Constructor for class javax.swing.JTextField.AccessibleJTextField
AccessibleJToggleButton() - Constructor for class javax.swing.JToggleButton.AccessibleJToggleButton
AccessibleJToolBar() - Constructor for class javax.swing.JToolBar.AccessibleJToolBar
AccessibleJToolTip() - Constructor for class javax.swing.JToolTip.AccessibleJToolTip
AccessibleJTree() - Constructor for class javax.swing.JTree.AccessibleJTree
AccessibleJTreeNode(JTree, TreePath, Accessible) - Constructor for class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode
Constructs an AccessibleJTreeNode
AccessibleJViewport() - Constructor for class javax.swing.JViewport.AccessibleJViewport
AccessibleJWindow() - Constructor for class javax.swing.JWindow.AccessibleJWindow
AccessibleKeyBinding - Interface in javax.accessibility
The AccessibleKeyBinding interface should be supported by any object that has a keyboard bindings such as a keyboard mnemonic and/or keyboard shortcut which can be used to select the object.
accessibleName - Variable in class javax.accessibility.AccessibleContext
A localized String containing the name of the object.
AccessibleObject - Class in java.lang.reflect
The AccessibleObject class is the base class for Field, Method and Constructor objects.
AccessibleObject() - Constructor for class java.lang.reflect.AccessibleObject
Constructor: only used by the Java Virtual Machine.
accessibleParent - Variable in class javax.accessibility.AccessibleContext
The accessible parent of this object.
AccessibleProgressMonitor() - Constructor for class javax.swing.ProgressMonitor.AccessibleProgressMonitor
AccessibleProgressMonitor constructor
AccessibleRelation - Class in javax.accessibility
Class AccessibleRelation describes a relation between the object that implements the AccessibleRelation and one or more other objects.
AccessibleRelation(String) - Constructor for class javax.accessibility.AccessibleRelation
Create a new AccessibleRelation using the given locale independent key.
AccessibleRelation(String, Object) - Constructor for class javax.accessibility.AccessibleRelation
Creates a new AccessibleRelation using the given locale independent key.
AccessibleRelation(String, Object[]) - Constructor for class javax.accessibility.AccessibleRelation
Creates a new AccessibleRelation using the given locale independent key.
AccessibleRelationSet - Class in javax.accessibility
Class AccessibleRelationSet determines a component's relation set.
AccessibleRelationSet() - Constructor for class javax.accessibility.AccessibleRelationSet
Creates a new empty relation set.
AccessibleRelationSet(AccessibleRelation[]) - Constructor for class javax.accessibility.AccessibleRelationSet
Creates a new relation with the initial set of relations contained in the array of relations passed in.
AccessibleResourceBundle - Class in javax.accessibility
Deprecated.
This class is deprecated as of version 1.3 of the Java Platform.
AccessibleResourceBundle() - Constructor for class javax.accessibility.AccessibleResourceBundle
Deprecated.
AccessibleRole - Class in javax.accessibility
Class AccessibleRole determines the role of a component.
AccessibleRole(String) - Constructor for class javax.accessibility.AccessibleRole
Creates a new AccessibleRole using the given locale independent key.
AccessibleSelection - Interface in javax.accessibility
This AccessibleSelection interface provides the standard mechanism for an assistive technology to determine what the current selected children are, as well as modify the selection set.
AccessibleState - Class in javax.accessibility
Class AccessibleState describes a component's particular state.
AccessibleState(String) - Constructor for class javax.accessibility.AccessibleState
Creates a new AccessibleState using the given locale independent key.
AccessibleStateSet - Class in javax.accessibility
Class AccessibleStateSet determines a component's state set.
AccessibleStateSet() - Constructor for class javax.accessibility.AccessibleStateSet
Creates a new empty state set.
AccessibleStateSet(AccessibleState[]) - Constructor for class javax.accessibility.AccessibleStateSet
Creates a new state with the initial set of states contained in the array of states passed in.
AccessibleStreamable - Interface in javax.accessibility
The AccessibleStreamable interface should be implemented by the AccessibleContext of any component that presents the raw stream behind a component on the display screen.
AccessibleTable - Interface in javax.accessibility
Class AccessibleTable describes a user-interface component that presents data in a two-dimensional table format.
AccessibleTableModelChange - Interface in javax.accessibility
The AccessibleTableModelChange interface describes a change to the table model.
AccessibleText - Interface in javax.accessibility
The AccessibleText interface should be implemented by all classes that present textual information on the display.
AccessibleTextSequence - Class in javax.accessibility
This class collects together key details of a span of text.
AccessibleTextSequence(int, int, String) - Constructor for class javax.accessibility.AccessibleTextSequence
Constructs an AccessibleTextSequence with the given parameters.
AccessibleValue - Interface in javax.accessibility
The AccessibleValue interface should be supported by any object that supports a numerical value (e.g., a scroll bar).
AccessMode - Enum in java.nio.file
Defines access modes used to test the accessibility of a file.
ACCESSORY_CHANGED_PROPERTY - Static variable in class javax.swing.JFileChooser
Says that a different accessory component is in use (for example, to preview files).
AccountException - Exception in javax.security.auth.login
A generic account exception.
AccountException() - Constructor for exception javax.security.auth.login.AccountException
Constructs a AccountException with no detail message.
AccountException(String) - Constructor for exception javax.security.auth.login.AccountException
Constructs a AccountException with the specified detail message.
AccountExpiredException - Exception in javax.security.auth.login
Signals that a user account has expired.
AccountExpiredException() - Constructor for exception javax.security.auth.login.AccountExpiredException
Constructs a AccountExpiredException with no detail message.
AccountExpiredException(String) - Constructor for exception javax.security.auth.login.AccountExpiredException
Constructs a AccountExpiredException with the specified detail message.
AccountLockedException - Exception in javax.security.auth.login
Signals that an account was locked.
AccountLockedException() - Constructor for exception javax.security.auth.login.AccountLockedException
Constructs a AccountLockedException with no detail message.
AccountLockedException(String) - Constructor for exception javax.security.auth.login.AccountLockedException
Constructs a AccountLockedException with the specified detail message.
AccountNotFoundException - Exception in javax.security.auth.login
Signals that an account was not found.
AccountNotFoundException() - Constructor for exception javax.security.auth.login.AccountNotFoundException
Constructs a AccountNotFoundException with no detail message.
AccountNotFoundException(String) - Constructor for exception javax.security.auth.login.AccountNotFoundException
Constructs a AccountNotFoundException with the specified detail message.
accumulate(double) - Method in class java.util.concurrent.atomic.DoubleAccumulator
Updates with the given value.
accumulate(long) - Method in class java.util.concurrent.atomic.LongAccumulator
Updates with the given value.
accumulateAndGet(int, IntBinaryOperator) - Method in class java.util.concurrent.atomic.AtomicInteger
Atomically updates the current value with the results of applying the given function to the current and given values, returning the updated value.
accumulateAndGet(int, int, IntBinaryOperator) - Method in class java.util.concurrent.atomic.AtomicIntegerArray
Atomically updates the element at index i with the results of applying the given function to the current and given values, returning the updated value.
accumulateAndGet(T, int, IntBinaryOperator) - Method in class java.util.concurrent.atomic.AtomicIntegerFieldUpdater
Atomically updates the field of the given object managed by this updater with the results of applying the given function to the current and given values, returning the updated value.
accumulateAndGet(long, LongBinaryOperator) - Method in class java.util.concurrent.atomic.AtomicLong
Atomically updates the current value with the results of applying the given function to the current and given values, returning the updated value.
accumulateAndGet(int, long, LongBinaryOperator) - Method in class java.util.concurrent.atomic.AtomicLongArray
Atomically updates the element at index i with the results of applying the given function to the current and given values, returning the updated value.
accumulateAndGet(T, long, LongBinaryOperator) - Method in class java.util.concurrent.atomic.AtomicLongFieldUpdater
Atomically updates the field of the given object managed by this updater with the results of applying the given function to the current and given values, returning the updated value.
accumulateAndGet(V, BinaryOperator<V>) - Method in class java.util.concurrent.atomic.AtomicReference
Atomically updates the current value with the results of applying the given function to the current and given values, returning the updated value.
accumulateAndGet(int, E, BinaryOperator<E>) - Method in class java.util.concurrent.atomic.AtomicReferenceArray
Atomically updates the element at index i with the results of applying the given function to the current and given values, returning the updated value.
accumulateAndGet(T, V, BinaryOperator<V>) - Method in class java.util.concurrent.atomic.AtomicReferenceFieldUpdater
Atomically updates the field of the given object managed by this updater with the results of applying the given function to the current and given values, returning the updated value.
accumulator() - Method in interface java.util.stream.Collector
A function that folds a value into a mutable result container.
Acl - Interface in java.security.acl
Interface representing an Access Control List (ACL).
AclEntry - Class in java.nio.file.attribute
An entry in an access control list (ACL).
AclEntry - Interface in java.security.acl
This is the interface used for representing one entry in an Access Control List (ACL).
AclEntry.Builder - Class in java.nio.file.attribute
A builder of AclEntry objects.
AclEntryFlag - Enum in java.nio.file.attribute
Defines the flags for used by the flags component of an ACL entry.
AclEntryPermission - Enum in java.nio.file.attribute
Defines the permissions for use with the permissions component of an ACL entry.
AclEntryType - Enum in java.nio.file.attribute
A typesafe enumeration of the access control entry types.
AclFileAttributeView - Interface in java.nio.file.attribute
A file attribute view that supports reading or updating a file's Access Control Lists (ACL) or file owner attributes.
AclNotFoundException - Exception in java.security.acl
This is an exception that is thrown whenever a reference is made to a non-existent ACL (Access Control List).
AclNotFoundException() - Constructor for exception java.security.acl.AclNotFoundException
Constructs an AclNotFoundException.
acos(double) - Static method in class java.lang.Math
Returns the arc cosine of a value; the returned angle is in the range 0.0 through pi.
acos(double) - Static method in class java.lang.StrictMath
Returns the arc cosine of a value; the returned angle is in the range 0.0 through pi.
acquire(long) - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer
Acquires in exclusive mode, ignoring interrupts.
acquire(int) - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer
Acquires in exclusive mode, ignoring interrupts.
acquire() - Method in class java.util.concurrent.Semaphore
Acquires a permit from this semaphore, blocking until one is available, or the thread is interrupted.
acquire(int) - Method in class java.util.concurrent.Semaphore
Acquires the given number of permits from this semaphore, blocking until all are available, or the thread is interrupted.
acquiredBy() - Method in class java.nio.channels.FileLock
Returns the channel upon whose file this lock was acquired.
acquireInterruptibly(long) - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer
Acquires in exclusive mode, aborting if interrupted.
acquireInterruptibly(int) - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer
Acquires in exclusive mode, aborting if interrupted.
acquireShared(long) - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer
Acquires in shared mode, ignoring interrupts.
acquireShared(int) - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer
Acquires in shared mode, ignoring interrupts.
acquireSharedInterruptibly(long) - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer
Acquires in shared mode, aborting if interrupted.
acquireSharedInterruptibly(int) - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer
Acquires in shared mode, aborting if interrupted.
acquireUninterruptibly() - Method in class java.util.concurrent.Semaphore
Acquires a permit from this semaphore, blocking until one is available.
acquireUninterruptibly(int) - Method in class java.util.concurrent.Semaphore
Acquires the given number of permits from this semaphore, blocking until all are available.
action(Event, Object) - Method in class java.awt.Component
Deprecated.
As of JDK version 1.1, should register this component as ActionListener on component which fires action events.
ACTION - Static variable in class javax.management.MBeanOperationInfo
Indicates that the operation is write-like: it has an effect but does not return any information from the MBean.
Action - Interface in javax.swing
The Action interface provides a useful extension to the ActionListener interface in cases where the same functionality may be accessed by several controls.
ACTION - Static variable in class javax.swing.text.html.HTML.Attribute
Action - Annotation Type in javax.xml.ws
The Action annotation allows explicit association of a WS-Addressing Action message addressing property with input, output, and fault messages of the mapped WSDL operation.
ACTION_APPEND_AS_CHILDREN - Static variable in interface org.w3c.dom.ls.LSParser
Append the result of the parse operation as children of the context node.
ACTION_COMMAND_KEY - Static variable in interface javax.swing.Action
The key used to determine the command String for the ActionEvent that will be created when an Action is going to be notified as the result of residing in a Keymap associated with a JComponent.
ACTION_COPY - Static variable in class java.awt.dnd.DnDConstants
An int representing a "copy" action.
ACTION_COPY_OR_MOVE - Static variable in class java.awt.dnd.DnDConstants
An int representing a "copy" or "move" action.
ACTION_EVENT - Static variable in class java.awt.Event
This event indicates that the user wants some action to occur.
ACTION_EVENT_MASK - Static variable in class java.awt.AWTEvent
The event mask for selecting action events.
ACTION_FIRST - Static variable in class java.awt.event.ActionEvent
The first number in the range of ids used for action events.
ACTION_INFO - Static variable in class javax.management.MBeanOperationInfo
Indicates that the operation is both read-like and write-like: it has an effect, and it also returns information from the MBean.
ACTION_INSERT_AFTER - Static variable in interface org.w3c.dom.ls.LSParser
Insert the result of the parse operation as the immediately following sibling of the context node.
ACTION_INSERT_BEFORE - Static variable in interface org.w3c.dom.ls.LSParser
Insert the result of the parse operation as the immediately preceding sibling of the context node.
ACTION_LAST - Static variable in class java.awt.event.ActionEvent
The last number in the range of ids used for action events.
ACTION_LINK - Static variable in class java.awt.dnd.DnDConstants
An int representing a "link" action.
ACTION_MOVE - Static variable in class java.awt.dnd.DnDConstants
An int representing a "move" action.
ACTION_NONE - Static variable in class java.awt.dnd.DnDConstants
An int representing no action.
ACTION_PERFORMED - Static variable in class java.awt.event.ActionEvent
This event id indicates that a meaningful action occurred.
ACTION_REFERENCE - Static variable in class java.awt.dnd.DnDConstants
An int representing a "reference" action (synonym for ACTION_LINK).
ACTION_REPLACE - Static variable in interface org.w3c.dom.ls.LSParser
Replace the context node with the result of the parse operation.
ACTION_REPLACE_CHILDREN - Static variable in interface org.w3c.dom.ls.LSParser
Replace all the children of the context node with the result of the parse operation.
actionCommand - Variable in class javax.swing.DefaultButtonModel
The action command string fired by the button.
actionCommand - Variable in class javax.swing.JComboBox
This protected field is implementation specific.
ActionEvent - Class in java.awt.event
A semantic event which indicates that a component-defined action occurred.
ActionEvent(Object, int, String) - Constructor for class java.awt.event.ActionEvent
Constructs an ActionEvent object.
ActionEvent(Object, int, String, int) - Constructor for class java.awt.event.ActionEvent
Constructs an ActionEvent object with modifier keys.
ActionEvent(Object, int, String, long, int) - Constructor for class java.awt.event.ActionEvent
Constructs an ActionEvent object with the specified modifier keys and timestamp.
ActionListener - Interface in java.awt.event
The listener interface for receiving action events.
actionListener - Variable in class javax.swing.AbstractButton
The button model's ActionListener.
ActionMap - Class in javax.swing
ActionMap provides mappings from Objects (called keys or Action names) to Actions.
ActionMap() - Constructor for class javax.swing.ActionMap
Creates an ActionMap with no parent and no mappings.
ActionMapUIResource - Class in javax.swing.plaf
A subclass of javax.swing.ActionMap that implements UIResource.
ActionMapUIResource() - Constructor for class javax.swing.plaf.ActionMapUIResource
actionName - Variable in class javax.swing.text.JTextComponent.KeyBinding
The name of the action for the key.
actionPerformed(ActionEvent) - Method in class java.awt.AWTEventMulticaster
Handles the actionPerformed event by invoking the actionPerformed methods on listener-a and listener-b.
actionPerformed(ActionEvent) - Method in class java.awt.dnd.DropTarget.DropTargetAutoScroller
cause autoscroll to occur
actionPerformed(ActionEvent) - Method in interface java.awt.event.ActionListener
Invoked when an action occurs.
actionPerformed(ActionEvent) - Method in class java.awt.List.AccessibleAWTList
actionPerformed(ActionEvent) - Method in class javax.swing.DefaultCellEditor.EditorDelegate
When an action is performed, editing is ended.
actionPerformed(ActionEvent) - Method in class javax.swing.JComboBox
This method is public as an implementation side effect.
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI.CloseAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI.MaximizeAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI.MinimizeAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI.NavigateAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI.OpenAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicFileChooserUI.ApproveSelectionAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicFileChooserUI.CancelSelectionAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicFileChooserUI.ChangeToParentDirectoryAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicFileChooserUI.GoHomeAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicFileChooserUI.NewFolderAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicFileChooserUI.UpdateAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane.CloseAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane.IconifyAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane.MaximizeAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane.MoveAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane.RestoreAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane.SizeAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicOptionPaneUI.ButtonActionListener
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicScrollBarUI.ScrollListener
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicSliderUI.ActionScroller
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicSliderUI.ScrollListener
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardDownRightHandler
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardEndHandler
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardHomeHandler
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardResizeToggleHandler
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardUpLeftHandler
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.ComponentHandler
Public as a result of Timer.
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.TreeCancelEditingAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.TreeHomeAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.TreeIncrementAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.TreePageAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.TreeToggleAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.TreeTraverseAction
actionPerformed(ActionEvent) - Method in class javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxAction
actionPerformed(ActionEvent) - Method in class javax.swing.text.DefaultEditorKit.BeepAction
The operation to perform when this action is triggered.
actionPerformed(ActionEvent) - Method in class javax.swing.text.DefaultEditorKit.CopyAction
The operation to perform when this action is triggered.
actionPerformed(ActionEvent) - Method in class javax.swing.text.DefaultEditorKit.CutAction
The operation to perform when this action is triggered.
actionPerformed(ActionEvent) - Method in class javax.swing.text.DefaultEditorKit.DefaultKeyTypedAction
The operation to perform when this action is triggered.
actionPerformed(ActionEvent) - Method in class javax.swing.text.DefaultEditorKit.InsertBreakAction
The operation to perform when this action is triggered.
actionPerformed(ActionEvent) - Method in class javax.swing.text.DefaultEditorKit.InsertContentAction
The operation to perform when this action is triggered.
actionPerformed(ActionEvent) - Method in class javax.swing.text.DefaultEditorKit.InsertTabAction
The operation to perform when this action is triggered.
actionPerformed(ActionEvent) - Method in class javax.swing.text.DefaultEditorKit.PasteAction
The operation to perform when this action is triggered.
actionPerformed(ActionEvent) - Method in class javax.swing.text.html.FormView
Responsible for processing the ActionEvent.
actionPerformed(ActionEvent) - Method in class javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction
Inserts the HTML into the document.
actionPerformed(ActionEvent) - Method in class javax.swing.text.StyledEditorKit.AlignmentAction
Sets the alignment.
actionPerformed(ActionEvent) - Method in class javax.swing.text.StyledEditorKit.BoldAction
Toggles the bold attribute.
actionPerformed(ActionEvent) - Method in class javax.swing.text.StyledEditorKit.FontFamilyAction
Sets the font family.
actionPerformed(ActionEvent) - Method in class javax.swing.text.StyledEditorKit.FontSizeAction
Sets the font size.
actionPerformed(ActionEvent) - Method in class javax.swing.text.StyledEditorKit.ForegroundAction
Sets the foreground color.
actionPerformed(ActionEvent) - Method in class javax.swing.text.StyledEditorKit.ItalicAction
Toggles the italic attribute.
actionPerformed(ActionEvent) - Method in class javax.swing.text.StyledEditorKit.UnderlineAction
Toggles the Underline attribute.
actionPerformed(ActionEvent) - Method in class javax.swing.ToolTipManager.insideTimerAction
actionPerformed(ActionEvent) - Method in class javax.swing.ToolTipManager.outsideTimerAction
actionPerformed(ActionEvent) - Method in class javax.swing.ToolTipManager.stillInsideTimerAction
actionPerformed(ActionEvent) - Method in class javax.swing.tree.DefaultTreeCellEditor
Messaged when the timer fires, this will start the editing session.
actionPropertyChanged(Action, String) - Method in class javax.swing.AbstractButton
Updates the button's state in response to property changes in the associated action.
actionPropertyChanged(Action, String) - Method in class javax.swing.JComboBox
Updates the combobox's state in response to property changes in associated action.
actionPropertyChanged(Action, String) - Method in class javax.swing.JMenuItem
Updates the button's state in response to property changes in the associated action.
actionPropertyChanged(Action, String) - Method in class javax.swing.JTextField
Updates the textfield's state in response to property changes in associated action.
ActionScroller(JSlider, int, boolean) - Constructor for class javax.swing.plaf.basic.BasicSliderUI.ActionScroller
Activatable - Class in java.rmi.activation
The Activatable class provides support for remote objects that require persistent access over time and that can be activated by the system.
Activatable(String, MarshalledObject<?>, boolean, int) - Constructor for class java.rmi.activation.Activatable
Constructs an activatable remote object by registering an activation descriptor (with the specified location, data, and restart mode) for this object, and exporting the object with the specified port.
Activatable(String, MarshalledObject<?>, boolean, int, RMIClientSocketFactory, RMIServerSocketFactory) - Constructor for class java.rmi.activation.Activatable
Constructs an activatable remote object by registering an activation descriptor (with the specified location, data, and restart mode) for this object, and exporting the object with the specified port, and specified client and server socket factories.
Activatable(ActivationID, int) - Constructor for class java.rmi.activation.Activatable
Constructor used to activate/export the object on a specified port.
Activatable(ActivationID, int, RMIClientSocketFactory, RMIServerSocketFactory) - Constructor for class java.rmi.activation.Activatable
Constructor used to activate/export the object on a specified port.
activate() - Method in interface java.awt.im.spi.InputMethod
Activates the input method for immediate input processing.
activate(Applet) - Method in interface java.beans.AppletInitializer
Activate, and/or mark Applet active.
activate(boolean) - Method in class java.rmi.activation.ActivationID
Activate the object for this id.
activate(ActivationID, boolean) - Method in interface java.rmi.activation.Activator
Activate the object associated with the activation identifier, id.
activate(IIOParam) - Method in interface javax.imageio.IIOParamController
Activates the controller.
activate(IIOMetadata) - Method in interface javax.imageio.metadata.IIOMetadataController
Activates the controller.
activate() - Method in interface org.omg.PortableServer.POAManagerOperations
This operation changes the state of the POA manager to active, causing associated POAs to start processing requests.
activate_object(Servant) - Method in interface org.omg.PortableServer.POAOperations
This operation generates an Object Id and enters the Object Id and the specified servant in the Active Object Map.
activate_object_with_id(byte[], Servant) - Method in interface org.omg.PortableServer.POAOperations
This operation enters an association between the specified Object Id and the specified servant in the Active Object Map.
activateController() - Method in class javax.imageio.IIOParam
Activates the installed IIOParamController for this IIOParam object and returns the resulting value.
activateController() - Method in class javax.imageio.metadata.IIOMetadata
Activates the installed IIOMetadataController for this IIOMetadata object and returns the resulting value.
ACTIVATED - Static variable in class javax.swing.event.HyperlinkEvent.EventType
Activated type.
ActivateFailedException - Exception in java.rmi.activation
This exception is thrown by the RMI runtime when activation fails during a remote call to an activatable object.
ActivateFailedException(String) - Constructor for exception java.rmi.activation.ActivateFailedException
Constructs an ActivateFailedException with the specified detail message.
ActivateFailedException(String, Exception) - Constructor for exception java.rmi.activation.ActivateFailedException
Constructs an ActivateFailedException with the specified detail message and nested exception.
activateFrame(JInternalFrame) - Method in class javax.swing.DefaultDesktopManager
This will activate f moving it to the front.
activateFrame(JInternalFrame) - Method in interface javax.swing.DesktopManager
Generally, indicate that this frame has focus.
activateFrame(JInternalFrame) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
This method is called when the frame becomes selected.
activateLink(int, JEditorPane) - Method in class javax.swing.text.html.HTMLEditorKit.LinkController
Calls linkActivated on the associated JEditorPane if the given position represents a link.
ActivationDataFlavor - Class in javax.activation
The ActivationDataFlavor class is a special subclass of java.awt.datatransfer.DataFlavor.
ActivationDataFlavor(Class, String, String) - Constructor for class javax.activation.ActivationDataFlavor
Construct a DataFlavor that represents an arbitrary Java object.
ActivationDataFlavor(Class, String) - Constructor for class javax.activation.ActivationDataFlavor
Construct a DataFlavor that represents a MimeType.
ActivationDataFlavor(String, String) - Constructor for class javax.activation.ActivationDataFlavor
Construct a DataFlavor that represents a MimeType.
ActivationDesc - Class in java.rmi.activation
An activation descriptor contains the information necessary to activate an object: the object's group identifier, the object's fully-qualified class name, the object's code location (the location of the class), a codebase URL path, the object's restart "mode", and, a "marshalled" object that can contain object specific initialization data.
ActivationDesc(String, String, MarshalledObject<?>) - Constructor for class java.rmi.activation.ActivationDesc
Constructs an object descriptor for an object whose class name is className, that can be loaded from the code location and whose initialization information is data.
ActivationDesc(String, String, MarshalledObject<?>, boolean) - Constructor for class java.rmi.activation.ActivationDesc
Constructs an object descriptor for an object whose class name is className, that can be loaded from the code location and whose initialization information is data.
ActivationDesc(ActivationGroupID, String, String, MarshalledObject<?>) - Constructor for class java.rmi.activation.ActivationDesc
Constructs an object descriptor for an object whose class name is className that can be loaded from the code location and whose initialization information is data.
ActivationDesc(ActivationGroupID, String, String, MarshalledObject<?>, boolean) - Constructor for class java.rmi.activation.ActivationDesc
Constructs an object descriptor for an object whose class name is className that can be loaded from the code location and whose initialization information is data.
ActivationException - Exception in java.rmi.activation
General exception used by the activation interfaces.
ActivationException() - Constructor for exception java.rmi.activation.ActivationException
Constructs an ActivationException.
ActivationException(String) - Constructor for exception java.rmi.activation.ActivationException
Constructs an ActivationException with the specified detail message.
ActivationException(String, Throwable) - Constructor for exception java.rmi.activation.ActivationException
Constructs an ActivationException with the specified detail message and cause.
ActivationGroup - Class in java.rmi.activation
An ActivationGroup is responsible for creating new instances of "activatable" objects in its group, informing its ActivationMonitor when either: its object's become active or inactive, or the group as a whole becomes inactive.
ActivationGroup(ActivationGroupID) - Constructor for class java.rmi.activation.ActivationGroup
Constructs an activation group with the given activation group identifier.
ActivationGroup_Stub - Class in java.rmi.activation
ActivationGroup_Stub is a stub class for the subclasses of java.rmi.activation.ActivationGroup that are exported as a java.rmi.server.UnicastRemoteObject.
ActivationGroup_Stub(RemoteRef) - Constructor for class java.rmi.activation.ActivationGroup_Stub
Constructs a stub for the ActivationGroup class.
ActivationGroupDesc - Class in java.rmi.activation
An activation group descriptor contains the information necessary to create/recreate an activation group in which to activate objects.
ActivationGroupDesc(Properties, ActivationGroupDesc.CommandEnvironment) - Constructor for class java.rmi.activation.ActivationGroupDesc
Constructs a group descriptor that uses the system defaults for group implementation and code location.
ActivationGroupDesc(String, String, MarshalledObject<?>, Properties, ActivationGroupDesc.CommandEnvironment) - Constructor for class java.rmi.activation.ActivationGroupDesc
Specifies an alternate group implementation and execution environment to be used for the group.
ActivationGroupDesc.CommandEnvironment - Class in java.rmi.activation
Startup options for ActivationGroup implementations.
ActivationGroupID - Class in java.rmi.activation
The identifier for a registered activation group serves several purposes: identifies the group uniquely within the activation system, and contains a reference to the group's activation system so that the group can contact its activation system when necessary.
ActivationGroupID(ActivationSystem) - Constructor for class java.rmi.activation.ActivationGroupID
Constructs a unique group id.
ActivationID - Class in java.rmi.activation
Activation makes use of special identifiers to denote remote objects that can be activated over time.
ActivationID(Activator) - Constructor for class java.rmi.activation.ActivationID
The constructor for ActivationID takes a single argument, activator, that specifies a remote reference to the activator responsible for activating the object associated with this identifier.
ActivationInstantiator - Interface in java.rmi.activation
An ActivationInstantiator is responsible for creating instances of "activatable" objects.
ActivationMonitor - Interface in java.rmi.activation
An ActivationMonitor is specific to an ActivationGroup and is obtained when a group is reported active via a call to ActivationSystem.activeGroup (this is done internally).
ActivationSystem - Interface in java.rmi.activation
The ActivationSystem provides a means for registering groups and "activatable" objects to be activated within those groups.
Activator - Interface in java.rmi.activation
The Activator facilitates remote object activation.
ACTIVATOR_ID - Static variable in class java.rmi.server.ObjID
Object number for well-known ObjID of the activator.
ACTIVE - Static variable in class javax.accessibility.AccessibleState
Indicates a window is currently the active window.
active - Variable in class javax.sound.midi.VoiceStatus
Indicates whether the voice is currently processing a MIDI note.
ACTIVE - Interface in org.omg.PortableInterceptor
org/omg/PortableInterceptor/ACTIVE.java .
ACTIVE - Static variable in class org.omg.PortableServer.POAManagerPackage.State
ACTIVE_CAPTION - Static variable in class java.awt.SystemColor
The array index for the SystemColor.activeCaption system color.
ACTIVE_CAPTION_BORDER - Static variable in class java.awt.SystemColor
The array index for the SystemColor.activeCaptionBorder system color.
ACTIVE_CAPTION_TEXT - Static variable in class java.awt.SystemColor
The array index for the SystemColor.activeCaptionText system color.
ACTIVE_SENSING - Static variable in class javax.sound.midi.ShortMessage
Status byte for Active Sensing message (0xFE, or 254).
activeCaption - Static variable in class java.awt.SystemColor
The color rendered for the window-title background of the currently active window.
activeCaptionBorder - Static variable in class java.awt.SystemColor
The color rendered for the border around the currently active window.
activeCaptionText - Static variable in class java.awt.SystemColor
The color rendered for the window-title text of the currently active window.
activeCount() - Static method in class java.lang.Thread
Returns an estimate of the number of active threads in the current thread's thread group and its subgroups.
activeCount() - Method in class java.lang.ThreadGroup
Returns an estimate of the number of active threads in this thread group and its subgroups.
ActiveEvent - Interface in java.awt
An interface for events that know how to dispatch themselves.
activeGroup(ActivationGroupID, ActivationInstantiator, long) - Method in interface java.rmi.activation.ActivationSystem
Callback to inform activation system that group is now active.
activeGroupCount() - Method in class java.lang.ThreadGroup
Returns an estimate of the number of active groups in this thread group and its subgroups.
activeObject(ActivationID, Remote) - Method in class java.rmi.activation.ActivationGroup
The group's activeObject method is called when an object is exported (either by Activatable object construction or an explicit call to Activatable.exportObject.
activeObject(ActivationID, MarshalledObject<? extends Remote>) - Method in class java.rmi.activation.ActivationGroup
This protected method is necessary for subclasses to make the activeObject callback to the group's monitor.
activeObject(ActivationID, MarshalledObject<? extends Remote>) - Method in interface java.rmi.activation.ActivationMonitor
Informs that an object is now active.
ACTIVITY_COMPLETED - Exception in org.omg.CORBA
The ACTIVITY_COMPLETED system exception may be raised on any method for which Activity context is accessed.
ACTIVITY_COMPLETED() - Constructor for exception org.omg.CORBA.ACTIVITY_COMPLETED
Constructs an ACTIVITY_COMPLETED exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.
ACTIVITY_COMPLETED(String) - Constructor for exception org.omg.CORBA.ACTIVITY_COMPLETED
Constructs an ACTIVITY_COMPLETED exception with the specified message.
ACTIVITY_COMPLETED(int, CompletionStatus) - Constructor for exception org.omg.CORBA.ACTIVITY_COMPLETED
Constructs an ACTIVITY_COMPLETED exception with the specified minor code and completion status.
ACTIVITY_COMPLETED(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.ACTIVITY_COMPLETED
Constructs an ACTIVITY_COMPLETED exception with the specified message, minor code, and completion status.
ACTIVITY_REQUIRED - Exception in org.omg.CORBA
The ACTIVITY_REQUIRED system exception may be raised on any method for which an Activity context is required.
ACTIVITY_REQUIRED() - Constructor for exception org.omg.CORBA.ACTIVITY_REQUIRED
Constructs an ACTIVITY_REQUIRED exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.
ACTIVITY_REQUIRED(String) - Constructor for exception org.omg.CORBA.ACTIVITY_REQUIRED
Constructs an ACTIVITY_REQUIRED exception with the specified message.
ACTIVITY_REQUIRED(int, CompletionStatus) - Constructor for exception org.omg.CORBA.ACTIVITY_REQUIRED
Constructs an ACTIVITY_REQUIRED exception with the specified minor code and completion status.
ACTIVITY_REQUIRED(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.ACTIVITY_REQUIRED
Constructs an ACTIVITY_REQUIRED exception with the specified message, minor code, and completion status.
ActivityCompletedException - Exception in javax.activity
This exception may be thrown on any method for which Activity context is accessed and indicates that ongoing work within the Activity is not possible.
ActivityCompletedException() - Constructor for exception javax.activity.ActivityCompletedException
Constructs a new instance with null as its detail message.
ActivityCompletedException(String) - Constructor for exception javax.activity.ActivityCompletedException
Constructs a new instance with the specified detail message.
ActivityCompletedException(Throwable) - Constructor for exception javax.activity.ActivityCompletedException
Constructs a new throwable with the specified cause.
ActivityCompletedException(String, Throwable) - Constructor for exception javax.activity.ActivityCompletedException
Constructs a new throwable with the specified detail message and cause.
ActivityRequiredException - Exception in javax.activity
This exception is thrown by a container if Activity context is not received on a method for which Activity context is mandatory.
ActivityRequiredException() - Constructor for exception javax.activity.ActivityRequiredException
Constructs a new instance with null as its detail message.
ActivityRequiredException(String) - Constructor for exception javax.activity.ActivityRequiredException
Constructs a new instance with the specified detail message.
ActivityRequiredException(Throwable) - Constructor for exception javax.activity.ActivityRequiredException
Constructs a new throwable with the specified cause.
ActivityRequiredException(String, Throwable) - Constructor for exception javax.activity.ActivityRequiredException
Constructs a new throwable with the specified detail message and cause.
AD - Static variable in class java.util.GregorianCalendar
Value of the ERA field indicating the common era (Anno Domini), also known as CE.
adapt(Runnable) - Static method in class java.util.concurrent.ForkJoinTask
Returns a new ForkJoinTask that performs the run method of the given Runnable as its action, and returns a null result upon ForkJoinTask.join().
adapt(Runnable, T) - Static method in class java.util.concurrent.ForkJoinTask
Returns a new ForkJoinTask that performs the run method of the given Runnable as its action, and returns the given result upon ForkJoinTask.join().
adapt(Callable<? extends T>) - Static method in class java.util.concurrent.ForkJoinTask
Returns a new ForkJoinTask that performs the call method of the given Callable as its action, and returns its result upon ForkJoinTask.join(), translating any checked exceptions encountered into RuntimeException.
adapter_id() - Method in interface org.omg.PortableInterceptor.ServerRequestInfoOperations
Returns the opaque identifier for the object adapter.
adapter_manager_state_changed(int, short) - Method in interface org.omg.PortableInterceptor.IORInterceptor_3_0Operations
Called whenever the state of an adapter manager changes.
adapter_name() - Method in interface org.omg.PortableInterceptor.ObjectReferenceTemplate
adapter_name() - Method in interface org.omg.PortableInterceptor.ServerRequestInfoOperations
Returns the sequence of strings that identifies the object adapter instance that is handling this request.
adapter_state_changed(ObjectReferenceTemplate[], short) - Method in interface org.omg.PortableInterceptor.IORInterceptor_3_0Operations
Called whenever the state of an object adapter changes, and the state change is not caused by an adapter manager.
adapter_template() - Method in interface org.omg.PortableInterceptor.IORInfoOperations
Return the object reference template of the object adapter that was just created and is running IOR interceptors.
AdapterActivator - Interface in org.omg.PortableServer
An adapter activator supplies a POA with the ability to create child POAs on demand, as a side-effect of receiving a request that names the child POA (or one of its children), or when find_POA is called with an activate parameter value of TRUE.
AdapterActivatorOperations - Interface in org.omg.PortableServer
An adapter activator supplies a POA with the ability to create child POAs on demand, as a side-effect of receiving a request that names the child POA (or one of its children), or when find_POA is called with an activate parameter value of TRUE.
AdapterAlreadyExists - Exception in org.omg.PortableServer.POAPackage
org/omg/PortableServer/POAPackage/AdapterAlreadyExists.java .
AdapterAlreadyExists() - Constructor for exception org.omg.PortableServer.POAPackage.AdapterAlreadyExists
AdapterAlreadyExists(String) - Constructor for exception org.omg.PortableServer.POAPackage.AdapterAlreadyExists
AdapterAlreadyExistsHelper - Class in org.omg.PortableServer.POAPackage
org/omg/PortableServer/POAPackage/AdapterAlreadyExistsHelper.java .
AdapterAlreadyExistsHelper() - Constructor for class org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper
AdapterInactive - Exception in org.omg.PortableServer.POAManagerPackage
org/omg/PortableServer/POAManagerPackage/AdapterInactive.java .
AdapterInactive() - Constructor for exception org.omg.PortableServer.POAManagerPackage.AdapterInactive
AdapterInactive(String) - Constructor for exception org.omg.PortableServer.POAManagerPackage.AdapterInactive
AdapterInactiveHelper - Class in org.omg.PortableServer.POAManagerPackage
org/omg/PortableServer/POAManagerPackage/AdapterInactiveHelper.java .
AdapterInactiveHelper() - Constructor for class org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper
AdapterManagerIdHelper - Class in org.omg.PortableInterceptor
Adapter manager identifier.
AdapterManagerIdHelper() - Constructor for class org.omg.PortableInterceptor.AdapterManagerIdHelper
AdapterNameHelper - Class in org.omg.PortableInterceptor
The name of an object adapter.
AdapterNameHelper() - Constructor for class org.omg.PortableInterceptor.AdapterNameHelper
AdapterNonExistent - Exception in org.omg.PortableServer.POAPackage
org/omg/PortableServer/POAPackage/AdapterNonExistent.java .
AdapterNonExistent() - Constructor for exception org.omg.PortableServer.POAPackage.AdapterNonExistent
AdapterNonExistent(String) - Constructor for exception org.omg.PortableServer.POAPackage.AdapterNonExistent
AdapterNonExistentHelper - Class in org.omg.PortableServer.POAPackage
org/omg/PortableServer/POAPackage/AdapterNonExistentHelper.java .
AdapterNonExistentHelper() - Constructor for class org.omg.PortableServer.POAPackage.AdapterNonExistentHelper
AdapterStateHelper - Class in org.omg.PortableInterceptor
Type of object adapter state.
AdapterStateHelper() - Constructor for class org.omg.PortableInterceptor.AdapterStateHelper
add(ComponentListener, ComponentListener) - Static method in class java.awt.AWTEventMulticaster
Adds component-listener-a with component-listener-b and returns the resulting multicast listener.
add(ContainerListener, ContainerListener) - Static method in class java.awt.AWTEventMulticaster
Adds container-listener-a with container-listener-b and returns the resulting multicast listener.
add(FocusListener, FocusListener) - Static method in class java.awt.AWTEventMulticaster
Adds focus-listener-a with focus-listener-b and returns the resulting multicast listener.
add(KeyListener, KeyListener) - Static method in class java.awt.AWTEventMulticaster
Adds key-listener-a with key-listener-b and returns the resulting multicast listener.
add(MouseListener, MouseListener) - Static method in class java.awt.AWTEventMulticaster
Adds mouse-listener-a with mouse-listener-b and returns the resulting multicast listener.
add(MouseMotionListener, MouseMotionListener) - Static method in class java.awt.AWTEventMulticaster
Adds mouse-motion-listener-a with mouse-motion-listener-b and returns the resulting multicast listener.
add(WindowListener, WindowListener) - Static method in class java.awt.AWTEventMulticaster
Adds window-listener-a with window-listener-b and returns the resulting multicast listener.
add(WindowStateListener, WindowStateListener) - Static method in class java.awt.AWTEventMulticaster
Adds window-state-listener-a with window-state-listener-b and returns the resulting multicast listener.
add(WindowFocusListener, WindowFocusListener) - Static method in class java.awt.AWTEventMulticaster
Adds window-focus-listener-a with window-focus-listener-b and returns the resulting multicast listener.
add(ActionListener, ActionListener) - Static method in class java.awt.AWTEventMulticaster
Adds action-listener-a with action-listener-b and returns the resulting multicast listener.
add(ItemListener, ItemListener) - Static method in class java.awt.AWTEventMulticaster
Adds item-listener-a with item-listener-b and returns the resulting multicast listener.
add(AdjustmentListener, AdjustmentListener) - Static method in class java.awt.AWTEventMulticaster
Adds adjustment-listener-a with adjustment-listener-b and returns the resulting multicast listener.
add(TextListener, TextListener) - Static method in class java.awt.AWTEventMulticaster
add(InputMethodListener, InputMethodListener) - Static method in class java.awt.AWTEventMulticaster
Adds input-method-listener-a with input-method-listener-b and returns the resulting multicast listener.
add(HierarchyListener, HierarchyListener) - Static method in class java.awt.AWTEventMulticaster
Adds hierarchy-listener-a with hierarchy-listener-b and returns the resulting multicast listener.
add(HierarchyBoundsListener, HierarchyBoundsListener) - Static method in class java.awt.AWTEventMulticaster
Adds hierarchy-bounds-listener-a with hierarchy-bounds-listener-b and returns the resulting multicast listener.
add(MouseWheelListener, MouseWheelListener) - Static method in class java.awt.AWTEventMulticaster
Adds mouse-wheel-listener-a with mouse-wheel-listener-b and returns the resulting multicast listener.
add(String) - Method in class java.awt.Choice
Adds an item to this Choice menu.
add(PopupMenu) - Method in class java.awt.Component
Adds the specified popup menu to the component.
add(Component) - Method in class java.awt.Container
Appends the specified component to the end of this container.
add(String, Component) - Method in class java.awt.Container
Adds the specified component to this container.
add(Component, int) - Method in class java.awt.Container
Adds the specified component to this container at the given position.
add(Component, Object) - Method in class java.awt.Container
Adds the specified component to the end of this container.
add(Component, Object, int) - Method in class java.awt.Container
Adds the specified component to this container with the specified constraints at the specified index.
add(Area) - Method in class java.awt.geom.Area
Adds the shape of the specified Area to the shape of this Area.
add(double, double) - Method in class java.awt.geom.Rectangle2D
Adds a point, specified by the double precision arguments newx and newy, to this Rectangle2D.
add(Point2D) - Method in class java.awt.geom.Rectangle2D
Adds the Point2D object pt to this Rectangle2D.
add(Rectangle2D) - Method in class java.awt.geom.Rectangle2D
Adds a Rectangle2D object to this Rectangle2D.
add(Object) - Method in class java.awt.image.renderable.ParameterBlock
Adds an object to the list of parameters.
add(byte) - Method in class java.awt.image.renderable.ParameterBlock
Adds a Byte to the list of parameters.
add(char) - Method in class java.awt.image.renderable.ParameterBlock
Adds a Character to the list of parameters.
add(short) - Method in class java.awt.image.renderable.ParameterBlock
Adds a Short to the list of parameters.
add(int) - Method in class java.awt.image.renderable.ParameterBlock
Adds a Integer to the list of parameters.
add(long) - Method in class java.awt.image.renderable.ParameterBlock
Adds a Long to the list of parameters.
add(float) - Method in class java.awt.image.renderable.ParameterBlock
Adds a Float to the list of parameters.
add(double) - Method in class java.awt.image.renderable.ParameterBlock
Adds a Double to the list of parameters.
add(String) - Method in class java.awt.List
Adds the specified item to the end of scrolling list.
add(String, int) - Method in class java.awt.List
Adds the specified item to the the scrolling list at the position indicated by the index.
add(MenuItem) - Method in class java.awt.Menu
Adds the specified menu item to this menu.
add(String) - Method in class java.awt.Menu
Adds an item with the specified label to this menu.
add(Menu) - Method in class java.awt.MenuBar
Adds the specified menu to the menu bar.
add(int, int) - Method in class java.awt.Rectangle
Adds a point, specified by the integer arguments newx,newy to the bounds of this Rectangle.
add(Point) - Method in class java.awt.Rectangle
Adds the specified Point to the bounds of this Rectangle.
add(Rectangle) - Method in class java.awt.Rectangle
Adds a Rectangle to this Rectangle.
add(RenderingHints) - Method in class java.awt.RenderingHints
Adds all of the keys and corresponding values from the specified RenderingHints object to this RenderingHints object.
add(TrayIcon) - Method in class java.awt.SystemTray
Adds a TrayIcon to the SystemTray.
add(Object) - Method in class java.beans.beancontext.BeanContextSupport
Adds/nests a child within this BeanContext.
add(BigDecimal) - Method in class java.math.BigDecimal
Returns a BigDecimal whose value is (this + augend), and whose scale is max(this.scale(), augend.scale()).
add(BigDecimal, MathContext) - Method in class java.math.BigDecimal
Returns a BigDecimal whose value is (this + augend), with rounding according to the context settings.
add(BigInteger) - Method in class java.math.BigInteger
Returns a BigInteger whose value is (this + val).
add(URI, HttpCookie) - Method in interface java.net.CookieStore
Adds one HTTP cookie to the store.
add(Permission) - Method in class java.security.PermissionCollection
Adds a permission object to the current collection of permission objects.
add(Permission) - Method in class java.security.Permissions
Adds a permission object to the PermissionCollection for the class the permission belongs to.
add(E) - Method in class java.util.AbstractCollection
Ensures that this collection contains the specified element (optional operation).
add(E) - Method in class java.util.AbstractList
Appends the specified element to the end of this list (optional operation).
add(int, E) - Method in class java.util.AbstractList
Inserts the specified element at the specified position in this list (optional operation).
add(E) - Method in class java.util.AbstractQueue
Inserts the specified element into this queue if it is possible to do so immediately without violating capacity restrictions, returning true upon success and throwing an IllegalStateException if no space is currently available.
add(int, E) - Method in class java.util.AbstractSequentialList
Inserts the specified element at the specified position in this list (optional operation).
add(E) - Method in class java.util.ArrayDeque
Inserts the specified element at the end of this deque.
add(E) - Method in class java.util.ArrayList
Appends the specified element to the end of this list.
add(int, E) - Method in class java.util.ArrayList
Inserts the specified element at the specified position in this list.
add(int, int) - Method in class java.util.Calendar
Adds or subtracts the specified amount of time to the given calendar field, based on the calendar's rules.
add(E) - Method in interface java.util.Collection
Ensures that this collection contains the specified element (optional operation).
add(E) - Method in class java.util.concurrent.ArrayBlockingQueue
Inserts the specified element at the tail of this queue if it is possible to do so immediately without exceeding the queue's capacity, returning true upon success and throwing an IllegalStateException if this queue is full.
add(double) - Method in class java.util.concurrent.atomic.DoubleAdder
Adds the given value.
add(long) - Method in class java.util.concurrent.atomic.LongAdder
Adds the given value.
add(E) - Method in interface java.util.concurrent.BlockingDeque
Inserts the specified element into the queue represented by this deque (in other words, at the tail of this deque) if it is possible to do so immediately without violating capacity restrictions, returning true upon success and throwing an IllegalStateException if no space is currently available.
add(E) - Method in interface java.util.concurrent.BlockingQueue
Inserts the specified element into this queue if it is possible to do so immediately without violating capacity restrictions, returning true upon success and throwing an IllegalStateException if no space is currently available.
add(K) - Method in class java.util.concurrent.ConcurrentHashMap.KeySetView
Adds the specified key to this set view by mapping the key to the default mapped value in the backing map, if defined.
add(E) - Method in class java.util.concurrent.ConcurrentLinkedDeque
Inserts the specified element at the tail of this deque.
add(E) - Method in class java.util.concurrent.ConcurrentLinkedQueue
Inserts the specified element at the tail of this queue.
add(E) - Method in class java.util.concurrent.ConcurrentSkipListSet
Adds the specified element to this set if it is not already present.
add(E) - Method in class java.util.concurrent.CopyOnWriteArrayList
Appends the specified element to the end of this list.
add(int, E) - Method in class java.util.concurrent.CopyOnWriteArrayList
Inserts the specified element at the specified position in this list.
add(E) - Method in class java.util.concurrent.CopyOnWriteArraySet
Adds the specified element to this set if it is not already present.
add(E) - Method in class java.util.concurrent.DelayQueue
Inserts the specified element into this delay queue.
add(E) - Method in class java.util.concurrent.LinkedBlockingDeque
Inserts the specified element at the end of this deque unless it would violate capacity restrictions.
add(E) - Method in class java.util.concurrent.LinkedTransferQueue
Inserts the specified element at the tail of this queue.
add(E) - Method in class java.util.concurrent.PriorityBlockingQueue
Inserts the specified element into this priority queue.
add(E) - Method in interface java.util.Deque
Inserts the specified element into the queue represented by this deque (in other words, at the tail of this deque) if it is possible to do so immediately without violating capacity restrictions, returning true upon success and throwing an IllegalStateException if no space is currently available.
add(int, int) - Method in class java.util.GregorianCalendar
Adds the specified (signed) amount of time to the given calendar field, based on the calendar's rules.
add(E) - Method in class java.util.HashSet
Adds the specified element to this set if it is not already present.
add(E) - Method in class java.util.LinkedList
Appends the specified element to the end of this list.
add(int, E) - Method in class java.util.LinkedList
Inserts the specified element at the specified position in this list.
add(E) - Method in interface java.util.List
Appends the specified element to the end of this list (optional operation).
add(int, E) - Method in interface java.util.List
Inserts the specified element at the specified position in this list (optional operation).
add(E) - Method in interface java.util.ListIterator
Inserts the specified element into the list (optional operation).
add(E) - Method in class java.util.PriorityQueue
Inserts the specified element into this priority queue.
add(E) - Method in interface java.util.Queue
Inserts the specified element into this queue if it is possible to do so immediately without violating capacity restrictions, returning true upon success and throwing an IllegalStateException if no space is currently available.
add(E) - Method in interface java.util.Set
Adds the specified element to this set if it is not already present (optional operation).
add(double) - Method in interface java.util.stream.DoubleStream.Builder
Adds an element to the stream being built.
add(int) - Method in interface java.util.stream.IntStream.Builder
Adds an element to the stream being built.
add(long) - Method in interface java.util.stream.LongStream.Builder
Adds an element to the stream being built.
add(T) - Method in interface java.util.stream.Stream.Builder
Adds an element to the stream being built.
add(CharSequence) - Method in class java.util.StringJoiner
Adds a copy of the given CharSequence value as the next element of the StringJoiner value.
add(E) - Method in class java.util.TreeSet
Adds the specified element to this set if it is not already present.
add(E) - Method in class java.util.Vector
Appends the specified element to the end of this Vector.
add(int, E) - Method in class java.util.Vector
Inserts the specified element at the specified position in this Vector.
add(AccessibleRelation) - Method in class javax.accessibility.AccessibleRelationSet
Adds a new relation to the current relation set.
add(AccessibleState) - Method in class javax.accessibility.AccessibleStateSet
Adds a new state to the current state set if it is not already present.
add(Attribute) - Method in class javax.management.AttributeList
Adds the Attribute specified as the last element of the list.
add(int, Attribute) - Method in class javax.management.AttributeList
Inserts the attribute specified as an element at the position specified.
add(Object) - Method in class javax.management.AttributeList
Appends the specified element to the end of this list.
add(int, Object) - Method in class javax.management.AttributeList
Inserts the specified element at the specified position in this list.
add(Role) - Method in class javax.management.relation.RoleList
Adds the Role specified as the last element of the list.
add(int, Role) - Method in class javax.management.relation.RoleList
Inserts the role specified as an element at the position specified.
add(Object) - Method in class javax.management.relation.RoleList
add(int, Object) - Method in class javax.management.relation.RoleList
add(RoleUnresolved) - Method in class javax.management.relation.RoleUnresolvedList
Adds the RoleUnresolved specified as the last element of the list.
add(int, RoleUnresolved) - Method in class javax.management.relation.RoleUnresolvedList
Inserts the unresolved role specified as an element at the position specified.
add(Object) - Method in class javax.management.relation.RoleUnresolvedList
add(int, Object) - Method in class javax.management.relation.RoleUnresolvedList
add(String) - Method in class javax.naming.CompositeName
Adds a single component to the end of this composite name.
add(int, String) - Method in class javax.naming.CompositeName
Adds a single component at a specified position within this composite name.
add(String) - Method in class javax.naming.CompoundName
Adds a single component to the end of this compound name.
add(int, String) - Method in class javax.naming.CompoundName
Adds a single component at a specified position within this compound name.
add(Object) - Method in interface javax.naming.directory.Attribute
Adds a new value to the attribute.
add(int, Object) - Method in interface javax.naming.directory.Attribute
Adds an attribute value to the ordered list of attribute values.
add(Object) - Method in class javax.naming.directory.BasicAttribute
Adds a new value to this attribute.
add(int, Object) - Method in class javax.naming.directory.BasicAttribute
add(String) - Method in class javax.naming.ldap.LdapName
Adds a single component to the end of this LDAP name.
add(Rdn) - Method in class javax.naming.ldap.LdapName
Adds a single RDN to the end of this LDAP name.
add(int, String) - Method in class javax.naming.ldap.LdapName
Adds a single component at a specified position within this LDAP name.
add(int, Rdn) - Method in class javax.naming.ldap.LdapName
Adds a single RDN at a specified position within this LDAP name.
add(String) - Method in interface javax.naming.Name
Adds a single component to the end of this name.
add(int, String) - Method in interface javax.naming.Name
Adds a single component at a specified position within this name.
add(RefAddr) - Method in class javax.naming.Reference
Adds an address to the end of the list of addresses.
add(int, RefAddr) - Method in class javax.naming.Reference
Adds an address to the list of addresses at index posn.
add(Attribute) - Method in interface javax.print.attribute.AttributeSet
Adds the specified attribute to this attribute set if it is not already present, first removing any existing value in the same attribute category as the specified attribute value.
add(Attribute) - Method in interface javax.print.attribute.DocAttributeSet
Adds the specified attribute value to this attribute set if it is not already present, first removing any existing value in the same attribute category as the specified attribute value (optional operation).
add(Attribute) - Method in class javax.print.attribute.HashAttributeSet
Adds the specified attribute to this attribute set if it is not already present, first removing any existing in the same attribute category as the specified attribute value.
add(Attribute) - Method in interface javax.print.attribute.PrintJobAttributeSet
Adds the specified attribute value to this attribute set if it is not already present, first removing any existing value in the same attribute category as the specified attribute value (optional operation).
add(Attribute) - Method in interface javax.print.attribute.PrintRequestAttributeSet
Adds the specified attribute value to this attribute set if it is not already present, first removing any existing value in the same attribute category as the specified attribute value (optional operation).
add(Attribute) - Method in interface javax.print.attribute.PrintServiceAttributeSet
Adds the specified attribute value to this attribute set if it is not already present, first removing any existing value in the same attribute category as the specified attribute value (optional operation).
add(JobStateReason) - Method in class javax.print.attribute.standard.JobStateReasons
Adds the specified element to this job state reasons attribute if it is not already present.
add(MidiEvent) - Method in class javax.sound.midi.Track
Adds a new event to the track.
add(AbstractButton) - Method in class javax.swing.ButtonGroup
Adds the button to the group.
add(int, E) - Method in class javax.swing.DefaultListModel
Inserts the specified element at the specified position in this list.
add(Class<T>, T) - Method in class javax.swing.event.EventListenerList
Adds the listener as a listener of the specified type.
add(JMenuItem) - Method in class javax.swing.JMenu
Appends a menu item to the end of this menu.
add(Component) - Method in class javax.swing.JMenu
Appends a component to the end of this menu.
add(Component, int) - Method in class javax.swing.JMenu
Adds the specified component to this container at the given position.
add(String) - Method in class javax.swing.JMenu
Creates a new menu item with the specified text and appends it to the end of this menu.
add(Action) - Method in class javax.swing.JMenu
Creates a new menu item attached to the specified Action object and appends it to the end of this menu.
add(JMenu) - Method in class javax.swing.JMenuBar
Appends the specified menu to the end of the menu bar.
add(JMenuItem) - Method in class javax.swing.JPopupMenu
Appends the specified menu item to the end of this menu.
add(String) - Method in class javax.swing.JPopupMenu
Creates a new menu item with the specified text and appends it to the end of this menu.
add(Action) - Method in class javax.swing.JPopupMenu
Appends a new menu item to the end of the menu which dispatches the specified Action object.
add(Component) - Method in class javax.swing.JTabbedPane
Adds a component with a tab title defaulting to the name of the component which is the result of calling component.getName.
add(String, Component) - Method in class javax.swing.JTabbedPane
Adds a component with the specified tab title.
add(Component, int) - Method in class javax.swing.JTabbedPane
Adds a component at the specified tab index with a tab title defaulting to the name of the component.
add(Component, Object) - Method in class javax.swing.JTabbedPane
Adds a component to the tabbed pane.
add(Component, Object, int) - Method in class javax.swing.JTabbedPane
Adds a component at the specified tab index.
add(Action) - Method in class javax.swing.JToolBar
Adds a new JButton which dispatches the action.
add(MutableTreeNode) - Method in class javax.swing.tree.DefaultMutableTreeNode
Removes newChild from its parent and makes it a child of this node by adding it to the end of this node's child array.
add(Duration) - Method in class javax.xml.datatype.Duration
Computes a new duration whose value is this+rhs.
add(Duration) - Method in class javax.xml.datatype.XMLGregorianCalendar
Add duration to this instance.
add(XMLEvent) - Method in interface javax.xml.stream.util.XMLEventConsumer
This method adds an event to the consumer.
add(XMLEvent) - Method in interface javax.xml.stream.XMLEventWriter
Add an event to the output stream Adding a START_ELEMENT will open a new namespace scope that will be closed when the corresponding END_ELEMENT is written.
add(XMLEventReader) - Method in interface javax.xml.stream.XMLEventWriter
Adds an entire stream to an output stream, calls next() on the inputStream argument until hasNext() returns false This should be treated as a convenience method that will perform the following loop over all the events in an event reader and call add on each event.
add(GSSName, int, int, Oid, int) - Method in interface org.ietf.jgss.GSSCredential
Adds a mechanism specific credential-element to an existing credential.
add(String) - Method in class org.omg.CORBA.ContextList
Adds a String object to this ContextList object.
add(TypeCode) - Method in class org.omg.CORBA.ExceptionList
Adds a TypeCode object describing an exception to this ExceptionList object.
add(int) - Method in class org.omg.CORBA.NVList
Creates a new NamedValue object initialized with the given flag and adds it to the end of this NVList object.
ADD_ATTRIBUTE - Static variable in interface javax.naming.directory.DirContext
This constant specifies to add an attribute with the specified values.
add_client_request_interceptor(ClientRequestInterceptor) - Method in interface org.omg.PortableInterceptor.ORBInitInfoOperations
Used to add a client-side request Interceptor to the list of client-side request Interceptors.
ADD_FILE - Static variable in enum java.nio.file.attribute.AclEntryPermission
Permission to add a new file to a directory (equal to AclEntryPermission.WRITE_DATA)
add_in_arg() - Method in class org.omg.CORBA.Request
Creates an input argument and adds it to this Request object.
add_inout_arg() - Method in class org.omg.CORBA.Request
Adds an input/output argument to this Request object.
add_ior_component(TaggedComponent) - Method in interface org.omg.PortableInterceptor.IORInfoOperations
A portable ORB service implementation calls add_ior_component from its implementation of establish_components to add a tagged component to the set which will be included when constructing IORs.
add_ior_component_to_profile(TaggedComponent, int) - Method in interface org.omg.PortableInterceptor.IORInfoOperations
A portable ORB service implementation calls add_ior_component_to_profile from its implementation of establish_components to add a tagged component to the set which will be included when constructing IORs.
add_ior_interceptor(IORInterceptor) - Method in interface org.omg.PortableInterceptor.ORBInitInfoOperations
Used to add an IOR Interceptor to the list of IOR Interceptors.
add_item(String, int) - Method in class org.omg.CORBA.NVList
Creates a new NamedValue object initialized with the given name and flag, and adds it to the end of this NVList object.
add_named_in_arg(String) - Method in class org.omg.CORBA.Request
Creates an input argument with the given name and adds it to this Request object.
add_named_inout_arg(String) - Method in class org.omg.CORBA.Request
Adds an input/output argument with the given name to this Request object.
add_named_out_arg(String) - Method in class org.omg.CORBA.Request
Adds an output argument with the given name to this Request object.
add_out_arg() - Method in class org.omg.CORBA.Request
Adds an output argument to this Request object.
ADD_OVERRIDE - Static variable in class org.omg.CORBA.SetOverrideType
The SetOverrideType constant for the enum value ADD_OVERRIDE.
add_reply_service_context(ServiceContext, boolean) - Method in interface org.omg.PortableInterceptor.ServerRequestInfoOperations
Allows Interceptors to add service contexts to the request.
add_request_service_context(ServiceContext, boolean) - Method in interface org.omg.PortableInterceptor.ClientRequestInfoOperations
Allows Interceptors to add service contexts to the request.
add_server_request_interceptor(ServerRequestInterceptor) - Method in interface org.omg.PortableInterceptor.ORBInitInfoOperations
Used to add a server-side request Interceptor to the list of server-side request Interceptors.
ADD_SUBDIRECTORY - Static variable in enum java.nio.file.attribute.AclEntryPermission
Permission to create a subdirectory to a directory (equal to AclEntryPermission.APPEND_DATA)
add_value(String, Any, int) - Method in class org.omg.CORBA.NVList
Creates a new NamedValue object initialized with the given name, value, and flag, and adds it to the end of this NVList object.
addAccessibleSelection(int) - Method in class java.awt.List.AccessibleAWTList
Adds the specified selected item in the object to the object's selection.
addAccessibleSelection(int) - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent
Adds the specified Accessible child of the object to the object's selection.
addAccessibleSelection(int) - Method in interface javax.accessibility.AccessibleSelection
Adds the specified Accessible child of the object to the object's selection.
addAccessibleSelection(int) - Method in class javax.swing.JComboBox.AccessibleJComboBox
Adds the specified Accessible child of the object to the object's selection.
addAccessibleSelection(int) - Method in class javax.swing.JList.AccessibleJList
Adds the specified selected item in the object to the object's selection.
addAccessibleSelection(int) - Method in class javax.swing.JMenu.AccessibleJMenu
Selects the ith menu in the menu.
addAccessibleSelection(int) - Method in class javax.swing.JMenuBar.AccessibleJMenuBar
Selects the nth menu in the menu bar, forcing it to pop up.
addAccessibleSelection(int) - Method in class javax.swing.JTabbedPane.AccessibleJTabbedPane
addAccessibleSelection(int) - Method in class javax.swing.JTable.AccessibleJTable
Adds the specified Accessible child of the object to the object's selection.
addAccessibleSelection(int) - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode
Adds the specified selected item in the object to the object's selection.
addAccessibleSelection(int) - Method in class javax.swing.JTree.AccessibleJTree
Adds the specified selected item in the object to the object's selection.
addActionForKeyStroke(KeyStroke, Action) - Method in interface javax.swing.text.Keymap
Adds a binding to the keymap.
addActionListener(ActionListener) - Method in class java.awt.Button
Adds the specified action listener to receive action events from this button.
addActionListener(ActionListener) - Method in class java.awt.List
Adds the specified action listener to receive action events from this list.
addActionListener(ActionListener) - Method in class java.awt.MenuItem
Adds the specified action listener to receive action events from this menu item.
addActionListener(ActionListener) - Method in class java.awt.TextField
Adds the specified action listener to receive action events from this text field.
addActionListener(ActionListener) - Method in class java.awt.TrayIcon
Adds the specified action listener to receive ActionEvents from this TrayIcon.
addActionListener(ActionListener) - Method in class javax.swing.AbstractButton
Adds an ActionListener to the button.
addActionListener(ActionListener) - Method in interface javax.swing.ButtonModel
Adds an ActionListener to the model.
addActionListener(ActionListener) - Method in interface javax.swing.ComboBoxEditor
Add an ActionListener.
addActionListener(ActionListener) - Method in class javax.swing.DefaultButtonModel
Adds an ActionListener to the model.
addActionListener(ActionListener) - Method in class javax.swing.JComboBox
Adds an ActionListener.
addActionListener(ActionListener) - Method in class javax.swing.JFileChooser
Adds an ActionListener to the file chooser.
addActionListener(ActionListener) - Method in class javax.swing.JTextField
Adds the specified action listener to receive action events from this textfield.
addActionListener(ActionListener) - Method in class javax.swing.plaf.basic.BasicComboBoxEditor
addActionListener(ActionListener) - Method in class javax.swing.Timer
Adds an action listener to the Timer.
addAdjustmentListener(AdjustmentListener) - Method in interface java.awt.Adjustable
Adds a listener to receive adjustment events when the value of the adjustable object changes.
addAdjustmentListener(AdjustmentListener) - Method in class java.awt.Scrollbar
Adds the specified adjustment listener to receive instances of AdjustmentEvent from this scroll bar.
addAdjustmentListener(AdjustmentListener) - Method in class java.awt.ScrollPaneAdjustable
Adds the specified adjustment listener to receive adjustment events from this ScrollPaneAdjustable.
addAdjustmentListener(AdjustmentListener) - Method in class javax.swing.JScrollBar
Adds an AdjustmentListener.
addAll(Collection) - Method in class java.beans.beancontext.BeanContextSupport
add Collection to set of Children (Unsupported) implementations must synchronized on the hierarchy lock and "children" protected field
addAll(Collection<? extends E>) - Method in class java.util.AbstractCollection
Adds all of the elements in the specified collection to this collection (optional operation).
addAll(int, Collection<? extends E>) - Method in class java.util.AbstractList
Inserts all of the elements in the specified collection into this list at the specified position (optional operation).
addAll(Collection<? extends E>) - Method in class java.util.AbstractQueue
Adds all of the elements in the specified collection to this queue.
addAll(int, Collection<? extends E>) - Method in class java.util.AbstractSequentialList
Inserts all of the elements in the specified collection into this list at the specified position (optional operation).
addAll(Collection<? extends E>) - Method in class java.util.ArrayList
Appends all of the elements in the specified collection to the end of this list, in the order that they are returned by the specified collection's Iterator.
addAll(int, Collection<? extends E>) - Method in class java.util.ArrayList
Inserts all of the elements in the specified collection into this list, starting at the specified position.
addAll(Collection<? extends E>) - Method in interface java.util.Collection
Adds all of the elements in the specified collection to this collection (optional operation).
addAll(Collection<? super T>, T...) - Static method in class java.util.Collections
Adds all of the specified elements to the specified collection.
addAll(Collection<? extends K>) - Method in class java.util.concurrent.ConcurrentHashMap.KeySetView
Adds all of the elements in the specified collection to this set, as if by calling ConcurrentHashMap.KeySetView.add(K) on each one.
addAll(Collection<? extends E>) - Method in class java.util.concurrent.ConcurrentLinkedDeque
Appends all of the elements in the specified collection to the end of this deque, in the order that they are returned by the specified collection's iterator.
addAll(Collection<? extends E>) - Method in class java.util.concurrent.ConcurrentLinkedQueue
Appends all of the elements in the specified collection to the end of this queue, in the order that they are returned by the specified collection's iterator.
addAll(Collection<? extends E>) - Method in class java.util.concurrent.CopyOnWriteArrayList
Appends all of the elements in the specified collection to the end of this list, in the order that they are returned by the specified collection's iterator.
addAll(int, Collection<? extends E>) - Method in class java.util.concurrent.CopyOnWriteArrayList
Inserts all of the elements in the specified collection into this list, starting at the specified position.
addAll(Collection<? extends E>) - Method in class java.util.concurrent.CopyOnWriteArraySet
Adds all of the elements in the specified collection to this set if they're not already present.
addAll(Collection<? extends E>) - Method in class java.util.LinkedList
Appends all of the elements in the specified collection to the end of this list, in the order that they are returned by the specified collection's iterator.
addAll(int, Collection<? extends E>) - Method in class java.util.LinkedList
Inserts all of the elements in the specified collection into this list, starting at the specified position.
addAll(Collection<? extends E>) - Method in interface java.util.List
Appends all of the elements in the specified collection to the end of this list, in the order that they are returned by the specified collection's iterator (optional operation).
addAll(int, Collection<? extends E>) - Method in interface java.util.List
Inserts all of the elements in the specified collection into this list at the specified position (optional operation).
addAll(Collection<? extends E>) - Method in interface java.util.Set
Adds all of the elements in the specified collection to this set if they're not already present (optional operation).
addAll(Collection<? extends E>) - Method in class java.util.TreeSet
Adds all of the elements in the specified collection to this set.
addAll(Collection<? extends E>) - Method in class java.util.Vector
Appends all of the elements in the specified Collection to the end of this Vector, in the order that they are returned by the specified Collection's Iterator.
addAll(int, Collection<? extends E>) - Method in class java.util.Vector
Inserts all of the elements in the specified Collection into this Vector at the specified position.
addAll(AccessibleRelation[]) - Method in class javax.accessibility.AccessibleRelationSet
Adds all of the relations to the existing relation set.
addAll(AccessibleState[]) - Method in class javax.accessibility.AccessibleStateSet
Adds all of the states to the existing state set.
addAll(AttributeList) - Method in class javax.management.AttributeList
Appends all the elements in the AttributeList specified to the end of the list, in the order in which they are returned by the Iterator of the AttributeList specified.
addAll(int, AttributeList) - Method in class javax.management.AttributeList
Inserts all of the elements in the AttributeList specified into this list, starting at the specified position, in the order in which they are returned by the Iterator of the AttributeList specified.
addAll(Collection<?>) - Method in class javax.management.AttributeList
Appends all of the elements in the specified collection to the end of this list, in the order that they are returned by the specified collection's Iterator.
addAll(int, Collection<?>) - Method in class javax.management.AttributeList
Inserts all of the elements in the specified collection into this list, starting at the specified position.
addAll(RoleList) - Method in class javax.management.relation.RoleList
Appends all the elements in the RoleList specified to the end of the list, in the order in which they are returned by the Iterator of the RoleList specified.
addAll(int, RoleList) - Method in class javax.management.relation.RoleList
Inserts all of the elements in the RoleList specified into this list, starting at the specified position, in the order in which they are returned by the Iterator of the RoleList specified.
addAll(Collection<?>) - Method in class javax.management.relation.RoleList
addAll(int, Collection<?>) - Method in class javax.management.relation.RoleList
addAll(RoleUnresolvedList) - Method in class javax.management.relation.RoleUnresolvedList
Appends all the elements in the RoleUnresolvedList specified to the end of the list, in the order in which they are returned by the Iterator of the RoleUnresolvedList specified.
addAll(int, RoleUnresolvedList) - Method in class javax.management.relation.RoleUnresolvedList
Inserts all of the elements in the RoleUnresolvedList specified into this list, starting at the specified position, in the order in which they are returned by the Iterator of the RoleUnresolvedList specified.
addAll(Collection<?>) - Method in class javax.management.relation.RoleUnresolvedList
addAll(int, Collection<?>) - Method in class javax.management.relation.RoleUnresolvedList
addAll(Name) - Method in class javax.naming.CompositeName
Adds the components of a composite name -- in order -- to the end of this composite name.
addAll(int, Name) - Method in class javax.naming.CompositeName
Adds the components of a composite name -- in order -- at a specified position within this composite name.
addAll(Name) - Method in class javax.naming.CompoundName
Adds the components of a compound name -- in order -- to the end of this compound name.
addAll(int, Name) - Method in class javax.naming.CompoundName
Adds the components of a compound name -- in order -- at a specified position within this compound name.
addAll(Name) - Method in class javax.naming.ldap.LdapName
Adds the components of a name -- in order -- to the end of this name.
addAll(List<Rdn>) - Method in class javax.naming.ldap.LdapName
Adds the RDNs of a name -- in order -- to the end of this name.
addAll(int, Name) - Method in class javax.naming.ldap.LdapName
Adds the components of a name -- in order -- at a specified position within this name.
addAll(int, List<Rdn>) - Method in class javax.naming.ldap.LdapName
Adds the RDNs of a name -- in order -- at a specified position within this name.
addAll(Name) - Method in interface javax.naming.Name
Adds the components of a name -- in order -- to the end of this name.
addAll(int, Name) - Method in interface javax.naming.Name
Adds the components of a name -- in order -- at a specified position within this name.
addAll(AttributeSet) - Method in interface javax.print.attribute.AttributeSet
Adds all of the elements in the specified set to this attribute.
addAll(AttributeSet) - Method in interface javax.print.attribute.DocAttributeSet
Adds all of the elements in the specified set to this attribute.
addAll(AttributeSet) - Method in class javax.print.attribute.HashAttributeSet
Adds all of the elements in the specified set to this attribute.
addAll(AttributeSet) - Method in interface javax.print.attribute.PrintJobAttributeSet
Adds all of the elements in the specified set to this attribute.
addAll(AttributeSet) - Method in interface javax.print.attribute.PrintRequestAttributeSet
Adds all of the elements in the specified set to this attribute.
addAll(AttributeSet) - Method in interface javax.print.attribute.PrintServiceAttributeSet
Adds all of the elements in the specified set to this attribute.
addAllAbsent(Collection<? extends E>) - Method in class java.util.concurrent.CopyOnWriteArrayList
Appends all of the elements in the specified collection that are not already contained in this list, to the end of this list, in the order that they are returned by the specified collection's iterator.
addAncestorListener(AncestorListener) - Method in class javax.swing.JComponent
Registers listener so that it will receive AncestorEvents when it or any of its ancestors move or are made visible or invisible.
addAndGet(int) - Method in class java.util.concurrent.atomic.AtomicInteger
Atomically adds the given value to the current value.
addAndGet(int, int) - Method in class java.util.concurrent.atomic.AtomicIntegerArray
Atomically adds the given value to the element at index i.
addAndGet(T, int) - Method in class java.util.concurrent.atomic.AtomicIntegerFieldUpdater
Atomically adds the given value to the current value of the field of the given object managed by this updater.
addAndGet(long) - Method in class java.util.concurrent.atomic.AtomicLong
Atomically adds the given value to the current value.
addAndGet(int, long) - Method in class java.util.concurrent.atomic.AtomicLongArray
Atomically adds the given value to the element at index i.
addAndGet(T, long) - Method in class java.util.concurrent.atomic.AtomicLongFieldUpdater
Atomically adds the given value to the current value of the field of the given object managed by this updater.
addAttachmentPart(AttachmentPart) - Method in class javax.xml.soap.SOAPMessage
Adds the given AttachmentPart object to this SOAPMessage object.
addAttribute(AttributedCharacterIterator.Attribute, Object) - Method in class java.text.AttributedString
Adds an attribute to the entire string.
addAttribute(AttributedCharacterIterator.Attribute, Object, int, int) - Method in class java.text.AttributedString
Adds an attribute to a subrange of the string.
addAttribute(String, String, int, boolean, String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl
Adds a new attribute to a previously defined element that may be set to an arbitrary value.
addAttribute(String, String, int, boolean, String, List<String>) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl
Adds a new attribute to a previously defined element that will be defined by a set of enumerated values.
addAttribute(String, String, int, boolean, String, String, String, boolean, boolean) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl
Adds a new attribute to a previously defined element that will be defined by a range of values.
addAttribute(String, String, int, boolean, int, int) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl
Adds a new attribute to a previously defined element that will be defined by a list of values.
addAttribute(Object, Object) - Method in class javax.swing.text.AbstractDocument.AbstractElement
Adds an attribute to the element.
addAttribute(AttributeSet, Object, Object) - Method in interface javax.swing.text.AbstractDocument.AttributeContext
Adds an attribute to the given set, and returns the new representative set.
addAttribute(AttributeSet, Object, Object) - Method in class javax.swing.text.html.StyleSheet
Adds an attribute to the given set, and returns the new representative set.
addAttribute(Object, Object) - Method in interface javax.swing.text.MutableAttributeSet
Creates a new attribute set similar to this one except that it contains an attribute with the given name and value.
addAttribute(Object, Object) - Method in class javax.swing.text.SimpleAttributeSet
Adds an attribute to the list.
addAttribute(AttributeSet, Object, Object) - Method in class javax.swing.text.StyleContext
Adds an attribute to the given set, and returns the new representative set.
addAttribute(Object, Object) - Method in class javax.swing.text.StyleContext.NamedStyle
Adds an attribute.
addAttribute(Name, String) - Method in interface javax.xml.soap.SOAPElement
Adds an attribute with the specified name and value to this SOAPElement object.
addAttribute(QName, String) - Method in interface javax.xml.soap.SOAPElement
Adds an attribute with the specified name and value to this SOAPElement object.
addAttribute(String, String, String, String, String) - Method in class org.xml.sax.ext.Attributes2Impl
Add an attribute to the end of the list, setting its "specified" flag to true.
addAttribute(String, String, String) - Method in class org.xml.sax.helpers.AttributeListImpl
Deprecated.
Add an attribute to an attribute list.
addAttribute(String, String, String, String, String) - Method in class org.xml.sax.helpers.AttributesImpl
Add an attribute to the end of the list.
addAttributeChangeNotificationListener(NotificationListener, String, Object) - Method in interface javax.management.modelmbean.ModelMBeanNotificationBroadcaster
Registers an object which implements the NotificationListener interface as a listener.
addAttributeChangeNotificationListener(NotificationListener, String, Object) - Method in class javax.management.modelmbean.RequiredModelMBean
addAttributes(Map<? extends AttributedCharacterIterator.Attribute, ?>, int, int) - Method in class java.text.AttributedString
Adds a set of attributes to a subrange of the string.
addAttributes(AttributeSet) - Method in class javax.swing.text.AbstractDocument.AbstractElement
Adds a set of attributes to the element.
addAttributes(AttributeSet, AttributeSet) - Method in interface javax.swing.text.AbstractDocument.AttributeContext
Adds a set of attributes to the element.
addAttributes(AttributeSet, AttributeSet) - Method in class javax.swing.text.html.StyleSheet
Adds a set of attributes to the element.
addAttributes(AttributeSet) - Method in interface javax.swing.text.MutableAttributeSet
Creates a new attribute set similar to this one except that it contains the given attributes and values.
addAttributes(AttributeSet) - Method in class javax.swing.text.SimpleAttributeSet
Adds a set of attributes to the list.
addAttributes(AttributeSet, AttributeSet) - Method in class javax.swing.text.StyleContext
Adds a set of attributes to the element.
addAttributes(AttributeSet) - Method in class javax.swing.text.StyleContext.NamedStyle
Adds a set of attributes to the element.
addAuxiliaryLookAndFeel(LookAndFeel) - Static method in class javax.swing.UIManager
Adds a LookAndFeel to the list of auxiliary look and feels.
addAWTEventListener(AWTEventListener, long) - Method in class java.awt.Toolkit
Adds an AWTEventListener to receive all AWTEvents dispatched system-wide that conform to the given eventMask.
addBatch() - Method in interface java.sql.PreparedStatement
Adds a set of parameters to this PreparedStatement object's batch of commands.
addBatch(String) - Method in interface java.sql.Statement
Adds the given SQL command to the current list of commands for this Statement object.
addBeanContextMembershipListener(BeanContextMembershipListener) - Method in interface java.beans.beancontext.BeanContext
Adds the specified BeanContextMembershipListener to receive BeanContextMembershipEvents from this BeanContext whenever it adds or removes a child Component(s).
addBeanContextMembershipListener(BeanContextMembershipListener) - Method in class java.beans.beancontext.BeanContextSupport
Adds a BeanContextMembershipListener
addBeanContextServicesListener(BeanContextServicesListener) - Method in interface java.beans.beancontext.BeanContextServices
Adds a BeanContextServicesListener to this BeanContext
addBeanContextServicesListener(BeanContextServicesListener) - Method in class java.beans.beancontext.BeanContextServicesSupport
add a BeanContextServicesListener
addBody() - Method in interface javax.xml.soap.SOAPEnvelope
Creates a SOAPBody object and sets it as the SOAPBody object for this SOAPEnvelope object.
addBodyElement(Name) - Method in interface javax.xml.soap.SOAPBody
Creates a new SOAPBodyElement object with the specified name and adds it to this SOAPBody object.
addBodyElement(QName) - Method in interface javax.xml.soap.SOAPBody
Creates a new SOAPBodyElement object with the specified QName and adds it to this SOAPBody object.
addBooleanAttribute(String, String, boolean, boolean) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl
Adds a new attribute to a previously defined element that will be defined by the enumerated values TRUE and FALSE, with a datatype of DATATYPE_BOOLEAN.
addButtonComponents(Container, Object[], int) - Method in class javax.swing.plaf.basic.BasicOptionPaneUI
Creates the appropriate object to represent each of the objects in buttons and adds it to container.
addCaretListener(CaretListener) - Method in class javax.swing.text.JTextComponent
Adds a caret listener for notification of any changes to the caret.
addCellEditorListener(CellEditorListener) - Method in class javax.swing.AbstractCellEditor
Adds a CellEditorListener to the listener list.
addCellEditorListener(CellEditorListener) - Method in interface javax.swing.CellEditor
Adds a listener to the list that's notified when the editor stops, or cancels editing.
addCellEditorListener(CellEditorListener) - Method in class javax.swing.tree.DefaultTreeCellEditor
Adds the CellEditorListener.
addCertificate(Certificate) - Method in class java.security.Identity
Deprecated.
Adds a certificate for this identity.
addCertPathChecker(PKIXCertPathChecker) - Method in class java.security.cert.PKIXParameters
Adds a PKIXCertPathChecker to the list of certification path checkers.
addCertStore(CertStore) - Method in class java.security.cert.PKIXParameters
Adds a CertStore to the end of the list of CertStores used in finding certificates and CRLs.
addChangeListener(ChangeListener) - Method in class javax.swing.AbstractButton
Adds a ChangeListener to the button.
addChangeListener(ChangeListener) - Method in class javax.swing.AbstractSpinnerModel
Adds a ChangeListener to the model's listener list.
addChangeListener(ChangeListener) - Method in interface javax.swing.BoundedRangeModel
Adds a ChangeListener to the model's listener list.
addChangeListener(ChangeListener) - Method in interface javax.swing.ButtonModel
Adds a ChangeListener to the model.
addChangeListener(ChangeListener) - Method in interface javax.swing.colorchooser.ColorSelectionModel
Adds listener as a listener to changes in the model.
addChangeListener(ChangeListener) - Method in class javax.swing.colorchooser.DefaultColorSelectionModel
Adds a ChangeListener to the model.
addChangeListener(ChangeListener) - Method in class javax.swing.DefaultBoundedRangeModel
Adds a ChangeListener.
addChangeListener(ChangeListener) - Method in class javax.swing.DefaultButtonModel
Adds a ChangeListener to the model.
addChangeListener(ChangeListener) - Method in class javax.swing.DefaultSingleSelectionModel
Adds a ChangeListener to the button.
addChangeListener(ChangeListener) - Method in class javax.swing.JProgressBar
Adds the specified ChangeListener to the progress bar.
addChangeListener(ChangeListener) - Method in class javax.swing.JSlider
Adds a ChangeListener to the slider.
addChangeListener(ChangeListener) - Method in class javax.swing.JSpinner
Adds a listener to the list that is notified each time a change to the model occurs.
addChangeListener(ChangeListener) - Method in class javax.swing.JTabbedPane
Adds a ChangeListener to this tabbedpane.
addChangeListener(ChangeListener) - Method in class javax.swing.JViewport
Adds a ChangeListener to the list that is notified each time the view's size, position, or the viewport's extent size has changed.
addChangeListener(ChangeListener) - Method in class javax.swing.MenuSelectionManager
Adds a ChangeListener to the button.
addChangeListener(ChangeListener) - Method in interface javax.swing.SingleSelectionModel
Adds listener as a listener to changes in the model.
addChangeListener(ChangeListener) - Method in interface javax.swing.SpinnerModel
Adds a ChangeListener to the model's listener list.
addChangeListener(ChangeListener) - Method in interface javax.swing.text.Caret
Adds a listener to track whenever the caret position has been changed.
addChangeListener(ChangeListener) - Method in class javax.swing.text.DefaultCaret
Adds a listener to track whenever the caret position has been changed.
addChangeListener(ChangeListener) - Method in interface javax.swing.text.Style
Adds a listener to track whenever an attribute has been changed.
addChangeListener(ChangeListener) - Method in class javax.swing.text.StyleContext
Adds a listener to track when styles are added or removed.
addChangeListener(ChangeListener) - Method in class javax.swing.text.StyleContext.NamedStyle
Adds a change listener.
addChildElement(String, String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl
Adds an existing element to the list of legal children for a given parent node type.
addChildElement(Name) - Method in interface javax.xml.soap.SOAPElement
Creates a new SOAPElement object initialized with the given Name object and adds the new element to this SOAPElement object.
addChildElement(QName) - Method in interface javax.xml.soap.SOAPElement
Creates a new SOAPElement object initialized with the given QName object and adds the new element to this SOAPElement object.
addChildElement(String) - Method in interface javax.xml.soap.SOAPElement
Creates a new SOAPElement object initialized with the specified local name and adds the new element to this SOAPElement object.
addChildElement(String, String) - Method in interface javax.xml.soap.SOAPElement
Creates a new SOAPElement object initialized with the specified local name and prefix and adds the new element to this SOAPElement object.
addChildElement(String, String, String) - Method in interface javax.xml.soap.SOAPElement
Creates a new SOAPElement object initialized with the specified local name, prefix, and URI and adds the new element to this SOAPElement object.
addChildElement(SOAPElement) - Method in interface javax.xml.soap.SOAPElement
Add a SOAPElement as a child of this SOAPElement instance.
addChoosableFileFilter(FileFilter) - Method in class javax.swing.JFileChooser
Adds a filter to the list of user choosable file filters.
addChooserPanel(AbstractColorChooserPanel) - Method in class javax.swing.JColorChooser
Adds a color chooser panel to the color chooser.
addColumn(TableColumn) - Method in class javax.swing.JTable
Appends aColumn to the end of the array of columns held by this JTable's column model.
addColumn(TableColumn) - Method in class javax.swing.table.DefaultTableColumnModel
Appends aColumn to the end of the tableColumns array.
addColumn(Object) - Method in class javax.swing.table.DefaultTableModel
Adds a column to the model.
addColumn(Object, Vector) - Method in class javax.swing.table.DefaultTableModel
Adds a column to the model.
addColumn(Object, Object[]) - Method in class javax.swing.table.DefaultTableModel
Adds a column to the model.
addColumn(TableColumn) - Method in interface javax.swing.table.TableColumnModel
Appends aColumn to the end of the tableColumns array.
addColumnModelListener(TableColumnModelListener) - Method in class javax.swing.table.DefaultTableColumnModel
Adds a listener for table column model events.
addColumnModelListener(TableColumnModelListener) - Method in interface javax.swing.table.TableColumnModel
Adds a listener for table column model events.
addColumnSelectionInterval(int, int) - Method in class javax.swing.JTable
Adds the columns from index0 to index1, inclusive, to the current selection.
addComponent(Component) - Method in class javax.swing.GroupLayout.Group
Adds a Component to this Group.
addComponent(Component, int, int, int) - Method in class javax.swing.GroupLayout.Group
Adds a Component to this Group with the specified size.
addComponent(Component) - Method in class javax.swing.GroupLayout.ParallelGroup
Adds a Component to this Group.
addComponent(Component, int, int, int) - Method in class javax.swing.GroupLayout.ParallelGroup
Adds a Component to this Group with the specified size.
addComponent(Component, GroupLayout.Alignment) - Method in class javax.swing.GroupLayout.ParallelGroup
Adds a Component to this ParallelGroup with the specified alignment.
addComponent(Component, GroupLayout.Alignment, int, int, int) - Method in class javax.swing.GroupLayout.ParallelGroup
Adds a Component to this ParallelGroup with the specified alignment and size.
addComponent(Component) - Method in class javax.swing.GroupLayout.SequentialGroup
Adds a Component to this Group.
addComponent(boolean, Component) - Method in class javax.swing.GroupLayout.SequentialGroup
Adds a Component to this Group.
addComponent(Component, int, int, int) - Method in class javax.swing.GroupLayout.SequentialGroup
Adds a Component to this Group with the specified size.
addComponent(boolean, Component, int, int, int) - Method in class javax.swing.GroupLayout.SequentialGroup
Adds a Component to this Group with the specified size.
addComponentListener(ComponentListener) - Method in class java.awt.Component
Adds the specified component listener to receive component events from this component.
addConnectionEventListener(ConnectionEventListener) - Method in interface javax.sql.PooledConnection
Registers the given event listener so that it will be notified when an event occurs on this PooledConnection object.
addConnectionNotificationListener(NotificationListener, NotificationFilter, Object) - Method in interface javax.management.remote.JMXConnector
Adds a listener to be informed of changes in connection status.
addConnectionNotificationListener(NotificationListener, NotificationFilter, Object) - Method in class javax.management.remote.rmi.RMIConnector
addConsumer(ImageConsumer) - Method in class java.awt.image.FilteredImageSource
Adds the specified ImageConsumer to the list of consumers interested in data for the filtered image.
addConsumer(ImageConsumer) - Method in interface java.awt.image.ImageProducer
Registers an ImageConsumer with the ImageProducer for access to the image data during a later reconstruction of the Image.
addConsumer(ImageConsumer) - Method in class java.awt.image.MemoryImageSource
Adds an ImageConsumer to the list of consumers interested in data for this image.
addConsumer(ImageConsumer) - Method in class java.awt.image.renderable.RenderableImageProducer
Adds an ImageConsumer to the list of consumers interested in data for this image.
addContainerGap() - Method in class javax.swing.GroupLayout.SequentialGroup
Adds an element representing the preferred gap between an edge the container and components that touch the border of the container.
addContainerGap(int, int) - Method in class javax.swing.GroupLayout.SequentialGroup
Adds an element representing the preferred gap between one edge of the container and the next or previous Component with the specified size.
addContainerListener(ContainerListener) - Method in class java.awt.Container
Adds the specified container listener to receive container events from this container.
addContent(char[], int, int) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader
Adds some text with the current character attributes.
addContent(char[], int, int, boolean) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader
Adds some text with the current character attributes.
addControlButtons() - Method in class javax.swing.plaf.metal.MetalFileChooserUI
addControllerEventListener(ControllerEventListener, int[]) - Method in interface javax.sound.midi.Sequencer
Registers a controller event listener to receive notification whenever the sequencer processes a control-change event of the requested type or types.
addCSSAttribute(MutableAttributeSet, CSS.Attribute, String) - Method in class javax.swing.text.html.StyleSheet
Adds a CSS attribute to the given set.
addCSSAttributeFromHTML(MutableAttributeSet, CSS.Attribute, String) - Method in class javax.swing.text.html.StyleSheet
Adds a CSS attribute to the given set.
addCustomEntriesToTable(UIDefaults) - Method in class javax.swing.plaf.metal.MetalTheme
Adds values specific to this theme to the defaults table.
addCustomEntriesToTable(UIDefaults) - Method in class javax.swing.plaf.metal.OceanTheme
Add this theme's custom entries to the defaults table.
addDetail() - Method in interface javax.xml.soap.SOAPFault
Creates an optional Detail object and sets it as the Detail object for this SOAPFault object.
addDetailEntry(Name) - Method in interface javax.xml.soap.Detail
Creates a new DetailEntry object with the given name and adds it to this Detail object.
addDetailEntry(QName) - Method in interface javax.xml.soap.Detail
Creates a new DetailEntry object with the given QName and adds it to this Detail object.
addDirtyRegion(JComponent, int, int, int, int) - Method in class javax.swing.RepaintManager
Add a component in the list of components that should be refreshed.
addDirtyRegion(Window, int, int, int, int) - Method in class javax.swing.RepaintManager
Adds window to the list of Components that need to be repainted.
addDirtyRegion(Applet, int, int, int, int) - Method in class javax.swing.RepaintManager
Adds applet to the list of Components that need to be repainted.
addDocument(Document) - Method in interface javax.xml.soap.SOAPBody
Adds the root node of the DOM Document to this SOAPBody object.
addDocumentListener(DocumentListener) - Method in class javax.swing.text.AbstractDocument
Adds a document listener for notification of any changes.
addDocumentListener(DocumentListener) - Method in class javax.swing.text.DefaultStyledDocument
Adds a document listener for notification of any changes.
addDocumentListener(DocumentListener) - Method in interface javax.swing.text.Document
Registers the given observer to begin receiving notifications when changes are made to the document.
addDragGestureListener(DragGestureListener) - Method in class java.awt.dnd.DragGestureRecognizer
Register a new DragGestureListener.
addDragSourceListener(DragSourceListener) - Method in class java.awt.dnd.DragSource
Adds the specified DragSourceListener to this DragSource to receive drag source events during drag operations intiated with this DragSource.
addDragSourceListener(DragSourceListener) - Method in class java.awt.dnd.DragSourceContext
Add a DragSourceListener to this DragSourceContext if one has not already been added.
addDragSourceMotionListener(DragSourceMotionListener) - Method in class java.awt.dnd.DragSource
Adds the specified DragSourceMotionListener to this DragSource to receive drag motion events during drag operations intiated with this DragSource.
addDropTargetListener(DropTargetListener) - Method in class java.awt.dnd.DropTarget
Adds a new DropTargetListener (UNICAST SOURCE).
addEdit(UndoableEdit) - Method in class javax.swing.text.AbstractDocument.DefaultDocumentEvent
Adds a document edit.
addEdit(UndoableEdit) - Method in class javax.swing.undo.AbstractUndoableEdit
This default implementation returns false.
addEdit(UndoableEdit) - Method in class javax.swing.undo.CompoundEdit
If this edit is inProgress, accepts anEdit and returns true.
addEdit(UndoableEdit) - Method in interface javax.swing.undo.UndoableEdit
Adds an UndoableEdit to this UndoableEdit.
addEdit(UndoableEdit) - Method in class javax.swing.undo.UndoManager
Adds an UndoableEdit to this UndoManager, if it's possible.
addEditor() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
This public method is implementation specific and should be private.
addElement(E) - Method in class java.util.Vector
Adds the specified component to the end of this vector, increasing its size by one.
addElement(String, String, int) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl
Adds a new element type to this metadata document format with a child policy other than CHILD_POLICY_REPEAT.
addElement(String, String, int, int) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl
Adds a new element type to this metadata document format with a child policy of CHILD_POLICY_REPEAT.
addElement(E) - Method in class javax.swing.DefaultComboBoxModel
addElement(E) - Method in class javax.swing.DefaultListModel
Adds the specified component to the end of this list.
addElement(E) - Method in interface javax.swing.MutableComboBoxModel
Adds an item at the end of the model.
addEntry(Principal, AclEntry) - Method in interface java.security.acl.Acl
Adds an ACL entry to this ACL.
addEventListener(String, EventListener, boolean) - Method in interface org.w3c.dom.events.EventTarget
This method allows the registration of event listeners on the event target.
addExact(int, int) - Static method in class java.lang.Math
Returns the sum of its arguments, throwing an exception if the result overflows an int.
addExact(long, long) - Static method in class java.lang.Math
Returns the sum of its arguments, throwing an exception if the result overflows a long.
addExact(int, int) - Static method in class java.lang.StrictMath
Returns the sum of its arguments, throwing an exception if the result overflows an int.
addExact(long, long) - Static method in class java.lang.StrictMath
Returns the sum of its arguments, throwing an exception if the result overflows a long.
addFault() - Method in interface javax.xml.soap.SOAPBody
Creates a new SOAPFault object and adds it to this SOAPBody object.
addFault(Name, String, Locale) - Method in interface javax.xml.soap.SOAPBody
Creates a new SOAPFault object and adds it to this SOAPBody object.
addFault(QName, String, Locale) - Method in interface javax.xml.soap.SOAPBody
Creates a new SOAPFault object and adds it to this SOAPBody object.
addFault(Name, String) - Method in interface javax.xml.soap.SOAPBody
Creates a new SOAPFault object and adds it to this SOAPBody object.
addFault(QName, String) - Method in interface javax.xml.soap.SOAPBody
Creates a new SOAPFault object and adds it to this SOAPBody object.
addFaultReasonText(String, Locale) - Method in interface javax.xml.soap.SOAPFault
Appends or replaces a Reason Text item containing the specified text message and an xml:lang derived from locale.
addFirst(E) - Method in class java.util.ArrayDeque
Inserts the specified element at the front of this deque.
addFirst(E) - Method in interface java.util.concurrent.BlockingDeque
Inserts the specified element at the front of this deque if it is possible to do so immediately without violating capacity restrictions, throwing an IllegalStateException if no space is currently available.
addFirst(E) - Method in class java.util.concurrent.ConcurrentLinkedDeque
Inserts the specified element at the front of this deque.
addFirst(E) - Method in class java.util.concurrent.LinkedBlockingDeque
addFirst(E) - Method in interface java.util.Deque
Inserts the specified element at the front of this deque if it is possible to do so immediately without violating capacity restrictions, throwing an IllegalStateException if no space is currently available.
addFirst(E) - Method in class java.util.LinkedList
Inserts the specified element at the beginning of this list.
addFlavorForUnencodedNative(String, DataFlavor) - Method in class java.awt.datatransfer.SystemFlavorMap
Adds a mapping from a single String native to a single DataFlavor.
addFlavorListener(FlavorListener) - Method in class java.awt.datatransfer.Clipboard
Registers the specified FlavorListener to receive FlavorEvents from this clipboard.
addFocusListener(FocusListener) - Method in class java.awt.Component.AccessibleAWTComponent
Adds the specified focus listener to receive focus events from this component.
addFocusListener(FocusListener) - Method in class java.awt.Component
Adds the specified focus listener to receive focus events from this component when this component gains input focus.
addFocusListener(FocusListener) - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild
Adds the specified focus listener to receive focus events from this component.
addFocusListener(FocusListener) - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent
Adds the specified focus listener to receive focus events from this component.
addFocusListener(FocusListener) - Method in interface javax.accessibility.AccessibleComponent
Adds the specified focus listener to receive focus events from this component.
addFocusListener(FocusListener) - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild
addFocusListener(FocusListener) - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell
addFocusListener(FocusListener) - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode
addFocusListener(FocusListener) - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
addGap(int) - Method in class javax.swing.GroupLayout.Group
Adds a rigid gap to this Group.
addGap(int, int, int) - Method in class javax.swing.GroupLayout.Group
Adds a gap to this Group with the specified size.
addGap(int) - Method in class javax.swing.GroupLayout.ParallelGroup
Adds a rigid gap to this Group.
addGap(int, int, int) - Method in class javax.swing.GroupLayout.ParallelGroup
Adds a gap to this Group with the specified size.
addGap(int) - Method in class javax.swing.GroupLayout.SequentialGroup
Adds a rigid gap to this Group.
addGap(int, int, int) - Method in class javax.swing.GroupLayout.SequentialGroup
Adds a gap to this Group with the specified size.
addGroup(GroupLayout.Group) - Method in class javax.swing.GroupLayout.Group
Adds a Group to this Group.
addGroup(GroupLayout.Group) - Method in class javax.swing.GroupLayout.ParallelGroup
Adds a Group to this Group.
addGroup(GroupLayout.Alignment, GroupLayout.Group) - Method in class javax.swing.GroupLayout.ParallelGroup
Adds a Group to this ParallelGroup with the specified alignment.
addGroup(GroupLayout.Group) - Method in class javax.swing.GroupLayout.SequentialGroup
Adds a Group to this Group.
addGroup(boolean, GroupLayout.Group) - Method in class javax.swing.GroupLayout.SequentialGroup
Adds a Group to this Group.
addHandler(Handler) - Method in class java.util.logging.Logger
Add a log Handler to receive logging messages.
addHandshakeCompletedListener(HandshakeCompletedListener) - Method in class javax.net.ssl.SSLSocket
Registers an event listener to receive notifications that an SSL handshake has completed on this connection.
addHeader(String, String) - Method in class javax.xml.soap.MimeHeaders
Adds a MimeHeader object with the specified name and value to this MimeHeaders object's list of headers.
addHeader() - Method in interface javax.xml.soap.SOAPEnvelope
Creates a SOAPHeader object and sets it as the SOAPHeader object for this SOAPEnvelope object.
addHeaderElement(Name) - Method in interface javax.xml.soap.SOAPHeader
Creates a new SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.
addHeaderElement(QName) - Method in interface javax.xml.soap.SOAPHeader
Creates a new SOAPHeaderElement object initialized with the specified qname and adds it to this SOAPHeader object.
addHierarchyBoundsListener(HierarchyBoundsListener) - Method in class java.awt.Component
Adds the specified hierarchy bounds listener to receive hierarchy bounds events from this component when the hierarchy to which this container belongs changes.
addHierarchyListener(HierarchyListener) - Method in class java.awt.Component
Adds the specified hierarchy listener to receive hierarchy changed events from this component when the hierarchy to which this container belongs changes.
addHighlight(int, int, Highlighter.HighlightPainter) - Method in class javax.swing.text.DefaultHighlighter
Adds a highlight to the view.
addHighlight(int, int, Highlighter.HighlightPainter) - Method in interface javax.swing.text.Highlighter
Adds a highlight to the view.
addHyperlinkListener(HyperlinkListener) - Method in class javax.swing.JEditorPane
Adds a hyperlink listener for notification of any changes, for example when a link is selected and entered.
addIcon(Container) - Method in class javax.swing.plaf.basic.BasicOptionPaneUI
Creates and adds a JLabel representing the icon returned from getIcon to top.
addIdentity(Identity) - Method in class java.security.IdentityScope
Deprecated.
Adds an identity to this identity scope.
addIfAbsent(E) - Method in class java.util.concurrent.CopyOnWriteArrayList
Appends the element, if not present.
addIIOReadProgressListener(IIOReadProgressListener) - Method in class javax.imageio.ImageReader
Adds an IIOReadProgressListener to the list of registered progress listeners.
addIIOReadUpdateListener(IIOReadUpdateListener) - Method in class javax.imageio.ImageReader
Adds an IIOReadUpdateListener to the list of registered update listeners.
addIIOReadWarningListener(IIOReadWarningListener) - Method in class javax.imageio.ImageReader
Adds an IIOReadWarningListener to the list of registered warning listeners.
addIIOWriteProgressListener(IIOWriteProgressListener) - Method in class javax.imageio.ImageWriter
Adds an IIOWriteProgressListener to the list of registered progress listeners.
addIIOWriteWarningListener(IIOWriteWarningListener) - Method in class javax.imageio.ImageWriter
Adds an IIOWriteWarningListener to the list of registered warning listeners.
addImage(Image, int) - Method in class java.awt.MediaTracker
Adds an image to the list of images being tracked by this media tracker.
addImage(Image, int, int, int) - Method in class java.awt.MediaTracker
Adds a scaled image to the list of images being tracked by this media tracker.
addImpl(Component, Object, int) - Method in class java.awt.Container
Adds the specified component to this container at the specified index.
addImpl(Component, Object, int) - Method in class java.awt.ScrollPane
Adds the specified component to this scroll pane container.
addImpl(Component, Object, int) - Method in class javax.swing.AbstractButton
Adds the specified component to this container at the specified index, refer to Container.addImpl(Component, Object, int) for a complete description of this method.
addImpl(Component, Object, int) - Method in class javax.swing.CellRendererPane
If the specified component is already a child of this then we don't bother doing anything - stacking order doesn't matter for cell renderer components (CellRendererPane doesn't paint anyway).
addImpl(Component, Object, int) - Method in class javax.swing.JApplet
Adds the specified child Component.
addImpl(Component, Object, int) - Method in class javax.swing.JDesktopPane
Adds the specified component to this container at the specified index.
addImpl(Component, Object, int) - Method in class javax.swing.JDialog
Adds the specified child Component.
addImpl(Component, Object, int) - Method in class javax.swing.JFrame
Adds the specified child Component.
addImpl(Component, Object, int) - Method in class javax.swing.JInternalFrame
Adds the specified child Component.
addImpl(Component, Object, int) - Method in class javax.swing.JLayer
This method is not supported by JLayer and always throws UnsupportedOperationException
addImpl(Component, Object, int) - Method in class javax.swing.JLayeredPane
addImpl(Component, Object, int) - Method in class javax.swing.JRootPane
Overridden to enforce the position of the glass component as the zero child.
addImpl(Component, Object, int) - Method in class javax.swing.JSplitPane
Adds the specified component to this split pane.
addImpl(Component, Object, int) - Method in class javax.swing.JToolBar
If a JButton is being added, it is initially set to be disabled.
addImpl(Component, Object, int) - Method in class javax.swing.JViewport
Sets the JViewport's one lightweight child, which can be null.
addImpl(Component, Object, int) - Method in class javax.swing.JWindow
Adds the specified child Component.
addInputMethodListener(InputMethodListener) - Method in class java.awt.Component
Adds the specified input method listener to receive input method events from this component.
addInputMethodListener(InputMethodListener) - Method in class javax.swing.text.JTextComponent
addInternal(EventListener, EventListener) - Static method in class java.awt.AWTEventMulticaster
Returns the resulting multicast listener from adding listener-a and listener-b together.
addInternalFrameListener(InternalFrameListener) - Method in class javax.swing.JInternalFrame
Adds the specified listener to receive internal frame events from this internal frame.
addInvalidComponent(JComponent) - Method in class javax.swing.RepaintManager
Mark the component as in need of layout and queue a runnable for the event dispatching thread that will validate the components first isValidateRoot() ancestor.
addIssuer(X500Principal) - Method in class java.security.cert.X509CRLSelector
Adds a name to the issuerNames criterion.
addIssuerName(String) - Method in class java.security.cert.X509CRLSelector
Denigrated, use X509CRLSelector.addIssuer(X500Principal) or X509CRLSelector.addIssuerName(byte[]) instead.
addIssuerName(byte[]) - Method in class java.security.cert.X509CRLSelector
Adds a name to the issuerNames criterion.
addItem(String) - Method in class java.awt.Choice
Obsolete as of Java 2 platform v1.1.
addItem(String) - Method in class java.awt.List
Deprecated.
replaced by add(String).
addItem(String, int) - Method in class java.awt.List
Deprecated.
replaced by add(String, int).
addItem(E) - Method in class javax.swing.JComboBox
Adds an item to the item list.
addItemListener(ItemListener) - Method in class java.awt.Checkbox
Adds the specified item listener to receive item events from this check box.
addItemListener(ItemListener) - Method in class java.awt.CheckboxMenuItem
Adds the specified item listener to receive item events from this check box menu item.
addItemListener(ItemListener) - Method in class java.awt.Choice
Adds the specified item listener to receive item events from this Choice menu.
addItemListener(ItemListener) - Method in interface java.awt.ItemSelectable
Adds a listener to receive item events when the state of an item is changed by the user.
addItemListener(ItemListener) - Method in class java.awt.List
Adds the specified item listener to receive item events from this list.
addItemListener(ItemListener) - Method in class javax.swing.AbstractButton
Adds an ItemListener to the checkbox.
addItemListener(ItemListener) - Method in interface javax.swing.ButtonModel
Adds an ItemListener to the model.
addItemListener(ItemListener) - Method in class javax.swing.DefaultButtonModel
Adds an ItemListener to the model.
addItemListener(ItemListener) - Method in class javax.swing.JComboBox
Adds an ItemListener.
ADDITION - Static variable in interface org.w3c.dom.events.MutationEvent
The Attr was just added.
AdditionalComments - Static variable in class javax.swing.text.html.HTMLDocument
Document property key value.
addKeyEventDispatcher(KeyEventDispatcher) - Method in class java.awt.KeyboardFocusManager
Adds a KeyEventDispatcher to this KeyboardFocusManager's dispatcher chain.
addKeyEventPostProcessor(KeyEventPostProcessor) - Method in class java.awt.KeyboardFocusManager
Adds a KeyEventPostProcessor to this KeyboardFocusManager's post- processor chain.
addKeyListener(KeyListener) - Method in class java.awt.Component
Adds the specified key listener to receive key events from this component.
addKeymap(String, Keymap) - Static method in class javax.swing.text.JTextComponent
Adds a new keymap into the keymap hierarchy.
addLast(E) - Method in class java.util.ArrayDeque
Inserts the specified element at the end of this deque.
addLast(E) - Method in interface java.util.concurrent.BlockingDeque
Inserts the specified element at the end of this deque if it is possible to do so immediately without violating capacity restrictions, throwing an IllegalStateException if no space is currently available.
addLast(E) - Method in class java.util.concurrent.ConcurrentLinkedDeque
Inserts the specified element at the end of this deque.
addLast(E) - Method in class java.util.concurrent.LinkedBlockingDeque
addLast(E) - Method in interface java.util.Deque
Inserts the specified element at the end of this deque if it is possible to do so immediately without violating capacity restrictions, throwing an IllegalStateException if no space is currently available.
addLast(E) - Method in class java.util.LinkedList
Appends the specified element to the end of this list.
addLayoutComponent(Component, Object) - Method in class java.awt.BorderLayout
Adds the specified component to the layout, using the specified constraint object.
addLayoutComponent(String, Component) - Method in class java.awt.BorderLayout
Deprecated.
replaced by addLayoutComponent(Component, Object).
addLayoutComponent(Component, Object) - Method in class java.awt.CardLayout
Adds the specified component to this card layout's internal table of names.
addLayoutComponent(String, Component) - Method in class java.awt.CardLayout
Deprecated.
replaced by addLayoutComponent(Component, Object).
addLayoutComponent(String, Component) - Method in class java.awt.FlowLayout
Adds the specified component to the layout.
addLayoutComponent(String, Component) - Method in class java.awt.GridBagLayout
Has no effect, since this layout manager does not use a per-component string.
addLayoutComponent(Component, Object) - Method in class java.awt.GridBagLayout
Adds the specified component to the layout, using the specified constraints object.
addLayoutComponent(String, Component) - Method in class java.awt.GridLayout
Adds the specified component with the specified name to the layout.
addLayoutComponent(String, Component) - Method in interface java.awt.LayoutManager
If the layout manager uses a per-component string, adds the component comp to the layout, associating it with the string specified by name.
addLayoutComponent(Component, Object) - Method in interface java.awt.LayoutManager2
Adds the specified component to the layout, using the specified constraint object.
addLayoutComponent(String, Component) - Method in class javax.swing.BoxLayout
Not used by this class.
addLayoutComponent(Component, Object) - Method in class javax.swing.BoxLayout
Not used by this class.
addLayoutComponent(String, Component) - Method in class javax.swing.GroupLayout
Notification that a Component has been added to the parent container.
addLayoutComponent(Component, Object) - Method in class javax.swing.GroupLayout
Notification that a Component has been added to the parent container.
addLayoutComponent(String, Component) - Method in class javax.swing.JRootPane.RootLayout
addLayoutComponent(Component, Object) - Method in class javax.swing.JRootPane.RootLayout
addLayoutComponent(String, Component) - Method in class javax.swing.JSpinner.DefaultEditor
This LayoutManager method does nothing.
addLayoutComponent(String, Component) - Method in class javax.swing.OverlayLayout
Adds the specified component to the layout.
addLayoutComponent(Component, Object) - Method in class javax.swing.OverlayLayout
Adds the specified component to the layout, using the specified constraint object.
addLayoutComponent(String, Component) - Method in class javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager
addLayoutComponent(String, Component) - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane.TitlePaneLayout
addLayoutComponent(String, Component) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.InternalFrameLayout
addLayoutComponent(String, Component) - Method in class javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout
addLayoutComponent(String, Component) - Method in class javax.swing.plaf.basic.BasicScrollBarUI
addLayoutComponent(String, Component) - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider.DividerLayout
addLayoutComponent(String, Component) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager
Adds the component at place.
addLayoutComponent(Component, Object) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager
Adds the specified component to the layout, using the specified constraint object.
addLayoutComponent(String, Component) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout
addLayoutComponent(String, Component) - Method in class javax.swing.ScrollPaneLayout
Adds the specified component to the layout.
addLayoutComponent(String, Component) - Method in class javax.swing.SpringLayout
Has no effect, since this layout manager does not use a per-component string.
addLayoutComponent(Component, Object) - Method in class javax.swing.SpringLayout
If constraints is an instance of SpringLayout.Constraints, associates the constraints with the specified component.
addLayoutComponent(String, Component) - Method in class javax.swing.ViewportLayout
Adds the specified component to the layout.
addLineListener(LineListener) - Method in interface javax.sound.sampled.Line
Adds a listener to this line.
addListDataListener(ListDataListener) - Method in class javax.swing.AbstractListModel
Adds a listener to the list that's notified each time a change to the data model occurs.
addListDataListener(ListDataListener) - Method in interface javax.swing.ListModel
Adds a listener to the list that's notified each time a change to the data model occurs.
addListSelectionListener(ListSelectionListener) - Method in class javax.swing.DefaultListSelectionModel
Add a listener to the list that's notified each time a change to the selection occurs.
addListSelectionListener(ListSelectionListener) - Method in class javax.swing.JList
Adds a listener to the list, to be notified each time a change to the selection occurs; the preferred way of listening for selection state changes.
addListSelectionListener(ListSelectionListener) - Method in interface javax.swing.ListSelectionModel
Add a listener to the list that's notified each time a change to the selection occurs.
addLogger(Logger) - Method in class java.util.logging.LogManager
Add a named logger.
addMailcap(String) - Method in class javax.activation.MailcapCommandMap
Add entries to the registry.
addMember(Principal) - Method in interface java.security.acl.Group
Adds the specified member to the group.
addMenuDragMouseListener(MenuDragMouseListener) - Method in class javax.swing.JMenuItem
Adds a MenuDragMouseListener to the menu item.
addMenuKeyListener(MenuKeyListener) - Method in class javax.swing.JMenuItem
Adds a MenuKeyListener to the menu item.
addMenuKeyListener(MenuKeyListener) - Method in class javax.swing.JPopupMenu
Adds a MenuKeyListener to the popup menu.
addMenuListener(MenuListener) - Method in class javax.swing.JMenu
Adds a listener for menu events.
addMessageComponents(Container, GridBagConstraints, Object, int, boolean) - Method in class javax.swing.plaf.basic.BasicOptionPaneUI
Creates the appropriate object to represent msg and places it into container.
addMetaEventListener(MetaEventListener) - Method in interface javax.sound.midi.Sequencer
Registers a meta-event listener to receive notification whenever a meta-event is encountered in the sequence and processed by the sequencer.
addMimeHeader(String, String) - Method in class javax.xml.soap.AttachmentPart
Adds a MIME header with the specified name and value to this AttachmentPart object.
addMimeHeader(String, String) - Method in class javax.xml.soap.SOAPPart
Creates a MimeHeader object with the specified name and value and adds it to this SOAPPart object.
addMimeTypes(String) - Method in class javax.activation.MimetypesFileTypeMap
Prepend the MIME type values to the registry.
addMouseListener(MouseListener) - Method in class java.awt.Component
Adds the specified mouse listener to receive mouse events from this component.
addMouseListener(MouseListener) - Method in class java.awt.TrayIcon
Adds the specified mouse listener to receive mouse events from this TrayIcon.
addMouseMotionListener(MouseMotionListener) - Method in class java.awt.Component
Adds the specified mouse motion listener to receive mouse motion events from this component.
addMouseMotionListener(MouseMotionListener) - Method in class java.awt.TrayIcon
Adds the specified mouse listener to receive mouse-motion events from this TrayIcon.
addMouseWheelListener(MouseWheelListener) - Method in class java.awt.Component
Adds the specified mouse wheel listener to receive mouse wheel events from this component.
addMtomAttachment(DataHandler, String, String) - Method in class javax.xml.bind.attachment.AttachmentMarshaller
Consider MIME content data for optimized binary storage as an attachment.
addMtomAttachment(byte[], int, int, String, String, String) - Method in class javax.xml.bind.attachment.AttachmentMarshaller
Consider binary data for optimized binary storage as an attachment.
addNamespaceDeclaration(String, String) - Method in interface javax.xml.soap.SOAPElement
Adds a namespace declaration with the specified prefix and URI to this SOAPElement object.
addNamingListener(Name, int, NamingListener) - Method in interface javax.naming.event.EventContext
Adds a listener for receiving naming events fired when the object(s) identified by a target and scope changes.
addNamingListener(String, int, NamingListener) - Method in interface javax.naming.event.EventContext
Adds a listener for receiving naming events fired when the object named by the string target name and scope changes.
addNamingListener(Name, String, SearchControls, NamingListener) - Method in interface javax.naming.event.EventDirContext
Adds a listener for receiving naming events fired when objects identified by the search filter filter at the object named by target are modified.
addNamingListener(String, String, SearchControls, NamingListener) - Method in interface javax.naming.event.EventDirContext
Adds a listener for receiving naming events fired when objects identified by the search filter filter at the object named by the string target name are modified.
addNamingListener(Name, String, Object[], SearchControls, NamingListener) - Method in interface javax.naming.event.EventDirContext
Adds a listener for receiving naming events fired when objects identified by the search filter filter and filter arguments at the object named by the target are modified.
addNamingListener(String, String, Object[], SearchControls, NamingListener) - Method in interface javax.naming.event.EventDirContext
Adds a listener for receiving naming events fired when objects identified by the search filter filter and filter arguments at the object named by the string target name are modified.
addNodeChangeListener(NodeChangeListener) - Method in class java.util.prefs.AbstractPreferences
addNodeChangeListener(NodeChangeListener) - Method in class java.util.prefs.Preferences
Registers the specified listener to receive node change events for this node.
addNotification(String, String, Object, Date, long, long, boolean) - Method in class javax.management.timer.Timer
Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date, period and number of occurrences.
addNotification(String, String, Object, Date, long, long) - Method in class javax.management.timer.Timer
Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date, period and number of occurrences.
addNotification(String, String, Object, Date, long) - Method in class javax.management.timer.Timer
Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date and period and a null number of occurrences.
addNotification(String, String, Object, Date) - Method in class javax.management.timer.Timer
Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date and a null period and number of occurrences.
addNotification(String, String, Object, Date, long, long, boolean) - Method in interface javax.management.timer.TimerMBean
Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date, period and number of occurrences.
addNotification(String, String, Object, Date, long, long) - Method in interface javax.management.timer.TimerMBean
Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date, period and number of occurrences.
addNotification(String, String, Object, Date, long) - Method in interface javax.management.timer.TimerMBean
Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date and period and a null number of occurrences.
addNotification(String, String, Object, Date) - Method in interface javax.management.timer.TimerMBean
Creates a new timer notification with the specified type, message and userData and inserts it into the list of notifications with a given date and a null period and number of occurrences.
addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) - Method in interface javax.management.MBeanServer
Adds a listener to a registered MBean.
addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) - Method in interface javax.management.MBeanServer
Adds a listener to a registered MBean.
addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) - Method in interface javax.management.MBeanServerConnection
Adds a listener to a registered MBean.
addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) - Method in interface javax.management.MBeanServerConnection
Adds a listener to a registered MBean.
addNotificationListener(NotificationListener, NotificationFilter, Object) - Method in class javax.management.MBeanServerDelegate
addNotificationListener(NotificationListener, NotificationFilter, Object) - Method in class javax.management.modelmbean.RequiredModelMBean
Registers an object which implements the NotificationListener interface as a listener.
addNotificationListener(NotificationListener, NotificationFilter, Object) - Method in interface javax.management.NotificationBroadcaster
Adds a listener to this MBean.
addNotificationListener(NotificationListener, NotificationFilter, Object) - Method in class javax.management.NotificationBroadcasterSupport
Adds a listener.
addNotificationListener(ObjectName, ObjectName, MarshalledObject, MarshalledObject, Subject) - Method in interface javax.management.remote.rmi.RMIConnection
Handles the method MBeanServerConnection.addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object).
addNotificationListener(ObjectName, ObjectName, MarshalledObject, MarshalledObject, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl
addNotificationListener(ObjectName, ObjectName, MarshalledObject, MarshalledObject, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub
addNotificationListener(NotificationListener, NotificationFilter, Object) - Method in class javax.management.StandardEmitterMBean
addNotificationListeners(ObjectName[], MarshalledObject[], Subject[]) - Method in interface javax.management.remote.rmi.RMIConnection
Handles the method MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object).
addNotificationListeners(ObjectName[], MarshalledObject[], Subject[]) - Method in class javax.management.remote.rmi.RMIConnectionImpl
addNotificationListeners(ObjectName[], MarshalledObject[], Subject[]) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub
addNotify() - Method in class java.awt.Button
Creates the peer of the button.
addNotify() - Method in class java.awt.Canvas
Creates the peer of the canvas.
addNotify() - Method in class java.awt.Checkbox
Creates the peer of the Checkbox.
addNotify() - Method in class java.awt.CheckboxMenuItem
Creates the peer of the checkbox item.
addNotify() - Method in class java.awt.Choice
Creates the Choice's peer.
addNotify() - Method in class java.awt.Component
Makes this Component displayable by connecting it to a native screen resource.
addNotify() - Method in class java.awt.Container
Makes this Container displayable by connecting it to a native screen resource.
addNotify() - Method in class java.awt.Dialog
Makes this Dialog displayable by connecting it to a native screen resource.
addNotify(ComponentPeer) - Method in class java.awt.dnd.DropTarget
Notify the DropTarget that it has been associated with a Component This method is usually called from java.awt.Component.addNotify() of the Component associated with this DropTarget to notify the DropTarget that a ComponentPeer has been associated with that Component.
addNotify(DropTargetContextPeer) - Method in class java.awt.dnd.DropTargetContext
Called when associated with the DropTargetContextPeer.
addNotify() - Method in class java.awt.FileDialog
Creates the file dialog's peer.
addNotify() - Method in class java.awt.Frame
Makes this Frame displayable by connecting it to a native screen resource.
addNotify() - Method in class java.awt.Label
Creates the peer for this label.
addNotify() - Method in class java.awt.List
Creates the peer for the list.
addNotify() - Method in class java.awt.Menu
Creates the menu's peer.
addNotify() - Method in class java.awt.MenuBar
Creates the menu bar's peer.
addNotify() - Method in class java.awt.MenuItem
Creates the menu item's peer.
addNotify() - Method in class java.awt.Panel
Creates the Panel's peer.
addNotify() - Method in class java.awt.PopupMenu
Creates the popup menu's peer.
addNotify() - Method in class java.awt.Scrollbar
Creates the Scrollbar's peer.
addNotify() - Method in class java.awt.ScrollPane
Creates the scroll pane's peer.
addNotify() - Method in class java.awt.TextArea
Creates the TextArea's peer.
addNotify() - Method in class java.awt.TextComponent
Makes this Component displayable by connecting it to a native screen resource.
addNotify() - Method in class java.awt.TextField
Creates the TextField's peer.
addNotify() - Method in class java.awt.Window
Makes this Window displayable by creating the connection to its native screen resource.
addNotify() - Method in class javax.swing.JComponent
Notifies this component that it now has a parent component.
addNotify() - Method in class javax.swing.JLayer
Notifies this component that it now has a parent component.
addNotify() - Method in class javax.swing.JMenuBar
Overrides JComponent.addNotify to register this menu bar with the current keyboard manager.
addNotify() - Method in class javax.swing.JRootPane
Notifies this component that it now has a parent component.
addNotify() - Method in class javax.swing.JTable
Calls the configureEnclosingScrollPane method.
addNotify() - Method in class javax.swing.JViewport
addNotify() - Method in class javax.swing.plaf.metal.MetalInternalFrameTitlePane
addNotUnderstoodHeaderElement(QName) - Method in interface javax.xml.soap.SOAPHeader
Creates a new NotUnderstood SOAPHeaderElement object initialized with the specified name and adds it to this SOAPHeader object.
addObjectValue(String, Class<T>, boolean, T) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl
Allows an Object reference of a given class type to be stored in nodes implementing the named element.
addObjectValue(String, Class<T>, boolean, T, List<? extends T>) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl
Allows an Object reference of a given class type to be stored in nodes implementing the named element.
addObjectValue(String, Class<T>, T, Comparable<? super T>, Comparable<? super T>, boolean, boolean) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl
Allows an Object reference of a given class type to be stored in nodes implementing the named element.
addObjectValue(String, Class<?>, int, int) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl
Allows an Object reference of a given class type to be stored in nodes implementing the named element.
addObservedObject(ObjectName) - Method in class javax.management.monitor.Monitor
Adds the specified object in the set of observed MBeans, if this object is not already present.
addObservedObject(ObjectName) - Method in interface javax.management.monitor.MonitorMBean
Adds the specified object in the set of observed MBeans.
addObserver(Observer) - Method in class java.util.Observable
Adds an observer to the set of observers for this object, provided that it is not the same as some observer already in the set.
addOwner(Principal, Principal) - Method in interface java.security.acl.Owner
Adds an owner.
addPathToName(int, String) - Method in class java.security.cert.X509CertSelector
Adds a name to the pathToNames criterion.
addPathToName(int, byte[]) - Method in class java.security.cert.X509CertSelector
Adds a name to the pathToNames criterion.
addPermission(Permission) - Method in interface java.security.acl.AclEntry
Adds the specified permission to this ACL entry.
addPoint(int, int) - Method in class java.awt.Polygon
Appends the specified coordinates to this Polygon.
addPopupMenuListener(PopupMenuListener) - Method in class javax.swing.JComboBox
Adds a PopupMenu listener which will listen to notification messages from the popup portion of the combo box.
addPopupMenuListener(PopupMenuListener) - Method in class javax.swing.JPopupMenu
Adds a PopupMenu listener.
addPort(QName, String, String) - Method in class javax.xml.ws.Service
Creates a new port for the service.
addPort(QName, String, String) - Method in class javax.xml.ws.spi.ServiceDelegate
Creates a new port for the service.
addPreferenceChangeListener(PreferenceChangeListener) - Method in class java.util.prefs.AbstractPreferences
addPreferenceChangeListener(PreferenceChangeListener) - Method in class java.util.prefs.Preferences
Registers the specified listener to receive preference change events for this preference node.
addPreferredGap(JComponent, JComponent, LayoutStyle.ComponentPlacement) - Method in class javax.swing.GroupLayout.SequentialGroup
Adds an element representing the preferred gap between two components.
addPreferredGap(JComponent, JComponent, LayoutStyle.ComponentPlacement, int, int) - Method in class javax.swing.GroupLayout.SequentialGroup
Adds an element representing the preferred gap between two components.
addPreferredGap(LayoutStyle.ComponentPlacement) - Method in class javax.swing.GroupLayout.SequentialGroup
Adds an element representing the preferred gap between the nearest components.
addPreferredGap(LayoutStyle.ComponentPlacement, int, int) - Method in class javax.swing.GroupLayout.SequentialGroup
Adds an element representing the preferred gap between the nearest components.
addPrintJobAttributeListener(PrintJobAttributeListener, PrintJobAttributeSet) - Method in interface javax.print.DocPrintJob
Registers a listener for changes in the specified attributes.
addPrintJobListener(PrintJobListener) - Method in interface javax.print.DocPrintJob
Registers a listener for event occurring during this print job.
addPrintServiceAttributeListener(PrintServiceAttributeListener) - Method in interface javax.print.PrintService
Registers a listener for events on this PrintService.
addPropertyChangeListener(PropertyChangeListener) - Method in class java.awt.Component.AccessibleAWTComponent
Adds a PropertyChangeListener to the listener list.
addPropertyChangeListener(PropertyChangeListener) - Method in class java.awt.Component
Adds a PropertyChangeListener to the listener list.
addPropertyChangeListener(String, PropertyChangeListener) - Method in class java.awt.Component
Adds a PropertyChangeListener to the listener list for a specific property.
addPropertyChangeListener(PropertyChangeListener) - Method in class java.awt.Container.AccessibleAWTContainer
Adds a PropertyChangeListener to the listener list.
addPropertyChangeListener(PropertyChangeListener) - Method in class java.awt.Container
Adds a PropertyChangeListener to the listener list.
addPropertyChangeListener(String, PropertyChangeListener) - Method in class java.awt.Container
Adds a PropertyChangeListener to the listener list for a specific property.
addPropertyChangeListener(PropertyChangeListener) - Method in class java.awt.KeyboardFocusManager
Adds a PropertyChangeListener to the listener list.
addPropertyChangeListener(String, PropertyChangeListener) - Method in class java.awt.KeyboardFocusManager
Adds a PropertyChangeListener to the listener list for a specific property.
addPropertyChangeListener(String, PropertyChangeListener) - Method in class java.awt.SystemTray
Adds a PropertyChangeListener to the list of listeners for the specific property.
addPropertyChangeListener(String, PropertyChangeListener) - Method in class java.awt.Toolkit
Adds the specified property change listener for the named desktop property.
addPropertyChangeListener(PropertyChangeListener) - Method in class java.awt.Window
Adds a PropertyChangeListener to the listener list.
addPropertyChangeListener(String, PropertyChangeListener) - Method in class java.awt.Window
Adds a PropertyChangeListener to the listener list for a specific property.
addPropertyChangeListener(String, PropertyChangeListener) - Method in interface java.beans.beancontext.BeanContextChild
Adds a PropertyChangeListener to this BeanContextChild in order to receive a PropertyChangeEvent whenever the specified property has changed.
addPropertyChangeListener(String, PropertyChangeListener) - Method in class java.beans.beancontext.BeanContextChildSupport
Add a PropertyChangeListener for a specific property.
addPropertyChangeListener(PropertyChangeListener) - Method in interface java.beans.Customizer
Register a listener for the PropertyChange event.
addPropertyChangeListener(PropertyChangeListener) - Method in class java.beans.PropertyChangeSupport
Add a PropertyChangeListener to the listener list.
addPropertyChangeListener(String, PropertyChangeListener) - Method in class java.beans.PropertyChangeSupport
Add a PropertyChangeListener for a specific property.
addPropertyChangeListener(PropertyChangeListener) - Method in interface java.beans.PropertyEditor
Adds a listener for the value change.
addPropertyChangeListener(PropertyChangeListener) - Method in class java.beans.PropertyEditorSupport
Adds a listener for the value change.
addPropertyChangeListener(PropertyChangeListener) - Method in interface java.util.jar.Pack200.Packer
Deprecated.
The dependency on PropertyChangeListener creates a significant impediment to future modularization of the Java platform. This method will be removed in a future release. Applications that need to monitor progress of the packer can poll the value of the PROGRESS property instead.
addPropertyChangeListener(PropertyChangeListener) - Method in interface java.util.jar.Pack200.Unpacker
Deprecated.
The dependency on PropertyChangeListener creates a significant impediment to future modularization of the Java platform. This method will be removed in a future release. Applications that need to monitor progress of the unpacker can poll the value of the PROGRESS property instead.
addPropertyChangeListener(PropertyChangeListener) - Method in class java.util.logging.LogManager
Deprecated.
The dependency on PropertyChangeListener creates a significant impediment to future modularization of the Java platform. This method will be removed in a future release. The global LogManager can detect changes to the logging configuration by overridding the readConfiguration method.
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.accessibility.AccessibleContext
Adds a PropertyChangeListener to the listener list.
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.AbstractAction
Adds a PropertyChangeListener to the listener list.
addPropertyChangeListener(PropertyChangeListener) - Method in interface javax.swing.Action
Adds a PropertyChange listener.
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.JComponent.AccessibleJComponent
Adds a PropertyChangeListener to the listener list.
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell
Adds a PropertyChangeListener to the listener list.
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode
Add a PropertyChangeListener to the listener list.
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.JTree.EmptySelectionModel
This is overriden to do nothing; EmptySelectionModel does not allow a selection.
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.plaf.basic.BasicDirectoryModel
Adds a PropertyChangeListener to the listener list.
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.plaf.LayerUI
Adds a PropertyChangeListener to the listener list.
addPropertyChangeListener(String, PropertyChangeListener) - Method in class javax.swing.plaf.LayerUI
Adds a PropertyChangeListener to the listener list for a specific property.
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.SwingWorker
Adds a PropertyChangeListener to the listener list.
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.table.TableColumn
Adds a PropertyChangeListener to the listener list.
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.tree.DefaultTreeSelectionModel
Adds a PropertyChangeListener to the listener list.
addPropertyChangeListener(PropertyChangeListener) - Method in interface javax.swing.tree.TreeSelectionModel
Adds a PropertyChangeListener to the listener list.
addPropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.UIDefaults
Adds a PropertyChangeListener to the listener list.
addPropertyChangeListener(PropertyChangeListener) - Static method in class javax.swing.UIManager
Adds a PropertyChangeListener to the listener list.
addProvider(Provider) - Static method in class java.security.Security
Adds a provider to the next position available.
addProviderAtEnd(Provider, Oid) - Method in class org.ietf.jgss.GSSManager
This method is used to indicate to the GSSManager that the application would like a particular provider to be used if no other provider can be found that supports the given mechanism.
addProviderAtFront(Provider, Oid) - Method in class org.ietf.jgss.GSSManager
This method is used to indicate to the GSSManager that the application would like a particular provider to be used ahead of all others when support is desired for the given mechanism.
addRelation(ObjectName) - Method in class javax.management.relation.RelationService
Adds an MBean created by the user (and registered by him in the MBean Server) as a relation in the Relation Service.
addRelation(ObjectName) - Method in interface javax.management.relation.RelationServiceMBean
Adds an MBean created by the user (and registered by him in the MBean Server) as a relation in the Relation Service.
addRelationType(RelationType) - Method in class javax.management.relation.RelationService
Adds given object as a relation type.
addRelationType(RelationType) - Method in interface javax.management.relation.RelationServiceMBean
Adds given object as a relation type.
addRenderingHints(Map<?, ?>) - Method in class java.awt.Graphics2D
Sets the values of an arbitrary number of preferences for the rendering algorithms.
addRequestProperty(String, String) - Method in class java.net.URLConnection
Adds a general request property specified by a key-value pair.
addResourceBundle(String) - Method in class javax.swing.UIDefaults
Adds a resource bundle to the list of resource bundles that are searched for localized values.
addResponseHeader(String, String) - Method in class javax.xml.ws.spi.http.HttpExchange
Adds a response header with the given name and value.
address() - Method in class java.net.Proxy
Returns the socket address of the proxy, or null if its a direct connection.
address - Variable in class java.net.SocketImpl
The IP address of the remote end of this socket.
ADDRESS - Static variable in class javax.swing.text.html.HTML.Tag
address(String) - Method in class javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder
Sets the address to the W3CEndpointReference instance's wsa:Address.
AddressHelper - Class in org.omg.CosNaming.NamingContextExtPackage
Address is the Host and Port information represented as a String.
AddressHelper() - Constructor for class org.omg.CosNaming.NamingContextExtPackage.AddressHelper
Addressing - Annotation Type in javax.xml.ws.soap
This annotation represents the use of WS-Addressing with either the SOAP 1.1/HTTP or SOAP 1.2/HTTP binding.
AddressingFeature - Class in javax.xml.ws.soap
AddressingFeature represents the use of WS-Addressing with either the SOAP 1.1/HTTP or SOAP 1.2/HTTP binding.
AddressingFeature() - Constructor for class javax.xml.ws.soap.AddressingFeature
Creates and configures an AddressingFeature with the use of addressing requirements.
AddressingFeature(boolean) - Constructor for class javax.xml.ws.soap.AddressingFeature
Creates and configures an AddressingFeature with the use of addressing requirements.
AddressingFeature(boolean, boolean) - Constructor for class javax.xml.ws.soap.AddressingFeature
Creates and configures an AddressingFeature with the use of addressing requirements.
AddressingFeature(boolean, boolean, AddressingFeature.Responses) - Constructor for class javax.xml.ws.soap.AddressingFeature
Creates and configures an AddressingFeature with the use of addressing requirements.
AddressingFeature.Responses - Enum in javax.xml.ws.soap
If addressing is enabled, this property determines if endpoint requires the use of only anonymous responses, or only non-anonymous responses, or all.
addRoleInfo(RoleInfo) - Method in class javax.management.relation.RelationTypeSupport
Add a role info.
addRow(Vector) - Method in class javax.swing.table.DefaultTableModel
Adds a row to the end of the model.
addRow(Object[]) - Method in class javax.swing.table.DefaultTableModel
Adds a row to the end of the model.
addRowSelectionInterval(int, int) - Method in class javax.swing.JTable
Adds the rows from index0 to index1, inclusive, to the current selection.
addRowSet(Joinable) - Method in interface javax.sql.rowset.JoinRowSet
Adds the given RowSet object to this JoinRowSet object.
addRowSet(RowSet, int) - Method in interface javax.sql.rowset.JoinRowSet
Adds the given RowSet object to this JoinRowSet object and sets the designated column as the match column for the RowSet object.
addRowSet(RowSet, String) - Method in interface javax.sql.rowset.JoinRowSet
Adds rowset to this JoinRowSet object and sets the designated column as the match column.
addRowSet(RowSet[], int[]) - Method in interface javax.sql.rowset.JoinRowSet
Adds one or more RowSet objects contained in the given array of RowSet objects to this JoinRowSet object and sets the match column for each of the RowSet objects to the match columns in the given array of column indexes.
addRowSet(RowSet[], String[]) - Method in interface javax.sql.rowset.JoinRowSet
Adds one or more RowSet objects contained in the given array of RowSet objects to this JoinRowSet object and sets the match column for each of the RowSet objects to the match columns in the given array of column names.
addRowSetListener(RowSetListener) - Method in interface javax.sql.RowSet
Registers the given listener so that it will be notified of events that occur on this RowSet object.
addRowSetListener(RowSetListener) - Method in class javax.sql.rowset.BaseRowSet
The listener will be notified whenever an event occurs on this RowSet object.
addRowSorterListener(RowSorterListener) - Method in class javax.swing.RowSorter
Adds a RowSorterListener to receive notification about this RowSorter.
addrs - Variable in class javax.naming.Reference
Contains the addresses contained in this Reference.
addrType - Variable in class javax.naming.RefAddr
Contains the type of this address.
addRule(String) - Method in class javax.swing.text.html.StyleSheet
Adds a set of rules to the sheet.
addSelectionInterval(int, int) - Method in class javax.swing.DefaultListSelectionModel
Changes the selection to be the set union of the current selection and the indices between index0 and index1 inclusive.
addSelectionInterval(int, int) - Method in class javax.swing.JList
Sets the selection to be the union of the specified interval with current selection.
addSelectionInterval(int, int) - Method in class javax.swing.JTree
Adds the specified rows (inclusive) to the selection.
addSelectionInterval(int, int) - Method in interface javax.swing.ListSelectionModel
Changes the selection to be the set union of the current selection and the indices between index0 and index1 inclusive.
addSelectionPath(TreePath) - Method in class javax.swing.JTree
Adds the node identified by the specified TreePath to the current selection.
addSelectionPath(TreePath) - Method in class javax.swing.tree.DefaultTreeSelectionModel
Adds path to the current selection.
addSelectionPath(TreePath) - Method in interface javax.swing.tree.TreeSelectionModel
Adds path to the current selection.
addSelectionPaths(TreePath[]) - Method in class javax.swing.JTree
Adds each path in the array of paths to the current selection.
addSelectionPaths(TreePath[]) - Method in class javax.swing.JTree.EmptySelectionModel
This is overriden to do nothing; EmptySelectionModel does not allow a selection.
addSelectionPaths(TreePath[]) - Method in class javax.swing.tree.DefaultTreeSelectionModel
Adds paths to the current selection.
addSelectionPaths(TreePath[]) - Method in interface javax.swing.tree.TreeSelectionModel
Adds paths to the current selection.
addSelectionRow(int) - Method in class javax.swing.JTree
Adds the path at the specified row to the current selection.
addSelectionRows(int[]) - Method in class javax.swing.JTree
Adds the paths at each of the specified rows to the current selection.
addSeparator() - Method in class java.awt.Menu
Adds a separator line, or a hypen, to the menu at the current position.
addSeparator() - Method in class javax.swing.JMenu
Appends a new separator to the end of the menu.
addSeparator() - Method in class javax.swing.JPopupMenu
Appends a new separator at the end of the menu.
addSeparator() - Method in class javax.swing.JToolBar
Appends a separator of default size to the end of the tool bar.
addSeparator(Dimension) - Method in class javax.swing.JToolBar
Appends a separator of a specified size to the end of the tool bar.
addService(Class, BeanContextServiceProvider) - Method in interface java.beans.beancontext.BeanContextServices
Adds a service to this BeanContext.
addService(Class, BeanContextServiceProvider) - Method in class java.beans.beancontext.BeanContextServicesSupport
add a service
addService(Class, BeanContextServiceProvider, boolean) - Method in class java.beans.beancontext.BeanContextServicesSupport
add a service
addShutdownHook(Thread) - Method in class java.lang.Runtime
Registers a new virtual-machine shutdown hook.
addSingletonComponent(Component, Component) - Method in class javax.swing.ScrollPaneLayout
Removes an existing component.
addSource(Object) - Method in class java.awt.image.renderable.ParameterBlock
Adds an image to end of the list of sources.
addSource(DOMImplementationSource) - Method in class org.w3c.dom.bootstrap.DOMImplementationRegistry
Register an implementation.
addSpecialElement(HTML.Tag, MutableAttributeSet) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader
Adds content that is basically specified entirely in the attribute set.
addStatementEventListener(StatementEventListener) - Method in interface javax.sql.PooledConnection
Registers a StatementEventListener with this PooledConnection object.
addStyle(String, Style) - Method in class javax.swing.JTextPane
Adds a new style into the logical style hierarchy.
addStyle(String, Style) - Method in class javax.swing.text.DefaultStyledDocument
Adds a new style into the logical style hierarchy.
addStyle(String, Style) - Method in class javax.swing.text.StyleContext
Adds a new style into the style hierarchy.
addStyle(String, Style) - Method in interface javax.swing.text.StyledDocument
Adds a new style into the logical style hierarchy.
addStyleSheet(StyleSheet) - Method in class javax.swing.text.html.StyleSheet
Adds the rules from the StyleSheet ss to those of the receiver.
addSubComponents() - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
addSubComponents() - Method in class javax.swing.plaf.metal.MetalInternalFrameTitlePane
Override the parent's method avoid creating a menu bar.
addSubjectAlternativeName(int, String) - Method in class java.security.cert.X509CertSelector
Adds a name to the subjectAlternativeNames criterion.
addSubjectAlternativeName(int, byte[]) - Method in class java.security.cert.X509CertSelector
Adds a name to the subjectAlternativeNames criterion.
addSuppressed(Throwable) - Method in class java.lang.Throwable
Appends the specified exception to the exceptions that were suppressed in order to deliver this exception.
addSwaRefAttachment(DataHandler) - Method in class javax.xml.bind.attachment.AttachmentMarshaller
Add MIME data as an attachment and return attachment's content-id, cid.
addSystemMenuItems(JMenu) - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
addSystemMenuItems(JMenu) - Method in class javax.swing.plaf.metal.MetalInternalFrameTitlePane
Override the parent's method to do nothing.
addTab(String, Icon, Component, String) - Method in class javax.swing.JTabbedPane
Adds a component and tip represented by a title and/or icon, either of which can be null.
addTab(String, Icon, Component) - Method in class javax.swing.JTabbedPane
Adds a component represented by a title and/or icon, either of which can be null.
addTab(String, Component) - Method in class javax.swing.JTabbedPane
Adds a component represented by a title and no icon.
addTableModelListener(TableModelListener) - Method in class javax.swing.table.AbstractTableModel
Adds a listener to the list that's notified each time a change to the data model occurs.
addTableModelListener(TableModelListener) - Method in interface javax.swing.table.TableModel
Adds a listener to the list that is notified each time a change to the data model occurs.
addTag - Variable in class javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction
Tag in HTML to start adding tags from.
addTask(Runnable) - Method in class javax.swing.text.LayoutQueue
Add a task that is not needed immediately because the results are not believed to be visible.
addTextListener(TextListener) - Method in class java.awt.TextComponent
Adds the specified text event listener to receive text events from this text component.
addTextNode(String) - Method in interface javax.xml.soap.SOAPElement
Creates a new Text object initialized with the given String and adds it to this SOAPElement object.
addTileObserver(TileObserver) - Method in class java.awt.image.BufferedImage
Adds a tile observer.
addTileObserver(TileObserver) - Method in interface java.awt.image.WritableRenderedImage
Adds an observer.
addTo(Temporal) - Method in interface java.time.chrono.ChronoPeriod
Adds this period to the specified temporal object.
addTo(Temporal) - Method in class java.time.Duration
Adds this duration to the specified temporal object.
addTo(Temporal) - Method in class java.time.Period
Adds this period to the specified temporal object.
addTo(R, long) - Method in enum java.time.temporal.ChronoUnit
addTo(Temporal) - Method in interface java.time.temporal.TemporalAmount
Adds to the specified temporal object.
addTo(R, long) - Method in interface java.time.temporal.TemporalUnit
Returns a copy of the specified temporal object with the specified period added.
addTo(Calendar) - Method in class javax.xml.datatype.Duration
Adds this duration to a Calendar object.
addTo(Date) - Method in class javax.xml.datatype.Duration
Adds this duration to a Date object.
addToEnvironment(String, Object) - Method in interface javax.naming.Context
Adds a new environment property to the environment of this context.
addToEnvironment(String, Object) - Method in class javax.naming.InitialContext
addToPendingCount(int) - Method in class java.util.concurrent.CountedCompleter
Adds (atomically) the given value to the pending count.
addTransformer(ClassFileTransformer, boolean) - Method in interface java.lang.instrument.Instrumentation
Registers the supplied transformer.
addTransformer(ClassFileTransformer) - Method in interface java.lang.instrument.Instrumentation
Registers the supplied transformer.
addTreeExpansionListener(TreeExpansionListener) - Method in class javax.swing.JTree
Adds a listener for TreeExpansion events.
addTreeModelListener(TreeModelListener) - Method in class javax.swing.tree.DefaultTreeModel
Adds a listener for the TreeModelEvent posted after the tree changes.
addTreeModelListener(TreeModelListener) - Method in interface javax.swing.tree.TreeModel
Adds a listener for the TreeModelEvent posted after the tree changes.
addTreeSelectionListener(TreeSelectionListener) - Method in class javax.swing.JTree
Adds a listener for TreeSelection events.
addTreeSelectionListener(TreeSelectionListener) - Method in class javax.swing.JTree.EmptySelectionModel
This is overriden to do nothing; EmptySelectionModel does not allow a selection.
addTreeSelectionListener(TreeSelectionListener) - Method in class javax.swing.tree.DefaultTreeSelectionModel
Adds x to the list of listeners that are notified each time the set of selected TreePaths changes.
addTreeSelectionListener(TreeSelectionListener) - Method in interface javax.swing.tree.TreeSelectionModel
Adds x to the list of listeners that are notified each time the set of selected TreePaths changes.
addTreeWillExpandListener(TreeWillExpandListener) - Method in class javax.swing.JTree
Adds a listener for TreeWillExpand events.
addUndoableEditListener(UndoableEditListener) - Method in class javax.swing.text.AbstractDocument
Adds an undo listener for notification of any changes.
addUndoableEditListener(UndoableEditListener) - Method in interface javax.swing.text.Document
Registers the given observer to begin receiving notifications when undoable edits are made to the document.
addUndoableEditListener(UndoableEditListener) - Method in class javax.swing.undo.UndoableEditSupport
Registers an UndoableEditListener.
addUnencodedNativeForFlavor(DataFlavor, String) - Method in class java.awt.datatransfer.SystemFlavorMap
Adds a mapping from the specified DataFlavor (and all DataFlavors equal to the specified DataFlavor) to the specified String native.
addUnicodeLocaleAttribute(String) - Method in class java.util.Locale.Builder
Adds a unicode locale attribute, if not already present, otherwise has no effect.
addUpgradeHeaderElement(Iterator) - Method in interface javax.xml.soap.SOAPHeader
Creates a new Upgrade SOAPHeaderElement object initialized with the specified List of supported SOAP URIs and adds it to this SOAPHeader object.
addUpgradeHeaderElement(String[]) - Method in interface javax.xml.soap.SOAPHeader
Creates a new Upgrade SOAPHeaderElement object initialized with the specified array of supported SOAP URIs and adds it to this SOAPHeader object.
addUpgradeHeaderElement(String) - Method in interface javax.xml.soap.SOAPHeader
Creates a new Upgrade SOAPHeaderElement object initialized with the specified supported SOAP URI and adds it to this SOAPHeader object.
addURL(URL) - Method in class java.net.URLClassLoader
Appends the specified URL to the list of URLs to search for classes and resources.
addURL(URL) - Method in class javax.management.loading.MLet
Appends the specified URL to the list of URLs to search for classes and resources.
addURL(String) - Method in class javax.management.loading.MLet
Appends the specified URL to the list of URLs to search for classes and resources.
addURL(URL) - Method in interface javax.management.loading.MLetMBean
Appends the specified URL to the list of URLs to search for classes and resources.
addURL(String) - Method in interface javax.management.loading.MLetMBean
Appends the specified URL to the list of URLs to search for classes and resources.
addVetoableChangeListener(VetoableChangeListener) - Method in class java.awt.KeyboardFocusManager
Adds a VetoableChangeListener to the listener list.
addVetoableChangeListener(String, VetoableChangeListener) - Method in class java.awt.KeyboardFocusManager
Adds a VetoableChangeListener to the listener list for a specific property.
addVetoableChangeListener(String, VetoableChangeListener) - Method in interface java.beans.beancontext.BeanContextChild
Adds a VetoableChangeListener to this BeanContextChild to receive events whenever the specified property changes.
addVetoableChangeListener(String, VetoableChangeListener) - Method in class java.beans.beancontext.BeanContextChildSupport
Add a VetoableChangeListener for a specific property.
addVetoableChangeListener(VetoableChangeListener) - Method in class java.beans.VetoableChangeSupport
Add a VetoableChangeListener to the listener list.
addVetoableChangeListener(String, VetoableChangeListener) - Method in class java.beans.VetoableChangeSupport
Add a VetoableChangeListener for a specific property.
addVetoableChangeListener(VetoableChangeListener) - Method in class javax.swing.JComponent
Adds a VetoableChangeListener to the listener list.
addWindowFocusListener(WindowFocusListener) - Method in class java.awt.Window
Adds the specified window focus listener to receive window events from this window.
addWindowListener(WindowListener) - Method in class java.awt.Window
Adds the specified window listener to receive window events from this window.
addWindowStateListener(WindowStateListener) - Method in class java.awt.Window
Adds the specified window state listener to receive window events from this window.
Adjustable - Interface in java.awt
The interface for objects which have an adjustable numeric value contained within a bounded range of values.
adjustAllocation(Shape) - Method in class javax.swing.text.FieldView
Adjusts the allocation given to the view to be a suitable allocation for a text field.
adjustForGravity(GridBagConstraints, Rectangle) - Method in class java.awt.GridBagLayout
Adjusts the x, y, width, and height fields to the correct values depending on the constraint geometry and pads.
AdjustForGravity(GridBagConstraints, Rectangle) - Method in class java.awt.GridBagLayout
This method is obsolete and supplied for backwards compatibility only; new code should call adjustForGravity instead.
adjustInto(Temporal) - Method in interface java.time.chrono.ChronoLocalDate
Adjusts the specified temporal object to have the same date as this object.
adjustInto(Temporal) - Method in interface java.time.chrono.ChronoLocalDateTime
Adjusts the specified temporal object to have the same date and time as this object.
adjustInto(Temporal) - Method in interface java.time.chrono.Era
Adjusts the specified temporal object to have the same era as this object.
adjustInto(Temporal) - Method in enum java.time.DayOfWeek
Adjusts the specified temporal object to have this day-of-week.
adjustInto(Temporal) - Method in class java.time.Instant
Adjusts the specified temporal object to have this instant.
adjustInto(Temporal) - Method in class java.time.LocalDate
Adjusts the specified temporal object to have the same date as this object.
adjustInto(Temporal) - Method in class java.time.LocalDateTime
Adjusts the specified temporal object to have the same date and time as this object.
adjustInto(Temporal) - Method in class java.time.LocalTime
Adjusts the specified temporal object to have the same time as this object.
adjustInto(Temporal) - Method in enum java.time.Month
Adjusts the specified temporal object to have this month-of-year.
adjustInto(Temporal) - Method in class java.time.MonthDay
Adjusts the specified temporal object to have this month-day.
adjustInto(Temporal) - Method in class java.time.OffsetDateTime
Adjusts the specified temporal object to have the same offset, date and time as this object.
adjustInto(Temporal) - Method in class java.time.OffsetTime
Adjusts the specified temporal object to have the same offset and time as this object.
adjustInto(R, long) - Method in enum java.time.temporal.ChronoField
adjustInto(Temporal) - Method in interface java.time.temporal.TemporalAdjuster
Adjusts the specified temporal object.
adjustInto(R, long) - Method in interface java.time.temporal.TemporalField
Returns a copy of the specified temporal object with the value of this field set.
adjustInto(Temporal) - Method in class java.time.Year
Adjusts the specified temporal object to have this year.
adjustInto(Temporal) - Method in class java.time.YearMonth
Adjusts the specified temporal object to have this year-month.
adjustInto(Temporal) - Method in class java.time.ZoneOffset
Adjusts the specified temporal object to have the same offset as this object.
ADJUSTMENT_EVENT_MASK - Static variable in class java.awt.AWTEvent
The event mask for selecting adjustment events.
ADJUSTMENT_FIRST - Static variable in class java.awt.event.AdjustmentEvent
Marks the first integer id for the range of adjustment event ids.
ADJUSTMENT_LAST - Static variable in class java.awt.event.AdjustmentEvent
Marks the last integer id for the range of adjustment event ids.
ADJUSTMENT_VALUE_CHANGED - Static variable in class java.awt.event.AdjustmentEvent
The adjustment value changed event.
AdjustmentEvent - Class in java.awt.event
The adjustment event emitted by Adjustable objects like Scrollbar and ScrollPane.
AdjustmentEvent(Adjustable, int, int, int) - Constructor for class java.awt.event.AdjustmentEvent
Constructs an AdjustmentEvent object with the specified Adjustable source, event type, adjustment type, and value.
AdjustmentEvent(Adjustable, int, int, int, boolean) - Constructor for class java.awt.event.AdjustmentEvent
Constructs an AdjustmentEvent object with the specified Adjustable source, event type, adjustment type, and value.
AdjustmentListener - Interface in java.awt.event
The listener interface for receiving adjustment events.
adjustmentValueChanged(AdjustmentEvent) - Method in class java.awt.AWTEventMulticaster
Handles the adjustmentValueChanged event by invoking the adjustmentValueChanged methods on listener-a and listener-b.
adjustmentValueChanged(AdjustmentEvent) - Method in interface java.awt.event.AdjustmentListener
Invoked when the value of the adjustable has changed.
adjustRow(FlowView, int, int, int) - Method in class javax.swing.text.FlowView.FlowStrategy
Adjusts the given row if possible to fit within the layout span.
adjustSizes(int, SizeRequirements[]) - Static method in class javax.swing.SizeRequirements
Adjust a specified array of sizes by a given amount.
adjustVisibility(Rectangle) - Method in class javax.swing.text.DefaultCaret
Scrolls the associated view (if necessary) to make the caret visible.
Adler32 - Class in java.util.zip
A class that can be used to compute the Adler-32 checksum of a data stream.
Adler32() - Constructor for class java.util.zip.Adler32
Creates a new Adler32 object.
ADMIN_UIROLE - Static variable in class javax.print.ServiceUIFactory
Denotes a UI which performs an administrative role.
adoptNode(Node) - Method in interface org.w3c.dom.Document
Attempts to adopt a node from another document to this document.
AEADBadTagException - Exception in javax.crypto
This exception is thrown when a Cipher operating in an AEAD mode (such as GCM/CCM) is unable to verify the supplied authentication tag.
AEADBadTagException() - Constructor for exception javax.crypto.AEADBadTagException
Constructs a AEADBadTagException with no detail message.
AEADBadTagException(String) - Constructor for exception javax.crypto.AEADBadTagException
Constructs a AEADBadTagException with the specified detail message.
AEGEAN_NUMBERS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Aegean Numbers" Unicode character block.
AffineTransform - Class in java.awt.geom
The AffineTransform class represents a 2D affine transform that performs a linear mapping from 2D coordinates to other 2D coordinates that preserves the "straightness" and "parallelness" of lines.
AffineTransform() - Constructor for class java.awt.geom.AffineTransform
Constructs a new AffineTransform representing the Identity transformation.
AffineTransform(AffineTransform) - Constructor for class java.awt.geom.AffineTransform
Constructs a new AffineTransform that is a copy of the specified AffineTransform object.
AffineTransform(float, float, float, float, float, float) - Constructor for class java.awt.geom.AffineTransform
Constructs a new AffineTransform from 6 floating point values representing the 6 specifiable entries of the 3x3 transformation matrix.
AffineTransform(float[]) - Constructor for class java.awt.geom.AffineTransform
Constructs a new AffineTransform from an array of floating point values representing either the 4 non-translation entries or the 6 specifiable entries of the 3x3 transformation matrix.
AffineTransform(double, double, double, double, double, double) - Constructor for class java.awt.geom.AffineTransform
Constructs a new AffineTransform from 6 double precision values representing the 6 specifiable entries of the 3x3 transformation matrix.
AffineTransform(double[]) - Constructor for class java.awt.geom.AffineTransform
Constructs a new AffineTransform from an array of double precision values representing either the 4 non-translation entries or the 6 specifiable entries of the 3x3 transformation matrix.
AffineTransformOp - Class in java.awt.image
This class uses an affine transform to perform a linear mapping from 2D coordinates in the source image or Raster to 2D coordinates in the destination image or Raster.
AffineTransformOp(AffineTransform, RenderingHints) - Constructor for class java.awt.image.AffineTransformOp
Constructs an AffineTransformOp given an affine transform.
AffineTransformOp(AffineTransform, int) - Constructor for class java.awt.image.AffineTransformOp
Constructs an AffineTransformOp given an affine transform and the interpolation type.
after(Timestamp) - Method in class java.sql.Timestamp
Indicates whether this Timestamp object is later than the given Timestamp object.
after(Object) - Method in class java.util.Calendar
Returns whether this Calendar represents a time after the time represented by the specified Object.
after(Date) - Method in class java.util.Date
Tests if this date is after the specified date.
AFTER_LAST_LINE - Static variable in class java.awt.BorderLayout
Synonym for PAGE_END.
AFTER_LINE_ENDS - Static variable in class java.awt.BorderLayout
Synonym for LINE_END.
afterExecute(Runnable, Throwable) - Method in class java.util.concurrent.ThreadPoolExecutor
Method invoked upon completion of execution of the given Runnable.
afterLast() - Method in interface java.sql.ResultSet
Moves the cursor to the end of this ResultSet object, just after the last row.
afterMarshal(Object) - Method in class javax.xml.bind.Marshaller.Listener

Callback method invoked after marshalling source to XML.

afterOffset(int) - Static method in class java.awt.font.TextHitInfo
Creates a TextHitInfo at the specified offset, associated with the character after the offset.
afterUnmarshal(Object, Object) - Method in class javax.xml.bind.Unmarshaller.Listener

Callback method invoked after unmarshalling XML data into target.

AIFC - Static variable in class javax.sound.sampled.AudioFileFormat.Type
Specifies an AIFF-C file.
AIFF - Static variable in class javax.sound.sampled.AudioFileFormat.Type
Specifies an AIFF file.
ALAW - Static variable in class javax.sound.sampled.AudioFormat.Encoding
Specifies a-law encoded data.
ALCHEMICAL_SYMBOLS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Alchemical Symbols" Unicode character block.
ALERT - Static variable in class javax.accessibility.AccessibleRole
Object is used to alert the user about something.
AlgorithmConstraints - Interface in java.security
This interface specifies constraints for cryptographic algorithms, keys (key sizes), and other algorithm parameters.
AlgorithmMethod - Interface in javax.xml.crypto
An abstract representation of an algorithm defined in the XML Security specifications.
AlgorithmParameterGenerator - Class in java.security
The AlgorithmParameterGenerator class is used to generate a set of parameters to be used with a certain algorithm.
AlgorithmParameterGenerator(AlgorithmParameterGeneratorSpi, Provider, String) - Constructor for class java.security.AlgorithmParameterGenerator
Creates an AlgorithmParameterGenerator object.
AlgorithmParameterGeneratorSpi - Class in java.security
This class defines the Service Provider Interface (SPI) for the AlgorithmParameterGenerator class, which is used to generate a set of parameters to be used with a certain algorithm.
AlgorithmParameterGeneratorSpi() - Constructor for class java.security.AlgorithmParameterGeneratorSpi
AlgorithmParameters - Class in java.security
This class is used as an opaque representation of cryptographic parameters.
AlgorithmParameters(AlgorithmParametersSpi, Provider, String) - Constructor for class java.security.AlgorithmParameters
Creates an AlgorithmParameters object.
AlgorithmParameterSpec - Interface in java.security.spec
A (transparent) specification of cryptographic parameters.
AlgorithmParametersSpi - Class in java.security
This class defines the Service Provider Interface (SPI) for the AlgorithmParameters class, which is used to manage algorithm parameters.
AlgorithmParametersSpi() - Constructor for class java.security.AlgorithmParametersSpi
aliases() - Method in class java.nio.charset.Charset
Returns a set containing this charset's aliases.
aliases() - Method in class java.security.KeyStore
Lists all the alias names of this keystore.
ALIGN - Static variable in class javax.swing.text.html.HTML.Attribute
ALIGN_BAR - Static variable in class javax.swing.text.TabStop
ALIGN_CENTER - Static variable in class javax.swing.text.StyleConstants
A possible value for paragraph alignment.
ALIGN_CENTER - Static variable in class javax.swing.text.TabStop
Characters following tab are positioned such that all following characters up to next tab/newline are centered around the tabs location.
ALIGN_DECIMAL - Static variable in class javax.swing.text.TabStop
Characters following tab are aligned such that next decimal/tab/newline is at the tab location, very similar to RIGHT_TAB, just includes decimal as additional character to look for.
ALIGN_JUSTIFIED - Static variable in class javax.swing.text.StyleConstants
A possible value for paragraph alignment.
ALIGN_LEFT - Static variable in class javax.swing.text.StyleConstants
A possible value for paragraph alignment.
ALIGN_LEFT - Static variable in class javax.swing.text.TabStop
Character following tab is positioned at location.
ALIGN_RIGHT - Static variable in class javax.swing.text.StyleConstants
A possible value for paragraph alignment.
ALIGN_RIGHT - Static variable in class javax.swing.text.TabStop
Characters following tab are positioned such that all following characters up to next tab/newline end at location.
alignment - Variable in class javax.swing.SizeRequirements
The alignment, specified as a value between 0.0 and 1.0, inclusive.
Alignment - Static variable in class javax.swing.text.StyleConstants
Alignment for the paragraph.
AlignmentAction(String, int) - Constructor for class javax.swing.text.StyledEditorKit.AlignmentAction
Creates a new AlignmentAction.
ALINK - Static variable in class javax.swing.text.html.HTML.Attribute
ALL - Static variable in class java.awt.JobAttributes.DefaultSelectionType
The DefaultSelectionType instance to use for specifying that all pages of the job should be printed.
ALL - Static variable in class java.util.logging.Level
ALL indicates that all messages should be logged.
ALL_COLUMNS - Static variable in class javax.swing.event.TableModelEvent
Specifies all columns in a row or rows.
ALL_RANGES - Static variable in class java.awt.font.NumericShaper
Identifies all ranges, for full contextual shaping.
ALL_STYLES - Static variable in class java.util.Calendar
A style specifier for getDisplayNames indicating names in all styles, such as "January" and "Jan".
ALLBITS - Static variable in interface java.awt.image.ImageObserver
This flag in the infoflags argument to imageUpdate indicates that a static image which was previously drawn is now complete and can be drawn again in its final form.
allHtmlFlavor - Static variable in class java.awt.datatransfer.DataFlavor
Represents a piece of an HTML markup.
allKeys() - Method in class javax.swing.ActionMap
Returns an array of the keys defined in this ActionMap and its parent.
allKeys() - Method in class javax.swing.InputMap
Returns an array of the KeyStrokes defined in this InputMap and its parent.
allMatch(DoublePredicate) - Method in interface java.util.stream.DoubleStream
Returns whether all elements of this stream match the provided predicate.
allMatch(IntPredicate) - Method in interface java.util.stream.IntStream
Returns whether all elements of this stream match the provided predicate.
allMatch(LongPredicate) - Method in interface java.util.stream.LongStream
Returns whether all elements of this stream match the provided predicate.
allMatch(Predicate<? super T>) - Method in interface java.util.stream.Stream
Returns whether all elements of this stream match the provided predicate.
allNotesOff() - Method in interface javax.sound.midi.MidiChannel
Turns off all notes that are currently sounding on this channel.
allocate(int) - Static method in class java.nio.ByteBuffer
Allocates a new byte buffer.
allocate(int) - Static method in class java.nio.CharBuffer
Allocates a new char buffer.
allocate(int) - Static method in class java.nio.DoubleBuffer
Allocates a new double buffer.
allocate(int) - Static method in class java.nio.FloatBuffer
Allocates a new float buffer.
allocate(int) - Static method in class java.nio.IntBuffer
Allocates a new int buffer.
allocate(int) - Static method in class java.nio.LongBuffer
Allocates a new long buffer.
allocate(int) - Static method in class java.nio.ShortBuffer
Allocates a new short buffer.
allocate(XMLStreamReader) - Method in interface javax.xml.stream.util.XMLEventAllocator
This method allocates an event given the current state of the XMLStreamReader.
allocate(XMLStreamReader, XMLEventConsumer) - Method in interface javax.xml.stream.util.XMLEventAllocator
This method allocates an event or set of events given the current state of the XMLStreamReader and adds the event or set of events to the consumer that was passed in.
allocate_slot_id() - Method in interface org.omg.PortableInterceptor.ORBInitInfoOperations
Called to allocate a slot on PortableInterceptor.Current.
allocateArray(int) - Method in class javax.swing.text.GapContent
Allocate an array to store items of the type appropriate (which is determined by the subclass).
allocateDirect(int) - Static method in class java.nio.ByteBuffer
Allocates a new direct byte buffer.
ALLOCATOR - Static variable in class javax.xml.stream.XMLInputFactory
The property used to set/get the implementation of the allocator
allOf(CompletableFuture<?>...) - Static method in class java.util.concurrent.CompletableFuture
Returns a new CompletableFuture that is completed when all of the given CompletableFutures complete.
allOf(Class<E>) - Static method in class java.util.EnumSet
Creates an enum set containing all of the elements in the specified element type.
ALLOW_UNASSIGNED - Static variable in class java.net.IDN
Flag to allow processing of unassigned code points
allowCoreThreadTimeOut(boolean) - Method in class java.util.concurrent.ThreadPoolExecutor
Sets the policy governing whether core threads may time out and terminate if no tasks arrive within the keep-alive time, being replaced if needed when new tasks arrive.
ALLOWED_CLASSNAMES - Static variable in class javax.management.openmbean.OpenType
Deprecated.
Use ALLOWED_CLASSNAMES_LIST instead.
ALLOWED_CLASSNAMES_LIST - Static variable in class javax.management.openmbean.OpenType
List of the fully qualified names of the Java classes allowed for open data values.
allowMultipleSelections() - Method in class javax.security.auth.callback.ChoiceCallback
Get the boolean determining whether multiple selections from the choices list are allowed.
allowsChildren - Variable in class javax.swing.tree.DefaultMutableTreeNode
true if the node is able to have children
allowsCoreThreadTimeOut() - Method in class java.util.concurrent.ThreadPoolExecutor
Returns true if this pool allows core threads to time out and terminate if no tasks arrive within the keepAlive time, being replaced if needed when new tasks arrive.
allowsMultipleSelections() - Method in class java.awt.List
Deprecated.
As of JDK version 1.1, replaced by isMultipleMode().
allowThreadSuspension(boolean) - Method in class java.lang.ThreadGroup
Deprecated.
The definition of this call depends on ThreadGroup.suspend(), which is deprecated. Further, the behavior of this call was never specified.
allowUserInteraction - Variable in class java.net.URLConnection
If true, this URL is being examined in a context in which it makes sense to allow user interactions such as popping up an authentication dialog.
AllPermission - Class in java.security
The AllPermission is a permission that implies all other permissions.
AllPermission() - Constructor for class java.security.AllPermission
Creates a new AllPermission object.
AllPermission(String, String) - Constructor for class java.security.AllPermission
Creates a new AllPermission object.
allProceduresAreCallable() - Method in interface java.sql.DatabaseMetaData
Retrieves whether the current user can call all the procedures returned by the method getProcedures.
allRowsChanged() - Method in class javax.swing.DefaultRowSorter
Invoked when the contents of the underlying model have completely changed.
allRowsChanged() - Method in class javax.swing.RowSorter
Invoked when the contents of the underlying model have completely changed.
allSoundOff() - Method in interface javax.sound.midi.MidiChannel
Immediately turns off all sounding notes on this channel, ignoring the state of the Hold Pedal and the internal decay rate of the current Instrument.
allTablesAreSelectable() - Method in interface java.sql.DatabaseMetaData
Retrieves whether the current user can use all the tables returned by the method getTables in a SELECT statement.
ALPHABETIC_PRESENTATION_FORMS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Alphabetic Presentation Forms" Unicode character block.
AlphaComposite - Class in java.awt
The AlphaComposite class implements basic alpha compositing rules for combining source and destination colors to achieve blending and transparency effects with graphics and images.
AlreadyBound - Exception in org.omg.CosNaming.NamingContextPackage
org/omg/CosNaming/NamingContextPackage/AlreadyBound.java .
AlreadyBound() - Constructor for exception org.omg.CosNaming.NamingContextPackage.AlreadyBound
AlreadyBound(String) - Constructor for exception org.omg.CosNaming.NamingContextPackage.AlreadyBound
AlreadyBoundException - Exception in java.nio.channels
Unchecked exception thrown when an attempt is made to bind the socket a network oriented channel that is already bound.
AlreadyBoundException() - Constructor for exception java.nio.channels.AlreadyBoundException
Constructs an instance of this class.
AlreadyBoundException - Exception in java.rmi
An AlreadyBoundException is thrown if an attempt is made to bind an object in the registry to a name that already has an associated binding.
AlreadyBoundException() - Constructor for exception java.rmi.AlreadyBoundException
Constructs an AlreadyBoundException with no specified detail message.
AlreadyBoundException(String) - Constructor for exception java.rmi.AlreadyBoundException
Constructs an AlreadyBoundException with the specified detail message.
AlreadyBoundHelper - Class in org.omg.CosNaming.NamingContextPackage
org/omg/CosNaming/NamingContextPackage/AlreadyBoundHelper.java .
AlreadyBoundHelper() - Constructor for class org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper
AlreadyBoundHolder - Class in org.omg.CosNaming.NamingContextPackage
org/omg/CosNaming/NamingContextPackage/AlreadyBoundHolder.java .
AlreadyBoundHolder() - Constructor for class org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder
AlreadyBoundHolder(AlreadyBound) - Constructor for class org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder
AlreadyConnectedException - Exception in java.nio.channels
Unchecked exception thrown when an attempt is made to connect a SocketChannel that is already connected.
AlreadyConnectedException() - Constructor for exception java.nio.channels.AlreadyConnectedException
Constructs an instance of this class.
alreadyNotified - Variable in class javax.management.monitor.Monitor
Deprecated.
equivalent to Monitor.alreadyNotifieds[0].
alreadyNotifieds - Variable in class javax.management.monitor.Monitor
Selected monitor errors that have already been notified.
ALT - Static variable in class javax.swing.text.html.HTML.Attribute
ALT_DOWN_MASK - Static variable in class java.awt.event.InputEvent
The Alt key extended modifier constant.
ALT_GRAPH_DOWN_MASK - Static variable in class java.awt.event.InputEvent
The AltGraph key extended modifier constant.
ALT_GRAPH_MASK - Static variable in class java.awt.event.InputEvent
The AltGraph key modifier constant.
ALT_MASK - Static variable in class java.awt.event.ActionEvent
The alt modifier.
ALT_MASK - Static variable in class java.awt.Event
This flag indicates that the Alt key was down when the event occurred.
ALT_MASK - Static variable in class java.awt.event.InputEvent
The Alt key modifier constant.
ALTERNATE - Static variable in class java.util.FormattableFlags
Requires the output to use an alternate form.
alternateAddTag - Variable in class javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction
Alternate tag in HTML to start adding tags from if parentTag is not found and alternateParentTag is found.
alternateParentTag - Variable in class javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction
Alternate Tag to check for in the document if parentTag is not found.
altMetafactory(MethodHandles.Lookup, String, MethodType, Object...) - Static method in class java.lang.invoke.LambdaMetafactory
Facilitates the creation of simple "function objects" that implement one or more interfaces by delegation to a provided MethodHandle, after appropriate type adaptation and partial evaluation of arguments.
altName - Variable in exception javax.naming.CannotProceedException
Contains the name of the resolved object, relative to the context altNameCtx.
altNameCtx - Variable in exception javax.naming.CannotProceedException
Contains the context relative to which altName is specified.
ALWAYS_UPDATE - Static variable in class javax.swing.text.DefaultCaret
Indicates that the caret position is to be always updated accordingly to the document changes regardless whether the document updates are performed on the Event Dispatching Thread or not.
AM - Static variable in class java.util.Calendar
Value of the Calendar.AM_PM field indicating the period of the day from midnight to just before noon.
AM_PM - Static variable in class java.text.DateFormat.Field
Constant identifying the time of day indicator (e.g.
AM_PM - Static variable in class java.util.Calendar
Field number for get and set indicating whether the HOUR is before or after noon.
AM_PM_FIELD - Static variable in class java.text.DateFormat
Useful constant for AM_PM field alignment.
ANCESTOR_ADDED - Static variable in class javax.swing.event.AncestorEvent
An ancestor-component was added to the hierarchy of visible objects (made visible), and is currently being displayed.
ANCESTOR_MOVED - Static variable in class java.awt.event.HierarchyEvent
The event id indicating an ancestor-Container was moved.
ANCESTOR_MOVED - Static variable in class javax.swing.event.AncestorEvent
An ancestor-component changed its position on the screen.
ANCESTOR_REMOVED - Static variable in class javax.swing.event.AncestorEvent
An ancestor-component was removed from the hierarchy of visible objects (hidden) and is no longer being displayed.
ANCESTOR_RESIZED - Static variable in class java.awt.event.HierarchyEvent
The event id indicating an ancestor-Container was resized.
ancestorAdded(AncestorEvent) - Method in interface javax.swing.event.AncestorListener
Called when the source or one of its ancestors is made visible either by setVisible(true) being called or by its being added to the component hierarchy.
AncestorEvent - Class in javax.swing.event
An event reported to a child component that originated from an ancestor in the component hierarchy.
AncestorEvent(JComponent, int, Container, Container) - Constructor for class javax.swing.event.AncestorEvent
Constructs an AncestorEvent object to identify a change in an ancestor-component's display-status.
AncestorListener - Interface in javax.swing.event
AncestorListener Interface to support notification when changes occur to a JComponent or one of its ancestors.
ancestorMoved(HierarchyEvent) - Method in class java.awt.AWTEventMulticaster
Handles the ancestorMoved event by invoking the ancestorMoved methods on listener-a and listener-b.
ancestorMoved(HierarchyEvent) - Method in class java.awt.event.HierarchyBoundsAdapter
Called when an ancestor of the source is moved.
ancestorMoved(HierarchyEvent) - Method in interface java.awt.event.HierarchyBoundsListener
Called when an ancestor of the source is moved.
ancestorMoved(AncestorEvent) - Method in interface javax.swing.event.AncestorListener
Called when either the source or one of its ancestors is moved.
ancestorRemoved(AncestorEvent) - Method in interface javax.swing.event.AncestorListener
Called when the source or one of its ancestors is made invisible either by setVisible(false) being called or by its being remove from the component hierarchy.
ancestorResized(HierarchyEvent) - Method in class java.awt.AWTEventMulticaster
Handles the ancestorResized event by invoking the ancestorResized methods on listener-a and listener-b.
ancestorResized(HierarchyEvent) - Method in class java.awt.event.HierarchyBoundsAdapter
Called when an ancestor of the source is resized.
ancestorResized(HierarchyEvent) - Method in interface java.awt.event.HierarchyBoundsListener
Called when an ancestor of the source is resized.
anchor - Variable in class java.awt.GridBagConstraints
This field is used when the component is smaller than its display area.
ANCHOR_SELECTION_PATH_PROPERTY - Static variable in class javax.swing.JTree
Bound property name for anchor selection path.
ANCIENT_GREEK_MUSICAL_NOTATION - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Ancient Greek Musical Notation" Unicode character block.
ANCIENT_GREEK_NUMBERS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Ancient Greek Numbers" Unicode character block.
ANCIENT_SYMBOLS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Ancient Symbols" Unicode character block.
and(BigInteger) - Method in class java.math.BigInteger
Returns a BigInteger whose value is (this & val).
and(BitSet) - Method in class java.util.BitSet
Performs a logical AND of this target bit set with the argument bit set.
and(BiPredicate<? super T, ? super U>) - Method in interface java.util.function.BiPredicate
Returns a composed predicate that represents a short-circuiting logical AND of this predicate and another.
and(DoublePredicate) - Method in interface java.util.function.DoublePredicate
Returns a composed predicate that represents a short-circuiting logical AND of this predicate and another.
and(IntPredicate) - Method in interface java.util.function.IntPredicate
Returns a composed predicate that represents a short-circuiting logical AND of this predicate and another.
and(LongPredicate) - Method in interface java.util.function.LongPredicate
Returns a composed predicate that represents a short-circuiting logical AND of this predicate and another.
and(Predicate<? super T>) - Method in interface java.util.function.Predicate
Returns a composed predicate that represents a short-circuiting logical AND of this predicate and another.
and(QueryExp, QueryExp) - Static method in class javax.management.Query
Returns a query expression that is the conjunction of two other query expressions.
andFilter(Iterable<? extends RowFilter<? super M, ? super I>>) - Static method in class javax.swing.RowFilter
Returns a RowFilter that includes entries if all of the supplied filters include the entry.
andNot(BigInteger) - Method in class java.math.BigInteger
Returns a BigInteger whose value is (this & ~val).
andNot(BitSet) - Method in class java.util.BitSet
Clears all of the bits in this BitSet whose corresponding bit is set in the specified BitSet.
andThen(BiConsumer<? super T, ? super U>) - Method in interface java.util.function.BiConsumer
Returns a composed BiConsumer that performs, in sequence, this operation followed by the after operation.
andThen(Function<? super R, ? extends V>) - Method in interface java.util.function.BiFunction
Returns a composed function that first applies this function to its input, and then applies the after function to the result.
andThen(Consumer<? super T>) - Method in interface java.util.function.Consumer
Returns a composed Consumer that performs, in sequence, this operation followed by the after operation.
andThen(DoubleConsumer) - Method in interface java.util.function.DoubleConsumer
Returns a composed DoubleConsumer that performs, in sequence, this operation followed by the after operation.
andThen(DoubleUnaryOperator) - Method in interface java.util.function.DoubleUnaryOperator
Returns a composed operator that first applies this operator to its input, and then applies the after operator to the result.
andThen(Function<? super R, ? extends V>) - Method in interface java.util.function.Function
Returns a composed function that first applies this function to its input, and then applies the after function to the result.
andThen(IntConsumer) - Method in interface java.util.function.IntConsumer
Returns a composed IntConsumer that performs, in sequence, this operation followed by the after operation.
andThen(IntUnaryOperator) - Method in interface java.util.function.IntUnaryOperator
Returns a composed operator that first applies this operator to its input, and then applies the after operator to the result.
andThen(LongConsumer) - Method in interface java.util.function.LongConsumer
Returns a composed LongConsumer that performs, in sequence, this operation followed by the after operation.
andThen(LongUnaryOperator) - Method in interface java.util.function.LongUnaryOperator
Returns a composed operator that first applies this operator to its input, and then applies the after operator to the result.
annotateClass(Class<?>) - Method in class java.io.ObjectOutputStream
Subclasses may implement this method to allow class data to be stored in the stream.
AnnotatedArrayType - Interface in java.lang.reflect
AnnotatedArrayType represents the potentially annotated use of an array type, whose component type may itself represent the annotated use of a type.
AnnotatedConstruct - Interface in javax.lang.model
Represents a construct that can be annotated.
AnnotatedElement - Interface in java.lang.reflect
Represents an annotated element of the program currently running in this VM.
AnnotatedParameterizedType - Interface in java.lang.reflect
AnnotatedParameterizedType represents the potentially annotated use of a parameterized type, whose type arguments may themselves represent annotated uses of types.
AnnotatedType - Interface in java.lang.reflect
AnnotatedType represents the potentially annotated use of a type in the program currently running in this VM.
AnnotatedTypeVariable - Interface in java.lang.reflect
AnnotatedTypeVariable represents the potentially annotated use of a type variable, whose declaration may have bounds which themselves represent annotated uses of types.
AnnotatedWildcardType - Interface in java.lang.reflect
AnnotatedWildcardType represents the potentially annotated use of a wildcard type argument, whose upper or lower bounds may themselves represent annotated uses of types.
annotateProxyClass(Class<?>) - Method in class java.io.ObjectOutputStream
Subclasses may implement this method to store custom data in the stream along with descriptors for dynamic proxy classes.
Annotation - Interface in java.lang.annotation
The common interface extended by all annotation types.
Annotation - Class in java.text
An Annotation object is used as a wrapper for a text attribute value if the attribute has annotation characteristics.
Annotation(Object) - Constructor for class java.text.Annotation
Constructs an annotation record with the given value, which may be null.
AnnotationFormatError - Error in java.lang.annotation
Thrown when the annotation parser attempts to read an annotation from a class file and determines that the annotation is malformed.
AnnotationFormatError(String) - Constructor for error java.lang.annotation.AnnotationFormatError
Constructs a new AnnotationFormatError with the specified detail message.
AnnotationFormatError(String, Throwable) - Constructor for error java.lang.annotation.AnnotationFormatError
Constructs a new AnnotationFormatError with the specified detail message and cause.
AnnotationFormatError(Throwable) - Constructor for error java.lang.annotation.AnnotationFormatError
Constructs a new AnnotationFormatError with the specified cause and a detail message of (cause == null ? null : cause.toString()) (which typically contains the class and detail message of cause).
AnnotationMirror - Interface in javax.lang.model.element
Represents an annotation.
annotationType() - Method in interface java.lang.annotation.Annotation
Returns the annotation type of this annotation.
annotationType() - Method in exception java.lang.annotation.IncompleteAnnotationException
Returns the Class object for the annotation type with the missing element.
AnnotationTypeMismatchException - Exception in java.lang.annotation
Thrown to indicate that a program has attempted to access an element of an annotation whose type has changed after the annotation was compiled (or serialized).
AnnotationTypeMismatchException(Method, String) - Constructor for exception java.lang.annotation.AnnotationTypeMismatchException
Constructs an AnnotationTypeMismatchException for the specified annotation type element and found data type.
AnnotationValue - Interface in javax.lang.model.element
Represents a value of an annotation type element.
AnnotationValueVisitor<R,P> - Interface in javax.lang.model.element
A visitor of the values of annotation type elements, using a variant of the visitor design pattern.
ANY - Static variable in interface javax.swing.text.html.parser.DTDConstants
Any - Class in org.omg.CORBA
Serves as a container for any data that can be described in IDL or for any IDL primitive type.
Any() - Constructor for class org.omg.CORBA.Any
AnyHolder - Class in org.omg.CORBA
The Holder for Any.
AnyHolder() - Constructor for class org.omg.CORBA.AnyHolder
Constructs a new AnyHolder object with its value field initialized to null.
AnyHolder(Any) - Constructor for class org.omg.CORBA.AnyHolder
Constructs a new AnyHolder object for the given Any object.
anyMatch(DoublePredicate) - Method in interface java.util.stream.DoubleStream
Returns whether any elements of this stream match the provided predicate.
anyMatch(IntPredicate) - Method in interface java.util.stream.IntStream
Returns whether any elements of this stream match the provided predicate.
anyMatch(LongPredicate) - Method in interface java.util.stream.LongStream
Returns whether any elements of this stream match the provided predicate.
anyMatch(Predicate<? super T>) - Method in interface java.util.stream.Stream
Returns whether any elements of this stream match the provided predicate.
anyOf(CompletableFuture<?>...) - Static method in class java.util.concurrent.CompletableFuture
Returns a new CompletableFuture that is completed when any of the given CompletableFutures complete, with the same result.
AnySeqHelper - Class in org.omg.CORBA
The Helper for AnySeq.
AnySeqHelper() - Constructor for class org.omg.CORBA.AnySeqHelper
AnySeqHelper - Class in org.omg.DynamicAny
org/omg/DynamicAny/AnySeqHelper.java .
AnySeqHelper() - Constructor for class org.omg.DynamicAny.AnySeqHelper
AnySeqHolder - Class in org.omg.CORBA
The Holder for AnySeq.
AnySeqHolder() - Constructor for class org.omg.CORBA.AnySeqHolder
AnySeqHolder(Any[]) - Constructor for class org.omg.CORBA.AnySeqHolder
anySubString(AttributeValueExp, StringValueExp) - Static method in class javax.management.Query
Returns a query expression that represents a matching constraint on a string argument.
AppConfigurationEntry - Class in javax.security.auth.login
This class represents a single LoginModule entry configured for the application specified in the getAppConfigurationEntry(String appName) method in the Configuration class.
AppConfigurationEntry(String, AppConfigurationEntry.LoginModuleControlFlag, Map<String, ?>) - Constructor for class javax.security.auth.login.AppConfigurationEntry
Default constructor for this class.
AppConfigurationEntry.LoginModuleControlFlag - Class in javax.security.auth.login
This class represents whether or not a LoginModule is REQUIRED, REQUISITE, SUFFICIENT or OPTIONAL.
append(Shape, boolean) - Method in class java.awt.geom.Path2D
Appends the geometry of the specified Shape object to the path, possibly connecting the new geometry to the existing path segments with a line segment.
append(PathIterator, boolean) - Method in class java.awt.geom.Path2D
Appends the geometry of the specified PathIterator object to the path, possibly connecting the new geometry to the existing path segments with a line segment.
append(PathIterator, boolean) - Method in class java.awt.geom.Path2D.Double
Appends the geometry of the specified PathIterator object to the path, possibly connecting the new geometry to the existing path segments with a line segment.
append(PathIterator, boolean) - Method in class java.awt.geom.Path2D.Float
Appends the geometry of the specified PathIterator object to the path, possibly connecting the new geometry to the existing path segments with a line segment.
append(Printable, PageFormat) - Method in class java.awt.print.Book
Appends a single page to the end of this Book.
append(Printable, PageFormat, int) - Method in class java.awt.print.Book
Appends numPages pages to the end of this Book.
append(String) - Method in class java.awt.TextArea
Appends the given text to the text area's current text.
append(CharSequence) - Method in class java.io.CharArrayWriter
Appends the specified character sequence to this writer.
append(CharSequence, int, int) - Method in class java.io.CharArrayWriter
Appends a subsequence of the specified character sequence to this writer.
append(char) - Method in class java.io.CharArrayWriter
Appends the specified character to this writer.
append(CharSequence) - Method in class java.io.PrintStream
Appends the specified character sequence to this output stream.
append(CharSequence, int, int) - Method in class java.io.PrintStream
Appends a subsequence of the specified character sequence to this output stream.
append(char) - Method in class java.io.PrintStream
Appends the specified character to this output stream.
append(CharSequence) - Method in class java.io.PrintWriter
Appends the specified character sequence to this writer.
append(CharSequence, int, int) - Method in class java.io.PrintWriter
Appends a subsequence of the specified character sequence to this writer.
append(char) - Method in class java.io.PrintWriter
Appends the specified character to this writer.
append(CharSequence) - Method in class java.io.StringWriter
Appends the specified character sequence to this writer.
append(CharSequence, int, int) - Method in class java.io.StringWriter
Appends a subsequence of the specified character sequence to this writer.
append(char) - Method in class java.io.StringWriter
Appends the specified character to this writer.
append(CharSequence) - Method in class java.io.Writer
Appends the specified character sequence to this writer.
append(CharSequence, int, int) - Method in class java.io.Writer
Appends a subsequence of the specified character sequence to this writer.
append(char) - Method in class java.io.Writer
Appends the specified character to this writer.
append(CharSequence) - Method in interface java.lang.Appendable
Appends the specified character sequence to this Appendable.
append(CharSequence, int, int) - Method in interface java.lang.Appendable
Appends a subsequence of the specified character sequence to this Appendable.
append(char) - Method in interface java.lang.Appendable
Appends the specified character to this Appendable.
append(Object) - Method in class java.lang.StringBuffer
append(String) - Method in class java.lang.StringBuffer
append(StringBuffer) - Method in class java.lang.StringBuffer
Appends the specified StringBuffer to this sequence.
append(CharSequence) - Method in class java.lang.StringBuffer
Appends the specified CharSequence to this sequence.
append(CharSequence, int, int) - Method in class java.lang.StringBuffer
append(char[]) - Method in class java.lang.StringBuffer
append(char[], int, int) - Method in class java.lang.StringBuffer
append(boolean) - Method in class java.lang.StringBuffer
append(char) - Method in class java.lang.StringBuffer
append(int) - Method in class java.lang.StringBuffer
append(long) - Method in class java.lang.StringBuffer
append(float) - Method in class java.lang.StringBuffer
append(double) - Method in class java.lang.StringBuffer
append(Object) - Method in class java.lang.StringBuilder
append(String) - Method in class java.lang.StringBuilder
append(StringBuffer) - Method in class java.lang.StringBuilder
Appends the specified StringBuffer to this sequence.
append(CharSequence) - Method in class java.lang.StringBuilder
append(CharSequence, int, int) - Method in class java.lang.StringBuilder
append(char[]) - Method in class java.lang.StringBuilder
append(char[], int, int) - Method in class java.lang.StringBuilder
append(boolean) - Method in class java.lang.StringBuilder
append(char) - Method in class java.lang.StringBuilder
append(int) - Method in class java.lang.StringBuilder
append(long) - Method in class java.lang.StringBuilder
append(float) - Method in class java.lang.StringBuilder
append(double) - Method in class java.lang.StringBuilder
append(CharSequence) - Method in class java.nio.CharBuffer
Appends the specified character sequence to this buffer (optional operation).
append(CharSequence, int, int) - Method in class java.nio.CharBuffer
Appends a subsequence of the specified character sequence to this buffer (optional operation).
append(char) - Method in class java.nio.CharBuffer
Appends the specified char to this buffer (optional operation).
append(DateTimeFormatter) - Method in class java.time.format.DateTimeFormatterBuilder
Appends all the elements of a formatter to the builder.
append(String) - Method in class javax.swing.JTextArea
Appends the given text to the end of the document.
append(View) - Method in class javax.swing.text.View
Appends a single child view.
Appendable - Interface in java.lang
An object to which char sequences and values can be appended.
appendChild(Node) - Method in class javax.imageio.metadata.IIOMetadataNode
Adds the node newChild to the end of the list of children of this node.
appendChild(Node) - Method in interface org.w3c.dom.Node
Adds the node newChild to the end of the list of children of this node.
appendChronologyId() - Method in class java.time.format.DateTimeFormatterBuilder
Appends the chronology ID, such as 'ISO' or 'ThaiBuddhist', to the formatter.
appendChronologyText(TextStyle) - Method in class java.time.format.DateTimeFormatterBuilder
Appends the chronology name to the formatter.
appendCodePoint(int) - Method in class java.lang.StringBuffer
appendCodePoint(int) - Method in class java.lang.StringBuilder
appendData(String) - Method in interface org.w3c.dom.CharacterData
Append the string to the end of the character data of the node.
appendEvent(InputEvent) - Method in class java.awt.dnd.DragGestureRecognizer
Listeners registered on the Component by this Recognizer shall record all Events that are recognized as part of the series of Events that go to comprise a Drag and Drop initiating gesture via this API.
appendFaultSubcode(QName) - Method in interface javax.xml.soap.SOAPFault
Adds a Subcode to the end of the sequence of Subcodes contained by this SOAPFault.
appendFraction(TemporalField, int, int, boolean) - Method in class java.time.format.DateTimeFormatterBuilder
Appends the fractional value of a date-time field to the formatter.
appendInstant() - Method in class java.time.format.DateTimeFormatterBuilder
Appends an instant using ISO-8601 to the formatter, formatting fractional digits in groups of three.
appendInstant(int) - Method in class java.time.format.DateTimeFormatterBuilder
Appends an instant using ISO-8601 to the formatter with control over the number of fractional digits.
appendLiteral(char) - Method in class java.time.format.DateTimeFormatterBuilder
Appends a character literal to the formatter.
appendLiteral(String) - Method in class java.time.format.DateTimeFormatterBuilder
Appends a string literal to the formatter.
appendLocalized(FormatStyle, FormatStyle) - Method in class java.time.format.DateTimeFormatterBuilder
Appends a localized date-time pattern to the formatter.
appendLocalizedOffset(TextStyle) - Method in class java.time.format.DateTimeFormatterBuilder
Appends the localized zone offset, such as 'GMT+01:00', to the formatter.
appendOffset(String, String) - Method in class java.time.format.DateTimeFormatterBuilder
Appends the zone offset, such as '+01:00', to the formatter.
appendOffsetId() - Method in class java.time.format.DateTimeFormatterBuilder
Appends the zone offset, such as '+01:00', to the formatter.
appendOptional(DateTimeFormatter) - Method in class java.time.format.DateTimeFormatterBuilder
Appends a formatter to the builder which will optionally format/parse.
appendParameterTypes(Class<?>...) - Method in class java.lang.invoke.MethodType
Finds or creates a method type with additional parameter types.
appendParameterTypes(List<Class<?>>) - Method in class java.lang.invoke.MethodType
Finds or creates a method type with additional parameter types.
appendPattern(String) - Method in class java.time.format.DateTimeFormatterBuilder
Appends the elements defined by the specified pattern to the builder.
appendRemainingComponent(String) - Method in exception javax.naming.NamingException
Add name as the last component in remaining name.
appendRemainingComponent(String) - Method in class javax.naming.spi.ResolveResult
Adds a single component to the end of remaining name.
appendRemainingName(Name) - Method in exception javax.naming.NamingException
Add components from 'name' as the last components in remaining name.
appendRemainingName(Name) - Method in class javax.naming.spi.ResolveResult
Adds components to the end of remaining name.
appendReplacement(StringBuffer, String) - Method in class java.util.regex.Matcher
Implements a non-terminal append-and-replace step.
appendTail(StringBuffer) - Method in class java.util.regex.Matcher
Implements a terminal append-and-replace step.
appendText(String) - Method in class java.awt.TextArea
Deprecated.
As of JDK version 1.1, replaced by append(String).
appendText(TemporalField) - Method in class java.time.format.DateTimeFormatterBuilder
Appends the text of a date-time field to the formatter using the full text style.
appendText(TemporalField, TextStyle) - Method in class java.time.format.DateTimeFormatterBuilder
Appends the text of a date-time field to the formatter.
appendText(TemporalField, Map<Long, String>) - Method in class java.time.format.DateTimeFormatterBuilder
Appends the text of a date-time field to the formatter using the specified map to supply the text.
appendTo(File) - Static method in class java.lang.ProcessBuilder.Redirect
Returns a redirect to append to the specified file.
appendToBootstrapClassLoaderSearch(JarFile) - Method in interface java.lang.instrument.Instrumentation
Specifies a JAR file with instrumentation classes to be defined by the bootstrap class loader.
appendToSystemClassLoaderSearch(JarFile) - Method in interface java.lang.instrument.Instrumentation
Specifies a JAR file with instrumentation classes to be defined by the system class loader.
appendValue(TemporalField) - Method in class java.time.format.DateTimeFormatterBuilder
Appends the value of a date-time field to the formatter using a normal output style.
appendValue(TemporalField, int) - Method in class java.time.format.DateTimeFormatterBuilder
Appends the value of a date-time field to the formatter using a fixed width, zero-padded approach.
appendValue(TemporalField, int, int, SignStyle) - Method in class java.time.format.DateTimeFormatterBuilder
Appends the value of a date-time field to the formatter providing full control over formatting.
appendValueReduced(TemporalField, int, int, int) - Method in class java.time.format.DateTimeFormatterBuilder
Appends the reduced value of a date-time field to the formatter.
appendValueReduced(TemporalField, int, int, ChronoLocalDate) - Method in class java.time.format.DateTimeFormatterBuilder
Appends the reduced value of a date-time field to the formatter.
appendZoneId() - Method in class java.time.format.DateTimeFormatterBuilder
Appends the time-zone ID, such as 'Europe/Paris' or '+02:00', to the formatter.
appendZoneOrOffsetId() - Method in class java.time.format.DateTimeFormatterBuilder
Appends the time-zone ID, such as 'Europe/Paris' or '+02:00', to the formatter, using the best available zone ID.
appendZoneRegionId() - Method in class java.time.format.DateTimeFormatterBuilder
Appends the time-zone region ID, such as 'Europe/Paris', to the formatter, rejecting the zone ID if it is a ZoneOffset.
appendZoneText(TextStyle) - Method in class java.time.format.DateTimeFormatterBuilder
Appends the time-zone name, such as 'British Summer Time', to the formatter.
appendZoneText(TextStyle, Set<ZoneId>) - Method in class java.time.format.DateTimeFormatterBuilder
Appends the time-zone name, such as 'British Summer Time', to the formatter.
Applet - Class in java.applet
An applet is a small program that is intended not to be run on its own, but rather to be embedded inside another application.
Applet() - Constructor for class java.applet.Applet
Constructs a new Applet.
APPLET - Static variable in interface javax.naming.Context
Constant that holds the name of the environment property for specifying an applet for the initial context constructor to use when searching for other properties.
APPLET - Static variable in class javax.swing.text.html.HTML.Tag
applet - Variable in class javax.swing.text.html.parser.DTD
Applet.AccessibleApplet - Class in java.applet
This class implements accessibility support for the Applet class.
AppletContext - Interface in java.applet
This interface corresponds to an applet's environment: the document containing the applet and the other applets in the same document.
AppletInitializer - Interface in java.beans
This interface is designed to work in collusion with java.beans.Beans.instantiate.
appletResize(int, int) - Method in interface java.applet.AppletStub
Called when the applet wants to be resized.
AppletStub - Interface in java.applet
When an applet is first created, an applet stub is attached to it using the applet's setStub method.
ApplicationException - Exception in org.omg.CORBA.portable
This class is used for reporting application level exceptions between ORBs and stubs.
ApplicationException(String, InputStream) - Constructor for exception org.omg.CORBA.portable.ApplicationException
Constructs an ApplicationException from the CORBA repository ID of the exception and an input stream from which the exception data can be read as its parameters.
apply(T, U) - Method in interface java.util.function.BiFunction
Applies this function to the given arguments.
apply(double) - Method in interface java.util.function.DoubleFunction
Applies this function to the given argument.
apply(T) - Method in interface java.util.function.Function
Applies this function to the given argument.
apply(int) - Method in interface java.util.function.IntFunction
Applies this function to the given argument.
apply(long) - Method in interface java.util.function.LongFunction
Applies this function to the given argument.
apply(ObjectName) - Method in class javax.management.AttributeValueExp
Applies the AttributeValueExp on an MBean.
apply(ObjectName) - Method in class javax.management.ObjectName
Test whether this ObjectName, which may be a pattern, matches another ObjectName.
apply(ObjectName) - Method in interface javax.management.QueryExp
Applies the QueryExp on an MBean.
apply(ObjectName) - Method in class javax.management.StringValueExp
Applies the ValueExp on a MBean.
apply(ObjectName) - Method in interface javax.management.ValueExp
Applies the ValueExp on a MBean.
APPLY_REVERB - Static variable in class javax.sound.sampled.BooleanControl.Type
Represents a control for whether reverberation is applied to a line.
applyAsDouble(double, double) - Method in interface java.util.function.DoubleBinaryOperator
Applies this operator to the given operands.
applyAsDouble(double) - Method in interface java.util.function.DoubleUnaryOperator
Applies this operator to the given operand.
applyAsDouble(int) - Method in interface java.util.function.IntToDoubleFunction
Applies this function to the given argument.
applyAsDouble(long) - Method in interface java.util.function.LongToDoubleFunction
Applies this function to the given argument.
applyAsDouble(T, U) - Method in interface java.util.function.ToDoubleBiFunction
Applies this function to the given arguments.
applyAsDouble(T) - Method in interface java.util.function.ToDoubleFunction
Applies this function to the given argument.
applyAsInt(double) - Method in interface java.util.function.DoubleToIntFunction
Applies this function to the given argument.
applyAsInt(int, int) - Method in interface java.util.function.IntBinaryOperator
Applies this operator to the given operands.
applyAsInt(int) - Method in interface java.util.function.IntUnaryOperator
Applies this operator to the given operand.
applyAsInt(long) - Method in interface java.util.function.LongToIntFunction
Applies this function to the given argument.
applyAsInt(T, U) - Method in interface java.util.function.ToIntBiFunction
Applies this function to the given arguments.
applyAsInt(T) - Method in interface java.util.function.ToIntFunction
Applies this function to the given argument.
applyAsLong(double) - Method in interface java.util.function.DoubleToLongFunction
Applies this function to the given argument.
applyAsLong(int) - Method in interface java.util.function.IntToLongFunction
Applies this function to the given argument.
applyAsLong(long, long) - Method in interface java.util.function.LongBinaryOperator
Applies this operator to the given operands.
applyAsLong(long) - Method in interface java.util.function.LongUnaryOperator
Applies this operator to the given operand.
applyAsLong(T, U) - Method in interface java.util.function.ToLongBiFunction
Applies this function to the given arguments.
applyAsLong(T) - Method in interface java.util.function.ToLongFunction
Applies this function to the given argument.
applyComponentOrientation(ComponentOrientation) - Method in class java.awt.Component
Sets the ComponentOrientation property of this component and all components contained within it.
applyComponentOrientation(ComponentOrientation) - Method in class java.awt.Container
Sets the ComponentOrientation property of this container and all components contained within it.
applyComponentOrientation(ComponentOrientation) - Method in class javax.swing.JMenu
Sets the ComponentOrientation property of this menu and all components contained within it.
applyLocalizedPattern(String) - Method in class java.text.DecimalFormat
Apply the given pattern to this Format object.
applyLocalizedPattern(String) - Method in class java.text.SimpleDateFormat
Applies the given localized pattern string to this date format.
applyPattern(String) - Method in class java.text.ChoiceFormat
Sets the pattern.
applyPattern(String) - Method in class java.text.DecimalFormat
Apply the given pattern to this Format object.
applyPattern(String) - Method in class java.text.MessageFormat
Sets the pattern used by this message format.
applyPattern(String) - Method in class java.text.SimpleDateFormat
Applies the given pattern string to this date format.
applyPropertyChange(PropertyChangeEvent, JLayer<? extends V>) - Method in class javax.swing.plaf.LayerUI
Notifies the LayerUI when any of its property are changed and enables updating every JLayer this LayerUI instance is set to.
applyResourceBundle(ResourceBundle) - Method in class java.awt.Window
Deprecated.
As of J2SE 1.4, replaced by Component.applyComponentOrientation.
applyResourceBundle(String) - Method in class java.awt.Window
Deprecated.
As of J2SE 1.4, replaced by Component.applyComponentOrientation.
applyToEither(CompletionStage<? extends T>, Function<? super T, U>) - Method in class java.util.concurrent.CompletableFuture
applyToEither(CompletionStage<? extends T>, Function<? super T, U>) - Method in interface java.util.concurrent.CompletionStage
Returns a new CompletionStage that, when either this or the other given stage complete normally, is executed with the corresponding result as argument to the supplied function.
applyToEitherAsync(CompletionStage<? extends T>, Function<? super T, U>) - Method in class java.util.concurrent.CompletableFuture
applyToEitherAsync(CompletionStage<? extends T>, Function<? super T, U>, Executor) - Method in class java.util.concurrent.CompletableFuture
applyToEitherAsync(CompletionStage<? extends T>, Function<? super T, U>) - Method in interface java.util.concurrent.CompletionStage
Returns a new CompletionStage that, when either this or the other given stage complete normally, is executed using this stage's default asynchronous execution facility, with the corresponding result as argument to the supplied function.
applyToEitherAsync(CompletionStage<? extends T>, Function<? super T, U>, Executor) - Method in interface java.util.concurrent.CompletionStage
Returns a new CompletionStage that, when either this or the other given stage complete normally, is executed using the supplied executor, with the corresponding result as argument to the supplied function.
appRandom - Variable in class java.security.SignatureSpi
Application-specified source of randomness.
APPROVE_BUTTON_MNEMONIC_CHANGED_PROPERTY - Static variable in class javax.swing.JFileChooser
Identifies change in the mnemonic for the approve (yes, ok) button.
APPROVE_BUTTON_TEXT_CHANGED_PROPERTY - Static variable in class javax.swing.JFileChooser
Identifies change in the text on the approve (yes, ok) button.
APPROVE_BUTTON_TOOL_TIP_TEXT_CHANGED_PROPERTY - Static variable in class javax.swing.JFileChooser
Identifies change in the tooltip text for the approve (yes, ok) button.
APPROVE_OPTION - Static variable in class javax.swing.JFileChooser
Return value if approve (yes, ok) is chosen.
APPROVE_SELECTION - Static variable in class javax.swing.JFileChooser
Instruction to approve the current selection (same as pressing yes or ok).
approveSelection() - Method in class javax.swing.JFileChooser
Called by the UI when the user hits the Approve button (labeled "Open" or "Save", by default).
ApproveSelectionAction() - Constructor for class javax.swing.plaf.basic.BasicFileChooserUI.ApproveSelectionAction
APRIL - Static variable in class java.util.Calendar
Value of the Calendar.MONTH field indicating the fourth month of the year in the Gregorian and Julian calendars.
APRIL - Static variable in class javax.xml.datatype.DatatypeConstants
Value for fourth month of year.
ARABIC - Static variable in class java.awt.font.NumericShaper
Identifies the ARABIC range and decimal base.
ARABIC - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Arabic" Unicode character block.
ARABIC_EXTENDED_A - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Arabic Extended-A" Unicode character block.
ARABIC_MATHEMATICAL_ALPHABETIC_SYMBOLS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Arabic Mathematical Alphabetic Symbols" Unicode character block.
ARABIC_PRESENTATION_FORMS_A - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Arabic Presentation Forms-A" Unicode character block.
ARABIC_PRESENTATION_FORMS_B - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Arabic Presentation Forms-B" Unicode character block.
ARABIC_SUPPLEMENT - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Arabic Supplement" Unicode character block.
Arc2D - Class in java.awt.geom
Arc2D is the abstract superclass for all objects that store a 2D arc defined by a framing rectangle, start angle, angular extent (length of the arc), and a closure type (OPEN, CHORD, or PIE).
Arc2D() - Constructor for class java.awt.geom.Arc2D
This is an abstract class that cannot be instantiated directly.
Arc2D(int) - Constructor for class java.awt.geom.Arc2D
This is an abstract class that cannot be instantiated directly.
Arc2D.Double - Class in java.awt.geom
This class defines an arc specified in double precision.
Arc2D.Float - Class in java.awt.geom
This class defines an arc specified in float precision.
archeight - Variable in class java.awt.geom.RoundRectangle2D.Double
The height of the arc that rounds off the corners.
archeight - Variable in class java.awt.geom.RoundRectangle2D.Float
The height of the arc that rounds off the corners.
ARCHIVE - Static variable in class javax.swing.text.html.HTML.Attribute
arcwidth - Variable in class java.awt.geom.RoundRectangle2D.Double
The width of the arc that rounds off the corners.
arcwidth - Variable in class java.awt.geom.RoundRectangle2D.Float
The width of the arc that rounds off the corners.
Area - Class in java.awt.geom
An Area object stores and manipulates a resolution-independent description of an enclosed area of 2-dimensional space.
Area() - Constructor for class java.awt.geom.Area
Default constructor which creates an empty area.
Area(Shape) - Constructor for class java.awt.geom.Area
The Area class creates an area geometry from the specified Shape object.
AREA - Static variable in class javax.swing.text.html.HTML.Tag
AreaAveragingScaleFilter - Class in java.awt.image
An ImageFilter class for scaling images using a simple area averaging algorithm that produces smoother results than the nearest neighbor algorithm.
AreaAveragingScaleFilter(int, int) - Constructor for class java.awt.image.AreaAveragingScaleFilter
Constructs an AreaAveragingScaleFilter that scales the pixels from its source Image as specified by the width and height parameters.
areExtraMouseButtonsEnabled() - Method in class java.awt.Toolkit
Reports whether events from extra mouse buttons are allowed to be processed and posted into EventQueue.
areFieldsSet - Variable in class java.util.Calendar
True if fields[] are in sync with the currently set time.
areFocusTraversalKeysSet(int) - Method in class java.awt.Component
Returns whether the Set of focus traversal keys for the given focus traversal operation has been explicitly defined for this Component.
areFocusTraversalKeysSet(int) - Method in class java.awt.Container
Returns whether the Set of focus traversal keys for the given focus traversal operation has been explicitly defined for this Container.
areNew - Variable in class javax.swing.event.TreeSelectionEvent
For each path identifies if that path is in fact new.
arePathsContiguous(TreePath[]) - Method in class javax.swing.tree.DefaultTreeSelectionModel
Returns true if the paths are contiguous, or this object has no RowMapper.
areTablesSet() - Method in class javax.imageio.plugins.jpeg.JPEGImageReadParam
Returns true if tables are currently set.
areTablesSet() - Method in class javax.imageio.plugins.jpeg.JPEGImageWriteParam
Returns true if tables are currently set.
arg - Variable in class java.awt.Event
An arbitrary argument of the event.
ARG_IN - Interface in org.omg.CORBA
Signifies an "input" argument to an invocation, meaning that the argument is being passed from the client to the server.
ARG_INOUT - Interface in org.omg.CORBA
Signifies an argument used for both input and output in an invocation, meaning that the argument is being passed from the client to the server and then back from the server to the client.
ARG_OUT - Interface in org.omg.CORBA
A constant that signifies an "output" argument to an invocation, meaning that the argument is being passed from the server to the client.
ARGUMENT - Static variable in class java.text.MessageFormat.Field
Constant identifying a portion of a message that was generated from an argument passed into formatToCharacterIterator.
argument - Variable in class org.omg.Dynamic.Parameter
arguments() - Method in class org.omg.CORBA.Request
Retrieves the NVList object containing the arguments to the method being invoked.
arguments(NVList) - Method in class org.omg.CORBA.ServerRequest
Specifies method parameter types and retrieves "in" and "inout" argument values.
arguments() - Method in interface org.omg.PortableInterceptor.ORBInitInfoOperations
Returns the arguments passed to ORB.init.
arguments() - Method in interface org.omg.PortableInterceptor.RequestInfoOperations
Returns an array of Parameter objects, containing the arguments on the operation being invoked.
ARGV - Static variable in interface javax.script.ScriptEngine
Reserved key for a named value that passes an array of positional arguments to a script.
ArithmeticException - Exception in java.lang
Thrown when an exceptional arithmetic condition has occurred.
ArithmeticException() - Constructor for exception java.lang.ArithmeticException
Constructs an ArithmeticException with no detail message.
ArithmeticException(String) - Constructor for exception java.lang.ArithmeticException
Constructs an ArithmeticException with the specified detail message.
ARMED - Static variable in class javax.accessibility.AccessibleState
Indicates that the object is armed.
ARMED - Static variable in class javax.swing.DefaultButtonModel
Identifies the "armed" bit in the bitmask, which indicates partial commitment towards choosing/triggering the button.
ARMENIAN - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Armenian" Unicode character block.
arrangeGrid(Container) - Method in class java.awt.GridBagLayout
Lays out the grid.
ArrangeGrid(Container) - Method in class java.awt.GridBagLayout
This method is obsolete and supplied for backwards compatibility only; new code should call arrangeGrid instead.
Array - Class in java.lang.reflect
The Array class provides static methods to dynamically create and access Java arrays.
array() - Method in class java.nio.Buffer
Returns the array that backs this buffer (optional operation).
array() - Method in class java.nio.ByteBuffer
Returns the byte array that backs this buffer (optional operation).
array() - Method in class java.nio.CharBuffer
Returns the char array that backs this buffer (optional operation).
array() - Method in class java.nio.DoubleBuffer
Returns the double array that backs this buffer (optional operation).
array() - Method in class java.nio.FloatBuffer
Returns the float array that backs this buffer (optional operation).
array() - Method in class java.nio.IntBuffer
Returns the int array that backs this buffer (optional operation).
array() - Method in class java.nio.LongBuffer
Returns the long array that backs this buffer (optional operation).
array() - Method in class java.nio.ShortBuffer
Returns the short array that backs this buffer (optional operation).
Array - Interface in java.sql
The mapping in the Java programming language for the SQL type ARRAY.
ARRAY - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type ARRAY.
array - Variable in class javax.swing.text.Segment
This is the array containing the text of interest.
ArrayBlockingQueue<E> - Class in java.util.concurrent
A bounded blocking queue backed by an array.
ArrayBlockingQueue(int) - Constructor for class java.util.concurrent.ArrayBlockingQueue
Creates an ArrayBlockingQueue with the given (fixed) capacity and default access policy.
ArrayBlockingQueue(int, boolean) - Constructor for class java.util.concurrent.ArrayBlockingQueue
Creates an ArrayBlockingQueue with the given (fixed) capacity and the specified access policy.
ArrayBlockingQueue(int, boolean, Collection<? extends E>) - Constructor for class java.util.concurrent.ArrayBlockingQueue
Creates an ArrayBlockingQueue with the given (fixed) capacity, the specified access policy and initially containing the elements of the given collection, added in traversal order of the collection's iterator.
arraycopy(Object, int, Object, int, int) - Static method in class java.lang.System
Copies an array from the specified source array, beginning at the specified position, to the specified position of the destination array.
ArrayDeque<E> - Class in java.util
Resizable-array implementation of the Deque interface.
ArrayDeque() - Constructor for class java.util.ArrayDeque
Constructs an empty array deque with an initial capacity sufficient to hold 16 elements.
ArrayDeque(int) - Constructor for class java.util.ArrayDeque
Constructs an empty array deque with an initial capacity sufficient to hold the specified number of elements.
ArrayDeque(Collection<? extends E>) - Constructor for class java.util.ArrayDeque
Constructs a deque containing the elements of the specified collection, in the order they are returned by the collection's iterator.
arrayElementGetter(Class<?>) - Static method in class java.lang.invoke.MethodHandles
Produces a method handle giving read access to elements of an array.
arrayElementSetter(Class<?>) - Static method in class java.lang.invoke.MethodHandles
Produces a method handle giving write access to elements of an array.
ArrayIndexOutOfBoundsException - Exception in java.lang
Thrown to indicate that an array has been accessed with an illegal index.
ArrayIndexOutOfBoundsException() - Constructor for exception java.lang.ArrayIndexOutOfBoundsException
Constructs an ArrayIndexOutOfBoundsException with no detail message.
ArrayIndexOutOfBoundsException(int) - Constructor for exception java.lang.ArrayIndexOutOfBoundsException
Constructs a new ArrayIndexOutOfBoundsException class with an argument indicating the illegal index.
ArrayIndexOutOfBoundsException(String) - Constructor for exception java.lang.ArrayIndexOutOfBoundsException
Constructs an ArrayIndexOutOfBoundsException class with the specified detail message.
ArrayList<E> - Class in java.util
Resizable-array implementation of the List interface.
ArrayList(int) - Constructor for class java.util.ArrayList
Constructs an empty list with the specified initial capacity.
ArrayList() - Constructor for class java.util.ArrayList
Constructs an empty list with an initial capacity of ten.
ArrayList(Collection<? extends E>) - Constructor for class java.util.ArrayList
Constructs a list containing the elements of the specified collection, in the order they are returned by the collection's iterator.
arrayOffset() - Method in class java.nio.Buffer
Returns the offset within this buffer's backing array of the first element of the buffer (optional operation).
arrayOffset() - Method in class java.nio.ByteBuffer
Returns the offset within this buffer's backing array of the first element of the buffer (optional operation).
arrayOffset() - Method in class java.nio.CharBuffer
Returns the offset within this buffer's backing array of the first element of the buffer (optional operation).
arrayOffset() - Method in class java.nio.DoubleBuffer
Returns the offset within this buffer's backing array of the first element of the buffer (optional operation).
arrayOffset() - Method in class java.nio.FloatBuffer
Returns the offset within this buffer's backing array of the first element of the buffer (optional operation).
arrayOffset() - Method in class java.nio.IntBuffer
Returns the offset within this buffer's backing array of the first element of the buffer (optional operation).
arrayOffset() - Method in class java.nio.LongBuffer
Returns the offset within this buffer's backing array of the first element of the buffer (optional operation).
arrayOffset() - Method in class java.nio.ShortBuffer
Returns the offset within this buffer's backing array of the first element of the buffer (optional operation).
Arrays - Class in java.util
This class contains various methods for manipulating arrays (such as sorting and searching).
ArrayStoreException - Exception in java.lang
Thrown to indicate that an attempt has been made to store the wrong type of object into an array of objects.
ArrayStoreException() - Constructor for exception java.lang.ArrayStoreException
Constructs an ArrayStoreException with no detail message.
ArrayStoreException(String) - Constructor for exception java.lang.ArrayStoreException
Constructs an ArrayStoreException with the specified detail message.
ArrayType - Interface in javax.lang.model.type
Represents an array type.
ArrayType<T> - Class in javax.management.openmbean
The ArrayType class is the open type class whose instances describe all open data values which are n-dimensional arrays of open data values.
ArrayType(int, OpenType<?>) - Constructor for class javax.management.openmbean.ArrayType
Constructs an ArrayType instance describing open data values which are arrays with dimension dimension of elements whose open type is elementType.
ArrayType(SimpleType<?>, boolean) - Constructor for class javax.management.openmbean.ArrayType
Constructs a unidimensional ArrayType instance for the supplied SimpleType.
arrive() - Method in class java.util.concurrent.Phaser
Arrives at this phaser, without waiting for others to arrive.
arriveAndAwaitAdvance() - Method in class java.util.concurrent.Phaser
Arrives at this phaser and awaits others.
arriveAndDeregister() - Method in class java.util.concurrent.Phaser
Arrives at this phaser and deregisters from it without waiting for others to arrive.
ARROW_BUTTON - Static variable in class javax.swing.plaf.synth.Region
ArrowButton's are special types of buttons that also render a directional indicator, typically an arrow.
arrowButton - Variable in class javax.swing.plaf.basic.BasicComboBoxUI
ArrowButtonListener() - Constructor for class javax.swing.plaf.basic.BasicScrollBarUI.ArrowButtonListener
arrowIcon - Variable in class javax.swing.plaf.basic.BasicMenuItemUI
ARROWS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Arrows" Unicode character block.
asCharacters() - Method in interface javax.xml.stream.events.XMLEvent
Returns this event as Characters, may result in a class cast exception if this event is not Characters.
asCharBuffer() - Method in class java.nio.ByteBuffer
Creates a view of this byte buffer as a char buffer.
ASCII_STREAM_PARAM - Static variable in class javax.sql.rowset.BaseRowSet
A constant indicating to a RowSetReaderImpl object that a given parameter is an ASCII stream.
asciiStream - Variable in class javax.sql.rowset.BaseRowSet
The InputStream object that will be returned by the method getAsciiStream, which is specified in the ResultSet interface.
asCollector(Class<?>, int) - Method in class java.lang.invoke.MethodHandle
Makes an array-collecting method handle, which accepts a given number of trailing positional arguments and collects them into an array argument.
asDoubleBuffer() - Method in class java.nio.ByteBuffer
Creates a view of this byte buffer as a double buffer.
asDoubleStream() - Method in interface java.util.stream.IntStream
Returns a DoubleStream consisting of the elements of this stream, converted to double.
asDoubleStream() - Method in interface java.util.stream.LongStream
Returns a DoubleStream consisting of the elements of this stream, converted to double.
asElement() - Method in interface javax.lang.model.type.DeclaredType
Returns the element corresponding to this type.
asElement() - Method in interface javax.lang.model.type.TypeVariable
Returns the element corresponding to this type variable.
asElement(TypeMirror) - Method in interface javax.lang.model.util.Types
Returns the element corresponding to a type.
asEndElement() - Method in interface javax.xml.stream.events.XMLEvent
Returns this event as an end element event, may result in a class cast exception if this event is not a end element.
asFileAttribute(Set<PosixFilePermission>) - Static method in class java.nio.file.attribute.PosixFilePermissions
Creates a FileAttribute, encapsulating a copy of the given file permissions, suitable for passing to the createFile or createDirectory methods.
asFixedArity() - Method in class java.lang.invoke.MethodHandle
Makes a fixed arity method handle which is otherwise equivalent to the current method handle.
asFloatBuffer() - Method in class java.nio.ByteBuffer
Creates a view of this byte buffer as a float buffer.
asin(double) - Static method in class java.lang.Math
Returns the arc sine of a value; the returned angle is in the range -pi/2 through pi/2.
asin(double) - Static method in class java.lang.StrictMath
Returns the arc sine of a value; the returned angle is in the range -pi/2 through pi/2.
asIntBuffer() - Method in class java.nio.ByteBuffer
Creates a view of this byte buffer as an int buffer.
asInterfaceInstance(Class<T>, MethodHandle) - Static method in class java.lang.invoke.MethodHandleProxies
Produces an instance of the given single-method interface which redirects its calls to the given method handle.
asksAllowsChildren - Variable in class javax.swing.tree.DefaultTreeModel
Determines how the isLeaf method figures out if a node is a leaf node.
asksAllowsChildren() - Method in class javax.swing.tree.DefaultTreeModel
Tells how leaf nodes are determined.
asLifoQueue(Deque<T>) - Static method in class java.util.Collections
Returns a view of a Deque as a Last-in-first-out (Lifo) Queue.
asList(T...) - Static method in class java.util.Arrays
Returns a fixed-size list backed by the specified array.
asList() - Method in class javax.management.AttributeList
Return a view of this list as a List<Attribute>.
asList() - Method in class javax.management.relation.RoleList
Return a view of this list as a List<Role>.
asList() - Method in class javax.management.relation.RoleUnresolvedList
Return a view of this list as a List<RoleUnresolved>.
asLongBuffer() - Method in class java.nio.ByteBuffer
Creates a view of this byte buffer as a long buffer.
asLongStream() - Method in interface java.util.stream.IntStream
Returns a LongStream consisting of the elements of this stream, converted to long.
asMemberOf(DeclaredType, Element) - Method in interface javax.lang.model.util.Types
Returns the type of an element when that element is viewed as a member of, or otherwise directly contained by, a given type.
asNormal() - Method in enum java.time.format.TextStyle
Returns the normal style with the same size.
asPredicate() - Method in class java.util.regex.Pattern
Creates a predicate which can be used to match a string.
asReadLock() - Method in class java.util.concurrent.locks.StampedLock
Returns a plain Lock view of this StampedLock in which the Lock.lock() method is mapped to StampedLock.readLock(), and similarly for other methods.
asReadOnlyBuffer() - Method in class java.nio.ByteBuffer
Creates a new, read-only byte buffer that shares this buffer's content.
asReadOnlyBuffer() - Method in class java.nio.CharBuffer
Creates a new, read-only char buffer that shares this buffer's content.
asReadOnlyBuffer() - Method in class java.nio.DoubleBuffer
Creates a new, read-only double buffer that shares this buffer's content.
asReadOnlyBuffer() - Method in class java.nio.FloatBuffer
Creates a new, read-only float buffer that shares this buffer's content.
asReadOnlyBuffer() - Method in class java.nio.IntBuffer
Creates a new, read-only int buffer that shares this buffer's content.
asReadOnlyBuffer() - Method in class java.nio.LongBuffer
Creates a new, read-only long buffer that shares this buffer's content.
asReadOnlyBuffer() - Method in class java.nio.ShortBuffer
Creates a new, read-only short buffer that shares this buffer's content.
asReadWriteLock() - Method in class java.util.concurrent.locks.StampedLock
Returns a ReadWriteLock view of this StampedLock in which the ReadWriteLock.readLock() method is mapped to StampedLock.asReadLock(), and ReadWriteLock.writeLock() to StampedLock.asWriteLock().
assembleSystemMenu() - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
assembleSystemMenu() - Method in class javax.swing.plaf.metal.MetalInternalFrameTitlePane
Override the parent's method to do nothing.
AssertionError - Error in java.lang
Thrown to indicate that an assertion has failed.
AssertionError() - Constructor for error java.lang.AssertionError
Constructs an AssertionError with no detail message.
AssertionError(Object) - Constructor for error java.lang.AssertionError
Constructs an AssertionError with its detail message derived from the specified object, which is converted to a string as defined in section 15.18.1.1 of The Java™ Language Specification.
AssertionError(boolean) - Constructor for error java.lang.AssertionError
Constructs an AssertionError with its detail message derived from the specified boolean, which is converted to a string as defined in section 15.18.1.1 of The Java™ Language Specification.
AssertionError(char) - Constructor for error java.lang.AssertionError
Constructs an AssertionError with its detail message derived from the specified char, which is converted to a string as defined in section 15.18.1.1 of The Java™ Language Specification.
AssertionError(int) - Constructor for error java.lang.AssertionError
Constructs an AssertionError with its detail message derived from the specified int, which is converted to a string as defined in section 15.18.1.1 of The Java™ Language Specification.
AssertionError(long) - Constructor for error java.lang.AssertionError
Constructs an AssertionError with its detail message derived from the specified long, which is converted to a string as defined in section 15.18.1.1 of The Java™ Language Specification.
AssertionError(float) - Constructor for error java.lang.AssertionError
Constructs an AssertionError with its detail message derived from the specified float, which is converted to a string as defined in section 15.18.1.1 of The Java™ Language Specification.
AssertionError(double) - Constructor for error java.lang.AssertionError
Constructs an AssertionError with its detail message derived from the specified double, which is converted to a string as defined in section 15.18.1.1 of The Java™ Language Specification.
AssertionError(String, Throwable) - Constructor for error java.lang.AssertionError
Constructs a new AssertionError with the specified detail message and cause.
asShortBuffer() - Method in class java.nio.ByteBuffer
Creates a view of this byte buffer as a short buffer.
assign(DynAny) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Copy the contents from one Dynamic Any into another.
assign(DynAny) - Method in class org.omg.DynamicAny._DynAnyStub
Initializes the value associated with a DynAny object with the value associated with another DynAny object.
assign(DynAny) - Method in class org.omg.DynamicAny._DynArrayStub
Initializes the value associated with a DynAny object with the value associated with another DynAny object.
assign(DynAny) - Method in class org.omg.DynamicAny._DynEnumStub
Initializes the value associated with a DynAny object with the value associated with another DynAny object.
assign(DynAny) - Method in class org.omg.DynamicAny._DynFixedStub
Initializes the value associated with a DynAny object with the value associated with another DynAny object.
assign(DynAny) - Method in class org.omg.DynamicAny._DynSequenceStub
Initializes the value associated with a DynAny object with the value associated with another DynAny object.
assign(DynAny) - Method in class org.omg.DynamicAny._DynStructStub
Initializes the value associated with a DynAny object with the value associated with another DynAny object.
assign(DynAny) - Method in class org.omg.DynamicAny._DynUnionStub
Initializes the value associated with a DynAny object with the value associated with another DynAny object.
assign(DynAny) - Method in class org.omg.DynamicAny._DynValueStub
Initializes the value associated with a DynAny object with the value associated with another DynAny object.
assign(DynAny) - Method in interface org.omg.DynamicAny.DynAnyOperations
Initializes the value associated with a DynAny object with the value associated with another DynAny object.
asSpreader(Class<?>, int) - Method in class java.lang.invoke.MethodHandle
Makes an array-spreading method handle, which accepts a trailing array argument and spreads its elements as positional arguments.
asStandalone() - Method in enum java.time.format.TextStyle
Returns the stand-alone style with the same size.
asStartElement() - Method in interface javax.xml.stream.events.XMLEvent
Returns this event as a start element event, may result in a class cast exception if this event is not a start element.
asSubclass(Class<U>) - Method in class java.lang.Class
Casts this Class object to represent a subclass of the class represented by the specified class object.
assureRectsCreated(int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
asType(MethodType) - Method in class java.lang.invoke.MethodHandle
Produces an adapter method handle which adapts the type of the current method handle to a new type.
asType() - Method in interface javax.lang.model.element.Element
Returns the type defined by this element.
asVarargsCollector(Class<?>) - Method in class java.lang.invoke.MethodHandle
Makes a variable arity adapter which is able to accept any number of trailing positional arguments and collect them into an array argument.
asWriteLock() - Method in class java.util.concurrent.locks.StampedLock
Returns a plain Lock view of this StampedLock in which the Lock.lock() method is mapped to StampedLock.writeLock(), and similarly for other methods.
AsyncBoxView - Class in javax.swing.text
A box that does layout asynchronously.
AsyncBoxView(Element, int) - Constructor for class javax.swing.text.AsyncBoxView
Construct a box view that does asynchronous layout.
AsyncBoxView.ChildLocator - Class in javax.swing.text
A class to manage the effective position of the child views in a localized area while changes are being made around the localized area.
AsyncBoxView.ChildState - Class in javax.swing.text
A record representing the layout state of a child view.
AsyncHandler<T> - Interface in javax.xml.ws
The AsyncHandler interface is implemented by clients that wish to receive callback notification of the completion of service endpoint operations invoked asynchronously.
AsynchronousByteChannel - Interface in java.nio.channels
An asynchronous channel that can read and write bytes.
AsynchronousChannel - Interface in java.nio.channels
A channel that supports asynchronous I/O operations.
AsynchronousChannelGroup - Class in java.nio.channels
A grouping of asynchronous channels for the purpose of resource sharing.
AsynchronousChannelGroup(AsynchronousChannelProvider) - Constructor for class java.nio.channels.AsynchronousChannelGroup
Initialize a new instance of this class.
AsynchronousChannelProvider - Class in java.nio.channels.spi
Service-provider class for asynchronous channels.
AsynchronousChannelProvider() - Constructor for class java.nio.channels.spi.AsynchronousChannelProvider
Initializes a new instance of this class.
AsynchronousCloseException - Exception in java.nio.channels
Checked exception received by a thread when another thread closes the channel or the part of the channel upon which it is blocked in an I/O operation.
AsynchronousCloseException() - Constructor for exception java.nio.channels.AsynchronousCloseException
Constructs an instance of this class.
AsynchronousFileChannel - Class in java.nio.channels
An asynchronous channel for reading, writing, and manipulating a file.
AsynchronousFileChannel() - Constructor for class java.nio.channels.AsynchronousFileChannel
Initializes a new instance of this class.
AsynchronousServerSocketChannel - Class in java.nio.channels
An asynchronous channel for stream-oriented listening sockets.
AsynchronousServerSocketChannel(AsynchronousChannelProvider) - Constructor for class java.nio.channels.AsynchronousServerSocketChannel
Initializes a new instance of this class.
AsynchronousSocketChannel - Class in java.nio.channels
An asynchronous channel for stream-oriented connecting sockets.
AsynchronousSocketChannel(AsynchronousChannelProvider) - Constructor for class java.nio.channels.AsynchronousSocketChannel
Initializes a new instance of this class.
AT_TARGET - Static variable in interface org.w3c.dom.events.Event
The event is currently being evaluated at the target EventTarget.
atan(double) - Static method in class java.lang.Math
Returns the arc tangent of a value; the returned angle is in the range -pi/2 through pi/2.
atan(double) - Static method in class java.lang.StrictMath
Returns the arc tangent of a value; the returned angle is in the range -pi/2 through pi/2.
atan2(double, double) - Static method in class java.lang.Math
Returns the angle theta from the conversion of rectangular coordinates (x, y) to polar coordinates (r, theta).
atan2(double, double) - Static method in class java.lang.StrictMath
Returns the angle theta from the conversion of rectangular coordinates (x, y) to polar coordinates (r, theta).
atDate(LocalDate) - Method in class java.time.LocalTime
Combines this time with a date to create a LocalDateTime.
atDate(LocalDate) - Method in class java.time.OffsetTime
Combines this time with a date to create an OffsetDateTime.
atDay(int) - Method in class java.time.Year
Combines this year with a day-of-year to create a LocalDate.
atDay(int) - Method in class java.time.YearMonth
Combines this year-month with a day-of-month to create a LocalDate.
atEndOfMonth() - Method in class java.time.YearMonth
Returns a LocalDate at the end of the month.
atMonth(Month) - Method in class java.time.Year
Combines this year with a month to create a YearMonth.
atMonth(int) - Method in class java.time.Year
Combines this year with a month to create a YearMonth.
atMonthDay(MonthDay) - Method in class java.time.Year
Combines this year with a month-day to create a LocalDate.
atOffset(ZoneOffset) - Method in class java.time.Instant
Combines this instant with an offset to create an OffsetDateTime.
atOffset(ZoneOffset) - Method in class java.time.LocalDateTime
Combines this date-time with an offset to create an OffsetDateTime.
atOffset(ZoneOffset) - Method in class java.time.LocalTime
Combines this time with an offset to create an OffsetTime.
AtomicBoolean - Class in java.util.concurrent.atomic
A boolean value that may be updated atomically.
AtomicBoolean(boolean) - Constructor for class java.util.concurrent.atomic.AtomicBoolean
Creates a new AtomicBoolean with the given initial value.
AtomicBoolean() - Constructor for class java.util.concurrent.atomic.AtomicBoolean
Creates a new AtomicBoolean with initial value false.
AtomicInteger - Class in java.util.concurrent.atomic
An int value that may be updated atomically.
AtomicInteger(int) - Constructor for class java.util.concurrent.atomic.AtomicInteger
Creates a new AtomicInteger with the given initial value.
AtomicInteger() - Constructor for class java.util.concurrent.atomic.AtomicInteger
Creates a new AtomicInteger with initial value 0.
AtomicIntegerArray - Class in java.util.concurrent.atomic
An int array in which elements may be updated atomically.
AtomicIntegerArray(int) - Constructor for class java.util.concurrent.atomic.AtomicIntegerArray
Creates a new AtomicIntegerArray of the given length, with all elements initially zero.
AtomicIntegerArray(int[]) - Constructor for class java.util.concurrent.atomic.AtomicIntegerArray
Creates a new AtomicIntegerArray with the same length as, and all elements copied from, the given array.
AtomicIntegerFieldUpdater<T> - Class in java.util.concurrent.atomic
A reflection-based utility that enables atomic updates to designated volatile int fields of designated classes.
AtomicIntegerFieldUpdater() - Constructor for class java.util.concurrent.atomic.AtomicIntegerFieldUpdater
Protected do-nothing constructor for use by subclasses.
AtomicLong - Class in java.util.concurrent.atomic
A long value that may be updated atomically.
AtomicLong(long) - Constructor for class java.util.concurrent.atomic.AtomicLong
Creates a new AtomicLong with the given initial value.
AtomicLong() - Constructor for class java.util.concurrent.atomic.AtomicLong
Creates a new AtomicLong with initial value 0.
AtomicLongArray - Class in java.util.concurrent.atomic
A long array in which elements may be updated atomically.
AtomicLongArray(int) - Constructor for class java.util.concurrent.atomic.AtomicLongArray
Creates a new AtomicLongArray of the given length, with all elements initially zero.
AtomicLongArray(long[]) - Constructor for class java.util.concurrent.atomic.AtomicLongArray
Creates a new AtomicLongArray with the same length as, and all elements copied from, the given array.
AtomicLongFieldUpdater<T> - Class in java.util.concurrent.atomic
A reflection-based utility that enables atomic updates to designated volatile long fields of designated classes.
AtomicLongFieldUpdater() - Constructor for class java.util.concurrent.atomic.AtomicLongFieldUpdater
Protected do-nothing constructor for use by subclasses.
AtomicMarkableReference<V> - Class in java.util.concurrent.atomic
An AtomicMarkableReference maintains an object reference along with a mark bit, that can be updated atomically.
AtomicMarkableReference(V, boolean) - Constructor for class java.util.concurrent.atomic.AtomicMarkableReference
Creates a new AtomicMarkableReference with the given initial values.
AtomicMoveNotSupportedException - Exception in java.nio.file
Checked exception thrown when a file cannot be moved as an atomic file system operation.
AtomicMoveNotSupportedException(String, String, String) - Constructor for exception java.nio.file.AtomicMoveNotSupportedException
Constructs an instance of this class.
AtomicReference<V> - Class in java.util.concurrent.atomic
An object reference that may be updated atomically.
AtomicReference(V) - Constructor for class java.util.concurrent.atomic.AtomicReference
Creates a new AtomicReference with the given initial value.
AtomicReference() - Constructor for class java.util.concurrent.atomic.AtomicReference
Creates a new AtomicReference with null initial value.
AtomicReferenceArray<E> - Class in java.util.concurrent.atomic
An array of object references in which elements may be updated atomically.
AtomicReferenceArray(int) - Constructor for class java.util.concurrent.atomic.AtomicReferenceArray
Creates a new AtomicReferenceArray of the given length, with all elements initially null.
AtomicReferenceArray(E[]) - Constructor for class java.util.concurrent.atomic.AtomicReferenceArray
Creates a new AtomicReferenceArray with the same length as, and all elements copied from, the given array.
AtomicReferenceFieldUpdater<T,V> - Class in java.util.concurrent.atomic
A reflection-based utility that enables atomic updates to designated volatile reference fields of designated classes.
AtomicReferenceFieldUpdater() - Constructor for class java.util.concurrent.atomic.AtomicReferenceFieldUpdater
Protected do-nothing constructor for use by subclasses.
AtomicStampedReference<V> - Class in java.util.concurrent.atomic
An AtomicStampedReference maintains an object reference along with an integer "stamp", that can be updated atomically.
AtomicStampedReference(V, int) - Constructor for class java.util.concurrent.atomic.AtomicStampedReference
Creates a new AtomicStampedReference with the given initial values.
atStartOfDay() - Method in class java.time.LocalDate
Combines this date with the time of midnight to create a LocalDateTime at the start of this date.
atStartOfDay(ZoneId) - Method in class java.time.LocalDate
Returns a zoned date-time from this date at the earliest valid time according to the rules in the time-zone.
attach(Object) - Method in class java.nio.channels.SelectionKey
Attaches the given object to this key.
attachment() - Method in class java.nio.channels.SelectionKey
Retrieves the current attachment.
AttachmentMarshaller - Class in javax.xml.bind.attachment
Enable JAXB marshalling to optimize storage of binary data.
AttachmentMarshaller() - Constructor for class javax.xml.bind.attachment.AttachmentMarshaller
AttachmentPart - Class in javax.xml.soap
A single attachment to a SOAPMessage object.
AttachmentPart() - Constructor for class javax.xml.soap.AttachmentPart
AttachmentUnmarshaller - Class in javax.xml.bind.attachment
Enables JAXB unmarshalling of a root document containing optimized binary data formats.
AttachmentUnmarshaller() - Constructor for class javax.xml.bind.attachment.AttachmentUnmarshaller
ATTEMPTED - Static variable in class javax.print.attribute.standard.PDLOverrideSupported
The printer attempts to make the external job attribute values take precedence over embedded instructions in the documents' print data, however there is no guarantee.
attemptMark(V, boolean) - Method in class java.util.concurrent.atomic.AtomicMarkableReference
Atomically sets the value of the mark to the given update value if the current reference is == to the expected reference.
attemptStamp(V, int) - Method in class java.util.concurrent.atomic.AtomicStampedReference
Atomically sets the value of the stamp to the given update value if the current reference is == to the expected reference.
atTime(LocalTime) - Method in interface java.time.chrono.ChronoLocalDate
Combines this date with a time to create a ChronoLocalDateTime.
atTime(LocalTime) - Method in class java.time.chrono.HijrahDate
atTime(LocalTime) - Method in class java.time.chrono.JapaneseDate
atTime(LocalTime) - Method in class java.time.chrono.MinguoDate
atTime(LocalTime) - Method in class java.time.chrono.ThaiBuddhistDate
atTime(LocalTime) - Method in class java.time.LocalDate
Combines this date with a time to create a LocalDateTime.
atTime(int, int) - Method in class java.time.LocalDate
Combines this date with a time to create a LocalDateTime.
atTime(int, int, int) - Method in class java.time.LocalDate
Combines this date with a time to create a LocalDateTime.
atTime(int, int, int, int) - Method in class java.time.LocalDate
Combines this date with a time to create a LocalDateTime.
atTime(OffsetTime) - Method in class java.time.LocalDate
Combines this date with an offset time to create an OffsetDateTime.
attr(String) - Static method in class javax.management.Query
Returns a new attribute expression.
attr(String, String) - Static method in class javax.management.Query
Returns a new qualified attribute expression.
Attr - Interface in org.w3c.dom
The Attr interface represents an attribute in an Element object.
Attribute(String) - Constructor for class java.text.AttributedCharacterIterator.Attribute
Constructs an Attribute with the given name.
Attribute - Class in javax.management
Represents an MBean attribute by associating its name with its value.
Attribute(String, Object) - Constructor for class javax.management.Attribute
Constructs an Attribute object which associates the given attribute name with the given value.
Attribute - Interface in javax.naming.directory
This interface represents an attribute associated with a named object.
Attribute - Interface in javax.print.attribute
Interface Attribute is the base interface implemented by any and every printing attribute class to indicate that the class represents a printing attribute.
Attribute - Interface in javax.xml.stream.events
An interface that contains information about an attribute.
ATTRIBUTE - Static variable in interface javax.xml.stream.XMLStreamConstants
Indicates an event is an attribute
attribute(QName, String) - Method in class javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder
Adds an extension attribute to the W3CEndpointReference instance's wsa:EndpointReference element.
ATTRIBUTE_CHANGE - Static variable in class javax.management.AttributeChangeNotification
Notification type which indicates that the observed MBean attribute value has changed.
ATTRIBUTE_NODE - Static variable in interface org.w3c.dom.Node
The node is an Attr.
ATTRIBUTE_RUN - Static variable in interface javax.accessibility.AccessibleExtendedText
Constant used to indicate that the part of the text that should be retrieved is contiguous text with the same text attributes.
AttributeChangeNotification - Class in javax.management
Provides definitions of the attribute change notifications sent by MBeans.
AttributeChangeNotification(Object, long, long, String, String, String, Object, Object) - Constructor for class javax.management.AttributeChangeNotification
Constructs an attribute change notification object.
AttributeChangeNotificationFilter - Class in javax.management
This class implements of the NotificationFilter interface for the attribute change notification.
AttributeChangeNotificationFilter() - Constructor for class javax.management.AttributeChangeNotificationFilter
AttributedCharacterIterator - Interface in java.text
An AttributedCharacterIterator allows iteration through both text and related attribute information.
AttributedCharacterIterator.Attribute - Class in java.text
Defines attribute keys that are used to identify text attributes.
attributeDecl(String, String, String, String, String) - Method in interface org.xml.sax.ext.DeclHandler
Report an attribute type declaration.
attributeDecl(String, String, String, String, String) - Method in class org.xml.sax.ext.DefaultHandler2
AttributedString - Class in java.text
An AttributedString holds text and related attribute information.
AttributedString(String) - Constructor for class java.text.AttributedString
Constructs an AttributedString instance with the given text.
AttributedString(String, Map<? extends AttributedCharacterIterator.Attribute, ?>) - Constructor for class java.text.AttributedString
Constructs an AttributedString instance with the given text and attributes.
AttributedString(AttributedCharacterIterator) - Constructor for class java.text.AttributedString
Constructs an AttributedString instance with the given attributed text represented by AttributedCharacterIterator.
AttributedString(AttributedCharacterIterator, int, int) - Constructor for class java.text.AttributedString
Constructs an AttributedString instance with the subrange of the given attributed text represented by AttributedCharacterIterator.
AttributedString(AttributedCharacterIterator, int, int, AttributedCharacterIterator.Attribute[]) - Constructor for class java.text.AttributedString
Constructs an AttributedString instance with the subrange of the given attributed text represented by AttributedCharacterIterator.
AttributeException - Interface in javax.print
Interface AttributeException is a mixin interface which a subclass of PrintException can implement to report an error condition involving one or more printing attributes that a particular Print Service instance does not support.
AttributeInUseException - Exception in javax.naming.directory
This exception is thrown when an operation attempts to add an attribute that already exists.
AttributeInUseException(String) - Constructor for exception javax.naming.directory.AttributeInUseException
Constructs a new instance of AttributeInUseException with an explanation.
AttributeInUseException() - Constructor for exception javax.naming.directory.AttributeInUseException
Constructs a new instance of AttributeInUseException.
AttributeList - Class in javax.management
Represents a list of values for attributes of an MBean.
AttributeList() - Constructor for class javax.management.AttributeList
Constructs an empty AttributeList.
AttributeList(int) - Constructor for class javax.management.AttributeList
Constructs an empty AttributeList with the initial capacity specified.
AttributeList(AttributeList) - Constructor for class javax.management.AttributeList
Constructs an AttributeList containing the elements of the AttributeList specified, in the order in which they are returned by the AttributeList's iterator.
AttributeList(List<Attribute>) - Constructor for class javax.management.AttributeList
Constructs an AttributeList containing the elements of the List specified, in the order in which they are returned by the List's iterator.
AttributeList - Class in javax.swing.text.html.parser
This class defines the attributes of an SGML element as described in a DTD using the ATTLIST construct.
AttributeList(String) - Constructor for class javax.swing.text.html.parser.AttributeList
Create an attribute list element.
AttributeList(String, int, int, String, Vector<?>, AttributeList) - Constructor for class javax.swing.text.html.parser.AttributeList
Create an attribute list element.
AttributeList - Interface in org.xml.sax
Deprecated.
This interface has been replaced by the SAX2 Attributes interface, which includes Namespace support.
AttributeListImpl - Class in org.xml.sax.helpers
Deprecated.
This class implements a deprecated interface, AttributeList; that interface has been replaced by Attributes, which is implemented in the AttributesImpl helper class.
AttributeListImpl() - Constructor for class org.xml.sax.helpers.AttributeListImpl
Deprecated.
Create an empty attribute list.
AttributeListImpl(AttributeList) - Constructor for class org.xml.sax.helpers.AttributeListImpl
Deprecated.
Construct a persistent copy of an existing attribute list.
AttributeModificationException - Exception in javax.naming.directory
This exception is thrown when an attempt is made to add, or remove, or modify an attribute, its identifier, or its values that conflicts with the attribute's (schema) definition or the attribute's state.
AttributeModificationException(String) - Constructor for exception javax.naming.directory.AttributeModificationException
Constructs a new instance of AttributeModificationException using an explanation.
AttributeModificationException() - Constructor for exception javax.naming.directory.AttributeModificationException
Constructs a new instance of AttributeModificationException.
attributeNames() - Method in class java.beans.FeatureDescriptor
Gets an enumeration of the locale-independent names of this feature.
attributeNoNulls - Static variable in interface java.sql.DatabaseMetaData
Indicates that NULL values might not be allowed.
AttributeNotFoundException - Exception in javax.management
The specified attribute does not exist or cannot be retrieved.
AttributeNotFoundException() - Constructor for exception javax.management.AttributeNotFoundException
Default constructor.
AttributeNotFoundException(String) - Constructor for exception javax.management.AttributeNotFoundException
Constructor that allows a specific error message to be specified.
attributeNullable - Static variable in interface java.sql.DatabaseMetaData
Indicates that NULL values are definitely allowed.
attributeNullableUnknown - Static variable in interface java.sql.DatabaseMetaData
Indicates that whether NULL values are allowed is not known.
Attributes - Class in java.util.jar
The Attributes class maps Manifest attribute names to associated string values.
Attributes() - Constructor for class java.util.jar.Attributes
Constructs a new, empty Attributes object with default size.
Attributes(int) - Constructor for class java.util.jar.Attributes
Constructs a new, empty Attributes object with the specified initial size.
Attributes(Attributes) - Constructor for class java.util.jar.Attributes
Constructs a new Attributes object with the same attribute name-value mappings as in the specified Attributes.
attributes - Variable in class javax.accessibility.AccessibleAttributeSequence
The text attributes
Attributes - Interface in javax.naming.directory
This interface represents a collection of attributes.
Attributes - Interface in org.xml.sax
Interface for a list of XML attributes.
Attributes.Name - Class in java.util.jar
The Attributes.Name class represents an attribute name stored in this Map.
Attributes2 - Interface in org.xml.sax.ext
SAX2 extension to augment the per-attribute information provided though Attributes.
Attributes2Impl - Class in org.xml.sax.ext
SAX2 extension helper for additional Attributes information, implementing the Attributes2 interface.
Attributes2Impl() - Constructor for class org.xml.sax.ext.Attributes2Impl
Construct a new, empty Attributes2Impl object.
Attributes2Impl(Attributes) - Constructor for class org.xml.sax.ext.Attributes2Impl
Copy an existing Attributes or Attributes2 object.
AttributeSet - Interface in javax.print.attribute
Interface AttributeSet specifies the interface for a set of printing attributes.
AttributeSet - Interface in javax.swing.text
A collection of unique attributes.
AttributeSet.CharacterAttribute - Interface in javax.swing.text
This interface is the type signature that is expected to be present on any attribute key that contributes to character level presentation.
AttributeSet.ColorAttribute - Interface in javax.swing.text
This interface is the type signature that is expected to be present on any attribute key that contributes to presentation of color.
AttributeSet.FontAttribute - Interface in javax.swing.text
This interface is the type signature that is expected to be present on any attribute key that contributes to the determination of what font to use to render some text.
AttributeSet.ParagraphAttribute - Interface in javax.swing.text
This interface is the type signature that is expected to be present on any attribute key that contributes to the paragraph level presentation.
AttributeSetUtilities - Class in javax.print.attribute
Class AttributeSetUtilities provides static methods for manipulating AttributeSets.
AttributesImpl - Class in org.xml.sax.helpers
Default implementation of the Attributes interface.
AttributesImpl() - Constructor for class org.xml.sax.helpers.AttributesImpl
Construct a new, empty AttributesImpl object.
AttributesImpl(Attributes) - Constructor for class org.xml.sax.helpers.AttributesImpl
Copy an existing Attributes object.
AttributeUndoableEdit(Element, AttributeSet, boolean) - Constructor for class javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit
attributeUpdate(PrintJobAttributeEvent) - Method in interface javax.print.event.PrintJobAttributeListener
Notifies the listener of a change in some print job attributes.
attributeUpdate(PrintServiceAttributeEvent) - Method in interface javax.print.event.PrintServiceAttributeListener
Called to notify a listener of an event in the print service.
AttributeValueExp - Class in javax.management
Represents attributes used as arguments to relational constraints.
AttributeValueExp() - Constructor for class javax.management.AttributeValueExp
Deprecated.
An instance created with this constructor cannot be used in a query.
AttributeValueExp(String) - Constructor for class javax.management.AttributeValueExp
Creates a new AttributeValueExp representing the specified object attribute, named attr.
AttributeView - Interface in java.nio.file.attribute
An object that provides a read-only or updatable view of non-opaque values associated with an object in a filesystem.
attrID - Variable in class javax.naming.directory.BasicAttribute
Holds the attribute's id.
atts - Variable in class javax.swing.text.html.parser.Element
atYear(int) - Method in class java.time.MonthDay
Combines this month-day with a year to create a LocalDate.
atZone(ZoneId) - Method in interface java.time.chrono.ChronoLocalDateTime
Combines this time with a time-zone to create a ChronoZonedDateTime.
atZone(ZoneId) - Method in class java.time.Instant
Combines this instant with a time-zone to create a ZonedDateTime.
atZone(ZoneId) - Method in class java.time.LocalDateTime
Combines this date-time with a time-zone to create a ZonedDateTime.
atZoneSameInstant(ZoneId) - Method in class java.time.OffsetDateTime
Combines this date-time with a time-zone to create a ZonedDateTime ensuring that the result has the same instant.
atZoneSimilarLocal(ZoneId) - Method in class java.time.OffsetDateTime
Combines this date-time with a time-zone to create a ZonedDateTime trying to keep the same local date and time.
AU - Static variable in class javax.sound.sampled.AudioFileFormat.Type
Specifies an AU file.
AudioClip - Interface in java.applet
The AudioClip interface is a simple abstraction for playing a sound clip.
AudioFileFormat - Class in javax.sound.sampled
An instance of the AudioFileFormat class describes an audio file, including the file type, the file's length in bytes, the length in sample frames of the audio data contained in the file, and the format of the audio data.
AudioFileFormat(AudioFileFormat.Type, int, AudioFormat, int) - Constructor for class javax.sound.sampled.AudioFileFormat
Constructs an audio file format object.
AudioFileFormat(AudioFileFormat.Type, AudioFormat, int) - Constructor for class javax.sound.sampled.AudioFileFormat
Constructs an audio file format object.
AudioFileFormat(AudioFileFormat.Type, AudioFormat, int, Map<String, Object>) - Constructor for class javax.sound.sampled.AudioFileFormat
Construct an audio file format object with a set of defined properties.
AudioFileFormat.Type - Class in javax.sound.sampled
An instance of the Type class represents one of the standard types of audio file.
AudioFileReader - Class in javax.sound.sampled.spi
Provider for audio file reading services.
AudioFileReader() - Constructor for class javax.sound.sampled.spi.AudioFileReader
AudioFileWriter - Class in javax.sound.sampled.spi
Provider for audio file writing services.
AudioFileWriter() - Constructor for class javax.sound.sampled.spi.AudioFileWriter
AudioFormat - Class in javax.sound.sampled
AudioFormat is the class that specifies a particular arrangement of data in a sound stream.
AudioFormat(AudioFormat.Encoding, float, int, int, int, float, boolean) - Constructor for class javax.sound.sampled.AudioFormat
Constructs an AudioFormat with the given parameters.
AudioFormat(AudioFormat.Encoding, float, int, int, int, float, boolean, Map<String, Object>) - Constructor for class javax.sound.sampled.AudioFormat
Constructs an AudioFormat with the given parameters.
AudioFormat(float, int, int, boolean, boolean) - Constructor for class javax.sound.sampled.AudioFormat
Constructs an AudioFormat with a linear PCM encoding and the given parameters.
AudioFormat.Encoding - Class in javax.sound.sampled
The Encoding class names the specific type of data representation used for an audio stream.
AudioInputStream - Class in javax.sound.sampled
An audio input stream is an input stream with a specified audio format and length.
AudioInputStream(InputStream, AudioFormat, long) - Constructor for class javax.sound.sampled.AudioInputStream
Constructs an audio input stream that has the requested format and length in sample frames, using audio data from the specified input stream.
AudioInputStream(TargetDataLine) - Constructor for class javax.sound.sampled.AudioInputStream
Constructs an audio input stream that reads its data from the target data line indicated.
AudioPermission - Class in javax.sound.sampled
The AudioPermission class represents access rights to the audio system resources.
AudioPermission(String) - Constructor for class javax.sound.sampled.AudioPermission
Creates a new AudioPermission object that has the specified symbolic name, such as "play" or "record".
AudioPermission(String, String) - Constructor for class javax.sound.sampled.AudioPermission
Creates a new AudioPermission object that has the specified symbolic name, such as "play" or "record".
AudioSystem - Class in javax.sound.sampled
The AudioSystem class acts as the entry point to the sampled-audio system resources.
augmentList(Action[], Action[]) - Static method in class javax.swing.text.TextAction
Takes one list of commands and augments it with another list of commands.
AUGUST - Static variable in class java.util.Calendar
Value of the Calendar.MONTH field indicating the eighth month of the year in the Gregorian and Julian calendars.
AUGUST - Static variable in class javax.xml.datatype.DatatypeConstants
Value for eighth month of year.
authenticate(Object) - Method in interface javax.management.remote.JMXAuthenticator
Authenticates the MBeanServerConnection client with the given client credentials.
AuthenticationException - Exception in javax.naming
This exception is thrown when an authentication error occurs while accessing the naming or directory service.
AuthenticationException(String) - Constructor for exception javax.naming.AuthenticationException
Constructs a new instance of AuthenticationException using the explanation supplied.
AuthenticationException() - Constructor for exception javax.naming.AuthenticationException
Constructs a new instance of AuthenticationException.
AuthenticationException - Exception in javax.security.sasl
This exception is thrown by a SASL mechanism implementation to indicate that the SASL exchange has failed due to reasons related to authentication, such as an invalid identity, passphrase, or key.
AuthenticationException() - Constructor for exception javax.security.sasl.AuthenticationException
Constructs a new instance of AuthenticationException.
AuthenticationException(String) - Constructor for exception javax.security.sasl.AuthenticationException
Constructs a new instance of AuthenticationException with a detailed message.
AuthenticationException(String, Throwable) - Constructor for exception javax.security.sasl.AuthenticationException
Constructs a new instance of AuthenticationException with a detailed message and a root exception.
AuthenticationNotSupportedException - Exception in javax.naming
This exception is thrown when the particular flavor of authentication requested is not supported.
AuthenticationNotSupportedException(String) - Constructor for exception javax.naming.AuthenticationNotSupportedException
Constructs a new instance of AuthenticationNotSupportedException using an explanation.
AuthenticationNotSupportedException() - Constructor for exception javax.naming.AuthenticationNotSupportedException
Constructs a new instance of AuthenticationNotSupportedException all name resolution fields and explanation initialized to null.
Authenticator - Class in java.net
The class Authenticator represents an object that knows how to obtain authentication for a network connection.
Authenticator() - Constructor for class java.net.Authenticator
AUTHENTICATOR - Static variable in class javax.management.remote.JMXConnectorServer
Name of the attribute that specifies the authenticator for a connector server.
Authenticator.RequestorType - Enum in java.net
The type of the entity requesting authentication.
AUTHORITATIVE - Static variable in interface javax.naming.Context
Constant that holds the name of the environment property for specifying the authoritativeness of the service requested.
AuthorizeCallback - Class in javax.security.sasl
This callback is used by SaslServer to determine whether one entity (identified by an authenticated authentication id) can act on behalf of another entity (identified by an authorization id).
AuthorizeCallback(String, String) - Constructor for class javax.security.sasl.AuthorizeCallback
Constructs an instance of AuthorizeCallback.
AuthPermission - Class in javax.security.auth
This class is for authentication permissions.
AuthPermission(String) - Constructor for class javax.security.auth.AuthPermission
Creates a new AuthPermission with the specified name.
AuthPermission(String, String) - Constructor for class javax.security.auth.AuthPermission
Creates a new AuthPermission object with the specified name.
AuthProvider - Class in java.security
This class defines login and logout methods for a provider.
AuthProvider(String, double, String) - Constructor for class java.security.AuthProvider
Constructs a provider with the specified name, version number, and information.
AUTO_RESIZE_ALL_COLUMNS - Static variable in class javax.swing.JTable
During all resize operations, proportionately resize all columns.
AUTO_RESIZE_LAST_COLUMN - Static variable in class javax.swing.JTable
During all resize operations, apply adjustments to the last column only.
AUTO_RESIZE_NEXT_COLUMN - Static variable in class javax.swing.JTable
When a column is adjusted in the UI, adjust the next column the opposite way.
AUTO_RESIZE_OFF - Static variable in class javax.swing.JTable
Do not adjust column widths automatically; use a horizontal scrollbar instead.
AUTO_RESIZE_SUBSEQUENT_COLUMNS - Static variable in class javax.swing.JTable
During UI adjustment, change subsequent columns to preserve the total width; this is the default behavior.
AutoCloseable - Interface in java.lang
An object that may hold resources (such as file or socket handles) until it is closed.
autoCommitFailureClosesAllResultSets() - Method in interface java.sql.DatabaseMetaData
Retrieves whether a SQLException while autoCommit is true indicates that all open ResultSets are closed, even ones that are holdable.
autoCreateColumnsFromModel - Variable in class javax.swing.JTable
The table will query the TableModel to build the default set of columns if this is true.
autoResizeMode - Variable in class javax.swing.JTable
Determines if the table automatically resizes the width of the table's columns to take up the entire width of the table, and how it does the resizing.
Autoscroll - Interface in java.awt.dnd
During DnD operations it is possible that a user may wish to drop the subject of the operation on a region of a scrollable GUI control that is not currently visible to the user.
autoscroll(Point) - Method in interface java.awt.dnd.Autoscroll
notify the Component to autoscroll
autoScrollDown() - Method in class javax.swing.plaf.basic.BasicComboPopup
This protected method is implementation specific and should be private.
autoscrollTimer - Variable in class javax.swing.plaf.basic.BasicComboPopup
This protected field is implementation specific.
autoScrollUp() - Method in class javax.swing.plaf.basic.BasicComboPopup
This protected method is implementation specific and should be private.
AUTOSENSE - Static variable in class javax.print.DocFlavor.BYTE_ARRAY
Doc flavor with MIME type = "application/octet-stream", print data representation class name = "[B" (byte array).
AUTOSENSE - Static variable in class javax.print.DocFlavor.INPUT_STREAM
Doc flavor with MIME type = "application/octet-stream", print data representation class name = "java.io.InputStream" (byte stream).
AUTOSENSE - Static variable in class javax.print.DocFlavor.URL
Doc flavor with MIME type = "application/octet-stream", print data representation class name = "java.net.URL".
AUX_RETURN - Static variable in class javax.sound.sampled.FloatControl.Type
Represents a control for the auxiliary return gain on a line.
AUX_SEND - Static variable in class javax.sound.sampled.FloatControl.Type
Represents a control for the auxiliary send gain on a line.
available() - Method in class java.io.BufferedInputStream
Returns an estimate of the number of bytes that can be read (or skipped over) from this input stream without blocking by the next invocation of a method for this input stream.
available() - Method in class java.io.ByteArrayInputStream
Returns the number of remaining bytes that can be read (or skipped over) from this input stream.
available() - Method in class java.io.FileInputStream
Returns an estimate of the number of remaining bytes that can be read (or skipped over) from this input stream without blocking by the next invocation of a method for this input stream.
available() - Method in class java.io.FilterInputStream
Returns an estimate of the number of bytes that can be read (or skipped over) from this input stream without blocking by the next caller of a method for this input stream.
available() - Method in class java.io.InputStream
Returns an estimate of the number of bytes that can be read (or skipped over) from this input stream without blocking by the next invocation of a method for this input stream.
available() - Method in class java.io.LineNumberInputStream
Deprecated.
Returns the number of bytes that can be read from this input stream without blocking.
available() - Method in interface java.io.ObjectInput
Returns the number of bytes that can be read without blocking.
available() - Method in class java.io.ObjectInputStream
Returns the number of bytes that can be read without blocking.
available() - Method in class java.io.PipedInputStream
Returns the number of bytes that can be read from this input stream without blocking.
available() - Method in class java.io.PushbackInputStream
Returns an estimate of the number of bytes that can be read (or skipped over) from this input stream without blocking by the next invocation of a method for this input stream.
available() - Method in class java.io.SequenceInputStream
Returns an estimate of the number of bytes that can be read (or skipped over) from the current underlying input stream without blocking by the next invocation of a method for the current underlying input stream.
available() - Method in class java.io.StringBufferInputStream
Deprecated.
Returns the number of bytes that can be read from the input stream without blocking.
available() - Method in class java.net.SocketImpl
Returns the number of bytes that can be read from this socket without blocking.
available() - Method in class java.util.zip.DeflaterInputStream
Returns 0 after EOF has been reached, otherwise always return 1.
available() - Method in class java.util.zip.InflaterInputStream
Returns 0 after EOF has been reached, otherwise always return 1.
available() - Method in class java.util.zip.ZipInputStream
Returns 0 after EOF has reached for the current entry data, otherwise always return 1.
available() - Method in class javax.crypto.CipherInputStream
Returns the number of bytes that can be read from this input stream without blocking.
available() - Method in class javax.sound.sampled.AudioInputStream
Returns the maximum number of bytes that can be read (or skipped over) from this audio input stream without blocking.
available() - Method in interface javax.sound.sampled.DataLine
Obtains the number of bytes of data currently available to the application for processing in the data line's internal buffer.
availableCharsets() - Static method in class java.nio.charset.Charset
Constructs a sorted map from canonical charset names to charset objects.
availableLocales - Variable in class javax.imageio.ImageReader
An array of Locales which may be used to localize warning messages, or null if localization is not supported.
availableLocales - Variable in class javax.imageio.ImageWriter
An array of Locales that may be used to localize warning messages and compression setting values, or null if localization is not supported.
availablePermits() - Method in class java.util.concurrent.Semaphore
Returns the current number of permits available in this semaphore.
availableProcessors() - Method in class java.lang.Runtime
Returns the number of processors available to the Java virtual machine.
average() - Method in interface java.util.stream.DoubleStream
Returns an OptionalDouble describing the arithmetic mean of elements of this stream, or an empty optional if this stream is empty.
average() - Method in interface java.util.stream.IntStream
Returns an OptionalDouble describing the arithmetic mean of elements of this stream, or an empty optional if this stream is empty.
average() - Method in interface java.util.stream.LongStream
Returns an OptionalDouble describing the arithmetic mean of elements of this stream, or an empty optional if this stream is empty.
averageBytesPerChar() - Method in class java.nio.charset.CharsetEncoder
Returns the average number of bytes that will be produced for each character of input.
averageCharsPerByte() - Method in class java.nio.charset.CharsetDecoder
Returns the average number of characters that will be produced for each byte of input.
averagingDouble(ToDoubleFunction<? super T>) - Static method in class java.util.stream.Collectors
Returns a Collector that produces the arithmetic mean of a double-valued function applied to the input elements.
averagingInt(ToIntFunction<? super T>) - Static method in class java.util.stream.Collectors
Returns a Collector that produces the arithmetic mean of an integer-valued function applied to the input elements.
averagingLong(ToLongFunction<? super T>) - Static method in class java.util.stream.Collectors
Returns a Collector that produces the arithmetic mean of a long-valued function applied to the input elements.
AVESTAN - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Avestan" Unicode character block.
avoidingGui() - Method in class java.beans.beancontext.BeanContextSupport
Used to determine if the BeanContext child is avoiding using its GUI.
avoidingGui() - Method in interface java.beans.Visibility
Determines whether this bean is avoiding using a GUI.
await() - Method in class java.util.concurrent.CountDownLatch
Causes the current thread to wait until the latch has counted down to zero, unless the thread is interrupted.
await(long, TimeUnit) - Method in class java.util.concurrent.CountDownLatch
Causes the current thread to wait until the latch has counted down to zero, unless the thread is interrupted, or the specified waiting time elapses.
await() - Method in class java.util.concurrent.CyclicBarrier
Waits until all parties have invoked await on this barrier.
await(long, TimeUnit) - Method in class java.util.concurrent.CyclicBarrier
Waits until all parties have invoked await on this barrier, or the specified waiting time elapses.
await() - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject
Implements interruptible condition wait.
await(long, TimeUnit) - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject
Implements timed condition wait.
await() - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject
Implements interruptible condition wait.
await(long, TimeUnit) - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject
Implements timed condition wait.
await() - Method in interface java.util.concurrent.locks.Condition
Causes the current thread to wait until it is signalled or interrupted.
await(long, TimeUnit) - Method in interface java.util.concurrent.locks.Condition
Causes the current thread to wait until it is signalled or interrupted, or the specified waiting time elapses.
awaitAdvance(int) - Method in class java.util.concurrent.Phaser
Awaits the phase of this phaser to advance from the given phase value, returning immediately if the current phase is not equal to the given phase value or this phaser is terminated.
awaitAdvanceInterruptibly(int) - Method in class java.util.concurrent.Phaser
Awaits the phase of this phaser to advance from the given phase value, throwing InterruptedException if interrupted while waiting, or returning immediately if the current phase is not equal to the given phase value or this phaser is terminated.
awaitAdvanceInterruptibly(int, long, TimeUnit) - Method in class java.util.concurrent.Phaser
Awaits the phase of this phaser to advance from the given phase value or the given timeout to elapse, throwing InterruptedException if interrupted while waiting, or returning immediately if the current phase is not equal to the given phase value or this phaser is terminated.
awaitNanos(long) - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject
Implements timed condition wait.
awaitNanos(long) - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject
Implements timed condition wait.
awaitNanos(long) - Method in interface java.util.concurrent.locks.Condition
Causes the current thread to wait until it is signalled or interrupted, or the specified waiting time elapses.
awaitQuiescence(long, TimeUnit) - Method in class java.util.concurrent.ForkJoinPool
If called by a ForkJoinTask operating in this pool, equivalent in effect to ForkJoinTask.helpQuiesce().
awaitTermination(long, TimeUnit) - Method in class java.nio.channels.AsynchronousChannelGroup
Awaits termination of the group.
awaitTermination(long, TimeUnit) - Method in interface java.util.concurrent.ExecutorService
Blocks until all tasks have completed execution after a shutdown request, or the timeout occurs, or the current thread is interrupted, whichever happens first.
awaitTermination(long, TimeUnit) - Method in class java.util.concurrent.ForkJoinPool
Blocks until all tasks have completed execution after a shutdown request, or the timeout occurs, or the current thread is interrupted, whichever happens first.
awaitTermination(long, TimeUnit) - Method in class java.util.concurrent.ThreadPoolExecutor
awaitUninterruptibly() - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject
Implements uninterruptible condition wait.
awaitUninterruptibly() - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject
Implements uninterruptible condition wait.
awaitUninterruptibly() - Method in interface java.util.concurrent.locks.Condition
Causes the current thread to wait until it is signalled.
awaitUntil(Date) - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject
Implements absolute timed condition wait.
awaitUntil(Date) - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject
Implements absolute timed condition wait.
awaitUntil(Date) - Method in interface java.util.concurrent.locks.Condition
Causes the current thread to wait until it is signalled or interrupted, or the specified deadline elapses.
AWT_COMPONENT - Static variable in class javax.accessibility.AccessibleRole
An AWT component, but nothing else is known about it.
AWTError - Error in java.awt
Thrown when a serious Abstract Window Toolkit error has occurred.
AWTError(String) - Constructor for error java.awt.AWTError
Constructs an instance of AWTError with the specified detail message.
AWTEvent - Class in java.awt
The root event class for all AWT events.
AWTEvent(Event) - Constructor for class java.awt.AWTEvent
Constructs an AWTEvent object from the parameters of a 1.0-style event.
AWTEvent(Object, int) - Constructor for class java.awt.AWTEvent
Constructs an AWTEvent object with the specified source object and type.
AWTEventListener - Interface in java.awt.event
The listener interface for receiving notification of events dispatched to objects that are instances of Component or MenuComponent or their subclasses.
AWTEventListenerProxy - Class in java.awt.event
A class which extends the EventListenerProxy specifically for adding an AWTEventListener for a specific event mask.
AWTEventListenerProxy(long, AWTEventListener) - Constructor for class java.awt.event.AWTEventListenerProxy
Constructor which binds the AWTEventListener to a specific event mask.
AWTEventMulticaster - Class in java.awt
AWTEventMulticaster implements efficient and thread-safe multi-cast event dispatching for the AWT events defined in the java.awt.event package.
AWTEventMulticaster(EventListener, EventListener) - Constructor for class java.awt.AWTEventMulticaster
Creates an event multicaster instance which chains listener-a with listener-b.
AWTException - Exception in java.awt
Signals that an Abstract Window Toolkit exception has occurred.
AWTException(String) - Constructor for exception java.awt.AWTException
Constructs an instance of AWTException with the specified detail message.
AWTKeyStroke - Class in java.awt
An AWTKeyStroke represents a key action on the keyboard, or equivalent input device.
AWTKeyStroke() - Constructor for class java.awt.AWTKeyStroke
Constructs an AWTKeyStroke with default values.
AWTKeyStroke(char, int, int, boolean) - Constructor for class java.awt.AWTKeyStroke
Constructs an AWTKeyStroke with the specified values.
AWTPermission - Class in java.awt
This class is for AWT permissions.
AWTPermission(String) - Constructor for class java.awt.AWTPermission
Creates a new AWTPermission with the specified name.
AWTPermission(String, String) - Constructor for class java.awt.AWTPermission
Creates a new AWTPermission object with the specified name.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames


B-Index (Java Platform SE 8 )

Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames
  • All Classes
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

B

b - Variable in class java.awt.AWTEventMulticaster
B - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for Engineering B, 11 x 17 in.
B - Static variable in class javax.print.attribute.standard.MediaSize.Engineering
Specifies the engineering B size, 11 inch by 17 inch.
B - Static variable in class javax.print.attribute.standard.MediaSizeName
B size .
B - Static variable in class javax.swing.text.html.HTML.Tag
B0 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_B0.
B0 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO B0 size, 1000 mm by 1414 mm.
B0 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS B0 size, 1030 mm by 1456 mm.
B1 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_B1.
B1 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO B1 size, 707 mm by 1000 mm.
B1 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS B1 size, 728 mm by 1030 mm.
B10 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_B10.
B10 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO B10 size, 31 mm by 44 mm.
B10 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS B10 size, 32 mm by 45 mm.
B2 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_B2.
B2 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO B2 size, 500 mm by 707 mm.
B2 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS B2 size, 515 mm by 728 mm.
B3 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_B3.
B3 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO B3 size, 353 mm by 500 mm.
B3 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS B3 size, 364 mm by 515 mm.
B4 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_B4.
B4 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO B4 size, 250 mm by 353 mm.
B4 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS B4 size, 257 mm by 364 mm.
B5 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_B5.
B5 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO B5 size, 176 mm by 250 mm.
B5 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS B5 size, 182 mm by 257 mm.
B6 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_B6.
B6 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO B6 size, 125 mm by 176 mm.
B6 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS B6 size, 128 mm by 182 mm.
B7 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_B7.
B7 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO B7 size, 88 mm by 125 mm.
B7 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS B7 size, 91 mm by 128 mm.
B8 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_B8.
B8 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO B8 size, 62 mm by 88 mm.
B8 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS B8 size, 64 mm by 91 mm.
B9 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_B9.
B9 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO B9 size, 44 mm by 62 mm.
B9 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS B9 size, 45 mm by 64 mm.
BACK_SPACE - Static variable in class java.awt.Event
The BackSpace key.
backBuffers - Variable in class java.awt.Component.BltBufferStrategy
The back buffers
BACKGROUND - Static variable in class java.awt.BufferCapabilities.FlipContents
When flip contents are BACKGROUND, the contents of the back buffer are cleared with the background color after flipping.
BACKGROUND - Static variable in class java.awt.font.TextAttribute
Attribute key for the paint used to render the background of the text.
BACKGROUND - Static variable in class javax.swing.plaf.synth.ColorType
ColorType for the background of a region.
BACKGROUND - Static variable in class javax.swing.text.html.CSS.Attribute
BACKGROUND - Static variable in class javax.swing.text.html.HTML.Attribute
Background - Static variable in class javax.swing.text.StyleConstants
Name of the background color attribute.
BACKGROUND_ATTACHMENT - Static variable in class javax.swing.text.html.CSS.Attribute
BACKGROUND_COLOR - Static variable in class javax.swing.text.html.CSS.Attribute
BACKGROUND_IMAGE - Static variable in class javax.swing.text.html.CSS.Attribute
BACKGROUND_POSITION - Static variable in class javax.swing.text.html.CSS.Attribute
BACKGROUND_REPEAT - Static variable in class javax.swing.text.html.CSS.Attribute
backgroundNonSelectionColor - Variable in class javax.swing.tree.DefaultTreeCellRenderer
Color to use for the background when the node isn't selected.
backgroundSelectionColor - Variable in class javax.swing.tree.DefaultTreeCellRenderer
Color to use for the background when a node is selected.
backingStore - Variable in class javax.swing.JViewport
Deprecated.
As of Java 2 platform v1.3
BACKINGSTORE_SCROLL_MODE - Static variable in class javax.swing.JViewport
Draws viewport contents into an offscreen image.
BackingStoreException - Exception in java.util.prefs
Thrown to indicate that a preferences operation could not complete because of a failure in the backing store, or a failure to contact the backing store.
BackingStoreException(String) - Constructor for exception java.util.prefs.BackingStoreException
Constructs a BackingStoreException with the specified detail message.
BackingStoreException(Throwable) - Constructor for exception java.util.prefs.BackingStoreException
Constructs a BackingStoreException with the specified cause.
backingStoreImage - Variable in class javax.swing.JViewport
The view image used for a backing store.
Backward - Static variable in class javax.swing.text.Position.Bias
Indicates a bias toward the previous character in the model.
BACKWARD_TRAVERSAL_KEYS - Static variable in class java.awt.KeyboardFocusManager
The identifier for the Backward focus traversal keys.
backwardAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the Action for moving the caret logically backward one position.
BAD_BINDINGS - Static variable in exception org.ietf.jgss.GSSException
Channel bindings mismatch.
BAD_CONTEXT - Exception in org.omg.CORBA
Exception thrown when an operation is invoked by a client but the passed context does not contain the context values required by the operation.
BAD_CONTEXT() - Constructor for exception org.omg.CORBA.BAD_CONTEXT
Constructs a BAD_CONTEXT exception with a default minor code of 0 and a completion state of COMPLETED_NO.
BAD_CONTEXT(String) - Constructor for exception org.omg.CORBA.BAD_CONTEXT
Constructs a BAD_CONTEXT exception with the specified detail message, a minor code of 0 and a completion state of COMPLETED_NO.
BAD_CONTEXT(int, CompletionStatus) - Constructor for exception org.omg.CORBA.BAD_CONTEXT
Constructs a BAD_CONTEXT exception with the specified minor code and completion status.
BAD_CONTEXT(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.BAD_CONTEXT
Constructs a BAD_CONTEXT exception with the specified detail message, minor code, and completion status.
BAD_INV_ORDER - Exception in org.omg.CORBA
This exception indicates that the caller has invoked operations in the wrong order.
BAD_INV_ORDER() - Constructor for exception org.omg.CORBA.BAD_INV_ORDER
Constructs a BAD_INV_ORDER exception with a default minor code of 0 and a completion state of COMPLETED_NO.
BAD_INV_ORDER(String) - Constructor for exception org.omg.CORBA.BAD_INV_ORDER
Constructs a BAD_INV_ORDER exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
BAD_INV_ORDER(int, CompletionStatus) - Constructor for exception org.omg.CORBA.BAD_INV_ORDER
Constructs a BAD_INV_ORDER exceptionBAD_INV_ORDER with the specified minor code and completion status.
BAD_INV_ORDER(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.BAD_INV_ORDER
Constructs a BAD_INV_ORDER exception with the specified detail message, minor code, and completion status.
BAD_LOCATION - Static variable in class javax.swing.text.AbstractDocument
Error message to indicate a bad location.
BAD_MECH - Static variable in exception org.ietf.jgss.GSSException
Unsupported mechanism requested.
BAD_MIC - Static variable in exception org.ietf.jgss.GSSException
Token had invalid integrity check.
BAD_NAME - Static variable in exception org.ietf.jgss.GSSException
Invalid name provided.
BAD_NAMETYPE - Static variable in exception org.ietf.jgss.GSSException
Name of unsupported type provided.
BAD_OPERATION - Exception in org.omg.CORBA
Exception thrown when an object reference denotes an existing object, but that the object does not support the operation that was invoked.
BAD_OPERATION() - Constructor for exception org.omg.CORBA.BAD_OPERATION
Constructs a BAD_OPERATION exception with a default minor code of 0 and a completion state of COMPLETED_NO.
BAD_OPERATION(String) - Constructor for exception org.omg.CORBA.BAD_OPERATION
Constructs a BAD_OPERATION exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
BAD_OPERATION(int, CompletionStatus) - Constructor for exception org.omg.CORBA.BAD_OPERATION
Constructs a BAD_OPERATION exception with the specified minor code and completion status.
BAD_OPERATION(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.BAD_OPERATION
Constructs a BAD_OPERATION exception with the specified detail message, minor code, and completion status.
BAD_PARAM - Exception in org.omg.CORBA
Exception thrown when a parameter passed to a call is out of range or otherwise considered illegal.
BAD_PARAM() - Constructor for exception org.omg.CORBA.BAD_PARAM
Constructs a BAD_PARAM exception with a default minor code of 0 and a completion state of COMPLETED_NO.
BAD_PARAM(String) - Constructor for exception org.omg.CORBA.BAD_PARAM
Constructs a BAD_PARAM exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
BAD_PARAM(int, CompletionStatus) - Constructor for exception org.omg.CORBA.BAD_PARAM
Constructs a BAD_PARAM exception with the specified minor code and completion status.
BAD_PARAM(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.BAD_PARAM
Constructs a BAD_PARAM exception with the specified detail message, minor code, and completion status.
BAD_POLICY - Interface in org.omg.CORBA
A PolicyErrorCode which would be filled in the PolicyError exception.
BAD_POLICY_TYPE - Interface in org.omg.CORBA
A PolicyErrorCode which would be filled in the PolicyError exception.
BAD_POLICY_VALUE - Interface in org.omg.CORBA
Contains the value used to indicate a policy value that is incorrect for a valid policy type in a call to the create_policy method defined in the ORB class.
BAD_QOP - Static variable in exception org.ietf.jgss.GSSException
Unsupported QOP value.
BAD_QOS - Exception in org.omg.CORBA
The BAD_QOS exception is raised whenever an object cannot support the quality of service required by an invocation parameter that has a quality of service semantics associated with it.
BAD_QOS() - Constructor for exception org.omg.CORBA.BAD_QOS
Constructs an BAD_QOS exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.
BAD_QOS(String) - Constructor for exception org.omg.CORBA.BAD_QOS
Constructs an BAD_QOS exception with the specified message.
BAD_QOS(int, CompletionStatus) - Constructor for exception org.omg.CORBA.BAD_QOS
Constructs an BAD_QOS exception with the specified minor code and completion status.
BAD_QOS(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.BAD_QOS
Constructs an BAD_QOS exception with the specified message, minor code, and completion status.
BAD_STATUS - Static variable in exception org.ietf.jgss.GSSException
Invalid status code.
BAD_TYPECODE - Exception in org.omg.CORBA
Exception thrown when the ORB has encountered a malformed type code (for example, a type code with an invalid TCKind value).
BAD_TYPECODE() - Constructor for exception org.omg.CORBA.BAD_TYPECODE
Constructs a BAD_TYPECODE exception with a default minor code of 0 and a completion state of COMPLETED_NO.
BAD_TYPECODE(String) - Constructor for exception org.omg.CORBA.BAD_TYPECODE
Constructs a BAD_TYPECODE exception with the specified detail, a minor code of 0, and a completion state of COMPLETED_NO.
BAD_TYPECODE(int, CompletionStatus) - Constructor for exception org.omg.CORBA.BAD_TYPECODE
Constructs a BAD_TYPECODE exception with the specified minor code and completion status.
BAD_TYPECODE(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.BAD_TYPECODE
Constructs a BAD_TYPECODE exception with the specified detail message, minor code, and completion status.
BadAttributeValueExpException - Exception in javax.management
Thrown when an invalid MBean attribute is passed to a query constructing method.
BadAttributeValueExpException(Object) - Constructor for exception javax.management.BadAttributeValueExpException
Constructs a BadAttributeValueExpException using the specified Object to create the toString() value.
BadBinaryOpValueExpException - Exception in javax.management
Thrown when an invalid expression is passed to a method for constructing a query.
BadBinaryOpValueExpException(ValueExp) - Constructor for exception javax.management.BadBinaryOpValueExpException
Constructs a BadBinaryOpValueExpException with the specified ValueExp.
BadBreakWeight - Static variable in class javax.swing.text.View
The weight to indicate a view is a bad break opportunity for the purpose of formatting.
BadKind - Exception in org.omg.CORBA.TypeCodePackage
The exception BadKind is thrown when an inappropriate operation is invoked on a TypeCode object.
BadKind() - Constructor for exception org.omg.CORBA.TypeCodePackage.BadKind
Constructs a BadKind exception with no reason message.
BadKind(String) - Constructor for exception org.omg.CORBA.TypeCodePackage.BadKind
Constructs a BadKind exception with the specified reason message.
BadLocationException - Exception in javax.swing.text
This exception is to report bad locations within a document model (that is, attempts to reference a location that doesn't exist).
BadLocationException(String, int) - Constructor for exception javax.swing.text.BadLocationException
Creates a new BadLocationException object.
BadPaddingException - Exception in javax.crypto
This exception is thrown when a particular padding mechanism is expected for the input data but the data is not padded properly.
BadPaddingException() - Constructor for exception javax.crypto.BadPaddingException
Constructs a BadPaddingException with no detail message.
BadPaddingException(String) - Constructor for exception javax.crypto.BadPaddingException
Constructs a BadPaddingException with the specified detail message.
BadStringOperationException - Exception in javax.management
Thrown when an invalid string operation is passed to a method for constructing a query.
BadStringOperationException(String) - Constructor for exception javax.management.BadStringOperationException
Constructs a BadStringOperationException with the specified detail message.
BALANCE - Static variable in class javax.sound.sampled.FloatControl.Type
Represents a control for the relative balance of a stereo signal between two stereo speakers.
BALINESE - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Balinese" Unicode character block.
BAMUM - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Bamum" Unicode character block.
BAMUM_SUPPLEMENT - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Bamum Supplement" Unicode character block.
BandCombineOp - Class in java.awt.image
This class performs an arbitrary linear combination of the bands in a Raster, using a specified matrix.
BandCombineOp(float[][], RenderingHints) - Constructor for class java.awt.image.BandCombineOp
Constructs a BandCombineOp with the specified matrix.
BandedSampleModel - Class in java.awt.image
This class represents image data which is stored in a band interleaved fashion and for which each sample of a pixel occupies one data element of the DataBuffer.
BandedSampleModel(int, int, int, int) - Constructor for class java.awt.image.BandedSampleModel
Constructs a BandedSampleModel with the specified parameters.
BandedSampleModel(int, int, int, int, int[], int[]) - Constructor for class java.awt.image.BandedSampleModel
Constructs a BandedSampleModel with the specified parameters.
bandOffsets - Variable in class java.awt.image.ComponentSampleModel
Offsets for all bands in data array elements.
bank - Variable in class javax.sound.midi.VoiceStatus
The bank number of the instrument that this voice is currently using.
bankIndices - Variable in class java.awt.image.ComponentSampleModel
Index for each bank storing a band of image data.
banks - Variable in class java.awt.image.DataBuffer
The number of banks in this DataBuffer.
BASE - Static variable in class javax.swing.text.html.HTML.Tag
base - Variable in class javax.swing.text.html.parser.DTD
Base64 - Class in java.util
This class consists exclusively of static methods for obtaining encoders and decoders for the Base64 encoding scheme.
BASE64 - Static variable in interface javax.xml.crypto.dsig.Transform
The Base64 transform algorithm URI.
Base64.Decoder - Class in java.util
This class implements a decoder for decoding byte data using the Base64 encoding scheme as specified in RFC 4648 and RFC 2045.
Base64.Encoder - Class in java.util
This class implements an encoder for encoding byte data using the Base64 encoding scheme as specified in RFC 4648 and RFC 2045.
BASEFONT - Static variable in class javax.swing.text.html.HTML.Tag
baseIsLeftToRight() - Method in class java.text.Bidi
Return true if the base direction is left-to-right.
BASELINE - Static variable in class java.awt.GridBagConstraints
Possible value for the anchor field.
BASELINE - Static variable in class javax.swing.SpringLayout
Specifies the baseline of a component.
BASELINE_LEADING - Static variable in class java.awt.GridBagConstraints
Possible value for the anchor field.
BASELINE_TRAILING - Static variable in class java.awt.GridBagConstraints
Possible value for the anchor field.
baselineLayout(int, int, int[], int[]) - Method in class javax.swing.text.BoxView
Computes the location and extent of each child view in this BoxView given the targetSpan, which is the width (or height) of the region we have to work with.
baselineRequirements(int, SizeRequirements) - Method in class javax.swing.text.BoxView
Calculates the size requirements for this BoxView by examining the size of each child view.
BaseRowSet - Class in javax.sql.rowset
An abstract class providing a RowSet object with its basic functionality.
BaseRowSet() - Constructor for class javax.sql.rowset.BaseRowSet
Constructs a new BaseRowSet object initialized with a default Vector object for its listeners field.
BaseStream<T,S extends BaseStream<T,S>> - Interface in java.util.stream
Base interface for streams, which are sequences of elements supporting sequential and parallel aggregate operations.
baseWireHandle - Static variable in interface java.io.ObjectStreamConstants
First wire handle to be assigned.
BASIC_ISO_DATE - Static variable in class java.time.format.DateTimeFormatter
The ISO date formatter that formats or parses a date without an offset, such as '20111203'.
BASIC_LATIN - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Basic Latin" Unicode character block.
BasicArrowButton - Class in javax.swing.plaf.basic
JButton object that draws a scaled Arrow in one of the cardinal directions.
BasicArrowButton(int, Color, Color, Color, Color) - Constructor for class javax.swing.plaf.basic.BasicArrowButton
Creates a BasicArrowButton whose arrow is drawn in the specified direction and with the specified colors.
BasicArrowButton(int) - Constructor for class javax.swing.plaf.basic.BasicArrowButton
Creates a BasicArrowButton whose arrow is drawn in the specified direction.
BasicAttribute - Class in javax.naming.directory
This class provides a basic implementation of the Attribute interface.
BasicAttribute(String) - Constructor for class javax.naming.directory.BasicAttribute
Constructs a new instance of an unordered attribute with no value.
BasicAttribute(String, Object) - Constructor for class javax.naming.directory.BasicAttribute
Constructs a new instance of an unordered attribute with a single value.
BasicAttribute(String, boolean) - Constructor for class javax.naming.directory.BasicAttribute
Constructs a new instance of a possibly ordered attribute with no value.
BasicAttribute(String, Object, boolean) - Constructor for class javax.naming.directory.BasicAttribute
Constructs a new instance of a possibly ordered attribute with a single value.
BasicAttributes - Class in javax.naming.directory
This class provides a basic implementation of the Attributes interface.
BasicAttributes() - Constructor for class javax.naming.directory.BasicAttributes
Constructs a new instance of Attributes.
BasicAttributes(boolean) - Constructor for class javax.naming.directory.BasicAttributes
Constructs a new instance of Attributes.
BasicAttributes(String, Object) - Constructor for class javax.naming.directory.BasicAttributes
Constructs a new instance of Attributes with one attribute.
BasicAttributes(String, Object, boolean) - Constructor for class javax.naming.directory.BasicAttributes
Constructs a new instance of Attributes with one attribute.
BasicBorders - Class in javax.swing.plaf.basic
Factory object that can vend Borders appropriate for the basic L & F.
BasicBorders() - Constructor for class javax.swing.plaf.basic.BasicBorders
BasicBorders.ButtonBorder - Class in javax.swing.plaf.basic
BasicBorders.FieldBorder - Class in javax.swing.plaf.basic
BasicBorders.MarginBorder - Class in javax.swing.plaf.basic
BasicBorders.MenuBarBorder - Class in javax.swing.plaf.basic
BasicBorders.RadioButtonBorder - Class in javax.swing.plaf.basic
BasicBorders.RolloverButtonBorder - Class in javax.swing.plaf.basic
Special thin border for rollover toolbar buttons.
BasicBorders.SplitPaneBorder - Class in javax.swing.plaf.basic
Draws the border around the splitpane.
BasicBorders.ToggleButtonBorder - Class in javax.swing.plaf.basic
BasicButtonListener - Class in javax.swing.plaf.basic
Button Listener
BasicButtonListener(AbstractButton) - Constructor for class javax.swing.plaf.basic.BasicButtonListener
BasicButtonUI - Class in javax.swing.plaf.basic
BasicButton implementation
BasicButtonUI() - Constructor for class javax.swing.plaf.basic.BasicButtonUI
BasicCaret() - Constructor for class javax.swing.plaf.basic.BasicTextUI.BasicCaret
BasicCheckBoxMenuItemUI - Class in javax.swing.plaf.basic
BasicCheckboxMenuItem implementation
BasicCheckBoxMenuItemUI() - Constructor for class javax.swing.plaf.basic.BasicCheckBoxMenuItemUI
BasicCheckBoxUI - Class in javax.swing.plaf.basic
CheckboxUI implementation for BasicCheckboxUI
BasicCheckBoxUI() - Constructor for class javax.swing.plaf.basic.BasicCheckBoxUI
BasicColorChooserUI - Class in javax.swing.plaf.basic
Provides the basic look and feel for a JColorChooser.
BasicColorChooserUI() - Constructor for class javax.swing.plaf.basic.BasicColorChooserUI
BasicColorChooserUI.PropertyHandler - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicComboBoxEditor - Class in javax.swing.plaf.basic
The default editor for editable combo boxes.
BasicComboBoxEditor() - Constructor for class javax.swing.plaf.basic.BasicComboBoxEditor
BasicComboBoxEditor.UIResource - Class in javax.swing.plaf.basic
A subclass of BasicComboBoxEditor that implements UIResource.
BasicComboBoxRenderer - Class in javax.swing.plaf.basic
ComboBox renderer
BasicComboBoxRenderer() - Constructor for class javax.swing.plaf.basic.BasicComboBoxRenderer
BasicComboBoxRenderer.UIResource - Class in javax.swing.plaf.basic
A subclass of BasicComboBoxRenderer that implements UIResource.
BasicComboBoxUI - Class in javax.swing.plaf.basic
Basic UI implementation for JComboBox.
BasicComboBoxUI() - Constructor for class javax.swing.plaf.basic.BasicComboBoxUI
BasicComboBoxUI.ComboBoxLayoutManager - Class in javax.swing.plaf.basic
This layout manager handles the 'standard' layout of combo boxes.
BasicComboBoxUI.FocusHandler - Class in javax.swing.plaf.basic
This listener hides the popup when the focus is lost.
BasicComboBoxUI.ItemHandler - Class in javax.swing.plaf.basic
This listener watches for changes to the selection in the combo box.
BasicComboBoxUI.KeyHandler - Class in javax.swing.plaf.basic
This listener checks to see if the key event isn't a navigation key.
BasicComboBoxUI.ListDataHandler - Class in javax.swing.plaf.basic
This listener watches for changes in the ComboBoxModel.
BasicComboBoxUI.PropertyChangeHandler - Class in javax.swing.plaf.basic
This listener watches for bound properties that have changed in the combo box.
BasicComboPopup - Class in javax.swing.plaf.basic
This is a basic implementation of the ComboPopup interface.
BasicComboPopup(JComboBox) - Constructor for class javax.swing.plaf.basic.BasicComboPopup
BasicComboPopup.InvocationKeyHandler - Class in javax.swing.plaf.basic
As of Java 2 platform v 1.4, this class is now obsolete and is only included for backwards API compatibility.
BasicComboPopup.InvocationMouseHandler - Class in javax.swing.plaf.basic
A listener to be registered upon the combo box (not its popup menu) to handle mouse events that affect the state of the popup menu.
BasicComboPopup.InvocationMouseMotionHandler - Class in javax.swing.plaf.basic
This listener watches for dragging and updates the current selection in the list if it is dragging over the list.
BasicComboPopup.ItemHandler - Class in javax.swing.plaf.basic
This listener watches for changes to the selection in the combo box.
BasicComboPopup.ListDataHandler - Class in javax.swing.plaf.basic
As of 1.4, this class is now obsolete, doesn't do anything, and is only included for backwards API compatibility.
BasicComboPopup.ListMouseHandler - Class in javax.swing.plaf.basic
This listener hides the popup when the mouse is released in the list.
BasicComboPopup.ListMouseMotionHandler - Class in javax.swing.plaf.basic
This listener changes the selected item as you move the mouse over the list.
BasicComboPopup.ListSelectionHandler - Class in javax.swing.plaf.basic
As of Java 2 platform v 1.4, this class is now obsolete, doesn't do anything, and is only included for backwards API compatibility.
BasicComboPopup.PropertyChangeHandler - Class in javax.swing.plaf.basic
This listener watches for bound properties that have changed in the combo box.
BasicControl - Class in javax.naming.ldap
This class provides a basic implementation of the Control interface.
BasicControl(String) - Constructor for class javax.naming.ldap.BasicControl
Constructs a non-critical control.
BasicControl(String, boolean, byte[]) - Constructor for class javax.naming.ldap.BasicControl
Constructs a control using the supplied arguments.
BasicDesktopIconUI - Class in javax.swing.plaf.basic
Basic L&F for a minimized window on a desktop.
BasicDesktopIconUI() - Constructor for class javax.swing.plaf.basic.BasicDesktopIconUI
BasicDesktopIconUI.MouseInputHandler - Class in javax.swing.plaf.basic
Listens for mouse movements and acts on them.
BasicDesktopPaneUI - Class in javax.swing.plaf.basic
Basic L&F for a desktop.
BasicDesktopPaneUI() - Constructor for class javax.swing.plaf.basic.BasicDesktopPaneUI
BasicDesktopPaneUI.CloseAction - Class in javax.swing.plaf.basic
Handles closing an internal frame.
BasicDesktopPaneUI.MaximizeAction - Class in javax.swing.plaf.basic
Handles maximizing an internal frame.
BasicDesktopPaneUI.MinimizeAction - Class in javax.swing.plaf.basic
Handles minimizing an internal frame.
BasicDesktopPaneUI.NavigateAction - Class in javax.swing.plaf.basic
Handles navigating to the next internal frame.
BasicDesktopPaneUI.OpenAction - Class in javax.swing.plaf.basic
Handles restoring a minimized or maximized internal frame.
BasicDirectoryModel - Class in javax.swing.plaf.basic
Basic implementation of a file list.
BasicDirectoryModel(JFileChooser) - Constructor for class javax.swing.plaf.basic.BasicDirectoryModel
BasicEditorPaneUI - Class in javax.swing.plaf.basic
Provides the look and feel for a JEditorPane.
BasicEditorPaneUI() - Constructor for class javax.swing.plaf.basic.BasicEditorPaneUI
Creates a new BasicEditorPaneUI.
BasicFileAttributes - Interface in java.nio.file.attribute
Basic attributes associated with a file in a file system.
BasicFileAttributeView - Interface in java.nio.file.attribute
A file attribute view that provides a view of a basic set of file attributes common to many file systems.
BasicFileChooserUI - Class in javax.swing.plaf.basic
Basic L&F implementation of a FileChooser.
BasicFileChooserUI(JFileChooser) - Constructor for class javax.swing.plaf.basic.BasicFileChooserUI
BasicFileChooserUI.AcceptAllFileFilter - Class in javax.swing.plaf.basic
BasicFileChooserUI.ApproveSelectionAction - Class in javax.swing.plaf.basic
Responds to an Open or Save request
BasicFileChooserUI.BasicFileView - Class in javax.swing.plaf.basic
BasicFileChooserUI.CancelSelectionAction - Class in javax.swing.plaf.basic
Responds to a cancel request.
BasicFileChooserUI.ChangeToParentDirectoryAction - Class in javax.swing.plaf.basic
BasicFileChooserUI.DoubleClickListener - Class in javax.swing.plaf.basic
BasicFileChooserUI.GoHomeAction - Class in javax.swing.plaf.basic
Acts on the "home" key event or equivalent event.
BasicFileChooserUI.NewFolderAction - Class in javax.swing.plaf.basic
Creates a new folder.
BasicFileChooserUI.SelectionListener - Class in javax.swing.plaf.basic
BasicFileChooserUI.UpdateAction - Class in javax.swing.plaf.basic
Rescans the files in the current directory
BasicFileView() - Constructor for class javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView
BasicFormattedTextFieldUI - Class in javax.swing.plaf.basic
Provides the look and feel implementation for JFormattedTextField.
BasicFormattedTextFieldUI() - Constructor for class javax.swing.plaf.basic.BasicFormattedTextFieldUI
BasicGraphicsUtils - Class in javax.swing.plaf.basic
BasicGraphicsUtils() - Constructor for class javax.swing.plaf.basic.BasicGraphicsUtils
BasicHighlighter() - Constructor for class javax.swing.plaf.basic.BasicTextUI.BasicHighlighter
BasicHTML - Class in javax.swing.plaf.basic
Support for providing html views for the swing components.
BasicHTML() - Constructor for class javax.swing.plaf.basic.BasicHTML
BasicIconFactory - Class in javax.swing.plaf.basic
Factory object that can vend Icons appropriate for the basic L & F.
BasicIconFactory() - Constructor for class javax.swing.plaf.basic.BasicIconFactory
BasicInternalFrameListener() - Constructor for class javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener
BasicInternalFrameTitlePane - Class in javax.swing.plaf.basic
The class that manages a basic title bar
BasicInternalFrameTitlePane(JInternalFrame) - Constructor for class javax.swing.plaf.basic.BasicInternalFrameTitlePane
BasicInternalFrameTitlePane.CloseAction - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicInternalFrameTitlePane.IconifyAction - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicInternalFrameTitlePane.MaximizeAction - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicInternalFrameTitlePane.MoveAction - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicInternalFrameTitlePane.PropertyChangeHandler - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicInternalFrameTitlePane.RestoreAction - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicInternalFrameTitlePane.SizeAction - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicInternalFrameTitlePane.SystemMenuBar - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicInternalFrameTitlePane.TitlePaneLayout - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicInternalFrameUI - Class in javax.swing.plaf.basic
A basic L&F implementation of JInternalFrame.
BasicInternalFrameUI(JInternalFrame) - Constructor for class javax.swing.plaf.basic.BasicInternalFrameUI
BasicInternalFrameUI.BasicInternalFrameListener - Class in javax.swing.plaf.basic
BasicInternalFrameUI.BorderListener - Class in javax.swing.plaf.basic
Listens for border adjustments.
BasicInternalFrameUI.ComponentHandler - Class in javax.swing.plaf.basic
BasicInternalFrameUI.GlassPaneDispatcher - Class in javax.swing.plaf.basic
BasicInternalFrameUI.InternalFrameLayout - Class in javax.swing.plaf.basic
BasicInternalFrameUI.InternalFramePropertyChangeListener - Class in javax.swing.plaf.basic
BasicLabelUI - Class in javax.swing.plaf.basic
A Windows L&F implementation of LabelUI.
BasicLabelUI() - Constructor for class javax.swing.plaf.basic.BasicLabelUI
BasicListUI - Class in javax.swing.plaf.basic
An extensible implementation of ListUI.
BasicListUI() - Constructor for class javax.swing.plaf.basic.BasicListUI
BasicListUI.FocusHandler - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicListUI.ListDataHandler - Class in javax.swing.plaf.basic
The ListDataListener that's added to the JLists model at installUI time, and whenever the JList.model property changes.
BasicListUI.ListSelectionHandler - Class in javax.swing.plaf.basic
The ListSelectionListener that's added to the JLists selection model at installUI time, and whenever the JList.selectionModel property changes.
BasicListUI.MouseInputHandler - Class in javax.swing.plaf.basic
Mouse input, and focus handling for JList.
BasicListUI.PropertyChangeHandler - Class in javax.swing.plaf.basic
The PropertyChangeListener that's added to the JList at installUI time.
BasicLookAndFeel - Class in javax.swing.plaf.basic
A base class to use in creating a look and feel for Swing.
BasicLookAndFeel() - Constructor for class javax.swing.plaf.basic.BasicLookAndFeel
BasicMenuBarUI - Class in javax.swing.plaf.basic
A default L&F implementation of MenuBarUI.
BasicMenuBarUI() - Constructor for class javax.swing.plaf.basic.BasicMenuBarUI
BasicMenuItemUI - Class in javax.swing.plaf.basic
BasicMenuItem implementation
BasicMenuItemUI() - Constructor for class javax.swing.plaf.basic.BasicMenuItemUI
BasicMenuItemUI.MouseInputHandler - Class in javax.swing.plaf.basic
BasicMenuUI - Class in javax.swing.plaf.basic
A default L&F implementation of MenuUI.
BasicMenuUI() - Constructor for class javax.swing.plaf.basic.BasicMenuUI
BasicMenuUI.ChangeHandler - Class in javax.swing.plaf.basic
As of Java 2 platform 1.4, this previously undocumented class is now obsolete.
BasicMenuUI.MouseInputHandler - Class in javax.swing.plaf.basic
Instantiated and used by a menu item to handle the current menu selection from mouse events.
BasicOptionPaneUI - Class in javax.swing.plaf.basic
Provides the basic look and feel for a JOptionPane.
BasicOptionPaneUI() - Constructor for class javax.swing.plaf.basic.BasicOptionPaneUI
BasicOptionPaneUI.ButtonActionListener - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicOptionPaneUI.ButtonAreaLayout - Class in javax.swing.plaf.basic
ButtonAreaLayout behaves in a similar manner to FlowLayout.
BasicOptionPaneUI.PropertyChangeHandler - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicPanelUI - Class in javax.swing.plaf.basic
BasicPanel implementation
BasicPanelUI() - Constructor for class javax.swing.plaf.basic.BasicPanelUI
BasicPasswordFieldUI - Class in javax.swing.plaf.basic
Provides the Windows look and feel for a password field.
BasicPasswordFieldUI() - Constructor for class javax.swing.plaf.basic.BasicPasswordFieldUI
BasicPermission - Class in java.security
The BasicPermission class extends the Permission class, and can be used as the base class for permissions that want to follow the same naming convention as BasicPermission.
BasicPermission(String) - Constructor for class java.security.BasicPermission
Creates a new BasicPermission with the specified name.
BasicPermission(String, String) - Constructor for class java.security.BasicPermission
Creates a new BasicPermission object with the specified name.
BasicPopupMenuSeparatorUI - Class in javax.swing.plaf.basic
A Basic L&F implementation of PopupMenuSeparatorUI.
BasicPopupMenuSeparatorUI() - Constructor for class javax.swing.plaf.basic.BasicPopupMenuSeparatorUI
BasicPopupMenuUI - Class in javax.swing.plaf.basic
A Windows L&F implementation of PopupMenuUI.
BasicPopupMenuUI() - Constructor for class javax.swing.plaf.basic.BasicPopupMenuUI
BasicProgressBarUI - Class in javax.swing.plaf.basic
A Basic L&F implementation of ProgressBarUI.
BasicProgressBarUI() - Constructor for class javax.swing.plaf.basic.BasicProgressBarUI
BasicProgressBarUI.ChangeHandler - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicRadioButtonMenuItemUI - Class in javax.swing.plaf.basic
BasicRadioButtonMenuItem implementation
BasicRadioButtonMenuItemUI() - Constructor for class javax.swing.plaf.basic.BasicRadioButtonMenuItemUI
BasicRadioButtonUI - Class in javax.swing.plaf.basic
RadioButtonUI implementation for BasicRadioButtonUI
BasicRadioButtonUI() - Constructor for class javax.swing.plaf.basic.BasicRadioButtonUI
BasicRootPaneUI - Class in javax.swing.plaf.basic
Basic implementation of RootPaneUI, there is one shared between all JRootPane instances.
BasicRootPaneUI() - Constructor for class javax.swing.plaf.basic.BasicRootPaneUI
BasicScrollBarUI - Class in javax.swing.plaf.basic
Implementation of ScrollBarUI for the Basic Look and Feel
BasicScrollBarUI() - Constructor for class javax.swing.plaf.basic.BasicScrollBarUI
BasicScrollBarUI.ArrowButtonListener - Class in javax.swing.plaf.basic
Listener for cursor keys.
BasicScrollBarUI.ModelListener - Class in javax.swing.plaf.basic
A listener to listen for model changes.
BasicScrollBarUI.PropertyChangeHandler - Class in javax.swing.plaf.basic
BasicScrollBarUI.ScrollListener - Class in javax.swing.plaf.basic
Listener for scrolling events initiated in the ScrollPane.
BasicScrollBarUI.TrackListener - Class in javax.swing.plaf.basic
Track mouse drags.
BasicScrollPaneUI - Class in javax.swing.plaf.basic
A default L&F implementation of ScrollPaneUI.
BasicScrollPaneUI() - Constructor for class javax.swing.plaf.basic.BasicScrollPaneUI
BasicScrollPaneUI.HSBChangeListener - Class in javax.swing.plaf.basic
Horizontal scrollbar listener.
BasicScrollPaneUI.MouseWheelHandler - Class in javax.swing.plaf.basic
MouseWheelHandler is an inner class which implements the MouseWheelListener interface.
BasicScrollPaneUI.PropertyChangeHandler - Class in javax.swing.plaf.basic
BasicScrollPaneUI.ViewportChangeHandler - Class in javax.swing.plaf.basic
Listener for viewport events.
BasicScrollPaneUI.VSBChangeListener - Class in javax.swing.plaf.basic
Vertical scrollbar listener.
BasicSeparatorUI - Class in javax.swing.plaf.basic
A Basic L&F implementation of SeparatorUI.
BasicSeparatorUI() - Constructor for class javax.swing.plaf.basic.BasicSeparatorUI
BasicSliderUI - Class in javax.swing.plaf.basic
A Basic L&F implementation of SliderUI.
BasicSliderUI(JSlider) - Constructor for class javax.swing.plaf.basic.BasicSliderUI
BasicSliderUI.ActionScroller - Class in javax.swing.plaf.basic
As of Java 2 platform v1.3 this undocumented class is no longer used.
BasicSliderUI.ChangeHandler - Class in javax.swing.plaf.basic
Data model listener.
BasicSliderUI.ComponentHandler - Class in javax.swing.plaf.basic
Listener for resizing events.
BasicSliderUI.FocusHandler - Class in javax.swing.plaf.basic
Focus-change listener.
BasicSliderUI.PropertyChangeHandler - Class in javax.swing.plaf.basic
BasicSliderUI.ScrollListener - Class in javax.swing.plaf.basic
Scroll-event listener.
BasicSliderUI.TrackListener - Class in javax.swing.plaf.basic
Track mouse movements.
BasicSpinnerUI - Class in javax.swing.plaf.basic
The default Spinner UI delegate.
BasicSpinnerUI() - Constructor for class javax.swing.plaf.basic.BasicSpinnerUI
BasicSplitPaneDivider - Class in javax.swing.plaf.basic
Divider used by BasicSplitPaneUI.
BasicSplitPaneDivider(BasicSplitPaneUI) - Constructor for class javax.swing.plaf.basic.BasicSplitPaneDivider
Creates an instance of BasicSplitPaneDivider.
BasicSplitPaneDivider.DividerLayout - Class in javax.swing.plaf.basic
Used to layout a BasicSplitPaneDivider.
BasicSplitPaneDivider.DragController - Class in javax.swing.plaf.basic
Handles the events during a dragging session for a HORIZONTAL_SPLIT oriented split pane.
BasicSplitPaneDivider.MouseHandler - Class in javax.swing.plaf.basic
MouseHandler is responsible for converting mouse events (released, dragged...) into the appropriate DragController methods.
BasicSplitPaneDivider.VerticalDragController - Class in javax.swing.plaf.basic
Handles the events during a dragging session for a VERTICAL_SPLIT oriented split pane.
BasicSplitPaneUI - Class in javax.swing.plaf.basic
A Basic L&F implementation of the SplitPaneUI.
BasicSplitPaneUI() - Constructor for class javax.swing.plaf.basic.BasicSplitPaneUI
BasicSplitPaneUI.BasicHorizontalLayoutManager - Class in javax.swing.plaf.basic
LayoutManager for JSplitPanes that have an orientation of HORIZONTAL_SPLIT.
BasicSplitPaneUI.BasicVerticalLayoutManager - Class in javax.swing.plaf.basic
LayoutManager used for JSplitPanes with an orientation of VERTICAL_SPLIT.
BasicSplitPaneUI.FocusHandler - Class in javax.swing.plaf.basic
Implementation of the FocusListener that the JSplitPane UI uses.
BasicSplitPaneUI.KeyboardDownRightHandler - Class in javax.swing.plaf.basic
Implementation of an ActionListener that the JSplitPane UI uses for handling specific key presses.
BasicSplitPaneUI.KeyboardEndHandler - Class in javax.swing.plaf.basic
Implementation of an ActionListener that the JSplitPane UI uses for handling specific key presses.
BasicSplitPaneUI.KeyboardHomeHandler - Class in javax.swing.plaf.basic
Implementation of an ActionListener that the JSplitPane UI uses for handling specific key presses.
BasicSplitPaneUI.KeyboardResizeToggleHandler - Class in javax.swing.plaf.basic
Implementation of an ActionListener that the JSplitPane UI uses for handling specific key presses.
BasicSplitPaneUI.KeyboardUpLeftHandler - Class in javax.swing.plaf.basic
Implementation of an ActionListener that the JSplitPane UI uses for handling specific key presses.
BasicSplitPaneUI.PropertyHandler - Class in javax.swing.plaf.basic
Implementation of the PropertyChangeListener that the JSplitPane UI uses.
BasicStroke - Class in java.awt
The BasicStroke class defines a basic set of rendering attributes for the outlines of graphics primitives, which are rendered with a Graphics2D object that has its Stroke attribute set to this BasicStroke.
BasicStroke(float, int, int, float, float[], float) - Constructor for class java.awt.BasicStroke
Constructs a new BasicStroke with the specified attributes.
BasicStroke(float, int, int, float) - Constructor for class java.awt.BasicStroke
Constructs a solid BasicStroke with the specified attributes.
BasicStroke(float, int, int) - Constructor for class java.awt.BasicStroke
Constructs a solid BasicStroke with the specified attributes.
BasicStroke(float) - Constructor for class java.awt.BasicStroke
Constructs a solid BasicStroke with the specified line width and with default values for the cap and join styles.
BasicStroke() - Constructor for class java.awt.BasicStroke
Constructs a new BasicStroke with defaults for all attributes.
BasicTabbedPaneUI - Class in javax.swing.plaf.basic
A Basic L&F implementation of TabbedPaneUI.
BasicTabbedPaneUI() - Constructor for class javax.swing.plaf.basic.BasicTabbedPaneUI
BasicTabbedPaneUI.FocusHandler - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicTabbedPaneUI.MouseHandler - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicTabbedPaneUI.PropertyChangeHandler - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicTabbedPaneUI.TabbedPaneLayout - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicTabbedPaneUI.TabSelectionHandler - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicTableHeaderUI - Class in javax.swing.plaf.basic
BasicTableHeaderUI implementation
BasicTableHeaderUI() - Constructor for class javax.swing.plaf.basic.BasicTableHeaderUI
BasicTableHeaderUI.MouseInputHandler - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicTableUI - Class in javax.swing.plaf.basic
BasicTableUI implementation
BasicTableUI() - Constructor for class javax.swing.plaf.basic.BasicTableUI
BasicTableUI.FocusHandler - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicTableUI.KeyHandler - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicTableUI.MouseInputHandler - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicTextAreaUI - Class in javax.swing.plaf.basic
Provides the look and feel for a plain text editor.
BasicTextAreaUI() - Constructor for class javax.swing.plaf.basic.BasicTextAreaUI
Constructs a new BasicTextAreaUI object.
BasicTextFieldUI - Class in javax.swing.plaf.basic
Basis of a look and feel for a JTextField.
BasicTextFieldUI() - Constructor for class javax.swing.plaf.basic.BasicTextFieldUI
Creates a new BasicTextFieldUI.
BasicTextPaneUI - Class in javax.swing.plaf.basic
Provides the look and feel for a styled text editor.
BasicTextPaneUI() - Constructor for class javax.swing.plaf.basic.BasicTextPaneUI
Creates a new BasicTextPaneUI.
BasicTextUI - Class in javax.swing.plaf.basic
Basis of a text components look-and-feel.
BasicTextUI() - Constructor for class javax.swing.plaf.basic.BasicTextUI
Creates a new UI.
BasicTextUI.BasicCaret - Class in javax.swing.plaf.basic
BasicTextUI.BasicHighlighter - Class in javax.swing.plaf.basic
BasicToggleButtonUI - Class in javax.swing.plaf.basic
BasicToggleButton implementation
BasicToggleButtonUI() - Constructor for class javax.swing.plaf.basic.BasicToggleButtonUI
BasicToolBarSeparatorUI - Class in javax.swing.plaf.basic
A Basic L&F implementation of ToolBarSeparatorUI.
BasicToolBarSeparatorUI() - Constructor for class javax.swing.plaf.basic.BasicToolBarSeparatorUI
BasicToolBarUI - Class in javax.swing.plaf.basic
A Basic L&F implementation of ToolBarUI.
BasicToolBarUI() - Constructor for class javax.swing.plaf.basic.BasicToolBarUI
BasicToolBarUI.DockingListener - Class in javax.swing.plaf.basic
This class should be treated as a "protected" inner class.
BasicToolBarUI.DragWindow - Class in javax.swing.plaf.basic
BasicToolBarUI.FrameListener - Class in javax.swing.plaf.basic
BasicToolBarUI.PropertyListener - Class in javax.swing.plaf.basic
BasicToolBarUI.ToolBarContListener - Class in javax.swing.plaf.basic
BasicToolBarUI.ToolBarFocusListener - Class in javax.swing.plaf.basic
BasicToolTipUI - Class in javax.swing.plaf.basic
Standard tool tip L&F.
BasicToolTipUI() - Constructor for class javax.swing.plaf.basic.BasicToolTipUI
BasicTreeUI - Class in javax.swing.plaf.basic
The basic L&F for a hierarchical data structure.
BasicTreeUI() - Constructor for class javax.swing.plaf.basic.BasicTreeUI
BasicTreeUI.CellEditorHandler - Class in javax.swing.plaf.basic
Listener responsible for getting cell editing events and updating the tree accordingly.
BasicTreeUI.ComponentHandler - Class in javax.swing.plaf.basic
Updates the preferred size when scrolling (if necessary).
BasicTreeUI.FocusHandler - Class in javax.swing.plaf.basic
Repaints the lead selection row when focus is lost/gained.
BasicTreeUI.KeyHandler - Class in javax.swing.plaf.basic
This is used to get multiple key down events to appropriately generate events.
BasicTreeUI.MouseHandler - Class in javax.swing.plaf.basic
TreeMouseListener is responsible for updating the selection based on mouse events.
BasicTreeUI.MouseInputHandler - Class in javax.swing.plaf.basic
MouseInputHandler handles passing all mouse events, including mouse motion events, until the mouse is released to the destination it is constructed with.
BasicTreeUI.NodeDimensionsHandler - Class in javax.swing.plaf.basic
Class responsible for getting size of node, method is forwarded to BasicTreeUI method.
BasicTreeUI.PropertyChangeHandler - Class in javax.swing.plaf.basic
PropertyChangeListener for the tree.
BasicTreeUI.SelectionModelPropertyChangeHandler - Class in javax.swing.plaf.basic
Listener on the TreeSelectionModel, resets the row selection if any of the properties of the model change.
BasicTreeUI.TreeCancelEditingAction - Class in javax.swing.plaf.basic
ActionListener that invokes cancelEditing when action performed.
BasicTreeUI.TreeExpansionHandler - Class in javax.swing.plaf.basic
Updates the TreeState in response to nodes expanding/collapsing.
BasicTreeUI.TreeHomeAction - Class in javax.swing.plaf.basic
TreeHomeAction is used to handle end/home actions.
BasicTreeUI.TreeIncrementAction - Class in javax.swing.plaf.basic
TreeIncrementAction is used to handle up/down actions.
BasicTreeUI.TreeModelHandler - Class in javax.swing.plaf.basic
Forwards all TreeModel events to the TreeState.
BasicTreeUI.TreePageAction - Class in javax.swing.plaf.basic
TreePageAction handles page up and page down events.
BasicTreeUI.TreeSelectionHandler - Class in javax.swing.plaf.basic
Listens for changes in the selection model and updates the display accordingly.
BasicTreeUI.TreeToggleAction - Class in javax.swing.plaf.basic
For the first selected row expandedness will be toggled.
BasicTreeUI.TreeTraverseAction - Class in javax.swing.plaf.basic
TreeTraverseAction is the action used for left/right keys.
BasicVerticalLayoutManager() - Constructor for class javax.swing.plaf.basic.BasicSplitPaneUI.BasicVerticalLayoutManager
BasicViewportUI - Class in javax.swing.plaf.basic
BasicViewport implementation
BasicViewportUI() - Constructor for class javax.swing.plaf.basic.BasicViewportUI
BATAK - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Batak" Unicode character block.
BATCHSIZE - Static variable in interface javax.naming.Context
Constant that holds the name of the environment property for specifying the batch size to use when returning data via the service's protocol.
BatchUpdateException - Exception in java.sql
The subclass of SQLException thrown when an error occurs during a batch update operation.
BatchUpdateException(String, String, int, int[]) - Constructor for exception java.sql.BatchUpdateException
Constructs a BatchUpdateException object initialized with a given reason, SQLState, vendorCode and updateCounts.
BatchUpdateException(String, String, int[]) - Constructor for exception java.sql.BatchUpdateException
Constructs a BatchUpdateException object initialized with a given reason, SQLState and updateCounts.
BatchUpdateException(String, int[]) - Constructor for exception java.sql.BatchUpdateException
Constructs a BatchUpdateException object initialized with a given reason and updateCounts.
BatchUpdateException(int[]) - Constructor for exception java.sql.BatchUpdateException
Constructs a BatchUpdateException object initialized with a given updateCounts.
BatchUpdateException() - Constructor for exception java.sql.BatchUpdateException
Constructs a BatchUpdateException object.
BatchUpdateException(Throwable) - Constructor for exception java.sql.BatchUpdateException
Constructs a BatchUpdateException object initialized with a given cause.
BatchUpdateException(int[], Throwable) - Constructor for exception java.sql.BatchUpdateException
Constructs a BatchUpdateException object initialized with a given cause and updateCounts.
BatchUpdateException(String, int[], Throwable) - Constructor for exception java.sql.BatchUpdateException
Constructs a BatchUpdateException object initialized with a given reason, cause and updateCounts.
BatchUpdateException(String, String, int[], Throwable) - Constructor for exception java.sql.BatchUpdateException
Constructs a BatchUpdateException object initialized with a given reason, SQLState,cause, and updateCounts.
BatchUpdateException(String, String, int, int[], Throwable) - Constructor for exception java.sql.BatchUpdateException
Constructs a BatchUpdateException object initialized with a given reason, SQLState, vendorCode cause and updateCounts.
BatchUpdateException(String, String, int, long[], Throwable) - Constructor for exception java.sql.BatchUpdateException
Constructs a BatchUpdateException object initialized with a given reason, SQLState, vendorCode cause and updateCounts.
BC - Static variable in class java.util.GregorianCalendar
Value of the ERA field indicating the period before the common era (before Christ), also known as BCE.
bcmListeners - Variable in class java.beans.beancontext.BeanContextSupport
all accesses to the protected ArrayList bcmListeners field shall be synchronized on that object.
bcsChildren() - Method in class java.beans.beancontext.BeanContextSupport
Returns an iterator of all children of this BeanContext.
bcsListeners - Variable in class java.beans.beancontext.BeanContextServicesSupport
List of BeanContextServicesListener objects.
bcsPreDeserializationHook(ObjectInputStream) - Method in class java.beans.beancontext.BeanContextServicesSupport
called from BeanContextSupport readObject before it deserializes the children ...
bcsPreDeserializationHook(ObjectInputStream) - Method in class java.beans.beancontext.BeanContextSupport
called by readObject after defaultReadObject() but prior to deserialization of any children.
bcsPreSerializationHook(ObjectOutputStream) - Method in class java.beans.beancontext.BeanContextServicesSupport
called from BeanContextSupport writeObject before it serializes the children ...
bcsPreSerializationHook(ObjectOutputStream) - Method in class java.beans.beancontext.BeanContextSupport
called by writeObject after defaultWriteObject() but prior to serialization of currently serializable children.
BeanContext - Interface in java.beans.beancontext
The BeanContext acts a logical hierarchical container for JavaBeans.
beanContext - Variable in class java.beans.beancontext.BeanContextChildSupport
The bean context.
BeanContextChild - Interface in java.beans.beancontext
JavaBeans wishing to be nested within, and obtain a reference to their execution environment, or context, as defined by the BeanContext sub-interface shall implement this interface.
BeanContextChildComponentProxy - Interface in java.beans.beancontext
This interface is implemented by BeanContextChildren that have an AWT Component associated with them.
beanContextChildPeer - Variable in class java.beans.beancontext.BeanContextChildSupport
The BeanContext in which this BeanContextChild is nested.
BeanContextChildSupport - Class in java.beans.beancontext
This is a general support class to provide support for implementing the BeanContextChild protocol.
BeanContextChildSupport() - Constructor for class java.beans.beancontext.BeanContextChildSupport
construct a BeanContextChildSupport where this class has been subclassed in order to implement the JavaBean component itself.
BeanContextChildSupport(BeanContextChild) - Constructor for class java.beans.beancontext.BeanContextChildSupport
construct a BeanContextChildSupport where the JavaBean component itself implements BeanContextChild, and encapsulates this, delegating that interface to this implementation
BeanContextContainerProxy - Interface in java.beans.beancontext
This interface is implemented by BeanContexts' that have an AWT Container associated with them.
BeanContextEvent - Class in java.beans.beancontext
BeanContextEvent is the abstract root event class for all events emitted from, and pertaining to the semantics of, a BeanContext.
BeanContextEvent(BeanContext) - Constructor for class java.beans.beancontext.BeanContextEvent
Contruct a BeanContextEvent
BeanContextMembershipEvent - Class in java.beans.beancontext
A BeanContextMembershipEvent encapsulates the list of children added to, or removed from, the membership of a particular BeanContext.
BeanContextMembershipEvent(BeanContext, Collection) - Constructor for class java.beans.beancontext.BeanContextMembershipEvent
Contruct a BeanContextMembershipEvent
BeanContextMembershipEvent(BeanContext, Object[]) - Constructor for class java.beans.beancontext.BeanContextMembershipEvent
Contruct a BeanContextMembershipEvent
BeanContextMembershipListener - Interface in java.beans.beancontext
Compliant BeanContexts fire events on this interface when the state of the membership of the BeanContext changes.
BeanContextProxy - Interface in java.beans.beancontext
This interface is implemented by a JavaBean that does not directly have a BeanContext(Child) associated with it (via implementing that interface or a subinterface thereof), but has a public BeanContext(Child) delegated from it.
BeanContextServiceAvailableEvent - Class in java.beans.beancontext
This event type is used by the BeanContextServicesListener in order to identify the service being registered.
BeanContextServiceAvailableEvent(BeanContextServices, Class) - Constructor for class java.beans.beancontext.BeanContextServiceAvailableEvent
Construct a BeanContextAvailableServiceEvent.
BeanContextServiceProvider - Interface in java.beans.beancontext
One of the primary functions of a BeanContext is to act a as rendezvous between JavaBeans, and BeanContextServiceProviders.
BeanContextServiceProviderBeanInfo - Interface in java.beans.beancontext
A BeanContextServiceProvider implementor who wishes to provide explicit information about the services their bean may provide shall implement a BeanInfo class that implements this BeanInfo subinterface and provides explicit information about the methods, properties, events, etc, of their services.
BeanContextServiceRevokedEvent - Class in java.beans.beancontext
This event type is used by the BeanContextServiceRevokedListener in order to identify the service being revoked.
BeanContextServiceRevokedEvent(BeanContextServices, Class, boolean) - Constructor for class java.beans.beancontext.BeanContextServiceRevokedEvent
Construct a BeanContextServiceEvent.
BeanContextServiceRevokedListener - Interface in java.beans.beancontext
The listener interface for receiving BeanContextServiceRevokedEvent objects.
BeanContextServices - Interface in java.beans.beancontext
The BeanContextServices interface provides a mechanism for a BeanContext to expose generic "services" to the BeanContextChild objects within.
BeanContextServicesListener - Interface in java.beans.beancontext
The listener interface for receiving BeanContextServiceAvailableEvent objects.
BeanContextServicesSupport - Class in java.beans.beancontext
This helper class provides a utility implementation of the java.beans.beancontext.BeanContextServices interface.
BeanContextServicesSupport(BeanContextServices, Locale, boolean, boolean) - Constructor for class java.beans.beancontext.BeanContextServicesSupport
Construct a BeanContextServicesSupport instance
BeanContextServicesSupport(BeanContextServices, Locale, boolean) - Constructor for class java.beans.beancontext.BeanContextServicesSupport
Create an instance using the specified Locale and design mode.
BeanContextServicesSupport(BeanContextServices, Locale) - Constructor for class java.beans.beancontext.BeanContextServicesSupport
Create an instance using the specified locale
BeanContextServicesSupport(BeanContextServices) - Constructor for class java.beans.beancontext.BeanContextServicesSupport
Create an instance with a peer
BeanContextServicesSupport() - Constructor for class java.beans.beancontext.BeanContextServicesSupport
Create an instance that is not a delegate of another object
BeanContextServicesSupport.BCSSChild - Class in java.beans.beancontext
BeanContextServicesSupport.BCSSProxyServiceProvider - Class in java.beans.beancontext
BeanContextServicesSupport.BCSSServiceProvider - Class in java.beans.beancontext
subclasses may subclass this nested class to add behaviors for each BeanContextServicesProvider.
BeanContextSupport - Class in java.beans.beancontext
This helper class provides a utility implementation of the java.beans.beancontext.BeanContext interface.
BeanContextSupport(BeanContext, Locale, boolean, boolean) - Constructor for class java.beans.beancontext.BeanContextSupport
Construct a BeanContextSupport instance
BeanContextSupport(BeanContext, Locale, boolean) - Constructor for class java.beans.beancontext.BeanContextSupport
Create an instance using the specified Locale and design mode.
BeanContextSupport(BeanContext, Locale) - Constructor for class java.beans.beancontext.BeanContextSupport
Create an instance using the specified locale
BeanContextSupport(BeanContext) - Constructor for class java.beans.beancontext.BeanContextSupport
Create an instance using with a default locale
BeanContextSupport() - Constructor for class java.beans.beancontext.BeanContextSupport
Create an instance that is not a delegate of another object
BeanContextSupport.BCSChild - Class in java.beans.beancontext
BeanContextSupport.BCSIterator - Class in java.beans.beancontext
protected final subclass that encapsulates an iterator but implements a noop remove() method.
BeanDescriptor - Class in java.beans
A BeanDescriptor provides global information about a "bean", including its Java class, its displayName, etc.
BeanDescriptor(Class<?>) - Constructor for class java.beans.BeanDescriptor
Create a BeanDescriptor for a bean that doesn't have a customizer.
BeanDescriptor(Class<?>, Class<?>) - Constructor for class java.beans.BeanDescriptor
Create a BeanDescriptor for a bean that has a customizer.
BeanInfo - Interface in java.beans
Use the BeanInfo interface to create a BeanInfo class and provide explicit information about the methods, properties, events, and other features of your beans.
Beans - Class in java.beans
This class provides some general purpose beans control methods.
Beans() - Constructor for class java.beans.Beans
beep() - Method in class java.awt.Toolkit
Emits an audio beep depending on native system settings and hardware capabilities.
beepAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the action to create a beep.
BeepAction() - Constructor for class javax.swing.text.DefaultEditorKit.BeepAction
Create this object with the appropriate identifier.
before(Timestamp) - Method in class java.sql.Timestamp
Indicates whether this Timestamp object is earlier than the given Timestamp object.
before(Object) - Method in class java.util.Calendar
Returns whether this Calendar represents a time before the time represented by the specified Object.
before(Date) - Method in class java.util.Date
Tests if this date is before the specified date.
BEFORE_FIRST_LINE - Static variable in class java.awt.BorderLayout
Synonym for PAGE_START.
BEFORE_LINE_BEGINS - Static variable in class java.awt.BorderLayout
Synonym for LINE_START.
beforeExecute(Thread, Runnable) - Method in class java.util.concurrent.ThreadPoolExecutor
Method invoked prior to executing the given Runnable in the given thread.
beforeFirst() - Method in interface java.sql.ResultSet
Moves the cursor to the front of this ResultSet object, just before the first row.
beforeMarshal(Object) - Method in class javax.xml.bind.Marshaller.Listener

Callback method invoked before marshalling from source to XML.

beforeOffset(int) - Static method in class java.awt.font.TextHitInfo
Creates a TextHitInfo at the specified offset, associated with the character before the offset.
beforeUnmarshal(Object, Object) - Method in class javax.xml.bind.Unmarshaller.Listener

Callback method invoked before unmarshalling into target.

begin() - Method in class java.nio.channels.spi.AbstractInterruptibleChannel
Marks the beginning of an I/O operation that might block indefinitely.
begin() - Method in class java.nio.channels.spi.AbstractSelector
Marks the beginning of an I/O operation that might block indefinitely.
beginAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the Action for moving the caret to the beginning of the document.
beginDragDividerLocation - Variable in class javax.swing.plaf.basic.BasicSplitPaneUI
Location of the divider when the dragging session began.
beginDraggingFrame(JComponent) - Method in class javax.swing.DefaultDesktopManager
beginDraggingFrame(JComponent) - Method in interface javax.swing.DesktopManager
This method is normally called when the user has indicated that they will begin dragging a component around.
beginHandshake() - Method in class javax.net.ssl.SSLEngine
Initiates handshaking (initial or renegotiation) on this SSLEngine.
beginLineAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the Action for moving the caret to the beginning of a line.
beginParagraphAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the Action for moving the caret to the beginning of a paragraph.
beginResizingFrame(JComponent, int) - Method in class javax.swing.DefaultDesktopManager
beginResizingFrame(JComponent, int) - Method in interface javax.swing.DesktopManager
This methods is normally called when the user has indicated that they will begin resizing the frame.
beginUpdate() - Method in class javax.swing.undo.UndoableEditSupport
beginWordAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the Action for moving the caret to the beginning of a word.
BELOW_BASELINE - Static variable in class java.awt.GridBagConstraints
Possible value for the anchor field.
BELOW_BASELINE_LEADING - Static variable in class java.awt.GridBagConstraints
Possible value for the anchor field.
BELOW_BASELINE_TRAILING - Static variable in class java.awt.GridBagConstraints
Possible value for the anchor field.
BELOW_BOTTOM - Static variable in class javax.swing.border.TitledBorder
Position the title below the border's bottom line.
BELOW_TOP - Static variable in class javax.swing.border.TitledBorder
Position the title below the border's top line.
BENGALI - Static variable in class java.awt.font.NumericShaper
Identifies the BENGALI range and decimal base.
BENGALI - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Bengali" Unicode character block.
BEST_COMPRESSION - Static variable in class java.util.zip.Deflater
Compression level for best compression.
BEST_SPEED - Static variable in class java.util.zip.Deflater
Compression level for fastest compression.
bestRowNotPseudo - Static variable in interface java.sql.DatabaseMetaData
Indicates that the best row identifier is NOT a pseudo column.
bestRowPseudo - Static variable in interface java.sql.DatabaseMetaData
Indicates that the best row identifier is a pseudo column.
bestRowSession - Static variable in interface java.sql.DatabaseMetaData
Indicates that the scope of the best row identifier is the remainder of the current session.
bestRowTemporary - Static variable in interface java.sql.DatabaseMetaData
Indicates that the scope of the best row identifier is very temporary, lasting only while the row is being used.
bestRowTransaction - Static variable in interface java.sql.DatabaseMetaData
Indicates that the scope of the best row identifier is the remainder of the current transaction.
bestRowUnknown - Static variable in interface java.sql.DatabaseMetaData
Indicates that the best row identifier may or may not be a pseudo column.
between(ChronoLocalDate, ChronoLocalDate) - Static method in interface java.time.chrono.ChronoPeriod
Obtains a ChronoPeriod consisting of amount of time between two dates.
between(Temporal, Temporal) - Static method in class java.time.Duration
Obtains a Duration representing the duration between two temporal objects.
between(LocalDate, LocalDate) - Static method in class java.time.Period
Obtains a Period consisting of the number of years, months, and days between two dates.
between(Temporal, Temporal) - Method in enum java.time.temporal.ChronoUnit
between(Temporal, Temporal) - Method in interface java.time.temporal.TemporalUnit
Calculates the amount of time between two temporal objects.
between(ValueExp, ValueExp, ValueExp) - Static method in class javax.management.Query
Returns a query expression that represents the constraint that one value is between two other values.
BevelBorder - Class in javax.swing.border
A class which implements a simple two-line bevel border.
BevelBorder(int) - Constructor for class javax.swing.border.BevelBorder
Creates a bevel border with the specified type and whose colors will be derived from the background color of the component passed into the paintBorder method.
BevelBorder(int, Color, Color) - Constructor for class javax.swing.border.BevelBorder
Creates a bevel border with the specified type, highlight and shadow colors.
BevelBorder(int, Color, Color, Color, Color) - Constructor for class javax.swing.border.BevelBorder
Creates a bevel border with the specified type, highlight and shadow colors.
BevelBorderUIResource(int) - Constructor for class javax.swing.plaf.BorderUIResource.BevelBorderUIResource
BevelBorderUIResource(int, Color, Color) - Constructor for class javax.swing.plaf.BorderUIResource.BevelBorderUIResource
BevelBorderUIResource(int, Color, Color, Color, Color) - Constructor for class javax.swing.plaf.BorderUIResource.BevelBorderUIResource
bevelType - Variable in class javax.swing.border.BevelBorder
BGCOLOR - Static variable in class javax.swing.text.html.HTML.Attribute
BiConsumer<T,U> - Interface in java.util.function
Represents an operation that accepts two input arguments and returns no result.
Bidi - Class in java.text
This class implements the Unicode Bidirectional Algorithm.
Bidi(String, int) - Constructor for class java.text.Bidi
Create Bidi from the given paragraph of text and base direction.
Bidi(AttributedCharacterIterator) - Constructor for class java.text.Bidi
Create Bidi from the given paragraph of text.
Bidi(char[], int, byte[], int, int, int) - Constructor for class java.text.Bidi
Create Bidi from the given text, embedding, and direction information.
BIDI_EMBEDDING - Static variable in class java.awt.font.TextAttribute
Attribute key for the embedding level of the text.
BidiElementName - Static variable in class javax.swing.text.AbstractDocument
Name of elements used to hold a unidirectional run
BidiLevel - Static variable in class javax.swing.text.StyleConstants
Bidirectional level of a character as assigned by the Unicode bidi algorithm.
BiFunction<T,U,R> - Interface in java.util.function
Represents a function that accepts two arguments and produces a result.
BIG - Static variable in class javax.swing.text.html.HTML.Tag
BIG_ENDIAN - Static variable in class java.nio.ByteOrder
Constant denoting big-endian byte order.
BigDecimal - Class in java.math
Immutable, arbitrary-precision signed decimal numbers.
BigDecimal(char[], int, int) - Constructor for class java.math.BigDecimal
Translates a character array representation of a BigDecimal into a BigDecimal, accepting the same sequence of characters as the BigDecimal.BigDecimal(String) constructor, while allowing a sub-array to be specified.
BigDecimal(char[], int, int, MathContext) - Constructor for class java.math.BigDecimal
Translates a character array representation of a BigDecimal into a BigDecimal, accepting the same sequence of characters as the BigDecimal.BigDecimal(String) constructor, while allowing a sub-array to be specified and with rounding according to the context settings.
BigDecimal(char[]) - Constructor for class java.math.BigDecimal
Translates a character array representation of a BigDecimal into a BigDecimal, accepting the same sequence of characters as the BigDecimal.BigDecimal(String) constructor.
BigDecimal(char[], MathContext) - Constructor for class java.math.BigDecimal
Translates a character array representation of a BigDecimal into a BigDecimal, accepting the same sequence of characters as the BigDecimal.BigDecimal(String) constructor and with rounding according to the context settings.
BigDecimal(String) - Constructor for class java.math.BigDecimal
Translates the string representation of a BigDecimal into a BigDecimal.
BigDecimal(String, MathContext) - Constructor for class java.math.BigDecimal
Translates the string representation of a BigDecimal into a BigDecimal, accepting the same strings as the BigDecimal.BigDecimal(String) constructor, with rounding according to the context settings.
BigDecimal(double) - Constructor for class java.math.BigDecimal
Translates a double into a BigDecimal which is the exact decimal representation of the double's binary floating-point value.
BigDecimal(double, MathContext) - Constructor for class java.math.BigDecimal
Translates a double into a BigDecimal, with rounding according to the context settings.
BigDecimal(BigInteger) - Constructor for class java.math.BigDecimal
Translates a BigInteger into a BigDecimal.
BigDecimal(BigInteger, MathContext) - Constructor for class java.math.BigDecimal
Translates a BigInteger into a BigDecimal rounding according to the context settings.
BigDecimal(BigInteger, int) - Constructor for class java.math.BigDecimal
Translates a BigInteger unscaled value and an int scale into a BigDecimal.
BigDecimal(BigInteger, int, MathContext) - Constructor for class java.math.BigDecimal
Translates a BigInteger unscaled value and an int scale into a BigDecimal, with rounding according to the context settings.
BigDecimal(int) - Constructor for class java.math.BigDecimal
Translates an int into a BigDecimal.
BigDecimal(int, MathContext) - Constructor for class java.math.BigDecimal
Translates an int into a BigDecimal, with rounding according to the context settings.
BigDecimal(long) - Constructor for class java.math.BigDecimal
Translates a long into a BigDecimal.
BigDecimal(long, MathContext) - Constructor for class java.math.BigDecimal
Translates a long into a BigDecimal, with rounding according to the context settings.
BIGDECIMAL - Static variable in class javax.management.openmbean.SimpleType
The SimpleType instance describing values whose Java class name is java.math.BigDecimal.
bigEndian - Variable in class javax.sound.sampled.AudioFormat
Indicates whether the audio data is stored in big-endian or little-endian order.
BIGINT - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type BIGINT.
BigInteger - Class in java.math
Immutable arbitrary-precision integers.
BigInteger(byte[]) - Constructor for class java.math.BigInteger
Translates a byte array containing the two's-complement binary representation of a BigInteger into a BigInteger.
BigInteger(int, byte[]) - Constructor for class java.math.BigInteger
Translates the sign-magnitude representation of a BigInteger into a BigInteger.
BigInteger(String, int) - Constructor for class java.math.BigInteger
Translates the String representation of a BigInteger in the specified radix into a BigInteger.
BigInteger(String) - Constructor for class java.math.BigInteger
Translates the decimal String representation of a BigInteger into a BigInteger.
BigInteger(int, Random) - Constructor for class java.math.BigInteger
Constructs a randomly generated BigInteger, uniformly distributed over the range 0 to (2numBits - 1), inclusive.
BigInteger(int, int, Random) - Constructor for class java.math.BigInteger
Constructs a randomly generated positive BigInteger that is probably prime, with the specified bitLength.
BIGINTEGER - Static variable in class javax.management.openmbean.SimpleType
The SimpleType instance describing values whose Java class name is java.math.BigInteger.
BINARY - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type BINARY.
BINARY_STREAM_PARAM - Static variable in class javax.sql.rowset.BaseRowSet
A constant indicating to a RowSetReaderImpl object that a given parameter is a binary stream.
BinaryOperator<T> - Interface in java.util.function
Represents an operation upon two operands of the same type, producing a result of the same type as the operands.
BinaryRefAddr - Class in javax.naming
This class represents the binary form of the address of a communications end-point.
BinaryRefAddr(String, byte[]) - Constructor for class javax.naming.BinaryRefAddr
Constructs a new instance of BinaryRefAddr using its address type and a byte array for contents.
BinaryRefAddr(String, byte[], int, int) - Constructor for class javax.naming.BinaryRefAddr
Constructs a new instance of BinaryRefAddr using its address type and a region of a byte array for contents.
binarySearch(long[], long) - Static method in class java.util.Arrays
Searches the specified array of longs for the specified value using the binary search algorithm.
binarySearch(long[], int, int, long) - Static method in class java.util.Arrays
Searches a range of the specified array of longs for the specified value using the binary search algorithm.
binarySearch(int[], int) - Static method in class java.util.Arrays
Searches the specified array of ints for the specified value using the binary search algorithm.
binarySearch(int[], int, int, int) - Static method in class java.util.Arrays
Searches a range of the specified array of ints for the specified value using the binary search algorithm.
binarySearch(short[], short) - Static method in class java.util.Arrays
Searches the specified array of shorts for the specified value using the binary search algorithm.
binarySearch(short[], int, int, short) - Static method in class java.util.Arrays
Searches a range of the specified array of shorts for the specified value using the binary search algorithm.
binarySearch(char[], char) - Static method in class java.util.Arrays
Searches the specified array of chars for the specified value using the binary search algorithm.
binarySearch(char[], int, int, char) - Static method in class java.util.Arrays
Searches a range of the specified array of chars for the specified value using the binary search algorithm.
binarySearch(byte[], byte) - Static method in class java.util.Arrays
Searches the specified array of bytes for the specified value using the binary search algorithm.
binarySearch(byte[], int, int, byte) - Static method in class java.util.Arrays
Searches a range of the specified array of bytes for the specified value using the binary search algorithm.
binarySearch(double[], double) - Static method in class java.util.Arrays
Searches the specified array of doubles for the specified value using the binary search algorithm.
binarySearch(double[], int, int, double) - Static method in class java.util.Arrays
Searches a range of the specified array of doubles for the specified value using the binary search algorithm.
binarySearch(float[], float) - Static method in class java.util.Arrays
Searches the specified array of floats for the specified value using the binary search algorithm.
binarySearch(float[], int, int, float) - Static method in class java.util.Arrays
Searches a range of the specified array of floats for the specified value using the binary search algorithm.
binarySearch(Object[], Object) - Static method in class java.util.Arrays
Searches the specified array for the specified object using the binary search algorithm.
binarySearch(Object[], int, int, Object) - Static method in class java.util.Arrays
Searches a range of the specified array for the specified object using the binary search algorithm.
binarySearch(T[], T, Comparator<? super T>) - Static method in class java.util.Arrays
Searches the specified array for the specified object using the binary search algorithm.
binarySearch(T[], int, int, T, Comparator<? super T>) - Static method in class java.util.Arrays
Searches a range of the specified array for the specified object using the binary search algorithm.
binarySearch(List<? extends Comparable<? super T>>, T) - Static method in class java.util.Collections
Searches the specified list for the specified object using the binary search algorithm.
binarySearch(List<? extends T>, T, Comparator<? super T>) - Static method in class java.util.Collections
Searches the specified list for the specified object using the binary search algorithm.
binaryStream - Variable in class javax.sql.rowset.BaseRowSet
The InputStream object that will be returned by the method getBinaryStream, which is specified in the ResultSet interface.
bind(Object, String, MethodType) - Method in class java.lang.invoke.MethodHandles.Lookup
Produces an early-bound method handle for a non-static method.
bind(SocketAddress) - Method in class java.net.DatagramSocket
Binds this DatagramSocket to a specific address and port.
bind(int, InetAddress) - Method in class java.net.DatagramSocketImpl
Binds a datagram socket to a local port and address.
bind(SocketAddress) - Method in class java.net.ServerSocket
Binds the ServerSocket to a specific address (IP address and port number).
bind(SocketAddress, int) - Method in class java.net.ServerSocket
Binds the ServerSocket to a specific address (IP address and port number).
bind(SocketAddress) - Method in class java.net.Socket
Binds the socket to a local address.
bind(InetAddress, int) - Method in class java.net.SocketImpl
Binds this socket to the specified local IP address and port number.
bind(SocketAddress) - Method in class java.nio.channels.AsynchronousServerSocketChannel
Binds the channel's socket to a local address and configures the socket to listen for connections.
bind(SocketAddress, int) - Method in class java.nio.channels.AsynchronousServerSocketChannel
Binds the channel's socket to a local address and configures the socket to listen for connections.
bind(SocketAddress) - Method in class java.nio.channels.AsynchronousSocketChannel
bind(SocketAddress) - Method in class java.nio.channels.DatagramChannel
bind(SocketAddress) - Method in interface java.nio.channels.NetworkChannel
Binds the channel's socket to a local address.
bind(SocketAddress) - Method in class java.nio.channels.ServerSocketChannel
Binds the channel's socket to a local address and configures the socket to listen for connections.
bind(SocketAddress, int) - Method in class java.nio.channels.ServerSocketChannel
Binds the channel's socket to a local address and configures the socket to listen for connections.
bind(SocketAddress) - Method in class java.nio.channels.SocketChannel
bind(String, Remote) - Static method in class java.rmi.Naming
Binds the specified name to a remote object.
bind(String, Remote) - Method in interface java.rmi.registry.Registry
Binds a remote reference to the specified name in this registry.
bind(Name, Object) - Method in interface javax.naming.Context
Binds a name to an object.
bind(String, Object) - Method in interface javax.naming.Context
Binds a name to an object.
bind(Name, Object, Attributes) - Method in interface javax.naming.directory.DirContext
Binds a name to an object, along with associated attributes.
bind(String, Object, Attributes) - Method in interface javax.naming.directory.DirContext
Binds a name to an object, along with associated attributes.
bind(String, Object, Attributes) - Method in class javax.naming.directory.InitialDirContext
bind(Name, Object, Attributes) - Method in class javax.naming.directory.InitialDirContext
bind(String, Object) - Method in class javax.naming.InitialContext
bind(Name, Object) - Method in class javax.naming.InitialContext
BIND - Static variable in class javax.print.attribute.standard.Finishings
This value indicates that a binding is to be applied to the document; the type and placement of the binding is site-defined.
bind(NameComponent[], Object) - Method in class org.omg.CosNaming._NamingContextExtStub
Creates a binding of a name and an object in the naming context.
bind(NameComponent[], Object) - Method in class org.omg.CosNaming._NamingContextStub
Creates a binding of a name and an object in the naming context.
bind(NameComponent[], Object) - Method in interface org.omg.CosNaming.NamingContextOperations
Creates a binding of a name and an object in the naming context.
bind_context(NameComponent[], NamingContext) - Method in class org.omg.CosNaming._NamingContextExtStub
Names an object that is a naming context.
bind_context(NameComponent[], NamingContext) - Method in class org.omg.CosNaming._NamingContextStub
Names an object that is a naming context.
bind_context(NameComponent[], NamingContext) - Method in interface org.omg.CosNaming.NamingContextOperations
Names an object that is a naming context.
bind_new_context(NameComponent[]) - Method in class org.omg.CosNaming._NamingContextExtStub
This operation creates a new context and binds it to the name supplied as an argument.
bind_new_context(NameComponent[]) - Method in class org.omg.CosNaming._NamingContextStub
This operation creates a new context and binds it to the name supplied as an argument.
bind_new_context(NameComponent[]) - Method in interface org.omg.CosNaming.NamingContextOperations
This operation creates a new context and binds it to the name supplied as an argument.
Binder<XmlNode> - Class in javax.xml.bind
Enable synchronization between XML infoset nodes and JAXB objects representing same XML document.
Binder() - Constructor for class javax.xml.bind.Binder
BindException - Exception in java.net
Signals that an error occurred while attempting to bind a socket to a local address and port.
BindException(String) - Constructor for exception java.net.BindException
Constructs a new BindException with the specified detail message as to why the bind error occurred.
BindException() - Constructor for exception java.net.BindException
Construct a new BindException with no detailed message.
Binding - Class in javax.naming
This class represents a name-to-object binding found in a context.
Binding(String, Object) - Constructor for class javax.naming.Binding
Constructs an instance of a Binding given its name and object.
Binding(String, Object, boolean) - Constructor for class javax.naming.Binding
Constructs an instance of a Binding given its name, object, and whether the name is relative.
Binding(String, String, Object) - Constructor for class javax.naming.Binding
Constructs an instance of a Binding given its name, class name, and object.
Binding(String, String, Object, boolean) - Constructor for class javax.naming.Binding
Constructs an instance of a Binding given its name, class name, object, and whether the name is relative.
Binding - Interface in javax.xml.ws
The Binding interface is the base interface for JAX-WS protocol bindings.
Binding - Class in org.omg.CosNaming
org/omg/CosNaming/Binding.java .
Binding() - Constructor for class org.omg.CosNaming.Binding
Binding(NameComponent[], BindingType) - Constructor for class org.omg.CosNaming.Binding
binding_name - Variable in class org.omg.CosNaming.Binding
binding_type - Variable in class org.omg.CosNaming.Binding
BindingHelper - Class in org.omg.CosNaming
org/omg/CosNaming/BindingHelper.java .
BindingHelper() - Constructor for class org.omg.CosNaming.BindingHelper
BindingHolder - Class in org.omg.CosNaming
org/omg/CosNaming/BindingHolder.java .
BindingHolder() - Constructor for class org.omg.CosNaming.BindingHolder
BindingHolder(Binding) - Constructor for class org.omg.CosNaming.BindingHolder
BindingIterator - Interface in org.omg.CosNaming
The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
BindingIteratorHelper - Class in org.omg.CosNaming
The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
BindingIteratorHelper() - Constructor for class org.omg.CosNaming.BindingIteratorHelper
BindingIteratorHolder - Class in org.omg.CosNaming
The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
BindingIteratorHolder() - Constructor for class org.omg.CosNaming.BindingIteratorHolder
BindingIteratorHolder(BindingIterator) - Constructor for class org.omg.CosNaming.BindingIteratorHolder
BindingIteratorOperations - Interface in org.omg.CosNaming
The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
BindingIteratorPOA - Class in org.omg.CosNaming
The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
BindingIteratorPOA() - Constructor for class org.omg.CosNaming.BindingIteratorPOA
BindingListHelper - Class in org.omg.CosNaming
List of Bindings.
BindingListHelper() - Constructor for class org.omg.CosNaming.BindingListHelper
BindingListHolder - Class in org.omg.CosNaming
List of Bindings.
BindingListHolder() - Constructor for class org.omg.CosNaming.BindingListHolder
BindingListHolder(Binding[]) - Constructor for class org.omg.CosNaming.BindingListHolder
BindingProvider - Interface in javax.xml.ws
The BindingProvider interface provides access to the protocol binding and associated context objects for request and response message processing.
Bindings - Interface in javax.script
A mapping of key/value pairs, all of whose keys are Strings.
BindingType - Annotation Type in javax.xml.ws
The BindingType annotation is used to specify the binding to use for a web service endpoint implementation class.
BindingType - Class in org.omg.CosNaming
Specifies whether the given binding is for a object (that is not a naming context) or for a naming context.
BindingType(int) - Constructor for class org.omg.CosNaming.BindingType
BindingTypeHelper - Class in org.omg.CosNaming
Specifies whether the given binding is for a object (that is not a naming context) or for a naming context.
BindingTypeHelper() - Constructor for class org.omg.CosNaming.BindingTypeHelper
BindingTypeHolder - Class in org.omg.CosNaming
Specifies whether the given binding is for a object (that is not a naming context) or for a naming context.
BindingTypeHolder() - Constructor for class org.omg.CosNaming.BindingTypeHolder
BindingTypeHolder(BindingType) - Constructor for class org.omg.CosNaming.BindingTypeHolder
bindTo(Object) - Method in class java.lang.invoke.MethodHandle
Binds a value x to the first argument of a method handle, without invoking it.
BiPredicate<T,U> - Interface in java.util.function
Represents a predicate (boolean-valued function) of two arguments.
BIT - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type BIT.
BIT_DEPTH_MULTI - Static variable in class java.awt.DisplayMode
Value of the bit depth if multiple bit depths are supported in this display mode.
bitCount(int) - Static method in class java.lang.Integer
Returns the number of one-bits in the two's complement binary representation of the specified int value.
bitCount(long) - Static method in class java.lang.Long
Returns the number of one-bits in the two's complement binary representation of the specified long value.
bitCount() - Method in class java.math.BigInteger
Returns the number of bits in the two's complement representation of this BigInteger that differ from its sign bit.
bitLength() - Method in class java.math.BigInteger
Returns the number of bits in the minimal two's-complement representation of this BigInteger, excluding a sign bit.
BITMASK - Static variable in interface java.awt.Transparency
Represents image data that is guaranteed to be either completely opaque, with an alpha value of 1.0, or completely transparent, with an alpha value of 0.0.
bitOffset - Variable in class javax.imageio.stream.ImageInputStreamImpl
The current bit offset within the stream.
BitSet - Class in java.util
This class implements a vector of bits that grows as needed.
BitSet() - Constructor for class java.util.BitSet
Creates a new bit set.
BitSet(int) - Constructor for class java.util.BitSet
Creates a bit set whose initial size is large enough to explicitly represent bits with indices in the range 0 through nbits-1.
black - Static variable in class java.awt.Color
The color black.
BLACK - Static variable in class java.awt.Color
The color black.
BLIT_SCROLL_MODE - Static variable in class javax.swing.JViewport
Use graphics.copyArea to implement scrolling.
Blob - Interface in java.sql
The representation (mapping) in the Java™ programming language of an SQL BLOB value.
BLOB - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type BLOB.
block(InetAddress) - Method in class java.nio.channels.MembershipKey
Block multicast datagrams from the given source address.
block() - Method in interface java.util.concurrent.ForkJoinPool.ManagedBlocker
Possibly blocks the current thread, for example waiting for a lock or condition.
BLOCK_DECREMENT - Static variable in class java.awt.event.AdjustmentEvent
The block decrement adjustment type.
BLOCK_ELEMENTS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Block Elements" Unicode character block.
BLOCK_INCREMENT - Static variable in class java.awt.event.AdjustmentEvent
The block increment adjustment type.
BlockAction() - Constructor for class javax.swing.text.html.HTMLDocument.HTMLReader.BlockAction
blockClose(HTML.Tag) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader
Adds an instruction to the parse buffer to close out a block element of the given type.
BlockElement(Element, AttributeSet) - Constructor for class javax.swing.text.html.HTMLDocument.BlockElement
Constructs a composite element that initially contains no children.
blockIncrement - Variable in class javax.swing.JScrollBar
BlockingDeque<E> - Interface in java.util.concurrent
A Deque that additionally supports blocking operations that wait for the deque to become non-empty when retrieving an element, and wait for space to become available in the deque when storing an element.
blockingLock() - Method in class java.nio.channels.SelectableChannel
Retrieves the object upon which the configureBlocking and register methods synchronize.
blockingLock() - Method in class java.nio.channels.spi.AbstractSelectableChannel
BlockingQueue<E> - Interface in java.util.concurrent
A Queue that additionally supports operations that wait for the queue to become non-empty when retrieving an element, and wait for space to become available in the queue when storing an element.
blockOpen(HTML.Tag, MutableAttributeSet) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader
Adds an instruction to the parse buffer to create a block element with the given attributes.
BLOCKQUOTE - Static variable in class javax.swing.text.html.HTML.Tag
BlockView - Class in javax.swing.text.html
A view implementation to display a block (as a box) with CSS specifications.
BlockView(Element, int) - Constructor for class javax.swing.text.html.BlockView
Creates a new view that represents an html box.
BltBufferStrategy(int, BufferCapabilities) - Constructor for class java.awt.Component.BltBufferStrategy
Creates a new blt buffer strategy around a component
blue - Static variable in class java.awt.Color
The color blue.
BLUE - Static variable in class java.awt.Color
The color blue.
BLUECOMPONENT - Static variable in class java.awt.color.ICC_ProfileRGB
Used to get a gamma value or TRC for the blue component.
BMPImageWriteParam - Class in javax.imageio.plugins.bmp
A subclass of ImageWriteParam for encoding images in the BMP format.
BMPImageWriteParam(Locale) - Constructor for class javax.imageio.plugins.bmp.BMPImageWriteParam
Constructs a BMPImageWriteParam set to use a given Locale and with default values for all parameters.
BMPImageWriteParam() - Constructor for class javax.imageio.plugins.bmp.BMPImageWriteParam
Constructs an BMPImageWriteParam object with default values for all parameters and a null Locale.
BODY - Static variable in class javax.swing.text.html.HTML.Tag
body - Variable in class javax.swing.text.html.parser.DTD
BOLD - Static variable in class java.awt.Font
The bold style constant.
Bold - Static variable in class javax.swing.text.StyleConstants
Name of the bold attribute.
BOLD_ACTION - Static variable in class javax.swing.text.html.HTMLEditorKit
The bold action identifier
BoldAction() - Constructor for class javax.swing.text.StyledEditorKit.BoldAction
Constructs a new BoldAction.
Book - Class in java.awt.print
The Book class provides a representation of a document in which pages may have different page formats and page painters.
Book() - Constructor for class java.awt.print.Book
Creates a new, empty Book.
Boolean - Class in java.lang
The Boolean class wraps a value of the primitive type boolean in an object.
Boolean(boolean) - Constructor for class java.lang.Boolean
Allocates a Boolean object representing the value argument.
Boolean(String) - Constructor for class java.lang.Boolean
Allocates a Boolean object representing the value true if the string argument is not null and is equal, ignoring case, to the string "true".
BOOLEAN - Static variable in class java.sql.Types
The constant in the Java programming language, somtimes referred to as a type code, that identifies the generic SQL type BOOLEAN.
BOOLEAN - Static variable in class javax.management.openmbean.SimpleType
The SimpleType instance describing values whose Java class name is java.lang.Boolean.
BOOLEAN - Static variable in class javax.xml.xpath.XPathConstants
The XPath 1.0 boolean data type.
BooleanControl - Class in javax.sound.sampled
A BooleanControl provides the ability to switch between two possible settings that affect a line's audio.
BooleanControl(BooleanControl.Type, boolean, String, String) - Constructor for class javax.sound.sampled.BooleanControl
Constructs a new boolean control object with the given parameters.
BooleanControl(BooleanControl.Type, boolean) - Constructor for class javax.sound.sampled.BooleanControl
Constructs a new boolean control object with the given parameters.
BooleanControl.Type - Class in javax.sound.sampled
An instance of the BooleanControl.Type class identifies one kind of boolean control.
BooleanHolder - Class in org.omg.CORBA
The Holder for Boolean.
BooleanHolder() - Constructor for class org.omg.CORBA.BooleanHolder
Constructs a new BooleanHolder object with its value field initialized to false.
BooleanHolder(boolean) - Constructor for class org.omg.CORBA.BooleanHolder
Constructs a new BooleanHolder object with its value field initialized with the given boolean.
BooleanSeqHelper - Class in org.omg.CORBA
The Helper for BooleanSeq.
BooleanSeqHelper() - Constructor for class org.omg.CORBA.BooleanSeqHelper
BooleanSeqHolder - Class in org.omg.CORBA
The Holder for BooleanSeq.
BooleanSeqHolder() - Constructor for class org.omg.CORBA.BooleanSeqHolder
BooleanSeqHolder(boolean[]) - Constructor for class org.omg.CORBA.BooleanSeqHolder
BooleanSupplier - Interface in java.util.function
Represents a supplier of boolean-valued results.
booleanValue() - Method in class java.lang.Boolean
Returns the value of this Boolean object as a boolean primitive.
BootstrapMethodError - Error in java.lang
Thrown to indicate that an invokedynamic instruction has failed to find its bootstrap method, or the bootstrap method has failed to provide a call site with a target of the correct method type.
BootstrapMethodError() - Constructor for error java.lang.BootstrapMethodError
Constructs a BootstrapMethodError with no detail message.
BootstrapMethodError(String) - Constructor for error java.lang.BootstrapMethodError
Constructs a BootstrapMethodError with the specified detail message.
BootstrapMethodError(String, Throwable) - Constructor for error java.lang.BootstrapMethodError
Constructs a BootstrapMethodError with the specified detail message and cause.
BootstrapMethodError(Throwable) - Constructor for error java.lang.BootstrapMethodError
Constructs a BootstrapMethodError with the specified cause.
BOPOMOFO - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Bopomofo" Unicode character block.
BOPOMOFO_EXTENDED - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Bopomofo Extended" Unicode character block.
Border - Interface in javax.swing.border
Interface describing an object capable of rendering a border around the edges of a swing component.
border - Variable in class javax.swing.border.TitledBorder
BORDER - Static variable in class javax.swing.text.html.CSS.Attribute
BORDER - Static variable in class javax.swing.text.html.HTML.Attribute
border - Variable in class javax.swing.tree.DefaultTreeCellEditor.DefaultTextField
Border to use.
BORDER_BOTTOM - Static variable in class javax.swing.text.html.CSS.Attribute
BORDER_BOTTOM_COLOR - Static variable in class javax.swing.text.html.CSS.Attribute
BORDER_BOTTOM_STYLE - Static variable in class javax.swing.text.html.CSS.Attribute
BORDER_BOTTOM_WIDTH - Static variable in class javax.swing.text.html.CSS.Attribute
BORDER_COLOR - Static variable in class javax.swing.text.html.CSS.Attribute
BORDER_LEFT - Static variable in class javax.swing.text.html.CSS.Attribute
BORDER_LEFT_COLOR - Static variable in class javax.swing.text.html.CSS.Attribute
BORDER_LEFT_STYLE - Static variable in class javax.swing.text.html.CSS.Attribute
BORDER_LEFT_WIDTH - Static variable in class javax.swing.text.html.CSS.Attribute
BORDER_PAINTED_CHANGED_PROPERTY - Static variable in class javax.swing.AbstractButton
Identifies a change to having the border drawn, or having it not drawn.
BORDER_PAINTED_FLAT_CHANGED_PROPERTY - Static variable in class javax.swing.JCheckBox
Identifies a change to the flat property.
BORDER_RIGHT - Static variable in class javax.swing.text.html.CSS.Attribute
BORDER_RIGHT_COLOR - Static variable in class javax.swing.text.html.CSS.Attribute
BORDER_RIGHT_STYLE - Static variable in class javax.swing.text.html.CSS.Attribute
BORDER_RIGHT_WIDTH - Static variable in class javax.swing.text.html.CSS.Attribute
BORDER_STYLE - Static variable in class javax.swing.text.html.CSS.Attribute
BORDER_TOP - Static variable in class javax.swing.text.html.CSS.Attribute
BORDER_TOP_COLOR - Static variable in class javax.swing.text.html.CSS.Attribute
BORDER_TOP_STYLE - Static variable in class javax.swing.text.html.CSS.Attribute
BORDER_TOP_WIDTH - Static variable in class javax.swing.text.html.CSS.Attribute
BORDER_WIDTH - Static variable in class javax.swing.text.html.CSS.Attribute
BorderFactory - Class in javax.swing
Factory class for vending standard Border objects.
borderInsets - Static variable in class javax.swing.plaf.metal.MetalBorders.ButtonBorder
borderInsets - Static variable in class javax.swing.plaf.metal.MetalBorders.MenuBarBorder
borderInsets - Static variable in class javax.swing.plaf.metal.MetalBorders.MenuItemBorder
borderInsets - Static variable in class javax.swing.plaf.metal.MetalBorders.PopupMenuBorder
BorderLayout - Class in java.awt
A border layout lays out a container, arranging and resizing its components to fit in five regions: north, south, east, west, and center.
BorderLayout() - Constructor for class java.awt.BorderLayout
Constructs a new border layout with no gaps between components.
BorderLayout(int, int) - Constructor for class java.awt.BorderLayout
Constructs a border layout with the specified gaps between components.
borderListener - Variable in class javax.swing.plaf.basic.BasicInternalFrameUI
BorderListener() - Constructor for class javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener
borderSelectionColor - Variable in class javax.swing.tree.DefaultTreeCellEditor
True if the border selection color should be drawn.
borderSelectionColor - Variable in class javax.swing.tree.DefaultTreeCellRenderer
Color to use for the focus indicator when the node has focus.
BorderUIResource - Class in javax.swing.plaf
BorderUIResource(Border) - Constructor for class javax.swing.plaf.BorderUIResource
Creates a UIResource border object which wraps an existing Border instance.
BorderUIResource.BevelBorderUIResource - Class in javax.swing.plaf
BorderUIResource.CompoundBorderUIResource - Class in javax.swing.plaf
BorderUIResource.EmptyBorderUIResource - Class in javax.swing.plaf
BorderUIResource.EtchedBorderUIResource - Class in javax.swing.plaf
BorderUIResource.LineBorderUIResource - Class in javax.swing.plaf
BorderUIResource.MatteBorderUIResource - Class in javax.swing.plaf
BorderUIResource.TitledBorderUIResource - Class in javax.swing.plaf
BOTH - Static variable in class java.awt.GridBagConstraints
Resize the component both horizontally and vertically.
bottom - Variable in class java.awt.Insets
The inset from the bottom.
BOTTOM - Static variable in class javax.print.attribute.standard.MediaTray
The bottom input tray in the printer.
bottom - Variable in class javax.swing.border.EmptyBorder
BOTTOM - Static variable in class javax.swing.border.TitledBorder
Position the title in the middle of the border's bottom line.
BOTTOM - Static variable in class javax.swing.JSplitPane
Used to add a Component below the other Component.
BOTTOM - Static variable in interface javax.swing.SwingConstants
Box-orientation constant used to specify the bottom of a box.
BOTTOM_ALIGNMENT - Static variable in class java.awt.Component
Ease-of-use constant for getAlignmentY.
BOTTOM_ALIGNMENT - Static variable in class java.awt.font.GraphicAttribute
Aligns bottom of graphic to bottom of line.
BOUND_SERVER_NAME - Static variable in class javax.security.sasl.Sasl
The name of a property that specifies the bound server name for an unbound server.
BoundedRangeModel - Interface in javax.swing
Defines the data model used by components like Sliders and ProgressBars.
bounds() - Method in class java.awt.Component
Deprecated.
As of JDK version 1.1, replaced by getBounds().
bounds - Variable in class java.awt.Polygon
The bounds of this Polygon.
Bounds - Exception in org.omg.CORBA
A user exception thrown when a parameter is not within the legal bounds for the object that a method is trying to access.
Bounds() - Constructor for exception org.omg.CORBA.Bounds
Constructs an Bounds with no specified detail message.
Bounds(String) - Constructor for exception org.omg.CORBA.Bounds
Constructs an Bounds with the specified detail message.
Bounds - Exception in org.omg.CORBA.TypeCodePackage
Provides the TypeCode operations member_name(), member_type(), and member_label.
Bounds() - Constructor for exception org.omg.CORBA.TypeCodePackage.Bounds
Constructs a Bounds exception with no reason message.
Bounds(String) - Constructor for exception org.omg.CORBA.TypeCodePackage.Bounds
Constructs a Bounds exception with the specified reason message.
Box - Class in javax.swing
A lightweight container that uses a BoxLayout object as its layout manager.
Box(int) - Constructor for class javax.swing.Box
Creates a Box that displays its components along the the specified axis.
Box.AccessibleBox - Class in javax.swing
This class implements accessibility support for the Box class.
Box.Filler - Class in javax.swing
An implementation of a lightweight component that participates in layout but has no view.
Box.Filler.AccessibleBoxFiller - Class in javax.swing
This class implements accessibility support for the Box.Filler class.
BOX_DRAWING - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Box Drawing" Unicode character block.
boxed() - Method in interface java.util.stream.DoubleStream
Returns a Stream consisting of the elements of this stream, boxed to Double.
boxed() - Method in interface java.util.stream.IntStream
Returns a Stream consisting of the elements of this stream, each boxed to an Integer.
boxed() - Method in interface java.util.stream.LongStream
Returns a Stream consisting of the elements of this stream, each boxed to a Long.
boxedClass(PrimitiveType) - Method in interface javax.lang.model.util.Types
Returns the class of a boxed value of a given primitive type.
BoxedValueHelper - Interface in org.omg.CORBA.portable
BoxLayout - Class in javax.swing
A layout manager that allows multiple components to be laid out either vertically or horizontally.
BoxLayout(Container, int) - Constructor for class javax.swing.BoxLayout
Creates a layout manager that will lay out components along the given axis.
boxRect - Variable in class javax.swing.plaf.basic.BasicProgressBarUI
Used to hold the location and size of the bouncing box (returned by getBox) to be painted.
BoxView - Class in javax.swing.text
A view that arranges its children into a box shape by tiling its children along an axis.
BoxView(Element, int) - Constructor for class javax.swing.text.BoxView
Constructs a BoxView.
BR - Static variable in class javax.swing.text.html.HTML.Tag
BRAHMI - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Brahmi" Unicode character block.
BRAILLE_PATTERNS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Braille Patterns" Unicode character block.
BranchElement(Element, AttributeSet) - Constructor for class javax.swing.text.AbstractDocument.BranchElement
Constructs a composite element that initially contains no children.
breadthFirstEnumeration() - Method in class javax.swing.tree.DefaultMutableTreeNode
Creates and returns an enumeration that traverses the subtree rooted at this node in breadth-first order.
BreakIterator - Class in java.text
The BreakIterator class implements methods for finding the location of boundaries in text.
BreakIterator() - Constructor for class java.text.BreakIterator
Constructor.
BreakIteratorProvider - Class in java.text.spi
An abstract class for service providers that provide concrete implementations of the BreakIterator class.
BreakIteratorProvider() - Constructor for class java.text.spi.BreakIteratorProvider
Sole constructor.
breaksFlow() - Method in class javax.swing.text.html.HTML.Tag
Returns true if this tag causes a line break to the flow of data, otherwise returns false.
breaksFlow() - Method in class javax.swing.text.html.parser.TagElement
breakView(int, int, float, float) - Method in class javax.swing.text.GlyphView
Breaks this view on the given axis at the given length.
breakView(int, int, float, float) - Method in class javax.swing.text.html.InlineView
Tries to break this view on the given axis.
breakView(int, float, Shape) - Method in class javax.swing.text.ParagraphView
Breaks this view on the given axis at the given length.
breakView(int, int, float, float) - Method in class javax.swing.text.View
Tries to break this view on the given axis.
BRIEF - Static variable in class java.rmi.server.LogStream
Deprecated.
log level constant (brief logging).
brighter() - Method in class java.awt.Color
Creates a new Color that is a brighter version of this Color.
BrokenBarrierException - Exception in java.util.concurrent
Exception thrown when a thread tries to wait upon a barrier that is in a broken state, or which enters the broken state while the thread is waiting.
BrokenBarrierException() - Constructor for exception java.util.concurrent.BrokenBarrierException
Constructs a BrokenBarrierException with no specified detail message.
BrokenBarrierException(String) - Constructor for exception java.util.concurrent.BrokenBarrierException
Constructs a BrokenBarrierException with the specified detail message.
browse(URI) - Method in class java.awt.Desktop
Launches the default browser to display a URI.
BUBBLING_PHASE - Static variable in interface org.w3c.dom.events.Event
The current event phase is the bubbling phase.
buf - Variable in class java.io.BufferedInputStream
The internal buffer array where the data is stored.
buf - Variable in class java.io.BufferedOutputStream
The internal buffer where data is stored.
buf - Variable in class java.io.ByteArrayInputStream
An array of bytes that was provided by the creator of the stream.
buf - Variable in class java.io.ByteArrayOutputStream
The buffer where data is stored.
buf - Variable in class java.io.CharArrayReader
The character buffer.
buf - Variable in class java.io.CharArrayWriter
The buffer where data is stored.
buf - Variable in class java.io.PushbackInputStream
The pushback buffer.
buf - Variable in class java.util.zip.DeflaterInputStream
Input buffer for reading compressed data.
buf - Variable in class java.util.zip.DeflaterOutputStream
Output buffer for writing compressed data.
buf - Variable in class java.util.zip.InflaterInputStream
Input buffer for decompression.
buf - Variable in class java.util.zip.InflaterOutputStream
Output buffer for writing uncompressed data.
buffer - Variable in class java.io.PipedInputStream
The circular buffer into which incoming data is placed.
buffer - Variable in class java.io.StringBufferInputStream
Deprecated.
The string from which bytes are read.
Buffer - Class in java.nio
A container for data of a specific primitive type.
buffer - Variable in class javax.swing.text.DefaultStyledDocument
BUFFER_SIZE_DEFAULT - Static variable in class javax.swing.text.DefaultStyledDocument
The default size of the initial content buffer.
BufferCapabilities - Class in java.awt
Capabilities and properties of buffers.
BufferCapabilities(ImageCapabilities, ImageCapabilities, BufferCapabilities.FlipContents) - Constructor for class java.awt.BufferCapabilities
Creates a new object for specifying buffering capabilities
BufferCapabilities.FlipContents - Class in java.awt
A type-safe enumeration of the possible back buffer contents after page-flipping
BUFFERED_OPTION - Static variable in class javax.swing.DebugGraphics
Show buffered operations in a separate Frame.
BufferedImage - Class in java.awt.image
The BufferedImage subclass describes an Image with an accessible buffer of image data.
BufferedImage(int, int, int) - Constructor for class java.awt.image.BufferedImage
Constructs a BufferedImage of one of the predefined image types.
BufferedImage(int, int, int, IndexColorModel) - Constructor for class java.awt.image.BufferedImage
Constructs a BufferedImage of one of the predefined image types: TYPE_BYTE_BINARY or TYPE_BYTE_INDEXED.
BufferedImage(ColorModel, WritableRaster, boolean, Hashtable<?, ?>) - Constructor for class java.awt.image.BufferedImage
Constructs a new BufferedImage with a specified ColorModel and Raster.
BufferedImageFilter - Class in java.awt.image
The BufferedImageFilter class subclasses an ImageFilter to provide a simple means of using a single-source/single-destination image operator (BufferedImageOp) to filter a BufferedImage in the Image Producer/Consumer/Observer paradigm.
BufferedImageFilter(BufferedImageOp) - Constructor for class java.awt.image.BufferedImageFilter
Constructs a BufferedImageFilter with the specified single-source/single-destination operator.
BufferedImageOp - Interface in java.awt.image
This interface describes single-input/single-output operations performed on BufferedImage objects.
BufferedInputStream - Class in java.io
A BufferedInputStream adds functionality to another input stream-namely, the ability to buffer the input and to support the mark and reset methods.
BufferedInputStream(InputStream) - Constructor for class java.io.BufferedInputStream
Creates a BufferedInputStream and saves its argument, the input stream in, for later use.
BufferedInputStream(InputStream, int) - Constructor for class java.io.BufferedInputStream
Creates a BufferedInputStream with the specified buffer size, and saves its argument, the input stream in, for later use.
BufferedOutputStream - Class in java.io
The class implements a buffered output stream.
BufferedOutputStream(OutputStream) - Constructor for class java.io.BufferedOutputStream
Creates a new buffered output stream to write data to the specified underlying output stream.
BufferedOutputStream(OutputStream, int) - Constructor for class java.io.BufferedOutputStream
Creates a new buffered output stream to write data to the specified underlying output stream with the specified buffer size.
BufferedReader - Class in java.io
Reads text from a character-input stream, buffering characters so as to provide for the efficient reading of characters, arrays, and lines.
BufferedReader(Reader, int) - Constructor for class java.io.BufferedReader
Creates a buffering character-input stream that uses an input buffer of the specified size.
BufferedReader(Reader) - Constructor for class java.io.BufferedReader
Creates a buffering character-input stream that uses a default-sized input buffer.
BufferedWriter - Class in java.io
Writes text to a character-output stream, buffering characters so as to provide for the efficient writing of single characters, arrays, and strings.
BufferedWriter(Writer) - Constructor for class java.io.BufferedWriter
Creates a buffered character-output stream that uses a default-sized output buffer.
BufferedWriter(Writer, int) - Constructor for class java.io.BufferedWriter
Creates a new buffered character-output stream that uses an output buffer of the given size.
BufferOverflowException - Exception in java.nio
Unchecked exception thrown when a relative put operation reaches the target buffer's limit.
BufferOverflowException() - Constructor for exception java.nio.BufferOverflowException
Constructs an instance of this class.
BufferPoolMXBean - Interface in java.lang.management
The management interface for a buffer pool, for example a pool of direct or mapped buffers.
BufferStrategy - Class in java.awt.image
The BufferStrategy class represents the mechanism with which to organize complex memory on a particular Canvas or Window.
BufferStrategy() - Constructor for class java.awt.image.BufferStrategy
BufferUnderflowException - Exception in java.nio
Unchecked exception thrown when a relative get operation reaches the source buffer's limit.
BufferUnderflowException() - Constructor for exception java.nio.BufferUnderflowException
Constructs an instance of this class.
BUGINESE - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Buginese" Unicode character block.
BUHID - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Buhid" Unicode character block.
build() - Method in class java.nio.file.attribute.AclEntry.Builder
Constructs an AclEntry from the components of this builder.
build(CertPathParameters) - Method in class java.security.cert.CertPathBuilder
Attempts to build a certification path using the specified algorithm parameter set.
build() - Method in class java.util.Calendar.Builder
Returns a Calendar built from the parameters set by the setter methods.
build() - Method in class java.util.Locale.Builder
Returns an instance of Locale created from the fields set on this builder.
build() - Method in interface java.util.stream.DoubleStream.Builder
Builds the stream, transitioning this builder to the built state.
build() - Method in interface java.util.stream.IntStream.Builder
Builds the stream, transitioning this builder to the built state.
build() - Method in interface java.util.stream.LongStream.Builder
Builds the stream, transitioning this builder to the built state.
build() - Method in interface java.util.stream.Stream.Builder
Builds the stream, transitioning this builder to the built state.
build() - Method in class javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder
Builds a W3CEndpointReference from the accumulated properties set on this W3CEndpointReferenceBuilder instance.
buildChooser() - Method in class javax.swing.colorchooser.AbstractColorChooserPanel
Builds a new chooser panel.
Builder() - Constructor for class java.security.KeyStore.Builder
Construct a new Builder.
Builder() - Constructor for class java.util.Calendar.Builder
Constructs a Calendar.Builder.
Builder() - Constructor for class java.util.Locale.Builder
Constructs an empty Builder.
builder() - Static method in interface java.util.stream.DoubleStream
Returns a builder for a DoubleStream.
builder() - Static method in interface java.util.stream.IntStream
Returns a builder for an IntStream.
builder() - Static method in interface java.util.stream.LongStream
Returns a builder for a LongStream.
builder() - Static method in interface java.util.stream.Stream
Returns a builder for a Stream.
bulkRegister(int) - Method in class java.util.concurrent.Phaser
Adds the given number of new unarrived parties to this phaser.
bumps - Variable in class javax.swing.plaf.metal.MetalBorders.ToolBarBorder
bumps - Variable in class javax.swing.plaf.metal.MetalScrollBarUI
burstStringInto(Container, String, int) - Method in class javax.swing.plaf.basic.BasicOptionPaneUI
Recursively creates new JLabel instances to represent d.
BUSY - Static variable in class javax.accessibility.AccessibleState
Indicates the current object is busy.
Button - Class in java.awt
This class creates a labeled button.
Button() - Constructor for class java.awt.Button
Constructs a button with an empty string for its label.
Button(String) - Constructor for class java.awt.Button
Constructs a button with the specified label.
BUTTON - Static variable in class javax.swing.plaf.synth.Region
Button region.
Button.AccessibleAWTButton - Class in java.awt
This class implements accessibility support for the Button class.
BUTTON1 - Static variable in class java.awt.event.MouseEvent
Indicates mouse button #1; used by MouseEvent.getButton().
BUTTON1_DOWN_MASK - Static variable in class java.awt.event.InputEvent
The Mouse Button1 extended modifier constant.
BUTTON1_MASK - Static variable in class java.awt.event.InputEvent
The Mouse Button1 modifier constant.
BUTTON2 - Static variable in class java.awt.event.MouseEvent
Indicates mouse button #2; used by MouseEvent.getButton().
BUTTON2_DOWN_MASK - Static variable in class java.awt.event.InputEvent
The Mouse Button2 extended modifier constant.
BUTTON2_MASK - Static variable in class java.awt.event.InputEvent
The Mouse Button2 modifier constant.
BUTTON3 - Static variable in class java.awt.event.MouseEvent
Indicates mouse button #3; used by MouseEvent.getButton().
BUTTON3_DOWN_MASK - Static variable in class java.awt.event.InputEvent
The Mouse Button3 extended modifier constant.
BUTTON3_MASK - Static variable in class java.awt.event.InputEvent
The Mouse Button3 modifier constant.
ButtonActionListener(int) - Constructor for class javax.swing.plaf.basic.BasicOptionPaneUI.ButtonActionListener
ButtonAreaLayout(boolean, int) - Constructor for class javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout
ButtonBorder(Color, Color, Color, Color) - Constructor for class javax.swing.plaf.basic.BasicBorders.ButtonBorder
ButtonBorder() - Constructor for class javax.swing.plaf.metal.MetalBorders.ButtonBorder
ButtonGroup - Class in javax.swing
This class is used to create a multiple-exclusion scope for a set of buttons.
ButtonGroup() - Constructor for class javax.swing.ButtonGroup
Creates a new ButtonGroup.
buttonIndex - Variable in class javax.swing.plaf.basic.BasicOptionPaneUI.ButtonActionListener
buttonListener - Variable in class javax.swing.plaf.basic.BasicScrollBarUI
ButtonModel - Interface in javax.swing
State model for buttons.
buttons - Variable in class javax.swing.ButtonGroup
ButtonUI - Class in javax.swing.plaf
Pluggable look and feel interface for JButton.
ButtonUI() - Constructor for class javax.swing.plaf.ButtonUI
Byte - Class in java.lang
The Byte class wraps a value of primitive type byte in an object.
Byte(byte) - Constructor for class java.lang.Byte
Constructs a newly allocated Byte object that represents the specified byte value.
Byte(String) - Constructor for class java.lang.Byte
Constructs a newly allocated Byte object that represents the byte value indicated by the String parameter.
BYTE - Static variable in class javax.management.openmbean.SimpleType
The SimpleType instance describing values whose Java class name is java.lang.Byte.
BYTE_ARRAY(String) - Constructor for class javax.print.DocFlavor.BYTE_ARRAY
Constructs a new doc flavor with the given MIME type and a print data representation class name of "[B" (byte array).
ByteArrayInputStream - Class in java.io
A ByteArrayInputStream contains an internal buffer that contains bytes that may be read from the stream.
ByteArrayInputStream(byte[]) - Constructor for class java.io.ByteArrayInputStream
Creates a ByteArrayInputStream so that it uses buf as its buffer array.
ByteArrayInputStream(byte[], int, int) - Constructor for class java.io.ByteArrayInputStream
Creates ByteArrayInputStream that uses buf as its buffer array.
ByteArrayOutputStream - Class in java.io
This class implements an output stream in which the data is written into a byte array.
ByteArrayOutputStream() - Constructor for class java.io.ByteArrayOutputStream
Creates a new byte array output stream.
ByteArrayOutputStream(int) - Constructor for class java.io.ByteArrayOutputStream
Creates a new byte array output stream, with a buffer capacity of the specified size, in bytes.
ByteBuffer - Class in java.nio
A byte buffer.
ByteChannel - Interface in java.nio.channels
A channel that can read and write bytes.
ByteHolder - Class in org.omg.CORBA
The Holder for Byte.
ByteHolder() - Constructor for class org.omg.CORBA.ByteHolder
Constructs a new ByteHolder object with its value field initialized to 0.
ByteHolder(byte) - Constructor for class org.omg.CORBA.ByteHolder
Constructs a new ByteHolder object for the given byte.
byteLength - Variable in class javax.sound.midi.MidiFileFormat
The length of the MIDI file in bytes.
ByteLookupTable - Class in java.awt.image
This class defines a lookup table object.
ByteLookupTable(int, byte[][]) - Constructor for class java.awt.image.ByteLookupTable
Constructs a ByteLookupTable object from an array of byte arrays representing a lookup table for each band.
ByteLookupTable(int, byte[]) - Constructor for class java.awt.image.ByteLookupTable
Constructs a ByteLookupTable object from an array of bytes representing a lookup table to be applied to all bands.
ByteOrder - Class in java.nio
A typesafe enumeration for byte orders.
byteOrder - Variable in class javax.imageio.stream.ImageInputStreamImpl
The byte order of the stream as an instance of the enumeration class java.nio.ByteOrder, where ByteOrder.BIG_ENDIAN indicates network byte order and ByteOrder.LITTLE_ENDIAN indicates the reverse order.
BYTES - Static variable in class java.lang.Byte
The number of bytes used to represent a byte value in two's complement binary form.
BYTES - Static variable in class java.lang.Character
The number of bytes used to represent a char value in unsigned binary form.
BYTES - Static variable in class java.lang.Double
The number of bytes used to represent a double value.
BYTES - Static variable in class java.lang.Float
The number of bytes used to represent a float value.
BYTES - Static variable in class java.lang.Integer
The number of bytes used to represent a int value in two's complement binary form.
BYTES - Static variable in class java.lang.Long
The number of bytes used to represent a long value in two's complement binary form.
BYTES - Static variable in class java.lang.Short
The number of bytes used to represent a short value in two's complement binary form.
bytesConsumed() - Method in class javax.net.ssl.SSLEngineResult
Returns the number of bytes consumed from the input buffer.
bytesProduced() - Method in class javax.net.ssl.SSLEngineResult
Returns the number of bytes written to the output buffer.
bytesTransferred - Variable in exception java.io.InterruptedIOException
Reports how many bytes had been transferred as part of the I/O operation before it was interrupted.
bytesWidth(byte[], int, int) - Method in class java.awt.FontMetrics
Returns the total advance width for showing the specified array of bytes in this Font.
byteValue() - Method in class java.lang.Byte
Returns the value of this Byte as a byte.
byteValue() - Method in class java.lang.Double
Returns the value of this Double as a byte after a narrowing primitive conversion.
byteValue() - Method in class java.lang.Float
Returns the value of this Float as a byte after a narrowing primitive conversion.
byteValue() - Method in class java.lang.Integer
Returns the value of this Integer as a byte after a narrowing primitive conversion.
byteValue() - Method in class java.lang.Long
Returns the value of this Long as a byte after a narrowing primitive conversion.
byteValue() - Method in class java.lang.Number
Returns the value of the specified number as a byte, which may involve rounding or truncation.
byteValue() - Method in class java.lang.Short
Returns the value of this Short as a byte after a narrowing primitive conversion.
byteValueExact() - Method in class java.math.BigDecimal
Converts this BigDecimal to a byte, checking for lost information.
byteValueExact() - Method in class java.math.BigInteger
Converts this BigInteger to a byte, checking for lost information.
BYZANTINE_MUSICAL_SYMBOLS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Byzantine Musical Symbols" Unicode character block.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames


C-Index (Java Platform SE 8 )

Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames
  • All Classes
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

C

C - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for Engineering C, 17 x 22 in.
C - Static variable in class javax.print.attribute.standard.MediaSize.Engineering
Specifies the engineering C size, 17 inch by 22 inch.
C - Static variable in class javax.print.attribute.standard.MediaSizeName
C size .
C0 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C0.
C1 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C1.
C10 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C10.
C14NMethodParameterSpec - Interface in javax.xml.crypto.dsig.spec
A specification of algorithm parameters for a CanonicalizationMethod Algorithm.
C2 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C2.
C3 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C3.
C3 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO C3 size, 324 mm by 458 mm.
C4 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C4.
C4 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO C4 size, 229 mm by 324 mm.
C5 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C5.
C5 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO C5 size, 162 mm by 229 mm.
C6 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C6.
C6 - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO C6 size, 114 mm by 162 mm.
C7 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C7.
C8 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C8.
C9 - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C9.
cachedChildren() - Method in class java.util.prefs.AbstractPreferences
Returns all known unremoved children of this node.
cachedMinimumSize - Variable in class javax.swing.plaf.basic.BasicComboBoxUI
CachedRowSet - Interface in javax.sql.rowset
The interface that all standard implementations of CachedRowSet must implement.
cacheIcon(File, Icon) - Method in class javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView
cacheMBeanInfo(MBeanInfo) - Method in class javax.management.StandardMBean
Customization hook: cache the MBeanInfo built for this object.
CacheRequest - Class in java.net
Represents channels for storing resources in the ResponseCache.
CacheRequest() - Constructor for class java.net.CacheRequest
CacheResponse - Class in java.net
Represent channels for retrieving resources from the ResponseCache.
CacheResponse() - Constructor for class java.net.CacheResponse
calcRect - Variable in class javax.swing.plaf.basic.BasicTabbedPaneUI
A rectangle used for general layout calculations in order to avoid constructing many new Rectangles on the fly.
calculateAlignedPositions(int, SizeRequirements, SizeRequirements[], int[], int[]) - Static method in class javax.swing.SizeRequirements
Creates a bunch of offset/span pairs specifying how to lay out a set of components with the specified alignments.
calculateAlignedPositions(int, SizeRequirements, SizeRequirements[], int[], int[], boolean) - Static method in class javax.swing.SizeRequirements
Creates a set of offset/span pairs specifying how to lay out a set of components with the specified alignments.
calculateBreakPosition(int, int) - Method in class javax.swing.text.WrappedPlainView
This is called by the nested wrapped line views to determine the break location.
calculateContentRect() - Method in class javax.swing.plaf.basic.BasicSliderUI
calculateFocusRect() - Method in class javax.swing.plaf.basic.BasicSliderUI
calculateGeometry() - Method in class javax.swing.plaf.basic.BasicSliderUI
calculateGeometry() - Method in class javax.swing.plaf.synth.SynthSliderUI
calculateIndex(CompositeData) - Method in interface javax.management.openmbean.TabularData
Calculates the index that would be used in this TabularData instance to refer to the specified composite data value parameter if it were added to this instance.
calculateIndex(CompositeData) - Method in class javax.management.openmbean.TabularDataSupport
Calculates the index that would be used in this TabularData instance to refer to the specified composite data value parameter if it were added to this instance.
calculateInnerArea(JComponent, Rectangle) - Static method in class javax.swing.SwingUtilities
Stores the position and size of the inner painting area of the specified component in r and returns r.
calculateLabelRect() - Method in class javax.swing.plaf.basic.BasicSliderUI
calculateLayoutInfo() - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout
calculateMajorAxisRequirements(int, SizeRequirements) - Method in class javax.swing.text.BoxView
Calculates the size requirements for the major axis axis.
calculateMajorAxisRequirements(int, SizeRequirements) - Method in class javax.swing.text.html.BlockView
Calculate the requirements of the block along the major axis (i.e.
calculateMaxTabHeight(int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
calculateMaxTabHeight(int) - Method in class javax.swing.plaf.metal.MetalTabbedPaneUI
calculateMaxTabHeight(int) - Method in class javax.swing.plaf.synth.SynthTabbedPaneUI
calculateMaxTabWidth(int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
calculateMaxTabWidth(int) - Method in class javax.swing.plaf.synth.SynthTabbedPaneUI
calculateMinorAxisRequirements(int, SizeRequirements) - Method in class javax.swing.text.BoxView
Calculates the size requirements for the minor axis axis.
calculateMinorAxisRequirements(int, SizeRequirements) - Method in class javax.swing.text.FlowView
Calculate requirements along the minor axis.
calculateMinorAxisRequirements(int, SizeRequirements) - Method in class javax.swing.text.html.BlockView
Calculate the requirements of the block along the minor axis (i.e.
calculateMinorAxisRequirements(int, SizeRequirements) - Method in class javax.swing.text.html.ParagraphView
Calculate the needs for the paragraph along the minor axis.
calculateMinorAxisRequirements(int, SizeRequirements) - Method in class javax.swing.text.ParagraphView
Calculate the needs for the paragraph along the minor axis.
calculateMinorAxisRequirements(int, SizeRequirements) - Method in class javax.swing.text.TableView
Calculate the requirements for the minor axis.
calculateSize(boolean) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout
calculateTabAreaHeight(int, int, int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
calculateTabAreaWidth(int, int, int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
calculateTabHeight(int, int, int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
calculateTabRects(int, int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout
calculateTabWidth(int, int, FontMetrics) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
calculateTabWidth(int, int, FontMetrics) - Method in class javax.swing.plaf.synth.SynthTabbedPaneUI
calculateThumbLocation() - Method in class javax.swing.plaf.basic.BasicSliderUI
calculateThumbLocation() - Method in class javax.swing.plaf.synth.SynthSliderUI
calculateThumbSize() - Method in class javax.swing.plaf.basic.BasicSliderUI
calculateTickRect() - Method in class javax.swing.plaf.basic.BasicSliderUI
calculateTiledPositions(int, SizeRequirements, SizeRequirements[], int[], int[]) - Static method in class javax.swing.SizeRequirements
Creates a set of offset/span pairs representing how to lay out a set of components end-to-end.
calculateTiledPositions(int, SizeRequirements, SizeRequirements[], int[], int[], boolean) - Static method in class javax.swing.SizeRequirements
Creates a set of offset/span pairs representing how to lay out a set of components end-to-end.
calculateTrackBuffer() - Method in class javax.swing.plaf.basic.BasicSliderUI
calculateTrackRect() - Method in class javax.swing.plaf.basic.BasicSliderUI
calendar - Variable in class java.text.DateFormat
The Calendar instance used for calculating the date-time fields and the instant of time.
Calendar - Class in java.util
The Calendar class is an abstract class that provides methods for converting between a specific instant in time and a set of calendar fields such as YEAR, MONTH, DAY_OF_MONTH, HOUR, and so on, and for manipulating the calendar fields, such as getting the date of the next week.
Calendar() - Constructor for class java.util.Calendar
Constructs a Calendar with the default time zone and the default FORMAT locale.
Calendar(TimeZone, Locale) - Constructor for class java.util.Calendar
Constructs a calendar with the specified time zone and locale.
Calendar.Builder - Class in java.util
Calendar.Builder is used for creating a Calendar from various date-time parameters.
CalendarDataProvider - Class in java.util.spi
An abstract class for service providers that provide locale-dependent Calendar parameters.
CalendarDataProvider() - Constructor for class java.util.spi.CalendarDataProvider
Sole constructor.
CalendarNameProvider - Class in java.util.spi
An abstract class for service providers that provide localized string representations (display names) of Calendar field values.
CalendarNameProvider() - Constructor for class java.util.spi.CalendarNameProvider
Sole constructor.
call() - Method in interface java.util.concurrent.Callable
Computes a result, or throws an exception if unable to do so.
call() - Method in interface javax.tools.DocumentationTool.DocumentationTask
Performs this documentation task.
call() - Method in interface javax.tools.JavaCompiler.CompilationTask
Performs this compilation task.
call(SOAPMessage, Object) - Method in class javax.xml.soap.SOAPConnection
Sends the given message to the specified endpoint and blocks until it has returned the response.
Callable<V> - Interface in java.util.concurrent
A task that returns a result and may throw an exception.
callable(Runnable, T) - Static method in class java.util.concurrent.Executors
Returns a Callable object that, when called, runs the given task and returns the given result.
callable(Runnable) - Static method in class java.util.concurrent.Executors
Returns a Callable object that, when called, runs the given task and returns null.
callable(PrivilegedAction<?>) - Static method in class java.util.concurrent.Executors
Returns a Callable object that, when called, runs the given privileged action and returns its result.
callable(PrivilegedExceptionAction<?>) - Static method in class java.util.concurrent.Executors
Returns a Callable object that, when called, runs the given privileged exception action and returns its result.
CallableStatement - Interface in java.sql
The interface used to execute SQL stored procedures.
Callback - Interface in javax.security.auth.callback
Implementations of this interface are passed to a CallbackHandler, allowing underlying security services the ability to interact with a calling application to retrieve specific authentication data such as usernames and passwords, or to display certain information, such as error and warning messages.
CallbackHandler - Interface in javax.security.auth.callback
An application implements a CallbackHandler and passes it to underlying security services so that they may interact with the application to retrieve specific authentication data, such as usernames and passwords, or to display certain information, such as error and warning messages.
CallbackHandlerProtection(CallbackHandler) - Constructor for class java.security.KeyStore.CallbackHandlerProtection
Constructs a new CallbackHandlerProtection from a CallbackHandler.
CallerRunsPolicy() - Constructor for class java.util.concurrent.ThreadPoolExecutor.CallerRunsPolicy
Creates a CallerRunsPolicy.
CallSite - Class in java.lang.invoke
A CallSite is a holder for a variable MethodHandle, which is called its target.
CANADA - Static variable in class java.util.Locale
Useful constant for country.
CANADA_FRENCH - Static variable in class java.util.Locale
Useful constant for country.
cancel() - Method in class java.awt.print.PrinterJob
Cancels a print job that is in progress.
cancel() - Method in class java.nio.channels.SelectionKey
Requests that the registration of this key's channel with its selector be cancelled.
cancel() - Method in class java.nio.channels.spi.AbstractSelectionKey
Cancels this key.
cancel() - Method in interface java.nio.file.WatchKey
Cancels the registration with the watch service.
cancel() - Method in interface java.sql.Statement
Cancels this Statement object if both the DBMS and driver support aborting an SQL statement.
cancel(boolean) - Method in class java.util.concurrent.CompletableFuture
If not already completed, completes this CompletableFuture with a CancellationException.
cancel(boolean) - Method in class java.util.concurrent.ForkJoinTask
Attempts to cancel execution of this task.
cancel(boolean) - Method in interface java.util.concurrent.Future
Attempts to cancel execution of this task.
cancel(boolean) - Method in class java.util.concurrent.FutureTask
cancel() - Method in class java.util.Timer
Terminates this timer, discarding any currently scheduled tasks.
cancel() - Method in class java.util.TimerTask
Cancels this timer task.
cancel() - Method in interface javax.print.CancelablePrintJob
Stops further processing of a print job.
CANCEL - Static variable in class javax.security.auth.callback.ConfirmationCallback
CANCEL option.
cancel(boolean) - Method in class javax.swing.SwingWorker
Attempts to cancel execution of this task.
CANCEL_OPTION - Static variable in class javax.swing.JFileChooser
Return value if cancel is chosen.
CANCEL_OPTION - Static variable in class javax.swing.JOptionPane
Return value from class method if CANCEL is chosen.
CANCEL_SELECTION - Static variable in class javax.swing.JFileChooser
Instruction to cancel the current selection.
CancelablePrintJob - Interface in javax.print
This interface is used by a printing application to cancel a print job.
cancelButtonMnemonic - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
cancelButtonText - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
cancelButtonToolTipText - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
cancelCellEditing() - Method in class javax.swing.AbstractCellEditor
Calls fireEditingCanceled.
cancelCellEditing() - Method in interface javax.swing.CellEditor
Tells the editor to cancel editing and not accept any partially edited value.
cancelCellEditing() - Method in class javax.swing.DefaultCellEditor
Forwards the message from the CellEditor to the delegate.
cancelCellEditing() - Method in class javax.swing.DefaultCellEditor.EditorDelegate
Cancels editing.
cancelCellEditing() - Method in class javax.swing.tree.DefaultTreeCellEditor
Messages cancelCellEditing to the realEditor and removes it from this instance.
CANCELED - Static variable in class javax.print.attribute.standard.JobState
The job has been canceled by some human agency, the printer has completed canceling the job, and all job status attributes have reached their final values for the job.
cancelEditing() - Method in class javax.swing.JTree
Cancels the current editing session.
cancelEditing(JTree) - Method in class javax.swing.plaf.basic.BasicTreeUI
Cancels the current editing session.
cancelEditing(JTree) - Method in class javax.swing.plaf.multi.MultiTreeUI
Invokes the cancelEditing method on each UI handled by this object.
cancelEditing(JTree) - Method in class javax.swing.plaf.TreeUI
Cancels the current editing session.
cancelLatestCommittedText(AttributedCharacterIterator.Attribute[]) - Method in interface java.awt.im.InputMethodRequests
Gets the latest committed text from the text editing component and removes it from the component's text body.
CancellationException - Exception in java.util.concurrent
Exception indicating that the result of a value-producing task, such as a FutureTask, cannot be retrieved because the task was cancelled.
CancellationException() - Constructor for exception java.util.concurrent.CancellationException
Constructs a CancellationException with no detail message.
CancellationException(String) - Constructor for exception java.util.concurrent.CancellationException
Constructs a CancellationException with the specified detail message.
CancelledKeyException - Exception in java.nio.channels
Unchecked exception thrown when an attempt is made to use a selection key that is no longer valid.
CancelledKeyException() - Constructor for exception java.nio.channels.CancelledKeyException
Constructs an instance of this class.
cancelledKeys() - Method in class java.nio.channels.spi.AbstractSelector
Retrieves this selector's cancelled-key set.
cancelRowUpdates() - Method in interface java.sql.ResultSet
Cancels the updates made to the current row in this ResultSet object.
cancelSelection() - Method in class javax.swing.JFileChooser
Called by the UI when the user chooses the Cancel button.
CancelSelectionAction() - Constructor for class javax.swing.plaf.basic.BasicFileChooserUI.CancelSelectionAction
canDecodeInput(Object) - Method in class javax.imageio.spi.ImageReaderSpi
Returns true if the supplied source object appears to be of the format supported by this reader.
canDisplay(char) - Method in class java.awt.Font
Checks if this Font has a glyph for the specified character.
canDisplay(int) - Method in class java.awt.Font
Checks if this Font has a glyph for the specified character.
canDisplayUpTo(String) - Method in class java.awt.Font
Indicates whether or not this Font can display a specified String.
canDisplayUpTo(char[], int, int) - Method in class java.awt.Font
Indicates whether or not this Font can display the characters in the specified text starting at start and ending at limit.
canDisplayUpTo(CharacterIterator, int, int) - Method in class java.awt.Font
Indicates whether or not this Font can display the text specified by the iter starting at start and ending at limit.
canDock(Component, Point) - Method in class javax.swing.plaf.basic.BasicToolBarUI
canEdit - Variable in class javax.swing.tree.DefaultTreeCellEditor
As of Java 2 platform v1.4 this field should no longer be used.
canEditImmediately(EventObject) - Method in class javax.swing.tree.DefaultTreeCellEditor
Returns true if event is null, or it is a MouseEvent with a click count > 2 and inHitRegion returns true.
canEncode() - Method in class java.nio.charset.Charset
Tells whether or not this charset supports encoding.
canEncode(char) - Method in class java.nio.charset.CharsetEncoder
Tells whether or not this encoder can encode the given character.
canEncode(CharSequence) - Method in class java.nio.charset.CharsetEncoder
Tells whether or not this encoder can encode the given character sequence.
canEncodeImage(ImageTypeSpecifier) - Method in class javax.imageio.spi.ImageWriterSpi
Returns true if the ImageWriter implementation associated with this service provider is able to encode an image with the given layout.
canEncodeImage(RenderedImage) - Method in class javax.imageio.spi.ImageWriterSpi
Returns true if the ImageWriter implementation associated with this service provider is able to encode the given RenderedImage instance.
canExecute() - Method in class java.io.File
Tests whether the application can execute the file denoted by this abstract pathname.
canFilterIndexColorModel - Variable in class java.awt.image.RGBImageFilter
This boolean indicates whether or not it is acceptable to apply the color filtering of the filterRGB method to the color table entries of an IndexColorModel object in lieu of pixel by pixel filtering.
canImport(TransferHandler.TransferSupport) - Method in class javax.swing.TransferHandler
This method is called repeatedly during a drag and drop operation to allow the developer to configure properties of, and to return the acceptability of transfers; with a return value of true indicating that the transfer represented by the given TransferSupport (which contains all of the details of the transfer) is acceptable at the current time, and a value of false rejecting the transfer.
canImport(JComponent, DataFlavor[]) - Method in class javax.swing.TransferHandler
Indicates whether a component will accept an import of the given set of data flavors prior to actually attempting to import it.
canInsertEmpty(int) - Method in class javax.imageio.ImageWriter
Returns true if the writer supports the insertion of a new, empty image at the given index.
canInsertImage(int) - Method in class javax.imageio.ImageWriter
Returns true if the writer supports the insertion of a new image at the given index.
canNodeAppear(String, ImageTypeSpecifier) - Method in interface javax.imageio.metadata.IIOMetadataFormat
Returns true if the element (and the subtree below it) is allowed to appear in a metadata document for an image of the given type, defined by an ImageTypeSpecifier.
canNodeAppear(String, ImageTypeSpecifier) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl
CannotProceed - Exception in org.omg.CosNaming.NamingContextPackage
org/omg/CosNaming/NamingContextPackage/CannotProceed.java .
CannotProceed() - Constructor for exception org.omg.CosNaming.NamingContextPackage.CannotProceed
CannotProceed(NamingContext, NameComponent[]) - Constructor for exception org.omg.CosNaming.NamingContextPackage.CannotProceed
CannotProceed(String, NamingContext, NameComponent[]) - Constructor for exception org.omg.CosNaming.NamingContextPackage.CannotProceed
CannotProceedException - Exception in javax.naming
This exception is thrown to indicate that the operation reached a point in the name where the operation cannot proceed any further.
CannotProceedException(String) - Constructor for exception javax.naming.CannotProceedException
Constructs a new instance of CannotProceedException using an explanation.
CannotProceedException() - Constructor for exception javax.naming.CannotProceedException
Constructs a new instance of CannotProceedException.
CannotProceedHelper - Class in org.omg.CosNaming.NamingContextPackage
org/omg/CosNaming/NamingContextPackage/CannotProceedHelper.java .
CannotProceedHelper() - Constructor for class org.omg.CosNaming.NamingContextPackage.CannotProceedHelper
CannotProceedHolder - Class in org.omg.CosNaming.NamingContextPackage
org/omg/CosNaming/NamingContextPackage/CannotProceedHolder.java .
CannotProceedHolder() - Constructor for class org.omg.CosNaming.NamingContextPackage.CannotProceedHolder
CannotProceedHolder(CannotProceed) - Constructor for class org.omg.CosNaming.NamingContextPackage.CannotProceedHolder
CannotRedoException - Exception in javax.swing.undo
Thrown when an UndoableEdit is told to redo() and can't.
CannotRedoException() - Constructor for exception javax.swing.undo.CannotRedoException
CannotUndoException - Exception in javax.swing.undo
Thrown when an UndoableEdit is told to undo() and can't.
CannotUndoException() - Constructor for exception javax.swing.undo.CannotUndoException
canOffsetTiles - Variable in class javax.imageio.ImageWriteParam
A boolean that is true if this ImageWriteParam allows tiling grid offset parameters to be set.
canOffsetTiles() - Method in class javax.imageio.ImageWriteParam
Returns true if the writer can perform tiling with non-zero grid offsets while writing.
CANON_EQ - Static variable in class java.util.regex.Pattern
Enables canonical equivalence.
CANONICAL - Static variable in class javax.security.auth.x500.X500Principal
Canonical String format of Distinguished Names.
CANONICAL_DECOMPOSITION - Static variable in class java.text.Collator
Decomposition mode value.
CanonicalizationMethod - Interface in javax.xml.crypto.dsig
A representation of the XML CanonicalizationMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
canonicalize(Oid) - Method in interface org.ietf.jgss.GSSName
Creates a name that is canonicalized for some mechanism.
canPathsBeAdded(TreePath[]) - Method in class javax.swing.tree.DefaultTreeSelectionModel
Used to test if a particular set of TreePaths can be added.
canPathsBeRemoved(TreePath[]) - Method in class javax.swing.tree.DefaultTreeSelectionModel
Returns true if the paths can be removed without breaking the continuity of the model.
canRead() - Method in class java.io.File
Tests whether the application can read the file denoted by this abstract pathname.
canReadRaster() - Method in class javax.imageio.ImageReader
Returns true if this plug-in supports reading just a Raster of pixel data.
canRedo() - Method in class javax.swing.undo.AbstractUndoableEdit
Returns true if this edit is alive and hasBeenDone is false.
canRedo() - Method in class javax.swing.undo.CompoundEdit
Returns false if isInProgress or if super returns false.
canRedo() - Method in interface javax.swing.undo.UndoableEdit
Returns true if this edit may be redone.
canRedo() - Method in class javax.swing.undo.UndoManager
Returns true if edits may be redone.
canRemoveImage(int) - Method in class javax.imageio.ImageWriter
Returns true if the writer supports the removal of an existing image at the given index.
canReplaceImageMetadata(int) - Method in class javax.imageio.ImageWriter
Returns true if it is possible to replace the image metadata associated with an existing image with index imageIndex.
canReplacePixels(int) - Method in class javax.imageio.ImageWriter
Returns true if the writer allows pixels of the given image to be replaced using the replacePixels methods.
canReplaceStreamMetadata() - Method in class javax.imageio.ImageWriter
Returns true if it is possible to replace the stream metadata already present in the output.
canSetParameter(String, Object) - Method in interface org.w3c.dom.DOMConfiguration
Check if setting a parameter to a specific value is supported.
canSetSourceRenderSize - Variable in class javax.imageio.ImageReadParam
true if this ImageReadParam allows the source rendering dimensions to be set.
canSetSourceRenderSize() - Method in class javax.imageio.ImageReadParam
Returns true if this reader allows the source image to be rendered at an arbitrary size as part of the decoding process, by means of the setSourceRenderSize method.
canUndo() - Method in class javax.swing.undo.AbstractUndoableEdit
Returns true if this edit is alive and hasBeenDone is true.
canUndo() - Method in class javax.swing.undo.CompoundEdit
Returns false if isInProgress or if super returns false.
canUndo() - Method in interface javax.swing.undo.UndoableEdit
Returns true if this edit may be undone.
canUndo() - Method in class javax.swing.undo.UndoManager
Returns true if edits may be undone.
canUndoOrRedo() - Method in class javax.swing.undo.UndoManager
Returns true if it is possible to invoke undo or redo.
canUseCacheFile() - Method in class javax.imageio.spi.ImageInputStreamSpi
Returns true if the ImageInputStream implementation associated with this service provider can optionally make use of a cache file for improved performance and/or memory footrprint.
canUseCacheFile() - Method in class javax.imageio.spi.ImageOutputStreamSpi
Returns true if the ImageOutputStream implementation associated with this service provider can optionally make use of a cache File for improved performance and/or memory footrprint.
Canvas - Class in java.awt
A Canvas component represents a blank rectangular area of the screen onto which the application can draw or from which the application can trap input events from the user.
Canvas() - Constructor for class java.awt.Canvas
Constructs a new Canvas.
Canvas(GraphicsConfiguration) - Constructor for class java.awt.Canvas
Constructs a new Canvas given a GraphicsConfiguration object.
CANVAS - Static variable in class javax.accessibility.AccessibleRole
Object that can be drawn into and is used to trap events.
Canvas.AccessibleAWTCanvas - Class in java.awt
This class implements accessibility support for the Canvas class.
canWrite() - Method in class java.io.File
Tests whether the application can modify the file denoted by this abstract pathname.
canWriteCompressed - Variable in class javax.imageio.ImageWriteParam
A boolean that is true if this writer can write images using compression.
canWriteCompressed() - Method in class javax.imageio.ImageWriteParam
Returns true if this writer supports compression.
canWriteEmpty() - Method in class javax.imageio.ImageWriter
Returns true if the writer supports the writing of a complete image stream consisting of a single image with undefined pixel values and associated metadata and thumbnails to the output.
canWriteProgressive - Variable in class javax.imageio.ImageWriteParam
A boolean that is true if this ImageWriteParam allows images to be written as a progressive sequence of increasing quality passes.
canWriteProgressive() - Method in class javax.imageio.ImageWriteParam
Returns true if the writer can write out images as a series of passes of progressively increasing quality.
canWriteRasters() - Method in class javax.imageio.ImageWriter
Returns true if the methods that take an IIOImage parameter are capable of dealing with a Raster (as opposed to RenderedImage) source image.
canWriteSequence() - Method in class javax.imageio.ImageWriter
Returns true if the writer is able to append an image to an image stream that already contains header information and possibly prior images.
canWriteTiles - Variable in class javax.imageio.ImageWriteParam
A boolean that is true if this ImageWriteParam allows tile width and tile height parameters to be set.
canWriteTiles() - Method in class javax.imageio.ImageWriteParam
Returns true if the writer can perform tiling while writing.
CAP_BUTT - Static variable in class java.awt.BasicStroke
Ends unclosed subpaths and dash segments with no added decoration.
CAP_ROUND - Static variable in class java.awt.BasicStroke
Ends unclosed subpaths and dash segments with a round decoration that has a radius equal to half of the width of the pen.
CAP_SQUARE - Static variable in class java.awt.BasicStroke
Ends unclosed subpaths and dash segments with a square projection that extends beyond the end of the segment to a distance equal to half of the line width.
capacity() - Method in class java.lang.StringBuffer
capacity() - Method in class java.nio.Buffer
Returns this buffer's capacity.
capacity() - Method in class java.util.Vector
Returns the current capacity of this vector.
capacity() - Method in class javax.swing.DefaultListModel
Returns the current capacity of this list.
capacityIncrement - Variable in class java.util.Vector
The amount by which the capacity of the vector is automatically incremented when its size becomes greater than its capacity.
capacityIncrement - Static variable in class javax.management.monitor.Monitor
The amount by which the capacity of the monitor arrays are automatically incremented when their size becomes greater than their capacity.
caps - Variable in class java.awt.Component.BltBufferStrategy
The buffering capabilities
caps - Variable in class java.awt.Component.FlipBufferStrategy
The buffering capabilities
CAPS_LOCK - Static variable in class java.awt.Event
The Caps Lock key, a non-ASCII action key.
CAPTION - Static variable in class javax.swing.text.html.HTML.Tag
capture(TypeMirror) - Method in interface javax.lang.model.util.Types
Applies capture conversion to a type.
CAPTURING_PHASE - Static variable in interface org.w3c.dom.events.Event
The current event phase is the capturing phase.
cardinality() - Method in class java.util.BitSet
Returns the number of bits set to true in this BitSet.
CardLayout - Class in java.awt
A CardLayout object is a layout manager for a container.
CardLayout() - Constructor for class java.awt.CardLayout
Creates a new card layout with gaps of size zero.
CardLayout(int, int) - Constructor for class java.awt.CardLayout
Creates a new card layout with the specified horizontal and vertical gaps.
Caret - Interface in javax.swing.text
A place within a document view that represents where things can be inserted into the document model.
CARET_POSITION_CHANGED - Static variable in class java.awt.event.InputMethodEvent
The event type indicating a changed insertion point in input method text.
CaretEvent - Class in javax.swing.event
CaretEvent is used to notify interested parties that the text caret has changed in the event source.
CaretEvent(Object) - Constructor for class javax.swing.event.CaretEvent
Creates a new CaretEvent object.
CaretListener - Interface in javax.swing.event
Listener for changes in the caret position of a text component.
CaretPolicy() - Constructor for class java.awt.font.TextLayout.CaretPolicy
Constructs a CaretPolicy.
caretPositionChanged(InputMethodEvent) - Method in class java.awt.AWTEventMulticaster
Handles the caretPositionChanged event by invoking the caretPositionChanged methods on listener-a and listener-b.
caretPositionChanged(InputMethodEvent) - Method in interface java.awt.event.InputMethodListener
Invoked when the caret within composed text has changed.
caretUpdate(CaretEvent) - Method in interface javax.swing.event.CaretListener
Called when the caret position is updated.
caretUpdate(CaretEvent) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent
Handles caret updates (fire appropriate property change event, which are AccessibleContext.ACCESSIBLE_CARET_PROPERTY and AccessibleContext.ACCESSIBLE_SELECTION_PROPERTY).
CARIAN - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Carian" Unicode character block.
CASE_INSENSITIVE - Static variable in class java.util.regex.Pattern
Enables case-insensitive matching.
CASE_INSENSITIVE_ORDER - Static variable in class java.lang.String
A Comparator that orders String objects as by compareToIgnoreCase.
cast(Object) - Method in class java.lang.Class
Casts an object to the class or interface represented by this Class object.
catchException(MethodHandle, Class<? extends Throwable>, MethodHandle) - Static method in class java.lang.invoke.MethodHandles
Makes a method handle which adapts a target method handle, by running it inside an exception handler.
catchExceptions - Variable in class java.awt.event.InvocationEvent
Set to true if dispatch() catches Throwable and stores it in the exception instance variable.
cbrt(double) - Static method in class java.lang.Math
Returns the cube root of a double value.
cbrt(double) - Static method in class java.lang.StrictMath
Returns the cube root of a double value.
CDATA - Static variable in interface javax.swing.text.html.parser.DTDConstants
CDATA - Static variable in interface javax.xml.stream.XMLStreamConstants
Indicates an event is a CDATA section
CDATA_SECTION_ELEMENTS - Static variable in class javax.xml.transform.OutputKeys
cdata-section-elements = expanded names.
CDATA_SECTION_NODE - Static variable in interface org.w3c.dom.Node
The node is a CDATASection.
CDATASection - Interface in org.w3c.dom
CDATA sections are used to escape blocks of text containing characters that would otherwise be regarded as markup.
ceil(double) - Static method in class java.lang.Math
Returns the smallest (closest to negative infinity) double value that is greater than or equal to the argument and is equal to a mathematical integer.
ceil(double) - Static method in class java.lang.StrictMath
Returns the smallest (closest to negative infinity) double value that is greater than or equal to the argument and is equal to a mathematical integer.
ceiling(E) - Method in class java.util.concurrent.ConcurrentSkipListSet
ceiling(E) - Method in interface java.util.NavigableSet
Returns the least element in this set greater than or equal to the given element, or null if there is no such element.
ceiling(E) - Method in class java.util.TreeSet
ceilingEntry(K) - Method in class java.util.concurrent.ConcurrentSkipListMap
Returns a key-value mapping associated with the least key greater than or equal to the given key, or null if there is no such entry.
ceilingEntry(K) - Method in interface java.util.NavigableMap
Returns a key-value mapping associated with the least key greater than or equal to the given key, or null if there is no such key.
ceilingEntry(K) - Method in class java.util.TreeMap
ceilingKey(K) - Method in class java.util.concurrent.ConcurrentSkipListMap
ceilingKey(K) - Method in interface java.util.NavigableMap
Returns the least key greater than or equal to the given key, or null if there is no such key.
ceilingKey(K) - Method in class java.util.TreeMap
CELL_EDITOR_PROPERTY - Static variable in class javax.swing.JTree
Bound property name for cellEditor.
CELL_RENDERER_PROPERTY - Static variable in class javax.swing.JTree
Bound property name for cellRenderer.
CELL_RENDERER_PROPERTY - Static variable in class javax.swing.table.TableColumn
Obsolete as of Java 2 platform v1.3.
CellEditor - Interface in javax.swing
This interface defines the methods any general editor should be able to implement.
cellEditor - Variable in class javax.swing.JTable
The active cell editor object, that overwrites the screen real estate occupied by the current cell and allows the user to change its contents.
cellEditor - Variable in class javax.swing.JTree
Editor for the entries.
cellEditor - Variable in class javax.swing.plaf.basic.BasicTreeUI
Editor for the tree.
cellEditor - Variable in class javax.swing.table.TableColumn
The editor used to edit the data cells of the column.
CellEditorHandler() - Constructor for class javax.swing.plaf.basic.BasicTreeUI.CellEditorHandler
CellEditorListener - Interface in javax.swing.event
CellEditorListener defines the interface for an object that listens to changes in a CellEditor
cellHeight - Variable in class javax.swing.plaf.basic.BasicListUI
cellHeights - Variable in class javax.swing.plaf.basic.BasicListUI
CELLPADDING - Static variable in class javax.swing.text.html.HTML.Attribute
cellRenderer - Variable in class javax.swing.JTree
The cell used to draw nodes.
cellRenderer - Variable in class javax.swing.table.TableColumn
The renderer used to draw the data cells of the column.
cellRendererChanged - Static variable in class javax.swing.plaf.basic.BasicListUI
CellRendererPane - Class in javax.swing
This class is inserted in between cell renderers and the components that use them.
CellRendererPane() - Constructor for class javax.swing.CellRendererPane
Construct a CellRendererPane object.
CellRendererPane.AccessibleCellRendererPane - Class in javax.swing
This class implements accessibility support for the CellRendererPane class.
cellSelectionEnabled - Variable in class javax.swing.JTable
Obsolete as of Java 2 platform v1.3.
CELLSPACING - Static variable in class javax.swing.text.html.HTML.Attribute
cellWidth - Variable in class javax.swing.plaf.basic.BasicListUI
CENTER - Static variable in class java.awt.BorderLayout
The center layout constraint (middle of container).
CENTER - Static variable in class java.awt.FlowLayout
This value indicates that each row of components should be centered.
CENTER - Static variable in class java.awt.GridBagConstraints
Put the component in the center of its display area.
CENTER - Static variable in class java.awt.Label
Indicates that the label should be centered.
CENTER - Static variable in class javax.swing.border.TitledBorder
Position title text in the center of the border line.
CENTER - Static variable in interface javax.swing.SwingConstants
The central position in an area.
CENTER - Static variable in class javax.swing.text.html.HTML.Tag
CENTER_ALIGNMENT - Static variable in class java.awt.Component
Ease-of-use constant for getAlignmentY and getAlignmentX.
CENTER_BASELINE - Static variable in class java.awt.Font
The baseline used in ideographic scripts like Chinese, Japanese, and Korean when laying out text.
CENTER_BASELINE - Static variable in class java.awt.font.GraphicAttribute
Aligns origin of graphic to center baseline of line.
centersChildren - Variable in class javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout
If true, children are lumped together in parent.
Certificate - Class in java.security.cert
Abstract class for managing a variety of identity certificates.
Certificate(String) - Constructor for class java.security.cert.Certificate
Creates a certificate of the specified type.
Certificate - Interface in java.security
Deprecated.
A new certificate handling package is created in the Java platform. This Certificate interface is entirely deprecated and is here to allow for a smooth transition to the new package.
Certificate - Class in javax.security.cert
Abstract class for managing a variety of identity certificates.
Certificate() - Constructor for class javax.security.cert.Certificate
Certificate.CertificateRep - Class in java.security.cert
Alternate Certificate class for serialization.
CertificateEncodingException - Exception in java.security.cert
Certificate Encoding Exception.
CertificateEncodingException() - Constructor for exception java.security.cert.CertificateEncodingException
Constructs a CertificateEncodingException with no detail message.
CertificateEncodingException(String) - Constructor for exception java.security.cert.CertificateEncodingException
Constructs a CertificateEncodingException with the specified detail message.
CertificateEncodingException(String, Throwable) - Constructor for exception java.security.cert.CertificateEncodingException
Creates a CertificateEncodingException with the specified detail message and cause.
CertificateEncodingException(Throwable) - Constructor for exception java.security.cert.CertificateEncodingException
Creates a CertificateEncodingException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
CertificateEncodingException - Exception in javax.security.cert
Certificate Encoding Exception.
CertificateEncodingException() - Constructor for exception javax.security.cert.CertificateEncodingException
Constructs a CertificateEncodingException with no detail message.
CertificateEncodingException(String) - Constructor for exception javax.security.cert.CertificateEncodingException
Constructs a CertificateEncodingException with the specified detail message.
CertificateException - Exception in java.security.cert
This exception indicates one of a variety of certificate problems.
CertificateException() - Constructor for exception java.security.cert.CertificateException
Constructs a certificate exception with no detail message.
CertificateException(String) - Constructor for exception java.security.cert.CertificateException
Constructs a certificate exception with the given detail message.
CertificateException(String, Throwable) - Constructor for exception java.security.cert.CertificateException
Creates a CertificateException with the specified detail message and cause.
CertificateException(Throwable) - Constructor for exception java.security.cert.CertificateException
Creates a CertificateException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
CertificateException - Exception in javax.security.cert
This exception indicates one of a variety of certificate problems.
CertificateException() - Constructor for exception javax.security.cert.CertificateException
Constructs a certificate exception with no detail message.
CertificateException(String) - Constructor for exception javax.security.cert.CertificateException
Constructs a certificate exception with the given detail message.
CertificateExpiredException - Exception in java.security.cert
Certificate Expired Exception.
CertificateExpiredException() - Constructor for exception java.security.cert.CertificateExpiredException
Constructs a CertificateExpiredException with no detail message.
CertificateExpiredException(String) - Constructor for exception java.security.cert.CertificateExpiredException
Constructs a CertificateExpiredException with the specified detail message.
CertificateExpiredException - Exception in javax.security.cert
Certificate Expired Exception.
CertificateExpiredException() - Constructor for exception javax.security.cert.CertificateExpiredException
Constructs a CertificateExpiredException with no detail message.
CertificateExpiredException(String) - Constructor for exception javax.security.cert.CertificateExpiredException
Constructs a CertificateExpiredException with the specified detail message.
CertificateFactory - Class in java.security.cert
This class defines the functionality of a certificate factory, which is used to generate certificate, certification path (CertPath) and certificate revocation list (CRL) objects from their encodings.
CertificateFactory(CertificateFactorySpi, Provider, String) - Constructor for class java.security.cert.CertificateFactory
Creates a CertificateFactory object of the given type, and encapsulates the given provider implementation (SPI object) in it.
CertificateFactorySpi - Class in java.security.cert
This class defines the Service Provider Interface (SPI) for the CertificateFactory class.
CertificateFactorySpi() - Constructor for class java.security.cert.CertificateFactorySpi
CertificateNotYetValidException - Exception in java.security.cert
Certificate is not yet valid exception.
CertificateNotYetValidException() - Constructor for exception java.security.cert.CertificateNotYetValidException
Constructs a CertificateNotYetValidException with no detail message.
CertificateNotYetValidException(String) - Constructor for exception java.security.cert.CertificateNotYetValidException
Constructs a CertificateNotYetValidException with the specified detail message.
CertificateNotYetValidException - Exception in javax.security.cert
Certificate is not yet valid exception.
CertificateNotYetValidException() - Constructor for exception javax.security.cert.CertificateNotYetValidException
Constructs a CertificateNotYetValidException with no detail message.
CertificateNotYetValidException(String) - Constructor for exception javax.security.cert.CertificateNotYetValidException
Constructs a CertificateNotYetValidException with the specified detail message.
CertificateParsingException - Exception in java.security.cert
Certificate Parsing Exception.
CertificateParsingException() - Constructor for exception java.security.cert.CertificateParsingException
Constructs a CertificateParsingException with no detail message.
CertificateParsingException(String) - Constructor for exception java.security.cert.CertificateParsingException
Constructs a CertificateParsingException with the specified detail message.
CertificateParsingException(String, Throwable) - Constructor for exception java.security.cert.CertificateParsingException
Creates a CertificateParsingException with the specified detail message and cause.
CertificateParsingException(Throwable) - Constructor for exception java.security.cert.CertificateParsingException
Creates a CertificateParsingException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
CertificateParsingException - Exception in javax.security.cert
Certificate Parsing Exception.
CertificateParsingException() - Constructor for exception javax.security.cert.CertificateParsingException
Constructs a CertificateParsingException with no detail message.
CertificateParsingException(String) - Constructor for exception javax.security.cert.CertificateParsingException
Constructs a CertificateParsingException with the specified detail message.
CertificateRep(String, byte[]) - Constructor for class java.security.cert.Certificate.CertificateRep
Construct the alternate Certificate class with the Certificate type and Certificate encoding bytes.
CertificateRevokedException - Exception in java.security.cert
An exception that indicates an X.509 certificate is revoked.
CertificateRevokedException(Date, CRLReason, X500Principal, Map<String, Extension>) - Constructor for exception java.security.cert.CertificateRevokedException
Constructs a CertificateRevokedException with the specified revocation date, reason code, authority name, and map of extensions.
certificates() - Method in class java.security.Identity
Deprecated.
Returns a copy of all the certificates for this identity.
CertPath - Class in java.security.cert
An immutable sequence of certificates (a certification path).
CertPath(String) - Constructor for class java.security.cert.CertPath
Creates a CertPath of the specified type.
CertPath.CertPathRep - Class in java.security.cert
Alternate CertPath class for serialization.
CertPathBuilder - Class in java.security.cert
A class for building certification paths (also known as certificate chains).
CertPathBuilder(CertPathBuilderSpi, Provider, String) - Constructor for class java.security.cert.CertPathBuilder
Creates a CertPathBuilder object of the given algorithm, and encapsulates the given provider implementation (SPI object) in it.
CertPathBuilderException - Exception in java.security.cert
An exception indicating one of a variety of problems encountered when building a certification path with a CertPathBuilder.
CertPathBuilderException() - Constructor for exception java.security.cert.CertPathBuilderException
Creates a CertPathBuilderException with null as its detail message.
CertPathBuilderException(String) - Constructor for exception java.security.cert.CertPathBuilderException
Creates a CertPathBuilderException with the given detail message.
CertPathBuilderException(Throwable) - Constructor for exception java.security.cert.CertPathBuilderException
Creates a CertPathBuilderException that wraps the specified throwable.
CertPathBuilderException(String, Throwable) - Constructor for exception java.security.cert.CertPathBuilderException
Creates a CertPathBuilderException with the specified detail message and cause.
CertPathBuilderResult - Interface in java.security.cert
A specification of the result of a certification path builder algorithm.
CertPathBuilderSpi - Class in java.security.cert
The Service Provider Interface (SPI) for the CertPathBuilder class.
CertPathBuilderSpi() - Constructor for class java.security.cert.CertPathBuilderSpi
The default constructor.
CertPathChecker - Interface in java.security.cert
Performs one or more checks on each Certificate of a CertPath.
CertPathParameters - Interface in java.security.cert
A specification of certification path algorithm parameters.
CertPathRep(String, byte[]) - Constructor for class java.security.cert.CertPath.CertPathRep
Creates a CertPathRep with the specified type and encoded form of a certification path.
CertPathTrustManagerParameters - Class in javax.net.ssl
A wrapper for CertPathParameters.
CertPathTrustManagerParameters(CertPathParameters) - Constructor for class javax.net.ssl.CertPathTrustManagerParameters
Construct new CertPathTrustManagerParameters from the specified parameters.
CertPathValidator - Class in java.security.cert
A class for validating certification paths (also known as certificate chains).
CertPathValidator(CertPathValidatorSpi, Provider, String) - Constructor for class java.security.cert.CertPathValidator
Creates a CertPathValidator object of the given algorithm, and encapsulates the given provider implementation (SPI object) in it.
CertPathValidatorException - Exception in java.security.cert
An exception indicating one of a variety of problems encountered when validating a certification path.
CertPathValidatorException() - Constructor for exception java.security.cert.CertPathValidatorException
Creates a CertPathValidatorException with no detail message.
CertPathValidatorException(String) - Constructor for exception java.security.cert.CertPathValidatorException
Creates a CertPathValidatorException with the given detail message.
CertPathValidatorException(Throwable) - Constructor for exception java.security.cert.CertPathValidatorException
Creates a CertPathValidatorException that wraps the specified throwable.
CertPathValidatorException(String, Throwable) - Constructor for exception java.security.cert.CertPathValidatorException
Creates a CertPathValidatorException with the specified detail message and cause.
CertPathValidatorException(String, Throwable, CertPath, int) - Constructor for exception java.security.cert.CertPathValidatorException
Creates a CertPathValidatorException with the specified detail message, cause, certification path, and index.
CertPathValidatorException(String, Throwable, CertPath, int, CertPathValidatorException.Reason) - Constructor for exception java.security.cert.CertPathValidatorException
Creates a CertPathValidatorException with the specified detail message, cause, certification path, index, and reason.
CertPathValidatorException.BasicReason - Enum in java.security.cert
The BasicReason enumerates the potential reasons that a certification path of any type may be invalid.
CertPathValidatorException.Reason - Interface in java.security.cert
The reason the validation algorithm failed.
CertPathValidatorResult - Interface in java.security.cert
A specification of the result of a certification path validator algorithm.
CertPathValidatorSpi - Class in java.security.cert
The Service Provider Interface (SPI) for the CertPathValidator class.
CertPathValidatorSpi() - Constructor for class java.security.cert.CertPathValidatorSpi
The default constructor.
CertSelector - Interface in java.security.cert
A selector that defines a set of criteria for selecting Certificates.
CertStore - Class in java.security.cert
A class for retrieving Certificates and CRLs from a repository.
CertStore(CertStoreSpi, Provider, String, CertStoreParameters) - Constructor for class java.security.cert.CertStore
Creates a CertStore object of the given type, and encapsulates the given provider implementation (SPI object) in it.
CertStoreException - Exception in java.security.cert
An exception indicating one of a variety of problems retrieving certificates and CRLs from a CertStore.
CertStoreException() - Constructor for exception java.security.cert.CertStoreException
Creates a CertStoreException with null as its detail message.
CertStoreException(String) - Constructor for exception java.security.cert.CertStoreException
Creates a CertStoreException with the given detail message.
CertStoreException(Throwable) - Constructor for exception java.security.cert.CertStoreException
Creates a CertStoreException that wraps the specified throwable.
CertStoreException(String, Throwable) - Constructor for exception java.security.cert.CertStoreException
Creates a CertStoreException with the specified detail message and cause.
CertStoreParameters - Interface in java.security.cert
A specification of CertStore parameters.
CertStoreSpi - Class in java.security.cert
The Service Provider Interface (SPI) for the CertStore class.
CertStoreSpi(CertStoreParameters) - Constructor for class java.security.cert.CertStoreSpi
The sole constructor.
CHAKMA - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Chakma" Unicode character block.
CHAM - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Cham" Unicode character block.
CHANGE - Static variable in class javax.swing.event.DocumentEvent.EventType
Change type.
change(int, int, AbstractDocument.DefaultDocumentEvent) - Method in class javax.swing.text.DefaultStyledDocument.ElementBuffer
Changes content.
CHANGED - Static variable in class java.awt.dnd.DragSourceContext
An int used by updateCurrentCursor() indicating that the user operation has changed.
ChangedCharSetException - Exception in javax.swing.text
ChangedCharSetException as the name indicates is an exception thrown when the charset is changed.
ChangedCharSetException(String, boolean) - Constructor for exception javax.swing.text.ChangedCharSetException
changedUpdate(DocumentEvent) - Method in interface javax.swing.event.DocumentListener
Gives notification that an attribute or set of attributes changed.
changedUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.FlowView
Gives notification from the document that attributes were changed in a location that this view is responsible for.
changedUpdate(FlowView, DocumentEvent, Rectangle) - Method in class javax.swing.text.FlowView.FlowStrategy
Gives notification from the document that attributes were changed in a location that this view is responsible for.
changedUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.GlyphView
Gives notification from the document that attributes were changed in a location that this view is responsible for.
changedUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.html.BlockView
changedUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.html.ImageView
Invoked when the Elements attributes have changed.
changedUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.html.InlineView
Gives notification from the document that attributes were changed in a location that this view is responsible for.
changedUpdate(DocumentEvent) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent
Handles document remove (fire appropriate property change event, which is AccessibleContext.ACCESSIBLE_TEXT_PROPERTY).
changedUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.LabelView
Gives notification from the document that attributes were changed in a location that this view is responsible for.
changedUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.ParagraphView
Gives notification from the document that attributes were changed in a location that this view is responsible for.
changedUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.PlainView
Gives notification from the document that attributes were changed in a location that this view is responsible for.
changedUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.View
Gives notification from the document that attributes were changed in a location that this view is responsible for.
changedUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.WrappedPlainView
Gives notification from the document that attributes were changed in a location that this view is responsible for.
changeEvent - Variable in class javax.swing.AbstractButton
Only one ChangeEvent is needed per button instance since the event's only state is the source property.
changeEvent - Variable in class javax.swing.AbstractCellEditor
changeEvent - Variable in class javax.swing.colorchooser.DefaultColorSelectionModel
Only one ChangeEvent is needed per model instance since the event's only (read-only) state is the source property.
changeEvent - Variable in class javax.swing.DefaultBoundedRangeModel
Only one ChangeEvent is needed per model instance since the event's only (read-only) state is the source property.
changeEvent - Variable in class javax.swing.DefaultButtonModel
Only one ChangeEvent is needed per button model instance since the event's only state is the source property.
changeEvent - Variable in class javax.swing.DefaultSingleSelectionModel
ChangeEvent - Class in javax.swing.event
ChangeEvent is used to notify interested parties that state has changed in the event source.
ChangeEvent(Object) - Constructor for class javax.swing.event.ChangeEvent
Constructs a ChangeEvent object.
changeEvent - Variable in class javax.swing.JProgressBar
Only one ChangeEvent is needed per instance since the event's only interesting property is the immutable source, which is the progress bar.
changeEvent - Variable in class javax.swing.JSlider
Only one ChangeEvent is needed per slider instance since the event's only (read-only) state is the source property.
changeEvent - Variable in class javax.swing.JTabbedPane
Only one ChangeEvent is needed per TabPane instance since the event's only (read-only) state is the source property.
changeEvent - Variable in class javax.swing.MenuSelectionManager
Only one ChangeEvent is needed per button model instance since the event's only state is the source property.
changeEvent - Variable in class javax.swing.table.DefaultTableColumnModel
Change event (only one needed)
changeEvent - Variable in class javax.swing.text.DefaultCaret
The change event for the model.
changeEvent - Variable in class javax.swing.text.StyleContext.NamedStyle
Only one ChangeEvent is needed per model instance since the event's only (read-only) state is the source property.
ChangeHandler(JMenu, BasicMenuUI) - Constructor for class javax.swing.plaf.basic.BasicMenuUI.ChangeHandler
ChangeHandler() - Constructor for class javax.swing.plaf.basic.BasicProgressBarUI.ChangeHandler
ChangeHandler() - Constructor for class javax.swing.plaf.basic.BasicSliderUI.ChangeHandler
changeHighlight(Object, int, int) - Method in class javax.swing.text.DefaultHighlighter
Changes a highlight.
changeHighlight(Object, int, int) - Method in interface javax.swing.text.Highlighter
Changes the given highlight to span a different portion of the document.
changeInfo - Variable in class javax.naming.event.NamingEvent
Contains information about the change that generated this event.
changeListener - Variable in class javax.swing.AbstractButton
The button model's changeListener.
ChangeListener - Interface in javax.swing.event
Defines an object which listens for ChangeEvents.
changeListener - Variable in class javax.swing.JProgressBar
Listens for change events sent by the progress bar's model, redispatching them to change-event listeners registered upon this progress bar.
changeListener - Variable in class javax.swing.JSlider
The changeListener (no suffix) is the listener we add to the slider's model.
changeListener - Variable in class javax.swing.JTabbedPane
The changeListener is the listener we add to the model.
changeListener - Variable in class javax.swing.plaf.basic.BasicMenuBarUI
changeListener - Variable in class javax.swing.plaf.basic.BasicMenuUI
changeListener - Variable in class javax.swing.plaf.basic.BasicProgressBarUI
changeListener - Variable in class javax.swing.plaf.basic.BasicSliderUI
changeParameterType(int, Class<?>) - Method in class java.lang.invoke.MethodType
Finds or creates a method type with a single different parameter type.
changeReturnType(Class<?>) - Method in class java.lang.invoke.MethodType
Finds or creates a method type with a different return type.
changeSelection(int, int, boolean, boolean) - Method in class javax.swing.JTable
Updates the selection models of the table, depending on the state of the two flags: toggle and extend.
changeShape(Dimension, Dimension, Dimension) - Method in class javax.swing.Box.Filler
Change the size requests for this shape.
changeSupport - Variable in class javax.swing.AbstractAction
If any PropertyChangeListeners have been registered, the changeSupport field describes them.
changeSupport - Variable in class javax.swing.tree.DefaultTreeSelectionModel
Used to messaged registered listeners.
changeToParentDirectory() - Method in class javax.swing.JFileChooser
Changes the directory to be set to the parent of the current directory.
ChangeToParentDirectoryAction() - Constructor for class javax.swing.plaf.basic.BasicFileChooserUI.ChangeToParentDirectoryAction
changeUpdate() - Method in class javax.swing.text.DefaultStyledDocument.ElementBuffer
Updates the element structure in response to a change in the document.
Channel - Interface in java.nio.channels
A nexus for I/O operations.
channel() - Method in class java.nio.channels.FileLock
Returns the file channel upon whose file this lock was acquired.
channel() - Method in class java.nio.channels.MembershipKey
Returns the channel for which this membership key was created.
channel() - Method in class java.nio.channels.SelectionKey
Returns the channel for which this key was created.
channel - Variable in class javax.sound.midi.VoiceStatus
The MIDI channel on which this voice is playing.
CHANNEL_PRESSURE - Static variable in class javax.sound.midi.ShortMessage
Command value for Channel Pressure (Aftertouch) message (0xD0, or 208)
ChannelBinding - Class in org.ietf.jgss
This class encapsulates the concept of caller-provided channel binding information.
ChannelBinding(InetAddress, InetAddress, byte[]) - Constructor for class org.ietf.jgss.ChannelBinding
Create a ChannelBinding object with user supplied address information and data.
ChannelBinding(byte[]) - Constructor for class org.ietf.jgss.ChannelBinding
Creates a ChannelBinding object without any addressing information.
Channels - Class in java.nio.channels
Utility methods for channels and streams.
channels - Variable in class javax.sound.sampled.AudioFormat
The number of audio channels in this format (1 for mono, 2 for stereo).
CHAR - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type CHAR.
CHAR_ARRAY(String) - Constructor for class javax.print.DocFlavor.CHAR_ARRAY
Constructs a new doc flavor with the given MIME type and a print data representation class name of "[C" (character array).
CHAR_REPLACEMENT - Static variable in class java.awt.font.TextAttribute
Attribute key for a user-defined glyph to display in lieu of the font's standard glyph for a character.
CHAR_UNDEFINED - Static variable in class java.awt.event.KeyEvent
KEY_PRESSED and KEY_RELEASED events which do not map to a valid Unicode character use this for the keyChar value.
Character - Class in java.lang
The Character class wraps a value of the primitive type char in an object.
Character(char) - Constructor for class java.lang.Character
Constructs a newly allocated Character object that represents the specified char value.
CHARACTER - Static variable in interface javax.accessibility.AccessibleText
Constant used to indicate that the part of the text that should be retrieved is a character.
CHARACTER - Static variable in class javax.management.openmbean.SimpleType
The SimpleType instance describing values whose Java class name is java.lang.Character.
Character.Subset - Class in java.lang
Instances of this class represent particular subsets of the Unicode character set.
Character.UnicodeBlock - Class in java.lang
A family of character subsets representing the character blocks in the Unicode specification.
Character.UnicodeScript - Enum in java.lang
A family of character subsets representing the character scripts defined in the Unicode Standard Annex #24: Script Names.
CHARACTER_SET_ENCODING - Static variable in class javax.xml.soap.SOAPMessage
Specifies the character type encoding for the SOAP Message.
CharacterAction() - Constructor for class javax.swing.text.html.HTMLDocument.HTMLReader.CharacterAction
CharacterCodingException - Exception in java.nio.charset
Checked exception thrown when a character encoding or decoding error occurs.
CharacterCodingException() - Constructor for exception java.nio.charset.CharacterCodingException
Constructs an instance of this class.
CharacterData - Interface in org.w3c.dom
The CharacterData interface extends Node with a set of attributes and methods for accessing character data in the DOM.
characteristics() - Method in interface java.util.Spliterator
Returns a set of characteristics of this Spliterator and its elements.
characteristics() - Method in class java.util.Spliterators.AbstractDoubleSpliterator
Returns a set of characteristics of this Spliterator and its elements.
characteristics() - Method in class java.util.Spliterators.AbstractIntSpliterator
Returns a set of characteristics of this Spliterator and its elements.
characteristics() - Method in class java.util.Spliterators.AbstractLongSpliterator
Returns a set of characteristics of this Spliterator and its elements.
characteristics() - Method in class java.util.Spliterators.AbstractSpliterator
Returns a set of characteristics of this Spliterator and its elements.
characteristics() - Method in interface java.util.stream.Collector
Returns a Set of Collector.Characteristics indicating the characteristics of this Collector.
CharacterIterator - Interface in java.text
This interface defines a protocol for bidirectional iteration over text.
Characters - Interface in javax.xml.stream.events
This describes the interface to Characters events.
CHARACTERS - Static variable in interface javax.xml.stream.XMLStreamConstants
Indicates an event is characters
characters(char[], int, int) - Method in interface org.xml.sax.ContentHandler
Receive notification of character data.
characters(char[], int, int) - Method in interface org.xml.sax.DocumentHandler
Deprecated.
Receive notification of character data.
characters(char[], int, int) - Method in class org.xml.sax.HandlerBase
Deprecated.
Receive notification of character data inside an element.
characters(char[], int, int) - Method in class org.xml.sax.helpers.DefaultHandler
Receive notification of character data inside an element.
characters(char[], int, int) - Method in class org.xml.sax.helpers.ParserAdapter
Adapter implementation method; do not call.
characters(char[], int, int) - Method in class org.xml.sax.helpers.XMLFilterImpl
Filter a character data event.
characters(char[], int, int) - Method in class org.xml.sax.helpers.XMLReaderAdapter
Adapt a SAX2 characters event.
CharArrayReader - Class in java.io
This class implements a character buffer that can be used as a character-input stream.
CharArrayReader(char[]) - Constructor for class java.io.CharArrayReader
Creates a CharArrayReader from the specified array of chars.
CharArrayReader(char[], int, int) - Constructor for class java.io.CharArrayReader
Creates a CharArrayReader from the specified array of chars.
CharArrayWriter - Class in java.io
This class implements a character buffer that can be used as an Writer.
CharArrayWriter() - Constructor for class java.io.CharArrayWriter
Creates a new CharArrayWriter.
CharArrayWriter(int) - Constructor for class java.io.CharArrayWriter
Creates a new CharArrayWriter with the specified initial size.
charAt(int) - Method in interface java.lang.CharSequence
Returns the char value at the specified index.
charAt(int) - Method in class java.lang.String
Returns the char value at the specified index.
charAt(int) - Method in class java.lang.StringBuffer
charAt(int) - Method in class java.nio.CharBuffer
Reads the character at the given index relative to the current position.
charAt(int) - Method in class javax.swing.text.Segment
Returns the char value at the specified index.
charAttr - Variable in class javax.swing.text.html.HTMLDocument.HTMLReader
CharBuffer - Class in java.nio
A char buffer.
CharConversionException - Exception in java.io
Base class for character conversion exceptions.
CharConversionException() - Constructor for exception java.io.CharConversionException
This provides no detailed message.
CharConversionException(String) - Constructor for exception java.io.CharConversionException
This provides a detailed message.
charCount(int) - Static method in class java.lang.Character
Determines the number of char values needed to represent the specified character (Unicode code point).
CharHolder - Class in org.omg.CORBA
The Holder for Char.
CharHolder() - Constructor for class org.omg.CORBA.CharHolder
Constructs a new CharHolder object with its value field initialized to 0.
CharHolder(char) - Constructor for class org.omg.CORBA.CharHolder
Constructs a new CharHolder object for the given char.
chars() - Method in interface java.lang.CharSequence
Returns a stream of int zero-extending the char values from this sequence.
chars() - Method in class java.nio.CharBuffer
CharSeqHelper - Class in org.omg.CORBA
The Helper for CharSeq.
CharSeqHelper() - Constructor for class org.omg.CORBA.CharSeqHelper
CharSeqHolder - Class in org.omg.CORBA
The Holder for CharSeq.
CharSeqHolder() - Constructor for class org.omg.CORBA.CharSeqHolder
CharSeqHolder(char[]) - Constructor for class org.omg.CORBA.CharSeqHolder
CharSequence - Interface in java.lang
A CharSequence is a readable sequence of char values.
Charset - Class in java.nio.charset
A named mapping between sequences of sixteen-bit Unicode code units and sequences of bytes.
Charset(String, String[]) - Constructor for class java.nio.charset.Charset
Initializes a new charset with the given canonical name and alias set.
charset() - Method in class java.nio.charset.CharsetDecoder
Returns the charset that created this decoder.
charset() - Method in class java.nio.charset.CharsetEncoder
Returns the charset that created this encoder.
CharsetDecoder - Class in java.nio.charset
An engine that can transform a sequence of bytes in a specific charset into a sequence of sixteen-bit Unicode characters.
CharsetDecoder(Charset, float, float) - Constructor for class java.nio.charset.CharsetDecoder
Initializes a new decoder.
CharsetEncoder - Class in java.nio.charset
An engine that can transform a sequence of sixteen-bit Unicode characters into a sequence of bytes in a specific charset.
CharsetEncoder(Charset, float, float, byte[]) - Constructor for class java.nio.charset.CharsetEncoder
Initializes a new encoder.
CharsetEncoder(Charset, float, float) - Constructor for class java.nio.charset.CharsetEncoder
Initializes a new encoder.
charsetForName(String) - Method in class java.nio.charset.spi.CharsetProvider
Retrieves a charset for the given charset name.
CharsetProvider - Class in java.nio.charset.spi
Charset service-provider class.
CharsetProvider() - Constructor for class java.nio.charset.spi.CharsetProvider
Initializes a new charset provider.
charsets() - Method in class java.nio.charset.spi.CharsetProvider
Creates an iterator that iterates over the charsets supported by this provider.
charStream - Variable in class javax.sql.rowset.BaseRowSet
The Reader object that will be returned by the method getCharacterStream, which is specified in the ResultSet interface.
charsWidth(char[], int, int) - Method in class java.awt.FontMetrics
Returns the total advance width for showing the specified array of characters in this Font.
charValue() - Method in class java.lang.Character
Returns the value of this Character object.
charWidth(int) - Method in class java.awt.FontMetrics
Returns the advance width of the specified character in this Font.
charWidth(char) - Method in class java.awt.FontMetrics
Returns the advance width of the specified character in this Font.
check(Certificate) - Method in interface java.security.cert.CertPathChecker
Performs the check(s) on the specified certificate using its internal state.
check(Certificate, Collection<String>) - Method in class java.security.cert.PKIXCertPathChecker
Performs the check(s) on the specified certificate using its internal state and removes any critical extensions that it processes from the specified collection of OID strings that represent the unresolved critical extensions.
check(Certificate) - Method in class java.security.cert.PKIXCertPathChecker
Performs the check(s) on the specified certificate using its internal state.
check(String, URL, String, MLetContent) - Method in class javax.management.loading.MLet
This method is to be overridden when extending this service to support caching and versioning.
CHECK_BOX - Static variable in class javax.accessibility.AccessibleRole
A choice that can be checked or unchecked and provides a separate indicator for the current state.
CHECK_BOX - Static variable in class javax.swing.plaf.synth.Region
CheckBox region.
CHECK_BOX_MENU_ITEM - Static variable in class javax.swing.plaf.synth.Region
CheckBoxMenuItem region.
checkAccept(String, int) - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not permitted to accept a socket connection from the specified host and port number.
checkAccess(Thread) - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to modify the thread argument.
checkAccess(ThreadGroup) - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to modify the thread group argument.
checkAccess() - Method in class java.lang.Thread
Determines if the currently running thread has permission to modify this thread.
checkAccess() - Method in class java.lang.ThreadGroup
Determines if the currently running thread has permission to modify this thread group.
checkAccess(Path, AccessMode...) - Method in class java.nio.file.spi.FileSystemProvider
Checks the existence, and optionally the accessibility, of a file.
checkAccess() - Method in class java.util.logging.LogManager
Check that the current context is trusted to modify the logging configuration.
checkAll() - Method in class java.awt.MediaTracker
Checks to see if all images being tracked by this media tracker have finished loading.
checkAll(boolean) - Method in class java.awt.MediaTracker
Checks to see if all images being tracked by this media tracker have finished loading.
checkAwtEventQueueAccess() - Method in class java.lang.SecurityManager
Deprecated.
The dependency on AWTPermission creates an impediment to future modularization of the Java platform. Users of this method should instead invoke SecurityManager.checkPermission(java.security.Permission) directly. This method will be changed in a future release to check the permission java.security.AllPermission.
Checkbox - Class in java.awt
A check box is a graphical component that can be in either an "on" (true) or "off" (false) state.
Checkbox() - Constructor for class java.awt.Checkbox
Creates a check box with an empty string for its label.
Checkbox(String) - Constructor for class java.awt.Checkbox
Creates a check box with the specified label.
Checkbox(String, boolean) - Constructor for class java.awt.Checkbox
Creates a check box with the specified label and sets the specified state.
Checkbox(String, boolean, CheckboxGroup) - Constructor for class java.awt.Checkbox
Constructs a Checkbox with the specified label, set to the specified state, and in the specified check box group.
Checkbox(String, CheckboxGroup, boolean) - Constructor for class java.awt.Checkbox
Creates a check box with the specified label, in the specified check box group, and set to the specified state.
Checkbox.AccessibleAWTCheckbox - Class in java.awt
This class implements accessibility support for the Checkbox class.
CheckboxGroup - Class in java.awt
The CheckboxGroup class is used to group together a set of Checkbox buttons.
CheckboxGroup() - Constructor for class java.awt.CheckboxGroup
Creates a new instance of CheckboxGroup.
CheckboxMenuItem - Class in java.awt
This class represents a check box that can be included in a menu.
CheckboxMenuItem() - Constructor for class java.awt.CheckboxMenuItem
Create a check box menu item with an empty label.
CheckboxMenuItem(String) - Constructor for class java.awt.CheckboxMenuItem
Create a check box menu item with the specified label.
CheckboxMenuItem(String, boolean) - Constructor for class java.awt.CheckboxMenuItem
Create a check box menu item with the specified label and state.
CheckboxMenuItem.AccessibleAWTCheckboxMenuItem - Class in java.awt
Inner class of CheckboxMenuItem used to provide default support for accessibility.
checkClientTrusted(X509Certificate[], String, Socket) - Method in class javax.net.ssl.X509ExtendedTrustManager
Given the partial or complete certificate chain provided by the peer, build and validate the certificate path based on the authentication type and ssl parameters.
checkClientTrusted(X509Certificate[], String, SSLEngine) - Method in class javax.net.ssl.X509ExtendedTrustManager
Given the partial or complete certificate chain provided by the peer, build and validate the certificate path based on the authentication type and ssl parameters.
checkClientTrusted(X509Certificate[], String) - Method in interface javax.net.ssl.X509TrustManager
Given the partial or complete certificate chain provided by the peer, build a certificate path to a trusted root and return if it can be validated and is trusted for client SSL authentication based on the authentication type.
checkClosed() - Method in class javax.imageio.stream.ImageInputStreamImpl
Throws an IOException if the stream has been closed.
checkConnect(String, int) - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to open a socket connection to the specified host and port number.
checkConnect(String, int, Object) - Method in class java.lang.SecurityManager
Throws a SecurityException if the specified security context is not allowed to open a socket connection to the specified host and port number.
checkCreateClassLoader() - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to create a new class loader.
checkDelete(String) - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to delete the specified file.
CHECKED - Static variable in class javax.accessibility.AccessibleState
Indicates this object is currently checked.
CHECKED - Static variable in class javax.swing.text.html.HTML.Attribute
checkedCollection(Collection<E>, Class<E>) - Static method in class java.util.Collections
Returns a dynamically typesafe view of the specified collection.
CheckedInputStream - Class in java.util.zip
An input stream that also maintains a checksum of the data being read.
CheckedInputStream(InputStream, Checksum) - Constructor for class java.util.zip.CheckedInputStream
Creates an input stream using the specified Checksum.
checkedList(List<E>, Class<E>) - Static method in class java.util.Collections
Returns a dynamically typesafe view of the specified list.
checkedMap(Map<K, V>, Class<K>, Class<V>) - Static method in class java.util.Collections
Returns a dynamically typesafe view of the specified map.
checkedNavigableMap(NavigableMap<K, V>, Class<K>, Class<V>) - Static method in class java.util.Collections
Returns a dynamically typesafe view of the specified navigable map.
checkedNavigableSet(NavigableSet<E>, Class<E>) - Static method in class java.util.Collections
Returns a dynamically typesafe view of the specified navigable set.
CheckedOutputStream - Class in java.util.zip
An output stream that also maintains a checksum of the data being written.
CheckedOutputStream(OutputStream, Checksum) - Constructor for class java.util.zip.CheckedOutputStream
Creates an output stream with the specified Checksum.
checkedQueue(Queue<E>, Class<E>) - Static method in class java.util.Collections
Returns a dynamically typesafe view of the specified queue.
checkedSet(Set<E>, Class<E>) - Static method in class java.util.Collections
Returns a dynamically typesafe view of the specified set.
checkedSortedMap(SortedMap<K, V>, Class<K>, Class<V>) - Static method in class java.util.Collections
Returns a dynamically typesafe view of the specified sorted map.
checkedSortedSet(SortedSet<E>, Class<E>) - Static method in class java.util.Collections
Returns a dynamically typesafe view of the specified sorted set.
checkError() - Method in class java.io.PrintStream
Flushes the stream and checks its error state.
checkError() - Method in class java.io.PrintWriter
Flushes the stream if it's not closed and checks its error state.
checkExec(String) - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to create a subprocess.
checkExit(int) - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to cause the Java Virtual Machine to halt with the specified status code.
checkForClickInExpandControl(TreePath, int, int) - Method in class javax.swing.plaf.basic.BasicTreeUI
If the mouseX and mouseY are in the expand/collapse region of the row, this will toggle the row.
checkGuard(Object) - Method in interface java.security.Guard
Determines whether or not to allow access to the guarded object object.
checkGuard(Object) - Method in class java.security.Permission
Implements the guard interface for a permission.
checkHorizontalKey(int, String) - Method in class javax.swing.AbstractButton
Verify that the key argument is a legal value for the horizontalAlignment and horizontalTextPosition properties.
checkHorizontalKey(int, String) - Method in class javax.swing.JLabel
Verify that key is a legal value for the horizontalAlignment properties.
checkIcon - Variable in class javax.swing.plaf.basic.BasicMenuItemUI
checkID(int) - Method in class java.awt.MediaTracker
Checks to see if all images tracked by this media tracker that are tagged with the specified identifier have finished loading.
checkID(int, boolean) - Method in class java.awt.MediaTracker
Checks to see if all images tracked by this media tracker that are tagged with the specified identifier have finished loading.
checkImage(Image, ImageObserver) - Method in class java.awt.Component
Returns the status of the construction of a screen representation of the specified image.
checkImage(Image, int, int, ImageObserver) - Method in class java.awt.Component
Returns the status of the construction of a screen representation of the specified image.
checkImage(Image, int, int, ImageObserver) - Method in class java.awt.Toolkit
Indicates the construction status of a specified image that is being prepared for display.
checkLink(String) - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to dynamic link the library code specified by the string argument file.
checkListen(int) - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to wait for a connection request on the specified local port number.
checkMaxDegree(int) - Method in class javax.management.relation.RoleInfo
Returns true if the value parameter is lower than or equal to the expected maximum degree, false otherwise.
checkMemberAccess(Class<?>, int) - Method in class java.lang.SecurityManager
Deprecated.
This method relies on the caller being at a stack depth of 4 which is error-prone and cannot be enforced by the runtime. Users of this method should instead invoke SecurityManager.checkPermission(java.security.Permission) directly. This method will be changed in a future release to check the permission java.security.AllPermission.
checkMinDegree(int) - Method in class javax.management.relation.RoleInfo
Returns true if the value parameter is greater than or equal to the expected minimum degree, false otherwise.
checkMulticast(InetAddress) - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to use (join/leave/send/receive) IP multicast.
checkMulticast(InetAddress, byte) - Method in class java.lang.SecurityManager
Deprecated.
Use #checkPermission(java.security.Permission) instead
checkOpacity(AbstractButton) - Method in class javax.swing.plaf.basic.BasicButtonListener
checkPackageAccess(String) - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to access the package specified by the argument.
checkPackageDefinition(String) - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to define classes in the package specified by the argument.
checkPainter() - Method in class javax.swing.text.GlyphView
Check to see that a glyph painter exists.
checkPermission(Permission) - Method in class java.lang.SecurityManager
Throws a SecurityException if the requested access, specified by the given permission, is not permitted based on the security policy currently in effect.
checkPermission(Permission, Object) - Method in class java.lang.SecurityManager
Throws a SecurityException if the specified security context is denied access to the resource specified by the given permission.
checkPermission(Permission) - Method in class java.security.AccessControlContext
Determines whether the access request indicated by the specified permission should be allowed or denied, based on the security policy currently in effect, and the context in this object.
checkPermission(Permission) - Static method in class java.security.AccessController
Determines whether the access request indicated by the specified permission should be allowed or denied, based on the current AccessControlContext and security policy.
checkPermission(Principal, Permission) - Method in interface java.security.acl.Acl
Checks whether or not the specified principal has the specified permission.
checkPermission(Permission) - Method in interface java.security.acl.AclEntry
Checks if the specified permission is part of the permission set in this entry.
checkPrintJobAccess() - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to initiate a print job request.
checkPropertiesAccess() - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to access or modify the system properties.
checkPropertyAccess(String) - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to access the system property with the specified key name.
checkRead(FileDescriptor) - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to read from the specified file descriptor.
checkRead(String) - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to read the file specified by the string argument.
checkRead(String, Object) - Method in class java.lang.SecurityManager
Throws a SecurityException if the specified security context is not allowed to read the file specified by the string argument.
checkReadParamBandSettings(ImageReadParam, int, int) - Static method in class javax.imageio.ImageReader
A utility method that may be used by readers to test the validity of the source and destination band settings of an ImageReadParam.
checkRoleReading(String, String) - Method in class javax.management.relation.RelationService
Checks if given Role can be read in a relation of the given type.
checkRoleReading(String, String) - Method in interface javax.management.relation.RelationServiceMBean
Checks if given Role can be read in a relation of the given type.
checkRoleWriting(Role, String, Boolean) - Method in class javax.management.relation.RelationService
Checks if given Role can be set in a relation of given type.
checkRoleWriting(Role, String, Boolean) - Method in interface javax.management.relation.RelationServiceMBean
Checks if given Role can be set in a relation of given type.
checkSecurityAccess(String) - Method in class java.lang.SecurityManager
Determines whether the permission with the specified permission target name should be granted or denied.
checkServerTrusted(X509Certificate[], String, Socket) - Method in class javax.net.ssl.X509ExtendedTrustManager
Given the partial or complete certificate chain provided by the peer, build and validate the certificate path based on the authentication type and ssl parameters.
checkServerTrusted(X509Certificate[], String, SSLEngine) - Method in class javax.net.ssl.X509ExtendedTrustManager
Given the partial or complete certificate chain provided by the peer, build and validate the certificate path based on the authentication type and ssl parameters.
checkServerTrusted(X509Certificate[], String) - Method in interface javax.net.ssl.X509TrustManager
Given the partial or complete certificate chain provided by the peer, build a certificate path to a trusted root and return if it can be validated and is trusted for server SSL authentication based on the authentication type.
checkSetFactory() - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to set the socket factory used by ServerSocket or Socket, or the stream handler factory used by URL.
Checksum - Interface in java.util.zip
An interface representing a data checksum.
checkSystemClipboardAccess() - Method in class java.lang.SecurityManager
Deprecated.
The dependency on AWTPermission creates an impediment to future modularization of the Java platform. Users of this method should instead invoke SecurityManager.checkPermission(java.security.Permission) directly. This method will be changed in a future release to check the permission java.security.AllPermission.
checkTopLevelWindow(Object) - Method in class java.lang.SecurityManager
Deprecated.
The dependency on AWTPermission creates an impediment to future modularization of the Java platform. Users of this method should instead invoke SecurityManager.checkPermission(java.security.Permission) directly. This method will be changed in a future release to check the permission java.security.AllPermission.
checkValidIntValue(long) - Method in enum java.time.temporal.ChronoField
Checks that the specified value is valid and fits in an int.
checkValidIntValue(long, TemporalField) - Method in class java.time.temporal.ValueRange
Checks that the specified value is valid and fits in an int.
checkValidity() - Method in class java.security.cert.X509Certificate
Checks that the certificate is currently valid.
checkValidity(Date) - Method in class java.security.cert.X509Certificate
Checks that the given date is within the certificate's validity period.
checkValidity() - Method in class javax.security.cert.X509Certificate
Checks that the certificate is currently valid.
checkValidity(Date) - Method in class javax.security.cert.X509Certificate
Checks that the specified date is within the certificate's validity period.
checkValidValue(long) - Method in enum java.time.temporal.ChronoField
Checks that the specified value is valid for this field.
checkValidValue(long, TemporalField) - Method in class java.time.temporal.ValueRange
Checks that the specified value is valid.
checkVerticalKey(int, String) - Method in class javax.swing.AbstractButton
Verify that the key argument is a legal value for the vertical properties.
checkVerticalKey(int, String) - Method in class javax.swing.JLabel
Verify that key is a legal value for the verticalAlignment or verticalTextPosition properties.
checkWrite(FileDescriptor) - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to write to the specified file descriptor.
checkWrite(String) - Method in class java.lang.SecurityManager
Throws a SecurityException if the calling thread is not allowed to write to the file specified by the string argument.
CHEROKEE - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Cherokee" Unicode character block.
CHILD_NODE_OF - Static variable in class javax.accessibility.AccessibleRelation
Indicates that an object is a child node of one or more objects.
CHILD_NODE_OF_PROPERTY - Static variable in class javax.accessibility.AccessibleRelation
Indicates the CHILD_NODE_OF relation between two or more objects has changed.
CHILD_POLICY_ALL - Static variable in interface javax.imageio.metadata.IIOMetadataFormat
A constant returned by getChildPolicy to indicate that an element must have a single instance of each of its legal child elements, in order.
CHILD_POLICY_CHOICE - Static variable in interface javax.imageio.metadata.IIOMetadataFormat
A constant returned by getChildPolicy to indicate that an element must have zero or one children, selected from among its legal child elements.
CHILD_POLICY_EMPTY - Static variable in interface javax.imageio.metadata.IIOMetadataFormat
A constant returned by getChildPolicy to indicate that an element may not have any children.
CHILD_POLICY_MAX - Static variable in interface javax.imageio.metadata.IIOMetadataFormat
The largest valid CHILD_POLICY_* constant, to be used for range checks.
CHILD_POLICY_REPEAT - Static variable in interface javax.imageio.metadata.IIOMetadataFormat
A constant returned by getChildPolicy to indicate that an element must have zero or more instances of its unique legal child element.
CHILD_POLICY_SEQUENCE - Static variable in interface javax.imageio.metadata.IIOMetadataFormat
A constant returned by getChildPolicy to indicate that an element must have a sequence of instances of any of its legal child elements.
CHILD_POLICY_SOME - Static variable in interface javax.imageio.metadata.IIOMetadataFormat
A constant returned by getChildPolicy to indicate that an element must have zero or one instance of each of its legal child elements, in order.
childAdded(NodeChangeEvent) - Method in interface java.util.prefs.NodeChangeListener
This method gets called when a child node is added.
childAlloc - Variable in class javax.swing.text.AsyncBoxView.ChildLocator
A shape to use for the child allocation to avoid creating a lot of garbage.
childAllocation(int, Rectangle) - Method in class javax.swing.text.BoxView
Allocates a region for a child view.
childAllocation(int, Rectangle) - Method in class javax.swing.text.CompositeView
Returns the allocation for a given child.
childChanged(AsyncBoxView.ChildState) - Method in class javax.swing.text.AsyncBoxView.ChildLocator
Notification that a child changed.
childDeserializedHook(Object, BeanContextSupport.BCSChild) - Method in class java.beans.beancontext.BeanContextSupport
Called by readObject with the newly deserialized child and BCSChild.
childIndices - Variable in class javax.swing.event.TreeModelEvent
Indices identifying the position of where the children were.
childJustAddedHook(Object, BeanContextSupport.BCSChild) - Method in class java.beans.beancontext.BeanContextSupport
subclasses may override this method to simply extend add() semantics after the child has been added and before the event notification has occurred.
childJustRemovedHook(Object, BeanContextSupport.BCSChild) - Method in class java.beans.beancontext.BeanContextServicesSupport
called from superclass child removal operations after a child has been successfully removed.
childJustRemovedHook(Object, BeanContextSupport.BCSChild) - Method in class java.beans.beancontext.BeanContextSupport
subclasses may override this method to simply extend remove() semantics after the child has been removed and before the event notification has occurred.
ChildLocator() - Constructor for class javax.swing.text.AsyncBoxView.ChildLocator
construct a child locator.
childRemoved(NodeChangeEvent) - Method in interface java.util.prefs.NodeChangeListener
This method gets called when a child node is removed.
children - Variable in class java.beans.beancontext.BeanContextMembershipEvent
The list of children affected by this event notification.
children - Variable in class java.beans.beancontext.BeanContextSupport
all accesses to the protected HashMap children field shall be synchronized on that object.
children - Variable in class javax.swing.event.TreeModelEvent
Children that have been removed.
children() - Method in class javax.swing.JTree.DynamicUtilTreeNode
Subclassed to load the children, if necessary.
children() - Method in class javax.swing.text.AbstractDocument.AbstractElement
Returns the children of the receiver as an Enumeration.
children() - Method in class javax.swing.text.AbstractDocument.BranchElement
Returns the children of the receiver as an Enumeration.
children() - Method in class javax.swing.text.AbstractDocument.LeafElement
Returns the children of the receiver as an Enumeration.
children - Variable in class javax.swing.tree.DefaultMutableTreeNode
array of children, may be null if this node has no children
children() - Method in class javax.swing.tree.DefaultMutableTreeNode
Creates and returns a forward-order enumeration of this node's children.
children() - Method in interface javax.swing.tree.TreeNode
Returns the children of the receiver as an Enumeration.
childrenAdded(BeanContextMembershipEvent) - Method in interface java.beans.beancontext.BeanContextMembershipListener
Called when a child or list of children is added to a BeanContext that this listener is registered with.
childrenNames() - Method in class java.util.prefs.AbstractPreferences
Implements the children method as per the specification in Preferences.childrenNames().
childrenNames() - Method in class java.util.prefs.Preferences
Returns the names of the children of this preference node, relative to this node.
childrenNamesSpi() - Method in class java.util.prefs.AbstractPreferences
Returns the names of the children of this preference node.
childrenRemoved(BeanContextMembershipEvent) - Method in interface java.beans.beancontext.BeanContextMembershipListener
Called when a child or list of children is removed from a BeanContext that this listener is registered with.
childSpi(String) - Method in class java.util.prefs.AbstractPreferences
Returns the named child of this preference node, creating it if it does not already exist.
ChildState(View) - Constructor for class javax.swing.text.AsyncBoxView.ChildState
Construct a child status.
childValue(T) - Method in class java.lang.InheritableThreadLocal
Computes the child's initial value for this inheritable thread-local variable as a function of the parent's value at the time the child thread is created.
childValue - Variable in class javax.swing.JTree.DynamicUtilTreeNode
Value to create children with.
CHINA - Static variable in class java.util.Locale
Useful constant for country.
CHINESE - Static variable in class java.util.Locale
Useful constant for language.
Choice - Class in java.awt
The Choice class presents a pop-up menu of choices.
Choice() - Constructor for class java.awt.Choice
Creates a new choice menu.
Choice.AccessibleAWTChoice - Class in java.awt
This class implements accessibility support for the Choice class.
ChoiceCallback - Class in javax.security.auth.callback
Underlying security services instantiate and pass a ChoiceCallback to the handle method of a CallbackHandler to display a list of choices and to retrieve the selected choice(s).
ChoiceCallback(String, String[], int, boolean) - Constructor for class javax.security.auth.callback.ChoiceCallback
Construct a ChoiceCallback with a prompt, a list of choices, a default choice, and a boolean specifying whether or not multiple selections from the list of choices are allowed.
ChoiceFormat - Class in java.text
A ChoiceFormat allows you to attach a format to a range of numbers.
ChoiceFormat(String) - Constructor for class java.text.ChoiceFormat
Constructs with limits and corresponding formats based on the pattern.
ChoiceFormat(double[], String[]) - Constructor for class java.text.ChoiceFormat
Constructs with the limits and the corresponding formats.
choices - Variable in class java.sql.DriverPropertyInfo
An array of possible values if the value for the field DriverPropertyInfo.value may be selected from a particular set of values; otherwise null.
CHOOSABLE_FILE_FILTER_CHANGED_PROPERTY - Static variable in class javax.swing.JFileChooser
Identifies a change in the list of predefined file filters the user can choose from.
chooseClientAlias(String[], Principal[], Socket) - Method in interface javax.net.ssl.X509KeyManager
Choose an alias to authenticate the client side of a secure socket given the public key type and the list of certificate issuer authorities recognized by the peer (if any).
chooseEngineClientAlias(String[], Principal[], SSLEngine) - Method in class javax.net.ssl.X509ExtendedKeyManager
Choose an alias to authenticate the client side of an SSLEngine connection given the public key type and the list of certificate issuer authorities recognized by the peer (if any).
chooseEngineServerAlias(String, Principal[], SSLEngine) - Method in class javax.net.ssl.X509ExtendedKeyManager
Choose an alias to authenticate the server side of an SSLEngine connection given the public key type and the list of certificate issuer authorities recognized by the peer (if any).
chooser - Variable in class javax.swing.plaf.basic.BasicColorChooserUI
JColorChooser this BasicColorChooserUI is installed on.
CHOOSER_PANELS_PROPERTY - Static variable in class javax.swing.JColorChooser
The chooserPanel array property name.
chooseServerAlias(String, Principal[], Socket) - Method in interface javax.net.ssl.X509KeyManager
Choose an alias to authenticate the server side of a secure socket given the public key type and the list of certificate issuer authorities recognized by the peer (if any).
CHORD - Static variable in class java.awt.geom.Arc2D
The closure type for an arc closed by drawing a straight line segment from the start of the arc segment to the end of the arc segment.
CHOU_1 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS Chou ("long") #1 envelope size, 142 mm by 332 mm.
CHOU_2 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS Chou ("long") #2 envelope size, 119 mm by 277 mm.
CHOU_3 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS Chou ("long") #3 envelope size, 120 mm by 235 mm.
CHOU_30 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS Chou ("long") #30 envelope size, 92 mm by 235 mm.
CHOU_4 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS Chou ("long") #4 envelope size, 90 mm by 205 mm.
CHOU_40 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS Chou ("long") #40 envelope size, 90 mm by 225 mm.
Chromaticity - Class in javax.print.attribute.standard
Class Chromaticity is a printing attribute class, an enumeration, that specifies monochrome or color printing.
Chromaticity(int) - Constructor for class javax.print.attribute.standard.Chromaticity
Construct a new chromaticity enumeration value with the given integer value.
ChronoField - Enum in java.time.temporal
A standard set of fields.
ChronoLocalDate - Interface in java.time.chrono
A date without time-of-day or time-zone in an arbitrary chronology, intended for advanced globalization use cases.
ChronoLocalDateTime<D extends ChronoLocalDate> - Interface in java.time.chrono
A date-time without a time-zone in an arbitrary chronology, intended for advanced globalization use cases.
Chronology - Interface in java.time.chrono
A calendar system, used to organize and identify dates.
chronology() - Static method in class java.time.temporal.TemporalQueries
A query for the Chronology.
ChronoPeriod - Interface in java.time.chrono
A date-based amount of time, such as '3 years, 4 months and 5 days' in an arbitrary chronology, intended for advanced globalization use cases.
ChronoUnit - Enum in java.time.temporal
A standard set of date periods units.
ChronoZonedDateTime<D extends ChronoLocalDate> - Interface in java.time.chrono
A date-time with a time-zone in an arbitrary chronology, intended for advanced globalization use cases.
chunkLength - Variable in class java.net.HttpURLConnection
The chunk-length when using chunked encoding streaming mode for output.
Cipher - Class in javax.crypto
This class provides the functionality of a cryptographic cipher for encryption and decryption.
Cipher(CipherSpi, Provider, String) - Constructor for class javax.crypto.Cipher
Creates a Cipher object.
CipherInputStream - Class in javax.crypto
A CipherInputStream is composed of an InputStream and a Cipher so that read() methods return data that are read in from the underlying InputStream but have been additionally processed by the Cipher.
CipherInputStream(InputStream, Cipher) - Constructor for class javax.crypto.CipherInputStream
Constructs a CipherInputStream from an InputStream and a Cipher.
CipherInputStream(InputStream) - Constructor for class javax.crypto.CipherInputStream
Constructs a CipherInputStream from an InputStream without specifying a Cipher.
CipherOutputStream - Class in javax.crypto
A CipherOutputStream is composed of an OutputStream and a Cipher so that write() methods first process the data before writing them out to the underlying OutputStream.
CipherOutputStream(OutputStream, Cipher) - Constructor for class javax.crypto.CipherOutputStream
Constructs a CipherOutputStream from an OutputStream and a Cipher.
CipherOutputStream(OutputStream) - Constructor for class javax.crypto.CipherOutputStream
Constructs a CipherOutputStream from an OutputStream without specifying a Cipher.
CipherSpi - Class in javax.crypto
This class defines the Service Provider Interface (SPI) for the Cipher class.
CipherSpi() - Constructor for class javax.crypto.CipherSpi
CITE - Static variable in class javax.swing.text.html.HTML.Tag
CJK_COMPATIBILITY - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "CJK Compatibility" Unicode character block.
CJK_COMPATIBILITY_FORMS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "CJK Compatibility Forms" Unicode character block.
CJK_COMPATIBILITY_IDEOGRAPHS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "CJK Compatibility Ideographs" Unicode character block.
CJK_COMPATIBILITY_IDEOGRAPHS_SUPPLEMENT - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "CJK Compatibility Ideographs Supplement" Unicode character block.
CJK_RADICALS_SUPPLEMENT - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "CJK Radicals Supplement" Unicode character block.
CJK_STROKES - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "CJK Strokes" Unicode character block.
CJK_SYMBOLS_AND_PUNCTUATION - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "CJK Symbols and Punctuation" Unicode character block.
CJK_UNIFIED_IDEOGRAPHS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "CJK Unified Ideographs" Unicode character block.
CJK_UNIFIED_IDEOGRAPHS_EXTENSION_A - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "CJK Unified Ideographs Extension A" Unicode character block.
CJK_UNIFIED_IDEOGRAPHS_EXTENSION_B - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "CJK Unified Ideographs Extension B" Unicode character block.
CJK_UNIFIED_IDEOGRAPHS_EXTENSION_C - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "CJK Unified Ideographs Extension C" Unicode character block.
CJK_UNIFIED_IDEOGRAPHS_EXTENSION_D - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "CJK Unified Ideographs Extension D" Unicode character block.
Class<T> - Class in java.lang
Instances of the class Class represent classes and interfaces in a running Java application.
CLASS - Static variable in class javax.swing.text.html.HTML.Attribute
CLASS_ABSTRACT - Static variable in class java.awt.color.ICC_Profile
Profile class is abstract.
CLASS_ATTRIBUTE_PFX - Static variable in interface java.util.jar.Pack200.Packer
When concatenated with a class attribute name, indicates the format of that attribute, using the layout language specified in the JSR 200 specification.
CLASS_COLORSPACECONVERSION - Static variable in class java.awt.color.ICC_Profile
Profile class is color space conversion.
CLASS_DEVICELINK - Static variable in class java.awt.color.ICC_Profile
Profile class is device link.
CLASS_DISPLAY - Static variable in class java.awt.color.ICC_Profile
Profile class is display.
CLASS_INPUT - Static variable in class java.awt.color.ICC_Profile
Profile class is input.
CLASS_LOADING_MXBEAN_NAME - Static variable in class java.lang.management.ManagementFactory
String representation of the ObjectName for the ClassLoadingMXBean.
CLASS_NAMEDCOLOR - Static variable in class java.awt.color.ICC_Profile
Profile class is named color.
CLASS_OUTPUT - Static variable in class java.awt.color.ICC_Profile
Profile class is output.
CLASS_PATH - Static variable in class java.util.jar.Attributes.Name
Name object for Class-Path manifest attribute.
classattr() - Static method in class javax.management.Query
Returns a new class attribute expression which can be used in any Query call that expects a ValueExp.
ClassCastException - Exception in java.lang
Thrown to indicate that the code has attempted to cast an object to a subclass of which it is not an instance.
ClassCastException() - Constructor for exception java.lang.ClassCastException
Constructs a ClassCastException with no detail message.
ClassCastException(String) - Constructor for exception java.lang.ClassCastException
Constructs a ClassCastException with the specified detail message.
ClassCircularityError - Error in java.lang
Thrown when the Java Virtual Machine detects a circularity in the superclass hierarchy of a class being loaded.
ClassCircularityError() - Constructor for error java.lang.ClassCircularityError
Constructs a ClassCircularityError with no detail message.
ClassCircularityError(String) - Constructor for error java.lang.ClassCircularityError
Constructs a ClassCircularityError with the specified detail message.
ClassDefinition - Class in java.lang.instrument
This class serves as a parameter block to the Instrumentation.redefineClasses method.
ClassDefinition(Class<?>, byte[]) - Constructor for class java.lang.instrument.ClassDefinition
Creates a new ClassDefinition binding using the supplied class and class file bytes.
classDepth(String) - Method in class java.lang.SecurityManager
Deprecated.
This type of security checking is not recommended. It is recommended that the checkPermission call be used instead.
ClassDesc - Class in javax.rmi.CORBA
This class is used to marshal java.lang.Class objects over IIOP.
ClassDesc() - Constructor for class javax.rmi.CORBA.ClassDesc
classEquals(Class, Class) - Static method in class java.beans.beancontext.BeanContextSupport
Tests to see if two class objects, or their names are equal.
classFactory - Variable in class javax.naming.Reference
Contains the name of the factory class for creating an instance of the object to which this Reference refers.
classFactoryLocation - Variable in class javax.naming.Reference
Contains the location of the factory class.
ClassFileTransformer - Interface in java.lang.instrument
An agent provides an implementation of this interface in order to transform class files.
ClassFormatError - Error in java.lang
Thrown when the Java Virtual Machine attempts to read a class file and determines that the file is malformed or otherwise cannot be interpreted as a class file.
ClassFormatError() - Constructor for error java.lang.ClassFormatError
Constructs a ClassFormatError with no detail message.
ClassFormatError(String) - Constructor for error java.lang.ClassFormatError
Constructs a ClassFormatError with the specified detail message.
CLASSID - Static variable in class javax.swing.text.html.HTML.Attribute
ClassLoader - Class in java.lang
A class loader is an object that is responsible for loading classes.
ClassLoader(ClassLoader) - Constructor for class java.lang.ClassLoader
Creates a new class loader using the specified parent class loader for delegation.
ClassLoader() - Constructor for class java.lang.ClassLoader
Creates a new class loader using the ClassLoader returned by the method getSystemClassLoader() as the parent class loader.
classLoaderDepth() - Method in class java.lang.SecurityManager
Deprecated.
This type of security checking is not recommended. It is recommended that the checkPermission call be used instead.
ClassLoaderRepository - Interface in javax.management.loading
Instances of this interface are used to keep the list of ClassLoaders registered in an MBean Server.
ClassLoadingMXBean - Interface in java.lang.management
The management interface for the class loading system of the Java virtual machine.
classModifiers() - Static method in class java.lang.reflect.Modifier
Return an int value OR-ing together the source language modifiers that can be applied to a class.
classname - Variable in exception java.io.InvalidClassException
Name of the invalid class.
className - Variable in class javax.naming.Reference
Contains the fully-qualified name of the class of the object to which this Reference refers.
ClassNotFoundException - Exception in java.lang
Thrown when an application tries to load in a class through its string name using: The forName method in class Class.
ClassNotFoundException() - Constructor for exception java.lang.ClassNotFoundException
Constructs a ClassNotFoundException with no detail message.
ClassNotFoundException(String) - Constructor for exception java.lang.ClassNotFoundException
Constructs a ClassNotFoundException with the specified detail message.
ClassNotFoundException(String, Throwable) - Constructor for exception java.lang.ClassNotFoundException
Constructs a ClassNotFoundException with the specified detail message and optional exception that was raised while loading the class.
ClassValue<T> - Class in java.lang
Lazily associate a computed value with (potentially) every type.
ClassValue() - Constructor for class java.lang.ClassValue
Sole constructor.
clean(ObjID[], long, VMID, boolean) - Method in interface java.rmi.dgc.DGC
The clean call removes the 'vmid' from the reference list of each remote object indicated in 'id's.
CLEAR - Static variable in class java.awt.AlphaComposite
Both the color and the alpha of the destination are cleared (Porter-Duff Clear rule).
Clear - Static variable in class java.awt.AlphaComposite
AlphaComposite object that implements the opaque CLEAR rule with an alpha of 1.0f.
clear() - Method in class java.awt.List
Deprecated.
As of JDK version 1.1, replaced by removeAll().
clear() - Method in class java.awt.RenderingHints
Clears this RenderingHints object of all key/value pairs.
clear() - Method in class java.beans.beancontext.BeanContextSupport
clear the children (Unsupported) implementations must synchronized on the hierarchy lock and "children" protected field
clear() - Method in class java.lang.ref.Reference
Clears this reference object.
clear() - Method in class java.nio.Buffer
Clears this buffer.
clear() - Method in class java.security.Provider
Clears this provider so that it no longer contains the properties used to look up facilities implemented by the provider.
clear() - Method in class java.util.AbstractCollection
Removes all of the elements from this collection (optional operation).
clear() - Method in class java.util.AbstractList
Removes all of the elements from this list (optional operation).
clear() - Method in class java.util.AbstractMap
Removes all of the mappings from this map (optional operation).
clear() - Method in class java.util.AbstractQueue
Removes all of the elements from this queue.
clear() - Method in class java.util.ArrayDeque
Removes all of the elements from this deque.
clear() - Method in class java.util.ArrayList
Removes all of the elements from this list.
clear(int) - Method in class java.util.BitSet
Sets the bit specified by the index to false.
clear(int, int) - Method in class java.util.BitSet
Sets the bits from the specified fromIndex (inclusive) to the specified toIndex (exclusive) to false.
clear() - Method in class java.util.BitSet
Sets all of the bits in this BitSet to false.
clear() - Method in class java.util.Calendar
Sets all the calendar field values and the time value (millisecond offset from the Epoch) of this Calendar undefined.
clear(int) - Method in class java.util.Calendar
Sets the given calendar field value and the time value (millisecond offset from the Epoch) of this Calendar undefined.
clear() - Method in interface java.util.Collection
Removes all of the elements from this collection (optional operation).
clear() - Method in class java.util.concurrent.ArrayBlockingQueue
Atomically removes all of the elements from this queue.
clear() - Method in class java.util.concurrent.ConcurrentHashMap
Removes all of the mappings from this map.
clear() - Method in class java.util.concurrent.ConcurrentLinkedDeque
Removes all of the elements from this deque.
clear() - Method in class java.util.concurrent.ConcurrentSkipListMap
Removes all of the mappings from this map.
clear() - Method in class java.util.concurrent.ConcurrentSkipListSet
Removes all of the elements from this set.
clear() - Method in class java.util.concurrent.CopyOnWriteArrayList
Removes all of the elements from this list.
clear() - Method in class java.util.concurrent.CopyOnWriteArraySet
Removes all of the elements from this set.
clear() - Method in class java.util.concurrent.DelayQueue
Atomically removes all of the elements from this delay queue.
clear() - Method in class java.util.concurrent.LinkedBlockingDeque
Atomically removes all of the elements from this deque.
clear() - Method in class java.util.concurrent.LinkedBlockingQueue
Atomically removes all of the elements from this queue.
clear() - Method in class java.util.concurrent.PriorityBlockingQueue
Atomically removes all of the elements from this queue.
clear() - Method in class java.util.concurrent.SynchronousQueue
Does nothing.
clear() - Method in class java.util.EnumMap
Removes all mappings from this map.
clear() - Method in class java.util.HashMap
Removes all of the mappings from this map.
clear() - Method in class java.util.HashSet
Removes all of the elements from this set.
clear() - Method in class java.util.Hashtable
Clears this hashtable so that it contains no keys.
clear() - Method in class java.util.IdentityHashMap
Removes all of the mappings from this map.
clear() - Method in class java.util.jar.Attributes
Removes all attributes from this Map.
clear() - Method in class java.util.jar.Manifest
Clears the main Attributes as well as the entries in this Manifest.
clear() - Method in class java.util.LinkedHashMap
Removes all of the mappings from this map.
clear() - Method in class java.util.LinkedList
Removes all of the elements from this list.
clear() - Method in interface java.util.List
Removes all of the elements from this list (optional operation).
clear() - Method in class java.util.Locale.Builder
Resets the builder to its initial, empty state.
clear() - Method in interface java.util.Map
Removes all of the mappings from this map (optional operation).
clear() - Method in class java.util.prefs.AbstractPreferences
Implements the clear method as per the specification in Preferences.clear().
clear() - Method in class java.util.prefs.Preferences
Removes all of the preferences (key-value associations) in this preference node.
clear() - Method in class java.util.PriorityQueue
Removes all of the elements from this priority queue.
clear() - Method in interface java.util.Set
Removes all of the elements from this set (optional operation).
clear() - Method in class java.util.TreeMap
Removes all of the mappings from this map.
clear() - Method in class java.util.TreeSet
Removes all of the elements from this set.
clear() - Method in class java.util.Vector
Removes all of the elements from this Vector.
clear() - Method in class java.util.WeakHashMap
Removes all of the mappings from this map.
clear() - Method in class javax.accessibility.AccessibleRelationSet
Removes all the relations from the current relation set.
clear() - Method in class javax.accessibility.AccessibleStateSet
Removes all the states from the current state set.
clear() - Method in interface javax.management.openmbean.TabularData
Removes all CompositeData values (ie rows) from this TabularData instance.
clear() - Method in class javax.management.openmbean.TabularDataSupport
Removes all rows from this TabularDataSupport instance.
clear() - Method in interface javax.naming.directory.Attribute
Removes all values from this attribute.
clear() - Method in class javax.naming.directory.BasicAttribute
clear() - Method in class javax.naming.Reference
Deletes all addresses from this reference.
clear() - Method in interface javax.print.attribute.AttributeSet
Removes all attributes from this attribute set.
clear() - Method in class javax.print.attribute.HashAttributeSet
Removes all attributes from this attribute set.
clear() - Method in class javax.script.SimpleBindings
Removes all of the mappings from this map (optional operation).
clear() - Method in class javax.swing.ActionMap
Removes all the mappings from this ActionMap.
clear() - Method in class javax.swing.ComponentInputMap
Removes all the mappings from this object.
clear() - Method in class javax.swing.DefaultListModel
Removes all of the elements from this list.
clear() - Method in class javax.swing.InputMap
Removes all the mappings from this InputMap.
CLEAR - Static variable in class javax.swing.text.html.CSS.Attribute
CLEAR - Static variable in class javax.swing.text.html.HTML.Attribute
clear() - Method in class javax.xml.datatype.XMLGregorianCalendar
Unset all fields to undefined.
clear() - Method in class org.omg.CORBA.Environment
Clears this Environment object of its exception.
clear() - Method in class org.xml.sax.helpers.AttributeListImpl
Deprecated.
Clear the attribute list.
clear() - Method in class org.xml.sax.helpers.AttributesImpl
Clear the attribute list for reuse.
clearAbortRequest() - Method in class javax.imageio.ImageReader
Clears any previous abort request.
clearAbortRequest() - Method in class javax.imageio.ImageWriter
Clears any previous abort request.
clearAccessibleSelection() - Method in class java.awt.List.AccessibleAWTList
Clears the selection in the object, so that nothing in the object is selected.
clearAccessibleSelection() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent
Clears the selection in the object, so that no children in the object are selected.
clearAccessibleSelection() - Method in interface javax.accessibility.AccessibleSelection
Clears the selection in the object, so that no children in the object are selected.
clearAccessibleSelection() - Method in class javax.swing.JComboBox.AccessibleJComboBox
Clears the selection in the object, so that no children in the object are selected.
clearAccessibleSelection() - Method in class javax.swing.JList.AccessibleJList
Clears the selection in the object, so that nothing in the object is selected.
clearAccessibleSelection() - Method in class javax.swing.JMenu.AccessibleJMenu
Clears the selection in the object, so that nothing in the object is selected.
clearAccessibleSelection() - Method in class javax.swing.JMenuBar.AccessibleJMenuBar
Clears the selection in the object, so that nothing in the object is selected.
clearAccessibleSelection() - Method in class javax.swing.JTabbedPane.AccessibleJTabbedPane
clearAccessibleSelection() - Method in class javax.swing.JTable.AccessibleJTable
Clears the selection in the object, so that no children in the object are selected.
clearAccessibleSelection() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode
Clears the selection in the object, so that nothing in the object is selected.
clearAccessibleSelection() - Method in class javax.swing.JTree.AccessibleJTree
Clears the selection in the object, so that nothing in the object is selected.
clearAssertionStatus() - Method in class java.lang.ClassLoader
Sets the default assertion status for this class loader to false and discards any package defaults or class assertion status settings associated with the class loader.
clearAutoscroll() - Method in class java.awt.dnd.DropTarget
clear autoscrolling
clearBatch() - Method in interface java.sql.Statement
Empties this Statement object's current list of SQL commands.
clearBit(int) - Method in class java.math.BigInteger
Returns a BigInteger whose value is equivalent to this BigInteger with the designated bit cleared.
clearCache() - Static method in class java.util.ResourceBundle
Removes all resource bundles from the cache that have been loaded using the caller's class loader.
clearCache(ClassLoader) - Static method in class java.util.ResourceBundle
Removes all resource bundles from the cache that have been loaded using the given class loader.
clearChanged() - Method in class java.util.Observable
Indicates that this object has no longer changed, or that it has already notified all of its observers of its most recent change, so that the hasChanged method will now return false.
clearContent() - Method in class javax.xml.soap.AttachmentPart
Clears out the content of this AttachmentPart object.
clearError() - Method in class java.io.PrintStream
Clears the internal error state of this stream.
clearError() - Method in class java.io.PrintWriter
Clears the error state of this stream.
clearExtensions() - Method in class java.util.Locale.Builder
Resets the extensions to their initial, empty state.
clearFocusOwner() - Method in class java.awt.KeyboardFocusManager
Clears the focus owner at both the Java and native levels if the focus owner exists and resides in the same context as the calling thread, otherwise the method returns silently.
clearGlobalFocusOwner() - Method in class java.awt.KeyboardFocusManager
Clears the global focus owner at both the Java and native levels.
clearIconCache() - Method in class javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView
clearIconCache() - Method in class javax.swing.plaf.basic.BasicFileChooserUI
clearParameters() - Method in interface java.sql.PreparedStatement
Clears the current parameter values immediately.
clearParameters() - Method in class javax.sql.rowset.BaseRowSet
Clears all of the current parameter values in this RowSet object's internal representation of the parameters to be set in this RowSet object's command when it is executed.
clearParameters() - Method in interface javax.sql.RowSet
Clears the parameters set for this RowSet object's command.
clearParameters() - Method in class javax.xml.transform.Transformer
Clear all parameters set with setParameter.
clearPassword() - Method in class javax.crypto.spec.PBEKeySpec
Clears the internal copy of the password.
clearPassword() - Method in class javax.security.auth.callback.PasswordCallback
Clear the retrieved password.
clearProperty(String) - Static method in class java.lang.System
Removes the system property indicated by the specified key.
clearRect(int, int, int, int) - Method in class java.awt.Graphics
Clears the specified rectangle by filling it with the background color of the current drawing surface.
clearRect(int, int, int, int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.clearRect.
clearSelectedPath() - Method in class javax.swing.MenuSelectionManager
Tell the menu selection to close and unselect all the menu components.
clearSelection() - Method in class javax.swing.ButtonGroup
Clears the selection such that none of the buttons in the ButtonGroup are selected.
clearSelection() - Method in class javax.swing.DefaultListSelectionModel
Change the selection to the empty set.
clearSelection() - Method in class javax.swing.DefaultSingleSelectionModel
clearSelection() - Method in class javax.swing.JList
Clears the selection; after calling this method, isSelectionEmpty will return true.
clearSelection() - Method in class javax.swing.JTable
Deselects all selected columns and rows.
clearSelection() - Method in class javax.swing.JTree
Clears the selection.
clearSelection() - Method in interface javax.swing.ListSelectionModel
Change the selection to the empty set.
clearSelection() - Method in interface javax.swing.SingleSelectionModel
Clears the selection (to -1).
clearSelection() - Method in class javax.swing.tree.DefaultTreeSelectionModel
Empties the current selection.
clearSelection() - Method in interface javax.swing.tree.TreeSelectionModel
Empties the current selection.
clearTextShiftOffset() - Method in class javax.swing.plaf.basic.BasicButtonUI
clearToggledPaths() - Method in class javax.swing.JTree
Clears the cache of toggled tree paths.
clearWarnings() - Method in interface java.sql.Connection
Clears all warnings reported for this Connection object.
clearWarnings() - Method in interface java.sql.ResultSet
Clears all warnings reported on this ResultSet object.
clearWarnings() - Method in interface java.sql.Statement
Clears all the warnings reported on this Statement object.
CLICK - Static variable in interface javax.accessibility.AccessibleAction
An action which causes a component to execute its default action.
clickCount - Variable in class java.awt.Event
For MOUSE_DOWN events, this field indicates the number of consecutive clicks.
clickCountToStart - Variable in class javax.swing.DefaultCellEditor
An integer specifying the number of clicks needed to start editing.
clientClosed(RMIConnection) - Method in class javax.management.remote.rmi.RMIServerImpl
Method called when a client connection created by makeClient is closed.
ClientInfoStatus - Enum in java.sql
Enumeration for status of the reason that a property could not be set via a call to Connection.setClientInfo
ClientRequestInfo - Interface in org.omg.PortableInterceptor
Request Information, accessible to client-side request interceptors.
ClientRequestInfoOperations - Interface in org.omg.PortableInterceptor
Request Information, accessible to client-side request interceptors.
ClientRequestInterceptor - Interface in org.omg.PortableInterceptor
Client-side request interceptor.
ClientRequestInterceptorOperations - Interface in org.omg.PortableInterceptor
Client-side request interceptor.
clip(Shape) - Method in class java.awt.Graphics2D
Intersects the current Clip with the interior of the specified Shape and sets the Clip to the resulting intersection.
Clip - Interface in javax.sound.sampled
The Clip interface represents a special kind of data line whose audio data can be loaded prior to playback, instead of being streamed in real time.
Clipboard - Class in java.awt.datatransfer
A class that implements a mechanism to transfer data using cut/copy/paste operations.
Clipboard(String) - Constructor for class java.awt.datatransfer.Clipboard
Creates a clipboard object.
ClipboardOwner - Interface in java.awt.datatransfer
Defines the interface for classes that will provide data to a clipboard.
clipRect(int, int, int, int) - Method in class java.awt.Graphics
Intersects the current clip with the specified rectangle.
clipRect(int, int, int, int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.clipRect.
Clob - Interface in java.sql
The mapping in the Java™ programming language for the SQL CLOB type.
CLOB - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type CLOB.
Clock - Class in java.time
A clock providing access to the current instant, date and time using a time-zone.
Clock() - Constructor for class java.time.Clock
Constructor accessible by subclasses.
clockSequence() - Method in class java.util.UUID
The clock sequence value associated with this UUID.
clone() - Method in class java.awt.BufferCapabilities
clone() - Method in class java.awt.datatransfer.DataFlavor
Returns a clone of this DataFlavor.
clone() - Method in class java.awt.font.TextLayout
Creates a copy of this TextLayout.
clone() - Method in class java.awt.font.TextMeasurer
clone() - Method in class java.awt.geom.AffineTransform
Returns a copy of this AffineTransform object.
clone() - Method in class java.awt.geom.Area
Returns an exact copy of this Area object.
clone() - Method in class java.awt.geom.CubicCurve2D
Creates a new object of the same class as this object.
clone() - Method in class java.awt.geom.Dimension2D
Creates a new object of the same class as this object.
clone() - Method in class java.awt.geom.Line2D
Creates a new object of the same class as this object.
clone() - Method in class java.awt.geom.Path2D
Creates a new object of the same class as this object.
clone() - Method in class java.awt.geom.Path2D.Double
Creates a new object of the same class as this object.
clone() - Method in class java.awt.geom.Path2D.Float
Creates a new object of the same class as this object.
clone() - Method in class java.awt.geom.Point2D
Creates a new object of the same class and with the same contents as this object.
clone() - Method in class java.awt.geom.QuadCurve2D
Creates a new object of the same class and with the same contents as this object.
clone() - Method in class java.awt.geom.RectangularShape
Creates a new object of the same class and with the same contents as this object.
clone() - Method in class java.awt.GridBagConstraints
Creates a copy of this grid bag constraint.
clone() - Method in class java.awt.image.ImageFilter
Clones this object.
clone() - Method in class java.awt.image.Kernel
Clones this object.
clone() - Method in class java.awt.image.renderable.ParameterBlock
Creates a copy of a ParameterBlock.
clone() - Method in class java.awt.image.renderable.RenderContext
Makes a copy of a RenderContext.
clone() - Method in class java.awt.ImageCapabilities
clone() - Method in class java.awt.Insets
Create a copy of this object.
clone() - Method in class java.awt.JobAttributes
Creates and returns a copy of this JobAttributes.
clone() - Method in class java.awt.PageAttributes
Creates and returns a copy of this PageAttributes.
clone() - Method in class java.awt.print.PageFormat
Makes a copy of this PageFormat with the same contents as this PageFormat.
clone() - Method in class java.awt.print.Paper
Creates a copy of this Paper with the same contents as this Paper.
clone() - Method in class java.awt.RenderingHints
Creates a clone of this RenderingHints object that has the same contents as this RenderingHints object.
clone() - Method in class java.lang.Enum
Throws CloneNotSupportedException.
clone() - Method in class java.lang.Object
Creates and returns a copy of this object.
clone() - Method in class java.lang.Thread
Throws CloneNotSupportedException as a Thread can not be meaningfully cloned.
clone() - Method in class java.net.HttpCookie
Create and return a copy of this object.
clone() - Method in class java.rmi.server.UnicastRemoteObject
Returns a clone of the remote object that is distinct from the original.
clone() - Method in interface java.security.acl.AclEntry
Clones this ACL entry.
clone() - Method in interface java.security.cert.CertPathBuilderResult
Makes a copy of this CertPathBuilderResult.
clone() - Method in interface java.security.cert.CertPathParameters
Makes a copy of this CertPathParameters.
clone() - Method in interface java.security.cert.CertPathValidatorResult
Makes a copy of this CertPathValidatorResult.
clone() - Method in interface java.security.cert.CertSelector
Makes a copy of this CertSelector.
clone() - Method in interface java.security.cert.CertStoreParameters
Makes a copy of this CertStoreParameters.
clone() - Method in class java.security.cert.CollectionCertStoreParameters
Returns a copy of this object.
clone() - Method in interface java.security.cert.CRLSelector
Makes a copy of this CRLSelector.
clone() - Method in class java.security.cert.LDAPCertStoreParameters
Returns a copy of this object.
clone() - Method in class java.security.cert.PKIXCertPathChecker
Returns a clone of this object.
clone() - Method in class java.security.cert.PKIXCertPathValidatorResult
Returns a copy of this object.
clone() - Method in class java.security.cert.PKIXParameters
Makes a copy of this PKIXParameters object.
clone() - Method in class java.security.cert.PKIXRevocationChecker
clone() - Method in class java.security.cert.X509CertSelector
Returns a copy of this object.
clone() - Method in class java.security.cert.X509CRLSelector
Returns a copy of this object.
clone() - Method in class java.security.MessageDigest
Returns a clone if the implementation is cloneable.
clone() - Method in class java.security.MessageDigestSpi
Returns a clone if the implementation is cloneable.
clone() - Method in class java.security.Signature
Returns a clone if the implementation is cloneable.
clone() - Method in class java.security.SignatureSpi
Returns a clone if the implementation is cloneable.
clone() - Method in class java.text.BreakIterator
Create a copy of this iterator
clone() - Method in interface java.text.CharacterIterator
Create a copy of this iterator
clone() - Method in class java.text.ChoiceFormat
Overrides Cloneable
clone() - Method in class java.text.Collator
Overrides Cloneable
clone() - Method in class java.text.DateFormat
Overrides Cloneable
clone() - Method in class java.text.DateFormatSymbols
Overrides Cloneable
clone() - Method in class java.text.DecimalFormat
Standard override; no change in semantics.
clone() - Method in class java.text.DecimalFormatSymbols
Standard override.
clone() - Method in class java.text.Format
Creates and returns a copy of this object.
clone() - Method in class java.text.MessageFormat
Creates and returns a copy of this object.
clone() - Method in class java.text.NumberFormat
Overrides Cloneable.
clone() - Method in class java.text.RuleBasedCollator
Standard override; no change in semantics.
clone() - Method in class java.text.SimpleDateFormat
Creates a copy of this SimpleDateFormat.
clone() - Method in class java.text.StringCharacterIterator
Creates a copy of this iterator.
clone() - Method in class java.util.AbstractMap
Returns a shallow copy of this AbstractMap instance: the keys and values themselves are not cloned.
clone() - Method in class java.util.ArrayDeque
Returns a copy of this deque.
clone() - Method in class java.util.ArrayList
Returns a shallow copy of this ArrayList instance.
clone() - Method in class java.util.BitSet
Cloning this BitSet produces a new BitSet that is equal to it.
clone() - Method in class java.util.Calendar
Creates and returns a copy of this object.
clone() - Method in class java.util.concurrent.ConcurrentSkipListMap
Returns a shallow copy of this ConcurrentSkipListMap instance.
clone() - Method in class java.util.concurrent.ConcurrentSkipListSet
Returns a shallow copy of this ConcurrentSkipListSet instance.
clone() - Method in class java.util.concurrent.CopyOnWriteArrayList
Returns a shallow copy of this list.
clone() - Method in class java.util.Date
Return a copy of this object.
clone() - Method in class java.util.EnumMap
Returns a shallow copy of this enum map.
clone() - Method in class java.util.EnumSet
Returns a copy of this set.
clone() - Method in class java.util.GregorianCalendar
clone() - Method in class java.util.HashMap
Returns a shallow copy of this HashMap instance: the keys and values themselves are not cloned.
clone() - Method in class java.util.HashSet
Returns a shallow copy of this HashSet instance: the elements themselves are not cloned.
clone() - Method in class java.util.Hashtable
Creates a shallow copy of this hashtable.
clone() - Method in class java.util.IdentityHashMap
Returns a shallow copy of this identity hash map: the keys and values themselves are not cloned.
clone() - Method in class java.util.jar.Attributes
Returns a copy of the Attributes, implemented as follows:
clone() - Method in class java.util.jar.Manifest
Returns a shallow copy of this Manifest.
clone() - Method in class java.util.LinkedList
Returns a shallow copy of this LinkedList.
clone() - Method in class java.util.Locale
Overrides Cloneable.
clone() - Method in class java.util.SimpleTimeZone
Returns a clone of this SimpleTimeZone instance.
clone() - Method in class java.util.TimeZone
Creates a copy of this TimeZone.
clone() - Method in class java.util.TreeMap
Returns a shallow copy of this TreeMap instance.
clone() - Method in class java.util.TreeSet
Returns a shallow copy of this TreeSet instance.
clone() - Method in class java.util.Vector
Returns a clone of this vector.
clone() - Method in class java.util.zip.ZipEntry
Returns a copy of this entry.
clone() - Method in class javax.crypto.Mac
Returns a clone if the provider implementation is cloneable.
clone() - Method in class javax.crypto.MacSpi
Returns a clone if the implementation is cloneable.
clone() - Method in interface javax.management.Descriptor
Returns a descriptor which is equal to this descriptor.
clone() - Method in class javax.management.ImmutableDescriptor
Returns a descriptor which is equal to this descriptor.
clone() - Method in class javax.management.MBeanAttributeInfo
Returns a shallow clone of this instance.
clone() - Method in class javax.management.MBeanConstructorInfo
Returns a shallow clone of this instance.
clone() - Method in class javax.management.MBeanInfo
Returns a shallow clone of this instance.
clone() - Method in class javax.management.MBeanNotificationInfo
Returns a shallow clone of this instance.
clone() - Method in class javax.management.MBeanOperationInfo
Returns a shallow clone of this instance.
clone() - Method in class javax.management.MBeanParameterInfo
Returns a shallow clone of this instance.
clone() - Method in class javax.management.modelmbean.DescriptorSupport
Returns a new Descriptor which is a duplicate of the Descriptor.
clone() - Method in class javax.management.modelmbean.ModelMBeanAttributeInfo
Creates and returns a new ModelMBeanAttributeInfo which is a duplicate of this ModelMBeanAttributeInfo.
clone() - Method in class javax.management.modelmbean.ModelMBeanConstructorInfo
Creates and returns a new ModelMBeanConstructorInfo which is a duplicate of this ModelMBeanConstructorInfo.
clone() - Method in interface javax.management.modelmbean.ModelMBeanInfo
Creates and returns a copy of this object.
clone() - Method in class javax.management.modelmbean.ModelMBeanInfoSupport
Returns a shallow clone of this instance.
clone() - Method in class javax.management.modelmbean.ModelMBeanNotificationInfo
Creates and returns a new ModelMBeanNotificationInfo which is a duplicate of this ModelMBeanNotificationInfo.
clone() - Method in class javax.management.modelmbean.ModelMBeanOperationInfo
Creates and returns a new ModelMBeanOperationInfo which is a duplicate of this ModelMBeanOperationInfo.
clone() - Method in class javax.management.openmbean.TabularDataSupport
Returns a clone of this TabularDataSupport instance: the clone is obtained by calling super.clone(), and then cloning the underlying map.
clone() - Method in class javax.management.relation.Role
Clone the role object.
clone() - Method in class javax.management.relation.RoleUnresolved
Clone this object.
clone() - Method in class javax.naming.CompositeName
Generates a copy of this composite name.
clone() - Method in class javax.naming.CompoundName
Creates a copy of this compound name.
clone() - Method in interface javax.naming.directory.Attribute
Makes a copy of the attribute.
clone() - Method in interface javax.naming.directory.Attributes
Makes a copy of the attribute set.
clone() - Method in class javax.naming.directory.BasicAttribute
clone() - Method in class javax.naming.directory.BasicAttributes
clone() - Method in class javax.naming.ldap.LdapName
Generates a new copy of this name.
clone() - Method in interface javax.naming.Name
Generates a new copy of this name.
clone() - Method in class javax.naming.Reference
Makes a copy of this reference using its class name list of addresses, class factory name and class factory location.
clone() - Method in class javax.print.attribute.EnumSyntax
Returns a clone of this enumeration value, which to preserve the semantics of enumeration values is the same object as this enumeration value.
clone() - Method in class javax.sound.midi.MetaMessage
Creates a new object of the same class and with the same contents as this object.
clone() - Method in class javax.sound.midi.MidiMessage
Creates a new object of the same class and with the same contents as this object.
clone() - Method in class javax.sound.midi.ShortMessage
Creates a new object of the same class and with the same contents as this object.
clone() - Method in class javax.sound.midi.SysexMessage
Creates a new object of the same class and with the same contents as this object.
clone() - Method in class javax.sql.rowset.serial.SerialArray
Returns a clone of this SerialArray.
clone() - Method in class javax.sql.rowset.serial.SerialBlob
Returns a clone of this SerialBlob.
clone() - Method in class javax.sql.rowset.serial.SerialClob
Returns a clone of this SerialClob.
clone() - Method in class javax.sql.rowset.serial.SerialDatalink
Returns a clone of this SerialDatalink.
clone() - Method in class javax.sql.rowset.serial.SerialJavaObject
Returns a clone of this SerialJavaObject.
clone() - Method in class javax.sql.rowset.serial.SerialRef
Returns a clone of this SerialRef.
clone() - Method in class javax.sql.rowset.serial.SerialStruct
Returns a clone of this SerialStruct.
clone() - Method in class javax.swing.AbstractAction
Clones the abstract action.
clone() - Method in class javax.swing.DefaultListSelectionModel
Returns a clone of this selection model with the same selection.
clone() - Method in class javax.swing.JFormattedTextField.AbstractFormatter
Clones the AbstractFormatter.
clone() - Method in class javax.swing.text.DefaultFormatter
Creates a copy of the DefaultFormatter.
clone(Element, Element) - Method in class javax.swing.text.DefaultStyledDocument.ElementBuffer
Creates a copy of this element, with a different parent.
clone() - Method in class javax.swing.text.EditorKit
Creates a copy of the editor kit.
clone() - Method in class javax.swing.text.ElementIterator
Clones the ElementIterator.
clone() - Method in class javax.swing.text.GlyphView
Creates a shallow copy.
clone() - Method in class javax.swing.text.html.HTMLEditorKit
Creates a copy of the editor kit.
clone() - Method in class javax.swing.text.InternationalFormatter
Creates a copy of the DefaultFormatter.
clone() - Method in class javax.swing.text.Segment
Creates a shallow copy.
clone() - Method in class javax.swing.text.SimpleAttributeSet
Clones a set of attributes.
clone() - Method in class javax.swing.text.StyleContext.SmallAttributeSet
Clones a set of attributes.
clone() - Method in class javax.swing.text.StyledEditorKit
Creates a copy of the editor kit.
clone() - Method in class javax.swing.tree.DefaultMutableTreeNode
Overridden to make clone public.
clone() - Method in class javax.swing.tree.DefaultTreeSelectionModel
Returns a clone of this object with the same selection.
clone() - Method in class javax.xml.datatype.XMLGregorianCalendar
Creates and returns a copy of this object.
Cloneable - Interface in java.lang
A class implements the Cloneable interface to indicate to the Object.clone() method that it is legal for that method to make a field-for-field copy of instances of that class.
cloneNode(boolean) - Method in class javax.imageio.metadata.IIOMetadataNode
Returns a duplicate of this node.
cloneNode(boolean) - Method in interface org.w3c.dom.Node
Returns a duplicate of this node, i.e., serves as a generic copy constructor for nodes.
CloneNotSupportedException - Exception in java.lang
Thrown to indicate that the clone method in class Object has been called to clone an object, but that the object's class does not implement the Cloneable interface.
CloneNotSupportedException() - Constructor for exception java.lang.CloneNotSupportedException
Constructs a CloneNotSupportedException with no detail message.
CloneNotSupportedException(String) - Constructor for exception java.lang.CloneNotSupportedException
Constructs a CloneNotSupportedException with the specified detail message.
cloneWithSource(Object) - Method in class javax.swing.event.TreeSelectionEvent
Returns a copy of the receiver, but with the source being newSource.
closable - Variable in class javax.swing.JInternalFrame
The frame can be closed.
close() - Method in class java.awt.SplashScreen
Hides the splash screen, closes the window, and releases all associated resources.
close() - Method in class java.beans.XMLDecoder
This method closes the input stream associated with this stream.
close() - Method in class java.beans.XMLEncoder
This method calls flush, writes the closing postamble and then closes the output stream associated with this stream.
close() - Method in class java.io.BufferedInputStream
Closes this input stream and releases any system resources associated with the stream.
close() - Method in class java.io.BufferedReader
close() - Method in class java.io.BufferedWriter
close() - Method in class java.io.ByteArrayInputStream
Closing a ByteArrayInputStream has no effect.
close() - Method in class java.io.ByteArrayOutputStream
Closing a ByteArrayOutputStream has no effect.
close() - Method in class java.io.CharArrayReader
Closes the stream and releases any system resources associated with it.
close() - Method in class java.io.CharArrayWriter
Close the stream.
close() - Method in interface java.io.Closeable
Closes this stream and releases any system resources associated with it.
close() - Method in class java.io.FileInputStream
Closes this file input stream and releases any system resources associated with the stream.
close() - Method in class java.io.FileOutputStream
Closes this file output stream and releases any system resources associated with this stream.
close() - Method in class java.io.FilterInputStream
Closes this input stream and releases any system resources associated with the stream.
close() - Method in class java.io.FilterOutputStream
Closes this output stream and releases any system resources associated with the stream.
close() - Method in class java.io.FilterReader
close() - Method in class java.io.FilterWriter
close() - Method in class java.io.InputStream
Closes this input stream and releases any system resources associated with the stream.
close() - Method in class java.io.InputStreamReader
close() - Method in interface java.io.ObjectInput
Closes the input stream.
close() - Method in class java.io.ObjectInputStream
Closes the input stream.
close() - Method in interface java.io.ObjectOutput
Closes the stream.
close() - Method in class java.io.ObjectOutputStream
Closes the stream.
close() - Method in class java.io.OutputStream
Closes this output stream and releases any system resources associated with this stream.
close() - Method in class java.io.OutputStreamWriter
close() - Method in class java.io.PipedInputStream
Closes this piped input stream and releases any system resources associated with the stream.
close() - Method in class java.io.PipedOutputStream
Closes this piped output stream and releases any system resources associated with this stream.
close() - Method in class java.io.PipedReader
Closes this piped stream and releases any system resources associated with the stream.
close() - Method in class java.io.PipedWriter
Closes this piped output stream and releases any system resources associated with this stream.
close() - Method in class java.io.PrintStream
Closes the stream.
close() - Method in class java.io.PrintWriter
Closes the stream and releases any system resources associated with it.
close() - Method in class java.io.PushbackInputStream
Closes this input stream and releases any system resources associated with the stream.
close() - Method in class java.io.PushbackReader
Closes the stream and releases any system resources associated with it.
close() - Method in class java.io.RandomAccessFile
Closes this random access file stream and releases any system resources associated with the stream.
close() - Method in class java.io.Reader
Closes the stream and releases any system resources associated with it.
close() - Method in class java.io.SequenceInputStream
Closes this input stream and releases any system resources associated with the stream.
close() - Method in class java.io.StringReader
Closes the stream and releases any system resources associated with it.
close() - Method in class java.io.StringWriter
Closing a StringWriter has no effect.
close() - Method in class java.io.Writer
Closes the stream, flushing it first.
close() - Method in interface java.lang.AutoCloseable
Closes this resource, relinquishing any underlying resources.
close() - Method in class java.net.DatagramSocket
Closes this datagram socket.
close() - Method in class java.net.DatagramSocketImpl
Close the socket.
close() - Method in class java.net.ServerSocket
Closes this socket.
close() - Method in class java.net.Socket
Closes this socket.
close() - Method in class java.net.SocketImpl
Closes this socket.
close() - Method in class java.net.URLClassLoader
Closes this URLClassLoader, so that it can no longer be used to load new classes or resources that are defined by this loader.
close() - Method in interface java.nio.channels.AsynchronousChannel
Closes this channel.
close() - Method in interface java.nio.channels.Channel
Closes this channel.
close() - Method in class java.nio.channels.FileLock
This method invokes the FileLock.release() method.
close() - Method in interface java.nio.channels.InterruptibleChannel
Closes this channel.
close() - Method in interface java.nio.channels.MulticastChannel
Closes this channel.
close() - Method in class java.nio.channels.Selector
Closes this selector.
close() - Method in class java.nio.channels.spi.AbstractInterruptibleChannel
Closes this channel.
close() - Method in class java.nio.channels.spi.AbstractSelector
Closes this selector.
close() - Method in class java.nio.file.FileSystem
Closes this file system.
close() - Method in interface java.nio.file.WatchService
Closes this watch service.
close() - Method in interface java.sql.Connection
Releases this Connection object's database and JDBC resources immediately instead of waiting for them to be automatically released.
close() - Method in interface java.sql.ResultSet
Releases this ResultSet object's database and JDBC resources immediately instead of waiting for this to happen when it is automatically closed.
close() - Method in interface java.sql.Statement
Releases this Statement object's database and JDBC resources immediately instead of waiting for this to happen when it is automatically closed.
close() - Method in class java.util.Formatter
Closes this formatter.
close() - Method in class java.util.logging.ConsoleHandler
Override StreamHandler.close to do a flush but not to close the output stream.
close() - Method in class java.util.logging.FileHandler
Close all the files.
close() - Method in class java.util.logging.Handler
Close the Handler and free all associated resources.
close() - Method in class java.util.logging.MemoryHandler
Close the Handler and free all associated resources.
close() - Method in class java.util.logging.SocketHandler
Close this output stream.
close() - Method in class java.util.logging.StreamHandler
Close the current output stream.
close() - Method in class java.util.Scanner
Closes this scanner.
close() - Method in interface java.util.stream.BaseStream
Closes this stream, causing all close handlers for this stream pipeline to be called.
close() - Method in class java.util.zip.DeflaterInputStream
Closes this input stream and its underlying input stream, discarding any pending uncompressed data.
close() - Method in class java.util.zip.DeflaterOutputStream
Writes remaining compressed data to the output stream and closes the underlying stream.
close() - Method in class java.util.zip.GZIPInputStream
Closes this input stream and releases any system resources associated with the stream.
close() - Method in class java.util.zip.InflaterInputStream
Closes this input stream and releases any system resources associated with the stream.
close() - Method in class java.util.zip.InflaterOutputStream
Writes any remaining uncompressed data to the output stream and closes the underlying output stream.
close() - Method in class java.util.zip.ZipFile
Closes the ZIP file.
close() - Method in class java.util.zip.ZipInputStream
Closes this input stream and releases any system resources associated with the stream.
close() - Method in class java.util.zip.ZipOutputStream
Closes the ZIP output stream as well as the stream being filtered.
close() - Method in class javax.crypto.CipherInputStream
Closes this input stream and releases any system resources associated with the stream.
close() - Method in class javax.crypto.CipherOutputStream
Closes this output stream and releases any system resources associated with this stream.
close() - Method in class javax.imageio.stream.FileCacheImageInputStream
Closes this FileCacheImageInputStream, closing and removing the cache file.
close() - Method in class javax.imageio.stream.FileCacheImageOutputStream
Closes this FileCacheImageOutputStream.
close() - Method in class javax.imageio.stream.FileImageInputStream
close() - Method in class javax.imageio.stream.FileImageOutputStream
close() - Method in interface javax.imageio.stream.ImageInputStream
Closes the stream.
close() - Method in class javax.imageio.stream.ImageInputStreamImpl
close() - Method in class javax.imageio.stream.MemoryCacheImageInputStream
Closes this MemoryCacheImageInputStream, freeing the cache.
close() - Method in class javax.imageio.stream.MemoryCacheImageOutputStream
Closes this MemoryCacheImageOutputStream.
close() - Method in interface javax.management.remote.JMXConnector
Closes the client connection to its server.
close() - Method in interface javax.management.remote.rmi.RMIConnection
Closes this connection.
close() - Method in class javax.management.remote.rmi.RMIConnectionImpl
close() - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub
close() - Method in class javax.management.remote.rmi.RMIConnector
close() - Method in class javax.management.remote.rmi.RMIServerImpl
Closes this connection server.
close() - Method in interface javax.naming.Context
Closes this context.
close() - Method in class javax.naming.InitialContext
close() - Method in class javax.naming.ldap.StartTlsResponse
Closes the TLS connection gracefully and reverts back to the underlying connection.
close() - Method in interface javax.naming.NamingEnumeration
Closes this enumeration.
close() - Method in interface javax.sound.midi.MidiDevice
Closes the device, indicating that the device should now release any system resources it is using.
close() - Method in interface javax.sound.midi.Receiver
Indicates that the application has finished using the receiver, and that limited resources it requires may be released or made available.
close() - Method in interface javax.sound.midi.Transmitter
Indicates that the application has finished using the transmitter, and that limited resources it requires may be released or made available.
close() - Method in class javax.sound.sampled.AudioInputStream
Closes this audio input stream and releases any system resources associated with the stream.
close() - Method in interface javax.sound.sampled.Line
Closes the line, indicating that any system resources in use by the line can be released.
CLOSE - Static variable in class javax.sound.sampled.LineEvent.Type
A type of event that is sent when a line closes, freeing the system resources it had obtained when it was opened.
close() - Method in interface javax.sql.PooledConnection
Closes the physical connection that this PooledConnection object represents.
close() - Method in class javax.swing.ProgressMonitor
Indicate that the operation is complete.
close() - Method in class javax.swing.ProgressMonitorInputStream
Overrides FilterInputStream.close to close the progress monitor as well as the stream.
close() - Method in class javax.tools.ForwardingJavaFileManager
close() - Method in interface javax.tools.JavaFileManager
Releases any resources opened by this file manager directly or indirectly.
close() - Method in class javax.xml.soap.SOAPConnection
Closes this SOAPConnection object.
close() - Method in class javax.xml.stream.util.EventReaderDelegate
close() - Method in class javax.xml.stream.util.StreamReaderDelegate
close() - Method in interface javax.xml.stream.XMLEventReader
Frees any resources associated with this Reader.
close() - Method in interface javax.xml.stream.XMLEventWriter
Frees any resources associated with this stream
close() - Method in interface javax.xml.stream.XMLStreamReader
Frees any resources associated with this Reader.
close() - Method in interface javax.xml.stream.XMLStreamWriter
Close this writer and free any resources associated with the writer.
close(MessageContext) - Method in interface javax.xml.ws.handler.Handler
Called at the conclusion of a message exchange pattern just prior to the JAX-WS runtime dispatching a message, fault or exception.
close() - Method in class javax.xml.ws.spi.http.HttpExchange
This must be called to end an exchange.
CLOSE_ALL_RESULTS - Static variable in interface java.sql.Statement
The constant indicating that all ResultSet objects that have previously been kept open should be closed when calling getMoreResults.
CLOSE_CMD - Static variable in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
CLOSE_CURRENT_RESULT - Static variable in interface java.sql.Statement
The constant indicating that the current ResultSet object should be closed when calling getMoreResults.
CLOSE_CURSORS_AT_COMMIT - Static variable in interface java.sql.ResultSet
The constant indicating that open ResultSet objects with this holdability will be closed when the current transaction is committed.
CLOSE_FAILURE - Static variable in class java.util.logging.ErrorManager
CLOSE_FAILURE is used when a close of an output stream fails.
Closeable - Interface in java.io
A Closeable is a source or destination of data that can be closed.
CloseAction() - Constructor for class javax.swing.plaf.basic.BasicDesktopPaneUI.CloseAction
closeAction - Variable in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
CloseAction() - Constructor for class javax.swing.plaf.basic.BasicInternalFrameTitlePane.CloseAction
closeButton - Variable in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
closeClient(RMIConnection) - Method in class javax.management.remote.rmi.RMIIIOPServerImpl
closeClient(RMIConnection) - Method in class javax.management.remote.rmi.RMIJRMPServerImpl
closeClient(RMIConnection) - Method in class javax.management.remote.rmi.RMIServerImpl
Closes a client connection made by makeClient.
CLOSED - Static variable in class javax.management.remote.JMXConnectionNotification
Notification type string for a connection-closed notification.
CLOSED_OPTION - Static variable in class javax.swing.JOptionPane
Return value from class method if user closes window without selecting anything, more than likely this should be treated as either a CANCEL_OPTION or NO_OPTION.
ClosedByInterruptException - Exception in java.nio.channels
Checked exception received by a thread when another thread interrupts it while it is blocked in an I/O operation upon a channel.
ClosedByInterruptException() - Constructor for exception java.nio.channels.ClosedByInterruptException
Constructs an instance of this class.
ClosedChannelException - Exception in java.nio.channels
Checked exception thrown when an attempt is made to invoke or complete an I/O operation upon channel that is closed, or at least closed to that operation.
ClosedChannelException() - Constructor for exception java.nio.channels.ClosedChannelException
Constructs an instance of this class.
ClosedDirectoryStreamException - Exception in java.nio.file
Unchecked exception thrown when an attempt is made to invoke an operation on a directory stream that is closed.
ClosedDirectoryStreamException() - Constructor for exception java.nio.file.ClosedDirectoryStreamException
Constructs an instance of this class.
ClosedFileSystemException - Exception in java.nio.file
Unchecked exception thrown when an attempt is made to invoke an operation on a file and the file system is closed.
ClosedFileSystemException() - Constructor for exception java.nio.file.ClosedFileSystemException
Constructs an instance of this class.
closedIcon - Variable in class javax.swing.tree.DefaultTreeCellRenderer
Icon used to show non-leaf nodes that aren't expanded.
ClosedSelectorException - Exception in java.nio.channels
Unchecked exception thrown when an attempt is made to invoke an I/O operation upon a closed selector.
ClosedSelectorException() - Constructor for exception java.nio.channels.ClosedSelectorException
Constructs an instance of this class.
ClosedWatchServiceException - Exception in java.nio.file
Unchecked exception thrown when an attempt is made to invoke an operation on a watch service that is closed.
ClosedWatchServiceException() - Constructor for exception java.nio.file.ClosedWatchServiceException
Constructs an instance of this class.
closeEntry() - Method in class java.util.zip.ZipInputStream
Closes the current ZIP entry and positions the stream for reading the next entry.
closeEntry() - Method in class java.util.zip.ZipOutputStream
Closes the current ZIP entry and positions the stream for writing the next entry.
closeFrame(JInternalFrame) - Method in class javax.swing.DefaultDesktopManager
Removes the frame, and, if necessary, the desktopIcon, from its parent.
closeFrame(JInternalFrame) - Method in interface javax.swing.DesktopManager
Generally, this call should remove the frame from it's parent.
closeFrame(JInternalFrame) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
This method is called when the user wants to close the frame.
closeIcon - Variable in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
closeInbound() - Method in class javax.net.ssl.SSLEngine
Signals that no more inbound network data will be sent to this SSLEngine.
closeKey - Variable in class javax.swing.plaf.basic.BasicDesktopPaneUI
Deprecated.
As of 1.3.
closeOnCompletion() - Method in interface java.sql.Statement
Specifies that this Statement will be closed when all its dependent result sets are closed.
closeOutbound() - Method in class javax.net.ssl.SSLEngine
Signals that no more outbound application data will be sent on this SSLEngine.
closeOutUnwantedEmbeddedTags(AttributeSet) - Method in class javax.swing.text.html.HTMLWriter
Searches the attribute set and for each tag that is stored in the tag vector.
closePath() - Method in class java.awt.geom.Path2D
Closes the current subpath by drawing a straight line back to the coordinates of the last moveTo.
closeServer() - Method in class javax.management.remote.rmi.RMIIIOPServerImpl
Called by RMIServerImpl.close() to close the connector server by unexporting this object.
closeServer() - Method in class javax.management.remote.rmi.RMIJRMPServerImpl
Called by RMIServerImpl.close() to close the connector server by unexporting this object.
closeServer() - Method in class javax.management.remote.rmi.RMIServerImpl
Called by RMIServerImpl.close() to close the connector server.
CMMException - Exception in java.awt.color
This exception is thrown if the native CMM returns an error.
CMMException(String) - Constructor for exception java.awt.color.CMMException
Constructs a CMMException with the specified detail message.
coalesceEvents(AWTEvent, AWTEvent) - Method in class java.awt.Component
Potentially coalesce an event being posted with an existing event.
CODE - Static variable in class javax.swing.text.html.HTML.Attribute
CODE - Static variable in class javax.swing.text.html.HTML.Tag
code - Variable in exception org.w3c.dom.DOMException
code - Variable in exception org.w3c.dom.events.EventException
code - Variable in exception org.w3c.dom.ls.LSException
CODE_ATTRIBUTE_PFX - Static variable in interface java.util.jar.Pack200.Packer
When concatenated with a code attribute name, indicates the format of that attribute.
CODEBASE - Static variable in class javax.swing.text.html.HTML.Attribute
Codec - Interface in org.omg.IOP
The formats of IOR components and service context data used by ORB services are often defined as CDR encapsulations encoding instances of IDL defined data types.
codec_factory() - Method in interface org.omg.PortableInterceptor.ORBInitInfoOperations
Returns the IOP.CodecFactory.
CodecFactory - Interface in org.omg.IOP
Codecs are obtained from the CodecFactory.
CodecFactoryHelper - Class in org.omg.IOP
Codecs are obtained from the CodecFactory.
CodecFactoryHelper() - Constructor for class org.omg.IOP.CodecFactoryHelper
CodecFactoryOperations - Interface in org.omg.IOP
Codecs are obtained from the CodecFactory.
CodecOperations - Interface in org.omg.IOP
The formats of IOR components and service context data used by ORB services are often defined as CDR encapsulations encoding instances of IDL defined data types.
codePointAt(CharSequence, int) - Static method in class java.lang.Character
Returns the code point at the given index of the CharSequence.
codePointAt(char[], int) - Static method in class java.lang.Character
Returns the code point at the given index of the char array.
codePointAt(char[], int, int) - Static method in class java.lang.Character
Returns the code point at the given index of the char array, where only array elements with index less than limit can be used.
codePointAt(int) - Method in class java.lang.String
Returns the character (Unicode code point) at the specified index.
codePointAt(int) - Method in class java.lang.StringBuffer
codePointBefore(CharSequence, int) - Static method in class java.lang.Character
Returns the code point preceding the given index of the CharSequence.
codePointBefore(char[], int) - Static method in class java.lang.Character
Returns the code point preceding the given index of the char array.
codePointBefore(char[], int, int) - Static method in class java.lang.Character
Returns the code point preceding the given index of the char array, where only array elements with index greater than or equal to start can be used.
codePointBefore(int) - Method in class java.lang.String
Returns the character (Unicode code point) before the specified index.
codePointBefore(int) - Method in class java.lang.StringBuffer
codePointCount(CharSequence, int, int) - Static method in class java.lang.Character
Returns the number of Unicode code points in the text range of the specified char sequence.
codePointCount(char[], int, int) - Static method in class java.lang.Character
Returns the number of Unicode code points in a subarray of the char array argument.
codePointCount(int, int) - Method in class java.lang.String
Returns the number of Unicode code points in the specified text range of this String.
codePointCount(int, int) - Method in class java.lang.StringBuffer
codePoints() - Method in interface java.lang.CharSequence
Returns a stream of code point values from this sequence.
CoderMalfunctionError - Error in java.nio.charset
Error thrown when the decodeLoop method of a CharsetDecoder, or the encodeLoop method of a CharsetEncoder, throws an unexpected exception.
CoderMalfunctionError(Exception) - Constructor for error java.nio.charset.CoderMalfunctionError
Initializes an instance of this class.
CoderResult - Class in java.nio.charset
A description of the result state of a coder.
CODESET_INCOMPATIBLE - Exception in org.omg.CORBA
This exception is raised whenever meaningful communication is not possible between client and server native code sets.
CODESET_INCOMPATIBLE() - Constructor for exception org.omg.CORBA.CODESET_INCOMPATIBLE
Constructs an CODESET_INCOMPATIBLE exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.
CODESET_INCOMPATIBLE(String) - Constructor for exception org.omg.CORBA.CODESET_INCOMPATIBLE
Constructs an CODESET_INCOMPATIBLE exception with the specified message.
CODESET_INCOMPATIBLE(int, CompletionStatus) - Constructor for exception org.omg.CORBA.CODESET_INCOMPATIBLE
Constructs an CODESET_INCOMPATIBLE exception with the specified minor code and completion status.
CODESET_INCOMPATIBLE(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.CODESET_INCOMPATIBLE
Constructs an CODESET_INCOMPATIBLE exception with the specified message, minor code, and completion status.
CodeSets - Interface in org.omg.IOP
org/omg/IOP/CodeSets.java .
CodeSigner - Class in java.security
This class encapsulates information about a code signer.
CodeSigner(CertPath, Timestamp) - Constructor for class java.security.CodeSigner
Constructs a CodeSigner object.
CodeSource - Class in java.security
This class extends the concept of a codebase to encapsulate not only the location (URL) but also the certificate chains that were used to verify signed code originating from that location.
CodeSource(URL, Certificate[]) - Constructor for class java.security.CodeSource
Constructs a CodeSource and associates it with the specified location and set of certificates.
CodeSource(URL, CodeSigner[]) - Constructor for class java.security.CodeSource
Constructs a CodeSource and associates it with the specified location and set of code signers.
CODETYPE - Static variable in class javax.swing.text.html.HTML.Attribute
CodingErrorAction - Class in java.nio.charset
A typesafe enumeration for coding-error actions.
coerceData(boolean) - Method in class java.awt.image.BufferedImage
Forces the data to match the state specified in the isAlphaPremultiplied variable.
coerceData(WritableRaster, boolean) - Method in class java.awt.image.ColorModel
Forces the raster data to match the state specified in the isAlphaPremultiplied variable, assuming the data is currently correctly described by this ColorModel.
coerceData(WritableRaster, boolean) - Method in class java.awt.image.ComponentColorModel
Forces the raster data to match the state specified in the isAlphaPremultiplied variable, assuming the data is currently correctly described by this ColorModel.
coerceData(WritableRaster, boolean) - Method in class java.awt.image.DirectColorModel
Forces the raster data to match the state specified in the isAlphaPremultiplied variable, assuming the data is currently correctly described by this ColorModel.
colHead - Variable in class javax.swing.ScrollPaneLayout
The column header child.
COLLAPSED - Static variable in class javax.accessibility.AccessibleState
Indicates this object is collapsed.
collapsedIcon - Variable in class javax.swing.plaf.basic.BasicTreeUI
CollapsedStringAdapter - Class in javax.xml.bind.annotation.adapters
Built-in XmlAdapter to handle xs:token and its derived types.
CollapsedStringAdapter() - Constructor for class javax.xml.bind.annotation.adapters.CollapsedStringAdapter
collapsePath(TreePath) - Method in class javax.swing.JTree
Ensures that the node identified by the specified path is collapsed and viewable.
collapseRow(int) - Method in class javax.swing.JTree
Ensures that the node in the specified row is collapsed.
COLLATED - Static variable in class javax.print.attribute.standard.SheetCollate
Sheets within a document appear in collated order when multiple copies are printed.
CollationElementIterator - Class in java.text
The CollationElementIterator class is used as an iterator to walk through each character of an international string.
CollationKey - Class in java.text
A CollationKey represents a String under the rules of a specific Collator object.
CollationKey(String) - Constructor for class java.text.CollationKey
CollationKey constructor.
Collator - Class in java.text
The Collator class performs locale-sensitive String comparison.
Collator() - Constructor for class java.text.Collator
Default constructor.
CollatorProvider - Class in java.text.spi
An abstract class for service providers that provide concrete implementations of the Collator class.
CollatorProvider() - Constructor for class java.text.spi.CollatorProvider
Sole constructor.
collect(Supplier<R>, ObjDoubleConsumer<R>, BiConsumer<R, R>) - Method in interface java.util.stream.DoubleStream
Performs a mutable reduction operation on the elements of this stream.
collect(Supplier<R>, ObjIntConsumer<R>, BiConsumer<R, R>) - Method in interface java.util.stream.IntStream
Performs a mutable reduction operation on the elements of this stream.
collect(Supplier<R>, ObjLongConsumer<R>, BiConsumer<R, R>) - Method in interface java.util.stream.LongStream
Performs a mutable reduction operation on the elements of this stream.
collect(Supplier<R>, BiConsumer<R, ? super T>, BiConsumer<R, R>) - Method in interface java.util.stream.Stream
Performs a mutable reduction operation on the elements of this stream.
collect(Collector<? super T, A, R>) - Method in interface java.util.stream.Stream
Performs a mutable reduction operation on the elements of this stream using a Collector.
collectArguments(MethodHandle, int, MethodHandle) - Static method in class java.lang.invoke.MethodHandles
Adapts a target method handle by pre-processing a sub-sequence of its arguments with a filter (another method handle).
collectingAndThen(Collector<T, A, R>, Function<R, RR>) - Static method in class java.util.stream.Collectors
Adapts a Collector to perform an additional finishing transformation.
Collection<E> - Interface in java.util
The root interface in the collection hierarchy.
CollectionCertStoreParameters - Class in java.security.cert
Parameters used as input for the Collection CertStore algorithm.
CollectionCertStoreParameters(Collection<?>) - Constructor for class java.security.cert.CollectionCertStoreParameters
Creates an instance of CollectionCertStoreParameters which will allow certificates and CRLs to be retrieved from the specified Collection.
CollectionCertStoreParameters() - Constructor for class java.security.cert.CollectionCertStoreParameters
Creates an instance of CollectionCertStoreParameters with the default parameter values (an empty and immutable Collection).
Collections - Class in java.util
This class consists exclusively of static methods that operate on or return collections.
Collector<T,A,R> - Interface in java.util.stream
A mutable reduction operation that accumulates input elements into a mutable result container, optionally transforming the accumulated result into a final representation after all input elements have been processed.
Collector.Characteristics - Enum in java.util.stream
Characteristics indicating properties of a Collector, which can be used to optimize reduction implementations.
Collectors - Class in java.util.stream
Implementations of Collector that implement various useful reduction operations, such as accumulating elements into collections, summarizing elements according to various criteria, etc.
Color - Class in java.awt
The Color class is used to encapsulate colors in the default sRGB color space or colors in arbitrary color spaces identified by a ColorSpace.
Color(int, int, int) - Constructor for class java.awt.Color
Creates an opaque sRGB color with the specified red, green, and blue values in the range (0 - 255).
Color(int, int, int, int) - Constructor for class java.awt.Color
Creates an sRGB color with the specified red, green, blue, and alpha values in the range (0 - 255).
Color(int) - Constructor for class java.awt.Color
Creates an opaque sRGB color with the specified combined RGB value consisting of the red component in bits 16-23, the green component in bits 8-15, and the blue component in bits 0-7.
Color(int, boolean) - Constructor for class java.awt.Color
Creates an sRGB color with the specified combined RGBA value consisting of the alpha component in bits 24-31, the red component in bits 16-23, the green component in bits 8-15, and the blue component in bits 0-7.
Color(float, float, float) - Constructor for class java.awt.Color
Creates an opaque sRGB color with the specified red, green, and blue values in the range (0.0 - 1.0).
Color(float, float, float, float) - Constructor for class java.awt.Color
Creates an sRGB color with the specified red, green, blue, and alpha values in the range (0.0 - 1.0).
Color(ColorSpace, float[], float) - Constructor for class java.awt.Color
Creates a color in the specified ColorSpace with the color components specified in the float array and the specified alpha.
COLOR - Static variable in class java.awt.PageAttributes.ColorType
The ColorType instance to use for specifying color printing.
COLOR - Static variable in class javax.print.attribute.standard.Chromaticity
Color printing.
color - Variable in class javax.swing.border.MatteBorder
COLOR - Static variable in class javax.swing.text.html.CSS.Attribute
COLOR - Static variable in class javax.swing.text.html.HTML.Attribute
COLOR_ACTION - Static variable in class javax.swing.text.html.HTMLEditorKit
The Color choice action identifier The color is passed as an argument
COLOR_CHOOSER - Static variable in class javax.accessibility.AccessibleRole
A specialized pane that lets the user choose a color.
COLOR_CHOOSER - Static variable in class javax.swing.plaf.synth.Region
ColorChooser region.
COLOR_CHOOSER_DIALOG - Static variable in class javax.swing.JRootPane
Constant used for the windowDecorationStyle property.
ColorChooserComponentFactory - Class in javax.swing.colorchooser
A class designed to produce preconfigured "accessory" objects to insert into color choosers.
ColorChooserUI - Class in javax.swing.plaf
Pluggable look and feel interface for JColorChooser.
ColorChooserUI() - Constructor for class javax.swing.plaf.ColorChooserUI
ColorConvertOp - Class in java.awt.image
This class performs a pixel-by-pixel color conversion of the data in the source image.
ColorConvertOp(RenderingHints) - Constructor for class java.awt.image.ColorConvertOp
Constructs a new ColorConvertOp which will convert from a source color space to a destination color space.
ColorConvertOp(ColorSpace, RenderingHints) - Constructor for class java.awt.image.ColorConvertOp
Constructs a new ColorConvertOp from a ColorSpace object.
ColorConvertOp(ColorSpace, ColorSpace, RenderingHints) - Constructor for class java.awt.image.ColorConvertOp
Constructs a new ColorConvertOp from two ColorSpace objects.
ColorConvertOp(ICC_Profile[], RenderingHints) - Constructor for class java.awt.image.ColorConvertOp
Constructs a new ColorConvertOp from an array of ICC_Profiles.
ColorModel - Class in java.awt.image
The ColorModel abstract class encapsulates the methods for translating a pixel value to color components (for example, red, green, and blue) and an alpha component.
ColorModel(int) - Constructor for class java.awt.image.ColorModel
Constructs a ColorModel that translates pixels of the specified number of bits to color/alpha components.
ColorModel(int, int[], ColorSpace, boolean, boolean, int, int) - Constructor for class java.awt.image.ColorModel
Constructs a ColorModel that translates pixel values to color/alpha components.
colorModel - Variable in class javax.imageio.ImageTypeSpecifier
The ColorModel to be used as a prototype.
ColorSelectionModel - Interface in javax.swing.colorchooser
A model that supports selecting a Color.
ColorSpace - Class in java.awt.color
This abstract class is used to serve as a color space tag to identify the specific color space of a Color object or, via a ColorModel object, of an Image, a BufferedImage, or a GraphicsDevice.
ColorSpace(int, int) - Constructor for class java.awt.color.ColorSpace
Constructs a ColorSpace object given a color space type and the number of components.
ColorSupported - Class in javax.print.attribute.standard
Class ColorSupported is a printing attribute class, an enumeration, that identifies whether the device is capable of any type of color printing at all, including highlight color as well as full process color.
ColorSupported(int) - Constructor for class javax.print.attribute.standard.ColorSupported
Construct a new color supported enumeration value with the given integer value.
ColorType - Class in javax.swing.plaf.synth
A typesafe enumeration of colors that can be fetched from a style.
ColorType(String) - Constructor for class javax.swing.plaf.synth.ColorType
Creates a new ColorType with the specified description.
ColorUIResource - Class in javax.swing.plaf
ColorUIResource(int, int, int) - Constructor for class javax.swing.plaf.ColorUIResource
ColorUIResource(int) - Constructor for class javax.swing.plaf.ColorUIResource
ColorUIResource(float, float, float) - Constructor for class javax.swing.plaf.ColorUIResource
ColorUIResource(Color) - Constructor for class javax.swing.plaf.ColorUIResource
COLS - Static variable in class javax.swing.text.html.HTML.Attribute
COLSPAN - Static variable in class javax.swing.text.html.HTML.Attribute
column - Variable in class javax.swing.event.TableModelEvent
COLUMN_HEADER - Static variable in class javax.accessibility.AccessibleRole
The header for a column of data.
COLUMN_HEADER - Static variable in interface javax.swing.ScrollPaneConstants
Identifies the area at the top the viewport between the upper left corner and the upper right corner.
COLUMN_WIDTH_PROPERTY - Static variable in class javax.swing.table.TableColumn
Obsolete as of Java 2 platform v1.3.
columnAdded(TableColumnModelEvent) - Method in interface javax.swing.event.TableColumnModelListener
Tells listeners that a column was added to the model.
columnAdded(TableColumnModelEvent) - Method in class javax.swing.JTable.AccessibleJTable
Track changes to the table contents (column insertions)
columnAdded(TableColumnModelEvent) - Method in class javax.swing.JTable
Invoked when a column is added to the table column model.
columnAdded(TableColumnModelEvent) - Method in class javax.swing.table.JTableHeader
Invoked when a column is added to the table column model.
columnAtPoint(Point) - Method in class javax.swing.JTable
Returns the index of the column that point lies in, or -1 if the result is not in the range [0, getColumnCount()-1].
columnAtPoint(Point) - Method in class javax.swing.table.JTableHeader
Returns the index of the column that point lies in, or -1 if it lies out of bounds.
columnHeader - Variable in class javax.swing.JScrollPane
The column header child.
columnIdentifiers - Variable in class javax.swing.table.DefaultTableModel
The Vector of column identifiers.
columnMargin - Variable in class javax.swing.table.DefaultTableColumnModel
Width margin between each column
columnMarginChanged(ChangeEvent) - Method in interface javax.swing.event.TableColumnModelListener
Tells listeners that a column was moved due to a margin change.
columnMarginChanged(ChangeEvent) - Method in class javax.swing.JTable.AccessibleJTable
Track changes of a column moving due to margin changes.
columnMarginChanged(ChangeEvent) - Method in class javax.swing.JTable
Invoked when a column is moved due to a margin change.
columnMarginChanged(ChangeEvent) - Method in class javax.swing.table.JTableHeader
Invoked when a column is moved due to a margin change.
columnModel - Variable in class javax.swing.JTable
The TableColumnModel of the table.
columnModel - Variable in class javax.swing.table.JTableHeader
The TableColumnModel of the table header.
columnMoved(TableColumnModelEvent) - Method in interface javax.swing.event.TableColumnModelListener
Tells listeners that a column was repositioned.
columnMoved(TableColumnModelEvent) - Method in class javax.swing.JTable.AccessibleJTable
Track changes of a column repositioning.
columnMoved(TableColumnModelEvent) - Method in class javax.swing.JTable
Invoked when a column is repositioned.
columnMoved(TableColumnModelEvent) - Method in class javax.swing.table.JTableHeader
Invoked when a column is repositioned.
columnNoNulls - Static variable in interface java.sql.DatabaseMetaData
Indicates that the column might not allow NULL values.
columnNoNulls - Static variable in interface java.sql.ResultSetMetaData
The constant indicating that a column does not allow NULL values.
columnNullable - Static variable in interface java.sql.DatabaseMetaData
Indicates that the column definitely allows NULL values.
columnNullable - Static variable in interface java.sql.ResultSetMetaData
The constant indicating that a column allows NULL values.
columnNullableUnknown - Static variable in interface java.sql.DatabaseMetaData
Indicates that the nullability of columns is unknown.
columnNullableUnknown - Static variable in interface java.sql.ResultSetMetaData
The constant indicating that the nullability of a column's values is unknown.
columnRemoved(TableColumnModelEvent) - Method in interface javax.swing.event.TableColumnModelListener
Tells listeners that a column was removed from the model.
columnRemoved(TableColumnModelEvent) - Method in class javax.swing.JTable.AccessibleJTable
Track changes to the table contents (column deletions)
columnRemoved(TableColumnModelEvent) - Method in class javax.swing.JTable
Invoked when a column is removed from the table column model.
columnRemoved(TableColumnModelEvent) - Method in class javax.swing.table.JTableHeader
Invoked when a column is removed from the table column model.
columnSelectionAllowed - Variable in class javax.swing.table.DefaultTableColumnModel
Column selection allowed in this column model
columnSelectionChanged(ListSelectionEvent) - Method in interface javax.swing.event.TableColumnModelListener
Tells listeners that the selection model of the TableColumnModel changed.
columnSelectionChanged(ListSelectionEvent) - Method in class javax.swing.JTable.AccessibleJTable
Track that the selection model of the TableColumnModel changed.
columnSelectionChanged(ListSelectionEvent) - Method in class javax.swing.JTable
Invoked when the selection model of the TableColumnModel is changed.
columnSelectionChanged(ListSelectionEvent) - Method in class javax.swing.table.JTableHeader
Invoked when the selection model of the TableColumnModel is changed.
columnUpdated(int) - Method in interface javax.sql.rowset.CachedRowSet
Indicates whether the designated column in the current row of this CachedRowSet object has been updated.
columnUpdated(String) - Method in interface javax.sql.rowset.CachedRowSet
Indicates whether the designated column in the current row of this CachedRowSet object has been updated.
columnWeights - Variable in class java.awt.GridBagLayout
This field holds the overrides to the column weights.
columnWidths - Variable in class java.awt.GridBagLayout
This field holds the overrides to the column minimum width.
combine(ProtectionDomain[], ProtectionDomain[]) - Method in interface java.security.DomainCombiner
Modify or update the provided ProtectionDomains.
combine(DoubleSummaryStatistics) - Method in class java.util.DoubleSummaryStatistics
Combines the state of another DoubleSummaryStatistics into this one.
combine(IntSummaryStatistics) - Method in class java.util.IntSummaryStatistics
Combines the state of another IntSummaryStatistics into this one.
combine(LongSummaryStatistics) - Method in class java.util.LongSummaryStatistics
Combines the state of another LongSummaryStatistics into this one.
combine(ProtectionDomain[], ProtectionDomain[]) - Method in class javax.security.auth.SubjectDomainCombiner
Update the relevant ProtectionDomains with the Principals from the Subject associated with this SubjectDomainCombiner.
combiner() - Method in interface java.util.stream.Collector
A function that accepts two partial results and merges them.
COMBINING - Static variable in class java.awt.font.GlyphMetrics
Indicates a glyph that represents a combining character, such as an umlaut.
COMBINING_DIACRITICAL_MARKS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Combining Diacritical Marks" Unicode character block.
COMBINING_DIACRITICAL_MARKS_SUPPLEMENT - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Combining Diacritical Marks Supplement" Unicode character block.
COMBINING_HALF_MARKS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Combining Half Marks" Unicode character block.
COMBINING_MARKS_FOR_SYMBOLS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Combining Diacritical Marks for Symbols" Unicode character block.
COMBINING_SPACING_MARK - Static variable in class java.lang.Character
General category "Mc" in the Unicode specification.
COMBO_BOX - Static variable in class javax.accessibility.AccessibleRole
A list of choices the user can select from.
COMBO_BOX - Static variable in class javax.swing.plaf.synth.Region
ComboBox region.
comboBox - Variable in class javax.swing.plaf.basic.BasicComboBoxUI
comboBox - Variable in class javax.swing.plaf.basic.BasicComboPopup
comboBox - Variable in class javax.swing.plaf.metal.MetalComboBoxButton
ComboBoxEditor - Interface in javax.swing
The editor component used for JComboBox components.
ComboBoxLayoutManager() - Constructor for class javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager
ComboBoxModel<E> - Interface in javax.swing
A data model for a combo box.
ComboBoxUI - Class in javax.swing.plaf
Pluggable look and feel interface for JComboBox.
ComboBoxUI() - Constructor for class javax.swing.plaf.ComboBoxUI
comboIcon - Variable in class javax.swing.plaf.metal.MetalComboBoxButton
ComboPopup - Interface in javax.swing.plaf.basic
The interface which defines the methods required for the implementation of the popup portion of a combo box.
COMM_FAILURE - Exception in org.omg.CORBA
This exception is raised if communication is lost while an operation is in progress, after the request was sent by the client, but before the reply from the server has been returned to the client.
COMM_FAILURE() - Constructor for exception org.omg.CORBA.COMM_FAILURE
Constructs a COMM_FAILURE exception with a default minor code of 0 and a completion state of COMPLETED_NO.
COMM_FAILURE(String) - Constructor for exception org.omg.CORBA.COMM_FAILURE
Constructs a COMM_FAILURE exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
COMM_FAILURE(int, CompletionStatus) - Constructor for exception org.omg.CORBA.COMM_FAILURE
Constructs a COMM_FAILURE exception with the specified minor code and completion status.
COMM_FAILURE(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.COMM_FAILURE
Constructs a COMM_FAILURE exception with the specified detail message, minor code, and completion status.
command(Object) - Static method in class java.lang.Compiler
Examines the argument type and its fields and perform some documented operation.
command(List<String>) - Method in class java.lang.ProcessBuilder
Sets this process builder's operating system program and arguments.
command(String...) - Method in class java.lang.ProcessBuilder
Sets this process builder's operating system program and arguments.
command() - Method in class java.lang.ProcessBuilder
Returns this process builder's operating system program and arguments.
CommandEnvironment(String, String[]) - Constructor for class java.rmi.activation.ActivationGroupDesc.CommandEnvironment
Create a CommandEnvironment with all the necessary information.
CommandInfo - Class in javax.activation
The CommandInfo class is used by CommandMap implementations to describe the results of command requests.
CommandInfo(String, String) - Constructor for class javax.activation.CommandInfo
The Constructor for CommandInfo.
CommandMap - Class in javax.activation
The CommandMap class provides an interface to a registry of command objects available in the system.
CommandMap() - Constructor for class javax.activation.CommandMap
CommandObject - Interface in javax.activation
JavaBeans components that are Activation Framework aware implement this interface to find out which command verb they're being asked to perform, and to obtain the DataHandler representing the data they should operate on.
COMMENT - Static variable in class javax.swing.text.html.HTML.Attribute
COMMENT - Static variable in class javax.swing.text.html.HTML.Tag
All comments are labeled with this tag.
comment(Element) - Method in class javax.swing.text.html.HTMLWriter
Writes out comments.
Comment - Interface in javax.xml.stream.events
An interface for comment events
COMMENT - Static variable in interface javax.xml.stream.XMLStreamConstants
Indicates an event is a comment
Comment - Interface in org.w3c.dom
This interface inherits from CharacterData and represents the content of a comment, i.e., all the characters between the starting ' <!--' and ending '-->'.
comment(char[], int, int) - Method in class org.xml.sax.ext.DefaultHandler2
comment(char[], int, int) - Method in interface org.xml.sax.ext.LexicalHandler
Report an XML comment anywhere in the document.
COMMENT_NODE - Static variable in interface org.w3c.dom.Node
The node is a Comment.
commentChar(int) - Method in class java.io.StreamTokenizer
Specified that the character argument starts a single-line comment.
COMMENTS - Static variable in class java.util.regex.Pattern
Permits whitespace and comments in pattern.
commit() - Method in interface java.sql.Connection
Makes all changes made since the previous commit/rollback permanent and releases any database locks currently held by this Connection object.
commit() - Method in interface javax.security.auth.spi.LoginModule
Method to commit the authentication process (phase 2).
commit() - Method in interface javax.sql.rowset.CachedRowSet
Each CachedRowSet object's SyncProvider contains a Connection object from the ResultSet or JDBC properties passed to it's constructors.
commit() - Method in interface javax.sql.rowset.JdbcRowSet
Each JdbcRowSet contains a Connection object from the ResultSet or JDBC properties passed to it's constructors.
commit() - Method in interface javax.sql.rowset.spi.TransactionalWriter
Makes permanent all changes that have been performed by the acceptChanges method since the last call to either the commit or rollback methods.
COMMIT - Static variable in class javax.swing.JFormattedTextField
Constant identifying that when focus is lost, commitEdit should be invoked.
commit(Xid, boolean) - Method in interface javax.transaction.xa.XAResource
Commits the global transaction specified by xid.
COMMIT_ON_ACCEPT_CHANGES - Static variable in interface javax.sql.rowset.CachedRowSet
Deprecated.
Because this field is final (it is part of an interface), its value cannot be changed.
COMMIT_OR_REVERT - Static variable in class javax.swing.JFormattedTextField
Constant identifying that when focus is lost, commitEdit should be invoked.
commitEdit() - Method in class javax.swing.JFormattedTextField
Forces the current value to be taken from the AbstractFormatter and set as the current value.
commitEdit() - Method in class javax.swing.JSpinner
Commits the currently edited value to the SpinnerModel.
commitEdit() - Method in class javax.swing.JSpinner.DefaultEditor
Pushes the currently edited value to the SpinnerModel.
COMMON - Static variable in class java.awt.JobAttributes.DialogType
The DialogType instance to use for specifying the cross-platform, pure Java print dialog.
COMMON - Static variable in class javax.print.attribute.standard.DialogTypeSelection
COMMON_INDIC_NUMBER_FORMS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Common Indic Number Forms" Unicode character block.
CommonDataSource - Interface in javax.sql
Interface that defines the methods which are common between DataSource, XADataSource and ConnectionPoolDataSource.
commonPool() - Static method in class java.util.concurrent.ForkJoinPool
Returns the common pool instance.
CommunicationException - Exception in javax.naming
This exception is thrown when the client is unable to communicate with the directory or naming service.
CommunicationException(String) - Constructor for exception javax.naming.CommunicationException
Constructs a new instance of CommunicationException using the arguments supplied.
CommunicationException() - Constructor for exception javax.naming.CommunicationException
Constructs a new instance of CommunicationException.
compact() - Method in class java.nio.ByteBuffer
Compacts this buffer (optional operation).
compact() - Method in class java.nio.CharBuffer
Compacts this buffer (optional operation).
compact() - Method in class java.nio.DoubleBuffer
Compacts this buffer (optional operation).
compact() - Method in class java.nio.FloatBuffer
Compacts this buffer (optional operation).
compact() - Method in class java.nio.IntBuffer
Compacts this buffer (optional operation).
compact() - Method in class java.nio.LongBuffer
Compacts this buffer (optional operation).
compact() - Method in class java.nio.ShortBuffer
Compacts this buffer (optional operation).
COMPACT - Static variable in class javax.swing.text.html.HTML.Attribute
COMPACT_DISC - Static variable in class javax.sound.sampled.Port.Info
A type of port that gets audio from a CD-ROM drive.
Comparable<T> - Interface in java.lang
This interface imposes a total ordering on the objects of each class that implements it.
Comparator<T> - Interface in java.util
A comparison function, which imposes a total ordering on some collection of objects.
comparator() - Method in class java.util.concurrent.ConcurrentSkipListMap
comparator() - Method in class java.util.concurrent.ConcurrentSkipListSet
comparator() - Method in class java.util.concurrent.PriorityBlockingQueue
Returns the comparator used to order the elements in this queue, or null if this queue uses the natural ordering of its elements.
comparator() - Method in class java.util.PriorityQueue
Returns the comparator used to order the elements in this queue, or null if this queue is sorted according to the natural ordering of its elements.
comparator() - Method in interface java.util.SortedMap
Returns the comparator used to order the keys in this map, or null if this map uses the natural ordering of its keys.
comparator() - Method in interface java.util.SortedSet
Returns the comparator used to order the elements in this set, or null if this set uses the natural ordering of its elements.
comparator() - Method in class java.util.TreeMap
comparator() - Method in class java.util.TreeSet
compare(boolean, boolean) - Static method in class java.lang.Boolean
Compares two boolean values.
compare(byte, byte) - Static method in class java.lang.Byte
Compares two byte values numerically.
compare(char, char) - Static method in class java.lang.Character
Compares two char values numerically.
compare(double, double) - Static method in class java.lang.Double
Compares the two specified double values.
compare(float, float) - Static method in class java.lang.Float
Compares the two specified float values.
compare(int, int) - Static method in class java.lang.Integer
Compares two int values numerically.
compare(long, long) - Static method in class java.lang.Long
Compares two long values numerically.
compare(short, short) - Static method in class java.lang.Short
Compares two short values numerically.
compare(String, String) - Method in class java.text.Collator
Compares the source string to the target string according to the collation rules for this Collator.
compare(Object, Object) - Method in class java.text.Collator
Compares its two arguments for order.
compare(String, String) - Method in class java.text.RuleBasedCollator
Compares the character data stored in two different strings based on the collation rules.
compare(T, T) - Method in interface java.util.Comparator
Compares its two arguments for order.
compare(T, T, Comparator<? super T>) - Static method in class java.util.Objects
Returns 0 if the arguments are identical and c.compare(a, b) otherwise.
compare(Duration) - Method in class javax.xml.datatype.Duration
Partial order relation comparison with this Duration instance.
compare(XMLGregorianCalendar) - Method in class javax.xml.datatype.XMLGregorianCalendar
Compare two instances of W3C XML Schema 1.0 date/time datatypes according to partial order relation defined in W3C XML Schema 1.0 Part 2, Section 3.2.7.3, Order relation on dateTime.
compareAndSet(boolean, boolean) - Method in class java.util.concurrent.atomic.AtomicBoolean
Atomically sets the value to the given updated value if the current value == the expected value.
compareAndSet(int, int) - Method in class java.util.concurrent.atomic.AtomicInteger
Atomically sets the value to the given updated value if the current value == the expected value.
compareAndSet(int, int, int) - Method in class java.util.concurrent.atomic.AtomicIntegerArray
Atomically sets the element at position i to the given updated value if the current value == the expected value.
compareAndSet(T, int, int) - Method in class java.util.concurrent.atomic.AtomicIntegerFieldUpdater
Atomically sets the field of the given object managed by this updater to the given updated value if the current value == the expected value.
compareAndSet(long, long) - Method in class java.util.concurrent.atomic.AtomicLong
Atomically sets the value to the given updated value if the current value == the expected value.
compareAndSet(int, long, long) - Method in class java.util.concurrent.atomic.AtomicLongArray
Atomically sets the element at position i to the given updated value if the current value == the expected value.
compareAndSet(T, long, long) - Method in class java.util.concurrent.atomic.AtomicLongFieldUpdater
Atomically sets the field of the given object managed by this updater to the given updated value if the current value == the expected value.
compareAndSet(V, V, boolean, boolean) - Method in class java.util.concurrent.atomic.AtomicMarkableReference
Atomically sets the value of both the reference and mark to the given update values if the current reference is == to the expected reference and the current mark is equal to the expected mark.
compareAndSet(V, V) - Method in class java.util.concurrent.atomic.AtomicReference
Atomically sets the value to the given updated value if the current value == the expected value.
compareAndSet(int, E, E) - Method in class java.util.concurrent.atomic.AtomicReferenceArray
Atomically sets the element at position i to the given updated value if the current value == the expected value.
compareAndSet(T, V, V) - Method in class java.util.concurrent.atomic.AtomicReferenceFieldUpdater
Atomically sets the field of the given object managed by this updater to the given updated value if the current value == the expected value.
compareAndSet(V, V, int, int) - Method in class java.util.concurrent.atomic.AtomicStampedReference
Atomically sets the value of both the reference and stamp to the given update values if the current reference is == to the expected reference and the current stamp is equal to the expected stamp.
compareAndSetForkJoinTaskTag(short, short) - Method in class java.util.concurrent.ForkJoinTask
Atomically conditionally sets the tag value for this task.
compareAndSetPendingCount(int, int) - Method in class java.util.concurrent.CountedCompleter
Sets (atomically) the pending count to the given count only if it currently holds the given expected value.
compareAndSetState(long, long) - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer
Atomically sets synchronization state to the given updated value if the current state value equals the expected value.
compareAndSetState(int, int) - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer
Atomically sets synchronization state to the given updated value if the current state value equals the expected value.
compareDocumentPosition(Node) - Method in class javax.imageio.metadata.IIOMetadataNode
This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
compareDocumentPosition(Node) - Method in interface org.w3c.dom.Node
Compares the reference node, i.e.
compareTabOrder(Component, Component) - Method in class javax.swing.DefaultFocusManager
compareTo(File) - Method in class java.io.File
Compares two abstract pathnames lexicographically.
compareTo(Object) - Method in class java.io.ObjectStreamField
Compare this field with another ObjectStreamField.
compareTo(Boolean) - Method in class java.lang.Boolean
Compares this Boolean instance with another.
compareTo(Byte) - Method in class java.lang.Byte
Compares two Byte objects numerically.
compareTo(Character) - Method in class java.lang.Character
Compares two Character objects numerically.
compareTo(T) - Method in interface java.lang.Comparable
Compares this object with the specified object for order.
compareTo(Double) - Method in class java.lang.Double
Compares two Double objects numerically.
compareTo(E) - Method in class java.lang.Enum
Compares this enum with the specified object for order.
compareTo(Float) - Method in class java.lang.Float
Compares two Float objects numerically.
compareTo(Integer) - Method in class java.lang.Integer
Compares two Integer objects numerically.
compareTo(Long) - Method in class java.lang.Long
Compares two Long objects numerically.
compareTo(Short) - Method in class java.lang.Short
Compares two Short objects numerically.
compareTo(String) - Method in class java.lang.String
Compares two strings lexicographically.
compareTo(BigDecimal) - Method in class java.math.BigDecimal
Compares this BigDecimal with the specified BigDecimal.
compareTo(BigInteger) - Method in class java.math.BigInteger
Compares this BigInteger with the specified BigInteger.
compareTo(URI) - Method in class java.net.URI
Compares this URI to another object, which must be a URI.
compareTo(ByteBuffer) - Method in class java.nio.ByteBuffer
Compares this buffer to another.
compareTo(CharBuffer) - Method in class java.nio.CharBuffer
Compares this buffer to another.
compareTo(Charset) - Method in class java.nio.charset.Charset
Compares this charset to another.
compareTo(DoubleBuffer) - Method in class java.nio.DoubleBuffer
Compares this buffer to another.
compareTo(FileTime) - Method in class java.nio.file.attribute.FileTime
Compares the value of two FileTime objects for order.
compareTo(Path) - Method in interface java.nio.file.Path
Compares two abstract paths lexicographically.
compareTo(FloatBuffer) - Method in class java.nio.FloatBuffer
Compares this buffer to another.
compareTo(IntBuffer) - Method in class java.nio.IntBuffer
Compares this buffer to another.
compareTo(LongBuffer) - Method in class java.nio.LongBuffer
Compares this buffer to another.
compareTo(ShortBuffer) - Method in class java.nio.ShortBuffer
Compares this buffer to another.
compareTo(Timestamp) - Method in class java.sql.Timestamp
Compares this Timestamp object to the given Timestamp object.
compareTo(Date) - Method in class java.sql.Timestamp
Compares this Timestamp object to the given Date object.
compareTo(CollationKey) - Method in class java.text.CollationKey
Compare this CollationKey to the target CollationKey.
compareTo(Chronology) - Method in class java.time.chrono.AbstractChronology
Compares this chronology to another chronology.
compareTo(ChronoLocalDate) - Method in interface java.time.chrono.ChronoLocalDate
Compares this date to another date, including the chronology.
compareTo(ChronoLocalDateTime<?>) - Method in interface java.time.chrono.ChronoLocalDateTime
Compares this date-time to another date-time, including the chronology.
compareTo(Chronology) - Method in interface java.time.chrono.Chronology
Compares this chronology to another chronology.
compareTo(ChronoZonedDateTime<?>) - Method in interface java.time.chrono.ChronoZonedDateTime
Compares this date-time to another date-time, including the chronology.
compareTo(Duration) - Method in class java.time.Duration
Compares this duration to the specified Duration.
compareTo(Instant) - Method in class java.time.Instant
Compares this instant to the specified instant.
compareTo(ChronoLocalDate) - Method in class java.time.LocalDate
Compares this date to another date.
compareTo(ChronoLocalDateTime<?>) - Method in class java.time.LocalDateTime
Compares this date-time to another date-time.
compareTo(LocalTime) - Method in class java.time.LocalTime
Compares this LocalTime to another time.
compareTo(MonthDay) - Method in class java.time.MonthDay
Compares this month-day to another month-day.
compareTo(OffsetDateTime) - Method in class java.time.OffsetDateTime
Compares this OffsetDateTime to another date-time.
compareTo(OffsetTime) - Method in class java.time.OffsetTime
Compares this OffsetTime to another time.
compareTo(Year) - Method in class java.time.Year
Compares this year to another year.
compareTo(YearMonth) - Method in class java.time.YearMonth
Compares this year-month to another year-month.
compareTo(ZoneOffsetTransition) - Method in class java.time.zone.ZoneOffsetTransition
Compares this transition to another based on the transition instant.
compareTo(ZoneOffset) - Method in class java.time.ZoneOffset
Compares this offset to another offset in descending order.
compareTo(Calendar) - Method in class java.util.Calendar
Compares the time values (millisecond offsets from the Epoch) represented by two Calendar objects.
compareTo(Date) - Method in class java.util.Date
Compares two Dates for ordering.
compareTo(UUID) - Method in class java.util.UUID
Compares this UUID with the specified UUID.
compareTo(ObjectName) - Method in class javax.management.ObjectName
Compares two ObjectName instances.
compareTo(Object) - Method in class javax.naming.CompositeName
Compares this CompositeName with the specified Object for order.
compareTo(Object) - Method in class javax.naming.CompoundName
Compares this CompoundName with the specified Object for order.
compareTo(Object) - Method in class javax.naming.ldap.LdapName
Compares this LdapName with the specified Object for order.
compareTo(Object) - Method in class javax.naming.ldap.Rdn
Compares this Rdn with the specified Object for order.
compareTo(Object) - Method in interface javax.naming.Name
Compares this name with another name for order.
compareToIgnoreCase(String) - Method in class java.lang.String
Compares two strings lexicographically, ignoring case differences.
compareUnsigned(int, int) - Static method in class java.lang.Integer
Compares two int values numerically treating the values as unsigned.
compareUnsigned(long, long) - Static method in class java.lang.Long
Compares two long values numerically treating the values as unsigned.
comparing(Function<? super T, ? extends U>, Comparator<? super U>) - Static method in interface java.util.Comparator
Accepts a function that extracts a sort key from a type T, and returns a Comparator<T> that compares by that sort key using the specified Comparator.
comparing(Function<? super T, ? extends U>) - Static method in interface java.util.Comparator
Accepts a function that extracts a Comparable sort key from a type T, and returns a Comparator<T> that compares by that sort key.
comparingByKey() - Static method in interface java.util.Map.Entry
Returns a comparator that compares Map.Entry in natural order on key.
comparingByKey(Comparator<? super K>) - Static method in interface java.util.Map.Entry
Returns a comparator that compares Map.Entry by key using the given Comparator.
comparingByValue() - Static method in interface java.util.Map.Entry
Returns a comparator that compares Map.Entry in natural order on value.
comparingByValue(Comparator<? super V>) - Static method in interface java.util.Map.Entry
Returns a comparator that compares Map.Entry by value using the given Comparator.
comparingDouble(ToDoubleFunction<? super T>) - Static method in interface java.util.Comparator
Accepts a function that extracts a double sort key from a type T, and returns a Comparator<T> that compares by that sort key.
comparingInt(ToIntFunction<? super T>) - Static method in interface java.util.Comparator
Accepts a function that extracts an int sort key from a type T, and returns a Comparator<T> that compares by that sort key.
comparingLong(ToLongFunction<? super T>) - Static method in interface java.util.Comparator
Accepts a function that extracts a long sort key from a type T, and returns a Comparator<T> that compares by that sort key.
Compilable - Interface in javax.script
The optional interface implemented by ScriptEngines whose methods compile scripts to a form that can be executed repeatedly without recompilation.
COMPILATION_MXBEAN_NAME - Static variable in class java.lang.management.ManagementFactory
String representation of the ObjectName for the CompilationMXBean.
CompilationMXBean - Interface in java.lang.management
The management interface for the compilation system of the Java virtual machine.
compile(String) - Static method in class java.util.regex.Pattern
Compiles the given regular expression into a pattern.
compile(String, int) - Static method in class java.util.regex.Pattern
Compiles the given regular expression into a pattern with the given flags.
compile(String) - Method in interface javax.script.Compilable
Compiles the script (source represented as a String) for later execution.
compile(Reader) - Method in interface javax.script.Compilable
Compiles the script (source read from Reader) for later execution.
compile(String) - Method in interface javax.xml.xpath.XPath
Compile an XPath expression for later evaluation.
compileClass(Class<?>) - Static method in class java.lang.Compiler
Compiles the specified class.
compileClasses(String) - Static method in class java.lang.Compiler
Compiles all classes whose name matches the specified string.
CompiledScript - Class in javax.script
Extended by classes that store results of compilations.
CompiledScript() - Constructor for class javax.script.CompiledScript
Compiler - Class in java.lang
The Compiler class is provided to support Java-to-native-code compilers and related services.
complementOf(EnumSet<E>) - Static method in class java.util.EnumSet
Creates an enum set with the same element type as the specified enum set, initially containing all the elements of this type that are not contained in the specified set.
CompletableFuture<T> - Class in java.util.concurrent
A Future that may be explicitly completed (setting its value and status), and may be used as a CompletionStage, supporting dependent functions and actions that trigger upon its completion.
CompletableFuture() - Constructor for class java.util.concurrent.CompletableFuture
Creates a new incomplete CompletableFuture.
CompletableFuture.AsynchronousCompletionTask - Interface in java.util.concurrent
A marker interface identifying asynchronous tasks produced by async methods.
COMPLETE - Static variable in class java.awt.MediaTracker
Flag indicating that the downloading of media was completed successfully.
complete() - Method in class java.util.Calendar
Fills in any unset fields in the calendar fields.
complete(T) - Method in class java.util.concurrent.CompletableFuture
If not already completed, sets the value returned by CompletableFuture.get() and related methods to the given value.
complete(T) - Method in class java.util.concurrent.CountedCompleter
Regardless of pending count, invokes CountedCompleter.onCompletion(CountedCompleter), marks this task as complete and further triggers CountedCompleter.tryComplete() on this task's completer, if one exists.
complete(V) - Method in class java.util.concurrent.ForkJoinTask
Completes this task, and if not already aborted or cancelled, returning the given value as the result of subsequent invocations of join and related operations.
completed(V, A) - Method in interface java.nio.channels.CompletionHandler
Invoked when an operation has completed.
COMPLETED - Static variable in class javax.print.attribute.standard.JobState
The job has completed successfully or with warnings or errors after processing, all of the job media sheets have been successfully stacked in the appropriate output bin(s), and all job status attributes have reached their final values for the job.
completed - Variable in exception org.omg.CORBA.SystemException
The status of the operation that threw this exception.
COMPLETED_MAYBE - Static variable in class org.omg.CORBA.CompletionStatus
An instance of CompletionStatus initialized with the constant _COMPLETED_MAYBE.
COMPLETED_NO - Static variable in class org.omg.CORBA.CompletionStatus
An instance of CompletionStatus initialized with the constant _COMPLETED_NO.
COMPLETED_YES - Static variable in class org.omg.CORBA.CompletionStatus
An instance of CompletionStatus initialized with the constant _COMPLETED_YES.
completedFuture(U) - Static method in class java.util.concurrent.CompletableFuture
Returns a new CompletableFuture that is already completed with the given value.
completeDrag(int, int) - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider.DragController
completeDrag(MouseEvent) - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider.DragController
Messages finishDraggingTo with the new location for the mouse event.
completeEditing() - Method in class javax.swing.plaf.basic.BasicTreeUI
Messages to stop the editing session.
completeEditing(boolean, boolean, boolean) - Method in class javax.swing.plaf.basic.BasicTreeUI
Stops the editing session.
completeExceptionally(Throwable) - Method in class java.util.concurrent.CompletableFuture
If not already completed, causes invocations of CompletableFuture.get() and related methods to throw the given exception.
completeExceptionally(Throwable) - Method in class java.util.concurrent.ForkJoinTask
Completes this task abnormally, and if not already aborted or cancelled, causes it to throw the given exception upon join and related operations.
COMPLETESCANLINES - Static variable in interface java.awt.image.ImageConsumer
The pixels will be delivered in (multiples of) complete scanlines at a time.
completeUIInstall() - Method in class javax.swing.plaf.basic.BasicTreeUI
Invoked from installUI after all the defaults/listeners have been installed.
completeUIUninstall() - Method in class javax.swing.plaf.basic.BasicTreeUI
Completion - Interface in javax.annotation.processing
A suggested completion for an annotation.
CompletionException - Exception in java.util.concurrent
Exception thrown when an error or other exception is encountered in the course of completing a result or task.
CompletionException() - Constructor for exception java.util.concurrent.CompletionException
Constructs a CompletionException with no detail message.
CompletionException(String) - Constructor for exception java.util.concurrent.CompletionException
Constructs a CompletionException with the specified detail message.
CompletionException(String, Throwable) - Constructor for exception java.util.concurrent.CompletionException
Constructs a CompletionException with the specified detail message and cause.
CompletionException(Throwable) - Constructor for exception java.util.concurrent.CompletionException
Constructs a CompletionException with the specified cause.
CompletionHandler<V,A> - Interface in java.nio.channels
A handler for consuming the result of an asynchronous I/O operation.
Completions - Class in javax.annotation.processing
Utility class for assembling Completion objects.
CompletionService<V> - Interface in java.util.concurrent
A service that decouples the production of new asynchronous tasks from the consumption of the results of completed tasks.
CompletionStage<T> - Interface in java.util.concurrent
A stage of a possibly asynchronous computation, that performs an action or computes a value when another CompletionStage completes.
CompletionStatus - Class in org.omg.CORBA
An object that indicates whether a method had completed running when a SystemException was thrown.
CompletionStatusHelper - Class in org.omg.CORBA
The Helper for CompletionStatus.
CompletionStatusHelper() - Constructor for class org.omg.CORBA.CompletionStatusHelper
Component - Class in java.awt
A component is an object having a graphical representation that can be displayed on the screen and that can interact with the user.
Component() - Constructor for class java.awt.Component
Constructs a new component.
component - Variable in class java.awt.dnd.DragGestureRecognizer
The Component associated with this DragGestureRecognizer.
COMPONENT - Static variable in class java.awt.font.GlyphMetrics
Indicates a glyph with no corresponding character in the backing store.
component - Static variable in class javax.swing.ImageIcon
Deprecated.
since 1.8
Component.AccessibleAWTComponent - Class in java.awt
Inner class of Component used to provide default support for accessibility.
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler - Class in java.awt
Fire PropertyChange listener, if one is registered, when shown/hidden..
Component.AccessibleAWTComponent.AccessibleAWTFocusHandler - Class in java.awt
Fire PropertyChange listener, if one is registered, when focus events happen
Component.BaselineResizeBehavior - Enum in java.awt
Enumeration of the common ways the baseline of a component can change as the size changes.
Component.BltBufferStrategy - Class in java.awt
Inner class for blitting offscreen surfaces to a component.
Component.FlipBufferStrategy - Class in java.awt
Inner class for flipping buffers on a component.
COMPONENT_ADDED - Static variable in class java.awt.event.ContainerEvent
This event indicates that a component was added to the container.
component_count() - Method in class org.omg.DynamicAny._DynAnyStub
Returns the number of components of a DynAny.
component_count() - Method in class org.omg.DynamicAny._DynArrayStub
Returns the number of components of a DynAny.
component_count() - Method in class org.omg.DynamicAny._DynEnumStub
Returns the number of components of a DynAny.
component_count() - Method in class org.omg.DynamicAny._DynFixedStub
Returns the number of components of a DynAny.
component_count() - Method in class org.omg.DynamicAny._DynSequenceStub
Returns the number of components of a DynAny.
component_count() - Method in class org.omg.DynamicAny._DynStructStub
Returns the number of components of a DynAny.
component_count() - Method in class org.omg.DynamicAny._DynUnionStub
Returns the number of components of a DynAny.
component_count() - Method in class org.omg.DynamicAny._DynValueStub
Returns the number of components of a DynAny.
component_count() - Method in interface org.omg.DynamicAny.DynAnyOperations
Returns the number of components of a DynAny.
component_data - Variable in class org.omg.IOP.TaggedComponent
The component data associated with the component id.
COMPONENT_EVENT_MASK - Static variable in class java.awt.AWTEvent
The event mask for selecting component events.
COMPONENT_FIRST - Static variable in class java.awt.event.ComponentEvent
The first number in the range of ids used for component events.
COMPONENT_HIDDEN - Static variable in class java.awt.event.ComponentEvent
This event indicates that the component was rendered invisible.
COMPONENT_LAST - Static variable in class java.awt.event.ComponentEvent
The last number in the range of ids used for component events.
COMPONENT_MOVED - Static variable in class java.awt.event.ComponentEvent
This event indicates that the component's position changed.
COMPONENT_REMOVED - Static variable in class java.awt.event.ContainerEvent
This event indicates that a component was removed from the container.
COMPONENT_RESIZED - Static variable in class java.awt.event.ComponentEvent
This event indicates that the component's size changed.
COMPONENT_SHOWN - Static variable in class java.awt.event.ComponentEvent
This event indicates that the component was made visible.
ComponentAdapter - Class in java.awt.event
An abstract adapter class for receiving component events.
ComponentAdapter() - Constructor for class java.awt.event.ComponentAdapter
componentAdded(ContainerEvent) - Method in class java.awt.AWTEventMulticaster
Handles the componentAdded container event by invoking the componentAdded methods on listener-a and listener-b.
componentAdded(ContainerEvent) - Method in class java.awt.Container.AccessibleAWTContainer.AccessibleContainerHandler
componentAdded(ContainerEvent) - Method in class java.awt.event.ContainerAdapter
Invoked when a component has been added to the container.
componentAdded(ContainerEvent) - Method in interface java.awt.event.ContainerListener
Invoked when a component has been added to the container.
componentAdded(ContainerEvent) - Method in class javax.swing.JComponent.AccessibleJComponent.AccessibleContainerHandler
componentAdded(ContainerEvent) - Method in class javax.swing.plaf.basic.BasicToolBarUI.ToolBarContListener
ComponentAttribute - Static variable in class javax.swing.text.StyleConstants
Name of the component attribute.
ComponentColorModel - Class in java.awt.image
A ColorModel class that works with pixel values that represent color and alpha information as separate samples and that store each sample in a separate data element.
ComponentColorModel(ColorSpace, int[], boolean, boolean, int, int) - Constructor for class java.awt.image.ComponentColorModel
Constructs a ComponentColorModel from the specified parameters.
ComponentColorModel(ColorSpace, boolean, boolean, int, int) - Constructor for class java.awt.image.ComponentColorModel
Constructs a ComponentColorModel from the specified parameters.
ComponentElementName - Static variable in class javax.swing.text.StyleConstants
Name of elements used to represent components.
ComponentEvent - Class in java.awt.event
A low-level event which indicates that a component moved, changed size, or changed visibility (also, the root class for the other component-level events).
ComponentEvent(Component, int) - Constructor for class java.awt.event.ComponentEvent
Constructs a ComponentEvent object.
componentForPoint(Component, Point) - Method in class javax.swing.MenuSelectionManager
Returns the component in the currently selected path which contains sourcePoint.
ComponentHandler() - Constructor for class javax.swing.plaf.basic.BasicInternalFrameUI.ComponentHandler
ComponentHandler() - Constructor for class javax.swing.plaf.basic.BasicSliderUI.ComponentHandler
ComponentHandler() - Constructor for class javax.swing.plaf.basic.BasicTreeUI.ComponentHandler
componentHidden(ComponentEvent) - Method in class java.awt.AWTEventMulticaster
Handles the componentHidden event by invoking the componentHidden methods on listener-a and listener-b.
componentHidden(ComponentEvent) - Method in class java.awt.Component.AccessibleAWTComponent.AccessibleAWTComponentHandler
componentHidden(ComponentEvent) - Method in class java.awt.event.ComponentAdapter
Invoked when the component has been made invisible.
componentHidden(ComponentEvent) - Method in interface java.awt.event.ComponentListener
Invoked when the component has been made invisible.
componentHidden(ComponentEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.ComponentHandler
ComponentIdHelper - Class in org.omg.IOP
Standard way of representing multicomponent profiles.
ComponentIdHelper() - Constructor for class org.omg.IOP.ComponentIdHelper
ComponentInputMap - Class in javax.swing
A ComponentInputMap is an InputMap associated with a particular JComponent.
ComponentInputMap(JComponent) - Constructor for class javax.swing.ComponentInputMap
Creates a ComponentInputMap associated with the specified component.
ComponentInputMapUIResource - Class in javax.swing.plaf
A subclass of javax.swing.ComponentInputMap that implements UIResource.
ComponentInputMapUIResource(JComponent) - Constructor for class javax.swing.plaf.ComponentInputMapUIResource
ComponentListener - Interface in java.awt.event
The listener interface for receiving component events.
componentListener - Variable in class javax.swing.plaf.basic.BasicInternalFrameUI
componentListener - Variable in class javax.swing.plaf.basic.BasicSliderUI
componentMoved(ComponentEvent) - Method in class java.awt.AWTEventMulticaster
Handles the componentMoved event by invoking the componentMoved methods on listener-a and listener-b.
componentMoved(ComponentEvent) - Method in class java.awt.Component.AccessibleAWTComponent.AccessibleAWTComponentHandler
componentMoved(ComponentEvent) - Method in class java.awt.event.ComponentAdapter
Invoked when the component's position changes.
componentMoved(ComponentEvent) - Method in interface java.awt.event.ComponentListener
Invoked when the component's position changes.
componentMoved(ComponentEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.ComponentHandler
componentMoved(ComponentEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.ComponentHandler
ComponentOrientation - Class in java.awt
The ComponentOrientation class encapsulates the language-sensitive orientation that is to be used to order the elements of a component or of text.
componentRemoved(ContainerEvent) - Method in class java.awt.AWTEventMulticaster
Handles the componentRemoved container event by invoking the componentRemoved methods on listener-a and listener-b.
componentRemoved(ContainerEvent) - Method in class java.awt.Container.AccessibleAWTContainer.AccessibleContainerHandler
componentRemoved(ContainerEvent) - Method in class java.awt.event.ContainerAdapter
Invoked when a component has been removed from the container.
componentRemoved(ContainerEvent) - Method in interface java.awt.event.ContainerListener
Invoked when a component has been removed from the container.
componentRemoved(ContainerEvent) - Method in class javax.swing.JComponent.AccessibleJComponent.AccessibleContainerHandler
componentRemoved(ContainerEvent) - Method in class javax.swing.plaf.basic.BasicToolBarUI.ToolBarContListener
componentResized(ComponentEvent) - Method in class java.awt.AWTEventMulticaster
Handles the componentResized event by invoking the componentResized methods on listener-a and listener-b.
componentResized(ComponentEvent) - Method in class java.awt.Component.AccessibleAWTComponent.AccessibleAWTComponentHandler
componentResized(ComponentEvent) - Method in class java.awt.event.ComponentAdapter
Invoked when the component's size changes.
componentResized(ComponentEvent) - Method in interface java.awt.event.ComponentListener
Invoked when the component's size changes.
componentResized(ComponentEvent) - Method in class javax.swing.JViewport.ViewListener
componentResized(ComponentEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.ComponentHandler
Invoked when a JInternalFrame's parent's size changes.
componentResized(ComponentEvent) - Method in class javax.swing.plaf.basic.BasicSliderUI.ComponentHandler
components - Variable in class javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager
components_established(IORInfo) - Method in interface org.omg.PortableInterceptor.IORInterceptor_3_0Operations
The components_established method is invoked on all registered IORInterceptor_3_0 instances after establish_components has been invoked on all registered IORInterceptor instances.
ComponentSampleModel - Class in java.awt.image
This class represents image data which is stored such that each sample of a pixel occupies one data element of the DataBuffer.
ComponentSampleModel(int, int, int, int, int, int[]) - Constructor for class java.awt.image.ComponentSampleModel
Constructs a ComponentSampleModel with the specified parameters.
ComponentSampleModel(int, int, int, int, int, int[], int[]) - Constructor for class java.awt.image.ComponentSampleModel
Constructs a ComponentSampleModel with the specified parameters.
componentShown(ComponentEvent) - Method in class java.awt.AWTEventMulticaster
Handles the componentShown event by invoking the componentShown methods on listener-a and listener-b.
componentShown(ComponentEvent) - Method in class java.awt.Component.AccessibleAWTComponent.AccessibleAWTComponentHandler
componentShown(ComponentEvent) - Method in class java.awt.event.ComponentAdapter
Invoked when the component has been made visible.
componentShown(ComponentEvent) - Method in interface java.awt.event.ComponentListener
Invoked when the component has been made visible.
componentShown(ComponentEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.ComponentHandler
ComponentUI - Class in javax.swing.plaf
The base class for all UI delegate objects in the Swing pluggable look and feel architecture.
ComponentUI() - Constructor for class javax.swing.plaf.ComponentUI
Sole constructor.
ComponentView - Class in javax.swing.text
Component decorator that implements the view interface.
ComponentView(Element) - Constructor for class javax.swing.text.ComponentView
Creates a new ComponentView object.
compose(Raster, Raster, WritableRaster) - Method in interface java.awt.CompositeContext
Composes the two source Raster objects and places the result in the destination WritableRaster.
compose(DoubleUnaryOperator) - Method in interface java.util.function.DoubleUnaryOperator
Returns a composed operator that first applies the before operator to its input, and then applies this operator to the result.
compose(Function<? super V, ? extends T>) - Method in interface java.util.function.Function
Returns a composed function that first applies the before function to its input, and then applies this function to the result.
compose(IntUnaryOperator) - Method in interface java.util.function.IntUnaryOperator
Returns a composed operator that first applies the before operator to its input, and then applies this operator to the result.
compose(LongUnaryOperator) - Method in interface java.util.function.LongUnaryOperator
Returns a composed operator that first applies the before operator to its input, and then applies this operator to the result.
ComposedTextAttribute - Static variable in class javax.swing.text.StyleConstants
Name of the input method composed text attribute.
composeName(Name, Name) - Method in interface javax.naming.Context
Composes the name of this context with a name relative to this context.
composeName(String, String) - Method in interface javax.naming.Context
Composes the name of this context with a name relative to this context.
composeName(String, String) - Method in class javax.naming.InitialContext
Composes the name of this context with a name relative to this context.
composeName(Name, Name) - Method in class javax.naming.InitialContext
Composes the name of this context with a name relative to this context.
Composite - Interface in java.awt
The Composite interface, along with CompositeContext, defines the methods to compose a draw primitive with the underlying graphics area.
CompositeContext - Interface in java.awt
The CompositeContext interface defines the encapsulated and optimized environment for a compositing operation.
CompositeData - Interface in javax.management.openmbean
The CompositeData interface specifies the behavior of a specific type of complex open data objects which represent composite data structures.
CompositeDataInvocationHandler - Class in javax.management.openmbean
An InvocationHandler that forwards getter methods to a CompositeData.
CompositeDataInvocationHandler(CompositeData) - Constructor for class javax.management.openmbean.CompositeDataInvocationHandler
Construct a handler backed by the given CompositeData.
CompositeDataSupport - Class in javax.management.openmbean
The CompositeDataSupport class is the open data class which implements the CompositeData interface.
CompositeDataSupport(CompositeType, String[], Object[]) - Constructor for class javax.management.openmbean.CompositeDataSupport
Constructs a CompositeDataSupport instance with the specified compositeType, whose item values are specified by itemValues[], in the same order as in itemNames[].
CompositeDataSupport(CompositeType, Map<String, ?>) - Constructor for class javax.management.openmbean.CompositeDataSupport
Constructs a CompositeDataSupport instance with the specified compositeType, whose item names and corresponding values are given by the mappings in the map items.
CompositeDataView - Interface in javax.management.openmbean
A Java class can implement this interface to indicate how it is to be converted into a CompositeData by the MXBean framework.
CompositeName - Class in javax.naming
This class represents a composite name -- a sequence of component names spanning multiple namespaces.
CompositeName(Enumeration<String>) - Constructor for class javax.naming.CompositeName
Constructs a new composite name instance using the components specified by 'comps'.
CompositeName(String) - Constructor for class javax.naming.CompositeName
Constructs a new composite name instance by parsing the string n using the composite name syntax (left-to-right, slash separated).
CompositeName() - Constructor for class javax.naming.CompositeName
Constructs a new empty composite name.
CompositeType - Class in javax.management.openmbean
The CompositeType class is the open type class whose instances describe the types of CompositeData values.
CompositeType(String, String, String[], String[], OpenType<?>[]) - Constructor for class javax.management.openmbean.CompositeType
Constructs a CompositeType instance, checking for the validity of the given parameters.
CompositeView - Class in javax.swing.text
CompositeView is an abstract View implementation which manages one or more child views.
CompositeView(Element) - Constructor for class javax.swing.text.CompositeView
Constructs a CompositeView for the given element.
CompoundBorder - Class in javax.swing.border
A composite Border class used to compose two Border objects into a single border by nesting an inside Border object within the insets of an outside Border object.
CompoundBorder() - Constructor for class javax.swing.border.CompoundBorder
Creates a compound border with null outside and inside borders.
CompoundBorder(Border, Border) - Constructor for class javax.swing.border.CompoundBorder
Creates a compound border with the specified outside and inside borders.
CompoundBorderUIResource(Border, Border) - Constructor for class javax.swing.plaf.BorderUIResource.CompoundBorderUIResource
CompoundControl - Class in javax.sound.sampled
A CompoundControl, such as a graphic equalizer, provides control over two or more related properties, each of which is itself represented as a Control.
CompoundControl(CompoundControl.Type, Control[]) - Constructor for class javax.sound.sampled.CompoundControl
Constructs a new compound control object with the given parameters.
CompoundControl.Type - Class in javax.sound.sampled
An instance of the CompoundControl.Type inner class identifies one kind of compound control.
CompoundEdit - Class in javax.swing.undo
A concrete subclass of AbstractUndoableEdit, used to assemble little UndoableEdits into great big ones.
CompoundEdit() - Constructor for class javax.swing.undo.CompoundEdit
compoundEdit - Variable in class javax.swing.undo.UndoableEditSupport
CompoundName - Class in javax.naming
This class represents a compound name -- a name from a hierarchical name space.
CompoundName(Enumeration<String>, Properties) - Constructor for class javax.naming.CompoundName
Constructs a new compound name instance using the components specified in comps and syntax.
CompoundName(String, Properties) - Constructor for class javax.naming.CompoundName
Constructs a new compound name instance by parsing the string n using the syntax specified by the syntax properties supplied.
COMPRESS - Static variable in class javax.print.attribute.standard.Compression
UNIX compression technology.
Compression - Class in javax.print.attribute.standard
Class Compression is a printing attribute class, an enumeration, that specifies how print data is compressed.
Compression(int) - Constructor for class javax.print.attribute.standard.Compression
Construct a new compression enumeration value with the given integer value.
COMPRESSION_ERROR - Static variable in class javax.print.attribute.standard.JobStateReason
The job was aborted by the system because the printer encountered an error in the document data while decompressing it.
compressionMode - Variable in class javax.imageio.ImageWriteParam
The mode controlling compression settings, which must be set to one of the four MODE_* values.
compressionQuality - Variable in class javax.imageio.ImageWriteParam
A float containing the current compression quality setting.
compressionType - Variable in class javax.imageio.ImageWriteParam
A String containing the name of the current compression type, or null if none is set.
compressionTypes - Variable in class javax.imageio.ImageWriteParam
An array of Strings containing the names of the available compression types.
comptable - Variable in class java.awt.GridBagLayout
This hashtable maintains the association between a component and its gridbag constraints.
compute(Object, BiFunction<? super Object, ? super Object, ? extends Object>) - Method in class java.security.Provider
Attempts to compute a mapping for the specified key and its current mapped value (or null if there is no current mapping).
compute(K, BiFunction<? super K, ? super V, ? extends V>) - Method in class java.util.concurrent.ConcurrentHashMap
Attempts to compute a mapping for the specified key and its current mapped value (or null if there is no current mapping).
compute(K, BiFunction<? super K, ? super V, ? extends V>) - Method in interface java.util.concurrent.ConcurrentMap
Attempts to compute a mapping for the specified key and its current mapped value (or null if there is no current mapping).
compute(K, BiFunction<? super K, ? super V, ? extends V>) - Method in class java.util.concurrent.ConcurrentSkipListMap
Attempts to compute a mapping for the specified key and its current mapped value (or null if there is no current mapping).
compute() - Method in class java.util.concurrent.CountedCompleter
The main computation performed by this task.
compute() - Method in class java.util.concurrent.RecursiveAction
The main computation performed by this task.
compute() - Method in class java.util.concurrent.RecursiveTask
The main computation performed by this task.
compute(K, BiFunction<? super K, ? super V, ? extends V>) - Method in class java.util.HashMap
compute(K, BiFunction<? super K, ? super V, ? extends V>) - Method in class java.util.Hashtable
compute(K, BiFunction<? super K, ? super V, ? extends V>) - Method in interface java.util.Map
Attempts to compute a mapping for the specified key and its current mapped value (or null if there is no current mapping).
computeBlit(int, int, Point, Point, Dimension, Rectangle) - Method in class javax.swing.JViewport
Computes the parameters for a blit where the backing store image currently contains oldLoc in the upper left hand corner and we're scrolling to newLoc.
computeDifference(Rectangle, Rectangle) - Static method in class javax.swing.SwingUtilities
Convenience returning an array of rect representing the regions within rectA that do not overlap with rectB.
computeFields() - Method in class java.util.Calendar
Converts the current millisecond time value Calendar.time to calendar field values in fields[].
computeFields() - Method in class java.util.GregorianCalendar
Converts the time value (millisecond offset from the Epoch) to calendar field values.
computeIfAbsent(Object, Function<? super Object, ? extends Object>) - Method in class java.security.Provider
If the specified key is not already associated with a value (or is mapped to null), attempts to compute its value using the given mapping function and enters it into this map unless null.
computeIfAbsent(K, Function<? super K, ? extends V>) - Method in class java.util.concurrent.ConcurrentHashMap
If the specified key is not already associated with a value, attempts to compute its value using the given mapping function and enters it into this map unless null.
computeIfAbsent(K, Function<? super K, ? extends V>) - Method in interface java.util.concurrent.ConcurrentMap
If the specified key is not already associated with a value (or is mapped to null), attempts to compute its value using the given mapping function and enters it into this map unless null.
computeIfAbsent(K, Function<? super K, ? extends V>) - Method in class java.util.concurrent.ConcurrentSkipListMap
If the specified key is not already associated with a value, attempts to compute its value using the given mapping function and enters it into this map unless null.
computeIfAbsent(K, Function<? super K, ? extends V>) - Method in class java.util.HashMap
computeIfAbsent(K, Function<? super K, ? extends V>) - Method in class java.util.Hashtable
computeIfAbsent(K, Function<? super K, ? extends V>) - Method in interface java.util.Map
If the specified key is not already associated with a value (or is mapped to null), attempts to compute its value using the given mapping function and enters it into this map unless null.
computeIfPresent(Object, BiFunction<? super Object, ? super Object, ? extends Object>) - Method in class java.security.Provider
If the value for the specified key is present and non-null, attempts to compute a new mapping given the key and its current mapped value.
computeIfPresent(K, BiFunction<? super K, ? super V, ? extends V>) - Method in class java.util.concurrent.ConcurrentHashMap
If the value for the specified key is present, attempts to compute a new mapping given the key and its current mapped value.
computeIfPresent(K, BiFunction<? super K, ? super V, ? extends V>) - Method in interface java.util.concurrent.ConcurrentMap
If the value for the specified key is present and non-null, attempts to compute a new mapping given the key and its current mapped value.
computeIfPresent(K, BiFunction<? super K, ? super V, ? extends V>) - Method in class java.util.concurrent.ConcurrentSkipListMap
If the value for the specified key is present, attempts to compute a new mapping given the key and its current mapped value.
computeIfPresent(K, BiFunction<? super K, ? super V, ? extends V>) - Method in class java.util.HashMap
computeIfPresent(K, BiFunction<? super K, ? super V, ? extends V>) - Method in class java.util.Hashtable
computeIfPresent(K, BiFunction<? super K, ? super V, ? extends V>) - Method in interface java.util.Map
If the value for the specified key is present and non-null, attempts to compute a new mapping given the key and its current mapped value.
computeIntersection(int, int, int, int, Rectangle) - Static method in class javax.swing.SwingUtilities
Convenience to calculate the intersection of two rectangles without allocating a new rectangle.
computePopupBounds(int, int, int, int) - Method in class javax.swing.plaf.basic.BasicComboPopup
Calculate the placement and size of the popup portion of the combo box based on the combo box location and the enclosing screen bounds.
computeRegions(ImageReadParam, int, int, BufferedImage, Rectangle, Rectangle) - Static method in class javax.imageio.ImageReader
Computes the source region of interest and the destination region of interest, taking the width and height of the source image, an optional destination image, and an optional ImageReadParam into account.
computerIcon - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
computeStringWidth(SynthContext, Font, FontMetrics, String) - Method in class javax.swing.plaf.synth.SynthGraphicsUtils
Returns the size of the passed in string.
computeStringWidth(FontMetrics, String) - Static method in class javax.swing.SwingUtilities
Compute the width of the string using a font with the specified "metrics" (sizes).
computeTime() - Method in class java.util.Calendar
Converts the current calendar field values in fields[] to the millisecond time value Calendar.time.
computeTime() - Method in class java.util.GregorianCalendar
Converts calendar field values to the time value (millisecond offset from the Epoch).
computeUnion(int, int, int, int, Rectangle) - Static method in class javax.swing.SwingUtilities
Convenience method that calculates the union of two rectangles without allocating a new rectangle.
computeValue(Class<?>) - Method in class java.lang.ClassValue
Computes the given class's derived value for this ClassValue.
computeVisibleRect(Rectangle) - Method in class javax.swing.JComponent
Returns the Component's "visible rect rectangle" - the intersection of the visible rectangles for this component and all of its ancestors.
concat(String) - Method in class java.lang.String
Concatenates the specified string to the end of this string.
concat(DoubleStream, DoubleStream) - Static method in interface java.util.stream.DoubleStream
Creates a lazily concatenated stream whose elements are all the elements of the first stream followed by all the elements of the second stream.
concat(IntStream, IntStream) - Static method in interface java.util.stream.IntStream
Creates a lazily concatenated stream whose elements are all the elements of the first stream followed by all the elements of the second stream.
concat(LongStream, LongStream) - Static method in interface java.util.stream.LongStream
Creates a lazily concatenated stream whose elements are all the elements of the first stream followed by all the elements of the second stream.
concat(Stream<? extends T>, Stream<? extends T>) - Static method in interface java.util.stream.Stream
Creates a lazily concatenated stream whose elements are all the elements of the first stream followed by all the elements of the second stream.
concatenate(AffineTransform) - Method in class java.awt.geom.AffineTransform
Concatenates an AffineTransform Tx to this AffineTransform Cx in the most commonly useful way to provide a new user space that is mapped to the former user space by Tx.
concatenateTransform(AffineTransform) - Method in class java.awt.image.renderable.RenderContext
Modifies the current user-to-device transform by appending another transform.
concetenateTransform(AffineTransform) - Method in class java.awt.image.renderable.RenderContext
Deprecated.
replaced by concatenateTransform(AffineTransform).
concrete_base_type() - Method in class org.omg.CORBA.TypeCode
Returns the TypeCode object that describes the concrete base type of the value type that this TypeCode object describes.
CONCUR_READ_ONLY - Static variable in interface java.sql.ResultSet
The constant indicating the concurrency mode for a ResultSet object that may NOT be updated.
CONCUR_UPDATABLE - Static variable in interface java.sql.ResultSet
The constant indicating the concurrency mode for a ResultSet object that may be updated.
CONCURRENT - Static variable in interface java.util.Spliterator
Characteristic value signifying that the element source may be safely concurrently modified (allowing additions, replacements, and/or removals) by multiple threads without external synchronization.
ConcurrentHashMap<K,V> - Class in java.util.concurrent
A hash table supporting full concurrency of retrievals and high expected concurrency for updates.
ConcurrentHashMap() - Constructor for class java.util.concurrent.ConcurrentHashMap
Creates a new, empty map with the default initial table size (16).
ConcurrentHashMap(int) - Constructor for class java.util.concurrent.ConcurrentHashMap
Creates a new, empty map with an initial table size accommodating the specified number of elements without the need to dynamically resize.
ConcurrentHashMap(Map<? extends K, ? extends V>) - Constructor for class java.util.concurrent.ConcurrentHashMap
Creates a new map with the same mappings as the given map.
ConcurrentHashMap(int, float) - Constructor for class java.util.concurrent.ConcurrentHashMap
Creates a new, empty map with an initial table size based on the given number of elements (initialCapacity) and initial table density (loadFactor).
ConcurrentHashMap(int, float, int) - Constructor for class java.util.concurrent.ConcurrentHashMap
Creates a new, empty map with an initial table size based on the given number of elements (initialCapacity), table density (loadFactor), and number of concurrently updating threads (concurrencyLevel).
ConcurrentHashMap.KeySetView<K,V> - Class in java.util.concurrent
A view of a ConcurrentHashMap as a Set of keys, in which additions may optionally be enabled by mapping to a common value.
ConcurrentLinkedDeque<E> - Class in java.util.concurrent
An unbounded concurrent deque based on linked nodes.
ConcurrentLinkedDeque() - Constructor for class java.util.concurrent.ConcurrentLinkedDeque
Constructs an empty deque.
ConcurrentLinkedDeque(Collection<? extends E>) - Constructor for class java.util.concurrent.ConcurrentLinkedDeque
Constructs a deque initially containing the elements of the given collection, added in traversal order of the collection's iterator.
ConcurrentLinkedQueue<E> - Class in java.util.concurrent
An unbounded thread-safe queue based on linked nodes.
ConcurrentLinkedQueue() - Constructor for class java.util.concurrent.ConcurrentLinkedQueue
Creates a ConcurrentLinkedQueue that is initially empty.
ConcurrentLinkedQueue(Collection<? extends E>) - Constructor for class java.util.concurrent.ConcurrentLinkedQueue
Creates a ConcurrentLinkedQueue initially containing the elements of the given collection, added in traversal order of the collection's iterator.
ConcurrentMap<K,V> - Interface in java.util.concurrent
A Map providing thread safety and atomicity guarantees.
ConcurrentModificationException - Exception in java.util
This exception may be thrown by methods that have detected concurrent modification of an object when such modification is not permissible.
ConcurrentModificationException() - Constructor for exception java.util.ConcurrentModificationException
Constructs a ConcurrentModificationException with no detail message.
ConcurrentModificationException(String) - Constructor for exception java.util.ConcurrentModificationException
Constructs a ConcurrentModificationException with the specified detail message.
ConcurrentModificationException(Throwable) - Constructor for exception java.util.ConcurrentModificationException
Constructs a new exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause.
ConcurrentModificationException(String, Throwable) - Constructor for exception java.util.ConcurrentModificationException
Constructs a new exception with the specified detail message and cause.
ConcurrentNavigableMap<K,V> - Interface in java.util.concurrent
A ConcurrentMap supporting NavigableMap operations, and recursively so for its navigable sub-maps.
ConcurrentSkipListMap<K,V> - Class in java.util.concurrent
A scalable concurrent ConcurrentNavigableMap implementation.
ConcurrentSkipListMap() - Constructor for class java.util.concurrent.ConcurrentSkipListMap
Constructs a new, empty map, sorted according to the natural ordering of the keys.
ConcurrentSkipListMap(Comparator<? super K>) - Constructor for class java.util.concurrent.ConcurrentSkipListMap
Constructs a new, empty map, sorted according to the specified comparator.
ConcurrentSkipListMap(Map<? extends K, ? extends V>) - Constructor for class java.util.concurrent.ConcurrentSkipListMap
Constructs a new map containing the same mappings as the given map, sorted according to the natural ordering of the keys.
ConcurrentSkipListMap(SortedMap<K, ? extends V>) - Constructor for class java.util.concurrent.ConcurrentSkipListMap
Constructs a new map containing the same mappings and using the same ordering as the specified sorted map.
ConcurrentSkipListSet<E> - Class in java.util.concurrent
A scalable concurrent NavigableSet implementation based on a ConcurrentSkipListMap.
ConcurrentSkipListSet() - Constructor for class java.util.concurrent.ConcurrentSkipListSet
Constructs a new, empty set that orders its elements according to their natural ordering.
ConcurrentSkipListSet(Comparator<? super E>) - Constructor for class java.util.concurrent.ConcurrentSkipListSet
Constructs a new, empty set that orders its elements according to the specified comparator.
ConcurrentSkipListSet(Collection<? extends E>) - Constructor for class java.util.concurrent.ConcurrentSkipListSet
Constructs a new set containing the elements in the specified collection, that orders its elements according to their natural ordering.
ConcurrentSkipListSet(SortedSet<E>) - Constructor for class java.util.concurrent.ConcurrentSkipListSet
Constructs a new set containing the same elements and using the same ordering as the specified sorted set.
Condition - Interface in java.util.concurrent.locks
Condition factors out the Object monitor methods (wait, notify and notifyAll) into distinct objects to give the effect of having multiple wait-sets per object, by combining them with the use of arbitrary Lock implementations.
ConditionObject() - Constructor for class java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject
Creates a new ConditionObject instance.
ConditionObject() - Constructor for class java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject
Creates a new ConditionObject instance.
CONFIG - Static variable in class java.util.logging.Level
CONFIG is a message level for static configuration messages.
config(String) - Method in class java.util.logging.Logger
Log a CONFIG message.
config(Supplier<String>) - Method in class java.util.logging.Logger
Log a CONFIG message, which is only to be constructed if the logging level is such that the message will actually be logged.
Configuration - Class in javax.security.auth.login
A Configuration object is responsible for specifying which LoginModules should be used for a particular application, and in what order the LoginModules should be invoked.
Configuration() - Constructor for class javax.security.auth.login.Configuration
Sole constructor.
Configuration.Parameters - Interface in javax.security.auth.login
This represents a marker interface for Configuration parameters.
ConfigurationException - Exception in javax.naming
This exception is thrown when there is a configuration problem.
ConfigurationException(String) - Constructor for exception javax.naming.ConfigurationException
Constructs a new instance of ConfigurationException using an explanation.
ConfigurationException() - Constructor for exception javax.naming.ConfigurationException
Constructs a new instance of ConfigurationException with all name resolution fields and explanation initialized to null.
ConfigurationSpi - Class in javax.security.auth.login
This class defines the Service Provider Interface (SPI) for the Configuration class.
ConfigurationSpi() - Constructor for class javax.security.auth.login.ConfigurationSpi
configureArrowButton() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
This public method is implementation specific and should be private.
configureBlocking(boolean) - Method in class java.nio.channels.SelectableChannel
Adjusts this channel's blocking mode.
configureBlocking(boolean) - Method in class java.nio.channels.spi.AbstractSelectableChannel
Adjusts this channel's blocking mode.
configureEditor(ComboBoxEditor, Object) - Method in class javax.swing.JComboBox
Initializes the editor with the specified item.
configureEditor() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
This protected method is implementation specific and should be private.
configureEditor() - Method in class javax.swing.plaf.metal.MetalComboBoxUI
configureEnclosingScrollPane() - Method in class javax.swing.JTable
If this JTable is the viewportView of an enclosing JScrollPane (the usual situation), configure this ScrollPane by, amongst other things, installing the table's tableHeader as the columnHeaderView of the scroll pane.
configureGraphics(Graphics2D) - Method in class javax.swing.plaf.nimbus.AbstractRegionPainter
Configures the given Graphics2D.
configureLayoutCache() - Method in class javax.swing.plaf.basic.BasicTreeUI
Resets the TreeState instance based on the tree we're providing the look and feel for.
configureList() - Method in class javax.swing.plaf.basic.BasicComboPopup
Configures the list which is used to hold the combo box items in the popup.
configurePopup() - Method in class javax.swing.plaf.basic.BasicComboPopup
Configures the popup portion of the combo box.
configurePropertiesFromAction(Action) - Method in class javax.swing.AbstractButton
Sets the properties on this button to match those in the specified Action.
configurePropertiesFromAction(Action) - Method in class javax.swing.JComboBox
Sets the properties on this combobox to match those in the specified Action.
configurePropertiesFromAction(Action) - Method in class javax.swing.JMenuItem
Sets the properties on this button to match those in the specified Action.
configurePropertiesFromAction(Action) - Method in class javax.swing.JTextField
Sets the properties on this textfield to match those in the specified Action.
configureScrollBarColors() - Method in class javax.swing.plaf.basic.BasicScrollBarUI
configureScrollBarColors() - Method in class javax.swing.plaf.metal.MetalScrollBarUI
configureScrollBarColors() - Method in class javax.swing.plaf.synth.SynthScrollBarUI
configureScroller() - Method in class javax.swing.plaf.basic.BasicComboPopup
Configures the scrollable portion which holds the list within the combo box popup.
ConfirmationCallback - Class in javax.security.auth.callback
Underlying security services instantiate and pass a ConfirmationCallback to the handle method of a CallbackHandler to ask for YES/NO, OK/CANCEL, YES/NO/CANCEL or other similar confirmations.
ConfirmationCallback(int, int, int) - Constructor for class javax.security.auth.callback.ConfirmationCallback
Construct a ConfirmationCallback with a message type, an option type and a default option.
ConfirmationCallback(int, String[], int) - Constructor for class javax.security.auth.callback.ConfirmationCallback
Construct a ConfirmationCallback with a message type, a list of options and a default option.
ConfirmationCallback(String, int, int, int) - Constructor for class javax.security.auth.callback.ConfirmationCallback
Construct a ConfirmationCallback with a prompt, message type, an option type and a default option.
ConfirmationCallback(String, int, String[], int) - Constructor for class javax.security.auth.callback.ConfirmationCallback
Construct a ConfirmationCallback with a prompt, message type, a list of options and a default option.
connect(PipedOutputStream) - Method in class java.io.PipedInputStream
Causes this piped input stream to be connected to the piped output stream src.
connect(PipedInputStream) - Method in class java.io.PipedOutputStream
Connects this piped output stream to a receiver.
connect(PipedWriter) - Method in class java.io.PipedReader
Causes this piped reader to be connected to the piped writer src.
connect(PipedReader) - Method in class java.io.PipedWriter
Connects this piped writer to a receiver.
connect(InetAddress, int) - Method in class java.net.DatagramSocket
Connects the socket to a remote address for this socket.
connect(SocketAddress) - Method in class java.net.DatagramSocket
Connects this socket to a remote socket address (IP address + port number).
connect(InetAddress, int) - Method in class java.net.DatagramSocketImpl
Connects a datagram socket to a remote destination.
connect(SocketAddress) - Method in class java.net.Socket
Connects this socket to the server.
connect(SocketAddress, int) - Method in class java.net.Socket
Connects this socket to the server with a specified timeout value.
connect(String, int) - Method in class java.net.SocketImpl
Connects this socket to the specified port on the named host.
connect(InetAddress, int) - Method in class java.net.SocketImpl
Connects this socket to the specified port number on the specified host.
connect(SocketAddress, int) - Method in class java.net.SocketImpl
Connects this socket to the specified port number on the specified host.
connect() - Method in class java.net.URLConnection
Opens a communications link to the resource referenced by this URL, if such a connection has not already been established.
connect(SocketAddress, A, CompletionHandler<Void, ? super A>) - Method in class java.nio.channels.AsynchronousSocketChannel
Connects this channel.
connect(SocketAddress) - Method in class java.nio.channels.AsynchronousSocketChannel
Connects this channel.
connect(SocketAddress) - Method in class java.nio.channels.DatagramChannel
Connects this channel's socket.
connect(SocketAddress) - Method in class java.nio.channels.SocketChannel
Connects this channel's socket.
connect(String, Properties) - Method in interface java.sql.Driver
Attempts to make a database connection to the given URL.
connect() - Method in interface javax.management.remote.JMXConnector
Establishes the connection to the connector server.
connect(Map<String, ?>) - Method in interface javax.management.remote.JMXConnector
Establishes the connection to the connector server.
connect(JMXServiceURL) - Static method in class javax.management.remote.JMXConnectorFactory
Creates a connection to the connector server at the given address.
connect(JMXServiceURL, Map<String, ?>) - Static method in class javax.management.remote.JMXConnectorFactory
Creates a connection to the connector server at the given address.
connect() - Method in class javax.management.remote.rmi.RMIConnector
connect(Map<String, ?>) - Method in class javax.management.remote.rmi.RMIConnector
connect(Remote, Remote) - Method in interface javax.rmi.CORBA.PortableRemoteObjectDelegate
Delegation call for PortableRemoteObject.connect(java.rmi.Remote, java.rmi.Remote).
connect(ORB) - Method in class javax.rmi.CORBA.Stub
Connects this stub to an ORB.
connect(Stub, ORB) - Method in interface javax.rmi.CORBA.StubDelegate
Delegation call for Stub.connect(org.omg.CORBA.ORB).
connect(Remote, Remote) - Static method in class javax.rmi.PortableRemoteObject
Makes a Remote object ready for remote communication.
connect(Object) - Method in class org.omg.CORBA.ORB
Connects the given servant object (a Java object that is an instance of the server implementation class) to the ORB.
connected - Variable in class java.net.URLConnection
If false, this connection object has not created a communications link to the specified URL.
ConnectException - Exception in java.net
Signals that an error occurred while attempting to connect a socket to a remote address and port.
ConnectException(String) - Constructor for exception java.net.ConnectException
Constructs a new ConnectException with the specified detail message as to why the connect error occurred.
ConnectException() - Constructor for exception java.net.ConnectException
Construct a new ConnectException with no detailed message.
ConnectException - Exception in java.rmi
A ConnectException is thrown if a connection is refused to the remote host for a remote method call.
ConnectException(String) - Constructor for exception java.rmi.ConnectException
Constructs a ConnectException with the specified detail message.
ConnectException(String, Exception) - Constructor for exception java.rmi.ConnectException
Constructs a ConnectException with the specified detail message and nested exception.
connectFailed(URI, SocketAddress, IOException) - Method in class java.net.ProxySelector
Called to indicate that a connection could not be established to a proxy/socks server.
CONNECTING_TO_DEVICE - Static variable in class javax.print.attribute.standard.PrinterStateReason
The printer has scheduled a job on the output device and is in the process of connecting to a shared network output device (and might not be able to actually start printing the job for an arbitrarily long time depending on the usage of the output device by other servers on the network).
ConnectIOException - Exception in java.rmi
A ConnectIOException is thrown if an IOException occurs while making a connection to the remote host for a remote method call.
ConnectIOException(String) - Constructor for exception java.rmi.ConnectIOException
Constructs a ConnectIOException with the specified detail message.
ConnectIOException(String, Exception) - Constructor for exception java.rmi.ConnectIOException
Constructs a ConnectIOException with the specified detail message and nested exception.
Connection - Interface in java.sql
A connection (session) with a specific database.
connectionClosed(String, String, Object) - Method in class javax.management.remote.JMXConnectorServer
Called by a subclass when a client connection is closed normally.
connectionClosed(String, String, Object) - Method in class javax.management.remote.rmi.RMIConnectorServer
connectionClosed(ConnectionEvent) - Method in interface javax.sql.ConnectionEventListener
Notifies this ConnectionEventListener that the application has called the method close on its representation of a pooled connection.
connectionErrorOccurred(ConnectionEvent) - Method in interface javax.sql.ConnectionEventListener
Notifies this ConnectionEventListener that a fatal error has occurred and the pooled connection can no longer be used.
ConnectionEvent - Class in javax.sql
An Event object that provides information about the source of a connection-related event.
ConnectionEvent(PooledConnection) - Constructor for class javax.sql.ConnectionEvent
Constructs a ConnectionEvent object initialized with the given PooledConnection object.
ConnectionEvent(PooledConnection, SQLException) - Constructor for class javax.sql.ConnectionEvent
Constructs a ConnectionEvent object initialized with the given PooledConnection object and SQLException object.
ConnectionEventListener - Interface in javax.sql
An object that registers to be notified of events generated by a PooledConnection object.
connectionFailed(String, String, Object) - Method in class javax.management.remote.JMXConnectorServer
Called by a subclass when a client connection fails.
connectionFailed(String, String, Object) - Method in class javax.management.remote.rmi.RMIConnectorServer
connectionOpened(String, String, Object) - Method in class javax.management.remote.JMXConnectorServer
Called by a subclass when a new client connection is opened.
connectionOpened(String, String, Object) - Method in class javax.management.remote.rmi.RMIConnectorServer
ConnectionPendingException - Exception in java.nio.channels
Unchecked exception thrown when an attempt is made to connect a SocketChannel for which a non-blocking connection operation is already in progress.
ConnectionPendingException() - Constructor for exception java.nio.channels.ConnectionPendingException
Constructs an instance of this class.
ConnectionPoolDataSource - Interface in javax.sql
A factory for PooledConnection objects.
CONNECTOR_PUNCTUATION - Static variable in class java.lang.Character
General category "Pc" in the Unicode specification.
CONREF - Static variable in interface javax.swing.text.html.parser.DTDConstants
Console - Class in java.io
Methods to access the character-based console device, if any, associated with the current Java virtual machine.
console() - Static method in class java.lang.System
Returns the unique Console object associated with the current Java virtual machine, if any.
ConsoleHandler - Class in java.util.logging
This Handler publishes log records to System.err.
ConsoleHandler() - Constructor for class java.util.logging.ConsoleHandler
Create a ConsoleHandler for System.err.
constant(Class<?>, Object) - Static method in class java.lang.invoke.MethodHandles
Produces a method handle of the requested return type which returns the given constant value every time it is invoked.
constant(int) - Static method in class javax.swing.Spring
Returns a strut -- a spring whose minimum, preferred, and maximum values each have the value pref.
constant(int, int, int) - Static method in class javax.swing.Spring
Returns a spring whose minimum, preferred, and maximum values have the values: min, pref, and max respectively.
ConstantCallSite - Class in java.lang.invoke
A ConstantCallSite is a CallSite whose target is permanent, and can never be changed.
ConstantCallSite(MethodHandle) - Constructor for class java.lang.invoke.ConstantCallSite
Creates a call site with a permanent target.
ConstantCallSite(MethodType, MethodHandle) - Constructor for class java.lang.invoke.ConstantCallSite
Creates a call site with a permanent target, possibly bound to the call site itself.
constantName() - Method in exception java.lang.EnumConstantNotPresentException
Returns the name of the missing enum constant.
constraintBeforeFloating - Variable in class javax.swing.plaf.basic.BasicToolBarUI
Constraints() - Constructor for class javax.swing.SpringLayout.Constraints
Creates an empty Constraints object.
Constraints(Spring, Spring) - Constructor for class javax.swing.SpringLayout.Constraints
Creates a Constraints object with the specified values for its x and y properties.
Constraints(Spring, Spring, Spring, Spring) - Constructor for class javax.swing.SpringLayout.Constraints
Creates a Constraints object with the specified values for its x, y, width, and height properties.
Constraints(Component) - Constructor for class javax.swing.SpringLayout.Constraints
Creates a Constraints object with suitable x, y, width and height springs for component, c.
Constructor<T> - Class in java.lang.reflect
Constructor provides information about, and access to, a single constructor for a class.
constructorModifiers() - Static method in class java.lang.reflect.Modifier
Return an int value OR-ing together the source language modifiers that can be applied to a constructor.
ConstructorProperties - Annotation Type in java.beans
An annotation on a constructor that shows how the parameters of that constructor correspond to the constructed object's getter methods.
constructorsIn(Iterable<? extends Element>) - Static method in class javax.lang.model.util.ElementFilter
Returns a list of constructors in elements.
constructorsIn(Set<? extends Element>) - Static method in class javax.lang.model.util.ElementFilter
Returns a set of constructors in elements.
consume() - Method in class java.awt.AWTEvent
Consumes this event, if this event can be consumed.
consume() - Method in class java.awt.event.InputEvent
Consumes this event so that it will not be processed in the default manner by the source which originated it.
consume() - Method in class java.awt.event.InputMethodEvent
Consumes this event so that it will not be processed in the default manner by the source which originated it.
consumed - Variable in class java.awt.AWTEvent
Controls whether or not the event is sent back down to the peer once the source has processed it - false means it's sent to the peer; true means it's not.
consumer - Variable in class java.awt.image.ImageFilter
The consumer of the particular image data stream for which this instance of the ImageFilter is filtering data.
Consumer<T> - Interface in java.util.function
Represents an operation that accepts a single input argument and returns no result.
containedIn(Oid[]) - Method in class org.ietf.jgss.Oid
A utility method to test if this Oid value is contained within the supplied Oid array.
Container - Class in java.awt
A generic Abstract Window Toolkit(AWT) container object is a component that can contain other AWT components.
Container() - Constructor for class java.awt.Container
Constructs a new Container.
Container.AccessibleAWTContainer - Class in java.awt
Inner class of Container used to provide default support for accessibility.
Container.AccessibleAWTContainer.AccessibleContainerHandler - Class in java.awt
Fire PropertyChange listener, if one is registered, when children are added or removed.
CONTAINER_EVENT_MASK - Static variable in class java.awt.AWTEvent
The event mask for selecting container events.
CONTAINER_FIRST - Static variable in class java.awt.event.ContainerEvent
The first number in the range of ids used for container events.
CONTAINER_LAST - Static variable in class java.awt.event.ContainerEvent
The last number in the range of ids used for container events.
ContainerAdapter - Class in java.awt.event
An abstract adapter class for receiving container events.
ContainerAdapter() - Constructor for class java.awt.event.ContainerAdapter
ContainerEvent - Class in java.awt.event
A low-level event which indicates that a container's contents changed because a component was added or removed.
ContainerEvent(Component, int, Component) - Constructor for class java.awt.event.ContainerEvent
Constructs a ContainerEvent object.
ContainerListener - Interface in java.awt.event
The listener interface for receiving container events.
containerListener - Variable in class javax.swing.plaf.basic.BasicMenuBarUI
ContainerOrderFocusTraversalPolicy - Class in java.awt
A FocusTraversalPolicy that determines traversal order based on the order of child Components in a Container.
ContainerOrderFocusTraversalPolicy() - Constructor for class java.awt.ContainerOrderFocusTraversalPolicy
contains(Point) - Method in class java.awt.Component.AccessibleAWTComponent
Checks whether the specified point is within this object's bounds, where the point's x and y coordinates are defined to be relative to the coordinate system of the object.
contains(int, int) - Method in class java.awt.Component
Checks whether this component "contains" the specified point, where x and y are defined to be relative to the coordinate system of this component.
contains(Point) - Method in class java.awt.Component
Checks whether this component "contains" the specified point, where the point's x and y coordinates are defined to be relative to the coordinate system of this component.
contains(double, double) - Method in class java.awt.geom.Arc2D
Determines whether or not the specified point is inside the boundary of the arc.
contains(double, double, double, double) - Method in class java.awt.geom.Arc2D
Determines whether or not the interior of the arc entirely contains the specified rectangle.
contains(Rectangle2D) - Method in class java.awt.geom.Arc2D
Determines whether or not the interior of the arc entirely contains the specified rectangle.
contains(double, double) - Method in class java.awt.geom.Area
Tests if the specified coordinates are inside the boundary of the Shape, as described by the definition of insideness.
contains(Point2D) - Method in class java.awt.geom.Area
Tests if a specified Point2D is inside the boundary of the Shape, as described by the definition of insideness.
contains(double, double, double, double) - Method in class java.awt.geom.Area
Tests if the interior of the Shape entirely contains the specified rectangular area.
contains(Rectangle2D) - Method in class java.awt.geom.Area
Tests if the interior of the Shape entirely contains the specified Rectangle2D.
contains(double, double) - Method in class java.awt.geom.CubicCurve2D
Tests if the specified coordinates are inside the boundary of the Shape, as described by the definition of insideness.
contains(Point2D) - Method in class java.awt.geom.CubicCurve2D
Tests if a specified Point2D is inside the boundary of the Shape, as described by the definition of insideness.
contains(double, double, double, double) - Method in class java.awt.geom.CubicCurve2D
Tests if the interior of the Shape entirely contains the specified rectangular area.
contains(Rectangle2D) - Method in class java.awt.geom.CubicCurve2D
Tests if the interior of the Shape entirely contains the specified Rectangle2D.
contains(double, double) - Method in class java.awt.geom.Ellipse2D
Tests if the specified coordinates are inside the boundary of the Shape, as described by the definition of insideness.
contains(double, double, double, double) - Method in class java.awt.geom.Ellipse2D
Tests if the interior of the Shape entirely contains the specified rectangular area.
contains(double, double) - Method in class java.awt.geom.Line2D
Tests if a specified coordinate is inside the boundary of this Line2D.
contains(Point2D) - Method in class java.awt.geom.Line2D
Tests if a given Point2D is inside the boundary of this Line2D.
contains(double, double, double, double) - Method in class java.awt.geom.Line2D
Tests if the interior of this Line2D entirely contains the specified set of rectangular coordinates.
contains(Rectangle2D) - Method in class java.awt.geom.Line2D
Tests if the interior of this Line2D entirely contains the specified Rectangle2D.
contains(PathIterator, double, double) - Static method in class java.awt.geom.Path2D
Tests if the specified coordinates are inside the closed boundary of the specified PathIterator.
contains(PathIterator, Point2D) - Static method in class java.awt.geom.Path2D
Tests if the specified Point2D is inside the closed boundary of the specified PathIterator.
contains(double, double) - Method in class java.awt.geom.Path2D
Tests if the specified coordinates are inside the boundary of the Shape, as described by the definition of insideness.
contains(Point2D) - Method in class java.awt.geom.Path2D
Tests if a specified Point2D is inside the boundary of the Shape, as described by the definition of insideness.
contains(PathIterator, double, double, double, double) - Static method in class java.awt.geom.Path2D
Tests if the specified rectangular area is entirely inside the closed boundary of the specified PathIterator.
contains(PathIterator, Rectangle2D) - Static method in class java.awt.geom.Path2D
Tests if the specified Rectangle2D is entirely inside the closed boundary of the specified PathIterator.
contains(double, double, double, double) - Method in class java.awt.geom.Path2D
Tests if the interior of the Shape entirely contains the specified rectangular area.
contains(Rectangle2D) - Method in class java.awt.geom.Path2D
Tests if the interior of the Shape entirely contains the specified Rectangle2D.
contains(double, double) - Method in class java.awt.geom.QuadCurve2D
Tests if the specified coordinates are inside the boundary of the Shape, as described by the definition of insideness.
contains(Point2D) - Method in class java.awt.geom.QuadCurve2D
Tests if a specified Point2D is inside the boundary of the Shape, as described by the definition of insideness.
contains(double, double, double, double) - Method in class java.awt.geom.QuadCurve2D
Tests if the interior of the Shape entirely contains the specified rectangular area.
contains(Rectangle2D) - Method in class java.awt.geom.QuadCurve2D
Tests if the interior of the Shape entirely contains the specified Rectangle2D.
contains(double, double) - Method in class java.awt.geom.Rectangle2D
Tests if the specified coordinates are inside the boundary of the Shape, as described by the definition of insideness.
contains(double, double, double, double) - Method in class java.awt.geom.Rectangle2D
Tests if the interior of the Shape entirely contains the specified rectangular area.
contains(Point2D) - Method in class java.awt.geom.RectangularShape
Tests if a specified Point2D is inside the boundary of the Shape, as described by the definition of insideness.
contains(Rectangle2D) - Method in class java.awt.geom.RectangularShape
Tests if the interior of the Shape entirely contains the specified Rectangle2D.
contains(double, double) - Method in class java.awt.geom.RoundRectangle2D
Tests if the specified coordinates are inside the boundary of the Shape, as described by the definition of insideness.
contains(double, double, double, double) - Method in class java.awt.geom.RoundRectangle2D
Tests if the interior of the Shape entirely contains the specified rectangular area.
contains(Point) - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild
Checks whether the specified point is within this object's bounds, where the point's x and y coordinates are defined to be relative to the coordinate system of the object.
contains(Point) - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent
Checks whether the specified point is within this object's bounds, where the point's x and y coordinates are defined to be relative to the coordinate system of the object.
contains(Point) - Method in class java.awt.Polygon
Determines whether the specified Point is inside this Polygon.
contains(int, int) - Method in class java.awt.Polygon
Determines whether the specified coordinates are inside this Polygon.
contains(double, double) - Method in class java.awt.Polygon
Tests if the specified coordinates are inside the boundary of the Shape, as described by the definition of insideness.
contains(Point2D) - Method in class java.awt.Polygon
Tests if a specified Point2D is inside the boundary of the Shape, as described by the definition of insideness.
contains(double, double, double, double) - Method in class java.awt.Polygon
Tests if the interior of the Shape entirely contains the specified rectangular area.
contains(Rectangle2D) - Method in class java.awt.Polygon
Tests if the interior of the Shape entirely contains the specified Rectangle2D.
contains(Point) - Method in class java.awt.Rectangle
Checks whether or not this Rectangle contains the specified Point.
contains(int, int) - Method in class java.awt.Rectangle
Checks whether or not this Rectangle contains the point at the specified location (x,y).
contains(Rectangle) - Method in class java.awt.Rectangle
Checks whether or not this Rectangle entirely contains the specified Rectangle.
contains(int, int, int, int) - Method in class java.awt.Rectangle
Checks whether this Rectangle entirely contains the Rectangle at the specified location (X,Y) with the specified dimensions (W,H).
contains(double, double) - Method in interface java.awt.Shape
Tests if the specified coordinates are inside the boundary of the Shape, as described by the definition of insideness.
contains(Point2D) - Method in interface java.awt.Shape
Tests if a specified Point2D is inside the boundary of the Shape, as described by the definition of insideness.
contains(double, double, double, double) - Method in interface java.awt.Shape
Tests if the interior of the Shape entirely contains the specified rectangular area.
contains(Rectangle2D) - Method in interface java.awt.Shape
Tests if the interior of the Shape entirely contains the specified Rectangle2D.
contains(Object) - Method in class java.beans.beancontext.BeanContextMembershipEvent
Is the child specified affected by the event?
contains(Object) - Method in class java.beans.beancontext.BeanContextSupport
Determines whether or not the specified object is currently a child of this BeanContext.
contains(CharSequence) - Method in class java.lang.String
Returns true if and only if this string contains the specified sequence of char values.
contains(Charset) - Method in class java.nio.charset.Charset
Tells whether or not this charset contains the given charset.
contains(Object) - Method in class java.util.AbstractCollection
Returns true if this collection contains the specified element.
contains(Object) - Method in class java.util.ArrayDeque
Returns true if this deque contains the specified element.
contains(Object) - Method in class java.util.ArrayList
Returns true if this list contains the specified element.
contains(Object) - Method in interface java.util.Collection
Returns true if this collection contains the specified element.
contains(Object) - Method in class java.util.concurrent.ArrayBlockingQueue
Returns true if this queue contains the specified element.
contains(Object) - Method in interface java.util.concurrent.BlockingDeque
Returns true if this deque contains the specified element.
contains(Object) - Method in interface java.util.concurrent.BlockingQueue
Returns true if this queue contains the specified element.
contains(Object) - Method in class java.util.concurrent.ConcurrentHashMap
Legacy method testing if some key maps into the specified value in this table.
contains(Object) - Method in class java.util.concurrent.ConcurrentHashMap.KeySetView
Returns true if this collection contains the specified element.
contains(Object) - Method in class java.util.concurrent.ConcurrentLinkedDeque
Returns true if this deque contains at least one element e such that o.equals(e).
contains(Object) - Method in class java.util.concurrent.ConcurrentLinkedQueue
Returns true if this queue contains the specified element.
contains(Object) - Method in class java.util.concurrent.ConcurrentSkipListSet
Returns true if this set contains the specified element.
contains(Object) - Method in class java.util.concurrent.CopyOnWriteArrayList
Returns true if this list contains the specified element.
contains(Object) - Method in class java.util.concurrent.CopyOnWriteArraySet
Returns true if this set contains the specified element.
contains(Object) - Method in class java.util.concurrent.LinkedBlockingDeque
Returns true if this deque contains the specified element.
contains(Object) - Method in class java.util.concurrent.LinkedBlockingQueue
Returns true if this queue contains the specified element.
contains(Object) - Method in class java.util.concurrent.LinkedTransferQueue
Returns true if this queue contains the specified element.
contains(Object) - Method in class java.util.concurrent.PriorityBlockingQueue
Returns true if this queue contains the specified element.
contains(Object) - Method in class java.util.concurrent.SynchronousQueue
Always returns false.
contains(Object) - Method in interface java.util.Deque
Returns true if this deque contains the specified element.
contains(Object) - Method in class java.util.HashSet
Returns true if this set contains the specified element.
contains(Object) - Method in class java.util.Hashtable
Tests if some key maps into the specified value in this hashtable.
contains(Object) - Method in class java.util.LinkedList
Returns true if this list contains the specified element.
contains(Object) - Method in interface java.util.List
Returns true if this list contains the specified element.
contains(Object) - Method in class java.util.PriorityQueue
Returns true if this queue contains the specified element.
contains(Object) - Method in interface java.util.Set
Returns true if this set contains the specified element.
contains(Object) - Method in class java.util.TreeSet
Returns true if this set contains the specified element.
contains(Object) - Method in class java.util.Vector
Returns true if this vector contains the specified element.
contains(Point) - Method in interface javax.accessibility.AccessibleComponent
Checks whether the specified point is within this object's bounds, where the point's x and y coordinates are defined to be relative to the coordinate system of the object.
contains(String) - Method in class javax.accessibility.AccessibleRelationSet
Returns whether the relation set contains a relation that matches the specified key.
contains(AccessibleState) - Method in class javax.accessibility.AccessibleStateSet
Checks if the current state is in the state set.
contains(Object) - Method in class javax.imageio.spi.ServiceRegistry
Returns true if provider is currently registered.
contains(TypeMirror, TypeMirror) - Method in interface javax.lang.model.util.Types
Tests whether one type argument contains another.
contains(Object) - Method in interface javax.naming.directory.Attribute
Determines whether a value is in the attribute.
contains(Object) - Method in class javax.naming.directory.BasicAttribute
Determines whether a value is in this attribute.
contains(int) - Method in class javax.print.attribute.SetOfIntegerSyntax
Determine if this set-of-integer attribute contains the given value.
contains(IntegerSyntax) - Method in class javax.print.attribute.SetOfIntegerSyntax
Determine if this set-of-integer attribute contains the given integer attribute's value.
contains(Object) - Method in class javax.swing.DefaultListModel
Tests whether the specified object is a component in this list.
contains(int, int) - Method in class javax.swing.JComponent
Gives the UI delegate an opportunity to define the precise shape of this component for the sake of mouse processing.
contains(Point) - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild
contains(Point) - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell
Checks whether the specified point is within this object's bounds, where the point's x and y coordinates are defined to be relative to the coordinate system of the object.
contains(Point) - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode
contains(Object) - Method in class javax.swing.plaf.basic.BasicDirectoryModel
contains(JComponent, int, int) - Method in class javax.swing.plaf.ComponentUI
Returns true if the specified x,y location is contained within the look and feel's defined shape of the specified component.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiButtonUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiColorChooserUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiComboBoxUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiDesktopIconUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiDesktopPaneUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiFileChooserUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiInternalFrameUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiLabelUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiListUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiMenuBarUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiMenuItemUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiOptionPaneUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiPanelUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiPopupMenuUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiProgressBarUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiRootPaneUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiScrollBarUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiScrollPaneUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiSeparatorUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiSliderUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiSpinnerUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiSplitPaneUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiTabbedPaneUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiTableHeaderUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiTableUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiTextUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiToolBarUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiToolTipUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiTreeUI
Invokes the contains method on each UI handled by this object.
contains(JComponent, int, int) - Method in class javax.swing.plaf.multi.MultiViewportUI
Invokes the contains method on each UI handled by this object.
contains(Point) - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
contains(String) - Method in interface org.w3c.dom.DOMStringList
Test if a string is part of this DOMStringList.
contains(String) - Method in interface org.w3c.dom.NameList
Test if a name is part of this NameList.
containsAlias(String) - Method in class java.security.KeyStore
Checks if the given alias exists in this keystore.
containsAll(Collection) - Method in class java.beans.beancontext.BeanContextSupport
Tests to see if all objects in the specified Collection are children of this BeanContext.
containsAll(Collection<?>) - Method in class java.util.AbstractCollection
Returns true if this collection contains all of the elements in the specified collection.
containsAll(Collection<?>) - Method in interface java.util.Collection
Returns true if this collection contains all of the elements in the specified collection.
containsAll(Collection<?>) - Method in class java.util.concurrent.CopyOnWriteArrayList
Returns true if this list contains all of the elements of the specified collection.
containsAll(Collection<?>) - Method in class java.util.concurrent.CopyOnWriteArraySet
Returns true if this set contains all of the elements of the specified collection.
containsAll(Collection<?>) - Method in class java.util.concurrent.SynchronousQueue
Returns false unless the given collection is empty.
containsAll(Collection<?>) - Method in interface java.util.List
Returns true if this list contains all of the elements of the specified collection.
containsAll(Collection<?>) - Method in interface java.util.Set
Returns true if this set contains all of the elements of the specified collection.
containsAll(Collection<?>) - Method in class java.util.Vector
Returns true if this Vector contains all of the elements in the specified Collection.
containsAngle(double) - Method in class java.awt.geom.Arc2D
Determines whether or not the specified angle is within the angular extents of the arc.
containsAttribute(Object, Object) - Method in class javax.swing.text.AbstractDocument.AbstractElement
Checks whether a given attribute name/value is defined.
containsAttribute(Object, Object) - Method in interface javax.swing.text.AttributeSet
Returns true if this set defines an attribute with the same name and an equal value.
containsAttribute(Object, Object) - Method in class javax.swing.text.SimpleAttributeSet
Checks whether the attribute list contains a specified attribute name/value pair.
containsAttribute(Object, Object) - Method in class javax.swing.text.StyleContext.NamedStyle
Checks whether a given attribute name/value is defined.
containsAttribute(Object, Object) - Method in class javax.swing.text.StyleContext.SmallAttributeSet
Checks whether a given attribute name/value is defined.
containsAttributes(AttributeSet) - Method in class javax.swing.text.AbstractDocument.AbstractElement
Checks whether the element contains all the attributes.
containsAttributes(AttributeSet) - Method in interface javax.swing.text.AttributeSet
Returns true if this set defines all the attributes from the given set with equal values.
containsAttributes(AttributeSet) - Method in class javax.swing.text.SimpleAttributeSet
Checks whether the attribute list contains all the specified name/value pairs.
containsAttributes(AttributeSet) - Method in class javax.swing.text.StyleContext.NamedStyle
Checks whether the element contains all the attributes.
containsAttributes(AttributeSet) - Method in class javax.swing.text.StyleContext.SmallAttributeSet
Checks whether the attribute set contains all of the given attributes.
containsCustomComponents(JOptionPane) - Method in class javax.swing.plaf.basic.BasicOptionPaneUI
Returns true if in the last call to validateComponent the message or buttons contained a subclass of Component.
containsCustomComponents(JOptionPane) - Method in class javax.swing.plaf.multi.MultiOptionPaneUI
Invokes the containsCustomComponents method on each UI handled by this object.
containsCustomComponents(JOptionPane) - Method in class javax.swing.plaf.OptionPaneUI
Returns true if the user has supplied instances of Component for either the options or message.
containsKey(Object) - Method in class java.awt.RenderingHints
Returns true if this RenderingHints contains a mapping for the specified key.
containsKey(Object) - Method in class java.beans.beancontext.BeanContextSupport
Determines whether or not the specified object is currently a child of this BeanContext.
containsKey(Object) - Method in class java.util.AbstractMap
Returns true if this map contains a mapping for the specified key.
containsKey(Object) - Method in class java.util.concurrent.ConcurrentHashMap
Tests if the specified object is a key in this table.
containsKey(Object) - Method in class java.util.concurrent.ConcurrentSkipListMap
Returns true if this map contains a mapping for the specified key.
containsKey(Object) - Method in class java.util.EnumMap
Returns true if this map contains a mapping for the specified key.
containsKey(Object) - Method in class java.util.HashMap
Returns true if this map contains a mapping for the specified key.
containsKey(Object) - Method in class java.util.Hashtable
Tests if the specified object is a key in this hashtable.
containsKey(Object) - Method in class java.util.IdentityHashMap
Tests whether the specified object reference is a key in this identity hash map.
containsKey(Object) - Method in class java.util.jar.Attributes
Returns true if this Map contains the specified attribute name (key).
containsKey(Object) - Method in interface java.util.Map
Returns true if this map contains a mapping for the specified key.
containsKey(String) - Method in class java.util.ResourceBundle
Determines whether the given key is contained in this ResourceBundle or its parent bundles.
containsKey(Object) - Method in class java.util.TreeMap
Returns true if this map contains a mapping for the specified key.
containsKey(Object) - Method in class java.util.WeakHashMap
Returns true if this map contains a mapping for the specified key.
containsKey(String) - Method in interface javax.management.openmbean.CompositeData
Returns true if and only if this CompositeData instance contains an item whose name is key.
containsKey(String) - Method in class javax.management.openmbean.CompositeDataSupport
Returns true if and only if this CompositeData instance contains an item whose name is key.
containsKey(String) - Method in class javax.management.openmbean.CompositeType
Returns true if this CompositeType instance defines an item whose name is itemName.
containsKey(Object[]) - Method in interface javax.management.openmbean.TabularData
Returns true if and only if this TabularData instance contains a CompositeData value (ie a row) whose index is the specified key.
containsKey(Object) - Method in class javax.management.openmbean.TabularDataSupport
Returns true if and only if this TabularData instance contains a CompositeData value (ie a row) whose index is the specified key.
containsKey(Object[]) - Method in class javax.management.openmbean.TabularDataSupport
Returns true if and only if this TabularData instance contains a CompositeData value (ie a row) whose index is the specified key.
containsKey(Class<?>) - Method in interface javax.print.attribute.AttributeSet
Returns true if this attribute set contains an attribute for the specified category.
containsKey(Class<?>) - Method in class javax.print.attribute.HashAttributeSet
Returns true if this attribute set contains an attribute for the specified category.
containsKey(Object) - Method in interface javax.script.Bindings
Returns true if this map contains a mapping for the specified key.
containsKey(Object) - Method in class javax.script.SimpleBindings
Returns true if this map contains a mapping for the specified key.
containsNS(String, String) - Method in interface org.w3c.dom.NameList
Test if the pair namespaceURI/name is part of this NameList.
containsObservedObject(ObjectName) - Method in class javax.management.monitor.Monitor
Tests whether the specified object is in the set of observed MBeans.
containsObservedObject(ObjectName) - Method in interface javax.management.monitor.MonitorMBean
Tests whether the specified object is in the set of observed MBeans.
containsValue(Object) - Method in class java.awt.RenderingHints
Returns true if this RenderingHints maps one or more keys to the specified value.
containsValue(Object) - Method in class java.util.AbstractMap
Returns true if this map maps one or more keys to the specified value.
containsValue(Object) - Method in class java.util.concurrent.ConcurrentHashMap
Returns true if this map maps one or more keys to the specified value.
containsValue(Object) - Method in class java.util.concurrent.ConcurrentSkipListMap
Returns true if this map maps one or more keys to the specified value.
containsValue(Object) - Method in class java.util.EnumMap
Returns true if this map maps one or more keys to the specified value.
containsValue(Object) - Method in class java.util.HashMap
Returns true if this map maps one or more keys to the specified value.
containsValue(Object) - Method in class java.util.Hashtable
Returns true if this hashtable maps one or more keys to this value.
containsValue(Object) - Method in class java.util.IdentityHashMap
Tests whether the specified object reference is a value in this identity hash map.
containsValue(Object) - Method in class java.util.jar.Attributes
Returns true if this Map maps one or more attribute names (keys) to the specified value.
containsValue(Object) - Method in class java.util.LinkedHashMap
Returns true if this map maps one or more keys to the specified value.
containsValue(Object) - Method in interface java.util.Map
Returns true if this map maps one or more keys to the specified value.
containsValue(Object) - Method in class java.util.TreeMap
Returns true if this map maps one or more keys to the specified value.
containsValue(Object) - Method in class java.util.WeakHashMap
Returns true if this map maps one or more keys to the specified value.
containsValue(Object) - Method in interface javax.management.openmbean.CompositeData
Returns true if and only if this CompositeData instance contains an item whose value is value.
containsValue(Object) - Method in class javax.management.openmbean.CompositeDataSupport
Returns true if and only if this CompositeData instance contains an item whose value is value.
containsValue(CompositeData) - Method in interface javax.management.openmbean.TabularData
Returns true if and only if this TabularData instance contains the specified CompositeData value.
containsValue(CompositeData) - Method in class javax.management.openmbean.TabularDataSupport
Returns true if and only if this TabularData instance contains the specified CompositeData value.
containsValue(Object) - Method in class javax.management.openmbean.TabularDataSupport
Returns true if and only if this TabularData instance contains the specified value.
containsValue(Attribute) - Method in interface javax.print.attribute.AttributeSet
Returns true if this attribute set contains the given attribute value.
containsValue(Attribute) - Method in class javax.print.attribute.HashAttributeSet
Returns true if this attribute set contains the given attribute.
containsValue(Object) - Method in class javax.script.SimpleBindings
Returns true if this map maps one or more keys to the specified value.
CONTENT - Static variable in class javax.swing.text.html.HTML.Attribute
CONTENT - Static variable in class javax.swing.text.html.HTML.Tag
All text content is labeled with this tag.
content - Variable in class javax.swing.text.html.parser.ContentModel
The content.
content - Variable in class javax.swing.text.html.parser.Element
CONTENT_AREA_FILLED_CHANGED_PROPERTY - Static variable in class javax.swing.AbstractButton
Identifies a change to having the button paint the content area.
CONTENT_PANE_PROPERTY - Static variable in class javax.swing.JInternalFrame
Bound property name.
CONTENT_TYPE - Static variable in class java.util.jar.Attributes.Name
Name object for Content-Type manifest attribute.
content_type() - Method in class org.omg.CORBA.TypeCode
Returns the TypeCode object representing the IDL type for the members of the object described by this TypeCode object.
contentBorderInsets - Variable in class javax.swing.plaf.basic.BasicTabbedPaneUI
ContentElementName - Static variable in class javax.swing.text.AbstractDocument
Name of elements used to represent content
contentEquals(StringBuffer) - Method in class java.lang.String
Compares this string to the specified StringBuffer.
contentEquals(CharSequence) - Method in class java.lang.String
Compares this string to the specified CharSequence.
contentEquals(CharSequence) - Method in interface javax.lang.model.element.Name
Compares this name to the specified CharSequence.
ContentHandler - Class in java.net
The abstract class ContentHandler is the superclass of all classes that read an Object from a URLConnection.
ContentHandler() - Constructor for class java.net.ContentHandler
ContentHandler - Interface in org.xml.sax
Receive notification of the logical content of a document.
ContentHandlerFactory - Interface in java.net
This interface defines a factory for content handlers.
ContentModel - Class in javax.swing.text.html.parser
A representation of a content model.
ContentModel() - Constructor for class javax.swing.text.html.parser.ContentModel
ContentModel(Element) - Constructor for class javax.swing.text.html.parser.ContentModel
Create a content model for an element.
ContentModel(int, ContentModel) - Constructor for class javax.swing.text.html.parser.ContentModel
Create a content model of a particular type.
ContentModel(int, Object, ContentModel) - Constructor for class javax.swing.text.html.parser.ContentModel
Create a content model of a particular type.
contentPane - Variable in class javax.swing.JRootPane
The content pane.
contentRect - Variable in class javax.swing.plaf.basic.BasicSliderUI
contents - Variable in class java.awt.datatransfer.Clipboard
CONTENTS_CHANGED - Static variable in class javax.swing.event.ListDataEvent
Identifies one or more changes in the lists contents.
contentsChanged(ListDataEvent) - Method in interface javax.swing.event.ListDataListener
Sent when the contents of the list has changed in a way that's too complex to characterize with the previous methods.
contentsChanged(ListDataEvent) - Method in class javax.swing.JComboBox
This method is public as an implementation side effect.
contentsChanged(ListDataEvent) - Method in class javax.swing.JList.AccessibleJList
List Data Listener contents changed method.
contentsChanged(ListDataEvent) - Method in class javax.swing.plaf.basic.BasicComboBoxUI.ListDataHandler
contentsChanged(ListDataEvent) - Method in class javax.swing.plaf.basic.BasicComboPopup.ListDataHandler
contentsChanged(ListDataEvent) - Method in class javax.swing.plaf.basic.BasicListUI.ListDataHandler
contentsLost() - Method in class java.awt.Component.BltBufferStrategy
contentsLost() - Method in class java.awt.Component.FlipBufferStrategy
contentsLost() - Method in class java.awt.image.BufferStrategy
Returns whether the drawing buffer was lost since the last call to getDrawGraphics.
contentsLost() - Method in class java.awt.image.VolatileImage
Returns true if rendering data was lost since last validate call.
contentsRestored() - Method in class java.awt.Component.BltBufferStrategy
contentsRestored() - Method in class java.awt.Component.FlipBufferStrategy
contentsRestored() - Method in class java.awt.image.BufferStrategy
Returns whether the drawing buffer was recently restored from a lost state and reinitialized to the default background color (white).
ContentType - Static variable in class javax.swing.text.DefaultStyledDocument.ElementSpec
A possible value for getType.
context - Variable in class java.awt.dnd.DropTargetEvent
The DropTargetContext associated with this DropTargetEvent.
context() - Method in interface java.nio.file.WatchEvent
Returns the context for the event.
Context - Interface in javax.naming
This interface represents a naming context, which consists of a set of name-to-object bindings.
context - Variable in class javax.script.AbstractScriptEngine
The default ScriptContext of this AbstractScriptEngine.
Context - Class in org.omg.CORBA
An object used in Request operations to specify the context object in which context strings must be resolved before being sent along with the request invocation.
Context() - Constructor for class org.omg.CORBA.Context
context_data - Variable in class org.omg.IOP.ServiceContext
The data associated with this service context
CONTEXT_EXPIRED - Static variable in exception org.ietf.jgss.GSSException
Security context expired.
context_id - Variable in class org.omg.IOP.ServiceContext
The service context id
context_name() - Method in class org.omg.CORBA.Context
Retrieves the name of this Context object.
ContextList - Class in org.omg.CORBA
An object containing a modifiable list of String objects that represent property names.
ContextList() - Constructor for class org.omg.CORBA.ContextList
ContextNotEmptyException - Exception in javax.naming
This exception is thrown when attempting to destroy a context that is not empty.
ContextNotEmptyException(String) - Constructor for exception javax.naming.ContextNotEmptyException
Constructs a new instance of ContextNotEmptyException using an explanation.
ContextNotEmptyException() - Constructor for exception javax.naming.ContextNotEmptyException
Constructs a new instance of ContextNotEmptyException with all name resolution fields and explanation initialized to null.
contexts() - Method in class org.omg.CORBA.Request
Retrieves the ContextList object for this request.
contexts() - Method in interface org.omg.PortableInterceptor.RequestInfoOperations
Returns an array of String objects describing the contexts that may be passed on this operation invocation.
ContextualRenderedImageFactory - Interface in java.awt.image.renderable
ContextualRenderedImageFactory provides an interface for the functionality that may differ between instances of RenderableImageOp.
CONTIGUOUS_TREE_SELECTION - Static variable in interface javax.swing.tree.TreeSelectionModel
Selection can only be contiguous.
CONTINUE - Static variable in class javax.sound.midi.ShortMessage
Status byte for Continue message (0xFB, or 251).
continueDrag(int, int) - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider.DragController
continueDrag(MouseEvent) - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider.DragController
Messages dragDividerTo with the new location for the mouse event.
CONTINUOUS_LAYOUT_PROPERTY - Static variable in class javax.swing.JSplitPane
Bound property name for continuousLayout.
continuousLayout - Variable in class javax.swing.JSplitPane
Whether or not the views are continuously redisplayed while resizing.
contListener - Variable in class javax.swing.plaf.metal.MetalToolBarUI
This protected field is implementation specific.
CONTROL - Static variable in class java.awt.SystemColor
The array index for the SystemColor.control system color.
control - Static variable in class java.awt.SystemColor
The color rendered for the background of control panels and control objects, such as pushbuttons.
CONTROL - Static variable in class java.lang.Character
General category "Cc" in the Unicode specification.
Control() - Constructor for class java.util.ResourceBundle.Control
Sole constructor.
Control - Interface in javax.naming.ldap
This interface represents an LDAPv3 control as defined in RFC 2251.
Control - Class in javax.sound.sampled
Lines often have a set of controls, such as gain and pan, that affect the audio signal passing through the line.
Control(Control.Type) - Constructor for class javax.sound.sampled.Control
Constructs a Control with the specified type.
Control.Type - Class in javax.sound.sampled
An instance of the Type class represents the type of the control.
CONTROL_BUTTONS_ARE_SHOWN_CHANGED_PROPERTY - Static variable in class javax.swing.JFileChooser
Instruction to display the control buttons.
CONTROL_CHANGE - Static variable in class javax.sound.midi.ShortMessage
Command value for Control Change message (0xB0, or 176)
CONTROL_DK_SHADOW - Static variable in class java.awt.SystemColor
The array index for the SystemColor.controlDkShadow system color.
CONTROL_FACTORIES - Static variable in interface javax.naming.ldap.LdapContext
Constant that holds the name of the environment property for specifying the list of control factories to use.
CONTROL_HIGHLIGHT - Static variable in class java.awt.SystemColor
The array index for the SystemColor.controlHighlight system color.
CONTROL_LT_HIGHLIGHT - Static variable in class java.awt.SystemColor
The array index for the SystemColor.controlLtHighlight system color.
CONTROL_PICTURES - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Control Pictures" Unicode character block.
CONTROL_SHADOW - Static variable in class java.awt.SystemColor
The array index for the SystemColor.controlShadow system color.
CONTROL_TEXT - Static variable in class java.awt.SystemColor
The array index for the SystemColor.controlText system color.
controlChange(ShortMessage) - Method in interface javax.sound.midi.ControllerEventListener
Invoked when a Sequencer has encountered and processed a control-change event of interest to this listener.
controlChange(int, int) - Method in interface javax.sound.midi.MidiChannel
Reacts to a change in the specified controller's value.
controlDkShadow - Static variable in class java.awt.SystemColor
The color rendered for dark shadow areas on 3D control objects, such as pushbuttons.
controlDown() - Method in class java.awt.Event
NOTE: The Event class is obsolete and is available only for backwards compatibility.
ControlFactory - Class in javax.naming.ldap
This abstract class represents a factory for creating LDAPv3 controls.
ControlFactory() - Constructor for class javax.naming.ldap.ControlFactory
Creates a new instance of a control factory.
controlHighlight - Static variable in class java.awt.SystemColor
The color rendered for light areas of 3D control objects, such as pushbuttons.
CONTROLLED_BY - Static variable in class javax.accessibility.AccessibleRelation
Indicates an object is controlled by one or more target objects.
CONTROLLED_BY_PROPERTY - Static variable in class javax.accessibility.AccessibleRelation
Identifies that the target object that is doing the controlling has changed
controller - Variable in class javax.imageio.IIOParam
The IIOParamController that will be used to provide settings for this IIOParam object when the activateController method is called.
controller - Variable in class javax.imageio.metadata.IIOMetadata
The IIOMetadataController that will be used to provide settings for this IIOMetadata object when the activateController method is called.
CONTROLLER_FOR - Static variable in class javax.accessibility.AccessibleRelation
Indicates an object is a controller for one or more target objects.
CONTROLLER_FOR_PROPERTY - Static variable in class javax.accessibility.AccessibleRelation
Identifies that the controller for the target object has changed
ControllerEventListener - Interface in javax.sound.midi
The ControllerEventListener interface should be implemented by classes whose instances need to be notified when a Sequencer has processed a requested type of MIDI control-change event.
controlLtHighlight - Static variable in class java.awt.SystemColor
The color rendered for highlight areas of 3D control objects, such as pushbuttons.
controlShadow - Static variable in class java.awt.SystemColor
The color rendered for shadow areas of 3D control objects, such as pushbuttons.
controlText - Static variable in class java.awt.SystemColor
The color rendered for the text of control panels and control objects, such as pushbuttons.
convert(long, TimeUnit) - Method in enum java.util.concurrent.TimeUnit
Converts the given time duration in the given unit to this unit.
convertColumnIndexToModel(int) - Method in class javax.swing.JTable
Maps the index of the column in the view at viewColumnIndex to the index of the column in the table model.
convertColumnIndexToView(int) - Method in class javax.swing.JTable
Maps the index of the column in the table model at modelColumnIndex to the index of the column in the view.
CONVERTED_TEXT - Static variable in class java.awt.im.InputMethodHighlight
Constant for the converted text state.
convertImageMetadata(IIOMetadata, ImageTypeSpecifier, ImageWriteParam) - Method in interface javax.imageio.ImageTranscoder
Returns an IIOMetadata object that may be used for encoding and optionally modified using its document interfaces or other interfaces specific to the writer plug-in that will be used for encoding.
convertImageMetadata(IIOMetadata, ImageTypeSpecifier, ImageWriteParam) - Method in class javax.imageio.ImageWriter
convertMouseEvent(MouseEvent) - Method in class javax.swing.plaf.basic.BasicComboPopup
convertMouseEvent(Component, MouseEvent, Component) - Static method in class javax.swing.SwingUtilities
Returns a MouseEvent similar to sourceEvent except that its x and y members have been converted to destination's coordinate system.
convertPoint(Component, Point, Component) - Static method in class javax.swing.SwingUtilities
Convert a aPoint in source coordinate system to destination coordinate system.
convertPoint(Component, int, int, Component) - Static method in class javax.swing.SwingUtilities
Convert the point (x,y) in source coordinate system to destination coordinate system.
convertPointFromScreen(Point, Component) - Static method in class javax.swing.SwingUtilities
Convert a point from a screen coordinates to a component's coordinate system
convertPointToScreen(Point, Component) - Static method in class javax.swing.SwingUtilities
Convert a point from a component's coordinate system to screen coordinates.
convertPreviousRowIndexToModel(int) - Method in class javax.swing.event.RowSorterEvent
Returns the location of index in terms of the model prior to the sort.
convertRectangle(Component, Rectangle, Component) - Static method in class javax.swing.SwingUtilities
Convert the rectangle aRectangle in source coordinate system to destination coordinate system.
convertRowIndexToModel(int) - Method in class javax.swing.DefaultRowSorter
Returns the location of index in terms of the underlying model.
convertRowIndexToModel(int) - Method in class javax.swing.JTable
Maps the index of the row in terms of the view to the underlying TableModel.
convertRowIndexToModel(int) - Method in class javax.swing.RowSorter
Returns the location of index in terms of the underlying model.
convertRowIndexToView(int) - Method in class javax.swing.DefaultRowSorter
Returns the location of index in terms of the view.
convertRowIndexToView(int) - Method in class javax.swing.JTable
Maps the index of the row in terms of the TableModel to the view.
convertRowIndexToView(int) - Method in class javax.swing.RowSorter
Returns the location of index in terms of the view.
convertRowToY(int) - Method in class javax.swing.plaf.basic.BasicListUI
Return the JList relative Y coordinate of the origin of the specified row or -1 if row isn't valid.
convertStreamMetadata(IIOMetadata, ImageWriteParam) - Method in interface javax.imageio.ImageTranscoder
Returns an IIOMetadata object that may be used for encoding and optionally modified using its document interfaces or other interfaces specific to the writer plug-in that will be used for encoding.
convertStreamMetadata(IIOMetadata, ImageWriteParam) - Method in class javax.imageio.ImageWriter
convertToIntDiscrete(Raster, boolean) - Method in class java.awt.image.IndexColorModel
Returns a new BufferedImage of TYPE_INT_ARGB or TYPE_INT_RGB that has a Raster with pixel data computed by expanding the indices in the source Raster using the color/alpha component arrays of this ColorModel.
convertToVector(Object[]) - Static method in class javax.swing.table.DefaultTableModel
Returns a vector that contains the same objects as the array.
convertToVector(Object[][]) - Static method in class javax.swing.table.DefaultTableModel
Returns a vector of vectors that contains the same objects as the array.
convertValueToText(Object, boolean, boolean, boolean, int, boolean) - Method in class javax.swing.JTree
Called by the renderers to convert the specified value to text.
convertYToRow(int) - Method in class javax.swing.plaf.basic.BasicListUI
Convert the JList relative coordinate to the row that contains it, based on the current layout.
ConvolveOp - Class in java.awt.image
This class implements a convolution from the source to the destination.
ConvolveOp(Kernel, int, RenderingHints) - Constructor for class java.awt.image.ConvolveOp
Constructs a ConvolveOp given a Kernel, an edge condition, and a RenderingHints object (which may be null).
ConvolveOp(Kernel) - Constructor for class java.awt.image.ConvolveOp
Constructs a ConvolveOp given a Kernel.
CookieHandler - Class in java.net
A CookieHandler object provides a callback mechanism to hook up a HTTP state management policy implementation into the HTTP protocol handler.
CookieHandler() - Constructor for class java.net.CookieHandler
CookieHolder - Class in org.omg.PortableServer.ServantLocatorPackage
The native type PortableServer::ServantLocator::Cookie is mapped to java.lang.Object.
CookieHolder() - Constructor for class org.omg.PortableServer.ServantLocatorPackage.CookieHolder
CookieHolder(Object) - Constructor for class org.omg.PortableServer.ServantLocatorPackage.CookieHolder
CookieManager - Class in java.net
CookieManager provides a concrete implementation of CookieHandler, which separates the storage of cookies from the policy surrounding accepting and rejecting cookies.
CookieManager() - Constructor for class java.net.CookieManager
Create a new cookie manager.
CookieManager(CookieStore, CookiePolicy) - Constructor for class java.net.CookieManager
Create a new cookie manager with specified cookie store and cookie policy.
CookiePolicy - Interface in java.net
CookiePolicy implementations decide which cookies should be accepted and which should be rejected.
CookieStore - Interface in java.net
A CookieStore object represents a storage for cookie.
COORDS - Static variable in class javax.swing.text.html.HTML.Attribute
COPIED - Static variable in class java.awt.BufferCapabilities.FlipContents
When flip contents are COPIED, the contents of the back buffer are copied to the front buffer when flipping.
Copies - Class in javax.print.attribute.standard
Class Copies is an integer valued printing attribute class that specifies the number of copies to be printed.
Copies(int) - Constructor for class javax.print.attribute.standard.Copies
Construct a new copies attribute with the given integer value.
CopiesSupported - Class in javax.print.attribute.standard
Class CopiesSupported is a printing attribute class, a set of integers, that gives the supported values for a Copies attribute.
CopiesSupported(int) - Constructor for class javax.print.attribute.standard.CopiesSupported
Construct a new copies supported attribute containing a single integer.
CopiesSupported(int, int) - Constructor for class javax.print.attribute.standard.CopiesSupported
Construct a new copies supported attribute containing a single range of integers.
COPTIC - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Coptic" Unicode character block.
copy(Path, Path, CopyOption...) - Static method in class java.nio.file.Files
Copy a file to a target file.
copy(InputStream, Path, CopyOption...) - Static method in class java.nio.file.Files
Copies all bytes from an input stream to a file.
copy(Path, OutputStream) - Static method in class java.nio.file.Files
Copies all bytes from a file to an output stream.
copy(Path, Path, CopyOption...) - Method in class java.nio.file.spi.FileSystemProvider
Copy a file to a target file.
copy(List<? super T>, List<? extends T>) - Static method in class java.util.Collections
Copies all of the elements from one list into another.
copy() - Method in class javax.swing.JPasswordField
Invokes provideErrorFeedback on the current look and feel, which typically initiates an error beep.
copy - Variable in class javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit
copy() - Method in class javax.swing.text.JTextComponent
Transfers the currently selected range in the associated text model to the system clipboard, leaving the contents in the text model.
COPY - Static variable in class javax.swing.TransferHandler
An int representing a "copy" transfer action.
copy() - Method in class org.omg.CORBA._PolicyStub
Copies the policy object.
copy() - Method in interface org.omg.CORBA.DynAny
Deprecated.
Clones this DynAny object.
copy() - Method in interface org.omg.CORBA.PolicyOperations
Returns a copy of the Policy object.
copy() - Method in class org.omg.DynamicAny._DynAnyStub
Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
copy() - Method in class org.omg.DynamicAny._DynArrayStub
Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
copy() - Method in class org.omg.DynamicAny._DynEnumStub
Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
copy() - Method in class org.omg.DynamicAny._DynFixedStub
Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
copy() - Method in class org.omg.DynamicAny._DynSequenceStub
Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
copy() - Method in class org.omg.DynamicAny._DynStructStub
Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
copy() - Method in class org.omg.DynamicAny._DynUnionStub
Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
copy() - Method in class org.omg.DynamicAny._DynValueStub
Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
copy() - Method in interface org.omg.DynamicAny.DynAnyOperations
Creates a new DynAny object whose value is a deep copy of the DynAny on which it is invoked.
COPY_OR_MOVE - Static variable in class javax.swing.TransferHandler
An int representing a source action capability of either "copy" or "move".
copyAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the action to copy the selected region and place the contents into the system clipboard.
CopyAction() - Constructor for class javax.swing.text.DefaultEditorKit.CopyAction
Create this object with the appropriate identifier.
copyArea(int, int, int, int, int, int) - Method in class java.awt.Graphics
Copies an area of the component by a distance specified by dx and dy.
copyArea(int, int, int, int, int, int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.copyArea.
copyAttributes() - Method in class javax.swing.text.AbstractDocument.AbstractElement
Copies a set of attributes.
copyAttributes() - Method in interface javax.swing.text.AttributeSet
Returns an attribute set that is guaranteed not to change over time.
copyAttributes() - Method in class javax.swing.text.SimpleAttributeSet
Makes a copy of the attributes.
copyAttributes() - Method in class javax.swing.text.StyleContext.NamedStyle
Copies a set of attributes.
copyAttributes() - Method in class javax.swing.text.StyleContext.SmallAttributeSet
Copies a set of attributes.
copyChildren() - Method in class java.beans.beancontext.BeanContextSupport
Gets a copy of the this BeanContext's children.
copyData(WritableRaster) - Method in class java.awt.image.BufferedImage
Computes an arbitrary rectangular region of the BufferedImage and copies it into a specified WritableRaster.
copyData(WritableRaster) - Method in interface java.awt.image.RenderedImage
Computes an arbitrary rectangular region of the RenderedImage and copies it into a caller-supplied WritableRaster.
copyInto(Object[]) - Method in class java.util.Vector
Copies the components of this vector into the specified array.
copyInto(Object[]) - Method in class javax.swing.DefaultListModel
Copies the components of this list into the specified array.
copyObject(Object, ORB) - Static method in class javax.rmi.CORBA.Util
Copies or connects an object.
copyObject(Object, ORB) - Method in interface javax.rmi.CORBA.UtilDelegate
Delegation call for Util.copyObject(java.lang.Object, org.omg.CORBA.ORB).
copyObjects(Object[], ORB) - Static method in class javax.rmi.CORBA.Util
Copies or connects an array of objects.
copyObjects(Object[], ORB) - Method in interface javax.rmi.CORBA.UtilDelegate
Delegation call for Util.copyObjects(java.lang.Object[], org.omg.CORBA.ORB).
copyOf(T[], int) - Static method in class java.util.Arrays
Copies the specified array, truncating or padding with nulls (if necessary) so the copy has the specified length.
copyOf(U[], int, Class<? extends T[]>) - Static method in class java.util.Arrays
Copies the specified array, truncating or padding with nulls (if necessary) so the copy has the specified length.
copyOf(byte[], int) - Static method in class java.util.Arrays
Copies the specified array, truncating or padding with zeros (if necessary) so the copy has the specified length.
copyOf(short[], int) - Static method in class java.util.Arrays
Copies the specified array, truncating or padding with zeros (if necessary) so the copy has the specified length.
copyOf(int[], int) - Static method in class java.util.Arrays
Copies the specified array, truncating or padding with zeros (if necessary) so the copy has the specified length.
copyOf(long[], int) - Static method in class java.util.Arrays
Copies the specified array, truncating or padding with zeros (if necessary) so the copy has the specified length.
copyOf(char[], int) - Static method in class java.util.Arrays
Copies the specified array, truncating or padding with null characters (if necessary) so the copy has the specified length.
copyOf(float[], int) - Static method in class java.util.Arrays
Copies the specified array, truncating or padding with zeros (if necessary) so the copy has the specified length.
copyOf(double[], int) - Static method in class java.util.Arrays
Copies the specified array, truncating or padding with zeros (if necessary) so the copy has the specified length.
copyOf(boolean[], int) - Static method in class java.util.Arrays
Copies the specified array, truncating or padding with false (if necessary) so the copy has the specified length.
copyOf(EnumSet<E>) - Static method in class java.util.EnumSet
Creates an enum set with the same element type as the specified enum set, initially containing the same elements (if any).
copyOf(Collection<E>) - Static method in class java.util.EnumSet
Creates an enum set initialized from the specified collection.
copyOfRange(T[], int, int) - Static method in class java.util.Arrays
Copies the specified range of the specified array into a new array.
copyOfRange(U[], int, int, Class<? extends T[]>) - Static method in class java.util.Arrays
Copies the specified range of the specified array into a new array.
copyOfRange(byte[], int, int) - Static method in class java.util.Arrays
Copies the specified range of the specified array into a new array.
copyOfRange(short[], int, int) - Static method in class java.util.Arrays
Copies the specified range of the specified array into a new array.
copyOfRange(int[], int, int) - Static method in class java.util.Arrays
Copies the specified range of the specified array into a new array.
copyOfRange(long[], int, int) - Static method in class java.util.Arrays
Copies the specified range of the specified array into a new array.
copyOfRange(char[], int, int) - Static method in class java.util.Arrays
Copies the specified range of the specified array into a new array.
copyOfRange(float[], int, int) - Static method in class java.util.Arrays
Copies the specified range of the specified array into a new array.
copyOfRange(double[], int, int) - Static method in class java.util.Arrays
Copies the specified range of the specified array into a new array.
copyOfRange(boolean[], int, int) - Static method in class java.util.Arrays
Copies the specified range of the specified array into a new array.
CopyOnWriteArrayList<E> - Class in java.util.concurrent
A thread-safe variant of ArrayList in which all mutative operations (add, set, and so on) are implemented by making a fresh copy of the underlying array.
CopyOnWriteArrayList() - Constructor for class java.util.concurrent.CopyOnWriteArrayList
Creates an empty list.
CopyOnWriteArrayList(Collection<? extends E>) - Constructor for class java.util.concurrent.CopyOnWriteArrayList
Creates a list containing the elements of the specified collection, in the order they are returned by the collection's iterator.
CopyOnWriteArrayList(E[]) - Constructor for class java.util.concurrent.CopyOnWriteArrayList
Creates a list holding a copy of the given array.
CopyOnWriteArraySet<E> - Class in java.util.concurrent
A Set that uses an internal CopyOnWriteArrayList for all of its operations.
CopyOnWriteArraySet() - Constructor for class java.util.concurrent.CopyOnWriteArraySet
Creates an empty set.
CopyOnWriteArraySet(Collection<? extends E>) - Constructor for class java.util.concurrent.CopyOnWriteArraySet
Creates a set containing all of the elements of the specified collection.
CopyOption - Interface in java.nio.file
An object that configures how to copy or move a file.
copySign(double, double) - Static method in class java.lang.Math
Returns the first floating-point argument with the sign of the second floating-point argument.
copySign(float, float) - Static method in class java.lang.Math
Returns the first floating-point argument with the sign of the second floating-point argument.
copySign(double, double) - Static method in class java.lang.StrictMath
Returns the first floating-point argument with the sign of the second floating-point argument.
copySign(float, float) - Static method in class java.lang.StrictMath
Returns the first floating-point argument with the sign of the second floating-point argument.
copyValueOf(char[], int, int) - Static method in class java.lang.String
Equivalent to String.valueOf(char[], int, int).
copyValueOf(char[]) - Static method in class java.lang.String
Equivalent to String.valueOf(char[]).
cos(double) - Static method in class java.lang.Math
Returns the trigonometric cosine of an angle.
cos(double) - Static method in class java.lang.StrictMath
Returns the trigonometric cosine of an angle.
cosh(double) - Static method in class java.lang.Math
Returns the hyperbolic cosine of a double value.
cosh(double) - Static method in class java.lang.StrictMath
Returns the hyperbolic cosine of a double value.
count - Variable in class java.io.BufferedInputStream
The index one greater than the index of the last valid byte in the buffer.
count - Variable in class java.io.BufferedOutputStream
The number of valid bytes in the buffer.
count - Variable in class java.io.ByteArrayInputStream
The index one greater than the last valid character in the input stream buffer.
count - Variable in class java.io.ByteArrayOutputStream
The number of valid bytes in the buffer.
count - Variable in class java.io.CharArrayReader
The index of the end of this buffer.
count - Variable in class java.io.CharArrayWriter
The number of chars in the buffer.
count - Variable in class java.io.StringBufferInputStream
Deprecated.
The number of valid characters in the input stream buffer.
count() - Method in interface java.nio.file.WatchEvent
Returns the event count.
count() - Method in interface java.util.stream.DoubleStream
Returns the count of elements in this stream.
count() - Method in interface java.util.stream.IntStream
Returns the count of elements in this stream.
count() - Method in interface java.util.stream.LongStream
Returns the count of elements in this stream.
count() - Method in interface java.util.stream.Stream
Returns the count of elements in this stream.
count - Variable in class javax.swing.text.Segment
This is the number of array elements that make up the text of interest.
count() - Method in class org.omg.CORBA.ContextList
Returns the number of String objects in this ContextList object.
count() - Method in class org.omg.CORBA.ExceptionList
Retrieves the number of TypeCode objects in this ExceptionList object.
count() - Method in class org.omg.CORBA.NVList
Returns the number of NamedValue objects that have been added to this NVList object.
countAttachments() - Method in class javax.xml.soap.SOAPMessage
Gets a count of the number of attachments in this message.
countComponents() - Method in class java.awt.Container
Deprecated.
As of JDK version 1.1, replaced by getComponentCount().
countDown() - Method in class java.util.concurrent.CountDownLatch
Decrements the count of the latch, releasing all waiting threads if the count reaches zero.
CountDownLatch - Class in java.util.concurrent
A synchronization aid that allows one or more threads to wait until a set of operations being performed in other threads completes.
CountDownLatch(int) - Constructor for class java.util.concurrent.CountDownLatch
Constructs a CountDownLatch initialized with the given count.
CountedCompleter<T> - Class in java.util.concurrent
A ForkJoinTask with a completion action performed when triggered and there are no remaining pending actions.
CountedCompleter(CountedCompleter<?>, int) - Constructor for class java.util.concurrent.CountedCompleter
Creates a new CountedCompleter with the given completer and initial pending count.
CountedCompleter(CountedCompleter<?>) - Constructor for class java.util.concurrent.CountedCompleter
Creates a new CountedCompleter with the given completer and an initial pending count of zero.
CountedCompleter() - Constructor for class java.util.concurrent.CountedCompleter
Creates a new CountedCompleter with no completer and an initial pending count of zero.
CounterMonitor - Class in javax.management.monitor
Defines a monitor MBean designed to observe the values of a counter attribute.
CounterMonitor() - Constructor for class javax.management.monitor.CounterMonitor
Default constructor.
CounterMonitorMBean - Interface in javax.management.monitor
Exposes the remote management interface of the counter monitor MBean.
counting() - Static method in class java.util.stream.Collectors
Returns a Collector accepting elements of type T that counts the number of input elements.
COUNTING_ROD_NUMERALS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Counting Rod Numerals" Unicode character block.
countItems() - Method in class java.awt.Choice
Deprecated.
As of JDK version 1.1, replaced by getItemCount().
countItems() - Method in class java.awt.List
Deprecated.
As of JDK version 1.1, replaced by getItemCount().
countItems() - Method in class java.awt.Menu
Deprecated.
As of JDK version 1.1, replaced by getItemCount().
countMenus() - Method in class java.awt.MenuBar
Deprecated.
As of JDK version 1.1, replaced by getMenuCount().
countObservers() - Method in class java.util.Observable
Returns the number of observers of this Observable object.
countStackFrames() - Method in class java.lang.Thread
Deprecated.
The definition of this call depends on Thread.suspend(), which is deprecated. Further, the results of this call were never well-defined.
countTokens() - Method in class java.util.StringTokenizer
Calculates the number of times that this tokenizer's nextToken method can be called before it generates an exception.
COVER - Static variable in class javax.print.attribute.standard.Finishings
This value is specified when it is desired to select a non-printed (or pre-printed) cover for the document.
COVER_OPEN - Static variable in class javax.print.attribute.standard.PrinterStateReason
One or more covers on the device are open.
CPE - Static variable in class javax.naming.spi.NamingManager
Constant that holds the name of the environment property into which getContinuationContext() stores the value of its CannotProceedException parameter.
crc - Variable in class java.util.zip.GZIPInputStream
CRC-32 for uncompressed data.
crc - Variable in class java.util.zip.GZIPOutputStream
CRC-32 of uncompressed data.
CRC32 - Class in java.util.zip
A class that can be used to compute the CRC-32 of a data stream.
CRC32() - Constructor for class java.util.zip.CRC32
Creates a new CRC32 object.
create() - Method in class java.awt.Graphics
Creates a new Graphics object that is a copy of this Graphics object.
create(int, int, int, int) - Method in class java.awt.Graphics
Creates a new Graphics object based on this Graphics object, but with a new translation and clip area.
create(RenderContext, ParameterBlock) - Method in interface java.awt.image.renderable.ContextualRenderedImageFactory
Creates a rendering, given a RenderContext and a ParameterBlock containing the operation's sources and parameters.
create(ParameterBlock, RenderingHints) - Method in interface java.awt.image.renderable.RenderedImageFactory
Creates a RenderedImage representing the results of an imaging operation (or chain of operations) for a given ParameterBlock and RenderingHints.
create(Class<T>, Object, String) - Static method in class java.beans.EventHandler
Creates an implementation of listenerInterface in which all of the methods in the listener interface apply the handler's action to the target.
create(Class<T>, Object, String, String) - Static method in class java.beans.EventHandler
/** Creates an implementation of listenerInterface in which all of the methods pass the value of the event expression, eventPropertyName, to the final method in the statement, action, which is applied to the target.
create(Class<T>, Object, String, String, String) - Static method in class java.beans.EventHandler
Creates an implementation of listenerInterface in which the method named listenerMethodName passes the value of the event expression, eventPropertyName, to the final method in the statement, action, which is applied to the target.
create() - Method in class java.net.DatagramSocketImpl
Creates a datagram socket.
create(boolean) - Method in class java.net.SocketImpl
Creates either a stream or a datagram socket.
create(String) - Static method in class java.net.URI
Creates a URI by parsing the given string.
create() - Method in class javax.swing.DebugGraphics
Overrides Graphics.create to return a DebugGraphics object.
create(int, int, int, int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.create to return a DebugGraphics object.
create(Element) - Method in class javax.swing.plaf.basic.BasicPasswordFieldUI
Creates a view (PasswordView) for an element.
create(Element) - Method in class javax.swing.plaf.basic.BasicTextAreaUI
Creates the view for an element.
create(Element) - Method in class javax.swing.plaf.basic.BasicTextFieldUI
Creates a view (FieldView) based on an element.
create(Element) - Method in class javax.swing.plaf.basic.BasicTextUI
Creates a view for an element.
create(Element, int, int) - Method in class javax.swing.plaf.basic.BasicTextUI
Creates a view for an element.
create(Element) - Method in class javax.swing.plaf.synth.SynthPasswordFieldUI
Creates a view (PasswordView) for an element.
create(DefaultStyledDocument.ElementSpec[]) - Method in class javax.swing.text.DefaultStyledDocument
Initialize the document to reflect the given element structure (i.e.
create(DefaultStyledDocument.ElementSpec[]) - Method in class javax.swing.text.html.HTMLDocument
Replaces the contents of the document with the given element specifications.
create(Element) - Method in class javax.swing.text.html.HTMLEditorKit.HTMLFactory
Creates a view from an element.
create(Element) - Method in interface javax.swing.text.ViewFactory
Creates a view from the given structural element of a document.
create(Name) - Method in class javax.xml.soap.SOAPElementFactory
Deprecated.
Use javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) instead
create(String) - Method in class javax.xml.soap.SOAPElementFactory
Deprecated.
Use javax.xml.soap.SOAPFactory.createElement(String localName) instead
create(String, String, String) - Method in class javax.xml.soap.SOAPElementFactory
Deprecated.
Use javax.xml.soap.SOAPFactory.createElement(String localName, String prefix, String uri) instead
create(Object) - Static method in class javax.xml.ws.Endpoint
Creates an endpoint with the specified implementor object.
create(Object, WebServiceFeature...) - Static method in class javax.xml.ws.Endpoint
Creates an endpoint with the specified implementor object and web service features.
create(String, Object) - Static method in class javax.xml.ws.Endpoint
Creates an endpoint with the specified binding type and implementor object.
create(String, Object, WebServiceFeature...) - Static method in class javax.xml.ws.Endpoint
Creates an endpoint with the specified binding type, implementor object, and web service features.
create(URL, QName) - Static method in class javax.xml.ws.Service
Creates a Service instance.
create(URL, QName, WebServiceFeature...) - Static method in class javax.xml.ws.Service
Creates a Service instance.
create(QName) - Static method in class javax.xml.ws.Service
Creates a Service instance.
create(QName, WebServiceFeature...) - Static method in class javax.xml.ws.Service
Creates a Service instance.
create_abstract_interface_tc(String, String) - Method in class org.omg.CORBA.ORB
Create a TypeCode object for an IDL abstract interface.
create_alias_tc(String, String, TypeCode) - Method in class org.omg.CORBA.ORB
Creates a TypeCode object representing an IDL alias (typedef).
create_any() - Method in class org.omg.CORBA.ORB
Creates an IDL Any object initialized to contain a Typecode object whose kind field is set to TCKind.tc_null.
create_array_tc(int, TypeCode) - Method in class org.omg.CORBA.ORB
Creates a TypeCode object representing an IDL array.
create_basic_dyn_any(TypeCode) - Method in class org.omg.CORBA.ORB
Deprecated.
Use the new DynAnyFactory API instead
create_child(String) - Method in class org.omg.CORBA.Context
Creates a Context object with the given string as its name and with this Context object set as its parent.
create_codec(Encoding) - Method in interface org.omg.IOP.CodecFactoryOperations
Create a Codec of the given encoding.
create_context_list() - Method in class org.omg.CORBA.ORB
Creates an empty ContextList object.
create_dyn_any(Any) - Method in class org.omg.CORBA.ORB
Deprecated.
Use the new DynAnyFactory API instead
create_dyn_any(Any) - Method in class org.omg.DynamicAny._DynAnyFactoryStub
Creates a new DynAny object from an any value.
create_dyn_any(Any) - Method in interface org.omg.DynamicAny.DynAnyFactoryOperations
Creates a new DynAny object from an any value.
create_dyn_any_from_type_code(TypeCode) - Method in class org.omg.DynamicAny._DynAnyFactoryStub
Creates a DynAny from a TypeCode.
create_dyn_any_from_type_code(TypeCode) - Method in interface org.omg.DynamicAny.DynAnyFactoryOperations
Creates a DynAny from a TypeCode.
create_dyn_array(TypeCode) - Method in class org.omg.CORBA.ORB
Deprecated.
Use the new DynAnyFactory API instead
create_dyn_enum(TypeCode) - Method in class org.omg.CORBA.ORB
Deprecated.
Use the new DynAnyFactory API instead
create_dyn_sequence(TypeCode) - Method in class org.omg.CORBA.ORB
Deprecated.
Use the new DynAnyFactory API instead
create_dyn_struct(TypeCode) - Method in class org.omg.CORBA.ORB
Deprecated.
Use the new DynAnyFactory API instead
create_dyn_union(TypeCode) - Method in class org.omg.CORBA.ORB
Deprecated.
Use the new DynAnyFactory API instead
create_enum_tc(String, String, String[]) - Method in class org.omg.CORBA.ORB
Creates a TypeCode object representing an IDL enum.
create_environment() - Method in class org.omg.CORBA.ORB
Creates an Environment object.
create_exception_list() - Method in class org.omg.CORBA.ORB
Creates an empty ExceptionList object.
create_exception_tc(String, String, StructMember[]) - Method in class org.omg.CORBA.ORB
Creates a TypeCode object representing an IDL exception.
create_fixed_tc(short, short) - Method in class org.omg.CORBA.ORB
Create a TypeCode object for an IDL fixed type.
create_id_assignment_policy(IdAssignmentPolicyValue) - Method in interface org.omg.PortableServer.POAOperations
These operations each return a reference to a policy object with the specified value.
create_id_uniqueness_policy(IdUniquenessPolicyValue) - Method in interface org.omg.PortableServer.POAOperations
These operations each return a reference to a policy object with the specified value.
create_implicit_activation_policy(ImplicitActivationPolicyValue) - Method in interface org.omg.PortableServer.POAOperations
These operations each return a reference to a policy object with the specified value.
create_input_stream() - Method in class org.omg.CORBA.Any
Creates an input stream from which this Any object's value can be unmarshalled.
create_input_stream() - Method in class org.omg.CORBA.portable.OutputStream
Returns an input stream with the same buffer.
create_interface_tc(String, String) - Method in class org.omg.CORBA.ORB
Creates a TypeCode object representing an IDL interface.
create_lifespan_policy(LifespanPolicyValue) - Method in interface org.omg.PortableServer.POAOperations
These operations each return a reference to a policy object with the specified value.
create_list(int) - Method in class org.omg.CORBA.ORB
Allocates an NVList with (probably) enough space for the specified number of NamedValue objects.
create_named_value(String, Any, int) - Method in class org.omg.CORBA.ORB
Creates a NamedValue object using the given name, value, and argument mode flags.
create_native_tc(String, String) - Method in class org.omg.CORBA.ORB
Create a TypeCode object for an IDL native type.
create_operation_list(Object) - Method in class org.omg.CORBA.ORB
Creates an NVList initialized with argument descriptions for the operation described in the given OperationDef object.
create_output_stream() - Method in class org.omg.CORBA.Any
Creates an output stream into which this Any object's value can be marshalled.
create_output_stream() - Method in class org.omg.CORBA.ORB
Creates a new org.omg.CORBA.portable.OutputStream into which IDL method parameters can be marshalled during method invocation.
create_POA(String, POAManager, Policy[]) - Method in interface org.omg.PortableServer.POAOperations
This operation creates a new POA as a child of the target POA.
create_policy(int, Any) - Method in class org.omg.CORBA.ORB
Can be invoked to create new instances of policy objects of a specific type with specified initial state.
create_policy(int, Any) - Method in interface org.omg.PortableInterceptor.PolicyFactoryOperations
Returns an instance of the appropriate interface derived from CORBA.Policy whose value corresponds to the specified any.
create_recursive_sequence_tc(int, int) - Method in class org.omg.CORBA.ORB
Deprecated.
Use a combination of create_recursive_tc and create_sequence_tc instead
create_recursive_tc(String) - Method in class org.omg.CORBA.ORB
Create a recursive TypeCode object which serves as a placeholder for a concrete TypeCode during the process of creating TypeCodes which contain recursion.
create_reference(String) - Method in interface org.omg.PortableServer.POAOperations
This operation creates an object reference that encapsulates a POA-generated Object Id value and the specified interface repository id.
create_reference_with_id(byte[], String) - Method in interface org.omg.PortableServer.POAOperations
This operation creates an object reference that encapsulates the specified Object Id and interface repository Id values.
create_request(Object, Context, String, NVList, NamedValue) - Method in class org.omg.CORBA.portable.Delegate
Creates a Request instance for use in the Dynamic Invocation Interface.
create_request(Object, Context, String, NVList, NamedValue, ExceptionList, ContextList) - Method in class org.omg.CORBA.portable.Delegate
Creates a Request instance for use in the Dynamic Invocation Interface.
create_request_processing_policy(RequestProcessingPolicyValue) - Method in interface org.omg.PortableServer.POAOperations
These operations each return a reference to a policy object with the specified value.
create_sequence_tc(int, TypeCode) - Method in class org.omg.CORBA.ORB
Creates a TypeCode object representing an IDL sequence.
create_servant_retention_policy(ServantRetentionPolicyValue) - Method in interface org.omg.PortableServer.POAOperations
These operations each return a reference to a policy object with the specified value.
create_string_tc(int) - Method in class org.omg.CORBA.ORB
Creates a TypeCode object representing a bounded IDL string.
create_struct_tc(String, String, StructMember[]) - Method in class org.omg.CORBA.ORB
Creates a TypeCode object representing an IDL struct.
create_thread_policy(ThreadPolicyValue) - Method in interface org.omg.PortableServer.POAOperations
These operations each return a reference to a policy object with the specified value.
create_union_tc(String, String, TypeCode, UnionMember[]) - Method in class org.omg.CORBA.ORB
Creates a TypeCode object representing an IDL union.
create_value_box_tc(String, String, TypeCode) - Method in class org.omg.CORBA.ORB
Creates a TypeCode object for an IDL value box.
create_value_tc(String, String, short, TypeCode, ValueMember[]) - Method in class org.omg.CORBA.ORB
Create a TypeCode object for an IDL value type.
create_wstring_tc(int) - Method in class org.omg.CORBA.ORB
Creates a TypeCode object representing a bounded IDL wstring (wide string).
createActionChangeListener(JMenuItem) - Method in class javax.swing.JMenu
Returns a properly configured PropertyChangeListener which updates the control as changes to the Action occur.
createActionChangeListener(JMenuItem) - Method in class javax.swing.JPopupMenu
Returns a properly configured PropertyChangeListener which updates the control as changes to the Action occur.
createActionChangeListener(JButton) - Method in class javax.swing.JToolBar
Returns a properly configured PropertyChangeListener which updates the control as changes to the Action occur, or null if the default property change listener for the control is desired.
createActionComponent(Action) - Method in class javax.swing.JMenu
Factory method which creates the JMenuItem for Actions added to the JMenu.
createActionComponent(Action) - Method in class javax.swing.JPopupMenu
Factory method which creates the JMenuItem for Actions added to the JPopupMenu.
createActionComponent(Action) - Method in class javax.swing.JToolBar
Factory method which creates the JButton for Actions added to the JToolBar.
createActionListener() - Method in class javax.swing.AbstractButton
createActionMap() - Method in class javax.swing.plaf.metal.MetalFileChooserUI
createActionPropertyChangeListener(Action) - Method in class javax.swing.AbstractButton
Creates and returns a PropertyChangeListener that is responsible for listening for changes from the specified Action and updating the appropriate properties.
createActionPropertyChangeListener(Action) - Method in class javax.swing.JComboBox
Creates and returns a PropertyChangeListener that is responsible for listening for changes from the specified Action and updating the appropriate properties.
createActionPropertyChangeListener(Action) - Method in class javax.swing.JTextField
Creates and returns a PropertyChangeListener that is responsible for listening for changes from the specified Action and updating the appropriate properties.
createActions() - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
createAndPublishEndpoint(String, Object) - Method in class javax.xml.ws.spi.Provider
Creates and publishes an endpoint object with the specified address and implementation object.
createAndPublishEndpoint(String, Object, WebServiceFeature...) - Method in class javax.xml.ws.spi.Provider
Creates and publishes an endpoint object with the specified address, implementation object and web service features.
createArrayOf(String, Object[]) - Method in interface java.sql.Connection
Factory method for creating Array objects.
createArrowButton() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Creates a button which will be used as the control to show or hide the popup portion of the combo box.
createArrowButton() - Method in class javax.swing.plaf.metal.MetalComboBoxUI
createArrowButton() - Method in class javax.swing.plaf.synth.SynthComboBoxUI
Creates a button which will be used as the control to show or hide the popup portion of the combo box.
createArrowButtonListener() - Method in class javax.swing.plaf.basic.BasicScrollBarUI
createAttachmentPart() - Method in class javax.xml.soap.SOAPMessage
Creates a new empty AttachmentPart object.
createAttachmentPart(DataHandler) - Method in class javax.xml.soap.SOAPMessage
Creates an AttachmentPart object and populates it using the given DataHandler object.
createAttachmentPart(Object, String) - Method in class javax.xml.soap.SOAPMessage
Creates an AttachmentPart object and populates it with the specified data of the specified content type.
createAttribute(String, String, String, String) - Method in class javax.xml.stream.XMLEventFactory
Create a new Attribute
createAttribute(String, String) - Method in class javax.xml.stream.XMLEventFactory
Create a new Attribute
createAttribute(QName, String) - Method in class javax.xml.stream.XMLEventFactory
Create a new Attribute
createAttribute(String) - Method in interface org.w3c.dom.Document
Creates an Attr of the given name.
createAttributeNS(String, String) - Method in interface org.w3c.dom.Document
Creates an attribute of the given qualified name and namespace URI.
createAudioAction(Object) - Method in class javax.swing.plaf.basic.BasicLookAndFeel
Creates and returns an Action used to play a sound.
createBackBuffers(int) - Method in class java.awt.Component.BltBufferStrategy
Creates the back buffers
createBanded(ColorSpace, int[], int[], int, boolean, boolean) - Static method in class javax.imageio.ImageTypeSpecifier
Returns a specifier for a banded image format that will use a ComponentColorModel and a BandedSampleModel to store each channel in a separate array.
createBandedRaster(int, int, int, int, Point) - Static method in class java.awt.image.Raster
Creates a Raster based on a BandedSampleModel with the specified data type, width, height, and number of bands.
createBandedRaster(int, int, int, int, int[], int[], Point) - Static method in class java.awt.image.Raster
Creates a Raster based on a BandedSampleModel with the specified data type, width, height, scanline stride, bank indices and band offsets.
createBandedRaster(DataBuffer, int, int, int, int[], int[], Point) - Static method in class java.awt.image.Raster
Creates a Raster based on a BandedSampleModel with the specified DataBuffer, width, height, scanline stride, bank indices, and band offsets.
createBaselineGroup(boolean, boolean) - Method in class javax.swing.GroupLayout
Creates and returns a ParallelGroup that aligns it's elements along the baseline.
createBCSChild(Object, Object) - Method in class java.beans.beancontext.BeanContextServicesSupport
Subclasses can override this method to insert their own subclass of Child without having to override add() or the other Collection methods that add children to the set.
createBCSChild(Object, Object) - Method in class java.beans.beancontext.BeanContextSupport
Subclasses can override this method to insert their own subclass of Child without having to override add() or the other Collection methods that add children to the set.
createBCSSServiceProvider(Class, BeanContextServiceProvider) - Method in class java.beans.beancontext.BeanContextServicesSupport
subclasses can override this method to create new subclasses of BCSSServiceProvider without having to override addService() in order to instantiate.
createBevelBorder(int) - Static method in class javax.swing.BorderFactory
Creates a beveled border of the specified type, using brighter shades of the component's current background color for highlighting, and darker shading for shadows.
createBevelBorder(int, Color, Color) - Static method in class javax.swing.BorderFactory
Creates a beveled border of the specified type, using the specified highlighting and shadowing.
createBevelBorder(int, Color, Color, Color, Color) - Static method in class javax.swing.BorderFactory
Creates a beveled border of the specified type, using the specified colors for the inner and outer highlight and shadow areas.
createBinder(Class<T>) - Method in class javax.xml.bind.JAXBContext
Creates a Binder object that can be used for associative/in-place unmarshalling/marshalling.
createBinder() - Method in class javax.xml.bind.JAXBContext
Creates a Binder for W3C DOM.
createBindings() - Method in interface javax.script.ScriptEngine
Returns an uninitialized Bindings.
createBlackLineBorder() - Static method in class javax.swing.border.LineBorder
Convenience method for getting the Color.black LineBorder of thickness 1.
createBlob() - Method in interface java.sql.Connection
Constructs an object that implements the Blob interface.
createBorderListener(JInternalFrame) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
createBorderListener(JInternalFrame) - Method in class javax.swing.plaf.metal.MetalInternalFrameUI
Returns the MouseInputAdapter that will be installed on the TitlePane.
createBranchElement(Element, AttributeSet) - Method in class javax.swing.text.AbstractDocument
Creates a document branch element, that can contain other elements.
createBranchElement(Element, AttributeSet) - Method in class javax.swing.text.html.HTMLDocument
Creates a document branch element, that can contain other elements.
createBufferedImage(int, int) - Method in class javax.imageio.ImageTypeSpecifier
Creates a BufferedImage with a given width and height according to the specification embodied in this object.
createBuffers(int, BufferCapabilities) - Method in class java.awt.Component.FlipBufferStrategy
Creates one or more complex, flipping buffers with the given capabilities.
createBufferStrategy(int) - Method in class java.awt.Canvas
Creates a new strategy for multi-buffering on this component.
createBufferStrategy(int, BufferCapabilities) - Method in class java.awt.Canvas
Creates a new strategy for multi-buffering on this component with the required buffer capabilities.
createBufferStrategy(int) - Method in class java.awt.Window
Creates a new strategy for multi-buffering on this component.
createBufferStrategy(int, BufferCapabilities) - Method in class java.awt.Window
Creates a new strategy for multi-buffering on this component with the required buffer capabilities.
createButton(Button) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of Button using the specified peer interface.
createButtonActionListener(int) - Method in class javax.swing.plaf.basic.BasicOptionPaneUI
createButtonArea() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI
Creates and returns a Container containing the buttons.
createButtonListener(AbstractButton) - Method in class javax.swing.plaf.basic.BasicButtonUI
createButtonListener(AbstractButton) - Method in class javax.swing.plaf.metal.MetalButtonUI
createButtons() - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
createButtons() - Method in class javax.swing.plaf.metal.MetalInternalFrameTitlePane
createCachedRowSet() - Method in interface javax.sql.rowset.RowSetFactory
Creates a new instance of a CachedRowSet.
createCanvas(Canvas) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of Canvas using the specified peer interface.
createCaret() - Method in class javax.swing.plaf.basic.BasicTextUI
Creates the object to use for a caret.
createCaret() - Method in class javax.swing.text.DefaultEditorKit
Fetches a caret that can navigate through views produced by the associated ViewFactory.
createCaret() - Method in class javax.swing.text.EditorKit
Fetches a caret that can navigate through views produced by the associated ViewFactory.
createCData(String) - Method in class javax.xml.stream.XMLEventFactory
Create a Characters event with the CData flag set to true
createCDATASection(String) - Method in interface org.w3c.dom.Document
Creates a CDATASection node whose value is the specified string.
createCellEditorListener() - Method in class javax.swing.plaf.basic.BasicTreeUI
Creates a listener to handle events from the current editor.
createCellRendererPane() - Method in class javax.swing.plaf.basic.BasicTreeUI
Returns the renderer pane that renderer components are placed in.
createChangeListener() - Method in class javax.swing.AbstractButton
Subclasses that want to handle ChangeEvents differently can override this to return another ChangeListener implementation.
createChangeListener() - Method in class javax.swing.JProgressBar
Subclasses that want to handle change events from the model differently can override this to return an instance of a custom ChangeListener implementation.
createChangeListener() - Method in class javax.swing.JSlider
Subclasses that want to handle ChangeEvents from the model differently can override this to return an instance of a custom ChangeListener implementation.
createChangeListener() - Method in class javax.swing.JTabbedPane
Subclasses that want to handle ChangeEvents differently can override this to return a subclass of ModelListener or another ChangeListener implementation.
createChangeListener() - Method in class javax.swing.plaf.basic.BasicMenuBarUI
createChangeListener(JComponent) - Method in class javax.swing.plaf.basic.BasicMenuUI
createChangeListener(JSlider) - Method in class javax.swing.plaf.basic.BasicSliderUI
createChangeListener() - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
createCharacters(String) - Method in class javax.xml.stream.XMLEventFactory
Create a Characters event, this method does not check if the content is all whitespace.
createCheckbox(Checkbox) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of Checkbox using the specified peer interface.
createCheckboxMenuItem(CheckboxMenuItem) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of CheckboxMenuItem using the specified peer interface.
createChild(int, int, int, int, int, int, int[]) - Method in class java.awt.image.Raster
Returns a new Raster which shares all or part of this Raster's DataBuffer.
createChildren(DefaultMutableTreeNode, Object) - Static method in class javax.swing.JTree.DynamicUtilTreeNode
Adds to parent all the children in children.
createChildState(View) - Method in class javax.swing.text.AsyncBoxView
New ChildState records are created through this method to allow subclasses the extend the ChildState records to do/hold more
createChoice(Choice) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of Choice using the specified peer interface.
createClassFile(CharSequence, Element...) - Method in interface javax.annotation.processing.Filer
Creates a new class file, and returns an object to allow writing to it.
createClob() - Method in interface java.sql.Connection
Constructs an object that implements the Clob interface.
createComment(String) - Method in class javax.xml.stream.XMLEventFactory
Create a comment
createComment(String) - Method in interface org.w3c.dom.Document
Creates a Comment node given the specified string.
createCompatibleDestImage(BufferedImage, ColorModel) - Method in class java.awt.image.AffineTransformOp
Creates a zeroed destination image with the correct size and number of bands.
createCompatibleDestImage(BufferedImage, ColorModel) - Method in interface java.awt.image.BufferedImageOp
Creates a zeroed destination image with the correct size and number of bands.
createCompatibleDestImage(BufferedImage, ColorModel) - Method in class java.awt.image.ColorConvertOp
Creates a zeroed destination image with the correct size and number of bands, given this source.
createCompatibleDestImage(BufferedImage, ColorModel) - Method in class java.awt.image.ConvolveOp
Creates a zeroed destination image with the correct size and number of bands.
createCompatibleDestImage(BufferedImage, ColorModel) - Method in class java.awt.image.LookupOp
Creates a zeroed destination image with the correct size and number of bands.
createCompatibleDestImage(BufferedImage, ColorModel) - Method in class java.awt.image.RescaleOp
Creates a zeroed destination image with the correct size and number of bands.
createCompatibleDestRaster(Raster) - Method in class java.awt.image.AffineTransformOp
Creates a zeroed destination Raster with the correct size and number of bands.
createCompatibleDestRaster(Raster) - Method in class java.awt.image.BandCombineOp
Creates a zeroed destination Raster with the correct size and number of bands.
createCompatibleDestRaster(Raster) - Method in class java.awt.image.ColorConvertOp
Creates a zeroed destination Raster with the correct size and number of bands, given this source.
createCompatibleDestRaster(Raster) - Method in class java.awt.image.ConvolveOp
Creates a zeroed destination Raster with the correct size and number of bands, given this source.
createCompatibleDestRaster(Raster) - Method in class java.awt.image.LookupOp
Creates a zeroed-destination Raster with the correct size and number of bands, given this source.
createCompatibleDestRaster(Raster) - Method in interface java.awt.image.RasterOp
Creates a zeroed destination Raster with the correct size and number of bands.
createCompatibleDestRaster(Raster) - Method in class java.awt.image.RescaleOp
Creates a zeroed-destination Raster with the correct size and number of bands, given this source.
createCompatibleImage(int, int) - Method in class java.awt.GraphicsConfiguration
Returns a BufferedImage with a data layout and color model compatible with this GraphicsConfiguration.
createCompatibleImage(int, int, int) - Method in class java.awt.GraphicsConfiguration
Returns a BufferedImage that supports the specified transparency and has a data layout and color model compatible with this GraphicsConfiguration.
createCompatibleSampleModel(int, int) - Method in class java.awt.image.BandedSampleModel
Creates a new BandedSampleModel with the specified width and height.
createCompatibleSampleModel(int, int) - Method in class java.awt.image.ColorModel
Creates a SampleModel with the specified width and height that has a data layout compatible with this ColorModel.
createCompatibleSampleModel(int, int) - Method in class java.awt.image.ComponentColorModel
Creates a SampleModel with the specified width and height, that has a data layout compatible with this ColorModel.
createCompatibleSampleModel(int, int) - Method in class java.awt.image.ComponentSampleModel
Creates a new ComponentSampleModel with the specified width and height.
createCompatibleSampleModel(int, int) - Method in class java.awt.image.IndexColorModel
Creates a SampleModel with the specified width and height that has a data layout compatible with this ColorModel.
createCompatibleSampleModel(int, int) - Method in class java.awt.image.MultiPixelPackedSampleModel
Creates a new MultiPixelPackedSampleModel with the specified width and height.
createCompatibleSampleModel(int, int) - Method in class java.awt.image.PackedColorModel
Creates a SampleModel with the specified width and height that has a data layout compatible with this ColorModel.
createCompatibleSampleModel(int, int) - Method in class java.awt.image.PixelInterleavedSampleModel
Creates a new PixelInterleavedSampleModel with the specified width and height.
createCompatibleSampleModel(int, int) - Method in class java.awt.image.SampleModel
Creates a SampleModel which describes data in this SampleModel's format, but with a different width and height.
createCompatibleSampleModel(int, int) - Method in class java.awt.image.SinglePixelPackedSampleModel
Creates a new SinglePixelPackedSampleModel with the specified width and height.
createCompatibleVolatileImage(int, int) - Method in class java.awt.GraphicsConfiguration
Returns a VolatileImage with a data layout and color model compatible with this GraphicsConfiguration.
createCompatibleVolatileImage(int, int, int) - Method in class java.awt.GraphicsConfiguration
Returns a VolatileImage with a data layout and color model compatible with this GraphicsConfiguration.
createCompatibleVolatileImage(int, int, ImageCapabilities) - Method in class java.awt.GraphicsConfiguration
Returns a VolatileImage with a data layout and color model compatible with this GraphicsConfiguration, using the specified image capabilities.
createCompatibleVolatileImage(int, int, ImageCapabilities, int) - Method in class java.awt.GraphicsConfiguration
Returns a VolatileImage with a data layout and color model compatible with this GraphicsConfiguration, using the specified image capabilities and transparency value.
createCompatibleWritableRaster(int, int) - Method in class java.awt.image.ColorModel
Creates a WritableRaster with the specified width and height that has a data layout (SampleModel) compatible with this ColorModel.
createCompatibleWritableRaster(int, int) - Method in class java.awt.image.ComponentColorModel
Creates a WritableRaster with the specified width and height, that has a data layout (SampleModel) compatible with this ColorModel.
createCompatibleWritableRaster(int, int) - Method in class java.awt.image.DirectColorModel
Creates a WritableRaster with the specified width and height that has a data layout (SampleModel) compatible with this ColorModel.
createCompatibleWritableRaster(int, int) - Method in class java.awt.image.IndexColorModel
Creates a WritableRaster with the specified width and height that has a data layout (SampleModel) compatible with this ColorModel.
createCompatibleWritableRaster() - Method in class java.awt.image.Raster
Create a compatible WritableRaster the same size as this Raster with the same SampleModel and a new initialized DataBuffer.
createCompatibleWritableRaster(int, int) - Method in class java.awt.image.Raster
Create a compatible WritableRaster with the specified size, a new SampleModel, and a new initialized DataBuffer.
createCompatibleWritableRaster(Rectangle) - Method in class java.awt.image.Raster
Create a compatible WritableRaster with location (minX, minY) and size (width, height) specified by rect, a new SampleModel, and a new initialized DataBuffer.
createCompatibleWritableRaster(int, int, int, int) - Method in class java.awt.image.Raster
Create a compatible WritableRaster with the specified location (minX, minY) and size (width, height), a new SampleModel, and a new initialized DataBuffer.
createComponent(Component) - Method in class java.awt.Toolkit
Creates a peer for a component or container.
createComponent() - Method in class javax.swing.text.ComponentView
Create the component that is associated with this view.
createComponent() - Method in class javax.swing.text.html.FormView
Create the component.
createComponent() - Method in class javax.swing.text.html.ObjectView
Create the component.
createComponentListener() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
createComponentListener(JSlider) - Method in class javax.swing.plaf.basic.BasicSliderUI
createComponentListener() - Method in class javax.swing.plaf.basic.BasicTreeUI
Creates and returns a new ComponentHandler.
createComponentListener() - Method in class javax.swing.plaf.synth.SynthInternalFrameUI
createCompoundBorder() - Static method in class javax.swing.BorderFactory
Creates a compound border with a null inside edge and a null outside edge.
createCompoundBorder(Border, Border) - Static method in class javax.swing.BorderFactory
Creates a compound border specifying the border objects to use for the outside and inside edges.
createCompoundEdit() - Method in class javax.swing.undo.UndoableEditSupport
Called only from beginUpdate.
createConnection() - Method in class javax.xml.soap.SOAPConnectionFactory
Create a new SOAPConnection.
createContainer() - Method in class javax.swing.tree.DefaultTreeCellEditor
Creates the container to manage placement of editingComponent.
createContainerListener() - Method in class javax.swing.plaf.basic.BasicMenuBarUI
createContainerListener() - Method in class javax.swing.plaf.metal.MetalToolBarUI
Creates a container listener that will be added to the JToolBar.
createContentHandler(String) - Method in interface java.net.ContentHandlerFactory
Creates a new ContentHandler to read an object from a URLStreamHandler.
createContentPane() - Method in class javax.swing.JRootPane
Called by the constructor methods to create the default contentPane.
createContext(ColorModel, ColorModel, RenderingHints) - Method in class java.awt.AlphaComposite
Creates a context for the compositing operation.
createContext(ColorModel, Rectangle, Rectangle2D, AffineTransform, RenderingHints) - Method in class java.awt.Color
Creates and returns a PaintContext used to generate a solid color field pattern.
createContext(ColorModel, ColorModel, RenderingHints) - Method in interface java.awt.Composite
Creates a context containing state that is used to perform the compositing operation.
createContext(ColorModel, Rectangle, Rectangle2D, AffineTransform, RenderingHints) - Method in class java.awt.GradientPaint
Creates and returns a PaintContext used to generate a linear color gradient pattern.
createContext(ColorModel, Rectangle, Rectangle2D, AffineTransform, RenderingHints) - Method in class java.awt.LinearGradientPaint
Creates and returns a PaintContext used to generate a linear color gradient pattern.
createContext(ColorModel, Rectangle, Rectangle2D, AffineTransform, RenderingHints) - Method in interface java.awt.Paint
Creates and returns a PaintContext used to generate the color pattern.
createContext(ColorModel, Rectangle, Rectangle2D, AffineTransform, RenderingHints) - Method in class java.awt.RadialGradientPaint
Creates and returns a PaintContext used to generate a circular radial color gradient pattern.
createContext(ColorModel, Rectangle, Rectangle2D, AffineTransform, RenderingHints) - Method in class java.awt.TexturePaint
Creates and returns a PaintContext used to generate a tiled image pattern.
createContext(GSSName, Oid, GSSCredential, int) - Method in class org.ietf.jgss.GSSManager
Factory method for creating a context on the initiator's side.
createContext(GSSCredential) - Method in class org.ietf.jgss.GSSManager
Factory method for creating a context on the acceptor' side.
createContext(byte[]) - Method in class org.ietf.jgss.GSSManager
Factory method for creating a previously exported context.
createCopy() - Method in interface javax.sql.rowset.CachedRowSet
Creates a RowSet object that is a deep copy of the data in this CachedRowSet object.
createCopyNoConstraints() - Method in interface javax.sql.rowset.CachedRowSet
Creates a CachedRowSet object that is a deep copy of this CachedRowSet object's data but is independent of it.
createCopySchema() - Method in interface javax.sql.rowset.CachedRowSet
Creates a CachedRowSet object that is an empty copy of this CachedRowSet object.
createCredential(int) - Method in class org.ietf.jgss.GSSManager
Factory method for acquiring default credentials.
createCredential(GSSName, int, Oid, int) - Method in class org.ietf.jgss.GSSManager
Factory method for acquiring a single mechanism credential.
createCredential(GSSName, int, Oid[], int) - Method in class org.ietf.jgss.GSSManager
Factory method for acquiring credentials over a set of mechanisms.
createCustomCursor(Image, Point, String) - Method in class java.awt.Toolkit
Creates a new custom cursor object.
createDashedBorder(Paint) - Static method in class javax.swing.BorderFactory
Creates a dashed border of the specified paint.
createDashedBorder(Paint, float, float) - Static method in class javax.swing.BorderFactory
Creates a dashed border of the specified paint, relative length, and relative spacing.
createDashedBorder(Paint, float, float, float, boolean) - Static method in class javax.swing.BorderFactory
Creates a dashed border of the specified paint, thickness, line shape, relative length, and relative spacing.
createDataBuffer() - Method in class java.awt.image.BandedSampleModel
Creates a DataBuffer that corresponds to this BandedSampleModel, The DataBuffer's data type, number of banks, and size will be consistent with this BandedSampleModel.
createDataBuffer() - Method in class java.awt.image.ComponentSampleModel
Creates a DataBuffer that corresponds to this ComponentSampleModel.
createDataBuffer() - Method in class java.awt.image.MultiPixelPackedSampleModel
Creates a DataBuffer that corresponds to this MultiPixelPackedSampleModel.
createDataBuffer() - Method in class java.awt.image.SampleModel
Creates a DataBuffer that corresponds to this SampleModel.
createDataBuffer() - Method in class java.awt.image.SinglePixelPackedSampleModel
Creates a DataBuffer that corresponds to this SinglePixelPackedSampleModel.
createDataContentHandler(String) - Method in class javax.activation.CommandMap
Locate a DataContentHandler that corresponds to the MIME type.
createDataContentHandler(String, DataSource) - Method in class javax.activation.CommandMap
Locate a DataContentHandler that corresponds to the MIME type.
createDataContentHandler(String) - Method in interface javax.activation.DataContentHandlerFactory
Creates a new DataContentHandler object for the MIME type.
createDataContentHandler(String) - Method in class javax.activation.MailcapCommandMap
Return the DataContentHandler for the specified MIME type.
createDatagramSocketImpl() - Method in interface java.net.DatagramSocketImplFactory
Creates a new DatagramSocketImpl instance.
createDateTime(LocalDateTime, ZoneOffset, ZoneOffset) - Method in enum java.time.zone.ZoneOffsetTransitionRule.TimeDefinition
Converts the specified local date-time to the local date-time actually seen on a wall clock.
createdCellEditor - Variable in class javax.swing.plaf.basic.BasicTreeUI
Set to true if editor that is currently in the tree was created by this instance.
createDecreaseButton(int) - Method in class javax.swing.plaf.basic.BasicScrollBarUI
createDecreaseButton(int) - Method in class javax.swing.plaf.metal.MetalScrollBarUI
Returns the view that represents the decrease view.
createDecreaseButton(int) - Method in class javax.swing.plaf.synth.SynthScrollBarUI
createDefaultCellEditor() - Method in class javax.swing.plaf.basic.BasicTreeUI
Creates a default cell editor.
createDefaultCellEditor() - Method in class javax.swing.plaf.synth.SynthTreeUI
Creates a default cell editor.
createDefaultCellRenderer() - Method in class javax.swing.plaf.basic.BasicTreeUI
Returns the default cell renderer that is used to do the stamping of each node.
createDefaultCellRenderer() - Method in class javax.swing.plaf.synth.SynthTreeUI
Returns the default cell renderer that is used to do the stamping of each node.
createDefaultChoosers() - Method in class javax.swing.plaf.basic.BasicColorChooserUI
createDefaultChoosers() - Method in class javax.swing.plaf.synth.SynthColorChooserUI
createDefaultColumnModel() - Method in class javax.swing.JTable
Returns the default column model object, which is a DefaultTableColumnModel.
createDefaultColumnModel() - Method in class javax.swing.table.JTableHeader
Returns the default column model object which is a DefaultTableColumnModel.
createDefaultColumnsFromModel() - Method in class javax.swing.JTable
Creates default columns for the table from the data model using the getColumnCount method defined in the TableModel interface.
createDefaultDataModel() - Method in class javax.swing.JTable
Returns the default table model object, which is a DefaultTableModel.
createDefaultDivider() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Creates the default divider.
createDefaultDivider() - Method in class javax.swing.plaf.metal.MetalSplitPaneUI
Creates the default divider.
createDefaultDivider() - Method in class javax.swing.plaf.synth.SynthSplitPaneUI
Creates the default divider.
createDefaultDocument() - Method in class javax.swing.text.DefaultEditorKit
Creates an uninitialized text storage model (PlainDocument) that is appropriate for this type of editor.
createDefaultDocument() - Method in class javax.swing.text.EditorKit
Creates an uninitialized text storage model that is appropriate for this type of editor.
createDefaultDocument() - Method in class javax.swing.text.html.HTMLEditorKit
Create an uninitialized text storage model that is appropriate for this type of editor.
createDefaultDocument() - Method in class javax.swing.text.StyledEditorKit
Creates an uninitialized text storage model that is appropriate for this type of editor.
createDefaultDragGestureRecognizer(Component, int, DragGestureListener) - Method in class java.awt.dnd.DragSource
Creates a new DragGestureRecognizer that implements the default abstract subclass of DragGestureRecognizer for this DragSource, and sets the specified Component and DragGestureListener on the newly created object.
createDefaultEditorKit() - Method in class javax.swing.JEditorPane
Creates the default editor kit (PlainEditorKit) for when the component is first created.
createDefaultEditorKit() - Method in class javax.swing.JTextPane
Creates the EditorKit to use by default.
createDefaultEditors() - Method in class javax.swing.JTable
Creates default cell editors for objects, numbers, and boolean values.
createDefaultHeaderRenderer() - Method in class javax.swing.table.TableColumn
As of Java 2 platform v1.3, this method is not called by the TableColumn constructor.
createDefaultKeySelectionManager() - Method in class javax.swing.JComboBox
Returns an instance of the default key-selection manager.
createDefaultModel() - Method in class javax.swing.JTextArea
Creates the default implementation of the model to be used at construction if one isn't explicitly given.
createDefaultModel() - Method in class javax.swing.JTextField
Creates the default implementation of the model to be used at construction if one isn't explicitly given.
createDefaultNonContinuousLayoutDivider() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Returns the default non continuous layout divider, which is an instance of Canvas that fills in the background with dark gray.
createDefaultNonContinuousLayoutDivider() - Method in class javax.swing.plaf.synth.SynthSplitPaneUI
Returns the default non continuous layout divider, which is an instance of Canvas that fills in the background with dark gray.
createDefaultRenderer() - Method in class javax.swing.table.JTableHeader
Returns a default renderer to be used when no header renderer is defined by a TableColumn.
createDefaultRenderers() - Method in class javax.swing.JTable
Creates default cell renderers for objects, numbers, doubles, dates, booleans, and icons.
createDefaultRendering() - Method in interface java.awt.image.renderable.RenderableImage
Returnd a RenderedImage instance of this image with a default width and height in pixels.
createDefaultRendering() - Method in class java.awt.image.renderable.RenderableImageOp
Gets a RenderedImage instance of this image with a default width and height in pixels.
createDefaultRoot() - Method in class javax.swing.text.DefaultStyledDocument
Creates the root element to be used to represent the default document structure.
createDefaultRoot() - Method in class javax.swing.text.html.HTMLDocument
Creates the root element to be used to represent the default document structure.
createDefaultRoot() - Method in class javax.swing.text.PlainDocument
Creates the root element to be used to represent the default document structure.
createDefaultSelectionModel() - Method in class javax.swing.JTable
Returns the default selection model object, which is a DefaultListSelectionModel.
createDefaultTableHeader() - Method in class javax.swing.JTable
Returns the default table header object, which is a JTableHeader.
createDefaultTheme() - Method in class javax.swing.plaf.metal.MetalLookAndFeel
Ensures the current MetalTheme is non-null.
createDesktopManager() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
createDesktopPeer(Desktop) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of the Desktop using the specified peer interface.
createDetail() - Method in class javax.xml.soap.SOAPFactory
Creates a new Detail object which serves as a container for DetailEntry objects.
createDetailsView(JFileChooser) - Method in class javax.swing.plaf.metal.MetalFileChooserUI
createDialog(Dialog) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of Dialog using the specified peer interface.
createDialog(Component, String, boolean, JColorChooser, ActionListener, ActionListener) - Static method in class javax.swing.JColorChooser
Creates and returns a new dialog containing the specified ColorChooser pane along with "OK", "Cancel", and "Reset" buttons.
createDialog(Component) - Method in class javax.swing.JFileChooser
Creates and returns a new JDialog wrapping this centered on the parent in the parent's frame.
createDialog(Component, String) - Method in class javax.swing.JOptionPane
Creates and returns a new JDialog wrapping this centered on the parentComponent in the parentComponent's frame.
createDialog(String) - Method in class javax.swing.JOptionPane
Creates and returns a new parentless JDialog with the specified title.
createDirectories(Path, FileAttribute<?>...) - Static method in class java.nio.file.Files
Creates a directory by creating all nonexistent parent directories first.
createDirectory(Path, FileAttribute<?>...) - Static method in class java.nio.file.Files
Creates a new directory.
createDirectory(Path, FileAttribute<?>...) - Method in class java.nio.file.spi.FileSystemProvider
Creates a new directory.
createDirectoryComboBoxModel(JFileChooser) - Method in class javax.swing.plaf.metal.MetalFileChooserUI
createDirectoryComboBoxRenderer(JFileChooser) - Method in class javax.swing.plaf.metal.MetalFileChooserUI
createDisabledImage(Image) - Static method in class javax.swing.GrayFilter
Creates a disabled image
createDispatch(QName, Class<T>, Service.Mode) - Method in class javax.xml.ws.Service
Creates a Dispatch instance for use with objects of the client's choosing.
createDispatch(QName, Class<T>, Service.Mode, WebServiceFeature...) - Method in class javax.xml.ws.Service
Creates a Dispatch instance for use with objects of the client's choosing.
createDispatch(EndpointReference, Class<T>, Service.Mode, WebServiceFeature...) - Method in class javax.xml.ws.Service
Creates a Dispatch instance for use with objects of the client's choosing.
createDispatch(QName, JAXBContext, Service.Mode) - Method in class javax.xml.ws.Service
Creates a Dispatch instance for use with JAXB generated objects.
createDispatch(QName, JAXBContext, Service.Mode, WebServiceFeature...) - Method in class javax.xml.ws.Service
Creates a Dispatch instance for use with JAXB generated objects.
createDispatch(EndpointReference, JAXBContext, Service.Mode, WebServiceFeature...) - Method in class javax.xml.ws.Service
Creates a Dispatch instance for use with JAXB generated objects.
createDispatch(QName, Class<T>, Service.Mode) - Method in class javax.xml.ws.spi.ServiceDelegate
Creates a Dispatch instance for use with objects of the user's choosing.
createDispatch(QName, Class<T>, Service.Mode, WebServiceFeature...) - Method in class javax.xml.ws.spi.ServiceDelegate
Creates a Dispatch instance for use with objects of the user's choosing.
createDispatch(EndpointReference, Class<T>, Service.Mode, WebServiceFeature...) - Method in class javax.xml.ws.spi.ServiceDelegate
Creates a Dispatch instance for use with objects of the user's choosing.
createDispatch(QName, JAXBContext, Service.Mode) - Method in class javax.xml.ws.spi.ServiceDelegate
Creates a Dispatch instance for use with JAXB generated objects.
createDispatch(QName, JAXBContext, Service.Mode, WebServiceFeature...) - Method in class javax.xml.ws.spi.ServiceDelegate
Creates a Dispatch instance for use with JAXB generated objects.
createDispatch(EndpointReference, JAXBContext, Service.Mode, WebServiceFeature...) - Method in class javax.xml.ws.spi.ServiceDelegate
Creates a Dispatch instance for use with JAXB generated objects.
createDockingListener() - Method in class javax.swing.plaf.basic.BasicToolBarUI
createDockingListener() - Method in class javax.swing.plaf.metal.MetalToolBarUI
createDocument(String, String, DocumentType) - Method in interface org.w3c.dom.DOMImplementation
Creates a DOM Document object of the specified type with its document element.
createDocumentFragment() - Method in interface org.w3c.dom.Document
Creates an empty DocumentFragment object.
createDocumentType(String, String, String) - Method in interface org.w3c.dom.DOMImplementation
Creates an empty DocumentType node.
createDoubleClickListener(JFileChooser, JList) - Method in class javax.swing.plaf.basic.BasicFileChooserUI
createDragGestureRecognizer(Class<T>, Component, int, DragGestureListener) - Method in class java.awt.dnd.DragSource
Creates a new DragGestureRecognizer that implements the specified abstract subclass of DragGestureRecognizer, and sets the specified Component and DragGestureListener on the newly created object.
createDragGestureRecognizer(Class<T>, DragSource, Component, int, DragGestureListener) - Method in class java.awt.Toolkit
Creates a concrete, platform dependent, subclass of the abstract DragGestureRecognizer class requested, and associates it with the DragSource, Component and DragGestureListener specified.
createDragSourceContext(DragSourceContextPeer, DragGestureEvent, Cursor, Image, Point, Transferable, DragSourceListener) - Method in class java.awt.dnd.DragSource
Creates the DragSourceContext to handle the current drag operation.
createDragSourceContextPeer(DragGestureEvent) - Method in class java.awt.Toolkit
Creates the peer for a DragSourceContext.
createDragWindow(JToolBar) - Method in class javax.swing.plaf.basic.BasicToolBarUI
createdRenderer - Variable in class javax.swing.plaf.basic.BasicTreeUI
Set to true if the renderer that is currently in the tree was created by this instance.
createDropTargetAutoScroller(Component, Point) - Method in class java.awt.dnd.DropTarget
create an embedded autoscroller
createDropTargetContext() - Method in class java.awt.dnd.DropTarget
Creates the DropTargetContext associated with this DropTarget.
createDTD(DTD, String) - Static method in class javax.swing.text.html.parser.ParserDelegator
createDTD(String) - Method in class javax.xml.stream.XMLEventFactory
Create a document type definition event This string contains the entire document type declaration that matches the doctypedecl in the XML 1.0 specification
createEastPane(JInternalFrame) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
createEditor(SpinnerModel) - Method in class javax.swing.JSpinner
This method is called by the constructors to create the JComponent that displays the current value of the sequence.
createEditor() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Creates the default editor that will be used in editable combo boxes.
createEditor() - Method in class javax.swing.plaf.basic.BasicSpinnerUI
This method is called by installUI to get the editor component of the JSpinner.
createEditor() - Method in class javax.swing.plaf.metal.MetalComboBoxUI
createEditor() - Method in class javax.swing.plaf.synth.SynthComboBoxUI
Creates the default editor that will be used in editable combo boxes.
createEditor() - Method in class javax.swing.plaf.synth.SynthSpinnerUI
This method is called by installUI to get the editor component of the JSpinner.
createEditorComponent() - Method in class javax.swing.plaf.basic.BasicComboBoxEditor
Creates the internal editor component.
createEditorKitForContentType(String) - Static method in class javax.swing.JEditorPane
Creates a handler for the given type from the default registry of editor kits.
createElement(Element) - Method in class javax.xml.soap.SOAPFactory
Creates a SOAPElement object from an existing DOM Element.
createElement(Name) - Method in class javax.xml.soap.SOAPFactory
Creates a SOAPElement object initialized with the given Name object.
createElement(QName) - Method in class javax.xml.soap.SOAPFactory
Creates a SOAPElement object initialized with the given QName object.
createElement(String) - Method in class javax.xml.soap.SOAPFactory
Creates a SOAPElement object initialized with the given local name.
createElement(String, String, String) - Method in class javax.xml.soap.SOAPFactory
Creates a new SOAPElement object with the given local name, prefix and uri.
createElement(String) - Method in interface org.w3c.dom.Document
Creates an element of the type specified.
createElementNS(String, String) - Method in interface org.w3c.dom.Document
Creates an element of the given qualified name and namespace URI.
createEmptyBorder() - Static method in class javax.swing.BorderFactory
Creates an empty border that takes up no space.
createEmptyBorder(int, int, int, int) - Static method in class javax.swing.BorderFactory
Creates an empty border that takes up space but which does no drawing, specifying the width of the top, left, bottom, and right sides.
createEmptyFrameIcon() - Static method in class javax.swing.plaf.basic.BasicIconFactory
createEndDocument() - Method in class javax.xml.stream.XMLEventFactory
Creates a new instance of an EndDocument event
createEndElement(QName, Iterator) - Method in class javax.xml.stream.XMLEventFactory
Create a new EndElement
createEndElement(String, String, String) - Method in class javax.xml.stream.XMLEventFactory
Create a new EndElement
createEndElement(String, String, String, Iterator) - Method in class javax.xml.stream.XMLEventFactory
Create a new EndElement
createEndpoint(String, Object) - Method in class javax.xml.ws.spi.Provider
Creates an endpoint object with the provided binding and implementation object.
createEndpoint(String, Object, WebServiceFeature...) - Method in class javax.xml.ws.spi.Provider
Creates an endpoint object with the provided binding, implementation object and web service features.
createEndpoint(String, Class<?>, Invoker, WebServiceFeature...) - Method in class javax.xml.ws.spi.Provider
Creates an endpoint object with the provided binding, implementation class, invoker and web service features.
createEntityReference(String, EntityDeclaration) - Method in class javax.xml.stream.XMLEventFactory
Creates a new instance of a EntityReference event
createEntityReference(String) - Method in interface org.w3c.dom.Document
Creates an EntityReference object.
createEtchedBorder() - Static method in class javax.swing.BorderFactory
Creates a border with an "etched" look using the component's current background color for highlighting and shading.
createEtchedBorder(Color, Color) - Static method in class javax.swing.BorderFactory
Creates a border with an "etched" look using the specified highlighting and shading colors.
createEtchedBorder(int) - Static method in class javax.swing.BorderFactory
Creates a border with an "etched" look using the component's current background color for highlighting and shading.
createEtchedBorder(int, Color, Color) - Static method in class javax.swing.BorderFactory
Creates a border with an "etched" look using the specified highlighting and shading colors.
createEvent(String) - Method in interface org.w3c.dom.events.DocumentEvent
createExceptionReply() - Method in interface org.omg.CORBA.portable.ResponseHandler
Called by the servant during a method invocation.
createExtendedResponse(String, byte[], int, int) - Method in interface javax.naming.ldap.ExtendedRequest
Creates the response object that corresponds to this request.
createExtendedResponse(String, byte[], int, int) - Method in class javax.naming.ldap.StartTlsRequest
Creates an extended response object that corresponds to the LDAP StartTLS extended request.
createFault(String, QName) - Method in class javax.xml.soap.SOAPFactory
Creates a new SOAPFault object initialized with the given reasonText and faultCode
createFault() - Method in class javax.xml.soap.SOAPFactory
Creates a new default SOAPFault object
createFile(Path, FileAttribute<?>...) - Static method in class java.nio.file.Files
Creates a new and empty file, failing if the file already exists.
createFileDialog(FileDialog) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of FileDialog using the specified peer interface.
createFileObject(File, String) - Method in class javax.swing.filechooser.FileSystemView
Returns a File object constructed in dir from the given filename.
createFileObject(String) - Method in class javax.swing.filechooser.FileSystemView
Returns a File object constructed from the given path string.
createFileSystemRoot(File) - Method in class javax.swing.filechooser.FileSystemView
Creates a new File object for f with correct behavior for a file system root directory.
createFilterComboBoxModel() - Method in class javax.swing.plaf.metal.MetalFileChooserUI
createFilterComboBoxRenderer() - Method in class javax.swing.plaf.metal.MetalFileChooserUI
createFilteredReader(XMLStreamReader, StreamFilter) - Method in class javax.xml.stream.XMLInputFactory
Create a filtered reader that wraps the filter around the reader
createFilteredReader(XMLEventReader, EventFilter) - Method in class javax.xml.stream.XMLInputFactory
Create a filtered event reader that wraps the filter around the event reader
createFilteredRowSet() - Method in interface javax.sql.rowset.RowSetFactory
Creates a new instance of a FilteredRowSet.
createFloatingFrame(JToolBar) - Method in class javax.swing.plaf.basic.BasicToolBarUI
No longer used, use BasicToolBarUI.createFloatingWindow(JToolBar)
createFloatingWindow(JToolBar) - Method in class javax.swing.plaf.basic.BasicToolBarUI
Creates a window which contains the toolbar after it has been dragged out from its container
createFocusListener() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Creates a FocusListener which will be added to the combo box.
createFocusListener() - Method in class javax.swing.plaf.basic.BasicListUI
createFocusListener(JSlider) - Method in class javax.swing.plaf.basic.BasicSliderUI
createFocusListener() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Creates a FocusListener for the JSplitPane UI.
createFocusListener() - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
createFocusListener() - Method in class javax.swing.plaf.basic.BasicTableUI
Creates the focus listener for handling keyboard navigation in the JTable.
createFocusListener() - Method in class javax.swing.plaf.basic.BasicTreeUI
Creates a listener that is responsible for updating the display when focus is lost/gained.
createFont(int, InputStream) - Static method in class java.awt.Font
Returns a new Font using the specified font type and input data.
createFont(int, File) - Static method in class java.awt.Font
Returns a new Font using the specified font type and the specified font file.
createFragment(int, int) - Method in class javax.swing.text.GlyphView
Creates a view that represents a portion of the element.
createFragment(int, int) - Method in class javax.swing.text.View
Creates a view that represents a portion of the element.
createFrame(Frame) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of Frame using the specified peer interface.
createFrameListener() - Method in class javax.swing.plaf.basic.BasicToolBarUI
createFromBufferedImageType(int) - Static method in class javax.imageio.ImageTypeSpecifier
Returns an ImageTypeSpecifier that encodes one of the standard BufferedImage types (other than TYPE_CUSTOM).
createFromRenderedImage(RenderedImage) - Static method in class javax.imageio.ImageTypeSpecifier
Returns an ImageTypeSpecifier that encodes the layout of a RenderedImage (which may be a BufferedImage).
createGlassPane() - Method in class javax.swing.JLayer
Called by the constructor methods to create a default glassPane.
createGlassPane() - Method in class javax.swing.JRootPane
Called by the constructor methods to create the default glassPane.
createGlassPaneDispatcher() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
createGlue() - Static method in class javax.swing.Box
Creates an invisible "glue" component that can be useful in a Box whose visible components have a maximum width (for a horizontal box) or height (for a vertical box).
createGlyphVector(FontRenderContext, String) - Method in class java.awt.Font
Creates a GlyphVector by mapping characters to glyphs one-to-one based on the Unicode cmap in this Font.
createGlyphVector(FontRenderContext, char[]) - Method in class java.awt.Font
Creates a GlyphVector by mapping characters to glyphs one-to-one based on the Unicode cmap in this Font.
createGlyphVector(FontRenderContext, CharacterIterator) - Method in class java.awt.Font
Creates a GlyphVector by mapping the specified characters to glyphs one-to-one based on the Unicode cmap in this Font.
createGlyphVector(FontRenderContext, int[]) - Method in class java.awt.Font
Creates a GlyphVector by mapping characters to glyphs one-to-one based on the Unicode cmap in this Font.
createGraphics(BufferedImage) - Method in class java.awt.GraphicsEnvironment
Returns a Graphics2D object for rendering into the specified BufferedImage.
createGraphics() - Method in class java.awt.image.BufferedImage
Creates a Graphics2D, which can be used to draw into this BufferedImage.
createGraphics() - Method in class java.awt.image.VolatileImage
Creates a Graphics2D, which can be used to draw into this VolatileImage.
createGraphics() - Method in class java.awt.SplashScreen
Creates a graphics context (as a Graphics2D object) for the splash screen overlay image, which allows you to draw over the splash screen.
createGrayLineBorder() - Static method in class javax.swing.border.LineBorder
Convenience method for getting the Color.gray LineBorder of thickness 1.
createGrayscale(int, int, boolean) - Static method in class javax.imageio.ImageTypeSpecifier
Returns a specifier for a grayscale image format that will pack pixels of the given bit depth into array elements of the specified data type.
createGrayscale(int, int, boolean, boolean) - Static method in class javax.imageio.ImageTypeSpecifier
Returns a specifier for a grayscale plus alpha image format that will pack pixels of the given bit depth into array elements of the specified data type.
createGroup(ActivationGroupID, ActivationGroupDesc, long) - Static method in class java.rmi.activation.ActivationGroup
Create and set the activation group for the current VM.
createHandler(Object, ExceptionListener, ClassLoader) - Static method in class java.beans.XMLDecoder
Creates a new handler for SAX parser that can be used to parse embedded XML archives created by the XMLEncoder class.
createHighlighter() - Method in class javax.swing.plaf.basic.BasicTextUI
Creates the object to use for adding highlights.
createHorizontalBox() - Static method in class javax.swing.Box
Creates a Box that displays its components from left to right.
createHorizontalGlue() - Static method in class javax.swing.Box
Creates a horizontal glue component.
createHorizontalScrollBar() - Method in class javax.swing.JScrollPane
Returns a JScrollPane.ScrollBar by default.
createHorizontalStrut(int) - Static method in class javax.swing.Box
Creates an invisible, fixed-width component.
createHSBChangeListener() - Method in class javax.swing.plaf.basic.BasicScrollPaneUI
createHTMLView(JComponent, String) - Static method in class javax.swing.plaf.basic.BasicHTML
Create an html renderer for the given component and string of html.
createIgnorableSpace(String) - Method in class javax.xml.stream.XMLEventFactory
Create an ignorable space
createImage(ImageProducer) - Method in class java.awt.Component
Creates an image from the specified image producer.
createImage(int, int) - Method in class java.awt.Component
Creates an off-screen drawable image to be used for double buffering.
createImage(String) - Method in class java.awt.Toolkit
Returns an image which gets pixel data from the specified file.
createImage(URL) - Method in class java.awt.Toolkit
Returns an image which gets pixel data from the specified URL.
createImage(ImageProducer) - Method in class java.awt.Toolkit
Creates an image with the specified image producer.
createImage(byte[]) - Method in class java.awt.Toolkit
Creates an image which decodes the image stored in the specified byte array.
createImage(byte[], int, int) - Method in class java.awt.Toolkit
Creates an image which decodes the image stored in the specified byte array, and at the specified offset and length.
createImageInputStream(Object) - Static method in class javax.imageio.ImageIO
Returns an ImageInputStream that will take its input from the given Object.
createImageOutputStream(Object) - Static method in class javax.imageio.ImageIO
Returns an ImageOutputStream that will send its output to the given Object.
createIncreaseButton(int) - Method in class javax.swing.plaf.basic.BasicScrollBarUI
createIncreaseButton(int) - Method in class javax.swing.plaf.metal.MetalScrollBarUI
Returns the view that represents the increase view.
createIncreaseButton(int) - Method in class javax.swing.plaf.synth.SynthScrollBarUI
createIndexed(byte[], byte[], byte[], byte[], int, int) - Static method in class javax.imageio.ImageTypeSpecifier
Returns a specifier for an indexed-color image format that will pack index values of the given bit depth into array elements of the specified data type.
createInitialContextFactory(Hashtable<?, ?>) - Method in interface javax.naming.spi.InitialContextFactoryBuilder
Creates an initial context factory using the specified environment.
createInputAttributes(Element, MutableAttributeSet) - Method in class javax.swing.text.html.HTMLEditorKit
Copies the key/values in elements AttributeSet into set.
createInputAttributes(Element, MutableAttributeSet) - Method in class javax.swing.text.StyledEditorKit
Copies the key/values in elements AttributeSet into set.
createInputMethod() - Method in interface java.awt.im.spi.InputMethodDescriptor
Creates a new instance of the corresponding input method.
createInputMethodJFrame(String, boolean) - Method in interface java.awt.im.spi.InputMethodContext
Creates a top-level Swing JFrame for use by the input method.
createInputMethodWindow(String, boolean) - Method in interface java.awt.im.spi.InputMethodContext
Creates a top-level window for use by the input method.
createInputStreamInstance(Object, boolean, File) - Method in class javax.imageio.spi.ImageInputStreamSpi
Returns an instance of the ImageInputStream implementation associated with this service provider.
createInputStreamInstance(Object) - Method in class javax.imageio.spi.ImageInputStreamSpi
Returns an instance of the ImageInputStream implementation associated with this service provider.
createInterleaved(ColorSpace, int[], int, boolean, boolean) - Static method in class javax.imageio.ImageTypeSpecifier
Returns a specifier for an interleaved image format that will use a ComponentColorModel and a PixelInterleavedSampleModel to store each pixel component in a separate byte, short, or int.
createInterleavedRaster(int, int, int, int, Point) - Static method in class java.awt.image.Raster
Creates a Raster based on a PixelInterleavedSampleModel with the specified data type, width, height, and number of bands.
createInterleavedRaster(int, int, int, int, int, int[], Point) - Static method in class java.awt.image.Raster
Creates a Raster based on a PixelInterleavedSampleModel with the specified data type, width, height, scanline stride, pixel stride, and band offsets.
createInterleavedRaster(DataBuffer, int, int, int, int, int[], Point) - Static method in class java.awt.image.Raster
Creates a Raster based on a PixelInterleavedSampleModel with the specified DataBuffer, width, height, scanline stride, pixel stride, and band offsets.
createInternalFrame(Component, String) - Method in class javax.swing.JOptionPane
Creates and returns an instance of JInternalFrame.
createInternalFrameListener() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
createIntersection(Rectangle2D) - Method in class java.awt.geom.Rectangle2D
Returns a new Rectangle2D object representing the intersection of this Rectangle2D with the specified Rectangle2D.
createIntersection(Rectangle2D) - Method in class java.awt.geom.Rectangle2D.Double
Returns a new Rectangle2D object representing the intersection of this Rectangle2D with the specified Rectangle2D.
createIntersection(Rectangle2D) - Method in class java.awt.geom.Rectangle2D.Float
Returns a new Rectangle2D object representing the intersection of this Rectangle2D with the specified Rectangle2D.
createIntersection(Rectangle2D) - Method in class java.awt.Rectangle
Returns a new Rectangle2D object representing the intersection of this Rectangle2D with the specified Rectangle2D.
createInverse() - Method in class java.awt.geom.AffineTransform
Returns an AffineTransform object representing the inverse transformation.
createItemListener() - Method in class javax.swing.AbstractButton
createItemListener() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Creates an ItemListener which will be added to the combo box.
createItemListener() - Method in class javax.swing.plaf.basic.BasicComboPopup
Creates an ItemListener which will be added to the combo box.
createJAXBIntrospector() - Method in class javax.xml.bind.JAXBContext
Creates a JAXBIntrospector object that can be used to introspect JAXB objects.
createJdbcRowSet() - Method in interface javax.sql.rowset.RowSetFactory
Creates a new instance of a JdbcRowSet.
createJoinRowSet() - Method in interface javax.sql.rowset.RowSetFactory
Creates a new instance of a JoinRowSet.
createKeyboardDownRightListener() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Deprecated.
As of Java 2 platform v1.3.
createKeyboardEndListener() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Deprecated.
As of Java 2 platform v1.3.
createKeyboardHomeListener() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Deprecated.
As of Java 2 platform v1.3.
createKeyboardResizeToggleListener() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Deprecated.
As of Java 2 platform v1.3.
createKeyboardUpLeftListener() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Deprecated.
As of Java 2 platform v1.3.
createKeyListener() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Creates a KeyListener which will be added to the combo box.
createKeyListener() - Method in class javax.swing.plaf.basic.BasicComboPopup
Creates the key listener that will be added to the combo box.
createKeyListener() - Method in class javax.swing.plaf.basic.BasicTableUI
Creates the key listener for handling keyboard navigation in the JTable.
createKeyListener() - Method in class javax.swing.plaf.basic.BasicTreeUI
Creates the listener reponsible for getting key events from the tree.
createKeymap() - Method in class javax.swing.plaf.basic.BasicTextUI
Creates the keymap to use for the text component, and installs any necessary bindings into it.
createLabel(Label) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of Label using the specified peer interface.
createLargeAttributeSet(AttributeSet) - Method in class javax.swing.text.html.StyleSheet
Creates a large set of attributes that should trade off space for time.
createLargeAttributeSet(AttributeSet) - Method in class javax.swing.text.StyleContext
Create a large set of attributes that should trade off space for time.
createLayeredPane() - Method in class javax.swing.JRootPane
Called by the constructor methods to create the default layeredPane.
createLayout() - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
createLayout() - Method in class javax.swing.plaf.basic.BasicSpinnerUI
Creates a LayoutManager that manages the editor, nextButton, and previousButton children of the JSpinner.
createLayout() - Method in class javax.swing.plaf.metal.MetalInternalFrameTitlePane
createLayout() - Method in class javax.swing.plaf.synth.SynthSpinnerUI
Creates a LayoutManager that manages the editor, nextButton, and previousButton children of the JSpinner.
createLayout() - Method in class javax.swing.plaf.synth.SynthToolBarUI
Creates a LayoutManager to use with the toolbar.
createLayoutCache() - Method in class javax.swing.plaf.basic.BasicTreeUI
Creates the object responsible for managing what is expanded, as well as the size of nodes.
createLayoutManager() - Method in class javax.swing.JViewport
Subclassers can override this to install a different layout manager (or null) in the constructor.
createLayoutManager() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Creates a layout manager for managing the components which make up the combo box.
createLayoutManager() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
createLayoutManager() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI
createLayoutManager() - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
Invoked by installUI to create a layout manager object to manage the JTabbedPane.
createLayoutManager() - Method in class javax.swing.plaf.metal.MetalComboBoxUI
createLayoutManager() - Method in class javax.swing.plaf.metal.MetalTabbedPaneUI
createLayoutManager() - Method in class javax.swing.plaf.synth.SynthTabbedPaneUI
Invoked by installUI to create a layout manager object to manage the JTabbedPane.
createLeafElement(Element, AttributeSet, int, int) - Method in class javax.swing.text.AbstractDocument
Creates a document leaf element.
createLeafElement(Element, AttributeSet, int, int) - Method in class javax.swing.text.html.HTMLDocument
Creates a document leaf element that directly represents text (doesn't have any children).
createLeftOneTouchButton() - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider
Creates and return an instance of JButton that can be used to collapse the left component in the split pane.
createLineBidi(int, int) - Method in class java.text.Bidi
Create a Bidi object representing the bidi information on a line of text within the paragraph represented by the current Bidi.
createLineBorder(Color) - Static method in class javax.swing.BorderFactory
Creates a line border withe the specified color.
createLineBorder(Color, int) - Static method in class javax.swing.BorderFactory
Creates a line border with the specified color and width.
createLineBorder(Color, int, boolean) - Static method in class javax.swing.BorderFactory
Creates a line border with the specified color, thickness, and corner shape.
createLink(Path, Path) - Static method in class java.nio.file.Files
Creates a new link (directory entry) for an existing file (optional operation).
createLink(Path, Path) - Method in class java.nio.file.spi.FileSystemProvider
Creates a new link (directory entry) for an existing file.
createList(List) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of List using the specified peer interface.
createList() - Method in class javax.swing.plaf.basic.BasicComboPopup
Creates the JList used in the popup to display the items in the combo box model.
createList(JFileChooser) - Method in class javax.swing.plaf.metal.MetalFileChooserUI
createListDataListener() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Creates a list data listener which will be added to the ComboBoxModel.
createListDataListener() - Method in class javax.swing.plaf.basic.BasicComboPopup
Creates a list data listener which will be added to the ComboBoxModel.
createListDataListener() - Method in class javax.swing.plaf.basic.BasicListUI
Creates an instance of ListDataListener that's added to the JLists by model as needed.
createListMouseListener() - Method in class javax.swing.plaf.basic.BasicComboPopup
Creates a mouse listener that watches for mouse events in the popup's list.
createListMouseMotionListener() - Method in class javax.swing.plaf.basic.BasicComboPopup
Creates a mouse motion listener that watches for mouse motion events in the popup's list.
createListSelectionListener() - Method in class javax.swing.plaf.basic.BasicComboPopup
Creates a list selection listener that watches for selection changes in the popup's list.
createListSelectionListener(JFileChooser) - Method in class javax.swing.plaf.basic.BasicFileChooserUI
createListSelectionListener() - Method in class javax.swing.plaf.basic.BasicListUI
Creates an instance of ListSelectionHandler that's added to the JLists by selectionModel as needed.
createListSelectionListener(JFileChooser) - Method in class javax.swing.plaf.metal.MetalFileChooserUI
Creates a selection listener for the list of files and directories.
createLoweredBevelBorder() - Static method in class javax.swing.BorderFactory
Creates a border with a lowered beveled edge, using brighter shades of the component's current background color for highlighting, and darker shading for shadows.
createLoweredSoftBevelBorder() - Static method in class javax.swing.BorderFactory
Creates a beveled border with a lowered edge and softened corners, using brighter shades of the component's current background color for highlighting, and darker shading for shadows.
createLSInput() - Method in interface org.w3c.dom.ls.DOMImplementationLS
Create a new empty input source object where LSInput.characterStream, LSInput.byteStream , LSInput.stringData LSInput.systemId, LSInput.publicId, LSInput.baseURI, and LSInput.encoding are null, and LSInput.certifiedText is false.
createLSOutput() - Method in interface org.w3c.dom.ls.DOMImplementationLS
Create a new empty output destination object where LSOutput.characterStream, LSOutput.byteStream, LSOutput.systemId, LSOutput.encoding are null.
createLSParser(short, String) - Method in interface org.w3c.dom.ls.DOMImplementationLS
Create a new LSParser.
createLSSerializer() - Method in interface org.w3c.dom.ls.DOMImplementationLS
Create a new LSSerializer object.
createMarshaller() - Method in class javax.xml.bind.JAXBContext
Create a Marshaller object that can be used to convert a java content tree into XML data.
createMatteBorder(int, int, int, int, Color) - Static method in class javax.swing.BorderFactory
Creates a matte-look border using a solid color.
createMatteBorder(int, int, int, int, Icon) - Static method in class javax.swing.BorderFactory
Creates a matte-look border that consists of multiple tiles of a specified icon.
createMBean(String, ObjectName) - Method in interface javax.management.MBeanServer
Instantiates and registers an MBean in the MBean server.
createMBean(String, ObjectName, ObjectName) - Method in interface javax.management.MBeanServer
Instantiates and registers an MBean in the MBean server.
createMBean(String, ObjectName, Object[], String[]) - Method in interface javax.management.MBeanServer
Instantiates and registers an MBean in the MBean server.
createMBean(String, ObjectName, ObjectName, Object[], String[]) - Method in interface javax.management.MBeanServer
Instantiates and registers an MBean in the MBean server.
createMBean(String, ObjectName) - Method in interface javax.management.MBeanServerConnection
Instantiates and registers an MBean in the MBean server.
createMBean(String, ObjectName, ObjectName) - Method in interface javax.management.MBeanServerConnection
Instantiates and registers an MBean in the MBean server.
createMBean(String, ObjectName, Object[], String[]) - Method in interface javax.management.MBeanServerConnection
Instantiates and registers an MBean in the MBean server.
createMBean(String, ObjectName, ObjectName, Object[], String[]) - Method in interface javax.management.MBeanServerConnection
Instantiates and registers an MBean in the MBean server.
createMBean(String, ObjectName, Subject) - Method in interface javax.management.remote.rmi.RMIConnection
Handles the method MBeanServerConnection.createMBean(String, ObjectName).
createMBean(String, ObjectName, ObjectName, Subject) - Method in interface javax.management.remote.rmi.RMIConnection
Handles the method MBeanServerConnection.createMBean(String, ObjectName, ObjectName).
createMBean(String, ObjectName, MarshalledObject, String[], Subject) - Method in interface javax.management.remote.rmi.RMIConnection
Handles the method MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]).
createMBean(String, ObjectName, ObjectName, MarshalledObject, String[], Subject) - Method in interface javax.management.remote.rmi.RMIConnection
Handles the method MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]).
createMBean(String, ObjectName, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl
createMBean(String, ObjectName, ObjectName, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl
createMBean(String, ObjectName, MarshalledObject, String[], Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl
createMBean(String, ObjectName, ObjectName, MarshalledObject, String[], Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl
createMBean(String, ObjectName, MarshalledObject, String[], Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub
createMBean(String, ObjectName, ObjectName, MarshalledObject, String[], Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub
createMBean(String, ObjectName, ObjectName, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub
createMBean(String, ObjectName, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub
createMBeanServer() - Static method in class javax.management.MBeanServerFactory
Return a new object implementing the MBeanServer interface with a standard default domain name.
createMBeanServer(String) - Static method in class javax.management.MBeanServerFactory
Return a new object implementing the MBeanServer interface with the specified default domain name.
createMenu(Menu) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of Menu using the specified peer interface.
createMenuBar(MenuBar) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of MenuBar using the specified peer interface.
createMenuDragMouseListener(JComponent) - Method in class javax.swing.plaf.basic.BasicMenuItemUI
createMenuDragMouseListener(JComponent) - Method in class javax.swing.plaf.basic.BasicMenuUI
createMenuItem(MenuItem) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of MenuItem using the specified peer interface.
createMenuKeyListener(JComponent) - Method in class javax.swing.plaf.basic.BasicMenuItemUI
createMenuKeyListener(JComponent) - Method in class javax.swing.plaf.basic.BasicMenuUI
createMenuListener(JComponent) - Method in class javax.swing.plaf.basic.BasicMenuUI
createMessage() - Method in class javax.xml.soap.MessageFactory
Creates a new SOAPMessage object with the default SOAPPart, SOAPEnvelope, SOAPBody, and SOAPHeader objects.
createMessage(MimeHeaders, InputStream) - Method in class javax.xml.soap.MessageFactory
Internalizes the contents of the given InputStream object into a new SOAPMessage object and returns the SOAPMessage object.
createMessageArea() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI
Messaged from installComponents to create a Container containing the body of the message.
createMessageArea() - Method in class javax.swing.plaf.synth.SynthOptionPaneUI
Called from SynthOptionPaneUI.installComponents() to create a Container containing the body of the message.
createModel() - Method in class javax.swing.plaf.basic.BasicFileChooserUI
createModelListener() - Method in class javax.swing.plaf.basic.BasicScrollBarUI
createMouseInputListener() - Method in class javax.swing.plaf.basic.BasicDesktopIconUI
createMouseInputListener() - Method in class javax.swing.plaf.basic.BasicListUI
Creates a delegate that implements MouseInputListener.
createMouseInputListener(JComponent) - Method in class javax.swing.plaf.basic.BasicMenuItemUI
createMouseInputListener(JComponent) - Method in class javax.swing.plaf.basic.BasicMenuUI
createMouseInputListener() - Method in class javax.swing.plaf.basic.BasicTableHeaderUI
Creates the mouse listener for the JTableHeader.
createMouseInputListener() - Method in class javax.swing.plaf.basic.BasicTableUI
Creates the mouse listener for the JTable.
createMouseListener() - Method in class javax.swing.plaf.basic.BasicComboPopup
Creates a listener that will watch for mouse-press and release events on the combo box.
createMouseListener() - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
createMouseListener() - Method in class javax.swing.plaf.basic.BasicTreeUI
Creates the listener responsible for updating the selection based on mouse events.
createMouseListener() - Method in class javax.swing.plaf.synth.SynthTabbedPaneUI
Overridden to keep track of whether the selected tab is also pressed.
createMouseMotionListener() - Method in class javax.swing.plaf.basic.BasicComboPopup
Creates the mouse motion listener which will be added to the combo box.
createMouseWheelListener() - Method in class javax.swing.plaf.basic.BasicScrollPaneUI
Creates an instance of MouseWheelListener, which is added to the JScrollPane by installUI().
createMultiDocPrintJob() - Method in interface javax.print.MultiDocPrintService
Create a job which can print a multiDoc.
createName(String, String, String) - Method in interface javax.xml.soap.SOAPEnvelope
Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.
createName(String) - Method in interface javax.xml.soap.SOAPEnvelope
Creates a new Name object initialized with the given local name.
createName(String, String, String) - Method in class javax.xml.soap.SOAPFactory
Creates a new Name object initialized with the given local name, namespace prefix, and namespace URI.
createName(String) - Method in class javax.xml.soap.SOAPFactory
Creates a new Name object initialized with the given local name.
createName(String, Oid) - Method in class org.ietf.jgss.GSSManager
Factory method to convert a string name from the specified namespace to a GSSName object.
createName(byte[], Oid) - Method in class org.ietf.jgss.GSSManager
Factory method to convert a byte array containing a name from the specified namespace to a GSSName object.
createName(String, Oid, Oid) - Method in class org.ietf.jgss.GSSManager
Factory method to convert a string name from the specified namespace to a GSSName object and canonicalize it at the same time for a mechanism.
createName(byte[], Oid, Oid) - Method in class org.ietf.jgss.GSSManager
Factory method to convert a byte array containing a name from the specified namespace to a GSSName object and canonicalize it at the same time for a mechanism.
createNamespace(String) - Method in class javax.xml.stream.XMLEventFactory
Create a new default Namespace
createNamespace(String, String) - Method in class javax.xml.stream.XMLEventFactory
Create a new Namespace
createNClob() - Method in interface java.sql.Connection
Constructs an object that implements the NClob interface.
createNewFile() - Method in class java.io.File
Atomically creates a new, empty file named by this abstract pathname if and only if a file with this name does not yet exist.
createNewFolder(File) - Method in class javax.swing.filechooser.FileSystemView
Creates a new folder with a default folder name.
createNextButton() - Method in class javax.swing.plaf.basic.BasicSpinnerUI
Creates an increment button, i.e.
createNextButton() - Method in class javax.swing.plaf.synth.SynthSpinnerUI
Creates an increment button, i.e.
createNodeDimensions() - Method in class javax.swing.plaf.basic.BasicTreeUI
Creates an instance of NodeDimensions that is able to determine the size of a given node in the tree.
createNonRolloverBorder() - Method in class javax.swing.plaf.basic.BasicToolBarUI
Creates the non rollover border for toolbar components.
createNonRolloverBorder() - Method in class javax.swing.plaf.metal.MetalToolBarUI
createNorthPane(JInternalFrame) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
createNorthPane(JInternalFrame) - Method in class javax.swing.plaf.metal.MetalInternalFrameUI
createNorthPane(JInternalFrame) - Method in class javax.swing.plaf.synth.SynthInternalFrameUI
createObjectFactory(Object, Hashtable<?, ?>) - Method in interface javax.naming.spi.ObjectFactoryBuilder
Creates a new object factory using the environment supplied.
createOutput(String, String) - Method in class javax.xml.bind.SchemaOutputResolver
Decides where the schema file (of the given namespace URI) will be written, and return it as a Result object.
createOutputStreamInstance(Object, boolean, File) - Method in class javax.imageio.spi.ImageOutputStreamSpi
Returns an instance of the ImageOutputStream implementation associated with this service provider.
createOutputStreamInstance(Object) - Method in class javax.imageio.spi.ImageOutputStreamSpi
Returns an instance of the ImageOutputStream implementation associated with this service provider.
createPacked(ColorSpace, int, int, int, int, int, boolean) - Static method in class javax.imageio.ImageTypeSpecifier
Returns a specifier for a packed image format that will use a DirectColorModel and a packed SampleModel to store each pixel packed into in a single byte, short, or int.
createPackedRaster(int, int, int, int[], Point) - Static method in class java.awt.image.Raster
Creates a Raster based on a SinglePixelPackedSampleModel with the specified data type, width, height, and band masks.
createPackedRaster(int, int, int, int, int, Point) - Static method in class java.awt.image.Raster
Creates a Raster based on a packed SampleModel with the specified data type, width, height, number of bands, and bits per band.
createPackedRaster(DataBuffer, int, int, int, int[], Point) - Static method in class java.awt.image.Raster
Creates a Raster based on a SinglePixelPackedSampleModel with the specified DataBuffer, width, height, scanline stride, and band masks.
createPackedRaster(DataBuffer, int, int, int, Point) - Static method in class java.awt.image.Raster
Creates a Raster based on a MultiPixelPackedSampleModel with the specified DataBuffer, width, height, and bits per pixel.
createPanel(Panel) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of Panel using the specified peer interface.
createParallelGroup() - Method in class javax.swing.GroupLayout
Creates and returns a ParallelGroup with an alignment of Alignment.LEADING.
createParallelGroup(GroupLayout.Alignment) - Method in class javax.swing.GroupLayout
Creates and returns a ParallelGroup with the specified alignment.
createParallelGroup(GroupLayout.Alignment, boolean) - Method in class javax.swing.GroupLayout
Creates and returns a ParallelGroup with the specified alignment and resize behavior.
createPopup() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Creates the popup portion of the combo box.
createPopup() - Method in class javax.swing.plaf.metal.MetalComboBoxUI
createPopup() - Method in class javax.swing.plaf.synth.SynthComboBoxUI
Creates the popup portion of the combo box.
createPopupMenu(PopupMenu) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of PopupMenu using the specified peer interface.
createPosition(int) - Method in interface javax.swing.text.AbstractDocument.Content
Creates a position within the content that will track change as the content is mutated.
createPosition(int) - Method in class javax.swing.text.AbstractDocument
Returns a position that will track change as the document is altered.
createPosition(int) - Method in interface javax.swing.text.Document
This method allows an application to mark a place in a sequence of character content.
createPosition(int) - Method in class javax.swing.text.GapContent
Creates a position within the content that will track change as the content is mutated.
createPosition(int) - Method in class javax.swing.text.StringContent
Creates a position within the content that will track change as the content is mutated.
createPreviousButton() - Method in class javax.swing.plaf.basic.BasicSpinnerUI
Creates a decrement button, i.e.
createPreviousButton() - Method in class javax.swing.plaf.synth.SynthSpinnerUI
Creates a decrement button, i.e.
createPrintJob() - Method in interface javax.print.PrintService
Creates and returns a PrintJob capable of handling data from any of the supported document flavors.
createProcessingInstruction(String, String) - Method in class javax.xml.stream.XMLEventFactory
Create a processing instruction
createProcessingInstruction(String, String) - Method in interface org.w3c.dom.Document
Creates a ProcessingInstruction node given the specified name and data strings.
createPropertyChangeListener() - Method in class javax.swing.plaf.basic.BasicColorChooserUI
createPropertyChangeListener() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Creates a PropertyChangeListener which will be added to the combo box.
createPropertyChangeListener() - Method in class javax.swing.plaf.basic.BasicComboPopup
Creates a PropertyChangeListener which will be added to the combo box.
createPropertyChangeListener() - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI
Returns the PropertyChangeListener to install on the JDesktopPane.
createPropertyChangeListener(JFileChooser) - Method in class javax.swing.plaf.basic.BasicFileChooserUI
createPropertyChangeListener() - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
createPropertyChangeListener() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
createPropertyChangeListener() - Method in class javax.swing.plaf.basic.BasicListUI
Creates an instance of PropertyChangeHandler that's added to the JList by installUI().
createPropertyChangeListener(JComponent) - Method in class javax.swing.plaf.basic.BasicMenuItemUI
Creates a PropertyChangeListener which will be added to the menu item.
createPropertyChangeListener(JComponent) - Method in class javax.swing.plaf.basic.BasicMenuUI
createPropertyChangeListener() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI
createPropertyChangeListener() - Method in class javax.swing.plaf.basic.BasicScrollBarUI
createPropertyChangeListener() - Method in class javax.swing.plaf.basic.BasicScrollPaneUI
Creates an instance of PropertyChangeListener that's added to the JScrollPane by installUI().
createPropertyChangeListener(JSlider) - Method in class javax.swing.plaf.basic.BasicSliderUI
createPropertyChangeListener() - Method in class javax.swing.plaf.basic.BasicSpinnerUI
Creates a PropertyChangeListener that can be added to the JSpinner itself.
createPropertyChangeListener() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Creates a PropertyChangeListener for the JSplitPane UI.
createPropertyChangeListener() - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
createPropertyChangeListener() - Method in class javax.swing.plaf.basic.BasicTreeUI
Creates a listener that is responsible that updates the UI based on how the tree changes.
createPropertyChangeListener() - Method in class javax.swing.plaf.metal.MetalComboBoxUI
createPropertyChangeListener(JFileChooser) - Method in class javax.swing.plaf.metal.MetalFileChooserUI
createPropertyChangeListener() - Method in class javax.swing.plaf.metal.MetalInternalFrameTitlePane
createPropertyChangeListener() - Method in class javax.swing.plaf.metal.MetalScrollBarUI
createPropertyChangeListener(JSlider) - Method in class javax.swing.plaf.metal.MetalSliderUI
createPropertyEditor(Object) - Method in class java.beans.PropertyDescriptor
Constructs an instance of a property editor using the current property editor class.
createPropertyListener() - Method in class javax.swing.plaf.basic.BasicToolBarUI
createQName(String, String) - Method in interface javax.xml.soap.SOAPElement
Creates a QName whose namespace URI is the one associated with the parameter, prefix, in the context of this SOAPElement.
createRaisedBevelBorder() - Static method in class javax.swing.BorderFactory
Creates a border with a raised beveled edge, using brighter shades of the component's current background color for highlighting, and darker shading for shadows.
createRaisedSoftBevelBorder() - Static method in class javax.swing.BorderFactory
Creates a beveled border with a raised edge and softened corners, using brighter shades of the component's current background color for highlighting, and darker shading for shadows.
createRaster(SampleModel, DataBuffer, Point) - Static method in class java.awt.image.Raster
Creates a Raster with the specified SampleModel and DataBuffer.
createReaderInstance() - Method in class javax.imageio.spi.ImageReaderSpi
Returns an instance of the ImageReader implementation associated with this service provider.
createReaderInstance(Object) - Method in class javax.imageio.spi.ImageReaderSpi
Returns an instance of the ImageReader implementation associated with this service provider.
createRegistry(int) - Static method in class java.rmi.registry.LocateRegistry
Creates and exports a Registry instance on the local host that accepts requests on the specified port.
createRegistry(int, RMIClientSocketFactory, RMIServerSocketFactory) - Static method in class java.rmi.registry.LocateRegistry
Creates and exports a Registry instance on the local host that uses custom socket factories for communication with that instance.
createRelation(String, String, RoleList) - Method in class javax.management.relation.RelationService
Creates a simple relation (represented by a RelationSupport object) of given relation type, and adds it in the Relation Service.
createRelation(String, String, RoleList) - Method in interface javax.management.relation.RelationServiceMBean
Creates a simple relation (represented by a RelationSupport object) of given relation type, and adds it in the Relation Service.
createRelationType(String, RoleInfo[]) - Method in class javax.management.relation.RelationService
Creates a relation type (a RelationTypeSupport object) with given role infos (provided by the RoleInfo objects), and adds it in the Relation Service.
createRelationType(String, RoleInfo[]) - Method in interface javax.management.relation.RelationServiceMBean
Creates a relation type (RelationTypeSupport object) with given role infos (provided by the RoleInfo objects), and adds it in the Relation Service.
createRenderer() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Creates the default renderer that will be used in a non-editiable combo box.
createRenderer() - Method in class javax.swing.plaf.synth.SynthComboBoxUI
Creates the default renderer that will be used in a non-editiable combo box.
createRendering(RenderContext) - Method in interface java.awt.image.renderable.RenderableImage
Creates a RenderedImage that represented a rendering of this image using a given RenderContext.
createRendering(RenderContext) - Method in class java.awt.image.renderable.RenderableImageOp
Creates a RenderedImage which represents this RenderableImageOp (including its Renderable sources) rendered according to the given RenderContext.
createReply() - Method in interface org.omg.CORBA.portable.ResponseHandler
Called by the servant during a method invocation.
createResource(JavaFileManager.Location, CharSequence, CharSequence, Element...) - Method in interface javax.annotation.processing.Filer
Creates a new auxiliary resource file for writing and returns a file object for it.
createRightOneTouchButton() - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider
Creates and return an instance of JButton that can be used to collapse the right component in the split pane.
createRigidArea(Dimension) - Static method in class javax.swing.Box
Creates an invisible component that's always the specified size.
createRolloverBorder() - Method in class javax.swing.plaf.basic.BasicToolBarUI
Creates a rollover border for toolbar components.
createRolloverBorder() - Method in class javax.swing.plaf.metal.MetalToolBarUI
createRolloverListener() - Method in class javax.swing.plaf.metal.MetalToolBarUI
Creates a property change listener that will be added to the JToolBar.
createRootLayout() - Method in class javax.swing.JRootPane
Called by the constructor methods to create the default layoutManager.
createRootPane() - Method in class javax.swing.JApplet
Called by the constructor methods to create the default rootPane.
createRootPane() - Method in class javax.swing.JDialog
Called by the constructor methods to create the default rootPane.
createRootPane() - Method in class javax.swing.JFrame
Called by the constructor methods to create the default rootPane.
createRootPane() - Method in class javax.swing.JInternalFrame
Called by the constructor to set up the JRootPane.
createRootPane() - Method in class javax.swing.JWindow
Called by the constructor methods to create the default rootPane.
createRow() - Method in class javax.swing.text.FlowView
Create a View that should be used to hold a a rows worth of children in a flow.
createRow() - Method in class javax.swing.text.ParagraphView
Create a View that should be used to hold a a row's worth of children in a flow.
createSaslClient(String[], String, String, String, Map<String, ?>, CallbackHandler) - Static method in class javax.security.sasl.Sasl
Creates a SaslClient using the parameters supplied.
createSaslClient(String[], String, String, String, Map<String, ?>, CallbackHandler) - Method in interface javax.security.sasl.SaslClientFactory
Creates a SaslClient using the parameters supplied.
createSaslServer(String, String, String, Map<String, ?>, CallbackHandler) - Static method in class javax.security.sasl.Sasl
Creates a SaslServer for the specified mechanism.
createSaslServer(String, String, String, Map<String, ?>, CallbackHandler) - Method in interface javax.security.sasl.SaslServerFactory
Creates a SaslServer using the parameters supplied.
createScaledRendering(int, int, RenderingHints) - Method in interface java.awt.image.renderable.RenderableImage
Creates a RenderedImage instance of this image with width w, and height h in pixels.
createScaledRendering(int, int, RenderingHints) - Method in class java.awt.image.renderable.RenderableImageOp
Creates a RenderedImage instance of this image with width w, and height h in pixels.
createScreenCapture(Rectangle) - Method in class java.awt.Robot
Creates an image containing pixels read from the screen.
createScrollbar(Scrollbar) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of Scrollbar using the specified peer interface.
createScrollBarSwapListener() - Method in class javax.swing.plaf.metal.MetalScrollPaneUI
createScrollButton(int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
Creates and returns a JButton that will provide the user with a way to scroll the tabs in a particular direction.
createScrollButton(int) - Method in class javax.swing.plaf.synth.SynthTabbedPaneUI
Creates and returns a JButton that will provide the user with a way to scroll the tabs in a particular direction.
createScroller() - Method in class javax.swing.plaf.basic.BasicComboPopup
Creates the scroll pane which houses the scrollable list.
createScrollListener() - Method in class javax.swing.plaf.basic.BasicScrollBarUI
createScrollListener(JSlider) - Method in class javax.swing.plaf.basic.BasicSliderUI
createScrollPane(ScrollPane) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of ScrollPane using the specified peer interface.
createScrollPaneForTable(JTable) - Static method in class javax.swing.JTable
Deprecated.
As of Swing version 1.0.2, replaced by new JScrollPane(aTable).
createSecondaryLoop() - Method in class java.awt.EventQueue
Creates a new secondary loop associated with this event queue.
createSelectionModel() - Method in class javax.swing.JList
Returns an instance of DefaultListSelectionModel; called during construction to initialize the list's selection model property.
createSelectionModel() - Method in class javax.swing.table.DefaultTableColumnModel
Creates a new default list selection model.
createSelectionModelPropertyChangeListener() - Method in class javax.swing.plaf.basic.BasicTreeUI
Creates the listener responsible for getting property change events from the selection model.
createSeparator() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI
createSeparator() - Method in class javax.swing.plaf.synth.SynthOptionPaneUI
createSequentialGroup() - Method in class javax.swing.GroupLayout
Creates and returns a SequentialGroup.
createServerSocket(int) - Method in interface java.rmi.server.RMIServerSocketFactory
Create a server socket on the specified port (port 0 indicates an anonymous port).
createServerSocket(int) - Method in class java.rmi.server.RMISocketFactory
Create a server socket on the specified port (port 0 indicates an anonymous port).
createServerSocket() - Method in class javax.net.ServerSocketFactory
Returns an unbound server socket.
createServerSocket(int) - Method in class javax.net.ServerSocketFactory
Returns a server socket bound to the specified port.
createServerSocket(int, int) - Method in class javax.net.ServerSocketFactory
Returns a server socket bound to the specified port, and uses the specified connection backlog.
createServerSocket(int, int, InetAddress) - Method in class javax.net.ServerSocketFactory
Returns a server socket bound to the specified port, with a specified listen backlog and local IP.
createServerSocket(int) - Method in class javax.rmi.ssl.SslRMIServerSocketFactory
Creates a server socket that accepts SSL connections configured according to this factory's SSL socket configuration parameters.
createServiceDelegate(URL, QName, Class<? extends Service>) - Method in class javax.xml.ws.spi.Provider
Creates a service delegate object.
createServiceDelegate(URL, QName, Class<? extends Service>, WebServiceFeature...) - Method in class javax.xml.ws.spi.Provider
Creates a service delegate object.
createShared() - Method in interface javax.sql.rowset.CachedRowSet
Returns a new RowSet object backed by the same data as that of this CachedRowSet object.
createSmallAttributeSet(AttributeSet) - Method in class javax.swing.text.html.StyleSheet
Creates a compact set of attributes that might be shared.
createSmallAttributeSet(AttributeSet) - Method in class javax.swing.text.StyleContext
Create a compact set of attributes that might be shared.
createSNIMatcher(String) - Static method in class javax.net.ssl.SNIHostName
Creates an SNIMatcher object for SNIHostNames.
createSocket(String, int) - Method in interface java.rmi.server.RMIClientSocketFactory
Create a client socket connected to the specified host and port.
createSocket(String, int) - Method in class java.rmi.server.RMISocketFactory
Creates a client socket connected to the specified host and port.
createSocket() - Method in class javax.net.SocketFactory
Creates an unconnected socket.
createSocket(String, int) - Method in class javax.net.SocketFactory
Creates a socket and connects it to the specified remote host at the specified remote port.
createSocket(String, int, InetAddress, int) - Method in class javax.net.SocketFactory
Creates a socket and connects it to the specified remote host on the specified remote port.
createSocket(InetAddress, int) - Method in class javax.net.SocketFactory
Creates a socket and connects it to the specified port number at the specified address.
createSocket(InetAddress, int, InetAddress, int) - Method in class javax.net.SocketFactory
Creates a socket and connect it to the specified remote address on the specified remote port.
createSocket(Socket, String, int, boolean) - Method in class javax.net.ssl.SSLSocketFactory
Returns a socket layered over an existing socket connected to the named host, at the given port.
createSocket(Socket, InputStream, boolean) - Method in class javax.net.ssl.SSLSocketFactory
Creates a server mode Socket layered over an existing connected socket, and is able to read data which has already been consumed/removed from the Socket's underlying InputStream.
createSocket(String, int) - Method in class javax.rmi.ssl.SslRMIClientSocketFactory
Creates an SSL socket.
createSocketImpl() - Method in interface java.net.SocketImplFactory
Creates a new SocketImpl instance.
createSoftBevelBorder(int) - Static method in class javax.swing.BorderFactory
Creates a beveled border of the specified type with softened corners, using brighter shades of the component's current background color for highlighting, and darker shading for shadows.
createSoftBevelBorder(int, Color, Color) - Static method in class javax.swing.BorderFactory
Creates a beveled border of the specified type with softened corners, using the specified highlighting and shadowing.
createSoftBevelBorder(int, Color, Color, Color, Color) - Static method in class javax.swing.BorderFactory
Creates a beveled border of the specified type with softened corners, using the specified colors for the inner and outer edges of the highlight and the shadow areas.
createSourceFile(CharSequence, Element...) - Method in interface javax.annotation.processing.Filer
Creates a new source file and returns an object to allow writing to it.
createSouthPane(JInternalFrame) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
createSpace(String) - Method in class javax.xml.stream.XMLEventFactory
Create a Characters event with the isSpace flag set to true
createSQLXML() - Method in interface java.sql.Connection
Constructs an object that implements the SQLXML interface.
createSSLEngine() - Method in class javax.net.ssl.SSLContext
Creates a new SSLEngine using this context.
createSSLEngine(String, int) - Method in class javax.net.ssl.SSLContext
Creates a new SSLEngine using this context using advisory peer information.
createStandardLabels(int) - Method in class javax.swing.JSlider
Creates a Hashtable of numerical text labels, starting at the slider minimum, and using the increment specified.
createStandardLabels(int, int) - Method in class javax.swing.JSlider
Creates a Hashtable of numerical text labels, starting at the starting point specified, and using the increment specified.
createStartDocument() - Method in class javax.xml.stream.XMLEventFactory
Creates a new instance of a StartDocument event
createStartDocument(String, String, boolean) - Method in class javax.xml.stream.XMLEventFactory
Creates a new instance of a StartDocument event
createStartDocument(String, String) - Method in class javax.xml.stream.XMLEventFactory
Creates a new instance of a StartDocument event
createStartDocument(String) - Method in class javax.xml.stream.XMLEventFactory
Creates a new instance of a StartDocument event
createStartElement(QName, Iterator, Iterator) - Method in class javax.xml.stream.XMLEventFactory
Create a new StartElement.
createStartElement(String, String, String) - Method in class javax.xml.stream.XMLEventFactory
Create a new StartElement.
createStartElement(String, String, String, Iterator, Iterator) - Method in class javax.xml.stream.XMLEventFactory
Create a new StartElement.
createStartElement(String, String, String, Iterator, Iterator, NamespaceContext) - Method in class javax.xml.stream.XMLEventFactory
Create a new StartElement.
createStatement() - Method in interface java.sql.Connection
Creates a Statement object for sending SQL statements to the database.
createStatement(int, int) - Method in interface java.sql.Connection
Creates a Statement object that will generate ResultSet objects with the given type and concurrency.
createStatement(int, int, int) - Method in interface java.sql.Connection
Creates a Statement object that will generate ResultSet objects with the given type, concurrency, and holdability.
createStrokeBorder(BasicStroke) - Static method in class javax.swing.BorderFactory
Creates a border of the specified stroke.
createStrokeBorder(BasicStroke, Paint) - Static method in class javax.swing.BorderFactory
Creates a border of the specified stroke and paint.
createStrokedShape(Shape) - Method in class java.awt.BasicStroke
Returns a Shape whose interior defines the stroked outline of a specified Shape.
createStrokedShape(Shape) - Method in interface java.awt.Stroke
Returns an outline Shape which encloses the area that should be painted when the Shape is stroked according to the rules defined by the object implementing the Stroke interface.
createStruct(String, Object[]) - Method in interface java.sql.Connection
Factory method for creating Struct objects.
createSubcontext(Name) - Method in interface javax.naming.Context
Creates and binds a new context.
createSubcontext(String) - Method in interface javax.naming.Context
Creates and binds a new context.
createSubcontext(Name, Attributes) - Method in interface javax.naming.directory.DirContext
Creates and binds a new context, along with associated attributes.
createSubcontext(String, Attributes) - Method in interface javax.naming.directory.DirContext
Creates and binds a new context, along with associated attributes.
createSubcontext(String, Attributes) - Method in class javax.naming.directory.InitialDirContext
createSubcontext(Name, Attributes) - Method in class javax.naming.directory.InitialDirContext
createSubcontext(String) - Method in class javax.naming.InitialContext
createSubcontext(Name) - Method in class javax.naming.InitialContext
createSubsetSampleModel(int[]) - Method in class java.awt.image.BandedSampleModel
Creates a new BandedSampleModel with a subset of the bands of this BandedSampleModel.
createSubsetSampleModel(int[]) - Method in class java.awt.image.ComponentSampleModel
Creates a new ComponentSampleModel with a subset of the bands of this ComponentSampleModel.
createSubsetSampleModel(int[]) - Method in class java.awt.image.MultiPixelPackedSampleModel
Creates a new MultiPixelPackedSampleModel with a subset of the bands of this MultiPixelPackedSampleModel.
createSubsetSampleModel(int[]) - Method in class java.awt.image.PixelInterleavedSampleModel
Creates a new PixelInterleavedSampleModel with a subset of the bands of this PixelInterleavedSampleModel.
createSubsetSampleModel(int[]) - Method in class java.awt.image.SampleModel
Creates a new SampleModel with a subset of the bands of this SampleModel.
createSubsetSampleModel(int[]) - Method in class java.awt.image.SinglePixelPackedSampleModel
This creates a new SinglePixelPackedSampleModel with a subset of the bands of this SinglePixelPackedSampleModel.
createSymbolicLink(Path, Path, FileAttribute<?>...) - Static method in class java.nio.file.Files
Creates a symbolic link to a target (optional operation).
createSymbolicLink(Path, Path, FileAttribute<?>...) - Method in class java.nio.file.spi.FileSystemProvider
Creates a symbolic link to a target.
createSystemMenu() - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
createSystemMenuBar() - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
createTableCell(Element) - Method in class javax.swing.text.TableView
Deprecated.
Table cells can now be any arbitrary View implementation and should be produced by the ViewFactory rather than the table.
createTableRow(Element) - Method in class javax.swing.text.TableView
Creates a new table row.
createTempDirectory(Path, String, FileAttribute<?>...) - Static method in class java.nio.file.Files
Creates a new directory in the specified directory, using the given prefix to generate its name.
createTempDirectory(String, FileAttribute<?>...) - Static method in class java.nio.file.Files
Creates a new directory in the default temporary-file directory, using the given prefix to generate its name.
createTempFile(String, String, File) - Static method in class java.io.File
Creates a new empty file in the specified directory, using the given prefix and suffix strings to generate its name.
createTempFile(String, String) - Static method in class java.io.File
Creates an empty file in the default temporary-file directory, using the given prefix and suffix to generate its name.
createTempFile(Path, String, String, FileAttribute<?>...) - Static method in class java.nio.file.Files
Creates a new empty file in the specified directory, using the given prefix and suffix strings to generate its name.
createTempFile(String, String, FileAttribute<?>...) - Static method in class java.nio.file.Files
Creates an empty file in the default temporary-file directory, using the given prefix and suffix to generate its name.
createTextArea(TextArea) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of TextArea using the specified peer interface.
createTextField(TextField) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of TextField using the specified peer interface.
createTextNode(String) - Method in interface org.w3c.dom.Document
Creates a Text node given the specified string.
createTitledBorder(String) - Static method in class javax.swing.BorderFactory
Creates a new titled border with the specified title, the default border type (determined by the current look and feel), the default text position (determined by the current look and feel), the default justification (leading), and the default font and text color (determined by the current look and feel).
createTitledBorder(Border) - Static method in class javax.swing.BorderFactory
Creates a new titled border with an empty title, the specified border object, the default text position (determined by the current look and feel), the default justification (leading), and the default font and text color (determined by the current look and feel).
createTitledBorder(Border, String) - Static method in class javax.swing.BorderFactory
Adds a title to an existing border, with default positioning (determined by the current look and feel), default justification (leading) and the default font and text color (determined by the current look and feel).
createTitledBorder(Border, String, int, int) - Static method in class javax.swing.BorderFactory
Adds a title to an existing border, with the specified positioning and using the default font and text color (determined by the current look and feel).
createTitledBorder(Border, String, int, int, Font) - Static method in class javax.swing.BorderFactory
Adds a title to an existing border, with the specified positioning and font, and using the default text color (determined by the current look and feel).
createTitledBorder(Border, String, int, int, Font, Color) - Static method in class javax.swing.BorderFactory
Adds a title to an existing border, with the specified positioning, font and color.
createToolBarContListener() - Method in class javax.swing.plaf.basic.BasicToolBarUI
createToolBarFocusListener() - Method in class javax.swing.plaf.basic.BasicToolBarUI
createToolTip() - Method in class javax.swing.JComponent
Returns the instance of JToolTip that should be used to display the tooltip.
createTrack() - Method in class javax.sound.midi.Sequence
Creates a new, initially empty track as part of this sequence.
createTrackListener() - Method in class javax.swing.plaf.basic.BasicScrollBarUI
createTrackListener(JSlider) - Method in class javax.swing.plaf.basic.BasicSliderUI
createTrackListener(JSlider) - Method in class javax.swing.plaf.synth.SynthSliderUI
createTranscoderInstance() - Method in class javax.imageio.spi.ImageTranscoderSpi
Returns an instance of the ImageTranscoder implementation associated with this service provider.
createTransferable(JComponent) - Method in class javax.swing.TransferHandler
Creates a Transferable to use as the source for a data transfer.
createTransferableProxy(Transferable, boolean) - Method in class java.awt.dnd.DropTargetContext
Creates a TransferableProxy to proxy for the specified Transferable.
createTransformedArea(AffineTransform) - Method in class java.awt.geom.Area
Creates a new Area object that contains the same geometry as this Area transformed by the specified AffineTransform.
createTransformedShape(Shape) - Method in class java.awt.geom.AffineTransform
Returns a new Shape object defined by the geometry of the specified Shape after it has been transformed by this transform.
createTransformedShape(AffineTransform) - Method in class java.awt.geom.Path2D
Returns a new Shape representing a transformed version of this Path2D.
createTransition(int) - Method in class java.time.zone.ZoneOffsetTransitionRule
Creates a transition instance for the specified year.
createTranslatedChild(int, int) - Method in class java.awt.image.Raster
Create a Raster with the same size, SampleModel and DataBuffer as this one, but with a different location.
createTreeCellEditor() - Method in class javax.swing.tree.DefaultTreeCellEditor
This is invoked if a TreeCellEditor is not supplied in the constructor.
createTreeExpansionListener() - Method in class javax.swing.plaf.basic.BasicTreeUI
Creates and returns the object responsible for updating the treestate when nodes expanded state changes.
createTreeModel(Object) - Static method in class javax.swing.JTree
Returns a TreeModel wrapping the specified object.
createTreeModelListener() - Method in class javax.swing.JTree
Creates and returns an instance of TreeModelHandler.
createTreeModelListener() - Method in class javax.swing.plaf.basic.BasicTreeUI
Returns a listener that can update the tree when the model changes.
createTreeSelectionListener() - Method in class javax.swing.plaf.basic.BasicTreeUI
Creates the listener that updates the display based on selection change methods.
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicButtonUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicCheckBoxMenuItemUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicCheckBoxUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicColorChooserUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicComboBoxUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicDesktopIconUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicDesktopPaneUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicEditorPaneUI
Creates a UI for the JTextPane.
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicFileChooserUI
Creates a BasicFileChooserUI implementation for the specified component.
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicFormattedTextFieldUI
Creates a UI for a JFormattedTextField.
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicInternalFrameUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicLabelUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicListUI
Returns a new instance of BasicListUI.
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicMenuBarUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicMenuItemUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicMenuUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicOptionPaneUI
Creates a new BasicOptionPaneUI instance.
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicPanelUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicPasswordFieldUI
Creates a UI for a JPasswordField.
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicPopupMenuSeparatorUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicPopupMenuUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicProgressBarUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicRadioButtonMenuItemUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicRadioButtonUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicRootPaneUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicScrollBarUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicScrollPaneUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicSeparatorUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicSliderUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicSpinnerUI
Returns a new instance of BasicSpinnerUI.
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicSplitPaneUI
Creates a new BasicSplitPaneUI instance
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicTabbedPaneUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicTableHeaderUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicTableUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicTextAreaUI
Creates a UI for a JTextArea.
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicTextFieldUI
Creates a UI for a JTextField.
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicTextPaneUI
Creates a UI for the JTextPane.
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicToggleButtonUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicToolBarSeparatorUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicToolBarUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicToolTipUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicTreeUI
createUI(JComponent) - Static method in class javax.swing.plaf.basic.BasicViewportUI
createUI(JComponent) - Static method in class javax.swing.plaf.ComponentUI
Returns an instance of the UI delegate for the specified component.
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalButtonUI
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalCheckBoxUI
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalComboBoxUI
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalDesktopIconUI
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalFileChooserUI
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalInternalFrameUI
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalLabelUI
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalMenuBarUI
Creates the ComponentUI implementation for the passed in component.
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalPopupMenuSeparatorUI
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalProgressBarUI
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalRadioButtonUI
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalRootPaneUI
Creates a UI for a JRootPane.
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalScrollBarUI
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalScrollPaneUI
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalSeparatorUI
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalSliderUI
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalSplitPaneUI
Creates a new MetalSplitPaneUI instance
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalTabbedPaneUI
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalTextFieldUI
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalToggleButtonUI
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalToolBarUI
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalToolTipUI
createUI(JComponent) - Static method in class javax.swing.plaf.metal.MetalTreeUI
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiButtonUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiColorChooserUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiComboBoxUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiDesktopIconUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiDesktopPaneUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiFileChooserUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiInternalFrameUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiLabelUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiListUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiMenuBarUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiMenuItemUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiOptionPaneUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiPanelUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiPopupMenuUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiProgressBarUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiRootPaneUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiScrollBarUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiScrollPaneUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiSeparatorUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiSliderUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiSpinnerUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiSplitPaneUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiTabbedPaneUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiTableHeaderUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiTableUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiTextUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiToolBarUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiToolTipUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiTreeUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.multi.MultiViewportUI
Returns a multiplexing UI instance if any of the auxiliary LookAndFeels supports this UI.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthButtonUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthCheckBoxMenuItemUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthCheckBoxUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthColorChooserUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthComboBoxUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthDesktopIconUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthDesktopPaneUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthEditorPaneUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthFormattedTextFieldUI
Creates a UI for a JFormattedTextField.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthInternalFrameUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthLabelUI
Returns the LabelUI implementation used for the skins look and feel.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthListUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthLookAndFeel
Creates the Synth look and feel ComponentUI for the passed in JComponent.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthMenuBarUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthMenuItemUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthMenuUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthOptionPaneUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthPanelUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthPasswordFieldUI
Creates a UI for a JPasswordField.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthPopupMenuUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthProgressBarUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthRadioButtonMenuItemUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthRadioButtonUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthRootPaneUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthScrollBarUI
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthScrollPaneUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthSeparatorUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthSliderUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthSpinnerUI
Returns a new instance of SynthSpinnerUI.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthSplitPaneUI
Creates a new SynthSplitPaneUI instance
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthTabbedPaneUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthTableHeaderUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthTableUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthTextAreaUI
Creates a UI object for a JTextArea.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthTextFieldUI
Creates a UI for a JTextField.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthTextPaneUI
Creates a UI for the JTextPane.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthToggleButtonUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthToolBarUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthToolTipUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthTreeUI
Creates a new UI object for the given component.
createUI(JComponent) - Static method in class javax.swing.plaf.synth.SynthViewportUI
Creates a new UI object for the given component.
createUIs(ComponentUI, Vector, JComponent) - Static method in class javax.swing.plaf.multi.MultiLookAndFeel
Creates the ComponentUI objects required to present the target component, placing the objects in the uis vector and returning the ComponentUI object that best represents the component's UI.
createUnion(Rectangle2D) - Method in class java.awt.geom.Rectangle2D
Returns a new Rectangle2D object representing the union of this Rectangle2D with the specified Rectangle2D.
createUnion(Rectangle2D) - Method in class java.awt.geom.Rectangle2D.Double
Returns a new Rectangle2D object representing the union of this Rectangle2D with the specified Rectangle2D.
createUnion(Rectangle2D) - Method in class java.awt.geom.Rectangle2D.Float
Returns a new Rectangle2D object representing the union of this Rectangle2D with the specified Rectangle2D.
createUnion(Rectangle2D) - Method in class java.awt.Rectangle
Returns a new Rectangle2D object representing the union of this Rectangle2D with the specified Rectangle2D.
createUnmarshalException(SAXException) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl
Creates an UnmarshalException from a SAXException.
createUnmarshaller(ValidationEventHandler) - Method in interface javax.xml.bind.annotation.DomHandler
When a JAXB provider needs to unmarshal a part of a document into an infoset representation, it first calls this method to create a Result object.
createUnmarshaller(ValidationEventHandler) - Method in class javax.xml.bind.annotation.W3CDomHandler
createUnmarshaller() - Method in class javax.xml.bind.JAXBContext
Create an Unmarshaller object that can be used to convert XML data into a java content tree.
createUnresolved(String, int) - Static method in class java.net.InetSocketAddress
Creates an unresolved socket address from a hostname and a port number.
createURLStreamHandler(String) - Method in interface java.net.URLStreamHandlerFactory
Creates a new URLStreamHandler instance with the specified protocol.
createValidator() - Method in class javax.xml.bind.JAXBContext
Deprecated.
since JAXB2.0
createValue(UIDefaults) - Method in interface javax.swing.UIDefaults.ActiveValue
Creates the value retrieved from the UIDefaults table.
createValue(UIDefaults) - Method in class javax.swing.UIDefaults.LazyInputMap
Creates an InputMap with the bindings that are passed in.
createValue(UIDefaults) - Method in interface javax.swing.UIDefaults.LazyValue
Creates the actual value retrieved from the UIDefaults table.
createValue(UIDefaults) - Method in class javax.swing.UIDefaults.ProxyLazyValue
Creates the value retrieved from the UIDefaults table.
createValueHandler() - Static method in class javax.rmi.CORBA.Util
Returns a singleton instance of a class that implements the ValueHandler interface.
createValueHandler() - Method in interface javax.rmi.CORBA.UtilDelegate
Delegation call for Util.createValueHandler().
createVerticalBox() - Static method in class javax.swing.Box
Creates a Box that displays its components from top to bottom.
createVerticalGlue() - Static method in class javax.swing.Box
Creates a vertical glue component.
createVerticalScrollBar() - Method in class javax.swing.JScrollPane
Returns a JScrollPane.ScrollBar by default.
createVerticalStrut(int) - Static method in class javax.swing.Box
Creates an invisible, fixed-height component.
createView(FlowView, int, int, int) - Method in class javax.swing.text.FlowView.FlowStrategy
Creates a view that can be used to represent the current piece of the flow.
createViewListener() - Method in class javax.swing.JViewport
Creates a listener for the view.
createViewport() - Method in class javax.swing.JScrollPane
Returns a new JViewport by default.
createViewportChangeListener() - Method in class javax.swing.plaf.basic.BasicScrollPaneUI
createVolatileImage(int, int) - Method in class java.awt.Component
Creates a volatile off-screen drawable image to be used for double buffering.
createVolatileImage(int, int, ImageCapabilities) - Method in class java.awt.Component
Creates a volatile off-screen drawable image, with the given capabilities.
createVSBChangeListener() - Method in class javax.swing.plaf.basic.BasicScrollPaneUI
createW3CEndpointReference(String, QName, QName, List<Element>, String, List<Element>) - Method in class javax.xml.ws.spi.Provider
Factory method to create a W3CEndpointReference.
createW3CEndpointReference(String, QName, QName, QName, List<Element>, String, List<Element>, List<Element>, Map<QName, String>) - Method in class javax.xml.ws.spi.Provider
Factory method to create a W3CEndpointReference.
createWebRowSet() - Method in interface javax.sql.rowset.RowSetFactory
Creates a new instance of a WebRowSet.
createWestPane(JInternalFrame) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
createWindow(Window) - Method in class java.awt.Toolkit
Creates this toolkit's implementation of Window using the specified peer interface.
createWinListener(JPopupMenu) - Method in class javax.swing.JMenu
Creates a window-closing listener for the popup.
createWritableChild(int, int, int, int, int, int, int[]) - Method in class java.awt.image.WritableRaster
Returns a new WritableRaster which shares all or part of this WritableRaster's DataBuffer.
createWritableRaster(SampleModel, Point) - Static method in class java.awt.image.Raster
Creates a WritableRaster with the specified SampleModel.
createWritableRaster(SampleModel, DataBuffer, Point) - Static method in class java.awt.image.Raster
Creates a WritableRaster with the specified SampleModel and DataBuffer.
createWritableTranslatedChild(int, int) - Method in class java.awt.image.WritableRaster
Create a WritableRaster with the same size, SampleModel and DataBuffer as this one, but with a different location.
createWriterInstance() - Method in class javax.imageio.spi.ImageWriterSpi
Returns an instance of the ImageWriter implementation associated with this service provider.
createWriterInstance(Object) - Method in class javax.imageio.spi.ImageWriterSpi
Returns an instance of the ImageWriter implementation associated with this service provider.
createXMLEventReader(Reader) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLEventReader from a reader
createXMLEventReader(String, Reader) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLEventReader from a reader
createXMLEventReader(XMLStreamReader) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLEventReader from an XMLStreamReader.
createXMLEventReader(Source) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLEventReader from a JAXP source.
createXMLEventReader(InputStream) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLEventReader from a java.io.InputStream
createXMLEventReader(InputStream, String) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLEventReader from a java.io.InputStream
createXMLEventReader(String, InputStream) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLEventReader from a java.io.InputStream
createXMLEventWriter(Result) - Method in class javax.xml.stream.XMLOutputFactory
Create a new XMLEventWriter that writes to a JAXP result.
createXMLEventWriter(OutputStream) - Method in class javax.xml.stream.XMLOutputFactory
Create a new XMLEventWriter that writes to a stream
createXMLEventWriter(OutputStream, String) - Method in class javax.xml.stream.XMLOutputFactory
Create a new XMLEventWriter that writes to a stream
createXMLEventWriter(Writer) - Method in class javax.xml.stream.XMLOutputFactory
Create a new XMLEventWriter that writes to a writer
createXMLReader() - Static method in class org.xml.sax.helpers.XMLReaderFactory
Attempt to create an XMLReader from system defaults.
createXMLReader(String) - Static method in class org.xml.sax.helpers.XMLReaderFactory
Attempt to create an XML reader from a class name.
createXMLStreamReader(Reader) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLStreamReader from a reader
createXMLStreamReader(Source) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLStreamReader from a JAXP source.
createXMLStreamReader(InputStream) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLStreamReader from a java.io.InputStream
createXMLStreamReader(InputStream, String) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLStreamReader from a java.io.InputStream
createXMLStreamReader(String, InputStream) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLStreamReader from a java.io.InputStream
createXMLStreamReader(String, Reader) - Method in class javax.xml.stream.XMLInputFactory
Create a new XMLStreamReader from a java.io.InputStream
createXMLStreamWriter(Writer) - Method in class javax.xml.stream.XMLOutputFactory
Create a new XMLStreamWriter that writes to a writer
createXMLStreamWriter(OutputStream) - Method in class javax.xml.stream.XMLOutputFactory
Create a new XMLStreamWriter that writes to a stream
createXMLStreamWriter(OutputStream, String) - Method in class javax.xml.stream.XMLOutputFactory
Create a new XMLStreamWriter that writes to a stream
createXMLStreamWriter(Result) - Method in class javax.xml.stream.XMLOutputFactory
Create a new XMLStreamWriter that writes to a JAXP result.
createZipEntry(String) - Method in class java.util.jar.JarInputStream
Creates a new JarEntry (ZipEntry) for the specified JAR file entry name.
createZipEntry(String) - Method in class java.util.zip.ZipInputStream
Creates a new ZipEntry object for the specified entry name.
createZone(int, int) - Method in class javax.swing.text.ZoneView
Create a view to represent a zone for the given range within the model (which should be within the range of this objects responsibility).
creationTime() - Method in interface java.nio.file.attribute.BasicFileAttributes
Returns the creation time.
CredentialException - Exception in javax.security.auth.login
A generic credential exception.
CredentialException() - Constructor for exception javax.security.auth.login.CredentialException
Constructs a CredentialException with no detail message.
CredentialException(String) - Constructor for exception javax.security.auth.login.CredentialException
Constructs a CredentialException with the specified detail message.
CredentialExpiredException - Exception in javax.security.auth.login
Signals that a Credential has expired.
CredentialExpiredException() - Constructor for exception javax.security.auth.login.CredentialExpiredException
Constructs a CredentialExpiredException with no detail message.
CredentialExpiredException(String) - Constructor for exception javax.security.auth.login.CredentialExpiredException
Constructs a CredentialExpiredException with the specified detail message.
CredentialNotFoundException - Exception in javax.security.auth.login
Signals that a credential was not found.
CredentialNotFoundException() - Constructor for exception javax.security.auth.login.CredentialNotFoundException
Constructs a CredentialNotFoundException with no detail message.
CredentialNotFoundException(String) - Constructor for exception javax.security.auth.login.CredentialNotFoundException
Constructs a CredentialNotFoundException with the specified detail message.
CREDENTIALS - Static variable in interface javax.management.remote.JMXConnector
Name of the attribute that specifies the credentials to send to the connector server during connection.
CREDENTIALS - Static variable in class javax.security.sasl.Sasl
The name of a property that specifies the credentials to use.
CREDENTIALS_EXPIRED - Static variable in exception org.ietf.jgss.GSSException
Expired credentials.
CRITICAL - Static variable in interface javax.naming.ldap.Control
Indicates a critical control.
criticality - Variable in class javax.naming.ldap.BasicControl
The control's criticality.
CRL - Class in java.security.cert
This class is an abstraction of certificate revocation lists (CRLs) that have different formats but important common uses.
CRL(String) - Constructor for class java.security.cert.CRL
Creates a CRL of the specified type.
CRLException - Exception in java.security.cert
CRL (Certificate Revocation List) Exception.
CRLException() - Constructor for exception java.security.cert.CRLException
Constructs a CRLException with no detail message.
CRLException(String) - Constructor for exception java.security.cert.CRLException
Constructs a CRLException with the specified detail message.
CRLException(String, Throwable) - Constructor for exception java.security.cert.CRLException
Creates a CRLException with the specified detail message and cause.
CRLException(Throwable) - Constructor for exception java.security.cert.CRLException
Creates a CRLException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
CRLReason - Enum in java.security.cert
The CRLReason enumeration specifies the reason that a certificate is revoked, as defined in RFC 3280: Internet X.509 Public Key Infrastructure Certificate and CRL Profile.
CRLSelector - Interface in java.security.cert
A selector that defines a set of criteria for selecting CRLs.
CropImageFilter - Class in java.awt.image
An ImageFilter class for cropping images.
CropImageFilter(int, int, int, int) - Constructor for class java.awt.image.CropImageFilter
Constructs a CropImageFilter that extracts the absolute rectangular region of pixels from its source Image as specified by the x, y, w, and h parameters.
CROSS_JOIN - Static variable in interface javax.sql.rowset.JoinRowSet
An ANSI-style JOIN providing a cross product of two tables
CROSSHAIR_CURSOR - Static variable in class java.awt.Cursor
The crosshair cursor type.
CROSSHAIR_CURSOR - Static variable in class java.awt.Frame
Deprecated.
replaced by Cursor.CROSSHAIR_CURSOR.
CryptoPrimitive - Enum in java.security
An enumeration of cryptographic primitives.
CS_CIEXYZ - Static variable in class java.awt.color.ColorSpace
The CIEXYZ conversion color space defined above.
CS_GRAY - Static variable in class java.awt.color.ColorSpace
The built-in linear gray scale color space.
CS_LINEAR_RGB - Static variable in class java.awt.color.ColorSpace
A built-in linear RGB color space.
CS_PYCC - Static variable in class java.awt.color.ColorSpace
The Photo YCC conversion color space.
CS_sRGB - Static variable in class java.awt.color.ColorSpace
The sRGB color space defined at http://www.w3.org/pub/WWW/Graphics/Color/sRGB.html .
CSS - Class in javax.swing.text.html
Defines a set of CSS attributes as a typesafe enumeration.
CSS() - Constructor for class javax.swing.text.html.CSS
CSS.Attribute - Class in javax.swing.text.html
Definitions to be used as a key on AttributeSet's that might hold CSS attributes.
CTRL_DOWN_MASK - Static variable in class java.awt.event.InputEvent
The Control key extended modifier constant.
CTRL_MASK - Static variable in class java.awt.event.ActionEvent
The control modifier.
CTRL_MASK - Static variable in class java.awt.Event
This flag indicates that the Control key was down when the event occurred.
CTRL_MASK - Static variable in class java.awt.event.InputEvent
The Control key modifier constant.
ctrlx - Variable in class java.awt.geom.QuadCurve2D.Double
The X coordinate of the control point of the quadratic curve segment.
ctrlx - Variable in class java.awt.geom.QuadCurve2D.Float
The X coordinate of the control point of the quadratic curve segment.
ctrlx1 - Variable in class java.awt.geom.CubicCurve2D.Double
The X coordinate of the first control point of the cubic curve segment.
ctrlx1 - Variable in class java.awt.geom.CubicCurve2D.Float
The X coordinate of the first control point of the cubic curve segment.
ctrlx2 - Variable in class java.awt.geom.CubicCurve2D.Double
The X coordinate of the second control point of the cubic curve segment.
ctrlx2 - Variable in class java.awt.geom.CubicCurve2D.Float
The X coordinate of the second control point of the cubic curve segment.
ctrly - Variable in class java.awt.geom.QuadCurve2D.Double
The Y coordinate of the control point of the quadratic curve segment.
ctrly - Variable in class java.awt.geom.QuadCurve2D.Float
The Y coordinate of the control point of the quadratic curve segment.
ctrly1 - Variable in class java.awt.geom.CubicCurve2D.Double
The Y coordinate of the first control point of the cubic curve segment.
ctrly1 - Variable in class java.awt.geom.CubicCurve2D.Float
The Y coordinate of the first control point of the cubic curve segment.
ctrly2 - Variable in class java.awt.geom.CubicCurve2D.Double
The Y coordinate of the second control point of the cubic curve segment.
ctrly2 - Variable in class java.awt.geom.CubicCurve2D.Float
The Y coordinate of the second control point of the cubic curve segment.
ctx() - Method in class org.omg.CORBA.Request
Retrieves the Context object for this request.
ctx(Context) - Method in class org.omg.CORBA.Request
Sets this request's Context object to the one given.
ctx() - Method in class org.omg.CORBA.ServerRequest
Returns the context information specified in IDL for the operation when the operation is not an attribute access and the operation's IDL definition contains a context expression; otherwise it returns a nil Context reference.
CTX_RESTRICT_SCOPE - Interface in org.omg.CORBA
A flag that can be used as the second parameter to the method Context.get_values to restrict the search scope.
CubicCurve2D - Class in java.awt.geom
The CubicCurve2D class defines a cubic parametric curve segment in (x,y) coordinate space.
CubicCurve2D() - Constructor for class java.awt.geom.CubicCurve2D
This is an abstract class that cannot be instantiated directly.
CubicCurve2D.Double - Class in java.awt.geom
A cubic parametric curve segment specified with double coordinates.
CubicCurve2D.Float - Class in java.awt.geom
A cubic parametric curve segment specified with float coordinates.
CUNEIFORM - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Cuneiform" Unicode character block.
CUNEIFORM_NUMBERS_AND_PUNCTUATION - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Cuneiform Numbers and Punctuation" Unicode character block.
CURRENCY - Static variable in class java.text.NumberFormat.Field
Constant identifying the currency field.
Currency - Class in java.util
Represents a currency.
CURRENCY_SYMBOL - Static variable in class java.lang.Character
General category "Sc" in the Unicode specification.
CURRENCY_SYMBOLS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Currency Symbols" Unicode character block.
CurrencyNameProvider - Class in java.util.spi
An abstract class for service providers that provide localized currency symbols and display names for the Currency class.
CurrencyNameProvider() - Constructor for class java.util.spi.CurrencyNameProvider
Sole constructor.
current() - Method in class java.text.BreakIterator
Returns character index of the text boundary that was most recently returned by next(), next(int), previous(), first(), last(), following(int) or preceding(int).
current() - Method in interface java.text.CharacterIterator
Gets the character at the current position (as returned by getIndex()).
current() - Method in class java.text.StringCharacterIterator
Implements CharacterIterator.current() for String.
current() - Static method in class java.util.concurrent.ThreadLocalRandom
Returns the current thread's ThreadLocalRandom.
current() - Method in class javax.swing.text.ElementIterator
Fetches the current Element.
CURRENT - Static variable in interface javax.swing.text.html.parser.DTDConstants
current() - Method in class javax.swing.text.Segment
Gets the character at the current position (as returned by getIndex()).
Current - Interface in org.omg.CORBA
Interfaces derived from the Current interface enable ORB and CORBA services to provide access to information (context) associated with the thread of execution in which they are running.
Current - Interface in org.omg.PortableInterceptor
Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context.
Current - Interface in org.omg.PortableServer
The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked.
current_component() - Method in interface org.omg.CORBA.DynAny
Deprecated.
Returns a DynAny object reference that can be used to get/set the value of the component currently accessed.
current_component() - Method in class org.omg.DynamicAny._DynAnyStub
Returns the DynAny for the component at the current position.
current_component() - Method in class org.omg.DynamicAny._DynArrayStub
Returns the DynAny for the component at the current position.
current_component() - Method in class org.omg.DynamicAny._DynEnumStub
Returns the DynAny for the component at the current position.
current_component() - Method in class org.omg.DynamicAny._DynFixedStub
Returns the DynAny for the component at the current position.
current_component() - Method in class org.omg.DynamicAny._DynSequenceStub
Returns the DynAny for the component at the current position.
current_component() - Method in class org.omg.DynamicAny._DynStructStub
Returns the DynAny for the component at the current position.
current_component() - Method in class org.omg.DynamicAny._DynUnionStub
Returns the DynAny for the component at the current position.
current_component() - Method in class org.omg.DynamicAny._DynValueStub
Returns the DynAny for the component at the current position.
current_component() - Method in interface org.omg.DynamicAny.DynAnyOperations
Returns the DynAny for the component at the current position.
current_factory() - Method in interface org.omg.PortableInterceptor.IORInfoOperations
On read, returns the current factory that will be used to create object references for the object adapter that was just created and is running IOR interceptors.
current_factory(ObjectReferenceFactory) - Method in interface org.omg.PortableInterceptor.IORInfoOperations
On read, returns the current factory that will be used to create object references for the object adapter that was just created and is running IOR interceptors.
current_member_kind() - Method in interface org.omg.CORBA.DynStruct
Deprecated.
Returns the TCKind object that describes the kind of the current member.
current_member_kind() - Method in interface org.omg.CORBA.DynValue
Deprecated.
Returns the TCKind object that describes the current member.
current_member_kind() - Method in class org.omg.DynamicAny._DynStructStub
Returns the TCKind associated with the member at the current position.
current_member_kind() - Method in class org.omg.DynamicAny._DynValueStub
Returns the TCKind associated with the member at the current position.
current_member_kind() - Method in interface org.omg.DynamicAny.DynStructOperations
Returns the TCKind associated with the member at the current position.
current_member_kind() - Method in interface org.omg.DynamicAny.DynValueOperations
Returns the TCKind associated with the member at the current position.
current_member_name() - Method in interface org.omg.CORBA.DynStruct
Deprecated.
During a traversal, returns the name of the current member.
current_member_name() - Method in interface org.omg.CORBA.DynValue
Deprecated.
Returns the name of the current member while traversing a DynAny object that represents a Value object.
current_member_name() - Method in class org.omg.DynamicAny._DynStructStub
Returns the name of the member at the current position.
current_member_name() - Method in class org.omg.DynamicAny._DynValueStub
Returns the name of the member at the current position.
current_member_name() - Method in interface org.omg.DynamicAny.DynStructOperations
Returns the name of the member at the current position.
current_member_name() - Method in interface org.omg.DynamicAny.DynValueOperations
Returns the name of the member at the current position.
currentCellRenderer - Variable in class javax.swing.plaf.basic.BasicTreeUI
Renderer that is being used to do the actual cell drawing.
currentClassLoader() - Method in class java.lang.SecurityManager
Deprecated.
This type of security checking is not recommended. It is recommended that the checkPermission call be used instead.
currentGroupID() - Static method in class java.rmi.activation.ActivationGroup
Returns the current activation group's identifier.
CurrentHelper - Class in org.omg.CORBA
The Helper for Current.
CurrentHelper() - Constructor for class org.omg.CORBA.CurrentHelper
CurrentHelper - Class in org.omg.PortableInterceptor
Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context.
CurrentHelper() - Constructor for class org.omg.PortableInterceptor.CurrentHelper
CurrentHelper - Class in org.omg.PortableServer
The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked.
CurrentHelper() - Constructor for class org.omg.PortableServer.CurrentHelper
CurrentHolder - Class in org.omg.CORBA
The Holder for Current.
CurrentHolder() - Constructor for class org.omg.CORBA.CurrentHolder
CurrentHolder(Current) - Constructor for class org.omg.CORBA.CurrentHolder
currentLoadedClass() - Method in class java.lang.SecurityManager
Deprecated.
This type of security checking is not recommended. It is recommended that the checkPermission call be used instead.
currentManager(Component) - Static method in class javax.swing.RepaintManager
Return the RepaintManager for the calling thread given a Component.
currentManager(JComponent) - Static method in class javax.swing.RepaintManager
Return the RepaintManager for the calling thread given a JComponent.
currentMouseX - Variable in class javax.swing.plaf.basic.BasicScrollBarUI.TrackListener
currentMouseX - Variable in class javax.swing.plaf.basic.BasicSliderUI.TrackListener
currentMouseY - Variable in class javax.swing.plaf.basic.BasicScrollBarUI.TrackListener
currentMouseY - Variable in class javax.swing.plaf.basic.BasicSliderUI.TrackListener
CurrentOperations - Interface in org.omg.CORBA
The interface for Current.
CurrentOperations - Interface in org.omg.PortableInterceptor
Portable Interceptors Current (also known as PICurrent) is merely a slot table, the slots of which are used by each service to transfer their context data between their context and the request's or reply's service context.
CurrentOperations - Interface in org.omg.PortableServer
The PortableServer::Current interface, derived from CORBA::Current, provides method implementations with access to the identity of the object on which the method was invoked.
currentSegment(float[]) - Method in class java.awt.geom.FlatteningPathIterator
Returns the coordinates and type of the current path segment in the iteration.
currentSegment(double[]) - Method in class java.awt.geom.FlatteningPathIterator
Returns the coordinates and type of the current path segment in the iteration.
currentSegment(float[]) - Method in interface java.awt.geom.PathIterator
Returns the coordinates and type of the current path segment in the iteration.
currentSegment(double[]) - Method in interface java.awt.geom.PathIterator
Returns the coordinates and type of the current path segment in the iteration.
currentThread() - Static method in class java.lang.Thread
Returns a reference to the currently executing thread object.
currentTimeMillis() - Static method in class java.lang.System
Returns the current time in milliseconds.
currentValuePane - Variable in class javax.swing.plaf.basic.BasicComboBoxUI
Cursor - Class in java.awt
A class to encapsulate the bitmap representation of the mouse cursor.
Cursor(int) - Constructor for class java.awt.Cursor
Creates a new cursor object with the specified type.
Cursor(String) - Constructor for class java.awt.Cursor
Creates a new custom cursor object with the specified name.
cursorMoved(RowSetEvent) - Method in interface javax.sql.RowSetListener
Notifies registered listeners that a RowSet object's cursor has moved.
curveTo(double, double, double, double, double, double) - Method in class java.awt.geom.Path2D
Adds a curved segment, defined by three new points, to the path by drawing a Bézier curve that intersects both the current coordinates and the specified coordinates (x3,y3), using the specified points (x1,y1) and (x2,y2) as Bézier control points.
curveTo(double, double, double, double, double, double) - Method in class java.awt.geom.Path2D.Double
Adds a curved segment, defined by three new points, to the path by drawing a Bézier curve that intersects both the current coordinates and the specified coordinates (x3,y3), using the specified points (x1,y1) and (x2,y2) as Bézier control points.
curveTo(double, double, double, double, double, double) - Method in class java.awt.geom.Path2D.Float
Adds a curved segment, defined by three new points, to the path by drawing a Bézier curve that intersects both the current coordinates and the specified coordinates (x3,y3), using the specified points (x1,y1) and (x2,y2) as Bézier control points.
curveTo(float, float, float, float, float, float) - Method in class java.awt.geom.Path2D.Float
Adds a curved segment, defined by three new points, to the path by drawing a Bézier curve that intersects both the current coordinates and the specified coordinates (x3,y3), using the specified points (x1,y1) and (x2,y2) as Bézier control points.
CUSTOM_CURSOR - Static variable in class java.awt.Cursor
The type associated with all custom cursors.
CUSTOM_DIALOG - Static variable in class javax.swing.JFileChooser
Type value indicating that the JFileChooser supports a developer-specified file operation.
Customizer - Interface in java.beans
A customizer class provides a complete custom GUI for customizing a target Java Bean.
CustomMarshal - Interface in org.omg.CORBA
An abstract value type that is meant to be used by the ORB, not the user.
CustomValue - Interface in org.omg.CORBA.portable
An extension of ValueBase that is implemented by custom value types.
cut(int, int) - Method in interface javax.accessibility.AccessibleEditableText
Cuts the text between two indices into the system clipboard.
cut() - Method in class javax.swing.JPasswordField
Invokes provideErrorFeedback on the current look and feel, which typically initiates an error beep.
cut(int, int) - Method in class javax.swing.JSpinner.AccessibleJSpinner
Cuts the text between two indices into the system clipboard.
cut(int, int) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent
Cuts the text between two indices into the system clipboard.
cut() - Method in class javax.swing.text.JTextComponent
Transfers the currently selected range in the associated text model to the system clipboard, removing the contents from the model.
cutAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the action to cut the selected region and place the contents into the system clipboard.
CutAction() - Constructor for class javax.swing.text.DefaultEditorKit.CutAction
Create this object with the appropriate identifier.
cxt - Variable in exception org.omg.CosNaming.NamingContextPackage.CannotProceed
cyan - Static variable in class java.awt.Color
The color cyan.
CYAN - Static variable in class java.awt.Color
The color cyan.
CyclicBarrier - Class in java.util.concurrent
A synchronization aid that allows a set of threads to all wait for each other to reach a common barrier point.
CyclicBarrier(int, Runnable) - Constructor for class java.util.concurrent.CyclicBarrier
Creates a new CyclicBarrier that will trip when the given number of parties (threads) are waiting upon it, and which will execute the given barrier action when the barrier is tripped, performed by the last thread entering the barrier.
CyclicBarrier(int) - Constructor for class java.util.concurrent.CyclicBarrier
Creates a new CyclicBarrier that will trip when the given number of parties (threads) are waiting upon it, and does not perform a predefined action when the barrier is tripped.
CYPRIOT_SYLLABARY - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Cypriot Syllabary" Unicode character block.
CYRILLIC - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Cyrillic" Unicode character block.
CYRILLIC_EXTENDED_A - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Cyrillic Extended-A" Unicode character block.
CYRILLIC_EXTENDED_B - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Cyrillic Extended-B" Unicode character block.
CYRILLIC_SUPPLEMENTARY - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Cyrillic Supplementary" Unicode character block.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames


D-Index (Java Platform SE 8 )

Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames
  • All Classes
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

D

D - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for Engineering D, 22 x 34 in.
D - Static variable in class javax.print.attribute.standard.MediaSize.Engineering
Specifies the engineering D size, 22 inch by 34 inch.
D - Static variable in class javax.print.attribute.standard.MediaSizeName
D size .
damage(Rectangle) - Method in class javax.swing.text.DefaultCaret
Damages the area surrounding the caret to cause it to be repainted in a new location.
damageLineRange(int, int, Shape, Component) - Method in class javax.swing.text.PlainView
Repaint the given line range.
damageRange(JTextComponent, int, int) - Method in class javax.swing.plaf.basic.BasicTextUI
Causes the portion of the view responsible for the given part of the model to be repainted.
damageRange(JTextComponent, int, int, Position.Bias, Position.Bias) - Method in class javax.swing.plaf.basic.BasicTextUI
Causes the portion of the view responsible for the given part of the model to be repainted.
damageRange(JTextComponent, int, int) - Method in class javax.swing.plaf.multi.MultiTextUI
Invokes the damageRange method on each UI handled by this object.
damageRange(JTextComponent, int, int, Position.Bias, Position.Bias) - Method in class javax.swing.plaf.multi.MultiTextUI
Invokes the damageRange method on each UI handled by this object.
damageRange(JTextComponent, int, int) - Method in class javax.swing.plaf.TextUI
Causes the portion of the view responsible for the given part of the model to be repainted.
damageRange(JTextComponent, int, int, Position.Bias, Position.Bias) - Method in class javax.swing.plaf.TextUI
Causes the portion of the view responsible for the given part of the model to be repainted.
DARK - Static variable in class javax.swing.plaf.metal.MetalIconFactory
DARK_GRAY - Static variable in class java.awt.Color
The color dark gray.
darker() - Method in class java.awt.Color
Creates a new Color that is a darker version of this Color.
darkGray - Static variable in class java.awt.Color
The color dark gray.
darkShadow - Variable in class javax.swing.plaf.basic.BasicBorders.ButtonBorder
darkShadow - Variable in class javax.swing.plaf.basic.BasicBorders.FieldBorder
darkShadow - Variable in class javax.swing.plaf.basic.BasicTabbedPaneUI
darkShadowColor - Static variable in class javax.swing.plaf.metal.MetalSliderUI
DASH_PUNCTUATION - Static variable in class java.lang.Character
General category "Pd" in the Unicode specification.
data - Variable in class javax.sound.midi.MidiMessage
The MIDI message data.
DATA - Static variable in class javax.swing.text.html.HTML.Attribute
data - Variable in class javax.swing.text.html.parser.Element
A field to store user data.
data - Variable in class javax.swing.text.html.parser.Entity
Data - Interface in javax.xml.crypto
An abstract representation of the result of dereferencing a URIReference or the input/output of subsequent Transforms.
DATA_CONVERSION - Exception in org.omg.CORBA
This exception is raised if an ORB cannot convert the representation of data as marshaled into its native representation or vice-versa.
DATA_CONVERSION() - Constructor for exception org.omg.CORBA.DATA_CONVERSION
Constructs a DATA_CONVERSION exception with a default minor code of 0 and a completion state of COMPLETED_NO.
DATA_CONVERSION(String) - Constructor for exception org.omg.CORBA.DATA_CONVERSION
Constructs a DATA_CONVERSION exception with the specified detail.
DATA_CONVERSION(int, CompletionStatus) - Constructor for exception org.omg.CORBA.DATA_CONVERSION
Constructs a DATA_CONVERSION exception with the specified minor code and completion status.
DATA_CONVERSION(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.DATA_CONVERSION
Constructs a DATA_CONVERSION exception with the specified detail message, minor code, and completion status.
DATA_TRANSFER_COMPLETE - Static variable in class javax.print.event.PrintJobEvent
The job is not necessarily printed yet, but the data has been transferred successfully from the client to the print service.
DatabaseMetaData - Interface in java.sql
Comprehensive information about the database as a whole.
DataBindingException - Exception in javax.xml.bind
Exception that represents a failure in a JAXB operation.
DataBindingException(String, Throwable) - Constructor for exception javax.xml.bind.DataBindingException
DataBindingException(Throwable) - Constructor for exception javax.xml.bind.DataBindingException
DataBuffer - Class in java.awt.image
This class exists to wrap one or more data arrays.
DataBuffer(int, int) - Constructor for class java.awt.image.DataBuffer
Constructs a DataBuffer containing one bank of the specified data type and size.
DataBuffer(int, int, int) - Constructor for class java.awt.image.DataBuffer
Constructs a DataBuffer containing the specified number of banks.
DataBuffer(int, int, int, int) - Constructor for class java.awt.image.DataBuffer
Constructs a DataBuffer that contains the specified number of banks.
DataBuffer(int, int, int, int[]) - Constructor for class java.awt.image.DataBuffer
Constructs a DataBuffer which contains the specified number of banks.
dataBuffer - Variable in class java.awt.image.Raster
The DataBuffer that stores the image data.
DataBufferByte - Class in java.awt.image
This class extends DataBuffer and stores data internally as bytes.
DataBufferByte(int) - Constructor for class java.awt.image.DataBufferByte
Constructs a byte-based DataBuffer with a single bank and the specified size.
DataBufferByte(int, int) - Constructor for class java.awt.image.DataBufferByte
Constructs a byte based DataBuffer with the specified number of banks all of which are the specified size.
DataBufferByte(byte[], int) - Constructor for class java.awt.image.DataBufferByte
Constructs a byte-based DataBuffer with a single bank using the specified array.
DataBufferByte(byte[], int, int) - Constructor for class java.awt.image.DataBufferByte
Constructs a byte-based DataBuffer with a single bank using the specified array, size, and offset.
DataBufferByte(byte[][], int) - Constructor for class java.awt.image.DataBufferByte
Constructs a byte-based DataBuffer with the specified arrays.
DataBufferByte(byte[][], int, int[]) - Constructor for class java.awt.image.DataBufferByte
Constructs a byte-based DataBuffer with the specified arrays, size, and offsets.
DataBufferDouble - Class in java.awt.image
This class extends DataBuffer and stores data internally in double form.
DataBufferDouble(int) - Constructor for class java.awt.image.DataBufferDouble
Constructs a double-based DataBuffer with a specified size.
DataBufferDouble(int, int) - Constructor for class java.awt.image.DataBufferDouble
Constructs a double-based DataBuffer with a specified number of banks, all of which are of a specified size.
DataBufferDouble(double[], int) - Constructor for class java.awt.image.DataBufferDouble
Constructs a double-based DataBuffer with the specified data array.
DataBufferDouble(double[], int, int) - Constructor for class java.awt.image.DataBufferDouble
Constructs a double-based DataBuffer with the specified data array.
DataBufferDouble(double[][], int) - Constructor for class java.awt.image.DataBufferDouble
Constructs a double-based DataBuffer with the specified data arrays.
DataBufferDouble(double[][], int, int[]) - Constructor for class java.awt.image.DataBufferDouble
Constructs a double-based DataBuffer with the specified data arrays, size, and per-bank offsets.
DataBufferFloat - Class in java.awt.image
This class extends DataBuffer and stores data internally in float form.
DataBufferFloat(int) - Constructor for class java.awt.image.DataBufferFloat
Constructs a float-based DataBuffer with a specified size.
DataBufferFloat(int, int) - Constructor for class java.awt.image.DataBufferFloat
Constructs a float-based DataBuffer with a specified number of banks, all of which are of a specified size.
DataBufferFloat(float[], int) - Constructor for class java.awt.image.DataBufferFloat
Constructs a float-based DataBuffer with the specified data array.
DataBufferFloat(float[], int, int) - Constructor for class java.awt.image.DataBufferFloat
Constructs a float-based DataBuffer with the specified data array.
DataBufferFloat(float[][], int) - Constructor for class java.awt.image.DataBufferFloat
Constructs a float-based DataBuffer with the specified data arrays.
DataBufferFloat(float[][], int, int[]) - Constructor for class java.awt.image.DataBufferFloat
Constructs a float-based DataBuffer with the specified data arrays, size, and per-bank offsets.
DataBufferInt - Class in java.awt.image
This class extends DataBuffer and stores data internally as integers.
DataBufferInt(int) - Constructor for class java.awt.image.DataBufferInt
Constructs an integer-based DataBuffer with a single bank and the specified size.
DataBufferInt(int, int) - Constructor for class java.awt.image.DataBufferInt
Constructs an integer-based DataBuffer with the specified number of banks, all of which are the specified size.
DataBufferInt(int[], int) - Constructor for class java.awt.image.DataBufferInt
Constructs an integer-based DataBuffer with a single bank using the specified array.
DataBufferInt(int[], int, int) - Constructor for class java.awt.image.DataBufferInt
Constructs an integer-based DataBuffer with a single bank using the specified array, size, and offset.
DataBufferInt(int[][], int) - Constructor for class java.awt.image.DataBufferInt
Constructs an integer-based DataBuffer with the specified arrays.
DataBufferInt(int[][], int, int[]) - Constructor for class java.awt.image.DataBufferInt
Constructs an integer-based DataBuffer with the specified arrays, size, and offsets.
DataBufferShort - Class in java.awt.image
This class extends DataBuffer and stores data internally as shorts.
DataBufferShort(int) - Constructor for class java.awt.image.DataBufferShort
Constructs a short-based DataBuffer with a single bank and the specified size.
DataBufferShort(int, int) - Constructor for class java.awt.image.DataBufferShort
Constructs a short-based DataBuffer with the specified number of banks all of which are the specified size.
DataBufferShort(short[], int) - Constructor for class java.awt.image.DataBufferShort
Constructs a short-based DataBuffer with a single bank using the specified array.
DataBufferShort(short[], int, int) - Constructor for class java.awt.image.DataBufferShort
Constructs a short-based DataBuffer with a single bank using the specified array, size, and offset.
DataBufferShort(short[][], int) - Constructor for class java.awt.image.DataBufferShort
Constructs a short-based DataBuffer with the specified arrays.
DataBufferShort(short[][], int, int[]) - Constructor for class java.awt.image.DataBufferShort
Constructs a short-based DataBuffer with the specified arrays, size, and offsets.
DataBufferUShort - Class in java.awt.image
This class extends DataBuffer and stores data internally as shorts.
DataBufferUShort(int) - Constructor for class java.awt.image.DataBufferUShort
Constructs an unsigned-short based DataBuffer with a single bank and the specified size.
DataBufferUShort(int, int) - Constructor for class java.awt.image.DataBufferUShort
Constructs an unsigned-short based DataBuffer with the specified number of banks, all of which are the specified size.
DataBufferUShort(short[], int) - Constructor for class java.awt.image.DataBufferUShort
Constructs an unsigned-short based DataBuffer with a single bank using the specified array.
DataBufferUShort(short[], int, int) - Constructor for class java.awt.image.DataBufferUShort
Constructs an unsigned-short based DataBuffer with a single bank using the specified array, size, and offset.
DataBufferUShort(short[][], int) - Constructor for class java.awt.image.DataBufferUShort
Constructs an unsigned-short based DataBuffer with the specified arrays.
DataBufferUShort(short[][], int, int[]) - Constructor for class java.awt.image.DataBufferUShort
Constructs an unsigned-short based DataBuffer with specified arrays, size, and offsets.
DataContentHandler - Interface in javax.activation
The DataContentHandler interface is implemented by objects that can be used to extend the capabilities of the DataHandler's implementation of the Transferable interface.
DataContentHandlerFactory - Interface in javax.activation
This interface defines a factory for DataContentHandlers.
dataDefinitionCausesTransactionCommit() - Method in interface java.sql.DatabaseMetaData
Retrieves whether a data definition statement within a transaction forces the transaction to commit.
dataDefinitionIgnoredInTransactions() - Method in interface java.sql.DatabaseMetaData
Retrieves whether this database ignores a data definition statement within a transaction.
DataFlavor - Class in java.awt.datatransfer
A DataFlavor provides meta information about data.
DataFlavor() - Constructor for class java.awt.datatransfer.DataFlavor
Constructs a new DataFlavor.
DataFlavor(Class<?>, String) - Constructor for class java.awt.datatransfer.DataFlavor
Constructs a DataFlavor that represents a Java class.
DataFlavor(String, String) - Constructor for class java.awt.datatransfer.DataFlavor
Constructs a DataFlavor that represents a MimeType.
DataFlavor(String, String, ClassLoader) - Constructor for class java.awt.datatransfer.DataFlavor
Constructs a DataFlavor that represents a MimeType.
DataFlavor(String) - Constructor for class java.awt.datatransfer.DataFlavor
Constructs a DataFlavor from a mimeType string.
DataFormatException - Exception in java.util.zip
Signals that a data format error has occurred.
DataFormatException() - Constructor for exception java.util.zip.DataFormatException
Constructs a DataFormatException with no detail message.
DataFormatException(String) - Constructor for exception java.util.zip.DataFormatException
Constructs a DataFormatException with the specified detail message.
DatagramChannel - Class in java.nio.channels
A selectable channel for datagram-oriented sockets.
DatagramChannel(SelectorProvider) - Constructor for class java.nio.channels.DatagramChannel
Initializes a new instance of this class.
DatagramPacket - Class in java.net
This class represents a datagram packet.
DatagramPacket(byte[], int, int) - Constructor for class java.net.DatagramPacket
Constructs a DatagramPacket for receiving packets of length length, specifying an offset into the buffer.
DatagramPacket(byte[], int) - Constructor for class java.net.DatagramPacket
Constructs a DatagramPacket for receiving packets of length length.
DatagramPacket(byte[], int, int, InetAddress, int) - Constructor for class java.net.DatagramPacket
Constructs a datagram packet for sending packets of length length with offset ioffsetto the specified port number on the specified host.
DatagramPacket(byte[], int, int, SocketAddress) - Constructor for class java.net.DatagramPacket
Constructs a datagram packet for sending packets of length length with offset ioffsetto the specified port number on the specified host.
DatagramPacket(byte[], int, InetAddress, int) - Constructor for class java.net.DatagramPacket
Constructs a datagram packet for sending packets of length length to the specified port number on the specified host.
DatagramPacket(byte[], int, SocketAddress) - Constructor for class java.net.DatagramPacket
Constructs a datagram packet for sending packets of length length to the specified port number on the specified host.
DatagramSocket - Class in java.net
This class represents a socket for sending and receiving datagram packets.
DatagramSocket() - Constructor for class java.net.DatagramSocket
Constructs a datagram socket and binds it to any available port on the local host machine.
DatagramSocket(DatagramSocketImpl) - Constructor for class java.net.DatagramSocket
Creates an unbound datagram socket with the specified DatagramSocketImpl.
DatagramSocket(SocketAddress) - Constructor for class java.net.DatagramSocket
Creates a datagram socket, bound to the specified local socket address.
DatagramSocket(int) - Constructor for class java.net.DatagramSocket
Constructs a datagram socket and binds it to the specified port on the local host machine.
DatagramSocket(int, InetAddress) - Constructor for class java.net.DatagramSocket
Creates a datagram socket, bound to the specified local address.
DatagramSocketImpl - Class in java.net
Abstract datagram and multicast socket implementation base class.
DatagramSocketImpl() - Constructor for class java.net.DatagramSocketImpl
DatagramSocketImplFactory - Interface in java.net
This interface defines a factory for datagram socket implementations.
DataHandler - Class in javax.activation
The DataHandler class provides a consistent interface to data available in many different sources and formats.
DataHandler(DataSource) - Constructor for class javax.activation.DataHandler
Create a DataHandler instance referencing the specified DataSource.
DataHandler(Object, String) - Constructor for class javax.activation.DataHandler
Create a DataHandler instance representing an object of this MIME type.
DataHandler(URL) - Constructor for class javax.activation.DataHandler
Create a DataHandler instance referencing a URL.
DataInput - Interface in java.io
The DataInput interface provides for reading bytes from a binary stream and reconstructing from them data in any of the Java primitive types.
DataInputStream - Class in java.io
A data input stream lets an application read primitive Java data types from an underlying input stream in a machine-independent way.
DataInputStream(InputStream) - Constructor for class java.io.DataInputStream
Creates a DataInputStream that uses the specified underlying InputStream.
DataInputStream - Interface in org.omg.CORBA
Defines the methods used to read primitive data types from input streams for unmarshaling custom value types.
DataLine - Interface in javax.sound.sampled
DataLine adds media-related functionality to its superinterface, Line.
DataLine.Info - Class in javax.sound.sampled
Besides the class information inherited from its superclass, DataLine.Info provides additional information specific to data lines.
DATALINK - Static variable in class java.sql.Types
The constant in the Java programming language, somtimes referred to as a type code, that identifies the generic SQL type DATALINK.
dataModel - Variable in class javax.swing.JComboBox
This protected field is implementation specific.
dataModel - Variable in class javax.swing.JTable
The TableModel of the table.
DataOutput - Interface in java.io
The DataOutput interface provides for converting data from any of the Java primitive types to a series of bytes and writing these bytes to a binary stream.
DataOutputStream - Class in java.io
A data output stream lets an application write primitive Java data types to an output stream in a portable way.
DataOutputStream(OutputStream) - Constructor for class java.io.DataOutputStream
Creates a new data output stream to write data to the specified underlying output stream.
DataOutputStream - Interface in org.omg.CORBA
Defines the methods used to write primitive data types to output streams for marshalling custom value types.
DataSource - Interface in javax.activation
The DataSource interface provides the JavaBeans Activation Framework with an abstraction of an arbitrary collection of data.
DataSource - Interface in javax.sql
A factory for connections to the physical data source that this DataSource object represents.
DATASOURCE_DB_LOCK - Static variable in class javax.sql.rowset.spi.SyncProvider
Indicates that a lock is placed on the entire data source that is the source of data for the RowSet object that is using this SyncProvider object.
DATASOURCE_NO_LOCK - Static variable in class javax.sql.rowset.spi.SyncProvider
Indicates that no locks remain on the originating data source.
DATASOURCE_ROW_LOCK - Static variable in class javax.sql.rowset.spi.SyncProvider
Indicates that a lock is placed on the rows that are touched by the original SQL statement used to populate the RowSet object that is using this SyncProvider object.
DATASOURCE_TABLE_LOCK - Static variable in class javax.sql.rowset.spi.SyncProvider
Indicates that a lock is placed on all tables that are touched by the original SQL statement used to populate the RowSet object that is using this SyncProvider object.
DataTruncation - Exception in java.sql
An exception thrown as a DataTruncation exception (on writes) or reported as a DataTruncation warning (on reads) when a data values is unexpectedly truncated for reasons other than its having exceeded MaxFieldSize.
DataTruncation(int, boolean, boolean, int, int) - Constructor for exception java.sql.DataTruncation
Creates a DataTruncation object with the SQLState initialized to 01004 when read is set to true and 22001 when read is set to false, the reason set to "Data truncation", the vendor code set to 0, and the other fields set to the given values.
DataTruncation(int, boolean, boolean, int, int, Throwable) - Constructor for exception java.sql.DataTruncation
Creates a DataTruncation object with the SQLState initialized to 01004 when read is set to true and 22001 when read is set to false, the reason set to "Data truncation", the vendor code set to 0, and the other fields set to the given values.
dataType - Variable in class java.awt.image.DataBuffer
The data type of this DataBuffer.
dataType - Variable in class java.awt.image.SampleModel
Data type of the DataBuffer storing the pixel data.
DATATYPE_BOOLEAN - Static variable in interface javax.imageio.metadata.IIOMetadataFormat
A constant returned by getAttributeDataType indicating that the value of an attribute is one of the boolean values 'true' or 'false'.
DATATYPE_DOUBLE - Static variable in interface javax.imageio.metadata.IIOMetadataFormat
A constant returned by getAttributeDataType indicating that the value of an attribute is a string representation of a double-precision decimal floating-point number.
DATATYPE_FLOAT - Static variable in interface javax.imageio.metadata.IIOMetadataFormat
A constant returned by getAttributeDataType indicating that the value of an attribute is a string representation of a decimal floating-point number.
DATATYPE_INTEGER - Static variable in interface javax.imageio.metadata.IIOMetadataFormat
A constant returned by getAttributeDataType indicating that the value of an attribute is a string representation of an integer.
DATATYPE_STRING - Static variable in interface javax.imageio.metadata.IIOMetadataFormat
A constant returned by getAttributeDataType indicating that the value of an attribute is a general Unicode string.
DatatypeConfigurationException - Exception in javax.xml.datatype
Indicates a serious configuration error.
DatatypeConfigurationException() - Constructor for exception javax.xml.datatype.DatatypeConfigurationException
Create a new DatatypeConfigurationException with no specified detail mesage and cause.
DatatypeConfigurationException(String) - Constructor for exception javax.xml.datatype.DatatypeConfigurationException
Create a new DatatypeConfigurationException with the specified detail message.
DatatypeConfigurationException(String, Throwable) - Constructor for exception javax.xml.datatype.DatatypeConfigurationException
Create a new DatatypeConfigurationException with the specified detail message and cause.
DatatypeConfigurationException(Throwable) - Constructor for exception javax.xml.datatype.DatatypeConfigurationException
Create a new DatatypeConfigurationException with the specified cause.
DatatypeConstants - Class in javax.xml.datatype
Utility class to contain basic Datatype values as constants.
DatatypeConstants.Field - Class in javax.xml.datatype
Type-safe enum class that represents six fields of the Duration class.
DatatypeConverter - Class in javax.xml.bind
The javaType binding declaration can be used to customize the binding of an XML schema datatype to a Java datatype.
DatatypeConverterInterface - Interface in javax.xml.bind
The DatatypeConverterInterface is for JAXB provider use only.
DatatypeFactory - Class in javax.xml.datatype
Factory that creates new javax.xml.datatype Objects that map XML to/from Java Objects.
DatatypeFactory() - Constructor for class javax.xml.datatype.DatatypeFactory
Protected constructor to prevent instaniation outside of package.
DATATYPEFACTORY_IMPLEMENTATION_CLASS - Static variable in class javax.xml.datatype.DatatypeFactory
Default implementation class name as defined in JSR 206: Java(TM) API for XML Processing (JAXP) 1.3.
DATATYPEFACTORY_PROPERTY - Static variable in class javax.xml.datatype.DatatypeFactory
Default property name as defined in JSR 206: Java(TM) API for XML Processing (JAXP) 1.3.
dataVector - Variable in class javax.swing.table.DefaultTableModel
The Vector of Vectors of Object values.
Date - Class in java.sql
A thin wrapper around a millisecond value that allows JDBC to identify this as an SQL DATE value.
Date(int, int, int) - Constructor for class java.sql.Date
Deprecated.
instead use the constructor Date(long date)
Date(long) - Constructor for class java.sql.Date
Constructs a Date object using the given milliseconds time value.
DATE - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type DATE.
date(Era, int, int, int) - Method in interface java.time.chrono.Chronology
Obtains a local date in this chronology from the era, year-of-era, month-of-year and day-of-month fields.
date(int, int, int) - Method in interface java.time.chrono.Chronology
Obtains a local date in this chronology from the proleptic-year, month-of-year and day-of-month fields.
date(TemporalAccessor) - Method in interface java.time.chrono.Chronology
Obtains a local date in this chronology from another temporal object.
date(Era, int, int, int) - Method in class java.time.chrono.HijrahChronology
Obtains a local date in Hijrah calendar system from the era, year-of-era, month-of-year and day-of-month fields.
date(int, int, int) - Method in class java.time.chrono.HijrahChronology
Obtains a local date in Hijrah calendar system from the proleptic-year, month-of-year and day-of-month fields.
date(TemporalAccessor) - Method in class java.time.chrono.HijrahChronology
date(Era, int, int, int) - Method in class java.time.chrono.IsoChronology
Obtains an ISO local date from the era, year-of-era, month-of-year and day-of-month fields.
date(int, int, int) - Method in class java.time.chrono.IsoChronology
Obtains an ISO local date from the proleptic-year, month-of-year and day-of-month fields.
date(TemporalAccessor) - Method in class java.time.chrono.IsoChronology
Obtains an ISO local date from another date-time object.
date(Era, int, int, int) - Method in class java.time.chrono.JapaneseChronology
Obtains a local date in Japanese calendar system from the era, year-of-era, month-of-year and day-of-month fields.
date(int, int, int) - Method in class java.time.chrono.JapaneseChronology
Obtains a local date in Japanese calendar system from the proleptic-year, month-of-year and day-of-month fields.
date(TemporalAccessor) - Method in class java.time.chrono.JapaneseChronology
date(Era, int, int, int) - Method in class java.time.chrono.MinguoChronology
Obtains a local date in Minguo calendar system from the era, year-of-era, month-of-year and day-of-month fields.
date(int, int, int) - Method in class java.time.chrono.MinguoChronology
Obtains a local date in Minguo calendar system from the proleptic-year, month-of-year and day-of-month fields.
date(TemporalAccessor) - Method in class java.time.chrono.MinguoChronology
date(Era, int, int, int) - Method in class java.time.chrono.ThaiBuddhistChronology
Obtains a local date in Thai Buddhist calendar system from the era, year-of-era, month-of-year and day-of-month fields.
date(int, int, int) - Method in class java.time.chrono.ThaiBuddhistChronology
Obtains a local date in Thai Buddhist calendar system from the proleptic-year, month-of-year and day-of-month fields.
date(TemporalAccessor) - Method in class java.time.chrono.ThaiBuddhistChronology
DATE - Static variable in class java.util.Calendar
Field number for get and set indicating the day of the month.
Date - Class in java.util
The class Date represents a specific instant in time, with millisecond precision.
Date() - Constructor for class java.util.Date
Allocates a Date object and initializes it so that it represents the time at which it was allocated, measured to the nearest millisecond.
Date(long) - Constructor for class java.util.Date
Allocates a Date object and initializes it to represent the specified number of milliseconds since the standard base time known as "the epoch", namely January 1, 1970, 00:00:00 GMT.
Date(int, int, int) - Constructor for class java.util.Date
Deprecated.
As of JDK version 1.1, replaced by Calendar.set(year + 1900, month, date) or GregorianCalendar(year + 1900, month, date).
Date(int, int, int, int, int) - Constructor for class java.util.Date
Deprecated.
As of JDK version 1.1, replaced by Calendar.set(year + 1900, month, date, hrs, min) or GregorianCalendar(year + 1900, month, date, hrs, min).
Date(int, int, int, int, int, int) - Constructor for class java.util.Date
Deprecated.
As of JDK version 1.1, replaced by Calendar.set(year + 1900, month, date, hrs, min, sec) or GregorianCalendar(year + 1900, month, date, hrs, min, sec).
Date(String) - Constructor for class java.util.Date
Deprecated.
As of JDK version 1.1, replaced by DateFormat.parse(String s).
DATE - Static variable in class javax.management.openmbean.SimpleType
The SimpleType instance describing values whose Java class name is java.util.Date.
DATE - Static variable in class javax.xml.datatype.DatatypeConstants
Fully qualified name for W3C XML Schema 1.0 datatype date.
DATE_EDITOR - Static variable in class javax.accessibility.AccessibleRole
A DATE_EDITOR is a component that allows users to edit java.util.Date and java.util.Time objects
DATE_FIELD - Static variable in class java.text.DateFormat
Useful constant for DATE field alignment.
DateEditor(JSpinner) - Constructor for class javax.swing.JSpinner.DateEditor
Construct a JSpinner editor that supports displaying and editing the value of a SpinnerDateModel with a JFormattedTextField.
DateEditor(JSpinner, String) - Constructor for class javax.swing.JSpinner.DateEditor
Construct a JSpinner editor that supports displaying and editing the value of a SpinnerDateModel with a JFormattedTextField.
dateEpochDay(long) - Method in interface java.time.chrono.Chronology
Obtains a local date in this chronology from the epoch-day.
dateEpochDay(long) - Method in class java.time.chrono.HijrahChronology
Obtains a local date in the Hijrah calendar system from the epoch-day.
dateEpochDay(long) - Method in class java.time.chrono.IsoChronology
Obtains an ISO local date from the epoch-day.
dateEpochDay(long) - Method in class java.time.chrono.JapaneseChronology
Obtains a local date in the Japanese calendar system from the epoch-day.
dateEpochDay(long) - Method in class java.time.chrono.MinguoChronology
Obtains a local date in the Minguo calendar system from the epoch-day.
dateEpochDay(long) - Method in class java.time.chrono.ThaiBuddhistChronology
Obtains a local date in the Thai Buddhist calendar system from the epoch-day.
dateFilter(RowFilter.ComparisonType, Date, int...) - Static method in class javax.swing.RowFilter
Returns a RowFilter that includes entries that have at least one Date value meeting the specified criteria.
DateFormat - Class in java.text
DateFormat is an abstract class for date/time formatting subclasses which formats and parses dates or time in a language-independent manner.
DateFormat() - Constructor for class java.text.DateFormat
Create a new date format.
DateFormat.Field - Class in java.text
Defines constants that are used as attribute keys in the AttributedCharacterIterator returned from DateFormat.formatToCharacterIterator and as field identifiers in FieldPosition.
DateFormatProvider - Class in java.text.spi
An abstract class for service providers that provide concrete implementations of the DateFormat class.
DateFormatProvider() - Constructor for class java.text.spi.DateFormatProvider
Sole constructor.
DateFormatSymbols - Class in java.text
DateFormatSymbols is a public class for encapsulating localizable date-time formatting data, such as the names of the months, the names of the days of the week, and the time zone data.
DateFormatSymbols() - Constructor for class java.text.DateFormatSymbols
Construct a DateFormatSymbols object by loading format data from resources for the default FORMAT locale.
DateFormatSymbols(Locale) - Constructor for class java.text.DateFormatSymbols
Construct a DateFormatSymbols object by loading format data from resources for the given locale.
DateFormatSymbolsProvider - Class in java.text.spi
An abstract class for service providers that provide instances of the DateFormatSymbols class.
DateFormatSymbolsProvider() - Constructor for class java.text.spi.DateFormatSymbolsProvider
Sole constructor.
DateFormatter - Class in javax.swing.text
DateFormatter is an InternationalFormatter that does its formatting by way of an instance of java.text.DateFormat.
DateFormatter() - Constructor for class javax.swing.text.DateFormatter
This is shorthand for new DateFormatter(DateFormat.getDateInstance()).
DateFormatter(DateFormat) - Constructor for class javax.swing.text.DateFormatter
Returns a DateFormatter configured with the specified Format instance.
dateNow() - Method in interface java.time.chrono.Chronology
Obtains the current local date in this chronology from the system clock in the default time-zone.
dateNow(ZoneId) - Method in interface java.time.chrono.Chronology
Obtains the current local date in this chronology from the system clock in the specified time-zone.
dateNow(Clock) - Method in interface java.time.chrono.Chronology
Obtains the current local date in this chronology from the specified clock.
dateNow() - Method in class java.time.chrono.HijrahChronology
dateNow(ZoneId) - Method in class java.time.chrono.HijrahChronology
dateNow(Clock) - Method in class java.time.chrono.HijrahChronology
dateNow() - Method in class java.time.chrono.IsoChronology
Obtains the current ISO local date from the system clock in the default time-zone.
dateNow(ZoneId) - Method in class java.time.chrono.IsoChronology
Obtains the current ISO local date from the system clock in the specified time-zone.
dateNow(Clock) - Method in class java.time.chrono.IsoChronology
Obtains the current ISO local date from the specified clock.
dateNow() - Method in class java.time.chrono.JapaneseChronology
dateNow(ZoneId) - Method in class java.time.chrono.JapaneseChronology
dateNow(Clock) - Method in class java.time.chrono.JapaneseChronology
dateNow() - Method in class java.time.chrono.MinguoChronology
dateNow(ZoneId) - Method in class java.time.chrono.MinguoChronology
dateNow(Clock) - Method in class java.time.chrono.MinguoChronology
dateNow() - Method in class java.time.chrono.ThaiBuddhistChronology
dateNow(ZoneId) - Method in class java.time.chrono.ThaiBuddhistChronology
dateNow(Clock) - Method in class java.time.chrono.ThaiBuddhistChronology
DATETIME - Static variable in class javax.xml.datatype.DatatypeConstants
Fully qualified name for W3C XML Schema 1.0 datatype dateTime.
DateTimeAtCompleted - Class in javax.print.attribute.standard
Class DateTimeAtCompleted is a printing attribute class, a date-time attribute, that indicates the date and time at which the Print Job completed (or was canceled or aborted).
DateTimeAtCompleted(Date) - Constructor for class javax.print.attribute.standard.DateTimeAtCompleted
Construct a new date-time at completed attribute with the given Date value.
DateTimeAtCreation - Class in javax.print.attribute.standard
Class DateTimeAtCreation is a printing attribute class, a date-time attribute, that indicates the date and time at which the Print Job was created.
DateTimeAtCreation(Date) - Constructor for class javax.print.attribute.standard.DateTimeAtCreation
Construct a new date-time at creation attribute with the given Date value.
DateTimeAtProcessing - Class in javax.print.attribute.standard
Class DateTimeAtProcessing is a printing attribute class, a date-time attribute, that indicates the date and time at which the Print Job first began processing.
DateTimeAtProcessing(Date) - Constructor for class javax.print.attribute.standard.DateTimeAtProcessing
Construct a new date-time at processing attribute with the given Date value.
DateTimeException - Exception in java.time
Exception used to indicate a problem while calculating a date-time.
DateTimeException(String) - Constructor for exception java.time.DateTimeException
Constructs a new date-time exception with the specified message.
DateTimeException(String, Throwable) - Constructor for exception java.time.DateTimeException
Constructs a new date-time exception with the specified message and cause.
DateTimeFormatter - Class in java.time.format
Formatter for printing and parsing date-time objects.
DateTimeFormatterBuilder - Class in java.time.format
Builder to create date-time formatters.
DateTimeFormatterBuilder() - Constructor for class java.time.format.DateTimeFormatterBuilder
Constructs a new instance of the builder.
DateTimeParseException - Exception in java.time.format
An exception thrown when an error occurs during parsing.
DateTimeParseException(String, CharSequence, int) - Constructor for exception java.time.format.DateTimeParseException
Constructs a new exception with the specified message.
DateTimeParseException(String, CharSequence, int, Throwable) - Constructor for exception java.time.format.DateTimeParseException
Constructs a new exception with the specified message and cause.
DateTimeSyntax - Class in javax.print.attribute
Class DateTimeSyntax is an abstract base class providing the common implementation of all attributes whose value is a date and time.
DateTimeSyntax(Date) - Constructor for class javax.print.attribute.DateTimeSyntax
Construct a new date-time attribute with the given java.util.Date value.
dateYearDay(Era, int, int) - Method in interface java.time.chrono.Chronology
Obtains a local date in this chronology from the era, year-of-era and day-of-year fields.
dateYearDay(int, int) - Method in interface java.time.chrono.Chronology
Obtains a local date in this chronology from the proleptic-year and day-of-year fields.
dateYearDay(Era, int, int) - Method in class java.time.chrono.HijrahChronology
Obtains a local date in Hijrah calendar system from the era, year-of-era and day-of-year fields.
dateYearDay(int, int) - Method in class java.time.chrono.HijrahChronology
Obtains a local date in Hijrah calendar system from the proleptic-year and day-of-year fields.
dateYearDay(Era, int, int) - Method in class java.time.chrono.IsoChronology
Obtains an ISO local date from the era, year-of-era and day-of-year fields.
dateYearDay(int, int) - Method in class java.time.chrono.IsoChronology
Obtains an ISO local date from the proleptic-year and day-of-year fields.
dateYearDay(Era, int, int) - Method in class java.time.chrono.JapaneseChronology
Obtains a local date in Japanese calendar system from the era, year-of-era and day-of-year fields.
dateYearDay(int, int) - Method in class java.time.chrono.JapaneseChronology
Obtains a local date in Japanese calendar system from the proleptic-year and day-of-year fields.
dateYearDay(Era, int, int) - Method in class java.time.chrono.MinguoChronology
Obtains a local date in Minguo calendar system from the era, year-of-era and day-of-year fields.
dateYearDay(int, int) - Method in class java.time.chrono.MinguoChronology
Obtains a local date in Minguo calendar system from the proleptic-year and day-of-year fields.
dateYearDay(Era, int, int) - Method in class java.time.chrono.ThaiBuddhistChronology
Obtains a local date in Thai Buddhist calendar system from the era, year-of-era and day-of-year fields.
dateYearDay(int, int) - Method in class java.time.chrono.ThaiBuddhistChronology
Obtains a local date in Thai Buddhist calendar system from the proleptic-year and day-of-year fields.
DAY_OF_MONTH - Static variable in class java.text.DateFormat.Field
Constant identifying the day of month field.
DAY_OF_MONTH - Static variable in class java.util.Calendar
Field number for get and set indicating the day of the month.
DAY_OF_QUARTER - Static variable in class java.time.temporal.IsoFields
The field that represents the day-of-quarter.
DAY_OF_WEEK - Static variable in class java.text.DateFormat.Field
Constant identifying the day of week field.
DAY_OF_WEEK - Static variable in class java.util.Calendar
Field number for get and set indicating the day of the week.
DAY_OF_WEEK_FIELD - Static variable in class java.text.DateFormat
Useful constant for DAY_OF_WEEK field alignment.
DAY_OF_WEEK_IN_MONTH - Static variable in class java.text.DateFormat.Field
Constant identifying the day of week field.
DAY_OF_WEEK_IN_MONTH - Static variable in class java.util.Calendar
Field number for get and set indicating the ordinal number of the day of the week within the current month.
DAY_OF_WEEK_IN_MONTH_FIELD - Static variable in class java.text.DateFormat
Useful constant for DAY_OF_WEEK_IN_MONTH field alignment.
DAY_OF_YEAR - Static variable in class java.text.DateFormat.Field
Constant identifying the day of year field.
DAY_OF_YEAR - Static variable in class java.util.Calendar
Field number for get and set indicating the day number within the current year.
DAY_OF_YEAR_FIELD - Static variable in class java.text.DateFormat
Useful constant for DAY_OF_YEAR field alignment.
DayOfWeek - Enum in java.time
A day-of-week, such as 'Tuesday'.
dayOfWeek() - Method in class java.time.temporal.WeekFields
Returns a field to access the day of week based on this WeekFields.
dayOfWeekInMonth(int, DayOfWeek) - Static method in class java.time.temporal.TemporalAdjusters
Returns the day-of-week in month adjuster, which returns a new date in the same month with the ordinal day-of-week.
DAYS - Static variable in class javax.xml.datatype.DatatypeConstants
A constant that represents the days field.
dbgTag - Variable in class javax.management.monitor.Monitor
Deprecated.
No replacement.
DD - Static variable in class javax.swing.text.html.HTML.Tag
deactivate(boolean) - Method in interface java.awt.im.spi.InputMethod
Deactivates the input method.
deactivate() - Method in interface javax.rmi.CORBA.Tie
Deactivates the target object represented by this tie.
deactivate(boolean, boolean) - Method in interface org.omg.PortableServer.POAManagerOperations
This operation changes the state of the POA manager to inactive, causing associated POAs to reject the requests that have not begun executing as well as as any new requests.
deactivate_object(byte[]) - Method in interface org.omg.PortableServer.POAOperations
This operation causes the ObjectId specified in the oid parameter to be deactivated.
deactivateFrame(JInternalFrame) - Method in class javax.swing.DefaultDesktopManager
deactivateFrame(JInternalFrame) - Method in interface javax.swing.DesktopManager
Generally, indicate that this frame has lost focus.
deactivateFrame(JInternalFrame) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
This method is called when the frame is no longer selected.
DebugGraphics - Class in javax.swing
Graphics subclass supporting graphics debugging.
DebugGraphics() - Constructor for class javax.swing.DebugGraphics
Constructs a new debug graphics context that supports slowed down drawing.
DebugGraphics(Graphics, JComponent) - Constructor for class javax.swing.DebugGraphics
Constructs a debug graphics context from an existing graphics context that slows down drawing for the specified component.
DebugGraphics(Graphics) - Constructor for class javax.swing.DebugGraphics
Constructs a debug graphics context from an existing graphics context that supports slowed down drawing.
decapitalize(String) - Static method in class java.beans.Introspector
Utility method to take a string and convert it to normal Java variable name capitalization.
DECEMBER - Static variable in class java.util.Calendar
Value of the Calendar.MONTH field indicating the twelfth month of the year in the Gregorian and Julian calendars.
DECEMBER - Static variable in class javax.xml.datatype.DatatypeConstants
Value for twelve month of year.
DECIMAL - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type DECIMAL.
DECIMAL128 - Static variable in class java.math.MathContext
A MathContext object with a precision setting matching the IEEE 754R Decimal128 format, 34 digits, and a rounding mode of HALF_EVEN, the IEEE 754R default.
DECIMAL32 - Static variable in class java.math.MathContext
A MathContext object with a precision setting matching the IEEE 754R Decimal32 format, 7 digits, and a rounding mode of HALF_EVEN, the IEEE 754R default.
DECIMAL64 - Static variable in class java.math.MathContext
A MathContext object with a precision setting matching the IEEE 754R Decimal64 format, 16 digits, and a rounding mode of HALF_EVEN, the IEEE 754R default.
DECIMAL_DIGIT_NUMBER - Static variable in class java.lang.Character
General category "Nd" in the Unicode specification.
DECIMAL_SEPARATOR - Static variable in class java.text.NumberFormat.Field
Constant identifying the decimal separator field.
DecimalFormat - Class in java.text
DecimalFormat is a concrete subclass of NumberFormat that formats decimal numbers.
DecimalFormat() - Constructor for class java.text.DecimalFormat
Creates a DecimalFormat using the default pattern and symbols for the default FORMAT locale.
DecimalFormat(String) - Constructor for class java.text.DecimalFormat
Creates a DecimalFormat using the given pattern and the symbols for the default FORMAT locale.
DecimalFormat(String, DecimalFormatSymbols) - Constructor for class java.text.DecimalFormat
Creates a DecimalFormat using the given pattern and symbols.
DecimalFormatSymbols - Class in java.text
This class represents the set of symbols (such as the decimal separator, the grouping separator, and so on) needed by DecimalFormat to format numbers.
DecimalFormatSymbols() - Constructor for class java.text.DecimalFormatSymbols
Create a DecimalFormatSymbols object for the default FORMAT locale.
DecimalFormatSymbols(Locale) - Constructor for class java.text.DecimalFormatSymbols
Create a DecimalFormatSymbols object for the given locale.
DecimalFormatSymbolsProvider - Class in java.text.spi
An abstract class for service providers that provide instances of the DecimalFormatSymbols class.
DecimalFormatSymbolsProvider() - Constructor for class java.text.spi.DecimalFormatSymbolsProvider
Sole constructor.
DecimalStyle - Class in java.time.format
Localized decimal style used in date and time formatting.
DECLARE - Static variable in class javax.swing.text.html.HTML.Attribute
DECLARED - Static variable in interface java.lang.reflect.Member
Identifies the set of declared members of a class or interface.
DeclaredType - Interface in javax.lang.model.type
Represents a declared type, either a class type or an interface type.
declaredType - Variable in class javax.xml.bind.JAXBElement
Java datatype binding for xml element declaration's type.
declarePrefix(String, String) - Method in class org.xml.sax.helpers.NamespaceSupport
Declare a Namespace prefix.
DeclHandler - Interface in org.xml.sax.ext
SAX2 extension handler for DTD declaration events.
decode(String) - Static method in class java.awt.Color
Converts a String to an integer and returns the specified opaque Color.
decode(String) - Static method in class java.awt.Font
Returns the Font that the str argument describes.
decode(String) - Static method in class java.lang.Byte
Decodes a String into a Byte.
decode(String) - Static method in class java.lang.Integer
Decodes a String into an Integer.
decode(String) - Static method in class java.lang.Long
Decodes a String into a Long.
decode(String) - Static method in class java.lang.Short
Decodes a String into a Short.
decode(String) - Static method in class java.net.URLDecoder
Deprecated.
The resulting string may vary depending on the platform's default encoding. Instead, use the decode(String,String) method to specify the encoding.
decode(String, String) - Static method in class java.net.URLDecoder
Decodes a application/x-www-form-urlencoded string using a specific encoding scheme.
decode(ByteBuffer) - Method in class java.nio.charset.Charset
Convenience method that decodes bytes in this charset into Unicode characters.
decode(ByteBuffer, CharBuffer, boolean) - Method in class java.nio.charset.CharsetDecoder
Decodes as many bytes as possible from the given input buffer, writing the results to the given output buffer.
decode(ByteBuffer) - Method in class java.nio.charset.CharsetDecoder
Convenience method that decodes the remaining content of a single input byte buffer into a newly-allocated character buffer.
decode(InputStream) - Method in interface java.security.Certificate
Deprecated.
Decodes a certificate from an input stream.
decode(byte[]) - Method in class java.util.Base64.Decoder
Decodes all bytes from the input byte array using the Base64 encoding scheme, writing the results into a newly-allocated output byte array.
decode(String) - Method in class java.util.Base64.Decoder
Decodes a Base64 encoded String into a newly-allocated byte array using the Base64 encoding scheme.
decode(byte[], byte[]) - Method in class java.util.Base64.Decoder
Decodes all bytes from the input byte array using the Base64 encoding scheme, writing the results into the given output byte array, starting at offset 0.
decode(ByteBuffer) - Method in class java.util.Base64.Decoder
Decodes all bytes from the input byte buffer using the Base64 encoding scheme, writing the results into a newly-allocated ByteBuffer.
decode(byte[]) - Method in interface org.omg.IOP.CodecOperations
Decodes the given byte array into an Any based on the encoding format effective for this Codec.
decode_value(byte[], TypeCode) - Method in interface org.omg.IOP.CodecOperations
Decodes the given byte array into an Any based on the given TypeCode and the encoding format effective for this Codec.
decodeAnchorX(float, float) - Method in class javax.swing.plaf.nimbus.AbstractRegionPainter
Decodes and returns a float value representing the actual pixel location for the anchor point given the encoded X value of the control point, and the offset distance to the anchor from that control point.
decodeAnchorY(float, float) - Method in class javax.swing.plaf.nimbus.AbstractRegionPainter
Decodes and returns a float value representing the actual pixel location for the anchor point given the encoded Y value of the control point, and the offset distance to the anchor from that control point.
decodeColor(String, float, float, float, int) - Method in class javax.swing.plaf.nimbus.AbstractRegionPainter
Decodes and returns a color, which is derived from a base color in UI defaults.
decodeColor(Color, Color, float) - Method in class javax.swing.plaf.nimbus.AbstractRegionPainter
Decodes and returns a color, which is derived from a offset between two other colors.
decodeDataFlavor(String) - Static method in class java.awt.datatransfer.SystemFlavorMap
Decodes a String native for use as a DataFlavor.
decodeGradient(float, float, float, float, float[], Color[]) - Method in class javax.swing.plaf.nimbus.AbstractRegionPainter
Given parameters for creating a LinearGradientPaint, this method will create and return a linear gradient paint.
decodeJavaMIMEType(String) - Static method in class java.awt.datatransfer.SystemFlavorMap
Decodes a String native for use as a Java MIME type.
decodeLineStyle(Object) - Method in class javax.swing.plaf.metal.MetalTreeUI
this function converts between the string passed into the client property and the internal representation (currently and int)
decodeLoop(ByteBuffer, CharBuffer) - Method in class java.nio.charset.CharsetDecoder
Decodes one or more bytes into one or more characters.
decodeRadialGradient(float, float, float, float[], Color[]) - Method in class javax.swing.plaf.nimbus.AbstractRegionPainter
Given parameters for creating a RadialGradientPaint, this method will create and return a radial gradient paint.
decodeX(float) - Method in class javax.swing.plaf.nimbus.AbstractRegionPainter
Decodes and returns a float value representing the actual pixel location for the given encoded X value.
decodeY(float) - Method in class javax.swing.plaf.nimbus.AbstractRegionPainter
Decodes and returns a float value representing the actual pixel location for the given encoded y value.
decorateTask(Runnable, RunnableScheduledFuture<V>) - Method in class java.util.concurrent.ScheduledThreadPoolExecutor
Modifies or replaces the task used to execute a runnable.
decorateTask(Callable<V>, RunnableScheduledFuture<V>) - Method in class java.util.concurrent.ScheduledThreadPoolExecutor
Modifies or replaces the task used to execute a callable.
decrButton - Variable in class javax.swing.plaf.basic.BasicScrollBarUI
DECREASE_HIGHLIGHT - Static variable in class javax.swing.plaf.basic.BasicScrollBarUI
decreaseButton - Variable in class javax.swing.plaf.metal.MetalScrollBarUI
decrement() - Method in class java.util.concurrent.atomic.LongAdder
Equivalent to add(-1).
DECREMENT - Static variable in interface javax.accessibility.AccessibleAction
An action which decrements a value.
decrementAndGet() - Method in class java.util.concurrent.atomic.AtomicInteger
Atomically decrements by one the current value.
decrementAndGet(int) - Method in class java.util.concurrent.atomic.AtomicIntegerArray
Atomically decrements by one the element at index i.
decrementAndGet(T) - Method in class java.util.concurrent.atomic.AtomicIntegerFieldUpdater
Atomically decrements by one the current value of the field of the given object managed by this updater.
decrementAndGet() - Method in class java.util.concurrent.atomic.AtomicLong
Atomically decrements by one the current value.
decrementAndGet(int) - Method in class java.util.concurrent.atomic.AtomicLongArray
Atomically decrements by one the element at index i.
decrementAndGet(T) - Method in class java.util.concurrent.atomic.AtomicLongFieldUpdater
Atomically decrements by one the current value of the field of the given object managed by this updater.
decrementExact(int) - Static method in class java.lang.Math
Returns the argument decremented by one, throwing an exception if the result overflows an int.
decrementExact(long) - Static method in class java.lang.Math
Returns the argument decremented by one, throwing an exception if the result overflows a long.
decrementPendingCountUnlessZero() - Method in class java.util.concurrent.CountedCompleter
If the pending count is nonzero, (atomically) decrements it.
decrGap - Variable in class javax.swing.plaf.basic.BasicScrollBarUI
Distance between the decrement button and the track.
decrIndent() - Method in class javax.swing.text.AbstractWriter
Decrements the indent level.
DECRYPT - Static variable in class javax.xml.crypto.KeySelector.Purpose
A key for decrypting.
DECRYPT_MODE - Static variable in class javax.crypto.Cipher
Constant used to initialize cipher to decryption mode.
deepEquals(Object[], Object[]) - Static method in class java.util.Arrays
Returns true if the two specified arrays are deeply equal to one another.
deepEquals(Object, Object) - Static method in class java.util.Objects
Returns true if the arguments are deeply equal to each other and false otherwise.
deepHashCode(Object[]) - Static method in class java.util.Arrays
Returns a hash code based on the "deep contents" of the specified array.
deepToString(Object[]) - Static method in class java.util.Arrays
Returns a string representation of the "deep contents" of the specified array.
def - Variable in class java.util.zip.DeflaterInputStream
Compressor for this stream.
def - Variable in class java.util.zip.DeflaterOutputStream
Compressor for this stream.
def_kind() - Method in class org.omg.CORBA._IDLTypeStub
def_kind() - Method in interface org.omg.CORBA.IRObjectOperations
Returns the DefinitionKind corresponding to this Interface Repository object.
defAttributeList(String, int, int, String, String, AttributeList) - Method in class javax.swing.text.html.parser.DTD
Creates and returns an AttributeList.
DEFAULT - Static variable in class java.awt.dnd.DragSourceContext
An int used by updateCurrentCursor() indicating that the Cursor should change to the default (no drop) Cursor.
DEFAULT - Static variable in class java.security.spec.PSSParameterSpec
The PSS parameter set with all default values.
DEFAULT - Static variable in class java.text.DateFormat
Constant for default style pattern.
DEFAULT - Static variable in class javax.crypto.spec.OAEPParameterSpec
The OAEP parameter set with all default values.
DEFAULT - Static variable in class javax.crypto.spec.PSource.PSpecified
The encoding input P whose value equals byte[0].
DEFAULT - Static variable in interface javax.swing.Action
Not currently used.
DEFAULT - Static variable in interface javax.swing.plaf.synth.SynthConstants
Indicates the region is the default.
DEFAULT - Static variable in interface javax.swing.text.html.parser.DTDConstants
DEFAULT() - Constructor for class javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT
DEFAULT() - Constructor for class javax.xml.bind.annotation.XmlElement.DEFAULT
DEFAULT() - Constructor for class javax.xml.bind.annotation.XmlElementRef.DEFAULT
DEFAULT() - Constructor for class javax.xml.bind.annotation.XmlSchemaType.DEFAULT
DEFAULT() - Constructor for class javax.xml.bind.annotation.XmlType.DEFAULT
DEFAULT - Static variable in class javax.xml.crypto.dsig.spec.ExcC14NParameterSpec
Indicates the default namespace ("#default").
DEFAULT_CARET_POLICY - Static variable in class java.awt.font.TextLayout
This CaretPolicy is used when a policy is not specified by the client.
DEFAULT_CLASS_LOADER - Static variable in class javax.management.remote.JMXConnectorFactory
Name of the attribute that specifies the default class loader.
DEFAULT_CLASS_LOADER - Static variable in class javax.management.remote.JMXConnectorServerFactory
Name of the attribute that specifies the default class loader.
DEFAULT_CLASS_LOADER_NAME - Static variable in class javax.management.remote.JMXConnectorServerFactory
Name of the attribute that specifies the default class loader MBean name.
DEFAULT_COMPRESSION - Static variable in class java.util.zip.Deflater
Default compression level.
DEFAULT_CSS - Static variable in class javax.swing.text.html.HTMLEditorKit
Default Cascading Style Sheet file that sets up the tag views.
DEFAULT_CURSOR - Static variable in class java.awt.Cursor
The default cursor type (gets set if no cursor is defined).
DEFAULT_CURSOR - Static variable in class java.awt.Frame
Deprecated.
replaced by Cursor.DEFAULT_CURSOR.
default_index() - Method in class org.omg.CORBA.TypeCode
Returns the index of the default member, or -1 if there is no default member.
DEFAULT_JUSTIFICATION - Static variable in class javax.swing.border.TitledBorder
Use the default justification for the title text.
DEFAULT_KEYMAP - Static variable in class javax.swing.text.JTextComponent
The default keymap that will be shared by all JTextComponent instances unless they have had a different keymap set.
DEFAULT_LAYER - Static variable in class javax.swing.JLayeredPane
Convenience object defining the Default layer.
DEFAULT_LIFETIME - Static variable in interface org.ietf.jgss.GSSContext
A lifetime constant representing the default context lifetime.
DEFAULT_LIFETIME - Static variable in interface org.ietf.jgss.GSSCredential
A lifetime constant representing the default credential lifetime.
DEFAULT_MODALITY_TYPE - Static variable in class java.awt.Dialog
Default modality type for modal dialogs.
DEFAULT_NS_PREFIX - Static variable in class javax.xml.XMLConstants
Prefix to use to represent the default XML Namespace.
DEFAULT_OBJECT_MODEL_URI - Static variable in class javax.xml.xpath.XPathFactory
Default Object Model URI.
DEFAULT_OPTION - Static variable in class javax.swing.JOptionPane
Type meaning Look and Feel should not supply any options -- only use the options from the JOptionPane.
default_POA(Servant) - Method in interface org.omg.PortableServer.portable.Delegate
The default behavior of this function is to return the root POA from the ORB instance associated with the servant.
DEFAULT_POSITION - Static variable in class javax.swing.border.TitledBorder
Use the default vertical orientation for the title text.
DEFAULT_PROPERTY_NAME - Static variable in class javax.xml.xpath.XPathFactory
The default property name according to the JAXP spec.
DEFAULT_SIZE - Static variable in class javax.swing.GroupLayout
Indicates the size from the component or gap should be used for a particular range value.
DEFAULT_SOAP_PROTOCOL - Static variable in interface javax.xml.soap.SOAPConstants
The default protocol: SOAP 1.1 for backwards compatibility.
DEFAULT_STRATEGY - Static variable in class java.util.zip.Deflater
Default compression strategy.
DEFAULT_STYLE - Static variable in class javax.swing.text.StyleContext
The name given to the default logical style attached to paragraphs.
DEFAULT_VALUE - Variable in class javax.lang.model.util.ElementScanner6
The specified default value.
DEFAULT_VALUE - Variable in class javax.lang.model.util.SimpleAnnotationValueVisitor6
Default value to be returned; defaultAction returns this value unless the method is overridden.
DEFAULT_VALUE - Variable in class javax.lang.model.util.SimpleElementVisitor6
Default value to be returned; defaultAction returns this value unless the method is overridden.
DEFAULT_VALUE - Variable in class javax.lang.model.util.SimpleTypeVisitor6
Default value to be returned; defaultAction returns this value unless the method is overridden.
DEFAULT_VALUE_FIELD - Static variable in class javax.management.JMX
The name of the defaultValue field.
defaultAction(Object, P) - Method in class javax.lang.model.util.SimpleAnnotationValueVisitor6
The default action for visit methods.
defaultAction(Element, P) - Method in class javax.lang.model.util.SimpleElementVisitor6
The default action for visit methods.
defaultAction(TypeMirror, P) - Method in class javax.lang.model.util.SimpleTypeVisitor6
The default action for visit methods.
DefaultBoundedRangeModel - Class in javax.swing
A generic implementation of BoundedRangeModel.
DefaultBoundedRangeModel() - Constructor for class javax.swing.DefaultBoundedRangeModel
Initializes all of the properties with default values.
DefaultBoundedRangeModel(int, int, int, int) - Constructor for class javax.swing.DefaultBoundedRangeModel
Initializes value, extent, minimum and maximum.
defaultButton - Variable in class javax.swing.JRootPane
The button that gets activated when the pane has the focus and a UI-specific action like pressing the Enter key occurs.
DefaultButtonModel - Class in javax.swing
The default implementation of a Button component's data model.
DefaultButtonModel() - Constructor for class javax.swing.DefaultButtonModel
Constructs a DefaultButtonModel.
DefaultCaret - Class in javax.swing.text
A default implementation of Caret.
DefaultCaret() - Constructor for class javax.swing.text.DefaultCaret
Constructs a default caret.
DefaultCellEditor - Class in javax.swing
The default editor for table and tree cells.
DefaultCellEditor(JTextField) - Constructor for class javax.swing.DefaultCellEditor
Constructs a DefaultCellEditor that uses a text field.
DefaultCellEditor(JCheckBox) - Constructor for class javax.swing.DefaultCellEditor
Constructs a DefaultCellEditor object that uses a check box.
DefaultCellEditor(JComboBox) - Constructor for class javax.swing.DefaultCellEditor
Constructs a DefaultCellEditor object that uses a combo box.
DefaultCellEditor.EditorDelegate - Class in javax.swing
The protected EditorDelegate class.
defaultCharset() - Static method in class java.nio.charset.Charset
Returns the default charset of this Java virtual machine.
defaultChoosers - Variable in class javax.swing.plaf.basic.BasicColorChooserUI
DefaultColorSelectionModel - Class in javax.swing.colorchooser
A generic implementation of ColorSelectionModel.
DefaultColorSelectionModel() - Constructor for class javax.swing.colorchooser.DefaultColorSelectionModel
Creates a DefaultColorSelectionModel with the current color set to Color.white.
DefaultColorSelectionModel(Color) - Constructor for class javax.swing.colorchooser.DefaultColorSelectionModel
Creates a DefaultColorSelectionModel with the current color set to color, which should be non-null.
DefaultComboBoxModel<E> - Class in javax.swing
The default model for combo boxes.
DefaultComboBoxModel() - Constructor for class javax.swing.DefaultComboBoxModel
Constructs an empty DefaultComboBoxModel object.
DefaultComboBoxModel(E[]) - Constructor for class javax.swing.DefaultComboBoxModel
Constructs a DefaultComboBoxModel object initialized with an array of objects.
DefaultComboBoxModel(Vector<E>) - Constructor for class javax.swing.DefaultComboBoxModel
Constructs a DefaultComboBoxModel object initialized with a vector.
defaultConstraints - Variable in class java.awt.GridBagLayout
This field holds a gridbag constraints instance containing the default values, so if a component does not have gridbag constraints associated with it, then the component will be assigned a copy of the defaultConstraints.
defaultController - Variable in class javax.imageio.IIOParam
The default IIOParamController that will be used to provide settings for this IIOParam object when the activateController method is called.
defaultController - Variable in class javax.imageio.metadata.IIOMetadata
An IIOMetadataController that is suggested for use as the controller for this IIOMetadata object.
DefaultCopyDrop - Static variable in class java.awt.dnd.DragSource
The default Cursor to use with a copy operation indicating that a drop is currently allowed.
DefaultCopyNoDrop - Static variable in class java.awt.dnd.DragSource
The default Cursor to use with a copy operation indicating that a drop is currently not allowed.
DefaultDesktopManager - Class in javax.swing
This is an implementation of the DesktopManager.
DefaultDesktopManager() - Constructor for class javax.swing.DefaultDesktopManager
DefaultDocumentEvent(int, int, DocumentEvent.EventType) - Constructor for class javax.swing.text.AbstractDocument.DefaultDocumentEvent
Constructs a change record.
defaulted(String) - Method in class java.io.ObjectInputStream.GetField
Return true if the named field is defaulted and has no value in this stream.
DefaultEditor(JSpinner) - Constructor for class javax.swing.JSpinner.DefaultEditor
Constructs an editor component for the specified JSpinner.
DefaultEditorKit - Class in javax.swing.text
This is the set of things needed by a text component to be a reasonably functioning editor for some type of text document.
DefaultEditorKit() - Constructor for class javax.swing.text.DefaultEditorKit
default constructor for DefaultEditorKit
DefaultEditorKit.BeepAction - Class in javax.swing.text
Creates a beep.
DefaultEditorKit.CopyAction - Class in javax.swing.text
Copies the selected region and place its contents into the system clipboard.
DefaultEditorKit.CutAction - Class in javax.swing.text
Cuts the selected region and place its contents into the system clipboard.
DefaultEditorKit.DefaultKeyTypedAction - Class in javax.swing.text
The action that is executed by default if a key typed event is received and there is no keymap entry.
DefaultEditorKit.InsertBreakAction - Class in javax.swing.text
Places a line/paragraph break into the document.
DefaultEditorKit.InsertContentAction - Class in javax.swing.text
Places content into the associated document.
DefaultEditorKit.InsertTabAction - Class in javax.swing.text
Places a tab character into the document.
DefaultEditorKit.PasteAction - Class in javax.swing.text
Pastes the contents of the system clipboard into the selected region, or before the caret if nothing is selected.
defaultEditorsByColumnClass - Variable in class javax.swing.JTable
A table of objects that display and edit the contents of a cell, indexed by class as declared in getColumnClass in the TableModel interface.
DefaultFocusManager - Class in javax.swing
This class has been obsoleted by the 1.4 focus APIs.
DefaultFocusManager() - Constructor for class javax.swing.DefaultFocusManager
DefaultFocusTraversalPolicy - Class in java.awt
A FocusTraversalPolicy that determines traversal order based on the order of child Components in a Container.
DefaultFocusTraversalPolicy() - Constructor for class java.awt.DefaultFocusTraversalPolicy
defaultForkJoinWorkerThreadFactory - Static variable in class java.util.concurrent.ForkJoinPool
Creates a new ForkJoinWorkerThread.
DefaultFormatter - Class in javax.swing.text
DefaultFormatter formats arbitrary objects.
DefaultFormatter() - Constructor for class javax.swing.text.DefaultFormatter
Creates a DefaultFormatter.
DefaultFormatterFactory - Class in javax.swing.text
An implementation of JFormattedTextField.AbstractFormatterFactory.
DefaultFormatterFactory() - Constructor for class javax.swing.text.DefaultFormatterFactory
DefaultFormatterFactory(JFormattedTextField.AbstractFormatter) - Constructor for class javax.swing.text.DefaultFormatterFactory
Creates a DefaultFormatterFactory with the specified JFormattedTextField.AbstractFormatter.
DefaultFormatterFactory(JFormattedTextField.AbstractFormatter, JFormattedTextField.AbstractFormatter) - Constructor for class javax.swing.text.DefaultFormatterFactory
Creates a DefaultFormatterFactory with the specified JFormattedTextField.AbstractFormatters.
DefaultFormatterFactory(JFormattedTextField.AbstractFormatter, JFormattedTextField.AbstractFormatter, JFormattedTextField.AbstractFormatter) - Constructor for class javax.swing.text.DefaultFormatterFactory
Creates a DefaultFormatterFactory with the specified JFormattedTextField.AbstractFormatters.
DefaultFormatterFactory(JFormattedTextField.AbstractFormatter, JFormattedTextField.AbstractFormatter, JFormattedTextField.AbstractFormatter, JFormattedTextField.AbstractFormatter) - Constructor for class javax.swing.text.DefaultFormatterFactory
Creates a DefaultFormatterFactory with the specified JFormattedTextField.AbstractFormatters.
DefaultHandler - Class in org.xml.sax.helpers
Default base class for SAX2 event handlers.
DefaultHandler() - Constructor for class org.xml.sax.helpers.DefaultHandler
DefaultHandler2 - Class in org.xml.sax.ext
This class extends the SAX2 base handler class to support the SAX2 LexicalHandler, DeclHandler, and EntityResolver2 extensions.
DefaultHandler2() - Constructor for class org.xml.sax.ext.DefaultHandler2
Constructs a handler which ignores all parsing events.
DefaultHighlighter - Class in javax.swing.text
Implements the Highlighter interfaces.
DefaultHighlighter() - Constructor for class javax.swing.text.DefaultHighlighter
Creates a new DefaultHighlighther object.
DefaultHighlighter.DefaultHighlightPainter - Class in javax.swing.text
Simple highlight painter that fills a highlighted area with a solid color.
DefaultHighlightPainter(Color) - Constructor for class javax.swing.text.DefaultHighlighter.DefaultHighlightPainter
Constructs a new highlight painter.
defaultInitCtx - Variable in class javax.naming.InitialContext
Field holding the result of calling NamingManager.getInitialContext().
DefaultKeyboardFocusManager - Class in java.awt
The default KeyboardFocusManager for AWT applications.
DefaultKeyboardFocusManager() - Constructor for class java.awt.DefaultKeyboardFocusManager
defaultKeyTypedAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the action that is executed by default if a key typed event is received and there is no keymap entry.
DefaultKeyTypedAction() - Constructor for class javax.swing.text.DefaultEditorKit.DefaultKeyTypedAction
Creates this object with the appropriate identifier.
DefaultLinkDrop - Static variable in class java.awt.dnd.DragSource
The default Cursor to use with a link operation indicating that a drop is currently allowed.
DefaultLinkNoDrop - Static variable in class java.awt.dnd.DragSource
The default Cursor to use with a link operation indicating that a drop is currently not allowed.
DefaultListCellRenderer - Class in javax.swing
Renders an item in a list.
DefaultListCellRenderer() - Constructor for class javax.swing.DefaultListCellRenderer
Constructs a default renderer object for an item in a list.
DefaultListCellRenderer.UIResource - Class in javax.swing
A subclass of DefaultListCellRenderer that implements UIResource.
DefaultListModel<E> - Class in javax.swing
This class loosely implements the java.util.Vector API, in that it implements the 1.1.x version of java.util.Vector, has no collection class support, and notifies the ListDataListeners when changes occur.
DefaultListModel() - Constructor for class javax.swing.DefaultListModel
DefaultListSelectionModel - Class in javax.swing
Default data model for list selections.
DefaultListSelectionModel() - Constructor for class javax.swing.DefaultListSelectionModel
DefaultLoaderRepository - Class in javax.management
Deprecated.
Use MBeanServer.getClassLoaderRepository() instead.
DefaultLoaderRepository() - Constructor for class javax.management.DefaultLoaderRepository
Deprecated.
DefaultLoaderRepository - Class in javax.management.loading
Deprecated.
Use MBeanServer.getClassLoaderRepository()} instead.
DefaultLoaderRepository() - Constructor for class javax.management.loading.DefaultLoaderRepository
Deprecated.
defaultManager() - Static method in class javax.swing.MenuSelectionManager
Returns the default menu selection manager.
DefaultMenuLayout - Class in javax.swing.plaf.basic
The default layout manager for Popup menus and menubars.
DefaultMenuLayout(Container, int) - Constructor for class javax.swing.plaf.basic.DefaultMenuLayout
DefaultMetalTheme - Class in javax.swing.plaf.metal
A concrete implementation of MetalTheme providing the original look of the Java Look and Feel, code-named "Steel".
DefaultMetalTheme() - Constructor for class javax.swing.plaf.metal.DefaultMetalTheme
Creates and returns an instance of DefaultMetalTheme.
DefaultMoveDrop - Static variable in class java.awt.dnd.DragSource
The default Cursor to use with a move operation indicating that a drop is currently allowed.
DefaultMoveNoDrop - Static variable in class java.awt.dnd.DragSource
The default Cursor to use with a move operation indicating that a drop is currently not allowed.
DefaultMutableTreeNode - Class in javax.swing.tree
A DefaultMutableTreeNode is a general-purpose node in a tree data structure.
DefaultMutableTreeNode() - Constructor for class javax.swing.tree.DefaultMutableTreeNode
Creates a tree node that has no parent and no children, but which allows children.
DefaultMutableTreeNode(Object) - Constructor for class javax.swing.tree.DefaultMutableTreeNode
Creates a tree node with no parent, no children, but which allows children, and initializes it with the specified user object.
DefaultMutableTreeNode(Object, boolean) - Constructor for class javax.swing.tree.DefaultMutableTreeNode
Creates a tree node with no parent, no children, initialized with the specified user object, and that allows children only if specified.
defaultPage(PageFormat) - Method in class java.awt.print.PrinterJob
Clones the PageFormat argument and alters the clone to describe a default page size and orientation.
defaultPage() - Method in class java.awt.print.PrinterJob
Creates a new PageFormat instance and sets it to a default size and orientation.
DefaultPainter - Static variable in class javax.swing.text.DefaultHighlighter
Default implementation of LayeredHighlighter.LayerPainter that can be used for painting highlights.
DefaultPersistenceDelegate - Class in java.beans
The DefaultPersistenceDelegate is a concrete implementation of the abstract PersistenceDelegate class and is the delegate used by default for classes about which no information is available.
DefaultPersistenceDelegate() - Constructor for class java.beans.DefaultPersistenceDelegate
Creates a persistence delegate for a class with a nullary constructor.
DefaultPersistenceDelegate(String[]) - Constructor for class java.beans.DefaultPersistenceDelegate
Creates a default persistence delegate for a class with a constructor whose arguments are the values of the property names as specified by constructorPropertyNames.
defaultPressAction - Variable in class javax.swing.JRootPane
Deprecated.
As of Java 2 platform v1.3.
defaultReadObject() - Method in class java.io.ObjectInputStream
Read the non-static and non-transient fields of the current class from this stream.
defaultReleaseAction - Variable in class javax.swing.JRootPane
Deprecated.
As of Java 2 platform v1.3.
defaultRenderersByColumnClass - Variable in class javax.swing.JTable
A table of objects that display the contents of a cell, indexed by class as declared in getColumnClass in the TableModel interface.
DefaultRowSorter<M,I> - Class in javax.swing
An implementation of RowSorter that provides sorting and filtering around a grid-based data model.
DefaultRowSorter() - Constructor for class javax.swing.DefaultRowSorter
Creates an empty DefaultRowSorter.
DefaultRowSorter.ModelWrapper<M,I> - Class in javax.swing
DefaultRowSorter.ModelWrapper is responsible for providing the data that gets sorted by DefaultRowSorter.
defaults - Variable in class java.util.Properties
A property list that contains default values for any keys not found in this property list.
DefaultSingleSelectionModel - Class in javax.swing
A generic implementation of SingleSelectionModel.
DefaultSingleSelectionModel() - Constructor for class javax.swing.DefaultSingleSelectionModel
DefaultStyledDocument - Class in javax.swing.text
A document that can be marked up with character and paragraph styles in a manner similar to the Rich Text Format.
DefaultStyledDocument(AbstractDocument.Content, StyleContext) - Constructor for class javax.swing.text.DefaultStyledDocument
Constructs a styled document.
DefaultStyledDocument(StyleContext) - Constructor for class javax.swing.text.DefaultStyledDocument
Constructs a styled document with the default content storage implementation and a shared set of styles.
DefaultStyledDocument() - Constructor for class javax.swing.text.DefaultStyledDocument
Constructs a default styled document.
DefaultStyledDocument.AttributeUndoableEdit - Class in javax.swing.text
An UndoableEdit used to remember AttributeSet changes to an Element.
DefaultStyledDocument.ElementBuffer - Class in javax.swing.text
Class to manage changes to the element hierarchy.
DefaultStyledDocument.ElementSpec - Class in javax.swing.text
Specification for building elements.
DefaultStyledDocument.SectionElement - Class in javax.swing.text
Default root element for a document...
DefaultTableCellRenderer - Class in javax.swing.table
The standard class for rendering (displaying) individual cells in a JTable.
DefaultTableCellRenderer() - Constructor for class javax.swing.table.DefaultTableCellRenderer
Creates a default table cell renderer.
DefaultTableCellRenderer.UIResource - Class in javax.swing.table
A subclass of DefaultTableCellRenderer that implements UIResource.
DefaultTableColumnModel - Class in javax.swing.table
The standard column-handler for a JTable.
DefaultTableColumnModel() - Constructor for class javax.swing.table.DefaultTableColumnModel
Creates a default table column model.
DefaultTableModel - Class in javax.swing.table
This is an implementation of TableModel that uses a Vector of Vectors to store the cell value objects.
DefaultTableModel() - Constructor for class javax.swing.table.DefaultTableModel
Constructs a default DefaultTableModel which is a table of zero columns and zero rows.
DefaultTableModel(int, int) - Constructor for class javax.swing.table.DefaultTableModel
Constructs a DefaultTableModel with rowCount and columnCount of null object values.
DefaultTableModel(Vector, int) - Constructor for class javax.swing.table.DefaultTableModel
Constructs a DefaultTableModel with as many columns as there are elements in columnNames and rowCount of null object values.
DefaultTableModel(Object[], int) - Constructor for class javax.swing.table.DefaultTableModel
Constructs a DefaultTableModel with as many columns as there are elements in columnNames and rowCount of null object values.
DefaultTableModel(Vector, Vector) - Constructor for class javax.swing.table.DefaultTableModel
Constructs a DefaultTableModel and initializes the table by passing data and columnNames to the setDataVector method.
DefaultTableModel(Object[][], Object[]) - Constructor for class javax.swing.table.DefaultTableModel
Constructs a DefaultTableModel and initializes the table by passing data and columnNames to the setDataVector method.
DefaultTextField(Border) - Constructor for class javax.swing.tree.DefaultTreeCellEditor.DefaultTextField
Constructs a DefaultTreeCellEditor.DefaultTextField object.
defaultTextIconGap - Variable in class javax.swing.plaf.basic.BasicButtonUI
defaultTextIconGap - Variable in class javax.swing.plaf.basic.BasicMenuItemUI
defaultTextShiftOffset - Variable in class javax.swing.plaf.basic.BasicButtonUI
DefaultTextUI - Class in javax.swing.text
Deprecated.
DefaultTextUI() - Constructor for class javax.swing.text.DefaultTextUI
Deprecated.
defaultThreadFactory() - Static method in class java.util.concurrent.Executors
Returns a default thread factory used to create new threads.
DefaultTreeCellEditor - Class in javax.swing.tree
A TreeCellEditor.
DefaultTreeCellEditor(JTree, DefaultTreeCellRenderer) - Constructor for class javax.swing.tree.DefaultTreeCellEditor
Constructs a DefaultTreeCellEditor object for a JTree using the specified renderer and a default editor.
DefaultTreeCellEditor(JTree, DefaultTreeCellRenderer, TreeCellEditor) - Constructor for class javax.swing.tree.DefaultTreeCellEditor
Constructs a DefaultTreeCellEditor object for a JTree using the specified renderer and the specified editor.
DefaultTreeCellEditor.DefaultTextField - Class in javax.swing.tree
TextField used when no editor is supplied.
DefaultTreeCellEditor.EditorContainer - Class in javax.swing.tree
Container responsible for placing the editingComponent.
DefaultTreeCellRenderer - Class in javax.swing.tree
Displays an entry in a tree.
DefaultTreeCellRenderer() - Constructor for class javax.swing.tree.DefaultTreeCellRenderer
Creates a DefaultTreeCellRenderer.
DefaultTreeModel - Class in javax.swing.tree
A simple tree data model that uses TreeNodes.
DefaultTreeModel(TreeNode) - Constructor for class javax.swing.tree.DefaultTreeModel
Creates a tree in which any node can have children.
DefaultTreeModel(TreeNode, boolean) - Constructor for class javax.swing.tree.DefaultTreeModel
Creates a tree specifying whether any node can have children, or whether only certain nodes can have children.
DefaultTreeSelectionModel - Class in javax.swing.tree
Default implementation of TreeSelectionModel.
DefaultTreeSelectionModel() - Constructor for class javax.swing.tree.DefaultTreeSelectionModel
Creates a new instance of DefaultTreeSelectionModel that is empty, with a selection mode of DISCONTIGUOUS_TREE_SELECTION.
DefaultValidationEventHandler - Class in javax.xml.bind.helpers
JAXB 1.0 only default validation event handler.
DefaultValidationEventHandler() - Constructor for class javax.xml.bind.helpers.DefaultValidationEventHandler
defaultWriteObject() - Method in class java.io.ObjectOutputStream
Write the non-static and non-transient fields of the current class to this stream.
defContentModel(int, Object, ContentModel) - Method in class javax.swing.text.html.parser.DTD
Creates and returns a new content model.
DEFECTIVE_CREDENTIAL - Static variable in exception org.ietf.jgss.GSSException
Defective credentials.
DEFECTIVE_TOKEN - Static variable in exception org.ietf.jgss.GSSException
Defective token.
defElement(String, int, boolean, boolean, ContentModel, String[], String[], AttributeList) - Method in class javax.swing.text.html.parser.DTD
Creates and returns an Element.
defEntity(String, int, int) - Method in class javax.swing.text.html.parser.DTD
Creates and returns a character Entity.
defEntity(String, int, String) - Method in class javax.swing.text.html.parser.DTD
Creates and returns an Entity.
defineAttributes(String, AttributeList) - Method in class javax.swing.text.html.parser.DTD
Defines attributes for an Element.
defineClass(byte[], int, int) - Method in class java.lang.ClassLoader
Deprecated.
Replaced by defineClass(String, byte[], int, int)
defineClass(String, byte[], int, int) - Method in class java.lang.ClassLoader
Converts an array of bytes into an instance of class Class.
defineClass(String, byte[], int, int, ProtectionDomain) - Method in class java.lang.ClassLoader
Converts an array of bytes into an instance of class Class, with an optional ProtectionDomain.
defineClass(String, ByteBuffer, ProtectionDomain) - Method in class java.lang.ClassLoader
Converts a ByteBuffer into an instance of class Class, with an optional ProtectionDomain.
defineClass(String, byte[], int, int, CodeSource) - Method in class java.security.SecureClassLoader
Converts an array of bytes into an instance of class Class, with an optional CodeSource.
defineClass(String, ByteBuffer, CodeSource) - Method in class java.security.SecureClassLoader
Converts a ByteBuffer into an instance of class Class, with an optional CodeSource.
defined_in - Variable in class org.omg.CORBA.ValueMember
The repository ID of the value in which this member is defined.
defineElement(String, int, boolean, boolean, ContentModel, BitSet, BitSet, AttributeList) - Method in class javax.swing.text.html.parser.DTD
Returns the Element which matches the specified parameters.
defineEntity(String, int, char[]) - Method in class javax.swing.text.html.parser.DTD
Defines an entity.
definePackage(String, String, String, String, String, String, String, URL) - Method in class java.lang.ClassLoader
Defines a package by name in this ClassLoader.
definePackage(String, Manifest, URL) - Method in class java.net.URLClassLoader
Defines a new package by name in this ClassLoader.
DefinitionKind - Class in org.omg.CORBA
The class that provides the constants used to identify the type of an Interface Repository object.
DefinitionKind(int) - Constructor for class org.omg.CORBA.DefinitionKind
Constructs a DefinitionKind object with its _value field initialized with the given value.
DefinitionKindHelper - Class in org.omg.CORBA
The Helper for DefinitionKind.
DefinitionKindHelper() - Constructor for class org.omg.CORBA.DefinitionKindHelper
deflate(byte[], int, int) - Method in class java.util.zip.Deflater
Compresses the input data and fills specified buffer with compressed data.
deflate(byte[]) - Method in class java.util.zip.Deflater
Compresses the input data and fills specified buffer with compressed data.
deflate(byte[], int, int, int) - Method in class java.util.zip.Deflater
Compresses the input data and fills the specified buffer with compressed data.
deflate() - Method in class java.util.zip.DeflaterOutputStream
Writes next block of compressed data to the output stream.
DEFLATE - Static variable in class javax.print.attribute.standard.Compression
ZIP public domain inflate/deflate compression technology.
DEFLATE_HINT - Static variable in interface java.util.jar.Pack200.Packer
If this property is set to Pack200.Packer.TRUE or Pack200.Packer.FALSE, the packer will set the deflation hint accordingly in the output archive, and will not transmit the individual deflation hints of archive elements.
DEFLATE_HINT - Static variable in interface java.util.jar.Pack200.Unpacker
Property indicating that the unpacker should ignore all transmitted values for DEFLATE_HINT, replacing them by the given value, Pack200.Unpacker.TRUE or Pack200.Unpacker.FALSE.
DEFLATED - Static variable in class java.util.zip.Deflater
Compression method for the deflate algorithm (the only one currently supported).
DEFLATED - Static variable in class java.util.zip.ZipEntry
Compression method for compressed (deflated) entries.
DEFLATED - Static variable in class java.util.zip.ZipOutputStream
Compression method for compressed (DEFLATED) entries.
Deflater - Class in java.util.zip
This class provides support for general purpose compression using the popular ZLIB compression library.
Deflater(int, boolean) - Constructor for class java.util.zip.Deflater
Creates a new compressor using the specified compression level.
Deflater(int) - Constructor for class java.util.zip.Deflater
Creates a new compressor using the specified compression level.
Deflater() - Constructor for class java.util.zip.Deflater
Creates a new compressor with the default compression level.
DeflaterInputStream - Class in java.util.zip
Implements an input stream filter for compressing data in the "deflate" compression format.
DeflaterInputStream(InputStream) - Constructor for class java.util.zip.DeflaterInputStream
Creates a new input stream with a default compressor and buffer size.
DeflaterInputStream(InputStream, Deflater) - Constructor for class java.util.zip.DeflaterInputStream
Creates a new input stream with the specified compressor and a default buffer size.
DeflaterInputStream(InputStream, Deflater, int) - Constructor for class java.util.zip.DeflaterInputStream
Creates a new input stream with the specified compressor and buffer size.
DeflaterOutputStream - Class in java.util.zip
This class implements an output stream filter for compressing data in the "deflate" compression format.
DeflaterOutputStream(OutputStream, Deflater, int, boolean) - Constructor for class java.util.zip.DeflaterOutputStream
Creates a new output stream with the specified compressor, buffer size and flush mode.
DeflaterOutputStream(OutputStream, Deflater, int) - Constructor for class java.util.zip.DeflaterOutputStream
Creates a new output stream with the specified compressor and buffer size.
DeflaterOutputStream(OutputStream, Deflater, boolean) - Constructor for class java.util.zip.DeflaterOutputStream
Creates a new output stream with the specified compressor, flush mode and a default buffer size.
DeflaterOutputStream(OutputStream, Deflater) - Constructor for class java.util.zip.DeflaterOutputStream
Creates a new output stream with the specified compressor and a default buffer size.
DeflaterOutputStream(OutputStream, boolean) - Constructor for class java.util.zip.DeflaterOutputStream
Creates a new output stream with a default compressor, a default buffer size and the specified flush mode.
DeflaterOutputStream(OutputStream) - Constructor for class java.util.zip.DeflaterOutputStream
Creates a new output stream with a default compressor and buffer size.
deiconifyFrame(JInternalFrame) - Method in class javax.swing.DefaultDesktopManager
Removes the desktopIcon from its parent and adds its frame to the parent.
deiconifyFrame(JInternalFrame) - Method in interface javax.swing.DesktopManager
Generally, remove any iconic representation that is present and restore the frame to it's original size and location.
deiconifyFrame(JInternalFrame) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
This method is called when the user wants to deiconify the frame.
deiconize() - Method in class javax.swing.plaf.basic.BasicDesktopIconUI
deinstall(JTextComponent) - Method in interface javax.swing.text.Caret
Called when the UI is being removed from the interface of a JTextComponent.
deinstall(JTextComponent) - Method in class javax.swing.text.DefaultCaret
Called when the UI is being removed from the interface of a JTextComponent.
deinstall(JTextComponent) - Method in class javax.swing.text.DefaultHighlighter
Called when the UI is being removed from the interface of a JTextComponent.
deinstall(JEditorPane) - Method in class javax.swing.text.EditorKit
Called when the kit is being removed from the JEditorPane.
deinstall(JTextComponent) - Method in interface javax.swing.text.Highlighter
Called when the UI is being removed from the interface of a JTextComponent.
deinstall(JEditorPane) - Method in class javax.swing.text.html.HTMLEditorKit
Called when the kit is being removed from the JEditorPane.
deinstall(JEditorPane) - Method in class javax.swing.text.StyledEditorKit
Called when the kit is being removed from the JEditorPane.
deinstallMouseHandlers(JComponent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
delay(int) - Method in class java.awt.Robot
Sleeps for the specified time.
Delayed - Interface in java.util.concurrent
A mix-in style interface for marking objects that should be acted upon after a given delay.
DelayQueue<E extends Delayed> - Class in java.util.concurrent
An unbounded blocking queue of Delayed elements, in which an element can only be taken when its delay has expired.
DelayQueue() - Constructor for class java.util.concurrent.DelayQueue
Creates a new DelayQueue that is initially empty.
DelayQueue(Collection<? extends E>) - Constructor for class java.util.concurrent.DelayQueue
Creates a DelayQueue initially containing the elements of the given collection of Delayed instances.
delegate - Variable in class javax.swing.DefaultCellEditor
The delegate class which handles all methods sent from the CellEditor.
Delegate - Class in org.omg.CORBA.portable
Specifies a portable API for ORB-vendor-specific implementation of the org.omg.CORBA.Object methods.
Delegate() - Constructor for class org.omg.CORBA.portable.Delegate
Delegate - Class in org.omg.CORBA_2_3.portable
Delegate class provides the ORB vendor specific implementation of CORBA object.
Delegate() - Constructor for class org.omg.CORBA_2_3.portable.Delegate
Delegate - Interface in org.omg.PortableServer.portable
The portability package contains interfaces and classes that are designed for and intended to be used by ORB implementor.
DELEGATE_NAME - Static variable in class javax.management.MBeanServerDelegate
Defines the default ObjectName of the MBeanServerDelegate.
delegateFocus(MouseEvent) - Method in class javax.swing.plaf.basic.BasicComboPopup
This is is a utility method that helps event handlers figure out where to send the focus when the popup is brought up.
delegateFocus(MouseEvent) - Method in class javax.swing.plaf.metal.MetalComboBoxUI.MetalComboPopup
Deprecated.
DelegationPermission - Class in javax.security.auth.kerberos
This class is used to restrict the usage of the Kerberos delegation model, ie: forwardable and proxiable tickets.
DelegationPermission(String) - Constructor for class javax.security.auth.kerberos.DelegationPermission
Create a new DelegationPermission with the specified subordinate and target principals.
DelegationPermission(String, String) - Constructor for class javax.security.auth.kerberos.DelegationPermission
Create a new DelegationPermission with the specified subordinate and target principals.
DELETE - Static variable in class java.awt.Event
The Delete key.
delete() - Method in class java.io.File
Deletes the file or directory denoted by this abstract pathname.
delete(int, int) - Method in class java.lang.StringBuffer
delete(int, int) - Method in class java.lang.StringBuilder
delete(String) - Method in interface java.nio.file.attribute.UserDefinedFileAttributeView
Deletes a user-defined attribute.
delete(Path) - Static method in class java.nio.file.Files
Deletes a file.
delete(Path) - Method in class java.nio.file.spi.FileSystemProvider
Deletes a file.
delete(int, int) - Method in interface javax.accessibility.AccessibleEditableText
Deletes the text between two indices
DELETE - Static variable in interface javax.accessibility.AccessibleTableModelChange
Identifies the deletion of rows and/or columns.
DELETE - Static variable in class javax.swing.event.TableModelEvent
Identifies the removal of rows or columns.
delete(int, int) - Method in class javax.swing.JSpinner.AccessibleJSpinner
Deletes the text between two indices
delete(int, int) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent
Deletes the text between two indices
delete() - Method in interface javax.tools.FileObject
Deletes this file object.
delete() - Method in class javax.tools.ForwardingFileObject
delete() - Method in class javax.tools.SimpleJavaFileObject
This implementation does nothing.
DELETE_ROW_CONFLICT - Static variable in interface javax.sql.rowset.spi.SyncResolver
Indicates that a conflict occurred while the RowSet object was attempting to delete a row in the data source.
delete_values(String) - Method in class org.omg.CORBA.Context
Deletes from this Context object the NamedValue object(s) whose name field matches the given property name.
deleteChar(AttributedCharacterIterator, int) - Method in class java.awt.font.LineBreakMeasurer
Updates this LineBreakMeasurer after a single character is deleted from the text, and sets the current position to the beginning of the paragraph.
deleteChar(AttributedCharacterIterator, int) - Method in class java.awt.font.TextMeasurer
Updates the TextMeasurer after a single character has been deleted from the paragraph currently represented by this TextMeasurer.
deleteCharAt(int) - Method in class java.lang.StringBuffer
deleteCharAt(int) - Method in class java.lang.StringBuilder
deleteData(int, int) - Method in interface org.w3c.dom.CharacterData
Remove a range of 16-bit units from the node.
deleteDirectory(T) - Method in interface java.nio.file.SecureDirectoryStream
Deletes a directory.
deleteEntry(String) - Method in class java.security.KeyStore
Deletes the entry identified by the given alias from this keystore.
deleteFile(T) - Method in interface java.nio.file.SecureDirectoryStream
Deletes a file.
deleteIfExists(Path) - Static method in class java.nio.file.Files
Deletes a file if it exists.
deleteIfExists(Path) - Method in class java.nio.file.spi.FileSystemProvider
Deletes a file if it exists.
deleteNextCharAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the action to delete the character of content that follows the current caret position.
deleteNextWordAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the action to delete the word that follows the beginning of the selection.
deleteObserver(Observer) - Method in class java.util.Observable
Deletes an observer from the set of observers of this object.
deleteObservers() - Method in class java.util.Observable
Clears the observer list so that this object no longer has any observers.
deleteOnExit() - Method in class java.io.File
Requests that the file or directory denoted by this abstract pathname be deleted when the virtual machine terminates.
deleteOwner(Principal, Principal) - Method in interface java.security.acl.Owner
Deletes an owner.
deletePrevCharAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the action to delete the character of content that precedes the current caret position.
deletePrevWordAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the action to delete the word that precedes the beginning of the selection.
deleteRow() - Method in interface java.sql.ResultSet
Deletes the current row from this ResultSet object and from the underlying database.
deletesAreDetected(int) - Method in interface java.sql.DatabaseMetaData
Retrieves whether or not a visible row delete can be detected by calling the method ResultSet.rowDeleted.
deleteShortcut(MenuShortcut) - Method in class java.awt.MenuBar
Deletes the specified menu shortcut.
deleteShortcut() - Method in class java.awt.MenuItem
Delete any MenuShortcut object associated with this menu item.
deleteTrack(Track) - Method in class javax.sound.midi.Sequence
Removes the specified track from the sequence.
delimiter() - Method in class java.util.Scanner
Returns the Pattern this Scanner is currently using to match delimiters.
delItem(int) - Method in class java.awt.List
Deprecated.
replaced by remove(String) and remove(int).
delItems(int, int) - Method in class java.awt.List
Deprecated.
As of JDK version 1.1, Not for public use in the future. This method is expected to be retained only as a package private method.
deliverEvent(Event) - Method in class java.awt.Component
Deprecated.
As of JDK version 1.1, replaced by dispatchEvent(AWTEvent e).
deliverEvent(Event) - Method in class java.awt.Container
Deprecated.
As of JDK version 1.1, replaced by dispatchEvent(AWTEvent e)
deltaTransform(Point2D, Point2D) - Method in class java.awt.geom.AffineTransform
Transforms the relative distance vector specified by ptSrc and stores the result in ptDst.
deltaTransform(double[], int, double[], int, int) - Method in class java.awt.geom.AffineTransform
Transforms an array of relative distance vectors by this transform.
Deprecated - Annotation Type in java.lang
A program element annotated @Deprecated is one that programmers are discouraged from using, typically because it is dangerous, or because a better alternative exists.
depth() - Method in class javax.swing.text.ElementIterator
Fetches the current depth of element tree.
depthFirstEnumeration() - Method in class javax.swing.tree.DefaultMutableTreeNode
Creates and returns an enumeration that traverses the subtree rooted at this node in depth-first order.
depthOffset - Variable in class javax.swing.plaf.basic.BasicTreeUI
How much the depth should be offset to properly calculate x locations.
Deque<E> - Interface in java.util
A linear collection that supports element insertion and removal at both ends.
dequeueKeyEvents(long, Component) - Method in class java.awt.DefaultKeyboardFocusManager
Releases for normal dispatching to the current focus owner all KeyEvents which were enqueued because of a call to enqueueKeyEvents with the same timestamp and Component.
dequeueKeyEvents(long, Component) - Method in class java.awt.KeyboardFocusManager
Called by the AWT to notify the KeyboardFocusManager that it should cancel delayed dispatching of KeyEvents.
dereference(XMLCryptoContext) - Method in interface javax.xml.crypto.dsig.keyinfo.RetrievalMethod
Dereferences the KeyInfo information referenced by this RetrievalMethod and applies the specified Transforms.
dereference(URIReference, XMLCryptoContext) - Method in interface javax.xml.crypto.URIDereferencer
Dereferences the specified URIReference and returns the dereferenced data.
deregister(AbstractSelectionKey) - Method in class java.nio.channels.spi.AbstractSelector
Removes the given key from its channel's key set.
deregister() - Method in interface java.sql.DriverAction
Method called by DriverManager.deregisterDriver(Driver) to notify the JDBC driver that it was de-registered.
deregisterAll(Class<?>) - Method in class javax.imageio.spi.ServiceRegistry
Deregisters all service provider object currently registered under the given category.
deregisterAll() - Method in class javax.imageio.spi.ServiceRegistry
Deregisters all currently registered service providers from all categories.
deregisterDriver(Driver) - Static method in class java.sql.DriverManager
Removes the specified driver from the DriverManager's list of registered drivers.
deregisterServiceProvider(T, Class<T>) - Method in class javax.imageio.spi.ServiceRegistry
Removes a service provider object from the given category.
deregisterServiceProvider(Object) - Method in class javax.imageio.spi.ServiceRegistry
Removes a service provider object from all categories that contain it.
DERIVATION_EXTENSION - Static variable in interface org.w3c.dom.TypeInfo
If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the derivation by extension.
DERIVATION_LIST - Static variable in interface org.w3c.dom.TypeInfo
If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the list.
DERIVATION_RESTRICTION - Static variable in interface org.w3c.dom.TypeInfo
If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the derivation by restriction if complex types are involved, or a restriction if simple types are involved.
DERIVATION_UNION - Static variable in interface org.w3c.dom.TypeInfo
If the document's schema is an XML Schema [XML Schema Part 1] , this constant represents the union if simple types are involved.
derive(int) - Method in class java.awt.AlphaComposite
Returns a similar AlphaComposite object that uses the specified compositing rule.
derive(float) - Method in class java.awt.AlphaComposite
Returns a similar AlphaComposite object that uses the specified alpha value.
deriveFont(int, float) - Method in class java.awt.Font
Creates a new Font object by replicating this Font object and applying a new style and size.
deriveFont(int, AffineTransform) - Method in class java.awt.Font
Creates a new Font object by replicating this Font object and applying a new style and transform.
deriveFont(float) - Method in class java.awt.Font
Creates a new Font object by replicating the current Font object and applying a new size to it.
deriveFont(AffineTransform) - Method in class java.awt.Font
Creates a new Font object by replicating the current Font object and applying a new transform to it.
deriveFont(int) - Method in class java.awt.Font
Creates a new Font object by replicating the current Font object and applying a new style to it.
deriveFont(Map<? extends AttributedCharacterIterator.Attribute, ?>) - Method in class java.awt.Font
Creates a new Font object by replicating the current Font object and applying a new set of font attributes to it.
deriveMMFont(float[]) - Method in interface java.awt.font.MultipleMaster
Creates a new instance of a multiple master font based on the design axis values contained in the specified array.
deriveMMFont(float[], float, float, float, float) - Method in interface java.awt.font.MultipleMaster
Creates a new instance of a multiple master font based on detailed metric information.
DES_EDE_KEY_LEN - Static variable in class javax.crypto.spec.DESedeKeySpec
The constant which defines the length of a DESede key in bytes.
DES_KEY_LEN - Static variable in class javax.crypto.spec.DESKeySpec
The constant which defines the length of a DES key in bytes.
descendingIterator() - Method in class java.util.ArrayDeque
descendingIterator() - Method in class java.util.concurrent.ConcurrentLinkedDeque
Returns an iterator over the elements in this deque in reverse sequential order.
descendingIterator() - Method in class java.util.concurrent.ConcurrentSkipListSet
Returns an iterator over the elements in this set in descending order.
descendingIterator() - Method in class java.util.concurrent.LinkedBlockingDeque
Returns an iterator over the elements in this deque in reverse sequential order.
descendingIterator() - Method in interface java.util.Deque
Returns an iterator over the elements in this deque in reverse sequential order.
descendingIterator() - Method in class java.util.LinkedList
descendingIterator() - Method in interface java.util.NavigableSet
Returns an iterator over the elements in this set, in descending order.
descendingIterator() - Method in class java.util.TreeSet
Returns an iterator over the elements in this set in descending order.
descendingKeySet() - Method in interface java.util.concurrent.ConcurrentNavigableMap
Returns a reverse order NavigableSet view of the keys contained in this map.
descendingKeySet() - Method in class java.util.concurrent.ConcurrentSkipListMap
descendingKeySet() - Method in interface java.util.NavigableMap
Returns a reverse order NavigableSet view of the keys contained in this map.
descendingKeySet() - Method in class java.util.TreeMap
descendingMap() - Method in interface java.util.concurrent.ConcurrentNavigableMap
Returns a reverse order view of the mappings contained in this map.
descendingMap() - Method in class java.util.concurrent.ConcurrentSkipListMap
descendingMap() - Method in interface java.util.NavigableMap
Returns a reverse order view of the mappings contained in this map.
descendingMap() - Method in class java.util.TreeMap
descendingSet() - Method in class java.util.concurrent.ConcurrentSkipListSet
Returns a reverse order view of the elements contained in this set.
descendingSet() - Method in interface java.util.NavigableSet
Returns a reverse order view of the elements contained in this set.
descendingSet() - Method in class java.util.TreeSet
description - Variable in class java.sql.DriverPropertyInfo
A brief description of the property, which may be null.
description - Variable in class javax.management.MBeanFeatureInfo
The human-readable description of the feature.
Descriptor - Interface in javax.management
Additional metadata for a JMX element.
DescriptorAccess - Interface in javax.management
This interface is used to gain access to descriptors of the Descriptor class which are associated with a JMX component, i.e.
DescriptorKey - Annotation Type in javax.management
Meta-annotation that describes how an annotation element relates to a field in a Descriptor.
DescriptorRead - Interface in javax.management
Interface to read the Descriptor of a management interface element such as an MBeanInfo.
DescriptorSupport - Class in javax.management.modelmbean
This class represents the metadata set for a ModelMBean element.
DescriptorSupport() - Constructor for class javax.management.modelmbean.DescriptorSupport
Descriptor default constructor.
DescriptorSupport(int) - Constructor for class javax.management.modelmbean.DescriptorSupport
Descriptor constructor.
DescriptorSupport(DescriptorSupport) - Constructor for class javax.management.modelmbean.DescriptorSupport
Descriptor constructor taking a Descriptor as parameter.
DescriptorSupport(String) - Constructor for class javax.management.modelmbean.DescriptorSupport
Descriptor constructor taking an XML String.
DescriptorSupport(String[], Object[]) - Constructor for class javax.management.modelmbean.DescriptorSupport
Constructor taking field names and field values.
DescriptorSupport(String...) - Constructor for class javax.management.modelmbean.DescriptorSupport
Constructor taking fields in the fieldName=fieldValue format.
DESedeKeySpec - Class in javax.crypto.spec
This class specifies a DES-EDE ("triple-DES") key.
DESedeKeySpec(byte[]) - Constructor for class javax.crypto.spec.DESedeKeySpec
Creates a DESedeKeySpec object using the first 24 bytes in key as the key material for the DES-EDE key.
DESedeKeySpec(byte[], int) - Constructor for class javax.crypto.spec.DESedeKeySpec
Creates a DESedeKeySpec object using the first 24 bytes in key, beginning at offset inclusive, as the key material for the DES-EDE key.
deselect(int) - Method in class java.awt.List
Deselects the item at the specified index.
DESELECTED - Static variable in class java.awt.event.ItemEvent
This state-change-value indicates that a selected item was deselected.
DESERET - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Deseret" Unicode character block.
deserialize(ObjectInputStream, Collection) - Method in class java.beans.beancontext.BeanContextSupport
used by readObject to deserialize a collection.
deserialize(ObjectName, byte[]) - Method in interface javax.management.MBeanServer
Deprecated.
Use getClassLoaderFor to obtain the appropriate class loader for deserialization.
deserialize(String, byte[]) - Method in interface javax.management.MBeanServer
Deprecated.
Use MBeanServer.getClassLoaderRepository() to obtain the class loader repository and use it to deserialize.
deserialize(String, ObjectName, byte[]) - Method in interface javax.management.MBeanServer
Deprecated.
Use getClassLoader to obtain the class loader for deserialization.
DESIGNATED_LONG - Static variable in class javax.print.attribute.standard.MediaSize.ISO
Specifies the ISO Designated Long size, 110 mm by 220 mm.
DesignMode - Interface in java.beans
This interface is intended to be implemented by, or delegated from, instances of java.beans.beancontext.BeanContext, in order to propagate to its nested hierarchy of java.beans.beancontext.BeanContextChild instances, the current "designTime" property.
designTime - Variable in class java.beans.beancontext.BeanContextSupport
A boolean indicating whether or not this object is currently in design time mode.
desiredAssertionStatus() - Method in class java.lang.Class
Returns the assertion status that would be assigned to this class if it were to be initialized at the time this method is invoked.
DESKeySpec - Class in javax.crypto.spec
This class specifies a DES key.
DESKeySpec(byte[]) - Constructor for class javax.crypto.spec.DESKeySpec
Creates a DESKeySpec object using the first 8 bytes in key as the key material for the DES key.
DESKeySpec(byte[], int) - Constructor for class javax.crypto.spec.DESKeySpec
Creates a DESKeySpec object using the first 8 bytes in key, beginning at offset inclusive, as the key material for the DES key.
Desktop - Class in java.awt
The Desktop class allows a Java application to launch associated applications registered on the native desktop to handle a URI or a file.
DESKTOP - Static variable in class java.awt.SystemColor
The array index for the SystemColor.desktop system color.
desktop - Static variable in class java.awt.SystemColor
The color rendered for the background of the desktop.
desktop - Variable in class javax.swing.plaf.basic.BasicDesktopPaneUI
Desktop.Action - Enum in java.awt
Represents an action type.
DESKTOP_ICON - Static variable in class javax.accessibility.AccessibleRole
An iconified internal frame in a DESKTOP_PANE.
DESKTOP_ICON - Static variable in class javax.swing.plaf.synth.Region
DesktopIcon region.
DESKTOP_PANE - Static variable in class javax.accessibility.AccessibleRole
A pane that supports internal frames and iconified versions of those internal frames.
DESKTOP_PANE - Static variable in class javax.swing.plaf.synth.Region
DesktopPane region.
desktopIcon - Variable in class javax.swing.JInternalFrame
The icon that is displayed when this internal frame is iconified.
desktopIcon - Variable in class javax.swing.plaf.basic.BasicDesktopIconUI
DesktopIconUI - Class in javax.swing.plaf
Pluggable look and feel interface for JDesktopIcon.
DesktopIconUI() - Constructor for class javax.swing.plaf.DesktopIconUI
DesktopManager - Interface in javax.swing
DesktopManager objects are owned by a JDesktopPane object.
desktopManager - Variable in class javax.swing.plaf.basic.BasicDesktopPaneUI
DesktopPaneUI - Class in javax.swing.plaf
Pluggable look and feel interface for JDesktopPane.
DesktopPaneUI() - Constructor for class javax.swing.plaf.DesktopPaneUI
desktopProperties - Variable in class java.awt.Toolkit
desktopPropsSupport - Variable in class java.awt.Toolkit
destHeight - Variable in class java.awt.image.ReplicateScaleFilter
The target height to scale the image.
destination - Variable in class javax.imageio.ImageReadParam
The current destination BufferedImage, or null if none has been set.
Destination - Class in javax.print.attribute.standard
Class Destination is a printing attribute class, a URI, that is used to indicate an alternate destination for the spooled printer formatted data.
Destination(URI) - Constructor for class javax.print.attribute.standard.Destination
Constructs a new destination attribute with the specified URI.
destination - Variable in class javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler
Destination that receives all events.
destinationBands - Variable in class javax.imageio.ImageReadParam
The set of destination bands to be used, as an array of ints.
destinationOffset - Variable in class javax.imageio.IIOParam
The offset in the destination where the upper-left decoded pixel should be placed.
destinationType - Variable in class javax.imageio.IIOParam
An ImageTypeSpecifier to be used to generate a destination image when reading, or to set the output color type when writing.
destroy() - Method in class java.applet.Applet
Called by the browser or applet viewer to inform this applet that it is being reclaimed and that it should destroy any resources that it has allocated.
destroy() - Method in class java.lang.Process
Kills the subprocess.
destroy() - Method in class java.lang.Thread
Deprecated.
This method was originally designed to destroy this thread without any cleanup. Any monitors it held would have remained locked. However, the method was never implemented. If if were to be implemented, it would be deadlock-prone in much the manner of Thread.suspend(). If the target thread held a lock protecting a critical system resource when it was destroyed, no thread could ever access this resource again. If another thread ever attempted to lock this resource, deadlock would result. Such deadlocks typically manifest themselves as "frozen" processes. For more information, see Why are Thread.stop, Thread.suspend and Thread.resume Deprecated?.
destroy() - Method in class java.lang.ThreadGroup
Destroys this thread group and all of its subgroups.
destroy() - Method in class java.security.KeyStore.PasswordProtection
Clears the password.
destroy() - Method in interface javax.security.auth.Destroyable
Destroy this Object.
destroy() - Method in class javax.security.auth.kerberos.KerberosKey
Destroys this key.
destroy() - Method in class javax.security.auth.kerberos.KerberosTicket
Destroys the ticket and destroys any sensitive information stored in it.
destroy() - Method in class javax.security.auth.x500.X500PrivateCredential
Clears the references to the X.509 certificate, private key and the KeyStore alias in this object.
destroy() - Method in class org.omg.CORBA._IDLTypeStub
destroy() - Method in class org.omg.CORBA._PolicyStub
Destroys the policy object.
destroy() - Method in interface org.omg.CORBA.DynAny
Deprecated.
Destroys this DynAny object and frees any resources used to represent the data value associated with it.
destroy() - Method in interface org.omg.CORBA.IRObjectOperations
Destroys this object.
destroy() - Method in class org.omg.CORBA.ORB
Destroys the ORB so that its resources can be reclaimed.
destroy() - Method in interface org.omg.CORBA.PolicyOperations
Destroys the Policy object.
destroy() - Method in class org.omg.CosNaming._BindingIteratorStub
This operation destroys the iterator.
destroy() - Method in class org.omg.CosNaming._NamingContextExtStub
The destroy operation deletes a naming context.
destroy() - Method in class org.omg.CosNaming._NamingContextStub
The destroy operation deletes a naming context.
destroy() - Method in interface org.omg.CosNaming.BindingIteratorOperations
This operation destroys the iterator.
destroy() - Method in interface org.omg.CosNaming.NamingContextOperations
The destroy operation deletes a naming context.
destroy() - Method in class org.omg.DynamicAny._DynAnyStub
Destroys a DynAny object.
destroy() - Method in class org.omg.DynamicAny._DynArrayStub
Destroys a DynAny object.
destroy() - Method in class org.omg.DynamicAny._DynEnumStub
Destroys a DynAny object.
destroy() - Method in class org.omg.DynamicAny._DynFixedStub
Destroys a DynAny object.
destroy() - Method in class org.omg.DynamicAny._DynSequenceStub
Destroys a DynAny object.
destroy() - Method in class org.omg.DynamicAny._DynStructStub
Destroys a DynAny object.
destroy() - Method in class org.omg.DynamicAny._DynUnionStub
Destroys a DynAny object.
destroy() - Method in class org.omg.DynamicAny._DynValueStub
Destroys a DynAny object.
destroy() - Method in interface org.omg.DynamicAny.DynAnyOperations
Destroys a DynAny object.
destroy() - Method in interface org.omg.PortableInterceptor.InterceptorOperations
Provides an opportunity to destroy this interceptor.
destroy(boolean, boolean) - Method in interface org.omg.PortableServer.POAOperations
This operation destroys the POA and all descendant POAs.
Destroyable - Interface in javax.security.auth
Objects such as credentials may optionally implement this interface to provide the capability to destroy its contents.
destroyBuffers() - Method in class java.awt.Component.FlipBufferStrategy
Destroys the buffers created through this object
DestroyFailedException - Exception in javax.security.auth
Signals that a destroy operation failed.
DestroyFailedException() - Constructor for exception javax.security.auth.DestroyFailedException
Constructs a DestroyFailedException with no detail message.
DestroyFailedException(String) - Constructor for exception javax.security.auth.DestroyFailedException
Constructs a DestroyFailedException with the specified detail message.
destroyForcibly() - Method in class java.lang.Process
Kills the subprocess.
destroySubcontext(Name) - Method in interface javax.naming.Context
Destroys the named context and removes it from the namespace.
destroySubcontext(String) - Method in interface javax.naming.Context
Destroys the named context and removes it from the namespace.
destroySubcontext(String) - Method in class javax.naming.InitialContext
destroySubcontext(Name) - Method in class javax.naming.InitialContext
destWidth - Variable in class java.awt.image.ReplicateScaleFilter
The target width to scale the image.
detachNode() - Method in interface javax.xml.soap.Node
Removes this Node object from the tree.
detail - Variable in exception java.io.WriteAbortedException
Exception that was caught while writing the ObjectStream.
detail - Variable in exception java.rmi.activation.ActivationException
The cause of the activation exception.
detail - Variable in exception java.rmi.RemoteException
The cause of the remote exception.
detail - Variable in exception java.rmi.server.ServerCloneException
The cause of the exception.
Detail - Interface in javax.xml.soap
A container for DetailEntry objects.
DetailEntry - Interface in javax.xml.soap
The content for a Detail object, giving details for a SOAPFault object.
detailsViewIcon - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
detectedCharset() - Method in class java.nio.charset.CharsetDecoder
Retrieves the charset that was detected by this decoder (optional operation).
determineOffset(JTree, Object, boolean, boolean, boolean, int) - Method in class javax.swing.tree.DefaultTreeCellEditor
DEVANAGARI - Static variable in class java.awt.font.NumericShaper
Identifies the DEVANAGARI range and decimal base.
DEVANAGARI - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Devanagari" Unicode character block.
DEVANAGARI_EXTENDED - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Devanagari Extended" Unicode character block.
DEVELOPER_EMPTY - Static variable in class javax.print.attribute.standard.PrinterStateReason
The device is out of developer.
DEVELOPER_LOW - Static variable in class javax.print.attribute.standard.PrinterStateReason
The device is low on developer.
DFN - Static variable in class javax.swing.text.html.HTML.Tag
DGC - Interface in java.rmi.dgc
The DGC abstraction is used for the server side of the distributed garbage collection algorithm.
DGC_ID - Static variable in class java.rmi.server.ObjID
Object number for well-known ObjID of the distributed garbage collector.
DHGenParameterSpec - Class in javax.crypto.spec
This class specifies the set of parameters used for generating Diffie-Hellman (system) parameters for use in Diffie-Hellman key agreement.
DHGenParameterSpec(int, int) - Constructor for class javax.crypto.spec.DHGenParameterSpec
Constructs a parameter set for the generation of Diffie-Hellman (system) parameters.
DHKey - Interface in javax.crypto.interfaces
The interface to a Diffie-Hellman key.
DHParameterSpec - Class in javax.crypto.spec
This class specifies the set of parameters used with the Diffie-Hellman algorithm, as specified in PKCS #3: Diffie-Hellman Key-Agreement Standard.
DHParameterSpec(BigInteger, BigInteger) - Constructor for class javax.crypto.spec.DHParameterSpec
Constructs a parameter set for Diffie-Hellman, using a prime modulus p and a base generator g.
DHParameterSpec(BigInteger, BigInteger, int) - Constructor for class javax.crypto.spec.DHParameterSpec
Constructs a parameter set for Diffie-Hellman, using a prime modulus p, a base generator g, and the size in bits, l, of the random exponent (private value).
DHPrivateKey - Interface in javax.crypto.interfaces
The interface to a Diffie-Hellman private key.
DHPrivateKeySpec - Class in javax.crypto.spec
This class specifies a Diffie-Hellman private key with its associated parameters.
DHPrivateKeySpec(BigInteger, BigInteger, BigInteger) - Constructor for class javax.crypto.spec.DHPrivateKeySpec
Constructor that takes a private value x, a prime modulus p, and a base generator g.
DHPublicKey - Interface in javax.crypto.interfaces
The interface to a Diffie-Hellman public key.
DHPublicKeySpec - Class in javax.crypto.spec
This class specifies a Diffie-Hellman public key with its associated parameters.
DHPublicKeySpec(BigInteger, BigInteger, BigInteger) - Constructor for class javax.crypto.spec.DHPublicKeySpec
Constructor that takes a public value y, a prime modulus p, and a base generator g.
Diagnostic<S> - Interface in javax.tools
Interface for diagnostics from tools.
Diagnostic.Kind - Enum in javax.tools
Kinds of diagnostics, for example, error or warning.
DiagnosticCollector<S> - Class in javax.tools
Provides an easy way to collect diagnostics in a list.
DiagnosticCollector() - Constructor for class javax.tools.DiagnosticCollector
DiagnosticListener<S> - Interface in javax.tools
Interface for receiving diagnostics from tools.
Dialog - Class in java.awt
A Dialog is a top-level window with a title and a border that is typically used to take some form of input from the user.
Dialog(Frame) - Constructor for class java.awt.Dialog
Constructs an initially invisible, modeless Dialog with the specified owner Frame and an empty title.
Dialog(Frame, boolean) - Constructor for class java.awt.Dialog
Constructs an initially invisible Dialog with the specified owner Frame and modality and an empty title.
Dialog(Frame, String) - Constructor for class java.awt.Dialog
Constructs an initially invisible, modeless Dialog with the specified owner Frame and title.
Dialog(Frame, String, boolean) - Constructor for class java.awt.Dialog
Constructs an initially invisible Dialog with the specified owner Frame, title and modality.
Dialog(Frame, String, boolean, GraphicsConfiguration) - Constructor for class java.awt.Dialog
Constructs an initially invisible Dialog with the specified owner Frame, title, modality, and GraphicsConfiguration.
Dialog(Dialog) - Constructor for class java.awt.Dialog
Constructs an initially invisible, modeless Dialog with the specified owner Dialog and an empty title.
Dialog(Dialog, String) - Constructor for class java.awt.Dialog
Constructs an initially invisible, modeless Dialog with the specified owner Dialog and title.
Dialog(Dialog, String, boolean) - Constructor for class java.awt.Dialog
Constructs an initially invisible Dialog with the specified owner Dialog, title, and modality.
Dialog(Dialog, String, boolean, GraphicsConfiguration) - Constructor for class java.awt.Dialog
Constructs an initially invisible Dialog with the specified owner Dialog, title, modality and GraphicsConfiguration.
Dialog(Window) - Constructor for class java.awt.Dialog
Constructs an initially invisible, modeless Dialog with the specified owner Window and an empty title.
Dialog(Window, String) - Constructor for class java.awt.Dialog
Constructs an initially invisible, modeless Dialog with the specified owner Window and title.
Dialog(Window, Dialog.ModalityType) - Constructor for class java.awt.Dialog
Constructs an initially invisible Dialog with the specified owner Window and modality and an empty title.
Dialog(Window, String, Dialog.ModalityType) - Constructor for class java.awt.Dialog
Constructs an initially invisible Dialog with the specified owner Window, title and modality.
Dialog(Window, String, Dialog.ModalityType, GraphicsConfiguration) - Constructor for class java.awt.Dialog
Constructs an initially invisible Dialog with the specified owner Window, title, modality and GraphicsConfiguration.
DIALOG - Static variable in class java.awt.Font
A String constant for the canonical family name of the logical font "Dialog".
DIALOG - Static variable in class javax.accessibility.AccessibleRole
A top level window with title bar and a border.
Dialog.AccessibleAWTDialog - Class in java.awt
This class implements accessibility support for the Dialog class.
Dialog.ModalExclusionType - Enum in java.awt
Any top-level window can be marked not to be blocked by modal dialogs.
Dialog.ModalityType - Enum in java.awt
Modal dialogs block all input to some top-level windows.
DIALOG_INPUT - Static variable in class java.awt.Font
A String constant for the canonical family name of the logical font "DialogInput".
DIALOG_TITLE_CHANGED_PROPERTY - Static variable in class javax.swing.JFileChooser
Identifies a change in the dialog title.
DIALOG_TYPE_CHANGED_PROPERTY - Static variable in class javax.swing.JFileChooser
Identifies a change in the type of files displayed (files only, directories only, or both files and directories).
DIALOG_UI - Static variable in class javax.print.ServiceUIFactory
Denotes a UI implemented as an AWT dialog.
dialogInit() - Method in class javax.swing.JDialog
Called by the constructors to init the JDialog properly.
DialogTypeSelection - Class in javax.print.attribute.standard
Class DialogTypeSelection is a printing attribute class, an enumeration, that indicates the user dialog type to be used for specifying printing options.
DialogTypeSelection(int) - Constructor for class javax.print.attribute.standard.DialogTypeSelection
Construct a new dialog type selection enumeration value with the given integer value.
Dictionary<K,V> - Class in java.util
The Dictionary class is the abstract parent of any class, such as Hashtable, which maps keys to values.
Dictionary() - Constructor for class java.util.Dictionary
Sole constructor.
die() - Method in class javax.swing.undo.AbstractUndoableEdit
Sets alive to false.
die() - Method in class javax.swing.undo.CompoundEdit
Sends die to each subedit, in the reverse of the order that they were added.
die() - Method in interface javax.swing.undo.UndoableEdit
Informs the edit that it should no longer be used.
digest - Variable in class java.security.DigestInputStream
The message digest associated with this stream.
digest - Variable in class java.security.DigestOutputStream
The message digest associated with this stream.
digest() - Method in class java.security.MessageDigest
Completes the hash computation by performing final operations such as padding.
digest(byte[], int, int) - Method in class java.security.MessageDigest
Completes the hash computation by performing final operations such as padding.
digest(byte[]) - Method in class java.security.MessageDigest
Performs a final update on the digest using the specified array of bytes, then completes the digest computation.
DigestException - Exception in java.security
This is the generic Message Digest exception.
DigestException() - Constructor for exception java.security.DigestException
Constructs a DigestException with no detail message.
DigestException(String) - Constructor for exception java.security.DigestException
Constructs a DigestException with the specified detail message.
DigestException(String, Throwable) - Constructor for exception java.security.DigestException
Creates a DigestException with the specified detail message and cause.
DigestException(Throwable) - Constructor for exception java.security.DigestException
Creates a DigestException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
DigestInputStream - Class in java.security
A transparent stream that updates the associated message digest using the bits going through the stream.
DigestInputStream(InputStream, MessageDigest) - Constructor for class java.security.DigestInputStream
Creates a digest input stream, using the specified input stream and message digest.
DigestMethod - Interface in javax.xml.crypto.dsig
A representation of the XML DigestMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
DigestMethodParameterSpec - Interface in javax.xml.crypto.dsig.spec
A specification of algorithm parameters for a DigestMethod algorithm.
DigestOutputStream - Class in java.security
A transparent stream that updates the associated message digest using the bits going through the stream.
DigestOutputStream(OutputStream, MessageDigest) - Constructor for class java.security.DigestOutputStream
Creates a digest output stream, using the specified output stream and message digest.
digit(char, int) - Static method in class java.lang.Character
Returns the numeric value of the character ch in the specified radix.
digit(int, int) - Static method in class java.lang.Character
Returns the numeric value of the specified character (Unicode code point) in the specified radix.
Dimension - Class in java.awt
The Dimension class encapsulates the width and height of a component (in integer precision) in a single object.
Dimension() - Constructor for class java.awt.Dimension
Creates an instance of Dimension with a width of zero and a height of zero.
Dimension(Dimension) - Constructor for class java.awt.Dimension
Creates an instance of Dimension whose width and height are the same as for the specified dimension.
Dimension(int, int) - Constructor for class java.awt.Dimension
Constructs a Dimension and initializes it to the specified width and specified height.
Dimension2D - Class in java.awt.geom
The Dimension2D class is to encapsulate a width and a height dimension.
Dimension2D() - Constructor for class java.awt.geom.Dimension2D
This is an abstract class that cannot be instantiated directly.
DimensionUIResource - Class in javax.swing.plaf
DimensionUIResource(int, int) - Constructor for class javax.swing.plaf.DimensionUIResource
DINGBATS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Dingbats" Unicode character block.
DIR - Static variable in class javax.swing.text.html.HTML.Attribute
DIR - Static variable in class javax.swing.text.html.HTML.Tag
DirContext - Interface in javax.naming.directory
The directory service interface, containing methods for examining and updating attributes associated with objects, and for searching the directory.
DirectColorModel - Class in java.awt.image
The DirectColorModel class is a ColorModel class that works with pixel values that represent RGB color and alpha information as separate samples and that pack all samples for a single pixel into a single int, short, or byte quantity.
DirectColorModel(int, int, int, int) - Constructor for class java.awt.image.DirectColorModel
Constructs a DirectColorModel from the specified masks that indicate which bits in an int pixel representation contain the red, green and blue color samples.
DirectColorModel(int, int, int, int, int) - Constructor for class java.awt.image.DirectColorModel
Constructs a DirectColorModel from the specified masks that indicate which bits in an int pixel representation contain the red, green and blue color samples and the alpha sample, if present.
DirectColorModel(ColorSpace, int, int, int, int, int, boolean, int) - Constructor for class java.awt.image.DirectColorModel
Constructs a DirectColorModel from the specified parameters.
direction - Variable in class javax.swing.plaf.basic.BasicArrowButton
The direction of the arrow.
direction - Variable in class javax.swing.plaf.basic.BasicTreeUI.TreeHomeAction
direction - Variable in class javax.swing.plaf.basic.BasicTreeUI.TreeIncrementAction
Specifies the direction to adjust the selection by.
direction - Variable in class javax.swing.plaf.basic.BasicTreeUI.TreePageAction
Specifies the direction to adjust the selection by.
direction - Variable in class javax.swing.plaf.basic.BasicTreeUI.TreeTraverseAction
Determines direction to traverse, 1 means expand, -1 means collapse.
DIRECTION_DEFAULT_LEFT_TO_RIGHT - Static variable in class java.text.Bidi
Constant indicating that the base direction depends on the first strong directional character in the text according to the Unicode Bidirectional Algorithm.
DIRECTION_DEFAULT_RIGHT_TO_LEFT - Static variable in class java.text.Bidi
Constant indicating that the base direction depends on the first strong directional character in the text according to the Unicode Bidirectional Algorithm.
DIRECTION_LEFT_TO_RIGHT - Static variable in class java.text.Bidi
Constant indicating base direction is left-to-right.
DIRECTION_RIGHT_TO_LEFT - Static variable in class java.text.Bidi
Constant indicating base direction is right-to-left.
DIRECTIONALITY_ARABIC_NUMBER - Static variable in class java.lang.Character
Weak bidirectional character type "AN" in the Unicode specification.
DIRECTIONALITY_BOUNDARY_NEUTRAL - Static variable in class java.lang.Character
Weak bidirectional character type "BN" in the Unicode specification.
DIRECTIONALITY_COMMON_NUMBER_SEPARATOR - Static variable in class java.lang.Character
Weak bidirectional character type "CS" in the Unicode specification.
DIRECTIONALITY_EUROPEAN_NUMBER - Static variable in class java.lang.Character
Weak bidirectional character type "EN" in the Unicode specification.
DIRECTIONALITY_EUROPEAN_NUMBER_SEPARATOR - Static variable in class java.lang.Character
Weak bidirectional character type "ES" in the Unicode specification.
DIRECTIONALITY_EUROPEAN_NUMBER_TERMINATOR - Static variable in class java.lang.Character
Weak bidirectional character type "ET" in the Unicode specification.
DIRECTIONALITY_LEFT_TO_RIGHT - Static variable in class java.lang.Character
Strong bidirectional character type "L" in the Unicode specification.
DIRECTIONALITY_LEFT_TO_RIGHT_EMBEDDING - Static variable in class java.lang.Character
Strong bidirectional character type "LRE" in the Unicode specification.
DIRECTIONALITY_LEFT_TO_RIGHT_OVERRIDE - Static variable in class java.lang.Character
Strong bidirectional character type "LRO" in the Unicode specification.
DIRECTIONALITY_NONSPACING_MARK - Static variable in class java.lang.Character
Weak bidirectional character type "NSM" in the Unicode specification.
DIRECTIONALITY_OTHER_NEUTRALS - Static variable in class java.lang.Character
Neutral bidirectional character type "ON" in the Unicode specification.
DIRECTIONALITY_PARAGRAPH_SEPARATOR - Static variable in class java.lang.Character
Neutral bidirectional character type "B" in the Unicode specification.
DIRECTIONALITY_POP_DIRECTIONAL_FORMAT - Static variable in class java.lang.Character
Weak bidirectional character type "PDF" in the Unicode specification.
DIRECTIONALITY_RIGHT_TO_LEFT - Static variable in class java.lang.Character
Strong bidirectional character type "R" in the Unicode specification.
DIRECTIONALITY_RIGHT_TO_LEFT_ARABIC - Static variable in class java.lang.Character
Strong bidirectional character type "AL" in the Unicode specification.
DIRECTIONALITY_RIGHT_TO_LEFT_EMBEDDING - Static variable in class java.lang.Character
Strong bidirectional character type "RLE" in the Unicode specification.
DIRECTIONALITY_RIGHT_TO_LEFT_OVERRIDE - Static variable in class java.lang.Character
Strong bidirectional character type "RLO" in the Unicode specification.
DIRECTIONALITY_SEGMENT_SEPARATOR - Static variable in class java.lang.Character
Neutral bidirectional character type "S" in the Unicode specification.
DIRECTIONALITY_UNDEFINED - Static variable in class java.lang.Character
Undefined bidirectional character type.
DIRECTIONALITY_WHITESPACE - Static variable in class java.lang.Character
Neutral bidirectional character type "WS" in the Unicode specification.
DIRECTORIES_ONLY - Static variable in class javax.swing.JFileChooser
Instruction to display only directories.
directory() - Method in class java.lang.ProcessBuilder
Returns this process builder's working directory.
directory(File) - Method in class java.lang.ProcessBuilder
Sets this process builder's working directory.
DIRECTORY_CHANGED_PROPERTY - Static variable in class javax.swing.JFileChooser
Identifies user's directory change.
DIRECTORY_PANE - Static variable in class javax.accessibility.AccessibleRole
A pane that allows the user to navigate through and select the contents of a directory.
DirectoryComboBoxAction() - Constructor for class javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxAction
DirectoryComboBoxModel() - Constructor for class javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxModel
directoryIcon - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
DirectoryIteratorException - Exception in java.nio.file
Runtime exception thrown if an I/O error is encountered when iterating over the entries in a directory.
DirectoryIteratorException(IOException) - Constructor for exception java.nio.file.DirectoryIteratorException
Constructs an instance of this class.
DirectoryManager - Class in javax.naming.spi
This class contains methods for supporting DirContext implementations.
DirectoryNotEmptyException - Exception in java.nio.file
Checked exception thrown when a file system operation fails because a directory is not empty.
DirectoryNotEmptyException(String) - Constructor for exception java.nio.file.DirectoryNotEmptyException
Constructs an instance of this class.
directoryOpenButtonMnemonic - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
The mnemonic keycode used for the approve button when a directory is selected and the current selection mode is FILES_ONLY.
directoryOpenButtonText - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
The label text displayed on the approve button when a directory is selected and the current selection mode is FILES_ONLY.
directoryOpenButtonToolTipText - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
The tooltip text displayed on the approve button when a directory is selected and the current selection mode is FILES_ONLY.
DirectoryStream<T> - Interface in java.nio.file
An object to iterate over the entries in a directory.
DirectoryStream.Filter<T> - Interface in java.nio.file
An interface that is implemented by objects that decide if a directory entry should be accepted or filtered.
directSupertypes(TypeMirror) - Method in interface javax.lang.model.util.Types
Returns the direct supertypes of a type.
DirObjectFactory - Interface in javax.naming.spi
This interface represents a factory for creating an object given an object and attributes about the object.
DirStateFactory - Interface in javax.naming.spi
This interface represents a factory for obtaining the state of an object and corresponding attributes for binding.
DirStateFactory.Result - Class in javax.naming.spi
An object/attributes pair for returning the result of DirStateFactory.getStateToBind().
dirty(ObjID[], long, Lease) - Method in interface java.rmi.dgc.DGC
The dirty call requests leases for the remote object references associated with the object identifiers contained in the array 'ids'.
disable() - Method in class java.awt.Component
Deprecated.
As of JDK version 1.1, replaced by setEnabled(boolean).
disable() - Method in class java.awt.MenuItem
Deprecated.
As of JDK version 1.1, replaced by setEnabled(boolean).
disable() - Static method in class java.lang.Compiler
Cause the Compiler to cease operation.
disable() - Method in class javax.swing.JComponent
Deprecated.
As of JDK version 1.1, replaced by java.awt.Component.setEnabled(boolean).
disableAllAttributes() - Method in class javax.management.AttributeChangeNotificationFilter
Disables all the attribute names.
disableAllObjectNames() - Method in class javax.management.relation.MBeanServerNotificationFilter
Disables any MBeanServerNotification (all ObjectNames are deselected).
disableAllTypes() - Method in class javax.management.NotificationFilterSupport
Disables all notification types.
disableAttribute(String) - Method in class javax.management.AttributeChangeNotificationFilter
Disables all the attribute change notifications the attribute name of which equals the specified attribute name to be sent to the listener.
DISABLED - Static variable in interface javax.swing.plaf.synth.SynthConstants
Primary state indicating the region is not enabled.
DISABLED_ICON_CHANGED_PROPERTY - Static variable in class javax.swing.AbstractButton
Identifies a change to the icon used when the button has been disabled.
DISABLED_SELECTED_ICON_CHANGED_PROPERTY - Static variable in class javax.swing.AbstractButton
Identifies a change to the icon used when the button has been disabled and selected.
disabledForeground - Variable in class javax.swing.plaf.basic.BasicMenuItemUI
disabledTextColor - Variable in class javax.swing.plaf.metal.MetalButtonUI
disabledTextColor - Variable in class javax.swing.plaf.metal.MetalRadioButtonUI
disabledTextColor - Variable in class javax.swing.plaf.metal.MetalToggleButtonUI
disableEvents(long) - Method in class java.awt.Component
Disables the events defined by the specified event mask parameter from being delivered to this component.
disableEvents(long) - Method in class java.awt.MenuItem
Disables event delivery to this menu item for events defined by the specified event mask parameter.
disableObjectName(ObjectName) - Method in class javax.management.relation.MBeanServerNotificationFilter
Disables MBeanServerNotifications concerning given ObjectName.
disableResizedPosting() - Method in class javax.swing.table.TableColumn
Deprecated.
as of Java 2 platform v1.3
disableSwingFocusManager() - Static method in class javax.swing.FocusManager
Deprecated.
as of 1.4, replaced by KeyboardFocusManager.setDefaultFocusTraversalPolicy(FocusTraversalPolicy)
disableType(String) - Method in class javax.management.NotificationFilterSupport
Removes the given prefix from the prefix list.
discard_requests(boolean) - Method in interface org.omg.PortableServer.POAManagerOperations
This operation changes the state of the POA manager to discarding.
discardAllEdits() - Method in class javax.swing.undo.UndoManager
Empties the undo manager sending each edit a die message in the process.
DISCARDING - Interface in org.omg.PortableInterceptor
org/omg/PortableInterceptor/DISCARDING.java .
DISCARDING - Static variable in class org.omg.PortableServer.POAManagerPackage.State
discardKeyEvents(Component) - Method in class java.awt.DefaultKeyboardFocusManager
Discards all KeyEvents which were enqueued because of one or more calls to enqueueKeyEvents with the specified Component, or one of its descendants.
discardKeyEvents(Component) - Method in class java.awt.KeyboardFocusManager
Called by the AWT to notify the KeyboardFocusManager that it should cancel delayed dispatching of KeyEvents.
DiscardOldestPolicy() - Constructor for class java.util.concurrent.ThreadPoolExecutor.DiscardOldestPolicy
Creates a DiscardOldestPolicy for the given executor.
DiscardPolicy() - Constructor for class java.util.concurrent.ThreadPoolExecutor.DiscardPolicy
Creates a DiscardPolicy.
disconnect() - Method in class java.net.DatagramSocket
Disconnects the socket.
disconnect() - Method in class java.net.DatagramSocketImpl
Disconnects a datagram socket from its remote destination.
disconnect() - Method in class java.net.HttpURLConnection
Indicates that other requests to the server are unlikely in the near future.
disconnect() - Method in class java.nio.channels.DatagramChannel
Disconnects this channel's socket.
disconnect(Object) - Method in class org.omg.CORBA.ORB
Disconnects the given servant object from the ORB.
DISCONTIGUOUS_TREE_SELECTION - Static variable in interface javax.swing.tree.TreeSelectionModel
Selection can contain any number of items that are not necessarily contiguous.
discriminator() - Method in interface org.omg.CORBA.DynUnion
Deprecated.
Returns a DynAny object reference that must be narrowed to the type of the discriminator in order to insert/get the discriminator value.
discriminator_kind() - Method in interface org.omg.CORBA.DynUnion
Deprecated.
Returns the TCKind object associated with the discriminator of this union.
discriminator_kind() - Method in class org.omg.DynamicAny._DynUnionStub
Returns the TCKind value of the discriminators TypeCode.
discriminator_kind() - Method in interface org.omg.DynamicAny.DynUnionOperations
Returns the TCKind value of the discriminators TypeCode.
discriminator_type() - Method in class org.omg.CORBA.TypeCode
Returns a TypeCode object describing all non-default member labels.
disjoint(Collection<?>, Collection<?>) - Static method in class java.util.Collections
Returns true if the two specified collections have no elements in common.
dismiss(JSpinner) - Method in class javax.swing.JSpinner.DefaultEditor
Disconnect this editor from the specified JSpinner.
dispatch() - Method in interface java.awt.ActiveEvent
Dispatch the event to its target, listeners of the events source, or do whatever it is this event is supposed to do.
dispatch() - Method in class java.awt.event.InvocationEvent
Executes the Runnable's run() method and notifies the notifier (if any) when run() has returned or thrown an exception.
dispatch(Remote, RemoteCall, int, long) - Method in interface java.rmi.server.Skeleton
Deprecated.
no replacement
dispatch(NamingListener) - Method in class javax.naming.event.NamingEvent
Invokes the appropriate listener method on this event.
dispatch(NamingListener) - Method in class javax.naming.event.NamingExceptionEvent
Invokes the namingExceptionThrown() method on a listener using this event.
dispatch(UnsolicitedNotificationListener) - Method in class javax.naming.ldap.UnsolicitedNotificationEvent
Invokes the notificationReceived() method on a listener using this event.
Dispatch<T> - Interface in javax.xml.ws
The Dispatch interface provides support for the dynamic invocation of a service endpoint operations.
dispatchEvent(AWTEvent) - Method in class java.awt.Component
Dispatches an event to this component or one of its sub components.
dispatchEvent(AWTEvent) - Method in class java.awt.DefaultKeyboardFocusManager
This method is called by the AWT event dispatcher requesting that the current KeyboardFocusManager dispatch the specified event on its behalf.
dispatchEvent(AWTEvent) - Method in class java.awt.EventQueue
Dispatches an event.
dispatchEvent(AWTEvent) - Method in class java.awt.im.InputContext
Dispatches an event to the active input method.
dispatchEvent(AWTEvent) - Method in interface java.awt.im.spi.InputMethod
Dispatches the event to the input method.
dispatchEvent(AWTEvent) - Method in class java.awt.KeyboardFocusManager
This method is called by the AWT event dispatcher requesting that the current KeyboardFocusManager dispatch the specified event on its behalf.
dispatchEvent(AWTEvent) - Method in class java.awt.MenuComponent
Delivers an event to this component or one of its sub components.
dispatchEvent(Event) - Method in interface org.w3c.dom.events.EventTarget
This method allows the dispatch of events into the implementations event model.
dispatchInputMethodEvent(int, AttributedCharacterIterator, int, TextHitInfo, TextHitInfo) - Method in interface java.awt.im.spi.InputMethodContext
Creates an input method event from the arguments given and dispatches it to the client component.
dispatchKeyEvent(KeyEvent) - Method in class java.awt.DefaultKeyboardFocusManager
Called by dispatchEvent if no other KeyEventDispatcher in the dispatcher chain dispatched the KeyEvent, or if no other KeyEventDispatchers are registered.
dispatchKeyEvent(KeyEvent) - Method in class java.awt.KeyboardFocusManager
Typically this method will be called by dispatchEvent if no other KeyEventDispatcher in the dispatcher chain dispatched the KeyEvent, or if no other KeyEventDispatchers are registered.
dispatchKeyEvent(KeyEvent) - Method in interface java.awt.KeyEventDispatcher
This method is called by the current KeyboardFocusManager requesting that this KeyEventDispatcher dispatch the specified event on its behalf.
DISPLAY - Static variable in class javax.swing.text.html.CSS.Attribute
DISPLAYABILITY_CHANGED - Static variable in class java.awt.event.HierarchyEvent
A change flag indicates that the HIERARCHY_CHANGED event was generated due to the changing of the hierarchy displayability.
DISPLAYED_MNEMONIC_INDEX_KEY - Static variable in interface javax.swing.Action
The key used for storing an Integer that corresponds to the index in the text (identified by the NAME property) that the decoration for a mnemonic should be rendered at.
displayMessage(String, String, TrayIcon.MessageType) - Method in class java.awt.TrayIcon
Displays a popup message near the tray icon.
DisplayMode - Class in java.awt
The DisplayMode class encapsulates the bit depth, height, width, and refresh rate of a GraphicsDevice.
DisplayMode(int, int, int, int) - Constructor for class java.awt.DisplayMode
Create a new display mode object with the supplied parameters.
displayName() - Method in class java.nio.charset.Charset
Returns this charset's human-readable name for the default locale.
displayName(Locale) - Method in class java.nio.charset.Charset
Returns this charset's human-readable name for the given locale.
dispose() - Method in class java.awt.Component.BltBufferStrategy
Releases system resources currently consumed by this BufferStrategy and removes it from the associated Component.
dispose() - Method in class java.awt.Component.FlipBufferStrategy
Releases system resources currently consumed by this BufferStrategy and removes it from the associated Component.
dispose() - Method in interface java.awt.CompositeContext
Releases resources allocated for a context.
dispose() - Method in class java.awt.Graphics
Disposes of this graphics context and releases any system resources that it is using.
dispose() - Method in class java.awt.im.InputContext
Releases the resources used by this input context.
dispose() - Method in interface java.awt.im.spi.InputMethod
Releases the resources used by this input method.
dispose() - Method in class java.awt.image.BufferStrategy
Releases system resources currently consumed by this BufferStrategy and removes it from the associated Component.
dispose() - Method in interface java.awt.PaintContext
Releases the resources allocated for the operation.
dispose() - Method in class java.awt.Window
Releases all of the native screen resources used by this Window, its subcomponents, and all of its owned children.
dispose() - Method in class javax.imageio.ImageReader
Allows any resources held by this object to be released.
dispose() - Method in class javax.imageio.ImageWriter
Allows any resources held by this object to be released.
dispose() - Method in class javax.print.StreamPrintService
Disposes this StreamPrintService.
dispose() - Method in interface javax.security.sasl.SaslClient
Disposes of any system resources or security-sensitive information the SaslClient might be using.
dispose() - Method in interface javax.security.sasl.SaslServer
Disposes of any system resources or security-sensitive information the SaslServer might be using.
dispose() - Method in class javax.swing.DebugGraphics
Overrides Graphics.dispose.
dispose() - Method in class javax.swing.JInternalFrame
Makes this internal frame invisible, unselected, and closed.
dispose() - Method in interface org.ietf.jgss.GSSContext
Releases any system resources and cryptographic information stored in the context object and invalidates the context.
dispose() - Method in interface org.ietf.jgss.GSSCredential
Releases any sensitive information that the GSSCredential object may be containing.
DISPOSE_ON_CLOSE - Static variable in interface javax.swing.WindowConstants
The dispose-window default window close operation.
distance(double, double, double, double) - Static method in class java.awt.geom.Point2D
Returns the distance between two points.
distance(double, double) - Method in class java.awt.geom.Point2D
Returns the distance from this Point2D to a specified point.
distance(Point2D) - Method in class java.awt.geom.Point2D
Returns the distance from this Point2D to a specified Point2D.
distanceSq(double, double, double, double) - Static method in class java.awt.geom.Point2D
Returns the square of the distance between two points.
distanceSq(double, double) - Method in class java.awt.geom.Point2D
Returns the square of the distance from this Point2D to a specified point.
distanceSq(Point2D) - Method in class java.awt.geom.Point2D
Returns the square of the distance from this Point2D to a specified Point2D.
DISTINCT - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type DISTINCT.
DISTINCT - Static variable in interface java.util.Spliterator
Characteristic value signifying that, for each pair of encountered elements x, y, !x.equals(y).
distinct() - Method in interface java.util.stream.DoubleStream
Returns a stream consisting of the distinct elements of this stream.
distinct() - Method in interface java.util.stream.IntStream
Returns a stream consisting of the distinct elements of this stream.
distinct() - Method in interface java.util.stream.LongStream
Returns a stream consisting of the distinct elements of this stream.
distinct() - Method in interface java.util.stream.Stream
Returns a stream consisting of the distinct elements (according to Object.equals(Object)) of this stream.
DIV - Static variable in class javax.management.Query
A code representing the Query.div(javax.management.ValueExp, javax.management.ValueExp) expression.
div(ValueExp, ValueExp) - Static method in class javax.management.Query
Returns a binary expression representing the quotient of two numeric values.
DIV - Static variable in class javax.swing.text.html.HTML.Tag
divide(BigDecimal, int, int) - Method in class java.math.BigDecimal
Returns a BigDecimal whose value is (this / divisor), and whose scale is as specified.
divide(BigDecimal, int, RoundingMode) - Method in class java.math.BigDecimal
Returns a BigDecimal whose value is (this / divisor), and whose scale is as specified.
divide(BigDecimal, int) - Method in class java.math.BigDecimal
Returns a BigDecimal whose value is (this / divisor), and whose scale is this.scale().
divide(BigDecimal, RoundingMode) - Method in class java.math.BigDecimal
Returns a BigDecimal whose value is (this / divisor), and whose scale is this.scale().
divide(BigDecimal) - Method in class java.math.BigDecimal
Returns a BigDecimal whose value is (this / divisor), and whose preferred scale is (this.scale() - divisor.scale()); if the exact quotient cannot be represented (because it has a non-terminating decimal expansion) an ArithmeticException is thrown.
divide(BigDecimal, MathContext) - Method in class java.math.BigDecimal
Returns a BigDecimal whose value is (this / divisor), with rounding according to the context settings.
divide(BigInteger) - Method in class java.math.BigInteger
Returns a BigInteger whose value is (this / val).
divideAndRemainder(BigDecimal) - Method in class java.math.BigDecimal
Returns a two-element BigDecimal array containing the result of divideToIntegralValue followed by the result of remainder on the two operands.
divideAndRemainder(BigDecimal, MathContext) - Method in class java.math.BigDecimal
Returns a two-element BigDecimal array containing the result of divideToIntegralValue followed by the result of remainder on the two operands calculated with rounding according to the context settings.
divideAndRemainder(BigInteger) - Method in class java.math.BigInteger
Returns an array of two BigIntegers containing (this / val) followed by (this % val).
dividedBy(long) - Method in class java.time.Duration
Returns a copy of this duration divided by the specified value.
DIVIDER - Static variable in class javax.swing.JSplitPane
Used to add a Component that will represent the divider.
divider - Variable in class javax.swing.plaf.basic.BasicSplitPaneUI
Instance of the divider for this JSplitPane.
DIVIDER_LOCATION_PROPERTY - Static variable in class javax.swing.JSplitPane
Bound property for the dividerLocation.
DIVIDER_SIZE_PROPERTY - Static variable in class javax.swing.JSplitPane
Bound property name for border.
DividerLayout() - Constructor for class javax.swing.plaf.basic.BasicSplitPaneDivider.DividerLayout
dividerResizeToggleKey - Variable in class javax.swing.plaf.basic.BasicSplitPaneUI
Deprecated.
As of Java 2 platform v1.3.
dividerSize - Variable in class javax.swing.JSplitPane
Size of the divider.
dividerSize - Variable in class javax.swing.plaf.basic.BasicSplitPaneDivider
Size of the divider.
dividerSize - Variable in class javax.swing.plaf.basic.BasicSplitPaneUI
The size of the divider while the dragging session is valid.
divideToIntegralValue(BigDecimal) - Method in class java.math.BigDecimal
Returns a BigDecimal whose value is the integer part of the quotient (this / divisor) rounded down.
divideToIntegralValue(BigDecimal, MathContext) - Method in class java.math.BigDecimal
Returns a BigDecimal whose value is the integer part of (this / divisor).
divideUnsigned(int, int) - Static method in class java.lang.Integer
Returns the unsigned quotient of dividing the first argument by the second where each argument and the result is interpreted as an unsigned value.
divideUnsigned(long, long) - Static method in class java.lang.Long
Returns the unsigned quotient of dividing the first argument by the second where each argument and the result is interpreted as an unsigned value.
divisionType - Variable in class javax.sound.midi.MidiFileFormat
The division type of the MIDI file.
divisionType - Variable in class javax.sound.midi.Sequence
The timing division type of the sequence.
dk_AbstractInterface - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object represents an abstract interface.
dk_Alias - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is an Alias.
dk_all - Static variable in class org.omg.CORBA.DefinitionKind
The wildcard DefinitionKind constant, useful in all occasions where any DefinitionKind is appropriate.
dk_Array - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is an Array.
dk_Attribute - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is an Attribute.
dk_Constant - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is a constant.
dk_Enum - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is an Enum.
dk_Exception - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is an Exception.
dk_Fixed - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is a Fixed value.
dk_Interface - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is an Interface.
dk_Module - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is a Module.
dk_Native - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is a Native value.
dk_none - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object has no definition kind.
dk_Operation - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is an Operation.
dk_Primitive - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is a Primitive.
dk_Repository - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is a Repository.
dk_Sequence - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is a Sequence.
dk_String - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is a String.
dk_Struct - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is a Struct.
dk_Typedef - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is a Typedef.
dk_Union - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is a Union.
dk_Value - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is a Value.
dk_ValueBox - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is a ValueBox.
dk_ValueMember - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is a ValueMember.
dk_Wstring - Static variable in class org.omg.CORBA.DefinitionKind
The static instance of DefinitionKind indicating that an Interface Repository object is a Wstring.
DL - Static variable in class javax.swing.text.html.HTML.Tag
DnDConstants - Class in java.awt.dnd
This class contains constant values representing the type of action(s) to be performed by a Drag and Drop operation.
DNS_URL - Static variable in interface javax.naming.Context
Constant that holds the name of the environment property for specifying the DNS host and domain names to use for the JNDI URL context (for example, "dns://somehost/wiz.com").
DO_NOTHING_ON_CLOSE - Static variable in interface javax.swing.WindowConstants
The do-nothing default window close operation.
doAccessibleAction(int) - Method in class java.awt.Button.AccessibleAWTButton
Perform the specified Action on the object
doAccessibleAction(int) - Method in class java.awt.Checkbox.AccessibleAWTCheckbox
Perform the specified Action on the object
doAccessibleAction(int) - Method in class java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem
Perform the specified Action on the object
doAccessibleAction(int) - Method in class java.awt.Choice.AccessibleAWTChoice
Perform the specified Action on the object
doAccessibleAction(int) - Method in class java.awt.MenuItem.AccessibleAWTMenuItem
Perform the specified Action on the object
doAccessibleAction(int) - Method in interface javax.accessibility.AccessibleAction
Performs the specified Action on the object
doAccessibleAction(int) - Method in class javax.accessibility.AccessibleHyperlink
Performs the specified Action on the object
doAccessibleAction(int) - Method in class javax.swing.AbstractButton.AccessibleAbstractButton
Perform the specified Action on the object
doAccessibleAction(int) - Method in class javax.swing.JComboBox.AccessibleJComboBox
Perform the specified Action on the object
doAccessibleAction(int) - Method in class javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink
Perform the specified Action on the object
doAccessibleAction(int) - Method in class javax.swing.JSpinner.AccessibleJSpinner
Performs the specified Action on the object
doAccessibleAction(int) - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode
Perform the specified Action on the tree node.
doAccessibleAction(int) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent
Performs the specified Action on the object
doAs(Subject, PrivilegedAction<T>) - Static method in class javax.security.auth.Subject
Perform work as a particular Subject.
doAs(Subject, PrivilegedExceptionAction<T>) - Static method in class javax.security.auth.Subject
Perform work as a particular Subject.
doAsPrivileged(Subject, PrivilegedAction<T>, AccessControlContext) - Static method in class javax.security.auth.Subject
Perform privileged work as a particular Subject.
doAsPrivileged(Subject, PrivilegedExceptionAction<T>, AccessControlContext) - Static method in class javax.security.auth.Subject
Perform privileged work as a particular Subject.
Doc - Interface in javax.print
Interface Doc specifies the interface for an object that supplies one piece of print data for a Print Job.
DocAttribute - Interface in javax.print.attribute
Interface DocAttribute is a tagging interface which a printing attribute class implements to indicate the attribute denotes a setting for a doc.
DocAttributeSet - Interface in javax.print.attribute
Interface DocAttributeSet specifies the interface for a set of doc attributes, i.e.
DocFlavor - Class in javax.print
Class DocFlavor encapsulates an object that specifies the format in which print data is supplied to a DocPrintJob.
DocFlavor(String, String) - Constructor for class javax.print.DocFlavor
Constructs a new doc flavor object from the given MIME type and representation class name.
DocFlavor.BYTE_ARRAY - Class in javax.print
Class DocFlavor.BYTE_ARRAY provides predefined static constant DocFlavor objects for example doc flavors using a byte array (byte[]) as the print data representation class.
DocFlavor.CHAR_ARRAY - Class in javax.print
Class DocFlavor.CHAR_ARRAY provides predefined static constant DocFlavor objects for example doc flavors using a character array (char[]) as the print data representation class.
DocFlavor.INPUT_STREAM - Class in javax.print
Class DocFlavor.INPUT_STREAM provides predefined static constant DocFlavor objects for example doc flavors using a byte stream (java.io.InputStream) as the print data representation class.
DocFlavor.READER - Class in javax.print
Class DocFlavor.READER provides predefined static constant DocFlavor objects for example doc flavors using a character stream (java.io.Reader) as the print data representation class.
DocFlavor.SERVICE_FORMATTED - Class in javax.print
Class DocFlavor.SERVICE_FORMATTED provides predefined static constant DocFlavor objects for example doc flavors for service formatted print data.
DocFlavor.STRING - Class in javax.print
Class DocFlavor.STRING provides predefined static constant DocFlavor objects for example doc flavors using a string (java.lang.String) as the print data representation class.
DocFlavor.URL - Class in javax.print
Class DocFlavor.URL provides predefined static constant DocFlavor objects.
dockingBorderColor - Variable in class javax.swing.plaf.basic.BasicToolBarUI
dockingColor - Variable in class javax.swing.plaf.basic.BasicToolBarUI
dockingListener - Variable in class javax.swing.plaf.basic.BasicToolBarUI
DockingListener(JToolBar) - Constructor for class javax.swing.plaf.basic.BasicToolBarUI.DockingListener
doClick() - Method in class javax.swing.AbstractButton
Programmatically perform a "click".
doClick(int) - Method in class javax.swing.AbstractButton
Programmatically perform a "click".
doClick(int) - Method in class javax.swing.JMenu
Programmatically performs a "click".
doClick(MenuSelectionManager) - Method in class javax.swing.plaf.basic.BasicMenuItemUI
Call this method when a menu item is to be activated.
DocPrintJob - Interface in javax.print
This interface represents a print job that can print a specified document with a set of job attributes.
DOCTYPE_PUBLIC - Static variable in class javax.xml.transform.OutputKeys
doctype-public = string.
DOCTYPE_SYSTEM - Static variable in class javax.xml.transform.OutputKeys
doctype-system = string.
Document - Interface in javax.swing.text
The Document is a container for text that serves as the model for swing text components.
Document - Interface in org.w3c.dom
The Document interface represents the entire HTML or XML document.
DOCUMENT_ACCESS_ERROR - Static variable in class javax.print.attribute.standard.JobStateReason
The Printer could not access one or more documents passed by reference (i.e., the print data representation object is a URL).
DOCUMENT_FORMAT_ERROR - Static variable in class javax.print.attribute.standard.JobStateReason
The job was aborted by the system because the printer encountered an error in the document data while processing it.
DOCUMENT_FRAGMENT_NODE - Static variable in interface org.w3c.dom.Node
The node is a DocumentFragment.
DOCUMENT_NODE - Static variable in interface org.w3c.dom.Node
The node is a Document.
DOCUMENT_POSITION_CONTAINED_BY - Static variable in interface org.w3c.dom.Node
The node is contained by the reference node.
DOCUMENT_POSITION_CONTAINS - Static variable in interface org.w3c.dom.Node
The node contains the reference node.
DOCUMENT_POSITION_DISCONNECTED - Static variable in interface org.w3c.dom.Node
The two nodes are disconnected.
DOCUMENT_POSITION_FOLLOWING - Static variable in interface org.w3c.dom.Node
The node follows the reference node.
DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC - Static variable in interface org.w3c.dom.Node
The determination of preceding versus following is implementation-specific.
DOCUMENT_POSITION_PRECEDING - Static variable in interface org.w3c.dom.Node
The second node precedes the reference node.
DOCUMENT_TYPE_NODE - Static variable in interface org.w3c.dom.Node
The node is a DocumentType.
DocumentationTool - Interface in javax.tools
Interface to invoke Java™ programming language documentation tools from programs.
DocumentationTool.DocumentationTask - Interface in javax.tools
Interface representing a future for a documentation task.
DocumentationTool.Location - Enum in javax.tools
Locations specific to DocumentationTool.
documentBaseKey - Static variable in class javax.swing.plaf.basic.BasicHTML
Key stored as a client property to indicate the base that relative references are resolved against.
DocumentBuilder - Class in javax.xml.parsers
Defines the API to obtain DOM Document instances from an XML document.
DocumentBuilder() - Constructor for class javax.xml.parsers.DocumentBuilder
Protected constructor
DocumentBuilderFactory - Class in javax.xml.parsers
Defines a factory API that enables applications to obtain a parser that produces DOM object trees from XML documents.
DocumentBuilderFactory() - Constructor for class javax.xml.parsers.DocumentBuilderFactory
Protected constructor to prevent instantiation.
Documented - Annotation Type in java.lang.annotation
Indicates that annotations with a type are to be documented by javadoc and similar tools by default.
DocumentEvent - Interface in javax.swing.event
Interface for document change notifications.
DocumentEvent - Interface in org.w3c.dom.events
The DocumentEvent interface provides a mechanism by which the user can create an Event of a type supported by the implementation.
DocumentEvent.ElementChange - Interface in javax.swing.event
Describes changes made to a specific element.
DocumentEvent.EventType - Class in javax.swing.event
Enumeration for document event types
DocumentFilter - Class in javax.swing.text
DocumentFilter, as the name implies, is a filter for the Document mutation methods.
DocumentFilter() - Constructor for class javax.swing.text.DocumentFilter
DocumentFilter.FilterBypass - Class in javax.swing.text
Used as a way to circumvent calling back into the Document to change it.
DocumentFragment - Interface in org.w3c.dom
DocumentFragment is a "lightweight" or "minimal" Document object.
DocumentHandler - Interface in org.xml.sax
Deprecated.
This interface has been replaced by the SAX2 ContentHandler interface, which includes Namespace support.
DocumentListener - Interface in javax.swing.event
Interface for an observer to register to receive notifications of changes to a text document.
DocumentName - Class in javax.print.attribute.standard
Class DocumentName is a printing attribute class, a text attribute, that specifies the name of a document.
DocumentName(String, Locale) - Constructor for class javax.print.attribute.standard.DocumentName
Constructs a new document name attribute with the given document name and locale.
DocumentParser - Class in javax.swing.text.html.parser
A Parser for HTML Documents (actually, you can specify a DTD, but you should really only use this class with the html dtd in swing).
DocumentParser(DTD) - Constructor for class javax.swing.text.html.parser.DocumentParser
DocumentType - Interface in org.w3c.dom
Each Document has a doctype attribute whose value is either null or a DocumentType object.
DocumentView - Interface in org.w3c.dom.views
The DocumentView interface is implemented by Document objects in DOM implementations supporting DOM Views.
doDefaultCloseAction() - Method in class javax.swing.JInternalFrame
Fires an INTERNAL_FRAME_CLOSING event and then performs the action specified by the internal frame's default close operation.
doesMaxRowSizeIncludeBlobs() - Method in interface java.sql.DatabaseMetaData
Retrieves whether the return value for the method getMaxRowSize includes the SQL data types LONGVARCHAR and LONGVARBINARY.
doFinal() - Method in class javax.crypto.Cipher
Finishes a multiple-part encryption or decryption operation, depending on how this cipher was initialized.
doFinal(byte[], int) - Method in class javax.crypto.Cipher
Finishes a multiple-part encryption or decryption operation, depending on how this cipher was initialized.
doFinal(byte[]) - Method in class javax.crypto.Cipher
Encrypts or decrypts data in a single-part operation, or finishes a multiple-part operation.
doFinal(byte[], int, int) - Method in class javax.crypto.Cipher
Encrypts or decrypts data in a single-part operation, or finishes a multiple-part operation.
doFinal(byte[], int, int, byte[]) - Method in class javax.crypto.Cipher
Encrypts or decrypts data in a single-part operation, or finishes a multiple-part operation.
doFinal(byte[], int, int, byte[], int) - Method in class javax.crypto.Cipher
Encrypts or decrypts data in a single-part operation, or finishes a multiple-part operation.
doFinal(ByteBuffer, ByteBuffer) - Method in class javax.crypto.Cipher
Encrypts or decrypts data in a single-part operation, or finishes a multiple-part operation.
doFinal() - Method in class javax.crypto.Mac
Finishes the MAC operation.
doFinal(byte[], int) - Method in class javax.crypto.Mac
Finishes the MAC operation.
doFinal(byte[]) - Method in class javax.crypto.Mac
Processes the given array of bytes and finishes the MAC operation.
doInBackground() - Method in class javax.swing.SwingWorker
Computes a result, or throws an exception if unable to do so.
doInput - Variable in class java.net.URLConnection
This variable is set by the setDoInput method.
doLayout() - Method in class java.awt.Component
Prompts the layout manager to lay out this component.
doLayout() - Method in class java.awt.Container
Causes this container to lay out its components.
doLayout() - Method in class java.awt.ScrollPane
Lays out this container by resizing its child to its preferred size.
doLayout() - Method in class javax.swing.JLayer
Delegates its functionality to the LayerUI.doLayout(JLayer) method, if LayerUI is set.
doLayout() - Method in class javax.swing.JTable
Causes this table to lay out its rows and columns.
doLayout(JLayer<? extends V>) - Method in class javax.swing.plaf.LayerUI
Causes the passed instance of JLayer to lay out its components.
doLayout() - Method in class javax.swing.tree.DefaultTreeCellEditor.EditorContainer
Lays out this Container.
doLookup(Name) - Static method in class javax.naming.InitialContext
A static method to retrieve the named object.
doLookup(String) - Static method in class javax.naming.InitialContext
A static method to retrieve the named object.
DOM_OBJECT_MODEL - Static variable in class javax.xml.xpath.XPathConstants
The URI for the DOM object model, "http://java.sun.com/jaxp/xpath/dom".
DomainCombiner - Interface in java.security
A DomainCombiner provides a means to dynamically update the ProtectionDomains associated with the current AccessControlContext.
DomainLoadStoreParameter - Class in java.security
Configuration data that specifies the keystores in a keystore domain.
DomainLoadStoreParameter(URI, Map<String, KeyStore.ProtectionParameter>) - Constructor for class java.security.DomainLoadStoreParameter
Constructs a DomainLoadStoreParameter for a keystore domain with the parameters used to protect keystore data.
DomainManager - Interface in org.omg.CORBA
Provides mechanisms for establishing and navigating relationships to superior and subordinate domains, as well as for creating and accessing policies.
DomainManagerOperations - Interface in org.omg.CORBA
Provides the DomainManager with the means to access policies.
domainMatches(String, String) - Static method in class java.net.HttpCookie
The utility method to check whether a host name is in a domain or not.
DOMConfiguration - Interface in org.w3c.dom
The DOMConfiguration interface represents the configuration of a document and maintains a table of recognized parameters.
DOMCryptoContext - Class in javax.xml.crypto.dom
This class provides a DOM-specific implementation of the XMLCryptoContext interface.
DOMCryptoContext() - Constructor for class javax.xml.crypto.dom.DOMCryptoContext
Default constructor.
DOMError - Interface in org.w3c.dom
DOMError is an interface that describes an error.
DOMErrorHandler - Interface in org.w3c.dom
DOMErrorHandler is a callback interface that the DOM implementation can call when reporting errors that happens while processing XML data, or when doing some other processing (e.g.
DOMException - Exception in org.w3c.dom
DOM operations only raise exceptions in "exceptional" circumstances, i.e., when an operation is impossible to perform (either for logical reasons, because data is lost, or because the implementation has become unstable).
DOMException(short, String) - Constructor for exception org.w3c.dom.DOMException
DomHandler<ElementT,ResultT extends Result> - Interface in javax.xml.bind.annotation
Converts an element (and its descendants) from/to DOM (or similar) representation.
DOMImplementation - Interface in org.w3c.dom
The DOMImplementation interface provides a number of methods for performing operations that are independent of any particular instance of the document object model.
DOMImplementationList - Interface in org.w3c.dom
The DOMImplementationList interface provides the abstraction of an ordered collection of DOM implementations, without defining or constraining how this collection is implemented.
DOMImplementationLS - Interface in org.w3c.dom.ls
DOMImplementationLS contains the factory methods for creating Load and Save objects.
DOMImplementationRegistry - Class in org.w3c.dom.bootstrap
A factory that enables applications to obtain instances of DOMImplementation.
DOMImplementationSource - Interface in org.w3c.dom
This interface permits a DOM implementer to supply one or more implementations, based upon requested features and versions, as specified in DOM Features.
DOMINO_TILES - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Domino Tiles" Unicode character block.
DOMLocator - Interface in javax.xml.transform.dom
Indicates the position of a node in a source DOM, intended primarily for error reporting.
DOMLocator - Interface in org.w3c.dom
DOMLocator is an interface that describes a location (e.g.
DOMResult - Class in javax.xml.transform.dom
Acts as a holder for a transformation result tree in the form of a Document Object Model (DOM) tree.
DOMResult() - Constructor for class javax.xml.transform.dom.DOMResult
Zero-argument default constructor.
DOMResult(Node) - Constructor for class javax.xml.transform.dom.DOMResult
Use a DOM node to create a new output target.
DOMResult(Node, String) - Constructor for class javax.xml.transform.dom.DOMResult
Use a DOM node to create a new output target with the specified System ID.
DOMResult(Node, Node) - Constructor for class javax.xml.transform.dom.DOMResult
Use a DOM node to create a new output target specifying the child node where the result nodes should be inserted before.
DOMResult(Node, Node, String) - Constructor for class javax.xml.transform.dom.DOMResult
Use a DOM node to create a new output target specifying the child node where the result nodes should be inserted before and the specified System ID.
DOMSignContext - Class in javax.xml.crypto.dsig.dom
A DOM-specific XMLSignContext.
DOMSignContext(Key, Node) - Constructor for class javax.xml.crypto.dsig.dom.DOMSignContext
Creates a DOMSignContext with the specified signing key and parent node.
DOMSignContext(Key, Node, Node) - Constructor for class javax.xml.crypto.dsig.dom.DOMSignContext
Creates a DOMSignContext with the specified signing key, parent and next sibling nodes.
DOMSignContext(KeySelector, Node) - Constructor for class javax.xml.crypto.dsig.dom.DOMSignContext
Creates a DOMSignContext with the specified key selector and parent node.
DOMSignContext(KeySelector, Node, Node) - Constructor for class javax.xml.crypto.dsig.dom.DOMSignContext
Creates a DOMSignContext with the specified key selector, parent and next sibling nodes.
DOMSource - Class in javax.xml.transform.dom
Acts as a holder for a transformation Source tree in the form of a Document Object Model (DOM) tree.
DOMSource() - Constructor for class javax.xml.transform.dom.DOMSource
Zero-argument default constructor.
DOMSource(Node) - Constructor for class javax.xml.transform.dom.DOMSource
Create a new input source with a DOM node.
DOMSource(Node, String) - Constructor for class javax.xml.transform.dom.DOMSource
Create a new input source with a DOM node, and with the system ID also passed in as the base URI.
DOMSTRING_SIZE_ERR - Static variable in exception org.w3c.dom.DOMException
If the specified range of text does not fit into a DOMString.
DOMStringList - Interface in org.w3c.dom
The DOMStringList interface provides the abstraction of an ordered collection of DOMString values, without defining or constraining how this collection is implemented.
DOMStructure - Class in javax.xml.crypto.dom
A DOM-specific XMLStructure.
DOMStructure(Node) - Constructor for class javax.xml.crypto.dom.DOMStructure
Creates a DOMStructure containing the specified node.
DOMURIReference - Interface in javax.xml.crypto.dom
A DOM-specific URIReference.
DOMValidateContext - Class in javax.xml.crypto.dsig.dom
A DOM-specific XMLValidateContext.
DOMValidateContext(KeySelector, Node) - Constructor for class javax.xml.crypto.dsig.dom.DOMValidateContext
Creates a DOMValidateContext containing the specified key selector and node.
DOMValidateContext(Key, Node) - Constructor for class javax.xml.crypto.dsig.dom.DOMValidateContext
Creates a DOMValidateContext containing the specified key and node.
done() - Method in interface java.rmi.server.RemoteCall
Deprecated.
no replacement
done(RemoteCall) - Method in interface java.rmi.server.RemoteRef
Deprecated.
1.2 style stubs no longer use this method. Instead of using a sequence of method calls to the remote reference (newCall, invoke, and done), a stub uses a single method, invoke(Remote, Method, Object[], int), on the remote reference to carry out parameter marshalling, remote method executing and unmarshalling of the return value.
DONE - Static variable in class java.text.BreakIterator
DONE is returned by previous(), next(), next(int), preceding(int) and following(int) when either the first or last text boundary has been reached.
DONE - Static variable in interface java.text.CharacterIterator
Constant that is returned when the iterator has reached either the end or the beginning of the text.
done() - Method in class java.util.concurrent.FutureTask
Protected method invoked when this task transitions to state isDone (whether normally or via cancellation).
done() - Method in class javax.swing.SwingWorker
Executed on the Event Dispatch Thread after the doInBackground method is finished.
dontUseGui() - Method in class java.beans.beancontext.BeanContextSupport
notify this instance that it may no longer render a GUI.
dontUseGui() - Method in interface java.beans.Visibility
This method instructs the bean that it should not use the Gui.
DOOR_OPEN - Static variable in class javax.print.attribute.standard.PrinterStateReason
One or more doors on the device are open.
doOutput - Variable in class java.net.URLConnection
This variable is set by the setDoOutput method.
doPaint(Graphics2D, JComponent, int, int, Object[]) - Method in class javax.swing.plaf.nimbus.AbstractRegionPainter
Actually performs the painting operation.
doPhase(Key, boolean) - Method in class javax.crypto.KeyAgreement
Executes the next phase of this key agreement with the given key that was received from one of the other parties involved in this key agreement.
doPrivileged(PrivilegedAction<T>) - Static method in class java.security.AccessController
Performs the specified PrivilegedAction with privileges enabled.
doPrivileged(PrivilegedAction<T>, AccessControlContext) - Static method in class java.security.AccessController
Performs the specified PrivilegedAction with privileges enabled and restricted by the specified AccessControlContext.
doPrivileged(PrivilegedAction<T>, AccessControlContext, Permission...) - Static method in class java.security.AccessController
Performs the specified PrivilegedAction with privileges enabled and restricted by the specified AccessControlContext and with a privilege scope limited by specified Permission arguments.
doPrivileged(PrivilegedExceptionAction<T>) - Static method in class java.security.AccessController
Performs the specified PrivilegedExceptionAction with privileges enabled.
doPrivileged(PrivilegedExceptionAction<T>, AccessControlContext) - Static method in class java.security.AccessController
Performs the specified PrivilegedExceptionAction with privileges enabled and restricted by the specified AccessControlContext.
doPrivileged(PrivilegedExceptionAction<T>, AccessControlContext, Permission...) - Static method in class java.security.AccessController
Performs the specified PrivilegedExceptionAction with privileges enabled and restricted by the specified AccessControlContext and with a privilege scope limited by specified Permission arguments.
doPrivilegedWithCombiner(PrivilegedAction<T>) - Static method in class java.security.AccessController
Performs the specified PrivilegedAction with privileges enabled.
doPrivilegedWithCombiner(PrivilegedAction<T>, AccessControlContext, Permission...) - Static method in class java.security.AccessController
Performs the specified PrivilegedAction with privileges enabled and restricted by the specified AccessControlContext and with a privilege scope limited by specified Permission arguments.
doPrivilegedWithCombiner(PrivilegedExceptionAction<T>) - Static method in class java.security.AccessController
Performs the specified PrivilegedExceptionAction with privileges enabled.
doPrivilegedWithCombiner(PrivilegedExceptionAction<T>, AccessControlContext, Permission...) - Static method in class java.security.AccessController
Performs the specified PrivilegedExceptionAction with privileges enabled and restricted by the specified AccessControlContext and with a privilege scope limited by specified Permission arguments.
DosFileAttributes - Interface in java.nio.file.attribute
File attributes associated with a file in a file system that supports legacy "DOS" attributes.
DosFileAttributeView - Interface in java.nio.file.attribute
A file attribute view that provides a view of the legacy "DOS" file attributes.
DOTALL - Static variable in class java.util.regex.Pattern
Enables dotall mode.
Double() - Constructor for class java.awt.geom.Arc2D.Double
Constructs a new OPEN arc, initialized to location (0, 0), size (0, 0), angular extents (start = 0, extent = 0).
Double(int) - Constructor for class java.awt.geom.Arc2D.Double
Constructs a new arc, initialized to location (0, 0), size (0, 0), angular extents (start = 0, extent = 0), and the specified closure type.
Double(double, double, double, double, double, double, int) - Constructor for class java.awt.geom.Arc2D.Double
Constructs a new arc, initialized to the specified location, size, angular extents, and closure type.
Double(Rectangle2D, double, double, int) - Constructor for class java.awt.geom.Arc2D.Double
Constructs a new arc, initialized to the specified location, size, angular extents, and closure type.
Double() - Constructor for class java.awt.geom.CubicCurve2D.Double
Constructs and initializes a CubicCurve with coordinates (0, 0, 0, 0, 0, 0, 0, 0).
Double(double, double, double, double, double, double, double, double) - Constructor for class java.awt.geom.CubicCurve2D.Double
Constructs and initializes a CubicCurve2D from the specified double coordinates.
Double() - Constructor for class java.awt.geom.Ellipse2D.Double
Constructs a new Ellipse2D, initialized to location (0, 0) and size (0, 0).
Double(double, double, double, double) - Constructor for class java.awt.geom.Ellipse2D.Double
Constructs and initializes an Ellipse2D from the specified coordinates.
Double() - Constructor for class java.awt.geom.Line2D.Double
Constructs and initializes a Line with coordinates (0, 0) → (0, 0).
Double(double, double, double, double) - Constructor for class java.awt.geom.Line2D.Double
Constructs and initializes a Line2D from the specified coordinates.
Double(Point2D, Point2D) - Constructor for class java.awt.geom.Line2D.Double
Constructs and initializes a Line2D from the specified Point2D objects.
Double() - Constructor for class java.awt.geom.Path2D.Double
Constructs a new empty double precision Path2D object with a default winding rule of Path2D.WIND_NON_ZERO.
Double(int) - Constructor for class java.awt.geom.Path2D.Double
Constructs a new empty double precision Path2D object with the specified winding rule to control operations that require the interior of the path to be defined.
Double(int, int) - Constructor for class java.awt.geom.Path2D.Double
Constructs a new empty double precision Path2D object with the specified winding rule and the specified initial capacity to store path segments.
Double(Shape) - Constructor for class java.awt.geom.Path2D.Double
Constructs a new double precision Path2D object from an arbitrary Shape object.
Double(Shape, AffineTransform) - Constructor for class java.awt.geom.Path2D.Double
Constructs a new double precision Path2D object from an arbitrary Shape object, transformed by an AffineTransform object.
Double() - Constructor for class java.awt.geom.Point2D.Double
Constructs and initializes a Point2D with coordinates (0, 0).
Double(double, double) - Constructor for class java.awt.geom.Point2D.Double
Constructs and initializes a Point2D with the specified coordinates.
Double() - Constructor for class java.awt.geom.QuadCurve2D.Double
Constructs and initializes a QuadCurve2D with coordinates (0, 0, 0, 0, 0, 0).
Double(double, double, double, double, double, double) - Constructor for class java.awt.geom.QuadCurve2D.Double
Constructs and initializes a QuadCurve2D from the specified double coordinates.
Double() - Constructor for class java.awt.geom.Rectangle2D.Double
Constructs a new Rectangle2D, initialized to location (0, 0) and size (0, 0).
Double(double, double, double, double) - Constructor for class java.awt.geom.Rectangle2D.Double
Constructs and initializes a Rectangle2D from the specified double coordinates.
Double() - Constructor for class java.awt.geom.RoundRectangle2D.Double
Constructs a new RoundRectangle2D, initialized to location (0.0, 0.0), size (0.0, 0.0), and corner arcs of radius 0.0.
Double(double, double, double, double, double, double) - Constructor for class java.awt.geom.RoundRectangle2D.Double
Constructs and initializes a RoundRectangle2D from the specified double coordinates.
Double - Class in java.lang
The Double class wraps a value of the primitive type double in an object.
Double(double) - Constructor for class java.lang.Double
Constructs a newly allocated Double object that represents the primitive double argument.
Double(String) - Constructor for class java.lang.Double
Constructs a newly allocated Double object that represents the floating-point value of type double represented by the string.
DOUBLE - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type DOUBLE.
DOUBLE - Static variable in class javax.management.openmbean.SimpleType
The SimpleType instance describing values whose Java class name is java.lang.Double.
DoubleAccumulator - Class in java.util.concurrent.atomic
One or more variables that together maintain a running double value updated using a supplied function.
DoubleAccumulator(DoubleBinaryOperator, double) - Constructor for class java.util.concurrent.atomic.DoubleAccumulator
Creates a new instance using the given accumulator function and identity element.
DoubleAdder - Class in java.util.concurrent.atomic
One or more variables that together maintain an initially zero double sum.
DoubleAdder() - Constructor for class java.util.concurrent.atomic.DoubleAdder
Creates a new adder with initial sum of zero.
DoubleBinaryOperator - Interface in java.util.function
Represents an operation upon two double-valued operands and producing a double-valued result.
DoubleBuffer - Class in java.nio
A double buffer.
DoubleClickListener(JList) - Constructor for class javax.swing.plaf.basic.BasicFileChooserUI.DoubleClickListener
DoubleConsumer - Interface in java.util.function
Represents an operation that accepts a single double-valued argument and returns no result.
DoubleFunction<R> - Interface in java.util.function
Represents a function that accepts a double-valued argument and produces a result.
DoubleHolder - Class in org.omg.CORBA
The Holder for Double.
DoubleHolder() - Constructor for class org.omg.CORBA.DoubleHolder
Constructs a new DoubleHolder object with its value field initialized to 0.0.
DoubleHolder(double) - Constructor for class org.omg.CORBA.DoubleHolder
Constructs a new DoubleHolder object for the given double.
DoublePredicate - Interface in java.util.function
Represents a predicate (boolean-valued function) of one double-valued argument.
doubles(long) - Method in class java.util.concurrent.ThreadLocalRandom
Returns a stream producing the given streamSize number of pseudorandom double values, each between zero (inclusive) and one (exclusive).
doubles() - Method in class java.util.concurrent.ThreadLocalRandom
Returns an effectively unlimited stream of pseudorandom double values, each between zero (inclusive) and one (exclusive).
doubles(long, double, double) - Method in class java.util.concurrent.ThreadLocalRandom
Returns a stream producing the given streamSize number of pseudorandom double values, each conforming to the given origin (inclusive) and bound (exclusive).
doubles(double, double) - Method in class java.util.concurrent.ThreadLocalRandom
Returns an effectively unlimited stream of pseudorandom double values, each conforming to the given origin (inclusive) and bound (exclusive).
doubles(long) - Method in class java.util.Random
Returns a stream producing the given streamSize number of pseudorandom double values, each between zero (inclusive) and one (exclusive).
doubles() - Method in class java.util.Random
Returns an effectively unlimited stream of pseudorandom double values, each between zero (inclusive) and one (exclusive).
doubles(long, double, double) - Method in class java.util.Random
Returns a stream producing the given streamSize number of pseudorandom double values, each conforming to the given origin (inclusive) and bound (exclusive).
doubles(double, double) - Method in class java.util.Random
Returns an effectively unlimited stream of pseudorandom double values, each conforming to the given origin (inclusive) and bound (exclusive).
doubles(long) - Method in class java.util.SplittableRandom
Returns a stream producing the given streamSize number of pseudorandom double values from this generator and/or one split from it; each value is between zero (inclusive) and one (exclusive).
doubles() - Method in class java.util.SplittableRandom
Returns an effectively unlimited stream of pseudorandom double values from this generator and/or one split from it; each value is between zero (inclusive) and one (exclusive).
doubles(long, double, double) - Method in class java.util.SplittableRandom
Returns a stream producing the given streamSize number of pseudorandom double values from this generator and/or one split from it; each value conforms to the given origin (inclusive) and bound (exclusive).
doubles(double, double) - Method in class java.util.SplittableRandom
Returns an effectively unlimited stream of pseudorandom double values from this generator and/or one split from it; each value conforms to the given origin (inclusive) and bound (exclusive).
DoubleSeqHelper - Class in org.omg.CORBA
The Helper for DoubleSeq.
DoubleSeqHelper() - Constructor for class org.omg.CORBA.DoubleSeqHelper
DoubleSeqHolder - Class in org.omg.CORBA
The Holder for DoubleSeq.
DoubleSeqHolder() - Constructor for class org.omg.CORBA.DoubleSeqHolder
DoubleSeqHolder(double[]) - Constructor for class org.omg.CORBA.DoubleSeqHolder
DoubleStream - Interface in java.util.stream
A sequence of primitive double-valued elements supporting sequential and parallel aggregate operations.
doubleStream(Spliterator.OfDouble, boolean) - Static method in class java.util.stream.StreamSupport
Creates a new sequential or parallel DoubleStream from a Spliterator.OfDouble.
doubleStream(Supplier<? extends Spliterator.OfDouble>, int, boolean) - Static method in class java.util.stream.StreamSupport
Creates a new sequential or parallel DoubleStream from a Supplier of Spliterator.OfDouble.
DoubleStream.Builder - Interface in java.util.stream
A mutable builder for a DoubleStream.
DoubleSummaryStatistics - Class in java.util
A state object for collecting statistics such as count, min, max, sum, and average.
DoubleSummaryStatistics() - Constructor for class java.util.DoubleSummaryStatistics
Construct an empty instance with zero count, zero sum, Double.POSITIVE_INFINITY min, Double.NEGATIVE_INFINITY max and zero average.
DoubleSupplier - Interface in java.util.function
Represents a supplier of double-valued results.
DoubleToIntFunction - Interface in java.util.function
Represents a function that accepts a double-valued argument and produces an int-valued result.
doubleToLongBits(double) - Static method in class java.lang.Double
Returns a representation of the specified floating-point value according to the IEEE 754 floating-point "double format" bit layout.
DoubleToLongFunction - Interface in java.util.function
Represents a function that accepts a double-valued argument and produces a long-valued result.
doubleToRawLongBits(double) - Static method in class java.lang.Double
Returns a representation of the specified floating-point value according to the IEEE 754 floating-point "double format" bit layout, preserving Not-a-Number (NaN) values.
DoubleUnaryOperator - Interface in java.util.function
Represents an operation on a single double-valued operand that produces a double-valued result.
doubleValue() - Method in class java.lang.Byte
Returns the value of this Byte as a double after a widening primitive conversion.
doubleValue() - Method in class java.lang.Double
Returns the double value of this Double object.
doubleValue() - Method in class java.lang.Float
Returns the value of this Float as a double after a widening primitive conversion.
doubleValue() - Method in class java.lang.Integer
Returns the value of this Integer as a double after a widening primitive conversion.
doubleValue() - Method in class java.lang.Long
Returns the value of this Long as a double after a widening primitive conversion.
doubleValue() - Method in class java.lang.Number
Returns the value of the specified number as a double, which may involve rounding.
doubleValue() - Method in class java.lang.Short
Returns the value of this Short as a double after a widening primitive conversion.
doubleValue() - Method in class java.math.BigDecimal
Converts this BigDecimal to a double.
doubleValue() - Method in class java.math.BigInteger
Converts this BigInteger to a double.
doubleValue() - Method in class java.util.concurrent.atomic.AtomicInteger
Returns the value of this AtomicInteger as a double after a widening primitive conversion.
doubleValue() - Method in class java.util.concurrent.atomic.AtomicLong
Returns the value of this AtomicLong as a double after a widening primitive conversion.
doubleValue() - Method in class java.util.concurrent.atomic.DoubleAccumulator
Equivalent to DoubleAccumulator.get().
doubleValue() - Method in class java.util.concurrent.atomic.DoubleAdder
Equivalent to DoubleAdder.sum().
doubleValue() - Method in class java.util.concurrent.atomic.LongAccumulator
Returns the current value as a double after a widening primitive conversion.
doubleValue() - Method in class java.util.concurrent.atomic.LongAdder
Returns the LongAdder.sum() as a double after a widening primitive conversion.
DOWN - Static variable in class java.awt.Event
The Down Arrow key, a non-ASCII action key.
DOWN_CYCLE_TRAVERSAL_KEYS - Static variable in class java.awt.KeyboardFocusManager
The identifier for the Down Cycle focus traversal keys.
downAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the Action for moving the caret logically downward one position.
downFocusCycle(Container) - Method in class java.awt.DefaultKeyboardFocusManager
Moves the focus down one focus traversal cycle.
downFocusCycle(Container) - Method in class java.awt.KeyboardFocusManager
Moves the focus down one focus traversal cycle.
downFocusCycle() - Method in class java.awt.KeyboardFocusManager
Moves the focus down one focus traversal cycle from the current focus owner, if and only if the current focus owner is a Container that is a focus cycle root.
downKey - Variable in class javax.swing.plaf.basic.BasicSplitPaneUI
Deprecated.
As of Java 2 platform v1.3.
downKey - Variable in class javax.swing.plaf.basic.BasicTabbedPaneUI
Deprecated.
As of Java 2 platform v1.3.
downKey - Variable in class javax.swing.plaf.basic.BasicToolBarUI
Deprecated.
As of Java 2 platform v1.3.
DPCM - Static variable in class javax.print.attribute.ResolutionSyntax
Value to indicate units of dots per centimeter (dpcm).
DPI - Static variable in class javax.print.attribute.ResolutionSyntax
Value to indicate units of dots per inch (dpi).
DRAFT - Static variable in class java.awt.PageAttributes.PrintQualityType
The PrintQualityType instance to use for specifying a draft print quality.
DRAFT - Static variable in class javax.print.attribute.standard.PrintQuality
Lowest quality available on the printer.
DRAG_LAYER - Static variable in class javax.swing.JLayeredPane
Convenience object defining the Drag layer.
DragController(MouseEvent) - Constructor for class javax.swing.plaf.basic.BasicSplitPaneDivider.DragController
dragDividerTo(int) - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider
Messages the BasicSplitPaneUI with dragDividerTo that this instance is contained in.
dragDividerTo(int) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Messaged during a dragging session to move the divider to the passed in location.
dragDropEnd(DragSourceDropEvent) - Method in class java.awt.dnd.DragSourceAdapter
This method is invoked to signify that the Drag and Drop operation is complete.
dragDropEnd(DragSourceDropEvent) - Method in class java.awt.dnd.DragSourceContext
Calls dragDropEnd on the DragSourceListeners registered with this DragSourceContext and with the associated DragSource, and passes them the specified DragSourceDropEvent.
dragDropEnd(DragSourceDropEvent) - Method in interface java.awt.dnd.DragSourceListener
This method is invoked to signify that the Drag and Drop operation is complete.
dragEnter(DragSourceDragEvent) - Method in class java.awt.dnd.DragSourceAdapter
Called as the cursor's hotspot enters a platform-dependent drop site.
dragEnter(DragSourceDragEvent) - Method in class java.awt.dnd.DragSourceContext
Calls dragEnter on the DragSourceListeners registered with this DragSourceContext and with the associated DragSource, and passes them the specified DragSourceDragEvent.
dragEnter(DragSourceDragEvent) - Method in interface java.awt.dnd.DragSourceListener
Called as the cursor's hotspot enters a platform-dependent drop site.
dragEnter(DropTargetDragEvent) - Method in class java.awt.dnd.DropTarget
Calls dragEnter on the registered DropTargetListener and passes it the specified DropTargetDragEvent.
dragEnter(DropTargetDragEvent) - Method in class java.awt.dnd.DropTargetAdapter
Called while a drag operation is ongoing, when the mouse pointer enters the operable part of the drop site for the DropTarget registered with this listener.
dragEnter(DropTargetDragEvent) - Method in interface java.awt.dnd.DropTargetListener
Called while a drag operation is ongoing, when the mouse pointer enters the operable part of the drop site for the DropTarget registered with this listener.
dragExit(DragSourceEvent) - Method in class java.awt.dnd.DragSourceAdapter
Called as the cursor's hotspot exits a platform-dependent drop site.
dragExit(DragSourceEvent) - Method in class java.awt.dnd.DragSourceContext
Calls dragExit on the DragSourceListeners registered with this DragSourceContext and with the associated DragSource, and passes them the specified DragSourceEvent.
dragExit(DragSourceEvent) - Method in interface java.awt.dnd.DragSourceListener
Called as the cursor's hotspot exits a platform-dependent drop site.
dragExit(DropTargetEvent) - Method in class java.awt.dnd.DropTarget
Calls dragExit on the registered DropTargetListener and passes it the specified DropTargetEvent.
dragExit(DropTargetEvent) - Method in class java.awt.dnd.DropTargetAdapter
Called while a drag operation is ongoing, when the mouse pointer has exited the operable part of the drop site for the DropTarget registered with this listener.
dragExit(DropTargetEvent) - Method in interface java.awt.dnd.DropTargetListener
Called while a drag operation is ongoing, when the mouse pointer has exited the operable part of the drop site for the DropTarget registered with this listener.
dragFrame(JComponent, int, int) - Method in class javax.swing.DefaultDesktopManager
Moves the visible location of the frame being dragged to the location specified.
dragFrame(JComponent, int, int) - Method in interface javax.swing.DesktopManager
The user has moved the frame.
draggedColumn - Variable in class javax.swing.table.JTableHeader
The index of the column being dragged.
draggedDistance - Variable in class javax.swing.table.JTableHeader
The distance from its original position the column has been dragged.
dragger - Variable in class javax.swing.plaf.basic.BasicSplitPaneDivider
Handles mouse dragging message to do the actual dragging.
DragGestureEvent - Class in java.awt.dnd
A DragGestureEvent is passed to DragGestureListener's dragGestureRecognized() method when a particular DragGestureRecognizer detects that a platform dependent drag initiating gesture has occurred on the Component that it is tracking.
DragGestureEvent(DragGestureRecognizer, int, Point, List<? extends InputEvent>) - Constructor for class java.awt.dnd.DragGestureEvent
Constructs a DragGestureEvent object given by the DragGestureRecognizer instance firing this event, an act parameter representing the user's preferred action, an ori parameter indicating the origin of the drag, and a List of events that comprise the gesture(evs parameter).
DragGestureListener - Interface in java.awt.dnd
The listener interface for receiving drag gesture events.
dragGestureListener - Variable in class java.awt.dnd.DragGestureRecognizer
The DragGestureListener associated with this DragGestureRecognizer.
dragGestureRecognized(DragGestureEvent) - Method in interface java.awt.dnd.DragGestureListener
This method is invoked by the DragGestureRecognizer when the DragGestureRecognizer detects a platform-dependent drag initiating gesture.
DragGestureRecognizer - Class in java.awt.dnd
The DragGestureRecognizer is an abstract base class for the specification of a platform-dependent listener that can be associated with a particular Component in order to identify platform-dependent drag initiating gestures.
DragGestureRecognizer(DragSource, Component, int, DragGestureListener) - Constructor for class java.awt.dnd.DragGestureRecognizer
Construct a new DragGestureRecognizer given the DragSource to be used in this Drag and Drop operation, the Component this DragGestureRecognizer should "observe" for drag initiating gestures, the action(s) supported for this Drag and Drop operation, and the DragGestureListener to notify once a drag initiating gesture has been detected.
DragGestureRecognizer(DragSource, Component, int) - Constructor for class java.awt.dnd.DragGestureRecognizer
Construct a new DragGestureRecognizer given the DragSource to be used in this Drag and Drop operation, the Component this DragGestureRecognizer should "observe" for drag initiating gestures, and the action(s) supported for this Drag and Drop operation.
DragGestureRecognizer(DragSource, Component) - Constructor for class java.awt.dnd.DragGestureRecognizer
Construct a new DragGestureRecognizer given the DragSource to be used in this Drag and Drop operation, and the Component this DragGestureRecognizer should "observe" for drag initiating gestures.
DragGestureRecognizer(DragSource) - Constructor for class java.awt.dnd.DragGestureRecognizer
Construct a new DragGestureRecognizer given the DragSource to be used in this Drag and Drop operation.
draggingHW - Variable in class javax.swing.plaf.basic.BasicSplitPaneUI
Set to true in startDragging if any of the children (not including the nonContinuousLayoutDivider) are heavy weights.
dragMouseMoved(DragSourceDragEvent) - Method in class java.awt.dnd.DragSourceAdapter
Called whenever the mouse is moved during a drag operation.
dragMouseMoved(DragSourceDragEvent) - Method in class java.awt.dnd.DragSourceContext
Calls dragMouseMoved on the DragSourceMotionListeners registered with the DragSource associated with this DragSourceContext, and them passes the specified DragSourceDragEvent.
dragMouseMoved(DragSourceDragEvent) - Method in interface java.awt.dnd.DragSourceMotionListener
Called whenever the mouse is moved during a drag operation.
dragOver(DragSourceDragEvent) - Method in class java.awt.dnd.DragSourceAdapter
Called as the cursor's hotspot moves over a platform-dependent drop site.
dragOver(DragSourceDragEvent) - Method in class java.awt.dnd.DragSourceContext
Calls dragOver on the DragSourceListeners registered with this DragSourceContext and with the associated DragSource, and passes them the specified DragSourceDragEvent.
dragOver(DragSourceDragEvent) - Method in interface java.awt.dnd.DragSourceListener
Called as the cursor's hotspot moves over a platform-dependent drop site.
dragOver(DropTargetDragEvent) - Method in class java.awt.dnd.DropTarget
Calls dragOver on the registered DropTargetListener and passes it the specified DropTargetDragEvent.
dragOver(DropTargetDragEvent) - Method in class java.awt.dnd.DropTargetAdapter
Called when a drag operation is ongoing, while the mouse pointer is still over the operable part of the drop site for the DropTarget registered with this listener.
dragOver(DropTargetDragEvent) - Method in interface java.awt.dnd.DropTargetListener
Called when a drag operation is ongoing, while the mouse pointer is still over the operable part of the drop site for the DropTarget registered with this listener.
dragSource - Variable in class java.awt.dnd.DragGestureRecognizer
The DragSource associated with this DragGestureRecognizer.
DragSource - Class in java.awt.dnd
The DragSource is the entity responsible for the initiation of the Drag and Drop operation, and may be used in a number of scenarios: 1 default instance per JVM for the lifetime of that JVM.
DragSource() - Constructor for class java.awt.dnd.DragSource
Creates a new DragSource.
DragSourceAdapter - Class in java.awt.dnd
An abstract adapter class for receiving drag source events.
DragSourceAdapter() - Constructor for class java.awt.dnd.DragSourceAdapter
DragSourceContext - Class in java.awt.dnd
The DragSourceContext class is responsible for managing the initiator side of the Drag and Drop protocol.
DragSourceContext(DragSourceContextPeer, DragGestureEvent, Cursor, Image, Point, Transferable, DragSourceListener) - Constructor for class java.awt.dnd.DragSourceContext
Called from DragSource, this constructor creates a new DragSourceContext given the DragSourceContextPeer for this Drag, the DragGestureEvent that triggered the Drag, the initial Cursor to use for the Drag, an (optional) Image to display while the Drag is taking place, the offset of the Image origin from the hotspot at the instant of the triggering event, the Transferable subject data, and the DragSourceListener to use during the Drag and Drop operation.
DragSourceDragEvent - Class in java.awt.dnd
The DragSourceDragEvent is delivered from the DragSourceContextPeer, via the DragSourceContext, to the DragSourceListener registered with that DragSourceContext and with its associated DragSource.
DragSourceDragEvent(DragSourceContext, int, int, int) - Constructor for class java.awt.dnd.DragSourceDragEvent
Constructs a DragSourceDragEvent.
DragSourceDragEvent(DragSourceContext, int, int, int, int, int) - Constructor for class java.awt.dnd.DragSourceDragEvent
Constructs a DragSourceDragEvent given the specified DragSourceContext, user drop action, target drop action, modifiers and coordinates.
DragSourceDropEvent - Class in java.awt.dnd
The DragSourceDropEvent is delivered from the DragSourceContextPeer, via the DragSourceContext, to the dragDropEnd method of DragSourceListeners registered with that DragSourceContext and with its associated DragSource.
DragSourceDropEvent(DragSourceContext, int, boolean) - Constructor for class java.awt.dnd.DragSourceDropEvent
Construct a DragSourceDropEvent for a drop, given the DragSourceContext, the drop action, and a boolean indicating if the drop was successful.
DragSourceDropEvent(DragSourceContext, int, boolean, int, int) - Constructor for class java.awt.dnd.DragSourceDropEvent
Construct a DragSourceDropEvent for a drop, given the DragSourceContext, the drop action, a boolean indicating if the drop was successful, and coordinates.
DragSourceDropEvent(DragSourceContext) - Constructor for class java.awt.dnd.DragSourceDropEvent
Construct a DragSourceDropEvent for a drag that does not result in a drop.
DragSourceEvent - Class in java.awt.dnd
This class is the base class for DragSourceDragEvent and DragSourceDropEvent.
DragSourceEvent(DragSourceContext) - Constructor for class java.awt.dnd.DragSourceEvent
Construct a DragSourceEvent given a specified DragSourceContext.
DragSourceEvent(DragSourceContext, int, int) - Constructor for class java.awt.dnd.DragSourceEvent
Construct a DragSourceEvent given a specified DragSourceContext, and coordinates of the cursor location.
DragSourceListener - Interface in java.awt.dnd
The DragSourceListener defines the event interface for originators of Drag and Drop operations to track the state of the user's gesture, and to provide appropriate "drag over" feedback to the user throughout the Drag and Drop operation.
DragSourceMotionListener - Interface in java.awt.dnd
A listener interface for receiving mouse motion events during a drag operation.
dragTo(Point, Point) - Method in class javax.swing.plaf.basic.BasicToolBarUI
dragWindow - Variable in class javax.swing.plaf.basic.BasicToolBarUI
drain() - Method in class java.io.ObjectOutputStream
Drain any buffered data in ObjectOutputStream.
drain() - Method in interface javax.sound.sampled.DataLine
Drains queued data from the line by continuing data I/O until the data line's internal buffer has been emptied.
drainPermits() - Method in class java.util.concurrent.Semaphore
Acquires and returns all permits that are immediately available.
drainTasksTo(Collection<? super ForkJoinTask<?>>) - Method in class java.util.concurrent.ForkJoinPool
Removes all available unexecuted submitted and forked tasks from scheduling queues and adds them to the given collection, without altering their execution status.
drainTo(Collection<? super E>) - Method in class java.util.concurrent.ArrayBlockingQueue
drainTo(Collection<? super E>, int) - Method in class java.util.concurrent.ArrayBlockingQueue
drainTo(Collection<? super E>) - Method in interface java.util.concurrent.BlockingQueue
Removes all available elements from this queue and adds them to the given collection.
drainTo(Collection<? super E>, int) - Method in interface java.util.concurrent.BlockingQueue
Removes at most the given number of available elements from this queue and adds them to the given collection.
drainTo(Collection<? super E>) - Method in class java.util.concurrent.DelayQueue
drainTo(Collection<? super E>, int) - Method in class java.util.concurrent.DelayQueue
drainTo(Collection<? super E>) - Method in class java.util.concurrent.LinkedBlockingDeque
drainTo(Collection<? super E>, int) - Method in class java.util.concurrent.LinkedBlockingDeque
drainTo(Collection<? super E>) - Method in class java.util.concurrent.LinkedBlockingQueue
drainTo(Collection<? super E>, int) - Method in class java.util.concurrent.LinkedBlockingQueue
drainTo(Collection<? super E>) - Method in class java.util.concurrent.LinkedTransferQueue
drainTo(Collection<? super E>, int) - Method in class java.util.concurrent.LinkedTransferQueue
drainTo(Collection<? super E>) - Method in class java.util.concurrent.PriorityBlockingQueue
drainTo(Collection<? super E>, int) - Method in class java.util.concurrent.PriorityBlockingQueue
drainTo(Collection<? super E>) - Method in class java.util.concurrent.SynchronousQueue
drainTo(Collection<? super E>, int) - Method in class java.util.concurrent.SynchronousQueue
draw(Graphics2D, float, float) - Method in class java.awt.font.GraphicAttribute
Renders this GraphicAttribute at the specified location.
draw(Graphics2D, float, float) - Method in class java.awt.font.ImageGraphicAttribute
Renders this GraphicAttribute at the specified location.
draw(Graphics2D, float, float) - Method in class java.awt.font.ShapeGraphicAttribute
Renders this GraphicAttribute at the specified location.
draw(Graphics2D, float, float) - Method in class java.awt.font.TextLayout
Renders this TextLayout at the specified location in the specified Graphics2D context.
draw(Shape) - Method in class java.awt.Graphics2D
Strokes the outline of a Shape using the settings of the current Graphics2D context.
draw3DRect(int, int, int, int, boolean) - Method in class java.awt.Graphics
Draws a 3-D highlighted outline of the specified rectangle.
draw3DRect(int, int, int, int, boolean) - Method in class java.awt.Graphics2D
Draws a 3-D highlighted outline of the specified rectangle.
draw3DRect(int, int, int, int, boolean) - Method in class javax.swing.DebugGraphics
Overrides Graphics.draw3DRect.
drawArc(int, int, int, int, int, int) - Method in class java.awt.Graphics
Draws the outline of a circular or elliptical arc covering the specified rectangle.
drawArc(int, int, int, int, int, int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.drawArc.
drawBezel(Graphics, int, int, int, int, boolean, boolean, Color, Color, Color, Color) - Static method in class javax.swing.plaf.basic.BasicGraphicsUtils
drawBuffer - Variable in class java.awt.Component.FlipBufferStrategy
The drawing buffer
drawBytes(byte[], int, int, int, int) - Method in class java.awt.Graphics
Draws the text given by the specified byte array, using this graphics context's current font and color.
drawBytes(byte[], int, int, int, int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.drawBytes.
drawCentered(Component, Graphics, Icon, int, int) - Method in class javax.swing.plaf.basic.BasicTreeUI
drawCentered(Component, Graphics, Icon, int, int) - Method in class javax.swing.plaf.synth.SynthTreeUI
drawChars(char[], int, int, int, int) - Method in class java.awt.Graphics
Draws the text given by the specified character array, using this graphics context's current font and color.
drawChars(char[], int, int, int, int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.drawChars.
drawCheck(Component, Graphics, int, int) - Method in class javax.swing.plaf.metal.MetalCheckBoxIcon
drawDashedHorizontalLine(Graphics, int, int, int) - Method in class javax.swing.plaf.basic.BasicTreeUI
drawDashedRect(Graphics, int, int, int, int) - Static method in class javax.swing.plaf.basic.BasicGraphicsUtils
drawDashedVerticalLine(Graphics, int, int, int) - Method in class javax.swing.plaf.basic.BasicTreeUI
drawEchoCharacter(Graphics, int, int, char) - Method in class javax.swing.text.PasswordView
Renders the echo character, or whatever graphic should be used to display the password characters.
drawEtchedRect(Graphics, int, int, int, int, Color, Color, Color, Color) - Static method in class javax.swing.plaf.basic.BasicGraphicsUtils
drawGlyphVector(GlyphVector, float, float) - Method in class java.awt.Graphics2D
Renders the text of the specified GlyphVector using the Graphics2D context's rendering attributes.
drawGroove(Graphics, int, int, int, int, Color, Color) - Static method in class javax.swing.plaf.basic.BasicGraphicsUtils
drawImage(Image, int, int, ImageObserver) - Method in class java.awt.Graphics
Draws as much of the specified image as is currently available.
drawImage(Image, int, int, int, int, ImageObserver) - Method in class java.awt.Graphics
Draws as much of the specified image as has already been scaled to fit inside the specified rectangle.
drawImage(Image, int, int, Color, ImageObserver) - Method in class java.awt.Graphics
Draws as much of the specified image as is currently available.
drawImage(Image, int, int, int, int, Color, ImageObserver) - Method in class java.awt.Graphics
Draws as much of the specified image as has already been scaled to fit inside the specified rectangle.
drawImage(Image, int, int, int, int, int, int, int, int, ImageObserver) - Method in class java.awt.Graphics
Draws as much of the specified area of the specified image as is currently available, scaling it on the fly to fit inside the specified area of the destination drawable surface.
drawImage(Image, int, int, int, int, int, int, int, int, Color, ImageObserver) - Method in class java.awt.Graphics
Draws as much of the specified area of the specified image as is currently available, scaling it on the fly to fit inside the specified area of the destination drawable surface.
drawImage(Image, AffineTransform, ImageObserver) - Method in class java.awt.Graphics2D
Renders an image, applying a transform from image space into user space before drawing.
drawImage(BufferedImage, BufferedImageOp, int, int) - Method in class java.awt.Graphics2D
Renders a BufferedImage that is filtered with a BufferedImageOp.
drawImage(Image, int, int, ImageObserver) - Method in class javax.swing.DebugGraphics
Overrides Graphics.drawImage.
drawImage(Image, int, int, int, int, ImageObserver) - Method in class javax.swing.DebugGraphics
Overrides Graphics.drawImage.
drawImage(Image, int, int, Color, ImageObserver) - Method in class javax.swing.DebugGraphics
Overrides Graphics.drawImage.
drawImage(Image, int, int, int, int, Color, ImageObserver) - Method in class javax.swing.DebugGraphics
Overrides Graphics.drawImage.
drawImage(Image, int, int, int, int, int, int, int, int, ImageObserver) - Method in class javax.swing.DebugGraphics
Overrides Graphics.drawImage.
drawImage(Image, int, int, int, int, int, int, int, int, Color, ImageObserver) - Method in class javax.swing.DebugGraphics
Overrides Graphics.drawImage.
drawingCache - Variable in class javax.swing.plaf.basic.BasicTreeUI
Used for minimizing the drawing of vertical lines.
drawInverted() - Method in class javax.swing.plaf.basic.BasicSliderUI
drawLine(int, int, int, int) - Method in class java.awt.Graphics
Draws a line, using the current color, between the points (x1, y1) and (x2, y2) in this graphics context's coordinate system.
drawLine(int, int, int, int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.drawLine.
drawLine(SynthContext, Object, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthGraphicsUtils
Draws a line between the two end points.
drawLine(SynthContext, Object, Graphics, int, int, int, int, Object) - Method in class javax.swing.plaf.synth.SynthGraphicsUtils
Draws a line between the two end points.
drawLine(int, Graphics, int, int) - Method in class javax.swing.text.PlainView
Renders a line of text, suppressing whitespace at the end and expanding any tabs.
drawLine(int, int, Graphics, int, int) - Method in class javax.swing.text.WrappedPlainView
Renders a line of text, suppressing whitespace at the end and expanding any tabs.
drawLoweredBezel(Graphics, int, int, int, int, Color, Color, Color, Color) - Static method in class javax.swing.plaf.basic.BasicGraphicsUtils
drawOval(int, int, int, int) - Method in class java.awt.Graphics
Draws the outline of an oval.
drawOval(int, int, int, int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.drawOval.
drawPolygon(int[], int[], int) - Method in class java.awt.Graphics
Draws a closed polygon defined by arrays of x and y coordinates.
drawPolygon(Polygon) - Method in class java.awt.Graphics
Draws the outline of a polygon defined by the specified Polygon object.
drawPolygon(int[], int[], int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.drawPolygon.
drawPolyline(int[], int[], int) - Method in class java.awt.Graphics
Draws a sequence of connected lines defined by arrays of x and y coordinates.
drawPolyline(int[], int[], int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.drawPolyline.
drawRect(int, int, int, int) - Method in class java.awt.Graphics
Draws the outline of the specified rectangle.
drawRect(int, int, int, int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.drawRect.
drawRenderableImage(RenderableImage, AffineTransform) - Method in class java.awt.Graphics2D
Renders a RenderableImage, applying a transform from image space into user space before drawing.
drawRenderedImage(RenderedImage, AffineTransform) - Method in class java.awt.Graphics2D
Renders a RenderedImage, applying a transform from image space into user space before drawing.
drawRoundRect(int, int, int, int, int, int) - Method in class java.awt.Graphics
Draws an outlined round-cornered rectangle using this graphics context's current color.
drawRoundRect(int, int, int, int, int, int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.drawRoundRect.
drawSelectedText(Graphics, int, int, int, int) - Method in class javax.swing.text.PasswordView
Renders the given range in the model as selected text.
drawSelectedText(Graphics, int, int, int, int) - Method in class javax.swing.text.PlainView
Renders the given range in the model as selected text.
drawSelectedText(Graphics, int, int, int, int) - Method in class javax.swing.text.WrappedPlainView
Renders the given range in the model as selected text.
drawString(String, int, int) - Method in class java.awt.Graphics
Draws the text given by the specified string, using this graphics context's current font and color.
drawString(AttributedCharacterIterator, int, int) - Method in class java.awt.Graphics
Renders the text of the specified iterator applying its attributes in accordance with the specification of the TextAttribute class.
drawString(String, int, int) - Method in class java.awt.Graphics2D
Renders the text of the specified String, using the current text attribute state in the Graphics2D context.
drawString(String, float, float) - Method in class java.awt.Graphics2D
Renders the text specified by the specified String, using the current text attribute state in the Graphics2D context.
drawString(AttributedCharacterIterator, int, int) - Method in class java.awt.Graphics2D
Renders the text of the specified iterator applying its attributes in accordance with the specification of the TextAttribute class.
drawString(AttributedCharacterIterator, float, float) - Method in class java.awt.Graphics2D
Renders the text of the specified iterator applying its attributes in accordance with the specification of the TextAttribute class.
drawString(String, int, int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.drawString.
drawString(AttributedCharacterIterator, int, int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.drawString.
drawString(Graphics, String, int, int, int) - Static method in class javax.swing.plaf.basic.BasicGraphicsUtils
Draw a string with the graphics g at location (x,y) just like g.drawString would.
drawStringUnderlineCharAt(Graphics, String, int, int, int) - Static method in class javax.swing.plaf.basic.BasicGraphicsUtils
Draw a string with the graphics g at location (x, y) just like g.drawString would.
drawTabbedText(Segment, int, int, Graphics, TabExpander, int) - Static method in class javax.swing.text.Utilities
Draws the given text, expanding any tabs that are contained using the given tab expansion technique.
drawUnselectedText(Graphics, int, int, int, int) - Method in class javax.swing.text.PasswordView
Renders the given range in the model as normal unselected text.
drawUnselectedText(Graphics, int, int, int, int) - Method in class javax.swing.text.PlainView
Renders the given range in the model as normal unselected text.
drawUnselectedText(Graphics, int, int, int, int) - Method in class javax.swing.text.WrappedPlainView
Renders the given range in the model as normal unselected text.
drawVBuffer - Variable in class java.awt.Component.FlipBufferStrategy
The drawing buffer as a volatile image
Driver - Interface in java.sql
The interface that every driver class must implement.
DriverAction - Interface in java.sql
An interface that must be implemented when a Driver wants to be notified by DriverManager.
DriverManager - Class in java.sql
The basic service for managing a set of JDBC drivers.
NOTE: The DataSource interface, new in the JDBC 2.0 API, provides another way to connect to a data source.
DriverPropertyInfo - Class in java.sql
Driver properties for making a connection.
DriverPropertyInfo(String, String) - Constructor for class java.sql.DriverPropertyInfo
Constructs a DriverPropertyInfo object with a given name and value.
drop(DropTargetDropEvent) - Method in class java.awt.dnd.DropTarget
Calls drop on the registered DropTargetListener and passes it the specified DropTargetDropEvent if this DropTarget is active.
drop(DropTargetDropEvent) - Method in interface java.awt.dnd.DropTargetListener
Called when the drag operation has terminated with a drop on the operable part of the drop site for the DropTarget registered with this listener.
drop() - Method in class java.nio.channels.MembershipKey
Drop membership.
dropActionChanged(DragSourceDragEvent) - Method in class java.awt.dnd.DragSourceAdapter
Called when the user has modified the drop gesture.
dropActionChanged(DragSourceDragEvent) - Method in class java.awt.dnd.DragSourceContext
Calls dropActionChanged on the DragSourceListeners registered with this DragSourceContext and with the associated DragSource, and passes them the specified DragSourceDragEvent.
dropActionChanged(DragSourceDragEvent) - Method in interface java.awt.dnd.DragSourceListener
Called when the user has modified the drop gesture.
dropActionChanged(DropTargetDragEvent) - Method in class java.awt.dnd.DropTarget
Calls dropActionChanged on the registered DropTargetListener and passes it the specified DropTargetDragEvent.
dropActionChanged(DropTargetDragEvent) - Method in class java.awt.dnd.DropTargetAdapter
Called if the user has modified the current drop gesture.
dropActionChanged(DropTargetDragEvent) - Method in interface java.awt.dnd.DropTargetListener
Called if the user has modified the current drop gesture.
dropArguments(MethodHandle, int, List<Class<?>>) - Static method in class java.lang.invoke.MethodHandles
Produces a method handle which will discard some dummy arguments before calling some other specified target method handle.
dropArguments(MethodHandle, int, Class<?>...) - Static method in class java.lang.invoke.MethodHandles
Produces a method handle which will discard some dummy arguments before calling some other specified target method handle.
dropComplete(boolean) - Method in class java.awt.dnd.DropTargetContext
This method signals that the drop is completed and if it was successful or not.
dropComplete(boolean) - Method in class java.awt.dnd.DropTargetDropEvent
This method notifies the DragSource that the drop transfer(s) are completed.
DropLocation(Point) - Constructor for class javax.swing.TransferHandler.DropLocation
Constructs a drop location for the given point.
DropMode - Enum in javax.swing
Drop modes, used to determine the method by which a component tracks and indicates a drop location during drag and drop.
dropParameterTypes(int, int) - Method in class java.lang.invoke.MethodType
Finds or creates a method type with some parameter types omitted.
DropTarget - Class in java.awt.dnd
The DropTarget is associated with a Component when that Component wishes to accept drops during Drag and Drop operations.
DropTarget(Component, int, DropTargetListener, boolean, FlavorMap) - Constructor for class java.awt.dnd.DropTarget
Creates a new DropTarget given the Component to associate itself with, an int representing the default acceptable action(s) to support, a DropTargetListener to handle event processing, a boolean indicating if the DropTarget is currently accepting drops, and a FlavorMap to use (or null for the default FlavorMap).
DropTarget(Component, int, DropTargetListener, boolean) - Constructor for class java.awt.dnd.DropTarget
Creates a DropTarget given the Component to associate itself with, an int representing the default acceptable action(s) to support, a DropTargetListener to handle event processing, and a boolean indicating if the DropTarget is currently accepting drops.
DropTarget() - Constructor for class java.awt.dnd.DropTarget
Creates a DropTarget.
DropTarget(Component, DropTargetListener) - Constructor for class java.awt.dnd.DropTarget
Creates a DropTarget given the Component to associate itself with, and the DropTargetListener to handle event processing.
DropTarget(Component, int, DropTargetListener) - Constructor for class java.awt.dnd.DropTarget
Creates a DropTarget given the Component to associate itself with, an int representing the default acceptable action(s) to support, and a DropTargetListener to handle event processing.
DropTarget.DropTargetAutoScroller - Class in java.awt.dnd
this protected nested class implements autoscrolling
DropTargetAdapter - Class in java.awt.dnd
An abstract adapter class for receiving drop target events.
DropTargetAdapter() - Constructor for class java.awt.dnd.DropTargetAdapter
DropTargetAutoScroller(Component, Point) - Constructor for class java.awt.dnd.DropTarget.DropTargetAutoScroller
construct a DropTargetAutoScroller
DropTargetContext - Class in java.awt.dnd
A DropTargetContext is created whenever the logical cursor associated with a Drag and Drop operation coincides with the visible geometry of a Component associated with a DropTarget.
DropTargetContext.TransferableProxy - Class in java.awt.dnd
TransferableProxy is a helper inner class that implements Transferable interface and serves as a proxy for another Transferable object which represents data transfer for a particular drag-n-drop operation.
DropTargetDragEvent - Class in java.awt.dnd
The DropTargetDragEvent is delivered to a DropTargetListener via its dragEnter() and dragOver() methods.
DropTargetDragEvent(DropTargetContext, Point, int, int) - Constructor for class java.awt.dnd.DropTargetDragEvent
Construct a DropTargetDragEvent given the DropTargetContext for this operation, the location of the "Drag" Cursor's hotspot in the Component's coordinates, the user drop action, and the source drop actions.
DropTargetDropEvent - Class in java.awt.dnd
The DropTargetDropEvent is delivered via the DropTargetListener drop() method.
DropTargetDropEvent(DropTargetContext, Point, int, int) - Constructor for class java.awt.dnd.DropTargetDropEvent
Construct a DropTargetDropEvent given the DropTargetContext for this operation, the location of the drag Cursor's hotspot in the Component's coordinates, the currently selected user drop action, and the current set of actions supported by the source.
DropTargetDropEvent(DropTargetContext, Point, int, int, boolean) - Constructor for class java.awt.dnd.DropTargetDropEvent
Construct a DropTargetEvent given the DropTargetContext for this operation, the location of the drag Cursor's hotspot in the Component's coordinates, the currently selected user drop action, the current set of actions supported by the source, and a boolean indicating if the source is in the same JVM as the target.
DropTargetEvent - Class in java.awt.dnd
The DropTargetEvent is the base class for both the DropTargetDragEvent and the DropTargetDropEvent.
DropTargetEvent(DropTargetContext) - Constructor for class java.awt.dnd.DropTargetEvent
Construct a DropTargetEvent object with the specified DropTargetContext.
DropTargetListener - Interface in java.awt.dnd
The DropTargetListener interface is the callback interface used by the DropTarget class to provide notification of DnD operations that involve the subject DropTarget.
DSA_SHA1 - Static variable in interface javax.xml.crypto.dsig.SignatureMethod
The DSAwithSHA1 (DSS) signature method algorithm URI.
DSA_TYPE - Static variable in interface javax.xml.crypto.dsig.keyinfo.KeyValue
URI identifying the DSA KeyValue KeyInfo type: http://www.w3.org/2000/09/xmldsig#DSAKeyValue.
DSAGenParameterSpec - Class in java.security.spec
This immutable class specifies the set of parameters used for generating DSA parameters as specified in FIPS 186-3 Digital Signature Standard (DSS).
DSAGenParameterSpec(int, int) - Constructor for class java.security.spec.DSAGenParameterSpec
Creates a domain parameter specification for DSA parameter generation using primePLen and subprimeQLen.
DSAGenParameterSpec(int, int, int) - Constructor for class java.security.spec.DSAGenParameterSpec
Creates a domain parameter specification for DSA parameter generation using primePLen, subprimeQLen, and seedLen.
DSAKey - Interface in java.security.interfaces
The interface to a DSA public or private key.
DSAKeyPairGenerator - Interface in java.security.interfaces
An interface to an object capable of generating DSA key pairs.
DSAParameterSpec - Class in java.security.spec
This class specifies the set of parameters used with the DSA algorithm.
DSAParameterSpec(BigInteger, BigInteger, BigInteger) - Constructor for class java.security.spec.DSAParameterSpec
Creates a new DSAParameterSpec with the specified parameter values.
DSAParams - Interface in java.security.interfaces
Interface to a DSA-specific set of key parameters, which defines a DSA key family.
DSAPrivateKey - Interface in java.security.interfaces
The standard interface to a DSA private key.
DSAPrivateKeySpec - Class in java.security.spec
This class specifies a DSA private key with its associated parameters.
DSAPrivateKeySpec(BigInteger, BigInteger, BigInteger, BigInteger) - Constructor for class java.security.spec.DSAPrivateKeySpec
Creates a new DSAPrivateKeySpec with the specified parameter values.
DSAPublicKey - Interface in java.security.interfaces
The interface to a DSA public key.
DSAPublicKeySpec - Class in java.security.spec
This class specifies a DSA public key with its associated parameters.
DSAPublicKeySpec(BigInteger, BigInteger, BigInteger, BigInteger) - Constructor for class java.security.spec.DSAPublicKeySpec
Creates a new DSAPublicKeySpec with the specified parameter values.
DST - Static variable in class java.awt.AlphaComposite
The destination is left untouched (Porter-Duff Destination rule).
Dst - Static variable in class java.awt.AlphaComposite
AlphaComposite object that implements the opaque DST rule with an alpha of 1.0f.
DST_ATOP - Static variable in class java.awt.AlphaComposite
The part of the destination lying inside of the source is composited over the source and replaces the destination (Porter-Duff Destination Atop Source rule).
DST_IN - Static variable in class java.awt.AlphaComposite
The part of the destination lying inside of the source replaces the destination (Porter-Duff Destination In Source rule).
DST_OFFSET - Static variable in class java.util.Calendar
Field number for get and set indicating the daylight saving offset in milliseconds.
DST_OUT - Static variable in class java.awt.AlphaComposite
The part of the destination lying outside of the source replaces the destination (Porter-Duff Destination Held Out By Source rule).
DST_OVER - Static variable in class java.awt.AlphaComposite
The destination is composited over the source and the result replaces the destination (Porter-Duff Destination Over Source rule).
DstAtop - Static variable in class java.awt.AlphaComposite
AlphaComposite object that implements the opaque DST_ATOP rule with an alpha of 1.0f.
DstIn - Static variable in class java.awt.AlphaComposite
AlphaComposite object that implements the opaque DST_IN rule with an alpha of 1.0f.
DstOut - Static variable in class java.awt.AlphaComposite
AlphaComposite object that implements the opaque DST_OUT rule with an alpha of 1.0f.
DstOver - Static variable in class java.awt.AlphaComposite
AlphaComposite object that implements the opaque DST_OVER rule with an alpha of 1.0f.
DT - Static variable in class javax.swing.text.html.HTML.Tag
DTD - Class in javax.swing.text.html.parser
The representation of an SGML DTD.
DTD(String) - Constructor for class javax.swing.text.html.parser.DTD
Creates a new DTD with the specified name.
dtd - Variable in class javax.swing.text.html.parser.Parser
DTD - Interface in javax.xml.stream.events
This is the top level interface for events dealing with DTDs
DTD - Static variable in interface javax.xml.stream.XMLStreamConstants
Indicates an event is a DTD
DTDConstants - Interface in javax.swing.text.html.parser
SGML constants used in a DTD.
DTDHandler - Interface in org.xml.sax
Receive notification of basic DTD-related events.
DUMMY - Static variable in class javax.swing.text.html.HTML.Attribute
dump(PrintStream, int) - Method in class javax.swing.text.AbstractDocument.AbstractElement
Dumps a debugging representation of the element hierarchy.
dump(PrintStream) - Method in class javax.swing.text.AbstractDocument
Gives a diagnostic dump.
dumpAllThreads(boolean, boolean) - Method in interface java.lang.management.ThreadMXBean
Returns the thread info for all live threads with stack trace and synchronization information.
dumpStack() - Static method in class java.lang.Thread
Prints a stack trace of the current thread to the standard error stream.
DUPLEX - Static variable in class javax.print.attribute.standard.Sides
An alias for "two sided long edge" (see TWO_SIDED_LONG_EDGE).
duplicate() - Method in class java.nio.ByteBuffer
Creates a new byte buffer that shares this buffer's content.
duplicate() - Method in class java.nio.CharBuffer
Creates a new char buffer that shares this buffer's content.
duplicate() - Method in class java.nio.DoubleBuffer
Creates a new double buffer that shares this buffer's content.
duplicate() - Method in class java.nio.FloatBuffer
Creates a new float buffer that shares this buffer's content.
duplicate() - Method in class java.nio.IntBuffer
Creates a new int buffer that shares this buffer's content.
duplicate() - Method in class java.nio.LongBuffer
Creates a new long buffer that shares this buffer's content.
duplicate() - Method in class java.nio.ShortBuffer
Creates a new short buffer that shares this buffer's content.
duplicate(Object) - Method in class org.omg.CORBA.portable.Delegate
Returns a duplicate of the object reference provided.
DUPLICATE_ELEMENT - Static variable in exception org.ietf.jgss.GSSException
Duplicate credential element requested.
DUPLICATE_TOKEN - Static variable in exception org.ietf.jgss.GSSException
The token was a duplicate of an earlier token.
DuplicateFormatFlagsException - Exception in java.util
Unchecked exception thrown when duplicate flags are provided in the format specifier.
DuplicateFormatFlagsException(String) - Constructor for exception java.util.DuplicateFormatFlagsException
Constructs an instance of this class with the specified flags.
DuplicateName - Exception in org.omg.PortableInterceptor.ORBInitInfoPackage
org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateName.java .
DuplicateName() - Constructor for exception org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateName
DuplicateName(String) - Constructor for exception org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateName
DuplicateName(String, String) - Constructor for exception org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateName
DuplicateNameHelper - Class in org.omg.PortableInterceptor.ORBInitInfoPackage
org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateNameHelper.java .
DuplicateNameHelper() - Constructor for class org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper
Duration - Class in java.time
A time-based amount of time, such as '34.5 seconds'.
DURATION - Static variable in class javax.xml.datatype.DatatypeConstants
Fully qualified name for W3C XML Schema datatype duration.
Duration - Class in javax.xml.datatype
Immutable representation of a time span as defined in the W3C XML Schema 1.0 specification.
Duration() - Constructor for class javax.xml.datatype.Duration
Default no-arg constructor.
DURATION_DAYTIME - Static variable in class javax.xml.datatype.DatatypeConstants
Fully qualified name for XQuery 1.0 and XPath 2.0 datatype dayTimeDuration.
DURATION_YEARMONTH - Static variable in class javax.xml.datatype.DatatypeConstants
Fully qualified name for XQuery 1.0 and XPath 2.0 datatype yearMonthDuration.
DYNAMIC_SOAP_PROTOCOL - Static variable in interface javax.xml.soap.SOAPConstants
Used to create MessageFactory instances that create SOAPMessages whose concrete type is based on the Content-Type MIME header passed to the createMessage method.
DynamicImplementation - Class in org.omg.CORBA
Deprecated.
org.omg.CORBA.DynamicImplementation
DynamicImplementation() - Constructor for class org.omg.CORBA.DynamicImplementation
Deprecated.
DynamicImplementation - Class in org.omg.PortableServer
Allows dynamic handling of object invocations.
DynamicImplementation() - Constructor for class org.omg.PortableServer.DynamicImplementation
dynamicInvoker() - Method in class java.lang.invoke.CallSite
Produces a method handle equivalent to an invokedynamic instruction which has been linked to this call site.
dynamicInvoker() - Method in class java.lang.invoke.ConstantCallSite
Returns this call site's permanent target.
dynamicInvoker() - Method in class java.lang.invoke.MutableCallSite
Produces a method handle equivalent to an invokedynamic instruction which has been linked to this call site.
dynamicInvoker() - Method in class java.lang.invoke.VolatileCallSite
Produces a method handle equivalent to an invokedynamic instruction which has been linked to this call site.
DynamicMBean - Interface in javax.management
Defines the methods that should be implemented by a Dynamic MBean (MBean that exposes a dynamic management interface).
DynamicUtilTreeNode(Object, Object) - Constructor for class javax.swing.JTree.DynamicUtilTreeNode
Creates a node with the specified object as its value and with the specified children.
DynAny - Interface in org.omg.CORBA
Deprecated.
Use the new DynAny instead
DynAny - Interface in org.omg.DynamicAny
Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
DynAnyFactory - Interface in org.omg.DynamicAny
DynAny objects can be created by invoking operations on the DynAnyFactory object.
DynAnyFactoryHelper - Class in org.omg.DynamicAny
DynAny objects can be created by invoking operations on the DynAnyFactory object.
DynAnyFactoryHelper() - Constructor for class org.omg.DynamicAny.DynAnyFactoryHelper
DynAnyFactoryOperations - Interface in org.omg.DynamicAny
DynAny objects can be created by invoking operations on the DynAnyFactory object.
DynAnyHelper - Class in org.omg.DynamicAny
Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
DynAnyHelper() - Constructor for class org.omg.DynamicAny.DynAnyHelper
DynAnyOperations - Interface in org.omg.DynamicAny
Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
DynAnySeqHelper - Class in org.omg.DynamicAny
org/omg/DynamicAny/DynAnySeqHelper.java .
DynAnySeqHelper() - Constructor for class org.omg.DynamicAny.DynAnySeqHelper
DynArray - Interface in org.omg.CORBA
Deprecated.
Use the new DynArray instead
DynArray - Interface in org.omg.DynamicAny
DynArray objects support the manipulation of IDL arrays.
DynArrayHelper - Class in org.omg.DynamicAny
DynArray objects support the manipulation of IDL arrays.
DynArrayHelper() - Constructor for class org.omg.DynamicAny.DynArrayHelper
DynArrayOperations - Interface in org.omg.DynamicAny
DynArray objects support the manipulation of IDL arrays.
DynEnum - Interface in org.omg.CORBA
Deprecated.
Use the new DynEnum instead
DynEnum - Interface in org.omg.DynamicAny
DynEnum objects support the manipulation of IDL enumerated values.
DynEnumHelper - Class in org.omg.DynamicAny
DynEnum objects support the manipulation of IDL enumerated values.
DynEnumHelper() - Constructor for class org.omg.DynamicAny.DynEnumHelper
DynEnumOperations - Interface in org.omg.DynamicAny
DynEnum objects support the manipulation of IDL enumerated values.
DynFixed - Interface in org.omg.CORBA
Deprecated.
Use the new DynFixed instead
DynFixed - Interface in org.omg.DynamicAny
DynFixed objects support the manipulation of IDL fixed values.
DynFixedHelper - Class in org.omg.DynamicAny
DynFixed objects support the manipulation of IDL fixed values.
DynFixedHelper() - Constructor for class org.omg.DynamicAny.DynFixedHelper
DynFixedOperations - Interface in org.omg.DynamicAny
DynFixed objects support the manipulation of IDL fixed values.
DynSequence - Interface in org.omg.CORBA
Deprecated.
Use the new DynSequence instead
DynSequence - Interface in org.omg.DynamicAny
DynSequence objects support the manipulation of IDL sequences.
DynSequenceHelper - Class in org.omg.DynamicAny
DynSequence objects support the manipulation of IDL sequences.
DynSequenceHelper() - Constructor for class org.omg.DynamicAny.DynSequenceHelper
DynSequenceOperations - Interface in org.omg.DynamicAny
DynSequence objects support the manipulation of IDL sequences.
DynStruct - Interface in org.omg.CORBA
Deprecated.
Use the new DynStruct instead
DynStruct - Interface in org.omg.DynamicAny
DynStruct objects support the manipulation of IDL struct and exception values.
DynStructHelper - Class in org.omg.DynamicAny
DynStruct objects support the manipulation of IDL struct and exception values.
DynStructHelper() - Constructor for class org.omg.DynamicAny.DynStructHelper
DynStructOperations - Interface in org.omg.DynamicAny
DynStruct objects support the manipulation of IDL struct and exception values.
DynUnion - Interface in org.omg.CORBA
Deprecated.
Use the new DynUnion instead
DynUnion - Interface in org.omg.DynamicAny
DynUnion objects support the manipulation of IDL unions.
DynUnionHelper - Class in org.omg.DynamicAny
DynUnion objects support the manipulation of IDL unions.
DynUnionHelper() - Constructor for class org.omg.DynamicAny.DynUnionHelper
DynUnionOperations - Interface in org.omg.DynamicAny
DynUnion objects support the manipulation of IDL unions.
DynValue - Interface in org.omg.CORBA
Deprecated.
Use the new DynValue instead
DynValue - Interface in org.omg.DynamicAny
DynValue objects support the manipulation of IDL non-boxed value types.
DynValueBox - Interface in org.omg.DynamicAny
DynValueBox objects support the manipulation of IDL boxed value types.
DynValueBoxOperations - Interface in org.omg.DynamicAny
DynValueBox objects support the manipulation of IDL boxed value types.
DynValueCommon - Interface in org.omg.DynamicAny
DynValueCommon provides operations supported by both the DynValue and DynValueBox interfaces.
DynValueCommonOperations - Interface in org.omg.DynamicAny
DynValueCommon provides operations supported by both the DynValue and DynValueBox interfaces.
DynValueHelper - Class in org.omg.DynamicAny
DynValue objects support the manipulation of IDL non-boxed value types.
DynValueHelper() - Constructor for class org.omg.DynamicAny.DynValueHelper
DynValueOperations - Interface in org.omg.DynamicAny
DynValue objects support the manipulation of IDL non-boxed value types.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames


E-Index (Java Platform SE 8 )

Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames
  • All Classes
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

E

E - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for Engineering E, 34 x 44 in.
E - Static variable in class java.lang.Math
The double value that is closer than any other to e, the base of the natural logarithms.
E - Static variable in class java.lang.StrictMath
The double value that is closer than any other to e, the base of the natural logarithms.
E - Static variable in class javax.print.attribute.standard.MediaSize.Engineering
Specifies the engineering E size, 34 inch by 44 inch.
E - Static variable in class javax.print.attribute.standard.MediaSizeName
E size .
E_RESIZE_CURSOR - Static variable in class java.awt.Cursor
The east-resize cursor type.
E_RESIZE_CURSOR - Static variable in class java.awt.Frame
Deprecated.
replaced by Cursor.E_RESIZE_CURSOR.
EAST - Static variable in class java.awt.BorderLayout
The east layout constraint (right side of container).
EAST - Static variable in class java.awt.GridBagConstraints
Put the component on the right side of its display area, centered vertically.
EAST - Static variable in class javax.swing.SpringLayout
Specifies the right edge of a component's bounding rectangle.
EAST - Static variable in interface javax.swing.SwingConstants
Compass-direction east (right).
EASTERN_ARABIC - Static variable in class java.awt.font.NumericShaper
Identifies the ARABIC range and ARABIC_EXTENDED decimal base.
eastPane - Variable in class javax.swing.plaf.basic.BasicInternalFrameUI
ECField - Interface in java.security.spec
This interface represents an elliptic curve (EC) finite field.
ECFieldF2m - Class in java.security.spec
This immutable class defines an elliptic curve (EC) characteristic 2 finite field.
ECFieldF2m(int) - Constructor for class java.security.spec.ECFieldF2m
Creates an elliptic curve characteristic 2 finite field which has 2^m elements with normal basis.
ECFieldF2m(int, BigInteger) - Constructor for class java.security.spec.ECFieldF2m
Creates an elliptic curve characteristic 2 finite field which has 2^m elements with polynomial basis.
ECFieldF2m(int, int[]) - Constructor for class java.security.spec.ECFieldF2m
Creates an elliptic curve characteristic 2 finite field which has 2^m elements with polynomial basis.
ECFieldFp - Class in java.security.spec
This immutable class defines an elliptic curve (EC) prime finite field.
ECFieldFp(BigInteger) - Constructor for class java.security.spec.ECFieldFp
Creates an elliptic curve prime finite field with the specified prime p.
ECGenParameterSpec - Class in java.security.spec
This immutable class specifies the set of parameters used for generating elliptic curve (EC) domain parameters.
ECGenParameterSpec(String) - Constructor for class java.security.spec.ECGenParameterSpec
Creates a parameter specification for EC parameter generation using a standard (or predefined) name stdName in order to generate the corresponding (precomputed) elliptic curve domain parameters.
echoCharIsSet() - Method in class java.awt.TextField
Indicates whether or not this text field has a character set for echoing.
echoCharIsSet() - Method in class javax.swing.JPasswordField
Returns true if this JPasswordField has a character set for echoing.
ECKey - Interface in java.security.interfaces
The interface to an elliptic curve (EC) key.
ECParameterSpec - Class in java.security.spec
This immutable class specifies the set of domain parameters used with elliptic curve cryptography (ECC).
ECParameterSpec(EllipticCurve, ECPoint, BigInteger, int) - Constructor for class java.security.spec.ECParameterSpec
Creates elliptic curve domain parameters based on the specified values.
ECPoint - Class in java.security.spec
This immutable class represents a point on an elliptic curve (EC) in affine coordinates.
ECPoint(BigInteger, BigInteger) - Constructor for class java.security.spec.ECPoint
Creates an ECPoint from the specified affine x-coordinate x and affine y-coordinate y.
ECPrivateKey - Interface in java.security.interfaces
The interface to an elliptic curve (EC) private key.
ECPrivateKeySpec - Class in java.security.spec
This immutable class specifies an elliptic curve private key with its associated parameters.
ECPrivateKeySpec(BigInteger, ECParameterSpec) - Constructor for class java.security.spec.ECPrivateKeySpec
Creates a new ECPrivateKeySpec with the specified parameter values.
ECPublicKey - Interface in java.security.interfaces
The interface to an elliptic curve (EC) public key.
ECPublicKeySpec - Class in java.security.spec
This immutable class specifies an elliptic curve public key with its associated parameters.
ECPublicKeySpec(ECPoint, ECParameterSpec) - Constructor for class java.security.spec.ECPublicKeySpec
Creates a new ECPublicKeySpec with the specified parameter values.
EDGE_NO_OP - Static variable in class java.awt.image.ConvolveOp
Pixels at the edge of the source image are copied to the corresponding pixels in the destination without modification.
EDGE_SPACING - Static variable in class javax.swing.border.TitledBorder
EDGE_STITCH - Static variable in class javax.print.attribute.standard.Finishings
Bind the document(s) with one or more staples (wire stitches) along one edge.
EDGE_STITCH_BOTTOM - Static variable in class javax.print.attribute.standard.Finishings
Bind the document(s) with one or more staples (wire stitches) along the bottom edge.
EDGE_STITCH_LEFT - Static variable in class javax.print.attribute.standard.Finishings
Bind the document(s) with one or more staples (wire stitches) along the left edge.
EDGE_STITCH_RIGHT - Static variable in class javax.print.attribute.standard.Finishings
Bind the document(s) with one or more staples (wire stitches) along the right edge.
EDGE_STITCH_TOP - Static variable in class javax.print.attribute.standard.Finishings
Bind the document(s) with one or more staples (wire stitches) along the top edge.
EDGE_ZERO_FILL - Static variable in class java.awt.image.ConvolveOp
Pixels at the edge of the destination image are set to zero.
edit(File) - Method in class java.awt.Desktop
Launches the associated editor application and opens a file for editing.
EDITABLE - Static variable in class javax.accessibility.AccessibleState
Indicates the user can change the contents of this object.
editable - Variable in class javax.swing.JTree
Is the tree editable? Default is false.
EDITABLE_PROPERTY - Static variable in class javax.swing.JTree
Bound property name for editable.
editablePropertyChanged(PropertyChangeEvent) - Method in class javax.swing.plaf.metal.MetalComboBoxUI
Deprecated.
As of Java 2 platform v1.4.
EDITBAR - Static variable in class javax.accessibility.AccessibleRole
A role indicating the object acts as a formula for calculating a value.
editCellAt(int, int) - Method in class javax.swing.JTable
Programmatically starts editing the cell at row and column, if those indices are in the valid range, and the cell at those indices is editable.
editCellAt(int, int, EventObject) - Method in class javax.swing.JTable
Programmatically starts editing the cell at row and column, if those indices are in the valid range, and the cell at those indices is editable.
editingCanceled(ChangeEvent) - Method in interface javax.swing.event.CellEditorListener
This tells the listeners the editor has canceled editing
editingCanceled(ChangeEvent) - Method in class javax.swing.JTable.AccessibleJTable
Invoked when editing is canceled.
editingCanceled(ChangeEvent) - Method in class javax.swing.JTable
Invoked when editing is canceled.
editingCanceled(ChangeEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.CellEditorHandler
Messaged when editing has been canceled in the tree.
editingColumn - Variable in class javax.swing.JTable
Identifies the column of the cell being edited.
editingComponent - Variable in class javax.swing.plaf.basic.BasicTreeUI
When editing, this will be the Component that is doing the actual editing.
editingComponent - Variable in class javax.swing.tree.DefaultTreeCellEditor
Component used in editing, obtained from the editingContainer.
editingContainer - Variable in class javax.swing.tree.DefaultTreeCellEditor
Editing container, will contain the editorComponent.
editingIcon - Variable in class javax.swing.tree.DefaultTreeCellEditor
Icon to use when editing.
editingPath - Variable in class javax.swing.plaf.basic.BasicTreeUI
Path that is being edited.
editingRow - Variable in class javax.swing.JTable
Identifies the row of the cell being edited.
editingRow - Variable in class javax.swing.plaf.basic.BasicTreeUI
Row that is being edited.
editingStopped(ChangeEvent) - Method in interface javax.swing.event.CellEditorListener
This tells the listeners the editor has ended editing
editingStopped(ChangeEvent) - Method in class javax.swing.JTable.AccessibleJTable
Track changes to a cell's contents.
editingStopped(ChangeEvent) - Method in class javax.swing.JTable
Invoked when editing is finished.
editingStopped(ChangeEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.CellEditorHandler
Messaged when editing has stopped in the tree.
editor - Variable in class javax.swing.JComboBox
This protected field is implementation specific.
editor - Variable in class javax.swing.plaf.basic.BasicComboBoxEditor
editor - Variable in class javax.swing.plaf.basic.BasicComboBoxUI
EDITOR_PANE - Static variable in class javax.swing.plaf.synth.Region
EditorPane region.
editorBorderInsets - Variable in class javax.swing.plaf.metal.MetalBorders.TableHeaderBorder
editorBorderInsets - Static variable in class javax.swing.plaf.metal.MetalComboBoxEditor
The default editor border Insets.
editorComp - Variable in class javax.swing.JTable
If editing, the Component that is handling the editing.
editorComponent - Variable in class javax.swing.DefaultCellEditor
The Swing component being edited.
EditorContainer() - Constructor for class javax.swing.tree.DefaultTreeCellEditor.EditorContainer
Constructs an EditorContainer object.
EditorContainer() - Method in class javax.swing.tree.DefaultTreeCellEditor.EditorContainer
EditorDelegate() - Constructor for class javax.swing.DefaultCellEditor.EditorDelegate
editorHasDifferentSize - Variable in class javax.swing.plaf.basic.BasicTreeUI
Set to true if the editor has a different size than the renderer.
EditorKit - Class in javax.swing.text
Establishes the set of things needed by a text component to be a reasonably functioning editor for some type of text content.
EditorKit() - Constructor for class javax.swing.text.EditorKit
Construct an EditorKit.
edits - Variable in class javax.swing.undo.CompoundEdit
The collection of UndoableEdits undone/redone en masse by this CompoundEdit.
editToBeRedone() - Method in class javax.swing.undo.UndoManager
Returns the the next significant edit to be redone if redo is invoked.
editToBeUndone() - Method in class javax.swing.undo.UndoManager
Returns the the next significant edit to be undone if undo is invoked.
effective_profile() - Method in interface org.omg.PortableInterceptor.ClientRequestInfoOperations
Returns the profile that will be used to send the request.
effective_target() - Method in interface org.omg.PortableInterceptor.ClientRequestInfoOperations
Returns the actual object on which the operation will be invoked.
EFFORT - Static variable in interface java.util.jar.Pack200.Packer
If this property is set to a single decimal digit, the packer will use the indicated amount of effort in compressing the archive.
EGYPTIAN_HIEROGLYPHS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Egyptian Hieroglyphs" Unicode character block.
element() - Method in exception java.lang.annotation.AnnotationTypeMismatchException
Returns the Method object for the incorrectly typed element.
element() - Method in class java.util.AbstractQueue
Retrieves, but does not remove, the head of this queue.
element() - Method in class java.util.ArrayDeque
Retrieves, but does not remove, the head of the queue represented by this deque.
element() - Method in interface java.util.concurrent.BlockingDeque
Retrieves, but does not remove, the head of the queue represented by this deque (in other words, the first element of this deque).
element() - Method in class java.util.concurrent.ConcurrentLinkedDeque
element() - Method in class java.util.concurrent.LinkedBlockingDeque
Retrieves, but does not remove, the head of the queue represented by this deque.
element() - Method in interface java.util.Deque
Retrieves, but does not remove, the head of the queue represented by this deque (in other words, the first element of this deque).
element() - Method in class java.util.LinkedList
Retrieves, but does not remove, the head (first element) of this list.
element() - Method in interface java.util.Queue
Retrieves, but does not remove, the head of this queue.
Element - Interface in javax.lang.model.element
Represents a program element such as a package, class, or method.
element - Variable in class javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit
Element - Interface in javax.swing.text
Interface to describe a structural piece of a document.
Element - Class in javax.swing.text.html.parser
An element as described in a DTD using the ELEMENT construct.
Element - Interface in javax.xml.bind
This is an element marker interface.
element(Element) - Method in class javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder
Adds an extension element to the W3CEndpointReference instance's wsa:EndpointReference element.
Element - Interface in org.w3c.dom
The Element interface represents an element in an HTML or XML document.
ELEMENT_NODE - Static variable in interface org.w3c.dom.Node
The node is an Element.
elementAt(int) - Method in class java.util.Vector
Returns the component at the specified index.
elementAt(int) - Method in class javax.swing.DefaultListModel
Returns the component at the specified index.
ElementBuffer(Element) - Constructor for class javax.swing.text.DefaultStyledDocument.ElementBuffer
Creates a new ElementBuffer.
elementCount - Variable in class java.util.Vector
The number of valid components in this Vector object.
elementCount - Variable in class javax.management.monitor.Monitor
The number of valid components in the vector of observed objects.
elementCountToTag(HTMLDocument, int, HTML.Tag) - Method in class javax.swing.text.html.HTMLEditorKit.HTMLTextAction
Returns number of elements, starting at the deepest leaf, needed to get to an element representing tag.
elementData - Variable in class java.util.Vector
The array buffer into which the components of the vector are stored.
elementDecl(String, String) - Method in interface org.xml.sax.ext.DeclHandler
Report an element type declaration.
elementDecl(String, String) - Method in class org.xml.sax.ext.DefaultHandler2
ElementEdit(Element, int, Element[], Element[]) - Constructor for class javax.swing.text.AbstractDocument.ElementEdit
Constructs an edit record.
ElementFilter - Class in javax.lang.model.util
Filters for selecting just the elements of interest from a collection of elements.
elementHash - Variable in class javax.swing.text.html.parser.DTD
ElementIterator - Class in javax.swing.text
ElementIterator, as the name suggests, iterates over the Element tree.
ElementIterator(Document) - Constructor for class javax.swing.text.ElementIterator
Creates a new ElementIterator.
ElementIterator(Element) - Constructor for class javax.swing.text.ElementIterator
Creates a new ElementIterator.
ElementKind - Enum in javax.lang.model.element
The kind of an element.
ElementKindVisitor6<R,P> - Class in javax.lang.model.util
A visitor of program elements based on their kind with default behavior appropriate for the RELEASE_6 source version.
ElementKindVisitor6() - Constructor for class javax.lang.model.util.ElementKindVisitor6
Constructor for concrete subclasses; uses null for the default value.
ElementKindVisitor6(R) - Constructor for class javax.lang.model.util.ElementKindVisitor6
Constructor for concrete subclasses; uses the argument for the default value.
ElementKindVisitor7<R,P> - Class in javax.lang.model.util
A visitor of program elements based on their kind with default behavior appropriate for the RELEASE_7 source version.
ElementKindVisitor7() - Constructor for class javax.lang.model.util.ElementKindVisitor7
Constructor for concrete subclasses; uses null for the default value.
ElementKindVisitor7(R) - Constructor for class javax.lang.model.util.ElementKindVisitor7
Constructor for concrete subclasses; uses the argument for the default value.
ElementKindVisitor8<R,P> - Class in javax.lang.model.util
A visitor of program elements based on their kind with default behavior appropriate for the RELEASE_8 source version.
ElementKindVisitor8() - Constructor for class javax.lang.model.util.ElementKindVisitor8
Constructor for concrete subclasses; uses null for the default value.
ElementKindVisitor8(R) - Constructor for class javax.lang.model.util.ElementKindVisitor8
Constructor for concrete subclasses; uses the argument for the default value.
elementName() - Method in exception java.lang.annotation.IncompleteAnnotationException
Returns the name of the missing element.
ElementNameAttribute - Static variable in class javax.swing.text.AbstractDocument
Name of the attribute used to specify element names.
elements() - Method in class java.security.PermissionCollection
Returns an enumeration of all the Permission objects in the collection.
elements() - Method in class java.security.Permissions
Returns an enumeration of all the Permission objects in all the PermissionCollections in this Permissions object.
elements() - Method in class java.security.Provider
elements() - Method in class java.util.concurrent.ConcurrentHashMap
Returns an enumeration of the values in this table.
elements() - Method in class java.util.Dictionary
Returns an enumeration of the values in this dictionary.
elements() - Method in class java.util.Hashtable
Returns an enumeration of the values in this hashtable.
elements() - Method in class java.util.Vector
Returns an enumeration of the components of this vector.
Elements - Interface in javax.lang.model.util
Utility methods for operating on program elements.
elements() - Method in class javax.swing.DefaultListModel
Returns an enumeration of the components of this list.
elements - Variable in class javax.swing.text.html.parser.DTD
ElementScanner6<R,P> - Class in javax.lang.model.util
A scanning visitor of program elements with default behavior appropriate for the RELEASE_6 source version.
ElementScanner6() - Constructor for class javax.lang.model.util.ElementScanner6
Constructor for concrete subclasses; uses null for the default value.
ElementScanner6(R) - Constructor for class javax.lang.model.util.ElementScanner6
Constructor for concrete subclasses; uses the argument for the default value.
ElementScanner7<R,P> - Class in javax.lang.model.util
A scanning visitor of program elements with default behavior appropriate for the RELEASE_7 source version.
ElementScanner7() - Constructor for class javax.lang.model.util.ElementScanner7
Constructor for concrete subclasses; uses null for the default value.
ElementScanner7(R) - Constructor for class javax.lang.model.util.ElementScanner7
Constructor for concrete subclasses; uses the argument for the default value.
ElementScanner8<R,P> - Class in javax.lang.model.util
A scanning visitor of program elements with default behavior appropriate for the RELEASE_8 source version.
ElementScanner8() - Constructor for class javax.lang.model.util.ElementScanner8
Constructor for concrete subclasses; uses null for the default value.
ElementScanner8(R) - Constructor for class javax.lang.model.util.ElementScanner8
Constructor for concrete subclasses; uses the argument for the default value.
ElementSpec(AttributeSet, short) - Constructor for class javax.swing.text.DefaultStyledDocument.ElementSpec
Constructor useful for markup when the markup will not be stored in the document.
ElementSpec(AttributeSet, short, int) - Constructor for class javax.swing.text.DefaultStyledDocument.ElementSpec
Constructor for parsing inside the document when the data has already been added, but len information is needed.
ElementSpec(AttributeSet, short, char[], int, int) - Constructor for class javax.swing.text.DefaultStyledDocument.ElementSpec
Constructor for creating a spec externally for batch input of content and markup into the document.
ElementType - Enum in java.lang.annotation
The constants of this enumerated type provide a simple classification of the syntactic locations where annotations may appear in a Java program.
ElementVisitor<R,P> - Interface in javax.lang.model.element
A visitor of program elements, in the style of the visitor design pattern.
Ellipse2D - Class in java.awt.geom
The Ellipse2D class describes an ellipse that is defined by a framing rectangle.
Ellipse2D() - Constructor for class java.awt.geom.Ellipse2D
This is an abstract class that cannot be instantiated directly.
Ellipse2D.Double - Class in java.awt.geom
The Double class defines an ellipse specified in double precision.
Ellipse2D.Float - Class in java.awt.geom
The Float class defines an ellipse specified in float precision.
EllipticCurve - Class in java.security.spec
This immutable class holds the necessary values needed to represent an elliptic curve.
EllipticCurve(ECField, BigInteger, BigInteger) - Constructor for class java.security.spec.EllipticCurve
Creates an elliptic curve with the specified elliptic field field and the coefficients a and b.
EllipticCurve(ECField, BigInteger, BigInteger, byte[]) - Constructor for class java.security.spec.EllipticCurve
Creates an elliptic curve with the specified elliptic field field, the coefficients a and b, and the seed used for curve generation.
EM - Static variable in class javax.swing.text.html.HTML.Tag
EMBEDDED_BY - Static variable in class javax.accessibility.AccessibleRelation
Indicates that an object is embedded in one or more objects.
EMBEDDED_BY_PROPERTY - Static variable in class javax.accessibility.AccessibleRelation
Indicates the EMBEDDED_BY relation between two or more objects has changed.
EMBEDS - Static variable in class javax.accessibility.AccessibleRelation
Indicates that an object has one or more objects embedded in it.
EMBEDS_PROPERTY - Static variable in class javax.accessibility.AccessibleRelation
Indicates the EMBEDS relation between two or more objects has changed.
EMOTICONS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Emoticons" Unicode character block.
empty() - Static method in class java.util.Optional
Returns an empty Optional instance.
empty() - Static method in class java.util.OptionalDouble
Returns an empty OptionalDouble instance.
empty() - Static method in class java.util.OptionalInt
Returns an empty OptionalInt instance.
empty() - Static method in class java.util.OptionalLong
Returns an empty OptionalLong instance.
empty() - Method in class java.util.Stack
Tests if this stack is empty.
empty() - Static method in interface java.util.stream.DoubleStream
Returns an empty sequential DoubleStream.
empty() - Static method in interface java.util.stream.IntStream
Returns an empty sequential IntStream.
empty() - Static method in interface java.util.stream.LongStream
Returns an empty sequential LongStream.
empty() - Static method in interface java.util.stream.Stream
Returns an empty sequential Stream.
empty() - Method in class javax.swing.text.html.parser.ContentModel
Return true if the content model could match an empty input stream.
EMPTY - Static variable in interface javax.swing.text.html.parser.DTDConstants
EMPTY - Static variable in class javax.swing.text.SimpleAttributeSet
An empty attribute set.
EMPTY_DESCRIPTOR - Static variable in class javax.management.ImmutableDescriptor
An empty descriptor.
EMPTY_ENUMERATION - Static variable in class javax.swing.tree.DefaultMutableTreeNode
An enumeration that is always empty.
EMPTY_LIST - Static variable in class java.util.Collections
The empty list (immutable).
EMPTY_MAP - Static variable in class java.util.Collections
The empty map (immutable).
EMPTY_SET - Static variable in class java.util.Collections
The empty set (immutable).
EmptyBorder - Class in javax.swing.border
A class which provides an empty, transparent border which takes up space but does no drawing.
EmptyBorder(int, int, int, int) - Constructor for class javax.swing.border.EmptyBorder
Creates an empty border with the specified insets.
EmptyBorder(Insets) - Constructor for class javax.swing.border.EmptyBorder
Creates an empty border with the specified insets.
EmptyBorderUIResource(int, int, int, int) - Constructor for class javax.swing.plaf.BorderUIResource.EmptyBorderUIResource
EmptyBorderUIResource(Insets) - Constructor for class javax.swing.plaf.BorderUIResource.EmptyBorderUIResource
emptyDoubleSpliterator() - Static method in class java.util.Spliterators
Creates an empty Spliterator.OfDouble
emptyEnumeration() - Static method in class java.util.Collections
Returns an enumeration that has no elements.
emptyIntSpliterator() - Static method in class java.util.Spliterators
Creates an empty Spliterator.OfInt
emptyIterator() - Static method in class java.util.Collections
Returns an iterator that has no elements.
emptyList() - Static method in class java.util.Collections
Returns an empty list (immutable).
emptyListIterator() - Static method in class java.util.Collections
Returns a list iterator that has no elements.
emptyLongSpliterator() - Static method in class java.util.Spliterators
Creates an empty Spliterator.OfLong
emptyMap() - Static method in class java.util.Collections
Returns an empty map (immutable).
emptyNavigableMap() - Static method in class java.util.Collections
Returns an empty navigable map (immutable).
emptyNavigableSet() - Static method in class java.util.Collections
Returns an empty navigable set (immutable).
EmptySelectionModel() - Constructor for class javax.swing.JTree.EmptySelectionModel
emptySet() - Static method in class java.util.Collections
Returns an empty set (immutable).
emptySortedMap() - Static method in class java.util.Collections
Returns an empty sorted map (immutable).
emptySortedSet() - Static method in class java.util.Collections
Returns an empty sorted set (immutable).
emptySpliterator() - Static method in class java.util.Spliterators
Creates an empty Spliterator
EmptyStackException - Exception in java.util
Thrown by methods in the Stack class to indicate that the stack is empty.
EmptyStackException() - Constructor for exception java.util.EmptyStackException
Constructs a new EmptyStackException with null as its error message string.
emptyTag(Element) - Method in class javax.swing.text.html.HTMLWriter
Writes out all empty elements (all tags that have no corresponding end tag).
enable() - Method in class java.awt.Component
Deprecated.
As of JDK version 1.1, replaced by setEnabled(boolean).
enable(boolean) - Method in class java.awt.Component
Deprecated.
As of JDK version 1.1, replaced by setEnabled(boolean).
enable() - Method in class java.awt.MenuItem
Deprecated.
As of JDK version 1.1, replaced by setEnabled(boolean).
enable(boolean) - Method in class java.awt.MenuItem
Deprecated.
As of JDK version 1.1, replaced by setEnabled(boolean).
enable() - Static method in class java.lang.Compiler
Cause the Compiler to resume operation.
enable() - Method in class javax.swing.JComponent
Deprecated.
As of JDK version 1.1, replaced by java.awt.Component.setEnabled(boolean).
enableActions() - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
enableAllObjectNames() - Method in class javax.management.relation.MBeanServerNotificationFilter
Enables all MBeanServerNotifications (all ObjectNames are selected).
enableAttribute(String) - Method in class javax.management.AttributeChangeNotificationFilter
Enables all the attribute change notifications the attribute name of which equals the specified name to be sent to the listener.
enableClientWindowNotification(InputMethod, boolean) - Method in interface java.awt.im.spi.InputMethodContext
Enables or disables notification of the current client window's location and state for the specified input method.
ENABLED - Static variable in class javax.accessibility.AccessibleState
Indicates this object is enabled.
enabled - Variable in class javax.swing.AbstractAction
Specifies whether action is enabled; the default is true.
ENABLED - Static variable in class javax.swing.DefaultButtonModel
Identifies the "enabled" bit in the bitmask, which indicates that the button can be selected by an input device (such as a mouse pointer).
ENABLED - Static variable in interface javax.swing.plaf.synth.SynthConstants
Primary state indicating the component is enabled.
enabled - Variable in class javax.xml.ws.WebServiceFeature
Specifies if the feature is enabled or disabled
enableEvents(long) - Method in class java.awt.Component
Enables the events defined by the specified event mask parameter to be delivered to this component.
enableEvents(long) - Method in class java.awt.MenuItem
Enables event delivery to this menu item for events to be defined by the specified event mask parameter
enableInputMethods(boolean) - Method in class java.awt.Component
Enables or disables input method support for this component.
enableInputMethods(boolean) - Method in class java.awt.TextComponent
Enables or disables input method support for this text component.
enableObjectName(ObjectName) - Method in class javax.management.relation.MBeanServerNotificationFilter
Enables MBeanServerNotifications concerning given ObjectName.
enableReplaceObject(boolean) - Method in class java.io.ObjectOutputStream
Enable the stream to do replacement of objects in the stream.
enableResizedPosting() - Method in class javax.swing.table.TableColumn
Deprecated.
as of Java 2 platform v1.3
enableResolveObject(boolean) - Method in class java.io.ObjectInputStream
Enable the stream to allow objects read from the stream to be replaced.
enableType(String) - Method in class javax.management.NotificationFilterSupport
Enables all the notifications the type of which starts with the specified prefix to be sent to the listener.
ENCLOSED_ALPHANUMERIC_SUPPLEMENT - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Enclosed Alphanumeric Supplement" Unicode character block.
ENCLOSED_ALPHANUMERICS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Enclosed Alphanumerics" Unicode character block.
ENCLOSED_CJK_LETTERS_AND_MONTHS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Enclosed CJK Letters and Months" Unicode character block.
ENCLOSED_IDEOGRAPHIC_SUPPLEMENT - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Enclosed Ideographic Supplement" Unicode character block.
ENCLOSING_MARK - Static variable in class java.lang.Character
General category "Me" in the Unicode specification.
encode(String) - Static method in class java.net.URLEncoder
Deprecated.
The resulting string may vary depending on the platform's default encoding. Instead, use the encode(String,String) method to specify the encoding.
encode(String, String) - Static method in class java.net.URLEncoder
Translates a string into application/x-www-form-urlencoded format using a specific encoding scheme.
encode(CharBuffer) - Method in class java.nio.charset.Charset
Convenience method that encodes Unicode characters into bytes in this charset.
encode(String) - Method in class java.nio.charset.Charset
Convenience method that encodes a string into bytes in this charset.
encode(CharBuffer, ByteBuffer, boolean) - Method in class java.nio.charset.CharsetEncoder
Encodes as many characters as possible from the given input buffer, writing the results to the given output buffer.
encode(CharBuffer) - Method in class java.nio.charset.CharsetEncoder
Convenience method that encodes the remaining content of a single input character buffer into a newly-allocated byte buffer.
encode(OutputStream) - Method in interface java.security.cert.Extension
Generates the extension's DER encoding and writes it to the output stream.
encode(OutputStream) - Method in interface java.security.Certificate
Deprecated.
Encodes the certificate to an output stream in a format that can be decoded by the decode method.
encode(byte[]) - Method in class java.util.Base64.Encoder
Encodes all bytes from the specified byte array into a newly-allocated byte array using the Base64 encoding scheme.
encode(byte[], byte[]) - Method in class java.util.Base64.Encoder
Encodes all bytes from the specified byte array using the Base64 encoding scheme, writing the resulting bytes to the given output byte array, starting at offset 0.
encode(ByteBuffer) - Method in class java.util.Base64.Encoder
Encodes all remaining bytes from the specified byte buffer into a newly-allocated ByteBuffer using the Base64 encoding scheme.
encode(Any) - Method in interface org.omg.IOP.CodecOperations
Converts the given any into a byte array based on the encoding format effective for this Codec.
encode_value(Any) - Method in interface org.omg.IOP.CodecOperations
Converts the given any into a byte array based on the encoding format effective for this Codec.
encodeDataFlavor(DataFlavor) - Static method in class java.awt.datatransfer.SystemFlavorMap
Encodes a DataFlavor for use as a String native.
EncodedKeySpec - Class in java.security.spec
This class represents a public or private key in encoded format.
EncodedKeySpec(byte[]) - Constructor for class java.security.spec.EncodedKeySpec
Creates a new EncodedKeySpec with the given encoded key.
encodedParams - Variable in class javax.crypto.SealedObject
The cryptographic parameters used by the sealing Cipher, encoded in the default format.
encodeJavaMIMEType(String) - Static method in class java.awt.datatransfer.SystemFlavorMap
Encodes a MIME type for use as a String native.
encodeLoop(CharBuffer, ByteBuffer) - Method in class java.nio.charset.CharsetEncoder
Encodes one or more characters into one or more bytes.
Encoder - Class in java.beans
An Encoder is a class which can be used to create files or streams that encode the state of a collection of JavaBeans in terms of their public APIs.
Encoder() - Constructor for class java.beans.Encoder
encodeToString(byte[]) - Method in class java.util.Base64.Encoder
Encodes the specified byte array into a String using the Base64 encoding scheme.
encoding - Variable in class javax.sound.sampled.AudioFormat
The audio encoding technique used by this format.
Encoding(String) - Constructor for class javax.sound.sampled.AudioFormat.Encoding
Constructs a new encoding.
ENCODING - Static variable in class javax.xml.transform.OutputKeys
encoding = string.
Encoding - Class in org.omg.IOP
org/omg/IOP/Encoding.java .
Encoding() - Constructor for class org.omg.IOP.Encoding
Encoding(short, byte, byte) - Constructor for class org.omg.IOP.Encoding
ENCODING_CDR_ENCAPS - Interface in org.omg.IOP
org/omg/IOP/ENCODING_CDR_ENCAPS.java .
encodingSet() - Method in interface javax.xml.stream.events.StartDocument
Returns true if CharacterEncodingScheme was set in the encoding declaration of the document
ENCRYPT - Static variable in class javax.xml.crypto.KeySelector.Purpose
A key for encrypting.
ENCRYPT_MODE - Static variable in class javax.crypto.Cipher
Constant used to initialize cipher to encryption mode.
EncryptedPrivateKeyInfo - Class in javax.crypto
This class implements the EncryptedPrivateKeyInfo type as defined in PKCS #8.
EncryptedPrivateKeyInfo(byte[]) - Constructor for class javax.crypto.EncryptedPrivateKeyInfo
Constructs (i.e., parses) an EncryptedPrivateKeyInfo from its ASN.1 encoding.
EncryptedPrivateKeyInfo(String, byte[]) - Constructor for class javax.crypto.EncryptedPrivateKeyInfo
Constructs an EncryptedPrivateKeyInfo from the encryption algorithm name and the encrypted data.
EncryptedPrivateKeyInfo(AlgorithmParameters, byte[]) - Constructor for class javax.crypto.EncryptedPrivateKeyInfo
Constructs an EncryptedPrivateKeyInfo from the encryption algorithm parameters and the encrypted data.
ENCTYPE - Static variable in class javax.swing.text.html.HTML.Attribute
END - Static variable in class java.awt.Event
The End key, a non-ASCII action key.
end() - Method in class java.awt.PrintJob
Ends the print job and does any necessary cleanup.
end(boolean) - Method in class java.nio.channels.spi.AbstractInterruptibleChannel
Marks the end of an I/O operation that might block indefinitely.
end() - Method in class java.nio.channels.spi.AbstractSelector
Marks the end of an I/O operation that might block indefinitely.
end() - Method in class java.util.regex.Matcher
Returns the offset after the last character matched.
end(int) - Method in class java.util.regex.Matcher
Returns the offset after the last character of the subsequence captured by the given group during the previous match operation.
end(String) - Method in class java.util.regex.Matcher
Returns the offset after the last character of the subsequence captured by the given named-capturing group during the previous match operation.
end() - Method in interface java.util.regex.MatchResult
Returns the offset after the last character matched.
end(int) - Method in interface java.util.regex.MatchResult
Returns the offset after the last character of the subsequence captured by the given group during this match.
end() - Method in class java.util.zip.Deflater
Closes the compressor and discards any unprocessed input.
end() - Method in class java.util.zip.Inflater
Closes the decompressor and discards any unprocessed input.
end(HTML.Tag) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader.BlockAction
end(HTML.Tag) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader.CharacterAction
end(HTML.Tag) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader.FormAction
end(HTML.Tag) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader.HiddenAction
end(HTML.Tag) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader.ParagraphAction
end(HTML.Tag) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader.PreAction
end(HTML.Tag) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
Called when an end tag is seen for the type of tag this action was registered to.
end() - Method in class javax.swing.undo.CompoundEdit
Sets inProgress to false.
end() - Method in class javax.swing.undo.StateEdit
Gets the post-edit state of the StateEditable object and ends the edit.
end() - Method in class javax.swing.undo.UndoManager
Turns this UndoManager into a normal CompoundEdit.
end(Xid, int) - Method in interface javax.transaction.xa.XAResource
Ends the work performed on behalf of a transaction branch.
END_DOCUMENT - Static variable in interface javax.xml.stream.XMLStreamConstants
Indicates an event is an end document
END_ELEMENT - Static variable in interface javax.xml.stream.XMLStreamConstants
Indicates an event is an end element
END_OF_EXCLUSIVE - Static variable in class javax.sound.midi.ShortMessage
Status byte for End of System Exclusive message (0xF7, or 247).
END_PUNCTUATION - Static variable in class java.lang.Character
General category "Pe" in the Unicode specification.
end_value() - Method in interface org.omg.CORBA.portable.ValueInputStream
The end_value method reads the end tag for the nested custom valuetype (after skipping any data that precedes the end tag) and decrements the valuetype nesting depth.
end_value() - Method in interface org.omg.CORBA.portable.ValueOutputStream
The end_value method ends any currently open chunk, writes the end tag for the nested custom valuetype, and decrements the valuetype nesting depth.
endAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the Action for moving the caret to the end of the document.
endCDATA() - Method in class org.xml.sax.ext.DefaultHandler2
endCDATA() - Method in interface org.xml.sax.ext.LexicalHandler
Report the end of a CDATA section.
endComposition() - Method in class java.awt.im.InputContext
Ends any input composition that may currently be going on in this context.
endComposition() - Method in interface java.awt.im.spi.InputMethod
Ends any input composition that may currently be going on in this context.
EndDocument - Interface in javax.xml.stream.events
A marker interface for the end of the document
endDocument() - Method in interface org.xml.sax.ContentHandler
Receive notification of the end of a document.
endDocument() - Method in interface org.xml.sax.DocumentHandler
Deprecated.
Receive notification of the end of a document.
endDocument() - Method in class org.xml.sax.HandlerBase
Deprecated.
Receive notification of the end of the document.
endDocument() - Method in class org.xml.sax.helpers.DefaultHandler
Receive notification of the end of the document.
endDocument() - Method in class org.xml.sax.helpers.ParserAdapter
Adapter implementation method; do not call.
endDocument() - Method in class org.xml.sax.helpers.XMLFilterImpl
Filter an end document event.
endDocument() - Method in class org.xml.sax.helpers.XMLReaderAdapter
End document event.
endDraggingFrame(JComponent) - Method in class javax.swing.DefaultDesktopManager
endDraggingFrame(JComponent) - Method in interface javax.swing.DesktopManager
This method signals the end of the dragging session.
endDTD() - Method in class org.xml.sax.ext.DefaultHandler2
endDTD() - Method in interface org.xml.sax.ext.LexicalHandler
Report the end of DTD declarations.
EndElement - Interface in javax.xml.stream.events
An interface for the end element event.
endElement(String, String, String) - Method in interface org.xml.sax.ContentHandler
Receive notification of the end of an element.
endElement(String) - Method in interface org.xml.sax.DocumentHandler
Deprecated.
Receive notification of the end of an element.
endElement(String) - Method in class org.xml.sax.HandlerBase
Deprecated.
Receive notification of the end of an element.
endElement(String, String, String) - Method in class org.xml.sax.helpers.DefaultHandler
Receive notification of the end of an element.
endElement(String) - Method in class org.xml.sax.helpers.ParserAdapter
Adapter implementation method; do not call.
endElement(String, String, String) - Method in class org.xml.sax.helpers.XMLFilterImpl
Filter an end element event.
endElement(String, String, String) - Method in class org.xml.sax.helpers.XMLReaderAdapter
Adapt a SAX2 end element event.
endEntity(String) - Method in class org.xml.sax.ext.DefaultHandler2
endEntity(String) - Method in interface org.xml.sax.ext.LexicalHandler
Report the end of an entity.
endFontTag() - Method in class javax.swing.text.html.MinimalHTMLWriter
This is no longer used, instead <span> will be written out.
endIndex - Variable in class javax.accessibility.AccessibleAttributeSequence
The end index of the text sequence
endIndex - Variable in class javax.accessibility.AccessibleTextSequence
The end index of the text sequence
endInsertEmpty() - Method in class javax.imageio.ImageWriter
Completes the insertion of a new image that was begun with a prior call to prepareInsertEmpty.
endKey - Variable in class javax.swing.plaf.basic.BasicSplitPaneUI
Deprecated.
As of Java 2 platform v1.3.
endLineAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the Action for moving the caret to the end of a line.
EndOfLineStringProperty - Static variable in class javax.swing.text.DefaultEditorKit
When reading a document if a CRLF is encountered a property with this name is added and the value will be "\r\n".
endParagraphAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the Action for moving the caret to the end of a paragraph.
Endpoint - Class in javax.xml.ws
A Web service endpoint.
Endpoint() - Constructor for class javax.xml.ws.Endpoint
ENDPOINT_ADDRESS_PROPERTY - Static variable in interface javax.xml.ws.BindingProvider
Standard property: Target service endpoint address.
EndpointContext - Class in javax.xml.ws
EndpointContext allows multiple endpoints in an application to share any information.
EndpointContext() - Constructor for class javax.xml.ws.EndpointContext
endpointName(QName) - Method in class javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder
Sets the endpointName as wsam:ServiceName/@EndpointName in the wsa:Metadata element.
EndpointReference - Class in javax.xml.ws
This class represents an WS-Addressing EndpointReference which is a remote reference to a web service endpoint.
EndpointReference() - Constructor for class javax.xml.ws.EndpointReference
endPrefixMapping(String) - Method in interface org.xml.sax.ContentHandler
End the scope of a prefix-URI mapping.
endPrefixMapping(String) - Method in class org.xml.sax.helpers.DefaultHandler
Receive notification of the end of a Namespace mapping.
endPrefixMapping(String) - Method in class org.xml.sax.helpers.XMLFilterImpl
Filter an end Namespace prefix mapping event.
endPrefixMapping(String) - Method in class org.xml.sax.helpers.XMLReaderAdapter
Adapt a SAX2 end prefix mapping event.
endReplacePixels() - Method in class javax.imageio.ImageWriter
Terminates a sequence of calls to replacePixels.
endResizingFrame(JComponent) - Method in class javax.swing.DefaultDesktopManager
endResizingFrame(JComponent) - Method in interface javax.swing.DesktopManager
This method signals the end of the resize session.
endsWith(String) - Method in class java.lang.String
Tests if this string ends with the specified suffix.
endsWith(Path) - Method in interface java.nio.file.Path
Tests if this path ends with the given path.
endsWith(String) - Method in interface java.nio.file.Path
Tests if this path ends with a Path, constructed by converting the given path string, in exactly the manner specified by the endsWith(Path) method.
endsWith(Name) - Method in class javax.naming.CompositeName
Determines whether a composite name is a suffix of this composite name.
endsWith(Name) - Method in class javax.naming.CompoundName
Determines whether a compound name is a suffix of this compound name.
endsWith(Name) - Method in class javax.naming.ldap.LdapName
Determines whether this LDAP name ends with a specified LDAP name suffix.
endsWith(List<Rdn>) - Method in class javax.naming.ldap.LdapName
Determines whether the specified RDN sequence forms a suffix of this LDAP name.
endsWith(Name) - Method in interface javax.naming.Name
Determines whether this name ends with a specified suffix.
ENDTAG - Static variable in class javax.swing.text.html.HTML.Attribute
endTag(Element) - Method in class javax.swing.text.html.HTMLWriter
Writes out an end tag for the element.
ENDTAG - Static variable in interface javax.swing.text.html.parser.DTDConstants
endTag(boolean) - Method in class javax.swing.text.html.parser.Parser
Handle an end tag.
EndTagType - Static variable in class javax.swing.text.DefaultStyledDocument.ElementSpec
A possible value for getType.
endUpdate() - Method in class javax.swing.undo.UndoableEditSupport
DEADLOCK WARNING: Calling this method may call undoableEditHappened in all listeners.
endWordAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the Action for moving the caret to the end of a word.
endWriteEmpty() - Method in class javax.imageio.ImageWriter
Completes the writing of a new image that was begun with a prior call to prepareWriteEmpty.
endWriteSequence() - Method in class javax.imageio.ImageWriter
Completes the writing of a sequence of images begun with prepareWriteSequence.
ENGINE - Static variable in interface javax.script.ScriptEngine
Reserved key for a named value that is the name of the ScriptEngine implementation.
ENGINE_SCOPE - Static variable in interface javax.script.ScriptContext
EngineScope attributes are visible during the lifetime of a single ScriptEngine and a set of attributes is maintained for each engine.
ENGINE_VERSION - Static variable in interface javax.script.ScriptEngine
Reserved key for a named value that identifies the version of the ScriptEngine implementation.
engineAliases() - Method in class java.security.KeyStoreSpi
Lists all the alias names of this keystore.
engineBuild(CertPathParameters) - Method in class java.security.cert.CertPathBuilderSpi
Attempts to build a certification path using the specified algorithm parameter set.
engineContainsAlias(String) - Method in class java.security.KeyStoreSpi
Checks if the given alias exists in this keystore.
engineCreateSSLEngine() - Method in class javax.net.ssl.SSLContextSpi
Creates a new SSLEngine using this context.
engineCreateSSLEngine(String, int) - Method in class javax.net.ssl.SSLContextSpi
Creates a SSLEngine using this context.
engineDeleteEntry(String) - Method in class java.security.KeyStoreSpi
Deletes the entry identified by the given alias from this keystore.
engineDigest() - Method in class java.security.MessageDigestSpi
Completes the hash computation by performing final operations such as padding.
engineDigest(byte[], int, int) - Method in class java.security.MessageDigestSpi
Completes the hash computation by performing final operations such as padding.
engineDoFinal(byte[], int, int) - Method in class javax.crypto.CipherSpi
Encrypts or decrypts data in a single-part operation, or finishes a multiple-part operation.
engineDoFinal(byte[], int, int, byte[], int) - Method in class javax.crypto.CipherSpi
Encrypts or decrypts data in a single-part operation, or finishes a multiple-part operation.
engineDoFinal(ByteBuffer, ByteBuffer) - Method in class javax.crypto.CipherSpi
Encrypts or decrypts data in a single-part operation, or finishes a multiple-part operation.
engineDoFinal() - Method in class javax.crypto.MacSpi
Completes the MAC computation and resets the MAC for further use, maintaining the secret key that the MAC was initialized with.
engineDoPhase(Key, boolean) - Method in class javax.crypto.KeyAgreementSpi
Executes the next phase of this key agreement with the given key that was received from one of the other parties involved in this key agreement.
engineEntryInstanceOf(String, Class<? extends KeyStore.Entry>) - Method in class java.security.KeyStoreSpi
Determines if the keystore Entry for the specified alias is an instance or subclass of the specified entryClass.
engineGenerateCertificate(InputStream) - Method in class java.security.cert.CertificateFactorySpi
Generates a certificate object and initializes it with the data read from the input stream inStream.
engineGenerateCertificates(InputStream) - Method in class java.security.cert.CertificateFactorySpi
Returns a (possibly empty) collection view of the certificates read from the given input stream inStream.
engineGenerateCertPath(InputStream) - Method in class java.security.cert.CertificateFactorySpi
Generates a CertPath object and initializes it with the data read from the InputStream inStream.
engineGenerateCertPath(InputStream, String) - Method in class java.security.cert.CertificateFactorySpi
Generates a CertPath object and initializes it with the data read from the InputStream inStream.
engineGenerateCertPath(List<? extends Certificate>) - Method in class java.security.cert.CertificateFactorySpi
Generates a CertPath object and initializes it with a List of Certificates.
engineGenerateCRL(InputStream) - Method in class java.security.cert.CertificateFactorySpi
Generates a certificate revocation list (CRL) object and initializes it with the data read from the input stream inStream.
engineGenerateCRLs(InputStream) - Method in class java.security.cert.CertificateFactorySpi
Returns a (possibly empty) collection view of the CRLs read from the given input stream inStream.
engineGenerateKey() - Method in class javax.crypto.KeyGeneratorSpi
Generates a secret key.
engineGenerateParameters() - Method in class java.security.AlgorithmParameterGeneratorSpi
Generates the parameters.
engineGeneratePrivate(KeySpec) - Method in class java.security.KeyFactorySpi
Generates a private key object from the provided key specification (key material).
engineGeneratePublic(KeySpec) - Method in class java.security.KeyFactorySpi
Generates a public key object from the provided key specification (key material).
engineGenerateSecret() - Method in class javax.crypto.KeyAgreementSpi
Generates the shared secret and returns it in a new buffer.
engineGenerateSecret(byte[], int) - Method in class javax.crypto.KeyAgreementSpi
Generates the shared secret, and places it into the buffer sharedSecret, beginning at offset inclusive.
engineGenerateSecret(String) - Method in class javax.crypto.KeyAgreementSpi
Creates the shared secret and returns it as a secret key object of the requested algorithm type.
engineGenerateSecret(KeySpec) - Method in class javax.crypto.SecretKeyFactorySpi
Generates a SecretKey object from the provided key specification (key material).
engineGenerateSeed(int) - Method in class java.security.SecureRandomSpi
Returns the given number of seed bytes.
engineGenExemptionBlob() - Method in class javax.crypto.ExemptionMechanismSpi
Generates the exemption mechanism key blob.
engineGenExemptionBlob(byte[], int) - Method in class javax.crypto.ExemptionMechanismSpi
Generates the exemption mechanism key blob, and stores the result in the output buffer, starting at outputOffset inclusive.
engineGetAppConfigurationEntry(String) - Method in class javax.security.auth.login.ConfigurationSpi
Retrieve the AppConfigurationEntries for the specified name.
engineGetBlockSize() - Method in class javax.crypto.CipherSpi
Returns the block size (in bytes).
engineGetCertificate(String) - Method in class java.security.KeyStoreSpi
Returns the certificate associated with the given alias.
engineGetCertificateAlias(Certificate) - Method in class java.security.KeyStoreSpi
Returns the (alias) name of the first keystore entry whose certificate matches the given certificate.
engineGetCertificateChain(String) - Method in class java.security.KeyStoreSpi
Returns the certificate chain associated with the given alias.
engineGetCertificates(CertSelector) - Method in class java.security.cert.CertStoreSpi
Returns a Collection of Certificates that match the specified selector.
engineGetCertPathEncodings() - Method in class java.security.cert.CertificateFactorySpi
Returns an iteration of the CertPath encodings supported by this certificate factory, with the default encoding first.
engineGetClientSessionContext() - Method in class javax.net.ssl.SSLContextSpi
Returns a client SSLSessionContext object for this context.
engineGetCreationDate(String) - Method in class java.security.KeyStoreSpi
Returns the creation date of the entry identified by the given alias.
engineGetCRLs(CRLSelector) - Method in class java.security.cert.CertStoreSpi
Returns a Collection of CRLs that match the specified selector.
engineGetDefaultSSLParameters() - Method in class javax.net.ssl.SSLContextSpi
Returns a copy of the SSLParameters indicating the default settings for this SSL context.
engineGetDigestLength() - Method in class java.security.MessageDigestSpi
Returns the digest length in bytes.
engineGetEncoded() - Method in class java.security.AlgorithmParametersSpi
Returns the parameters in their primary encoding format.
engineGetEncoded(String) - Method in class java.security.AlgorithmParametersSpi
Returns the parameters encoded in the specified format.
engineGetEntry(String, KeyStore.ProtectionParameter) - Method in class java.security.KeyStoreSpi
Gets a KeyStore.Entry for the specified alias with the specified protection parameter.
engineGetIV() - Method in class javax.crypto.CipherSpi
Returns the initialization vector (IV) in a new buffer.
engineGetKey(String, char[]) - Method in class java.security.KeyStoreSpi
Returns the key associated with the given alias, using the given password to recover it.
engineGetKeyManagers() - Method in class javax.net.ssl.KeyManagerFactorySpi
Returns one key manager for each type of key material.
engineGetKeySize(Key) - Method in class javax.crypto.CipherSpi
Returns the key size of the given key object in bits.
engineGetKeySpec(Key, Class<T>) - Method in class java.security.KeyFactorySpi
Returns a specification (key material) of the given key object.
engineGetKeySpec(SecretKey, Class<?>) - Method in class javax.crypto.SecretKeyFactorySpi
Returns a specification (key material) of the given key object in the requested format.
engineGetMacLength() - Method in class javax.crypto.MacSpi
Returns the length of the MAC in bytes.
engineGetOutputSize(int) - Method in class javax.crypto.CipherSpi
Returns the length in bytes that an output buffer would need to be in order to hold the result of the next update or doFinal operation, given the input length inputLen (in bytes).
engineGetOutputSize(int) - Method in class javax.crypto.ExemptionMechanismSpi
Returns the length in bytes that an output buffer would need to be in order to hold the result of the next engineGenExemptionBlob operation, given the input length inputLen (in bytes).
engineGetParameter(String) - Method in class java.security.SignatureSpi
Deprecated.
engineGetParameters() - Method in class java.security.SignatureSpi
This method is overridden by providers to return the parameters used with this signature engine, or null if this signature engine does not use any parameters.
engineGetParameters() - Method in class javax.crypto.CipherSpi
Returns the parameters used with this cipher.
engineGetParameterSpec(Class<T>) - Method in class java.security.AlgorithmParametersSpi
Returns a (transparent) specification of this parameters object.
engineGetPermissions(CodeSource) - Method in class java.security.PolicySpi
Return a PermissionCollection object containing the set of permissions granted to the specified CodeSource.
engineGetPermissions(ProtectionDomain) - Method in class java.security.PolicySpi
Return a PermissionCollection object containing the set of permissions granted to the specified ProtectionDomain.
engineGetRevocationChecker() - Method in class java.security.cert.CertPathBuilderSpi
Returns a CertPathChecker that this implementation uses to check the revocation status of certificates.
engineGetRevocationChecker() - Method in class java.security.cert.CertPathValidatorSpi
Returns a CertPathChecker that this implementation uses to check the revocation status of certificates.
engineGetServerSessionContext() - Method in class javax.net.ssl.SSLContextSpi
Returns a server SSLSessionContext object for this context.
engineGetServerSocketFactory() - Method in class javax.net.ssl.SSLContextSpi
Returns a ServerSocketFactory object for this context.
engineGetSocketFactory() - Method in class javax.net.ssl.SSLContextSpi
Returns a SocketFactory object for this context.
engineGetSupportedSSLParameters() - Method in class javax.net.ssl.SSLContextSpi
Returns a copy of the SSLParameters indicating the maximum supported settings for this SSL context.
engineGetTrustManagers() - Method in class javax.net.ssl.TrustManagerFactorySpi
Returns one trust manager for each type of trust material.
engineImplies(ProtectionDomain, Permission) - Method in class java.security.PolicySpi
Check whether the policy has granted a Permission to a ProtectionDomain.
engineInit(int, SecureRandom) - Method in class java.security.AlgorithmParameterGeneratorSpi
Initializes this parameter generator for a certain size and source of randomness.
engineInit(AlgorithmParameterSpec, SecureRandom) - Method in class java.security.AlgorithmParameterGeneratorSpi
Initializes this parameter generator with a set of algorithm-specific parameter generation values.
engineInit(AlgorithmParameterSpec) - Method in class java.security.AlgorithmParametersSpi
Initializes this parameters object using the parameters specified in paramSpec.
engineInit(byte[]) - Method in class java.security.AlgorithmParametersSpi
Imports the specified parameters and decodes them according to the primary decoding format for parameters.
engineInit(byte[], String) - Method in class java.security.AlgorithmParametersSpi
Imports the parameters from params and decodes them according to the specified decoding format.
engineInit(int, Key, SecureRandom) - Method in class javax.crypto.CipherSpi
Initializes this cipher with a key and a source of randomness.
engineInit(int, Key, AlgorithmParameterSpec, SecureRandom) - Method in class javax.crypto.CipherSpi
Initializes this cipher with a key, a set of algorithm parameters, and a source of randomness.
engineInit(int, Key, AlgorithmParameters, SecureRandom) - Method in class javax.crypto.CipherSpi
Initializes this cipher with a key, a set of algorithm parameters, and a source of randomness.
engineInit(Key) - Method in class javax.crypto.ExemptionMechanismSpi
Initializes this exemption mechanism with a key.
engineInit(Key, AlgorithmParameterSpec) - Method in class javax.crypto.ExemptionMechanismSpi
Initializes this exemption mechanism with a key and a set of algorithm parameters.
engineInit(Key, AlgorithmParameters) - Method in class javax.crypto.ExemptionMechanismSpi
Initializes this exemption mechanism with a key and a set of algorithm parameters.
engineInit(Key, SecureRandom) - Method in class javax.crypto.KeyAgreementSpi
Initializes this key agreement with the given key and source of randomness.
engineInit(Key, AlgorithmParameterSpec, SecureRandom) - Method in class javax.crypto.KeyAgreementSpi
Initializes this key agreement with the given key, set of algorithm parameters, and source of randomness.
engineInit(SecureRandom) - Method in class javax.crypto.KeyGeneratorSpi
Initializes the key generator.
engineInit(AlgorithmParameterSpec, SecureRandom) - Method in class javax.crypto.KeyGeneratorSpi
Initializes the key generator with the specified parameter set and a user-provided source of randomness.
engineInit(int, SecureRandom) - Method in class javax.crypto.KeyGeneratorSpi
Initializes this key generator for a certain keysize, using the given source of randomness.
engineInit(Key, AlgorithmParameterSpec) - Method in class javax.crypto.MacSpi
Initializes the MAC with the given (secret) key and algorithm parameters.
engineInit(KeyStore, char[]) - Method in class javax.net.ssl.KeyManagerFactorySpi
Initializes this factory with a source of key material.
engineInit(ManagerFactoryParameters) - Method in class javax.net.ssl.KeyManagerFactorySpi
Initializes this factory with a source of key material.
engineInit(KeyManager[], TrustManager[], SecureRandom) - Method in class javax.net.ssl.SSLContextSpi
Initializes this context.
engineInit(KeyStore) - Method in class javax.net.ssl.TrustManagerFactorySpi
Initializes this factory with a source of certificate authorities and related trust material.
engineInit(ManagerFactoryParameters) - Method in class javax.net.ssl.TrustManagerFactorySpi
Initializes this factory with a source of provider-specific key material.
engineInitSign(PrivateKey) - Method in class java.security.SignatureSpi
Initializes this signature object with the specified private key for signing operations.
engineInitSign(PrivateKey, SecureRandom) - Method in class java.security.SignatureSpi
Initializes this signature object with the specified private key and source of randomness for signing operations.
engineInitVerify(PublicKey) - Method in class java.security.SignatureSpi
Initializes this signature object with the specified public key for verification operations.
engineIsCertificateEntry(String) - Method in class java.security.KeyStoreSpi
Returns true if the entry identified by the given alias was created by a call to setCertificateEntry, or created by a call to setEntry with a TrustedCertificateEntry.
engineIsKeyEntry(String) - Method in class java.security.KeyStoreSpi
Returns true if the entry identified by the given alias was created by a call to setKeyEntry, or created by a call to setEntry with a PrivateKeyEntry or a SecretKeyEntry.
engineLoad(InputStream, char[]) - Method in class java.security.KeyStoreSpi
Loads the keystore from the given input stream.
engineLoad(KeyStore.LoadStoreParameter) - Method in class java.security.KeyStoreSpi
Loads the keystore using the given KeyStore.LoadStoreParameter.
engineNextBytes(byte[]) - Method in class java.security.SecureRandomSpi
Generates a user-specified number of random bytes.
engineRefresh() - Method in class java.security.PolicySpi
Refreshes/reloads the policy configuration.
engineRefresh() - Method in class javax.security.auth.login.ConfigurationSpi
Refresh and reload the Configuration.
engineReset() - Method in class java.security.MessageDigestSpi
Resets the digest for further use.
engineReset() - Method in class javax.crypto.MacSpi
Resets the MAC for further use, maintaining the secret key that the MAC was initialized with.
engineScope - Variable in class javax.script.SimpleScriptContext
This is the engine scope bindings.
engineSetCertificateEntry(String, Certificate) - Method in class java.security.KeyStoreSpi
Assigns the given certificate to the given alias.
engineSetEntry(String, KeyStore.Entry, KeyStore.ProtectionParameter) - Method in class java.security.KeyStoreSpi
Saves a KeyStore.Entry under the specified alias.
engineSetKeyEntry(String, Key, char[], Certificate[]) - Method in class java.security.KeyStoreSpi
Assigns the given key to the given alias, protecting it with the given password.
engineSetKeyEntry(String, byte[], Certificate[]) - Method in class java.security.KeyStoreSpi
Assigns the given key (that has already been protected) to the given alias.
engineSetMode(String) - Method in class javax.crypto.CipherSpi
Sets the mode of this cipher.
engineSetPadding(String) - Method in class javax.crypto.CipherSpi
Sets the padding mechanism of this cipher.
engineSetParameter(String, Object) - Method in class java.security.SignatureSpi
Deprecated.
Replaced by engineSetParameter.
engineSetParameter(AlgorithmParameterSpec) - Method in class java.security.SignatureSpi
This method is overridden by providers to initialize this signature engine with the specified parameter set.
engineSetSeed(byte[]) - Method in class java.security.SecureRandomSpi
Reseeds this random object.
engineSign() - Method in class java.security.SignatureSpi
Returns the signature bytes of all the data updated so far.
engineSign(byte[], int, int) - Method in class java.security.SignatureSpi
Finishes this signature operation and stores the resulting signature bytes in the provided buffer outbuf, starting at offset.
engineSize() - Method in class java.security.KeyStoreSpi
Retrieves the number of entries in this keystore.
engineStore(OutputStream, char[]) - Method in class java.security.KeyStoreSpi
Stores this keystore to the given output stream, and protects its integrity with the given password.
engineStore(KeyStore.LoadStoreParameter) - Method in class java.security.KeyStoreSpi
Stores this keystore using the given KeyStore.LoadStoreParmeter.
engineToString() - Method in class java.security.AlgorithmParametersSpi
Returns a formatted string describing the parameters.
engineTranslateKey(Key) - Method in class java.security.KeyFactorySpi
Translates a key object, whose provider may be unknown or potentially untrusted, into a corresponding key object of this key factory.
engineTranslateKey(SecretKey) - Method in class javax.crypto.SecretKeyFactorySpi
Translates a key object, whose provider may be unknown or potentially untrusted, into a corresponding key object of this secret-key factory.
engineUnwrap(byte[], String, int) - Method in class javax.crypto.CipherSpi
Unwrap a previously wrapped key.
engineUpdate(byte) - Method in class java.security.MessageDigestSpi
Updates the digest using the specified byte.
engineUpdate(byte[], int, int) - Method in class java.security.MessageDigestSpi
Updates the digest using the specified array of bytes, starting at the specified offset.
engineUpdate(ByteBuffer) - Method in class java.security.MessageDigestSpi
Update the digest using the specified ByteBuffer.
engineUpdate(byte) - Method in class java.security.SignatureSpi
Updates the data to be signed or verified using the specified byte.
engineUpdate(byte[], int, int) - Method in class java.security.SignatureSpi
Updates the data to be signed or verified, using the specified array of bytes, starting at the specified offset.
engineUpdate(ByteBuffer) - Method in class java.security.SignatureSpi
Updates the data to be signed or verified using the specified ByteBuffer.
engineUpdate(byte[], int, int) - Method in class javax.crypto.CipherSpi
Continues a multiple-part encryption or decryption operation (depending on how this cipher was initialized), processing another data part.
engineUpdate(byte[], int, int, byte[], int) - Method in class javax.crypto.CipherSpi
Continues a multiple-part encryption or decryption operation (depending on how this cipher was initialized), processing another data part.
engineUpdate(ByteBuffer, ByteBuffer) - Method in class javax.crypto.CipherSpi
Continues a multiple-part encryption or decryption operation (depending on how this cipher was initialized), processing another data part.
engineUpdate(byte) - Method in class javax.crypto.MacSpi
Processes the given byte.
engineUpdate(byte[], int, int) - Method in class javax.crypto.MacSpi
Processes the first len bytes in input, starting at offset inclusive.
engineUpdate(ByteBuffer) - Method in class javax.crypto.MacSpi
Processes input.remaining() bytes in the ByteBuffer input, starting at input.position().
engineUpdateAAD(byte[], int, int) - Method in class javax.crypto.CipherSpi
Continues a multi-part update of the Additional Authentication Data (AAD), using a subset of the provided buffer.
engineUpdateAAD(ByteBuffer) - Method in class javax.crypto.CipherSpi
Continues a multi-part update of the Additional Authentication Data (AAD).
engineValidate(CertPath, CertPathParameters) - Method in class java.security.cert.CertPathValidatorSpi
Validates the specified certification path using the specified algorithm parameter set.
engineVerify(byte[]) - Method in class java.security.SignatureSpi
Verifies the passed-in signature.
engineVerify(byte[], int, int) - Method in class java.security.SignatureSpi
Verifies the passed-in signature in the specified array of bytes, starting at the specified offset.
engineWrap(Key) - Method in class javax.crypto.CipherSpi
Wrap a key.
ENGLISH - Static variable in class java.util.Locale
Useful constant for language.
enqueue() - Method in class java.lang.ref.Reference
Adds this reference object to the queue with which it is registered, if any.
enqueueKeyEvents(long, Component) - Method in class java.awt.DefaultKeyboardFocusManager
Delays dispatching of KeyEvents until the specified Component becomes the focus owner.
enqueueKeyEvents(long, Component) - Method in class java.awt.KeyboardFocusManager
Called by the AWT to notify the KeyboardFocusManager that it should delay dispatching of KeyEvents until the specified Component becomes the focus owner.
ensureCapacity(int) - Method in class java.lang.StringBuffer
ensureCapacity(int) - Method in class java.util.ArrayList
Increases the capacity of this ArrayList instance, if necessary, to ensure that it can hold at least the number of elements specified by the minimum capacity argument.
ensureCapacity(int) - Method in class java.util.Vector
Increases the capacity of this vector, if necessary, to ensure that it can hold at least the number of components specified by the minimum capacity argument.
ensureCapacity(int) - Method in class javax.swing.DefaultListModel
Increases the capacity of this list, if necessary, to ensure that it can hold at least the number of components specified by the minimum capacity argument.
ensureFileIsVisible(File) - Method in class javax.swing.JFileChooser
Makes sure that the specified file is viewable, and not hidden.
ensureFileIsVisible(JFileChooser, File) - Method in class javax.swing.plaf.basic.BasicFileChooserUI
ensureFileIsVisible(JFileChooser, File) - Method in class javax.swing.plaf.FileChooserUI
ensureFileIsVisible(JFileChooser, File) - Method in class javax.swing.plaf.metal.MetalFileChooserUI
ensureFileIsVisible(JFileChooser, File) - Method in class javax.swing.plaf.multi.MultiFileChooserUI
Invokes the ensureFileIsVisible method on each UI handled by this object.
ensureIndexIsVisible(int) - Method in class javax.swing.JList
Scrolls the list within an enclosing viewport to make the specified cell completely visible.
ensureRowsAreVisible(int, int) - Method in class javax.swing.plaf.basic.BasicTreeUI
Ensures that the rows identified by beginRow through endRow are visible.
ENTER - Static variable in class java.awt.dnd.DragSourceContext
An int used by updateCurrentCursor() indicating that the Cursor has entered a DropTarget.
ENTER - Static variable in class java.awt.Event
The Enter key.
enter() - Method in interface java.awt.SecondaryLoop
Blocks the execution of the current thread and enters a new secondary event loop on the event dispatch thread.
ENTERED - Static variable in class javax.swing.event.HyperlinkEvent.EventType
Entered type.
entering(String, String) - Method in class java.util.logging.Logger
Log a method entry.
entering(String, String, Object) - Method in class java.util.logging.Logger
Log a method entry, with one parameter.
entering(String, String, Object[]) - Method in class java.util.logging.Logger
Log a method entry, with an array of parameters.
ENTITIES - Static variable in interface javax.swing.text.html.parser.DTDConstants
ENTITY - Static variable in interface javax.swing.text.html.parser.DTDConstants
Entity - Class in javax.swing.text.html.parser
An entity is described in a DTD using the ENTITY construct.
Entity(String, int, char[]) - Constructor for class javax.swing.text.html.parser.Entity
Creates an entity.
Entity - Interface in org.w3c.dom
This interface represents a known entity, either parsed or unparsed, in an XML document.
ENTITY_DECLARATION - Static variable in interface javax.xml.stream.XMLStreamConstants
Indicates a Entity Declaration
ENTITY_NODE - Static variable in interface org.w3c.dom.Node
The node is an Entity.
ENTITY_REFERENCE - Static variable in interface javax.xml.stream.XMLStreamConstants
Indicates an event is an entity reference
ENTITY_REFERENCE_NODE - Static variable in interface org.w3c.dom.Node
The node is an EntityReference.
EntityDeclaration - Interface in javax.xml.stream.events
An interface for handling Entity Declarations This interface is used to record and report unparsed entity declarations.
entityHash - Variable in class javax.swing.text.html.parser.DTD
EntityReference - Interface in javax.xml.stream.events
An interface for handling Entity events.
EntityReference - Interface in org.w3c.dom
EntityReference nodes may be used to represent an entity reference in the tree.
EntityResolver - Interface in org.xml.sax
Basic interface for resolving entities.
EntityResolver2 - Interface in org.xml.sax.ext
Extended interface for mapping external entity references to input sources, or providing a missing external subset.
entries() - Method in interface java.security.acl.Acl
Returns an enumeration of the entries in this ACL.
entries() - Method in class java.util.jar.JarFile
Returns an enumeration of the zip file entries.
entries() - Method in class java.util.zip.ZipFile
Returns an enumeration of the ZIP file entries.
Entry() - Constructor for class javax.swing.RowFilter.Entry
Creates an Entry.
ENTRY_CREATE - Static variable in class java.nio.file.StandardWatchEventKinds
Directory entry created.
ENTRY_DELETE - Static variable in class java.nio.file.StandardWatchEventKinds
Directory entry deleted.
ENTRY_MODIFY - Static variable in class java.nio.file.StandardWatchEventKinds
Directory entry modified.
entryInstanceOf(String, Class<? extends KeyStore.Entry>) - Method in class java.security.KeyStore
Determines if the keystore Entry for the specified alias is an instance or subclass of the specified entryClass.
entrySet() - Method in class java.awt.RenderingHints
Returns a Set view of the mappings contained in this RenderingHints.
entrySet() - Method in class java.security.Provider
Returns an unmodifiable Set view of the property entries contained in this Provider.
entrySet() - Method in class java.util.AbstractMap
entrySet() - Method in class java.util.concurrent.ConcurrentHashMap
Returns a Set view of the mappings contained in this map.
entrySet() - Method in class java.util.concurrent.ConcurrentSkipListMap
Returns a Set view of the mappings contained in this map.
entrySet() - Method in class java.util.EnumMap
Returns a Set view of the mappings contained in this map.
entrySet() - Method in class java.util.HashMap
Returns a Set view of the mappings contained in this map.
entrySet() - Method in class java.util.Hashtable
Returns a Set view of the mappings contained in this map.
entrySet() - Method in class java.util.IdentityHashMap
Returns a Set view of the mappings contained in this map.
entrySet() - Method in class java.util.jar.Attributes
Returns a Collection view of the attribute name-value mappings contained in this Map.
entrySet() - Method in class java.util.LinkedHashMap
Returns a Set view of the mappings contained in this map.
entrySet() - Method in interface java.util.Map
Returns a Set view of the mappings contained in this map.
entrySet() - Method in interface java.util.SortedMap
Returns a Set view of the mappings contained in this map.
entrySet() - Method in class java.util.TreeMap
Returns a Set view of the mappings contained in this map.
entrySet() - Method in class java.util.WeakHashMap
Returns a Set view of the mappings contained in this map.
entrySet() - Method in class javax.management.openmbean.TabularDataSupport
Returns a collection view of the index to row mappings contained in this TabularDataSupport instance.
entrySet() - Method in class javax.script.SimpleBindings
Returns a Set view of the mappings contained in this map.
Enum<E extends Enum<E>> - Class in java.lang
This is the common base class of all Java language enumeration types.
Enum(String, int) - Constructor for class java.lang.Enum
Sole constructor.
EnumConstantNotPresentException - Exception in java.lang
Thrown when an application tries to access an enum constant by name and the enum type contains no constant with the specified name.
EnumConstantNotPresentException(Class<? extends Enum>, String) - Constructor for exception java.lang.EnumConstantNotPresentException
Constructs an EnumConstantNotPresentException for the specified constant.
EnumControl - Class in javax.sound.sampled
A EnumControl provides control over a set of discrete possible values, each represented by an object.
EnumControl(EnumControl.Type, Object[], Object) - Constructor for class javax.sound.sampled.EnumControl
Constructs a new enumerated control object with the given parameters.
EnumControl.Type - Class in javax.sound.sampled
An instance of the EnumControl.Type inner class identifies one kind of enumerated control.
enumerate(Thread[]) - Static method in class java.lang.Thread
Copies into the specified array every active thread in the current thread's thread group and its subgroups.
enumerate(Thread[]) - Method in class java.lang.ThreadGroup
Copies into the specified array every active thread in this thread group and its subgroups.
enumerate(Thread[], boolean) - Method in class java.lang.ThreadGroup
Copies into the specified array every active thread in this thread group.
enumerate(ThreadGroup[]) - Method in class java.lang.ThreadGroup
Copies into the specified array references to every active subgroup in this thread group and its subgroups.
enumerate(ThreadGroup[], boolean) - Method in class java.lang.ThreadGroup
Copies into the specified array references to every active subgroup in this thread group.
enumeration(Collection<T>) - Static method in class java.util.Collections
Returns an enumeration over the specified collection.
Enumeration<E> - Interface in java.util
An object that implements the Enumeration interface generates a series of elements, one at a time.
EnumMap<K extends Enum<K>,V> - Class in java.util
A specialized Map implementation for use with enum type keys.
EnumMap(Class<K>) - Constructor for class java.util.EnumMap
Creates an empty enum map with the specified key type.
EnumMap(EnumMap<K, ? extends V>) - Constructor for class java.util.EnumMap
Creates an enum map with the same key type as the specified enum map, initially containing the same mappings (if any).
EnumMap(Map<K, ? extends V>) - Constructor for class java.util.EnumMap
Creates an enum map initialized from the specified map.
EnumSet<E extends Enum<E>> - Class in java.util
A specialized Set implementation for use with enum types.
EnumSyntax - Class in javax.print.attribute
Class EnumSyntax is an abstract base class providing the common implementation of all "type safe enumeration" objects.
EnumSyntax(int) - Constructor for class javax.print.attribute.EnumSyntax
Construct a new enumeration value with the given integer value.
enumType() - Method in exception java.lang.EnumConstantNotPresentException
Returns the type of the missing enum constant.
env() - Method in class org.omg.CORBA.Request
Retrieves the Environment object for this request.
ENV_10 - Static variable in class java.awt.PageAttributes.MediaType
An alias for NA_NUMBER_10_ENVELOPE.
ENV_10X13 - Static variable in class java.awt.PageAttributes.MediaType
An alias for NA_10X13_ENVELOPE.
ENV_10X14 - Static variable in class java.awt.PageAttributes.MediaType
An alias for NA_10X14_ENVELOPE.
ENV_10X15 - Static variable in class java.awt.PageAttributes.MediaType
An alias for NA_10X15_ENVELOPE.
ENV_11 - Static variable in class java.awt.PageAttributes.MediaType
An alias for NA_NUMBER_11_ENVELOPE.
ENV_12 - Static variable in class java.awt.PageAttributes.MediaType
An alias for NA_NUMBER_12_ENVELOPE.
ENV_14 - Static variable in class java.awt.PageAttributes.MediaType
An alias for NA_NUMBER_14_ENVELOPE.
ENV_6X9 - Static variable in class java.awt.PageAttributes.MediaType
An alias for NA_6X9_ENVELOPE.
ENV_7X9 - Static variable in class java.awt.PageAttributes.MediaType
An alias for NA_7X9_ENVELOPE.
ENV_9 - Static variable in class java.awt.PageAttributes.MediaType
An alias for NA_NUMBER_9_ENVELOPE.
ENV_9X11 - Static variable in class java.awt.PageAttributes.MediaType
An alias for NA_9X11_ENVELOPE.
ENV_9X12 - Static variable in class java.awt.PageAttributes.MediaType
An alias for NA_9X12_ENVELOPE.
ENV_INVITE - Static variable in class java.awt.PageAttributes.MediaType
An alias for INVITE_ENVELOPE.
ENV_ITALY - Static variable in class java.awt.PageAttributes.MediaType
An alias for ITALY_ENVELOPE.
ENV_MONARCH - Static variable in class java.awt.PageAttributes.MediaType
An alias for MONARCH_ENVELOPE.
ENV_PERSONAL - Static variable in class java.awt.PageAttributes.MediaType
An alias for PERSONAL_ENVELOPE.
ENVELOPE - Static variable in class javax.print.attribute.standard.MediaTray
The envelope input tray in the printer.
ENVELOPED - Static variable in interface javax.xml.crypto.dsig.Transform
The Enveloped Signature transform algorithm URI.
environment() - Method in class java.lang.ProcessBuilder
Returns a string map view of this process builder's environment.
environment - Variable in exception javax.naming.CannotProceedException
Contains the environment relevant for the Context or DirContext method that cannot proceed.
Environment - Class in org.omg.CORBA
A container (holder) for an exception that is used in Request operations to make exceptions available to the client.
Environment() - Constructor for class org.omg.CORBA.Environment
eof - Variable in exception java.io.OptionalDataException
True if there is no more data in the buffered part of the stream.
EOFException - Exception in java.io
Signals that an end of file or end of stream has been reached unexpectedly during input.
EOFException() - Constructor for exception java.io.EOFException
Constructs an EOFException with null as its error detail message.
EOFException(String) - Constructor for exception java.io.EOFException
Constructs an EOFException with the specified detail message.
eolIsSignificant(boolean) - Method in class java.io.StreamTokenizer
Determines whether or not ends of line are treated as tokens.
eos - Variable in class java.util.zip.GZIPInputStream
Indicates end of input stream.
EPOCH - Static variable in class java.time.Instant
Constant for the 1970-01-01T00:00:00Z epoch instant.
EQ - Static variable in class javax.management.Query
A code representing the Query.eq(javax.management.ValueExp, javax.management.ValueExp) query.
eq(ValueExp, ValueExp) - Static method in class javax.management.Query
Returns a query expression that represents an equality constraint on two values.
EQUAL - Static variable in class javax.xml.datatype.DatatypeConstants
Comparison result.
equal(Any) - Method in class org.omg.CORBA.Any
Checks for equality between this Any object and the given Any object.
equal(TypeCode) - Method in class org.omg.CORBA.TypeCode
Compares this TypeCode object with the given one, testing for equality.
equal(DynAny) - Method in class org.omg.DynamicAny._DynAnyStub
Compares two DynAny values for equality.
equal(DynAny) - Method in class org.omg.DynamicAny._DynArrayStub
Compares two DynAny values for equality.
equal(DynAny) - Method in class org.omg.DynamicAny._DynEnumStub
Compares two DynAny values for equality.
equal(DynAny) - Method in class org.omg.DynamicAny._DynFixedStub
Compares two DynAny values for equality.
equal(DynAny) - Method in class org.omg.DynamicAny._DynSequenceStub
Compares two DynAny values for equality.
equal(DynAny) - Method in class org.omg.DynamicAny._DynStructStub
Compares two DynAny values for equality.
equal(DynAny) - Method in class org.omg.DynamicAny._DynUnionStub
Compares two DynAny values for equality.
equal(DynAny) - Method in class org.omg.DynamicAny._DynValueStub
Compares two DynAny values for equality.
equal(DynAny) - Method in interface org.omg.DynamicAny.DynAnyOperations
Compares two DynAny values for equality.
equals(Object) - Method in class java.awt.AlphaComposite
Determines whether the specified object is equal to this AlphaComposite.
equals(Object) - Method in class java.awt.AWTKeyStroke
Returns true if this object is identical to the specified object.
equals(Object) - Method in class java.awt.BasicStroke
Tests if a specified object is equal to this BasicStroke by first testing if it is a BasicStroke and then comparing its width, join, cap, miter limit, dash, and dash phase attributes with those of this BasicStroke.
equals(Object) - Method in class java.awt.Color
Determines whether another object is equal to this Color.
equals(Object) - Method in class java.awt.datatransfer.DataFlavor
Indicates whether some other object is "equal to" this one.
equals(DataFlavor) - Method in class java.awt.datatransfer.DataFlavor
This method has the same behavior as DataFlavor.equals(Object).
equals(String) - Method in class java.awt.datatransfer.DataFlavor
Deprecated.
As inconsistent with hashCode() contract, use isMimeTypeEqual(String) instead.
equals(Object) - Method in class java.awt.Dimension
Checks whether two dimension objects have equal values.
equals(DisplayMode) - Method in class java.awt.DisplayMode
Returns whether the two display modes are equal.
equals(Object) - Method in class java.awt.DisplayMode
Indicates whether some other object is "equal to" this one.
equals(Object) - Method in class java.awt.Font
Compares this Font object to the specified Object.
equals(Object) - Method in class java.awt.font.FontRenderContext
Return true if obj is an instance of FontRenderContext and has the same transform, antialiasing, and fractional metrics values as this.
equals(FontRenderContext) - Method in class java.awt.font.FontRenderContext
Return true if rhs has the same transform, antialiasing, and fractional metrics values as this.
equals(GlyphVector) - Method in class java.awt.font.GlyphVector
Tests if the specified GlyphVector exactly equals this GlyphVector.
equals(Object) - Method in class java.awt.font.ImageGraphicAttribute
Compares this ImageGraphicAttribute to the specified Object.
equals(ImageGraphicAttribute) - Method in class java.awt.font.ImageGraphicAttribute
Compares this ImageGraphicAttribute to the specified ImageGraphicAttribute.
equals(Object) - Method in class java.awt.font.NumericShaper
Returns true if the specified object is an instance of NumericShaper and shapes identically to this one, regardless of the range representations, the bit mask or the enum.
equals(Object) - Method in class java.awt.font.ShapeGraphicAttribute
Compares this ShapeGraphicAttribute to the specified Object.
equals(ShapeGraphicAttribute) - Method in class java.awt.font.ShapeGraphicAttribute
Compares this ShapeGraphicAttribute to the specified ShapeGraphicAttribute.
equals(Object) - Method in class java.awt.font.TextHitInfo
Returns true if the specified Object is a TextHitInfo and equals this TextHitInfo.
equals(TextHitInfo) - Method in class java.awt.font.TextHitInfo
Returns true if the specified TextHitInfo has the same charIndex and isLeadingEdge as this TextHitInfo.
equals(Object) - Method in class java.awt.font.TextLayout
Returns true if the specified Object is a TextLayout object and if the specified Object equals this TextLayout.
equals(TextLayout) - Method in class java.awt.font.TextLayout
Returns true if the two layouts are equal.
equals(Object) - Method in class java.awt.font.TransformAttribute
Returns true if rhs is a TransformAttribute whose transform is equal to this TransformAttribute's transform.
equals(Object) - Method in class java.awt.geom.AffineTransform
Returns true if this AffineTransform represents the same affine coordinate transform as the specified argument.
equals(Object) - Method in class java.awt.geom.Arc2D
Determines whether or not the specified Object is equal to this Arc2D.
equals(Area) - Method in class java.awt.geom.Area
Tests whether the geometries of the two Area objects are equal.
equals(Object) - Method in class java.awt.geom.Ellipse2D
Determines whether or not the specified Object is equal to this Ellipse2D.
equals(Object) - Method in class java.awt.geom.Point2D
Determines whether or not two points are equal.
equals(Object) - Method in class java.awt.geom.Rectangle2D
Determines whether or not the specified Object is equal to this Rectangle2D.
equals(Object) - Method in class java.awt.geom.RoundRectangle2D
Determines whether or not the specified Object is equal to this RoundRectangle2D.
equals(Object) - Method in class java.awt.image.ColorModel
Tests if the specified Object is an instance of ColorModel and if it equals this ColorModel.
equals(Object) - Method in class java.awt.image.ComponentColorModel
Compares this color model with another for equality.
equals(Object) - Method in class java.awt.image.ComponentSampleModel
equals(Object) - Method in class java.awt.image.MultiPixelPackedSampleModel
equals(Object) - Method in class java.awt.image.PackedColorModel
Tests if the specified Object is an instance of PackedColorModel and equals this PackedColorModel.
equals(Object) - Method in class java.awt.image.SinglePixelPackedSampleModel
equals(Object) - Method in class java.awt.Insets
Checks whether two insets objects are equal.
equals(Object) - Method in class java.awt.JobAttributes
Determines whether two JobAttributes are equal to each other.
equals(MenuShortcut) - Method in class java.awt.MenuShortcut
Returns whether this MenuShortcut is the same as another: equality is defined to mean that both MenuShortcuts use the same key and both either use or don't use the SHIFT key.
equals(Object) - Method in class java.awt.MenuShortcut
Returns whether this MenuShortcut is the same as another: equality is defined to mean that both MenuShortcuts use the same key and both either use or don't use the SHIFT key.
equals(Object) - Method in class java.awt.PageAttributes
Determines whether two PageAttributes are equal to each other.
equals(Object) - Method in class java.awt.Point
Determines whether or not two points are equal.
equals(Object) - Method in class java.awt.Rectangle
Checks whether two rectangles are equal.
equals(Object) - Method in class java.awt.RenderingHints
Compares the specified Object with this RenderingHints for equality.
equals(Object) - Method in class java.awt.RenderingHints.Key
The equals method for all Key objects will return the same result as the equality operator '=='.
equals(Object) - Method in class java.beans.IndexedPropertyDescriptor
Compares this PropertyDescriptor against the specified object.
equals(Object) - Method in class java.beans.PropertyDescriptor
Compares this PropertyDescriptor against the specified object.
equals(Object) - Method in class java.io.File
Tests this abstract pathname for equality with the given object.
equals(Object) - Method in class java.io.FilePermission
Checks two FilePermission objects for equality.
equals(Object) - Method in interface java.lang.annotation.Annotation
Returns true if the specified object represents an annotation that is logically equivalent to this one.
equals(Object) - Method in class java.lang.Boolean
Returns true if and only if the argument is not null and is a Boolean object that represents the same boolean value as this object.
equals(Object) - Method in class java.lang.Byte
Compares this object to the specified object.
equals(Object) - Method in class java.lang.Character
Compares this object against the specified object.
equals(Object) - Method in class java.lang.Character.Subset
Compares two Subset objects for equality.
equals(Object) - Method in class java.lang.Double
Compares this object against the specified object.
equals(Object) - Method in class java.lang.Enum
Returns true if the specified object is equal to this enum constant.
equals(Object) - Method in class java.lang.Float
Compares this object against the specified object.
equals(Object) - Method in class java.lang.Integer
Compares this object to the specified object.
equals(Object) - Method in class java.lang.invoke.MethodType
Compares the specified object with this type for equality.
equals(Object) - Method in class java.lang.Long
Compares this object to the specified object.
equals(Object) - Method in class java.lang.Object
Indicates whether some other object is "equal to" this one.
equals(Object) - Method in class java.lang.ProcessBuilder.Redirect
Compares the specified object with this Redirect for equality.
equals(Object) - Method in class java.lang.reflect.Constructor
Compares this Constructor against the specified object.
equals(Object) - Method in class java.lang.reflect.Field
Compares this Field against the specified object.
equals(Object) - Method in class java.lang.reflect.Method
Compares this Method against the specified object.
equals(Object) - Method in class java.lang.reflect.Parameter
Compares based on the executable and the index.
equals(Object) - Method in class java.lang.Short
Compares this object to the specified object.
equals(Object) - Method in class java.lang.StackTraceElement
Returns true if the specified object is another StackTraceElement instance representing the same execution point as this instance.
equals(Object) - Method in class java.lang.String
Compares this string to the specified object.
equals(Object) - Method in class java.math.BigDecimal
Compares this BigDecimal with the specified Object for equality.
equals(Object) - Method in class java.math.BigInteger
Compares this BigInteger with the specified Object for equality.
equals(Object) - Method in class java.math.MathContext
Compares this MathContext with the specified Object for equality.
equals(Object) - Method in class java.net.HttpCookie
Test the equality of two HTTP cookies.
equals(Object) - Method in class java.net.Inet4Address
Compares this object against the specified object.
equals(Object) - Method in class java.net.Inet6Address
Compares this object against the specified object.
equals(Object) - Method in class java.net.InetAddress
Compares this object against the specified object.
equals(Object) - Method in class java.net.InetSocketAddress
Compares this object against the specified object.
equals(Object) - Method in class java.net.InterfaceAddress
Compares this object against the specified object.
equals(Object) - Method in class java.net.NetworkInterface
Compares this object against the specified object.
equals(Object) - Method in class java.net.Proxy
Compares this object against the specified object.
equals(Object) - Method in class java.net.SocketPermission
Checks two SocketPermission objects for equality.
equals(Object) - Method in class java.net.URI
Tests this URI for equality with another object.
equals(Object) - Method in class java.net.URL
Compares this URL for equality with another object.
equals(Object) - Method in class java.net.URLPermission
Returns true if, this.getActions().equals(p.getActions()) and p's url equals this's url.
equals(URL, URL) - Method in class java.net.URLStreamHandler
Provides the default equals calculation.
equals(Object) - Method in class java.nio.ByteBuffer
Tells whether or not this buffer is equal to another object.
equals(Object) - Method in class java.nio.CharBuffer
Tells whether or not this buffer is equal to another object.
equals(Object) - Method in class java.nio.charset.Charset
Tells whether or not this object is equal to another.
equals(Object) - Method in class java.nio.DoubleBuffer
Tells whether or not this buffer is equal to another object.
equals(Object) - Method in class java.nio.file.attribute.AclEntry
Compares the specified object with this ACL entry for equality.
equals(Object) - Method in class java.nio.file.attribute.FileTime
Tests this FileTime for equality with the given object.
equals(Object) - Method in interface java.nio.file.Path
Tests this path for equality with the given object.
equals(Object) - Method in class java.nio.FloatBuffer
Tells whether or not this buffer is equal to another object.
equals(Object) - Method in class java.nio.IntBuffer
Tells whether or not this buffer is equal to another object.
equals(Object) - Method in class java.nio.LongBuffer
Tells whether or not this buffer is equal to another object.
equals(Object) - Method in class java.nio.ShortBuffer
Tells whether or not this buffer is equal to another object.
equals(Object) - Method in class java.rmi.activation.ActivationDesc
Compares two activation descriptors for content equality.
equals(Object) - Method in class java.rmi.activation.ActivationGroupDesc.CommandEnvironment
Compares two command environments for content equality.
equals(Object) - Method in class java.rmi.activation.ActivationGroupDesc
Compares two activation group descriptors for content equality.
equals(Object) - Method in class java.rmi.activation.ActivationGroupID
Compares two group identifiers for content equality.
equals(Object) - Method in class java.rmi.activation.ActivationID
Compares two activation ids for content equality.
equals(Object) - Method in class java.rmi.dgc.VMID
Compare this VMID to another, and return true if they are the same identifier.
equals(Object) - Method in class java.rmi.MarshalledObject
Compares this MarshalledObject to another object.
equals(Object) - Method in class java.rmi.server.ObjID
Compares the specified object with this ObjID for equality.
equals(Object) - Method in class java.rmi.server.RemoteObject
Compares two remote objects for equality.
equals(Object) - Method in class java.rmi.server.UID
Compares the specified object with this UID for equality.
equals(Object) - Method in class java.security.AccessControlContext
Checks two AccessControlContext objects for equality.
equals(Object) - Method in interface java.security.acl.Permission
Returns true if the object passed matches the permission represented in this interface.
equals(Object) - Method in class java.security.AllPermission
Checks two AllPermission objects for equality.
equals(Object) - Method in class java.security.BasicPermission
Checks two BasicPermission objects for equality.
equals(Object) - Method in class java.security.cert.Certificate
Compares this certificate for equality with the specified object.
equals(Object) - Method in class java.security.cert.CertPath
Compares this certification path for equality with the specified object.
equals(Object) - Method in class java.security.cert.X509CRL
Compares this CRL for equality with the given object.
equals(Object) - Method in class java.security.cert.X509CRLEntry
Compares this CRL entry for equality with the given object.
equals(Object) - Method in class java.security.CodeSigner
Tests for equality between the specified object and this code signer.
equals(Object) - Method in class java.security.CodeSource
Tests for equality between the specified object and this object.
equals(Object) - Method in class java.security.Identity
Deprecated.
Tests for equality between the specified object and this identity.
equals(Object) - Method in class java.security.Permission
Checks two Permission objects for equality.
equals(Object) - Method in class java.security.PKCS12Attribute
Compares this PKCS12Attribute and a specified object for equality.
equals(Object) - Method in interface java.security.Principal
Compares this principal to the specified object.
equals(Object) - Method in class java.security.spec.ECFieldF2m
Compares this finite field for equality with the specified object.
equals(Object) - Method in class java.security.spec.ECFieldFp
Compares this prime finite field for equality with the specified object.
equals(Object) - Method in class java.security.spec.ECPoint
Compares this elliptic curve point for equality with the specified object.
equals(Object) - Method in class java.security.spec.EllipticCurve
Compares this elliptic curve for equality with the specified object.
equals(Object) - Method in class java.security.Timestamp
Tests for equality between the specified object and this timestamp.
equals(Object) - Method in class java.security.UnresolvedPermission
Checks two UnresolvedPermission objects for equality.
equals(Object) - Method in interface java.sql.RowId
Compares this RowId to the specified object.
equals(Timestamp) - Method in class java.sql.Timestamp
Tests to see if this Timestamp object is equal to the given Timestamp object.
equals(Object) - Method in class java.sql.Timestamp
Tests to see if this Timestamp object is equal to the given object.
equals(Object) - Method in class java.text.AttributedCharacterIterator.Attribute
Compares two objects for equality.
equals(Object) - Method in class java.text.ChoiceFormat
Equality comparision between two
equals(String, String) - Method in class java.text.Collator
Convenience method for comparing the equality of two strings based on this Collator's collation rules.
equals(Object) - Method in class java.text.Collator
Compares the equality of two Collators.
equals(Object) - Method in class java.text.DateFormat
Overrides equals
equals(Object) - Method in class java.text.DateFormatSymbols
Override equals
equals(Object) - Method in class java.text.DecimalFormat
Overrides equals
equals(Object) - Method in class java.text.DecimalFormatSymbols
Override equals.
equals(Object) - Method in class java.text.FieldPosition
Overrides equals
equals(Object) - Method in class java.text.MessageFormat
Equality comparison between two message format objects
equals(Object) - Method in class java.text.NumberFormat
Overrides equals.
equals(Object) - Method in class java.text.ParsePosition
Overrides equals
equals(Object) - Method in class java.text.RuleBasedCollator
Compares the equality of two collation objects.
equals(Object) - Method in class java.text.SimpleDateFormat
Compares the given object with this SimpleDateFormat for equality.
equals(Object) - Method in class java.text.StringCharacterIterator
Compares the equality of two StringCharacterIterator objects.
equals(Object) - Method in class java.time.chrono.AbstractChronology
Checks if this chronology is equal to another chronology.
equals(Object) - Method in interface java.time.chrono.ChronoLocalDate
Checks if this date is equal to another date, including the chronology.
equals(Object) - Method in interface java.time.chrono.ChronoLocalDateTime
Checks if this date-time is equal to another date-time, including the chronology.
equals(Object) - Method in interface java.time.chrono.Chronology
Checks if this chronology is equal to another chronology.
equals(Object) - Method in interface java.time.chrono.ChronoPeriod
Checks if this period is equal to another period, including the chronology.
equals(Object) - Method in interface java.time.chrono.ChronoZonedDateTime
Checks if this date-time is equal to another date-time.
equals(Object) - Method in class java.time.chrono.HijrahDate
Compares this date to another date, including the chronology.
equals(Object) - Method in class java.time.chrono.JapaneseDate
Compares this date to another date, including the chronology.
equals(Object) - Method in class java.time.chrono.MinguoDate
Compares this date to another date, including the chronology.
equals(Object) - Method in class java.time.chrono.ThaiBuddhistDate
Compares this date to another date, including the chronology.
equals(Object) - Method in class java.time.Clock
Checks if this clock is equal to another clock.
equals(Object) - Method in class java.time.Duration
Checks if this duration is equal to the specified Duration.
equals(Object) - Method in class java.time.format.DecimalStyle
Checks if this DecimalStyle is equal another DecimalStyle.
equals(Object) - Method in class java.time.Instant
Checks if this instant is equal to the specified instant.
equals(Object) - Method in class java.time.LocalDate
Checks if this date is equal to another date.
equals(Object) - Method in class java.time.LocalDateTime
Checks if this date-time is equal to another date-time.
equals(Object) - Method in class java.time.LocalTime
Checks if this time is equal to another time.
equals(Object) - Method in class java.time.MonthDay
Checks if this month-day is equal to another month-day.
equals(Object) - Method in class java.time.OffsetDateTime
Checks if this date-time is equal to another date-time.
equals(Object) - Method in class java.time.OffsetTime
Checks if this time is equal to another time.
equals(Object) - Method in class java.time.Period
Checks if this period is equal to another period.
equals(Object) - Method in class java.time.temporal.ValueRange
Checks if this range is equal to another range.
equals(Object) - Method in class java.time.temporal.WeekFields
Checks if this WeekFields is equal to the specified object.
equals(Object) - Method in class java.time.Year
Checks if this year is equal to another year.
equals(Object) - Method in class java.time.YearMonth
Checks if this year-month is equal to another year-month.
equals(Object) - Method in class java.time.zone.ZoneOffsetTransition
Checks if this object equals another.
equals(Object) - Method in class java.time.zone.ZoneOffsetTransitionRule
Checks if this object equals another.
equals(Object) - Method in class java.time.zone.ZoneRules
Checks if this set of rules equals another.
equals(Object) - Method in class java.time.ZonedDateTime
Checks if this date-time is equal to another date-time.
equals(Object) - Method in class java.time.ZoneId
Checks if this time-zone ID is equal to another time-zone ID.
equals(Object) - Method in class java.time.ZoneOffset
Checks if this offset is equal to another offset.
equals(Object) - Method in class java.util.AbstractList
Compares the specified object with this list for equality.
equals(Object) - Method in class java.util.AbstractMap
Compares the specified object with this map for equality.
equals(Object) - Method in class java.util.AbstractMap.SimpleEntry
Compares the specified object with this entry for equality.
equals(Object) - Method in class java.util.AbstractMap.SimpleImmutableEntry
Compares the specified object with this entry for equality.
equals(Object) - Method in class java.util.AbstractSet
Compares the specified object with this set for equality.
equals(long[], long[]) - Static method in class java.util.Arrays
Returns true if the two specified arrays of longs are equal to one another.
equals(int[], int[]) - Static method in class java.util.Arrays
Returns true if the two specified arrays of ints are equal to one another.
equals(short[], short[]) - Static method in class java.util.Arrays
Returns true if the two specified arrays of shorts are equal to one another.
equals(char[], char[]) - Static method in class java.util.Arrays
Returns true if the two specified arrays of chars are equal to one another.
equals(byte[], byte[]) - Static method in class java.util.Arrays
Returns true if the two specified arrays of bytes are equal to one another.
equals(boolean[], boolean[]) - Static method in class java.util.Arrays
Returns true if the two specified arrays of booleans are equal to one another.
equals(double[], double[]) - Static method in class java.util.Arrays
Returns true if the two specified arrays of doubles are equal to one another.
equals(float[], float[]) - Static method in class java.util.Arrays
Returns true if the two specified arrays of floats are equal to one another.
equals(Object[], Object[]) - Static method in class java.util.Arrays
Returns true if the two specified arrays of Objects are equal to one another.
equals(Object) - Method in class java.util.BitSet
Compares this object against the specified object.
equals(Object) - Method in class java.util.Calendar
Compares this Calendar to the specified Object.
equals(Object) - Method in interface java.util.Collection
Compares the specified object with this collection for equality.
equals(Object) - Method in interface java.util.Comparator
Indicates whether some other object is "equal to" this comparator.
equals(Object) - Method in class java.util.concurrent.ConcurrentHashMap
Compares the specified object with this map for equality.
equals(Object) - Method in class java.util.concurrent.ConcurrentHashMap.KeySetView
equals(Object) - Method in class java.util.concurrent.ConcurrentSkipListMap
Compares the specified object with this map for equality.
equals(Object) - Method in class java.util.concurrent.ConcurrentSkipListSet
Compares the specified object with this set for equality.
equals(Object) - Method in class java.util.concurrent.CopyOnWriteArrayList
Compares the specified object with this list for equality.
equals(Object) - Method in class java.util.concurrent.CopyOnWriteArraySet
Compares the specified object with this set for equality.
equals(Object) - Method in class java.util.Date
Compares two dates for equality.
equals(Object) - Method in class java.util.EnumMap
Compares the specified object with this map for equality.
equals(Object) - Method in class java.util.GregorianCalendar
Compares this GregorianCalendar to the specified Object.
equals(Object) - Method in class java.util.Hashtable
Compares the specified Object with this Map for equality, as per the definition in the Map interface.
equals(Object) - Method in class java.util.IdentityHashMap
Compares the specified object with this map for equality.
equals(Object) - Method in class java.util.jar.Attributes
Compares the specified Attributes object with this Map for equality.
equals(Object) - Method in class java.util.jar.Attributes.Name
Compares this attribute name to another for equality.
equals(Object) - Method in class java.util.jar.Manifest
Returns true if the specified Object is also a Manifest and has the same main Attributes and entries.
equals(Object) - Method in interface java.util.List
Compares the specified object with this list for equality.
equals(Object) - Method in class java.util.Locale
Returns true if this Locale is equal to another object.
equals(Object) - Method in class java.util.Locale.LanguageRange
Compares this object to the specified object.
equals(Object) - Method in class java.util.logging.Level
Compare two objects for value equality.
equals(Object) - Method in interface java.util.Map.Entry
Compares the specified object with this entry for equality.
equals(Object) - Method in interface java.util.Map
Compares the specified object with this map for equality.
equals(Object, Object) - Static method in class java.util.Objects
Returns true if the arguments are equal to each other and false otherwise.
equals(Object) - Method in class java.util.Optional
Indicates whether some other object is "equal to" this Optional.
equals(Object) - Method in class java.util.OptionalDouble
Indicates whether some other object is "equal to" this OptionalDouble.
equals(Object) - Method in class java.util.OptionalInt
Indicates whether some other object is "equal to" this OptionalInt.
equals(Object) - Method in class java.util.OptionalLong
Indicates whether some other object is "equal to" this OptionalLong.
equals(Object) - Method in class java.util.PropertyPermission
Checks two PropertyPermission objects for equality.
equals(Object) - Method in interface java.util.Set
Compares the specified object with this set for equality.
equals(Object) - Method in class java.util.SimpleTimeZone
Compares the equality of two SimpleTimeZone objects.
equals(Object) - Method in class java.util.UUID
Compares this object to the specified object.
equals(Object) - Method in class java.util.Vector
Compares the specified Object with this Vector for equality.
equals(DataFlavor) - Method in class javax.activation.ActivationDataFlavor
Compares the DataFlavor passed in with this DataFlavor; calls the isMimeTypeEqual method.
equals(Object) - Method in class javax.crypto.spec.RC2ParameterSpec
Tests for equality between the specified object and this object.
equals(Object) - Method in class javax.crypto.spec.RC5ParameterSpec
Tests for equality between the specified object and this object.
equals(Object) - Method in class javax.crypto.spec.SecretKeySpec
Tests for equality between the specified object and this object.
equals(Object) - Method in class javax.imageio.ImageTypeSpecifier
Returns true if the given Object is an ImageTypeSpecifier and has a SampleModel and ColorModel that are equal to those of this object.
equals(Object) - Method in interface javax.lang.model.element.Element
Returns true if the argument represents the same element as this, or false otherwise.
equals(Object) - Method in interface javax.lang.model.element.Name
Returns true if the argument represents the same name as this, and false otherwise.
equals(Object) - Method in interface javax.lang.model.type.TypeMirror
Obeys the general contract of Object.equals.
equals(Object) - Method in class javax.management.Attribute
Compares the current Attribute Object with another Attribute Object.
equals(Object) - Method in interface javax.management.Descriptor
Compares this descriptor to the given object.
equals(Object) - Method in class javax.management.ImmutableDescriptor
Compares this descriptor to the given object.
equals(Object) - Method in class javax.management.MBeanAttributeInfo
Compare this MBeanAttributeInfo to another.
equals(Object) - Method in class javax.management.MBeanConstructorInfo
Compare this MBeanConstructorInfo to another.
equals(Object) - Method in class javax.management.MBeanFeatureInfo
Compare this MBeanFeatureInfo to another.
equals(Object) - Method in class javax.management.MBeanInfo
Compare this MBeanInfo to another.
equals(Object) - Method in class javax.management.MBeanNotificationInfo
Compare this MBeanNotificationInfo to another.
equals(Object) - Method in class javax.management.MBeanOperationInfo
Compare this MBeanOperationInfo to another.
equals(Object) - Method in class javax.management.MBeanParameterInfo
Compare this MBeanParameterInfo to another.
equals(Object) - Method in class javax.management.MBeanPermission
Checks two MBeanPermission objects for equality.
equals(Object) - Method in class javax.management.MBeanServerPermission
Checks two MBeanServerPermission objects for equality.
equals(Object) - Method in class javax.management.modelmbean.DescriptorSupport
Compares this descriptor to the given object.
equals(Object) - Method in class javax.management.ObjectInstance
Compares the current object instance with another object instance.
equals(Object) - Method in class javax.management.ObjectName
Compares the current object name with another object name.
equals(Object) - Method in class javax.management.openmbean.ArrayType
Compares the specified obj parameter with this ArrayType instance for equality.
equals(Object) - Method in interface javax.management.openmbean.CompositeData
Compares the specified obj parameter with this CompositeData instance for equality.
equals(Object) - Method in class javax.management.openmbean.CompositeDataSupport
Compares the specified obj parameter with this CompositeDataSupport instance for equality.
equals(Object) - Method in class javax.management.openmbean.CompositeType
Compares the specified obj parameter with this CompositeType instance for equality.
equals(Object) - Method in interface javax.management.openmbean.OpenMBeanAttributeInfo
Compares the specified obj parameter with this OpenMBeanAttributeInfo instance for equality.
equals(Object) - Method in class javax.management.openmbean.OpenMBeanAttributeInfoSupport
Compares the specified obj parameter with this OpenMBeanAttributeInfoSupport instance for equality.
equals(Object) - Method in interface javax.management.openmbean.OpenMBeanConstructorInfo
Compares the specified obj parameter with this OpenMBeanConstructorInfo instance for equality.
equals(Object) - Method in class javax.management.openmbean.OpenMBeanConstructorInfoSupport
Compares the specified obj parameter with this OpenMBeanConstructorInfoSupport instance for equality.
equals(Object) - Method in interface javax.management.openmbean.OpenMBeanInfo
Compares the specified obj parameter with this OpenMBeanInfo instance for equality.
equals(Object) - Method in class javax.management.openmbean.OpenMBeanInfoSupport
Compares the specified obj parameter with this OpenMBeanInfoSupport instance for equality.
equals(Object) - Method in interface javax.management.openmbean.OpenMBeanOperationInfo
Compares the specified obj parameter with this OpenMBeanOperationInfo instance for equality.
equals(Object) - Method in class javax.management.openmbean.OpenMBeanOperationInfoSupport
Compares the specified obj parameter with this OpenMBeanOperationInfoSupport instance for equality.
equals(Object) - Method in interface javax.management.openmbean.OpenMBeanParameterInfo
Compares the specified obj parameter with this OpenMBeanParameterInfo instance for equality.
equals(Object) - Method in class javax.management.openmbean.OpenMBeanParameterInfoSupport
Compares the specified obj parameter with this OpenMBeanParameterInfoSupport instance for equality.
equals(Object) - Method in class javax.management.openmbean.OpenType
Compares the specified obj parameter with this open type instance for equality.
equals(Object) - Method in class javax.management.openmbean.SimpleType
Compares the specified obj parameter with this SimpleType instance for equality.
equals(Object) - Method in interface javax.management.openmbean.TabularData
Compares the specified obj parameter with this TabularData instance for equality.
equals(Object) - Method in class javax.management.openmbean.TabularDataSupport
Compares the specified obj parameter with this TabularDataSupport instance for equality.
equals(Object) - Method in class javax.management.openmbean.TabularType
Compares the specified obj parameter with this TabularType instance for equality.
equals(Object) - Method in class javax.management.remote.JMXPrincipal
Compares the specified Object with this JMXPrincipal for equality.
equals(Object) - Method in class javax.management.remote.JMXServiceURL
Indicates whether some other object is equal to this one.
equals(Object) - Method in class javax.naming.BinaryRefAddr
Determines whether obj is equal to this address.
equals(Object) - Method in class javax.naming.CompositeName
Determines whether two composite names are equal.
equals(Object) - Method in class javax.naming.CompoundName
Determines whether obj is syntactically equal to this compound name.
equals(Object) - Method in class javax.naming.directory.BasicAttribute
Determines whether obj is equal to this attribute.
equals(Object) - Method in class javax.naming.directory.BasicAttributes
Determines whether this BasicAttributes is equal to another Attributes Two Attributes are equal if they are both instances of Attributes, treat the case of attribute IDs the same way, and contain the same attributes.
equals(Object) - Method in class javax.naming.ldap.LdapName
Determines whether two LDAP names are equal.
equals(Object) - Method in class javax.naming.ldap.Rdn
Compares the specified Object with this Rdn for equality.
equals(Object) - Method in class javax.naming.RefAddr
Determines whether obj is equal to this RefAddr.
equals(Object) - Method in class javax.naming.Reference
Determines whether obj is a reference with the same addresses (in same order) as this reference.
equals(Object) - Method in class javax.net.ssl.SNIHostName
Compares this server name to the specified object.
equals(Object) - Method in class javax.net.ssl.SNIServerName
Indicates whether some other object is "equal to" this server name.
equals(Object) - Method in interface javax.print.attribute.AttributeSet
Compares the specified object with this attribute set for equality.
equals(Object) - Method in class javax.print.attribute.DateTimeSyntax
Returns whether this date-time attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.HashAttributeSet
Compares the specified object with this attribute set for equality.
equals(Object) - Method in class javax.print.attribute.IntegerSyntax
Returns whether this integer attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.ResolutionSyntax
Returns whether this resolution attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.SetOfIntegerSyntax
Returns whether this set-of-integer attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.Size2DSyntax
Returns whether this two-dimensional size attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.Copies
Returns whether this copies attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.CopiesSupported
Returns whether this copies supported attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.DateTimeAtCompleted
Returns whether this date-time at completed attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.DateTimeAtCreation
Returns whether this date-time at creation attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.DateTimeAtProcessing
Returns whether this date-time at processing attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.Destination
Returns whether this destination attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.DocumentName
Returns whether this document name attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.JobHoldUntil
Returns whether this job hold until attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.JobImpressions
Returns whether this job impressions attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.JobImpressionsCompleted
Returns whether this job impressions completed attribute is equivalent tp the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.JobImpressionsSupported
Returns whether this job impressions supported attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.JobKOctets
Returns whether this job K octets attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.JobKOctetsProcessed
Returns whether this job K octets processed attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.JobKOctetsSupported
Returns whether this job K octets supported attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.JobMediaSheets
Returns whether this job media sheets attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.JobMediaSheetsCompleted
Returns whether this job media sheets completed attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.JobMediaSheetsSupported
Returns whether this job media sheets supported attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.JobMessageFromOperator
Returns whether this job message from operator attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.JobName
Returns whether this job name attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.JobOriginatingUserName
Returns whether this job originating user name attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.JobPriority
Returns whether this job priority attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.JobPrioritySupported
Returns whether this job priority supported attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.Media
Returns whether this media attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.MediaPrintableArea
Returns whether this media margins attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.MediaSize
Returns whether this media size attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.NumberOfDocuments
Returns whether this number of documents attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.NumberOfInterveningJobs
Returns whether this number of intervening jobs attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.NumberUp
Returns whether this number up attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.NumberUpSupported
Returns whether this number up supported attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.OutputDeviceAssigned
Returns whether this output device assigned attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.PageRanges
Returns whether this page ranges attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.PagesPerMinute
Returns whether this pages per minute attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.PagesPerMinuteColor
Returns whether this pages per minute color attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.PrinterInfo
Returns whether this printer info attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.PrinterLocation
Returns whether this printer location attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.PrinterMakeAndModel
Returns whether this printer make and model attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.PrinterMessageFromOperator
Returns whether this printer message from operator attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.PrinterMoreInfo
Returns whether this printer more info attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.PrinterMoreInfoManufacturer
Returns whether this printer more info manufacturer attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.PrinterName
Returns whether this printer name attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.PrinterResolution
Returns whether this printer resolution attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.PrinterURI
Returns whether this printer name attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.QueuedJobCount
Returns whether this queued job count attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.standard.RequestingUserName
Returns whether this requesting user name attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.TextSyntax
Returns whether this text attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.attribute.URISyntax
Returns whether this URI attribute is equivalent to the passed in object.
equals(Object) - Method in class javax.print.DocFlavor
Determines if this doc flavor object is equal to the given object.
equals(Object) - Method in interface javax.print.PrintService
Determines if two services are referring to the same underlying service.
equals(Object) - Method in class javax.rmi.CORBA.Stub
Compares two stubs for equality.
equals(Stub, Object) - Method in interface javax.rmi.CORBA.StubDelegate
Delegation call for Stub.equals(java.lang.Object).
equals(Object) - Method in class javax.rmi.ssl.SslRMIClientSocketFactory
Indicates whether some other object is "equal to" this one.
equals(Object) - Method in class javax.rmi.ssl.SslRMIServerSocketFactory
Indicates whether some other object is "equal to" this one.
equals(Object) - Method in class javax.security.auth.kerberos.DelegationPermission
Checks two DelegationPermission objects for equality.
equals(Object) - Method in class javax.security.auth.kerberos.KerberosKey
Compares the specified Object with this KerberosKey for equality.
equals(Object) - Method in class javax.security.auth.kerberos.KerberosPrincipal
Compares the specified Object with this Principal for equality.
equals(Object) - Method in class javax.security.auth.kerberos.KerberosTicket
Compares the specified Object with this KerberosTicket for equality.
equals(Object) - Method in class javax.security.auth.kerberos.KeyTab
Compares the specified Object with this KeyTab for equality.
equals(Object) - Method in class javax.security.auth.kerberos.ServicePermission
Checks two ServicePermission objects for equality.
equals(Object) - Method in class javax.security.auth.PrivateCredentialPermission
Checks two PrivateCredentialPermission objects for equality.
equals(Object) - Method in class javax.security.auth.Subject
Compares the specified Object with this Subject for equality.
equals(Object) - Method in class javax.security.auth.x500.X500Principal
Compares the specified Object with this X500Principal for equality.
equals(Object) - Method in class javax.security.cert.Certificate
Compares this certificate for equality with the specified object.
equals(Object) - Method in class javax.sound.midi.MidiDevice.Info
Reports whether two objects are equal.
equals(Object) - Method in class javax.sound.midi.Sequencer.SyncMode
Determines whether two objects are equal.
equals(Object) - Method in class javax.sound.sampled.AudioFileFormat.Type
Finalizes the equals method
equals(Object) - Method in class javax.sound.sampled.AudioFormat.Encoding
Finalizes the equals method
equals(Object) - Method in class javax.sound.sampled.Control.Type
Finalizes the equals method
equals(Object) - Method in class javax.sound.sampled.LineEvent.Type
Indicates whether the specified object is equal to this event type, returning true if the objects are identical.
equals(Object) - Method in class javax.sound.sampled.Mixer.Info
Indicates whether two info objects are equal, returning true if they are identical.
equals(Object) - Method in class javax.sound.sampled.Port.Info
Finalizes the equals method
equals(Object) - Method in class javax.sound.sampled.ReverbType
Indicates whether the specified object is equal to this reverb type, returning true if the objects are identical.
equals(Object) - Method in class javax.sql.rowset.serial.SerialArray
Compares this SerialArray to the specified object.
equals(Object) - Method in class javax.sql.rowset.serial.SerialBlob
Compares this SerialBlob to the specified object.
equals(Object) - Method in class javax.sql.rowset.serial.SerialClob
Compares this SerialClob to the specified object.
equals(Object) - Method in class javax.sql.rowset.serial.SerialDatalink
Compares this SerialDatalink to the specified object.
equals(Object) - Method in class javax.sql.rowset.serial.SerialJavaObject
Compares this SerialJavaObject to the specified object.
equals(Object) - Method in class javax.sql.rowset.serial.SerialRef
Compares this SerialRef to the specified object.
equals(Object) - Method in class javax.sql.rowset.serial.SerialStruct
Compares this SerialStruct to the specified object.
equals(Object) - Method in class javax.swing.RowSorter.SortKey
Returns true if this object equals the specified object.
equals(Object) - Method in class javax.swing.text.DefaultCaret
Compares this object to the specified object.
equals(Object) - Method in class javax.swing.text.html.HTML.UnknownTag
Compares this object to the specified object.
equals(Object) - Method in class javax.swing.text.SimpleAttributeSet
Compares this object to the specified object.
equals(Object) - Method in class javax.swing.text.StyleContext.SmallAttributeSet
Compares this object to the specified object.
equals(Object) - Method in class javax.swing.text.TabSet
Indicates whether this TabSet is equal to another one.
equals(Object) - Method in class javax.swing.text.TabStop
Returns true if the tabs are equal.
equals(Object) - Method in class javax.swing.tree.TreePath
Compares this TreePath to the specified object.
equals(Object) - Method in class javax.xml.datatype.Duration
Checks if this duration object has the same duration as another Duration object.
equals(Object) - Method in class javax.xml.datatype.XMLGregorianCalendar
Compares this calendar to the specified object.
equals(Object) - Method in class javax.xml.namespace.QName
Test this QName for equality with another Object.
equals(Object) - Method in class org.ietf.jgss.ChannelBinding
Compares two instances of ChannelBinding.
equals(Object) - Method in interface org.ietf.jgss.GSSCredential
Tests if this GSSCredential asserts the same entity as the supplied object.
equals(GSSName) - Method in interface org.ietf.jgss.GSSName
Compares two GSSName objects to determine if they refer to the same entity.
equals(Object) - Method in interface org.ietf.jgss.GSSName
Compares this GSSName object to another Object that might be a GSSName.
equals(Object) - Method in class org.ietf.jgss.Oid
Tests if two Oid objects represent the same Object identifier value.
equals(Object, Object) - Method in class org.omg.CORBA.portable.Delegate
Provides the implementation to override the equals(java.lang.Object obj) method of the delegating CORBA object.
equals(Object) - Method in class org.omg.CORBA.portable.ObjectImpl
Compares this ObjectImpl object with the given one for equality.
equalsIgnoreCase(String) - Method in class java.lang.String
Compares this String to another String, ignoring case considerations.
equivalent(TypeCode) - Method in class org.omg.CORBA.TypeCode
Tests to see if the given TypeCode object is equivalent to this TypeCode object.
ERA - Static variable in class java.text.DateFormat.Field
Constant identifying the era field.
Era - Interface in java.time.chrono
An era of the time-line.
ERA - Static variable in class java.util.Calendar
Field number for get and set indicating the era, e.g., AD or BC in the Julian calendar.
ERA_FIELD - Static variable in class java.text.DateFormat
Useful constant for ERA field alignment.
eraOf(int) - Method in interface java.time.chrono.Chronology
Creates the chronology era object from the numeric value.
eraOf(int) - Method in class java.time.chrono.HijrahChronology
eraOf(int) - Method in class java.time.chrono.IsoChronology
eraOf(int) - Method in class java.time.chrono.JapaneseChronology
Returns the calendar system era object from the given numeric value.
eraOf(int) - Method in class java.time.chrono.MinguoChronology
eraOf(int) - Method in class java.time.chrono.ThaiBuddhistChronology
eras() - Method in interface java.time.chrono.Chronology
Gets the list of eras for the chronology.
eras() - Method in class java.time.chrono.HijrahChronology
eras() - Method in class java.time.chrono.IsoChronology
eras() - Method in class java.time.chrono.JapaneseChronology
eras() - Method in class java.time.chrono.MinguoChronology
eras() - Method in class java.time.chrono.ThaiBuddhistChronology
erase() - Method in class java.lang.invoke.MethodType
Erases all reference types to Object.
erasure(TypeMirror) - Method in interface javax.lang.model.util.Types
Returns the erasure of a type.
err - Static variable in class java.io.FileDescriptor
A handle to the standard error stream.
err - Static variable in class java.lang.System
The "standard" error output stream.
ERROR - Static variable in interface java.awt.image.ImageObserver
This flag in the infoflags argument to imageUpdate indicates that an image which was being tracked asynchronously has encountered an error.
Error - Error in java.lang
An Error is a subclass of Throwable that indicates serious problems that a reasonable application should not try to catch.
Error() - Constructor for error java.lang.Error
Constructs a new error with null as its detail message.
Error(String) - Constructor for error java.lang.Error
Constructs a new error with the specified detail message.
Error(String, Throwable) - Constructor for error java.lang.Error
Constructs a new error with the specified detail message and cause.
Error(Throwable) - Constructor for error java.lang.Error
Constructs a new error with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
Error(String, Throwable, boolean, boolean) - Constructor for error java.lang.Error
Constructs a new error with the specified detail message, cause, suppression enabled or disabled, and writable stack trace enabled or disabled.
ERROR - Static variable in interface java.util.jar.Pack200.Packer
The string "error", a possible value for certain properties.
error(String, Exception, int) - Method in class java.util.logging.ErrorManager
The error method is called when a Handler failure occurs.
ERROR - Static variable in class javax.print.attribute.standard.Severity
Indicates that the PrinterStateReason is an "error" (most severe).
ERROR - Static variable in class javax.security.auth.callback.ConfirmationCallback
ERROR message type.
ERROR - Static variable in class javax.security.auth.callback.TextOutputCallback
Error message.
error(String, String, String, String) - Method in class javax.swing.text.html.parser.Parser
Invoke the error handler.
error(String, String, String) - Method in class javax.swing.text.html.parser.Parser
error(String, String) - Method in class javax.swing.text.html.parser.Parser
error(String) - Method in class javax.swing.text.html.parser.Parser
ERROR - Static variable in interface javax.xml.bind.ValidationEvent
Conditions that correspond to the definition of "error" in section 1.2 of the W3C XML 1.0 Recommendation
error(TransformerException) - Method in interface javax.xml.transform.ErrorListener
Receive notification of a recoverable error.
error(SAXParseException) - Method in interface org.xml.sax.ErrorHandler
Receive notification of a recoverable error.
error(SAXParseException) - Method in class org.xml.sax.HandlerBase
Deprecated.
Receive notification of a recoverable parser error.
error(SAXParseException) - Method in class org.xml.sax.helpers.DefaultHandler
Receive notification of a recoverable parser error.
error(SAXParseException) - Method in class org.xml.sax.helpers.XMLFilterImpl
Filter an error event.
ERROR_DIALOG - Static variable in class javax.swing.JRootPane
Constant used for the windowDecorationStyle property.
ERROR_MESSAGE - Static variable in class javax.swing.JOptionPane
Used for error messages.
ERROR_OPTION - Static variable in class javax.swing.JFileChooser
Return value if an error occurred.
errorCode - Variable in exception javax.transaction.xa.XAException
The error code with which to create the SystemException.
ERRORED - Static variable in class java.awt.MediaTracker
Flag indicating that the downloading of media encountered an error.
ErrorHandler - Interface in org.xml.sax
Basic interface for SAX error handlers.
ErrorListener - Interface in javax.xml.transform
To provide customized error handling, implement this interface and use the setErrorListener method to register an instance of the implmentation with the Transformer.
ErrorManager - Class in java.util.logging
ErrorManager objects can be attached to Handlers to process any error that occurs on a Handler during Logging.
ErrorManager() - Constructor for class java.util.logging.ErrorManager
errorRaised() - Method in interface javax.annotation.processing.RoundEnvironment
Returns true if an error was raised in the prior round of processing; returns false otherwise.
ErrorType - Interface in javax.lang.model.type
Represents a class or interface type that cannot be properly modeled.
errorWriter - Variable in class javax.script.SimpleScriptContext
This is the writer to be used to output errors from scripts.
ESCAPE - Static variable in class java.awt.Event
The Escape key.
escapeValue(Object) - Static method in class javax.naming.ldap.Rdn
Given the value of an attribute, returns a string escaped according to the rules specified in RFC 2253.
establish_components(IORInfo) - Method in interface org.omg.PortableInterceptor.IORInterceptorOperations
A server side ORB calls the establish_components operation on all registered IORInterceptor instances when it is assembling the list of components that will be included in the profile or profiles of an object reference.
estimateSize() - Method in interface java.util.Spliterator
Returns an estimate of the number of elements that would be encountered by a Spliterator.forEachRemaining(java.util.function.Consumer<? super T>) traversal, or returns Long.MAX_VALUE if infinite, unknown, or too expensive to compute.
estimateSize() - Method in class java.util.Spliterators.AbstractDoubleSpliterator
Returns an estimate of the number of elements that would be encountered by a Spliterator.forEachRemaining(java.util.function.Consumer<? super T>) traversal, or returns Long.MAX_VALUE if infinite, unknown, or too expensive to compute.
estimateSize() - Method in class java.util.Spliterators.AbstractIntSpliterator
Returns an estimate of the number of elements that would be encountered by a Spliterator.forEachRemaining(java.util.function.Consumer<? super T>) traversal, or returns Long.MAX_VALUE if infinite, unknown, or too expensive to compute.
estimateSize() - Method in class java.util.Spliterators.AbstractLongSpliterator
Returns an estimate of the number of elements that would be encountered by a Spliterator.forEachRemaining(java.util.function.Consumer<? super T>) traversal, or returns Long.MAX_VALUE if infinite, unknown, or too expensive to compute.
estimateSize() - Method in class java.util.Spliterators.AbstractSpliterator
Returns an estimate of the number of elements that would be encountered by a Spliterator.forEachRemaining(java.util.function.Consumer<? super T>) traversal, or returns Long.MAX_VALUE if infinite, unknown, or too expensive to compute.
EtchedBorder - Class in javax.swing.border
A class which implements a simple etched border which can either be etched-in or etched-out.
EtchedBorder() - Constructor for class javax.swing.border.EtchedBorder
Creates a lowered etched border whose colors will be derived from the background color of the component passed into the paintBorder method.
EtchedBorder(int) - Constructor for class javax.swing.border.EtchedBorder
Creates an etched border with the specified etch-type whose colors will be derived from the background color of the component passed into the paintBorder method.
EtchedBorder(Color, Color) - Constructor for class javax.swing.border.EtchedBorder
Creates a lowered etched border with the specified highlight and shadow colors.
EtchedBorder(int, Color, Color) - Constructor for class javax.swing.border.EtchedBorder
Creates an etched border with the specified etch-type, highlight and shadow colors.
EtchedBorderUIResource() - Constructor for class javax.swing.plaf.BorderUIResource.EtchedBorderUIResource
EtchedBorderUIResource(int) - Constructor for class javax.swing.plaf.BorderUIResource.EtchedBorderUIResource
EtchedBorderUIResource(Color, Color) - Constructor for class javax.swing.plaf.BorderUIResource.EtchedBorderUIResource
EtchedBorderUIResource(int, Color, Color) - Constructor for class javax.swing.plaf.BorderUIResource.EtchedBorderUIResource
etchType - Variable in class javax.swing.border.EtchedBorder
etherealize(byte[], POA, Servant, boolean, boolean) - Method in class org.omg.PortableServer._ServantActivatorStub
This operation is invoked whenever a servant for an object is deactivated, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
etherealize(byte[], POA, Servant, boolean, boolean) - Method in interface org.omg.PortableServer.ServantActivatorOperations
This operation is invoked whenever a servant for an object is deactivated, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
ETHIOPIC - Static variable in class java.awt.font.NumericShaper
Identifies the ETHIOPIC range and decimal base.
ETHIOPIC - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Ethiopic" Unicode character block.
ETHIOPIC_EXTENDED - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Ethiopic Extended" Unicode character block.
ETHIOPIC_EXTENDED_A - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Ethiopic Extended-A" Unicode character block.
ETHIOPIC_SUPPLEMENT - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Ethiopic Supplement" Unicode character block.
EUROPEAN - Static variable in class java.awt.font.NumericShaper
Identifies the Latin-1 (European) and extended range, and Latin-1 (European) decimal base.
eval(Reader, Bindings) - Method in class javax.script.AbstractScriptEngine
eval(Reader, Bindings) calls the abstract eval(Reader, ScriptContext) method, passing it a ScriptContext whose Reader, Writers and Bindings for scopes other that ENGINE_SCOPE are identical to those members of the protected context field.
eval(String, Bindings) - Method in class javax.script.AbstractScriptEngine
Same as eval(Reader, Bindings) except that the abstract eval(String, ScriptContext) is used.
eval(Reader) - Method in class javax.script.AbstractScriptEngine
eval(Reader) calls the abstract eval(Reader, ScriptContext) passing the value of the context field.
eval(String) - Method in class javax.script.AbstractScriptEngine
Same as eval(Reader) except that the abstract eval(String, ScriptContext) is used.
eval(ScriptContext) - Method in class javax.script.CompiledScript
Executes the program stored in this CompiledScript object.
eval(Bindings) - Method in class javax.script.CompiledScript
Executes the program stored in the CompiledScript object using the supplied Bindings of attributes as the ENGINE_SCOPE of the associated ScriptEngine during script execution.
eval() - Method in class javax.script.CompiledScript
Executes the program stored in the CompiledScript object.
eval(String, ScriptContext) - Method in interface javax.script.ScriptEngine
Causes the immediate execution of the script whose source is the String passed as the first argument.
eval(Reader, ScriptContext) - Method in interface javax.script.ScriptEngine
Same as eval(String, ScriptContext) where the source of the script is read from a Reader.
eval(String) - Method in interface javax.script.ScriptEngine
Executes the specified script.
eval(Reader) - Method in interface javax.script.ScriptEngine
Same as eval(String) except that the source of the script is provided as a Reader
eval(String, Bindings) - Method in interface javax.script.ScriptEngine
Executes the script using the Bindings argument as the ENGINE_SCOPE Bindings of the ScriptEngine during the script execution.
eval(Reader, Bindings) - Method in interface javax.script.ScriptEngine
Same as eval(String, Bindings) except that the source of the script is provided as a Reader.
evaluate(RowSet) - Method in interface javax.sql.rowset.Predicate
This method is typically called a FilteredRowSet object internal methods (not public) that control the RowSet object's cursor moving from row to the next.
evaluate(Object, int) - Method in interface javax.sql.rowset.Predicate
This method is called by a FilteredRowSet object to check whether the value lies between the filtering criterion (or criteria if multiple constraints exist) set using the setFilter() method.
evaluate(Object, String) - Method in interface javax.sql.rowset.Predicate
This method is called by the FilteredRowSet object to check whether the value lies between the filtering criteria set using the setFilter method.
evaluate(String, Object, QName) - Method in interface javax.xml.xpath.XPath
Evaluate an XPath expression in the specified context and return the result as the specified type.
evaluate(String, Object) - Method in interface javax.xml.xpath.XPath
Evaluate an XPath expression in the specified context and return the result as a String.
evaluate(String, InputSource, QName) - Method in interface javax.xml.xpath.XPath
Evaluate an XPath expression in the context of the specified InputSource and return the result as the specified type.
evaluate(String, InputSource) - Method in interface javax.xml.xpath.XPath
Evaluate an XPath expression in the context of the specified InputSource and return the result as a String.
evaluate(Object, QName) - Method in interface javax.xml.xpath.XPathExpression
Evaluate the compiled XPath expression in the specified context and return the result as the specified type.
evaluate(Object) - Method in interface javax.xml.xpath.XPathExpression
Evaluate the compiled XPath expression in the specified context and return the result as a String.
evaluate(InputSource, QName) - Method in interface javax.xml.xpath.XPathExpression
Evaluate the compiled XPath expression in the context of the specified InputSource and return the result as the specified type.
evaluate(InputSource) - Method in interface javax.xml.xpath.XPathExpression
Evaluate the compiled XPath expression in the context of the specified InputSource and return the result as a String.
evaluate(List) - Method in interface javax.xml.xpath.XPathFunction
Evaluate the function with the specified arguments.
evaluateChallenge(byte[]) - Method in interface javax.security.sasl.SaslClient
Evaluates the challenge data and generates a response.
evaluateResponse(byte[]) - Method in interface javax.security.sasl.SaslServer
Evaluates the response data and generates a challenge.
Event - Class in java.awt
NOTE: The Event class is obsolete and is available only for backwards compatibility.
Event(Object, long, int, int, int, int, int, Object) - Constructor for class java.awt.Event
NOTE: The Event class is obsolete and is available only for backwards compatibility.
Event(Object, long, int, int, int, int, int) - Constructor for class java.awt.Event
NOTE: The Event class is obsolete and is available only for backwards compatibility.
Event(Object, int, Object) - Constructor for class java.awt.Event
NOTE: The Event class is obsolete and is available only for backwards compatibility.
event - Variable in exception javax.swing.tree.ExpandVetoException
The event that the exception was created for.
Event - Interface in org.w3c.dom.events
The Event interface is used to provide contextual information about an event to the handler processing the event.
EventContext - Interface in javax.naming.event
Contains methods for registering/deregistering listeners to be notified of events fired when objects named in a context changes.
EventDirContext - Interface in javax.naming.event
Contains methods for registering listeners to be notified of events fired when objects named in a directory context changes.
eventDispatched(AWTEvent) - Method in interface java.awt.event.AWTEventListener
Invoked when an event is dispatched in the AWT.
eventDispatched(AWTEvent) - Method in class java.awt.event.AWTEventListenerProxy
Forwards the AWT event to the listener delegate.
eventDispatched(AWTEvent, JLayer<? extends V>) - Method in class javax.swing.plaf.LayerUI
Processes AWTEvents for JLayer and all its descendants to this LayerUI instance.
EventException - Exception in org.w3c.dom.events
Event operations may throw an EventException as specified in their method descriptions.
EventException(short, String) - Constructor for exception org.w3c.dom.events.EventException
EventFilter - Interface in javax.xml.stream
This interface declares a simple filter interface that one can create to filter XMLEventReaders
EventHandler - Class in java.beans
The EventHandler class provides support for dynamically generating event listeners whose methods execute a simple statement involving an incoming event object and a target object.
EventHandler(Object, String, String, String) - Constructor for class java.beans.EventHandler
Creates a new EventHandler object; you generally use one of the create methods instead of invoking this constructor directly.
EventListener - Interface in java.util
A tagging interface that all event listener interfaces must extend.
EventListener - Interface in org.w3c.dom.events
The EventListener interface is the primary method for handling events.
EventListenerList - Class in javax.swing.event
A class that holds a list of EventListeners.
EventListenerList() - Constructor for class javax.swing.event.EventListenerList
EventListenerProxy<T extends EventListener> - Class in java.util
An abstract wrapper class for an EventListener class which associates a set of additional parameters with the listener.
EventListenerProxy(T) - Constructor for class java.util.EventListenerProxy
Creates a proxy for the specified listener.
EventObject - Class in java.util
The root class from which all event state objects shall be derived.
EventObject(Object) - Constructor for class java.util.EventObject
Constructs a prototypical Event.
EventQueue - Class in java.awt
EventQueue is a platform-independent class that queues events, both from the underlying peer classes and from trusted application classes.
EventQueue() - Constructor for class java.awt.EventQueue
EventReaderDelegate - Class in javax.xml.stream.util
This is the base class for deriving an XMLEventReader filter.
EventReaderDelegate() - Constructor for class javax.xml.stream.util.EventReaderDelegate
Construct an empty filter with no parent.
EventReaderDelegate(XMLEventReader) - Constructor for class javax.xml.stream.util.EventReaderDelegate
Construct an filter with the specified parent.
events - Variable in class java.awt.dnd.DragGestureRecognizer
The list of events (in order) that the DragGestureRecognizer "recognized" as a "gesture" that triggers a drag.
EventSetDescriptor - Class in java.beans
An EventSetDescriptor describes a group of events that a given Java bean fires.
EventSetDescriptor(Class<?>, String, Class<?>, String) - Constructor for class java.beans.EventSetDescriptor
Creates an EventSetDescriptor assuming that you are following the most simple standard design pattern where a named event "fred" is (1) delivered as a call on the single method of interface FredListener, (2) has a single argument of type FredEvent, and (3) where the FredListener may be registered with a call on an addFredListener method of the source component and removed with a call on a removeFredListener method.
EventSetDescriptor(Class<?>, String, Class<?>, String[], String, String) - Constructor for class java.beans.EventSetDescriptor
Creates an EventSetDescriptor from scratch using string names.
EventSetDescriptor(Class<?>, String, Class<?>, String[], String, String, String) - Constructor for class java.beans.EventSetDescriptor
This constructor creates an EventSetDescriptor from scratch using string names.
EventSetDescriptor(String, Class<?>, Method[], Method, Method) - Constructor for class java.beans.EventSetDescriptor
Creates an EventSetDescriptor from scratch using java.lang.reflect.Method and java.lang.Class objects.
EventSetDescriptor(String, Class<?>, Method[], Method, Method, Method) - Constructor for class java.beans.EventSetDescriptor
This constructor creates an EventSetDescriptor from scratch using java.lang.reflect.Method and java.lang.Class objects.
EventSetDescriptor(String, Class<?>, MethodDescriptor[], Method, Method) - Constructor for class java.beans.EventSetDescriptor
Creates an EventSetDescriptor from scratch using java.lang.reflect.MethodDescriptor and java.lang.Class objects.
EventTarget - Interface in org.w3c.dom.events
The EventTarget interface is implemented by all Nodes in an implementation which supports the DOM Event Model.
eventTypeEnabled(int) - Method in class java.awt.ScrollPane
If wheel scrolling is enabled, we return true for MouseWheelEvents
evt - Variable in class java.awt.Event
The next event.
exactInvoker(MethodType) - Static method in class java.lang.invoke.MethodHandles
Produces a special invoker method handle which can be used to invoke any method handle of the given type, as if by invokeExact.
examineAllHeaderElements() - Method in interface javax.xml.soap.SOAPHeader
Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object.
examineHeaderElements(String) - Method in interface javax.xml.soap.SOAPHeader
Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor.
examineMustUnderstandHeaderElements(String) - Method in interface javax.xml.soap.SOAPHeader
Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor and that have a MustUnderstand attribute whose value is equivalent to true.
ExcC14NParameterSpec - Class in javax.xml.crypto.dsig.spec
Parameters for the W3C Recommendation: Exclusive XML Canonicalization (C14N) algorithm.
ExcC14NParameterSpec() - Constructor for class javax.xml.crypto.dsig.spec.ExcC14NParameterSpec
Creates a ExcC14NParameterSpec with an empty prefix list.
ExcC14NParameterSpec(List) - Constructor for class javax.xml.crypto.dsig.spec.ExcC14NParameterSpec
Creates a ExcC14NParameterSpec with the specified list of prefixes.
ExcellentBreakWeight - Static variable in class javax.swing.text.View
The weight to indicate a view supports breaking, and this represents a very attractive place to break.
except(Any) - Method in class org.omg.CORBA.ServerRequest
Deprecated.
use set_exception()
except - Variable in exception org.omg.CORBA.UnknownUserException
The Any instance that contains the actual user exception thrown by the server.
Exception - Exception in java.lang
The class Exception and its subclasses are a form of Throwable that indicates conditions that a reasonable application might want to catch.
Exception() - Constructor for exception java.lang.Exception
Constructs a new exception with null as its detail message.
Exception(String) - Constructor for exception java.lang.Exception
Constructs a new exception with the specified detail message.
Exception(String, Throwable) - Constructor for exception java.lang.Exception
Constructs a new exception with the specified detail message and cause.
Exception(Throwable) - Constructor for exception java.lang.Exception
Constructs a new exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
Exception(String, Throwable, boolean, boolean) - Constructor for exception java.lang.Exception
Constructs a new exception with the specified detail message, cause, suppression enabled or disabled, and writable stack trace enabled or disabled.
exception() - Method in class org.omg.CORBA.Environment
Retrieves the exception in this Environment object.
exception(Exception) - Method in class org.omg.CORBA.Environment
Inserts the given exception into this Environment object.
exceptionally(Function<Throwable, ? extends T>) - Method in class java.util.concurrent.CompletableFuture
Returns a new CompletableFuture that is completed when this CompletableFuture completes, with the result of the given function of the exception triggering this CompletableFuture's completion when it completes exceptionally; otherwise, if this CompletableFuture completes normally, then the returned CompletableFuture also completes normally with the same value.
exceptionally(Function<Throwable, ? extends T>) - Method in interface java.util.concurrent.CompletionStage
Returns a new CompletionStage that, when this stage completes exceptionally, is executed with this stage's exception as the argument to the supplied function.
ExceptionDetailMessage - Interface in org.omg.IOP
org/omg/IOP/ExceptionDetailMessage.java .
ExceptionInInitializerError - Error in java.lang
Signals that an unexpected exception has occurred in a static initializer.
ExceptionInInitializerError() - Constructor for error java.lang.ExceptionInInitializerError
Constructs an ExceptionInInitializerError with null as its detail message string and with no saved throwable object.
ExceptionInInitializerError(Throwable) - Constructor for error java.lang.ExceptionInInitializerError
Constructs a new ExceptionInInitializerError class by saving a reference to the Throwable object thrown for later retrieval by the ExceptionInInitializerError.getException() method.
ExceptionInInitializerError(String) - Constructor for error java.lang.ExceptionInInitializerError
Constructs an ExceptionInInitializerError with the specified detail message string.
ExceptionList - Class in org.omg.CORBA
An object used in Request operations to describe the exceptions that can be thrown by a method.
ExceptionList() - Constructor for class org.omg.CORBA.ExceptionList
ExceptionListener - Interface in java.beans
An ExceptionListener is notified of internal exceptions.
exceptions() - Method in class org.omg.CORBA.Request
Retrieves the ExceptionList object for this request.
exceptions() - Method in interface org.omg.PortableInterceptor.RequestInfoOperations
Returns an array of TypeCode objects describing the TypeCodes of the user exceptions that this operation invocation may throw.
exceptionThrown(Exception) - Method in interface java.beans.ExceptionListener
This method is called when a recoverable exception has been caught.
exchange(V) - Method in class java.util.concurrent.Exchanger
Waits for another thread to arrive at this exchange point (unless the current thread is interrupted), and then transfers the given object to it, receiving its object in return.
exchange(V, long, TimeUnit) - Method in class java.util.concurrent.Exchanger
Waits for another thread to arrive at this exchange point (unless the current thread is interrupted or the specified waiting time elapses), and then transfers the given object to it, receiving its object in return.
Exchanger<V> - Class in java.util.concurrent
A synchronization point at which threads can pair and swap elements within pairs.
Exchanger() - Constructor for class java.util.concurrent.Exchanger
Creates a new Exchanger.
exclusions - Variable in class javax.swing.text.html.parser.Element
EXCLUSIVE - Static variable in interface javax.xml.crypto.dsig.CanonicalizationMethod
The Exclusive Canonical XML (without comments) canonicalization method algorithm URI.
EXCLUSIVE_WITH_COMMENTS - Static variable in interface javax.xml.crypto.dsig.CanonicalizationMethod
The Exclusive Canonical XML with comments canonicalization method algorithm URI.
exclusiveOr(Area) - Method in class java.awt.geom.Area
Sets the shape of this Area to be the combined area of its current shape and the shape of the specified Area, minus their intersection.
exec(String) - Method in class java.lang.Runtime
Executes the specified string command in a separate process.
exec(String, String[]) - Method in class java.lang.Runtime
Executes the specified string command in a separate process with the specified environment.
exec(String, String[], File) - Method in class java.lang.Runtime
Executes the specified string command in a separate process with the specified environment and working directory.
exec(String[]) - Method in class java.lang.Runtime
Executes the specified command and arguments in a separate process.
exec(String[], String[]) - Method in class java.lang.Runtime
Executes the specified command and arguments in a separate process with the specified environment.
exec(String[], String[], File) - Method in class java.lang.Runtime
Executes the specified command and arguments in a separate process with the specified environment and working directory.
exec() - Method in class java.util.concurrent.CountedCompleter
Implements execution conventions for CountedCompleters.
exec() - Method in class java.util.concurrent.ForkJoinTask
Immediately performs the base action of this task and returns true if, upon return from this method, this task is guaranteed to have completed normally.
exec() - Method in class java.util.concurrent.RecursiveAction
Implements execution conventions for RecursiveActions.
exec() - Method in class java.util.concurrent.RecursiveTask
Implements execution conventions for RecursiveTask.
Executable - Class in java.lang.reflect
A shared superclass for the common functionality of Method and Constructor.
ExecutableElement - Interface in javax.lang.model.element
Represents a method, constructor, or initializer (static or instance) of a class or interface, including annotation type elements.
ExecutableType - Interface in javax.lang.model.type
Represents the type of an executable.
execute() - Method in class java.beans.Expression
The execute method finds a method whose name is the same as the methodName property, and invokes the method on the target.
execute() - Method in class java.beans.Statement
The execute method finds a method whose name is the same as the methodName property, and invokes the method on the target.
execute() - Method in interface java.sql.PreparedStatement
Executes the SQL statement in this PreparedStatement object, which may be any kind of SQL statement.
execute(String) - Method in interface java.sql.Statement
Executes the given SQL statement, which may return multiple results.
execute(String, int) - Method in interface java.sql.Statement
Executes the given SQL statement, which may return multiple results, and signals the driver that any auto-generated keys should be made available for retrieval.
execute(String, int[]) - Method in interface java.sql.Statement
Executes the given SQL statement, which may return multiple results, and signals the driver that the auto-generated keys indicated in the given array should be made available for retrieval.
execute(String, String[]) - Method in interface java.sql.Statement
Executes the given SQL statement, which may return multiple results, and signals the driver that the auto-generated keys indicated in the given array should be made available for retrieval.
execute(Runnable) - Method in interface java.util.concurrent.Executor
Executes the given command at some time in the future.
execute(ForkJoinTask<?>) - Method in class java.util.concurrent.ForkJoinPool
Arranges for (asynchronous) execution of the given task.
execute(Runnable) - Method in class java.util.concurrent.ForkJoinPool
execute(Runnable) - Method in class java.util.concurrent.ScheduledThreadPoolExecutor
Executes command with zero required delay.
execute(Runnable) - Method in class java.util.concurrent.ThreadPoolExecutor
Executes the given task sometime in the future.
execute(Connection) - Method in interface javax.sql.rowset.CachedRowSet
Populates this CachedRowSet object with data, using the given connection to produce the result set from which the data will be read.
execute() - Method in interface javax.sql.RowSet
Fills this RowSet object with data.
execute() - Method in class javax.swing.SwingWorker
Schedules this SwingWorker for execution on a worker thread.
EXECUTE_FAILED - Static variable in interface java.sql.Statement
The constant indicating that an error occurred while executing a batch statement.
executeBatch() - Method in interface java.sql.Statement
Submits a batch of commands to the database for execution and if all commands execute successfully, returns an array of update counts.
executeCall() - Method in interface java.rmi.server.RemoteCall
Deprecated.
no replacement
executeLargeBatch() - Method in interface java.sql.Statement
Submits a batch of commands to the database for execution and if all commands execute successfully, returns an array of update counts.
executeLargeUpdate() - Method in interface java.sql.PreparedStatement
Executes the SQL statement in this PreparedStatement object, which must be an SQL Data Manipulation Language (DML) statement, such as INSERT, UPDATE or DELETE; or an SQL statement that returns nothing, such as a DDL statement.
executeLargeUpdate(String) - Method in interface java.sql.Statement
Executes the given SQL statement, which may be an INSERT, UPDATE, or DELETE statement or an SQL statement that returns nothing, such as an SQL DDL statement.
executeLargeUpdate(String, int) - Method in interface java.sql.Statement
Executes the given SQL statement and signals the driver with the given flag about whether the auto-generated keys produced by this Statement object should be made available for retrieval.
executeLargeUpdate(String, int[]) - Method in interface java.sql.Statement
Executes the given SQL statement and signals the driver that the auto-generated keys indicated in the given array should be made available for retrieval.
executeLargeUpdate(String, String[]) - Method in interface java.sql.Statement
Executes the given SQL statement and signals the driver that the auto-generated keys indicated in the given array should be made available for retrieval.
executeQuery() - Method in interface java.sql.PreparedStatement
Executes the SQL query in this PreparedStatement object and returns the ResultSet object generated by the query.
executeQuery(String) - Method in interface java.sql.Statement
Executes the given SQL statement, which returns a single ResultSet object.
executeUpdate() - Method in interface java.sql.PreparedStatement
Executes the SQL statement in this PreparedStatement object, which must be an SQL Data Manipulation Language (DML) statement, such as INSERT, UPDATE or DELETE; or an SQL statement that returns nothing, such as a DDL statement.
executeUpdate(String) - Method in interface java.sql.Statement
Executes the given SQL statement, which may be an INSERT, UPDATE, or DELETE statement or an SQL statement that returns nothing, such as an SQL DDL statement.
executeUpdate(String, int) - Method in interface java.sql.Statement
Executes the given SQL statement and signals the driver with the given flag about whether the auto-generated keys produced by this Statement object should be made available for retrieval.
executeUpdate(String, int[]) - Method in interface java.sql.Statement
Executes the given SQL statement and signals the driver that the auto-generated keys indicated in the given array should be made available for retrieval.
executeUpdate(String, String[]) - Method in interface java.sql.Statement
Executes the given SQL statement and signals the driver that the auto-generated keys indicated in the given array should be made available for retrieval.
ExecutionException - Exception in java.util.concurrent
Exception thrown when attempting to retrieve the result of a task that aborted by throwing an exception.
ExecutionException() - Constructor for exception java.util.concurrent.ExecutionException
Constructs an ExecutionException with no detail message.
ExecutionException(String) - Constructor for exception java.util.concurrent.ExecutionException
Constructs an ExecutionException with the specified detail message.
ExecutionException(String, Throwable) - Constructor for exception java.util.concurrent.ExecutionException
Constructs an ExecutionException with the specified detail message and cause.
ExecutionException(Throwable) - Constructor for exception java.util.concurrent.ExecutionException
Constructs an ExecutionException with the specified cause.
EXECUTIVE - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for Executive, 7 1/4 x 10 1/2 in.
EXECUTIVE - Static variable in class javax.print.attribute.standard.MediaSize.Other
Specifies the executive size, 7.25 inches by 10.5 inches.
EXECUTIVE - Static variable in class javax.print.attribute.standard.MediaSizeName
executive size .
Executor - Interface in java.util.concurrent
An object that executes submitted Runnable tasks.
ExecutorCompletionService<V> - Class in java.util.concurrent
A CompletionService that uses a supplied Executor to execute tasks.
ExecutorCompletionService(Executor) - Constructor for class java.util.concurrent.ExecutorCompletionService
Creates an ExecutorCompletionService using the supplied executor for base task execution and a LinkedBlockingQueue as a completion queue.
ExecutorCompletionService(Executor, BlockingQueue<Future<V>>) - Constructor for class java.util.concurrent.ExecutorCompletionService
Creates an ExecutorCompletionService using the supplied executor for base task execution and the supplied queue as its completion queue.
Executors - Class in java.util.concurrent
Factory and utility methods for Executor, ExecutorService, ScheduledExecutorService, ThreadFactory, and Callable classes defined in this package.
ExecutorService - Interface in java.util.concurrent
An Executor that provides methods to manage termination and methods that can produce a Future for tracking progress of one or more asynchronous tasks.
ExemptionMechanism - Class in javax.crypto
This class provides the functionality of an exemption mechanism, examples of which are key recovery, key weakening, and key escrow.
ExemptionMechanism(ExemptionMechanismSpi, Provider, String) - Constructor for class javax.crypto.ExemptionMechanism
Creates a ExemptionMechanism object.
ExemptionMechanismException - Exception in javax.crypto
This is the generic ExemptionMechanism exception.
ExemptionMechanismException() - Constructor for exception javax.crypto.ExemptionMechanismException
Constructs a ExemptionMechanismException with no detailed message.
ExemptionMechanismException(String) - Constructor for exception javax.crypto.ExemptionMechanismException
Constructs a ExemptionMechanismException with the specified detailed message.
ExemptionMechanismSpi - Class in javax.crypto
This class defines the Service Provider Interface (SPI) for the ExemptionMechanism class.
ExemptionMechanismSpi() - Constructor for class javax.crypto.ExemptionMechanismSpi
exists() - Method in class java.io.File
Tests whether the file or directory denoted by this abstract pathname exists.
exists(Path, LinkOption...) - Static method in class java.nio.file.Files
Tests whether a file exists.
exists() - Method in class javax.security.auth.kerberos.KeyTab
Checks if the keytab file exists.
exit() - Method in interface java.awt.SecondaryLoop
Unblocks the execution of the thread blocked by the SecondaryLoop.enter() method and exits the secondary loop.
exit(int) - Method in class java.lang.Runtime
Terminates the currently running Java virtual machine by initiating its shutdown sequence.
exit(int) - Static method in class java.lang.System
Terminates the currently running Java Virtual Machine.
EXIT_ON_CLOSE - Static variable in class javax.swing.JFrame
The exit application default window close operation.
EXIT_ON_CLOSE - Static variable in interface javax.swing.WindowConstants
The exit application default window close operation.
EXITED - Static variable in class javax.swing.event.HyperlinkEvent.EventType
Exited type.
exiting(String, String) - Method in class java.util.logging.Logger
Log a method return.
exiting(String, String, Object) - Method in class java.util.logging.Logger
Log a method return, with result object.
exitValue() - Method in class java.lang.Process
Returns the exit value for the subprocess.
exp(double) - Static method in class java.lang.Math
Returns Euler's number e raised to the power of a double value.
exp(double) - Static method in class java.lang.StrictMath
Returns Euler's number e raised to the power of a double value.
EXPANDABLE - Static variable in class javax.accessibility.AccessibleState
Indicates this object allows progressive disclosure of its children.
EXPANDED - Static variable in class javax.accessibility.AccessibleState
Indicates this object is expanded.
expandedIcon - Variable in class javax.swing.plaf.basic.BasicTreeUI
expandPath(TreePath) - Method in class javax.swing.JTree
Ensures that the node identified by the specified path is expanded and viewable.
expandRow(int) - Method in class javax.swing.JTree
Ensures that the node in the specified row is expanded and viewable.
EXPANDS_SELECTED_PATHS_PROPERTY - Static variable in class javax.swing.JTree
Bound property name for expands selected paths property
expandTabRunsArray() - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
ExpandVetoException - Exception in javax.swing.tree
Exception used to stop and expand/collapse from happening.
ExpandVetoException(TreeExpansionEvent) - Constructor for exception javax.swing.tree.ExpandVetoException
Constructs an ExpandVetoException object with no message.
ExpandVetoException(TreeExpansionEvent, String) - Constructor for exception javax.swing.tree.ExpandVetoException
Constructs an ExpandVetoException object with the specified message.
explicitCastArguments(MethodHandle, MethodType) - Static method in class java.lang.invoke.MethodHandles
Produces a method handle which adapts the type of the given method handle to a new type by pairwise argument and return type conversion.
expm1(double) - Static method in class java.lang.Math
Returns ex -1.
expm1(double) - Static method in class java.lang.StrictMath
Returns ex -1.
EXPONENT - Static variable in class java.text.NumberFormat.Field
Constant identifying the exponent field.
EXPONENT_SIGN - Static variable in class java.text.NumberFormat.Field
Constant identifying the exponent sign field.
EXPONENT_SYMBOL - Static variable in class java.text.NumberFormat.Field
Constant identifying the exponent symbol field.
export() - Method in class javax.management.remote.rmi.RMIIIOPServerImpl
export() - Method in class javax.management.remote.rmi.RMIJRMPServerImpl
export() - Method in class javax.management.remote.rmi.RMIServerImpl
Exports this RMI object.
export() - Method in interface org.ietf.jgss.GSSContext
Exports this context so that another process may import it..
export() - Method in interface org.ietf.jgss.GSSName
Returns a canonical contiguous byte representation of a mechanism name (MN), suitable for direct, byte by byte comparison by authorization functions.
exportAsDrag(JComponent, InputEvent, int) - Method in class javax.swing.TransferHandler
Causes the Swing drag support to be initiated.
exportDone(JComponent, Transferable, int) - Method in class javax.swing.TransferHandler
Invoked after data has been exported.
ExportException - Exception in java.rmi.server
An ExportException is a RemoteException thrown if an attempt to export a remote object fails.
ExportException(String) - Constructor for exception java.rmi.server.ExportException
Constructs an ExportException with the specified detail message.
ExportException(String, Exception) - Constructor for exception java.rmi.server.ExportException
Constructs an ExportException with the specified detail message and nested exception.
exportNode(OutputStream) - Method in class java.util.prefs.AbstractPreferences
Implements the exportNode method as per the specification in Preferences.exportNode(OutputStream).
exportNode(OutputStream) - Method in class java.util.prefs.Preferences
Emits on the specified output stream an XML document representing all of the preferences contained in this node (but not its descendants).
exportObject(Remote, String, MarshalledObject<?>, boolean, int) - Static method in class java.rmi.activation.Activatable
Registers an activation descriptor (with the specified location, data, and restart mode) for the specified object, and exports that object with the specified port.
exportObject(Remote, String, MarshalledObject<?>, boolean, int, RMIClientSocketFactory, RMIServerSocketFactory) - Static method in class java.rmi.activation.Activatable
Registers an activation descriptor (with the specified location, data, and restart mode) for the specified object, and exports that object with the specified port, and the specified client and server socket factories.
exportObject(Remote, ActivationID, int) - Static method in class java.rmi.activation.Activatable
Export the activatable remote object to the RMI runtime to make the object available to receive incoming calls.
exportObject(Remote, ActivationID, int, RMIClientSocketFactory, RMIServerSocketFactory) - Static method in class java.rmi.activation.Activatable
Export the activatable remote object to the RMI runtime to make the object available to receive incoming calls.
exportObject(Remote, Object) - Method in interface java.rmi.server.ServerRef
Deprecated.
Creates a client stub object for the supplied Remote object.
exportObject(Remote) - Static method in class java.rmi.server.UnicastRemoteObject
Deprecated.
This method is deprecated because it supports only static stubs. Use exportObject(Remote, port) or exportObject(Remote, port, csf, ssf) instead.
exportObject(Remote, int) - Static method in class java.rmi.server.UnicastRemoteObject
Exports the remote object to make it available to receive incoming calls, using the particular supplied port.
exportObject(Remote, int, RMIClientSocketFactory, RMIServerSocketFactory) - Static method in class java.rmi.server.UnicastRemoteObject
Exports the remote object to make it available to receive incoming calls, using a transport specified by the given socket factory.
exportObject(Remote) - Method in interface javax.rmi.CORBA.PortableRemoteObjectDelegate
Delegation call for PortableRemoteObject.exportObject(java.rmi.Remote).
exportObject(Remote) - Static method in class javax.rmi.PortableRemoteObject
Makes a server object ready to receive remote calls.
exportSubtree(OutputStream) - Method in class java.util.prefs.AbstractPreferences
Implements the exportSubtree method as per the specification in Preferences.exportSubtree(OutputStream).
exportSubtree(OutputStream) - Method in class java.util.prefs.Preferences
Emits an XML document representing all of the preferences contained in this node and all of its descendants.
exportToClipboard(JComponent, Clipboard, int) - Method in class javax.swing.TransferHandler
Causes a transfer from the given component to the given clipboard.
Expression - Class in java.beans
An Expression object represents a primitive expression in which a single method is applied to a target and a set of arguments to return a result - as in "a.getFoo()".
Expression(Object, String, Object[]) - Constructor for class java.beans.Expression
Creates a new Expression object for the specified target object to invoke the method specified by the name and by the array of arguments.
Expression(Object, Object, String, Object[]) - Constructor for class java.beans.Expression
Creates a new Expression object with the specified value for the specified target object to invoke the method specified by the name and by the array of arguments.
extendedOperation(ExtendedRequest) - Method in class javax.naming.ldap.InitialLdapContext
extendedOperation(ExtendedRequest) - Method in interface javax.naming.ldap.LdapContext
Performs an extended operation.
ExtendedRequest - Interface in javax.naming.ldap
This interface represents an LDAPv3 extended operation request as defined in RFC 2251.
ExtendedResponse - Interface in javax.naming.ldap
This interface represents an LDAP extended operation response as defined in RFC 2251.
ExtendedSSLSession - Class in javax.net.ssl
Extends the SSLSession interface to support additional session attributes.
ExtendedSSLSession() - Constructor for class javax.net.ssl.ExtendedSSLSession
Extension - Interface in java.security.cert
This interface represents an X.509 extension.
extension - Variable in enum javax.tools.JavaFileObject.Kind
The extension which (by convention) is normally used for this kind of file object.
EXTENSION_INSTALLATION - Static variable in class java.util.jar.Attributes.Name
Name object for Extension-Name manifest attribute used for declaring dependencies on installed extensions.
EXTENSION_LIST - Static variable in class java.util.jar.Attributes.Name
Name object for Extension-List manifest attribute used for declaring dependencies on installed extensions.
EXTENSION_NAME - Static variable in class java.util.jar.Attributes.Name
Name object for Extension-Name manifest attribute used for declaring dependencies on installed extensions.
extent - Variable in class java.awt.geom.Arc2D.Double
The angular extent of the arc in degrees.
extent - Variable in class java.awt.geom.Arc2D.Float
The angular extent of the arc in degrees.
externalEntityDecl(String, String, String) - Method in interface org.xml.sax.ext.DeclHandler
Report a parsed external entity declaration.
externalEntityDecl(String, String, String) - Method in class org.xml.sax.ext.DefaultHandler2
Externalizable - Interface in java.io
Only the identity of the class of an Externalizable instance is written in the serialization stream and it is the responsibility of the class to save and restore the contents of its instances.
extract(Any) - Static method in class org.omg.CORBA.AnySeqHelper
extract(Any) - Static method in class org.omg.CORBA.BooleanSeqHelper
extract(Any) - Static method in class org.omg.CORBA.CharSeqHelper
extract(Any) - Static method in class org.omg.CORBA.CompletionStatusHelper
extract(Any) - Static method in class org.omg.CORBA.CurrentHelper
extract(Any) - Static method in class org.omg.CORBA.DefinitionKindHelper
extract(Any) - Static method in class org.omg.CORBA.DoubleSeqHelper
extract(Any) - Static method in class org.omg.CORBA.FieldNameHelper
extract(Any) - Static method in class org.omg.CORBA.FloatSeqHelper
extract(Any) - Static method in class org.omg.CORBA.IdentifierHelper
extract(Any) - Static method in class org.omg.CORBA.IDLTypeHelper
extract(Any) - Static method in class org.omg.CORBA.LongLongSeqHelper
extract(Any) - Static method in class org.omg.CORBA.LongSeqHelper
extract(Any) - Static method in class org.omg.CORBA.NameValuePairHelper
extract(Any) - Static method in class org.omg.CORBA.ObjectHelper
extract(Any) - Static method in class org.omg.CORBA.OctetSeqHelper
extract(Any) - Static method in class org.omg.CORBA.ParameterModeHelper
extract(Any) - Static method in class org.omg.CORBA.PolicyErrorCodeHelper
extract(Any) - Static method in class org.omg.CORBA.PolicyErrorHelper
extract(Any) - Static method in class org.omg.CORBA.PolicyHelper
extract(Any) - Static method in class org.omg.CORBA.PolicyListHelper
extract(Any) - Static method in class org.omg.CORBA.PolicyTypeHelper
extract(Any) - Static method in class org.omg.CORBA.RepositoryIdHelper
extract(Any) - Static method in class org.omg.CORBA.ServiceDetailHelper
extract(Any) - Static method in class org.omg.CORBA.ServiceInformationHelper
extract(Any) - Static method in class org.omg.CORBA.SetOverrideTypeHelper
extract(Any) - Static method in class org.omg.CORBA.ShortSeqHelper
extract(Any) - Static method in class org.omg.CORBA.StringSeqHelper
extract(Any) - Static method in class org.omg.CORBA.StringValueHelper
extract(Any) - Static method in class org.omg.CORBA.StructMemberHelper
extract(Any) - Static method in class org.omg.CORBA.ULongLongSeqHelper
extract(Any) - Static method in class org.omg.CORBA.ULongSeqHelper
extract(Any) - Static method in class org.omg.CORBA.UnionMemberHelper
extract(Any) - Static method in class org.omg.CORBA.UnknownUserExceptionHelper
extract(Any) - Static method in class org.omg.CORBA.UShortSeqHelper
extract(Any) - Static method in class org.omg.CORBA.ValueBaseHelper
extract(Any) - Static method in class org.omg.CORBA.ValueMemberHelper
extract(Any) - Static method in class org.omg.CORBA.VersionSpecHelper
extract(Any) - Static method in class org.omg.CORBA.VisibilityHelper
extract(Any) - Static method in class org.omg.CORBA.WCharSeqHelper
extract(Any) - Static method in class org.omg.CORBA.WrongTransactionHelper
extract(Any) - Static method in class org.omg.CORBA.WStringSeqHelper
extract(Any) - Static method in class org.omg.CORBA.WStringValueHelper
extract(Any) - Static method in class org.omg.CosNaming.BindingHelper
extract(Any) - Static method in class org.omg.CosNaming.BindingIteratorHelper
extract(Any) - Static method in class org.omg.CosNaming.BindingListHelper
extract(Any) - Static method in class org.omg.CosNaming.BindingTypeHelper
extract(Any) - Static method in class org.omg.CosNaming.IstringHelper
extract(Any) - Static method in class org.omg.CosNaming.NameComponentHelper
extract(Any) - Static method in class org.omg.CosNaming.NameHelper
extract(Any) - Static method in class org.omg.CosNaming.NamingContextExtHelper
extract(Any) - Static method in class org.omg.CosNaming.NamingContextExtPackage.AddressHelper
extract(Any) - Static method in class org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper
extract(Any) - Static method in class org.omg.CosNaming.NamingContextExtPackage.StringNameHelper
extract(Any) - Static method in class org.omg.CosNaming.NamingContextExtPackage.URLStringHelper
extract(Any) - Static method in class org.omg.CosNaming.NamingContextHelper
extract(Any) - Static method in class org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper
extract(Any) - Static method in class org.omg.CosNaming.NamingContextPackage.CannotProceedHelper
extract(Any) - Static method in class org.omg.CosNaming.NamingContextPackage.InvalidNameHelper
extract(Any) - Static method in class org.omg.CosNaming.NamingContextPackage.NotEmptyHelper
extract(Any) - Static method in class org.omg.CosNaming.NamingContextPackage.NotFoundHelper
extract(Any) - Static method in class org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper
extract(Any) - Static method in class org.omg.DynamicAny.AnySeqHelper
extract(Any) - Static method in class org.omg.DynamicAny.DynAnyFactoryHelper
extract(Any) - Static method in class org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper
extract(Any) - Static method in class org.omg.DynamicAny.DynAnyHelper
extract(Any) - Static method in class org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper
extract(Any) - Static method in class org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper
extract(Any) - Static method in class org.omg.DynamicAny.DynAnySeqHelper
extract(Any) - Static method in class org.omg.DynamicAny.DynArrayHelper
extract(Any) - Static method in class org.omg.DynamicAny.DynEnumHelper
extract(Any) - Static method in class org.omg.DynamicAny.DynFixedHelper
extract(Any) - Static method in class org.omg.DynamicAny.DynSequenceHelper
extract(Any) - Static method in class org.omg.DynamicAny.DynStructHelper
extract(Any) - Static method in class org.omg.DynamicAny.DynUnionHelper
extract(Any) - Static method in class org.omg.DynamicAny.DynValueHelper
extract(Any) - Static method in class org.omg.DynamicAny.FieldNameHelper
extract(Any) - Static method in class org.omg.DynamicAny.NameDynAnyPairHelper
extract(Any) - Static method in class org.omg.DynamicAny.NameDynAnyPairSeqHelper
extract(Any) - Static method in class org.omg.DynamicAny.NameValuePairHelper
extract(Any) - Static method in class org.omg.DynamicAny.NameValuePairSeqHelper
extract(Any) - Static method in class org.omg.IOP.CodecFactoryHelper
extract(Any) - Static method in class org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper
extract(Any) - Static method in class org.omg.IOP.CodecPackage.FormatMismatchHelper
extract(Any) - Static method in class org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper
extract(Any) - Static method in class org.omg.IOP.CodecPackage.TypeMismatchHelper
extract(Any) - Static method in class org.omg.IOP.ComponentIdHelper
extract(Any) - Static method in class org.omg.IOP.IORHelper
extract(Any) - Static method in class org.omg.IOP.MultipleComponentProfileHelper
extract(Any) - Static method in class org.omg.IOP.ProfileIdHelper
extract(Any) - Static method in class org.omg.IOP.ServiceContextHelper
extract(Any) - Static method in class org.omg.IOP.ServiceContextListHelper
extract(Any) - Static method in class org.omg.IOP.ServiceIdHelper
extract(Any) - Static method in class org.omg.IOP.TaggedComponentHelper
extract(Any) - Static method in class org.omg.IOP.TaggedProfileHelper
extract(Any) - Static method in class org.omg.Messaging.SyncScopeHelper
extract(Any) - Static method in class org.omg.PortableInterceptor.AdapterManagerIdHelper
extract(Any) - Static method in class org.omg.PortableInterceptor.AdapterNameHelper
extract(Any) - Static method in class org.omg.PortableInterceptor.AdapterStateHelper
extract(Any) - Static method in class org.omg.PortableInterceptor.CurrentHelper
extract(Any) - Static method in class org.omg.PortableInterceptor.ForwardRequestHelper
extract(Any) - Static method in class org.omg.PortableInterceptor.InvalidSlotHelper
extract(Any) - Static method in class org.omg.PortableInterceptor.IORInterceptor_3_0Helper
extract(Any) - Static method in class org.omg.PortableInterceptor.ObjectIdHelper
extract(Any) - Static method in class org.omg.PortableInterceptor.ObjectReferenceFactoryHelper
extract(Any) - Static method in class org.omg.PortableInterceptor.ObjectReferenceTemplateHelper
extract(Any) - Static method in class org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper
extract(Any) - Static method in class org.omg.PortableInterceptor.ORBIdHelper
extract(Any) - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper
extract(Any) - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper
extract(Any) - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper
extract(Any) - Static method in class org.omg.PortableInterceptor.ServerIdHelper
extract(Any) - Static method in class org.omg.PortableServer.CurrentHelper
extract(Any) - Static method in class org.omg.PortableServer.CurrentPackage.NoContextHelper
extract(Any) - Static method in class org.omg.PortableServer.ForwardRequestHelper
extract(Any) - Static method in class org.omg.PortableServer.POAHelper
extract(Any) - Static method in class org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper
extract(Any) - Static method in class org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper
extract(Any) - Static method in class org.omg.PortableServer.POAPackage.AdapterNonExistentHelper
extract(Any) - Static method in class org.omg.PortableServer.POAPackage.InvalidPolicyHelper
extract(Any) - Static method in class org.omg.PortableServer.POAPackage.NoServantHelper
extract(Any) - Static method in class org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper
extract(Any) - Static method in class org.omg.PortableServer.POAPackage.ObjectNotActiveHelper
extract(Any) - Static method in class org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper
extract(Any) - Static method in class org.omg.PortableServer.POAPackage.ServantNotActiveHelper
extract(Any) - Static method in class org.omg.PortableServer.POAPackage.WrongAdapterHelper
extract(Any) - Static method in class org.omg.PortableServer.POAPackage.WrongPolicyHelper
extract(Any) - Static method in class org.omg.PortableServer.ServantActivatorHelper
extract(Any) - Static method in class org.omg.PortableServer.ServantLocatorHelper
extract_any() - Method in class org.omg.CORBA.Any
Extracts the Any object in this Any object's value field.
extract_boolean() - Method in class org.omg.CORBA.Any
Extracts the boolean in this Any object's value field.
extract_char() - Method in class org.omg.CORBA.Any
Extracts the char in this Any object's value field.
extract_double() - Method in class org.omg.CORBA.Any
Extracts the double in this Any object's value field.
extract_fixed() - Method in class org.omg.CORBA.Any
Extracts the java.math.BigDecimal object in this Any object's value field.
extract_float() - Method in class org.omg.CORBA.Any
Extracts the float in this Any object's value field.
extract_long() - Method in class org.omg.CORBA.Any
Extracts the int in this Any object's value field.
extract_longlong() - Method in class org.omg.CORBA.Any
Extracts the long in this Any object's value field.
extract_Object() - Method in class org.omg.CORBA.Any
Extracts the org.omg.CORBA.Object in this Any object's value field.
extract_octet() - Method in class org.omg.CORBA.Any
Extracts the byte in this Any object's value field.
extract_Principal() - Method in class org.omg.CORBA.Any
Deprecated.
Deprecated by CORBA 2.2.
extract_short() - Method in class org.omg.CORBA.Any
Extracts the short in this Any object's value field.
extract_Streamable() - Method in class org.omg.CORBA.Any
Extracts a Streamable from this Any object's value field.
extract_string() - Method in class org.omg.CORBA.Any
Extracts the String object in this Any object's value field.
extract_TypeCode() - Method in class org.omg.CORBA.Any
Extracts the TypeCode object in this Any object's value field.
extract_ulong() - Method in class org.omg.CORBA.Any
Extracts the int in this Any object's value field.
extract_ulonglong() - Method in class org.omg.CORBA.Any
Extracts the long in this Any object's value field.
extract_ushort() - Method in class org.omg.CORBA.Any
Extracts the short in this Any object's value field.
extract_Value() - Method in class org.omg.CORBA.Any
Extracts the java.io.Serializable object in this Any object's value field.
extract_wchar() - Method in class org.omg.CORBA.Any
Extracts the char in this Any object's value field.
extract_wstring() - Method in class org.omg.CORBA.Any
Extracts the String object in this Any object's value field.
extractAllHeaderElements() - Method in interface javax.xml.soap.SOAPHeader
Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object and detaches them from this SOAPHeader object.
extractContentAsDocument() - Method in interface javax.xml.soap.SOAPBody
Creates a new DOM Document and sets the first child of this SOAPBody as it's document element.
extractHeaderElements(String) - Method in interface javax.xml.soap.SOAPHeader
Returns an Iterator over all the SOAPHeaderElement objects in this SOAPHeader object that have the specified actor and detaches them from this SOAPHeader object.
extraImageMetadataFormatClassNames - Variable in class javax.imageio.spi.ImageReaderWriterSpi
An array of Strings containing the class names of any additional image metadata formats supported by this plug-in, initially null.
extraImageMetadataFormatNames - Variable in class javax.imageio.spi.ImageReaderWriterSpi
An array of Strings containing the names of any additional image metadata formats supported by this plug-in, initially null.
extraMetadataFormatClassNames - Variable in class javax.imageio.metadata.IIOMetadata
An array of names of classes implementing IIOMetadataFormat and representing the metadata formats, other than the standard and native formats, that are supported by this plug-in, initialized to null and set via the constructor.
extraMetadataFormatNames - Variable in class javax.imageio.metadata.IIOMetadata
An array of names of formats, other than the standard and native formats, that are supported by this plug-in, initialized to null and set via the constructor.
extraStreamMetadataFormatClassNames - Variable in class javax.imageio.spi.ImageReaderWriterSpi
An array of Strings containing the class names of any additional stream metadata formats supported by this plug-in, initially null.
extraStreamMetadataFormatNames - Variable in class javax.imageio.spi.ImageReaderWriterSpi
An array of Strings containing the names of any additional stream metadata formats supported by this plug-in, initially null.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames


F-Index (Java Platform SE 8 )

Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames
  • All Classes
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

F

F0 - Static variable in class java.security.spec.RSAKeyGenParameterSpec
The public-exponent value F0 = 3.
F1 - Static variable in class java.awt.Event
The F1 function key, a non-ASCII action key.
F10 - Static variable in class java.awt.Event
The F10 function key, a non-ASCII action key.
F11 - Static variable in class java.awt.Event
The F11 function key, a non-ASCII action key.
F12 - Static variable in class java.awt.Event
The F12 function key, a non-ASCII action key.
F2 - Static variable in class java.awt.Event
The F2 function key, a non-ASCII action key.
F3 - Static variable in class java.awt.Event
The F3 function key, a non-ASCII action key.
F4 - Static variable in class java.awt.Event
The F4 function key, a non-ASCII action key.
F4 - Static variable in class java.security.spec.RSAKeyGenParameterSpec
The public exponent-value F4 = 65537.
F5 - Static variable in class java.awt.Event
The F5 function key, a non-ASCII action key.
F6 - Static variable in class java.awt.Event
The F6 function key, a non-ASCII action key.
F7 - Static variable in class java.awt.Event
The F7 function key, a non-ASCII action key.
F8 - Static variable in class java.awt.Event
The F8 function key, a non-ASCII action key.
F9 - Static variable in class java.awt.Event
The F9 function key, a non-ASCII action key.
FACE - Static variable in class javax.swing.text.html.HTML.Attribute
FactoryConfigurationError - Error in javax.xml.parsers
Thrown when a problem with configuration with the Parser Factories exists.
FactoryConfigurationError() - Constructor for error javax.xml.parsers.FactoryConfigurationError
Create a new FactoryConfigurationError with no detail mesage.
FactoryConfigurationError(String) - Constructor for error javax.xml.parsers.FactoryConfigurationError
Create a new FactoryConfigurationError with the String specified as an error message.
FactoryConfigurationError(Exception) - Constructor for error javax.xml.parsers.FactoryConfigurationError
Create a new FactoryConfigurationError with a given Exception base cause of the error.
FactoryConfigurationError(Exception, String) - Constructor for error javax.xml.parsers.FactoryConfigurationError
Create a new FactoryConfigurationError with the given Exception base cause and detail message.
FactoryConfigurationError - Error in javax.xml.stream
An error class for reporting factory configuration errors.
FactoryConfigurationError() - Constructor for error javax.xml.stream.FactoryConfigurationError
Default constructor
FactoryConfigurationError(Exception) - Constructor for error javax.xml.stream.FactoryConfigurationError
Construct an exception with a nested inner exception
FactoryConfigurationError(Exception, String) - Constructor for error javax.xml.stream.FactoryConfigurationError
Construct an exception with a nested inner exception and a message
FactoryConfigurationError(String, Exception) - Constructor for error javax.xml.stream.FactoryConfigurationError
Construct an exception with a nested inner exception and a message
FactoryConfigurationError(String) - Constructor for error javax.xml.stream.FactoryConfigurationError
Construct an exception with associated message
failed(Throwable, A) - Method in interface java.nio.channels.CompletionHandler
Invoked when an operation fails.
FAILED - Static variable in class javax.management.remote.JMXConnectionNotification
Notification type string for a connection-failed notification.
FailedLoginException - Exception in javax.security.auth.login
Signals that user authentication failed.
FailedLoginException() - Constructor for exception javax.security.auth.login.FailedLoginException
Constructs a FailedLoginException with no detail message.
FailedLoginException(String) - Constructor for exception javax.security.auth.login.FailedLoginException
Constructs a FailedLoginException with the specified detail message.
failure(Exception) - Method in interface java.rmi.server.RMIFailureHandler
The failure callback is invoked when the RMI runtime is unable to create a ServerSocket via the RMISocketFactory.
FAILURE - Static variable in exception org.ietf.jgss.GSSException
General failure, unspecified at GSS-API level.
FALSE - Static variable in class java.lang.Boolean
The Boolean object corresponding to the primitive value false.
FALSE - Static variable in interface java.util.jar.Pack200.Packer
The string "false", a possible value for certain properties.
FALSE - Static variable in interface java.util.jar.Pack200.Unpacker
The string "false", a possible value for certain properties.
FAMILY - Static variable in class java.awt.font.TextAttribute
Attribute key for the font name.
Family - Static variable in class javax.swing.text.StyleConstants
Name of the font family.
FATAL_ERROR - Static variable in interface javax.xml.bind.ValidationEvent
Conditions that correspond to the definition of "fatal error" in section 1.2 of the W3C XML 1.0 Recommendation
fatalError(TransformerException) - Method in interface javax.xml.transform.ErrorListener
Receive notification of a non-recoverable error.
fatalError(SAXParseException) - Method in interface org.xml.sax.ErrorHandler
Receive notification of a non-recoverable error.
fatalError(SAXParseException) - Method in class org.xml.sax.HandlerBase
Deprecated.
Report a fatal XML parsing error.
fatalError(SAXParseException) - Method in class org.xml.sax.helpers.DefaultHandler
Report a fatal XML parsing error.
fatalError(SAXParseException) - Method in class org.xml.sax.helpers.XMLFilterImpl
Filter a fatal error event.
FaultAction - Annotation Type in javax.xml.ws
The FaultAction annotation is used inside an Action annotation to allow an explicit association of a WS-Addressing Action message addressing property with the fault messages of the WSDL operation mapped from the exception class.
fd - Variable in class java.net.DatagramSocketImpl
The file descriptor object.
fd - Variable in class java.net.SocketImpl
The file descriptor object for this socket.
FEATURE - Static variable in class javax.xml.transform.dom.DOMResult
If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Result output of this type.
FEATURE - Static variable in class javax.xml.transform.dom.DOMSource
If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Source input of this type.
FEATURE - Static variable in class javax.xml.transform.sax.SAXResult
If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Result output of this type.
FEATURE - Static variable in class javax.xml.transform.sax.SAXSource
If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Source input of this type.
FEATURE - Static variable in class javax.xml.transform.sax.SAXTransformerFactory
If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the TransformerFactory returned from TransformerFactory.newInstance() may be safely cast to a SAXTransformerFactory.
FEATURE - Static variable in class javax.xml.transform.stax.StAXResult
If TransformerFactory.getFeature(String name) returns true when passed this value as an argument, the Transformer supports Result output of this type.
FEATURE - Static variable in class javax.xml.transform.stax.StAXSource
If TransformerFactory.getFeature(String name) returns true when passed this value as an argument, the Transformer supports Source input of this type.
FEATURE - Static variable in class javax.xml.transform.stream.StreamResult
If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Result output of this type.
FEATURE - Static variable in class javax.xml.transform.stream.StreamSource
If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the Transformer supports Source input of this type.
FEATURE_SECURE_PROCESSING - Static variable in class javax.xml.XMLConstants
Feature for secure processing.
FEATURE_XMLFILTER - Static variable in class javax.xml.transform.sax.SAXTransformerFactory
If TransformerFactory.getFeature(java.lang.String) returns true when passed this value as an argument, the SAXTransformerFactory.newXMLFilter(Source src) and SAXTransformerFactory.newXMLFilter(Templates templates) methods are supported.
FeatureDescriptor - Class in java.beans
The FeatureDescriptor class is the common baseclass for PropertyDescriptor, EventSetDescriptor, and MethodDescriptor, etc.
FeatureDescriptor() - Constructor for class java.beans.FeatureDescriptor
Constructs a FeatureDescriptor.
FEBRUARY - Static variable in class java.util.Calendar
Value of the Calendar.MONTH field indicating the second month of the year in the Gregorian and Julian calendars.
FEBRUARY - Static variable in class javax.xml.datatype.DatatypeConstants
Value for second month of year.
FETCH_FORWARD - Static variable in interface java.sql.ResultSet
The constant indicating that the rows in a result set will be processed in a forward direction; first-to-last.
FETCH_REVERSE - Static variable in interface java.sql.ResultSet
The constant indicating that the rows in a result set will be processed in a reverse direction; last-to-first.
FETCH_UNKNOWN - Static variable in interface java.sql.ResultSet
The constant indicating that the order in which rows in a result set will be processed is unknown.
fetchNotifications(long, int, long) - Method in interface javax.management.remote.rmi.RMIConnection
Retrieves notifications from the connector server.
fetchNotifications(long, int, long) - Method in class javax.management.remote.rmi.RMIConnectionImpl
fetchNotifications(long, int, long) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub
fictional() - Method in class javax.swing.text.html.parser.TagElement
Fidelity - Class in javax.print.attribute.standard
Class Fidelity is a printing attribute class, an enumeration, that indicates whether total fidelity to client supplied print request attributes is required.
Fidelity(int) - Constructor for class javax.print.attribute.standard.Fidelity
Construct a new fidelity enumeration value with the given integer value.
FIDELITY_FALSE - Static variable in class javax.print.attribute.standard.Fidelity
The printer should make reasonable attempts to print the job, even if it cannot print it exactly as specified.
FIDELITY_TRUE - Static variable in class javax.print.attribute.standard.Fidelity
The job must be printed exactly as specified.
Field - Class in java.lang.reflect
A Field provides information about, and dynamic access to, a single field of a class or an interface.
Field(String, int) - Constructor for class java.text.DateFormat.Field
Creates a Field.
Field(String) - Constructor for class java.text.Format.Field
Creates a Field with the specified name.
Field(String) - Constructor for class java.text.MessageFormat.Field
Creates a Field with the specified name.
Field(String) - Constructor for class java.text.NumberFormat.Field
Creates a Field instance with the specified name.
FIELD_ATTRIBUTE_PFX - Static variable in interface java.util.jar.Pack200.Packer
When concatenated with a field attribute name, indicates the format of that attribute.
FIELD_COUNT - Static variable in class java.util.Calendar
The number of distinct fields recognized by get and set.
FIELD_UNDEFINED - Static variable in class javax.xml.datatype.DatatypeConstants
Designation that an "int" field is not set.
FieldBorder(Color, Color, Color, Color) - Constructor for class javax.swing.plaf.basic.BasicBorders.FieldBorder
fieldModifiers() - Static method in class java.lang.reflect.Modifier
Return an int value OR-ing together the source language modifiers that can be applied to a field.
FieldNameHelper - Class in org.omg.CORBA
The Helper for FieldName.
FieldNameHelper() - Constructor for class org.omg.CORBA.FieldNameHelper
FieldNameHelper - Class in org.omg.DynamicAny
org/omg/DynamicAny/FieldNameHelper.java .
FieldNameHelper() - Constructor for class org.omg.DynamicAny.FieldNameHelper
FieldPosition - Class in java.text
FieldPosition is a simple class used by Format and its subclasses to identify fields in formatted output.
FieldPosition(int) - Constructor for class java.text.FieldPosition
Creates a FieldPosition object for the given field.
FieldPosition(Format.Field) - Constructor for class java.text.FieldPosition
Creates a FieldPosition object for the given field constant.
FieldPosition(Format.Field, int) - Constructor for class java.text.FieldPosition
Creates a FieldPosition object for the given field.
fields - Variable in class java.util.Calendar
The calendar field values for the currently set time for this calendar.
fieldsIn(Iterable<? extends Element>) - Static method in class javax.lang.model.util.ElementFilter
Returns a list of fields in elements.
fieldsIn(Set<? extends Element>) - Static method in class javax.lang.model.util.ElementFilter
Returns a set of fields in elements.
FieldView - Class in javax.swing.text
Extends the multi-line plain text view to be suitable for a single-line editor view.
FieldView(Element) - Constructor for class javax.swing.text.FieldView
Constructs a new FieldView wrapped on an element.
FILE - Static variable in class java.awt.JobAttributes.DestinationType
The DestinationType instance to use for specifying print to file.
File - Class in java.io
An abstract representation of file and directory pathnames.
File(String) - Constructor for class java.io.File
Creates a new File instance by converting the given pathname string into an abstract pathname.
File(String, String) - Constructor for class java.io.File
Creates a new File instance from a parent pathname string and a child pathname string.
File(File, String) - Constructor for class java.io.File
Creates a new File instance from a parent abstract pathname and a child pathname string.
File(URI) - Constructor for class java.io.File
Creates a new File instance by converting the given file: URI into an abstract pathname.
file() - Method in class java.lang.ProcessBuilder.Redirect
Returns the File source or destination associated with this redirect, or null if there is no such file.
FILE - Static variable in class javax.print.attribute.standard.ReferenceUriSchemesSupported
Host-specific file names.
FILE_CHOOSER - Static variable in class javax.accessibility.AccessibleRole
A specialized dialog that displays the files in the directory and lets the user select a file, browse a different directory, or specify a filename.
FILE_CHOOSER - Static variable in class javax.swing.plaf.synth.Region
FileChooser region.
FILE_CHOOSER_DIALOG - Static variable in class javax.swing.JRootPane
Constant used for the windowDecorationStyle property.
FILE_FILTER_CHANGED_PROPERTY - Static variable in class javax.swing.JFileChooser
User changed the kind of files to display.
FILE_HIDING_CHANGED_PROPERTY - Static variable in class javax.swing.JFileChooser
Identifies a change in the display-hidden-files property.
FILE_SELECTION_MODE_CHANGED_PROPERTY - Static variable in class javax.swing.JFileChooser
Identifies a change in the kind of selection (single, multiple, etc.).
FILE_SYSTEM_VIEW_CHANGED_PROPERTY - Static variable in class javax.swing.JFileChooser
Says that a different object is being used to find available drives on the system.
FILE_VERSION - Static variable in class javax.swing.text.html.parser.DTD
FILE_VIEW_CHANGED_PROPERTY - Static variable in class javax.swing.JFileChooser
Says that a different object is being used to retrieve file information.
FileAlreadyExistsException - Exception in java.nio.file
Checked exception thrown when an attempt is made to create a file or directory and a file of that name already exists.
FileAlreadyExistsException(String) - Constructor for exception java.nio.file.FileAlreadyExistsException
Constructs an instance of this class.
FileAlreadyExistsException(String, String, String) - Constructor for exception java.nio.file.FileAlreadyExistsException
Constructs an instance of this class.
FileAttribute<T> - Interface in java.nio.file.attribute
An object that encapsulates the value of a file attribute that can be set atomically when creating a new file or directory by invoking the createFile or createDirectory methods.
FileAttributeView - Interface in java.nio.file.attribute
An attribute view that is a read-only or updatable view of non-opaque values associated with a file in a filesystem.
FileCacheImageInputStream - Class in javax.imageio.stream
An implementation of ImageInputStream that gets its input from a regular InputStream.
FileCacheImageInputStream(InputStream, File) - Constructor for class javax.imageio.stream.FileCacheImageInputStream
Constructs a FileCacheImageInputStream that will read from a given InputStream.
FileCacheImageOutputStream - Class in javax.imageio.stream
An implementation of ImageOutputStream that writes its output to a regular OutputStream.
FileCacheImageOutputStream(OutputStream, File) - Constructor for class javax.imageio.stream.FileCacheImageOutputStream
Constructs a FileCacheImageOutputStream that will write to a given outputStream.
FileChannel - Class in java.nio.channels
A channel for reading, writing, mapping, and manipulating a file.
FileChannel() - Constructor for class java.nio.channels.FileChannel
Initializes a new instance of this class.
FileChannel.MapMode - Class in java.nio.channels
A typesafe enumeration for file-mapping modes.
FileChooserUI - Class in javax.swing.plaf
Pluggable look and feel interface for JFileChooser.
FileChooserUI() - Constructor for class javax.swing.plaf.FileChooserUI
FileDataSource - Class in javax.activation
The FileDataSource class implements a simple DataSource object that encapsulates a file.
FileDataSource(File) - Constructor for class javax.activation.FileDataSource
Creates a FileDataSource from a File object.
FileDataSource(String) - Constructor for class javax.activation.FileDataSource
Creates a FileDataSource from the specified path name.
FileDescriptor - Class in java.io
Instances of the file descriptor class serve as an opaque handle to the underlying machine-specific structure representing an open file, an open socket, or another source or sink of bytes.
FileDescriptor() - Constructor for class java.io.FileDescriptor
Constructs an (invalid) FileDescriptor object.
FileDialog - Class in java.awt
The FileDialog class displays a dialog window from which the user can select a file.
FileDialog(Frame) - Constructor for class java.awt.FileDialog
Creates a file dialog for loading a file.
FileDialog(Frame, String) - Constructor for class java.awt.FileDialog
Creates a file dialog window with the specified title for loading a file.
FileDialog(Frame, String, int) - Constructor for class java.awt.FileDialog
Creates a file dialog window with the specified title for loading or saving a file.
FileDialog(Dialog) - Constructor for class java.awt.FileDialog
Creates a file dialog for loading a file.
FileDialog(Dialog, String) - Constructor for class java.awt.FileDialog
Creates a file dialog window with the specified title for loading a file.
FileDialog(Dialog, String, int) - Constructor for class java.awt.FileDialog
Creates a file dialog window with the specified title for loading or saving a file.
FileFilter - Interface in java.io
A filter for abstract pathnames.
FileFilter - Class in javax.swing.filechooser
FileFilter is an abstract class used by JFileChooser for filtering the set of files shown to the user.
FileFilter() - Constructor for class javax.swing.filechooser.FileFilter
FileHandler - Class in java.util.logging
Simple file logging Handler.
FileHandler() - Constructor for class java.util.logging.FileHandler
Construct a default FileHandler.
FileHandler(String) - Constructor for class java.util.logging.FileHandler
Initialize a FileHandler to write to the given filename.
FileHandler(String, boolean) - Constructor for class java.util.logging.FileHandler
Initialize a FileHandler to write to the given filename, with optional append.
FileHandler(String, int, int) - Constructor for class java.util.logging.FileHandler
Initialize a FileHandler to write to a set of files.
FileHandler(String, int, int, boolean) - Constructor for class java.util.logging.FileHandler
Initialize a FileHandler to write to a set of files with optional append.
fileIcon - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
FileIcon16() - Constructor for class javax.swing.plaf.metal.MetalIconFactory.FileIcon16
FileImageInputStream - Class in javax.imageio.stream
An implementation of ImageInputStream that gets its input from a File or RandomAccessFile.
FileImageInputStream(File) - Constructor for class javax.imageio.stream.FileImageInputStream
Constructs a FileImageInputStream that will read from a given File.
FileImageInputStream(RandomAccessFile) - Constructor for class javax.imageio.stream.FileImageInputStream
Constructs a FileImageInputStream that will read from a given RandomAccessFile.
FileImageOutputStream - Class in javax.imageio.stream
An implementation of ImageOutputStream that writes its output directly to a File or RandomAccessFile.
FileImageOutputStream(File) - Constructor for class javax.imageio.stream.FileImageOutputStream
Constructs a FileImageOutputStream that will write to a given File.
FileImageOutputStream(RandomAccessFile) - Constructor for class javax.imageio.stream.FileImageOutputStream
Constructs a FileImageOutputStream that will write to a given RandomAccessFile.
FileInputStream - Class in java.io
A FileInputStream obtains input bytes from a file in a file system.
FileInputStream(String) - Constructor for class java.io.FileInputStream
Creates a FileInputStream by opening a connection to an actual file, the file named by the path name name in the file system.
FileInputStream(File) - Constructor for class java.io.FileInputStream
Creates a FileInputStream by opening a connection to an actual file, the file named by the File object file in the file system.
FileInputStream(FileDescriptor) - Constructor for class java.io.FileInputStream
Creates a FileInputStream by using the file descriptor fdObj, which represents an existing connection to an actual file in the file system.
fileKey() - Method in interface java.nio.file.attribute.BasicFileAttributes
Returns an object that uniquely identifies the given file, or null if a file key is not available.
FileLock - Class in java.nio.channels
A token representing a lock on a region of a file.
FileLock(FileChannel, long, long, boolean) - Constructor for class java.nio.channels.FileLock
Initializes a new instance of this class.
FileLock(AsynchronousFileChannel, long, long, boolean) - Constructor for class java.nio.channels.FileLock
Initializes a new instance of this class.
FileLockInterruptionException - Exception in java.nio.channels
Checked exception received by a thread when another thread interrupts it while it is waiting to acquire a file lock.
FileLockInterruptionException() - Constructor for exception java.nio.channels.FileLockInterruptionException
Constructs an instance of this class.
fileManager - Variable in class javax.tools.ForwardingJavaFileManager
The file manager which all methods are delegated to.
FILENAME - Static variable in interface javax.script.ScriptEngine
Reserved key for a named value that is the name of the file being executed.
FileNameExtensionFilter - Class in javax.swing.filechooser
An implementation of FileFilter that filters using a specified set of extensions.
FileNameExtensionFilter(String, String...) - Constructor for class javax.swing.filechooser.FileNameExtensionFilter
Creates a FileNameExtensionFilter with the specified description and file name extensions.
FilenameFilter - Interface in java.io
Instances of classes that implement this interface are used to filter filenames.
FileNameMap - Interface in java.net
A simple interface which provides a mechanism to map between a file name and a MIME type string.
FileNotFoundException - Exception in java.io
Signals that an attempt to open the file denoted by a specified pathname has failed.
FileNotFoundException() - Constructor for exception java.io.FileNotFoundException
Constructs a FileNotFoundException with null as its error detail message.
FileNotFoundException(String) - Constructor for exception java.io.FileNotFoundException
Constructs a FileNotFoundException with the specified detail message.
FileObject - Interface in javax.tools
File abstraction for tools.
fileObject - Variable in class javax.tools.ForwardingFileObject
The file object which all methods are delegated to.
FileOutputStream - Class in java.io
A file output stream is an output stream for writing data to a File or to a FileDescriptor.
FileOutputStream(String) - Constructor for class java.io.FileOutputStream
Creates a file output stream to write to the file with the specified name.
FileOutputStream(String, boolean) - Constructor for class java.io.FileOutputStream
Creates a file output stream to write to the file with the specified name.
FileOutputStream(File) - Constructor for class java.io.FileOutputStream
Creates a file output stream to write to the file represented by the specified File object.
FileOutputStream(File, boolean) - Constructor for class java.io.FileOutputStream
Creates a file output stream to write to the file represented by the specified File object.
FileOutputStream(FileDescriptor) - Constructor for class java.io.FileOutputStream
Creates a file output stream to write to the specified file descriptor, which represents an existing connection to an actual file in the file system.
FileOwnerAttributeView - Interface in java.nio.file.attribute
A file attribute view that supports reading or updating the owner of a file.
FilePermission - Class in java.io
This class represents access to a file or directory.
FilePermission(String, String) - Constructor for class java.io.FilePermission
Creates a new FilePermission object with the specified actions.
Filer - Interface in javax.annotation.processing
This interface supports the creation of new files by an annotation processor.
FileReader - Class in java.io
Convenience class for reading character files.
FileReader(String) - Constructor for class java.io.FileReader
Creates a new FileReader, given the name of the file to read from.
FileReader(File) - Constructor for class java.io.FileReader
Creates a new FileReader, given the File to read from.
FileReader(FileDescriptor) - Constructor for class java.io.FileReader
Creates a new FileReader, given the FileDescriptor to read from.
FileRenderer() - Constructor for class javax.swing.plaf.metal.MetalFileChooserUI.FileRenderer
FilerException - Exception in javax.annotation.processing
Indicates a Filer detected an attempt to open a file that would violate the guarantees provided by the Filer.
FilerException(String) - Constructor for exception javax.annotation.processing.FilerException
Constructs an exception with the specified detail message.
Files - Class in java.nio.file
This class consists exclusively of static methods that operate on files, directories, or other types of files.
FILES_AND_DIRECTORIES - Static variable in class javax.swing.JFileChooser
Instruction to display both files and directories.
FILES_ONLY - Static variable in class javax.swing.JFileChooser
Instruction to display only files.
FileStore - Class in java.nio.file
Storage for files.
FileStore() - Constructor for class java.nio.file.FileStore
Initializes a new instance of this class.
FileStoreAttributeView - Interface in java.nio.file.attribute
An attribute view that is a read-only or updatable view of the attributes of a FileStore.
FileSystem - Class in java.nio.file
Provides an interface to a file system and is the factory for objects to access files and other objects in the file system.
FileSystem() - Constructor for class java.nio.file.FileSystem
Initializes a new instance of this class.
FileSystemAlreadyExistsException - Exception in java.nio.file
Runtime exception thrown when an attempt is made to create a file system that already exists.
FileSystemAlreadyExistsException() - Constructor for exception java.nio.file.FileSystemAlreadyExistsException
Constructs an instance of this class.
FileSystemAlreadyExistsException(String) - Constructor for exception java.nio.file.FileSystemAlreadyExistsException
Constructs an instance of this class.
FileSystemException - Exception in java.nio.file
Thrown when a file system operation fails on one or two files.
FileSystemException(String) - Constructor for exception java.nio.file.FileSystemException
Constructs an instance of this class.
FileSystemException(String, String, String) - Constructor for exception java.nio.file.FileSystemException
Constructs an instance of this class.
FileSystemLoopException - Exception in java.nio.file
Checked exception thrown when a file system loop, or cycle, is encountered.
FileSystemLoopException(String) - Constructor for exception java.nio.file.FileSystemLoopException
Constructs an instance of this class.
FileSystemNotFoundException - Exception in java.nio.file
Runtime exception thrown when a file system cannot be found.
FileSystemNotFoundException() - Constructor for exception java.nio.file.FileSystemNotFoundException
Constructs an instance of this class.
FileSystemNotFoundException(String) - Constructor for exception java.nio.file.FileSystemNotFoundException
Constructs an instance of this class.
FileSystemProvider - Class in java.nio.file.spi
Service-provider class for file systems.
FileSystemProvider() - Constructor for class java.nio.file.spi.FileSystemProvider
Initializes a new instance of this class.
FileSystems - Class in java.nio.file
Factory methods for file systems.
FileSystemView - Class in javax.swing.filechooser
FileSystemView is JFileChooser's gateway to the file system.
FileSystemView() - Constructor for class javax.swing.filechooser.FileSystemView
FileTime - Class in java.nio.file.attribute
Represents the value of a file's time stamp attribute.
FileTypeDetector - Class in java.nio.file.spi
A file type detector for probing a file to guess its file type.
FileTypeDetector() - Constructor for class java.nio.file.spi.FileTypeDetector
Initializes a new instance of this class.
FileTypeMap - Class in javax.activation
The FileTypeMap is an abstract class that provides a data typing interface for files.
FileTypeMap() - Constructor for class javax.activation.FileTypeMap
The default constructor.
FileView - Class in javax.swing.filechooser
FileView defines an abstract class that can be implemented to provide the filechooser with UI information for a File.
FileView() - Constructor for class javax.swing.filechooser.FileView
FileVisitOption - Enum in java.nio.file
Defines the file tree traversal options.
FileVisitor<T> - Interface in java.nio.file
A visitor of files.
FileVisitResult - Enum in java.nio.file
The result type of a FileVisitor.
FileWriter - Class in java.io
Convenience class for writing character files.
FileWriter(String) - Constructor for class java.io.FileWriter
Constructs a FileWriter object given a file name.
FileWriter(String, boolean) - Constructor for class java.io.FileWriter
Constructs a FileWriter object given a file name with a boolean indicating whether or not to append the data written.
FileWriter(File) - Constructor for class java.io.FileWriter
Constructs a FileWriter object given a File object.
FileWriter(File, boolean) - Constructor for class java.io.FileWriter
Constructs a FileWriter object given a File object.
FileWriter(FileDescriptor) - Constructor for class java.io.FileWriter
Constructs a FileWriter object associated with a file descriptor.
FILL - Static variable in class java.awt.font.ShapeGraphicAttribute
A key indicating the shape should be filled.
fill(Shape) - Method in class java.awt.Graphics2D
Fills the interior of a Shape using the settings of the Graphics2D context.
fill - Variable in class java.awt.GridBagConstraints
This field is used when the component's display area is larger than the component's requested size.
fill(long[], long) - Static method in class java.util.Arrays
Assigns the specified long value to each element of the specified array of longs.
fill(long[], int, int, long) - Static method in class java.util.Arrays
Assigns the specified long value to each element of the specified range of the specified array of longs.
fill(int[], int) - Static method in class java.util.Arrays
Assigns the specified int value to each element of the specified array of ints.
fill(int[], int, int, int) - Static method in class java.util.Arrays
Assigns the specified int value to each element of the specified range of the specified array of ints.
fill(short[], short) - Static method in class java.util.Arrays
Assigns the specified short value to each element of the specified array of shorts.
fill(short[], int, int, short) - Static method in class java.util.Arrays
Assigns the specified short value to each element of the specified range of the specified array of shorts.
fill(char[], char) - Static method in class java.util.Arrays
Assigns the specified char value to each element of the specified array of chars.
fill(char[], int, int, char) - Static method in class java.util.Arrays
Assigns the specified char value to each element of the specified range of the specified array of chars.
fill(byte[], byte) - Static method in class java.util.Arrays
Assigns the specified byte value to each element of the specified array of bytes.
fill(byte[], int, int, byte) - Static method in class java.util.Arrays
Assigns the specified byte value to each element of the specified range of the specified array of bytes.
fill(boolean[], boolean) - Static method in class java.util.Arrays
Assigns the specified boolean value to each element of the specified array of booleans.
fill(boolean[], int, int, boolean) - Static method in class java.util.Arrays
Assigns the specified boolean value to each element of the specified range of the specified array of booleans.
fill(double[], double) - Static method in class java.util.Arrays
Assigns the specified double value to each element of the specified array of doubles.
fill(double[], int, int, double) - Static method in class java.util.Arrays
Assigns the specified double value to each element of the specified range of the specified array of doubles.
fill(float[], float) - Static method in class java.util.Arrays
Assigns the specified float value to each element of the specified array of floats.
fill(float[], int, int, float) - Static method in class java.util.Arrays
Assigns the specified float value to each element of the specified range of the specified array of floats.
fill(Object[], Object) - Static method in class java.util.Arrays
Assigns the specified Object reference to each element of the specified array of Objects.
fill(Object[], int, int, Object) - Static method in class java.util.Arrays
Assigns the specified Object reference to each element of the specified range of the specified array of Objects.
fill(List<? super T>, T) - Static method in class java.util.Collections
Replaces all of the elements of the specified list with the specified element.
fill() - Method in class java.util.zip.InflaterInputStream
Fills input buffer with more data to decompress.
fill3DRect(int, int, int, int, boolean) - Method in class java.awt.Graphics
Paints a 3-D highlighted rectangle filled with the current color.
fill3DRect(int, int, int, int, boolean) - Method in class java.awt.Graphics2D
Paints a 3-D highlighted rectangle filled with the current color.
fill3DRect(int, int, int, int, boolean) - Method in class javax.swing.DebugGraphics
Overrides Graphics.fill3DRect.
fillArc(int, int, int, int, int, int) - Method in class java.awt.Graphics
Fills a circular or elliptical arc covering the specified rectangle.
fillArc(int, int, int, int, int, int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.fillArc.
filledSlider - Variable in class javax.swing.plaf.metal.MetalSliderUI
FILLER - Static variable in class javax.accessibility.AccessibleRole
An object that fills up space in a user interface.
Filler(Dimension, Dimension, Dimension) - Constructor for class javax.swing.Box.Filler
Constructor to create shape with the given size ranges.
fillInStackTrace() - Method in class java.lang.Throwable
Fills in the execution stack trace.
fillOval(int, int, int, int) - Method in class java.awt.Graphics
Fills an oval bounded by the specified rectangle with the current color.
fillOval(int, int, int, int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.fillOval.
fillPolygon(int[], int[], int) - Method in class java.awt.Graphics
Fills a closed polygon defined by arrays of x and y coordinates.
fillPolygon(Polygon) - Method in class java.awt.Graphics
Fills the polygon defined by the specified Polygon object with the graphics context's current color.
fillPolygon(int[], int[], int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.fillPolygon.
fillRect(int, int, int, int) - Method in class java.awt.Graphics
Fills the specified rectangle.
fillRect(int, int, int, int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.fillRect.
fillRoundRect(int, int, int, int, int, int) - Method in class java.awt.Graphics
Fills the specified rounded corner rectangle with the current color.
fillRoundRect(int, int, int, int, int, int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.fillRoundRect.
filter(BufferedImage, BufferedImage) - Method in class java.awt.image.AffineTransformOp
Transforms the source BufferedImage and stores the results in the destination BufferedImage.
filter(Raster, WritableRaster) - Method in class java.awt.image.AffineTransformOp
Transforms the source Raster and stores the results in the destination Raster.
filter(Raster, WritableRaster) - Method in class java.awt.image.BandCombineOp
Transforms the Raster using the matrix specified in the constructor.
filter(BufferedImage, BufferedImage) - Method in interface java.awt.image.BufferedImageOp
Performs a single-input/single-output operation on a BufferedImage.
filter(BufferedImage, BufferedImage) - Method in class java.awt.image.ColorConvertOp
ColorConverts the source BufferedImage.
filter(Raster, WritableRaster) - Method in class java.awt.image.ColorConvertOp
ColorConverts the image data in the source Raster.
filter(BufferedImage, BufferedImage) - Method in class java.awt.image.ConvolveOp
Performs a convolution on BufferedImages.
filter(Raster, WritableRaster) - Method in class java.awt.image.ConvolveOp
Performs a convolution on Rasters.
filter(BufferedImage, BufferedImage) - Method in class java.awt.image.LookupOp
Performs a lookup operation on a BufferedImage.
filter(Raster, WritableRaster) - Method in class java.awt.image.LookupOp
Performs a lookup operation on a Raster.
filter(Raster, WritableRaster) - Method in interface java.awt.image.RasterOp
Performs a single-input/single-output operation from a source Raster to a destination Raster.
filter(BufferedImage, BufferedImage) - Method in class java.awt.image.RescaleOp
Rescales the source BufferedImage.
filter(Raster, WritableRaster) - Method in class java.awt.image.RescaleOp
Rescales the pixel data in the source Raster.
filter(List<Locale.LanguageRange>, Collection<Locale>, Locale.FilteringMode) - Static method in class java.util.Locale
Returns a list of matching Locale instances using the filtering mechanism defined in RFC 4647.
filter(List<Locale.LanguageRange>, Collection<Locale>) - Static method in class java.util.Locale
Returns a list of matching Locale instances using the filtering mechanism defined in RFC 4647.
Filter - Interface in java.util.logging
A Filter can be used to provide fine grain control over what is logged, beyond the control provided by log levels.
filter(Predicate<? super T>) - Method in class java.util.Optional
If a value is present, and the value matches the given predicate, return an Optional describing the value, otherwise return an empty Optional.
filter(DoublePredicate) - Method in interface java.util.stream.DoubleStream
Returns a stream consisting of the elements of this stream that match the given predicate.
filter(IntPredicate) - Method in interface java.util.stream.IntStream
Returns a stream consisting of the elements of this stream that match the given predicate.
filter(LongPredicate) - Method in interface java.util.stream.LongStream
Returns a stream consisting of the elements of this stream that match the given predicate.
filter(Predicate<? super T>) - Method in interface java.util.stream.Stream
Returns a stream consisting of the elements of this stream that match the given predicate.
filter(Object) - Method in interface javax.imageio.spi.ServiceRegistry.Filter
Returns true if the given provider object matches the criterion defined by this Filter.
FILTER_ACCEPT - Static variable in interface org.w3c.dom.ls.LSParserFilter
Accept the node.
FILTER_INTERRUPT - Static variable in interface org.w3c.dom.ls.LSParserFilter
Interrupt the normal processing of the document.
FILTER_REJECT - Static variable in interface org.w3c.dom.ls.LSParserFilter
Reject the node and its children.
FILTER_SKIP - Static variable in interface org.w3c.dom.ls.LSParserFilter
Skip this single node.
filterArguments(MethodHandle, int, MethodHandle...) - Static method in class java.lang.invoke.MethodHandles
Adapts a target method handle by pre-processing one or more of its arguments, each with its own unary filter function, and then calling the target with each pre-processed argument replaced by the result of its corresponding filter function.
FilterBypass() - Constructor for class javax.swing.text.DocumentFilter.FilterBypass
FilterBypass() - Constructor for class javax.swing.text.NavigationFilter.FilterBypass
FilterComboBoxModel() - Constructor for class javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxModel
FilterComboBoxRenderer() - Constructor for class javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxRenderer
FILTERED - Static variable in class java.util.zip.Deflater
Compression strategy best used for data consisting mostly of small values with a somewhat random distribution.
FilteredImageSource - Class in java.awt.image
This class is an implementation of the ImageProducer interface which takes an existing image and a filter object and uses them to produce image data for a new filtered version of the original image.
FilteredImageSource(ImageProducer, ImageFilter) - Constructor for class java.awt.image.FilteredImageSource
Constructs an ImageProducer object from an existing ImageProducer and a filter object.
FilteredRowSet - Interface in javax.sql.rowset
The standard interface that all standard implementations of FilteredRowSet must implement.
filterIndexColorModel(IndexColorModel) - Method in class java.awt.image.RGBImageFilter
Filters an IndexColorModel object by running each entry in its color tables through the filterRGB function that RGBImageFilter subclasses must provide.
FilterInputStream - Class in java.io
A FilterInputStream contains some other input stream, which it uses as its basic source of data, possibly transforming the data along the way or providing additional functionality.
FilterInputStream(InputStream) - Constructor for class java.io.FilterInputStream
Creates a FilterInputStream by assigning the argument in to the field this.in so as to remember it for later use.
FilterOutputStream - Class in java.io
This class is the superclass of all classes that filter output streams.
FilterOutputStream(OutputStream) - Constructor for class java.io.FilterOutputStream
Creates an output stream filter built on top of the specified underlying output stream.
FilterReader - Class in java.io
Abstract class for reading filtered character streams.
FilterReader(Reader) - Constructor for class java.io.FilterReader
Creates a new filtered reader.
filterReturnValue(MethodHandle, MethodHandle) - Static method in class java.lang.invoke.MethodHandles
Adapts a target method handle by post-processing its return value (if any) with a filter (another method handle).
filterRGB(int, int, int) - Method in class java.awt.image.RGBImageFilter
Subclasses must specify a method to convert a single input pixel in the default RGB ColorModel to a single output pixel.
filterRGB(int, int, int) - Method in class javax.swing.GrayFilter
Overrides RGBImageFilter.filterRGB.
filterRGBPixels(int, int, int, int, int[], int, int) - Method in class java.awt.image.RGBImageFilter
Filters a buffer of pixels in the default RGB ColorModel by passing them one by one through the filterRGB method.
filters - Variable in class javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxModel
filterTags(List<Locale.LanguageRange>, Collection<String>, Locale.FilteringMode) - Static method in class java.util.Locale
Returns a list of matching languages tags using the basic filtering mechanism defined in RFC 4647.
filterTags(List<Locale.LanguageRange>, Collection<String>) - Static method in class java.util.Locale
Returns a list of matching languages tags using the basic filtering mechanism defined in RFC 4647.
FilterWriter - Class in java.io
Abstract class for writing filtered character streams.
FilterWriter(Writer) - Constructor for class java.io.FilterWriter
Create a new filtered writer.
FINAL - Static variable in class java.lang.reflect.Modifier
The int value representing the final modifier.
FINAL_QUOTE_PUNCTUATION - Static variable in class java.lang.Character
General category "Pf" in the Unicode specification.
finalize() - Method in class java.awt.color.ICC_Profile
Frees the resources associated with an ICC_Profile object.
finalize() - Method in class java.awt.Graphics
Disposes of this graphics context once it is no longer referenced.
finalize() - Method in class java.awt.image.ColorModel
Disposes of system resources associated with this ColorModel once this ColorModel is no longer referenced.
finalize() - Method in class java.awt.image.IndexColorModel
Disposes of system resources associated with this ColorModel once this ColorModel is no longer referenced.
finalize() - Method in class java.awt.PrintJob
Ends this print job once it is no longer referenced.
finalize() - Method in class java.io.FileInputStream
Ensures that the close method of this file input stream is called when there are no more references to it.
finalize() - Method in class java.io.FileOutputStream
Cleans up the connection to the file, and ensures that the close method of this file output stream is called when there are no more references to this stream.
finalize() - Method in class java.lang.Enum
enum classes cannot have finalize methods.
finalize() - Method in class java.lang.Object
Called by the garbage collector on an object when garbage collection determines that there are no more references to the object.
finalize() - Method in class java.util.concurrent.ThreadPoolExecutor
Invokes shutdown when this executor is no longer referenced and it has no threads.
finalize() - Method in class java.util.zip.Deflater
Closes the compressor when garbage is collected.
finalize() - Method in class java.util.zip.Inflater
Closes the decompressor when garbage is collected.
finalize() - Method in class java.util.zip.ZipFile
Ensures that the system resources held by this ZipFile object are released when there are no more references to it.
finalize() - Method in class javax.crypto.ExemptionMechanism
Ensures that the key stored away by this ExemptionMechanism object will be wiped out when there are no more references to it.
finalize() - Method in class javax.imageio.spi.ServiceRegistry
Finalizes this object prior to garbage collection.
finalize() - Method in class javax.imageio.stream.FileCacheImageInputStream
Finalizes this object prior to garbage collection.
finalize() - Method in class javax.imageio.stream.FileImageInputStream
Finalizes this object prior to garbage collection.
finalize() - Method in class javax.imageio.stream.FileImageOutputStream
Finalizes this object prior to garbage collection.
finalize() - Method in class javax.imageio.stream.ImageInputStreamImpl
Finalizes this object prior to garbage collection.
finalize() - Method in class javax.imageio.stream.MemoryCacheImageInputStream
Finalizes this object prior to garbage collection.
finalSubString(AttributeValueExp, StringValueExp) - Static method in class javax.management.Query
Returns a query expression that represents a matching constraint on a string argument.
find(Path, int, BiPredicate<Path, BasicFileAttributes>, FileVisitOption...) - Static method in class java.nio.file.Files
Return a Stream that is lazily populated with Path by searching for files in a file tree rooted at a given starting file.
find() - Method in class java.util.regex.Matcher
Attempts to find the next subsequence of the input sequence that matches the pattern.
find(int) - Method in class java.util.regex.Matcher
Resets this matcher and then attempts to find the next subsequence of the input sequence that matches the pattern, starting at the specified index.
find_POA(String, boolean) - Method in interface org.omg.PortableServer.POAOperations
If the target POA is the parent of a child POA with the specified name (relative to the target POA), that child POA is returned.
findAny() - Method in interface java.util.stream.DoubleStream
Returns an OptionalDouble describing some element of the stream, or an empty OptionalDouble if the stream is empty.
findAny() - Method in interface java.util.stream.IntStream
Returns an OptionalInt describing some element of the stream, or an empty OptionalInt if the stream is empty.
findAny() - Method in interface java.util.stream.LongStream
Returns an OptionalLong describing some element of the stream, or an empty OptionalLong if the stream is empty.
findAny() - Method in interface java.util.stream.Stream
Returns an Optional describing some element of the stream, or an empty Optional if the stream is empty.
findAssociatedMBeans(ObjectName, String, String) - Method in class javax.management.relation.RelationService
Retrieves the MBeans associated to given one in a relation.
findAssociatedMBeans(ObjectName, String, String) - Method in interface javax.management.relation.RelationServiceMBean
Retrieves the MBeans associated to given one in a relation.
findClass(String) - Method in class java.lang.ClassLoader
Finds the class with the specified binary name.
findClass(String) - Method in class java.net.URLClassLoader
Finds and loads the class with the specified name from the URL search path.
findClass(String) - Method in class javax.management.loading.MLet
This is the main method for class loaders that is being redefined.
findColumn(String) - Method in interface java.sql.ResultSet
Maps the given ResultSet column label to its ResultSet column index.
findColumn(String) - Method in class javax.swing.table.AbstractTableModel
Returns a column given its name.
findComponentAt(int, int) - Method in class java.awt.Container
Locates the visible child component that contains the specified position.
findComponentAt(Point) - Method in class java.awt.Container
Locates the visible child component that contains the specified point.
findConstructor(Class<?>, MethodType) - Method in class java.lang.invoke.MethodHandles.Lookup
Produces a method handle which creates an object and initializes it, using the constructor of the specified type.
findDeadlockedThreads() - Method in interface java.lang.management.ThreadMXBean
Finds cycles of threads that are in deadlock waiting to acquire object monitors or ownable synchronizers.
findEditor(Class<?>) - Static method in class java.beans.PropertyEditorManager
Locate a value editor for a given target type.
findElementMatchingTag(HTMLDocument, int, HTML.Tag) - Method in class javax.swing.text.html.HTMLEditorKit.HTMLTextAction
Returns the deepest element at offset matching tag.
findFirst() - Method in interface java.util.stream.DoubleStream
Returns an OptionalDouble describing the first element of this stream, or an empty OptionalDouble if the stream is empty.
findFirst() - Method in interface java.util.stream.IntStream
Returns an OptionalInt describing the first element of this stream, or an empty OptionalInt if the stream is empty.
findFirst() - Method in interface java.util.stream.LongStream
Returns an OptionalLong describing the first element of this stream, or an empty OptionalLong if the stream is empty.
findFirst() - Method in interface java.util.stream.Stream
Returns an Optional describing the first element of this stream, or an empty Optional if the stream is empty.
findFocusOwner(Component) - Static method in class javax.swing.SwingUtilities
Deprecated.
As of 1.4, replaced by KeyboardFocusManager.getFocusOwner().
findGetter(Class<?>, String, Class<?>) - Method in class java.lang.invoke.MethodHandles.Lookup
Produces a method handle giving read access to a non-static field.
findInLine(String) - Method in class java.util.Scanner
Attempts to find the next occurrence of a pattern constructed from the specified string, ignoring delimiters.
findInLine(Pattern) - Method in class java.util.Scanner
Attempts to find the next occurrence of the specified pattern ignoring delimiters.
findLibrary(String) - Method in class java.lang.ClassLoader
Returns the absolute path name of a native library.
findLibrary(String) - Method in class javax.management.loading.MLet
Returns the absolute path name of a native library.
findLoadedClass(String) - Method in class java.lang.ClassLoader
Returns the class with the given binary name if this loader has been recorded by the Java virtual machine as an initiating loader of a class with that binary name.
findMBeanServer(String) - Static method in class javax.management.MBeanServerFactory
Return a list of registered MBeanServer objects.
findMedia(float, float, int) - Static method in class javax.print.attribute.standard.MediaSize
The specified dimensions are used to locate a matching MediaSize instance from amongst all the standard MediaSize instances.
findMonitorDeadlockedThreads() - Method in interface java.lang.management.ThreadMXBean
Finds cycles of threads that are in deadlock waiting to acquire object monitors.
findOffsetToCharactersInString(char[], int) - Method in class javax.swing.text.ParagraphView
Finds the next character in the document with a character in string, starting at offset start.
findReferencingRelations(ObjectName, String, String) - Method in class javax.management.relation.RelationService
Retrieves the relations where a given MBean is referenced.
findReferencingRelations(ObjectName, String, String) - Method in interface javax.management.relation.RelationServiceMBean
Retrieves the relations where a given MBean is referenced.
findRelationsOfType(String) - Method in class javax.management.relation.RelationService
Returns the relation ids for relations of the given type.
findRelationsOfType(String) - Method in interface javax.management.relation.RelationServiceMBean
Returns the relation ids for relations of the given type.
findResource(String) - Method in class java.lang.ClassLoader
Finds the resource with the given name.
findResource(String) - Method in class java.net.URLClassLoader
Finds the resource with the specified name on the URL search path.
findResources(String) - Method in class java.lang.ClassLoader
Returns an enumeration of URL objects representing all the resources with the given name.
findResources(String) - Method in class java.net.URLClassLoader
Returns an Enumeration of URLs representing all of the resources on the URL search path having the specified name.
findSetter(Class<?>, String, Class<?>) - Method in class java.lang.invoke.MethodHandles.Lookup
Produces a method handle giving write access to a non-static field.
findSpecial(Class<?>, String, MethodType, Class<?>) - Method in class java.lang.invoke.MethodHandles.Lookup
Produces an early-bound method handle for a virtual method.
findStatic(Class<?>, String, MethodType) - Method in class java.lang.invoke.MethodHandles.Lookup
Produces a method handle for a static method.
findStaticGetter(Class<?>, String, Class<?>) - Method in class java.lang.invoke.MethodHandles.Lookup
Produces a method handle giving read access to a static field.
findStaticSetter(Class<?>, String, Class<?>) - Method in class java.lang.invoke.MethodHandles.Lookup
Produces a method handle giving write access to a static field.
findSystemClass(String) - Method in class java.lang.ClassLoader
Finds a class with the specified binary name, loading it if necessary.
findVirtual(Class<?>, String, MethodType) - Method in class java.lang.invoke.MethodHandles.Lookup
Produces a method handle for a virtual method.
findWithinHorizon(String, int) - Method in class java.util.Scanner
Attempts to find the next occurrence of a pattern constructed from the specified string, ignoring delimiters.
findWithinHorizon(Pattern, int) - Method in class java.util.Scanner
Attempts to find the next occurrence of the specified pattern.
FINE - Static variable in class java.util.logging.Level
FINE is a message level providing tracing information.
fine(String) - Method in class java.util.logging.Logger
Log a FINE message.
fine(Supplier<String>) - Method in class java.util.logging.Logger
Log a FINE message, which is only to be constructed if the logging level is such that the message will actually be logged.
FINER - Static variable in class java.util.logging.Level
FINER indicates a fairly detailed tracing message.
finer(String) - Method in class java.util.logging.Logger
Log a FINER message.
finer(Supplier<String>) - Method in class java.util.logging.Logger
Log a FINER message, which is only to be constructed if the logging level is such that the message will actually be logged.
FINEST - Static variable in class java.util.logging.Level
FINEST indicates a highly detailed tracing message.
finest(String) - Method in class java.util.logging.Logger
Log a FINEST message.
finest(Supplier<String>) - Method in class java.util.logging.Logger
Log a FINEST message, which is only to be constructed if the logging level is such that the message will actually be logged.
finish() - Method in class java.util.zip.Deflater
When called, indicates that compression should end with the current contents of the input buffer.
finish() - Method in class java.util.zip.DeflaterOutputStream
Finishes writing compressed data to the output stream without closing the underlying stream.
finish() - Method in class java.util.zip.GZIPOutputStream
Finishes writing compressed data to the output stream without closing the underlying stream.
finish() - Method in class java.util.zip.InflaterOutputStream
Finishes writing uncompressed data to the output stream without closing the underlying stream.
finish() - Method in class java.util.zip.ZipOutputStream
Finishes writing the contents of the ZIP output stream without closing the underlying stream.
finishConnect() - Method in class java.nio.channels.SocketChannel
Finishes the process of connecting a socket channel.
finishDraggingTo(int) - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider
Messages the BasicSplitPaneUI with finishDraggingTo that this instance is contained in.
finishDraggingTo(int) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Messaged to finish the dragging session.
finished() - Method in class java.util.zip.Deflater
Returns true if the end of the compressed data output stream has been reached.
finished() - Method in class java.util.zip.Inflater
Returns true if the end of the compressed data stream has been reached.
finishedPaintingChildren(JSplitPane, Graphics) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Called when the specified split pane has finished painting its children.
finishedPaintingChildren(JSplitPane, Graphics) - Method in class javax.swing.plaf.multi.MultiSplitPaneUI
Invokes the finishedPaintingChildren method on each UI handled by this object.
finishedPaintingChildren(JSplitPane, Graphics) - Method in class javax.swing.plaf.SplitPaneUI
Messaged after the JSplitPane the receiver is providing the look and feel for paints its children.
finishedPaintingChildren(JSplitPane, Graphics) - Method in class javax.swing.plaf.synth.SynthSplitPaneUI
Called when the specified split pane has finished painting its children.
finisher() - Method in interface java.util.stream.Collector
Perform the final transformation from the intermediate accumulation type A to the final result type R.
Finishings - Class in javax.print.attribute.standard
Class Finishings is a printing attribute class, an enumeration, that identifies whether the printer applies a finishing operation of some kind of binding to each copy of each printed document in the job.
Finishings(int) - Constructor for class javax.print.attribute.standard.Finishings
Construct a new finishings binding enumeration value with the given integer value.
fireActionEvent() - Method in class javax.swing.JComboBox
Notifies all listeners that have registered interest for notification on this event type.
fireActionPerformed(ActionEvent) - Method in class javax.swing.AbstractButton
Notifies all listeners that have registered interest for notification on this event type.
fireActionPerformed(ActionEvent) - Method in class javax.swing.DefaultButtonModel
Notifies all listeners that have registered interest for notification on this event type.
fireActionPerformed(String) - Method in class javax.swing.JFileChooser
Notifies all listeners that have registered interest for notification on this event type.
fireActionPerformed() - Method in class javax.swing.JTextField
Notifies all listeners that have registered interest for notification on this event type.
fireActionPerformed(ActionEvent) - Method in class javax.swing.Timer
Notifies all listeners that have registered interest for notification on this event type.
fireAdjustmentValueChanged(int, int, int) - Method in class javax.swing.JScrollBar
Notify listeners that the scrollbar's model has changed.
fireCaretUpdate(CaretEvent) - Method in class javax.swing.text.JTextComponent
Notifies all listeners that have registered interest for notification on this event type.
fireChangedUpdate(DocumentEvent) - Method in class javax.swing.text.AbstractDocument
Notifies all listeners that have registered interest for notification on this event type.
fireChangedUpdate(DocumentEvent) - Method in class javax.swing.text.html.HTMLDocument
Notifies all listeners that have registered interest for notification on this event type.
fireChildrenAdded(BeanContextMembershipEvent) - Method in class java.beans.beancontext.BeanContextSupport
Fire a BeanContextshipEvent on the BeanContextMembershipListener interface
fireChildrenRemoved(BeanContextMembershipEvent) - Method in class java.beans.beancontext.BeanContextSupport
Fire a BeanContextshipEvent on the BeanContextMembershipListener interface
fireColumnAdded(TableColumnModelEvent) - Method in class javax.swing.table.DefaultTableColumnModel
Notifies all listeners that have registered interest for notification on this event type.
fireColumnMarginChanged() - Method in class javax.swing.table.DefaultTableColumnModel
Notifies all listeners that have registered interest for notification on this event type.
fireColumnMoved(TableColumnModelEvent) - Method in class javax.swing.table.DefaultTableColumnModel
Notifies all listeners that have registered interest for notification on this event type.
fireColumnRemoved(TableColumnModelEvent) - Method in class javax.swing.table.DefaultTableColumnModel
Notifies all listeners that have registered interest for notification on this event type.
fireColumnSelectionChanged(ListSelectionEvent) - Method in class javax.swing.table.DefaultTableColumnModel
Notifies all listeners that have registered interest for notification on this event type.
fireContentsChanged(Object, int, int) - Method in class javax.swing.AbstractListModel
AbstractListModel subclasses must call this method after one or more elements of the list change.
fireContentsChanged() - Method in class javax.swing.plaf.basic.BasicDirectoryModel
fireDragGestureRecognized(int, Point) - Method in class java.awt.dnd.DragGestureRecognizer
Notify the DragGestureListener that a Drag and Drop initiating gesture has occurred.
fireEditingCanceled() - Method in class javax.swing.AbstractCellEditor
Notifies all listeners that have registered interest for notification on this event type.
fireEditingStopped() - Method in class javax.swing.AbstractCellEditor
Notifies all listeners that have registered interest for notification on this event type.
fireHyperlinkUpdate(HyperlinkEvent) - Method in class javax.swing.JEditorPane
Notifies all listeners that have registered interest for notification on this event type.
fireIndexedPropertyChange(String, int, Object, Object) - Method in class java.beans.PropertyChangeSupport
Reports a bound indexed property update to listeners that have been registered to track updates of all properties or a property with the specified name.
fireIndexedPropertyChange(String, int, int, int) - Method in class java.beans.PropertyChangeSupport
Reports an integer bound indexed property update to listeners that have been registered to track updates of all properties or a property with the specified name.
fireIndexedPropertyChange(String, int, boolean, boolean) - Method in class java.beans.PropertyChangeSupport
Reports a boolean bound indexed property update to listeners that have been registered to track updates of all properties or a property with the specified name.
fireInsertUpdate(DocumentEvent) - Method in class javax.swing.text.AbstractDocument
Notifies all listeners that have registered interest for notification on this event type.
fireInternalFrameEvent(int) - Method in class javax.swing.JInternalFrame
Fires an internal frame event.
fireIntervalAdded(Object, int, int) - Method in class javax.swing.AbstractListModel
AbstractListModel subclasses must call this method after one or more elements are added to the model.
fireIntervalRemoved(Object, int, int) - Method in class javax.swing.AbstractListModel
AbstractListModel subclasses must call this method after one or more elements are removed from the model.
fireItemStateChanged(ItemEvent) - Method in class javax.swing.AbstractButton
Notifies all listeners that have registered interest for notification on this event type.
fireItemStateChanged(ItemEvent) - Method in class javax.swing.DefaultButtonModel
Notifies all listeners that have registered interest for notification on this event type.
fireItemStateChanged(ItemEvent) - Method in class javax.swing.JComboBox
Notifies all listeners that have registered interest for notification on this event type.
fireMenuCanceled() - Method in class javax.swing.JMenu
Notifies all listeners that have registered interest for notification on this event type.
fireMenuDeselected() - Method in class javax.swing.JMenu
Notifies all listeners that have registered interest for notification on this event type.
fireMenuDragMouseDragged(MenuDragMouseEvent) - Method in class javax.swing.JMenuItem
Notifies all listeners that have registered interest for notification on this event type.
fireMenuDragMouseEntered(MenuDragMouseEvent) - Method in class javax.swing.JMenuItem
Notifies all listeners that have registered interest for notification on this event type.
fireMenuDragMouseExited(MenuDragMouseEvent) - Method in class javax.swing.JMenuItem
Notifies all listeners that have registered interest for notification on this event type.
fireMenuDragMouseReleased(MenuDragMouseEvent) - Method in class javax.swing.JMenuItem
Notifies all listeners that have registered interest for notification on this event type.
fireMenuKeyPressed(MenuKeyEvent) - Method in class javax.swing.JMenuItem
Notifies all listeners that have registered interest for notification on this event type.
fireMenuKeyReleased(MenuKeyEvent) - Method in class javax.swing.JMenuItem
Notifies all listeners that have registered interest for notification on this event type.
fireMenuKeyTyped(MenuKeyEvent) - Method in class javax.swing.JMenuItem
Notifies all listeners that have registered interest for notification on this event type.
fireMenuSelected() - Method in class javax.swing.JMenu
Notifies all listeners that have registered interest for notification on this event type.
firePopupMenuCanceled() - Method in class javax.swing.JComboBox
Notifies PopupMenuListeners that the popup portion of the combo box has been canceled.
firePopupMenuCanceled() - Method in class javax.swing.JPopupMenu
Notifies PopupMenuListeners that this popup menu is cancelled.
firePopupMenuCanceled() - Method in class javax.swing.plaf.basic.BasicComboPopup
firePopupMenuWillBecomeInvisible() - Method in class javax.swing.JComboBox
Notifies PopupMenuListeners that the popup portion of the combo box has become invisible.
firePopupMenuWillBecomeInvisible() - Method in class javax.swing.JPopupMenu
Notifies PopupMenuListeners that this popup menu will become invisible.
firePopupMenuWillBecomeInvisible() - Method in class javax.swing.plaf.basic.BasicComboPopup
firePopupMenuWillBecomeVisible() - Method in class javax.swing.JComboBox
Notifies PopupMenuListeners that the popup portion of the combo box will become visible.
firePopupMenuWillBecomeVisible() - Method in class javax.swing.JPopupMenu
Notifies PopupMenuListeners that this popup menu will become visible.
firePopupMenuWillBecomeVisible() - Method in class javax.swing.plaf.basic.BasicComboPopup
firePropertyChange(String, Object, Object) - Method in class java.awt.Component
Support for reporting bound property changes for Object properties.
firePropertyChange(String, boolean, boolean) - Method in class java.awt.Component
Support for reporting bound property changes for boolean properties.
firePropertyChange(String, int, int) - Method in class java.awt.Component
Support for reporting bound property changes for integer properties.
firePropertyChange(String, byte, byte) - Method in class java.awt.Component
Reports a bound property change.
firePropertyChange(String, char, char) - Method in class java.awt.Component
Reports a bound property change.
firePropertyChange(String, short, short) - Method in class java.awt.Component
Reports a bound property change.
firePropertyChange(String, long, long) - Method in class java.awt.Component
Reports a bound property change.
firePropertyChange(String, float, float) - Method in class java.awt.Component
Reports a bound property change.
firePropertyChange(String, double, double) - Method in class java.awt.Component
Reports a bound property change.
firePropertyChange(String, Object, Object) - Method in class java.awt.KeyboardFocusManager
Fires a PropertyChangeEvent in response to a change in a bound property.
firePropertyChange(String, Object, Object) - Method in class java.beans.beancontext.BeanContextChildSupport
Report a bound property update to any registered listeners.
firePropertyChange(String, Object, Object) - Method in class java.beans.PropertyChangeSupport
Reports a bound property update to listeners that have been registered to track updates of all properties or a property with the specified name.
firePropertyChange(String, int, int) - Method in class java.beans.PropertyChangeSupport
Reports an integer bound property update to listeners that have been registered to track updates of all properties or a property with the specified name.
firePropertyChange(String, boolean, boolean) - Method in class java.beans.PropertyChangeSupport
Reports a boolean bound property update to listeners that have been registered to track updates of all properties or a property with the specified name.
firePropertyChange(PropertyChangeEvent) - Method in class java.beans.PropertyChangeSupport
Fires a property change event to listeners that have been registered to track updates of all properties or a property with the specified name.
firePropertyChange() - Method in class java.beans.PropertyEditorSupport
Report that we have been modified to any interested listeners.
firePropertyChange(String, Object, Object) - Method in class javax.accessibility.AccessibleContext
Support for reporting bound property changes.
firePropertyChange(String, Object, Object) - Method in class javax.swing.AbstractAction
Supports reporting bound property changes.
firePropertyChange(String, Object, Object) - Method in class javax.swing.DefaultListCellRenderer
Overridden for performance reasons.
firePropertyChange(String, byte, byte) - Method in class javax.swing.DefaultListCellRenderer
Overridden for performance reasons.
firePropertyChange(String, char, char) - Method in class javax.swing.DefaultListCellRenderer
Overridden for performance reasons.
firePropertyChange(String, short, short) - Method in class javax.swing.DefaultListCellRenderer
Overridden for performance reasons.
firePropertyChange(String, int, int) - Method in class javax.swing.DefaultListCellRenderer
Overridden for performance reasons.
firePropertyChange(String, long, long) - Method in class javax.swing.DefaultListCellRenderer
Overridden for performance reasons.
firePropertyChange(String, float, float) - Method in class javax.swing.DefaultListCellRenderer
Overridden for performance reasons.
firePropertyChange(String, double, double) - Method in class javax.swing.DefaultListCellRenderer
Overridden for performance reasons.
firePropertyChange(String, boolean, boolean) - Method in class javax.swing.DefaultListCellRenderer
Overridden for performance reasons.
firePropertyChange(PropertyChangeEvent) - Method in class javax.swing.event.SwingPropertyChangeSupport
Fires a property change event to listeners that have been registered to track updates of all properties or a property with the specified name.
firePropertyChange(String, boolean, boolean) - Method in class javax.swing.JComponent
Support for reporting bound property changes for boolean properties.
firePropertyChange(String, int, int) - Method in class javax.swing.JComponent
Support for reporting bound property changes for integer properties.
firePropertyChange(String, char, char) - Method in class javax.swing.JComponent
firePropertyChange(String, Object, Object) - Method in class javax.swing.JViewport
Notifies listeners of a property change.
firePropertyChange(String, Object, Object) - Method in class javax.swing.plaf.basic.BasicDirectoryModel
Support for reporting bound property changes for boolean properties.
firePropertyChange(String, Object, Object) - Method in class javax.swing.plaf.LayerUI
Support for reporting bound property changes for Object properties.
firePropertyChange(String, Object, Object) - Method in class javax.swing.SwingWorker
Reports a bound property update to any registered listeners.
firePropertyChange(String, Object, Object) - Method in class javax.swing.table.DefaultTableCellRenderer
Overridden for performance reasons.
firePropertyChange(String, boolean, boolean) - Method in class javax.swing.table.DefaultTableCellRenderer
Overridden for performance reasons.
firePropertyChange(String, Object, Object) - Method in class javax.swing.tree.DefaultTreeCellRenderer
Overridden for performance reasons.
firePropertyChange(String, byte, byte) - Method in class javax.swing.tree.DefaultTreeCellRenderer
Overridden for performance reasons.
firePropertyChange(String, char, char) - Method in class javax.swing.tree.DefaultTreeCellRenderer
Overridden for performance reasons.
firePropertyChange(String, short, short) - Method in class javax.swing.tree.DefaultTreeCellRenderer
Overridden for performance reasons.
firePropertyChange(String, int, int) - Method in class javax.swing.tree.DefaultTreeCellRenderer
Overridden for performance reasons.
firePropertyChange(String, long, long) - Method in class javax.swing.tree.DefaultTreeCellRenderer
Overridden for performance reasons.
firePropertyChange(String, float, float) - Method in class javax.swing.tree.DefaultTreeCellRenderer
Overridden for performance reasons.
firePropertyChange(String, double, double) - Method in class javax.swing.tree.DefaultTreeCellRenderer
Overridden for performance reasons.
firePropertyChange(String, boolean, boolean) - Method in class javax.swing.tree.DefaultTreeCellRenderer
Overridden for performance reasons.
firePropertyChange(String, Object, Object) - Method in class javax.swing.UIDefaults
Support for reporting bound property changes.
fireRemoveUpdate(DocumentEvent) - Method in class javax.swing.text.AbstractDocument
Notifies all listeners that have registered interest for notification on this event type.
fireRowSorterChanged(int[]) - Method in class javax.swing.RowSorter
Notifies listener that the mapping has changed.
fireSelectionValueChanged(int, int, boolean) - Method in class javax.swing.JList
Notifies ListSelectionListeners added directly to the list of selection changes made to the selection model.
fireServiceAdded(Class) - Method in class java.beans.beancontext.BeanContextServicesSupport
Fires a BeanContextServiceEvent notifying of a new service.
fireServiceAdded(BeanContextServiceAvailableEvent) - Method in class java.beans.beancontext.BeanContextServicesSupport
Fires a BeanContextServiceAvailableEvent indicating that a new service has become available.
fireServiceRevoked(BeanContextServiceRevokedEvent) - Method in class java.beans.beancontext.BeanContextServicesSupport
Fires a BeanContextServiceEvent notifying of a service being revoked.
fireServiceRevoked(Class, boolean) - Method in class java.beans.beancontext.BeanContextServicesSupport
Fires a BeanContextServiceRevokedEvent indicating that a particular service is no longer available.
fireSortOrderChanged() - Method in class javax.swing.RowSorter
Notifies listener that the sort order has changed.
fireStateChanged() - Method in class javax.swing.AbstractButton
Notifies all listeners that have registered interest for notification on this event type.
fireStateChanged() - Method in class javax.swing.AbstractSpinnerModel
Run each ChangeListeners stateChanged() method.
fireStateChanged() - Method in class javax.swing.colorchooser.DefaultColorSelectionModel
Runs each ChangeListener's stateChanged method.
fireStateChanged() - Method in class javax.swing.DefaultBoundedRangeModel
Runs each ChangeListener's stateChanged method.
fireStateChanged() - Method in class javax.swing.DefaultButtonModel
Notifies all listeners that have registered interest for notification on this event type.
fireStateChanged() - Method in class javax.swing.DefaultSingleSelectionModel
Notifies all listeners that have registered interest for notification on this event type.
fireStateChanged() - Method in class javax.swing.JProgressBar
Send a ChangeEvent, whose source is this JProgressBar, to all ChangeListeners that have registered interest in ChangeEvents.
fireStateChanged() - Method in class javax.swing.JSlider
Send a ChangeEvent, whose source is this JSlider, to all ChangeListeners that have registered interest in ChangeEvents.
fireStateChanged() - Method in class javax.swing.JSpinner
Sends a ChangeEvent, whose source is this JSpinner, to each ChangeListener.
fireStateChanged() - Method in class javax.swing.JTabbedPane
Sends a ChangeEvent, with this JTabbedPane as the source, to each registered listener.
fireStateChanged() - Method in class javax.swing.JViewport
Notifies all ChangeListeners when the views size, position, or the viewports extent size has changed.
fireStateChanged() - Method in class javax.swing.MenuSelectionManager
Notifies all listeners that have registered interest for notification on this event type.
fireStateChanged() - Method in class javax.swing.text.DefaultCaret
Notifies all listeners that have registered interest for notification on this event type.
fireStateChanged() - Method in class javax.swing.text.StyleContext.NamedStyle
Notifies all listeners that have registered interest for notification on this event type.
fireTableCellUpdated(int, int) - Method in class javax.swing.table.AbstractTableModel
Notifies all listeners that the value of the cell at [row, column] has been updated.
fireTableChanged(TableModelEvent) - Method in class javax.swing.table.AbstractTableModel
Forwards the given notification event to all TableModelListeners that registered themselves as listeners for this table model.
fireTableDataChanged() - Method in class javax.swing.table.AbstractTableModel
Notifies all listeners that all cell values in the table's rows may have changed.
fireTableRowsDeleted(int, int) - Method in class javax.swing.table.AbstractTableModel
Notifies all listeners that rows in the range [firstRow, lastRow], inclusive, have been deleted.
fireTableRowsInserted(int, int) - Method in class javax.swing.table.AbstractTableModel
Notifies all listeners that rows in the range [firstRow, lastRow], inclusive, have been inserted.
fireTableRowsUpdated(int, int) - Method in class javax.swing.table.AbstractTableModel
Notifies all listeners that rows in the range [firstRow, lastRow], inclusive, have been updated.
fireTableStructureChanged() - Method in class javax.swing.table.AbstractTableModel
Notifies all listeners that the table's structure has changed.
fireTreeCollapsed(TreePath) - Method in class javax.swing.JTree
Notifies all listeners that have registered interest for notification on this event type.
fireTreeExpanded(TreePath) - Method in class javax.swing.JTree
Notifies all listeners that have registered interest for notification on this event type.
fireTreeNodesChanged(Object, Object[], int[], Object[]) - Method in class javax.swing.tree.DefaultTreeModel
Notifies all listeners that have registered interest for notification on this event type.
fireTreeNodesInserted(Object, Object[], int[], Object[]) - Method in class javax.swing.tree.DefaultTreeModel
Notifies all listeners that have registered interest for notification on this event type.
fireTreeNodesRemoved(Object, Object[], int[], Object[]) - Method in class javax.swing.tree.DefaultTreeModel
Notifies all listeners that have registered interest for notification on this event type.
fireTreeStructureChanged(Object, Object[], int[], Object[]) - Method in class javax.swing.tree.DefaultTreeModel
Notifies all listeners that have registered interest for notification on this event type.
fireTreeWillCollapse(TreePath) - Method in class javax.swing.JTree
Notifies all listeners that have registered interest for notification on this event type.
fireTreeWillExpand(TreePath) - Method in class javax.swing.JTree
Notifies all listeners that have registered interest for notification on this event type.
fireUndoableEditUpdate(UndoableEditEvent) - Method in class javax.swing.text.AbstractDocument
Notifies all listeners that have registered interest for notification on this event type.
fireUndoableEditUpdate(UndoableEditEvent) - Method in class javax.swing.text.html.HTMLDocument
Notifies all listeners that have registered interest for notification on this event type.
fireValueChanged(boolean) - Method in class javax.swing.DefaultListSelectionModel
Notifies listeners that we have ended a series of adjustments.
fireValueChanged(int, int) - Method in class javax.swing.DefaultListSelectionModel
Notifies ListSelectionListeners that the value of the selection, in the closed interval firstIndex, lastIndex, has changed.
fireValueChanged(int, int, boolean) - Method in class javax.swing.DefaultListSelectionModel
fireValueChanged(TreeSelectionEvent) - Method in class javax.swing.JTree
Notifies all listeners that have registered interest for notification on this event type.
fireValueChanged(TreeSelectionEvent) - Method in class javax.swing.tree.DefaultTreeSelectionModel
Notifies all listeners that are registered for tree selection events on this object.
fireVetoableChange(String, Object, Object) - Method in class java.awt.KeyboardFocusManager
Fires a PropertyChangeEvent in response to a change in a vetoable property.
fireVetoableChange(String, Object, Object) - Method in class java.beans.beancontext.BeanContextChildSupport
Report a vetoable property update to any registered listeners.
fireVetoableChange(String, Object, Object) - Method in class java.beans.VetoableChangeSupport
Reports a constrained property update to listeners that have been registered to track updates of all properties or a property with the specified name.
fireVetoableChange(String, int, int) - Method in class java.beans.VetoableChangeSupport
Reports an integer constrained property update to listeners that have been registered to track updates of all properties or a property with the specified name.
fireVetoableChange(String, boolean, boolean) - Method in class java.beans.VetoableChangeSupport
Reports a boolean constrained property update to listeners that have been registered to track updates of all properties or a property with the specified name.
fireVetoableChange(PropertyChangeEvent) - Method in class java.beans.VetoableChangeSupport
Fires a property change event to listeners that have been registered to track updates of all properties or a property with the specified name.
fireVetoableChange(String, Object, Object) - Method in class javax.swing.JComponent
Supports reporting constrained property changes.
fireVisibleDataPropertyChange() - Method in class javax.swing.JTree.AccessibleJTree
Fire a visible data property change notification.
first(Container) - Method in class java.awt.CardLayout
Flips to the first card of the container.
first() - Method in interface java.sql.ResultSet
Moves the cursor to the first row in this ResultSet object.
first() - Method in class java.text.BreakIterator
Returns the first boundary.
first() - Method in interface java.text.CharacterIterator
Sets the position to getBeginIndex() and returns the character at that position.
first() - Method in class java.text.StringCharacterIterator
Implements CharacterIterator.first() for String.
first() - Method in class java.util.concurrent.ConcurrentSkipListSet
first() - Method in interface java.util.SortedSet
Returns the first (lowest) element currently in this set.
first() - Method in class java.util.TreeSet
first() - Method in class javax.swing.text.ElementIterator
Fetches the first element.
first(Object) - Method in class javax.swing.text.html.parser.ContentModel
Return true if the token could potentially be the first token in the input stream.
first() - Method in class javax.swing.text.html.parser.ContentModel
Return the element that must be next.
first() - Method in class javax.swing.text.Segment
Sets the position to getBeginIndex() and returns the character at that position.
FIRST_LINE_END - Static variable in class java.awt.GridBagConstraints
Place the component in the corner of its display area where the first line of text on a page would normally end for the current ComponentOrientation.
FIRST_LINE_START - Static variable in class java.awt.GridBagConstraints
Place the component in the corner of its display area where the first line of text on a page would normally begin for the current ComponentOrientation.
firstColumn - Variable in class javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange
firstComplete() - Method in class java.util.concurrent.CountedCompleter
If this task's pending count is zero, returns this task; otherwise decrements its pending count and returns null.
firstDayOfMonth() - Static method in class java.time.temporal.TemporalAdjusters
Returns the "first day of month" adjuster, which returns a new date set to the first day of the current month.
firstDayOfNextMonth() - Static method in class java.time.temporal.TemporalAdjusters
Returns the "first day of next month" adjuster, which returns a new date set to the first day of the next month.
firstDayOfNextYear() - Static method in class java.time.temporal.TemporalAdjusters
Returns the "first day of next year" adjuster, which returns a new date set to the first day of the next year.
firstDayOfYear(boolean) - Method in enum java.time.Month
Gets the day-of-year corresponding to the first day of this month.
firstDayOfYear() - Static method in class java.time.temporal.TemporalAdjusters
Returns the "first day of year" adjuster, which returns a new date set to the first day of the current year.
firstElement() - Method in class java.util.Vector
Returns the first component (the item at index 0) of this vector.
firstElement() - Method in class javax.swing.DefaultListModel
Returns the first component of this list.
firstEntry() - Method in class java.util.concurrent.ConcurrentSkipListMap
Returns a key-value mapping associated with the least key in this map, or null if the map is empty.
firstEntry() - Method in interface java.util.NavigableMap
Returns a key-value mapping associated with the least key in this map, or null if the map is empty.
firstEntry() - Method in class java.util.TreeMap
firstInMonth(DayOfWeek) - Static method in class java.time.temporal.TemporalAdjusters
Returns the first in month adjuster, which returns a new date in the same month with the first matching day-of-week.
firstKey() - Method in class java.util.concurrent.ConcurrentSkipListMap
firstKey() - Method in interface java.util.SortedMap
Returns the first (lowest) key currently in this map.
firstKey() - Method in class java.util.TreeMap
firstLineIndent - Variable in class javax.swing.text.ParagraphView
Indentation for the first line, from the left inset.
FirstLineIndent - Static variable in class javax.swing.text.StyleConstants
The amount of space to indent the first line of the paragraph.
firstMonthOfQuarter() - Method in enum java.time.Month
Gets the month corresponding to the first month of this quarter.
firstRow - Variable in class javax.swing.event.TableModelEvent
firstRow - Variable in class javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange
fixed(Instant, ZoneId) - Static method in class java.time.Clock
Obtains a clock that always returns the same instant.
FIXED - Static variable in interface javax.swing.text.html.parser.DTDConstants
fixed_digits() - Method in class org.omg.CORBA.TypeCode
Returns the number of digits in the fixed type described by this TypeCode object.
fixed_scale() - Method in class org.omg.CORBA.TypeCode
Returns the scale of the fixed type described by this TypeCode object.
fixedCellHeightChanged - Static variable in class javax.swing.plaf.basic.BasicListUI
fixedCellWidthChanged - Static variable in class javax.swing.plaf.basic.BasicListUI
fixedContentLength - Variable in class java.net.HttpURLConnection
The fixed content-length when using fixed-length streaming mode.
fixedContentLengthLong - Variable in class java.net.HttpURLConnection
The fixed content-length when using fixed-length streaming mode.
FixedHeightLayoutCache - Class in javax.swing.tree
NOTE: This will become more open in a future release.
FixedHeightLayoutCache() - Constructor for class javax.swing.tree.FixedHeightLayoutCache
FixedHolder - Class in org.omg.CORBA
The Holder for Fixed.
FixedHolder() - Constructor for class org.omg.CORBA.FixedHolder
Construct the FixedHolder without initializing the contained value.
FixedHolder(BigDecimal) - Constructor for class org.omg.CORBA.FixedHolder
Construct the FixedHolder and initialize it with the given value.
FLAG_BRIDGES - Static variable in class java.lang.invoke.LambdaMetafactory
Flag for alternate metafactories indicating the lambda object requires additional bridge methods
FLAG_COMPLEX_GLYPHS - Static variable in class java.awt.font.GlyphVector
A flag used with getLayoutFlags that indicates that this GlyphVector has a complex glyph-to-char mapping (one that does not map glyphs to chars one-to-one in strictly ascending or descending order matching the run direction).
FLAG_HAS_POSITION_ADJUSTMENTS - Static variable in class java.awt.font.GlyphVector
A flag used with getLayoutFlags that indicates that this GlyphVector has position adjustments.
FLAG_HAS_TRANSFORMS - Static variable in class java.awt.font.GlyphVector
A flag used with getLayoutFlags that indicates that this GlyphVector has per-glyph transforms.
FLAG_MARKERS - Static variable in class java.lang.invoke.LambdaMetafactory
Flag for alternate metafactories indicating the lambda object implements other marker interfaces besides Serializable
FLAG_MASK - Static variable in class java.awt.font.GlyphVector
A mask for supported flags from getLayoutFlags.
FLAG_RUN_RTL - Static variable in class java.awt.font.GlyphVector
A flag used with getLayoutFlags that indicates that this GlyphVector has a right-to-left run direction.
FLAG_SERIALIZABLE - Static variable in class java.lang.invoke.LambdaMetafactory
Flag for alternate metafactories indicating the lambda object must be serializable
flags() - Method in class java.nio.file.attribute.AclEntry
Returns a copy of the flags component.
flags() - Method in class java.util.regex.Pattern
Returns this pattern's match flags.
flags() - Method in class org.omg.CORBA.NamedValue
Retrieves the argument mode flag for this NamedValue object.
FLASH_OPTION - Static variable in class javax.swing.DebugGraphics
Flash graphics operations.
flashColor() - Static method in class javax.swing.DebugGraphics
Returns the Color used to flash drawing operations.
flashCount() - Static method in class javax.swing.DebugGraphics
Returns the number of times that drawing operations will flash.
flashTime() - Static method in class javax.swing.DebugGraphics
Returns the time delay of drawing operation flashing.
flatMap(Function<? super T, Optional<U>>) - Method in class java.util.Optional
If a value is present, apply the provided Optional-bearing mapping function to it, return that result, otherwise return an empty Optional.
flatMap(DoubleFunction<? extends DoubleStream>) - Method in interface java.util.stream.DoubleStream
Returns a stream consisting of the results of replacing each element of this stream with the contents of a mapped stream produced by applying the provided mapping function to each element.
flatMap(IntFunction<? extends IntStream>) - Method in interface java.util.stream.IntStream
Returns a stream consisting of the results of replacing each element of this stream with the contents of a mapped stream produced by applying the provided mapping function to each element.
flatMap(LongFunction<? extends LongStream>) - Method in interface java.util.stream.LongStream
Returns a stream consisting of the results of replacing each element of this stream with the contents of a mapped stream produced by applying the provided mapping function to each element.
flatMap(Function<? super T, ? extends Stream<? extends R>>) - Method in interface java.util.stream.Stream
Returns a stream consisting of the results of replacing each element of this stream with the contents of a mapped stream produced by applying the provided mapping function to each element.
flatMapToDouble(Function<? super T, ? extends DoubleStream>) - Method in interface java.util.stream.Stream
Returns an DoubleStream consisting of the results of replacing each element of this stream with the contents of a mapped stream produced by applying the provided mapping function to each element.
flatMapToInt(Function<? super T, ? extends IntStream>) - Method in interface java.util.stream.Stream
Returns an IntStream consisting of the results of replacing each element of this stream with the contents of a mapped stream produced by applying the provided mapping function to each element.
flatMapToLong(Function<? super T, ? extends LongStream>) - Method in interface java.util.stream.Stream
Returns an LongStream consisting of the results of replacing each element of this stream with the contents of a mapped stream produced by applying the provided mapping function to each element.
FlatteningPathIterator - Class in java.awt.geom
The FlatteningPathIterator class returns a flattened view of another PathIterator object.
FlatteningPathIterator(PathIterator, double) - Constructor for class java.awt.geom.FlatteningPathIterator
Constructs a new FlatteningPathIterator object that flattens a path as it iterates over it.
FlatteningPathIterator(PathIterator, double, int) - Constructor for class java.awt.geom.FlatteningPathIterator
Constructs a new FlatteningPathIterator object that flattens a path as it iterates over it.
FlavorEvent - Class in java.awt.datatransfer
FlavorEvent is used to notify interested parties that available DataFlavors have changed in the Clipboard (the event source).
FlavorEvent(Clipboard) - Constructor for class java.awt.datatransfer.FlavorEvent
Constructs a FlavorEvent object.
FlavorException - Interface in javax.print
Interface FlavorException is a mixin interface which a subclass of PrintException can implement to report an error condition involving a doc flavor or flavors (class DocFlavor).
FlavorListener - Interface in java.awt.datatransfer
Defines an object which listens for FlavorEvents.
FlavorMap - Interface in java.awt.datatransfer
A two-way Map between "natives" (Strings), which correspond to platform- specific data formats, and "flavors" (DataFlavors), which correspond to platform-independent MIME types.
flavorsChanged(FlavorEvent) - Method in interface java.awt.datatransfer.FlavorListener
Invoked when the target Clipboard of the listener has changed its available DataFlavors.
FlavorTable - Interface in java.awt.datatransfer
A FlavorMap which relaxes the traditional 1-to-1 restriction of a Map.
flip(BufferCapabilities.FlipContents) - Method in class java.awt.Component.FlipBufferStrategy
Flipping moves the contents of the back buffer to the front buffer, either by copying or by moving the video pointer.
flip() - Method in class java.nio.Buffer
Flips this buffer.
flip(int) - Method in class java.util.BitSet
Sets the bit at the specified index to the complement of its current value.
flip(int, int) - Method in class java.util.BitSet
Sets each bit from the specified fromIndex (inclusive) to the specified toIndex (exclusive) to the complement of its current value.
flipBit(int) - Method in class java.math.BigInteger
Returns a BigInteger whose value is equivalent to this BigInteger with the designated bit flipped.
FlipBufferStrategy(int, BufferCapabilities) - Constructor for class java.awt.Component.FlipBufferStrategy
Creates a new flipping buffer strategy for this component.
flipEastAndWestAtEnds(int, Position.Bias) - Method in class javax.swing.text.BoxView
Determines in which direction the next view lays.
flipEastAndWestAtEnds(int, Position.Bias) - Method in class javax.swing.text.CompositeView
Determines in which direction the next view lays.
flipEastAndWestAtEnds(int, Position.Bias) - Method in class javax.swing.text.ParagraphView
Determines in which direction the next view lays.
Float() - Constructor for class java.awt.geom.Arc2D.Float
Constructs a new OPEN arc, initialized to location (0, 0), size (0, 0), angular extents (start = 0, extent = 0).
Float(int) - Constructor for class java.awt.geom.Arc2D.Float
Constructs a new arc, initialized to location (0, 0), size (0, 0), angular extents (start = 0, extent = 0), and the specified closure type.
Float(float, float, float, float, float, float, int) - Constructor for class java.awt.geom.Arc2D.Float
Constructs a new arc, initialized to the specified location, size, angular extents, and closure type.
Float(Rectangle2D, float, float, int) - Constructor for class java.awt.geom.Arc2D.Float
Constructs a new arc, initialized to the specified location, size, angular extents, and closure type.
Float() - Constructor for class java.awt.geom.CubicCurve2D.Float
Constructs and initializes a CubicCurve with coordinates (0, 0, 0, 0, 0, 0, 0, 0).
Float(float, float, float, float, float, float, float, float) - Constructor for class java.awt.geom.CubicCurve2D.Float
Constructs and initializes a CubicCurve2D from the specified float coordinates.
Float() - Constructor for class java.awt.geom.Ellipse2D.Float
Constructs a new Ellipse2D, initialized to location (0, 0) and size (0, 0).
Float(float, float, float, float) - Constructor for class java.awt.geom.Ellipse2D.Float
Constructs and initializes an Ellipse2D from the specified coordinates.
Float() - Constructor for class java.awt.geom.Line2D.Float
Constructs and initializes a Line with coordinates (0, 0) → (0, 0).
Float(float, float, float, float) - Constructor for class java.awt.geom.Line2D.Float
Constructs and initializes a Line from the specified coordinates.
Float(Point2D, Point2D) - Constructor for class java.awt.geom.Line2D.Float
Constructs and initializes a Line2D from the specified Point2D objects.
Float() - Constructor for class java.awt.geom.Path2D.Float
Constructs a new empty single precision Path2D object with a default winding rule of Path2D.WIND_NON_ZERO.
Float(int) - Constructor for class java.awt.geom.Path2D.Float
Constructs a new empty single precision Path2D object with the specified winding rule to control operations that require the interior of the path to be defined.
Float(int, int) - Constructor for class java.awt.geom.Path2D.Float
Constructs a new empty single precision Path2D object with the specified winding rule and the specified initial capacity to store path segments.
Float(Shape) - Constructor for class java.awt.geom.Path2D.Float
Constructs a new single precision Path2D object from an arbitrary Shape object.
Float(Shape, AffineTransform) - Constructor for class java.awt.geom.Path2D.Float
Constructs a new single precision Path2D object from an arbitrary Shape object, transformed by an AffineTransform object.
Float() - Constructor for class java.awt.geom.Point2D.Float
Constructs and initializes a Point2D with coordinates (0, 0).
Float(float, float) - Constructor for class java.awt.geom.Point2D.Float
Constructs and initializes a Point2D with the specified coordinates.
Float() - Constructor for class java.awt.geom.QuadCurve2D.Float
Constructs and initializes a QuadCurve2D with coordinates (0, 0, 0, 0, 0, 0).
Float(float, float, float, float, float, float) - Constructor for class java.awt.geom.QuadCurve2D.Float
Constructs and initializes a QuadCurve2D from the specified float coordinates.
Float() - Constructor for class java.awt.geom.Rectangle2D.Float
Constructs a new Rectangle2D, initialized to location (0.0, 0.0) and size (0.0, 0.0).
Float(float, float, float, float) - Constructor for class java.awt.geom.Rectangle2D.Float
Constructs and initializes a Rectangle2D from the specified float coordinates.
Float() - Constructor for class java.awt.geom.RoundRectangle2D.Float
Constructs a new RoundRectangle2D, initialized to location (0.0, 0.0), size (0.0, 0.0), and corner arcs of radius 0.0.
Float(float, float, float, float, float, float) - Constructor for class java.awt.geom.RoundRectangle2D.Float
Constructs and initializes a RoundRectangle2D from the specified float coordinates.
Float - Class in java.lang
The Float class wraps a value of primitive type float in an object.
Float(float) - Constructor for class java.lang.Float
Constructs a newly allocated Float object that represents the primitive float argument.
Float(double) - Constructor for class java.lang.Float
Constructs a newly allocated Float object that represents the argument converted to type float.
Float(String) - Constructor for class java.lang.Float
Constructs a newly allocated Float object that represents the floating-point value of type float represented by the string.
FLOAT - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type FLOAT.
FLOAT - Static variable in class javax.management.openmbean.SimpleType
The SimpleType instance describing values whose Java class name is java.lang.Float.
FLOAT - Static variable in class javax.swing.text.html.CSS.Attribute
floatAt(Point, Point) - Method in class javax.swing.plaf.basic.BasicToolBarUI
FloatBuffer - Class in java.nio
A float buffer.
FloatControl - Class in javax.sound.sampled
A FloatControl object provides control over a range of floating-point values.
FloatControl(FloatControl.Type, float, float, float, int, float, String, String, String, String) - Constructor for class javax.sound.sampled.FloatControl
Constructs a new float control object with the given parameters
FloatControl(FloatControl.Type, float, float, float, int, float, String) - Constructor for class javax.sound.sampled.FloatControl
Constructs a new float control object with the given parameters.
FloatControl.Type - Class in javax.sound.sampled
An instance of the FloatControl.Type inner class identifies one kind of float control.
FloatHolder - Class in org.omg.CORBA
The Holder for Float.
FloatHolder() - Constructor for class org.omg.CORBA.FloatHolder
Constructs a new FloatHolder object with its value field initialized to 0.0.
FloatHolder(float) - Constructor for class org.omg.CORBA.FloatHolder
Constructs a new FloatHolder object for the given float.
floatingBorderColor - Variable in class javax.swing.plaf.basic.BasicToolBarUI
floatingColor - Variable in class javax.swing.plaf.basic.BasicToolBarUI
FloatSeqHelper - Class in org.omg.CORBA
The Helper for FloatSeq.
FloatSeqHelper() - Constructor for class org.omg.CORBA.FloatSeqHelper
FloatSeqHolder - Class in org.omg.CORBA
The Holder for FloatSeq.
FloatSeqHolder() - Constructor for class org.omg.CORBA.FloatSeqHolder
FloatSeqHolder(float[]) - Constructor for class org.omg.CORBA.FloatSeqHolder
floatToIntBits(float) - Static method in class java.lang.Float
Returns a representation of the specified floating-point value according to the IEEE 754 floating-point "single format" bit layout.
floatToRawIntBits(float) - Static method in class java.lang.Float
Returns a representation of the specified floating-point value according to the IEEE 754 floating-point "single format" bit layout, preserving Not-a-Number (NaN) values.
floatValue() - Method in class java.lang.Byte
Returns the value of this Byte as a float after a widening primitive conversion.
floatValue() - Method in class java.lang.Double
Returns the value of this Double as a float after a narrowing primitive conversion.
floatValue() - Method in class java.lang.Float
Returns the float value of this Float object.
floatValue() - Method in class java.lang.Integer
Returns the value of this Integer as a float after a widening primitive conversion.
floatValue() - Method in class java.lang.Long
Returns the value of this Long as a float after a widening primitive conversion.
floatValue() - Method in class java.lang.Number
Returns the value of the specified number as a float, which may involve rounding.
floatValue() - Method in class java.lang.Short
Returns the value of this Short as a float after a widening primitive conversion.
floatValue() - Method in class java.math.BigDecimal
Converts this BigDecimal to a float.
floatValue() - Method in class java.math.BigInteger
Converts this BigInteger to a float.
floatValue() - Method in class java.util.concurrent.atomic.AtomicInteger
Returns the value of this AtomicInteger as a float after a widening primitive conversion.
floatValue() - Method in class java.util.concurrent.atomic.AtomicLong
Returns the value of this AtomicLong as a float after a widening primitive conversion.
floatValue() - Method in class java.util.concurrent.atomic.DoubleAccumulator
Returns the current value as a float after a narrowing primitive conversion.
floatValue() - Method in class java.util.concurrent.atomic.DoubleAdder
Returns the DoubleAdder.sum() as a float after a narrowing primitive conversion.
floatValue() - Method in class java.util.concurrent.atomic.LongAccumulator
Returns the current value as a float after a widening primitive conversion.
floatValue() - Method in class java.util.concurrent.atomic.LongAdder
Returns the LongAdder.sum() as a float after a widening primitive conversion.
floor(double) - Static method in class java.lang.Math
Returns the largest (closest to positive infinity) double value that is less than or equal to the argument and is equal to a mathematical integer.
floor(double) - Static method in class java.lang.StrictMath
Returns the largest (closest to positive infinity) double value that is less than or equal to the argument and is equal to a mathematical integer.
floor(E) - Method in class java.util.concurrent.ConcurrentSkipListSet
floor(E) - Method in interface java.util.NavigableSet
Returns the greatest element in this set less than or equal to the given element, or null if there is no such element.
floor(E) - Method in class java.util.TreeSet
floorDiv(int, int) - Static method in class java.lang.Math
Returns the largest (closest to positive infinity) int value that is less than or equal to the algebraic quotient.
floorDiv(long, long) - Static method in class java.lang.Math
Returns the largest (closest to positive infinity) long value that is less than or equal to the algebraic quotient.
floorDiv(int, int) - Static method in class java.lang.StrictMath
Returns the largest (closest to positive infinity) int value that is less than or equal to the algebraic quotient.
floorDiv(long, long) - Static method in class java.lang.StrictMath
Returns the largest (closest to positive infinity) long value that is less than or equal to the algebraic quotient.
floorEntry(K) - Method in class java.util.concurrent.ConcurrentSkipListMap
Returns a key-value mapping associated with the greatest key less than or equal to the given key, or null if there is no such key.
floorEntry(K) - Method in interface java.util.NavigableMap
Returns a key-value mapping associated with the greatest key less than or equal to the given key, or null if there is no such key.
floorEntry(K) - Method in class java.util.TreeMap
floorKey(K) - Method in class java.util.concurrent.ConcurrentSkipListMap
floorKey(K) - Method in interface java.util.NavigableMap
Returns the greatest key less than or equal to the given key, or null if there is no such key.
floorKey(K) - Method in class java.util.TreeMap
floorMod(int, int) - Static method in class java.lang.Math
Returns the floor modulus of the int arguments.
floorMod(long, long) - Static method in class java.lang.Math
Returns the floor modulus of the long arguments.
floorMod(int, int) - Static method in class java.lang.StrictMath
Returns the floor modulus of the int arguments.
floorMod(long, long) - Static method in class java.lang.StrictMath
Returns the floor modulus of the long arguments.
floppyDriveIcon - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
FlowLayout - Class in java.awt
A flow layout arranges components in a directional flow, much like lines of text in a paragraph.
FlowLayout() - Constructor for class java.awt.FlowLayout
Constructs a new FlowLayout with a centered alignment and a default 5-unit horizontal and vertical gap.
FlowLayout(int) - Constructor for class java.awt.FlowLayout
Constructs a new FlowLayout with the specified alignment and a default 5-unit horizontal and vertical gap.
FlowLayout(int, int, int) - Constructor for class java.awt.FlowLayout
Creates a new flow layout manager with the indicated alignment and the indicated horizontal and vertical gaps.
FLOWS_FROM - Static variable in class javax.accessibility.AccessibleRelation
Indicates an object is logically contiguous with a second object where the second object occurs before the object.
FLOWS_FROM_PROPERTY - Static variable in class javax.accessibility.AccessibleRelation
Indicates the FLOWS_FROM relation between two objects has changed.
FLOWS_TO - Static variable in class javax.accessibility.AccessibleRelation
Indicates an object is logically contiguous with a second object where the second object occurs after the object.
FLOWS_TO_PROPERTY - Static variable in class javax.accessibility.AccessibleRelation
Indicates the FLOWS_TO relation between two objects has changed.
FlowStrategy() - Constructor for class javax.swing.text.FlowView.FlowStrategy
FlowView - Class in javax.swing.text
A View that tries to flow it's children into some partially constrained space.
FlowView(Element, int) - Constructor for class javax.swing.text.FlowView
Constructs a FlowView for the given element.
FlowView.FlowStrategy - Class in javax.swing.text
Strategy for maintaining the physical form of the flow.
flush() - Method in class java.awt.Image
Flushes all reconstructable resources being used by this Image object.
flush() - Method in class java.beans.XMLEncoder
This method writes out the preamble associated with the XML encoding if it has not been written already and then writes out all of the values that been written to the stream since the last time flush was called.
flush() - Method in class java.io.BufferedOutputStream
Flushes this buffered output stream.
flush() - Method in class java.io.BufferedWriter
Flushes the stream.
flush() - Method in class java.io.CharArrayWriter
Flush the stream.
flush() - Method in class java.io.Console
Flushes the console and forces any buffered output to be written immediately .
flush() - Method in class java.io.DataOutputStream
Flushes this data output stream.
flush() - Method in class java.io.FilterOutputStream
Flushes this output stream and forces any buffered output bytes to be written out to the stream.
flush() - Method in class java.io.FilterWriter
Flushes the stream.
flush() - Method in interface java.io.Flushable
Flushes this stream by writing any buffered output to the underlying stream.
flush() - Method in interface java.io.ObjectOutput
Flushes the stream.
flush() - Method in class java.io.ObjectOutputStream
Flushes the stream.
flush() - Method in class java.io.OutputStream
Flushes this output stream and forces any buffered output bytes to be written out.
flush() - Method in class java.io.OutputStreamWriter
Flushes the stream.
flush() - Method in class java.io.PipedOutputStream
Flushes this output stream and forces any buffered output bytes to be written out.
flush() - Method in class java.io.PipedWriter
Flushes this output stream and forces any buffered output characters to be written out.
flush() - Method in class java.io.PrintStream
Flushes the stream.
flush() - Method in class java.io.PrintWriter
Flushes the stream.
flush() - Method in class java.io.StringWriter
Flush the stream.
flush() - Method in class java.io.Writer
Flushes the stream.
flush(CharBuffer) - Method in class java.nio.charset.CharsetDecoder
Flushes this decoder.
flush(ByteBuffer) - Method in class java.nio.charset.CharsetEncoder
Flushes this encoder.
flush() - Method in class java.util.Formatter
Flushes this formatter.
flush() - Method in class java.util.logging.Handler
Flush any buffered output.
flush() - Method in class java.util.logging.MemoryHandler
Causes a flush on the target Handler.
flush() - Method in class java.util.logging.StreamHandler
Flush any buffered messages.
flush() - Method in class java.util.prefs.AbstractPreferences
Implements the flush method as per the specification in Preferences.flush().
flush() - Method in class java.util.prefs.Preferences
Forces any changes in the contents of this preference node and its descendants to the persistent store.
flush() - Method in class java.util.zip.DeflaterOutputStream
Flushes the compressed output stream.
flush() - Method in class java.util.zip.InflaterOutputStream
Flushes this output stream, forcing any pending buffered output bytes to be written.
flush() - Method in class javax.crypto.CipherOutputStream
Flushes this output stream by forcing any buffered output bytes that have already been processed by the encapsulated cipher object to be written out.
flush() - Method in interface javax.imageio.stream.ImageInputStream
Discards the initial position of the stream prior to the current stream position.
flush() - Method in class javax.imageio.stream.ImageInputStreamImpl
flush() - Method in interface javax.sound.sampled.DataLine
Flushes queued data from the line.
flush() - Method in class javax.swing.text.html.HTMLDocument.HTMLReader
The last method called on the reader.
flush() - Method in class javax.swing.text.html.HTMLEditorKit.ParserCallback
flush() - Method in class javax.tools.ForwardingJavaFileManager
flush() - Method in interface javax.tools.JavaFileManager
Flushes any resources opened for output by this file manager directly or indirectly.
flush() - Method in interface javax.xml.stream.XMLEventWriter
Writes any cached events to the underlying output mechanism
flush() - Method in interface javax.xml.stream.XMLStreamWriter
Write any cached data to the underlying output mechanism.
Flush3DBorder() - Constructor for class javax.swing.plaf.metal.MetalBorders.Flush3DBorder
FLUSH_FAILURE - Static variable in class java.util.logging.ErrorManager
FLUSH_FAILURE is used when a flush to an output stream fails.
Flushable - Interface in java.io
A Flushable is a destination of data that can be flushed.
flushAttributes() - Method in class javax.swing.text.html.parser.Parser
flushBefore(long) - Method in class javax.imageio.stream.FileCacheImageOutputStream
flushBefore(long) - Method in interface javax.imageio.stream.ImageInputStream
Discards the initial portion of the stream prior to the indicated position.
flushBefore(long) - Method in class javax.imageio.stream.ImageInputStreamImpl
flushBefore(long) - Method in interface javax.imageio.stream.ImageOutputStream
Flushes all data prior to the given position to the underlying destination, such as an OutputStream or File.
flushBefore(long) - Method in class javax.imageio.stream.MemoryCacheImageInputStream
flushBefore(long) - Method in class javax.imageio.stream.MemoryCacheImageOutputStream
flushBits() - Method in class javax.imageio.stream.ImageOutputStreamImpl
If the bit offset is non-zero, forces the remaining bits in the current byte to 0 and advances the stream position by one.
flushCaches() - Static method in class java.beans.Introspector
Flush all of the Introspector's internal caches.
flushedPos - Variable in class javax.imageio.stream.ImageInputStreamImpl
The position prior to which data may be discarded.
flushFromCaches(Class<?>) - Static method in class java.beans.Introspector
Flush the Introspector's internal cached information for a given class.
flushRequirementChanges() - Method in class javax.swing.text.AsyncBoxView
Publish the changes in preferences upward to the parent view.
flushSpi() - Method in class java.util.prefs.AbstractPreferences
This method is invoked with this node locked.
focus - Variable in class javax.swing.plaf.basic.BasicTabbedPaneUI
FOCUS - Static variable in class javax.swing.plaf.synth.ColorType
ColorType for the focus.
FOCUS_ACCELERATOR_KEY - Static variable in class javax.swing.text.JTextComponent
The bound property name for the focus accelerator.
FOCUS_EVENT_MASK - Static variable in class java.awt.AWTEvent
The event mask for selecting focus events.
FOCUS_FIRST - Static variable in class java.awt.event.FocusEvent
The first number in the range of ids used for focus events.
FOCUS_GAINED - Static variable in class java.awt.event.FocusEvent
This event indicates that the Component is now the focus owner.
FOCUS_LAST - Static variable in class java.awt.event.FocusEvent
The last number in the range of ids used for focus events.
FOCUS_LOST - Static variable in class java.awt.event.FocusEvent
This event indicates that the Component is no longer the focus owner.
FOCUS_MANAGER_CLASS_PROPERTY - Static variable in class javax.swing.FocusManager
This field is obsolete, and its use is discouraged since its specification is incompatible with the 1.4 focus APIs.
FOCUS_PAINTED_CHANGED_PROPERTY - Static variable in class javax.swing.AbstractButton
Identifies a change to having the border highlighted when focused, or not.
FOCUSABLE - Static variable in class javax.accessibility.AccessibleState
Indicates this object can accept keyboard focus, which means all events resulting from typing on the keyboard will normally be passed to it when it has focus.
FocusAdapter - Class in java.awt.event
An abstract adapter class for receiving keyboard focus events.
FocusAdapter() - Constructor for class java.awt.event.FocusAdapter
focusColor - Variable in class javax.swing.plaf.metal.MetalButtonUI
focusColor - Variable in class javax.swing.plaf.metal.MetalRadioButtonUI
focusColor - Variable in class javax.swing.plaf.metal.MetalToggleButtonUI
FOCUSED - Static variable in class javax.accessibility.AccessibleState
Indicates this object currently has the keyboard focus.
FOCUSED - Static variable in interface javax.swing.plaf.synth.SynthConstants
Indicates the region has focus.
focusedCompIndex - Variable in class javax.swing.plaf.basic.BasicToolBarUI
FocusEvent - Class in java.awt.event
A low-level event which indicates that a Component has gained or lost the input focus.
FocusEvent(Component, int, boolean, Component) - Constructor for class java.awt.event.FocusEvent
Constructs a FocusEvent object with the specified temporary state and opposite Component.
FocusEvent(Component, int, boolean) - Constructor for class java.awt.event.FocusEvent
Constructs a FocusEvent object and identifies whether or not the change is temporary.
FocusEvent(Component, int) - Constructor for class java.awt.event.FocusEvent
Constructs a FocusEvent object and identifies it as a permanent change in focus.
focusGained(FocusEvent) - Method in class java.awt.AWTEventMulticaster
Handles the focusGained event by invoking the focusGained methods on listener-a and listener-b.
focusGained(FocusEvent) - Method in class java.awt.Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
focusGained(FocusEvent) - Method in class java.awt.event.FocusAdapter
Invoked when a component gains the keyboard focus.
focusGained(FocusEvent) - Method in interface java.awt.event.FocusListener
Invoked when a component gains the keyboard focus.
focusGained(FocusEvent) - Method in class javax.swing.JComponent.AccessibleJComponent.AccessibleFocusHandler
focusGained(FocusEvent) - Method in class javax.swing.plaf.basic.BasicButtonListener
focusGained(FocusEvent) - Method in class javax.swing.plaf.basic.BasicComboBoxEditor
focusGained(FocusEvent) - Method in class javax.swing.plaf.basic.BasicComboBoxUI.FocusHandler
focusGained(FocusEvent) - Method in class javax.swing.plaf.basic.BasicListUI.FocusHandler
focusGained(FocusEvent) - Method in class javax.swing.plaf.basic.BasicSliderUI.FocusHandler
focusGained(FocusEvent) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.FocusHandler
focusGained(FocusEvent) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI.FocusHandler
focusGained(FocusEvent) - Method in class javax.swing.plaf.basic.BasicTableUI.FocusHandler
focusGained(FocusEvent) - Method in class javax.swing.plaf.basic.BasicToolBarUI.ToolBarFocusListener
focusGained(FocusEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.FocusHandler
Invoked when focus is activated on the tree we're in, redraws the lead row.
focusGained(FocusEvent) - Method in class javax.swing.text.DefaultCaret
Called when the component containing the caret gains focus.
FocusHandler() - Constructor for class javax.swing.plaf.basic.BasicComboBoxUI.FocusHandler
FocusHandler() - Constructor for class javax.swing.plaf.basic.BasicListUI.FocusHandler
FocusHandler() - Constructor for class javax.swing.plaf.basic.BasicSliderUI.FocusHandler
FocusHandler() - Constructor for class javax.swing.plaf.basic.BasicSplitPaneUI.FocusHandler
FocusHandler() - Constructor for class javax.swing.plaf.basic.BasicTabbedPaneUI.FocusHandler
FocusHandler() - Constructor for class javax.swing.plaf.basic.BasicTableUI.FocusHandler
FocusHandler() - Constructor for class javax.swing.plaf.basic.BasicTreeUI.FocusHandler
focusInsets - Variable in class javax.swing.plaf.basic.BasicSliderUI
FocusListener - Interface in java.awt.event
The listener interface for receiving keyboard focus events on a component.
focusListener - Variable in class javax.swing.plaf.basic.BasicComboBoxUI
This protected field is implementation specific.
focusListener - Variable in class javax.swing.plaf.basic.BasicListUI
focusListener - Variable in class javax.swing.plaf.basic.BasicSliderUI
focusListener - Variable in class javax.swing.plaf.basic.BasicSplitPaneUI
Instance of the FocusListener for this JSplitPane.
focusListener - Variable in class javax.swing.plaf.basic.BasicTabbedPaneUI
focusListener - Variable in class javax.swing.plaf.basic.BasicTableUI
focusLost(FocusEvent) - Method in class java.awt.AWTEventMulticaster
Handles the focusLost event by invoking the focusLost methods on listener-a and listener-b.
focusLost(FocusEvent) - Method in class java.awt.Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
focusLost(FocusEvent) - Method in class java.awt.event.FocusAdapter
Invoked when a component loses the keyboard focus.
focusLost(FocusEvent) - Method in interface java.awt.event.FocusListener
Invoked when a component loses the keyboard focus.
focusLost(FocusEvent) - Method in class javax.swing.JComponent.AccessibleJComponent.AccessibleFocusHandler
focusLost(FocusEvent) - Method in class javax.swing.plaf.basic.BasicButtonListener
focusLost(FocusEvent) - Method in class javax.swing.plaf.basic.BasicComboBoxEditor
focusLost(FocusEvent) - Method in class javax.swing.plaf.basic.BasicComboBoxUI.FocusHandler
focusLost(FocusEvent) - Method in class javax.swing.plaf.basic.BasicListUI.FocusHandler
focusLost(FocusEvent) - Method in class javax.swing.plaf.basic.BasicSliderUI.FocusHandler
focusLost(FocusEvent) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.FocusHandler
focusLost(FocusEvent) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI.FocusHandler
focusLost(FocusEvent) - Method in class javax.swing.plaf.basic.BasicTableUI.FocusHandler
focusLost(FocusEvent) - Method in class javax.swing.plaf.basic.BasicToolBarUI.ToolBarFocusListener
focusLost(FocusEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.FocusHandler
Invoked when focus is activated on the tree we're in, redraws the lead row.
focusLost(FocusEvent) - Method in class javax.swing.text.DefaultCaret
Called when the component containing the caret loses focus.
FocusManager - Class in javax.swing
This class has been obsoleted by the 1.4 focus APIs.
FocusManager() - Constructor for class javax.swing.FocusManager
focusNextComponent(Component) - Method in class java.awt.DefaultKeyboardFocusManager
Focuses the Component after aComponent, typically based on a FocusTraversalPolicy.
focusNextComponent(Component) - Method in class java.awt.KeyboardFocusManager
Focuses the Component after aComponent, typically based on a FocusTraversalPolicy.
focusNextComponent() - Method in class java.awt.KeyboardFocusManager
Focuses the Component after the current focus owner.
focusPreviousComponent(Component) - Method in class java.awt.DefaultKeyboardFocusManager
Focuses the Component before aComponent, typically based on a FocusTraversalPolicy.
focusPreviousComponent(Component) - Method in class java.awt.KeyboardFocusManager
Focuses the Component before aComponent, typically based on a FocusTraversalPolicy.
focusPreviousComponent() - Method in class java.awt.KeyboardFocusManager
Focuses the Component before the current focus owner.
focusRect - Variable in class javax.swing.plaf.basic.BasicSliderUI
FocusTraversalPolicy - Class in java.awt
A FocusTraversalPolicy defines the order in which Components with a particular focus cycle root are traversed.
FocusTraversalPolicy() - Constructor for class java.awt.FocusTraversalPolicy
foldArguments(MethodHandle, MethodHandle) - Static method in class java.lang.invoke.MethodHandles
Adapts a target method handle by pre-processing some of its arguments, and then calling the target with the result of the pre-processing, inserted into the original sequence of arguments.
FolderIcon16() - Constructor for class javax.swing.plaf.metal.MetalIconFactory.FolderIcon16
FOLIO - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for Folio, 8 1/2 x 13 in.
FOLIO - Static variable in class javax.print.attribute.standard.MediaSize.Other
Specifies the folio size, 8.5 inches by 13 inches.
FOLIO - Static variable in class javax.print.attribute.standard.MediaSizeName
folio size .
following(int) - Method in class java.text.BreakIterator
Returns the first boundary following the specified character offset.
Font - Class in java.awt
The Font class represents fonts, which are used to render text in a visible way.
Font(String, int, int) - Constructor for class java.awt.Font
Creates a new Font from the specified name, style and point size.
Font(Map<? extends AttributedCharacterIterator.Attribute, ?>) - Constructor for class java.awt.Font
Creates a new Font with the specified attributes.
Font(Font) - Constructor for class java.awt.Font
Creates a new Font from the specified font.
FONT - Static variable in class java.awt.font.TextAttribute
Attribute key used to provide the font to use to render text.
font - Variable in class java.awt.FontMetrics
The actual Font from which the font metrics are created.
FONT - Static variable in class javax.swing.text.html.CSS.Attribute
FONT - Static variable in class javax.swing.text.html.HTML.Tag
font - Variable in class javax.swing.tree.DefaultTreeCellEditor
Font to paint with, null indicates font of renderer is to be used.
FONT_CHANGE_BIGGER - Static variable in class javax.swing.text.html.HTMLEditorKit
The font size increase to next value action identifier
FONT_CHANGE_SMALLER - Static variable in class javax.swing.text.html.HTMLEditorKit
The font size decrease to next value action identifier
FONT_CHOOSER - Static variable in class javax.accessibility.AccessibleRole
A FONT_CHOOSER is a component that lets the user pick various attributes for fonts.
FONT_FAMILY - Static variable in class javax.swing.text.html.CSS.Attribute
FONT_SIZE - Static variable in class javax.swing.text.html.CSS.Attribute
FONT_STYLE - Static variable in class javax.swing.text.html.CSS.Attribute
FONT_VARIANT - Static variable in class javax.swing.text.html.CSS.Attribute
FONT_WEIGHT - Static variable in class javax.swing.text.html.CSS.Attribute
fontChanged - Static variable in class javax.swing.plaf.basic.BasicListUI
FontFamily - Static variable in class javax.swing.text.StyleConstants
Name of the font family.
FontFamilyAction(String, String) - Constructor for class javax.swing.text.StyledEditorKit.FontFamilyAction
Creates a new FontFamilyAction.
FontFormatException - Exception in java.awt
Thrown by method createFont in the Font class to indicate that the specified font is bad.
FontFormatException(String) - Constructor for exception java.awt.FontFormatException
Report a FontFormatException for the reason specified.
FontMetrics - Class in java.awt
The FontMetrics class defines a font metrics object, which encapsulates information about the rendering of a particular font on a particular screen.
FontMetrics(Font) - Constructor for class java.awt.FontMetrics
Creates a new FontMetrics object for finding out height and width information about the specified Font and specific character glyphs in that Font.
FontRenderContext - Class in java.awt.font
The FontRenderContext class is a container for the information needed to correctly measure text.
FontRenderContext() - Constructor for class java.awt.font.FontRenderContext
Constructs a new FontRenderContext object.
FontRenderContext(AffineTransform, boolean, boolean) - Constructor for class java.awt.font.FontRenderContext
Constructs a FontRenderContext object from an optional AffineTransform and two boolean values that determine if the newly constructed object has anti-aliasing or fractional metrics.
FontRenderContext(AffineTransform, Object, Object) - Constructor for class java.awt.font.FontRenderContext
Constructs a FontRenderContext object from an optional AffineTransform and two Object values that determine if the newly constructed object has anti-aliasing or fractional metrics.
FontSize - Static variable in class javax.swing.text.StyleConstants
Name of the font size.
FontSizeAction(String, int) - Constructor for class javax.swing.text.StyledEditorKit.FontSizeAction
Creates a new FontSizeAction.
FontUIResource - Class in javax.swing.plaf
A subclass of java.awt.Font that implements UIResource.
FontUIResource(String, int, int) - Constructor for class javax.swing.plaf.FontUIResource
FontUIResource(Font) - Constructor for class javax.swing.plaf.FontUIResource
FOOTER - Static variable in class javax.accessibility.AccessibleRole
A text footer
force(boolean) - Method in class java.nio.channels.AsynchronousFileChannel
Forces any updates to this channel's file to be written to the storage device that contains it.
force(boolean) - Method in class java.nio.channels.FileChannel
Forces any updates to this channel's file to be written to the storage device that contains it.
force() - Method in class java.nio.MappedByteBuffer
Forces any changes made to this buffer's content to be written to the storage device containing the mapped file.
ForcedBreakWeight - Static variable in class javax.swing.text.View
The weight to indicate a view supports breaking, and must be broken to be represented properly when placed in a view that formats its children by breaking them.
forceTermination() - Method in class java.util.concurrent.Phaser
Forces this phaser to enter termination state.
forClass() - Method in class java.io.ObjectStreamClass
Return the class in the local VM that this version is mapped to.
forDigit(int, int) - Static method in class java.lang.Character
Determines the character representation for a specific digit in the specified radix.
forEach(Consumer<? super T>) - Method in interface java.lang.Iterable
Performs the given action for each element of the Iterable until all elements have been processed or the action throws an exception.
forEach(BiConsumer<? super Object, ? super Object>) - Method in class java.security.Provider
forEach(Consumer<? super E>) - Method in class java.util.ArrayList
forEach(BiConsumer<? super K, ? super V>) - Method in class java.util.concurrent.ConcurrentHashMap
forEach(long, BiConsumer<? super K, ? super V>) - Method in class java.util.concurrent.ConcurrentHashMap
Performs the given action for each (key, value).
forEach(long, BiFunction<? super K, ? super V, ? extends U>, Consumer<? super U>) - Method in class java.util.concurrent.ConcurrentHashMap
Performs the given action for each non-null transformation of each (key, value).
forEach(Consumer<? super K>) - Method in class java.util.concurrent.ConcurrentHashMap.KeySetView
forEach(BiConsumer<? super K, ? super V>) - Method in interface java.util.concurrent.ConcurrentMap
Performs the given action for each entry in this map until all entries have been processed or the action throws an exception.
forEach(BiConsumer<? super K, ? super V>) - Method in class java.util.concurrent.ConcurrentSkipListMap
forEach(Consumer<? super E>) - Method in class java.util.concurrent.CopyOnWriteArrayList
forEach(Consumer<? super E>) - Method in class java.util.concurrent.CopyOnWriteArraySet
forEach(BiConsumer<? super K, ? super V>) - Method in class java.util.HashMap
forEach(BiConsumer<? super K, ? super V>) - Method in class java.util.Hashtable
forEach(BiConsumer<? super K, ? super V>) - Method in class java.util.IdentityHashMap
forEach(BiConsumer<? super K, ? super V>) - Method in class java.util.LinkedHashMap
forEach(BiConsumer<? super K, ? super V>) - Method in interface java.util.Map
Performs the given action for each entry in this map until all entries have been processed or the action throws an exception.
forEach(DoubleConsumer) - Method in interface java.util.stream.DoubleStream
Performs an action for each element of this stream.
forEach(IntConsumer) - Method in interface java.util.stream.IntStream
Performs an action for each element of this stream.
forEach(LongConsumer) - Method in interface java.util.stream.LongStream
Performs an action for each element of this stream.
forEach(Consumer<? super T>) - Method in interface java.util.stream.Stream
Performs an action for each element of this stream.
forEach(BiConsumer<? super K, ? super V>) - Method in class java.util.TreeMap
forEach(Consumer<? super E>) - Method in class java.util.Vector
forEach(BiConsumer<? super K, ? super V>) - Method in class java.util.WeakHashMap
forEachEntry(long, Consumer<? super Map.Entry<K, V>>) - Method in class java.util.concurrent.ConcurrentHashMap
Performs the given action for each entry.
forEachEntry(long, Function<Map.Entry<K, V>, ? extends U>, Consumer<? super U>) - Method in class java.util.concurrent.ConcurrentHashMap
Performs the given action for each non-null transformation of each entry.
forEachKey(long, Consumer<? super K>) - Method in class java.util.concurrent.ConcurrentHashMap
Performs the given action for each key.
forEachKey(long, Function<? super K, ? extends U>, Consumer<? super U>) - Method in class java.util.concurrent.ConcurrentHashMap
Performs the given action for each non-null transformation of each key.
forEachOrdered(DoubleConsumer) - Method in interface java.util.stream.DoubleStream
Performs an action for each element of this stream, guaranteeing that each element is processed in encounter order for streams that have a defined encounter order.
forEachOrdered(IntConsumer) - Method in interface java.util.stream.IntStream
Performs an action for each element of this stream, guaranteeing that each element is processed in encounter order for streams that have a defined encounter order.
forEachOrdered(LongConsumer) - Method in interface java.util.stream.LongStream
Performs an action for each element of this stream, guaranteeing that each element is processed in encounter order for streams that have a defined encounter order.
forEachOrdered(Consumer<? super T>) - Method in interface java.util.stream.Stream
Performs an action for each element of this stream, in the encounter order of the stream if the stream has a defined encounter order.
forEachRemaining(Consumer<? super E>) - Method in interface java.util.Iterator
Performs the given action for each remaining element until all elements have been processed or the action throws an exception.
forEachRemaining(T_CONS) - Method in interface java.util.PrimitiveIterator
Performs the given action for each remaining element, in the order elements occur when iterating, until all elements have been processed or the action throws an exception.
forEachRemaining(DoubleConsumer) - Method in interface java.util.PrimitiveIterator.OfDouble
Performs the given action for each remaining element until all elements have been processed or the action throws an exception.
forEachRemaining(Consumer<? super Double>) - Method in interface java.util.PrimitiveIterator.OfDouble
Performs the given action for each remaining element until all elements have been processed or the action throws an exception.
forEachRemaining(IntConsumer) - Method in interface java.util.PrimitiveIterator.OfInt
Performs the given action for each remaining element until all elements have been processed or the action throws an exception.
forEachRemaining(Consumer<? super Integer>) - Method in interface java.util.PrimitiveIterator.OfInt
Performs the given action for each remaining element until all elements have been processed or the action throws an exception.
forEachRemaining(LongConsumer) - Method in interface java.util.PrimitiveIterator.OfLong
Performs the given action for each remaining element until all elements have been processed or the action throws an exception.
forEachRemaining(Consumer<? super Long>) - Method in interface java.util.PrimitiveIterator.OfLong
Performs the given action for each remaining element until all elements have been processed or the action throws an exception.
forEachRemaining(Consumer<? super T>) - Method in interface java.util.Spliterator
Performs the given action for each remaining element, sequentially in the current thread, until all elements have been processed or the action throws an exception.
forEachRemaining(DoubleConsumer) - Method in interface java.util.Spliterator.OfDouble
forEachRemaining(Consumer<? super Double>) - Method in interface java.util.Spliterator.OfDouble
Performs the given action for each remaining element, sequentially in the current thread, until all elements have been processed or the action throws an exception.
forEachRemaining(IntConsumer) - Method in interface java.util.Spliterator.OfInt
forEachRemaining(Consumer<? super Integer>) - Method in interface java.util.Spliterator.OfInt
Performs the given action for each remaining element, sequentially in the current thread, until all elements have been processed or the action throws an exception.
forEachRemaining(LongConsumer) - Method in interface java.util.Spliterator.OfLong
forEachRemaining(Consumer<? super Long>) - Method in interface java.util.Spliterator.OfLong
Performs the given action for each remaining element, sequentially in the current thread, until all elements have been processed or the action throws an exception.
forEachRemaining(T_CONS) - Method in interface java.util.Spliterator.OfPrimitive
Performs the given action for each remaining element, sequentially in the current thread, until all elements have been processed or the action throws an exception.
forEachValue(long, Consumer<? super V>) - Method in class java.util.concurrent.ConcurrentHashMap
Performs the given action for each value.
forEachValue(long, Function<? super V, ? extends U>, Consumer<? super U>) - Method in class java.util.concurrent.ConcurrentHashMap
Performs the given action for each non-null transformation of each value.
FOREGROUND - Static variable in class java.awt.font.TextAttribute
Attribute key for the paint used to render the text.
FOREGROUND - Static variable in class javax.swing.plaf.synth.ColorType
ColorType for the foreground of a region.
Foreground - Static variable in class javax.swing.text.StyleConstants
Name of the foreground color attribute.
ForegroundAction(String, Color) - Constructor for class javax.swing.text.StyledEditorKit.ForegroundAction
Creates a new ForegroundAction.
forget(Xid) - Method in interface javax.transaction.xa.XAResource
Tells the resource manager to forget about a heuristically completed transaction branch.
fork() - Method in class java.util.concurrent.ForkJoinTask
Arranges to asynchronously execute this task in the pool the current task is running in, if applicable, or using the ForkJoinPool.commonPool() if not ForkJoinTask.inForkJoinPool().
ForkJoinPool - Class in java.util.concurrent
An ExecutorService for running ForkJoinTasks.
ForkJoinPool() - Constructor for class java.util.concurrent.ForkJoinPool
Creates a ForkJoinPool with parallelism equal to Runtime.availableProcessors(), using the default thread factory, no UncaughtExceptionHandler, and non-async LIFO processing mode.
ForkJoinPool(int) - Constructor for class java.util.concurrent.ForkJoinPool
Creates a ForkJoinPool with the indicated parallelism level, the default thread factory, no UncaughtExceptionHandler, and non-async LIFO processing mode.
ForkJoinPool(int, ForkJoinPool.ForkJoinWorkerThreadFactory, Thread.UncaughtExceptionHandler, boolean) - Constructor for class java.util.concurrent.ForkJoinPool
Creates a ForkJoinPool with the given parameters.
ForkJoinPool.ForkJoinWorkerThreadFactory - Interface in java.util.concurrent
Factory for creating new ForkJoinWorkerThreads.
ForkJoinPool.ManagedBlocker - Interface in java.util.concurrent
Interface for extending managed parallelism for tasks running in ForkJoinPools.
ForkJoinTask<V> - Class in java.util.concurrent
Abstract base class for tasks that run within a ForkJoinPool.
ForkJoinTask() - Constructor for class java.util.concurrent.ForkJoinTask
ForkJoinWorkerThread - Class in java.util.concurrent
A thread managed by a ForkJoinPool, which executes ForkJoinTasks.
ForkJoinWorkerThread(ForkJoinPool) - Constructor for class java.util.concurrent.ForkJoinWorkerThread
Creates a ForkJoinWorkerThread operating in the given pool.
forLanguageTag(String) - Static method in class java.util.Locale
Returns a locale for the specified IETF BCP 47 language tag string.
FORM - Static variable in class javax.swing.text.html.HTML.Tag
FormAction() - Constructor for class javax.swing.text.html.HTMLDocument.HTMLReader.FormAction
format(String, Object...) - Method in class java.io.Console
Writes a formatted string to this console's output stream using the specified format string and arguments.
format(String, Object...) - Method in class java.io.PrintStream
Writes a formatted string to this output stream using the specified format string and arguments.
format(Locale, String, Object...) - Method in class java.io.PrintStream
Writes a formatted string to this output stream using the specified format string and arguments.
format(String, Object...) - Method in class java.io.PrintWriter
Writes a formatted string to this writer using the specified format string and arguments.
format(Locale, String, Object...) - Method in class java.io.PrintWriter
Writes a formatted string to this writer using the specified format string and arguments.
FORMAT - Static variable in class java.lang.Character
General category "Cf" in the Unicode specification.
format(String, Object...) - Static method in class java.lang.String
Returns a formatted string using the specified format string and arguments.
format(Locale, String, Object...) - Static method in class java.lang.String
Returns a formatted string using the specified locale, format string, and arguments.
format(long, StringBuffer, FieldPosition) - Method in class java.text.ChoiceFormat
Specialization of format.
format(double, StringBuffer, FieldPosition) - Method in class java.text.ChoiceFormat
Returns pattern with formatted double.
format(Object, StringBuffer, FieldPosition) - Method in class java.text.DateFormat
Overrides Format.
format(Date, StringBuffer, FieldPosition) - Method in class java.text.DateFormat
Formats a Date into a date/time string.
format(Date) - Method in class java.text.DateFormat
Formats a Date into a date/time string.
format(Object, StringBuffer, FieldPosition) - Method in class java.text.DecimalFormat
Formats a number and appends the resulting text to the given string buffer.
format(double, StringBuffer, FieldPosition) - Method in class java.text.DecimalFormat
Formats a double to produce a string.
format(long, StringBuffer, FieldPosition) - Method in class java.text.DecimalFormat
Format a long to produce a string.
Format - Class in java.text
Format is an abstract base class for formatting locale-sensitive information such as dates, messages, and numbers.
Format() - Constructor for class java.text.Format
Sole constructor.
format(Object) - Method in class java.text.Format
Formats an object to produce a string.
format(Object, StringBuffer, FieldPosition) - Method in class java.text.Format
Formats an object and appends the resulting text to a given string buffer.
format(Object[], StringBuffer, FieldPosition) - Method in class java.text.MessageFormat
Formats an array of objects and appends the MessageFormat's pattern, with format elements replaced by the formatted objects, to the provided StringBuffer.
format(String, Object...) - Static method in class java.text.MessageFormat
Creates a MessageFormat with the given pattern and uses it to format the given arguments.
format(Object, StringBuffer, FieldPosition) - Method in class java.text.MessageFormat
Formats an array of objects and appends the MessageFormat's pattern, with format elements replaced by the formatted objects, to the provided StringBuffer.
format(Object, StringBuffer, FieldPosition) - Method in class java.text.NumberFormat
Formats a number and appends the resulting text to the given string buffer.
format(double) - Method in class java.text.NumberFormat
Specialization of format.
format(long) - Method in class java.text.NumberFormat
Specialization of format.
format(double, StringBuffer, FieldPosition) - Method in class java.text.NumberFormat
Specialization of format.
format(long, StringBuffer, FieldPosition) - Method in class java.text.NumberFormat
Specialization of format.
format(Date, StringBuffer, FieldPosition) - Method in class java.text.SimpleDateFormat
Formats the given Date into a date/time string and appends the result to the given StringBuffer.
format(DateTimeFormatter) - Method in interface java.time.chrono.ChronoLocalDate
Formats this date using the specified formatter.
format(DateTimeFormatter) - Method in interface java.time.chrono.ChronoLocalDateTime
Formats this date-time using the specified formatter.
format(DateTimeFormatter) - Method in interface java.time.chrono.ChronoZonedDateTime
Formats this date-time using the specified formatter.
format(TemporalAccessor) - Method in class java.time.format.DateTimeFormatter
Formats a date-time object using this formatter.
format(DateTimeFormatter) - Method in class java.time.LocalDate
Formats this date using the specified formatter.
format(DateTimeFormatter) - Method in class java.time.LocalDateTime
Formats this date-time using the specified formatter.
format(DateTimeFormatter) - Method in class java.time.LocalTime
Formats this time using the specified formatter.
format(DateTimeFormatter) - Method in class java.time.MonthDay
Formats this month-day using the specified formatter.
format(DateTimeFormatter) - Method in class java.time.OffsetDateTime
Formats this date-time using the specified formatter.
format(DateTimeFormatter) - Method in class java.time.OffsetTime
Formats this time using the specified formatter.
format(DateTimeFormatter) - Method in class java.time.Year
Formats this year using the specified formatter.
format(DateTimeFormatter) - Method in class java.time.YearMonth
Formats this year-month using the specified formatter.
format(DateTimeFormatter) - Method in class java.time.ZonedDateTime
Formats this date-time using the specified formatter.
format(String, Object...) - Method in class java.util.Formatter
Writes a formatted string to this object's destination using the specified format string and arguments.
format(Locale, String, Object...) - Method in class java.util.Formatter
Writes a formatted string to this object's destination using the specified locale, format string, and arguments.
format(LogRecord) - Method in class java.util.logging.Formatter
Format the given log record and return the formatted string.
format(LogRecord) - Method in class java.util.logging.SimpleFormatter
Format the given LogRecord.
format(LogRecord) - Method in class java.util.logging.XMLFormatter
Format the given message to XML.
format - Variable in class javax.sound.sampled.AudioInputStream
The format of the audio data contained in the stream.
format - Variable in class org.omg.IOP.Encoding
The encoding format.
Format.Field - Class in java.text
Defines constants that are used as attribute keys in the AttributedCharacterIterator returned from Format.formatToCharacterIterator and as field identifiers in FieldPosition.
FORMAT_CLASS - Static variable in class java.util.ResourceBundle.Control
The class-only format List containing "java.class".
FORMAT_DEFAULT - Static variable in class java.util.ResourceBundle.Control
The default format List, which contains the strings "java.class" and "java.properties", in this order.
FORMAT_FAILURE - Static variable in class java.util.logging.ErrorManager
FORMAT_FAILURE is used when formatting fails for any reason.
FORMAT_PROPERTIES - Static variable in class java.util.ResourceBundle.Control
The properties-only format List containing "java.properties".
FormatConversionProvider - Class in javax.sound.sampled.spi
A format conversion provider provides format conversion services from one or more input formats to one or more output formats.
FormatConversionProvider() - Constructor for class javax.sound.sampled.spi.FormatConversionProvider
FormatFlagsConversionMismatchException - Exception in java.util
Unchecked exception thrown when a conversion and flag are incompatible.
FormatFlagsConversionMismatchException(String, char) - Constructor for exception java.util.FormatFlagsConversionMismatchException
Constructs an instance of this class with the specified flag and conversion.
formatMessage(LogRecord) - Method in class java.util.logging.Formatter
Localize and format the message string from a log record.
FormatMismatch - Exception in org.omg.IOP.CodecPackage
org/omg/IOP/CodecPackage/FormatMismatch.java .
FormatMismatch() - Constructor for exception org.omg.IOP.CodecPackage.FormatMismatch
FormatMismatch(String) - Constructor for exception org.omg.IOP.CodecPackage.FormatMismatch
FormatMismatchHelper - Class in org.omg.IOP.CodecPackage
org/omg/IOP/CodecPackage/FormatMismatchHelper.java .
FormatMismatchHelper() - Constructor for class org.omg.IOP.CodecPackage.FormatMismatchHelper
FormatStyle - Enum in java.time.format
Enumeration of the style of a localized date, time or date-time formatter.
Formattable - Interface in java.util
The Formattable interface must be implemented by any class that needs to perform custom formatting using the 's' conversion specifier of Formatter.
FormattableFlags - Class in java.util
FomattableFlags are passed to the Formattable.formatTo() method and modify the output format for Formattables.
FORMATTED_TEXT_FIELD - Static variable in class javax.swing.plaf.synth.Region
FormattedTextField region.
Formatter - Class in java.util
An interpreter for printf-style format strings.
Formatter() - Constructor for class java.util.Formatter
Constructs a new formatter.
Formatter(Appendable) - Constructor for class java.util.Formatter
Constructs a new formatter with the specified destination.
Formatter(Locale) - Constructor for class java.util.Formatter
Constructs a new formatter with the specified locale.
Formatter(Appendable, Locale) - Constructor for class java.util.Formatter
Constructs a new formatter with the specified destination and locale.
Formatter(String) - Constructor for class java.util.Formatter
Constructs a new formatter with the specified file name.
Formatter(String, String) - Constructor for class java.util.Formatter
Constructs a new formatter with the specified file name and charset.
Formatter(String, String, Locale) - Constructor for class java.util.Formatter
Constructs a new formatter with the specified file name, charset, and locale.
Formatter(File) - Constructor for class java.util.Formatter
Constructs a new formatter with the specified file.
Formatter(File, String) - Constructor for class java.util.Formatter
Constructs a new formatter with the specified file and charset.
Formatter(File, String, Locale) - Constructor for class java.util.Formatter
Constructs a new formatter with the specified file, charset, and locale.
Formatter(PrintStream) - Constructor for class java.util.Formatter
Constructs a new formatter with the specified print stream.
Formatter(OutputStream) - Constructor for class java.util.Formatter
Constructs a new formatter with the specified output stream.
Formatter(OutputStream, String) - Constructor for class java.util.Formatter
Constructs a new formatter with the specified output stream and charset.
Formatter(OutputStream, String, Locale) - Constructor for class java.util.Formatter
Constructs a new formatter with the specified output stream, charset, and locale.
Formatter - Class in java.util.logging
A Formatter provides support for formatting LogRecords.
Formatter() - Constructor for class java.util.logging.Formatter
Construct a new formatter.
Formatter.BigDecimalLayoutForm - Enum in java.util
Enum for BigDecimal formatting.
FormatterClosedException - Exception in java.util
Unchecked exception thrown when the formatter has been closed.
FormatterClosedException() - Constructor for exception java.util.FormatterClosedException
Constructs an instance of this class.
formatTo(TemporalAccessor, Appendable) - Method in class java.time.format.DateTimeFormatter
Formats a date-time object to an Appendable using this formatter.
formatTo(Formatter, int, int, int) - Method in interface java.util.Formattable
Formats the object using the provided formatter.
formatToCharacterIterator(Object) - Method in class java.text.DecimalFormat
Formats an Object producing an AttributedCharacterIterator.
formatToCharacterIterator(Object) - Method in class java.text.Format
Formats an Object producing an AttributedCharacterIterator.
formatToCharacterIterator(Object) - Method in class java.text.MessageFormat
Formats an array of objects and inserts them into the MessageFormat's pattern, producing an AttributedCharacterIterator.
formatToCharacterIterator(Object) - Method in class java.text.SimpleDateFormat
Formats an Object producing an AttributedCharacterIterator.
FormSubmitEvent - Class in javax.swing.text.html
FormSubmitEvent is used to notify interested parties that a form was submitted.
FormSubmitEvent.MethodType - Enum in javax.swing.text.html
Represents an HTML form method type.
FormView - Class in javax.swing.text.html
Component decorator that implements the view interface for form elements, <input>, <textarea>, and <select>.
FormView(Element) - Constructor for class javax.swing.text.html.FormView
Creates a new FormView object.
FormView.MouseEventListener - Class in javax.swing.text.html
MouseEventListener class to handle form submissions when an input with type equal to image is clicked on.
forName(String) - Static method in class java.lang.Character.UnicodeBlock
Returns the UnicodeBlock with the given name.
forName(String) - Static method in enum java.lang.Character.UnicodeScript
Returns the UnicodeScript constant with the given Unicode script name or the script name alias.
forName(String) - Static method in class java.lang.Class
Returns the Class object associated with the class or interface with the given string name.
forName(String, boolean, ClassLoader) - Static method in class java.lang.Class
Returns the Class object associated with the class or interface with the given string name, using the given class loader.
forName(String) - Static method in class java.nio.charset.Charset
Returns a charset object for the named charset.
Forward - Static variable in class javax.swing.text.Position.Bias
Indicates to bias toward the next character in the model.
forward - Variable in exception org.omg.PortableInterceptor.ForwardRequest
The new object to forward the request to.
forward_reference() - Method in interface org.omg.PortableInterceptor.RequestInfoOperations
Contains the object to which the request will be forwarded, if the reply_status attribute is LOCATION_FORWARD.
forward_reference - Variable in exception org.omg.PortableServer.ForwardRequest
FORWARD_TRAVERSAL_KEYS - Static variable in class java.awt.KeyboardFocusManager
The identifier for the Forward focus traversal keys.
forwardAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the Action for moving the caret logically forward one position.
ForwardingFileObject<F extends FileObject> - Class in javax.tools
Forwards calls to a given file object.
ForwardingFileObject(F) - Constructor for class javax.tools.ForwardingFileObject
Creates a new instance of ForwardingFileObject.
ForwardingJavaFileManager<M extends JavaFileManager> - Class in javax.tools
Forwards calls to a given file manager.
ForwardingJavaFileManager(M) - Constructor for class javax.tools.ForwardingJavaFileManager
Creates a new instance of ForwardingJavaFileManager.
ForwardingJavaFileObject<F extends JavaFileObject> - Class in javax.tools
Forwards calls to a given file object.
ForwardingJavaFileObject(F) - Constructor for class javax.tools.ForwardingJavaFileObject
Creates a new instance of ForwardingJavaFileObject.
ForwardRequest - Exception in org.omg.PortableInterceptor
org/omg/PortableInterceptor/ForwardRequest.java .
ForwardRequest() - Constructor for exception org.omg.PortableInterceptor.ForwardRequest
ForwardRequest(Object) - Constructor for exception org.omg.PortableInterceptor.ForwardRequest
ForwardRequest(String, Object) - Constructor for exception org.omg.PortableInterceptor.ForwardRequest
ForwardRequest - Exception in org.omg.PortableServer
org/omg/PortableServer/ForwardRequest.java .
ForwardRequest() - Constructor for exception org.omg.PortableServer.ForwardRequest
ForwardRequest(Object) - Constructor for exception org.omg.PortableServer.ForwardRequest
ForwardRequest(String, Object) - Constructor for exception org.omg.PortableServer.ForwardRequest
ForwardRequestHelper - Class in org.omg.PortableInterceptor
org/omg/PortableInterceptor/ForwardRequestHelper.java .
ForwardRequestHelper() - Constructor for class org.omg.PortableInterceptor.ForwardRequestHelper
ForwardRequestHelper - Class in org.omg.PortableServer
org/omg/PortableServer/ForwardRequestHelper.java .
ForwardRequestHelper() - Constructor for class org.omg.PortableServer.ForwardRequestHelper
forwardUpdate(DocumentEvent.ElementChange, DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.BoxView
Forwards the given DocumentEvent to the child views that need to be notified of the change to the model.
forwardUpdate(DocumentEvent.ElementChange, DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.TableView
forwardUpdate(DocumentEvent.ElementChange, DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.View
Forwards the given DocumentEvent to the child views that need to be notified of the change to the model.
forwardUpdateToView(View, DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.View
Forwards the DocumentEvent to the give child view.
foundType() - Method in exception java.lang.annotation.AnnotationTypeMismatchException
Returns the type of data found in the incorrectly typed element.
FRACTION - Static variable in class java.text.NumberFormat.Field
Constant identifying the fraction field.
FRACTION_FIELD - Static variable in class java.text.NumberFormat
Field constant used to construct a FieldPosition object.
fragmentHtmlFlavor - Static variable in class java.awt.datatransfer.DataFlavor
Represents a piece of an HTML markup.
Frame - Class in java.awt
A Frame is a top-level window with a title and a border.
Frame() - Constructor for class java.awt.Frame
Constructs a new instance of Frame that is initially invisible.
Frame(GraphicsConfiguration) - Constructor for class java.awt.Frame
Constructs a new, initially invisible Frame with the specified GraphicsConfiguration.
Frame(String) - Constructor for class java.awt.Frame
Constructs a new, initially invisible Frame object with the specified title.
Frame(String, GraphicsConfiguration) - Constructor for class java.awt.Frame
Constructs a new, initially invisible Frame object with the specified title and a GraphicsConfiguration.
FRAME - Static variable in class javax.accessibility.AccessibleRole
A top level window with a title bar, border, menu bar, etc.
FRAME - Static variable in class javax.swing.JRootPane
Constant used for the windowDecorationStyle property.
frame - Variable in class javax.swing.plaf.basic.BasicDesktopIconUI
frame - Variable in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
frame - Variable in class javax.swing.plaf.basic.BasicInternalFrameUI
FRAME - Static variable in class javax.swing.text.html.HTML.Tag
Frame.AccessibleAWTFrame - Class in java.awt
This class implements accessibility support for the Frame class.
FRAME_CONTENT_LAYER - Static variable in class javax.swing.JLayeredPane
Convenience object defining the Frame Content layer.
FRAME_ICON_PROPERTY - Static variable in class javax.swing.JInternalFrame
Bound property name.
FRAMEBITS - Static variable in interface java.awt.image.ImageObserver
This flag in the infoflags argument to imageUpdate indicates that another complete frame of a multi-frame image which was previously drawn is now available to be drawn again.
FRAMEBORDER - Static variable in class javax.swing.text.html.HTML.Attribute
frameIcon - Variable in class javax.swing.JInternalFrame
The icon shown in the top-left corner of this internal frame.
frameInit() - Method in class javax.swing.JFrame
Called by the constructors to init the JFrame properly.
frameLength - Variable in class javax.sound.sampled.AudioInputStream
This stream's length, in sample frames.
FrameListener() - Constructor for class javax.swing.plaf.basic.BasicToolBarUI.FrameListener
framePos - Variable in class javax.sound.sampled.AudioInputStream
The current position in this stream, in sample frames (zero-based).
frameRate - Variable in class javax.sound.sampled.AudioFormat
The number of frames played or recorded per second, for sounds that have this format.
FRAMESET - Static variable in class javax.swing.text.html.HTML.Tag
frameSize - Variable in class javax.sound.sampled.AudioFormat
The number of bytes in each frame of a sound that has this format.
frameSize - Variable in class javax.sound.sampled.AudioInputStream
The size of each frame, in bytes.
FRANCE - Static variable in class java.util.Locale
Useful constant for country.
free() - Method in interface java.sql.Array
This method frees the Array object and releases the resources that it holds.
free() - Method in interface java.sql.Blob
This method frees the Blob object and releases the resources that it holds.
free() - Method in interface java.sql.Clob
This method frees the Clob object and releases the resources the resources that it holds.
free() - Method in interface java.sql.SQLXML
This method closes this object and releases the resources that it held.
free() - Method in class javax.sql.rowset.serial.SerialArray
This method frees the SeriableArray object and releases the resources that it holds.
free() - Method in class javax.sql.rowset.serial.SerialBlob
This method frees the SeriableBlob object and releases the resources that it holds.
free() - Method in class javax.sql.rowset.serial.SerialClob
This method frees the SeriableClob object and releases the resources that it holds.
FREE_MEM - Exception in org.omg.CORBA
Exception thrown when the ORB failed in an attempt to free dynamic memory, for example because of heap corruption or memory segments being locked.
FREE_MEM() - Constructor for exception org.omg.CORBA.FREE_MEM
Constructs a FREE_MEM exception with a default minor code of 0 and a completion state of COMPLETED_NO.
FREE_MEM(String) - Constructor for exception org.omg.CORBA.FREE_MEM
Constructs a FREE_MEM exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
FREE_MEM(int, CompletionStatus) - Constructor for exception org.omg.CORBA.FREE_MEM
Constructs a FREE_MEM exception with the specified minor code and completion status.
FREE_MEM(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.FREE_MEM
Constructs a FREE_MEM exception with the specified detail message, minor code, and completion status.
FREE_STANDING_PROP - Static variable in class javax.swing.plaf.metal.MetalScrollBarUI
freeMemory() - Method in class java.lang.Runtime
Returns the amount of free memory in the Java Virtual Machine.
FRENCH - Static variable in class java.util.Locale
Useful constant for language.
frequency(Collection<?>, Object) - Static method in class java.util.Collections
Returns the number of elements in the specified collection equal to the specified object.
FRIDAY - Static variable in class java.util.Calendar
Value of the Calendar.DAY_OF_WEEK field indicating Friday.
from(CompositeData) - Static method in class java.lang.management.LockInfo
Returns a LockInfo object represented by the given CompositeData.
from(CompositeData) - Static method in class java.lang.management.MemoryNotificationInfo
Returns a MemoryNotificationInfo object represented by the given CompositeData.
from(CompositeData) - Static method in class java.lang.management.MemoryUsage
Returns a MemoryUsage object represented by the given CompositeData.
from(CompositeData) - Static method in class java.lang.management.MonitorInfo
Returns a MonitorInfo object represented by the given CompositeData.
from(CompositeData) - Static method in class java.lang.management.ThreadInfo
Returns a ThreadInfo object represented by the given CompositeData.
from(File) - Static method in class java.lang.ProcessBuilder.Redirect
Returns a redirect to read from the specified file.
from(long, TimeUnit) - Static method in class java.nio.file.attribute.FileTime
Returns a FileTime representing a value at the given unit of granularity.
from(Instant) - Static method in class java.nio.file.attribute.FileTime
Returns a FileTime representing the same point of time value on the time-line as the provided Instant object.
from(Instant) - Static method in class java.sql.Timestamp
Obtains an instance of Timestamp from an Instant object.
from(TemporalAccessor) - Static method in interface java.time.chrono.ChronoLocalDate
Obtains an instance of ChronoLocalDate from a temporal object.
from(TemporalAccessor) - Static method in interface java.time.chrono.ChronoLocalDateTime
Obtains an instance of ChronoLocalDateTime from a temporal object.
from(TemporalAccessor) - Static method in interface java.time.chrono.Chronology
Obtains an instance of Chronology from a temporal object.
from(TemporalAccessor) - Static method in interface java.time.chrono.ChronoZonedDateTime
Obtains an instance of ChronoZonedDateTime from a temporal object.
from(TemporalAccessor) - Static method in class java.time.chrono.HijrahDate
Obtains a HijrahDate of the Islamic Umm Al-Qura calendar from a temporal object.
from(TemporalAccessor) - Static method in class java.time.chrono.JapaneseDate
Obtains a JapaneseDate from a temporal object.
from(TemporalAccessor) - Static method in class java.time.chrono.MinguoDate
Obtains a MinguoDate from a temporal object.
from(TemporalAccessor) - Static method in class java.time.chrono.ThaiBuddhistDate
Obtains a ThaiBuddhistDate from a temporal object.
from(TemporalAccessor) - Static method in enum java.time.DayOfWeek
Obtains an instance of DayOfWeek from a temporal object.
from(TemporalAmount) - Static method in class java.time.Duration
Obtains an instance of Duration from a temporal amount.
from(TemporalAccessor) - Static method in class java.time.Instant
Obtains an instance of Instant from a temporal object.
from(TemporalAccessor) - Static method in class java.time.LocalDate
Obtains an instance of LocalDate from a temporal object.
from(TemporalAccessor) - Static method in class java.time.LocalDateTime
Obtains an instance of LocalDateTime from a temporal object.
from(TemporalAccessor) - Static method in class java.time.LocalTime
Obtains an instance of LocalTime from a temporal object.
from(TemporalAccessor) - Static method in enum java.time.Month
Obtains an instance of Month from a temporal object.
from(TemporalAccessor) - Static method in class java.time.MonthDay
Obtains an instance of MonthDay from a temporal object.
from(TemporalAccessor) - Static method in class java.time.OffsetDateTime
Obtains an instance of OffsetDateTime from a temporal object.
from(TemporalAccessor) - Static method in class java.time.OffsetTime
Obtains an instance of OffsetTime from a temporal object.
from(TemporalAmount) - Static method in class java.time.Period
Obtains an instance of Period from a temporal amount.
from(TemporalAccessor) - Static method in class java.time.Year
Obtains an instance of Year from a temporal object.
from(TemporalAccessor) - Static method in class java.time.YearMonth
Obtains an instance of YearMonth from a temporal object.
from(TemporalAccessor) - Static method in class java.time.ZonedDateTime
Obtains an instance of ZonedDateTime from a temporal object.
from(TemporalAccessor) - Static method in class java.time.ZoneId
Obtains an instance of ZoneId from a temporal object.
from(TemporalAccessor) - Static method in class java.time.ZoneOffset
Obtains an instance of ZoneOffset from a temporal object.
from(Instant) - Static method in class java.util.Date
Obtains an instance of Date from an Instant object.
from(ZonedDateTime) - Static method in class java.util.GregorianCalendar
Obtains an instance of GregorianCalendar with the default locale from a ZonedDateTime object.
from_any(Any) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Make a DynAny object from an Any object.
from_any(Any) - Method in class org.omg.DynamicAny._DynAnyStub
Initializes the value associated with a DynAny object with the value contained in an any.
from_any(Any) - Method in class org.omg.DynamicAny._DynArrayStub
Initializes the value associated with a DynAny object with the value contained in an any.
from_any(Any) - Method in class org.omg.DynamicAny._DynEnumStub
Initializes the value associated with a DynAny object with the value contained in an any.
from_any(Any) - Method in class org.omg.DynamicAny._DynFixedStub
Initializes the value associated with a DynAny object with the value contained in an any.
from_any(Any) - Method in class org.omg.DynamicAny._DynSequenceStub
Initializes the value associated with a DynAny object with the value contained in an any.
from_any(Any) - Method in class org.omg.DynamicAny._DynStructStub
Initializes the value associated with a DynAny object with the value contained in an any.
from_any(Any) - Method in class org.omg.DynamicAny._DynUnionStub
Initializes the value associated with a DynAny object with the value contained in an any.
from_any(Any) - Method in class org.omg.DynamicAny._DynValueStub
Initializes the value associated with a DynAny object with the value contained in an any.
from_any(Any) - Method in interface org.omg.DynamicAny.DynAnyOperations
Initializes the value associated with a DynAny object with the value contained in an any.
from_int(int) - Static method in class org.omg.CORBA.CompletionStatus
Creates a CompletionStatus object from the given int.
from_int(int) - Static method in class org.omg.CORBA.DefinitionKind
Creates a DefinitionKind instance corresponding to the given code .
from_int(int) - Static method in class org.omg.CORBA.ParameterMode
from_int(int) - Static method in class org.omg.CORBA.SetOverrideType
Converts the given int to the corresponding SetOverrideType instance.
from_int(int) - Static method in class org.omg.CORBA.TCKind
Converts the given int to the corresponding TCKind instance.
from_int(int) - Static method in class org.omg.CosNaming.BindingType
from_int(int) - Static method in class org.omg.CosNaming.NamingContextPackage.NotFoundReason
from_int(int) - Static method in class org.omg.PortableServer.IdAssignmentPolicyValue
from_int(int) - Static method in class org.omg.PortableServer.IdUniquenessPolicyValue
from_int(int) - Static method in class org.omg.PortableServer.ImplicitActivationPolicyValue
from_int(int) - Static method in class org.omg.PortableServer.LifespanPolicyValue
from_int(int) - Static method in class org.omg.PortableServer.POAManagerPackage.State
from_int(int) - Static method in class org.omg.PortableServer.RequestProcessingPolicyValue
from_int(int) - Static method in class org.omg.PortableServer.ServantRetentionPolicyValue
from_int(int) - Static method in class org.omg.PortableServer.ThreadPolicyValue
fromCIEXYZ(float[]) - Method in class java.awt.color.ColorSpace
Transforms a color value assumed to be in the CS_CIEXYZ conversion color space into this ColorSpace.
fromCIEXYZ(float[]) - Method in class java.awt.color.ICC_ColorSpace
Transforms a color value assumed to be in the CS_CIEXYZ conversion color space into this ColorSpace.
fromIndex - Variable in class javax.swing.event.TableColumnModelEvent
The index of the column from where it was moved or removed
fromMethodDescriptorString(String, ClassLoader) - Static method in class java.lang.invoke.MethodType
Finds or creates an instance of a method type, given the spelling of its bytecode descriptor.
fromMillis(long) - Static method in class java.nio.file.attribute.FileTime
Returns a FileTime representing the given value in milliseconds.
fromRGB(float[]) - Method in class java.awt.color.ColorSpace
Transforms a color value assumed to be in the default CS_sRGB color space into this ColorSpace.
fromRGB(float[]) - Method in class java.awt.color.ICC_ColorSpace
Transforms a color value assumed to be in the default CS_sRGB color space into this ColorSpace.
fromString(String) - Static method in class java.nio.file.attribute.PosixFilePermissions
Returns the set of permissions corresponding to a given String representation.
fromString(String) - Static method in class java.util.UUID
Creates a UUID from the string standard representation as described in the UUID.toString() method.
FTP - Static variable in class javax.print.attribute.standard.ReferenceUriSchemesSupported
File Transfer Protocol (FTP).
FULL - Static variable in class java.text.DateFormat
Constant for full style pattern.
FULL_DECOMPOSITION - Static variable in class java.text.Collator
Decomposition mode value.
FULL_FLUSH - Static variable in class java.util.zip.Deflater
Compression flush mode used to flush out all pending output and reset the deflater.
FULL_JOIN - Static variable in interface javax.sql.rowset.JoinRowSet
An ANSI-style JOIN providing a a full JOIN.
FULLWIDTH_DIGITS - Static variable in class java.awt.im.InputSubset
Constant for the fullwidth digits included in the Unicode halfwidth and fullwidth forms character block.
FULLWIDTH_LATIN - Static variable in class java.awt.im.InputSubset
Constant for the fullwidth ASCII variants subset of the Unicode halfwidth and fullwidth forms character block.
Function<T,R> - Interface in java.util.function
Represents a function that accepts one argument and produces a result.
FunctionalInterface - Annotation Type in java.lang
An informative annotation type used to indicate that an interface type declaration is intended to be a functional interface as defined by the Java Language Specification.
functionColumnIn - Static variable in interface java.sql.DatabaseMetaData
Indicates that the parameter or column is an IN parameter.
functionColumnInOut - Static variable in interface java.sql.DatabaseMetaData
Indicates that the parameter or column is an INOUT parameter.
functionColumnOut - Static variable in interface java.sql.DatabaseMetaData
Indicates that the parameter or column is an OUT parameter.
functionColumnResult - Static variable in interface java.sql.DatabaseMetaData
Indicates that the parameter or column is a column in a result set.
functionColumnUnknown - Static variable in interface java.sql.DatabaseMetaData
Indicates that type of the parameter or column is unknown.
functionNoNulls - Static variable in interface java.sql.DatabaseMetaData
Indicates that NULL values are not allowed.
functionNoTable - Static variable in interface java.sql.DatabaseMetaData
Indicates that the function does not return a table.
functionNullable - Static variable in interface java.sql.DatabaseMetaData
Indicates that NULL values are allowed.
functionNullableUnknown - Static variable in interface java.sql.DatabaseMetaData
Indicates that whether NULL values are allowed is unknown.
functionResultUnknown - Static variable in interface java.sql.DatabaseMetaData
Indicates that it is not known whether the function returns a result or a table.
functionReturn - Static variable in interface java.sql.DatabaseMetaData
Indicates that the parameter or column is a return value.
functionReturnsTable - Static variable in interface java.sql.DatabaseMetaData
Indicates that the function returns a table.
FUSER_OVER_TEMP - Static variable in class javax.print.attribute.standard.PrinterStateReason
The fuser temperature is above normal.
FUSER_UNDER_TEMP - Static variable in class javax.print.attribute.standard.PrinterStateReason
The fuser temperature is below normal.
Future<V> - Interface in java.util.concurrent
A Future represents the result of an asynchronous computation.
FutureTask<V> - Class in java.util.concurrent
A cancellable asynchronous computation.
FutureTask(Callable<V>) - Constructor for class java.util.concurrent.FutureTask
Creates a FutureTask that will, upon running, execute the given Callable.
FutureTask(Runnable, V) - Constructor for class java.util.concurrent.FutureTask
Creates a FutureTask that will, upon running, execute the given Runnable, and arrange that get will return the given result on successful completion.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames


G-Index (Java Platform SE 8 )

Overview

Package

Class

Use

Tree

Deprecated

Index

Help

Java™ Platform
Standard Ed. 8

Prev Letter

Next Letter

Frames

No Frames

All Classes

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
G

GAP_TOKEN - Static variable in exception org.ietf.jgss.GSSException

An expected per-message token was not received.

GapContent - Class in javax.swing.text

An implementation of the AbstractDocument.Content interface implemented using a gapped buffer similar to that used by emacs.

GapContent() - Constructor for class javax.swing.text.GapContent

Creates a new GapContent object.

GapContent(int) - Constructor for class javax.swing.text.GapContent

Creates a new GapContent object, with the initial size specified.

GARBAGE_COLLECTOR_MXBEAN_DOMAIN_TYPE - Static variable in class java.lang.management.ManagementFactory

The domain name and the type key property in the ObjectName for a GarbageCollectorMXBean.

GarbageCollectorMXBean - Interface in java.lang.management

The management interface for the garbage collection of the Java virtual machine.

GatheringByteChannel - Interface in java.nio.channels

A channel that can write bytes from a sequence of buffers.

GaugeMonitor - Class in javax.management.monitor

Defines a monitor MBean designed to observe the values of a gauge attribute.

GaugeMonitor() - Constructor for class javax.management.monitor.GaugeMonitor

Default constructor.

GaugeMonitorMBean - Interface in javax.management.monitor

Exposes the remote management interface of the gauge monitor MBean.

gc() - Method in interface java.lang.management.MemoryMXBean

Runs the garbage collector.

gc() - Method in class java.lang.Runtime

Runs the garbage collector.

gc() - Static method in class java.lang.System

Runs the garbage collector.

gcd(BigInteger) - Method in class java.math.BigInteger

Returns a BigInteger whose value is the greatest common divisor of abs(this) and abs(val).

GCMParameterSpec - Class in javax.crypto.spec

Specifies the set of parameters required by a Cipher using the Galois/Counter Mode (GCM) mode.

GCMParameterSpec(int, byte[]) - Constructor for class javax.crypto.spec.GCMParameterSpec

Constructs a GCMParameterSpec using the specified authentication tag bit-length and IV buffer.

GCMParameterSpec(int, byte[], int, int) - Constructor for class javax.crypto.spec.GCMParameterSpec

Constructs a GCMParameterSpec object using the specified authentication tag bit-length and a subset of the specified buffer as the IV.

GDAY - Static variable in class javax.xml.datatype.DatatypeConstants

Fully qualified name for W3C XML Schema 1.0 datatype gDay.

GE - Static variable in class javax.management.Query

A code representing the Query.geq(javax.management.ValueExp, javax.management.ValueExp) query.

GENERAL - Static variable in interface javax.swing.text.html.parser.DTDConstants

GENERAL_PUNCTUATION - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "General Punctuation" Unicode character block.

GeneralPath - Class in java.awt.geom

The GeneralPath class represents a geometric path constructed from straight lines, and quadratic and cubic (Bézier) curves.

GeneralPath() - Constructor for class java.awt.geom.GeneralPath

Constructs a new empty single precision GeneralPath object with a default winding rule of Path2D.WIND_NON_ZERO.

GeneralPath(int) - Constructor for class java.awt.geom.GeneralPath

Constructs a new GeneralPath object with the specified winding rule to control operations that require the interior of the path to be defined.

GeneralPath(int, int) - Constructor for class java.awt.geom.GeneralPath

Constructs a new GeneralPath object with the specified winding rule and the specified initial capacity to store path coordinates.

GeneralPath(Shape) - Constructor for class java.awt.geom.GeneralPath

Constructs a new GeneralPath object from an arbitrary Shape object.

GeneralSecurityException - Exception in java.security

The GeneralSecurityException class is a generic security exception class that provides type safety for all the security-related exception classes that extend from it.

GeneralSecurityException() - Constructor for exception java.security.GeneralSecurityException

Constructs a GeneralSecurityException with no detail message.

GeneralSecurityException(String) - Constructor for exception java.security.GeneralSecurityException

Constructs a GeneralSecurityException with the specified detail message.

GeneralSecurityException(String, Throwable) - Constructor for exception java.security.GeneralSecurityException

Creates a GeneralSecurityException with the specified detail message and cause.

GeneralSecurityException(Throwable) - Constructor for exception java.security.GeneralSecurityException

Creates a GeneralSecurityException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

generate(DoubleSupplier) - Static method in interface java.util.stream.DoubleStream

Returns an infinite sequential unordered stream where each element is generated by the provided DoubleSupplier.

generate(IntSupplier) - Static method in interface java.util.stream.IntStream

Returns an infinite sequential unordered stream where each element is generated by the provided IntSupplier.

generate(LongSupplier) - Static method in interface java.util.stream.LongStream

Returns an infinite sequential unordered stream where each element is generated by the provided LongSupplier.

generate(Supplier<T>) - Static method in interface java.util.stream.Stream

Returns an infinite sequential unordered stream where each element is generated by the provided Supplier.

generateCertificate(InputStream) - Method in class java.security.cert.CertificateFactory

Generates a certificate object and initializes it with the data read from the input stream inStream.

generateCertificates(InputStream) - Method in class java.security.cert.CertificateFactory

Returns a (possibly empty) collection view of the certificates read from the given input stream inStream.

generateCertPath(InputStream) - Method in class java.security.cert.CertificateFactory

Generates a CertPath object and initializes it with the data read from the InputStream inStream.

generateCertPath(InputStream, String) - Method in class java.security.cert.CertificateFactory

Generates a CertPath object and initializes it with the data read from the InputStream inStream.

generateCertPath(List<? extends Certificate>) - Method in class java.security.cert.CertificateFactory

Generates a CertPath object and initializes it with a List of Certificates.

generateCRL(InputStream) - Method in class java.security.cert.CertificateFactory

Generates a certificate revocation list (CRL) object and initializes it with the data read from the input stream inStream.

generateCRLs(InputStream) - Method in class java.security.cert.CertificateFactory

Returns a (possibly empty) collection view of the CRLs read from the given input stream inStream.

Generated - Annotation Type in javax.annotation

The Generated annotation is used to mark source code that has been generated.

generatedKeyAlwaysReturned() - Method in interface java.sql.DatabaseMetaData

Retrieves whether a generated key will always be returned if the column name(s) or index(es) specified for the auto generated key column(s) are valid and the statement succeeds.

generateKey() - Method in class javax.crypto.KeyGenerator

Generates a secret key.

generateKeyPair() - Method in class java.security.KeyPairGenerator

Generates a key pair.

generateKeyPair() - Method in class java.security.KeyPairGeneratorSpi

Generates a key pair.

generateParameters() - Method in class java.security.AlgorithmParameterGenerator

Generates the parameters.

generatePrivate(KeySpec) - Method in class java.security.KeyFactory

Generates a private key object from the provided key specification (key material).

generatePublic(KeySpec) - Method in class java.security.KeyFactory

Generates a public key object from the provided key specification (key material).

generateSchema(SchemaOutputResolver) - Method in class javax.xml.bind.JAXBContext

Generates the schema documents for this context.

generateSecret() - Method in class javax.crypto.KeyAgreement

Generates the shared secret and returns it in a new buffer.

generateSecret(byte[], int) - Method in class javax.crypto.KeyAgreement

Generates the shared secret, and places it into the buffer sharedSecret, beginning at offset inclusive.

generateSecret(String) - Method in class javax.crypto.KeyAgreement

Creates the shared secret and returns it as a SecretKey object of the specified algorithm.

generateSecret(KeySpec) - Method in class javax.crypto.SecretKeyFactory

Generates a SecretKey object from the provided key specification (key material).

generateSeed(int) - Method in class java.security.SecureRandom

Returns the given number of seed bytes, computed using the seed generation algorithm that this class uses to seed itself.

generic() - Method in class java.lang.invoke.MethodType

Converts all types, both reference and primitive, to Object.

GENERIC_FAILURE - Static variable in class java.util.logging.ErrorManager

GENERIC_FAILURE is used for failure that don't fit into one of the other categories.

GenericArrayType - Interface in java.lang.reflect

GenericArrayType represents an array type whose component type is either a parameterized type or a type variable.

GenericDeclaration - Interface in java.lang.reflect

A common interface for all entities that declare type variables.

genericMethodType(int, boolean) - Static method in class java.lang.invoke.MethodType

Finds or creates a method type whose components are Object with an optional trailing Object[] array.

genericMethodType(int) - Static method in class java.lang.invoke.MethodType

Finds or creates a method type whose components are all Object.

GenericSignatureFormatError - Error in java.lang.reflect

Thrown when a syntactically malformed signature attribute is encountered by a reflective method that needs to interpret the generic signature information for a type, method or constructor.

GenericSignatureFormatError() - Constructor for error java.lang.reflect.GenericSignatureFormatError

Constructs a new GenericSignatureFormatError.

GenericSignatureFormatError(String) - Constructor for error java.lang.reflect.GenericSignatureFormatError

Constructs a new GenericSignatureFormatError with the specified message.

genExemptionBlob() - Method in class javax.crypto.ExemptionMechanism

Generates the exemption mechanism key blob.

genExemptionBlob(byte[]) - Method in class javax.crypto.ExemptionMechanism

Generates the exemption mechanism key blob, and stores the result in the output buffer.

genExemptionBlob(byte[], int) - Method in class javax.crypto.ExemptionMechanism

Generates the exemption mechanism key blob, and stores the result in the output buffer, starting at outputOffset inclusive.

genKeyPair() - Method in class java.security.KeyPairGenerator

Generates a key pair.

GEOMETRIC_SHAPES - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "Geometric Shapes" Unicode character block.

GEORGIAN - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "Georgian" Unicode character block.

GEORGIAN_SUPPLEMENT - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "Georgian Supplement" Unicode character block.

geq(ValueExp, ValueExp) - Static method in class javax.management.Query

Returns a query expression that represents a "greater than or equal to" constraint on two values.

GERMAN - Static variable in class java.util.Locale

Useful constant for language.

GERMANY - Static variable in class java.util.Locale

Useful constant for country.

get(Object) - Method in class java.awt.RenderingHints

Returns the value to which the specified key is mapped.

get(Object) - Method in class java.beans.Encoder

Returns a tentative value for oldInstance in the environment created by this stream.

get(String, boolean) - Method in class java.io.ObjectInputStream.GetField

Get the value of the named boolean field from the persistent field.

get(String, byte) - Method in class java.io.ObjectInputStream.GetField

Get the value of the named byte field from the persistent field.

get(String, char) - Method in class java.io.ObjectInputStream.GetField

Get the value of the named char field from the persistent field.

get(String, short) - Method in class java.io.ObjectInputStream.GetField

Get the value of the named short field from the persistent field.

get(String, int) - Method in class java.io.ObjectInputStream.GetField

Get the value of the named int field from the persistent field.

get(String, long) - Method in class java.io.ObjectInputStream.GetField

Get the value of the named long field from the persistent field.

get(String, float) - Method in class java.io.ObjectInputStream.GetField

Get the value of the named float field from the persistent field.

get(String, double) - Method in class java.io.ObjectInputStream.GetField

Get the value of the named double field from the persistent field.

get(String, Object) - Method in class java.io.ObjectInputStream.GetField

Get the value of the named Object field from the persistent field.

get(Class<?>) - Method in class java.lang.ClassValue

Returns the value for the given class.

get() - Method in class java.lang.ref.PhantomReference

Returns this reference object's referent.

get() - Method in class java.lang.ref.Reference

Returns this reference object's referent.

get() - Method in class java.lang.ref.SoftReference

Returns this reference object's referent.

get(Object, int) - Static method in class java.lang.reflect.Array

Returns the value of the indexed component in the specified array object.

get(Object) - Method in class java.lang.reflect.Field

Returns the value of the field represented by this Field, on the specified object.

get() - Method in class java.lang.ThreadLocal

Returns the value in the current thread's copy of this thread-local variable.

get(URI, Map<String, List<String>>) - Method in class java.net.CookieHandler

Gets all the applicable cookies from a cookie cache for the specified uri in the request header.

get(URI, Map<String, List<String>>) - Method in class java.net.CookieManager

get(URI) - Method in interface java.net.CookieStore

Retrieve cookies associated with given URI, or whose domain matches the given URI.

get(URI, String, Map<String, List<String>>) - Method in class java.net.ResponseCache

Retrieve the cached response based on the requesting uri, request method and request headers.

get() - Method in class java.nio.ByteBuffer

Relative get method.

get(int) - Method in class java.nio.ByteBuffer

Absolute get method.

get(byte[], int, int) - Method in class java.nio.ByteBuffer

Relative bulk get method.

get(byte[]) - Method in class java.nio.ByteBuffer

Relative bulk get method.

get() - Method in class java.nio.CharBuffer

Relative get method.

get(int) - Method in class java.nio.CharBuffer

Absolute get method.

get(char[], int, int) - Method in class java.nio.CharBuffer

Relative bulk get method.

get(char[]) - Method in class java.nio.CharBuffer

Relative bulk get method.

get() - Method in class java.nio.DoubleBuffer

Relative get method.

get(int) - Method in class java.nio.DoubleBuffer

Absolute get method.

get(double[], int, int) - Method in class java.nio.DoubleBuffer

Relative bulk get method.

get(double[]) - Method in class java.nio.DoubleBuffer

Relative bulk get method.

get(String, String...) - Static method in class java.nio.file.Paths

Converts a path string, or a sequence of strings that when joined form a path string, to a Path.

get(URI) - Static method in class java.nio.file.Paths

Converts the given URI to a Path object.

get() - Method in class java.nio.FloatBuffer

Relative get method.

get(int) - Method in class java.nio.FloatBuffer

Absolute get method.

get(float[], int, int) - Method in class java.nio.FloatBuffer

Relative bulk get method.

get(float[]) - Method in class java.nio.FloatBuffer

Relative bulk get method.

get() - Method in class java.nio.IntBuffer

Relative get method.

get(int) - Method in class java.nio.IntBuffer

Absolute get method.

get(int[], int, int) - Method in class java.nio.IntBuffer

Relative bulk get method.

get(int[]) - Method in class java.nio.IntBuffer

Relative bulk get method.

get() - Method in class java.nio.LongBuffer

Relative get method.

get(int) - Method in class java.nio.LongBuffer

Absolute get method.

get(long[], int, int) - Method in class java.nio.LongBuffer

Relative bulk get method.

get(long[]) - Method in class java.nio.LongBuffer

Relative bulk get method.

get() - Method in class java.nio.ShortBuffer

Relative get method.

get(int) - Method in class java.nio.ShortBuffer

Absolute get method.

get(short[], int, int) - Method in class java.nio.ShortBuffer

Relative bulk get method.

get(short[]) - Method in class java.nio.ShortBuffer

Relative bulk get method.

get() - Method in class java.rmi.MarshalledObject

Returns a new copy of the contained marshalledobject.

get(Object) - Method in class java.security.Provider

get(TemporalUnit) - Method in interface java.time.chrono.ChronoPeriod

Gets the value of the requested unit.

get(TemporalField) - Method in interface java.time.chrono.ChronoZonedDateTime

get(TemporalField) - Method in interface java.time.chrono.Era

Gets the value of the specified field from this era as an int.

get(TemporalField) - Method in enum java.time.DayOfWeek

Gets the value of the specified field from this day-of-week as an int.

get(TemporalUnit) - Method in class java.time.Duration

Gets the value of the requested unit.

get(TemporalField) - Method in class java.time.Instant

Gets the value of the specified field from this instant as an int.

get(TemporalField) - Method in class java.time.LocalDate

Gets the value of the specified field from this date as an int.

get(TemporalField) - Method in class java.time.LocalDateTime

Gets the value of the specified field from this date-time as an int.

get(TemporalField) - Method in class java.time.LocalTime

Gets the value of the specified field from this time as an int.

get(TemporalField) - Method in enum java.time.Month

Gets the value of the specified field from this month-of-year as an int.

get(TemporalField) - Method in class java.time.MonthDay

Gets the value of the specified field from this month-day as an int.

get(TemporalField) - Method in class java.time.OffsetDateTime

Gets the value of the specified field from this date-time as an int.

get(TemporalField) - Method in class java.time.OffsetTime

Gets the value of the specified field from this time as an int.

get(TemporalUnit) - Method in class java.time.Period

Gets the value of the requested unit.

get(TemporalField) - Method in interface java.time.temporal.TemporalAccessor

Gets the value of the specified field as an int.

get(TemporalUnit) - Method in interface java.time.temporal.TemporalAmount

Returns the value of the requested unit.

get(TemporalField) - Method in class java.time.Year

Gets the value of the specified field from this year as an int.

get(TemporalField) - Method in class java.time.YearMonth

Gets the value of the specified field from this year-month as an int.

get(TemporalField) - Method in class java.time.ZonedDateTime

Gets the value of the specified field from this date-time as an int.

get(TemporalField) - Method in class java.time.ZoneOffset

Gets the value of the specified field from this offset as an int.

get(int) - Method in class java.util.AbstractList

Returns the element at the specified position in this list.

get(Object) - Method in class java.util.AbstractMap

Returns the value to which the specified key is mapped, or null if this map contains no mapping for the key.

get(int) - Method in class java.util.AbstractSequentialList

Returns the element at the specified position in this list.

get(int) - Method in class java.util.ArrayList

Returns the element at the specified position in this list.

get(int) - Method in class java.util.BitSet

Returns the value of the bit with the specified index.

get(int, int) - Method in class java.util.BitSet

Returns a new BitSet composed of bits from this BitSet from fromIndex (inclusive) to toIndex (exclusive).

get(int) - Method in class java.util.Calendar

Returns the value of the given calendar field.

get() - Method in class java.util.concurrent.atomic.AtomicBoolean

Returns the current value.

get() - Method in class java.util.concurrent.atomic.AtomicInteger

Gets the current value.

get(int) - Method in class java.util.concurrent.atomic.AtomicIntegerArray

Gets the current value at position i.

get(T) - Method in class java.util.concurrent.atomic.AtomicIntegerFieldUpdater

Gets the current value held in the field of the given object managed by this updater.

get() - Method in class java.util.concurrent.atomic.AtomicLong

Gets the current value.

get(int) - Method in class java.util.concurrent.atomic.AtomicLongArray

Gets the current value at position i.

get(T) - Method in class java.util.concurrent.atomic.AtomicLongFieldUpdater

Gets the current value held in the field of the given object managed by this updater.

get(boolean[]) - Method in class java.util.concurrent.atomic.AtomicMarkableReference

Returns the current values of both the reference and the mark.

get() - Method in class java.util.concurrent.atomic.AtomicReference

Gets the current value.

get(int) - Method in class java.util.concurrent.atomic.AtomicReferenceArray

Gets the current value at position i.

get(T) - Method in class java.util.concurrent.atomic.AtomicReferenceFieldUpdater

Gets the current value held in the field of the given object managed by this updater.

get(int[]) - Method in class java.util.concurrent.atomic.AtomicStampedReference

Returns the current values of both the reference and the stamp.

get() - Method in class java.util.concurrent.atomic.DoubleAccumulator

Returns the current value.

get() - Method in class java.util.concurrent.atomic.LongAccumulator

Returns the current value.

get() - Method in class java.util.concurrent.CompletableFuture

Waits if necessary for this future to complete, and then returns its result.

get(long, TimeUnit) - Method in class java.util.concurrent.CompletableFuture

Waits if necessary for at most the given time for this future to complete, and then returns its result, if available.

get(Object) - Method in class java.util.concurrent.ConcurrentHashMap

Returns the value to which the specified key is mapped, or null if this map contains no mapping for the key.

get(Object) - Method in class java.util.concurrent.ConcurrentSkipListMap

Returns the value to which the specified key is mapped, or null if this map contains no mapping for the key.

get(int) - Method in class java.util.concurrent.CopyOnWriteArrayList

Returns the element at the specified position in this list.

get() - Method in class java.util.concurrent.ForkJoinTask

Waits if necessary for the computation to complete, and then retrieves its result.

get(long, TimeUnit) - Method in class java.util.concurrent.ForkJoinTask

Waits if necessary for at most the given time for the computation to complete, and then retrieves its result, if available.

get() - Method in interface java.util.concurrent.Future

Waits if necessary for the computation to complete, and then retrieves its result.

get(long, TimeUnit) - Method in interface java.util.concurrent.Future

Waits if necessary for at most the given time for the computation to complete, and then retrieves its result, if available.

get() - Method in class java.util.concurrent.FutureTask

get(long, TimeUnit) - Method in class java.util.concurrent.FutureTask

get(Object) - Method in class java.util.Dictionary

Returns the value to which the key is mapped in this dictionary.

get(Object) - Method in class java.util.EnumMap

Returns the value to which the specified key is mapped, or null if this map contains no mapping for the key.

get() - Method in interface java.util.function.Supplier

Gets a result.

get(Object) - Method in class java.util.HashMap

Returns the value to which the specified key is mapped, or null if this map contains no mapping for the key.

get(Object) - Method in class java.util.Hashtable

Returns the value to which the specified key is mapped, or null if this map contains no mapping for the key.

get(Object) - Method in class java.util.IdentityHashMap

Returns the value to which the specified key is mapped, or null if this map contains no mapping for the key.

get(Object) - Method in class java.util.jar.Attributes

Returns the value of the specified attribute name, or null if the attribute name was not found.

get(Object) - Method in class java.util.LinkedHashMap

Returns the value to which the specified key is mapped, or null if this map contains no mapping for the key.

get(int) - Method in class java.util.LinkedList

Returns the element at the specified position in this list.

get(int) - Method in interface java.util.List

Returns the element at the specified position in this list.

get(Object) - Method in interface java.util.Map

Returns the value to which the specified key is mapped, or null if this map contains no mapping for the key.

get() - Method in class java.util.Optional

If a value is present in this Optional, returns the value, otherwise throws NoSuchElementException.

get(String, String) - Method in class java.util.prefs.AbstractPreferences

Implements the get method as per the specification in Preferences.get(String,String).

get(String, String) - Method in class java.util.prefs.Preferences

Returns the value associated with the specified key in this preference node.

get(Object) - Method in class java.util.TreeMap

Returns the value to which the specified key is mapped, or null if this map contains no mapping for the key.

get(int) - Method in class java.util.Vector

Returns the element at the specified position in this Vector.

get(Object) - Method in class java.util.WeakHashMap

Returns the value to which the specified key is mapped, or null if this map contains no mapping for the key.

get(String) - Method in class javax.accessibility.AccessibleRelationSet

Returns the relation that matches the specified key.

get(String) - Method in class javax.activation.MimeTypeParameterList

Retrieve the value associated with the given name, or null if there is no current association.

get(String) - Method in interface javax.management.openmbean.CompositeData

Returns the value of the item whose name is key.

get(String) - Method in class javax.management.openmbean.CompositeDataSupport

Returns the value of the item whose name is key.

get(Object[]) - Method in interface javax.management.openmbean.TabularData

Returns the CompositeData value whose index is key, or null if there is no value mapping to key, in this TabularData instance.

get(Object) - Method in class javax.management.openmbean.TabularDataSupport

This method simply calls get((Object[]) key).

get(Object[]) - Method in class javax.management.openmbean.TabularDataSupport

Returns the CompositeData value whose index is key, or null if there is no value mapping to key, in this TabularData instance.

get(int) - Method in class javax.naming.CompositeName

Retrieves a component of this composite name.

get(int) - Method in class javax.naming.CompoundName

Retrieves a component of this compound name.

get() - Method in interface javax.naming.directory.Attribute

Retrieves one of this attribute's values.

get(int) - Method in interface javax.naming.directory.Attribute

Retrieves the attribute value from the ordered list of attribute values.

get(String) - Method in interface javax.naming.directory.Attributes

Retrieves the attribute with the given attribute id from the attribute set.

get() - Method in class javax.naming.directory.BasicAttribute

Retrieves one of this attribute's values.

get(int) - Method in class javax.naming.directory.BasicAttribute

get(String) - Method in class javax.naming.directory.BasicAttributes

get(int) - Method in class javax.naming.ldap.LdapName

Retrieves a component of this LDAP name as a string.

get(int) - Method in interface javax.naming.Name

Retrieves a component of this name.

get(String) - Method in class javax.naming.Reference

Retrieves the first address that has the address type 'addrType'.

get(int) - Method in class javax.naming.Reference

Retrieves the address at index posn.

get(Class<?>) - Method in interface javax.print.attribute.AttributeSet

Returns the attribute value which this attribute set contains in the given attribute category.

get(Class<?>) - Method in class javax.print.attribute.HashAttributeSet

Returns the attribute value which this attribute set contains in the given attribute category.

get(String) - Method in class javax.script.AbstractScriptEngine

Gets the value for the specified key in the ENGINE_SCOPE of the protected context field.

get(Object) - Method in interface javax.script.Bindings

Returns the value to which this map maps the specified key.

get(String) - Method in interface javax.script.ScriptEngine

Retrieves a value set in the state of this engine.

get(String) - Method in class javax.script.ScriptEngineManager

Gets the value for the specified key in the Global Scope

get(Object) - Method in class javax.script.SimpleBindings

Returns the value to which this map maps the specified key.

get(int) - Method in class javax.sound.midi.Track

Obtains the event at the specified index.

get(Object) - Method in class javax.swing.ActionMap

Returns the binding for key, messaging the parent ActionMap if the binding is not locally defined.

get(int) - Method in class javax.swing.DefaultListModel

Returns the element at the specified position in this list.

get(KeyStroke) - Method in class javax.swing.InputMap

Returns the binding for keyStroke, messaging the parent InputMap if the binding is not locally defined.

get(SynthContext, Object) - Method in class javax.swing.plaf.nimbus.NimbusStyle

Getter for a region specific style property.

get(SynthContext, Object) - Method in class javax.swing.plaf.synth.SynthStyle

Getter for a region specific style property.

get() - Method in class javax.swing.SwingWorker

Waits if necessary for the computation to complete, and then retrieves its result.

get(long, TimeUnit) - Method in class javax.swing.SwingWorker

Waits if necessary for at most the given time for the computation to complete, and then retrieves its result, if available.

get(Object) - Method in class javax.swing.UIDefaults

Returns the value for key.

get(Object, Locale) - Method in class javax.swing.UIDefaults

Returns the value for key associated with the given locale.

get(Object) - Static method in class javax.swing.UIManager

Returns an object from the defaults.

get(Object, Locale) - Static method in class javax.swing.UIManager

Returns an object from the defaults that is appropriate for the given locale.

get(Object) - Method in class javax.xml.crypto.dom.DOMCryptoContext

This implementation uses an internal HashMap to get the object that the specified key maps to.

get(Object) - Method in interface javax.xml.crypto.XMLCryptoContext

Returns the value to which this context maps the specified key.

get(Object) - Method in class javax.xml.soap.SOAPConnection

Gets a message from a specific endpoint and blocks until it receives,

get2DigitYearStart() - Method in class java.text.SimpleDateFormat

Returns the beginning date of the 100-year period 2-digit years are interpreted as being within.

get_any() - Method in interface org.omg.CORBA.DynAny

Deprecated.

Retrieves the org.omg.CORBA.Any contained in this DynAny object.

get_any() - Method in class org.omg.DynamicAny._DynAnyStub

Extracts an Any value contained in the Any represented by this DynAny.

get_any() - Method in class org.omg.DynamicAny._DynArrayStub

Extracts an Any value contained in the Any represented by this DynAny.

get_any() - Method in class org.omg.DynamicAny._DynEnumStub

Extracts an Any value contained in the Any represented by this DynAny.

get_any() - Method in class org.omg.DynamicAny._DynFixedStub

Extracts an Any value contained in the Any represented by this DynAny.

get_any() - Method in class org.omg.DynamicAny._DynSequenceStub

Extracts an Any value contained in the Any represented by this DynAny.

get_any() - Method in class org.omg.DynamicAny._DynStructStub

Extracts an Any value contained in the Any represented by this DynAny.

get_any() - Method in class org.omg.DynamicAny._DynUnionStub

Extracts an Any value contained in the Any represented by this DynAny.

get_any() - Method in class org.omg.DynamicAny._DynValueStub

Extracts an Any value contained in the Any represented by this DynAny.

get_any() - Method in interface org.omg.DynamicAny.DynAnyOperations

Extracts an Any value contained in the Any represented by this DynAny.

get_as_string() - Method in class org.omg.DynamicAny._DynEnumStub

Returns the value of the DynEnum as an IDL identifier.

get_as_string() - Method in interface org.omg.DynamicAny.DynEnumOperations

Returns the value of the DynEnum as an IDL identifier.

get_as_ulong() - Method in class org.omg.DynamicAny._DynEnumStub

Returns the value of the DynEnum as the enumerated value's ordinal value.

get_as_ulong() - Method in interface org.omg.DynamicAny.DynEnumOperations

Returns the value of the DynEnum as the enumerated value's ordinal value.

get_boolean() - Method in interface org.omg.CORBA.DynAny

Deprecated.

Retrieves the boolean contained in this DynAny object.

get_boolean() - Method in class org.omg.DynamicAny._DynAnyStub

Extracts the boolean value from this DynAny.

get_boolean() - Method in class org.omg.DynamicAny._DynArrayStub

Extracts the boolean value from this DynAny.

get_boolean() - Method in class org.omg.DynamicAny._DynEnumStub

Extracts the boolean value from this DynAny.

get_boolean() - Method in class org.omg.DynamicAny._DynFixedStub

Extracts the boolean value from this DynAny.

get_boolean() - Method in class org.omg.DynamicAny._DynSequenceStub

Extracts the boolean value from this DynAny.

get_boolean() - Method in class org.omg.DynamicAny._DynStructStub

Extracts the boolean value from this DynAny.

get_boolean() - Method in class org.omg.DynamicAny._DynUnionStub

Extracts the boolean value from this DynAny.

get_boolean() - Method in class org.omg.DynamicAny._DynValueStub

Extracts the boolean value from this DynAny.

get_boolean() - Method in interface org.omg.DynamicAny.DynAnyOperations

Extracts the boolean value from this DynAny.

get_boxed_value() - Method in interface org.omg.DynamicAny.DynValueBoxOperations

Returns the boxed value as an Any.

get_boxed_value_as_dyn_any() - Method in interface org.omg.DynamicAny.DynValueBoxOperations

Returns the boxed value as a DynAny.

get_char() - Method in interface org.omg.CORBA.DynAny

Deprecated.

Retrieves the char contained in this DynAny object.

get_char() - Method in class org.omg.DynamicAny._DynAnyStub

Extracts the char value from this DynAny.

get_char() - Method in class org.omg.DynamicAny._DynArrayStub

Extracts the char value from this DynAny.

get_char() - Method in class org.omg.DynamicAny._DynEnumStub

Extracts the char value from this DynAny.

get_char() - Method in class org.omg.DynamicAny._DynFixedStub

Extracts the char value from this DynAny.

get_char() - Method in class org.omg.DynamicAny._DynSequenceStub

Extracts the char value from this DynAny.

get_char() - Method in class org.omg.DynamicAny._DynStructStub

Extracts the char value from this DynAny.

get_char() - Method in class org.omg.DynamicAny._DynUnionStub

Extracts the char value from this DynAny.

get_char() - Method in class org.omg.DynamicAny._DynValueStub

Extracts the char value from this DynAny.

get_char() - Method in interface org.omg.DynamicAny.DynAnyOperations

Extracts the char value from this DynAny.

get_codebase(Object) - Method in class org.omg.CORBA_2_3.portable.Delegate

Returns the codebase for object reference provided.

get_compact_typecode() - Method in class org.omg.CORBA.TypeCode

Strips out all optional name and member name fields, but leaves all alias typecodes intact.

get_current() - Method in class org.omg.CORBA.ORB

Deprecated.
use resolve_initial_references.

get_default_context() - Method in class org.omg.CORBA.ORB

Gets the default Context object.

get_discriminator() - Method in class org.omg.DynamicAny._DynUnionStub

Returns the current discriminator value.

get_discriminator() - Method in interface org.omg.DynamicAny.DynUnionOperations

Returns the current discriminator value.

get_domain_managers(Object) - Method in class org.omg.CORBA.portable.Delegate

Retrieves the DomainManagers of this object.

get_domain_policy(int) - Method in interface org.omg.CORBA.DomainManagerOperations

This returns the policy of the specified type for objects in this domain.

get_double() - Method in interface org.omg.CORBA.DynAny

Deprecated.

Retrieves the double contained in this DynAny object.

get_double() - Method in class org.omg.DynamicAny._DynAnyStub

Extracts the double value from this DynAny.

get_double() - Method in class org.omg.DynamicAny._DynArrayStub

Extracts the double value from this DynAny.

get_double() - Method in class org.omg.DynamicAny._DynEnumStub

Extracts the double value from this DynAny.

get_double() - Method in class org.omg.DynamicAny._DynFixedStub

Extracts the double value from this DynAny.

get_double() - Method in class org.omg.DynamicAny._DynSequenceStub

Extracts the double value from this DynAny.

get_double() - Method in class org.omg.DynamicAny._DynStructStub

Extracts the double value from this DynAny.

get_double() - Method in class org.omg.DynamicAny._DynUnionStub

Extracts the double value from this DynAny.

get_double() - Method in class org.omg.DynamicAny._DynValueStub

Extracts the double value from this DynAny.

get_double() - Method in interface org.omg.DynamicAny.DynAnyOperations

Extracts the double value from this DynAny.

get_dyn_any() - Method in class org.omg.DynamicAny._DynAnyStub

Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.

get_dyn_any() - Method in class org.omg.DynamicAny._DynArrayStub

Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.

get_dyn_any() - Method in class org.omg.DynamicAny._DynEnumStub

Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.

get_dyn_any() - Method in class org.omg.DynamicAny._DynFixedStub

Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.

get_dyn_any() - Method in class org.omg.DynamicAny._DynSequenceStub

Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.

get_dyn_any() - Method in class org.omg.DynamicAny._DynStructStub

Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.

get_dyn_any() - Method in class org.omg.DynamicAny._DynUnionStub

Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.

get_dyn_any() - Method in class org.omg.DynamicAny._DynValueStub

Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.

get_dyn_any() - Method in interface org.omg.DynamicAny.DynAnyOperations

Extracts the Any value contained in the Any represented by this DynAny and returns it wrapped into a new DynAny.

get_effective_component(int) - Method in interface org.omg.PortableInterceptor.ClientRequestInfoOperations

Returns the IOP.TaggedComponent with the given ID from the profile selected for this request.

get_effective_components(int) - Method in interface org.omg.PortableInterceptor.ClientRequestInfoOperations

Returns an array of all tagged components with the given ID from the profile selected for this request.

get_effective_policy(int) - Method in interface org.omg.PortableInterceptor.IORInfoOperations

Allows an ORB service implementation to determine what server side policy of a particular type is in effect for an IOR being constructed.

get_elements() - Method in interface org.omg.CORBA.DynArray

Deprecated.

Returns the value of all the elements of this array.

get_elements() - Method in interface org.omg.CORBA.DynSequence

Deprecated.

Returns the value of every element in this sequence.

get_elements() - Method in class org.omg.DynamicAny._DynArrayStub

Returns the elements of the DynArray.

get_elements() - Method in class org.omg.DynamicAny._DynSequenceStub

Returns the elements of the sequence.

get_elements() - Method in interface org.omg.DynamicAny.DynArrayOperations

Returns the elements of the DynArray.

get_elements() - Method in interface org.omg.DynamicAny.DynSequenceOperations

Returns the elements of the sequence.

get_elements_as_dyn_any() - Method in class org.omg.DynamicAny._DynArrayStub

Returns the elements of the DynArray as DynAnys.

get_elements_as_dyn_any() - Method in class org.omg.DynamicAny._DynSequenceStub

Returns the DynAnys representing the elements of the sequence.

get_elements_as_dyn_any() - Method in interface org.omg.DynamicAny.DynArrayOperations

Returns the elements of the DynArray as DynAnys.

get_elements_as_dyn_any() - Method in interface org.omg.DynamicAny.DynSequenceOperations

Returns the DynAnys representing the elements of the sequence.

get_float() - Method in interface org.omg.CORBA.DynAny

Deprecated.

Retrieves the float contained in this DynAny object.

get_float() - Method in class org.omg.DynamicAny._DynAnyStub

Extracts the float value from this DynAny.

get_float() - Method in class org.omg.DynamicAny._DynArrayStub

Extracts the float value from this DynAny.

get_float() - Method in class org.omg.DynamicAny._DynEnumStub

Extracts the float value from this DynAny.

get_float() - Method in class org.omg.DynamicAny._DynFixedStub

Extracts the float value from this DynAny.

get_float() - Method in class org.omg.DynamicAny._DynSequenceStub

Extracts the float value from this DynAny.

get_float() - Method in class org.omg.DynamicAny._DynStructStub

Extracts the float value from this DynAny.

get_float() - Method in class org.omg.DynamicAny._DynUnionStub

Extracts the float value from this DynAny.

get_float() - Method in class org.omg.DynamicAny._DynValueStub

Extracts the float value from this DynAny.

get_float() - Method in interface org.omg.DynamicAny.DynAnyOperations

Extracts the float value from this DynAny.

get_id() - Method in interface org.omg.CORBA.portable.BoxedValueHelper

get_id() - Method in class org.omg.CORBA.StringValueHelper

get_id() - Method in class org.omg.CORBA.WStringValueHelper

get_interface_def(Object) - Method in class org.omg.CORBA.portable.Delegate

Return an InterfaceDef for the object reference provided.

get_interface_def(Servant) - Method in interface org.omg.PortableServer.portable.Delegate

This operation returns an object in the Interface Repository which provides type information that may be useful to a program.

get_length() - Method in class org.omg.DynamicAny._DynSequenceStub

Returns the current length of the sequence.

get_length() - Method in interface org.omg.DynamicAny.DynSequenceOperations

Returns the current length of the sequence.

get_long() - Method in interface org.omg.CORBA.DynAny

Deprecated.

Retrieves the int contained in this DynAny object.

get_long() - Method in class org.omg.DynamicAny._DynAnyStub

Extracts the integer value from this DynAny.

get_long() - Method in class org.omg.DynamicAny._DynArrayStub

Extracts the integer value from this DynAny.

get_long() - Method in class org.omg.DynamicAny._DynEnumStub

Extracts the integer value from this DynAny.

get_long() - Method in class org.omg.DynamicAny._DynFixedStub

Extracts the integer value from this DynAny.

get_long() - Method in class org.omg.DynamicAny._DynSequenceStub

Extracts the integer value from this DynAny.

get_long() - Method in class org.omg.DynamicAny._DynStructStub

Extracts the integer value from this DynAny.

get_long() - Method in class org.omg.DynamicAny._DynUnionStub

Extracts the integer value from this DynAny.

get_long() - Method in class org.omg.DynamicAny._DynValueStub

Extracts the integer value from this DynAny.

get_long() - Method in interface org.omg.DynamicAny.DynAnyOperations

Extracts the integer value from this DynAny.

get_longlong() - Method in interface org.omg.CORBA.DynAny

Deprecated.

Retrieves the long contained in this DynAny object.

get_longlong() - Method in class org.omg.DynamicAny._DynAnyStub

Extracts the long value from this DynAny.

get_longlong() - Method in class org.omg.DynamicAny._DynArrayStub

Extracts the long value from this DynAny.

get_longlong() - Method in class org.omg.DynamicAny._DynEnumStub

Extracts the long value from this DynAny.

get_longlong() - Method in class org.omg.DynamicAny._DynFixedStub

Extracts the long value from this DynAny.

get_longlong() - Method in class org.omg.DynamicAny._DynSequenceStub

Extracts the long value from this DynAny.

get_longlong() - Method in class org.omg.DynamicAny._DynStructStub

Extracts the long value from this DynAny.

get_longlong() - Method in class org.omg.DynamicAny._DynUnionStub

Extracts the long value from this DynAny.

get_longlong() - Method in class org.omg.DynamicAny._DynValueStub

Extracts the long value from this DynAny.

get_longlong() - Method in interface org.omg.DynamicAny.DynAnyOperations

Extracts the long value from this DynAny.

get_members() - Method in interface org.omg.CORBA.DynStruct

Deprecated.

Returns an array containing all the members of the stored struct.

get_members() - Method in interface org.omg.CORBA.DynValue

Deprecated.

Returns an array containing all the members of the value object stored in this DynValue.

get_members() - Method in class org.omg.DynamicAny._DynStructStub

Returns a sequence of NameValuePairs describing the name and the value of each member in the struct associated with a DynStruct object.

get_members() - Method in class org.omg.DynamicAny._DynValueStub

Returns a sequence of NameValuePairs describing the name and the value of each member in the value type.

get_members() - Method in interface org.omg.DynamicAny.DynStructOperations

Returns a sequence of NameValuePairs describing the name and the value of each member in the struct associated with a DynStruct object.

get_members() - Method in interface org.omg.DynamicAny.DynValueOperations

Returns a sequence of NameValuePairs describing the name and the value of each member in the value type.

get_members_as_dyn_any() - Method in class org.omg.DynamicAny._DynStructStub

Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the struct associated with a DynStruct object.

get_members_as_dyn_any() - Method in class org.omg.DynamicAny._DynValueStub

Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the value type.

get_members_as_dyn_any() - Method in interface org.omg.DynamicAny.DynStructOperations

Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the struct associated with a DynStruct object.

get_members_as_dyn_any() - Method in interface org.omg.DynamicAny.DynValueOperations

Returns a sequence of NameDynAnyPairs describing the name and the value of each member in the value type.

get_next_response() - Method in class org.omg.CORBA.ORB

Gets the next Request instance for which a response has been received.

get_object_id() - Method in interface org.omg.PortableServer.CurrentOperations

Returns the ObjectId identifying the object in whose context it is called.

get_octet() - Method in interface org.omg.CORBA.DynAny

Deprecated.

Retrieves the byte contained in this DynAny object.

get_octet() - Method in class org.omg.DynamicAny._DynAnyStub

Extracts the byte value from this DynAny.

get_octet() - Method in class org.omg.DynamicAny._DynArrayStub

Extracts the byte value from this DynAny.

get_octet() - Method in class org.omg.DynamicAny._DynEnumStub

Extracts the byte value from this DynAny.

get_octet() - Method in class org.omg.DynamicAny._DynFixedStub

Extracts the byte value from this DynAny.

get_octet() - Method in class org.omg.DynamicAny._DynSequenceStub

Extracts the byte value from this DynAny.

get_octet() - Method in class org.omg.DynamicAny._DynStructStub

Extracts the byte value from this DynAny.

get_octet() - Method in class org.omg.DynamicAny._DynUnionStub

Extracts the byte value from this DynAny.

get_octet() - Method in class org.omg.DynamicAny._DynValueStub

Extracts the byte value from this DynAny.

get_octet() - Method in interface org.omg.DynamicAny.DynAnyOperations

Extracts the byte value from this DynAny.

get_POA() - Method in interface org.omg.PortableServer.CurrentOperations

Returns reference to the POA implementing the object in whose context it is called.

get_policy(Object, int) - Method in class org.omg.CORBA.portable.Delegate

Returns the Policy object of the specified type which applies to this object.

get_primitive_tc(TCKind) - Method in class org.omg.CORBA.ORB

Retrieves the TypeCode object that represents the given primitive IDL type.

get_reference() - Method in interface org.omg.CORBA.DynAny

Deprecated.

Retrieves the org.omg.CORBA.Other contained in this DynAny object.

get_reference() - Method in class org.omg.DynamicAny._DynAnyStub

Extracts the reference to a CORBA Object from this DynAny.

get_reference() - Method in class org.omg.DynamicAny._DynArrayStub

Extracts the reference to a CORBA Object from this DynAny.

get_reference() - Method in class org.omg.DynamicAny._DynEnumStub

Extracts the reference to a CORBA Object from this DynAny.

get_reference() - Method in class org.omg.DynamicAny._DynFixedStub

Extracts the reference to a CORBA Object from this DynAny.

get_reference() - Method in class org.omg.DynamicAny._DynSequenceStub

Extracts the reference to a CORBA Object from this DynAny.

get_reference() - Method in class org.omg.DynamicAny._DynStructStub

Extracts the reference to a CORBA Object from this DynAny.

get_reference() - Method in class org.omg.DynamicAny._DynUnionStub

Extracts the reference to a CORBA Object from this DynAny.

get_reference() - Method in class org.omg.DynamicAny._DynValueStub

Extracts the reference to a CORBA Object from this DynAny.

get_reference() - Method in interface org.omg.DynamicAny.DynAnyOperations

Extracts the reference to a CORBA Object from this DynAny.

get_reply_service_context(int) - Method in interface org.omg.PortableInterceptor.RequestInfoOperations

Returns a copy of the service context with the given ID that is associated with the reply.

get_request_policy(int) - Method in interface org.omg.PortableInterceptor.ClientRequestInfoOperations

Returns the given policy in effect for this operation.

get_request_service_context(int) - Method in interface org.omg.PortableInterceptor.RequestInfoOperations

Returns a copy of the service context with the given ID that is associated with the request.

get_response() - Method in class org.omg.CORBA.Request

Allows the user to access the response for the invocation triggered earlier with the send_deferred method.

get_servant() - Method in interface org.omg.PortableServer.POAOperations

This operation returns the default servant associated with the POA.

get_servant_manager() - Method in interface org.omg.PortableServer.POAOperations

If the ServantRetentionPolicy of the POA is RETAIN, then the ServantManager argument (imgr) shall support the ServantActivator interface.

get_server_policy(int) - Method in interface org.omg.PortableInterceptor.ServerRequestInfoOperations

Returns the policy in effect for this operation for the given policy type.

get_service_information(short, ServiceInformationHolder) - Method in class org.omg.CORBA.ORB

Used to obtain information about CORBA facilities and services that are supported by this ORB.

get_short() - Method in interface org.omg.CORBA.DynAny

Deprecated.

Retrieves the short contained in this DynAny object.

get_short() - Method in class org.omg.DynamicAny._DynAnyStub

Extracts the short value from this DynAny.

get_short() - Method in class org.omg.DynamicAny._DynArrayStub

Extracts the short value from this DynAny.

get_short() - Method in class org.omg.DynamicAny._DynEnumStub

Extracts the short value from this DynAny.

get_short() - Method in class org.omg.DynamicAny._DynFixedStub

Extracts the short value from this DynAny.

get_short() - Method in class org.omg.DynamicAny._DynSequenceStub

Extracts the short value from this DynAny.

get_short() - Method in class org.omg.DynamicAny._DynStructStub

Extracts the short value from this DynAny.

get_short() - Method in class org.omg.DynamicAny._DynUnionStub

Extracts the short value from this DynAny.

get_short() - Method in class org.omg.DynamicAny._DynValueStub

Extracts the short value from this DynAny.

get_short() - Method in interface org.omg.DynamicAny.DynAnyOperations

Extracts the short value from this DynAny.

get_slot(int) - Method in interface org.omg.PortableInterceptor.CurrentOperations

Retrieves the slot data the application set in PICurrent via get_slot.

get_slot(int) - Method in interface org.omg.PortableInterceptor.RequestInfoOperations

Returns the data from the given slot of the PortableInterceptor.Current that is in the scope of the request.

get_state() - Method in interface org.omg.PortableServer.POAManagerOperations

This operation returns the state of the POA manager.

get_string() - Method in interface org.omg.CORBA.DynAny

Deprecated.

Retrieves the String contained in this DynAny object.

get_string() - Method in class org.omg.DynamicAny._DynAnyStub

Extracts the string value from this DynAny.

get_string() - Method in class org.omg.DynamicAny._DynArrayStub

Extracts the string value from this DynAny.

get_string() - Method in class org.omg.DynamicAny._DynEnumStub

Extracts the string value from this DynAny.

get_string() - Method in class org.omg.DynamicAny._DynFixedStub

Extracts the string value from this DynAny.

get_string() - Method in class org.omg.DynamicAny._DynSequenceStub

Extracts the string value from this DynAny.

get_string() - Method in class org.omg.DynamicAny._DynStructStub

Extracts the string value from this DynAny.

get_string() - Method in class org.omg.DynamicAny._DynUnionStub

Extracts the string value from this DynAny.

get_string() - Method in class org.omg.DynamicAny._DynValueStub

Extracts the string value from this DynAny.

get_string() - Method in interface org.omg.DynamicAny.DynAnyOperations

Extracts the string value from this DynAny.

get_typecode() - Method in interface org.omg.CORBA.DynAny

Deprecated.

Retrieves the org.omg.CORBA.TypeCode contained in this DynAny object.

get_typecode() - Method in class org.omg.DynamicAny._DynAnyStub

Extracts the TypeCode object from this DynAny.

get_typecode() - Method in class org.omg.DynamicAny._DynArrayStub

Extracts the TypeCode object from this DynAny.

get_typecode() - Method in class org.omg.DynamicAny._DynEnumStub

Extracts the TypeCode object from this DynAny.

get_typecode() - Method in class org.omg.DynamicAny._DynFixedStub

Extracts the TypeCode object from this DynAny.

get_typecode() - Method in class org.omg.DynamicAny._DynSequenceStub

Extracts the TypeCode object from this DynAny.

get_typecode() - Method in class org.omg.DynamicAny._DynStructStub

Extracts the TypeCode object from this DynAny.

get_typecode() - Method in class org.omg.DynamicAny._DynUnionStub

Extracts the TypeCode object from this DynAny.

get_typecode() - Method in class org.omg.DynamicAny._DynValueStub

Extracts the TypeCode object from this DynAny.

get_typecode() - Method in interface org.omg.DynamicAny.DynAnyOperations

Extracts the TypeCode object from this DynAny.

get_ulong() - Method in interface org.omg.CORBA.DynAny

Deprecated.

Retrieves the int contained in this DynAny object.

get_ulong() - Method in class org.omg.DynamicAny._DynAnyStub

Extracts the integer value from this DynAny.

get_ulong() - Method in class org.omg.DynamicAny._DynArrayStub

Extracts the integer value from this DynAny.

get_ulong() - Method in class org.omg.DynamicAny._DynEnumStub

Extracts the integer value from this DynAny.

get_ulong() - Method in class org.omg.DynamicAny._DynFixedStub

Extracts the integer value from this DynAny.

get_ulong() - Method in class org.omg.DynamicAny._DynSequenceStub

Extracts the integer value from this DynAny.

get_ulong() - Method in class org.omg.DynamicAny._DynStructStub

Extracts the integer value from this DynAny.

get_ulong() - Method in class org.omg.DynamicAny._DynUnionStub

Extracts the integer value from this DynAny.

get_ulong() - Method in class org.omg.DynamicAny._DynValueStub

Extracts the integer value from this DynAny.

get_ulong() - Method in interface org.omg.DynamicAny.DynAnyOperations

Extracts the integer value from this DynAny.

get_ulonglong() - Method in interface org.omg.CORBA.DynAny

Deprecated.

Retrieves the long contained in this DynAny object.

get_ulonglong() - Method in class org.omg.DynamicAny._DynAnyStub

Extracts the long value from this DynAny.

get_ulonglong() - Method in class org.omg.DynamicAny._DynArrayStub

Extracts the long value from this DynAny.

get_ulonglong() - Method in class org.omg.DynamicAny._DynEnumStub

Extracts the long value from this DynAny.

get_ulonglong() - Method in class org.omg.DynamicAny._DynFixedStub

Extracts the long value from this DynAny.

get_ulonglong() - Method in class org.omg.DynamicAny._DynSequenceStub

Extracts the long value from this DynAny.

get_ulonglong() - Method in class org.omg.DynamicAny._DynStructStub

Extracts the long value from this DynAny.

get_ulonglong() - Method in class org.omg.DynamicAny._DynUnionStub

Extracts the long value from this DynAny.

get_ulonglong() - Method in class org.omg.DynamicAny._DynValueStub

Extracts the long value from this DynAny.

get_ulonglong() - Method in interface org.omg.DynamicAny.DynAnyOperations

Extracts the long value from this DynAny.

get_ushort() - Method in interface org.omg.CORBA.DynAny

Deprecated.

Retrieves the short contained in this DynAny object.

get_ushort() - Method in class org.omg.DynamicAny._DynAnyStub

Extracts the short value from this DynAny.

get_ushort() - Method in class org.omg.DynamicAny._DynArrayStub

Extracts the short value from this DynAny.

get_ushort() - Method in class org.omg.DynamicAny._DynEnumStub

Extracts the short value from this DynAny.

get_ushort() - Method in class org.omg.DynamicAny._DynFixedStub

Extracts the short value from this DynAny.

get_ushort() - Method in class org.omg.DynamicAny._DynSequenceStub

Extracts the short value from this DynAny.

get_ushort() - Method in class org.omg.DynamicAny._DynStructStub

Extracts the short value from this DynAny.

get_ushort() - Method in class org.omg.DynamicAny._DynUnionStub

Extracts the short value from this DynAny.

get_ushort() - Method in class org.omg.DynamicAny._DynValueStub

Extracts the short value from this DynAny.

get_ushort() - Method in interface org.omg.DynamicAny.DynAnyOperations

Extracts the short value from this DynAny.

get_val() - Method in interface org.omg.CORBA.DynAny

Deprecated.

Retrieves the java.io.Serializable object contained in this DynAny object.

get_val() - Method in class org.omg.DynamicAny._DynAnyStub

Extracts a Serializable object from this DynAny.

get_val() - Method in class org.omg.DynamicAny._DynArrayStub

Extracts a Serializable object from this DynAny.

get_val() - Method in class org.omg.DynamicAny._DynEnumStub

Extracts a Serializable object from this DynAny.

get_val() - Method in class org.omg.DynamicAny._DynFixedStub

Extracts a Serializable object from this DynAny.

get_val() - Method in class org.omg.DynamicAny._DynSequenceStub

Extracts a Serializable object from this DynAny.

get_val() - Method in class org.omg.DynamicAny._DynStructStub

Extracts a Serializable object from this DynAny.

get_val() - Method in class org.omg.DynamicAny._DynUnionStub

Extracts a Serializable object from this DynAny.

get_val() - Method in class org.omg.DynamicAny._DynValueStub

Extracts a Serializable object from this DynAny.

get_val() - Method in interface org.omg.DynamicAny.DynAnyOperations

Extracts a Serializable object from this DynAny.

get_value() - Method in interface org.omg.CORBA.DynFixed

Deprecated.

Returns the value of the fixed type represented in this DynFixed object.

get_value() - Method in class org.omg.DynamicAny._DynFixedStub

Returns the value of a DynFixed.

get_value() - Method in interface org.omg.DynamicAny.DynFixedOperations

Returns the value of a DynFixed.

get_value_def(String) - Method in class org.omg.CORBA_2_3.ORB

get_values(String, int, String) - Method in class org.omg.CORBA.Context

Retrieves the NamedValue objects whose name field matches the given name or name pattern.

get_wchar() - Method in interface org.omg.CORBA.DynAny

Deprecated.

Retrieves the char contained in this DynAny object.

get_wchar() - Method in class org.omg.DynamicAny._DynAnyStub

Extracts the long value from this DynAny.

get_wchar() - Method in class org.omg.DynamicAny._DynArrayStub

Extracts the long value from this DynAny.

get_wchar() - Method in class org.omg.DynamicAny._DynEnumStub

Extracts the long value from this DynAny.

get_wchar() - Method in class org.omg.DynamicAny._DynFixedStub

Extracts the long value from this DynAny.

get_wchar() - Method in class org.omg.DynamicAny._DynSequenceStub

Extracts the long value from this DynAny.

get_wchar() - Method in class org.omg.DynamicAny._DynStructStub

Extracts the long value from this DynAny.

get_wchar() - Method in class org.omg.DynamicAny._DynUnionStub

Extracts the long value from this DynAny.

get_wchar() - Method in class org.omg.DynamicAny._DynValueStub

Extracts the long value from this DynAny.

get_wchar() - Method in interface org.omg.DynamicAny.DynAnyOperations

Extracts the long value from this DynAny.

get_wstring() - Method in interface org.omg.CORBA.DynAny

Deprecated.

Retrieves the String contained in this DynAny object.

get_wstring() - Method in class org.omg.DynamicAny._DynAnyStub

Extracts the string value from this DynAny.

get_wstring() - Method in class org.omg.DynamicAny._DynArrayStub

Extracts the string value from this DynAny.

get_wstring() - Method in class org.omg.DynamicAny._DynEnumStub

Extracts the string value from this DynAny.

get_wstring() - Method in class org.omg.DynamicAny._DynFixedStub

Extracts the string value from this DynAny.

get_wstring() - Method in class org.omg.DynamicAny._DynSequenceStub

Extracts the string value from this DynAny.

get_wstring() - Method in class org.omg.DynamicAny._DynStructStub

Extracts the string value from this DynAny.

get_wstring() - Method in class org.omg.DynamicAny._DynUnionStub

Extracts the string value from this DynAny.

get_wstring() - Method in class org.omg.DynamicAny._DynValueStub

Extracts the string value from this DynAny.

get_wstring() - Method in interface org.omg.DynamicAny.DynAnyOperations

Extracts the string value from this DynAny.

getA() - Method in class java.security.spec.EllipticCurve

Returns the first coefficient a of the elliptic curve.

getAbsoluteFile() - Method in class java.io.File

Returns the absolute form of this abstract pathname.

getAbsolutePath() - Method in class java.io.File

Returns the absolute pathname string of this abstract pathname.

getAccelerationPriority() - Method in class java.awt.Image

Returns the current value of the acceleration priority hint.

getAccelerator() - Method in class javax.swing.JMenuItem

Returns the KeyStroke which serves as an accelerator for the menu item.

getAcceleratorForeground() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the accelerator foreground color of the current theme.

getAcceleratorForeground() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the accelerator foreground color.

getAcceleratorSelectedForeground() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the accelerator selected foreground color of the current theme.

getAcceleratorSelectedForeground() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the accelerator selected foreground color.

getAcceleratorString() - Method in class javax.swing.plaf.metal.MetalToolTipUI

getAcceptAllFileFilter() - Method in class javax.swing.JFileChooser

Returns the AcceptAll file filter.

getAcceptAllFileFilter(JFileChooser) - Method in class javax.swing.plaf.basic.BasicFileChooserUI

Returns the default accept all file filter

getAcceptAllFileFilter(JFileChooser) - Method in class javax.swing.plaf.FileChooserUI

getAcceptAllFileFilter(JFileChooser) - Method in class javax.swing.plaf.multi.MultiFileChooserUI

Invokes the getAcceptAllFileFilter method on each UI handled by this object.

getAcceptedIssuers() - Method in interface javax.net.ssl.X509TrustManager

Return an array of certificate authority certificates which are trusted for authenticating peers.

getAcceptorAddress() - Method in class org.ietf.jgss.ChannelBinding

Get the acceptor's address for this channel binding.

getAccessibleAction() - Method in class java.awt.Button.AccessibleAWTButton

Get the AccessibleAction associated with this object.

getAccessibleAction() - Method in class java.awt.Checkbox.AccessibleAWTCheckbox

Get the AccessibleAction associated with this object.

getAccessibleAction() - Method in class java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem

Get the AccessibleAction associated with this object.

getAccessibleAction() - Method in class java.awt.Choice.AccessibleAWTChoice

Get the AccessibleAction associated with this object.

getAccessibleAction() - Method in class java.awt.MenuItem.AccessibleAWTMenuItem

Get the AccessibleAction associated with this object.

getAccessibleAction() - Method in class javax.accessibility.AccessibleContext

Gets the AccessibleAction associated with this object that supports one or more actions.

getAccessibleAction() - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Get the AccessibleAction associated with this object.

getAccessibleAction() - Method in class javax.swing.JComboBox.AccessibleJComboBox

Get the AccessibleAction associated with this object.

getAccessibleAction() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getAccessibleAction() - Method in class javax.swing.JSpinner.AccessibleJSpinner

Gets the AccessibleAction associated with this object that supports one or more actions.

getAccessibleAction() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the AccessibleAction associated with this object if one exists.

getAccessibleAction() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Get the AccessibleAction associated with this object.

getAccessibleAction() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getAccessibleAction() - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

getAccessibleActionAnchor(int) - Method in class javax.accessibility.AccessibleHyperlink

Returns an object that represents the link anchor, as appropriate for that link.

getAccessibleActionAnchor(int) - Method in class javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink

Return an object that represents the link anchor, as appropriate for that link.

getAccessibleActionCount() - Method in class java.awt.Button.AccessibleAWTButton

Returns the number of Actions available in this object.

getAccessibleActionCount() - Method in class java.awt.Checkbox.AccessibleAWTCheckbox

Returns the number of Actions available in this object.

getAccessibleActionCount() - Method in class java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem

Returns the number of Actions available in this object.

getAccessibleActionCount() - Method in class java.awt.Choice.AccessibleAWTChoice

Returns the number of accessible actions available in this object If there are more than one, the first one is considered the "default" action of the object.

getAccessibleActionCount() - Method in class java.awt.MenuItem.AccessibleAWTMenuItem

Returns the number of Actions available in this object.

getAccessibleActionCount() - Method in interface javax.accessibility.AccessibleAction

Returns the number of accessible actions available in this object If there are more than one, the first one is considered the "default" action of the object.

getAccessibleActionCount() - Method in class javax.accessibility.AccessibleHyperlink

Returns the number of accessible actions available in this Link If there are more than one, the first one is NOT considered the "default" action of this LINK object (e.g.

getAccessibleActionCount() - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Returns the number of Actions available in this object.

getAccessibleActionCount() - Method in class javax.swing.JComboBox.AccessibleJComboBox

Returns the number of Actions available in this object.

getAccessibleActionCount() - Method in class javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink

Returns the number of accessible actions available in this Link If there are more than one, the first one is NOT considered the "default" action of this LINK object (e.g.

getAccessibleActionCount() - Method in class javax.swing.JSpinner.AccessibleJSpinner

Returns the number of accessible actions available in this object If there are more than one, the first one is considered the "default" action of the object.

getAccessibleActionCount() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Returns the number of accessible actions available in this tree node.

getAccessibleActionCount() - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Returns the number of accessible actions available in this object If there are more than one, the first one is considered the "default" action of the object.

getAccessibleActionDescription(int) - Method in class java.awt.Button.AccessibleAWTButton

Return a description of the specified action of the object.

getAccessibleActionDescription(int) - Method in class java.awt.Checkbox.AccessibleAWTCheckbox

Return a description of the specified action of the object.

getAccessibleActionDescription(int) - Method in class java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem

Return a description of the specified action of the object.

getAccessibleActionDescription(int) - Method in class java.awt.Choice.AccessibleAWTChoice

Returns a description of the specified action of the object.

getAccessibleActionDescription(int) - Method in class java.awt.MenuItem.AccessibleAWTMenuItem

Return a description of the specified action of the object.

getAccessibleActionDescription(int) - Method in interface javax.accessibility.AccessibleAction

Returns a description of the specified action of the object.

getAccessibleActionDescription(int) - Method in class javax.accessibility.AccessibleHyperlink

Returns a String description of this particular link action.

getAccessibleActionDescription(int) - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Return a description of the specified action of the object.

getAccessibleActionDescription(int) - Method in class javax.swing.JComboBox.AccessibleJComboBox

Return a description of the specified action of the object.

getAccessibleActionDescription(int) - Method in class javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink

Return a String description of this particular link action.

getAccessibleActionDescription(int) - Method in class javax.swing.JSpinner.AccessibleJSpinner

Returns a description of the specified action of the object.

getAccessibleActionDescription(int) - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Return a description of the specified action of the tree node.

getAccessibleActionDescription(int) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Returns a description of the specified action of the object.

getAccessibleActionObject(int) - Method in class javax.accessibility.AccessibleHyperlink

Returns an object that represents the link action, as appropriate for that link.

getAccessibleActionObject(int) - Method in class javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink

Returns a URL object that represents the link.

getAccessibleAt(Point) - Method in class java.awt.Component.AccessibleAWTComponent

Returns the Accessible child, if one exists, contained at the local coordinate Point.

getAccessibleAt(Point) - Method in class java.awt.Container.AccessibleAWTContainer

Returns the Accessible child, if one exists, contained at the local coordinate Point.

getAccessibleAt(Point) - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Returns the Accessible child, if one exists, contained at the local coordinate Point.

getAccessibleAt(Point) - Method in class java.awt.List.AccessibleAWTList

Returns the Accessible child contained at the local coordinate Point, if one exists.

getAccessibleAt(Point) - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Returns the Accessible child, if one exists, contained at the local coordinate Point.

getAccessibleAt(Point) - Method in interface javax.accessibility.AccessibleComponent

Returns the Accessible child, if one exists, contained at the local coordinate Point.

getAccessibleAt(int, int) - Method in interface javax.accessibility.AccessibleTable

Returns the Accessible at a specified row and column in the table.

getAccessibleAt(Point) - Method in class javax.swing.JEditorPane.AccessibleJEditorPaneHTML

Returns the Accessible child, if one exists, contained at the local coordinate Point.

getAccessibleAt(Point) - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getAccessibleAt(Point) - Method in class javax.swing.JList.AccessibleJList

Returns the Accessible child contained at the local coordinate Point, if one exists.

getAccessibleAt(Point) - Method in class javax.swing.JTabbedPane.AccessibleJTabbedPane

Returns the Accessible child contained at the local coordinate Point, if one exists.

getAccessibleAt(Point) - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

getAccessibleAt(Point) - Method in class javax.swing.JTable.AccessibleJTable

Returns the Accessible child, if one exists, contained at the local coordinate Point.

getAccessibleAt(int, int) - Method in class javax.swing.JTable.AccessibleJTable

getAccessibleAt(Point) - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Returns the Accessible child, if one exists, contained at the local coordinate Point.

getAccessibleAt(Point) - Method in class javax.swing.JTree.AccessibleJTree

Returns the Accessible child, if one exists, contained at the local coordinate Point.

getAccessibleAt(Component, Point) - Static method in class javax.swing.SwingUtilities

Returns the Accessible child contained at the local coordinate Point, if one exists.

getAccessibleAt(Point) - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getAccessibleAt(Point) - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader

Returns the Accessible child, if one exists, contained at the local coordinate Point.

getAccessibleCaption() - Method in interface javax.accessibility.AccessibleTable

Returns the caption for the table.

getAccessibleCaption() - Method in class javax.swing.JTable.AccessibleJTable

Returns the caption for the table.

getAccessibleChild(int) - Method in class java.awt.Component.AccessibleAWTComponent

Returns the nth Accessible child of the object.

getAccessibleChild(int) - Method in class java.awt.Container.AccessibleAWTContainer

Returns the nth Accessible child of the object.

getAccessibleChild(int) - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Return the specified Accessible child of the object.

getAccessibleChild(int) - Method in class java.awt.List.AccessibleAWTList

Return the nth Accessible child of the object.

getAccessibleChild(int) - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Returns the nth Accessible child of the object.

getAccessibleChild(int) - Method in class javax.accessibility.AccessibleContext

Returns the specified Accessible child of the object.

getAccessibleChild(int) - Method in class javax.swing.ImageIcon.AccessibleImageIcon

Returns the nth Accessible child of the object.

getAccessibleChild(int) - Method in class javax.swing.JComboBox.AccessibleJComboBox

Returns the nth Accessible child of the object.

getAccessibleChild(int) - Method in class javax.swing.JComponent.AccessibleJComponent

Returns the nth Accessible child of the object.

getAccessibleChild(int) - Method in class javax.swing.JEditorPane.AccessibleJEditorPaneHTML

Returns the specified Accessible child of the object.

getAccessibleChild(int) - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getAccessibleChild(int) - Method in class javax.swing.JList.AccessibleJList

Return the nth Accessible child of the object.

getAccessibleChild(int) - Method in class javax.swing.JMenu.AccessibleJMenu

Returns the nth Accessible child of the object.

getAccessibleChild(int) - Method in class javax.swing.JRootPane.AccessibleJRootPane

Returns the specified Accessible child of the object.

getAccessibleChild(int) - Method in class javax.swing.JSpinner.AccessibleJSpinner

Returns the specified Accessible child of the object.

getAccessibleChild(int) - Method in class javax.swing.JTabbedPane.AccessibleJTabbedPane

Return the specified Accessible child of the object.

getAccessibleChild(int) - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Returns the specified Accessible child of the object.

getAccessibleChild(int) - Method in class javax.swing.JTable.AccessibleJTable

Returns the nth Accessible child of the object.

getAccessibleChild(int) - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Return the specified Accessible child of the object.

getAccessibleChild(int) - Method in class javax.swing.JTree.AccessibleJTree

Return the nth Accessible child of the object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.basic.BasicComboBoxUI

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.ComponentUI

Returns the ith Accessible child of the object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiButtonUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiColorChooserUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiComboBoxUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiDesktopIconUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiDesktopPaneUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiFileChooserUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiInternalFrameUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiLabelUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiListUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiMenuBarUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiMenuItemUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiOptionPaneUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiPanelUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiPopupMenuUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiProgressBarUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiRootPaneUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiScrollBarUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiScrollPaneUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiSeparatorUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiSliderUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiSpinnerUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiSplitPaneUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiTabbedPaneUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiTableHeaderUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiTableUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiTextUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiToolBarUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiToolTipUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiTreeUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(JComponent, int) - Method in class javax.swing.plaf.multi.MultiViewportUI

Invokes the getAccessibleChild method on each UI handled by this object.

getAccessibleChild(int) - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Returns the specified Accessible child of the object.

getAccessibleChild(Component, int) - Static method in class javax.swing.SwingUtilities

Return the nth Accessible child of the object.

getAccessibleChild(int) - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getAccessibleChild(int) - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader

Return the nth Accessible child of the object.

getAccessibleChildrenCount() - Method in class java.awt.Component.AccessibleAWTComponent

Returns the number of accessible children in the object.

getAccessibleChildrenCount() - Method in class java.awt.Container.AccessibleAWTContainer

Returns the number of accessible children in the object.

getAccessibleChildrenCount() - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Returns the number of accessible children of the object.

getAccessibleChildrenCount() - Method in class java.awt.List.AccessibleAWTList

Returns the number of accessible children in the object.

getAccessibleChildrenCount() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Returns the number of accessible children in the object.

getAccessibleChildrenCount() - Method in class javax.accessibility.AccessibleContext

Returns the number of accessible children of the object.

getAccessibleChildrenCount() - Method in class javax.swing.ImageIcon.AccessibleImageIcon

Returns the number of accessible children in the object.

getAccessibleChildrenCount() - Method in class javax.swing.JComboBox.AccessibleJComboBox

Returns the number of accessible children in the object.

getAccessibleChildrenCount() - Method in class javax.swing.JComponent.AccessibleJComponent

Returns the number of accessible children in the object.

getAccessibleChildrenCount() - Method in class javax.swing.JEditorPane.AccessibleJEditorPaneHTML

Returns the number of accessible children of the object.

getAccessibleChildrenCount() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getAccessibleChildrenCount() - Method in class javax.swing.JList.AccessibleJList

Returns the number of accessible children in the object.

getAccessibleChildrenCount() - Method in class javax.swing.JMenu.AccessibleJMenu

Returns the number of accessible children in the object.

getAccessibleChildrenCount() - Method in class javax.swing.JRootPane.AccessibleJRootPane

Returns the number of accessible children of the object.

getAccessibleChildrenCount() - Method in class javax.swing.JSpinner.AccessibleJSpinner

Returns the number of accessible children of the object.

getAccessibleChildrenCount() - Method in class javax.swing.JTabbedPane.AccessibleJTabbedPane

Returns the number of accessible children in the object.

getAccessibleChildrenCount() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Returns the number of accessible children in the object.

getAccessibleChildrenCount() - Method in class javax.swing.JTable.AccessibleJTable

Returns the number of accessible children in the object.

getAccessibleChildrenCount() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Returns the number of accessible children in the object.

getAccessibleChildrenCount() - Method in class javax.swing.JTree.AccessibleJTree

Returns the number of top-level children nodes of this JTree.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.basic.BasicComboBoxUI

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.ComponentUI

Returns the number of accessible children in the object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiButtonUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiColorChooserUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiComboBoxUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiDesktopIconUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiDesktopPaneUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiFileChooserUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiInternalFrameUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiLabelUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiListUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiMenuBarUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiMenuItemUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiOptionPaneUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiPanelUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiPopupMenuUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiProgressBarUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiRootPaneUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiScrollBarUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiScrollPaneUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiSeparatorUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiSliderUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiSpinnerUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiSplitPaneUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiTabbedPaneUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiTableHeaderUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiTableUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiTextUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiToolBarUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiToolTipUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiTreeUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount(JComponent) - Method in class javax.swing.plaf.multi.MultiViewportUI

Invokes the getAccessibleChildrenCount method on each UI handled by this object.

getAccessibleChildrenCount() - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Returns the number of accessible children of the object.

getAccessibleChildrenCount(Component) - Static method in class javax.swing.SwingUtilities

Returns the number of accessible children in the object.

getAccessibleChildrenCount() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getAccessibleChildrenCount() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader

Returns the number of accessible children in the object.

getAccessibleColumn(int) - Method in interface javax.accessibility.AccessibleExtendedTable

Returns the column number of an index in the table.

getAccessibleColumn(int) - Method in class javax.swing.JTable.AccessibleJTable

Returns the column number of an index in the table.

getAccessibleColumnAtIndex(int) - Method in class javax.swing.JTable.AccessibleJTable

Returns the column at a given index into the table.

getAccessibleColumnCount() - Method in interface javax.accessibility.AccessibleTable

Returns the number of columns in the table.

getAccessibleColumnCount() - Method in class javax.swing.JTable.AccessibleJTable

getAccessibleColumnDescription(int) - Method in interface javax.accessibility.AccessibleTable

Returns the description text of the specified column in the table.

getAccessibleColumnDescription(int) - Method in class javax.swing.JTable.AccessibleJTable

Returns the description of the specified column in the table.

getAccessibleColumnExtentAt(int, int) - Method in interface javax.accessibility.AccessibleTable

Returns the number of columns occupied by the Accessible at a specified row and column in the table.

getAccessibleColumnExtentAt(int, int) - Method in class javax.swing.JTable.AccessibleJTable

Returns the number of columns occupied by the Accessible at a given (row, column).

getAccessibleColumnHeader() - Method in interface javax.accessibility.AccessibleTable

Returns the column headers as an AccessibleTable.

getAccessibleColumnHeader() - Method in class javax.swing.JTable.AccessibleJTable

Returns the column headers as an AccessibleTable.

getAccessibleComponent() - Method in class java.awt.Component.AccessibleAWTComponent

Gets the AccessibleComponent associated with this object if one exists.

getAccessibleComponent() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Gets the AccessibleComponent associated with this object if one exists.

getAccessibleComponent() - Method in class javax.accessibility.AccessibleContext

Gets the AccessibleComponent associated with this object that has a graphical representation.

getAccessibleComponent() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

Get the AccessibleComponent associated with this object.

getAccessibleComponent() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the AccessibleComponent associated with this object if one exists.

getAccessibleComponent() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Get the AccessibleComponent associated with this object.

getAccessibleComponent() - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Gets the AccessibleComponent associated with this object that has a graphical representation.

getAccessibleComponent() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

Get the AccessibleComponent associated with this object.

getAccessibleContext() - Method in class java.applet.Applet

Gets the AccessibleContext associated with this Applet.

getAccessibleContext() - Method in class java.awt.Button

Gets the AccessibleContext associated with this Button.

getAccessibleContext() - Method in class java.awt.Canvas

Gets the AccessibleContext associated with this Canvas.

getAccessibleContext() - Method in class java.awt.Checkbox

Gets the AccessibleContext associated with this Checkbox.

getAccessibleContext() - Method in class java.awt.CheckboxMenuItem

Gets the AccessibleContext associated with this CheckboxMenuItem.

getAccessibleContext() - Method in class java.awt.Choice

Gets the AccessibleContext associated with this Choice.

getAccessibleContext() - Method in class java.awt.Component

Gets the AccessibleContext associated with this Component.

getAccessibleContext() - Method in class java.awt.Dialog

Gets the AccessibleContext associated with this Dialog.

getAccessibleContext() - Method in class java.awt.Frame

Gets the AccessibleContext associated with this Frame.

getAccessibleContext() - Method in class java.awt.Label

Gets the AccessibleContext associated with this Label.

getAccessibleContext() - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Gets the AccessibleContext for this object.

getAccessibleContext() - Method in class java.awt.List

Gets the AccessibleContext associated with this List.

getAccessibleContext() - Method in class java.awt.Menu

Gets the AccessibleContext associated with this Menu.

getAccessibleContext() - Method in class java.awt.MenuBar

Gets the AccessibleContext associated with this MenuBar.

getAccessibleContext() - Method in class java.awt.MenuComponent

Gets the AccessibleContext associated with this MenuComponent.

getAccessibleContext() - Method in class java.awt.MenuItem

Gets the AccessibleContext associated with this MenuItem.

getAccessibleContext() - Method in class java.awt.Panel

Gets the AccessibleContext associated with this Panel.

getAccessibleContext() - Method in class java.awt.PopupMenu

Gets the AccessibleContext associated with this PopupMenu.

getAccessibleContext() - Method in class java.awt.Scrollbar

Gets the AccessibleContext associated with this Scrollbar.

getAccessibleContext() - Method in class java.awt.ScrollPane

Gets the AccessibleContext associated with this ScrollPane.

getAccessibleContext() - Method in class java.awt.TextArea

Returns the AccessibleContext associated with this TextArea.

getAccessibleContext() - Method in class java.awt.TextComponent

Gets the AccessibleContext associated with this TextComponent.

getAccessibleContext() - Method in class java.awt.TextField

Gets the AccessibleContext associated with this TextField.

getAccessibleContext() - Method in class java.awt.Window

Gets the AccessibleContext associated with this Window.

getAccessibleContext() - Method in interface javax.accessibility.Accessible

Returns the AccessibleContext associated with this object.

getAccessibleContext() - Method in class javax.swing.Box.Filler

Gets the AccessibleContext associated with this Box.Filler.

getAccessibleContext() - Method in class javax.swing.Box

Gets the AccessibleContext associated with this Box.

getAccessibleContext() - Method in class javax.swing.CellRendererPane

Gets the AccessibleContext associated with this CellRendererPane.

getAccessibleContext() - Method in class javax.swing.ImageIcon

Gets the AccessibleContext associated with this ImageIcon.

getAccessibleContext() - Method in class javax.swing.JApplet

Gets the AccessibleContext associated with this JApplet.

getAccessibleContext() - Method in class javax.swing.JButton

Gets the AccessibleContext associated with this JButton.

getAccessibleContext() - Method in class javax.swing.JCheckBox

Gets the AccessibleContext associated with this JCheckBox.

getAccessibleContext() - Method in class javax.swing.JCheckBoxMenuItem

Gets the AccessibleContext associated with this JCheckBoxMenuItem.

getAccessibleContext() - Method in class javax.swing.JColorChooser

Gets the AccessibleContext associated with this JColorChooser.

getAccessibleContext() - Method in class javax.swing.JComboBox

Gets the AccessibleContext associated with this JComboBox.

getAccessibleContext() - Method in class javax.swing.JDesktopPane

Gets the AccessibleContext associated with this JDesktopPane.

getAccessibleContext() - Method in class javax.swing.JDialog

Gets the AccessibleContext associated with this JDialog.

getAccessibleContext() - Method in class javax.swing.JEditorPane

Gets the AccessibleContext associated with this JEditorPane.

getAccessibleContext() - Method in class javax.swing.JFileChooser

Gets the AccessibleContext associated with this JFileChooser.

getAccessibleContext() - Method in class javax.swing.JFrame

Gets the AccessibleContext associated with this JFrame.

getAccessibleContext() - Method in class javax.swing.JInternalFrame

Gets the AccessibleContext associated with this JInternalFrame.

getAccessibleContext() - Method in class javax.swing.JInternalFrame.JDesktopIcon

Gets the AccessibleContext associated with this JDesktopIcon.

getAccessibleContext() - Method in class javax.swing.JLabel

Get the AccessibleContext of this object

getAccessibleContext() - Method in class javax.swing.JLayer

Gets the AccessibleContext associated with this JLayer.

getAccessibleContext() - Method in class javax.swing.JLayeredPane

Gets the AccessibleContext associated with this JLayeredPane.

getAccessibleContext() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

Get the AccessibleContext for this object.

getAccessibleContext() - Method in class javax.swing.JList

Gets the AccessibleContext associated with this JList.

getAccessibleContext() - Method in class javax.swing.JMenu

Gets the AccessibleContext associated with this JMenu.

getAccessibleContext() - Method in class javax.swing.JMenuBar

Gets the AccessibleContext associated with this JMenuBar.

getAccessibleContext() - Method in class javax.swing.JMenuItem

Returns the AccessibleContext associated with this JMenuItem.

getAccessibleContext() - Method in class javax.swing.JOptionPane

Returns the AccessibleContext associated with this JOptionPane.

getAccessibleContext() - Method in class javax.swing.JPanel

Gets the AccessibleContext associated with this JPanel.

getAccessibleContext() - Method in class javax.swing.JPasswordField

Returns the AccessibleContext associated with this JPasswordField.

getAccessibleContext() - Method in class javax.swing.JPopupMenu

Gets the AccessibleContext associated with this JPopupMenu.

getAccessibleContext() - Method in class javax.swing.JProgressBar

Gets the AccessibleContext associated with this JProgressBar.

getAccessibleContext() - Method in class javax.swing.JRadioButton

Gets the AccessibleContext associated with this JRadioButton.

getAccessibleContext() - Method in class javax.swing.JRadioButtonMenuItem

Gets the AccessibleContext associated with this JRadioButtonMenuItem.

getAccessibleContext() - Method in class javax.swing.JRootPane

Gets the AccessibleContext associated with this JRootPane.

getAccessibleContext() - Method in class javax.swing.JScrollBar

Gets the AccessibleContext associated with this JScrollBar.

getAccessibleContext() - Method in class javax.swing.JScrollPane

Gets the AccessibleContext associated with this JScrollPane.

getAccessibleContext() - Method in class javax.swing.JSeparator

Gets the AccessibleContext associated with this JSeparator.

getAccessibleContext() - Method in class javax.swing.JSlider

Gets the AccessibleContext associated with this JSlider.

getAccessibleContext() - Method in class javax.swing.JSpinner

Gets the AccessibleContext for the JSpinner

getAccessibleContext() - Method in class javax.swing.JSplitPane

Gets the AccessibleContext associated with this JSplitPane.

getAccessibleContext() - Method in class javax.swing.JTabbedPane

Gets the AccessibleContext associated with this JTabbedPane.

getAccessibleContext() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the AccessibleContext associated with this component.

getAccessibleContext() - Method in class javax.swing.JTable

Gets the AccessibleContext associated with this JTable.

getAccessibleContext() - Method in class javax.swing.JTextArea

Gets the AccessibleContext associated with this JTextArea.

getAccessibleContext() - Method in class javax.swing.JTextField

Gets the AccessibleContext associated with this JTextField.

getAccessibleContext() - Method in class javax.swing.JToggleButton

Gets the AccessibleContext associated with this JToggleButton.

getAccessibleContext() - Method in class javax.swing.JToolBar

Gets the AccessibleContext associated with this JToolBar.

getAccessibleContext() - Method in class javax.swing.JToolTip

Gets the AccessibleContext associated with this JToolTip.

getAccessibleContext() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Get the AccessibleContext associated with this tree node.

getAccessibleContext() - Method in class javax.swing.JTree

Gets the AccessibleContext associated with this JTree.

getAccessibleContext() - Method in class javax.swing.JViewport

Gets the AccessibleContext associated with this JViewport.

getAccessibleContext() - Method in class javax.swing.JWindow

Gets the AccessibleContext associated with this JWindow.

getAccessibleContext() - Method in class javax.swing.plaf.basic.BasicComboPopup

Gets the AccessibleContext associated with this BasicComboPopup.

getAccessibleContext() - Method in class javax.swing.ProgressMonitor

Gets the AccessibleContext for the ProgressMonitor

getAccessibleContext() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

Get the AccessibleContext associated with this object.

getAccessibleContext() - Method in class javax.swing.table.JTableHeader

Gets the AccessibleContext associated with this JTableHeader.

getAccessibleContext() - Method in class javax.swing.text.html.HTMLEditorKit

returns the AccessibleContext associated with this editor kit

getAccessibleContext() - Method in class javax.swing.text.JTextComponent

Gets the AccessibleContext associated with this JTextComponent.

getAccessibleDescription() - Method in class java.awt.Component.AccessibleAWTComponent

Gets the accessible description of this object.

getAccessibleDescription() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Gets the accessible description of this object.

getAccessibleDescription() - Method in class javax.accessibility.AccessibleContext

Gets the accessibleDescription property of this object.

getAccessibleDescription() - Method in class javax.swing.JComponent.AccessibleJComponent

Gets the accessible description of this object.

getAccessibleDescription() - Method in class javax.swing.JEditorPane.AccessibleJEditorPane

Gets the accessibleDescription property of this object.

getAccessibleDescription() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getAccessibleDescription() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the accessible description of this object.

getAccessibleDescription() - Method in class javax.swing.JToolTip.AccessibleJToolTip

Get the accessible description of this object.

getAccessibleDescription() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Get the accessible description of this object.

getAccessibleDescription() - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Gets the accessibleDescription property of this object.

getAccessibleDescription() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getAccessibleEditableText() - Method in class javax.accessibility.AccessibleContext

Gets the AccessibleEditableText associated with this object presenting editable text on the display.

getAccessibleEditableText() - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Returns the AccessibleEditableText interface for this text component.

getAccessibleIcon() - Method in class javax.accessibility.AccessibleContext

Gets the AccessibleIcons associated with an object that has one or more associated icons

getAccessibleIcon() - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Get the AccessibleIcons associated with this object if one or more exist.

getAccessibleIcon() - Method in class javax.swing.JLabel.AccessibleJLabel

Get the AccessibleIcons associated with this object if one or more exist.

getAccessibleIcon() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

Returns the icon for the element renderer, as the only item of an array of AccessibleIcons or a null array if the renderer component contains no icons.

getAccessibleIconDescription() - Method in interface javax.accessibility.AccessibleIcon

Gets the description of the icon.

getAccessibleIconDescription() - Method in class javax.swing.ImageIcon.AccessibleImageIcon

Gets the description of the icon.

getAccessibleIconHeight() - Method in interface javax.accessibility.AccessibleIcon

Gets the height of the icon

getAccessibleIconHeight() - Method in class javax.swing.ImageIcon.AccessibleImageIcon

Gets the height of the icon.

getAccessibleIconWidth() - Method in interface javax.accessibility.AccessibleIcon

Gets the width of the icon

getAccessibleIconWidth() - Method in class javax.swing.ImageIcon.AccessibleImageIcon

Gets the width of the icon.

getAccessibleIndex(int, int) - Method in interface javax.accessibility.AccessibleExtendedTable

Returns the index at a row and column in the table.

getAccessibleIndex(int, int) - Method in class javax.swing.JTable.AccessibleJTable

Returns the index at a row and column in the table.

getAccessibleIndexAt(int, int) - Method in class javax.swing.JTable.AccessibleJTable

Returns the index at a given (row, column) in the table.

getAccessibleIndexInParent() - Method in class java.awt.Component.AccessibleAWTComponent

Gets the index of this object in its accessible parent.

getAccessibleIndexInParent() - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Get the 0-based index of this object in its accessible parent.

getAccessibleIndexInParent() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Gets the index of this object in its accessible parent.

getAccessibleIndexInParent() - Method in class javax.accessibility.AccessibleContext

Gets the 0-based index of this object in its accessible parent.

getAccessibleIndexInParent() - Method in class javax.swing.ImageIcon.AccessibleImageIcon

Gets the index of this object in its accessible parent.

getAccessibleIndexInParent() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getAccessibleIndexInParent() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the index of this object in its accessible parent.

getAccessibleIndexInParent() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Get the index of this object in its accessible parent.

getAccessibleIndexInParent() - Method in class javax.swing.JTree.AccessibleJTree

Get the index of this object in its accessible parent.

getAccessibleIndexInParent() - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Gets the 0-based index of this object in its accessible parent.

getAccessibleIndexInParent(Component) - Static method in class javax.swing.SwingUtilities

Get the index of this object in its accessible parent.

getAccessibleIndexInParent() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getAccessibleKeyBinding() - Method in interface javax.accessibility.AccessibleExtendedComponent

Returns key bindings associated with this object

getAccessibleKeyBinding(int) - Method in interface javax.accessibility.AccessibleKeyBinding

Returns a key binding for this object.

getAccessibleKeyBinding() - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Returns key bindings associated with this object

getAccessibleKeyBinding() - Method in class javax.swing.JComponent.AccessibleJComponent

Returns key bindings associated with this object

getAccessibleKeyBinding() - Method in class javax.swing.JLabel.AccessibleJLabel

Returns key bindings associated with this object

getAccessibleKeyBindingCount() - Method in interface javax.accessibility.AccessibleKeyBinding

Returns the number of key bindings for this object

getAccessibleName() - Method in class java.awt.Button.AccessibleAWTButton

Get the accessible name of this object.

getAccessibleName() - Method in class java.awt.Component.AccessibleAWTComponent

Gets the accessible name of this object.

getAccessibleName() - Method in class java.awt.Label.AccessibleAWTLabel

Get the accessible name of this object.

getAccessibleName() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Gets the accessible name of this object.

getAccessibleName() - Method in class java.awt.MenuItem.AccessibleAWTMenuItem

Get the accessible name of this object.

getAccessibleName() - Method in class javax.accessibility.AccessibleContext

Gets the accessibleName property of this object.

getAccessibleName() - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Returns the accessible name of this object.

getAccessibleName() - Method in class javax.swing.JComponent.AccessibleJComponent

Gets the accessible name of this object.

getAccessibleName() - Method in class javax.swing.JDialog.AccessibleJDialog

Get the accessible name of this object.

getAccessibleName() - Method in class javax.swing.JFrame.AccessibleJFrame

Get the accessible name of this object.

getAccessibleName() - Method in class javax.swing.JInternalFrame.AccessibleJInternalFrame

Get the accessible name of this object.

getAccessibleName() - Method in class javax.swing.JLabel.AccessibleJLabel

Get the accessible name of this object.

getAccessibleName() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getAccessibleName() - Method in class javax.swing.JTabbedPane.AccessibleJTabbedPane

Returns the accessible name of this object, or null if there is no accessible name.

getAccessibleName() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the accessible name of this object.

getAccessibleName() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Get the accessible name of this object.

getAccessibleName() - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Gets the accessibleName property of this object.

getAccessibleName() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getAccessibleParent() - Method in class java.awt.Component.AccessibleAWTComponent

Gets the Accessible parent of this object.

getAccessibleParent() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Gets the Accessible parent of this object.

getAccessibleParent() - Method in class javax.accessibility.AccessibleContext

Gets the Accessible parent of this object.

getAccessibleParent() - Method in class javax.swing.ImageIcon.AccessibleImageIcon

Gets the Accessible parent of this object.

getAccessibleParent() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the Accessible parent of this object.

getAccessibleParent() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Get the Accessible parent of this object.

getAccessibleParent() - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Gets the Accessible parent of this object.

getAccessibleRelationSet() - Method in class javax.accessibility.AccessibleContext

Gets the AccessibleRelationSet associated with an object

getAccessibleRelationSet() - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Get the AccessibleRelationSet associated with this object if one exists.

getAccessibleRelationSet() - Method in class javax.swing.JLabel.AccessibleJLabel

Get the AccessibleRelationSet associated with this object if one exists.

getAccessibleRole() - Method in class java.applet.Applet.AccessibleApplet

Get the role of this object.

getAccessibleRole() - Method in class java.awt.Button.AccessibleAWTButton

Get the role of this object.

getAccessibleRole() - Method in class java.awt.Canvas.AccessibleAWTCanvas

Get the role of this object.

getAccessibleRole() - Method in class java.awt.Checkbox.AccessibleAWTCheckbox

Get the role of this object.

getAccessibleRole() - Method in class java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem

Get the role of this object.

getAccessibleRole() - Method in class java.awt.Choice.AccessibleAWTChoice

Get the role of this object.

getAccessibleRole() - Method in class java.awt.Component.AccessibleAWTComponent

Gets the role of this object.

getAccessibleRole() - Method in class java.awt.Dialog.AccessibleAWTDialog

Get the role of this object.

getAccessibleRole() - Method in class java.awt.Frame.AccessibleAWTFrame

Get the role of this object.

getAccessibleRole() - Method in class java.awt.Label.AccessibleAWTLabel

Get the role of this object.

getAccessibleRole() - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Get the role of this object.

getAccessibleRole() - Method in class java.awt.List.AccessibleAWTList

Get the role of this object.

getAccessibleRole() - Method in class java.awt.Menu.AccessibleAWTMenu

Get the role of this object.

getAccessibleRole() - Method in class java.awt.MenuBar.AccessibleAWTMenuBar

Get the role of this object.

getAccessibleRole() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Gets the role of this object.

getAccessibleRole() - Method in class java.awt.MenuItem.AccessibleAWTMenuItem

Get the role of this object.

getAccessibleRole() - Method in class java.awt.Panel.AccessibleAWTPanel

Get the role of this object.

getAccessibleRole() - Method in class java.awt.PopupMenu.AccessibleAWTPopupMenu

Get the role of this object.

getAccessibleRole() - Method in class java.awt.Scrollbar.AccessibleAWTScrollBar

Get the role of this object.

getAccessibleRole() - Method in class java.awt.ScrollPane.AccessibleAWTScrollPane

Get the role of this object.

getAccessibleRole() - Method in class java.awt.TextComponent.AccessibleAWTTextComponent

Gets the role of this object.

getAccessibleRole() - Method in class java.awt.Window.AccessibleAWTWindow

Get the role of this object.

getAccessibleRole() - Method in class javax.accessibility.AccessibleContext

Gets the role of this object.

getAccessibleRole() - Method in class javax.swing.Box.AccessibleBox

Gets the role of this object.

getAccessibleRole() - Method in class javax.swing.Box.Filler.AccessibleBoxFiller

Gets the role of this object.

getAccessibleRole() - Method in class javax.swing.CellRendererPane.AccessibleCellRendererPane

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.ImageIcon.AccessibleImageIcon

Gets the role of this object.

getAccessibleRole() - Method in class javax.swing.JButton.AccessibleJButton

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JCheckBox.AccessibleJCheckBox

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JColorChooser.AccessibleJColorChooser

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JComboBox.AccessibleJComboBox

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JComponent.AccessibleJComponent

Gets the role of this object.

getAccessibleRole() - Method in class javax.swing.JDesktopPane.AccessibleJDesktopPane

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JFileChooser.AccessibleJFileChooser

Gets the role of this object.

getAccessibleRole() - Method in class javax.swing.JInternalFrame.AccessibleJInternalFrame

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon

Gets the role of this object.

getAccessibleRole() - Method in class javax.swing.JLabel.AccessibleJLabel

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JLayeredPane.AccessibleJLayeredPane

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getAccessibleRole() - Method in class javax.swing.JList.AccessibleJList

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JMenu.AccessibleJMenu

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JMenuBar.AccessibleJMenuBar

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JMenuItem.AccessibleJMenuItem

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JOptionPane.AccessibleJOptionPane

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JPanel.AccessibleJPanel

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JPasswordField.AccessibleJPasswordField

Gets the role of this object.

getAccessibleRole() - Method in class javax.swing.JPopupMenu.AccessibleJPopupMenu

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JProgressBar.AccessibleJProgressBar

Gets the role of this object.

getAccessibleRole() - Method in class javax.swing.JRadioButton.AccessibleJRadioButton

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JRootPane.AccessibleJRootPane

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JScrollBar.AccessibleJScrollBar

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JScrollPane.AccessibleJScrollPane

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JSeparator.AccessibleJSeparator

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JSlider.AccessibleJSlider

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JSpinner.AccessibleJSpinner

Gets the role of this object.

getAccessibleRole() - Method in class javax.swing.JSplitPane.AccessibleJSplitPane

Gets the role of this object.

getAccessibleRole() - Method in class javax.swing.JTabbedPane.AccessibleJTabbedPane

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the role of this object.

getAccessibleRole() - Method in class javax.swing.JTable.AccessibleJTable

Gets the role of this object.

getAccessibleRole() - Method in class javax.swing.JToggleButton.AccessibleJToggleButton

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JToolBar.AccessibleJToolBar

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JToolTip.AccessibleJToolTip

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JTree.AccessibleJTree

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.JViewport.AccessibleJViewport

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Gets the role of this object.

getAccessibleRole() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getAccessibleRole() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader

Get the role of this object.

getAccessibleRole() - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Gets the role of this object.

getAccessibleRow(int) - Method in interface javax.accessibility.AccessibleExtendedTable

Returns the row number of an index in the table.

getAccessibleRow(int) - Method in class javax.swing.JTable.AccessibleJTable

Returns the row number of an index in the table.

getAccessibleRowAtIndex(int) - Method in class javax.swing.JTable.AccessibleJTable

Returns the row at a given index into the table.

getAccessibleRowCount() - Method in interface javax.accessibility.AccessibleTable

Returns the number of rows in the table.

getAccessibleRowCount() - Method in class javax.swing.JTable.AccessibleJTable

getAccessibleRowDescription(int) - Method in interface javax.accessibility.AccessibleTable

Returns the description of the specified row in the table.

getAccessibleRowDescription(int) - Method in class javax.swing.JTable.AccessibleJTable

Returns the description of the specified row in the table.

getAccessibleRowExtentAt(int, int) - Method in interface javax.accessibility.AccessibleTable

Returns the number of rows occupied by the Accessible at a specified row and column in the table.

getAccessibleRowExtentAt(int, int) - Method in class javax.swing.JTable.AccessibleJTable

Returns the number of rows occupied by the Accessible at a specified row and column in the table.

getAccessibleRowHeader() - Method in interface javax.accessibility.AccessibleTable

Returns the row headers as an AccessibleTable.

getAccessibleRowHeader() - Method in class javax.swing.JTable.AccessibleJTable

Returns the row headers as an AccessibleTable.

getAccessibleSelection() - Method in class java.awt.List.AccessibleAWTList

Get the AccessibleSelection associated with this object.

getAccessibleSelection(int) - Method in class java.awt.List.AccessibleAWTList

Returns an Accessible representing the specified selected item in the object.

getAccessibleSelection() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Gets the AccessibleSelection associated with this object which allows its Accessible children to be selected.

getAccessibleSelection(int) - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Returns an Accessible representing the specified selected child in the object.

getAccessibleSelection() - Method in class javax.accessibility.AccessibleContext

Gets the AccessibleSelection associated with this object which allows its Accessible children to be selected.

getAccessibleSelection(int) - Method in interface javax.accessibility.AccessibleSelection

Returns an Accessible representing the specified selected child of the object.

getAccessibleSelection() - Method in class javax.swing.JComboBox.AccessibleJComboBox

Get the AccessibleSelection associated with this object.

getAccessibleSelection(int) - Method in class javax.swing.JComboBox.AccessibleJComboBox

Returns an Accessible representing the specified selected child in the popup.

getAccessibleSelection() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getAccessibleSelection() - Method in class javax.swing.JList.AccessibleJList

Get the AccessibleSelection associated with this object.

getAccessibleSelection(int) - Method in class javax.swing.JList.AccessibleJList

Returns an Accessible representing the specified selected item in the object.

getAccessibleSelection() - Method in class javax.swing.JMenu.AccessibleJMenu

Get the AccessibleSelection associated with this object.

getAccessibleSelection(int) - Method in class javax.swing.JMenu.AccessibleJMenu

Returns the currently selected sub-menu if one is selected, otherwise null (there can only be one selection, and it can only be a sub-menu, as otherwise menu items don't remain selected).

getAccessibleSelection() - Method in class javax.swing.JMenuBar.AccessibleJMenuBar

Get the AccessibleSelection associated with this object.

getAccessibleSelection(int) - Method in class javax.swing.JMenuBar.AccessibleJMenuBar

Returns the currently selected menu if one is selected, otherwise null.

getAccessibleSelection() - Method in class javax.swing.JTabbedPane.AccessibleJTabbedPane

Gets the AccessibleSelection associated with this object.

getAccessibleSelection(int) - Method in class javax.swing.JTabbedPane.AccessibleJTabbedPane

getAccessibleSelection() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the AccessibleSelection associated with this object if one exists.

getAccessibleSelection() - Method in class javax.swing.JTable.AccessibleJTable

Get the AccessibleSelection associated with this object.

getAccessibleSelection(int) - Method in class javax.swing.JTable.AccessibleJTable

Returns an Accessible representing the specified selected child in the object.

getAccessibleSelection() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Get the AccessibleSelection associated with this object if one exists.

getAccessibleSelection(int) - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Returns an Accessible representing the specified selected item in the object.

getAccessibleSelection() - Method in class javax.swing.JTree.AccessibleJTree

Get the AccessibleSelection associated with this object.

getAccessibleSelection(int) - Method in class javax.swing.JTree.AccessibleJTree

Returns an Accessible representing the specified selected item in the object.

getAccessibleSelection() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getAccessibleSelectionCount() - Method in class java.awt.List.AccessibleAWTList

Returns the number of items currently selected.

getAccessibleSelectionCount() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Returns the number of Accessible children currently selected.

getAccessibleSelectionCount() - Method in interface javax.accessibility.AccessibleSelection

Returns the number of Accessible children currently selected.

getAccessibleSelectionCount() - Method in class javax.swing.JComboBox.AccessibleJComboBox

Returns the number of Accessible children currently selected.

getAccessibleSelectionCount() - Method in class javax.swing.JList.AccessibleJList

Returns the number of items currently selected.

getAccessibleSelectionCount() - Method in class javax.swing.JMenu.AccessibleJMenu

Returns 1 if a sub-menu is currently selected in this menu.

getAccessibleSelectionCount() - Method in class javax.swing.JMenuBar.AccessibleJMenuBar

Returns 1 if a menu is currently selected in this menu bar.

getAccessibleSelectionCount() - Method in class javax.swing.JTabbedPane.AccessibleJTabbedPane

getAccessibleSelectionCount() - Method in class javax.swing.JTable.AccessibleJTable

Returns the number of Accessible children currently selected.

getAccessibleSelectionCount() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Returns the number of items currently selected.

getAccessibleSelectionCount() - Method in class javax.swing.JTree.AccessibleJTree

Returns the number of items currently selected.

getAccessibleStateSet() - Method in class java.applet.Applet.AccessibleApplet

Get the state of this object.

getAccessibleStateSet() - Method in class java.awt.Checkbox.AccessibleAWTCheckbox

Get the state set of this object.

getAccessibleStateSet() - Method in class java.awt.Component.AccessibleAWTComponent

Gets the state of this object.

getAccessibleStateSet() - Method in class java.awt.Dialog.AccessibleAWTDialog

Get the state of this object.

getAccessibleStateSet() - Method in class java.awt.Frame.AccessibleAWTFrame

Get the state of this object.

getAccessibleStateSet() - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Get the state set of this object.

getAccessibleStateSet() - Method in class java.awt.List.AccessibleAWTList

Get the state set of this object.

getAccessibleStateSet() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Gets the state of this object.

getAccessibleStateSet() - Method in class java.awt.Scrollbar.AccessibleAWTScrollBar

Get the state set of this object.

getAccessibleStateSet() - Method in class java.awt.TextArea.AccessibleAWTTextArea

Gets the state set of this object.

getAccessibleStateSet() - Method in class java.awt.TextComponent.AccessibleAWTTextComponent

Gets the state set of the TextComponent.

getAccessibleStateSet() - Method in class java.awt.TextField.AccessibleAWTTextField

Gets the state set of this object.

getAccessibleStateSet() - Method in class java.awt.Window.AccessibleAWTWindow

Get the state of this object.

getAccessibleStateSet() - Method in class javax.accessibility.AccessibleContext

Gets the state set of this object.

getAccessibleStateSet() - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Get the state set of this object.

getAccessibleStateSet() - Method in class javax.swing.ImageIcon.AccessibleImageIcon

Gets the state of this object.

getAccessibleStateSet() - Method in class javax.swing.JComboBox.AccessibleJComboBox

Gets the state set of this object.

getAccessibleStateSet() - Method in class javax.swing.JComponent.AccessibleJComponent

Gets the state of this object.

getAccessibleStateSet() - Method in class javax.swing.JDialog.AccessibleJDialog

Get the state of this object.

getAccessibleStateSet() - Method in class javax.swing.JEditorPane.AccessibleJEditorPane

Gets the state set of this object.

getAccessibleStateSet() - Method in class javax.swing.JFrame.AccessibleJFrame

Get the state of this object.

getAccessibleStateSet() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getAccessibleStateSet() - Method in class javax.swing.JList.AccessibleJList

Get the state set of this object.

getAccessibleStateSet() - Method in class javax.swing.JMenuBar.AccessibleJMenuBar

Get the accessible state set of this object.

getAccessibleStateSet() - Method in class javax.swing.JProgressBar.AccessibleJProgressBar

Gets the state set of this object.

getAccessibleStateSet() - Method in class javax.swing.JScrollBar.AccessibleJScrollBar

Get the state set of this object.

getAccessibleStateSet() - Method in class javax.swing.JSlider.AccessibleJSlider

Get the state set of this object.

getAccessibleStateSet() - Method in class javax.swing.JSplitPane.AccessibleJSplitPane

Gets the state set of this object.

getAccessibleStateSet() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the state set of this object.

getAccessibleStateSet() - Method in class javax.swing.JTextArea.AccessibleJTextArea

Gets the state set of this object.

getAccessibleStateSet() - Method in class javax.swing.JTextField.AccessibleJTextField

Gets the state set of this object.

getAccessibleStateSet() - Method in class javax.swing.JToolBar.AccessibleJToolBar

Get the state of this object.

getAccessibleStateSet() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Get the state set of this object.

getAccessibleStateSet() - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Gets the state set of this object.

getAccessibleStateSet(Component) - Static method in class javax.swing.SwingUtilities

Get the state of this object.

getAccessibleStateSet() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getAccessibleStateSet() - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Gets the state set of the JTextComponent.

getAccessibleSummary() - Method in interface javax.accessibility.AccessibleTable

Returns the summary description of the table.

getAccessibleSummary() - Method in class javax.swing.JTable.AccessibleJTable

Returns the summary description of the table.

getAccessibleTable() - Method in class javax.accessibility.AccessibleContext

Gets the AccessibleTable associated with an object

getAccessibleTable() - Method in class javax.swing.JTable.AccessibleJTable

Gets the AccessibleTable associated with this object.

getAccessibleText() - Method in class java.awt.TextComponent.AccessibleAWTTextComponent

Get the AccessibleText associated with this object.

getAccessibleText() - Method in class javax.accessibility.AccessibleContext

Gets the AccessibleText associated with this object presenting text on the display.

getAccessibleText() - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

getAccessibleText() - Method in class javax.swing.JEditorPane.AccessibleJEditorPaneHTML

getAccessibleText() - Method in class javax.swing.JLabel.AccessibleJLabel

getAccessibleText() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getAccessibleText() - Method in class javax.swing.JPasswordField.AccessibleJPasswordField

Gets the AccessibleText for the JPasswordField.

getAccessibleText() - Method in class javax.swing.JSpinner.AccessibleJSpinner

Gets the AccessibleText associated with this object presenting text on the display.

getAccessibleText() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the AccessibleText associated with this object if one exists.

getAccessibleText() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Get the AccessibleText associated with this object if one exists.

getAccessibleText() - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Gets the AccessibleText associated with this object presenting text on the display.

getAccessibleText() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getAccessibleText() - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Get the AccessibleText associated with this object.

getAccessibleValue() - Method in class java.awt.Button.AccessibleAWTButton

Get the AccessibleValue associated with this object.

getAccessibleValue() - Method in class java.awt.Checkbox.AccessibleAWTCheckbox

Get the AccessibleValue associated with this object.

getAccessibleValue() - Method in class java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem

Get the AccessibleValue associated with this object.

getAccessibleValue() - Method in class java.awt.MenuItem.AccessibleAWTMenuItem

Get the AccessibleValue associated with this object.

getAccessibleValue() - Method in class java.awt.Scrollbar.AccessibleAWTScrollBar

Get the AccessibleValue associated with this object.

getAccessibleValue() - Method in class javax.accessibility.AccessibleContext

Gets the AccessibleValue associated with this object that supports a Numerical value.

getAccessibleValue() - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Get the AccessibleValue associated with this object.

getAccessibleValue() - Method in class javax.swing.JInternalFrame.AccessibleJInternalFrame

Gets the AccessibleValue associated with this object.

getAccessibleValue() - Method in class javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon

Gets the AccessibleValue associated with this object.

getAccessibleValue() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getAccessibleValue() - Method in class javax.swing.JProgressBar.AccessibleJProgressBar

Gets the AccessibleValue associated with this object.

getAccessibleValue() - Method in class javax.swing.JScrollBar.AccessibleJScrollBar

Get the AccessibleValue associated with this object.

getAccessibleValue() - Method in class javax.swing.JSlider.AccessibleJSlider

Get the AccessibleValue associated with this object.

getAccessibleValue() - Method in class javax.swing.JSpinner.AccessibleJSpinner

Gets the AccessibleValue associated with this object.

getAccessibleValue() - Method in class javax.swing.JSplitPane.AccessibleJSplitPane

Get the AccessibleValue associated with this object.

getAccessibleValue() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the AccessibleValue associated with this object if one exists.

getAccessibleValue() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Get the AccessibleValue associated with this object if one exists.

getAccessibleValue() - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Gets the AccessibleValue associated with this object that supports a Numerical value.

getAccessibleValue() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getAccessLevel() - Method in class javax.tools.ForwardingJavaFileObject

getAccessLevel() - Method in interface javax.tools.JavaFileObject

Provides a hint about the access level of the class represented by this file object.

getAccessLevel() - Method in class javax.tools.SimpleJavaFileObject

This implementation returns null.

getAccessory() - Method in class javax.swing.JFileChooser

Returns the accessory component.

getAccessoryPanel() - Method in class javax.swing.plaf.basic.BasicFileChooserUI

getACHuffmanTables() - Method in class javax.imageio.plugins.jpeg.JPEGImageReadParam

Returns a copy of the array of AC Huffman tables set on the most recent call to setDecodeTables, or null if tables are not currently set.

getACHuffmanTables() - Method in class javax.imageio.plugins.jpeg.JPEGImageWriteParam

Returns a copy of the array of AC Huffman tables set on the most recent call to setEncodeTables, or null if tables are not currently set.

getAcl() - Method in interface java.nio.file.attribute.AclFileAttributeView

Reads the access control list.

getAction() - Method in class java.beans.EventHandler

Returns the name of the target's writable property that this event handler will set, or the name of the method that this event handler will invoke on the target.

getAction() - Method in class javax.swing.AbstractButton

Returns the currently set Action for this ActionEvent source, or null if no Action is set.

getAction() - Method in class javax.swing.JComboBox

Returns the currently set Action for this ActionEvent source, or null if no Action is set.

getAction() - Method in class javax.swing.JTextField

Returns the currently set Action for this ActionEvent source, or null if no Action is set.

getAction(KeyStroke) - Method in interface javax.swing.text.Keymap

Fetches the action appropriate for the given symbolic event sequence.

getActionCommand() - Method in class java.awt.Button

Returns the command name of the action event fired by this button.

getActionCommand() - Method in class java.awt.event.ActionEvent

Returns the command string associated with this action.

getActionCommand() - Method in class java.awt.MenuItem

Gets the command name of the action event that is fired by this menu item.

getActionCommand() - Method in class java.awt.TrayIcon

Returns the command name of the action event fired by this tray icon.

getActionCommand() - Method in class javax.swing.AbstractButton

Returns the action command for this button.

getActionCommand() - Method in interface javax.swing.ButtonModel

Returns the action command string for the button.

getActionCommand() - Method in class javax.swing.DefaultButtonModel

Returns the action command string for the button.

getActionCommand() - Method in class javax.swing.JComboBox

Returns the action command that is included in the event sent to action listeners.

getActionCommand() - Method in class javax.swing.Timer

Returns the string that will be delivered as the action command in ActionEvents fired by this timer.

getActionForKeyStroke(KeyStroke) - Method in class javax.swing.JComponent

Returns the object that will perform the action registered for a given keystroke.

getActionListeners() - Method in class java.awt.Button

Returns an array of all the action listeners registered on this button.

getActionListeners() - Method in class java.awt.List

Returns an array of all the action listeners registered on this list.

getActionListeners() - Method in class java.awt.MenuItem

Returns an array of all the action listeners registered on this menu item.

getActionListeners() - Method in class java.awt.TextField

Returns an array of all the action listeners registered on this textfield.

getActionListeners() - Method in class java.awt.TrayIcon

Returns an array of all the action listeners registered on this TrayIcon.

getActionListeners() - Method in class javax.swing.AbstractButton

Returns an array of all the ActionListeners added to this AbstractButton with addActionListener().

getActionListeners() - Method in class javax.swing.DefaultButtonModel

Returns an array of all the action listeners registered on this DefaultButtonModel.

getActionListeners() - Method in class javax.swing.JComboBox

Returns an array of all the ActionListeners added to this JComboBox with addActionListener().

getActionListeners() - Method in class javax.swing.JFileChooser

Returns an array of all the action listeners registered on this file chooser.

getActionListeners() - Method in class javax.swing.JTextField

Returns an array of all the ActionListeners added to this JTextField with addActionListener().

getActionListeners() - Method in class javax.swing.Timer

Returns an array of all the action listeners registered on this timer.

getActionMap() - Method in class javax.swing.JComponent

Returns the ActionMap used to determine what Action to fire for particular KeyStroke binding.

getActionMap() - Method in class javax.swing.plaf.metal.MetalFileChooserUI

getActions() - Method in class java.io.FilePermission

Returns the "canonical string representation" of the actions.

getActions() - Method in class java.net.SocketPermission

Returns the canonical string representation of the actions.

getActions() - Method in class java.net.URLPermission

Returns the normalized method list and request header list, in the form:

getActions() - Method in class java.security.AllPermission

Returns the canonical string representation of the actions.

getActions() - Method in class java.security.BasicPermission

Returns the canonical string representation of the actions, which currently is the empty string "", since there are no actions for a BasicPermission.

getActions() - Method in class java.security.Permission

Returns the actions as a String.

getActions() - Method in class java.security.UnresolvedPermission

Returns the canonical string representation of the actions, which currently is the empty string "", since there are no actions for an UnresolvedPermission.

getActions() - Method in class java.util.PropertyPermission

Returns the "canonical string representation" of the actions.

getActions() - Method in class javax.management.MBeanPermission

Returns the "canonical string representation" of the actions.

getActions() - Method in class javax.security.auth.kerberos.ServicePermission

Returns the canonical string representation of the actions.

getActions() - Method in class javax.security.auth.PrivateCredentialPermission

Returns the "canonical string representation" of the actions.

getActions() - Method in class javax.swing.JFormattedTextField.AbstractFormatter

Subclass and override if you wish to provide a custom set of Actions.

getActions() - Method in class javax.swing.JFormattedTextField

Fetches the command list for the editor.

getActions() - Method in class javax.swing.JTextField

Fetches the command list for the editor.

getActions() - Method in class javax.swing.text.DefaultEditorKit

Fetches the set of commands that can be used on a text component that is using a model and view produced by this kit.

getActions() - Method in class javax.swing.text.EditorKit

Fetches the set of commands that can be used on a text component that is using a model and view produced by this kit.

getActions() - Method in class javax.swing.text.html.HTMLEditorKit

Fetches the command list for the editor.

getActions() - Method in class javax.swing.text.InternationalFormatter

If getSupportsIncrement returns true, this returns two Actions suitable for incrementing/decrementing the value.

getActions() - Method in class javax.swing.text.JTextComponent

Fetches the command list for the editor.

getActions() - Method in class javax.swing.text.StyledEditorKit

Fetches the command list for the editor.

getActivationDesc(ActivationID) - Method in interface java.rmi.activation.ActivationSystem

Returns the activation descriptor, for the object with the activation identifier, id.

getActivationGroupDesc(ActivationGroupID) - Method in interface java.rmi.activation.ActivationSystem

Returns the activation group descriptor, for the group with the activation group identifier, id.

getActiveCount() - Method in class java.util.concurrent.ThreadPoolExecutor

Returns the approximate number of threads that are actively executing tasks.

getActiveThreadCount() - Method in class java.util.concurrent.ForkJoinPool

Returns an estimate of the number of threads that are currently stealing or executing tasks.

getActiveWindow() - Method in class java.awt.KeyboardFocusManager

Returns the active Window, if the active Window is in the same context as the calling thread.

getActor() - Method in interface javax.xml.soap.SOAPHeaderElement

Returns the uri of the actor attribute of this SOAPHeaderElement.

getActualMaximum(int) - Method in class java.util.Calendar

Returns the maximum value that the specified calendar field could have, given the time value of this Calendar.

getActualMaximum(int) - Method in class java.util.GregorianCalendar

Returns the maximum value that this calendar field could have, taking into consideration the given time value and the current values of the getFirstDayOfWeek, getMinimalDaysInFirstWeek, getGregorianChange and getTimeZone methods.

getActualMinimum(int) - Method in class java.util.Calendar

Returns the minimum value that the specified calendar field could have, given the time value of this Calendar.

getActualMinimum(int) - Method in class java.util.GregorianCalendar

Returns the minimum value that this calendar field could have, taking into consideration the given time value and the current values of the getFirstDayOfWeek, getMinimalDaysInFirstWeek, getGregorianChange and getTimeZone methods.

getActualTypeArguments() - Method in interface java.lang.reflect.ParameterizedType

Returns an array of Type objects representing the actual type arguments to this type.

getAdapter(Class<A>) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

getAdapter(Class<A>) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

getAdapter(Class<A>) - Method in interface javax.xml.bind.Marshaller

Gets the adapter associated with the specified type.

getAdapter(Class<A>) - Method in interface javax.xml.bind.Unmarshaller

Gets the adapter associated with the specified type.

getAdditionalBeanInfo() - Method in interface java.beans.BeanInfo

This method enables the current BeanInfo object to return an arbitrary collection of other BeanInfo objects that provide additional information about the current bean.

getAdditionalBeanInfo() - Method in class java.beans.SimpleBeanInfo

Claim there are no other relevant BeanInfo objects.

getAdditionalHeight() - Method in class javax.swing.plaf.metal.MetalIconFactory.FileIcon16

getAdditionalHeight() - Method in class javax.swing.plaf.metal.MetalIconFactory.FolderIcon16

getAdditionalHeight() - Method in class javax.swing.plaf.metal.MetalIconFactory.TreeFolderIcon

getAdditionalHeight() - Method in class javax.swing.plaf.metal.MetalIconFactory.TreeLeafIcon

getAddListenerMethod() - Method in class java.beans.EventSetDescriptor

Gets the method used to add event listeners.

getAddress() - Method in class java.net.DatagramPacket

Returns the IP address of the machine to which this datagram is being sent or from which the datagram was received.

getAddress() - Method in class java.net.Inet4Address

Returns the raw IP address of this InetAddress object.

getAddress() - Method in class java.net.Inet6Address

Returns the raw IP address of this InetAddress object.

getAddress() - Method in class java.net.InetAddress

Returns the raw IP address of this InetAddress object.

getAddress() - Method in class java.net.InetSocketAddress

Gets the InetAddress.

getAddress() - Method in class java.net.InterfaceAddress

Returns an InetAddress for this address.

getAddress() - Method in interface javax.management.remote.JMXAddressable

The address of this object.

getAddress() - Method in interface javax.management.remote.JMXConnectorServerMBean

The address of this connector server.

getAddress() - Method in class javax.management.remote.rmi.RMIConnector

The address of this connector.

getAddress() - Method in class javax.management.remote.rmi.RMIConnectorServer

getAdjustable() - Method in class java.awt.event.AdjustmentEvent

Returns the Adjustable object where this event originated.

getAdjustmentListeners() - Method in class java.awt.Scrollbar

Returns an array of all the adjustment listeners registered on this scrollbar.

getAdjustmentListeners() - Method in class java.awt.ScrollPaneAdjustable

Returns an array of all the adjustment listeners registered on this ScrollPaneAdjustable.

getAdjustmentListeners() - Method in class javax.swing.JScrollBar

Returns an array of all the AdjustmentListeners added to this JScrollBar with addAdjustmentListener().

getAdjustmentType() - Method in class java.awt.event.AdjustmentEvent

Returns the type of adjustment which caused the value changed event.

getAdler() - Method in class java.util.zip.Deflater

Returns the ADLER-32 value of the uncompressed data.

getAdler() - Method in class java.util.zip.Inflater

Returns the ADLER-32 value of the uncompressed data.

getAdvance() - Method in class java.awt.font.GlyphMetrics

Returns the advance of the glyph along the baseline (either horizontal or vertical).

getAdvance() - Method in class java.awt.font.GraphicAttribute

Returns the advance of this GraphicAttribute.

getAdvance() - Method in class java.awt.font.ImageGraphicAttribute

Returns the advance of this ImageGraphicAttribute.

getAdvance() - Method in class java.awt.font.ShapeGraphicAttribute

Returns the advance of this ShapeGraphicAttribute.

getAdvance() - Method in class java.awt.font.TextLayout

Returns the advance of this TextLayout.

getAdvanceBetween(int, int) - Method in class java.awt.font.TextMeasurer

Returns the graphical width of a line beginning at start and including characters up to limit.

getAdvanceX() - Method in class java.awt.font.GlyphMetrics

Returns the x-component of the advance of the glyph.

getAdvanceY() - Method in class java.awt.font.GlyphMetrics

Returns the y-component of the advance of the glyph.

getAffineX() - Method in class java.security.spec.ECPoint

Returns the affine x-coordinate x.

getAffineY() - Method in class java.security.spec.ECPoint

Returns the affine y-coordinate y.

getAfterIndex(int, int) - Method in class java.awt.TextComponent.AccessibleAWTTextComponent

Returns the String after a given index.

getAfterIndex(int, int) - Method in interface javax.accessibility.AccessibleText

Returns the String after a given index.

getAfterIndex(int, int) - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Returns the String after a given index.

getAfterIndex(int, int) - Method in class javax.swing.JLabel.AccessibleJLabel

Returns the String after a given index.

getAfterIndex(int, int) - Method in class javax.swing.JPasswordField.AccessibleJPasswordField

Returns the String after a given index.

getAfterIndex(int, int) - Method in class javax.swing.JSpinner.AccessibleJSpinner

Returns the String after a given index.

getAfterIndex(int, int) - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Returns the String after a given index.

getAfterIndex(int, int) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Returns the String after a given index.

getAlgName() - Method in class javax.crypto.EncryptedPrivateKeyInfo

Returns the encryption algorithm.

getAlgorithm() - Method in class java.security.AlgorithmParameterGenerator

Returns the standard name of the algorithm this parameter generator is associated with.

getAlgorithm() - Method in class java.security.AlgorithmParameters

Returns the name of the algorithm associated with this parameter object.

getAlgorithm() - Method in class java.security.cert.CertPathBuilder

Returns the name of the algorithm of this CertPathBuilder.

getAlgorithm() - Method in class java.security.cert.CertPathValidator

Returns the algorithm name of this CertPathValidator.

getAlgorithm() - Method in interface java.security.Key

Returns the standard algorithm name for this key.

getAlgorithm() - Method in class java.security.KeyFactory

Gets the name of the algorithm associated with this KeyFactory.

getAlgorithm() - Method in class java.security.KeyPairGenerator

Returns the standard name of the algorithm for this key pair generator.

getAlgorithm() - Method in class java.security.MessageDigest

Returns a string that identifies the algorithm, independent of implementation details.

getAlgorithm() - Method in class java.security.Provider.Service

Return the name of the algorithm of this service.

getAlgorithm() - Method in class java.security.SecureRandom

Returns the name of the algorithm implemented by this SecureRandom object.

getAlgorithm() - Method in class java.security.Signature

Returns the name of the algorithm for this signature object.

getAlgorithm() - Method in class java.security.SignedObject

Retrieves the name of the signature algorithm.

getAlgorithm() - Method in class javax.crypto.Cipher

Returns the algorithm name of this Cipher object.

getAlgorithm() - Method in class javax.crypto.KeyAgreement

Returns the algorithm name of this KeyAgreement object.

getAlgorithm() - Method in class javax.crypto.KeyGenerator

Returns the algorithm name of this KeyGenerator object.

getAlgorithm() - Method in class javax.crypto.Mac

Returns the algorithm name of this Mac object.

getAlgorithm() - Method in class javax.crypto.SealedObject

Returns the algorithm that was used to seal this object.

getAlgorithm() - Method in class javax.crypto.SecretKeyFactory

Returns the algorithm name of this SecretKeyFactory object.

getAlgorithm() - Method in class javax.crypto.spec.PSource

Returns the PSource algorithm name.

getAlgorithm() - Method in class javax.crypto.spec.SecretKeySpec

Returns the name of the algorithm associated with this secret key.

getAlgorithm() - Method in class javax.net.ssl.KeyManagerFactory

Returns the algorithm name of this KeyManagerFactory object.

getAlgorithm() - Method in class javax.net.ssl.TrustManagerFactory

Returns the algorithm name of this TrustManagerFactory object.

getAlgorithm() - Method in class javax.security.auth.kerberos.KerberosKey

Returns the standard algorithm name for this key.

getAlgorithm() - Method in interface javax.xml.crypto.AlgorithmMethod

Returns the algorithm URI of this AlgorithmMethod.

getAlgorithm() - Method in class javax.xml.crypto.dsig.TransformService

Returns the URI of the algorithm supported by this TransformService.

getAlgorithmConstraints() - Method in class javax.net.ssl.SSLParameters

Returns the cryptographic algorithm constraints.

getAlgorithmProperty(String, String) - Static method in class java.security.Security

Deprecated.
This method used to return the value of a proprietary property in the master file of the "SUN" Cryptographic Service Provider in order to determine how to parse algorithm-specific parameters. Use the new provider-based and algorithm-independent AlgorithmParameters and KeyFactory engine classes (introduced in the J2SE version 1.2 platform) instead.

getAlgorithms(String) - Static method in class java.security.Security

Returns a Set of Strings containing the names of all available algorithms or types for the specified Java cryptographic service (e.g., Signature, MessageDigest, Cipher, Mac, KeyStore).

getAlgParameters() - Method in class javax.crypto.EncryptedPrivateKeyInfo

Returns the algorithm parameters used by the encryption algorithm.

getAlias() - Method in class javax.security.auth.x500.X500PrivateCredential

Returns the KeyStore alias.

getAlignedSizeRequirements(SizeRequirements[]) - Static method in class javax.swing.SizeRequirements

Determines the total space necessary to align a set of components.

getAlignment() - Method in class java.awt.FlowLayout

Gets the alignment for this layout.

getAlignment() - Method in class java.awt.font.GraphicAttribute

Returns the alignment of this GraphicAttribute.

getAlignment() - Method in class java.awt.Label

Gets the current alignment of this label.

getAlignment(int) - Method in class javax.swing.text.BoxView

Determines the desired alignment for this view along an axis.

getAlignment(int) - Method in class javax.swing.text.ComponentView

Determines the desired alignment for this view along an axis.

getAlignment(int) - Method in class javax.swing.text.GlyphView

Determines the desired alignment for this view along an axis.

getAlignment(int) - Method in class javax.swing.text.html.BlockView

Gets the alignment.

getAlignment(int) - Method in class javax.swing.text.html.ImageView

Determines the desired alignment for this view along an axis.

getAlignment(int) - Method in class javax.swing.text.html.ListView

Calculates the desired shape of the list.

getAlignment(int) - Method in class javax.swing.text.IconView

Determines the desired alignment for this view along an axis.

getAlignment(int) - Method in class javax.swing.text.ParagraphView

Determines the desired alignment for this view along an axis.

getAlignment(AttributeSet) - Static method in class javax.swing.text.StyleConstants

Gets the alignment setting.

getAlignment() - Method in class javax.swing.text.TabStop

Returns the alignment, as an integer, of the tab.

getAlignment(int) - Method in class javax.swing.text.View

Determines the desired alignment for this view along an axis.

getAlignmentX() - Method in class java.awt.Component

Returns the alignment along the x axis.

getAlignmentX() - Method in class java.awt.Container

Returns the alignment along the x axis.

getAlignmentX() - Method in class javax.swing.JComponent

Overrides Container.getAlignmentX to return the vertical alignment.

getAlignmentY() - Method in class java.awt.Component

Returns the alignment along the y axis.

getAlignmentY() - Method in class java.awt.Container

Returns the alignment along the y axis.

getAlignmentY() - Method in class javax.swing.JComponent

Overrides Container.getAlignmentY to return the horizontal alignment.

getAlignOnBaseline() - Method in class java.awt.FlowLayout

Returns true if components are to be vertically aligned along their baseline.

getAll(String[]) - Method in interface javax.management.openmbean.CompositeData

Returns an array of the values of the items whose names are specified by keys, in the same order as keys.

getAll(String[]) - Method in class javax.management.openmbean.CompositeDataSupport

Returns an array of the values of the items whose names are specified by keys, in the same order as keys.

getAll() - Method in class javax.naming.CompositeName

Retrieves the components of this composite name as an enumeration of strings.

getAll() - Method in class javax.naming.CompoundName

Retrieves the components of this compound name as an enumeration of strings.

getAll() - Method in interface javax.naming.directory.Attribute

Retrieves an enumeration of the attribute's values.

getAll() - Method in interface javax.naming.directory.Attributes

Retrieves an enumeration of the attributes in the attribute set.

getAll() - Method in class javax.naming.directory.BasicAttribute

Retrieves an enumeration of this attribute's values.

getAll() - Method in class javax.naming.directory.BasicAttributes

getAll() - Method in class javax.naming.ldap.LdapName

Retrieves the components of this name as an enumeration of strings.

getAll() - Method in interface javax.naming.Name

Retrieves the components of this name as an enumeration of strings.

getAll() - Method in class javax.naming.Reference

Retrieves an enumeration of the addresses in this reference.

getAllAnnotationMirrors(Element) - Method in interface javax.lang.model.util.Elements

Returns all annotations present on an element, whether directly present or present via inheritance.

getAllAttributeKeys() - Method in interface java.text.AttributedCharacterIterator

Returns the keys of all attributes defined on the iterator's text range.

getAllAttributeKeys() - Static method in class javax.swing.text.html.CSS

Return the set of all possible CSS attribute keys.

getAllAttributeKeys() - Static method in class javax.swing.text.html.HTML

Returns the set of HTML attributes recognized.

getAllAttributes() - Method in interface javax.xml.soap.SOAPElement

Returns an Iterator over all of the attribute Name objects in this SOAPElement object.

getAllAttributesAsQNames() - Method in interface javax.xml.soap.SOAPElement

Returns an Iterator over all of the attributes in this SOAPElement as QName objects.

getAllByName(String) - Static method in class java.net.InetAddress

Given the name of a host, returns an array of its IP addresses, based on the configured name service on the system.

getAllCommands(String) - Method in class javax.activation.CommandMap

Get all the available commands for this type.

getAllCommands(String, DataSource) - Method in class javax.activation.CommandMap

Get all the available commands for this type.

getAllCommands() - Method in class javax.activation.DataHandler

Return all the commands for this type of data.

getAllCommands(String) - Method in class javax.activation.MailcapCommandMap

Get all the available commands in all mailcap files known to this instance of MailcapCommandMap for this MIME type.

getAllFonts() - Method in class java.awt.GraphicsEnvironment

Returns an array containing a one-point size instance of all fonts available in this GraphicsEnvironment.

getAllFrames() - Method in class javax.swing.JDesktopPane

Returns all JInternalFrames currently displayed in the desktop.

getAllFramesInLayer(int) - Method in class javax.swing.JDesktopPane

Returns all JInternalFrames currently displayed in the specified layer of the desktop.

getAllHeaders() - Method in class javax.xml.soap.MimeHeaders

Returns all the MimeHeaders in this MimeHeaders object.

getAllLoadedClasses() - Method in interface java.lang.instrument.Instrumentation

Returns an array of all classes currently loaded by the JVM.

getAllMembers(TypeElement) - Method in interface javax.lang.model.util.Elements

Returns all members of a type element, whether inherited or declared directly.

getAllMimeHeaders() - Method in class javax.xml.soap.AttachmentPart

Retrieves all the headers for this AttachmentPart object as an iterator over the MimeHeader objects.

getAllMimeHeaders() - Method in class javax.xml.soap.SOAPPart

Retrieves all the headers for this SOAPPart object as an iterator over the MimeHeader objects.

getAllNotificationIDs() - Method in class javax.management.timer.Timer

Gets all timer notification identifiers registered into the list of notifications.

getAllNotificationIDs() - Method in interface javax.management.timer.TimerMBean

Gets all timer notification identifiers registered into the list of notifications.

getAllowsChildren() - Method in class javax.swing.text.AbstractDocument.AbstractElement

Returns true if the receiver allows children.

getAllowsChildren() - Method in class javax.swing.text.AbstractDocument.BranchElement

Returns true if the receiver allows children.

getAllowsChildren() - Method in class javax.swing.text.AbstractDocument.LeafElement

Returns true if the receiver allows children.

getAllowsChildren() - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns true if this node is allowed to have children.

getAllowsChildren() - Method in interface javax.swing.tree.TreeNode

Returns true if the receiver allows children.

getAllowsInvalid() - Method in class javax.swing.text.DefaultFormatter

Returns whether or not the value being edited is allowed to be invalid for a length of time.

getAllowUserInteraction() - Method in class java.net.URLConnection

Returns the value of the allowUserInteraction field for this object.

getAllRelationIds() - Method in class javax.management.relation.RelationService

Returns all the relation ids for all the relations handled by the Relation Service.

getAllRelationIds() - Method in interface javax.management.relation.RelationServiceMBean

Returns all the relation ids for all the relations handled by the Relation Service.

getAllRelationTypeNames() - Method in class javax.management.relation.RelationService

Retrieves names of all known relation types.

getAllRelationTypeNames() - Method in interface javax.management.relation.RelationServiceMBean

Retrieves names of all known relation types.

getAllRoles() - Method in interface javax.management.relation.Relation

Returns all roles present in the relation.

getAllRoles(String) - Method in class javax.management.relation.RelationService

Returns all roles present in the relation.

getAllRoles(String) - Method in interface javax.management.relation.RelationServiceMBean

Returns all roles present in the relation.

getAllRoles() - Method in class javax.management.relation.RelationSupport

Returns all roles present in the relation.

getAllStackTraces() - Static method in class java.lang.Thread

Returns a map of stack traces for all live threads.

getAllTags() - Static method in class javax.swing.text.html.HTML

Returns the set of actual HTML tags that are recognized by the default HTML reader.

getAllThreadIds() - Method in interface java.lang.management.ThreadMXBean

Returns all live thread IDs.

getAlpha() - Method in class java.awt.AlphaComposite

Returns the alpha value of this AlphaComposite.

getAlpha() - Method in class java.awt.Color

Returns the alpha component in the range 0-255.

getAlpha(int) - Method in class java.awt.image.ColorModel

Returns the alpha component for the specified pixel, scaled from 0 to 255.

getAlpha(Object) - Method in class java.awt.image.ColorModel

Returns the alpha component for the specified pixel, scaled from 0 to 255.

getAlpha(int) - Method in class java.awt.image.ComponentColorModel

Returns the alpha component for the specified pixel, scaled from 0 to 255.

getAlpha(Object) - Method in class java.awt.image.ComponentColorModel

Returns the alpha component for the specified pixel, scaled from 0 to 255.

getAlpha(int) - Method in class java.awt.image.DirectColorModel

Returns the alpha component for the specified pixel, scaled from 0 to 255.

getAlpha(Object) - Method in class java.awt.image.DirectColorModel

Returns the alpha component for the specified pixel, scaled from 0 to 255.

getAlpha(int) - Method in class java.awt.image.IndexColorModel

Returns the alpha component for the specified pixel, scaled from 0 to 255.

getAlphaMask() - Method in class java.awt.image.DirectColorModel

Returns the mask indicating which bits in an int pixel representation contain the alpha component.

getAlphaRaster() - Method in class java.awt.image.BufferedImage

Returns a WritableRaster representing the alpha channel for BufferedImage objects with ColorModel objects that support a separate spatial alpha channel, such as ComponentColorModel and DirectColorModel.

getAlphaRaster(WritableRaster) - Method in class java.awt.image.ColorModel

Returns a Raster representing the alpha channel of an image, extracted from the input Raster, provided that pixel values of this ColorModel represent color and alpha information as separate spatial bands (e.g.

getAlphaRaster(WritableRaster) - Method in class java.awt.image.ComponentColorModel

Returns a Raster representing the alpha channel of an image, extracted from the input Raster.

getAlphaRaster(WritableRaster) - Method in class java.awt.image.PackedColorModel

Returns a WritableRaster representing the alpha channel of an image, extracted from the input WritableRaster.

getAlphas(byte[]) - Method in class java.awt.image.IndexColorModel

Copies the array of alpha transparency components into the specified array.

getAlternatives() - Method in interface javax.lang.model.type.UnionType

Return the alternatives comprising this union type.

getAltKey() - Method in interface org.w3c.dom.events.MouseEvent

Used to indicate whether the 'alt' key was depressed during the firing of the event.

getAltName() - Method in exception javax.naming.CannotProceedException

Retrieves the altName field of this exception.

getAltNameCtx() - Method in exception javax.naming.CannotProceedException

Retrieves the altNameCtx field of this exception.

getAltText() - Method in class javax.swing.text.html.ImageView

Returns the text to display if the image can't be loaded.

getAmountFull(Insets, int, int) - Method in class javax.swing.plaf.basic.BasicProgressBarUI

This determines the amount of the progress bar that should be filled based on the percent done gathered from the model.

getAmPmStrings() - Method in class java.text.DateFormatSymbols

Gets ampm strings.

getAncestor() - Method in class javax.swing.event.AncestorEvent

Returns the ancestor that the event actually occurred on.

getAncestorListeners() - Method in class javax.swing.JComponent

Returns an array of all the ancestor listeners registered on this component.

getAncestorNamed(String, Component) - Static method in class javax.swing.SwingUtilities

Convenience method for searching above comp in the component hierarchy and returns the first object of name it finds.

getAncestorOfClass(Class<?>, Component) - Static method in class javax.swing.SwingUtilities

Convenience method for searching above comp in the component hierarchy and returns the first object of class c it finds.

getAncestorParent() - Method in class javax.swing.event.AncestorEvent

Returns the parent of the ancestor the event actually occurred on.

getAnchorRect() - Method in class java.awt.TexturePaint

Returns a copy of the anchor rectangle which positions and sizes the textured image.

getAnchorSelectionIndex() - Method in class javax.swing.DefaultListSelectionModel

Return the first index argument from the most recent call to setSelectionInterval(), addSelectionInterval() or removeSelectionInterval().

getAnchorSelectionIndex() - Method in class javax.swing.JList

Returns the anchor selection index.

getAnchorSelectionIndex() - Method in interface javax.swing.ListSelectionModel

Return the first index argument from the most recent call to setSelectionInterval(), addSelectionInterval() or removeSelectionInterval().

getAnchorSelectionPath() - Method in class javax.swing.JTree

Returns the path identified as the anchor.

getAndAccumulate(int, IntBinaryOperator) - Method in class java.util.concurrent.atomic.AtomicInteger

Atomically updates the current value with the results of applying the given function to the current and given values, returning the previous value.

getAndAccumulate(int, int, IntBinaryOperator) - Method in class java.util.concurrent.atomic.AtomicIntegerArray

Atomically updates the element at index i with the results of applying the given function to the current and given values, returning the previous value.

getAndAccumulate(T, int, IntBinaryOperator) - Method in class java.util.concurrent.atomic.AtomicIntegerFieldUpdater

Atomically updates the field of the given object managed by this updater with the results of applying the given function to the current and given values, returning the previous value.

getAndAccumulate(long, LongBinaryOperator) - Method in class java.util.concurrent.atomic.AtomicLong

Atomically updates the current value with the results of applying the given function to the current and given values, returning the previous value.

getAndAccumulate(int, long, LongBinaryOperator) - Method in class java.util.concurrent.atomic.AtomicLongArray

Atomically updates the element at index i with the results of applying the given function to the current and given values, returning the previous value.

getAndAccumulate(T, long, LongBinaryOperator) - Method in class java.util.concurrent.atomic.AtomicLongFieldUpdater

Atomically updates the field of the given object managed by this updater with the results of applying the given function to the current and given values, returning the previous value.

getAndAccumulate(V, BinaryOperator<V>) - Method in class java.util.concurrent.atomic.AtomicReference

Atomically updates the current value with the results of applying the given function to the current and given values, returning the previous value.

getAndAccumulate(int, E, BinaryOperator<E>) - Method in class java.util.concurrent.atomic.AtomicReferenceArray

Atomically updates the element at index i with the results of applying the given function to the current and given values, returning the previous value.

getAndAccumulate(T, V, BinaryOperator<V>) - Method in class java.util.concurrent.atomic.AtomicReferenceFieldUpdater

Atomically updates the field of the given object managed by this updater with the results of applying the given function to the current and given values, returning the previous value.

getAndAdd(int) - Method in class java.util.concurrent.atomic.AtomicInteger

Atomically adds the given value to the current value.

getAndAdd(int, int) - Method in class java.util.concurrent.atomic.AtomicIntegerArray

Atomically adds the given value to the element at index i.

getAndAdd(T, int) - Method in class java.util.concurrent.atomic.AtomicIntegerFieldUpdater

Atomically adds the given value to the current value of the field of the given object managed by this updater.

getAndAdd(long) - Method in class java.util.concurrent.atomic.AtomicLong

Atomically adds the given value to the current value.

getAndAdd(int, long) - Method in class java.util.concurrent.atomic.AtomicLongArray

Atomically adds the given value to the element at index i.

getAndAdd(T, long) - Method in class java.util.concurrent.atomic.AtomicLongFieldUpdater

Atomically adds the given value to the current value of the field of the given object managed by this updater.

getAndDecrement() - Method in class java.util.concurrent.atomic.AtomicInteger

Atomically decrements by one the current value.

getAndDecrement(int) - Method in class java.util.concurrent.atomic.AtomicIntegerArray

Atomically decrements by one the element at index i.

getAndDecrement(T) - Method in class java.util.concurrent.atomic.AtomicIntegerFieldUpdater

Atomically decrements by one the current value of the field of the given object managed by this updater.

getAndDecrement() - Method in class java.util.concurrent.atomic.AtomicLong

Atomically decrements by one the current value.

getAndDecrement(int) - Method in class java.util.concurrent.atomic.AtomicLongArray

Atomically decrements by one the element at index i.

getAndDecrement(T) - Method in class java.util.concurrent.atomic.AtomicLongFieldUpdater

Atomically decrements by one the current value of the field of the given object managed by this updater.

getAndIncrement() - Method in class java.util.concurrent.atomic.AtomicInteger

Atomically increments by one the current value.

getAndIncrement(int) - Method in class java.util.concurrent.atomic.AtomicIntegerArray

Atomically increments by one the element at index i.

getAndIncrement(T) - Method in class java.util.concurrent.atomic.AtomicIntegerFieldUpdater

Atomically increments by one the current value of the field of the given object managed by this updater.

getAndIncrement() - Method in class java.util.concurrent.atomic.AtomicLong

Atomically increments by one the current value.

getAndIncrement(int) - Method in class java.util.concurrent.atomic.AtomicLongArray

Atomically increments by one the element at index i.

getAndIncrement(T) - Method in class java.util.concurrent.atomic.AtomicLongFieldUpdater

Atomically increments by one the current value of the field of the given object managed by this updater.

getAndSet(boolean) - Method in class java.util.concurrent.atomic.AtomicBoolean

Atomically sets to the given value and returns the previous value.

getAndSet(int) - Method in class java.util.concurrent.atomic.AtomicInteger

Atomically sets to the given value and returns the old value.

getAndSet(int, int) - Method in class java.util.concurrent.atomic.AtomicIntegerArray

Atomically sets the element at position i to the given value and returns the old value.

getAndSet(T, int) - Method in class java.util.concurrent.atomic.AtomicIntegerFieldUpdater

Atomically sets the field of the given object managed by this updater to the given value and returns the old value.

getAndSet(long) - Method in class java.util.concurrent.atomic.AtomicLong

Atomically sets to the given value and returns the old value.

getAndSet(int, long) - Method in class java.util.concurrent.atomic.AtomicLongArray

Atomically sets the element at position i to the given value and returns the old value.

getAndSet(T, long) - Method in class java.util.concurrent.atomic.AtomicLongFieldUpdater

Atomically sets the field of the given object managed by this updater to the given value and returns the old value.

getAndSet(V) - Method in class java.util.concurrent.atomic.AtomicReference

Atomically sets to the given value and returns the old value.

getAndSet(int, E) - Method in class java.util.concurrent.atomic.AtomicReferenceArray

Atomically sets the element at position i to the given value and returns the old value.

getAndSet(T, V) - Method in class java.util.concurrent.atomic.AtomicReferenceFieldUpdater

Atomically sets the field of the given object managed by this updater to the given value and returns the old value.

getAndUpdate(IntUnaryOperator) - Method in class java.util.concurrent.atomic.AtomicInteger

Atomically updates the current value with the results of applying the given function, returning the previous value.

getAndUpdate(int, IntUnaryOperator) - Method in class java.util.concurrent.atomic.AtomicIntegerArray

Atomically updates the element at index i with the results of applying the given function, returning the previous value.

getAndUpdate(T, IntUnaryOperator) - Method in class java.util.concurrent.atomic.AtomicIntegerFieldUpdater

Atomically updates the field of the given object managed by this updater with the results of applying the given function, returning the previous value.

getAndUpdate(LongUnaryOperator) - Method in class java.util.concurrent.atomic.AtomicLong

Atomically updates the current value with the results of applying the given function, returning the previous value.

getAndUpdate(int, LongUnaryOperator) - Method in class java.util.concurrent.atomic.AtomicLongArray

Atomically updates the element at index i with the results of applying the given function, returning the previous value.

getAndUpdate(T, LongUnaryOperator) - Method in class java.util.concurrent.atomic.AtomicLongFieldUpdater

Atomically updates the field of the given object managed by this updater with the results of applying the given function, returning the previous value.

getAndUpdate(UnaryOperator<V>) - Method in class java.util.concurrent.atomic.AtomicReference

Atomically updates the current value with the results of applying the given function, returning the previous value.

getAndUpdate(int, UnaryOperator<E>) - Method in class java.util.concurrent.atomic.AtomicReferenceArray

Atomically updates the element at index i with the results of applying the given function, returning the previous value.

getAndUpdate(T, UnaryOperator<V>) - Method in class java.util.concurrent.atomic.AtomicReferenceFieldUpdater

Atomically updates the field of the given object managed by this updater with the results of applying the given function, returning the previous value.

getAngleExtent() - Method in class java.awt.geom.Arc2D.Double

Returns the angular extent of the arc.

getAngleExtent() - Method in class java.awt.geom.Arc2D.Float

Returns the angular extent of the arc.

getAngleExtent() - Method in class java.awt.geom.Arc2D

Returns the angular extent of the arc.

getAngleStart() - Method in class java.awt.geom.Arc2D.Double

Returns the starting angle of the arc.

getAngleStart() - Method in class java.awt.geom.Arc2D.Float

Returns the starting angle of the arc.

getAngleStart() - Method in class java.awt.geom.Arc2D

Returns the starting angle of the arc.

getAnimationIndex() - Method in class javax.swing.plaf.basic.BasicProgressBarUI

Gets the index of the current animation frame.

getAnnotatedActualTypeArguments() - Method in interface java.lang.reflect.AnnotatedParameterizedType

Returns the potentially annotated actual type arguments of this parameterized type.

getAnnotatedBounds() - Method in interface java.lang.reflect.AnnotatedTypeVariable

Returns the potentially annotated bounds of this type variable.

getAnnotatedBounds() - Method in interface java.lang.reflect.TypeVariable

Returns an array of AnnotatedType objects that represent the use of types to denote the upper bounds of the type parameter represented by this TypeVariable.

getAnnotatedExceptionTypes() - Method in class java.lang.reflect.Executable

Returns an array of AnnotatedType objects that represent the use of types to specify the declared exceptions of the method/constructor represented by this Executable.

getAnnotatedGenericComponentType() - Method in interface java.lang.reflect.AnnotatedArrayType

Returns the potentially annotated generic component type of this array type.

getAnnotatedInterfaces() - Method in class java.lang.Class

Returns an array of AnnotatedType objects that represent the use of types to specify superinterfaces of the entity represented by this Class object.

getAnnotatedLowerBounds() - Method in interface java.lang.reflect.AnnotatedWildcardType

Returns the potentially annotated lower bounds of this wildcard type.

getAnnotatedParameterTypes() - Method in class java.lang.reflect.Executable

Returns an array of AnnotatedType objects that represent the use of types to specify formal parameter types of the method/constructor represented by this Executable.

getAnnotatedReceiverType() - Method in class java.lang.reflect.Constructor

Returns an AnnotatedType object that represents the use of a type to specify the receiver type of the method/constructor represented by this Executable object.

getAnnotatedReceiverType() - Method in class java.lang.reflect.Executable

Returns an AnnotatedType object that represents the use of a type to specify the receiver type of the method/constructor represented by this Executable object.

getAnnotatedReturnType() - Method in class java.lang.reflect.Constructor

Returns an AnnotatedType object that represents the use of a type to specify the return type of the method/constructor represented by this Executable.

getAnnotatedReturnType() - Method in class java.lang.reflect.Executable

Returns an AnnotatedType object that represents the use of a type to specify the return type of the method/constructor represented by this Executable.

getAnnotatedReturnType() - Method in class java.lang.reflect.Method

Returns an AnnotatedType object that represents the use of a type to specify the return type of the method/constructor represented by this Executable.

getAnnotatedSuperclass() - Method in class java.lang.Class

Returns an AnnotatedType object that represents the use of a type to specify the superclass of the entity represented by this Class object.

getAnnotatedType() - Method in class java.lang.reflect.Field

Returns an AnnotatedType object that represents the use of a type to specify the declared type of the field represented by this Field.

getAnnotatedType() - Method in class java.lang.reflect.Parameter

Returns an AnnotatedType object that represents the use of a type to specify the type of the formal parameter represented by this Parameter.

getAnnotatedUpperBounds() - Method in interface java.lang.reflect.AnnotatedWildcardType

Returns the potentially annotated upper bounds of this wildcard type.

getAnnotation(Class<A>) - Method in class java.lang.Class

getAnnotation(Class<A>) - Method in class java.lang.Package

getAnnotation(Class<T>) - Method in class java.lang.reflect.AccessibleObject

getAnnotation(Class<T>) - Method in interface java.lang.reflect.AnnotatedElement

Returns this element's annotation for the specified type if such an annotation is present, else null.

getAnnotation(Class<T>) - Method in class java.lang.reflect.Constructor

Returns this element's annotation for the specified type if such an annotation is present, else null.

getAnnotation(Class<T>) - Method in class java.lang.reflect.Executable

Returns this element's annotation for the specified type if such an annotation is present, else null.

getAnnotation(Class<T>) - Method in class java.lang.reflect.Field

getAnnotation(Class<T>) - Method in class java.lang.reflect.Method

Returns this element's annotation for the specified type if such an annotation is present, else null.

getAnnotation(Class<T>) - Method in class java.lang.reflect.Parameter

Returns this element's annotation for the specified type if such an annotation is present, else null.

getAnnotation(Class<A>) - Method in interface javax.lang.model.AnnotatedConstruct

Returns this construct's annotation of the specified type if such an annotation is present, else null.

getAnnotation(Class<A>) - Method in interface javax.lang.model.element.Element

Returns this construct's annotation of the specified type if such an annotation is present, else null.

getAnnotationMirrors() - Method in interface javax.lang.model.AnnotatedConstruct

Returns the annotations that are directly present on this construct.

getAnnotationMirrors() - Method in interface javax.lang.model.element.Element

Returns the annotations that are directly present on this construct.

getAnnotations() - Method in class java.lang.Class

getAnnotations() - Method in class java.lang.Package

getAnnotations() - Method in class java.lang.reflect.AccessibleObject

getAnnotations() - Method in interface java.lang.reflect.AnnotatedElement

Returns annotations that are present on this element.

getAnnotations() - Method in class java.lang.reflect.Parameter

Returns annotations that are present on this element.

getAnnotationsByType(Class<A>) - Method in class java.lang.Class

getAnnotationsByType(Class<A>) - Method in class java.lang.Package

getAnnotationsByType(Class<T>) - Method in class java.lang.reflect.AccessibleObject

getAnnotationsByType(Class<T>) - Method in interface java.lang.reflect.AnnotatedElement

Returns annotations that are associated with this element.

getAnnotationsByType(Class<T>) - Method in class java.lang.reflect.Executable

Returns annotations that are associated with this element.

getAnnotationsByType(Class<T>) - Method in class java.lang.reflect.Field

Returns annotations that are associated with this element.

getAnnotationsByType(Class<T>) - Method in class java.lang.reflect.Parameter

Returns annotations that are associated with this element.

getAnnotationsByType(Class<A>) - Method in interface javax.lang.model.AnnotatedConstruct

Returns annotations that are associated with this construct.

getAnnotationType() - Method in interface javax.lang.model.element.AnnotationMirror

Returns the type of this annotation.

getAnonymityState() - Method in interface org.ietf.jgss.GSSContext

Determines if the context initiator is anonymously authenticated to the context acceptor.

getAnonymousLogger() - Static method in class java.util.logging.Logger

Create an anonymous Logger.

getAnonymousLogger(String) - Static method in class java.util.logging.Logger

Create an anonymous Logger.

getAntiAliasingHint() - Method in class java.awt.font.FontRenderContext

Return the text anti-aliasing rendering mode hint used in this FontRenderContext.

getAppConfigurationEntry(String) - Method in class javax.security.auth.login.Configuration

Retrieve the AppConfigurationEntries for the specified name from this Configuration.

getApplet(String) - Method in interface java.applet.AppletContext

Finds and returns the applet in the document represented by this applet context with the given name.

getAppletContext() - Method in class java.applet.Applet

Determines this applet's context, which allows the applet to query and affect the environment in which it runs.

getAppletContext() - Method in interface java.applet.AppletStub

Returns the applet's context.

getAppletInfo() - Method in class java.applet.Applet

Returns information about this applet.

getApplets() - Method in interface java.applet.AppletContext

Finds all the applets in the document represented by this applet context.

getApplicationBufferSize() - Method in interface javax.net.ssl.SSLSession

Gets the current size of the largest application data that is expected when using this session.

getApplicationData() - Method in class org.ietf.jgss.ChannelBinding

Get the application specified data for this channel binding.

getApproveButton(JFileChooser) - Method in class javax.swing.plaf.basic.BasicFileChooserUI

getApproveButton(JFileChooser) - Method in class javax.swing.plaf.metal.MetalFileChooserUI

getApproveButtonMnemonic() - Method in class javax.swing.JFileChooser

Returns the approve button's mnemonic.

getApproveButtonMnemonic(JFileChooser) - Method in class javax.swing.plaf.basic.BasicFileChooserUI

getApproveButtonText() - Method in class javax.swing.JFileChooser

Returns the text used in the ApproveButton in the FileChooserUI.

getApproveButtonText(JFileChooser) - Method in class javax.swing.plaf.basic.BasicFileChooserUI

getApproveButtonText(JFileChooser) - Method in class javax.swing.plaf.FileChooserUI

getApproveButtonText(JFileChooser) - Method in class javax.swing.plaf.multi.MultiFileChooserUI

Invokes the getApproveButtonText method on each UI handled by this object.

getApproveButtonToolTipText() - Method in class javax.swing.JFileChooser

Returns the tooltip text used in the ApproveButton.

getApproveButtonToolTipText(JFileChooser) - Method in class javax.swing.plaf.basic.BasicFileChooserUI

getApproveSelectionAction() - Method in class javax.swing.plaf.basic.BasicFileChooserUI

getArch() - Method in interface java.lang.management.OperatingSystemMXBean

Returns the operating system architecture.

getArcHeight() - Method in class java.awt.geom.RoundRectangle2D.Double

Gets the height of the arc that rounds off the corners.

getArcHeight() - Method in class java.awt.geom.RoundRectangle2D.Float

Gets the height of the arc that rounds off the corners.

getArcHeight() - Method in class java.awt.geom.RoundRectangle2D

Gets the height of the arc that rounds off the corners.

getArcType() - Method in class java.awt.geom.Arc2D

Returns the arc closure type of the arc: Arc2D.OPEN, Arc2D.CHORD, or Arc2D.PIE.

getArcWidth() - Method in class java.awt.geom.RoundRectangle2D.Double

Gets the width of the arc that rounds off the corners.

getArcWidth() - Method in class java.awt.geom.RoundRectangle2D.Float

Gets the width of the arc that rounds off the corners.

getArcWidth() - Method in class java.awt.geom.RoundRectangle2D

Gets the width of the arc that rounds off the corners.

getAreaOfInterest() - Method in class java.awt.image.renderable.RenderContext

Gets the ares of interest currently contained in the RenderContext.

getArgument() - Method in exception javax.lang.model.element.UnknownAnnotationValueException

Returns the additional argument.

getArgument() - Method in exception javax.lang.model.element.UnknownElementException

Returns the additional argument.

getArgument() - Method in exception javax.lang.model.type.UnknownTypeException

Returns the additional argument.

getArgumentClass() - Method in exception java.util.IllegalFormatConversionException

Returns the class of the mismatched argument.

getArguments() - Method in class java.beans.Statement

Returns the arguments for the method to invoke.

getArray() - Method in interface java.sql.Array

Retrieves the contents of the SQL ARRAY value designated by this Array object in the form of an array in the Java programming language.

getArray(Map<String, Class<?>>) - Method in interface java.sql.Array

Retrieves the contents of the SQL ARRAY value designated by this Array object.

getArray(long, int) - Method in interface java.sql.Array

Retrieves a slice of the SQL ARRAY value designated by this Array object, beginning with the specified index and containing up to count successive elements of the SQL array.

getArray(long, int, Map<String, Class<?>>) - Method in interface java.sql.Array

Retreives a slice of the SQL ARRAY value designated by this Array object, beginning with the specified index and containing up to count successive elements of the SQL array.

getArray(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC ARRAY parameter as an Array object in the Java programming language.

getArray(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC ARRAY parameter as an Array object in the Java programming language.

getArray(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as an Array object in the Java programming language.

getArray(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as an Array object in the Java programming language.

getArray() - Method in class javax.sql.rowset.serial.SerialArray

Returns a new array that is a copy of this SerialArray object.

getArray(Map<String, Class<?>>) - Method in class javax.sql.rowset.serial.SerialArray

Returns a new array that is a copy of this SerialArray object, using the given type map for the custom mapping of each element when the elements are SQL UDTs.

getArray(long, int) - Method in class javax.sql.rowset.serial.SerialArray

Returns a new array that is a copy of a slice of this SerialArray object, starting with the element at the given index and containing the given number of consecutive elements.

getArray(long, int, Map<String, Class<?>>) - Method in class javax.sql.rowset.serial.SerialArray

Returns a new array that is a copy of a slice of this SerialArray object, starting with the element at the given index and containing the given number of consecutive elements.

getArray() - Method in class javax.swing.text.DefaultStyledDocument.ElementSpec

Gets the array of characters.

getArrayLength() - Method in class javax.swing.text.GapContent

Get the length of the allocated array.

getArrayType(TypeMirror) - Method in interface javax.lang.model.util.Types

Returns an array type with the specified component type.

getArrayType(OpenType<E>) - Static method in class javax.management.openmbean.ArrayType

Create an ArrayType instance in a type-safe manner.

getArrivedParties() - Method in class java.util.concurrent.Phaser

Returns the number of registered parties that have arrived at the current phase of this phaser.

getAsBoolean() - Method in interface java.util.function.BooleanSupplier

Gets a result.

getAscent() - Method in class java.awt.font.GraphicAttribute

Returns the ascent of this GraphicAttribute.

getAscent() - Method in class java.awt.font.ImageGraphicAttribute

Returns the ascent of this ImageGraphicAttribute.

getAscent() - Method in class java.awt.font.LineMetrics

Returns the ascent of the text.

getAscent() - Method in class java.awt.font.ShapeGraphicAttribute

Returns the ascent of this ShapeGraphicAttribute.

getAscent() - Method in class java.awt.font.TextLayout

Returns the ascent of this TextLayout.

getAscent() - Method in class java.awt.FontMetrics

Determines the font ascent of the Font described by this FontMetrics object.

getAscent(GlyphView) - Method in class javax.swing.text.GlyphView.GlyphPainter

getAsciiName() - Method in class javax.net.ssl.SNIHostName

Returns the StandardCharsets.US_ASCII-compliant hostname of this SNIHostName object.

getAsciiStream() - Method in interface java.sql.Clob

Retrieves the CLOB value designated by this Clob object as an ascii stream.

getAsciiStream(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a stream of ASCII characters.

getAsciiStream(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a stream of ASCII characters.

getAsciiStream() - Method in class javax.sql.rowset.serial.SerialClob

Retrieves the CLOB value designated by this SerialClob object as an ascii stream.

getAsDouble() - Method in interface java.util.function.DoubleSupplier

Gets a result.

getAsDouble() - Method in class java.util.OptionalDouble

If a value is present in this OptionalDouble, returns the value, otherwise throws NoSuchElementException.

getAsInt() - Method in interface java.util.function.IntSupplier

Gets a result.

getAsInt() - Method in class java.util.OptionalInt

If a value is present in this OptionalInt, returns the value, otherwise throws NoSuchElementException.

getAsLong() - Method in interface java.util.function.LongSupplier

Gets a result.

getAsLong() - Method in class java.util.OptionalLong

If a value is present in this OptionalLong, returns the value, otherwise throws NoSuchElementException.

getAspectRatio(int) - Method in class javax.imageio.ImageReader

Returns the aspect ratio of the given image (that is, its width divided by its height) as a float.

getAssociatedStylesheet(Source, String, String, String) - Method in class javax.xml.transform.TransformerFactory

Get the stylesheet specification(s) associated with the XML Source document via the xml-stylesheet processing instruction that match the given criteria.

getAsText() - Method in interface java.beans.PropertyEditor

Gets the property value as text.

getAsText() - Method in class java.beans.PropertyEditorSupport

Gets the property value as a string suitable for presentation to a human to edit.

getAsTree(String) - Method in class javax.imageio.metadata.IIOMetadata

Returns an XML DOM Node object that represents the root of a tree of metadata contained within this object according to the conventions defined by a given metadata format.

getAsync() - Method in interface org.w3c.dom.ls.LSParser

true if the LSParser is asynchronous, false if it is synchronous.

getAsynchronousLoadPriority() - Method in class javax.swing.text.AbstractDocument

Gets the asynchronous loading priority.

getAsyncMode() - Method in class java.util.concurrent.ForkJoinPool

Returns true if this pool uses local first-in-first-out scheduling mode for forked tasks that are never joined.

getAtIndex(int, int) - Method in class java.awt.TextComponent.AccessibleAWTTextComponent

Returns the String at a given index.

getAtIndex(int, int) - Method in interface javax.accessibility.AccessibleText

Returns the String at a given index.

getAtIndex(int, int) - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Returns the String at a given index.

getAtIndex(int, int) - Method in class javax.swing.JLabel.AccessibleJLabel

Returns the String at a given index.

getAtIndex(int, int) - Method in class javax.swing.JPasswordField.AccessibleJPasswordField

Returns the String at a given index.

getAtIndex(int, int) - Method in class javax.swing.JSpinner.AccessibleJSpinner

Returns the String at a given index.

getAtIndex(int, int) - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Returns the String at a given index.

getAtIndex(int, int) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Returns the String at a given index.

getAttachment(SOAPElement) - Method in class javax.xml.soap.SOAPMessage

Returns an AttachmentPart object that is associated with an attachment that is referenced by this SOAPElement or null if no such attachment exists.

getAttachmentAsByteArray(String) - Method in class javax.xml.bind.attachment.AttachmentUnmarshaller

Retrieve the attachment identified by content-id, cid, as a byte[]

getAttachmentAsDataHandler(String) - Method in class javax.xml.bind.attachment.AttachmentUnmarshaller

Lookup MIME content by content-id, cid, and return as a DataHandler.

getAttachmentMarshaller() - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

getAttachmentMarshaller() - Method in interface javax.xml.bind.Marshaller

getAttachments() - Method in class javax.xml.soap.SOAPMessage

Retrieves all the AttachmentPart objects that are part of this SOAPMessage object.

getAttachments(MimeHeaders) - Method in class javax.xml.soap.SOAPMessage

Retrieves all the AttachmentPart objects that have header entries that match the specified headers.

getAttachmentUnmarshaller() - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

getAttachmentUnmarshaller() - Method in interface javax.xml.bind.Unmarshaller

getAttrChange() - Method in interface org.w3c.dom.events.MutationEvent

attrChange indicates the type of change which triggered the DOMAttrModified event.

getAttribute(Path, String, LinkOption...) - Static method in class java.nio.file.Files

Reads the value of a file attribute.

getAttribute(String) - Method in class java.nio.file.FileStore

Reads the value of a file store attribute.

getAttribute(String) - Method in class java.security.Provider.Service

Return the value of the specified attribute or null if this attribute is not set for this Service.

getAttribute(AttributedCharacterIterator.Attribute) - Method in interface java.text.AttributedCharacterIterator

Returns the value of the named attribute for the current character.

getAttribute(String) - Method in class javax.imageio.metadata.IIOMetadataNode

Retrieves an attribute value by name.

getAttribute(ObjectName) - Method in class javax.management.AttributeValueExp

Return the value of the given attribute in the named MBean.

getAttribute(String) - Method in interface javax.management.DynamicMBean

Obtain the value of a specific attribute of the Dynamic MBean.

getAttribute(ObjectName, String) - Method in interface javax.management.MBeanServer

getAttribute(ObjectName, String) - Method in interface javax.management.MBeanServerConnection

Gets the value of a specific attribute of a named MBean.

getAttribute(String) - Method in interface javax.management.modelmbean.ModelMBeanInfo

Returns a ModelMBeanAttributeInfo requested by name.

getAttribute(String) - Method in class javax.management.modelmbean.ModelMBeanInfoSupport

getAttribute(String) - Method in class javax.management.modelmbean.RequiredModelMBean

Returns the value of a specific attribute defined for this ModelMBean.

getAttribute(ObjectName, String, Subject) - Method in interface javax.management.remote.rmi.RMIConnection

Handles the method MBeanServerConnection.getAttribute(ObjectName, String).

getAttribute(ObjectName, String, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl

getAttribute(ObjectName, String, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub

getAttribute(String) - Method in class javax.management.StandardMBean

getAttribute() - Method in class javax.naming.directory.ModificationItem

Retrieves the attribute associated with this modification item.

getAttribute(Class<T>) - Method in interface javax.print.PrintService

Gets the value of the single specified service attribute.

getAttribute(String, int) - Method in interface javax.script.ScriptContext

Gets the value of an attribute in a given scope.

getAttribute(String) - Method in interface javax.script.ScriptContext

Retrieves the value of the attribute with the given name in the scope occurring earliest in the search order.

getAttribute(String) - Method in class javax.script.SimpleScriptContext

Retrieves the value of the attribute with the given name in the scope occurring earliest in the search order.

getAttribute(String, int) - Method in class javax.script.SimpleScriptContext

Gets the value of an attribute in a given scope.

getAttribute(Object) - Method in class javax.swing.text.AbstractDocument.AbstractElement

Gets the value of an attribute.

getAttribute(Object) - Method in interface javax.swing.text.AttributeSet

Fetches the value of the given attribute.

getAttribute(String) - Static method in class javax.swing.text.html.CSS

Translates a string to a CSS.Attribute object.

getAttribute(String) - Method in class javax.swing.text.html.parser.Element

Get an attribute by name.

getAttribute(Object) - Method in class javax.swing.text.SimpleAttributeSet

Gets the value of an attribute.

getAttribute(Object) - Method in class javax.swing.text.StyleContext.NamedStyle

Gets the value of an attribute.

getAttribute(Object) - Method in class javax.swing.text.StyleContext.SmallAttributeSet

Gets the value of an attribute.

getAttribute(String) - Method in class javax.xml.parsers.DocumentBuilderFactory

Allows the user to retrieve specific attributes on the underlying implementation.

getAttribute(String) - Method in class javax.xml.transform.TransformerFactory

Allows the user to retrieve specific attributes on the underlying implementation.

getAttribute(String) - Method in class javax.xml.ws.spi.http.HttpContext

Returns an attribute value for container's configuration and other data that can be used by jax-ws runtime.

getAttribute(String) - Method in class javax.xml.ws.spi.http.HttpExchange

Returns an attribute that is associated with this HttpExchange.

getAttribute(String) - Method in interface org.w3c.dom.Element

Retrieves an attribute value by name.

getAttributeByName(QName) - Method in interface javax.xml.stream.events.StartElement

Returns the attribute referred to by this name

getAttributeByValue(String) - Method in class javax.swing.text.html.parser.Element

Get an attribute by value.

getAttributeContext() - Method in class javax.swing.text.AbstractDocument

Fetches the context for managing attributes.

getAttributeCount() - Method in class javax.swing.text.AbstractDocument.AbstractElement

Gets the number of attributes that are defined.

getAttributeCount() - Method in interface javax.swing.text.AttributeSet

Returns the number of attributes that are defined locally in this set.

getAttributeCount() - Method in class javax.swing.text.SimpleAttributeSet

Gets a count of the number of attributes.

getAttributeCount() - Method in class javax.swing.text.StyleContext.NamedStyle

Gets the number of attributes that are defined.

getAttributeCount() - Method in class javax.swing.text.StyleContext.SmallAttributeSet

Gets the number of attributes that are defined.

getAttributeCount() - Method in class javax.xml.stream.util.StreamReaderDelegate

getAttributeCount() - Method in interface javax.xml.stream.XMLStreamReader

Returns the count of attributes on this START_ELEMENT, this method is only valid on a START_ELEMENT or ATTRIBUTE.

getAttributeDataType(String, String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns one of the constants starting with DATATYPE_, indicating the format and interpretation of the value of the given attribute within the named element.

getAttributeDataType(String, String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getAttributeDefaultValue(String, String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns the default value of the named attribute, if it is not explicitly present within the named element, as a String, or null if no default value is available.

getAttributeDefaultValue(String, String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getAttributeDefinition() - Method in interface javax.naming.directory.Attribute

Retrieves the attribute's schema definition.

getAttributeDefinition() - Method in class javax.naming.directory.BasicAttribute

Retrieves this attribute's schema definition.

getAttributeDescription(String, String, Locale) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns a String containing a description of the named attribute, or null.

getAttributeDescription(String, String, Locale) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

Returns a String containing a description of the named attribute, or null.

getAttributeEnumerations(String, String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns an array of Strings containing the legal enumerated values for the given attribute within the named element.

getAttributeEnumerations(String, String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getAttributeID() - Method in class javax.naming.ldap.SortKey

Retrieves the attribute ID of the sort key.

getAttributeID() - Method in class javax.naming.ldap.SortResponseControl

Retrieves the ID of the attribute that caused the sort to fail.

getAttributeKey(String) - Static method in class javax.swing.text.html.HTML

Fetches an attribute constant for a well-known attribute name (i.e.

getAttributeListMaxLength(String, String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns the maximum number of list items that may be used to define this attribute.

getAttributeListMaxLength(String, String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getAttributeListMinLength(String, String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns the minimum number of list items that may be used to define this attribute.

getAttributeListMinLength(String, String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getAttributeLocalName(int) - Method in class javax.xml.stream.util.StreamReaderDelegate

getAttributeLocalName(int) - Method in interface javax.xml.stream.XMLStreamReader

Returns the localName of the attribute at the provided index

getAttributeMaxValue(String, String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns the maximum legal value for the attribute.

getAttributeMaxValue(String, String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getAttributeMinValue(String, String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns the minimum legal value for the attribute.

getAttributeMinValue(String, String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getAttributeName() - Method in class javax.management.AttributeChangeNotification

Gets the name of the attribute which has changed.

getAttributeName() - Method in class javax.management.AttributeValueExp

Returns a string representation of the name of the attribute.

getAttributeName(int) - Method in class javax.xml.stream.util.StreamReaderDelegate

getAttributeName(int) - Method in interface javax.xml.stream.XMLStreamReader

Returns the qname of the attribute at the provided index

getAttributeNames(String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns an array of Strings listing the names of the attributes that may be associated with the named element.

getAttributeNames(String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getAttributeNames() - Method in class javax.swing.text.AbstractDocument.AbstractElement

Gets the names of all attributes.

getAttributeNames() - Method in interface javax.swing.text.AttributeSet

Returns an enumeration over the names of the attributes that are defined locally in the set.

getAttributeNames() - Method in class javax.swing.text.SimpleAttributeSet

Gets the names of the attributes in the set.

getAttributeNames() - Method in class javax.swing.text.StyleContext.NamedStyle

Gets the names of all attributes.

getAttributeNames() - Method in class javax.swing.text.StyleContext.SmallAttributeSet

Gets the names of all attributes.

getAttributeNames() - Method in class javax.xml.ws.spi.http.HttpContext

Returns all attribute names for container's configuration and other data that can be used by jax-ws runtime.

getAttributeNames() - Method in class javax.xml.ws.spi.http.HttpExchange

Gives all the attribute names that are associated with this HttpExchange.

getAttributeNamespace(int) - Method in class javax.xml.stream.util.StreamReaderDelegate

getAttributeNamespace(int) - Method in interface javax.xml.stream.XMLStreamReader

Returns the namespace of the attribute at the provided index

getAttributeNode(String) - Method in class javax.imageio.metadata.IIOMetadataNode

getAttributeNode(String) - Method in interface org.w3c.dom.Element

Retrieves an attribute node by name.

getAttributeNodeNS(String, String) - Method in class javax.imageio.metadata.IIOMetadataNode

Equivalent to getAttributeNode(localName).

getAttributeNodeNS(String, String) - Method in interface org.w3c.dom.Element

Retrieves an Attr node by local name and namespace URI.

getAttributeNS(String, String) - Method in class javax.imageio.metadata.IIOMetadataNode

Equivalent to getAttribute(localName).

getAttributeNS(String, String) - Method in interface org.w3c.dom.Element

Retrieves an attribute value by local name and namespace URI.

getAttributePrefix(int) - Method in class javax.xml.stream.util.StreamReaderDelegate

getAttributePrefix(int) - Method in interface javax.xml.stream.XMLStreamReader

Returns the prefix of this attribute at the provided index

getAttributes() - Method in class java.awt.Font

Returns a map of font attributes available in this Font.

getAttributes() - Method in class java.net.JarURLConnection

Return the Attributes object for this connection if the URL for it points to a JAR file entry, null otherwise.

getAttributes() - Method in interface java.security.KeyStore.Entry

Retrieves the attributes associated with an entry.

getAttributes() - Method in class java.security.KeyStore.PrivateKeyEntry

Retrieves the attributes associated with an entry.

getAttributes() - Method in class java.security.KeyStore.SecretKeyEntry

Retrieves the attributes associated with an entry.

getAttributes() - Method in class java.security.KeyStore.TrustedCertificateEntry

Retrieves the attributes associated with an entry.

getAttributes(String, String, String, String) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of the given attribute of the given type for a user-defined type (UDT) that is available in the given schema and catalog.

getAttributes() - Method in interface java.sql.Struct

Produces the ordered values of the attributes of the SQL structured type that this Struct object represents.

getAttributes(Map<String, Class<?>>) - Method in interface java.sql.Struct

Produces the ordered values of the attributes of the SQL structured type that this Struct object represents.

getAttributes() - Method in interface java.text.AttributedCharacterIterator

Returns a map with the attributes defined on the current character.

getAttributes() - Method in class java.util.jar.JarEntry

Returns the Manifest Attributes for this entry, or null if none.

getAttributes(String) - Method in class java.util.jar.Manifest

Returns the Attributes for the specified entry name.

getAttributes() - Method in class javax.imageio.metadata.IIOMetadataNode

Returns a NamedNodeMap containing the attributes of this node.

getAttributes(String[]) - Method in interface javax.management.DynamicMBean

Get the values of several attributes of the Dynamic MBean.

getAttributes() - Method in class javax.management.loading.MLetContent

Gets the attributes of the MLET tag.

getAttributes() - Method in class javax.management.MBeanInfo

Returns the list of attributes exposed for management.

getAttributes(ObjectName, String[]) - Method in interface javax.management.MBeanServer

getAttributes(ObjectName, String[]) - Method in interface javax.management.MBeanServerConnection

Retrieves the values of several attributes of a named MBean.

getAttributes() - Method in interface javax.management.modelmbean.ModelMBeanInfo

Returns the list of attributes exposed for management.

getAttributes(String[]) - Method in class javax.management.modelmbean.RequiredModelMBean

Returns the values of several attributes in the ModelMBean.

getAttributes() - Method in interface javax.management.openmbean.OpenMBeanInfo

Returns an array of OpenMBeanAttributeInfo instances describing each attribute in the open MBean described by this OpenMBeanInfo instance.

getAttributes() - Method in interface javax.management.remote.JMXConnectorServerMBean

The attributes for this connector server.

getAttributes(ObjectName, String[], Subject) - Method in interface javax.management.remote.rmi.RMIConnection

Handles the method MBeanServerConnection.getAttributes(ObjectName, String[]).

getAttributes(ObjectName, String[], Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl

getAttributes(ObjectName, String[], Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub

getAttributes() - Method in class javax.management.remote.rmi.RMIConnectorServer

getAttributes(String[]) - Method in class javax.management.StandardMBean

getAttributes(Name) - Method in interface javax.naming.directory.DirContext

Retrieves all of the attributes associated with a named object.

getAttributes(String) - Method in interface javax.naming.directory.DirContext

Retrieves all of the attributes associated with a named object.

getAttributes(Name, String[]) - Method in interface javax.naming.directory.DirContext

Retrieves selected attributes associated with a named object.

getAttributes(String, String[]) - Method in interface javax.naming.directory.DirContext

Retrieves selected attributes associated with a named object.

getAttributes(String) - Method in class javax.naming.directory.InitialDirContext

getAttributes(String, String[]) - Method in class javax.naming.directory.InitialDirContext

getAttributes(Name) - Method in class javax.naming.directory.InitialDirContext

getAttributes(Name, String[]) - Method in class javax.naming.directory.InitialDirContext

getAttributes() - Method in class javax.naming.directory.SearchResult

Retrieves the attributes in this search result.

getAttributes() - Method in class javax.naming.spi.DirStateFactory.Result

Retrieves the attributes to be bound.

getAttributes() - Method in interface javax.print.Doc

Obtains the set of printing attributes for this doc object.

getAttributes() - Method in interface javax.print.DocPrintJob

Obtains this Print Job's set of printing attributes.

getAttributes() - Method in class javax.print.event.PrintJobAttributeEvent

Determine the printing attributes that changed and their new values.

getAttributes() - Method in class javax.print.event.PrintServiceAttributeEvent

Determine the printing service attributes that changed and their new values.

getAttributes() - Method in interface javax.print.PrintService

Obtains this print service's set of printer description attributes giving this Print Service's status.

getAttributes() - Method in class javax.print.SimpleDoc

Obtains the set of printing attributes for this doc object.

getAttributes() - Method in class javax.sql.rowset.serial.SerialStruct

Retrieves an array of Object values containing the attributes of the SQL structured type that this SerialStruct object represents.

getAttributes(Map<String, Class<?>>) - Method in class javax.sql.rowset.serial.SerialStruct

Retrieves the attributes for the SQL structured type that this SerialStruct represents as an array of Object values, using the given type map for custom mapping if appropriate.

getAttributes() - Method in class javax.swing.text.AbstractDocument.AbstractElement

Gets the attributes for the element.

getAttributes() - Method in class javax.swing.text.DefaultStyledDocument.ElementSpec

Gets the element attributes.

getAttributes() - Method in interface javax.swing.text.Element

Fetches the collection of attributes this element contains.

getAttributes() - Method in class javax.swing.text.html.BlockView

Fetches the attributes to use when rendering.

getAttributes() - Method in class javax.swing.text.html.HTMLDocument.Iterator

Return the attributes for this tag.

getAttributes() - Method in class javax.swing.text.html.ImageView

Fetches the attributes to use when rendering.

getAttributes() - Method in class javax.swing.text.html.InlineView

Fetches the attributes to use when rendering.

getAttributes() - Method in class javax.swing.text.html.Option

Fetch the attributes associated with this option.

getAttributes() - Method in class javax.swing.text.html.ParagraphView

Fetches the attributes to use when rendering.

getAttributes() - Method in class javax.swing.text.html.parser.Element

Get the attributes.

getAttributes() - Method in class javax.swing.text.html.parser.Parser

getAttributes() - Method in class javax.swing.text.View

Fetches the attributes to use when rendering.

getAttributes() - Method in interface javax.xml.stream.events.StartElement

Returns an Iterator of non-namespace declared attributes declared on this START_ELEMENT, returns an empty iterator if there are no attributes.

getAttributes() - Method in interface org.w3c.dom.Node

A NamedNodeMap containing the attributes of this node (if it is an Element) or null otherwise.

getAttributesScope(String) - Method in interface javax.script.ScriptContext

Get the lowest scope in which an attribute is defined.

getAttributesScope(String) - Method in class javax.script.SimpleScriptContext

Get the lowest scope in which an attribute is defined.

getAttributeSyntaxDefinition() - Method in interface javax.naming.directory.Attribute

Retrieves the syntax definition associated with the attribute.

getAttributeSyntaxDefinition() - Method in class javax.naming.directory.BasicAttribute

Retrieves the syntax definition associated with this attribute.

getAttributeType() - Method in class javax.management.AttributeChangeNotification

Gets the type of the attribute which has changed.

getAttributeType(int) - Method in class javax.xml.stream.util.StreamReaderDelegate

getAttributeType(int) - Method in interface javax.xml.stream.XMLStreamReader

Returns the XML type of the attribute at the provided index

getAttributeTypeInfo(int) - Method in class javax.xml.validation.TypeInfoProvider

Returns the immutable TypeInfo object for the specified attribute of the current element.

getAttributeValue(Name) - Method in interface javax.xml.soap.SOAPElement

Returns the value of the attribute with the specified name.

getAttributeValue(QName) - Method in interface javax.xml.soap.SOAPElement

Returns the value of the attribute with the specified qname.

getAttributeValue(String, String) - Method in class javax.xml.stream.util.StreamReaderDelegate

getAttributeValue(int) - Method in class javax.xml.stream.util.StreamReaderDelegate

getAttributeValue(String, String) - Method in interface javax.xml.stream.XMLStreamReader

Returns the normalized attribute value of the attribute with the namespace and localName If the namespaceURI is null the namespace is not checked for equality

getAttributeValue(int) - Method in interface javax.xml.stream.XMLStreamReader

Returns the value of the attribute at the index

getAttributeValueType(String, String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns one of the constants starting with VALUE_, indicating whether the values of the given attribute within the named element are arbitrary, constrained to lie within a specified range, constrained to be one of a set of enumerated values, or are a whitespace-separated list of arbitrary values.

getAttributeValueType(String, String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getAttrName() - Method in interface org.w3c.dom.events.MutationEvent

attrName indicates the name of the changed Attr node in a DOMAttrModified event.

getAudioActionMap() - Method in class javax.swing.plaf.basic.BasicLookAndFeel

Returns an ActionMap containing the audio actions for this look and feel.

getAudioClip(URL) - Method in class java.applet.Applet

Returns the AudioClip object specified by the URL argument.

getAudioClip(URL, String) - Method in class java.applet.Applet

Returns the AudioClip object specified by the URL and name arguments.

getAudioClip(URL) - Method in interface java.applet.AppletContext

Creates an audio clip.

getAudioFileFormat(InputStream) - Static method in class javax.sound.sampled.AudioSystem

Obtains the audio file format of the provided input stream.

getAudioFileFormat(URL) - Static method in class javax.sound.sampled.AudioSystem

Obtains the audio file format of the specified URL.

getAudioFileFormat(File) - Static method in class javax.sound.sampled.AudioSystem

Obtains the audio file format of the specified File.

getAudioFileFormat(InputStream) - Method in class javax.sound.sampled.spi.AudioFileReader

Obtains the audio file format of the input stream provided.

getAudioFileFormat(URL) - Method in class javax.sound.sampled.spi.AudioFileReader

Obtains the audio file format of the URL provided.

getAudioFileFormat(File) - Method in class javax.sound.sampled.spi.AudioFileReader

Obtains the audio file format of the File provided.

getAudioFileTypes() - Static method in class javax.sound.sampled.AudioSystem

Obtains the file types for which file writing support is provided by the system.

getAudioFileTypes(AudioInputStream) - Static method in class javax.sound.sampled.AudioSystem

Obtains the file types that the system can write from the audio input stream specified.

getAudioFileTypes() - Method in class javax.sound.sampled.spi.AudioFileWriter

Obtains the file types for which file writing support is provided by this audio file writer.

getAudioFileTypes(AudioInputStream) - Method in class javax.sound.sampled.spi.AudioFileWriter

Obtains the file types that this audio file writer can write from the audio input stream specified.

getAudioInputStream(AudioFormat.Encoding, AudioInputStream) - Static method in class javax.sound.sampled.AudioSystem

Obtains an audio input stream of the indicated encoding, by converting the provided audio input stream.

getAudioInputStream(AudioFormat, AudioInputStream) - Static method in class javax.sound.sampled.AudioSystem

Obtains an audio input stream of the indicated format, by converting the provided audio input stream.

getAudioInputStream(InputStream) - Static method in class javax.sound.sampled.AudioSystem

Obtains an audio input stream from the provided input stream.

getAudioInputStream(URL) - Static method in class javax.sound.sampled.AudioSystem

Obtains an audio input stream from the URL provided.

getAudioInputStream(File) - Static method in class javax.sound.sampled.AudioSystem

Obtains an audio input stream from the provided File.

getAudioInputStream(InputStream) - Method in class javax.sound.sampled.spi.AudioFileReader

Obtains an audio input stream from the input stream provided.

getAudioInputStream(URL) - Method in class javax.sound.sampled.spi.AudioFileReader

Obtains an audio input stream from the URL provided.

getAudioInputStream(File) - Method in class javax.sound.sampled.spi.AudioFileReader

Obtains an audio input stream from the File provided.

getAudioInputStream(AudioFormat.Encoding, AudioInputStream) - Method in class javax.sound.sampled.spi.FormatConversionProvider

Obtains an audio input stream with the specified encoding from the given audio input stream.

getAudioInputStream(AudioFormat, AudioInputStream) - Method in class javax.sound.sampled.spi.FormatConversionProvider

Obtains an audio input stream with the specified format from the given audio input stream.

getAuthenticationID() - Method in class javax.security.sasl.AuthorizeCallback

Returns the authentication id to check.

getAuthority() - Method in class java.net.URI

Returns the decoded authority component of this URI.

getAuthority() - Method in class java.net.URL

Gets the authority part of this URL.

getAuthorityKeyIdentifier() - Method in class java.security.cert.X509CertSelector

Returns the authorityKeyIdentifier criterion.

getAuthorityName() - Method in exception java.security.cert.CertificateRevokedException

Returns the name of the authority that signed the certificate's revocation status information.

getAuthorizationID() - Method in class javax.security.sasl.AuthorizeCallback

Returns the authorization id to check.

getAuthorizationID() - Method in interface javax.security.sasl.SaslServer

Reports the authorization ID in effect for the client of this session.

getAuthorizedID() - Method in class javax.security.sasl.AuthorizeCallback

Returns the id of the authorized user.

getAuthTime() - Method in class javax.security.auth.kerberos.KerberosTicket

Returns the time that the client was authenticated.

getAutoCommit() - Method in interface java.sql.Connection

Retrieves the current auto-commit mode for this Connection object.

getAutoCommit() - Method in interface javax.sql.rowset.JdbcRowSet

Each JdbcRowSet contains a Connection object from the original ResultSet or JDBC properties passed to it.

getAutoCreateColumnsFromModel() - Method in class javax.swing.JTable

Determines whether the table will create default columns from the model.

getAutoCreateContainerGaps() - Method in class javax.swing.GroupLayout

Returns true if gaps between the container and components that border the container are automatically created.

getAutoCreateGaps() - Method in class javax.swing.GroupLayout

Returns true if gaps between components are automatically created.

getAutoCreateRowSorter() - Method in class javax.swing.JTable

Returns true if whenever the model changes, a new RowSorter should be created and installed as the table's sorter; otherwise, returns false.

getAutoDelay() - Method in class java.awt.Robot

Returns the number of milliseconds this Robot sleeps after generating an event.

getAutoResizeMode() - Method in class javax.swing.JTable

Returns the auto resize mode of the table.

getAutoscrollInsets() - Method in interface java.awt.dnd.Autoscroll

This method returns the Insets describing the autoscrolling region or border relative to the geometry of the implementing Component.

getAutoscrolls() - Method in class javax.swing.JComponent

Gets the autoscrolls property.

getAuxiliaryLookAndFeels() - Static method in class javax.swing.UIManager

Returns the list of auxiliary look and feels (can be null).

getAvailableAcceleratedMemory() - Method in class java.awt.GraphicsDevice

This method returns the number of bytes available in accelerated memory on this device.

getAvailableAttributes() - Method in class java.awt.Font

Returns the keys of all the attributes supported by this Font.

getAvailableCalendarTypes() - Static method in class java.util.Calendar

Returns an unmodifiable Set containing all calendar types supported by Calendar in the runtime environment.

getAvailableChronologies() - Static method in interface java.time.chrono.Chronology

Returns the available chronologies.

getAvailableCurrencies() - Static method in class java.util.Currency

Gets the set of available currencies.

getAvailableDataFlavors() - Method in class java.awt.datatransfer.Clipboard

Returns an array of DataFlavors in which the current contents of this clipboard can be provided.

getAvailableFontFamilyNames() - Method in class java.awt.GraphicsEnvironment

Returns an array containing the names of all font families in this GraphicsEnvironment localized for the default locale, as returned by Locale.getDefault().

getAvailableFontFamilyNames(Locale) - Method in class java.awt.GraphicsEnvironment

Returns an array containing the names of all font families in this GraphicsEnvironment localized for the specified locale.

getAvailableIDs(int) - Static method in class java.util.TimeZone

Gets the available IDs according to the given time zone offset in milliseconds.

getAvailableIDs() - Static method in class java.util.TimeZone

Gets all the available IDs supported.

getAvailableInstruments() - Method in interface javax.sound.midi.Synthesizer

Obtains a list of instruments that come with the synthesizer.

getAvailableLocales() - Method in interface java.awt.im.spi.InputMethodDescriptor

Returns the locales supported by the corresponding input method.

getAvailableLocales() - Static method in class java.text.BreakIterator

Returns an array of all locales for which the get*Instance methods of this class can return localized instances.

getAvailableLocales() - Static method in class java.text.Collator

Returns an array of all locales for which the getInstance methods of this class can return localized instances.

getAvailableLocales() - Static method in class java.text.DateFormat

Returns an array of all locales for which the get*Instance methods of this class can return localized instances.

getAvailableLocales() - Static method in class java.text.DateFormatSymbols

Returns an array of all locales for which the getInstance methods of this class can return localized instances.

getAvailableLocales() - Static method in class java.text.DecimalFormatSymbols

Returns an array of all locales for which the getInstance methods of this class can return localized instances.

getAvailableLocales() - Static method in class java.text.NumberFormat

Returns an array of all locales for which the get*Instance methods of this class can return localized instances.

getAvailableLocales() - Static method in class java.time.format.DecimalStyle

Lists all the locales that are supported.

getAvailableLocales() - Static method in class java.util.Calendar

Returns an array of all locales for which the getInstance methods of this class can return localized instances.

getAvailableLocales() - Static method in class java.util.Locale

Returns an array of all installed locales.

getAvailableLocales() - Method in class java.util.spi.LocaleServiceProvider

Returns an array of all locales for which this locale service provider can provide localized objects or names.

getAvailableLocales() - Method in class javax.imageio.ImageReader

Returns an array of Locales that may be used to localize warning listeners and compression settings.

getAvailableLocales() - Method in class javax.imageio.ImageWriter

Returns an array of Locales that may be used to localize warning listeners and compression settings.

getAvailableProcessors() - Method in interface java.lang.management.OperatingSystemMXBean

Returns the number of processors available to the Java virtual machine.

getAvailableSize(Dimension, Insets) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager

Returns the available width based on the container size and Insets.

getAvailableZoneIds() - Static method in class java.time.zone.ZoneRulesProvider

Gets the set of available zone IDs.

getAvailableZoneIds() - Static method in class java.time.ZoneId

Gets the set of available zone IDs.

getAverage() - Method in class java.util.DoubleSummaryStatistics

Returns the arithmetic mean of values recorded, or zero if no values have been recorded.

getAverage() - Method in class java.util.IntSummaryStatistics

Returns the arithmetic mean of values recorded, or zero if no values have been recorded.

getAverage() - Method in class java.util.LongSummaryStatistics

Returns the arithmetic mean of values recorded, or zero if no values have been recorded.

getAWTEventListeners() - Method in class java.awt.Toolkit

Returns an array of all the AWTEventListeners registered on this toolkit.

getAWTEventListeners(long) - Method in class java.awt.Toolkit

Returns an array of all the AWTEventListeners registered on this toolkit which listen to all of the event types specified in the eventMask argument.

getAWTKeyStroke(char) - Static method in class java.awt.AWTKeyStroke

Returns a shared instance of an AWTKeyStroke that represents a KEY_TYPED event for the specified character.

getAWTKeyStroke(Character, int) - Static method in class java.awt.AWTKeyStroke

Returns a shared instance of an AWTKeyStroke that represents a KEY_TYPED event for the specified Character object and a set of modifiers.

getAWTKeyStroke(int, int, boolean) - Static method in class java.awt.AWTKeyStroke

Returns a shared instance of an AWTKeyStroke, given a numeric key code and a set of modifiers, specifying whether the key is activated when it is pressed or released.

getAWTKeyStroke(int, int) - Static method in class java.awt.AWTKeyStroke

Returns a shared instance of an AWTKeyStroke, given a numeric key code and a set of modifiers.

getAWTKeyStroke(String) - Static method in class java.awt.AWTKeyStroke

Parses a string and returns an AWTKeyStroke.

getAWTKeyStrokeForEvent(KeyEvent) - Static method in class java.awt.AWTKeyStroke

Returns an AWTKeyStroke which represents the stroke which generated a given KeyEvent.

getAxis() - Method in class javax.swing.BoxLayout

Returns the axis that was used to lay out components.

getAxis() - Method in class javax.swing.text.BoxView

Fetches the tile axis property.

getB() - Method in class java.security.spec.EllipticCurve

Returns the second coefficient b of the elliptic curve.

getBackBuffer() - Method in class java.awt.Component.FlipBufferStrategy

getBackBufferCapabilities() - Method in class java.awt.BufferCapabilities

getBackground() - Method in class java.awt.Component.AccessibleAWTComponent

Gets the background color of this object.

getBackground() - Method in class java.awt.Component

Gets the background color of this component.

getBackground() - Method in class java.awt.Graphics2D

Returns the background color used for clearing a region.

getBackground() - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Get the background color of this object.

getBackground() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Gets the background color of this object.

getBackground() - Method in class java.awt.TextComponent

Gets the background color of this text component.

getBackground() - Method in class java.awt.Window

Gets the background color of this window.

getBackground() - Method in interface javax.accessibility.AccessibleComponent

Gets the background color of this object.

getBackground() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getBackground() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the background color of this object.

getBackground() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Get the background color of this object.

getBackground() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getBackground(AttributeSet) - Method in class javax.swing.text.DefaultStyledDocument

Gets the background color from an attribute set.

getBackground() - Method in class javax.swing.text.GlyphView

Fetch the background color to use to render the glyphs.

getBackground(AttributeSet) - Method in class javax.swing.text.html.StyleSheet

Takes a set of attributes and turn it into a background color specification.

getBackground() - Method in class javax.swing.text.LabelView

Fetches the background color to use to render the glyphs.

getBackground(AttributeSet) - Static method in class javax.swing.text.StyleConstants

Gets the background color setting from the attribute list.

getBackground(AttributeSet) - Method in class javax.swing.text.StyleContext

Takes a set of attributes and turn it into a background color specification.

getBackground(AttributeSet) - Method in interface javax.swing.text.StyledDocument

Takes a set of attributes and turn it into a background color specification.

getBackgroundAt(int) - Method in class javax.swing.JTabbedPane

Returns the tab background color at index.

getBackgroundNonSelectionColor() - Method in class javax.swing.tree.DefaultTreeCellRenderer

Returns the background color to be used for non selected nodes.

getBackgroundPainter(SynthContext) - Method in class javax.swing.plaf.nimbus.NimbusStyle

Gets the appropriate background Painter, if there is one, for the state specified in the given SynthContext.

getBackgroundSelectionColor() - Method in class javax.swing.tree.DefaultTreeCellRenderer

Returns the color to use for the background if node is selected.

getBandOffsets() - Method in class java.awt.image.ComponentSampleModel

Returns the band offset for all bands.

getBank() - Method in class javax.sound.midi.Patch

Returns the number of the bank that contains the instrument whose location this Patch specifies.

getBankData() - Method in class java.awt.image.DataBufferByte

Returns the data arrays for all banks.

getBankData() - Method in class java.awt.image.DataBufferDouble

Returns the data array for all banks.

getBankData() - Method in class java.awt.image.DataBufferFloat

Returns the data array for all banks.

getBankData() - Method in class java.awt.image.DataBufferInt

Returns the data arrays for all banks.

getBankData() - Method in class java.awt.image.DataBufferShort

Returns the data arrays for all banks.

getBankData() - Method in class java.awt.image.DataBufferUShort

Returns the data arrays for all banks.

getBankIndices() - Method in class java.awt.image.ComponentSampleModel

Returns the bank indices for all bands.

getBase() - Method in class javax.swing.text.html.HTMLDocument

Returns the location to resolve relative URLs against.

getBase() - Method in class javax.swing.text.html.StyleSheet

Returns the base.

getBase64Content() - Method in class javax.xml.soap.AttachmentPart

Returns an InputStream which can be used to obtain the content of AttachmentPart as Base64 encoded character data, this method would base64 encode the raw bytes of the attachment and return.

getBaseBundleName() - Method in class java.util.ResourceBundle

Returns the base name of this bundle, if known, or null if unknown.

getBaseLevel() - Method in class java.text.Bidi

Return the base level (0 if left-to-right, 1 if right-to-left).

getBaseline(int, int) - Method in class java.awt.Component

Returns the baseline.

getBaseline() - Method in class java.awt.font.TextLayout

Returns the baseline for this TextLayout.

getBaseline(Component, int, int) - Method in class javax.swing.border.AbstractBorder

Returns the baseline.

getBaseline(Component, int, int) - Method in class javax.swing.border.TitledBorder

Returns the baseline.

getBaseline(int, int) - Method in class javax.swing.JComponent

Returns the baseline.

getBaseline(int, int) - Method in class javax.swing.JSpinner.DefaultEditor

Returns the baseline.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic.BasicButtonUI

Returns the baseline.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic.BasicComboBoxUI

Returns the baseline.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic.BasicLabelUI

Returns the baseline.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic.BasicListUI

Returns the baseline.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic.BasicPanelUI

Returns the baseline.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic.BasicProgressBarUI

Returns the baseline.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic.BasicScrollPaneUI

Returns the baseline.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic.BasicSliderUI

Returns the baseline.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic.BasicSpinnerUI

Returns the baseline.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

Returns the baseline.

getBaseline(int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

Returns the baseline for the specified tab.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic.BasicTableHeaderUI

Returns the baseline.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic.BasicTableUI

Returns the baseline.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic.BasicTextAreaUI

Returns the baseline.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic.BasicTextFieldUI

Returns the baseline.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.basic.BasicTreeUI

Returns the baseline.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.ComponentUI

Returns the baseline.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.LayerUI

If the JLayer's view component is not null, this calls the view's getBaseline() method.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.metal.MetalComboBoxUI

Returns the baseline.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.synth.SynthButtonUI

Returns the baseline.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.synth.SynthLabelUI

Returns the baseline.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.synth.SynthProgressBarUI

Returns the baseline.

getBaseline(JComponent, int, int) - Method in class javax.swing.plaf.synth.SynthSliderUI

Returns the baseline.

getBaseline(int) - Method in class javax.swing.plaf.synth.SynthTabbedPaneUI

Returns the baseline for the specified tab.

getBaselineFor(char) - Method in class java.awt.Font

Returns the baseline appropriate for displaying this character.

getBaselineIndex() - Method in class java.awt.font.LineMetrics

Returns the baseline index of the text.

getBaselineOffset() - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

Returns the amount the baseline is offset by.

getBaselineOffset() - Method in class javax.swing.plaf.metal.MetalTabbedPaneUI

Returns the amount the baseline is offset by.

getBaselineOffsets() - Method in class java.awt.font.LineMetrics

Returns the baseline offsets of the text, relative to the baseline of the text.

getBaselineOffsets() - Method in class java.awt.font.TextLayout

Returns the offsets array for the baselines used for this TextLayout.

getBaselineResizeBehavior() - Method in class java.awt.Component

Returns an enum indicating how the baseline of the component changes as the size changes.

getBaselineResizeBehavior(Component) - Method in class javax.swing.border.AbstractBorder

Returns an enum indicating how the baseline of a component changes as the size changes.

getBaselineResizeBehavior(Component) - Method in class javax.swing.border.TitledBorder

Returns an enum indicating how the baseline of the border changes as the size changes.

getBaselineResizeBehavior() - Method in class javax.swing.JComponent

Returns an enum indicating how the baseline of the component changes as the size changes.

getBaselineResizeBehavior() - Method in class javax.swing.JSpinner.DefaultEditor

Returns an enum indicating how the baseline of the component changes as the size changes.

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic.BasicButtonUI

Returns an enum indicating how the baseline of the component changes as the size changes.

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic.BasicComboBoxUI

Returns an enum indicating how the baseline of the component changes as the size changes.

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic.BasicLabelUI

Returns an enum indicating how the baseline of the component changes as the size changes.

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic.BasicListUI

Returns an enum indicating how the baseline of the component changes as the size changes.

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic.BasicPanelUI

Returns an enum indicating how the baseline of the component changes as the size changes.

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic.BasicProgressBarUI

Returns an enum indicating how the baseline of the component changes as the size changes.

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic.BasicScrollPaneUI

Returns an enum indicating how the baseline of the component changes as the size changes.

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic.BasicSliderUI

Returns an enum indicating how the baseline of the component changes as the size changes.

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic.BasicSpinnerUI

Returns an enum indicating how the baseline of the component changes as the size changes.

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

Returns an enum indicating how the baseline of the component changes as the size changes.

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic.BasicTableUI

Returns an enum indicating how the baseline of the component changes as the size changes.

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic.BasicTextAreaUI

Returns an enum indicating how the baseline of the component changes as the size changes.

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic.BasicTextFieldUI

Returns an enum indicating how the baseline of the component changes as the size changes.

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.basic.BasicTreeUI

Returns an enum indicating how the baseline of the component changes as the size changes.

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.ComponentUI

Returns an enum indicating how the baseline of he component changes as the size changes.

getBaselineResizeBehavior(JComponent) - Method in class javax.swing.plaf.LayerUI

If the JLayer's view component is not null, this returns the result of the view's getBaselineResizeBehavior() method.

getBaseType() - Method in interface java.sql.Array

Retrieves the JDBC type of the elements in the array designated by this Array object.

getBaseType() - Method in class javax.activation.MimeType

Return a String representation of this object without the parameter list.

getBaseType() - Method in class javax.sql.rowset.serial.SerialArray

Retrieves the SQL type of the elements in this SerialArray object.

getBaseTypeName() - Method in interface java.sql.Array

Retrieves the SQL type name of the elements in the array designated by this Array object.

getBaseTypeName() - Method in interface java.sql.Ref

Retrieves the fully-qualified SQL name of the SQL structured type that this Ref object references.

getBaseTypeName() - Method in class javax.sql.rowset.serial.SerialArray

Retrieves the DBMS-specific type name for the elements in this SerialArray object.

getBaseTypeName() - Method in class javax.sql.rowset.serial.SerialRef

Returns a string describing the base type name of the Ref.

getBaseUnit() - Method in enum java.time.temporal.ChronoField

getBaseUnit() - Method in interface java.time.temporal.TemporalField

Gets the unit that the field is measured in.

getBaseURI() - Method in class javax.imageio.metadata.IIOMetadataNode

This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.

getBaseURI() - Method in class javax.xml.crypto.dom.DOMCryptoContext

getBaseURI() - Method in interface javax.xml.crypto.XMLCryptoContext

Returns the base URI.

getBaseURI() - Method in interface javax.xml.stream.events.EntityDeclaration

Get the base URI for this reference or null if this information is not available

getBaseURI() - Method in interface org.w3c.dom.ls.LSInput

The base URI to be used (see section 5.1.4 in [IETF RFC 2396]) for resolving a relative systemId to an absolute URI.

getBaseURI() - Method in interface org.w3c.dom.Node

The absolute base URI of this node or null if the implementation wasn't able to obtain an absolute URI.

getBasicConstraints() - Method in class java.security.cert.X509Certificate

Gets the certificate constraints path length from the critical BasicConstraints extension, (OID = 2.5.29.19).

getBasicConstraints() - Method in class java.security.cert.X509CertSelector

Returns the basic constraints constraint.

getBasicSplitPaneUI() - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider

Returns the SplitPaneUI the receiver is currently in.

getBean(CommandInfo) - Method in class javax.activation.DataHandler

A convenience method that takes a CommandInfo object and instantiates the corresponding command, usually a JavaBean component.

getBeanClass() - Method in class java.beans.BeanDescriptor

Gets the bean's Class object.

getBeanContext() - Method in interface java.beans.beancontext.BeanContextChild

Gets the BeanContext associated with this BeanContextChild.

getBeanContext() - Method in class java.beans.beancontext.BeanContextChildSupport

Gets the nesting BeanContext for this BeanContextChildSupport.

getBeanContext() - Method in class java.beans.beancontext.BeanContextEvent

Gets the BeanContext associated with this event.

getBeanContextChildPeer() - Method in class java.beans.beancontext.BeanContextChildSupport

Gets the BeanContextChild associated with this BeanContextChildSupport.

getBeanContextPeer() - Method in class java.beans.beancontext.BeanContextSupport

Gets the instance of BeanContext that this object is providing the implementation for.

getBeanContextProxy() - Method in interface java.beans.beancontext.BeanContextProxy

Gets the BeanContextChild (or subinterface) associated with this object.

getBeanContextServicesPeer() - Method in class java.beans.beancontext.BeanContextServicesSupport

Gets the BeanContextServices associated with this BeanContextServicesSupport.

getBeanDescriptor() - Method in interface java.beans.BeanInfo

Returns the bean descriptor that provides overall information about the bean, such as its display name or its customizer.

getBeanDescriptor() - Method in class java.beans.SimpleBeanInfo

Deny knowledge about the class and customizer of the bean.

getBeanInfo(Class<?>) - Static method in class java.beans.Introspector

Introspect on a Java Bean and learn about all its properties, exposed methods, and events.

getBeanInfo(Class<?>, int) - Static method in class java.beans.Introspector

Introspect on a Java bean and learn about all its properties, exposed methods, and events, subject to some control flags.

getBeanInfo(Class<?>, Class<?>) - Static method in class java.beans.Introspector

Introspect on a Java bean and learn all about its properties, exposed methods, below a given "stop" point.

getBeanInfo(Class<?>, Class<?>, int) - Static method in class java.beans.Introspector

Introspect on a Java Bean and learn about all its properties, exposed methods and events, below a given stopClass point subject to some control flags.

getBeanInfoSearchPath() - Static method in class java.beans.Introspector

Gets the list of package names that will be used for finding BeanInfo classes.

getBeforeIndex(int, int) - Method in class java.awt.TextComponent.AccessibleAWTTextComponent

Returns the String before a given index.

getBeforeIndex(int, int) - Method in interface javax.accessibility.AccessibleText

Returns the String before a given index.

getBeforeIndex(int, int) - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Returns the String before a given index.

getBeforeIndex(int, int) - Method in class javax.swing.JLabel.AccessibleJLabel

Returns the String before a given index.

getBeforeIndex(int, int) - Method in class javax.swing.JPasswordField.AccessibleJPasswordField

Returns the String before a given index.

getBeforeIndex(int, int) - Method in class javax.swing.JSpinner.AccessibleJSpinner

Returns the String before a given index.

getBeforeIndex(int, int) - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Returns the String before a given index.

getBeforeIndex(int, int) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Returns the String before a given index.

getBeginIndex() - Method in interface java.text.CharacterIterator

Returns the start index of the text.

getBeginIndex() - Method in class java.text.FieldPosition

Retrieves the index of the first character in the requested field.

getBeginIndex() - Method in class java.text.StringCharacterIterator

Implements CharacterIterator.getBeginIndex() for String.

getBeginIndex() - Method in class javax.swing.text.Segment

Returns the start index of the text.

getBestConfiguration(GraphicsConfiguration[]) - Method in class java.awt.GraphicsConfigTemplate

Returns the "best" configuration possible that passes the criteria defined in the GraphicsConfigTemplate.

getBestConfiguration(GraphicsConfigTemplate) - Method in class java.awt.GraphicsDevice

Returns the "best" configuration possible that passes the criteria defined in the GraphicsConfigTemplate.

getBestCursorSize(int, int) - Method in class java.awt.Toolkit

Returns the supported cursor dimension which is closest to the desired sizes.

getBestRowIdentifier(String, String, String, int, boolean) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of a table's optimal set of columns that uniquely identifies a row.

getBevelType() - Method in class javax.swing.border.BevelBorder

Returns the type of the bevel border.

getBias() - Method in class javax.swing.text.JTextComponent.DropLocation

Returns the bias for the drop index.

getBidiLevel(AttributeSet) - Static method in class javax.swing.text.StyleConstants

Gets the BidiLevel setting.

getBidiRootElement() - Method in class javax.swing.text.AbstractDocument

Returns the root element of the bidirectional structure for this document.

getBigDecimal(int, int) - Method in interface java.sql.CallableStatement

Deprecated.
use getBigDecimal(int parameterIndex) or getBigDecimal(String parameterName)

getBigDecimal(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC NUMERIC parameter as a java.math.BigDecimal object with as many digits to the right of the decimal point as the value contains.

getBigDecimal(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC NUMERIC parameter as a java.math.BigDecimal object with as many digits to the right of the decimal point as the value contains.

getBigDecimal(int, int) - Method in interface java.sql.ResultSet

Deprecated.
Use getBigDecimal(int columnIndex) or getBigDecimal(String columnLabel)

getBigDecimal(String, int) - Method in interface java.sql.ResultSet

Deprecated.
Use getBigDecimal(int columnIndex) or getBigDecimal(String columnLabel)

getBigDecimal(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.math.BigDecimal with full precision.

getBigDecimal(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.math.BigDecimal with full precision.

getBinaryName(TypeElement) - Method in interface javax.lang.model.util.Elements

Returns the binary name of a type element.

getBinaryStream() - Method in interface java.sql.Blob

Retrieves the BLOB value designated by this Blob instance as a stream.

getBinaryStream(long, long) - Method in interface java.sql.Blob

Returns an InputStream object that contains a partial Blob value, starting with the byte specified by pos, which is length bytes in length.

getBinaryStream(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a stream of uninterpreted bytes.

getBinaryStream(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a stream of uninterpreted bytes.

getBinaryStream() - Method in interface java.sql.SQLXML

Retrieves the XML value designated by this SQLXML instance as a stream.

getBinaryStream() - Method in class javax.sql.rowset.serial.SerialBlob

Returns this SerialBlob object as an input stream.

getBinaryStream(long, long) - Method in class javax.sql.rowset.serial.SerialBlob

Returns an InputStream object that contains a partial Blob value, starting with the byte specified by pos, which is length bytes in length.

getBinding() - Method in interface javax.xml.ws.BindingProvider

Get the Binding for this binding provider.

getBinding() - Method in class javax.xml.ws.Endpoint

Returns the binding for this endpoint.

getBindingID() - Method in interface javax.xml.ws.Binding

Get the URI for this binding instance.

getBindingID() - Method in interface javax.xml.ws.handler.PortInfo

Gets the URI identifying the binding used by the port being accessed.

getBindings(int) - Method in class javax.script.AbstractScriptEngine

Returns the Bindings with the specified scope value in the protected context field.

getBindings(int) - Method in interface javax.script.ScriptContext

Gets the Bindings associated with the given scope in this ScriptContext.

getBindings(int) - Method in interface javax.script.ScriptEngine

Returns a scope of named values.

getBindings() - Method in class javax.script.ScriptEngineManager

getBindings returns the value of the globalScope field.

getBindings(int) - Method in class javax.script.SimpleScriptContext

Returns the value of the engineScope field if specified scope is ENGINE_SCOPE.

getBitDepth() - Method in class java.awt.DisplayMode

Returns the bit depth of the display, in bits per pixel.

getBitMasks() - Method in class java.awt.image.SinglePixelPackedSampleModel

Returns the bit masks for all bands.

getBitOffset(int) - Method in class java.awt.image.MultiPixelPackedSampleModel

Returns the offset, in bits, into the data element in which it is stored for the xth pixel of a scanline.

getBitOffset() - Method in interface javax.imageio.stream.ImageInputStream

Returns the current bit offset, as an integer between 0 and 7, inclusive.

getBitOffset() - Method in class javax.imageio.stream.ImageInputStreamImpl

getBitOffsets() - Method in class java.awt.image.SinglePixelPackedSampleModel

Returns the bit offsets into the data array element representing a pixel for all bands.

getBitRate(float) - Method in class javax.imageio.ImageWriteParam

Returns a float indicating an estimate of the number of bits of output data for each bit of input image data at the given quality level.

getBitsPerBand(int) - Method in class javax.imageio.ImageTypeSpecifier

Return the number of bits used to represent samples of the given band.

getBlack() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the black color of the current theme.

getBlack() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the black color.

getBlack() - Method in class javax.swing.plaf.metal.OceanTheme

Returns the black color.

getBlackBoxBounds(int, int) - Method in class java.awt.font.TextLayout

Returns the black box bounds of the characters in the specified range.

getBlackLineBorderUIResource() - Static method in class javax.swing.plaf.BorderUIResource

getBlinkRate() - Method in interface javax.swing.text.Caret

Gets the blink rate of the caret.

getBlinkRate() - Method in class javax.swing.text.DefaultCaret

Gets the caret blink rate.

getBlob(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC BLOB parameter as a Blob object in the Java programming language.

getBlob(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC BLOB parameter as a Blob object in the Java programming language.

getBlob(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a Blob object in the Java programming language.

getBlob(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a Blob object in the Java programming language.

getBlockedCount() - Method in class java.lang.management.ThreadInfo

Returns the total number of times that the thread associated with this ThreadInfo blocked to enter or reenter a monitor.

getBlockedTime() - Method in class java.lang.management.ThreadInfo

Returns the approximate accumulated elapsed time (in milliseconds) that the thread associated with this ThreadInfo has blocked to enter or reenter a monitor since thread contention monitoring is enabled.

getBlocker(Thread) - Static method in class java.util.concurrent.locks.LockSupport

Returns the blocker object supplied to the most recent invocation of a park method that has not yet unblocked, or null if not blocked.

getBlockIncrement() - Method in interface java.awt.Adjustable

Gets the block value increment for the adjustable object.

getBlockIncrement() - Method in class java.awt.Scrollbar

Gets the block increment of this scroll bar.

getBlockIncrement() - Method in class java.awt.ScrollPaneAdjustable

getBlockIncrement(int) - Method in class javax.swing.JScrollBar

Returns the amount to change the scrollbar's value by, given a block (usually "page") up/down request.

getBlockIncrement() - Method in class javax.swing.JScrollBar

For backwards compatibility with java.awt.Scrollbar.

getBlockIncrement(int) - Method in class javax.swing.JScrollPane.ScrollBar

Computes the block increment for scrolling if the viewport's view is a Scrollable object.

getBlockSize() - Method in class javax.crypto.Cipher

Returns the block size (in bytes).

getBlue() - Method in class java.awt.Color

Returns the blue component in the range 0-255 in the default sRGB space.

getBlue(int) - Method in class java.awt.image.ColorModel

Returns the blue color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getBlue(Object) - Method in class java.awt.image.ColorModel

Returns the blue color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getBlue(int) - Method in class java.awt.image.ComponentColorModel

Returns the blue color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getBlue(Object) - Method in class java.awt.image.ComponentColorModel

Returns the blue color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getBlue(int) - Method in class java.awt.image.DirectColorModel

Returns the blue color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getBlue(Object) - Method in class java.awt.image.DirectColorModel

Returns the blue color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getBlue(int) - Method in class java.awt.image.IndexColorModel

Returns the blue color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getBlueMask() - Method in class java.awt.image.DirectColorModel

Returns the mask indicating which bits in an int pixel representation contain the blue color component.

getBlues(byte[]) - Method in class java.awt.image.IndexColorModel

Copies the array of blue color components into the specified array.

getBody() - Method in class java.net.CacheRequest

Returns an OutputStream to which the response body can be written.

getBody() - Method in class java.net.CacheResponse

Returns the response body as an InputStream.

getBody() - Method in interface javax.xml.soap.SOAPEnvelope

Returns the SOAPBody object associated with this SOAPEnvelope object.

getBoolean(String) - Static method in class java.lang.Boolean

Returns true if and only if the system property named by the argument exists and is equal to the string "true".

getBoolean(Object, int) - Static method in class java.lang.reflect.Array

Returns the value of the indexed component in the specified array object, as a boolean.

getBoolean(Object) - Method in class java.lang.reflect.Field

Gets the value of a static or instance boolean field.

getBoolean(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC BIT or BOOLEAN parameter as a boolean in the Java programming language.

getBoolean(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC BIT or BOOLEAN parameter as a boolean in the Java programming language.

getBoolean(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a boolean in the Java programming language.

getBoolean(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a boolean in the Java programming language.

getBoolean(String, boolean) - Method in class java.util.prefs.AbstractPreferences

Implements the getBoolean method as per the specification in Preferences.getBoolean(String,boolean).

getBoolean(String, boolean) - Method in class java.util.prefs.Preferences

Returns the boolean value represented by the string associated with the specified key in this preference node.

getBoolean(SynthContext, Object, boolean) - Method in class javax.swing.plaf.synth.SynthStyle

Convenience method to get a specific style property whose value is an Boolean.

getBoolean(Object) - Method in class javax.swing.UIDefaults

If the value of key is boolean, return the boolean value, otherwise return false.

getBoolean(Object, Locale) - Method in class javax.swing.UIDefaults

If the value of key for the given Locale is boolean, return the boolean value, otherwise return false.

getBoolean(Object) - Static method in class javax.swing.UIManager

Returns a boolean from the defaults which is associated with the key value.

getBoolean(Object, Locale) - Static method in class javax.swing.UIManager

Returns a boolean from the defaults which is associated with the key value and the given Locale.

getBootClassPath() - Method in interface java.lang.management.RuntimeMXBean

Returns the boot class path that is used by the bootstrap class loader to search for class files.

getBorder() - Method in class javax.swing.border.TitledBorder

Returns the border of the titled border.

getBorder() - Method in class javax.swing.JComponent

Returns the border of this component or null if no border is currently set.

getBorder() - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider

Returns the border of this component or null if no border is currently set.

getBorder() - Method in class javax.swing.tree.DefaultTreeCellEditor.DefaultTextField

Overrides JComponent.getBorder to returns the current border.

getBorder(Object) - Method in class javax.swing.UIDefaults

If the value of key is a Border return it, otherwise return null.

getBorder(Object, Locale) - Method in class javax.swing.UIDefaults

If the value of key for the given Locale is a Border return it, otherwise return null.

getBorder(Object) - Static method in class javax.swing.UIManager

Returns a border from the defaults.

getBorder(Object, Locale) - Static method in class javax.swing.UIManager

Returns a border from the defaults that is appropriate for the given locale.

getBorderColor() - Method in class javax.swing.plaf.basic.BasicToolBarUI.DragWindow

getBorderInsets(Component) - Method in class javax.swing.border.AbstractBorder

This default implementation returns a new Insets object that is initialized by the AbstractBorder.getBorderInsets(Component,Insets) method.

getBorderInsets(Component, Insets) - Method in class javax.swing.border.AbstractBorder

Reinitializes the insets parameter with this Border's current Insets.

getBorderInsets(Component, Insets) - Method in class javax.swing.border.BevelBorder

Reinitialize the insets parameter with this Border's current Insets.

getBorderInsets(Component) - Method in interface javax.swing.border.Border

Returns the insets of the border.

getBorderInsets(Component, Insets) - Method in class javax.swing.border.CompoundBorder

Reinitialize the insets parameter with this Border's current Insets.

getBorderInsets(Component, Insets) - Method in class javax.swing.border.EmptyBorder

Reinitialize the insets parameter with this Border's current Insets.

getBorderInsets() - Method in class javax.swing.border.EmptyBorder

Returns the insets of the border.

getBorderInsets(Component, Insets) - Method in class javax.swing.border.EtchedBorder

Reinitialize the insets parameter with this Border's current Insets.

getBorderInsets(Component, Insets) - Method in class javax.swing.border.LineBorder

Reinitialize the insets parameter with this Border's current Insets.

getBorderInsets(Component, Insets) - Method in class javax.swing.border.MatteBorder

Reinitialize the insets parameter with this Border's current Insets.

getBorderInsets() - Method in class javax.swing.border.MatteBorder

Returns the insets of the border.

getBorderInsets(Component, Insets) - Method in class javax.swing.border.SoftBevelBorder

Reinitialize the insets parameter with this Border's current Insets.

getBorderInsets(Component, Insets) - Method in class javax.swing.border.StrokeBorder

Reinitializes the insets parameter with this border's current insets.

getBorderInsets(Component, Insets) - Method in class javax.swing.border.TitledBorder

Reinitialize the insets parameter with this Border's current Insets.

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.basic.BasicBorders.ButtonBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.basic.BasicBorders.FieldBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.basic.BasicBorders.MarginBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.basic.BasicBorders.MenuBarBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.basic.BasicBorders.RadioButtonBorder

getBorderInsets(Component) - Method in class javax.swing.plaf.basic.BasicBorders.SplitPaneBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.basic.BasicBorders.ToggleButtonBorder

getBorderInsets(Component) - Method in class javax.swing.plaf.BorderUIResource

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.metal.MetalBorders.ButtonBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.metal.MetalBorders.Flush3DBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.metal.MetalBorders.InternalFrameBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.metal.MetalBorders.MenuBarBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.metal.MetalBorders.MenuItemBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.metal.MetalBorders.OptionDialogBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.metal.MetalBorders.PaletteBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.metal.MetalBorders.PopupMenuBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.metal.MetalBorders.ScrollPaneBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.metal.MetalBorders.TableHeaderBorder

getBorderInsets(Component, Insets) - Method in class javax.swing.plaf.metal.MetalBorders.ToolBarBorder

getBorderPainter(SynthContext) - Method in class javax.swing.plaf.nimbus.NimbusStyle

Gets the appropriate border Painter, if there is one, for the state specified in the given SynthContext.

getBorderSelectionColor() - Method in class javax.swing.tree.DefaultTreeCellEditor

Returns the color the border is drawn.

getBorderSelectionColor() - Method in class javax.swing.tree.DefaultTreeCellRenderer

Returns the color the border is drawn.

getBorderTitle(Border) - Method in class javax.swing.JComponent.AccessibleJComponent

Recursively search through the border hierarchy (if it exists) for a TitledBorder with a non-null title.

getBottomComponent() - Method in class javax.swing.JSplitPane

Returns the component below, or to the right of the divider.

getBottomInset() - Method in class javax.swing.text.AsyncBoxView

Get the bottom part of the margin around the view.

getBottomInset() - Method in class javax.swing.text.CompositeView

Gets the bottom inset.

getBottomPanel() - Method in class javax.swing.plaf.metal.MetalFileChooserUI

getBoundActions() - Method in interface javax.swing.text.Keymap

Fetches all of the actions defined in this keymap.

getBoundedPosition(GlyphView, int, float, float) - Method in class javax.swing.text.GlyphView.GlyphPainter

Determines the model location that represents the maximum advance that fits within the given span.

getBoundingBox() - Method in class java.awt.Polygon

Deprecated.
As of JDK version 1.1, replaced by getBounds().

getBoundKeyStrokes() - Method in interface javax.swing.text.Keymap

Fetches all of the keystrokes in this map that are bound to some action.

getBounds() - Method in class java.awt.Component.AccessibleAWTComponent

Gets the bounds of this object in the form of a Rectangle object.

getBounds() - Method in class java.awt.Component

Gets the bounds of this component in the form of a Rectangle object.

getBounds(Rectangle) - Method in class java.awt.Component

Stores the bounds of this component into "return value" rv and return rv.

getBounds() - Method in class java.awt.font.GraphicAttribute

Returns a Rectangle2D that encloses all of the bits drawn by this GraphicAttribute relative to the rendering position.

getBounds() - Method in class java.awt.font.ImageGraphicAttribute

Returns a Rectangle2D that encloses all of the bits rendered by this ImageGraphicAttribute, relative to the rendering position.

getBounds() - Method in class java.awt.font.ShapeGraphicAttribute

Returns a Rectangle2D that encloses all of the bits drawn by this ShapeGraphicAttribute relative to the rendering position.

getBounds() - Method in class java.awt.font.TextLayout

Returns the bounds of this TextLayout.

getBounds() - Method in class java.awt.geom.Area

Returns a bounding Rectangle that completely encloses this Area.

getBounds() - Method in class java.awt.geom.CubicCurve2D

Returns an integer Rectangle that completely encloses the Shape.

getBounds() - Method in class java.awt.geom.Line2D

Returns an integer Rectangle that completely encloses the Shape.

getBounds() - Method in class java.awt.geom.Path2D

Returns an integer Rectangle that completely encloses the Shape.

getBounds() - Method in class java.awt.geom.QuadCurve2D

Returns an integer Rectangle that completely encloses the Shape.

getBounds() - Method in class java.awt.geom.RectangularShape

Returns an integer Rectangle that completely encloses the Shape.

getBounds() - Method in class java.awt.GraphicsConfiguration

Returns the bounds of the GraphicsConfiguration in the device coordinates.

getBounds() - Method in class java.awt.image.Raster

Returns the bounding Rectangle of this Raster.

getBounds() - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Gets the bounds of this object in the form of a Rectangle object.

getBounds() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Gets the bounds of this object in the form of a Rectangle object.

getBounds() - Method in class java.awt.Polygon

Gets the bounding box of this Polygon.

getBounds() - Method in class java.awt.Rectangle

Gets the bounding Rectangle of this Rectangle.

getBounds() - Method in interface java.awt.Shape

Returns an integer Rectangle that completely encloses the Shape.

getBounds() - Method in class java.awt.SplashScreen

Returns the bounds of the splash screen window as a Rectangle.

getBounds() - Method in interface java.lang.reflect.TypeVariable

Returns an array of Type objects representing the upper bound(s) of this type variable.

getBounds() - Method in interface javax.accessibility.AccessibleComponent

Gets the bounds of this object in the form of a Rectangle object.

getBounds() - Method in interface javax.lang.model.element.TypeParameterElement

Returns the bounds of this type parameter.

getBounds() - Method in interface javax.lang.model.type.IntersectionType

Return the bounds comprising this intersection type.

getBounds(Rectangle) - Method in class javax.swing.JComponent

Stores the bounds of this component into "return value" rv and returns rv.

getBounds() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getBounds() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

getBounds() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

getBounds() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getBounds(TreePath, Rectangle) - Method in class javax.swing.tree.AbstractLayoutCache

Returns a rectangle giving the bounds needed to draw path.

getBounds(TreePath, Rectangle) - Method in class javax.swing.tree.FixedHeightLayoutCache

Returns a rectangle giving the bounds needed to draw path.

getBounds(TreePath, Rectangle) - Method in class javax.swing.tree.VariableHeightLayoutCache

Returns the Rectangle enclosing the label portion into which the item identified by path will be drawn.

getBounds2D() - Method in class java.awt.font.GlyphMetrics

Returns the bounds of the glyph.

getBounds2D() - Method in class java.awt.geom.Arc2D

Returns the high-precision framing rectangle of the arc.

getBounds2D() - Method in class java.awt.geom.Area

Returns a high precision bounding Rectangle2D that completely encloses this Area.

getBounds2D() - Method in class java.awt.geom.CubicCurve2D.Double

Returns a high precision and more accurate bounding box of the Shape than the getBounds method.

getBounds2D() - Method in class java.awt.geom.CubicCurve2D.Float

Returns a high precision and more accurate bounding box of the Shape than the getBounds method.

getBounds2D() - Method in class java.awt.geom.Ellipse2D.Double

Returns a high precision and more accurate bounding box of the Shape than the getBounds method.

getBounds2D() - Method in class java.awt.geom.Ellipse2D.Float

Returns a high precision and more accurate bounding box of the Shape than the getBounds method.

getBounds2D() - Method in class java.awt.geom.Line2D.Double

Returns a high precision and more accurate bounding box of the Shape than the getBounds method.

getBounds2D() - Method in class java.awt.geom.Line2D.Float

Returns a high precision and more accurate bounding box of the Shape than the getBounds method.

getBounds2D() - Method in class java.awt.geom.Path2D.Double

Returns a high precision and more accurate bounding box of the Shape than the getBounds method.

getBounds2D() - Method in class java.awt.geom.Path2D.Float

Returns a high precision and more accurate bounding box of the Shape than the getBounds method.

getBounds2D() - Method in class java.awt.geom.QuadCurve2D.Double

Returns a high precision and more accurate bounding box of the Shape than the getBounds method.

getBounds2D() - Method in class java.awt.geom.QuadCurve2D.Float

Returns a high precision and more accurate bounding box of the Shape than the getBounds method.

getBounds2D() - Method in class java.awt.geom.Rectangle2D.Double

Returns a high precision and more accurate bounding box of the Shape than the getBounds method.

getBounds2D() - Method in class java.awt.geom.Rectangle2D.Float

Returns a high precision and more accurate bounding box of the Shape than the getBounds method.

getBounds2D() - Method in class java.awt.geom.Rectangle2D

Returns a high precision and more accurate bounding box of the Shape than the getBounds method.

getBounds2D() - Method in class java.awt.geom.RoundRectangle2D.Double

Returns a high precision and more accurate bounding box of the Shape than the getBounds method.

getBounds2D() - Method in class java.awt.geom.RoundRectangle2D.Float

Returns a high precision and more accurate bounding box of the Shape than the getBounds method.

getBounds2D(BufferedImage) - Method in class java.awt.image.AffineTransformOp

Returns the bounding box of the transformed destination.

getBounds2D(Raster) - Method in class java.awt.image.AffineTransformOp

Returns the bounding box of the transformed destination.

getBounds2D(Raster) - Method in class java.awt.image.BandCombineOp

Returns the bounding box of the transformed destination.

getBounds2D(BufferedImage) - Method in interface java.awt.image.BufferedImageOp

Returns the bounding box of the filtered destination image.

getBounds2D(BufferedImage) - Method in class java.awt.image.ColorConvertOp

Returns the bounding box of the destination, given this source.

getBounds2D(Raster) - Method in class java.awt.image.ColorConvertOp

Returns the bounding box of the destination, given this source.

getBounds2D(BufferedImage) - Method in class java.awt.image.ConvolveOp

Returns the bounding box of the filtered destination image.

getBounds2D(Raster) - Method in class java.awt.image.ConvolveOp

Returns the bounding box of the filtered destination Raster.

getBounds2D(BufferedImage) - Method in class java.awt.image.LookupOp

Returns the bounding box of the filtered destination image.

getBounds2D(Raster) - Method in class java.awt.image.LookupOp

Returns the bounding box of the filtered destination Raster.

getBounds2D(Raster) - Method in interface java.awt.image.RasterOp

Returns the bounding box of the filtered destination Raster.

getBounds2D(ParameterBlock) - Method in interface java.awt.image.renderable.ContextualRenderedImageFactory

Returns the bounding box for the output of the operation, performed on a given set of sources, in rendering-independent space.

getBounds2D(BufferedImage) - Method in class java.awt.image.RescaleOp

Returns the bounding box of the rescaled destination image.

getBounds2D(Raster) - Method in class java.awt.image.RescaleOp

Returns the bounding box of the rescaled destination Raster.

getBounds2D() - Method in class java.awt.Polygon

Returns a high precision and more accurate bounding box of the Shape than the getBounds method.

getBounds2D() - Method in class java.awt.Rectangle

Returns a high precision and more accurate bounding box of the Shape than the getBounds method.

getBounds2D() - Method in interface java.awt.Shape

Returns a high precision and more accurate bounding box of the Shape than the getBounds method.

getBoundsAt(int) - Method in class javax.swing.JTabbedPane

Returns the tab bounds at index.

getBoundsForIconOf(JInternalFrame) - Method in class javax.swing.DefaultDesktopManager

The iconifyFrame() code calls this to determine the proper bounds for the desktopIcon.

getBox(Rectangle) - Method in class javax.swing.plaf.basic.BasicProgressBarUI

Stores the position and size of the bouncing box that would be painted for the current animation index in r and returns r.

getBox(Rectangle) - Method in class javax.swing.plaf.synth.SynthProgressBarUI

Stores the position and size of the bouncing box that would be painted for the current animation index in r and returns r.

getBoxLength(int, int) - Method in class javax.swing.plaf.basic.BasicProgressBarUI

Returns the length of the "bouncing box" to be painted.

getBoxPainter(AttributeSet) - Method in class javax.swing.text.html.StyleSheet

Fetches the box formatter to use for the given set of CSS attributes.

getBranchQualifier() - Method in interface javax.transaction.xa.Xid

Obtain the transaction branch identifier part of XID as an array of bytes.

getBreakLocation(Segment, FontMetrics, int, int, TabExpander, int) - Static method in class javax.swing.text.Utilities

Determine where to break the given text to fit within the given span.

getBreakWeight(int, float, float) - Method in class javax.swing.text.GlyphView

Determines how attractive a break opportunity in this view is.

getBreakWeight(int, float, float) - Method in class javax.swing.text.html.InlineView

Determines how attractive a break opportunity in this view is.

getBreakWeight(int, float) - Method in class javax.swing.text.ParagraphView

Gets the break weight for a given location.

getBreakWeight(int, float, float) - Method in class javax.swing.text.View

Determines how attractive a break opportunity in this view is.

getBroadcast() - Method in class java.net.DatagramSocket

Tests if SO_BROADCAST is enabled.

getBroadcast() - Method in class java.net.InterfaceAddress

Returns an InetAddress for the broadcast address for this InterfaceAddress.

getBubbles() - Method in interface org.w3c.dom.events.Event

Used to indicate whether or not an event is a bubbling event.

getBuffer() - Method in class java.io.StringWriter

Return the string buffer itself.

getBufferCapabilities() - Method in class java.awt.GraphicsConfiguration

Returns the buffering capabilities of this GraphicsConfiguration.

getBufferedImageOp() - Method in class java.awt.image.BufferedImageFilter

Returns the BufferedImageOp.

getBufferedImageType() - Method in class javax.imageio.ImageTypeSpecifier

Returns an int containing one of the enumerated constant values describing image formats from BufferedImage.

getBufferSize() - Method in interface javax.sound.sampled.DataLine

Obtains the maximum number of bytes of data that will fit in the data line's internal buffer.

getBufferStrategy() - Method in class java.awt.Canvas

Returns the BufferStrategy used by this component.

getBufferStrategy() - Method in class java.awt.Window

Returns the BufferStrategy used by this component.

getBuilder() - Method in class javax.xml.bind.annotation.W3CDomHandler

getBundle(String) - Static method in class java.util.ResourceBundle

Gets a resource bundle using the specified base name, the default locale, and the caller's class loader.

getBundle(String, ResourceBundle.Control) - Static method in class java.util.ResourceBundle

Returns a resource bundle using the specified base name, the default locale and the specified control.

getBundle(String, Locale) - Static method in class java.util.ResourceBundle

Gets a resource bundle using the specified base name and locale, and the caller's class loader.

getBundle(String, Locale, ResourceBundle.Control) - Static method in class java.util.ResourceBundle

Returns a resource bundle using the specified base name, target locale and control, and the caller's class loader.

getBundle(String, Locale, ClassLoader) - Static method in class java.util.ResourceBundle

Gets a resource bundle using the specified base name, locale, and class loader.

getBundle(String, Locale, ClassLoader, ResourceBundle.Control) - Static method in class java.util.ResourceBundle

Returns a resource bundle using the specified base name, target locale, class loader and control.

getBusy() - Method in interface org.w3c.dom.ls.LSParser

true if the LSParser is currently busy loading a document, otherwise false.

getButton() - Method in class java.awt.event.MouseEvent

Returns which, if any, of the mouse buttons has changed state.

getButton() - Method in interface org.w3c.dom.events.MouseEvent

During mouse events caused by the depression or release of a mouse button, button is used to indicate which mouse button changed state.

getButtonBorder() - Static method in class javax.swing.plaf.basic.BasicBorders

getButtonBorder() - Static method in class javax.swing.plaf.metal.MetalBorders

Returns a border instance for a JButton

getButtonCount() - Method in class javax.swing.ButtonGroup

Returns the number of buttons in the group.

getButtonPanel() - Method in class javax.swing.plaf.metal.MetalFileChooserUI

getButtons() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI

Returns the buttons to display from the JOptionPane the receiver is providing the look and feel for.

getButtonWidth() - Method in class javax.swing.plaf.metal.MetalScrollButton

getByAddress(String, byte[], NetworkInterface) - Static method in class java.net.Inet6Address

Create an Inet6Address in the exact manner of InetAddress.getByAddress(String,byte[]) except that the IPv6 scope_id is set to the value corresponding to the given interface for the address type specified in addr.

getByAddress(String, byte[], int) - Static method in class java.net.Inet6Address

Create an Inet6Address in the exact manner of InetAddress.getByAddress(String,byte[]) except that the IPv6 scope_id is set to the given numeric value.

getByAddress(String, byte[]) - Static method in class java.net.InetAddress

Creates an InetAddress based on the provided host name and IP address.

getByAddress(byte[]) - Static method in class java.net.InetAddress

Returns an InetAddress object given the raw IP address .

getByIndex(int) - Static method in class java.net.NetworkInterface

Get a network interface given its index.

getByInetAddress(InetAddress) - Static method in class java.net.NetworkInterface

Convenience method to search for a network interface that has the specified Internet Protocol (IP) address bound to it.

getByName(String) - Static method in class java.net.InetAddress

Determines the IP address of a host, given the host's name.

getByName(String) - Static method in class java.net.NetworkInterface

Searches for the network interface with the specified name.

getByte(Object, int) - Static method in class java.lang.reflect.Array

Returns the value of the indexed component in the specified array object, as a byte.

getByte(Object) - Method in class java.lang.reflect.Field

Gets the value of a static or instance byte field.

getByte(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC TINYINT parameter as a byte in the Java programming language.

getByte(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC TINYINT parameter as a byte in the Java programming language.

getByte(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a byte in the Java programming language.

getByte(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a byte in the Java programming language.

getByteArray(String, byte[]) - Method in class java.util.prefs.AbstractPreferences

Implements the getByteArray method as per the specification in Preferences.getByteArray(String,byte[]).

getByteArray(String, byte[]) - Method in class java.util.prefs.Preferences

Returns the byte array value represented by the string associated with the specified key in this preference node.

getByteLength() - Method in class javax.sound.midi.MidiFileFormat

Obtains the length of the MIDI file, expressed in 8-bit bytes.

getByteLength() - Method in class javax.sound.sampled.AudioFileFormat

Obtains the size in bytes of the entire audio file (not just its audio data).

getByteOffset() - Method in interface org.w3c.dom.DOMLocator

The byte offset into the input source this locator is pointing to or -1 if there is no byte offset available.

getByteOrder() - Method in interface javax.imageio.stream.ImageInputStream

Returns the byte order with which data values will be read from this stream as an instance of the java.nio.ByteOrder enumeration.

getByteOrder() - Method in class javax.imageio.stream.ImageInputStreamImpl

getByteParameter(int) - Method in class java.awt.image.renderable.ParameterBlock

A convenience method to return a parameter as a byte.

getBytes(int, int, byte[], int) - Method in class java.lang.String

Deprecated.
This method does not properly convert characters into bytes. As of JDK 1.1, the preferred way to do this is via the String.getBytes() method, which uses the platform's default charset.

getBytes(String) - Method in class java.lang.String

Encodes this String into a sequence of bytes using the named charset, storing the result into a new byte array.

getBytes(Charset) - Method in class java.lang.String

Encodes this String into a sequence of bytes using the given charset, storing the result into a new byte array.

getBytes() - Method in class java.lang.String

Encodes this String into a sequence of bytes using the platform's default charset, storing the result into a new byte array.

getBytes(long, int) - Method in interface java.sql.Blob

Retrieves all or part of the BLOB value that this Blob object represents, as an array of bytes.

getBytes(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC BINARY or VARBINARY parameter as an array of byte values in the Java programming language.

getBytes(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC BINARY or VARBINARY parameter as an array of byte values in the Java programming language.

getBytes(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a byte array in the Java programming language.

getBytes(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a byte array in the Java programming language.

getBytes() - Method in interface java.sql.RowId

Returns an array of bytes representing the value of the SQL ROWID designated by this java.sql.RowId object.

getBytes(long, int) - Method in class javax.sql.rowset.serial.SerialBlob

Copies the specified number of bytes, starting at the given position, from this SerialBlob object to another array of bytes.

getBytesRead() - Method in class java.util.zip.Deflater

Returns the total number of uncompressed bytes input so far.

getBytesRead() - Method in class java.util.zip.Inflater

Returns the total number of compressed bytes input so far.

getByteStream() - Method in interface org.w3c.dom.ls.LSInput

An attribute of a language and binding dependent type that represents a stream of bytes.

getByteStream() - Method in interface org.w3c.dom.ls.LSOutput

An attribute of a language and binding dependent type that represents a writable stream of bytes.

getByteStream() - Method in class org.xml.sax.InputSource

Get the byte stream for this input source.

getBytesWritten() - Method in class java.util.zip.Deflater

Returns the total number of compressed bytes output so far.

getBytesWritten() - Method in class java.util.zip.Inflater

Returns the total number of uncompressed bytes output so far.

getCA() - Method in class java.security.cert.TrustAnchor

Returns the name of the most-trusted CA as an X500Principal.

getCachedIcon(File) - Method in class javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView

getCacheDirectory() - Static method in class javax.imageio.ImageIO

Returns the current value set by setCacheDirectory, or null if no explicit setting has been made.

getCachedMBeanInfo() - Method in class javax.management.StandardMBean

Customization hook: Return the MBeanInfo cached for this object.

getCalculatedDigestValue() - Method in interface javax.xml.crypto.dsig.Reference

Returns the calculated digest value of this Reference after a validation operation.

getCalendar() - Method in class java.text.DateFormat

Gets the calendar associated with this date/time formatter.

getCalendarField() - Method in class java.text.DateFormat.Field

Returns the Calendar field associated with this attribute.

getCalendarField() - Method in class javax.swing.SpinnerDateModel

Returns the Calendar field that is added to or subtracted from by the nextValue and previousValue methods.

getCalendarType() - Method in interface java.time.chrono.Chronology

Gets the calendar type of the calendar system.

getCalendarType() - Method in class java.time.chrono.HijrahChronology

Gets the calendar type of the Islamic calendar.

getCalendarType() - Method in class java.time.chrono.IsoChronology

Gets the calendar type of the underlying calendar system - 'iso8601'.

getCalendarType() - Method in class java.time.chrono.JapaneseChronology

Gets the calendar type of the underlying calendar system - 'japanese'.

getCalendarType() - Method in class java.time.chrono.MinguoChronology

Gets the calendar type of the underlying calendar system - 'roc'.

getCalendarType() - Method in class java.time.chrono.ThaiBuddhistChronology

Gets the calendar type of the underlying calendar system - 'buddhist'.

getCalendarType() - Method in class java.util.Calendar

Returns the calendar type of this Calendar.

getCalendarType() - Method in class java.util.GregorianCalendar

Returns "gregory" as the calendar type.

getCallback() - Method in exception javax.security.auth.callback.UnsupportedCallbackException

Get the unrecognized Callback.

getCallbackHandler() - Method in class java.security.KeyStore.CallbackHandlerProtection

Returns the CallbackHandler.

getCAName() - Method in class java.security.cert.TrustAnchor

Returns the name of the most-trusted CA in RFC 2253 String format.

getCancelable() - Method in interface org.w3c.dom.events.Event

Used to indicate whether or not an event can have its default action prevented.

getCancelSelectionAction() - Method in class javax.swing.plaf.basic.BasicFileChooserUI

getCandidateLocales(String, Locale) - Method in class java.util.ResourceBundle.Control

Returns a List of Locales as candidate locales for baseName and locale.

getCanonicalFile() - Method in class java.io.File

Returns the canonical form of this abstract pathname.

getCanonicalHostName() - Method in class java.net.InetAddress

Gets the fully qualified domain name for this IP address.

getCanonicalizationMethod() - Method in interface javax.xml.crypto.dsig.SignedInfo

Returns the canonicalization method of this SignedInfo.

getCanonicalizedData() - Method in interface javax.xml.crypto.dsig.SignedInfo

Returns the canonicalized signed info bytes after a signing or validation operation.

getCanonicalKeyPropertyListString() - Method in class javax.management.ObjectName

Returns a string representation of the list of key properties, in which the key properties are sorted in lexical order.

getCanonicalName() - Method in class java.lang.Class

Returns the canonical name of the underlying class as defined by the Java Language Specification.

getCanonicalName() - Method in class javax.management.ObjectName

Returns the canonical form of the name; that is, a string representation where the properties are sorted in lexical order.

getCanonicalPath() - Method in class java.io.File

Returns the canonical pathname string of this abstract pathname.

getCanWrapLines() - Method in class javax.swing.text.AbstractWriter

Returns whether or not the lines can be wrapped.

getCapabilities() - Method in class java.awt.Component.BltBufferStrategy

getCapabilities() - Method in class java.awt.Component.FlipBufferStrategy

getCapabilities() - Method in class java.awt.image.BufferStrategy

Returns the BufferCapabilities for this BufferStrategy.

getCapabilities(GraphicsConfiguration) - Method in class java.awt.Image

Returns an ImageCapabilities object which can be inquired as to the capabilities of this Image on the specified GraphicsConfiguration.

getCapabilities() - Method in class java.awt.image.VolatileImage

Returns an ImageCapabilities object which can be inquired as to the specific capabilities of this VolatileImage.

getCapturedArg(int) - Method in class java.lang.invoke.SerializedLambda

Get a dynamic argument to the lambda capture site.

getCapturedArgCount() - Method in class java.lang.invoke.SerializedLambda

Get the count of dynamic arguments to the lambda capture site.

getCapturingClass() - Method in class java.lang.invoke.SerializedLambda

Get the name of the class that captured this lambda.

getCAPublicKey() - Method in class java.security.cert.TrustAnchor

Returns the public key of the most-trusted CA.

getCaret() - Method in class java.awt.event.InputMethodEvent

Gets the caret.

getCaret() - Method in class javax.swing.text.JTextComponent

Fetches the caret that allows text-oriented navigation over the view.

getCaret() - Method in class javax.swing.text.NavigationFilter.FilterBypass

Returns the Caret that is changing.

getCaretColor() - Method in class javax.swing.text.JTextComponent

Fetches the current color used to render the caret.

getCaretInfo(TextHitInfo, Rectangle2D) - Method in class java.awt.font.TextLayout

Returns information about the caret corresponding to hit.

getCaretInfo(TextHitInfo) - Method in class java.awt.font.TextLayout

Returns information about the caret corresponding to hit.

getCaretListeners() - Method in class javax.swing.text.JTextComponent

Returns an array of all the caret listeners registered on this text component.

getCaretPosition() - Method in class java.awt.TextComponent.AccessibleAWTTextComponent

Returns the zero-based offset of the caret.

getCaretPosition() - Method in class java.awt.TextComponent

Returns the position of the text insertion caret.

getCaretPosition() - Method in interface javax.accessibility.AccessibleText

Returns the zero-based offset of the caret.

getCaretPosition() - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Return the zero-based offset of the caret.

getCaretPosition() - Method in class javax.swing.JLabel.AccessibleJLabel

Return the zero-based offset of the caret.

getCaretPosition() - Method in class javax.swing.JSpinner.AccessibleJSpinner

Returns the zero-based offset of the caret.

getCaretPosition() - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Returns the zero-based offset of the caret.

getCaretPosition() - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Returns the zero-based offset of the caret.

getCaretPosition() - Method in class javax.swing.text.JTextComponent

Returns the position of the text insertion caret for the text component.

getCaretShape(TextHitInfo, Rectangle2D) - Method in class java.awt.font.TextLayout

Returns a Shape representing the caret at the specified hit inside the specified bounds.

getCaretShape(TextHitInfo) - Method in class java.awt.font.TextLayout

Returns a Shape representing the caret at the specified hit inside the natural bounds of this TextLayout.

getCaretShapes(int, Rectangle2D, TextLayout.CaretPolicy) - Method in class java.awt.font.TextLayout

Returns two paths corresponding to the strong and weak caret.

getCaretShapes(int, Rectangle2D) - Method in class java.awt.font.TextLayout

Returns two paths corresponding to the strong and weak caret.

getCaretShapes(int) - Method in class java.awt.font.TextLayout

Returns two paths corresponding to the strong and weak caret.

getCatalog() - Method in interface java.sql.Connection

Retrieves this Connection object's current catalog name.

getCatalogName(int) - Method in interface java.sql.ResultSetMetaData

Gets the designated column's table's catalog name.

getCatalogName(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Retrieves the catalog name of the table from which the value in the designated column was derived.

getCatalogs() - Method in interface java.sql.DatabaseMetaData

Retrieves the catalog names available in this database.

getCatalogSeparator() - Method in interface java.sql.DatabaseMetaData

Retrieves the String that this database uses as the separator between a catalog and table name.

getCatalogTerm() - Method in interface java.sql.DatabaseMetaData

Retrieves the database vendor's preferred term for "catalog".

getCategories() - Method in class javax.imageio.spi.ServiceRegistry

Returns an Iterator of Class objects indicating the current set of categories.

getCategory() - Method in interface javax.print.attribute.Attribute

Get the printing attribute class which is to be used as the "category" for this printing attribute value when it is added to an attribute set.

getCategory() - Method in class javax.print.attribute.standard.Chromaticity

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.ColorSupported

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.Compression

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.Copies

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.CopiesSupported

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.DateTimeAtCompleted

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.DateTimeAtCreation

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.DateTimeAtProcessing

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.Destination

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.DialogTypeSelection

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.DocumentName

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.Fidelity

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.Finishings

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.JobHoldUntil

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.JobImpressions

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.JobImpressionsCompleted

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.JobImpressionsSupported

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.JobKOctets

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.JobKOctetsProcessed

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.JobKOctetsSupported

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.JobMediaSheets

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.JobMediaSheetsCompleted

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.JobMediaSheetsSupported

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.JobMessageFromOperator

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.JobName

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.JobOriginatingUserName

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.JobPriority

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.JobPrioritySupported

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.JobSheets

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.JobState

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.JobStateReason

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.JobStateReasons

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.Media

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.MediaPrintableArea

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.MediaSize

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.MultipleDocumentHandling

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.NumberOfDocuments

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.NumberOfInterveningJobs

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.NumberUp

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.NumberUpSupported

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.OrientationRequested

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.OutputDeviceAssigned

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.PageRanges

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.PagesPerMinute

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.PagesPerMinuteColor

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.PDLOverrideSupported

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.PresentationDirection

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.PrinterInfo

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.PrinterIsAcceptingJobs

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.PrinterLocation

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.PrinterMakeAndModel

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.PrinterMessageFromOperator

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.PrinterMoreInfo

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.PrinterMoreInfoManufacturer

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.PrinterName

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.PrinterResolution

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.PrinterState

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.PrinterStateReason

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.PrinterStateReasons

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.PrinterURI

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.PrintQuality

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.QueuedJobCount

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.ReferenceUriSchemesSupported

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.RequestingUserName

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.Severity

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.SheetCollate

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCategory() - Method in class javax.print.attribute.standard.Sides

Get the printing attribute class which is to be used as the "category" for this printing attribute value.

getCause() - Method in exception java.awt.print.PrinterIOException

Returns the the cause of this exception (the IOException that terminated the print job).

getCause() - Method in exception java.io.UncheckedIOException

Returns the cause of this exception.

getCause() - Method in exception java.io.WriteAbortedException

Returns the exception that terminated the operation (the cause).

getCause() - Method in exception java.lang.ClassNotFoundException

Returns the cause of this exception (the exception that was raised if an error occurred while attempting to load the class; otherwise null).

getCause() - Method in error java.lang.ExceptionInInitializerError

Returns the cause of this error (the exception that occurred during a static initialization that caused this error to be created).

getCause() - Method in exception java.lang.reflect.InvocationTargetException

Returns the cause of this exception (the thrown target exception, which may be null).

getCause() - Method in exception java.lang.reflect.UndeclaredThrowableException

Returns the cause of this exception (the Throwable instance wrapped in this UndeclaredThrowableException, which may be null).

getCause() - Method in class java.lang.Throwable

Returns the cause of this throwable or null if the cause is nonexistent or unknown.

getCause() - Method in exception java.nio.file.DirectoryIteratorException

Returns the cause of this exception.

getCause() - Method in exception java.rmi.activation.ActivationException

Returns the cause of this exception.

getCause() - Method in exception java.rmi.RemoteException

Returns the cause of this exception.

getCause() - Method in exception java.rmi.server.ServerCloneException

Returns the cause of this exception.

getCause() - Method in exception java.security.PrivilegedActionException

Returns the cause of this exception (the exception thrown by the privileged computation that resulted in this PrivilegedActionException).

getCause() - Method in exception javax.management.MBeanException

Return the actual Exception thrown.

getCause() - Method in exception javax.management.ReflectionException

Returns the actual Exception thrown.

getCause() - Method in exception javax.management.remote.JMXProviderException

getCause() - Method in exception javax.management.remote.JMXServerErrorException

getCause() - Method in exception javax.management.RuntimeErrorException

Returns the actual Error thrown.

getCause() - Method in exception javax.management.RuntimeMBeanException

Returns the actual RuntimeException thrown.

getCause() - Method in exception javax.management.RuntimeOperationsException

Returns the actual RuntimeException thrown.

getCause() - Method in exception javax.naming.NamingException

Returns the cause of this exception.

getCause() - Method in exception javax.security.sasl.SaslException

getCause() - Method in exception javax.xml.bind.JAXBException

getCause() - Method in exception javax.xml.crypto.dsig.TransformException

Returns the cause of this TransformException or null if the cause is nonexistent or unknown.

getCause() - Method in exception javax.xml.crypto.dsig.XMLSignatureException

Returns the cause of this XMLSignatureException or null if the cause is nonexistent or unknown.

getCause() - Method in exception javax.xml.crypto.KeySelectorException

Returns the cause of this KeySelectorException or null if the cause is nonexistent or unknown.

getCause() - Method in exception javax.xml.crypto.MarshalException

Returns the cause of this MarshalException or null if the cause is nonexistent or unknown.

getCause() - Method in exception javax.xml.crypto.NoSuchMechanismException

Returns the cause of this NoSuchMechanismException or null if the cause is nonexistent or unknown.

getCause() - Method in exception javax.xml.crypto.URIReferenceException

Returns the cause of this URIReferenceException or null if the cause is nonexistent or unknown.

getCause() - Method in error javax.xml.parsers.FactoryConfigurationError

use the exception chaining mechanism of JDK1.4

getCause() - Method in exception javax.xml.soap.SOAPException

Returns the Throwable object embedded in this SOAPException if there is one.

getCause() - Method in error javax.xml.stream.FactoryConfigurationError

use the exception chaining mechanism of JDK1.4

getCause() - Method in exception javax.xml.transform.TransformerException

Returns the cause of this throwable or null if the cause is nonexistent or unknown.

getCause() - Method in error javax.xml.transform.TransformerFactoryConfigurationError

use the exception chaining mechanism of JDK1.4

getCause() - Method in exception javax.xml.xpath.XPathException

Get the cause of this XPathException.

getCause() - Method in exception org.xml.sax.SAXException

Return the cause of the exception

getCellBounds(int, int) - Method in class javax.swing.JList

Returns the bounding rectangle, in the list's coordinate system, for the range of cells specified by the two indices.

getCellBounds(JList, int, int) - Method in class javax.swing.plaf.basic.BasicListUI

Returns the bounding rectangle, in the given list's coordinate system, for the range of cells specified by the two indices.

getCellBounds(JList, int, int) - Method in class javax.swing.plaf.ListUI

Returns the bounding rectangle, in the given list's coordinate system, for the range of cells specified by the two indices.

getCellBounds(JList, int, int) - Method in class javax.swing.plaf.multi.MultiListUI

Invokes the getCellBounds method on each UI handled by this object.

getCellEditor() - Method in class javax.swing.JTable

Returns the active cell editor, which is null if the table is not currently editing.

getCellEditor(int, int) - Method in class javax.swing.JTable

Returns an appropriate editor for the cell specified by row and column.

getCellEditor() - Method in class javax.swing.JTree

Returns the editor used to edit entries in the tree.

getCellEditor() - Method in class javax.swing.plaf.basic.BasicTreeUI

getCellEditor() - Method in class javax.swing.table.TableColumn

Returns the TableCellEditor used by the JTable to edit values for this column.

getCellEditorListeners() - Method in class javax.swing.AbstractCellEditor

Returns an array of all the CellEditorListeners added to this AbstractCellEditor with addCellEditorListener().

getCellEditorListeners() - Method in class javax.swing.tree.DefaultTreeCellEditor

Returns an array of all the CellEditorListeners added to this DefaultTreeCellEditor with addCellEditorListener().

getCellEditorValue() - Method in interface javax.swing.CellEditor

Returns the value contained in the editor.

getCellEditorValue() - Method in class javax.swing.DefaultCellEditor.EditorDelegate

Returns the value of this cell.

getCellEditorValue() - Method in class javax.swing.DefaultCellEditor

Forwards the message from the CellEditor to the delegate.

getCellEditorValue() - Method in class javax.swing.tree.DefaultTreeCellEditor

Returns the value currently being edited.

getCellLength() - Method in class javax.swing.plaf.basic.BasicProgressBarUI

Returns the width (if HORIZONTAL) or height (if VERTICAL) of each of the individual cells/units to be rendered in the progress bar.

getCellRect(int, int, boolean) - Method in class javax.swing.JTable

Returns a rectangle for the cell that lies at the intersection of row and column.

getCellRenderer() - Method in class javax.swing.JList

Returns the object responsible for painting list items.

getCellRenderer(int, int) - Method in class javax.swing.JTable

Returns an appropriate renderer for the cell specified by this row and column.

getCellRenderer() - Method in class javax.swing.JTree

Returns the current TreeCellRenderer that is rendering each cell.

getCellRenderer() - Method in class javax.swing.plaf.basic.BasicTreeUI

Return currentCellRenderer, which will either be the trees renderer, or defaultCellRenderer, which ever wasn't null.

getCellRenderer() - Method in class javax.swing.table.TableColumn

Returns the TableCellRenderer used by the JTable to draw values for this column.

getCellSelectionEnabled() - Method in class javax.swing.JTable

Returns true if both row and column selection models are enabled.

getCellSpacing() - Method in class javax.swing.plaf.basic.BasicProgressBarUI

Returns the spacing between each of the cells/units in the progress bar.

getCenterPoint() - Method in class java.awt.GraphicsEnvironment

Returns the Point where Windows should be centered.

getCenterPoint() - Method in class java.awt.RadialGradientPaint

Returns a copy of the center point of the radial gradient.

getCentersChildren() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout

getCenterX() - Method in class java.awt.geom.RectangularShape

Returns the X coordinate of the center of the framing rectangle of the Shape in double precision.

getCenterY() - Method in class java.awt.geom.RectangularShape

Returns the Y coordinate of the center of the framing rectangle of the Shape in double precision.

getCertificate() - Method in class java.security.cert.X509CertSelector

Returns the certificateEquals criterion.

getCertificate(String) - Method in class java.security.KeyStore

Returns the certificate associated with the given alias.

getCertificate() - Method in class java.security.KeyStore.PrivateKeyEntry

Gets the end entity Certificate from the certificate chain in this entry.

getCertificate() - Method in class javax.security.auth.x500.X500PrivateCredential

Returns the X.509 certificate.

getCertificateAlias(Certificate) - Method in class java.security.KeyStore

Returns the (alias) name of the first keystore entry whose certificate matches the given certificate.

getCertificateChain(String) - Method in class java.security.KeyStore

Returns the certificate chain associated with the given alias.

getCertificateChain() - Method in class java.security.KeyStore.PrivateKeyEntry

Gets the Certificate chain from this entry.

getCertificateChain(String) - Method in interface javax.net.ssl.X509KeyManager

Returns the certificate chain associated with the given alias.

getCertificateChecking() - Method in class java.security.cert.X509CRLSelector

Returns the certificate being checked.

getCertificateIssuer() - Method in class java.security.cert.X509CRLEntry

Get the issuer of the X509Certificate described by this entry.

getCertificates() - Method in class java.net.JarURLConnection

Return the Certificate object for this connection if the URL for it points to a JAR file entry, null otherwise.

getCertificates() - Method in class java.security.cert.CertPath

Returns the list of certificates in this certification path.

getCertificates(CertSelector) - Method in class java.security.cert.CertStore

Returns a Collection of Certificates that match the specified selector.

getCertificates() - Method in class java.security.CodeSource

Returns the certificates associated with this CodeSource.

getCertificates() - Method in class java.util.jar.JarEntry

Returns the Certificate objects for this entry, or null if none.

getCertificateValid() - Method in class java.security.cert.X509CertSelector

Returns the certificateValid criterion.

getCertifiedText() - Method in interface org.w3c.dom.ls.LSInput

If set to true, assume that the input is certified (see section 2.13 in [XML 1.1]) when parsing [XML 1.1].

getCertPath() - Method in interface java.security.cert.CertPathBuilderResult

Returns the built certification path.

getCertPath() - Method in exception java.security.cert.CertPathValidatorException

Returns the certification path that was being validated when the exception was thrown.

getCertPath() - Method in class java.security.cert.PKIXCertPathBuilderResult

Returns the built and validated certification path.

getCertPathCheckers() - Method in class java.security.cert.PKIXParameters

Returns the List of certification path checkers.

getCertPathEncodings() - Method in class java.security.cert.CertificateFactory

Returns an iteration of the CertPath encodings supported by this certificate factory, with the default encoding first.

getCertStoreParameters() - Method in class java.security.cert.CertStore

Returns the parameters used to initialize this CertStore.

getCertStores() - Method in class java.security.cert.PKIXParameters

Returns an immutable List of CertStores that are used to find certificates and CRLs.

getChange(Element) - Method in interface javax.swing.event.DocumentEvent

Gets the change information for the given element.

getChange(Element) - Method in class javax.swing.text.AbstractDocument.DefaultDocumentEvent

Gets the changes for an element.

getChanged() - Method in class java.awt.event.HierarchyEvent

Returns the Component at the top of the hierarchy which was changed.

getChangedParent() - Method in class java.awt.event.HierarchyEvent

Returns the parent of the Component returned by getChanged().

getChangeFlags() - Method in class java.awt.event.HierarchyEvent

Returns a bitmask which indicates the type(s) of HIERARCHY_CHANGED events represented in this event object.

getChangeInfo() - Method in class javax.naming.event.NamingEvent

Retrieves the change information for this event.

getChangeListeners() - Method in class javax.swing.AbstractButton

Returns an array of all the ChangeListeners added to this AbstractButton with addChangeListener().

getChangeListeners() - Method in class javax.swing.AbstractSpinnerModel

Returns an array of all the ChangeListeners added to this AbstractSpinnerModel with addChangeListener().

getChangeListeners() - Method in class javax.swing.colorchooser.DefaultColorSelectionModel

Returns an array of all the ChangeListeners added to this DefaultColorSelectionModel with addChangeListener.

getChangeListeners() - Method in class javax.swing.DefaultBoundedRangeModel

Returns an array of all the change listeners registered on this DefaultBoundedRangeModel.

getChangeListeners() - Method in class javax.swing.DefaultButtonModel

Returns an array of all the change listeners registered on this DefaultButtonModel.

getChangeListeners() - Method in class javax.swing.DefaultSingleSelectionModel

Returns an array of all the change listeners registered on this DefaultSingleSelectionModel.

getChangeListeners() - Method in class javax.swing.JProgressBar

Returns an array of all the ChangeListeners added to this progress bar with addChangeListener.

getChangeListeners() - Method in class javax.swing.JSlider

Returns an array of all the ChangeListeners added to this JSlider with addChangeListener().

getChangeListeners() - Method in class javax.swing.JSpinner

Returns an array of all the ChangeListeners added to this JSpinner with addChangeListener().

getChangeListeners() - Method in class javax.swing.JTabbedPane

Returns an array of all the ChangeListeners added to this JTabbedPane with addChangeListener.

getChangeListeners() - Method in class javax.swing.JViewport

Returns an array of all the ChangeListeners added to this JViewport with addChangeListener().

getChangeListeners() - Method in class javax.swing.MenuSelectionManager

Returns an array of all the ChangeListeners added to this MenuSelectionManager with addChangeListener().

getChangeListeners() - Method in class javax.swing.text.DefaultCaret

Returns an array of all the change listeners registered on this caret.

getChangeListeners() - Method in class javax.swing.text.StyleContext

Returns an array of all the ChangeListeners added to this StyleContext with addChangeListener().

getChangeListeners() - Method in class javax.swing.text.StyleContext.NamedStyle

Returns an array of all the ChangeListeners added to this NamedStyle with addChangeListener().

getChangeToParentDirectoryAction() - Method in class javax.swing.plaf.basic.BasicFileChooserUI

getChannel() - Method in class java.io.FileInputStream

Returns the unique FileChannel object associated with this file input stream.

getChannel() - Method in class java.io.FileOutputStream

Returns the unique FileChannel object associated with this file output stream.

getChannel() - Method in class java.io.RandomAccessFile

Returns the unique FileChannel object associated with this file.

getChannel() - Method in class java.net.DatagramSocket

Returns the unique DatagramChannel object associated with this datagram socket, if any.

getChannel() - Method in class java.net.ServerSocket

Returns the unique ServerSocketChannel object associated with this socket, if any.

getChannel() - Method in class java.net.Socket

Returns the unique SocketChannel object associated with this socket, if any.

getChannel() - Method in class javax.sound.midi.ShortMessage

Obtains the MIDI channel associated with this event.

getChannelPressure() - Method in interface javax.sound.midi.MidiChannel

Obtains the channel's keyboard pressure.

getChannels() - Method in interface javax.sound.midi.Synthesizer

Obtains the set of MIDI channels controlled by this synthesizer.

getChannels() - Method in class javax.sound.sampled.AudioFormat

Obtains the number of channels.

getChar(Object, int) - Static method in class java.lang.reflect.Array

Returns the value of the indexed component in the specified array object, as a char.

getChar(Object) - Method in class java.lang.reflect.Field

Gets the value of a static or instance field of type char or of another primitive type convertible to type char via a widening conversion.

getChar() - Method in class java.nio.ByteBuffer

Relative get method for reading a char value.

getChar(int) - Method in class java.nio.ByteBuffer

Absolute get method for reading a char value.

getCharacterAttribute(int) - Method in class java.awt.TextComponent.AccessibleAWTTextComponent

Returns the AttributeSet for a given character (at a given index).

getCharacterAttribute(int) - Method in interface javax.accessibility.AccessibleText

Returns the AttributeSet for a given character at a given index

getCharacterAttribute(int) - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Return the AttributeSet for a given character at a given index

getCharacterAttribute(int) - Method in class javax.swing.JLabel.AccessibleJLabel

Return the AttributeSet for a given character at a given index

getCharacterAttribute(int) - Method in class javax.swing.JSpinner.AccessibleJSpinner

Returns the AttributeSet for a given character at a given index

getCharacterAttribute(int) - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Returns the AttributeSet for a given character at a given index

getCharacterAttribute(int) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Returns the AttributeSet for a given character (at a given index).

getCharacterAttributeRun() - Method in class javax.swing.text.StyledEditorKit

Fetches the element representing the current run of character attributes for the caret.

getCharacterAttributes() - Method in class javax.swing.JTextPane

Fetches the character attributes in effect at the current location of the caret, or null.

getCharacterBounds(int) - Method in class java.awt.TextComponent.AccessibleAWTTextComponent

Determines the bounding box of the character at the given index into the string.

getCharacterBounds(int) - Method in interface javax.accessibility.AccessibleText

Determines the bounding box of the character at the given index into the string.

getCharacterBounds(int) - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Determine the bounding box of the character at the given index into the string.

getCharacterBounds(int) - Method in class javax.swing.JLabel.AccessibleJLabel

Returns the bounding box of the character at the given index in the string.

getCharacterBounds(int) - Method in class javax.swing.JSpinner.AccessibleJSpinner

Determines the bounding box of the character at the given index into the string.

getCharacterBounds(int) - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Determines the bounding box of the character at the given index into the string.

getCharacterBounds(int) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Determines the bounding box of the character at the given index into the string.

getCharacterCount() - Method in class java.awt.font.TextLayout

Returns the number of characters represented by this TextLayout.

getCharacterElement(int) - Method in class javax.swing.text.DefaultStyledDocument

Gets a character element based on a position.

getCharacterElement(int) - Method in interface javax.swing.text.StyledDocument

Gets the element that represents the character that is at the given offset within the document.

getCharacterEncodingScheme() - Method in interface javax.xml.stream.events.StartDocument

Returns the encoding style of the XML data

getCharacterEncodingScheme() - Method in class javax.xml.stream.util.StreamReaderDelegate

getCharacterEncodingScheme() - Method in interface javax.xml.stream.XMLStreamReader

Returns the character encoding declared on the xml declaration Returns null if none was declared

getCharacterInstance() - Static method in class java.text.BreakIterator

Returns a new BreakIterator instance for character breaks for the default locale.

getCharacterInstance(Locale) - Static method in class java.text.BreakIterator

Returns a new BreakIterator instance for character breaks for the given locale.

getCharacterInstance(Locale) - Method in class java.text.spi.BreakIteratorProvider

Returns a new BreakIterator instance for character breaks for the given locale.

getCharacterLevel(int) - Method in class java.awt.font.TextLayout

Returns the level of the character at index.

getCharacterOffset() - Method in interface javax.xml.stream.Location

Return the byte or character offset into the input source this location is pointing to.

getCharacterStream(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated parameter as a java.io.Reader object in the Java programming language.

getCharacterStream(String) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated parameter as a java.io.Reader object in the Java programming language.

getCharacterStream() - Method in interface java.sql.Clob

Retrieves the CLOB value designated by this Clob object as a java.io.Reader object (or as a stream of characters).

getCharacterStream(long, long) - Method in interface java.sql.Clob

Returns a Reader object that contains a partial Clob value, starting with the character specified by pos, which is length characters in length.

getCharacterStream(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.io.Reader object.

getCharacterStream(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.io.Reader object.

getCharacterStream() - Method in interface java.sql.SQLXML

Retrieves the XML value designated by this SQLXML instance as a java.io.Reader object.

getCharacterStream() - Method in class javax.sql.rowset.serial.SerialClob

Returns this SerialClob object's data as a stream of Unicode characters.

getCharacterStream(long, long) - Method in class javax.sql.rowset.serial.SerialClob

Returns a Reader object that contains a partial SerialClob value, starting with the character specified by pos, which is length characters in length.

getCharacterStream() - Method in interface org.w3c.dom.ls.LSInput

An attribute of a language and binding dependent type that represents a stream of 16-bit units.

getCharacterStream() - Method in interface org.w3c.dom.ls.LSOutput

An attribute of a language and binding dependent type that represents a writable stream to which 16-bit units can be output.

getCharacterStream() - Method in class org.xml.sax.InputSource

Get the character stream for this input source.

getCharContent(boolean) - Method in interface javax.tools.FileObject

Gets the character content of this file object, if available.

getCharContent(boolean) - Method in class javax.tools.ForwardingFileObject

getCharContent(boolean) - Method in class javax.tools.SimpleJavaFileObject

This implementation always throws UnsupportedOperationException.

getCharCount() - Method in class java.awt.TextComponent.AccessibleAWTTextComponent

Returns the number of characters (valid indicies)

getCharCount() - Method in interface javax.accessibility.AccessibleText

Returns the number of characters (valid indicies)

getCharCount() - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Return the number of characters (valid indicies)

getCharCount() - Method in class javax.swing.JLabel.AccessibleJLabel

Return the number of characters (valid indicies)

getCharCount() - Method in class javax.swing.JSpinner.AccessibleJSpinner

Returns the number of characters (valid indicies)

getCharCount() - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Returns the number of characters (valid indicies)

getCharCount() - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Returns the number of characters (valid indices)

getCharIndex() - Method in class java.awt.font.TextHitInfo

Returns the index of the character hit.

getCharParameter(int) - Method in class java.awt.image.renderable.ParameterBlock

A convenience method to return a parameter as a char.

getChars(int, int, char[], int) - Method in class java.lang.String

Copies characters from this string into the destination character array.

getChars(int, int, char[], int) - Method in class java.lang.StringBuffer

getChars(int, int, Segment) - Method in interface javax.swing.text.AbstractDocument.Content

Gets a sequence of characters and copies them into a Segment.

getChars(int, int, Segment) - Method in class javax.swing.text.GapContent

Retrieves a portion of the content.

getChars(int, int, Segment) - Method in class javax.swing.text.StringContent

Retrieves a portion of the content.

getCharsetName() - Method in exception java.nio.charset.IllegalCharsetNameException

Retrieves the illegal charset name.

getCharsetName() - Method in exception java.nio.charset.UnsupportedCharsetException

Retrieves the name of the unsupported charset.

getCharSetSpec() - Method in exception javax.swing.text.ChangedCharSetException

getCheckboxGroup() - Method in class java.awt.Checkbox

Determines this check box's group.

getCheckBoxIcon() - Static method in class javax.swing.plaf.basic.BasicIconFactory

getCheckBoxIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

Returns a checkbox icon.

getCheckBoxMenuItemIcon() - Static method in class javax.swing.plaf.basic.BasicIconFactory

getCheckBoxMenuItemIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

getChecksum() - Method in class java.util.zip.CheckedInputStream

Returns the Checksum for this input stream.

getChecksum() - Method in class java.util.zip.CheckedOutputStream

Returns the Checksum for this output stream.

getChild() - Method in class java.awt.event.ContainerEvent

Returns the component that was affected by the event.

getChild(String) - Method in class java.util.prefs.AbstractPreferences

Returns the named child if it exists, or null if it does not.

getChild() - Method in class java.util.prefs.NodeChangeEvent

Returns the node that was added or removed.

getChild(File, String) - Method in class javax.swing.filechooser.FileSystemView

getChild(Object, int) - Method in class javax.swing.tree.DefaultTreeModel

Returns the child of parent at index index in the parent's child array.

getChild(Object, int) - Method in interface javax.swing.tree.TreeModel

Returns the child of parent at index index in the parent's child array.

getChildAfter(TreeNode) - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns the child in this node's child array that immediately follows aChild, which must be a child of this node.

getChildAllocation(int, Shape) - Method in class javax.swing.text.AsyncBoxView.ChildLocator

Fetch the allocation to use for a child view.

getChildAllocation(int) - Method in class javax.swing.text.AsyncBoxView.ChildLocator

Fetch the allocation to use for a child view.

getChildAllocation(int, Shape) - Method in class javax.swing.text.AsyncBoxView

Fetches the allocation for the given child view.

getChildAllocation(int, Shape) - Method in class javax.swing.text.BoxView

Fetches the allocation for the given child view.

getChildAllocation(int, Shape) - Method in class javax.swing.text.CompositeView

Fetches the allocation for the given child view to render into.

getChildAllocation(int, Shape) - Method in class javax.swing.text.View

Fetches the allocation for the given child view.

getChildAt(int) - Method in class javax.swing.JTree.DynamicUtilTreeNode

Subclassed to load the children, if necessary.

getChildAt(int) - Method in class javax.swing.text.AbstractDocument.AbstractElement

Returns the child TreeNode at index childIndex.

getChildAt(int) - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns the child at the specified index in this node's child array.

getChildAt(int) - Method in interface javax.swing.tree.TreeNode

Returns the child TreeNode at index childIndex.

getChildBeanContextChild(Object) - Static method in class java.beans.beancontext.BeanContextSupport

Gets the BeanContextChild (if any) of the specified child

getChildBeanContextMembershipListener(Object) - Static method in class java.beans.beancontext.BeanContextSupport

Gets the BeanContextMembershipListener (if any) of the specified child

getChildBeanContextServicesListener(Object) - Static method in class java.beans.beancontext.BeanContextServicesSupport

Gets the BeanContextServicesListener (if any) of the specified child.

getChildBefore(TreeNode) - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns the child in this node's child array that immediately precedes aChild, which must be a child of this node.

getChildCount() - Method in class javax.swing.JTree.DynamicUtilTreeNode

Returns the number of child nodes.

getChildCount() - Method in class javax.swing.text.AbstractDocument.AbstractElement

Returns the number of children TreeNode's receiver contains.

getChildCount() - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns the number of children of this node.

getChildCount(Object) - Method in class javax.swing.tree.DefaultTreeModel

Returns the number of children of parent.

getChildCount(Object) - Method in interface javax.swing.tree.TreeModel

Returns the number of children of parent.

getChildCount() - Method in interface javax.swing.tree.TreeNode

Returns the number of children TreeNodes the receiver contains.

getChildElements() - Method in interface javax.xml.soap.SOAPElement

Returns an Iterator over all the immediate child Nodes of this element.

getChildElements(Name) - Method in interface javax.xml.soap.SOAPElement

Returns an Iterator over all the immediate child Nodes of this element with the specified name.

getChildElements(QName) - Method in interface javax.xml.soap.SOAPElement

Returns an Iterator over all the immediate child Nodes of this element with the specified qname.

getChildIndex() - Method in class javax.swing.JTree.DropLocation

Returns the index where the dropped data should be inserted with respect to the path returned by getPath().

getChildIndices() - Method in class javax.swing.event.TreeModelEvent

Returns the values of the child indexes.

getChildNames(String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns an array of Strings indicating the names of the element which are allowed to be children of the named element, in the order in which they should appear.

getChildNames(String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getChildNodes() - Method in class javax.imageio.metadata.IIOMetadataNode

Returns a NodeList that contains all children of this node.

getChildNodes() - Method in interface org.w3c.dom.Node

A NodeList that contains all children of this node.

getChildPolicy(String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns one of the constants starting with CHILD_POLICY_, indicating the legal pattern of children for the named element.

getChildPolicy(String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getChildPropertyChangeListener(Object) - Static method in class java.beans.beancontext.BeanContextSupport

Gets the PropertyChangeListener (if any) of the specified child

getChildren() - Method in interface java.security.cert.PolicyNode

Returns an iterator over the children of this node.

getChildren() - Method in class javax.swing.event.TreeModelEvent

Returns the objects that are children of the node identified by getPath at the locations specified by getChildIndices.

getChildrenAdded() - Method in interface javax.swing.event.DocumentEvent.ElementChange

Gets the child elements that were added to the given parent element.

getChildrenAdded() - Method in class javax.swing.text.AbstractDocument.ElementEdit

Gets a list of children that were added.

getChildrenRemoved() - Method in interface javax.swing.event.DocumentEvent.ElementChange

Gets the child elements that were removed from the given parent element.

getChildrenRemoved() - Method in class javax.swing.text.AbstractDocument.ElementEdit

Gets a list of children that were removed.

getChildSerializable(Object) - Static method in class java.beans.beancontext.BeanContextSupport

Gets the Serializable (if any) associated with the specified Child

getChildState(int) - Method in class javax.swing.text.AsyncBoxView

Fetch the object representing the layout state of of the child at the given index.

getChildVetoableChangeListener(Object) - Static method in class java.beans.beancontext.BeanContextSupport

Gets the VetoableChangeListener (if any) of the specified child

getChildView() - Method in class javax.swing.text.AsyncBoxView.ChildState

Fetch the child view this record represents

getChildVisibility(Object) - Static method in class java.beans.beancontext.BeanContextSupport

Gets the Component (if any) associated with the specified child.

getChoices() - Method in class javax.security.auth.callback.ChoiceCallback

Get the list of choices.

getChoosableFileFilters() - Method in class javax.swing.JFileChooser

Gets the list of user choosable file filters.

getChooserPanels() - Method in class javax.swing.JColorChooser

Returns the specified color panels.

getChronology() - Method in interface java.time.chrono.ChronoLocalDate

Gets the chronology of this date.

getChronology() - Method in interface java.time.chrono.ChronoLocalDateTime

Gets the chronology of this date-time.

getChronology() - Method in interface java.time.chrono.ChronoPeriod

Gets the chronology that defines the meaning of the supported units.

getChronology() - Method in interface java.time.chrono.ChronoZonedDateTime

Gets the chronology of this date-time.

getChronology() - Method in class java.time.chrono.HijrahDate

Gets the chronology of this date, which is the Hijrah calendar system.

getChronology() - Method in class java.time.chrono.JapaneseDate

Gets the chronology of this date, which is the Japanese calendar system.

getChronology() - Method in class java.time.chrono.MinguoDate

Gets the chronology of this date, which is the Minguo calendar system.

getChronology() - Method in class java.time.chrono.ThaiBuddhistDate

Gets the chronology of this date, which is the Thai Buddhist calendar system.

getChronology() - Method in class java.time.format.DateTimeFormatter

Gets the overriding chronology to be used during formatting.

getChronology() - Method in class java.time.LocalDate

Gets the chronology of this date, which is the ISO calendar system.

getChronology() - Method in class java.time.Period

Gets the chronology of this period, which is the ISO calendar system.

getCipherSuite() - Method in class java.net.SecureCacheResponse

Returns the cipher suite in use on the original connection that retrieved the network resource.

getCipherSuite() - Method in class javax.net.ssl.HandshakeCompletedEvent

Returns the cipher suite in use by the session which was produced by the handshake.

getCipherSuite() - Method in class javax.net.ssl.HttpsURLConnection

Returns the cipher suite in use on this connection.

getCipherSuite() - Method in interface javax.net.ssl.SSLSession

Returns the name of the SSL cipher suite which is used for all connections in the session.

getCipherSuites() - Method in class javax.net.ssl.SSLParameters

Returns a copy of the array of ciphersuites or null if none have been set.

getClass() - Method in class java.lang.Object

Returns the runtime class of this Object.

getClassAnnotation(Class<?>) - Static method in class java.rmi.server.RMIClassLoader

Returns the annotation string (representing a location for the class definition) that RMI will use to annotate the class descriptor when marshalling objects of the given class.

getClassAnnotation(Class<?>) - Method in class java.rmi.server.RMIClassLoaderSpi

Provides the implementation for RMIClassLoader.getClassAnnotation(Class).

getClassContext() - Method in class java.lang.SecurityManager

Returns the current execution stack as an array of classes.

getClasses() - Method in class java.lang.Class

Returns an array containing Class objects representing all the public classes and interfaces that are members of the class represented by this Class object.

getClassLoader() - Method in class java.lang.Class

Returns the class loader for the class.

getClassLoader(String) - Static method in class java.rmi.server.RMIClassLoader

Returns a class loader that loads classes from the given codebase URL path.

getClassLoader(String) - Method in class java.rmi.server.RMIClassLoaderSpi

Provides the implementation for RMIClassLoader.getClassLoader(String).

getClassLoader() - Method in class java.security.ProtectionDomain

Returns the ClassLoader of this domain.

getClassLoader(ObjectName) - Method in interface javax.management.MBeanServer

Return the named ClassLoader.

getClassLoader(JavaFileManager.Location) - Method in class javax.tools.ForwardingJavaFileManager

getClassLoader(JavaFileManager.Location) - Method in interface javax.tools.JavaFileManager

Gets a class loader for loading plug-ins from the given location.

getClassLoaderFor(ObjectName) - Method in interface javax.management.MBeanServer

Return the ClassLoader that was used for loading the class of the named MBean.

getClassLoaderRepository() - Method in interface javax.management.MBeanServer

Return the ClassLoaderRepository for this MBeanServer.

getClassLoaderRepository(MBeanServer) - Static method in class javax.management.MBeanServerFactory

Return the ClassLoaderRepository used by the given MBeanServer.

getClassLoaderRepository() - Method in class javax.management.modelmbean.RequiredModelMBean

Return the Class Loader Repository used to perform class loading.

getClassLoadingLock(String) - Method in class java.lang.ClassLoader

Returns the lock object for class loading operations.

getClassLoadingMXBean() - Static method in class java.lang.management.ManagementFactory

Returns the managed bean for the class loading system of the Java virtual machine.

getClassName() - Method in class java.lang.management.LockInfo

Returns the fully qualified name of the class of the lock object.

getClassName() - Method in class java.lang.StackTraceElement

Returns the fully qualified name of the class containing the execution point represented by this stack trace element.

getClassName() - Method in class java.rmi.activation.ActivationDesc

Returns the class name for the object specified by this descriptor.

getClassName() - Method in class java.rmi.activation.ActivationGroupDesc

Returns the group's class name (possibly null).

getClassName() - Method in class java.security.Provider.Service

Return the name of the class implementing this service.

getClassName() - Method in exception java.util.MissingResourceException

Gets parameter passed by constructor.

getClassName() - Method in class javax.management.MBeanInfo

Returns the name of the Java class of the MBean described by this MBeanInfo.

getClassName() - Method in interface javax.management.modelmbean.ModelMBeanInfo

Returns the name of the Java class of the MBean described by this MBeanInfo.

getClassName() - Method in class javax.management.ObjectInstance

Returns the class part.

getClassName() - Method in interface javax.management.openmbean.OpenMBeanInfo

Returns the fully qualified Java class name of the open MBean instances this OpenMBeanInfo describes.

getClassName() - Method in class javax.management.openmbean.OpenType

Returns the fully qualified Java class name of the open data values this open type describes.

getClassName(MBeanInfo) - Method in class javax.management.StandardMBean

Customization hook: Get the className that will be used in the MBeanInfo returned by this MBean.

getClassName() - Method in class javax.naming.Binding

Retrieves the class name of the object bound to the name of this binding.

getClassName() - Method in class javax.naming.NameClassPair

Retrieves the class name of the object bound to the name of this binding.

getClassName() - Method in class javax.naming.Reference

Retrieves the class name of the object to which this reference refers.

getClassName() - Method in class javax.swing.UIManager.LookAndFeelInfo

Returns the name of the class that implements this look and feel.

getClassPath() - Method in interface java.lang.management.RuntimeMXBean

Returns the Java class path that is used by the system class loader to search for class files.

getClickCount() - Method in class java.awt.event.MouseEvent

Returns the number of mouse clicks associated with this event.

getClickCountToStart() - Method in class javax.swing.DefaultCellEditor

Returns the number of clicks needed to start editing.

getClient() - Method in class javax.security.auth.kerberos.KerberosTicket

Returns the client principal associated with this ticket.

getClientAddresses() - Method in class javax.security.auth.kerberos.KerberosTicket

Returns a list of addresses from where the ticket can be used.

getClientAliases(String, Principal[]) - Method in interface javax.net.ssl.X509KeyManager

Get the matching aliases for authenticating the client side of a secure socket given the public key type and the list of certificate issuer authorities recognized by the peer (if any).

getClientHost() - Static method in class java.rmi.server.RemoteServer

Returns a string representation of the client host for the remote method invocation being processed in the current thread.

getClientHost() - Method in interface java.rmi.server.ServerRef

Deprecated.

Returns the hostname of the current client.

getClientInfo(String) - Method in interface java.sql.Connection

Returns the value of the client info property specified by name.

getClientInfo() - Method in interface java.sql.Connection

Returns a list containing the name and current value of each client info property supported by the driver.

getClientInfoProperties() - Method in interface java.sql.DatabaseMetaData

Retrieves a list of the client info properties that the driver supports.

getClientProperty(Object) - Method in class javax.swing.JComponent

Returns the value of the property with the specified key.

getClientSessionContext() - Method in class javax.net.ssl.SSLContext

Returns the client session context, which represents the set of SSL sessions available for use during the handshake phase of client-side SSL sockets.

getClientX() - Method in interface org.w3c.dom.events.MouseEvent

The horizontal coordinate at which the event occurred relative to the DOM implementation's client area.

getClientY() - Method in interface org.w3c.dom.events.MouseEvent

The vertical coordinate at which the event occurred relative to the DOM implementation's client area.

getClip() - Method in class java.awt.Graphics

Gets the current clipping area.

getClip() - Static method in class javax.sound.sampled.AudioSystem

Obtains a clip that can be used for playing back an audio file or an audio stream.

getClip(Mixer.Info) - Static method in class javax.sound.sampled.AudioSystem

Obtains a clip from the specified mixer that can be used for playing back an audio file or an audio stream.

getClip() - Method in class javax.swing.DebugGraphics

Overrides Graphics.getClip.

getClipBounds() - Method in class java.awt.Graphics

Returns the bounding rectangle of the current clipping area.

getClipBounds(Rectangle) - Method in class java.awt.Graphics

Returns the bounding rectangle of the current clipping area.

getClipBounds() - Method in class javax.swing.DebugGraphics

Overrides Graphics.getClipBounds.

getClipRect() - Method in class java.awt.Graphics

Deprecated.
As of JDK version 1.1, replaced by getClipBounds().

getClob(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC CLOB parameter as a java.sql.Clob object in the Java programming language.

getClob(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC CLOB parameter as a java.sql.Clob object in the Java programming language.

getClob(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a Clob object in the Java programming language.

getClob(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a Clob object in the Java programming language.

getClosedIcon() - Method in class javax.swing.tree.DefaultTreeCellRenderer

Returns the icon used to represent non-leaf nodes that are not expanded.

getClosestPathForLocation(int, int) - Method in class javax.swing.JTree

Returns the path to the node that is closest to x,y.

getClosestPathForLocation(JTree, int, int) - Method in class javax.swing.plaf.basic.BasicTreeUI

Returns the path to the node that is closest to x,y.

getClosestPathForLocation(JTree, int, int) - Method in class javax.swing.plaf.multi.MultiTreeUI

Invokes the getClosestPathForLocation method on each UI handled by this object.

getClosestPathForLocation(JTree, int, int) - Method in class javax.swing.plaf.TreeUI

Returns the path to the node that is closest to x,y.

getClosestPositionTo(int, Position.Bias, Shape, int, Position.Bias[], int, int) - Method in class javax.swing.text.ParagraphView

Returns the closest model position to x.

getClosestRowForLocation(int, int) - Method in class javax.swing.JTree

Returns the row to the node that is closest to x,y.

getCode() - Method in class javax.management.loading.MLetContent

Gets the value of the CODE attribute of the MLET tag.

getCode() - Method in interface javax.tools.Diagnostic

Gets a diagnostic code indicating the type of diagnostic.

getCodeBase() - Method in class java.applet.Applet

Gets the base URL.

getCodeBase() - Method in interface java.applet.AppletStub

Gets the base URL.

getCodeBase() - Method in class javax.management.loading.MLetContent

Gets the code base URL.

getCodebase(Class) - Static method in class javax.rmi.CORBA.Util

Returns the codebase, if any, for the given class.

getCodebase(Class) - Method in interface javax.rmi.CORBA.UtilDelegate

Delegation call for Util.getCodebase(java.lang.Class).

getCodePoint() - Method in exception java.util.IllegalFormatCodePointException

Returns the illegal code point as defined by Character.isValidCodePoint(int).

getCodeSigners() - Method in class java.security.CodeSource

Returns the code signers associated with this CodeSource.

getCodeSigners() - Method in class java.util.jar.JarEntry

Returns the CodeSigner objects for this entry, or null if none.

getCodeSource() - Method in class java.security.ProtectionDomain

Returns the CodeSource of this domain.

getCofactor() - Method in class java.security.spec.ECParameterSpec

Returns the cofactor.

getCollapsedIcon() - Method in class javax.swing.plaf.basic.BasicTreeUI

getCollationElementIterator(String) - Method in class java.text.RuleBasedCollator

Returns a CollationElementIterator for the given String.

getCollationElementIterator(CharacterIterator) - Method in class java.text.RuleBasedCollator

Returns a CollationElementIterator for the given CharacterIterator.

getCollationKey(String) - Method in class java.text.Collator

Transforms the String into a series of bits that can be compared bitwise to other CollationKeys.

getCollationKey(String) - Method in class java.text.RuleBasedCollator

Transforms the string into a series of characters that can be compared with CollationKey.compareTo.

getCollection() - Method in class java.security.cert.CollectionCertStoreParameters

Returns the Collection from which Certificates and CRLs are retrieved.

getCollectionCount() - Method in interface java.lang.management.GarbageCollectorMXBean

Returns the total number of collections that have occurred.

getCollectionTime() - Method in interface java.lang.management.GarbageCollectorMXBean

Returns the approximate accumulated collection elapsed time in milliseconds.

getCollectionUsage() - Method in interface java.lang.management.MemoryPoolMXBean

Returns the memory usage after the Java virtual machine most recently expended effort in recycling unused objects in this memory pool.

getCollectionUsageThreshold() - Method in interface java.lang.management.MemoryPoolMXBean

Returns the collection usage threshold value of this memory pool in bytes.

getCollectionUsageThresholdCount() - Method in interface java.lang.management.MemoryPoolMXBean

Returns the number of times that the Java virtual machine has detected that the memory usage has reached or exceeded the collection usage threshold.

getColor(String) - Static method in class java.awt.Color

Finds a color in the system properties.

getColor(String, Color) - Static method in class java.awt.Color

Finds a color in the system properties.

getColor(String, int) - Static method in class java.awt.Color

Finds a color in the system properties.

getColor() - Method in class java.awt.Graphics

Gets this graphics context's current color.

getColor() - Method in class java.awt.PageAttributes

Returns whether pages using these attributes will be rendered in color or monochrome.

getColor() - Method in class javax.swing.DebugGraphics

Returns the Color used for text drawing operations.

getColor() - Method in class javax.swing.JColorChooser

Gets the current color value from the color chooser.

getColor(SynthContext, ColorType) - Method in class javax.swing.plaf.synth.SynthStyle

Returns the color for the specified state.

getColor() - Method in class javax.swing.text.DefaultHighlighter.DefaultHighlightPainter

Returns the color of the highlight.

getColor(Object) - Method in class javax.swing.UIDefaults

If the value of key is a Color return it, otherwise return null.

getColor(Object, Locale) - Method in class javax.swing.UIDefaults

If the value of key for the given Locale is a Color return it, otherwise return null.

getColor(Object) - Static method in class javax.swing.UIManager

Returns a color from the defaults.

getColor(Object, Locale) - Static method in class javax.swing.UIManager

Returns a color from the defaults that is appropriate for the given locale.

getColor1() - Method in class java.awt.GradientPaint

Returns the color C1 anchored by the point P1.

getColor2() - Method in class java.awt.GradientPaint

Returns the color C2 anchored by the point P2.

getColorComponents(float[]) - Method in class java.awt.Color

Returns a float array containing only the color components of the Color, in the ColorSpace of the Color.

getColorComponents(ColorSpace, float[]) - Method in class java.awt.Color

Returns a float array containing only the color components of the Color in the ColorSpace specified by the cspace parameter.

getColorForGap(int, int, int) - Method in class javax.swing.plaf.metal.MetalTabbedPaneUI

getColorForState(SynthContext, ColorType) - Method in class javax.swing.plaf.nimbus.NimbusStyle

Returns the color for the specified state.

getColorForState(SynthContext, ColorType) - Method in class javax.swing.plaf.synth.SynthStyle

Returns the color for the specified state.

getColorFromModel() - Method in class javax.swing.colorchooser.AbstractColorChooserPanel

Returns the color that is currently selected.

getColorModel() - Method in class java.awt.Component

Gets the instance of ColorModel used to display the component on the output device.

getColorModel() - Method in class java.awt.GraphicsConfiguration

Returns the ColorModel associated with this GraphicsConfiguration.

getColorModel(int) - Method in class java.awt.GraphicsConfiguration

Returns the ColorModel associated with this GraphicsConfiguration that supports the specified transparency.

getColorModel() - Method in class java.awt.image.BufferedImage

Returns the ColorModel.

getColorModel() - Method in class java.awt.image.PixelGrabber

Get the ColorModel for the pixels stored in the array.

getColorModel() - Method in interface java.awt.image.RenderedImage

Returns the ColorModel associated with this image.

getColorModel() - Method in interface java.awt.PaintContext

Returns the ColorModel of the output.

getColorModel() - Method in class java.awt.Toolkit

Determines the color model of this toolkit's screen.

getColorModel() - Method in class javax.imageio.ImageTypeSpecifier

Returns the ColorModel specified by this object.

getColors() - Method in class java.awt.MultipleGradientPaint

Returns a copy of the array of colors used by this gradient.

getColorSelectionModel() - Method in class javax.swing.colorchooser.AbstractColorChooserPanel

Returns the model that the chooser panel is editing.

getColorSpace() - Method in class java.awt.Color

Returns the ColorSpace of this Color.

getColorSpace() - Method in class java.awt.image.ColorModel

Returns the ColorSpace associated with this ColorModel.

getColorSpace() - Method in class java.awt.MultipleGradientPaint

Returns the enumerated type which specifies color space for interpolation.

getColorSpaceType() - Method in class java.awt.color.ICC_Profile

Returns the color space type.

getColumn() - Method in class javax.swing.event.TableModelEvent

Returns the column for the event.

getColumn() - Method in class javax.swing.JTable.DropLocation

Returns the column index where a dropped item should be placed in the table.

getColumn(Object) - Method in class javax.swing.JTable

Returns the TableColumn object for the column in the table whose identifier is equal to identifier, when compared using equals.

getColumn() - Method in class javax.swing.RowSorter.SortKey

Returns the index of the column.

getColumn(int) - Method in class javax.swing.table.DefaultTableColumnModel

Returns the TableColumn object for the column at columnIndex.

getColumn(int) - Method in interface javax.swing.table.TableColumnModel

Returns the TableColumn object for the column at columnIndex.

getColumnClass(int) - Method in class javax.swing.JTable

Returns the type of the column appearing in the view at column position column.

getColumnClass(int) - Method in class javax.swing.table.AbstractTableModel

Returns Object.class regardless of columnIndex.

getColumnClass(int) - Method in interface javax.swing.table.TableModel

Returns the most specific superclass for all the cell values in the column.

getColumnClassName(int) - Method in interface java.sql.ResultSetMetaData

Returns the fully-qualified name of the Java class whose instances are manufactured if the method ResultSet.getObject is called to retrieve a value from the column.

getColumnClassName(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Retrieves the fully-qualified name of the class in the Java programming language to which a value in the designated column will be mapped.

getColumnCount() - Method in interface java.sql.ResultSetMetaData

Returns the number of columns in this ResultSet object.

getColumnCount() - Method in class javax.sql.rowset.RowSetMetaDataImpl

Retrieves the number of columns in the RowSet object for which this RowSetMetaDataImpl object was created.

getColumnCount() - Method in class javax.swing.DefaultRowSorter.ModelWrapper

Returns the number of columns in the model.

getColumnCount() - Method in class javax.swing.JTable

Returns the number of columns in the column model.

getColumnCount() - Method in class javax.swing.table.DefaultTableColumnModel

Returns the number of columns in the tableColumns array.

getColumnCount() - Method in class javax.swing.table.DefaultTableModel

Returns the number of columns in this data table.

getColumnCount() - Method in interface javax.swing.table.TableColumnModel

Returns the number of columns in the model.

getColumnCount() - Method in interface javax.swing.table.TableModel

Returns the number of columns in the model.

getColumnCount() - Method in class javax.swing.text.TableView.TableCell

Deprecated.

Gets the number of columns this cell spans (e.g.

getColumnDisplaySize(int) - Method in interface java.sql.ResultSetMetaData

Indicates the designated column's normal maximum width in characters.

getColumnDisplaySize(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Retrieves the normal maximum width in chars of the designated column.

getColumnHeader() - Method in class javax.swing.JScrollPane

Returns the column header.

getColumnHeader() - Method in class javax.swing.ScrollPaneLayout

Returns the JViewport object that is the column header.

getColumnIndex(Object) - Method in class javax.swing.table.DefaultTableColumnModel

Returns the index of the first column in the tableColumns array whose identifier is equal to identifier, when compared using equals.

getColumnIndex(Object) - Method in interface javax.swing.table.TableColumnModel

Returns the index of the first column in the table whose identifier is equal to identifier, when compared using equals.

getColumnIndexAtX(int) - Method in class javax.swing.table.DefaultTableColumnModel

Returns the index of the column that lies at position x, or -1 if no column covers this point.

getColumnIndexAtX(int) - Method in interface javax.swing.table.TableColumnModel

Returns the index of the column that lies on the horizontal point, xPosition; or -1 if it lies outside the any of the column's bounds.

getColumnLabel(int) - Method in interface java.sql.ResultSetMetaData

Gets the designated column's suggested title for use in printouts and displays.

getColumnLabel(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Retrieves the the suggested column title for the designated column for use in printouts and displays.

getColumnMargin() - Method in class javax.swing.table.DefaultTableColumnModel

Returns the width margin for TableColumn.

getColumnMargin() - Method in interface javax.swing.table.TableColumnModel

Returns the width between the cells in each column.

getColumnModel() - Method in class javax.swing.JTable

Returns the TableColumnModel that contains all column information of this table.

getColumnModel() - Method in class javax.swing.table.JTableHeader

Returns the TableColumnModel that contains all column information of this table header.

getColumnModelListeners() - Method in class javax.swing.table.DefaultTableColumnModel

Returns an array of all the column model listeners registered on this model.

getColumnName(int) - Method in interface java.sql.ResultSetMetaData

Get the designated column's name.

getColumnName(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Retrieves the name of the designated column.

getColumnName(int) - Method in class javax.swing.JTable

Returns the name of the column appearing in the view at column position column.

getColumnName(int) - Method in class javax.swing.table.AbstractTableModel

Returns a default name for the column using spreadsheet conventions: A, B, C, ...

getColumnName(int) - Method in class javax.swing.table.DefaultTableModel

Returns the column name.

getColumnName(int) - Method in interface javax.swing.table.TableModel

Returns the name of the column at columnIndex.

getColumnNumber() - Method in exception javax.script.ScriptException

Get the column number on which an error occurred.

getColumnNumber() - Method in interface javax.tools.Diagnostic

Gets the column number of the character offset returned by Diagnostic.getPosition().

getColumnNumber() - Method in class javax.xml.bind.helpers.ValidationEventLocatorImpl

getColumnNumber() - Method in interface javax.xml.bind.ValidationEventLocator

Return the column number if available

getColumnNumber() - Method in interface javax.xml.stream.Location

Return the column number where the current event ends, returns -1 if none is available.

getColumnNumber() - Method in interface javax.xml.transform.SourceLocator

Return the character position where the current document event ends.

getColumnNumber() - Method in interface org.w3c.dom.DOMLocator

The column number this locator is pointing to, or -1 if there is no column number available.

getColumnNumber() - Method in class org.xml.sax.helpers.LocatorImpl

Return the saved column number (1-based).

getColumnNumber() - Method in interface org.xml.sax.Locator

Return the column number where the current document event ends.

getColumnNumber() - Method in exception org.xml.sax.SAXParseException

The column number of the end of the text where the exception occurred.

getColumnPrivileges(String, String, String, String) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of the access rights for a table's columns.

getColumns() - Method in class java.awt.GridLayout

Gets the number of columns in this layout.

getColumns() - Method in class java.awt.TextArea

Returns the number of columns in this text area.

getColumns() - Method in class java.awt.TextField

Gets the number of columns in this text field.

getColumns(String, String, String, String) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of table columns available in the specified catalog.

getColumns() - Method in class javax.swing.JTextArea

Returns the number of columns in the TextArea.

getColumns() - Method in class javax.swing.JTextField

Returns the number of columns in this TextField.

getColumns() - Method in class javax.swing.table.DefaultTableColumnModel

Returns an Enumeration of all the columns in the model.

getColumns() - Method in interface javax.swing.table.TableColumnModel

Returns an Enumeration of all the columns in the model.

getColumnSelectionAllowed() - Method in class javax.swing.JTable

Returns true if columns can be selected.

getColumnSelectionAllowed() - Method in class javax.swing.table.DefaultTableColumnModel

Returns true if column selection is allowed, otherwise false.

getColumnSelectionAllowed() - Method in interface javax.swing.table.TableColumnModel

Returns true if columns may be selected.

getColumnType(int) - Method in interface java.sql.ResultSetMetaData

Retrieves the designated column's SQL type.

getColumnType(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Retrieves the type code (one of the java.sql.Types constants) for the SQL type of the value stored in the designated column.

getColumnTypeName(int) - Method in interface java.sql.ResultSetMetaData

Retrieves the designated column's database-specific type name.

getColumnTypeName(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Retrieves the DBMS-specific type name for values stored in the designated column.

getColumnWidth() - Method in class javax.swing.JTextArea

Gets column width.

getColumnWidth() - Method in class javax.swing.JTextField

Returns the column width.

getComboBox() - Method in class javax.swing.plaf.metal.MetalComboBoxButton

getComboIcon() - Method in class javax.swing.plaf.metal.MetalComboBoxButton

getCommand(String, String) - Method in class javax.activation.CommandMap

Get the default command corresponding to the MIME type.

getCommand(String, String, DataSource) - Method in class javax.activation.CommandMap

Get the default command corresponding to the MIME type.

getCommand(String) - Method in class javax.activation.DataHandler

Get the command cmdName.

getCommand(String, String) - Method in class javax.activation.MailcapCommandMap

Get the command corresponding to cmdName for the MIME type.

getCommand() - Method in class javax.sound.midi.ShortMessage

Obtains the MIDI command associated with this event.

getCommand() - Method in class javax.sql.rowset.BaseRowSet

Retrieves the SQL query that is the command for this RowSet object.

getCommand() - Method in interface javax.sql.RowSet

Retrieves this RowSet object's command property.

getCommandClass() - Method in class javax.activation.CommandInfo

Return the command's class name.

getCommandEnvironment() - Method in class java.rmi.activation.ActivationGroupDesc

Returns the group's command-environment control object.

getCommandName() - Method in class javax.activation.CommandInfo

Return the command verb.

getCommandObject(DataHandler, ClassLoader) - Method in class javax.activation.CommandInfo

Return the instantiated JavaBean component.

getCommandOptions() - Method in class java.rmi.activation.ActivationGroupDesc.CommandEnvironment

Fetch the configured java command options.

getCommandPath() - Method in class java.rmi.activation.ActivationGroupDesc.CommandEnvironment

Fetch the configured path-qualified java command name.

getComment() - Method in class java.net.HttpCookie

Returns the comment describing the purpose of this cookie, or null if the cookie has no comment.

getComment() - Method in class java.util.zip.ZipEntry

Returns the comment string for the entry.

getComment() - Method in class java.util.zip.ZipFile

Returns the zip file comment, or null if none.

getCommentURL() - Method in class java.net.HttpCookie

Returns the comment URL describing the purpose of this cookie, or null if the cookie has no comment URL.

getCommitsOnValidEdit() - Method in class javax.swing.text.DefaultFormatter

Returns when edits are published back to the JFormattedTextField.

getCommitted() - Method in class java.lang.management.MemoryUsage

Returns the amount of memory in bytes that is committed for the Java virtual machine to use.

getCommittedCharacterCount() - Method in class java.awt.event.InputMethodEvent

Gets the number of committed characters in the text.

getCommittedText(int, int, AttributedCharacterIterator.Attribute[]) - Method in interface java.awt.im.InputMethodRequests

Gets an iterator providing access to the entire text and attributes contained in the text editing component except for uncommitted text.

getCommittedTextLength() - Method in interface java.awt.im.InputMethodRequests

Gets the length of the entire text contained in the text editing component except for uncommitted (composed) text.

getCommonPoolParallelism() - Static method in class java.util.concurrent.ForkJoinPool

Returns the targeted parallelism level of the common pool.

getComparator() - Method in interface java.util.Spliterator

If this Spliterator's source is Spliterator.SORTED by a Comparator, returns that Comparator.

getComparator(int) - Method in class javax.swing.DefaultRowSorter

Returns the Comparator for the specified column.

getComparator() - Method in class javax.swing.SortingFocusTraversalPolicy

Returns the Comparator which will be used to sort the Components in a focus traversal cycle.

getComparator(int) - Method in class javax.swing.table.TableRowSorter

Returns the Comparator for the specified column.

getCompilationMXBean() - Static method in class java.lang.management.ManagementFactory

Returns the managed bean for the compilation system of the Java virtual machine.

getCompletedTaskCount() - Method in class java.util.concurrent.ThreadPoolExecutor

Returns the approximate total number of tasks that have completed execution.

getCompleter() - Method in class java.util.concurrent.CountedCompleter

Returns the completer established in this task's constructor, or null if none.

getCompletions(Element, AnnotationMirror, ExecutableElement, String) - Method in class javax.annotation.processing.AbstractProcessor

Returns an empty iterable of completions.

getCompletions(Element, AnnotationMirror, ExecutableElement, String) - Method in interface javax.annotation.processing.Processor

Returns to the tool infrastructure an iterable of suggested completions to an annotation.

getComponent(int) - Method in class java.awt.Container

Gets the nth component in this container.

getComponent() - Method in class java.awt.dnd.DragGestureEvent

Returns the Component associated with this DragGestureEvent.

getComponent() - Method in class java.awt.dnd.DragGestureRecognizer

This method returns the Component that is to be "observed" by the DragGestureRecognizer for drag initiating gestures.

getComponent() - Method in class java.awt.dnd.DragSourceContext

Returns the Component associated with this DragSourceContext.

getComponent() - Method in class java.awt.dnd.DropTarget

Gets the Component associated with this DropTarget.

getComponent() - Method in class java.awt.dnd.DropTargetContext

This method returns the Component associated with this DropTargetContext.

getComponent() - Method in class java.awt.event.ComponentEvent

Returns the originator of the event.

getComponent() - Method in class java.awt.event.HierarchyEvent

Returns the originator of the event.

getComponent() - Method in interface java.beans.beancontext.BeanContextChildComponentProxy

Gets the java.awt.Component associated with this BeanContextChild.

getComponent() - Method in class javax.swing.ComponentInputMap

Returns the component the InputMap was created for.

getComponent() - Method in class javax.swing.DefaultCellEditor

Returns a reference to the editor component.

getComponent() - Method in class javax.swing.event.AncestorEvent

Returns the component that the listener was added to.

getComponent() - Method in class javax.swing.JMenu

Returns the java.awt.Component used to paint this MenuElement.

getComponent() - Method in class javax.swing.JMenuBar

Implemented to be a MenuElement.

getComponent() - Method in class javax.swing.JMenuItem

Returns the java.awt.Component used to paint this object.

getComponent() - Method in class javax.swing.JPopupMenu

Returns this JPopupMenu component.

getComponent() - Method in class javax.swing.JToolTip

Returns the component the tooltip applies to.

getComponent() - Method in interface javax.swing.MenuElement

This method should return the java.awt.Component used to paint the receiving element.

getComponent() - Method in class javax.swing.plaf.basic.BasicTextUI

Fetches the text component associated with this UI implementation.

getComponent() - Method in class javax.swing.plaf.synth.SynthContext

Returns the hosting component containing the region.

getComponent() - Method in interface javax.swing.Renderer

Returns the component used to render the value.

getComponent() - Method in class javax.swing.text.ComponentView

Fetch the component associated with the view.

getComponent() - Method in class javax.swing.text.DefaultCaret

Gets the text editor component that this caret is is bound to.

getComponent(AttributeSet) - Static method in class javax.swing.text.StyleConstants

Gets the component setting from the attribute list.

getComponent() - Method in class javax.swing.TransferHandler.TransferSupport

Returns the target component of this transfer.

getComponentAfter(Container, Component) - Method in class java.awt.ContainerOrderFocusTraversalPolicy

Returns the Component that should receive the focus after aComponent.

getComponentAfter(Container, Component) - Method in class java.awt.FocusTraversalPolicy

Returns the Component that should receive the focus after aComponent.

getComponentAfter(Container, Component) - Method in class javax.swing.DefaultFocusManager

getComponentAfter(Container, Component) - Method in class javax.swing.LayoutFocusTraversalPolicy

Returns the Component that should receive the focus after aComponent.

getComponentAfter(Container, Component) - Method in class javax.swing.SortingFocusTraversalPolicy

Returns the Component that should receive the focus after aComponent.

getComponentAt(int, int) - Method in class java.awt.Component

Determines if this component or one of its immediate subcomponents contains the (x, y) location, and if so, returns the containing component.

getComponentAt(Point) - Method in class java.awt.Component

Returns the component or subcomponent that contains the specified point.

getComponentAt(int, int) - Method in class java.awt.Container

Locates the component that contains the x,y position.

getComponentAt(Point) - Method in class java.awt.Container

Gets the component that contains the specified point.

getComponentAt(int) - Method in class javax.swing.JTabbedPane

Returns the component at index.

getComponentAtIndex(int) - Method in class javax.swing.JMenuBar

Deprecated.
replaced by getComponent(int i)

getComponentAtIndex(int) - Method in class javax.swing.JPopupMenu

Deprecated.
replaced by Container.getComponent(int)

getComponentAtIndex(int) - Method in class javax.swing.JToolBar

Returns the component at the specified index.

getComponentBefore(Container, Component) - Method in class java.awt.ContainerOrderFocusTraversalPolicy

Returns the Component that should receive the focus before aComponent.

getComponentBefore(Container, Component) - Method in class java.awt.FocusTraversalPolicy

Returns the Component that should receive the focus before aComponent.

getComponentBefore(Container, Component) - Method in class javax.swing.DefaultFocusManager

getComponentBefore(Container, Component) - Method in class javax.swing.LayoutFocusTraversalPolicy

Returns the Component that should receive the focus before aComponent.

getComponentBefore(Container, Component) - Method in class javax.swing.SortingFocusTraversalPolicy

Returns the Component that should receive the focus before aComponent.

getComponentColor(JComponent, String, Color, float, float, int) - Method in class javax.swing.plaf.nimbus.AbstractRegionPainter

Get a color property from the given JComponent.

getComponentCount() - Method in class java.awt.Container

Gets the number of components in this panel.

getComponentCountInLayer(int) - Method in class javax.swing.JLayeredPane

Returns the number of children currently in the specified layer.

getComponentGraphics(Graphics) - Method in class javax.swing.JComponent

Returns the graphics object used to paint this component.

getComponentIndex(Component) - Method in class javax.swing.JMenuBar

Returns the index of the specified component.

getComponentIndex(Component) - Method in class javax.swing.JPopupMenu

Returns the index of the specified component.

getComponentIndex(Component) - Method in class javax.swing.JToolBar

Returns the index of the specified component.

getComponentListeners() - Method in class java.awt.Component

Returns an array of all the component listeners registered on this component.

getComponentOrientation() - Method in class java.awt.Component

Retrieves the language-sensitive orientation that is to be used to order the elements or text within this component.

getComponentPopupMenu() - Method in class javax.swing.JComponent

Returns JPopupMenu that assigned for this component.

getComponents(float[]) - Method in class java.awt.Color

Returns a float array containing the color and alpha components of the Color, in the ColorSpace of the Color.

getComponents(ColorSpace, float[]) - Method in class java.awt.Color

Returns a float array containing the color and alpha components of the Color, in the ColorSpace specified by the cspace parameter.

getComponents() - Method in class java.awt.Container

Gets all the components in this container.

getComponents(int, int[], int) - Method in class java.awt.image.ColorModel

Returns an array of unnormalized color/alpha components given a pixel in this ColorModel.

getComponents(Object, int[], int) - Method in class java.awt.image.ColorModel

Returns an array of unnormalized color/alpha components given a pixel in this ColorModel.

getComponents(int, int[], int) - Method in class java.awt.image.ComponentColorModel

Returns an array of unnormalized color/alpha components given a pixel in this ColorModel.

getComponents(Object, int[], int) - Method in class java.awt.image.ComponentColorModel

Returns an array of unnormalized color/alpha components given a pixel in this ColorModel.

getComponents(int, int[], int) - Method in class java.awt.image.DirectColorModel

Returns an array of unnormalized color/alpha components given a pixel in this ColorModel.

getComponents(Object, int[], int) - Method in class java.awt.image.DirectColorModel

Returns an array of unnormalized color/alpha components given a pixel in this ColorModel.

getComponents(int, int[], int) - Method in class java.awt.image.IndexColorModel

Returns an array of unnormalized color/alpha components for a specified pixel in this ColorModel.

getComponents(Object, int[], int) - Method in class java.awt.image.IndexColorModel

Returns an array of unnormalized color/alpha components for a specified pixel in this ColorModel.

getComponentsInLayer(int) - Method in class javax.swing.JLayeredPane

Returns an array of the components in the specified layer.

getComponentSize(int) - Method in class java.awt.image.ColorModel

Returns the number of bits for the specified color/alpha component.

getComponentSize() - Method in class java.awt.image.ColorModel

Returns an array of the number of bits per color/alpha component.

getComponentSize() - Method in class java.awt.image.IndexColorModel

Returns an array of the number of bits for each color/alpha component.

getComponentState() - Method in class javax.swing.plaf.synth.SynthContext

Returns the state of the widget, which is a bitmask of the values defined in SynthConstants.

getComponentToLayer() - Method in class javax.swing.JLayeredPane

Returns the hashtable that maps components to layers.

getComponentType() - Method in class java.lang.Class

Returns the Class representing the component type of an array.

getComponentType() - Method in interface javax.lang.model.type.ArrayType

Returns the component type of this array type.

getComponentZOrder(Component) - Method in class java.awt.Container

Returns the z-order index of the component inside the container.

getComposite() - Method in class java.awt.Graphics2D

Returns the current Composite in the Graphics2D context.

getCompositeData() - Method in class javax.management.openmbean.CompositeDataInvocationHandler

Return the CompositeData that was supplied to the constructor.

getCompositeType() - Method in interface javax.management.openmbean.CompositeData

Returns the composite type of this composite data instance.

getCompositeType() - Method in class javax.management.openmbean.CompositeDataSupport

Returns the composite type of this composite data instance.

getCompressedSize() - Method in class java.util.zip.ZipEntry

Returns the size of the compressed entry data.

getCompressionMode() - Method in class javax.imageio.ImageWriteParam

Returns the current compression mode, if compression is supported.

getCompressionQuality() - Method in class javax.imageio.ImageWriteParam

Returns the current compression quality setting.

getCompressionQualityDescriptions() - Method in class javax.imageio.ImageWriteParam

Returns an array of Strings that may be used along with getCompressionQualityValues as part of a user interface for setting or displaying the compression quality level.

getCompressionQualityDescriptions() - Method in class javax.imageio.plugins.jpeg.JPEGImageWriteParam

getCompressionQualityValues() - Method in class javax.imageio.ImageWriteParam

Returns an array of floats that may be used along with getCompressionQualityDescriptions as part of a user interface for setting or displaying the compression quality level.

getCompressionQualityValues() - Method in class javax.imageio.plugins.jpeg.JPEGImageWriteParam

getCompressionThreshold() - Method in class javax.swing.text.StyleContext

Returns the maximum number of key/value pairs to try and compress into unique/immutable sets.

getCompressionType() - Method in class javax.imageio.ImageWriteParam

Returns the currently set compression type, or null if none has been set.

getCompressionTypes() - Method in class javax.imageio.ImageWriteParam

Returns a list of available compression types, as an array or Strings, or null if a compression type may not be chosen using these interfaces.

getConcurrency() - Method in interface java.sql.ResultSet

Retrieves the concurrency mode of this ResultSet object.

getConcurrency() - Method in class javax.sql.rowset.BaseRowSet

Returns the concurrency for this RowSet object.

getConditionForKeyStroke(KeyStroke) - Method in class javax.swing.JComponent

Returns the condition that determines whether a registered action occurs in response to the specified keystroke.

getConfiguration() - Method in class java.security.DomainLoadStoreParameter

Gets the identifier for the domain configuration data.

getConfiguration() - Static method in class javax.security.auth.login.Configuration

Get the installed login Configuration.

getConfigurations() - Method in class java.awt.GraphicsDevice

Returns all of the GraphicsConfiguration objects associated with this GraphicsDevice.

getConflictValue(int) - Method in interface javax.sql.rowset.spi.SyncResolver

Retrieves the value in the designated column in the current row of this SyncResolver object, which is the value in the data source that caused a conflict.

getConflictValue(String) - Method in interface javax.sql.rowset.spi.SyncResolver

Retrieves the value in the designated column in the current row of this SyncResolver object, which is the value in the data source that caused a conflict.

getConfState() - Method in interface org.ietf.jgss.GSSContext

Determines if data confidentiality is available over the context.

getConnectControls() - Method in class javax.naming.ldap.InitialLdapContext

getConnectControls() - Method in interface javax.naming.ldap.LdapContext

Retrieves the connection request controls in effect for this context.

getConnection() - Method in interface java.sql.DatabaseMetaData

Retrieves the connection that produced this metadata object.

getConnection(String, Properties) - Static method in class java.sql.DriverManager

Attempts to establish a connection to the given database URL.

getConnection(String, String, String) - Static method in class java.sql.DriverManager

Attempts to establish a connection to the given database URL.

getConnection(String) - Static method in class java.sql.DriverManager

Attempts to establish a connection to the given database URL.

getConnection() - Method in interface java.sql.Statement

Retrieves the Connection object that produced this Statement object.

getConnection() - Method in interface javax.sql.DataSource

Attempts to establish a connection with the data source that this DataSource object represents.

getConnection(String, String) - Method in interface javax.sql.DataSource

Attempts to establish a connection with the data source that this DataSource object represents.

getConnection() - Method in interface javax.sql.PooledConnection

Creates and returns a Connection object that is a handle for the physical connection that this PooledConnection object represents.

getConnection() - Method in interface javax.sql.RowSetInternal

Retrieves the Connection object that was passed to this RowSet object.

getConnectionId() - Method in class javax.management.remote.JMXConnectionNotification

The connection ID to which this notification pertains.

getConnectionId() - Method in interface javax.management.remote.JMXConnector

Gets this connection's ID from the connector server.

getConnectionId() - Method in interface javax.management.remote.rmi.RMIConnection

Returns the connection ID.

getConnectionId() - Method in class javax.management.remote.rmi.RMIConnectionImpl

getConnectionId() - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub

getConnectionId() - Method in class javax.management.remote.rmi.RMIConnector

getConnectionIds() - Method in class javax.management.remote.JMXConnectorServer

getConnectionIds() - Method in interface javax.management.remote.JMXConnectorServerMBean

The list of IDs for currently-open connections to this connector server.

getConnectTimeout() - Method in class java.net.URLConnection

Returns setting for connect timeout.

getConstantExpression(Object) - Method in interface javax.lang.model.util.Elements

Returns the text of a constant expression representing a primitive value or a string.

getConstantValue() - Method in interface javax.lang.model.element.VariableElement

Returns the value of this variable if this is a final field initialized to a compile-time constant.

getConstraint(String) - Method in class javax.swing.SpringLayout.Constraints

Returns the value of the specified edge, which may be a derived value, or even null.

getConstraint(String, Component) - Method in class javax.swing.SpringLayout

Returns the spring controlling the distance between the specified edge of the component and the top or left edge of its parent.

getConstraints(Component) - Method in class java.awt.BorderLayout

Gets the constraints for the specified component

getConstraints(Component) - Method in class java.awt.GridBagLayout

Gets the constraints for the specified component.

getConstraints(Component) - Method in class javax.swing.SpringLayout

Returns the constraints for the specified component.

getConstructor(Class<?>...) - Method in class java.lang.Class

Returns a Constructor object that reflects the specified public constructor of the class represented by this Class object.

getConstructor(String) - Method in class javax.management.modelmbean.ModelMBeanInfoSupport

Returns the ModelMBeanConstructorInfo requested by name.

getConstructors() - Method in class java.lang.Class

Returns an array containing Constructor objects reflecting all the public constructors of the class represented by this Class object.

getConstructors() - Method in class javax.management.MBeanInfo

Returns the list of the public constructors of the MBean.

getConstructors() - Method in interface javax.management.modelmbean.ModelMBeanInfo

Returns the list of the public constructors of the MBean.

getConstructors() - Method in interface javax.management.openmbean.OpenMBeanInfo

Returns an array of OpenMBeanConstructorInfo instances describing each constructor in the open MBean described by this OpenMBeanInfo instance.

getConstructors(MBeanConstructorInfo[], Object) - Method in class javax.management.StandardMBean

Customization hook: Get the MBeanConstructorInfo[] that will be used in the MBeanInfo returned by this MBean.

getContainer() - Method in class java.awt.event.ContainerEvent

Returns the originator of the event.

getContainer() - Method in interface java.beans.beancontext.BeanContextContainerProxy

Gets the java.awt.Container associated with this BeanContext.

getContainer() - Method in class javax.swing.text.View

Fetches the container hosting the view.

getContainerGap(JComponent, int, Container) - Method in class javax.swing.LayoutStyle

Returns the amount of space to place between the component and specified edge of its parent.

getContainerListeners() - Method in class java.awt.Container

Returns an array of all the container listeners registered on this container.

getContent(URLConnection) - Method in class java.net.ContentHandler

Given a URL connect stream positioned at the beginning of the representation of an object, this method reads that stream and creates an object from it.

getContent(URLConnection, Class[]) - Method in class java.net.ContentHandler

Given a URL connect stream positioned at the beginning of the representation of an object, this method reads that stream and creates an object that matches one of the types specified.

getContent() - Method in class java.net.URL

Gets the contents of this URL.

getContent(Class[]) - Method in class java.net.URL

Gets the contents of this URL.

getContent() - Method in class java.net.URLConnection

Retrieves the contents of this URL connection.

getContent(Class[]) - Method in class java.net.URLConnection

Retrieves the contents of this URL connection.

getContent(DataSource) - Method in interface javax.activation.DataContentHandler

Return an object representing the data in its most preferred form.

getContent() - Method in class javax.activation.DataHandler

Return the data in its preferred Object form.

getContent() - Method in class javax.naming.BinaryRefAddr

Retrieves the contents of this address as an Object.

getContent() - Method in class javax.naming.RefAddr

Retrieves the contents of this address.

getContent() - Method in class javax.naming.StringRefAddr

Retrieves the contents of this address.

getContent() - Method in class javax.swing.text.AbstractDocument

Gets the content for the document.

getContent() - Method in class javax.swing.text.html.parser.Element

Get content model

getContent() - Method in interface javax.xml.crypto.dsig.keyinfo.KeyInfo

Returns an unmodifiable list containing the key information.

getContent() - Method in interface javax.xml.crypto.dsig.keyinfo.X509Data

Returns an unmodifiable list of the content in this X509Data.

getContent() - Method in interface javax.xml.crypto.dsig.SignatureProperty

Returns an unmodifiable list of one or more XMLStructures that are contained in this SignatureProperty.

getContent() - Method in interface javax.xml.crypto.dsig.XMLObject

Returns an unmodifiable list of XMLStructures contained in this XMLObject, which represent elements from any namespace.

getContent() - Method in class javax.xml.soap.AttachmentPart

Gets the content of this AttachmentPart object as a Java object.

getContent() - Method in class javax.xml.soap.SOAPPart

Returns the content of the SOAPEnvelope as a JAXP Source object.

getContentBorderInsets(int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getContentDescription() - Method in class javax.xml.soap.SOAPMessage

Retrieves a description of this SOAPMessage object's content.

getContentEncoding() - Method in class java.net.URLConnection

Returns the value of the content-encoding header field.

getContentHandler() - Method in class javax.xml.validation.ValidatorHandler

Gets the ContentHandler which receives the augmented validation result.

getContentHandler() - Method in class org.xml.sax.helpers.ParserAdapter

Return the current content handler.

getContentHandler() - Method in class org.xml.sax.helpers.XMLFilterImpl

Get the content event handler.

getContentHandler() - Method in interface org.xml.sax.XMLReader

Return the current content handler.

getContentId() - Method in class javax.xml.soap.AttachmentPart

Gets the value of the MIME header whose name is "Content-ID".

getContentId() - Method in class javax.xml.soap.SOAPPart

Retrieves the value of the MIME header whose name is "Content-Id".

getContentLength() - Method in class java.net.URLConnection

Returns the value of the content-length header field.

getContentLengthLong() - Method in class java.net.URLConnection

Returns the value of the content-length header field as a long.

getContentLocation() - Method in class javax.xml.soap.AttachmentPart

Gets the value of the MIME header whose name is "Content-Location".

getContentLocation() - Method in class javax.xml.soap.SOAPPart

Retrieves the value of the MIME header whose name is "Content-Location".

getContentPane() - Method in class javax.swing.JApplet

Returns the contentPane object for this applet.

getContentPane() - Method in class javax.swing.JDialog

Returns the contentPane object for this dialog.

getContentPane() - Method in class javax.swing.JFrame

Returns the contentPane object for this frame.

getContentPane() - Method in class javax.swing.JInternalFrame

Returns the content pane for this internal frame.

getContentPane() - Method in class javax.swing.JRootPane

Returns the content pane -- the container that holds the components parented by the root pane.

getContentPane() - Method in class javax.swing.JWindow

Returns the Container which is the contentPane for this window.

getContentPane() - Method in interface javax.swing.RootPaneContainer

Returns the contentPane.

getContents(Object) - Method in class java.awt.datatransfer.Clipboard

Returns a transferable object representing the current contents of the clipboard.

getContents() - Method in class java.util.ListResourceBundle

Returns an array in which each item is a pair of objects in an Object array.

getContents() - Method in class javax.accessibility.AccessibleResourceBundle

Deprecated.

Returns the mapping between the programmatic keys and the localized display strings.

getContentType() - Method in class java.net.URLConnection

Returns the value of the content-type header field.

getContentType() - Method in class javax.activation.DataHandler

Return the MIME type of this object as retrieved from the source object.

getContentType() - Method in interface javax.activation.DataSource

This method returns the MIME type of the data in the form of a string.

getContentType() - Method in class javax.activation.FileDataSource

This method returns the MIME type of the data in the form of a string.

getContentType(File) - Method in class javax.activation.FileTypeMap

Return the type of the file object.

getContentType(String) - Method in class javax.activation.FileTypeMap

Return the type of the file passed in.

getContentType(File) - Method in class javax.activation.MimetypesFileTypeMap

Return the MIME type of the file object.

getContentType(String) - Method in class javax.activation.MimetypesFileTypeMap

Return the MIME type based on the specified file name.

getContentType() - Method in class javax.activation.URLDataSource

Returns the value of the URL content-type header field.

getContentType() - Method in class javax.swing.JEditorPane

Gets the type of content that this editor is currently set to deal with.

getContentType() - Method in class javax.swing.text.DefaultEditorKit

Gets the MIME type of the data that this kit represents support for.

getContentType() - Method in class javax.swing.text.EditorKit

Gets the MIME type of the data that this kit represents support for.

getContentType() - Method in class javax.swing.text.html.HTMLEditorKit

Get the MIME type of the data that this kit represents support for.

getContentType() - Method in class javax.swing.text.rtf.RTFEditorKit

Get the MIME type of the data that this kit represents support for.

getContentType() - Method in class javax.xml.soap.AttachmentPart

Gets the value of the MIME header whose name is "Content-Type".

getContentTypeFor(String) - Method in interface java.net.FileNameMap

Gets the MIME type for the specified file name.

getContext() - Static method in class java.security.AccessController

This method takes a "snapshot" of the current calling context, which includes the current Thread's inherited AccessControlContext and any limited privilege scope, and places it in an AccessControlContext object.

getContext() - Method in class javax.script.AbstractScriptEngine

Returns the value of the protected context field.

getContext() - Method in interface javax.script.ScriptEngine

Returns the default ScriptContext of the ScriptEngine whose Bindings, Reader and Writers are used for script executions when no ScriptContext is specified.

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthButtonUI

Returns the Context for the specified component.

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthColorChooserUI

Returns the Context for the specified component.

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthComboBoxUI

Returns the Context for the specified component.

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthDesktopIconUI

Returns the Context for the specified component.

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthDesktopPaneUI

Returns the Context for the specified component.

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthEditorPaneUI

Returns the Context for the specified component.

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthInternalFrameUI

Returns the Context for the specified component.

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthLabelUI

Returns the Context for the specified component.

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthListUI

Returns the Context for the specified component.

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthMenuBarUI

Returns the Context for the specified component.

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthMenuItemUI

Returns the Context for the specified component.

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthMenuUI

Returns the Context for the specified component.

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthOptionPaneUI

Returns the Context for the specified component.

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthPanelUI

Returns the Context for the specified component.

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthPopupMenuUI

Returns the Context for the specified component.

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthProgressBarUI

Returns the Context for the specified component.

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthRootPaneUI

Returns the Context for the specified component.

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthScrollBarUI

Returns the Context for the specified component.

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthScrollPaneUI

Returns the Context for the specified component.

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthSeparatorUI

Returns the Context for the specified component.

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthSliderUI

Returns the Context for the specified component.

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthSpinnerUI

Returns the Context for the specified component.

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthSplitPaneUI

Returns the Context for the specified component.

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthTabbedPaneUI

Returns the Context for the specified component.

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthTableHeaderUI

Returns the Context for the specified component.

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthTableUI

Returns the Context for the specified component.

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthTextAreaUI

Returns the Context for the specified component.

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthTextFieldUI

Returns the Context for the specified component.

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthToolBarUI

Returns the Context for the specified component.

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthToolTipUI

Returns the Context for the specified component.

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthTreeUI

Returns the Context for the specified component.

getContext(JComponent) - Method in interface javax.swing.plaf.synth.SynthUI

Returns the Context for the specified component.

getContext(JComponent) - Method in class javax.swing.plaf.synth.SynthViewportUI

Returns the Context for the specified component.

getContext() - Method in interface javax.xml.ws.Response

Gets the contained response context.

getContextClassLoader() - Method in class java.lang.Thread

Returns the context ClassLoader for this Thread.

getContextPath() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns the context path of all the endpoints in an application.

getContextualShaper(int) - Static method in class java.awt.font.NumericShaper

Returns a contextual shaper for the provided unicode range(s).

getContextualShaper(Set<NumericShaper.Range>) - Static method in class java.awt.font.NumericShaper

Returns a contextual shaper for the provided Unicode range(s).

getContextualShaper(int, int) - Static method in class java.awt.font.NumericShaper

Returns a contextual shaper for the provided unicode range(s).

getContextualShaper(Set<NumericShaper.Range>, NumericShaper.Range) - Static method in class java.awt.font.NumericShaper

Returns a contextual shaper for the provided Unicode range(s).

getContinuationContext(CannotProceedException) - Static method in class javax.naming.spi.NamingManager

Creates a context in which to continue a context operation.

getContinuationDirContext(CannotProceedException) - Static method in class javax.naming.spi.DirectoryManager

Creates a context in which to continue a DirContext operation.

getContinueExistingPeriodicTasksAfterShutdownPolicy() - Method in class java.util.concurrent.ScheduledThreadPoolExecutor

Gets the policy on whether to continue executing existing periodic tasks even when this executor has been shutdown.

getControl(List<String>) - Static method in class java.util.ResourceBundle.Control

Returns a ResourceBundle.Control in which the getFormats method returns the specified formats.

getControl(String) - Method in interface java.util.spi.ResourceBundleControlProvider

Returns a ResourceBundle.Control instance that is used to handle resource bundle loading for the given baseName.

getControl(Control.Type) - Method in interface javax.sound.sampled.Line

Obtains a control of the specified type, if there is any.

getControl() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the control color of the current theme.

getControl() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the control color.

getControlButtonsAreShown() - Method in class javax.swing.JFileChooser

Returns the value of the controlButtonsAreShown property.

getControlDarkShadow() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the control dark shadow color of the current theme.

getControlDarkShadow() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the control dark shadow color.

getControlDisabled() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the control disabled color of the current theme.

getControlDisabled() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the control disabled color.

getControlFlag() - Method in class javax.security.auth.login.AppConfigurationEntry

Return the controlFlag (either REQUIRED, REQUISITE, SUFFICIENT, or OPTIONAL) for this LoginModule.

getControlHighlight() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the control highlight color of the current theme.

getControlHighlight() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the control highlight color.

getControlInfo() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the control info color of the current theme.

getControlInfo() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the control info color.

getControlInstance(Control) - Method in class javax.naming.ldap.ControlFactory

Creates a control using this control factory.

getControlInstance(Control, Context, Hashtable<?, ?>) - Static method in class javax.naming.ldap.ControlFactory

Creates a control using known control factories.

getController() - Method in class javax.imageio.IIOParam

Returns whatever IIOParamController is currently installed.

getController() - Method in class javax.imageio.metadata.IIOMetadata

Returns whatever IIOMetadataController is currently installed.

getController(int) - Method in interface javax.sound.midi.MidiChannel

Obtains the current value of the specified controller.

getControlObject() - Method in interface java.awt.im.spi.InputMethod

Returns a control object from this input method, or null.

getControls() - Method in interface javax.naming.ldap.HasControls

Retrieves an array of Controls from the object that implements this interface.

getControls() - Method in interface javax.sound.sampled.Line

Obtains the set of controls associated with this line.

getControlShadow() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the control shadow color of the current theme.

getControlShadow() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the control shadow color.

getControlSize() - Method in class javax.swing.plaf.metal.MetalCheckBoxIcon

getControlTextColor() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the control text color of the current theme.

getControlTextColor() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the control text color.

getControlTextColor() - Method in class javax.swing.plaf.metal.OceanTheme

Returns the control text color.

getControlTextFont() - Method in class javax.swing.plaf.metal.DefaultMetalTheme

Returns the control text font.

getControlTextFont() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the control text font of the current theme.

getControlTextFont() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the control text font.

getConversion() - Method in exception java.util.FormatFlagsConversionMismatchException

Returns the incompatible conversion.

getConversion() - Method in exception java.util.IllegalFormatConversionException

Returns the inapplicable conversion.

getConversion() - Method in exception java.util.UnknownFormatConversionException

Returns the unknown conversion.

getCookie() - Method in class javax.naming.ldap.PagedResultsResponseControl

Retrieves the server-generated cookie.

getCookies() - Method in interface java.net.CookieStore

Get all not-expired cookies in cookie store.

getCookieStore() - Method in class java.net.CookieManager

To retrieve current cookie store.

getCopies() - Method in class java.awt.JobAttributes

Returns the number of copies the application should render for jobs using these attributes.

getCopies() - Method in class java.awt.print.PrinterJob

Gets the number of copies to be printed.

getCopyAction() - Static method in class javax.swing.TransferHandler

Returns an Action that performs copy operations to the clipboard.

getCorePoolSize() - Method in class java.util.concurrent.ThreadPoolExecutor

Returns the core number of threads.

getCorner(String) - Method in class javax.swing.JScrollPane

Returns the component at the specified corner.

getCorner(String) - Method in class javax.swing.ScrollPaneLayout

Returns the Component at the specified corner.

getCount() - Method in interface java.lang.management.BufferPoolMXBean

Returns an estimate of the number of buffers in the pool.

getCount() - Method in class java.lang.management.MemoryNotificationInfo

Returns the number of times that the memory usage has crossed a threshold when the notification was constructed.

getCount() - Method in class java.util.concurrent.CountDownLatch

Returns the current count.

getCount() - Method in class java.util.DoubleSummaryStatistics

Return the count of values recorded.

getCount() - Method in class java.util.IntSummaryStatistics

Returns the count of values recorded.

getCount() - Method in class java.util.LongSummaryStatistics

Returns the count of values recorded.

getCountLimit() - Method in class javax.naming.directory.SearchControls

Retrieves the maximum number of entries that will be returned as a result of the search.

getCountry() - Method in class java.util.Locale

Returns the country/region code for this locale, which should either be the empty string, an uppercase ISO 3166 2-letter code, or a UN M.49 3-digit code.

getCrc() - Method in class java.util.zip.ZipEntry

Returns the CRC-32 checksum of the uncompressed entry data.

getCreationDate(String) - Method in class java.security.KeyStore

Returns the creation date of the entry identified by the given alias.

getCreationTime() - Method in class java.util.zip.ZipEntry

Returns the creation time of the entry.

getCreationTime() - Method in interface javax.net.ssl.SSLSession

Returns the time at which this Session representation was created, in milliseconds since midnight, January 1, 1970 UTC.

getCredDelegState() - Method in interface org.ietf.jgss.GSSContext

Determines if credential delegation is enabled on this context.

getCredentialClass() - Method in class javax.security.auth.PrivateCredentialPermission

Returns the Class name of the Credential associated with this PrivateCredentialPermission.

getCriticalExtensionOIDs() - Method in interface java.security.cert.X509Extension

Gets a Set of the OID strings for the extension(s) marked CRITICAL in the certificate/CRL managed by the object implementing this interface.

getCRLs(CRLSelector) - Method in class java.security.cert.CertStore

Returns a Collection of CRLs that match the specified selector.

getCrossFeedResolution(int) - Method in class javax.print.attribute.ResolutionSyntax

Returns this resolution attribute's cross feed direction resolution in the given units.

getCrossFeedResolutionDphi() - Method in class javax.print.attribute.ResolutionSyntax

Returns this resolution attribute's cross feed direction resolution in units of dphi.

getCrossPlatformLookAndFeelClassName() - Static method in class javax.swing.UIManager

Returns the name of the LookAndFeel class that implements the default cross platform look and feel -- the Java Look and Feel (JLF).

getCrossReference(String, String, String, String, String, String) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of the foreign key columns in the given foreign key table that reference the primary key or the columns representing a unique constraint of the parent table (could be the same or a different table).

getCrtCoefficient() - Method in interface java.security.interfaces.RSAMultiPrimePrivateCrtKey

Returns the crtCoefficient.

getCrtCoefficient() - Method in interface java.security.interfaces.RSAPrivateCrtKey

Returns the crtCoefficient.

getCrtCoefficient() - Method in class java.security.spec.RSAMultiPrimePrivateCrtKeySpec

Returns the crtCoefficient.

getCrtCoefficient() - Method in class java.security.spec.RSAOtherPrimeInfo

Returns the prime's crtCoefficient.

getCrtCoefficient() - Method in class java.security.spec.RSAPrivateCrtKeySpec

Returns the crtCoefficient.

getCtrlKey() - Method in interface org.w3c.dom.events.MouseEvent

Used to indicate whether the 'ctrl' key was depressed during the firing of the event.

getCtrlP1() - Method in class java.awt.geom.CubicCurve2D.Double

Returns the first control point.

getCtrlP1() - Method in class java.awt.geom.CubicCurve2D.Float

Returns the first control point.

getCtrlP1() - Method in class java.awt.geom.CubicCurve2D

Returns the first control point.

getCtrlP2() - Method in class java.awt.geom.CubicCurve2D.Double

Returns the second control point.

getCtrlP2() - Method in class java.awt.geom.CubicCurve2D.Float

Returns the second control point.

getCtrlP2() - Method in class java.awt.geom.CubicCurve2D

Returns the second control point.

getCtrlPt() - Method in class java.awt.geom.QuadCurve2D.Double

Returns the control point.

getCtrlPt() - Method in class java.awt.geom.QuadCurve2D.Float

Returns the control point.

getCtrlPt() - Method in class java.awt.geom.QuadCurve2D

Returns the control point.

getCtrlX() - Method in class java.awt.geom.QuadCurve2D.Double

Returns the X coordinate of the control point in double precision.

getCtrlX() - Method in class java.awt.geom.QuadCurve2D.Float

Returns the X coordinate of the control point in double precision.

getCtrlX() - Method in class java.awt.geom.QuadCurve2D

Returns the X coordinate of the control point in double precision.

getCtrlX1() - Method in class java.awt.geom.CubicCurve2D.Double

Returns the X coordinate of the first control point in double precision.

getCtrlX1() - Method in class java.awt.geom.CubicCurve2D.Float

Returns the X coordinate of the first control point in double precision.

getCtrlX1() - Method in class java.awt.geom.CubicCurve2D

Returns the X coordinate of the first control point in double precision.

getCtrlX2() - Method in class java.awt.geom.CubicCurve2D.Double

Returns the X coordinate of the second control point in double precision.

getCtrlX2() - Method in class java.awt.geom.CubicCurve2D.Float

Returns the X coordinate of the second control point in double precision.

getCtrlX2() - Method in class java.awt.geom.CubicCurve2D

Returns the X coordinate of the second control point in double precision.

getCtrlY() - Method in class java.awt.geom.QuadCurve2D.Double

Returns the Y coordinate of the control point in double precision.

getCtrlY() - Method in class java.awt.geom.QuadCurve2D.Float

Returns the Y coordinate of the control point in double precision.

getCtrlY() - Method in class java.awt.geom.QuadCurve2D

Returns the Y coordinate of the control point in double precision.

getCtrlY1() - Method in class java.awt.geom.CubicCurve2D.Double

Returns the Y coordinate of the first control point in double precision.

getCtrlY1() - Method in class java.awt.geom.CubicCurve2D.Float

Returns the Y coordinate of the first control point in double precision.

getCtrlY1() - Method in class java.awt.geom.CubicCurve2D

Returns the Y coordinate of the first control point in double precision.

getCtrlY2() - Method in class java.awt.geom.CubicCurve2D.Double

Returns the Y coordinate of the second control point in double precision.

getCtrlY2() - Method in class java.awt.geom.CubicCurve2D.Float

Returns the Y coordinate of the second control point in double precision.

getCtrlY2() - Method in class java.awt.geom.CubicCurve2D

Returns the Y coordinate of the second control point in double precision.

getCurrency() - Method in class java.text.DecimalFormat

Gets the currency used by this decimal format when formatting currency values.

getCurrency() - Method in class java.text.DecimalFormatSymbols

Gets the currency of these DecimalFormatSymbols.

getCurrency() - Method in class java.text.NumberFormat

Gets the currency used by this number format when formatting currency values.

getCurrencyCode() - Method in class java.util.Currency

Gets the ISO 4217 currency code of this currency.

getCurrencyInstance() - Static method in class java.text.NumberFormat

Returns a currency format for the current default FORMAT locale.

getCurrencyInstance(Locale) - Static method in class java.text.NumberFormat

Returns a currency format for the specified locale.

getCurrencyInstance(Locale) - Method in class java.text.spi.NumberFormatProvider

Returns a new NumberFormat instance which formats monetary values for the specified locale.

getCurrencySymbol() - Method in class java.text.DecimalFormatSymbols

Returns the currency symbol for the currency of these DecimalFormatSymbols in their locale.

getCurrent() - Method in class java.awt.CheckboxGroup

Deprecated.
As of JDK version 1.1, replaced by getSelectedCheckbox().

getCurrentAccessibleContext() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the AccessibleContext for the table cell renderer.

getCurrentAccessibleValue() - Method in class java.awt.Button.AccessibleAWTButton

Get the value of this object as a Number.

getCurrentAccessibleValue() - Method in class java.awt.Checkbox.AccessibleAWTCheckbox

Get the value of this object as a Number.

getCurrentAccessibleValue() - Method in class java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem

Get the value of this object as a Number.

getCurrentAccessibleValue() - Method in class java.awt.MenuItem.AccessibleAWTMenuItem

Get the value of this object as a Number.

getCurrentAccessibleValue() - Method in class java.awt.Scrollbar.AccessibleAWTScrollBar

Get the accessible value of this object.

getCurrentAccessibleValue() - Method in interface javax.accessibility.AccessibleValue

Get the value of this object as a Number.

getCurrentAccessibleValue() - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Get the value of this object as a Number.

getCurrentAccessibleValue() - Method in class javax.swing.JInternalFrame.AccessibleJInternalFrame

Get the value of this object as a Number.

getCurrentAccessibleValue() - Method in class javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon

Gets the value of this object as a Number.

getCurrentAccessibleValue() - Method in class javax.swing.JProgressBar.AccessibleJProgressBar

Gets the accessible value of this object.

getCurrentAccessibleValue() - Method in class javax.swing.JScrollBar.AccessibleJScrollBar

Get the accessible value of this object.

getCurrentAccessibleValue() - Method in class javax.swing.JSlider.AccessibleJSlider

Get the accessible value of this object.

getCurrentAccessibleValue() - Method in class javax.swing.JSpinner.AccessibleJSpinner

Get the value of this object as a Number.

getCurrentAccessibleValue() - Method in class javax.swing.JSplitPane.AccessibleJSplitPane

Gets the accessible value of this object.

getCurrentComponent() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the table cell renderer component.

getCurrentDataFlavors() - Method in class java.awt.dnd.DropTargetContext

get the available DataFlavors of the Transferable operand of this operation.

getCurrentDataFlavors() - Method in class java.awt.dnd.DropTargetDragEvent

This method returns the current DataFlavors from the DropTargetContext.

getCurrentDataFlavors() - Method in class java.awt.dnd.DropTargetDropEvent

This method returns the current DataFlavors.

getCurrentDataFlavorsAsList() - Method in class java.awt.dnd.DropTargetContext

This method returns a the currently available DataFlavors of the Transferable operand as a java.util.List.

getCurrentDataFlavorsAsList() - Method in class java.awt.dnd.DropTargetDragEvent

This method returns the current DataFlavors as a java.util.List

getCurrentDataFlavorsAsList() - Method in class java.awt.dnd.DropTargetDropEvent

This method returns the currently available DataFlavors as a java.util.List.

getCurrentDirectory() - Method in class javax.swing.JFileChooser

Returns the current directory.

getCurrentEvent() - Static method in class java.awt.EventQueue

Returns the the event currently being dispatched by the EventQueue associated with the calling thread.

getCurrentFocusCycleRoot() - Method in class java.awt.KeyboardFocusManager

Returns the current focus cycle root, if the current focus cycle root is in the same context as the calling thread.

getCurrentKeyboardFocusManager() - Static method in class java.awt.KeyboardFocusManager

Returns the current KeyboardFocusManager instance for the calling thread's context.

getCurrentLine() - Method in class javax.swing.text.html.parser.Parser

getCurrentLineLength() - Method in class javax.swing.text.AbstractWriter

Returns the current line length.

getCurrentManager() - Static method in class javax.swing.FocusManager

Returns the current KeyboardFocusManager instance for the calling thread's context.

getCurrentPoint() - Method in class java.awt.geom.Path2D

Returns the coordinates most recently added to the end of the path as a Point2D object.

getCurrentPos() - Method in class javax.swing.text.html.parser.Parser

getCurrentServiceClasses() - Method in interface java.beans.beancontext.BeanContextServices

Gets the currently available services for this context.

getCurrentServiceClasses() - Method in class java.beans.beancontext.BeanContextServicesSupport

getCurrentServiceSelectors() - Method in class java.beans.beancontext.BeanContextServiceAvailableEvent

Gets the list of service dependent selectors.

getCurrentServiceSelectors(BeanContextServices, Class) - Method in interface java.beans.beancontext.BeanContextServiceProvider

Invoked by BeanContextServices, this method gets the current service selectors for the specified service.

getCurrentServiceSelectors(Class) - Method in interface java.beans.beancontext.BeanContextServices

Gets the list of service dependent service parameters (Service Selectors) for the specified service, by calling getCurrentServiceSelectors() on the underlying BeanContextServiceProvider.

getCurrentServiceSelectors(BeanContextServices, Class) - Method in class java.beans.beancontext.BeanContextServicesSupport.BCSSProxyServiceProvider

getCurrentServiceSelectors(Class) - Method in class java.beans.beancontext.BeanContextServicesSupport

getCurrentTarget() - Method in interface org.w3c.dom.events.Event

Used to indicate the EventTarget whose EventListeners are currently being processed.

getCurrentTheme() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Return the theme currently being used by MetalLookAndFeel.

getCurrentThreadCpuTime() - Method in interface java.lang.management.ThreadMXBean

Returns the total CPU time for the current thread in nanoseconds.

getCurrentThreadUserTime() - Method in interface java.lang.management.ThreadMXBean

Returns the CPU time that the current thread has executed in user mode in nanoseconds.

getCurrentWriter() - Method in class javax.swing.text.AbstractDocument

Fetches the current writing thread if there is one.

getCursor() - Method in class java.awt.Component.AccessibleAWTComponent

Gets the Cursor of this object.

getCursor() - Method in class java.awt.Component

Gets the cursor set in the component.

getCursor() - Method in class java.awt.dnd.DragSourceContext

Returns the current drag Cursor.

getCursor() - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Get the Cursor of this object.

getCursor() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Gets the Cursor of this object.

getCursor() - Method in interface javax.accessibility.AccessibleComponent

Gets the Cursor of this object.

getCursor() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getCursor() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the Cursor of this object.

getCursor() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

getCursor() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getCursorName() - Method in interface java.sql.ResultSet

Retrieves the name of the SQL cursor used by this ResultSet object.

getCursorType() - Method in class java.awt.Frame

Deprecated.
As of JDK version 1.1, replaced by Component.getCursor().

getCurve() - Method in class java.security.spec.ECParameterSpec

Returns the elliptic curve that this parameter defines.

getCustomEditor() - Method in interface java.beans.PropertyEditor

A PropertyEditor may choose to make available a full custom Component that edits its property value.

getCustomEditor() - Method in class java.beans.PropertyEditorSupport

A PropertyEditor may chose to make available a full custom Component that edits its property value.

getCustomizerClass() - Method in class java.beans.BeanDescriptor

Gets the Class object for the bean's customizer.

getCutAction() - Static method in class javax.swing.TransferHandler

Returns an Action that performs cut operations to the clipboard.

getCycleMethod() - Method in class java.awt.MultipleGradientPaint

Returns the enumerated type which specifies cycling behavior.

getDaemonThreadCount() - Method in interface java.lang.management.ThreadMXBean

Returns the current number of live daemon threads.

getDashArray() - Method in class java.awt.BasicStroke

Returns the array representing the lengths of the dash segments.

getDashPhase() - Method in class java.awt.BasicStroke

Returns the current dash phase.

getData() - Method in class java.awt.color.ICC_Profile

Returns a byte array corresponding to the data of this ICC_Profile.

getData(int) - Method in class java.awt.color.ICC_Profile

Returns a particular tagged data element from the profile as a byte array.

getData(DataFlavor) - Method in class java.awt.datatransfer.Clipboard

Returns an object representing the current contents of this clipboard in the specified DataFlavor.

getData() - Method in class java.awt.image.BufferedImage

Returns the image as one large tile.

getData(Rectangle) - Method in class java.awt.image.BufferedImage

Computes and returns an arbitrary region of the BufferedImage.

getData() - Method in class java.awt.image.DataBufferByte

Returns the default (first) byte data array.

getData(int) - Method in class java.awt.image.DataBufferByte

Returns the data array for the specified bank.

getData() - Method in class java.awt.image.DataBufferDouble

Returns the default (first) double data array.

getData(int) - Method in class java.awt.image.DataBufferDouble

Returns the data array for the specified bank.

getData() - Method in class java.awt.image.DataBufferFloat

Returns the default (first) float data array.

getData(int) - Method in class java.awt.image.DataBufferFloat

Returns the data array for the specified bank.

getData() - Method in class java.awt.image.DataBufferInt

Returns the default (first) int data array in DataBuffer.

getData(int) - Method in class java.awt.image.DataBufferInt

Returns the data array for the specified bank.

getData() - Method in class java.awt.image.DataBufferShort

Returns the default (first) byte data array.

getData(int) - Method in class java.awt.image.DataBufferShort

Returns the data array for the specified bank.

getData() - Method in class java.awt.image.DataBufferUShort

Returns the default (first) unsigned-short data array.

getData(int) - Method in class java.awt.image.DataBufferUShort

Returns the data array for the specified bank.

getData() - Method in interface java.awt.image.RenderedImage

Returns the image as one large tile (for tile based images this will require fetching the whole image and copying the image data over).

getData(Rectangle) - Method in interface java.awt.image.RenderedImage

Computes and returns an arbitrary region of the RenderedImage.

getData() - Method in class java.net.DatagramPacket

Returns the data buffer.

getData() - Method in class java.rmi.activation.ActivationDesc

Returns a "marshalled object" containing intialization/activation data for the object specified by this descriptor.

getData() - Method in class java.rmi.activation.ActivationGroupDesc

Returns the group's initialization data.

getData() - Method in class javax.imageio.stream.IIOByteBuffer

Returns a reference to the byte array.

getData() - Method in class javax.sound.midi.MetaMessage

Obtains a copy of the data for the meta message.

getData() - Method in class javax.sound.midi.SoundbankResource

Obtains the sampled audio that is stored in this SoundbankResource.

getData() - Method in class javax.sound.midi.SysexMessage

Obtains a copy of the data for the system exclusive message.

getData() - Method in class javax.swing.text.html.FormSubmitEvent

Gets the form submission data.

getData() - Method in class javax.swing.text.html.parser.Entity

Returns the data.

getData() - Method in interface javax.xml.stream.events.Characters

Get the character data of this event

getData() - Method in interface javax.xml.stream.events.ProcessingInstruction

The data section of the processing instruction

getData() - Method in interface org.w3c.dom.CharacterData

The character data of the node that implements this interface.

getData() - Method in interface org.w3c.dom.ProcessingInstruction

The content of this processing instruction.

getData1() - Method in class javax.sound.midi.ShortMessage

Obtains the first data byte in the message.

getData2() - Method in class javax.sound.midi.ShortMessage

Obtains the second data byte in the message.

getDatabaseMajorVersion() - Method in interface java.sql.DatabaseMetaData

Retrieves the major version number of the underlying database.

getDatabaseMinorVersion() - Method in interface java.sql.DatabaseMetaData

Retrieves the minor version number of the underlying database.

getDatabaseProductName() - Method in interface java.sql.DatabaseMetaData

Retrieves the name of this database product.

getDatabaseProductVersion() - Method in interface java.sql.DatabaseMetaData

Retrieves the version number of this database product.

getDataBitOffset() - Method in class java.awt.image.MultiPixelPackedSampleModel

Returns the data bit offset in bits.

getDataBuffer() - Method in class java.awt.image.Raster

Returns the DataBuffer associated with this Raster.

getDataClass() - Method in class javax.sound.midi.SoundbankResource

Obtains the class used by this sample to represent its data.

getDataElement(int[], int) - Method in class java.awt.image.ColorModel

Returns a pixel value represented as an int in this ColorModel, given an array of unnormalized color/alpha components.

getDataElement(float[], int) - Method in class java.awt.image.ColorModel

Returns a pixel value represented as an int in this ColorModel, given an array of normalized color/alpha components.

getDataElement(int[], int) - Method in class java.awt.image.ComponentColorModel

Returns a pixel value represented as an int in this ColorModel, given an array of unnormalized color/alpha components.

getDataElement(float[], int) - Method in class java.awt.image.ComponentColorModel

Returns a pixel value represented as an int in this ColorModel, given an array of normalized color/alpha components.

getDataElement(int[], int) - Method in class java.awt.image.DirectColorModel

Returns a pixel value represented as an int in this ColorModel, given an array of unnormalized color/alpha components.

getDataElement(int[], int) - Method in class java.awt.image.IndexColorModel

Returns a pixel value represented as an int in this ColorModel given an array of unnormalized color/alpha components.

getDataElements(int, int, Object, DataBuffer) - Method in class java.awt.image.BandedSampleModel

Returns data for a single pixel in a primitive array of type TransferType.

getDataElements(int, Object) - Method in class java.awt.image.ColorModel

Returns a data element array representation of a pixel in this ColorModel, given an integer pixel representation in the default RGB color model.

getDataElements(int[], int, Object) - Method in class java.awt.image.ColorModel

Returns a data element array representation of a pixel in this ColorModel, given an array of unnormalized color/alpha components.

getDataElements(float[], int, Object) - Method in class java.awt.image.ColorModel

Returns a data element array representation of a pixel in this ColorModel, given an array of normalized color/alpha components.

getDataElements(int, Object) - Method in class java.awt.image.ComponentColorModel

Returns a data element array representation of a pixel in this ColorModel, given an integer pixel representation in the default RGB color model.

getDataElements(int[], int, Object) - Method in class java.awt.image.ComponentColorModel

Returns a data element array representation of a pixel in this ColorModel, given an array of unnormalized color/alpha components.

getDataElements(float[], int, Object) - Method in class java.awt.image.ComponentColorModel

Returns a data element array representation of a pixel in this ColorModel, given an array of normalized color/alpha components.

getDataElements(int, int, Object, DataBuffer) - Method in class java.awt.image.ComponentSampleModel

Returns data for a single pixel in a primitive array of type TransferType.

getDataElements(int, Object) - Method in class java.awt.image.DirectColorModel

Returns a data element array representation of a pixel in this ColorModel, given an integer pixel representation in the default RGB color model.

getDataElements(int[], int, Object) - Method in class java.awt.image.DirectColorModel

Returns a data element array representation of a pixel in this ColorModel, given an array of unnormalized color/alpha components.

getDataElements(int, Object) - Method in class java.awt.image.IndexColorModel

Returns a data element array representation of a pixel in this ColorModel, given an integer pixel representation in the default RGB color model.

getDataElements(int[], int, Object) - Method in class java.awt.image.IndexColorModel

Returns a data element array representation of a pixel in this ColorModel given an array of unnormalized color/alpha components.

getDataElements(int, int, Object, DataBuffer) - Method in class java.awt.image.MultiPixelPackedSampleModel

Returns data for a single pixel in a primitive array of type TransferType.

getDataElements(int, int, Object) - Method in class java.awt.image.Raster

Returns data for a single pixel in a primitive array of type TransferType.

getDataElements(int, int, int, int, Object) - Method in class java.awt.image.Raster

Returns the pixel data for the specified rectangle of pixels in a primitive array of type TransferType.

getDataElements(int, int, Object, DataBuffer) - Method in class java.awt.image.SampleModel

Returns data for a single pixel in a primitive array of type TransferType.

getDataElements(int, int, int, int, Object, DataBuffer) - Method in class java.awt.image.SampleModel

Returns the pixel data for the specified rectangle of pixels in a primitive array of type TransferType.

getDataElements(int, int, Object, DataBuffer) - Method in class java.awt.image.SinglePixelPackedSampleModel

Returns data for a single pixel in a primitive array of type TransferType.

getDataFlavors() - Method in class javax.swing.TransferHandler.TransferSupport

Returns the data flavors for this transfer.

getDataHandler() - Method in class javax.xml.soap.AttachmentPart

Gets the DataHandler object for this AttachmentPart object.

getDataLength(int) - Method in class javax.sound.midi.ShortMessage

Retrieves the number of data bytes associated with a particular status byte value.

getDatalink() - Method in class javax.sql.rowset.serial.SerialDatalink

Returns a new URL that is a copy of this SerialDatalink object.

getDataSize() - Method in exception java.sql.DataTruncation

Gets the number of bytes of data that should have been transferred.

getDataSource() - Method in class javax.activation.DataHandler

Return the DataSource associated with this instance of DataHandler.

getDataSourceLock() - Method in class javax.sql.rowset.spi.SyncProvider

Returns the current data source lock severity level active in this SyncProvider implementation.

getDataSourceName() - Method in class javax.sql.rowset.BaseRowSet

Returns the logical name that when supplied to a naming service that uses the Java Naming and Directory Interface (JNDI) API, will retrieve a javax.sql.DataSource object.

getDataSourceName() - Method in interface javax.sql.RowSet

Retrieves the logical name that identifies the data source for this RowSet object.

getDataType() - Method in class java.awt.image.DataBuffer

Returns the data type of this DataBuffer.

getDataType() - Method in class java.awt.image.SampleModel

Returns the data type of the DataBuffer storing the pixel data.

getDataTypeSize(int) - Static method in class java.awt.image.DataBuffer

Returns the size (in bits) of the data type, given a datatype tag.

getDataVector() - Method in class javax.swing.table.DefaultTableModel

Returns the Vector of Vectors that contains the table's data values.

getDate() - Method in class java.net.URLConnection

Returns the value of the date header field.

getDate() - Method in class java.security.cert.PKIXParameters

Returns the time for which the validity of the certification path should be determined.

getDate(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC DATE parameter as a java.sql.Date object.

getDate(int, Calendar) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC DATE parameter as a java.sql.Date object, using the given Calendar object to construct the date.

getDate(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC DATE parameter as a java.sql.Date object.

getDate(String, Calendar) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC DATE parameter as a java.sql.Date object, using the given Calendar object to construct the date.

getDate(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.sql.Date object in the Java programming language.

getDate(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.sql.Date object in the Java programming language.

getDate(int, Calendar) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.sql.Date object in the Java programming language.

getDate(String, Calendar) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.sql.Date object in the Java programming language.

getDate() - Method in class java.sql.Time

Deprecated.

getDate() - Method in class java.util.Date

Deprecated.
As of JDK version 1.1, replaced by Calendar.get(Calendar.DAY_OF_MONTH).

getDate(Integer) - Method in class javax.management.timer.Timer

Gets a copy of the date associated to a timer notification.

getDate(Integer) - Method in interface javax.management.timer.TimerMBean

Gets a copy of the date associated to a timer notification.

getDate() - Method in class javax.swing.SpinnerDateModel

Returns the current element in this sequence of Dates.

getDateAndTime() - Method in class java.security.cert.X509CRLSelector

Returns the dateAndTime criterion.

getDateFormatSymbols() - Method in class java.text.SimpleDateFormat

Gets a copy of the date and time format symbols of this date format.

getDateInstance() - Static method in class java.text.DateFormat

Gets the date formatter with the default formatting style for the default FORMAT locale.

getDateInstance(int) - Static method in class java.text.DateFormat

Gets the date formatter with the given formatting style for the default FORMAT locale.

getDateInstance(int, Locale) - Static method in class java.text.DateFormat

Gets the date formatter with the given formatting style for the given locale.

getDateInstance(int, Locale) - Method in class java.text.spi.DateFormatProvider

Returns a new DateFormat instance which formats date with the given formatting style for the specified locale.

getDateTimeAfter() - Method in class java.time.zone.ZoneOffsetTransition

Gets the local transition date-time, as would be expressed with the 'after' offset.

getDateTimeBefore() - Method in class java.time.zone.ZoneOffsetTransition

Gets the local transition date-time, as would be expressed with the 'before' offset.

getDateTimeInstance() - Static method in class java.text.DateFormat

Gets the date/time formatter with the default formatting style for the default FORMAT locale.

getDateTimeInstance(int, int) - Static method in class java.text.DateFormat

Gets the date/time formatter with the given date and time formatting styles for the default FORMAT locale.

getDateTimeInstance(int, int, Locale) - Static method in class java.text.DateFormat

Gets the date/time formatter with the given formatting styles for the given locale.

getDateTimeInstance(int, int, Locale) - Method in class java.text.spi.DateFormatProvider

Returns a new DateFormat instance which formats date and time with the given formatting style for the specified locale.

getDay() - Method in class java.sql.Time

Deprecated.

getDay() - Method in class java.util.Date

Deprecated.
As of JDK version 1.1, replaced by Calendar.get(Calendar.DAY_OF_WEEK).

getDay() - Method in class javax.xml.datatype.XMLGregorianCalendar

Return day in month or DatatypeConstants.FIELD_UNDEFINED.

getDaylightSavings(Instant) - Method in class java.time.zone.ZoneRules

Gets the amount of daylight savings in use for the specified instant in this zone.

getDayOfMonth() - Method in class java.time.LocalDate

Gets the day-of-month field.

getDayOfMonth() - Method in class java.time.LocalDateTime

Gets the day-of-month field.

getDayOfMonth() - Method in class java.time.MonthDay

Gets the day-of-month field.

getDayOfMonth() - Method in class java.time.OffsetDateTime

Gets the day-of-month field.

getDayOfMonth() - Method in class java.time.ZonedDateTime

Gets the day-of-month field.

getDayOfMonthIndicator() - Method in class java.time.zone.ZoneOffsetTransitionRule

Gets the indicator of the day-of-month of the transition.

getDayOfWeek() - Method in class java.time.LocalDate

Gets the day-of-week field, which is an enum DayOfWeek.

getDayOfWeek() - Method in class java.time.LocalDateTime

Gets the day-of-week field, which is an enum DayOfWeek.

getDayOfWeek() - Method in class java.time.OffsetDateTime

Gets the day-of-week field, which is an enum DayOfWeek.

getDayOfWeek() - Method in class java.time.zone.ZoneOffsetTransitionRule

Gets the day-of-week of the transition.

getDayOfWeek() - Method in class java.time.ZonedDateTime

Gets the day-of-week field, which is an enum DayOfWeek.

getDayOfYear() - Method in class java.time.LocalDate

Gets the day-of-year field.

getDayOfYear() - Method in class java.time.LocalDateTime

Gets the day-of-year field.

getDayOfYear() - Method in class java.time.OffsetDateTime

Gets the day-of-year field.

getDayOfYear() - Method in class java.time.ZonedDateTime

Gets the day-of-year field.

getDays() - Method in class java.time.Period

Gets the amount of days of this period.

getDays() - Method in class javax.xml.datatype.Duration

Obtains the value of the DAYS field as an integer value, or 0 if not present.

getDCHuffmanTables() - Method in class javax.imageio.plugins.jpeg.JPEGImageReadParam

Returns a copy of the array of DC Huffman tables set on the most recent call to setDecodeTables, or null if tables are not currently set.

getDCHuffmanTables() - Method in class javax.imageio.plugins.jpeg.JPEGImageWriteParam

Returns a copy of the array of DC Huffman tables set on the most recent call to setEncodeTables, or null if tables are not currently set.

getDebugGraphicsOptions() - Method in class javax.swing.JComponent

Returns the state of graphics debugging.

getDebugOptions() - Method in class javax.swing.DebugGraphics

Returns the current debugging options for this DebugGraphics.

getDecayTime() - Method in class javax.sound.sampled.ReverbType

Obtains the decay time, which is the amount of time over which the late reflections attenuate to effective zero.

getDecimalFormatSymbols() - Method in class java.text.DecimalFormat

Returns a copy of the decimal format symbols, which is generally not changed by the programmer or user.

getDecimalSeparator() - Method in class java.text.DecimalFormatSymbols

Gets the character used for decimal sign.

getDecimalSeparator() - Method in class java.time.format.DecimalStyle

Gets the character that represents the decimal point.

getDecimalStyle() - Method in class java.time.format.DateTimeFormatter

Gets the DecimalStyle to be used during formatting.

getDeclaration(String) - Method in class javax.swing.text.html.StyleSheet

Translates a CSS declaration to an AttributeSet that represents the CSS declaration.

getDeclaration() - Method in interface javax.xml.stream.events.EntityReference

Return the declaration of this entity.

getDeclaredAnnotation(Class<A>) - Method in class java.lang.Class

getDeclaredAnnotation(Class<A>) - Method in class java.lang.Package

getDeclaredAnnotation(Class<T>) - Method in class java.lang.reflect.AccessibleObject

getDeclaredAnnotation(Class<T>) - Method in interface java.lang.reflect.AnnotatedElement

Returns this element's annotation for the specified type if such an annotation is directly present, else null.

getDeclaredAnnotation(Class<T>) - Method in class java.lang.reflect.Parameter

getDeclaredAnnotations() - Method in class java.lang.Class

getDeclaredAnnotations() - Method in class java.lang.Package

getDeclaredAnnotations() - Method in class java.lang.reflect.AccessibleObject

getDeclaredAnnotations() - Method in interface java.lang.reflect.AnnotatedElement

Returns annotations that are directly present on this element.

getDeclaredAnnotations() - Method in class java.lang.reflect.Constructor

Returns annotations that are directly present on this element.

getDeclaredAnnotations() - Method in class java.lang.reflect.Executable

Returns annotations that are directly present on this element.

getDeclaredAnnotations() - Method in class java.lang.reflect.Field

Returns annotations that are directly present on this element.

getDeclaredAnnotations() - Method in class java.lang.reflect.Method

Returns annotations that are directly present on this element.

getDeclaredAnnotations() - Method in class java.lang.reflect.Parameter

Returns annotations that are directly present on this element.

getDeclaredAnnotationsByType(Class<A>) - Method in class java.lang.Class

getDeclaredAnnotationsByType(Class<A>) - Method in class java.lang.Package

getDeclaredAnnotationsByType(Class<T>) - Method in class java.lang.reflect.AccessibleObject

getDeclaredAnnotationsByType(Class<T>) - Method in interface java.lang.reflect.AnnotatedElement

Returns this element's annotation(s) for the specified type if such annotations are either directly present or indirectly present.

getDeclaredAnnotationsByType(Class<T>) - Method in class java.lang.reflect.Parameter

getDeclaredClasses() - Method in class java.lang.Class

Returns an array of Class objects reflecting all the classes and interfaces declared as members of the class represented by this Class object.

getDeclaredConstructor(Class<?>...) - Method in class java.lang.Class

Returns a Constructor object that reflects the specified constructor of the class or interface represented by this Class object.

getDeclaredConstructors() - Method in class java.lang.Class

Returns an array of Constructor objects reflecting all the constructors declared by the class represented by this Class object.

getDeclaredField(String) - Method in class java.lang.Class

Returns a Field object that reflects the specified declared field of the class or interface represented by this Class object.

getDeclaredFields() - Method in class java.lang.Class

Returns an array of Field objects reflecting all the fields declared by the class or interface represented by this Class object.

getDeclaredMethod(String, Class<?>...) - Method in class java.lang.Class

Returns a Method object that reflects the specified declared method of the class or interface represented by this Class object.

getDeclaredMethods() - Method in class java.lang.Class

Returns an array containing Method objects reflecting all the declared methods of the class or interface represented by this Class object, including public, protected, default (package) access, and private methods, but excluding inherited methods.

getDeclaredPrefixes() - Method in class org.xml.sax.helpers.NamespaceSupport

Return an enumeration of all prefixes declared in this context.

getDeclaredType(TypeElement, TypeMirror...) - Method in interface javax.lang.model.util.Types

Returns the type corresponding to a type element and actual type arguments.

getDeclaredType(DeclaredType, TypeElement, TypeMirror...) - Method in interface javax.lang.model.util.Types

Returns the type corresponding to a type element and actual type arguments, given a containing type of which it is a member.

getDeclaredType() - Method in class javax.xml.bind.JAXBElement

Returns the Java binding of the xml element declaration's type attribute.

getDeclaringClass() - Method in class java.lang.Class

If the class or interface represented by this Class object is a member of another class, returns the Class object representing the class in which it was declared.

getDeclaringClass() - Method in class java.lang.Enum

Returns the Class object corresponding to this enum constant's enum type.

getDeclaringClass() - Method in interface java.lang.invoke.MethodHandleInfo

Returns the class in which the cracked method handle's underlying member was defined.

getDeclaringClass() - Method in class java.lang.reflect.Constructor

Returns the Class object representing the class or interface that declares the executable represented by this object.

getDeclaringClass() - Method in class java.lang.reflect.Executable

Returns the Class object representing the class or interface that declares the executable represented by this object.

getDeclaringClass() - Method in class java.lang.reflect.Field

Returns the Class object representing the class or interface that declares the field represented by this Field object.

getDeclaringClass() - Method in interface java.lang.reflect.Member

Returns the Class object representing the class or interface that declares the member or constructor represented by this Member.

getDeclaringClass() - Method in class java.lang.reflect.Method

Returns the Class object representing the class or interface that declares the executable represented by this object.

getDeclaringExecutable() - Method in class java.lang.reflect.Parameter

Return the Executable which declares this parameter.

getDecoder() - Static method in class java.util.Base64

Returns a Base64.Decoder that decodes using the Basic type base64 encoding scheme.

getDecomposition() - Method in class java.text.Collator

Get the decomposition mode of this Collator.

getDeepestComponentAt(Component, int, int) - Static method in class javax.swing.SwingUtilities

Returns the deepest visible descendent Component of parent that contains the location x, y.

getDefault() - Static method in class java.net.CookieHandler

Gets the system-wide cookie handler.

getDefault() - Static method in class java.net.ProxySelector

Gets the system-wide proxy selector.

getDefault() - Static method in class java.net.ResponseCache

Gets the system-wide response cache.

getDefault() - Static method in class java.nio.file.FileSystems

Returns the default FileSystem.

getDefault() - Static method in class java.util.Locale

Gets the current value of the default locale for this instance of the Java Virtual Machine.

getDefault(Locale.Category) - Static method in class java.util.Locale

Gets the current value of the default locale for the specified Category for this instance of the Java Virtual Machine.

getDefault() - Static method in class java.util.TimeZone

Gets the default TimeZone of the Java virtual machine.

getDefault() - Static method in class javax.net.ServerSocketFactory

Returns a copy of the environment's default socket factory.

getDefault() - Static method in class javax.net.SocketFactory

Returns a copy of the environment's default socket factory.

getDefault() - Static method in class javax.net.ssl.SSLContext

Returns the default SSL context.

getDefault() - Static method in class javax.net.ssl.SSLServerSocketFactory

Returns the default SSL server socket factory.

getDefault() - Static method in class javax.net.ssl.SSLSocketFactory

Returns the default SSL socket factory.

getDefaultAction() - Method in interface javax.swing.text.Keymap

Fetches the default action to fire if a key is typed (i.e.

getDefaultActions() - Method in class java.awt.dnd.DropTarget

Gets an int representing the current action(s) supported by this DropTarget.

getDefaultAlgorithm() - Static method in class javax.net.ssl.KeyManagerFactory

Obtains the default KeyManagerFactory algorithm name.

getDefaultAlgorithm() - Static method in class javax.net.ssl.TrustManagerFactory

Obtains the default TrustManagerFactory algorithm name.

getDefaultAllowUserInteraction() - Static method in class java.net.URLConnection

Returns the default value of the allowUserInteraction field.

getDefaultAttributeValue(Class<? extends Attribute>) - Method in interface javax.print.PrintService

Determines this print service's default printing attribute value in the given category.

getDefaultButton() - Method in class javax.swing.JRootPane

Returns the value of the defaultButton property.

getDefaultButton(JFileChooser) - Method in class javax.swing.plaf.basic.BasicFileChooserUI

getDefaultButton(JFileChooser) - Method in class javax.swing.plaf.FileChooserUI

Returns default button for current LookAndFeel.

getDefaultChoice() - Method in class javax.security.auth.callback.ChoiceCallback

Get the defaultChoice.

getDefaultChooserPanels() - Static method in class javax.swing.colorchooser.ColorChooserComponentFactory

getDefaultCipherSuites() - Method in class javax.net.ssl.SSLServerSocketFactory

Returns the list of cipher suites which are enabled by default.

getDefaultCipherSuites() - Method in class javax.net.ssl.SSLSocketFactory

Returns the list of cipher suites which are enabled by default.

getDefaultClassLoader() - Method in class javax.management.remote.rmi.RMIServerImpl

Gets the default ClassLoader used by this connector server.

getDefaultClosedIcon() - Method in class javax.swing.tree.DefaultTreeCellRenderer

Returns the default icon, for the current laf, that is used to represent non-leaf nodes that are not expanded.

getDefaultCloseOperation() - Method in class javax.swing.JDialog

Returns the operation which occurs when the user initiates a "close" on this dialog.

getDefaultCloseOperation() - Method in class javax.swing.JFrame

Returns the operation that occurs when the user initiates a "close" on this frame.

getDefaultCloseOperation() - Method in class javax.swing.JInternalFrame

Returns the default operation that occurs when the user initiates a "close" on this internal frame.

getDefaultCommandMap() - Static method in class javax.activation.CommandMap

Get the default CommandMap.

getDefaultComponent(Container) - Method in class java.awt.ContainerOrderFocusTraversalPolicy

Returns the default Component to focus.

getDefaultComponent(Container) - Method in class java.awt.FocusTraversalPolicy

Returns the default Component to focus.

getDefaultComponent(Container) - Method in class javax.swing.SortingFocusTraversalPolicy

Returns the default Component to focus.

getDefaultConfiguration() - Method in class java.awt.GraphicsDevice

Returns the default GraphicsConfiguration associated with this GraphicsDevice.

getDefaultController() - Method in class javax.imageio.IIOParam

Returns the default IIOParamController, if there is one, regardless of the currently installed controller.

getDefaultController() - Method in class javax.imageio.metadata.IIOMetadata

Returns the default IIOMetadataController, if there is one, regardless of the currently installed controller.

getDefaultCursor() - Static method in class java.awt.Cursor

Return the system default cursor.

getDefaultCursor() - Method in class javax.swing.text.html.HTMLEditorKit

Returns the default cursor.

getDefaultDirectory() - Method in class javax.swing.filechooser.FileSystemView

Return the user's default starting directory for the file chooser.

getDefaultDomain() - Method in interface javax.management.MBeanServer

getDefaultDomain() - Method in interface javax.management.MBeanServerConnection

Returns the default domain used for naming the MBean.

getDefaultDomain(Subject) - Method in interface javax.management.remote.rmi.RMIConnection

Handles the method MBeanServerConnection.getDefaultDomain().

getDefaultDomain(Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl

getDefaultDomain(Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub

getDefaultDragSource() - Static method in class java.awt.dnd.DragSource

Gets the DragSource object associated with the underlying platform.

getDefaultEditor(Class<?>) - Method in class javax.swing.JTable

Returns the editor to be used when no editor has been set in a TableColumn.

getDefaultEventIndex() - Method in interface java.beans.BeanInfo

A bean may have a default event typically applied when this bean is used.

getDefaultEventIndex() - Method in class java.beans.SimpleBeanInfo

Deny knowledge of a default event.

getDefaultFileTypeMap() - Static method in class javax.activation.FileTypeMap

Return the default FileTypeMap for the system.

getDefaultFlavorMap() - Static method in class java.awt.datatransfer.SystemFlavorMap

Returns the default FlavorMap for this thread's ClassLoader.

getDefaultFocusTraversalKeys(int) - Method in class java.awt.KeyboardFocusManager

Returns a Set of default focus traversal keys for a given traversal operation.

getDefaultFocusTraversalPolicy() - Method in class java.awt.KeyboardFocusManager

Returns the default FocusTraversalPolicy.

getDefaultFormatter() - Method in class javax.swing.text.DefaultFormatterFactory

Returns the JFormattedTextField.AbstractFormatter to use as a last resort, eg in case a display, edit or null JFormattedTextField.AbstractFormatter has not been specified.

getDefaultFractionDigits() - Method in class java.util.Currency

Gets the default number of fraction digits used with this currency.

getDefaultHostnameVerifier() - Static method in class javax.net.ssl.HttpsURLConnection

Gets the default HostnameVerifier that is inherited by new instances of this class.

getDefaultIcon() - Method in class javax.swing.plaf.basic.BasicRadioButtonUI

getDefaultIcon(AbstractButton) - Method in class javax.swing.plaf.synth.SynthButtonUI

Returns the default icon.

getDefaultImageMetadata(ImageTypeSpecifier, ImageWriteParam) - Method in class javax.imageio.ImageWriter

Returns an IIOMetadata object containing default values for encoding an image of the given type.

getDefaultInitCtx() - Method in class javax.naming.InitialContext

Retrieves the initial context by calling NamingManager.getInitialContext() and cache it in defaultInitCtx.

getDefaultInstance() - Static method in class javax.imageio.spi.IIORegistry

Returns the default IIORegistry instance used by the Image I/O API.

getDefaultLeafIcon() - Method in class javax.swing.tree.DefaultTreeCellRenderer

Returns the default icon, for the current laf, that is used to represent leaf nodes.

getDefaultLightWeightPopupEnabled() - Static method in class javax.swing.JPopupMenu

Gets the defaultLightWeightPopupEnabled property, which by default is true.

getDefaultLocale() - Static method in class javax.swing.JComponent

Returns the default locale used to initialize each JComponent's locale property upon creation.

getDefaultLocale() - Method in class javax.swing.UIDefaults

Returns the default locale.

getDefaultName() - Method in class javax.security.auth.callback.NameCallback

Get the default name.

getDefaultNamespacePrefix() - Method in class javax.xml.crypto.dom.DOMCryptoContext

getDefaultNamespacePrefix() - Method in interface javax.xml.crypto.XMLCryptoContext

Returns the default namespace prefix.

getDefaultOpenIcon() - Method in class javax.swing.tree.DefaultTreeCellRenderer

Returns the default icon, for the current laf, that is used to represent non-leaf nodes that are expanded.

getDefaultOption() - Method in class javax.security.auth.callback.ConfirmationCallback

Get the default option.

getDefaultPort() - Method in class java.net.URL

Gets the default port number of the protocol associated with this URL.

getDefaultPort() - Method in class java.net.URLStreamHandler

Returns the default port for a URL parsed by this handler.

getDefaultPrintService() - Method in class javax.print.PrintServiceLookup

Not called directly by applications.

getDefaultPropertyIndex() - Method in interface java.beans.BeanInfo

A bean may have a default property commonly updated when this bean is customized.

getDefaultPropertyIndex() - Method in class java.beans.SimpleBeanInfo

Deny knowledge of a default property.

getDefaultProviderInstance() - Static method in class java.rmi.server.RMIClassLoader

Returns the canonical instance of the default provider for the service provider interface RMIClassLoaderSpi.

getDefaultQueue() - Static method in class javax.swing.text.LayoutQueue

Fetch the default layout queue.

getDefaultReadParam() - Method in class javax.imageio.ImageReader

Returns a default ImageReadParam object appropriate for this format.

getDefaultRenderer(Class<?>) - Method in class javax.swing.JTable

Returns the cell renderer to be used when no renderer has been set in a TableColumn.

getDefaultRenderer() - Method in class javax.swing.table.JTableHeader

Returns the default renderer used when no headerRenderer is defined by a TableColumn.

getDefaultRepresentationClass() - Method in class java.awt.datatransfer.DataFlavor

getDefaultRepresentationClassAsString() - Method in class java.awt.datatransfer.DataFlavor

getDefaultRequestProperty(String) - Static method in class java.net.URLConnection

Deprecated.
The instance specific getRequestProperty method should be used after an appropriate instance of URLConnection is obtained.

getDefaultRootElement() - Method in class javax.swing.text.AbstractDocument

Returns the root element that views should be based upon unless some other mechanism for assigning views to element structures is provided.

getDefaultRootElement() - Method in class javax.swing.text.DefaultStyledDocument

Gets the default root element.

getDefaultRootElement() - Method in interface javax.swing.text.Document

Returns the root element that views should be based upon, unless some other mechanism for assigning views to element structures is provided.

getDefaultRootElement() - Method in class javax.swing.text.PlainDocument

Gets the default root element for the document model.

getDefaults() - Method in class javax.swing.LookAndFeel

Returns the look and feel defaults.

getDefaults() - Method in class javax.swing.plaf.basic.BasicLookAndFeel

Returns the look and feel defaults.

getDefaults() - Method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the look and feel defaults.

getDefaults() - Method in class javax.swing.plaf.multi.MultiLookAndFeel

Creates, initializes, and returns the look and feel specific defaults.

getDefaults() - Method in class javax.swing.plaf.nimbus.NimbusLookAndFeel

Returns the defaults for this SynthLookAndFeel.

getDefaults() - Method in class javax.swing.plaf.synth.SynthLookAndFeel

Returns the defaults for this SynthLookAndFeel.

getDefaults() - Static method in class javax.swing.UIManager

Returns the defaults.

getDefaultScreenDevice() - Method in class java.awt.GraphicsEnvironment

Returns the default screen GraphicsDevice.

getDefaultSelection() - Method in class java.awt.JobAttributes

Specifies whether, for jobs using these attributes, the application should print all pages, the range specified by the return value of getPageRanges, or the current selection.

getDefaultSize() - Method in class javax.swing.plaf.basic.BasicComboBoxUI

Return the default size of an empty display area of the combo box using the current renderer and font.

getDefaultSize() - Method in class javax.swing.plaf.synth.SynthComboBoxUI

Returns the default size of an empty display area of the combo box using the current renderer and font.

getDefaultSocketFactory() - Static method in class java.rmi.server.RMISocketFactory

Returns a reference to the default socket factory used by this RMI implementation.

getDefaultSoundbank() - Method in interface javax.sound.midi.Synthesizer

Obtains the default soundbank for the synthesizer, if one exists.

getDefaultSSLParameters() - Method in class javax.net.ssl.SSLContext

Returns a copy of the SSLParameters indicating the default settings for this SSL context.

getDefaultSSLSocketFactory() - Static method in class javax.net.ssl.HttpsURLConnection

Gets the default static SSLSocketFactory that is inherited by new instances of this class.

getDefaultStream() - Static method in class java.rmi.server.LogStream

Deprecated.
no replacement

getDefaultStreamMetadata(ImageWriteParam) - Method in class javax.imageio.ImageWriter

Returns an IIOMetadata object containing default values for encoding a stream of images.

getDefaultStyleContext() - Static method in class javax.swing.text.StyleContext

Returns default AttributeContext shared by all documents that don't bother to define/supply their own context.

getDefaultText() - Method in class javax.security.auth.callback.TextInputCallback

Get the default text.

getDefaultTextIconGap(AbstractButton) - Method in class javax.swing.plaf.basic.BasicButtonUI

getDefaultToolkit() - Static method in class java.awt.Toolkit

Gets the default toolkit.

getDefaultTransactionIsolation() - Method in interface java.sql.DatabaseMetaData

Retrieves this database's default transaction isolation level.

getDefaultTransform() - Method in class java.awt.GraphicsConfiguration

Returns the default AffineTransform for this GraphicsConfiguration.

getDefaultTreeModel() - Static method in class javax.swing.JTree

Creates and returns a sample TreeModel.

getDefaultType() - Static method in class java.security.cert.CertPathBuilder

Returns the default CertPathBuilder type as specified by the certpathbuilder.type security property, or the string "PKIX" if no such property exists.

getDefaultType() - Static method in class java.security.cert.CertPathValidator

Returns the default CertPathValidator type as specified by the certpathvalidator.type security property, or the string "PKIX" if no such property exists.

getDefaultType() - Static method in class java.security.cert.CertStore

Returns the default CertStore type as specified by the certstore.type security property, or the string "LDAP" if no such property exists.

getDefaultType() - Static method in class java.security.KeyStore

Returns the default keystore type as specified by the keystore.type security property, or the string "jks" (acronym for "Java keystore") if no such property exists.

getDefaultUncaughtExceptionHandler() - Static method in class java.lang.Thread

Returns the default handler invoked when a thread abruptly terminates due to an uncaught exception.

getDefaultUseCaches() - Method in class java.net.URLConnection

Returns the default value of a URLConnection's useCaches flag.

getDefaultValue() - Method in class java.lang.reflect.Method

Returns the default value for the annotation member represented by this Method instance.

getDefaultValue() - Method in interface javax.lang.model.element.ExecutableElement

Returns the default value if this executable is an annotation type element.

getDefaultValue() - Method in class javax.management.openmbean.OpenMBeanAttributeInfoSupport

Returns the default value for the attribute described by this OpenMBeanAttributeInfoSupport instance, if specified, or null otherwise.

getDefaultValue() - Method in interface javax.management.openmbean.OpenMBeanParameterInfo

Returns the default value for this parameter, if it has one, or null otherwise.

getDefaultValue() - Method in class javax.management.openmbean.OpenMBeanParameterInfoSupport

Returns the default value for the parameter described by this OpenMBeanParameterInfoSupport instance, if specified, or null otherwise.

getDefaultValue() - Method in class javax.swing.text.html.CSS.Attribute

Fetch the default value for the attribute.

getDefaultView() - Method in interface org.w3c.dom.views.DocumentView

The default AbstractView for this Document, or null if none available.

getDefaultWriteParam() - Method in class javax.imageio.ImageWriter

Returns a new ImageWriteParam object of the appropriate type for this file format containing default values, that is, those values that would be used if no ImageWriteParam object were specified.

getDefinitionClass() - Method in class java.lang.instrument.ClassDefinition

Returns the class.

getDefinitionClassFile() - Method in class java.lang.instrument.ClassDefinition

Returns the array of bytes that contains the new class file.

getDelay(TimeUnit) - Method in interface java.util.concurrent.Delayed

Returns the remaining delay associated with this object, in the given time unit.

getDelay() - Method in class javax.swing.JMenu

Returns the suggested delay, in milliseconds, before submenus are popped up or down.

getDelay() - Method in class javax.swing.Timer

Returns the delay, in milliseconds, between firings of action events.

getDelegatedTask() - Method in class javax.net.ssl.SSLEngine

Returns a delegated Runnable task for this SSLEngine.

getDelegCred() - Method in interface org.ietf.jgss.GSSContext

Obtains the credentials delegated by the context initiator to the context acceptor.

getDepth() - Method in interface java.security.cert.PolicyNode

Returns the depth of this node in the valid policy tree.

getDepth(int) - Method in class javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxModel

getDepth() - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns the depth of the tree rooted at this node -- the longest distance from this node to a leaf.

getDER() - Method in class org.ietf.jgss.Oid

Returns the full ASN.1 DER encoding for this oid object, which includes the tag and length.

getDereferencedData() - Method in interface javax.xml.crypto.dsig.Reference

Returns the dereferenced data, if reference caching is enabled.

getDerefLinkFlag() - Method in class javax.naming.directory.SearchControls

Determines whether links will be dereferenced during the search.

getDerivedColor(String, float, float, float, int, boolean) - Method in class javax.swing.plaf.nimbus.NimbusLookAndFeel

Get a derived color, derived colors are shared instances and is color value will change when its parent UIDefault color changes.

getDerivedColor(Color, Color, float, boolean) - Method in class javax.swing.plaf.nimbus.NimbusLookAndFeel

Decodes and returns a color, which is derived from an offset between two other colors.

getDerivedColor(Color, Color, float) - Method in class javax.swing.plaf.nimbus.NimbusLookAndFeel

Decodes and returns a color, which is derived from a offset between two other colors.

getDerivedGauge(ObjectName) - Method in class javax.management.monitor.CounterMonitor

Gets the derived gauge of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.

getDerivedGauge() - Method in class javax.management.monitor.CounterMonitor

Deprecated.
As of JMX 1.2, replaced by CounterMonitor.getDerivedGauge(ObjectName)

getDerivedGauge() - Method in interface javax.management.monitor.CounterMonitorMBean

Deprecated.
As of JMX 1.2, replaced by CounterMonitorMBean.getDerivedGauge(ObjectName)

getDerivedGauge(ObjectName) - Method in interface javax.management.monitor.CounterMonitorMBean

Gets the derived gauge for the specified MBean.

getDerivedGauge(ObjectName) - Method in class javax.management.monitor.GaugeMonitor

Gets the derived gauge of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.

getDerivedGauge() - Method in class javax.management.monitor.GaugeMonitor

Deprecated.
As of JMX 1.2, replaced by GaugeMonitor.getDerivedGauge(ObjectName)

getDerivedGauge() - Method in interface javax.management.monitor.GaugeMonitorMBean

Deprecated.
As of JMX 1.2, replaced by GaugeMonitorMBean.getDerivedGauge(ObjectName)

getDerivedGauge(ObjectName) - Method in interface javax.management.monitor.GaugeMonitorMBean

Gets the derived gauge for the specified MBean.

getDerivedGauge() - Method in class javax.management.monitor.MonitorNotification

Gets the derived gauge of this monitor notification.

getDerivedGauge(ObjectName) - Method in class javax.management.monitor.StringMonitor

Gets the derived gauge of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.

getDerivedGauge() - Method in class javax.management.monitor.StringMonitor

Deprecated.
As of JMX 1.2, replaced by StringMonitor.getDerivedGauge(ObjectName)

getDerivedGauge() - Method in interface javax.management.monitor.StringMonitorMBean

Deprecated.
As of JMX 1.2, replaced by StringMonitorMBean.getDerivedGauge(ObjectName)

getDerivedGauge(ObjectName) - Method in interface javax.management.monitor.StringMonitorMBean

Gets the derived gauge for the specified MBean.

getDerivedGaugeTimeStamp(ObjectName) - Method in class javax.management.monitor.CounterMonitor

Gets the derived gauge timestamp of the specified object, if this object is contained in the set of observed MBeans, or 0 otherwise.

getDerivedGaugeTimeStamp() - Method in class javax.management.monitor.CounterMonitor

Deprecated.
As of JMX 1.2, replaced by CounterMonitor.getDerivedGaugeTimeStamp(ObjectName)

getDerivedGaugeTimeStamp() - Method in interface javax.management.monitor.CounterMonitorMBean

Deprecated.
As of JMX 1.2, replaced by CounterMonitorMBean.getDerivedGaugeTimeStamp(ObjectName)

getDerivedGaugeTimeStamp(ObjectName) - Method in interface javax.management.monitor.CounterMonitorMBean

Gets the derived gauge timestamp for the specified MBean.

getDerivedGaugeTimeStamp(ObjectName) - Method in class javax.management.monitor.GaugeMonitor

Gets the derived gauge timestamp of the specified object, if this object is contained in the set of observed MBeans, or 0 otherwise.

getDerivedGaugeTimeStamp() - Method in class javax.management.monitor.GaugeMonitor

Deprecated.
As of JMX 1.2, replaced by GaugeMonitor.getDerivedGaugeTimeStamp(ObjectName)

getDerivedGaugeTimeStamp() - Method in interface javax.management.monitor.GaugeMonitorMBean

Deprecated.
As of JMX 1.2, replaced by GaugeMonitorMBean.getDerivedGaugeTimeStamp(ObjectName)

getDerivedGaugeTimeStamp(ObjectName) - Method in interface javax.management.monitor.GaugeMonitorMBean

Gets the derived gauge timestamp for the specified MBean.

getDerivedGaugeTimeStamp(ObjectName) - Method in class javax.management.monitor.StringMonitor

Gets the derived gauge timestamp of the specified object, if this object is contained in the set of observed MBeans, or 0 otherwise.

getDerivedGaugeTimeStamp() - Method in class javax.management.monitor.StringMonitor

Deprecated.
As of JMX 1.2, replaced by StringMonitor.getDerivedGaugeTimeStamp(ObjectName)

getDerivedGaugeTimeStamp() - Method in interface javax.management.monitor.StringMonitorMBean

Deprecated.
As of JMX 1.2, replaced by StringMonitorMBean.getDerivedGaugeTimeStamp(ObjectName)

getDerivedGaugeTimeStamp(ObjectName) - Method in interface javax.management.monitor.StringMonitorMBean

Gets the derived gauge timestamp for the specified MBean.

getDescendantToggledPaths(TreePath) - Method in class javax.swing.JTree

Returns an Enumeration of TreePaths that have been expanded that are descendants of parent.

getDescent() - Method in class java.awt.font.GraphicAttribute

Returns the descent of this GraphicAttribute.

getDescent() - Method in class java.awt.font.ImageGraphicAttribute

Returns the descent of this ImageGraphicAttribute.

getDescent() - Method in class java.awt.font.LineMetrics

Returns the descent of the text.

getDescent() - Method in class java.awt.font.ShapeGraphicAttribute

Returns the descent of this ShapeGraphicAttribute.

getDescent() - Method in class java.awt.font.TextLayout

Returns the descent of this TextLayout.

getDescent() - Method in class java.awt.FontMetrics

Determines the font descent of the Font described by this FontMetrics object.

getDescent(GlyphView) - Method in class javax.swing.text.GlyphView.GlyphPainter

getDescription() - Method in exception java.util.regex.PatternSyntaxException

Retrieves the description of the error.

getDescription(Locale) - Method in class javax.imageio.spi.IIOServiceProvider

Returns a brief, human-readable description of this service provider and its associated implementation.

getDescription() - Method in class javax.management.MBeanFeatureInfo

Returns the human-readable description of the feature.

getDescription() - Method in class javax.management.MBeanInfo

Returns a human readable description of the MBean.

getDescription() - Method in interface javax.management.modelmbean.ModelMBeanInfo

Returns a human readable description of the MBean.

getDescription(String) - Method in class javax.management.openmbean.CompositeType

Returns the description of the item whose name is itemName, or null if this CompositeType instance does not define any item whose name is itemName.

getDescription() - Method in interface javax.management.openmbean.OpenMBeanConstructorInfo

Returns a human readable description of the constructor described by this OpenMBeanConstructorInfo instance.

getDescription() - Method in interface javax.management.openmbean.OpenMBeanInfo

Returns a human readable description of the type of open MBean instances this OpenMBeanInfo describes.

getDescription() - Method in interface javax.management.openmbean.OpenMBeanOperationInfo

Returns a human readable description of the operation described by this OpenMBeanOperationInfo instance.

getDescription() - Method in interface javax.management.openmbean.OpenMBeanParameterInfo

Returns a human readable description of the parameter described by this OpenMBeanParameterInfo instance.

getDescription() - Method in class javax.management.openmbean.OpenType

Returns the text description of this OpenType instance.

getDescription() - Method in class javax.management.relation.RoleInfo

Returns description text for the role.

getDescription(MBeanInfo) - Method in class javax.management.StandardMBean

Customization hook: Get the description that will be used in the MBeanInfo returned by this MBean.

getDescription(MBeanFeatureInfo) - Method in class javax.management.StandardMBean

Customization hook: Get the description that will be used in the MBeanFeatureInfo returned by this MBean.

getDescription(MBeanAttributeInfo) - Method in class javax.management.StandardMBean

Customization hook: Get the description that will be used in the MBeanAttributeInfo returned by this MBean.

getDescription(MBeanConstructorInfo) - Method in class javax.management.StandardMBean

Customization hook: Get the description that will be used in the MBeanConstructorInfo returned by this MBean.

getDescription(MBeanConstructorInfo, MBeanParameterInfo, int) - Method in class javax.management.StandardMBean

Customization hook: Get the description that will be used for the sequence MBeanParameterInfo of the MBeanConstructorInfo returned by this MBean.

getDescription(MBeanOperationInfo) - Method in class javax.management.StandardMBean

Customization hook: Get the description that will be used in the MBeanOperationInfo returned by this MBean.

getDescription(MBeanOperationInfo, MBeanParameterInfo, int) - Method in class javax.management.StandardMBean

Customization hook: Get the description that will be used for the sequence MBeanParameterInfo of the MBeanOperationInfo returned by this MBean.

getDescription() - Method in class javax.sound.midi.MidiDevice.Info

Obtains the description of the device.

getDescription() - Method in interface javax.sound.midi.Soundbank

Obtains a textual description of the sound bank, suitable for display.

getDescription() - Method in class javax.sound.sampled.Mixer.Info

Obtains the description of the mixer.

getDescription() - Method in class javax.swing.event.HyperlinkEvent

Get the description of the link as a string.

getDescription() - Method in class javax.swing.filechooser.FileFilter

The description of this filter.

getDescription() - Method in class javax.swing.filechooser.FileNameExtensionFilter

The description of this filter.

getDescription(File) - Method in class javax.swing.filechooser.FileView

A human readable description of the file.

getDescription() - Method in class javax.swing.ImageIcon

Gets the description of the image.

getDescription(File) - Method in class javax.swing.JFileChooser

Returns the file description.

getDescription() - Method in class javax.swing.LookAndFeel

Return a one line description of this look and feel implementation, e.g.

getDescription() - Method in class javax.swing.plaf.basic.BasicFileChooserUI.AcceptAllFileFilter

getDescription(File) - Method in class javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView

getDescription() - Method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns a short description of this look and feel.

getDescription() - Method in class javax.swing.plaf.multi.MultiLookAndFeel

Returns a one-line description of this look and feel.

getDescription() - Method in class javax.swing.plaf.nimbus.NimbusLookAndFeel

Returns a textual description of this look and feel.

getDescription() - Method in class javax.swing.plaf.synth.SynthLookAndFeel

Returns a textual description of SynthLookAndFeel.

getDescriptor() - Method in interface javax.management.DescriptorRead

Returns a copy of Descriptor.

getDescriptor() - Method in class javax.management.MBeanFeatureInfo

Returns the descriptor for the feature.

getDescriptor() - Method in class javax.management.MBeanInfo

Get the descriptor of this MBeanInfo.

getDescriptor() - Method in class javax.management.modelmbean.ModelMBeanAttributeInfo

Gets a copy of the associated Descriptor for the ModelMBeanAttributeInfo.

getDescriptor() - Method in class javax.management.modelmbean.ModelMBeanConstructorInfo

Returns a copy of the associated Descriptor.

getDescriptor(String, String) - Method in interface javax.management.modelmbean.ModelMBeanInfo

Returns a Descriptor requested by name and descriptorType.

getDescriptor(String) - Method in class javax.management.modelmbean.ModelMBeanInfoSupport

Returns a Descriptor requested by name.

getDescriptor(String, String) - Method in class javax.management.modelmbean.ModelMBeanInfoSupport

getDescriptor() - Method in class javax.management.modelmbean.ModelMBeanInfoSupport

getDescriptor() - Method in class javax.management.modelmbean.ModelMBeanNotificationInfo

Returns a copy of the associated Descriptor for the ModelMBeanNotificationInfo.

getDescriptor() - Method in class javax.management.modelmbean.ModelMBeanOperationInfo

Returns a copy of the associated Descriptor of the ModelMBeanOperationInfo.

getDescriptors(String) - Method in interface javax.management.modelmbean.ModelMBeanInfo

Returns a Descriptor array consisting of all Descriptors for the ModelMBeanInfo of type inDescriptorType.

getDescriptors(String) - Method in class javax.management.modelmbean.ModelMBeanInfoSupport

getDesignAxisDefaults() - Method in interface java.awt.font.MultipleMaster

Returns an array of default design values for each axis.

getDesignAxisNames() - Method in interface java.awt.font.MultipleMaster

Returns the name for each design axis.

getDesignAxisRanges() - Method in interface java.awt.font.MultipleMaster

Returns an array of design limits interleaved in the form [from→to] for each axis.

getDesktop() - Static method in class java.awt.Desktop

Returns the Desktop instance of the current browser context.

getDesktopColor() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the desktop color of the current theme.

getDesktopColor() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the desktop color.

getDesktopColor() - Method in class javax.swing.plaf.metal.OceanTheme

Returns the desktop color.

getDesktopIcon() - Method in class javax.swing.JInternalFrame

Returns the JDesktopIcon used when this JInternalFrame is iconified.

getDesktopIconBorder() - Static method in class javax.swing.plaf.metal.MetalBorders

Returns a border instance for a Desktop Icon

getDesktopManager() - Method in class javax.swing.JDesktopPane

Returns the DesktopManger that handles desktop-specific UI actions.

getDesktopManager() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI

Returns the proper DesktopManager.

getDesktopPane() - Method in class javax.swing.JInternalFrame

Convenience method that searches the ancestor hierarchy for a JDesktop instance.

getDesktopPane() - Method in class javax.swing.JInternalFrame.JDesktopIcon

Convenience method to ask the icon for the Desktop object it belongs to.

getDesktopPaneForComponent(Component) - Static method in class javax.swing.JOptionPane

Returns the specified component's desktop pane.

getDesktopProperty(String) - Method in class java.awt.Toolkit

Obtains a value for the specified desktop property.

getDesktopPropertyValue(String, Object) - Static method in class javax.swing.LookAndFeel

Returns the value of the specified system desktop property by invoking Toolkit.getDefaultToolkit().getDesktopProperty().

getDestination() - Method in class java.awt.JobAttributes

Specifies whether output will be to a printer or a file for jobs using these attributes.

getDestination(ImageReadParam, Iterator<ImageTypeSpecifier>, int, int) - Static method in class javax.imageio.ImageReader

Returns the BufferedImage to which decoded pixel data should be written.

getDestination() - Method in class javax.imageio.ImageReadParam

Returns the BufferedImage currently set by the setDestination method, or null if none is set.

getDestinationBands() - Method in class javax.imageio.ImageReadParam

Returns the set of band indices where data will be placed.

getDestinationOffset() - Method in class javax.imageio.IIOParam

Returns the offset in the destination image at which pixels are to be placed.

getDestinationType() - Method in class javax.imageio.IIOParam

Returns the type of image to be returned by the read, if one was set by a call to setDestination(ImageTypeSpecifier), as an ImageTypeSpecifier.

getDetail() - Method in interface javax.xml.soap.SOAPFault

Returns the optional detail element for this SOAPFault object.

getDetail() - Method in interface org.w3c.dom.events.UIEvent

Specifies some detail information about the Event, depending on the type of event.

getDetailEntries() - Method in interface javax.xml.soap.Detail

Gets an Iterator over all of the DetailEntrys in this Detail object.

getDeterminant() - Method in class java.awt.geom.AffineTransform

Returns the determinant of the matrix representation of the transform.

getDevice() - Method in class java.awt.GraphicsConfiguration

Returns the GraphicsDevice associated with this GraphicsConfiguration.

getDevice() - Method in class java.awt.PointerInfo

Returns the GraphicsDevice where the mouse pointer was at the moment this PointerInfo was created.

getDevice(MidiDevice.Info) - Method in class javax.sound.midi.spi.MidiDeviceProvider

Obtains an instance of the device represented by the info object.

getDeviceConfiguration() - Method in class java.awt.Graphics2D

Returns the device configuration associated with this Graphics2D.

getDeviceInfo() - Method in interface javax.sound.midi.MidiDevice

Obtains information about the device, including its Java class and Strings containing its name, vendor, and description.

getDeviceInfo() - Method in class javax.sound.midi.spi.MidiDeviceProvider

Obtains the set of info objects representing the device or devices provided by this MidiDeviceProvider.

getDiagnostics() - Method in class javax.tools.DiagnosticCollector

Gets a list view of diagnostics collected by this object.

getDialog() - Method in class java.awt.JobAttributes

Returns whether, for jobs using these attributes, the user should see a print dialog in which to modify the print settings, and which type of print dialog should be displayed.

getDialogTitle() - Method in class javax.swing.JFileChooser

Gets the string that goes in the JFileChooser's titlebar.

getDialogTitle(JFileChooser) - Method in class javax.swing.plaf.basic.BasicFileChooserUI

Returns the title of this dialog

getDialogTitle(JFileChooser) - Method in class javax.swing.plaf.FileChooserUI

getDialogTitle(JFileChooser) - Method in class javax.swing.plaf.multi.MultiFileChooserUI

Invokes the getDialogTitle method on each UI handled by this object.

getDialogType() - Method in class javax.swing.JFileChooser

Returns the type of this dialog.

getDifferenceMode() - Method in class javax.management.monitor.CounterMonitor

Gets the difference mode flag value common to all observed MBeans.

getDifferenceMode() - Method in interface javax.management.monitor.CounterMonitorMBean

Gets the difference mode flag value.

getDifferenceMode() - Method in class javax.management.monitor.GaugeMonitor

Gets the difference mode flag value common to all observed MBeans.

getDifferenceMode() - Method in interface javax.management.monitor.GaugeMonitorMBean

Gets the difference mode flag value.

getDigestAlgorithm() - Method in class java.security.spec.MGF1ParameterSpec

Returns the algorithm name of the message digest used by the mask generation function.

getDigestAlgorithm() - Method in class java.security.spec.PSSParameterSpec

Returns the message digest algorithm name.

getDigestAlgorithm() - Method in class javax.crypto.spec.OAEPParameterSpec

Returns the message digest algorithm name.

getDigestInputStream() - Method in interface javax.xml.crypto.dsig.Reference

Returns the pre-digested input stream, if reference caching is enabled.

getDigestLength() - Method in class java.security.MessageDigest

Returns the length of the digest in bytes, or 0 if this operation is not supported by the provider and the implementation is not cloneable.

getDigestMethod() - Method in interface javax.xml.crypto.dsig.Reference

Returns the digest method of this Reference.

getDigestValue() - Method in interface javax.xml.crypto.dsig.Reference

Returns the digest value of this Reference.

getDigit() - Method in class java.text.DecimalFormatSymbols

Gets the character used for a digit in a pattern.

getDimension() - Method in class javax.management.openmbean.ArrayType

Returns the dimension of arrays described by this ArrayType instance.

getDimension(Object) - Method in class javax.swing.UIDefaults

If the value of key is a Dimension return it, otherwise return null.

getDimension(Object, Locale) - Method in class javax.swing.UIDefaults

If the value of key for the given Locale is a Dimension return it, otherwise return null.

getDimension(Object) - Static method in class javax.swing.UIManager

Returns a dimension from the defaults.

getDimension(Object, Locale) - Static method in class javax.swing.UIManager

Returns a dimension from the defaults that is appropriate for the given locale.

getDirection() - Method in class javax.swing.plaf.basic.BasicArrowButton

Returns the direction of the arrow.

getDirection() - Method in class javax.swing.text.DefaultStyledDocument.ElementSpec

Gets the direction.

getDirectionality(char) - Static method in class java.lang.Character

Returns the Unicode directionality property for the given character.

getDirectionality(int) - Static method in class java.lang.Character

Returns the Unicode directionality property for the given character (Unicode code point).

getDirectories() - Method in class javax.swing.plaf.basic.BasicDirectoryModel

getDirectory() - Method in class java.awt.FileDialog

Gets the directory of this file dialog.

getDirectory() - Method in class javax.swing.plaf.basic.BasicFileChooserUI

Property to remember the directory that is currently selected in the UI.

getDirectoryName() - Method in class javax.swing.plaf.basic.BasicFileChooserUI

getDirectoryName() - Method in class javax.swing.plaf.metal.MetalFileChooserUI

getDirtyRegion(JComponent) - Method in class javax.swing.RepaintManager

Return the current dirty region for a component.

getDisabledIcon() - Method in class javax.swing.AbstractButton

Returns the icon used by the button when it's disabled.

getDisabledIcon() - Method in class javax.swing.JLabel

Returns the icon used by the label when it's disabled.

getDisabledIcon(JComponent, Icon) - Method in class javax.swing.LookAndFeel

Returns an Icon with a disabled appearance.

getDisabledIcon(JComponent, Icon) - Method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns an Icon with a disabled appearance.

getDisabledIcon(JComponent, Icon) - Method in class javax.swing.plaf.nimbus.NimbusLookAndFeel

getDisabledIconAt(int) - Method in class javax.swing.JTabbedPane

Returns the tab disabled icon at index.

getDisabledObjectNames() - Method in class javax.management.relation.MBeanServerNotificationFilter

Gets all the ObjectNames disabled.

getDisabledSelectedIcon() - Method in class javax.swing.AbstractButton

Returns the icon used by the button when it's disabled and selected.

getDisabledSelectedIcon(JComponent, Icon) - Method in class javax.swing.LookAndFeel

Returns an Icon for use by disabled components that are also selected.

getDisabledSelectedIcon(JComponent, Icon) - Method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns an Icon for use by disabled components that are also selected.

getDisabledTextColor() - Method in class javax.swing.plaf.metal.MetalButtonUI

getDisabledTextColor() - Method in class javax.swing.plaf.metal.MetalRadioButtonUI

getDisabledTextColor() - Method in class javax.swing.plaf.metal.MetalToggleButtonUI

getDisabledTextColor() - Method in class javax.swing.text.JTextComponent

Fetches the current color used to render the disabled text.

getDiscard() - Method in class java.net.HttpCookie

Returns the discard attribute of the cookie

getDismissDelay() - Method in class javax.swing.ToolTipManager

Returns the dismissal delay value.

getDisplayCountry() - Method in class java.util.Locale

Returns a name for the locale's country that is appropriate for display to the user.

getDisplayCountry(Locale) - Method in class java.util.Locale

Returns a name for the locale's country that is appropriate for display to the user.

getDisplayCountry(String, Locale) - Method in class java.util.spi.LocaleNameProvider

Returns a localized name for the given IETF BCP47 region code (either ISO 3166 country code or UN M.49 area codes) and the given locale that is appropriate for display to the user.

getDisplayedMnemonic() - Method in class javax.swing.JLabel

Return the keycode that indicates a mnemonic key.

getDisplayedMnemonicIndex() - Method in class javax.swing.AbstractButton

Returns the character, as an index, that the look and feel should provide decoration for as representing the mnemonic character.

getDisplayedMnemonicIndex() - Method in class javax.swing.colorchooser.AbstractColorChooserPanel

Provides a hint to the look and feel as to the index of the character in getDisplayName that should be visually identified as the mnemonic.

getDisplayedMnemonicIndex() - Method in class javax.swing.JLabel

Returns the character, as an index, that the look and feel should provide decoration for as representing the mnemonic character.

getDisplayedMnemonicIndexAt(int) - Method in class javax.swing.JTabbedPane

Returns the character, as an index, that the look and feel should provide decoration for as representing the mnemonic character.

getDisplayFormatter() - Method in class javax.swing.text.DefaultFormatterFactory

Returns the JFormattedTextField.AbstractFormatter to use if the JFormattedTextField is not being edited and either the value is not-null, or the value is null and a null formatter has has not been specified.

getDisplayLanguage() - Method in class java.util.Locale

Returns a name for the locale's language that is appropriate for display to the user.

getDisplayLanguage(Locale) - Method in class java.util.Locale

Returns a name for the locale's language that is appropriate for display to the user.

getDisplayLanguage(String, Locale) - Method in class java.util.spi.LocaleNameProvider

Returns a localized name for the given IETF BCP47 language code and the given locale that is appropriate for display to the user.

getDisplayMode() - Method in class java.awt.GraphicsDevice

Returns the current display mode of this GraphicsDevice.

getDisplayModes() - Method in class java.awt.GraphicsDevice

Returns all display modes available for this GraphicsDevice.

getDisplayName() - Method in class java.beans.FeatureDescriptor

Gets the localized display name of this feature.

getDisplayName() - Method in class java.net.NetworkInterface

Get the display name of this network interface.

getDisplayName(TextStyle, Locale) - Method in interface java.time.chrono.Chronology

Gets the textual representation of this chronology.

getDisplayName(TextStyle, Locale) - Method in interface java.time.chrono.Era

Gets the textual representation of this era.

getDisplayName(TextStyle, Locale) - Method in enum java.time.DayOfWeek

Gets the textual representation, such as 'Mon' or 'Friday'.

getDisplayName(TextStyle, Locale) - Method in enum java.time.Month

Gets the textual representation, such as 'Jan' or 'December'.

getDisplayName(Locale) - Method in enum java.time.temporal.ChronoField

getDisplayName(Locale) - Method in interface java.time.temporal.TemporalField

Gets the display name for the field in the requested locale.

getDisplayName(TextStyle, Locale) - Method in class java.time.ZoneId

Gets the textual representation of the zone, such as 'British Time' or '+02:00'.

getDisplayName(int, int, Locale) - Method in class java.util.Calendar

Returns the string representation of the calendar field value in the given style and locale.

getDisplayName() - Method in class java.util.Currency

Gets the name that is suitable for displaying this currency for the default DISPLAY locale.

getDisplayName(Locale) - Method in class java.util.Currency

Gets the name that is suitable for displaying this currency for the specified locale.

getDisplayName() - Method in class java.util.Locale

Returns a name for the locale that is appropriate for display to the user.

getDisplayName(Locale) - Method in class java.util.Locale

Returns a name for the locale that is appropriate for display to the user.

getDisplayName(String, int, int, int, Locale) - Method in class java.util.spi.CalendarNameProvider

Returns the string representation (display name) of the calendar field value in the given style and locale.

getDisplayName(String, Locale) - Method in class java.util.spi.CurrencyNameProvider

Returns a name for the currency that is appropriate for display to the user.

getDisplayName(String, boolean, int, Locale) - Method in class java.util.spi.TimeZoneNameProvider

Returns a name for the given time zone ID that's suitable for presentation to the user in the specified locale.

getDisplayName() - Method in class java.util.TimeZone

Returns a long standard time name of this TimeZone suitable for presentation to the user in the default locale.

getDisplayName(Locale) - Method in class java.util.TimeZone

Returns a long standard time name of this TimeZone suitable for presentation to the user in the specified locale.

getDisplayName(boolean, int) - Method in class java.util.TimeZone

Returns a name in the specified style of this TimeZone suitable for presentation to the user in the default locale.

getDisplayName(boolean, int, Locale) - Method in class java.util.TimeZone

Returns a name in the specified style of this TimeZone suitable for presentation to the user in the specified locale.

getDisplayName() - Method in class javax.swing.colorchooser.AbstractColorChooserPanel

Returns a string containing the display name of the panel.

getDisplayNames(int, int, Locale) - Method in class java.util.Calendar

Returns a Map containing all names of the calendar field in the given style and locale and their corresponding field values.

getDisplayNames(String, int, int, Locale) - Method in class java.util.spi.CalendarNameProvider

Returns a Map containing all string representations (display names) of the Calendar field in the given style and locale and their corresponding field values.

getDisplayScript() - Method in class java.util.Locale

Returns a name for the the locale's script that is appropriate for display to the user.

getDisplayScript(Locale) - Method in class java.util.Locale

Returns a name for the locale's script that is appropriate for display to the user.

getDisplayScript(String, Locale) - Method in class java.util.spi.LocaleNameProvider

Returns a localized name for the given IETF BCP47 script code and the given locale that is appropriate for display to the user.

getDisplaySize() - Method in class javax.swing.plaf.basic.BasicComboBoxUI

Returns the calculated size of the display area.

getDisplayVariant() - Method in class java.util.Locale

Returns a name for the locale's variant code that is appropriate for display to the user.

getDisplayVariant(Locale) - Method in class java.util.Locale

Returns a name for the locale's variant code that is appropriate for display to the user.

getDisplayVariant(String, Locale) - Method in class java.util.spi.LocaleNameProvider

Returns a localized name for the given variant code and the given locale that is appropriate for display to the user.

getDivider() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI

Returns the divider between the top Components.

getDividerBorderSize() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI

Deprecated.
As of Java 2 platform v1.3, instead set the border on the divider.

getDividerLocation() - Method in class javax.swing.JSplitPane

Returns the last value passed to setDividerLocation.

getDividerLocation(JSplitPane) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI

Returns the location of the divider, which may differ from what the splitpane thinks the location of the divider is.

getDividerLocation(JSplitPane) - Method in class javax.swing.plaf.multi.MultiSplitPaneUI

Invokes the getDividerLocation method on each UI handled by this object.

getDividerLocation(JSplitPane) - Method in class javax.swing.plaf.SplitPaneUI

Returns the location of the divider.

getDividerSize() - Method in class javax.swing.JSplitPane

Returns the size of the divider.

getDividerSize() - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider

Returns the size of the divider, that is the width if the splitpane is HORIZONTAL_SPLIT, or the height of VERTICAL_SPLIT.

getDivisionType() - Method in class javax.sound.midi.MidiFileFormat

Obtains the timing division type for the MIDI file.

getDivisionType() - Method in class javax.sound.midi.Sequence

Obtains the timing division type for this sequence.

getDoc() - Method in interface javax.print.MultiDoc

Obtain the current doc object.

getDocComment(Element) - Method in interface javax.lang.model.util.Elements

Returns the text of the documentation ("Javadoc") comment of an element.

getDocFlavor() - Method in interface javax.print.Doc

Determines the doc flavor in which this doc object will supply its piece of print data.

getDocFlavor() - Method in class javax.print.SimpleDoc

Determines the doc flavor in which this doc object will supply its piece of print data.

getDockingColor() - Method in class javax.swing.plaf.basic.BasicToolBarUI

Gets the color displayed when over a docking area

getDoctype() - Method in interface org.w3c.dom.Document

The Document Type Declaration (see DocumentType) associated with this document.

getDocument() - Method in interface javax.swing.event.DocumentEvent

Gets the document that sourced the change event.

getDocument() - Method in class javax.swing.text.AbstractDocument.AbstractElement

Retrieves the underlying model.

getDocument() - Method in class javax.swing.text.AbstractDocument.DefaultDocumentEvent

Gets the document that sourced the change event.

getDocument() - Method in class javax.swing.text.AbstractWriter

Fetches the document.

getDocument() - Method in class javax.swing.text.DocumentFilter.FilterBypass

Returns the Document the mutation is occurring on.

getDocument() - Method in interface javax.swing.text.Element

Fetches the document associated with this element.

getDocument() - Method in class javax.swing.text.JTextComponent

Fetches the model associated with the editor.

getDocument() - Method in class javax.swing.text.View

Fetches the model associated with the view.

getDocument() - Method in interface org.w3c.dom.views.AbstractView

The source DocumentView of which this is an AbstractView.

getDocumentBase() - Method in class java.applet.Applet

Gets the URL of the document in which this applet is embedded.

getDocumentBase() - Method in interface java.applet.AppletStub

Gets the URL of the document in which the applet is embedded.

getDocumentBase() - Method in class javax.management.loading.MLetContent

Gets the MLet text file's base URL.

getDocumentElement() - Method in interface org.w3c.dom.Document

This is a convenience attribute that allows direct access to the child node that is the document element of the document.

getDocumentFilter() - Method in class javax.swing.JFormattedTextField.AbstractFormatter

Subclass and override if you wish to provide a DocumentFilter to restrict what can be input.

getDocumentFilter() - Method in class javax.swing.text.AbstractDocument

Returns the DocumentFilter that is responsible for filtering of insertion/removal.

getDocumentFilter() - Method in class javax.swing.text.DefaultFormatter

Returns the DocumentFilter used to restrict the characters that can be input into the JFormattedTextField.

getDocumentListeners() - Method in class javax.swing.text.AbstractDocument

Returns an array of all the document listeners registered on this document.

getDocumentProperties() - Method in class javax.swing.text.AbstractDocument

Supports managing a set of properties.

getDocumentTypeDeclaration() - Method in interface javax.xml.stream.events.DTD

Returns the entire Document Type Declaration as a string, including the internal DTD subset.

getDocumentURI() - Method in interface org.w3c.dom.Document

The location of the document or null if undefined or if the Document was created using DOMImplementation.createDocument.

getDoInput() - Method in class java.net.URLConnection

Returns the value of this URLConnection's doInput flag.

getDomain() - Method in class java.net.HttpCookie

Returns the domain name set for this cookie.

getDomain() - Method in class javax.management.ObjectName

Returns the domain part.

getDomainCombiner() - Method in class java.security.AccessControlContext

Get the DomainCombiner associated with this AccessControlContext.

getDomains() - Method in interface javax.management.MBeanServer

getDomains() - Method in interface javax.management.MBeanServerConnection

Returns the list of domains in which any MBean is currently registered.

getDomains(Subject) - Method in interface javax.management.remote.rmi.RMIConnection

Handles the method MBeanServerConnection.getDomains().

getDomains(Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl

getDomains(Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub

getDomConfig() - Method in interface org.w3c.dom.Document

The configuration used when Document.normalizeDocument() is invoked.

getDomConfig() - Method in interface org.w3c.dom.ls.LSParser

The DOMConfiguration object used when parsing an input source.

getDomConfig() - Method in interface org.w3c.dom.ls.LSSerializer

The DOMConfiguration object used by the LSSerializer when serializing a DOM node.

getDOMImplementation() - Method in class javax.xml.parsers.DocumentBuilder

Obtain an instance of a DOMImplementation object.

getDOMImplementation(String) - Method in class org.w3c.dom.bootstrap.DOMImplementationRegistry

Return the first implementation that has the desired features, or null if none is found.

getDOMImplementation(String) - Method in interface org.w3c.dom.DOMImplementationSource

A method to request the first DOM implementation that supports the specified features.

getDOMImplementationList(String) - Method in class org.w3c.dom.bootstrap.DOMImplementationRegistry

Return a list of implementations that support the desired features.

getDOMImplementationList(String) - Method in interface org.w3c.dom.DOMImplementationSource

A method to request a list of DOM implementations that support the specified features and versions, as specified in .

getDoOutput() - Method in class java.net.URLConnection

Returns the value of this URLConnection's doOutput flag.

getDot() - Method in class javax.swing.event.CaretEvent

Fetches the location of the caret.

getDot() - Method in interface javax.swing.text.Caret

Fetches the current position of the caret.

getDot() - Method in class javax.swing.text.DefaultCaret

Fetches the current position of the caret.

getDotBias() - Method in class javax.swing.text.DefaultCaret

Returns the bias of the caret position.

getDouble(Object, int) - Static method in class java.lang.reflect.Array

Returns the value of the indexed component in the specified array object, as a double.

getDouble(Object) - Method in class java.lang.reflect.Field

Gets the value of a static or instance field of type double or of another primitive type convertible to type double via a widening conversion.

getDouble() - Method in class java.nio.ByteBuffer

Relative get method for reading a double value.

getDouble(int) - Method in class java.nio.ByteBuffer

Absolute get method for reading a double value.

getDouble(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC DOUBLE parameter as a double in the Java programming language.

getDouble(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC DOUBLE parameter as a double in the Java programming language.

getDouble(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a double in the Java programming language.

getDouble(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a double in the Java programming language.

getDouble(String, double) - Method in class java.util.prefs.AbstractPreferences

Implements the getDouble method as per the specification in Preferences.getDouble(String,double).

getDouble(String, double) - Method in class java.util.prefs.Preferences

Returns the double value represented by the string associated with the specified key in this preference node.

getDoubleBufferMaximumSize() - Method in class javax.swing.RepaintManager

Returns the maximum double buffer size.

getDoubleParameter(int) - Method in class java.awt.image.renderable.ParameterBlock

A convenience method to return a parameter as a double.

getDragAction() - Method in class java.awt.dnd.DragGestureEvent

Returns an int representing the action selected by the user.

getDragEnabled() - Method in class javax.swing.JColorChooser

Gets the value of the dragEnabled property.

getDragEnabled() - Method in class javax.swing.JFileChooser

Gets the value of the dragEnabled property.

getDragEnabled() - Method in class javax.swing.JList

Returns whether or not automatic drag handling is enabled.

getDragEnabled() - Method in class javax.swing.JTable

Returns whether or not automatic drag handling is enabled.

getDragEnabled() - Method in class javax.swing.JTree

Returns whether or not automatic drag handling is enabled.

getDragEnabled() - Method in class javax.swing.text.JTextComponent

Returns whether or not automatic drag handling is enabled.

getDraggedColumn() - Method in class javax.swing.table.JTableHeader

Returns the the dragged column, if and only if, a drag is in process, otherwise returns null.

getDraggedDistance() - Method in class javax.swing.table.JTableHeader

Returns the column's horizontal distance from its original position, if and only if, a drag is in process.

getDragImage() - Method in class javax.swing.TransferHandler

Returns the drag image.

getDragImageOffset() - Method in class javax.swing.TransferHandler

Returns an anchor offset for the image to drag.

getDragMode() - Method in class javax.swing.JDesktopPane

Gets the current "dragging style" used by the desktop pane.

getDragOrigin() - Method in class java.awt.dnd.DragGestureEvent

Returns a Point in the coordinates of the Component over which the drag originated.

getDragSource() - Method in class java.awt.dnd.DragGestureEvent

Returns the DragSource.

getDragSource() - Method in class java.awt.dnd.DragGestureRecognizer

This method returns the DragSource this DragGestureRecognizer will use in order to process the Drag and Drop operation.

getDragSource() - Method in class java.awt.dnd.DragSourceContext

Returns the DragSource that instantiated this DragSourceContext.

getDragSourceContext() - Method in class java.awt.dnd.DragSourceEvent

This method returns the DragSourceContext that originated the event.

getDragSourceListeners() - Method in class java.awt.dnd.DragSource

Gets all the DragSourceListeners registered with this DragSource.

getDragSourceMotionListeners() - Method in class java.awt.dnd.DragSource

Gets all of the DragSourceMotionListeners registered with this DragSource.

getDragThreshold() - Static method in class java.awt.dnd.DragSource

Returns the drag gesture motion threshold.

getDrawGraphics() - Method in class java.awt.Component.BltBufferStrategy

getDrawGraphics() - Method in class java.awt.Component.FlipBufferStrategy

getDrawGraphics() - Method in class java.awt.image.BufferStrategy

Creates a graphics context for the drawing buffer.

getDrawsLayeredHighlights() - Method in class javax.swing.text.DefaultHighlighter

getDriver(String) - Static method in class java.sql.DriverManager

Attempts to locate a driver that understands the given URL.

getDriverMajorVersion() - Method in interface java.sql.DatabaseMetaData

Retrieves this JDBC driver's major version number.

getDriverMinorVersion() - Method in interface java.sql.DatabaseMetaData

Retrieves this JDBC driver's minor version number.

getDriverName() - Method in interface java.sql.DatabaseMetaData

Retrieves the name of this JDBC driver.

getDrivers() - Static method in class java.sql.DriverManager

Retrieves an Enumeration with all of the currently loaded JDBC drivers to which the current caller has access.

getDriverVersion() - Method in interface java.sql.DatabaseMetaData

Retrieves the version number of this JDBC driver as a String.

getDropAction() - Method in class java.awt.dnd.DragSourceDragEvent

This method returns the logical intersection of the target drop action and the set of drop actions supported by the drag source.

getDropAction() - Method in class java.awt.dnd.DragSourceDropEvent

This method returns an int representing the action performed by the target on the subject of the drop.

getDropAction() - Method in class java.awt.dnd.DropTargetDragEvent

This method returns the user drop action.

getDropAction() - Method in class java.awt.dnd.DropTargetDropEvent

This method returns the user drop action.

getDropAction() - Method in class javax.swing.TransferHandler.TransferSupport

Returns the action chosen for the drop, when this TransferSupport represents a drop.

getDropLineRect(JTree.DropLocation) - Method in class javax.swing.plaf.basic.BasicTreeUI

Returns a unbounding box for the drop line.

getDropLocation() - Method in class javax.swing.JList

Returns the location that this component should visually indicate as the drop location during a DnD operation over the component, or null if no location is to currently be shown.

getDropLocation() - Method in class javax.swing.JTable

Returns the location that this component should visually indicate as the drop location during a DnD operation over the component, or null if no location is to currently be shown.

getDropLocation() - Method in class javax.swing.JTree

Returns the location that this component should visually indicate as the drop location during a DnD operation over the component, or null if no location is to currently be shown.

getDropLocation() - Method in class javax.swing.text.JTextComponent

Returns the location that this component should visually indicate as the drop location during a DnD operation over the component, or null if no location is to currently be shown.

getDropLocation() - Method in class javax.swing.TransferHandler.TransferSupport

Returns the current (non-null) drop location for the component, when this TransferSupport represents a drop.

getDropMode() - Method in class javax.swing.JList

Returns the drop mode for this component.

getDropMode() - Method in class javax.swing.JTable

Returns the drop mode for this component.

getDropMode() - Method in class javax.swing.JTree

Returns the drop mode for this component.

getDropMode() - Method in class javax.swing.text.JTextComponent

Returns the drop mode for this component.

getDropPoint() - Method in class javax.swing.TransferHandler.DropLocation

Returns the drop point, representing the mouse's current location within the component.

getDropSuccess() - Method in class java.awt.dnd.DragSourceDropEvent

This method returns a boolean indicating if the drop was successful.

getDropTarget() - Method in class java.awt.Component

Gets the DropTarget associated with this Component.

getDropTarget() - Method in class java.awt.dnd.DropTargetContext

This method returns the DropTarget associated with this DropTargetContext.

getDropTargetContext() - Method in class java.awt.dnd.DropTarget

Gets the DropTargetContext associated with this DropTarget.

getDropTargetContext() - Method in class java.awt.dnd.DropTargetEvent

This method returns the DropTargetContext associated with this DropTargetEvent.

getDSTSavings() - Method in class java.util.SimpleTimeZone

Returns the amount of time in milliseconds that the clock is advanced during daylight saving time.

getDSTSavings() - Method in class java.util.TimeZone

Returns the amount of time to be added to local standard time to get local wall clock time.

getDTD(String) - Static method in class javax.swing.text.html.parser.DTD

Returns a DTD with the specified name.

getDTDHandler() - Method in class org.xml.sax.helpers.ParserAdapter

Return the current DTD handler.

getDTDHandler() - Method in class org.xml.sax.helpers.XMLFilterImpl

Get the current DTD event handler.

getDTDHandler() - Method in interface org.xml.sax.XMLReader

Return the current DTD handler.

getDTDType() - Method in interface javax.xml.stream.events.Attribute

Gets the type of this attribute, default is the String "CDATA"

getDuration() - Method in enum java.time.temporal.ChronoUnit

Gets the estimated duration of this unit in the ISO calendar system.

getDuration() - Method in interface java.time.temporal.TemporalUnit

Gets the duration of this unit, which may be an estimate.

getDuration() - Method in class java.time.zone.ZoneOffsetTransition

Gets the duration of the transition.

getEarliestSequenceNumber() - Method in class javax.management.remote.NotificationResult

Returns the sequence number of the earliest notification still in the buffer.

getEarlyReflectionDelay() - Method in class javax.sound.sampled.ReverbType

Returns the early reflection delay time in microseconds.

getEarlyReflectionIntensity() - Method in class javax.sound.sampled.ReverbType

Returns the early reflection intensity in decibels.

getEastPane() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI

getEchoChar() - Method in class java.awt.TextField

Gets the character that is to be used for echoing.

getEchoChar() - Method in class javax.swing.JPasswordField

Returns the character to be used for echoing.

getEdgeCondition() - Method in class java.awt.image.ConvolveOp

Returns the edge condition.

getEdit() - Method in class javax.swing.event.UndoableEditEvent

Returns the edit value.

getEditFormatter() - Method in class javax.swing.text.DefaultFormatterFactory

Returns the JFormattedTextField.AbstractFormatter to use if the JFormattedTextField is being edited and either the value is not-null, or the value is null and a null formatter has has not been specified.

getEditingColumn() - Method in class javax.swing.JTable

Returns the index of the column that contains the cell currently being edited.

getEditingPath() - Method in class javax.swing.JTree

Returns the path to the element that is currently being edited.

getEditingPath(JTree) - Method in class javax.swing.plaf.basic.BasicTreeUI

Returns the path to the element that is being edited.

getEditingPath(JTree) - Method in class javax.swing.plaf.multi.MultiTreeUI

Invokes the getEditingPath method on each UI handled by this object.

getEditingPath(JTree) - Method in class javax.swing.plaf.TreeUI

Returns the path to the element that is being edited.

getEditingRow() - Method in class javax.swing.JTable

Returns the index of the row that contains the cell currently being edited.

getEditor() - Method in class javax.swing.JComboBox

Returns the editor used to paint and edit the selected item in the JComboBox field.

getEditor() - Method in class javax.swing.JSpinner

Returns the component that displays and potentially changes the model's value.

getEditor(ActionEvent) - Method in class javax.swing.text.StyledEditorKit.StyledTextAction

Gets the target editor for an action.

getEditorComponent() - Method in interface javax.swing.ComboBoxEditor

Return the component that should be added to the tree hierarchy for this editor

getEditorComponent() - Method in class javax.swing.JTable

Returns the component that is handling the editing session.

getEditorComponent() - Method in class javax.swing.plaf.basic.BasicComboBoxEditor

getEditorKit() - Method in class javax.swing.JEditorPane

Fetches the currently installed kit for handling content.

getEditorKit(JTextComponent) - Method in class javax.swing.plaf.basic.BasicEditorPaneUI

Fetches the EditorKit for the UI.

getEditorKit(JTextComponent) - Method in class javax.swing.plaf.basic.BasicTextUI

Fetches the EditorKit for the UI.

getEditorKit(JTextComponent) - Method in class javax.swing.plaf.multi.MultiTextUI

Invokes the getEditorKit method on each UI handled by this object.

getEditorKit(JTextComponent) - Method in class javax.swing.plaf.TextUI

Fetches the binding of services that set a policy for the type of document being edited.

getEditorKitClassNameForContentType(String) - Static method in class javax.swing.JEditorPane

Returns the currently registered EditorKit class name for the type type.

getEditorKitForContentType(String) - Method in class javax.swing.JEditorPane

Fetches the editor kit to use for the given type of content.

getEditorSearchPath() - Static method in class java.beans.PropertyEditorManager

Gets the package names that will be searched for property editors.

getEffectiveKeyBits() - Method in class javax.crypto.spec.RC2ParameterSpec

Returns the effective key size in bits.

getElem(int) - Method in class java.awt.image.DataBuffer

Returns the requested data array element from the first (default) bank as an integer.

getElem(int, int) - Method in class java.awt.image.DataBuffer

Returns the requested data array element from the specified bank as an integer.

getElem(int) - Method in class java.awt.image.DataBufferByte

Returns the requested data array element from the first (default) bank.

getElem(int, int) - Method in class java.awt.image.DataBufferByte

Returns the requested data array element from the specified bank.

getElem(int) - Method in class java.awt.image.DataBufferDouble

Returns the requested data array element from the first (default) bank as an int.

getElem(int, int) - Method in class java.awt.image.DataBufferDouble

Returns the requested data array element from the specified bank as an int.

getElem(int) - Method in class java.awt.image.DataBufferFloat

Returns the requested data array element from the first (default) bank as an int.

getElem(int, int) - Method in class java.awt.image.DataBufferFloat

Returns the requested data array element from the specified bank as an int.

getElem(int) - Method in class java.awt.image.DataBufferInt

Returns the requested data array element from the first (default) bank.

getElem(int, int) - Method in class java.awt.image.DataBufferInt

Returns the requested data array element from the specified bank.

getElem(int) - Method in class java.awt.image.DataBufferShort

Returns the requested data array element from the first (default) bank.

getElem(int, int) - Method in class java.awt.image.DataBufferShort

Returns the requested data array element from the specified bank.

getElem(int) - Method in class java.awt.image.DataBufferUShort

Returns the requested data array element from the first (default) bank.

getElem(int, int) - Method in class java.awt.image.DataBufferUShort

Returns the requested data array element from the specified bank.

getElemDouble(int) - Method in class java.awt.image.DataBuffer

Returns the requested data array element from the first (default) bank as a double.

getElemDouble(int, int) - Method in class java.awt.image.DataBuffer

Returns the requested data array element from the specified bank as a double.

getElemDouble(int) - Method in class java.awt.image.DataBufferDouble

Returns the requested data array element from the first (default) bank as a double.

getElemDouble(int, int) - Method in class java.awt.image.DataBufferDouble

Returns the requested data array element from the specified bank as a double.

getElemDouble(int) - Method in class java.awt.image.DataBufferFloat

Returns the requested data array element from the first (default) bank as a double.

getElemDouble(int, int) - Method in class java.awt.image.DataBufferFloat

Returns the requested data array element from the specified bank as a double.

getElement() - Method in interface javax.swing.event.DocumentEvent.ElementChange

Returns the element represented.

getElement(int) - Method in class javax.swing.text.AbstractDocument.AbstractElement

Gets a child element.

getElement(int) - Method in class javax.swing.text.AbstractDocument.BranchElement

Gets a child element.

getElement() - Method in class javax.swing.text.AbstractDocument.ElementEdit

Returns the underlying element.

getElement(int) - Method in class javax.swing.text.AbstractDocument.LeafElement

Gets a child element.

getElement(int) - Method in interface javax.swing.text.Element

Fetches the child element at the given index.

getElement(String) - Method in class javax.swing.text.html.HTMLDocument

Returns the element that has the given id Attribute.

getElement(Element, Object, Object) - Method in class javax.swing.text.html.HTMLDocument

Returns the child element of e that contains the attribute, attribute with value value, or null if one isn't found.

getElement(String) - Method in class javax.swing.text.html.parser.DTD

Gets an element by name.

getElement(int) - Method in class javax.swing.text.html.parser.DTD

Gets an element by index.

getElement() - Method in class javax.swing.text.html.parser.TagElement

getElement() - Method in class javax.swing.text.View

Fetches the structural portion of the subject that this view is mapped to.

getElement(ResultT) - Method in interface javax.xml.bind.annotation.DomHandler

Once the portion is sent to the Result.

getElement(DOMResult) - Method in class javax.xml.bind.annotation.W3CDomHandler

getElementAt(int) - Method in class javax.swing.DefaultComboBoxModel

getElementAt(int) - Method in class javax.swing.DefaultListModel

Returns the component at the specified index.

getElementAt(int) - Method in interface javax.swing.ListModel

Returns the value at the specified index.

getElementAt(int) - Method in class javax.swing.plaf.basic.BasicDirectoryModel

getElementAt(int) - Method in class javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxModel

getElementAt(int) - Method in class javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxModel

getElementById(String) - Method in class javax.xml.crypto.dom.DOMCryptoContext

Returns the Element with the specified ID attribute value.

getElementById(String) - Method in interface org.w3c.dom.Document

Returns the Element that has an ID attribute with the given value.

getElementCount() - Method in class javax.swing.text.AbstractDocument.AbstractElement

Gets the number of children for the element.

getElementCount() - Method in class javax.swing.text.AbstractDocument.BranchElement

Gets the number of children for the element.

getElementCount() - Method in class javax.swing.text.AbstractDocument.LeafElement

Returns the number of child elements.

getElementCount() - Method in interface javax.swing.text.Element

Gets the number of child elements contained by this element.

getElementDescription(String, Locale) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns a String containing a description of the named element, or null.

getElementDescription(String, Locale) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

Returns a String containing a description of the named element, or null.

getElementIndex(int) - Method in class javax.swing.text.AbstractDocument.AbstractElement

Gets the child element index closest to the given model offset.

getElementIndex(int) - Method in class javax.swing.text.AbstractDocument.BranchElement

Gets the child element index closest to the given model offset.

getElementIndex(int) - Method in class javax.swing.text.AbstractDocument.LeafElement

Gets the child element index closest to the given model offset.

getElementIndex(int) - Method in interface javax.swing.text.Element

Gets the child element index closest to the given offset.

getElementIterator() - Method in class javax.swing.text.AbstractWriter

Fetches the ElementIterator.

getElementMaxChildren(String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns the maximum number of children of the named element with child policy CHILD_POLICY_REPEAT.

getElementMaxChildren(String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getElementMinChildren(String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns the minimum number of children of the named element with child policy CHILD_POLICY_REPEAT.

getElementMinChildren(String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getElementName(Object) - Method in class javax.xml.bind.JAXBIntrospector

Get xml element qname for jaxbElement.

getElementName() - Method in interface javax.xml.soap.SOAPElement

Returns the name of this SOAPElement object.

getElementOpenType() - Method in class javax.management.openmbean.ArrayType

Returns the open type of element values contained in the arrays described by this ArrayType instance.

getElementQName() - Method in interface javax.xml.soap.SOAPElement

Returns the qname of this SOAPElement object.

getElements() - Method in class javax.swing.ButtonGroup

Returns all the buttons that are participating in this group.

getElements(Vector<Element>) - Method in class javax.swing.text.html.parser.ContentModel

Update elemVec with the list of elements that are part of the this contentModel.

getElementsAnnotatedWith(TypeElement) - Method in interface javax.annotation.processing.RoundEnvironment

Returns the elements annotated with the given annotation type.

getElementsAnnotatedWith(Class<? extends Annotation>) - Method in interface javax.annotation.processing.RoundEnvironment

Returns the elements annotated with the given annotation type.

getElementsAt(HTMLDocument, int) - Method in class javax.swing.text.html.HTMLEditorKit.HTMLTextAction

Returns an array of the Elements that contain offset.

getElementsByTagName(String) - Method in class javax.imageio.metadata.IIOMetadataNode

getElementsByTagName(String) - Method in interface org.w3c.dom.Document

Returns a NodeList of all the Elements in document order with a given tag name and are contained in the document.

getElementsByTagName(String) - Method in interface org.w3c.dom.Element

Returns a NodeList of all descendant Elements with a given tag name, in document order.

getElementsByTagNameNS(String, String) - Method in class javax.imageio.metadata.IIOMetadataNode

Equivalent to getElementsByTagName(localName).

getElementsByTagNameNS(String, String) - Method in interface org.w3c.dom.Document

Returns a NodeList of all the Elements with a given local name and namespace URI in document order.

getElementsByTagNameNS(String, String) - Method in interface org.w3c.dom.Element

Returns a NodeList of all the descendant Elements with a given local name and namespace URI in document order.

getElementText() - Method in class javax.xml.stream.util.EventReaderDelegate

getElementText() - Method in class javax.xml.stream.util.StreamReaderDelegate

getElementText() - Method in interface javax.xml.stream.XMLEventReader

Reads the content of a text-only element.

getElementText() - Method in interface javax.xml.stream.XMLStreamReader

Reads the content of a text-only element, an exception is thrown if this is not a text-only element.

getElementTypeInfo() - Method in class javax.xml.validation.TypeInfoProvider

Returns the immutable TypeInfo object for the current element.

getElementUtils() - Method in interface javax.annotation.processing.ProcessingEnvironment

Returns an implementation of some utility methods for operating on elements

getElementValues() - Method in interface javax.lang.model.element.AnnotationMirror

Returns the values of this annotation's elements.

getElementValuesWithDefaults(AnnotationMirror) - Method in interface javax.lang.model.util.Elements

Returns the values of an annotation's elements, including defaults.

getElemFloat(int) - Method in class java.awt.image.DataBuffer

Returns the requested data array element from the first (default) bank as a float.

getElemFloat(int, int) - Method in class java.awt.image.DataBuffer

Returns the requested data array element from the specified bank as a float.

getElemFloat(int) - Method in class java.awt.image.DataBufferDouble

Returns the requested data array element from the first (default) bank as a float.

getElemFloat(int, int) - Method in class java.awt.image.DataBufferDouble

Returns the requested data array element from the specified bank as a float.

getElemFloat(int) - Method in class java.awt.image.DataBufferFloat

Returns the requested data array element from the first (default) bank as a float.

getElemFloat(int, int) - Method in class java.awt.image.DataBufferFloat

Returns the requested data array element from the specified bank as a float.

getEmptySet() - Method in interface javax.swing.text.AbstractDocument.AttributeContext

Fetches an empty AttributeSet.

getEmptySet() - Method in class javax.swing.text.StyleContext

Fetches an empty AttributeSet.

getEnabledAttributes() - Method in class javax.management.AttributeChangeNotificationFilter

Gets all the enabled attribute names for this filter.

getEnabledCipherSuites() - Method in class javax.net.ssl.SSLEngine

Returns the names of the SSL cipher suites which are currently enabled for use on this engine.

getEnabledCipherSuites() - Method in class javax.net.ssl.SSLServerSocket

Returns the list of cipher suites which are currently enabled for use by newly accepted connections.

getEnabledCipherSuites() - Method in class javax.net.ssl.SSLSocket

Returns the names of the SSL cipher suites which are currently enabled for use on this connection.

getEnabledCipherSuites() - Method in class javax.rmi.ssl.SslRMIServerSocketFactory

Returns the names of the cipher suites enabled on SSL connections accepted by server sockets created by this factory, or null if this factory uses the cipher suites that are enabled by default.

getEnabledObjectNames() - Method in class javax.management.relation.MBeanServerNotificationFilter

Gets all the ObjectNames enabled.

getEnabledProtocols() - Method in class javax.net.ssl.SSLEngine

Returns the names of the protocol versions which are currently enabled for use with this SSLEngine.

getEnabledProtocols() - Method in class javax.net.ssl.SSLServerSocket

Returns the names of the protocols which are currently enabled for use by the newly accepted connections.

getEnabledProtocols() - Method in class javax.net.ssl.SSLSocket

Returns the names of the protocol versions which are currently enabled for use on this connection.

getEnabledProtocols() - Method in class javax.rmi.ssl.SslRMIServerSocketFactory

Returns the names of the protocol versions enabled on SSL connections accepted by server sockets created by this factory, or null if this factory uses the protocol versions that are enabled by default.

getEnabledTypes() - Method in class javax.management.NotificationFilterSupport

Gets all the enabled notification types for this filter.

getEnableSessionCreation() - Method in class javax.net.ssl.SSLEngine

Returns true if new SSL sessions may be established by this engine.

getEnableSessionCreation() - Method in class javax.net.ssl.SSLServerSocket

Returns true if new SSL sessions may be established by the sockets which are created from this server socket.

getEnableSessionCreation() - Method in class javax.net.ssl.SSLSocket

Returns true if new SSL sessions may be established by this socket.

getEnclosedElements() - Method in interface javax.lang.model.element.Element

Returns the elements that are, loosely speaking, directly enclosed by this element.

getEnclosedElements() - Method in interface javax.lang.model.element.PackageElement

Returns the top-level classes and interfaces within this package.

getEnclosedElements() - Method in interface javax.lang.model.element.TypeElement

Returns the fields, methods, constructors, and member types that are directly declared in this class or interface.

getEnclosingClass() - Method in class java.lang.Class

Returns the immediately enclosing class of the underlying class.

getEnclosingConstructor() - Method in class java.lang.Class

If this Class object represents a local or anonymous class within a constructor, returns a Constructor object representing the immediately enclosing constructor of the underlying class.

getEnclosingElement() - Method in interface javax.lang.model.element.Element

Returns the innermost element within which this element is, loosely speaking, enclosed.

getEnclosingElement() - Method in interface javax.lang.model.element.PackageElement

Returns null since a package is not enclosed by another element.

getEnclosingElement() - Method in interface javax.lang.model.element.TypeElement

Returns the package of a top-level type and returns the immediately lexically enclosing element for a nested type.

getEnclosingElement() - Method in interface javax.lang.model.element.TypeParameterElement

Returns the generic element of this type parameter.

getEnclosingElement() - Method in interface javax.lang.model.element.VariableElement

Returns the enclosing element of this variable.

getEnclosingMethod() - Method in class java.lang.Class

If this Class object represents a local or anonymous class within a method, returns a Method object representing the immediately enclosing method of the underlying class.

getEnclosingType() - Method in interface javax.lang.model.type.DeclaredType

Returns the type of the innermost enclosing instance or a NoType of kind NONE if there is no enclosing instance.

getEncoded() - Method in class java.security.AlgorithmParameters

Returns the parameters in their primary encoding format.

getEncoded(String) - Method in class java.security.AlgorithmParameters

Returns the parameters encoded in the specified scheme.

getEncoded() - Method in class java.security.cert.Certificate

Returns the encoded form of this certificate.

getEncoded() - Method in class java.security.cert.CertPath

Returns the encoded form of this certification path, using the default encoding.

getEncoded(String) - Method in class java.security.cert.CertPath

Returns the encoded form of this certification path, using the specified encoding.

getEncoded() - Method in class java.security.cert.PolicyQualifierInfo

Returns the ASN.1 DER encoded form of this PolicyQualifierInfo.

getEncoded() - Method in class java.security.cert.X509CRL

Returns the ASN.1 DER-encoded form of this CRL.

getEncoded() - Method in class java.security.cert.X509CRLEntry

Returns the ASN.1 DER-encoded form of this CRL Entry, that is the inner SEQUENCE.

getEncoded() - Method in interface java.security.Key

Returns the key in its primary encoding format, or null if this key does not support encoding.

getEncoded() - Method in class java.security.PKCS12Attribute

Returns the attribute's ASN.1 DER encoding.

getEncoded() - Method in class java.security.spec.EncodedKeySpec

Returns the encoded key.

getEncoded() - Method in class java.security.spec.PKCS8EncodedKeySpec

Returns the key bytes, encoded according to the PKCS #8 standard.

getEncoded() - Method in class java.security.spec.X509EncodedKeySpec

Returns the key bytes, encoded according to the X.509 standard.

getEncoded() - Method in class javax.crypto.EncryptedPrivateKeyInfo

Returns the ASN.1 encoding of this object.

getEncoded() - Method in class javax.crypto.spec.SecretKeySpec

Returns the key material of this secret key.

getEncoded() - Method in class javax.net.ssl.SNIServerName

Returns a copy of the encoded server name value of this server name.

getEncoded() - Method in class javax.security.auth.kerberos.KerberosKey

Returns the key material of this secret key.

getEncoded() - Method in class javax.security.auth.kerberos.KerberosTicket

Returns an ASN.1 encoding of the entire ticket.

getEncoded() - Method in class javax.security.auth.x500.X500Principal

Returns the distinguished name in ASN.1 DER encoded form.

getEncoded() - Method in class javax.security.cert.Certificate

Returns the encoded form of this certificate.

getEncodedValue() - Method in class javax.naming.ldap.BasicControl

Retrieves the control's ASN.1 BER encoded value.

getEncodedValue() - Method in interface javax.naming.ldap.Control

Retrieves the ASN.1 BER encoded value of the LDAP control.

getEncodedValue() - Method in interface javax.naming.ldap.ExtendedRequest

Retrieves the ASN.1 BER encoded value of the LDAP extended operation request.

getEncodedValue() - Method in interface javax.naming.ldap.ExtendedResponse

Retrieves the ASN.1 BER encoded value of the LDAP extended operation response.

getEncodedValue() - Method in class javax.naming.ldap.StartTlsRequest

Retrieves the StartTLS request's ASN.1 BER encoded value.

getEncodedValue() - Method in class javax.naming.ldap.StartTlsResponse

Retrieves the StartTLS response's ASN.1 BER encoded value.

getEncoder() - Static method in class java.util.Base64

Returns a Base64.Encoder that encodes using the Basic type base64 encoding scheme.

getEncoding() - Method in class java.io.InputStreamReader

Returns the name of the character encoding being used by this stream.

getEncoding() - Method in class java.io.OutputStreamWriter

Returns the name of the character encoding being used by this stream.

getEncoding() - Method in class java.util.logging.Handler

Return the character encoding for this Handler.

getEncoding() - Method in class javax.sound.sampled.AudioFormat

Obtains the type of encoding for sounds in this format.

getEncoding() - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

Convenience method for getting the current output encoding.

getEncoding() - Method in interface javax.xml.crypto.dsig.XMLObject

Returns the encoding URI of this XMLObject.

getEncoding() - Method in class javax.xml.stream.util.StreamReaderDelegate

getEncoding() - Method in interface javax.xml.stream.XMLStreamReader

Return input encoding if known or null if unknown.

getEncoding() - Method in interface org.w3c.dom.ls.LSInput

The character encoding, if known.

getEncoding() - Method in interface org.w3c.dom.ls.LSOutput

The character encoding to use for the output.

getEncoding() - Method in interface org.xml.sax.ext.Locator2

Returns the name of the character encoding for the entity.

getEncoding() - Method in class org.xml.sax.ext.Locator2Impl

Returns the current value of the encoding property.

getEncoding() - Method in class org.xml.sax.InputSource

Get the character encoding for a byte stream or URI.

getEncodings() - Method in class java.security.cert.CertPath

Returns an iteration of the encodings supported by this certification path, with the default encoding first.

getEncodingStyle() - Method in interface javax.xml.soap.SOAPElement

Returns the encoding style for this SOAPElement object.

getEncryptedData() - Method in class javax.crypto.EncryptedPrivateKeyInfo

Returns the encrypted data.

getEnd() - Method in class javax.swing.SpinnerDateModel

Returns the last Date in the sequence.

getEndCap() - Method in class java.awt.BasicStroke

Returns the end cap style.

getEndIndex() - Method in interface java.text.CharacterIterator

Returns the end index of the text.

getEndIndex() - Method in class java.text.FieldPosition

Retrieves the index of the character following the last character in the requested field.

getEndIndex() - Method in class java.text.StringCharacterIterator

Implements CharacterIterator.getEndIndex() for String.

getEndIndex() - Method in class javax.accessibility.AccessibleHyperlink

Gets the index with the hypertext document at which this link ends

getEndIndex() - Method in class javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink

Get the index with the hypertext document at which this link ends

getEndIndex() - Method in class javax.swing.text.Segment

Returns the end index of the text.

getEndOffset() - Method in class javax.swing.text.AbstractDocument.AbstractElement

Gets the ending offset in the model for the element.

getEndOffset() - Method in class javax.swing.text.AbstractDocument.BranchElement

Gets the ending offset in the model for the element.

getEndOffset() - Method in class javax.swing.text.AbstractDocument.LeafElement

Gets the ending offset in the model for the element.

getEndOffset() - Method in class javax.swing.text.AbstractWriter

Returns the last offset to be output.

getEndOffset() - Method in interface javax.swing.text.Element

Fetches the offset from the beginning of the document that this element ends at.

getEndOffset() - Method in class javax.swing.text.GlyphView

Fetches the portion of the model that this view is responsible for.

getEndOffset() - Method in interface javax.swing.text.Highlighter.Highlight

Gets the ending model offset for the highlight.

getEndOffset() - Method in class javax.swing.text.html.HTMLDocument.Iterator

Returns the end of the range for which the current occurrence of the tag is defined and has the same attributes.

getEndOffset() - Method in class javax.swing.text.View

Fetches the portion of the model for which this view is responsible.

getEndPoint() - Method in class java.awt.geom.Arc2D

Returns the ending point of the arc.

getEndPoint() - Method in class java.awt.LinearGradientPaint

Returns a copy of the end point of the gradient axis.

getEndpointIdentificationAlgorithm() - Method in class javax.net.ssl.SSLParameters

Gets the endpoint identification algorithm.

getEndpointReference() - Method in interface javax.xml.ws.BindingProvider

Returns the EndpointReference associated with this BindingProvider instance.

getEndpointReference(Class<T>) - Method in interface javax.xml.ws.BindingProvider

Returns the EndpointReference associated with this BindingProvider instance.

getEndpointReference(Element...) - Method in class javax.xml.ws.Endpoint

Returns the EndpointReference associated with this Endpoint instance.

getEndpointReference(Class<T>, Element...) - Method in class javax.xml.ws.Endpoint

Returns the EndpointReference associated with this Endpoint instance.

getEndpointReference(Element...) - Method in interface javax.xml.ws.WebServiceContext

Returns the EndpointReference for this endpoint.

getEndpointReference(Class<T>, Element...) - Method in interface javax.xml.ws.WebServiceContext

Returns the EndpointReference associated with this endpoint.

getEndpoints() - Method in class javax.xml.ws.EndpointContext

This gives list of endpoints in an application.

getEndPosition() - Method in class javax.swing.text.AbstractDocument

Returns a position that represents the end of the document.

getEndPosition() - Method in interface javax.swing.text.Document

Returns a position that represents the end of the document.

getEndPosition() - Method in interface javax.tools.Diagnostic

Gets the character offset from the beginning of the file associated with this diagnostic that indicates the end of the problem.

getEndTime() - Method in class javax.security.auth.kerberos.KerberosTicket

Returns the expiration time for this ticket's validity period.

getEngine() - Method in class javax.script.CompiledScript

Returns the ScriptEngine whose compile method created this CompiledScript.

getEngineByExtension(String) - Method in class javax.script.ScriptEngineManager

Look up and create a ScriptEngine for a given extension.

getEngineByMimeType(String) - Method in class javax.script.ScriptEngineManager

Look up and create a ScriptEngine for a given mime type.

getEngineByName(String) - Method in class javax.script.ScriptEngineManager

Looks up and creates a ScriptEngine for a given name.

getEngineFactories() - Method in class javax.script.ScriptEngineManager

Returns a list whose elements are instances of all the ScriptEngineFactory classes found by the discovery mechanism.

getEngineName() - Method in interface javax.script.ScriptEngineFactory

Returns the full name of the ScriptEngine.

getEngineVersion() - Method in interface javax.script.ScriptEngineFactory

Returns the version of the ScriptEngine.

getEntities() - Method in interface javax.xml.stream.events.DTD

Return a List containing the general entities, both external and internal, declared in the DTD.

getEntities() - Method in interface org.w3c.dom.DocumentType

A NamedNodeMap containing the general entities, both external and internal, declared in the DTD.

getEntity(String) - Method in class javax.swing.text.html.parser.DTD

Gets an entity by name.

getEntity(int) - Method in class javax.swing.text.html.parser.DTD

Gets a character entity.

getEntityResolver() - Method in class org.xml.sax.helpers.ParserAdapter

Return the current entity resolver.

getEntityResolver() - Method in class org.xml.sax.helpers.XMLFilterImpl

Get the current entity resolver.

getEntityResolver() - Method in interface org.xml.sax.XMLReader

Return the current entity resolver.

getEntries() - Method in class java.util.jar.Manifest

Returns a Map of the entries contained in this Manifest.

getEntry(String, KeyStore.ProtectionParameter) - Method in class java.security.KeyStore

Gets a keystore Entry for the specified alias with the specified protection parameter.

getEntry(String) - Method in class java.util.jar.JarFile

Returns the ZipEntry for the given entry name or null if not found.

getEntry(String) - Method in class java.util.zip.ZipFile

Returns the zip file entry for the specified name, or null if not found.

getEntryName() - Method in class java.net.JarURLConnection

Return the entry name for this connection.

getEnumConstants() - Method in class java.lang.Class

Returns the elements of this enum class or null if this Class object does not represent an enum type.

getEnumValueTable() - Method in class javax.print.attribute.EnumSyntax

Returns the enumeration value table for this enumeration value's enumeration class.

getEnumValueTable() - Method in class javax.print.attribute.standard.Chromaticity

Returns the enumeration value table for class Chromaticity.

getEnumValueTable() - Method in class javax.print.attribute.standard.ColorSupported

Returns the enumeration value table for class ColorSupported.

getEnumValueTable() - Method in class javax.print.attribute.standard.Compression

Returns the enumeration value table for class Compression.

getEnumValueTable() - Method in class javax.print.attribute.standard.DialogTypeSelection

Returns the enumeration value table for class DialogTypeSelection.

getEnumValueTable() - Method in class javax.print.attribute.standard.Fidelity

Returns the enumeration value table for class Fidelity.

getEnumValueTable() - Method in class javax.print.attribute.standard.Finishings

Returns the enumeration value table for class Finishings.

getEnumValueTable() - Method in class javax.print.attribute.standard.JobSheets

Returns the enumeration value table for class JobSheets.

getEnumValueTable() - Method in class javax.print.attribute.standard.JobState

Returns the enumeration value table for class JobState.

getEnumValueTable() - Method in class javax.print.attribute.standard.JobStateReason

Returns the enumeration value table for class JobStateReason.

getEnumValueTable() - Method in class javax.print.attribute.standard.MediaName

Returns the enumeration value table for class MediaTray.

getEnumValueTable() - Method in class javax.print.attribute.standard.MediaSizeName

Returns the enumeration value table for class MediaSizeName.

getEnumValueTable() - Method in class javax.print.attribute.standard.MediaTray

Returns the enumeration value table for class MediaTray.

getEnumValueTable() - Method in class javax.print.attribute.standard.MultipleDocumentHandling

Returns the enumeration value table for class MultipleDocumentHandling.

getEnumValueTable() - Method in class javax.print.attribute.standard.OrientationRequested

Returns the enumeration value table for class OrientationRequested.

getEnumValueTable() - Method in class javax.print.attribute.standard.PDLOverrideSupported

Returns the enumeration value table for class PDLOverrideSupported.

getEnumValueTable() - Method in class javax.print.attribute.standard.PresentationDirection

Returns the enumeration value table for class PresentationDirection.

getEnumValueTable() - Method in class javax.print.attribute.standard.PrinterIsAcceptingJobs

Returns the enumeration value table for class PrinterIsAcceptingJobs.

getEnumValueTable() - Method in class javax.print.attribute.standard.PrinterState

Returns the enumeration value table for class PrinterState.

getEnumValueTable() - Method in class javax.print.attribute.standard.PrinterStateReason

Returns the enumeration value table for class PrinterStateReason.

getEnumValueTable() - Method in class javax.print.attribute.standard.PrintQuality

Returns the enumeration value table for class PrintQuality.

getEnumValueTable() - Method in class javax.print.attribute.standard.ReferenceUriSchemesSupported

Returns the enumeration value table for class ReferenceUriSchemesSupported.

getEnumValueTable() - Method in class javax.print.attribute.standard.Severity

Returns the enumeration value table for class Severity.

getEnumValueTable() - Method in class javax.print.attribute.standard.SheetCollate

Returns the enumeration value table for class SheetCollate.

getEnumValueTable() - Method in class javax.print.attribute.standard.Sides

Returns the enumeration value table for class Sides.

getenv(String) - Static method in class java.lang.System

Gets the value of the specified environment variable.

getenv() - Static method in class java.lang.System

Returns an unmodifiable string map view of the current system environment.

getEnvelope() - Method in class javax.xml.soap.SOAPPart

Gets the SOAPEnvelope object associated with this SOAPPart object.

getEnvironment() - Method in exception javax.naming.CannotProceedException

Retrieves the environment that was in effect when this exception was created.

getEnvironment() - Method in interface javax.naming.Context

Retrieves the environment in effect for this context.

getEnvironment() - Method in class javax.naming.InitialContext

getEon() - Method in class javax.xml.datatype.XMLGregorianCalendar

Return high order component for XML Schema 1.0 dateTime datatype field for year.

getEonAndYear() - Method in class javax.xml.datatype.XMLGregorianCalendar

Return XML Schema 1.0 dateTime datatype field for year.

getEpochSecond() - Method in class java.time.Instant

Gets the number of seconds from the Java epoch of 1970-01-01T00:00:00Z.

getEra() - Method in interface java.time.chrono.ChronoLocalDate

Gets the era, as defined by the chronology.

getEra() - Method in class java.time.chrono.HijrahDate

Gets the era applicable at this date.

getEra() - Method in class java.time.chrono.JapaneseDate

Gets the era applicable at this date.

getEra() - Method in class java.time.chrono.MinguoDate

Gets the era applicable at this date.

getEra() - Method in class java.time.chrono.ThaiBuddhistDate

Gets the era applicable at this date.

getEra() - Method in class java.time.LocalDate

Gets the era applicable at this date.

getEras() - Method in class java.text.DateFormatSymbols

Gets era strings.

getErrorCode() - Method in exception java.sql.SQLException

Retrieves the vendor-specific exception code for this SQLException object.

getErrorCode() - Method in exception javax.xml.bind.JAXBException

Get the vendor specific error code

getErrorCode() - Method in exception javax.xml.bind.TypeConstraintException

Get the vendor specific error code

getErrorHandler() - Method in class javax.xml.validation.SchemaFactory

Gets the current ErrorHandler set to this SchemaFactory.

getErrorHandler() - Method in class javax.xml.validation.Validator

Gets the current ErrorHandler set to this Validator.

getErrorHandler() - Method in class javax.xml.validation.ValidatorHandler

Gets the current ErrorHandler set to this ValidatorHandler.

getErrorHandler() - Method in class org.xml.sax.helpers.ParserAdapter

Return the current error handler.

getErrorHandler() - Method in class org.xml.sax.helpers.XMLFilterImpl

Get the current error event handler.

getErrorHandler() - Method in interface org.xml.sax.XMLReader

Return the current error handler.

getErrorIndex() - Method in class java.text.ParsePosition

Retrieve the index at which an error occurred, or -1 if the error index has not been set.

getErrorIndex() - Method in exception java.time.format.DateTimeParseException

Returns the index where the error was found.

getErrorIndex() - Method in exception java.util.IllformedLocaleException

Returns the index where the error was found.

getErrorListener() - Method in class javax.xml.transform.Transformer

Get the error event handler in effect for the transformation.

getErrorListener() - Method in class javax.xml.transform.TransformerFactory

Get the error event handler for the TransformerFactory.

getErrorManager() - Method in class java.util.logging.Handler

Retrieves the ErrorManager for this Handler.

getErrorOffset() - Method in exception java.text.ParseException

Returns the position where the error was found.

getErrorsAny() - Method in class java.awt.MediaTracker

Returns a list of all media that have encountered an error.

getErrorsID(int) - Method in class java.awt.MediaTracker

Returns a list of media with the specified ID that have encountered an error.

getErrorStream() - Method in class java.lang.Process

Returns the input stream connected to the error output of the subprocess.

getErrorStream() - Method in class java.net.HttpURLConnection

Returns the error stream if the connection failed but the server sent useful data nonetheless.

getErrorWriter() - Method in interface javax.script.ScriptContext

Returns the Writer used to display error output.

getErrorWriter() - Method in class javax.script.SimpleScriptContext

Returns the Writer used to display error output.

getEscapeProcessing() - Method in class javax.sql.rowset.BaseRowSet

Ascertains whether escape processing is enabled for this RowSet object.

getEscapeProcessing() - Method in interface javax.sql.RowSet

Retrieves whether escape processing is enabled for this RowSet object.

getEstimatedMajorSpan() - Method in class javax.swing.text.AsyncBoxView

Is the major span currently estimated?

getEtchedBorderUIResource() - Static method in class javax.swing.plaf.BorderUIResource

getEtchedInsets() - Static method in class javax.swing.plaf.basic.BasicGraphicsUtils

Returns the amount of space taken up by a border drawn by drawEtchedRect()

getEtchType() - Method in class javax.swing.border.EtchedBorder

Returns which etch-type is set on the etched border.

getEventAllocator() - Method in class javax.xml.stream.XMLInputFactory

Gets the allocator used by streams created with this factory

getEventContext() - Method in class javax.naming.event.NamingEvent

Retrieves the event source that fired this event.

getEventContext() - Method in class javax.naming.event.NamingExceptionEvent

Retrieves the EventContext that fired this event.

getEventHandler() - Method in class javax.xml.bind.Binder

Return the current event handler or the default event handler if one hasn't been set.

getEventHandler() - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

getEventHandler() - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

Return the current event handler or the default event handler if one hasn't been set.

getEventHandler() - Method in interface javax.xml.bind.Marshaller

Return the current event handler or the default event handler if one hasn't been set.

getEventHandler() - Method in interface javax.xml.bind.Unmarshaller

Return the current event handler or the default event handler if one hasn't been set.

getEventHandler() - Method in interface javax.xml.bind.Validator

Deprecated.
since JAXB2.0

getEventMask() - Method in class java.awt.event.AWTEventListenerProxy

Returns the event mask associated with the listener.

getEventPhase() - Method in interface org.w3c.dom.events.Event

Used to indicate which phase of event flow is currently being evaluated.

getEventPropertyName() - Method in class java.beans.EventHandler

Returns the property of the event that should be used in the action applied to the target.

getEvents() - Method in class javax.xml.bind.util.ValidationEventCollector

Return an array of ValidationEvent objects containing a copy of each of the collected errors and warnings.

getEventSetDescriptors() - Method in interface java.beans.BeanInfo

Returns the event descriptors of the bean that define the types of events fired by this bean.

getEventSetDescriptors() - Method in class java.beans.SimpleBeanInfo

Deny knowledge of event sets.

getEventType() - Method in class javax.swing.event.HyperlinkEvent

Gets the type of event.

getEventType() - Method in interface javax.xml.stream.events.XMLEvent

Returns an integer code for this event.

getEventType() - Method in class javax.xml.stream.util.StreamReaderDelegate

getEventType() - Method in interface javax.xml.stream.XMLStreamReader

Returns an integer code that indicates the type of the event the cursor is pointing to.

getExactSizeIfKnown() - Method in interface java.util.Spliterator

Convenience method that returns Spliterator.estimateSize() if this Spliterator is Spliterator.SIZED, else -1.

getException() - Method in class java.awt.event.InvocationEvent

Returns any Exception caught while executing the Runnable's run() method.

getException() - Method in exception java.lang.ClassNotFoundException

Returns the exception that was raised if an error occurred while attempting to load the class.

getException() - Method in error java.lang.ExceptionInInitializerError

Returns the exception that occurred during a static initialization that caused this error to be created.

getException() - Method in exception java.security.PrivilegedActionException

Returns the exception thrown by the privileged computation that resulted in this PrivilegedActionException.

getException() - Method in class java.util.concurrent.ForkJoinTask

Returns the exception thrown by the base computation, or a CancellationException if cancelled, or null if none or if the method has not yet completed.

getException() - Method in class javax.naming.event.NamingExceptionEvent

Retrieves the exception that was thrown.

getException() - Method in class javax.naming.ldap.SortResponseControl

Retrieves the NamingException appropriate for the result code.

getException() - Method in interface javax.naming.ldap.UnsolicitedNotification

Retrieves the exception as constructed using information sent by the server.

getException() - Method in error javax.xml.parsers.FactoryConfigurationError

Return the actual exception (if any) that caused this exception to be raised.

getException() - Method in error javax.xml.stream.FactoryConfigurationError

Return the nested exception (if any)

getException() - Method in exception javax.xml.transform.TransformerException

This method retrieves an exception that this exception wraps.

getException() - Method in error javax.xml.transform.TransformerFactoryConfigurationError

Return the actual exception (if any) that caused this exception to be raised.

getException() - Method in exception org.xml.sax.SAXException

Return the embedded exception, if any.

getExceptionListener() - Method in class java.beans.Encoder

Gets the exception handler for this stream.

getExceptionListener() - Method in class java.beans.XMLDecoder

Gets the exception handler for this stream.

getExceptionTypes() - Method in class java.lang.reflect.Constructor

Returns an array of Class objects that represent the types of exceptions declared to be thrown by the underlying executable represented by this object.

getExceptionTypes() - Method in class java.lang.reflect.Executable

Returns an array of Class objects that represent the types of exceptions declared to be thrown by the underlying executable represented by this object.

getExceptionTypes() - Method in class java.lang.reflect.Method

Returns an array of Class objects that represent the types of exceptions declared to be thrown by the underlying executable represented by this object.

getExclusiveOwnerThread() - Method in class java.util.concurrent.locks.AbstractOwnableSynchronizer

Returns the thread last set by setExclusiveOwnerThread, or null if never set.

getExclusiveQueuedThreads() - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer

Returns a collection containing threads that may be waiting to acquire in exclusive mode.

getExclusiveQueuedThreads() - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer

Returns a collection containing threads that may be waiting to acquire in exclusive mode.

getExecuteExistingDelayedTasksAfterShutdownPolicy() - Method in class java.util.concurrent.ScheduledThreadPoolExecutor

Gets the policy on whether to execute existing delayed tasks even when this executor has been shutdown.

getExecutor() - Method in class javax.xml.ws.Endpoint

Returns the executor for this Endpointinstance.

getExecutor() - Method in class javax.xml.ws.Service

Returns the executor for this Serviceinstance.

getExecutor() - Method in class javax.xml.ws.spi.ServiceDelegate

Returns the executor for this Serviceinstance.

getExemptionMechanism() - Method in class javax.crypto.Cipher

Returns the exemption mechanism object used with this cipher.

getExp() - Method in exception javax.management.BadBinaryOpValueExpException

Returns the ValueExp that originated the exception.

getExpandedDescendants(TreePath) - Method in class javax.swing.JTree

Returns an Enumeration of the descendants of the path parent that are currently expanded.

getExpandedIcon() - Method in class javax.swing.plaf.basic.BasicTreeUI

getExpandedIcon() - Method in class javax.swing.plaf.synth.SynthTreeUI

getExpandedState(TreePath) - Method in class javax.swing.tree.AbstractLayoutCache

Returns true if the path is expanded, and visible.

getExpandedState(TreePath) - Method in class javax.swing.tree.FixedHeightLayoutCache

Returns true if the path is expanded, and visible.

getExpandedState(TreePath) - Method in class javax.swing.tree.VariableHeightLayoutCache

Returns true if the path is expanded, and visible.

getExpandsSelectedPaths() - Method in class javax.swing.JTree

Returns the expandsSelectedPaths property.

getExpectedPolicies() - Method in interface java.security.cert.PolicyNode

Returns the set of expected policies that would satisfy this node's valid policy in the next certificate to be processed.

getExpiration() - Method in class java.net.URLConnection

Returns the value of the expires header field.

getExplanation() - Method in exception javax.naming.NamingException

Retrieves the explanation associated with this exception.

getExponent(float) - Static method in class java.lang.Math

Returns the unbiased exponent used in the representation of a float.

getExponent(double) - Static method in class java.lang.Math

Returns the unbiased exponent used in the representation of a double.

getExponent(float) - Static method in class java.lang.StrictMath

Returns the unbiased exponent used in the representation of a float.

getExponent(double) - Static method in class java.lang.StrictMath

Returns the unbiased exponent used in the representation of a double.

getExponent() - Method in class java.security.spec.RSAOtherPrimeInfo

Returns the prime's exponent.

getExponentSeparator() - Method in class java.text.DecimalFormatSymbols

Returns the string used to separate the mantissa from the exponent.

getExponentSize() - Method in class javax.crypto.spec.DHGenParameterSpec

Returns the size in bits of the random exponent (private value).

getExportedKeys(String, String, String) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of the foreign key columns that reference the given table's primary key columns (the foreign keys exported by a table).

getExpression() - Method in class javax.xml.crypto.dsig.spec.XPathType

Returns the XPath expression to be evaluated.

getExtendedCacheKeys(JComponent) - Method in class javax.swing.plaf.nimbus.AbstractRegionPainter

Get any extra attributes which the painter implementation would like to include in the image cache lookups.

getExtendedKeyCode() - Method in class java.awt.event.KeyEvent

Returns an extended key code for the event.

getExtendedKeyCodeForChar(int) - Static method in class java.awt.event.KeyEvent

Returns an extended key code for a unicode character.

getExtendedKeyUsage() - Method in class java.security.cert.X509Certificate

Gets an unmodifiable list of Strings representing the OBJECT IDENTIFIERs of the ExtKeyUsageSyntax field of the extended key usage extension, (OID = 2.5.29.37).

getExtendedKeyUsage() - Method in class java.security.cert.X509CertSelector

Returns the extendedKeyUsage criterion.

getExtendedState() - Method in class java.awt.Frame

Gets the state of this frame.

getExtendsBound() - Method in interface javax.lang.model.type.WildcardType

Returns the upper bound of this wildcard.

getExtension(char) - Method in class java.util.Locale

Returns the extension (or private use) value associated with the specified key, or null if there is no extension associated with the key.

getExtension() - Method in class javax.sound.sampled.AudioFileFormat.Type

Obtains the common file name extension for this file type.

getExtensionKeys() - Method in class java.util.Locale

Returns the set of extension keys associated with this locale, or the empty set if it has no extensions.

getExtensions() - Method in exception java.security.cert.CertificateRevokedException

Returns a map of X.509 extensions containing additional information about the revoked certificate, such as the Invalidity Date Extension.

getExtensions() - Method in interface javax.script.ScriptEngineFactory

Returns an immutable list of filename extensions, which generally identify scripts written in the language supported by this ScriptEngine.

getExtensions() - Method in class javax.swing.filechooser.FileNameExtensionFilter

Returns the set of file name extensions files are tested against.

getExtensionValue(String) - Method in interface java.security.cert.X509Extension

Gets the DER-encoded OCTET string for the extension value (extnValue) identified by the passed-in oid String.

getExtent() - Method in interface javax.swing.BoundedRangeModel

Returns the model's extent, the length of the inner range that begins at the model's value.

getExtent() - Method in class javax.swing.DefaultBoundedRangeModel

Returns the model's extent.

getExtent() - Method in class javax.swing.JSlider

Returns the "extent" from the BoundedRangeModel.

getExtentSize() - Method in class javax.swing.JViewport

Returns the size of the visible part of the view in view coordinates.

getExternalElements() - Method in interface javax.xml.crypto.dsig.keyinfo.PGPData

Returns an unmodifiable list of XMLStructures representing elements from an external namespace.

getExternalSubset(String, String) - Method in class org.xml.sax.ext.DefaultHandler2

Tells the parser that if no external subset has been declared in the document text, none should be used.

getExternalSubset(String, String) - Method in interface org.xml.sax.ext.EntityResolver2

Allows applications to provide an external subset for documents that don't explicitly define one.

getExtra() - Method in class java.util.zip.ZipEntry

Returns the extra field data for the entry.

getExtraImageMetadataFormatNames() - Method in class javax.imageio.spi.ImageReaderWriterSpi

Returns an array of Strings containing the names of additional document formats, other than the native and standard formats, recognized by the getAsTree and setFromTree methods on the image metadata objects produced or consumed by this plug-in.

getExtraMetadataFormatNames() - Method in class javax.imageio.metadata.IIOMetadata

Returns an array of Strings containing the names of additional metadata formats, other than the native and standard formats, recognized by this plug-in's getAsTree, setFromTree, and mergeTree methods.

getExtraNameCharacters() - Method in interface java.sql.DatabaseMetaData

Retrieves all the "extra" characters that can be used in unquoted identifier names (those beyond a-z, A-Z, 0-9 and _).

getExtraStreamMetadataFormatNames() - Method in class javax.imageio.spi.ImageReaderWriterSpi

Returns an array of Strings containing the names of additional document formats, other than the native and standard formats, recognized by the getAsTree and setFromTree methods on the stream metadata objects produced or consumed by this plug-in.

getFactory() - Method in class java.util.concurrent.ForkJoinPool

Returns the factory used for constructing new workers.

getFactory() - Method in interface javax.script.ScriptEngine

Returns a ScriptEngineFactory for the class to which this ScriptEngine belongs.

getFactoryClassLocation() - Method in class javax.naming.Reference

Retrieves the location of the factory of the object to which this reference refers.

getFactoryClassName() - Method in class javax.naming.Reference

Retrieves the class name of the factory of the object to which this reference refers.

getFailedProperties() - Method in exception java.sql.SQLClientInfoException

Returns the list of client info properties that could not be set.

getFailureHandler() - Static method in class java.rmi.server.RMISocketFactory

Returns the handler for socket creation failure set by the setFailureHandler method.

getFallbackLocale(String, Locale) - Method in class java.util.ResourceBundle.Control

Returns a Locale to be used as a fallback locale for further resource bundle searches by the ResourceBundle.getBundle factory method.

getFamily() - Method in class java.awt.Font

Returns the family name of this Font.

getFamily(Locale) - Method in class java.awt.Font

Returns the family name of this Font, localized for the specified locale.

getFault() - Method in interface javax.xml.soap.SOAPBody

Returns the SOAPFault object in this SOAPBody object.

getFault() - Method in exception javax.xml.ws.soap.SOAPFaultException

Gets the embedded SOAPFault instance.

getFaultActor() - Method in interface javax.xml.soap.SOAPFault

Gets the fault actor for this SOAPFault object.

getFaultCode() - Method in interface javax.xml.soap.SOAPFault

Gets the fault code for this SOAPFault object.

getFaultCodeAsName() - Method in interface javax.xml.soap.SOAPFault

Gets the mandatory SOAP 1.1 fault code for this SOAPFault object as a SAAJ Name object.

getFaultCodeAsQName() - Method in interface javax.xml.soap.SOAPFault

Gets the fault code for this SOAPFault object as a QName object.

getFaultNode() - Method in interface javax.xml.soap.SOAPFault

Returns the optional Node element value for this SOAPFault object.

getFaultReasonLocales() - Method in interface javax.xml.soap.SOAPFault

Returns an Iterator over a distinct sequence of Locales for which there are associated Reason Text items.

getFaultReasonText(Locale) - Method in interface javax.xml.soap.SOAPFault

Returns the Reason Text associated with the given Locale.

getFaultReasonTexts() - Method in interface javax.xml.soap.SOAPFault

Returns an Iterator over a sequence of String objects containing all of the Reason Text items for this SOAPFault.

getFaultRole() - Method in interface javax.xml.soap.SOAPFault

Returns the optional Role element value for this SOAPFault object.

getFaultString() - Method in interface javax.xml.soap.SOAPFault

Gets the fault string for this SOAPFault object.

getFaultStringLocale() - Method in interface javax.xml.soap.SOAPFault

Gets the locale of the fault string for this SOAPFault object.

getFaultSubcodes() - Method in interface javax.xml.soap.SOAPFault

Gets the Subcodes for this SOAPFault as an iterator over QNames.

getFD() - Method in class java.io.FileInputStream

Returns the FileDescriptor object that represents the connection to the actual file in the file system being used by this FileInputStream.

getFD() - Method in class java.io.FileOutputStream

Returns the file descriptor associated with this stream.

getFD() - Method in class java.io.RandomAccessFile

Returns the opaque file descriptor object associated with this stream.

getFeature(String, String) - Method in class javax.imageio.metadata.IIOMetadataNode

This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.

getFeature(String) - Method in class javax.xml.parsers.DocumentBuilderFactory

Get the state of the named feature.

getFeature(String) - Method in class javax.xml.parsers.SAXParserFactory

Returns the particular property requested for in the underlying implementation of org.xml.sax.XMLReader.

getFeature(String) - Method in class javax.xml.transform.TransformerFactory

Look up the value of a feature.

getFeature(String) - Method in class javax.xml.validation.SchemaFactory

Look up the value of a feature flag.

getFeature(String) - Method in class javax.xml.validation.Validator

Look up the value of a feature flag.

getFeature(String) - Method in class javax.xml.validation.ValidatorHandler

Look up the value of a feature flag.

getFeature(String) - Method in class javax.xml.xpath.XPathFactory

Get the state of the named feature.

getFeature(String, String) - Method in interface org.w3c.dom.DOMImplementation

This method returns a specialized object which implements the specialized APIs of the specified feature and version, as specified in DOM Features.

getFeature(String, String) - Method in interface org.w3c.dom.Node

This method returns a specialized object which implements the specialized APIs of the specified feature and version, as specified in .

getFeature(String) - Method in class org.xml.sax.helpers.ParserAdapter

Check a parser feature flag.

getFeature(String) - Method in class org.xml.sax.helpers.XMLFilterImpl

Look up the value of a feature.

getFeature(String) - Method in interface org.xml.sax.XMLReader

Look up the value of a feature flag.

getFeedResolution(int) - Method in class javax.print.attribute.ResolutionSyntax

Returns this resolution attribute's feed direction resolution in the given units.

getFeedResolutionDphi() - Method in class javax.print.attribute.ResolutionSyntax

Returns this resolution attribute's feed direction resolution in units of dphi.

getFetchDirection() - Method in interface java.sql.ResultSet

Retrieves the fetch direction for this ResultSet object.

getFetchDirection() - Method in interface java.sql.Statement

Retrieves the direction for fetching rows from database tables that is the default for result sets generated from this Statement object.

getFetchDirection() - Method in class javax.sql.rowset.BaseRowSet

Retrieves this RowSet object's current setting for the fetch direction.

getFetchSize() - Method in interface java.sql.ResultSet

Retrieves the fetch size for this ResultSet object.

getFetchSize() - Method in interface java.sql.Statement

Retrieves the number of result set rows that is the default fetch size for ResultSet objects generated from this Statement object.

getFetchSize() - Method in class javax.sql.rowset.BaseRowSet

Returns the fetch size for this RowSet object.

GetField() - Constructor for class java.io.ObjectInputStream.GetField

getField(String) - Method in class java.io.ObjectStreamClass

Get the field of this class by name.

getField(String) - Method in class java.lang.Class

Returns a Field object that reflects the specified public member field of the class or interface represented by this Class object.

getField() - Method in class java.security.spec.EllipticCurve

Returns the finite field field that this elliptic curve is over.

getField() - Method in class java.text.FieldPosition

Retrieves the field identifier.

getField(DatatypeConstants.Field) - Method in class javax.xml.datatype.Duration

Gets the value of a field.

getFieldAttribute() - Method in class java.text.FieldPosition

Returns the field identifier as an attribute constant from one of the Field subclasses.

getFieldNames() - Method in interface javax.management.Descriptor

Returns all the field names in the descriptor.

getFieldNames() - Method in class javax.management.ImmutableDescriptor

getFieldNames() - Method in class javax.management.modelmbean.DescriptorSupport

getFields() - Method in class java.io.ObjectStreamClass

Return an array of the fields of this serializable class.

getFields() - Method in class java.lang.Class

Returns an array containing Field objects reflecting all the accessible public fields of the class or interface represented by this Class object.

getFields() - Method in interface javax.management.Descriptor

Returns all of the fields contained in this descriptor as a string array.

getFields() - Method in class javax.management.ImmutableDescriptor

getFields() - Method in class javax.management.modelmbean.DescriptorSupport

getFields() - Method in class javax.sql.rowset.serial.SerialJavaObject

Returns an array of Field objects that contains each field of the object that this helper class is serializing.

getFields(int) - Method in class javax.swing.text.InternationalFormatter

Returns the Format.Field constants associated with the text at offset.

getFieldSize() - Method in interface java.security.spec.ECField

Returns the field size in bits.

getFieldSize() - Method in class java.security.spec.ECFieldF2m

Returns the field size in bits which is m for this characteristic 2 finite field.

getFieldSize() - Method in class java.security.spec.ECFieldFp

Returns the field size in bits which is size of prime p for this prime finite field.

getFieldValue(String) - Method in interface javax.management.Descriptor

Returns the value for a specific field name, or null if no value is present for that name.

getFieldValue(String) - Method in class javax.management.ImmutableDescriptor

getFieldValue(String) - Method in class javax.management.modelmbean.DescriptorSupport

getFieldValues(String...) - Method in interface javax.management.Descriptor

Returns all the field values in the descriptor as an array of Objects.

getFieldValues(String...) - Method in class javax.management.ImmutableDescriptor

getFieldValues(String...) - Method in class javax.management.modelmbean.DescriptorSupport

getFile() - Method in class java.awt.FileDialog

Gets the selected file of this file dialog.

getFile() - Method in class java.net.URL

Gets the file name of this URL.

getFile() - Method in exception java.nio.file.FileSystemException

Returns the file used to create this exception.

getFile() - Method in class javax.activation.FileDataSource

Return the File object that corresponds to this FileDataSource.

getFileAttributeView(Path, Class<V>, LinkOption...) - Static method in class java.nio.file.Files

Returns a file attribute view of a given type.

getFileAttributeView(Class<V>) - Method in interface java.nio.file.SecureDirectoryStream

Returns a new file attribute view to access the file attributes of this directory.

getFileAttributeView(T, Class<V>, LinkOption...) - Method in interface java.nio.file.SecureDirectoryStream

Returns a new file attribute view to access the file attributes of a file in this directory.

getFileAttributeView(Path, Class<V>, LinkOption...) - Method in class java.nio.file.spi.FileSystemProvider

Returns a file attribute view of a given type.

getFileChooser() - Method in class javax.swing.plaf.basic.BasicFileChooserUI

getFileChooserDetailViewIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

getFileChooserHomeFolderIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

getFileChooserListViewIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

getFileChooserNewFolderIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

getFileChooserUpFolderIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

getFileDescriptor() - Method in class java.net.DatagramSocketImpl

Gets the datagram socket file descriptor.

getFileDescriptor() - Method in class java.net.SocketImpl

Returns the value of this socket's fd field.

getFileFilter() - Method in class javax.swing.JFileChooser

Returns the currently selected file filter.

getFileForInput(JavaFileManager.Location, String, String) - Method in class javax.tools.ForwardingJavaFileManager

getFileForInput(JavaFileManager.Location, String, String) - Method in interface javax.tools.JavaFileManager

Gets a file object for input representing the specified relative name in the specified package in the given location.

getFileForOutput(JavaFileManager.Location, String, String, FileObject) - Method in class javax.tools.ForwardingJavaFileManager

getFileForOutput(JavaFileManager.Location, String, String, FileObject) - Method in interface javax.tools.JavaFileManager

Gets a file object for output representing the specified relative name in the specified package in the given location.

getFileName() - Method in class java.awt.JobAttributes

Specifies the file name for the output file for jobs using these attributes.

getFileName() - Method in class java.lang.StackTraceElement

Returns the name of the source file containing the execution point represented by this stack trace element.

getFileName() - Method in interface java.nio.file.Path

Returns the name of the file or directory denoted by this path as a Path object.

getFileName() - Method in exception javax.script.ScriptException

Get the source of the script causing the error.

getFileName() - Method in class javax.swing.plaf.basic.BasicFileChooserUI

getFileName() - Method in class javax.swing.plaf.metal.MetalFileChooserUI

getFilenameFilter() - Method in class java.awt.FileDialog

Determines this file dialog's filename filter.

getFileNameMap() - Static method in class java.net.URLConnection

Loads filename map (a mimetable) from a data file.

getFilePointer() - Method in class java.io.RandomAccessFile

Returns the current offset in this file.

getFiler() - Method in interface javax.annotation.processing.ProcessingEnvironment

Returns the filer used to create new source, class, or auxiliary files.

getFiles() - Method in class java.awt.FileDialog

Returns files that the user selects.

getFiles(File, boolean) - Method in class javax.swing.filechooser.FileSystemView

Gets the list of shown (i.e.

getFiles() - Method in class javax.swing.plaf.basic.BasicDirectoryModel

getFileSelectionMode() - Method in class javax.swing.JFileChooser

Returns the current file-selection mode.

getFileStore(Path) - Static method in class java.nio.file.Files

Returns the FileStore representing the file store where a file is located.

getFileStore(Path) - Method in class java.nio.file.spi.FileSystemProvider

Returns the FileStore representing the file store where a file is located.

getFileStoreAttributeView(Class<V>) - Method in class java.nio.file.FileStore

Returns a FileStoreAttributeView of the given type.

getFileStores() - Method in class java.nio.file.FileSystem

Returns an object to iterate over the underlying file stores.

getFileSuffixes() - Method in class javax.imageio.spi.ImageReaderWriterSpi

Returns an array of Strings containing a list of file suffixes associated with the formats that are generally usable by the ImageReader or ImageWriter implementation associated with this service provider.

getFileSystem(URI) - Static method in class java.nio.file.FileSystems

Returns a reference to an existing FileSystem.

getFileSystem() - Method in interface java.nio.file.Path

Returns the file system that created this object.

getFileSystem(URI) - Method in class java.nio.file.spi.FileSystemProvider

Returns an existing FileSystem created by this provider.

getFileSystemView() - Static method in class javax.swing.filechooser.FileSystemView

getFileSystemView() - Method in class javax.swing.JFileChooser

Returns the file system view.

getFileView() - Method in class javax.swing.JFileChooser

Returns the current file view.

getFileView(JFileChooser) - Method in class javax.swing.plaf.basic.BasicFileChooserUI

getFileView(JFileChooser) - Method in class javax.swing.plaf.FileChooserUI

getFileView(JFileChooser) - Method in class javax.swing.plaf.multi.MultiFileChooserUI

Invokes the getFileView method on each UI handled by this object.

getFillsViewportHeight() - Method in class javax.swing.JTable

Returns whether or not this table is always made large enough to fill the height of an enclosing viewport.

getFilter() - Method in class java.util.logging.Handler

Get the current Filter for this Handler.

getFilter() - Method in class java.util.logging.Logger

Get the current filter for this Logger.

getFilter() - Method in interface javax.sql.rowset.FilteredRowSet

Retrieves the active filter for this FilteredRowSet object.

getFilter() - Method in class javax.xml.crypto.dsig.spec.XPathType

Returns the filter operation.

getFilter() - Method in interface org.w3c.dom.ls.LSParser

When a filter is provided, the implementation will call out to the filter as it is constructing the DOM tree structure.

getFilter() - Method in interface org.w3c.dom.ls.LSSerializer

When the application provides a filter, the serializer will call out to the filter before serializing each Node.

getFilterInstance(ImageConsumer) - Method in class java.awt.image.ImageFilter

Returns a unique instance of an ImageFilter object which will actually perform the filtering for the specified ImageConsumer.

getFirst() - Method in class java.util.ArrayDeque

getFirst() - Method in class java.util.concurrent.ConcurrentLinkedDeque

getFirst() - Method in class java.util.concurrent.LinkedBlockingDeque

getFirst() - Method in interface java.util.Deque

Retrieves, but does not remove, the first element of this deque.

getFirst() - Method in class java.util.LinkedList

Returns the first element in this list.

getFirstChild() - Method in class javax.imageio.metadata.IIOMetadataNode

Returns the first child of this node, or null if the node has no children.

getFirstChild() - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns this node's first child.

getFirstChild() - Method in interface org.w3c.dom.Node

The first child of this node.

getFirstColumn() - Method in interface javax.accessibility.AccessibleTableModelChange

Returns the first column that changed.

getFirstColumn() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange

getFirstComponent(Container) - Method in class java.awt.ContainerOrderFocusTraversalPolicy

Returns the first Component in the traversal cycle.

getFirstComponent(Container) - Method in class java.awt.FocusTraversalPolicy

Returns the first Component in the traversal cycle.

getFirstComponent(Container) - Method in class javax.swing.DefaultFocusManager

getFirstComponent(Container) - Method in class javax.swing.LayoutFocusTraversalPolicy

Returns the first Component in the traversal cycle.

getFirstComponent(Container) - Method in class javax.swing.SortingFocusTraversalPolicy

Returns the first Component in the traversal cycle.

getFirstDayOfWeek() - Method in class java.time.temporal.WeekFields

Gets the first day-of-week.

getFirstDayOfWeek() - Method in class java.util.Calendar

Gets what the first day of the week is; e.g., SUNDAY in the U.S., MONDAY in France.

getFirstDayOfWeek(Locale) - Method in class java.util.spi.CalendarDataProvider

Returns the first day of a week in the given locale.

getFirstIndex() - Method in class javax.swing.event.ListSelectionEvent

Returns the index of the first row whose selection may have changed.

getFirstLeaf() - Method in class javax.swing.tree.DefaultMutableTreeNode

Finds and returns the first leaf that is a descendant of this node -- either this node or its first child's first leaf.

getFirstLineIndent(AttributeSet) - Static method in class javax.swing.text.StyleConstants

Gets the first line indent setting.

getFirstQueuedThread() - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer

Returns the first (longest-waiting) thread in the queue, or null if no threads are currently queued.

getFirstQueuedThread() - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer

Returns the first (longest-waiting) thread in the queue, or null if no threads are currently queued.

getFirstRow() - Method in interface javax.accessibility.AccessibleTableModelChange

Returns the first row that changed.

getFirstRow() - Method in class javax.swing.event.TableModelEvent

Returns the first row that changed.

getFirstRow() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange

getFirstVisibleIndex() - Method in class javax.swing.JList

Returns the smallest list index that is currently visible.

getFixedCellHeight() - Method in class javax.swing.JList

Returns the value of the fixedCellHeight property.

getFixedCellWidth() - Method in class javax.swing.JList

Returns the value of the fixedCellWidth property.

getFixedRate(Integer) - Method in class javax.management.timer.Timer

Gets a copy of the flag indicating whether a periodic notification is executed at fixed-delay or at fixed-rate.

getFixedRate(Integer) - Method in interface javax.management.timer.TimerMBean

Gets a copy of the flag indicating whether a periodic notification is executed at fixed-delay or at fixed-rate.

getFlags() - Method in exception java.util.DuplicateFormatFlagsException

Returns the set of flags which contains a duplicate flag.

getFlags() - Method in exception java.util.FormatFlagsConversionMismatchException

Returns the incompatible flag.

getFlags() - Method in exception java.util.IllegalFormatFlagsException

Returns the set of flags which contains an illegal combination.

getFlags() - Method in exception java.util.UnknownFormatFlagsException

Returns the set of flags which contains an unknown flag.

getFlags() - Method in class javax.security.auth.kerberos.KerberosTicket

Returns the flags associated with this ticket.

getFlatness(double, double, double, double, double, double, double, double) - Static method in class java.awt.geom.CubicCurve2D

Returns the flatness of the cubic curve specified by the indicated control points.

getFlatness(double[], int) - Static method in class java.awt.geom.CubicCurve2D

Returns the flatness of the cubic curve specified by the control points stored in the indicated array at the indicated index.

getFlatness() - Method in class java.awt.geom.CubicCurve2D

Returns the flatness of this curve.

getFlatness() - Method in class java.awt.geom.FlatteningPathIterator

Returns the flatness of this iterator.

getFlatness(double, double, double, double, double, double) - Static method in class java.awt.geom.QuadCurve2D

Returns the flatness, or maximum distance of a control point from the line connecting the end points, of the quadratic curve specified by the indicated control points.

getFlatness(double[], int) - Static method in class java.awt.geom.QuadCurve2D

Returns the flatness, or maximum distance of a control point from the line connecting the end points, of the quadratic curve specified by the control points stored in the indicated array at the indicated index.

getFlatness() - Method in class java.awt.geom.QuadCurve2D

Returns the flatness, or maximum distance of a control point from the line connecting the end points, of this QuadCurve2D.

getFlatnessSq(double, double, double, double, double, double, double, double) - Static method in class java.awt.geom.CubicCurve2D

Returns the square of the flatness of the cubic curve specified by the indicated control points.

getFlatnessSq(double[], int) - Static method in class java.awt.geom.CubicCurve2D

Returns the square of the flatness of the cubic curve specified by the control points stored in the indicated array at the indicated index.

getFlatnessSq() - Method in class java.awt.geom.CubicCurve2D

Returns the square of the flatness of this curve.

getFlatnessSq(double, double, double, double, double, double) - Static method in class java.awt.geom.QuadCurve2D

Returns the square of the flatness, or maximum distance of a control point from the line connecting the end points, of the quadratic curve specified by the indicated control points.

getFlatnessSq(double[], int) - Static method in class java.awt.geom.QuadCurve2D

Returns the square of the flatness, or maximum distance of a control point from the line connecting the end points, of the quadratic curve specified by the control points stored in the indicated array at the indicated index.

getFlatnessSq() - Method in class java.awt.geom.QuadCurve2D

Returns the square of the flatness, or maximum distance of a control point from the line connecting the end points, of this QuadCurve2D.

getFlavorListeners() - Method in class java.awt.datatransfer.Clipboard

Returns an array of all the FlavorListeners currently registered on this Clipboard.

getFlavorMap() - Method in class java.awt.dnd.DragSource

This method returns the FlavorMap for this DragSource.

getFlavorMap() - Method in class java.awt.dnd.DropTarget

Gets the FlavorMap associated with this DropTarget.

getFlavorsForNative(String) - Method in interface java.awt.datatransfer.FlavorTable

Returns a List of DataFlavors to which the specified String corresponds.

getFlavorsForNative(String) - Method in class java.awt.datatransfer.SystemFlavorMap

Returns a List of DataFlavors to which the specified String native can be translated by the data transfer subsystem.

getFlavorsForNatives(String[]) - Method in interface java.awt.datatransfer.FlavorMap

Returns a Map of the specified String natives to their corresponding DataFlavor.

getFlavorsForNatives(String[]) - Method in class java.awt.datatransfer.SystemFlavorMap

Returns a Map of the specified String natives to their most preferred DataFlavor.

getFlipContents() - Method in class java.awt.BufferCapabilities

getFloat(Object, int) - Static method in class java.lang.reflect.Array

Returns the value of the indexed component in the specified array object, as a float.

getFloat(Object) - Method in class java.lang.reflect.Field

Gets the value of a static or instance field of type float or of another primitive type convertible to type float via a widening conversion.

getFloat() - Method in class java.nio.ByteBuffer

Relative get method for reading a float value.

getFloat(int) - Method in class java.nio.ByteBuffer

Absolute get method for reading a float value.

getFloat(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC FLOAT parameter as a float in the Java programming language.

getFloat(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC FLOAT parameter as a float in the Java programming language.

getFloat(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a float in the Java programming language.

getFloat(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a float in the Java programming language.

getFloat(String, float) - Method in class java.util.prefs.AbstractPreferences

Implements the getFloat method as per the specification in Preferences.getFloat(String,float).

getFloat(String, float) - Method in class java.util.prefs.Preferences

Returns the float value represented by the string associated with the specified key in this preference node.

getFloatingColor() - Method in class javax.swing.plaf.basic.BasicToolBarUI

Gets the color displayed when over a floating area

getFloatParameter(int) - Method in class java.awt.image.renderable.ParameterBlock

A convenience method to return a parameter as a float.

getFlowAxis() - Method in class javax.swing.text.FlowView

Fetches the axis along which views should be flowed.

getFlowSpan(int) - Method in class javax.swing.text.FlowView

Fetch the constraining span to flow against for the given child index.

getFlowSpan(int) - Method in class javax.swing.text.ParagraphView

Fetches the constraining span to flow against for the given child index.

getFlowStart(int) - Method in class javax.swing.text.FlowView

Fetch the location along the flow axis that the flow span will start at.

getFlowStart(int) - Method in class javax.swing.text.ParagraphView

Fetches the location along the flow axis that the flow span will start at.

getFlushedPosition() - Method in interface javax.imageio.stream.ImageInputStream

Returns the earliest position in the stream to which seeking may be performed.

getFlushedPosition() - Method in class javax.imageio.stream.ImageInputStreamImpl

getFocusableWindowState() - Method in class java.awt.Window

Returns whether this Window can become the focused Window if it meets the other requirements outlined in isFocusableWindow.

getFocusAccelerator() - Method in class javax.swing.text.JTextComponent

Returns the key accelerator that will cause the receiving text component to get the focus.

getFocusColor() - Method in class javax.swing.plaf.basic.BasicSliderUI

getFocusColor() - Method in class javax.swing.plaf.metal.MetalButtonUI

getFocusColor() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the focus color of the current theme.

getFocusColor() - Method in class javax.swing.plaf.metal.MetalRadioButtonUI

getFocusColor() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the focus color.

getFocusColor() - Method in class javax.swing.plaf.metal.MetalToggleButtonUI

getFocusCycleRootAncestor() - Method in class java.awt.Component

Returns the Container which is the focus cycle root of this Component's focus traversal cycle.

getFocusCycleRootAncestor() - Method in class java.awt.Window

Always returns null because Windows have no ancestors; they represent the top of the Component hierarchy.

getFocusCycleRootAncestor() - Method in class javax.swing.JInternalFrame

Always returns null because JInternalFrames must always be roots of a focus traversal cycle.

getFocusedComponent() - Method in class javax.swing.text.TextAction

Fetches the text component that currently has focus.

getFocusedWindow() - Method in class java.awt.KeyboardFocusManager

Returns the focused Window, if the focused Window is in the same context as the calling thread.

getFocusIndex() - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

Returns the index of the tab that has focus.

getFocusListeners() - Method in class java.awt.Component

Returns an array of all the focus listeners registered on this component.

getFocusLostBehavior() - Method in class javax.swing.JFormattedTextField

Returns the behavior when focus is lost.

getFocusOwner() - Method in class java.awt.KeyboardFocusManager

Returns the focus owner, if the focus owner is in the same context as the calling thread.

getFocusOwner() - Method in class java.awt.Window

Returns the child Component of this Window that has focus if this Window is focused; returns null otherwise.

getFocusOwner() - Method in class javax.swing.JInternalFrame

If this JInternalFrame is active, returns the child that has focus.

getFocusPoint() - Method in class java.awt.RadialGradientPaint

Returns a copy of the focus point of the radial gradient.

getFocusTraversalKeys(int) - Method in class java.awt.Component

Returns the Set of focus traversal keys for a given traversal operation for this Component.

getFocusTraversalKeys(int) - Method in class java.awt.Container

Returns the Set of focus traversal keys for a given traversal operation for this Container.

getFocusTraversalKeys(int) - Method in class java.awt.Window

Gets a focus traversal key for this Window.

getFocusTraversalKeysEnabled() - Method in class java.awt.Component

Returns whether focus traversal keys are enabled for this Component.

getFocusTraversalPolicy() - Method in class java.awt.Container

Returns the focus traversal policy that will manage keyboard traversal of this Container's children, or null if this Container is not a focus cycle root.

getFollowRedirects() - Static method in class java.net.HttpURLConnection

Returns a boolean indicating whether or not HTTP redirects (3xx) should be automatically followed.

getFont() - Method in class java.awt.Component.AccessibleAWTComponent

Gets the Font of this object.

getFont() - Method in class java.awt.Component

Gets the font of this component.

getFont(Map<? extends AttributedCharacterIterator.Attribute, ?>) - Static method in class java.awt.Font

Returns a Font appropriate to the attributes.

getFont(String) - Static method in class java.awt.Font

Returns a Font object from the system properties list.

getFont(String, Font) - Static method in class java.awt.Font

Gets the specified Font from the system properties list.

getFont() - Method in class java.awt.font.GlyphVector

Returns the Font associated with this GlyphVector.

getFont() - Method in class java.awt.FontMetrics

Gets the Font described by this FontMetrics object.

getFont() - Method in class java.awt.Graphics

Gets the current font.

getFont() - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Get the Font of this object.

getFont() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Gets the Font of this object.

getFont() - Method in class java.awt.MenuComponent

Gets the font used for this menu component.

getFont() - Method in interface java.awt.MenuContainer

getFont() - Method in interface javax.accessibility.AccessibleComponent

Gets the Font of this object.

getFont(Component) - Method in class javax.swing.border.TitledBorder

getFont() - Method in class javax.swing.DebugGraphics

Returns the Font used for text drawing operations.

getFont() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getFont() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the Font of this object.

getFont() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

getFont(SynthContext) - Method in class javax.swing.plaf.synth.SynthStyle

Returns the Font for the specified state.

getFont() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getFont(AttributeSet) - Method in class javax.swing.text.DefaultStyledDocument

Gets the font from an attribute set.

getFont() - Method in class javax.swing.text.GlyphView

Fetch the font that the glyphs should be based upon.

getFont(AttributeSet) - Method in class javax.swing.text.html.StyleSheet

Fetches the font to use for the given set of attributes.

getFont() - Method in class javax.swing.text.LabelView

Fetches the font that the glyphs should be based upon.

getFont(AttributeSet) - Method in class javax.swing.text.StyleContext

Gets the font from an attribute set.

getFont(String, int, int) - Method in class javax.swing.text.StyleContext

Gets a new font.

getFont(AttributeSet) - Method in interface javax.swing.text.StyledDocument

Takes a set of attributes and turn it into a font specification.

getFont() - Method in class javax.swing.tree.DefaultTreeCellEditor.DefaultTextField

getFont() - Method in class javax.swing.tree.DefaultTreeCellEditor

Gets the font used for editing.

getFont() - Method in class javax.swing.tree.DefaultTreeCellRenderer

Gets the font of this component.

getFont(Object) - Method in class javax.swing.UIDefaults

If the value of key is a Font return it, otherwise return null.

getFont(Object, Locale) - Method in class javax.swing.UIDefaults

If the value of key for the given Locale is a Font return it, otherwise return null.

getFont(Object) - Static method in class javax.swing.UIManager

Returns a font from the defaults.

getFont(Object, Locale) - Static method in class javax.swing.UIManager

Returns a font from the defaults that is appropriate for the given locale.

getFontFamily(AttributeSet) - Static method in class javax.swing.text.StyleConstants

Gets the font family setting from the attribute list.

getFontForState(SynthContext) - Method in class javax.swing.plaf.nimbus.NimbusStyle

Returns the font for the specified state.

getFontForState(SynthContext) - Method in class javax.swing.plaf.synth.SynthStyle

Returns the font for the specified state.

getFontList() - Method in class java.awt.Toolkit

Deprecated.
see GraphicsEnvironment.getAvailableFontFamilyNames()

getFontMetrics(Font) - Method in class java.awt.Component.AccessibleAWTComponent

Gets the FontMetrics of this object.

getFontMetrics(Font) - Method in class java.awt.Component

Gets the font metrics for the specified font.

getFontMetrics() - Method in class java.awt.Graphics

Gets the font metrics of the current font.

getFontMetrics(Font) - Method in class java.awt.Graphics

Gets the font metrics for the specified font.

getFontMetrics(Font) - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Get the FontMetrics of this object.

getFontMetrics(Font) - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Gets the FontMetrics of this object.

getFontMetrics(Font) - Method in class java.awt.Toolkit

Deprecated.
As of JDK version 1.2, replaced by the Font method getLineMetrics.

getFontMetrics(Font) - Method in interface javax.accessibility.AccessibleComponent

Gets the FontMetrics of this object.

getFontMetrics() - Method in class javax.swing.DebugGraphics

Overrides Graphics.getFontMetrics.

getFontMetrics(Font) - Method in class javax.swing.DebugGraphics

Overrides Graphics.getFontMetrics.

getFontMetrics(Font) - Method in class javax.swing.JComponent

Gets the FontMetrics for the specified Font.

getFontMetrics(Font) - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getFontMetrics(Font) - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the FontMetrics of this object.

getFontMetrics(Font) - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

getFontMetrics() - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getFontMetrics() - Method in class javax.swing.plaf.synth.SynthTabbedPaneUI

getFontMetrics(Font) - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getFontMetrics() - Method in class javax.swing.text.FieldView

Fetches the font metrics associated with the component hosting this view.

getFontMetrics() - Method in class javax.swing.text.LabelView

Deprecated.
FontMetrics are not used for glyph rendering when running in the JDK.

getFontMetrics(Font) - Method in class javax.swing.text.StyleContext

Returns font metrics for a font.

getFontName() - Method in class java.awt.Font

Returns the font face name of this Font.

getFontName(Locale) - Method in class java.awt.Font

Returns the font face name of the Font, localized for the specified locale.

getFontPeer(String, int) - Method in class java.awt.Toolkit

Deprecated.
see java.awt.GraphicsEnvironment#getAllFonts

getFontRenderContext() - Method in class java.awt.font.GlyphVector

Returns the FontRenderContext associated with this GlyphVector.

getFontRenderContext() - Method in class java.awt.FontMetrics

Gets the FontRenderContext used by this FontMetrics object to measure text.

getFontRenderContext() - Method in class java.awt.Graphics2D

Get the rendering context of the Font within this Graphics2D context.

getFontSize(AttributeSet) - Static method in class javax.swing.text.StyleConstants

Gets the font size setting from the attribute list.

getFontTable(int) - Method in interface java.awt.font.OpenType

Returns the table as an array of bytes for a specified tag.

getFontTable(String) - Method in interface java.awt.font.OpenType

Returns the table as an array of bytes for a specified tag.

getFontTable(int, int, int) - Method in interface java.awt.font.OpenType

Returns a subset of the table as an array of bytes for a specified tag.

getFontTable(String, int, int) - Method in interface java.awt.font.OpenType

Returns a subset of the table as an array of bytes for a specified tag.

getFontTableSize(int) - Method in interface java.awt.font.OpenType

Returns the size of the table for a specified tag.

getFontTableSize(String) - Method in interface java.awt.font.OpenType

Returns the size of the table for a specified tag.

getForeground() - Method in class java.awt.Component.AccessibleAWTComponent

Gets the foreground color of this object.

getForeground() - Method in class java.awt.Component

Gets the foreground color of this component.

getForeground() - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Get the foreground color of this object.

getForeground() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Gets the foreground color of this object.

getForeground() - Method in interface javax.accessibility.AccessibleComponent

Gets the foreground color of this object.

getForeground() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getForeground() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the foreground color of this object.

getForeground() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Get the foreground color of this object.

getForeground() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getForeground(AttributeSet) - Method in class javax.swing.text.DefaultStyledDocument

Gets the foreground color from an attribute set.

getForeground() - Method in class javax.swing.text.GlyphView

Fetch the foreground color to use to render the glyphs.

getForeground(AttributeSet) - Method in class javax.swing.text.html.StyleSheet

Takes a set of attributes and turn it into a foreground color specification.

getForeground() - Method in class javax.swing.text.LabelView

Fetches the foreground color to use to render the glyphs.

getForeground(AttributeSet) - Static method in class javax.swing.text.StyleConstants

Gets the foreground color setting from the attribute list.

getForeground(AttributeSet) - Method in class javax.swing.text.StyleContext

Takes a set of attributes and turn it into a foreground color specification.

getForeground(AttributeSet) - Method in interface javax.swing.text.StyledDocument

Takes a set of attributes and turn it into a foreground color specification.

getForegroundAt(int) - Method in class javax.swing.JTabbedPane

Returns the tab foreground color at index.

getForegroundPainter(SynthContext) - Method in class javax.swing.plaf.nimbus.NimbusStyle

Gets the appropriate foreground Painter, if there is one, for the state specified in the given SynthContext.

getForkJoinTaskTag() - Method in class java.util.concurrent.ForkJoinTask

Returns the tag for this task.

getFormat() - Method in interface java.security.Certificate

Deprecated.

Returns the name of the coding format.

getFormat() - Method in interface java.security.Key

Returns the name of the primary encoding format of this key, or null if this key does not support encoding.

getFormat() - Method in class java.security.spec.EncodedKeySpec

Returns the name of the encoding format associated with this key specification.

getFormat() - Method in class java.security.spec.PKCS8EncodedKeySpec

Returns the name of the encoding format associated with this key specification.

getFormat() - Method in class java.security.spec.X509EncodedKeySpec

Returns the name of the encoding format associated with this key specification.

getFormat() - Method in class javax.crypto.spec.SecretKeySpec

Returns the name of the encoding format for this secret key.

getFormat() - Method in class javax.security.auth.kerberos.KerberosKey

Returns the name of the encoding format for this secret key.

getFormat() - Method in class javax.sound.sampled.AudioFileFormat

Obtains the format of the audio data contained in the audio file.

getFormat() - Method in class javax.sound.sampled.AudioInputStream

Obtains the audio format of the sound data in this audio input stream.

getFormat() - Method in interface javax.sound.sampled.DataLine

Obtains the current format (encoding, sample rate, number of channels, etc.) of the data line's audio data.

getFormat() - Method in class javax.swing.JSpinner.DateEditor

Returns the java.text.SimpleDateFormat object the JFormattedTextField uses to parse and format numbers.

getFormat() - Method in class javax.swing.JSpinner.NumberEditor

Returns the java.text.DecimalFormat object the JFormattedTextField uses to parse and format numbers.

getFormat() - Method in class javax.swing.text.InternationalFormatter

Returns the format that dictates the legal values that can be edited and displayed.

getFormatId() - Method in interface javax.transaction.xa.Xid

Obtain the format identifier part of the XID.

getFormatName() - Method in class javax.imageio.ImageReader

Returns a String identifying the format of the input source.

getFormatNames() - Method in class javax.imageio.spi.ImageReaderWriterSpi

Returns an array of Strings containing human-readable names for the formats that are generally usable by the ImageReader or ImageWriter implementation associated with this service provider.

getFormats() - Method in class java.text.ChoiceFormat

Get the formats passed in the constructor.

getFormats() - Method in class java.text.MessageFormat

Gets the formats used for the format elements in the previously set pattern string.

getFormats(String) - Method in class java.util.ResourceBundle.Control

Returns a List of Strings containing formats to be used to load resource bundles for the given baseName.

getFormats() - Method in class javax.sound.sampled.DataLine.Info

Obtains a set of audio formats supported by the data line.

getFormatsByArgumentIndex() - Method in class java.text.MessageFormat

Gets the formats used for the values passed into format methods or returned from parse methods.

getFormatSpecifier() - Method in exception java.util.MissingFormatArgumentException

Returns the unmatched format specifier.

getFormatSpecifier() - Method in exception java.util.MissingFormatWidthException

Returns the format specifier which does not have a width.

getFormattedTextField() - Method in class javax.swing.JFormattedTextField.AbstractFormatter

Returns the current JFormattedTextField the AbstractFormatter is installed on.

getFormatter() - Method in class java.util.logging.Handler

Return the Formatter for this Handler.

getFormatter(JFormattedTextField) - Method in class javax.swing.JFormattedTextField.AbstractFormatterFactory

Returns an AbstractFormatter that can handle formatting of the passed in JFormattedTextField.

getFormatter() - Method in class javax.swing.JFormattedTextField

Returns the AbstractFormatter that is used to format and parse the current value.

getFormatter(JFormattedTextField) - Method in class javax.swing.text.DefaultFormatterFactory

Returns either the default formatter, display formatter, editor formatter or null formatter based on the state of the JFormattedTextField.

getFormatterFactory() - Method in class javax.swing.JFormattedTextField

Returns the current AbstractFormatterFactory.

getFractionalMetricsHint() - Method in class java.awt.font.FontRenderContext

Return the text fractional metrics rendering mode hint used in this FontRenderContext.

getFractionalSecond() - Method in class javax.xml.datatype.XMLGregorianCalendar

Return fractional seconds.

getFractions() - Method in class java.awt.MultipleGradientPaint

Returns a copy of the array of floats used by this gradient to calculate color distribution.

getFragment() - Method in class java.net.URI

Returns the decoded fragment component of this URI.

getFrame() - Method in class java.awt.geom.RectangularShape

Returns the framing Rectangle2D that defines the overall shape of this object.

getFrameCount() - Method in class javax.swing.plaf.basic.BasicProgressBarUI

Returns the number of frames for the complete animation loop used by an indeterminate JProgessBar.

getFrameForComponent(Component) - Static method in class javax.swing.JOptionPane

Returns the specified component's Frame.

getFrameIcon() - Method in class javax.swing.JInternalFrame

Returns the image displayed in the title bar of this internal frame (usually in the top-left corner).

getFrameLength() - Method in class javax.sound.sampled.AudioFileFormat

Obtains the length of the audio data contained in the file, expressed in sample frames.

getFrameLength() - Method in class javax.sound.sampled.AudioInputStream

Obtains the length of the stream, expressed in sample frames rather than bytes.

getFrameLength() - Method in interface javax.sound.sampled.Clip

Obtains the media length in sample frames.

getFramePosition() - Method in interface javax.sound.sampled.DataLine

Obtains the current position in the audio data, in sample frames.

getFramePosition() - Method in class javax.sound.sampled.LineEvent

Obtains the position in the line's audio data when the event occurred, expressed in sample frames.

getFrameRate() - Method in class javax.sound.sampled.AudioFormat

Obtains the frame rate in frames per second.

getFrames() - Static method in class java.awt.Frame

Returns an array of all Frames created by this application.

getFrameSize() - Method in class javax.sound.sampled.AudioFormat

Obtains the frame size in bytes.

getFreeSpace() - Method in class java.io.File

Returns the number of unallocated bytes in the partition named by this abstract path name.

getFrom(TemporalAccessor) - Method in enum java.time.temporal.ChronoField

getFrom(TemporalAccessor) - Method in interface java.time.temporal.TemporalField

Gets the value of this field from the specified temporal object.

getFromIndex() - Method in class javax.swing.event.TableColumnModelEvent

Returns the fromIndex.

getFromPage() - Method in class java.awt.JobAttributes

Returns, for jobs using these attributes, the first page to be printed, if a range of pages is to be printed.

getFrontBufferCapabilities() - Method in class java.awt.BufferCapabilities

getFullScreenWindow() - Method in class java.awt.GraphicsDevice

Returns the Window object representing the full-screen window if the device is in full-screen mode.

getFunctionalInterfaceClass() - Method in class java.lang.invoke.SerializedLambda

Get the name of the invoked type to which this lambda has been converted

getFunctionalInterfaceMethodName() - Method in class java.lang.invoke.SerializedLambda

Get the name of the primary method for the functional interface to which this lambda has been converted.

getFunctionalInterfaceMethodSignature() - Method in class java.lang.invoke.SerializedLambda

Get the signature of the primary method for the functional interface to which this lambda has been converted.

getFunctionColumns(String, String, String, String) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of the given catalog's system or user function parameters and return type.

getFunctions(String, String, String) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of the system and user functions available in the given catalog.

getG() - Method in interface java.security.interfaces.DSAParams

Returns the base, g.

getG() - Method in class java.security.spec.DSAParameterSpec

Returns the base g.

getG() - Method in class java.security.spec.DSAPrivateKeySpec

Returns the base g.

getG() - Method in class java.security.spec.DSAPublicKeySpec

Returns the base g.

getG() - Method in class javax.crypto.spec.DHParameterSpec

Returns the base generator g.

getG() - Method in class javax.crypto.spec.DHPrivateKeySpec

Returns the base generator g.

getG() - Method in class javax.crypto.spec.DHPublicKeySpec

Returns the base generator g.

getGamma() - Method in class java.awt.color.ICC_ProfileGray

Returns a gamma value representing the tone reproduction curve (TRC).

getGamma(int) - Method in class java.awt.color.ICC_ProfileRGB

Returns a gamma value representing the tone reproduction curve (TRC) for a particular component.

getGarbageCollectorMXBeans() - Static method in class java.lang.management.ManagementFactory

Returns a list of GarbageCollectorMXBean objects in the Java virtual machine.

getGeneratedKeys() - Method in interface java.sql.Statement

Retrieves any auto-generated keys created as a result of executing this Statement object.

getGenerator() - Method in class java.security.spec.ECParameterSpec

Returns the generator which is also known as the base point.

getGenericComponentType() - Method in interface java.lang.reflect.GenericArrayType

Returns a Type object representing the component type of this array.

getGenericDeclaration() - Method in interface java.lang.reflect.TypeVariable

Returns the GenericDeclaration object representing the generic declaration declared this type variable.

getGenericDisplayName(String, int, Locale) - Method in class java.util.spi.TimeZoneNameProvider

Returns a generic name for the given time zone ID that's suitable for presentation to the user in the specified locale.

getGenericElement() - Method in interface javax.lang.model.element.TypeParameterElement

Returns the generic class, interface, method, or constructor that is parameterized by this type parameter.

getGenericExceptionTypes() - Method in class java.lang.reflect.Constructor

Returns an array of Type objects that represent the exceptions declared to be thrown by this executable object.

getGenericExceptionTypes() - Method in class java.lang.reflect.Executable

Returns an array of Type objects that represent the exceptions declared to be thrown by this executable object.

getGenericExceptionTypes() - Method in class java.lang.reflect.Method

Returns an array of Type objects that represent the exceptions declared to be thrown by this executable object.

getGenericInterfaces() - Method in class java.lang.Class

Returns the Types representing the interfaces directly implemented by the class or interface represented by this object.

getGenericParameterTypes() - Method in class java.lang.reflect.Constructor

Returns an array of Type objects that represent the formal parameter types, in declaration order, of the executable represented by this object.

getGenericParameterTypes() - Method in class java.lang.reflect.Executable

Returns an array of Type objects that represent the formal parameter types, in declaration order, of the executable represented by this object.

getGenericParameterTypes() - Method in class java.lang.reflect.Method

Returns an array of Type objects that represent the formal parameter types, in declaration order, of the executable represented by this object.

getGenericReturnType() - Method in class java.lang.reflect.Method

Returns a Type object that represents the formal return type of the method represented by this Method object.

getGenericSuperclass() - Method in class java.lang.Class

Returns the Type representing the direct superclass of the entity (class, interface, primitive type or void) represented by this Class.

getGenericType() - Method in class java.lang.reflect.Field

Returns a Type object that represents the declared type for the field represented by this Field object.

getGestureModifiers() - Method in class java.awt.dnd.DragSourceDragEvent

This method returns an int representing the current state of the input device modifiers associated with the user's gesture.

getGestureModifiersEx() - Method in class java.awt.dnd.DragSourceDragEvent

This method returns an int representing the current state of the input device extended modifiers associated with the user's gesture.

getGetListenerMethod() - Method in class java.beans.EventSetDescriptor

Gets the method used to access the registered event listeners.

getGlassPane() - Method in class javax.swing.JApplet

Returns the glassPane object for this applet.

getGlassPane() - Method in class javax.swing.JDialog

Returns the glassPane object for this dialog.

getGlassPane() - Method in class javax.swing.JFrame

Returns the glassPane object for this frame.

getGlassPane() - Method in class javax.swing.JInternalFrame

Returns the glass pane for this internal frame.

getGlassPane() - Method in class javax.swing.JLayer

Returns the JLayer's glassPane component or null.

getGlassPane() - Method in class javax.swing.JRootPane

Returns the current glass pane for this JRootPane.

getGlassPane() - Method in class javax.swing.JWindow

Returns the glassPane Component for this window.

getGlassPane() - Method in interface javax.swing.RootPaneContainer

Returns the glassPane.

getGlobal() - Static method in class java.util.logging.Logger

Return global logger object with the name Logger.GLOBAL_LOGGER_NAME.

getGlobalActiveWindow() - Method in class java.awt.KeyboardFocusManager

Returns the active Window, even if the calling thread is in a different context than the active Window.

getGlobalCurrentFocusCycleRoot() - Method in class java.awt.KeyboardFocusManager

Returns the current focus cycle root, even if the calling thread is in a different context than the current focus cycle root.

getGlobalFocusedWindow() - Method in class java.awt.KeyboardFocusManager

Returns the focused Window, even if the calling thread is in a different context than the focused Window.

getGlobalFocusOwner() - Method in class java.awt.KeyboardFocusManager

Returns the focus owner, even if the calling thread is in a different context than the focus owner.

getGlobalPermanentFocusOwner() - Method in class java.awt.KeyboardFocusManager

Returns the permanent focus owner, even if the calling thread is in a different context than the permanent focus owner.

getGlobalTransactionId() - Method in interface javax.transaction.xa.Xid

Obtain the global transaction identifier part of XID as an array of bytes.

getGlyphCharIndex(int) - Method in class java.awt.font.GlyphVector

Returns the character index of the specified glyph.

getGlyphCharIndices(int, int, int[]) - Method in class java.awt.font.GlyphVector

Returns the character indices of the specified glyphs.

getGlyphCode(int) - Method in class java.awt.font.GlyphVector

Returns the glyphcode of the specified glyph.

getGlyphCodes(int, int, int[]) - Method in class java.awt.font.GlyphVector

Returns an array of glyphcodes for the specified glyphs.

getGlyphJustificationInfo(int) - Method in class java.awt.font.GlyphVector

Returns the justification information for the glyph at the specified index into this GlyphVector.

getGlyphLogicalBounds(int) - Method in class java.awt.font.GlyphVector

Returns the logical bounds of the specified glyph within this GlyphVector.

getGlyphMetrics(int) - Method in class java.awt.font.GlyphVector

Returns the metrics of the glyph at the specified index into this GlyphVector.

getGlyphOutline(int) - Method in class java.awt.font.GlyphVector

Returns a Shape whose interior corresponds to the visual representation of the specified glyph within this GlyphVector.

getGlyphOutline(int, float, float) - Method in class java.awt.font.GlyphVector

Returns a Shape whose interior corresponds to the visual representation of the specified glyph within this GlyphVector, offset to x, y.

getGlyphPainter() - Method in class javax.swing.text.GlyphView

Fetch the currently installed glyph painter.

getGlyphPixelBounds(int, FontRenderContext, float, float) - Method in class java.awt.font.GlyphVector

Returns the pixel bounds of the glyph at index when this GlyphVector is rendered in a Graphics with the given FontRenderContext at the given location.

getGlyphPosition(int) - Method in class java.awt.font.GlyphVector

Returns the position of the specified glyph relative to the origin of this GlyphVector.

getGlyphPositions(int, int, float[]) - Method in class java.awt.font.GlyphVector

Returns an array of glyph positions for the specified glyphs.

getGlyphTransform(int) - Method in class java.awt.font.GlyphVector

Returns the transform of the specified glyph within this GlyphVector.

getGlyphVisualBounds(int) - Method in class java.awt.font.GlyphVector

Returns the visual bounds of the specified glyph within the GlyphVector.

getGoHomeAction() - Method in class javax.swing.plaf.basic.BasicFileChooserUI

getGranularityPeriod() - Method in class javax.management.monitor.Monitor

Gets the granularity period (in milliseconds).

getGranularityPeriod() - Method in interface javax.management.monitor.MonitorMBean

Gets the granularity period (in milliseconds).

getGraphics() - Method in class java.awt.Component

Creates a graphics context for this component.

getGraphics() - Method in class java.awt.image.BufferedImage

This method returns a Graphics2D, but is here for backwards compatibility.

getGraphics() - Method in class java.awt.Image

Creates a graphics context for drawing to an off-screen image.

getGraphics() - Method in class java.awt.image.VolatileImage

This method returns a Graphics2D, but is here for backwards compatibility.

getGraphics() - Method in class java.awt.PrintJob

Gets a Graphics object that will draw to the next page.

getGraphics() - Method in class javax.swing.JApplet

Creates a graphics context for this component.

getGraphics() - Method in class javax.swing.JComponent

Returns this component's graphics context, which lets you draw on a component.

getGraphics() - Method in class javax.swing.JDialog

Creates a graphics context for this component.

getGraphics() - Method in class javax.swing.JFrame

Creates a graphics context for this component.

getGraphics() - Method in class javax.swing.JWindow

Creates a graphics context for this component.

getGraphics() - Method in class javax.swing.text.View

Fetch a Graphics for rendering.

getGraphicsConfiguration() - Method in class java.awt.Component

Gets the GraphicsConfiguration associated with this Component.

getGraphicsUtils(SynthContext) - Method in class javax.swing.plaf.synth.SynthStyle

Returns the SynthGraphicUtils for the specified context.

getGreatestMinimum(int) - Method in class java.util.Calendar

Returns the highest minimum value for the given calendar field of this Calendar instance.

getGreatestMinimum(int) - Method in class java.util.GregorianCalendar

Returns the highest minimum value for the given calendar field of this GregorianCalendar instance.

getGreen() - Method in class java.awt.Color

Returns the green component in the range 0-255 in the default sRGB space.

getGreen(int) - Method in class java.awt.image.ColorModel

Returns the green color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getGreen(Object) - Method in class java.awt.image.ColorModel

Returns the green color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getGreen(int) - Method in class java.awt.image.ComponentColorModel

Returns the green color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getGreen(Object) - Method in class java.awt.image.ComponentColorModel

Returns the green color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getGreen(int) - Method in class java.awt.image.DirectColorModel

Returns the green color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getGreen(Object) - Method in class java.awt.image.DirectColorModel

Returns the green color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getGreen(int) - Method in class java.awt.image.IndexColorModel

Returns the green color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getGreenMask() - Method in class java.awt.image.DirectColorModel

Returns the mask indicating which bits in an int pixel representation contain the green color component.

getGreens(byte[]) - Method in class java.awt.image.IndexColorModel

Copies the array of green color components into the specified array.

getGregorianChange() - Method in class java.util.GregorianCalendar

Gets the Gregorian Calendar change date.

getGridColor() - Method in class javax.swing.JTable

Returns the color used to draw grid lines.

getGridColumn() - Method in class javax.swing.text.TableView.TableCell

Deprecated.

Gets the column of the grid location

getGridRow() - Method in class javax.swing.text.TableView.TableCell

Deprecated.

Gets the row of the grid location

getGrooveInsets() - Static method in class javax.swing.plaf.basic.BasicGraphicsUtils

Returns the amount of space taken up by a border drawn by drawGroove()

getGroup() - Method in class javax.swing.DefaultButtonModel

Returns the group that the button belongs to.

getGroupID() - Method in class java.rmi.activation.ActivationDesc

Returns the group identifier for the object specified by this descriptor.

getGroupingSeparator() - Method in class java.text.DecimalFormatSymbols

Gets the character used for thousands separator.

getGroupingSize() - Method in class java.text.DecimalFormat

Return the grouping size.

getGuarantor() - Method in interface java.security.Certificate

Deprecated.

Returns the guarantor of the certificate, that is, the principal guaranteeing that the public key associated with this certificate is that of the principal associated with this certificate.

getHAdjustable() - Method in class java.awt.ScrollPane

Returns the ScrollPaneAdjustable object which represents the state of the horizontal scrollbar.

getHandler() - Method in class javax.xml.transform.sax.SAXResult

Get the ContentHandler that is the Result.

getHandlerChain() - Method in interface javax.xml.ws.Binding

Gets a copy of the handler chain for a protocol binding instance.

getHandlerChain(PortInfo) - Method in interface javax.xml.ws.handler.HandlerResolver

Gets the handler chain for the specified port.

getHandlerResolver() - Method in class javax.xml.ws.Service

Returns the configured handler resolver.

getHandlerResolver() - Method in class javax.xml.ws.spi.ServiceDelegate

Returns the configured handler resolver.

getHandlers() - Method in class java.util.logging.Logger

Get the Handlers associated with this logger.

getHandshakeSession() - Method in class javax.net.ssl.SSLEngine

Returns the SSLSession being constructed during a SSL/TLS handshake.

getHandshakeSession() - Method in class javax.net.ssl.SSLSocket

Returns the SSLSession being constructed during a SSL/TLS handshake.

getHandshakeStatus() - Method in class javax.net.ssl.SSLEngine

Returns the current handshake status for this SSLEngine.

getHandshakeStatus() - Method in class javax.net.ssl.SSLEngineResult

Gets the handshake status of this SSLEngine operation.

getHardwareAddress() - Method in class java.net.NetworkInterface

Returns the hardware address (usually MAC) of the interface if it has one and if it can be accessed given the current privileges.

getHashColor() - Method in class javax.swing.plaf.basic.BasicTreeUI

getHead(Handler) - Method in class java.util.logging.Formatter

Return the header string for a set of formatted records.

getHead(Handler) - Method in class java.util.logging.XMLFormatter

Return the header string for a set of XML formatted records.

getHeader(String) - Method in class javax.xml.soap.MimeHeaders

Returns all of the values for the specified header as an array of String objects.

getHeader() - Method in interface javax.xml.soap.SOAPEnvelope

Returns the SOAPHeader object for this SOAPEnvelope object.

getHeaderField(int) - Method in class java.net.HttpURLConnection

Returns the value for the nth header field.

getHeaderField(String) - Method in class java.net.URLConnection

Returns the value of the named header field.

getHeaderField(int) - Method in class java.net.URLConnection

Returns the value for the nth header field.

getHeaderFieldDate(String, long) - Method in class java.net.HttpURLConnection

getHeaderFieldDate(String, long) - Method in class java.net.URLConnection

Returns the value of the named field parsed as date.

getHeaderFieldInt(String, int) - Method in class java.net.URLConnection

Returns the value of the named field parsed as a number.

getHeaderFieldKey(int) - Method in class java.net.HttpURLConnection

Returns the key for the nth header field.

getHeaderFieldKey(int) - Method in class java.net.URLConnection

Returns the key for the nth header field.

getHeaderFieldLong(String, long) - Method in class java.net.URLConnection

Returns the value of the named field parsed as a number.

getHeaderFields() - Method in class java.net.URLConnection

Returns an unmodifiable Map of the header fields.

getHeaderRect(int) - Method in class javax.swing.table.JTableHeader

Returns the rectangle containing the header tile at column.

getHeaderRenderer() - Method in class javax.swing.table.TableColumn

Returns the TableCellRenderer used to draw the header of the TableColumn.

getHeaders() - Method in class java.net.CacheResponse

Returns the response headers as a Map.

getHeaders() - Method in interface javax.xml.ws.handler.soap.SOAPHandler

Gets the header blocks that can be processed by this Handler instance.

getHeaders(QName, JAXBContext, boolean) - Method in interface javax.xml.ws.handler.soap.SOAPMessageContext

Gets headers that have a particular qualified name from the message in the message context.

getHeaderValue() - Method in class javax.swing.table.TableColumn

Returns the Object used as the value for the header renderer.

getHeapMemoryUsage() - Method in interface java.lang.management.MemoryMXBean

Returns the current memory usage of the heap that is used for object allocation.

getHeight() - Method in class java.awt.Component

Returns the current height of this component.

getHeight() - Method in class java.awt.Dimension

Returns the height of this Dimension in double precision.

getHeight() - Method in class java.awt.DisplayMode

Returns the height of the display, in pixels.

getHeight() - Method in class java.awt.font.LineMetrics

Returns the height of the text.

getHeight() - Method in class java.awt.FontMetrics

Gets the standard height of a line of text in this font.

getHeight() - Method in class java.awt.geom.Arc2D.Double

Returns the height of the framing rectangle in double precision.

getHeight() - Method in class java.awt.geom.Arc2D.Float

Returns the height of the framing rectangle in double precision.

getHeight() - Method in class java.awt.geom.Dimension2D

Returns the height of this Dimension in double precision.

getHeight() - Method in class java.awt.geom.Ellipse2D.Double

Returns the height of the framing rectangle in double precision.

getHeight() - Method in class java.awt.geom.Ellipse2D.Float

Returns the height of the framing rectangle in double precision.

getHeight() - Method in class java.awt.geom.Rectangle2D.Double

Returns the height of the framing rectangle in double precision.

getHeight() - Method in class java.awt.geom.Rectangle2D.Float

Returns the height of the framing rectangle in double precision.

getHeight() - Method in class java.awt.geom.RectangularShape

Returns the height of the framing rectangle in double precision.

getHeight() - Method in class java.awt.geom.RoundRectangle2D.Double

Returns the height of the framing rectangle in double precision.

getHeight() - Method in class java.awt.geom.RoundRectangle2D.Float

Returns the height of the framing rectangle in double precision.

getHeight() - Method in class java.awt.image.BufferedImage

Returns the height of the BufferedImage.

getHeight(ImageObserver) - Method in class java.awt.image.BufferedImage

Returns the height of the BufferedImage.

getHeight(ImageObserver) - Method in class java.awt.Image

Determines the height of the image.

getHeight() - Method in class java.awt.image.Kernel

Returns the height of this Kernel.

getHeight() - Method in class java.awt.image.PixelGrabber

Get the height of the pixel buffer (after adjusting for image height).

getHeight() - Method in class java.awt.image.Raster

Returns the height in pixels of the Raster.

getHeight() - Method in interface java.awt.image.renderable.RenderableImage

Gets the height in user coordinate space.

getHeight() - Method in class java.awt.image.renderable.RenderableImageOp

Gets the height in user coordinate space.

getHeight() - Method in interface java.awt.image.RenderedImage

Returns the height of the RenderedImage.

getHeight() - Method in class java.awt.image.SampleModel

Returns the height in pixels.

getHeight() - Method in class java.awt.image.VolatileImage

Returns the height of the VolatileImage.

getHeight() - Method in class java.awt.print.PageFormat

Returns the height, in 1/72nds of an inch, of the page.

getHeight() - Method in class java.awt.print.Paper

Returns the height of the page in 1/72nds of an inch.

getHeight() - Method in class java.awt.Rectangle

Returns the height of the bounding Rectangle in double precision.

getHeight(int) - Method in class javax.imageio.ImageReader

Returns the height in pixels of the given image within the input source.

getHeight(int) - Method in class javax.print.attribute.standard.MediaPrintableArea

Get the height of the printable area in the specified units.

getHeight() - Method in class javax.swing.JComponent

Returns the current height of this component.

getHeight() - Method in class javax.swing.SpringLayout.Constraints

Returns the value of the height property.

getHeight() - Method in class javax.swing.text.BoxView

Returns the current height of the box.

getHeight(GlyphView) - Method in class javax.swing.text.GlyphView.GlyphPainter

getHeightOfHighValueLabel() - Method in class javax.swing.plaf.basic.BasicSliderUI

getHeightOfLowValueLabel() - Method in class javax.swing.plaf.basic.BasicSliderUI

getHeightOfTallestLabel() - Method in class javax.swing.plaf.basic.BasicSliderUI

getHelpMenu() - Method in class java.awt.MenuBar

Gets the help menu on the menu bar.

getHelpMenu() - Method in class javax.swing.JMenuBar

Gets the help menu for the menu bar.

getHere() - Method in interface javax.xml.crypto.dom.DOMURIReference

Returns the here node.

getHgap() - Method in class java.awt.BorderLayout

Returns the horizontal gap between components.

getHgap() - Method in class java.awt.CardLayout

Gets the horizontal gap between components.

getHgap() - Method in class java.awt.FlowLayout

Gets the horizontal gap between components and between the components and the borders of the Container

getHgap() - Method in class java.awt.GridLayout

Gets the horizontal gap between components.

getHideActionText() - Method in class javax.swing.AbstractButton

Returns the value of the hideActionText property, which determines whether the button displays text from the Action.

getHierarchyBoundsListeners() - Method in class java.awt.Component

Returns an array of all the hierarchy bounds listeners registered on this component.

getHierarchyListeners() - Method in class java.awt.Component

Returns an array of all the hierarchy listeners registered on this component.

getHighestValue() - Method in class javax.swing.plaf.basic.BasicSliderUI

Returns the biggest value that has an entry in the label table.

getHighestValueLabel() - Method in class javax.swing.plaf.basic.BasicSliderUI

Returns the label that corresponds to the lowest slider value in the label table.

getHighlightColor(Component) - Method in class javax.swing.border.EtchedBorder

Returns the highlight color of the etched border when rendered on the specified component.

getHighlightColor() - Method in class javax.swing.border.EtchedBorder

Returns the highlight color of the etched border.

getHighlightColor() - Method in class javax.swing.plaf.basic.BasicSliderUI

getHighlightedTextColor() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the highlighted text color of the current theme.

getHighlightedTextColor() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the highlighted text color.

getHighlighter() - Method in class javax.swing.text.JTextComponent

Fetches the object responsible for making highlights.

getHighlightInnerColor(Component) - Method in class javax.swing.border.BevelBorder

Returns the inner highlight color of the bevel border when rendered on the specified component.

getHighlightInnerColor() - Method in class javax.swing.border.BevelBorder

Returns the inner highlight color of the bevel border.

getHighlightOuterColor(Component) - Method in class javax.swing.border.BevelBorder

Returns the outer highlight color of the bevel border when rendered on the specified component.

getHighlightOuterColor() - Method in class javax.swing.border.BevelBorder

Returns the outer highlight color of the bevel border.

getHighlights() - Method in class javax.swing.text.DefaultHighlighter

Makes a copy of the highlights.

getHighlights() - Method in interface javax.swing.text.Highlighter

Fetches the current list of highlights.

getHighThreshold() - Method in class javax.management.monitor.GaugeMonitor

Gets the high threshold value common to all observed MBeans.

getHighThreshold() - Method in interface javax.management.monitor.GaugeMonitorMBean

Gets the high threshold value.

getHoldability() - Method in interface java.sql.Connection

Retrieves the current holdability of ResultSet objects created using this Connection object.

getHoldability() - Method in interface java.sql.ResultSet

Retrieves the holdability of this ResultSet object

getHoldCount() - Method in class java.util.concurrent.locks.ReentrantLock

Queries the number of holds on this lock by the current thread.

getHoldCount() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock

Queries the number of holds on this write lock by the current thread.

getHomeDirectory() - Method in class javax.swing.filechooser.FileSystemView

getHonorsVisibility() - Method in class javax.swing.GroupLayout

Returns whether component visibility is considered when sizing and positioning components.

getHorizontalAlignment() - Method in class javax.swing.AbstractButton

Returns the horizontal alignment of the icon and text.

getHorizontalAlignment() - Method in class javax.swing.JLabel

Returns the alignment of the label's contents along the X axis.

getHorizontalAlignment() - Method in class javax.swing.JTextField

Returns the horizontal alignment of the text.

getHorizontalLegBuffer() - Method in class javax.swing.plaf.basic.BasicTreeUI

The horizontal element of legs between nodes starts at the right of the left-hand side of the child node by default.

getHorizontalLegBuffer() - Method in class javax.swing.plaf.metal.MetalTreeUI

getHorizontalScrollBar() - Method in class javax.swing.JScrollPane

Returns the horizontal scroll bar that controls the viewport's horizontal view position.

getHorizontalScrollBar() - Method in class javax.swing.ScrollPaneLayout

Returns the JScrollBar object that handles horizontal scrolling.

getHorizontalScrollBarPolicy() - Method in class javax.swing.JScrollPane

Returns the horizontal scroll bar policy value.

getHorizontalScrollBarPolicy() - Method in class javax.swing.ScrollPaneLayout

Returns the horizontal scrollbar-display policy.

getHorizontalSliderThumbIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

getHorizontalTextPosition() - Method in class javax.swing.AbstractButton

Returns the horizontal position of the text relative to the icon.

getHorizontalTextPosition() - Method in class javax.swing.JLabel

Returns the horizontal position of the label's text, relative to its image.

getHorizontalVisibility() - Method in class javax.swing.JTextField

Gets the visibility of the text field.

getHost() - Method in class java.net.URI

Returns the host component of this URI.

getHost() - Method in class java.net.URL

Gets the host name of this URL, if applicable.

getHost() - Method in class javax.management.remote.JMXServiceURL

The host part of the Service URL.

getHostAddress() - Method in class java.net.Inet4Address

Returns the IP address string in textual presentation form.

getHostAddress() - Method in class java.net.Inet6Address

Returns the IP address string in textual presentation.

getHostAddress() - Method in class java.net.InetAddress

Returns the IP address string in textual presentation.

getHostAddress(URL) - Method in class java.net.URLStreamHandler

Get the IP address of our host.

getHostName() - Method in class java.net.InetAddress

Gets the host name for this IP address.

getHostName() - Method in class java.net.InetSocketAddress

Gets the hostname.

getHostnameVerifier() - Method in class javax.net.ssl.HttpsURLConnection

Gets the HostnameVerifier in place on this instance.

getHostString() - Method in class java.net.InetSocketAddress

Returns the hostname, or the String form of the address if it doesn't have a hostname (it was created using a literal).

getHour() - Method in class java.time.LocalDateTime

Gets the hour-of-day field.

getHour() - Method in class java.time.LocalTime

Gets the hour-of-day field.

getHour() - Method in class java.time.OffsetDateTime

Gets the hour-of-day field.

getHour() - Method in class java.time.OffsetTime

Gets the hour-of-day field.

getHour() - Method in class java.time.ZonedDateTime

Gets the hour-of-day field.

getHour() - Method in class javax.xml.datatype.XMLGregorianCalendar

Return hours or DatatypeConstants.FIELD_UNDEFINED.

getHours() - Method in class java.sql.Date

Deprecated.

getHours() - Method in class java.util.Date

Deprecated.
As of JDK version 1.1, replaced by Calendar.get(Calendar.HOUR_OF_DAY).

getHours() - Method in class javax.xml.datatype.Duration

Obtains the value of the HOURS field as an integer value, or 0 if not present.

getHSBColor(float, float, float) - Static method in class java.awt.Color

Creates a Color object based on the specified values for the HSB color model.

getHScrollbarHeight() - Method in class java.awt.ScrollPane

Returns the height that would be occupied by a horizontal scrollbar, which is independent of whether it is currently displayed by the scroll pane or not.

getHTMLBaseline(View, int, int) - Static method in class javax.swing.plaf.basic.BasicHTML

Returns the baseline for the html renderer.

getHTMLDocument(JEditorPane) - Method in class javax.swing.text.html.HTMLEditorKit.HTMLTextAction

getHTMLEditorKit(JEditorPane) - Method in class javax.swing.text.html.HTMLEditorKit.HTMLTextAction

getHTMLTag() - Method in class javax.swing.text.html.parser.TagElement

getHttpContext() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns a HttpContext for this exchange.

getHumanPresentableName() - Method in class java.awt.datatransfer.DataFlavor

Returns the human presentable name for the data format that this DataFlavor represents.

getHumanPresentableName() - Method in class javax.activation.ActivationDataFlavor

Return the Human Presentable name.

getHyperlinkListeners() - Method in class javax.swing.JEditorPane

Returns an array of all the HyperLinkListeners added to this JEditorPane with addHyperlinkListener().

getICC_Profiles() - Method in class java.awt.image.ColorConvertOp

Returns the array of ICC_Profiles used to construct this ColorConvertOp.

getIcon(int) - Method in interface java.beans.BeanInfo

Returns an image that can be used to represent the bean in toolboxes or toolbars.

getIcon(int) - Method in class java.beans.SimpleBeanInfo

Claim there are no icons available.

getIcon() - Method in class javax.swing.AbstractButton

Returns the default icon.

getIcon(File) - Method in class javax.swing.filechooser.FileView

The icon that represents this file in the JFileChooser.

getIcon(File) - Method in class javax.swing.JFileChooser

Returns the icon for this file or type of file, depending on the system.

getIcon() - Method in class javax.swing.JLabel

Returns the graphic image (glyph, icon) that the label displays.

getIcon() - Method in class javax.swing.JOptionPane

Returns the icon this pane displays.

getIcon(File) - Method in class javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView

getIcon() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI

Returns the icon from the JOptionPane the receiver is providing the look and feel for, or the default icon as returned from getDefaultIcon.

getIcon(AbstractButton) - Method in class javax.swing.plaf.synth.SynthButtonUI

Returns the Icon to use for painting the button.

getIcon(SynthContext, Object) - Method in class javax.swing.plaf.synth.SynthStyle

Convenience method to get a specific style property whose value is an Icon.

getIcon(AttributeSet) - Static method in class javax.swing.text.StyleConstants

Gets the icon setting from the attribute list.

getIcon(Object) - Method in class javax.swing.UIDefaults

If the value of key is an Icon return it, otherwise return null.

getIcon(Object, Locale) - Method in class javax.swing.UIDefaults

If the value of key for the given Locale is an Icon return it, otherwise return null.

getIcon(Object) - Static method in class javax.swing.UIManager

Returns an Icon from the defaults.

getIcon(Object, Locale) - Static method in class javax.swing.UIManager

Returns an Icon from the defaults that is appropriate for the given locale.

getIconAt(int) - Method in class javax.swing.JTabbedPane

Returns the tab icon at index.

getIconForTab(int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getIconForType(int) - Method in class javax.swing.plaf.basic.BasicOptionPaneUI

Returns the icon to use for the passed in type.

getIconHeight() - Method in interface javax.swing.Icon

Returns the icon's height.

getIconHeight() - Method in class javax.swing.ImageIcon

Gets the height of the icon.

getIconHeight() - Method in class javax.swing.plaf.IconUIResource

getIconHeight() - Method in class javax.swing.plaf.metal.MetalCheckBoxIcon

getIconHeight() - Method in class javax.swing.plaf.metal.MetalComboBoxIcon

Created a stub to satisfy the interface.

getIconHeight() - Method in class javax.swing.plaf.metal.MetalIconFactory.FileIcon16

getIconHeight() - Method in class javax.swing.plaf.metal.MetalIconFactory.FolderIcon16

getIconHeight() - Method in class javax.swing.plaf.metal.MetalIconFactory.PaletteCloseIcon

getIconHeight() - Method in class javax.swing.plaf.metal.MetalIconFactory.TreeControlIcon

getIconImage() - Method in class java.awt.Frame

Returns the image to be displayed as the icon for this frame.

getIconImages() - Method in class java.awt.Window

Returns the sequence of images to be displayed as the icon for this window.

getIconTextGap() - Method in class javax.swing.AbstractButton

Returns the amount of space between the text and the icon displayed in this button.

getIconTextGap() - Method in class javax.swing.JLabel

Returns the amount of space between the text and the icon displayed in this label.

getIconWidth() - Method in interface javax.swing.Icon

Returns the icon's width.

getIconWidth() - Method in class javax.swing.ImageIcon

Gets the width of the icon.

getIconWidth() - Method in class javax.swing.plaf.IconUIResource

getIconWidth() - Method in class javax.swing.plaf.metal.MetalCheckBoxIcon

getIconWidth() - Method in class javax.swing.plaf.metal.MetalComboBoxIcon

Created a stub to satisfy the interface.

getIconWidth() - Method in class javax.swing.plaf.metal.MetalIconFactory.FileIcon16

getIconWidth() - Method in class javax.swing.plaf.metal.MetalIconFactory.FolderIcon16

getIconWidth() - Method in class javax.swing.plaf.metal.MetalIconFactory.PaletteCloseIcon

getIconWidth() - Method in class javax.swing.plaf.metal.MetalIconFactory.TreeControlIcon

getID() - Method in class java.awt.AWTEvent

Returns the event type.

getId() - Method in class java.lang.Thread

Returns the identifier of this Thread.

getID() - Method in class java.rmi.activation.Activatable

Returns the object's activation identifier.

getId() - Method in interface java.security.cert.Extension

Gets the extensions's object identifier.

getId() - Method in interface java.time.chrono.Chronology

Gets the ID of the chronology.

getId() - Method in class java.time.chrono.HijrahChronology

Gets the ID of the chronology.

getId() - Method in class java.time.chrono.IsoChronology

Gets the ID of the chronology - 'ISO'.

getId() - Method in class java.time.chrono.JapaneseChronology

Gets the ID of the chronology - 'Japanese'.

getId() - Method in class java.time.chrono.MinguoChronology

Gets the ID of the chronology - 'Minguo'.

getId() - Method in class java.time.chrono.ThaiBuddhistChronology

Gets the ID of the chronology - 'ThaiBuddhist'.

getId() - Method in class java.time.ZoneId

Gets the unique time-zone ID.

getId() - Method in class java.time.ZoneOffset

Gets the normalized zone offset ID.

getID() - Method in class java.util.TimeZone

Gets the ID of this time zone.

getID() - Method in interface javax.naming.directory.Attribute

Retrieves the id of this attribute.

getID() - Method in class javax.naming.directory.BasicAttribute

getID() - Method in class javax.naming.ldap.BasicControl

Retrieves the control's object identifier string.

getID() - Method in interface javax.naming.ldap.Control

Retrieves the object identifier assigned for the LDAP control.

getID() - Method in interface javax.naming.ldap.ExtendedRequest

Retrieves the object identifier of the request.

getID() - Method in interface javax.naming.ldap.ExtendedResponse

Retrieves the object identifier of the response.

getID() - Method in class javax.naming.ldap.StartTlsRequest

Retrieves the StartTLS request's object identifier string.

getID() - Method in class javax.naming.ldap.StartTlsResponse

Retrieves the StartTLS response's object identifier string.

getId() - Method in interface javax.net.ssl.SSLSession

Returns the identifier assigned to this Session.

getID() - Method in class javax.swing.LookAndFeel

Return a string that identifies this look and feel.

getID() - Method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns an identifier for this look and feel.

getID() - Method in class javax.swing.plaf.multi.MultiLookAndFeel

Returns a string, suitable for use by applications/services, that identifies this look and feel.

getID() - Method in class javax.swing.plaf.nimbus.NimbusLookAndFeel

Return a string that identifies this look and feel.

getID() - Method in class javax.swing.plaf.synth.ColorType

Returns a unique id, as an integer, for this ColorType.

getID() - Method in class javax.swing.plaf.synth.SynthLookAndFeel

Return a string that identifies this look and feel.

getId() - Method in interface javax.xml.crypto.dsig.keyinfo.KeyInfo

Return the optional Id attribute of this KeyInfo, which may be useful for referencing this KeyInfo from other XML structures.

getId() - Method in interface javax.xml.crypto.dsig.Manifest

Returns the Id of this Manifest.

getId() - Method in interface javax.xml.crypto.dsig.Reference

Returns the optional Id attribute of this Reference, which permits this reference to be referenced from elsewhere.

getId() - Method in interface javax.xml.crypto.dsig.SignatureProperties

Returns the Id of this SignatureProperties.

getId() - Method in interface javax.xml.crypto.dsig.SignatureProperty

Returns the Id of this SignatureProperty.

getId() - Method in interface javax.xml.crypto.dsig.SignedInfo

Returns the optional Id attribute of this SignedInfo.

getId() - Method in interface javax.xml.crypto.dsig.XMLObject

Returns the Id of this XMLObject.

getId() - Method in interface javax.xml.crypto.dsig.XMLSignature

Returns the optional Id of this XMLSignature.

getId() - Method in interface javax.xml.crypto.dsig.XMLSignature.SignatureValue

Returns the optional Id attribute of this SignatureValue, which permits this element to be referenced from elsewhere.

getId() - Method in class javax.xml.datatype.DatatypeConstants.Field

Get id of this Field.

getID() - Method in class javax.xml.ws.RespectBindingFeature

Get the unique identifier for this WebServiceFeature.

getID() - Method in class javax.xml.ws.soap.AddressingFeature

Get the unique identifier for this WebServiceFeature.

getID() - Method in class javax.xml.ws.soap.MTOMFeature

Get the unique identifier for this WebServiceFeature.

getID() - Method in class javax.xml.ws.WebServiceFeature

Get the unique identifier for this WebServiceFeature.

getId() - Method in exception org.omg.CORBA.portable.ApplicationException

Returns the CORBA repository ID of the exception without removing it from the exceptions input stream.

getIdentifier(int) - Method in class javax.swing.DefaultRowSorter.ModelWrapper

Returns the identifier for the specified row.

getIdentifier() - Method in class javax.swing.RowFilter.Entry

Returns the identifer (in the model) of the entry.

getIdentifier() - Method in class javax.swing.table.TableColumn

Returns the identifier object for this column.

getIdentifierQuoteString() - Method in interface java.sql.DatabaseMetaData

Retrieves the string used to quote SQL identifiers.

getIdentity(String) - Method in class java.security.IdentityScope

Deprecated.

Returns the identity in this scope with the specified name (if any).

getIdentity(Principal) - Method in class java.security.IdentityScope

Deprecated.

Retrieves the identity whose name is the same as that of the specified principal.

getIdentity(PublicKey) - Method in class java.security.IdentityScope

Deprecated.

Retrieves the identity with the specified public key.

getIdentityHashCode() - Method in class java.lang.management.LockInfo

Returns the identity hash code of the lock object returned from the System.identityHashCode(java.lang.Object) method.

getIDs() - Method in interface javax.naming.directory.Attributes

Retrieves an enumeration of the ids of the attributes in the attribute set.

getIDs() - Method in class javax.naming.directory.BasicAttributes

getIds() - Method in interface javax.net.ssl.SSLSessionContext

Returns an Enumeration of all session id's grouped under this SSLSessionContext.

getIDstring() - Method in class java.awt.GraphicsDevice

Returns the identification string associated with this GraphicsDevice.

getIfModifiedSince() - Method in class java.net.URLConnection

Returns the value of this object's ifModifiedSince field.

getIgnoreRepaint() - Method in class java.awt.Component

getImage(URL) - Method in class java.applet.Applet

Returns an Image object that can then be painted on the screen.

getImage(URL, String) - Method in class java.applet.Applet

Returns an Image object that can then be painted on the screen.

getImage(URL) - Method in interface java.applet.AppletContext

Returns an Image object that can then be painted on the screen.

getImage() - Method in class java.awt.TexturePaint

Returns the BufferedImage texture used to fill the shapes.

getImage(String) - Method in class java.awt.Toolkit

Returns an image which gets pixel data from the specified file, whose format can be either GIF, JPEG or PNG.

getImage(URL) - Method in class java.awt.Toolkit

Returns an image which gets pixel data from the specified URL.

getImage() - Method in class java.awt.TrayIcon

Returns the current image used for this TrayIcon.

getImage() - Method in class javax.swing.ImageIcon

Returns this icon's Image.

getImage() - Method in class javax.swing.text.html.ImageView

Returns the image to render.

getImageableHeight() - Method in class java.awt.print.PageFormat

Return the height, in 1/72nds of an inch, of the imageable area of the page.

getImageableHeight() - Method in class java.awt.print.Paper

Returns the height of this Paper object's imageable area.

getImageableWidth() - Method in class java.awt.print.PageFormat

Returns the width, in 1/72nds of an inch, of the imageable area of the page.

getImageableWidth() - Method in class java.awt.print.Paper

Returns the width of this Paper object's imageable area.

getImageableX() - Method in class java.awt.print.PageFormat

Returns the x coordinate of the upper left point of the imageable area of the Paper object associated with this PageFormat.

getImageableX() - Method in class java.awt.print.Paper

Returns the x coordinate of the upper-left corner of this Paper object's imageable area.

getImageableY() - Method in class java.awt.print.PageFormat

Returns the y coordinate of the upper left point of the imageable area of the Paper object associated with this PageFormat.

getImageableY() - Method in class java.awt.print.Paper

Returns the y coordinate of the upper-left corner of this Paper object's imageable area.

getImageCapabilities() - Method in class java.awt.GraphicsConfiguration

Returns the image capabilities of this GraphicsConfiguration.

getImageLoadStatus() - Method in class javax.swing.ImageIcon

Returns the status of the image loading operation.

getImageMetadata(int) - Method in class javax.imageio.ImageReader

Returns an IIOMetadata object containing metadata associated with the given image, or null if the reader does not support reading metadata, is set to ignore metadata, or if no metadata is available.

getImageMetadata(int, String, Set<String>) - Method in class javax.imageio.ImageReader

Returns an IIOMetadata object representing the metadata associated with the given image, or null if the reader does not support reading metadata or none is available.

getImageMetadataFormat(String) - Method in class javax.imageio.spi.ImageReaderWriterSpi

Returns an IIOMetadataFormat object describing the given image metadata format, or null if no description is available.

getImageObserver() - Method in class javax.swing.ImageIcon

Returns the image observer for the image.

getImageReader(ImageWriter) - Static method in class javax.imageio.ImageIO

Returns an ImageReadercorresponding to the given ImageWriter, if there is one, or null if the plug-in for this ImageWriter does not specify a corresponding ImageReader, or if the given ImageWriter is not registered.

getImageReaders(Object) - Static method in class javax.imageio.ImageIO

Returns an Iterator containing all currently registered ImageReaders that claim to be able to decode the supplied Object, typically an ImageInputStream.

getImageReadersByFormatName(String) - Static method in class javax.imageio.ImageIO

Returns an Iterator containing all currently registered ImageReaders that claim to be able to decode the named format.

getImageReadersByMIMEType(String) - Static method in class javax.imageio.ImageIO

Returns an Iterator containing all currently registered ImageReaders that claim to be able to decode files with the given MIME type.

getImageReadersBySuffix(String) - Static method in class javax.imageio.ImageIO

Returns an Iterator containing all currently registered ImageReaders that claim to be able to decode files with the given suffix.

getImageReaderSpiNames() - Method in class javax.imageio.spi.ImageWriterSpi

Returns an array of Strings containing all the fully qualified names of all the ImageReaderSpi classes that can understand the internal metadata representation used by the ImageWriter associated with this service provider, or null if there are no such ImageReaders specified.

getImageTranscoders(ImageReader, ImageWriter) - Static method in class javax.imageio.ImageIO

Returns an Iterator containing all currently registered ImageTranscoders that claim to be able to transcode between the metadata of the given ImageReader and ImageWriter.

getImageTypes(int) - Method in class javax.imageio.ImageReader

Returns an Iterator containing possible image types to which the given image may be decoded, in the form of ImageTypeSpecifierss.

getImageURL() - Method in class java.awt.SplashScreen

Returns the current splash screen image.

getImageURL() - Method in class javax.swing.text.html.ImageView

Return a URL for the image source, or null if it could not be determined.

getImageWriter(ImageReader) - Static method in class javax.imageio.ImageIO

Returns an ImageWritercorresponding to the given ImageReader, if there is one, or null if the plug-in for this ImageReader does not specify a corresponding ImageWriter, or if the given ImageReader is not registered.

getImageWriters(ImageTypeSpecifier, String) - Static method in class javax.imageio.ImageIO

Returns an Iterator containing all currently registered ImageWriters that claim to be able to encode images of the given layout (specified using an ImageTypeSpecifier) in the given format.

getImageWritersByFormatName(String) - Static method in class javax.imageio.ImageIO

Returns an Iterator containing all currently registered ImageWriters that claim to be able to encode the named format.

getImageWritersByMIMEType(String) - Static method in class javax.imageio.ImageIO

Returns an Iterator containing all currently registered ImageWriters that claim to be able to encode files with the given MIME type.

getImageWritersBySuffix(String) - Static method in class javax.imageio.ImageIO

Returns an Iterator containing all currently registered ImageWriters that claim to be able to encode files with the given suffix.

getImageWriterSpiNames() - Method in class javax.imageio.spi.ImageReaderSpi

Returns an array of Strings containing the fully qualified names of all the ImageWriterSpi classes that can understand the internal metadata representation used by the ImageReader associated with this service provider, or null if there are no such ImageWriters specified.

getImpact() - Method in class javax.management.MBeanOperationInfo

Returns the impact of the method, one of INFO, ACTION, ACTION_INFO, UNKNOWN.

getImpact() - Method in interface javax.management.openmbean.OpenMBeanOperationInfo

Returns an int constant qualifying the impact of the operation described by this OpenMBeanOperationInfo instance.

getImpact(MBeanOperationInfo) - Method in class javax.management.StandardMBean

Customization hook: Get the impact flag of the operation that will be used in the MBeanOperationInfo returned by this MBean.

getImplClass() - Method in class java.lang.invoke.SerializedLambda

Get the name of the class containing the implementation method.

getImplementation() - Method in class javax.management.StandardMBean

Get the implementation of this Standard MBean (or MXBean).

getImplementation() - Method in interface org.w3c.dom.Document

The DOMImplementation object that handles this document.

getImplementationClass() - Method in class javax.management.StandardMBean

Get the class of the implementation of this Standard MBean (or MXBean).

getImplementationName() - Method in class javax.management.MBeanServerDelegate

Returns the JMX implementation name (the name of this product).

getImplementationName() - Method in interface javax.management.MBeanServerDelegateMBean

Returns the JMX implementation name (the name of this product).

getImplementationTitle() - Method in class java.lang.Package

Return the title of this package.

getImplementationVendor() - Method in class java.lang.Package

Returns the name of the organization, vendor or company that provided this implementation.

getImplementationVendor() - Method in class javax.management.MBeanServerDelegate

Returns the JMX implementation vendor (the vendor of this product).

getImplementationVendor() - Method in interface javax.management.MBeanServerDelegateMBean

Returns the JMX implementation vendor (the vendor of this product).

getImplementationVersion() - Method in class java.lang.Package

Return the version of this implementation.

getImplementationVersion() - Method in class javax.management.MBeanServerDelegate

Returns the JMX implementation version (the version of this product).

getImplementationVersion() - Method in interface javax.management.MBeanServerDelegateMBean

Returns the JMX implementation version (the version of this product).

getImplementor() - Method in class javax.xml.ws.Endpoint

Returns the implementation object for this endpoint.

getImplicitDownCycleTraversal() - Method in class java.awt.ContainerOrderFocusTraversalPolicy

Returns whether this ContainerOrderFocusTraversalPolicy transfers focus down-cycle implicitly.

getImplicitDownCycleTraversal() - Method in class javax.swing.SortingFocusTraversalPolicy

Returns whether this SortingFocusTraversalPolicy transfers focus down- cycle implicitly.

getImplMethodKind() - Method in class java.lang.invoke.SerializedLambda

Get the method handle kind (see MethodHandleInfo) of the implementation method.

getImplMethodName() - Method in class java.lang.invoke.SerializedLambda

Get the name of the implementation method.

getImplMethodSignature() - Method in class java.lang.invoke.SerializedLambda

Get the signature of the implementation method.

getImportedKeys(String, String, String) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of the primary key columns that are referenced by the given table's foreign key columns (the primary keys imported by a table).

getInactiveControlTextColor() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the inactive control text color of the current theme.

getInactiveControlTextColor() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the inactive control text color.

getInactiveControlTextColor() - Method in class javax.swing.plaf.metal.OceanTheme

Returns the inactive control text color.

getInactiveSystemTextColor() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the inactive system text color of the current theme.

getInactiveSystemTextColor() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the inactive system text color.

getInCheck() - Method in class java.lang.SecurityManager

Deprecated.
This type of security checking is not recommended. It is recommended that the checkPermission call be used instead.

getIndentLevel() - Method in class javax.swing.text.AbstractWriter

Returns the current indentation level.

getIndentSpace() - Method in class javax.swing.text.AbstractWriter

Returns the amount of space to indent.

getIndex() - Method in class java.beans.IndexedPropertyChangeEvent

Gets the index of the property that was changed.

getIndex() - Method in class java.net.NetworkInterface

Returns the index of this network interface.

getIndex() - Method in exception java.net.URISyntaxException

Returns an index into the input string of the position at which the parse error occurred, or -1 if this position is not known.

getIndex() - Method in exception java.nio.file.InvalidPathException

Returns an index into the input string of the position at which the error occurred, or -1 if this position is not known.

getIndex() - Method in exception java.security.cert.CertPathValidatorException

Returns the index of the certificate in the certification path that caused the exception to be thrown.

getIndex() - Method in exception java.sql.DataTruncation

Retrieves the index of the column or parameter that was truncated.

getIndex() - Method in interface java.text.CharacterIterator

Returns the current index.

getIndex() - Method in class java.text.ParsePosition

Retrieve the current parse position.

getIndex() - Method in class java.text.StringCharacterIterator

Implements CharacterIterator.getIndex() for String.

getIndex() - Method in exception java.util.regex.PatternSyntaxException

Retrieves the error index.

getIndex() - Method in interface javax.swing.event.DocumentEvent.ElementChange

Fetches the index within the element represented.

getIndex() - Method in class javax.swing.JList.DropLocation

Returns the index where dropped data should be placed in the list.

getIndex(int) - Method in class javax.swing.SizeSequence

Returns the index of the entry that corresponds to the specified position.

getIndex(TreeNode) - Method in class javax.swing.text.AbstractDocument.AbstractElement

Returns the index of node in the receivers children.

getIndex() - Method in class javax.swing.text.AbstractDocument.ElementEdit

Returns the index into the list of elements.

getIndex() - Method in class javax.swing.text.html.parser.Element

Get index.

getIndex() - Method in class javax.swing.text.JTextComponent.DropLocation

Returns the index where dropped data should be inserted into the associated component.

getIndex() - Method in class javax.swing.text.Segment

Returns the current index.

getIndex(TreeNode) - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns the index of the specified child in this node's child array.

getIndex(TreeNode) - Method in interface javax.swing.tree.TreeNode

Returns the index of node in the receivers children.

getIndex(String, String) - Method in interface org.xml.sax.Attributes

Look up the index of an attribute by Namespace name.

getIndex(String) - Method in interface org.xml.sax.Attributes

Look up the index of an attribute by XML qualified (prefixed) name.

getIndex(String, String) - Method in class org.xml.sax.helpers.AttributesImpl

Look up an attribute's index by Namespace name.

getIndex(String) - Method in class org.xml.sax.helpers.AttributesImpl

Look up an attribute's index by qualified (prefixed) name.

getIndex0() - Method in class javax.swing.event.ListDataEvent

Returns the lower index of the range.

getIndex1() - Method in class javax.swing.event.ListDataEvent

Returns the upper index of the range.

getIndexAtPoint(Point) - Method in class java.awt.TextComponent.AccessibleAWTTextComponent

Given a point in local coordinates, return the zero-based index of the character under that Point.

getIndexAtPoint(Point) - Method in interface javax.accessibility.AccessibleText

Given a point in local coordinates, return the zero-based index of the character under that Point.

getIndexAtPoint(Point) - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Given a point in local coordinates, return the zero-based index of the character under that Point.

getIndexAtPoint(Point) - Method in class javax.swing.JLabel.AccessibleJLabel

Given a point in local coordinates, return the zero-based index of the character under that Point.

getIndexAtPoint(Point) - Method in class javax.swing.JSpinner.AccessibleJSpinner

Given a point in local coordinates, return the zero-based index of the character under that Point.

getIndexAtPoint(Point) - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Given a point in local coordinates, return the zero-based index of the character under that Point.

getIndexAtPoint(Point) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Given a point in local coordinates, return the zero-based index of the character under that Point.

getIndexedPropertyType() - Method in class java.beans.IndexedPropertyDescriptor

Returns the Java type info for the indexed property.

getIndexedReadMethod() - Method in class java.beans.IndexedPropertyDescriptor

Gets the method that should be used to read an indexed property value.

getIndexedWriteMethod() - Method in class java.beans.IndexedPropertyDescriptor

Gets the method that should be used to write an indexed property value.

getIndexInfo(String, String, String, boolean, boolean) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of the given table's indices and statistics.

getIndexNames() - Method in class javax.management.openmbean.TabularType

Returns, in the same order as was given to this instance's constructor, an unmodifiable List of the names of the items the values of which are used to uniquely index each row element of tabular data values described by this TabularType instance.

getIndexOf(Object) - Method in class javax.swing.DefaultComboBoxModel

Returns the index-position of the specified object in the list.

getIndexOf(Component) - Method in class javax.swing.JLayeredPane

Returns the index of the specified Component.

getIndexOfChild(Object, Object) - Method in class javax.swing.tree.DefaultTreeModel

Returns the index of child in parent.

getIndexOfChild(Object, Object) - Method in interface javax.swing.tree.TreeModel

Returns the index of child in parent.

getIndexOfSize(float) - Static method in class javax.swing.text.html.StyleSheet

getInetAddress() - Method in class java.net.DatagramSocket

Returns the address to which this socket is connected.

getInetAddress() - Method in class java.net.ServerSocket

Returns the local address of this server socket.

getInetAddress() - Method in class java.net.Socket

Returns the address to which the socket is connected.

getInetAddress() - Method in class java.net.SocketImpl

Returns the value of this socket's address field.

getInetAddresses() - Method in class java.net.NetworkInterface

Convenience method to return an Enumeration with all or a subset of the InetAddresses bound to this network interface.

getInfinity() - Method in class java.text.DecimalFormatSymbols

Gets the string used to represent infinity.

getInfo() - Method in class java.security.Identity

Deprecated.

Returns general information previously specified for this identity.

getInfo() - Method in class java.security.Provider

Returns a human-readable description of the provider and its services.

getInheritsPopupMenu() - Method in class javax.swing.JComponent

Returns true if the JPopupMenu should be inherited from the parent.

getInit() - Method in class java.lang.management.MemoryUsage

Returns the amount of memory in bytes that the Java virtual machine initially requests from the operating system for memory management.

getInitialComponent(Window) - Method in class java.awt.FocusTraversalPolicy

Returns the Component that should receive the focus when a Window is made visible for the first time.

getInitialComponent(JInternalFrame) - Method in class javax.swing.InternalFrameFocusTraversalPolicy

Returns the Component that should receive the focus when a JInternalFrame is selected for the first time.

getInitialContext(Hashtable<?, ?>) - Method in interface javax.naming.spi.InitialContextFactory

Creates an Initial Context for beginning name resolution.

getInitialContext(Hashtable<?, ?>) - Static method in class javax.naming.spi.NamingManager

Creates an initial context using the specified environment properties.

getInitialDelay() - Method in class javax.swing.Timer

Returns the Timer's initial delay.

getInitialDelay() - Method in class javax.swing.ToolTipManager

Returns the initial delay value.

getInitialLocation(Insets) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager

Returns the left inset, unless the Insets are null in which case 0 is returned.

getInitialPolicies() - Method in class java.security.cert.PKIXParameters

Returns an immutable Set of initial policy identifiers (OID strings), indicating that any one of these policies would be acceptable to the certificate user for the purposes of certification path processing.

getInitialSelectionValue() - Method in class javax.swing.JOptionPane

Returns the input value that is displayed as initially selected to the user.

getInitialValue() - Method in class javax.swing.JOptionPane

Returns the initial value.

getInitialValueIndex() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI

Returns the initial index into the buttons to select.

getInitiatedClasses(ClassLoader) - Method in interface java.lang.instrument.Instrumentation

Returns an array of all classes for which loader is an initiating loader.

getInitiatorAddress() - Method in class org.ietf.jgss.ChannelBinding

Get the initiator's address for this channel binding.

getInitThreshold() - Method in class javax.management.monitor.CounterMonitor

Gets the initial threshold value common to all observed objects.

getInitThreshold() - Method in interface javax.management.monitor.CounterMonitorMBean

Gets the initial threshold value common to all observed objects.

getInput() - Method in exception java.net.URISyntaxException

Returns the input string.

getInput() - Method in exception java.nio.file.InvalidPathException

Returns the input string.

getInput() - Method in class javax.imageio.ImageReader

Returns the ImageInputStream or other Object previously set as the input source.

getInput() - Method in interface org.w3c.dom.ls.LSLoadEvent

The input source that was parsed.

getInput() - Method in interface org.w3c.dom.ls.LSProgressEvent

The input source that is being parsed.

getInputArguments() - Method in interface java.lang.management.RuntimeMXBean

Returns the input arguments passed to the Java virtual machine which does not include the arguments to the main method.

getInputAttributes() - Method in class javax.swing.JTextPane

Gets the input attributes for the pane.

getInputAttributes() - Method in class javax.swing.text.html.HTMLEditorKit

Gets the input attributes used for the styled editing actions.

getInputAttributes() - Method in class javax.swing.text.StyledEditorKit

Gets the input attributes for the pane.

getInputClass() - Method in class javax.imageio.spi.ImageInputStreamSpi

Returns a Class object representing the class or interface type that must be implemented by an input source in order to be "wrapped" in an ImageInputStream via the createInputStreamInstance method.

getInputContext() - Method in class java.awt.Component

Gets the input context used by this component for handling the communication with input methods when text is entered in this component.

getInputContext() - Method in class java.awt.Window

Gets the input context for this window.

getInputEncoding() - Method in interface org.w3c.dom.Document

An attribute specifying the encoding used for this document at the time of the parsing.

getInputEncoding() - Method in interface org.w3c.dom.Entity

An attribute specifying the encoding used for this entity at the time of parsing, when it is an external parsed entity.

getInputEvent() - Method in class javax.swing.event.HyperlinkEvent

Returns the InputEvent that triggered the hyperlink event.

getInputLength() - Method in exception java.nio.charset.MalformedInputException

Returns the length of the input.

getInputLength() - Method in exception java.nio.charset.UnmappableCharacterException

Returns the length of the input.

getInputMap(int) - Method in class javax.swing.JComponent

Returns the InputMap that is used during condition.

getInputMap() - Method in class javax.swing.JComponent

Returns the InputMap that is used when the component has focus.

getInputMethodControlObject() - Method in class java.awt.im.InputContext

Returns a control object from the current input method, or null.

getInputMethodDisplayName(Locale, Locale) - Method in interface java.awt.im.spi.InputMethodDescriptor

Returns the user-visible name of the corresponding input method for the given input locale in the language in which the name will be displayed.

getInputMethodIcon(Locale) - Method in interface java.awt.im.spi.InputMethodDescriptor

Returns an icon for the corresponding input method.

getInputMethodListeners() - Method in class java.awt.Component

Returns an array of all the input method listeners registered on this component.

getInputMethodRequests() - Method in class java.awt.Component

Gets the input method request handler which supports requests from input methods for this component.

getInputMethodRequests() - Method in class java.awt.TextComponent

getInputMethodRequests() - Method in class javax.swing.text.JTextComponent

getInputSource() - Method in class javax.xml.transform.sax.SAXSource

Get the SAX InputSource to be used for the Source.

getInputStream() - Method in class java.lang.Process

Returns the input stream connected to the normal output of the subprocess.

getInputStream() - Method in class java.net.Socket

Returns an input stream for this socket.

getInputStream() - Method in class java.net.SocketImpl

Returns an input stream for this socket.

getInputStream() - Method in class java.net.URLConnection

Returns an input stream that reads from this open connection.

getInputStream() - Method in interface java.rmi.server.RemoteCall

Deprecated.
no replacement

getInputStream(ZipEntry) - Method in class java.util.jar.JarFile

Returns an input stream for reading the contents of the specified zip file entry.

getInputStream(ZipEntry) - Method in class java.util.zip.ZipFile

Returns an input stream for reading the contents of the specified zip file entry.

getInputStream() - Method in class javax.activation.DataHandler

Get the InputStream for this object.

getInputStream() - Method in interface javax.activation.DataSource

This method returns an InputStream representing the data and throws the appropriate exception if it can not do so.

getInputStream() - Method in class javax.activation.FileDataSource

This method will return an InputStream representing the the data and will throw an IOException if it can not do so.

getInputStream() - Method in class javax.activation.URLDataSource

The getInputStream method from the URL.

getInputStream() - Method in class javax.xml.transform.stream.StreamSource

Get the byte stream that was set with setByteStream.

getInputStream() - Method in exception org.omg.CORBA.portable.ApplicationException

Returns the input stream from which the exception data can be read as its parameters.

getInputTypes() - Method in class javax.imageio.spi.ImageReaderSpi

Returns an array of Class objects indicating what types of objects may be used as arguments to the reader's setInput method.

getInputValue() - Method in class javax.swing.JOptionPane

Returns the value the user has input, if wantsInput is true.

getInputVerifier() - Method in class javax.swing.JComponent

Returns the input verifier for this component.

getInsertionIndex() - Method in class java.awt.font.TextHitInfo

Returns the insertion index.

getInsertPositionOffset() - Method in interface java.awt.im.InputMethodRequests

Gets the offset of the insert position in the committed text contained in the text editing component.

getInset(int, View) - Method in class javax.swing.text.html.StyleSheet.BoxPainter

Fetches the inset needed on a given side to account for the margin, border, and padding.

getInsets() - Method in class java.awt.Container

Determines the insets of this container, which indicate the size of the container's border.

getInsets() - Method in class javax.swing.JComponent

If a border has been set on this component, returns the border's insets; otherwise calls super.getInsets.

getInsets(Insets) - Method in class javax.swing.JComponent

Returns an Insets object containing this component's inset values.

getInsets() - Method in class javax.swing.JViewport

Returns the insets (border) dimensions as (0,0,0,0), since borders are not supported on a JViewport.

getInsets(Insets) - Method in class javax.swing.JViewport

Returns an Insets object containing this JViewports inset values.

getInsets() - Method in class javax.swing.plaf.basic.BasicComboBoxUI

Gets the insets from the JComboBox.

getInsets(JComponent) - Method in class javax.swing.plaf.basic.BasicDesktopIconUI

getInsets() - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider

If a border has been set on this component, returns the border's insets, else calls super.getInsets.

getInsets(JComponent) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI

Returns the insets.

getInsets() - Method in class javax.swing.plaf.basic.BasicToolBarUI.DragWindow

getInsets(SynthContext, Insets) - Method in class javax.swing.plaf.nimbus.NimbusStyle

Returns the Insets that are used to calculate sizing information.

getInsets(SynthContext, Insets) - Method in class javax.swing.plaf.synth.SynthStyle

Returns the Insets that are used to calculate sizing information.

getInsets(Object) - Method in class javax.swing.UIDefaults

If the value of key is an Insets return it, otherwise return null.

getInsets(Object, Locale) - Method in class javax.swing.UIDefaults

If the value of key for the given Locale is an Insets return it, otherwise return null.

getInsets(Object) - Static method in class javax.swing.UIManager

Returns an Insets object from the defaults.

getInsets(Object, Locale) - Static method in class javax.swing.UIManager

Returns an Insets object from the defaults that is appropriate for the given locale.

getInsetSpan(int) - Method in class javax.swing.text.AsyncBoxView

Fetch the span along an axis that is taken up by the insets.

getInsideAllocation(Shape) - Method in class javax.swing.text.CompositeView

Translates the immutable allocation given to the view to a mutable allocation that represents the interior allocation (i.e.

getInsideBorder() - Method in class javax.swing.border.CompoundBorder

Returns the inside border object.

getInstalledLookAndFeels() - Static method in class javax.swing.UIManager

Returns an array of LookAndFeelInfos representing the LookAndFeel implementations currently available.

getInstance(int) - Static method in class java.awt.AlphaComposite

Creates an AlphaComposite object with the specified rule.

getInstance(int, float) - Static method in class java.awt.AlphaComposite

Creates an AlphaComposite object with the specified rule and the constant alpha to multiply with the alpha of the source.

getInstance(int) - Static method in class java.awt.color.ColorSpace

Returns a ColorSpace representing one of the specific predefined color spaces.

getInstance(byte[]) - Static method in class java.awt.color.ICC_Profile

Constructs an ICC_Profile object corresponding to the data in a byte array.

getInstance(int) - Static method in class java.awt.color.ICC_Profile

Constructs an ICC_Profile corresponding to one of the specific color spaces defined by the ColorSpace class (for example CS_sRGB).

getInstance(String) - Static method in class java.awt.color.ICC_Profile

Constructs an ICC_Profile corresponding to the data in a file.

getInstance(InputStream) - Static method in class java.awt.color.ICC_Profile

Constructs an ICC_Profile corresponding to the data in an InputStream.

getInstance() - Static method in class java.awt.im.InputContext

Returns a new InputContext instance.

getInstance(String) - Static method in class java.security.AlgorithmParameterGenerator

Returns an AlgorithmParameterGenerator object for generating a set of parameters to be used with the specified algorithm.

getInstance(String, String) - Static method in class java.security.AlgorithmParameterGenerator

Returns an AlgorithmParameterGenerator object for generating a set of parameters to be used with the specified algorithm.

getInstance(String, Provider) - Static method in class java.security.AlgorithmParameterGenerator

Returns an AlgorithmParameterGenerator object for generating a set of parameters to be used with the specified algorithm.

getInstance(String) - Static method in class java.security.AlgorithmParameters

Returns a parameter object for the specified algorithm.

getInstance(String, String) - Static method in class java.security.AlgorithmParameters

Returns a parameter object for the specified algorithm.

getInstance(String, Provider) - Static method in class java.security.AlgorithmParameters

Returns a parameter object for the specified algorithm.

getInstance(String) - Static method in class java.security.cert.CertificateFactory

Returns a certificate factory object that implements the specified certificate type.

getInstance(String, String) - Static method in class java.security.cert.CertificateFactory

Returns a certificate factory object for the specified certificate type.

getInstance(String, Provider) - Static method in class java.security.cert.CertificateFactory

Returns a certificate factory object for the specified certificate type.

getInstance(String) - Static method in class java.security.cert.CertPathBuilder

Returns a CertPathBuilder object that implements the specified algorithm.

getInstance(String, String) - Static method in class java.security.cert.CertPathBuilder

Returns a CertPathBuilder object that implements the specified algorithm.

getInstance(String, Provider) - Static method in class java.security.cert.CertPathBuilder

Returns a CertPathBuilder object that implements the specified algorithm.

getInstance(String) - Static method in class java.security.cert.CertPathValidator

Returns a CertPathValidator object that implements the specified algorithm.

getInstance(String, String) - Static method in class java.security.cert.CertPathValidator

Returns a CertPathValidator object that implements the specified algorithm.

getInstance(String, Provider) - Static method in class java.security.cert.CertPathValidator

Returns a CertPathValidator object that implements the specified algorithm.

getInstance(String, CertStoreParameters) - Static method in class java.security.cert.CertStore

Returns a CertStore object that implements the specified CertStore type and is initialized with the specified parameters.

getInstance(String, CertStoreParameters, String) - Static method in class java.security.cert.CertStore

Returns a CertStore object that implements the specified CertStore type.

getInstance(String, CertStoreParameters, Provider) - Static method in class java.security.cert.CertStore

Returns a CertStore object that implements the specified CertStore type.

getInstance(String) - Static method in class java.security.KeyFactory

Returns a KeyFactory object that converts public/private keys of the specified algorithm.

getInstance(String, String) - Static method in class java.security.KeyFactory

Returns a KeyFactory object that converts public/private keys of the specified algorithm.

getInstance(String, Provider) - Static method in class java.security.KeyFactory

Returns a KeyFactory object that converts public/private keys of the specified algorithm.

getInstance(String) - Static method in class java.security.KeyPairGenerator

Returns a KeyPairGenerator object that generates public/private key pairs for the specified algorithm.

getInstance(String, String) - Static method in class java.security.KeyPairGenerator

Returns a KeyPairGenerator object that generates public/private key pairs for the specified algorithm.

getInstance(String, Provider) - Static method in class java.security.KeyPairGenerator

Returns a KeyPairGenerator object that generates public/private key pairs for the specified algorithm.

getInstance(String) - Static method in class java.security.KeyStore

Returns a keystore object of the specified type.

getInstance(String, String) - Static method in class java.security.KeyStore

Returns a keystore object of the specified type.

getInstance(String, Provider) - Static method in class java.security.KeyStore

Returns a keystore object of the specified type.

getInstance(String) - Static method in class java.security.MessageDigest

Returns a MessageDigest object that implements the specified digest algorithm.

getInstance(String, String) - Static method in class java.security.MessageDigest

Returns a MessageDigest object that implements the specified digest algorithm.

getInstance(String, Provider) - Static method in class java.security.MessageDigest

Returns a MessageDigest object that implements the specified digest algorithm.

getInstance(String, Policy.Parameters) - Static method in class java.security.Policy

Returns a Policy object of the specified type.

getInstance(String, Policy.Parameters, String) - Static method in class java.security.Policy

Returns a Policy object of the specified type.

getInstance(String, Policy.Parameters, Provider) - Static method in class java.security.Policy

Returns a Policy object of the specified type.

getInstance(String) - Static method in class java.security.SecureRandom

Returns a SecureRandom object that implements the specified Random Number Generator (RNG) algorithm.

getInstance(String, String) - Static method in class java.security.SecureRandom

Returns a SecureRandom object that implements the specified Random Number Generator (RNG) algorithm.

getInstance(String, Provider) - Static method in class java.security.SecureRandom

Returns a SecureRandom object that implements the specified Random Number Generator (RNG) algorithm.

getInstance(String) - Static method in class java.security.Signature

Returns a Signature object that implements the specified signature algorithm.

getInstance(String, String) - Static method in class java.security.Signature

Returns a Signature object that implements the specified signature algorithm.

getInstance(String, Provider) - Static method in class java.security.Signature

Returns a Signature object that implements the specified signature algorithm.

getInstance() - Static method in class java.text.Collator

Gets the Collator for the current default locale.

getInstance(Locale) - Static method in class java.text.Collator

Gets the Collator for the desired locale.

getInstance() - Static method in class java.text.DateFormat

Get a default date/time formatter that uses the SHORT style for both the date and the time.

getInstance() - Static method in class java.text.DateFormatSymbols

Gets the DateFormatSymbols instance for the default locale.

getInstance(Locale) - Static method in class java.text.DateFormatSymbols

Gets the DateFormatSymbols instance for the specified locale.

getInstance() - Static method in class java.text.DecimalFormatSymbols

Gets the DecimalFormatSymbols instance for the default locale.

getInstance(Locale) - Static method in class java.text.DecimalFormatSymbols

Gets the DecimalFormatSymbols instance for the specified locale.

getInstance() - Static method in class java.text.NumberFormat

Returns a general-purpose number format for the current default FORMAT locale.

getInstance(Locale) - Static method in class java.text.NumberFormat

Returns a general-purpose number format for the specified locale.

getInstance(Locale) - Method in class java.text.spi.CollatorProvider

Returns a new Collator instance for the specified locale.

getInstance(Locale) - Method in class java.text.spi.DateFormatSymbolsProvider

Returns a new DateFormatSymbols instance for the specified locale.

getInstance(Locale) - Method in class java.text.spi.DecimalFormatSymbolsProvider

Returns a new DecimalFormatSymbols instance for the specified locale.

getInstance() - Static method in class java.util.Calendar

Gets a calendar using the default time zone and locale.

getInstance(TimeZone) - Static method in class java.util.Calendar

Gets a calendar using the specified time zone and default locale.

getInstance(Locale) - Static method in class java.util.Calendar

Gets a calendar using the default time zone and specified locale.

getInstance(TimeZone, Locale) - Static method in class java.util.Calendar

Gets a calendar with the specified time zone and locale.

getInstance(String) - Static method in class java.util.Currency

Returns the Currency instance for the given currency code.

getInstance(Locale) - Static method in class java.util.Currency

Returns the Currency instance for the country of the given locale.

getInstance(String) - Static method in class javax.crypto.Cipher

Returns a Cipher object that implements the specified transformation.

getInstance(String, String) - Static method in class javax.crypto.Cipher

Returns a Cipher object that implements the specified transformation.

getInstance(String, Provider) - Static method in class javax.crypto.Cipher

Returns a Cipher object that implements the specified transformation.

getInstance(String) - Static method in class javax.crypto.ExemptionMechanism

Returns an ExemptionMechanism object that implements the specified exemption mechanism algorithm.

getInstance(String, String) - Static method in class javax.crypto.ExemptionMechanism

Returns an ExemptionMechanism object that implements the specified exemption mechanism algorithm.

getInstance(String, Provider) - Static method in class javax.crypto.ExemptionMechanism

Returns an ExemptionMechanism object that implements the specified exemption mechanism algorithm.

getInstance(String) - Static method in class javax.crypto.KeyAgreement

Returns a KeyAgreement object that implements the specified key agreement algorithm.

getInstance(String, String) - Static method in class javax.crypto.KeyAgreement

Returns a KeyAgreement object that implements the specified key agreement algorithm.

getInstance(String, Provider) - Static method in class javax.crypto.KeyAgreement

Returns a KeyAgreement object that implements the specified key agreement algorithm.

getInstance(String) - Static method in class javax.crypto.KeyGenerator

Returns a KeyGenerator object that generates secret keys for the specified algorithm.

getInstance(String, String) - Static method in class javax.crypto.KeyGenerator

Returns a KeyGenerator object that generates secret keys for the specified algorithm.

getInstance(String, Provider) - Static method in class javax.crypto.KeyGenerator

Returns a KeyGenerator object that generates secret keys for the specified algorithm.

getInstance(String) - Static method in class javax.crypto.Mac

Returns a Mac object that implements the specified MAC algorithm.

getInstance(String, String) - Static method in class javax.crypto.Mac

Returns a Mac object that implements the specified MAC algorithm.

getInstance(String, Provider) - Static method in class javax.crypto.Mac

Returns a Mac object that implements the specified MAC algorithm.

getInstance(String) - Static method in class javax.crypto.SecretKeyFactory

Returns a SecretKeyFactory object that converts secret keys of the specified algorithm.

getInstance(String, String) - Static method in class javax.crypto.SecretKeyFactory

Returns a SecretKeyFactory object that converts secret keys of the specified algorithm.

getInstance(String, Provider) - Static method in class javax.crypto.SecretKeyFactory

Returns a SecretKeyFactory object that converts secret keys of the specified algorithm.

getInstance(String) - Static method in class javax.management.ObjectName

Return an instance of ObjectName that can be used anywhere an object obtained with new ObjectName(name) can be used.

getInstance(String, String, String) - Static method in class javax.management.ObjectName

Return an instance of ObjectName that can be used anywhere an object obtained with new ObjectName(domain, key, value) can be used.

getInstance(String, Hashtable<String, String>) - Static method in class javax.management.ObjectName

Return an instance of ObjectName that can be used anywhere an object obtained with new ObjectName(domain, table) can be used.

getInstance(ObjectName) - Static method in class javax.management.ObjectName

Return an instance of ObjectName that can be used anywhere the given object can be used.

getInstance(String) - Static method in class javax.net.ssl.KeyManagerFactory

Returns a KeyManagerFactory object that acts as a factory for key managers.

getInstance(String, String) - Static method in class javax.net.ssl.KeyManagerFactory

Returns a KeyManagerFactory object that acts as a factory for key managers.

getInstance(String, Provider) - Static method in class javax.net.ssl.KeyManagerFactory

Returns a KeyManagerFactory object that acts as a factory for key managers.

getInstance(String) - Static method in class javax.net.ssl.SSLContext

Returns a SSLContext object that implements the specified secure socket protocol.

getInstance(String, String) - Static method in class javax.net.ssl.SSLContext

Returns a SSLContext object that implements the specified secure socket protocol.

getInstance(String, Provider) - Static method in class javax.net.ssl.SSLContext

Returns a SSLContext object that implements the specified secure socket protocol.

getInstance(String) - Static method in class javax.net.ssl.TrustManagerFactory

Returns a TrustManagerFactory object that acts as a factory for trust managers.

getInstance(String, String) - Static method in class javax.net.ssl.TrustManagerFactory

Returns a TrustManagerFactory object that acts as a factory for trust managers.

getInstance(String, Provider) - Static method in class javax.net.ssl.TrustManagerFactory

Returns a TrustManagerFactory object that acts as a factory for trust managers.

getInstance(File) - Static method in class javax.security.auth.kerberos.KeyTab

Returns a KeyTab instance from a File object that is bound to an unknown service principal.

getInstance(KerberosPrincipal, File) - Static method in class javax.security.auth.kerberos.KeyTab

Returns a KeyTab instance from a File object that is bound to the specified service principal.

getInstance() - Static method in class javax.security.auth.kerberos.KeyTab

Returns the default KeyTab instance that is bound to an unknown service principal.

getInstance(KerberosPrincipal) - Static method in class javax.security.auth.kerberos.KeyTab

Returns the default KeyTab instance that is bound to the specified service principal.

getInstance(String, Configuration.Parameters) - Static method in class javax.security.auth.login.Configuration

Returns a Configuration object of the specified type.

getInstance(String, Configuration.Parameters, String) - Static method in class javax.security.auth.login.Configuration

Returns a Configuration object of the specified type.

getInstance(String, Configuration.Parameters, Provider) - Static method in class javax.security.auth.login.Configuration

Returns a Configuration object of the specified type.

getInstance(InputStream) - Static method in class javax.security.cert.X509Certificate

Instantiates an X509Certificate object, and initializes it with the data read from the input stream inStream.

getInstance(byte[]) - Static method in class javax.security.cert.X509Certificate

Instantiates an X509Certificate object, and initializes it with the specified byte array.

getInstance(String) - Static method in class javax.sql.rowset.spi.SyncFactory

Returns the SyncProvider instance identified by providerID.

getInstance() - Static method in class javax.swing.LayoutStyle

Returns the shared instance of LayoutStyle.

getInstance(String) - Static method in class javax.xml.crypto.dsig.keyinfo.KeyInfoFactory

Returns a KeyInfoFactory that supports the specified XML processing mechanism and representation type (ex: "DOM").

getInstance(String, Provider) - Static method in class javax.xml.crypto.dsig.keyinfo.KeyInfoFactory

Returns a KeyInfoFactory that supports the requested XML processing mechanism and representation type (ex: "DOM"), as supplied by the specified provider.

getInstance(String, String) - Static method in class javax.xml.crypto.dsig.keyinfo.KeyInfoFactory

Returns a KeyInfoFactory that supports the requested XML processing mechanism and representation type (ex: "DOM"), as supplied by the specified provider.

getInstance() - Static method in class javax.xml.crypto.dsig.keyinfo.KeyInfoFactory

Returns a KeyInfoFactory that supports the default XML processing mechanism and representation type ("DOM").

getInstance(String, String) - Static method in class javax.xml.crypto.dsig.TransformService

Returns a TransformService that supports the specified algorithm URI (ex: Transform.XPATH2) and mechanism type (ex: DOM).

getInstance(String, String, Provider) - Static method in class javax.xml.crypto.dsig.TransformService

Returns a TransformService that supports the specified algorithm URI (ex: Transform.XPATH2) and mechanism type (ex: DOM) as supplied by the specified provider.

getInstance(String, String, String) - Static method in class javax.xml.crypto.dsig.TransformService

Returns a TransformService that supports the specified algorithm URI (ex: Transform.XPATH2) and mechanism type (ex: DOM) as supplied by the specified provider.

getInstance(String) - Static method in class javax.xml.crypto.dsig.XMLSignatureFactory

Returns an XMLSignatureFactory that supports the specified XML processing mechanism and representation type (ex: "DOM").

getInstance(String, Provider) - Static method in class javax.xml.crypto.dsig.XMLSignatureFactory

Returns an XMLSignatureFactory that supports the requested XML processing mechanism and representation type (ex: "DOM"), as supplied by the specified provider.

getInstance(String, String) - Static method in class javax.xml.crypto.dsig.XMLSignatureFactory

Returns an XMLSignatureFactory that supports the requested XML processing mechanism and representation type (ex: "DOM"), as supplied by the specified provider.

getInstance() - Static method in class javax.xml.crypto.dsig.XMLSignatureFactory

Returns an XMLSignatureFactory that supports the default XML processing mechanism and representation type ("DOM").

getInstance() - Static method in class org.ietf.jgss.GSSManager

Returns the default GSSManager implementation.

getInstanceFollowRedirects() - Method in class java.net.HttpURLConnection

Returns the value of this HttpURLConnection's instanceFollowRedirects field.

getInstanceOf(Object, Class<?>) - Static method in class java.beans.Beans

From a given bean, obtain an object representing a specified type view of that source object.

getInstanceStrong() - Static method in class java.security.SecureRandom

Returns a SecureRandom object that was selected by using the algorithms/providers specified in the securerandom.strongAlgorithms Security property.

getInstant() - Method in class java.time.zone.ZoneOffsetTransition

Gets the transition instant.

getInstantiatedMethodType() - Method in class java.lang.invoke.SerializedLambda

Get the signature of the primary functional interface method after type variables are substituted with their instantiation from the capture site.

getInstrument(Patch) - Method in interface javax.sound.midi.Soundbank

Obtains an Instrument from the given Patch.

getInstruments() - Method in interface javax.sound.midi.Soundbank

Obtains a list of instruments contained in this sound bank.

getInt(Object, int) - Static method in class java.lang.reflect.Array

Returns the value of the indexed component in the specified array object, as an int.

getInt(Object) - Method in class java.lang.reflect.Field

Gets the value of a static or instance field of type int or of another primitive type convertible to type int via a widening conversion.

getInt() - Method in class java.nio.ByteBuffer

Relative get method for reading an int value.

getInt(int) - Method in class java.nio.ByteBuffer

Absolute get method for reading an int value.

getInt(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC INTEGER parameter as an int in the Java programming language.

getInt(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC INTEGER parameter as an int in the Java programming language.

getInt(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as an int in the Java programming language.

getInt(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as an int in the Java programming language.

getInt(String, int) - Method in class java.util.prefs.AbstractPreferences

Implements the getInt method as per the specification in Preferences.getInt(String,int).

getInt(String, int) - Method in class java.util.prefs.Preferences

Returns the int value represented by the string associated with the specified key in this preference node.

getInt(SynthContext, Object, int) - Method in class javax.swing.plaf.synth.SynthStyle

Convenience method to get a specific style property whose value is a Number.

getInt(Object) - Method in class javax.swing.UIDefaults

If the value of key is an Integer return its integer value, otherwise return 0.

getInt(Object, Locale) - Method in class javax.swing.UIDefaults

If the value of key for the given Locale is an Integer return its integer value, otherwise return 0.

getInt(Object) - Static method in class javax.swing.UIManager

Returns an integer from the defaults.

getInt(Object, Locale) - Static method in class javax.swing.UIManager

Returns an integer from the defaults that is appropriate for the given locale.

getInteger(String) - Static method in class java.lang.Integer

Determines the integer value of the system property with the specified name.

getInteger(String, int) - Static method in class java.lang.Integer

Determines the integer value of the system property with the specified name.

getInteger(String, Integer) - Static method in class java.lang.Integer

Returns the integer value of the system property with the specified name.

getIntegerAttributeValue(AttributeSet, HTML.Attribute, int) - Static method in class javax.swing.text.html.HTML

Fetches an integer attribute value.

getIntegerInstance() - Static method in class java.text.NumberFormat

Returns an integer number format for the current default FORMAT locale.

getIntegerInstance(Locale) - Static method in class java.text.NumberFormat

Returns an integer number format for the specified locale.

getIntegerInstance(Locale) - Method in class java.text.spi.NumberFormatProvider

Returns a new NumberFormat instance which formats integer values for the specified locale.

getIntegState() - Method in interface org.ietf.jgss.GSSContext

Determines if data integrity is available over the context.

getIntercellSpacing() - Method in class javax.swing.JTable

Returns the horizontal and vertical space between cells.

getInterface() - Method in class java.net.MulticastSocket

Retrieve the address of the network interface used for multicast packets.

getInterface(Class<T>) - Method in interface javax.script.Invocable

Returns an implementation of an interface using functions compiled in the interpreter.

getInterface(Object, Class<T>) - Method in interface javax.script.Invocable

Returns an implementation of an interface using member functions of a scripting object compiled in the interpreter.

getInterfaceAddresses() - Method in class java.net.NetworkInterface

Get a List of all or a subset of the InterfaceAddresses of this network interface.

getInterfaces() - Method in class java.lang.Class

Determines the interfaces implemented by the class or interface represented by this object.

getInterfaces() - Method in interface javax.lang.model.element.TypeElement

Returns the interface types directly implemented by this class or extended by this interface.

getInteriorRectangle(Component, int, int, int, int) - Method in class javax.swing.border.AbstractBorder

This convenience method calls the static method.

getInteriorRectangle(Component, Border, int, int, int, int) - Static method in class javax.swing.border.AbstractBorder

Returns a rectangle using the arguments minus the insets of the border.

getInternalFrame() - Method in class javax.swing.event.InternalFrameEvent

Returns the originator of the event.

getInternalFrame() - Method in class javax.swing.JInternalFrame.JDesktopIcon

Returns the JInternalFrame that this DesktopIcon is associated with.

getInternalFrameAltMaximizeIcon(int) - Static method in class javax.swing.plaf.metal.MetalIconFactory

getInternalFrameBorder() - Static method in class javax.swing.plaf.basic.BasicBorders

getInternalFrameCloseIcon(int) - Static method in class javax.swing.plaf.metal.MetalIconFactory

getInternalFrameDefaultMenuIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

getInternalFrameListeners() - Method in class javax.swing.JInternalFrame

Returns an array of all the InternalFrameListeners added to this JInternalFrame with addInternalFrameListener.

getInternalFrameMaximizeIcon(int) - Static method in class javax.swing.plaf.metal.MetalIconFactory

getInternalFrameMinimizeIcon(int) - Static method in class javax.swing.plaf.metal.MetalIconFactory

getInternalSubset() - Method in interface org.w3c.dom.DocumentType

The internal subset as a string, or null if there is none.

getInternationalCurrencySymbol() - Method in class java.text.DecimalFormatSymbols

Returns the ISO 4217 currency code of the currency of these DecimalFormatSymbols.

getInterpolationType() - Method in class java.awt.image.AffineTransformOp

Returns the interpolation type used by this op.

getIntParameter(int) - Method in class java.awt.image.renderable.ParameterBlock

A convenience method to return a parameter as an int.

getInvalidCharacters() - Method in class javax.swing.text.MaskFormatter

Returns the characters that are not valid for input.

getInvalidityDate() - Method in exception java.security.cert.CertificateRevokedException

Returns the invalidity date, as specified in the Invalidity Date extension of this CertificateRevokedException.

getInverted() - Method in class javax.swing.JSlider

Returns true if the value-range shown for the slider is reversed,

getInvocationHandler(Object) - Static method in class java.lang.reflect.Proxy

Returns the invocation handler for the specified proxy instance.

getInvoker() - Method in class javax.swing.JPopupMenu

Returns the component which is the 'invoker' of this popup menu.

getInvokesStopCellEditing() - Method in class javax.swing.JTree

Returns the indicator that tells what happens when editing is interrupted.

getIOException() - Method in exception java.awt.print.PrinterIOException

Returns the IOException that terminated the print job.

getISO3Country() - Method in class java.util.Locale

Returns a three-letter abbreviation for this locale's country.

getISO3Language() - Method in class java.util.Locale

Returns a three-letter abbreviation of this locale's language.

getISOCountries() - Static method in class java.util.Locale

Returns a list of all 2-letter country codes defined in ISO 3166.

getISOLanguages() - Static method in class java.util.Locale

Returns a list of all 2-letter language codes defined in ISO 639.

getIssuer() - Method in class java.security.cert.X509CertSelector

Returns the issuer criterion as an X500Principal.

getIssuerAlternativeNames() - Method in class java.security.cert.X509Certificate

Gets an immutable collection of issuer alternative names from the IssuerAltName extension, (OID = 2.5.29.18).

getIssuerAsBytes() - Method in class java.security.cert.X509CertSelector

Returns the issuer criterion as a byte array.

getIssuerAsString() - Method in class java.security.cert.X509CertSelector

Denigrated, use X509CertSelector.getIssuer() or X509CertSelector.getIssuerAsBytes() instead.

getIssuerDN() - Method in class java.security.cert.X509Certificate

Denigrated, replaced by X509Certificate.getIssuerX500Principal().

getIssuerDN() - Method in class java.security.cert.X509CRL

Denigrated, replaced by X509CRL.getIssuerX500Principal().

getIssuerDN() - Method in class javax.security.cert.X509Certificate

Gets the issuer (issuer distinguished name) value from the certificate.

getIssuerName() - Method in interface javax.xml.crypto.dsig.keyinfo.X509IssuerSerial

Returns the X.500 distinguished name of this X509IssuerSerial in RFC 2253 String format.

getIssuerNames() - Method in class java.security.cert.X509CRLSelector

Returns a copy of the issuerNames criterion.

getIssuers() - Method in class java.security.cert.X509CRLSelector

Returns the issuerNames criterion.

getIssuerUniqueID() - Method in class java.security.cert.X509Certificate

Gets the issuerUniqueID value from the certificate.

getIssuerX500Principal() - Method in class java.security.cert.X509Certificate

Returns the issuer (issuer distinguished name) value from the certificate as an X500Principal.

getIssuerX500Principal() - Method in class java.security.cert.X509CRL

Returns the issuer (issuer distinguished name) value from the CRL as an X500Principal.

getItalicAngle() - Method in class java.awt.Font

Returns the italic angle of this Font.

getItem(int) - Method in class java.awt.Choice

Gets the string at the specified index in this Choice menu.

getItem() - Method in class java.awt.event.ItemEvent

Returns the item affected by the event.

getItem(int) - Method in class java.awt.List

Gets the item associated with the specified index.

getItem(int) - Method in class java.awt.Menu

Gets the item located at the specified index of this menu.

getItem() - Method in interface javax.swing.ComboBoxEditor

Return the edited item

getItem(int) - Method in class javax.swing.JMenu

Returns the JMenuItem at the specified position.

getItem() - Method in class javax.swing.plaf.basic.BasicComboBoxEditor

getItemAt(int) - Method in class javax.swing.JComboBox

Returns the list item at the specified index.

getItemCount() - Method in class java.awt.Choice

Returns the number of items in this Choice menu.

getItemCount() - Method in class java.awt.List

Gets the number of items in the list.

getItemCount() - Method in class java.awt.Menu

Get the number of items in this menu.

getItemCount() - Method in class javax.swing.JComboBox

Returns the number of items in the list.

getItemCount() - Method in class javax.swing.JMenu

Returns the number of items on the menu, including separators.

getItemListeners() - Method in class java.awt.Checkbox

Returns an array of all the item listeners registered on this checkbox.

getItemListeners() - Method in class java.awt.CheckboxMenuItem

Returns an array of all the item listeners registered on this checkbox menuitem.

getItemListeners() - Method in class java.awt.Choice

Returns an array of all the item listeners registered on this choice.

getItemListeners() - Method in class java.awt.List

Returns an array of all the item listeners registered on this list.

getItemListeners() - Method in class javax.swing.AbstractButton

Returns an array of all the ItemListeners added to this AbstractButton with addItemListener().

getItemListeners() - Method in class javax.swing.DefaultButtonModel

Returns an array of all the item listeners registered on this DefaultButtonModel.

getItemListeners() - Method in class javax.swing.JComboBox

Returns an array of all the ItemListeners added to this JComboBox with addItemListener().

getItems() - Method in class java.awt.List

Gets the items in the list.

getItemSelectable() - Method in class java.awt.event.ItemEvent

Returns the originator of the event.

getIterationCount() - Method in interface javax.crypto.interfaces.PBEKey

Returns the iteration count or 0 if not specified.

getIterationCount() - Method in class javax.crypto.spec.PBEKeySpec

Returns the iteration count or 0 if not specified.

getIterationCount() - Method in class javax.crypto.spec.PBEParameterSpec

Returns the iteration count.

getIterator() - Method in class java.text.AttributedString

Creates an AttributedCharacterIterator instance that provides access to the entire contents of this string.

getIterator(AttributedCharacterIterator.Attribute[]) - Method in class java.text.AttributedString

Creates an AttributedCharacterIterator instance that provides access to selected contents of this string.

getIterator(AttributedCharacterIterator.Attribute[], int, int) - Method in class java.text.AttributedString

Creates an AttributedCharacterIterator instance that provides access to selected contents of this string.

getIterator(HTML.Tag) - Method in class javax.swing.text.html.HTMLDocument

Fetches an iterator for the specified HTML tag.

getIV() - Method in class javax.crypto.Cipher

Returns the initialization vector (IV) in a new buffer.

getIV() - Method in class javax.crypto.spec.GCMParameterSpec

Returns the Initialization Vector (IV).

getIV() - Method in class javax.crypto.spec.IvParameterSpec

Returns the initialization vector (IV).

getIV() - Method in class javax.crypto.spec.RC2ParameterSpec

Returns the IV or null if this parameter set does not contain an IV.

getIV() - Method in class javax.crypto.spec.RC5ParameterSpec

Returns the IV or null if this parameter set does not contain an IV.

getJarEntry() - Method in class java.net.JarURLConnection

Return the JAR entry object for this connection, if any.

getJarEntry(String) - Method in class java.util.jar.JarFile

Returns the JarEntry for the given entry name or null if not found.

getJarFile() - Method in class java.net.JarURLConnection

Return the JAR file for this connection.

getJarFiles() - Method in class javax.management.loading.MLetContent

Gets the list of .jar files specified by the ARCHIVE attribute of the MLET tag.

getJarFileURL() - Method in class java.net.JarURLConnection

Returns the URL for the Jar file for this connection.

getJavaEncoding(String) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

Gets the corresponding Java encoding name from an IANA name.

getJavaFileForInput(JavaFileManager.Location, String, JavaFileObject.Kind) - Method in class javax.tools.ForwardingJavaFileManager

getJavaFileForInput(JavaFileManager.Location, String, JavaFileObject.Kind) - Method in interface javax.tools.JavaFileManager

Gets a file object for input representing the specified class of the specified kind in the given location.

getJavaFileForOutput(JavaFileManager.Location, String, JavaFileObject.Kind, FileObject) - Method in class javax.tools.ForwardingJavaFileManager

getJavaFileForOutput(JavaFileManager.Location, String, JavaFileObject.Kind, FileObject) - Method in interface javax.tools.JavaFileManager

Gets a file object for output representing the specified class of the specified kind in the given location.

getJavaFileObjects(File...) - Method in interface javax.tools.StandardJavaFileManager

Gets file objects representing the given files.

getJavaFileObjects(String...) - Method in interface javax.tools.StandardJavaFileManager

Gets file objects representing the given file names.

getJavaFileObjectsFromFiles(Iterable<? extends File>) - Method in interface javax.tools.StandardJavaFileManager

Gets file objects representing the given files.

getJavaFileObjectsFromStrings(Iterable<String>) - Method in interface javax.tools.StandardJavaFileManager

Gets file objects representing the given file names.

getJavaInitializationString() - Method in interface java.beans.PropertyEditor

Returns a fragment of Java code that can be used to set a property to match the editors current state.

getJavaInitializationString() - Method in class java.beans.PropertyEditorSupport

This method is intended for use when generating Java code to set the value of the property.

getJAXBNode(XmlNode) - Method in class javax.xml.bind.Binder

Gets the JAXB object associated with the given XML element.

getJDBCMajorVersion() - Method in interface java.sql.DatabaseMetaData

Retrieves the major JDBC version number for this driver.

getJDBCMinorVersion() - Method in interface java.sql.DatabaseMetaData

Retrieves the minor JDBC version number for this driver.

getJMenuBar() - Method in class javax.swing.JApplet

Returns the menubar set on this applet.

getJMenuBar() - Method in class javax.swing.JDialog

Returns the menubar set on this dialog.

getJMenuBar() - Method in class javax.swing.JFrame

Returns the menubar set on this frame.

getJMenuBar() - Method in class javax.swing.JInternalFrame

Returns the current JMenuBar for this JInternalFrame, or null if no menu bar has been set.

getJMenuBar() - Method in class javax.swing.JRootPane

Returns the menu bar from the layered pane.

getJobName() - Method in class java.awt.print.PrinterJob

Gets the name of the document to be printed.

getJoinType() - Method in interface javax.sql.rowset.JoinRowSet

Returns a int describing the set SQL JOIN type governing this JoinRowSet instance.

getJustificationInfo() - Method in class java.awt.font.GraphicAttribute

Returns the justification information for this GraphicAttribute.

getJustifiedLayout(float) - Method in class java.awt.font.TextLayout

Creates a copy of this TextLayout justified to the specified width.

getKeepAlive() - Method in class java.net.Socket

Tests if SO_KEEPALIVE is enabled.

getKeepAliveTime(TimeUnit) - Method in class java.util.concurrent.ThreadPoolExecutor

Returns the thread keep-alive time, which is the amount of time that threads in excess of the core pool size may remain idle before being terminated.

getKernel() - Method in class java.awt.image.ConvolveOp

Returns the Kernel.

getKernelData(float[]) - Method in class java.awt.image.Kernel

Returns the kernel data in row major order.

getKey() - Method in class java.awt.MenuShortcut

Returns the raw keycode of this MenuShortcut.

getKey(String, char[]) - Method in class java.security.KeyStore

Returns the key associated with the given alias, using the given password to recover it.

getKey() - Method in class java.util.AbstractMap.SimpleEntry

Returns the key corresponding to this entry.

getKey() - Method in class java.util.AbstractMap.SimpleImmutableEntry

Returns the key corresponding to this entry.

getKey() - Method in interface java.util.Map.Entry

Returns the key corresponding to this entry.

getKey() - Method in exception java.util.MissingResourceException

Gets parameter passed by constructor.

getKey() - Method in class java.util.prefs.PreferenceChangeEvent

Returns the key of the preference that was changed.

getKey() - Method in class javax.accessibility.AccessibleRelation

Returns the key for this relation

getKey() - Method in class javax.crypto.spec.DESedeKeySpec

Returns the DES-EDE key.

getKey() - Method in class javax.crypto.spec.DESKeySpec

Returns the DES key material.

getKey() - Method in interface javax.xml.crypto.KeySelectorResult

Returns the selected key.

getKeyChar() - Method in class java.awt.AWTKeyStroke

Returns the character for this AWTKeyStroke.

getKeyChar() - Method in class java.awt.event.KeyEvent

Returns the character associated with the key in this event.

getKeyCode() - Method in class java.awt.AWTKeyStroke

Returns the numeric key code for this AWTKeyStroke.

getKeyCode() - Method in class java.awt.event.KeyEvent

Returns the integer keyCode associated with the key in this event.

getKeyColumns() - Method in interface javax.sql.rowset.CachedRowSet

Returns an array containing one or more column numbers indicating the columns that form a key that uniquely identifies a row in this CachedRowSet object.

getKeyEventDispatchers() - Method in class java.awt.KeyboardFocusManager

Returns this KeyboardFocusManager's KeyEventDispatcher chain as a List.

getKeyEventPostProcessors() - Method in class java.awt.KeyboardFocusManager

Returns this KeyboardFocusManager's KeyEventPostProcessor chain as a List.

getKeyEventType() - Method in class java.awt.AWTKeyStroke

Returns the type of KeyEvent which corresponds to this AWTKeyStroke.

getKeyId() - Method in interface javax.xml.crypto.dsig.keyinfo.PGPData

Returns the PGP public key identifier of this PGPData as defined in RFC 2440, section 11.2.

getKeyInfo() - Method in interface javax.xml.crypto.dsig.XMLSignature

Returns the key info of this XMLSignature.

getKeyInfoFactory() - Method in class javax.xml.crypto.dsig.XMLSignatureFactory

Returns a KeyInfoFactory that creates KeyInfo objects.

getKeyLength() - Method in class javax.crypto.spec.PBEKeySpec

Returns the to-be-derived key length or 0 if not specified.

getKeyListener() - Method in class javax.swing.plaf.basic.BasicComboPopup

Implementation of ComboPopup.getKeyListener().

getKeyListener() - Method in interface javax.swing.plaf.basic.ComboPopup

Returns a key listener that will be added to the combo box or null.

getKeyListeners() - Method in class java.awt.Component

Returns an array of all the key listeners registered on this component.

getKeyLocation() - Method in class java.awt.event.KeyEvent

Returns the location of the key that originated this key event.

getKeyManagers() - Method in class javax.net.ssl.KeyManagerFactory

Returns one key manager for each type of key material.

getKeymap() - Method in class javax.swing.text.JTextComponent

Fetches the keymap currently active in this text component.

getKeymap(String) - Static method in class javax.swing.text.JTextComponent

Fetches a named keymap previously added to the document.

getKeymapName() - Method in class javax.swing.plaf.basic.BasicTextUI

Fetches the name of the keymap that will be installed/used by default for this UI.

getKeyModifiersText(int) - Static method in class java.awt.event.KeyEvent

Returns a String describing the modifier key(s), such as "Shift", or "Ctrl+Shift".

getKeyPacket() - Method in interface javax.xml.crypto.dsig.keyinfo.PGPData

Returns the PGP key material packet of this PGPData as defined in RFC 2440, section 5.5.

getKeyProperty(String) - Method in class javax.management.ObjectName

Obtains the value associated with a key in a key property.

getKeyPropertyList() - Method in class javax.management.ObjectName

Returns the key properties as a Hashtable.

getKeyPropertyListString() - Method in class javax.management.ObjectName

Returns a string representation of the list of key properties specified at creation time.

getKeys() - Method in class java.util.ListResourceBundle

Returns an Enumeration of the keys contained in this ResourceBundle and its parent bundles.

getKeys() - Method in class java.util.PropertyResourceBundle

Returns an Enumeration of the keys contained in this ResourceBundle and its parent bundles.

getKeys() - Method in class java.util.ResourceBundle

Returns an enumeration of the keys.

getKeys(KerberosPrincipal) - Method in class javax.security.auth.kerberos.KeyTab

Returns fresh keys for the given Kerberos principal.

getKeys() - Method in class javax.swing.AbstractAction

Returns an array of Objects which are keys for which values have been set for this AbstractAction, or null if no keys have values set.

getKeySelectionManager() - Method in class javax.swing.JComboBox

Returns the list's key-selection manager.

getKeySelector() - Method in class javax.xml.crypto.dom.DOMCryptoContext

getKeySelector() - Method in interface javax.xml.crypto.XMLCryptoContext

Returns the key selector for finding a key.

getKeySelectorResult() - Method in interface javax.xml.crypto.dsig.XMLSignature

Returns the result of the KeySelector, if specified, after this XMLSignature has been signed or validated.

getKeysize() - Method in class java.security.spec.RSAKeyGenParameterSpec

Returns the keysize.

getKeySpec(Key, Class<T>) - Method in class java.security.KeyFactory

Returns a specification (key material) of the given key object.

getKeySpec(Cipher) - Method in class javax.crypto.EncryptedPrivateKeyInfo

Extract the enclosed PKCS8EncodedKeySpec object from the encrypted data and return it.

getKeySpec(Key) - Method in class javax.crypto.EncryptedPrivateKeyInfo

Extract the enclosed PKCS8EncodedKeySpec object from the encrypted data and return it.

getKeySpec(Key, String) - Method in class javax.crypto.EncryptedPrivateKeyInfo

Extract the enclosed PKCS8EncodedKeySpec object from the encrypted data and return it.

getKeySpec(Key, Provider) - Method in class javax.crypto.EncryptedPrivateKeyInfo

Extract the enclosed PKCS8EncodedKeySpec object from the encrypted data and return it.

getKeySpec(SecretKey, Class<?>) - Method in class javax.crypto.SecretKeyFactory

Returns a specification (key material) of the given key object in the requested format.

getKeyStore() - Method in class java.security.KeyStore.Builder

Returns the KeyStore described by this object.

getKeyStroke(char) - Static method in class javax.swing.KeyStroke

Returns a shared instance of a KeyStroke that represents a KEY_TYPED event for the specified character.

getKeyStroke(char, boolean) - Static method in class javax.swing.KeyStroke

Deprecated.
use getKeyStroke(char)

getKeyStroke(Character, int) - Static method in class javax.swing.KeyStroke

Returns a shared instance of a KeyStroke that represents a KEY_TYPED event for the specified Character object and a set of modifiers.

getKeyStroke(int, int, boolean) - Static method in class javax.swing.KeyStroke

Returns a shared instance of a KeyStroke, given a numeric key code and a set of modifiers, specifying whether the key is activated when it is pressed or released.

getKeyStroke(int, int) - Static method in class javax.swing.KeyStroke

Returns a shared instance of a KeyStroke, given a numeric key code and a set of modifiers.

getKeyStroke(String) - Static method in class javax.swing.KeyStroke

Parses a string and returns a KeyStroke.

getKeyStrokeForEvent(KeyEvent) - Static method in class javax.swing.KeyStroke

Returns a KeyStroke which represents the stroke which generated a given KeyEvent.

getKeyStrokesForAction(Action) - Method in interface javax.swing.text.Keymap

Fetches the keystrokes that will result in the given action.

getKeyText(int) - Static method in class java.awt.event.KeyEvent

Returns a String describing the keyCode, such as "HOME", "F1" or "A".

getKeyType() - Method in class javax.security.auth.kerberos.KerberosKey

Returns the key type for this long-term key.

getKeyUsage() - Method in class java.security.cert.X509Certificate

Gets a boolean array representing bits of the KeyUsage extension, (OID = 2.5.29.15).

getKeyUsage() - Method in class java.security.cert.X509CertSelector

Returns the keyUsage criterion.

getKind() - Method in interface javax.lang.model.element.Element

Returns the kind of this element.

getKind() - Method in interface javax.lang.model.type.TypeMirror

Returns the kind of this type.

getKind() - Method in interface javax.tools.Diagnostic

Gets the kind of this diagnostic, for example, error or warning.

getKind() - Method in class javax.tools.ForwardingJavaFileObject

getKind() - Method in interface javax.tools.JavaFileObject

Gets the kind of this file object.

getKind() - Method in class javax.tools.SimpleJavaFileObject

getL() - Method in class javax.crypto.spec.DHParameterSpec

Returns the size in bits, l, of the random exponent (private value).

getLabel() - Method in class java.awt.Button

Gets the label of this button.

getLabel() - Method in class java.awt.Checkbox

Gets the label of this check box.

getLabel() - Method in class java.awt.MenuItem

Gets the label for this menu item.

getLabel() - Method in class javax.swing.AbstractButton

Deprecated.
- Replaced by getText

getLabel() - Method in class javax.swing.JPopupMenu

Returns the popup menu's label

getLabel() - Method in class javax.swing.text.html.Option

Fetch the label associated with the option.

getLabelFor() - Method in class javax.swing.JLabel

Get the component this is labelling.

getLabelTable() - Method in class javax.swing.JSlider

Returns the dictionary of what labels to draw at which values.

getLanguage() - Method in class java.util.Locale

Returns the language code of this Locale.

getLanguageName() - Method in interface javax.script.ScriptEngineFactory

Returns the name of the scripting langauge supported by this ScriptEngine.

getLanguageVersion() - Method in interface javax.script.ScriptEngineFactory

Returns the version of the scripting language supported by this ScriptEngine.

getLargeDisplayIcon() - Method in class javax.swing.colorchooser.AbstractColorChooserPanel

Returns the large display icon for the panel.

getLargeMaxRows() - Method in interface java.sql.Statement

Retrieves the maximum number of rows that a ResultSet object produced by this Statement object can contain.

getLargestMinimum() - Method in class java.time.temporal.ValueRange

Gets the largest possible minimum value that the field can take.

getLargestPoolSize() - Method in class java.util.concurrent.ThreadPoolExecutor

Returns the largest number of threads that have ever simultaneously been in the pool.

getLargeUpdateCount() - Method in interface java.sql.Statement

Retrieves the current result as an update count; if the result is a ResultSet object or there are no more results, -1 is returned.

getLargeUpdateCounts() - Method in exception java.sql.BatchUpdateException

Retrieves the update count for each update statement in the batch update that executed successfully before this exception occurred.

getLast() - Method in class java.util.ArrayDeque

getLast() - Method in class java.util.concurrent.ConcurrentLinkedDeque

getLast() - Method in class java.util.concurrent.LinkedBlockingDeque

getLast() - Method in interface java.util.Deque

Retrieves, but does not remove, the last element of this deque.

getLast() - Method in class java.util.LinkedList

Returns the last element in this list.

getLastAccessedTime() - Method in interface javax.net.ssl.SSLSession

Returns the last time this Session representation was accessed by the session level infrastructure, in milliseconds since midnight, January 1, 1970 UTC.

getLastAccessTime() - Method in class java.util.zip.ZipEntry

Returns the last access time of the entry.

getLastChild() - Method in class javax.imageio.metadata.IIOMetadataNode

Returns the last child of this node, or null if the node has no children.

getLastChild() - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns this node's last child.

getLastChild() - Method in interface org.w3c.dom.Node

The last child of this node.

getLastChildPath(TreePath) - Method in class javax.swing.plaf.basic.BasicTreeUI

Returns a path to the last child of parent.

getLastColumn() - Method in interface javax.accessibility.AccessibleTableModelChange

Returns the last column that changed.

getLastColumn() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange

getLastComponent(Container) - Method in class java.awt.ContainerOrderFocusTraversalPolicy

Returns the last Component in the traversal cycle.

getLastComponent(Container) - Method in class java.awt.FocusTraversalPolicy

Returns the last Component in the traversal cycle.

getLastComponent(Container) - Method in class javax.swing.DefaultFocusManager

getLastComponent(Container) - Method in class javax.swing.LayoutFocusTraversalPolicy

Returns the last Component in the traversal cycle.

getLastComponent(Container) - Method in class javax.swing.SortingFocusTraversalPolicy

Returns the last Component in the traversal cycle.

getLastCursor() - Method in class javax.swing.JInternalFrame

Returns the last Cursor that was set by the setCursor method that is not a resizable Cursor.

getLastDividerLocation() - Method in class javax.swing.JSplitPane

Returns the last location the divider was at.

getLastDragLocation() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI

Returns the last drag location of the JSplitPane.

getLastIndex() - Method in class javax.swing.event.ListSelectionEvent

Returns the index of the last row whose selection may have changed.

getLastLeaf() - Method in class javax.swing.tree.DefaultMutableTreeNode

Finds and returns the last leaf that is a descendant of this node -- either this node or its last child's last leaf.

getLastModified() - Method in class java.net.URLConnection

Returns the value of the last-modified header field.

getLastModified() - Method in interface javax.tools.FileObject

Gets the time this file object was last modified.

getLastModified() - Method in class javax.tools.ForwardingFileObject

getLastModified() - Method in class javax.tools.SimpleJavaFileObject

This implementation returns 0L.

getLastModifiedTime(Path, LinkOption...) - Static method in class java.nio.file.Files

Returns a file's last modified time.

getLastModifiedTime() - Method in class java.util.zip.ZipEntry

Returns the last modification time of the entry.

getLastPathComponent() - Method in class javax.swing.tree.TreePath

Returns the last element of this path.

getLastRow() - Method in interface javax.accessibility.AccessibleTableModelChange

Returns the last row that changed.

getLastRow() - Method in class javax.swing.event.TableModelEvent

Returns the last row that changed.

getLastRow() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange

getLastSelectedPathComponent() - Method in class javax.swing.JTree

Returns the last path component of the selected path.

getLastVisibleIndex() - Method in class javax.swing.JList

Returns the largest list index that is currently visible.

getLatency() - Method in interface javax.sound.midi.Synthesizer

Obtains the processing latency incurred by this synthesizer, expressed in microseconds.

getLateReflectionDelay() - Method in class javax.sound.sampled.ReverbType

Returns the late reflection delay time in microseconds.

getLateReflectionIntensity() - Method in class javax.sound.sampled.ReverbType

Returns the late reflection intensity in decibels.

getLayer() - Method in class javax.swing.JInternalFrame

Convenience method for getting the layer attribute of this component.

getLayer(JComponent) - Static method in class javax.swing.JLayeredPane

Gets the layer property for a JComponent, it does not cause any side effects like setLayer().

getLayer(Component) - Method in class javax.swing.JLayeredPane

Returns the layer attribute for the specified Component.

getLayeredPane() - Method in class javax.swing.JApplet

Returns the layeredPane object for this applet.

getLayeredPane() - Method in class javax.swing.JDialog

Returns the layeredPane object for this dialog.

getLayeredPane() - Method in class javax.swing.JFrame

Returns the layeredPane object for this frame.

getLayeredPane() - Method in class javax.swing.JInternalFrame

Returns the layered pane for this internal frame.

getLayeredPane() - Method in class javax.swing.JRootPane

Gets the layered pane used by the root pane.

getLayeredPane() - Method in class javax.swing.JWindow

Returns the layeredPane object for this window.

getLayeredPane() - Method in interface javax.swing.RootPaneContainer

Returns the layeredPane.

getLayeredPaneAbove(Component) - Static method in class javax.swing.JLayeredPane

Convenience method that returns the first JLayeredPane which contains the specified component.

getLayerEventMask() - Method in class javax.swing.JLayer

Returns the bitmap of event mask to receive by this JLayer and its LayerUI.

getLayout() - Method in class java.awt.Container

Gets the layout manager for this container.

getLayout(int, int) - Method in class java.awt.font.TextMeasurer

Returns a TextLayout on the given character range.

getLayoutAlignmentX(Container) - Method in class java.awt.BorderLayout

Returns the alignment along the x axis.

getLayoutAlignmentX(Container) - Method in class java.awt.CardLayout

Returns the alignment along the x axis.

getLayoutAlignmentX(Container) - Method in class java.awt.GridBagLayout

Returns the alignment along the x axis.

getLayoutAlignmentX(Container) - Method in interface java.awt.LayoutManager2

Returns the alignment along the x axis.

getLayoutAlignmentX(Container) - Method in class javax.swing.BoxLayout

Returns the alignment along the X axis for the container.

getLayoutAlignmentX(Container) - Method in class javax.swing.GroupLayout

Returns the alignment along the x axis.

getLayoutAlignmentX(Container) - Method in class javax.swing.JRootPane.RootLayout

getLayoutAlignmentX(Container) - Method in class javax.swing.OverlayLayout

Returns the alignment along the x axis for the container.

getLayoutAlignmentX(Container) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager

Returns the alignment along the x axis.

getLayoutAlignmentX(Container) - Method in class javax.swing.SpringLayout

Returns 0.5f (centered).

getLayoutAlignmentY(Container) - Method in class java.awt.BorderLayout

Returns the alignment along the y axis.

getLayoutAlignmentY(Container) - Method in class java.awt.CardLayout

Returns the alignment along the y axis.

getLayoutAlignmentY(Container) - Method in class java.awt.GridBagLayout

Returns the alignment along the y axis.

getLayoutAlignmentY(Container) - Method in interface java.awt.LayoutManager2

Returns the alignment along the y axis.

getLayoutAlignmentY(Container) - Method in class javax.swing.BoxLayout

Returns the alignment along the Y axis for the container.

getLayoutAlignmentY(Container) - Method in class javax.swing.GroupLayout

Returns the alignment along the y axis.

getLayoutAlignmentY(Container) - Method in class javax.swing.JRootPane.RootLayout

getLayoutAlignmentY(Container) - Method in class javax.swing.OverlayLayout

Returns the alignment along the y axis for the container.

getLayoutAlignmentY(Container) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager

Returns the alignment along the y axis.

getLayoutAlignmentY(Container) - Method in class javax.swing.SpringLayout

Returns 0.5f (centered).

getLayoutComponent(Object) - Method in class java.awt.BorderLayout

Gets the component that was added using the given constraint

getLayoutComponent(Container, Object) - Method in class java.awt.BorderLayout

Returns the component that corresponds to the given constraint location based on the target Container's component orientation.

getLayoutDimensions() - Method in class java.awt.GridBagLayout

Determines column widths and row heights for the layout grid.

getLayoutFlags() - Method in class java.awt.font.GlyphVector

Returns flags describing the global state of the GlyphVector.

getLayoutInfo(Container, int) - Method in class java.awt.GridBagLayout

Fills in an instance of GridBagLayoutInfo for the current set of managed children.

GetLayoutInfo(Container, int) - Method in class java.awt.GridBagLayout

This method is obsolete and supplied for backwards compatibility only; new code should call getLayoutInfo instead.

getLayoutOrientation() - Method in class javax.swing.JList

Returns the layout orientation property for the list: VERTICAL if the layout is a single column of cells, VERTICAL_WRAP if the layout is "newspaper style" with the content flowing vertically then horizontally, or HORIZONTAL_WRAP if the layout is "newspaper style" with the content flowing horizontally then vertically.

getLayoutOrigin() - Method in class java.awt.GridBagLayout

Determines the origin of the layout area, in the graphics coordinate space of the target container.

getLayoutPath() - Method in class java.awt.font.TextLayout

Return the LayoutPath, or null if the layout path is the default path (x maps to advance, y maps to offset).

getLayoutQueue() - Method in class javax.swing.text.AsyncBoxView

Fetch the queue to use for layout.

getLayoutStyle() - Method in class javax.swing.GroupLayout

Returns the LayoutStyle used for calculating the preferred gap between components.

getLayoutStyle() - Method in class javax.swing.LookAndFeel

Returns the LayoutStyle for this look and feel.

getLayoutStyle() - Method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns a LayoutStyle implementing the Java look and feel design guidelines as specified at http://www.oracle.com/technetwork/java/hig-136467.html.

getLayoutView(int) - Method in class javax.swing.text.ParagraphView

Returns the view at a given index.

getLayoutViewCount() - Method in class javax.swing.text.ParagraphView

Returns the number of views that this view is responsible for.

getLayoutWeights() - Method in class java.awt.GridBagLayout

Determines the weights of the layout grid's columns and rows.

getLeader() - Method in class javax.swing.text.TabStop

Returns the leader of the tab.

getLeading() - Method in class java.awt.font.LineMetrics

Returns the leading of the text.

getLeading() - Method in class java.awt.font.TextLayout

Returns the leading of the TextLayout.

getLeading() - Method in class java.awt.FontMetrics

Determines the standard leading of the Font described by this FontMetrics object.

getLeadSelectionIndex() - Method in class javax.swing.DefaultListSelectionModel

Return the second index argument from the most recent call to setSelectionInterval(), addSelectionInterval() or removeSelectionInterval().

getLeadSelectionIndex() - Method in class javax.swing.JList

Returns the lead selection index.

getLeadSelectionIndex() - Method in interface javax.swing.ListSelectionModel

Return the second index argument from the most recent call to setSelectionInterval(), addSelectionInterval() or removeSelectionInterval().

getLeadSelectionPath() - Method in class javax.swing.JTree

Returns the path identified as the lead.

getLeadSelectionPath() - Method in class javax.swing.tree.DefaultTreeSelectionModel

Returns the last path that was added.

getLeadSelectionPath() - Method in interface javax.swing.tree.TreeSelectionModel

Returns the last path that was added.

getLeadSelectionRow() - Method in class javax.swing.JTree

Returns the row index corresponding to the lead path.

getLeadSelectionRow() - Method in class javax.swing.plaf.basic.BasicTreeUI

Returns the lead row of the selection.

getLeadSelectionRow() - Method in class javax.swing.tree.DefaultTreeSelectionModel

Returns the lead selection index.

getLeadSelectionRow() - Method in interface javax.swing.tree.TreeSelectionModel

Returns the lead selection index.

getLeafCount() - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns the total number of leaves that are descendants of this node.

getLeafIcon() - Method in class javax.swing.tree.DefaultTreeCellRenderer

Returns the icon used to represent leaf nodes.

getLeastMaximum(int) - Method in class java.util.Calendar

Returns the lowest maximum value for the given calendar field of this Calendar instance.

getLeastMaximum(int) - Method in class java.util.GregorianCalendar

Returns the lowest maximum value for the given calendar field of this GregorianCalendar instance.

getLeastSignificantBits() - Method in class java.util.UUID

Returns the least significant 64 bits of this UUID's 128 bit value.

getLeftChildIndent() - Method in class javax.swing.plaf.basic.BasicTreeUI

getLeftComponent() - Method in class javax.swing.JSplitPane

Returns the component to the left (or above) the divider.

getLeftIndent(AttributeSet) - Static method in class javax.swing.text.StyleConstants

Gets the left indent setting.

getLeftInset() - Method in class javax.swing.text.AsyncBoxView

Get the left part of the margin around the view.

getLeftInset() - Method in class javax.swing.text.CompositeView

Gets the left inset.

getLegalValues() - Method in class javax.management.openmbean.OpenMBeanAttributeInfoSupport

Returns an unmodifiable Set of legal values for the attribute described by this OpenMBeanAttributeInfoSupport instance, if specified, or null otherwise.

getLegalValues() - Method in interface javax.management.openmbean.OpenMBeanParameterInfo

Returns the set of legal values for this parameter, if it has one, or null otherwise.

getLegalValues() - Method in class javax.management.openmbean.OpenMBeanParameterInfoSupport

Returns an unmodifiable Set of legal values for the parameter described by this OpenMBeanParameterInfoSupport instance, if specified, or null otherwise.

getLength(Object) - Static method in class java.lang.reflect.Array

Returns the length of the specified array object, as an int.

getLength() - Method in class java.net.DatagramPacket

Returns the length of the data to be sent or the length of the data received.

getLength() - Method in class java.text.Bidi

Return the length of text in the line.

getLength() - Method in class javax.imageio.metadata.IIOMetadataNode

getLength() - Method in class javax.imageio.stream.IIOByteBuffer

Returns the length of the data of interest within the byte array returned by getData.

getLength() - Method in class javax.sound.midi.MidiMessage

Obtains the total length of the MIDI message in bytes.

getLength() - Method in interface javax.swing.event.DocumentEvent

Returns the length of the change.

getLength() - Method in class javax.swing.text.AbstractDocument.DefaultDocumentEvent

Returns the length of the change.

getLength() - Method in class javax.swing.text.AbstractDocument

Returns the length of the data.

getLength() - Method in class javax.swing.text.DefaultStyledDocument.ElementSpec

Gets the length.

getLength() - Method in interface javax.swing.text.Document

Returns number of characters of content currently in the document.

getLength() - Method in interface org.w3c.dom.CharacterData

The number of 16-bit units that are available through data and the substringData method below.

getLength() - Method in interface org.w3c.dom.DOMImplementationList

The number of DOMImplementations in the list.

getLength() - Method in interface org.w3c.dom.DOMStringList

The number of DOMStrings in the list.

getLength() - Method in interface org.w3c.dom.NamedNodeMap

The number of nodes in this map.

getLength() - Method in interface org.w3c.dom.NameList

The number of pairs (name and namespaceURI) in the list.

getLength() - Method in interface org.w3c.dom.NodeList

The number of nodes in the list.

getLength() - Method in interface org.xml.sax.AttributeList

Deprecated.

Return the number of attributes in this list.

getLength() - Method in interface org.xml.sax.Attributes

Return the number of attributes in the list.

getLength() - Method in class org.xml.sax.helpers.AttributeListImpl

Deprecated.

Return the number of attributes in the list.

getLength() - Method in class org.xml.sax.helpers.AttributesImpl

Return the number of attributes in the list.

getLengths() - Method in class javax.imageio.plugins.jpeg.JPEGHuffmanTable

Returns an array of shorts containing the number of values for each length in the Huffman table.

getLevel() - Method in class java.util.logging.Handler

Get the log level specifying which messages will be logged by this Handler.

getLevel() - Method in class java.util.logging.Logger

Get the log Level that has been specified for this Logger.

getLevel() - Method in class java.util.logging.LogRecord

Get the logging message level, for example Level.SEVERE.

getLevel() - Method in interface javax.sound.sampled.DataLine

Obtains the current volume level for the line.

getLevel() - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns the number of levels above this node -- the distance from the root to this node.

getLevelAt(int) - Method in class java.text.Bidi

Return the resolved level of the character at offset.

getLexicalHandler() - Method in class javax.xml.transform.sax.SAXResult

Get a SAX2 LexicalHandler for the output.

getLibraryDirectory() - Method in class javax.management.loading.MLet

Gets the current directory used by the library loader for storing native libraries before they are loaded into memory.

getLibraryDirectory() - Method in interface javax.management.loading.MLetMBean

Gets the current directory used by the library loader for storing native libraries before they are loaded into memory.

getLibraryPath() - Method in interface java.lang.management.RuntimeMXBean

Returns the Java library path.

getLifetime() - Method in interface org.ietf.jgss.GSSContext

Determines what the remaining lifetime for this context is.

getLimit() - Method in class javax.swing.undo.UndoManager

Returns the maximum number of edits this UndoManager holds.

getLimits() - Method in class java.text.ChoiceFormat

Get the limits passed in the constructor.

getLine(Line.Info) - Static method in class javax.sound.sampled.AudioSystem

Obtains a line that matches the description in the specified Line.Info object.

getLine() - Method in class javax.sound.sampled.LineEvent

Obtains the audio line that is the source of this event.

getLine(Line.Info) - Method in interface javax.sound.sampled.Mixer

Obtains a line that is available for use and that matches the description in the specified Line.Info object.

getLineBreakIndex(int, float) - Method in class java.awt.font.TextMeasurer

Returns the index of the first character which will not fit on on a line beginning at start and possible measuring up to maxAdvance in graphical width.

getLineBuffer() - Method in class javax.swing.text.PlainView

Gives access to a buffer that can be used to fetch text from the associated document.

getLineBuffer() - Method in class javax.swing.text.WrappedPlainView

Gives access to a buffer that can be used to fetch text from the associated document.

getLineClass() - Method in class javax.sound.sampled.Line.Info

Obtains the class of the line that this Line.Info object describes.

getLineColor() - Method in class javax.swing.border.LineBorder

Returns the color of the border.

getLineCount() - Method in class javax.swing.JTextArea

Determines the number of lines contained in the area.

getLineEndOffset(int) - Method in class javax.swing.JTextArea

Determines the offset of the end of the given line.

getLineIncrement() - Method in class java.awt.Scrollbar

Deprecated.
As of JDK version 1.1, replaced by getUnitIncrement().

getLineInfo() - Method in interface javax.sound.sampled.Line

Obtains the Line.Info object describing this line.

getLineInstance() - Static method in class java.text.BreakIterator

Returns a new BreakIterator instance for line breaks for the default locale.

getLineInstance(Locale) - Static method in class java.text.BreakIterator

Returns a new BreakIterator instance for line breaks for the given locale.

getLineInstance(Locale) - Method in class java.text.spi.BreakIteratorProvider

Returns a new BreakIterator instance for line breaks for the given locale.

getLineJoin() - Method in class java.awt.BasicStroke

Returns the line join style.

getLineLength() - Method in class javax.swing.text.AbstractWriter

Returns the maximum line length.

getLineMetrics(String, FontRenderContext) - Method in class java.awt.Font

Returns a LineMetrics object created with the specified String and FontRenderContext.

getLineMetrics(String, int, int, FontRenderContext) - Method in class java.awt.Font

Returns a LineMetrics object created with the specified arguments.

getLineMetrics(char[], int, int, FontRenderContext) - Method in class java.awt.Font

Returns a LineMetrics object created with the specified arguments.

getLineMetrics(CharacterIterator, int, int, FontRenderContext) - Method in class java.awt.Font

Returns a LineMetrics object created with the specified arguments.

getLineMetrics(String, Graphics) - Method in class java.awt.FontMetrics

Returns the LineMetrics object for the specified String in the specified Graphics context.

getLineMetrics(String, int, int, Graphics) - Method in class java.awt.FontMetrics

Returns the LineMetrics object for the specified String in the specified Graphics context.

getLineMetrics(char[], int, int, Graphics) - Method in class java.awt.FontMetrics

Returns the LineMetrics object for the specified character array in the specified Graphics context.

getLineMetrics(CharacterIterator, int, int, Graphics) - Method in class java.awt.FontMetrics

Returns the LineMetrics object for the specified CharacterIterator in the specified Graphics context.

getLineNumber() - Method in class java.io.LineNumberInputStream

Deprecated.

Returns the current line number.

getLineNumber() - Method in class java.io.LineNumberReader

Get the current line number.

getLineNumber() - Method in class java.lang.StackTraceElement

Returns the line number of the source line containing the execution point represented by this stack trace element.

getLineNumber() - Method in exception javax.script.ScriptException

Get the line number on which an error occurred.

getLineNumber() - Method in interface javax.tools.Diagnostic

Gets the line number of the character offset returned by Diagnostic.getPosition().

getLineNumber() - Method in class javax.xml.bind.helpers.ValidationEventLocatorImpl

getLineNumber() - Method in interface javax.xml.bind.ValidationEventLocator

Return the line number if available

getLineNumber() - Method in interface javax.xml.stream.Location

Return the line number where the current event ends, returns -1 if none is available.

getLineNumber() - Method in interface javax.xml.transform.SourceLocator

Return the line number where the current document event ends.

getLineNumber() - Method in interface org.w3c.dom.DOMLocator

The line number this locator is pointing to, or -1 if there is no column number available.

getLineNumber() - Method in class org.xml.sax.helpers.LocatorImpl

Return the saved line number (1-based).

getLineNumber() - Method in interface org.xml.sax.Locator

Return the line number where the current document event ends.

getLineNumber() - Method in exception org.xml.sax.SAXParseException

The line number of the end of the text where the exception occurred.

getLineOfOffset(int) - Method in class javax.swing.JTextArea

Translates an offset into the components text to a line number.

getLineSeparator() - Method in class javax.swing.text.AbstractWriter

Returns the string used to represent newlines.

getLineSpacing(AttributeSet) - Static method in class javax.swing.text.StyleConstants

Gets the line spacing setting.

getLineStartOffset(int) - Method in class javax.swing.JTextArea

Determines the offset of the start of the given line.

getLineWidth() - Method in class java.awt.BasicStroke

Returns the line width.

getLineWrap() - Method in class javax.swing.JTextArea

Gets the line-wrapping policy of the text area.

getLink(int) - Method in interface javax.accessibility.AccessibleHypertext

Returns the nth Link of this Hypertext document.

getLink(int) - Method in class javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport

Returns the index into an array of hyperlinks that index.

getLinkCount() - Method in interface javax.accessibility.AccessibleHypertext

Returns the number of links within this hypertext document.

getLinkCount() - Method in class javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport

Returns the number of links within this hypertext doc.

getLinkCursor() - Method in class javax.swing.text.html.HTMLEditorKit

Returns the cursor to use over hyper links.

getLinkedException() - Method in class javax.xml.bind.helpers.ValidationEventImpl

getLinkedException() - Method in exception javax.xml.bind.JAXBException

Get the linked exception

getLinkedException() - Method in exception javax.xml.bind.TypeConstraintException

Get the linked exception

getLinkedException() - Method in interface javax.xml.bind.ValidationEvent

Retrieve the linked exception for this warning/error.

getLinkExplanation() - Method in exception javax.naming.LinkException

Retrieves the explanation associated with the problem encounter when resolving a link.

getLinkIndex(int) - Method in interface javax.accessibility.AccessibleHypertext

Returns the index into an array of hyperlinks that is associated with this character index, or -1 if there is no hyperlink associated with this index.

getLinkIndex(int) - Method in class javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport

Returns the index into an array of hyperlinks that is associated with this character index, or -1 if there is no hyperlink associated with this index.

getLinkName() - Method in class javax.naming.LinkRef

Retrieves the name of this link.

getLinkRemainingName() - Method in exception javax.naming.LinkException

Retrieves the remaining unresolved portion of the link name.

getLinkResolvedName() - Method in exception javax.naming.LinkException

Retrieves the leading portion of the link name that was resolved successfully.

getLinkResolvedObj() - Method in exception javax.naming.LinkException

Retrieves the object to which resolution was successful.

getLinkText(int) - Method in class javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport

Returns the contiguous text within the document that is associated with this hyperlink.

getList() - Method in class javax.swing.plaf.basic.BasicComboPopup

Implementation of ComboPopup.getList().

getList() - Method in interface javax.swing.plaf.basic.ComboPopup

Returns the list that is being used to draw the items in the combo box.

getList() - Method in class javax.swing.SpinnerListModel

Returns the List that defines the sequence for this model.

getListCellRendererComponent(JList<?>, Object, int, boolean, boolean) - Method in class javax.swing.DefaultListCellRenderer

getListCellRendererComponent(JList<? extends E>, E, int, boolean, boolean) - Method in interface javax.swing.ListCellRenderer

Return a component that has been configured to display the specified value.

getListCellRendererComponent(JList, Object, int, boolean, boolean) - Method in class javax.swing.plaf.basic.BasicComboBoxRenderer

getListCellRendererComponent(JList, Object, int, boolean, boolean) - Method in class javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxRenderer

getListDataListeners() - Method in class javax.swing.AbstractListModel

Returns an array of all the list data listeners registered on this AbstractListModel.

getListener() - Method in class java.util.EventListenerProxy

Returns the listener associated with the proxy.

getListener() - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

getListener() - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

getListener() - Method in interface javax.xml.bind.Marshaller

Return Marshaller.Listener registered with this Marshaller.

getListener() - Method in interface javax.xml.bind.Unmarshaller

Return Unmarshaller.Listener registered with this Unmarshaller.

getListenerCount() - Method in class javax.swing.event.EventListenerList

Returns the total number of listeners for this listener list.

getListenerCount(Class<?>) - Method in class javax.swing.event.EventListenerList

Returns the total number of listeners of the supplied type for this listener list.

getListenerID() - Method in class javax.management.remote.TargetedNotification

The ID of the listener to which the notification is targeted.

getListenerList() - Method in class javax.swing.event.EventListenerList

Passes back the event listener list as an array of ListenerType-listener pairs.

getListenerMethodDescriptors() - Method in class java.beans.EventSetDescriptor

Gets the MethodDescriptors of the target listener interface.

getListenerMethodName() - Method in class java.beans.EventHandler

Returns the name of the method that will trigger the action.

getListenerMethods() - Method in class java.beans.EventSetDescriptor

Gets the methods of the target listener interface.

getListeners(EventListener, Class<T>) - Static method in class java.awt.AWTEventMulticaster

Returns an array of all the objects chained as FooListeners by the specified java.util.EventListener.

getListeners(Class<T>) - Method in class java.awt.Button

Returns an array of all the objects currently registered as FooListeners upon this Button.

getListeners(Class<T>) - Method in class java.awt.Checkbox

Returns an array of all the objects currently registered as FooListeners upon this Checkbox.

getListeners(Class<T>) - Method in class java.awt.CheckboxMenuItem

Returns an array of all the objects currently registered as FooListeners upon this CheckboxMenuItem.

getListeners(Class<T>) - Method in class java.awt.Choice

Returns an array of all the objects currently registered as FooListeners upon this Choice.

getListeners(Class<T>) - Method in class java.awt.Component

Returns an array of all the objects currently registered as FooListeners upon this Component.

getListeners(Class<T>) - Method in class java.awt.Container

Returns an array of all the objects currently registered as FooListeners upon this Container.

getListeners(Class<T>) - Method in class java.awt.dnd.DragSource

Gets all the objects currently registered as FooListeners upon this DragSource.

getListeners(Class<T>) - Method in class java.awt.List

Returns an array of all the objects currently registered as FooListeners upon this List.

getListeners(Class<T>) - Method in class java.awt.MenuItem

Returns an array of all the objects currently registered as FooListeners upon this MenuItem.

getListeners(Class<T>) - Method in class java.awt.Scrollbar

Returns an array of all the objects currently registered as FooListeners upon this Scrollbar.

getListeners(Class<T>) - Method in class java.awt.TextComponent

Returns an array of all the objects currently registered as FooListeners upon this TextComponent.

getListeners(Class<T>) - Method in class java.awt.TextField

Returns an array of all the objects currently registered as FooListeners upon this TextField.

getListeners(Class<T>) - Method in class java.awt.Window

Returns an array of all the objects currently registered as FooListeners upon this Window.

getListeners(Class<T>) - Method in class javax.swing.AbstractListModel

Returns an array of all the objects currently registered as FooListeners upon this model.

getListeners(Class<T>) - Method in class javax.swing.AbstractSpinnerModel

Return an array of all the listeners of the given type that were added to this model.

getListeners(Class<T>) - Method in class javax.swing.DefaultBoundedRangeModel

Returns an array of all the objects currently registered as FooListeners upon this model.

getListeners(Class<T>) - Method in class javax.swing.DefaultButtonModel

Returns an array of all the objects currently registered as FooListeners upon this model.

getListeners(Class<T>) - Method in class javax.swing.DefaultListSelectionModel

Returns an array of all the objects currently registered as FooListeners upon this model.

getListeners(Class<T>) - Method in class javax.swing.DefaultSingleSelectionModel

Returns an array of all the objects currently registered as FooListeners upon this model.

getListeners(Class<T>) - Method in class javax.swing.event.EventListenerList

Return an array of all the listeners of the given type.

getListeners(Class<T>) - Method in class javax.swing.JComponent

Returns an array of all the objects currently registered as FooListeners upon this JComponent.

getListeners(Class<T>) - Method in class javax.swing.table.AbstractTableModel

Returns an array of all the objects currently registered as FooListeners upon this AbstractTableModel.

getListeners(Class<T>) - Method in class javax.swing.table.DefaultTableColumnModel

Returns an array of all the objects currently registered as FooListeners upon this model.

getListeners(Class<T>) - Method in class javax.swing.text.AbstractDocument

Returns an array of all the objects currently registered as FooListeners upon this document.

getListeners(Class<T>) - Method in class javax.swing.text.DefaultCaret

Returns an array of all the objects currently registered as FooListeners upon this caret.

getListeners(Class<T>) - Method in class javax.swing.text.StyleContext.NamedStyle

Return an array of all the listeners of the given type that were added to this model.

getListeners(Class<T>) - Method in class javax.swing.Timer

Returns an array of all the objects currently registered as FooListeners upon this Timer.

getListeners(Class<T>) - Method in class javax.swing.tree.DefaultTreeModel

Returns an array of all the objects currently registered as FooListeners upon this model.

getListeners(Class<T>) - Method in class javax.swing.tree.DefaultTreeSelectionModel

Returns an array of all the objects currently registered as FooListeners upon this model.

getListenerType() - Method in class java.beans.EventSetDescriptor

Gets the Class object for the target interface.

getListPainter(AttributeSet) - Method in class javax.swing.text.html.StyleSheet

Fetches the list formatter to use for the given set of CSS attributes.

getListSelectionListeners() - Method in class javax.swing.DefaultListSelectionModel

Returns an array of all the list selection listeners registered on this DefaultListSelectionModel.

getListSelectionListeners() - Method in class javax.swing.JList

Returns an array of all the ListSelectionListeners added to this JList by way of addListSelectionListener.

getLoadedClassCount() - Method in interface java.lang.management.ClassLoadingMXBean

Returns the number of classes that are currently loaded in the Java virtual machine.

getLoadedInstruments() - Method in interface javax.sound.midi.Synthesizer

Obtains a list of the instruments that are currently loaded onto this Synthesizer.

getLoadingImageIcon() - Method in class javax.swing.text.html.ImageView

Returns the icon to use while in the process of loading the image.

getLoadsSynchronously() - Method in class javax.swing.text.html.ImageView

Returns true if the image should be loaded when first asked for.

getLocalAddress() - Method in class java.net.DatagramSocket

Gets the local address to which the socket is bound.

getLocalAddress() - Method in class java.net.Socket

Gets the local address to which the socket is bound.

getLocalAddress() - Method in class java.nio.channels.AsynchronousServerSocketChannel

Returns the socket address that this channel's socket is bound to.

getLocalAddress() - Method in class java.nio.channels.AsynchronousSocketChannel

Returns the socket address that this channel's socket is bound to.

getLocalAddress() - Method in class java.nio.channels.DatagramChannel

Returns the socket address that this channel's socket is bound to.

getLocalAddress() - Method in interface java.nio.channels.NetworkChannel

Returns the socket address that this channel's socket is bound to.

getLocalAddress() - Method in class java.nio.channels.ServerSocketChannel

Returns the socket address that this channel's socket is bound to.

getLocalAddress() - Method in class java.nio.channels.SocketChannel

Returns the socket address that this channel's socket is bound to.

getLocalAddress() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns the unresolved local address on which the request was received.

getLocalBounds(Component) - Static method in class javax.swing.SwingUtilities

Return the rectangle (0,0,bounds.width,bounds.height) for the component aComponent

getLocalCertificateChain() - Method in class java.net.SecureCacheResponse

Returns the certificate chain that were sent to the server during handshaking of the original connection that retrieved the network resource.

getLocalCertificates() - Method in class javax.net.ssl.HandshakeCompletedEvent

Returns the certificate(s) that were sent to the peer during handshaking.

getLocalCertificates() - Method in class javax.net.ssl.HttpsURLConnection

Returns the certificate(s) that were sent to the server during handshaking.

getLocalCertificates() - Method in interface javax.net.ssl.SSLSession

Returns the certificate(s) that were sent to the peer during handshaking.

getLocale() - Method in class java.applet.Applet

Gets the locale of the applet.

getLocale() - Method in class java.awt.Component.AccessibleAWTComponent

Returns the locale of this object.

getLocale() - Method in class java.awt.Component

Gets the locale of this component.

getLocale() - Method in class java.awt.im.InputContext

Returns the current locale of the current input method or keyboard layout.

getLocale() - Method in interface java.awt.im.spi.InputMethod

Returns the current input locale.

getLocale() - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Gets the locale of the component.

getLocale() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Returns the locale of this object.

getLocale() - Method in class java.awt.Window

Gets the Locale object that is associated with this window, if the locale has been set.

getLocale() - Method in class java.beans.beancontext.BeanContextSupport

Gets the locale for this BeanContext.

getLocale() - Method in class java.text.MessageFormat

Gets the locale that's used when creating or comparing subformats.

getLocale() - Method in class java.time.format.DateTimeFormatter

Gets the locale to be used during formatting.

getLocale() - Method in class java.util.ResourceBundle

Returns the locale of this resource bundle.

getLocale() - Method in class javax.accessibility.AccessibleContext

Gets the locale of the component.

getLocale() - Method in interface javax.annotation.processing.ProcessingEnvironment

Returns the current locale or null if no locale is in effect.

getLocale() - Method in class javax.imageio.ImageReader

Returns the currently set Locale, or null if none has been set.

getLocale() - Method in class javax.imageio.ImageWriteParam

Returns the currently set Locale, or null if only a default Locale is supported.

getLocale() - Method in class javax.imageio.ImageWriter

Returns the currently set Locale, or null if none has been set.

getLocale() - Method in class javax.print.attribute.TextSyntax

Returns this text attribute's text string's natural language (locale).

getLocale() - Method in class javax.security.auth.callback.LanguageCallback

Get the retrieved Locale.

getLocale() - Method in class javax.swing.ImageIcon.AccessibleImageIcon

Returns the locale of this object.

getLocale() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getLocale() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the locale of the component.

getLocale() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Gets the locale of the component.

getLocale() - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Gets the locale of the component.

getLocale() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getLocalGraphicsEnvironment() - Static method in class java.awt.GraphicsEnvironment

Returns the local GraphicsEnvironment.

getLocalHost() - Static method in class java.net.InetAddress

Returns the address of the local host.

getLocalizedCompressionTypeName() - Method in class javax.imageio.ImageWriteParam

Returns a localized version of the name of the current compression type, using the Locale returned by getLocale.

getLocalizedDateTimePattern(FormatStyle, FormatStyle, Chronology, Locale) - Static method in class java.time.format.DateTimeFormatterBuilder

Gets the formatting pattern for date and time styles for a locale and chronology.

getLocalizedInputStream(InputStream) - Method in class java.lang.Runtime

Deprecated.
As of JDK 1.1, the preferred way to translate a byte stream in the local encoding into a character stream in Unicode is via the InputStreamReader and BufferedReader classes.

getLocalizedMessage() - Method in class java.lang.Throwable

Creates a localized description of this throwable.

getLocalizedName() - Method in class java.util.logging.Level

Return the localized string name of the Level, for the current default locale.

getLocalizedOutputStream(OutputStream) - Method in class java.lang.Runtime

Deprecated.
As of JDK 1.1, the preferred way to translate a Unicode character stream into a byte stream in the local encoding is via the OutputStreamWriter, BufferedWriter, and PrintWriter classes.

getLocalName() - Method in class javax.imageio.metadata.IIOMetadataNode

Equivalent to getNodeName.

getLocalName() - Method in interface javax.xml.soap.Name

Gets the local name part of the XML name that this Name object represents.

getLocalName() - Method in class javax.xml.stream.util.StreamReaderDelegate

getLocalName() - Method in interface javax.xml.stream.XMLStreamReader

Returns the (local) name of the current event.

getLocalName() - Method in interface org.w3c.dom.Node

Returns the local part of the qualified name of this node.

getLocalName(int) - Method in interface org.xml.sax.Attributes

Look up an attribute's local name by index.

getLocalName(int) - Method in class org.xml.sax.helpers.AttributesImpl

Return an attribute's local name.

getLocalPart() - Method in class javax.xml.namespace.QName

Get the local part of this QName.

getLocalPatternChars() - Method in class java.text.DateFormatSymbols

Gets localized date-time pattern characters.

getLocalPort() - Method in class java.net.DatagramSocket

Returns the port number on the local host to which this socket is bound.

getLocalPort() - Method in class java.net.DatagramSocketImpl

Gets the local port.

getLocalPort() - Method in class java.net.ServerSocket

Returns the port number on which this socket is listening.

getLocalPort() - Method in class java.net.Socket

Returns the local port number to which this socket is bound.

getLocalPort() - Method in class java.net.SocketImpl

Returns the value of this socket's localport field.

getLocalPrincipal() - Method in class java.net.SecureCacheResponse

Returns the principal that was sent to the server during handshaking in the original connection that retrieved the network resource.

getLocalPrincipal() - Method in class javax.net.ssl.HandshakeCompletedEvent

Returns the principal that was sent to the peer during handshaking.

getLocalPrincipal() - Method in class javax.net.ssl.HttpsURLConnection

Returns the principal that was sent to the server during handshaking.

getLocalPrincipal() - Method in interface javax.net.ssl.SSLSession

Returns the principal that was sent to the peer during handshaking.

getLocalSocketAddress() - Method in class java.net.DatagramSocket

Returns the address of the endpoint this socket is bound to.

getLocalSocketAddress() - Method in class java.net.ServerSocket

Returns the address of the endpoint this socket is bound to.

getLocalSocketAddress() - Method in class java.net.Socket

Returns the address of the endpoint this socket is bound to.

getLocalSupportedSignatureAlgorithms() - Method in class javax.net.ssl.ExtendedSSLSession

Obtains an array of supported signature algorithms that the local side is willing to use.

getLocalTime() - Method in class java.time.zone.ZoneOffsetTransitionRule

Gets the local time of day of the transition which must be checked with ZoneOffsetTransitionRule.isMidnightEndOfDay().

getLocation() - Method in class java.awt.Component.AccessibleAWTComponent

Gets the location of the object relative to the parent in the form of a point specifying the object's top-left corner in the screen's coordinate space.

getLocation() - Method in class java.awt.Component

Gets the location of this component in the form of a point specifying the component's top-left corner.

getLocation(Point) - Method in class java.awt.Component

Stores the x,y origin of this component into "return value" rv and return rv.

getLocation() - Method in class java.awt.dnd.DragSourceEvent

This method returns a Point indicating the cursor location in screen coordinates at the moment this event occurred, or null if the cursor location is not specified for this event.

getLocation() - Method in class java.awt.dnd.DropTargetDragEvent

This method returns a Point indicating the Cursor's current location within the Component's coordinates.

getLocation() - Method in class java.awt.dnd.DropTargetDropEvent

This method returns a Point indicating the Cursor's current location in the Component's coordinates.

getLocation() - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Gets the location of the object relative to the parent in the form of a point specifying the object's top-left corner in the screen's coordinate space.

getLocation() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Gets the location of the object relative to the parent in the form of a point specifying the object's top-left corner in the screen's coordinate space.

getLocation() - Method in class java.awt.Point

Returns the location of this point.

getLocation() - Method in class java.awt.PointerInfo

Returns the Point that represents the coordinates of the pointer on the screen.

getLocation() - Method in class java.awt.Rectangle

Returns the location of this Rectangle.

getLocation() - Method in exception java.net.HttpRetryException

Returns the value of the Location header field if the error resulted from redirection.

getLocation() - Method in class java.rmi.activation.ActivationDesc

Returns the code location for the object specified by this descriptor.

getLocation() - Method in class java.rmi.activation.ActivationGroupDesc

Returns the group's code location.

getLocation() - Method in class java.security.CodeSource

Returns the location associated with this CodeSource.

getLocation() - Method in interface javax.accessibility.AccessibleComponent

Gets the location of the object relative to the parent in the form of a point specifying the object's top-left corner in the screen's coordinate space.

getLocation(Point) - Method in class javax.swing.JComponent

Stores the x,y origin of this component into "return value" rv and returns rv.

getLocation() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getLocation() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Gets the location of the object relative to the parent in the form of a point specifying the object's top-left corner in the screen's coordinate space.

getLocation() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

getLocation() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getLocation(JavaFileManager.Location) - Method in interface javax.tools.StandardJavaFileManager

Gets the path associated with the given location.

getLocation() - Method in interface javax.xml.stream.events.XMLEvent

Return the location of this event.

getLocation() - Method in class javax.xml.stream.util.StreamReaderDelegate

getLocation() - Method in exception javax.xml.stream.XMLStreamException

Gets the location of the exception

getLocation() - Method in interface javax.xml.stream.XMLStreamReader

Return the current location of the processor.

getLocation() - Method in interface org.w3c.dom.DOMError

The location of the error.

getLocationAsString() - Method in exception javax.xml.transform.TransformerException

Get the location information as a string.

getLocationInJTree() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

getLocationOffset(int, int) - Method in interface java.awt.im.InputMethodRequests

Gets the offset within the composed text for the specified absolute x and y coordinates on the screen.

getLocationOnScreen() - Method in class java.awt.Component.AccessibleAWTComponent

Returns the location of the object on the screen.

getLocationOnScreen() - Method in class java.awt.Component

Gets the location of this component in the form of a point specifying the component's top-left corner in the screen's coordinate space.

getLocationOnScreen() - Method in class java.awt.event.MouseEvent

Returns the absolute x, y position of the event.

getLocationOnScreen() - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Returns the location of the object on the screen.

getLocationOnScreen() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Returns the location of the object on the screen.

getLocationOnScreen() - Method in interface javax.accessibility.AccessibleComponent

Returns the location of the object on the screen.

getLocationOnScreen() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getLocationOnScreen() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Returns the location of the object on the screen.

getLocationOnScreen() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

getLocationOnScreen() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getLocator() - Method in class javax.xml.bind.helpers.ValidationEventImpl

getLocator() - Method in interface javax.xml.bind.ValidationEvent

Retrieve the locator for this warning/error.

getLocator() - Method in exception javax.xml.transform.TransformerException

Method getLocator retrieves an instance of a SourceLocator object that specifies where an error occured.

getLockedMonitors() - Method in class java.lang.management.ThreadInfo

Returns an array of MonitorInfo objects, each of which represents an object monitor currently locked by the thread associated with this ThreadInfo.

getLockedStackDepth() - Method in class java.lang.management.MonitorInfo

Returns the depth in the stack trace where the object monitor was locked.

getLockedStackFrame() - Method in class java.lang.management.MonitorInfo

Returns the stack frame that locked the object monitor.

getLockedSynchronizers() - Method in class java.lang.management.ThreadInfo

Returns an array of LockInfo objects, each of which represents an ownable synchronizer currently locked by the thread associated with this ThreadInfo.

getLockInfo() - Method in class java.lang.management.ThreadInfo

Returns the LockInfo of an object for which the thread associated with this ThreadInfo is blocked waiting.

getLockingKeyState(int) - Method in class java.awt.Toolkit

Returns whether the given locking key on the keyboard is currently in its "on" state.

getLockName() - Method in class java.lang.management.ThreadInfo

Returns the string representation of an object for which the thread associated with this ThreadInfo is blocked waiting.

getLockOwnerId() - Method in class java.lang.management.ThreadInfo

Returns the ID of the thread which owns the object for which the thread associated with this ThreadInfo is blocked waiting.

getLockOwnerName() - Method in class java.lang.management.ThreadInfo

Returns the name of the thread which owns the object for which the thread associated with this ThreadInfo is blocked waiting.

getLog() - Static method in class java.rmi.server.RemoteServer

Returns stream for the RMI call log.

getLogger(String) - Static method in class java.util.logging.Logger

Find or create a logger for a named subsystem.

getLogger(String, String) - Static method in class java.util.logging.Logger

Find or create a logger for a named subsystem.

getLogger(String) - Method in class java.util.logging.LogManager

Method to find a named logger.

getLogger() - Static method in class javax.sql.rowset.spi.SyncFactory

Returns the logging object for applications to retrieve synchronization events posted by SyncProvider implementations.

getLoggerLevel(String) - Method in interface java.lang.management.PlatformLoggingMXBean

Gets the name of the log level associated with the specified logger.

getLoggerLevel(String) - Method in interface java.util.logging.LoggingMXBean

Gets the name of the log level associated with the specified logger.

getLoggerName() - Method in class java.util.logging.LogRecord

Get the source Logger's name.

getLoggerNames() - Method in interface java.lang.management.PlatformLoggingMXBean

Returns the list of the currently registered logger names.

getLoggerNames() - Method in interface java.util.logging.LoggingMXBean

Returns the list of currently registered logger names.

getLoggerNames() - Method in class java.util.logging.LogManager

Get an enumeration of known logger names.

getLoggingMXBean() - Static method in class java.util.logging.LogManager

Returns LoggingMXBean for managing loggers.

getLogicalBounds() - Method in class java.awt.font.GlyphVector

Returns the logical bounds of this GlyphVector.

getLogicalHighlightShape(int, int, Rectangle2D) - Method in class java.awt.font.TextLayout

Returns a Shape enclosing the logical selection in the specified range, extended to the specified bounds.

getLogicalHighlightShape(int, int) - Method in class java.awt.font.TextLayout

Returns a Shape enclosing the logical selection in the specified range, extended to the natural bounds of this TextLayout.

getLogicalRangesForVisualSelection(TextHitInfo, TextHitInfo) - Method in class java.awt.font.TextLayout

Returns the logical ranges of text corresponding to a visual selection.

getLogicalStyle() - Method in class javax.swing.JTextPane

Fetches the logical style assigned to the paragraph represented by the current position of the caret, or null.

getLogicalStyle(int) - Method in class javax.swing.text.DefaultStyledDocument

Fetches the logical style assigned to the paragraph represented by the given position.

getLogicalStyle(int) - Method in interface javax.swing.text.StyledDocument

Gets a logical style for a given position in a paragraph.

getLogicalView(FlowView) - Method in class javax.swing.text.FlowView.FlowStrategy

This method gives flow strategies access to the logical view of the FlowView.

getLoginModuleName() - Method in class javax.security.auth.login.AppConfigurationEntry

Get the class name of the configured LoginModule.

getLoginTimeout() - Static method in class java.sql.DriverManager

Gets the maximum time in seconds that a driver can wait when attempting to log in to a database.

getLoginTimeout() - Method in interface javax.sql.CommonDataSource

Gets the maximum time in seconds that this data source can wait while attempting to connect to a database.

getLogManager() - Static method in class java.util.logging.LogManager

Returns the global LogManager object.

getLogStream() - Static method in class java.sql.DriverManager

Deprecated.
Use getLogWriter

getLogTimers() - Static method in class javax.swing.Timer

Returns true if logging is enabled.

getLogWriter() - Static method in class java.sql.DriverManager

Retrieves the log writer.

getLogWriter() - Method in interface javax.sql.CommonDataSource

Retrieves the log writer for this DataSource object.

getLong(String) - Static method in class java.lang.Long

Determines the long value of the system property with the specified name.

getLong(String, long) - Static method in class java.lang.Long

Determines the long value of the system property with the specified name.

getLong(String, Long) - Static method in class java.lang.Long

Returns the long value of the system property with the specified name.

getLong(Object, int) - Static method in class java.lang.reflect.Array

Returns the value of the indexed component in the specified array object, as a long.

getLong(Object) - Method in class java.lang.reflect.Field

Gets the value of a static or instance field of type long or of another primitive type convertible to type long via a widening conversion.

getLong() - Method in class java.nio.ByteBuffer

Relative get method for reading a long value.

getLong(int) - Method in class java.nio.ByteBuffer

Absolute get method for reading a long value.

getLong(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC BIGINT parameter as a long in the Java programming language.

getLong(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC BIGINT parameter as a long in the Java programming language.

getLong(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a long in the Java programming language.

getLong(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a long in the Java programming language.

getLong(TemporalField) - Method in interface java.time.chrono.ChronoZonedDateTime

getLong(TemporalField) - Method in interface java.time.chrono.Era

Gets the value of the specified field from this era as a long.

getLong(TemporalField) - Method in class java.time.chrono.HijrahDate

getLong(TemporalField) - Method in class java.time.chrono.JapaneseDate

getLong(TemporalField) - Method in class java.time.chrono.MinguoDate

getLong(TemporalField) - Method in class java.time.chrono.ThaiBuddhistDate

getLong(TemporalField) - Method in enum java.time.DayOfWeek

Gets the value of the specified field from this day-of-week as a long.

getLong(TemporalField) - Method in class java.time.Instant

Gets the value of the specified field from this instant as a long.

getLong(TemporalField) - Method in class java.time.LocalDate

Gets the value of the specified field from this date as a long.

getLong(TemporalField) - Method in class java.time.LocalDateTime

Gets the value of the specified field from this date-time as a long.

getLong(TemporalField) - Method in class java.time.LocalTime

Gets the value of the specified field from this time as a long.

getLong(TemporalField) - Method in enum java.time.Month

Gets the value of the specified field from this month-of-year as a long.

getLong(TemporalField) - Method in class java.time.MonthDay

Gets the value of the specified field from this month-day as a long.

getLong(TemporalField) - Method in class java.time.OffsetDateTime

Gets the value of the specified field from this date-time as a long.

getLong(TemporalField) - Method in class java.time.OffsetTime

Gets the value of the specified field from this time as a long.

getLong(TemporalField) - Method in interface java.time.temporal.TemporalAccessor

Gets the value of the specified field as a long.

getLong(TemporalField) - Method in class java.time.Year

Gets the value of the specified field from this year as a long.

getLong(TemporalField) - Method in class java.time.YearMonth

Gets the value of the specified field from this year-month as a long.

getLong(TemporalField) - Method in class java.time.ZonedDateTime

Gets the value of the specified field from this date-time as a long.

getLong(TemporalField) - Method in class java.time.ZoneOffset

Gets the value of the specified field from this offset as a long.

getLong(String, long) - Method in class java.util.prefs.AbstractPreferences

Implements the getLong method as per the specification in Preferences.getLong(String,long).

getLong(String, long) - Method in class java.util.prefs.Preferences

Returns the long value represented by the string associated with the specified key in this preference node.

getLongFramePosition() - Method in interface javax.sound.sampled.DataLine

Obtains the current position in the audio data, in sample frames.

getLongParameter(int) - Method in class java.awt.image.renderable.ParameterBlock

A convenience method to return a parameter as a long.

getLookAndFeel() - Static method in class javax.swing.UIManager

Returns the current look and feel or null.

getLookAndFeelDefaults() - Static method in class javax.swing.UIManager

Returns the UIDefaults from the current look and feel, that were obtained at the time the look and feel was installed.

getLoopbackAddress() - Static method in class java.net.InetAddress

Returns the loopback address.

getLoopbackMode() - Method in class java.net.MulticastSocket

Get the setting for local loopback of multicast datagrams.

getLoopCount() - Method in interface javax.sound.midi.Sequencer

Obtains the number of repetitions for playback.

getLoopEndPoint() - Method in interface javax.sound.midi.Sequencer

Obtains the end position of the loop, in MIDI ticks.

getLoopStartPoint() - Method in interface javax.sound.midi.Sequencer

Obtains the start position of the loop, in MIDI ticks.

getLowerBound() - Method in interface javax.lang.model.type.TypeVariable

Returns the lower bound of this type variable.

getLowerBounds() - Method in interface java.lang.reflect.WildcardType

Returns an array of Type objects representing the lower bound(s) of this type variable.

getLoweredBevelBorderUIResource() - Static method in class javax.swing.plaf.BorderUIResource

getLowestSetBit() - Method in class java.math.BigInteger

Returns the index of the rightmost (lowest-order) one bit in this BigInteger (the number of zero bits to the right of the rightmost one bit).

getLowestValue() - Method in class javax.swing.plaf.basic.BasicSliderUI

Returns the smallest value that has an entry in the label table.

getLowestValueLabel() - Method in class javax.swing.plaf.basic.BasicSliderUI

Returns the label that corresponds to the highest slider value in the label table.

getLowThreshold() - Method in class javax.management.monitor.GaugeMonitor

Gets the low threshold value common to all observed MBeans.

getLowThreshold() - Method in interface javax.management.monitor.GaugeMonitorMBean

Gets the low threshold value.

getLSB() - Method in class java.awt.font.GlyphMetrics

Returns the left (top) side bearing of the glyph.

getM() - Method in class java.security.spec.ECFieldF2m

Returns the value m of this characteristic 2 finite field.

getMacLength() - Method in class javax.crypto.Mac

Returns the length of the MAC in bytes.

getMagicCaretPosition() - Method in interface javax.swing.text.Caret

Gets the current caret visual location.

getMagicCaretPosition() - Method in class javax.swing.text.DefaultCaret

Gets the saved caret position.

getMainAttributes() - Method in class java.net.JarURLConnection

Returns the main Attributes for the JAR file for this connection.

getMainAttributes() - Method in class java.util.jar.Manifest

Returns the main Attributes for the Manifest.

getMajor() - Method in exception org.ietf.jgss.GSSException

Returns the GSS-API level major error code for the problem causing this exception to be thrown.

getMajorAxis() - Method in class javax.swing.text.AsyncBoxView

Fetch the major axis (the axis the children are tiled along).

getMajorOffset() - Method in class javax.swing.text.AsyncBoxView.ChildState

Get the offset along the major axis

getMajorSpan() - Method in class javax.swing.text.AsyncBoxView.ChildState

What is the span along the major axis.

getMajorString() - Method in exception org.ietf.jgss.GSSException

Returns a string explaining the GSS-API level major error code in this exception.

getMajorTickSpacing() - Method in class javax.swing.JSlider

This method returns the major tick spacing.

getMajorVersion() - Method in class java.awt.color.ICC_Profile

Returns profile major version.

getMajorVersion() - Method in interface java.sql.Driver

Retrieves the driver's major version number.

getManagementSpecVersion() - Method in interface java.lang.management.RuntimeMXBean

Returns the version of the specification for the management interface implemented by the running Java virtual machine.

getManifest() - Method in class java.net.JarURLConnection

Returns the Manifest for this connection, or null if none.

getManifest() - Method in class java.util.jar.JarFile

Returns the jar file manifest, or null if none.

getManifest() - Method in class java.util.jar.JarInputStream

Returns the Manifest for this JAR file, or null if none.

getMappedValue() - Method in class java.util.concurrent.ConcurrentHashMap.KeySetView

Returns the default mapped value for additions, or null if additions are not supported.

getMapSize() - Method in class java.awt.image.IndexColorModel

Returns the size of the color/alpha component arrays in this IndexColorModel.

getMargin() - Method in class javax.swing.AbstractButton

Returns the margin between the button's border and the label.

getMargin() - Method in class javax.swing.JMenuBar

Returns the margin between the menubar's border and its menus.

getMargin() - Method in class javax.swing.JPopupMenu

Returns the margin, in pixels, between the popup menu's border and its containers.

getMargin() - Method in class javax.swing.JToolBar

Returns the margin between the tool bar's border and its buttons.

getMargin() - Method in class javax.swing.text.JTextComponent

Returns the margin between the text component's border and its text.

getMark() - Method in class javax.swing.event.CaretEvent

Fetches the location of other end of a logical selection.

getMark() - Method in interface javax.swing.text.Caret

Fetches the current position of the mark.

getMark() - Method in class javax.swing.text.DefaultCaret

Fetches the current position of the mark.

getMarkBias() - Method in class javax.swing.text.DefaultCaret

Returns the bias of the mark.

getMask(int) - Method in class java.awt.image.PackedColorModel

Returns the mask indicating which bits in a pixel contain the specified color/alpha sample.

getMask() - Method in class javax.swing.text.MaskFormatter

Returns the formatting mask.

getMaskForButton(int) - Static method in class java.awt.event.InputEvent

A method to obtain a mask for any existing mouse button.

getMasks() - Method in class java.awt.image.PackedColorModel

Returns a mask array indicating which bits in a pixel contain the color and alpha samples.

getMasterSyncMode() - Method in interface javax.sound.midi.Sequencer

Obtains the current master synchronization mode for this sequencer.

getMasterSyncModes() - Method in interface javax.sound.midi.Sequencer

Obtains the set of master synchronization modes supported by this sequencer.

getMatchAllSubjectAltNames() - Method in class java.security.cert.X509CertSelector

Indicates if the X509Certificate must contain all or at least one of the subjectAlternativeNames specified in the setSubjectAlternativeNames or addSubjectAlternativeName methods.

getMatchColumnIndexes() - Method in interface javax.sql.rowset.Joinable

Retrieves the indexes of the match columns that were set for this RowSet object with the method setMatchColumn(int[] columnIdxes).

getMatchColumnNames() - Method in interface javax.sql.rowset.Joinable

Retrieves the names of the match columns that were set for this RowSet object with the method setMatchColumn(String [] columnNames).

getMatchingHeaders(String[]) - Method in class javax.xml.soap.MimeHeaders

Returns all the MimeHeader objects whose name matches a name in the given array of names.

getMatchingMimeHeaders(String[]) - Method in class javax.xml.soap.AttachmentPart

Retrieves all MimeHeader objects that match a name in the given array.

getMatchingMimeHeaders(String[]) - Method in class javax.xml.soap.SOAPPart

Retrieves all MimeHeader objects that match a name in the given array.

getMatchingRuleID() - Method in class javax.naming.ldap.SortKey

Retrieves the matching rule ID used to order the attribute values.

getMatrix() - Method in class java.awt.color.ICC_ProfileRGB

Returns a 3x3 float matrix constructed from the X, Y, and Z components of the profile's redColorantTag, greenColorantTag, and blueColorantTag.

getMatrix(double[]) - Method in class java.awt.geom.AffineTransform

Retrieves the 6 specifiable values in the 3x3 affine transformation matrix and places them into an array of double precisions values.

getMatrix() - Method in class java.awt.image.BandCombineOp

Returns a copy of the linear combination matrix.

getMatrix() - Method in class java.awt.print.PageFormat

Returns a transformation matrix that translates user space rendering to the requested orientation of the page.

getMatteColor() - Method in class javax.swing.border.MatteBorder

Returns the color used for tiling the border or null if a tile icon is being used.

getMax() - Method in class java.lang.management.MemoryUsage

Returns the maximum amount of memory in bytes that can be used for memory management.

getMax() - Method in class java.util.DoubleSummaryStatistics

Returns the maximum recorded value, Double.NaN if any recorded value was NaN or Double.NEGATIVE_INFINITY if no values were recorded.

getMax() - Method in class java.util.IntSummaryStatistics

Returns the maximum value recorded, or Integer.MIN_VALUE if no values have been recorded.

getMax() - Method in class java.util.LongSummaryStatistics

Returns the maximum value recorded, or Long.MIN_VALUE if no values have been recorded

getMaxAdvance() - Method in class java.awt.FontMetrics

Gets the maximum advance width of any character in this Font.

getMaxAge() - Method in class java.net.HttpCookie

Returns the maximum age of the cookie, specified in seconds.

getMaxAllowedKeyLength(String) - Static method in class javax.crypto.Cipher

Returns the maximum key length for the specified transformation according to the installed JCE jurisdiction policy files.

getMaxAllowedParameterSpec(String) - Static method in class javax.crypto.Cipher

Returns an AlgorithmParameterSpec object which contains the maximum cipher parameter value according to the jurisdiction policy file.

getMaxAscent() - Method in class java.awt.FontMetrics

Determines the maximum ascent of the Font described by this FontMetrics object.

getMaxBinaryLiteralLength() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of hex characters this database allows in an inline binary literal.

getMaxBufferSize() - Method in class javax.sound.sampled.DataLine.Info

Obtains the maximum buffer size supported by the data line.

getMaxCatalogNameLength() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of characters that this database allows in a catalog name.

getMaxCharactersPerLineCount() - Method in class javax.swing.JOptionPane

Returns the maximum number of characters to place on a line in a message.

getMaxCharactersPerLineCount() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI

Returns the maximum number of characters to place on a line.

getMaxCharBounds(FontRenderContext) - Method in class java.awt.Font

Returns the bounds for the character with the maximum bounds as defined in the specified FontRenderContext.

getMaxCharBounds(Graphics) - Method in class java.awt.FontMetrics

Returns the bounds for the character with the maximum bounds in the specified Graphics context.

getMaxCharLiteralLength() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of characters this database allows for a character literal.

getMaxColumnNameLength() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of characters this database allows for a column name.

getMaxColumnsInGroupBy() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of columns this database allows in a GROUP BY clause.

getMaxColumnsInIndex() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of columns this database allows in an index.

getMaxColumnsInOrderBy() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of columns this database allows in an ORDER BY clause.

getMaxColumnsInSelect() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of columns this database allows in a SELECT list.

getMaxColumnsInTable() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of columns this database allows in a table.

getMaxConnections() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of concurrent connections to this database that are possible.

getMaxCRL() - Method in class java.security.cert.X509CRLSelector

Returns the maxCRLNumber criterion.

getMaxCursorNameLength() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of characters that this database allows in a cursor name.

getMaxDecent() - Method in class java.awt.FontMetrics

Deprecated.
As of JDK version 1.1.1, replaced by getMaxDescent().

getMaxDegree() - Method in class javax.management.relation.RoleInfo

Returns maximum degree for corresponding role reference.

getMaxDescent() - Method in class java.awt.FontMetrics

Determines the maximum descent of the Font described by this FontMetrics object.

getMaxExpansion(int) - Method in class java.text.CollationElementIterator

Return the maximum length of any expansion sequences that end with the specified comparison order.

getMaxFieldSize() - Method in interface java.sql.Statement

Retrieves the maximum number of bytes that can be returned for character and binary column values in a ResultSet object produced by this Statement object.

getMaxFieldSize() - Method in class javax.sql.rowset.BaseRowSet

Retrieves the maximum number of bytes that can be used for a column value in this RowSet object.

getMaxFieldSize() - Method in interface javax.sql.RowSet

Retrieves the maximum number of bytes that may be returned for certain column values.

getMaximizedBounds() - Method in class java.awt.Frame

Gets maximized bounds for this frame.

getMaximum() - Method in interface java.awt.Adjustable

Gets the maximum value of the adjustable object.

getMaximum() - Method in class java.awt.Scrollbar

Gets the maximum value of this scroll bar.

getMaximum() - Method in class java.awt.ScrollPaneAdjustable

getMaximum() - Method in class java.time.temporal.ValueRange

Gets the maximum value that the field can take.

getMaximum(int) - Method in class java.util.Calendar

Returns the maximum value for the given calendar field of this Calendar instance.

getMaximum(int) - Method in class java.util.GregorianCalendar

Returns the maximum value for the given calendar field of this GregorianCalendar instance.

getMaximum() - Method in class javax.sound.sampled.FloatControl

Obtains the maximum value permitted.

getMaximum() - Method in interface javax.swing.BoundedRangeModel

Returns the model's maximum.

getMaximum() - Method in class javax.swing.DefaultBoundedRangeModel

Returns the model's maximum.

getMaximum() - Method in class javax.swing.JProgressBar

Returns the progress bar's maximum value from the BoundedRangeModel.

getMaximum() - Method in class javax.swing.JScrollBar

The maximum value of the scrollbar is maximum - extent.

getMaximum() - Method in class javax.swing.JSlider

Returns the maximum value supported by the slider from the BoundedRangeModel.

getMaximum() - Method in class javax.swing.ProgressMonitor

Returns the maximum value -- the higher end of the progress value.

getMaximum() - Method in class javax.swing.SpinnerNumberModel

Returns the last number in the sequence.

getMaximum() - Method in class javax.swing.text.InternationalFormatter

Returns the maximum permissible value.

getMaximumAccessibleValue() - Method in class java.awt.Button.AccessibleAWTButton

Get the maximum value of this object as a Number.

getMaximumAccessibleValue() - Method in class java.awt.Checkbox.AccessibleAWTCheckbox

Get the maximum value of this object as a Number.

getMaximumAccessibleValue() - Method in class java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem

Get the maximum value of this object as a Number.

getMaximumAccessibleValue() - Method in class java.awt.MenuItem.AccessibleAWTMenuItem

Get the maximum value of this object as a Number.

getMaximumAccessibleValue() - Method in class java.awt.Scrollbar.AccessibleAWTScrollBar

Get the maximum accessible value of this object.

getMaximumAccessibleValue() - Method in interface javax.accessibility.AccessibleValue

Get the maximum value of this object as a Number.

getMaximumAccessibleValue() - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Get the maximum value of this object as a Number.

getMaximumAccessibleValue() - Method in class javax.swing.JInternalFrame.AccessibleJInternalFrame

Get the maximum value of this object as a Number.

getMaximumAccessibleValue() - Method in class javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon

Gets the maximum value of this object as a Number.

getMaximumAccessibleValue() - Method in class javax.swing.JProgressBar.AccessibleJProgressBar

Gets the maximum accessible value of this object.

getMaximumAccessibleValue() - Method in class javax.swing.JScrollBar.AccessibleJScrollBar

Get the maximum accessible value of this object.

getMaximumAccessibleValue() - Method in class javax.swing.JSlider.AccessibleJSlider

Get the maximum accessible value of this object.

getMaximumAccessibleValue() - Method in class javax.swing.JSpinner.AccessibleJSpinner

Get the maximum value of this object as a Number.

getMaximumAccessibleValue() - Method in class javax.swing.JSplitPane.AccessibleJSplitPane

Gets the maximum accessible value of this object.

getMaximumCharHeight(SynthContext) - Method in class javax.swing.plaf.synth.SynthGraphicsUtils

Returns the maximum height of the the Font from the passed in SynthContext.

getMaximumCursorColors() - Method in class java.awt.Toolkit

Returns the maximum number of colors the Toolkit supports in a custom cursor palette.

getMaximumDividerLocation() - Method in class javax.swing.JSplitPane

Returns the maximum location of the divider from the look and feel implementation.

getMaximumDividerLocation(JSplitPane) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI

Gets the maximum location of the divider.

getMaximumDividerLocation(JSplitPane) - Method in class javax.swing.plaf.multi.MultiSplitPaneUI

Invokes the getMaximumDividerLocation method on each UI handled by this object.

getMaximumDividerLocation(JSplitPane) - Method in class javax.swing.plaf.SplitPaneUI

Returns the maximum possible location of the divider.

getMaximumFractionDigits() - Method in class java.text.DecimalFormat

Gets the maximum number of digits allowed in the fraction portion of a number.

getMaximumFractionDigits() - Method in class java.text.NumberFormat

Returns the maximum number of digits allowed in the fraction portion of a number.

getMaximumIntegerDigits() - Method in class java.text.DecimalFormat

Gets the maximum number of digits allowed in the integer portion of a number.

getMaximumIntegerDigits() - Method in class java.text.NumberFormat

Returns the maximum number of digits allowed in the integer portion of a number.

getMaximumPoolSize() - Method in class java.util.concurrent.ThreadPoolExecutor

Returns the maximum allowed number of threads.

getMaximumRowCount() - Method in class javax.swing.JComboBox

Returns the maximum number of items the combo box can display without a scrollbar

getMaximumSize() - Method in class java.awt.Component

Gets the maximum size of this component.

getMaximumSize() - Method in class java.awt.Container

Returns the maximum size of this container.

getMaximumSize() - Method in class javax.swing.JComponent

If the maximum size has been set to a non-null value just returns it.

getMaximumSize() - Method in class javax.swing.JScrollBar

The scrollbar is flexible along it's scrolling axis and rigid along the other axis.

getMaximumSize() - Method in class javax.swing.JToolBar.Separator

Returns the maximum size for the separator.

getMaximumSize() - Method in class javax.swing.plaf.basic.BasicArrowButton

Returns the maximum size of the BasicArrowButton.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicButtonUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicComboBoxUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicDesktopIconUI

Desktop icons can not be resized.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicLabelUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicMenuBarUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicMenuItemUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicMenuUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicProgressBarUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicScrollBarUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicScrollPaneUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicSeparatorUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicSliderUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI

Returns the maximum size for the passed in component, This is passed off to the current layout manager.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicTableHeaderUI

Return the maximum size of the header.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicTableUI

Return the maximum size of the table.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicTextUI

Gets the maximum size for the editor component.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicToolTipUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicTreeUI

Returns the maximum size for this component, which will be the preferred size if the instance is currently in a JTree, or 0, 0.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.ComponentUI

Returns the specified component's maximum size appropriate for the look and feel.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.LayerUI

If the JLayer's view component is not null, this returns the result of the view's getMaximumSize() method.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.metal.MetalDesktopIconUI

getMaximumSize(JComponent) - Method in class javax.swing.plaf.metal.MetalFileChooserUI

Returns the maximum size of the JFileChooser.

getMaximumSize() - Method in class javax.swing.plaf.metal.MetalScrollButton

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiButtonUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiColorChooserUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiComboBoxUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiDesktopIconUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiDesktopPaneUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiFileChooserUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiInternalFrameUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiLabelUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiListUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiMenuBarUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiMenuItemUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiOptionPaneUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiPanelUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiPopupMenuUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiProgressBarUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiRootPaneUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiScrollBarUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiScrollPaneUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiSeparatorUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiSliderUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiSpinnerUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiSplitPaneUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiTabbedPaneUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiTableHeaderUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiTableUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiTextUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiToolBarUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiToolTipUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiTreeUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiViewportUI

Invokes the getMaximumSize method on each UI handled by this object.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.synth.SynthButtonUI

Returns the specified component's maximum size appropriate for the look and feel.

getMaximumSize(SynthContext, Font, String, Icon, int, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthGraphicsUtils

Returns the maximum size needed to properly render an icon and text.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.synth.SynthLabelUI

Returns the specified component's maximum size appropriate for the look and feel.

getMaximumSize(JComponent) - Method in class javax.swing.plaf.synth.SynthSeparatorUI

Returns the specified component's maximum size appropriate for the look and feel.

getMaximumSpan(int) - Method in class javax.swing.text.AsyncBoxView

Determines the maximum span for this view along an axis.

getMaximumSpan(int) - Method in class javax.swing.text.BoxView

Determines the maximum span for this view along an axis.

getMaximumSpan(int) - Method in class javax.swing.text.ComponentView

Determines the maximum span for this view along an axis.

getMaximumSpan(int) - Method in class javax.swing.text.html.BlockView

Determines the maximum span for this view along an axis.

getMaximumSpan(int) - Method in class javax.swing.text.html.FormView

Determines the maximum span for this view along an axis.

getMaximumSpan(int) - Method in class javax.swing.text.html.ParagraphView

Determines the maximum span for this view along an axis.

getMaximumSpan(int) - Method in class javax.swing.text.View

Determines the maximum span for this view along an axis.

getMaximumSpan(int) - Method in class javax.swing.text.WrappedPlainView

Determines the maximum span for this view along an axis.

getMaximumStreamFormatVersion() - Method in interface javax.rmi.CORBA.ValueHandlerMultiFormat

Returns the maximum stream format version for RMI/IDL custom value types that is supported by this ValueHandler object.

getMaximumThumbSize() - Method in class javax.swing.plaf.basic.BasicScrollBarUI

Returns the largest acceptable size for the thumb.

getMaximumValue() - Method in class javax.swing.Spring

Returns the maximum value of this Spring.

getMaximumWindowBounds() - Method in class java.awt.GraphicsEnvironment

Returns the maximum bounds for centered Windows.

getMaximumZoneSize() - Method in class javax.swing.text.ZoneView

Get the current maximum zone size.

getMaxIndexLength() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of bytes this database allows for an index, including all of the parts of the index.

getMaxLabel() - Method in class javax.sound.sampled.FloatControl

Obtains the label for the maximum value, such as "Right" or "Full."

getMaxLines(Line.Info) - Method in interface javax.sound.sampled.Mixer

Obtains the approximate maximum number of lines of the requested type that can be open simultaneously on the mixer.

getMaxLogicalLobSize() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of bytes this database allows for the logical size for a LOB.

getMaxPage() - Method in class java.awt.JobAttributes

Specifies the maximum value the user can specify as the last page to be printed for jobs using these attributes.

getMaxPathLength() - Method in class java.security.cert.PKIXBuilderParameters

Returns the value of the maximum number of intermediate non-self-issued certificates that may exist in a certification path.

getMaxPolyphony() - Method in interface javax.sound.midi.Synthesizer

Obtains the maximum number of notes that this synthesizer can sound simultaneously.

getMaxPriority() - Method in class java.lang.ThreadGroup

Returns the maximum priority of this thread group.

getMaxProcedureNameLength() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of characters that this database allows in a procedure name.

getMaxReceivers() - Method in interface javax.sound.midi.MidiDevice

Obtains the maximum number of MIDI IN connections available on this MIDI device for receiving MIDI data.

getMaxRows() - Method in interface java.sql.Statement

Retrieves the maximum number of rows that a ResultSet object produced by this Statement object can contain.

getMaxRows() - Method in class javax.sql.rowset.BaseRowSet

Retrieves the maximum number of rows that this RowSet object may contain.

getMaxRows() - Method in interface javax.sql.RowSet

Retrieves the maximum number of rows that this RowSet object can contain.

getMaxRowSize() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of bytes this database allows in a single row.

getMaxSchemaNameLength() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of characters that this database allows in a schema name.

getMaxSelectionIndex() - Method in class javax.swing.DefaultListSelectionModel

Returns the last selected index or -1 if the selection is empty.

getMaxSelectionIndex() - Method in class javax.swing.JList

Returns the largest selected cell index, or -1 if the selection is empty.

getMaxSelectionIndex() - Method in interface javax.swing.ListSelectionModel

Returns the last selected index or -1 if the selection is empty.

getMaxSelectionRow() - Method in class javax.swing.JTree

Returns the largest selected row.

getMaxSelectionRow() - Method in class javax.swing.tree.DefaultTreeSelectionModel

Returns the largest value obtained from the RowMapper for the current set of selected TreePaths.

getMaxSelectionRow() - Method in interface javax.swing.tree.TreeSelectionModel

Returns the largest value obtained from the RowMapper for the current set of selected TreePaths.

getMaxSortKeys() - Method in class javax.swing.DefaultRowSorter

Returns the maximum number of sort keys.

getMaxStatementLength() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of characters this database allows in an SQL statement.

getMaxStatements() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of active statements to this database that can be open at the same time.

getMaxTableNameLength() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of characters this database allows in a table name.

getMaxTablesInSelect() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of tables this database allows in a SELECT statement.

getMaxTransmitters() - Method in interface javax.sound.midi.MidiDevice

Obtains the maximum number of MIDI OUT connections available on this MIDI device for transmitting MIDI data.

getMaxUserNameLength() - Method in interface java.sql.DatabaseMetaData

Retrieves the maximum number of characters this database allows in a user name.

getMaxValue(int) - Method in class java.awt.color.ColorSpace

Returns the maximum normalized color component value for the specified component.

getMaxValue(int) - Method in class java.awt.color.ICC_ColorSpace

Returns the maximum normalized color component value for the specified component.

getMaxValue() - Method in class javax.management.openmbean.OpenMBeanAttributeInfoSupport

Returns the maximal value for the attribute described by this OpenMBeanAttributeInfoSupport instance, if specified, or null otherwise.

getMaxValue() - Method in interface javax.management.openmbean.OpenMBeanParameterInfo

Returns the maximal value for this parameter, if it has one, or null otherwise.

getMaxValue() - Method in class javax.management.openmbean.OpenMBeanParameterInfoSupport

Returns the maximal value for the parameter described by this OpenMBeanParameterInfoSupport instance, if specified, or null otherwise.

getMaxWidth() - Method in class javax.swing.table.TableColumn

Returns the maximum width for the TableColumn.

getMaxX() - Method in class java.awt.geom.RectangularShape

Returns the largest X coordinate of the framing rectangle of the Shape in double precision.

getMaxY() - Method in class java.awt.geom.RectangularShape

Returns the largest Y coordinate of the framing rectangle of the Shape in double precision.

getMaxZonesLoaded() - Method in class javax.swing.text.ZoneView

Get the current setting of the number of zones allowed to be loaded at the same time.

getMBeanCount() - Method in interface javax.management.MBeanServer

Returns the number of MBeans registered in the MBean server.

getMBeanCount() - Method in interface javax.management.MBeanServerConnection

Returns the number of MBeans registered in the MBean server.

getMBeanCount(Subject) - Method in interface javax.management.remote.rmi.RMIConnection

Handles the method MBeanServerConnection.getMBeanCount().

getMBeanCount(Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl

getMBeanCount(Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub

getMBeanDescriptor() - Method in interface javax.management.modelmbean.ModelMBeanInfo

Returns the ModelMBean's descriptor which contains MBean wide policies.

getMBeanDescriptor() - Method in class javax.management.modelmbean.ModelMBeanInfoSupport

getMBeanInfo() - Method in interface javax.management.DynamicMBean

Provides the exposed attributes and actions of the Dynamic MBean using an MBeanInfo object.

getMBeanInfo(ObjectName) - Method in interface javax.management.MBeanServer

getMBeanInfo(ObjectName) - Method in interface javax.management.MBeanServerConnection

This method discovers the attributes and operations that an MBean exposes for management.

getMBeanInfo() - Method in class javax.management.modelmbean.RequiredModelMBean

Returns the attributes, operations, constructors and notifications that this RequiredModelMBean exposes for management.

getMBeanInfo(ObjectName, Subject) - Method in interface javax.management.remote.rmi.RMIConnection

Handles the method MBeanServerConnection.getMBeanInfo(ObjectName).

getMBeanInfo(ObjectName, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl

getMBeanInfo(ObjectName, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub

getMBeanInfo() - Method in class javax.management.StandardMBean

Get the MBeanInfo for this MBean.

getMBeanInterface() - Method in class javax.management.StandardMBean

Get the Management Interface of this Standard MBean (or MXBean).

getMBeanName() - Method in class javax.management.MBeanServerNotification

Returns the object name of the MBean that caused the notification.

getMBeanServer() - Static method in class javax.management.QueryEval

Return the MBean server that was most recently given to the setMBeanServer method by this thread.

getMBeanServer() - Method in class javax.management.remote.JMXConnectorServer

Returns the MBean server that this connector server is attached to.

getMBeanServer() - Method in interface javax.management.remote.MBeanServerForwarder

Returns the MBeanServer object to which requests will be forwarded.

getMBeanServer() - Method in class javax.management.remote.rmi.RMIServerImpl

The MBeanServer to which this connector server is attached.

getMBeanServerConnection() - Method in class javax.management.MBeanServerInvocationHandler

The MBean server connection through which the methods of a proxy using this handler are forwarded.

getMBeanServerConnection() - Method in interface javax.management.remote.JMXConnector

Returns an MBeanServerConnection object representing a remote MBean server.

getMBeanServerConnection(Subject) - Method in interface javax.management.remote.JMXConnector

Returns an MBeanServerConnection object representing a remote MBean server on which operations are performed on behalf of the supplied delegation subject.

getMBeanServerConnection() - Method in class javax.management.remote.rmi.RMIConnector

getMBeanServerConnection(Subject) - Method in class javax.management.remote.rmi.RMIConnector

getMBeanServerId() - Method in class javax.management.MBeanServerDelegate

Returns the MBean server agent identity.

getMBeanServerId() - Method in interface javax.management.MBeanServerDelegateMBean

Returns the MBean server agent identity.

getMBeansFromURL(URL) - Method in class javax.management.loading.MLet

Loads a text file containing MLET tags that define the MBeans to be added to the MBean server.

getMBeansFromURL(String) - Method in class javax.management.loading.MLet

Loads a text file containing MLET tags that define the MBeans to be added to the MBean server.

getMBeansFromURL(String) - Method in interface javax.management.loading.MLetMBean

Loads a text file containing MLET tags that define the MBeans to be added to the MBean server.

getMBeansFromURL(URL) - Method in interface javax.management.loading.MLetMBean

Loads a text file containing MLET tags that define the MBeans to be added to the MBean server.

getMBeansToUnregister() - Method in class javax.management.relation.RelationNotification

Returns the list of ObjectNames of MBeans expected to be unregistered due to a relation removal (only for relation removal).

getMech() - Method in interface org.ietf.jgss.GSSContext

Determines what mechanism is being used for this context.

getMechanismName() - Method in interface javax.security.sasl.SaslClient

Returns the IANA-registered mechanism name of this SASL client.

getMechanismName() - Method in interface javax.security.sasl.SaslServer

Returns the IANA-registered mechanism name of this SASL server.

getMechanismNames(Map<String, ?>) - Method in interface javax.security.sasl.SaslClientFactory

Returns an array of names of mechanisms that match the specified mechanism selection policies.

getMechanismNames(Map<String, ?>) - Method in interface javax.security.sasl.SaslServerFactory

Returns an array of names of mechanisms that match the specified mechanism selection policies.

getMechanismType() - Method in class javax.xml.crypto.dsig.keyinfo.KeyInfoFactory

Returns the type of the XML processing mechanism and representation supported by this KeyInfoFactory (ex: "DOM")

getMechanismType() - Method in class javax.xml.crypto.dsig.TransformService

Returns the mechanism type supported by this TransformService.

getMechanismType() - Method in class javax.xml.crypto.dsig.XMLSignatureFactory

Returns the type of the XML processing mechanism and representation supported by this XMLSignatureFactory (ex: "DOM").

getMechs() - Method in interface org.ietf.jgss.GSSCredential

Returns a list of mechanisms supported by this credential.

getMechs() - Method in class org.ietf.jgss.GSSManager

Returns a list of mechanisms that are available to GSS-API callers through this GSSManager.

getMechsForName(Oid) - Method in class org.ietf.jgss.GSSManager

Returns a list of mechanisms that support the indicated name type.

getMedia() - Method in class java.awt.PageAttributes

Returns the paper size for pages using these attributes.

getMediaSizeForName(MediaSizeName) - Static method in class javax.print.attribute.standard.MediaSize

Get the MediaSize for the specified named media.

getMediaSizeName() - Method in class javax.print.attribute.standard.MediaSize

Get the media name, if any, for this size.

getMediaSubtype() - Method in class javax.print.DocFlavor

Returns this doc flavor object's media subtype (from the MIME type).

getMediaType() - Method in class javax.print.DocFlavor

Returns this doc flavor object's media type (from the MIME type).

getMediaWhitePoint() - Method in class java.awt.color.ICC_ProfileGray

Returns a float array of length 3 containing the X, Y, and Z components of the mediaWhitePointTag in the ICC profile.

getMediaWhitePoint() - Method in class java.awt.color.ICC_ProfileRGB

Returns an array that contains the components of the profile's mediaWhitePointTag.

getMemberControls() - Method in class javax.sound.sampled.CompoundControl

Returns the set of member controls that comprise the compound control.

getMembers() - Method in class javax.print.attribute.SetOfIntegerSyntax

Obtain this set-of-integer attribute's members in canonical array form.

getMemoryManagerMXBeans() - Static method in class java.lang.management.ManagementFactory

Returns a list of MemoryManagerMXBean objects in the Java virtual machine.

getMemoryManagerNames() - Method in interface java.lang.management.MemoryPoolMXBean

Returns the name of memory managers that manages this memory pool.

getMemoryMXBean() - Static method in class java.lang.management.ManagementFactory

Returns the managed bean for the memory system of the Java virtual machine.

getMemoryPoolMXBeans() - Static method in class java.lang.management.ManagementFactory

Returns a list of MemoryPoolMXBean objects in the Java virtual machine.

getMemoryPoolNames() - Method in interface java.lang.management.MemoryManagerMXBean

Returns the name of memory pools that this memory manager manages.

getMemoryUsed() - Method in interface java.lang.management.BufferPoolMXBean

Returns an estimate of the memory that the Java virtual machine is using for this buffer pool.

getMenu(int) - Method in class java.awt.MenuBar

Gets the specified menu.

getMenu(int) - Method in class javax.swing.JMenuBar

Returns the menu at the specified position in the menu bar.

getMenuArrowIcon() - Static method in class javax.swing.plaf.basic.BasicIconFactory

getMenuArrowIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

getMenuBackground() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the menu background color of the current theme.

getMenuBackground() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the menu background color.

getMenuBar() - Method in class java.awt.Frame

Gets the menu bar for this frame.

getMenuBar() - Method in class javax.swing.JInternalFrame

Deprecated.
As of Swing version 1.0.3, replaced by getJMenuBar().

getMenuBar() - Method in class javax.swing.JRootPane

Deprecated.
As of Swing version 1.0.3 replaced by getJMenuBar().

getMenuBarBorder() - Static method in class javax.swing.plaf.basic.BasicBorders

getMenuComponent(int) - Method in class javax.swing.JMenu

Returns the component at position n.

getMenuComponentCount() - Method in class javax.swing.JMenu

Returns the number of components on the menu.

getMenuComponents() - Method in class javax.swing.JMenu

Returns an array of Components of the menu's subcomponents.

getMenuCount() - Method in class java.awt.MenuBar

Gets the number of menus on the menu bar.

getMenuCount() - Method in class javax.swing.JMenuBar

Returns the number of items in the menu bar.

getMenuDisabledForeground() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the menu disabled foreground color of the current theme.

getMenuDisabledForeground() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the menu disabled foreground color.

getMenuDisabledForeground() - Method in class javax.swing.plaf.metal.OceanTheme

Returns the menu disabled foreground color.

getMenuDragMouseListeners() - Method in class javax.swing.JMenuItem

Returns an array of all the MenuDragMouseListeners added to this JMenuItem with addMenuDragMouseListener().

getMenuForeground() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the menu foreground color of the current theme.

getMenuForeground() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the menu foreground color.

getMenuItemArrowIcon() - Static method in class javax.swing.plaf.basic.BasicIconFactory

getMenuItemArrowIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

getMenuItemCheckIcon() - Static method in class javax.swing.plaf.basic.BasicIconFactory

getMenuItemCheckIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

Returns an icon to be used by JCheckBoxMenuItem.

getMenuKeyListeners() - Method in class javax.swing.JMenuItem

Returns an array of all the MenuKeyListeners added to this JMenuItem with addMenuKeyListener().

getMenuKeyListeners() - Method in class javax.swing.JPopupMenu

Returns an array of all the MenuKeyListeners added to this JPopupMenu with addMenuKeyListener().

getMenuListeners() - Method in class javax.swing.JMenu

Returns an array of all the MenuListeners added to this JMenu with addMenuListener().

getMenuSelectedBackground() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the menu selected background color of the current theme.

getMenuSelectedBackground() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the menu selected background color.

getMenuSelectedForeground() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the menu selected foreground color of the current theme.

getMenuSelectedForeground() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the menu selected foreground color.

getMenuSelectionManager() - Method in class javax.swing.event.MenuDragMouseEvent

Returns the current menu selection manager.

getMenuSelectionManager() - Method in class javax.swing.event.MenuKeyEvent

Returns the current menu selection manager.

getMenuShortcutKeyMask() - Method in class java.awt.Toolkit

Determines which modifier key is the appropriate accelerator key for menu shortcuts.

getMenuTextFont() - Method in class javax.swing.plaf.metal.DefaultMetalTheme

Returns the menu text font.

getMenuTextFont() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the menu text font of the current theme.

getMenuTextFont() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the menu text font.

getMessage() - Method in exception java.awt.HeadlessException

getMessage() - Method in exception java.io.InvalidClassException

Produce the message and include the classname, if present.

getMessage() - Method in exception java.io.WriteAbortedException

Produce the message and include the message from the nested exception, if there is one.

getMessage() - Method in class java.lang.Throwable

Returns the detail message string of this throwable.

getMessage() - Method in exception java.net.URISyntaxException

Returns a string describing the parse error.

getMessage() - Method in exception java.nio.charset.MalformedInputException

Returns the message.

getMessage() - Method in exception java.nio.charset.UnmappableCharacterException

Returns the message.

getMessage() - Method in exception java.nio.file.FileSystemException

Returns the detail message string.

getMessage() - Method in exception java.nio.file.InvalidPathException

Returns a string describing the error.

getMessage() - Method in exception java.rmi.activation.ActivationException

Returns the detail message, including the message from the cause, if any, of this exception.

getMessage() - Method in exception java.rmi.RemoteException

Returns the detail message, including the message from the cause, if any, of this exception.

getMessage() - Method in exception java.rmi.server.ServerCloneException

Returns the detail message, including the message from the cause, if any, of this exception.

getMessage() - Method in exception java.security.cert.CertificateRevokedException

getMessage() - Method in exception java.util.DuplicateFormatFlagsException

getMessage() - Method in exception java.util.FormatFlagsConversionMismatchException

getMessage() - Method in exception java.util.IllegalFormatCodePointException

getMessage() - Method in exception java.util.IllegalFormatConversionException

getMessage() - Method in exception java.util.IllegalFormatFlagsException

getMessage() - Method in exception java.util.IllegalFormatPrecisionException

getMessage() - Method in exception java.util.IllegalFormatWidthException

getMessage() - Method in class java.util.logging.LogRecord

Get the "raw" log message, before localization or formatting.

getMessage() - Method in exception java.util.MissingFormatArgumentException

getMessage() - Method in exception java.util.MissingFormatWidthException

getMessage() - Method in exception java.util.regex.PatternSyntaxException

Returns a multi-line string containing the description of the syntax error and its index, the erroneous regular-expression pattern, and a visual indication of the error index within the pattern.

getMessage() - Method in exception java.util.UnknownFormatConversionException

getMessage() - Method in exception java.util.UnknownFormatFlagsException

getMessage() - Method in interface javax.annotation.processing.Completion

Returns an informative message about the completion.

getMessage() - Method in class javax.management.Notification

Get the notification message.

getMessage() - Method in exception javax.script.ScriptException

Returns a message containing the String passed to a constructor as well as line and column numbers and filename if any of these are known.

getMessage() - Method in class javax.security.auth.callback.TextOutputCallback

Get the message to be displayed.

getMessage() - Method in class javax.sound.midi.MidiEvent

Obtains the MIDI message contained in the event.

getMessage() - Method in class javax.sound.midi.MidiMessage

Obtains the MIDI message data.

getMessage() - Method in class javax.swing.JOptionPane

Returns the message-object this pane displays.

getMessage() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI

Returns the message to display from the JOptionPane the receiver is providing the look and feel for.

getMessage(Locale) - Method in interface javax.tools.Diagnostic

Gets a localized message for the given locale.

getMessage() - Method in class javax.xml.bind.helpers.ValidationEventImpl

getMessage() - Method in interface javax.xml.bind.ValidationEvent

Retrieve the text message for this warning/error.

getMessage() - Method in error javax.xml.parsers.FactoryConfigurationError

Return the message (if any) for this error .

getMessage() - Method in exception javax.xml.soap.SOAPException

Returns the detail message for this SOAPException object.

getMessage() - Method in error javax.xml.stream.FactoryConfigurationError

Report the message associated with this error

getMessage() - Method in error javax.xml.transform.TransformerFactoryConfigurationError

Return the message (if any) for this error .

getMessage() - Method in interface javax.xml.ws.handler.LogicalMessageContext

Gets the message from this message context

getMessage() - Method in interface javax.xml.ws.handler.soap.SOAPMessageContext

Gets the SOAPMessage from this message context.

getMessage() - Method in exception org.ietf.jgss.GSSException

Returns a textual representation of both the major and the minor status codes.

getMessage() - Method in interface org.w3c.dom.DOMError

An implementation specific string describing the error that occurred.

getMessage() - Method in exception org.xml.sax.SAXException

Return a detail message for this exception.

getMessageAndLocation() - Method in exception javax.xml.transform.TransformerException

Get the error message with location information appended.

getMessageContext() - Method in interface javax.xml.ws.WebServiceContext

Returns the MessageContext for the request being served at the time this method is called.

getMessageDigest() - Method in class java.security.DigestInputStream

Returns the message digest associated with this stream.

getMessageDigest() - Method in class java.security.DigestOutputStream

Returns the message digest associated with this stream.

getMessageFactory() - Method in interface javax.xml.ws.soap.SOAPBinding

Gets the SAAJ MessageFactory instance used by this SOAP binding.

getMessager() - Method in interface javax.annotation.processing.ProcessingEnvironment

Returns the messager used to report errors, warnings, and other notices.

getMessageType() - Method in class javax.security.auth.callback.ConfirmationCallback

Get the message type.

getMessageType() - Method in class javax.security.auth.callback.TextOutputCallback

Get the message type.

getMessageType() - Method in class javax.swing.JOptionPane

Returns the message type.

getMetaData() - Method in interface java.sql.Connection

Retrieves a DatabaseMetaData object that contains metadata about the database to which this Connection object represents a connection.

getMetaData() - Method in interface java.sql.PreparedStatement

Retrieves a ResultSetMetaData object that contains information about the columns of the ResultSet object that will be returned when this PreparedStatement object is executed.

getMetaData() - Method in interface java.sql.ResultSet

Retrieves the number, types and properties of this ResultSet object's columns.

getMetadata() - Method in class javax.imageio.IIOImage

Returns a reference to the current IIOMetadata object, or null is none is set.

getMetadata() - Method in class javax.xml.ws.Endpoint

Returns a list of metadata documents for the service.

getMetadataFormat(String) - Method in class javax.imageio.metadata.IIOMetadata

Returns an IIOMetadataFormat object describing the given metadata format, or null if no description is available.

getMetadataFormatNames() - Method in class javax.imageio.metadata.IIOMetadata

Returns an array of Strings containing the names of all metadata formats, including the native and standard formats, recognized by this plug-in's getAsTree, setFromTree, and mergeTree methods.

getMetaKey() - Method in interface org.w3c.dom.events.MouseEvent

Used to indicate whether the 'meta' key was depressed during the firing of the event.

getMethod() - Method in class java.beans.MethodDescriptor

Gets the method that this MethodDescriptor encapsulates.

getMethod(String, Class<?>...) - Method in class java.lang.Class

Returns a Method object that reflects the specified public member method of the class or interface represented by this Class object.

getMethod() - Method in class java.util.zip.ZipEntry

Returns the compression method of the entry.

getMethod() - Method in class javax.swing.text.html.FormSubmitEvent

Gets the form method type.

getMethodCallSyntax(String, String, String...) - Method in interface javax.script.ScriptEngineFactory

Returns a String which can be used to invoke a method of a Java object using the syntax of the supported scripting language.

getMethodDescriptors() - Method in interface java.beans.BeanInfo

Returns the method descriptors of the bean that define the externally visible methods supported by this bean.

getMethodDescriptors() - Method in class java.beans.SimpleBeanInfo

Deny knowledge of methods.

getMethodName() - Method in class java.beans.Statement

Returns the name of the method to invoke.

getMethodName() - Method in class java.lang.StackTraceElement

Returns the name of the method containing the execution point represented by this stack trace element.

getMethods() - Method in class java.lang.Class

Returns an array containing Method objects reflecting all the public methods of the class or interface represented by this Class object, including those declared by the class or interface and those inherited from superclasses and superinterfaces.

getMethodType() - Method in interface java.lang.invoke.MethodHandleInfo

Returns the nominal type of the cracked symbolic reference, expressed as a method type.

getMGFAlgorithm() - Method in class java.security.spec.PSSParameterSpec

Returns the mask generation function algorithm name.

getMGFAlgorithm() - Method in class javax.crypto.spec.OAEPParameterSpec

Returns the mask generation function algorithm name.

getMGFParameters() - Method in class java.security.spec.PSSParameterSpec

Returns the parameters for the mask generation function.

getMGFParameters() - Method in class javax.crypto.spec.OAEPParameterSpec

Returns the parameters for the mask generation function.

getMIC(byte[], int, int, MessageProp) - Method in interface org.ietf.jgss.GSSContext

Returns a token containing a cryptographic Message Integrity Code (MIC) for the supplied message, for transfer to the peer application.

getMIC(InputStream, OutputStream, MessageProp) - Method in interface org.ietf.jgss.GSSContext

Uses streams to produce a token containing a cryptographic MIC for the supplied message, for transfer to the peer application.

getMicrosecondLength() - Method in class javax.sound.midi.MidiFileFormat

Obtains the length of the MIDI file, expressed in microseconds.

getMicrosecondLength() - Method in class javax.sound.midi.Sequence

Obtains the duration of this sequence, expressed in microseconds.

getMicrosecondLength() - Method in interface javax.sound.midi.Sequencer

Obtains the length of the current sequence, expressed in microseconds, or 0 if no sequence is set.

getMicrosecondLength() - Method in interface javax.sound.sampled.Clip

Obtains the media duration in microseconds

getMicrosecondPosition() - Method in interface javax.sound.midi.MidiDevice

Obtains the current time-stamp of the device, in microseconds.

getMicrosecondPosition() - Method in interface javax.sound.midi.Sequencer

Obtains the current position in the sequence, expressed in microseconds.

getMicrosecondPosition() - Method in interface javax.sound.sampled.DataLine

Obtains the current position in the audio data, in microseconds.

getMidiDevice() - Method in interface javax.sound.midi.MidiDeviceReceiver

Obtains a MidiDevice object which is an owner of this Receiver.

getMidiDevice() - Method in interface javax.sound.midi.MidiDeviceTransmitter

Obtains a MidiDevice object which is an owner of this Transmitter.

getMidiDevice(MidiDevice.Info) - Static method in class javax.sound.midi.MidiSystem

Obtains the requested MIDI device.

getMidiDeviceInfo() - Static method in class javax.sound.midi.MidiSystem

Obtains an array of information objects representing the set of all MIDI devices available on the system.

getMidiFileFormat(InputStream) - Static method in class javax.sound.midi.MidiSystem

Obtains the MIDI file format of the data in the specified input stream.

getMidiFileFormat(URL) - Static method in class javax.sound.midi.MidiSystem

Obtains the MIDI file format of the data in the specified URL.

getMidiFileFormat(File) - Static method in class javax.sound.midi.MidiSystem

Obtains the MIDI file format of the specified File.

getMidiFileFormat(InputStream) - Method in class javax.sound.midi.spi.MidiFileReader

Obtains the MIDI file format of the input stream provided.

getMidiFileFormat(URL) - Method in class javax.sound.midi.spi.MidiFileReader

Obtains the MIDI file format of the URL provided.

getMidiFileFormat(File) - Method in class javax.sound.midi.spi.MidiFileReader

Obtains the MIDI file format of the File provided.

getMidiFileTypes() - Static method in class javax.sound.midi.MidiSystem

Obtains the set of MIDI file types for which file writing support is provided by the system.

getMidiFileTypes(Sequence) - Static method in class javax.sound.midi.MidiSystem

Obtains the set of MIDI file types that the system can write from the sequence specified.

getMidiFileTypes() - Method in class javax.sound.midi.spi.MidiFileWriter

Obtains the set of MIDI file types for which file writing support is provided by this file writer.

getMidiFileTypes(Sequence) - Method in class javax.sound.midi.spi.MidiFileWriter

Obtains the file types that this file writer can write from the sequence specified.

getMidLabel() - Method in class javax.sound.sampled.FloatControl

Obtains the label for the mid-point value, such as "Center" or "Default."

getMidTermsOfReductionPolynomial() - Method in class java.security.spec.ECFieldF2m

Returns an integer array which contains the order of the middle term(s) of the reduction polynomial for polynomial basis or null for normal basis.

getMillis() - Method in class java.util.logging.LogRecord

Get event time in milliseconds since 1970.

getMillisecond() - Method in class javax.xml.datatype.XMLGregorianCalendar

Return millisecond precision of XMLGregorianCalendar.getFractionalSecond().

getMillisToDecideToPopup() - Method in class javax.swing.ProgressMonitor

Returns the amount of time this object waits before deciding whether or not to popup a progress monitor.

getMillisToPopup() - Method in class javax.swing.ProgressMonitor

Returns the amount of time it will take for the popup to appear.

getMimeDecoder() - Static method in class java.util.Base64

Returns a Base64.Decoder that decodes using the MIME type base64 decoding scheme.

getMimeEncoder() - Static method in class java.util.Base64

Returns a Base64.Encoder that encodes using the MIME type base64 encoding scheme.

getMimeEncoder(int, byte[]) - Static method in class java.util.Base64

Returns a Base64.Encoder that encodes using the MIME type base64 encoding scheme with specified line length and line separators.

getMimeHeader(String) - Method in class javax.xml.soap.AttachmentPart

Gets all the values of the header identified by the given String.

getMimeHeader(String) - Method in class javax.xml.soap.SOAPPart

Gets all the values of the MimeHeader object in this SOAPPart object that is identified by the given String.

getMimeHeaders() - Method in class javax.xml.soap.SOAPMessage

Returns all the transport-specific MIME headers for this SOAPMessage object in a transport-independent fashion.

getMimeType() - Method in class java.awt.datatransfer.DataFlavor

Returns the MIME type string for this DataFlavor.

getMimeType() - Method in class javax.activation.ActivationDataFlavor

Return the MIME type for this DataFlavor.

getMimeType() - Method in class javax.print.DocFlavor

Returns this doc flavor object's MIME type string based on the canonical form.

getMimeType() - Method in interface javax.xml.crypto.dsig.XMLObject

Returns the mime type of this XMLObject.

getMimeType() - Method in class javax.xml.crypto.OctetStreamData

Returns the MIME type associated with the data object represented by this OctetStreamData.

getMimeTypes() - Method in interface javax.accessibility.AccessibleStreamable

Returns an array of DataFlavor objects for the MIME types this object supports.

getMimeTypes() - Method in class javax.activation.CommandMap

Get all the MIME types known to this command map.

getMimeTypes() - Method in class javax.activation.MailcapCommandMap

Get all the MIME types known to this command map.

getMIMETypes() - Method in class javax.imageio.spi.ImageReaderWriterSpi

Returns an array of Strings containing a list of MIME types associated with the formats that are generally usable by the ImageReader or ImageWriter implementation associated with this service provider.

getMimeTypes() - Method in interface javax.script.ScriptEngineFactory

Returns an immutable list of mimetypes, associated with scripts that can be executed by the engine.

getMin() - Method in class java.util.DoubleSummaryStatistics

Returns the minimum recorded value, Double.NaN if any recorded value was NaN or Double.POSITIVE_INFINITY if no values were recorded.

getMin() - Method in class java.util.IntSummaryStatistics

Returns the minimum value recorded, or Integer.MAX_VALUE if no values have been recorded.

getMin() - Method in class java.util.LongSummaryStatistics

Returns the minimum value recorded, or Long.MAX_VALUE if no values have been recorded.

getMinBufferSize() - Method in class javax.sound.sampled.DataLine.Info

Obtains the minimum buffer size supported by the data line.

getMinCRL() - Method in class java.security.cert.X509CRLSelector

Returns the minCRLNumber criterion.

getMinDegree() - Method in class javax.management.relation.RoleInfo

Returns minimum degree for corresponding role reference.

getMinimalDaysInFirstWeek() - Method in class java.time.temporal.WeekFields

Gets the minimal number of days in the first week.

getMinimalDaysInFirstWeek() - Method in class java.util.Calendar

Gets what the minimal days required in the first week of the year are; e.g., if the first week is defined as one that contains the first day of the first month of a year, this method returns 1.

getMinimalDaysInFirstWeek(Locale) - Method in class java.util.spi.CalendarDataProvider

Returns the minimal number of days required in the first week of a year.

getMinimum() - Method in interface java.awt.Adjustable

Gets the minimum value of the adjustable object.

getMinimum() - Method in class java.awt.Scrollbar

Gets the minimum value of this scroll bar.

getMinimum() - Method in class java.awt.ScrollPaneAdjustable

getMinimum() - Method in class java.time.temporal.ValueRange

Gets the minimum value that the field can take.

getMinimum(int) - Method in class java.util.Calendar

Returns the minimum value for the given calendar field of this Calendar instance.

getMinimum(int) - Method in class java.util.GregorianCalendar

Returns the minimum value for the given calendar field of this GregorianCalendar instance.

getMinimum() - Method in class javax.sound.sampled.FloatControl

Obtains the minimum value permitted.

getMinimum() - Method in interface javax.swing.BoundedRangeModel

Returns the minimum acceptable value.

getMinimum() - Method in class javax.swing.DefaultBoundedRangeModel

Returns the model's minimum.

getMinimum() - Method in class javax.swing.JProgressBar

Returns the progress bar's minimum value from the BoundedRangeModel.

getMinimum() - Method in class javax.swing.JScrollBar

Returns the minimum value supported by the scrollbar (usually zero).

getMinimum() - Method in class javax.swing.JSlider

Returns the minimum value supported by the slider from the BoundedRangeModel.

getMinimum() - Method in class javax.swing.ProgressMonitor

Returns the minimum value -- the lower end of the progress value.

getMinimum() - Method in class javax.swing.SpinnerNumberModel

Returns the first number in this sequence.

getMinimum() - Method in class javax.swing.text.InternationalFormatter

Returns the minimum permissible value.

getMinimumAccessibleValue() - Method in class java.awt.Button.AccessibleAWTButton

Get the minimum value of this object as a Number.

getMinimumAccessibleValue() - Method in class java.awt.Checkbox.AccessibleAWTCheckbox

Get the minimum value of this object as a Number.

getMinimumAccessibleValue() - Method in class java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem

Get the minimum value of this object as a Number.

getMinimumAccessibleValue() - Method in class java.awt.MenuItem.AccessibleAWTMenuItem

Get the minimum value of this object as a Number.

getMinimumAccessibleValue() - Method in class java.awt.Scrollbar.AccessibleAWTScrollBar

Get the minimum accessible value of this object.

getMinimumAccessibleValue() - Method in interface javax.accessibility.AccessibleValue

Get the minimum value of this object as a Number.

getMinimumAccessibleValue() - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Get the minimum value of this object as a Number.

getMinimumAccessibleValue() - Method in class javax.swing.JInternalFrame.AccessibleJInternalFrame

Get the minimum value of this object as a Number.

getMinimumAccessibleValue() - Method in class javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon

Gets the minimum value of this object as a Number.

getMinimumAccessibleValue() - Method in class javax.swing.JProgressBar.AccessibleJProgressBar

Gets the minimum accessible value of this object.

getMinimumAccessibleValue() - Method in class javax.swing.JScrollBar.AccessibleJScrollBar

Get the minimum accessible value of this object.

getMinimumAccessibleValue() - Method in class javax.swing.JSlider.AccessibleJSlider

Get the minimum accessible value of this object.

getMinimumAccessibleValue() - Method in class javax.swing.JSpinner.AccessibleJSpinner

Get the minimum value of this object as a Number.

getMinimumAccessibleValue() - Method in class javax.swing.JSplitPane.AccessibleJSplitPane

Gets the minimum accessible value of this object.

getMinimumDividerLocation() - Method in class javax.swing.JSplitPane

Returns the minimum location of the divider from the look and feel implementation.

getMinimumDividerLocation(JSplitPane) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI

Gets the minimum location of the divider.

getMinimumDividerLocation(JSplitPane) - Method in class javax.swing.plaf.multi.MultiSplitPaneUI

Invokes the getMinimumDividerLocation method on each UI handled by this object.

getMinimumDividerLocation(JSplitPane) - Method in class javax.swing.plaf.SplitPaneUI

Returns the minimum possible location of the divider.

getMinimumFractionDigits() - Method in class java.text.DecimalFormat

Gets the minimum number of digits allowed in the fraction portion of a number.

getMinimumFractionDigits() - Method in class java.text.NumberFormat

Returns the minimum number of digits allowed in the fraction portion of a number.

getMinimumHorizontalSize() - Method in class javax.swing.plaf.basic.BasicSliderUI

getMinimumIntegerDigits() - Method in class java.text.DecimalFormat

Gets the minimum number of digits allowed in the integer portion of a number.

getMinimumIntegerDigits() - Method in class java.text.NumberFormat

Returns the minimum number of digits allowed in the integer portion of a number.

getMinimumOptionPaneSize() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI

Returns the minimum size the option pane should be.

getMinimumSize() - Method in class java.awt.Component

Gets the minimum size of this component.

getMinimumSize() - Method in class java.awt.Container

Returns the minimum size of this container.

getMinimumSize(int) - Method in class java.awt.List

Gets the minimum dimensions for a list with the specified number of rows.

getMinimumSize() - Method in class java.awt.List

Determines the minimum size of this scrolling list.

getMinimumSize(int, int) - Method in class java.awt.TextArea

Determines the minimum size of a text area with the specified number of rows and columns.

getMinimumSize() - Method in class java.awt.TextArea

Determines the minimum size of this text area.

getMinimumSize(int) - Method in class java.awt.TextField

Gets the minimum dimensions for a text field with the specified number of columns.

getMinimumSize() - Method in class java.awt.TextField

Gets the minimum dimensions for this text field.

getMinimumSize(Component) - Method in class javax.swing.border.TitledBorder

Returns the minimum dimensions this border requires in order to fully display the border and title.

getMinimumSize() - Method in class javax.swing.JComponent

If the minimum size has been set to a non-null value just returns it.

getMinimumSize() - Method in class javax.swing.JScrollBar

The scrollbar is flexible along it's scrolling axis and rigid along the other axis.

getMinimumSize() - Method in class javax.swing.JToolBar.Separator

Returns the minimum size for the separator.

getMinimumSize() - Method in class javax.swing.plaf.basic.BasicArrowButton

Returns the minimum size of the BasicArrowButton.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicButtonUI

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicComboBoxUI

The minimum size is the size of the display area plus insets plus the button.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicDesktopIconUI

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicLabelUI

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicMenuBarUI

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicMenuItemUI

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicProgressBarUI

The Minimum size for this component is 10.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicSeparatorUI

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicSliderUI

getMinimumSize() - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider

Returns dividerSize x dividerSize

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI

Returns the minimum size for the passed in component, This is passed off to the current layout manager.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicTableHeaderUI

Return the minimum size of the header.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicTableUI

Return the minimum size of the table.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicTextAreaUI

The method is overridden to take into account caret width.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicTextUI

Gets the minimum size for the editor component.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicToolTipUI

getMinimumSize(JComponent) - Method in class javax.swing.plaf.basic.BasicTreeUI

Returns the minimum size for this component.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.ComponentUI

Returns the specified component's minimum size appropriate for the look and feel.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.LayerUI

If the JLayer's view component is not null, this returns the result of the view's getMinimalSize() method.

getMinimumSize() - Method in class javax.swing.plaf.metal.MetalComboBoxButton

getMinimumSize(JComponent) - Method in class javax.swing.plaf.metal.MetalComboBoxUI

getMinimumSize(JComponent) - Method in class javax.swing.plaf.metal.MetalDesktopIconUI

getMinimumSize(JComponent) - Method in class javax.swing.plaf.metal.MetalFileChooserUI

Returns the minimum size of the JFileChooser.

getMinimumSize() - Method in class javax.swing.plaf.metal.MetalScrollButton

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiButtonUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiColorChooserUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiComboBoxUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiDesktopIconUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiDesktopPaneUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiFileChooserUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiInternalFrameUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiLabelUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiListUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiMenuBarUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiMenuItemUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiOptionPaneUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiPanelUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiPopupMenuUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiProgressBarUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiRootPaneUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiScrollBarUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiScrollPaneUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiSeparatorUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiSliderUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiSpinnerUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiSplitPaneUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiTabbedPaneUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiTableHeaderUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiTableUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiTextUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiToolBarUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiToolTipUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiTreeUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.multi.MultiViewportUI

Invokes the getMinimumSize method on each UI handled by this object.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.synth.SynthButtonUI

Returns the specified component's minimum size appropriate for the look and feel.

getMinimumSize(SynthContext, Font, String, Icon, int, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthGraphicsUtils

Returns the minimum size needed to properly render an icon and text.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.synth.SynthLabelUI

Returns the specified component's minimum size appropriate for the look and feel.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.synth.SynthSeparatorUI

Returns the specified component's minimum size appropriate for the look and feel.

getMinimumSize(JComponent) - Method in class javax.swing.plaf.synth.SynthSliderUI

Returns the specified component's minimum size appropriate for the look and feel.

getMinimumSpan(int) - Method in class javax.swing.text.AsyncBoxView

Determines the minimum span for this view along an axis.

getMinimumSpan(int) - Method in class javax.swing.text.BoxView

Determines the minimum span for this view along an axis.

getMinimumSpan(int) - Method in class javax.swing.text.ComponentView

Determines the minimum span for this view along an axis.

getMinimumSpan(int) - Method in class javax.swing.text.GlyphView

Determines the minimum span for this view along an axis.

getMinimumSpan(int) - Method in class javax.swing.text.html.BlockView

Determines the minimum span for this view along an axis.

getMinimumSpan(int) - Method in class javax.swing.text.html.ParagraphView

Determines the minimum span for this view along an axis.

getMinimumSpan(int) - Method in class javax.swing.text.View

Determines the minimum span for this view along an axis.

getMinimumSpan(int) - Method in class javax.swing.text.WrappedPlainView

Determines the minimum span for this view along an axis.

getMinimumThumbSize() - Method in class javax.swing.plaf.basic.BasicScrollBarUI

Returns the smallest acceptable size for the thumb.

getMinimumThumbSize() - Method in class javax.swing.plaf.metal.MetalScrollBarUI

getMinimumThumbSize() - Method in class javax.swing.plaf.synth.SynthScrollBarUI

Returns the smallest acceptable size for the thumb.

getMinimumValue() - Method in class javax.swing.Spring

Returns the minimum value of this Spring.

getMinimumVerticalSize() - Method in class javax.swing.plaf.basic.BasicSliderUI

getMinIndex() - Method in class javax.imageio.ImageReader

Returns the lowest valid index for reading an image, thumbnail, or image metadata.

getMinLabel() - Method in class javax.sound.sampled.FloatControl

Obtains the label for the minimum value, such as "Left" or "Off."

getMinor() - Method in exception org.ietf.jgss.GSSException

Returns the mechanism level error code for the problem causing this exception to be thrown.

getMinorAxis() - Method in class javax.swing.text.AsyncBoxView

Fetch the minor axis (the axis orthogonal to the tiled axis).

getMinorOffset() - Method in class javax.swing.text.AsyncBoxView.ChildState

What is the offset along the minor axis

getMinorSpan() - Method in class javax.swing.text.AsyncBoxView.ChildState

What is the span along the minor axis.

getMinorStatus() - Method in class org.ietf.jgss.MessageProp

Retrieves the minor status code that the underlying mechanism might have set for this per-message operation.

getMinorString() - Method in exception org.ietf.jgss.GSSException

Returns a string explaining the mechanism specific error code.

getMinorString() - Method in class org.ietf.jgss.MessageProp

Retrieves a string explaining the minor status code.

getMinorTickSpacing() - Method in class javax.swing.JSlider

This method returns the minor tick spacing.

getMinorVersion() - Method in class java.awt.color.ICC_Profile

Returns profile minor version.

getMinorVersion() - Method in interface java.sql.Driver

Gets the driver's minor version number.

getMinPage() - Method in class java.awt.JobAttributes

Specifies the minimum value the user can specify as the first page to be printed for jobs using these attributes.

getMinSelectionIndex() - Method in class javax.swing.DefaultListSelectionModel

Returns the first selected index or -1 if the selection is empty.

getMinSelectionIndex() - Method in class javax.swing.JList

Returns the smallest selected cell index, or -1 if the selection is empty.

getMinSelectionIndex() - Method in interface javax.swing.ListSelectionModel

Returns the first selected index or -1 if the selection is empty.

getMinSelectionRow() - Method in class javax.swing.JTree

Returns the smallest selected row.

getMinSelectionRow() - Method in class javax.swing.tree.DefaultTreeSelectionModel

Returns the smallest value obtained from the RowMapper for the current set of selected TreePaths.

getMinSelectionRow() - Method in interface javax.swing.tree.TreeSelectionModel

Returns the smallest value obtained from the RowMapper for the current set of selected TreePaths.

getMinSize(Container, GridBagLayoutInfo) - Method in class java.awt.GridBagLayout

Figures out the minimum size of the master based on the information from getLayoutInfo.

GetMinSize(Container, GridBagLayoutInfo) - Method in class java.awt.GridBagLayout

This method is obsolete and supplied for backwards compatibility only; new code should call getMinSize instead.

getMinTileX() - Method in class java.awt.image.BufferedImage

Returns the minimum tile index in the x direction.

getMinTileX() - Method in interface java.awt.image.RenderedImage

Returns the minimum tile index in the X direction.

getMinTileY() - Method in class java.awt.image.BufferedImage

Returns the minimum tile index in the y direction.

getMinTileY() - Method in interface java.awt.image.RenderedImage

Returns the minimum tile index in the Y direction.

getMinusSign() - Method in class java.text.DecimalFormatSymbols

Gets the character used to represent minus sign.

getMinute() - Method in class java.time.LocalDateTime

Gets the minute-of-hour field.

getMinute() - Method in class java.time.LocalTime

Gets the minute-of-hour field.

getMinute() - Method in class java.time.OffsetDateTime

Gets the minute-of-hour field.

getMinute() - Method in class java.time.OffsetTime

Gets the minute-of-hour field.

getMinute() - Method in class java.time.ZonedDateTime

Gets the minute-of-hour field.

getMinute() - Method in class javax.xml.datatype.XMLGregorianCalendar

Return minutes or DatatypeConstants.FIELD_UNDEFINED.

getMinutes() - Method in class java.sql.Date

Deprecated.

getMinutes() - Method in class java.util.Date

Deprecated.
As of JDK version 1.1, replaced by Calendar.get(Calendar.MINUTE).

getMinutes() - Method in class javax.xml.datatype.Duration

Obtains the value of the MINUTES field as an integer value, or 0 if not present.

getMinValue(int) - Method in class java.awt.color.ColorSpace

Returns the minimum normalized color component value for the specified component.

getMinValue(int) - Method in class java.awt.color.ICC_ColorSpace

Returns the minimum normalized color component value for the specified component.

getMinValue() - Method in class javax.management.openmbean.OpenMBeanAttributeInfoSupport

Returns the minimal value for the attribute described by this OpenMBeanAttributeInfoSupport instance, if specified, or null otherwise.

getMinValue() - Method in interface javax.management.openmbean.OpenMBeanParameterInfo

Returns the minimal value for this parameter, if it has one, or null otherwise.

getMinValue() - Method in class javax.management.openmbean.OpenMBeanParameterInfoSupport

Returns the minimal value for the parameter described by this OpenMBeanParameterInfoSupport instance, if specified, or null otherwise.

getMinWidth() - Method in class javax.swing.table.TableColumn

Returns the minimum width for the TableColumn.

getMinX() - Method in class java.awt.geom.RectangularShape

Returns the smallest X coordinate of the framing rectangle of the Shape in double precision.

getMinX() - Method in class java.awt.image.BufferedImage

Returns the minimum x coordinate of this BufferedImage.

getMinX() - Method in class java.awt.image.Raster

Returns the minimum valid X coordinate of the Raster.

getMinX() - Method in interface java.awt.image.renderable.RenderableImage

Gets the minimum X coordinate of the rendering-independent image data.

getMinX() - Method in class java.awt.image.renderable.RenderableImageOp

Gets the minimum X coordinate of the rendering-independent image data.

getMinX() - Method in interface java.awt.image.RenderedImage

Returns the minimum X coordinate (inclusive) of the RenderedImage.

getMinY() - Method in class java.awt.geom.RectangularShape

Returns the smallest Y coordinate of the framing rectangle of the Shape in double precision.

getMinY() - Method in class java.awt.image.BufferedImage

Returns the minimum y coordinate of this BufferedImage.

getMinY() - Method in class java.awt.image.Raster

Returns the minimum valid Y coordinate of the Raster.

getMinY() - Method in interface java.awt.image.renderable.RenderableImage

Gets the minimum Y coordinate of the rendering-independent image data.

getMinY() - Method in class java.awt.image.renderable.RenderableImageOp

Gets the minimum Y coordinate of the rendering-independent image data.

getMinY() - Method in interface java.awt.image.RenderedImage

Returns the minimum Y coordinate (inclusive) of the RenderedImage.

getMissingGlyphCode() - Method in class java.awt.Font

Returns the glyphCode which is used when this Font does not have a glyph for a specified unicode code point.

getMiterLimit() - Method in class java.awt.BasicStroke

Returns the limit of miter joins.

getMixer(Mixer.Info) - Static method in class javax.sound.sampled.AudioSystem

Obtains the requested audio mixer.

getMixer(Mixer.Info) - Method in class javax.sound.sampled.spi.MixerProvider

Obtains an instance of the mixer represented by the info object.

getMixerInfo() - Static method in class javax.sound.sampled.AudioSystem

Obtains an array of mixer info objects that represents the set of audio mixers that are currently installed on the system.

getMixerInfo() - Method in interface javax.sound.sampled.Mixer

Obtains information about this mixer, including the product's name, version, vendor, etc.

getMixerInfo() - Method in class javax.sound.sampled.spi.MixerProvider

Obtains the set of info objects representing the mixer or mixers provided by this MixerProvider.

getMnemonic() - Method in class javax.swing.AbstractButton

Returns the keyboard mnemonic from the the current model.

getMnemonic() - Method in interface javax.swing.ButtonModel

Gets the keyboard mnemonic for the button.

getMnemonic() - Method in class javax.swing.colorchooser.AbstractColorChooserPanel

Provides a hint to the look and feel as to the KeyEvent.VK constant that can be used as a mnemonic to access the panel.

getMnemonic() - Method in class javax.swing.DefaultButtonModel

Gets the keyboard mnemonic for the button.

getMnemonicAt(int) - Method in class javax.swing.JTabbedPane

Returns the keyboard mnemonic for accessing the specified tab.

getModalExclusionType() - Method in class java.awt.Window

Returns the modal exclusion type of this window.

getModalityType() - Method in class java.awt.Dialog

Returns the modality type of this dialog.

getMode() - Method in class java.awt.FileDialog

Indicates whether this file dialog box is for loading from a file or for saving to a file.

getModel() - Method in class javax.swing.AbstractButton

Returns the model that this button represents.

getModel() - Method in class javax.swing.DefaultRowSorter

Returns the underlying model.

getModel() - Method in class javax.swing.DefaultRowSorter.ModelWrapper

Returns the underlying model that this Model is wrapping.

getModel() - Method in class javax.swing.JComboBox

Returns the data model currently used by the JComboBox.

getModel() - Method in class javax.swing.JList

Returns the data model that holds the list of items displayed by the JList component.

getModel() - Method in class javax.swing.JProgressBar

Returns the data model used by this progress bar.

getModel() - Method in class javax.swing.JScrollBar

Returns data model that handles the scrollbar's four fundamental properties: minimum, maximum, value, extent.

getModel() - Method in class javax.swing.JSlider

Returns the BoundedRangeModel that handles the slider's three fundamental properties: minimum, maximum, value.

getModel() - Method in class javax.swing.JSpinner.DateEditor

Return our spinner ancestor's SpinnerDateModel.

getModel() - Method in class javax.swing.JSpinner

Returns the SpinnerModel that defines this spinners sequence of values.

getModel() - Method in class javax.swing.JSpinner.ListEditor

Return our spinner ancestor's SpinnerNumberModel.

getModel() - Method in class javax.swing.JSpinner.NumberEditor

Return our spinner ancestor's SpinnerNumberModel.

getModel() - Method in class javax.swing.JTabbedPane

Returns the model associated with this tabbedpane.

getModel() - Method in class javax.swing.JTable

Returns the TableModel that provides the data displayed by this JTable.

getModel() - Method in class javax.swing.JTree

Returns the TreeModel that is providing the data.

getModel() - Method in class javax.swing.plaf.basic.BasicFileChooserUI

getModel() - Method in class javax.swing.plaf.basic.BasicTreeUI

getModel() - Method in class javax.swing.RowFilter.Entry

Returns the underlying model.

getModel() - Method in class javax.swing.RowSorter

Returns the underlying model.

getModel() - Method in class javax.swing.tree.AbstractLayoutCache

Returns the TreeModel that is providing the data.

getModelIndex() - Method in class javax.swing.table.TableColumn

Returns the model index for this column.

getModelRowCount() - Method in class javax.swing.DefaultRowSorter

Returns the number of rows in the underlying model.

getModelRowCount() - Method in class javax.swing.RowSorter

Returns the number of rows in the underlying model.

getModelWrapper() - Method in class javax.swing.DefaultRowSorter

Returns the model wrapper providing the data that is being sorted and filtered.

getModificationOp() - Method in class javax.naming.directory.ModificationItem

Retrieves the modification code of this modification item.

getModifier() - Method in class javax.swing.text.html.parser.AttributeList

getModifiers() - Method in class java.awt.AWTKeyStroke

Returns the modifier keys for this AWTKeyStroke.

getModifiers() - Method in class java.awt.event.ActionEvent

Returns the modifier keys held down during this action event.

getModifiers() - Method in class java.awt.event.InputEvent

Returns the modifier mask for this event.

getModifiers() - Method in class java.lang.Class

Returns the Java language modifiers for this class or interface, encoded in an integer.

getModifiers() - Method in interface java.lang.invoke.MethodHandleInfo

Returns the access modifiers of the underlying member.

getModifiers() - Method in class java.lang.reflect.Constructor

Returns the Java language modifiers for the executable represented by this object.

getModifiers() - Method in class java.lang.reflect.Executable

Returns the Java language modifiers for the executable represented by this object.

getModifiers() - Method in class java.lang.reflect.Field

Returns the Java language modifiers for the field represented by this Field object, as an integer.

getModifiers() - Method in interface java.lang.reflect.Member

Returns the Java language modifiers for the member or constructor represented by this Member, as an integer.

getModifiers() - Method in class java.lang.reflect.Method

Returns the Java language modifiers for the executable represented by this object.

getModifiers() - Method in class java.lang.reflect.Parameter

Get the modifier flags for this the parameter represented by this Parameter object.

getModifiers() - Method in interface javax.lang.model.element.Element

Returns the modifiers of this element, excluding annotations.

getModifiersEx() - Method in class java.awt.event.InputEvent

Returns the extended modifier mask for this event.

getModifiersEx() - Method in class java.awt.event.MouseEvent

Returns the extended modifier mask for this event.

getModifiersExText(int) - Static method in class java.awt.event.InputEvent

Returns a String describing the extended modifier keys and mouse buttons, such as "Shift", "Button1", or "Ctrl+Shift".

getModulus() - Method in interface java.security.interfaces.RSAKey

Returns the modulus.

getModulus() - Method in class java.security.spec.RSAPrivateKeySpec

Returns the modulus.

getModulus() - Method in class java.security.spec.RSAPublicKeySpec

Returns the modulus.

getModulus() - Method in class javax.management.monitor.CounterMonitor

Gets the modulus value common to all observed MBeans.

getModulus() - Method in interface javax.management.monitor.CounterMonitorMBean

Gets the modulus value.

getMonetaryDecimalSeparator() - Method in class java.text.DecimalFormatSymbols

Returns the monetary decimal separator.

getMono() - Method in interface javax.sound.midi.MidiChannel

Obtains the current mono/poly mode.

getMonth() - Method in class java.sql.Time

Deprecated.

getMonth() - Method in class java.time.LocalDate

Gets the month-of-year field using the Month enum.

getMonth() - Method in class java.time.LocalDateTime

Gets the month-of-year field using the Month enum.

getMonth() - Method in class java.time.MonthDay

Gets the month-of-year field using the Month enum.

getMonth() - Method in class java.time.OffsetDateTime

Gets the month-of-year field using the Month enum.

getMonth() - Method in class java.time.YearMonth

Gets the month-of-year field using the Month enum.

getMonth() - Method in class java.time.zone.ZoneOffsetTransitionRule

Gets the month of the transition.

getMonth() - Method in class java.time.ZonedDateTime

Gets the month-of-year field using the Month enum.

getMonth() - Method in class java.util.Date

Deprecated.
As of JDK version 1.1, replaced by Calendar.get(Calendar.MONTH).

getMonth() - Method in class javax.xml.datatype.XMLGregorianCalendar

Return number of month or DatatypeConstants.FIELD_UNDEFINED.

getMonths() - Method in class java.text.DateFormatSymbols

Gets month strings.

getMonths() - Method in class java.time.Period

Gets the amount of months of this period.

getMonths() - Method in class javax.xml.datatype.Duration

Obtains the value of the MONTHS field as an integer value, or 0 if not present.

getMonthValue() - Method in class java.time.LocalDate

Gets the month-of-year field from 1 to 12.

getMonthValue() - Method in class java.time.LocalDateTime

Gets the month-of-year field from 1 to 12.

getMonthValue() - Method in class java.time.MonthDay

Gets the month-of-year field from 1 to 12.

getMonthValue() - Method in class java.time.OffsetDateTime

Gets the month-of-year field from 1 to 12.

getMonthValue() - Method in class java.time.YearMonth

Gets the month-of-year field from 1 to 12.

getMonthValue() - Method in class java.time.ZonedDateTime

Gets the month-of-year field from 1 to 12.

getMoreResults() - Method in interface java.sql.Statement

Moves to this Statement object's next result, returns true if it is a ResultSet object, and implicitly closes any current ResultSet object(s) obtained with the method getResultSet.

getMoreResults(int) - Method in interface java.sql.Statement

Moves to this Statement object's next result, deals with any current ResultSet object(s) according to the instructions specified by the given flag, and returns true if the next result is a ResultSet object.

getMostRecentEventTime() - Static method in class java.awt.EventQueue

Returns the timestamp of the most recent event that had a timestamp, and that was dispatched from the EventQueue associated with the calling thread.

getMostRecentFocusOwner() - Method in class java.awt.Window

Returns the child Component of this Window that will receive the focus when this Window is focused.

getMostRecentFocusOwner() - Method in class javax.swing.JInternalFrame

Returns the child component of this JInternalFrame that will receive the focus when this JInternalFrame is selected.

getMostSignificantBits() - Method in class java.util.UUID

Returns the most significant 64 bits of this UUID's 128 bit value.

getMouseInfoPeer() - Method in class java.awt.Toolkit

Obtains this toolkit's implementation of helper class for MouseInfo operations.

getMouseListener() - Method in class javax.swing.plaf.basic.BasicComboPopup

Implementation of ComboPopup.getMouseListener().

getMouseListener() - Method in interface javax.swing.plaf.basic.ComboPopup

Returns a mouse listener that will be added to the combo box or null.

getMouseListeners() - Method in class java.awt.Component

Returns an array of all the mouse listeners registered on this component.

getMouseListeners() - Method in class java.awt.TrayIcon

Returns an array of all the mouse listeners registered on this TrayIcon.

getMouseModifiersText(int) - Static method in class java.awt.event.MouseEvent

Returns a String instance describing the modifier keys and mouse buttons that were down during the event, such as "Shift", or "Ctrl+Shift".

getMouseMotionListener() - Method in class javax.swing.plaf.basic.BasicComboPopup

Implementation of ComboPopup.getMouseMotionListener().

getMouseMotionListener() - Method in interface javax.swing.plaf.basic.ComboPopup

Returns a mouse motion listener that will be added to the combo box or null.

getMouseMotionListeners() - Method in class java.awt.Component

Returns an array of all the mouse motion listeners registered on this component.

getMouseMotionListeners() - Method in class java.awt.TrayIcon

Returns an array of all the mouse-motion listeners registered on this TrayIcon.

getMousePosition() - Method in class java.awt.Component

Returns the position of the mouse pointer in this Component's coordinate space if the Component is directly under the mouse pointer, otherwise returns null.

getMousePosition(boolean) - Method in class java.awt.Container

Returns the position of the mouse pointer in this Container's coordinate space if the Container is under the mouse pointer, otherwise returns null.

getMouseWheelListeners() - Method in class java.awt.Component

Returns an array of all the mouse wheel listeners registered on this component.

getMTU() - Method in class java.net.NetworkInterface

Returns the Maximum Transmission Unit (MTU) of this interface.

getMultiClickThreshhold() - Method in class javax.swing.AbstractButton

Gets the amount of time (in milliseconds) required between mouse press events for the button to generate the corresponding action events.

getMultiDocPrintServices(DocFlavor[], AttributeSet) - Method in class javax.print.PrintServiceLookup

Not called directly by applications.

getMultipleDocumentHandling() - Method in class java.awt.JobAttributes

Specifies the handling of multiple copies, including collation, for jobs using these attributes.

getMultiplier() - Method in class java.text.DecimalFormat

Gets the multiplier for use in percent, per mille, and similar formats.

getMustUnderstand() - Method in interface javax.xml.soap.SOAPHeaderElement

Returns the boolean value of the mustUnderstand attribute for this SOAPHeaderElement.

getMute() - Method in interface javax.sound.midi.MidiChannel

Obtains the current mute state for this channel.

getMutualAuthState() - Method in interface org.ietf.jgss.GSSContext

Determines if mutual authentication is enabled on this context.

getName(int) - Method in class java.awt.color.ColorSpace

Returns the name of the component given the component index.

getName() - Method in class java.awt.Component

Gets the name of the component.

getName() - Method in class java.awt.Cursor

Returns the name of this cursor.

getName() - Method in class java.awt.datatransfer.Clipboard

Returns the name of this clipboard object.

getName() - Method in class java.awt.Font

Returns the logical name of this Font.

getName() - Method in class java.awt.MenuComponent

Gets the name of the menu component.

getName() - Method in class java.beans.FeatureDescriptor

Gets the programmatic name of this feature.

getName() - Method in class java.io.File

Returns the name of the file or directory denoted by this abstract pathname.

getName() - Method in class java.io.ObjectStreamClass

Returns the name of the class described by this descriptor.

getName() - Method in class java.io.ObjectStreamField

Get the name of this field.

getName(int) - Static method in class java.lang.Character

Returns the Unicode name of the specified character codePoint, or null if the code point is unassigned.

getName() - Method in class java.lang.Class

Returns the name of the entity (class, interface, array class, primitive type, or void) represented by this Class object, as a String.

getName() - Method in interface java.lang.invoke.MethodHandleInfo

Returns the name of the cracked method handle's underlying member.

getName() - Method in interface java.lang.management.BufferPoolMXBean

Returns the name representing this buffer pool.

getName() - Method in interface java.lang.management.CompilationMXBean

Returns the name of the Just-in-time (JIT) compiler.

getName() - Method in interface java.lang.management.MemoryManagerMXBean

Returns the name representing this memory manager.

getName() - Method in interface java.lang.management.MemoryPoolMXBean

Returns the name representing this memory pool.

getName() - Method in interface java.lang.management.OperatingSystemMXBean

Returns the operating system name.

getName() - Method in interface java.lang.management.RuntimeMXBean

Returns the name representing the running Java virtual machine.

getName() - Method in class java.lang.Package

Return the name of this package.

getName() - Method in class java.lang.reflect.Constructor

Returns the name of this constructor, as a string.

getName() - Method in class java.lang.reflect.Executable

Returns the name of the executable represented by this object.

getName() - Method in class java.lang.reflect.Field

Returns the name of the field represented by this Field object.

getName() - Method in interface java.lang.reflect.Member

Returns the simple name of the underlying member or constructor represented by this Member.

getName() - Method in class java.lang.reflect.Method

Returns the name of the method represented by this Method object, as a String.

getName() - Method in class java.lang.reflect.Parameter

Returns the name of the parameter.

getName() - Method in interface java.lang.reflect.TypeVariable

Returns the name of this type variable, as it occurs in the source code.

getName() - Method in class java.lang.Thread

Returns this thread's name.

getName() - Method in class java.lang.ThreadGroup

Returns the name of this thread group.

getName() - Method in class java.net.HttpCookie

Returns the name of the cookie.

getName() - Method in class java.net.NetworkInterface

Get the name of this network interface.

getName() - Method in exception java.nio.file.attribute.UserPrincipalNotFoundException

Returns the user principal name if this exception was created with the user principal name that was not found, otherwise null.

getName(int) - Method in interface java.nio.file.Path

Returns a name element of this path as a Path object.

getName() - Method in interface java.security.acl.Acl

Returns the name of this ACL.

getName() - Method in class java.security.Identity

Deprecated.

Returns this identity's name.

getName() - Method in interface java.security.KeyStore.Entry.Attribute

Returns the attribute's name.

getName() - Method in class java.security.Permission

Returns the name of this Permission.

getName() - Method in class java.security.PKCS12Attribute

Returns the attribute's ASN.1 Object Identifier represented as a list of dot-separated integers.

getName() - Method in interface java.security.Principal

Returns the name of this principal.

getName() - Method in class java.security.Provider

Returns the name of this provider.

getName() - Method in class java.security.spec.ECGenParameterSpec

Returns the standard or predefined name of the to-be-generated EC domain parameters.

getName() - Method in enum java.sql.JDBCType

Returns the SQLType name that represents a SQL data type.

getName() - Method in interface java.sql.SQLType

Returns the SQLType name that represents a SQL data type.

getName() - Method in class java.text.AttributedCharacterIterator.Attribute

Returns the name of the attribute.

getName() - Method in class java.util.logging.Level

Return the non-localized string name of the Level.

getName() - Method in class java.util.logging.Logger

Get the name for this logger.

getName() - Method in class java.util.zip.ZipEntry

Returns the name of the entry.

getName() - Method in class java.util.zip.ZipFile

Returns the path name of the ZIP file.

getName() - Method in class javax.activation.DataHandler

Return the name of the data object.

getName() - Method in interface javax.activation.DataSource

Return the name of this object where the name of the object is dependant on the nature of the underlying objects.

getName() - Method in class javax.activation.FileDataSource

Return the name of this object.

getName() - Method in class javax.activation.URLDataSource

Calls the getFile method on the URL used to instantiate the object.

getName() - Method in class javax.crypto.ExemptionMechanism

Returns the exemption mechanism name of this ExemptionMechanism object.

getName(CharSequence) - Method in interface javax.lang.model.util.Elements

Return a name with the same sequence of characters as the argument.

getName() - Method in class javax.management.Attribute

Returns a String containing the name of the attribute.

getName() - Method in class javax.management.loading.MLetContent

Gets the value of the NAME attribute of the MLET tag.

getName() - Method in class javax.management.MBeanFeatureInfo

Returns the name of the feature.

getName() - Method in interface javax.management.openmbean.OpenMBeanConstructorInfo

Returns the name of the constructor described by this OpenMBeanConstructorInfo instance.

getName() - Method in interface javax.management.openmbean.OpenMBeanOperationInfo

Returns the name of the operation described by this OpenMBeanOperationInfo instance.

getName() - Method in interface javax.management.openmbean.OpenMBeanParameterInfo

Returns the name of the parameter described by this OpenMBeanParameterInfo instance.

getName() - Method in class javax.management.relation.RoleInfo

Returns the name of the role.

getName() - Method in class javax.management.remote.JMXPrincipal

Returns the name of this principal.

getName() - Method in class javax.naming.NameClassPair

Retrieves the name of this binding.

getName() - Method in class javax.net.ssl.SSLSessionBindingEvent

Returns the name to which the object is being bound, or the name from which the object is being unbound.

getName() - Method in interface javax.print.attribute.Attribute

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.Chromaticity

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.ColorSupported

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.Compression

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.Copies

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.CopiesSupported

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.DateTimeAtCompleted

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.DateTimeAtCreation

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.DateTimeAtProcessing

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.Destination

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.DialogTypeSelection

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.DocumentName

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.Fidelity

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.Finishings

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.JobHoldUntil

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.JobImpressions

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.JobImpressionsCompleted

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.JobImpressionsSupported

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.JobKOctets

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.JobKOctetsProcessed

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.JobKOctetsSupported

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.JobMediaSheets

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.JobMediaSheetsCompleted

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.JobMediaSheetsSupported

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.JobMessageFromOperator

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.JobName

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.JobOriginatingUserName

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.JobPriority

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.JobPrioritySupported

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.JobSheets

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.JobState

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.JobStateReason

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.JobStateReasons

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.Media

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.MediaPrintableArea

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.MediaSize

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.MultipleDocumentHandling

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.NumberOfDocuments

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.NumberOfInterveningJobs

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.NumberUp

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.NumberUpSupported

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.OrientationRequested

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.OutputDeviceAssigned

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.PageRanges

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.PagesPerMinute

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.PagesPerMinuteColor

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.PDLOverrideSupported

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.PresentationDirection

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.PrinterInfo

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.PrinterIsAcceptingJobs

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.PrinterLocation

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.PrinterMakeAndModel

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.PrinterMessageFromOperator

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.PrinterMoreInfo

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.PrinterMoreInfoManufacturer

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.PrinterName

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.PrinterResolution

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.PrinterState

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.PrinterStateReason

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.PrinterStateReasons

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.PrinterURI

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.PrintQuality

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.QueuedJobCount

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.ReferenceUriSchemesSupported

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.RequestingUserName

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.Severity

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.SheetCollate

Get the name of the category of which this attribute value is an instance.

getName() - Method in class javax.print.attribute.standard.Sides

Get the name of the category of which this attribute value is an instance.

getName() - Method in interface javax.print.PrintService

Returns a String name for this print service which may be used by applications to request a particular print service.

getName() - Method in class javax.security.auth.callback.NameCallback

Get the retrieved name.

getName() - Method in class javax.security.auth.kerberos.KerberosPrincipal

The returned string corresponds to the single-string representation of a Kerberos Principal name as specified in Section 2.1 of RFC 1964.

getName() - Method in class javax.security.auth.x500.X500Principal

Returns a string representation of the X.500 distinguished name using the format defined in RFC 2253.

getName(String) - Method in class javax.security.auth.x500.X500Principal

Returns a string representation of the X.500 distinguished name using the specified format.

getName(String, Map<String, String>) - Method in class javax.security.auth.x500.X500Principal

Returns a string representation of the X.500 distinguished name using the specified format.

getName() - Method in class javax.sound.midi.MidiDevice.Info

Obtains the name of the device.

getName() - Method in interface javax.sound.midi.Soundbank

Obtains the name of the sound bank.

getName() - Method in class javax.sound.midi.SoundbankResource

Obtains the name of the resource.

getName() - Method in class javax.sound.sampled.Mixer.Info

Obtains the name of the mixer.

getName() - Method in class javax.sound.sampled.Port.Info

Obtains the name of the port.

getName() - Method in class javax.sound.sampled.ReverbType

Obtains the name of this reverb type.

getName(File) - Method in class javax.swing.filechooser.FileView

The name of the file.

getName(File) - Method in class javax.swing.JFileChooser

Returns the filename.

getName() - Method in class javax.swing.LookAndFeel

Return a short string that identifies this look and feel, e.g.

getName(File) - Method in class javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView

getName() - Method in class javax.swing.plaf.metal.DefaultMetalTheme

Returns the name of this theme.

getName() - Method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the name of this look and feel.

getName() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the name of this theme.

getName() - Method in class javax.swing.plaf.metal.OceanTheme

Return the name of this theme, "Ocean".

getName() - Method in class javax.swing.plaf.multi.MultiLookAndFeel

Returns a string, suitable for use in menus, that identifies this look and feel.

getName() - Method in class javax.swing.plaf.nimbus.NimbusLookAndFeel

Return a short string that identifies this look and feel.

getName() - Method in class javax.swing.plaf.synth.Region

Returns the name of the region.

getName() - Method in class javax.swing.plaf.synth.SynthLookAndFeel

Return a short string that identifies this look and feel.

getName() - Method in class javax.swing.text.AbstractDocument.AbstractElement

Gets the name of the element.

getName() - Method in class javax.swing.text.AbstractDocument.BranchElement

Gets the element name.

getName() - Method in class javax.swing.text.AbstractDocument.LeafElement

Gets the element name.

getName() - Method in class javax.swing.text.DefaultStyledDocument.SectionElement

Gets the name of the element.

getName() - Method in interface javax.swing.text.Element

Fetches the name of the element.

getName() - Method in class javax.swing.text.html.HTMLDocument.BlockElement

Gets the name of the element.

getName() - Method in class javax.swing.text.html.HTMLDocument.RunElement

Gets the name of the element.

getName() - Method in class javax.swing.text.html.parser.AttributeList

getName() - Method in class javax.swing.text.html.parser.DTD

Gets the name of the DTD.

getName() - Method in class javax.swing.text.html.parser.Element

Get the name of the element.

getName() - Method in class javax.swing.text.html.parser.Entity

Gets the name of the entity.

getName() - Method in interface javax.swing.text.Keymap

Fetches the name of the set of key-bindings.

getName() - Method in interface javax.swing.text.Style

Fetches the name of the style.

getName() - Method in class javax.swing.text.StyleContext.NamedStyle

Fetches the name of the style.

getName() - Method in class javax.swing.UIManager.LookAndFeelInfo

Returns the name of the look and feel in a form suitable for a menu or other presentation

getName() - Method in enum javax.tools.DocumentationTool.Location

getName() - Method in interface javax.tools.FileObject

Gets a user-friendly name for this file object.

getName() - Method in class javax.tools.ForwardingFileObject

getName() - Method in interface javax.tools.JavaFileManager.Location

Gets the name of this location.

getName() - Method in class javax.tools.SimpleJavaFileObject

getName() - Method in enum javax.tools.StandardLocation

getName() - Method in class javax.xml.bind.JAXBElement

Returns the xml element tag name.

getName() - Method in interface javax.xml.crypto.dsig.keyinfo.KeyName

Returns the name of this KeyName.

getName() - Method in class javax.xml.soap.MimeHeader

Returns the name of this MimeHeader object.

getName() - Method in interface javax.xml.stream.events.Attribute

Returns the QName for this attribute

getName() - Method in interface javax.xml.stream.events.EndElement

Get the name of this event

getName() - Method in interface javax.xml.stream.events.EntityDeclaration

The entity's name

getName() - Method in interface javax.xml.stream.events.EntityReference

The name of the entity

getName() - Method in interface javax.xml.stream.events.NotationDeclaration

The notation name.

getName() - Method in interface javax.xml.stream.events.StartElement

Get the name of this event

getName() - Method in class javax.xml.stream.util.StreamReaderDelegate

getName() - Method in interface javax.xml.stream.XMLStreamReader

Returns a QName for the current START_ELEMENT or END_ELEMENT event

getName() - Method in interface org.ietf.jgss.GSSCredential

Retrieves the name of the entity that the credential asserts.

getName(Oid) - Method in interface org.ietf.jgss.GSSCredential

Retrieves a Mechanism Name of the entity that the credential asserts.

getName() - Method in interface org.w3c.dom.Attr

Returns the name of this attribute.

getName() - Method in interface org.w3c.dom.DocumentType

The name of DTD; i.e., the name immediately following the DOCTYPE keyword.

getName(int) - Method in interface org.w3c.dom.NameList

Returns the indexth name item in the collection.

getName(int) - Method in interface org.xml.sax.AttributeList

Deprecated.

Return the name of an attribute in this list (by position).

getName(int) - Method in class org.xml.sax.helpers.AttributeListImpl

Deprecated.

Get the name of an attribute (by position).

getNameConstraints() - Method in class java.security.cert.TrustAnchor

Returns the name constraints parameter.

getNameConstraints() - Method in class java.security.cert.X509CertSelector

Returns the name constraints criterion.

getNameCount() - Method in interface java.nio.file.Path

Returns the number of name elements in the path.

getNamedItem(String) - Method in interface org.w3c.dom.NamedNodeMap

Retrieves a node specified by name.

getNamedItemNS(String, String) - Method in interface org.w3c.dom.NamedNodeMap

Retrieves a node specified by local name and namespace URI.

getNameInNamespace() - Method in interface javax.naming.Context

Retrieves the full name of this context within its own namespace.

getNameInNamespace() - Method in class javax.naming.InitialContext

getNameInNamespace() - Method in class javax.naming.NameClassPair

Retrieves the full name of this binding.

getNameParser(Name) - Method in interface javax.naming.Context

Retrieves the parser associated with the named context.

getNameParser(String) - Method in interface javax.naming.Context

Retrieves the parser associated with the named context.

getNameParser(String) - Method in class javax.naming.InitialContext

getNameParser(Name) - Method in class javax.naming.InitialContext

getNames() - Method in class javax.activation.MimeTypeParameterList

Retrieve an enumeration of all the names in this list.

getNames() - Method in interface javax.script.ScriptEngineFactory

Returns an immutable list of short names for the ScriptEngine, which may be used to identify the ScriptEngine by the ScriptEngineManager.

getNamesForMech(Oid) - Method in class org.ietf.jgss.GSSManager

Returns then name types supported by the indicated mechanism.

getNamespaceContext() - Method in interface javax.xml.stream.events.StartElement

Gets a read-only namespace context.

getNamespaceContext() - Method in class javax.xml.stream.util.StreamReaderDelegate

getNamespaceContext() - Method in interface javax.xml.stream.XMLEventWriter

Returns the current namespace context.

getNamespaceContext() - Method in interface javax.xml.stream.XMLStreamReader

Returns a read only namespace context for the current position.

getNamespaceContext() - Method in interface javax.xml.stream.XMLStreamWriter

Returns the current namespace context.

getNamespaceContext() - Method in interface javax.xml.xpath.XPath

Return the current namespace context.

getNamespaceCount() - Method in class javax.xml.stream.util.StreamReaderDelegate

getNamespaceCount() - Method in interface javax.xml.stream.XMLStreamReader

Returns the count of namespaces declared on this START_ELEMENT or END_ELEMENT, this method is only valid on a START_ELEMENT, END_ELEMENT or NAMESPACE.

getNamespaceMap() - Method in class javax.xml.crypto.dsig.spec.XPathFilterParameterSpec

Returns a map of namespace prefixes.

getNamespaceMap() - Method in class javax.xml.crypto.dsig.spec.XPathType

Returns a map of namespace prefixes.

getNamespacePrefix(String, String) - Method in class javax.xml.crypto.dom.DOMCryptoContext

This implementation uses an internal HashMap to get the prefix that the specified URI maps to.

getNamespacePrefix(String, String) - Method in interface javax.xml.crypto.XMLCryptoContext

Returns the namespace prefix that the specified namespace URI is associated with.

getNamespacePrefix(int) - Method in class javax.xml.stream.util.StreamReaderDelegate

getNamespacePrefix(int) - Method in interface javax.xml.stream.XMLStreamReader

Returns the prefix for the namespace declared at the index.

getNamespacePrefixes() - Method in interface javax.xml.soap.SOAPElement

Returns an Iterator over the namespace prefix Strings declared by this element.

getNamespaces() - Method in interface javax.xml.stream.events.EndElement

Returns an Iterator of namespaces that have gone out of scope.

getNamespaces() - Method in interface javax.xml.stream.events.StartElement

Returns an Iterator of namespaces declared on this element.

getNamespaceURI() - Method in class javax.imageio.metadata.IIOMetadataNode

Returns null, since namespaces are not supported.

getNamespaceURI(String) - Method in interface javax.xml.namespace.NamespaceContext

Get Namespace URI bound to a prefix in the current scope.

getNamespaceURI() - Method in class javax.xml.namespace.QName

Get the Namespace URI of this QName.

getNamespaceURI(String) - Method in interface javax.xml.soap.SOAPElement

Returns the URI of the namespace that has the given prefix.

getNamespaceURI() - Method in interface javax.xml.stream.events.Namespace

Gets the uri bound to the prefix of this namespace

getNamespaceURI(String) - Method in interface javax.xml.stream.events.StartElement

Gets the value that the prefix is bound to in the context of this element.

getNamespaceURI(String) - Method in class javax.xml.stream.util.StreamReaderDelegate

getNamespaceURI(int) - Method in class javax.xml.stream.util.StreamReaderDelegate

getNamespaceURI() - Method in class javax.xml.stream.util.StreamReaderDelegate

getNamespaceURI(String) - Method in interface javax.xml.stream.XMLStreamReader

Return the uri for the given prefix.

getNamespaceURI(int) - Method in interface javax.xml.stream.XMLStreamReader

Returns the uri for the namespace declared at the index.

getNamespaceURI() - Method in interface javax.xml.stream.XMLStreamReader

If the current event is a START_ELEMENT or END_ELEMENT this method returns the URI of the prefix or the default namespace.

getNamespaceURI(int) - Method in interface org.w3c.dom.NameList

Returns the indexth namespaceURI item in the collection.

getNamespaceURI() - Method in interface org.w3c.dom.Node

The namespace URI of this node, or null if it is unspecified (see ).

getNameType() - Method in class javax.security.auth.kerberos.KerberosPrincipal

Returns the name type of the KerberosPrincipal.

getNaN() - Method in class java.text.DecimalFormatSymbols

Gets the string used to represent "not a number".

getNano() - Method in class java.time.Duration

Gets the number of nanoseconds within the second in this duration.

getNano() - Method in class java.time.Instant

Gets the number of nanoseconds, later along the time-line, from the start of the second.

getNano() - Method in class java.time.LocalDateTime

Gets the nano-of-second field.

getNano() - Method in class java.time.LocalTime

Gets the nano-of-second field.

getNano() - Method in class java.time.OffsetDateTime

Gets the nano-of-second field.

getNano() - Method in class java.time.OffsetTime

Gets the nano-of-second field.

getNano() - Method in class java.time.ZonedDateTime

Gets the nano-of-second field.

getNanos() - Method in class java.sql.Timestamp

Gets this Timestamp object's nanos value.

getNativeCommands(String) - Method in class javax.activation.MailcapCommandMap

Get the native commands for the given MIME type.

getNativeContainer(Component) - Static method in class java.awt.Toolkit

Give native peers the ability to query the native container given a native component (eg the direct parent may be lightweight).

getNativeImageMetadataFormatName() - Method in class javax.imageio.spi.ImageReaderWriterSpi

Returns the name of the "native" image metadata format for this plug-in, which typically allows for lossless encoding and transmission of the image metadata stored in the format handled by this plug-in.

getNativeMetadataFormatName() - Method in class javax.imageio.metadata.IIOMetadata

Returns the name of the "native" metadata format for this plug-in, which typically allows for lossless encoding and transmission of the metadata stored in the format handled by this plug-in.

getNativesForFlavor(DataFlavor) - Method in interface java.awt.datatransfer.FlavorTable

Returns a List of String natives to which the specified DataFlavor corresponds.

getNativesForFlavor(DataFlavor) - Method in class java.awt.datatransfer.SystemFlavorMap

Returns a List of String natives to which the specified DataFlavor can be translated by the data transfer subsystem.

getNativesForFlavors(DataFlavor[]) - Method in interface java.awt.datatransfer.FlavorMap

Returns a Map of the specified DataFlavors to their corresponding String native.

getNativesForFlavors(DataFlavor[]) - Method in class java.awt.datatransfer.SystemFlavorMap

Returns a Map of the specified DataFlavors to their most preferred String native.

getNativeStreamMetadataFormatName() - Method in class javax.imageio.spi.ImageReaderWriterSpi

Returns the name of the "native" stream metadata format for this plug-in, which typically allows for lossless encoding and transmission of the stream metadata stored in the format handled by this plug-in.

getNavigationFilter() - Method in class javax.swing.JFormattedTextField.AbstractFormatter

Subclass and override if you wish to provide a filter to restrict where the user can navigate to.

getNavigationFilter() - Method in class javax.swing.text.DefaultFormatter

Returns the NavigationFilter used to restrict where the cursor can be placed.

getNavigationFilter() - Method in class javax.swing.text.JTextComponent

Returns the NavigationFilter.

getNbNotifications() - Method in class javax.management.timer.Timer

Gets the number of timer notifications registered into the list of notifications.

getNbNotifications() - Method in interface javax.management.timer.TimerMBean

Gets the number of timer notifications registered into the list of notifications.

getNbOccurences(Integer) - Method in class javax.management.timer.Timer

Gets a copy of the remaining number of occurrences associated to a timer notification.

getNbOccurences(Integer) - Method in interface javax.management.timer.TimerMBean

Gets a copy of the remaining number of occurrences associated to a timer notification.

getNCharacterStream(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated parameter as a java.io.Reader object in the Java programming language.

getNCharacterStream(String) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated parameter as a java.io.Reader object in the Java programming language.

getNCharacterStream(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.io.Reader object.

getNCharacterStream(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.io.Reader object.

getNClob(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC NCLOB parameter as a java.sql.NClob object in the Java programming language.

getNClob(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC NCLOB parameter as a java.sql.NClob object in the Java programming language.

getNClob(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a NClob object in the Java programming language.

getNClob(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a NClob object in the Java programming language.

getNeedClientAuth() - Method in class javax.net.ssl.SSLEngine

Returns true if the engine will require client authentication.

getNeedClientAuth() - Method in class javax.net.ssl.SSLParameters

Returns whether client authentication should be required.

getNeedClientAuth() - Method in class javax.net.ssl.SSLServerSocket

Returns true if client authentication will be required on newly accepted server-mode SSLSockets.

getNeedClientAuth() - Method in class javax.net.ssl.SSLSocket

Returns true if the socket will require client authentication.

getNeedClientAuth() - Method in class javax.rmi.ssl.SslRMIServerSocketFactory

Returns true if client authentication is required on SSL connections accepted by server sockets created by this factory.

getNeededLocation(int, int) - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider.DragController

Returns the x argument, since this is used for horizontal splits.

getNeededLocation(int, int) - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider.VerticalDragController

Returns the y argument, since this is used for vertical splits.

getNegativePrefix() - Method in class java.text.DecimalFormat

Get the negative prefix.

getNegativeSign() - Method in class java.time.format.DecimalStyle

Gets the character that represents the negative sign.

getNegativeSuffix() - Method in class java.text.DecimalFormat

Get the negative suffix.

getNegotiatedProperty(String) - Method in interface javax.security.sasl.SaslClient

Retrieves the negotiated property.

getNegotiatedProperty(String) - Method in interface javax.security.sasl.SaslServer

Retrieves the negotiated property.

getNestedException() - Method in exception javax.xml.stream.XMLStreamException

Gets the nested exception.

getNestingKind() - Method in interface javax.lang.model.element.TypeElement

Returns the nesting kind of this type element.

getNestingKind() - Method in class javax.tools.ForwardingJavaFileObject

getNestingKind() - Method in interface javax.tools.JavaFileObject

Provides a hint about the nesting level of the class represented by this file object.

getNestingKind() - Method in class javax.tools.SimpleJavaFileObject

This implementation returns null.

getNetworkInterface() - Method in class java.net.MulticastSocket

Get the multicast network interface set.

getNetworkInterfaces() - Static method in class java.net.NetworkInterface

Returns all the interfaces on this machine.

getNetworkPrefixLength() - Method in class java.net.InterfaceAddress

Returns the network prefix length for this address.

getNetworkTimeout() - Method in interface java.sql.Connection

Retrieves the number of milliseconds the driver will wait for a database request to complete.

getNewBinding() - Method in class javax.naming.event.NamingEvent

Retrieves the binding of the object after the change.

getNewDocument() - Method in interface org.w3c.dom.ls.LSLoadEvent

The document that finished loading.

getNewFolderAction() - Method in class javax.swing.plaf.basic.BasicFileChooserUI

getNewLeadSelectionPath() - Method in class javax.swing.event.TreeSelectionEvent

Returns the current lead path.

getNewLine() - Method in interface org.w3c.dom.ls.LSSerializer

The end-of-line sequence of characters to be used in the XML being written out.

getNewRoleValue() - Method in class javax.management.relation.RelationNotification

Returns new value of updated role (only for role update).

getNewState() - Method in class java.awt.event.WindowEvent

For WINDOW_STATE_CHANGED events returns the new state of the window.

getNewValue() - Method in class java.beans.PropertyChangeEvent

Gets the new value for the property, expressed as an Object.

getNewValue() - Method in class java.util.prefs.PreferenceChangeEvent

Returns the new value for the preference.

getNewValue() - Method in class javax.management.AttributeChangeNotification

Gets the new value of the attribute which has changed.

getNewValue() - Method in interface org.w3c.dom.events.MutationEvent

newValue indicates the new value of the Attr node in DOMAttrModified events, and of the CharacterData node in DOMCharacterDataModified events.

getNext() - Method in class javax.swing.text.html.parser.AttributeList

getNextEastWestVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[]) - Method in class javax.swing.text.CompositeView

Returns the next visual position for the cursor, in either the east or west direction.

getNextEntry() - Method in class java.util.jar.JarInputStream

Reads the next ZIP file entry and positions the stream at the beginning of the entry data.

getNextEntry() - Method in class java.util.zip.ZipInputStream

Reads the next ZIP file entry and positions the stream at the beginning of the entry data.

getNextEvent() - Method in class java.awt.EventQueue

Removes an event from the EventQueue and returns it.

getNextException() - Method in exception java.sql.SQLException

Retrieves the exception chained to this SQLException object by setNextException(SQLException ex).

getNextFocusableComponent() - Method in class javax.swing.JComponent

Deprecated.
As of 1.4, replaced by FocusTraversalPolicy.

getNextJarEntry() - Method in class java.util.jar.JarInputStream

Reads the next JAR file entry and positions the stream at the beginning of the entry data.

getNextLeaf() - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns the leaf after this node or null if this node is the last leaf in the tree.

getNextLeftHit(TextHitInfo) - Method in class java.awt.font.TextLayout

Returns the hit for the next caret to the left (top); if no such hit, returns null.

getNextLeftHit(int, TextLayout.CaretPolicy) - Method in class java.awt.font.TextLayout

Returns the hit for the next caret to the left (top); if no such hit, returns null.

getNextLeftHit(int) - Method in class java.awt.font.TextLayout

Returns the hit for the next caret to the left (top); if no such hit, returns null.

getNextMatch(String, int, Position.Bias) - Method in class javax.swing.JList

Returns the next list element whose toString value starts with the given prefix.

getNextMatch(String, int, Position.Bias) - Method in class javax.swing.JTree

Returns the TreePath to the next tree element that begins with a prefix.

getNextNode() - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns the node that follows this node in a preorder traversal of this node's tree.

getNextNorthSouthVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[]) - Method in class javax.swing.text.CompositeView

Returns the next visual position for the cursor, in either the north or south direction.

getNextNorthSouthVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[]) - Method in class javax.swing.text.ParagraphView

Returns the next visual position for the cursor, in either the east or west direction.

getNextRightHit(TextHitInfo) - Method in class java.awt.font.TextLayout

Returns the hit for the next caret to the right (bottom); if there is no such hit, returns null.

getNextRightHit(int, TextLayout.CaretPolicy) - Method in class java.awt.font.TextLayout

Returns the hit for the next caret to the right (bottom); if no such hit, returns null.

getNextRightHit(int) - Method in class java.awt.font.TextLayout

Returns the hit for the next caret to the right (bottom); if no such hit, returns null.

getNextSequenceNumber() - Method in class javax.management.remote.NotificationResult

Returns the sequence number of the next notification available for querying.

getNextSibling() - Method in class javax.imageio.metadata.IIOMetadataNode

Returns the next sibling of this node, or null if the node has no next sibling.

getNextSibling() - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns the next sibling of this node in the parent's children array.

getNextSibling() - Method in class javax.xml.crypto.dsig.dom.DOMSignContext

Returns the nextSibling node.

getNextSibling() - Method in class javax.xml.transform.dom.DOMResult

Get the child node before which the result nodes will be inserted.

getNextSibling() - Method in interface org.w3c.dom.Node

The node immediately following this node.

getNextTabIndex(int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getNextTabIndexInRun(int, int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getNextTabRun(int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getNextUpdate() - Method in class java.security.cert.X509CRL

Gets the nextUpdate date from the CRL.

getNextValue() - Method in class javax.swing.JSpinner

Returns the object in the sequence that comes after the object returned by getValue().

getNextValue() - Method in class javax.swing.SpinnerDateModel

Returns the next Date in the sequence, or null if the next date is after end.

getNextValue() - Method in class javax.swing.SpinnerListModel

Returns the next legal value of the underlying sequence or null if value is already the last element.

getNextValue() - Method in interface javax.swing.SpinnerModel

Return the object in the sequence that comes after the object returned by getValue().

getNextValue() - Method in class javax.swing.SpinnerNumberModel

Returns the next number in the sequence.

getNextVisualPositionFrom(JTextComponent, int, Position.Bias, int, Position.Bias[]) - Method in class javax.swing.plaf.basic.BasicTextUI

Provides a way to determine the next visually represented model location that one might place a caret.

getNextVisualPositionFrom(JTextComponent, int, Position.Bias, int, Position.Bias[]) - Method in class javax.swing.plaf.multi.MultiTextUI

Invokes the getNextVisualPositionFrom method on each UI handled by this object.

getNextVisualPositionFrom(JTextComponent, int, Position.Bias, int, Position.Bias[]) - Method in class javax.swing.plaf.TextUI

Provides a way to determine the next visually represented model location that one might place a caret.

getNextVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[]) - Method in class javax.swing.text.AsyncBoxView

Provides a way to determine the next visually represented model location that one might place a caret.

getNextVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[]) - Method in class javax.swing.text.CompositeView

Provides a way to determine the next visually represented model location that one might place a caret.

getNextVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[]) - Method in class javax.swing.text.GlyphView

Provides a way to determine the next visually represented model location that one might place a caret.

getNextVisualPositionFrom(GlyphView, int, Position.Bias, Shape, int, Position.Bias[]) - Method in class javax.swing.text.GlyphView.GlyphPainter

Provides a way to determine the next visually represented model location that one might place a caret.

getNextVisualPositionFrom(JTextComponent, int, Position.Bias, int, Position.Bias[]) - Method in class javax.swing.text.NavigationFilter

Returns the next visual position to place the caret at from an existing position.

getNextVisualPositionFrom(int, Position.Bias, Shape, int, Position.Bias[]) - Method in class javax.swing.text.View

Provides a way to determine the next visually represented model location at which one might place a caret.

getNextWarning() - Method in exception java.sql.SQLWarning

Retrieves the warning chained to this SQLWarning object by setNextWarning.

getNextWarning() - Method in exception javax.sql.rowset.RowSetWarning

Retrieves the warning chained to this RowSetWarning object.

getNextWord(JTextComponent, int) - Static method in class javax.swing.text.Utilities

Determines the start of the next word for the given location.

getNode() - Method in class java.util.prefs.PreferenceChangeEvent

Returns the preference node that emitted the event.

getNode(Object) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

By default, the getNode method is unsupported and throw an UnsupportedOperationException.

getNode() - Method in class javax.xml.bind.helpers.ValidationEventLocatorImpl

getNode(Object) - Method in interface javax.xml.bind.Marshaller

Get a DOM tree view of the content tree(Optional).

getNode() - Method in interface javax.xml.bind.ValidationEventLocator

Return a reference to the DOM Node if available

getNode() - Method in class javax.xml.crypto.dom.DOMStructure

Returns the node contained in this DOMStructure.

getNode() - Method in class javax.xml.crypto.dsig.dom.DOMValidateContext

Returns the node.

getNode() - Method in class javax.xml.transform.dom.DOMResult

Get the node that will contain the result DOM tree.

getNode() - Method in class javax.xml.transform.dom.DOMSource

Get the node that represents a Source DOM tree.

getNodeDimensions(Object, int, int, boolean, Rectangle) - Method in class javax.swing.plaf.basic.BasicTreeUI.NodeDimensionsHandler

Responsible for getting the size of a particular node.

getNodeDimensions() - Method in class javax.swing.tree.AbstractLayoutCache

Returns the object that renders nodes in the tree, and which is responsible for calculating the dimensions of individual nodes.

getNodeDimensions(Object, int, int, boolean, Rectangle) - Method in class javax.swing.tree.AbstractLayoutCache

Returns, by reference in placeIn, the size needed to represent value.

getNodeDimensions(Object, int, int, boolean, Rectangle) - Method in class javax.swing.tree.AbstractLayoutCache.NodeDimensions

Returns, by reference in bounds, the size and x origin to place value at.

getNodeName() - Method in class javax.imageio.metadata.IIOMetadataNode

Returns the node name associated with this node.

getNodeName() - Method in interface org.w3c.dom.Node

The name of this node, depending on its type; see the table above.

getNodeType() - Method in class javax.imageio.metadata.IIOMetadataNode

Returns the node type, which is always ELEMENT_NODE.

getNodeType() - Method in interface org.w3c.dom.Node

A code representing the type of the underlying object, as defined above.

getNodeValue() - Method in class javax.imageio.metadata.IIOMetadataNode

Returns the value associated with this node.

getNodeValue() - Method in interface org.w3c.dom.Node

The value of this node, depending on its type; see the table above.

getNoFallbackControl(List<String>) - Static method in class java.util.ResourceBundle.Control

Returns a ResourceBundle.Control in which the getFormats method returns the specified formats and the getFallbackLocale method returns null.

getNoImageIcon() - Method in class javax.swing.text.html.ImageView

Returns the icon to use if the image couldn't be found.

getNonContinuousLayoutDivider() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI

Returns the divider to use when the splitPane is configured to not continuously layout.

getNonCriticalExtensionOIDs() - Method in interface java.security.cert.X509Extension

Gets a Set of the OID strings for the extension(s) marked NON-CRITICAL in the certificate/CRL managed by the object implementing this interface.

getNonHeapMemoryUsage() - Method in interface java.lang.management.MemoryMXBean

Returns the current memory usage of non-heap memory that is used by the Java virtual machine.

getNonMatchingHeaders(String[]) - Method in class javax.xml.soap.MimeHeaders

Returns all of the MimeHeader objects whose name does not match a name in the given array of names.

getNonMatchingMimeHeaders(String[]) - Method in class javax.xml.soap.AttachmentPart

Retrieves all MimeHeader objects whose name does not match a name in the given array.

getNonMatchingMimeHeaders(String[]) - Method in class javax.xml.soap.SOAPPart

Retrieves all MimeHeader objects whose name does not match a name in the given array.

getNonRolloverBorder(AbstractButton) - Method in class javax.swing.plaf.basic.BasicToolBarUI

Returns a non-rollover border for the button.

getNoNSSchemaLocation() - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

Convenience method for getting the current noNamespaceSchemaLocation.

getNormalBounds() - Method in class javax.swing.JInternalFrame

If the JInternalFrame is not in maximized state, returns getBounds(); otherwise, returns the bounds that the JInternalFrame would be restored to.

getNormalizedComponents(int[], int, float[], int) - Method in class java.awt.image.ColorModel

Returns an array of all of the color/alpha components in normalized form, given an unnormalized component array.

getNormalizedComponents(Object, float[], int) - Method in class java.awt.image.ColorModel

Returns an array of all of the color/alpha components in normalized form, given a pixel in this ColorModel.

getNormalizedComponents(int[], int, float[], int) - Method in class java.awt.image.ComponentColorModel

Returns an array of all of the color/alpha components in normalized form, given an unnormalized component array.

getNormalizedComponents(Object, float[], int) - Method in class java.awt.image.ComponentColorModel

Returns an array of all of the color/alpha components in normalized form, given a pixel in this ColorModel.

getNormalizingTransform() - Method in class java.awt.GraphicsConfiguration

Returns a AffineTransform that can be concatenated with the default AffineTransform of a GraphicsConfiguration so that 72 units in user space equals 1 inch in device space.

getNorthPane() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI

getNotAfter() - Method in class java.security.cert.X509Certificate

Gets the notAfter date from the validity period of the certificate.

getNotAfter() - Method in class javax.security.cert.X509Certificate

Gets the notAfter date from the validity period of the certificate.

getNotationName() - Method in interface javax.xml.stream.events.EntityDeclaration

The name of the associated notation.

getNotationName() - Method in interface org.w3c.dom.Entity

For unparsed entities, the name of the notation for the entity.

getNotations() - Method in interface javax.xml.stream.events.DTD

Return a List containing the notations declared in the DTD.

getNotations() - Method in interface org.w3c.dom.DocumentType

A NamedNodeMap containing the notations declared in the DTD.

getNotBefore() - Method in class java.security.cert.X509Certificate

Gets the notBefore date from the validity period of the certificate.

getNotBefore() - Method in class javax.security.cert.X509Certificate

Gets the notBefore date from the validity period of the certificate.

getNote() - Method in class javax.swing.ProgressMonitor

Specifies the additional note that is displayed along with the progress message.

getNotification(String) - Method in interface javax.management.modelmbean.ModelMBeanInfo

Returns a ModelMBeanNotificationInfo requested by name.

getNotification(String) - Method in class javax.management.modelmbean.ModelMBeanInfoSupport

getNotification() - Method in class javax.management.remote.TargetedNotification

The emitted notification.

getNotification() - Method in class javax.naming.ldap.UnsolicitedNotificationEvent

Returns the unsolicited notification.

getNotificationID() - Method in class javax.management.timer.TimerNotification

Gets the identifier of this timer notification.

getNotificationIDs(String) - Method in class javax.management.timer.Timer

Gets all the identifiers of timer notifications corresponding to the specified type.

getNotificationIDs(String) - Method in interface javax.management.timer.TimerMBean

Gets all the identifiers of timer notifications corresponding to the specified type.

getNotificationInfo() - Method in class javax.management.MBeanServerDelegate

getNotificationInfo() - Method in class javax.management.modelmbean.RequiredModelMBean

Returns the array of Notifications always generated by the RequiredModelMBean.

getNotificationInfo() - Method in class javax.management.monitor.CounterMonitor

Returns a NotificationInfo object containing the name of the Java class of the notification and the notification types sent by the counter monitor.

getNotificationInfo() - Method in class javax.management.monitor.GaugeMonitor

Returns a NotificationInfo object containing the name of the Java class of the notification and the notification types sent by the gauge monitor.

getNotificationInfo() - Method in class javax.management.monitor.StringMonitor

Returns a NotificationInfo object containing the name of the Java class of the notification and the notification types sent by the string monitor.

getNotificationInfo() - Method in interface javax.management.NotificationBroadcaster

Returns an array indicating, for each notification this MBean may send, the name of the Java class of the notification and the notification type.

getNotificationInfo() - Method in class javax.management.NotificationBroadcasterSupport

getNotificationInfo() - Method in class javax.management.relation.RelationService

Returns a NotificationInfo object containing the name of the Java class of the notification and the notification types sent.

getNotificationInfo() - Method in class javax.management.remote.JMXConnectorServer

Returns an array indicating the notifications that this MBean sends.

getNotificationInfo() - Method in class javax.management.StandardEmitterMBean

getNotificationInfo() - Method in class javax.management.timer.Timer

getNotificationMessage(Integer) - Method in class javax.management.timer.Timer

Gets the timer notification detailed message corresponding to the specified identifier.

getNotificationMessage(Integer) - Method in interface javax.management.timer.TimerMBean

Gets the timer notification detailed message corresponding to the specified identifier.

getNotifications() - Method in class javax.management.MBeanInfo

Returns the list of the notifications emitted by the MBean.

getNotifications() - Method in interface javax.management.modelmbean.ModelMBeanInfo

Returns the list of the notifications emitted by the MBean.

getNotifications() - Method in interface javax.management.openmbean.OpenMBeanInfo

Returns an array of MBeanNotificationInfo instances describing each notification emitted by the open MBean described by this OpenMBeanInfo instance.

getNotificationType(Integer) - Method in class javax.management.timer.Timer

Gets the timer notification type corresponding to the specified identifier.

getNotificationType(Integer) - Method in interface javax.management.timer.TimerMBean

Gets the timer notification type corresponding to the specified identifier.

getNotificationUserData(Integer) - Method in class javax.management.timer.Timer

Gets the timer notification user data object corresponding to the specified identifier.

getNotificationUserData(Integer) - Method in interface javax.management.timer.TimerMBean

Gets the timer notification user data object corresponding to the specified identifier.

getNotifTypes() - Method in class javax.management.MBeanNotificationInfo

Returns the array of strings (in dot notation) containing the notification types that the MBean may emit.

getNotify() - Method in class javax.management.monitor.CounterMonitor

Gets the notification's on/off switch value common to all observed MBeans.

getNotify() - Method in interface javax.management.monitor.CounterMonitorMBean

Gets the notification's on/off switch value.

getNotifyDiffer() - Method in class javax.management.monitor.StringMonitor

Gets the differing notification's on/off switch value common to all observed MBeans.

getNotifyDiffer() - Method in interface javax.management.monitor.StringMonitorMBean

Gets the differing notification's on/off switch value.

getNotifyHigh() - Method in class javax.management.monitor.GaugeMonitor

Gets the high notification's on/off switch value common to all observed MBeans.

getNotifyHigh() - Method in interface javax.management.monitor.GaugeMonitorMBean

Gets the high notification's on/off switch value.

getNotifyLow() - Method in class javax.management.monitor.GaugeMonitor

Gets the low notification's on/off switch value common to all observed MBeans.

getNotifyLow() - Method in interface javax.management.monitor.GaugeMonitorMBean

Gets the low notification's on/off switch value.

getNotifyMatch() - Method in class javax.management.monitor.StringMonitor

Gets the matching notification's on/off switch value common to all observed MBeans.

getNotifyMatch() - Method in interface javax.management.monitor.StringMonitorMBean

Gets the matching notification's on/off switch value.

getNoType(TypeKind) - Method in interface javax.lang.model.util.Types

Returns a pseudo-type used where no actual type is appropriate.

getNow(T) - Method in class java.util.concurrent.CompletableFuture

Returns the result value (or throws any encountered exception) if completed, else returns the given valueIfAbsent.

getNString(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated NCHAR, NVARCHAR or LONGNVARCHAR parameter as a String in the Java programming language.

getNString(String) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated NCHAR, NVARCHAR or LONGNVARCHAR parameter as a String in the Java programming language.

getNString(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a String in the Java programming language.

getNString(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a String in the Java programming language.

getNullFormatter() - Method in class javax.swing.text.DefaultFormatterFactory

Returns the formatter to use if the value is null.

getNullType() - Method in interface javax.lang.model.util.Types

Returns the null type.

getNumBands() - Method in class java.awt.image.Raster

Returns the number of bands (samples per pixel) in this Raster.

getNumBands() - Method in class java.awt.image.SampleModel

Returns the total number of bands of image data.

getNumBands() - Method in class javax.imageio.ImageTypeSpecifier

Return the number of bands specified by this object.

getNumBanks() - Method in class java.awt.image.DataBuffer

Returns the number of banks in this DataBuffer.

getNumber() - Method in class javax.swing.SpinnerNumberModel

Returns the value of the current element of the sequence.

getNumberFormat() - Method in class java.text.DateFormat

Gets the number formatter which this date/time formatter uses to format and parse a time.

getNumberInstance() - Static method in class java.text.NumberFormat

Returns a general-purpose number format for the current default FORMAT locale.

getNumberInstance(Locale) - Static method in class java.text.NumberFormat

Returns a general-purpose number format for the specified locale.

getNumberInstance(Locale) - Method in class java.text.spi.NumberFormatProvider

Returns a new general-purpose NumberFormat instance for the specified locale.

getNumberOfButtons() - Static method in class java.awt.MouseInfo

Returns the number of buttons on the mouse.

getNumberOfDependents() - Method in class java.util.concurrent.CompletableFuture

Returns the estimated number of CompletableFutures whose completions are awaiting completion of this CompletableFuture.

getNumberOfPages() - Method in class java.awt.print.Book

Returns the number of pages in this Book.

getNumberOfPages() - Method in interface java.awt.print.Pageable

Returns the number of pages in the set.

getNumberWaiting() - Method in class java.util.concurrent.CyclicBarrier

Returns the number of parties currently waiting at the barrier.

getNumChars() - Method in class java.awt.font.LineMetrics

Returns the number of characters (char values) in the text whose metrics are encapsulated by this LineMetrics object.

getNumColorComponents() - Method in class java.awt.image.ColorModel

Returns the number of color components in this ColorModel.

getNumComponents() - Method in class java.awt.color.ColorSpace

Returns the number of components of this ColorSpace.

getNumComponents() - Method in class java.awt.color.ICC_Profile

Returns the number of color components in the "input" color space of this profile.

getNumComponents() - Method in class java.awt.image.ColorModel

Returns the number of components, including alpha, in this ColorModel.

getNumComponents() - Method in class java.awt.image.LookupTable

Returns the number of components in the lookup table.

getNumComponents() - Method in class javax.imageio.ImageTypeSpecifier

Return the number of color components specified by this object.

getNumDataElements() - Method in class java.awt.image.ComponentSampleModel

Returns the number of data elements needed to transfer a pixel with the ComponentSampleModel.getDataElements(int, int, Object, DataBuffer) and ComponentSampleModel.setDataElements(int, int, Object, DataBuffer) methods.

getNumDataElements() - Method in class java.awt.image.MultiPixelPackedSampleModel

Returns the number of data elements needed to transfer one pixel via the MultiPixelPackedSampleModel.getDataElements(int, int, java.lang.Object, java.awt.image.DataBuffer) and MultiPixelPackedSampleModel.setDataElements(int, int, java.lang.Object, java.awt.image.DataBuffer) methods.

getNumDataElements() - Method in class java.awt.image.Raster

Returns the number of data elements needed to transfer one pixel via the getDataElements and setDataElements methods.

getNumDataElements() - Method in class java.awt.image.SampleModel

Returns the number of data elements needed to transfer a pixel via the getDataElements and setDataElements methods.

getNumDataElements() - Method in class java.awt.image.SinglePixelPackedSampleModel

Returns the number of data elements needed to transfer one pixel via the getDataElements and setDataElements methods.

getNumDesignAxes() - Method in interface java.awt.font.MultipleMaster

Returns the number of multiple master design controls.

getNumericCode() - Method in class java.util.Currency

Returns the ISO 4217 numeric code of this currency.

getNumericFunctions() - Method in interface java.sql.DatabaseMetaData

Retrieves a comma-separated list of math functions available with this database.

getNumericValue(char) - Static method in class java.lang.Character

Returns the int value that the specified Unicode character represents.

getNumericValue(int) - Static method in class java.lang.Character

Returns the int value that the specified character (Unicode code point) represents.

getNumFactors() - Method in class java.awt.image.RescaleOp

Returns the number of scaling factors and offsets used in this RescaleOp.

getNumGlyphs() - Method in class java.awt.Font

Returns the number of glyphs in this Font.

getNumGlyphs() - Method in class java.awt.font.GlyphVector

Returns the number of glyphs in this GlyphVector.

getNumImages(boolean) - Method in class javax.imageio.ImageReader

Returns the number of images, not including thumbnails, available from the current input source.

getNumParameters() - Method in class java.awt.image.renderable.ParameterBlock

Returns the number of parameters (not including source images).

getNumSources() - Method in class java.awt.image.renderable.ParameterBlock

Returns the number of source images.

getNumThumbnails() - Method in class javax.imageio.IIOImage

Returns the number of thumbnails stored in this IIOImage.

getNumThumbnails(int) - Method in class javax.imageio.ImageReader

Returns the number of thumbnail preview images associated with the given image.

getNumThumbnailsSupported(ImageTypeSpecifier, ImageWriteParam, IIOMetadata, IIOMetadata) - Method in class javax.imageio.ImageWriter

Returns the number of thumbnails supported by the format being written, given the image type and any additional write parameters and metadata objects that will be used during encoding.

getNumXTiles() - Method in class java.awt.image.BufferedImage

Returns the number of tiles in the x direction.

getNumXTiles() - Method in interface java.awt.image.RenderedImage

Returns the number of tiles in the X direction.

getNumYTiles() - Method in class java.awt.image.BufferedImage

Returns the number of tiles in the y direction.

getNumYTiles() - Method in interface java.awt.image.RenderedImage

Returns the number of tiles in the Y direction.

getObject() - Method in class java.security.GuardedObject

Retrieves the guarded object, or throws an exception if access to the guarded object is denied by the guard.

getObject() - Method in class java.security.SignedObject

Retrieves the encapsulated object.

getObject(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated parameter as an Object in the Java programming language.

getObject(int, Map<String, Class<?>>) - Method in interface java.sql.CallableStatement

Returns an object representing the value of OUT parameter parameterIndex and uses map for the custom mapping of the parameter value.

getObject(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a parameter as an Object in the Java programming language.

getObject(String, Map<String, Class<?>>) - Method in interface java.sql.CallableStatement

Returns an object representing the value of OUT parameter parameterName and uses map for the custom mapping of the parameter value.

getObject(int, Class<T>) - Method in interface java.sql.CallableStatement

Returns an object representing the value of OUT parameter parameterIndex and will convert from the SQL type of the parameter to the requested Java data type, if the conversion is supported.

getObject(String, Class<T>) - Method in interface java.sql.CallableStatement

Returns an object representing the value of OUT parameter parameterName and will convert from the SQL type of the parameter to the requested Java data type, if the conversion is supported.

getObject(Map<String, Class<?>>) - Method in interface java.sql.Ref

Retrieves the referenced object and maps it to a Java type using the given type map.

getObject() - Method in interface java.sql.Ref

Retrieves the SQL structured type instance referenced by this Ref object.

getObject(int) - Method in interface java.sql.ResultSet

Gets the value of the designated column in the current row of this ResultSet object as an Object in the Java programming language.

getObject(String) - Method in interface java.sql.ResultSet

Gets the value of the designated column in the current row of this ResultSet object as an Object in the Java programming language.

getObject(int, Map<String, Class<?>>) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as an Object in the Java programming language.

getObject(String, Map<String, Class<?>>) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as an Object in the Java programming language.

getObject(int, Class<T>) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object and will convert from the SQL type of the column to the requested Java data type, if the conversion is supported.

getObject(String, Class<T>) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object and will convert from the SQL type of the column to the requested Java data type, if the conversion is supported.

getObject(String) - Method in class java.util.ResourceBundle

Gets an object for the given key from this resource bundle or one of its parents.

getObject(Key) - Method in class javax.crypto.SealedObject

Retrieves the original (encapsulated) object.

getObject(Cipher) - Method in class javax.crypto.SealedObject

Retrieves the original (encapsulated) object.

getObject(Key, String) - Method in class javax.crypto.SealedObject

Retrieves the original (encapsulated) object.

getObject() - Method in class javax.naming.Binding

Retrieves the object bound to the name of this binding.

getObject() - Method in class javax.naming.spi.DirStateFactory.Result

Retrieves the object to be bound.

getObject() - Method in class javax.sql.rowset.serial.SerialJavaObject

Returns an Object that is a copy of this SerialJavaObject object.

getObject(Map<String, Class<?>>) - Method in class javax.sql.rowset.serial.SerialRef

Returns an Object representing the SQL structured type to which this SerialRef object refers.

getObject() - Method in class javax.sql.rowset.serial.SerialRef

Returns an Object representing the SQL structured type to which this SerialRef object refers.

getObject() - Method in class javax.xml.bind.helpers.ValidationEventLocatorImpl

getObject() - Method in interface javax.xml.bind.ValidationEventLocator

Return a reference to the object in the Java content tree if available

getObjectArrayMaxLength(String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns the maximum number of array elements that may be used to define the Object reference within the named element.

getObjectArrayMaxLength(String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getObjectArrayMinLength(String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns the minimum number of array elements that may be used to define the Object reference within the named element.

getObjectArrayMinLength(String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getObjectClass(String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns the Class type of the Object reference stored within the element.

getObjectClass(String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getObjectDefaultValue(String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns an Objects containing the default value for the Object reference within the named element.

getObjectDefaultValue(String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getObjectEnumerations(String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns an array of Objects containing the legal enumerated values for the Object reference within the named element.

getObjectEnumerations(String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getObjectForLayer(int) - Method in class javax.swing.JLayeredPane

Returns the Integer object associated with a specified layer.

getObjectInstance(ObjectName) - Method in interface javax.management.MBeanServer

getObjectInstance(ObjectName) - Method in interface javax.management.MBeanServerConnection

Gets the ObjectInstance for a given MBean registered with the MBean server.

getObjectInstance(ObjectName, Subject) - Method in interface javax.management.remote.rmi.RMIConnection

Handles the method MBeanServerConnection.getObjectInstance(ObjectName).

getObjectInstance(ObjectName, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl

getObjectInstance(ObjectName, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub

getObjectInstance(Object, Name, Context, Hashtable<?, ?>, Attributes) - Static method in class javax.naming.spi.DirectoryManager

Creates an instance of an object for the specified object, attributes, and environment.

getObjectInstance(Object, Name, Context, Hashtable<?, ?>, Attributes) - Method in interface javax.naming.spi.DirObjectFactory

Creates an object using the location or reference information, and attributes specified.

getObjectInstance(Object, Name, Context, Hashtable<?, ?>) - Static method in class javax.naming.spi.NamingManager

Creates an instance of an object for the specified object and environment.

getObjectInstance(Object, Name, Context, Hashtable<?, ?>) - Method in interface javax.naming.spi.ObjectFactory

Creates an object using the location or reference information specified.

getObjectMaxValue(String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns the maximum legal value for the Object reference within the named element.

getObjectMaxValue(String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getObjectMinValue(String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns the minimum legal value for the Object reference within the named element.

getObjectMinValue(String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getObjectName() - Method in interface java.lang.management.PlatformManagedObject

Returns an ObjectName instance representing the object name of this platform managed object.

getObjectName() - Method in class javax.management.MBeanServerInvocationHandler

The name of the MBean within the MBean server to which methods are forwarded.

getObjectName() - Method in class javax.management.ObjectInstance

Returns the object name part.

getObjectName() - Method in class javax.management.relation.RelationNotification

Returns the ObjectName of the created/removed/updated relation.

getObjectParameter(int) - Method in class java.awt.image.renderable.ParameterBlock

Gets a parameter as an object.

getObjectPendingFinalizationCount() - Method in interface java.lang.management.MemoryMXBean

Returns the approximate number of objects for which finalization is pending.

getObjects() - Method in interface javax.xml.crypto.dsig.XMLSignature

Returns an unmodifiable list of XMLObjects contained in this XMLSignature.

getObjectSize(Object) - Method in interface java.lang.instrument.Instrumentation

Returns an implementation-specific approximation of the amount of storage consumed by the specified object.

getObjectStreamClass() - Method in class java.io.ObjectInputStream.GetField

Get the ObjectStreamClass that describes the fields in the stream.

getObjectValueType(String) - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns one of the enumerated values starting with VALUE_, indicating the type of values (enumeration, range, or array) that are allowed for the Object reference.

getObjectValueType(String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getObservedAttribute() - Method in class javax.management.monitor.Monitor

Gets the attribute being observed.

getObservedAttribute() - Method in interface javax.management.monitor.MonitorMBean

Gets the attribute being observed.

getObservedAttribute() - Method in class javax.management.monitor.MonitorNotification

Gets the observed attribute of this monitor notification.

getObservedObject() - Method in class javax.management.monitor.Monitor

Deprecated.
As of JMX 1.2, replaced by Monitor.getObservedObjects()

getObservedObject() - Method in interface javax.management.monitor.MonitorMBean

Deprecated.
As of JMX 1.2, replaced by MonitorMBean.getObservedObjects()

getObservedObject() - Method in class javax.management.monitor.MonitorNotification

Gets the observed object of this monitor notification.

getObservedObjects() - Method in class javax.management.monitor.Monitor

Returns an array containing the objects being observed.

getObservedObjects() - Method in interface javax.management.monitor.MonitorMBean

Returns an array containing the objects being observed.

getOcspExtensions() - Method in class java.security.cert.PKIXRevocationChecker

Gets the optional OCSP request extensions.

getOcspResponder() - Method in class java.security.cert.PKIXRevocationChecker

Gets the URI that identifies the location of the OCSP responder.

getOcspResponderCert() - Method in class java.security.cert.PKIXRevocationChecker

Gets the OCSP responder's certificate.

getOcspResponses() - Method in class java.security.cert.PKIXRevocationChecker

Gets the OCSP responses.

getOctetStream() - Method in class javax.xml.crypto.OctetStreamData

Returns the input stream of this OctetStreamData.

getOffendingNode() - Method in exception javax.imageio.metadata.IIOInvalidTreeException

Returns the Node that caused the error in parsing.

getOffscreenBuffer(Component, int, int) - Method in class javax.swing.RepaintManager

Return the offscreen buffer that should be used as a double buffer with the component c.

getOffset(int, int) - Method in class java.awt.image.ComponentSampleModel

Gets the offset for the first band of pixel (x,y).

getOffset(int, int, int) - Method in class java.awt.image.ComponentSampleModel

Gets the offset for band b of pixel (x,y).

getOffset() - Method in class java.awt.image.DataBuffer

Returns the offset of the default bank in array elements.

getOffset() - Method in class java.awt.image.LookupTable

Returns the offset.

getOffset(int, int) - Method in class java.awt.image.MultiPixelPackedSampleModel

Returns the offset of pixel (x, y) in data array elements.

getOffset(int, int) - Method in class java.awt.image.SinglePixelPackedSampleModel

Returns the offset (in data array elements) of pixel (x,y).

getOffset() - Method in class java.io.ObjectStreamField

Offset of field within instance data.

getOffset() - Method in class java.net.DatagramPacket

Returns the offset of the data to be sent or the offset of the data received.

getOffset() - Method in class java.text.CollationElementIterator

Returns the character offset in the original text corresponding to the next collation element.

getOffset() - Method in interface java.time.chrono.ChronoZonedDateTime

Gets the zone offset, such as '+01:00'.

getOffset() - Method in class java.time.OffsetDateTime

Gets the zone offset, such as '+01:00'.

getOffset() - Method in class java.time.OffsetTime

Gets the zone offset, such as '+01:00'.

getOffset(Instant) - Method in class java.time.zone.ZoneRules

Gets the offset applicable at the specified instant in these rules.

getOffset(LocalDateTime) - Method in class java.time.zone.ZoneRules

Gets a suitable offset for the specified local date-time in these rules.

getOffset() - Method in class java.time.ZonedDateTime

Gets the zone offset, such as '+01:00'.

getOffset(long) - Method in class java.util.SimpleTimeZone

Returns the offset of this time zone from UTC at the given time.

getOffset(int, int, int, int, int, int) - Method in class java.util.SimpleTimeZone

Returns the difference in milliseconds between local time and UTC, taking into account both the raw offset and the effect of daylight saving, for the specified date and time.

getOffset(int, int, int, int, int, int) - Method in class java.util.TimeZone

Gets the time zone offset, for current date, modified in case of daylight savings.

getOffset(long) - Method in class java.util.TimeZone

Returns the offset of this time zone from UTC at the specified date.

getOffset() - Method in class javax.imageio.stream.IIOByteBuffer

Returns the offset within the byte array returned by getData at which the data of interest start.

getOffset() - Method in class javax.management.monitor.CounterMonitor

Gets the offset value common to all observed MBeans.

getOffset() - Method in interface javax.management.monitor.CounterMonitorMBean

Gets the offset value.

getOffset() - Method in class javax.print.attribute.EnumSyntax

Returns the lowest integer value used by this enumeration value's enumeration class.

getOffset() - Method in class javax.print.attribute.standard.Finishings

Returns the lowest integer value used by class Finishings.

getOffset() - Method in class javax.print.attribute.standard.OrientationRequested

Returns the lowest integer value used by class OrientationRequested.

getOffset() - Method in class javax.print.attribute.standard.PrintQuality

Returns the lowest integer value used by class PrintQuality.

getOffset() - Method in interface javax.swing.event.DocumentEvent

Returns the offset within the document of the start of the change.

getOffset() - Method in class javax.swing.plaf.basic.BasicToolBarUI.DragWindow

getOffset() - Method in class javax.swing.text.AbstractDocument.DefaultDocumentEvent

Returns the offset within the document of the start of the change.

getOffset(int, int) - Method in class javax.swing.text.BoxView

Fetches the offset of a particular child's current layout.

getOffset() - Method in class javax.swing.text.DefaultStyledDocument.ElementSpec

Gets the starting offset.

getOffset() - Method in interface javax.swing.text.Position

Fetches the current offset within the document.

getOffset() - Method in class javax.xml.bind.helpers.ValidationEventLocatorImpl

getOffset() - Method in interface javax.xml.bind.ValidationEventLocator

Return the byte offset if available

getOffsetAfter() - Method in class java.time.zone.ZoneOffsetTransition

Gets the offset after the transition.

getOffsetAfter() - Method in class java.time.zone.ZoneOffsetTransitionRule

Gets the offset after the transition.

getOffsetBefore() - Method in class java.time.zone.ZoneOffsetTransition

Gets the offset before the transition.

getOffsetBefore() - Method in class java.time.zone.ZoneOffsetTransitionRule

Gets the offset before the transition.

getOffsetHit(int) - Method in class java.awt.font.TextHitInfo

Creates a TextHitInfo whose character index is offset by delta from the charIndex of this TextHitInfo.

getOffsets() - Method in class java.awt.image.DataBuffer

Returns the offsets (in array elements) of all the banks.

getOffsets(float[]) - Method in class java.awt.image.RescaleOp

Returns the offsets in the given array.

getOldBinding() - Method in class javax.naming.event.NamingEvent

Retrieves the binding of the object before the change.

getOldLeadSelectionPath() - Method in class javax.swing.event.TreeSelectionEvent

Returns the path that was previously the lead path.

getOldRoleValue() - Method in class javax.management.relation.RelationNotification

Returns old value of updated role (only for role update).

getOldState() - Method in class java.awt.event.WindowEvent

For WINDOW_STATE_CHANGED events returns the previous state of the window.

getOldValue() - Method in class java.beans.PropertyChangeEvent

Gets the old value for the property, expressed as an Object.

getOldValue() - Method in class javax.management.AttributeChangeNotification

Gets the old value of the attribute which has changed.

getOmni() - Method in interface javax.sound.midi.MidiChannel

Obtains the current omni mode.

getOOBInline() - Method in class java.net.Socket

Tests if SO_OOBINLINE is enabled.

getOpacity() - Method in class java.awt.Window

Returns the opacity of the window.

getOpenIcon() - Method in class javax.swing.tree.DefaultTreeCellRenderer

Returns the icon used to represent non-leaf nodes that are expanded.

getOpenType() - Method in class javax.management.openmbean.OpenMBeanAttributeInfoSupport

Returns the open type for the values of the attribute described by this OpenMBeanAttributeInfoSupport instance.

getOpenType() - Method in interface javax.management.openmbean.OpenMBeanParameterInfo

Returns the open type of the values of the parameter described by this OpenMBeanParameterInfo instance.

getOpenType() - Method in class javax.management.openmbean.OpenMBeanParameterInfoSupport

Returns the open type for the values of the parameter described by this OpenMBeanParameterInfoSupport instance.

getOperatingSystemMXBean() - Static method in class java.lang.management.ManagementFactory

Returns the managed bean for the operating system on which the Java virtual machine is running.

getOperation() - Method in class java.rmi.server.Operation

Deprecated.
no replacement

getOperation(String) - Method in interface javax.management.modelmbean.ModelMBeanInfo

Returns a ModelMBeanOperationInfo requested by name.

getOperation(String) - Method in class javax.management.modelmbean.ModelMBeanInfoSupport

getOperations() - Method in interface java.rmi.server.Skeleton

Deprecated.
no replacement

getOperations() - Method in class javax.management.MBeanInfo

Returns the list of operations of the MBean.

getOperations() - Method in interface javax.management.modelmbean.ModelMBeanInfo

Returns the list of operations of the MBean.

getOperations() - Method in interface javax.management.openmbean.OpenMBeanInfo

Returns an array of OpenMBeanOperationInfo instances describing each operation in the open MBean described by this OpenMBeanInfo instance.

getOppositeComponent() - Method in class java.awt.event.FocusEvent

Returns the other Component involved in this focus change.

getOppositeWindow() - Method in class java.awt.event.WindowEvent

Returns the other Window involved in this focus or activation change.

getOptimizeHuffmanTables() - Method in class javax.imageio.plugins.jpeg.JPEGImageWriteParam

Returns the value passed into the most recent call to setOptimizeHuffmanTables, or false if setOptimizeHuffmanTables has never been called.

getOption(int) - Method in interface java.net.SocketOptions

Fetch the value of an option.

getOption(SocketOption<T>) - Method in interface java.nio.channels.NetworkChannel

Returns the value of a socket option.

getOptions() - Method in class java.security.cert.PKIXRevocationChecker

Gets the revocation options.

getOptions() - Method in interface javax.annotation.processing.ProcessingEnvironment

Returns the processor-specific options passed to the annotation processing tool.

getOptions() - Method in class javax.security.auth.callback.ConfirmationCallback

Get the confirmation options.

getOptions() - Method in class javax.security.auth.login.AppConfigurationEntry

Get the options configured for this LoginModule.

getOptions() - Method in class javax.swing.JOptionPane

Returns the choices the user can make.

getOptionType() - Method in class javax.security.auth.callback.ConfirmationCallback

Get the option type.

getOptionType() - Method in class javax.swing.JOptionPane

Returns the type of options that are displayed.

getOrDefault(Object, Object) - Method in class java.security.Provider

getOrDefault(Object, V) - Method in class java.util.concurrent.ConcurrentHashMap

Returns the value to which the specified key is mapped, or the given default value if this map contains no mapping for the key.

getOrDefault(Object, V) - Method in interface java.util.concurrent.ConcurrentMap

Returns the value to which the specified key is mapped, or defaultValue if this map contains no mapping for the key.

getOrDefault(Object, V) - Method in class java.util.concurrent.ConcurrentSkipListMap

Returns the value to which the specified key is mapped, or the given defaultValue if this map contains no mapping for the key.

getOrDefault(Object, V) - Method in class java.util.HashMap

getOrDefault(Object, V) - Method in class java.util.Hashtable

getOrDefault(Object, V) - Method in class java.util.LinkedHashMap

Returns the value to which the specified key is mapped, or defaultValue if this map contains no mapping for the key.

getOrDefault(Object, V) - Method in interface java.util.Map

Returns the value to which the specified key is mapped, or defaultValue if this map contains no mapping for the key.

getOrder() - Method in class java.security.spec.ECParameterSpec

Returns the order of the generator.

getOrientation() - Method in interface java.awt.Adjustable

Gets the orientation of the adjustable object.

getOrientation(Locale) - Static method in class java.awt.ComponentOrientation

Returns the orientation that is appropriate for the given locale.

getOrientation(ResourceBundle) - Static method in class java.awt.ComponentOrientation

Deprecated.
As of J2SE 1.4, use ComponentOrientation.getOrientation(java.util.Locale).

getOrientation() - Method in class java.awt.print.PageFormat

Returns the orientation of this PageFormat.

getOrientation() - Method in class java.awt.Scrollbar

Returns the orientation of this scroll bar.

getOrientation() - Method in class java.awt.ScrollPaneAdjustable

Returns the orientation of this scrollbar.

getOrientation() - Method in class javax.swing.JProgressBar

Returns SwingConstants.VERTICAL or SwingConstants.HORIZONTAL, depending on the orientation of the progress bar.

getOrientation() - Method in class javax.swing.JScrollBar

Returns the component's orientation (horizontal or vertical).

getOrientation() - Method in class javax.swing.JSeparator

Returns the orientation of this separator.

getOrientation() - Method in class javax.swing.JSlider

Return this slider's vertical or horizontal orientation.

getOrientation() - Method in class javax.swing.JSplitPane

Returns the orientation.

getOrientation() - Method in class javax.swing.JToolBar

Returns the current orientation of the tool bar.

getOrientation() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI

Returns the orientation for the JSplitPane.

getOrientation() - Method in class javax.swing.plaf.basic.BasicToolBarUI.DragWindow

Returns the orientation of the toolbar window when the toolbar is floating.

getOrientationRequested() - Method in class java.awt.PageAttributes

Returns the print orientation for pages using these attributes.

getOrigin() - Method in class java.awt.PageAttributes

Returns whether drawing at (0, 0) to pages using these attributes draws at the upper-left corner of the physical page, or at the upper-left corner of the printable area.

getOriginal() - Method in interface javax.sql.rowset.CachedRowSet

Returns a ResultSet object containing the original value of this CachedRowSet object.

getOriginal() - Method in interface javax.sql.RowSetInternal

Retrieves a ResultSet object containing the original value of this RowSet object.

getOriginalRow() - Method in interface javax.sql.rowset.CachedRowSet

Returns a ResultSet object containing the original value for the current row only of this CachedRowSet object.

getOriginalRow() - Method in interface javax.sql.RowSetInternal

Retrieves a ResultSet object containing the original value of the current row only.

getOriginatingNode() - Method in interface javax.xml.transform.dom.DOMLocator

Return the node where the event occurred.

getOriginatingProvider() - Method in class javax.imageio.ImageReader

Returns the ImageReaderSpi that was passed in on the constructor.

getOriginatingProvider() - Method in class javax.imageio.ImageWriter

Returns the ImageWriterSpi object that created this ImageWriter, or null if this object was not created through the IIORegistry.

getOtherFile() - Method in exception java.nio.file.FileSystemException

Returns the other file used to create this exception.

getOtherHit() - Method in class java.awt.font.TextHitInfo

Creates a TextHitInfo on the other side of the insertion point.

getOtherPrimeInfo() - Method in interface java.security.interfaces.RSAMultiPrimePrivateCrtKey

Returns the otherPrimeInfo or null if there are only two prime factors (p and q).

getOtherPrimeInfo() - Method in class java.security.spec.RSAMultiPrimePrivateCrtKeySpec

Returns a copy of the otherPrimeInfo or null if there are only two prime factors (p and q).

getOutline() - Method in class java.awt.font.GlyphVector

Returns a Shape whose interior corresponds to the visual representation of this GlyphVector.

getOutline(float, float) - Method in class java.awt.font.GlyphVector

Returns a Shape whose interior corresponds to the visual representation of this GlyphVector when rendered at x, y.

getOutline(AffineTransform) - Method in class java.awt.font.GraphicAttribute

Return a Shape that represents the region that this GraphicAttribute renders.

getOutline(AffineTransform) - Method in class java.awt.font.ShapeGraphicAttribute

Return a Shape that represents the region that this ShapeGraphicAttribute renders.

getOutline(AffineTransform) - Method in class java.awt.font.TextLayout

Returns a Shape representing the outline of this TextLayout.

getOutput() - Method in class javax.imageio.ImageWriter

Returns the ImageOutputStream or other Object set by the most recent call to the setOutput method.

getOutputClass() - Method in class javax.imageio.spi.ImageOutputStreamSpi

Returns a Class object representing the class or interface type that must be implemented by an output destination in order to be "wrapped" in an ImageOutputStream via the createOutputStreamInstance method.

getOutputFormat() - Method in class javax.print.StreamPrintService

Returns the document format emitted by this print service.

getOutputFormat() - Method in class javax.print.StreamPrintServiceFactory

Queries the factory for the document format that is emitted by printers obtained from this factory.

getOutputLength() - Method in class javax.xml.crypto.dsig.spec.HMACParameterSpec

Returns the truncation length.

getOutputProperties() - Method in interface javax.xml.transform.Templates

Get the properties corresponding to the effective xsl:output element.

getOutputProperties() - Method in class javax.xml.transform.Transformer

Get a copy of the output properties for the transformation.

getOutputProperty(String) - Method in class javax.xml.transform.Transformer

Get an output property that is in effect for the transformer.

getOutputSize(int) - Method in class javax.crypto.Cipher

Returns the length in bytes that an output buffer would need to be in order to hold the result of the next update or doFinal operation, given the input length inputLen (in bytes).

getOutputSize(int) - Method in class javax.crypto.ExemptionMechanism

Returns the length in bytes that an output buffer would need to be in order to hold the result of the next genExemptionBlob operation, given the input length inputLen (in bytes).

getOutputStatement(String) - Method in interface javax.script.ScriptEngineFactory

Returns a String that can be used as a statement to display the specified String using the syntax of the supported scripting language.

getOutputStream() - Method in class java.lang.Process

Returns the output stream connected to the normal input of the subprocess.

getOutputStream() - Method in class java.net.Socket

Returns an output stream for this socket.

getOutputStream() - Method in class java.net.SocketImpl

Returns an output stream for this socket.

getOutputStream() - Method in class java.net.URLConnection

Returns an output stream that writes to this connection.

getOutputStream() - Method in class java.rmi.server.LogStream

Deprecated.
no replacement

getOutputStream() - Method in interface java.rmi.server.RemoteCall

Deprecated.
no replacement

getOutputStream() - Method in class javax.activation.DataHandler

Get an OutputStream for this DataHandler to allow overwriting the underlying data.

getOutputStream() - Method in interface javax.activation.DataSource

This method returns an OutputStream where the data can be written and throws the appropriate exception if it can not do so.

getOutputStream() - Method in class javax.activation.FileDataSource

This method will return an OutputStream representing the the data and will throw an IOException if it can not do so.

getOutputStream() - Method in class javax.activation.URLDataSource

The getOutputStream method from the URL.

getOutputStream() - Method in class javax.print.StreamPrintService

Gets the output stream.

getOutputStream() - Method in class javax.xml.transform.stream.StreamResult

Get the byte stream that was set with setOutputStream.

getOutputTypes() - Method in class javax.imageio.spi.ImageWriterSpi

Returns an array of Class objects indicating what types of objects may be used as arguments to the writer's setOutput method.

getOutsideBorder() - Method in class javax.swing.border.CompoundBorder

Returns the outside border object.

getOverwriteMode() - Method in class javax.swing.text.DefaultFormatter

Returns the behavior when inserting characters.

getOwnedWindows() - Method in class java.awt.Window

Return an array containing all the windows this window currently owns.

getOwner() - Method in class java.awt.Window

Returns the owner of this window.

getOwner() - Method in class java.beans.XMLDecoder

Gets the owner of this decoder.

getOwner() - Method in class java.beans.XMLEncoder

Gets the owner of this encoder.

getOwner() - Method in interface java.nio.file.attribute.FileOwnerAttributeView

Read the file owner.

getOwner(Path, LinkOption...) - Static method in class java.nio.file.Files

Returns the owner of a file.

getOwner() - Method in class java.util.concurrent.locks.ReentrantLock

Returns the thread that currently owns this lock, or null if not owned.

getOwner() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock

Returns the thread that currently owns the write lock, or null if not owned.

getOwnerDocument() - Method in class javax.imageio.metadata.IIOMetadataNode

Returns null, since IIOMetadataNodes do not belong to any Document.

getOwnerDocument() - Method in interface org.w3c.dom.Node

The Document object associated with this node.

getOwnerElement() - Method in interface org.w3c.dom.Attr

The Element node this attribute is attached to or null if this attribute is not in use.

getOwnerlessWindows() - Static method in class java.awt.Window

Returns an array of all Windows created by this application that have no owner.

getOwnerType() - Method in interface java.lang.reflect.ParameterizedType

Returns a Type object representing the type that this type is a member of.

getP() - Method in interface java.security.interfaces.DSAParams

Returns the prime, p.

getP() - Method in class java.security.spec.DSAParameterSpec

Returns the prime p.

getP() - Method in class java.security.spec.DSAPrivateKeySpec

Returns the prime p.

getP() - Method in class java.security.spec.DSAPublicKeySpec

Returns the prime p.

getP() - Method in class java.security.spec.ECFieldFp

Returns the prime p of this prime finite field.

getP() - Method in class javax.crypto.spec.DHParameterSpec

Returns the prime modulus p.

getP() - Method in class javax.crypto.spec.DHPrivateKeySpec

Returns the prime modulus p.

getP() - Method in class javax.crypto.spec.DHPublicKeySpec

Returns the prime modulus p.

getP1() - Method in class java.awt.geom.CubicCurve2D.Double

Returns the start point.

getP1() - Method in class java.awt.geom.CubicCurve2D.Float

Returns the start point.

getP1() - Method in class java.awt.geom.CubicCurve2D

Returns the start point.

getP1() - Method in class java.awt.geom.Line2D.Double

Returns the start Point2D of this Line2D.

getP1() - Method in class java.awt.geom.Line2D.Float

Returns the start Point2D of this Line2D.

getP1() - Method in class java.awt.geom.Line2D

Returns the start Point2D of this Line2D.

getP1() - Method in class java.awt.geom.QuadCurve2D.Double

Returns the start point.

getP1() - Method in class java.awt.geom.QuadCurve2D.Float

Returns the start point.

getP1() - Method in class java.awt.geom.QuadCurve2D

Returns the start point.

getP2() - Method in class java.awt.geom.CubicCurve2D.Double

Returns the end point.

getP2() - Method in class java.awt.geom.CubicCurve2D.Float

Returns the end point.

getP2() - Method in class java.awt.geom.CubicCurve2D

Returns the end point.

getP2() - Method in class java.awt.geom.Line2D.Double

Returns the end Point2D of this Line2D.

getP2() - Method in class java.awt.geom.Line2D.Float

Returns the end Point2D of this Line2D.

getP2() - Method in class java.awt.geom.Line2D

Returns the end Point2D of this Line2D.

getP2() - Method in class java.awt.geom.QuadCurve2D.Double

Returns the end point.

getP2() - Method in class java.awt.geom.QuadCurve2D.Float

Returns the end point.

getP2() - Method in class java.awt.geom.QuadCurve2D

Returns the end point.

getPackage() - Method in class java.lang.Class

Gets the package for this class.

getPackage(String) - Method in class java.lang.ClassLoader

Returns a Package that has been defined by this class loader or any of its ancestors.

getPackage(String) - Static method in class java.lang.Package

Find a package by name in the callers ClassLoader instance.

getPackageElement(CharSequence) - Method in interface javax.lang.model.util.Elements

Returns a package given its fully qualified name.

getPackageOf(Element) - Method in interface javax.lang.model.util.Elements

Returns the package of an element.

getPackages() - Method in class java.lang.ClassLoader

Returns all of the Packages defined by this class loader and its ancestors.

getPackages() - Static method in class java.lang.Package

Get all the packages currently known for the caller's ClassLoader instance.

getPacketBufferSize() - Method in interface javax.net.ssl.SSLSession

Gets the current size of the largest SSL/TLS packet that is expected when using this session.

getPadding() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout

getPage() - Method in class javax.swing.JEditorPane

Gets the current URL being displayed.

getPageDimension() - Method in class java.awt.PrintJob

Returns the dimensions of the page in pixels.

getPageFormat(int) - Method in class java.awt.print.Book

Returns the PageFormat of the page specified by pageIndex.

getPageFormat(int) - Method in interface java.awt.print.Pageable

Returns the PageFormat of the page specified by pageIndex.

getPageFormat(PrintRequestAttributeSet) - Method in class java.awt.print.PrinterJob

Calculates a PageFormat with values consistent with those supported by the current PrintService for this job (ie the value returned by getPrintService()) and media, printable area and orientation contained in attributes.

getPageIncrement() - Method in class java.awt.Scrollbar

Deprecated.
As of JDK version 1.1, replaced by getBlockIncrement().

getPageRanges() - Method in class java.awt.JobAttributes

Specifies, for jobs using these attributes, the ranges of pages to be printed, if a range of pages is to be printed.

getPageResolution() - Method in class java.awt.PrintJob

Returns the resolution of the page in pixels per inch.

getPageSize() - Method in interface javax.sql.rowset.CachedRowSet

Returns the page-size for the CachedRowSet object

getPaint() - Method in class java.awt.Graphics2D

Returns the current Paint of the Graphics2D context.

getPaint() - Method in class javax.swing.border.StrokeBorder

Returns the Paint object used to generate a color during the border rendering.

getPaintContext() - Method in class javax.swing.plaf.nimbus.AbstractRegionPainter

Gets the PaintContext for this painting operation.

getPainter(SynthContext) - Method in class javax.swing.plaf.nimbus.NimbusStyle

Returns the SynthPainter that will be used for painting.

getPainter(SynthContext) - Method in class javax.swing.plaf.synth.SynthStyle

Returns the SynthPainter that will be used for painting.

getPainter(GlyphView, int, int) - Method in class javax.swing.text.GlyphView.GlyphPainter

Create a painter to use for the given GlyphView.

getPainter() - Method in interface javax.swing.text.Highlighter.Highlight

Gets the painter for the highlighter.

getPaintLabels() - Method in class javax.swing.JSlider

Tells if labels are to be painted.

getPaintTicks() - Method in class javax.swing.JSlider

Tells if tick marks are to be painted.

getPaintTrack() - Method in class javax.swing.JSlider

Tells if the track (area the slider slides in) is to be painted.

getPaper() - Method in class java.awt.print.PageFormat

Returns a copy of the Paper object associated with this PageFormat.

getParagraphAttributes() - Method in class javax.swing.JTextPane

Fetches the current paragraph attributes in effect at the location of the caret, or null if none.

getParagraphElement(int) - Method in class javax.swing.text.AbstractDocument

Get the paragraph element containing the given position.

getParagraphElement(int) - Method in class javax.swing.text.DefaultStyledDocument

Gets the paragraph element at the offset pos.

getParagraphElement(int) - Method in class javax.swing.text.PlainDocument

Get the paragraph element containing the given position.

getParagraphElement(int) - Method in interface javax.swing.text.StyledDocument

Gets the element that represents the paragraph that encloses the given offset within the document.

getParagraphElement(JTextComponent, int) - Static method in class javax.swing.text.Utilities

Determines the element to use for a paragraph/line.

getParallelism() - Method in class java.util.concurrent.ForkJoinPool

Returns the targeted parallelism level of this pool.

getParamClasses() - Method in class java.awt.image.renderable.ParameterBlock

Returns an array of Class objects describing the types of the parameters.

getParameter(String) - Method in class java.applet.Applet

Returns the value of the named parameter in the HTML tag.

getParameter(String) - Method in interface java.applet.AppletStub

Returns the value of the named parameter in the HTML tag.

getParameter(String) - Method in class java.awt.datatransfer.DataFlavor

Returns the human presentable name for this DataFlavor if paramName equals "humanPresentableName".

getParameter(String) - Method in class java.security.Signature

Deprecated.

getParameter() - Method in exception java.sql.DataTruncation

Indicates whether the value truncated was a parameter value or a column value.

getParameter(String) - Method in class javax.activation.MimeType

Retrieve the value associated with the given name, or null if there is no current association.

getParameter(String) - Method in class javax.print.DocFlavor

Returns a String representing a MIME parameter.

getParameter(String) - Method in interface javax.script.ScriptEngineFactory

Returns the value of an attribute whose meaning may be implementation-specific.

getParameter(String) - Method in class javax.xml.transform.Transformer

Get a parameter that was explicitly set with setParameter.

getParameter(String) - Method in interface org.w3c.dom.DOMConfiguration

Return the value of a parameter if known.

getParameterAnnotations() - Method in class java.lang.reflect.Constructor

Returns an array of arrays of Annotations that represent the annotations on the formal parameters, in declaration order, of the Executable represented by this object.

getParameterAnnotations() - Method in class java.lang.reflect.Executable

Returns an array of arrays of Annotations that represent the annotations on the formal parameters, in declaration order, of the Executable represented by this object.

getParameterAnnotations() - Method in class java.lang.reflect.Method

Returns an array of arrays of Annotations that represent the annotations on the formal parameters, in declaration order, of the Executable represented by this object.

getParameterBlock() - Method in class java.awt.image.renderable.RenderableImageOp

Returns a reference to the current parameter block.

getParameterClassName(int) - Method in interface java.sql.ParameterMetaData

Retrieves the fully-qualified name of the Java class whose instances should be passed to the method PreparedStatement.setObject.

getParameterCount() - Method in class java.lang.reflect.Constructor

Returns the number of formal parameters (whether explicitly declared or implicitly declared or neither) for the executable represented by this object.

getParameterCount() - Method in class java.lang.reflect.Executable

Returns the number of formal parameters (whether explicitly declared or implicitly declared or neither) for the executable represented by this object.

getParameterCount() - Method in class java.lang.reflect.Method

Returns the number of formal parameters (whether explicitly declared or implicitly declared or neither) for the executable represented by this object.

getParameterCount() - Method in interface java.sql.ParameterMetaData

Retrieves the number of parameters in the PreparedStatement object for which this ParameterMetaData object contains information.

getParameterDescriptors() - Method in class java.beans.MethodDescriptor

Gets the ParameterDescriptor for each of this MethodDescriptor's method's parameters.

getParameterInfo() - Method in class java.applet.Applet

Returns information about the parameters that are understood by this applet.

getParameterizedType() - Method in class java.lang.reflect.Parameter

Returns a Type object that identifies the parameterized type for the parameter represented by this Parameter object.

getParameterMetaData() - Method in interface java.sql.PreparedStatement

Retrieves the number, types and properties of this PreparedStatement object's parameters.

getParameterMode(int) - Method in interface java.sql.ParameterMetaData

Retrieves the designated parameter's mode.

getParameterName(MBeanConstructorInfo, MBeanParameterInfo, int) - Method in class javax.management.StandardMBean

Customization hook: Get the name that will be used for the sequence MBeanParameterInfo of the MBeanConstructorInfo returned by this MBean.

getParameterName(MBeanOperationInfo, MBeanParameterInfo, int) - Method in class javax.management.StandardMBean

Customization hook: Get the name that will be used for the sequence MBeanParameterInfo of the MBeanOperationInfo returned by this MBean.

getParameterNames() - Method in interface org.w3c.dom.DOMConfiguration

The list of the parameters supported by this DOMConfiguration object and for which at least one value can be set by the application.

getParameters() - Method in class java.awt.image.renderable.ParameterBlock

Returns the entire Vector of parameters.

getParameters() - Method in class java.lang.reflect.Executable

Returns an array of Parameter objects that represent all the parameters to the underlying executable represented by this object.

getParameters() - Method in class java.security.Policy

Return Policy parameters.

getParameters() - Method in class java.security.Signature

Returns the parameters used with this signature object.

getParameters() - Method in class java.util.logging.LogRecord

Get the parameters to the log message.

getParameters() - Method in class javax.activation.MimeType

Retrieve this object's parameter list.

getParameters() - Method in class javax.crypto.Cipher

Returns the parameters used with this cipher.

getParameters() - Method in interface javax.lang.model.element.ExecutableElement

Returns the formal parameters of this executable.

getParameters() - Method in class javax.net.ssl.CertPathTrustManagerParameters

Return a clone of the CertPathParameters encapsulated by this class.

getParameters() - Method in class javax.net.ssl.KeyStoreBuilderParameters

Return the unmodifiable List of the KeyStore.Builders encapsulated by this object.

getParameters() - Method in class javax.security.auth.login.Configuration

Return Configuration parameters.

getParameterSpec(Class<T>) - Method in class java.security.AlgorithmParameters

Returns a (transparent) specification of this parameter object.

getParameterSpec() - Method in class javax.crypto.spec.PBEParameterSpec

Returns the cipher algorithm parameter specification.

getParameterSpec() - Method in interface javax.xml.crypto.AlgorithmMethod

Returns the algorithm parameters of this AlgorithmMethod.

getParameterSpec() - Method in interface javax.xml.crypto.dsig.CanonicalizationMethod

Returns the algorithm-specific input parameters associated with this CanonicalizationMethod.

getParameterSpec() - Method in interface javax.xml.crypto.dsig.DigestMethod

Returns the algorithm-specific input parameters associated with this DigestMethod.

getParameterSpec() - Method in interface javax.xml.crypto.dsig.SignatureMethod

Returns the algorithm-specific input parameters of this SignatureMethod.

getParameterSpec() - Method in interface javax.xml.crypto.dsig.Transform

Returns the algorithm-specific input parameters associated with this Transform.

getParameterType(int) - Method in interface java.sql.ParameterMetaData

Retrieves the designated parameter's SQL type.

getParameterTypeName(int) - Method in interface java.sql.ParameterMetaData

Retrieves the designated parameter's database-specific type name.

getParameterTypes() - Method in class java.lang.reflect.Constructor

Returns an array of Class objects that represent the formal parameter types, in declaration order, of the executable represented by this object.

getParameterTypes() - Method in class java.lang.reflect.Executable

Returns an array of Class objects that represent the formal parameter types, in declaration order, of the executable represented by this object.

getParameterTypes() - Method in class java.lang.reflect.Method

Returns an array of Class objects that represent the formal parameter types, in declaration order, of the executable represented by this object.

getParameterTypes() - Method in interface javax.lang.model.type.ExecutableType

Returns the types of this executable's formal parameters.

getParameterTypes() - Method in class javax.management.loading.MLetContent

Gets the list of values of the TYPE attribute in each nested <PARAM> tag within the MLET tag.

getParameterValues() - Method in class javax.management.loading.MLetContent

Gets the list of values of the VALUE attribute in each nested <PARAM> tag within the MLET tag.

getParams() - Method in interface java.security.interfaces.DSAKey

Returns the DSA-specific key parameters.

getParams() - Method in interface java.security.interfaces.ECKey

Returns the domain parameters associated with this key.

getParams() - Method in class java.security.spec.ECPrivateKeySpec

Returns the associated elliptic curve domain parameters.

getParams() - Method in class java.security.spec.ECPublicKeySpec

Returns the associated elliptic curve domain parameters.

getParams() - Method in interface javax.crypto.interfaces.DHKey

Returns the key parameters.

getParams() - Method in class javax.sql.rowset.BaseRowSet

Retrieves an array containing the parameter values (both Objects and primitives) that have been set for this RowSet object's command and throws an SQLException object if all parameters have not been set.

getParams() - Method in interface javax.sql.RowSetInternal

Retrieves the parameters that have been set for this RowSet object's command.

getParent() - Method in class java.awt.Component

Gets the parent of this component.

getParent() - Method in class java.awt.image.Raster

Returns the parent Raster (if any) of this Raster or null.

getParent() - Method in class java.awt.MenuComponent

Returns the parent container for this menu component.

getParent() - Method in class java.awt.PopupMenu

Returns the parent container for this menu component.

getParent() - Method in class java.io.File

Returns the pathname string of this abstract pathname's parent, or null if this pathname does not name a parent directory.

getParent() - Method in class java.lang.ClassLoader

Returns the parent class loader for delegation.

getParent() - Method in class java.lang.ThreadGroup

Returns the parent of this thread group.

getParent() - Method in class java.net.NetworkInterface

Returns the parent NetworkInterface of this interface if this is a subinterface, or null if it is a physical (non virtual) interface or has no parent.

getParent() - Method in interface java.nio.file.Path

Returns the parent path, or null if this path does not have a parent.

getParent() - Method in interface java.security.cert.PolicyNode

Returns the parent of this node, or null if this is the root node.

getParent() - Method in class java.util.concurrent.Phaser

Returns the parent of this phaser, or null if none.

getParent() - Method in class java.util.logging.Logger

Return the parent for this Logger.

getParent() - Method in class java.util.prefs.NodeChangeEvent

Returns the parent of the node that was added or removed.

getParent() - Method in class javax.swing.ActionMap

Returns this ActionMap's parent.

getParent() - Method in class javax.swing.InputMap

Gets this InputMap's parent.

getParent() - Method in class javax.swing.text.AbstractDocument.AbstractElement

Returns the parent TreeNode of the receiver.

getParent() - Method in class javax.swing.text.View

Returns the parent of the view.

getParent() - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns this node's parent or null if this node has no parent.

getParent() - Method in interface javax.swing.tree.TreeNode

Returns the parent TreeNode of the receiver.

getParent() - Method in class javax.xml.crypto.dsig.dom.DOMSignContext

Returns the parent node.

getParent() - Method in class javax.xml.stream.util.EventReaderDelegate

Get the parent of this instance.

getParent() - Method in class javax.xml.stream.util.StreamReaderDelegate

Get the parent of this instance.

getParent() - Method in class org.xml.sax.helpers.XMLFilterImpl

Get the parent reader.

getParent() - Method in interface org.xml.sax.XMLFilter

Get the parent reader.

getParentDirectory(File) - Method in class javax.swing.filechooser.FileSystemView

Returns the parent directory of dir.

getParentElement() - Method in class javax.swing.text.AbstractDocument.AbstractElement

Gets the parent of the element.

getParentElement() - Method in interface javax.swing.text.Element

Fetches the parent element.

getParentElement() - Method in interface javax.xml.soap.Node

Returns the parent element of this Node object.

getParentFile() - Method in class java.io.File

Returns the abstract pathname of this abstract pathname's parent, or null if this pathname does not name a parent directory.

getParentLogger() - Method in interface java.sql.Driver

Return the parent Logger of all the Loggers used by this driver.

getParentLogger() - Method in interface javax.sql.CommonDataSource

Return the parent Logger of all the Loggers used by this data source.

getParentLoggerName(String) - Method in interface java.lang.management.PlatformLoggingMXBean

Returns the name of the parent for the specified logger.

getParentLoggerName(String) - Method in interface java.util.logging.LoggingMXBean

Returns the name of the parent for the specified logger.

getParentNode() - Method in class javax.imageio.metadata.IIOMetadataNode

Returns the parent of this node.

getParentNode() - Method in interface org.w3c.dom.Node

The parent of this node.

getParentPath() - Method in class javax.swing.tree.TreePath

Returns the TreePath of the parent.

getParsedString() - Method in exception java.time.format.DateTimeParseException

Returns the string that was being parsed.

getParser() - Method in class javax.swing.text.html.HTMLDocument

Returns the parser that is used when inserting HTML into the existing document.

getParser() - Method in class javax.swing.text.html.HTMLEditorKit

Fetch the parser to use for reading HTML streams.

getParser() - Method in class javax.xml.parsers.SAXParser

Returns the SAX parser that is encapsultated by the implementation of this class.

getPartialSize(int, int) - Method in class javax.swing.text.ParagraphView

Returns the size used by the views between startOffset and endOffset.

getPartialSpan(int, int) - Method in class javax.swing.text.GlyphView

Determines the span along the same axis as tab expansion for a portion of the view.

getPartialSpan(int, int) - Method in interface javax.swing.text.TabableView

Determines the span along the same axis as tab expansion for a portion of the view.

getParties() - Method in class java.util.concurrent.CyclicBarrier

Returns the number of parties required to trip this barrier.

getPassword() - Method in class java.net.PasswordAuthentication

Returns the user password.

getPassword() - Method in class java.security.KeyStore.PasswordProtection

Gets the password.

getPassword() - Method in interface javax.crypto.interfaces.PBEKey

Returns the password.

getPassword() - Method in class javax.crypto.spec.PBEKeySpec

Returns a copy of the password.

getPassword() - Method in class javax.security.auth.callback.PasswordCallback

Get the retrieved password.

getPassword() - Method in class javax.sql.rowset.BaseRowSet

Returns the password used to create a database connection for this RowSet object.

getPassword() - Method in interface javax.sql.RowSet

Retrieves the password used to create a database connection.

getPassword() - Method in class javax.swing.JPasswordField

Returns the text contained in this TextComponent.

getPasswordAuthentication() - Method in class java.net.Authenticator

Called when password authorization is needed.

getPasteAction() - Static method in class javax.swing.TransferHandler

Returns an Action that performs paste operations from the clipboard.

getPatch() - Method in class javax.sound.midi.Instrument

Obtains the Patch object that indicates the bank and program numbers where this instrument is to be stored in the synthesizer.

getPatchList() - Method in class javax.sound.midi.Sequence

Obtains a list of patches referenced in this sequence.

getPath() - Method in class java.io.File

Converts this abstract pathname into a pathname string.

getPath() - Method in class java.net.HttpCookie

Returns the path on the server to which the browser returns this cookie.

getPath() - Method in class java.net.URI

Returns the decoded path component of this URI.

getPath() - Method in class java.net.URL

Gets the path part of this URL.

getPath(String, String...) - Method in class java.nio.file.FileSystem

Converts a path string, or a sequence of strings that when joined form a path string, to a Path.

getPath(URI) - Method in class java.nio.file.spi.FileSystemProvider

Return a Path object by converting the given URI.

getPath() - Method in class javax.swing.event.MenuDragMouseEvent

Returns the path to the selected menu item.

getPath() - Method in class javax.swing.event.MenuKeyEvent

Returns the path to the menu item referenced by this event.

getPath() - Method in class javax.swing.event.TreeExpansionEvent

Returns the path to the value that has been expanded/collapsed.

getPath() - Method in class javax.swing.event.TreeModelEvent

Convenience method to get the array of objects from the TreePath instance that this event wraps.

getPath() - Method in class javax.swing.event.TreeSelectionEvent

Returns the first path element.

getPath() - Method in class javax.swing.JTree.DropLocation

Returns the path where dropped data should be placed in the tree.

getPath() - Method in class javax.swing.plaf.basic.BasicMenuItemUI

getPath() - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns the path from the root, to get to this node.

getPath() - Method in class javax.swing.tree.TreePath

Returns an ordered array of the elements of this TreePath.

getPath() - Method in class javax.xml.ws.spi.http.HttpContext

Returns the path for this context.

getPathBetweenRows(int, int) - Method in class javax.swing.JTree

Returns the paths (inclusive) between the specified rows.

getPathBounds(TreePath) - Method in class javax.swing.JTree

Returns the Rectangle that the specified node will be drawn into.

getPathBounds(JTree, TreePath) - Method in class javax.swing.plaf.basic.BasicTreeUI

Returns the Rectangle enclosing the label portion that the last item in path will be drawn into.

getPathBounds(JTree, TreePath) - Method in class javax.swing.plaf.multi.MultiTreeUI

Invokes the getPathBounds method on each UI handled by this object.

getPathBounds(JTree, TreePath) - Method in class javax.swing.plaf.TreeUI

Returns the Rectangle enclosing the label portion that the last item in path will be drawn into.

getPathClosestTo(int, int) - Method in class javax.swing.tree.AbstractLayoutCache

Returns the path to the node that is closest to x,y.

getPathClosestTo(int, int) - Method in class javax.swing.tree.FixedHeightLayoutCache

Returns the path to the node that is closest to x,y.

getPathClosestTo(int, int) - Method in class javax.swing.tree.VariableHeightLayoutCache

Returns the path to the node that is closest to x,y.

getPathComponent(int) - Method in class javax.swing.tree.TreePath

Returns the path element at the specified index.

getPathCount() - Method in class javax.swing.tree.TreePath

Returns the number of elements in the path.

getPathForLocation(int, int) - Method in class javax.swing.JTree

Returns the path for the node at the specified location.

getPathForRow(int) - Method in class javax.swing.JTree

Returns the path for the specified row.

getPathForRow(JTree, int) - Method in class javax.swing.plaf.basic.BasicTreeUI

Returns the path for passed in row.

getPathForRow(JTree, int) - Method in class javax.swing.plaf.multi.MultiTreeUI

Invokes the getPathForRow method on each UI handled by this object.

getPathForRow(JTree, int) - Method in class javax.swing.plaf.TreeUI

Returns the path for passed in row.

getPathForRow(int) - Method in class javax.swing.tree.AbstractLayoutCache

Returns the path for passed in row.

getPathForRow(int) - Method in class javax.swing.tree.FixedHeightLayoutCache

Returns the path for passed in row.

getPathForRow(int) - Method in class javax.swing.tree.VariableHeightLayoutCache

Returns the path for row.

getPathInfo() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns the extra path information that follows the web service path but precedes the query string in the request URI and will start with a "/" character.

getPathIterator(AffineTransform) - Method in class java.awt.geom.Arc2D

Returns an iteration object that defines the boundary of the arc.

getPathIterator(AffineTransform) - Method in class java.awt.geom.Area

Creates a PathIterator for the outline of this Area object.

getPathIterator(AffineTransform, double) - Method in class java.awt.geom.Area

Creates a PathIterator for the flattened outline of this Area object.

getPathIterator(AffineTransform) - Method in class java.awt.geom.CubicCurve2D

Returns an iteration object that defines the boundary of the shape.

getPathIterator(AffineTransform, double) - Method in class java.awt.geom.CubicCurve2D

Return an iteration object that defines the boundary of the flattened shape.

getPathIterator(AffineTransform) - Method in class java.awt.geom.Ellipse2D

Returns an iteration object that defines the boundary of this Ellipse2D.

getPathIterator(AffineTransform) - Method in class java.awt.geom.Line2D

Returns an iteration object that defines the boundary of this Line2D.

getPathIterator(AffineTransform, double) - Method in class java.awt.geom.Line2D

Returns an iteration object that defines the boundary of this flattened Line2D.

getPathIterator(AffineTransform) - Method in class java.awt.geom.Path2D.Double

Returns an iterator object that iterates along the Shape boundary and provides access to the geometry of the Shape outline.

getPathIterator(AffineTransform) - Method in class java.awt.geom.Path2D.Float

Returns an iterator object that iterates along the Shape boundary and provides access to the geometry of the Shape outline.

getPathIterator(AffineTransform, double) - Method in class java.awt.geom.Path2D

Returns an iterator object that iterates along the Shape boundary and provides access to a flattened view of the Shape outline geometry.

getPathIterator(AffineTransform) - Method in class java.awt.geom.QuadCurve2D

Returns an iteration object that defines the boundary of the shape of this QuadCurve2D.

getPathIterator(AffineTransform, double) - Method in class java.awt.geom.QuadCurve2D

Returns an iteration object that defines the boundary of the flattened shape of this QuadCurve2D.

getPathIterator(AffineTransform) - Method in class java.awt.geom.Rectangle2D

Returns an iteration object that defines the boundary of this Rectangle2D.

getPathIterator(AffineTransform, double) - Method in class java.awt.geom.Rectangle2D

Returns an iteration object that defines the boundary of the flattened Rectangle2D.

getPathIterator(AffineTransform, double) - Method in class java.awt.geom.RectangularShape

Returns an iterator object that iterates along the Shape object's boundary and provides access to a flattened view of the outline of the Shape object's geometry.

getPathIterator(AffineTransform) - Method in class java.awt.geom.RoundRectangle2D

Returns an iteration object that defines the boundary of this RoundRectangle2D.

getPathIterator(AffineTransform) - Method in class java.awt.Polygon

Returns an iterator object that iterates along the boundary of this Polygon and provides access to the geometry of the outline of this Polygon.

getPathIterator(AffineTransform, double) - Method in class java.awt.Polygon

Returns an iterator object that iterates along the boundary of the Shape and provides access to the geometry of the outline of the Shape.

getPathIterator(AffineTransform) - Method in interface java.awt.Shape

Returns an iterator object that iterates along the Shape boundary and provides access to the geometry of the Shape outline.

getPathIterator(AffineTransform, double) - Method in interface java.awt.Shape

Returns an iterator object that iterates along the Shape boundary and provides access to a flattened view of the Shape outline geometry.

getPathMatcher(String) - Method in class java.nio.file.FileSystem

Returns a PathMatcher that performs match operations on the String representation of Path objects by interpreting a given pattern.

getPaths() - Method in class javax.swing.event.TreeSelectionEvent

Returns the paths that have been added or removed from the selection.

getPathToNames() - Method in class java.security.cert.X509CertSelector

Returns a copy of the pathToNames criterion.

getPathToRoot(TreeNode, int) - Method in class javax.swing.tree.DefaultMutableTreeNode

Builds the parents of node up to and including the root node, where the original node is the last element in the returned array.

getPathToRoot(TreeNode) - Method in class javax.swing.tree.DefaultTreeModel

Builds the parents of node up to and including the root node, where the original node is the last element in the returned array.

getPathToRoot(TreeNode, int) - Method in class javax.swing.tree.DefaultTreeModel

Builds the parents of node up to and including the root node, where the original node is the last element in the returned array.

getPattern() - Method in exception java.util.regex.PatternSyntaxException

Retrieves the erroneous regular-expression pattern.

getPatternSeparator() - Method in class java.text.DecimalFormatSymbols

Gets the character used to separate positive and negative subpatterns in a pattern.

getPayload() - Method in interface javax.xml.ws.LogicalMessage

Gets the message payload as an XML source, may be called multiple times on the same LogicalMessage instance, always returns a new Source that may be used to retrieve the entire message payload.

getPayload(JAXBContext) - Method in interface javax.xml.ws.LogicalMessage

Gets the message payload as a JAXB object.

getPCSType() - Method in class java.awt.color.ICC_Profile

Returns the color space type of the Profile Connection Space (PCS).

getPeakThreadCount() - Method in interface java.lang.management.ThreadMXBean

Returns the peak live thread count since the Java virtual machine started or peak was reset.

getPeakUsage() - Method in interface java.lang.management.MemoryPoolMXBean

Returns the peak memory usage of this memory pool since the Java virtual machine was started or since the peak was reset.

getPeer() - Method in class java.awt.Component

Deprecated.
As of JDK version 1.1, programs should not directly manipulate peers; replaced by boolean isDisplayable().

getPeer() - Method in class java.awt.Font

Deprecated.
Font rendering is now platform independent.

getPeer() - Method in class java.awt.MenuComponent

Deprecated.
As of JDK version 1.1, programs should not directly manipulate peers.

getPeerCertificateChain() - Method in class javax.net.ssl.HandshakeCompletedEvent

Returns the identity of the peer which was identified as part of defining the session.

getPeerCertificateChain() - Method in interface javax.net.ssl.SSLSession

Returns the identity of the peer which was identified as part of defining the session.

getPeerCertificates() - Method in class javax.net.ssl.HandshakeCompletedEvent

Returns the identity of the peer which was established as part of defining the session.

getPeerCertificates() - Method in interface javax.net.ssl.SSLSession

Returns the identity of the peer which was established as part of defining the session.

getPeerHost() - Method in class javax.net.ssl.SSLEngine

Returns the host name of the peer.

getPeerHost() - Method in interface javax.net.ssl.SSLSession

Returns the host name of the peer in this session.

getPeerPort() - Method in class javax.net.ssl.SSLEngine

Returns the port number of the peer.

getPeerPort() - Method in interface javax.net.ssl.SSLSession

Returns the port number of the peer in this session.

getPeerPrincipal() - Method in class java.net.SecureCacheResponse

Returns the server's principal which was established as part of defining the session during the original connection that retrieved the network resource.

getPeerPrincipal() - Method in class javax.net.ssl.HandshakeCompletedEvent

Returns the identity of the peer which was established as part of defining the session.

getPeerPrincipal() - Method in class javax.net.ssl.HttpsURLConnection

Returns the server's principal which was established as part of defining the session.

getPeerPrincipal() - Method in interface javax.net.ssl.SSLSession

Returns the identity of the peer which was established as part of defining the session.

getPeerSupportedSignatureAlgorithms() - Method in class javax.net.ssl.ExtendedSSLSession

Obtains an array of supported signature algorithms that the peer is able to use.

getPendingCount() - Method in class java.util.concurrent.CountedCompleter

Returns the current pending count.

getPercent() - Method in class java.text.DecimalFormatSymbols

Gets the character used for percent sign.

getPercentComplete() - Method in class javax.swing.JProgressBar

Returns the percent complete for the progress bar.

getPercentInstance() - Static method in class java.text.NumberFormat

Returns a percentage format for the current default FORMAT locale.

getPercentInstance(Locale) - Static method in class java.text.NumberFormat

Returns a percentage format for the specified locale.

getPercentInstance(Locale) - Method in class java.text.spi.NumberFormatProvider

Returns a new NumberFormat instance which formats percentage values for the specified locale.

getPeriod(Integer) - Method in class javax.management.timer.Timer

Gets a copy of the period (in milliseconds) associated to a timer notification.

getPeriod(Integer) - Method in interface javax.management.timer.TimerMBean

Gets a copy of the period (in milliseconds) associated to a timer notification.

getPermanentFocusOwner() - Method in class java.awt.KeyboardFocusManager

Returns the permanent focus owner, if the permanent focus owner is in the same context as the calling thread.

getPerMill() - Method in class java.text.DecimalFormatSymbols

Gets the character used for per mille sign.

getPermission() - Method in class java.net.HttpURLConnection

Returns a SocketPermission object representing the permission necessary to connect to the destination host and port.

getPermission() - Method in class java.net.URLConnection

Returns a permission object representing the permission necessary to make the connection represented by this object.

getPermission() - Method in exception java.security.AccessControlException

Gets the Permission object associated with this exception, or null if there was no corresponding Permission object.

getPermissions(CodeSource) - Method in class java.net.URLClassLoader

Returns the permissions for the given codesource object.

getPermissions(Principal) - Method in interface java.security.acl.Acl

Returns an enumeration for the set of allowed permissions for the specified principal (representing an entity such as an individual or a group).

getPermissions(CodeSource) - Method in class java.security.Policy

Return a PermissionCollection object containing the set of permissions granted to the specified CodeSource.

getPermissions(ProtectionDomain) - Method in class java.security.Policy

Return a PermissionCollection object containing the set of permissions granted to the specified ProtectionDomain.

getPermissions() - Method in class java.security.ProtectionDomain

Returns the static permissions granted to this domain.

getPermissions(CodeSource) - Method in class java.security.SecureClassLoader

Returns the permissions for the given CodeSource object.

getPermissions(Subject, CodeSource) - Method in class javax.security.auth.Policy

Deprecated.

Retrieve the Permissions granted to the Principals associated with the specified CodeSource.

getPersistenceDelegate(Class<?>) - Method in class java.beans.Encoder

Returns the persistence delegate for the given type.

getPhase() - Method in class java.util.concurrent.Phaser

Returns the current phase number.

getPIData() - Method in class javax.xml.stream.util.StreamReaderDelegate

getPIData() - Method in interface javax.xml.stream.XMLStreamReader

Get the data section of a processing instruction

getPITarget() - Method in class javax.xml.stream.util.StreamReaderDelegate

getPITarget() - Method in interface javax.xml.stream.XMLStreamReader

Get the target of a processing instruction

getPitchBend() - Method in interface javax.sound.midi.MidiChannel

Obtains the upward or downward pitch offset for this channel.

getPixel(int, int, int[], DataBuffer) - Method in class java.awt.image.BandedSampleModel

Returns all samples for the specified pixel in an int array.

getPixel(int, int, int[], DataBuffer) - Method in class java.awt.image.ComponentSampleModel

Returns all samples for the specified pixel in an int array, one sample per array element.

getPixel(int, int, int[], DataBuffer) - Method in class java.awt.image.MultiPixelPackedSampleModel

Returns the specified single band pixel in the first element of an int array.

getPixel(int, int, int[]) - Method in class java.awt.image.Raster

Returns the samples in an array of int for the specified pixel.

getPixel(int, int, float[]) - Method in class java.awt.image.Raster

Returns the samples in an array of float for the specified pixel.

getPixel(int, int, double[]) - Method in class java.awt.image.Raster

Returns the samples in an array of double for the specified pixel.

getPixel(int, int, int[], DataBuffer) - Method in class java.awt.image.SampleModel

Returns the samples for a specified pixel in an int array, one sample per array element.

getPixel(int, int, float[], DataBuffer) - Method in class java.awt.image.SampleModel

Returns the samples for the specified pixel in an array of float.

getPixel(int, int, double[], DataBuffer) - Method in class java.awt.image.SampleModel

Returns the samples for the specified pixel in an array of double.

getPixel(int, int, int[], DataBuffer) - Method in class java.awt.image.SinglePixelPackedSampleModel

Returns all samples in for the specified pixel in an int array.

getPixelBitStride() - Method in class java.awt.image.MultiPixelPackedSampleModel

Returns the pixel bit stride in bits.

getPixelBounds(FontRenderContext, float, float) - Method in class java.awt.font.GlyphVector

Returns the pixel bounds of this GlyphVector when rendered in a graphics with the given FontRenderContext at the given location.

getPixelBounds(FontRenderContext, float, float) - Method in class java.awt.font.TextLayout

Returns the pixel bounds of this TextLayout when rendered in a graphics with the given FontRenderContext at the given location.

getPixelColor(int, int) - Method in class java.awt.Robot

Returns the color of a pixel at the given screen coordinates.

getPixels(int, int, int, int, int[], DataBuffer) - Method in class java.awt.image.BandedSampleModel

Returns all samples for the specified rectangle of pixels in an int array, one sample per data array element.

getPixels(int, int, int, int, int[], DataBuffer) - Method in class java.awt.image.ComponentSampleModel

Returns all samples for the specified rectangle of pixels in an int array, one sample per array element.

getPixels() - Method in class java.awt.image.PixelGrabber

Get the pixel buffer.

getPixels(int, int, int, int, int[]) - Method in class java.awt.image.Raster

Returns an int array containing all samples for a rectangle of pixels, one sample per array element.

getPixels(int, int, int, int, float[]) - Method in class java.awt.image.Raster

Returns a float array containing all samples for a rectangle of pixels, one sample per array element.

getPixels(int, int, int, int, double[]) - Method in class java.awt.image.Raster

Returns a double array containing all samples for a rectangle of pixels, one sample per array element.

getPixels(int, int, int, int, int[], DataBuffer) - Method in class java.awt.image.SampleModel

Returns all samples for a rectangle of pixels in an int array, one sample per array element.

getPixels(int, int, int, int, float[], DataBuffer) - Method in class java.awt.image.SampleModel

Returns all samples for a rectangle of pixels in a float array, one sample per array element.

getPixels(int, int, int, int, double[], DataBuffer) - Method in class java.awt.image.SampleModel

Returns all samples for a rectangle of pixels in a double array, one sample per array element.

getPixels(int, int, int, int, int[], DataBuffer) - Method in class java.awt.image.SinglePixelPackedSampleModel

Returns all samples for the specified rectangle of pixels in an int array, one sample per array element.

getPixelSize() - Method in class java.awt.image.ColorModel

Returns the number of bits per pixel described by this ColorModel.

getPixelStride() - Method in class java.awt.image.ComponentSampleModel

Returns the pixel stride of this ComponentSampleModel.

getPlaceholder() - Method in class javax.swing.text.MaskFormatter

Returns the String to use if the value does not completely fill in the mask.

getPlaceholderCharacter() - Method in class javax.swing.text.MaskFormatter

Returns the character to use in place of characters that are not present in the value, ie the user must fill them in.

getPlatformManagementInterfaces() - Static method in class java.lang.management.ManagementFactory

Returns the set of Class objects, subinterface of PlatformManagedObject, representing all management interfaces for monitoring and managing the Java platform.

getPlatformMBeanServer() - Static method in class java.lang.management.ManagementFactory

Returns the platform MBeanServer.

getPlatformMXBean(Class<T>) - Static method in class java.lang.management.ManagementFactory

Returns the platform MXBean implementing the given mxbeanInterface which is specified to have one single instance in the Java virtual machine.

getPlatformMXBean(MBeanServerConnection, Class<T>) - Static method in class java.lang.management.ManagementFactory

Returns the platform MXBean proxy for mxbeanInterface which is specified to have one single instance in a Java virtual machine and the proxy will forward the method calls through the given MBeanServerConnection.

getPlatformMXBeans(Class<T>) - Static method in class java.lang.management.ManagementFactory

Returns the list of platform MXBeans implementing the given mxbeanInterface in the Java virtual machine.

getPlatformMXBeans(MBeanServerConnection, Class<T>) - Static method in class java.lang.management.ManagementFactory

Returns the list of the platform MXBean proxies for forwarding the method calls of the mxbeanInterface through the given MBeanServerConnection.

getPluginClassName() - Method in class javax.imageio.spi.ImageReaderWriterSpi

Returns the fully-qualified class name of the ImageReader or ImageWriter plug-in associated with this service provider.

getPoint() - Method in class java.awt.event.MouseEvent

Returns the x,y position of the event relative to the source component.

getPoint1() - Method in class java.awt.GradientPaint

Returns a copy of the point P1 that anchors the first color.

getPoint2() - Method in class java.awt.GradientPaint

Returns a copy of the point P2 which anchors the second color.

getPoint2D(Point2D, Point2D) - Method in class java.awt.image.AffineTransformOp

Returns the location of the corresponding destination point given a point in the source.

getPoint2D(Point2D, Point2D) - Method in class java.awt.image.BandCombineOp

Returns the location of the corresponding destination point given a point in the source Raster.

getPoint2D(Point2D, Point2D) - Method in interface java.awt.image.BufferedImageOp

Returns the location of the corresponding destination point given a point in the source image.

getPoint2D(Point2D, Point2D) - Method in class java.awt.image.ColorConvertOp

Returns the location of the destination point given a point in the source.

getPoint2D(Point2D, Point2D) - Method in class java.awt.image.ConvolveOp

Returns the location of the destination point given a point in the source.

getPoint2D(Point2D, Point2D) - Method in class java.awt.image.LookupOp

Returns the location of the destination point given a point in the source.

getPoint2D(Point2D, Point2D) - Method in interface java.awt.image.RasterOp

Returns the location of the destination point given a point in the source Raster.

getPoint2D(Point2D, Point2D) - Method in class java.awt.image.RescaleOp

Returns the location of the destination point given a point in the source.

getPointerInfo() - Static method in class java.awt.MouseInfo

Returns a PointerInfo instance that represents the current location of the mouse pointer.

getPointSize(int) - Method in class javax.swing.text.html.StyleSheet

Returns the point size, given a size index.

getPointSize(String) - Method in class javax.swing.text.html.StyleSheet

Given a string such as "+2", "-2", or "2", returns a point size value.

getPolicy() - Method in class java.security.cert.X509CertSelector

Returns the policy criterion.

getPolicy() - Static method in class java.security.Policy

Returns the installed Policy object.

getPolicy() - Static method in class javax.security.auth.Policy

Deprecated.

Returns the installed Policy object.

getPolicyQualifier() - Method in class java.security.cert.PolicyQualifierInfo

Returns the ASN.1 DER encoded form of the qualifier field of this PolicyQualifierInfo.

getPolicyQualifierId() - Method in class java.security.cert.PolicyQualifierInfo

Returns the policyQualifierId field of this PolicyQualifierInfo.

getPolicyQualifiers() - Method in interface java.security.cert.PolicyNode

Returns the set of policy qualifiers associated with the valid policy represented by this node.

getPolicyQualifiersRejected() - Method in class java.security.cert.PKIXParameters

Gets the PolicyQualifiersRejected flag.

getPolicyTree() - Method in class java.security.cert.PKIXCertPathValidatorResult

Returns the root node of the valid policy tree resulting from the PKIX certification path validation algorithm.

getPolyPressure(int) - Method in interface javax.sound.midi.MidiChannel

Obtains the pressure with which the specified key is being depressed.

getPool() - Static method in class java.util.concurrent.ForkJoinTask

Returns the pool hosting the current task execution, or null if this task is executing outside of any ForkJoinPool.

getPool() - Method in class java.util.concurrent.ForkJoinWorkerThread

Returns the pool hosting this thread.

getPooledConnection() - Method in interface javax.sql.ConnectionPoolDataSource

Attempts to establish a physical database connection that can be used as a pooled connection.

getPooledConnection(String, String) - Method in interface javax.sql.ConnectionPoolDataSource

Attempts to establish a physical database connection that can be used as a pooled connection.

getPoolIndex() - Method in class java.util.concurrent.ForkJoinWorkerThread

Returns the unique index number of this thread in its pool.

getPoolName() - Method in class java.lang.management.MemoryNotificationInfo

Returns the name of the memory pool that triggers this notification.

getPoolSize() - Method in class java.util.concurrent.ForkJoinPool

Returns the number of worker threads that have started but not yet terminated.

getPoolSize() - Method in class java.util.concurrent.ThreadPoolExecutor

Returns the current number of threads in the pool.

getPopup(JPopupMenu, int, int) - Method in class javax.swing.plaf.multi.MultiPopupMenuUI

Invokes the getPopup method on each UI handled by this object.

getPopup(JPopupMenu, int, int) - Method in class javax.swing.plaf.PopupMenuUI

Returns the Popup that will be responsible for displaying the JPopupMenu.

getPopup(Component, Component, int, int) - Method in class javax.swing.PopupFactory

Creates a Popup for the Component owner containing the Component contents.

getPopupHeightForRowCount(int) - Method in class javax.swing.plaf.basic.BasicComboPopup

Retrieves the height of the popup based on the current ListCellRenderer and the maximum row count.

getPopupLocation(MouseEvent) - Method in class javax.swing.JComponent

Returns the preferred location to display the popup menu in this component's coordinate system.

getPopupMenu() - Method in class java.awt.TrayIcon

Returns the popup menu associated with this TrayIcon.

getPopupMenu() - Method in class javax.swing.JMenu

Returns the popupmenu associated with this menu.

getPopupMenuListeners() - Method in class javax.swing.JComboBox

Returns an array of all the PopupMenuListeners added to this JComboBox with addPopupMenuListener().

getPopupMenuListeners() - Method in class javax.swing.JPopupMenu

Returns an array of all the PopupMenuListeners added to this JMenuItem with addPopupMenuListener().

getPopupMenuOrigin() - Method in class javax.swing.JMenu

Computes the origin for the JMenu's popup menu.

getPort() - Method in class java.net.DatagramPacket

Returns the port number on the remote host to which this datagram is being sent or from which the datagram was received.

getPort() - Method in class java.net.DatagramSocket

Returns the port number to which this socket is connected.

getPort() - Method in class java.net.InetSocketAddress

Gets the port number.

getPort() - Method in class java.net.Socket

Returns the remote port number to which this socket is connected.

getPort() - Method in class java.net.SocketImpl

Returns the value of this socket's port field.

getPort() - Method in class java.net.URI

Returns the port number of this URI.

getPort() - Method in class java.net.URL

Gets the port number of this URL.

getPort() - Method in class java.security.cert.LDAPCertStoreParameters

Returns the port number of the LDAP server.

getPort() - Method in class javax.management.remote.JMXServiceURL

The port of the Service URL.

getPort(Class<T>, WebServiceFeature...) - Method in class javax.xml.ws.EndpointReference

The getPort method returns a proxy.

getPort(QName, Class<T>) - Method in class javax.xml.ws.Service

The getPort method returns a proxy.

getPort(QName, Class<T>, WebServiceFeature...) - Method in class javax.xml.ws.Service

The getPort method returns a proxy.

getPort(Class<T>) - Method in class javax.xml.ws.Service

The getPort method returns a proxy.

getPort(Class<T>, WebServiceFeature...) - Method in class javax.xml.ws.Service

The getPort method returns a proxy.

getPort(EndpointReference, Class<T>, WebServiceFeature...) - Method in class javax.xml.ws.Service

The getPort method returns a proxy.

getPort(EndpointReference, Class<T>, WebServiceFeature...) - Method in class javax.xml.ws.spi.Provider

The getPort method returns a proxy.

getPort(QName, Class<T>) - Method in class javax.xml.ws.spi.ServiceDelegate

The getPort method returns a proxy.

getPort(QName, Class<T>, WebServiceFeature...) - Method in class javax.xml.ws.spi.ServiceDelegate

The getPort method returns a proxy.

getPort(EndpointReference, Class<T>, WebServiceFeature...) - Method in class javax.xml.ws.spi.ServiceDelegate

The getPort method returns a proxy.

getPort(Class<T>) - Method in class javax.xml.ws.spi.ServiceDelegate

The getPort method returns a proxy.

getPort(Class<T>, WebServiceFeature...) - Method in class javax.xml.ws.spi.ServiceDelegate

The getPort method returns a proxy.

getPortlist() - Method in class java.net.HttpCookie

Returns the port list attribute of the cookie

getPortName() - Method in interface javax.xml.ws.handler.PortInfo

Gets the qualified name of the WSDL port being accessed.

getPorts() - Method in class javax.xml.ws.Service

Returns an Iterator for the list of QNames of service endpoints grouped by this service

getPorts() - Method in class javax.xml.ws.spi.ServiceDelegate

Returns an Iterator for the list of QNames of service endpoints grouped by this service

getPosition() - Method in class java.awt.font.LineBreakMeasurer

Returns the current position of this LineBreakMeasurer.

getPosition(Component) - Method in class javax.swing.JLayeredPane

Get the relative position of the component within its layer.

getPosition(int) - Method in class javax.swing.SizeSequence

Returns the start position for the specified entry.

getPosition() - Method in class javax.swing.text.TabStop

Returns the position, as a float, of the tab.

getPosition() - Method in interface javax.tools.Diagnostic

Gets a character offset from the beginning of the source object associated with this diagnostic that indicates the location of the problem.

getPosition() - Method in interface org.w3c.dom.ls.LSProgressEvent

The current position in the input source, including all external entities and other resources that have been read.

getPositionAbove(JTextComponent, int, int) - Static method in class javax.swing.text.Utilities

Determines the position in the model that is closest to the given view location in the row above.

getPositionBelow(JTextComponent, int, int) - Static method in class javax.swing.text.Utilities

Determines the position in the model that is closest to the given view location in the row below.

getPositionsInRange(Vector, int, int) - Method in class javax.swing.text.GapContent

Returns a Vector containing instances of UndoPosRef for the Positions in the range offset to offset + length.

getPositionsInRange(Vector, int, int) - Method in class javax.swing.text.StringContent

Returns a Vector containing instances of UndoPosRef for the Positions in the range offset to offset + length.

getPositivePrefix() - Method in class java.text.DecimalFormat

Get the positive prefix.

getPositiveSign() - Method in class java.time.format.DecimalStyle

Gets the character that represents the positive sign.

getPositiveSuffix() - Method in class java.text.DecimalFormat

Get the positive suffix.

getPosixFilePermissions(Path, LinkOption...) - Static method in class java.nio.file.Files

Returns a file's POSIX file permissions.

getPreciseWheelRotation() - Method in class java.awt.event.MouseWheelEvent

Returns the number of "clicks" the mouse wheel was rotated, as a double.

getPrecision() - Method in class java.math.MathContext

Returns the precision setting.

getPrecision(int) - Method in interface java.sql.ParameterMetaData

Retrieves the designated parameter's specified column size.

getPrecision(int) - Method in interface java.sql.ResultSetMetaData

Get the designated column's specified column size.

getPrecision() - Method in exception java.util.IllegalFormatPrecisionException

Returns the precision

getPrecision() - Method in class javax.sound.sampled.FloatControl

Obtains the resolution or granularity of the control, in the units that the control measures.

getPrecision(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Retrieves the total number of digits for values stored in the designated column.

getPredefinedCursor(int) - Static method in class java.awt.Cursor

Returns a cursor object with the specified predefined type.

getPreferredButtonSize(AbstractButton, int) - Static method in class javax.swing.plaf.basic.BasicGraphicsUtils

getPreferredCommands(String) - Method in class javax.activation.CommandMap

Get the preferred command list from a MIME Type.

getPreferredCommands(String, DataSource) - Method in class javax.activation.CommandMap

Get the preferred command list from a MIME Type.

getPreferredCommands() - Method in class javax.activation.DataHandler

Return the preferred commands for this type of data.

getPreferredCommands(String) - Method in class javax.activation.MailcapCommandMap

Get the preferred command list for a MIME Type.

getPreferredGap(JComponent, JComponent, LayoutStyle.ComponentPlacement, int, Container) - Method in class javax.swing.LayoutStyle

Returns the amount of space to use between two components.

getPreferredHeight() - Method in class javax.swing.tree.AbstractLayoutCache

Returns the preferred height.

getPreferredHeight() - Method in class javax.swing.tree.VariableHeightLayoutCache

Returns the preferred height.

getPreferredHorizontalSize() - Method in class javax.swing.plaf.basic.BasicSliderUI

getPreferredInnerHorizontal() - Method in class javax.swing.plaf.basic.BasicProgressBarUI

getPreferredInnerVertical() - Method in class javax.swing.plaf.basic.BasicProgressBarUI

getPreferredMenuItemSize(JComponent, Icon, Icon, int) - Method in class javax.swing.plaf.basic.BasicMenuItemUI

getPreferredMenuItemSize(JComponent, Icon, Icon, int) - Method in class javax.swing.plaf.synth.SynthMenuItemUI

getPreferredMenuItemSize(JComponent, Icon, Icon, int) - Method in class javax.swing.plaf.synth.SynthMenuUI

getPreferredMinSize() - Method in class javax.swing.plaf.basic.BasicTreeUI

Returns the minimum preferred size.

getPreferredScrollableViewportSize() - Method in class javax.swing.JLayer

Returns the preferred size of the viewport for a view component.

getPreferredScrollableViewportSize() - Method in class javax.swing.JList

Computes the size of viewport needed to display visibleRowCount rows.

getPreferredScrollableViewportSize() - Method in class javax.swing.JTable

Returns the preferred size of the viewport for this table.

getPreferredScrollableViewportSize() - Method in class javax.swing.JTextArea

Returns the preferred size of the viewport if this component is embedded in a JScrollPane.

getPreferredScrollableViewportSize() - Method in class javax.swing.JTree

Returns the preferred display size of a JTree.

getPreferredScrollableViewportSize() - Method in interface javax.swing.Scrollable

Returns the preferred size of the viewport for a view component.

getPreferredScrollableViewportSize() - Method in class javax.swing.text.JTextComponent

Returns the preferred size of the viewport for a view component.

getPreferredSize() - Method in class java.awt.Component

Gets the preferred size of this component.

getPreferredSize() - Method in class java.awt.Container

Returns the preferred size of this container.

getPreferredSize(int) - Method in class java.awt.List

Gets the preferred dimensions for a list with the specified number of rows.

getPreferredSize() - Method in class java.awt.List

Gets the preferred size of this scrolling list.

getPreferredSize(int, int) - Method in class java.awt.TextArea

Determines the preferred size of a text area with the specified number of rows and columns.

getPreferredSize() - Method in class java.awt.TextArea

Determines the preferred size of this text area.

getPreferredSize(int) - Method in class java.awt.TextField

Gets the preferred size of this text field with the specified number of columns.

getPreferredSize() - Method in class java.awt.TextField

Gets the preferred size of this text field.

getPreferredSize() - Method in class javax.swing.JComponent

If the preferredSize has been set to a non-null value just returns it.

getPreferredSize() - Method in class javax.swing.JEditorPane

Returns the preferred size for the JEditorPane.

getPreferredSize() - Method in class javax.swing.JTextArea

Returns the preferred size of the TextArea.

getPreferredSize() - Method in class javax.swing.JTextField

Returns the preferred size Dimensions needed for this TextField.

getPreferredSize() - Method in class javax.swing.JToolBar.Separator

Returns the preferred size for the separator.

getPreferredSize() - Method in class javax.swing.plaf.basic.BasicArrowButton

Returns the preferred size of the BasicArrowButton.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicButtonUI

getPreferredSize() - Method in class javax.swing.plaf.basic.BasicComboBoxRenderer

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicComboBoxUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicDesktopIconUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicLabelUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicListUI

The preferredSize of the list depends upon the layout orientation.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicMenuItemUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicOptionPaneUI

If c is the JOptionPane the receiver is contained in, the preferred size that is returned is the maximum of the preferred size of the LayoutManager for the JOptionPane, and getMinimumOptionPaneSize.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicPopupMenuSeparatorUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicProgressBarUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicRadioButtonUI

The preferred size of the radio button

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicScrollBarUI

A vertical scrollbar's preferred width is the maximum of preferred widths of the (non null) increment/decrement buttons, and the minimum width of the thumb.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicSeparatorUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicSliderUI

getPreferredSize() - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider

Returns dividerSize x dividerSize

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI

Returns the preferred size for the passed in component, This is passed off to the current layout manager.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicTableHeaderUI

Return the preferred size of the header.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicTableUI

Return the preferred size of the table.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicTextAreaUI

The method is overridden to take into account caret width.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicTextUI

Gets the preferred size for the editor component.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicToolBarSeparatorUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicToolTipUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.basic.BasicTreeUI

Returns the preferred size to properly display the tree, this is a cover method for getPreferredSize(c, true).

getPreferredSize(JComponent, boolean) - Method in class javax.swing.plaf.basic.BasicTreeUI

Returns the preferred size to represent the tree in c.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.ComponentUI

Returns the specified component's preferred size appropriate for the look and feel.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.LayerUI

If the JLayer's view component is not null, this returns the result of the view's getPreferredSize() method.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.metal.MetalDesktopIconUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.metal.MetalFileChooserUI

Returns the preferred size of the specified JFileChooser.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.metal.MetalPopupMenuSeparatorUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.metal.MetalScrollBarUI

getPreferredSize() - Method in class javax.swing.plaf.metal.MetalScrollButton

getPreferredSize(JComponent) - Method in class javax.swing.plaf.metal.MetalSeparatorUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.metal.MetalToolTipUI

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiButtonUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiColorChooserUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiComboBoxUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiDesktopIconUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiDesktopPaneUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiFileChooserUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiInternalFrameUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiLabelUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiListUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiMenuBarUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiMenuItemUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiOptionPaneUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiPanelUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiPopupMenuUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiProgressBarUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiRootPaneUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiScrollBarUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiScrollPaneUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiSeparatorUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiSliderUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiSpinnerUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiSplitPaneUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiTabbedPaneUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiTableHeaderUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiTableUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiTextUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiToolBarUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiToolTipUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiTreeUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.multi.MultiViewportUI

Invokes the getPreferredSize method on each UI handled by this object.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.synth.SynthButtonUI

Returns the specified component's preferred size appropriate for the look and feel.

getPreferredSize(SynthContext, Font, String, Icon, int, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthGraphicsUtils

Returns the preferred size needed to properly render an icon and text.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.synth.SynthLabelUI

Returns the specified component's preferred size appropriate for the look and feel.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.synth.SynthProgressBarUI

Returns the specified component's preferred size appropriate for the look and feel.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.synth.SynthScrollBarUI

A vertical scrollbar's preferred width is the maximum of preferred widths of the (non null) increment/decrement buttons, and the minimum width of the thumb.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.synth.SynthSeparatorUI

Returns the specified component's preferred size appropriate for the look and feel.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.synth.SynthSliderUI

Returns the specified component's preferred size appropriate for the look and feel.

getPreferredSize(JComponent) - Method in class javax.swing.plaf.synth.SynthToolTipUI

Returns the specified component's preferred size appropriate for the look and feel.

getPreferredSize() - Method in class javax.swing.tree.DefaultTreeCellEditor.DefaultTextField

Overrides JTextField.getPreferredSize to return the preferred size based on current font, if set, or else use renderer's font.

getPreferredSize() - Method in class javax.swing.tree.DefaultTreeCellEditor.EditorContainer

Returns the preferred size for the Container.

getPreferredSize() - Method in class javax.swing.tree.DefaultTreeCellRenderer

Overrides JComponent.getPreferredSize to return slightly wider preferred size value.

getPreferredSizeOfComponent(Component) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager

Returns the width of the passed in Components preferred size.

getPreferredSpan(int) - Method in class javax.swing.text.AsyncBoxView

Determines the preferred span for this view along an axis.

getPreferredSpan(int) - Method in class javax.swing.text.BoxView

Determines the preferred span for this view along an axis.

getPreferredSpan(int) - Method in class javax.swing.text.ComponentView

Determines the preferred span for this view along an axis.

getPreferredSpan(int) - Method in class javax.swing.text.FieldView

Determines the preferred span for this view along an axis.

getPreferredSpan(int) - Method in class javax.swing.text.GlyphView

Determines the preferred span for this view along an axis.

getPreferredSpan(int) - Method in class javax.swing.text.html.BlockView

Determines the preferred span for this view along an axis.

getPreferredSpan(int) - Method in class javax.swing.text.html.ImageView

Determines the preferred span for this view along an axis.

getPreferredSpan(int) - Method in class javax.swing.text.html.ParagraphView

Determines the preferred span for this view.

getPreferredSpan(int) - Method in class javax.swing.text.IconView

Determines the preferred span for this view along an axis.

getPreferredSpan(int) - Method in class javax.swing.text.PasswordView

Determines the preferred span for this view along an axis.

getPreferredSpan(int) - Method in class javax.swing.text.PlainView

Determines the preferred span for this view along an axis.

getPreferredSpan(int) - Method in class javax.swing.text.View

Determines the preferred span for this view along an axis.

getPreferredSpan(int) - Method in class javax.swing.text.WrappedPlainView

Determines the preferred span for this view along an axis.

getPreferredThumbnailSizes(ImageTypeSpecifier, ImageWriteParam, IIOMetadata, IIOMetadata) - Method in class javax.imageio.ImageWriter

Returns an array of Dimensions indicating the legal size ranges for thumbnail images as they will be encoded in the output file or stream.

getPreferredTileSizes() - Method in class javax.imageio.ImageWriteParam

Returns an array of Dimensions indicating the legal size ranges for tiles as they will be encoded in the output file or stream.

getPreferredValue() - Method in class javax.swing.Spring

Returns the preferred value of this Spring.

getPreferredVerticalSize() - Method in class javax.swing.plaf.basic.BasicSliderUI

getPreferredWidth() - Method in class javax.swing.table.TableColumn

Returns the preferred width of the TableColumn.

getPreferredWidth(Rectangle) - Method in class javax.swing.tree.AbstractLayoutCache

Returns the preferred width for the passed in region.

getPreferredWidth(Rectangle) - Method in class javax.swing.tree.VariableHeightLayoutCache

Returns the preferred width and height for the region in visibleRegion.

getPrefix() - Method in class javax.imageio.metadata.IIOMetadataNode

Returns null, since namespaces are not supported.

getPrefix(int) - Method in class javax.naming.CompositeName

Creates a composite name whose components consist of a prefix of the components in this composite name.

getPrefix(int) - Method in class javax.naming.CompoundName

Creates a compound name whose components consist of a prefix of the components in this compound name.

getPrefix(int) - Method in class javax.naming.ldap.LdapName

Creates a name whose components consist of a prefix of the components of this LDAP name.

getPrefix(int) - Method in interface javax.naming.Name

Creates a name whose components consist of a prefix of the components of this name.

getPrefix(String) - Method in interface javax.xml.namespace.NamespaceContext

Get prefix bound to Namespace URI in the current scope.

getPrefix() - Method in class javax.xml.namespace.QName

Get the prefix of this QName.

getPrefix() - Method in interface javax.xml.soap.Name

Returns the prefix that was specified when this Name object was initialized.

getPrefix() - Method in interface javax.xml.stream.events.Namespace

Gets the prefix, returns "" if this is a default namespace declaration.

getPrefix() - Method in class javax.xml.stream.util.StreamReaderDelegate

getPrefix(String) - Method in interface javax.xml.stream.XMLEventWriter

Gets the prefix the uri is bound to

getPrefix() - Method in interface javax.xml.stream.XMLStreamReader

Returns the prefix of the current event or null if the event does not have a prefix

getPrefix(String) - Method in interface javax.xml.stream.XMLStreamWriter

Gets the prefix the uri is bound to

getPrefix() - Method in interface org.w3c.dom.Node

The namespace prefix of this node, or null if it is unspecified.

getPrefix(String) - Method in class org.xml.sax.helpers.NamespaceSupport

Return one of the prefixes mapped to a Namespace URI.

getPrefixes(String) - Method in interface javax.xml.namespace.NamespaceContext

Get all prefixes bound to a Namespace URI in the current scope.

getPrefixes() - Method in class org.xml.sax.helpers.NamespaceSupport

Return an enumeration of all prefixes whose declarations are active in the current context.

getPrefixes(String) - Method in class org.xml.sax.helpers.NamespaceSupport

Return an enumeration of all prefixes for a given URI whose declarations are active in the current context.

getPrefixList() - Method in class javax.xml.crypto.dsig.spec.ExcC14NParameterSpec

Returns the inclusive namespace prefix list.

getPresentationName() - Method in class javax.swing.text.AbstractDocument.DefaultDocumentEvent

Provides a localized, human readable description of this edit suitable for use in, say, a change log.

getPresentationName() - Method in class javax.swing.undo.AbstractUndoableEdit

This default implementation returns "".

getPresentationName() - Method in class javax.swing.undo.CompoundEdit

Returns getPresentationName from the last UndoableEdit added to edits.

getPresentationName() - Method in class javax.swing.undo.StateEdit

Gets the presentation name for this edit

getPresentationName() - Method in interface javax.swing.undo.UndoableEdit

Returns a localized, human-readable description of this edit, suitable for use in a change log, for example.

getPreservesUnknownTags() - Method in class javax.swing.text.html.HTMLDocument

Returns the behavior the parser observes when encountering unknown tags.

getPressedIcon() - Method in class javax.swing.AbstractButton

Returns the pressed icon for the button.

getPreviewPanel() - Static method in class javax.swing.colorchooser.ColorChooserComponentFactory

getPreviewPanel() - Method in class javax.swing.JColorChooser

Returns the preview panel that shows a chosen color.

getPreviousBounds(JInternalFrame) - Method in class javax.swing.DefaultDesktopManager

Gets the normal bounds of the component prior to the component being maximized.

getPreviousLeaf() - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns the leaf before this node or null if this node is the first leaf in the tree.

getPreviousNode() - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns the node that precedes this node in a preorder traversal of this node's tree.

getPreviousRowCount() - Method in class javax.swing.event.RowSorterEvent

Returns the number of rows before the sort.

getPreviousSibling() - Method in class javax.imageio.metadata.IIOMetadataNode

Returns the previous sibling of this node, or null if this node has no previous sibling.

getPreviousSibling() - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns the previous sibling of this node in the parent's children array.

getPreviousSibling() - Method in interface org.w3c.dom.Node

The node immediately preceding this node.

getPreviousTabIndex(int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getPreviousTabIndexInRun(int, int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getPreviousTabRun(int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getPreviousValue() - Method in class javax.swing.JSpinner

Returns the object in the sequence that comes before the object returned by getValue().

getPreviousValue() - Method in class javax.swing.SpinnerDateModel

Returns the previous Date in the sequence, or null if the previous date is before start.

getPreviousValue() - Method in class javax.swing.SpinnerListModel

Returns the previous element of the underlying sequence or null if value is already the first element.

getPreviousValue() - Method in interface javax.swing.SpinnerModel

Return the object in the sequence that comes before the object returned by getValue().

getPreviousValue() - Method in class javax.swing.SpinnerNumberModel

Returns the previous number in the sequence.

getPreviousWord(JTextComponent, int) - Static method in class javax.swing.text.Utilities

Determine the start of the prev word for the given location.

getPrevValue() - Method in interface org.w3c.dom.events.MutationEvent

prevValue indicates the previous value of the Attr node in DOMAttrModified events, and of the CharacterData node in DOMCharacterDataModified events.

getPrimary1() - Method in class javax.swing.plaf.metal.DefaultMetalTheme

Returns the primary 1 color.

getPrimary1() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the primary 1 color.

getPrimary1() - Method in class javax.swing.plaf.metal.OceanTheme

Returns the primary 1 color.

getPrimary2() - Method in class javax.swing.plaf.metal.DefaultMetalTheme

Returns the primary 2 color.

getPrimary2() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the primary 2 color.

getPrimary2() - Method in class javax.swing.plaf.metal.OceanTheme

Returns the primary 2 color.

getPrimary3() - Method in class javax.swing.plaf.metal.DefaultMetalTheme

Returns the primary 3 color.

getPrimary3() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the primary 3 color.

getPrimary3() - Method in class javax.swing.plaf.metal.OceanTheme

Returns the primary 3 color.

getPrimaryControl() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the primary control color of the current theme.

getPrimaryControl() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the primary control color.

getPrimaryControlDarkShadow() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the primary control dark shadow color of the current theme.

getPrimaryControlDarkShadow() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the primary control dark shadow color.

getPrimaryControlHighlight() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the primary control highlight color of the current theme.

getPrimaryControlHighlight() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the primary control highlight color.

getPrimaryControlInfo() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the primary control info color of the current theme.

getPrimaryControlInfo() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the primary control info color.

getPrimaryControlShadow() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the primary control shadow color of the current theme.

getPrimaryControlShadow() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the primary control shadow color.

getPrimaryKeys(String, String, String) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of the given table's primary key columns.

getPrimaryType() - Method in class java.awt.datatransfer.DataFlavor

Returns the primary MIME type for this DataFlavor.

getPrimaryType() - Method in class javax.activation.MimeType

Retrieve the primary type of this object.

getPrime() - Method in class java.security.spec.RSAOtherPrimeInfo

Returns the prime.

getPrimeExponentP() - Method in interface java.security.interfaces.RSAMultiPrimePrivateCrtKey

Returns the primeExponentP.

getPrimeExponentP() - Method in interface java.security.interfaces.RSAPrivateCrtKey

Returns the primeExponentP.

getPrimeExponentP() - Method in class java.security.spec.RSAMultiPrimePrivateCrtKeySpec

Returns the primeExponentP.

getPrimeExponentP() - Method in class java.security.spec.RSAPrivateCrtKeySpec

Returns the primeExponentP.

getPrimeExponentQ() - Method in interface java.security.interfaces.RSAMultiPrimePrivateCrtKey

Returns the primeExponentQ.

getPrimeExponentQ() - Method in interface java.security.interfaces.RSAPrivateCrtKey

Returns the primeExponentQ.

getPrimeExponentQ() - Method in class java.security.spec.RSAMultiPrimePrivateCrtKeySpec

Returns the primeExponentQ.

getPrimeExponentQ() - Method in class java.security.spec.RSAPrivateCrtKeySpec

Returns the primeExponentQ.

getPrimeP() - Method in interface java.security.interfaces.RSAMultiPrimePrivateCrtKey

Returns the primeP.

getPrimeP() - Method in interface java.security.interfaces.RSAPrivateCrtKey

Returns the primeP.

getPrimeP() - Method in class java.security.spec.RSAMultiPrimePrivateCrtKeySpec

Returns the primeP.

getPrimeP() - Method in class java.security.spec.RSAPrivateCrtKeySpec

Returns the primeP.

getPrimePLength() - Method in class java.security.spec.DSAGenParameterSpec

Returns the desired length of the prime P of the to-be-generated DSA domain parameters in bits.

getPrimeQ() - Method in interface java.security.interfaces.RSAMultiPrimePrivateCrtKey

Returns the primeQ.

getPrimeQ() - Method in interface java.security.interfaces.RSAPrivateCrtKey

Returns the primeQ.

getPrimeQ() - Method in class java.security.spec.RSAMultiPrimePrivateCrtKeySpec

Returns the primeQ.

getPrimeQ() - Method in class java.security.spec.RSAPrivateCrtKeySpec

Returns the primeQ.

getPrimeSize() - Method in class javax.crypto.spec.DHGenParameterSpec

Returns the size in bits of the prime modulus.

getPrimitiveArrayType(Class<T>) - Static method in class javax.management.openmbean.ArrayType

Create an ArrayType instance in a type-safe manner.

getPrimitiveType(TypeKind) - Method in interface javax.lang.model.util.Types

Returns a primitive type.

getPrincipal() - Method in interface java.security.acl.AclEntry

Returns the principal for which permissions are granted or denied by this ACL entry.

getPrincipal() - Method in interface java.security.Certificate

Deprecated.

Returns the principal of the principal-key pair being guaranteed by the guarantor.

getPrincipal() - Method in class javax.security.auth.kerberos.KerberosKey

Returns the principal that this key belongs to.

getPrincipal() - Method in class javax.security.auth.kerberos.KeyTab

Returns the service principal this KeyTab object is bound to.

getPrincipals() - Method in class java.security.ProtectionDomain

Returns an array of principals for this domain.

getPrincipals() - Method in class javax.security.auth.PrivateCredentialPermission

Returns the Principal classes and names associated with this PrivateCredentialPermission.

getPrincipals() - Method in class javax.security.auth.Subject

Return the Set of Principals associated with this Subject.

getPrincipals(Class<T>) - Method in class javax.security.auth.Subject

Return a Set of Principals associated with this Subject that are instances or subclasses of the specified Class.

getPrintable(int) - Method in class java.awt.print.Book

Returns the Printable instance responsible for rendering the page specified by pageIndex.

getPrintable(int) - Method in interface java.awt.print.Pageable

Returns the Printable instance responsible for rendering the page specified by pageIndex.

getPrintable(JTable.PrintMode, MessageFormat, MessageFormat) - Method in class javax.swing.JTable

Return a Printable for use in printing this JTable.

getPrintable(MessageFormat, MessageFormat) - Method in class javax.swing.text.JTextComponent

Returns a Printable to use for printing the content of this JTextComponent.

getPrintableArea(int) - Method in class javax.print.attribute.standard.MediaPrintableArea

Get the printable area as an array of 4 values in the order x, y, w, h.

getPrintData() - Method in interface javax.print.Doc

Obtains the print data representation object that contains this doc object's piece of print data in the format corresponding to the supported doc flavor.

getPrintData() - Method in class javax.print.SimpleDoc

getPrinter() - Method in class java.awt.JobAttributes

Returns the destination printer for jobs using these attributes.

getPrinterJob() - Method in interface java.awt.print.PrinterGraphics

Returns the PrinterJob that is controlling the current rendering request.

getPrinterJob() - Static method in class java.awt.print.PrinterJob

Creates and returns a PrinterJob which is initially associated with the default printer.

getPrinterResolution() - Method in class java.awt.PageAttributes

Returns the print resolution for pages using these attributes.

getPrintEventType() - Method in class javax.print.event.PrintJobEvent

Gets the reason for this event.

getPrintJob() - Method in interface java.awt.PrintGraphics

Returns the PrintJob object from which this PrintGraphics object originated.

getPrintJob(Frame, String, Properties) - Method in class java.awt.Toolkit

Gets a PrintJob object which is the result of initiating a print operation on the toolkit's platform.

getPrintJob(Frame, String, JobAttributes, PageAttributes) - Method in class java.awt.Toolkit

Gets a PrintJob object which is the result of initiating a print operation on the toolkit's platform.

getPrintJob() - Method in class javax.print.event.PrintJobAttributeEvent

Determine the Print Job to which this print job event pertains.

getPrintJob() - Method in class javax.print.event.PrintJobEvent

Determines the DocPrintJob to which this print job event pertains.

getPrintQuality() - Method in class java.awt.PageAttributes

Returns the print quality for pages using these attributes.

getPrintService() - Method in class java.awt.print.PrinterJob

Returns the service (printer) for this printer job.

getPrintService() - Method in interface javax.print.DocPrintJob

Determines the PrintService object to which this print job object is bound.

getPrintService() - Method in class javax.print.event.PrintServiceAttributeEvent

Returns the print service.

getPrintService(OutputStream) - Method in class javax.print.StreamPrintServiceFactory

Returns a StreamPrintService that can print to the specified output stream.

getPrintServices(DocFlavor, AttributeSet) - Method in class javax.print.PrintServiceLookup

Locates services that can be positively confirmed to support the combination of attributes and DocFlavors specified.

getPrintServices() - Method in class javax.print.PrintServiceLookup

Not called directly by applications.

getPriority() - Method in class java.lang.Thread

Returns this thread's priority.

getPrivacy() - Method in class org.ietf.jgss.MessageProp

Retrieves the privacy state.

getPrivate() - Method in class java.security.KeyPair

Returns a reference to the private key component of this key pair.

getPrivateCredentials() - Method in class javax.security.auth.Subject

Return the Set of private credentials held by this Subject.

getPrivateCredentials(Class<T>) - Method in class javax.security.auth.Subject

Return a Set of private credentials associated with this Subject that are instances or subclasses of the specified Class.

getPrivateExponent() - Method in interface java.security.interfaces.RSAPrivateKey

Returns the private exponent.

getPrivateExponent() - Method in class java.security.spec.RSAPrivateKeySpec

Returns the private exponent.

getPrivateKey() - Method in class java.security.KeyStore.PrivateKeyEntry

Gets the PrivateKey from this entry.

getPrivateKey() - Method in class java.security.Signer

Deprecated.

Returns this signer's private key.

getPrivateKey(String) - Method in interface javax.net.ssl.X509KeyManager

Returns the key associated with the given alias.

getPrivateKey() - Method in class javax.security.auth.x500.X500PrivateCredential

Returns the PrivateKey.

getPrivateKeyValid() - Method in class java.security.cert.X509CertSelector

Returns the privateKeyValid criterion.

getProblemType() - Method in class javax.management.relation.RoleUnresolved

Retrieves problem type.

getProcedureColumns(String, String, String, String) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of the given catalog's stored procedure parameter and result columns.

getProcedures(String, String, String) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of the stored procedures available in the given catalog.

getProcedureTerm() - Method in interface java.sql.DatabaseMetaData

Retrieves the database vendor's preferred term for "procedure".

getProcessedDTD() - Method in interface javax.xml.stream.events.DTD

Returns an implementation defined representation of the DTD.

getProfile() - Method in class java.awt.color.ICC_ColorSpace

Returns the ICC_Profile for this ICC_ColorSpace.

getProfileClass() - Method in class java.awt.color.ICC_Profile

Returns the profile class.

getProgram(String...) - Method in interface javax.script.ScriptEngineFactory

Returns a valid scripting language executable program with given statements.

getProgram() - Method in interface javax.sound.midi.MidiChannel

Obtains the current program number for this channel.

getProgram() - Method in class javax.sound.midi.Patch

Returns the index, within a bank, of the instrument whose location this Patch specifies.

getProgress() - Method in class javax.swing.SwingWorker

Returns the progress bound property.

getProgressBarBorder() - Static method in class javax.swing.plaf.basic.BasicBorders

getProgressiveMode() - Method in class javax.imageio.ImageWriteParam

Returns the current mode for writing the stream in a progressive manner.

getProgressMonitor() - Method in class javax.swing.ProgressMonitorInputStream

Get the ProgressMonitor object being used by this stream.

getPrompt() - Method in class javax.security.auth.callback.ChoiceCallback

Get the prompt.

getPrompt() - Method in class javax.security.auth.callback.ConfirmationCallback

Get the prompt.

getPrompt() - Method in class javax.security.auth.callback.NameCallback

Get the prompt.

getPrompt() - Method in class javax.security.auth.callback.PasswordCallback

Get the prompt.

getPrompt() - Method in class javax.security.auth.callback.TextInputCallback

Get the prompt.

getPropagatedFrom() - Method in class java.beans.beancontext.BeanContextEvent

Gets the BeanContext from which this event was propagated.

getPropagationId() - Method in class java.beans.PropertyChangeEvent

The "propagationId" field is reserved for future use.

getProperties() - Static method in class java.lang.System

Determines the current system properties.

getProperties() - Method in interface javax.xml.crypto.dsig.SignatureProperties

Returns an unmodifiable list of one or more SignaturePropertys that are contained in this SignatureProperties.

getProperties() - Method in class javax.xml.ws.Endpoint

Returns the property bag for this Endpoint instance.

getProperty(String, ImageObserver) - Method in class java.awt.image.BufferedImage

Returns a property of the image by name.

getProperty(String) - Method in class java.awt.image.BufferedImage

Returns a property of the image by name.

getProperty(String, ImageObserver) - Method in class java.awt.Image

Gets a property of this image by name.

getProperty(ParameterBlock, String) - Method in interface java.awt.image.renderable.ContextualRenderedImageFactory

Gets the appropriate instance of the property specified by the name parameter.

getProperty(String) - Method in interface java.awt.image.renderable.RenderableImage

Gets a property from the property set of this image.

getProperty(String) - Method in class java.awt.image.renderable.RenderableImageOp

Gets a property from the property set of this image.

getProperty(String) - Method in interface java.awt.image.RenderedImage

Gets a property from the property set of this image.

getProperty(String, String) - Static method in class java.awt.Toolkit

Gets a property with the specified key and default.

getProperty(String) - Static method in class java.lang.System

Gets the system property indicated by the specified key.

getProperty(String, String) - Static method in class java.lang.System

Gets the system property indicated by the specified key.

getProperty(String) - Method in class java.security.Provider

getProperty(String) - Static method in class java.security.Security

Gets a security property value.

getProperty(String) - Method in class java.util.logging.LogManager

Get the value of a logging property.

getProperty(String) - Method in class java.util.Properties

Searches for the property with the specified key in this property list.

getProperty(String, String) - Method in class java.util.Properties

Searches for the property with the specified key in this property list.

getProperty(String) - Method in class javax.sound.midi.MidiFileFormat

Obtain the property value specified by the key.

getProperty(String) - Method in class javax.sound.sampled.AudioFileFormat

Obtain the property value specified by the key.

getProperty(String) - Method in class javax.sound.sampled.AudioFormat

Obtain the property value specified by the key.

getProperty(Object) - Method in class javax.swing.text.AbstractDocument

A convenience method for looking up a property value.

getProperty(Object) - Method in interface javax.swing.text.Document

Gets the properties associated with the document.

getProperty(String) - Method in class javax.xml.bind.Binder

Get the particular property in the underlying implementation of Binder.

getProperty(String) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

Default implementation of the getProperty method handles the four defined properties in Marshaller.

getProperty(String) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

Default implementation of the getProperty method always throws PropertyException since there are no required properties.

getProperty(String) - Method in interface javax.xml.bind.Marshaller

Get the particular property in the underlying implementation of Marshaller.

getProperty(String) - Method in interface javax.xml.bind.Unmarshaller

Get the particular property in the underlying implementation of Unmarshaller.

getProperty(String) - Method in interface javax.xml.bind.Validator

Deprecated.
since JAXB2.0

getProperty(String) - Method in class javax.xml.crypto.dom.DOMCryptoContext

This implementation uses an internal HashMap to get the object that the specified name maps to.

getProperty(String) - Method in interface javax.xml.crypto.XMLCryptoContext

Returns the value of the specified property.

getProperty(String) - Method in class javax.xml.parsers.SAXParser

Returns the particular property requested for in the underlying implementation of XMLReader.

getProperty(String) - Method in class javax.xml.soap.SOAPMessage

Retrieves value of the specified property.

getProperty(String) - Method in class javax.xml.stream.util.EventReaderDelegate

getProperty(String) - Method in class javax.xml.stream.util.StreamReaderDelegate

getProperty(String) - Method in interface javax.xml.stream.XMLEventReader

Get the value of a feature/property from the underlying implementation

getProperty(String) - Method in class javax.xml.stream.XMLInputFactory

Get the value of a feature/property from the underlying implementation

getProperty(String) - Method in class javax.xml.stream.XMLOutputFactory

Get a feature/property on the underlying implementation

getProperty(String) - Method in interface javax.xml.stream.XMLStreamReader

Get the value of a feature/property from the underlying implementation

getProperty(String) - Method in interface javax.xml.stream.XMLStreamWriter

Get the value of a feature/property from the underlying implementation

getProperty(String) - Method in class javax.xml.validation.SchemaFactory

Look up the value of a property.

getProperty(String) - Method in class javax.xml.validation.Validator

Look up the value of a property.

getProperty(String) - Method in class javax.xml.validation.ValidatorHandler

Look up the value of a property.

getProperty(String) - Method in class org.xml.sax.helpers.ParserAdapter

Get a parser property.

getProperty(String) - Method in class org.xml.sax.helpers.XMLFilterImpl

Look up the value of a property.

getProperty(String) - Method in interface org.xml.sax.XMLReader

Look up the value of a property.

getPropertyChangeEvent() - Method in exception java.beans.PropertyVetoException

Gets the vetoed PropertyChangeEvent.

getPropertyChangeListeners() - Method in class java.awt.Component

Returns an array of all the property change listeners registered on this component.

getPropertyChangeListeners(String) - Method in class java.awt.Component

Returns an array of all the listeners which have been associated with the named property.

getPropertyChangeListeners() - Method in class java.awt.KeyboardFocusManager

Returns an array of all the property change listeners registered on this keyboard focus manager.

getPropertyChangeListeners(String) - Method in class java.awt.KeyboardFocusManager

Returns an array of all the PropertyChangeListeners associated with the named property.

getPropertyChangeListeners(String) - Method in class java.awt.SystemTray

Returns an array of all the listeners that have been associated with the named property.

getPropertyChangeListeners() - Method in class java.awt.Toolkit

Returns an array of all the property change listeners registered on this toolkit.

getPropertyChangeListeners(String) - Method in class java.awt.Toolkit

Returns an array of all property change listeners associated with the specified name of a desktop property.

getPropertyChangeListeners() - Method in class java.beans.PropertyChangeSupport

Returns an array of all the listeners that were added to the PropertyChangeSupport object with addPropertyChangeListener().

getPropertyChangeListeners(String) - Method in class java.beans.PropertyChangeSupport

Returns an array of all the listeners which have been associated with the named property.

getPropertyChangeListeners() - Method in class javax.swing.AbstractAction

Returns an array of all the PropertyChangeListeners added to this AbstractAction with addPropertyChangeListener().

getPropertyChangeListeners() - Method in class javax.swing.plaf.basic.BasicDirectoryModel

Returns an array of all the property change listeners registered on this component.

getPropertyChangeListeners() - Method in class javax.swing.plaf.LayerUI

Returns an array of all the property change listeners registered on this component.

getPropertyChangeListeners(String) - Method in class javax.swing.plaf.LayerUI

Returns an array of all the listeners which have been associated with the named property.

getPropertyChangeListeners() - Method in class javax.swing.table.TableColumn

Returns an array of all the PropertyChangeListeners added to this TableColumn with addPropertyChangeListener().

getPropertyChangeListeners() - Method in class javax.swing.tree.DefaultTreeSelectionModel

Returns an array of all the property change listeners registered on this DefaultTreeSelectionModel.

getPropertyChangeListeners() - Method in class javax.swing.UIDefaults

Returns an array of all the PropertyChangeListeners added to this UIDefaults with addPropertyChangeListener().

getPropertyChangeListeners() - Static method in class javax.swing.UIManager

Returns an array of all the PropertyChangeListeners added to this UIManager with addPropertyChangeListener().

getPropertyChangeSupport() - Method in class javax.swing.SwingWorker

Returns the PropertyChangeSupport for this SwingWorker.

getPropertyDescriptors() - Method in interface java.beans.BeanInfo

Returns descriptors for all properties of the bean.

getPropertyDescriptors() - Method in class java.beans.SimpleBeanInfo

Deny knowledge of properties.

getPropertyEditorClass() - Method in class java.beans.PropertyDescriptor

Gets any explicit PropertyEditor Class that has been registered for this property.

getPropertyInfo(String, Properties) - Method in interface java.sql.Driver

Gets information about the possible properties for this driver.

getPropertyName() - Method in class java.beans.PropertyChangeEvent

Gets the programmatic name of the property that was changed.

getPropertyName() - Method in class java.beans.PropertyChangeListenerProxy

Returns the name of the named property associated with the listener.

getPropertyName() - Method in class java.beans.VetoableChangeListenerProxy

Returns the name of the named property associated with the listener.

getPropertyNames() - Method in class java.awt.image.BufferedImage

Returns an array of names recognized by getProperty(String) or null, if no property names are recognized.

getPropertyNames() - Method in interface java.awt.image.renderable.ContextualRenderedImageFactory

Returns a list of names recognized by getProperty.

getPropertyNames() - Method in interface java.awt.image.renderable.RenderableImage

Returns a list of names recognized by getProperty.

getPropertyNames() - Method in class java.awt.image.renderable.RenderableImageOp

Return a list of names recognized by getProperty.

getPropertyNames() - Method in interface java.awt.image.RenderedImage

Returns an array of names recognized by getProperty(String) or null, if no property names are recognized.

getPropertyOverrides() - Method in class java.rmi.activation.ActivationGroupDesc

Returns the group's property-override list.

getPropertyPrefix() - Method in class javax.swing.plaf.basic.BasicButtonUI

getPropertyPrefix() - Method in class javax.swing.plaf.basic.BasicCheckBoxMenuItemUI

getPropertyPrefix() - Method in class javax.swing.plaf.basic.BasicCheckBoxUI

getPropertyPrefix() - Method in class javax.swing.plaf.basic.BasicEditorPaneUI

Fetches the name used as a key to lookup properties through the UIManager.

getPropertyPrefix() - Method in class javax.swing.plaf.basic.BasicFormattedTextFieldUI

Fetches the name used as a key to lookup properties through the UIManager.

getPropertyPrefix() - Method in class javax.swing.plaf.basic.BasicMenuItemUI

getPropertyPrefix() - Method in class javax.swing.plaf.basic.BasicMenuUI

getPropertyPrefix() - Method in class javax.swing.plaf.basic.BasicPasswordFieldUI

Fetches the name used as a key to look up properties through the UIManager.

getPropertyPrefix() - Method in class javax.swing.plaf.basic.BasicRadioButtonMenuItemUI

getPropertyPrefix() - Method in class javax.swing.plaf.basic.BasicRadioButtonUI

getPropertyPrefix() - Method in class javax.swing.plaf.basic.BasicTextAreaUI

Fetches the name used as a key to look up properties through the UIManager.

getPropertyPrefix() - Method in class javax.swing.plaf.basic.BasicTextFieldUI

Fetches the name used as a key to lookup properties through the UIManager.

getPropertyPrefix() - Method in class javax.swing.plaf.basic.BasicTextPaneUI

Fetches the name used as a key to lookup properties through the UIManager.

getPropertyPrefix() - Method in class javax.swing.plaf.basic.BasicTextUI

Gets the name used as a key to look up properties through the UIManager.

getPropertyPrefix() - Method in class javax.swing.plaf.basic.BasicToggleButtonUI

getPropertyPrefix() - Method in class javax.swing.plaf.metal.MetalCheckBoxUI

getPropertyPrefix() - Method in class javax.swing.plaf.synth.SynthCheckBoxMenuItemUI

getPropertyPrefix() - Method in class javax.swing.plaf.synth.SynthCheckBoxUI

getPropertyPrefix() - Method in class javax.swing.plaf.synth.SynthFormattedTextFieldUI

Fetches the name used as a key to lookup properties through the UIManager.

getPropertyPrefix() - Method in class javax.swing.plaf.synth.SynthPasswordFieldUI

Fetches the name used as a key to look up properties through the UIManager.

getPropertyPrefix() - Method in class javax.swing.plaf.synth.SynthRadioButtonMenuItemUI

getPropertyPrefix() - Method in class javax.swing.plaf.synth.SynthRadioButtonUI

getPropertyPrefix() - Method in class javax.swing.plaf.synth.SynthTextPaneUI

Fetches the name used as a key to lookup properties through the UIManager.

getPropertyPrefix() - Method in class javax.swing.plaf.synth.SynthToggleButtonUI

getPropertyType() - Method in class java.beans.PropertyDescriptor

Returns the Java type info for the property.

getProtectionAlgorithm() - Method in class java.security.KeyStore.PasswordProtection

Gets the name of the protection algorithm.

getProtectionDomain() - Method in class java.lang.Class

Returns the ProtectionDomain of this class.

getProtectionParameter() - Method in class java.security.DomainLoadStoreParameter

Gets the keystore protection parameters for this domain.

getProtectionParameter(String) - Method in class java.security.KeyStore.Builder

Returns the ProtectionParameters that should be used to obtain the Entry with the given alias.

getProtectionParameter() - Method in interface java.security.KeyStore.LoadStoreParameter

Gets the parameter used to protect keystore data.

getProtectionParameters() - Method in class java.security.KeyStore.PasswordProtection

Gets the parameters supplied for the protection algorithm.

getProtectionParams() - Method in class java.security.DomainLoadStoreParameter

Gets the keystore protection parameters for keystores in this domain.

getProtocol() - Method in class java.net.URL

Gets the protocol name of this URL.

getProtocol() - Method in class javax.management.remote.JMXServiceURL

The protocol part of the Service URL.

getProtocol() - Method in class javax.management.remote.rmi.RMIIIOPServerImpl

getProtocol() - Method in class javax.management.remote.rmi.RMIJRMPServerImpl

getProtocol() - Method in class javax.management.remote.rmi.RMIServerImpl

Returns the protocol string for this object.

getProtocol() - Method in class javax.net.ssl.SSLContext

Returns the protocol name of this SSLContext object.

getProtocol() - Method in interface javax.net.ssl.SSLSession

Returns the standard name of the protocol used for all connections in the session.

getProtocol() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns the protocol string from the request in the form protocol/majorVersion.minorVersion.

getProtocols() - Method in class javax.net.ssl.SSLParameters

Returns a copy of the array of protocols or null if none have been set.

getPrototypeCellValue() - Method in class javax.swing.JList

Returns the "prototypical" cell value -- a value used to calculate a fixed width and height for cells.

getPrototypeDisplayValue() - Method in class javax.swing.JComboBox

Returns the "prototypical display" value - an Object used for the calculation of the display height and width.

getProvider() - Method in class java.security.AlgorithmParameterGenerator

Returns the provider of this algorithm parameter generator object.

getProvider() - Method in class java.security.AlgorithmParameters

Returns the provider of this parameter object.

getProvider() - Method in class java.security.cert.CertificateFactory

Returns the provider of this certificate factory.

getProvider() - Method in class java.security.cert.CertPathBuilder

Returns the provider of this CertPathBuilder.

getProvider() - Method in class java.security.cert.CertPathValidator

Returns the Provider of this CertPathValidator.

getProvider() - Method in class java.security.cert.CertStore

Returns the provider of this CertStore.

getProvider() - Method in class java.security.KeyFactory

Returns the provider of this key factory object.

getProvider() - Method in class java.security.KeyPairGenerator

Returns the provider of this key pair generator object.

getProvider() - Method in class java.security.KeyStore

Returns the provider of this keystore.

getProvider() - Method in class java.security.MessageDigest

Returns the provider of this message digest object.

getProvider() - Method in class java.security.Policy

Return the Provider of this Policy.

getProvider() - Method in class java.security.Provider.Service

Return the Provider of this service.

getProvider() - Method in class java.security.SecureRandom

Returns the provider of this SecureRandom object.

getProvider(String) - Static method in class java.security.Security

Returns the provider installed with the specified name, if any.

getProvider() - Method in class java.security.Signature

Returns the provider of this signature object.

getProvider() - Method in class javax.crypto.Cipher

Returns the provider of this Cipher object.

getProvider() - Method in class javax.crypto.ExemptionMechanism

Returns the provider of this ExemptionMechanism object.

getProvider() - Method in class javax.crypto.KeyAgreement

Returns the provider of this KeyAgreement object.

getProvider() - Method in class javax.crypto.KeyGenerator

Returns the provider of this KeyGenerator object.

getProvider() - Method in class javax.crypto.Mac

Returns the provider of this Mac object.

getProvider() - Method in class javax.crypto.SecretKeyFactory

Returns the provider of this SecretKeyFactory object.

getProvider() - Method in class javax.net.ssl.KeyManagerFactory

Returns the provider of this KeyManagerFactory object.

getProvider() - Method in class javax.net.ssl.SSLContext

Returns the provider of this SSLContext object.

getProvider() - Method in class javax.net.ssl.TrustManagerFactory

Returns the provider of this TrustManagerFactory object.

getProvider() - Method in class javax.security.auth.login.Configuration

Return the Provider of this Configuration.

getProvider() - Method in class javax.xml.crypto.dsig.keyinfo.KeyInfoFactory

Returns the provider of this KeyInfoFactory.

getProvider() - Method in class javax.xml.crypto.dsig.TransformService

Returns the provider of this TransformService.

getProvider() - Method in class javax.xml.crypto.dsig.XMLSignatureFactory

Returns the provider of this XMLSignatureFactory.

getProviderGrade() - Method in class javax.sql.rowset.spi.SyncProvider

Returns a constant indicating the grade of synchronization a RowSet object can expect from this SyncProvider object.

getProviderID() - Method in class javax.sql.rowset.spi.SyncProvider

Returns the unique identifier for this SyncProvider object.

getProviders() - Static method in class java.security.Security

Returns an array containing all the installed providers.

getProviders(String) - Static method in class java.security.Security

Returns an array containing all installed providers that satisfy the specified selection criterion, or null if no such providers have been installed.

getProviders(Map<String, String>) - Static method in class java.security.Security

Returns an array containing all installed providers that satisfy the specified* selection criteria, or null if no such providers have been installed.

getProxyClass(ClassLoader, Class<?>...) - Static method in class java.lang.reflect.Proxy

Returns the java.lang.Class object for a proxy class given a class loader and an array of interfaces.

getPseudoColumns(String, String, String, String) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of the pseudo or hidden columns available in a given table within the specified catalog and schema.

getPSName() - Method in class java.awt.Font

Returns the postscript name of this Font.

getPSource() - Method in class javax.crypto.spec.OAEPParameterSpec

Returns the source of encoding input P.

getPublic() - Method in class java.security.KeyPair

Returns a reference to the public key component of this key pair.

getPublicCredentials() - Method in class javax.security.auth.Subject

Return the Set of public credentials held by this Subject.

getPublicCredentials(Class<T>) - Method in class javax.security.auth.Subject

Return a Set of public credentials associated with this Subject that are instances or subclasses of the specified Class.

getPublicExponent() - Method in interface java.security.interfaces.RSAMultiPrimePrivateCrtKey

Returns the public exponent.

getPublicExponent() - Method in interface java.security.interfaces.RSAPrivateCrtKey

Returns the public exponent.

getPublicExponent() - Method in interface java.security.interfaces.RSAPublicKey

Returns the public exponent.

getPublicExponent() - Method in class java.security.spec.RSAKeyGenParameterSpec

Returns the public-exponent value.

getPublicExponent() - Method in class java.security.spec.RSAMultiPrimePrivateCrtKeySpec

Returns the public exponent.

getPublicExponent() - Method in class java.security.spec.RSAPrivateCrtKeySpec

Returns the public exponent.

getPublicExponent() - Method in class java.security.spec.RSAPublicKeySpec

Returns the public exponent.

getPublicId() - Method in interface javax.xml.stream.events.EntityDeclaration

The entity's public identifier, or null if none was given

getPublicId() - Method in interface javax.xml.stream.events.NotationDeclaration

The notation's public identifier, or null if none was given.

getPublicId() - Method in interface javax.xml.stream.Location

Returns the public ID of the XML

getPublicId() - Method in interface javax.xml.transform.SourceLocator

Return the public identifier for the current document event.

getPublicId() - Method in class javax.xml.transform.stream.StreamSource

Get the public identifier that was set with setPublicId.

getPublicId() - Method in interface org.w3c.dom.DocumentType

The public identifier of the external subset.

getPublicId() - Method in interface org.w3c.dom.Entity

The public identifier associated with the entity if specified, and null otherwise.

getPublicId() - Method in interface org.w3c.dom.ls.LSInput

The public identifier for this input source.

getPublicId() - Method in interface org.w3c.dom.Notation

The public identifier of this notation.

getPublicId() - Method in class org.xml.sax.helpers.LocatorImpl

Return the saved public identifier.

getPublicId() - Method in class org.xml.sax.InputSource

Get the public identifier for this input source.

getPublicId() - Method in interface org.xml.sax.Locator

Return the public identifier for the current document event.

getPublicId() - Method in exception org.xml.sax.SAXParseException

Get the public identifier of the entity where the exception occurred.

getPublicKey() - Method in class java.security.cert.Certificate

Gets the public key from this certificate.

getPublicKey() - Method in class java.security.cert.PKIXCertPathValidatorResult

Returns the public key of the subject (target) of the certification path, including any inherited public key parameters if applicable.

getPublicKey() - Method in interface java.security.Certificate

Deprecated.

Returns the key of the principal-key pair being guaranteed by the guarantor.

getPublicKey() - Method in class java.security.Identity

Deprecated.

Returns this identity's public key.

getPublicKey() - Method in class javax.security.cert.Certificate

Gets the public key from this certificate.

getPublicKey() - Method in interface javax.xml.crypto.dsig.keyinfo.KeyValue

Returns the public key of this KeyValue.

getPurgeFlag() - Method in class javax.management.relation.RelationService

Returns the flag to indicate if when a notification is received for the unregistration of an MBean referenced in a relation, if an immediate "purge" of the relations (look for the relations no longer valid) has to be performed , or if that will be performed only when the purgeRelations method will be explicitly called.

getPurgeFlag() - Method in interface javax.management.relation.RelationServiceMBean

Returns the flag to indicate if when a notification is received for the unregistration of an MBean referenced in a relation, if an immediate "purge" of the relations (look for the relations no longer valid) has to be performed, or if that will be performed only when the purgeRelations method is explicitly called.

getPushLevel() - Method in class java.util.logging.MemoryHandler

Get the pushLevel.

getQ() - Method in interface java.security.interfaces.DSAParams

Returns the subprime, q.

getQ() - Method in class java.security.spec.DSAParameterSpec

Returns the sub-prime q.

getQ() - Method in class java.security.spec.DSAPrivateKeySpec

Returns the sub-prime q.

getQ() - Method in class java.security.spec.DSAPublicKeySpec

Returns the sub-prime q.

getQName(int) - Method in interface org.xml.sax.Attributes

Look up an attribute's XML qualified (prefixed) name by index.

getQName(int) - Method in class org.xml.sax.helpers.AttributesImpl

Return an attribute's qualified (prefixed) name.

getQOP() - Method in class org.ietf.jgss.MessageProp

Retrieves the QOP value.

getQTables() - Method in class javax.imageio.plugins.jpeg.JPEGImageReadParam

Returns a copy of the array of quantization tables set on the most recent call to setDecodeTables, or null if tables are not currently set.

getQTables() - Method in class javax.imageio.plugins.jpeg.JPEGImageWriteParam

Returns a copy of the array of quantization tables set on the most recent call to setEncodeTables, or null if tables are not currently set.

getQuadrantRotateInstance(int) - Static method in class java.awt.geom.AffineTransform

Returns a transform that rotates coordinates by the specified number of quadrants.

getQuadrantRotateInstance(int, double, double) - Static method in class java.awt.geom.AffineTransform

Returns a transform that rotates coordinates by the specified number of quadrants around the specified anchor point.

getQualifiedName() - Method in interface javax.lang.model.element.PackageElement

Returns the fully qualified name of this package.

getQualifiedName() - Method in interface javax.lang.model.element.QualifiedNameable

Returns the fully qualified name of an element.

getQualifiedName() - Method in interface javax.lang.model.element.TypeElement

Returns the fully qualified name of this type element.

getQualifiedName() - Method in interface javax.xml.soap.Name

Gets the namespace-qualified name of the XML name that this Name object represents.

getQuery() - Method in class java.net.URI

Returns the decoded query component of this URI.

getQuery() - Method in class java.net.URL

Gets the query part of this URL.

getQueryString() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns the query string that is contained in the request URI after the path.

getQueryTimeout() - Method in interface java.sql.Statement

Retrieves the number of seconds the driver will wait for a Statement object to execute.

getQueryTimeout() - Method in class javax.sql.rowset.BaseRowSet

Retrieves the maximum number of seconds the driver will wait for a query to execute.

getQueryTimeout() - Method in interface javax.sql.RowSet

Retrieves the maximum number of seconds the driver will wait for a statement to execute.

getQueue() - Method in class java.util.concurrent.ScheduledThreadPoolExecutor

Returns the task queue used by this executor.

getQueue() - Method in class java.util.concurrent.ThreadPoolExecutor

Returns the task queue used by this executor.

getQueuedReaderThreads() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock

Returns a collection containing threads that may be waiting to acquire the read lock.

getQueuedSubmissionCount() - Method in class java.util.concurrent.ForkJoinPool

Returns an estimate of the number of tasks submitted to this pool that have not yet begun executing.

getQueuedTaskCount() - Method in class java.util.concurrent.ForkJoinPool

Returns an estimate of the total number of tasks currently held in queues by worker threads (but not including tasks submitted to the pool that have not begun executing).

getQueuedTaskCount() - Static method in class java.util.concurrent.ForkJoinTask

Returns an estimate of the number of tasks that have been forked by the current worker thread but not yet executed.

getQueuedThreads() - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer

Returns a collection containing threads that may be waiting to acquire.

getQueuedThreads() - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer

Returns a collection containing threads that may be waiting to acquire.

getQueuedThreads() - Method in class java.util.concurrent.locks.ReentrantLock

Returns a collection containing threads that may be waiting to acquire this lock.

getQueuedThreads() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock

Returns a collection containing threads that may be waiting to acquire either the read or write lock.

getQueuedThreads() - Method in class java.util.concurrent.Semaphore

Returns a collection containing threads that may be waiting to acquire.

getQueuedWriterThreads() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock

Returns a collection containing threads that may be waiting to acquire the write lock.

getQueueLength() - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer

Returns an estimate of the number of threads waiting to acquire.

getQueueLength() - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer

Returns an estimate of the number of threads waiting to acquire.

getQueueLength() - Method in class java.util.concurrent.locks.ReentrantLock

Returns an estimate of the number of threads waiting to acquire this lock.

getQueueLength() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock

Returns an estimate of the number of threads waiting to acquire either the read or write lock.

getQueueLength() - Method in class java.util.concurrent.Semaphore

Returns an estimate of the number of threads waiting to acquire.

getRadioButtonBorder() - Static method in class javax.swing.plaf.basic.BasicBorders

getRadioButtonIcon() - Static method in class javax.swing.plaf.basic.BasicIconFactory

getRadioButtonIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

getRadioButtonMenuItemIcon() - Static method in class javax.swing.plaf.basic.BasicIconFactory

getRadioButtonMenuItemIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

getRadius() - Method in class java.awt.RadialGradientPaint

Returns the radius of the circle defining the radial gradient.

getRaisedBevelBorderUIResource() - Static method in class javax.swing.plaf.BorderUIResource

getRange() - Method in class java.util.Locale.LanguageRange

Returns the language range of this LanguageRange.

getRanges() - Method in class java.awt.font.NumericShaper

Returns an int that ORs together the values for all the ranges that will be shaped.

getRangeSet() - Method in class java.awt.font.NumericShaper

Returns a Set representing all the Unicode ranges in this NumericShaper that will be shaped.

getRangeUnit() - Method in enum java.time.temporal.ChronoField

getRangeUnit() - Method in interface java.time.temporal.TemporalField

Gets the range that the field is bound by.

getRaster() - Method in class java.awt.image.BufferedImage

Returns the WritableRaster.

getRaster(int, int, int, int) - Method in interface java.awt.PaintContext

Returns a Raster containing the colors generated for the graphics operation.

getRaster() - Method in class javax.imageio.IIOImage

Returns the currently set Raster, or null if only a RenderedImage is available.

getRawAuthority() - Method in class java.net.URI

Returns the raw authority component of this URI.

getRawContent() - Method in class javax.xml.soap.AttachmentPart

Gets the content of this AttachmentPart object as an InputStream as if a call had been made to getContent and no DataContentHandler had been registered for the content-type of this AttachmentPart.

getRawContentBytes() - Method in class javax.xml.soap.AttachmentPart

Gets the content of this AttachmentPart object as a byte[] array as if a call had been made to getContent and no DataContentHandler had been registered for the content-type of this AttachmentPart.

getRawFragment() - Method in class java.net.URI

Returns the raw fragment component of this URI.

getRawImageType(int) - Method in class javax.imageio.ImageReader

Returns an ImageTypeSpecifier indicating the SampleModel and ColorModel which most closely represents the "raw" internal format of the image.

getRawOffset() - Method in class java.util.SimpleTimeZone

Gets the GMT offset for this time zone.

getRawOffset() - Method in class java.util.TimeZone

Returns the amount of time in milliseconds to add to UTC to get standard time in this time zone.

getRawPath() - Method in class java.net.URI

Returns the raw path component of this URI.

getRawQuery() - Method in class java.net.URI

Returns the raw query component of this URI.

getRawResult() - Method in class java.util.concurrent.CountedCompleter

Returns the result of the computation.

getRawResult() - Method in class java.util.concurrent.ForkJoinTask

Returns the result that would be returned by ForkJoinTask.join(), even if this task completed abnormally, or null if this task is not known to have been completed.

getRawResult() - Method in class java.util.concurrent.RecursiveAction

Always returns null.

getRawResult() - Method in class java.util.concurrent.RecursiveTask

getRawSchemeSpecificPart() - Method in class java.net.URI

Returns the raw scheme-specific part of this URI.

getRawType() - Method in interface java.lang.reflect.ParameterizedType

Returns the Type object representing the class or interface that declared this type.

getRawUserInfo() - Method in class java.net.URI

Returns the raw user-information component of this URI.

getRdn(int) - Method in class javax.naming.ldap.LdapName

Retrieves an RDN of this LDAP name as an Rdn.

getRdns() - Method in class javax.naming.ldap.LdapName

Retrieves the list of relative distinguished names.

getRead() - Method in exception java.sql.DataTruncation

Indicates whether or not the value was truncated on a read.

getReader() - Method in interface javax.script.ScriptContext

Returns a Reader to be used by the script to read input.

getReader() - Method in class javax.script.SimpleScriptContext

Returns a Reader to be used by the script to read input.

getReader(int) - Method in class javax.swing.text.html.HTMLDocument

Fetches the reader for the parser to use when loading the document with HTML.

getReader(int, int, int, HTML.Tag) - Method in class javax.swing.text.html.HTMLDocument

Returns the reader for the parser to use to load the document with HTML.

getReader() - Method in class javax.xml.transform.stream.StreamSource

Get the character stream that was set with setReader.

getReaderFileSuffixes() - Static method in class javax.imageio.ImageIO

Returns an array of Strings listing all of the file suffixes associated with the formats understood by the current set of registered readers.

getReaderFormatNames() - Static method in class javax.imageio.ImageIO

Returns an array of Strings listing all of the informal format names understood by the current set of registered readers.

getReaderForText(Transferable) - Method in class java.awt.datatransfer.DataFlavor

Gets a Reader for a text flavor, decoded, if necessary, for the expected charset (encoding).

getReaderForText() - Method in interface javax.print.Doc

Obtains a reader for extracting character print data from this doc.

getReaderForText() - Method in class javax.print.SimpleDoc

Obtains a reader for extracting character print data from this doc.

getReaderMIMETypes() - Static method in class javax.imageio.ImageIO

Returns an array of Strings listing all of the MIME types understood by the current set of registered readers.

getReaderServiceProviderName() - Method in class javax.imageio.spi.ImageTranscoderSpi

Returns the fully qualified class name of an ImageReaderSpi class that generates IIOMetadata objects that may be used as input to this transcoder.

getReadHoldCount() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock

Queries the number of reentrant read holds on this lock by the current thread.

getReadLockCount() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock

Queries the number of read locks held for this lock.

getReadLockCount() - Method in class java.util.concurrent.locks.StampedLock

Queries the number of read locks held for this lock.

getReadMethod() - Method in class java.beans.PropertyDescriptor

Gets the method that should be used to read the property value.

getReadTimeout() - Method in class java.net.URLConnection

Returns setting for read timeout.

getRealm() - Method in class javax.security.auth.kerberos.KerberosPrincipal

Returns the realm component of this Kerberos principal.

getReason() - Method in exception java.net.HttpRetryException

Returns a string explaining why the http request could not be retried.

getReason() - Method in exception java.net.URISyntaxException

Returns a string explaining why the input string could not be parsed.

getReason() - Method in exception java.nio.file.FileSystemException

Returns the string explaining why the file system operation failed.

getReason() - Method in exception java.nio.file.InvalidPathException

Returns a string explaining why the input string was rejected.

getReason() - Method in exception java.security.cert.CertPathValidatorException

Returns the reason that the validation failed.

getReason() - Method in interface javax.print.URIException

Return the reason for the event.

getReceiveBufferSize() - Method in class java.net.DatagramSocket

Get value of the SO_RCVBUF option for this DatagramSocket, that is the buffer size used by the platform for input on this DatagramSocket.

getReceiveBufferSize() - Method in class java.net.ServerSocket

Gets the value of the SO_RCVBUF option for this ServerSocket, that is the proposed buffer size that will be used for Sockets accepted from this ServerSocket.

getReceiveBufferSize() - Method in class java.net.Socket

Gets the value of the SO_RCVBUF option for this Socket, that is the buffer size used by the platform for input on this Socket.

getReceiver() - Method in interface javax.sound.midi.MidiDevice

Obtains a MIDI IN receiver through which the MIDI device may receive MIDI data.

getReceiver() - Static method in class javax.sound.midi.MidiSystem

Obtains a MIDI receiver from an external MIDI port or other default device.

getReceiver() - Method in interface javax.sound.midi.Transmitter

Obtains the current receiver to which this transmitter will deliver MIDI messages.

getReceivers() - Method in interface javax.sound.midi.MidiDevice

Returns all currently active, non-closed receivers connected with this MidiDevice.

getReceiverType() - Method in interface javax.lang.model.element.ExecutableElement

Returns the receiver type of this executable, or NoType with kind NONE if the executable has no receiver type.

getReceiverType() - Method in interface javax.lang.model.type.ExecutableType

Returns the receiver type of this executable, or NoType with kind NONE if the executable has no receiver type.

getRecursionLimit() - Method in class java.awt.geom.FlatteningPathIterator

Returns the recursion limit of this iterator.

getRed() - Method in class java.awt.Color

Returns the red component in the range 0-255 in the default sRGB space.

getRed(int) - Method in class java.awt.image.ColorModel

Returns the red color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getRed(Object) - Method in class java.awt.image.ColorModel

Returns the red color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getRed(int) - Method in class java.awt.image.ComponentColorModel

Returns the red color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getRed(Object) - Method in class java.awt.image.ComponentColorModel

Returns the red color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getRed(int) - Method in class java.awt.image.DirectColorModel

Returns the red color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getRed(Object) - Method in class java.awt.image.DirectColorModel

Returns the red color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getRed(int) - Method in class java.awt.image.IndexColorModel

Returns the red color component for the specified pixel, scaled from 0 to 255 in the default RGB ColorSpace, sRGB.

getRedMask() - Method in class java.awt.image.DirectColorModel

Returns the mask indicating which bits in an int pixel representation contain the red color component.

getRedoPresentationName() - Method in class javax.swing.text.AbstractDocument.DefaultDocumentEvent

Provides a localized, human readable description of the redoable form of this edit, e.g.

getRedoPresentationName() - Method in class javax.swing.undo.AbstractUndoableEdit

Retreives the value from the defaults table with key AbstractUndoableEdit.redoText and returns that value followed by a space, followed by getPresentationName.

getRedoPresentationName() - Method in class javax.swing.undo.CompoundEdit

Returns getRedoPresentationName from the last UndoableEdit added to edits.

getRedoPresentationName() - Method in interface javax.swing.undo.UndoableEdit

Returns a localized, human-readable description of the redoable form of this edit, suitable for use as a Redo menu item, for example.

getRedoPresentationName() - Method in class javax.swing.undo.UndoManager

Returns a description of the redoable form of this edit.

getReds(byte[]) - Method in class java.awt.image.IndexColorModel

Copies the array of red color components into the specified array.

getReductionPolynomial() - Method in class java.security.spec.ECFieldF2m

Returns a BigInteger whose i-th bit corresponds to the i-th coefficient of the reduction polynomial for polynomial basis or null for normal basis.

getRef() - Method in class java.net.URL

Gets the anchor (also known as the "reference") of this URL.

getRef() - Method in class java.rmi.server.RemoteObject

Returns the remote reference for the remote object.

getRef(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC REF(<structured-type>) parameter as a Ref object in the Java programming language.

getRef(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC REF(<structured-type>) parameter as a Ref object in the Java programming language.

getRef(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a Ref object in the Java programming language.

getRef(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a Ref object in the Java programming language.

getRefClass(ObjectOutput) - Method in interface java.rmi.server.RemoteRef

Returns the class name of the ref type to be serialized onto the stream 'out'.

getReference() - Method in class java.util.concurrent.atomic.AtomicMarkableReference

Returns the current value of the reference.

getReference() - Method in class java.util.concurrent.atomic.AtomicStampedReference

Returns the current value of the reference.

getReference() - Method in interface javax.naming.Referenceable

Retrieves the Reference of this object.

getReferencedMBeans() - Method in interface javax.management.relation.Relation

Retrieves MBeans referenced in the various roles of the relation.

getReferencedMBeans(String) - Method in class javax.management.relation.RelationService

Retrieves MBeans referenced in the various roles of the relation.

getReferencedMBeans(String) - Method in interface javax.management.relation.RelationServiceMBean

Retrieves MBeans referenced in the various roles of the relation.

getReferencedMBeans() - Method in class javax.management.relation.RelationSupport

Retrieves MBeans referenced in the various roles of the relation.

getReferenceKind() - Method in interface java.lang.invoke.MethodHandleInfo

Returns the reference kind of the cracked method handle, which in turn determines whether the method handle's underlying member was a constructor, method, or field.

getReferences() - Method in interface javax.xml.crypto.dsig.Manifest

Returns an unmodifiable list of one or more References that are contained in this Manifest.

getReferences() - Method in interface javax.xml.crypto.dsig.SignedInfo

Returns an unmodifiable list of one or more References.

getReferralContext() - Method in exception javax.naming.ldap.LdapReferralException

Retrieves the context at which to continue the method using the context's environment and no controls.

getReferralContext(Hashtable<?, ?>) - Method in exception javax.naming.ldap.LdapReferralException

Retrieves the context at which to continue the method using environment properties and no controls.

getReferralContext(Hashtable<?, ?>, Control[]) - Method in exception javax.naming.ldap.LdapReferralException

Retrieves the context at which to continue the method using request controls and environment properties.

getReferralContext() - Method in exception javax.naming.ReferralException

Retrieves the context at which to continue the method.

getReferralContext(Hashtable<?, ?>) - Method in exception javax.naming.ReferralException

Retrieves the context at which to continue the method using environment properties.

getReferralInfo() - Method in exception javax.naming.ReferralException

Retrieves information (such as URLs) related to this referral.

getReferrals() - Method in interface javax.naming.ldap.UnsolicitedNotification

Retrieves the referral(s) sent by the server.

getRefMBeanClassName() - Method in class javax.management.relation.RoleInfo

Returns name of type of MBean expected to be referenced in corresponding role.

getRefreshRate() - Method in class java.awt.DisplayMode

Returns the refresh rate of the display, in hertz.

getRegion() - Method in class javax.swing.plaf.synth.SynthContext

Returns the Region identifying this state.

getRegion(JComponent) - Static method in class javax.swing.plaf.synth.SynthLookAndFeel

Returns the Region for the JComponent c.

getRegisteredKeyStrokes() - Method in class javax.swing.JComponent

Returns the KeyStrokes that will initiate registered actions.

getRegisteredParties() - Method in class java.util.concurrent.Phaser

Returns the number of parties registered at this phaser.

getRegisteredProviders() - Static method in class javax.sql.rowset.spi.SyncFactory

Returns an Enumeration of currently registered synchronization providers.

getRegistry() - Static method in class java.rmi.registry.LocateRegistry

Returns a reference to the the remote object Registry for the local host on the default registry port of 1099.

getRegistry(int) - Static method in class java.rmi.registry.LocateRegistry

Returns a reference to the the remote object Registry for the local host on the specified port.

getRegistry(String) - Static method in class java.rmi.registry.LocateRegistry

Returns a reference to the remote object Registry on the specified host on the default registry port of 1099.

getRegistry(String, int) - Static method in class java.rmi.registry.LocateRegistry

Returns a reference to the remote object Registry on the specified host and port.

getRegistry(String, int, RMIClientSocketFactory) - Static method in class java.rmi.registry.LocateRegistry

Returns a locally created remote reference to the remote object Registry on the specified host and port.

getRejectedExecutionHandler() - Method in class java.util.concurrent.ThreadPoolExecutor

Returns the current handler for unexecutable tasks.

getRelatedData() - Method in interface org.w3c.dom.DOMError

The related DOMError.type dependent data if any.

getRelatedException() - Method in interface org.w3c.dom.DOMError

The related platform dependent exception if any.

getRelatedNode() - Method in interface org.w3c.dom.DOMLocator

The node this locator is pointing to, or null if no node is available.

getRelatedNode() - Method in interface org.w3c.dom.events.MutationEvent

relatedNode is used to identify a secondary node related to a mutation event.

getRelatedTarget() - Method in interface org.w3c.dom.events.MouseEvent

Used to identify a secondary EventTarget related to a UI event.

getRelationId() - Method in interface javax.management.relation.Relation

Returns relation identifier (used to uniquely identify the relation inside the Relation Service).

getRelationId() - Method in class javax.management.relation.RelationNotification

Returns the relation identifier of created/removed/updated relation.

getRelationId() - Method in class javax.management.relation.RelationSupport

Returns relation identifier (used to uniquely identify the relation inside the Relation Service).

getRelationServiceName() - Method in interface javax.management.relation.Relation

Returns ObjectName of the Relation Service handling the relation.

getRelationServiceName() - Method in class javax.management.relation.RelationSupport

Returns ObjectName of the Relation Service handling the relation.

getRelationTypeName() - Method in interface javax.management.relation.Relation

Returns name of associated relation type.

getRelationTypeName() - Method in class javax.management.relation.RelationNotification

Returns the relation type name of created/removed/updated relation.

getRelationTypeName(String) - Method in class javax.management.relation.RelationService

Returns name of associated relation type for given relation.

getRelationTypeName(String) - Method in interface javax.management.relation.RelationServiceMBean

Returns name of associated relation type for given relation.

getRelationTypeName() - Method in class javax.management.relation.RelationSupport

Returns name of associated relation type.

getRelationTypeName() - Method in interface javax.management.relation.RelationType

Returns the relation type name.

getRelationTypeName() - Method in class javax.management.relation.RelationTypeSupport

Returns the relation type name.

getRelay() - Method in interface javax.xml.soap.SOAPHeaderElement

Returns the boolean value of the relay attribute for this SOAPHeaderElement

getRemaining() - Method in class java.util.zip.Inflater

Returns the total number of bytes remaining in the input buffer.

getRemainingAcceptLifetime(Oid) - Method in interface org.ietf.jgss.GSSCredential

Returns the lifetime in seconds for the credential to remain capable of accepting security contexts using the specified mechanism.

getRemainingInitLifetime(Oid) - Method in interface org.ietf.jgss.GSSCredential

Returns the lifetime in seconds for the credential to remain capable of initiating security contexts using the specified mechanism.

getRemainingLifetime() - Method in interface org.ietf.jgss.GSSCredential

Returns the remaining lifetime in seconds for a credential.

getRemainingName() - Method in exception javax.naming.NamingException

Retrieves the remaining unresolved portion of the name.

getRemainingName() - Method in class javax.naming.spi.ResolveResult

Retrieves the remaining unresolved portion of the name.

getRemainingNewName() - Method in exception javax.naming.CannotProceedException

Retrieves the "remaining new name" field of this exception, which is used when this exception is thrown during a rename() operation.

getRemoteAddress() - Method in class java.nio.channels.AsynchronousSocketChannel

Returns the remote address to which this channel's socket is connected.

getRemoteAddress() - Method in class java.nio.channels.DatagramChannel

Returns the remote address to which this channel's socket is connected.

getRemoteAddress() - Method in class java.nio.channels.SocketChannel

Returns the remote address to which this channel's socket is connected.

getRemoteAddress() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns the unresolved address of the remote entity invoking this request.

getRemoteSocketAddress() - Method in class java.net.DatagramSocket

Returns the address of the endpoint this socket is connected to, or null if it is unconnected.

getRemoteSocketAddress() - Method in class java.net.Socket

Returns the address of the endpoint this socket is connected to, or null if it is unconnected.

getRemoveListenerMethod() - Method in class java.beans.EventSetDescriptor

Gets the method used to remove event listeners.

getRemoveOnCancelPolicy() - Method in class java.util.concurrent.ScheduledThreadPoolExecutor

Gets the policy on whether cancelled tasks should be immediately removed from the work queue at time of cancellation.

getRenderableSource(int) - Method in class java.awt.image.renderable.ParameterBlock

Returns a source as a RenderableImage.

getRenderedImage() - Method in class javax.imageio.IIOImage

Returns the currently set RenderedImage, or null if only a Raster is available.

getRenderedSource(int) - Method in class java.awt.image.renderable.ParameterBlock

Returns a source as a RenderedImage.

getRenderer() - Method in class javax.swing.JComboBox

Returns the renderer used to display the selected item in the JComboBox field.

getRenderingHint(RenderingHints.Key) - Method in class java.awt.Graphics2D

Returns the value of a single preference for the rendering algorithms.

getRenderingHints() - Method in class java.awt.Graphics2D

Gets the preferences for the rendering algorithms.

getRenderingHints() - Method in class java.awt.image.AffineTransformOp

Returns the rendering hints used by this transform operation.

getRenderingHints() - Method in class java.awt.image.BandCombineOp

Returns the rendering hints for this operation.

getRenderingHints() - Method in interface java.awt.image.BufferedImageOp

Returns the rendering hints for this operation.

getRenderingHints() - Method in class java.awt.image.ColorConvertOp

Returns the rendering hints used by this op.

getRenderingHints() - Method in class java.awt.image.ConvolveOp

Returns the rendering hints for this op.

getRenderingHints() - Method in class java.awt.image.LookupOp

Returns the rendering hints for this op.

getRenderingHints() - Method in interface java.awt.image.RasterOp

Returns the rendering hints for this RasterOp.

getRenderingHints() - Method in class java.awt.image.renderable.RenderContext

Gets the rendering hints of this RenderContext.

getRenderingHints() - Method in class java.awt.image.RescaleOp

Returns the rendering hints for this op.

getRenewTill() - Method in class javax.security.auth.kerberos.KerberosTicket

Returns the latest expiration time for this ticket, including all renewals.

getReorderingAllowed() - Method in class javax.swing.table.JTableHeader

Returns true if the user is allowed to rearrange columns by dragging their headers, false otherwise.

getReplacementText() - Method in interface javax.xml.stream.events.EntityDeclaration

The replacement text of the entity.

getReplayDetState() - Method in interface org.ietf.jgss.GSSContext

Determines if replay detection is enabled for the per-message security services from this context.

getRepresentationClass() - Method in class java.awt.datatransfer.DataFlavor

Returns the Class which objects supporting this DataFlavor will return when this DataFlavor is requested.

getRepresentationClass() - Method in class javax.activation.ActivationDataFlavor

Return the representation class.

getRepresentationClassName() - Method in class javax.print.DocFlavor

Returns the name of this doc flavor object's representation class.

getRequestBody() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns a stream from which the request body can be read.

getRequestContext() - Method in interface javax.xml.ws.BindingProvider

Get the context that is used to initialize the message context for request messages.

getRequestControls() - Method in class javax.naming.ldap.InitialLdapContext

getRequestControls() - Method in interface javax.naming.ldap.LdapContext

Retrieves the request controls in effect for this context.

getRequestedServerNames() - Method in class javax.net.ssl.ExtendedSSLSession

Obtains a List containing all SNIServerNames of the requested Server Name Indication (SNI) extension.

getRequestHeader(String) - Method in class javax.xml.ws.spi.http.HttpExchange

Returns the value of the specified request header.

getRequestHeaders() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns an immutable Map containing the HTTP headers that were included with this request.

getRequestingHost() - Method in class java.net.Authenticator

Gets the hostname of the site or proxy requesting authentication, or null if not available.

getRequestingPort() - Method in class java.net.Authenticator

Gets the port number for the requested connection.

getRequestingPrompt() - Method in class java.net.Authenticator

Gets the prompt string given by the requestor.

getRequestingProtocol() - Method in class java.net.Authenticator

Give the protocol that's requesting the connection.

getRequestingScheme() - Method in class java.net.Authenticator

Gets the scheme of the requestor (the HTTP scheme for an HTTP firewall, for example).

getRequestingSite() - Method in class java.net.Authenticator

Gets the InetAddress of the site requesting authorization, or null if not available.

getRequestingURL() - Method in class java.net.Authenticator

Returns the URL that resulted in this request for authentication.

getRequestMethod() - Method in class java.net.HttpURLConnection

Get the request method.

getRequestMethod() - Method in class javax.xml.ws.spi.http.HttpExchange

Get the HTTP request method

getRequestorType() - Method in class java.net.Authenticator

Returns whether the requestor is a Proxy or a Server.

getRequestProperties() - Method in class java.net.URLConnection

Returns an unmodifiable Map of general request properties for this connection.

getRequestProperty(String) - Method in class java.net.URLConnection

Returns the value of the named general request property for this connection.

getRequestURI() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns the part of the request's URI from the protocol name up to the query string in the first line of the HTTP request.

getReshowDelay() - Method in class javax.swing.ToolTipManager

Returns the reshow delay property.

getResizable() - Method in class javax.swing.table.TableColumn

Returns true if the user is allowed to resize the TableColumn's width, false otherwise.

getResizeWeight() - Method in class javax.swing.JSplitPane

Returns the number that determines how extra space is distributed.

getResizeWeight(int) - Method in class javax.swing.text.BoxView

Gets the resize weight.

getResizeWeight(int) - Method in class javax.swing.text.FieldView

Determines the resizability of the view along the given axis.

getResizeWeight(int) - Method in class javax.swing.text.html.BlockView

Gets the resize weight.

getResizeWeight(int) - Method in class javax.swing.text.TableView.TableRow

Determines the resizability of the view along the given axis.

getResizeWeight(int) - Method in class javax.swing.text.View

Determines the resizability of the view along the given axis.

getResizingAllowed() - Method in class javax.swing.table.JTableHeader

Returns true if the user is allowed to resize columns by dragging between their headers, false otherwise.

getResizingColumn() - Method in class javax.swing.table.JTableHeader

Returns the resizing column.

getResolution(int) - Method in class javax.print.attribute.ResolutionSyntax

Get this resolution attribute's resolution values in the given units.

getResolution() - Method in class javax.sound.midi.MidiFileFormat

Obtains the timing resolution for the MIDI file.

getResolution() - Method in class javax.sound.midi.Sequence

Obtains the timing resolution for this sequence.

getResolvedName() - Method in exception javax.naming.NamingException

Retrieves the leading portion of the name that was resolved successfully.

getResolvedObj() - Method in exception javax.naming.NamingException

Retrieves the object to which resolution was successful.

getResolvedObj() - Method in class javax.naming.spi.ResolveResult

Retrieves the Object to which resolution was successful.

getResolveParent() - Method in class javax.swing.text.AbstractDocument.AbstractElement

Gets the resolving parent.

getResolveParent() - Method in interface javax.swing.text.AttributeSet

Gets the resolving parent.

getResolveParent() - Method in class javax.swing.text.html.HTMLDocument.BlockElement

Gets the resolving parent.

getResolveParent() - Method in class javax.swing.text.html.HTMLDocument.RunElement

Gets the resolving parent.

getResolveParent() - Method in interface javax.swing.text.Keymap

Fetches the parent keymap used to resolve key-bindings.

getResolveParent() - Method in class javax.swing.text.SimpleAttributeSet

Gets the resolving parent.

getResolveParent() - Method in class javax.swing.text.StyleContext.NamedStyle

Gets attributes from the parent.

getResolveParent() - Method in class javax.swing.text.StyleContext.SmallAttributeSet

If not overriden, the resolving parent defaults to the parent element.

getResolverFields() - Method in class java.time.format.DateTimeFormatter

Gets the resolver fields to use during parsing.

getResolverStyle() - Method in class java.time.format.DateTimeFormatter

Gets the resolver style to use during parsing.

getResource(String, BeanContextChild) - Method in interface java.beans.beancontext.BeanContext

Analagous to java.lang.ClassLoader.getResource(), this method allows a BeanContext implementation to interpose behavior between the child Component and underlying ClassLoader.

getResource(String, BeanContextChild) - Method in class java.beans.beancontext.BeanContextSupport

getResource(String) - Method in class java.lang.Class

Finds a resource with a given name.

getResource(String) - Method in class java.lang.ClassLoader

Finds the resource with the given name.

getResource(JavaFileManager.Location, CharSequence, CharSequence) - Method in interface javax.annotation.processing.Filer

Returns an object for reading an existing resource.

getResource(String) - Method in interface javax.management.loading.MLetMBean

Finds the resource with the given name.

getResourceAsStream(String, BeanContextChild) - Method in interface java.beans.beancontext.BeanContext

Analagous to java.lang.ClassLoader.getResourceAsStream(), this method allows a BeanContext implementation to interpose behavior between the child Component and underlying ClassLoader.

getResourceAsStream(String, BeanContextChild) - Method in class java.beans.beancontext.BeanContextSupport

getResourceAsStream(String) - Method in class java.lang.Class

Finds a resource with a given name.

getResourceAsStream(String) - Method in class java.lang.ClassLoader

Returns an input stream for reading the specified resource.

getResourceAsStream(String) - Method in class java.net.URLClassLoader

Returns an input stream for reading the specified resource.

getResourceAsStream(String) - Method in interface javax.management.loading.MLetMBean

Returns an input stream for reading the specified resource.

getResourceBaseName() - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

Returns the currently set base name for locating ResourceBundles.

getResourceBundle() - Method in class java.util.logging.Logger

Retrieve the localization resource bundle for this logger.

getResourceBundle() - Method in class java.util.logging.LogRecord

Get the localization resource bundle

getResourceBundleName() - Method in class java.util.logging.Level

Return the level's localization resource bundle name, or null if no localization bundle is defined.

getResourceBundleName() - Method in class java.util.logging.Logger

Retrieve the localization resource bundle name for this logger.

getResourceBundleName() - Method in class java.util.logging.LogRecord

Get the localization resource bundle name

getResourceResolver() - Method in class javax.xml.validation.SchemaFactory

Gets the current LSResourceResolver set to this SchemaFactory.

getResourceResolver() - Method in class javax.xml.validation.Validator

Gets the current LSResourceResolver set to this Validator.

getResourceResolver() - Method in class javax.xml.validation.ValidatorHandler

Gets the current LSResourceResolver set to this ValidatorHandler.

getResources(String) - Method in class java.lang.ClassLoader

Finds all the resources with the given name.

getResources(String) - Method in interface javax.management.loading.MLetMBean

Finds all the resources with the given name.

getResources() - Method in interface javax.sound.midi.Soundbank

Extracts a list of non-Instrument resources contained in the sound bank.

getResponseBody() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns a stream to which the response body must be written.

getResponseCode() - Method in class java.net.HttpURLConnection

Gets the status code from an HTTP response message.

getResponseContext() - Method in interface javax.xml.ws.BindingProvider

Get the context that resulted from processing a response message.

getResponseControls() - Method in class javax.naming.ldap.InitialLdapContext

getResponseControls() - Method in interface javax.naming.ldap.LdapContext

Retrieves the response controls produced as a result of the last method invoked on this context.

getResponseHeaders() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns a mutable Map into which the HTTP response headers can be stored and which will be transmitted as part of this response.

getResponseMessage() - Method in class java.net.HttpURLConnection

Gets the HTTP response message, if any, returned along with the response code from a server.

getResponses() - Method in class javax.xml.ws.soap.AddressingFeature

If addressing is enabled, this property determines whether endpoint requires the use of anonymous responses, or non-anonymous responses, or all responses.

getRestartMode() - Method in class java.rmi.activation.ActivationDesc

Returns the "restart" mode of the object associated with this activation descriptor.

getResult() - Method in interface javax.xml.bind.UnmarshallerHandler

Obtains the unmarshalled result.

getResult() - Method in class javax.xml.bind.util.JAXBResult

Gets the unmarshalled object created by the transformation.

getResult() - Method in class javax.xml.soap.SAAJResult

getResultCode() - Method in class javax.naming.ldap.SortResponseControl

Retrieves the LDAP result code of the sort operation.

getResultSet() - Method in interface java.sql.Array

Retrieves a result set that contains the elements of the SQL ARRAY value designated by this Array object.

getResultSet(Map<String, Class<?>>) - Method in interface java.sql.Array

Retrieves a result set that contains the elements of the SQL ARRAY value designated by this Array object.

getResultSet(long, int) - Method in interface java.sql.Array

Retrieves a result set holding the elements of the subarray that starts at index index and contains up to count successive elements.

getResultSet(long, int, Map<String, Class<?>>) - Method in interface java.sql.Array

Retrieves a result set holding the elements of the subarray that starts at index index and contains up to count successive elements.

getResultSet() - Method in interface java.sql.Statement

Retrieves the current result as a ResultSet object.

getResultSet(long, int) - Method in class javax.sql.rowset.serial.SerialArray

Retrieves a ResultSet object holding the elements of the subarray that starts at index index and contains up to count successive elements.

getResultSet(Map<String, Class<?>>) - Method in class javax.sql.rowset.serial.SerialArray

Retrieves a ResultSet object that contains all of the elements of the SQL ARRAY value represented by this SerialArray object.

getResultSet() - Method in class javax.sql.rowset.serial.SerialArray

Retrieves a ResultSet object that contains all of the elements in the ARRAY value that this SerialArray object represents.

getResultSet(long, int, Map<String, Class<?>>) - Method in class javax.sql.rowset.serial.SerialArray

Retrieves a result set holding the elements of the subarray that starts at Retrieves a ResultSet object that contains a subarray of the elements in this SerialArray object, starting at index index and containing up to count successive elements.

getResultSetConcurrency() - Method in interface java.sql.Statement

Retrieves the result set concurrency for ResultSet objects generated by this Statement object.

getResultSetHoldability() - Method in interface java.sql.DatabaseMetaData

Retrieves this database's default holdability for ResultSet objects.

getResultSetHoldability() - Method in interface java.sql.Statement

Retrieves the result set holdability for ResultSet objects generated by this Statement object.

getResultSetType() - Method in interface java.sql.Statement

Retrieves the result set type for ResultSet objects generated by this Statement object.

getResultSize() - Method in class javax.naming.ldap.PagedResultsResponseControl

Retrieves (an estimate of) the number of entries in the search result.

getResultStream(boolean) - Method in interface java.rmi.server.RemoteCall

Deprecated.
no replacement

getReturningAttributes() - Method in class javax.naming.directory.SearchControls

Retrieves the attributes that will be returned as part of the search.

getReturningObjFlag() - Method in class javax.naming.directory.SearchControls

Determines whether objects will be returned as part of the result.

getReturnOpenType() - Method in interface javax.management.openmbean.OpenMBeanOperationInfo

Returns the open type of the values returned by the operation described by this OpenMBeanOperationInfo instance.

getReturnOpenType() - Method in class javax.management.openmbean.OpenMBeanOperationInfoSupport

Returns the open type of the values returned by the operation described by this OpenMBeanOperationInfo instance.

getReturnType() - Method in class java.lang.reflect.Method

Returns a Class object that represents the formal return type of the method represented by this Method object.

getReturnType() - Method in interface javax.lang.model.element.ExecutableElement

Returns the return type of this executable.

getReturnType() - Method in interface javax.lang.model.type.ExecutableType

Returns the return type of this executable.

getReturnType() - Method in class javax.management.MBeanOperationInfo

Returns the type of the method's return value.

getReturnType() - Method in interface javax.management.openmbean.OpenMBeanOperationInfo

Returns the fully qualified Java class name of the values returned by the operation described by this OpenMBeanOperationInfo instance.

getReuseAddress() - Method in class java.net.DatagramSocket

Tests if SO_REUSEADDR is enabled.

getReuseAddress() - Method in class java.net.ServerSocket

Tests if SO_REUSEADDR is enabled.

getReuseAddress() - Method in class java.net.Socket

Tests if SO_REUSEADDR is enabled.

getRevocationChecker() - Method in class java.security.cert.CertPathBuilder

Returns a CertPathChecker that the encapsulated CertPathBuilderSpi implementation uses to check the revocation status of certificates.

getRevocationChecker() - Method in class java.security.cert.CertPathValidator

Returns a CertPathChecker that the encapsulated CertPathValidatorSpi implementation uses to check the revocation status of certificates.

getRevocationDate() - Method in exception java.security.cert.CertificateRevokedException

Returns the date on which the certificate was revoked.

getRevocationDate() - Method in class java.security.cert.X509CRLEntry

Gets the revocation date from this X509CRLEntry, the revocationDate.

getRevocationReason() - Method in exception java.security.cert.CertificateRevokedException

Returns the reason the certificate was revoked.

getRevocationReason() - Method in class java.security.cert.X509CRLEntry

Returns the reason the certificate has been revoked, as specified in the Reason Code extension of this CRL entry.

getRevokedCertificate(BigInteger) - Method in class java.security.cert.X509CRL

Gets the CRL entry, if any, with the given certificate serialNumber.

getRevokedCertificate(X509Certificate) - Method in class java.security.cert.X509CRL

Get the CRL entry, if any, for the given certificate.

getRevokedCertificates() - Method in class java.security.cert.X509CRL

Gets all the entries from this CRL.

getRGB() - Method in class java.awt.Color

Returns the RGB value representing the color in the default sRGB ColorModel.

getRGB(int, int) - Method in class java.awt.image.BufferedImage

Returns an integer pixel in the default RGB color model (TYPE_INT_ARGB) and default sRGB colorspace.

getRGB(int, int, int, int, int[], int, int) - Method in class java.awt.image.BufferedImage

Returns an array of integer pixels in the default RGB color model (TYPE_INT_ARGB) and default sRGB color space, from a portion of the image data.

getRGB(int) - Method in class java.awt.image.ColorModel

Returns the color/alpha components of the pixel in the default RGB color model format.

getRGB(Object) - Method in class java.awt.image.ColorModel

Returns the color/alpha components for the specified pixel in the default RGB color model format.

getRGB(int) - Method in class java.awt.image.ComponentColorModel

Returns the color/alpha components of the pixel in the default RGB color model format.

getRGB(Object) - Method in class java.awt.image.ComponentColorModel

Returns the color/alpha components for the specified pixel in the default RGB color model format.

getRGB(int) - Method in class java.awt.image.DirectColorModel

Returns the color/alpha components of the pixel in the default RGB color model format.

getRGB(Object) - Method in class java.awt.image.DirectColorModel

Returns the color/alpha components for the specified pixel in the default RGB color model format.

getRGB(int) - Method in class java.awt.image.IndexColorModel

Returns the color/alpha components of the pixel in the default RGB color model format.

getRGBColorComponents(float[]) - Method in class java.awt.Color

Returns a float array containing only the color components of the Color, in the default sRGB color space.

getRGBComponents(float[]) - Method in class java.awt.Color

Returns a float array containing the color and alpha components of the Color, as represented in the default sRGB color space.

getRGBdefault() - Static method in class java.awt.image.ColorModel

Returns a DirectColorModel that describes the default format for integer RGB values used in many of the methods in the AWT image interfaces for the convenience of the programmer.

getRGBs(int[]) - Method in class java.awt.image.IndexColorModel

Converts data for each index from the color and alpha component arrays to an int in the default RGB ColorModel format and copies the resulting 32-bit ARGB values into the specified array.

getRightChildIndent() - Method in class javax.swing.plaf.basic.BasicTreeUI

getRightComponent() - Method in class javax.swing.JSplitPane

Returns the component to the right (or below) the divider.

getRightIndent(AttributeSet) - Static method in class javax.swing.text.StyleConstants

Gets the right indent setting.

getRightInset() - Method in class javax.swing.text.AsyncBoxView

Get the right part of the margin around the view.

getRightInset() - Method in class javax.swing.text.CompositeView

Gets the right inset.

getRMIRepositoryID(Class) - Method in interface javax.rmi.CORBA.ValueHandler

Returns the CORBA RepositoryId for the given Java class.

getRole(String) - Method in interface javax.management.relation.Relation

Retrieves role value for given role name.

getRole(String, String) - Method in class javax.management.relation.RelationService

Retrieves role value for given role name in given relation.

getRole(String, String) - Method in interface javax.management.relation.RelationServiceMBean

Retrieves role value for given role name in given relation.

getRole(String) - Method in class javax.management.relation.RelationSupport

Retrieves role value for given role name.

getRole() - Method in interface javax.xml.soap.SOAPHeaderElement

Returns the value of the Role attribute of this SOAPHeaderElement.

getRoleCardinality(String) - Method in interface javax.management.relation.Relation

Returns the number of MBeans currently referenced in the given role.

getRoleCardinality(String, String) - Method in class javax.management.relation.RelationService

Retrieves the number of MBeans currently referenced in the given role.

getRoleCardinality(String, String) - Method in interface javax.management.relation.RelationServiceMBean

Retrieves the number of MBeans currently referenced in the given role.

getRoleCardinality(String) - Method in class javax.management.relation.RelationSupport

Returns the number of MBeans currently referenced in the given role.

getRoleInfo(String, String) - Method in class javax.management.relation.RelationService

Retrieves role info for given role name of a given relation type.

getRoleInfo(String, String) - Method in interface javax.management.relation.RelationServiceMBean

Retrieves role info for given role of a given relation type.

getRoleInfo(String) - Method in interface javax.management.relation.RelationType

Returns the role info (RoleInfo object) for the given role info name (null if not found).

getRoleInfo(String) - Method in class javax.management.relation.RelationTypeSupport

Returns the role info (RoleInfo object) for the given role info name (null if not found).

getRoleInfos(String) - Method in class javax.management.relation.RelationService

Retrieves list of role infos (RoleInfo objects) of a given relation type.

getRoleInfos(String) - Method in interface javax.management.relation.RelationServiceMBean

Retrieves list of role infos (RoleInfo objects) of a given relation type.

getRoleInfos() - Method in interface javax.management.relation.RelationType

Returns the list of role definitions (ArrayList of RoleInfo objects).

getRoleInfos() - Method in class javax.management.relation.RelationTypeSupport

Returns the list of role definitions (ArrayList of RoleInfo objects).

getRoleName() - Method in class javax.management.relation.RelationNotification

Returns name of updated role of updated relation (only for role update).

getRoleName() - Method in class javax.management.relation.Role

Retrieves role name.

getRoleName() - Method in class javax.management.relation.RoleUnresolved

Retrieves role name.

getRoles(String[]) - Method in interface javax.management.relation.Relation

Retrieves values of roles with given names.

getRoles(String, String[]) - Method in class javax.management.relation.RelationService

Retrieves values of roles with given names in given relation.

getRoles(String, String[]) - Method in interface javax.management.relation.RelationServiceMBean

Retrieves values of roles with given names in given relation.

getRoles(String[]) - Method in class javax.management.relation.RelationSupport

Retrieves values of roles with given names.

getRoles() - Method in class javax.management.relation.RoleResult

Retrieves list of roles successfully accessed.

getRoles() - Method in interface javax.xml.ws.handler.soap.SOAPMessageContext

Gets the SOAP actor roles associated with an execution of the handler chain.

getRoles() - Method in interface javax.xml.ws.soap.SOAPBinding

Gets the roles played by the SOAP binding instance.

getRolesUnresolved() - Method in class javax.management.relation.RoleResult

Retrieves list of roles unsuccessfully accessed.

getRoleValue() - Method in class javax.management.relation.Role

Retrieves role value.

getRoleValue() - Method in class javax.management.relation.RoleUnresolved

Retrieves role value.

getRolloverBorder(AbstractButton) - Method in class javax.swing.plaf.basic.BasicToolBarUI

Returns a rollover border for the button.

getRolloverColumn() - Method in class javax.swing.plaf.basic.BasicTableHeaderUI

Returns the index of the column header over which the mouse currently is.

getRolloverIcon() - Method in class javax.swing.AbstractButton

Returns the rollover icon for the button.

getRolloverSelectedIcon() - Method in class javax.swing.AbstractButton

Returns the rollover selection icon for the button.

getRolloverTab() - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

Returns the tab the mouse is currently over, or -1 if the mouse is no longer over any tab.

getRoot() - Method in interface java.nio.file.Path

Returns the root component of this path as a Path object, or null if this path does not have a root component.

getRoot() - Method in class java.util.concurrent.CountedCompleter

Returns the root of the current computation; i.e., this task if it has no completer, else its completer's root.

getRoot() - Method in class java.util.concurrent.Phaser

Returns the root ancestor of this phaser, which is the same as this phaser if it has no parent.

getRoot(Component) - Static method in class javax.swing.SwingUtilities

Returns the root component for the current component tree.

getRoot() - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns the root of the tree that contains this node.

getRoot() - Method in class javax.swing.tree.DefaultTreeModel

Returns the root of the tree.

getRoot() - Method in interface javax.swing.tree.TreeModel

Returns the root of the tree.

getRootCause() - Method in exception javax.naming.NamingException

Retrieves the root cause of this NamingException, if any.

getRootDirectories() - Method in class java.nio.file.FileSystem

Returns an object to iterate over the paths of the root directories.

getRootElement() - Method in class javax.swing.text.DefaultStyledDocument.ElementBuffer

Gets the root element.

getRootElements() - Method in interface javax.annotation.processing.RoundEnvironment

Returns the root elements for annotation processing generated by the prior round.

getRootElements() - Method in class javax.swing.text.AbstractDocument

Gets all root elements defined.

getRootElements() - Method in interface javax.swing.text.Document

Returns all of the root elements that are defined.

getRootFrame() - Static method in class javax.swing.JOptionPane

Returns the Frame to use for the class methods in which a frame is not provided.

getRootName() - Method in interface javax.imageio.metadata.IIOMetadataFormat

Returns the name of the root element of the format.

getRootName() - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

getRootPane() - Method in class javax.swing.JApplet

Returns the rootPane object for this applet.

getRootPane() - Method in class javax.swing.JComponent

Returns the JRootPane ancestor for this component.

getRootPane() - Method in class javax.swing.JDialog

Returns the rootPane object for this dialog.

getRootPane() - Method in class javax.swing.JFrame

Returns the rootPane object for this frame.

getRootPane() - Method in class javax.swing.JInternalFrame

Returns the rootPane object for this internal frame.

getRootPane() - Method in class javax.swing.JWindow

Returns the rootPane object for this window.

getRootPane() - Method in interface javax.swing.RootPaneContainer

Return this component's single JRootPane child.

getRootPane(Component) - Static method in class javax.swing.SwingUtilities

If c is a JRootPane descendant return its JRootPane ancestor.

getRoots() - Method in class javax.swing.filechooser.FileSystemView

Returns all root partitions on this system.

getRootView(JTextComponent) - Method in class javax.swing.plaf.basic.BasicTextUI

Fetches a View with the allocation of the associated text component (i.e.

getRootView(JTextComponent) - Method in class javax.swing.plaf.multi.MultiTextUI

Invokes the getRootView method on each UI handled by this object.

getRootView(JTextComponent) - Method in class javax.swing.plaf.TextUI

Fetches a View with the allocation of the associated text component (i.e.

getRotateInstance(double) - Static method in class java.awt.geom.AffineTransform

Returns a transform representing a rotation transformation.

getRotateInstance(double, double, double) - Static method in class java.awt.geom.AffineTransform

Returns a transform that rotates coordinates around an anchor point.

getRotateInstance(double, double) - Static method in class java.awt.geom.AffineTransform

Returns a transform that rotates coordinates according to a rotation vector.

getRotateInstance(double, double, double, double) - Static method in class java.awt.geom.AffineTransform

Returns a transform that rotates coordinates around an anchor point according to a rotation vector.

getRoundedCorners() - Method in class javax.swing.border.LineBorder

Returns whether this border will be drawn with rounded corners.

getRoundingMode() - Method in class java.math.MathContext

Returns the roundingMode setting.

getRoundingMode() - Method in class java.text.DecimalFormat

Gets the RoundingMode used in this DecimalFormat.

getRoundingMode() - Method in class java.text.NumberFormat

Gets the RoundingMode used in this NumberFormat.

getRounds() - Method in class javax.crypto.spec.RC5ParameterSpec

Returns the number of rounds.

getRow() - Method in interface java.sql.ResultSet

Retrieves the current row number.

getRow() - Method in class javax.swing.JTable.DropLocation

Returns the row index where a dropped item should be placed in the table.

getRowBounds(int) - Method in class javax.swing.JTree

Returns the Rectangle that the node at the specified row is drawn in.

getRowCount() - Method in class javax.swing.DefaultRowSorter.ModelWrapper

Returns the number of rows in the model.

getRowCount() - Method in class javax.swing.JTable

Returns the number of rows that can be shown in the JTable, given unlimited space.

getRowCount() - Method in class javax.swing.JTree

Returns the number of viewable nodes.

getRowCount(JTree) - Method in class javax.swing.plaf.basic.BasicTreeUI

Returns the number of rows that are being displayed.

getRowCount(JTree) - Method in class javax.swing.plaf.multi.MultiTreeUI

Invokes the getRowCount method on each UI handled by this object.

getRowCount(JTree) - Method in class javax.swing.plaf.TreeUI

Returns the number of rows that are being displayed.

getRowCount() - Method in class javax.swing.table.DefaultTableModel

Returns the number of rows in this data table.

getRowCount() - Method in interface javax.swing.table.TableModel

Returns the number of rows in the model.

getRowCount() - Method in class javax.swing.text.TableView.TableCell

Deprecated.

Gets the number of rows this cell spans (that is, the grid height).

getRowCount() - Method in class javax.swing.tree.AbstractLayoutCache

Number of rows being displayed.

getRowCount() - Method in class javax.swing.tree.FixedHeightLayoutCache

Returns the number of visible rows.

getRowCount() - Method in class javax.swing.tree.VariableHeightLayoutCache

Returns the number of visible rows.

getRowEnd(JTextComponent, int) - Static method in class javax.swing.text.Utilities

Determines the ending row model position of the row that contains the specified model position.

getRowFilter() - Method in class javax.swing.DefaultRowSorter

Returns the filter that determines which rows, if any, should be hidden from view.

getRowForLocation(int, int) - Method in class javax.swing.JTree

Returns the row for the specified location.

getRowForPath(TreePath) - Method in class javax.swing.JTree

Returns the row that displays the node identified by the specified path.

getRowForPath(JTree, TreePath) - Method in class javax.swing.plaf.basic.BasicTreeUI

Returns the row that the last item identified in path is visible at.

getRowForPath(JTree, TreePath) - Method in class javax.swing.plaf.multi.MultiTreeUI

Invokes the getRowForPath method on each UI handled by this object.

getRowForPath(JTree, TreePath) - Method in class javax.swing.plaf.TreeUI

Returns the row that the last item identified in path is visible at.

getRowForPath(TreePath) - Method in class javax.swing.tree.AbstractLayoutCache

Returns the row that the last item identified in path is visible at.

getRowForPath(TreePath) - Method in class javax.swing.tree.FixedHeightLayoutCache

Returns the row that the last item identified in path is visible at.

getRowForPath(TreePath) - Method in class javax.swing.tree.VariableHeightLayoutCache

Returns the row where the last item identified in path is visible.

getRowHeader() - Method in class javax.swing.JScrollPane

Returns the row header.

getRowHeader() - Method in class javax.swing.ScrollPaneLayout

Returns the JViewport object that is the row header.

getRowHeight() - Method in class javax.swing.JTable

Returns the height of a table row, in pixels.

getRowHeight(int) - Method in class javax.swing.JTable

Returns the height, in pixels, of the cells in row.

getRowHeight() - Method in class javax.swing.JTextArea

Defines the meaning of the height of a row.

getRowHeight() - Method in class javax.swing.JTree

Returns the height of each row.

getRowHeight(int) - Method in class javax.swing.plaf.basic.BasicListUI

Returns the height of the specified row based on the current layout.

getRowHeight() - Method in class javax.swing.plaf.basic.BasicTreeUI

getRowHeight() - Method in class javax.swing.tree.AbstractLayoutCache

Returns the height of each row.

getRowId(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC ROWID parameter as a java.sql.RowId object.

getRowId(String) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC ROWID parameter as a java.sql.RowId object.

getRowId(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.sql.RowId object in the Java programming language.

getRowId(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.sql.RowId object in the Java programming language.

getRowIdLifetime() - Method in interface java.sql.DatabaseMetaData

Indicates whether or not this data source supports the SQL ROWID type, and if so the lifetime for which a RowId object remains valid.

getRowMapper() - Method in class javax.swing.tree.DefaultTreeSelectionModel

Returns the RowMapper instance that is able to map a TreePath to a row.

getRowMapper() - Method in interface javax.swing.tree.TreeSelectionModel

Returns the RowMapper instance that is able to map a TreePath to a row.

getRowMargin() - Method in class javax.swing.JTable

Gets the amount of empty space, in pixels, between cells.

getRows() - Method in class java.awt.GridLayout

Gets the number of rows in this layout.

getRows() - Method in class java.awt.List

Gets the number of visible lines in this list.

getRows() - Method in class java.awt.TextArea

Returns the number of rows in the text area.

getRows() - Method in class javax.swing.JTextArea

Returns the number of rows in the TextArea.

getRowSelectionAllowed() - Method in class javax.swing.JTable

Returns true if rows can be selected.

getRowSetNames() - Method in interface javax.sql.rowset.JoinRowSet

Returns a String array containing the names of the RowSet objects added to this JoinRowSet object.

getRowSetReader() - Method in class javax.sql.rowset.spi.SyncProvider

Returns a javax.sql.RowSetReader object, which can be used to populate a RowSet object with data.

getRowSets() - Method in interface javax.sql.rowset.JoinRowSet

Returns a Collection object containing the RowSet objects that have been added to this JoinRowSet object.

getRowSetWarnings() - Method in interface javax.sql.rowset.CachedRowSet

Retrieves the first warning reported by calls on this RowSet object.

getRowSetWarnings() - Method in interface javax.sql.rowset.JdbcRowSet

Retrieves the first warning reported by calls on this JdbcRowSet object.

getRowSetWriter() - Method in class javax.sql.rowset.spi.SyncProvider

Returns a javax.sql.RowSetWriter object, which can be used to write a RowSet object's data back to the underlying data source.

getRowsForPaths(TreePath[]) - Method in class javax.swing.tree.AbstractLayoutCache

Returns the rows that the TreePath instances in path are being displayed at.

getRowsForPaths(TreePath[]) - Method in interface javax.swing.tree.RowMapper

Returns the rows that the TreePath instances in path are being displayed at.

getRowSorter() - Method in class javax.swing.JTable

Returns the object responsible for sorting.

getRowStart(JTextComponent, int) - Static method in class javax.swing.text.Utilities

Determines the starting row model position of the row that contains the specified model position.

getRowType() - Method in class javax.management.openmbean.TabularType

Returns the type of the row elements of tabular data values described by this TabularType instance.

getRowX(int, int) - Method in class javax.swing.plaf.basic.BasicTreeUI

Returns the location, along the x-axis, to render a particular row at.

getRowX(int, int) - Method in class javax.swing.plaf.basic.BasicTreeUI.NodeDimensionsHandler

getRowX(int, int) - Method in class javax.swing.plaf.synth.SynthTreeUI

Returns the location, along the x-axis, to render a particular row at.

getRSB() - Method in class java.awt.font.GlyphMetrics

Returns the right (bottom) side bearing of the glyph.

getRule() - Method in class java.awt.AlphaComposite

Returns the compositing rule of this AlphaComposite.

getRule(HTML.Tag, Element) - Method in class javax.swing.text.html.StyleSheet

Fetches the style to use to render the given type of HTML tag.

getRule(String) - Method in class javax.swing.text.html.StyleSheet

Fetches the rule that best matches the selector given in string form.

getRules() - Method in class java.text.RuleBasedCollator

Gets the table-based rules for the collation object.

getRules(String, boolean) - Static method in class java.time.zone.ZoneRulesProvider

Gets the rules for the zone ID.

getRules() - Method in class java.time.ZoneId

Gets the time-zone rules for this ID allowing calculations to be performed.

getRules() - Method in class java.time.ZoneOffset

Gets the associated time-zone rules.

getRunCount() - Method in class java.text.Bidi

Return the number of level runs.

getRunForTab(int, int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getRunLevel(int) - Method in class java.text.Bidi

Return the level of the nth logical run in this line.

getRunLimit() - Method in interface java.text.AttributedCharacterIterator

Returns the index of the first character following the run with respect to all attributes containing the current character.

getRunLimit(AttributedCharacterIterator.Attribute) - Method in interface java.text.AttributedCharacterIterator

Returns the index of the first character following the run with respect to the given attribute containing the current character.

getRunLimit(Set<? extends AttributedCharacterIterator.Attribute>) - Method in interface java.text.AttributedCharacterIterator

Returns the index of the first character following the run with respect to the given attributes containing the current character.

getRunLimit(int) - Method in class java.text.Bidi

Return the index of the character past the end of the nth logical run in this line, as an offset from the start of the line.

getRunningThreadCount() - Method in class java.util.concurrent.ForkJoinPool

Returns an estimate of the number of worker threads that are not blocked waiting to join tasks or for other managed synchronization.

getRunStart() - Method in interface java.text.AttributedCharacterIterator

Returns the index of the first character of the run with respect to all attributes containing the current character.

getRunStart(AttributedCharacterIterator.Attribute) - Method in interface java.text.AttributedCharacterIterator

Returns the index of the first character of the run with respect to the given attribute containing the current character.

getRunStart(Set<? extends AttributedCharacterIterator.Attribute>) - Method in interface java.text.AttributedCharacterIterator

Returns the index of the first character of the run with respect to the given attributes containing the current character.

getRunStart(int) - Method in class java.text.Bidi

Return the index of the character at the start of the nth logical run in this line, as an offset from the start of the line.

getRuntime() - Static method in class java.lang.Runtime

Returns the runtime object associated with the current Java application.

getRunTimeCodeBase() - Method in interface javax.rmi.CORBA.ValueHandler

Returns the CodeBase for this ValueHandler.

getRuntimeMXBean() - Static method in class java.lang.management.ManagementFactory

Returns the managed bean for the runtime system of the Java virtual machine.

getS() - Method in interface java.security.interfaces.ECPrivateKey

Returns the private value S.

getS() - Method in class java.security.spec.ECPrivateKeySpec

Returns the private value S.

getSalt() - Method in interface javax.crypto.interfaces.PBEKey

Returns the salt or null if not specified.

getSalt() - Method in class javax.crypto.spec.PBEKeySpec

Returns a copy of the salt or null if not specified.

getSalt() - Method in class javax.crypto.spec.PBEParameterSpec

Returns the salt.

getSaltLength() - Method in class java.security.spec.PSSParameterSpec

Returns the salt length in bits.

getSample(int, int, int, DataBuffer) - Method in class java.awt.image.BandedSampleModel

Returns as int the sample in a specified band for the pixel located at (x,y).

getSample(int, int, int, DataBuffer) - Method in class java.awt.image.ComponentSampleModel

Returns as int the sample in a specified band for the pixel located at (x,y).

getSample(int, int, int, DataBuffer) - Method in class java.awt.image.MultiPixelPackedSampleModel

Returns as int the sample in a specified band for the pixel located at (x, y).

getSample(int, int, int) - Method in class java.awt.image.Raster

Returns the sample in a specified band for the pixel located at (x,y) as an int.

getSample(int, int, int, DataBuffer) - Method in class java.awt.image.SampleModel

Returns the sample in a specified band for the pixel located at (x,y) as an int.

getSample(int, int, int, DataBuffer) - Method in class java.awt.image.SinglePixelPackedSampleModel

Returns as int the sample in a specified band for the pixel located at (x,y).

getSampleDouble(int, int, int, DataBuffer) - Method in class java.awt.image.BandedSampleModel

Returns the sample in a specified band for a pixel located at (x,y) as a double.

getSampleDouble(int, int, int, DataBuffer) - Method in class java.awt.image.ComponentSampleModel

Returns the sample in a specified band for a pixel located at (x,y) as a double.

getSampleDouble(int, int, int) - Method in class java.awt.image.Raster

Returns the sample in a specified band for a pixel located at (x,y) as a double.

getSampleDouble(int, int, int, DataBuffer) - Method in class java.awt.image.SampleModel

Returns the sample in a specified band for a pixel located at (x,y) as a double.

getSampleFloat(int, int, int, DataBuffer) - Method in class java.awt.image.BandedSampleModel

Returns the sample in a specified band for the pixel located at (x,y) as a float.

getSampleFloat(int, int, int, DataBuffer) - Method in class java.awt.image.ComponentSampleModel

Returns the sample in a specified band for the pixel located at (x,y) as a float.

getSampleFloat(int, int, int) - Method in class java.awt.image.Raster

Returns the sample in a specified band for the pixel located at (x,y) as a float.

getSampleFloat(int, int, int, DataBuffer) - Method in class java.awt.image.SampleModel

Returns the sample in a specified band for the pixel located at (x,y) as a float.

getSampleModel() - Method in class java.awt.image.BufferedImage

Returns the SampleModel associated with this BufferedImage.

getSampleModel() - Method in class java.awt.image.Raster

Returns the SampleModel that describes the layout of the image data.

getSampleModel() - Method in interface java.awt.image.RenderedImage

Returns the SampleModel associated with this image.

getSampleModel() - Method in class javax.imageio.ImageTypeSpecifier

Returns a SampleModel based on the settings encapsulated within this object.

getSampleModel(int, int) - Method in class javax.imageio.ImageTypeSpecifier

Returns a SampleModel based on the settings encapsulated within this object.

getSampleModelTranslateX() - Method in class java.awt.image.Raster

Returns the X translation from the coordinate system of the SampleModel to that of the Raster.

getSampleModelTranslateY() - Method in class java.awt.image.Raster

Returns the Y translation from the coordinate system of the SampleModel to that of the Raster.

getSampleRate() - Method in class javax.sound.sampled.AudioFormat

Obtains the sample rate.

getSamples(int, int, int, int, int, int[], DataBuffer) - Method in class java.awt.image.BandedSampleModel

Returns the samples in a specified band for the specified rectangle of pixels in an int array, one sample per data array element.

getSamples(int, int, int, int, int, int[], DataBuffer) - Method in class java.awt.image.ComponentSampleModel

Returns the samples in a specified band for the specified rectangle of pixels in an int array, one sample per data array element.

getSamples(int, int, int, int, int, int[]) - Method in class java.awt.image.Raster

Returns the samples for a specified band for the specified rectangle of pixels in an int array, one sample per array element.

getSamples(int, int, int, int, int, float[]) - Method in class java.awt.image.Raster

Returns the samples for a specified band for the specified rectangle of pixels in a float array, one sample per array element.

getSamples(int, int, int, int, int, double[]) - Method in class java.awt.image.Raster

Returns the samples for a specified band for a specified rectangle of pixels in a double array, one sample per array element.

getSamples(int, int, int, int, int, int[], DataBuffer) - Method in class java.awt.image.SampleModel

Returns the samples for a specified band for the specified rectangle of pixels in an int array, one sample per array element.

getSamples(int, int, int, int, int, float[], DataBuffer) - Method in class java.awt.image.SampleModel

Returns the samples for a specified band for the specified rectangle of pixels in a float array, one sample per array element.

getSamples(int, int, int, int, int, double[], DataBuffer) - Method in class java.awt.image.SampleModel

Returns the samples for a specified band for a specified rectangle of pixels in a double array, one sample per array element.

getSamples(int, int, int, int, int, int[], DataBuffer) - Method in class java.awt.image.SinglePixelPackedSampleModel

Returns the samples for a specified band for the specified rectangle of pixels in an int array, one sample per array element.

getSampleSize() - Method in class java.awt.image.ComponentSampleModel

Returns the number of bits per sample for all bands.

getSampleSize(int) - Method in class java.awt.image.ComponentSampleModel

Returns the number of bits per sample for the specified band.

getSampleSize() - Method in class java.awt.image.MultiPixelPackedSampleModel

Returns the number of bits per sample for all bands.

getSampleSize(int) - Method in class java.awt.image.MultiPixelPackedSampleModel

Returns the number of bits per sample for the specified band.

getSampleSize() - Method in class java.awt.image.SampleModel

Returns the size in bits of samples for all bands.

getSampleSize(int) - Method in class java.awt.image.SampleModel

Returns the size in bits of samples for the specified band.

getSampleSize() - Method in class java.awt.image.SinglePixelPackedSampleModel

Returns the number of bits per sample for all bands.

getSampleSize(int) - Method in class java.awt.image.SinglePixelPackedSampleModel

Returns the number of bits per sample for the specified band.

getSampleSizeInBits() - Method in class javax.sound.sampled.AudioFormat

Obtains the size of a sample.

getSaslClientFactories() - Static method in class javax.security.sasl.Sasl

Gets an enumeration of known factories for producing SaslClient.

getSaslServerFactories() - Static method in class javax.security.sasl.Sasl

Gets an enumeration of known factories for producing SaslServer.

getSavepointId() - Method in interface java.sql.Savepoint

Retrieves the generated ID for the savepoint that this Savepoint object represents.

getSavepointName() - Method in interface java.sql.Savepoint

Retrieves the name of the savepoint that this Savepoint object represents.

getScale(int) - Method in interface java.sql.ParameterMetaData

Retrieves the designated parameter's number of digits to right of the decimal point.

getScale(int) - Method in interface java.sql.ResultSetMetaData

Gets the designated column's number of digits to right of the decimal point.

getScale(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Retrieves the number of digits to the right of the decimal point for values stored in the designated column.

getScaledInstance(int, int, int) - Method in class java.awt.Image

Creates a scaled version of this image.

getScaledInstance(float, boolean) - Method in class javax.imageio.plugins.jpeg.JPEGQTable

Returns a new quantization table where the values are multiplied by scaleFactor and then clamped to the range 1..32767 (or to 1..255 if forceBaseline is true).

getScaleFactors(float[]) - Method in class java.awt.image.RescaleOp

Returns the scale factors in the given array.

getScaleInstance(double, double) - Static method in class java.awt.geom.AffineTransform

Returns a transform representing a scaling transformation.

getScaleX() - Method in class java.awt.geom.AffineTransform

Returns the X coordinate scaling element (m00) of the 3x3 affine transformation matrix.

getScaleY() - Method in class java.awt.geom.AffineTransform

Returns the Y coordinate scaling element (m11) of the 3x3 affine transformation matrix.

getScanlineStride() - Method in class java.awt.image.ComponentSampleModel

Returns the scanline stride of this ComponentSampleModel.

getScanlineStride() - Method in class java.awt.image.MultiPixelPackedSampleModel

Returns the scanline stride.

getScanlineStride() - Method in class java.awt.image.SinglePixelPackedSampleModel

Returns the scanline stride of this SinglePixelPackedSampleModel.

getSchema() - Method in interface java.sql.Connection

Retrieves this Connection object's current schema name.

getSchema(Name) - Method in interface javax.naming.directory.DirContext

Retrieves the schema associated with the named object.

getSchema(String) - Method in interface javax.naming.directory.DirContext

Retrieves the schema associated with the named object.

getSchema(String) - Method in class javax.naming.directory.InitialDirContext

getSchema(Name) - Method in class javax.naming.directory.InitialDirContext

getSchema() - Method in class javax.xml.bind.Binder

Gets the last Schema object (including null) set by the Binder.setSchema(Schema) method.

getSchema() - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

getSchema() - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

getSchema() - Method in interface javax.xml.bind.Marshaller

Get the JAXP 1.3 Schema object being used to perform marshal-time validation.

getSchema() - Method in interface javax.xml.bind.Unmarshaller

Get the JAXP 1.3 Schema object being used to perform unmarshal-time validation.

getSchema() - Method in class javax.xml.parsers.DocumentBuilder

Get a reference to the the Schema being used by the XML processor.

getSchema() - Method in class javax.xml.parsers.DocumentBuilderFactory

Gets the Schema object specified through the DocumentBuilderFactory.setSchema(Schema schema) method.

getSchema() - Method in class javax.xml.parsers.SAXParser

Get a reference to the the Schema being used by the XML processor.

getSchema() - Method in class javax.xml.parsers.SAXParserFactory

Gets the Schema object specified through the SAXParserFactory.setSchema(Schema schema) method.

getSchemaClassDefinition(Name) - Method in interface javax.naming.directory.DirContext

Retrieves a context containing the schema objects of the named object's class definitions.

getSchemaClassDefinition(String) - Method in interface javax.naming.directory.DirContext

Retrieves a context containing the schema objects of the named object's class definitions.

getSchemaClassDefinition(String) - Method in class javax.naming.directory.InitialDirContext

getSchemaClassDefinition(Name) - Method in class javax.naming.directory.InitialDirContext

getSchemaLocation() - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

Convenience method for getting the current schemaLocation.

getSchemaName(int) - Method in interface java.sql.ResultSetMetaData

Get the designated column's table's schema.

getSchemaName(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Retrieves the schema name of the table from which the value in the designated column was derived.

getSchemas() - Method in interface java.sql.DatabaseMetaData

Retrieves the schema names available in this database.

getSchemas(String, String) - Method in interface java.sql.DatabaseMetaData

Retrieves the schema names available in this database.

getSchemaTerm() - Method in interface java.sql.DatabaseMetaData

Retrieves the database vendor's preferred term for "schema".

getSchemaType() - Method in interface javax.xml.stream.events.XMLEvent

This method is provided for implementations to provide optional type information about the associated event.

getSchemaTypeInfo() - Method in class javax.imageio.metadata.IIOMetadataNode

This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.

getSchemaTypeInfo() - Method in interface org.w3c.dom.Attr

The type information associated with this attribute.

getSchemaTypeInfo() - Method in interface org.w3c.dom.Element

The type information associated with this element.

getScheme() - Method in class java.net.URI

Returns the scheme component of this URI.

getScheme() - Method in class java.nio.file.spi.FileSystemProvider

Returns the URI scheme that identifies this provider.

getScheme() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns the name of the scheme used to make this request, for example: http, or https.

getSchemeSpecificPart() - Method in class java.net.URI

Returns the decoded scheme-specific part of this URI.

getScope() - Method in class java.security.Identity

Deprecated.

Returns this identity's scope.

getScope() - Method in class javax.xml.bind.JAXBElement

Returns scope of xml element declaration.

getScope(String) - Method in interface javax.xml.ws.handler.MessageContext

Gets the scope of a property.

getScopedInterface() - Method in class java.net.Inet6Address

Returns the scoped interface, if this instance was created with with a scoped interface.

getScopeId() - Method in class java.net.Inet6Address

Returns the numeric scopeId, if this instance is associated with an interface.

getScopes() - Method in interface javax.script.ScriptContext

Returns immutable List of all the valid values for scope in the ScriptContext.

getScopes() - Method in class javax.script.SimpleScriptContext

Returns immutable List of all the valid values for scope in the ScriptContext.

getScreenDevices() - Method in class java.awt.GraphicsEnvironment

Returns an array of all of the screen GraphicsDevice objects.

getScreenInsets(GraphicsConfiguration) - Method in class java.awt.Toolkit

Gets the insets of the screen.

getScreenResolution() - Method in class java.awt.Toolkit

Returns the screen resolution in dots-per-inch.

getScreenSize() - Method in class java.awt.Toolkit

Gets the size of the screen.

getScreenX() - Method in interface org.w3c.dom.events.MouseEvent

The horizontal coordinate at which the event occurred relative to the origin of the screen coordinate system.

getScreenY() - Method in interface org.w3c.dom.events.MouseEvent

The vertical coordinate at which the event occurred relative to the origin of the screen coordinate system.

getScript() - Method in class java.util.Locale

Returns the script for this locale, which should either be the empty string or an ISO 15924 4-letter script code.

getScriptContext(Bindings) - Method in class javax.script.AbstractScriptEngine

Returns a SimpleScriptContext.

getScriptEngine() - Method in interface javax.script.ScriptEngineFactory

Returns an instance of the ScriptEngine associated with this ScriptEngineFactory.

getScrollableBlockIncrement(Rectangle, int, int) - Method in class javax.swing.JLayer

Returns a scroll increment, which is required for components that display logical rows or columns in order to completely expose one block of rows or columns, depending on the value of orientation.

getScrollableBlockIncrement(Rectangle, int, int) - Method in class javax.swing.JList

Returns the distance to scroll to expose the next or previous block.

getScrollableBlockIncrement(Rectangle, int, int) - Method in class javax.swing.JTable

Returns visibleRect.height or visibleRect.width, depending on this table's orientation.

getScrollableBlockIncrement(Rectangle, int, int) - Method in class javax.swing.JTree

Returns the amount for a block increment, which is the height or width of visibleRect, based on orientation.

getScrollableBlockIncrement(Rectangle, int, int) - Method in interface javax.swing.Scrollable

Components that display logical rows or columns should compute the scroll increment that will completely expose one block of rows or columns, depending on the value of orientation.

getScrollableBlockIncrement(Rectangle, int, int) - Method in class javax.swing.text.JTextComponent

Components that display logical rows or columns should compute the scroll increment that will completely expose one block of rows or columns, depending on the value of orientation.

getScrollableTracksViewportHeight() - Method in class javax.swing.JEditorPane

Returns true if a viewport should always force the height of this Scrollable to match the height of the viewport.

getScrollableTracksViewportHeight() - Method in class javax.swing.JLayer

Returns false to indicate that the height of the viewport does not determine the height of the layer, unless the preferred height of the layer is smaller than the height of the viewport.

getScrollableTracksViewportHeight() - Method in class javax.swing.JList

Returns true if this JList is displayed in a JViewport and the viewport is taller than the list's preferred height, or if the layout orientation is VERTICAL_WRAP and visibleRowCount <= 0; otherwise returns false.

getScrollableTracksViewportHeight() - Method in class javax.swing.JTable

Returns false to indicate that the height of the viewport does not determine the height of the table, unless getFillsViewportHeight is true and the preferred height of the table is smaller than the viewport's height.

getScrollableTracksViewportHeight() - Method in class javax.swing.JTree

Returns false to indicate that the height of the viewport does not determine the height of the table, unless the preferred height of the tree is smaller than the viewports height.

getScrollableTracksViewportHeight() - Method in interface javax.swing.Scrollable

Return true if a viewport should always force the height of this Scrollable to match the height of the viewport.

getScrollableTracksViewportHeight() - Method in class javax.swing.text.JTextComponent

Returns true if a viewport should always force the height of this Scrollable to match the height of the viewport.

getScrollableTracksViewportWidth() - Method in class javax.swing.JEditorPane

Returns true if a viewport should always force the width of this Scrollable to match the width of the viewport.

getScrollableTracksViewportWidth() - Method in class javax.swing.JLayer

Returns false to indicate that the width of the viewport does not determine the width of the layer, unless the preferred width of the layer is smaller than the width of the viewport.

getScrollableTracksViewportWidth() - Method in class javax.swing.JList

Returns true if this JList is displayed in a JViewport and the viewport is wider than the list's preferred width, or if the layout orientation is HORIZONTAL_WRAP and visibleRowCount <= 0; otherwise returns false.

getScrollableTracksViewportWidth() - Method in class javax.swing.JTable

Returns false if autoResizeMode is set to AUTO_RESIZE_OFF, which indicates that the width of the viewport does not determine the width of the table.

getScrollableTracksViewportWidth() - Method in class javax.swing.JTextArea

Returns true if a viewport should always force the width of this Scrollable to match the width of the viewport.

getScrollableTracksViewportWidth() - Method in class javax.swing.JTree

Returns false to indicate that the width of the viewport does not determine the width of the table, unless the preferred width of the tree is smaller than the viewports width.

getScrollableTracksViewportWidth() - Method in interface javax.swing.Scrollable

Return true if a viewport should always force the width of this Scrollable to match the width of the viewport.

getScrollableTracksViewportWidth() - Method in class javax.swing.text.JTextComponent

Returns true if a viewport should always force the width of this Scrollable to match the width of the viewport.

getScrollableUnitIncrement(Rectangle, int, int) - Method in class javax.swing.JLayer

Returns a scroll increment, which is required for components that display logical rows or columns in order to completely expose one new row or column, depending on the value of orientation.

getScrollableUnitIncrement(Rectangle, int, int) - Method in class javax.swing.JList

Returns the distance to scroll to expose the next or previous row (for vertical scrolling) or column (for horizontal scrolling).

getScrollableUnitIncrement(Rectangle, int, int) - Method in class javax.swing.JTable

Returns the scroll increment (in pixels) that completely exposes one new row or column (depending on the orientation).

getScrollableUnitIncrement(Rectangle, int, int) - Method in class javax.swing.JTextArea

Components that display logical rows or columns should compute the scroll increment that will completely expose one new row or column, depending on the value of orientation.

getScrollableUnitIncrement(Rectangle, int, int) - Method in class javax.swing.JTree

Returns the amount to increment when scrolling.

getScrollableUnitIncrement(Rectangle, int, int) - Method in interface javax.swing.Scrollable

Components that display logical rows or columns should compute the scroll increment that will completely expose one new row or column, depending on the value of orientation.

getScrollableUnitIncrement(Rectangle, int, int) - Method in class javax.swing.text.JTextComponent

Components that display logical rows or columns should compute the scroll increment that will completely expose one new row or column, depending on the value of orientation.

getScrollAmount() - Method in class java.awt.event.MouseWheelEvent

Returns the number of units that should be scrolled per click of mouse wheel rotation.

getScrollbarDisplayPolicy() - Method in class java.awt.ScrollPane

Returns the display policy for the scrollbars.

getScrollbarVisibility() - Method in class java.awt.TextArea

Returns an enumerated value that indicates which scroll bars the text area uses.

getScrollMode() - Method in class javax.swing.JViewport

Returns the current scrolling mode.

getScrollOffset() - Method in class javax.swing.JTextField

Gets the scroll offset, in pixels.

getScrollPane() - Method in class javax.swing.plaf.basic.BasicTreeUI.ComponentHandler

Returns the JScrollPane housing the JTree, or null if one isn't found.

getScrollPosition() - Method in class java.awt.ScrollPane

Returns the current x,y position within the child which is displayed at the 0,0 location of the scrolled panel's view port.

getScrollsOnExpand() - Method in class javax.swing.JTree

Returns the value of the scrollsOnExpand property.

getScrollType() - Method in class java.awt.event.MouseWheelEvent

Returns the type of scrolling that should take place in response to this event.

getSearchScope() - Method in class javax.naming.directory.SearchControls

Retrieves the search scope of these SearchControls.

getSearchStringEscape() - Method in interface java.sql.DatabaseMetaData

Retrieves the string that can be used to escape wildcard characters.

getSecond() - Method in class java.time.LocalDateTime

Gets the second-of-minute field.

getSecond() - Method in class java.time.LocalTime

Gets the second-of-minute field.

getSecond() - Method in class java.time.OffsetDateTime

Gets the second-of-minute field.

getSecond() - Method in class java.time.OffsetTime

Gets the second-of-minute field.

getSecond() - Method in class java.time.ZonedDateTime

Gets the second-of-minute field.

getSecond() - Method in class javax.xml.datatype.XMLGregorianCalendar

Return seconds or DatatypeConstants.FIELD_UNDEFINED.

getSecondary1() - Method in class javax.swing.plaf.metal.DefaultMetalTheme

Returns the secondary 1 color.

getSecondary1() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the secondary 1 color.

getSecondary1() - Method in class javax.swing.plaf.metal.OceanTheme

Returns the secondary 1 color.

getSecondary2() - Method in class javax.swing.plaf.metal.DefaultMetalTheme

Returns the secondary 2 color.

getSecondary2() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the secondary 2 color.

getSecondary2() - Method in class javax.swing.plaf.metal.OceanTheme

Returns the secondary 2 color.

getSecondary3() - Method in class javax.swing.plaf.metal.DefaultMetalTheme

Returns the secondary 3 color.

getSecondary3() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the secondary 3 color.

getSecondary3() - Method in class javax.swing.plaf.metal.OceanTheme

Returns the secondary 3 color.

getSeconds() - Method in class java.sql.Date

Deprecated.

getSeconds() - Method in class java.time.Duration

Gets the number of seconds in this duration.

getSeconds() - Method in class java.util.Date

Deprecated.
As of JDK version 1.1, replaced by Calendar.get(Calendar.SECOND).

getSeconds() - Method in class javax.xml.datatype.Duration

Obtains the value of the SECONDS field as an integer value, or 0 if not present.

getSecretKey() - Method in class java.security.KeyStore.SecretKeyEntry

Gets the SecretKey from this entry.

getSecure() - Method in class java.net.HttpCookie

Returns true if sending this cookie should be restricted to a secure protocol, or false if the it can be sent using any protocol.

getSecurityContext() - Method in class java.lang.SecurityManager

Creates an object that encapsulates the current execution environment.

getSecurityContext(ClassLoader) - Method in interface java.rmi.server.LoaderHandler

Deprecated.
no replacement

getSecurityContext(ClassLoader) - Static method in class java.rmi.server.RMIClassLoader

Deprecated.
no replacement. As of the Java 2 platform v1.2, RMI no longer uses this method to obtain a class loader's security context.

getSecurityManager() - Static method in class java.lang.System

Gets the system security interface.

getSeed(int) - Static method in class java.security.SecureRandom

Returns the given number of seed bytes, computed using the seed generation algorithm that this class uses to seed itself.

getSeed() - Method in class java.security.spec.EllipticCurve

Returns the seeding bytes seed used during curve generation.

getSeedLength() - Method in class java.security.spec.DSAGenParameterSpec

Returns the desired length of the domain parameter seed in bits.

getSelectColor() - Method in class javax.swing.plaf.metal.MetalButtonUI

getSelectColor() - Method in class javax.swing.plaf.metal.MetalRadioButtonUI

getSelectColor() - Method in class javax.swing.plaf.metal.MetalToggleButtonUI

getSelectedAccessibleColumns() - Method in interface javax.accessibility.AccessibleTable

Returns the selected columns in a table.

getSelectedAccessibleColumns() - Method in class javax.swing.JTable.AccessibleJTable

Returns the selected columns in a table.

getSelectedAccessibleRows() - Method in interface javax.accessibility.AccessibleTable

Returns the selected rows in a table.

getSelectedAccessibleRows() - Method in class javax.swing.JTable.AccessibleJTable

Returns the selected rows in a table.

getSelectedCheckbox() - Method in class java.awt.CheckboxGroup

Gets the current choice from this check box group.

getSelectedColor() - Method in interface javax.swing.colorchooser.ColorSelectionModel

Returns the selected Color which should be non-null.

getSelectedColor() - Method in class javax.swing.colorchooser.DefaultColorSelectionModel

Returns the selected Color which should be non-null.

getSelectedColumn() - Method in class javax.swing.JTable

Returns the index of the first selected column, -1 if no column is selected.

getSelectedColumnCount() - Method in class javax.swing.JTable

Returns the number of selected columns.

getSelectedColumnCount() - Method in class javax.swing.table.DefaultTableColumnModel

Returns the number of columns selected.

getSelectedColumnCount() - Method in interface javax.swing.table.TableColumnModel

Returns the number of selected columns.

getSelectedColumns() - Method in class javax.swing.JTable

Returns the indices of all selected columns.

getSelectedColumns() - Method in class javax.swing.table.DefaultTableColumnModel

Returns an array of selected columns.

getSelectedColumns() - Method in interface javax.swing.table.TableColumnModel

Returns an array of indicies of all selected columns.

getSelectedComponent() - Method in class javax.swing.JTabbedPane

Returns the currently selected component for this tabbedpane.

getSelectedFile() - Method in class javax.swing.JFileChooser

Returns the selected file.

getSelectedFiles() - Method in class javax.swing.JFileChooser

Returns a list of selected files if the file chooser is set to allow multiple selection.

getSelectedFrame() - Method in class javax.swing.JDesktopPane

Returns the currently active JInternalFrame in this JDesktopPane, or null if no JInternalFrame is currently active.

getSelectedIcon() - Method in class javax.swing.AbstractButton

Returns the selected icon for the button.

getSelectedIndex() - Method in class java.awt.Choice

Returns the index of the currently selected item.

getSelectedIndex() - Method in class java.awt.List

Gets the index of the selected item on the list,

getSelectedIndex() - Method in class javax.security.auth.callback.ConfirmationCallback

Get the selected confirmation option.

getSelectedIndex() - Method in class javax.swing.DefaultSingleSelectionModel

getSelectedIndex() - Method in class javax.swing.JComboBox

Returns the first item in the list that matches the given item.

getSelectedIndex() - Method in class javax.swing.JList

Returns the smallest selected cell index; the selection when only a single item is selected in the list.

getSelectedIndex() - Method in class javax.swing.JTabbedPane

Returns the currently selected index for this tabbedpane.

getSelectedIndex() - Method in interface javax.swing.SingleSelectionModel

Returns the model's selection.

getSelectedIndexes() - Method in class java.awt.List

Gets the selected indexes on the list.

getSelectedIndexes() - Method in class javax.security.auth.callback.ChoiceCallback

Get the selected choices.

getSelectedIndices() - Method in class javax.swing.JList

Returns an array of all of the selected indices, in increasing order.

getSelectedItem() - Method in class java.awt.Choice

Gets a representation of the current choice as a string.

getSelectedItem() - Method in class java.awt.List

Gets the selected item on this scrolling list.

getSelectedItem() - Method in interface javax.swing.ComboBoxModel

Returns the selected item

getSelectedItem() - Method in class javax.swing.DefaultComboBoxModel

getSelectedItem() - Method in class javax.swing.JComboBox

Returns the current selected item.

getSelectedItem() - Method in class javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxModel

getSelectedItem() - Method in class javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxModel

getSelectedItems() - Method in class java.awt.List

Gets the selected items on this scrolling list.

getSelectedObjects() - Method in class java.awt.Checkbox

Returns an array (length 1) containing the checkbox label or null if the checkbox is not selected.

getSelectedObjects() - Method in class java.awt.CheckboxMenuItem

Returns the an array (length 1) containing the checkbox menu item label or null if the checkbox is not selected.

getSelectedObjects() - Method in class java.awt.Choice

Returns an array (length 1) containing the currently selected item.

getSelectedObjects() - Method in interface java.awt.ItemSelectable

Returns the selected items or null if no items are selected.

getSelectedObjects() - Method in class java.awt.List

Gets the selected items on this scrolling list in an array of Objects.

getSelectedObjects() - Method in class javax.swing.AbstractButton

Returns an array (length 1) containing the label or null if the button is not selected.

getSelectedObjects() - Method in class javax.swing.DefaultButtonModel

Overridden to return null.

getSelectedObjects() - Method in class javax.swing.JCheckBoxMenuItem

Returns an array (length 1) containing the check box menu item label or null if the check box is not selected.

getSelectedObjects() - Method in class javax.swing.JComboBox

Returns an array containing the selected item.

getSelectedPath() - Method in class javax.swing.MenuSelectionManager

Returns the path to the currently selected menu item

getSelectedRow() - Method in class javax.swing.JTable

Returns the index of the first selected row, -1 if no row is selected.

getSelectedRowCount() - Method in class javax.swing.JTable

Returns the number of selected rows.

getSelectedRows() - Method in class javax.swing.JTable

Returns the indices of all selected rows.

getSelectedTabPadInsets(int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getSelectedText(AttributedCharacterIterator.Attribute[]) - Method in interface java.awt.im.InputMethodRequests

Gets the currently selected text from the text editing component.

getSelectedText() - Method in class java.awt.TextComponent.AccessibleAWTTextComponent

Returns the portion of the text that is selected.

getSelectedText() - Method in class java.awt.TextComponent

Returns the selected text from the text that is presented by this text component.

getSelectedText() - Method in interface javax.accessibility.AccessibleText

Returns the portion of the text that is selected.

getSelectedText() - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Returns the portion of the text that is selected.

getSelectedText() - Method in class javax.swing.JLabel.AccessibleJLabel

Returns the portion of the text that is selected.

getSelectedText() - Method in class javax.swing.JSpinner.AccessibleJSpinner

Returns the portion of the text that is selected.

getSelectedText() - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Returns the portion of the text that is selected.

getSelectedText() - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Returns the portion of the text that is selected.

getSelectedText() - Method in class javax.swing.text.JTextComponent

Returns the selected text contained in this TextComponent.

getSelectedTextColor() - Method in class javax.swing.text.JTextComponent

Fetches the current color used to render the selected text.

getSelectedValue() - Method in class javax.swing.JList

Returns the value for the smallest selected cell index; the selected value when only a single item is selected in the list.

getSelectedValues() - Method in class javax.swing.JList

Deprecated.
As of JDK 1.7, replaced by JList.getSelectedValuesList()

getSelectedValuesList() - Method in class javax.swing.JList

Returns a list of all the selected items, in increasing order based on their indices in the list.

getSelection() - Method in class javax.swing.ButtonGroup

Returns the model of the selected button.

getSelectionBackground() - Method in class javax.swing.JList

Returns the color used to draw the background of selected items.

getSelectionBackground() - Method in class javax.swing.JTable

Returns the background color for selected cells.

getSelectionBackground() - Method in class javax.swing.plaf.basic.BasicProgressBarUI

The "selectionBackground" is the color of the text when it is painted over an unfilled area of the progress bar.

getSelectionColor() - Method in class javax.swing.text.JTextComponent

Fetches the current color used to render the selection.

getSelectionCount() - Method in class javax.swing.JTree

Returns the number of nodes selected.

getSelectionCount() - Method in class javax.swing.tree.DefaultTreeSelectionModel

Returns the number of paths that are selected.

getSelectionCount() - Method in interface javax.swing.tree.TreeSelectionModel

Returns the number of paths that are selected.

getSelectionEnd() - Method in class java.awt.TextComponent.AccessibleAWTTextComponent

Returns the end offset within the selected text.

getSelectionEnd() - Method in class java.awt.TextComponent

Gets the end position of the selected text in this text component.

getSelectionEnd() - Method in interface javax.accessibility.AccessibleText

Returns the end offset within the selected text.

getSelectionEnd() - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Returns the end offset within the selected text.

getSelectionEnd() - Method in class javax.swing.JLabel.AccessibleJLabel

Returns the end offset within the selected text.

getSelectionEnd() - Method in class javax.swing.JSpinner.AccessibleJSpinner

Returns the end offset within the selected text.

getSelectionEnd() - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Returns the end offset within the selected text.

getSelectionEnd() - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Returns the end offset within the selected text.

getSelectionEnd() - Method in class javax.swing.text.JTextComponent

Returns the selected text's end position.

getSelectionForeground() - Method in class javax.swing.JList

Returns the color used to draw the foreground of selected items.

getSelectionForeground() - Method in class javax.swing.JTable

Returns the foreground color for selected cells.

getSelectionForeground() - Method in class javax.swing.plaf.basic.BasicProgressBarUI

The "selectionForeground" is the color of the text when it is painted over a filled area of the progress bar.

getSelectionMode() - Method in class javax.swing.DefaultListSelectionModel

Returns the current selection mode.

getSelectionMode() - Method in class javax.swing.JList

Returns the current selection mode for the list.

getSelectionMode() - Method in interface javax.swing.ListSelectionModel

Returns the current selection mode.

getSelectionMode() - Method in class javax.swing.tree.DefaultTreeSelectionModel

Returns the selection mode, one of SINGLE_TREE_SELECTION, DISCONTIGUOUS_TREE_SELECTION or CONTIGUOUS_TREE_SELECTION.

getSelectionMode() - Method in interface javax.swing.tree.TreeSelectionModel

Returns the current selection mode, one of SINGLE_TREE_SELECTION, CONTIGUOUS_TREE_SELECTION or DISCONTIGUOUS_TREE_SELECTION.

getSelectionModel() - Method in class javax.swing.JColorChooser

Returns the data model that handles color selections.

getSelectionModel() - Method in class javax.swing.JList

Returns the current selection model.

getSelectionModel() - Method in class javax.swing.JMenuBar

Returns the model object that handles single selections.

getSelectionModel() - Method in class javax.swing.JPopupMenu

Returns the model object that handles single selections.

getSelectionModel() - Method in class javax.swing.JTable

Returns the ListSelectionModel that is used to maintain row selection state.

getSelectionModel() - Method in class javax.swing.JTree

Returns the model for selections.

getSelectionModel() - Method in class javax.swing.plaf.basic.BasicTreeUI

getSelectionModel() - Method in class javax.swing.table.DefaultTableColumnModel

Returns the ListSelectionModel that is used to maintain column selection state.

getSelectionModel() - Method in interface javax.swing.table.TableColumnModel

Returns the current selection model.

getSelectionModel() - Method in class javax.swing.tree.AbstractLayoutCache

Returns the model used to maintain the selection.

getSelectionPainter() - Method in class javax.swing.text.DefaultCaret

Gets the painter for the Highlighter.

getSelectionPath() - Method in class javax.swing.JTree

Returns the path to the first selected node.

getSelectionPath() - Method in class javax.swing.tree.DefaultTreeSelectionModel

Returns the first path in the selection.

getSelectionPath() - Method in interface javax.swing.tree.TreeSelectionModel

Returns the first path in the selection.

getSelectionPaths() - Method in class javax.swing.JTree

Returns the paths of all selected values.

getSelectionPaths() - Method in class javax.swing.tree.DefaultTreeSelectionModel

Returns the selection.

getSelectionPaths() - Method in interface javax.swing.tree.TreeSelectionModel

Returns the paths in the selection.

getSelectionRows() - Method in class javax.swing.JTree

Returns all of the currently selected rows.

getSelectionRows() - Method in class javax.swing.tree.DefaultTreeSelectionModel

Returns the selection in terms of rows.

getSelectionRows() - Method in interface javax.swing.tree.TreeSelectionModel

Returns all of the currently selected rows.

getSelectionStart() - Method in class java.awt.TextComponent.AccessibleAWTTextComponent

Returns the start offset within the selected text.

getSelectionStart() - Method in class java.awt.TextComponent

Gets the start position of the selected text in this text component.

getSelectionStart() - Method in interface javax.accessibility.AccessibleText

Returns the start offset within the selected text.

getSelectionStart() - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Returns the start offset within the selected text.

getSelectionStart() - Method in class javax.swing.JLabel.AccessibleJLabel

Returns the start offset within the selected text.

getSelectionStart() - Method in class javax.swing.JSpinner.AccessibleJSpinner

Returns the start offset within the selected text.

getSelectionStart() - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Returns the start offset within the selected text.

getSelectionStart() - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Returns the start offset within the selected text.

getSelectionStart() - Method in class javax.swing.text.JTextComponent

Returns the selected text's start position.

getSelectionValues() - Method in class javax.swing.JOptionPane

Returns the input selection values.

getSendBufferSize() - Method in class java.net.DatagramSocket

Get value of the SO_SNDBUF option for this DatagramSocket, that is the buffer size used by the platform for output on this DatagramSocket.

getSendBufferSize() - Method in class java.net.Socket

Get value of the SO_SNDBUF option for this Socket, that is the buffer size used by the platform for output on this Socket.

getSendPastNotifications() - Method in class javax.management.timer.Timer

Gets the flag indicating whether or not the timer sends past notifications.

getSendPastNotifications() - Method in interface javax.management.timer.TimerMBean

Gets the flag indicating whether or not the timer sends past notifications.

getSentenceInstance() - Static method in class java.text.BreakIterator

Returns a new BreakIterator instance for sentence breaks for the default locale.

getSentenceInstance(Locale) - Static method in class java.text.BreakIterator

Returns a new BreakIterator instance for sentence breaks for the given locale.

getSentenceInstance(Locale) - Method in class java.text.spi.BreakIteratorProvider

Returns a new BreakIterator instance for sentence breaks for the given locale.

getSeparator() - Method in class java.nio.file.FileSystem

Returns the name separator, represented as a string.

getSeparatorBackground() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the separator background color of the current theme.

getSeparatorBackground() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the separator background color.

getSeparatorForeground() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the separator foreground color of the current theme.

getSeparatorForeground() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the separator foreground color.

getSeparatorSize() - Method in class javax.swing.JToolBar.Separator

Returns the size of the separator

getSequence(InputStream) - Static method in class javax.sound.midi.MidiSystem

Obtains a MIDI sequence from the specified input stream.

getSequence(URL) - Static method in class javax.sound.midi.MidiSystem

Obtains a MIDI sequence from the specified URL.

getSequence(File) - Static method in class javax.sound.midi.MidiSystem

Obtains a MIDI sequence from the specified File.

getSequence() - Method in interface javax.sound.midi.Sequencer

Obtains the sequence on which the Sequencer is currently operating.

getSequence(InputStream) - Method in class javax.sound.midi.spi.MidiFileReader

Obtains a MIDI sequence from the input stream provided.

getSequence(URL) - Method in class javax.sound.midi.spi.MidiFileReader

Obtains a MIDI sequence from the URL provided.

getSequence(File) - Method in class javax.sound.midi.spi.MidiFileReader

Obtains a MIDI sequence from the File provided.

getSequenceDetState() - Method in interface org.ietf.jgss.GSSContext

Determines if sequence checking is enabled for the per-message security services from this context.

getSequenceNumber() - Method in class java.util.logging.LogRecord

Get the sequence number.

getSequenceNumber() - Method in class javax.management.Notification

Get the notification sequence number.

getSequencer() - Static method in class javax.sound.midi.MidiSystem

Obtains the default Sequencer, connected to a default device.

getSequencer(boolean) - Static method in class javax.sound.midi.MidiSystem

Obtains the default Sequencer, optionally connected to a default device.

getSerializedObject() - Method in class javax.management.loading.MLetContent

Gets the value of the OBJECT attribute of the MLET tag.

getSerialNumber() - Method in class java.security.cert.X509Certificate

Gets the serialNumber value from the certificate.

getSerialNumber() - Method in class java.security.cert.X509CertSelector

Returns the serialNumber criterion.

getSerialNumber() - Method in class java.security.cert.X509CRLEntry

Gets the serial number from this X509CRLEntry, the userCertificate.

getSerialNumber() - Method in class javax.security.cert.X509Certificate

Gets the serialNumber value from the certificate.

getSerialNumber() - Method in interface javax.xml.crypto.dsig.keyinfo.X509IssuerSerial

Returns the serial number of this X509IssuerSerial.

getSerialVersionUID() - Method in class java.io.ObjectStreamClass

Return the serialVersionUID for this class.

getServer() - Method in class javax.security.auth.kerberos.KerberosTicket

Returns the service principal associated with this ticket.

getServerAliases(String, Principal[]) - Method in interface javax.net.ssl.X509KeyManager

Get the matching aliases for authenticating the server side of a secure socket given the public key type and the list of certificate issuer authorities recognized by the peer (if any).

getServerCertificateChain() - Method in class java.net.SecureCacheResponse

Returns the server's certificate chain, which was established as part of defining the session in the original connection that retrieved the network resource, from cache.

getServerCertificates() - Method in class javax.net.ssl.HttpsURLConnection

Returns the server's certificate chain which was established as part of defining the session.

getServerName() - Method in class java.security.cert.LDAPCertStoreParameters

Returns the DNS name of the LDAP server.

getServerNames() - Method in class javax.net.ssl.SSLParameters

Returns a List containing all SNIServerNames of the Server Name Indication (SNI) parameter, or null if none has been set.

getServerSessionContext() - Method in class javax.net.ssl.SSLContext

Returns the server session context, which represents the set of SSL sessions available for use during the handshake phase of server-side SSL sockets.

getServerSocketFactory() - Method in class javax.net.ssl.SSLContext

Returns a ServerSocketFactory object for this context.

getService(BeanContextServices, Object, Class, Object) - Method in interface java.beans.beancontext.BeanContextServiceProvider

Invoked by BeanContextServices, this method requests an instance of a service from this BeanContextServiceProvider.

getService(BeanContextChild, Object, Class, Object, BeanContextServiceRevokedListener) - Method in interface java.beans.beancontext.BeanContextServices

A BeanContextChild, or any arbitrary object associated with a BeanContextChild, may obtain a reference to a currently registered service from its nesting BeanContextServices via invocation of this method.

getService(BeanContextServices, Object, Class, Object) - Method in class java.beans.beancontext.BeanContextServicesSupport.BCSSProxyServiceProvider

getService(BeanContextChild, Object, Class, Object, BeanContextServiceRevokedListener) - Method in class java.beans.beancontext.BeanContextServicesSupport

obtain a service which may be delegated

getService(String, String) - Method in class java.security.Provider

Get the service describing this Provider's implementation of the specified type of this algorithm or alias.

getServiceClass() - Method in class java.beans.beancontext.BeanContextServiceAvailableEvent

Gets the service class that is the subject of this notification.

getServiceClass() - Method in class java.beans.beancontext.BeanContextServiceRevokedEvent

Gets the service class that is the subject of this notification

getServiceName() - Method in interface javax.xml.ws.handler.PortInfo

Gets the qualified name of the WSDL service name containing the port being accessed.

getServiceName() - Method in class javax.xml.ws.Service

Gets the name of this service.

getServiceName() - Method in class javax.xml.ws.spi.ServiceDelegate

Gets the name of this service.

getServiceProvider() - Method in class java.beans.beancontext.BeanContextServicesSupport.BCSSServiceProvider

Returns the service provider.

getServiceProviderByClass(Class<T>) - Method in class javax.imageio.spi.ServiceRegistry

Returns the currently registered service provider object that is of the given class type.

getServiceProviders(Class<T>, boolean) - Method in class javax.imageio.spi.ServiceRegistry

Returns an Iterator containing all registered service providers in the given category.

getServiceProviders(Class<T>, ServiceRegistry.Filter, boolean) - Method in class javax.imageio.spi.ServiceRegistry

Returns an Iterator containing service provider objects within a given category that satisfy a criterion imposed by the supplied ServiceRegistry.Filter object's filter method.

getServices() - Method in class java.security.Provider

Get an unmodifiable Set of all services supported by this Provider.

getServicesBeanInfo() - Method in interface java.beans.beancontext.BeanContextServiceProviderBeanInfo

Gets a BeanInfo array, one for each service class or interface statically available from this ServiceProvider.

getServiceUIFactory() - Method in interface javax.print.PrintService

Returns a factory for UI components which allow users to interact with the service in various roles.

getSession() - Method in class javax.net.ssl.HandshakeCompletedEvent

Returns the session that triggered this event.

getSession() - Method in class javax.net.ssl.SSLEngine

Returns the SSLSession in use in this SSLEngine.

getSession() - Method in class javax.net.ssl.SSLSessionBindingEvent

Returns the SSLSession into which the listener is being bound or from which the listener is being unbound.

getSession(byte[]) - Method in interface javax.net.ssl.SSLSessionContext

Returns the SSLSession bound to the specified session id.

getSession() - Method in class javax.net.ssl.SSLSocket

Returns the SSL Session in use by this connection.

getSessionCacheSize() - Method in interface javax.net.ssl.SSLSessionContext

Returns the size of the cache used for storing SSLSession objects grouped under this SSLSessionContext.

getSessionContext() - Method in interface javax.net.ssl.SSLSession

Returns the context in which this session is bound.

getSessionKey() - Method in class javax.security.auth.kerberos.KerberosTicket

Returns the session key associated with this ticket.

getSessionKeyType() - Method in class javax.security.auth.kerberos.KerberosTicket

Returns the key type of the session key associated with this ticket as defined by the Kerberos Protocol Specification.

getSessionTimeout() - Method in interface javax.net.ssl.SSLSessionContext

Returns the timeout limit of SSLSession objects grouped under this SSLSessionContext.

getSeverity() - Method in class javax.xml.bind.helpers.ValidationEventImpl

getSeverity() - Method in interface javax.xml.bind.ValidationEvent

Retrieve the severity code for this warning/error.

getSeverity() - Method in interface org.w3c.dom.DOMError

The severity of the error, either SEVERITY_WARNING, SEVERITY_ERROR, or SEVERITY_FATAL_ERROR.

getShadowColor(Component) - Method in class javax.swing.border.EtchedBorder

Returns the shadow color of the etched border when rendered on the specified component.

getShadowColor() - Method in class javax.swing.border.EtchedBorder

Returns the shadow color of the etched border.

getShadowColor() - Method in class javax.swing.plaf.basic.BasicSliderUI

getShadowInnerColor(Component) - Method in class javax.swing.border.BevelBorder

Returns the inner shadow color of the bevel border when rendered on the specified component.

getShadowInnerColor() - Method in class javax.swing.border.BevelBorder

Returns the inner shadow color of the bevel border.

getShadowOuterColor(Component) - Method in class javax.swing.border.BevelBorder

Returns the outer shadow color of the bevel border when rendered on the specified component.

getShadowOuterColor() - Method in class javax.swing.border.BevelBorder

Returns the outer shadow color of the bevel border.

getShape() - Method in class java.awt.Window

Returns the shape of the window.

getShaper(int) - Static method in class java.awt.font.NumericShaper

Returns a shaper for the provided unicode range.

getShaper(NumericShaper.Range) - Static method in class java.awt.font.NumericShaper

Returns a shaper for the provided Unicode range.

getSharedAncestor(DefaultMutableTreeNode) - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns the nearest common ancestor to this node and aNode.

getSharedInstance() - Static method in class javax.swing.PopupFactory

Returns the shared PopupFactory which can be used to obtain Popups.

getSharedQueuedThreads() - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer

Returns a collection containing threads that may be waiting to acquire in shared mode.

getSharedQueuedThreads() - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer

Returns a collection containing threads that may be waiting to acquire in shared mode.

getShearInstance(double, double) - Static method in class java.awt.geom.AffineTransform

Returns a transform representing a shearing transformation.

getShearX() - Method in class java.awt.geom.AffineTransform

Returns the X coordinate shearing element (m01) of the 3x3 affine transformation matrix.

getShearY() - Method in class java.awt.geom.AffineTransform

Returns the Y coordinate shearing element (m10) of the 3x3 affine transformation matrix.

getShift() - Method in class javax.swing.plaf.metal.MetalIconFactory.FileIcon16

getShift() - Method in class javax.swing.plaf.metal.MetalIconFactory.FolderIcon16

getShift() - Method in class javax.swing.plaf.metal.MetalIconFactory.TreeFolderIcon

getShift() - Method in class javax.swing.plaf.metal.MetalIconFactory.TreeLeafIcon

getShiftKey() - Method in interface org.w3c.dom.events.MouseEvent

Used to indicate whether the 'shift' key was depressed during the firing of the event.

getShort(Object, int) - Static method in class java.lang.reflect.Array

Returns the value of the indexed component in the specified array object, as a short.

getShort(Object) - Method in class java.lang.reflect.Field

Gets the value of a static or instance field of type short or of another primitive type convertible to type short via a widening conversion.

getShort() - Method in class java.nio.ByteBuffer

Relative get method for reading a short value.

getShort(int) - Method in class java.nio.ByteBuffer

Absolute get method for reading a short value.

getShort(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC SMALLINT parameter as a short in the Java programming language.

getShort(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC SMALLINT parameter as a short in the Java programming language.

getShort(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a short in the Java programming language.

getShort(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a short in the Java programming language.

getShortcut() - Method in class java.awt.MenuItem

Get the MenuShortcut object associated with this menu item,

getShortcutMenuItem(MenuShortcut) - Method in class java.awt.MenuBar

Gets the instance of MenuItem associated with the specified MenuShortcut object, or null if none of the menu items being managed by this menu bar is associated with the specified menu shortcut.

getShortDescription() - Method in class java.beans.FeatureDescriptor

Gets the short description of this feature.

getShortMonths() - Method in class java.text.DateFormatSymbols

Gets short month strings.

getShortParameter(int) - Method in class java.awt.image.renderable.ParameterBlock

A convenience method to return a parameter as a short.

getShortWeekdays() - Method in class java.text.DateFormatSymbols

Gets short weekday strings.

getShowDeleted() - Method in class javax.sql.rowset.BaseRowSet

Retrieves a boolean indicating whether rows marked for deletion appear in the set of current rows.

getShowDeleted() - Method in interface javax.sql.rowset.CachedRowSet

Retrieves a boolean indicating whether rows marked for deletion appear in the set of current rows.

getShowDeleted() - Method in interface javax.sql.rowset.JdbcRowSet

Retrieves a boolean indicating whether rows marked for deletion appear in the set of current rows.

getShowHorizontalLines() - Method in class javax.swing.JTable

Returns true if the table draws horizontal lines between cells, false if it doesn't.

getShowsRootHandles() - Method in class javax.swing.JTree

Returns the value of the showsRootHandles property.

getShowsRootHandles() - Method in class javax.swing.plaf.basic.BasicTreeUI

getShowVerticalLines() - Method in class javax.swing.JTable

Returns true if the table draws vertical lines between cells, false if it doesn't.

getSiblingCount() - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns the number of siblings of this node.

getSides() - Method in class java.awt.JobAttributes

Returns how consecutive pages should be imposed upon the sides of the print medium for jobs using these attributes.

getSigAlgName() - Method in class java.security.cert.X509Certificate

Gets the signature algorithm name for the certificate signature algorithm.

getSigAlgName() - Method in class java.security.cert.X509CRL

Gets the signature algorithm name for the CRL signature algorithm.

getSigAlgName() - Method in class javax.security.cert.X509Certificate

Gets the signature algorithm name for the certificate signature algorithm.

getSigAlgOID() - Method in class java.security.cert.X509Certificate

Gets the signature algorithm OID string from the certificate.

getSigAlgOID() - Method in class java.security.cert.X509CRL

Gets the signature algorithm OID string from the CRL.

getSigAlgOID() - Method in class javax.security.cert.X509Certificate

Gets the signature algorithm OID string from the certificate.

getSigAlgParams() - Method in class java.security.cert.X509Certificate

Gets the DER-encoded signature algorithm parameters from this certificate's signature algorithm.

getSigAlgParams() - Method in class java.security.cert.X509CRL

Gets the DER-encoded signature algorithm parameters from this CRL's signature algorithm.

getSigAlgParams() - Method in class javax.security.cert.X509Certificate

Gets the DER-encoded signature algorithm parameters from this certificate's signature algorithm.

getSign() - Method in class javax.xml.datatype.Duration

Returns the sign of this duration in -1,0, or 1.

getSignature() - Method in class java.security.cert.X509Certificate

Gets the signature value (the raw signature bits) from the certificate.

getSignature() - Method in class java.security.cert.X509CRL

Gets the signature value (the raw signature bits) from the CRL.

getSignature() - Method in class java.security.SignedObject

Retrieves the signature on the signed object, in the form of a byte array.

getSignature() - Method in class javax.management.MBeanConstructorInfo

Returns the list of parameters for this constructor.

getSignature() - Method in class javax.management.MBeanOperationInfo

Returns the list of parameters for this operation.

getSignature() - Method in interface javax.management.openmbean.OpenMBeanConstructorInfo

Returns an array of OpenMBeanParameterInfo instances describing each parameter in the signature of the constructor described by this OpenMBeanConstructorInfo instance.

getSignature() - Method in interface javax.management.openmbean.OpenMBeanOperationInfo

Returns an array of OpenMBeanParameterInfo instances describing each parameter in the signature of the operation described by this OpenMBeanOperationInfo instance.

getSignatureMethod() - Method in interface javax.xml.crypto.dsig.SignedInfo

Returns the signature method of this SignedInfo.

getSignatureValue() - Method in interface javax.xml.crypto.dsig.XMLSignature

Returns the signature value of this XMLSignature.

getSignedInfo() - Method in interface javax.xml.crypto.dsig.XMLSignature

Returns the signed info of this XMLSignature.

getSignerCertPath() - Method in class java.security.CodeSigner

Returns the signer's certificate path.

getSignerCertPath() - Method in class java.security.Timestamp

Returns the certificate path for the Timestamping Authority.

getSigners() - Method in class java.lang.Class

Gets the signers of this class.

getSigProvider() - Method in class java.security.cert.PKIXParameters

Returns the signature provider's name, or null if not set.

getSimpleName() - Method in class java.lang.Class

Returns the simple name of the underlying class as given in the source code.

getSimpleName() - Method in interface javax.lang.model.element.Element

Returns the simple (unqualified) name of this element.

getSimpleName() - Method in interface javax.lang.model.element.ExecutableElement

Returns the simple name of a constructor, method, or initializer.

getSimpleName() - Method in interface javax.lang.model.element.PackageElement

Returns the simple name of this package.

getSimpleName() - Method in interface javax.lang.model.element.TypeElement

Returns the simple name of this type element.

getSimpleName() - Method in interface javax.lang.model.element.VariableElement

Returns the simple name of this variable element.

getSize() - Method in class java.awt.Component.AccessibleAWTComponent

Returns the size of this object in the form of a Dimension object.

getSize() - Method in class java.awt.Component

Returns the size of this component in the form of a Dimension object.

getSize(Dimension) - Method in class java.awt.Component

Stores the width/height of this component into "return value" rv and return rv.

getSize() - Method in class java.awt.Dimension

Gets the size of this Dimension object.

getSize() - Method in class java.awt.Font

Returns the point size of this Font, rounded to an integer.

getSize() - Method in class java.awt.image.DataBuffer

Returns the size (in array elements) of all banks.

getSize() - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Returns the size of this object in the form of a Dimension object.

getSize() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Returns the size of this object in the form of a Dimension object.

getSize() - Method in class java.awt.Rectangle

Gets the size of this Rectangle, represented by the returned Dimension.

getSize() - Method in class java.awt.SplashScreen

Returns the size of the splash screen window as a Dimension.

getSize() - Method in class java.awt.TrayIcon

Returns the size, in pixels, of the space that the tray icon occupies in the system tray.

getSize() - Method in class java.util.zip.ZipEntry

Returns the uncompressed size of the entry data.

getSize() - Method in interface javax.accessibility.AccessibleComponent

Returns the size of this object in the form of a Dimension object.

getSize(int) - Method in class javax.print.attribute.Size2DSyntax

Get this two-dimensional size attribute's dimensions in the given units as floating-point values.

getSize() - Method in class javax.swing.DefaultComboBoxModel

getSize() - Method in class javax.swing.DefaultListModel

Returns the number of components in this list.

getSize(Dimension) - Method in class javax.swing.JComponent

Stores the width/height of this component into "return value" rv and returns rv.

getSize() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

getSize() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

getSize() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

getSize() - Method in interface javax.swing.ListModel

Returns the length of the list.

getSize() - Method in class javax.swing.plaf.basic.BasicDirectoryModel

getSize() - Method in class javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxModel

getSize() - Method in class javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxModel

getSize(int) - Method in class javax.swing.SizeSequence

Returns the size of the specified entry.

getSize() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

getSize() - Method in class javax.xml.soap.AttachmentPart

Returns the number of bytes in this AttachmentPart object.

getSize2D() - Method in class java.awt.Font

Returns the point size of this Font in float value.

getSizeButtonsToSameWidth() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI

Returns true, basic L&F wants all the buttons to have the same width.

getSizeButtonsToSameWidth() - Method in class javax.swing.plaf.synth.SynthOptionPaneUI

Returns true, basic L&F wants all the buttons to have the same width.

getSizeForComponent(Component) - Method in class javax.swing.plaf.basic.BasicComboBoxUI

Returns the size a component would have if used as a cell renderer.

getSizeOfComponent(Component) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager

Returns the width of the passed in component.

getSizes() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager

Returns the sizes of the components.

getSizes() - Method in class javax.swing.SizeSequence

Returns the size of all entries.

getSizingIcon(AbstractButton) - Method in class javax.swing.plaf.synth.SynthButtonUI

Returns the Icon used in calculating the preferred/minimum/maximum size.

getSizingIcon(AbstractButton) - Method in class javax.swing.plaf.synth.SynthRadioButtonUI

Returns the Icon used in calculating the preferred/minimum/maximum size.

getSlaveSyncMode() - Method in interface javax.sound.midi.Sequencer

Obtains the current slave synchronization mode for this sequencer.

getSlaveSyncModes() - Method in interface javax.sound.midi.Sequencer

Obtains the set of slave synchronization modes supported by the sequencer.

getSmallDisplayIcon() - Method in class javax.swing.colorchooser.AbstractColorChooserPanel

Returns the small display icon for the panel.

getSmallestMaximum() - Method in class java.time.temporal.ValueRange

Gets the smallest possible maximum value that the field can take.

getSnapshot() - Method in class java.awt.image.VolatileImage

Returns a static snapshot image of this object.

getSnapToTicks() - Method in class javax.swing.JSlider

Returns true if the knob (and the data value it represents) resolve to the closest tick mark next to where the user positioned the knob.

getSNIMatchers() - Method in class javax.net.ssl.SSLParameters

Returns a Collection containing all SNIMatchers of the Server Name Indication (SNI) parameter, or null if none has been set.

getSOAPBody() - Method in class javax.xml.soap.SOAPMessage

Gets the SOAP Body contained in this SOAPMessage object.

getSOAPFactory() - Method in interface javax.xml.ws.soap.SOAPBinding

Gets the SAAJ SOAPFactory instance used by this SOAP binding.

getSOAPHeader() - Method in class javax.xml.soap.SOAPMessage

Gets the SOAP Header contained in this SOAPMessage object.

getSOAPPart() - Method in class javax.xml.soap.SOAPMessage

Gets the SOAP part of this SOAPMessage object.

getSocket() - Method in class javax.net.ssl.HandshakeCompletedEvent

Returns the socket which is the source of this event.

getSocketAddress() - Method in class java.net.DatagramPacket

Gets the SocketAddress (usually IP address + port number) of the remote host that this packet is being sent to or is coming from.

getSocketFactory() - Static method in class java.rmi.server.RMISocketFactory

Returns the socket factory set by the setSocketFactory method.

getSocketFactory() - Method in class javax.net.ssl.SSLContext

Returns a SocketFactory object for this context.

getSoftFailExceptions() - Method in class java.security.cert.PKIXRevocationChecker

Returns a list containing the exceptions that are ignored by the revocation checker when the SOFT_FAIL option is set.

getSoLinger() - Method in class java.net.Socket

Returns setting for SO_LINGER.

getSolo() - Method in interface javax.sound.midi.MidiChannel

Obtains the current solo state for this channel.

getSortKeys() - Method in class javax.swing.DefaultRowSorter

Returns the current sort keys.

getSortKeys() - Method in class javax.swing.RowSorter

Returns the current sort keys.

getSortOrder() - Method in class javax.swing.RowSorter.SortKey

Returns the sort order of the column.

getSortsOnUpdates() - Method in class javax.swing.DefaultRowSorter

Returns true if a sort should happen when the underlying model is updated; otherwise, returns false.

getSoTimeout() - Method in class java.net.DatagramSocket

Retrieve setting for SO_TIMEOUT.

getSoTimeout() - Method in class java.net.ServerSocket

Retrieve setting for SO_TIMEOUT.

getSoTimeout() - Method in class java.net.Socket

Returns setting for SO_TIMEOUT.

getSoundbank(InputStream) - Static method in class javax.sound.midi.MidiSystem

Constructs a MIDI sound bank by reading it from the specified stream.

getSoundbank(URL) - Static method in class javax.sound.midi.MidiSystem

Constructs a Soundbank by reading it from the specified URL.

getSoundbank(File) - Static method in class javax.sound.midi.MidiSystem

Constructs a Soundbank by reading it from the specified File.

getSoundbank() - Method in class javax.sound.midi.SoundbankResource

Obtains the sound bank that contains this SoundbankResource.

getSoundbank(URL) - Method in class javax.sound.midi.spi.SoundbankReader

Obtains a soundbank object from the URL provided.

getSoundbank(InputStream) - Method in class javax.sound.midi.spi.SoundbankReader

Obtains a soundbank object from the InputStream provided.

getSoundbank(File) - Method in class javax.sound.midi.spi.SoundbankReader

Obtains a soundbank object from the File provided.

getSource() - Method in class java.awt.image.BufferedImage

Returns the object that produces the pixels for the image.

getSource() - Method in class java.awt.Image

Gets the object that produces the pixels for the image.

getSource(int) - Method in class java.awt.image.renderable.ParameterBlock

Returns a source as a general Object.

getSource() - Method in class java.awt.image.VolatileImage

This returns an ImageProducer for this VolatileImage.

getSource() - Method in class java.beans.PropertyEditorSupport

Returns the bean that is used as the source of events.

getSource(Class<T>) - Method in interface java.sql.SQLXML

Returns a Source for reading the XML value designated by this SQLXML instance.

getSource() - Method in class java.util.EventObject

The object on which the Event initially occurred.

getSource() - Method in class javax.swing.event.RowSorterEvent

Returns the source of the event as a RowSorter.

getSource() - Method in interface javax.tools.Diagnostic

Gets the source object associated with this diagnostic.

getSourceActions() - Method in class java.awt.dnd.DragGestureRecognizer

This method returns an int representing the type of action(s) this Drag and Drop operation will support.

getSourceActions() - Method in class java.awt.dnd.DragSourceContext

Returns a bitwise mask of DnDConstants that represent the set of drop actions supported by the drag source for the drag operation associated with this DragSourceContext.

getSourceActions() - Method in class java.awt.dnd.DropTargetDragEvent

This method returns the source drop actions.

getSourceActions() - Method in class java.awt.dnd.DropTargetDropEvent

This method returns the source drop actions.

getSourceActions(JComponent) - Method in class javax.swing.TransferHandler

Returns the type of transfer actions supported by the source; any bitwise-OR combination of COPY, MOVE and LINK.

getSourceAsBeanContextServices() - Method in class java.beans.beancontext.BeanContextServiceAvailableEvent

Gets the source as a reference of type BeanContextServices.

getSourceAsBeanContextServices() - Method in class java.beans.beancontext.BeanContextServiceRevokedEvent

Gets the source as a reference of type BeanContextServices

getSourceAsDragGestureRecognizer() - Method in class java.awt.dnd.DragGestureEvent

Returns the source as a DragGestureRecognizer.

getSourceBands() - Method in class javax.imageio.IIOParam

Returns the set of of source bands to be used.

getSourceClassName() - Method in class java.util.logging.LogRecord

Get the name of the class that (allegedly) issued the logging request.

getSourceDataLine(AudioFormat) - Static method in class javax.sound.sampled.AudioSystem

Obtains a source data line that can be used for playing back audio data in the format specified by the AudioFormat object.

getSourceDataLine(AudioFormat, Mixer.Info) - Static method in class javax.sound.sampled.AudioSystem

Obtains a source data line that can be used for playing back audio data in the format specified by the AudioFormat object, provided by the mixer specified by the Mixer.Info object.

getSourceDropActions() - Method in class javax.swing.TransferHandler.TransferSupport

Returns the drag source's supported drop actions, when this TransferSupport represents a drop.

getSourceElement() - Method in class javax.swing.event.HyperlinkEvent

Returns the Element that corresponds to the source of the event.

getSourceEncodings() - Method in class javax.sound.sampled.spi.FormatConversionProvider

Obtains the set of source format encodings from which format conversion services are provided by this provider.

getSourceLineInfo(Line.Info) - Static method in class javax.sound.sampled.AudioSystem

Obtains information about all source lines of a particular type that are supported by the installed mixers.

getSourceLineInfo() - Method in interface javax.sound.sampled.Mixer

Obtains information about the set of source lines supported by this mixer.

getSourceLineInfo(Line.Info) - Method in interface javax.sound.sampled.Mixer

Obtains information about source lines of a particular type supported by the mixer.

getSourceLines() - Method in interface javax.sound.sampled.Mixer

Obtains the set of all source lines currently open to this mixer.

getSourceMaxProgressivePass() - Method in class javax.imageio.ImageReadParam

If getSourceNumProgressivePasses is equal to Integer.MAX_VALUE, returns Integer.MAX_VALUE.

getSourceMethodName() - Method in class java.util.logging.LogRecord

Get the name of the method that (allegedly) issued the logging request.

getSourceMinProgressivePass() - Method in class javax.imageio.ImageReadParam

Returns the index of the first progressive pass that will be decoded.

getSourceNumProgressivePasses() - Method in class javax.imageio.ImageReadParam

Returns the number of the progressive passes that will be decoded.

getSourceRegion() - Method in class javax.imageio.IIOParam

Returns the source region to be used.

getSourceRegion(ImageReadParam, int, int) - Static method in class javax.imageio.ImageReader

A utility method that may be used by readers to compute the region of the source image that should be read, taking into account any source region and subsampling offset settings in the supplied ImageReadParam.

getSourceRenderSize() - Method in class javax.imageio.ImageReadParam

Returns the width and height of the source image as it will be rendered during decoding, if they have been set via the setSourceRenderSize method.

getSources() - Method in class java.awt.image.BufferedImage

Returns a Vector of RenderedImage objects that are the immediate sources, not the sources of these immediate sources, of image data for this BufferedImage.

getSources() - Method in class java.awt.image.renderable.ParameterBlock

Returns the entire Vector of sources.

getSources() - Method in interface java.awt.image.renderable.RenderableImage

Returns a vector of RenderableImages that are the sources of image data for this RenderableImage.

getSources() - Method in class java.awt.image.renderable.RenderableImageOp

Returns a vector of RenderableImages that are the sources of image data for this RenderableImage.

getSources() - Method in interface java.awt.image.RenderedImage

Returns a vector of RenderedImages that are the immediate sources of image data for this RenderedImage.

getSourceString() - Method in class java.text.CollationKey

Returns the String that this CollationKey represents.

getSourceVersion() - Method in interface javax.annotation.processing.ProcessingEnvironment

Returns the source version that any generated source and class files should conform to.

getSourceVersions() - Method in interface javax.tools.Tool

Gets the source versions of the Java™ programming language supported by this tool.

getSourceXSubsampling() - Method in class javax.imageio.IIOParam

Returns the number of source columns to advance for each pixel.

getSourceYSubsampling() - Method in class javax.imageio.IIOParam

Returns the number of rows to advance for each pixel.

getSouthPane() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI

getSpaceAbove(AttributeSet) - Static method in class javax.swing.text.StyleConstants

Gets the space above setting.

getSpaceBelow(AttributeSet) - Static method in class javax.swing.text.StyleConstants

Gets the space below setting.

getSpan(int, int) - Method in class javax.swing.text.BoxView

Fetches the span of a particular child's current layout.

getSpan(GlyphView, int, int, TabExpander, float) - Method in class javax.swing.text.GlyphView.GlyphPainter

Determine the span the glyphs given a start location (for tab expansion).

getSpecificationName() - Method in class javax.management.MBeanServerDelegate

Returns the full name of the JMX specification implemented by this product.

getSpecificationName() - Method in interface javax.management.MBeanServerDelegateMBean

Returns the full name of the JMX specification implemented by this product.

getSpecificationTitle() - Method in class java.lang.Package

Return the title of the specification that this package implements.

getSpecificationVendor() - Method in class java.lang.Package

Return the name of the organization, vendor, or company that owns and maintains the specification of the classes that implement this package.

getSpecificationVendor() - Method in class javax.management.MBeanServerDelegate

Returns the vendor of the JMX specification implemented by this product.

getSpecificationVendor() - Method in interface javax.management.MBeanServerDelegateMBean

Returns the vendor of the JMX specification implemented by this product.

getSpecificationVersion() - Method in class java.lang.Package

Returns the version number of the specification that this package implements.

getSpecificationVersion() - Method in class javax.management.MBeanServerDelegate

Returns the version of the JMX specification implemented by this product.

getSpecificationVersion() - Method in interface javax.management.MBeanServerDelegateMBean

Returns the version of the JMX specification implemented by this product.

getSpecified() - Method in interface org.w3c.dom.Attr

True if this attribute was explicitly given a value in the instance document, false otherwise.

getSpecName() - Method in interface java.lang.management.RuntimeMXBean

Returns the Java virtual machine specification name.

getSpecVendor() - Method in interface java.lang.management.RuntimeMXBean

Returns the Java virtual machine specification vendor.

getSpecVersion() - Method in interface java.lang.management.RuntimeMXBean

Returns the Java virtual machine specification version.

getSpi(String) - Method in class java.util.prefs.AbstractPreferences

Return the value associated with the specified key at this preference node, or null if there is no association for this key, or the association cannot be determined at this time.

getSpinner() - Method in class javax.swing.JSpinner.DefaultEditor

Returns the JSpinner ancestor of this editor or null if none of the ancestors are a JSpinner.

getSplashScreen() - Static method in class java.awt.SplashScreen

Returns the SplashScreen object used for Java startup splash screen control on systems that support display.

getSplitPane() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI

Returns the splitpane this instance is currently contained in.

getSplitPaneBorder() - Static method in class javax.swing.plaf.basic.BasicBorders

getSplitPaneDividerBorder() - Static method in class javax.swing.plaf.basic.BasicBorders

Returns a border instance for a JSplitPane divider

getSQLException() - Method in class javax.sql.ConnectionEvent

Retrieves the SQLException for this ConnectionEvent object.

getSQLException() - Method in class javax.sql.StatementEvent

Returns the SQLException the driver is about to throw

getSQLKeywords() - Method in interface java.sql.DatabaseMetaData

Retrieves a comma-separated list of all of this database's SQL keywords that are NOT also SQL:2003 keywords.

getSQLState() - Method in exception java.sql.SQLException

Retrieves the SQLState for this SQLException object.

getSQLStateType() - Method in interface java.sql.DatabaseMetaData

Indicates whether the SQLSTATE returned by SQLException.getSQLState is X/Open (now known as Open Group) SQL CLI or SQL:2003.

getSQLTypeName() - Method in interface java.sql.SQLData

Returns the fully-qualified name of the SQL user-defined type that this object represents.

getSQLTypeName() - Method in interface java.sql.Struct

Retrieves the SQL type name of the SQL structured type that this Struct object represents.

getSQLTypeName() - Method in class javax.sql.rowset.serial.SerialStruct

Retrieves the SQL type name for this SerialStruct object.

getSQLXML(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated SQL XML parameter as a java.sql.SQLXML object in the Java programming language.

getSQLXML(String) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated SQL XML parameter as a java.sql.SQLXML object in the Java programming language.

getSQLXML(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet as a java.sql.SQLXML object in the Java programming language.

getSQLXML(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet as a java.sql.SQLXML object in the Java programming language.

getSrcName() - Method in interface org.ietf.jgss.GSSContext

Returns the name of the context initiator.

getSSLParameters() - Method in class javax.net.ssl.SSLEngine

Returns the SSLParameters in effect for this SSLEngine.

getSSLParameters() - Method in class javax.net.ssl.SSLServerSocket

Returns the SSLParameters in effect for newly accepted connections.

getSSLParameters() - Method in class javax.net.ssl.SSLSocket

Returns the SSLParameters in effect for this SSLSocket.

getSSLSocketFactory() - Method in class javax.net.ssl.HttpsURLConnection

Gets the SSL socket factory to be used when creating sockets for secure https URL connections.

getStackTrace() - Method in class java.lang.management.ThreadInfo

Returns the stack trace of the thread associated with this ThreadInfo.

getStackTrace() - Method in class java.lang.Thread

Returns an array of stack trace elements representing the stack dump of this thread.

getStackTrace() - Method in class java.lang.Throwable

Provides programmatic access to the stack trace information printed by Throwable.printStackTrace().

getStamp() - Method in class java.util.concurrent.atomic.AtomicStampedReference

Returns the current value of the stamp.

getStandardChromaNode() - Method in class javax.imageio.metadata.IIOMetadata

Returns an IIOMetadataNode representing the chroma information of the standard javax_imageio_1.0 metadata format, or null if no such information is available.

getStandardCompressionNode() - Method in class javax.imageio.metadata.IIOMetadata

Returns an IIOMetadataNode representing the compression information of the standard javax_imageio_1.0 metadata format, or null if no such information is available.

getStandardDataNode() - Method in class javax.imageio.metadata.IIOMetadata

Returns an IIOMetadataNode representing the data format information of the standard javax_imageio_1.0 metadata format, or null if no such information is available.

getStandardDimensionNode() - Method in class javax.imageio.metadata.IIOMetadata

Returns an IIOMetadataNode representing the dimension information of the standard javax_imageio_1.0 metadata format, or null if no such information is available.

getStandardDocumentNode() - Method in class javax.imageio.metadata.IIOMetadata

Returns an IIOMetadataNode representing the document information of the standard javax_imageio_1.0 metadata format, or null if no such information is available.

getStandardFileManager(DiagnosticListener<? super JavaFileObject>, Locale, Charset) - Method in interface javax.tools.DocumentationTool

Gets a new instance of the standard file manager implementation for this tool.

getStandardFileManager(DiagnosticListener<? super JavaFileObject>, Locale, Charset) - Method in interface javax.tools.JavaCompiler

Gets a new instance of the standard file manager implementation for this tool.

getStandardFormatInstance() - Static method in class javax.imageio.metadata.IIOMetadataFormatImpl

Returns an IIOMetadataFormat object describing the standard, plug-in neutral javax.imageio_1.0 metadata document format described in the comment of the javax.imageio.metadata package.

getStandardOffset() - Method in class java.time.zone.ZoneOffsetTransitionRule

Gets the standard offset in force at the transition.

getStandardOffset(Instant) - Method in class java.time.zone.ZoneRules

Gets the standard offset for the specified instant in this zone.

getStandardTextNode() - Method in class javax.imageio.metadata.IIOMetadata

Returns an IIOMetadataNode representing the textual information of the standard javax_imageio_1.0 metadata format, or null if no such information is available.

getStandardTileNode() - Method in class javax.imageio.metadata.IIOMetadata

Returns an IIOMetadataNode representing the tiling information of the standard javax_imageio_1.0 metadata format, or null if no such information is available.

getStandardTransparencyNode() - Method in class javax.imageio.metadata.IIOMetadata

Returns an IIOMetadataNode representing the transparency information of the standard javax_imageio_1.0 metadata format, or null if no such information is available.

getStandardTree() - Method in class javax.imageio.metadata.IIOMetadata

A utility method to return a tree of IIOMetadataNodes representing the metadata contained within this object according to the conventions of the standard javax_imageio_1.0 metadata format.

getStart() - Method in class javax.swing.SpinnerDateModel

Returns the first Date in the sequence.

getStartIndex() - Method in class javax.accessibility.AccessibleHyperlink

Gets the index with the hypertext document at which this link begins

getStartIndex() - Method in class javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink

Get the index with the hypertext document at which this link begins

getStartOffset() - Method in class javax.swing.text.AbstractDocument.AbstractElement

Gets the starting offset in the model for the element.

getStartOffset() - Method in class javax.swing.text.AbstractDocument.BranchElement

Gets the starting offset in the model for the element.

getStartOffset() - Method in class javax.swing.text.AbstractDocument.LeafElement

Gets the starting offset in the model for the element.

getStartOffset() - Method in class javax.swing.text.AbstractWriter

Returns the first offset to be output.

getStartOffset() - Method in interface javax.swing.text.Element

Fetches the offset from the beginning of the document that this element begins at.

getStartOffset() - Method in class javax.swing.text.GlyphView

Fetches the portion of the model that this view is responsible for.

getStartOffset() - Method in interface javax.swing.text.Highlighter.Highlight

Gets the starting model offset for the highlight.

getStartOffset() - Method in class javax.swing.text.html.HTMLDocument.Iterator

Returns the start of the range for which the current occurrence of the tag is defined and has the same attributes.

getStartOffset() - Method in class javax.swing.text.View

Fetches the portion of the model for which this view is responsible.

getStartPoint() - Method in class java.awt.geom.Arc2D

Returns the starting point of the arc.

getStartPoint() - Method in class java.awt.LinearGradientPaint

Returns a copy of the start point of the gradient axis.

getStartPosition() - Method in class javax.swing.text.AbstractDocument

Returns a position that represents the start of the document.

getStartPosition() - Method in interface javax.swing.text.Document

Returns a position that represents the start of the document.

getStartPosition() - Method in interface javax.tools.Diagnostic

Gets the character offset from the beginning of the file associated with this diagnostic that indicates the start of the problem.

getStartTime() - Method in interface java.lang.management.RuntimeMXBean

Returns the start time of the Java virtual machine in milliseconds.

getStartTime() - Method in class javax.security.auth.kerberos.KerberosTicket

Returns the start time for this ticket's validity period.

getState() - Method in class java.awt.Checkbox

Determines whether this check box is in the "on" or "off" state.

getState() - Method in class java.awt.CheckboxMenuItem

Determines whether the state of this check box menu item is "on" or "off."

getState() - Method in class java.awt.Frame

Gets the state of this frame (obsolete).

getState() - Method in class java.awt.im.InputMethodHighlight

Returns the conversion state of the text range.

getState() - Method in class java.lang.Thread

Returns the state of this thread.

getState() - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer

Returns the current value of synchronization state.

getState() - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer

Returns the current value of synchronization state.

getState() - Method in class javax.swing.JCheckBoxMenuItem

Returns the selected-state of the item.

getState() - Method in class javax.swing.SwingWorker

Returns the SwingWorker state bound property.

getStateChange() - Method in class java.awt.event.ItemEvent

Returns the type of state change (selected or deselected).

getStateLabel(boolean) - Method in class javax.sound.sampled.BooleanControl

Obtains the label for the specified state.

getStatement() - Method in interface java.sql.ResultSet

Retrieves the Statement object that produced this ResultSet object.

getStatement() - Method in class javax.sql.StatementEvent

Returns the PreparedStatement that is being closed or is invalid

getStateToBind(Object, Name, Context, Hashtable<?, ?>, Attributes) - Static method in class javax.naming.spi.DirectoryManager

Retrieves the state of an object for binding when given the original object and its attributes.

getStateToBind(Object, Name, Context, Hashtable<?, ?>, Attributes) - Method in interface javax.naming.spi.DirStateFactory

Retrieves the state of an object for binding given the object and attributes to be transformed.

getStateToBind(Object, Name, Context, Hashtable<?, ?>) - Static method in class javax.naming.spi.NamingManager

Retrieves the state of an object for binding.

getStateToBind(Object, Name, Context, Hashtable<?, ?>) - Method in interface javax.naming.spi.StateFactory

Retrieves the state of an object for binding.

getStaticAttribute(Object) - Static method in class javax.swing.text.StyleContext

Returns the object previously registered with registerStaticAttributeKey.

getStaticAttributeKey(Object) - Static method in class javax.swing.text.StyleContext

Returns the String that key will be registered with

getStatus() - Method in class java.awt.image.PixelGrabber

Return the status of the pixels.

getStatus() - Method in class javax.net.ssl.SSLEngineResult

Gets the return value of this SSLEngine operation.

getStatus() - Method in class javax.sound.midi.MidiMessage

Obtains the status byte for the MIDI message.

getStatus() - Method in interface javax.sql.rowset.spi.SyncResolver

Retrieves the conflict status of the current row of this SyncResolver, which indicates the operation the RowSet object was attempting when the conflict occurred.

getStatusCode() - Method in exception javax.xml.ws.http.HTTPException

Gets the HTTP status code.

getStealCount() - Method in class java.util.concurrent.ForkJoinPool

Returns an estimate of the total number of tasks stolen from one thread's work queue by another.

getStepSize() - Method in class javax.swing.SpinnerNumberModel

Returns the size of the value change computed by the getNextValue and getPreviousValue methods.

getStream(String) - Method in interface java.applet.AppletContext

Returns the stream to which specified key is associated within this applet context.

getStream(DataFlavor) - Method in interface javax.accessibility.AccessibleStreamable

Returns an InputStream for a DataFlavor

getStream(URL) - Method in class javax.swing.JEditorPane

Fetches a stream for the given URL, which is about to be loaded by the setPage method.

getStreamForBytes() - Method in interface javax.print.Doc

Obtains an input stream for extracting byte print data from this doc.

getStreamForBytes() - Method in class javax.print.SimpleDoc

Obtains an input stream for extracting byte print data from this doc.

getStreamKeys() - Method in interface java.applet.AppletContext

Finds all the keys of the streams in this applet context.

getStreamMetadata() - Method in class javax.imageio.ImageReader

Returns an IIOMetadata object representing the metadata associated with the input source as a whole (i.e., not associated with any particular image), or null if the reader does not support reading metadata, is set to ignore metadata, or if no metadata is available.

getStreamMetadata(String, Set<String>) - Method in class javax.imageio.ImageReader

Returns an IIOMetadata object representing the metadata associated with the input source as a whole (i.e., not associated with any particular image).

getStreamMetadataFormat(String) - Method in class javax.imageio.spi.ImageReaderWriterSpi

Returns an IIOMetadataFormat object describing the given stream metadata format, or null if no description is available.

getStreamPosition() - Method in interface javax.imageio.stream.ImageInputStream

Returns the current byte position of the stream.

getStreamPosition() - Method in class javax.imageio.stream.ImageInputStreamImpl

getStrength() - Method in class java.text.Collator

Returns this Collator's strength property.

getStrictErrorChecking() - Method in interface org.w3c.dom.Document

An attribute specifying whether error checking is enforced or not.

getStrikethroughOffset() - Method in class java.awt.font.LineMetrics

Returns the position of the strike-through line relative to the baseline.

getStrikethroughThickness() - Method in class java.awt.font.LineMetrics

Returns the thickness of the strike-through line.

getString(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC CHAR, VARCHAR, or LONGVARCHAR parameter as a String in the Java programming language.

getString(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC CHAR, VARCHAR, or LONGVARCHAR parameter as a String in the Java programming language.

getString(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a String in the Java programming language.

getString(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a String in the Java programming language.

getString() - Method in interface java.sql.SQLXML

Returns a string representation of the XML value designated by this SQLXML instance.

getString(String) - Method in class java.util.ResourceBundle

Gets a string for the given key from this resource bundle or one of its parents.

getString() - Method in class javax.swing.JProgressBar

Returns a String representation of the current progress.

getString(SynthContext, Object, String) - Method in class javax.swing.plaf.synth.SynthStyle

Convenience method to get a specific style property whose value is a String.

getString(int, int) - Method in interface javax.swing.text.AbstractDocument.Content

Fetches a string of characters contained in the sequence.

getString(int, int) - Method in class javax.swing.text.GapContent

Retrieves a portion of the content.

getString() - Method in class javax.swing.text.html.parser.Entity

Returns the data as a String.

getString(int, int) - Method in class javax.swing.text.StringContent

Retrieves a portion of the content.

getString(Object) - Method in class javax.swing.UIDefaults

If the value of key is a String return it, otherwise return null.

getString(Object, Locale) - Method in class javax.swing.UIDefaults

If the value of key for the given Locale is a String return it, otherwise return null.

getString(Object) - Static method in class javax.swing.UIManager

Returns a string from the defaults.

getString(Object, Locale) - Static method in class javax.swing.UIManager

Returns a string from the defaults that is appropriate for the given locale.

getStringArray(String) - Method in class java.util.ResourceBundle

Gets a string array for the given key from this resource bundle or one of its parents.

getStringBounds(String, FontRenderContext) - Method in class java.awt.Font

Returns the logical bounds of the specified String in the specified FontRenderContext.

getStringBounds(String, int, int, FontRenderContext) - Method in class java.awt.Font

Returns the logical bounds of the specified String in the specified FontRenderContext.

getStringBounds(char[], int, int, FontRenderContext) - Method in class java.awt.Font

Returns the logical bounds of the specified array of characters in the specified FontRenderContext.

getStringBounds(CharacterIterator, int, int, FontRenderContext) - Method in class java.awt.Font

Returns the logical bounds of the characters indexed in the specified CharacterIterator in the specified FontRenderContext.

getStringBounds(String, Graphics) - Method in class java.awt.FontMetrics

Returns the bounds of the specified String in the specified Graphics context.

getStringBounds(String, int, int, Graphics) - Method in class java.awt.FontMetrics

Returns the bounds of the specified String in the specified Graphics context.

getStringBounds(char[], int, int, Graphics) - Method in class java.awt.FontMetrics

Returns the bounds of the specified array of characters in the specified Graphics context.

getStringBounds(CharacterIterator, int, int, Graphics) - Method in class java.awt.FontMetrics

Returns the bounds of the characters indexed in the specified CharacterIterator in the specified Graphics context.

getStringConverter() - Method in class javax.swing.table.TableRowSorter

Returns the object responsible for converting values from the model to strings.

getStringData() - Method in interface org.w3c.dom.ls.LSInput

String data to parse.

getStringFunctions() - Method in interface java.sql.DatabaseMetaData

Retrieves a comma-separated list of string functions available with this database.

getStringNameType() - Method in interface org.ietf.jgss.GSSName

Returns the name type of the printable representation of this name that can be obtained from the toString method.

getStringPlacement(Graphics, String, int, int, int, int) - Method in class javax.swing.plaf.basic.BasicProgressBarUI

Designate the place where the progress string will be painted.

getStringTable() - Method in class javax.print.attribute.EnumSyntax

Returns the string table for this enumeration value's enumeration class.

getStringTable() - Method in class javax.print.attribute.standard.Chromaticity

Returns the string table for class Chromaticity.

getStringTable() - Method in class javax.print.attribute.standard.ColorSupported

Returns the string table for class ColorSupported.

getStringTable() - Method in class javax.print.attribute.standard.Compression

Returns the string table for class Compression.

getStringTable() - Method in class javax.print.attribute.standard.DialogTypeSelection

Returns the string table for class DialogTypeSelection.

getStringTable() - Method in class javax.print.attribute.standard.Fidelity

Returns the string table for class Fidelity.

getStringTable() - Method in class javax.print.attribute.standard.Finishings

Returns the string table for class Finishings.

getStringTable() - Method in class javax.print.attribute.standard.JobSheets

Returns the string table for class JobSheets.

getStringTable() - Method in class javax.print.attribute.standard.JobState

Returns the string table for class JobState.

getStringTable() - Method in class javax.print.attribute.standard.JobStateReason

Returns the string table for class JobStateReason.

getStringTable() - Method in class javax.print.attribute.standard.MediaName

Returns the string table for class MediaTray.

getStringTable() - Method in class javax.print.attribute.standard.MediaSizeName

Returns the string table for class MediaSizeName.

getStringTable() - Method in class javax.print.attribute.standard.MediaTray

Returns the string table for class MediaTray.

getStringTable() - Method in class javax.print.attribute.standard.MultipleDocumentHandling

Returns the string table for class MultipleDocumentHandling.

getStringTable() - Method in class javax.print.attribute.standard.OrientationRequested

Returns the string table for class OrientationRequested.

getStringTable() - Method in class javax.print.attribute.standard.PDLOverrideSupported

Returns the string table for class PDLOverrideSupported.

getStringTable() - Method in class javax.print.attribute.standard.PresentationDirection

Returns the string table for class PresentationDirection.

getStringTable() - Method in class javax.print.attribute.standard.PrinterIsAcceptingJobs

Returns the string table for class PrinterIsAcceptingJobs.

getStringTable() - Method in class javax.print.attribute.standard.PrinterState

Returns the string table for class PrinterState.

getStringTable() - Method in class javax.print.attribute.standard.PrinterStateReason

Returns the string table for class PrinterStateReason.

getStringTable() - Method in class javax.print.attribute.standard.PrintQuality

Returns the string table for class PrintQuality.

getStringTable() - Method in class javax.print.attribute.standard.ReferenceUriSchemesSupported

Returns the string table for class ReferenceUriSchemesSupported.

getStringTable() - Method in class javax.print.attribute.standard.Severity

Returns the string table for class Severity.

getStringTable() - Method in class javax.print.attribute.standard.SheetCollate

Returns the string table for class SheetCollate.

getStringTable() - Method in class javax.print.attribute.standard.Sides

Returns the string table for class Sides.

getStringToCompare() - Method in class javax.management.monitor.StringMonitor

Gets the string to compare with the observed attribute common to all observed MBeans.

getStringToCompare() - Method in interface javax.management.monitor.StringMonitorMBean

Gets the string to compare with the observed attribute.

getStringValue(int) - Method in class javax.swing.RowFilter.Entry

Returns the string value at the specified index.

getStringValueAt(int, int) - Method in class javax.swing.DefaultRowSorter.ModelWrapper

Returns the value as a String at the specified index.

getStroke() - Method in class java.awt.Graphics2D

Returns the current Stroke in the Graphics2D context.

getStroke() - Method in class javax.swing.border.StrokeBorder

Returns the BasicStroke object used to stroke a shape during the border rendering.

getStrongCaret(TextHitInfo, TextHitInfo, TextLayout) - Method in class java.awt.font.TextLayout.CaretPolicy

Chooses one of the specified TextHitInfo instances as a strong caret in the specified TextLayout.

getStyle() - Method in class java.awt.Font

Returns the style of this Font.

getStyle() - Method in class java.awt.im.InputMethodHighlight

Returns the rendering style attributes for the text range, or null.

getStyle(String) - Method in class javax.swing.JTextPane

Fetches a named non-null style previously added.

getStyle(JComponent, Region) - Static method in class javax.swing.plaf.nimbus.NimbusLookAndFeel

Gets the style associated with the given component and region.

getStyle() - Method in class javax.swing.plaf.synth.SynthContext

Returns the style associated with this Region.

getStyle(JComponent, Region) - Static method in class javax.swing.plaf.synth.SynthLookAndFeel

Gets a SynthStyle for the specified region of the specified component.

getStyle(JComponent, Region) - Method in class javax.swing.plaf.synth.SynthStyleFactory

Returns the style for the specified Component.

getStyle(String) - Method in class javax.swing.text.DefaultStyledDocument

Fetches a named style previously added.

getStyle(String) - Method in class javax.swing.text.StyleContext

Fetches a named style previously added to the document

getStyle(String) - Method in interface javax.swing.text.StyledDocument

Fetches a named style previously added.

getStyledDocument() - Method in class javax.swing.JTextPane

Fetches the model associated with the editor.

getStyledDocument(JEditorPane) - Method in class javax.swing.text.StyledEditorKit.StyledTextAction

Gets the document associated with an editor pane.

getStyledEditorKit() - Method in class javax.swing.JTextPane

Gets the editor kit.

getStyledEditorKit(JEditorPane) - Method in class javax.swing.text.StyledEditorKit.StyledTextAction

Gets the editor kit associated with an editor pane.

getStyleFactory() - Static method in class javax.swing.plaf.synth.SynthLookAndFeel

Returns the current SynthStyleFactory.

getStyleNames() - Method in class javax.swing.text.DefaultStyledDocument

Fetches the list of of style names.

getStyleNames() - Method in class javax.swing.text.StyleContext

Fetches the names of the styles defined.

getStyleSheet() - Method in class javax.swing.text.html.BlockView

getStyleSheet() - Method in class javax.swing.text.html.HTMLDocument

Fetches the StyleSheet with the document-specific display rules (CSS) that were specified in the HTML document itself.

getStyleSheet() - Method in class javax.swing.text.html.HTMLEditorKit

Get the set of styles currently being used to render the HTML elements.

getStyleSheet() - Method in class javax.swing.text.html.ImageView

Convenience method to get the StyleSheet.

getStyleSheet() - Method in class javax.swing.text.html.InlineView

getStyleSheet() - Method in class javax.swing.text.html.ParagraphView

getStylesheet() - Method in class javax.xml.crypto.dsig.spec.XSLTTransformParameterSpec

Returns the stylesheet.

getStyleSheets() - Method in class javax.swing.text.html.StyleSheet

Returns an array of the linked StyleSheets.

getSubElements() - Method in class javax.swing.JMenu

Returns an array of MenuElements containing the submenu for this menu component.

getSubElements() - Method in class javax.swing.JMenuBar

Implemented to be a MenuElement -- returns the menus in this menu bar.

getSubElements() - Method in class javax.swing.JMenuItem

This method returns an array containing the sub-menu components for this menu component.

getSubElements() - Method in class javax.swing.JPopupMenu

Returns an array of MenuElements containing the submenu for this menu component.

getSubElements() - Method in interface javax.swing.MenuElement

This method should return an array containing the sub-elements for the receiving menu element

getSubimage(int, int, int, int) - Method in class java.awt.image.BufferedImage

Returns a subimage defined by a specified rectangular region.

getSubInterfaces() - Method in class java.net.NetworkInterface

Get an Enumeration with all the subinterfaces (also known as virtual interfaces) attached to this network interface.

getSubject() - Method in class java.security.cert.X509CertSelector

Returns the subject criterion as an X500Principal.

getSubject() - Method in class javax.security.auth.login.LoginContext

Return the authenticated Subject.

getSubject(AccessControlContext) - Static method in class javax.security.auth.Subject

Get the Subject associated with the provided AccessControlContext.

getSubject() - Method in class javax.security.auth.SubjectDomainCombiner

Get the Subject associated with this SubjectDomainCombiner.

getSubjectAlternativeNames() - Method in class java.security.cert.X509Certificate

Gets an immutable collection of subject alternative names from the SubjectAltName extension, (OID = 2.5.29.17).

getSubjectAlternativeNames() - Method in class java.security.cert.X509CertSelector

Returns a copy of the subjectAlternativeNames criterion.

getSubjectAsBytes() - Method in class java.security.cert.X509CertSelector

Returns the subject criterion as a byte array.

getSubjectAsString() - Method in class java.security.cert.X509CertSelector

Denigrated, use X509CertSelector.getSubject() or X509CertSelector.getSubjectAsBytes() instead.

getSubjectDN() - Method in class java.security.cert.X509Certificate

Denigrated, replaced by X509Certificate.getSubjectX500Principal().

getSubjectDN() - Method in class javax.security.cert.X509Certificate

Gets the subject (subject distinguished name) value from the certificate.

getSubjectKeyIdentifier() - Method in class java.security.cert.X509CertSelector

Returns the subjectKeyIdentifier criterion.

getSubjectPublicKey() - Method in class java.security.cert.X509CertSelector

Returns the subjectPublicKey criterion.

getSubjectPublicKeyAlgID() - Method in class java.security.cert.X509CertSelector

Returns the subjectPublicKeyAlgID criterion.

getSubjectUniqueID() - Method in class java.security.cert.X509Certificate

Gets the subjectUniqueID value from the certificate.

getSubjectX500Principal() - Method in class java.security.cert.X509Certificate

Returns the subject (subject distinguished name) value from the certificate as an X500Principal.

getSubprimeQLength() - Method in class java.security.spec.DSAGenParameterSpec

Returns the desired length of the sub-prime Q of the to-be-generated DSA domain parameters in bits.

getSubsamplingXOffset() - Method in class javax.imageio.IIOParam

Returns the horizontal offset of the subsampling grid.

getSubsamplingYOffset() - Method in class javax.imageio.IIOParam

Returns the vertical offset of the subsampling grid.

getSubString(long, int) - Method in interface java.sql.Clob

Retrieves a copy of the specified substring in the CLOB value designated by this Clob object.

getSubString(long, int) - Method in class javax.sql.rowset.serial.SerialClob

Returns a copy of the substring contained in this SerialClob object, starting at the given position and continuing for the specified number or characters.

getSubTextFont() - Method in class javax.swing.plaf.metal.DefaultMetalTheme

Returns the sub-text font.

getSubTextFont() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the sub-text font of the current theme.

getSubTextFont() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the sub-text font.

getSubType() - Method in class java.awt.datatransfer.DataFlavor

Returns the sub MIME type of this DataFlavor.

getSubType() - Method in class javax.activation.MimeType

Retrieve the subtype of this object.

getSuffix(int) - Method in class javax.naming.CompositeName

Creates a composite name whose components consist of a suffix of the components in this composite name.

getSuffix(int) - Method in class javax.naming.CompoundName

Creates a compound name whose components consist of a suffix of the components in this compound name.

getSuffix(int) - Method in class javax.naming.ldap.LdapName

Creates a name whose components consist of a suffix of the components in this LDAP name.

getSuffix(int) - Method in interface javax.naming.Name

Creates a name whose components consist of a suffix of the components in this name.

getSum() - Method in class java.util.DoubleSummaryStatistics

Returns the sum of values recorded, or zero if no values have been recorded.

getSum() - Method in class java.util.IntSummaryStatistics

Returns the sum of values recorded, or zero if no values have been recorded.

getSum() - Method in class java.util.LongSummaryStatistics

Returns the sum of values recorded, or zero if no values have been recorded.

getSuperBound() - Method in interface javax.lang.model.type.WildcardType

Returns the lower bound of this wildcard.

getSuperclass() - Method in class java.lang.Class

Returns the Class representing the superclass of the entity (class, interface, primitive type or void) represented by this Class.

getSuperclass() - Method in interface javax.lang.model.element.TypeElement

Returns the direct superclass of this type element.

getSuperTables(String, String, String) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of the table hierarchies defined in a particular schema in this database.

getSuperTypes(String, String, String) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of the user-defined type (UDT) hierarchies defined in a particular schema in this database.

getSupportedAnnotationTypes() - Method in class javax.annotation.processing.AbstractProcessor

If the processor class is annotated with SupportedAnnotationTypes, return an unmodifiable set with the same set of strings as the annotation.

getSupportedAnnotationTypes() - Method in interface javax.annotation.processing.Processor

Returns the names of the annotation types supported by this processor.

getSupportedAttributeCategories() - Method in interface javax.print.PrintService

Determines the printing attribute categories a client can specify when setting up a job for this print service.

getSupportedAttributeValues(Class<? extends Attribute>, DocFlavor, AttributeSet) - Method in interface javax.print.PrintService

Determines the printing attribute values a client can specify in the given category when setting up a job for this print service.

getSupportedCipherSuites() - Method in class javax.net.ssl.SSLEngine

Returns the names of the cipher suites which could be enabled for use on this engine.

getSupportedCipherSuites() - Method in class javax.net.ssl.SSLServerSocket

Returns the names of the cipher suites which could be enabled for use on an SSL connection.

getSupportedCipherSuites() - Method in class javax.net.ssl.SSLServerSocketFactory

Returns the names of the cipher suites which could be enabled for use on an SSL connection created by this factory.

getSupportedCipherSuites() - Method in class javax.net.ssl.SSLSocket

Returns the names of the cipher suites which could be enabled for use on this connection.

getSupportedCipherSuites() - Method in class javax.net.ssl.SSLSocketFactory

Returns the names of the cipher suites which could be enabled for use on an SSL connection.

getSupportedDocFlavors() - Method in interface javax.print.PrintService

Determines the print data formats a client can specify when setting up a job for this PrintService.

getSupportedDocFlavors() - Method in class javax.print.StreamPrintServiceFactory

Queries the factory for the document flavors that can be accepted by printers obtained from this factory.

getSupportedExtensions() - Method in class java.security.cert.PKIXCertPathChecker

Returns an immutable Set of X.509 certificate extensions that this PKIXCertPathChecker supports (i.e.

getSupportedOptions() - Method in class javax.annotation.processing.AbstractProcessor

If the processor class is annotated with SupportedOptions, return an unmodifiable set with the same set of strings as the annotation.

getSupportedOptions() - Method in interface javax.annotation.processing.Processor

Returns the options recognized by this processor.

getSupportedProtocols() - Method in class javax.net.ssl.SSLEngine

Returns the names of the protocols which could be enabled for use with this SSLEngine.

getSupportedProtocols() - Method in class javax.net.ssl.SSLServerSocket

Returns the names of the protocols which could be enabled for use.

getSupportedProtocols() - Method in class javax.net.ssl.SSLSocket

Returns the names of the protocols which could be enabled for use on an SSL connection.

getSupportedSourceVersion() - Method in class javax.annotation.processing.AbstractProcessor

If the processor class is annotated with SupportedSourceVersion, return the source version in the annotation.

getSupportedSourceVersion() - Method in interface javax.annotation.processing.Processor

Returns the latest source version supported by this annotation processor.

getSupportedSSLParameters() - Method in class javax.net.ssl.SSLContext

Returns a copy of the SSLParameters indicating the supported settings for this SSL context.

getSupportsAbsolutePositioning() - Method in class javax.swing.plaf.basic.BasicScrollBarUI

Indicates whether the user can absolutely position the thumb with a mouse gesture (usually the middle mouse button).

getSupportsAbsolutePositioning() - Method in class javax.swing.plaf.synth.SynthScrollBarUI

Indicates whether the user can absolutely position the thumb with a mouse gesture (usually the middle mouse button).

getSupportsWindowDecorations() - Method in class javax.swing.LookAndFeel

Returns true if the LookAndFeel returned RootPaneUI instances support providing Window decorations in a JRootPane.

getSupportsWindowDecorations() - Method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns true; metal can provide Window decorations.

getSuppressed() - Method in class java.lang.Throwable

Returns an array containing all of the exceptions that were suppressed, typically by the try-with-resources statement, in order to deliver this exception.

getSurplusQueuedTaskCount() - Static method in class java.util.concurrent.ForkJoinTask

Returns an estimate of how many more locally queued tasks are held by the current worker thread than there are other worker threads that might steal them, or zero if this thread is not operating in a ForkJoinPool.

getSurrendersFocusOnKeystroke() - Method in class javax.swing.JTable

Returns true if the editor should get the focus when keystrokes cause the editor to be activated

getSymbol() - Method in class java.util.Currency

Gets the symbol of this currency for the default DISPLAY locale.

getSymbol(Locale) - Method in class java.util.Currency

Gets the symbol of this currency for the specified locale.

getSymbol(String, Locale) - Method in class java.util.spi.CurrencyNameProvider

Gets the symbol of the given currency code for the specified locale.

getSyncAllWidths() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout

getSyncFactory() - Static method in class javax.sql.rowset.spi.SyncFactory

Returns the SyncFactory singleton.

getSyncProvider() - Method in interface javax.sql.rowset.CachedRowSet

Retrieves the SyncProvider implementation for this CachedRowSet object.

getSyncResolver() - Method in exception javax.sql.rowset.spi.SyncProviderException

Retrieves the SyncResolver object that has been set for this SyncProviderException object, or if none has been set, an instance of the default SyncResolver implementation included in the reference implementation.

getSynthesizer() - Static method in class javax.sound.midi.MidiSystem

Obtains the default synthesizer.

getSystem() - Static method in class java.rmi.activation.ActivationGroup

Returns the activation system for the VM.

getSystem() - Method in class java.rmi.activation.ActivationGroupID

Returns the group's activation system.

getSystemClassLoader() - Static method in class java.lang.ClassLoader

Returns the system class loader for delegation.

getSystemClipboard() - Method in class java.awt.Toolkit

Gets the singleton instance of the system Clipboard which interfaces with clipboard facilities provided by the native platform.

getSystemCustomCursor(String) - Static method in class java.awt.Cursor

Returns a system-specific custom cursor object matching the specified name.

getSystemDisplayName(File) - Method in class javax.swing.filechooser.FileSystemView

Name of a file, directory, or folder as it would be displayed in a system file browser.

getSystemDocumentationTool() - Static method in class javax.tools.ToolProvider

Gets the Java™ programming language documentation tool provided with this platform.

getSystemEventQueue() - Method in class java.awt.Toolkit

Get the application's or applet's EventQueue instance.

getSystemEventQueueImpl() - Method in class java.awt.Toolkit

Gets the application's or applet's EventQueue instance, without checking access.

getSystemFunctions() - Method in interface java.sql.DatabaseMetaData

Retrieves a comma-separated list of system functions available with this database.

getSystemIcon(File) - Method in class javax.swing.filechooser.FileSystemView

Icon for a file, directory, or folder as it would be displayed in a system file browser.

getSystemId() - Method in interface javax.xml.stream.events.EntityDeclaration

The entity's system identifier.

getSystemId() - Method in interface javax.xml.stream.events.NotationDeclaration

The notation's system identifier, or null if none was given.

getSystemId() - Method in interface javax.xml.stream.events.StartDocument

Returns the system ID of the XML data

getSystemId() - Method in interface javax.xml.stream.Location

Returns the system ID of the XML

getSystemId() - Method in class javax.xml.transform.dom.DOMResult

Get the System Identifier.

getSystemId() - Method in class javax.xml.transform.dom.DOMSource

Get the base ID (URL or system ID) from where URLs will be resolved.

getSystemId() - Method in interface javax.xml.transform.Result

Get the system identifier that was set with setSystemId.

getSystemId() - Method in class javax.xml.transform.sax.SAXResult

Get the system identifier that was set with setSystemId.

getSystemId() - Method in class javax.xml.transform.sax.SAXSource

Get the base ID (URI or system ID) from where URIs will be resolved.

getSystemId() - Method in interface javax.xml.transform.sax.TemplatesHandler

Get the base ID (URI or system ID) from where relative URLs will be resolved.

getSystemId() - Method in interface javax.xml.transform.sax.TransformerHandler

Get the base ID (URI or system ID) from where relative URLs will be resolved.

getSystemId() - Method in interface javax.xml.transform.Source

Get the system identifier that was set with setSystemId.

getSystemId() - Method in interface javax.xml.transform.SourceLocator

Return the system identifier for the current document event.

getSystemId() - Method in class javax.xml.transform.stax.StAXResult

The returned system identifier is always null.

getSystemId() - Method in class javax.xml.transform.stax.StAXSource

Get the system identifier used by this StAXSource.

getSystemId() - Method in class javax.xml.transform.stream.StreamResult

Get the system identifier that was set with setSystemId.

getSystemId() - Method in class javax.xml.transform.stream.StreamSource

Get the system identifier that was set with setSystemId.

getSystemId() - Method in interface org.w3c.dom.DocumentType

The system identifier of the external subset.

getSystemId() - Method in interface org.w3c.dom.Entity

The system identifier associated with the entity if specified, and null otherwise.

getSystemId() - Method in interface org.w3c.dom.ls.LSInput

The system identifier, a URI reference [IETF RFC 2396], for this input source.

getSystemId() - Method in interface org.w3c.dom.ls.LSOutput

The system identifier, a URI reference [IETF RFC 2396], for this output destination.

getSystemId() - Method in interface org.w3c.dom.Notation

The system identifier of this notation.

getSystemId() - Method in class org.xml.sax.helpers.LocatorImpl

Return the saved system identifier.

getSystemId() - Method in class org.xml.sax.InputSource

Get the system identifier for this input source.

getSystemId() - Method in interface org.xml.sax.Locator

Return the system identifier for the current document event.

getSystemId() - Method in exception org.xml.sax.SAXParseException

Get the system identifier of the entity where the exception occurred.

getSystemJavaCompiler() - Static method in class javax.tools.ToolProvider

Gets the Java™ programming language compiler provided with this platform.

getSystemLoadAverage() - Method in interface java.lang.management.OperatingSystemMXBean

Returns the system load average for the last minute.

getSystemLookAndFeelClassName() - Static method in class javax.swing.UIManager

Returns the name of the LookAndFeel class that implements the native system look and feel if there is one, otherwise the name of the default cross platform LookAndFeel class.

getSystemProperties() - Method in interface java.lang.management.RuntimeMXBean

Returns a map of names and values of all system properties.

getSystemResource(String) - Static method in class java.lang.ClassLoader

Find a resource of the specified name from the search path used to load classes.

getSystemResourceAsStream(String) - Static method in class java.lang.ClassLoader

Open for reading, a resource of the specified name from the search path used to load classes.

getSystemResources(String) - Static method in class java.lang.ClassLoader

Finds all resources of the specified name from the search path used to load classes.

getSystemScope() - Static method in class java.security.IdentityScope

Deprecated.

Returns the system's identity scope.

getSystemSelection() - Method in class java.awt.Toolkit

Gets the singleton instance of the system selection as a Clipboard object.

getSystemTextColor() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the system text color of the current theme.

getSystemTextColor() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the system text color.

getSystemTextFont() - Method in class javax.swing.plaf.metal.DefaultMetalTheme

Returns the system text font.

getSystemTextFont() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the system text font of the current theme.

getSystemTextFont() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the system text font.

getSystemToolClassLoader() - Static method in class javax.tools.ToolProvider

Returns the class loader for tools provided with this platform.

getSystemTray() - Static method in class java.awt.SystemTray

Gets the SystemTray instance that represents the desktop's tray area.

getSystemTypeDescription(File) - Method in class javax.swing.filechooser.FileSystemView

Type description for a file, directory, or folder as it would be displayed in a system file browser.

getTab(int) - Method in class javax.swing.text.TabSet

Returns the TabStop at index index.

getTabAfter(float) - Method in class javax.swing.text.TabSet

Returns the Tab instance after location.

getTabAreaInsets(int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getTabBase() - Method in class javax.swing.text.ParagraphView

Returns where the tabs are calculated from.

getTabbedSpan(float, TabExpander) - Method in class javax.swing.text.GlyphView

Determines the desired span when using the given tab expansion implementation.

getTabbedSpan(float, TabExpander) - Method in interface javax.swing.text.TabableView

Determines the desired span when using the given tab expansion implementation.

getTabbedTextOffset(Segment, FontMetrics, int, int, TabExpander, int) - Static method in class javax.swing.text.Utilities

Determines the relative offset into the given text that best represents the given span in the view coordinate system.

getTabbedTextOffset(Segment, FontMetrics, int, int, TabExpander, int, boolean) - Static method in class javax.swing.text.Utilities

getTabbedTextWidth(Segment, FontMetrics, int, TabExpander, int) - Static method in class javax.swing.text.Utilities

Determines the width of the given segment of text taking tabs into consideration.

getTabBounds(JTabbedPane, int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

Returns the bounds of the specified tab index.

getTabBounds(int, Rectangle) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

Returns the bounds of the specified tab in the coordinate space of the JTabbedPane component.

getTabBounds(JTabbedPane, int) - Method in class javax.swing.plaf.multi.MultiTabbedPaneUI

Invokes the getTabBounds method on each UI handled by this object.

getTabBounds(JTabbedPane, int) - Method in class javax.swing.plaf.TabbedPaneUI

getTabComponentAt(int) - Method in class javax.swing.JTabbedPane

Returns the tab component at index.

getTabCount() - Method in class javax.swing.JTabbedPane

Returns the number of tabs in this tabbedpane.

getTabCount() - Method in class javax.swing.text.TabSet

Returns the number of Tab instances the receiver contains.

getTabExpander() - Method in class javax.swing.text.GlyphView

Fetch the TabExpander to use if tabs are present in this view.

getTabIndex(TabStop) - Method in class javax.swing.text.TabSet

getTabIndexAfter(float) - Method in class javax.swing.text.TabSet

Returns the index of the Tab to be used after location.

getTabInsets(int, int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getTabInsets(int, int) - Method in class javax.swing.plaf.synth.SynthTabbedPaneUI

getTabLabelShiftX(int, int, boolean) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getTabLabelShiftX(int, int, boolean) - Method in class javax.swing.plaf.metal.MetalTabbedPaneUI

Overridden to do nothing for the Java L&F.

getTabLabelShiftX(int, int, boolean) - Method in class javax.swing.plaf.synth.SynthTabbedPaneUI

getTabLabelShiftY(int, int, boolean) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getTabLabelShiftY(int, int, boolean) - Method in class javax.swing.plaf.metal.MetalTabbedPaneUI

Overridden to do nothing for the Java L&F.

getTabLabelShiftY(int, int, boolean) - Method in class javax.swing.plaf.synth.SynthTabbedPaneUI

getTabLayoutPolicy() - Method in class javax.swing.JTabbedPane

Returns the policy used by the tabbedpane to layout the tabs when all the tabs will not fit within a single run.

getTable() - Method in class java.awt.image.ByteLookupTable

Returns the lookup table data by reference.

getTable() - Method in class java.awt.image.LookupOp

Returns the LookupTable.

getTable() - Method in class java.awt.image.ShortLookupTable

Returns the lookup table data by reference.

getTable() - Method in class javax.imageio.plugins.jpeg.JPEGQTable

Returns a copy of the current quantization table as an array of ints in natural (not zig-zag) order.

getTable() - Method in class javax.swing.table.JTableHeader

Returns the table associated with this header.

getTableCellEditorComponent(JTable, Object, boolean, int, int) - Method in class javax.swing.DefaultCellEditor

Implements the TableCellEditor interface.

getTableCellEditorComponent(JTable, Object, boolean, int, int) - Method in interface javax.swing.table.TableCellEditor

Sets an initial value for the editor.

getTableCellRendererComponent(JTable, Object, boolean, boolean, int, int) - Method in class javax.swing.table.DefaultTableCellRenderer

Returns the default table cell renderer.

getTableCellRendererComponent(JTable, Object, boolean, boolean, int, int) - Method in interface javax.swing.table.TableCellRenderer

Returns the component used for drawing the cell.

getTableHeader() - Method in class javax.swing.JTable

Returns the tableHeader used by this JTable.

getTableModelListeners() - Method in class javax.swing.table.AbstractTableModel

Returns an array of all the table model listeners registered on this model.

getTableName(int) - Method in interface java.sql.ResultSetMetaData

Gets the designated column's table name.

getTableName() - Method in interface javax.sql.rowset.CachedRowSet

Returns an identifier for the object (table) that was used to create this CachedRowSet object.

getTableName(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Retrieves the name of the table from which the value in the designated column was derived.

getTablePrivileges(String, String, String) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of the access rights for each table available in a catalog.

getTables(String, String, String, String[]) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of the tables available in the given catalog.

getTableTypes() - Method in interface java.sql.DatabaseMetaData

Retrieves the table types available in this database.

getTabPlacement() - Method in class javax.swing.JTabbedPane

Returns the placement of the tabs for this tabbedpane.

getTabRunCount() - Method in class javax.swing.JTabbedPane

Returns the number of tab runs currently used to display the tabs.

getTabRunCount(JTabbedPane) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getTabRunCount(JTabbedPane) - Method in class javax.swing.plaf.multi.MultiTabbedPaneUI

Invokes the getTabRunCount method on each UI handled by this object.

getTabRunCount(JTabbedPane) - Method in class javax.swing.plaf.TabbedPaneUI

getTabRunIndent(int, int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getTabRunOffset(int, int, int, boolean) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getTabRunOverlay(int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getTabRunOverlay(int) - Method in class javax.swing.plaf.metal.MetalTabbedPaneUI

getTabSet() - Method in class javax.swing.text.ParagraphView

Gets the Tabset to be used in calculating tabs.

getTabSet(AttributeSet) - Static method in class javax.swing.text.StyleConstants

Gets the TabSet.

getTabSize() - Method in class javax.swing.JTextArea

Gets the number of characters used to expand tabs.

getTabSize() - Method in class javax.swing.text.PlainView

Returns the tab size set for the document, defaulting to 8.

getTabSize() - Method in class javax.swing.text.WrappedPlainView

Returns the tab size set for the document, defaulting to 8.

getTabularType() - Method in interface javax.management.openmbean.TabularData

Returns the tabular type describing this TabularData instance.

getTabularType() - Method in class javax.management.openmbean.TabularDataSupport

Returns the tabular type describing this TabularData instance.

getTag(String) - Static method in class javax.swing.text.html.HTML

Fetches a tag constant for a well-known tag name (i.e.

getTag() - Method in class javax.swing.text.html.HTMLDocument.Iterator

Type of tag this iterator represents.

getTagName() - Method in class javax.imageio.metadata.IIOMetadataNode

Equivalent to getNodeName.

getTagName() - Method in interface org.w3c.dom.Element

The name of the element.

getTags() - Method in interface java.beans.PropertyEditor

If the property value must be one of a set of known tagged values, then this method should return an array of the tags.

getTags() - Method in class java.beans.PropertyEditorSupport

If the property value must be one of a set of known tagged values, then this method should return an array of the tag values.

getTail(Handler) - Method in class java.util.logging.Formatter

Return the tail string for a set of formatted records.

getTail(Handler) - Method in class java.util.logging.XMLFormatter

Return the tail string for a set of XML formatted records.

getTarget() - Method in class java.beans.EventHandler

Returns the object to which this event handler will send a message.

getTarget() - Method in class java.beans.Statement

Returns the target object of this statement.

getTarget() - Method in class java.lang.invoke.CallSite

Returns the target method of the call site, according to the behavior defined by this call site's specific class.

getTarget() - Method in class java.lang.invoke.ConstantCallSite

Returns the target method of the call site, which behaves like a final field of the ConstantCallSite.

getTarget() - Method in class java.lang.invoke.MutableCallSite

Returns the target method of the call site, which behaves like a normal field of the MutableCallSite.

getTarget() - Method in class java.lang.invoke.VolatileCallSite

Returns the target method of the call site, which behaves like a volatile field of the VolatileCallSite.

getTarget() - Method in class javax.accessibility.AccessibleRelation

Returns the target objects for this relation

getTarget() - Method in interface javax.rmi.CORBA.Tie

Returns the target for this tie.

getTarget() - Method in class javax.swing.BoxLayout

Returns the container that uses this layout manager.

getTarget() - Method in class javax.swing.OverlayLayout

Returns the container that uses this layout manager.

getTarget() - Method in class javax.swing.text.html.HTMLFrameHyperlinkEvent

returns the target for the link.

getTarget() - Method in interface javax.xml.crypto.dsig.SignatureProperty

Returns the target URI of this SignatureProperty.

getTarget() - Method in interface javax.xml.stream.events.ProcessingInstruction

The target section of the processing instruction

getTarget() - Method in interface org.w3c.dom.events.Event

Used to indicate the EventTarget to which the event was originally dispatched.

getTarget() - Method in interface org.w3c.dom.ProcessingInstruction

The target of this processing instruction.

getTargetActions() - Method in class java.awt.dnd.DragSourceDragEvent

This method returns the target drop action.

getTargetActions() - Method in class java.awt.dnd.DropTargetContext

This method returns an int representing the current actions this DropTarget will accept.

getTargetCertConstraints() - Method in class java.security.cert.PKIXParameters

Returns the required constraints on the target certificate.

getTargetDataLine(AudioFormat) - Static method in class javax.sound.sampled.AudioSystem

Obtains a target data line that can be used for recording audio data in the format specified by the AudioFormat object.

getTargetDataLine(AudioFormat, Mixer.Info) - Static method in class javax.sound.sampled.AudioSystem

Obtains a target data line that can be used for recording audio data in the format specified by the AudioFormat object, provided by the mixer specified by the Mixer.Info object.

getTargetedNotifications() - Method in class javax.management.remote.NotificationResult

Returns the notifications resulting from the query, and the listeners they correspond to.

getTargetEncodings(AudioFormat.Encoding) - Static method in class javax.sound.sampled.AudioSystem

Obtains the encodings that the system can obtain from an audio input stream with the specified encoding using the set of installed format converters.

getTargetEncodings(AudioFormat) - Static method in class javax.sound.sampled.AudioSystem

Obtains the encodings that the system can obtain from an audio input stream with the specified format using the set of installed format converters.

getTargetEncodings() - Method in class javax.sound.sampled.spi.FormatConversionProvider

Obtains the set of target format encodings to which format conversion services are provided by this provider.

getTargetEncodings(AudioFormat) - Method in class javax.sound.sampled.spi.FormatConversionProvider

Obtains the set of target format encodings supported by the format converter given a particular source format.

getTargetError() - Method in exception javax.management.RuntimeErrorException

Returns the actual Error thrown.

getTargetException() - Method in exception java.lang.reflect.InvocationTargetException

Get the thrown target exception.

getTargetException() - Method in exception javax.management.MBeanException

Return the actual Exception thrown.

getTargetException() - Method in exception javax.management.ReflectionException

Returns the actual Exception thrown.

getTargetException() - Method in exception javax.management.RuntimeMBeanException

Returns the actual RuntimeException thrown.

getTargetException() - Method in exception javax.management.RuntimeOperationsException

Returns the actual RuntimeException thrown.

getTargetFormats(AudioFormat.Encoding, AudioFormat) - Static method in class javax.sound.sampled.AudioSystem

Obtains the formats that have a particular encoding and that the system can obtain from a stream of the specified format using the set of installed format converters.

getTargetFormats(AudioFormat.Encoding, AudioFormat) - Method in class javax.sound.sampled.spi.FormatConversionProvider

Obtains the set of target formats with the encoding specified supported by the format converter If no target formats with the specified encoding are supported for this source format, an array of length 0 is returned.

getTargetLineInfo(Line.Info) - Static method in class javax.sound.sampled.AudioSystem

Obtains information about all target lines of a particular type that are supported by the installed mixers.

getTargetLineInfo() - Method in interface javax.sound.sampled.Mixer

Obtains information about the set of target lines supported by this mixer.

getTargetLineInfo(Line.Info) - Method in interface javax.sound.sampled.Mixer

Obtains information about target lines of a particular type supported by the mixer.

getTargetLines() - Method in interface javax.sound.sampled.Mixer

Obtains the set of all target lines currently open from this mixer.

getTargName() - Method in interface org.ietf.jgss.GSSContext

Returns the name of the context acceptor.

getTask(Writer, JavaFileManager, DiagnosticListener<? super JavaFileObject>, Class<?>, Iterable<String>, Iterable<? extends JavaFileObject>) - Method in interface javax.tools.DocumentationTool

Creates a future for a documentation task with the given components and arguments.

getTask(Writer, JavaFileManager, DiagnosticListener<? super JavaFileObject>, Iterable<String>, Iterable<String>, Iterable<? extends JavaFileObject>) - Method in interface javax.tools.JavaCompiler

Creates a future for a compilation task with the given components and arguments.

getTaskCount() - Method in class java.util.concurrent.ThreadPoolExecutor

Returns the approximate total number of tasks that have ever been scheduled for execution.

getTBSCertificate() - Method in class java.security.cert.X509Certificate

Gets the DER-encoded certificate information, the tbsCertificate from this certificate.

getTBSCertList() - Method in class java.security.cert.X509CRL

Gets the DER-encoded CRL information, the tbsCertList from this CRL.

getTcpNoDelay() - Method in class java.net.Socket

Tests if TCP_NODELAY is enabled.

getTemplates() - Method in interface javax.xml.transform.sax.TemplatesHandler

When a TemplatesHandler object is used as a ContentHandler for the parsing of transformation instructions, it creates a Templates object, which the caller can get once the SAX events have been completed.

getTempoFactor() - Method in interface javax.sound.midi.Sequencer

Returns the current tempo factor for the sequencer.

getTempoInBPM() - Method in interface javax.sound.midi.Sequencer

Obtains the current tempo, expressed in beats per minute.

getTempoInMPQ() - Method in interface javax.sound.midi.Sequencer

Obtains the current tempo, expressed in microseconds per quarter note.

getText() - Method in class java.awt.event.InputMethodEvent

Gets the combined committed and composed text.

getText() - Method in class java.awt.Label

Gets the text of this label.

getText() - Method in class java.awt.TextComponent

Returns the text that is presented by this text component.

getText() - Method in class java.text.BreakIterator

Get the text being scanned

getText() - Method in class javax.security.auth.callback.TextInputCallback

Get the retrieved text.

getText() - Method in class javax.swing.AbstractButton

Returns the button's text.

getText() - Method in class javax.swing.JEditorPane

Returns the text contained in this TextComponent in terms of the content type of this editor.

getText() - Method in class javax.swing.JLabel

Returns the text string that the label displays.

getText() - Method in class javax.swing.JPasswordField

Deprecated.
As of Java 2 platform v1.2, replaced by getPassword.

getText(int, int) - Method in class javax.swing.JPasswordField

Deprecated.
As of Java 2 platform v1.2, replaced by getPassword.

getText(int, int) - Method in class javax.swing.text.AbstractDocument

Gets a sequence of text from the document.

getText(int, int, Segment) - Method in class javax.swing.text.AbstractDocument

Fetches the text contained within the given portion of the document.

getText(Element) - Method in class javax.swing.text.AbstractWriter

Returns the text associated with the element.

getText(int, int) - Method in interface javax.swing.text.Document

Fetches the text contained within the given portion of the document.

getText(int, int, Segment) - Method in interface javax.swing.text.Document

Fetches the text contained within the given portion of the document.

getText(int, int) - Method in class javax.swing.text.GlyphView

Fetch a reference to the text that occupies the given range.

getText(int, int) - Method in class javax.swing.text.JTextComponent

Fetches a portion of the text represented by the component.

getText() - Method in class javax.swing.text.JTextComponent

Returns the text contained in this TextComponent.

getText() - Method in interface javax.xml.stream.events.Comment

Return the string data of the comment, returns empty string if it does not exist

getText() - Method in class javax.xml.stream.util.StreamReaderDelegate

getText() - Method in interface javax.xml.stream.XMLStreamReader

Returns the current value of the parse event as a string, this returns the string value of a CHARACTERS event, returns the value of a COMMENT, the replacement value for an ENTITY_REFERENCE, the string value of a CDATA section, the string value for a SPACE event, or the String value of the internal subset of the DTD.

getTextBorder() - Static method in class javax.swing.plaf.metal.MetalBorders

Returns a border instance for a text component

getTextBounds(int, int) - Method in interface javax.accessibility.AccessibleExtendedText

Returns the bounding rectangle of the text between two indices.

getTextBounds(int, int) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Returns the Rectangle enclosing the text between two indicies.

getTextCharacters(int, char[], int, int) - Method in class javax.xml.stream.util.StreamReaderDelegate

getTextCharacters() - Method in class javax.xml.stream.util.StreamReaderDelegate

getTextCharacters() - Method in interface javax.xml.stream.XMLStreamReader

Returns an array which contains the characters from this event.

getTextCharacters(int, char[], int, int) - Method in interface javax.xml.stream.XMLStreamReader

Gets the the text associated with a CHARACTERS, SPACE or CDATA event.

getTextComponent(ActionEvent) - Method in class javax.swing.text.TextAction

Determines the component to use for the action.

getTextContent() - Method in class javax.imageio.metadata.IIOMetadataNode

This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.

getTextContent() - Method in interface org.w3c.dom.Node

This attribute returns the text content of this node and its descendants.

getTextField() - Method in class javax.swing.JSpinner.DefaultEditor

Returns the JFormattedTextField child of this editor.

getTextFieldBorder() - Static method in class javax.swing.plaf.basic.BasicBorders

getTextFieldBorder() - Static method in class javax.swing.plaf.metal.MetalBorders

Returns a border instance for a JTextField

getTextHighlightColor() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the text highlight color of the current theme.

getTextHighlightColor() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the text highlight color.

getTextLength() - Method in class javax.xml.stream.util.StreamReaderDelegate

getTextLength() - Method in interface javax.xml.stream.XMLStreamReader

Returns the length of the sequence of characters for this Text event within the text character array.

getTextListeners() - Method in class java.awt.TextComponent

Returns an array of all the text listeners registered on this text component.

getTextLocation(TextHitInfo) - Method in interface java.awt.im.InputMethodRequests

Gets the location of a specified offset in the current composed text, or of the selection in committed text.

getTextNonSelectionColor() - Method in class javax.swing.tree.DefaultTreeCellRenderer

Returns the color the text is drawn with when the node isn't selected.

getTextPlainUnicodeFlavor() - Static method in class java.awt.datatransfer.DataFlavor

Returns a DataFlavor representing plain text with Unicode encoding, where:

getTextRange(int, int) - Method in interface javax.accessibility.AccessibleEditableText

Returns the text string between two indices.

getTextRange(int, int) - Method in interface javax.accessibility.AccessibleExtendedText

Returns the text between two indices

getTextRange(int, int) - Method in class javax.swing.JPasswordField.AccessibleJPasswordField

Returns the text between two indices.

getTextRange(int, int) - Method in class javax.swing.JSpinner.AccessibleJSpinner

Returns the text string between two indices.

getTextRange(int, int) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Returns the text string between two indices.

getTextSelectionColor() - Method in class javax.swing.tree.DefaultTreeCellRenderer

Returns the color the text is drawn with when the node is selected.

getTextSequenceAfter(int, int) - Method in interface javax.accessibility.AccessibleExtendedText

Returns the AccessibleTextSequence after a given index.

getTextSequenceAfter(int, int) - Method in class javax.swing.JPasswordField.AccessibleJPasswordField

Returns the AccessibleTextSequence after a given index.

getTextSequenceAfter(int, int) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Returns the AccessibleTextSequence after a given index.

getTextSequenceAt(int, int) - Method in interface javax.accessibility.AccessibleExtendedText

Returns the AccessibleTextSequence at a given index.

getTextSequenceAt(int, int) - Method in class javax.swing.JPasswordField.AccessibleJPasswordField

Returns the AccessibleTextSequence at a given index.

getTextSequenceAt(int, int) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Returns the AccessibleTextSequence at a given index.

getTextSequenceBefore(int, int) - Method in interface javax.accessibility.AccessibleExtendedText

Returns the AccessibleTextSequence before a given index.

getTextSequenceBefore(int, int) - Method in class javax.swing.JPasswordField.AccessibleJPasswordField

Returns the AccessibleTextSequence before a given index.

getTextSequenceBefore(int, int) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Returns the AccessibleTextSequence before a given index.

getTextShiftOffset() - Method in class javax.swing.plaf.basic.BasicButtonUI

getTextShiftOffset() - Method in class javax.swing.plaf.basic.BasicToggleButtonUI

Overriden so that the text will not be rendered as shifted for Toggle buttons and subclasses.

getTextStart() - Method in class javax.xml.stream.util.StreamReaderDelegate

getTextStart() - Method in interface javax.xml.stream.XMLStreamReader

Returns the offset into the text character array where the first character (of this text event) is stored.

getTextViewForTab(int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

Returns the text View object required to render stylized text (HTML) for the specified tab or null if no specialized text rendering is needed for this tab.

getThenReset() - Method in class java.util.concurrent.atomic.DoubleAccumulator

Equivalent in effect to DoubleAccumulator.get() followed by DoubleAccumulator.reset().

getThenReset() - Method in class java.util.concurrent.atomic.LongAccumulator

Equivalent in effect to LongAccumulator.get() followed by LongAccumulator.reset().

getThickness() - Method in class javax.swing.border.LineBorder

Returns the thickness of the border.

getThisUpdate() - Method in class java.security.cert.X509CRL

Gets the thisUpdate date from the CRL.

getThreadCount() - Method in interface java.lang.management.ThreadMXBean

Returns the current number of live threads including both daemon and non-daemon threads.

getThreadCpuTime(long) - Method in interface java.lang.management.ThreadMXBean

Returns the total CPU time for a thread of the specified ID in nanoseconds.

getThreadFactory() - Method in class java.util.concurrent.ThreadPoolExecutor

Returns the thread factory used to create new threads.

getThreadGroup() - Method in class java.lang.SecurityManager

Returns the thread group into which to instantiate any new thread being created at the time this is being called.

getThreadGroup() - Method in class java.lang.Thread

Returns the thread group to which this thread belongs.

getThreadId() - Method in class java.lang.management.ThreadInfo

Returns the ID of the thread associated with this ThreadInfo.

getThreadID() - Method in class java.util.logging.LogRecord

Get an identifier for the thread where the message originated.

getThreadInfo(long) - Method in interface java.lang.management.ThreadMXBean

Returns the thread info for a thread of the specified id with no stack trace.

getThreadInfo(long[]) - Method in interface java.lang.management.ThreadMXBean

Returns the thread info for each thread whose ID is in the input array ids with no stack trace.

getThreadInfo(long, int) - Method in interface java.lang.management.ThreadMXBean

Returns a thread info for a thread of the specified id, with stack trace of a specified number of stack trace elements.

getThreadInfo(long[], int) - Method in interface java.lang.management.ThreadMXBean

Returns the thread info for each thread whose ID is in the input array ids, with stack trace of a specified number of stack trace elements.

getThreadInfo(long[], boolean, boolean) - Method in interface java.lang.management.ThreadMXBean

Returns the thread info for each thread whose ID is in the input array ids, with stack trace and synchronization information.

getThreadMXBean() - Static method in class java.lang.management.ManagementFactory

Returns the managed bean for the thread system of the Java virtual machine.

getThreadName() - Method in class java.lang.management.ThreadInfo

Returns the name of the thread associated with this ThreadInfo.

getThreadState() - Method in class java.lang.management.ThreadInfo

Returns the state of the thread associated with this ThreadInfo.

getThreadUserTime(long) - Method in interface java.lang.management.ThreadMXBean

Returns the CPU time that a thread of the specified ID has executed in user mode in nanoseconds.

getThreshold(ObjectName) - Method in class javax.management.monitor.CounterMonitor

Gets the current threshold value of the specified object, if this object is contained in the set of observed MBeans, or null otherwise.

getThreshold() - Method in class javax.management.monitor.CounterMonitor

Deprecated.
As of JMX 1.2, replaced by CounterMonitor.getThreshold(ObjectName)

getThreshold() - Method in interface javax.management.monitor.CounterMonitorMBean

Deprecated.
As of JMX 1.2, replaced by CounterMonitorMBean.getThreshold(ObjectName)

getThreshold(ObjectName) - Method in interface javax.management.monitor.CounterMonitorMBean

Gets the threshold value for the specified MBean.

getThreshold() - Method in class javax.xml.ws.soap.MTOMFeature

Gets the threshold value used to determine when binary data should be sent as an attachment.

getThrowable() - Method in class java.awt.event.InvocationEvent

Returns any Throwable caught while executing the Runnable's run() method.

getThrown() - Method in class java.util.logging.LogRecord

Get any throwable associated with the log record.

getThrownTypes() - Method in interface javax.lang.model.element.ExecutableElement

Returns the exceptions and other throwables listed in this method or constructor's throws clause in declaration order.

getThrownTypes() - Method in interface javax.lang.model.type.ExecutableType

Returns the exceptions and other throwables listed in this executable's throws clause.

getThumbBounds() - Method in class javax.swing.plaf.basic.BasicScrollBarUI

Return the current size/location of the thumb.

getThumbnail(int) - Method in class javax.imageio.IIOImage

Returns a thumbnail associated with the main image.

getThumbnailHeight(int, int) - Method in class javax.imageio.ImageReader

Returns the height of the thumbnail preview image indexed by thumbnailIndex, associated with the image indexed by ImageIndex.

getThumbnails() - Method in class javax.imageio.IIOImage

Returns the current List of thumbnail BufferedImages, or null if none is set.

getThumbnailWidth(int, int) - Method in class javax.imageio.ImageReader

Returns the width of the thumbnail preview image indexed by thumbnailIndex, associated with the image indexed by ImageIndex.

getThumbOverhang() - Method in class javax.swing.plaf.metal.MetalSliderUI

Returns the amount that the thumb goes past the slide bar.

getThumbSize() - Method in class javax.swing.plaf.basic.BasicSliderUI

getThumbSize() - Method in class javax.swing.plaf.metal.MetalSliderUI

getThumbSize() - Method in class javax.swing.plaf.synth.SynthSliderUI

getTick() - Method in class javax.sound.midi.MidiEvent

Obtains the time-stamp for the event, in MIDI ticks

getTickLength() - Method in class javax.sound.midi.Sequence

Obtains the duration of this sequence, expressed in MIDI ticks.

getTickLength() - Method in interface javax.sound.midi.Sequencer

Obtains the length of the current sequence, expressed in MIDI ticks, or 0 if no sequence is set.

getTickLength() - Method in class javax.swing.plaf.basic.BasicSliderUI

Gets the height of the tick area for horizontal sliders and the width of the tick area for vertical sliders.

getTickLength() - Method in class javax.swing.plaf.metal.MetalSliderUI

Gets the height of the tick area for horizontal sliders and the width of the tick area for vertical sliders.

getTickPosition() - Method in interface javax.sound.midi.Sequencer

Obtains the current position in the sequence, expressed in MIDI ticks.

getTie(Remote) - Static method in class javax.rmi.CORBA.Util

Returns the tie (if any) for a given target object.

getTie(Remote) - Method in interface javax.rmi.CORBA.UtilDelegate

Delegation call for Util.getTie(java.rmi.Remote).

getTile(int, int) - Method in class java.awt.image.BufferedImage

Returns tile (tileX, tileY).

getTile(int, int) - Method in interface java.awt.image.RenderedImage

Returns tile (tileX, tileY).

getTiledSizeRequirements(SizeRequirements[]) - Static method in class javax.swing.SizeRequirements

Determines the total space necessary to place a set of components end-to-end.

getTileGridXOffset() - Method in class java.awt.image.BufferedImage

Returns the x offset of the tile grid relative to the origin, For example, the x coordinate of the location of tile (0, 0).

getTileGridXOffset() - Method in interface java.awt.image.RenderedImage

Returns the X offset of the tile grid relative to the origin, i.e., the X coordinate of the upper-left pixel of tile (0, 0).

getTileGridXOffset(int) - Method in class javax.imageio.ImageReader

Returns the X coordinate of the upper-left corner of tile (0, 0) in the given image.

getTileGridXOffset() - Method in class javax.imageio.ImageWriteParam

Returns the horizontal tile grid offset of an image as it will be written to the output stream.

getTileGridYOffset() - Method in class java.awt.image.BufferedImage

Returns the y offset of the tile grid relative to the origin, For example, the y coordinate of the location of tile (0, 0).

getTileGridYOffset() - Method in interface java.awt.image.RenderedImage

Returns the Y offset of the tile grid relative to the origin, i.e., the Y coordinate of the upper-left pixel of tile (0, 0).

getTileGridYOffset(int) - Method in class javax.imageio.ImageReader

Returns the Y coordinate of the upper-left corner of tile (0, 0) in the given image.

getTileGridYOffset() - Method in class javax.imageio.ImageWriteParam

Returns the vertical tile grid offset of an image as it will be written to the output stream.

getTileHeight() - Method in class java.awt.image.BufferedImage

Returns the tile height in pixels.

getTileHeight() - Method in interface java.awt.image.RenderedImage

Returns the tile height in pixels.

getTileHeight(int) - Method in class javax.imageio.ImageReader

Returns the height of a tile in the given image.

getTileHeight() - Method in class javax.imageio.ImageWriteParam

Returns the height of each tile in an image as it will be written to the output stream.

getTileIcon() - Method in class javax.swing.border.MatteBorder

Returns the icon used for tiling the border or null if a solid color is being used.

getTileWidth() - Method in class java.awt.image.BufferedImage

Returns the tile width in pixels.

getTileWidth() - Method in interface java.awt.image.RenderedImage

Returns the tile width in pixels.

getTileWidth(int) - Method in class javax.imageio.ImageReader

Returns the width of a tile in the given image.

getTileWidth() - Method in class javax.imageio.ImageWriteParam

Returns the width of each tile in an image as it will be written to the output stream.

getTilingMode() - Method in class javax.imageio.ImageWriteParam

Returns the current tiling mode, if tiling is supported.

getTime(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC TIME parameter as a java.sql.Time object.

getTime(int, Calendar) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC TIME parameter as a java.sql.Time object, using the given Calendar object to construct the time.

getTime(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC TIME parameter as a java.sql.Time object.

getTime(String, Calendar) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC TIME parameter as a java.sql.Time object, using the given Calendar object to construct the time.

getTime(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.sql.Time object in the Java programming language.

getTime(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.sql.Time object in the Java programming language.

getTime(int, Calendar) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.sql.Time object in the Java programming language.

getTime(String, Calendar) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.sql.Time object in the Java programming language.

getTime() - Method in class java.sql.Timestamp

Returns the number of milliseconds since January 1, 1970, 00:00:00 GMT represented by this Timestamp object.

getTime() - Method in class java.util.Calendar

Returns a Date object representing this Calendar's time value (millisecond offset from the Epoch").

getTime() - Method in class java.util.Date

Returns the number of milliseconds since January 1, 1970, 00:00:00 GMT represented by this Date object.

getTime() - Method in class java.util.zip.ZipEntry

Returns the last modification time of the entry.

getTimeDateFunctions() - Method in interface java.sql.DatabaseMetaData

Retrieves a comma-separated list of the time and date functions available with this database.

getTimeDefinition() - Method in class java.time.zone.ZoneOffsetTransitionRule

Gets the time definition, specifying how to convert the time to an instant.

getTimeInMillis() - Method in class java.util.Calendar

Returns this Calendar's time value in milliseconds.

getTimeInMillis(Calendar) - Method in class javax.xml.datatype.Duration

Returns the length of the duration in milli-seconds.

getTimeInMillis(Date) - Method in class javax.xml.datatype.Duration

Returns the length of the duration in milli-seconds.

getTimeInstance() - Static method in class java.text.DateFormat

Gets the time formatter with the default formatting style for the default FORMAT locale.

getTimeInstance(int) - Static method in class java.text.DateFormat

Gets the time formatter with the given formatting style for the default FORMAT locale.

getTimeInstance(int, Locale) - Static method in class java.text.DateFormat

Gets the time formatter with the given formatting style for the given locale.

getTimeInstance(int, Locale) - Method in class java.text.spi.DateFormatProvider

Returns a new DateFormat instance which formats time with the given formatting style for the specified locale.

getTimeLimit() - Method in class javax.naming.directory.SearchControls

Retrieves the time limit of these SearchControls in milliseconds.

getTimestamp() - Method in class java.security.CodeSigner

Returns the signature timestamp.

getTimestamp() - Method in class java.security.Timestamp

Returns the date and time when the timestamp was generated.

getTimestamp(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC TIMESTAMP parameter as a java.sql.Timestamp object.

getTimestamp(int, Calendar) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC TIMESTAMP parameter as a java.sql.Timestamp object, using the given Calendar object to construct the Timestamp object.

getTimestamp(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC TIMESTAMP parameter as a java.sql.Timestamp object.

getTimestamp(String, Calendar) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC TIMESTAMP parameter as a java.sql.Timestamp object, using the given Calendar object to construct the Timestamp object.

getTimestamp(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.sql.Timestamp object in the Java programming language.

getTimestamp(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.sql.Timestamp object in the Java programming language.

getTimestamp(int, Calendar) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.sql.Timestamp object in the Java programming language.

getTimestamp(String, Calendar) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.sql.Timestamp object in the Java programming language.

getTimeStamp() - Method in class javax.management.Notification

Get the notification timestamp.

getTimeStamp() - Method in interface org.w3c.dom.events.Event

Used to specify the time (in milliseconds relative to the epoch) at which the event was created.

getTimeToLive() - Method in class java.net.DatagramSocketImpl

Retrieve the TTL (time-to-live) option.

getTimeToLive() - Method in class java.net.MulticastSocket

Get the default time-to-live for multicast packets sent out on the socket.

getTimeToLive(String, Locale) - Method in class java.util.ResourceBundle.Control

Returns the time-to-live (TTL) value for resource bundles that are loaded under this ResourceBundle.Control.

getTimeZone() - Method in class java.text.DateFormat

Gets the time zone.

getTimeZone() - Method in class java.util.Calendar

Gets the time zone.

getTimeZone() - Method in class java.util.GregorianCalendar

getTimeZone(String) - Static method in class java.util.TimeZone

Gets the TimeZone for the given ID.

getTimeZone(ZoneId) - Static method in class java.util.TimeZone

Gets the TimeZone for the given zoneId.

getTimezone() - Method in class javax.xml.datatype.XMLGregorianCalendar

Return timezone offset in minutes or DatatypeConstants.FIELD_UNDEFINED if this optional field is not defined.

getTimeZone(int) - Method in class javax.xml.datatype.XMLGregorianCalendar

Returns a java.util.TimeZone for this class.

getTimezoneOffset() - Method in class java.util.Date

Deprecated.
As of JDK version 1.1, replaced by -(Calendar.get(Calendar.ZONE_OFFSET) + Calendar.get(Calendar.DST_OFFSET)) / (60 * 1000).

getTipText() - Method in class javax.swing.JToolTip

Returns the text that is shown when the tool tip is displayed.

getTitle() - Method in class java.awt.Dialog

Gets the title of the dialog.

getTitle() - Method in class java.awt.Frame

Gets the title of the frame.

getTitle() - Method in class javax.swing.border.TitledBorder

Returns the title of the titled border.

getTitle() - Method in class javax.swing.JInternalFrame

Returns the title of the JInternalFrame.

getTitle(String, FontMetrics, int) - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane

getTitleAt(int) - Method in class javax.swing.JTabbedPane

Returns the tab title at index.

getTitleColor() - Method in class javax.swing.border.TitledBorder

Returns the title-color of the titled border.

getTitledBorderText() - Method in interface javax.accessibility.AccessibleExtendedComponent

Returns the titled border text

getTitledBorderText() - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Returns the titled border text

getTitledBorderText() - Method in class javax.swing.JComponent.AccessibleJComponent

Returns the titled border text

getTitledBorderText() - Method in class javax.swing.JLabel.AccessibleJLabel

Returns the titled border text

getTitleFont() - Method in class javax.swing.border.TitledBorder

Returns the title-font of the titled border.

getTitleJustification() - Method in class javax.swing.border.TitledBorder

Returns the title-justification of the titled border.

getTitlePosition() - Method in class javax.swing.border.TitledBorder

Returns the title-position of the titled border.

getTLen() - Method in class javax.crypto.spec.GCMParameterSpec

Returns the authentication tag length.

getToggleButtonBorder() - Static method in class javax.swing.plaf.basic.BasicBorders

getToggleButtonBorder() - Static method in class javax.swing.plaf.metal.MetalBorders

Returns a border instance for a JToggleButton

getToggleClickCount() - Method in class javax.swing.JTree

Returns the number of mouse clicks needed to expand or close a node.

getToIndex() - Method in class javax.swing.event.TableColumnModelEvent

Returns the toIndex.

getTokenThreshold() - Method in class javax.swing.text.html.HTMLDocument

Gets the number of tokens to buffer before trying to update the documents element structure.

getToolkit() - Method in class java.awt.Component

Gets the toolkit of this component.

getToolkit() - Method in class java.awt.Window

Returns the toolkit of this frame.

getToolTip() - Method in class java.awt.TrayIcon

Returns the tooltip string associated with this TrayIcon.

getToolTipLocation(MouseEvent) - Method in class javax.swing.JComponent

Returns the tooltip location in this component's coordinate system.

getToolTipText() - Method in interface javax.accessibility.AccessibleExtendedComponent

Returns the tool tip text

getToolTipText() - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Returns the tool tip text

getToolTipText() - Method in class javax.swing.JComponent.AccessibleJComponent

Returns the tool tip text

getToolTipText() - Method in class javax.swing.JComponent

Returns the tooltip string that has been set with setToolTipText.

getToolTipText(MouseEvent) - Method in class javax.swing.JComponent

Returns the string to be used as the tooltip for event.

getToolTipText() - Method in class javax.swing.JLabel.AccessibleJLabel

Returns the tool tip text

getToolTipText(MouseEvent) - Method in class javax.swing.JList

Returns the tooltip text to be used for the given event.

getToolTipText(MouseEvent) - Method in class javax.swing.JTabbedPane

Returns the tooltip text for the component determined by the mouse event location.

getToolTipText(MouseEvent) - Method in class javax.swing.JTable

Overrides JComponent's getToolTipText method in order to allow the renderer's tips to be used if it has text set.

getToolTipText(MouseEvent) - Method in class javax.swing.JTree

Overrides JComponent's getToolTipText method in order to allow renderer's tips to be used if it has text set.

getToolTipText(JTextComponent, Point) - Method in class javax.swing.plaf.basic.BasicTextUI

Returns the string to be used as the tooltip at the passed in location.

getToolTipText(JTextComponent, Point) - Method in class javax.swing.plaf.multi.MultiTextUI

Invokes the getToolTipText method on each UI handled by this object.

getToolTipText(JTextComponent, Point) - Method in class javax.swing.plaf.TextUI

Returns the string to be used as the tooltip at the passed in location.

getToolTipText(MouseEvent) - Method in class javax.swing.table.JTableHeader

Allows the renderer's tips to be used if there is text set.

getToolTipText(float, float, Shape) - Method in class javax.swing.text.html.ImageView

For images the tooltip text comes from text specified with the ALT attribute.

getToolTipText(MouseEvent) - Method in class javax.swing.text.JTextComponent

Returns the string to be used as the tooltip for event.

getToolTipText(float, float, Shape) - Method in class javax.swing.text.View

Returns the tooltip text at the specified location.

getToolTipTextAt(int) - Method in class javax.swing.JTabbedPane

Returns the tab tooltip text at index.

getToPage() - Method in class java.awt.JobAttributes

Returns, for jobs using these attributes, the last page (inclusive) to be printed, if a range of pages is to be printed.

getTopComponent() - Method in class javax.swing.JSplitPane

Returns the component above, or to the left of the divider.

getTopInset() - Method in class javax.swing.text.AsyncBoxView

Get the top part of the margin around the view.

getTopInset() - Method in class javax.swing.text.CompositeView

Gets the top inset.

getTopLevelAncestor() - Method in class javax.swing.JComponent

Returns the top-level ancestor of this component (either the containing Window or Applet), or null if this component has not been added to any container.

getTotalCapacity() - Method in interface java.lang.management.BufferPoolMXBean

Returns an estimate of the total capacity of the buffers in this pool.

getTotalColumnWidth() - Method in class javax.swing.table.DefaultTableColumnModel

Returns the total combined width of all columns.

getTotalColumnWidth() - Method in interface javax.swing.table.TableColumnModel

Returns the total width of all the columns.

getTotalCompilationTime() - Method in interface java.lang.management.CompilationMXBean

Returns the approximate accumulated elapsed time (in milliseconds) spent in compilation.

getTotalIn() - Method in class java.util.zip.Deflater

Returns the total number of uncompressed bytes input so far.

getTotalIn() - Method in class java.util.zip.Inflater

Returns the total number of compressed bytes input so far.

getTotalLoadedClassCount() - Method in interface java.lang.management.ClassLoadingMXBean

Returns the total number of classes that have been loaded since the Java virtual machine has started execution.

getTotalOut() - Method in class java.util.zip.Deflater

Returns the total number of compressed bytes output so far.

getTotalOut() - Method in class java.util.zip.Inflater

Returns the total number of uncompressed bytes output so far.

getTotalSeconds() - Method in class java.time.ZoneOffset

Gets the total zone offset in seconds.

getTotalSize() - Method in interface org.w3c.dom.ls.LSProgressEvent

The total size of the document including all external resources, this number might change as a document is being parsed if references to more external resources are seen.

getTotalSpace() - Method in class java.io.File

Returns the size of the partition named by this abstract pathname.

getTotalSpace() - Method in class java.nio.file.FileStore

Returns the size, in bytes, of the file store.

getTotalStartedThreadCount() - Method in interface java.lang.management.ThreadMXBean

Returns the total number of threads created and also started since the Java virtual machine started.

getTrackBounds() - Method in class javax.swing.plaf.basic.BasicScrollBarUI

Returns the current bounds of the track, i.e.

getTrackLength() - Method in class javax.swing.plaf.metal.MetalSliderUI

Returns the longer dimension of the slide bar.

getTrackMute(int) - Method in interface javax.sound.midi.Sequencer

Obtains the current mute state for a track.

getTracks() - Method in class javax.sound.midi.Sequence

Obtains an array containing all the tracks in this sequence.

getTrackSolo(int) - Method in interface javax.sound.midi.Sequencer

Obtains the current solo state for a track.

getTrackWidth() - Method in class javax.swing.plaf.metal.MetalSliderUI

Returns the shorter dimension of the track.

getTrafficClass() - Method in class java.net.DatagramSocket

Gets traffic class or type-of-service in the IP datagram header for packets sent from this DatagramSocket.

getTrafficClass() - Method in class java.net.Socket

Gets traffic class or type-of-service in the IP header for packets sent from this Socket

getTrailerField() - Method in class java.security.spec.PSSParameterSpec

Returns the value for the trailer field, i.e.

getTransactionIsolation() - Method in interface java.sql.Connection

Retrieves this Connection object's current transaction isolation level.

getTransactionIsolation() - Method in class javax.sql.rowset.BaseRowSet

Returns the transaction isolation property for this RowSet object's connection.

getTransactionIsolation() - Method in interface javax.sql.RowSet

Retrieves the transaction isolation level set for this RowSet object.

getTransactionTimeout() - Method in interface javax.transaction.xa.XAResource

Obtains the current transaction timeout value set for this XAResource instance.

getTransferable() - Method in class java.awt.dnd.DragSourceContext

Returns the Transferable associated with this DragSourceContext.

getTransferable() - Method in class java.awt.dnd.DropTargetContext

get the Transferable (proxy) operand of this operation

getTransferable() - Method in class java.awt.dnd.DropTargetDragEvent

This method returns the Transferable object that represents the data associated with the current drag operation.

getTransferable() - Method in class java.awt.dnd.DropTargetDropEvent

This method returns the Transferable object associated with the drop.

getTransferable() - Method in class javax.swing.TransferHandler.TransferSupport

Returns the Transferable associated with this transfer.

getTransferData(DataFlavor) - Method in class java.awt.datatransfer.StringSelection

Returns the Transferable's data in the requested DataFlavor if possible.

getTransferData(DataFlavor) - Method in interface java.awt.datatransfer.Transferable

Returns an object which represents the data to be transferred.

getTransferData(DataFlavor) - Method in class java.awt.dnd.DropTargetContext.TransferableProxy

Returns an object which represents the data provided by the encapsulated transferable for the requested data flavor.

getTransferData(DataFlavor, DataSource) - Method in interface javax.activation.DataContentHandler

Returns an object which represents the data to be transferred.

getTransferData(DataFlavor) - Method in class javax.activation.DataHandler

Returns an object that represents the data to be transferred.

getTransferDataFlavors() - Method in class java.awt.datatransfer.StringSelection

Returns an array of flavors in which this Transferable can provide the data.

getTransferDataFlavors() - Method in interface java.awt.datatransfer.Transferable

Returns an array of DataFlavor objects indicating the flavors the data can be provided in.

getTransferDataFlavors() - Method in class java.awt.dnd.DropTargetContext.TransferableProxy

Returns an array of DataFlavor objects indicating the flavors the data can be provided in by the encapsulated transferable.

getTransferDataFlavors() - Method in interface javax.activation.DataContentHandler

Returns an array of DataFlavor objects indicating the flavors the data can be provided in.

getTransferDataFlavors() - Method in class javax.activation.DataHandler

Return the DataFlavors in which this data is available.

getTransferHandler() - Method in class javax.swing.JApplet

Gets the transferHandler property.

getTransferHandler() - Method in class javax.swing.JComponent

Gets the transferHandler property.

getTransferHandler() - Method in class javax.swing.JDialog

Gets the transferHandler property.

getTransferHandler() - Method in class javax.swing.JFrame

Gets the transferHandler property.

getTransferHandler() - Method in class javax.swing.JWindow

Gets the transferHandler property.

getTransferSize() - Method in exception java.sql.DataTruncation

Gets the number of bytes of data actually transferred.

getTransferType() - Method in class java.awt.image.ColorModel

Returns the transfer type of this ColorModel.

getTransferType() - Method in class java.awt.image.MultiPixelPackedSampleModel

Returns the TransferType used to transfer pixels by way of the getDataElements and setDataElements methods.

getTransferType() - Method in class java.awt.image.Raster

Returns the TransferType used to transfer pixels via the getDataElements and setDataElements methods.

getTransferType() - Method in class java.awt.image.SampleModel

Returns the TransferType used to transfer pixels via the getDataElements and setDataElements methods.

getTransform() - Method in class java.awt.font.FontRenderContext

Gets the transform that is used to scale typographical points to pixels in this FontRenderContext.

getTransform() - Method in class java.awt.Font

Returns a copy of the transform associated with this Font.

getTransform() - Method in class java.awt.font.TransformAttribute

Returns a copy of the wrapped transform.

getTransform() - Method in class java.awt.Graphics2D

Returns a copy of the current Transform in the Graphics2D context.

getTransform() - Method in class java.awt.image.AffineTransformOp

Returns the affine transform used by this transform operation.

getTransform() - Method in class java.awt.image.renderable.RenderContext

Gets the current user-to-device AffineTransform.

getTransform() - Method in class java.awt.MultipleGradientPaint

Returns a copy of the transform applied to the gradient.

getTransformer() - Method in interface javax.xml.transform.sax.TransformerHandler

Get the Transformer associated with this handler, which is needed in order to set parameters and output properties.

getTransforms() - Method in interface javax.xml.crypto.dsig.keyinfo.RetrievalMethod

Returns an unmodifiable list of Transforms of this RetrievalMethod.

getTransforms() - Method in interface javax.xml.crypto.dsig.Reference

Returns an unmodifiable list of Transforms that are contained in this Reference.

getTransformType() - Method in class java.awt.font.FontRenderContext

Returns the integer type of the affine transform for this FontRenderContext as specified by AffineTransform.getType()

getTransition(LocalDateTime) - Method in class java.time.zone.ZoneRules

Gets the offset transition applicable at the specified local date-time in these rules.

getTransitionRules() - Method in class java.time.zone.ZoneRules

Gets the list of transition rules for years beyond those defined in the transition list.

getTransitions() - Method in class java.time.zone.ZoneRules

Gets the complete list of fully defined transitions.

getTranslateInstance(double, double) - Static method in class java.awt.geom.AffineTransform

Returns a transform representing a translation transformation.

getTranslateX() - Method in class java.awt.geom.AffineTransform

Returns the X coordinate of the translation element (m02) of the 3x3 affine transformation matrix.

getTranslateY() - Method in class java.awt.geom.AffineTransform

Returns the Y coordinate of the translation element (m12) of the 3x3 affine transformation matrix.

getTransmitter() - Method in interface javax.sound.midi.MidiDevice

Obtains a MIDI OUT connection from which the MIDI device will transmit MIDI data The returned transmitter must be closed when the application has finished using it.

getTransmitter() - Static method in class javax.sound.midi.MidiSystem

Obtains a MIDI transmitter from an external MIDI port or other default source.

getTransmitters() - Method in interface javax.sound.midi.MidiDevice

Returns all currently active, non-closed transmitters connected with this MidiDevice.

getTransparency() - Method in class java.awt.Color

Returns the transparency mode for this Color.

getTransparency() - Method in class java.awt.GradientPaint

Returns the transparency mode for this GradientPaint.

getTransparency() - Method in class java.awt.image.BufferedImage

Returns the transparency.

getTransparency() - Method in class java.awt.image.ColorModel

Returns the transparency.

getTransparency() - Method in class java.awt.image.IndexColorModel

Returns the transparency.

getTransparency() - Method in class java.awt.image.VolatileImage

Returns the transparency.

getTransparency() - Method in class java.awt.MultipleGradientPaint

Returns the transparency mode for this Paint object.

getTransparency() - Method in class java.awt.TexturePaint

Returns the transparency mode for this TexturePaint.

getTransparency() - Method in interface java.awt.Transparency

Returns the type of this Transparency.

getTransparentPixel() - Method in class java.awt.image.IndexColorModel

Returns the index of a transparent pixel in this IndexColorModel or -1 if there is no pixel with an alpha value of 0.

getTrayIcons() - Method in class java.awt.SystemTray

Returns an array of all icons added to the tray by this application.

getTrayIconSize() - Method in class java.awt.SystemTray

Returns the size, in pixels, of the space that a tray icon will occupy in the system tray.

getTRC() - Method in class java.awt.color.ICC_ProfileGray

Returns the TRC as an array of shorts.

getTRC(int) - Method in class java.awt.color.ICC_ProfileRGB

Returns the TRC for a particular component as an array.

getTreeCellEditorComponent(JTree, Object, boolean, boolean, boolean, int) - Method in class javax.swing.DefaultCellEditor

Implements the TreeCellEditor interface.

getTreeCellEditorComponent(JTree, Object, boolean, boolean, boolean, int) - Method in class javax.swing.tree.DefaultTreeCellEditor

Configures the editor.

getTreeCellEditorComponent(JTree, Object, boolean, boolean, boolean, int) - Method in interface javax.swing.tree.TreeCellEditor

Sets an initial value for the editor.

getTreeCellRendererComponent(JTree, Object, boolean, boolean, boolean, int, boolean) - Method in class javax.swing.tree.DefaultTreeCellRenderer

Configures the renderer based on the passed in components.

getTreeCellRendererComponent(JTree, Object, boolean, boolean, boolean, int, boolean) - Method in interface javax.swing.tree.TreeCellRenderer

Sets the value of the current tree cell to value.

getTreeComputerIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

getTreeControlIcon(boolean) - Static method in class javax.swing.plaf.metal.MetalIconFactory

getTreeExpansionListeners() - Method in class javax.swing.JTree

Returns an array of all the TreeExpansionListeners added to this JTree with addTreeExpansionListener().

getTreeFloppyDriveIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

getTreeFolderIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

getTreeHardDriveIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

getTreeLeafIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

getTreeLock() - Method in class java.awt.Component

Gets this component's locking object (the object that owns the thread synchronization monitor) for AWT component-tree and layout operations.

getTreeLock() - Method in class java.awt.MenuComponent

Gets this component's locking object (the object that owns the thread synchronization monitor) for AWT component-tree and layout operations.

getTreeModelListeners() - Method in class javax.swing.tree.DefaultTreeModel

Returns an array of all the tree model listeners registered on this model.

getTreePath() - Method in class javax.swing.event.TreeModelEvent

For all events, except treeStructureChanged, returns the parent of the changed nodes.

getTreeSelectionListeners() - Method in class javax.swing.JTree

Returns an array of all the TreeSelectionListeners added to this JTree with addTreeSelectionListener().

getTreeSelectionListeners() - Method in class javax.swing.tree.DefaultTreeSelectionModel

Returns an array of all the tree selection listeners registered on this model.

getTreeWillExpandListeners() - Method in class javax.swing.JTree

Returns an array of all the TreeWillExpandListeners added to this JTree with addTreeWillExpandListener().

getTrigger() - Method in class java.awt.dnd.DragSourceContext

Returns the DragGestureEvent that initially triggered the drag.

getTrigger() - Method in class javax.management.monitor.MonitorNotification

Gets the threshold/string (depending on the monitor type) that triggered off this monitor notification.

getTriggerEvent() - Method in class java.awt.dnd.DragGestureEvent

Returns the initial event that triggered the gesture.

getTriggerEvent() - Method in class java.awt.dnd.DragGestureRecognizer

This method returns the first event in the series of events that initiated the Drag and Drop operation.

getTrustAnchor() - Method in class java.security.cert.PKIXCertPathValidatorResult

Returns the TrustAnchor describing the CA that served as a trust anchor for the certification path.

getTrustAnchors() - Method in class java.security.cert.PKIXParameters

Returns an immutable Set of the most-trusted CAs.

getTrustedCert() - Method in class java.security.cert.TrustAnchor

Returns the most-trusted CA certificate.

getTrustedCertificate() - Method in class java.security.KeyStore.TrustedCertificateEntry

Gets the trusted Certficate from this entry.

getTrustManagers() - Method in class javax.net.ssl.TrustManagerFactory

Returns one trust manager for each type of trust material.

getTTL() - Method in class java.net.DatagramSocketImpl

Deprecated.
use getTimeToLive instead.

getTTL() - Method in class java.net.MulticastSocket

Deprecated.
use the getTimeToLive method instead, which returns an int instead of a byte.

getType() - Method in class java.awt.color.ColorSpace

Returns the color space type of this ColorSpace (for example TYPE_RGB, TYPE_XYZ, ...).

getType() - Method in class java.awt.Cursor

Returns the type for this cursor.

getType() - Method in class java.awt.font.GlyphMetrics

Returns the raw glyph type code.

getType() - Method in class java.awt.geom.AffineTransform

Retrieves the flag bits describing the conversion properties of this transform.

getType() - Method in class java.awt.GraphicsDevice

Returns the type of this GraphicsDevice.

getType() - Method in class java.awt.image.BufferedImage

Returns the image type.

getType() - Method in class java.awt.Window

Returns the type of the window.

getType() - Method in class java.io.ObjectStreamField

Get the type of the field.

getType(char) - Static method in class java.lang.Character

Returns a value indicating a character's general category.

getType(int) - Static method in class java.lang.Character

Returns a value indicating a character's general category.

getType() - Method in interface java.lang.management.MemoryPoolMXBean

Returns the type of this memory pool.

getType() - Method in interface java.lang.reflect.AnnotatedType

Returns the underlying type that this annotated type represents.

getType() - Method in class java.lang.reflect.Field

Returns a Class object that identifies the declared type for the field represented by this Field object.

getType() - Method in class java.lang.reflect.Parameter

Returns a Class object that identifies the declared type for the parameter represented by this Parameter object.

getType() - Method in class java.security.cert.Certificate

Returns the type of this certificate.

getType() - Method in class java.security.cert.CertificateFactory

Returns the name of the certificate type associated with this certificate factory.

getType() - Method in class java.security.cert.CertPath

Returns the type of Certificates in this certification path.

getType() - Method in class java.security.cert.CertStore

Returns the type of this CertStore.

getType() - Method in class java.security.cert.CRL

Returns the type of this CRL.

getType() - Method in class java.security.KeyStore

Returns the type of this keystore.

getType() - Method in class java.security.Policy

Return the type of this Policy.

getType() - Method in class java.security.Provider.Service

Get the type of this service.

getType() - Method in interface java.sql.ResultSet

Retrieves the type of this ResultSet object.

getType() - Method in interface javax.accessibility.AccessibleTableModelChange

Returns the type of event.

getType() - Method in class javax.management.MBeanAttributeInfo

Returns the class name of the attribute.

getType() - Method in class javax.management.MBeanParameterInfo

Returns the type or class name of the data.

getType() - Method in class javax.management.Notification

Get the notification type.

getType(String) - Method in class javax.management.openmbean.CompositeType

Returns the open type of the item whose name is itemName, or null if this CompositeType instance does not define any item whose name is itemName.

getType() - Method in class javax.naming.event.NamingEvent

Returns the type of this event.

getType() - Method in class javax.naming.ldap.Rdn

Retrieves one of this Rdn's type.

getType() - Method in class javax.naming.RefAddr

Retrieves the address type of this address.

getType() - Method in class javax.net.ssl.SNIMatcher

Returns the server name type of this SNIMatcher object.

getType() - Method in class javax.net.ssl.SNIServerName

Returns the name type of this server name.

getType() - Method in class javax.security.auth.login.Configuration

Return the type of this Configuration.

getType() - Method in class javax.sound.midi.MetaMessage

Obtains the type of the MetaMessage.

getType() - Method in class javax.sound.midi.MidiFileFormat

Obtains the MIDI file type.

getType() - Method in class javax.sound.sampled.AudioFileFormat

Obtains the audio file type, such as WAVE or AU.

getType() - Method in class javax.sound.sampled.Control

Obtains the control's type.

getType() - Method in class javax.sound.sampled.LineEvent

Obtains the event's type.

getType() - Method in class javax.sql.rowset.BaseRowSet

Returns the type of this RowSet object.

getType() - Method in interface javax.swing.event.DocumentEvent

Gets the type of event.

getType() - Method in class javax.swing.event.ListDataEvent

Returns the event type.

getType() - Method in class javax.swing.event.RowSorterEvent

Returns the type of event.

getType() - Method in class javax.swing.event.TableModelEvent

Returns the type of event - one of: INSERT, UPDATE and DELETE.

getType() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange

getType() - Method in class javax.swing.text.AbstractDocument.DefaultDocumentEvent

Returns the type of event.

getType() - Method in class javax.swing.text.DefaultStyledDocument.ElementSpec

Gets the element type.

getType() - Method in class javax.swing.text.html.parser.AttributeList

getType() - Method in class javax.swing.text.html.parser.Element

Get type.

getType() - Method in class javax.swing.text.html.parser.Entity

Gets the type of the entity.

getType() - Method in interface javax.xml.crypto.URIReference

Returns the type of data referenced by this URI.

getType() - Method in interface org.w3c.dom.DOMError

A DOMString indicating which related data is expected in relatedData.

getType() - Method in interface org.w3c.dom.events.Event

The name of the event (case-insensitive).

getType(int) - Method in interface org.xml.sax.AttributeList

Deprecated.

Return the type of an attribute in the list (by position).

getType(String) - Method in interface org.xml.sax.AttributeList

Deprecated.

Return the type of an attribute in the list (by name).

getType(int) - Method in interface org.xml.sax.Attributes

Look up an attribute's type by index.

getType(String, String) - Method in interface org.xml.sax.Attributes

Look up an attribute's type by Namespace name.

getType(String) - Method in interface org.xml.sax.Attributes

Look up an attribute's type by XML qualified (prefixed) name.

getType(int) - Method in class org.xml.sax.helpers.AttributeListImpl

Deprecated.

Get the type of an attribute (by position).

getType(String) - Method in class org.xml.sax.helpers.AttributeListImpl

Deprecated.

Get the type of an attribute (by name).

getType(int) - Method in class org.xml.sax.helpers.AttributesImpl

Return an attribute's type by index.

getType(String, String) - Method in class org.xml.sax.helpers.AttributesImpl

Look up an attribute's type by Namespace-qualified name.

getType(String) - Method in class org.xml.sax.helpers.AttributesImpl

Look up an attribute's type by qualified (prefixed) name.

getTypeArguments() - Method in interface javax.lang.model.type.DeclaredType

Returns the actual type arguments of this type.

getTypeCode() - Method in class java.io.ObjectStreamField

Returns character encoding of field type.

getTypeDescription(File) - Method in class javax.swing.filechooser.FileView

A human readable description of the type of the file.

getTypeDescription(File) - Method in class javax.swing.JFileChooser

Returns the file type.

getTypeDescription(File) - Method in class javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView

getTypeElement(CharSequence) - Method in interface javax.lang.model.util.Elements

Returns a type element given its canonical name.

getTypeInfo() - Method in interface java.sql.DatabaseMetaData

Retrieves a description of all the data types supported by this database.

getTypeInfoProvider() - Method in class javax.xml.validation.ValidatorHandler

Obtains the TypeInfoProvider implementation of this ValidatorHandler.

getTypeMap() - Method in interface java.sql.Connection

Retrieves the Map object associated with this Connection object.

getTypeMap() - Method in class javax.sql.rowset.BaseRowSet

Retrieves the type map associated with the Connection object for this RowSet object.

getTypeMap() - Method in interface javax.sql.RowSet

Retrieves the Map object associated with this RowSet object, which specifies the custom mapping of SQL user-defined types, if any.

getTypeMirror() - Method in exception javax.lang.model.type.MirroredTypeException

Returns the type mirror corresponding to the type being accessed.

getTypeMirrors() - Method in exception javax.lang.model.type.MirroredTypesException

Returns the type mirrors corresponding to the types being accessed.

getTypeName() - Method in class java.lang.Class

Return an informative string for the name of this type.

getTypeName() - Method in interface java.lang.reflect.Type

Returns a string describing this type, including information about any type parameters.

getTypeName() - Method in class javax.management.openmbean.OpenType

Returns the name of this OpenType instance.

getTypeName() - Method in interface org.w3c.dom.TypeInfo

The name of a type declared for the associated element or attribute, or null if unknown.

getTypeNamespace() - Method in interface org.w3c.dom.TypeInfo

The namespace of the type declared for the associated element or attribute or null if the element does not have declaration or if no namespace information is available.

getTypeParameters() - Method in class java.lang.Class

Returns an array of TypeVariable objects that represent the type variables declared by the generic declaration represented by this GenericDeclaration object, in declaration order.

getTypeParameters() - Method in class java.lang.reflect.Constructor

Returns an array of TypeVariable objects that represent the type variables declared by the generic declaration represented by this GenericDeclaration object, in declaration order.

getTypeParameters() - Method in class java.lang.reflect.Executable

Returns an array of TypeVariable objects that represent the type variables declared by the generic declaration represented by this GenericDeclaration object, in declaration order.

getTypeParameters() - Method in interface java.lang.reflect.GenericDeclaration

Returns an array of TypeVariable objects that represent the type variables declared by the generic declaration represented by this GenericDeclaration object, in declaration order.

getTypeParameters() - Method in class java.lang.reflect.Method

Returns an array of TypeVariable objects that represent the type variables declared by the generic declaration represented by this GenericDeclaration object, in declaration order.

getTypeParameters() - Method in interface javax.lang.model.element.ExecutableElement

Returns the formal type parameters of this executable in declaration order.

getTypeParameters() - Method in interface javax.lang.model.element.Parameterizable

Returns the formal type parameters of the type element in declaration order.

getTypeParameters() - Method in interface javax.lang.model.element.TypeElement

Returns the formal type parameters of this type element in declaration order.

getTypeString() - Method in class java.io.ObjectStreamField

Return the JVM type signature.

getTypeUtils() - Method in interface javax.annotation.processing.ProcessingEnvironment

Returns an implementation of some utility methods for operating on types.

getTypeVariables() - Method in interface javax.lang.model.type.ExecutableType

Returns the type variables declared by the formal type parameters of this executable.

getUDTs(String, String, String, int[]) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of the user-defined types (UDTs) defined in a particular schema.

getUI(int, String) - Method in class javax.print.ServiceUIFactory

Get a UI object which may be cast to the requested UI type by the application and used in its user interface.

getUI() - Method in class javax.swing.AbstractButton

Returns the L&F object that renders this component.

getUI() - Method in class javax.swing.JColorChooser

Returns the L&F object that renders this component.

getUI() - Method in class javax.swing.JComboBox

Returns the L&F object that renders this component.

getUI() - Method in class javax.swing.JDesktopPane

Returns the L&F object that renders this component.

getUI() - Method in class javax.swing.JFileChooser

Gets the UI object which implements the L&F for this component.

getUI() - Method in class javax.swing.JInternalFrame

Returns the look-and-feel object that renders this component.

getUI() - Method in class javax.swing.JInternalFrame.JDesktopIcon

Returns the look-and-feel object that renders this component.

getUI() - Method in class javax.swing.JLabel

Returns the L&F object that renders this component.

getUI() - Method in class javax.swing.JLayer

Returns the LayerUI for this JLayer.

getUI() - Method in class javax.swing.JList

Returns the ListUI, the look and feel object that renders this component.

getUI() - Method in class javax.swing.JMenuBar

Returns the menubar's current UI.

getUI() - Method in class javax.swing.JOptionPane

Returns the UI object which implements the L&F for this component.

getUI() - Method in class javax.swing.JPanel

Returns the look and feel (L&amp;F) object that renders this component.

getUI() - Method in class javax.swing.JPopupMenu

Returns the look and feel (L&F) object that renders this component.

getUI() - Method in class javax.swing.JProgressBar

Returns the look-and-feel object that renders this component.

getUI() - Method in class javax.swing.JRootPane

Returns the L&F object that renders this component.

getUI() - Method in class javax.swing.JScrollBar

Returns the delegate that implements the look and feel for this component.

getUI() - Method in class javax.swing.JScrollPane

Returns the look and feel (L&F) object that renders this component.

getUI() - Method in class javax.swing.JSeparator

Returns the L&F object that renders this component.

getUI() - Method in class javax.swing.JSlider

Gets the UI object which implements the L&F for this component.

getUI() - Method in class javax.swing.JSpinner

Returns the look and feel (L&F) object that renders this component.

getUI() - Method in class javax.swing.JSplitPane

Returns the SplitPaneUI that is providing the current look and feel.

getUI() - Method in class javax.swing.JTabbedPane

Returns the UI object which implements the L&F for this component.

getUI() - Method in class javax.swing.JTable

Returns the L&F object that renders this component.

getUI() - Method in class javax.swing.JToolBar

Returns the tool bar's current UI.

getUI() - Method in class javax.swing.JToolTip

Returns the L&F object that renders this component.

getUI() - Method in class javax.swing.JTree

Returns the L&F object that renders this component.

getUI() - Method in class javax.swing.JViewport

Returns the L&F object that renders this component.

getUI() - Method in class javax.swing.table.JTableHeader

Returns the look and feel (L&F) object that renders this component.

getUI() - Method in class javax.swing.text.JTextComponent

Fetches the user-interface factory for this text-oriented editor.

getUI(JComponent) - Method in class javax.swing.UIDefaults

Creates an ComponentUI implementation for the specified component.

getUI(JComponent) - Static method in class javax.swing.UIManager

Returns the appropriate ComponentUI implementation for target.

getUIActionMap(JComponent) - Static method in class javax.swing.SwingUtilities

Returns the ActionMap provided by the UI in component component.

getUIClass(String, ClassLoader) - Method in class javax.swing.UIDefaults

The value of get(uidClassID) must be the String name of a class that implements the corresponding ComponentUI class.

getUIClass(String) - Method in class javax.swing.UIDefaults

Returns the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JButton

Returns a string that specifies the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JCheckBox

Returns a string that specifies the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JCheckBoxMenuItem

Returns the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JColorChooser

Returns the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JComboBox

Returns the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JComponent

Returns the UIDefaults key used to look up the name of the swing.plaf.ComponentUI class that defines the look and feel for this component.

getUIClassID() - Method in class javax.swing.JDesktopPane

Returns the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JEditorPane

Gets the class ID for the UI.

getUIClassID() - Method in class javax.swing.JFileChooser

Returns a string that specifies the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JFormattedTextField

Gets the class ID for a UI.

getUIClassID() - Method in class javax.swing.JInternalFrame

Returns the name of the look-and-feel class that renders this component.

getUIClassID() - Method in class javax.swing.JInternalFrame.JDesktopIcon

Returns the name of the look-and-feel class that renders this component.

getUIClassID() - Method in class javax.swing.JLabel

Returns a string that specifies the name of the l&f class that renders this component.

getUIClassID() - Method in class javax.swing.JList

Returns "ListUI", the UIDefaults key used to look up the name of the javax.swing.plaf.ListUI class that defines the look and feel for this component.

getUIClassID() - Method in class javax.swing.JMenu

Returns the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JMenuBar

Returns the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JMenuItem

Returns the suffix used to construct the name of the L&F class used to render this component.

getUIClassID() - Method in class javax.swing.JOptionPane

Returns the name of the UI class that implements the L&F for this component.

getUIClassID() - Method in class javax.swing.JPanel

Returns a string that specifies the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JPasswordField

Returns the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JPopupMenu

Returns the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JPopupMenu.Separator

Returns the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JProgressBar

Returns the name of the look-and-feel class that renders this component.

getUIClassID() - Method in class javax.swing.JRadioButton

Returns the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JRadioButtonMenuItem

Returns the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JRootPane

Returns a string that specifies the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JScrollBar

Returns the name of the LookAndFeel class for this component.

getUIClassID() - Method in class javax.swing.JScrollPane

Returns the suffix used to construct the name of the L&F class used to render this component.

getUIClassID() - Method in class javax.swing.JSeparator

Returns the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JSlider

Returns the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JSpinner

Returns the suffix used to construct the name of the look and feel (L&F) class used to render this component.

getUIClassID() - Method in class javax.swing.JSplitPane

Returns the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JTabbedPane

Returns the name of the UI class that implements the L&F for this component.

getUIClassID() - Method in class javax.swing.JTable

Returns the suffix used to construct the name of the L&F class used to render this component.

getUIClassID() - Method in class javax.swing.JTextArea

Returns the class ID for the UI.

getUIClassID() - Method in class javax.swing.JTextField

Gets the class ID for a UI.

getUIClassID() - Method in class javax.swing.JTextPane

Returns the class ID for the UI.

getUIClassID() - Method in class javax.swing.JToggleButton

Returns a string that specifies the name of the l&f class that renders this component.

getUIClassID() - Method in class javax.swing.JToolBar

Returns the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JToolBar.Separator

Returns the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JToolTip

Returns the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JTree

Returns the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.JViewport

Returns a string that specifies the name of the L&F class that renders this component.

getUIClassID() - Method in class javax.swing.table.JTableHeader

Returns the suffix used to construct the name of the look and feel (L&F) class used to render this component.

getUIClassNamesForRole(int) - Method in class javax.print.ServiceUIFactory

Given a UI role obtained from this factory obtain the UI types available from this factory which implement this role.

getUIError(String) - Method in class javax.swing.UIDefaults

If getUI() fails for any reason, it calls this method before returning null.

getUIInputMap(JComponent, int) - Static method in class javax.swing.SwingUtilities

Returns the InputMap provided by the UI for condition condition in component component.

getUIs() - Method in class javax.swing.plaf.multi.MultiButtonUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiColorChooserUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiComboBoxUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiDesktopIconUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiDesktopPaneUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiFileChooserUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiInternalFrameUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiLabelUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiListUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiMenuBarUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiMenuItemUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiOptionPaneUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiPanelUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiPopupMenuUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiProgressBarUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiRootPaneUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiScrollBarUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiScrollPaneUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiSeparatorUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiSliderUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiSpinnerUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiSplitPaneUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiTabbedPaneUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiTableHeaderUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiTableUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiTextUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiToolBarUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiToolTipUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiTreeUI

Returns the list of UIs associated with this multiplexing UI.

getUIs() - Method in class javax.swing.plaf.multi.MultiViewportUI

Returns the list of UIs associated with this multiplexing UI.

getUnallocatedSpace() - Method in class java.nio.file.FileStore

Returns the number of unallocated bytes in the file store.

getUnarrivedParties() - Method in class java.util.concurrent.Phaser

Returns the number of registered parties that have not yet arrived at the current phase of this phaser.

getUnboundInstance(File) - Static method in class javax.security.auth.kerberos.KeyTab

Returns an unbound KeyTab instance from a File object.

getUnboundInstance() - Static method in class javax.security.auth.kerberos.KeyTab

Returns the default unbound KeyTab instance.

getUncaughtExceptionHandler() - Method in class java.lang.Thread

Returns the handler invoked when this thread abruptly terminates due to an uncaught exception.

getUncaughtExceptionHandler() - Method in class java.util.concurrent.ForkJoinPool

Returns the handler for internal worker threads that terminate due to unrecoverable errors encountered while executing tasks.

getUndeclaredThrowable() - Method in exception java.lang.reflect.UndeclaredThrowableException

Returns the Throwable instance wrapped in this UndeclaredThrowableException, which may be null.

getUnderlineOffset() - Method in class java.awt.font.LineMetrics

Returns the position of the underline relative to the baseline.

getUnderlineThickness() - Method in class java.awt.font.LineMetrics

Returns the thickness of the underline.

getUndoableEditListeners() - Method in class javax.swing.text.AbstractDocument

Returns an array of all the undoable edit listeners registered on this document.

getUndoableEditListeners() - Method in class javax.swing.undo.UndoableEditSupport

Returns an array of all the UndoableEditListeners added to this UndoableEditSupport with addUndoableEditListener().

getUndoOrRedoPresentationName() - Method in class javax.swing.undo.UndoManager

Convenience method that returns either getUndoPresentationName or getRedoPresentationName.

getUndoPresentationName() - Method in class javax.swing.text.AbstractDocument.DefaultDocumentEvent

Provides a localized, human readable description of the undoable form of this edit, e.g.

getUndoPresentationName() - Method in class javax.swing.undo.AbstractUndoableEdit

Retreives the value from the defaults table with key AbstractUndoableEdit.undoText and returns that value followed by a space, followed by getPresentationName.

getUndoPresentationName() - Method in class javax.swing.undo.CompoundEdit

Returns getUndoPresentationName from the last UndoableEdit added to edits.

getUndoPresentationName() - Method in interface javax.swing.undo.UndoableEdit

Returns a localized, human-readable description of the undoable form of this edit, suitable for use as an Undo menu item, for example.

getUndoPresentationName() - Method in class javax.swing.undo.UndoManager

Returns a description of the undoable form of this edit.

getUnexecutedModifications() - Method in exception javax.naming.directory.AttributeModificationException

Retrieves the unexecuted modification list.

getUnicodeLocaleAttributes() - Method in class java.util.Locale

Returns the set of unicode locale attributes associated with this locale, or the empty set if it has no attributes.

getUnicodeLocaleKeys() - Method in class java.util.Locale

Returns the set of Unicode locale keys defined by this locale, or the empty set if this locale has none.

getUnicodeLocaleType(String) - Method in class java.util.Locale

Returns the Unicode locale type associated with the specified Unicode locale key for this locale.

getUnicodeStream(int) - Method in interface java.sql.ResultSet

Deprecated.
use getCharacterStream in place of getUnicodeStream

getUnicodeStream(String) - Method in interface java.sql.ResultSet

Deprecated.
use getCharacterStream instead

getUnitIncrement() - Method in interface java.awt.Adjustable

Gets the unit value increment for the adjustable object.

getUnitIncrement() - Method in class java.awt.Scrollbar

Gets the unit increment for this scrollbar.

getUnitIncrement() - Method in class java.awt.ScrollPaneAdjustable

getUnitIncrement(int) - Method in class javax.swing.JScrollBar

Returns the amount to change the scrollbar's value by, given a unit up/down request.

getUnitIncrement() - Method in class javax.swing.JScrollBar

For backwards compatibility with java.awt.Scrollbar.

getUnitIncrement(int) - Method in class javax.swing.JScrollPane.ScrollBar

Computes the unit increment for scrolling if the viewport's view is a Scrollable object.

getUnits() - Method in interface java.time.chrono.ChronoPeriod

Gets the set of units supported by this period.

getUnits() - Method in class java.time.Duration

Gets the set of units supported by this duration.

getUnits() - Method in class java.time.Period

Gets the set of units supported by this period.

getUnits() - Method in interface java.time.temporal.TemporalAmount

Returns the list of units uniquely defining the value of this TemporalAmount.

getUnits() - Method in class javax.sound.sampled.FloatControl

Obtains the label for the units in which the control's values are expressed, such as "dB" or "frames per second."

getUnitsToScroll() - Method in class java.awt.event.MouseWheelEvent

This is a convenience method to aid in the implementation of the common-case MouseWheelListener - to scroll a ScrollPane or JScrollPane by an amount which conforms to the platform settings.

getUnknownAnnotationValue() - Method in exception javax.lang.model.element.UnknownAnnotationValueException

Returns the unknown annotation value.

getUnknownElement() - Method in exception javax.lang.model.element.UnknownElementException

Returns the unknown element.

getUnknownType() - Method in exception javax.lang.model.type.UnknownTypeException

Returns the unknown type.

getUnloadedClassCount() - Method in interface java.lang.management.ClassLoadingMXBean

Returns the total number of classes unloaded since the Java virtual machine has started execution.

getUnmarshallerHandler() - Method in interface javax.xml.bind.Unmarshaller

Get an unmarshaller handler object that can be used as a component in an XML pipeline.

getUnnormalizedComponents(float[], int, int[], int) - Method in class java.awt.image.ColorModel

Returns an array of all of the color/alpha components in unnormalized form, given a normalized component array.

getUnnormalizedComponents(float[], int, int[], int) - Method in class java.awt.image.ComponentColorModel

Returns an array of all of the color/alpha components in unnormalized form, given a normalized component array.

getUnresolvedActions() - Method in class java.security.UnresolvedPermission

Get the actions for the underlying permission that has not been resolved.

getUnresolvedCerts() - Method in class java.security.UnresolvedPermission

Get the signer certificates (without any supporting chain) for the underlying permission that has not been resolved.

getUnresolvedName() - Method in class java.security.UnresolvedPermission

Get the target name of the underlying permission that has not been resolved.

getUnresolvedType() - Method in class java.security.UnresolvedPermission

Get the type (class name) of the underlying permission that has not been resolved.

getUnsupportedAttributes() - Method in interface javax.print.AttributeException

Returns the array of printing attribute classes for which the Print Service instance does not support the attribute at all, or null if there are no such attributes.

getUnsupportedAttributes(DocFlavor, AttributeSet) - Method in interface javax.print.PrintService

Identifies the attributes that are unsupported for a print request in the context of a particular DocFlavor.

getUnsupportedFlavors() - Method in interface javax.print.FlavorException

Returns the unsupported flavors.

getUnsupportedURI() - Method in interface javax.print.URIException

Return the URI.

getUnsupportedValues() - Method in interface javax.print.AttributeException

Returns the array of printing attributes for which the Print Service instance supports the attribute but does not support that particular value of the attribute, or null if there are no such attribute values.

getUnwrappedParent(Component) - Static method in class javax.swing.SwingUtilities

Returns the first ancestor of the component which is not an instance of JLayer.

getUnwrappedView(JViewport) - Static method in class javax.swing.SwingUtilities

Returns the first JViewport's descendant which is not an instance of JLayer.

getUpdateAction() - Method in class javax.swing.plaf.basic.BasicFileChooserUI

getUpdateCount() - Method in interface java.sql.Statement

Retrieves the current result as an update count; if the result is a ResultSet object or there are no more results, -1 is returned.

getUpdateCounts() - Method in exception java.sql.BatchUpdateException

Retrieves the update count for each update statement in the batch update that executed successfully before this exception occurred.

getUpdateLevel() - Method in class javax.swing.undo.UndoableEditSupport

Returns the update level value.

getUpdatePeriod() - Method in class javax.sound.sampled.FloatControl

Obtains the smallest time interval, in microseconds, over which the control's value can change during a shift.

getUpdatePolicy() - Method in class javax.swing.text.DefaultCaret

Gets the caret movement policy on document updates.

getUpdateRect() - Method in class java.awt.event.PaintEvent

Returns the rectangle representing the area which needs to be repainted in response to this event.

getUpdateSelectionOnSort() - Method in class javax.swing.JTable

Returns true if the selection should be updated after sorting.

getUpdateTableInRealTime() - Method in class javax.swing.table.JTableHeader

Obsolete as of Java 2 platform v1.3.

getUpperBound() - Method in interface javax.lang.model.type.TypeVariable

Returns the upper bound of this type variable.

getUpperBounds() - Method in interface java.lang.reflect.WildcardType

Returns an array of Type objects representing the upper bound(s) of this type variable.

getUptime() - Method in interface java.lang.management.RuntimeMXBean

Returns the uptime of the Java virtual machine in milliseconds.

getURI() - Method in class java.security.URIParameter

Returns the URI.

getURI() - Method in class javax.print.attribute.URISyntax

Returns this URI attribute's URI value.

getURI() - Method in interface javax.xml.crypto.dsig.keyinfo.RetrievalMethod

Returns the URI of the referenced KeyInfo information.

getURI() - Method in class javax.xml.crypto.OctetStreamData

Returns the URI String identifying the data object represented by this OctetStreamData.

getURI() - Method in interface javax.xml.crypto.URIReference

Returns the URI of the referenced data object.

getURI() - Method in interface javax.xml.soap.Name

Returns the URI of the namespace for the XML name that this Name object represents.

getUri() - Method in interface org.w3c.dom.DOMLocator

The URI this locator is pointing to, or null if no URI is available.

getURI(int) - Method in interface org.xml.sax.Attributes

Look up an attribute's Namespace URI by index.

getURI(int) - Method in class org.xml.sax.helpers.AttributesImpl

Return an attribute's Namespace URI.

getURI(String) - Method in class org.xml.sax.helpers.NamespaceSupport

Look up a prefix and get the currently-mapped Namespace URI.

getURIDereferencer() - Method in class javax.xml.crypto.dom.DOMCryptoContext

getURIDereferencer() - Method in class javax.xml.crypto.dsig.keyinfo.KeyInfoFactory

Returns a reference to the URIDereferencer that is used by default to dereference URIs in RetrievalMethod objects.

getURIDereferencer() - Method in class javax.xml.crypto.dsig.XMLSignatureFactory

Returns a reference to the URIDereferencer that is used by default to dereference URIs in Reference objects.

getURIDereferencer() - Method in interface javax.xml.crypto.XMLCryptoContext

Returns a URIDereferencer that is used to dereference URIReferences.

getURIReference() - Method in exception javax.xml.crypto.URIReferenceException

Returns the URIReference that was being dereferenced when the exception was thrown.

getURIResolver() - Method in class javax.xml.transform.Transformer

Get an object that will be used to resolve URIs used in document().

getURIResolver() - Method in class javax.xml.transform.TransformerFactory

Get the object that is used by default during the transformation to resolve URIs used in document(), xsl:import, or xsl:include.

getURIs() - Method in interface java.net.CookieStore

Get all URIs which identify the cookies in this cookie store.

getURL() - Method in class java.net.URLConnection

Returns the value of this URLConnection's URL field.

getURL(int) - Method in interface java.sql.CallableStatement

Retrieves the value of the designated JDBC DATALINK parameter as a java.net.URL object.

getURL(String) - Method in interface java.sql.CallableStatement

Retrieves the value of a JDBC DATALINK parameter as a java.net.URL object.

getURL() - Method in interface java.sql.DatabaseMetaData

Retrieves the URL for this DBMS.

getURL(int) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.net.URL object in the Java programming language.

getURL(String) - Method in interface java.sql.ResultSet

Retrieves the value of the designated column in the current row of this ResultSet object as a java.net.URL object in the Java programming language.

getURL() - Method in class javax.activation.URLDataSource

Return the URL used to create this DataSource.

getUrl() - Method in class javax.sql.rowset.BaseRowSet

Retrieves the JDBC URL that this RowSet object's javax.sql.Reader object uses to make a connection with a relational database using a JDBC technology-enabled driver.

getUrl() - Method in interface javax.sql.RowSet

Retrieves the url property this RowSet object will use to create a connection if it uses the DriverManager instead of a DataSource object to establish the connection.

getURL() - Method in class javax.swing.event.HyperlinkEvent

Gets the URL that the link refers to.

getURL() - Method in class javax.xml.bind.helpers.ValidationEventLocatorImpl

getURL() - Method in interface javax.xml.bind.ValidationEventLocator

Return the name of the XML source as a URL if available

getURLContext(String, Hashtable<?, ?>) - Static method in class javax.naming.spi.NamingManager

Creates a context for the given URL scheme id.

getUrlDecoder() - Static method in class java.util.Base64

Returns a Base64.Decoder that decodes using the URL and Filename safe type base64 encoding scheme.

getUrlEncoder() - Static method in class java.util.Base64

Returns a Base64.Encoder that encodes using the URL and Filename safe type base64 encoding scheme.

getURLOrDefaultInitCtx(String) - Method in class javax.naming.InitialContext

Retrieves a context for resolving the string name name.

getURLOrDefaultInitCtx(Name) - Method in class javax.naming.InitialContext

Retrieves a context for resolving name.

getURLPath() - Method in class javax.management.remote.JMXServiceURL

The URL Path part of the Service URL.

getURLs() - Method in class java.net.URLClassLoader

Returns the search path of URLs for loading classes and resources.

getURLs() - Method in class javax.management.loading.MLet

Returns the search path of URLs for loading classes and resources.

getURLs() - Method in interface javax.management.loading.MLetMBean

Returns the search path of URLs for loading classes and resources.

getUsableSpace() - Method in class java.io.File

Returns the number of bytes available to this virtual machine on the partition named by this abstract pathname.

getUsableSpace() - Method in class java.nio.file.FileStore

Returns the number of bytes available to this Java virtual machine on the file store.

getUsage() - Method in class java.lang.management.MemoryNotificationInfo

Returns the memory usage of the memory pool when this notification was constructed.

getUsage() - Method in interface java.lang.management.MemoryPoolMXBean

Returns an estimate of the memory usage of this memory pool.

getUsage() - Method in interface org.ietf.jgss.GSSCredential

Returns the credential usage mode.

getUsage(Oid) - Method in interface org.ietf.jgss.GSSCredential

Returns the credential usage mode for a specific mechanism.

getUsageThreshold() - Method in interface java.lang.management.MemoryPoolMXBean

Returns the usage threshold value of this memory pool in bytes.

getUsageThresholdCount() - Method in interface java.lang.management.MemoryPoolMXBean

Returns the number of times that the memory usage has crossed the usage threshold.

getUseCache() - Static method in class javax.imageio.ImageIO

Returns the current value set by setUseCache, or true if no explicit setting has been made.

getUseCaches() - Method in class java.net.URLConnection

Returns the value of this URLConnection's useCaches field.

getUseCipherSuitesOrder() - Method in class javax.net.ssl.SSLParameters

Returns whether the local cipher suites preference should be honored.

getUseClientMode() - Method in class javax.net.ssl.SSLEngine

Returns true if the engine is set to use client mode when handshaking.

getUseClientMode() - Method in class javax.net.ssl.SSLServerSocket

Returns true if accepted connections will be in SSL client mode.

getUseClientMode() - Method in class javax.net.ssl.SSLSocket

Returns true if the socket is set to use client mode when handshaking.

getUsed() - Method in class java.lang.management.MemoryUsage

Returns the amount of used memory in bytes.

getUseParentHandlers() - Method in class java.util.logging.Logger

Discover whether or not this logger is sending its output to its parent logger.

getUserAction() - Method in class java.awt.dnd.DragSourceDragEvent

This method returns the user drop action.

getUserData(String) - Method in class javax.imageio.metadata.IIOMetadataNode

This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.

getUserData() - Method in class javax.management.Notification

Get the user data.

getUserData(String) - Method in interface org.w3c.dom.Node

Retrieves the object associated to a key on a this node.

getUserDropAction() - Method in class javax.swing.TransferHandler.TransferSupport

Returns the user drop action for the drop, when this TransferSupport represents a drop.

getUserInfo() - Method in class java.net.URI

Returns the decoded user-information component of this URI.

getUserInfo() - Method in class java.net.URL

Gets the userInfo part of this URL.

getUserName() - Method in class java.awt.print.PrinterJob

Gets the name of the printing user.

getUserName() - Method in class java.net.PasswordAuthentication

Returns the user name.

getUserName() - Method in interface java.sql.DatabaseMetaData

Retrieves the user name as known to this database.

getUsername() - Method in class javax.sql.rowset.BaseRowSet

Returns the user name used to create a database connection.

getUsername() - Method in interface javax.sql.RowSet

Retrieves the username used to create a database connection for this RowSet object.

getUserObject() - Method in class javax.imageio.metadata.IIOMetadataNode

Returns the Object value associated with this node.

getUserObject() - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns this node's user object.

getUserObjectPath() - Method in class javax.swing.tree.DefaultMutableTreeNode

Returns the user object path, from the root, to get to this node.

getUserPrincipal() - Method in class javax.xml.ws.spi.http.HttpExchange

Returns the Principal that represents the authenticated user for this HttpExchange.

getUserPrincipal() - Method in interface javax.xml.ws.WebServiceContext

Returns the Principal that identifies the sender of the request currently being serviced.

getUserPrincipalLookupService() - Method in class java.nio.file.FileSystem

Returns the UserPrincipalLookupService for this file system (optional operation).

getUserTextColor() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the user text color of the current theme.

getUserTextColor() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the user text color.

getUserTextFont() - Method in class javax.swing.plaf.metal.DefaultMetalTheme

Returns the user text font.

getUserTextFont() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the user text font of the current theme.

getUserTextFont() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the user text font.

getUtf16Offset() - Method in interface org.w3c.dom.DOMLocator

The UTF-16, as defined in [Unicode] and Amendment 1 of [ISO/IEC 10646], offset into the input source this locator is pointing to or -1 if there is no UTF-16 offset available.

getVAdjustable() - Method in class java.awt.ScrollPane

Returns the ScrollPaneAdjustable object which represents the state of the vertical scrollbar.

getValidCharacters() - Method in class javax.swing.text.MaskFormatter

Returns the valid characters that can be input.

getValidOffsets(LocalDateTime) - Method in class java.time.zone.ZoneRules

Gets the offset applicable at the specified local date-time in these rules.

getValidPixels() - Method in class java.awt.image.IndexColorModel

Returns a BigInteger that indicates the valid/invalid pixels in the colormap.

getValidPolicy() - Method in interface java.security.cert.PolicyNode

Returns the valid policy represented by this node.

getValue() - Method in interface java.awt.Adjustable

Gets the current value of the adjustable object.

getValue() - Method in class java.awt.event.AdjustmentEvent

Returns the current value in the adjustment event.

getValue() - Method in class java.awt.Scrollbar

Gets the current value of this scroll bar.

getValue() - Method in class java.awt.ScrollPaneAdjustable

getValue() - Method in class java.beans.Expression

If the value property of this instance is not already set, this method dynamically finds the method with the specified methodName on this target with these arguments and calls it.

getValue(String) - Method in class java.beans.FeatureDescriptor

Retrieve a named attribute with this feature.

getValue() - Method in interface java.beans.PropertyEditor

Gets the property value.

getValue() - Method in class java.beans.PropertyEditorSupport

Gets the value of the property.

getValue() - Method in class java.net.HttpCookie

Returns the value of the cookie.

getValue() - Method in class java.rmi.dgc.Lease

Returns the lease duration.

getValue() - Method in interface java.security.cert.Extension

Gets the extensions's DER-encoded value.

getValue() - Method in interface java.security.KeyStore.Entry.Attribute

Returns the attribute's value.

getValue() - Method in class java.security.PKCS12Attribute

Returns the attribute's ASN.1 DER-encoded value as a string.

getValue() - Method in class java.text.Annotation

Returns the value of the attribute, which may be null.

getValue() - Method in interface java.time.chrono.Era

Gets the numeric value associated with the era as defined by the chronology.

getValue() - Method in enum java.time.chrono.HijrahEra

Gets the numeric era int value.

getValue() - Method in enum java.time.chrono.IsoEra

Gets the numeric era int value.

getValue() - Method in class java.time.chrono.JapaneseEra

Gets the numeric era int value.

getValue() - Method in enum java.time.chrono.MinguoEra

Gets the numeric era int value.

getValue() - Method in enum java.time.chrono.ThaiBuddhistEra

Gets the numeric era int value.

getValue() - Method in enum java.time.DayOfWeek

Gets the day-of-week int value.

getValue() - Method in enum java.time.Month

Gets the month-of-year int value.

getValue() - Method in class java.time.Year

Gets the year value.

getValue() - Method in class java.util.AbstractMap.SimpleEntry

Returns the value corresponding to this entry.

getValue() - Method in class java.util.AbstractMap.SimpleImmutableEntry

Returns the value corresponding to this entry.

getValue(String) - Method in class java.util.jar.Attributes

Returns the value of the specified attribute name, specified as a string, or null if the attribute was not found.

getValue(Attributes.Name) - Method in class java.util.jar.Attributes

Returns the value of the specified Attributes.Name, or null if the attribute was not found.

getValue() - Method in interface java.util.Map.Entry

Returns the value corresponding to this entry.

getValue() - Method in class java.util.zip.Adler32

Returns the checksum value.

getValue() - Method in interface java.util.zip.Checksum

Returns the current checksum value.

getValue() - Method in class java.util.zip.CRC32

Returns CRC-32 value.

getValue() - Method in interface javax.annotation.processing.Completion

Returns the text of the suggested completion.

getValue() - Method in class javax.crypto.spec.PSource.PSpecified

Returns the value of encoding input P.

getValue() - Method in interface javax.lang.model.element.AnnotationValue

Returns the value.

getValue() - Method in class javax.management.Attribute

Returns an Object that is the value of this attribute.

getValue() - Method in class javax.management.StringValueExp

Returns the string represented by the StringValueExp instance.

getValue() - Method in class javax.naming.ldap.Rdn

Retrieves one of this Rdn's value.

getValue(String) - Method in interface javax.net.ssl.SSLSession

Returns the object bound to the given name in the session's application layer data.

getValue() - Method in class javax.print.attribute.DateTimeSyntax

Returns this date-time attribute's java.util.Date value.

getValue() - Method in class javax.print.attribute.EnumSyntax

Returns this enumeration value's integer value.

getValue() - Method in class javax.print.attribute.IntegerSyntax

Returns this integer attribute's integer value.

getValue() - Method in class javax.print.attribute.TextSyntax

Returns this text attribute's text string.

getValue() - Method in class javax.sound.sampled.BooleanControl

Obtains this control's current value.

getValue() - Method in class javax.sound.sampled.EnumControl

Obtains this control's current value.

getValue() - Method in class javax.sound.sampled.FloatControl

Obtains this control's current value.

getValue(String) - Method in class javax.swing.AbstractAction

Gets the Object associated with the specified key.

getValue(String) - Method in interface javax.swing.Action

Gets one of this object's properties using the associated key.

getValue() - Method in interface javax.swing.BoundedRangeModel

Returns the model's current value.

getValue() - Method in class javax.swing.DefaultBoundedRangeModel

Returns the model's current value.

getValue() - Method in class javax.swing.JFormattedTextField

Returns the last valid value.

getValue() - Method in class javax.swing.JOptionPane

Returns the value the user has selected.

getValue() - Method in class javax.swing.JProgressBar

Returns the progress bar's current value from the BoundedRangeModel.

getValue() - Method in class javax.swing.JScrollBar

Returns the scrollbar's value.

getValue() - Method in class javax.swing.JSlider

Returns the slider's current value from the BoundedRangeModel.

getValue() - Method in class javax.swing.JSpinner

Returns the current value of the model, typically this value is displayed by the editor.

getValue(int) - Method in class javax.swing.RowFilter.Entry

Returns the value at the specified index.

getValue() - Method in class javax.swing.SpinnerDateModel

Returns the current element in this sequence of Dates.

getValue() - Method in class javax.swing.SpinnerListModel

Returns the current element of the sequence.

getValue() - Method in interface javax.swing.SpinnerModel

The current element of the sequence.

getValue() - Method in class javax.swing.SpinnerNumberModel

Returns the value of the current element of the sequence.

getValue() - Method in class javax.swing.Spring

Returns the current value of this Spring.

getValue() - Method in class javax.swing.text.html.Option

Convenience method to return the string associated with the value attribute.

getValue() - Method in class javax.swing.text.html.parser.AttributeList

getValue() - Method in class javax.xml.bind.JAXBElement

Return the content model and attribute values for this element.

getValue(Object) - Static method in class javax.xml.bind.JAXBIntrospector

Get the element value of a JAXB element.

getValue() - Method in interface javax.xml.crypto.dsig.XMLSignature.SignatureValue

Returns the signature value of this SignatureValue.

getValue() - Method in class javax.xml.soap.MimeHeader

Returns the value of this MimeHeader object.

getValue() - Method in interface javax.xml.soap.Node

Returns the value of this node if this is a Text node or the value of the immediate child of this node otherwise.

getValue() - Method in interface javax.xml.stream.events.Attribute

Gets the normalized value of this attribute

getValue() - Method in interface org.w3c.dom.Attr

On retrieval, the value of the attribute is returned as a string.

getValue(int) - Method in interface org.xml.sax.AttributeList

Deprecated.

Return the value of an attribute in the list (by position).

getValue(String) - Method in interface org.xml.sax.AttributeList

Deprecated.

Return the value of an attribute in the list (by name).

getValue(int) - Method in interface org.xml.sax.Attributes

Look up an attribute's value by index.

getValue(String, String) - Method in interface org.xml.sax.Attributes

Look up an attribute's value by Namespace name.

getValue(String) - Method in interface org.xml.sax.Attributes

Look up an attribute's value by XML qualified (prefixed) name.

getValue(int) - Method in class org.xml.sax.helpers.AttributeListImpl

Deprecated.

Get the value of an attribute (by position).

getValue(String) - Method in class org.xml.sax.helpers.AttributeListImpl

Deprecated.

Get the value of an attribute (by name).

getValue(int) - Method in class org.xml.sax.helpers.AttributesImpl

Return an attribute's value by index.

getValue(String, String) - Method in class org.xml.sax.helpers.AttributesImpl

Look up an attribute's value by Namespace-qualified name.

getValue(String) - Method in class org.xml.sax.helpers.AttributesImpl

Look up an attribute's value by qualified (prefixed) name.

getValueAt(int, int) - Method in class javax.swing.DefaultRowSorter.ModelWrapper

Returns the value at the specified index.

getValueAt(int, int) - Method in class javax.swing.JTable

Returns the cell value at row and column.

getValueAt(int, int) - Method in class javax.swing.table.DefaultTableModel

Returns an attribute value for the cell at row and column.

getValueAt(int, int) - Method in interface javax.swing.table.TableModel

Returns the value for the cell at columnIndex and rowIndex.

getValueClass() - Method in class javax.swing.text.DefaultFormatter

Returns that class that is used to create new Objects.

getValueContainsLiteralCharacters() - Method in class javax.swing.text.MaskFormatter

Returns true if stringToValue should return literal characters in the mask.

getValueCount() - Method in class javax.swing.RowFilter.Entry

Returns the number of values in the entry.

getValueIsAdjusting() - Method in class java.awt.event.AdjustmentEvent

Returns true if this is one of multiple adjustment events.

getValueIsAdjusting() - Method in class java.awt.Scrollbar

Returns true if the value is in the process of changing as a result of actions being taken by the user.

getValueIsAdjusting() - Method in class java.awt.ScrollPaneAdjustable

Returns true if the value is in the process of changing as a result of actions being taken by the user.

getValueIsAdjusting() - Method in interface javax.swing.BoundedRangeModel

Returns true if the current changes to the value property are part of a series of changes.

getValueIsAdjusting() - Method in class javax.swing.DefaultBoundedRangeModel

Returns true if the value is in the process of changing as a result of actions being taken by the user.

getValueIsAdjusting() - Method in class javax.swing.DefaultListSelectionModel

Returns true if the selection is undergoing a series of changes.

getValueIsAdjusting() - Method in class javax.swing.event.ListSelectionEvent

Returns whether or not this is one in a series of multiple events, where changes are still being made.

getValueIsAdjusting() - Method in class javax.swing.JList

Returns the value of the selection model's isAdjusting property.

getValueIsAdjusting() - Method in class javax.swing.JScrollBar

True if the scrollbar knob is being dragged.

getValueIsAdjusting() - Method in class javax.swing.JSlider

Returns the valueIsAdjusting property from the model.

getValueIsAdjusting() - Method in interface javax.swing.ListSelectionModel

Returns true if the selection is undergoing a series of changes.

getValueNames() - Method in interface javax.net.ssl.SSLSession

Returns an array of the names of all the application layer data objects bound into the Session.

getValues() - Method in class javax.imageio.plugins.jpeg.JPEGHuffmanTable

Returns an array of shorts containing the values arranged by increasing length of their corresponding codes.

getValues() - Method in class javax.sound.sampled.EnumControl

Returns the set of possible values for this control.

getValues() - Method in class javax.swing.text.html.parser.AttributeList

getVariant() - Method in class java.util.Locale

Returns the variant code for this locale.

getVariation() - Method in class java.awt.im.InputMethodHighlight

Returns the variation of the text range.

getVendor() - Method in enum java.sql.JDBCType

Returns the name of the vendor that supports this data type.

getVendor() - Method in interface java.sql.SQLType

Returns the name of the vendor that supports this data type.

getVendor() - Method in class javax.sound.midi.MidiDevice.Info

Obtains the name of the company who supplies the device.

getVendor() - Method in interface javax.sound.midi.Soundbank

Obtains a string naming the company that provides the sound bank

getVendor() - Method in class javax.sound.sampled.Mixer.Info

Obtains the vendor of the mixer.

getVendor() - Method in class javax.sql.rowset.spi.SyncProvider

Returns the vendor name of this SyncProvider instance

getVendorName() - Method in class javax.imageio.spi.IIOServiceProvider

Returns the name of the vendor responsible for creating this service provider and its associated implementation.

getVendorTypeNumber() - Method in enum java.sql.JDBCType

Returns the vendor specific type number for the data type.

getVendorTypeNumber() - Method in interface java.sql.SQLType

Returns the vendor specific type number for the data type.

getVerifyInputWhenFocusTarget() - Method in class javax.swing.JComponent

Returns the value that indicates whether the input verifier for the current focus owner will be called before this component requests focus.

getVersion() - Method in interface java.awt.font.OpenType

Returns the version of the OpenType font.

getVersion() - Method in interface java.lang.management.OperatingSystemMXBean

Returns the operating system version.

getVersion() - Method in class java.net.HttpCookie

Returns the version of the protocol this cookie complies with.

getVersion() - Method in class java.security.cert.X509Certificate

Gets the version (version number) value from the certificate.

getVersion() - Method in class java.security.cert.X509CRL

Gets the version (version number) value from the CRL.

getVersion() - Method in class java.security.Provider

Returns the version number for this provider.

getVersion() - Method in class javax.crypto.spec.RC5ParameterSpec

Returns the version.

getVersion() - Method in class javax.imageio.spi.IIOServiceProvider

Returns a string describing the version number of this service provider and its associated implementation.

getVersion() - Method in class javax.management.loading.MLetContent

Gets the value of the VERSION attribute of the MLET tag.

getVersion() - Method in interface javax.management.remote.rmi.RMIServer

The version of the RMI Connector Protocol understood by this connector server.

getVersion() - Method in class javax.management.remote.rmi.RMIServerImpl

getVersion() - Method in class javax.management.remote.rmi.RMIServerImpl_Stub

getVersion() - Method in class javax.security.cert.X509Certificate

Gets the version (version number) value from the certificate.

getVersion() - Method in class javax.sound.midi.MidiDevice.Info

Obtains the version of the device.

getVersion() - Method in interface javax.sound.midi.Soundbank

Obtains the version string for the sound bank.

getVersion() - Method in class javax.sound.sampled.Mixer.Info

Obtains the version of the mixer.

getVersion() - Method in class javax.sql.rowset.spi.SyncProvider

Returns the release version of this SyncProvider instance.

getVersion() - Method in interface javax.xml.stream.events.StartDocument

Returns the version of XML of this XML stream

getVersion() - Method in class javax.xml.stream.util.StreamReaderDelegate

getVersion() - Method in interface javax.xml.stream.XMLStreamReader

Get the xml version declared on the xml declaration Returns null if none was declared

getVersionColumns(String, String, String) - Method in interface java.sql.DatabaseMetaData

Retrieves a description of a table's columns that are automatically updated when any value in a row is updated.

getVersionNumber() - Method in class javax.security.auth.kerberos.KerberosKey

Returns the key version number.

getVersions(String) - Static method in class java.time.zone.ZoneRulesProvider

Gets the history of rules for the zone ID.

getVerticalAlignment() - Method in class javax.swing.AbstractButton

Returns the vertical alignment of the text and icon.

getVerticalAlignment() - Method in class javax.swing.JLabel

Returns the alignment of the label's contents along the Y axis.

getVerticalLegBuffer() - Method in class javax.swing.plaf.basic.BasicTreeUI

The vertical element of legs between nodes starts at the bottom of the parent node by default.

getVerticalScrollBar() - Method in class javax.swing.JScrollPane

Returns the vertical scroll bar that controls the viewports vertical view position.

getVerticalScrollBar() - Method in class javax.swing.ScrollPaneLayout

Returns the JScrollBar object that handles vertical scrolling.

getVerticalScrollBarPolicy() - Method in class javax.swing.JScrollPane

Returns the vertical scroll bar policy value.

getVerticalScrollBarPolicy() - Method in class javax.swing.ScrollPaneLayout

Returns the vertical scrollbar-display policy.

getVerticalSliderThumbIcon() - Static method in class javax.swing.plaf.metal.MetalIconFactory

getVerticalTextPosition() - Method in class javax.swing.AbstractButton

Returns the vertical position of the text relative to the icon.

getVerticalTextPosition() - Method in class javax.swing.JLabel

Returns the vertical position of the label's text, relative to its image.

getVetoableChangeListeners() - Method in class java.awt.KeyboardFocusManager

Returns an array of all the vetoable change listeners registered on this keyboard focus manager.

getVetoableChangeListeners(String) - Method in class java.awt.KeyboardFocusManager

Returns an array of all the VetoableChangeListeners associated with the named property.

getVetoableChangeListeners() - Method in class java.beans.VetoableChangeSupport

Returns an array of all the listeners that were added to the VetoableChangeSupport object with addVetoableChangeListener().

getVetoableChangeListeners(String) - Method in class java.beans.VetoableChangeSupport

Returns an array of all the listeners which have been associated with the named property.

getVetoableChangeListeners() - Method in class javax.swing.JComponent

Returns an array of all the vetoable change listeners registered on this component.

getVgap() - Method in class java.awt.BorderLayout

Returns the vertical gap between components.

getVgap() - Method in class java.awt.CardLayout

Gets the vertical gap between components.

getVgap() - Method in class java.awt.FlowLayout

Gets the vertical gap between components and between the components and the borders of the Container.

getVgap() - Method in class java.awt.GridLayout

Gets the vertical gap between components.

getView() - Method in class javax.swing.JLayer

Returns the JLayer's view component or null.

getView() - Method in class javax.swing.JViewport

Returns the JViewport's one child or null.

getView(int) - Method in class javax.swing.text.AsyncBoxView

Gets the nth child view.

getView(int) - Method in class javax.swing.text.CompositeView

Returns the n-th view in this container.

getView(int) - Method in class javax.swing.text.View

Gets the nth child view.

getView() - Method in interface org.w3c.dom.events.UIEvent

The view attribute identifies the AbstractView from which the event was generated.

getViewAtPoint(int, int, Rectangle) - Method in class javax.swing.text.BoxView

Fetches the child view at the given coordinates.

getViewAtPoint(int, int, Rectangle) - Method in class javax.swing.text.CompositeView

Fetches the child view at the given coordinates.

getViewAtPosition(int, Rectangle) - Method in class javax.swing.text.CompositeView

Fetches the child view that represents the given position in the model.

getViewAtPosition(int, Rectangle) - Method in class javax.swing.text.TableView

Fetches the child view that represents the given position in the model.

getViewAtPosition(int, Rectangle) - Method in class javax.swing.text.TableView.TableRow

Fetches the child view that represents the given position in the model.

getViewAttributes(View) - Method in class javax.swing.text.html.StyleSheet

Fetches a set of attributes to use in the view for displaying.

getViewCount() - Method in class javax.swing.text.AsyncBoxView

Returns the number of views in this view.

getViewCount() - Method in class javax.swing.text.CompositeView

Returns the number of child views of this view.

getViewCount() - Method in class javax.swing.text.View

Returns the number of views in this view.

getViewFactory() - Method in class javax.swing.text.DefaultEditorKit

Fetches a factory that is suitable for producing views of any models that are produced by this kit.

getViewFactory() - Method in class javax.swing.text.EditorKit

Fetches a factory that is suitable for producing views of any models that are produced by this kit.

getViewFactory() - Method in class javax.swing.text.html.HTMLEditorKit

Fetch a factory that is suitable for producing views of any models that are produced by this kit.

getViewFactory() - Method in class javax.swing.text.StyledEditorKit

Fetches a factory that is suitable for producing views of any models that are produced by this kit.

getViewFactory() - Method in class javax.swing.text.View

Fetches the ViewFactory implementation that is feeding the view hierarchy.

getViewIndex(int, Position.Bias) - Method in class javax.swing.text.AsyncBoxView

Returns the child view index representing the given position in the model.

getViewIndex(int, Position.Bias) - Method in class javax.swing.text.CompositeView

Returns the child view index representing the given position in the model.

getViewIndex(int, Position.Bias) - Method in class javax.swing.text.View

Returns the child view index representing the given position in the model.

getViewIndex(float, float, Shape) - Method in class javax.swing.text.View

Returns the child view index representing the given position in the view.

getViewIndexAtPoint(float, float, Shape) - Method in class javax.swing.text.AsyncBoxView.ChildLocator

Fetches the child view index at the given point.

getViewIndexAtPosition(int, Position.Bias) - Method in class javax.swing.text.AsyncBoxView

Fetches the child view index representing the given position in the model.

getViewIndexAtPosition(int) - Method in class javax.swing.text.CompositeView

Fetches the child view index representing the given position in the model.

getViewIndexAtPosition(int) - Method in class javax.swing.text.FlowView

Fetches the child view index representing the given position in the model.

getViewIndexAtPosition(int) - Method in class javax.swing.text.ZoneView

Returns the child view index representing the given position in the model.

getViewIndexAtVisualOffset(float) - Method in class javax.swing.text.AsyncBoxView.ChildLocator

Locate the view responsible for an offset into the box along the major axis.

getViewport() - Method in class javax.swing.JScrollPane

Returns the current JViewport.

getViewport() - Method in class javax.swing.ScrollPaneLayout

Returns the JViewport object that displays the scrollable contents.

getViewportBorder() - Method in class javax.swing.JScrollPane

Returns the Border object that surrounds the viewport.

getViewportBorderBounds() - Method in class javax.swing.JScrollPane

Returns the bounds of the viewport's border.

getViewportBorderBounds(JScrollPane) - Method in class javax.swing.ScrollPaneLayout

Deprecated.
As of JDK version Swing1.1 replaced by JScrollPane.getViewportBorderBounds().

getViewportSize() - Method in class java.awt.ScrollPane

Returns the current size of the scroll pane's view port.

getViewPosition() - Method in class javax.swing.JViewport

Returns the view coordinates that appear in the upper left hand corner of the viewport, or 0,0 if there's no view.

getViewRect() - Method in class javax.swing.JViewport

Returns a rectangle whose origin is getViewPosition and size is getExtentSize.

getViewRowCount() - Method in class javax.swing.DefaultRowSorter

Returns the number of rows in the view.

getViewRowCount() - Method in class javax.swing.RowSorter

Returns the number of rows in the view.

getViewSize() - Method in class javax.swing.JViewport

If the view's size hasn't been explicitly set, return the preferred size, otherwise return the view's current size.

getVisible() - Method in class java.awt.Scrollbar

Deprecated.
As of JDK version 1.1, replaced by getVisibleAmount().

getVisibleAdvance() - Method in class java.awt.font.TextLayout

Returns the advance of this TextLayout, minus trailing whitespace.

getVisibleAmount() - Method in interface java.awt.Adjustable

Gets the length of the proportional indicator.

getVisibleAmount() - Method in class java.awt.Scrollbar

Gets the visible amount of this scroll bar.

getVisibleAmount() - Method in class java.awt.ScrollPaneAdjustable

getVisibleAmount() - Method in class javax.swing.JScrollBar

Returns the scrollbar's extent, aka its "visibleAmount".

getVisibleChildCount(TreePath) - Method in class javax.swing.tree.AbstractLayoutCache

Returns the number of visible children for row.

getVisibleChildCount(TreePath) - Method in class javax.swing.tree.FixedHeightLayoutCache

Returns the number of visible children for row.

getVisibleChildCount(TreePath) - Method in class javax.swing.tree.VariableHeightLayoutCache

Returns the number of visible children for path.

getVisibleComponent() - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

getVisibleEditorRect() - Method in class javax.swing.plaf.basic.BasicTextUI

Gets the allocation to give the root View.

getVisibleIndex() - Method in class java.awt.List

Gets the index of the item that was last made visible by the method makeVisible.

getVisibleNamespacePrefixes() - Method in interface javax.xml.soap.SOAPElement

Returns an Iterator over the namespace prefix Strings visible to this element.

getVisiblePathsFrom(TreePath) - Method in class javax.swing.tree.AbstractLayoutCache

Returns an Enumerator that increments over the visible paths starting at the passed in location.

getVisiblePathsFrom(TreePath) - Method in class javax.swing.tree.FixedHeightLayoutCache

Returns an Enumerator that increments over the visible paths starting at the passed in location.

getVisiblePathsFrom(TreePath) - Method in class javax.swing.tree.VariableHeightLayoutCache

Returns an Enumerator that increments over the visible paths starting at the passed in location.

getVisiblePosition() - Method in class java.awt.event.InputMethodEvent

Gets the position that's most important to be visible.

getVisibleRect() - Method in class javax.swing.JComponent

Returns the Component's "visible rectangle" - the intersection of this component's visible rectangle, new Rectangle(0, 0, getWidth(), getHeight()), and all of its ancestors' visible rectangles.

getVisibleRowCount() - Method in class javax.swing.JList

Returns the value of the visibleRowCount property.

getVisibleRowCount() - Method in class javax.swing.JTree

Returns the number of rows that are displayed in the display area.

getVisualBounds() - Method in class java.awt.font.GlyphVector

Returns the visual bounds of this GlyphVector The visual bounds is the bounding box of the outline of this GlyphVector.

getVisualHighlightShape(TextHitInfo, TextHitInfo, Rectangle2D) - Method in class java.awt.font.TextLayout

Returns a path enclosing the visual selection in the specified range, extended to bounds.

getVisualHighlightShape(TextHitInfo, TextHitInfo) - Method in class java.awt.font.TextLayout

Returns a Shape enclosing the visual selection in the specified range, extended to the bounds.

getVisualOtherHit(TextHitInfo) - Method in class java.awt.font.TextLayout

Returns the hit on the opposite side of the specified hit's caret.

getVisualRepresentation(Transferable) - Method in class javax.swing.TransferHandler

Returns an object that establishes the look of a transfer.

getVMID() - Method in class java.rmi.dgc.Lease

Returns the client VMID associated with the lease.

getVmName() - Method in interface java.lang.management.RuntimeMXBean

Returns the Java virtual machine implementation name.

getVmVendor() - Method in interface java.lang.management.RuntimeMXBean

Returns the Java virtual machine implementation vendor.

getVmVersion() - Method in interface java.lang.management.RuntimeMXBean

Returns the Java virtual machine implementation version.

getVoiceStatus() - Method in interface javax.sound.midi.Synthesizer

Obtains the current status of the voices produced by this synthesizer.

getVolatileOffscreenBuffer(Component, int, int) - Method in class javax.swing.RepaintManager

Return a volatile offscreen buffer that should be used as a double buffer with the specified component c.

getVScrollbarWidth() - Method in class java.awt.ScrollPane

Returns the width that would be occupied by a vertical scrollbar, which is independent of whether it is currently displayed by the scroll pane or not.

getW() - Method in interface java.security.interfaces.ECPublicKey

Returns the public point W.

getW() - Method in class java.security.spec.ECPublicKeySpec

Returns the public point W.

getWaitedCount() - Method in class java.lang.management.ThreadInfo

Returns the total number of times that the thread associated with this ThreadInfo waited for notification.

getWaitedTime() - Method in class java.lang.management.ThreadInfo

Returns the approximate accumulated elapsed time (in milliseconds) that the thread associated with this ThreadInfo has waited for notification since thread contention monitoring is enabled.

getWaitingConsumerCount() - Method in class java.util.concurrent.LinkedTransferQueue

getWaitingConsumerCount() - Method in interface java.util.concurrent.TransferQueue

Returns an estimate of the number of consumers waiting to receive elements via BlockingQueue.take() or timed poll.

getWaitingThreads() - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject

Returns a collection containing those threads that may be waiting on this Condition.

getWaitingThreads(AbstractQueuedLongSynchronizer.ConditionObject) - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer

Returns a collection containing those threads that may be waiting on the given condition associated with this synchronizer.

getWaitingThreads() - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject

Returns a collection containing those threads that may be waiting on this Condition.

getWaitingThreads(AbstractQueuedSynchronizer.ConditionObject) - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer

Returns a collection containing those threads that may be waiting on the given condition associated with this synchronizer.

getWaitingThreads(Condition) - Method in class java.util.concurrent.locks.ReentrantLock

Returns a collection containing those threads that may be waiting on the given condition associated with this lock.

getWaitingThreads(Condition) - Method in class java.util.concurrent.locks.ReentrantReadWriteLock

Returns a collection containing those threads that may be waiting on the given condition associated with the write lock.

getWaitQueueLength() - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject

Returns an estimate of the number of threads waiting on this condition.

getWaitQueueLength(AbstractQueuedLongSynchronizer.ConditionObject) - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer

Returns an estimate of the number of threads waiting on the given condition associated with this synchronizer.

getWaitQueueLength() - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject

Returns an estimate of the number of threads waiting on this condition.

getWaitQueueLength(AbstractQueuedSynchronizer.ConditionObject) - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer

Returns an estimate of the number of threads waiting on the given condition associated with this synchronizer.

getWaitQueueLength(Condition) - Method in class java.util.concurrent.locks.ReentrantLock

Returns an estimate of the number of threads waiting on the given condition associated with this lock.

getWaitQueueLength(Condition) - Method in class java.util.concurrent.locks.ReentrantReadWriteLock

Returns an estimate of the number of threads waiting on the given condition associated with the write lock.

getWantClientAuth() - Method in class javax.net.ssl.SSLEngine

Returns true if the engine will request client authentication.

getWantClientAuth() - Method in class javax.net.ssl.SSLParameters

Returns whether client authentication should be requested.

getWantClientAuth() - Method in class javax.net.ssl.SSLServerSocket

Returns true if client authentication will be requested on newly accepted server-mode connections.

getWantClientAuth() - Method in class javax.net.ssl.SSLSocket

Returns true if the socket will request client authentication.

getWantsInput() - Method in class javax.swing.JOptionPane

Returns the value of the wantsInput property.

getWarnings() - Method in interface java.sql.Connection

Retrieves the first warning reported by calls on this Connection object.

getWarnings() - Method in interface java.sql.ResultSet

Retrieves the first warning reported by calls on this ResultSet object.

getWarnings() - Method in interface java.sql.Statement

Retrieves the first warning reported by calls on this Statement object.

getWarningString() - Method in class java.awt.Window

Gets the warning string that is displayed with this window.

getWarningString() - Method in class javax.swing.JInternalFrame

Gets the warning string that is displayed with this internal frame.

getWeekdays() - Method in class java.text.DateFormatSymbols

Gets weekday strings.

getWeeksInWeekYear() - Method in class java.util.Calendar

Returns the number of weeks in the week year represented by this Calendar.

getWeeksInWeekYear() - Method in class java.util.GregorianCalendar

Returns the number of weeks in the week year represented by this GregorianCalendar.

getWeekYear() - Method in class java.util.Calendar

Returns the week year represented by this Calendar.

getWeekYear() - Method in class java.util.GregorianCalendar

Returns the week year represented by this GregorianCalendar.

getWeight() - Method in class java.util.Locale.LanguageRange

Returns the weight of this LanguageRange.

getWestPane() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI

getWhatToShow() - Method in interface org.w3c.dom.ls.LSParserFilter

Tells the LSParser what types of nodes to show to the method LSParserFilter.acceptNode.

getWhatToShow() - Method in interface org.w3c.dom.ls.LSSerializerFilter

Tells the LSSerializer what types of nodes to show to the filter.

getWheelRotation() - Method in class java.awt.event.MouseWheelEvent

Returns the number of "clicks" the mouse wheel was rotated, as an integer.

getWhen() - Method in class java.awt.event.ActionEvent

Returns the timestamp of when this event occurred.

getWhen() - Method in class java.awt.event.InputEvent

Returns the difference in milliseconds between the timestamp of when this event occurred and midnight, January 1, 1970 UTC.

getWhen() - Method in class java.awt.event.InputMethodEvent

Returns the time stamp of when this event occurred.

getWhen() - Method in class java.awt.event.InvocationEvent

Returns the timestamp of when this event occurred.

getWhereClause() - Method in interface javax.sql.rowset.JoinRowSet

Return a SQL-like description of the WHERE clause being used in a JoinRowSet object.

getWhite() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the white color of the current theme.

getWhite() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the white color.

getWholeText() - Method in interface org.w3c.dom.Text

Returns all text of Text nodes logically-adjacent text nodes to this node, concatenated in document order.

getWidth() - Method in class java.awt.Component

Returns the current width of this component.

getWidth() - Method in class java.awt.Dimension

Returns the width of this Dimension in double precision.

getWidth() - Method in class java.awt.DisplayMode

Returns the width of the display, in pixels.

getWidth() - Method in class java.awt.geom.Arc2D.Double

Returns the width of the framing rectangle in double precision.

getWidth() - Method in class java.awt.geom.Arc2D.Float

Returns the width of the framing rectangle in double precision.

getWidth() - Method in class java.awt.geom.Dimension2D

Returns the width of this Dimension in double precision.

getWidth() - Method in class java.awt.geom.Ellipse2D.Double

Returns the width of the framing rectangle in double precision.

getWidth() - Method in class java.awt.geom.Ellipse2D.Float

Returns the width of the framing rectangle in double precision.

getWidth() - Method in class java.awt.geom.Rectangle2D.Double

Returns the width of the framing rectangle in double precision.

getWidth() - Method in class java.awt.geom.Rectangle2D.Float

Returns the width of the framing rectangle in double precision.

getWidth() - Method in class java.awt.geom.RectangularShape

Returns the width of the framing rectangle in double precision.

getWidth() - Method in class java.awt.geom.RoundRectangle2D.Double

Returns the width of the framing rectangle in double precision.

getWidth() - Method in class java.awt.geom.RoundRectangle2D.Float

Returns the width of the framing rectangle in double precision.

getWidth() - Method in class java.awt.image.BufferedImage

Returns the width of the BufferedImage.

getWidth(ImageObserver) - Method in class java.awt.image.BufferedImage

Returns the width of the BufferedImage.

getWidth(ImageObserver) - Method in class java.awt.Image

Determines the width of the image.

getWidth() - Method in class java.awt.image.Kernel

Returns the width of this Kernel.

getWidth() - Method in class java.awt.image.PixelGrabber

Get the width of the pixel buffer (after adjusting for image width).

getWidth() - Method in class java.awt.image.Raster

Returns the width in pixels of the Raster.

getWidth() - Method in interface java.awt.image.renderable.RenderableImage

Gets the width in user coordinate space.

getWidth() - Method in class java.awt.image.renderable.RenderableImageOp

Gets the width in user coordinate space.

getWidth() - Method in interface java.awt.image.RenderedImage

Returns the width of the RenderedImage.

getWidth() - Method in class java.awt.image.SampleModel

Returns the width in pixels.

getWidth() - Method in class java.awt.image.VolatileImage

Returns the width of the VolatileImage.

getWidth() - Method in class java.awt.print.PageFormat

Returns the width, in 1/72nds of an inch, of the page.

getWidth() - Method in class java.awt.print.Paper

Returns the width of the page in 1/72nds of an inch.

getWidth() - Method in class java.awt.Rectangle

Returns the width of the bounding Rectangle in double precision.

getWidth() - Method in exception java.util.IllegalFormatWidthException

Returns the width

getWidth(int) - Method in class javax.imageio.ImageReader

Returns the width in pixels of the given image within the input source.

getWidth(int) - Method in class javax.print.attribute.standard.MediaPrintableArea

Get the width of the printable area in the specified units.

getWidth() - Method in class javax.swing.JComponent

Returns the current width of this component.

getWidth() - Method in class javax.swing.SpringLayout.Constraints

Returns the value of the width property.

getWidth() - Method in class javax.swing.table.TableColumn

Returns the width of the TableColumn.

getWidth() - Method in class javax.swing.text.BoxView

Returns the current width of the box.

getWidthOfHighValueLabel() - Method in class javax.swing.plaf.basic.BasicSliderUI

getWidthOfLowValueLabel() - Method in class javax.swing.plaf.basic.BasicSliderUI

getWidthOfWidestLabel() - Method in class javax.swing.plaf.basic.BasicSliderUI

getWidths() - Method in class java.awt.FontMetrics

Gets the advance widths of the first 256 characters in the Font.

getWildcardType(TypeMirror, TypeMirror) - Method in interface javax.lang.model.util.Types

Returns a new wildcard type argument.

getWindingRule() - Method in class java.awt.geom.FlatteningPathIterator

Returns the winding rule for determining the interior of the path.

getWindingRule() - Method in class java.awt.geom.Path2D

Returns the fill style winding rule.

getWindingRule() - Method in interface java.awt.geom.PathIterator

Returns the winding rule for determining the interior of the path.

getWindow() - Method in class java.awt.event.WindowEvent

Returns the originator of the event.

getWindowAncestor(Component) - Static method in class javax.swing.SwingUtilities

Returns the first Window ancestor of c, or null if c is not contained inside a Window.

getWindowBackground() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the window background color of the current theme.

getWindowBackground() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the window background color.

getWindowDecorationStyle() - Method in class javax.swing.JRootPane

Returns a constant identifying the type of Window decorations the JRootPane is providing.

getWindowFocusListeners() - Method in class java.awt.Window

Returns an array of all the window focus listeners registered on this window.

getWindowListeners() - Method in class java.awt.Window

Returns an array of all the window listeners registered on this window.

getWindows() - Static method in class java.awt.Window

Returns an array of all Windows, both owned and ownerless, created by this application.

getWindowStateListeners() - Method in class java.awt.Window

Returns an array of all the window state listeners registered on this window.

getWindowTitleBackground() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the window title background color of the current theme.

getWindowTitleBackground() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the window title background color.

getWindowTitleFont() - Method in class javax.swing.plaf.metal.DefaultMetalTheme

Returns the window title font.

getWindowTitleFont() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the window title font of the current theme.

getWindowTitleFont() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the window title font.

getWindowTitleForeground() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the window title foreground color of the current theme.

getWindowTitleForeground() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the window title foreground color.

getWindowTitleInactiveBackground() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the window title inactive background color of the current theme.

getWindowTitleInactiveBackground() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the window title inactive background color.

getWindowTitleInactiveForeground() - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Returns the window title inactive foreground color of the current theme.

getWindowTitleInactiveForeground() - Method in class javax.swing.plaf.metal.MetalTheme

Returns the window title inactive foreground color.

getWordEnd(JTextComponent, int) - Static method in class javax.swing.text.Utilities

Determines the end of a word for the given location.

getWordInstance() - Static method in class java.text.BreakIterator

Returns a new BreakIterator instance for word breaks for the default locale.

getWordInstance(Locale) - Static method in class java.text.BreakIterator

Returns a new BreakIterator instance for word breaks for the given locale.

getWordInstance(Locale) - Method in class java.text.spi.BreakIteratorProvider

Returns a new BreakIterator instance for word breaks for the given locale.

getWordSize() - Method in class javax.crypto.spec.RC5ParameterSpec

Returns the word size in bits.

getWordStart(JTextComponent, int) - Static method in class javax.swing.text.Utilities

Determines the start of a word for the given model location.

getWrapSizeLimit(int, boolean, int) - Method in interface org.ietf.jgss.GSSContext

Used to determine limits on the size of the message that can be passed to wrap.

getWrapStyleWord() - Method in class javax.swing.JTextArea

Gets the style of wrapping used if the text area is wrapping lines.

getWritableParent() - Method in class java.awt.image.WritableRaster

Returns the parent WritableRaster (if any) of this WritableRaster, or else null.

getWritableTile(int, int) - Method in class java.awt.image.BufferedImage

Checks out a tile for writing.

getWritableTile(int, int) - Method in interface java.awt.image.WritableRenderedImage

Checks out a tile for writing.

getWritableTileIndices() - Method in class java.awt.image.BufferedImage

Returns an array of Point objects indicating which tiles are checked out for writing.

getWritableTileIndices() - Method in interface java.awt.image.WritableRenderedImage

Returns an array of Point objects indicating which tiles are checked out for writing.

getWriteHoldCount() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock

Queries the number of reentrant write holds on this lock by the current thread.

getWriteMethod() - Method in class java.beans.PropertyDescriptor

Gets the method that should be used to write the property value.

getWriter() - Method in interface javax.script.ScriptContext

Returns the Writer for scripts to use when displaying output.

getWriter() - Method in class javax.script.SimpleScriptContext

Returns the Writer for scripts to use when displaying output.

getWriter() - Method in class javax.swing.text.AbstractWriter

Returns the Writer that is used to output the content.

getWriter() - Method in class javax.xml.transform.stream.StreamResult

Get the character stream that was set with setWriter.

getWriterFileSuffixes() - Static method in class javax.imageio.ImageIO

Returns an array of Strings listing all of the file suffixes associated with the formats understood by the current set of registered writers.

getWriterFormatNames() - Static method in class javax.imageio.ImageIO

Returns an array of Strings listing all of the informal format names understood by the current set of registered writers.

getWriterMIMETypes() - Static method in class javax.imageio.ImageIO

Returns an array of Strings listing all of the MIME types understood by the current set of registered writers.

getWriterServiceProviderName() - Method in class javax.imageio.spi.ImageTranscoderSpi

Returns the fully qualified class name of an ImageWriterSpi class that generates IIOMetadata objects that may be used as input to this transcoder.

getWSDLDocumentLocation() - Method in class javax.xml.ws.Service

Gets the location of the WSDL document for this Service.

getWSDLDocumentLocation() - Method in class javax.xml.ws.spi.ServiceDelegate

Gets the location of the WSDL document for this Service.

getX() - Method in class java.awt.Component

Returns the current x coordinate of the components origin.

getX() - Method in class java.awt.dnd.DragSourceEvent

This method returns the horizontal coordinate of the cursor location in screen coordinates at the moment this event occurred, or zero if the cursor location is not specified for this event.

getX() - Method in class java.awt.event.MouseEvent

Returns the horizontal x position of the event relative to the source component.

getX() - Method in class java.awt.geom.Arc2D.Double

Returns the X coordinate of the upper-left corner of the framing rectangle in double precision.

getX() - Method in class java.awt.geom.Arc2D.Float

Returns the X coordinate of the upper-left corner of the framing rectangle in double precision.

getX() - Method in class java.awt.geom.Ellipse2D.Double

Returns the X coordinate of the upper-left corner of the framing rectangle in double precision.

getX() - Method in class java.awt.geom.Ellipse2D.Float

Returns the X coordinate of the upper-left corner of the framing rectangle in double precision.

getX() - Method in class java.awt.geom.Point2D.Double

Returns the X coordinate of this Point2D in double precision.

getX() - Method in class java.awt.geom.Point2D.Float

Returns the X coordinate of this Point2D in double precision.

getX() - Method in class java.awt.geom.Point2D

Returns the X coordinate of this Point2D in double precision.

getX() - Method in class java.awt.geom.Rectangle2D.Double

Returns the X coordinate of the upper-left corner of the framing rectangle in double precision.

getX() - Method in class java.awt.geom.Rectangle2D.Float

Returns the X coordinate of the upper-left corner of the framing rectangle in double precision.

getX() - Method in class java.awt.geom.RectangularShape

Returns the X coordinate of the upper-left corner of the framing rectangle in double precision.

getX() - Method in class java.awt.geom.RoundRectangle2D.Double

Returns the X coordinate of the upper-left corner of the framing rectangle in double precision.

getX() - Method in class java.awt.geom.RoundRectangle2D.Float

Returns the X coordinate of the upper-left corner of the framing rectangle in double precision.

getX() - Method in class java.awt.Point

Returns the X coordinate of this Point2D in double precision.

getX() - Method in class java.awt.Rectangle

Returns the X coordinate of the bounding Rectangle in double precision.

getX() - Method in interface java.security.interfaces.DSAPrivateKey

Returns the value of the private key, x.

getX() - Method in class java.security.spec.DSAPrivateKeySpec

Returns the private key x.

getX() - Method in interface javax.crypto.interfaces.DHPrivateKey

Returns the private value, x.

getX() - Method in class javax.crypto.spec.DHPrivateKeySpec

Returns the private value x.

getX(int) - Method in class javax.print.attribute.Size2DSyntax

Returns this two-dimensional size attribute's X dimension in the given units as a floating-point value.

getX(int) - Method in class javax.print.attribute.standard.MediaPrintableArea

Get the x location of the origin of the printable area in the specified units.

getX() - Method in class javax.swing.JComponent

Returns the current x coordinate of the component's origin.

getX() - Method in class javax.swing.SpringLayout.Constraints

Returns the value of the x property.

getX1() - Method in class java.awt.geom.CubicCurve2D.Double

Returns the X coordinate of the start point in double precision.

getX1() - Method in class java.awt.geom.CubicCurve2D.Float

Returns the X coordinate of the start point in double precision.

getX1() - Method in class java.awt.geom.CubicCurve2D

Returns the X coordinate of the start point in double precision.

getX1() - Method in class java.awt.geom.Line2D.Double

Returns the X coordinate of the start point in double precision.

getX1() - Method in class java.awt.geom.Line2D.Float

Returns the X coordinate of the start point in double precision.

getX1() - Method in class java.awt.geom.Line2D

Returns the X coordinate of the start point in double precision.

getX1() - Method in class java.awt.geom.QuadCurve2D.Double

Returns the X coordinate of the start point in double in precision.

getX1() - Method in class java.awt.geom.QuadCurve2D.Float

Returns the X coordinate of the start point in double in precision.

getX1() - Method in class java.awt.geom.QuadCurve2D

Returns the X coordinate of the start point in double in precision.

getX2() - Method in class java.awt.geom.CubicCurve2D.Double

Returns the X coordinate of the end point in double precision.

getX2() - Method in class java.awt.geom.CubicCurve2D.Float

Returns the X coordinate of the end point in double precision.

getX2() - Method in class java.awt.geom.CubicCurve2D

Returns the X coordinate of the end point in double precision.

getX2() - Method in class java.awt.geom.Line2D.Double

Returns the X coordinate of the end point in double precision.

getX2() - Method in class java.awt.geom.Line2D.Float

Returns the X coordinate of the end point in double precision.

getX2() - Method in class java.awt.geom.Line2D

Returns the X coordinate of the end point in double precision.

getX2() - Method in class java.awt.geom.QuadCurve2D.Double

Returns the X coordinate of the end point in double precision.

getX2() - Method in class java.awt.geom.QuadCurve2D.Float

Returns the X coordinate of the end point in double precision.

getX2() - Method in class java.awt.geom.QuadCurve2D

Returns the X coordinate of the end point in double precision.

getXAConnection() - Method in interface javax.sql.XADataSource

Attempts to establish a physical database connection that can be used in a distributed transaction.

getXAConnection(String, String) - Method in interface javax.sql.XADataSource

Attempts to establish a physical database connection, using the given user name and password.

getXAResource() - Method in interface javax.sql.XAConnection

Retrieves an XAResource object that the transaction manager will use to manage this XAConnection object's participation in a distributed transaction.

getXMicrometers() - Method in class javax.print.attribute.Size2DSyntax

Returns this two-dimensional size attribute's X dimension in units of micrometers (µm).

getXmlEncoding() - Method in interface org.w3c.dom.Document

An attribute specifying, as part of the XML declaration, the encoding of this document.

getXmlEncoding() - Method in interface org.w3c.dom.Entity

An attribute specifying, as part of the text declaration, the encoding of this entity, when it is an external parsed entity.

getXMLEventReader() - Method in class javax.xml.transform.stax.StAXSource

Get the XMLEventReader used by this StAXSource.

getXMLEventWriter() - Method in class javax.xml.transform.stax.StAXResult

Get the XMLEventWriter used by this StAXResult.

getXMLNode(Object) - Method in class javax.xml.bind.Binder

Gets the XML element associated with the given JAXB object.

getXMLReader() - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

Obtains a configured XMLReader.

getXMLReader() - Method in class javax.xml.parsers.SAXParser

Returns the XMLReader that is encapsulated by the implementation of this class.

getXMLReader() - Method in class javax.xml.transform.sax.SAXSource

Get the XMLReader to be used for the Source.

getXMLReporter() - Method in class javax.xml.stream.XMLInputFactory

The reporter that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.

getXMLResolver() - Method in class javax.xml.stream.XMLInputFactory

The resolver that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.

getXMLSchemaType() - Method in class javax.xml.datatype.Duration

Return the name of the XML Schema date/time type that this instance maps to.

getXMLSchemaType() - Method in class javax.xml.datatype.XMLGregorianCalendar

Return the name of the XML Schema date/time type that this instance maps to.

getXmlStandalone() - Method in interface org.w3c.dom.Document

An attribute specifying, as part of the XML declaration, whether this document is standalone.

getXMLStreamReader() - Method in class javax.xml.transform.stax.StAXSource

Get the XMLStreamReader used by this StAXSource.

getXMLStreamWriter() - Method in class javax.xml.transform.stax.StAXResult

Get the XMLStreamWriter used by this StAXResult.

getXmlVersion() - Method in interface org.w3c.dom.Document

An attribute specifying, as part of the XML declaration, the version number of this document.

getXmlVersion() - Method in interface org.w3c.dom.Entity

An attribute specifying, as part of the text declaration, the version number of this entity, when it is an external parsed entity.

getXMLVersion() - Method in interface org.xml.sax.ext.Locator2

Returns the version of XML used for the entity.

getXMLVersion() - Method in class org.xml.sax.ext.Locator2Impl

Returns the current value of the version property.

getXOnScreen() - Method in class java.awt.event.MouseEvent

Returns the absolute horizontal x position of the event.

getXOrigin() - Method in class java.awt.image.Kernel

Returns the X origin of this Kernel.

getXPath() - Method in class javax.xml.crypto.dsig.spec.XPathFilterParameterSpec

Returns the XPath expression to be evaluated.

getXPathFunctionResolver() - Method in interface javax.xml.xpath.XPath

Return the current function resolver.

getXPathList() - Method in class javax.xml.crypto.dsig.spec.XPathFilter2ParameterSpec

Returns a list of one or more XPathType objects.

getXPathVariableResolver() - Method in interface javax.xml.xpath.XPath

Return the current variable resolver.

getY() - Method in class java.awt.Component

Returns the current y coordinate of the components origin.

getY() - Method in class java.awt.dnd.DragSourceEvent

This method returns the vertical coordinate of the cursor location in screen coordinates at the moment this event occurred, or zero if the cursor location is not specified for this event.

getY() - Method in class java.awt.event.MouseEvent

Returns the vertical y position of the event relative to the source component.

getY() - Method in class java.awt.geom.Arc2D.Double

Returns the Y coordinate of the upper-left corner of the framing rectangle in double precision.

getY() - Method in class java.awt.geom.Arc2D.Float

Returns the Y coordinate of the upper-left corner of the framing rectangle in double precision.

getY() - Method in class java.awt.geom.Ellipse2D.Double

Returns the Y coordinate of the upper-left corner of the framing rectangle in double precision.

getY() - Method in class java.awt.geom.Ellipse2D.Float

Returns the Y coordinate of the upper-left corner of the framing rectangle in double precision.

getY() - Method in class java.awt.geom.Point2D.Double

Returns the Y coordinate of this Point2D in double precision.

getY() - Method in class java.awt.geom.Point2D.Float

Returns the Y coordinate of this Point2D in double precision.

getY() - Method in class java.awt.geom.Point2D

Returns the Y coordinate of this Point2D in double precision.

getY() - Method in class java.awt.geom.Rectangle2D.Double

Returns the Y coordinate of the upper-left corner of the framing rectangle in double precision.

getY() - Method in class java.awt.geom.Rectangle2D.Float

Returns the Y coordinate of the upper-left corner of the framing rectangle in double precision.

getY() - Method in class java.awt.geom.RectangularShape

Returns the Y coordinate of the upper-left corner of the framing rectangle in double precision.

getY() - Method in class java.awt.geom.RoundRectangle2D.Double

Returns the Y coordinate of the upper-left corner of the framing rectangle in double precision.

getY() - Method in class java.awt.geom.RoundRectangle2D.Float

Returns the Y coordinate of the upper-left corner of the framing rectangle in double precision.

getY() - Method in class java.awt.Point

Returns the Y coordinate of this Point2D in double precision.

getY() - Method in class java.awt.Rectangle

Returns the Y coordinate of the bounding Rectangle in double precision.

getY() - Method in interface java.security.interfaces.DSAPublicKey

Returns the value of the public key, y.

getY() - Method in class java.security.spec.DSAPublicKeySpec

Returns the public key y.

getY() - Method in interface javax.crypto.interfaces.DHPublicKey

Returns the public value, y.

getY() - Method in class javax.crypto.spec.DHPublicKeySpec

Returns the public value y.

getY(int) - Method in class javax.print.attribute.Size2DSyntax

Returns this two-dimensional size attribute's Y dimension in the given units as a floating-point value.

getY(int) - Method in class javax.print.attribute.standard.MediaPrintableArea

Get the y location of the origin of the printable area in the specified units.

getY() - Method in class javax.swing.JComponent

Returns the current y coordinate of the component's origin.

getY() - Method in class javax.swing.SpringLayout.Constraints

Returns the value of the y property.

getY1() - Method in class java.awt.geom.CubicCurve2D.Double

Returns the Y coordinate of the start point in double precision.

getY1() - Method in class java.awt.geom.CubicCurve2D.Float

Returns the Y coordinate of the start point in double precision.

getY1() - Method in class java.awt.geom.CubicCurve2D

Returns the Y coordinate of the start point in double precision.

getY1() - Method in class java.awt.geom.Line2D.Double

Returns the Y coordinate of the start point in double precision.

getY1() - Method in class java.awt.geom.Line2D.Float

Returns the Y coordinate of the start point in double precision.

getY1() - Method in class java.awt.geom.Line2D

Returns the Y coordinate of the start point in double precision.

getY1() - Method in class java.awt.geom.QuadCurve2D.Double

Returns the Y coordinate of the start point in double precision.

getY1() - Method in class java.awt.geom.QuadCurve2D.Float

Returns the Y coordinate of the start point in double precision.

getY1() - Method in class java.awt.geom.QuadCurve2D

Returns the Y coordinate of the start point in double precision.

getY2() - Method in class java.awt.geom.CubicCurve2D.Double

Returns the Y coordinate of the end point in double precision.

getY2() - Method in class java.awt.geom.CubicCurve2D.Float

Returns the Y coordinate of the end point in double precision.

getY2() - Method in class java.awt.geom.CubicCurve2D

Returns the Y coordinate of the end point in double precision.

getY2() - Method in class java.awt.geom.Line2D.Double

Returns the Y coordinate of the end point in double precision.

getY2() - Method in class java.awt.geom.Line2D.Float

Returns the Y coordinate of the end point in double precision.

getY2() - Method in class java.awt.geom.Line2D

Returns the Y coordinate of the end point in double precision.

getY2() - Method in class java.awt.geom.QuadCurve2D.Double

Returns the Y coordinate of the end point in double precision.

getY2() - Method in class java.awt.geom.QuadCurve2D.Float

Returns the Y coordinate of the end point in double precision.

getY2() - Method in class java.awt.geom.QuadCurve2D

Returns the Y coordinate of the end point in double precision.

getYear() - Method in class java.sql.Time

Deprecated.

getYear() - Method in class java.time.LocalDate

Gets the year field.

getYear() - Method in class java.time.LocalDateTime

Gets the year field.

getYear() - Method in class java.time.OffsetDateTime

Gets the year field.

getYear() - Method in class java.time.YearMonth

Gets the year field.

getYear() - Method in class java.time.ZonedDateTime

Gets the year field.

getYear() - Method in class java.util.Date

Deprecated.
As of JDK version 1.1, replaced by Calendar.get(Calendar.YEAR) - 1900.

getYear() - Method in class javax.xml.datatype.XMLGregorianCalendar

Return low order component for XML Schema 1.0 dateTime datatype field for year or DatatypeConstants.FIELD_UNDEFINED.

getYears() - Method in class java.time.Period

Gets the amount of years of this period.

getYears() - Method in class javax.xml.datatype.Duration

Get the years value of this Duration as an int or 0 if not present.

getYMicrometers() - Method in class javax.print.attribute.Size2DSyntax

Returns this two-dimensional size attribute's Y dimension in units of micrometers (µm).

getYOnScreen() - Method in class java.awt.event.MouseEvent

Returns the absolute vertical y position of the event.

getYOrigin() - Method in class java.awt.image.Kernel

Returns the Y origin of this Kernel.

getZeroDigit() - Method in class java.text.DecimalFormatSymbols

Gets the character used for zero.

getZeroDigit() - Method in class java.time.format.DecimalStyle

Gets the character that represents zero.

getZone() - Method in interface java.time.chrono.ChronoZonedDateTime

Gets the zone ID, such as 'Europe/Paris'.

getZone() - Method in class java.time.Clock

Gets the time-zone being used to create dates and times.

getZone() - Method in class java.time.format.DateTimeFormatter

Gets the overriding zone to be used during formatting.

getZone() - Method in class java.time.ZonedDateTime

Gets the time-zone, such as 'Europe/Paris'.

getZoneStrings() - Method in class java.text.DateFormatSymbols

Gets time zone strings.

GIF - Static variable in class javax.print.DocFlavor.BYTE_ARRAY

Doc flavor with MIME type = "image/gif", print data representation class name = "[B" (byte array).

GIF - Static variable in class javax.print.DocFlavor.INPUT_STREAM

Doc flavor with MIME type = "image/gif", print data representation class name = "java.io.InputStream" (byte stream).

GIF - Static variable in class javax.print.DocFlavor.URL

Doc flavor with MIME type = "image/gif", print data representation class name = "java.net.URL".

GLAGOLITIC - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "Glagolitic" Unicode character block.

GLASS_PANE - Static variable in class javax.accessibility.AccessibleRole

A pane that is guaranteed to be painted on top of all panes beneath it.

GLASS_PANE_PROPERTY - Static variable in class javax.swing.JInternalFrame

Bound property name.

glassPane - Variable in class javax.swing.JRootPane

The glass pane that overlays the menu bar and content pane, so it can intercept mouse movements and such.

glassPaneDispatcher - Variable in class javax.swing.plaf.basic.BasicInternalFrameUI

GlassPaneDispatcher() - Constructor for class javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher

global - Static variable in class java.util.logging.Logger

Deprecated.
Initialization of this field is prone to deadlocks. The field must be initialized by the Logger class initialization which may cause deadlocks with the LogManager class initialization. In such cases two class initialization wait for each other to complete. The preferred way to get the global logger object is via the call Logger.getGlobal(). For compatibility with old JDK versions where the Logger.getGlobal() is not available use the call Logger.getLogger(Logger.GLOBAL_LOGGER_NAME) or Logger.getLogger("global").

GLOBAL() - Constructor for class javax.xml.bind.annotation.XmlElementDecl.GLOBAL

GLOBAL_LOGGER_NAME - Static variable in class java.util.logging.Logger

GLOBAL_LOGGER_NAME is a name for the global logger.

GLOBAL_SCOPE - Static variable in interface javax.script.ScriptContext

GlobalScope attributes are visible to all engines created by same ScriptEngineFactory.

globalHierarchyLock - Static variable in interface java.beans.beancontext.BeanContext

This global lock is used by both BeanContext and BeanContextServices implementors to serialize changes in a BeanContext hierarchy and any service requests etc.

globalScope - Variable in class javax.script.SimpleScriptContext

This is the global scope bindings.

GlobalScope() - Constructor for class javax.xml.bind.JAXBElement.GlobalScope

GlyphJustificationInfo - Class in java.awt.font

The GlyphJustificationInfo class represents information about the justification properties of a glyph.

GlyphJustificationInfo(float, boolean, int, float, float, boolean, int, float, float) - Constructor for class java.awt.font.GlyphJustificationInfo

Constructs information about the justification properties of a glyph.

GlyphMetrics - Class in java.awt.font

The GlyphMetrics class represents information for a single glyph.

GlyphMetrics(float, Rectangle2D, byte) - Constructor for class java.awt.font.GlyphMetrics

Constructs a GlyphMetrics object.

GlyphMetrics(boolean, float, float, Rectangle2D, byte) - Constructor for class java.awt.font.GlyphMetrics

Constructs a GlyphMetrics object.

GlyphPainter() - Constructor for class javax.swing.text.GlyphView.GlyphPainter

GlyphVector - Class in java.awt.font

A GlyphVector object is a collection of glyphs containing geometric information for the placement of each glyph in a transformed coordinate space which corresponds to the device on which the GlyphVector is ultimately displayed.

GlyphVector() - Constructor for class java.awt.font.GlyphVector

GlyphView - Class in javax.swing.text

A GlyphView is a styled chunk of text that represents a view mapped over an element in the text model.

GlyphView(Element) - Constructor for class javax.swing.text.GlyphView

Constructs a new view wrapped on an element.

GlyphView.GlyphPainter - Class in javax.swing.text

A class to perform rendering of the glyphs.

GMONTH - Static variable in class javax.xml.datatype.DatatypeConstants

Fully qualified name for W3C XML Schema 1.0 datatype gMonth.

GMONTHDAY - Static variable in class javax.xml.datatype.DatatypeConstants

Fully qualified name for W3C XML Schema 1.0 datatype gMonthDay.

GoHomeAction() - Constructor for class javax.swing.plaf.basic.BasicFileChooserUI.GoHomeAction

GoodBreakWeight - Static variable in class javax.swing.text.View

The weight to indicate a view supports breaking, but better opportunities probably exist.

GOPHER - Static variable in class javax.print.attribute.standard.ReferenceUriSchemesSupported

Gopher Protocol.

GOT_FOCUS - Static variable in class java.awt.Event

A component gained the focus.

gotDefault - Variable in class javax.naming.InitialContext

Field indicating whether the initial context has been obtained by calling NamingManager.getInitialContext().

gotFocus(Event, Object) - Method in class java.awt.Component

Deprecated.
As of JDK version 1.1, replaced by processFocusEvent(FocusEvent).

GOTHIC - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "Gothic" Unicode character block.

grabFocus() - Method in class javax.swing.JComponent

Requests that this Component get the input focus, and that this Component's top-level ancestor become the focused Window.

grabPixels() - Method in class java.awt.image.PixelGrabber

Request the Image or ImageProducer to start delivering pixels and wait for all of the pixels in the rectangle of interest to be delivered.

grabPixels(long) - Method in class java.awt.image.PixelGrabber

Request the Image or ImageProducer to start delivering pixels and wait for all of the pixels in the rectangle of interest to be delivered or until the specified timeout has elapsed.

GRADE_CHECK_ALL_AT_COMMIT - Static variable in class javax.sql.rowset.spi.SyncProvider

Indicates a high level optimistic synchronization grade with respect to the originating data source.

GRADE_CHECK_MODIFIED_AT_COMMIT - Static variable in class javax.sql.rowset.spi.SyncProvider

Indicates a low level optimistic synchronization grade with respect to the originating data source.

GRADE_LOCK_WHEN_LOADED - Static variable in class javax.sql.rowset.spi.SyncProvider

Indicates the most pessimistic synchronization grade with respect to the originating data source.

GRADE_LOCK_WHEN_MODIFIED - Static variable in class javax.sql.rowset.spi.SyncProvider

Indicates a pessimistic synchronization grade with respect to the originating data source.

GRADE_NONE - Static variable in class javax.sql.rowset.spi.SyncProvider

Indicates that no synchronization with the originating data source is provided.

GradientPaint - Class in java.awt

The GradientPaint class provides a way to fill a Shape with a linear color gradient pattern.

GradientPaint(float, float, Color, float, float, Color) - Constructor for class java.awt.GradientPaint

Constructs a simple acyclic GradientPaint object.

GradientPaint(Point2D, Color, Point2D, Color) - Constructor for class java.awt.GradientPaint

Constructs a simple acyclic GradientPaint object.

GradientPaint(float, float, Color, float, float, Color, boolean) - Constructor for class java.awt.GradientPaint

Constructs either a cyclic or acyclic GradientPaint object depending on the boolean parameter.

GradientPaint(Point2D, Color, Point2D, Color, boolean) - Constructor for class java.awt.GradientPaint

Constructs either a cyclic or acyclic GradientPaint object depending on the boolean parameter.

GraphicAttribute - Class in java.awt.font

This class is used with the CHAR_REPLACEMENT attribute.

GraphicAttribute(int) - Constructor for class java.awt.font.GraphicAttribute

Constructs a GraphicAttribute.

Graphics - Class in java.awt

The Graphics class is the abstract base class for all graphics contexts that allow an application to draw onto components that are realized on various devices, as well as onto off-screen images.

Graphics() - Constructor for class java.awt.Graphics

Constructs a new Graphics object.

Graphics2D - Class in java.awt

This Graphics2D class extends the Graphics class to provide more sophisticated control over geometry, coordinate transformations, color management, and text layout.

Graphics2D() - Constructor for class java.awt.Graphics2D

Constructs a new Graphics2D object.

GraphicsConfigTemplate - Class in java.awt

The GraphicsConfigTemplate class is used to obtain a valid GraphicsConfiguration.

GraphicsConfigTemplate() - Constructor for class java.awt.GraphicsConfigTemplate

This class is an abstract class so only subclasses can be instantiated.

GraphicsConfiguration - Class in java.awt

The GraphicsConfiguration class describes the characteristics of a graphics destination such as a printer or monitor.

GraphicsConfiguration() - Constructor for class java.awt.GraphicsConfiguration

This is an abstract class that cannot be instantiated directly.

GraphicsDevice - Class in java.awt

The GraphicsDevice class describes the graphics devices that might be available in a particular graphics environment.

GraphicsDevice() - Constructor for class java.awt.GraphicsDevice

This is an abstract class that cannot be instantiated directly.

GraphicsDevice.WindowTranslucency - Enum in java.awt

Kinds of translucency supported by the underlying system.

GraphicsEnvironment - Class in java.awt

The GraphicsEnvironment class describes the collection of GraphicsDevice objects and Font objects available to a Java(tm) application on a particular platform.

GraphicsEnvironment() - Constructor for class java.awt.GraphicsEnvironment

This is an abstract class and cannot be instantiated directly.

gray - Static variable in class java.awt.Color

The color gray.

GRAY - Static variable in class java.awt.Color

The color gray.

GrayFilter - Class in javax.swing

An image filter that "disables" an image by turning it into a grayscale image, and brightening the pixels in the image.

GrayFilter(boolean, int) - Constructor for class javax.swing.GrayFilter

Constructs a GrayFilter object that filters a color image to a grayscale image.

GREATER - Static variable in class javax.xml.datatype.DatatypeConstants

Comparison result.

GREEK - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "Greek and Coptic" Unicode character block.

GREEK_EXTENDED - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "Greek Extended" Unicode character block.

green - Static variable in class java.awt.Color

The color green.

GREEN - Static variable in class java.awt.Color

The color green.

GREENCOMPONENT - Static variable in class java.awt.color.ICC_ProfileRGB

Used to get a gamma value or TRC for the green component.

GregorianCalendar - Class in java.util

GregorianCalendar is a concrete subclass of Calendar and provides the standard calendar system used by most of the world.

GregorianCalendar() - Constructor for class java.util.GregorianCalendar

Constructs a default GregorianCalendar using the current time in the default time zone with the default FORMAT locale.

GregorianCalendar(TimeZone) - Constructor for class java.util.GregorianCalendar

Constructs a GregorianCalendar based on the current time in the given time zone with the default FORMAT locale.

GregorianCalendar(Locale) - Constructor for class java.util.GregorianCalendar

Constructs a GregorianCalendar based on the current time in the default time zone with the given locale.

GregorianCalendar(TimeZone, Locale) - Constructor for class java.util.GregorianCalendar

Constructs a GregorianCalendar based on the current time in the given time zone with the given locale.

GregorianCalendar(int, int, int) - Constructor for class java.util.GregorianCalendar

Constructs a GregorianCalendar with the given date set in the default time zone with the default locale.

GregorianCalendar(int, int, int, int, int) - Constructor for class java.util.GregorianCalendar

Constructs a GregorianCalendar with the given date and time set for the default time zone with the default locale.

GregorianCalendar(int, int, int, int, int, int) - Constructor for class java.util.GregorianCalendar

Constructs a GregorianCalendar with the given date and time set for the default time zone with the default locale.

GridBagConstraints - Class in java.awt

The GridBagConstraints class specifies constraints for components that are laid out using the GridBagLayout class.

GridBagConstraints() - Constructor for class java.awt.GridBagConstraints

Creates a GridBagConstraint object with all of its fields set to their default value.

GridBagConstraints(int, int, int, int, double, double, int, int, Insets, int, int) - Constructor for class java.awt.GridBagConstraints

Creates a GridBagConstraints object with all of its fields set to the passed-in arguments.

GridBagLayout - Class in java.awt

The GridBagLayout class is a flexible layout manager that aligns components vertically, horizontally or along their baseline without requiring that the components be of the same size.

GridBagLayout() - Constructor for class java.awt.GridBagLayout

Creates a grid bag layout manager.

GridBagLayoutInfo - Class in java.awt

The GridBagLayoutInfo is an utility class for GridBagLayout layout manager.

gridColor - Variable in class javax.swing.JTable

The color of the grid.

gridheight - Variable in class java.awt.GridBagConstraints

Specifies the number of cells in a column for the component's display area.

GridLayout - Class in java.awt

The GridLayout class is a layout manager that lays out a container's components in a rectangular grid.

GridLayout() - Constructor for class java.awt.GridLayout

Creates a grid layout with a default of one column per component, in a single row.

GridLayout(int, int) - Constructor for class java.awt.GridLayout

Creates a grid layout with the specified number of rows and columns.

GridLayout(int, int, int, int) - Constructor for class java.awt.GridLayout

Creates a grid layout with the specified number of rows and columns.

gridwidth - Variable in class java.awt.GridBagConstraints

Specifies the number of cells in a row for the component's display area.

gridx - Variable in class java.awt.GridBagConstraints

Specifies the cell containing the leading edge of the component's display area, where the first cell in a row has gridx=0.

gridy - Variable in class java.awt.GridBagConstraints

Specifies the cell at the top of the component's display area, where the topmost cell has gridy=0.

group() - Method in class java.nio.channels.MembershipKey

Returns the multicast group for which this membership key was created.

group() - Method in interface java.nio.file.attribute.PosixFileAttributes

Returns the group owner of the file.

Group - Interface in java.security.acl

This interface is used to represent a group of principals.

group() - Method in class java.util.regex.Matcher

Returns the input subsequence matched by the previous match.

group(int) - Method in class java.util.regex.Matcher

Returns the input subsequence captured by the given group during the previous match operation.

group(String) - Method in class java.util.regex.Matcher

Returns the input subsequence captured by the given named-capturing group during the previous match operation.

group() - Method in interface java.util.regex.MatchResult

Returns the input subsequence matched by the previous match.

group(int) - Method in interface java.util.regex.MatchResult

Returns the input subsequence captured by the given group during the previous match operation.

group - Variable in class javax.swing.DefaultButtonModel

The button group that the button belongs to.

GROUP_BOX - Static variable in class javax.accessibility.AccessibleRole

A GROUP_BOX is a simple container that contains a border around it and contains components inside it.

groupCount() - Method in class java.util.regex.Matcher

Returns the number of capturing groups in this matcher's pattern.

groupCount() - Method in interface java.util.regex.MatchResult

Returns the number of capturing groups in this match result's pattern.

GROUPING_SEPARATOR - Static variable in class java.text.NumberFormat.Field

Constant identifying the grouping separator field.

groupingBy(Function<? super T, ? extends K>) - Static method in class java.util.stream.Collectors

Returns a Collector implementing a "group by" operation on input elements of type T, grouping elements according to a classification function, and returning the results in a Map.

groupingBy(Function<? super T, ? extends K>, Collector<? super T, A, D>) - Static method in class java.util.stream.Collectors

Returns a Collector implementing a cascaded "group by" operation on input elements of type T, grouping elements according to a classification function, and then performing a reduction operation on the values associated with a given key using the specified downstream Collector.

groupingBy(Function<? super T, ? extends K>, Supplier<M>, Collector<? super T, A, D>) - Static method in class java.util.stream.Collectors

Returns a Collector implementing a cascaded "group by" operation on input elements of type T, grouping elements according to a classification function, and then performing a reduction operation on the values associated with a given key using the specified downstream Collector.

groupingByConcurrent(Function<? super T, ? extends K>) - Static method in class java.util.stream.Collectors

Returns a concurrent Collector implementing a "group by" operation on input elements of type T, grouping elements according to a classification function.

groupingByConcurrent(Function<? super T, ? extends K>, Collector<? super T, A, D>) - Static method in class java.util.stream.Collectors

Returns a concurrent Collector implementing a cascaded "group by" operation on input elements of type T, grouping elements according to a classification function, and then performing a reduction operation on the values associated with a given key using the specified downstream Collector.

groupingByConcurrent(Function<? super T, ? extends K>, Supplier<M>, Collector<? super T, A, D>) - Static method in class java.util.stream.Collectors

Returns a concurrent Collector implementing a cascaded "group by" operation on input elements of type T, grouping elements according to a classification function, and then performing a reduction operation on the values associated with a given key using the specified downstream Collector.

GroupLayout - Class in javax.swing

GroupLayout is a LayoutManager that hierarchically groups components in order to position them in a Container.

GroupLayout(Container) - Constructor for class javax.swing.GroupLayout

Creates a GroupLayout for the specified Container.

GroupLayout.Alignment - Enum in javax.swing

Enumeration of the possible ways ParallelGroup can align its children.

GroupLayout.Group - Class in javax.swing

Group provides the basis for the two types of operations supported by GroupLayout: laying out components one after another (SequentialGroup) or aligned (ParallelGroup).

GroupLayout.ParallelGroup - Class in javax.swing

A Group that aligns and sizes it's children.

GroupLayout.SequentialGroup - Class in javax.swing

A Group that positions and sizes its elements sequentially, one after another.

GroupPrincipal - Interface in java.nio.file.attribute

A UserPrincipal representing a group identity, used to determine access rights to objects in a file system.

grow(int, int) - Method in class java.awt.Rectangle

Resizes the Rectangle both horizontally and vertically.

growAbsorb - Variable in class java.awt.font.GlyphJustificationInfo

If true, this glyph absorbs all extra space at this and lower priority levels when it grows.

growLeftLimit - Variable in class java.awt.font.GlyphJustificationInfo

The maximum amount by which the left side of this glyph can grow.

growPriority - Variable in class java.awt.font.GlyphJustificationInfo

The priority level of this glyph as it is growing.

growRightLimit - Variable in class java.awt.font.GlyphJustificationInfo

The maximum amount by which the right side of this glyph can grow.

GSSContext - Interface in org.ietf.jgss

This interface encapsulates the GSS-API security context and provides the security services that are available over the context.

GSSCredential - Interface in org.ietf.jgss

This interface encapsulates the GSS-API credentials for an entity.

GSSException - Exception in org.ietf.jgss

This exception is thrown whenever a GSS-API error occurs, including any mechanism specific error.

GSSException(int) - Constructor for exception org.ietf.jgss.GSSException

Creates a GSSException object with a specified major code.

GSSException(int, int, String) - Constructor for exception org.ietf.jgss.GSSException

Creates a GSSException object with the specified major code, minor code, and minor code textual explanation.

GSSManager - Class in org.ietf.jgss

This class serves as a factory for other important GSS-API classes and also provides information about the mechanisms that are supported.

GSSManager() - Constructor for class org.ietf.jgss.GSSManager

GSSName - Interface in org.ietf.jgss

This interface encapsulates a single GSS-API principal entity.

GT - Static variable in class javax.management.Query

A code representing the Query.gt(javax.management.ValueExp, javax.management.ValueExp) query.

gt(ValueExp, ValueExp) - Static method in class javax.management.Query

Returns a query expression that represents a "greater than" constraint on two values.

Guard - Interface in java.security

This interface represents a guard, which is an object that is used to protect access to another object.

GuardedObject - Class in java.security

A GuardedObject is an object that is used to protect access to another object.

GuardedObject(Object, Guard) - Constructor for class java.security.GuardedObject

Constructs a GuardedObject using the specified object and guard.

guardWithTest(MethodHandle, MethodHandle, MethodHandle) - Static method in class java.lang.invoke.MethodHandles

Makes a method handle which adapts a target method handle, by guarding it with a test, a boolean-valued method handle.

guardWithTest(MethodHandle, MethodHandle) - Method in class java.lang.invoke.SwitchPoint

Returns a method handle which always delegates either to the target or the fallback.

guessContentTypeFromName(String) - Static method in class java.net.URLConnection

Tries to determine the content type of an object, based on the specified "file" component of a URL.

guessContentTypeFromStream(InputStream) - Static method in class java.net.URLConnection

Tries to determine the type of an input stream based on the characters at the beginning of the input stream.

GUJARATI - Static variable in class java.awt.font.NumericShaper

Identifies the GUJARATI range and decimal base.

GUJARATI - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "Gujarati" Unicode character block.

GURMUKHI - Static variable in class java.awt.font.NumericShaper

Identifies the GURMUKHI range and decimal base.

GURMUKHI - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "Gurmukhi" Unicode character block.

GYEAR - Static variable in class javax.xml.datatype.DatatypeConstants

Fully qualified name for W3C XML Schema 1.0 datatype gYear.

GYEARMONTH - Static variable in class javax.xml.datatype.DatatypeConstants

Fully qualified name for W3C XML Schema 1.0 datatype gYearMonth.

GZIP - Static variable in class javax.print.attribute.standard.Compression

GNU zip compression technology described in RFC 1952.

GZIP_MAGIC - Static variable in class java.util.zip.GZIPInputStream

GZIP header magic number.

GZIPInputStream - Class in java.util.zip

This class implements a stream filter for reading compressed data in the GZIP file format.

GZIPInputStream(InputStream, int) - Constructor for class java.util.zip.GZIPInputStream

Creates a new input stream with the specified buffer size.

GZIPInputStream(InputStream) - Constructor for class java.util.zip.GZIPInputStream

Creates a new input stream with a default buffer size.

GZIPOutputStream - Class in java.util.zip

This class implements a stream filter for writing compressed data in the GZIP file format.

GZIPOutputStream(OutputStream, int) - Constructor for class java.util.zip.GZIPOutputStream

Creates a new output stream with the specified buffer size.

GZIPOutputStream(OutputStream, int, boolean) - Constructor for class java.util.zip.GZIPOutputStream

Creates a new output stream with the specified buffer size and flush mode.

GZIPOutputStream(OutputStream) - Constructor for class java.util.zip.GZIPOutputStream

Creates a new output stream with a default buffer size.

GZIPOutputStream(OutputStream, boolean) - Constructor for class java.util.zip.GZIPOutputStream

Creates a new output stream with a default buffer size and the specified flush mode.

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

Skip navigation links

Overview

Package

Class

Use

Tree

Deprecated

Index

Help

Java™ Platform
Standard Ed. 8

Prev Letter

Next Letter

Frames

No Frames

All Classes


H-Index (Java Platform SE 8 )

Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames
  • All Classes
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

H

h - Variable in class java.lang.reflect.Proxy
the invocation handler for this proxy instance.
H1 - Static variable in class javax.swing.text.html.HTML.Tag
H2 - Static variable in class javax.swing.text.html.HTML.Tag
H3 - Static variable in class javax.swing.text.html.HTML.Tag
H4 - Static variable in class javax.swing.text.html.HTML.Tag
H5 - Static variable in class javax.swing.text.html.HTML.Tag
H6 - Static variable in class javax.swing.text.html.HTML.Tag
HALFWIDTH_AND_FULLWIDTH_FORMS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Halfwidth and Fullwidth Forms" Unicode character block.
HALFWIDTH_KATAKANA - Static variable in class java.awt.im.InputSubset
Constant for the halfwidth katakana subset of the Unicode halfwidth and fullwidth forms character block.
HALIGN - Static variable in class javax.swing.text.html.HTML.Attribute
halt(int) - Method in class java.lang.Runtime
Forcibly terminates the currently running Java virtual machine.
HAND_CURSOR - Static variable in class java.awt.Cursor
The hand cursor type.
HAND_CURSOR - Static variable in class java.awt.Frame
Deprecated.
replaced by Cursor.HAND_CURSOR.
handle(BiFunction<? super T, Throwable, ? extends U>) - Method in class java.util.concurrent.CompletableFuture
handle(BiFunction<? super T, Throwable, ? extends U>) - Method in interface java.util.concurrent.CompletionStage
Returns a new CompletionStage that, when this stage completes either normally or exceptionally, is executed with this stage's result and exception as arguments to the supplied function.
handle(Callback[]) - Method in interface javax.security.auth.callback.CallbackHandler
Retrieve or display the information requested in the provided Callbacks.
handle(HttpExchange) - Method in class javax.xml.ws.spi.http.HttpHandler
Handles a given request and generates an appropriate response.
handle(short, String, Object, Node, Node) - Method in interface org.w3c.dom.UserDataHandler
This method is called whenever the node for which this handler is registered is imported or cloned.
handleAsync(BiFunction<? super T, Throwable, ? extends U>) - Method in class java.util.concurrent.CompletableFuture
handleAsync(BiFunction<? super T, Throwable, ? extends U>, Executor) - Method in class java.util.concurrent.CompletableFuture
handleAsync(BiFunction<? super T, Throwable, ? extends U>) - Method in interface java.util.concurrent.CompletionStage
Returns a new CompletionStage that, when this stage completes either normally or exceptionally, is executed using this stage's default asynchronous execution facility, with this stage's result and exception as arguments to the supplied function.
handleAsync(BiFunction<? super T, Throwable, ? extends U>, Executor) - Method in interface java.util.concurrent.CompletionStage
Returns a new CompletionStage that, when this stage completes either normally or exceptionally, is executed using the supplied executor, with this stage's result and exception as arguments to the supplied function.
handleComment(char[], int) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader
handleComment(char[], int) - Method in class javax.swing.text.html.HTMLEditorKit.ParserCallback
handleComment(char[]) - Method in class javax.swing.text.html.parser.DocumentParser
handleComment(char[]) - Method in class javax.swing.text.html.parser.Parser
Called when an HTML comment is encountered.
handleEmptyTag(TagElement) - Method in class javax.swing.text.html.parser.DocumentParser
Handle Empty Tag.
handleEmptyTag(TagElement) - Method in class javax.swing.text.html.parser.Parser
Called when an empty tag is encountered.
handleEndOfLineString(String) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader
This is invoked after the stream has been parsed, but before flush.
handleEndOfLineString(String) - Method in class javax.swing.text.html.HTMLEditorKit.ParserCallback
This is invoked after the stream has been parsed, but before flush.
handleEndTag(HTML.Tag, int) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader
Callback from the parser.
handleEndTag(HTML.Tag, int) - Method in class javax.swing.text.html.HTMLEditorKit.ParserCallback
handleEndTag(TagElement) - Method in class javax.swing.text.html.parser.DocumentParser
Handle End Tag.
handleEndTag(TagElement) - Method in class javax.swing.text.html.parser.Parser
Called when an end tag is encountered.
handleEOFInComment() - Method in class javax.swing.text.html.parser.Parser
handleError(String, int) - Method in class javax.swing.text.html.HTMLEditorKit.ParserCallback
handleError(int, String) - Method in class javax.swing.text.html.parser.DocumentParser
handleError(int, String) - Method in class javax.swing.text.html.parser.Parser
An error has occurred.
handleError(DOMError) - Method in interface org.w3c.dom.DOMErrorHandler
This method is called on the error handler when an error occurs.
handleEvent(Event) - Method in class java.awt.Component
Deprecated.
As of JDK version 1.1 replaced by processEvent(AWTEvent).
handleEvent(ValidationEvent) - Method in class javax.xml.bind.helpers.DefaultValidationEventHandler
handleEvent(ValidationEvent) - Method in class javax.xml.bind.util.ValidationEventCollector
handleEvent(ValidationEvent) - Method in interface javax.xml.bind.ValidationEventHandler
Receive notification of a validation warning or error.
handleEvent(Event) - Method in interface org.w3c.dom.events.EventListener
This method is called whenever an event occurs of the type for which the EventListener interface was registered.
handleExpandControlClick(TreePath, int, int) - Method in class javax.swing.plaf.basic.BasicTreeUI
Messaged when the user clicks the particular row, this invokes toggleExpandState.
handleFault(C) - Method in interface javax.xml.ws.handler.Handler
The handleFault method is invoked for fault message processing.
handleGetObject(String) - Method in class java.util.ListResourceBundle
handleGetObject(String) - Method in class java.util.PropertyResourceBundle
handleGetObject(String) - Method in class java.util.ResourceBundle
Gets an object for the given key from this resource bundle.
handleJustify(float) - Method in class java.awt.font.TextLayout
Justify this layout.
handleKeySet() - Method in class java.util.ListResourceBundle
Returns a Set of the keys contained only in this ResourceBundle.
handleKeySet() - Method in class java.util.PropertyResourceBundle
Returns a Set of the keys contained only in this ResourceBundle.
handleKeySet() - Method in class java.util.ResourceBundle
Returns a Set of the keys contained only in this ResourceBundle.
handleMBeanUnregistration(ObjectName, String) - Method in interface javax.management.relation.Relation
Callback used by the Relation Service when a MBean referenced in a role is unregistered.
handleMBeanUnregistration(ObjectName, String) - Method in class javax.management.relation.RelationSupport
Callback used by the Relation Service when a MBean referenced in a role is unregistered.
handleMessage(C) - Method in interface javax.xml.ws.handler.Handler
The handleMessage method is invoked for normal processing of inbound and outbound messages.
handleNotification(NotificationListener, Notification, Object) - Method in class javax.management.NotificationBroadcasterSupport
This method is called by sendNotification for each listener in order to send the notification to that listener.
handleNotification(Notification, Object) - Method in interface javax.management.NotificationListener
Invoked when a JMX notification occurs.
handleNotification(Notification, Object) - Method in class javax.management.relation.RelationService
Invoked when a JMX notification occurs.
handleOption(String, Iterator<String>) - Method in class javax.tools.ForwardingJavaFileManager
handleOption(String, Iterator<String>) - Method in interface javax.tools.JavaFileManager
Handles one option.
Handler - Class in java.util.logging
A Handler object takes log messages from a Logger and exports them.
Handler() - Constructor for class java.util.logging.Handler
Default constructor.
Handler<C extends MessageContext> - Interface in javax.xml.ws.handler
The Handler interface is the base interface for JAX-WS handlers.
handler - Variable in class javax.xml.ws.spi.http.HttpContext
HandlerBase - Class in org.xml.sax
Deprecated.
This class works with the deprecated DocumentHandler interface. It has been replaced by the SAX2 DefaultHandler class.
HandlerBase() - Constructor for class org.xml.sax.HandlerBase
Deprecated.
HandlerChain - Annotation Type in javax.jws
handleResponse(Response<T>) - Method in interface javax.xml.ws.AsyncHandler
Called when the response to an asynchronous operation is available.
HandlerResolver - Interface in javax.xml.ws.handler
HandlerResolver is an interface implemented by an application to get control over the handler chain set on proxy/dispatch objects at the time of their creation.
handleSimpleTag(HTML.Tag, MutableAttributeSet, int) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader
Callback from the parser.
handleSimpleTag(HTML.Tag, MutableAttributeSet, int) - Method in class javax.swing.text.html.HTMLEditorKit.ParserCallback
handleStartTag(HTML.Tag, MutableAttributeSet, int) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader
Callback from the parser.
handleStartTag(HTML.Tag, MutableAttributeSet, int) - Method in class javax.swing.text.html.HTMLEditorKit.ParserCallback
handleStartTag(TagElement) - Method in class javax.swing.text.html.parser.DocumentParser
Handle Start Tag.
handleStartTag(TagElement) - Method in class javax.swing.text.html.parser.Parser
Called when a start tag is encountered.
handleText(char[], int) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader
Called by the parser to indicate a block of text was encountered.
handleText(char[], int) - Method in class javax.swing.text.html.HTMLEditorKit.ParserCallback
handleText(char[]) - Method in class javax.swing.text.html.parser.DocumentParser
Handle Text.
handleText(char[]) - Method in class javax.swing.text.html.parser.Parser
Called when PCDATA is encountered.
handleTitle(char[]) - Method in class javax.swing.text.html.parser.Parser
Called when an HTML title tag is encountered.
handshakeCompleted(HandshakeCompletedEvent) - Method in interface javax.net.ssl.HandshakeCompletedListener
This method is invoked on registered objects when a SSL handshake is completed.
HandshakeCompletedEvent - Class in javax.net.ssl
This event indicates that an SSL handshake completed on a given SSL connection.
HandshakeCompletedEvent(SSLSocket, SSLSession) - Constructor for class javax.net.ssl.HandshakeCompletedEvent
Constructs a new HandshakeCompletedEvent.
HandshakeCompletedListener - Interface in javax.net.ssl
This interface is implemented by any class which wants to receive notifications about the completion of an SSL protocol handshake on a given SSL connection.
HANGING_BASELINE - Static variable in class java.awt.font.GraphicAttribute
Aligns origin of graphic to hanging baseline of line.
HANGING_BASELINE - Static variable in class java.awt.Font
The baseline used in Devanigiri and similar scripts when laying out text.
HANGUL_COMPATIBILITY_JAMO - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Hangul Compatibility Jamo" Unicode character block.
HANGUL_JAMO - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Hangul Jamo" Unicode character block.
HANGUL_JAMO_EXTENDED_A - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Hangul Jamo Extended-A" Unicode character block.
HANGUL_JAMO_EXTENDED_B - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Hangul Jamo Extended-B" Unicode character block.
HANGUL_SYLLABLES - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Hangul Syllables" Unicode character block.
HANJA - Static variable in class java.awt.im.InputSubset
Constant for all Han characters used in writing Korean, including a subset of the CJK unified ideographs as well as Korean Han characters that may be defined as surrogate characters.
HANUNOO - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Hanunoo" Unicode character block.
hardDriveIcon - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
has_no_active_member() - Method in class org.omg.DynamicAny._DynUnionStub
Returns true if the union has no active member, that is, the unions value consists solely of its discriminator because the discriminator has a value that is not listed as an explicit case label.
has_no_active_member() - Method in interface org.omg.DynamicAny.DynUnionOperations
Returns true if the union has no active member, that is, the unions value consists solely of its discriminator because the discriminator has a value that is not listed as an explicit case label.
hasAlpha() - Method in class java.awt.image.ColorModel
Returns whether or not alpha is supported in this ColorModel.
hasAnchoringBounds() - Method in class java.util.regex.Matcher
Queries the anchoring of region bounds for this matcher.
hasArray() - Method in class java.nio.Buffer
Tells whether or not this buffer is backed by an accessible array.
hasArray() - Method in class java.nio.ByteBuffer
Tells whether or not this buffer is backed by an accessible byte array.
hasArray() - Method in class java.nio.CharBuffer
Tells whether or not this buffer is backed by an accessible char array.
hasArray() - Method in class java.nio.DoubleBuffer
Tells whether or not this buffer is backed by an accessible double array.
hasArray() - Method in class java.nio.FloatBuffer
Tells whether or not this buffer is backed by an accessible float array.
hasArray() - Method in class java.nio.IntBuffer
Tells whether or not this buffer is backed by an accessible int array.
hasArray() - Method in class java.nio.LongBuffer
Tells whether or not this buffer is backed by an accessible long array.
hasArray() - Method in class java.nio.ShortBuffer
Tells whether or not this buffer is backed by an accessible short array.
hasAttribute(String) - Method in class javax.imageio.metadata.IIOMetadataNode
hasAttribute(String) - Method in interface org.w3c.dom.Element
Returns true when an attribute with a given name is specified on this element or has a default value, false otherwise.
hasAttributeNS(String, String) - Method in class javax.imageio.metadata.IIOMetadataNode
Equivalent to hasAttribute(localName).
hasAttributeNS(String, String) - Method in interface org.w3c.dom.Element
Returns true when an attribute with a given local name and namespace URI is specified on this element or has a default value, false otherwise.
hasAttributes() - Method in class javax.imageio.metadata.IIOMetadataNode
hasAttributes() - Method in interface org.w3c.dom.Node
Returns whether this node (if it is an element) has any attributes.
hasBeenExpanded(TreePath) - Method in class javax.swing.JTree
Returns true if the node identified by the path has ever been expanded.
hasBeenInvalidated() - Method in class java.lang.invoke.SwitchPoint
Determines if this switch point has been invalidated yet.
hasChanged() - Method in class java.util.Observable
Tests if this object has changed.
hasCharacteristics(int) - Method in interface java.util.Spliterator
Returns true if this Spliterator's Spliterator.characteristics() contain all of the given characteristics.
hasChildNodes() - Method in class javax.imageio.metadata.IIOMetadataNode
Returns true if this node has child nodes.
hasChildNodes() - Method in interface org.w3c.dom.Node
Returns whether this node has any children.
hasChildren - Variable in class javax.swing.JTree.DynamicUtilTreeNode
Does the this JTree have children? This property is currently not implemented.
hasContended() - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer
Queries whether any threads have ever contended to acquire this synchronizer; that is if an acquire method has ever blocked.
hasContended() - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer
Queries whether any threads have ever contended to acquire this synchronizer; that is if an acquire method has ever blocked.
hasController() - Method in class javax.imageio.IIOParam
Returns true if there is a controller installed for this IIOParam object.
hasController() - Method in class javax.imageio.metadata.IIOMetadata
Returns true if there is a controller installed for this IIOMetadata object.
HasControls - Interface in javax.naming.ldap
This interface is for returning controls with objects returned in NamingEnumerations.
hasCustomComponents - Variable in class javax.swing.plaf.basic.BasicOptionPaneUI
This is set to true in validateComponent if a Component is contained in either the message or the buttons.
hasDefaultValue() - Method in class javax.management.openmbean.OpenMBeanAttributeInfoSupport
Returns true if this OpenMBeanAttributeInfoSupport instance specifies a non-null default value for the described attribute, false otherwise.
hasDefaultValue() - Method in interface javax.management.openmbean.OpenMBeanParameterInfo
Returns true if this parameter has a specified default value, or false otherwise.
hasDefaultValue() - Method in class javax.management.openmbean.OpenMBeanParameterInfoSupport
Returns true if this OpenMBeanParameterInfoSupport instance specifies a non-null default value for the described parameter, false otherwise.
hasDetail() - Method in interface javax.xml.soap.SOAPFault
Returns true if this SOAPFault has a Detail subelement and false otherwise.
hasDynamicLocaleList() - Method in interface java.awt.im.spi.InputMethodDescriptor
Returns whether the list of available locales can change at runtime.
hasEntered - Variable in class javax.swing.plaf.basic.BasicComboPopup
hasEvents() - Method in class javax.xml.bind.util.ValidationEventCollector
Returns true if this event collector contains at least one ValidationEvent.
hasExpired() - Method in class java.net.HttpCookie
Reports whether this HTTP cookie has expired or not.
hasExtensions() - Method in class java.security.cert.X509CRLEntry
Returns true if this CRL entry has extensions.
hasExtensions() - Method in class java.util.Locale
Returns true if this Locale has any extensions.
hasFault() - Method in interface javax.xml.soap.SOAPBody
Indicates whether a SOAPFault object exists in this SOAPBody object.
hasFeature(String, String) - Method in interface org.w3c.dom.DOMImplementation
Test if the DOM implementation implements a specific feature and version, as specified in DOM Features.
hasFocus() - Method in class java.awt.Component
Returns true if this Component is the focus owner.
hasFocus - Variable in class javax.swing.plaf.basic.BasicComboBoxUI
This protected field is implementation specific.
hasFocus - Variable in class javax.swing.tree.DefaultTreeCellRenderer
True if has focus.
hash(Object...) - Static method in class java.util.Objects
Generates a hash code for a sequence of input values.
hash(Object, int) - Method in class org.omg.CORBA.portable.Delegate
Returns an ORB-internal identifier (hashcode) for this object reference.
HashAttributeSet - Class in javax.print.attribute
Class HashAttributeSet provides an AttributeSet implementation with characteristics of a hash map.
HashAttributeSet() - Constructor for class javax.print.attribute.HashAttributeSet
Construct a new, empty attribute set.
HashAttributeSet(Attribute) - Constructor for class javax.print.attribute.HashAttributeSet
Construct a new attribute set, initially populated with the given attribute.
HashAttributeSet(Attribute[]) - Constructor for class javax.print.attribute.HashAttributeSet
Construct a new attribute set, initially populated with the values from the given array.
HashAttributeSet(AttributeSet) - Constructor for class javax.print.attribute.HashAttributeSet
Construct a new attribute set, initially populated with the values from the given set.
HashAttributeSet(Class<?>) - Constructor for class javax.print.attribute.HashAttributeSet
Construct a new, empty attribute set, where the members of the attribute set are restricted to the given interface.
HashAttributeSet(Attribute, Class<?>) - Constructor for class javax.print.attribute.HashAttributeSet
Construct a new attribute set, initially populated with the given attribute, where the members of the attribute set are restricted to the given interface.
HashAttributeSet(Attribute[], Class<?>) - Constructor for class javax.print.attribute.HashAttributeSet
Construct a new attribute set, where the members of the attribute set are restricted to the given interface.
HashAttributeSet(AttributeSet, Class<?>) - Constructor for class javax.print.attribute.HashAttributeSet
Construct a new attribute set, initially populated with the values from the given set where the members of the attribute set are restricted to the given interface.
hashCode() - Method in class java.awt.AlphaComposite
Returns the hashcode for this composite.
hashCode() - Method in class java.awt.AWTKeyStroke
Returns a numeric value for this object that is likely to be unique, making it a good choice as the index value in a hash table.
hashCode() - Method in class java.awt.BasicStroke
Returns the hashcode for this stroke.
hashCode() - Method in class java.awt.Color
Computes the hash code for this Color.
hashCode() - Method in class java.awt.datatransfer.DataFlavor
Returns hash code for this DataFlavor.
hashCode() - Method in class java.awt.Dimension
Returns the hash code for this Dimension.
hashCode() - Method in class java.awt.DisplayMode
Returns a hash code value for the object.
hashCode() - Method in class java.awt.font.FontRenderContext
Return a hashcode for this FontRenderContext.
hashCode() - Method in class java.awt.Font
Returns a hashcode for this Font.
hashCode() - Method in class java.awt.font.ImageGraphicAttribute
Returns a hashcode for this ImageGraphicAttribute.
hashCode() - Method in class java.awt.font.NumericShaper
Returns a hash code for this shaper.
hashCode() - Method in class java.awt.font.ShapeGraphicAttribute
Returns a hashcode for this ShapeGraphicAttribute.
hashCode() - Method in class java.awt.font.TextHitInfo
Returns the hash code.
hashCode() - Method in class java.awt.font.TextLayout
Returns the hash code of this TextLayout.
hashCode() - Method in class java.awt.font.TransformAttribute
hashCode() - Method in class java.awt.geom.AffineTransform
Returns the hashcode for this transform.
hashCode() - Method in class java.awt.geom.Arc2D
Returns the hashcode for this Arc2D.
hashCode() - Method in class java.awt.geom.Ellipse2D
Returns the hashcode for this Ellipse2D.
hashCode() - Method in class java.awt.geom.Point2D
Returns the hashcode for this Point2D.
hashCode() - Method in class java.awt.geom.Rectangle2D
Returns the hashcode for this Rectangle2D.
hashCode() - Method in class java.awt.geom.RoundRectangle2D
Returns the hashcode for this RoundRectangle2D.
hashCode() - Method in class java.awt.image.BandedSampleModel
hashCode() - Method in class java.awt.image.ColorModel
Returns the hash code for this ColorModel.
hashCode() - Method in class java.awt.image.ComponentSampleModel
hashCode() - Method in class java.awt.image.MultiPixelPackedSampleModel
hashCode() - Method in class java.awt.image.PixelInterleavedSampleModel
hashCode() - Method in class java.awt.image.SinglePixelPackedSampleModel
hashCode() - Method in class java.awt.Insets
Returns the hash code for this Insets.
hashCode() - Method in class java.awt.JobAttributes
Returns a hash code value for this JobAttributes.
hashCode() - Method in class java.awt.MenuShortcut
Returns the hashcode for this MenuShortcut.
hashCode() - Method in class java.awt.PageAttributes
Returns a hash code value for this PageAttributes.
hashCode() - Method in class java.awt.RenderingHints
Returns the hash code value for this RenderingHints.
hashCode() - Method in class java.awt.RenderingHints.Key
The hash code for all Key objects will be the same as the system identity code of the object as defined by the System.identityHashCode() method.
hashCode() - Method in class java.beans.IndexedPropertyDescriptor
Returns a hash code value for the object.
hashCode() - Method in class java.beans.PropertyDescriptor
Returns a hash code value for the object.
hashCode() - Method in class java.io.File
Computes a hash code for this abstract pathname.
hashCode() - Method in class java.io.FilePermission
Returns the hash code value for this object.
hashCode() - Method in interface java.lang.annotation.Annotation
Returns the hash code of this annotation, as defined below:
hashCode() - Method in class java.lang.Boolean
Returns a hash code for this Boolean object.
hashCode(boolean) - Static method in class java.lang.Boolean
Returns a hash code for a boolean value; compatible with Boolean.hashCode().
hashCode() - Method in class java.lang.Byte
Returns a hash code for this Byte; equal to the result of invoking intValue().
hashCode(byte) - Static method in class java.lang.Byte
Returns a hash code for a byte value; compatible with Byte.hashCode().
hashCode() - Method in class java.lang.Character
Returns a hash code for this Character; equal to the result of invoking charValue().
hashCode(char) - Static method in class java.lang.Character
Returns a hash code for a char value; compatible with Character.hashCode().
hashCode() - Method in class java.lang.Character.Subset
Returns the standard hash code as defined by the Object.hashCode() method.
hashCode() - Method in class java.lang.Double
Returns a hash code for this Double object.
hashCode(double) - Static method in class java.lang.Double
Returns a hash code for a double value; compatible with Double.hashCode().
hashCode() - Method in class java.lang.Enum
Returns a hash code for this enum constant.
hashCode() - Method in class java.lang.Float
Returns a hash code for this Float object.
hashCode(float) - Static method in class java.lang.Float
Returns a hash code for a float value; compatible with Float.hashCode().
hashCode() - Method in class java.lang.Integer
Returns a hash code for this Integer.
hashCode(int) - Static method in class java.lang.Integer
Returns a hash code for a int value; compatible with Integer.hashCode().
hashCode() - Method in class java.lang.invoke.MethodType
Returns the hash code value for this method type.
hashCode() - Method in class java.lang.Long
Returns a hash code for this Long.
hashCode(long) - Static method in class java.lang.Long
Returns a hash code for a long value; compatible with Long.hashCode().
hashCode() - Method in class java.lang.Object
Returns a hash code value for the object.
hashCode() - Method in class java.lang.Package
Return the hash code computed from the package name.
hashCode() - Method in class java.lang.ProcessBuilder.Redirect
Returns a hash code value for this Redirect.
hashCode() - Method in class java.lang.reflect.Constructor
Returns a hashcode for this Constructor.
hashCode() - Method in class java.lang.reflect.Field
Returns a hashcode for this Field.
hashCode() - Method in class java.lang.reflect.Method
Returns a hashcode for this Method.
hashCode() - Method in class java.lang.reflect.Parameter
Returns a hash code based on the executable's hash code and the index.
hashCode() - Method in class java.lang.Short
Returns a hash code for this Short; equal to the result of invoking intValue().
hashCode(short) - Static method in class java.lang.Short
Returns a hash code for a short value; compatible with Short.hashCode().
hashCode() - Method in class java.lang.StackTraceElement
Returns a hash code value for this stack trace element.
hashCode() - Method in class java.lang.String
Returns a hash code for this string.
hashCode() - Method in class java.math.BigDecimal
Returns the hash code for this BigDecimal.
hashCode() - Method in class java.math.BigInteger
Returns the hash code for this BigInteger.
hashCode() - Method in class java.math.MathContext
Returns the hash code for this MathContext.
hashCode() - Method in class java.net.HttpCookie
Returns the hash code of this HTTP cookie.
hashCode() - Method in class java.net.Inet4Address
Returns a hashcode for this IP address.
hashCode() - Method in class java.net.Inet6Address
Returns a hashcode for this IP address.
hashCode() - Method in class java.net.InetAddress
Returns a hashcode for this IP address.
hashCode() - Method in class java.net.InetSocketAddress
Returns a hashcode for this socket address.
hashCode() - Method in class java.net.InterfaceAddress
Returns a hashcode for this Interface address.
hashCode() - Method in class java.net.NetworkInterface
hashCode() - Method in class java.net.Proxy
Returns a hashcode for this Proxy.
hashCode() - Method in class java.net.SocketPermission
Returns the hash code value for this object.
hashCode() - Method in class java.net.URI
Returns a hash-code value for this URI.
hashCode() - Method in class java.net.URL
Creates an integer suitable for hash table indexing.
hashCode() - Method in class java.net.URLPermission
Returns a hashcode calculated from the hashcode of the actions String and the url string.
hashCode(URL) - Method in class java.net.URLStreamHandler
Provides the default hash calculation.
hashCode() - Method in class java.nio.ByteBuffer
Returns the current hash code of this buffer.
hashCode() - Method in class java.nio.CharBuffer
Returns the current hash code of this buffer.
hashCode() - Method in class java.nio.charset.Charset
Computes a hashcode for this charset.
hashCode() - Method in class java.nio.DoubleBuffer
Returns the current hash code of this buffer.
hashCode() - Method in class java.nio.file.attribute.AclEntry
Returns the hash-code value for this ACL entry.
hashCode() - Method in class java.nio.file.attribute.FileTime
Computes a hash code for this file time.
hashCode() - Method in interface java.nio.file.Path
Computes a hash code for this path.
hashCode() - Method in class java.nio.FloatBuffer
Returns the current hash code of this buffer.
hashCode() - Method in class java.nio.IntBuffer
Returns the current hash code of this buffer.
hashCode() - Method in class java.nio.LongBuffer
Returns the current hash code of this buffer.
hashCode() - Method in class java.nio.ShortBuffer
Returns the current hash code of this buffer.
hashCode() - Method in class java.rmi.activation.ActivationDesc
Return the same hashCode for similar ActivationDescs.
hashCode() - Method in class java.rmi.activation.ActivationGroupDesc.CommandEnvironment
Return identical values for similar CommandEnvironments.
hashCode() - Method in class java.rmi.activation.ActivationGroupDesc
Produce identical numbers for similar ActivationGroupDescs.
hashCode() - Method in class java.rmi.activation.ActivationGroupID
Returns a hashcode for the group's identifier.
hashCode() - Method in class java.rmi.activation.ActivationID
Returns a hashcode for the activation id.
hashCode() - Method in class java.rmi.dgc.VMID
Compute hash code for this VMID.
hashCode() - Method in class java.rmi.MarshalledObject
Return a hash code for this MarshalledObject.
hashCode() - Method in class java.rmi.server.ObjID
Returns the hash code value for this object identifier, the object number.
hashCode() - Method in class java.rmi.server.RemoteObject
Returns a hashcode for a remote object.
hashCode() - Method in class java.rmi.server.UID
Returns the hash code value for this UID.
hashCode() - Method in class java.security.AccessControlContext
Returns the hash code value for this context.
hashCode() - Method in class java.security.AllPermission
Returns the hash code value for this object.
hashCode() - Method in class java.security.BasicPermission
Returns the hash code value for this object.
hashCode() - Method in class java.security.cert.Certificate
Returns a hashcode value for this certificate from its encoded form.
hashCode() - Method in class java.security.cert.CertPath
Returns the hashcode for this certification path.
hashCode() - Method in class java.security.cert.X509CRL
Returns a hashcode value for this CRL from its encoded form.
hashCode() - Method in class java.security.cert.X509CRLEntry
Returns a hashcode value for this CRL entry from its encoded form.
hashCode() - Method in class java.security.CodeSigner
Returns the hash code value for this code signer.
hashCode() - Method in class java.security.CodeSource
Returns the hash code value for this object.
hashCode() - Method in class java.security.Identity
Deprecated.
Returns a hashcode for this identity.
hashCode() - Method in class java.security.Permission
Returns the hash code value for this Permission object.
hashCode() - Method in class java.security.PKCS12Attribute
Returns the hashcode for this PKCS12Attribute.
hashCode() - Method in interface java.security.Principal
Returns a hashcode for this principal.
hashCode() - Method in class java.security.spec.ECFieldF2m
Returns a hash code value for this characteristic 2 finite field.
hashCode() - Method in class java.security.spec.ECFieldFp
Returns a hash code value for this prime finite field.
hashCode() - Method in class java.security.spec.ECPoint
Returns a hash code value for this elliptic curve point.
hashCode() - Method in class java.security.spec.EllipticCurve
Returns a hash code value for this elliptic curve.
hashCode() - Method in class java.security.Timestamp
Returns the hash code value for this timestamp.
hashCode() - Method in class java.security.UnresolvedPermission
Returns the hash code value for this object.
hashCode() - Method in interface java.sql.RowId
Returns a hash code value of this RowId object.
hashCode() - Method in class java.sql.Timestamp
Returns a hash code value for this object.
hashCode() - Method in class java.text.AttributedCharacterIterator.Attribute
Returns a hash code value for the object.
hashCode() - Method in class java.text.ChoiceFormat
Generates a hash code for the message format object.
hashCode() - Method in class java.text.Collator
Generates the hash code for this Collator.
hashCode() - Method in class java.text.DateFormat
Overrides hashCode
hashCode() - Method in class java.text.DateFormatSymbols
Override hashCode.
hashCode() - Method in class java.text.DecimalFormat
Overrides hashCode
hashCode() - Method in class java.text.DecimalFormatSymbols
Override hashCode.
hashCode() - Method in class java.text.FieldPosition
Returns a hash code for this FieldPosition.
hashCode() - Method in class java.text.MessageFormat
Generates a hash code for the message format object.
hashCode() - Method in class java.text.NumberFormat
Overrides hashCode.
hashCode() - Method in class java.text.ParsePosition
Returns a hash code for this ParsePosition.
hashCode() - Method in class java.text.RuleBasedCollator
Generates the hash code for the table-based collation object
hashCode() - Method in class java.text.SimpleDateFormat
Returns the hash code value for this SimpleDateFormat object.
hashCode() - Method in class java.text.StringCharacterIterator
Computes a hashcode for this iterator.
hashCode() - Method in class java.time.chrono.AbstractChronology
A hash code for this chronology.
hashCode() - Method in interface java.time.chrono.ChronoLocalDate
A hash code for this date.
hashCode() - Method in interface java.time.chrono.ChronoLocalDateTime
A hash code for this date-time.
hashCode() - Method in interface java.time.chrono.Chronology
A hash code for this chronology.
hashCode() - Method in interface java.time.chrono.ChronoPeriod
A hash code for this period.
hashCode() - Method in interface java.time.chrono.ChronoZonedDateTime
A hash code for this date-time.
hashCode() - Method in class java.time.chrono.HijrahDate
A hash code for this date.
hashCode() - Method in class java.time.chrono.JapaneseDate
A hash code for this date.
hashCode() - Method in class java.time.chrono.MinguoDate
A hash code for this date.
hashCode() - Method in class java.time.chrono.ThaiBuddhistDate
A hash code for this date.
hashCode() - Method in class java.time.Clock
A hash code for this clock.
hashCode() - Method in class java.time.Duration
A hash code for this duration.
hashCode() - Method in class java.time.format.DecimalStyle
A hash code for this DecimalStyle.
hashCode() - Method in class java.time.Instant
Returns a hash code for this instant.
hashCode() - Method in class java.time.LocalDate
A hash code for this date.
hashCode() - Method in class java.time.LocalDateTime
A hash code for this date-time.
hashCode() - Method in class java.time.LocalTime
A hash code for this time.
hashCode() - Method in class java.time.MonthDay
A hash code for this month-day.
hashCode() - Method in class java.time.OffsetDateTime
A hash code for this date-time.
hashCode() - Method in class java.time.OffsetTime
A hash code for this time.
hashCode() - Method in class java.time.Period
A hash code for this period.
hashCode() - Method in class java.time.temporal.ValueRange
A hash code for this range.
hashCode() - Method in class java.time.temporal.WeekFields
A hash code for this WeekFields.
hashCode() - Method in class java.time.Year
A hash code for this year.
hashCode() - Method in class java.time.YearMonth
A hash code for this year-month.
hashCode() - Method in class java.time.zone.ZoneOffsetTransition
Returns a suitable hash code.
hashCode() - Method in class java.time.zone.ZoneOffsetTransitionRule
Returns a suitable hash code.
hashCode() - Method in class java.time.zone.ZoneRules
Returns a suitable hash code given the definition of #equals.
hashCode() - Method in class java.time.ZonedDateTime
A hash code for this date-time.
hashCode() - Method in class java.time.ZoneId
A hash code for this time-zone ID.
hashCode() - Method in class java.time.ZoneOffset
A hash code for this offset.
hashCode() - Method in class java.util.AbstractList
Returns the hash code value for this list.
hashCode() - Method in class java.util.AbstractMap
Returns the hash code value for this map.
hashCode() - Method in class java.util.AbstractMap.SimpleEntry
Returns the hash code value for this map entry.
hashCode() - Method in class java.util.AbstractMap.SimpleImmutableEntry
Returns the hash code value for this map entry.
hashCode() - Method in class java.util.AbstractSet
Returns the hash code value for this set.
hashCode(long[]) - Static method in class java.util.Arrays
Returns a hash code based on the contents of the specified array.
hashCode(int[]) - Static method in class java.util.Arrays
Returns a hash code based on the contents of the specified array.
hashCode(short[]) - Static method in class java.util.Arrays
Returns a hash code based on the contents of the specified array.
hashCode(char[]) - Static method in class java.util.Arrays
Returns a hash code based on the contents of the specified array.
hashCode(byte[]) - Static method in class java.util.Arrays
Returns a hash code based on the contents of the specified array.
hashCode(boolean[]) - Static method in class java.util.Arrays
Returns a hash code based on the contents of the specified array.
hashCode(float[]) - Static method in class java.util.Arrays
Returns a hash code based on the contents of the specified array.
hashCode(double[]) - Static method in class java.util.Arrays
Returns a hash code based on the contents of the specified array.
hashCode(Object[]) - Static method in class java.util.Arrays
Returns a hash code based on the contents of the specified array.
hashCode() - Method in class java.util.BitSet
Returns the hash code value for this bit set.
hashCode() - Method in class java.util.Calendar
Returns a hash code for this calendar.
hashCode() - Method in interface java.util.Collection
Returns the hash code value for this collection.
hashCode() - Method in class java.util.concurrent.ConcurrentHashMap
Returns the hash code value for this Map, i.e., the sum of, for each key-value pair in the map, key.hashCode() ^ value.hashCode().
hashCode() - Method in class java.util.concurrent.ConcurrentHashMap.KeySetView
hashCode() - Method in class java.util.concurrent.CopyOnWriteArrayList
Returns the hash code value for this list.
hashCode() - Method in class java.util.Date
Returns a hash code value for this object.
hashCode() - Method in class java.util.EnumMap
Returns the hash code value for this map.
hashCode() - Method in class java.util.GregorianCalendar
Generates the hash code for this GregorianCalendar object.
hashCode() - Method in class java.util.Hashtable
Returns the hash code value for this Map as per the definition in the Map interface.
hashCode() - Method in class java.util.IdentityHashMap
Returns the hash code value for this map.
hashCode() - Method in class java.util.jar.Attributes
Returns the hash code value for this Map.
hashCode() - Method in class java.util.jar.Attributes.Name
Computes the hash value for this attribute name.
hashCode() - Method in class java.util.jar.Manifest
Returns the hash code for this Manifest.
hashCode() - Method in interface java.util.List
Returns the hash code value for this list.
hashCode() - Method in class java.util.Locale
Override hashCode.
hashCode() - Method in class java.util.Locale.LanguageRange
Returns a hash code value for the object.
hashCode() - Method in class java.util.logging.Level
Generate a hashcode.
hashCode() - Method in interface java.util.Map.Entry
Returns the hash code value for this map entry.
hashCode() - Method in interface java.util.Map
Returns the hash code value for this map.
hashCode(Object) - Static method in class java.util.Objects
Returns the hash code of a non-null argument and 0 for a null argument.
hashCode() - Method in class java.util.Optional
Returns the hash code value of the present value, if any, or 0 (zero) if no value is present.
hashCode() - Method in class java.util.OptionalDouble
Returns the hash code value of the present value, if any, or 0 (zero) if no value is present.
hashCode() - Method in class java.util.OptionalInt
Returns the hash code value of the present value, if any, or 0 (zero) if no value is present.
hashCode() - Method in class java.util.OptionalLong
Returns the hash code value of the present value, if any, or 0 (zero) if no value is present.
hashCode() - Method in class java.util.PropertyPermission
Returns the hash code value for this object.
hashCode() - Method in interface java.util.Set
Returns the hash code value for this set.
hashCode() - Method in class java.util.SimpleTimeZone
Generates the hash code for the SimpleDateFormat object.
hashCode() - Method in class java.util.UUID
Returns a hash code for this UUID.
hashCode() - Method in class java.util.Vector
Returns the hash code value for this Vector.
hashCode() - Method in class java.util.zip.ZipEntry
Returns the hash code value for this entry.
hashCode() - Method in class javax.crypto.spec.RC2ParameterSpec
Calculates a hash code value for the object.
hashCode() - Method in class javax.crypto.spec.RC5ParameterSpec
Calculates a hash code value for the object.
hashCode() - Method in class javax.crypto.spec.SecretKeySpec
Calculates a hash code value for the object.
hashCode() - Method in class javax.imageio.ImageTypeSpecifier
Returns the hash code for this ImageTypeSpecifier.
hashCode() - Method in interface javax.lang.model.element.Element
Obeys the general contract of Object.hashCode.
hashCode() - Method in interface javax.lang.model.element.Name
Obeys the general contract of Object.hashCode.
hashCode() - Method in interface javax.lang.model.type.TypeMirror
Obeys the general contract of Object.hashCode.
hashCode() - Method in class javax.management.Attribute
Returns a hash code value for this attribute.
hashCode() - Method in interface javax.management.Descriptor
Returns the hash code value for this descriptor.
hashCode() - Method in class javax.management.ImmutableDescriptor
Returns the hash code value for this descriptor.
hashCode() - Method in class javax.management.MBeanAttributeInfo
hashCode() - Method in class javax.management.MBeanConstructorInfo
hashCode() - Method in class javax.management.MBeanFeatureInfo
hashCode() - Method in class javax.management.MBeanInfo
hashCode() - Method in class javax.management.MBeanNotificationInfo
hashCode() - Method in class javax.management.MBeanOperationInfo
hashCode() - Method in class javax.management.MBeanParameterInfo
hashCode() - Method in class javax.management.MBeanPermission
Returns the hash code value for this object.
hashCode() - Method in class javax.management.MBeanServerPermission
hashCode() - Method in class javax.management.modelmbean.DescriptorSupport
Returns the hash code value for this descriptor.
hashCode() - Method in class javax.management.ObjectInstance
hashCode() - Method in class javax.management.ObjectName
Returns a hash code for this object name.
hashCode() - Method in class javax.management.openmbean.ArrayType
Returns the hash code value for this ArrayType instance.
hashCode() - Method in interface javax.management.openmbean.CompositeData
Returns the hash code value for this CompositeData instance.
hashCode() - Method in class javax.management.openmbean.CompositeDataSupport
Returns the hash code value for this CompositeDataSupport instance.
hashCode() - Method in class javax.management.openmbean.CompositeType
Returns the hash code value for this CompositeType instance.
hashCode() - Method in interface javax.management.openmbean.OpenMBeanAttributeInfo
Returns the hash code value for this OpenMBeanAttributeInfo instance.
hashCode() - Method in class javax.management.openmbean.OpenMBeanAttributeInfoSupport
Returns the hash code value for this OpenMBeanAttributeInfoSupport instance.
hashCode() - Method in interface javax.management.openmbean.OpenMBeanConstructorInfo
Returns the hash code value for this OpenMBeanConstructorInfo instance.
hashCode() - Method in class javax.management.openmbean.OpenMBeanConstructorInfoSupport
Returns the hash code value for this OpenMBeanConstructorInfoSupport instance.
hashCode() - Method in interface javax.management.openmbean.OpenMBeanInfo
Returns the hash code value for this OpenMBeanInfo instance.
hashCode() - Method in class javax.management.openmbean.OpenMBeanInfoSupport
Returns the hash code value for this OpenMBeanInfoSupport instance.
hashCode() - Method in interface javax.management.openmbean.OpenMBeanOperationInfo
Returns the hash code value for this OpenMBeanOperationInfo instance.
hashCode() - Method in class javax.management.openmbean.OpenMBeanOperationInfoSupport
Returns the hash code value for this OpenMBeanOperationInfoSupport instance.
hashCode() - Method in interface javax.management.openmbean.OpenMBeanParameterInfo
Returns the hash code value for this OpenMBeanParameterInfo instance.
hashCode() - Method in class javax.management.openmbean.OpenMBeanParameterInfoSupport
Returns the hash code value for this OpenMBeanParameterInfoSupport instance.
hashCode() - Method in class javax.management.openmbean.OpenType
hashCode() - Method in class javax.management.openmbean.SimpleType
Returns the hash code value for this SimpleType instance.
hashCode() - Method in interface javax.management.openmbean.TabularData
Returns the hash code value for this TabularData instance.
hashCode() - Method in class javax.management.openmbean.TabularDataSupport
Returns the hash code value for this TabularDataSupport instance.
hashCode() - Method in class javax.management.openmbean.TabularType
Returns the hash code value for this TabularType instance.
hashCode() - Method in class javax.management.remote.JMXPrincipal
Returns a hash code for this JMXPrincipal.
hashCode() - Method in class javax.management.remote.JMXServiceURL
hashCode() - Method in class javax.naming.BinaryRefAddr
Computes the hash code of this address using its address type and contents.
hashCode() - Method in class javax.naming.CompositeName
Computes the hash code of this composite name.
hashCode() - Method in class javax.naming.CompoundName
Computes the hash code of this compound name.
hashCode() - Method in class javax.naming.directory.BasicAttribute
Calculates the hash code of this attribute.
hashCode() - Method in class javax.naming.directory.BasicAttributes
Calculates the hash code of this BasicAttributes.
hashCode() - Method in class javax.naming.ldap.LdapName
Computes the hash code of this LDAP name.
hashCode() - Method in class javax.naming.ldap.Rdn
Returns the hash code of this RDN.
hashCode() - Method in class javax.naming.RefAddr
Computes the hash code of this address using its address type and contents.
hashCode() - Method in class javax.naming.Reference
Computes the hash code of this reference.
hashCode() - Method in class javax.net.ssl.SNIHostName
Returns a hash code value for this SNIHostName.
hashCode() - Method in class javax.net.ssl.SNIServerName
Returns a hash code value for this server name.
hashCode() - Method in interface javax.print.attribute.AttributeSet
Returns the hash code value for this attribute set.
hashCode() - Method in class javax.print.attribute.DateTimeSyntax
Returns a hash code value for this date-time attribute.
hashCode() - Method in class javax.print.attribute.EnumSyntax
Returns a hash code value for this enumeration value.
hashCode() - Method in class javax.print.attribute.HashAttributeSet
Returns the hash code value for this attribute set.
hashCode() - Method in class javax.print.attribute.IntegerSyntax
Returns a hash code value for this integer attribute.
hashCode() - Method in class javax.print.attribute.ResolutionSyntax
Returns a hash code value for this resolution attribute.
hashCode() - Method in class javax.print.attribute.SetOfIntegerSyntax
Returns a hash code value for this set-of-integer attribute.
hashCode() - Method in class javax.print.attribute.Size2DSyntax
Returns a hash code value for this two-dimensional size attribute.
hashCode() - Method in class javax.print.attribute.standard.MediaPrintableArea
Returns a hash code value for this attribute.
hashCode() - Method in class javax.print.attribute.TextSyntax
Returns a hashcode for this text attribute.
hashCode() - Method in class javax.print.attribute.URISyntax
Returns a hashcode for this URI attribute.
hashCode() - Method in class javax.print.DocFlavor
Returns a hash code for this doc flavor object.
hashCode() - Method in interface javax.print.PrintService
This method should be implemented consistently with equals(Object).
hashCode() - Method in class javax.rmi.CORBA.Stub
Returns a hash code value for the object which is the same for all stubs that represent the same remote object.
hashCode(Stub) - Method in interface javax.rmi.CORBA.StubDelegate
Delegation call for Stub.hashCode().
hashCode() - Method in class javax.rmi.ssl.SslRMIClientSocketFactory
Returns a hash code value for this SslRMIClientSocketFactory.
hashCode() - Method in class javax.rmi.ssl.SslRMIServerSocketFactory
Returns a hash code value for this SslRMIServerSocketFactory.
hashCode() - Method in class javax.security.auth.kerberos.DelegationPermission
Returns the hash code value for this object.
hashCode() - Method in class javax.security.auth.kerberos.KerberosKey
Returns a hashcode for this KerberosKey.
hashCode() - Method in class javax.security.auth.kerberos.KerberosPrincipal
Returns a hashcode for this principal.
hashCode() - Method in class javax.security.auth.kerberos.KerberosTicket
Returns a hashcode for this KerberosTicket.
hashCode() - Method in class javax.security.auth.kerberos.KeyTab
Returns a hashcode for this KeyTab.
hashCode() - Method in class javax.security.auth.kerberos.ServicePermission
Returns the hash code value for this object.
hashCode() - Method in class javax.security.auth.PrivateCredentialPermission
Returns the hash code value for this object.
hashCode() - Method in class javax.security.auth.Subject
Returns a hashcode for this Subject.
hashCode() - Method in class javax.security.auth.x500.X500Principal
Return a hash code for this X500Principal.
hashCode() - Method in class javax.security.cert.Certificate
Returns a hashcode value for this certificate from its encoded form.
hashCode() - Method in class javax.sound.midi.MidiDevice.Info
Finalizes the hashcode method.
hashCode() - Method in class javax.sound.midi.Sequencer.SyncMode
Finalizes the hashcode method.
hashCode() - Method in class javax.sound.sampled.AudioFileFormat.Type
Finalizes the hashCode method
hashCode() - Method in class javax.sound.sampled.AudioFormat.Encoding
Finalizes the hashCode method
hashCode() - Method in class javax.sound.sampled.Control.Type
Finalizes the hashCode method
hashCode() - Method in class javax.sound.sampled.LineEvent.Type
Finalizes the hashcode method.
hashCode() - Method in class javax.sound.sampled.Mixer.Info
Finalizes the hashcode method.
hashCode() - Method in class javax.sound.sampled.Port.Info
Finalizes the hashCode method
hashCode() - Method in class javax.sound.sampled.ReverbType
Finalizes the hashcode method.
hashCode() - Method in class javax.sql.rowset.serial.SerialArray
Returns a hash code for this SerialArray.
hashCode() - Method in class javax.sql.rowset.serial.SerialBlob
Returns a hash code for this SerialBlob.
hashCode() - Method in class javax.sql.rowset.serial.SerialClob
Returns a hash code for this SerialClob.
hashCode() - Method in class javax.sql.rowset.serial.SerialDatalink
Returns a hash code for this SerialDatalink.
hashCode() - Method in class javax.sql.rowset.serial.SerialJavaObject
Returns a hash code for this SerialJavaObject.
hashCode() - Method in class javax.sql.rowset.serial.SerialRef
Returns a hash code for this SerialRef.
hashCode() - Method in class javax.sql.rowset.serial.SerialStruct
Returns a hash code for this SerialStruct.
hashCode() - Method in class javax.swing.RowSorter.SortKey
Returns the hash code for this SortKey.
hashCode() - Method in class javax.swing.text.html.HTML.UnknownTag
Returns the hash code which corresponds to the string for this tag.
hashCode() - Method in class javax.swing.text.SimpleAttributeSet
Returns a hashcode for this set of attributes.
hashCode() - Method in class javax.swing.text.StyleContext.SmallAttributeSet
Returns a hashcode for this set of attributes.
hashCode() - Method in class javax.swing.text.TabSet
Returns a hashcode for this set of TabStops.
hashCode() - Method in class javax.swing.text.TabStop
Returns the hashCode for the object.
hashCode() - Method in class javax.swing.tree.TreePath
Returns the hash code of this TreePath.
hashCode() - Method in class javax.xml.datatype.Duration
Returns a hash code consistent with the definition of the equals method.
hashCode() - Method in class javax.xml.datatype.XMLGregorianCalendar
Returns a hash code consistent with the definition of the equals method.
hashCode() - Method in class javax.xml.namespace.QName
Generate the hash code for this QName.
hashCode() - Method in class org.ietf.jgss.ChannelBinding
Returns a hashcode value for this ChannelBinding object.
hashCode() - Method in interface org.ietf.jgss.GSSCredential
Returns a hashcode value for this GSSCredential.
hashCode() - Method in interface org.ietf.jgss.GSSName
Returns a hashcode value for this GSSName.
hashCode() - Method in class org.ietf.jgss.Oid
Returns a hashcode value for this Oid.
hashCode(Object) - Method in class org.omg.CORBA.portable.Delegate
Provides the implementation to override the hashCode() method of the delegating CORBA object.
hashCode() - Method in class org.omg.CORBA.portable.ObjectImpl
Returns the hash code for this ObjectImpl object.
HashDocAttributeSet - Class in javax.print.attribute
Class HashDocAttributeSet provides an attribute set which inherits its implementation from class HashAttributeSet and enforces the semantic restrictions of interface DocAttributeSet.
HashDocAttributeSet() - Constructor for class javax.print.attribute.HashDocAttributeSet
Construct a new, empty hash doc attribute set.
HashDocAttributeSet(DocAttribute) - Constructor for class javax.print.attribute.HashDocAttributeSet
Construct a new hash doc attribute set, initially populated with the given value.
HashDocAttributeSet(DocAttribute[]) - Constructor for class javax.print.attribute.HashDocAttributeSet
Construct a new hash doc attribute set, initially populated with the values from the given array.
HashDocAttributeSet(DocAttributeSet) - Constructor for class javax.print.attribute.HashDocAttributeSet
Construct a new attribute set, initially populated with the values from the given set where the members of the attribute set are restricted to the DocAttribute interface.
HashMap<K,V> - Class in java.util
Hash table based implementation of the Map interface.
HashMap(int, float) - Constructor for class java.util.HashMap
Constructs an empty HashMap with the specified initial capacity and load factor.
HashMap(int) - Constructor for class java.util.HashMap
Constructs an empty HashMap with the specified initial capacity and the default load factor (0.75).
HashMap() - Constructor for class java.util.HashMap
Constructs an empty HashMap with the default initial capacity (16) and the default load factor (0.75).
HashMap(Map<? extends K, ? extends V>) - Constructor for class java.util.HashMap
Constructs a new HashMap with the same mappings as the specified Map.
HashPrintJobAttributeSet - Class in javax.print.attribute
Class HashPrintJobAttributeSet provides an attribute set which inherits its implementation from class HashAttributeSet and enforces the semantic restrictions of interface PrintJobAttributeSet.
HashPrintJobAttributeSet() - Constructor for class javax.print.attribute.HashPrintJobAttributeSet
Construct a new, empty hash print job attribute set.
HashPrintJobAttributeSet(PrintJobAttribute) - Constructor for class javax.print.attribute.HashPrintJobAttributeSet
Construct a new hash print job attribute set, initially populated with the given value.
HashPrintJobAttributeSet(PrintJobAttribute[]) - Constructor for class javax.print.attribute.HashPrintJobAttributeSet
Construct a new hash print job attribute set, initially populated with the values from the given array.
HashPrintJobAttributeSet(PrintJobAttributeSet) - Constructor for class javax.print.attribute.HashPrintJobAttributeSet
Construct a new attribute set, initially populated with the values from the given set where the members of the attribute set are restricted to the PrintJobAttribute interface.
HashPrintRequestAttributeSet - Class in javax.print.attribute
Class HashPrintRequestAttributeSet inherits its implementation from class HashAttributeSet and enforces the semantic restrictions of interface PrintRequestAttributeSet.
HashPrintRequestAttributeSet() - Constructor for class javax.print.attribute.HashPrintRequestAttributeSet
Construct a new, empty print request attribute set.
HashPrintRequestAttributeSet(PrintRequestAttribute) - Constructor for class javax.print.attribute.HashPrintRequestAttributeSet
Construct a new print request attribute set, initially populated with the given value.
HashPrintRequestAttributeSet(PrintRequestAttribute[]) - Constructor for class javax.print.attribute.HashPrintRequestAttributeSet
Construct a new print request attribute set, initially populated with the values from the given array.
HashPrintRequestAttributeSet(PrintRequestAttributeSet) - Constructor for class javax.print.attribute.HashPrintRequestAttributeSet
Construct a new attribute set, initially populated with the values from the given set where the members of the attribute set are restricted to the (PrintRequestAttributeSe interface.
HashPrintServiceAttributeSet - Class in javax.print.attribute
Class HashPrintServiceAttributeSet provides an attribute set which inherits its implementation from class HashAttributeSet and enforces the semantic restrictions of interface PrintServiceAttributeSet.
HashPrintServiceAttributeSet() - Constructor for class javax.print.attribute.HashPrintServiceAttributeSet
Construct a new, empty hash print service attribute set.
HashPrintServiceAttributeSet(PrintServiceAttribute) - Constructor for class javax.print.attribute.HashPrintServiceAttributeSet
Construct a new hash print service attribute set, initially populated with the given value.
HashPrintServiceAttributeSet(PrintServiceAttribute[]) - Constructor for class javax.print.attribute.HashPrintServiceAttributeSet
Construct a new print service attribute set, initially populated with the values from the given array.
HashPrintServiceAttributeSet(PrintServiceAttributeSet) - Constructor for class javax.print.attribute.HashPrintServiceAttributeSet
Construct a new attribute set, initially populated with the values from the given set where the members of the attribute set are restricted to the PrintServiceAttribute interface.
HashSet<E> - Class in java.util
This class implements the Set interface, backed by a hash table (actually a HashMap instance).
HashSet() - Constructor for class java.util.HashSet
Constructs a new, empty set; the backing HashMap instance has default initial capacity (16) and load factor (0.75).
HashSet(Collection<? extends E>) - Constructor for class java.util.HashSet
Constructs a new set containing the elements in the specified collection.
HashSet(int, float) - Constructor for class java.util.HashSet
Constructs a new, empty set; the backing HashMap instance has the specified initial capacity and the specified load factor.
HashSet(int) - Constructor for class java.util.HashSet
Constructs a new, empty set; the backing HashMap instance has the specified initial capacity and default load factor (0.75).
Hashtable<K,V> - Class in java.util
This class implements a hash table, which maps keys to values.
Hashtable(int, float) - Constructor for class java.util.Hashtable
Constructs a new, empty hashtable with the specified initial capacity and the specified load factor.
Hashtable(int) - Constructor for class java.util.Hashtable
Constructs a new, empty hashtable with the specified initial capacity and default load factor (0.75).
Hashtable() - Constructor for class java.util.Hashtable
Constructs a new, empty hashtable with a default initial capacity (11) and load factor (0.75).
Hashtable(Map<? extends K, ? extends V>) - Constructor for class java.util.Hashtable
Constructs a new hashtable with the same mappings as the given Map.
hasInitialContextFactoryBuilder() - Static method in class javax.naming.spi.NamingManager
Determines whether an initial context factory builder has been set.
hasInitialResponse() - Method in interface javax.security.sasl.SaslClient
Determines whether this mechanism has an optional initial response.
hasLayoutAttributes() - Method in class java.awt.Font
Return true if this Font contains attributes that require extra layout processing.
hasLegalValues() - Method in class javax.management.openmbean.OpenMBeanAttributeInfoSupport
Returns true if this OpenMBeanAttributeInfoSupport instance specifies a non-null set of legal values for the described attribute, false otherwise.
hasLegalValues() - Method in interface javax.management.openmbean.OpenMBeanParameterInfo
Returns true if this parameter has a specified set of legal values, or false otherwise.
hasLegalValues() - Method in class javax.management.openmbean.OpenMBeanParameterInfoSupport
Returns true if this OpenMBeanParameterInfoSupport instance specifies a non-null set of legal values for the described parameter, false otherwise.
hasListeners(String) - Method in class java.beans.PropertyChangeSupport
Check if there are any listeners for a specific property, including those registered on all properties.
hasListeners(String) - Method in class java.beans.VetoableChangeSupport
Check if there are any listeners for a specific property, including those registered on all properties.
hasLocation(JavaFileManager.Location) - Method in class javax.tools.ForwardingJavaFileManager
hasLocation(JavaFileManager.Location) - Method in interface javax.tools.JavaFileManager
Determines if a location is known to this file manager.
hasMaxValue() - Method in class javax.management.openmbean.OpenMBeanAttributeInfoSupport
Returns true if this OpenMBeanAttributeInfoSupport instance specifies a non-null maximal value for the described attribute, false otherwise.
hasMaxValue() - Method in interface javax.management.openmbean.OpenMBeanParameterInfo
Returns true if this parameter has a specified maximal value, or false otherwise.
hasMaxValue() - Method in class javax.management.openmbean.OpenMBeanParameterInfoSupport
Returns true if this OpenMBeanParameterInfoSupport instance specifies a non-null maximal value for the described parameter, false otherwise.
hasMinValue() - Method in class javax.management.openmbean.OpenMBeanAttributeInfoSupport
Returns true if this OpenMBeanAttributeInfoSupport instance specifies a non-null minimal value for the described attribute, false otherwise.
hasMinValue() - Method in interface javax.management.openmbean.OpenMBeanParameterInfo
Returns true if this parameter has a specified minimal value, or false otherwise.
hasMinValue() - Method in class javax.management.openmbean.OpenMBeanParameterInfoSupport
Returns true if this OpenMBeanParameterInfoSupport instance specifies a non-null minimal value for the described parameter, false otherwise.
hasMore() - Method in interface javax.naming.NamingEnumeration
Determines whether there are any more elements in the enumeration.
hasMoreElements() - Method in interface java.util.Enumeration
Tests if this enumeration contains more elements.
hasMoreElements() - Method in class java.util.StringTokenizer
Returns the same value as the hasMoreTokens method.
hasMoreTokens() - Method in class java.util.StringTokenizer
Tests if there are more tokens available from this tokenizer's string.
hasName() - Method in class javax.xml.stream.util.StreamReaderDelegate
hasName() - Method in interface javax.xml.stream.XMLStreamReader
returns true if the current event has a name (is a START_ELEMENT or END_ELEMENT) returns false otherwise
hasNext() - Method in class java.beans.beancontext.BeanContextSupport.BCSIterator
hasNext() - Method in interface java.util.Iterator
Returns true if the iteration has more elements.
hasNext() - Method in interface java.util.ListIterator
Returns true if this list iterator has more elements when traversing the list in the forward direction.
hasNext() - Method in class java.util.Scanner
Returns true if this scanner has another token in its input.
hasNext(String) - Method in class java.util.Scanner
Returns true if the next token matches the pattern constructed from the specified string.
hasNext(Pattern) - Method in class java.util.Scanner
Returns true if the next complete token matches the specified pattern.
hasNext() - Method in class javax.xml.stream.util.EventReaderDelegate
hasNext() - Method in class javax.xml.stream.util.StreamReaderDelegate
hasNext() - Method in interface javax.xml.stream.XMLEventReader
Check if there are more events.
hasNext() - Method in interface javax.xml.stream.XMLStreamReader
Returns true if there are more parsing events and false if there are no more events.
hasNextBigDecimal() - Method in class java.util.Scanner
Returns true if the next token in this scanner's input can be interpreted as a BigDecimal using the Scanner.nextBigDecimal() method.
hasNextBigInteger() - Method in class java.util.Scanner
Returns true if the next token in this scanner's input can be interpreted as a BigInteger in the default radix using the Scanner.nextBigInteger() method.
hasNextBigInteger(int) - Method in class java.util.Scanner
Returns true if the next token in this scanner's input can be interpreted as a BigInteger in the specified radix using the Scanner.nextBigInteger() method.
hasNextBoolean() - Method in class java.util.Scanner
Returns true if the next token in this scanner's input can be interpreted as a boolean value using a case insensitive pattern created from the string "true|false".
hasNextByte() - Method in class java.util.Scanner
Returns true if the next token in this scanner's input can be interpreted as a byte value in the default radix using the Scanner.nextByte() method.
hasNextByte(int) - Method in class java.util.Scanner
Returns true if the next token in this scanner's input can be interpreted as a byte value in the specified radix using the Scanner.nextByte() method.
hasNextDouble() - Method in class java.util.Scanner
Returns true if the next token in this scanner's input can be interpreted as a double value using the Scanner.nextDouble() method.
hasNextFloat() - Method in class java.util.Scanner
Returns true if the next token in this scanner's input can be interpreted as a float value using the Scanner.nextFloat() method.
hasNextInt() - Method in class java.util.Scanner
Returns true if the next token in this scanner's input can be interpreted as an int value in the default radix using the Scanner.nextInt() method.
hasNextInt(int) - Method in class java.util.Scanner
Returns true if the next token in this scanner's input can be interpreted as an int value in the specified radix using the Scanner.nextInt() method.
hasNextLine() - Method in class java.util.Scanner
Returns true if there is another line in the input of this scanner.
hasNextLong() - Method in class java.util.Scanner
Returns true if the next token in this scanner's input can be interpreted as a long value in the default radix using the Scanner.nextLong() method.
hasNextLong(int) - Method in class java.util.Scanner
Returns true if the next token in this scanner's input can be interpreted as a long value in the specified radix using the Scanner.nextLong() method.
hasNextShort() - Method in class java.util.Scanner
Returns true if the next token in this scanner's input can be interpreted as a short value in the default radix using the Scanner.nextShort() method.
hasNextShort(int) - Method in class java.util.Scanner
Returns true if the next token in this scanner's input can be interpreted as a short value in the specified radix using the Scanner.nextShort() method.
hasPrevious() - Method in interface java.util.ListIterator
Returns true if this list iterator has more elements when traversing the list in the reverse direction.
hasPrimitives() - Method in class java.lang.invoke.MethodType
Reports if this type contains a primitive argument or return value.
hasQueuedPredecessors() - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer
Queries whether any threads have been waiting to acquire longer than the current thread.
hasQueuedPredecessors() - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer
Queries whether any threads have been waiting to acquire longer than the current thread.
hasQueuedSubmissions() - Method in class java.util.concurrent.ForkJoinPool
Returns true if there are any tasks submitted to this pool that have not yet begun executing.
hasQueuedThread(Thread) - Method in class java.util.concurrent.locks.ReentrantLock
Queries whether the given thread is waiting to acquire this lock.
hasQueuedThread(Thread) - Method in class java.util.concurrent.locks.ReentrantReadWriteLock
Queries whether the given thread is waiting to acquire either the read or write lock.
hasQueuedThreads() - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer
Queries whether any threads are waiting to acquire.
hasQueuedThreads() - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer
Queries whether any threads are waiting to acquire.
hasQueuedThreads() - Method in class java.util.concurrent.locks.ReentrantLock
Queries whether any threads are waiting to acquire this lock.
hasQueuedThreads() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock
Queries whether any threads are waiting to acquire the read or write lock.
hasQueuedThreads() - Method in class java.util.concurrent.Semaphore
Queries whether any threads are waiting to acquire.
hasRaster() - Method in class javax.imageio.IIOImage
Returns true if this IIOImage stores a Raster rather than a RenderedImage.
hasRelation(String) - Method in class javax.management.relation.RelationService
Checks if there is a relation identified in Relation Service with given relation id.
hasRelation(String) - Method in interface javax.management.relation.RelationServiceMBean
Checks if there is a relation identified in Relation Service with given relation id.
hasRemaining() - Method in class java.nio.Buffer
Tells whether there are any elements between the current position and the limit.
hasSameRules(TimeZone) - Method in class java.util.SimpleTimeZone
Returns true if this zone has the same rules and offset as another zone.
hasSameRules(TimeZone) - Method in class java.util.TimeZone
Returns true if this zone has the same rule and offset as another zone.
hasService(Class) - Method in interface java.beans.beancontext.BeanContextServices
Reports whether or not a given service is currently available from this context.
hasService(Class) - Method in class java.beans.beancontext.BeanContextServicesSupport
has a service, which may be delegated
hasText() - Method in class javax.xml.stream.util.StreamReaderDelegate
hasText() - Method in interface javax.xml.stream.XMLStreamReader
Return true if the current event has text, false otherwise The following events have text: CHARACTERS,DTD ,ENTITY_REFERENCE, COMMENT, SPACE
hasThumbnails(int) - Method in class javax.imageio.ImageReader
Returns true if the given image has thumbnail preview images associated with it.
hasTileWriters() - Method in class java.awt.image.BufferedImage
Returns whether or not any tile is checked out for writing.
hasTileWriters() - Method in interface java.awt.image.WritableRenderedImage
Returns whether any tile is checked out for writing.
hasTransparentBounds() - Method in class java.util.regex.Matcher
Queries the transparency of region bounds for this matcher.
hasUniformLineMetrics() - Method in class java.awt.Font
Checks whether or not this Font has uniform line metrics.
hasUniformLineMetrics() - Method in class java.awt.FontMetrics
Checks to see if the Font has uniform line metrics.
hasUnsupportedCriticalExtension() - Method in interface java.security.cert.X509Extension
Check if there is a critical extension that is not supported.
hasWaiters() - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject
Queries whether any threads are waiting on this condition.
hasWaiters(AbstractQueuedLongSynchronizer.ConditionObject) - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer
Queries whether any threads are waiting on the given condition associated with this synchronizer.
hasWaiters() - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject
Queries whether any threads are waiting on this condition.
hasWaiters(AbstractQueuedSynchronizer.ConditionObject) - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer
Queries whether any threads are waiting on the given condition associated with this synchronizer.
hasWaiters(Condition) - Method in class java.util.concurrent.locks.ReentrantLock
Queries whether any threads are waiting on the given condition associated with this lock.
hasWaiters(Condition) - Method in class java.util.concurrent.locks.ReentrantReadWriteLock
Queries whether any threads are waiting on the given condition associated with the write lock.
hasWaitingConsumer() - Method in class java.util.concurrent.LinkedTransferQueue
hasWaitingConsumer() - Method in interface java.util.concurrent.TransferQueue
Returns true if there is at least one consumer waiting to receive an element via BlockingQueue.take() or timed poll.
hasWrappers() - Method in class java.lang.invoke.MethodType
Reports if this type contains a wrapper argument or return value.
HEAD - Static variable in class javax.swing.text.html.HTML.Tag
head - Variable in class javax.swing.text.html.parser.DTD
HEADER - Static variable in class javax.accessibility.AccessibleRole
A text header
header - Variable in class javax.swing.plaf.basic.BasicTableHeaderUI
The JTableHeader that is delegating the painting to this UI.
HEADER_RENDERER_PROPERTY - Static variable in class javax.swing.table.TableColumn
Obsolete as of Java 2 platform v1.3.
HEADER_ROW - Static variable in class javax.swing.event.TableModelEvent
Identifies the header row.
HEADER_VALUE_PROPERTY - Static variable in class javax.swing.table.TableColumn
Obsolete as of Java 2 platform v1.3.
headerRenderer - Variable in class javax.swing.table.TableColumn
The renderer used to draw the header of the column.
headerValue - Variable in class javax.swing.table.TableColumn
The header value of the column.
HeadlessException - Exception in java.awt
Thrown when code that is dependent on a keyboard, display, or mouse is called in an environment that does not support a keyboard, display, or mouse.
HeadlessException() - Constructor for exception java.awt.HeadlessException
HeadlessException(String) - Constructor for exception java.awt.HeadlessException
headMap(K, boolean) - Method in interface java.util.concurrent.ConcurrentNavigableMap
headMap(K) - Method in interface java.util.concurrent.ConcurrentNavigableMap
headMap(K, boolean) - Method in class java.util.concurrent.ConcurrentSkipListMap
headMap(K) - Method in class java.util.concurrent.ConcurrentSkipListMap
headMap(K, boolean) - Method in interface java.util.NavigableMap
Returns a view of the portion of this map whose keys are less than (or equal to, if inclusive is true) toKey.
headMap(K) - Method in interface java.util.NavigableMap
Returns a view of the portion of this map whose keys are strictly less than toKey.
headMap(K) - Method in interface java.util.SortedMap
Returns a view of the portion of this map whose keys are strictly less than toKey.
headMap(K, boolean) - Method in class java.util.TreeMap
headMap(K) - Method in class java.util.TreeMap
HEADPHONE - Static variable in class javax.sound.sampled.Port.Info
A type of port that sends audio to a headphone jack.
headSet(E, boolean) - Method in class java.util.concurrent.ConcurrentSkipListSet
headSet(E) - Method in class java.util.concurrent.ConcurrentSkipListSet
headSet(E, boolean) - Method in interface java.util.NavigableSet
Returns a view of the portion of this set whose elements are less than (or equal to, if inclusive is true) toElement.
headSet(E) - Method in interface java.util.NavigableSet
Returns a view of the portion of this set whose elements are strictly less than toElement.
headSet(E) - Method in interface java.util.SortedSet
Returns a view of the portion of this set whose elements are strictly less than toElement.
headSet(E, boolean) - Method in class java.util.TreeSet
headSet(E) - Method in class java.util.TreeSet
heavyWeightPopupEnabled - Variable in class javax.swing.ToolTipManager
HEBREW - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Hebrew" Unicode character block.
height - Variable in class java.awt.Component.BltBufferStrategy
height - Variable in class java.awt.Dimension
The height dimension; negative values can be used.
height - Variable in class java.awt.geom.Arc2D.Double
The overall height of the full ellipse of which this arc is a partial section (not considering the angular extents).
height - Variable in class java.awt.geom.Arc2D.Float
The overall height of the full ellipse of which this arc is a partial section (not considering the angular extents).
height - Variable in class java.awt.geom.Ellipse2D.Double
The overall height of the Ellipse2D.
height - Variable in class java.awt.geom.Ellipse2D.Float
The overall height of this Ellipse2D.
height - Variable in class java.awt.geom.Rectangle2D.Double
The height of this Rectangle2D.
height - Variable in class java.awt.geom.Rectangle2D.Float
The height of this Rectangle2D.
height - Variable in class java.awt.geom.RoundRectangle2D.Double
The height of this RoundRectangle2D.
height - Variable in class java.awt.geom.RoundRectangle2D.Float
The height of this RoundRectangle2D.
HEIGHT - Static variable in interface java.awt.image.ImageObserver
This flag in the infoflags argument to imageUpdate indicates that the height of the base image is now available and can be taken from the height argument to the imageUpdate callback method.
height - Variable in class java.awt.image.Raster
The height of this Raster.
height - Variable in class java.awt.image.SampleModel
Height in pixels of the region of image data that this SampleModel describes.
height - Variable in class java.awt.Rectangle
The height of the Rectangle.
height(Component) - Static method in class javax.swing.Spring
Returns a spring whose minimum, preferred, maximum and value properties are defined by the heights of the minimumSize, preferredSize, maximumSize and size properties of the supplied component.
HEIGHT - Static variable in class javax.swing.SpringLayout
Specifies the height of a component's bounding rectangle.
HEIGHT - Static variable in class javax.swing.text.html.CSS.Attribute
HEIGHT - Static variable in class javax.swing.text.html.HTML.Attribute
HEISEI - Static variable in class java.time.chrono.JapaneseEra
The singleton instance for the 'Heisei' era (1989-01-08 - current) which has the value 2.
helpButtonMnemonic - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
helpButtonText - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
helpButtonToolTipText - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
helpComplete(int) - Method in class java.util.concurrent.CountedCompleter
If this task has not completed, attempts to process at most the given number of other unprocessed tasks for which this task is on the completion path, if any are known to exist.
helpQuiesce() - Static method in class java.util.concurrent.ForkJoinTask
Possibly executes tasks until the pool hosting the current task is quiescent.
HexBinaryAdapter - Class in javax.xml.bind.annotation.adapters
XmlAdapter for xs:hexBinary.
HexBinaryAdapter() - Constructor for class javax.xml.bind.annotation.adapters.HexBinaryAdapter
HiddenAction() - Constructor for class javax.swing.text.html.HTMLDocument.HTMLReader.HiddenAction
hiddenDivider - Variable in class javax.swing.plaf.basic.BasicSplitPaneDivider
Divider that is used for noncontinuous layout mode.
hide() - Method in class java.awt.Component
Deprecated.
As of JDK version 1.1, replaced by setVisible(boolean).
hide() - Method in class java.awt.Dialog
Deprecated.
As of JDK version 1.5, replaced by setVisible(boolean).
hide() - Method in class java.awt.Window
Deprecated.
As of JDK version 1.5, replaced by Window.setVisible(boolean).
hide() - Method in class javax.swing.JComponent
Deprecated.
hide() - Method in class javax.swing.JInternalFrame
hide() - Method in class javax.swing.plaf.basic.BasicComboPopup
Implementation of ComboPopup.hide().
hide() - Method in interface javax.swing.plaf.basic.ComboPopup
Hides the popup
hide() - Method in class javax.swing.Popup
Hides and disposes of the Popup.
HIDE_ON_CLOSE - Static variable in interface javax.swing.WindowConstants
The hide-window default window close operation
hidePopup() - Method in class javax.swing.JComboBox
Causes the combo box to close its popup window.
hides(Element, Element) - Method in interface javax.lang.model.util.Elements
Tests whether one type, method, or field hides another.
hideWindows() - Method in interface java.awt.im.spi.InputMethod
Closes or hides all windows opened by this input method instance or its class.
HIERARCHY_BOUNDS_EVENT_MASK - Static variable in class java.awt.AWTEvent
The event mask for selecting hierarchy bounds events.
HIERARCHY_CHANGED - Static variable in class java.awt.event.HierarchyEvent
The event id indicating that modification was made to the entire hierarchy tree.
HIERARCHY_EVENT_MASK - Static variable in class java.awt.AWTEvent
The event mask for selecting hierarchy events.
HIERARCHY_FIRST - Static variable in class java.awt.event.HierarchyEvent
Marks the first integer id for the range of hierarchy event ids.
HIERARCHY_LAST - Static variable in class java.awt.event.HierarchyEvent
Marks the last integer id for the range of ancestor event ids.
HIERARCHY_REQUEST_ERR - Static variable in exception org.w3c.dom.DOMException
If any Node is inserted somewhere it doesn't belong.
HierarchyBoundsAdapter - Class in java.awt.event
An abstract adapter class for receiving ancestor moved and resized events.
HierarchyBoundsAdapter() - Constructor for class java.awt.event.HierarchyBoundsAdapter
HierarchyBoundsListener - Interface in java.awt.event
The listener interface for receiving ancestor moved and resized events.
hierarchyChanged(HierarchyEvent) - Method in class java.awt.AWTEventMulticaster
Handles the hierarchyChanged event by invoking the hierarchyChanged methods on listener-a and listener-b.
hierarchyChanged(HierarchyEvent) - Method in interface java.awt.event.HierarchyListener
Called when the hierarchy has been changed.
HierarchyEvent - Class in java.awt.event
An event which indicates a change to the Component hierarchy to which Component belongs.
HierarchyEvent(Component, int, Component, Container) - Constructor for class java.awt.event.HierarchyEvent
Constructs an HierarchyEvent object to identify a change in the Component hierarchy.
HierarchyEvent(Component, int, Component, Container, long) - Constructor for class java.awt.event.HierarchyEvent
Constructs an HierarchyEvent object to identify a change in the Component hierarchy.
HierarchyListener - Interface in java.awt.event
The listener interface for receiving hierarchy changed events.
HIGH - Static variable in class java.awt.PageAttributes.PrintQualityType
The PrintQualityType instance to use for specifying a high print quality.
HIGH - Static variable in class javax.print.attribute.standard.PrintQuality
Highest quality available on the printer.
HIGH_PRIVATE_USE_SURROGATES - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "High Private Use Surrogates" Unicode character block.
HIGH_SURROGATES - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "High Surrogates" Unicode character block.
higher(E) - Method in class java.util.concurrent.ConcurrentSkipListSet
higher(E) - Method in interface java.util.NavigableSet
Returns the least element in this set strictly greater than the given element, or null if there is no such element.
higher(E) - Method in class java.util.TreeSet
higherEntry(K) - Method in class java.util.concurrent.ConcurrentSkipListMap
Returns a key-value mapping associated with the least key strictly greater than the given key, or null if there is no such key.
higherEntry(K) - Method in interface java.util.NavigableMap
Returns a key-value mapping associated with the least key strictly greater than the given key, or null if there is no such key.
higherEntry(K) - Method in class java.util.TreeMap
higherKey(K) - Method in class java.util.concurrent.ConcurrentSkipListMap
higherKey(K) - Method in interface java.util.NavigableMap
Returns the least key strictly greater than the given key, or null if there is no such key.
higherKey(K) - Method in class java.util.TreeMap
highestLayer() - Method in class javax.swing.JLayeredPane
Returns the highest layer value from all current children.
highestOneBit(int) - Static method in class java.lang.Integer
Returns an int value with at most a single one-bit, in the position of the highest-order ("leftmost") one-bit in the specified int value.
highestOneBit(long) - Static method in class java.lang.Long
Returns a long value with at most a single one-bit, in the position of the highest-order ("leftmost") one-bit in the specified long value.
highlight - Variable in class javax.swing.border.EtchedBorder
highlight - Variable in class javax.swing.plaf.basic.BasicBorders.ButtonBorder
highlight - Variable in class javax.swing.plaf.basic.BasicBorders.FieldBorder
highlight - Variable in class javax.swing.plaf.basic.BasicBorders.SplitPaneBorder
highlight - Variable in class javax.swing.plaf.basic.BasicSeparatorUI
highlight - Variable in class javax.swing.plaf.basic.BasicTabbedPaneUI
highlightColor - Static variable in class javax.swing.plaf.metal.MetalSliderUI
Highlighter - Interface in javax.swing.text
An interface for an object that allows one to mark up the background with colored areas.
Highlighter.Highlight - Interface in javax.swing.text
Highlighter.HighlightPainter - Interface in javax.swing.text
Highlight renderer.
highlightInner - Variable in class javax.swing.border.BevelBorder
highlightOuter - Variable in class javax.swing.border.BevelBorder
highSurrogate(int) - Static method in class java.lang.Character
Returns the leading surrogate (a high surrogate code unit) of the surrogate pair representing the specified supplementary character (Unicode code point) in the UTF-16 encoding.
HijrahChronology - Class in java.time.chrono
The Hijrah calendar is a lunar calendar supporting Islamic calendars.
HijrahDate - Class in java.time.chrono
A date in the Hijrah calendar system.
HijrahEra - Enum in java.time.chrono
An era in the Hijrah calendar system.
HINTS_OBSERVED - Static variable in interface java.awt.image.renderable.RenderableImage
String constant that can be used to identify a property on a RenderedImage obtained via the createRendering or createScaledRendering methods.
HIRAGANA - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Hiragana" Unicode character block.
hit(Rectangle, Shape, boolean) - Method in class java.awt.Graphics2D
Checks whether or not the specified Shape intersects the specified Rectangle, which is in device space.
hitClip(int, int, int, int) - Method in class java.awt.Graphics
Returns true if the specified rectangular area might intersect the current clipping area.
hitEnd() - Method in class java.util.regex.Matcher
Returns true if the end of input was hit by the search engine in the last match operation performed by this matcher.
hitTestChar(float, float, Rectangle2D) - Method in class java.awt.font.TextLayout
Returns a TextHitInfo corresponding to the specified point.
hitTestChar(float, float) - Method in class java.awt.font.TextLayout
Returns a TextHitInfo corresponding to the specified point.
hitToPoint(TextHitInfo, Point2D) - Method in class java.awt.font.TextLayout
Convert a hit to a point in standard coordinates.
HMAC_SHA1 - Static variable in interface javax.xml.crypto.dsig.SignatureMethod
The HMAC-SHA1 MAC signature method algorithm URI
HMACParameterSpec - Class in javax.xml.crypto.dsig.spec
Parameters for the XML Signature HMAC Algorithm.
HMACParameterSpec(int) - Constructor for class javax.xml.crypto.dsig.spec.HMACParameterSpec
Creates an HMACParameterSpec with the specified truncation length.
HOLD_CURSORS_OVER_COMMIT - Static variable in interface java.sql.ResultSet
The constant indicating that open ResultSet objects with this holdability will remain open when the current transaction is committed.
hold_requests(boolean) - Method in interface org.omg.PortableServer.POAManagerOperations
This operation changes the state of the POA manager to holding, causing associated POAs to queue incoming requests.
Holder<T> - Class in javax.xml.ws
Holds a value of type T.
Holder() - Constructor for class javax.xml.ws.Holder
Creates a new holder with a null value.
Holder(T) - Constructor for class javax.xml.ws.Holder
Create a new holder with the specified value.
HOLDING - Interface in org.omg.PortableInterceptor
org/omg/PortableInterceptor/HOLDING.java .
HOLDING - Static variable in class org.omg.PortableServer.POAManagerPackage.State
holdsLock(Object) - Static method in class java.lang.Thread
Returns true if and only if the current thread holds the monitor lock on the specified object.
HOME - Static variable in class java.awt.Event
The Home key, a non-ASCII action key.
homeFolderIcon - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
homeKey - Variable in class javax.swing.plaf.basic.BasicSplitPaneUI
Deprecated.
As of Java 2 platform v1.3.
HONOR_DISPLAY_PROPERTIES - Static variable in class javax.swing.JEditorPane
Key for a client property used to indicate whether the default font and foreground color from the component are used if a font or foreground color is not specified in the styled text.
HORIZONTAL - Static variable in interface java.awt.Adjustable
Indicates that the Adjustable has horizontal orientation.
HORIZONTAL - Static variable in class java.awt.GridBagConstraints
Resize the component horizontally but not vertically.
HORIZONTAL - Static variable in class java.awt.Scrollbar
A constant that indicates a horizontal scroll bar.
HORIZONTAL - Static variable in class javax.accessibility.AccessibleState
Indicates the orientation of this object is horizontal.
HORIZONTAL - Static variable in interface javax.swing.SwingConstants
Horizontal orientation.
HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY - Static variable in class javax.swing.AbstractButton
Identifies a change in the button's horizontal alignment.
HORIZONTAL_CENTER - Static variable in class javax.swing.SpringLayout
Specifies the horizontal center of a component's bounding rectangle.
HORIZONTAL_SCROLLBAR - Static variable in interface javax.swing.ScrollPaneConstants
Identifies a horizontal scrollbar.
HORIZONTAL_SCROLLBAR_ALWAYS - Static variable in interface javax.swing.ScrollPaneConstants
Used to set the horizontal scroll bar policy so that horizontal scrollbars are always displayed.
HORIZONTAL_SCROLLBAR_AS_NEEDED - Static variable in interface javax.swing.ScrollPaneConstants
Used to set the horizontal scroll bar policy so that horizontal scrollbars are displayed only when needed.
HORIZONTAL_SCROLLBAR_NEVER - Static variable in interface javax.swing.ScrollPaneConstants
Used to set the horizontal scroll bar policy so that horizontal scrollbars are never displayed.
HORIZONTAL_SCROLLBAR_POLICY - Static variable in interface javax.swing.ScrollPaneConstants
Identifies the horizontal scroll bar policy property.
HORIZONTAL_SPLIT - Static variable in class javax.swing.JSplitPane
Horizontal split indicates the Components are split along the x axis.
HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY - Static variable in class javax.swing.AbstractButton
Identifies a change in the button's horizontal text position.
HORIZONTAL_WRAP - Static variable in class javax.swing.JList
Indicates a "newspaper style" layout with cells flowing horizontally then vertically.
horizontalScrollBar - Variable in class javax.swing.JScrollPane
The scrollpane's horizontal scrollbar child.
horizontalScrollBarPolicy - Variable in class javax.swing.JScrollPane
The display policy for the horizontal scrollbar.
horizThumbIcon - Static variable in class javax.swing.plaf.metal.MetalSliderUI
A default horizontal thumb Icon.
hostEncoding - Static variable in class javax.print.DocFlavor
A String representing the host operating system encoding.
HostnameVerifier - Interface in javax.net.ssl
This class is the base interface for hostname verification.
hostnameVerifier - Variable in class javax.net.ssl.HttpsURLConnection
The hostnameVerifier for this object.
hostsEqual(URL, URL) - Method in class java.net.URLStreamHandler
Compares the host components of two URLs.
HOUR - Static variable in class java.util.Calendar
Field number for get and set indicating the hour of the morning or afternoon.
HOUR0 - Static variable in class java.text.DateFormat.Field
Constant identifying the hour field, where the legal values are 0 to 11.
HOUR0_FIELD - Static variable in class java.text.DateFormat
Useful constant for zero-based HOUR field alignment.
HOUR1 - Static variable in class java.text.DateFormat.Field
Constant identifying the hour field, where the legal values are 1 to 12.
HOUR1_FIELD - Static variable in class java.text.DateFormat
Useful constant for one-based HOUR field alignment.
HOUR_OF_DAY - Static variable in class java.util.Calendar
Field number for get and set indicating the hour of the day.
HOUR_OF_DAY0 - Static variable in class java.text.DateFormat.Field
Constant identifying the hour of day field, where the legal values are 0 to 23.
HOUR_OF_DAY0_FIELD - Static variable in class java.text.DateFormat
Useful constant for zero-based HOUR_OF_DAY field alignment.
HOUR_OF_DAY1 - Static variable in class java.text.DateFormat.Field
Constant identifying the hour of day field, where the legal values are 1 to 24.
HOUR_OF_DAY1_FIELD - Static variable in class java.text.DateFormat
Useful constant for one-based HOUR_OF_DAY field alignment.
HOURS - Static variable in class javax.xml.datatype.DatatypeConstants
A constant that represents the hours field.
HR - Static variable in class javax.swing.text.html.HTML.Tag
HREF - Static variable in class javax.swing.text.html.HTML.Attribute
hsb - Variable in class javax.swing.ScrollPaneLayout
The scrollpane's horizontal scrollbar child.
hsbChangeListener - Variable in class javax.swing.plaf.basic.BasicScrollPaneUI
HSBChangeListener() - Constructor for class javax.swing.plaf.basic.BasicScrollPaneUI.HSBChangeListener
hsbPolicy - Variable in class javax.swing.ScrollPaneLayout
The display policy for the horizontal scrollbar.
HSBtoRGB(float, float, float) - Static method in class java.awt.Color
Converts the components of a color, as specified by the HSB model, to an equivalent set of values for the default RGB model.
HSPACE - Static variable in class javax.swing.text.html.HTML.Attribute
HTML - Class in javax.swing.text.html
Constants used in the HTMLDocument.
HTML() - Constructor for class javax.swing.text.html.HTML
HTML - Static variable in class javax.swing.text.html.HTML.Tag
html - Variable in class javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction
HTML to insert.
html - Variable in class javax.swing.text.html.parser.DTD
HTML.Attribute - Class in javax.swing.text.html
Typesafe enumeration representing an HTML attribute.
HTML.Tag - Class in javax.swing.text.html
Typesafe enumeration for an HTML tag.
HTML.UnknownTag - Class in javax.swing.text.html
HTML_CONTAINER - Static variable in class javax.accessibility.AccessibleRole
An object containing a collection of Accessibles that together represents HTML content.
HTMLDocument - Class in javax.swing.text.html
A document that models HTML.
HTMLDocument() - Constructor for class javax.swing.text.html.HTMLDocument
Constructs an HTML document using the default buffer size and a default StyleSheet.
HTMLDocument(StyleSheet) - Constructor for class javax.swing.text.html.HTMLDocument
Constructs an HTML document with the default content storage implementation and the specified style/attribute storage mechanism.
HTMLDocument(AbstractDocument.Content, StyleSheet) - Constructor for class javax.swing.text.html.HTMLDocument
Constructs an HTML document with the given content storage implementation and the given style/attribute storage mechanism.
HTMLDocument.BlockElement - Class in javax.swing.text.html
An element that represents a structural block of HTML.
HTMLDocument.HTMLReader - Class in javax.swing.text.html
An HTML reader to load an HTML document with an HTML element structure.
HTMLDocument.HTMLReader.BlockAction - Class in javax.swing.text.html
HTMLDocument.HTMLReader.CharacterAction - Class in javax.swing.text.html
HTMLDocument.HTMLReader.FormAction - Class in javax.swing.text.html
Action to support forms by building all of the elements used to represent form controls.
HTMLDocument.HTMLReader.HiddenAction - Class in javax.swing.text.html
HTMLDocument.HTMLReader.IsindexAction - Class in javax.swing.text.html
HTMLDocument.HTMLReader.ParagraphAction - Class in javax.swing.text.html
HTMLDocument.HTMLReader.PreAction - Class in javax.swing.text.html
HTMLDocument.HTMLReader.SpecialAction - Class in javax.swing.text.html
HTMLDocument.HTMLReader.TagAction - Class in javax.swing.text.html
An action to be performed in response to parsing a tag.
HTMLDocument.Iterator - Class in javax.swing.text.html
An iterator to iterate over a particular type of tag.
HTMLDocument.RunElement - Class in javax.swing.text.html
An element that represents a chunk of text that has a set of HTML character level attributes assigned to it.
HTMLEditorKit - Class in javax.swing.text.html
The Swing JEditorPane text component supports different kinds of content via a plug-in mechanism called an EditorKit.
HTMLEditorKit() - Constructor for class javax.swing.text.html.HTMLEditorKit
Constructs an HTMLEditorKit, creates a StyleContext, and loads the style sheet.
HTMLEditorKit.HTMLFactory - Class in javax.swing.text.html
A factory to build views for HTML.
HTMLEditorKit.HTMLTextAction - Class in javax.swing.text.html
An abstract Action providing some convenience methods that may be useful in inserting HTML into an existing document.
HTMLEditorKit.InsertHTMLTextAction - Class in javax.swing.text.html
InsertHTMLTextAction can be used to insert an arbitrary string of HTML into an existing HTML document.
HTMLEditorKit.LinkController - Class in javax.swing.text.html
Class to watch the associated component and fire hyperlink events on it when appropriate.
HTMLEditorKit.Parser - Class in javax.swing.text.html
Interface to be supported by the parser.
HTMLEditorKit.ParserCallback - Class in javax.swing.text.html
The result of parsing drives these callback methods.
HTMLFactory() - Constructor for class javax.swing.text.html.HTMLEditorKit.HTMLFactory
HTMLFrameHyperlinkEvent - Class in javax.swing.text.html
HTMLFrameHyperlinkEvent is used to notify interested parties that link was activated in a frame.
HTMLFrameHyperlinkEvent(Object, HyperlinkEvent.EventType, URL, String) - Constructor for class javax.swing.text.html.HTMLFrameHyperlinkEvent
Creates a new object representing a html frame hypertext link event.
HTMLFrameHyperlinkEvent(Object, HyperlinkEvent.EventType, URL, String, String) - Constructor for class javax.swing.text.html.HTMLFrameHyperlinkEvent
Creates a new object representing a hypertext link event.
HTMLFrameHyperlinkEvent(Object, HyperlinkEvent.EventType, URL, Element, String) - Constructor for class javax.swing.text.html.HTMLFrameHyperlinkEvent
Creates a new object representing a hypertext link event.
HTMLFrameHyperlinkEvent(Object, HyperlinkEvent.EventType, URL, String, Element, String) - Constructor for class javax.swing.text.html.HTMLFrameHyperlinkEvent
Creates a new object representing a hypertext link event.
HTMLFrameHyperlinkEvent(Object, HyperlinkEvent.EventType, URL, String, Element, InputEvent, String) - Constructor for class javax.swing.text.html.HTMLFrameHyperlinkEvent
Creates a new object representing a hypertext link event.
HTMLLink(Element) - Constructor for class javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink
HTMLReader(int) - Constructor for class javax.swing.text.html.HTMLDocument.HTMLReader
HTMLReader(int, int, int, HTML.Tag) - Constructor for class javax.swing.text.html.HTMLDocument.HTMLReader
HTMLTextAction(String) - Constructor for class javax.swing.text.html.HTMLEditorKit.HTMLTextAction
HTMLWriter - Class in javax.swing.text.html
This is a writer for HTMLDocuments.
HTMLWriter(Writer, HTMLDocument) - Constructor for class javax.swing.text.html.HTMLWriter
Creates a new HTMLWriter.
HTMLWriter(Writer, HTMLDocument, int, int) - Constructor for class javax.swing.text.html.HTMLWriter
Creates a new HTMLWriter.
HTTP - Static variable in class javax.print.attribute.standard.ReferenceUriSchemesSupported
HyperText Transfer Protocol (HTTP).
HTTP_ACCEPTED - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 202: Accepted.
HTTP_BAD_GATEWAY - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 502: Bad Gateway.
HTTP_BAD_METHOD - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 405: Method Not Allowed.
HTTP_BAD_REQUEST - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 400: Bad Request.
HTTP_BINDING - Static variable in interface javax.xml.ws.http.HTTPBinding
A constant representing the identity of the XML/HTTP binding.
HTTP_CLIENT_TIMEOUT - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 408: Request Time-Out.
HTTP_CONFLICT - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 409: Conflict.
HTTP_CREATED - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 201: Created.
HTTP_ENTITY_TOO_LARGE - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 413: Request Entity Too Large.
HTTP_FORBIDDEN - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 403: Forbidden.
HTTP_GATEWAY_TIMEOUT - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 504: Gateway Timeout.
HTTP_GONE - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 410: Gone.
HTTP_INTERNAL_ERROR - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 500: Internal Server Error.
HTTP_LENGTH_REQUIRED - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 411: Length Required.
HTTP_MOVED_PERM - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 301: Moved Permanently.
HTTP_MOVED_TEMP - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 302: Temporary Redirect.
HTTP_MULT_CHOICE - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 300: Multiple Choices.
HTTP_NO_CONTENT - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 204: No Content.
HTTP_NOT_ACCEPTABLE - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 406: Not Acceptable.
HTTP_NOT_AUTHORITATIVE - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 203: Non-Authoritative Information.
HTTP_NOT_FOUND - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 404: Not Found.
HTTP_NOT_IMPLEMENTED - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 501: Not Implemented.
HTTP_NOT_MODIFIED - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 304: Not Modified.
HTTP_OK - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 200: OK.
HTTP_PARTIAL - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 206: Partial Content.
HTTP_PAYMENT_REQUIRED - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 402: Payment Required.
HTTP_PRECON_FAILED - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 412: Precondition Failed.
HTTP_PROXY_AUTH - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 407: Proxy Authentication Required.
HTTP_REQ_TOO_LONG - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 414: Request-URI Too Large.
HTTP_REQUEST_HEADERS - Static variable in interface javax.xml.ws.handler.MessageContext
Standard property: HTTP request headers.
HTTP_REQUEST_METHOD - Static variable in interface javax.xml.ws.handler.MessageContext
Standard property: HTTP request method.
HTTP_RESET - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 205: Reset Content.
HTTP_RESPONSE_CODE - Static variable in interface javax.xml.ws.handler.MessageContext
Standard property: HTTP response status code.
HTTP_RESPONSE_HEADERS - Static variable in interface javax.xml.ws.handler.MessageContext
Standard property: HTTP response headers.
HTTP_SEE_OTHER - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 303: See Other.
HTTP_SERVER_ERROR - Static variable in class java.net.HttpURLConnection
Deprecated.
it is misplaced and shouldn't have existed.
HTTP_UNAUTHORIZED - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 401: Unauthorized.
HTTP_UNAVAILABLE - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 503: Service Unavailable.
HTTP_UNSUPPORTED_TYPE - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 415: Unsupported Media Type.
HTTP_USE_PROXY - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 305: Use Proxy.
HTTP_VERSION - Static variable in class java.net.HttpURLConnection
HTTP Status-Code 505: HTTP Version Not Supported.
HTTPBinding - Interface in javax.xml.ws.http
The HTTPBinding interface is an abstraction for the XML/HTTP binding.
HttpContext - Class in javax.xml.ws.spi.http
HttpContext represents a mapping between the root URI path of a web service to a HttpHandler which is invoked to handle requests destined for that path on the associated container.
HttpContext() - Constructor for class javax.xml.ws.spi.http.HttpContext
HttpCookie - Class in java.net
An HttpCookie object represents an HTTP cookie, which carries state information between server and user agent.
HttpCookie(String, String) - Constructor for class java.net.HttpCookie
Constructs a cookie with a specified name and value.
HTTPEQUIV - Static variable in class javax.swing.text.html.HTML.Attribute
HTTPException - Exception in javax.xml.ws.http
The HTTPException exception represents a XML/HTTP fault.
HTTPException(int) - Constructor for exception javax.xml.ws.http.HTTPException
Constructor for the HTTPException
HttpExchange - Class in javax.xml.ws.spi.http
This class encapsulates a HTTP request received and a response to be generated in one exchange.
HttpExchange() - Constructor for class javax.xml.ws.spi.http.HttpExchange
HttpHandler - Class in javax.xml.ws.spi.http
A handler which is invoked to process HTTP requests.
HttpHandler() - Constructor for class javax.xml.ws.spi.http.HttpHandler
HttpRetryException - Exception in java.net
Thrown to indicate that a HTTP request needs to be retried but cannot be retried automatically, due to streaming mode being enabled.
HttpRetryException(String, int) - Constructor for exception java.net.HttpRetryException
Constructs a new HttpRetryException from the specified response code and exception detail message
HttpRetryException(String, int, String) - Constructor for exception java.net.HttpRetryException
Constructs a new HttpRetryException with detail message responseCode and the contents of the Location response header field.
HTTPS - Static variable in class javax.print.attribute.standard.ReferenceUriSchemesSupported
Secure HyperText Transfer Protocol (HTTPS).
HttpsURLConnection - Class in javax.net.ssl
HttpsURLConnection extends HttpURLConnection with support for https-specific features.
HttpsURLConnection(URL) - Constructor for class javax.net.ssl.HttpsURLConnection
Creates an HttpsURLConnection using the URL specified.
HttpURLConnection - Class in java.net
A URLConnection with support for HTTP-specific features.
HttpURLConnection(URL) - Constructor for class java.net.HttpURLConnection
Constructor for the HttpURLConnection.
HUFFMAN_ONLY - Static variable in class java.util.zip.Deflater
Compression strategy for Huffman coding only.
HYPERLINK - Static variable in class javax.accessibility.AccessibleRole
A hypertext anchor
HyperlinkEvent - Class in javax.swing.event
HyperlinkEvent is used to notify interested parties that something has happened with respect to a hypertext link.
HyperlinkEvent(Object, HyperlinkEvent.EventType, URL) - Constructor for class javax.swing.event.HyperlinkEvent
Creates a new object representing a hypertext link event.
HyperlinkEvent(Object, HyperlinkEvent.EventType, URL, String) - Constructor for class javax.swing.event.HyperlinkEvent
Creates a new object representing a hypertext link event.
HyperlinkEvent(Object, HyperlinkEvent.EventType, URL, String, Element) - Constructor for class javax.swing.event.HyperlinkEvent
Creates a new object representing a hypertext link event.
HyperlinkEvent(Object, HyperlinkEvent.EventType, URL, String, Element, InputEvent) - Constructor for class javax.swing.event.HyperlinkEvent
Creates a new object representing a hypertext link event.
HyperlinkEvent.EventType - Class in javax.swing.event
Defines the ENTERED, EXITED, and ACTIVATED event types, along with their string representations, returned by toString().
HyperlinkListener - Interface in javax.swing.event
HyperlinkListener
hyperlinkUpdate(HyperlinkEvent) - Method in interface javax.swing.event.HyperlinkListener
Called when a hypertext link is updated.
hypot(double, double) - Static method in class java.lang.Math
Returns sqrt(x2 +y2) without intermediate overflow or underflow.
hypot(double, double) - Static method in class java.lang.StrictMath
Returns sqrt(x2 +y2) without intermediate overflow or underflow.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames


I-Index (Java Platform SE 8 )

Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames
  • All Classes
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

I

I - Static variable in class javax.swing.text.html.HTML.Tag
icAbsoluteColorimetric - Static variable in class java.awt.color.ICC_Profile
ICC Profile Rendering Intent: AbsoluteColorimetric.
ICC_ColorSpace - Class in java.awt.color
The ICC_ColorSpace class is an implementation of the abstract ColorSpace class.
ICC_ColorSpace(ICC_Profile) - Constructor for class java.awt.color.ICC_ColorSpace
Constructs a new ICC_ColorSpace from an ICC_Profile object.
ICC_Profile - Class in java.awt.color
A representation of color profile data for device independent and device dependent color spaces based on the International Color Consortium Specification ICC.1:2001-12, File Format for Color Profiles, (see http://www.color.org).
ICC_ProfileGray - Class in java.awt.color
A subclass of the ICC_Profile class which represents profiles which meet the following criteria: the color space type of the profile is TYPE_GRAY and the profile includes the grayTRCTag and mediaWhitePointTag tags.
ICC_ProfileRGB - Class in java.awt.color
The ICC_ProfileRGB class is a subclass of the ICC_Profile class that represents profiles which meet the following criteria: The profile's color space type is RGB. The profile includes the redColorantTag, greenColorantTag, blueColorantTag, redTRCTag, greenTRCTag, blueTRCTag, and mediaWhitePointTag tags. The ICC_Profile getInstance method will return an ICC_ProfileRGB object when these conditions are met.
icCurveCount - Static variable in class java.awt.color.ICC_Profile
ICC Profile Constant: curveType count.
icCurveData - Static variable in class java.awt.color.ICC_Profile
ICC Profile Constant: curveType data.
icHdrAttributes - Static variable in class java.awt.color.ICC_Profile
ICC Profile Header Location: device attributes.
icHdrCmmId - Static variable in class java.awt.color.ICC_Profile
ICC Profile Header Location: CMM for this profile.
icHdrColorSpace - Static variable in class java.awt.color.ICC_Profile
ICC Profile Header Location: color space of data.
icHdrCreator - Static variable in class java.awt.color.ICC_Profile
ICC Profile Header Location: profile creator.
icHdrDate - Static variable in class java.awt.color.ICC_Profile
ICC Profile Header Location: date profile was created.
icHdrDeviceClass - Static variable in class java.awt.color.ICC_Profile
ICC Profile Header Location: type of profile.
icHdrFlags - Static variable in class java.awt.color.ICC_Profile
ICC Profile Header Location: various bit settings.
icHdrIlluminant - Static variable in class java.awt.color.ICC_Profile
ICC Profile Header Location: profile illuminant.
icHdrMagic - Static variable in class java.awt.color.ICC_Profile
ICC Profile Header Location: icMagicNumber.
icHdrManufacturer - Static variable in class java.awt.color.ICC_Profile
ICC Profile Header Location: device manufacturer.
icHdrModel - Static variable in class java.awt.color.ICC_Profile
ICC Profile Header Location: device model number.
icHdrPcs - Static variable in class java.awt.color.ICC_Profile
ICC Profile Header Location: PCS - XYZ or Lab only.
icHdrPlatform - Static variable in class java.awt.color.ICC_Profile
ICC Profile Header Location: primary platform.
icHdrProfileID - Static variable in class java.awt.color.ICC_Profile
ICC Profile Header Location: profile's ID.
icHdrRenderingIntent - Static variable in class java.awt.color.ICC_Profile
ICC Profile Header Location: rendering intent.
icHdrSize - Static variable in class java.awt.color.ICC_Profile
ICC Profile Header Location: profile size in bytes.
icHdrVersion - Static variable in class java.awt.color.ICC_Profile
ICC Profile Header Location: format version number.
icICCAbsoluteColorimetric - Static variable in class java.awt.color.ICC_Profile
ICC Profile Rendering Intent: ICC-AbsoluteColorimetric.
icMediaRelativeColorimetric - Static variable in class java.awt.color.ICC_Profile
ICC Profile Rendering Intent: Media-RelativeColorimetric.
ICON - Static variable in class javax.accessibility.AccessibleRole
A small fixed size picture, typically used to decorate components.
Icon - Interface in javax.swing
A small fixed size picture, typically used to decorate components.
icon - Variable in class javax.swing.JOptionPane
Icon used in pane.
icon - Variable in class javax.swing.plaf.basic.BasicRadioButtonUI
ICON_CHANGED_PROPERTY - Static variable in class javax.swing.AbstractButton
Identifies a change to the icon that represents the button.
ICON_COLOR_16x16 - Static variable in interface java.beans.BeanInfo
Constant to indicate a 16 x 16 color icon.
ICON_COLOR_32x32 - Static variable in interface java.beans.BeanInfo
Constant to indicate a 32 x 32 color icon.
ICON_MONO_16x16 - Static variable in interface java.beans.BeanInfo
Constant to indicate a 16 x 16 monochrome icon.
ICON_MONO_32x32 - Static variable in interface java.beans.BeanInfo
Constant to indicate a 32 x 32 monochrome icon.
ICON_PROPERTY - Static variable in class javax.swing.JOptionPane
Bound property name for icon.
iconable - Variable in class javax.swing.JInternalFrame
The frame can "iconified" (shrunk down and displayed as an icon-image).
IconAttribute - Static variable in class javax.swing.text.StyleConstants
Name of the icon attribute.
iconButton - Variable in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
iconCache - Variable in class javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView
IconElementName - Static variable in class javax.swing.text.StyleConstants
Name of elements used to represent icons.
iconIcon - Variable in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
ICONIFIED - Static variable in class java.awt.Frame
This state bit indicates that frame is iconified.
ICONIFIED - Static variable in class javax.accessibility.AccessibleState
Indicates this object is minimized and is represented only by an icon.
ICONIFY_CMD - Static variable in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
iconifyAction - Variable in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
IconifyAction() - Constructor for class javax.swing.plaf.basic.BasicInternalFrameTitlePane.IconifyAction
iconifyFrame(JInternalFrame) - Method in class javax.swing.DefaultDesktopManager
Removes the frame from its parent and adds its desktopIcon to the parent.
iconifyFrame(JInternalFrame) - Method in interface javax.swing.DesktopManager
Generally, remove this frame from it's parent and add an iconic representation.
iconifyFrame(JInternalFrame) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
This method is called when the user wants to iconify the frame.
iconOnly - Variable in class javax.swing.plaf.metal.MetalComboBoxButton
iconPane - Variable in class javax.swing.plaf.basic.BasicDesktopIconUI
The title pane component used in the desktop icon.
IconUIResource - Class in javax.swing.plaf
An Icon wrapper class which implements UIResource.
IconUIResource(Icon) - Constructor for class javax.swing.plaf.IconUIResource
Creates a UIResource icon object which wraps an existing Icon instance.
IconView - Class in javax.swing.text
Icon decorator that implements the view interface.
IconView(Element) - Constructor for class javax.swing.text.IconView
Creates a new icon view that represents an element.
icPerceptual - Static variable in class java.awt.color.ICC_Profile
ICC Profile Rendering Intent: Perceptual.
icRelativeColorimetric - Static variable in class java.awt.color.ICC_Profile
ICC Profile Rendering Intent: RelativeColorimetric.
icSaturation - Static variable in class java.awt.color.ICC_Profile
ICC Profile Rendering Intent: Saturation.
icSigAbstractClass - Static variable in class java.awt.color.ICC_Profile
ICC Profile Class Signature: 'abst'.
icSigAToB0Tag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'A2B0'.
icSigAToB1Tag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'A2B1'.
icSigAToB2Tag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'A2B2'.
icSigBlueColorantTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'bXYZ'.
icSigBlueMatrixColumnTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'bXYZ'.
icSigBlueTRCTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'bTRC'.
icSigBToA0Tag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'B2A0'.
icSigBToA1Tag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'B2A1'.
icSigBToA2Tag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'B2A2'.
icSigCalibrationDateTimeTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'calt'.
icSigCharTargetTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'targ'.
icSigChromaticAdaptationTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'chad'.
icSigChromaticityTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'chrm'.
icSigCmyData - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: 'CMY '.
icSigCmykData - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: 'CMYK'.
icSigColorantOrderTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'clro'.
icSigColorantTableTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'clrt'.
icSigColorSpaceClass - Static variable in class java.awt.color.ICC_Profile
ICC Profile Class Signature: 'spac'.
icSigCopyrightTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'cprt'.
icSigCrdInfoTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'crdi'.
icSigDeviceMfgDescTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'dmnd'.
icSigDeviceModelDescTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'dmdd'.
icSigDeviceSettingsTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'devs'.
icSigDisplayClass - Static variable in class java.awt.color.ICC_Profile
ICC Profile Class Signature: 'mntr'.
icSigGamutTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'gamt'.
icSigGrayData - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: 'GRAY'.
icSigGrayTRCTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'kTRC'.
icSigGreenColorantTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'gXYZ'.
icSigGreenMatrixColumnTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'gXYZ'.
icSigGreenTRCTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'gTRC'.
icSigHead - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'head' - special.
icSigHlsData - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: 'HLS'.
icSigHsvData - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: 'HSV'.
icSigInputClass - Static variable in class java.awt.color.ICC_Profile
ICC Profile Class Signature: 'scnr'.
icSigLabData - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: 'Lab '.
icSigLinkClass - Static variable in class java.awt.color.ICC_Profile
ICC Profile Class Signature: 'link'.
icSigLuminanceTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'lumi'.
icSigLuvData - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: 'Luv '.
icSigMeasurementTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'meas'.
icSigMediaBlackPointTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'bkpt'.
icSigMediaWhitePointTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'wtpt'.
icSigNamedColor2Tag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'ncl2'.
icSigNamedColorClass - Static variable in class java.awt.color.ICC_Profile
ICC Profile Class Signature: 'nmcl'.
icSigOutputClass - Static variable in class java.awt.color.ICC_Profile
ICC Profile Class Signature: 'prtr'.
icSigOutputResponseTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'resp'.
icSigPreview0Tag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'pre0'.
icSigPreview1Tag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'pre1'.
icSigPreview2Tag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'pre2'.
icSigProfileDescriptionTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'desc'.
icSigProfileSequenceDescTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'pseq'.
icSigPs2CRD0Tag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'psd0'.
icSigPs2CRD1Tag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'psd1'.
icSigPs2CRD2Tag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'psd2'.
icSigPs2CRD3Tag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'psd3'.
icSigPs2CSATag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'ps2s'.
icSigPs2RenderingIntentTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'ps2i'.
icSigRedColorantTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'rXYZ'.
icSigRedMatrixColumnTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'rXYZ'.
icSigRedTRCTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'rTRC'.
icSigRgbData - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: 'RGB '.
icSigScreeningDescTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'scrd'.
icSigScreeningTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'scrn'.
icSigSpace2CLR - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: '2CLR'.
icSigSpace3CLR - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: '3CLR'.
icSigSpace4CLR - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: '4CLR'.
icSigSpace5CLR - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: '5CLR'.
icSigSpace6CLR - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: '6CLR'.
icSigSpace7CLR - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: '7CLR'.
icSigSpace8CLR - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: '8CLR'.
icSigSpace9CLR - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: '9CLR'.
icSigSpaceACLR - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: 'ACLR'.
icSigSpaceBCLR - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: 'BCLR'.
icSigSpaceCCLR - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: 'CCLR'.
icSigSpaceDCLR - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: 'DCLR'.
icSigSpaceECLR - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: 'ECLR'.
icSigSpaceFCLR - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: 'FCLR'.
icSigTechnologyTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'tech'.
icSigUcrBgTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'bfd '.
icSigViewingCondDescTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'vued'.
icSigViewingConditionsTag - Static variable in class java.awt.color.ICC_Profile
ICC Profile Tag Signature: 'view'.
icSigXYZData - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: 'XYZ '.
icSigYCbCrData - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: 'YCbr'.
icSigYxyData - Static variable in class java.awt.color.ICC_Profile
ICC Profile Color Space Type Signature: 'Yxy '.
icTagReserved - Static variable in class java.awt.color.ICC_Profile
ICC Profile Constant: reserved.
icTagType - Static variable in class java.awt.color.ICC_Profile
ICC Profile Constant: tag type signaturE.
icXYZNumberX - Static variable in class java.awt.color.ICC_Profile
ICC Profile Constant: XYZNumber X.
id - Variable in class java.awt.AWTEvent
The event's id.
id - Variable in class java.awt.Event
Indicates which type of event the event is, and which other Event variables are relevant for the event.
id - Variable in class javax.naming.ldap.BasicControl
The control's object identifier string.
ID - Static variable in class javax.swing.text.html.HTML.Attribute
ID - Static variable in interface javax.swing.text.html.parser.DTDConstants
ID - Static variable in class javax.xml.ws.RespectBindingFeature
Constant value identifying the RespectBindingFeature
ID - Static variable in class javax.xml.ws.soap.AddressingFeature
Constant value identifying the AddressingFeature
ID - Static variable in class javax.xml.ws.soap.MTOMFeature
Constant value identifying the MTOMFeature
id() - Static method in class org.omg.CORBA.AnySeqHelper
id() - Static method in class org.omg.CORBA.BooleanSeqHelper
id() - Static method in class org.omg.CORBA.CharSeqHelper
id() - Static method in class org.omg.CORBA.CompletionStatusHelper
id() - Static method in class org.omg.CORBA.CurrentHelper
id() - Static method in class org.omg.CORBA.DefinitionKindHelper
id() - Static method in class org.omg.CORBA.DoubleSeqHelper
id() - Static method in class org.omg.CORBA.FieldNameHelper
id() - Static method in class org.omg.CORBA.FloatSeqHelper
id() - Static method in class org.omg.CORBA.IdentifierHelper
id() - Static method in class org.omg.CORBA.IDLTypeHelper
id() - Static method in class org.omg.CORBA.LongLongSeqHelper
id() - Static method in class org.omg.CORBA.LongSeqHelper
id - Variable in class org.omg.CORBA.NameValuePair
The name to be associated with a value by this NameValuePair object.
id() - Static method in class org.omg.CORBA.NameValuePairHelper
id() - Static method in class org.omg.CORBA.ObjectHelper
id() - Static method in class org.omg.CORBA.OctetSeqHelper
id() - Static method in class org.omg.CORBA.ParameterModeHelper
id() - Static method in class org.omg.CORBA.PolicyErrorCodeHelper
id() - Static method in class org.omg.CORBA.PolicyErrorHelper
id() - Static method in class org.omg.CORBA.PolicyHelper
id() - Static method in class org.omg.CORBA.PolicyListHelper
id() - Static method in class org.omg.CORBA.PolicyTypeHelper
id() - Static method in class org.omg.CORBA.RepositoryIdHelper
id() - Static method in class org.omg.CORBA.ServiceDetailHelper
id() - Static method in class org.omg.CORBA.ServiceInformationHelper
id() - Static method in class org.omg.CORBA.SetOverrideTypeHelper
id() - Static method in class org.omg.CORBA.ShortSeqHelper
id() - Static method in class org.omg.CORBA.StringSeqHelper
id() - Static method in class org.omg.CORBA.StringValueHelper
id() - Static method in class org.omg.CORBA.StructMemberHelper
id() - Method in class org.omg.CORBA.TypeCode
Retrieves the RepositoryId globally identifying the type of this TypeCode object.
id() - Static method in class org.omg.CORBA.ULongLongSeqHelper
id() - Static method in class org.omg.CORBA.ULongSeqHelper
id() - Static method in class org.omg.CORBA.UnionMemberHelper
id() - Static method in class org.omg.CORBA.UnknownUserExceptionHelper
id() - Static method in class org.omg.CORBA.UShortSeqHelper
id() - Static method in class org.omg.CORBA.ValueBaseHelper
id - Variable in class org.omg.CORBA.ValueMember
The repository ID of the value member described by this ValueMember object;
id() - Static method in class org.omg.CORBA.ValueMemberHelper
id() - Static method in class org.omg.CORBA.VersionSpecHelper
id() - Static method in class org.omg.CORBA.VisibilityHelper
id() - Static method in class org.omg.CORBA.WCharSeqHelper
id() - Static method in class org.omg.CORBA.WrongTransactionHelper
id() - Static method in class org.omg.CORBA.WStringSeqHelper
id() - Static method in class org.omg.CORBA.WStringValueHelper
id() - Static method in class org.omg.CosNaming.BindingHelper
id() - Static method in class org.omg.CosNaming.BindingIteratorHelper
id() - Static method in class org.omg.CosNaming.BindingListHelper
id() - Static method in class org.omg.CosNaming.BindingTypeHelper
id() - Static method in class org.omg.CosNaming.IstringHelper
id - Variable in class org.omg.CosNaming.NameComponent
id() - Static method in class org.omg.CosNaming.NameComponentHelper
id() - Static method in class org.omg.CosNaming.NameHelper
id() - Static method in class org.omg.CosNaming.NamingContextExtHelper
id() - Static method in class org.omg.CosNaming.NamingContextExtPackage.AddressHelper
id() - Static method in class org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper
id() - Static method in class org.omg.CosNaming.NamingContextExtPackage.StringNameHelper
id() - Static method in class org.omg.CosNaming.NamingContextExtPackage.URLStringHelper
id() - Static method in class org.omg.CosNaming.NamingContextHelper
id() - Static method in class org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper
id() - Static method in class org.omg.CosNaming.NamingContextPackage.CannotProceedHelper
id() - Static method in class org.omg.CosNaming.NamingContextPackage.InvalidNameHelper
id() - Static method in class org.omg.CosNaming.NamingContextPackage.NotEmptyHelper
id() - Static method in class org.omg.CosNaming.NamingContextPackage.NotFoundHelper
id() - Static method in class org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper
id() - Static method in class org.omg.DynamicAny.AnySeqHelper
id() - Static method in class org.omg.DynamicAny.DynAnyFactoryHelper
id() - Static method in class org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper
id() - Static method in class org.omg.DynamicAny.DynAnyHelper
id() - Static method in class org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper
id() - Static method in class org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper
id() - Static method in class org.omg.DynamicAny.DynAnySeqHelper
id() - Static method in class org.omg.DynamicAny.DynArrayHelper
id() - Static method in class org.omg.DynamicAny.DynEnumHelper
id() - Static method in class org.omg.DynamicAny.DynFixedHelper
id() - Static method in class org.omg.DynamicAny.DynSequenceHelper
id() - Static method in class org.omg.DynamicAny.DynStructHelper
id() - Static method in class org.omg.DynamicAny.DynUnionHelper
id() - Static method in class org.omg.DynamicAny.DynValueHelper
id() - Static method in class org.omg.DynamicAny.FieldNameHelper
id - Variable in class org.omg.DynamicAny.NameDynAnyPair
The name associated with the DynAny.
id() - Static method in class org.omg.DynamicAny.NameDynAnyPairHelper
id() - Static method in class org.omg.DynamicAny.NameDynAnyPairSeqHelper
id - Variable in class org.omg.DynamicAny.NameValuePair
The name associated with the Any.
id() - Static method in class org.omg.DynamicAny.NameValuePairHelper
id() - Static method in class org.omg.DynamicAny.NameValuePairSeqHelper
id() - Static method in class org.omg.IOP.CodecFactoryHelper
id() - Static method in class org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper
id() - Static method in class org.omg.IOP.CodecPackage.FormatMismatchHelper
id() - Static method in class org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper
id() - Static method in class org.omg.IOP.CodecPackage.TypeMismatchHelper
id() - Static method in class org.omg.IOP.ComponentIdHelper
id() - Static method in class org.omg.IOP.IORHelper
id() - Static method in class org.omg.IOP.MultipleComponentProfileHelper
id() - Static method in class org.omg.IOP.ProfileIdHelper
id() - Static method in class org.omg.IOP.ServiceContextHelper
id() - Static method in class org.omg.IOP.ServiceContextListHelper
id() - Static method in class org.omg.IOP.ServiceIdHelper
id() - Static method in class org.omg.IOP.TaggedComponentHelper
id() - Static method in class org.omg.IOP.TaggedProfileHelper
id() - Static method in class org.omg.Messaging.SyncScopeHelper
id() - Static method in class org.omg.PortableInterceptor.AdapterManagerIdHelper
id() - Static method in class org.omg.PortableInterceptor.AdapterNameHelper
id() - Static method in class org.omg.PortableInterceptor.AdapterStateHelper
id() - Static method in class org.omg.PortableInterceptor.CurrentHelper
id() - Static method in class org.omg.PortableInterceptor.ForwardRequestHelper
id() - Static method in class org.omg.PortableInterceptor.InvalidSlotHelper
id() - Static method in class org.omg.PortableInterceptor.IORInterceptor_3_0Helper
id() - Static method in class org.omg.PortableInterceptor.ObjectIdHelper
id() - Static method in class org.omg.PortableInterceptor.ObjectReferenceFactoryHelper
id() - Static method in class org.omg.PortableInterceptor.ObjectReferenceTemplateHelper
id() - Static method in class org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper
id() - Static method in class org.omg.PortableInterceptor.ORBIdHelper
id() - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper
id() - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper
id() - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper
id() - Static method in class org.omg.PortableInterceptor.ServerIdHelper
id() - Static method in class org.omg.PortableServer.CurrentHelper
id() - Static method in class org.omg.PortableServer.CurrentPackage.NoContextHelper
id() - Static method in class org.omg.PortableServer.ForwardRequestHelper
id() - Static method in class org.omg.PortableServer.POAHelper
id() - Static method in class org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper
id() - Method in interface org.omg.PortableServer.POAOperations
This returns the unique id of the POA in the process in which it is created.
id() - Static method in class org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper
id() - Static method in class org.omg.PortableServer.POAPackage.AdapterNonExistentHelper
id() - Static method in class org.omg.PortableServer.POAPackage.InvalidPolicyHelper
id() - Static method in class org.omg.PortableServer.POAPackage.NoServantHelper
id() - Static method in class org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper
id() - Static method in class org.omg.PortableServer.POAPackage.ObjectNotActiveHelper
id() - Static method in class org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper
id() - Static method in class org.omg.PortableServer.POAPackage.ServantNotActiveHelper
id() - Static method in class org.omg.PortableServer.POAPackage.WrongAdapterHelper
id() - Static method in class org.omg.PortableServer.POAPackage.WrongPolicyHelper
id() - Static method in class org.omg.PortableServer.ServantActivatorHelper
id() - Static method in class org.omg.PortableServer.ServantLocatorHelper
ID_ASSIGNMENT_POLICY_ID - Interface in org.omg.PortableServer
org/omg/PortableServer/ID_ASSIGNMENT_POLICY_ID.java .
id_to_reference(byte[]) - Method in interface org.omg.PortableServer.POAOperations
If an object with the specified Object Id value is currently active, a reference encapsulating the information used to activate the object is returned.
id_to_servant(byte[]) - Method in interface org.omg.PortableServer.POAOperations
If the POA has the RETAIN policy and the specified ObjectId is in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map.
ID_UNIQUENESS_POLICY_ID - Interface in org.omg.PortableServer
org/omg/PortableServer/ID_UNIQUENESS_POLICY_ID.java .
IdAssignmentPolicy - Interface in org.omg.PortableServer
IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB.
IdAssignmentPolicyOperations - Interface in org.omg.PortableServer
IdAssignmentPolicy specifies whether Object Ids in the created POA are generated by the application or by the ORB.
IdAssignmentPolicyValue - Class in org.omg.PortableServer
The IdAssignmentPolicyValue can have the following values.
IdAssignmentPolicyValue(int) - Constructor for class org.omg.PortableServer.IdAssignmentPolicyValue
IDENTICAL - Static variable in class java.text.Collator
Collator strength value.
identifier - Variable in class javax.swing.table.TableColumn
This object is not used internally by the drawing machinery of the JTable; identifiers may be set in the TableColumn as as an optional way to tag and locate table columns.
IdentifierHelper - Class in org.omg.CORBA
The Helper for Identifier.
IdentifierHelper() - Constructor for class org.omg.CORBA.IdentifierHelper
identities() - Method in class java.security.IdentityScope
Deprecated.
Returns an enumeration of all identities in this identity scope.
IDENTITY - Static variable in class java.awt.font.TransformAttribute
A TransformAttribute representing the identity transform.
identity(Class<?>) - Static method in class java.lang.invoke.MethodHandles
Produces a method handle which returns its sole argument when invoked.
Identity - Class in java.security
Deprecated.
This class is no longer used. Its functionality has been replaced by java.security.KeyStore, the java.security.cert package, and java.security.Principal.
Identity() - Constructor for class java.security.Identity
Deprecated.
Constructor for serialization only.
Identity(String, IdentityScope) - Constructor for class java.security.Identity
Deprecated.
Constructs an identity with the specified name and scope.
Identity(String) - Constructor for class java.security.Identity
Deprecated.
Constructs an identity with the specified name and no scope.
identity() - Static method in interface java.util.function.DoubleUnaryOperator
Returns a unary operator that always returns its input argument.
identity() - Static method in interface java.util.function.Function
Returns a function that always returns its input argument.
identity() - Static method in interface java.util.function.IntUnaryOperator
Returns a unary operator that always returns its input argument.
identity() - Static method in interface java.util.function.LongUnaryOperator
Returns a unary operator that always returns its input argument.
identity() - Static method in interface java.util.function.UnaryOperator
Returns a unary operator that always returns its input argument.
identityEquals(Identity) - Method in class java.security.Identity
Deprecated.
Tests for equality between the specified identity and this identity.
identityHashCode(Object) - Static method in class java.lang.System
Returns the same hash code for the given object as would be returned by the default method hashCode(), whether or not the given object's class overrides hashCode().
IdentityHashMap<K,V> - Class in java.util
This class implements the Map interface with a hash table, using reference-equality in place of object-equality when comparing keys (and values).
IdentityHashMap() - Constructor for class java.util.IdentityHashMap
Constructs a new, empty identity hash map with a default expected maximum size (21).
IdentityHashMap(int) - Constructor for class java.util.IdentityHashMap
Constructs a new, empty map with the specified expected maximum size.
IdentityHashMap(Map<? extends K, ? extends V>) - Constructor for class java.util.IdentityHashMap
Constructs a new identity hash map containing the keys-value mappings in the specified map.
IdentityScope - Class in java.security
Deprecated.
This class is no longer used. Its functionality has been replaced by java.security.KeyStore, the java.security.cert package, and java.security.Principal.
IdentityScope() - Constructor for class java.security.IdentityScope
Deprecated.
This constructor is used for serialization only and should not be used by subclasses.
IdentityScope(String) - Constructor for class java.security.IdentityScope
Deprecated.
Constructs a new identity scope with the specified name.
IdentityScope(String, IdentityScope) - Constructor for class java.security.IdentityScope
Deprecated.
Constructs a new identity scope with the specified name and scope.
IDEOGRAPHIC_DESCRIPTION_CHARACTERS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Ideographic Description Characters" Unicode character block.
IDLE - Static variable in class javax.print.attribute.standard.PrinterState
Indicates that new jobs can start processing without waiting.
IDLEntity - Interface in org.omg.CORBA.portable
An interface with no members whose only purpose is to serve as a marker indicating that an implementing class is a Java value type from IDL that has a corresponding Helper class.
IDLType - Interface in org.omg.CORBA
An abstract interface inherited by all Interface Repository (IR) objects that represent OMG IDL types.
IDLTypeHelper - Class in org.omg.CORBA
The Helper for IDLType.
IDLTypeHelper() - Constructor for class org.omg.CORBA.IDLTypeHelper
IDLTypeOperations - Interface in org.omg.CORBA
This interface must be implemented by all IDLType objects.
IDN - Class in java.net
Provides methods to convert internationalized domain names (IDNs) between a normal Unicode representation and an ASCII Compatible Encoding (ACE) representation.
IDREF - Static variable in interface javax.swing.text.html.parser.DTDConstants
IDREFS - Static variable in interface javax.swing.text.html.parser.DTDConstants
IdUniquenessPolicy - Interface in org.omg.PortableServer
The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities.
IdUniquenessPolicyOperations - Interface in org.omg.PortableServer
The IdUniquenessPolicy specifies whether the servants activated in the created POA must have unique object i identities.
IdUniquenessPolicyValue - Class in org.omg.PortableServer
IdUniquenessPolicyValue can have the following values.
IdUniquenessPolicyValue(int) - Constructor for class org.omg.PortableServer.IdUniquenessPolicyValue
IEEEremainder(double, double) - Static method in class java.lang.Math
Computes the remainder operation on two arguments as prescribed by the IEEE 754 standard.
IEEEremainder(double, double) - Static method in class java.lang.StrictMath
Computes the remainder operation on two arguments as prescribed by the IEEE 754 standard.
ifModifiedSince - Variable in class java.net.URLConnection
Some protocols support skipping the fetching of the object unless the object has been modified more recently than a certain time.
ifPresent(Consumer<? super T>) - Method in class java.util.Optional
If a value is present, invoke the specified consumer with the value, otherwise do nothing.
ifPresent(DoubleConsumer) - Method in class java.util.OptionalDouble
Have the specified consumer accept the value if a value is present, otherwise do nothing.
ifPresent(IntConsumer) - Method in class java.util.OptionalInt
Have the specified consumer accept the value if a value is present, otherwise do nothing.
ifPresent(LongConsumer) - Method in class java.util.OptionalLong
Have the specified consumer accept the value if a value is present, otherwise do nothing.
ignorableWhitespace(char[], int, int) - Method in interface org.xml.sax.ContentHandler
Receive notification of ignorable whitespace in element content.
ignorableWhitespace(char[], int, int) - Method in interface org.xml.sax.DocumentHandler
Deprecated.
Receive notification of ignorable whitespace in element content.
ignorableWhitespace(char[], int, int) - Method in class org.xml.sax.HandlerBase
Deprecated.
Receive notification of ignorable whitespace in element content.
ignorableWhitespace(char[], int, int) - Method in class org.xml.sax.helpers.DefaultHandler
Receive notification of ignorable whitespace in element content.
ignorableWhitespace(char[], int, int) - Method in class org.xml.sax.helpers.ParserAdapter
Adapter implementation method; do not call.
ignorableWhitespace(char[], int, int) - Method in class org.xml.sax.helpers.XMLFilterImpl
Filter an ignorable whitespace event.
ignorableWhitespace(char[], int, int) - Method in class org.xml.sax.helpers.XMLReaderAdapter
Adapt a SAX2 ignorable whitespace event.
IGNORE - Static variable in class java.nio.charset.CodingErrorAction
Action indicating that a coding error is to be handled by dropping the erroneous input and resuming the coding operation.
IGNORE_ALL_BEANINFO - Static variable in class java.beans.Introspector
Flag to indicate to ignore all beaninfo.
IGNORE_IMMEDIATE_BEANINFO - Static variable in class java.beans.Introspector
Flag to indicate to ignore immediate beaninfo.
ignoreMetadata - Variable in class javax.imageio.ImageReader
true if the current input source has been marked as allowing metadata to be ignored by setInput.
IIOByteBuffer - Class in javax.imageio.stream
A class representing a mutable reference to an array of bytes and an offset and length within that array.
IIOByteBuffer(byte[], int, int) - Constructor for class javax.imageio.stream.IIOByteBuffer
Constructs an IIOByteBuffer that references a given byte array, offset, and length.
IIOException - Exception in javax.imageio
An exception class used for signaling run-time failure of reading and writing operations.
IIOException(String) - Constructor for exception javax.imageio.IIOException
Constructs an IIOException with a given message String.
IIOException(String, Throwable) - Constructor for exception javax.imageio.IIOException
Constructs an IIOException with a given message String and a Throwable that was its underlying cause.
IIOImage - Class in javax.imageio
A simple container class to aggregate an image, a set of thumbnail (preview) images, and an object representing metadata associated with the image.
IIOImage(RenderedImage, List<? extends BufferedImage>, IIOMetadata) - Constructor for class javax.imageio.IIOImage
Constructs an IIOImage containing a RenderedImage, and thumbnails and metadata associated with it.
IIOImage(Raster, List<? extends BufferedImage>, IIOMetadata) - Constructor for class javax.imageio.IIOImage
Constructs an IIOImage containing a Raster, and thumbnails and metadata associated with it.
IIOInvalidTreeException - Exception in javax.imageio.metadata
An IIOInvalidTreeException is thrown when an attempt by an IIOMetadata object to parse a tree of IIOMetadataNodes fails.
IIOInvalidTreeException(String, Node) - Constructor for exception javax.imageio.metadata.IIOInvalidTreeException
Constructs an IIOInvalidTreeException with a message string and a reference to the Node that caused the parsing error.
IIOInvalidTreeException(String, Throwable, Node) - Constructor for exception javax.imageio.metadata.IIOInvalidTreeException
Constructs an IIOInvalidTreeException with a message string, a reference to an exception that caused this exception, and a reference to the Node that caused the parsing error.
IIOMetadata - Class in javax.imageio.metadata
An abstract class to be extended by objects that represent metadata (non-image data) associated with images and streams.
IIOMetadata() - Constructor for class javax.imageio.metadata.IIOMetadata
Constructs an empty IIOMetadata object.
IIOMetadata(boolean, String, String, String[], String[]) - Constructor for class javax.imageio.metadata.IIOMetadata
Constructs an IIOMetadata object with the given format names and format class names, as well as a boolean indicating whether the standard format is supported.
IIOMetadataController - Interface in javax.imageio.metadata
An interface to be implemented by objects that can determine the settings of an IIOMetadata object, either by putting up a GUI to obtain values from a user, or by other means.
IIOMetadataFormat - Interface in javax.imageio.metadata
An object describing the structure of metadata documents returned from IIOMetadata.getAsTree and passed to IIOMetadata.setFromTree and mergeTree.
IIOMetadataFormatImpl - Class in javax.imageio.metadata
A concrete class providing a reusable implementation of the IIOMetadataFormat interface.
IIOMetadataFormatImpl(String, int) - Constructor for class javax.imageio.metadata.IIOMetadataFormatImpl
Constructs a blank IIOMetadataFormatImpl instance, with a given root element name and child policy (other than CHILD_POLICY_REPEAT).
IIOMetadataFormatImpl(String, int, int) - Constructor for class javax.imageio.metadata.IIOMetadataFormatImpl
Constructs a blank IIOMetadataFormatImpl instance, with a given root element name and a child policy of CHILD_POLICY_REPEAT.
IIOMetadataNode - Class in javax.imageio.metadata
A class representing a node in a meta-data tree, which implements the org.w3c.dom.Element interface and additionally allows for the storage of non-textual objects via the getUserObject and setUserObject methods.
IIOMetadataNode() - Constructor for class javax.imageio.metadata.IIOMetadataNode
Constructs an empty IIOMetadataNode.
IIOMetadataNode(String) - Constructor for class javax.imageio.metadata.IIOMetadataNode
Constructs an IIOMetadataNode with a given node name.
IIOParam - Class in javax.imageio
A superclass of all classes describing how streams should be decoded or encoded.
IIOParam() - Constructor for class javax.imageio.IIOParam
Protected constructor may be called only by subclasses.
IIOParamController - Interface in javax.imageio
An interface to be implemented by objects that can determine the settings of an IIOParam object, either by putting up a GUI to obtain values from a user, or by other means.
IIOReadProgressListener - Interface in javax.imageio.event
An interface used by ImageReader implementations to notify callers of their image and thumbnail reading methods of progress.
IIOReadUpdateListener - Interface in javax.imageio.event
An interface used by ImageReader implementations to notify callers of their image and thumbnail reading methods of pixel updates.
IIOReadWarningListener - Interface in javax.imageio.event
An interface used by ImageReader implementations to notify callers of their image and thumbnail reading methods of warnings (non-fatal errors).
IIORegistry - Class in javax.imageio.spi
A registry for service provider instances.
IIOServiceProvider - Class in javax.imageio.spi
A superinterface for functionality common to all Image I/O service provider interfaces (SPIs).
IIOServiceProvider(String, String) - Constructor for class javax.imageio.spi.IIOServiceProvider
Constructs an IIOServiceProvider with a given vendor name and version identifier.
IIOServiceProvider() - Constructor for class javax.imageio.spi.IIOServiceProvider
Constructs a blank IIOServiceProvider.
IIOWriteProgressListener - Interface in javax.imageio.event
An interface used by ImageWriter implementations to notify callers of their image writing methods of progress.
IIOWriteWarningListener - Interface in javax.imageio.event
An interface used by ImageWriter implementations to notify callers of their image and thumbnail reading methods of warnings (non-fatal errors).
IllegalAccessError - Error in java.lang
Thrown if an application attempts to access or modify a field, or to call a method that it does not have access to.
IllegalAccessError() - Constructor for error java.lang.IllegalAccessError
Constructs an IllegalAccessError with no detail message.
IllegalAccessError(String) - Constructor for error java.lang.IllegalAccessError
Constructs an IllegalAccessError with the specified detail message.
IllegalAccessException - Exception in java.lang
An IllegalAccessException is thrown when an application tries to reflectively create an instance (other than an array), set or get a field, or invoke a method, but the currently executing method does not have access to the definition of the specified class, field, method or constructor.
IllegalAccessException() - Constructor for exception java.lang.IllegalAccessException
Constructs an IllegalAccessException without a detail message.
IllegalAccessException(String) - Constructor for exception java.lang.IllegalAccessException
Constructs an IllegalAccessException with a detail message.
IllegalArgumentException - Exception in java.lang
Thrown to indicate that a method has been passed an illegal or inappropriate argument.
IllegalArgumentException() - Constructor for exception java.lang.IllegalArgumentException
Constructs an IllegalArgumentException with no detail message.
IllegalArgumentException(String) - Constructor for exception java.lang.IllegalArgumentException
Constructs an IllegalArgumentException with the specified detail message.
IllegalArgumentException(String, Throwable) - Constructor for exception java.lang.IllegalArgumentException
Constructs a new exception with the specified detail message and cause.
IllegalArgumentException(Throwable) - Constructor for exception java.lang.IllegalArgumentException
Constructs a new exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
IllegalBlockingModeException - Exception in java.nio.channels
Unchecked exception thrown when a blocking-mode-specific operation is invoked upon a channel in the incorrect blocking mode.
IllegalBlockingModeException() - Constructor for exception java.nio.channels.IllegalBlockingModeException
Constructs an instance of this class.
IllegalBlockSizeException - Exception in javax.crypto
This exception is thrown when the length of data provided to a block cipher is incorrect, i.e., does not match the block size of the cipher.
IllegalBlockSizeException() - Constructor for exception javax.crypto.IllegalBlockSizeException
Constructs an IllegalBlockSizeException with no detail message.
IllegalBlockSizeException(String) - Constructor for exception javax.crypto.IllegalBlockSizeException
Constructs an IllegalBlockSizeException with the specified detail message.
IllegalChannelGroupException - Exception in java.nio.channels
Unchecked exception thrown when an attempt is made to open a channel in a group that was not created by the same provider.
IllegalChannelGroupException() - Constructor for exception java.nio.channels.IllegalChannelGroupException
Constructs an instance of this class.
IllegalCharsetNameException - Exception in java.nio.charset
Unchecked exception thrown when a string that is not a legal charset name is used as such.
IllegalCharsetNameException(String) - Constructor for exception java.nio.charset.IllegalCharsetNameException
Constructs an instance of this class.
IllegalClassFormatException - Exception in java.lang.instrument
Thrown by an implementation of ClassFileTransformer.transform when its input parameters are invalid.
IllegalClassFormatException() - Constructor for exception java.lang.instrument.IllegalClassFormatException
Constructs an IllegalClassFormatException with no detail message.
IllegalClassFormatException(String) - Constructor for exception java.lang.instrument.IllegalClassFormatException
Constructs an IllegalClassFormatException with the specified detail message.
IllegalComponentStateException - Exception in java.awt
Signals that an AWT component is not in an appropriate state for the requested operation.
IllegalComponentStateException() - Constructor for exception java.awt.IllegalComponentStateException
Constructs an IllegalComponentStateException with no detail message.
IllegalComponentStateException(String) - Constructor for exception java.awt.IllegalComponentStateException
Constructs an IllegalComponentStateException with the specified detail message.
IllegalFormatCodePointException - Exception in java.util
Unchecked exception thrown when a character with an invalid Unicode code point as defined by Character.isValidCodePoint(int) is passed to the Formatter.
IllegalFormatCodePointException(int) - Constructor for exception java.util.IllegalFormatCodePointException
Constructs an instance of this class with the specified illegal code point as defined by Character.isValidCodePoint(int).
IllegalFormatConversionException - Exception in java.util
Unchecked exception thrown when the argument corresponding to the format specifier is of an incompatible type.
IllegalFormatConversionException(char, Class<?>) - Constructor for exception java.util.IllegalFormatConversionException
Constructs an instance of this class with the mismatched conversion and the corresponding argument class.
IllegalFormatException - Exception in java.util
Unchecked exception thrown when a format string contains an illegal syntax or a format specifier that is incompatible with the given arguments.
IllegalFormatFlagsException - Exception in java.util
Unchecked exception thrown when an illegal combination flags is given.
IllegalFormatFlagsException(String) - Constructor for exception java.util.IllegalFormatFlagsException
Constructs an instance of this class with the specified flags.
IllegalFormatPrecisionException - Exception in java.util
Unchecked exception thrown when the precision is a negative value other than -1, the conversion does not support a precision, or the value is otherwise unsupported.
IllegalFormatPrecisionException(int) - Constructor for exception java.util.IllegalFormatPrecisionException
Constructs an instance of this class with the specified precision.
IllegalFormatWidthException - Exception in java.util
Unchecked exception thrown when the format width is a negative value other than -1 or is otherwise unsupported.
IllegalFormatWidthException(int) - Constructor for exception java.util.IllegalFormatWidthException
Constructs an instance of this class with the specified width.
IllegalMonitorStateException - Exception in java.lang
Thrown to indicate that a thread has attempted to wait on an object's monitor or to notify other threads waiting on an object's monitor without owning the specified monitor.
IllegalMonitorStateException() - Constructor for exception java.lang.IllegalMonitorStateException
Constructs an IllegalMonitorStateException with no detail message.
IllegalMonitorStateException(String) - Constructor for exception java.lang.IllegalMonitorStateException
Constructs an IllegalMonitorStateException with the specified detail message.
IllegalPathStateException - Exception in java.awt.geom
The IllegalPathStateException represents an exception that is thrown if an operation is performed on a path that is in an illegal state with respect to the particular operation being performed, such as appending a path segment to a GeneralPath without an initial moveto.
IllegalPathStateException() - Constructor for exception java.awt.geom.IllegalPathStateException
Constructs an IllegalPathStateException with no detail message.
IllegalPathStateException(String) - Constructor for exception java.awt.geom.IllegalPathStateException
Constructs an IllegalPathStateException with the specified detail message.
IllegalSelectorException - Exception in java.nio.channels
Unchecked exception thrown when an attempt is made to register a channel with a selector that was not created by the provider that created the channel.
IllegalSelectorException() - Constructor for exception java.nio.channels.IllegalSelectorException
Constructs an instance of this class.
IllegalStateException - Exception in java.lang
Signals that a method has been invoked at an illegal or inappropriate time.
IllegalStateException() - Constructor for exception java.lang.IllegalStateException
Constructs an IllegalStateException with no detail message.
IllegalStateException(String) - Constructor for exception java.lang.IllegalStateException
Constructs an IllegalStateException with the specified detail message.
IllegalStateException(String, Throwable) - Constructor for exception java.lang.IllegalStateException
Constructs a new exception with the specified detail message and cause.
IllegalStateException(Throwable) - Constructor for exception java.lang.IllegalStateException
Constructs a new exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
IllegalThreadStateException - Exception in java.lang
Thrown to indicate that a thread is not in an appropriate state for the requested operation.
IllegalThreadStateException() - Constructor for exception java.lang.IllegalThreadStateException
Constructs an IllegalThreadStateException with no detail message.
IllegalThreadStateException(String) - Constructor for exception java.lang.IllegalThreadStateException
Constructs an IllegalThreadStateException with the specified detail message.
IllformedLocaleException - Exception in java.util
Thrown by methods in Locale and Locale.Builder to indicate that an argument is not a well-formed BCP 47 tag.
IllformedLocaleException() - Constructor for exception java.util.IllformedLocaleException
Constructs a new IllformedLocaleException with no detail message and -1 as the error index.
IllformedLocaleException(String) - Constructor for exception java.util.IllformedLocaleException
Constructs a new IllformedLocaleException with the given message and -1 as the error index.
IllformedLocaleException(String, int) - Constructor for exception java.util.IllformedLocaleException
Constructs a new IllformedLocaleException with the given message and the error index.
Image - Class in java.awt
The abstract class Image is the superclass of all classes that represent graphical images.
Image() - Constructor for class java.awt.Image
image - Variable in class javax.imageio.IIOImage
The RenderedImage being referenced.
IMAGE_INCOMPATIBLE - Static variable in class java.awt.image.VolatileImage
Validated image is incompatible with supplied GraphicsConfiguration object and should be re-created as appropriate.
IMAGE_OK - Static variable in class java.awt.image.VolatileImage
Validated image is ready to use as-is.
IMAGE_RESTORED - Static variable in class java.awt.image.VolatileImage
Validated image has been restored and is now ready to use.
IMAGEABORTED - Static variable in interface java.awt.image.ImageConsumer
The image creation process was deliberately aborted.
ImageCapabilities - Class in java.awt
Capabilities and properties of images.
ImageCapabilities(boolean) - Constructor for class java.awt.ImageCapabilities
Creates a new object for specifying image capabilities.
imageComplete(int) - Method in class java.awt.image.BufferedImageFilter
Filters the information provided in the imageComplete method of the ImageConsumer interface.
imageComplete(int) - Method in interface java.awt.image.ImageConsumer
The imageComplete method is called when the ImageProducer is finished delivering all of the pixels that the source image contains, or when a single frame of a multi-frame animation has been completed, or when an error in loading or producing the image has occurred.
imageComplete(int) - Method in class java.awt.image.ImageFilter
Filters the information provided in the imageComplete method of the ImageConsumer interface.
imageComplete(int) - Method in class java.awt.image.PixelGrabber
The imageComplete method is part of the ImageConsumer API which this class must implement to retrieve the pixels.
imageComplete(ImageReader) - Method in interface javax.imageio.event.IIOReadProgressListener
Reports that the current image read operation has completed.
imageComplete(ImageWriter) - Method in interface javax.imageio.event.IIOWriteProgressListener
Reports that the image write operation has completed.
ImageConsumer - Interface in java.awt.image
The interface for objects expressing interest in image data through the ImageProducer interfaces.
IMAGEERROR - Static variable in interface java.awt.image.ImageConsumer
An error was encountered while producing the image.
ImageFilter - Class in java.awt.image
This class implements a filter for the set of interface methods that are used to deliver data from an ImageProducer to an ImageConsumer.
ImageFilter() - Constructor for class java.awt.image.ImageFilter
imageFlavor - Static variable in class java.awt.datatransfer.DataFlavor
The DataFlavor representing a Java Image class, where:
ImageGraphicAttribute - Class in java.awt.font
The ImageGraphicAttribute class is an implementation of GraphicAttribute which draws images in a TextLayout.
ImageGraphicAttribute(Image, int) - Constructor for class java.awt.font.ImageGraphicAttribute
Constucts an ImageGraphicAttribute from the specified Image.
ImageGraphicAttribute(Image, int, float, float) - Constructor for class java.awt.font.ImageGraphicAttribute
Constructs an ImageGraphicAttribute from the specified Image.
ImageIcon - Class in javax.swing
An implementation of the Icon interface that paints Icons from Images.
ImageIcon(String, String) - Constructor for class javax.swing.ImageIcon
Creates an ImageIcon from the specified file.
ImageIcon(String) - Constructor for class javax.swing.ImageIcon
Creates an ImageIcon from the specified file.
ImageIcon(URL, String) - Constructor for class javax.swing.ImageIcon
Creates an ImageIcon from the specified URL.
ImageIcon(URL) - Constructor for class javax.swing.ImageIcon
Creates an ImageIcon from the specified URL.
ImageIcon(Image, String) - Constructor for class javax.swing.ImageIcon
Creates an ImageIcon from the image.
ImageIcon(Image) - Constructor for class javax.swing.ImageIcon
Creates an ImageIcon from an image object.
ImageIcon(byte[], String) - Constructor for class javax.swing.ImageIcon
Creates an ImageIcon from an array of bytes which were read from an image file containing a supported image format, such as GIF, JPEG, or (as of 1.3) PNG.
ImageIcon(byte[]) - Constructor for class javax.swing.ImageIcon
Creates an ImageIcon from an array of bytes which were read from an image file containing a supported image format, such as GIF, JPEG, or (as of 1.3) PNG.
ImageIcon() - Constructor for class javax.swing.ImageIcon
Creates an uninitialized image icon.
ImageIcon.AccessibleImageIcon - Class in javax.swing
This class implements accessibility support for the ImageIcon class.
ImageInputStream - Interface in javax.imageio.stream
A seekable input stream interface for use by ImageReaders.
ImageInputStreamImpl - Class in javax.imageio.stream
An abstract class implementing the ImageInputStream interface.
ImageInputStreamImpl() - Constructor for class javax.imageio.stream.ImageInputStreamImpl
Constructs an ImageInputStreamImpl.
ImageInputStreamSpi - Class in javax.imageio.spi
The service provider interface (SPI) for ImageInputStreams.
ImageInputStreamSpi() - Constructor for class javax.imageio.spi.ImageInputStreamSpi
Constructs a blank ImageInputStreamSpi.
ImageInputStreamSpi(String, String, Class<?>) - Constructor for class javax.imageio.spi.ImageInputStreamSpi
Constructs an ImageInputStreamSpi with a given set of values.
ImageIO - Class in javax.imageio
A class containing static convenience methods for locating ImageReaders and ImageWriters, and performing simple encoding and decoding.
ImageObserver - Interface in java.awt.image
An asynchronous update interface for receiving notifications about Image information as the Image is constructed.
ImageOutputStream - Interface in javax.imageio.stream
A seekable output stream interface for use by ImageWriters.
ImageOutputStreamImpl - Class in javax.imageio.stream
An abstract class implementing the ImageOutputStream interface.
ImageOutputStreamImpl() - Constructor for class javax.imageio.stream.ImageOutputStreamImpl
Constructs an ImageOutputStreamImpl.
ImageOutputStreamSpi - Class in javax.imageio.spi
The service provider interface (SPI) for ImageOutputStreams.
ImageOutputStreamSpi() - Constructor for class javax.imageio.spi.ImageOutputStreamSpi
Constructs a blank ImageOutputStreamSpi.
ImageOutputStreamSpi(String, String, Class<?>) - Constructor for class javax.imageio.spi.ImageOutputStreamSpi
Constructs an ImageOutputStreamSpi with a given set of values.
ImageProducer - Interface in java.awt.image
The interface for objects which can produce the image data for Images.
imageProgress(ImageReader, float) - Method in interface javax.imageio.event.IIOReadProgressListener
Reports the approximate degree of completion of the current read call of the associated ImageReader.
imageProgress(ImageWriter, float) - Method in interface javax.imageio.event.IIOWriteProgressListener
Reports the approximate degree of completion of the current write call within the associated ImageWriter.
ImageReader - Class in javax.imageio
An abstract superclass for parsing and decoding of images.
ImageReader(ImageReaderSpi) - Constructor for class javax.imageio.ImageReader
Constructs an ImageReader and sets its originatingProvider field to the supplied value.
ImageReaderSpi - Class in javax.imageio.spi
The service provider interface (SPI) for ImageReaders.
ImageReaderSpi() - Constructor for class javax.imageio.spi.ImageReaderSpi
Constructs a blank ImageReaderSpi.
ImageReaderSpi(String, String, String[], String[], String[], String, Class[], String[], boolean, String, String, String[], String[], boolean, String, String, String[], String[]) - Constructor for class javax.imageio.spi.ImageReaderSpi
Constructs an ImageReaderSpi with a given set of values.
ImageReaderWriterSpi - Class in javax.imageio.spi
A superclass containing instance variables and methods common to ImageReaderSpi and ImageWriterSpi.
ImageReaderWriterSpi(String, String, String[], String[], String[], String, boolean, String, String, String[], String[], boolean, String, String, String[], String[]) - Constructor for class javax.imageio.spi.ImageReaderWriterSpi
Constructs an ImageReaderWriterSpi with a given set of values.
ImageReaderWriterSpi() - Constructor for class javax.imageio.spi.ImageReaderWriterSpi
Constructs a blank ImageReaderWriterSpi.
ImageReadParam - Class in javax.imageio
A class describing how a stream is to be decoded.
ImageReadParam() - Constructor for class javax.imageio.ImageReadParam
Constructs an ImageReadParam.
imageStarted(ImageReader, int) - Method in interface javax.imageio.event.IIOReadProgressListener
Reports that an image read operation is beginning.
imageStarted(ImageWriter, int) - Method in interface javax.imageio.event.IIOWriteProgressListener
Reports that an image write operation is beginning.
imageSubmit(String) - Method in class javax.swing.text.html.FormView
This method is called to submit a form in response to a click on an image -- an <INPUT> form element of type "image".
ImageTranscoder - Interface in javax.imageio
An interface providing metadata transcoding capability.
ImageTranscoderSpi - Class in javax.imageio.spi
The service provider interface (SPI) for ImageTranscoders.
ImageTranscoderSpi() - Constructor for class javax.imageio.spi.ImageTranscoderSpi
Constructs a blank ImageTranscoderSpi.
ImageTranscoderSpi(String, String) - Constructor for class javax.imageio.spi.ImageTranscoderSpi
Constructs an ImageTranscoderSpi with a given set of values.
ImageTypeSpecifier - Class in javax.imageio
A class that allows the format of an image (in particular, its SampleModel and ColorModel) to be specified in a convenient manner.
ImageTypeSpecifier(ColorModel, SampleModel) - Constructor for class javax.imageio.ImageTypeSpecifier
Constructs an ImageTypeSpecifier directly from a ColorModel and a SampleModel.
ImageTypeSpecifier(RenderedImage) - Constructor for class javax.imageio.ImageTypeSpecifier
Constructs an ImageTypeSpecifier from a RenderedImage.
imageUpdate(Image, int, int, int, int, int) - Method in class java.awt.Component
Repaints the component when the image has changed.
imageUpdate(Image, int, int, int, int, int) - Method in interface java.awt.image.ImageObserver
This method is called when information about an image which was previously requested using an asynchronous interface becomes available.
imageUpdate(ImageReader, BufferedImage, int, int, int, int, int, int, int[]) - Method in interface javax.imageio.event.IIOReadUpdateListener
Reports that a given region of the image has been updated.
imageUpdate(Image, int, int, int, int, int) - Method in class javax.swing.AbstractButton
This is overridden to return false if the current Icon's Image is not equal to the passed in Image img.
imageUpdate(Image, int, int, int, int, int) - Method in class javax.swing.JLabel
This is overridden to return false if the current Icon's Image is not equal to the passed in Image img.
imageUpdate(Image, int, int, int, int, int) - Method in class javax.swing.JSlider
Repaints the component when the image has changed.
ImageView - Class in javax.swing.text.html
View of an Image, intended to support the HTML <IMG> tag.
ImageView(Element) - Constructor for class javax.swing.text.html.ImageView
Creates a new view that represents an IMG element.
ImageWriteParam - Class in javax.imageio
A class describing how a stream is to be encoded.
ImageWriteParam() - Constructor for class javax.imageio.ImageWriteParam
Constructs an empty ImageWriteParam.
ImageWriteParam(Locale) - Constructor for class javax.imageio.ImageWriteParam
Constructs an ImageWriteParam set to use a given Locale.
ImageWriter - Class in javax.imageio
An abstract superclass for encoding and writing images.
ImageWriter(ImageWriterSpi) - Constructor for class javax.imageio.ImageWriter
Constructs an ImageWriter and sets its originatingProvider instance variable to the supplied value.
ImageWriterSpi - Class in javax.imageio.spi
The service provider interface (SPI) for ImageWriters.
ImageWriterSpi() - Constructor for class javax.imageio.spi.ImageWriterSpi
Constructs a blank ImageWriterSpi.
ImageWriterSpi(String, String, String[], String[], String[], String, Class[], String[], boolean, String, String, String[], String[], boolean, String, String, String[], String[]) - Constructor for class javax.imageio.spi.ImageWriterSpi
Constructs an ImageWriterSpi with a given set of values.
ImagingOpException - Exception in java.awt.image
The ImagingOpException is thrown if one of the BufferedImageOp or RasterOp filter methods cannot process the image.
ImagingOpException(String) - Constructor for exception java.awt.image.ImagingOpException
Constructs an ImagingOpException object with the specified message.
IMG - Static variable in class javax.swing.text.html.HTML.Tag
IMG_ALIGN_BOTTOM - Static variable in class javax.swing.text.html.HTMLEditorKit
Align images at the bottom.
IMG_ALIGN_MIDDLE - Static variable in class javax.swing.text.html.HTMLEditorKit
Align images in the middle.
IMG_ALIGN_TOP - Static variable in class javax.swing.text.html.HTMLEditorKit
Align images at the top.
IMG_BORDER - Static variable in class javax.swing.text.html.HTMLEditorKit
Align images at the border.
IMMUTABLE - Static variable in interface java.util.Spliterator
Characteristic value signifying that the element source cannot be structurally modified; that is, elements cannot be added, replaced, or removed, so such changes cannot occur during traversal.
IMMUTABLE_INFO_FIELD - Static variable in class javax.management.JMX
The name of the immutableInfo field.
ImmutableDescriptor - Class in javax.management
An immutable descriptor.
ImmutableDescriptor(String[], Object[]) - Constructor for class javax.management.ImmutableDescriptor
Construct a descriptor containing the given fields and values.
ImmutableDescriptor(String...) - Constructor for class javax.management.ImmutableDescriptor
Construct a descriptor containing the given fields.
ImmutableDescriptor(Map<String, ?>) - Constructor for class javax.management.ImmutableDescriptor
Construct a descriptor where the names and values of the fields are the keys and values of the given Map.
IMP_LIMIT - Exception in org.omg.CORBA
This exception indicates that an implementation limit was exceeded in the ORB run time.
IMP_LIMIT() - Constructor for exception org.omg.CORBA.IMP_LIMIT
Constructs an IMP_LIMIT exception with a default minor code of 0 and a completion state of COMPLETED_NO.
IMP_LIMIT(String) - Constructor for exception org.omg.CORBA.IMP_LIMIT
Constructs an IMP_LIMIT exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
IMP_LIMIT(int, CompletionStatus) - Constructor for exception org.omg.CORBA.IMP_LIMIT
Constructs an IMP_LIMIT exception with the specified minor code and completion status.
IMP_LIMIT(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.IMP_LIMIT
Constructs an IMP_LIMIT exception with the specified detail message, minor code, and completion status.
IMPERIAL_ARAMAIC - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Imperial Aramaic" Unicode character block.
impl - Variable in class javax.naming.CompoundName
Implementation of this compound name.
implAccept(Socket) - Method in class java.net.ServerSocket
Subclasses of ServerSocket use this method to override accept() to return their own subclass of socket.
implCloseChannel() - Method in class java.nio.channels.spi.AbstractInterruptibleChannel
Closes this channel.
implCloseChannel() - Method in class java.nio.channels.spi.AbstractSelectableChannel
Closes this channel.
implCloseSelectableChannel() - Method in class java.nio.channels.spi.AbstractSelectableChannel
Closes this selectable channel.
implCloseSelector() - Method in class java.nio.channels.spi.AbstractSelector
Closes this selector.
implConfigureBlocking(boolean) - Method in class java.nio.channels.spi.AbstractSelectableChannel
Adjusts this channel's blocking mode.
IMPLEMENTATION_TITLE - Static variable in class java.util.jar.Attributes.Name
Name object for Implementation-Title manifest attribute used for package versioning.
IMPLEMENTATION_URL - Static variable in class java.util.jar.Attributes.Name
Name object for Implementation-URL manifest attribute used for package versioning.
IMPLEMENTATION_VENDOR - Static variable in class java.util.jar.Attributes.Name
Name object for Implementation-Vendor manifest attribute used for package versioning.
IMPLEMENTATION_VENDOR_ID - Static variable in class java.util.jar.Attributes.Name
Name object for Implementation-Vendor-Id manifest attribute used for package versioning.
IMPLEMENTATION_VERSION - Static variable in class java.util.jar.Attributes.Name
Name object for Implementation-Version manifest attribute used for package versioning.
implFlush(CharBuffer) - Method in class java.nio.charset.CharsetDecoder
Flushes this decoder.
implFlush(ByteBuffer) - Method in class java.nio.charset.CharsetEncoder
Flushes this encoder.
IMPLICIT_ACTIVATION - Static variable in class org.omg.PortableServer.ImplicitActivationPolicyValue
IMPLICIT_ACTIVATION_POLICY_ID - Interface in org.omg.PortableServer
org/omg/PortableServer/IMPLICIT_ACTIVATION_POLICY_ID.java .
ImplicitActivationPolicy - Interface in org.omg.PortableServer
This policy specifies whether implicit activation of servants is supported in the created POA.
ImplicitActivationPolicyOperations - Interface in org.omg.PortableServer
This policy specifies whether implicit activation of servants is supported in the created POA.
ImplicitActivationPolicyValue - Class in org.omg.PortableServer
ImplicitActivationPolicyValue has the following semantics.
ImplicitActivationPolicyValue(int) - Constructor for class org.omg.PortableServer.ImplicitActivationPolicyValue
IMPLIED - Static variable in class javax.swing.text.html.HTML.Tag
All text content must be in a paragraph element.
IMPLIED - Static variable in class javax.swing.text.html.HTMLEditorKit.ParserCallback
This is passed as an attribute in the attributeset to indicate the element is implied eg, the string '<>foo<\t>' contains an implied html element and an implied body element.
IMPLIED - Static variable in interface javax.swing.text.html.parser.DTDConstants
implies(Permission) - Method in class java.io.FilePermission
Checks if this FilePermission object "implies" the specified permission.
implies(Permission) - Method in class java.net.SocketPermission
Checks if this socket permission object "implies" the specified permission.
implies(Permission) - Method in class java.net.URLPermission
Checks if this URLPermission implies the given permission.
implies(Permission) - Method in class java.security.AllPermission
Checks if the specified permission is "implied" by this object.
implies(Permission) - Method in class java.security.BasicPermission
Checks if the specified permission is "implied" by this object.
implies(CodeSource) - Method in class java.security.CodeSource
Returns true if this CodeSource object "implies" the specified CodeSource.
implies(Permission) - Method in class java.security.Permission
Checks if the specified permission's actions are "implied by" this object's actions.
implies(Permission) - Method in class java.security.PermissionCollection
Checks to see if the specified permission is implied by the collection of Permission objects held in this PermissionCollection.
implies(Permission) - Method in class java.security.Permissions
Checks to see if this object's PermissionCollection for permissions of the specified permission's class implies the permissions expressed in the permission object.
implies(ProtectionDomain, Permission) - Method in class java.security.Policy
Evaluates the global policy for the permissions granted to the ProtectionDomain and tests whether the permission is granted.
implies(Subject) - Method in interface java.security.Principal
Returns true if the specified subject is implied by this principal.
implies(Permission) - Method in class java.security.ProtectionDomain
Check and see if this ProtectionDomain implies the permissions expressed in the Permission object.
implies(Permission) - Method in class java.security.UnresolvedPermission
This method always returns false for unresolved permissions.
implies(Permission) - Method in class java.util.PropertyPermission
Checks if this PropertyPermission object "implies" the specified permission.
implies(Permission) - Method in class javax.management.MBeanPermission
Checks if this MBeanPermission object "implies" the specified permission.
implies(Permission) - Method in class javax.management.MBeanServerPermission
Checks if this MBeanServerPermission object "implies" the specified permission.
implies(Permission) - Method in class javax.security.auth.kerberos.DelegationPermission
Checks if this Kerberos delegation permission object "implies" the specified permission.
implies(Permission) - Method in class javax.security.auth.kerberos.ServicePermission
Checks if this Kerberos service permission object "implies" the specified permission.
implies(Permission) - Method in class javax.security.auth.PrivateCredentialPermission
Checks if this PrivateCredentialPermission implies the specified Permission.
implOnMalformedInput(CodingErrorAction) - Method in class java.nio.charset.CharsetDecoder
Reports a change to this decoder's malformed-input action.
implOnMalformedInput(CodingErrorAction) - Method in class java.nio.charset.CharsetEncoder
Reports a change to this encoder's malformed-input action.
implOnUnmappableCharacter(CodingErrorAction) - Method in class java.nio.charset.CharsetDecoder
Reports a change to this decoder's unmappable-character action.
implOnUnmappableCharacter(CodingErrorAction) - Method in class java.nio.charset.CharsetEncoder
Reports a change to this encoder's unmappable-character action.
implReplaceWith(String) - Method in class java.nio.charset.CharsetDecoder
Reports a change to this decoder's replacement value.
implReplaceWith(byte[]) - Method in class java.nio.charset.CharsetEncoder
Reports a change to this encoder's replacement value.
implReset() - Method in class java.nio.charset.CharsetDecoder
Resets this decoder, clearing any charset-specific internal state.
implReset() - Method in class java.nio.charset.CharsetEncoder
Resets this encoder, clearing any charset-specific internal state.
importData(TransferHandler.TransferSupport) - Method in class javax.swing.TransferHandler
Causes a transfer to occur from a clipboard or a drag and drop operation.
importData(JComponent, Transferable) - Method in class javax.swing.TransferHandler
Causes a transfer to a component from a clipboard or a DND drop operation.
importedKeyCascade - Static variable in interface java.sql.DatabaseMetaData
For the column UPDATE_RULE, indicates that when the primary key is updated, the foreign key (imported key) is changed to agree with it.
importedKeyInitiallyDeferred - Static variable in interface java.sql.DatabaseMetaData
Indicates deferrability.
importedKeyInitiallyImmediate - Static variable in interface java.sql.DatabaseMetaData
Indicates deferrability.
importedKeyNoAction - Static variable in interface java.sql.DatabaseMetaData
For the columns UPDATE_RULE and DELETE_RULE, indicates that if the primary key has been imported, it cannot be updated or deleted.
importedKeyNotDeferrable - Static variable in interface java.sql.DatabaseMetaData
Indicates deferrability.
importedKeyRestrict - Static variable in interface java.sql.DatabaseMetaData
For the column UPDATE_RULE, indicates that a primary key may not be updated if it has been imported by another table as a foreign key.
importedKeySetDefault - Static variable in interface java.sql.DatabaseMetaData
For the columns UPDATE_RULE and DELETE_RULE, indicates that if the primary key is updated or deleted, the foreign key (imported key) is set to the default value.
importedKeySetNull - Static variable in interface java.sql.DatabaseMetaData
For the columns UPDATE_RULE and DELETE_RULE, indicates that when the primary key is updated or deleted, the foreign key (imported key) is changed to NULL.
importNode(Node, boolean) - Method in interface org.w3c.dom.Document
Imports a node from another document to this document, without altering or removing the source node from the original document; this method creates a new copy of the source node.
importPreferences(InputStream) - Static method in class java.util.prefs.Preferences
Imports all of the preferences represented by the XML document on the specified input stream.
importStyleSheet(URL) - Method in class javax.swing.text.html.StyleSheet
Imports a style sheet from url.
in - Static variable in class java.io.FileDescriptor
A handle to the standard input stream.
in - Variable in class java.io.FilterInputStream
The input stream to be filtered.
in - Variable in class java.io.FilterReader
The underlying character-input stream.
in - Variable in class java.io.PipedInputStream
The index of the position in the circular buffer at which the next byte of data will be stored when received from the connected piped output stream.
in(Class<?>) - Method in class java.lang.invoke.MethodHandles.Lookup
Creates a lookup on the specified new lookup class.
in - Static variable in class java.lang.System
The "standard" input stream.
in(ValueExp, ValueExp[]) - Static method in class javax.management.Query
Returns an expression constraining a value to be one of an explicit list.
inactive(ActivationID) - Static method in class java.rmi.activation.Activatable
Informs the system that the object with the corresponding activation id is currently inactive.
INACTIVE - Interface in org.omg.PortableInterceptor
org/omg/PortableInterceptor/INACTIVE.java .
INACTIVE - Static variable in class org.omg.PortableServer.POAManagerPackage.State
INACTIVE_CAPTION - Static variable in class java.awt.SystemColor
The array index for the SystemColor.inactiveCaption system color.
INACTIVE_CAPTION_BORDER - Static variable in class java.awt.SystemColor
The array index for the SystemColor.inactiveCaptionBorder system color.
INACTIVE_CAPTION_TEXT - Static variable in class java.awt.SystemColor
The array index for the SystemColor.inactiveCaptionText system color.
inactiveCaption - Static variable in class java.awt.SystemColor
The color rendered for the window-title background of inactive windows.
inactiveCaptionBorder - Static variable in class java.awt.SystemColor
The color rendered for the border around inactive windows.
inactiveCaptionText - Static variable in class java.awt.SystemColor
The color rendered for the window-title text of inactive windows.
inactiveGroup() - Method in class java.rmi.activation.ActivationGroup
This protected method is necessary for subclasses to make the inactiveGroup callback to the group's monitor.
inactiveGroup(ActivationGroupID, long) - Method in interface java.rmi.activation.ActivationMonitor
Informs that the group is now inactive.
inactiveObject(ActivationID) - Method in class java.rmi.activation.ActivationGroup
The group's inactiveObject method is called indirectly via a call to the Activatable.inactive method.
inactiveObject(ActivationID) - Method in interface java.rmi.activation.ActivationMonitor
An activation group calls its monitor's inactiveObject method when an object in its group becomes inactive (deactivates).
INBOUND_MESSAGE_ATTACHMENTS - Static variable in interface javax.xml.ws.handler.MessageContext
Standard property: Map of attachments to a message for the inbound message, key is the MIME Content-ID, value is a DataHandler.
incarnate(byte[], POA) - Method in class org.omg.PortableServer._ServantActivatorStub
This operation is invoked by the POA whenever the POA receives a request for an object that is not currently active, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
incarnate(byte[], POA) - Method in interface org.omg.PortableServer.ServantActivatorOperations
This operation is invoked by the POA whenever the POA receives a request for an object that is not currently active, assuming the POA has the USE_SERVANT_MANAGER and RETAIN policies.
INCH - Static variable in class javax.print.attribute.Size2DSyntax
Value to indicate units of inches (in).
INCH - Static variable in class javax.print.attribute.standard.MediaPrintableArea
Value to indicate units of inches (in).
inCheck - Variable in class java.lang.SecurityManager
Deprecated.
This type of security checking is not recommended. It is recommended that the checkPermission call be used instead.
inClass(String) - Method in class java.lang.SecurityManager
Deprecated.
This type of security checking is not recommended. It is recommended that the checkPermission call be used instead.
inClassLoader() - Method in class java.lang.SecurityManager
Deprecated.
This type of security checking is not recommended. It is recommended that the checkPermission call be used instead.
include(RowFilter.Entry<? extends M, ? extends I>) - Method in class javax.swing.RowFilter
Returns true if the specified entry should be shown; returns false if the entry should be hidden.
inclusions - Variable in class javax.swing.text.html.parser.Element
INCLUSIVE - Static variable in interface javax.xml.crypto.dsig.CanonicalizationMethod
The Canonical XML (without comments) canonicalization method algorithm URI.
INCLUSIVE_WITH_COMMENTS - Static variable in interface javax.xml.crypto.dsig.CanonicalizationMethod
The Canonical XML with comments canonicalization method algorithm URI.
IncompatibleClassChangeError - Error in java.lang
Thrown when an incompatible class change has occurred to some class definition.
IncompatibleClassChangeError() - Constructor for error java.lang.IncompatibleClassChangeError
Constructs an IncompatibleClassChangeError with no detail message.
IncompatibleClassChangeError(String) - Constructor for error java.lang.IncompatibleClassChangeError
Constructs an IncompatibleClassChangeError with the specified detail message.
IncompleteAnnotationException - Exception in java.lang.annotation
Thrown to indicate that a program has attempted to access an element of an annotation type that was added to the annotation type definition after the annotation was compiled (or serialized).
IncompleteAnnotationException(Class<? extends Annotation>, String) - Constructor for exception java.lang.annotation.IncompleteAnnotationException
Constructs an IncompleteAnnotationException to indicate that the named element was missing from the specified annotation type.
InconsistentTypeCode - Exception in org.omg.CORBA.ORBPackage
InconsistentTypeCode is thrown when an attempt is made to create a dynamic any with a type code that does not match the particular subclass of DynAny.
InconsistentTypeCode() - Constructor for exception org.omg.CORBA.ORBPackage.InconsistentTypeCode
Constructs an InconsistentTypeCode user exception with no reason message.
InconsistentTypeCode(String) - Constructor for exception org.omg.CORBA.ORBPackage.InconsistentTypeCode
Constructs an InconsistentTypeCode user exception with the specified reason message.
InconsistentTypeCode - Exception in org.omg.DynamicAny.DynAnyFactoryPackage
org/omg/DynamicAny/DynAnyFactoryPackage/InconsistentTypeCode.java .
InconsistentTypeCode() - Constructor for exception org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCode
InconsistentTypeCode(String) - Constructor for exception org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCode
InconsistentTypeCodeHelper - Class in org.omg.DynamicAny.DynAnyFactoryPackage
org/omg/DynamicAny/DynAnyFactoryPackage/InconsistentTypeCodeHelper.java .
InconsistentTypeCodeHelper() - Constructor for class org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper
incrButton - Variable in class javax.swing.plaf.basic.BasicScrollBarUI
INCREASE_HIGHLIGHT - Static variable in class javax.swing.plaf.basic.BasicScrollBarUI
increaseButton - Variable in class javax.swing.plaf.metal.MetalScrollBarUI
increment() - Method in class java.util.concurrent.atomic.LongAdder
Equivalent to add(1).
INCREMENT - Static variable in interface javax.accessibility.AccessibleAction
An action which increments a value.
incrementAndGet() - Method in class java.util.concurrent.atomic.AtomicInteger
Atomically increments by one the current value.
incrementAndGet(int) - Method in class java.util.concurrent.atomic.AtomicIntegerArray
Atomically increments by one the element at index i.
incrementAndGet(T) - Method in class java.util.concurrent.atomic.AtomicIntegerFieldUpdater
Atomically increments by one the current value of the field of the given object managed by this updater.
incrementAndGet() - Method in class java.util.concurrent.atomic.AtomicLong
Atomically increments by one the current value.
incrementAndGet(int) - Method in class java.util.concurrent.atomic.AtomicLongArray
Atomically increments by one the element at index i.
incrementAndGet(T) - Method in class java.util.concurrent.atomic.AtomicLongFieldUpdater
Atomically increments by one the current value of the field of the given object managed by this updater.
incrementAnimationIndex() - Method in class javax.swing.plaf.basic.BasicProgressBarUI
Sets the index of the current animation frame, to the next valid value, which results in the progress bar being repainted.
incrementExact(int) - Static method in class java.lang.Math
Returns the argument incremented by one, throwing an exception if the result overflows an int.
incrementExact(long) - Static method in class java.lang.Math
Returns the argument incremented by one, throwing an exception if the result overflows a long.
incrGap - Variable in class javax.swing.plaf.basic.BasicScrollBarUI
Distance between the increment button and the track.
incrIndent() - Method in class javax.swing.text.AbstractWriter
Increments the indent level.
inDaylightTime(Date) - Method in class java.util.SimpleTimeZone
Queries if the given date is in daylight saving time.
inDaylightTime(Date) - Method in class java.util.TimeZone
Queries if the given date is in Daylight Saving Time in this time zone.
INDEFINITE_LIFETIME - Static variable in interface org.ietf.jgss.GSSContext
A lifetime constant representing indefinite context lifetime.
INDEFINITE_LIFETIME - Static variable in interface org.ietf.jgss.GSSCredential
A lifetime constant representing indefinite credential lifetime.
indent() - Method in class javax.swing.text.AbstractWriter
Does indentation.
INDENT - Static variable in class javax.xml.transform.OutputKeys
indent = "yes" | "no".
INDETERMINATE - Static variable in class javax.accessibility.AccessibleState
Indicates that the object state is indeterminate.
INDETERMINATE - Static variable in class javax.xml.datatype.DatatypeConstants
Comparison result.
index - Variable in class javax.swing.text.html.parser.Element
index - Variable in exception org.omg.PortableServer.POAPackage.InvalidPolicy
INDEX_SIZE_ERR - Static variable in exception org.w3c.dom.DOMException
If index or size is negative, or greater than the allowed value.
indexAtLocation(int, int) - Method in class javax.swing.JTabbedPane
Returns the tab index corresponding to the tab whose bounds intersect the specified location.
IndexColorModel - Class in java.awt.image
The IndexColorModel class is a ColorModel class that works with pixel values consisting of a single sample that is an index into a fixed colormap in the default sRGB color space.
IndexColorModel(int, int, byte[], byte[], byte[]) - Constructor for class java.awt.image.IndexColorModel
Constructs an IndexColorModel from the specified arrays of red, green, and blue components.
IndexColorModel(int, int, byte[], byte[], byte[], int) - Constructor for class java.awt.image.IndexColorModel
Constructs an IndexColorModel from the given arrays of red, green, and blue components.
IndexColorModel(int, int, byte[], byte[], byte[], byte[]) - Constructor for class java.awt.image.IndexColorModel
Constructs an IndexColorModel from the given arrays of red, green, blue and alpha components.
IndexColorModel(int, int, byte[], int, boolean) - Constructor for class java.awt.image.IndexColorModel
Constructs an IndexColorModel from a single array of interleaved red, green, blue and optional alpha components.
IndexColorModel(int, int, byte[], int, boolean, int) - Constructor for class java.awt.image.IndexColorModel
Constructs an IndexColorModel from a single array of interleaved red, green, blue and optional alpha components.
IndexColorModel(int, int, int[], int, boolean, int, int) - Constructor for class java.awt.image.IndexColorModel
Constructs an IndexColorModel from an array of ints where each int is comprised of red, green, blue, and optional alpha components in the default RGB color model format.
IndexColorModel(int, int, int[], int, int, BigInteger) - Constructor for class java.awt.image.IndexColorModel
Constructs an IndexColorModel from an int array where each int is comprised of red, green, blue, and alpha components in the default RGB color model format.
IndexedPropertyChangeEvent - Class in java.beans
An "IndexedPropertyChange" event gets delivered whenever a component that conforms to the JavaBeans™ specification (a "bean") changes a bound indexed property.
IndexedPropertyChangeEvent(Object, String, Object, Object, int) - Constructor for class java.beans.IndexedPropertyChangeEvent
Constructs a new IndexedPropertyChangeEvent object.
IndexedPropertyDescriptor - Class in java.beans
An IndexedPropertyDescriptor describes a property that acts like an array and has an indexed read and/or indexed write method to access specific elements of the array.
IndexedPropertyDescriptor(String, Class<?>) - Constructor for class java.beans.IndexedPropertyDescriptor
This constructor constructs an IndexedPropertyDescriptor for a property that follows the standard Java conventions by having getFoo and setFoo accessor methods, for both indexed access and array access.
IndexedPropertyDescriptor(String, Class<?>, String, String, String, String) - Constructor for class java.beans.IndexedPropertyDescriptor
This constructor takes the name of a simple property, and method names for reading and writing the property, both indexed and non-indexed.
IndexedPropertyDescriptor(String, Method, Method, Method, Method) - Constructor for class java.beans.IndexedPropertyDescriptor
This constructor takes the name of a simple property, and Method objects for reading and writing the property.
indexOf(int) - Method in class java.lang.String
Returns the index within this string of the first occurrence of the specified character.
indexOf(int, int) - Method in class java.lang.String
Returns the index within this string of the first occurrence of the specified character, starting the search at the specified index.
indexOf(String) - Method in class java.lang.String
Returns the index within this string of the first occurrence of the specified substring.
indexOf(String, int) - Method in class java.lang.String
Returns the index within this string of the first occurrence of the specified substring, starting at the specified index.
indexOf(String) - Method in class java.lang.StringBuffer
indexOf(String, int) - Method in class java.lang.StringBuffer
indexOf(String) - Method in class java.lang.StringBuilder
indexOf(String, int) - Method in class java.lang.StringBuilder
indexOf(Object) - Method in class java.util.AbstractList
Returns the index of the first occurrence of the specified element in this list, or -1 if this list does not contain the element.
indexOf(Object) - Method in class java.util.ArrayList
Returns the index of the first occurrence of the specified element in this list, or -1 if this list does not contain the element.
indexOf(Object) - Method in class java.util.concurrent.CopyOnWriteArrayList
Returns the index of the first occurrence of the specified element in this list, or -1 if this list does not contain the element.
indexOf(E, int) - Method in class java.util.concurrent.CopyOnWriteArrayList
Returns the index of the first occurrence of the specified element in this list, searching forwards from index, or returns -1 if the element is not found.
indexOf(Object) - Method in class java.util.LinkedList
Returns the index of the first occurrence of the specified element in this list, or -1 if this list does not contain the element.
indexOf(Object) - Method in interface java.util.List
Returns the index of the first occurrence of the specified element in this list, or -1 if this list does not contain the element.
indexOf(Object) - Method in class java.util.Vector
Returns the index of the first occurrence of the specified element in this vector, or -1 if this vector does not contain the element.
indexOf(Object, int) - Method in class java.util.Vector
Returns the index of the first occurrence of the specified element in this vector, searching forwards from index, or returns -1 if the element is not found.
indexOf(Object) - Method in class javax.swing.DefaultListModel
Searches for the first occurrence of elem.
indexOf(Object, int) - Method in class javax.swing.DefaultListModel
Searches for the first occurrence of elem, beginning the search at index.
indexOf(Object) - Method in class javax.swing.plaf.basic.BasicDirectoryModel
indexOfComponent(Component) - Method in class javax.swing.JTabbedPane
Returns the index of the tab for the specified component.
indexOfSubList(List<?>, List<?>) - Static method in class java.util.Collections
Returns the starting position of the first occurrence of the specified target list within the specified source list, or -1 if there is no such occurrence.
indexOfTab(String) - Method in class javax.swing.JTabbedPane
Returns the first tab index with a given title, or -1 if no tab has this title.
indexOfTab(Icon) - Method in class javax.swing.JTabbedPane
Returns the first tab index with a given icon, or -1 if no tab has this icon.
indexOfTabComponent(Component) - Method in class javax.swing.JTabbedPane
Returns the index of the tab for the specified tab component.
IndexOutOfBoundsException - Exception in java.lang
Thrown to indicate that an index of some sort (such as to an array, to a string, or to a vector) is out of range.
IndexOutOfBoundsException() - Constructor for exception java.lang.IndexOutOfBoundsException
Constructs an IndexOutOfBoundsException with no detail message.
IndexOutOfBoundsException(String) - Constructor for exception java.lang.IndexOutOfBoundsException
Constructs an IndexOutOfBoundsException with the specified detail message.
indexToLocation(int) - Method in class javax.swing.JList
Returns the origin of the specified item in the list's coordinate system.
indexToLocation(JList, int) - Method in class javax.swing.plaf.basic.BasicListUI
Returns the origin in the given JList, of the specified item, in the list's coordinate system.
indexToLocation(JList, int) - Method in class javax.swing.plaf.ListUI
Returns the origin in the given JList, of the specified item, in the list's coordinate system.
indexToLocation(JList, int) - Method in class javax.swing.plaf.multi.MultiListUI
Invokes the indexToLocation method on each UI handled by this object.
IndirectionException - Exception in org.omg.CORBA.portable
The Indirection exception is a Java specific system exception.
IndirectionException(int) - Constructor for exception org.omg.CORBA.portable.IndirectionException
Creates an IndirectionException with the right offset value.
Inet4Address - Class in java.net
This class represents an Internet Protocol version 4 (IPv4) address.
Inet6Address - Class in java.net
This class represents an Internet Protocol version 6 (IPv6) address.
InetAddress - Class in java.net
This class represents an Internet Protocol (IP) address.
InetSocketAddress - Class in java.net
This class implements an IP Socket Address (IP address + port number) It can also be a pair (hostname + port number), in which case an attempt will be made to resolve the hostname.
InetSocketAddress(int) - Constructor for class java.net.InetSocketAddress
Creates a socket address where the IP address is the wildcard address and the port number a specified value.
InetSocketAddress(InetAddress, int) - Constructor for class java.net.InetSocketAddress
Creates a socket address from an IP address and a port number.
InetSocketAddress(String, int) - Constructor for class java.net.InetSocketAddress
Creates a socket address from a hostname and a port number.
inf - Variable in class java.util.zip.InflaterInputStream
Decompressor for this stream.
inf - Variable in class java.util.zip.InflaterOutputStream
Decompressor for this stream.
inferBinaryName(JavaFileManager.Location, JavaFileObject) - Method in class javax.tools.ForwardingJavaFileManager
inferBinaryName(JavaFileManager.Location, JavaFileObject) - Method in interface javax.tools.JavaFileManager
Infers a binary name of a file object based on a location.
inflate(byte[], int, int) - Method in class java.util.zip.Inflater
Uncompresses bytes into specified buffer.
inflate(byte[]) - Method in class java.util.zip.Inflater
Uncompresses bytes into specified buffer.
Inflater - Class in java.util.zip
This class provides support for general purpose decompression using the popular ZLIB compression library.
Inflater(boolean) - Constructor for class java.util.zip.Inflater
Creates a new decompressor.
Inflater() - Constructor for class java.util.zip.Inflater
Creates a new decompressor.
InflaterInputStream - Class in java.util.zip
This class implements a stream filter for uncompressing data in the "deflate" compression format.
InflaterInputStream(InputStream, Inflater, int) - Constructor for class java.util.zip.InflaterInputStream
Creates a new input stream with the specified decompressor and buffer size.
InflaterInputStream(InputStream, Inflater) - Constructor for class java.util.zip.InflaterInputStream
Creates a new input stream with the specified decompressor and a default buffer size.
InflaterInputStream(InputStream) - Constructor for class java.util.zip.InflaterInputStream
Creates a new input stream with a default decompressor and buffer size.
InflaterOutputStream - Class in java.util.zip
Implements an output stream filter for uncompressing data stored in the "deflate" compression format.
InflaterOutputStream(OutputStream) - Constructor for class java.util.zip.InflaterOutputStream
Creates a new output stream with a default decompressor and buffer size.
InflaterOutputStream(OutputStream, Inflater) - Constructor for class java.util.zip.InflaterOutputStream
Creates a new output stream with the specified decompressor and a default buffer size.
InflaterOutputStream(OutputStream, Inflater, int) - Constructor for class java.util.zip.InflaterOutputStream
Creates a new output stream with the specified decompressor and buffer size.
INFO - Static variable in class java.awt.SystemColor
The array index for the SystemColor.info system color.
info - Static variable in class java.awt.SystemColor
The color rendered for the background of tooltips or spot help.
INFO - Static variable in class java.util.logging.Level
INFO is a message level for informational messages.
info(String) - Method in class java.util.logging.Logger
Log an INFO message.
info(Supplier<String>) - Method in class java.util.logging.Logger
Log a INFO message, which is only to be constructed if the logging level is such that the message will actually be logged.
INFO - Static variable in class javax.management.MBeanOperationInfo
Indicates that the operation is read-like: it returns information but does not change any state.
Info(String, String, String, String) - Constructor for class javax.sound.midi.MidiDevice.Info
Constructs a device info object.
Info(Class<?>, AudioFormat[], int, int) - Constructor for class javax.sound.sampled.DataLine.Info
Constructs a data line's info object from the specified information, which includes a set of supported audio formats and a range for the buffer size.
Info(Class<?>, AudioFormat, int) - Constructor for class javax.sound.sampled.DataLine.Info
Constructs a data line's info object from the specified information, which includes a single audio format and a desired buffer size.
Info(Class<?>, AudioFormat) - Constructor for class javax.sound.sampled.DataLine.Info
Constructs a data line's info object from the specified information, which includes a single audio format.
Info(Class<?>) - Constructor for class javax.sound.sampled.Line.Info
Constructs an info object that describes a line of the specified class.
Info(String, String, String, String) - Constructor for class javax.sound.sampled.Mixer.Info
Constructs a mixer's info object, passing it the given textual information.
Info(Class<?>, String, boolean) - Constructor for class javax.sound.sampled.Port.Info
Constructs a port's info object from the information given.
INFO_TEXT - Static variable in class java.awt.SystemColor
The array index for the SystemColor.infoText system color.
inFontTag() - Method in class javax.swing.text.html.MinimalHTMLWriter
Returns true if we are currently in a <font> tag.
inForkJoinPool() - Static method in class java.util.concurrent.ForkJoinTask
Returns true if the current thread is a ForkJoinWorkerThread executing as a ForkJoinPool computation.
INFORMATION - Static variable in class javax.security.auth.callback.ConfirmationCallback
INFORMATION message type.
INFORMATION - Static variable in class javax.security.auth.callback.TextOutputCallback
Information message.
INFORMATION_DIALOG - Static variable in class javax.swing.JRootPane
Constant used for the windowDecorationStyle property.
INFORMATION_MESSAGE - Static variable in class javax.swing.JOptionPane
Used for information messages.
infoText - Static variable in class java.awt.SystemColor
The color rendered for the text of tooltips or spot help.
INHERIT - Static variable in class java.lang.ProcessBuilder.Redirect
Indicates that subprocess I/O source or destination will be the same as those of the current process.
InheritableThreadLocal<T> - Class in java.lang
This class extends ThreadLocal to provide inheritance of values from parent thread to child thread: when a child thread is created, the child receives initial values for all inheritable thread-local variables for which the parent has values.
InheritableThreadLocal() - Constructor for class java.lang.InheritableThreadLocal
Inherited - Annotation Type in java.lang.annotation
Indicates that an annotation type is automatically inherited.
inheritedChannel() - Static method in class java.lang.System
Returns the channel inherited from the entity that created this Java virtual machine.
inheritedChannel() - Method in class java.nio.channels.spi.SelectorProvider
Returns the channel inherited from the entity that created this Java virtual machine.
inheritIO() - Method in class java.lang.ProcessBuilder
Sets the source and destination for subprocess standard I/O to be the same as those of the current Java process.
inHitRegion(int, int) - Method in class javax.swing.tree.DefaultTreeCellEditor
Returns true if the passed in location is a valid mouse location to start editing from.
init() - Method in class java.applet.Applet
Called by the browser or applet viewer to inform this applet that it has been loaded into the system.
init(int) - Method in class java.security.AlgorithmParameterGenerator
Initializes this parameter generator for a certain size.
init(int, SecureRandom) - Method in class java.security.AlgorithmParameterGenerator
Initializes this parameter generator for a certain size and source of randomness.
init(AlgorithmParameterSpec) - Method in class java.security.AlgorithmParameterGenerator
Initializes this parameter generator with a set of algorithm-specific parameter generation values.
init(AlgorithmParameterSpec, SecureRandom) - Method in class java.security.AlgorithmParameterGenerator
Initializes this parameter generator with a set of algorithm-specific parameter generation values.
init(AlgorithmParameterSpec) - Method in class java.security.AlgorithmParameters
Initializes this parameter object using the parameters specified in paramSpec.
init(byte[]) - Method in class java.security.AlgorithmParameters
Imports the specified parameters and decodes them according to the primary decoding format for parameters.
init(byte[], String) - Method in class java.security.AlgorithmParameters
Imports the parameters from params and decodes them according to the specified decoding scheme.
init(boolean) - Method in interface java.security.cert.CertPathChecker
Initializes the internal state of this CertPathChecker.
init(boolean) - Method in class java.security.cert.PKIXCertPathChecker
Initializes the internal state of this PKIXCertPathChecker.
init(ProcessingEnvironment) - Method in class javax.annotation.processing.AbstractProcessor
Initializes the processor with the processing environment by setting the processingEnv field to the value of the processingEnv argument.
init(ProcessingEnvironment) - Method in interface javax.annotation.processing.Processor
Initializes the processor with the processing environment.
init(int, Key) - Method in class javax.crypto.Cipher
Initializes this cipher with a key.
init(int, Key, SecureRandom) - Method in class javax.crypto.Cipher
Initializes this cipher with a key and a source of randomness.
init(int, Key, AlgorithmParameterSpec) - Method in class javax.crypto.Cipher
Initializes this cipher with a key and a set of algorithm parameters.
init(int, Key, AlgorithmParameterSpec, SecureRandom) - Method in class javax.crypto.Cipher
Initializes this cipher with a key, a set of algorithm parameters, and a source of randomness.
init(int, Key, AlgorithmParameters) - Method in class javax.crypto.Cipher
Initializes this cipher with a key and a set of algorithm parameters.
init(int, Key, AlgorithmParameters, SecureRandom) - Method in class javax.crypto.Cipher
Initializes this cipher with a key, a set of algorithm parameters, and a source of randomness.
init(int, Certificate) - Method in class javax.crypto.Cipher
Initializes this cipher with the public key from the given certificate.
init(int, Certificate, SecureRandom) - Method in class javax.crypto.Cipher
Initializes this cipher with the public key from the given certificate and a source of randomness.
init(Key) - Method in class javax.crypto.ExemptionMechanism
Initializes this exemption mechanism with a key.
init(Key, AlgorithmParameterSpec) - Method in class javax.crypto.ExemptionMechanism
Initializes this exemption mechanism with a key and a set of algorithm parameters.
init(Key, AlgorithmParameters) - Method in class javax.crypto.ExemptionMechanism
Initializes this exemption mechanism with a key and a set of algorithm parameters.
init(Key) - Method in class javax.crypto.KeyAgreement
Initializes this key agreement with the given key, which is required to contain all the algorithm parameters required for this key agreement.
init(Key, SecureRandom) - Method in class javax.crypto.KeyAgreement
Initializes this key agreement with the given key and source of randomness.
init(Key, AlgorithmParameterSpec) - Method in class javax.crypto.KeyAgreement
Initializes this key agreement with the given key and set of algorithm parameters.
init(Key, AlgorithmParameterSpec, SecureRandom) - Method in class javax.crypto.KeyAgreement
Initializes this key agreement with the given key, set of algorithm parameters, and source of randomness.
init(SecureRandom) - Method in class javax.crypto.KeyGenerator
Initializes this key generator.
init(AlgorithmParameterSpec) - Method in class javax.crypto.KeyGenerator
Initializes this key generator with the specified parameter set.
init(AlgorithmParameterSpec, SecureRandom) - Method in class javax.crypto.KeyGenerator
Initializes this key generator with the specified parameter set and a user-provided source of randomness.
init(int) - Method in class javax.crypto.KeyGenerator
Initializes this key generator for a certain keysize.
init(int, SecureRandom) - Method in class javax.crypto.KeyGenerator
Initializes this key generator for a certain keysize, using a user-provided source of randomness.
init(Key) - Method in class javax.crypto.Mac
Initializes this Mac object with the given key.
init(Key, AlgorithmParameterSpec) - Method in class javax.crypto.Mac
Initializes this Mac object with the given key and algorithm parameters.
init(Hashtable<?, ?>) - Method in class javax.naming.InitialContext
Initializes the initial context using the supplied environment.
init(KeyStore, char[]) - Method in class javax.net.ssl.KeyManagerFactory
Initializes this factory with a source of key material.
init(ManagerFactoryParameters) - Method in class javax.net.ssl.KeyManagerFactory
Initializes this factory with a source of provider-specific key material.
init(KeyManager[], TrustManager[], SecureRandom) - Method in class javax.net.ssl.SSLContext
Initializes this context.
init(KeyStore) - Method in class javax.net.ssl.TrustManagerFactory
Initializes this factory with a source of certificate authorities and related trust material.
init(ManagerFactoryParameters) - Method in class javax.net.ssl.TrustManagerFactory
Initializes this factory with a source of provider-specific trust material.
init(String, Icon) - Method in class javax.swing.AbstractButton
init(String, Icon) - Method in class javax.swing.JMenuItem
Initializes the menu item with the specified text and icon.
init(StateEditable, String) - Method in class javax.swing.undo.StateEdit
init(TransformParameterSpec) - Method in class javax.xml.crypto.dsig.TransformService
Initializes this TransformService with the specified parameters.
init(XMLStructure, XMLCryptoContext) - Method in class javax.xml.crypto.dsig.TransformService
Initializes this TransformService with the specified parameters and document context.
init() - Static method in class org.omg.CORBA.ORB
Returns the ORB singleton object.
init(String[], Properties) - Static method in class org.omg.CORBA.ORB
Creates a new ORB instance for a standalone application.
init(Applet, Properties) - Static method in class org.omg.CORBA.ORB
Creates a new ORB instance for an applet.
initCause(Throwable) - Method in class java.lang.Throwable
Initializes the cause of this throwable to the specified value.
initCause(Throwable) - Method in exception javax.naming.NamingException
Initializes the cause of this exception to the specified value.
initCause(Throwable) - Method in exception javax.security.sasl.SaslException
initCause(Throwable) - Method in exception javax.xml.soap.SOAPException
Initializes the cause field of this SOAPException object with the given Throwable object.
initCause(Throwable) - Method in exception javax.xml.transform.TransformerException
Initializes the cause of this throwable to the specified value.
initClassDefaults(UIDefaults) - Method in class javax.swing.plaf.basic.BasicLookAndFeel
Populates table with mappings from uiClassID to the fully qualified name of the ui class.
initClassDefaults(UIDefaults) - Method in class javax.swing.plaf.metal.MetalLookAndFeel
Populates table with mappings from uiClassID to the fully qualified name of the ui class.
initComponentDefaults(UIDefaults) - Method in class javax.swing.plaf.basic.BasicLookAndFeel
Populates table with the defaults for the basic look and feel.
initComponentDefaults(UIDefaults) - Method in class javax.swing.plaf.metal.MetalLookAndFeel
Populates table with the defaults for metal.
initEvent(String, boolean, boolean) - Method in interface org.w3c.dom.events.Event
The initEvent method is used to initialize the value of an Event created through the DocumentEvent interface.
INITIAL_CONTEXT_FACTORY - Static variable in interface javax.naming.Context
Constant that holds the name of the environment property for specifying the initial context factory to use.
INITIAL_QUOTE_PUNCTUATION - Static variable in class java.lang.Character
General category "Pi" in the Unicode specification.
INITIAL_SELECTION_VALUE_PROPERTY - Static variable in class javax.swing.JOptionPane
Bound property name for initialSelectionValue.
INITIAL_VALUE_PROPERTY - Static variable in class javax.swing.JOptionPane
Bound property name for initialValue.
InitialContext - Class in javax.naming
This class is the starting context for performing naming operations.
InitialContext(boolean) - Constructor for class javax.naming.InitialContext
Constructs an initial context with the option of not initializing it.
InitialContext() - Constructor for class javax.naming.InitialContext
Constructs an initial context.
InitialContext(Hashtable<?, ?>) - Constructor for class javax.naming.InitialContext
Constructs an initial context using the supplied environment.
InitialContextFactory - Interface in javax.naming.spi
This interface represents a factory that creates an initial context.
InitialContextFactoryBuilder - Interface in javax.naming.spi
This interface represents a builder that creates initial context factories.
InitialDirContext - Class in javax.naming.directory
This class is the starting context for performing directory operations.
InitialDirContext(boolean) - Constructor for class javax.naming.directory.InitialDirContext
Constructs an initial DirContext with the option of not initializing it.
InitialDirContext() - Constructor for class javax.naming.directory.InitialDirContext
Constructs an initial DirContext.
InitialDirContext(Hashtable<?, ?>) - Constructor for class javax.naming.directory.InitialDirContext
Constructs an initial DirContext using the supplied environment.
initialFocusComponent - Variable in class javax.swing.plaf.basic.BasicOptionPaneUI
Component to receive focus when messaged with selectInitialValue.
initialize(Applet, BeanContext) - Method in interface java.beans.AppletInitializer
If passed to the appropriate variant of java.beans.Beans.instantiate this method will be called in order to associate the newly instantiated Applet (JavaBean) with its AppletContext, AppletStub, and Container.
initialize() - Method in class java.beans.beancontext.BeanContextServicesSupport
called by BeanContextSupport superclass during construction and deserialization to initialize subclass transient state.
initialize() - Method in class java.beans.beancontext.BeanContextSupport
protected method called from constructor and readObject to initialize transient state of BeanContextSupport instance.
initialize(Class<?>, Object, Object, Encoder) - Method in class java.beans.DefaultPersistenceDelegate
This default implementation of the initialize method assumes all state held in objects of this type is exposed via the matching pairs of "setter" and "getter" methods in the order they are returned by the Introspector.
initialize(Class<?>, Object, Object, Encoder) - Method in class java.beans.PersistenceDelegate
Produce a series of statements with side effects on newInstance so that the new instance becomes equivalent to oldInstance.
initialize(DSAParams, SecureRandom) - Method in interface java.security.interfaces.DSAKeyPairGenerator
Initializes the key pair generator using the DSA family parameters (p,q and g) and an optional SecureRandom bit source.
initialize(int, boolean, SecureRandom) - Method in interface java.security.interfaces.DSAKeyPairGenerator
Initializes the key pair generator for a given modulus length (instead of parameters), and an optional SecureRandom bit source.
initialize(int) - Method in class java.security.KeyPairGenerator
Initializes the key pair generator for a certain keysize using a default parameter set and the SecureRandom implementation of the highest-priority installed provider as the source of randomness.
initialize(int, SecureRandom) - Method in class java.security.KeyPairGenerator
Initializes the key pair generator for a certain keysize with the given source of randomness (and a default parameter set).
initialize(AlgorithmParameterSpec) - Method in class java.security.KeyPairGenerator
Initializes the key pair generator using the specified parameter set and the SecureRandom implementation of the highest-priority installed provider as the source of randomness.
initialize(AlgorithmParameterSpec, SecureRandom) - Method in class java.security.KeyPairGenerator
Initializes the key pair generator with the given parameter set and source of randomness.
initialize(int, SecureRandom) - Method in class java.security.KeyPairGeneratorSpi
Initializes the key pair generator for a certain keysize, using the default parameter set.
initialize(AlgorithmParameterSpec, SecureRandom) - Method in class java.security.KeyPairGeneratorSpi
Initializes the key pair generator using the specified parameter set and user-provided source of randomness.
initialize(Subject, CallbackHandler, Map<String, ?>, Map<String, ?>) - Method in interface javax.security.auth.spi.LoginModule
Initialize this LoginModule.
initialize() - Method in class javax.swing.LookAndFeel
Initializes the look and feel.
initialize() - Method in class javax.swing.plaf.basic.BasicLookAndFeel
Initializes the look and feel.
initialize() - Method in class javax.swing.plaf.nimbus.NimbusLookAndFeel
Called by UIManager when this look and feel is installed.
initialize() - Method in class javax.swing.plaf.synth.SynthLookAndFeel
Called by UIManager when this look and feel is installed.
INITIALIZE - Exception in org.omg.CORBA
Exception thrown when an ORB has encountered a failure during its initialization, such as failure to acquire networking resources or detecting a configuration error.
INITIALIZE() - Constructor for exception org.omg.CORBA.INITIALIZE
Constructs an INITIALIZE exception with a default minor code of 0 and a completion state of CompletionStatus.COMPLETED_NO.
INITIALIZE(String) - Constructor for exception org.omg.CORBA.INITIALIZE
Constructs an INITIALIZE exception with the specified detail message, a minor code of 0, and a completion state of CompletionStatus.COMPLETED_NO.
INITIALIZE(int, CompletionStatus) - Constructor for exception org.omg.CORBA.INITIALIZE
Constructs an INITIALIZE exception with the specified minor code and completion status.
INITIALIZE(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.INITIALIZE
Constructs an INITIALIZE exception with the specified detail message, minor code, and completion status.
initializeAutoscrolling(Point) - Method in class java.awt.dnd.DropTarget
initialize autoscrolling
initializeBeanContextResources() - Method in class java.beans.beancontext.BeanContextChildSupport
This method may be overridden by subclasses to provide their own initialization behaviors.
initializeBeanContextResources() - Method in class java.beans.beancontext.BeanContextServicesSupport
called from setBeanContext to notify a BeanContextChild to allocate resources obtained from the nesting BeanContext.
initializeDesktopProperties() - Method in class java.awt.Toolkit
initializeDesktopProperties
initializeLocalVars() - Method in class javax.swing.JTable
Initializes table properties to their default values.
initializeLocalVars() - Method in class javax.swing.table.JTableHeader
Initializes the local variables and properties with default values.
InitialLdapContext - Class in javax.naming.ldap
This class is the starting context for performing LDAPv3-style extended operations and controls.
InitialLdapContext() - Constructor for class javax.naming.ldap.InitialLdapContext
Constructs an initial context using no environment properties or connection request controls.
InitialLdapContext(Hashtable<?, ?>, Control[]) - Constructor for class javax.naming.ldap.InitialLdapContext
Constructs an initial context using environment properties and connection request controls.
initialSelectionValue - Variable in class javax.swing.JOptionPane
Initial value to select in selectionValues.
initialSubString(AttributeValueExp, StringValueExp) - Static method in class javax.management.Query
Returns a query expression that represents a matching constraint on a string argument.
initialValue() - Method in class java.lang.ThreadLocal
Returns the current thread's "initial value" for this thread-local variable.
initialValue - Variable in class javax.swing.JOptionPane
Value that should be initially selected in options.
INITIATE_AND_ACCEPT - Static variable in interface org.ietf.jgss.GSSCredential
Credential usage flag requesting that it be usable for both context initiation and acceptance.
INITIATE_ONLY - Static variable in interface org.ietf.jgss.GSSCredential
Credential usage flag requesting that it be usable for context initiation only.
initMouseEvent(String, boolean, boolean, AbstractView, int, int, int, int, int, boolean, boolean, boolean, boolean, short, EventTarget) - Method in interface org.w3c.dom.events.MouseEvent
The initMouseEvent method is used to initialize the value of a MouseEvent created through the DocumentEvent interface.
initMutationEvent(String, boolean, boolean, Node, String, String, String, short) - Method in interface org.w3c.dom.events.MutationEvent
The initMutationEvent method is used to initialize the value of a MutationEvent created through the DocumentEvent interface.
InitParam - Annotation Type in javax.jws.soap
Deprecated.
initParams() - Method in class javax.sql.rowset.BaseRowSet
Performs the necessary internal configurations and initializations to allow any JDBC RowSet implementation to start using the standard facilities provided by a BaseRowSet instance.
initSecContext(byte[], int, int) - Method in interface org.ietf.jgss.GSSContext
Called by the context initiator to start the context creation phase and process any tokens generated by the peer's acceptSecContext method.
initSecContext(InputStream, OutputStream) - Method in interface org.ietf.jgss.GSSContext
Called by the context initiator to start the context creation phase and process any tokens generated by the peer's acceptSecContext method using streams.
initSign(PrivateKey) - Method in class java.security.Signature
Initialize this object for signing.
initSign(PrivateKey, SecureRandom) - Method in class java.security.Signature
Initialize this object for signing.
initSystemColorDefaults(UIDefaults) - Method in class javax.swing.plaf.basic.BasicLookAndFeel
Populates table with system colors.
initSystemColorDefaults(UIDefaults) - Method in class javax.swing.plaf.metal.MetalLookAndFeel
Populates table with system colors.
initUIEvent(String, boolean, boolean, AbstractView, int) - Method in interface org.w3c.dom.events.UIEvent
The initUIEvent method is used to initialize the value of a UIEvent created through the DocumentEvent interface.
initVerify(PublicKey) - Method in class java.security.Signature
Initializes this object for verification.
initVerify(Certificate) - Method in class java.security.Signature
Initializes this object for verification, using the public key from the given certificate.
inject(WebServiceContext) - Method in class javax.xml.ws.spi.Invoker
JAX-WS runtimes calls this method to ask container to inject WebServiceContext on the endpoint instance.
InlineView - Class in javax.swing.text.html
Displays the inline element styles based upon css attributes.
InlineView(Element) - Constructor for class javax.swing.text.html.InlineView
Constructs a new view wrapped on an element.
INNER_JOIN - Static variable in interface javax.sql.rowset.JoinRowSet
An ANSI-style JOIN providing a inner join between two tables.
input - Variable in class javax.imageio.ImageReader
The ImageInputStream or other Object by setInput and retrieved by getInput.
INPUT - Static variable in class javax.swing.text.html.HTML.Tag
INPUT_METHOD_EVENT_MASK - Static variable in class java.awt.AWTEvent
The event mask for selecting input method events.
INPUT_METHOD_FIRST - Static variable in class java.awt.event.InputMethodEvent
Marks the first integer id for the range of input method event ids.
INPUT_METHOD_HIGHLIGHT - Static variable in class java.awt.font.TextAttribute
Attribute key for input method highlight styles.
INPUT_METHOD_LAST - Static variable in class java.awt.event.InputMethodEvent
Marks the last integer id for the range of input method event ids.
INPUT_METHOD_SEGMENT - Static variable in class java.text.AttributedCharacterIterator.Attribute
Attribute key for input method segments.
INPUT_METHOD_TEXT_CHANGED - Static variable in class java.awt.event.InputMethodEvent
The event type indicating changed input method text.
INPUT_METHOD_UNDERLINE - Static variable in class java.awt.font.TextAttribute
Attribute key for input method underlines.
INPUT_STREAM(String) - Constructor for class javax.print.DocFlavor.INPUT_STREAM
Constructs a new doc flavor with the given MIME type and a print data representation class name of "java.io.InputStream" (byte stream).
INPUT_TRAY_MISSING - Static variable in class javax.print.attribute.standard.PrinterStateReason
One or more input trays are not in the device.
INPUT_VALUE_PROPERTY - Static variable in class javax.swing.JOptionPane
Bound property name for inputValue.
inputClass - Variable in class javax.imageio.spi.ImageInputStreamSpi
A Class object indicating the legal object type for use by the createInputStreamInstance method.
inputComponent - Variable in class javax.swing.plaf.basic.BasicOptionPaneUI
JComponent provide for input if optionPane.getWantsInput() returns true.
InputContext - Class in java.awt.im
Provides methods to control text input facilities such as input methods and keyboard layouts.
InputContext() - Constructor for class java.awt.im.InputContext
Constructs an InputContext.
InputEvent - Class in java.awt.event
The root event class for all component-level input events.
InputMap - Class in javax.swing
InputMap provides a binding between an input event (currently only KeyStrokes are used) and an Object.
InputMap() - Constructor for class javax.swing.InputMap
Creates an InputMap with no parent and no mappings.
InputMapUIResource - Class in javax.swing.plaf
A subclass of javax.swing.InputMap that implements UIResource.
InputMapUIResource() - Constructor for class javax.swing.plaf.InputMapUIResource
InputMethod - Interface in java.awt.im.spi
Defines the interface for an input method that supports complex text input.
InputMethodContext - Interface in java.awt.im.spi
Provides methods that input methods can use to communicate with their client components or to request other services.
InputMethodDescriptor - Interface in java.awt.im.spi
Defines methods that provide sufficient information about an input method to enable selection and loading of that input method.
InputMethodEvent - Class in java.awt.event
Input method events contain information about text that is being composed using an input method.
InputMethodEvent(Component, int, long, AttributedCharacterIterator, int, TextHitInfo, TextHitInfo) - Constructor for class java.awt.event.InputMethodEvent
Constructs an InputMethodEvent with the specified source component, type, time, text, caret, and visiblePosition.
InputMethodEvent(Component, int, AttributedCharacterIterator, int, TextHitInfo, TextHitInfo) - Constructor for class java.awt.event.InputMethodEvent
Constructs an InputMethodEvent with the specified source component, type, text, caret, and visiblePosition.
InputMethodEvent(Component, int, TextHitInfo, TextHitInfo) - Constructor for class java.awt.event.InputMethodEvent
Constructs an InputMethodEvent with the specified source component, type, caret, and visiblePosition.
InputMethodHighlight - Class in java.awt.im
An InputMethodHighlight is used to describe the highlight attributes of text being composed.
InputMethodHighlight(boolean, int) - Constructor for class java.awt.im.InputMethodHighlight
Constructs an input method highlight record.
InputMethodHighlight(boolean, int, int) - Constructor for class java.awt.im.InputMethodHighlight
Constructs an input method highlight record.
InputMethodHighlight(boolean, int, int, Map<TextAttribute, ?>) - Constructor for class java.awt.im.InputMethodHighlight
Constructs an input method highlight record.
InputMethodListener - Interface in java.awt.event
The listener interface for receiving input method events.
InputMethodRequests - Interface in java.awt.im
InputMethodRequests defines the requests that a text editing component has to handle in order to work with input methods.
inputMethodTextChanged(InputMethodEvent) - Method in class java.awt.AWTEventMulticaster
Handles the inputMethodTextChanged event by invoking the inputMethodTextChanged methods on listener-a and listener-b.
inputMethodTextChanged(InputMethodEvent) - Method in interface java.awt.event.InputMethodListener
Invoked when the text entered through an input method has changed.
InputMismatchException - Exception in java.util
Thrown by a Scanner to indicate that the token retrieved does not match the pattern for the expected type, or that the token is out of range for the expected type.
InputMismatchException() - Constructor for exception java.util.InputMismatchException
Constructs an InputMismatchException with null as its error message string.
InputMismatchException(String) - Constructor for exception java.util.InputMismatchException
Constructs an InputMismatchException, saving a reference to the error message string s for later retrieval by the getMessage method.
InputSource - Class in org.xml.sax
A single input source for an XML entity.
InputSource() - Constructor for class org.xml.sax.InputSource
Zero-argument default constructor.
InputSource(String) - Constructor for class org.xml.sax.InputSource
Create a new input source with a system identifier.
InputSource(InputStream) - Constructor for class org.xml.sax.InputSource
Create a new input source with a byte stream.
InputSource(Reader) - Constructor for class org.xml.sax.InputSource
Create a new input source with a character stream.
InputStream - Class in java.io
This abstract class is the superclass of all classes representing an input stream of bytes.
InputStream() - Constructor for class java.io.InputStream
InputStream - Class in org.omg.CORBA.portable
InputStream is the Java API for reading IDL types from CDR marshal streams.
InputStream() - Constructor for class org.omg.CORBA.portable.InputStream
InputStream - Class in org.omg.CORBA_2_3.portable
InputStream provides for the reading of all of the mapped IDL types from the stream.
InputStream() - Constructor for class org.omg.CORBA_2_3.portable.InputStream
Create a new instance of this class.
InputStreamReader - Class in java.io
An InputStreamReader is a bridge from byte streams to character streams: It reads bytes and decodes them into characters using a specified charset.
InputStreamReader(InputStream) - Constructor for class java.io.InputStreamReader
Creates an InputStreamReader that uses the default charset.
InputStreamReader(InputStream, String) - Constructor for class java.io.InputStreamReader
Creates an InputStreamReader that uses the named charset.
InputStreamReader(InputStream, Charset) - Constructor for class java.io.InputStreamReader
Creates an InputStreamReader that uses the given charset.
InputStreamReader(InputStream, CharsetDecoder) - Constructor for class java.io.InputStreamReader
Creates an InputStreamReader that uses the given charset decoder.
InputSubset - Class in java.awt.im
Defines additional Unicode subsets for use by input methods.
inputTypes - Variable in class javax.imageio.spi.ImageReaderSpi
An array of Class objects to be returned from getInputTypes, initially null.
inputValue - Variable in class javax.swing.JOptionPane
Value the user has input.
InputVerifier - Class in javax.swing
The purpose of this class is to help clients support smooth focus navigation through GUIs with text fields.
InputVerifier() - Constructor for class javax.swing.InputVerifier
inRange(Element) - Method in class javax.swing.text.AbstractWriter
This method determines whether the current element is in the range specified.
INSCRIPTIONAL_PAHLAVI - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Inscriptional Pahlavi" Unicode character block.
INSCRIPTIONAL_PARTHIAN - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Inscriptional Parthian" Unicode character block.
insert(String, int) - Method in class java.awt.Choice
Inserts the item into this choice at the specified position.
INSERT - Static variable in class java.awt.Event
The Insert key, a non-ASCII action key.
insert(MenuItem, int) - Method in class java.awt.Menu
Inserts a menu item into this menu at the specified position.
insert(String, int) - Method in class java.awt.Menu
Inserts a menu item with the specified label into this menu at the specified position.
insert(String, int) - Method in class java.awt.TextArea
Inserts the specified text at the specified position in this text area.
insert(int, char[], int, int) - Method in class java.lang.StringBuffer
insert(int, Object) - Method in class java.lang.StringBuffer
insert(int, String) - Method in class java.lang.StringBuffer
insert(int, char[]) - Method in class java.lang.StringBuffer
insert(int, CharSequence) - Method in class java.lang.StringBuffer
insert(int, CharSequence, int, int) - Method in class java.lang.StringBuffer
insert(int, boolean) - Method in class java.lang.StringBuffer
insert(int, char) - Method in class java.lang.StringBuffer
insert(int, int) - Method in class java.lang.StringBuffer
insert(int, long) - Method in class java.lang.StringBuffer
insert(int, float) - Method in class java.lang.StringBuffer
insert(int, double) - Method in class java.lang.StringBuffer
insert(int, char[], int, int) - Method in class java.lang.StringBuilder
insert(int, Object) - Method in class java.lang.StringBuilder
insert(int, String) - Method in class java.lang.StringBuilder
insert(int, char[]) - Method in class java.lang.StringBuilder
insert(int, CharSequence) - Method in class java.lang.StringBuilder
insert(int, CharSequence, int, int) - Method in class java.lang.StringBuilder
insert(int, boolean) - Method in class java.lang.StringBuilder
insert(int, char) - Method in class java.lang.StringBuilder
insert(int, int) - Method in class java.lang.StringBuilder
insert(int, long) - Method in class java.lang.StringBuilder
insert(int, float) - Method in class java.lang.StringBuilder
insert(int, double) - Method in class java.lang.StringBuilder
INSERT - Static variable in interface javax.accessibility.AccessibleTableModelChange
Identifies the insertion of new rows and/or columns.
INSERT - Static variable in class javax.swing.event.DocumentEvent.EventType
Insert type.
INSERT - Static variable in class javax.swing.event.TableModelEvent
Identifies the addition of new rows or columns.
insert(String, int) - Method in class javax.swing.JMenu
Inserts a new menu item with the specified text at a given position.
insert(JMenuItem, int) - Method in class javax.swing.JMenu
Inserts the specified JMenuitem at a given position.
insert(Action, int) - Method in class javax.swing.JMenu
Inserts a new menu item attached to the specified Action object at a given position.
insert(Action, int) - Method in class javax.swing.JPopupMenu
Inserts a menu item for the specified Action object at a given position.
insert(Component, int) - Method in class javax.swing.JPopupMenu
Inserts the specified component into the menu at a given position.
insert(String, int) - Method in class javax.swing.JTextArea
Inserts the specified text at the specified position.
insert(int, int, DefaultStyledDocument.ElementSpec[], AbstractDocument.DefaultDocumentEvent) - Method in class javax.swing.text.DefaultStyledDocument.ElementBuffer
Inserts new content.
insert(int, DefaultStyledDocument.ElementSpec[]) - Method in class javax.swing.text.DefaultStyledDocument
Inserts new elements in bulk.
insert(int, DefaultStyledDocument.ElementSpec[]) - Method in class javax.swing.text.html.HTMLDocument
Inserts new elements in bulk.
insert(int, View) - Method in class javax.swing.text.View
Inserts a single child view.
insert(MutableTreeNode, int) - Method in class javax.swing.tree.DefaultMutableTreeNode
Removes newChild from its present parent (if it has a parent), sets the child's parent to this node, and then adds the child to this node's child array at index childIndex.
insert(MutableTreeNode, int) - Method in interface javax.swing.tree.MutableTreeNode
Adds child to the receiver at index.
insert(Any, Any[]) - Static method in class org.omg.CORBA.AnySeqHelper
insert(Any, boolean[]) - Static method in class org.omg.CORBA.BooleanSeqHelper
insert(Any, char[]) - Static method in class org.omg.CORBA.CharSeqHelper
insert(Any, CompletionStatus) - Static method in class org.omg.CORBA.CompletionStatusHelper
insert(Any, Current) - Static method in class org.omg.CORBA.CurrentHelper
insert(Any, DefinitionKind) - Static method in class org.omg.CORBA.DefinitionKindHelper
insert(Any, double[]) - Static method in class org.omg.CORBA.DoubleSeqHelper
insert(Any, String) - Static method in class org.omg.CORBA.FieldNameHelper
insert(Any, float[]) - Static method in class org.omg.CORBA.FloatSeqHelper
insert(Any, String) - Static method in class org.omg.CORBA.IdentifierHelper
insert(Any, IDLType) - Static method in class org.omg.CORBA.IDLTypeHelper
insert(Any, long[]) - Static method in class org.omg.CORBA.LongLongSeqHelper
insert(Any, int[]) - Static method in class org.omg.CORBA.LongSeqHelper
insert(Any, NameValuePair) - Static method in class org.omg.CORBA.NameValuePairHelper
insert(Any, Object) - Static method in class org.omg.CORBA.ObjectHelper
insert(Any, byte[]) - Static method in class org.omg.CORBA.OctetSeqHelper
insert(Any, ParameterMode) - Static method in class org.omg.CORBA.ParameterModeHelper
insert(Any, short) - Static method in class org.omg.CORBA.PolicyErrorCodeHelper
insert(Any, PolicyError) - Static method in class org.omg.CORBA.PolicyErrorHelper
insert(Any, Policy) - Static method in class org.omg.CORBA.PolicyHelper
insert(Any, Policy[]) - Static method in class org.omg.CORBA.PolicyListHelper
insert(Any, int) - Static method in class org.omg.CORBA.PolicyTypeHelper
insert(Any, String) - Static method in class org.omg.CORBA.RepositoryIdHelper
insert(Any, ServiceDetail) - Static method in class org.omg.CORBA.ServiceDetailHelper
insert(Any, ServiceInformation) - Static method in class org.omg.CORBA.ServiceInformationHelper
insert(Any, SetOverrideType) - Static method in class org.omg.CORBA.SetOverrideTypeHelper
insert(Any, short[]) - Static method in class org.omg.CORBA.ShortSeqHelper
insert(Any, String[]) - Static method in class org.omg.CORBA.StringSeqHelper
insert(Any, String) - Static method in class org.omg.CORBA.StringValueHelper
insert(Any, StructMember) - Static method in class org.omg.CORBA.StructMemberHelper
insert(Any, long[]) - Static method in class org.omg.CORBA.ULongLongSeqHelper
insert(Any, int[]) - Static method in class org.omg.CORBA.ULongSeqHelper
insert(Any, UnionMember) - Static method in class org.omg.CORBA.UnionMemberHelper
insert(Any, UnknownUserException) - Static method in class org.omg.CORBA.UnknownUserExceptionHelper
insert(Any, short[]) - Static method in class org.omg.CORBA.UShortSeqHelper
insert(Any, Serializable) - Static method in class org.omg.CORBA.ValueBaseHelper
insert(Any, ValueMember) - Static method in class org.omg.CORBA.ValueMemberHelper
insert(Any, String) - Static method in class org.omg.CORBA.VersionSpecHelper
insert(Any, short) - Static method in class org.omg.CORBA.VisibilityHelper
insert(Any, char[]) - Static method in class org.omg.CORBA.WCharSeqHelper
insert(Any, WrongTransaction) - Static method in class org.omg.CORBA.WrongTransactionHelper
insert(Any, String[]) - Static method in class org.omg.CORBA.WStringSeqHelper
insert(Any, String) - Static method in class org.omg.CORBA.WStringValueHelper
insert(Any, Binding) - Static method in class org.omg.CosNaming.BindingHelper
insert(Any, BindingIterator) - Static method in class org.omg.CosNaming.BindingIteratorHelper
insert(Any, Binding[]) - Static method in class org.omg.CosNaming.BindingListHelper
insert(Any, BindingType) - Static method in class org.omg.CosNaming.BindingTypeHelper
insert(Any, String) - Static method in class org.omg.CosNaming.IstringHelper
insert(Any, NameComponent) - Static method in class org.omg.CosNaming.NameComponentHelper
insert(Any, NameComponent[]) - Static method in class org.omg.CosNaming.NameHelper
insert(Any, NamingContextExt) - Static method in class org.omg.CosNaming.NamingContextExtHelper
insert(Any, String) - Static method in class org.omg.CosNaming.NamingContextExtPackage.AddressHelper
insert(Any, InvalidAddress) - Static method in class org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper
insert(Any, String) - Static method in class org.omg.CosNaming.NamingContextExtPackage.StringNameHelper
insert(Any, String) - Static method in class org.omg.CosNaming.NamingContextExtPackage.URLStringHelper
insert(Any, NamingContext) - Static method in class org.omg.CosNaming.NamingContextHelper
insert(Any, AlreadyBound) - Static method in class org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper
insert(Any, CannotProceed) - Static method in class org.omg.CosNaming.NamingContextPackage.CannotProceedHelper
insert(Any, InvalidName) - Static method in class org.omg.CosNaming.NamingContextPackage.InvalidNameHelper
insert(Any, NotEmpty) - Static method in class org.omg.CosNaming.NamingContextPackage.NotEmptyHelper
insert(Any, NotFound) - Static method in class org.omg.CosNaming.NamingContextPackage.NotFoundHelper
insert(Any, NotFoundReason) - Static method in class org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper
insert(Any, Any[]) - Static method in class org.omg.DynamicAny.AnySeqHelper
insert(Any, DynAnyFactory) - Static method in class org.omg.DynamicAny.DynAnyFactoryHelper
insert(Any, InconsistentTypeCode) - Static method in class org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper
insert(Any, DynAny) - Static method in class org.omg.DynamicAny.DynAnyHelper
insert(Any, InvalidValue) - Static method in class org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper
insert(Any, TypeMismatch) - Static method in class org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper
insert(Any, DynAny[]) - Static method in class org.omg.DynamicAny.DynAnySeqHelper
insert(Any, DynArray) - Static method in class org.omg.DynamicAny.DynArrayHelper
insert(Any, DynEnum) - Static method in class org.omg.DynamicAny.DynEnumHelper
insert(Any, DynFixed) - Static method in class org.omg.DynamicAny.DynFixedHelper
insert(Any, DynSequence) - Static method in class org.omg.DynamicAny.DynSequenceHelper
insert(Any, DynStruct) - Static method in class org.omg.DynamicAny.DynStructHelper
insert(Any, DynUnion) - Static method in class org.omg.DynamicAny.DynUnionHelper
insert(Any, DynValue) - Static method in class org.omg.DynamicAny.DynValueHelper
insert(Any, String) - Static method in class org.omg.DynamicAny.FieldNameHelper
insert(Any, NameDynAnyPair) - Static method in class org.omg.DynamicAny.NameDynAnyPairHelper
insert(Any, NameDynAnyPair[]) - Static method in class org.omg.DynamicAny.NameDynAnyPairSeqHelper
insert(Any, NameValuePair) - Static method in class org.omg.DynamicAny.NameValuePairHelper
insert(Any, NameValuePair[]) - Static method in class org.omg.DynamicAny.NameValuePairSeqHelper
insert(Any, CodecFactory) - Static method in class org.omg.IOP.CodecFactoryHelper
insert(Any, UnknownEncoding) - Static method in class org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper
insert(Any, FormatMismatch) - Static method in class org.omg.IOP.CodecPackage.FormatMismatchHelper
insert(Any, InvalidTypeForEncoding) - Static method in class org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper
insert(Any, TypeMismatch) - Static method in class org.omg.IOP.CodecPackage.TypeMismatchHelper
insert(Any, int) - Static method in class org.omg.IOP.ComponentIdHelper
insert(Any, IOR) - Static method in class org.omg.IOP.IORHelper
insert(Any, TaggedComponent[]) - Static method in class org.omg.IOP.MultipleComponentProfileHelper
insert(Any, int) - Static method in class org.omg.IOP.ProfileIdHelper
insert(Any, ServiceContext) - Static method in class org.omg.IOP.ServiceContextHelper
insert(Any, ServiceContext[]) - Static method in class org.omg.IOP.ServiceContextListHelper
insert(Any, int) - Static method in class org.omg.IOP.ServiceIdHelper
insert(Any, TaggedComponent) - Static method in class org.omg.IOP.TaggedComponentHelper
insert(Any, TaggedProfile) - Static method in class org.omg.IOP.TaggedProfileHelper
insert(Any, short) - Static method in class org.omg.Messaging.SyncScopeHelper
insert(Any, int) - Static method in class org.omg.PortableInterceptor.AdapterManagerIdHelper
insert(Any, String[]) - Static method in class org.omg.PortableInterceptor.AdapterNameHelper
insert(Any, short) - Static method in class org.omg.PortableInterceptor.AdapterStateHelper
insert(Any, Current) - Static method in class org.omg.PortableInterceptor.CurrentHelper
insert(Any, ForwardRequest) - Static method in class org.omg.PortableInterceptor.ForwardRequestHelper
insert(Any, InvalidSlot) - Static method in class org.omg.PortableInterceptor.InvalidSlotHelper
insert(Any, IORInterceptor_3_0) - Static method in class org.omg.PortableInterceptor.IORInterceptor_3_0Helper
insert(Any, byte[]) - Static method in class org.omg.PortableInterceptor.ObjectIdHelper
insert(Any, ObjectReferenceFactory) - Static method in class org.omg.PortableInterceptor.ObjectReferenceFactoryHelper
insert(Any, ObjectReferenceTemplate) - Static method in class org.omg.PortableInterceptor.ObjectReferenceTemplateHelper
insert(Any, ObjectReferenceTemplate[]) - Static method in class org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper
insert(Any, String) - Static method in class org.omg.PortableInterceptor.ORBIdHelper
insert(Any, DuplicateName) - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper
insert(Any, InvalidName) - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper
insert(Any, String) - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper
insert(Any, String) - Static method in class org.omg.PortableInterceptor.ServerIdHelper
insert(Any, Current) - Static method in class org.omg.PortableServer.CurrentHelper
insert(Any, NoContext) - Static method in class org.omg.PortableServer.CurrentPackage.NoContextHelper
insert(Any, ForwardRequest) - Static method in class org.omg.PortableServer.ForwardRequestHelper
insert(Any, POA) - Static method in class org.omg.PortableServer.POAHelper
insert(Any, AdapterInactive) - Static method in class org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper
insert(Any, AdapterAlreadyExists) - Static method in class org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper
insert(Any, AdapterNonExistent) - Static method in class org.omg.PortableServer.POAPackage.AdapterNonExistentHelper
insert(Any, InvalidPolicy) - Static method in class org.omg.PortableServer.POAPackage.InvalidPolicyHelper
insert(Any, NoServant) - Static method in class org.omg.PortableServer.POAPackage.NoServantHelper
insert(Any, ObjectAlreadyActive) - Static method in class org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper
insert(Any, ObjectNotActive) - Static method in class org.omg.PortableServer.POAPackage.ObjectNotActiveHelper
insert(Any, ServantAlreadyActive) - Static method in class org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper
insert(Any, ServantNotActive) - Static method in class org.omg.PortableServer.POAPackage.ServantNotActiveHelper
insert(Any, WrongAdapter) - Static method in class org.omg.PortableServer.POAPackage.WrongAdapterHelper
insert(Any, WrongPolicy) - Static method in class org.omg.PortableServer.POAPackage.WrongPolicyHelper
insert(Any, ServantActivator) - Static method in class org.omg.PortableServer.ServantActivatorHelper
insert(Any, ServantLocator) - Static method in class org.omg.PortableServer.ServantLocatorHelper
insert_any(Any) - Method in class org.omg.CORBA.Any
Inserts the given Any object into this Any object's value field.
insert_any(Any) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Inserts the given org.omg.CORBA.Any object as the value for this DynAny object.
insert_any(Any) - Method in class org.omg.DynamicAny._DynAnyStub
Inserts an Any value into the Any represented by this DynAny.
insert_any(Any) - Method in class org.omg.DynamicAny._DynArrayStub
Inserts an Any value into the Any represented by this DynAny.
insert_any(Any) - Method in class org.omg.DynamicAny._DynEnumStub
Inserts an Any value into the Any represented by this DynAny.
insert_any(Any) - Method in class org.omg.DynamicAny._DynFixedStub
Inserts an Any value into the Any represented by this DynAny.
insert_any(Any) - Method in class org.omg.DynamicAny._DynSequenceStub
Inserts an Any value into the Any represented by this DynAny.
insert_any(Any) - Method in class org.omg.DynamicAny._DynStructStub
Inserts an Any value into the Any represented by this DynAny.
insert_any(Any) - Method in class org.omg.DynamicAny._DynUnionStub
Inserts an Any value into the Any represented by this DynAny.
insert_any(Any) - Method in class org.omg.DynamicAny._DynValueStub
Inserts an Any value into the Any represented by this DynAny.
insert_any(Any) - Method in interface org.omg.DynamicAny.DynAnyOperations
Inserts an Any value into the Any represented by this DynAny.
insert_boolean(boolean) - Method in class org.omg.CORBA.Any
Inserts the given boolean into this Any object's value field.
insert_boolean(boolean) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Inserts the given boolean as the value for this DynAny object.
insert_boolean(boolean) - Method in class org.omg.DynamicAny._DynAnyStub
Inserts a boolean value into the DynAny.
insert_boolean(boolean) - Method in class org.omg.DynamicAny._DynArrayStub
Inserts a boolean value into the DynAny.
insert_boolean(boolean) - Method in class org.omg.DynamicAny._DynEnumStub
Inserts a boolean value into the DynAny.
insert_boolean(boolean) - Method in class org.omg.DynamicAny._DynFixedStub
Inserts a boolean value into the DynAny.
insert_boolean(boolean) - Method in class org.omg.DynamicAny._DynSequenceStub
Inserts a boolean value into the DynAny.
insert_boolean(boolean) - Method in class org.omg.DynamicAny._DynStructStub
Inserts a boolean value into the DynAny.
insert_boolean(boolean) - Method in class org.omg.DynamicAny._DynUnionStub
Inserts a boolean value into the DynAny.
insert_boolean(boolean) - Method in class org.omg.DynamicAny._DynValueStub
Inserts a boolean value into the DynAny.
insert_boolean(boolean) - Method in interface org.omg.DynamicAny.DynAnyOperations
Inserts a boolean value into the DynAny.
insert_char(char) - Method in class org.omg.CORBA.Any
Inserts the given char into this Any object's value field.
insert_char(char) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Inserts the given char as the value for this DynAny object.
insert_char(char) - Method in class org.omg.DynamicAny._DynAnyStub
Inserts a char value into the DynAny.
insert_char(char) - Method in class org.omg.DynamicAny._DynArrayStub
Inserts a char value into the DynAny.
insert_char(char) - Method in class org.omg.DynamicAny._DynEnumStub
Inserts a char value into the DynAny.
insert_char(char) - Method in class org.omg.DynamicAny._DynFixedStub
Inserts a char value into the DynAny.
insert_char(char) - Method in class org.omg.DynamicAny._DynSequenceStub
Inserts a char value into the DynAny.
insert_char(char) - Method in class org.omg.DynamicAny._DynStructStub
Inserts a char value into the DynAny.
insert_char(char) - Method in class org.omg.DynamicAny._DynUnionStub
Inserts a char value into the DynAny.
insert_char(char) - Method in class org.omg.DynamicAny._DynValueStub
Inserts a char value into the DynAny.
insert_char(char) - Method in interface org.omg.DynamicAny.DynAnyOperations
Inserts a char value into the DynAny.
insert_double(double) - Method in class org.omg.CORBA.Any
Inserts the given double into this Any object's value field.
insert_double(double) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Inserts the given double as the value for this DynAny object.
insert_double(double) - Method in class org.omg.DynamicAny._DynAnyStub
Inserts a double value into the DynAny.
insert_double(double) - Method in class org.omg.DynamicAny._DynArrayStub
Inserts a double value into the DynAny.
insert_double(double) - Method in class org.omg.DynamicAny._DynEnumStub
Inserts a double value into the DynAny.
insert_double(double) - Method in class org.omg.DynamicAny._DynFixedStub
Inserts a double value into the DynAny.
insert_double(double) - Method in class org.omg.DynamicAny._DynSequenceStub
Inserts a double value into the DynAny.
insert_double(double) - Method in class org.omg.DynamicAny._DynStructStub
Inserts a double value into the DynAny.
insert_double(double) - Method in class org.omg.DynamicAny._DynUnionStub
Inserts a double value into the DynAny.
insert_double(double) - Method in class org.omg.DynamicAny._DynValueStub
Inserts a double value into the DynAny.
insert_double(double) - Method in interface org.omg.DynamicAny.DynAnyOperations
Inserts a double value into the DynAny.
insert_dyn_any(DynAny) - Method in class org.omg.DynamicAny._DynAnyStub
Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
insert_dyn_any(DynAny) - Method in class org.omg.DynamicAny._DynArrayStub
Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
insert_dyn_any(DynAny) - Method in class org.omg.DynamicAny._DynEnumStub
Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
insert_dyn_any(DynAny) - Method in class org.omg.DynamicAny._DynFixedStub
Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
insert_dyn_any(DynAny) - Method in class org.omg.DynamicAny._DynSequenceStub
Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
insert_dyn_any(DynAny) - Method in class org.omg.DynamicAny._DynStructStub
Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
insert_dyn_any(DynAny) - Method in class org.omg.DynamicAny._DynUnionStub
Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
insert_dyn_any(DynAny) - Method in class org.omg.DynamicAny._DynValueStub
Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
insert_dyn_any(DynAny) - Method in interface org.omg.DynamicAny.DynAnyOperations
Inserts the Any value contained in the parameter DynAny into the Any represented by this DynAny.
insert_fixed(BigDecimal) - Method in class org.omg.CORBA.Any
Throws an org.omg.CORBA.NO_IMPLEMENT exception.
insert_fixed(BigDecimal, TypeCode) - Method in class org.omg.CORBA.Any
Throws an org.omg.CORBA.NO_IMPLEMENT exception.
insert_float(float) - Method in class org.omg.CORBA.Any
Inserts the given float into this Any object's value field.
insert_float(float) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Inserts the given float as the value for this DynAny object.
insert_float(float) - Method in class org.omg.DynamicAny._DynAnyStub
Inserts a float value into the DynAny.
insert_float(float) - Method in class org.omg.DynamicAny._DynArrayStub
Inserts a float value into the DynAny.
insert_float(float) - Method in class org.omg.DynamicAny._DynEnumStub
Inserts a float value into the DynAny.
insert_float(float) - Method in class org.omg.DynamicAny._DynFixedStub
Inserts a float value into the DynAny.
insert_float(float) - Method in class org.omg.DynamicAny._DynSequenceStub
Inserts a float value into the DynAny.
insert_float(float) - Method in class org.omg.DynamicAny._DynStructStub
Inserts a float value into the DynAny.
insert_float(float) - Method in class org.omg.DynamicAny._DynUnionStub
Inserts a float value into the DynAny.
insert_float(float) - Method in class org.omg.DynamicAny._DynValueStub
Inserts a float value into the DynAny.
insert_float(float) - Method in interface org.omg.DynamicAny.DynAnyOperations
Inserts a float value into the DynAny.
insert_long(int) - Method in class org.omg.CORBA.Any
Inserts the given int into this Any object's value field.
insert_long(int) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Inserts the given int as the value for this DynAny object.
insert_long(int) - Method in class org.omg.DynamicAny._DynAnyStub
Inserts an integer value into the DynAny.
insert_long(int) - Method in class org.omg.DynamicAny._DynArrayStub
Inserts an integer value into the DynAny.
insert_long(int) - Method in class org.omg.DynamicAny._DynEnumStub
Inserts an integer value into the DynAny.
insert_long(int) - Method in class org.omg.DynamicAny._DynFixedStub
Inserts an integer value into the DynAny.
insert_long(int) - Method in class org.omg.DynamicAny._DynSequenceStub
Inserts an integer value into the DynAny.
insert_long(int) - Method in class org.omg.DynamicAny._DynStructStub
Inserts an integer value into the DynAny.
insert_long(int) - Method in class org.omg.DynamicAny._DynUnionStub
Inserts an integer value into the DynAny.
insert_long(int) - Method in class org.omg.DynamicAny._DynValueStub
Inserts an integer value into the DynAny.
insert_long(int) - Method in interface org.omg.DynamicAny.DynAnyOperations
Inserts an integer value into the DynAny.
insert_longlong(long) - Method in class org.omg.CORBA.Any
Inserts the given long into this Any object's value field.
insert_longlong(long) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Inserts the given long as the value for this DynAny object.
insert_longlong(long) - Method in class org.omg.DynamicAny._DynAnyStub
Inserts a long value into the DynAny.
insert_longlong(long) - Method in class org.omg.DynamicAny._DynArrayStub
Inserts a long value into the DynAny.
insert_longlong(long) - Method in class org.omg.DynamicAny._DynEnumStub
Inserts a long value into the DynAny.
insert_longlong(long) - Method in class org.omg.DynamicAny._DynFixedStub
Inserts a long value into the DynAny.
insert_longlong(long) - Method in class org.omg.DynamicAny._DynSequenceStub
Inserts a long value into the DynAny.
insert_longlong(long) - Method in class org.omg.DynamicAny._DynStructStub
Inserts a long value into the DynAny.
insert_longlong(long) - Method in class org.omg.DynamicAny._DynUnionStub
Inserts a long value into the DynAny.
insert_longlong(long) - Method in class org.omg.DynamicAny._DynValueStub
Inserts a long value into the DynAny.
insert_longlong(long) - Method in interface org.omg.DynamicAny.DynAnyOperations
Inserts a long value into the DynAny.
insert_Object(Object) - Method in class org.omg.CORBA.Any
Inserts the given org.omg.CORBA.Object object into this Any object's value field.
insert_Object(Object, TypeCode) - Method in class org.omg.CORBA.Any
Inserts the given org.omg.CORBA.Object object into this Any object's value field.
insert_octet(byte) - Method in class org.omg.CORBA.Any
Inserts the given byte into this Any object's value field.
insert_octet(byte) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Inserts the given byte as the value for this DynAny object.
insert_octet(byte) - Method in class org.omg.DynamicAny._DynAnyStub
Inserts a byte value into the DynAny.
insert_octet(byte) - Method in class org.omg.DynamicAny._DynArrayStub
Inserts a byte value into the DynAny.
insert_octet(byte) - Method in class org.omg.DynamicAny._DynEnumStub
Inserts a byte value into the DynAny.
insert_octet(byte) - Method in class org.omg.DynamicAny._DynFixedStub
Inserts a byte value into the DynAny.
insert_octet(byte) - Method in class org.omg.DynamicAny._DynSequenceStub
Inserts a byte value into the DynAny.
insert_octet(byte) - Method in class org.omg.DynamicAny._DynStructStub
Inserts a byte value into the DynAny.
insert_octet(byte) - Method in class org.omg.DynamicAny._DynUnionStub
Inserts a byte value into the DynAny.
insert_octet(byte) - Method in class org.omg.DynamicAny._DynValueStub
Inserts a byte value into the DynAny.
insert_octet(byte) - Method in interface org.omg.DynamicAny.DynAnyOperations
Inserts a byte value into the DynAny.
insert_Principal(Principal) - Method in class org.omg.CORBA.Any
Deprecated.
Deprecated by CORBA 2.2.
insert_reference(Object) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Inserts the given org.omg.CORBA.Object as the value for this DynAny object.
insert_reference(Object) - Method in class org.omg.DynamicAny._DynAnyStub
Inserts a reference to a CORBA object into the DynAny.
insert_reference(Object) - Method in class org.omg.DynamicAny._DynArrayStub
Inserts a reference to a CORBA object into the DynAny.
insert_reference(Object) - Method in class org.omg.DynamicAny._DynEnumStub
Inserts a reference to a CORBA object into the DynAny.
insert_reference(Object) - Method in class org.omg.DynamicAny._DynFixedStub
Inserts a reference to a CORBA object into the DynAny.
insert_reference(Object) - Method in class org.omg.DynamicAny._DynSequenceStub
Inserts a reference to a CORBA object into the DynAny.
insert_reference(Object) - Method in class org.omg.DynamicAny._DynStructStub
Inserts a reference to a CORBA object into the DynAny.
insert_reference(Object) - Method in class org.omg.DynamicAny._DynUnionStub
Inserts a reference to a CORBA object into the DynAny.
insert_reference(Object) - Method in class org.omg.DynamicAny._DynValueStub
Inserts a reference to a CORBA object into the DynAny.
insert_reference(Object) - Method in interface org.omg.DynamicAny.DynAnyOperations
Inserts a reference to a CORBA object into the DynAny.
INSERT_ROW_CONFLICT - Static variable in interface javax.sql.rowset.spi.SyncResolver
Indicates that a conflict occurred while the RowSet object was attempting to insert a row into the data source.
insert_short(short) - Method in class org.omg.CORBA.Any
Inserts the given short into this Any object's value field.
insert_short(short) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Inserts the given short as the value for this DynAny object.
insert_short(short) - Method in class org.omg.DynamicAny._DynAnyStub
Inserts a short value into the DynAny.
insert_short(short) - Method in class org.omg.DynamicAny._DynArrayStub
Inserts a short value into the DynAny.
insert_short(short) - Method in class org.omg.DynamicAny._DynEnumStub
Inserts a short value into the DynAny.
insert_short(short) - Method in class org.omg.DynamicAny._DynFixedStub
Inserts a short value into the DynAny.
insert_short(short) - Method in class org.omg.DynamicAny._DynSequenceStub
Inserts a short value into the DynAny.
insert_short(short) - Method in class org.omg.DynamicAny._DynStructStub
Inserts a short value into the DynAny.
insert_short(short) - Method in class org.omg.DynamicAny._DynUnionStub
Inserts a short value into the DynAny.
insert_short(short) - Method in class org.omg.DynamicAny._DynValueStub
Inserts a short value into the DynAny.
insert_short(short) - Method in interface org.omg.DynamicAny.DynAnyOperations
Inserts a short value into the DynAny.
insert_Streamable(Streamable) - Method in class org.omg.CORBA.Any
Inserts the given Streamable object into this Any object's value field.
insert_string(String) - Method in class org.omg.CORBA.Any
Inserts the given String object into this Any object's value field.
insert_string(String) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Inserts the given String object as the value for this DynAny object.
insert_string(String) - Method in class org.omg.DynamicAny._DynAnyStub
Inserts a string value into the DynAny.
insert_string(String) - Method in class org.omg.DynamicAny._DynArrayStub
Inserts a string value into the DynAny.
insert_string(String) - Method in class org.omg.DynamicAny._DynEnumStub
Inserts a string value into the DynAny.
insert_string(String) - Method in class org.omg.DynamicAny._DynFixedStub
Inserts a string value into the DynAny.
insert_string(String) - Method in class org.omg.DynamicAny._DynSequenceStub
Inserts a string value into the DynAny.
insert_string(String) - Method in class org.omg.DynamicAny._DynStructStub
Inserts a string value into the DynAny.
insert_string(String) - Method in class org.omg.DynamicAny._DynUnionStub
Inserts a string value into the DynAny.
insert_string(String) - Method in class org.omg.DynamicAny._DynValueStub
Inserts a string value into the DynAny.
insert_string(String) - Method in interface org.omg.DynamicAny.DynAnyOperations
Inserts a string value into the DynAny.
insert_TypeCode(TypeCode) - Method in class org.omg.CORBA.Any
Inserts the given TypeCode object into this Any object's value field.
insert_typecode(TypeCode) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Inserts the given org.omg.CORBA.TypeCode as the value for this DynAny object.
insert_typecode(TypeCode) - Method in class org.omg.DynamicAny._DynAnyStub
Inserts a TypeCode object into the DynAny.
insert_typecode(TypeCode) - Method in class org.omg.DynamicAny._DynArrayStub
Inserts a TypeCode object into the DynAny.
insert_typecode(TypeCode) - Method in class org.omg.DynamicAny._DynEnumStub
Inserts a TypeCode object into the DynAny.
insert_typecode(TypeCode) - Method in class org.omg.DynamicAny._DynFixedStub
Inserts a TypeCode object into the DynAny.
insert_typecode(TypeCode) - Method in class org.omg.DynamicAny._DynSequenceStub
Inserts a TypeCode object into the DynAny.
insert_typecode(TypeCode) - Method in class org.omg.DynamicAny._DynStructStub
Inserts a TypeCode object into the DynAny.
insert_typecode(TypeCode) - Method in class org.omg.DynamicAny._DynUnionStub
Inserts a TypeCode object into the DynAny.
insert_typecode(TypeCode) - Method in class org.omg.DynamicAny._DynValueStub
Inserts a TypeCode object into the DynAny.
insert_typecode(TypeCode) - Method in interface org.omg.DynamicAny.DynAnyOperations
Inserts a TypeCode object into the DynAny.
insert_ulong(int) - Method in class org.omg.CORBA.Any
Inserts the given int into this Any object's value field.
insert_ulong(int) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Inserts the given int as the value for this DynAny object.
insert_ulong(int) - Method in class org.omg.DynamicAny._DynAnyStub
Inserts an integer value into the DynAny.
insert_ulong(int) - Method in class org.omg.DynamicAny._DynArrayStub
Inserts an integer value into the DynAny.
insert_ulong(int) - Method in class org.omg.DynamicAny._DynEnumStub
Inserts an integer value into the DynAny.
insert_ulong(int) - Method in class org.omg.DynamicAny._DynFixedStub
Inserts an integer value into the DynAny.
insert_ulong(int) - Method in class org.omg.DynamicAny._DynSequenceStub
Inserts an integer value into the DynAny.
insert_ulong(int) - Method in class org.omg.DynamicAny._DynStructStub
Inserts an integer value into the DynAny.
insert_ulong(int) - Method in class org.omg.DynamicAny._DynUnionStub
Inserts an integer value into the DynAny.
insert_ulong(int) - Method in class org.omg.DynamicAny._DynValueStub
Inserts an integer value into the DynAny.
insert_ulong(int) - Method in interface org.omg.DynamicAny.DynAnyOperations
Inserts an integer value into the DynAny.
insert_ulonglong(long) - Method in class org.omg.CORBA.Any
Inserts the given long into this Any object's value field.
insert_ulonglong(long) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Inserts the given long as the value for this DynAny object.
insert_ulonglong(long) - Method in class org.omg.DynamicAny._DynAnyStub
Inserts a long value into the DynAny.
insert_ulonglong(long) - Method in class org.omg.DynamicAny._DynArrayStub
Inserts a long value into the DynAny.
insert_ulonglong(long) - Method in class org.omg.DynamicAny._DynEnumStub
Inserts a long value into the DynAny.
insert_ulonglong(long) - Method in class org.omg.DynamicAny._DynFixedStub
Inserts a long value into the DynAny.
insert_ulonglong(long) - Method in class org.omg.DynamicAny._DynSequenceStub
Inserts a long value into the DynAny.
insert_ulonglong(long) - Method in class org.omg.DynamicAny._DynStructStub
Inserts a long value into the DynAny.
insert_ulonglong(long) - Method in class org.omg.DynamicAny._DynUnionStub
Inserts a long value into the DynAny.
insert_ulonglong(long) - Method in class org.omg.DynamicAny._DynValueStub
Inserts a long value into the DynAny.
insert_ulonglong(long) - Method in interface org.omg.DynamicAny.DynAnyOperations
Inserts a long value into the DynAny.
insert_ushort(short) - Method in class org.omg.CORBA.Any
Inserts the given short into this Any object's value field.
insert_ushort(short) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Inserts the given short as the value for this DynAny object.
insert_ushort(short) - Method in class org.omg.DynamicAny._DynAnyStub
Inserts a short value into the DynAny.
insert_ushort(short) - Method in class org.omg.DynamicAny._DynArrayStub
Inserts a short value into the DynAny.
insert_ushort(short) - Method in class org.omg.DynamicAny._DynEnumStub
Inserts a short value into the DynAny.
insert_ushort(short) - Method in class org.omg.DynamicAny._DynFixedStub
Inserts a short value into the DynAny.
insert_ushort(short) - Method in class org.omg.DynamicAny._DynSequenceStub
Inserts a short value into the DynAny.
insert_ushort(short) - Method in class org.omg.DynamicAny._DynStructStub
Inserts a short value into the DynAny.
insert_ushort(short) - Method in class org.omg.DynamicAny._DynUnionStub
Inserts a short value into the DynAny.
insert_ushort(short) - Method in class org.omg.DynamicAny._DynValueStub
Inserts a short value into the DynAny.
insert_ushort(short) - Method in interface org.omg.DynamicAny.DynAnyOperations
Inserts a short value into the DynAny.
insert_val(Serializable) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Inserts the given java.io.Serializable object as the value for this DynAny object.
insert_val(Serializable) - Method in class org.omg.DynamicAny._DynAnyStub
Inserts a reference to a Serializable object into this DynAny.
insert_val(Serializable) - Method in class org.omg.DynamicAny._DynArrayStub
Inserts a reference to a Serializable object into this DynAny.
insert_val(Serializable) - Method in class org.omg.DynamicAny._DynEnumStub
Inserts a reference to a Serializable object into this DynAny.
insert_val(Serializable) - Method in class org.omg.DynamicAny._DynFixedStub
Inserts a reference to a Serializable object into this DynAny.
insert_val(Serializable) - Method in class org.omg.DynamicAny._DynSequenceStub
Inserts a reference to a Serializable object into this DynAny.
insert_val(Serializable) - Method in class org.omg.DynamicAny._DynStructStub
Inserts a reference to a Serializable object into this DynAny.
insert_val(Serializable) - Method in class org.omg.DynamicAny._DynUnionStub
Inserts a reference to a Serializable object into this DynAny.
insert_val(Serializable) - Method in class org.omg.DynamicAny._DynValueStub
Inserts a reference to a Serializable object into this DynAny.
insert_val(Serializable) - Method in interface org.omg.DynamicAny.DynAnyOperations
Inserts a reference to a Serializable object into this DynAny.
insert_Value(Serializable) - Method in class org.omg.CORBA.Any
Inserts the given java.io.Serializable object into this Any object's value field.
insert_Value(Serializable, TypeCode) - Method in class org.omg.CORBA.Any
Inserts the given java.io.Serializable object into this Any object's value field.
insert_wchar(char) - Method in class org.omg.CORBA.Any
Inserts the given char into this Any object's value field.
insert_wchar(char) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Inserts the given char as the value for this DynAny object.
insert_wchar(char) - Method in class org.omg.DynamicAny._DynAnyStub
Inserts a char value into the DynAny.
insert_wchar(char) - Method in class org.omg.DynamicAny._DynArrayStub
Inserts a char value into the DynAny.
insert_wchar(char) - Method in class org.omg.DynamicAny._DynEnumStub
Inserts a char value into the DynAny.
insert_wchar(char) - Method in class org.omg.DynamicAny._DynFixedStub
Inserts a char value into the DynAny.
insert_wchar(char) - Method in class org.omg.DynamicAny._DynSequenceStub
Inserts a char value into the DynAny.
insert_wchar(char) - Method in class org.omg.DynamicAny._DynStructStub
Inserts a char value into the DynAny.
insert_wchar(char) - Method in class org.omg.DynamicAny._DynUnionStub
Inserts a char value into the DynAny.
insert_wchar(char) - Method in class org.omg.DynamicAny._DynValueStub
Inserts a char value into the DynAny.
insert_wchar(char) - Method in interface org.omg.DynamicAny.DynAnyOperations
Inserts a char value into the DynAny.
insert_wstring(String) - Method in class org.omg.CORBA.Any
Inserts the given String object into this Any object's value field.
insert_wstring(String) - Method in interface org.omg.CORBA.DynAny
Deprecated.
Inserts the given String as the value for this DynAny object.
insert_wstring(String) - Method in class org.omg.DynamicAny._DynAnyStub
Inserts a string value into the DynAny.
insert_wstring(String) - Method in class org.omg.DynamicAny._DynArrayStub
Inserts a string value into the DynAny.
insert_wstring(String) - Method in class org.omg.DynamicAny._DynEnumStub
Inserts a string value into the DynAny.
insert_wstring(String) - Method in class org.omg.DynamicAny._DynFixedStub
Inserts a string value into the DynAny.
insert_wstring(String) - Method in class org.omg.DynamicAny._DynSequenceStub
Inserts a string value into the DynAny.
insert_wstring(String) - Method in class org.omg.DynamicAny._DynStructStub
Inserts a string value into the DynAny.
insert_wstring(String) - Method in class org.omg.DynamicAny._DynUnionStub
Inserts a string value into the DynAny.
insert_wstring(String) - Method in class org.omg.DynamicAny._DynValueStub
Inserts a string value into the DynAny.
insert_wstring(String) - Method in interface org.omg.DynamicAny.DynAnyOperations
Inserts a string value into the DynAny.
insertAfterEnd(Element, String) - Method in class javax.swing.text.html.HTMLDocument
Inserts the HTML specified as a string after the the end of the given element.
insertAfterStart(Element, String) - Method in class javax.swing.text.html.HTMLDocument
Inserts the HTML specified as a string at the start of the element.
insertArguments(MethodHandle, int, Object...) - Static method in class java.lang.invoke.MethodHandles
Provides a target method handle with one or more bound arguments in advance of the method handle's invocation.
insertAtBoundary(JEditorPane, HTMLDocument, int, Element, String, HTML.Tag, HTML.Tag) - Method in class javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction
This is invoked when inserting at a boundary.
insertAtBoundry(JEditorPane, HTMLDocument, int, Element, String, HTML.Tag, HTML.Tag) - Method in class javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction
Deprecated.
As of Java 2 platform v1.3, use insertAtBoundary
insertBefore(Node, Node) - Method in class javax.imageio.metadata.IIOMetadataNode
Inserts the node newChild before the existing child node refChild.
insertBefore(Node, Node) - Method in interface org.w3c.dom.Node
Inserts the node newChild before the existing child node refChild.
insertBeforeEnd(Element, String) - Method in class javax.swing.text.html.HTMLDocument
Inserts the HTML specified as a string at the end of the element.
insertBeforeStart(Element, String) - Method in class javax.swing.text.html.HTMLDocument
Inserts the HTML specified as a string before the start of the given element.
insertBreakAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the action to place a line/paragraph break into the document.
InsertBreakAction() - Constructor for class javax.swing.text.DefaultEditorKit.InsertBreakAction
Creates this object with the appropriate identifier.
insertChar(AttributedCharacterIterator, int) - Method in class java.awt.font.LineBreakMeasurer
Updates this LineBreakMeasurer after a single character is inserted into the text, and sets the current position to the beginning of the paragraph.
insertChar(AttributedCharacterIterator, int) - Method in class java.awt.font.TextMeasurer
Updates the TextMeasurer after a single character has been inserted into the paragraph currently represented by this TextMeasurer.
insertComponent(Component) - Method in class javax.swing.JTextPane
Inserts a component into the document as a replacement for the currently selected content.
insertContentAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the action to place content into the associated document.
InsertContentAction() - Constructor for class javax.swing.text.DefaultEditorKit.InsertContentAction
Creates this object with the appropriate identifier.
insertData(int, String) - Method in interface org.w3c.dom.CharacterData
Insert a string at the specified 16-bit unit offset.
insertElementAt(E, int) - Method in class java.util.Vector
Inserts the specified object as a component in this vector at the specified index.
insertElementAt(E, int) - Method in class javax.swing.DefaultComboBoxModel
insertElementAt(E, int) - Method in class javax.swing.DefaultListModel
Inserts the specified element as a component in this list at the specified index.
insertElementAt(E, int) - Method in interface javax.swing.MutableComboBoxModel
Adds an item at a specific index.
insertEntries(int, int, int) - Method in class javax.swing.SizeSequence
Adds a contiguous group of entries to this SizeSequence.
insertHTML(HTMLDocument, int, String, int, int, HTML.Tag) - Method in class javax.swing.text.html.HTMLEditorKit
Inserts HTML into an existing document.
insertHTML(JEditorPane, HTMLDocument, int, String, int, int, HTML.Tag) - Method in class javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction
A cover for HTMLEditorKit.insertHTML.
InsertHTMLTextAction(String, String, HTML.Tag, HTML.Tag) - Constructor for class javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction
InsertHTMLTextAction(String, String, HTML.Tag, HTML.Tag, HTML.Tag, HTML.Tag) - Constructor for class javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction
insertIcon(Icon) - Method in class javax.swing.JTextPane
Inserts an icon into the document as a replacement for the currently selected content.
insertIndexForLayer(int, int) - Method in class javax.swing.JLayeredPane
Primitive method that determines the proper location to insert a new child based on layer and position requests.
insertIndexInterval(int, int, boolean) - Method in class javax.swing.DefaultListSelectionModel
Insert length indices beginning before/after index.
insertIndexInterval(int, int, boolean) - Method in interface javax.swing.ListSelectionModel
Insert length indices beginning before/after index.
insertItemAt(E, int) - Method in class javax.swing.JComboBox
Inserts an item into the item list at a given index.
insertNodeInto(MutableTreeNode, MutableTreeNode, int) - Method in class javax.swing.tree.DefaultTreeModel
Invoked this to insert newChild at location index in parents children.
insertParameterTypes(int, Class<?>...) - Method in class java.lang.invoke.MethodType
Finds or creates a method type with additional parameter types.
insertParameterTypes(int, List<Class<?>>) - Method in class java.lang.invoke.MethodType
Finds or creates a method type with additional parameter types.
insertProviderAt(Provider, int) - Static method in class java.security.Security
Adds a new provider, at a specified position.
insertRow() - Method in interface java.sql.ResultSet
Inserts the contents of the insert row into this ResultSet object and into the database.
insertRow(int, Vector) - Method in class javax.swing.table.DefaultTableModel
Inserts a row at row in the model.
insertRow(int, Object[]) - Method in class javax.swing.table.DefaultTableModel
Inserts a row at row in the model.
insertsAreDetected(int) - Method in interface java.sql.DatabaseMetaData
Retrieves whether or not a visible row insert can be detected by calling the method ResultSet.rowInserted.
insertSeparator(int) - Method in class java.awt.Menu
Inserts a separator at the specified position.
insertSeparator(int) - Method in class javax.swing.JMenu
Inserts a separator at the specified position.
insertString(int, String) - Method in interface javax.swing.text.AbstractDocument.Content
Inserts a string of characters into the sequence.
insertString(int, String, AttributeSet) - Method in class javax.swing.text.AbstractDocument
Inserts some content into the document.
insertString(int, String, AttributeSet) - Method in interface javax.swing.text.Document
Inserts a string of content.
insertString(int, String, AttributeSet) - Method in class javax.swing.text.DocumentFilter.FilterBypass
Inserts the specified text, bypassing the DocumentFilter.
insertString(DocumentFilter.FilterBypass, int, String, AttributeSet) - Method in class javax.swing.text.DocumentFilter
Invoked prior to insertion of text into the specified Document.
insertString(int, String) - Method in class javax.swing.text.GapContent
Inserts a string into the content.
insertString(int, String, AttributeSet) - Method in class javax.swing.text.PlainDocument
Inserts some content into the document.
insertString(int, String) - Method in class javax.swing.text.StringContent
Inserts a string into the content.
insertTab(String, Icon, Component, String, int) - Method in class javax.swing.JTabbedPane
Inserts a new tab for the given component, at the given index, represented by the given title and/or icon, either of which may be null.
insertTabAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the action to place a tab character into the document.
InsertTabAction() - Constructor for class javax.swing.text.DefaultEditorKit.InsertTabAction
Creates this object with the appropriate identifier.
insertText(String, int) - Method in class java.awt.TextArea
Deprecated.
As of JDK version 1.1, replaced by insert(String, int).
insertTextAtIndex(int, String) - Method in interface javax.accessibility.AccessibleEditableText
Inserts the specified string at the given index/
insertTextAtIndex(int, String) - Method in class javax.swing.JSpinner.AccessibleJSpinner
Inserts the specified string at the given index/
insertTextAtIndex(int, String) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent
Inserts the specified string at the given index
insertUpdate(DocumentEvent) - Method in interface javax.swing.event.DocumentListener
Gives notification that there was an insert into the document.
insertUpdate(AbstractDocument.DefaultDocumentEvent, AttributeSet) - Method in class javax.swing.text.AbstractDocument
Updates document structure as a result of text insertion.
insertUpdate(DefaultStyledDocument.ElementSpec[]) - Method in class javax.swing.text.DefaultStyledDocument.ElementBuffer
Inserts an update into the document.
insertUpdate(AbstractDocument.DefaultDocumentEvent, AttributeSet) - Method in class javax.swing.text.DefaultStyledDocument
Updates document structure as a result of text insertion.
insertUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.FieldView
Gives notification that something was inserted into the document in a location that this view is responsible for.
insertUpdate(FlowView, DocumentEvent, Rectangle) - Method in class javax.swing.text.FlowView.FlowStrategy
Gives notification that something was inserted into the document in a location that the given flow view is responsible for.
insertUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.FlowView
Gives notification that something was inserted into the document in a location that this view is responsible for.
insertUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.GlyphView
Gives notification that something was inserted into the document in a location that this view is responsible for.
insertUpdate(AbstractDocument.DefaultDocumentEvent, AttributeSet) - Method in class javax.swing.text.html.HTMLDocument
Updates document structure as a result of text insertion.
insertUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.html.InlineView
Gives notification that something was inserted into the document in a location that this view is responsible for.
insertUpdate(DocumentEvent) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent
Handles document insert (fire appropriate property change event which is AccessibleContext.ACCESSIBLE_TEXT_PROPERTY).
insertUpdate(AbstractDocument.DefaultDocumentEvent, AttributeSet) - Method in class javax.swing.text.PlainDocument
Updates document structure as a result of text insertion.
insertUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.PlainView
Gives notification that something was inserted into the document in a location that this view is responsible for.
insertUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.View
Gives notification that something was inserted into the document in a location that this view is responsible for.
insertUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.WrappedPlainView
Gives notification that something was inserted into the document in a location that this view is responsible for.
insertUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.ZoneView
Gives notification that something was inserted into the document in a location that this view is responsible for.
insetCache - Variable in class javax.swing.plaf.basic.BasicSliderUI
insets() - Method in class java.awt.Container
Deprecated.
As of JDK version 1.1, replaced by getInsets().
insets - Variable in class java.awt.GridBagConstraints
This field specifies the external padding of the component, the minimum amount of space between the component and the edges of its display area.
Insets - Class in java.awt
An Insets object is a representation of the borders of a container.
Insets(int, int, int, int) - Constructor for class java.awt.Insets
Creates and initializes a new Insets object with the specified top, left, bottom, and right insets.
InsetsUIResource - Class in javax.swing.plaf
InsetsUIResource(int, int, int, int) - Constructor for class javax.swing.plaf.InsetsUIResource
inside(int, int) - Method in class java.awt.Component
Deprecated.
As of JDK version 1.1, replaced by contains(int, int).
inside(int, int) - Method in class java.awt.Polygon
Deprecated.
As of JDK version 1.1, replaced by contains(int, int).
inside(int, int) - Method in class java.awt.Rectangle
Deprecated.
As of JDK version 1.1, replaced by contains(int, int).
insideBorder - Variable in class javax.swing.border.CompoundBorder
insideTimerAction() - Constructor for class javax.swing.ToolTipManager.insideTimerAction
install(JFormattedTextField) - Method in class javax.swing.JFormattedTextField.AbstractFormatter
Installs the AbstractFormatter onto a particular JFormattedTextField.
install(JTextComponent) - Method in interface javax.swing.text.Caret
Called when the UI is being installed into the interface of a JTextComponent.
install(JTextComponent) - Method in class javax.swing.text.DefaultCaret
Called when the UI is being installed into the interface of a JTextComponent.
install(JFormattedTextField) - Method in class javax.swing.text.DefaultFormatter
Installs the DefaultFormatter onto a particular JFormattedTextField.
install(JTextComponent) - Method in class javax.swing.text.DefaultHighlighter
Called when the UI is being installed into the interface of a JTextComponent.
install(JEditorPane) - Method in class javax.swing.text.EditorKit
Called when the kit is being installed into the a JEditorPane.
install(JTextComponent) - Method in interface javax.swing.text.Highlighter
Called when the UI is being installed into the interface of a JTextComponent.
install(JEditorPane) - Method in class javax.swing.text.html.HTMLEditorKit
Called when the kit is being installed into the a JEditorPane.
install(JFormattedTextField) - Method in class javax.swing.text.InternationalFormatter
Installs the DefaultFormatter onto a particular JFormattedTextField.
install(JFormattedTextField) - Method in class javax.swing.text.MaskFormatter
Installs the DefaultFormatter onto a particular JFormattedTextField.
install(JEditorPane) - Method in class javax.swing.text.StyledEditorKit
Called when the kit is being installed into a JEditorPane.
installAncestorListener() - Method in class javax.swing.JComboBox
installBorder(JComponent, String) - Static method in class javax.swing.LookAndFeel
Convenience method for setting a component's border property with a value from the defaults.
installChooserPanel(JColorChooser) - Method in class javax.swing.colorchooser.AbstractColorChooserPanel
Invoked when the panel is added to the chooser.
installColors(JComponent, String, String) - Static method in class javax.swing.LookAndFeel
Convenience method for setting a component's foreground and background color properties with values from the defaults.
installColorsAndFont(JComponent, String, String, String) - Static method in class javax.swing.LookAndFeel
Convenience method for setting a component's foreground, background and font properties with values from the defaults.
installComboBoxListeners() - Method in class javax.swing.plaf.basic.BasicComboPopup
This method adds the necessary listeners to the JComboBox.
installComboBoxModelListeners(ComboBoxModel) - Method in class javax.swing.plaf.basic.BasicComboPopup
Installs the listeners on the combo box model.
installComponents() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Creates and initializes the components which make up the aggregate combo box.
installComponents() - Method in class javax.swing.plaf.basic.BasicDesktopIconUI
installComponents(JFileChooser) - Method in class javax.swing.plaf.basic.BasicFileChooserUI
installComponents() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
installComponents(JLabel) - Method in class javax.swing.plaf.basic.BasicLabelUI
installComponents(JMenuItem) - Method in class javax.swing.plaf.basic.BasicMenuItemUI
installComponents() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI
installComponents(JRootPane) - Method in class javax.swing.plaf.basic.BasicRootPaneUI
installComponents() - Method in class javax.swing.plaf.basic.BasicScrollBarUI
installComponents() - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
Creates and installs any required subcomponents for the JTabbedPane.
installComponents() - Method in class javax.swing.plaf.basic.BasicToolBarUI
installComponents() - Method in class javax.swing.plaf.basic.BasicTreeUI
Intalls the subcomponents of the tree, which is the renderer pane.
installComponents() - Method in class javax.swing.plaf.metal.MetalDesktopIconUI
installComponents(JFileChooser) - Method in class javax.swing.plaf.metal.MetalFileChooserUI
installComponents() - Method in class javax.swing.plaf.synth.SynthDesktopIconUI
installComponents() - Method in class javax.swing.plaf.synth.SynthOptionPaneUI
installComponents() - Method in class javax.swing.plaf.synth.SynthToolBarUI
installDefaults(AbstractButton) - Method in class javax.swing.plaf.basic.BasicButtonUI
installDefaults() - Method in class javax.swing.plaf.basic.BasicColorChooserUI
installDefaults() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Installs the default colors, default font, default renderer, and default editor into the JComboBox.
installDefaults() - Method in class javax.swing.plaf.basic.BasicDesktopIconUI
installDefaults() - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI
installDefaults(JFileChooser) - Method in class javax.swing.plaf.basic.BasicFileChooserUI
installDefaults() - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
installDefaults() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
installDefaults(JLabel) - Method in class javax.swing.plaf.basic.BasicLabelUI
installDefaults() - Method in class javax.swing.plaf.basic.BasicListUI
Initializes list properties such as font, foreground, and background, and adds the CellRendererPane.
installDefaults() - Method in class javax.swing.plaf.basic.BasicMenuBarUI
installDefaults() - Method in class javax.swing.plaf.basic.BasicMenuItemUI
installDefaults() - Method in class javax.swing.plaf.basic.BasicMenuUI
installDefaults() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI
installDefaults(JPanel) - Method in class javax.swing.plaf.basic.BasicPanelUI
installDefaults() - Method in class javax.swing.plaf.basic.BasicPasswordFieldUI
Installs the necessary properties on the JPasswordField.
installDefaults() - Method in class javax.swing.plaf.basic.BasicPopupMenuUI
installDefaults() - Method in class javax.swing.plaf.basic.BasicProgressBarUI
installDefaults(AbstractButton) - Method in class javax.swing.plaf.basic.BasicRadioButtonUI
installDefaults(JRootPane) - Method in class javax.swing.plaf.basic.BasicRootPaneUI
installDefaults() - Method in class javax.swing.plaf.basic.BasicScrollBarUI
installDefaults(JScrollPane) - Method in class javax.swing.plaf.basic.BasicScrollPaneUI
installDefaults(JSeparator) - Method in class javax.swing.plaf.basic.BasicSeparatorUI
installDefaults(JSlider) - Method in class javax.swing.plaf.basic.BasicSliderUI
installDefaults() - Method in class javax.swing.plaf.basic.BasicSpinnerUI
Initialize the JSpinner border, foreground, and background, properties based on the corresponding "Spinner.*" properties from defaults table.
installDefaults() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Installs the UI defaults.
installDefaults() - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
installDefaults() - Method in class javax.swing.plaf.basic.BasicTableHeaderUI
Initializes JTableHeader properties such as font, foreground, and background.
installDefaults() - Method in class javax.swing.plaf.basic.BasicTableUI
Initialize JTable properties, e.g.
installDefaults() - Method in class javax.swing.plaf.basic.BasicTextAreaUI
installDefaults() - Method in class javax.swing.plaf.basic.BasicTextUI
Initializes component properties, such as font, foreground, background, caret color, selection color, selected text color, disabled text color, and border color.
installDefaults(JSeparator) - Method in class javax.swing.plaf.basic.BasicToolBarSeparatorUI
installDefaults() - Method in class javax.swing.plaf.basic.BasicToolBarUI
installDefaults(JComponent) - Method in class javax.swing.plaf.basic.BasicToolTipUI
installDefaults() - Method in class javax.swing.plaf.basic.BasicTreeUI
installDefaults(JComponent) - Method in class javax.swing.plaf.basic.BasicViewportUI
installDefaults(AbstractButton) - Method in class javax.swing.plaf.metal.MetalButtonUI
installDefaults(AbstractButton) - Method in class javax.swing.plaf.metal.MetalCheckBoxUI
installDefaults() - Method in class javax.swing.plaf.metal.MetalDesktopIconUI
installDefaults() - Method in class javax.swing.plaf.metal.MetalInternalFrameTitlePane
installDefaults(AbstractButton) - Method in class javax.swing.plaf.metal.MetalRadioButtonUI
installDefaults() - Method in class javax.swing.plaf.metal.MetalScrollBarUI
installDefaults(JSeparator) - Method in class javax.swing.plaf.metal.MetalSeparatorUI
installDefaults() - Method in class javax.swing.plaf.metal.MetalTabbedPaneUI
installDefaults(AbstractButton) - Method in class javax.swing.plaf.metal.MetalToggleButtonUI
installDefaults(SynthContext) - Method in class javax.swing.plaf.nimbus.NimbusStyle
Installs the necessary state from this Style on the JComponent from context.
installDefaults(AbstractButton) - Method in class javax.swing.plaf.synth.SynthButtonUI
installDefaults() - Method in class javax.swing.plaf.synth.SynthColorChooserUI
installDefaults() - Method in class javax.swing.plaf.synth.SynthComboBoxUI
installDefaults() - Method in class javax.swing.plaf.synth.SynthDesktopIconUI
installDefaults() - Method in class javax.swing.plaf.synth.SynthDesktopPaneUI
installDefaults() - Method in class javax.swing.plaf.synth.SynthEditorPaneUI
Initializes component properties, such as font, foreground, background, caret color, selection color, selected text color, disabled text color, and border color.
installDefaults() - Method in class javax.swing.plaf.synth.SynthInternalFrameUI
installDefaults(JLabel) - Method in class javax.swing.plaf.synth.SynthLabelUI
installDefaults() - Method in class javax.swing.plaf.synth.SynthListUI
Initializes list properties such as font, foreground, and background, and adds the CellRendererPane.
installDefaults() - Method in class javax.swing.plaf.synth.SynthMenuBarUI
installDefaults() - Method in class javax.swing.plaf.synth.SynthMenuItemUI
installDefaults() - Method in class javax.swing.plaf.synth.SynthMenuUI
installDefaults() - Method in class javax.swing.plaf.synth.SynthOptionPaneUI
installDefaults(JPanel) - Method in class javax.swing.plaf.synth.SynthPanelUI
installDefaults() - Method in class javax.swing.plaf.synth.SynthPopupMenuUI
installDefaults() - Method in class javax.swing.plaf.synth.SynthProgressBarUI
installDefaults(JRootPane) - Method in class javax.swing.plaf.synth.SynthRootPaneUI
installDefaults() - Method in class javax.swing.plaf.synth.SynthScrollBarUI
installDefaults(JScrollPane) - Method in class javax.swing.plaf.synth.SynthScrollPaneUI
installDefaults(JSeparator) - Method in class javax.swing.plaf.synth.SynthSeparatorUI
Installs default setting.
installDefaults(JSlider) - Method in class javax.swing.plaf.synth.SynthSliderUI
installDefaults() - Method in class javax.swing.plaf.synth.SynthSpinnerUI
Initializes the JSpinner border, foreground, and background, properties based on the corresponding "Spinner.*" properties from defaults table.
installDefaults() - Method in class javax.swing.plaf.synth.SynthSplitPaneUI
Installs the UI defaults.
installDefaults(SynthContext) - Method in class javax.swing.plaf.synth.SynthStyle
Installs the necessary state from this Style on the JComponent from context.
installDefaults() - Method in class javax.swing.plaf.synth.SynthTabbedPaneUI
installDefaults() - Method in class javax.swing.plaf.synth.SynthTableHeaderUI
Initializes JTableHeader properties such as font, foreground, and background.
installDefaults() - Method in class javax.swing.plaf.synth.SynthTableUI
Initializes JTable properties, such as font, foreground, and background.
installDefaults() - Method in class javax.swing.plaf.synth.SynthTextAreaUI
Initializes component properties, such as font, foreground, background, caret color, selection color, selected text color, disabled text color, and border color.
installDefaults() - Method in class javax.swing.plaf.synth.SynthTextFieldUI
Initializes component properties, such as font, foreground, background, caret color, selection color, selected text color, disabled text color, and border color.
installDefaults() - Method in class javax.swing.plaf.synth.SynthToolBarUI
installDefaults(JComponent) - Method in class javax.swing.plaf.synth.SynthToolTipUI
installDefaults() - Method in class javax.swing.plaf.synth.SynthTreeUI
installDefaults(JComponent) - Method in class javax.swing.plaf.synth.SynthViewportUI
Installs defaults for a viewport.
installDesktopManager() - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI
installDesktopManager() - Method in class javax.swing.plaf.synth.SynthDesktopPaneUI
installedProviders() - Static method in class java.nio.file.spi.FileSystemProvider
Returns a list of the installed file system providers.
installIcons(JFileChooser) - Method in class javax.swing.plaf.basic.BasicFileChooserUI
installKeyboardActions(JComponent) - Method in class javax.swing.plaf.basic.BasicButtonListener
Register default key actions: pressing space to "click" a button and registring the keyboard mnemonic (if any).
installKeyboardActions(AbstractButton) - Method in class javax.swing.plaf.basic.BasicButtonUI
installKeyboardActions() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Adds keyboard actions to the JComboBox.
installKeyboardActions() - Method in class javax.swing.plaf.basic.BasicComboPopup
installKeyboardActions() - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI
installKeyboardActions() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
installKeyboardActions(JLabel) - Method in class javax.swing.plaf.basic.BasicLabelUI
installKeyboardActions() - Method in class javax.swing.plaf.basic.BasicListUI
Registers the keyboard bindings on the JList that the BasicListUI is associated with.
installKeyboardActions() - Method in class javax.swing.plaf.basic.BasicMenuBarUI
installKeyboardActions() - Method in class javax.swing.plaf.basic.BasicMenuItemUI
installKeyboardActions() - Method in class javax.swing.plaf.basic.BasicMenuUI
installKeyboardActions() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI
installKeyboardActions() - Method in class javax.swing.plaf.basic.BasicPopupMenuUI
installKeyboardActions(JRootPane) - Method in class javax.swing.plaf.basic.BasicRootPaneUI
installKeyboardActions() - Method in class javax.swing.plaf.basic.BasicScrollBarUI
installKeyboardActions(JScrollPane) - Method in class javax.swing.plaf.basic.BasicScrollPaneUI
installKeyboardActions(JSlider) - Method in class javax.swing.plaf.basic.BasicSliderUI
installKeyboardActions() - Method in class javax.swing.plaf.basic.BasicSpinnerUI
Installs the keyboard Actions onto the JSpinner.
installKeyboardActions() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Installs the keyboard actions for the UI.
installKeyboardActions() - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
installKeyboardActions() - Method in class javax.swing.plaf.basic.BasicTableHeaderUI
Register all keyboard actions on the JTableHeader.
installKeyboardActions() - Method in class javax.swing.plaf.basic.BasicTableUI
Register all keyboard actions on the JTable.
installKeyboardActions() - Method in class javax.swing.plaf.basic.BasicTextUI
installKeyboardActions() - Method in class javax.swing.plaf.basic.BasicToolBarUI
installKeyboardActions() - Method in class javax.swing.plaf.basic.BasicTreeUI
installKeyboardActions() - Method in class javax.swing.plaf.metal.MetalInternalFrameUI
installKeyboardActions() - Method in class javax.swing.plaf.synth.SynthPasswordFieldUI
installListeners(AbstractButton) - Method in class javax.swing.plaf.basic.BasicButtonUI
installListeners() - Method in class javax.swing.plaf.basic.BasicColorChooserUI
installListeners() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Creates and installs listeners for the combo box and its model.
installListeners() - Method in class javax.swing.plaf.basic.BasicDesktopIconUI
installListeners() - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI
Installs the PropertyChangeListener returned from createPropertyChangeListener on the JDesktopPane.
installListeners(JFileChooser) - Method in class javax.swing.plaf.basic.BasicFileChooserUI
installListeners() - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
installListeners() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
installListeners(JLabel) - Method in class javax.swing.plaf.basic.BasicLabelUI
installListeners() - Method in class javax.swing.plaf.basic.BasicListUI
Creates and installs the listeners for the JList, its model, and its selectionModel.
installListeners() - Method in class javax.swing.plaf.basic.BasicMenuBarUI
installListeners() - Method in class javax.swing.plaf.basic.BasicMenuItemUI
installListeners() - Method in class javax.swing.plaf.basic.BasicMenuUI
installListeners() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI
installListeners() - Method in class javax.swing.plaf.basic.BasicPopupMenuUI
installListeners() - Method in class javax.swing.plaf.basic.BasicProgressBarUI
installListeners(JRootPane) - Method in class javax.swing.plaf.basic.BasicRootPaneUI
installListeners() - Method in class javax.swing.plaf.basic.BasicScrollBarUI
installListeners(JScrollPane) - Method in class javax.swing.plaf.basic.BasicScrollPaneUI
installListeners(JSeparator) - Method in class javax.swing.plaf.basic.BasicSeparatorUI
installListeners(JSlider) - Method in class javax.swing.plaf.basic.BasicSliderUI
installListeners() - Method in class javax.swing.plaf.basic.BasicSpinnerUI
Initializes PropertyChangeListener with a shared object that delegates interesting PropertyChangeEvents to protected methods.
installListeners() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Installs the event listeners for the UI.
installListeners() - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
installListeners() - Method in class javax.swing.plaf.basic.BasicTableHeaderUI
Attaches listeners to the JTableHeader.
installListeners() - Method in class javax.swing.plaf.basic.BasicTableUI
Attaches listeners to the JTable.
installListeners() - Method in class javax.swing.plaf.basic.BasicTextUI
Installs listeners for the UI.
installListeners() - Method in class javax.swing.plaf.basic.BasicToolBarUI
installListeners(JComponent) - Method in class javax.swing.plaf.basic.BasicToolTipUI
installListeners() - Method in class javax.swing.plaf.basic.BasicTreeUI
installListeners() - Method in class javax.swing.plaf.metal.MetalDesktopIconUI
installListeners(JFileChooser) - Method in class javax.swing.plaf.metal.MetalFileChooserUI
installListeners() - Method in class javax.swing.plaf.metal.MetalInternalFrameUI
installListeners() - Method in class javax.swing.plaf.metal.MetalScrollBarUI
installListeners(JScrollPane) - Method in class javax.swing.plaf.metal.MetalScrollPaneUI
installListeners() - Method in class javax.swing.plaf.metal.MetalToolBarUI
installListeners(AbstractButton) - Method in class javax.swing.plaf.synth.SynthButtonUI
installListeners() - Method in class javax.swing.plaf.synth.SynthColorChooserUI
installListeners() - Method in class javax.swing.plaf.synth.SynthComboBoxUI
Creates and installs listeners for the combo box and its model.
installListeners() - Method in class javax.swing.plaf.synth.SynthDesktopIconUI
installListeners() - Method in class javax.swing.plaf.synth.SynthDesktopPaneUI
Installs the PropertyChangeListener returned from createPropertyChangeListener on the JDesktopPane.
installListeners() - Method in class javax.swing.plaf.synth.SynthInternalFrameUI
installListeners() - Method in class javax.swing.plaf.synth.SynthListUI
Creates and installs the listeners for the JList, its model, and its selectionModel.
installListeners() - Method in class javax.swing.plaf.synth.SynthMenuBarUI
installListeners() - Method in class javax.swing.plaf.synth.SynthMenuItemUI
installListeners() - Method in class javax.swing.plaf.synth.SynthMenuUI
installListeners() - Method in class javax.swing.plaf.synth.SynthOptionPaneUI
installListeners(JPanel) - Method in class javax.swing.plaf.synth.SynthPanelUI
Installs listeners into the panel.
installListeners() - Method in class javax.swing.plaf.synth.SynthPopupMenuUI
installListeners() - Method in class javax.swing.plaf.synth.SynthProgressBarUI
installListeners() - Method in class javax.swing.plaf.synth.SynthScrollBarUI
installListeners(JScrollPane) - Method in class javax.swing.plaf.synth.SynthScrollPaneUI
installListeners(JSeparator) - Method in class javax.swing.plaf.synth.SynthSeparatorUI
Installs listeners.
installListeners(JSlider) - Method in class javax.swing.plaf.synth.SynthSliderUI
installListeners() - Method in class javax.swing.plaf.synth.SynthSpinnerUI
Initializes PropertyChangeListener with a shared object that delegates interesting PropertyChangeEvents to protected methods.
installListeners() - Method in class javax.swing.plaf.synth.SynthSplitPaneUI
Installs the event listeners for the UI.
installListeners() - Method in class javax.swing.plaf.synth.SynthTabbedPaneUI
installListeners() - Method in class javax.swing.plaf.synth.SynthTableHeaderUI
Attaches listeners to the JTableHeader.
installListeners() - Method in class javax.swing.plaf.synth.SynthTableUI
Attaches listeners to the JTable.
installListeners() - Method in class javax.swing.plaf.synth.SynthToolBarUI
installListeners(JComponent) - Method in class javax.swing.plaf.synth.SynthToolTipUI
installListeners() - Method in class javax.swing.plaf.synth.SynthTreeUI
installListeners(JComponent) - Method in class javax.swing.plaf.synth.SynthViewportUI
Installs listeners into the viewport.
installListListeners() - Method in class javax.swing.plaf.basic.BasicComboPopup
Adds the listeners to the list control.
installLookAndFeel(UIManager.LookAndFeelInfo) - Static method in class javax.swing.UIManager
Adds the specified look and feel to the set of available look and feels.
installLookAndFeel(String, String) - Static method in class javax.swing.UIManager
Adds the specified look and feel to the set of available look and feels.
installMouseHandlers(JComponent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
installNextButtonListeners(Component) - Method in class javax.swing.plaf.basic.BasicSpinnerUI
Installs the necessary listeners on the next button, c, to update the JSpinner in response to a user gesture.
installNonRolloverBorders(JComponent) - Method in class javax.swing.plaf.basic.BasicToolBarUI
Installs non-rollover borders on all the child components of the JComponent.
installNormalBorders(JComponent) - Method in class javax.swing.plaf.basic.BasicToolBarUI
Installs normal borders on all the child components of the JComponent.
installPreviewPanel() - Method in class javax.swing.plaf.basic.BasicColorChooserUI
installPreviousButtonListeners(Component) - Method in class javax.swing.plaf.basic.BasicSpinnerUI
Installs the necessary listeners on the previous button, c, to update the JSpinner in response to a user gesture.
installProperty(JComponent, String, Object) - Static method in class javax.swing.LookAndFeel
Convenience method for installing a property with the specified name and value on a component if that property has not already been set by the developer.
installRolloverBorders(JComponent) - Method in class javax.swing.plaf.basic.BasicToolBarUI
Installs rollover borders on all the child components of the JComponent.
installStrings(JFileChooser) - Method in class javax.swing.plaf.basic.BasicFileChooserUI
installStrings(JFileChooser) - Method in class javax.swing.plaf.metal.MetalFileChooserUI
installTitlePane() - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicButtonUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicColorChooserUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicComboBoxUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicDesktopIconUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicEditorPaneUI
Installs the UI for a component.
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicFileChooserUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicLabelUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicListUI
Initializes this.list by calling installDefaults(), installListeners(), and installKeyboardActions() in order.
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicMenuBarUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicMenuItemUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicOptionPaneUI
Installs the receiver as the L&F for the passed in JOptionPane.
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicPanelUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicPopupMenuUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicProgressBarUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicRootPaneUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicScrollBarUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicScrollPaneUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicSeparatorUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicSliderUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicSpinnerUI
Calls installDefaults, installListeners, and then adds the components returned by createNextButton, createPreviousButton, and createEditor.
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Installs the UI.
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicTableHeaderUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicTableUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicTextPaneUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicTextUI
Installs the UI for a component.
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicToolBarUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicToolTipUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicTreeUI
installUI(JComponent) - Method in class javax.swing.plaf.basic.BasicViewportUI
installUI(JComponent) - Method in class javax.swing.plaf.ComponentUI
Configures the specified component appropriately for the look and feel.
installUI(JComponent) - Method in class javax.swing.plaf.LayerUI
Configures the JLayer this LayerUI is set to.
installUI(JComponent) - Method in class javax.swing.plaf.metal.MetalFileChooserUI
installUI(JComponent) - Method in class javax.swing.plaf.metal.MetalInternalFrameUI
installUI(JComponent) - Method in class javax.swing.plaf.metal.MetalMenuBarUI
Configures the specified component appropriate for the metal look and feel.
installUI(JComponent) - Method in class javax.swing.plaf.metal.MetalRootPaneUI
Invokes supers implementation of installUI to install the necessary state onto the passed in JRootPane to render the metal look and feel implementation of RootPaneUI.
installUI(JComponent) - Method in class javax.swing.plaf.metal.MetalScrollPaneUI
installUI(JComponent) - Method in class javax.swing.plaf.metal.MetalSliderUI
installUI(JComponent) - Method in class javax.swing.plaf.metal.MetalToolBarUI
installUI(JComponent) - Method in class javax.swing.plaf.metal.MetalToolTipUI
installUI(JComponent) - Method in class javax.swing.plaf.metal.MetalTreeUI
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiButtonUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiColorChooserUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiComboBoxUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiDesktopIconUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiDesktopPaneUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiFileChooserUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiInternalFrameUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiLabelUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiListUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiMenuBarUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiMenuItemUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiOptionPaneUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiPanelUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiPopupMenuUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiProgressBarUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiRootPaneUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiScrollBarUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiScrollPaneUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiSeparatorUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiSliderUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiSpinnerUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiSplitPaneUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiTabbedPaneUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiTableHeaderUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiTableUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiTextUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiToolBarUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiToolTipUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiTreeUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.multi.MultiViewportUI
Invokes the installUI method on each UI handled by this object.
installUI(JComponent) - Method in class javax.swing.plaf.synth.SynthComboBoxUI
Configures the specified component appropriately for the look and feel.
installUI(JComponent) - Method in class javax.swing.plaf.synth.SynthPanelUI
Configures the specified component appropriately for the look and feel.
installUI(JComponent) - Method in class javax.swing.plaf.synth.SynthSeparatorUI
Configures the specified component appropriately for the look and feel.
installUI(JComponent) - Method in class javax.swing.plaf.synth.SynthTextPaneUI
Installs the UI for a component.
installUI(JComponent) - Method in class javax.swing.plaf.synth.SynthViewportUI
Configures the specified component appropriately for the look and feel.
INSTANCE - Static variable in class java.time.chrono.HijrahChronology
Singleton instance of the Islamic Umm Al-Qura calendar of Saudi Arabia.
INSTANCE - Static variable in class java.time.chrono.IsoChronology
Singleton instance of the ISO chronology.
INSTANCE - Static variable in class java.time.chrono.JapaneseChronology
Singleton instance for Japanese chronology.
INSTANCE - Static variable in class java.time.chrono.MinguoChronology
Singleton instance for the Minguo chronology.
INSTANCE - Static variable in class java.time.chrono.ThaiBuddhistChronology
Singleton instance of the Buddhist chronology.
InstanceAlreadyExistsException - Exception in javax.management
The MBean is already registered in the repository.
InstanceAlreadyExistsException() - Constructor for exception javax.management.InstanceAlreadyExistsException
Default constructor.
InstanceAlreadyExistsException(String) - Constructor for exception javax.management.InstanceAlreadyExistsException
Constructor that allows a specific error message to be specified.
instanceFollowRedirects - Variable in class java.net.HttpURLConnection
If true, the protocol will automatically follow redirects.
InstanceNotFoundException - Exception in javax.management
The specified MBean does not exist in the repository.
InstanceNotFoundException() - Constructor for exception javax.management.InstanceNotFoundException
Default constructor.
InstanceNotFoundException(String) - Constructor for exception javax.management.InstanceNotFoundException
Constructor that allows a specific error message to be specified.
instant() - Method in class java.time.Clock
Gets the current instant of the clock.
Instant - Class in java.time
An instantaneous point on the time-line.
instantiate(ClassLoader, String) - Static method in class java.beans.Beans
Instantiate a JavaBean.
instantiate(ClassLoader, String, BeanContext) - Static method in class java.beans.Beans
Instantiate a JavaBean.
instantiate(ClassLoader, String, BeanContext, AppletInitializer) - Static method in class java.beans.Beans
Instantiate a bean.
instantiate(Object, Encoder) - Method in class java.beans.DefaultPersistenceDelegate
This default implementation of the instantiate method returns an expression containing the predefined method name "new" which denotes a call to a constructor with the arguments as specified in the DefaultPersistenceDelegate's constructor.
instantiate(Object, Encoder) - Method in class java.beans.PersistenceDelegate
Returns an expression whose value is oldInstance.
instantiate(String) - Method in interface javax.management.MBeanServer
Instantiates an object using the list of all class loaders registered in the MBean server's Class Loader Repository.
instantiate(String, ObjectName) - Method in interface javax.management.MBeanServer
Instantiates an object using the class Loader specified by its ObjectName.
instantiate(String, Object[], String[]) - Method in interface javax.management.MBeanServer
Instantiates an object using the list of all class loaders registered in the MBean server Class Loader Repository.
instantiate(String, ObjectName, Object[], String[]) - Method in interface javax.management.MBeanServer
Instantiates an object.
instantiateChild(String) - Method in interface java.beans.beancontext.BeanContext
Instantiate the javaBean named as a child of this BeanContext.
instantiateChild(String) - Method in class java.beans.beancontext.BeanContextSupport
The instantiateChild method is a convenience hook in BeanContext to simplify the task of instantiating a Bean, nested, into a BeanContext.
InstantiationError - Error in java.lang
Thrown when an application tries to use the Java new construct to instantiate an abstract class or an interface.
InstantiationError() - Constructor for error java.lang.InstantiationError
Constructs an InstantiationError with no detail message.
InstantiationError(String) - Constructor for error java.lang.InstantiationError
Constructs an InstantiationError with the specified detail message.
InstantiationException - Exception in java.lang
Thrown when an application tries to create an instance of a class using the newInstance method in class Class, but the specified class object cannot be instantiated.
InstantiationException() - Constructor for exception java.lang.InstantiationException
Constructs an InstantiationException with no detail message.
InstantiationException(String) - Constructor for exception java.lang.InstantiationException
Constructs an InstantiationException with the specified detail message.
Instrument - Class in javax.sound.midi
An instrument is a sound-synthesis algorithm with certain parameter settings, usually designed to emulate a specific real-world musical instrument or to achieve a specific sort of sound effect.
Instrument(Soundbank, Patch, String, Class<?>) - Constructor for class javax.sound.midi.Instrument
Constructs a new MIDI instrument from the specified Patch.
Instrumentation - Interface in java.lang.instrument
This class provides services needed to instrument Java programming language code.
InsufficientResourcesException - Exception in javax.naming
This exception is thrown when resources are not available to complete the requested operation.
InsufficientResourcesException(String) - Constructor for exception javax.naming.InsufficientResourcesException
Constructs a new instance of InsufficientResourcesException using an explanation.
InsufficientResourcesException() - Constructor for exception javax.naming.InsufficientResourcesException
Constructs a new instance of InsufficientResourcesException with all name resolution fields and explanation initialized to null.
insureRowContinuity() - Method in class javax.swing.tree.DefaultTreeSelectionModel
Makes sure the currently selected TreePaths are valid for the current selection mode.
insureUniqueness() - Method in class javax.swing.tree.DefaultTreeSelectionModel
This method is obsolete and its implementation is now a noop.
IntBinaryOperator - Interface in java.util.function
Represents an operation upon two int-valued operands and producing an int-valued result.
intBitsToFloat(int) - Static method in class java.lang.Float
Returns the float value corresponding to a given bit representation.
IntBuffer - Class in java.nio
An int buffer.
IntConsumer - Interface in java.util.function
Represents an operation that accepts a single int-valued argument and returns no result.
Integer - Class in java.lang
The Integer class wraps a value of the primitive type int in an object.
Integer(int) - Constructor for class java.lang.Integer
Constructs a newly allocated Integer object that represents the specified int value.
Integer(String) - Constructor for class java.lang.Integer
Constructs a newly allocated Integer object that represents the int value indicated by the String parameter.
INTEGER - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type INTEGER.
INTEGER - Static variable in class java.text.NumberFormat.Field
Constant identifying the integer field.
INTEGER - Static variable in class javax.management.openmbean.SimpleType
The SimpleType instance describing values whose Java class name is java.lang.Integer.
INTEGER_FIELD - Static variable in class java.text.NumberFormat
Field constant used to construct a FieldPosition object.
IntegerSyntax - Class in javax.print.attribute
Class IntegerSyntax is an abstract base class providing the common implementation of all attributes with integer values.
IntegerSyntax(int) - Constructor for class javax.print.attribute.IntegerSyntax
Construct a new integer attribute with the given integer value.
IntegerSyntax(int, int, int) - Constructor for class javax.print.attribute.IntegerSyntax
Construct a new integer attribute with the given integer value, which must lie within the given range.
Interceptor - Interface in org.omg.PortableInterceptor
All Portable Interceptors implement Interceptor.
InterceptorOperations - Interface in org.omg.PortableInterceptor
All Portable Interceptors implement Interceptor.
interestOps() - Method in class java.nio.channels.SelectionKey
Retrieves this key's interest set.
interestOps(int) - Method in class java.nio.channels.SelectionKey
Sets this key's interest set to the given value.
INTERFACE - Static variable in class java.lang.reflect.Modifier
The int value representing the interface modifier.
INTERFACE_CLASS_NAME_FIELD - Static variable in class javax.management.JMX
The name of the interfaceClassName field.
InterfaceAddress - Class in java.net
This class represents a Network Interface address.
interfaceModifiers() - Static method in class java.lang.reflect.Modifier
Return an int value OR-ing together the source language modifiers that can be applied to an interface.
interfaceName(QName) - Method in class javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder
Sets the interfaceName as the wsam:InterfaceName element in the wsa:Metadata element.
INTERLOCK_OPEN - Static variable in class javax.print.attribute.standard.PrinterStateReason
One or more interlock devices on the printer are unlocked.
intern() - Method in class java.lang.String
Returns a canonical representation for the string object.
INTERNAL - Exception in org.omg.CORBA
This exception indicates an internal failure in an ORB, for example, if an ORB has detected corruption of its internal data structures.
INTERNAL() - Constructor for exception org.omg.CORBA.INTERNAL
Constructs an INTERNAL exception with a default minor code of 0 and a completion state of COMPLETED_NO.
INTERNAL(String) - Constructor for exception org.omg.CORBA.INTERNAL
Constructs an INTERNAL exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
INTERNAL(int, CompletionStatus) - Constructor for exception org.omg.CORBA.INTERNAL
Constructs an INTERNAL exception with the specified minor code and completion status.
INTERNAL(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.INTERNAL
Constructs an INTERNAL exception with the specified detail message, minor code, and completion status.
INTERNAL_CLOCK - Static variable in class javax.sound.midi.Sequencer.SyncMode
A master synchronization mode that makes the sequencer get its timing information from its internal clock.
INTERNAL_FRAME - Static variable in class javax.accessibility.AccessibleRole
A frame-like object that is clipped by a desktop pane.
INTERNAL_FRAME - Static variable in class javax.swing.plaf.synth.Region
InternalFrame region.
INTERNAL_FRAME_ACTIVATED - Static variable in class javax.swing.event.InternalFrameEvent
The "window activated" event type.
INTERNAL_FRAME_CLOSED - Static variable in class javax.swing.event.InternalFrameEvent
The "window closed" event.
INTERNAL_FRAME_CLOSING - Static variable in class javax.swing.event.InternalFrameEvent
The "window is closing" event.
INTERNAL_FRAME_DEACTIVATED - Static variable in class javax.swing.event.InternalFrameEvent
The "window deactivated" event type.
INTERNAL_FRAME_DEICONIFIED - Static variable in class javax.swing.event.InternalFrameEvent
The "window deiconified" event type.
INTERNAL_FRAME_FIRST - Static variable in class javax.swing.event.InternalFrameEvent
The first number in the range of IDs used for internal frame events.
INTERNAL_FRAME_ICONIFIED - Static variable in class javax.swing.event.InternalFrameEvent
The "window iconified" event.
INTERNAL_FRAME_LAST - Static variable in class javax.swing.event.InternalFrameEvent
The last number in the range of IDs used for internal frame events.
INTERNAL_FRAME_OPENED - Static variable in class javax.swing.event.InternalFrameEvent
The "window opened" event.
INTERNAL_FRAME_TITLE_PANE - Static variable in class javax.swing.plaf.synth.Region
TitlePane of an InternalFrame.
internalEntityDecl(String, String) - Method in interface org.xml.sax.ext.DeclHandler
Report an internal entity declaration.
internalEntityDecl(String, String) - Method in class org.xml.sax.ext.DefaultHandler2
InternalError - Error in java.lang
Thrown to indicate some unexpected internal error has occurred in the Java Virtual Machine.
InternalError() - Constructor for error java.lang.InternalError
Constructs an InternalError with no detail message.
InternalError(String) - Constructor for error java.lang.InternalError
Constructs an InternalError with the specified detail message.
InternalError(String, Throwable) - Constructor for error java.lang.InternalError
Constructs an InternalError with the specified detail message and cause.
InternalError(Throwable) - Constructor for error java.lang.InternalError
Constructs an InternalError with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
internalFrameActivated(InternalFrameEvent) - Method in class javax.swing.event.InternalFrameAdapter
Invoked when an internal frame is activated.
internalFrameActivated(InternalFrameEvent) - Method in interface javax.swing.event.InternalFrameListener
Invoked when an internal frame is activated.
internalFrameActivated(InternalFrameEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener
InternalFrameAdapter - Class in javax.swing.event
An abstract adapter class for receiving internal frame events.
InternalFrameAdapter() - Constructor for class javax.swing.event.InternalFrameAdapter
InternalFrameBorder() - Constructor for class javax.swing.plaf.metal.MetalBorders.InternalFrameBorder
internalFrameClosed(InternalFrameEvent) - Method in class javax.swing.event.InternalFrameAdapter
Invoked when an internal frame has been closed.
internalFrameClosed(InternalFrameEvent) - Method in interface javax.swing.event.InternalFrameListener
Invoked when an internal frame has been closed.
internalFrameClosed(InternalFrameEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener
internalFrameClosing(InternalFrameEvent) - Method in class javax.swing.event.InternalFrameAdapter
Invoked when an internal frame is in the process of being closed.
internalFrameClosing(InternalFrameEvent) - Method in interface javax.swing.event.InternalFrameListener
Invoked when an internal frame is in the process of being closed.
internalFrameClosing(InternalFrameEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener
internalFrameDeactivated(InternalFrameEvent) - Method in class javax.swing.event.InternalFrameAdapter
Invoked when an internal frame is de-activated.
internalFrameDeactivated(InternalFrameEvent) - Method in interface javax.swing.event.InternalFrameListener
Invoked when an internal frame is de-activated.
internalFrameDeactivated(InternalFrameEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener
internalFrameDeiconified(InternalFrameEvent) - Method in class javax.swing.event.InternalFrameAdapter
Invoked when an internal frame is de-iconified.
internalFrameDeiconified(InternalFrameEvent) - Method in interface javax.swing.event.InternalFrameListener
Invoked when an internal frame is de-iconified.
internalFrameDeiconified(InternalFrameEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener
InternalFrameEvent - Class in javax.swing.event
An AWTEvent that adds support for JInternalFrame objects as the event source.
InternalFrameEvent(JInternalFrame, int) - Constructor for class javax.swing.event.InternalFrameEvent
Constructs an InternalFrameEvent object.
InternalFrameFocusTraversalPolicy - Class in javax.swing
A FocusTraversalPolicy which can optionally provide an algorithm for determining a JInternalFrame's initial Component.
InternalFrameFocusTraversalPolicy() - Constructor for class javax.swing.InternalFrameFocusTraversalPolicy
internalFrameIconified(InternalFrameEvent) - Method in class javax.swing.event.InternalFrameAdapter
Invoked when an internal frame is iconified.
internalFrameIconified(InternalFrameEvent) - Method in interface javax.swing.event.InternalFrameListener
Invoked when an internal frame is iconified.
internalFrameIconified(InternalFrameEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener
internalFrameLayout - Variable in class javax.swing.plaf.basic.BasicInternalFrameUI
InternalFrameLayout() - Constructor for class javax.swing.plaf.basic.BasicInternalFrameUI.InternalFrameLayout
InternalFrameListener - Interface in javax.swing.event
The listener interface for receiving internal frame events.
internalFrameOpened(InternalFrameEvent) - Method in class javax.swing.event.InternalFrameAdapter
Invoked when an internal frame has been opened.
internalFrameOpened(InternalFrameEvent) - Method in interface javax.swing.event.InternalFrameListener
Invoked when a internal frame has been opened.
internalFrameOpened(InternalFrameEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener
InternalFramePropertyChangeListener() - Constructor for class javax.swing.plaf.basic.BasicInternalFrameUI.InternalFramePropertyChangeListener
InternalFrameUI - Class in javax.swing.plaf
Pluggable look and feel interface for JInternalFrame.
InternalFrameUI() - Constructor for class javax.swing.plaf.InternalFrameUI
internalGet(int) - Method in class java.util.Calendar
Returns the value of the given calendar field.
InternationalFormatter - Class in javax.swing.text
InternationalFormatter extends DefaultFormatter, using an instance of java.text.Format to handle the conversion to a String, and the conversion from a String.
InternationalFormatter() - Constructor for class javax.swing.text.InternationalFormatter
Creates an InternationalFormatter with no Format specified.
InternationalFormatter(Format) - Constructor for class javax.swing.text.InternationalFormatter
Creates an InternationalFormatter with the specified Format instance.
INTERPRETER_RESOURCE_UNAVAILABLE - Static variable in class javax.print.attribute.standard.PrinterStateReason
An interpreter resource is unavailable (e.g., font, form).
interrupt() - Method in class java.lang.Thread
Interrupts this thread.
interrupt() - Method in class java.lang.ThreadGroup
Interrupts all threads in this thread group.
interrupted() - Static method in class java.lang.Thread
Tests whether the current thread has been interrupted.
InterruptedByTimeoutException - Exception in java.nio.channels
Checked exception received by a thread when a timeout elapses before an asynchronous operation completes.
InterruptedByTimeoutException() - Constructor for exception java.nio.channels.InterruptedByTimeoutException
Constructs an instance of this class.
InterruptedException - Exception in java.lang
Thrown when a thread is waiting, sleeping, or otherwise occupied, and the thread is interrupted, either before or during the activity.
InterruptedException() - Constructor for exception java.lang.InterruptedException
Constructs an InterruptedException with no detail message.
InterruptedException(String) - Constructor for exception java.lang.InterruptedException
Constructs an InterruptedException with the specified detail message.
InterruptedIOException - Exception in java.io
Signals that an I/O operation has been interrupted.
InterruptedIOException() - Constructor for exception java.io.InterruptedIOException
Constructs an InterruptedIOException with null as its error detail message.
InterruptedIOException(String) - Constructor for exception java.io.InterruptedIOException
Constructs an InterruptedIOException with the specified detail message.
InterruptedNamingException - Exception in javax.naming
This exception is thrown when the naming operation being invoked has been interrupted.
InterruptedNamingException(String) - Constructor for exception javax.naming.InterruptedNamingException
Constructs an instance of InterruptedNamingException using an explanation of the problem.
InterruptedNamingException() - Constructor for exception javax.naming.InterruptedNamingException
Constructs an instance of InterruptedNamingException with all name resolution fields and explanation initialized to null.
InterruptibleChannel - Interface in java.nio.channels
A channel that can be asynchronously closed and interrupted.
intersect(Area) - Method in class java.awt.geom.Area
Sets the shape of this Area to the intersection of its current shape and the shape of the specified Area.
intersect(Rectangle2D, Rectangle2D, Rectangle2D) - Static method in class java.awt.geom.Rectangle2D
Intersects the pair of specified source Rectangle2D objects and puts the result into the specified destination Rectangle2D object.
INTERSECT - Static variable in class javax.xml.crypto.dsig.spec.XPathType.Filter
The intersect filter operation.
intersection(Rectangle) - Method in class java.awt.Rectangle
Computes the intersection of this Rectangle with the specified Rectangle.
IntersectionType - Interface in javax.lang.model.type
Represents an intersection type.
intersects(double, double, double, double) - Method in class java.awt.geom.Arc2D
Determines whether or not the interior of the arc intersects the interior of the specified rectangle.
intersects(double, double, double, double) - Method in class java.awt.geom.Area
Tests if the interior of the Shape intersects the interior of a specified rectangular area.
intersects(Rectangle2D) - Method in class java.awt.geom.Area
Tests if the interior of the Shape intersects the interior of a specified Rectangle2D.
intersects(double, double, double, double) - Method in class java.awt.geom.CubicCurve2D
Tests if the interior of the Shape intersects the interior of a specified rectangular area.
intersects(Rectangle2D) - Method in class java.awt.geom.CubicCurve2D
Tests if the interior of the Shape intersects the interior of a specified Rectangle2D.
intersects(double, double, double, double) - Method in class java.awt.geom.Ellipse2D
Tests if the interior of the Shape intersects the interior of a specified rectangular area.
intersects(double, double, double, double) - Method in class java.awt.geom.Line2D
Tests if the interior of the Shape intersects the interior of a specified rectangular area.
intersects(Rectangle2D) - Method in class java.awt.geom.Line2D
Tests if the interior of the Shape intersects the interior of a specified Rectangle2D.
intersects(PathIterator, double, double, double, double) - Static method in class java.awt.geom.Path2D
Tests if the interior of the specified PathIterator intersects the interior of a specified set of rectangular coordinates.
intersects(PathIterator, Rectangle2D) - Static method in class java.awt.geom.Path2D
Tests if the interior of the specified PathIterator intersects the interior of a specified Rectangle2D.
intersects(double, double, double, double) - Method in class java.awt.geom.Path2D
Tests if the interior of the Shape intersects the interior of a specified rectangular area.
intersects(Rectangle2D) - Method in class java.awt.geom.Path2D
Tests if the interior of the Shape intersects the interior of a specified Rectangle2D.
intersects(double, double, double, double) - Method in class java.awt.geom.QuadCurve2D
Tests if the interior of the Shape intersects the interior of a specified rectangular area.
intersects(Rectangle2D) - Method in class java.awt.geom.QuadCurve2D
Tests if the interior of the Shape intersects the interior of a specified Rectangle2D.
intersects(double, double, double, double) - Method in class java.awt.geom.Rectangle2D
Tests if the interior of the Shape intersects the interior of a specified rectangular area.
intersects(Rectangle2D) - Method in class java.awt.geom.RectangularShape
Tests if the interior of the Shape intersects the interior of a specified Rectangle2D.
intersects(double, double, double, double) - Method in class java.awt.geom.RoundRectangle2D
Tests if the interior of the Shape intersects the interior of a specified rectangular area.
intersects(double, double, double, double) - Method in class java.awt.Polygon
Tests if the interior of the Shape intersects the interior of a specified rectangular area.
intersects(Rectangle2D) - Method in class java.awt.Polygon
Tests if the interior of the Shape intersects the interior of a specified Rectangle2D.
intersects(Rectangle) - Method in class java.awt.Rectangle
Determines whether or not this Rectangle and the specified Rectangle intersect.
intersects(double, double, double, double) - Method in interface java.awt.Shape
Tests if the interior of the Shape intersects the interior of a specified rectangular area.
intersects(Rectangle2D) - Method in interface java.awt.Shape
Tests if the interior of the Shape intersects the interior of a specified Rectangle2D.
intersects(BitSet) - Method in class java.util.BitSet
Returns true if the specified BitSet has any bits set to true that are also set to true in this BitSet.
intersectsLine(double, double, double, double) - Method in class java.awt.geom.Line2D
Tests if the line segment from (x1,y1) to (x2,y2) intersects this line segment.
intersectsLine(Line2D) - Method in class java.awt.geom.Line2D
Tests if the specified line segment intersects this line segment.
intersectsLine(double, double, double, double) - Method in class java.awt.geom.Rectangle2D
Tests if the specified line segment intersects the interior of this Rectangle2D.
intersectsLine(Line2D) - Method in class java.awt.geom.Rectangle2D
Tests if the specified line segment intersects the interior of this Rectangle2D.
INTERVAL_ADDED - Static variable in class javax.swing.event.ListDataEvent
Identifies the addition of one or more contiguous items to the list
INTERVAL_REMOVED - Static variable in class javax.swing.event.ListDataEvent
Identifies the removal of one or more contiguous items from the list
intervalAdded(ListDataEvent) - Method in interface javax.swing.event.ListDataListener
Sent after the indices in the index0,index1 interval have been inserted in the data model.
intervalAdded(ListDataEvent) - Method in class javax.swing.JComboBox
This method is public as an implementation side effect.
intervalAdded(ListDataEvent) - Method in class javax.swing.JList.AccessibleJList
List Data Listener interval added method.
intervalAdded(ListDataEvent) - Method in class javax.swing.plaf.basic.BasicComboBoxUI.ListDataHandler
intervalAdded(ListDataEvent) - Method in class javax.swing.plaf.basic.BasicComboPopup.ListDataHandler
intervalAdded(ListDataEvent) - Method in class javax.swing.plaf.basic.BasicDirectoryModel
Obsolete - not used.
intervalAdded(ListDataEvent) - Method in class javax.swing.plaf.basic.BasicListUI.ListDataHandler
intervalRemoved(ListDataEvent) - Method in interface javax.swing.event.ListDataListener
Sent after the indices in the index0,index1 interval have been removed from the data model.
intervalRemoved(ListDataEvent) - Method in class javax.swing.JComboBox
This method is public as an implementation side effect.
intervalRemoved(ListDataEvent) - Method in class javax.swing.JList.AccessibleJList
List Data Listener interval removed method.
intervalRemoved(ListDataEvent) - Method in class javax.swing.plaf.basic.BasicComboBoxUI.ListDataHandler
intervalRemoved(ListDataEvent) - Method in class javax.swing.plaf.basic.BasicComboPopup.ListDataHandler
intervalRemoved(ListDataEvent) - Method in class javax.swing.plaf.basic.BasicDirectoryModel
Obsolete - not used.
intervalRemoved(ListDataEvent) - Method in class javax.swing.plaf.basic.BasicListUI.ListDataHandler
INTF_REPOS - Exception in org.omg.CORBA
Exception raised when an ORB cannot reach the interface repository, or some other failure relating to the interface repository is detected.
INTF_REPOS() - Constructor for exception org.omg.CORBA.INTF_REPOS
Constructs an INTF_REPOS exception with a default minor code of 0 and a completion state of COMPLETED_NO.
INTF_REPOS(String) - Constructor for exception org.omg.CORBA.INTF_REPOS
Constructs an INTF_REPOS exception with the specified detail.
INTF_REPOS(int, CompletionStatus) - Constructor for exception org.omg.CORBA.INTF_REPOS
Constructs an INTF_REPOS exception with the specified minor code and completion status.
INTF_REPOS(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.INTF_REPOS
Constructs an INTF_REPOS exception with the specified detail message, minor code, and completion status.
IntFunction<R> - Interface in java.util.function
Represents a function that accepts an int-valued argument and produces a result.
IntHolder - Class in org.omg.CORBA
The Holder for Int.
IntHolder() - Constructor for class org.omg.CORBA.IntHolder
Constructs a new IntHolder object with its value field initialized to 0.
IntHolder(int) - Constructor for class org.omg.CORBA.IntHolder
Constructs a new IntHolder object with its value field initialized to the given int.
intKey() - Method in class java.awt.RenderingHints.Key
Returns the private integer key that the subclass instantiated this Key with.
IntPredicate - Interface in java.util.function
Represents a predicate (boolean-valued function) of one int-valued argument.
IntrospectionException - Exception in java.beans
Thrown when an exception happens during Introspection.
IntrospectionException(String) - Constructor for exception java.beans.IntrospectionException
Constructs an IntrospectionException with a detailed message.
IntrospectionException - Exception in javax.management
An exception occurred during the introspection of an MBean.
IntrospectionException() - Constructor for exception javax.management.IntrospectionException
Default constructor.
IntrospectionException(String) - Constructor for exception javax.management.IntrospectionException
Constructor that allows a specific error message to be specified.
Introspector - Class in java.beans
The Introspector class provides a standard way for tools to learn about the properties, events, and methods supported by a target Java Bean.
ints(long) - Method in class java.util.concurrent.ThreadLocalRandom
Returns a stream producing the given streamSize number of pseudorandom int values.
ints() - Method in class java.util.concurrent.ThreadLocalRandom
Returns an effectively unlimited stream of pseudorandom int values.
ints(long, int, int) - Method in class java.util.concurrent.ThreadLocalRandom
Returns a stream producing the given streamSize number of pseudorandom int values, each conforming to the given origin (inclusive) and bound (exclusive).
ints(int, int) - Method in class java.util.concurrent.ThreadLocalRandom
Returns an effectively unlimited stream of pseudorandom int values, each conforming to the given origin (inclusive) and bound (exclusive).
ints(long) - Method in class java.util.Random
Returns a stream producing the given streamSize number of pseudorandom int values.
ints() - Method in class java.util.Random
Returns an effectively unlimited stream of pseudorandom int values.
ints(long, int, int) - Method in class java.util.Random
Returns a stream producing the given streamSize number of pseudorandom int values, each conforming to the given origin (inclusive) and bound (exclusive).
ints(int, int) - Method in class java.util.Random
Returns an effectively unlimited stream of pseudorandom int values, each conforming to the given origin (inclusive) and bound (exclusive).
ints(long) - Method in class java.util.SplittableRandom
Returns a stream producing the given streamSize number of pseudorandom int values from this generator and/or one split from it.
ints() - Method in class java.util.SplittableRandom
Returns an effectively unlimited stream of pseudorandom int values from this generator and/or one split from it.
ints(long, int, int) - Method in class java.util.SplittableRandom
Returns a stream producing the given streamSize number of pseudorandom int values from this generator and/or one split from it; each value conforms to the given origin (inclusive) and bound (exclusive).
ints(int, int) - Method in class java.util.SplittableRandom
Returns an effectively unlimited stream of pseudorandom int values from this generator and/or one split from it; each value conforms to the given origin (inclusive) and bound (exclusive).
IntStream - Interface in java.util.stream
A sequence of primitive int-valued elements supporting sequential and parallel aggregate operations.
intStream(Spliterator.OfInt, boolean) - Static method in class java.util.stream.StreamSupport
Creates a new sequential or parallel IntStream from a Spliterator.OfInt.
intStream(Supplier<? extends Spliterator.OfInt>, int, boolean) - Static method in class java.util.stream.StreamSupport
Creates a new sequential or parallel IntStream from a Supplier of Spliterator.OfInt.
IntStream.Builder - Interface in java.util.stream
A mutable builder for an IntStream.
IntSummaryStatistics - Class in java.util
A state object for collecting statistics such as count, min, max, sum, and average.
IntSummaryStatistics() - Constructor for class java.util.IntSummaryStatistics
Construct an empty instance with zero count, zero sum, Integer.MAX_VALUE min, Integer.MIN_VALUE max and zero average.
IntSupplier - Interface in java.util.function
Represents a supplier of int-valued results.
IntToDoubleFunction - Interface in java.util.function
Represents a function that accepts an int-valued argument and produces a double-valued result.
IntToLongFunction - Interface in java.util.function
Represents a function that accepts an int-valued argument and produces a long-valued result.
IntUnaryOperator - Interface in java.util.function
Represents an operation on a single int-valued operand that produces an int-valued result.
intValue() - Method in class java.lang.Byte
Returns the value of this Byte as an int after a widening primitive conversion.
intValue() - Method in class java.lang.Double
Returns the value of this Double as an int after a narrowing primitive conversion.
intValue() - Method in class java.lang.Float
Returns the value of this Float as an int after a narrowing primitive conversion.
intValue() - Method in class java.lang.Integer
Returns the value of this Integer as an int.
intValue() - Method in class java.lang.Long
Returns the value of this Long as an int after a narrowing primitive conversion.
intValue() - Method in class java.lang.Number
Returns the value of the specified number as an int, which may involve rounding or truncation.
intValue() - Method in class java.lang.Short
Returns the value of this Short as an int after a widening primitive conversion.
intValue() - Method in class java.math.BigDecimal
Converts this BigDecimal to an int.
intValue() - Method in class java.math.BigInteger
Converts this BigInteger to an int.
intValue() - Method in class java.util.concurrent.atomic.AtomicInteger
Returns the value of this AtomicInteger as an int.
intValue() - Method in class java.util.concurrent.atomic.AtomicLong
Returns the value of this AtomicLong as an int after a narrowing primitive conversion.
intValue() - Method in class java.util.concurrent.atomic.DoubleAccumulator
Returns the current value as an int after a narrowing primitive conversion.
intValue() - Method in class java.util.concurrent.atomic.DoubleAdder
Returns the DoubleAdder.sum() as an int after a narrowing primitive conversion.
intValue() - Method in class java.util.concurrent.atomic.LongAccumulator
Returns the current value as an int after a narrowing primitive conversion.
intValue() - Method in class java.util.concurrent.atomic.LongAdder
Returns the LongAdder.sum() as an int after a narrowing primitive conversion.
intValue() - Method in class java.util.logging.Level
Get the integer value for this level.
intValueExact() - Method in class java.math.BigDecimal
Converts this BigDecimal to an int, checking for lost information.
intValueExact() - Method in class java.math.BigInteger
Converts this BigInteger to an int, checking for lost information.
INUSE_ATTRIBUTE_ERR - Static variable in exception org.w3c.dom.DOMException
If an attempt is made to add an attribute that is already in use elsewhere.
INV_FLAG - Exception in org.omg.CORBA
Exception thrown when an invalid flag was passed to an operation (for example, when creating a DII request).
INV_FLAG() - Constructor for exception org.omg.CORBA.INV_FLAG
Constructs an INV_FLAG exception with a default minor code of 0 and a completion state of COMPLETED_NO.
INV_FLAG(String) - Constructor for exception org.omg.CORBA.INV_FLAG
Constructs an INV_FLAG exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
INV_FLAG(int, CompletionStatus) - Constructor for exception org.omg.CORBA.INV_FLAG
Constructs an INV_FLAG exception with the specified minor code and completion status.
INV_FLAG(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.INV_FLAG
Constructs an INV_FLAG exception with the specified detail message, minor code, and completion status.
INV_IDENT - Exception in org.omg.CORBA
This exception indicates that an IDL identifier is syntactically invalid.
INV_IDENT() - Constructor for exception org.omg.CORBA.INV_IDENT
Constructs an INV_IDENT exception with a default minor code of 0 and a completion state of COMPLETED_NO.
INV_IDENT(String) - Constructor for exception org.omg.CORBA.INV_IDENT
Constructs an INV_IDENT exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
INV_IDENT(int, CompletionStatus) - Constructor for exception org.omg.CORBA.INV_IDENT
Constructs an INV_IDENT exception with the specified minor code and completion status.
INV_IDENT(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.INV_IDENT
Constructs an INV_IDENT exception with the specified detail message, minor code, and completion status.
INV_OBJREF - Exception in org.omg.CORBA
This exception indicates that an object reference is internally malformed.
INV_OBJREF() - Constructor for exception org.omg.CORBA.INV_OBJREF
Constructs an INV_OBJREF exception with a default minor code of 0 and a completion state of COMPLETED_NO.
INV_OBJREF(String) - Constructor for exception org.omg.CORBA.INV_OBJREF
Constructs an INV_OBJREF exception with the specified detail message, a minor code of 0, and a completion state of COMPLETED_NO.
INV_OBJREF(int, CompletionStatus) - Constructor for exception org.omg.CORBA.INV_OBJREF
Constructs an INV_OBJREF exception with the specified minor code and completion status.
INV_OBJREF(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.INV_OBJREF
Constructs an INV_OBJREF exception with the specified detail message, minor code, and completion status.
INV_POLICY - Exception in org.omg.CORBA
Standard exception thrown when an invocation cannot be made because of an incompatibility between Policy overrides that apply to the particular invocation.
INV_POLICY() - Constructor for exception org.omg.CORBA.INV_POLICY
Constructs a INV_POLICY exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
INV_POLICY(String) - Constructor for exception org.omg.CORBA.INV_POLICY
Constructs a INV_POLICY exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
INV_POLICY(int, CompletionStatus) - Constructor for exception org.omg.CORBA.INV_POLICY
Constructs a INV_POLICY exception with the specified minor code and completion status.
INV_POLICY(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.INV_POLICY
Constructs a INV_POLICY exception with the specified description message, minor code, and completion status.
Invalid - Exception in org.omg.CORBA.DynAnyPackage
Invalid is thrown by dynamic any operations when a bad DynAny or Any is passed as a parameter.
Invalid() - Constructor for exception org.omg.CORBA.DynAnyPackage.Invalid
Constructs an Invalid object.
Invalid(String) - Constructor for exception org.omg.CORBA.DynAnyPackage.Invalid
Constructs an Invalid object.
INVALID_ACCESS_ERR - Static variable in exception org.w3c.dom.DOMException
If a parameter or an operation is not supported by the underlying object.
INVALID_ACTIVITY - Exception in org.omg.CORBA
The INVALID_ACTIVITY system exception may be raised on the Activity or Transaction services' resume methods if a transaction or Activity is resumed in a context different to that from which it was suspended.
INVALID_ACTIVITY() - Constructor for exception org.omg.CORBA.INVALID_ACTIVITY
Constructs an INVALID_ACTIVITY exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.
INVALID_ACTIVITY(String) - Constructor for exception org.omg.CORBA.INVALID_ACTIVITY
Constructs an INVALID_ACTIVITY exception with the specified message.
INVALID_ACTIVITY(int, CompletionStatus) - Constructor for exception org.omg.CORBA.INVALID_ACTIVITY
Constructs an INVALID_ACTIVITY exception with the specified minor code and completion status.
INVALID_ACTIVITY(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.INVALID_ACTIVITY
Constructs an INVALID_ACTIVITY exception with the specified message, minor code, and completion status.
INVALID_CHARACTER_ERR - Static variable in exception org.w3c.dom.DOMException
If an invalid or illegal character is specified, such as in an XML name.
INVALID_MODIFICATION_ERR - Static variable in exception org.w3c.dom.DOMException
If an attempt is made to modify the type of the underlying object.
INVALID_STATE_ERR - Static variable in exception org.w3c.dom.DOMException
If an attempt is made to use an object that is not, or is no longer, usable.
INVALID_TRANSACTION - Exception in org.omg.CORBA
Exception thrown when the request carried an invalid transaction context.
INVALID_TRANSACTION() - Constructor for exception org.omg.CORBA.INVALID_TRANSACTION
Constructs an INVALID_TRANSACTION exception with a default minor code of 0 and a completion state of COMPLETED_NO.
INVALID_TRANSACTION(String) - Constructor for exception org.omg.CORBA.INVALID_TRANSACTION
Constructs an INVALID_TRANSACTION exception with the specified detail message.
INVALID_TRANSACTION(int, CompletionStatus) - Constructor for exception org.omg.CORBA.INVALID_TRANSACTION
Constructs an INVALID_TRANSACTION exception with the specified minor code and completion status.
INVALID_TRANSACTION(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.INVALID_TRANSACTION
Constructs an INVALID_TRANSACTION exception with the specified detail message, minor code, and completion status.
InvalidActivityException - Exception in javax.activity
This exception may be thrown on any method for which Activity context is accessed and indicates that the attempted invocation or the Activity context associated with the attempted invocation is incompatible with the Activity's current state.
InvalidActivityException() - Constructor for exception javax.activity.InvalidActivityException
Constructs a new instance with null as its detail message.
InvalidActivityException(String) - Constructor for exception javax.activity.InvalidActivityException
Constructs a new instance with the specified detail message.
InvalidActivityException(Throwable) - Constructor for exception javax.activity.InvalidActivityException
Constructs a new throwable with the specified cause.
InvalidActivityException(String, Throwable) - Constructor for exception javax.activity.InvalidActivityException
Constructs a new throwable with the specified detail message and cause.
InvalidAddress - Exception in org.omg.CosNaming.NamingContextExtPackage
org/omg/CosNaming/NamingContextExtPackage/InvalidAddress.java .
InvalidAddress() - Constructor for exception org.omg.CosNaming.NamingContextExtPackage.InvalidAddress
InvalidAddress(String) - Constructor for exception org.omg.CosNaming.NamingContextExtPackage.InvalidAddress
InvalidAddressHelper - Class in org.omg.CosNaming.NamingContextExtPackage
org/omg/CosNaming/NamingContextExtPackage/InvalidAddressHelper.java .
InvalidAddressHelper() - Constructor for class org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper
InvalidAddressHolder - Class in org.omg.CosNaming.NamingContextExtPackage
org/omg/CosNaming/NamingContextExtPackage/InvalidAddressHolder.java .
InvalidAddressHolder() - Constructor for class org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder
InvalidAddressHolder(InvalidAddress) - Constructor for class org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder
InvalidAlgorithmParameterException - Exception in java.security
This is the exception for invalid or inappropriate algorithm parameters.
InvalidAlgorithmParameterException() - Constructor for exception java.security.InvalidAlgorithmParameterException
Constructs an InvalidAlgorithmParameterException with no detail message.
InvalidAlgorithmParameterException(String) - Constructor for exception java.security.InvalidAlgorithmParameterException
Constructs an InvalidAlgorithmParameterException with the specified detail message.
InvalidAlgorithmParameterException(String, Throwable) - Constructor for exception java.security.InvalidAlgorithmParameterException
Creates a InvalidAlgorithmParameterException with the specified detail message and cause.
InvalidAlgorithmParameterException(Throwable) - Constructor for exception java.security.InvalidAlgorithmParameterException
Creates a InvalidAlgorithmParameterException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
InvalidApplicationException - Exception in javax.management
Thrown when an attempt is made to apply either of the following: A subquery expression to an MBean or a qualified attribute expression to an MBean of the wrong class.
InvalidApplicationException(Object) - Constructor for exception javax.management.InvalidApplicationException
Constructs an InvalidApplicationException with the specified Object.
invalidate() - Method in class java.awt.Component
Invalidates this component and its ancestors.
invalidate() - Method in class java.awt.Container
Invalidates the container.
invalidate() - Method in class java.awt.Polygon
Invalidates or flushes any internally-cached data that depends on the vertex coordinates of this Polygon.
invalidate() - Method in interface javax.net.ssl.SSLSession
Invalidates the session.
invalidate() - Method in class javax.swing.CellRendererPane
Overridden to avoid propagating a invalidate up the tree when the cell renderer child is configured.
invalidate() - Method in class javax.swing.DefaultListCellRenderer
Overridden for performance reasons.
invalidate() - Method in class javax.swing.table.DefaultTableCellRenderer
Overridden for performance reasons.
invalidate() - Method in class javax.swing.tree.DefaultTreeCellRenderer
Overridden for performance reasons.
invalidateAll(SwitchPoint[]) - Static method in class java.lang.invoke.SwitchPoint
Sets all of the given switch points into the invalid state.
invalidateFileCache() - Method in class javax.swing.plaf.basic.BasicDirectoryModel
This method is used to interrupt file loading thread.
invalidateLayout(Container) - Method in class java.awt.BorderLayout
Invalidates the layout, indicating that if the layout manager has cached information it should be discarded.
invalidateLayout(Container) - Method in class java.awt.CardLayout
Invalidates the layout, indicating that if the layout manager has cached information it should be discarded.
invalidateLayout(Container) - Method in class java.awt.GridBagLayout
Invalidates the layout, indicating that if the layout manager has cached information it should be discarded.
invalidateLayout(Container) - Method in interface java.awt.LayoutManager2
Invalidates the layout, indicating that if the layout manager has cached information it should be discarded.
invalidateLayout(Container) - Method in class javax.swing.BoxLayout
Indicates that a child has changed its layout related information, and thus any cached calculations should be flushed.
invalidateLayout(Container) - Method in class javax.swing.GroupLayout
Invalidates the layout, indicating that if the layout manager has cached information it should be discarded.
invalidateLayout(Container) - Method in class javax.swing.JRootPane.RootLayout
invalidateLayout(Container) - Method in class javax.swing.OverlayLayout
Indicates a child has changed its layout related information, which causes any cached calculations to be flushed.
invalidateLayout(Container) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager
Does nothing.
invalidateLayout(Container) - Method in class javax.swing.SpringLayout
invalidatePathBounds(TreePath) - Method in class javax.swing.tree.AbstractLayoutCache
Instructs the LayoutCache that the bounds for path are invalid, and need to be updated.
invalidatePathBounds(TreePath) - Method in class javax.swing.tree.FixedHeightLayoutCache
Does nothing, FixedHeightLayoutCache doesn't cache width, and that is all that could change.
invalidatePathBounds(TreePath) - Method in class javax.swing.tree.VariableHeightLayoutCache
Instructs the LayoutCache that the bounds for path are invalid, and need to be updated.
invalidateSizes() - Method in class javax.swing.tree.AbstractLayoutCache
Informs the TreeState that it needs to recalculate all the sizes it is referencing.
invalidateSizes() - Method in class javax.swing.tree.FixedHeightLayoutCache
Informs the TreeState that it needs to recalculate all the sizes it is referencing.
invalidateSizes() - Method in class javax.swing.tree.VariableHeightLayoutCache
Informs the TreeState that it needs to recalculate all the sizes it is referencing.
InvalidAttributeIdentifierException - Exception in javax.naming.directory
This exception is thrown when an attempt is made to add to create an attribute with an invalid attribute identifier.
InvalidAttributeIdentifierException(String) - Constructor for exception javax.naming.directory.InvalidAttributeIdentifierException
Constructs a new instance of InvalidAttributeIdentifierException using the explanation supplied.
InvalidAttributeIdentifierException() - Constructor for exception javax.naming.directory.InvalidAttributeIdentifierException
Constructs a new instance of InvalidAttributeIdentifierException.
InvalidAttributesException - Exception in javax.naming.directory
This exception is thrown when an attempt is made to add or modify an attribute set that has been specified incompletely or incorrectly.
InvalidAttributesException(String) - Constructor for exception javax.naming.directory.InvalidAttributesException
Constructs a new instance of InvalidAttributesException using an explanation.
InvalidAttributesException() - Constructor for exception javax.naming.directory.InvalidAttributesException
Constructs a new instance of InvalidAttributesException.
InvalidAttributeValueException - Exception in javax.management
The value specified is not valid for the attribute.
InvalidAttributeValueException() - Constructor for exception javax.management.InvalidAttributeValueException
Default constructor.
InvalidAttributeValueException(String) - Constructor for exception javax.management.InvalidAttributeValueException
Constructor that allows a specific error message to be specified.
InvalidAttributeValueException - Exception in javax.naming.directory
This class is thrown when an attempt is made to add to an attribute a value that conflicts with the attribute's schema definition.
InvalidAttributeValueException(String) - Constructor for exception javax.naming.directory.InvalidAttributeValueException
Constructs a new instance of InvalidAttributeValueException using an explanation.
InvalidAttributeValueException() - Constructor for exception javax.naming.directory.InvalidAttributeValueException
Constructs a new instance of InvalidAttributeValueException.
InvalidClassException - Exception in java.io
Thrown when the Serialization runtime detects one of the following problems with a Class.
InvalidClassException(String) - Constructor for exception java.io.InvalidClassException
Report an InvalidClassException for the reason specified.
InvalidClassException(String, String) - Constructor for exception java.io.InvalidClassException
Constructs an InvalidClassException object.
InvalidDnDOperationException - Exception in java.awt.dnd
This exception is thrown by various methods in the java.awt.dnd package.
InvalidDnDOperationException() - Constructor for exception java.awt.dnd.InvalidDnDOperationException
Create a default Exception
InvalidDnDOperationException(String) - Constructor for exception java.awt.dnd.InvalidDnDOperationException
Create an Exception with its own descriptive message
invalidEdit() - Method in class javax.swing.JFormattedTextField.AbstractFormatter
This should be invoked when the user types an invalid character.
invalidEdit() - Method in class javax.swing.JFormattedTextField
Invoked when the user inputs an invalid value.
InvalidKeyException - Exception in java.security
This is the exception for invalid Keys (invalid encoding, wrong length, uninitialized, etc).
InvalidKeyException() - Constructor for exception java.security.InvalidKeyException
Constructs an InvalidKeyException with no detail message.
InvalidKeyException(String) - Constructor for exception java.security.InvalidKeyException
Constructs an InvalidKeyException with the specified detail message.
InvalidKeyException(String, Throwable) - Constructor for exception java.security.InvalidKeyException
Creates a InvalidKeyException with the specified detail message and cause.
InvalidKeyException(Throwable) - Constructor for exception java.security.InvalidKeyException
Creates a InvalidKeyException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
InvalidKeyException - Exception in javax.management.openmbean
This runtime exception is thrown to indicate that a method parameter which was expected to be an item name of a composite data or a row index of a tabular data is not valid.
InvalidKeyException() - Constructor for exception javax.management.openmbean.InvalidKeyException
An InvalidKeyException with no detail message.
InvalidKeyException(String) - Constructor for exception javax.management.openmbean.InvalidKeyException
An InvalidKeyException with a detail message.
InvalidKeySpecException - Exception in java.security.spec
This is the exception for invalid key specifications.
InvalidKeySpecException() - Constructor for exception java.security.spec.InvalidKeySpecException
Constructs an InvalidKeySpecException with no detail message.
InvalidKeySpecException(String) - Constructor for exception java.security.spec.InvalidKeySpecException
Constructs an InvalidKeySpecException with the specified detail message.
InvalidKeySpecException(String, Throwable) - Constructor for exception java.security.spec.InvalidKeySpecException
Creates a InvalidKeySpecException with the specified detail message and cause.
InvalidKeySpecException(Throwable) - Constructor for exception java.security.spec.InvalidKeySpecException
Creates a InvalidKeySpecException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
InvalidMarkException - Exception in java.nio
Unchecked exception thrown when an attempt is made to reset a buffer when its mark is not defined.
InvalidMarkException() - Constructor for exception java.nio.InvalidMarkException
Constructs an instance of this class.
InvalidMidiDataException - Exception in javax.sound.midi
An InvalidMidiDataException indicates that inappropriate MIDI data was encountered.
InvalidMidiDataException() - Constructor for exception javax.sound.midi.InvalidMidiDataException
Constructs an InvalidMidiDataException with null for its error detail message.
InvalidMidiDataException(String) - Constructor for exception javax.sound.midi.InvalidMidiDataException
Constructs an InvalidMidiDataException with the specified detail message.
InvalidName - Exception in org.omg.CORBA.ORBPackage
The InvalidName exception is raised when ORB.resolve_initial_references is passed a name for which there is no initial reference.
InvalidName() - Constructor for exception org.omg.CORBA.ORBPackage.InvalidName
Constructs an InvalidName exception with no reason message.
InvalidName(String) - Constructor for exception org.omg.CORBA.ORBPackage.InvalidName
Constructs an InvalidName exception with the specified reason message.
InvalidName - Exception in org.omg.CosNaming.NamingContextPackage
org/omg/CosNaming/NamingContextPackage/InvalidName.java .
InvalidName() - Constructor for exception org.omg.CosNaming.NamingContextPackage.InvalidName
InvalidName(String) - Constructor for exception org.omg.CosNaming.NamingContextPackage.InvalidName
InvalidName - Exception in org.omg.PortableInterceptor.ORBInitInfoPackage
org/omg/PortableInterceptor/ORBInitInfoPackage/InvalidName.java .
InvalidName() - Constructor for exception org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidName
InvalidName(String) - Constructor for exception org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidName
InvalidNameException - Exception in javax.naming
This exception indicates that the name being specified does not conform to the naming syntax of a naming system.
InvalidNameException(String) - Constructor for exception javax.naming.InvalidNameException
Constructs an instance of InvalidNameException using an explanation of the problem.
InvalidNameException() - Constructor for exception javax.naming.InvalidNameException
Constructs an instance of InvalidNameException with all fields set to null.
InvalidNameHelper - Class in org.omg.CosNaming.NamingContextPackage
org/omg/CosNaming/NamingContextPackage/InvalidNameHelper.java .
InvalidNameHelper() - Constructor for class org.omg.CosNaming.NamingContextPackage.InvalidNameHelper
InvalidNameHelper - Class in org.omg.PortableInterceptor.ORBInitInfoPackage
org/omg/PortableInterceptor/ORBInitInfoPackage/InvalidNameHelper.java .
InvalidNameHelper() - Constructor for class org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper
InvalidNameHolder - Class in org.omg.CosNaming.NamingContextPackage
org/omg/CosNaming/NamingContextPackage/InvalidNameHolder.java .
InvalidNameHolder() - Constructor for class org.omg.CosNaming.NamingContextPackage.InvalidNameHolder
InvalidNameHolder(InvalidName) - Constructor for class org.omg.CosNaming.NamingContextPackage.InvalidNameHolder
InvalidObjectException - Exception in java.io
Indicates that one or more deserialized objects failed validation tests.
InvalidObjectException(String) - Constructor for exception java.io.InvalidObjectException
Constructs an InvalidObjectException.
InvalidOpenTypeException - Exception in javax.management.openmbean
This runtime exception is thrown to indicate that the open type of an open data value is not the one expected.
InvalidOpenTypeException() - Constructor for exception javax.management.openmbean.InvalidOpenTypeException
An InvalidOpenTypeException with no detail message.
InvalidOpenTypeException(String) - Constructor for exception javax.management.openmbean.InvalidOpenTypeException
An InvalidOpenTypeException with a detail message.
InvalidParameterException - Exception in java.security
This exception, designed for use by the JCA/JCE engine classes, is thrown when an invalid parameter is passed to a method.
InvalidParameterException() - Constructor for exception java.security.InvalidParameterException
Constructs an InvalidParameterException with no detail message.
InvalidParameterException(String) - Constructor for exception java.security.InvalidParameterException
Constructs an InvalidParameterException with the specified detail message.
InvalidParameterSpecException - Exception in java.security.spec
This is the exception for invalid parameter specifications.
InvalidParameterSpecException() - Constructor for exception java.security.spec.InvalidParameterSpecException
Constructs an InvalidParameterSpecException with no detail message.
InvalidParameterSpecException(String) - Constructor for exception java.security.spec.InvalidParameterSpecException
Constructs an InvalidParameterSpecException with the specified detail message.
InvalidPathException - Exception in java.nio.file
Unchecked exception thrown when path string cannot be converted into a Path because the path string contains invalid characters, or the path string is invalid for other file system specific reasons.
InvalidPathException(String, String, int) - Constructor for exception java.nio.file.InvalidPathException
Constructs an instance from the given input string, reason, and error index.
InvalidPathException(String, String) - Constructor for exception java.nio.file.InvalidPathException
Constructs an instance from the given input string and reason.
InvalidPolicy - Exception in org.omg.PortableServer.POAPackage
org/omg/PortableServer/POAPackage/InvalidPolicy.java .
InvalidPolicy() - Constructor for exception org.omg.PortableServer.POAPackage.InvalidPolicy
InvalidPolicy(short) - Constructor for exception org.omg.PortableServer.POAPackage.InvalidPolicy
InvalidPolicy(String, short) - Constructor for exception org.omg.PortableServer.POAPackage.InvalidPolicy
InvalidPolicyHelper - Class in org.omg.PortableServer.POAPackage
org/omg/PortableServer/POAPackage/InvalidPolicyHelper.java .
InvalidPolicyHelper() - Constructor for class org.omg.PortableServer.POAPackage.InvalidPolicyHelper
InvalidPreferencesFormatException - Exception in java.util.prefs
Thrown to indicate that an operation could not complete because the input did not conform to the appropriate XML document type for a collection of preferences, as per the Preferences specification.
InvalidPreferencesFormatException(Throwable) - Constructor for exception java.util.prefs.InvalidPreferencesFormatException
Constructs an InvalidPreferencesFormatException with the specified cause.
InvalidPreferencesFormatException(String) - Constructor for exception java.util.prefs.InvalidPreferencesFormatException
Constructs an InvalidPreferencesFormatException with the specified detail message.
InvalidPreferencesFormatException(String, Throwable) - Constructor for exception java.util.prefs.InvalidPreferencesFormatException
Constructs an InvalidPreferencesFormatException with the specified detail message and cause.
InvalidPropertiesFormatException - Exception in java.util
Thrown to indicate that an operation could not complete because the input did not conform to the appropriate XML document type for a collection of properties, as per the Properties specification.
InvalidPropertiesFormatException(Throwable) - Constructor for exception java.util.InvalidPropertiesFormatException
Constructs an InvalidPropertiesFormatException with the specified cause.
InvalidPropertiesFormatException(String) - Constructor for exception java.util.InvalidPropertiesFormatException
Constructs an InvalidPropertiesFormatException with the specified detail message.
InvalidRelationIdException - Exception in javax.management.relation
This exception is raised when relation id provided for a relation is already used.
InvalidRelationIdException() - Constructor for exception javax.management.relation.InvalidRelationIdException
Default constructor, no message put in exception.
InvalidRelationIdException(String) - Constructor for exception javax.management.relation.InvalidRelationIdException
Constructor with given message put in exception.
InvalidRelationServiceException - Exception in javax.management.relation
This exception is raised when an invalid Relation Service is provided.
InvalidRelationServiceException() - Constructor for exception javax.management.relation.InvalidRelationServiceException
Default constructor, no message put in exception.
InvalidRelationServiceException(String) - Constructor for exception javax.management.relation.InvalidRelationServiceException
Constructor with given message put in exception.
InvalidRelationTypeException - Exception in javax.management.relation
Invalid relation type.
InvalidRelationTypeException() - Constructor for exception javax.management.relation.InvalidRelationTypeException
Default constructor, no message put in exception.
InvalidRelationTypeException(String) - Constructor for exception javax.management.relation.InvalidRelationTypeException
Constructor with given message put in exception.
InvalidRoleInfoException - Exception in javax.management.relation
This exception is raised when, in a role info, its minimum degree is greater than its maximum degree.
InvalidRoleInfoException() - Constructor for exception javax.management.relation.InvalidRoleInfoException
Default constructor, no message put in exception.
InvalidRoleInfoException(String) - Constructor for exception javax.management.relation.InvalidRoleInfoException
Constructor with given message put in exception.
InvalidRoleValueException - Exception in javax.management.relation
Role value is invalid.
InvalidRoleValueException() - Constructor for exception javax.management.relation.InvalidRoleValueException
Default constructor, no message put in exception.
InvalidRoleValueException(String) - Constructor for exception javax.management.relation.InvalidRoleValueException
Constructor with given message put in exception.
InvalidSearchControlsException - Exception in javax.naming.directory
This exception is thrown when the specification of the SearchControls for a search operation is invalid.
InvalidSearchControlsException() - Constructor for exception javax.naming.directory.InvalidSearchControlsException
Constructs a new instance of InvalidSearchControlsException.
InvalidSearchControlsException(String) - Constructor for exception javax.naming.directory.InvalidSearchControlsException
Constructs a new instance of InvalidSearchControlsException with an explanation.
InvalidSearchFilterException - Exception in javax.naming.directory
This exception is thrown when the specification of a search filter is invalid.
InvalidSearchFilterException() - Constructor for exception javax.naming.directory.InvalidSearchFilterException
Constructs a new instance of InvalidSearchFilterException.
InvalidSearchFilterException(String) - Constructor for exception javax.naming.directory.InvalidSearchFilterException
Constructs a new instance of InvalidSearchFilterException with an explanation.
InvalidSeq - Exception in org.omg.CORBA.DynAnyPackage
The InvalidSeq exception is thrown by all operations on dynamic anys that take a sequence (Java array) as an argument, when that sequence is invalid.
InvalidSeq() - Constructor for exception org.omg.CORBA.DynAnyPackage.InvalidSeq
Constructs an InvalidSeq object.
InvalidSeq(String) - Constructor for exception org.omg.CORBA.DynAnyPackage.InvalidSeq
Constructs an InvalidSeq object.
InvalidSlot - Exception in org.omg.PortableInterceptor
org/omg/PortableInterceptor/InvalidSlot.java .
InvalidSlot() - Constructor for exception org.omg.PortableInterceptor.InvalidSlot
InvalidSlot(String) - Constructor for exception org.omg.PortableInterceptor.InvalidSlot
InvalidSlotHelper - Class in org.omg.PortableInterceptor
org/omg/PortableInterceptor/InvalidSlotHelper.java .
InvalidSlotHelper() - Constructor for class org.omg.PortableInterceptor.InvalidSlotHelper
InvalidTargetObjectTypeException - Exception in javax.management.modelmbean
Exception thrown when an invalid target object type is specified.
InvalidTargetObjectTypeException() - Constructor for exception javax.management.modelmbean.InvalidTargetObjectTypeException
Default constructor.
InvalidTargetObjectTypeException(String) - Constructor for exception javax.management.modelmbean.InvalidTargetObjectTypeException
Constructor from a string.
InvalidTargetObjectTypeException(Exception, String) - Constructor for exception javax.management.modelmbean.InvalidTargetObjectTypeException
Constructor taking an exception and a string.
InvalidTransactionException - Exception in javax.transaction
This exception indicates that the request carried an invalid transaction context.
InvalidTransactionException() - Constructor for exception javax.transaction.InvalidTransactionException
InvalidTransactionException(String) - Constructor for exception javax.transaction.InvalidTransactionException
InvalidTypeForEncoding - Exception in org.omg.IOP.CodecPackage
org/omg/IOP/CodecPackage/InvalidTypeForEncoding.java .
InvalidTypeForEncoding() - Constructor for exception org.omg.IOP.CodecPackage.InvalidTypeForEncoding
InvalidTypeForEncoding(String) - Constructor for exception org.omg.IOP.CodecPackage.InvalidTypeForEncoding
InvalidTypeForEncodingHelper - Class in org.omg.IOP.CodecPackage
org/omg/IOP/CodecPackage/InvalidTypeForEncodingHelper.java .
InvalidTypeForEncodingHelper() - Constructor for class org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper
InvalidValue - Exception in org.omg.CORBA.DynAnyPackage
InvalidValue() - Constructor for exception org.omg.CORBA.DynAnyPackage.InvalidValue
Constructs an InvalidValue object.
InvalidValue(String) - Constructor for exception org.omg.CORBA.DynAnyPackage.InvalidValue
Constructs an InvalidValue object.
InvalidValue - Exception in org.omg.DynamicAny.DynAnyPackage
org/omg/DynamicAny/DynAnyPackage/InvalidValue.java .
InvalidValue() - Constructor for exception org.omg.DynamicAny.DynAnyPackage.InvalidValue
InvalidValue(String) - Constructor for exception org.omg.DynamicAny.DynAnyPackage.InvalidValue
InvalidValueHelper - Class in org.omg.DynamicAny.DynAnyPackage
org/omg/DynamicAny/DynAnyPackage/InvalidValueHelper.java .
InvalidValueHelper() - Constructor for class org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper
inverseTransform(Point2D, Point2D) - Method in class java.awt.geom.AffineTransform
Inverse transforms the specified ptSrc and stores the result in ptDst.
inverseTransform(double[], int, double[], int, int) - Method in class java.awt.geom.AffineTransform
Inverse transforms an array of double precision coordinates by this transform.
invert() - Method in class java.awt.geom.AffineTransform
Sets this transform to the inverse of itself.
INVITE - Static variable in class java.awt.PageAttributes.MediaType
An alias for INVITE_ENVELOPE.
INVITE_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for Invitation Envelope, 220 x 220 mm.
Invocable - Interface in javax.script
The optional interface implemented by ScriptEngines whose methods allow the invocation of procedures in scripts that have previously been executed.
INVOCATION_DEFAULT - Static variable in class java.awt.event.InvocationEvent
The default id for all InvocationEvents.
INVOCATION_EVENT_MASK - Static variable in class java.awt.AWTEvent
The event mask for selecting invocation events.
INVOCATION_FIRST - Static variable in class java.awt.event.InvocationEvent
Marks the first integer id for the range of invocation event ids.
INVOCATION_LAST - Static variable in class java.awt.event.InvocationEvent
Marks the last integer id for the range of invocation event ids.
InvocationEvent - Class in java.awt.event
An event which executes the run() method on a Runnable when dispatched by the AWT event dispatcher thread.
InvocationEvent(Object, Runnable) - Constructor for class java.awt.event.InvocationEvent
Constructs an InvocationEvent with the specified source which will execute the runnable's run method when dispatched.
InvocationEvent(Object, Runnable, Object, boolean) - Constructor for class java.awt.event.InvocationEvent
Constructs an InvocationEvent with the specified source which will execute the runnable's run method when dispatched.
InvocationEvent(Object, Runnable, Runnable, boolean) - Constructor for class java.awt.event.InvocationEvent
Constructs an InvocationEvent with the specified source which will execute the runnable's run method when dispatched.
InvocationEvent(Object, int, Runnable, Object, boolean) - Constructor for class java.awt.event.InvocationEvent
Constructs an InvocationEvent with the specified source and ID which will execute the runnable's run method when dispatched.
InvocationHandler - Interface in java.lang.reflect
InvocationHandler is the interface implemented by the invocation handler of a proxy instance.
InvocationKeyHandler() - Constructor for class javax.swing.plaf.basic.BasicComboPopup.InvocationKeyHandler
InvocationMouseHandler() - Constructor for class javax.swing.plaf.basic.BasicComboPopup.InvocationMouseHandler
InvocationMouseMotionHandler() - Constructor for class javax.swing.plaf.basic.BasicComboPopup.InvocationMouseMotionHandler
InvocationTargetException - Exception in java.lang.reflect
InvocationTargetException is a checked exception that wraps an exception thrown by an invoked method or constructor.
InvocationTargetException() - Constructor for exception java.lang.reflect.InvocationTargetException
Constructs an InvocationTargetException with null as the target exception.
InvocationTargetException(Throwable) - Constructor for exception java.lang.reflect.InvocationTargetException
Constructs a InvocationTargetException with a target exception.
InvocationTargetException(Throwable, String) - Constructor for exception java.lang.reflect.InvocationTargetException
Constructs a InvocationTargetException with a target exception and a detail message.
INVOICE - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for Invoice, 5 1/2 x 8 1/2 in.
INVOICE - Static variable in class javax.print.attribute.standard.MediaSize.Other
Specifies the invoice size, 5.5 inches by 8.5 inches.
INVOICE - Static variable in class javax.print.attribute.standard.MediaSizeName
invoice size .
invoke(Object, Method, Object[]) - Method in class java.beans.EventHandler
Extract the appropriate property value from the event and pass it to the action associated with this EventHandler.
invoke(Object...) - Method in class java.lang.invoke.MethodHandle
Invokes the method handle, allowing any caller type descriptor, and optionally performing conversions on arguments and return values.
invoke(Object, Method, Object[]) - Method in interface java.lang.reflect.InvocationHandler
Processes a method invocation on a proxy instance and returns the result.
invoke(Object, Object...) - Method in class java.lang.reflect.Method
Invokes the underlying method represented by this Method object, on the specified object with the specified parameters.
invoke(Object, Method, Object[]) - Method in class java.rmi.server.RemoteObjectInvocationHandler
Processes a method invocation made on the encapsulating proxy instance, proxy, and returns the result.
invoke(Remote, Method, Object[], long) - Method in interface java.rmi.server.RemoteRef
Invoke a method.
invoke(RemoteCall) - Method in interface java.rmi.server.RemoteRef
Deprecated.
1.2 style stubs no longer use this method. Instead of using a sequence of method calls to the remote reference (newCall, invoke, and done), a stub uses a single method, invoke(Remote, Method, Object[], int), on the remote reference to carry out parameter marshalling, remote method executing and unmarshalling of the return value.
invoke(ForkJoinTask<T>) - Method in class java.util.concurrent.ForkJoinPool
Performs the given task, returning its result upon completion.
invoke() - Method in class java.util.concurrent.ForkJoinTask
Commences performing this task, awaits its completion if necessary, and returns its result, or throws an (unchecked) RuntimeException or Error if the underlying computation did so.
invoke(String, Object[], String[]) - Method in interface javax.management.DynamicMBean
Allows an action to be invoked on the Dynamic MBean.
invoke(ObjectName, String, Object[], String[]) - Method in interface javax.management.MBeanServer
invoke(ObjectName, String, Object[], String[]) - Method in interface javax.management.MBeanServerConnection
Invokes an operation on an MBean.
invoke(Object, Method, Object[]) - Method in class javax.management.MBeanServerInvocationHandler
invoke(String, Object[], String[]) - Method in class javax.management.modelmbean.RequiredModelMBean
Invokes a method on or through a RequiredModelMBean and returns the result of the method execution.
invoke(Object, Method, Object[]) - Method in class javax.management.openmbean.CompositeDataInvocationHandler
invoke(ObjectName, String, MarshalledObject, String[], Subject) - Method in interface javax.management.remote.rmi.RMIConnection
Handles the method MBeanServerConnection.invoke(ObjectName, String, Object[], String[]).
invoke(ObjectName, String, MarshalledObject, String[], Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl
invoke(ObjectName, String, MarshalledObject, String[], Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub
invoke(String, Object[], String[]) - Method in class javax.management.StandardMBean
invoke(T) - Method in interface javax.xml.ws.Dispatch
Invoke a service operation synchronously.
invoke(T) - Method in interface javax.xml.ws.Provider
Invokes an operation occording to the contents of the request message.
invoke(Method, Object...) - Method in class javax.xml.ws.spi.Invoker
JAX-WS runtime calls this method to do the actual web service invocation on endpoint instance.
invoke(ServerRequest) - Method in class org.omg.CORBA.DynamicImplementation
Deprecated.
Deprecated by Portable Object Adapter
invoke(Object, OutputStream) - Method in class org.omg.CORBA.portable.Delegate
invoke is called by a stub to invoke an operation.
invoke() - Method in class org.omg.CORBA.Request
Makes a synchronous invocation using the information in the Request object.
invoke(ServerRequest) - Method in class org.omg.CosNaming._BindingIteratorImplBase
invoke(ServerRequest) - Method in class org.omg.CosNaming._NamingContextImplBase
invoke(ServerRequest) - Method in class org.omg.PortableServer.DynamicImplementation
Receives requests issued to any CORBA object incarnated by the DSI servant and performs the processing necessary to execute the request.
invokeAll(Collection<? extends Callable<T>>) - Method in class java.util.concurrent.AbstractExecutorService
invokeAll(Collection<? extends Callable<T>>, long, TimeUnit) - Method in class java.util.concurrent.AbstractExecutorService
invokeAll(Collection<? extends Callable<T>>) - Method in interface java.util.concurrent.ExecutorService
Executes the given tasks, returning a list of Futures holding their status and results when all complete.
invokeAll(Collection<? extends Callable<T>>, long, TimeUnit) - Method in interface java.util.concurrent.ExecutorService
Executes the given tasks, returning a list of Futures holding their status and results when all complete or the timeout expires, whichever happens first.
invokeAll(Collection<? extends Callable<T>>) - Method in class java.util.concurrent.ForkJoinPool
invokeAll(ForkJoinTask<?>, ForkJoinTask<?>) - Static method in class java.util.concurrent.ForkJoinTask
Forks the given tasks, returning when isDone holds for each task or an (unchecked) exception is encountered, in which case the exception is rethrown.
invokeAll(ForkJoinTask<?>...) - Static method in class java.util.concurrent.ForkJoinTask
Forks the given tasks, returning when isDone holds for each task or an (unchecked) exception is encountered, in which case the exception is rethrown.
invokeAll(Collection<T>) - Static method in class java.util.concurrent.ForkJoinTask
Forks all tasks in the specified collection, returning when isDone holds for each task or an (unchecked) exception is encountered, in which case the exception is rethrown.
invokeAndWait(Runnable) - Static method in class java.awt.EventQueue
Causes runnable to have its run method called in the dispatch thread of the system EventQueue.
invokeAndWait(Runnable) - Static method in class javax.swing.SwingUtilities
Causes doRun.run() to be executed synchronously on the AWT event dispatching thread.
invokeAny(Collection<? extends Callable<T>>) - Method in class java.util.concurrent.AbstractExecutorService
invokeAny(Collection<? extends Callable<T>>, long, TimeUnit) - Method in class java.util.concurrent.AbstractExecutorService
invokeAny(Collection<? extends Callable<T>>) - Method in interface java.util.concurrent.ExecutorService
Executes the given tasks, returning the result of one that has completed successfully (i.e., without throwing an exception), if any do.
invokeAny(Collection<? extends Callable<T>>, long, TimeUnit) - Method in interface java.util.concurrent.ExecutorService
Executes the given tasks, returning the result of one that has completed successfully (i.e., without throwing an exception), if any do before the given timeout elapses.
invokeAsync(T) - Method in interface javax.xml.ws.Dispatch
Invoke a service operation asynchronously.
invokeAsync(T, AsyncHandler<T>) - Method in interface javax.xml.ws.Dispatch
Invoke a service operation asynchronously.
invokeExact(Object...) - Method in class java.lang.invoke.MethodHandle
Invokes the method handle, allowing any caller type descriptor, but requiring an exact type match.
invokeFunction(String, Object...) - Method in interface javax.script.Invocable
Used to call top-level procedures and functions defined in scripts.
InvokeHandler - Interface in org.omg.CORBA.portable
This interface provides a dispatching mechanism for an incoming call.
invokeLater(Runnable) - Static method in class java.awt.EventQueue
Causes runnable to have its run method called in the dispatch thread of the system EventQueue.
invokeLater(Runnable) - Static method in class javax.swing.SwingUtilities
Causes doRun.run() to be executed asynchronously on the AWT event dispatching thread.
invokeMethod(Object, String, Object...) - Method in interface javax.script.Invocable
Calls a method on a script object compiled during a previous script execution, which is retained in the state of the ScriptEngine.
invokeOneWay(T) - Method in interface javax.xml.ws.Dispatch
Invokes a service operation using the one-way interaction mode.
invoker(MethodType) - Static method in class java.lang.invoke.MethodHandles
Produces a special invoker method handle which can be used to invoke any method handle compatible with the given type, as if by invoke.
Invoker - Class in javax.xml.ws.spi
Invoker hides the detail of calling into application endpoint implementation.
Invoker() - Constructor for class javax.xml.ws.spi.Invoker
INVOKES_STOP_CELL_EDITING_PROPERTY - Static variable in class javax.swing.JTree
Bound property name for messagesStopCellEditing.
invokesStopCellEditing - Variable in class javax.swing.JTree
If true, when editing is to be stopped by way of selection changing, data in tree changing or other means stopCellEditing is invoked, and changes are saved.
invokeWithArguments(Object...) - Method in class java.lang.invoke.MethodHandle
Performs a variable arity invocation, passing the arguments in the given list to the method handle, as if via an inexact invoke from a call site which mentions only the type Object, and whose arity is the length of the argument list.
invokeWithArguments(List<?>) - Method in class java.lang.invoke.MethodHandle
Performs a variable arity invocation, passing the arguments in the given array to the method handle, as if via an inexact invoke from a call site which mentions only the type Object, and whose arity is the length of the argument array.
IOError - Error in java.io
Thrown when a serious I/O error has occurred.
IOError(Throwable) - Constructor for error java.io.IOError
Constructs a new instance of IOError with the specified cause.
IOException - Exception in java.io
Signals that an I/O exception of some sort has occurred.
IOException() - Constructor for exception java.io.IOException
Constructs an IOException with null as its error detail message.
IOException(String) - Constructor for exception java.io.IOException
Constructs an IOException with the specified detail message.
IOException(String, Throwable) - Constructor for exception java.io.IOException
Constructs an IOException with the specified detail message and cause.
IOException(Throwable) - Constructor for exception java.io.IOException
Constructs an IOException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
ioException() - Method in class java.util.Formatter
Returns the IOException last thrown by this formatter's Appendable.
ioException() - Method in class java.util.Scanner
Returns the IOException last thrown by this Scanner's underlying Readable.
IOR - Class in org.omg.IOP
org/omg/IOP/IOR.java .
IOR() - Constructor for class org.omg.IOP.IOR
IOR(String, TaggedProfile[]) - Constructor for class org.omg.IOP.IOR
IORHelper - Class in org.omg.IOP
org/omg/IOP/IORHelper.java .
IORHelper() - Constructor for class org.omg.IOP.IORHelper
IORHolder - Class in org.omg.IOP
org/omg/IOP/IORHolder.java .
IORHolder() - Constructor for class org.omg.IOP.IORHolder
IORHolder(IOR) - Constructor for class org.omg.IOP.IORHolder
IORInfo - Interface in org.omg.PortableInterceptor
Provides the server-side ORB service with access to the applicable policies during IOR construction and the ability to add components.
IORInfoOperations - Interface in org.omg.PortableInterceptor
Provides the server-side ORB service with access to the applicable policies during IOR construction and the ability to add components.
IORInterceptor - Interface in org.omg.PortableInterceptor
Interceptor used to establish tagged components in the profiles within an IOR.
IORInterceptor_3_0 - Interface in org.omg.PortableInterceptor
org/omg/PortableInterceptor/IORInterceptor_3_0.java .
IORInterceptor_3_0Helper - Class in org.omg.PortableInterceptor
org/omg/PortableInterceptor/IORInterceptor_3_0Helper.java .
IORInterceptor_3_0Helper() - Constructor for class org.omg.PortableInterceptor.IORInterceptor_3_0Helper
IORInterceptor_3_0Holder - Class in org.omg.PortableInterceptor
org/omg/PortableInterceptor/IORInterceptor_3_0Holder.java .
IORInterceptor_3_0Holder() - Constructor for class org.omg.PortableInterceptor.IORInterceptor_3_0Holder
IORInterceptor_3_0Holder(IORInterceptor_3_0) - Constructor for class org.omg.PortableInterceptor.IORInterceptor_3_0Holder
IORInterceptor_3_0Operations - Interface in org.omg.PortableInterceptor
org/omg/PortableInterceptor/IORInterceptor_3_0Operations.java .
IORInterceptorOperations - Interface in org.omg.PortableInterceptor
Interceptor used to establish tagged components in the profiles within an IOR.
IP_MULTICAST_IF - Static variable in interface java.net.SocketOptions
Set which outgoing interface on which to send multicast packets.
IP_MULTICAST_IF - Static variable in class java.net.StandardSocketOptions
The network interface for Internet Protocol (IP) multicast datagrams.
IP_MULTICAST_IF2 - Static variable in interface java.net.SocketOptions
Same as above.
IP_MULTICAST_LOOP - Static variable in interface java.net.SocketOptions
This option enables or disables local loopback of multicast datagrams.
IP_MULTICAST_LOOP - Static variable in class java.net.StandardSocketOptions
Loopback for Internet Protocol (IP) multicast datagrams.
IP_MULTICAST_TTL - Static variable in class java.net.StandardSocketOptions
The time-to-live for Internet Protocol (IP) multicast datagrams.
IP_TOS - Static variable in interface java.net.SocketOptions
This option sets the type-of-service or traffic class field in the IP header for a TCP or UDP socket.
IP_TOS - Static variable in class java.net.StandardSocketOptions
The Type of Service (ToS) octet in the Internet Protocol (IP) header.
IPA_EXTENSIONS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "IPA Extensions" Unicode character block.
ipadx - Variable in class java.awt.GridBagConstraints
This field specifies the internal padding of the component, how much space to add to the minimum width of the component.
ipady - Variable in class java.awt.GridBagConstraints
This field specifies the internal padding, that is, how much space to add to the minimum height of the component.
IRObject - Interface in org.omg.CORBA
An IRObject IDL interface represents the most generic interface from which all other Interface Repository interfaces are derived, even the Repository itself.
IRObjectOperations - Interface in org.omg.CORBA
This is the Operations interface for the mapping from IRObject.
is_a(Object, String) - Method in class org.omg.CORBA.portable.Delegate
Checks if the object reference is an instance of the given interface.
is_a(Servant, String) - Method in interface org.omg.PortableServer.portable.Delegate
This method checks to see if the specified repid is present on the list returned by _all_interfaces() or is the repository id for the generic CORBA Object.
IS_CLOSED_PROPERTY - Static variable in class javax.swing.JInternalFrame
Constrained property name indicating that the internal frame is closed.
IS_COALESCING - Static variable in class javax.xml.stream.XMLInputFactory
The property that requires the parser to coalesce adjacent character data sections
is_equivalent(Object, Object) - Method in class org.omg.CORBA.portable.Delegate
Determines if the two object references are equivalent.
IS_ICON_PROPERTY - Static variable in class javax.swing.JInternalFrame
Constrained property name indicating that the internal frame is iconified.
is_local(Object) - Method in class org.omg.CORBA.portable.Delegate
Returns true if this object is implemented by a local servant.
IS_MAXIMUM_PROPERTY - Static variable in class javax.swing.JInternalFrame
Constrained property name indicating that the internal frame is maximized.
IS_NAMESPACE_AWARE - Static variable in class javax.xml.stream.XMLInputFactory
The property used to turn on/off namespace support, this is to support XML 1.0 documents, only the true setting must be supported
is_null() - Method in class org.omg.DynamicAny._DynValueStub
Returns true if the DynValueCommon represents a null value type.
is_null() - Method in interface org.omg.DynamicAny.DynValueCommonOperations
Returns true if the DynValueCommon represents a null value type.
IS_PALETTE - Static variable in class javax.swing.plaf.metal.MetalInternalFrameUI
IS_REPAIRING_NAMESPACES - Static variable in class javax.xml.stream.XMLOutputFactory
Property used to set prefix defaulting on the output side
IS_REPLACING_ENTITY_REFERENCES - Static variable in class javax.xml.stream.XMLInputFactory
Requires the parser to replace internal entity references with their replacement text and report them as characters
IS_SELECTED_PROPERTY - Static variable in class javax.swing.JInternalFrame
Constrained property name indicated that this frame has selected status.
IS_SUPPORTING_EXTERNAL_ENTITIES - Static variable in class javax.xml.stream.XMLInputFactory
The property that requires the parser to resolve external parsed entities
IS_VALIDATING - Static variable in class javax.xml.stream.XMLInputFactory
The property used to turn on/off implementation specific validation
isAbsolute() - Method in class java.io.File
Tests whether this abstract pathname is absolute.
isAbsolute() - Method in class java.net.URI
Tells whether or not this URI is absolute.
isAbsolute() - Method in interface java.nio.file.Path
Tells whether or not this path is absolute.
isAbstract(int) - Static method in class java.lang.reflect.Modifier
Return true if the integer argument includes the abstract modifier, false otherwise.
isAccelerated() - Method in class java.awt.ImageCapabilities
Returns true if the object whose capabilities are encapsulated in this ImageCapabilities can be or is accelerated.
isAcceleratorHidden() - Method in class javax.swing.plaf.metal.MetalToolTipUI
isAcceptable() - Method in class java.nio.channels.SelectionKey
Tests whether this key's channel is ready to accept a new socket connection.
isAcceptAllFileFilterUsed() - Method in class javax.swing.JFileChooser
Returns whether the AcceptAll FileFilter is used.
isAccessible() - Method in class java.lang.reflect.AccessibleObject
Get the value of the accessible flag for this object.
isAccessibleChildSelected(int) - Method in class java.awt.List.AccessibleAWTList
Returns true if the current child of this object is selected.
isAccessibleChildSelected(int) - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent
Determines if the current child of this object is selected.
isAccessibleChildSelected(int) - Method in interface javax.accessibility.AccessibleSelection
Determines if the current child of this object is selected.
isAccessibleChildSelected(int) - Method in class javax.swing.JComboBox.AccessibleJComboBox
Determines if the current child of this object is selected.
isAccessibleChildSelected(int) - Method in class javax.swing.JList.AccessibleJList
Returns true if the current child of this object is selected.
isAccessibleChildSelected(int) - Method in class javax.swing.JMenu.AccessibleJMenu
Returns true if the current child of this object is selected (that is, if this child is a popped-up submenu).
isAccessibleChildSelected(int) - Method in class javax.swing.JMenuBar.AccessibleJMenuBar
Returns true if the current child of this object is selected.
isAccessibleChildSelected(int) - Method in class javax.swing.JTabbedPane.AccessibleJTabbedPane
isAccessibleChildSelected(int) - Method in class javax.swing.JTable.AccessibleJTable
Determines if the current child of this object is selected.
isAccessibleChildSelected(int) - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode
Returns true if the current child of this object is selected.
isAccessibleChildSelected(int) - Method in class javax.swing.JTree.AccessibleJTree
Returns true if the current child of this object is selected.
isAccessibleColumnSelected(int) - Method in interface javax.accessibility.AccessibleTable
Returns a boolean value indicating whether the specified column is selected.
isAccessibleColumnSelected(int) - Method in class javax.swing.JTable.AccessibleJTable
Returns a boolean value indicating whether the specified column is selected.
isAccessibleRowSelected(int) - Method in interface javax.accessibility.AccessibleTable
Returns a boolean value indicating whether the specified row is selected.
isAccessibleRowSelected(int) - Method in class javax.swing.JTable.AccessibleJTable
Returns a boolean value indicating whether the specified row is selected.
isAccessibleSelected(int, int) - Method in interface javax.accessibility.AccessibleTable
Returns a boolean value indicating whether the accessible at a specified row and column is selected.
isAccessibleSelected(int, int) - Method in class javax.swing.JTable.AccessibleJTable
Returns a boolean value indicating whether the accessible at a given (row, column) is selected.
isActionKey() - Method in class java.awt.event.KeyEvent
Returns whether the key in this event is an "action" key.
isActive() - Method in class java.applet.Applet
Determines if this applet is active.
isActive() - Method in interface java.applet.AppletStub
Determines if the applet is active.
isActive() - Method in class java.awt.dnd.DropTarget
Reports whether or not this DropTarget is currently active (ready to accept drops).
isActive() - Method in class java.awt.Window
Returns whether this Window is active.
isActive() - Method in class javax.management.monitor.Monitor
Tests whether the monitor MBean is active.
isActive() - Method in interface javax.management.monitor.MonitorMBean
Tests if the monitor MBean is active.
isActive() - Method in class javax.management.relation.RelationService
Checks if the Relation Service is active.
isActive() - Method in interface javax.management.relation.RelationServiceMBean
Checks if the Relation Service is active.
isActive() - Method in interface javax.management.remote.JMXConnectorServerMBean
Determines whether the connector server is active.
isActive() - Method in class javax.management.remote.rmi.RMIConnectorServer
isActive() - Method in class javax.management.timer.Timer
Tests whether the timer MBean is active.
isActive() - Method in interface javax.management.timer.TimerMBean
Tests whether the timer MBean is active.
isActive() - Method in interface javax.sound.sampled.DataLine
Indicates whether the line is engaging in active I/O (such as playback or capture).
isActive() - Method in class javax.swing.text.DefaultCaret
Determines if the caret is currently active.
isAddedPath() - Method in class javax.swing.event.TreeSelectionEvent
Returns whether the path identified by getPath was added to the selection.
isAddedPath(TreePath) - Method in class javax.swing.event.TreeSelectionEvent
Returns whether the specified path was added to the selection.
isAddedPath(int) - Method in class javax.swing.event.TreeSelectionEvent
Returns whether the path at getPaths()[index] was added to the selection.
isAfter(ChronoLocalDate) - Method in interface java.time.chrono.ChronoLocalDate
Checks if this date is after the specified date ignoring the chronology.
isAfter(ChronoLocalDateTime<?>) - Method in interface java.time.chrono.ChronoLocalDateTime
Checks if this date-time is after the specified date-time ignoring the chronology.
isAfter(ChronoZonedDateTime<?>) - Method in interface java.time.chrono.ChronoZonedDateTime
Checks if the instant of this date-time is after that of the specified date-time.
isAfter(Instant) - Method in class java.time.Instant
Checks if this instant is after the specified instant.
isAfter(ChronoLocalDate) - Method in class java.time.LocalDate
Checks if this date is after the specified date.
isAfter(ChronoLocalDateTime<?>) - Method in class java.time.LocalDateTime
Checks if this date-time is after the specified date-time.
isAfter(LocalTime) - Method in class java.time.LocalTime
Checks if this LocalTime is after the specified time.
isAfter(MonthDay) - Method in class java.time.MonthDay
Is this month-day after the specified month-day.
isAfter(OffsetDateTime) - Method in class java.time.OffsetDateTime
Checks if the instant of this date-time is after that of the specified date-time.
isAfter(OffsetTime) - Method in class java.time.OffsetTime
Checks if the instant of this OffsetTime is after that of the specified time applying both times to a common date.
isAfter(Year) - Method in class java.time.Year
Is this year after the specified year.
isAfter(YearMonth) - Method in class java.time.YearMonth
Is this year-month after the specified year-month.
isAfter(int, int, Rectangle) - Method in class javax.swing.text.BoxView
Determines if a point falls after an allocated region.
isAfter(int, int, Rectangle) - Method in class javax.swing.text.CompositeView
Tests whether a point lies after the rectangle range.
isAfterLast() - Method in interface java.sql.ResultSet
Retrieves whether the cursor is after the last row in this ResultSet object.
isAlive() - Method in class java.lang.Process
Tests whether the subprocess represented by this Process is alive.
isAlive() - Method in class java.lang.Thread
Tests if this thread is alive.
isAllocationValid() - Method in class javax.swing.text.BoxView
Are the allocations for the children still valid?
isAlphabetic(int) - Static method in class java.lang.Character
Determines if the specified character (Unicode code point) is an alphabet.
isAlphaPremultiplied() - Method in class java.awt.image.BufferedImage
Returns whether or not the alpha has been premultiplied.
isAlphaPremultiplied() - Method in class java.awt.image.ColorModel
Returns whether or not the alpha has been premultiplied in the pixel values to be translated by this ColorModel.
isAltDown() - Method in class java.awt.event.InputEvent
Returns whether or not the Alt modifier is down on this event.
isAltGraphDown() - Method in class java.awt.event.InputEvent
Returns whether or not the AltGraph modifier is down on this event.
isAlwaysOnTop() - Method in class java.awt.Window
Returns whether this window is an always-on-top window.
isAlwaysOnTopSupported() - Method in class java.awt.Toolkit
Returns whether the always-on-top mode is supported by this toolkit.
isAlwaysOnTopSupported() - Method in class java.awt.Window
Returns whether the always-on-top mode is supported for this window.
isAncestorOf(Component) - Method in class java.awt.Container
Checks if the component is contained in the component hierarchy of this container.
isAnnotation() - Method in class java.lang.Class
Returns true if this Class object represents an annotation type.
isAnnotationPresent(Class<? extends Annotation>) - Method in class java.lang.Class
Returns true if an annotation for the specified type is present on this element, else false.
isAnnotationPresent(Class<? extends Annotation>) - Method in class java.lang.Package
Returns true if an annotation for the specified type is present on this element, else false.
isAnnotationPresent(Class<? extends Annotation>) - Method in class java.lang.reflect.AccessibleObject
Returns true if an annotation for the specified type is present on this element, else false.
isAnnotationPresent(Class<? extends Annotation>) - Method in interface java.lang.reflect.AnnotatedElement
Returns true if an annotation for the specified type is present on this element, else false.
isAnonymous() - Method in interface org.ietf.jgss.GSSName
Tests if this name object represents an anonymous entity.
isAnonymousClass() - Method in class java.lang.Class
Returns true if and only if the underlying class is an anonymous class.
isAntiAliased() - Method in class java.awt.font.FontRenderContext
Returns a boolean which indicates whether or not some form of antialiasing is specified by this FontRenderContext.
isAnyLocalAddress() - Method in class java.net.Inet4Address
Utility routine to check if the InetAddress in a wildcard address.
isAnyLocalAddress() - Method in class java.net.Inet6Address
Utility routine to check if the InetAddress in a wildcard address.
isAnyLocalAddress() - Method in class java.net.InetAddress
Utility routine to check if the InetAddress in a wildcard address.
isAnyPolicyInhibited() - Method in class java.security.cert.PKIXParameters
Checks whether the any policy OID should be processed if it is included in a certificate.
isArchive() - Method in interface java.nio.file.attribute.DosFileAttributes
Returns the value of the archive attribute.
isArmed() - Method in interface javax.swing.ButtonModel
Indicates partial commitment towards triggering the button.
isArmed() - Method in class javax.swing.DefaultButtonModel
Indicates partial commitment towards triggering the button.
isArmed() - Method in class javax.swing.JMenuItem
Returns whether the menu item is "armed".
isArray() - Method in class java.lang.Class
Determines if this Class object represents an array class.
isArray() - Method in class javax.management.openmbean.OpenType
Returns true if the open data values this open type describes are arrays, false otherwise.
isAscending() - Method in class javax.naming.ldap.SortKey
Determines the sort order.
isAssignable(TypeMirror, TypeMirror) - Method in interface javax.lang.model.util.Types
Tests whether one type is assignable to another.
isAssignableFrom(Class<?>) - Method in class java.lang.Class
Determines if the class or interface represented by this Class object is either the same as, or is a superclass or superinterface of, the class or interface represented by the specified Class parameter.
isAttribute() - Method in interface javax.xml.stream.events.XMLEvent
A utility function to check if this event is an Attribute.
isAttributeCategorySupported(Class<? extends Attribute>) - Method in interface javax.print.PrintService
Determines whether a client can specify the given printing attribute category when setting up a job for this print service.
isAttributeRequired(String, String) - Method in interface javax.imageio.metadata.IIOMetadataFormat
Returns true if the named attribute must be present within the named element.
isAttributeRequired(String, String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl
isAttributeSpecified(int) - Method in class javax.xml.stream.util.StreamReaderDelegate
isAttributeSpecified(int) - Method in interface javax.xml.stream.XMLStreamReader
Returns a boolean which indicates if this attribute was created by default
isAttributeValueSupported(Attribute, DocFlavor, AttributeSet) - Method in interface javax.print.PrintService
Determines whether a client can specify the given printing attribute value when setting up a job for this Print Service.
isAuthorized() - Method in class javax.security.sasl.AuthorizeCallback
Determines whether the authentication id is allowed to act on behalf of the authorization id.
isAutoDetecting() - Method in class java.nio.charset.CharsetDecoder
Tells whether or not this decoder implements an auto-detecting charset.
isAutoFormSubmission() - Method in class javax.swing.text.html.HTMLEditorKit
Indicates whether an html form submission is processed automatically or only FormSubmitEvent is fired.
isAutoIncrement(int) - Method in interface java.sql.ResultSetMetaData
Indicates whether the designated column is automatically numbered.
isAutoIncrement(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl
Retrieves whether a value stored in the designated column is automatically numbered, and thus readonly.
isAutoRequestFocus() - Method in class java.awt.Window
Returns whether this window should receive focus on subsequently being shown (with a call to setVisible(true)), or being moved to the front (with a call to Window.toFront()).
isAutoScrolling - Variable in class javax.swing.plaf.basic.BasicComboPopup
isAutoWaitForIdle() - Method in class java.awt.Robot
Returns whether this Robot automatically invokes waitForIdle after generating an event.
isBackgroundSet() - Method in class java.awt.Component
Returns whether the background color has been explicitly set for this Component.
isBackingStoreEnabled() - Method in class javax.swing.JViewport
Deprecated.
As of Java 2 platform v1.3, replaced by getScrollMode().
isBefore(ChronoLocalDate) - Method in interface java.time.chrono.ChronoLocalDate
Checks if this date is before the specified date ignoring the chronology.
isBefore(ChronoLocalDateTime<?>) - Method in interface java.time.chrono.ChronoLocalDateTime
Checks if this date-time is before the specified date-time ignoring the chronology.
isBefore(ChronoZonedDateTime<?>) - Method in interface java.time.chrono.ChronoZonedDateTime
Checks if the instant of this date-time is before that of the specified date-time.
isBefore(Instant) - Method in class java.time.Instant
Checks if this instant is before the specified instant.
isBefore(ChronoLocalDate) - Method in class java.time.LocalDate
Checks if this date is before the specified date.
isBefore(ChronoLocalDateTime<?>) - Method in class java.time.LocalDateTime
Checks if this date-time is before the specified date-time.
isBefore(LocalTime) - Method in class java.time.LocalTime
Checks if this LocalTime is before the specified time.
isBefore(MonthDay) - Method in class java.time.MonthDay
Is this month-day before the specified month-day.
isBefore(OffsetDateTime) - Method in class java.time.OffsetDateTime
Checks if the instant of this date-time is before that of the specified date-time.
isBefore(OffsetTime) - Method in class java.time.OffsetTime
Checks if the instant of this OffsetTime is before that of the specified time applying both times to a common date.
isBefore(Year) - Method in class java.time.Year
Is this year before the specified year.
isBefore(YearMonth) - Method in class java.time.YearMonth
Is this year-month before the specified year-month.
isBefore(int, int, Rectangle) - Method in class javax.swing.text.BoxView
Determines if a point falls before an allocated region.
isBefore(int, int, Rectangle) - Method in class javax.swing.text.CompositeView
Tests whether a point lies before the rectangle range.
isBeforeFirst() - Method in interface java.sql.ResultSet
Retrieves whether the cursor is before the first row in this ResultSet object.
isBigEndian() - Method in class javax.sound.sampled.AudioFormat
Indicates whether the audio data is stored in big-endian or little-endian byte order.
isBlock() - Method in class javax.swing.text.html.HTML.Tag
Returns true if this tag is a block tag, which is a tag used to add structure to a document.
isBlocking() - Method in class java.nio.channels.SelectableChannel
Tells whether or not every I/O operation on this channel will block until it completes.
isBlocking() - Method in class java.nio.channels.spi.AbstractSelectableChannel
isBlockTag(AttributeSet) - Method in class javax.swing.text.html.HTMLWriter
Determines if the HTML.Tag associated with the element is a block tag.
isBmpCodePoint(int) - Static method in class java.lang.Character
Determines whether the specified character (Unicode code point) is in the Basic Multilingual Plane (BMP).
isBold() - Method in class java.awt.Font
Indicates whether or not this Font object's style is BOLD.
isBold(AttributeSet) - Static method in class javax.swing.text.StyleConstants
Checks whether the bold attribute is set.
isBootClassPathSupported() - Method in interface java.lang.management.RuntimeMXBean
Tests if the Java virtual machine supports the boot class path mechanism used by the bootstrap class loader to search for class files.
isBorderOpaque() - Method in class javax.swing.border.AbstractBorder
This default implementation returns false.
isBorderOpaque() - Method in class javax.swing.border.BevelBorder
Returns whether or not the border is opaque.
isBorderOpaque() - Method in interface javax.swing.border.Border
Returns whether or not the border is opaque.
isBorderOpaque() - Method in class javax.swing.border.CompoundBorder
Returns whether or not the compound border is opaque.
isBorderOpaque() - Method in class javax.swing.border.EmptyBorder
Returns whether or not the border is opaque.
isBorderOpaque() - Method in class javax.swing.border.EtchedBorder
Returns whether or not the border is opaque.
isBorderOpaque() - Method in class javax.swing.border.LineBorder
Returns whether or not the border is opaque.
isBorderOpaque() - Method in class javax.swing.border.MatteBorder
Returns whether or not the border is opaque.
isBorderOpaque() - Method in class javax.swing.border.SoftBevelBorder
Returns whether or not the border is opaque.
isBorderOpaque() - Method in class javax.swing.border.TitledBorder
Returns whether or not the border is opaque.
isBorderOpaque() - Method in class javax.swing.plaf.basic.BasicBorders.SplitPaneBorder
isBorderOpaque() - Method in class javax.swing.plaf.BorderUIResource
isBorderPainted() - Method in class javax.swing.AbstractButton
Gets the borderPainted property.
isBorderPainted() - Method in class javax.swing.JMenuBar
Returns true if the menu bars border should be painted.
isBorderPainted() - Method in class javax.swing.JPopupMenu
Checks whether the border should be painted.
isBorderPainted() - Method in class javax.swing.JProgressBar
Returns the borderPainted property.
isBorderPainted() - Method in class javax.swing.JToolBar
Gets the borderPainted property.
isBorderPaintedFlat() - Method in class javax.swing.JCheckBox
Gets the value of the borderPaintedFlat property.
isBound() - Method in class java.beans.PropertyDescriptor
Updates to "bound" properties will cause a "PropertyChange" event to get fired when the property is changed.
isBound() - Method in class java.net.DatagramSocket
Returns the binding state of the socket.
isBound() - Method in class java.net.ServerSocket
Returns the binding state of the ServerSocket.
isBound() - Method in class java.net.Socket
Returns the binding state of the socket.
isBound() - Method in class javax.security.auth.kerberos.KeyTab
Returns if the keytab is bound to a principal
isBoundary(int) - Method in class java.text.BreakIterator
Returns true if the specified character offset is a text boundary.
isBridge() - Method in class java.lang.reflect.Method
Returns true if this method is a bridge method; returns false otherwise.
isBroken() - Method in class java.util.concurrent.CyclicBarrier
Queries if this barrier is in a broken state.
isCached() - Method in class javax.imageio.stream.FileCacheImageInputStream
Returns true since this ImageInputStream caches data in order to allow seeking backwards.
isCached() - Method in class javax.imageio.stream.FileCacheImageOutputStream
Returns true since this ImageOutputStream caches data in order to allow seeking backwards.
isCached() - Method in interface javax.imageio.stream.ImageInputStream
Returns true if this ImageInputStream caches data itself in order to allow seeking backwards.
isCached() - Method in class javax.imageio.stream.ImageInputStreamImpl
Default implementation returns false.
isCached() - Method in class javax.imageio.stream.MemoryCacheImageInputStream
Returns true since this ImageInputStream caches data in order to allow seeking backwards.
isCached() - Method in class javax.imageio.stream.MemoryCacheImageOutputStream
Returns true since this ImageOutputStream caches data in order to allow seeking backwards.
isCachedFile() - Method in class javax.imageio.stream.FileCacheImageInputStream
Returns true since this ImageInputStream maintains a file cache.
isCachedFile() - Method in class javax.imageio.stream.FileCacheImageOutputStream
Returns true since this ImageOutputStream maintains a file cache.
isCachedFile() - Method in interface javax.imageio.stream.ImageInputStream
Returns true if this ImageInputStream caches data itself in order to allow seeking backwards, and the cache is kept in a temporary file.
isCachedFile() - Method in class javax.imageio.stream.ImageInputStreamImpl
Default implementation returns false.
isCachedFile() - Method in class javax.imageio.stream.MemoryCacheImageInputStream
Returns false since this ImageInputStream does not maintain a file cache.
isCachedFile() - Method in class javax.imageio.stream.MemoryCacheImageOutputStream
Returns false since this ImageOutputStream does not maintain a file cache.
isCachedMemory() - Method in class javax.imageio.stream.FileCacheImageInputStream
Returns false since this ImageInputStream does not maintain a main memory cache.
isCachedMemory() - Method in class javax.imageio.stream.FileCacheImageOutputStream
Returns false since this ImageOutputStream does not maintain a main memory cache.
isCachedMemory() - Method in interface javax.imageio.stream.ImageInputStream
Returns true if this ImageInputStream caches data itself in order to allow seeking backwards, and the cache is kept in main memory.
isCachedMemory() - Method in class javax.imageio.stream.ImageInputStreamImpl
Default implementation returns false.
isCachedMemory() - Method in class javax.imageio.stream.MemoryCacheImageInputStream
Returns true since this ImageInputStream maintains a main memory cache.
isCachedMemory() - Method in class javax.imageio.stream.MemoryCacheImageOutputStream
Returns true since this ImageOutputStream maintains a main memory cache.
isCanceled() - Method in class javax.swing.ProgressMonitor
Returns true if the user hits the Cancel button in the progress dialog.
isCancelled() - Method in class java.awt.print.PrinterJob
Returns true if a print job is in progress, but is going to be cancelled at the next opportunity; otherwise returns false.
isCancelled() - Method in class java.util.concurrent.CompletableFuture
Returns true if this CompletableFuture was cancelled before it completed normally.
isCancelled() - Method in class java.util.concurrent.ForkJoinTask
isCancelled() - Method in interface java.util.concurrent.Future
Returns true if this task was cancelled before it completed normally.
isCancelled() - Method in class java.util.concurrent.FutureTask
isCancelled() - Method in class javax.swing.SwingWorker
Returns true if this task was cancelled before it completed normally.
isCaseIgnored() - Method in interface javax.naming.directory.Attributes
Determines whether the attribute set ignores the case of attribute identifiers when retrieving or adding attributes.
isCaseIgnored() - Method in class javax.naming.directory.BasicAttributes
isCaseSensitive(int) - Method in interface java.sql.ResultSetMetaData
Indicates whether a column's case matters.
isCaseSensitive(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl
Indicates whether the case of the designated column's name matters.
isCatalogAtStart() - Method in interface java.sql.DatabaseMetaData
Retrieves whether a catalog appears at the start of a fully qualified table name.
isCData() - Method in interface javax.xml.stream.events.Characters
Returns true if this is a CData section.
isCellEditable(EventObject) - Method in class javax.swing.AbstractCellEditor
Returns true.
isCellEditable(EventObject) - Method in interface javax.swing.CellEditor
Asks the editor if it can start editing using anEvent.
isCellEditable(EventObject) - Method in class javax.swing.DefaultCellEditor.EditorDelegate
Returns true if anEvent is not a MouseEvent.
isCellEditable(EventObject) - Method in class javax.swing.DefaultCellEditor
Forwards the message from the CellEditor to the delegate.
isCellEditable(int, int) - Method in class javax.swing.JTable
Returns true if the cell at row and column is editable.
isCellEditable(int, int) - Method in class javax.swing.table.AbstractTableModel
Returns false.
isCellEditable(int, int) - Method in class javax.swing.table.DefaultTableModel
Returns true regardless of parameter values.
isCellEditable(int, int) - Method in interface javax.swing.table.TableModel
Returns true if the cell at rowIndex and columnIndex is editable.
isCellEditable(EventObject) - Method in class javax.swing.tree.DefaultTreeCellEditor
If the realEditor returns true to this message, prepareForEditing is messaged and true is returned.
isCellSelected(int, int) - Method in class javax.swing.JTable
Returns true if the specified indices are in the valid range of rows and columns and the cell at the specified position is selected.
isCertificateEntry(String) - Method in class java.security.KeyStore
Returns true if the entry identified by the given alias was created by a call to setCertificateEntry, or created by a call to setEntry with a TrustedCertificateEntry.
isCharacters() - Method in interface javax.xml.stream.events.XMLEvent
A utility function to check if this event is Characters.
isCharacters() - Method in class javax.xml.stream.util.StreamReaderDelegate
isCharacters() - Method in interface javax.xml.stream.XMLStreamReader
Returns true if the cursor points to a character data event
isCharsetDetected() - Method in class java.nio.charset.CharsetDecoder
Tells whether or not this decoder has yet detected a charset (optional operation).
isClass() - Method in enum javax.lang.model.element.ElementKind
Returns true if this is a kind of class: either CLASS or ENUM.
isClosable() - Method in class javax.swing.JInternalFrame
Returns whether this JInternalFrame can be closed by some user action.
isClosed() - Method in class java.net.DatagramSocket
Returns whether the socket is closed or not.
isClosed() - Method in class java.net.ServerSocket
Returns the closed state of the ServerSocket.
isClosed() - Method in class java.net.Socket
Returns the closed state of the socket.
isClosed() - Method in interface java.sql.Connection
Retrieves whether this Connection object has been closed.
isClosed() - Method in interface java.sql.ResultSet
Retrieves whether this ResultSet object has been closed.
isClosed() - Method in interface java.sql.Statement
Retrieves whether this Statement object has been closed.
isClosed - Variable in class javax.swing.JInternalFrame
The frame has been closed.
isClosed() - Method in class javax.swing.JInternalFrame
Returns whether this JInternalFrame is currently closed.
isCloseOnCompletion() - Method in interface java.sql.Statement
Returns a value indicating whether this Statement will be closed when all its dependent result sets are closed.
isCoalesce() - Method in class javax.swing.Timer
Returns true if the Timer coalesces multiple pending action events.
isCoalescing() - Method in class javax.xml.parsers.DocumentBuilderFactory
Indicates whether or not the factory is configured to produce parsers which converts CDATA nodes to Text nodes and appends it to the adjacent (if any) Text node.
isCollapsed(TreePath) - Method in class javax.swing.JTree
Returns true if the value identified by path is currently collapsed, this will return false if any of the values in path are currently not being displayed.
isCollapsed(int) - Method in class javax.swing.JTree
Returns true if the node at the specified display row is collapsed.
isCollectionUsageThresholdExceeded() - Method in interface java.lang.management.MemoryPoolMXBean
Tests if the memory usage of this memory pool after the most recent collection on which the Java virtual machine has expended effort has reached or exceeded its collection usage threshold.
isCollectionUsageThresholdSupported() - Method in interface java.lang.management.MemoryPoolMXBean
Tests if this memory pool supports a collection usage threshold.
isColumnSelected(int) - Method in class javax.swing.JTable
Returns true if the specified index is in the valid range of columns, and the column at that index is selected.
isCombining() - Method in class java.awt.font.GlyphMetrics
Returns true if this is a combining glyph.
isComment() - Method in interface javax.xml.soap.Text
Retrieves whether this Text object represents a comment.
isCompatibleRaster(Raster) - Method in class java.awt.image.ColorModel
Returns true if raster is compatible with this ColorModel and false if it is not.
isCompatibleRaster(Raster) - Method in class java.awt.image.ComponentColorModel
Returns true if raster is compatible with this ColorModel; false if it is not.
isCompatibleRaster(Raster) - Method in class java.awt.image.DirectColorModel
Returns true if raster is compatible with this ColorModel and false if it is not.
isCompatibleRaster(Raster) - Method in class java.awt.image.IndexColorModel
Returns true if raster is compatible with this ColorModel or false if it is not compatible with this ColorModel.
isCompatibleSampleModel(SampleModel) - Method in class java.awt.image.ColorModel
Checks if the SampleModel is compatible with this ColorModel.
isCompatibleSampleModel(SampleModel) - Method in class java.awt.image.ComponentColorModel
Checks whether or not the specified SampleModel is compatible with this ColorModel.
isCompatibleSampleModel(SampleModel) - Method in class java.awt.image.IndexColorModel
Checks if the specified SampleModel is compatible with this ColorModel.
isCompatibleSampleModel(SampleModel) - Method in class java.awt.image.PackedColorModel
Checks if the specified SampleModel is compatible with this ColorModel.
isCompatibleValue(Object) - Method in class java.awt.RenderingHints.Key
Returns true if the specified object is a valid value for this Key.
isCompatibleWith(String) - Method in class java.lang.Package
Compare this package's specification version with a desired version.
isCompilationTimeMonitoringSupported() - Method in interface java.lang.management.CompilationMXBean
Tests if the Java virtual machine supports the monitoring of compilation time.
isComplete() - Method in interface javax.security.sasl.SaslClient
Determines whether the authentication exchange has completed.
isComplete() - Method in interface javax.security.sasl.SaslServer
Determines whether the authentication exchange has completed.
isCompletedAbnormally() - Method in class java.util.concurrent.ForkJoinTask
Returns true if this task threw an exception or was cancelled.
isCompletedExceptionally() - Method in class java.util.concurrent.CompletableFuture
Returns true if this CompletableFuture completed exceptionally, in any way.
isCompletedNormally() - Method in class java.util.concurrent.ForkJoinTask
Returns true if this task completed without throwing an exception and was not cancelled.
isCompletelyDirty(JComponent) - Method in class javax.swing.RepaintManager
Convenience method that returns true if aComponent will be completely painted during the next paintDirtyRegions().
isComponent() - Method in class java.awt.font.GlyphMetrics
Returns true if this is a component glyph.
isComponentPartOfCurrentMenu(Component) - Method in class javax.swing.MenuSelectionManager
Return true if c is part of the currently used menu
isCompositionEnabled() - Method in class java.awt.im.InputContext
Determines whether the current input method is enabled for composition.
isCompositionEnabled() - Method in interface java.awt.im.spi.InputMethod
Determines whether this input method is enabled.
isCompressionLossless() - Method in class javax.imageio.ImageWriteParam
Returns true if the current compression type provides lossless compression.
isCompressionLossless() - Method in class javax.imageio.plugins.jpeg.JPEGImageWriteParam
Returns false since the JPEG plug-in only supports lossy compression.
isComputerNode(File) - Method in class javax.swing.filechooser.FileSystemView
Used by UI classes to decide whether to display a special icon for a computer node, e.g.
isConnectable() - Method in class java.nio.channels.SelectionKey
Tests whether this key's channel has either finished, or failed to finish, its socket-connection operation.
isConnected() - Method in class java.net.DatagramSocket
Returns the connection state of the socket.
isConnected() - Method in class java.net.Socket
Returns the connection state of the socket.
isConnected() - Method in class java.nio.channels.DatagramChannel
Tells whether or not this channel's socket is connected.
isConnected() - Method in class java.nio.channels.SocketChannel
Tells whether or not this channel's network socket is connected.
isConnectionPending() - Method in class java.nio.channels.SocketChannel
Tells whether or not a connection operation is in progress on this channel.
isConstrained() - Method in class java.beans.PropertyDescriptor
Attempted updates to "Constrained" properties will cause a "VetoableChange" event to get fired when the property is changed.
isConsumed() - Method in class java.awt.AWTEvent
Returns whether this event has been consumed.
isConsumed() - Method in class java.awt.event.InputEvent
Returns whether or not this event has been consumed.
isConsumed() - Method in class java.awt.event.InputMethodEvent
Returns whether or not this event has been consumed.
isConsumer(ImageConsumer) - Method in class java.awt.image.FilteredImageSource
Determines whether an ImageConsumer is on the list of consumers currently interested in data for this image.
isConsumer(ImageConsumer) - Method in interface java.awt.image.ImageProducer
Determines if a specified ImageConsumer object is currently registered with this ImageProducer as one of its consumers.
isConsumer(ImageConsumer) - Method in class java.awt.image.MemoryImageSource
Determines if an ImageConsumer is on the list of consumers currently interested in data for this image.
isConsumer(ImageConsumer) - Method in class java.awt.image.renderable.RenderableImageProducer
Determine if an ImageConsumer is on the list of consumers currently interested in data for this image.
isContentAreaFilled() - Method in class javax.swing.AbstractButton
Gets the contentAreaFilled property.
isContextual() - Method in class java.awt.font.NumericShaper
Returns a boolean indicating whether or not this shaper shapes contextually.
isContinuousLayout() - Method in class javax.swing.JSplitPane
Gets the continuousLayout property.
isContinuousLayout() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Determines whether the JSplitPane is set to use a continuous layout.
isControlDown() - Method in class java.awt.event.InputEvent
Returns whether or not the Control modifier is down on this event.
isControlSupported(Control.Type) - Method in interface javax.sound.sampled.Line
Indicates whether the line supports a control of the specified type.
isConversionSupported(AudioFormat.Encoding, AudioFormat) - Static method in class javax.sound.sampled.AudioSystem
Indicates whether an audio input stream of the specified encoding can be obtained from an audio input stream that has the specified format.
isConversionSupported(AudioFormat, AudioFormat) - Static method in class javax.sound.sampled.AudioSystem
Indicates whether an audio input stream of a specified format can be obtained from an audio input stream of another specified format.
isConversionSupported(AudioFormat.Encoding, AudioFormat) - Method in class javax.sound.sampled.spi.FormatConversionProvider
Indicates whether the format converter supports conversion to a particular encoding from a particular format.
isConversionSupported(AudioFormat, AudioFormat) - Method in class javax.sound.sampled.spi.FormatConversionProvider
Indicates whether the format converter supports conversion to one particular format from another.
isCritical() - Method in interface java.security.cert.Extension
Gets the extension's criticality setting.
isCritical() - Method in interface java.security.cert.PolicyNode
Returns the criticality indicator of the certificate policy extension in the most recently processed certificate.
isCritical() - Method in class javax.naming.ldap.BasicControl
Determines the control's criticality.
isCritical() - Method in interface javax.naming.ldap.Control
Determines the criticality of the LDAP control.
isCryptoAllowed(Key) - Method in class javax.crypto.ExemptionMechanism
Returns whether the result blob has been generated successfully by this exemption mechanism.
isCS_sRGB() - Method in class java.awt.color.ColorSpace
Returns true if the ColorSpace is CS_sRGB.
isCurrency(int) - Method in interface java.sql.ResultSetMetaData
Indicates whether the designated column is a cash value.
isCurrency(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl
Indicates whether a value stored in the designated column is a cash value.
isCurrent() - Method in class javax.security.auth.kerberos.KerberosTicket
Determines if this ticket is still current.
isCurrent() - Method in interface javax.security.auth.Refreshable
Determine if this Object is current.
isCurrentServiceInvalidNow() - Method in class java.beans.beancontext.BeanContextServiceRevokedEvent
Reports if the current service is being forcibly revoked, in which case the references are now invalidated and unusable.
isCurrentThreadCpuTimeSupported() - Method in interface java.lang.management.ThreadMXBean
Tests if the Java virtual machine supports CPU time measurement for the current thread.
isCursorSet() - Method in class java.awt.Component
Returns whether the cursor has been explicitly set for this Component.
isCustomMarshaled(Class) - Method in interface javax.rmi.CORBA.ValueHandler
Indicates whether the given class performs custom or default marshaling.
isCyclic() - Method in class java.awt.GradientPaint
Returns true if the gradient cycles repeatedly between the two colors C1 and C2.
isDaemon() - Method in class java.lang.Thread
Tests if this thread is a daemon thread.
isDaemon() - Method in class java.lang.ThreadGroup
Tests if this thread group is a daemon thread group.
isDataFlavorAvailable(DataFlavor) - Method in class java.awt.datatransfer.Clipboard
Returns whether or not the current contents of this clipboard can be provided in the specified DataFlavor.
isDataFlavorSupported(DataFlavor) - Method in class java.awt.datatransfer.StringSelection
Returns whether the requested flavor is supported by this Transferable.
isDataFlavorSupported(DataFlavor) - Method in interface java.awt.datatransfer.Transferable
Returns whether or not the specified data flavor is supported for this object.
isDataFlavorSupported(DataFlavor) - Method in class java.awt.dnd.DropTargetContext
This method returns a boolean indicating if the given DataFlavor is supported by this DropTargetContext.
isDataFlavorSupported(DataFlavor) - Method in class java.awt.dnd.DropTargetContext.TransferableProxy
Returns whether or not the specified data flavor is supported by the encapsulated transferable.
isDataFlavorSupported(DataFlavor) - Method in class java.awt.dnd.DropTargetDragEvent
This method returns a boolean indicating if the specified DataFlavor is supported.
isDataFlavorSupported(DataFlavor) - Method in class java.awt.dnd.DropTargetDropEvent
This method returns a boolean indicating if the specified DataFlavor is available from the source.
isDataFlavorSupported(DataFlavor) - Method in class javax.activation.DataHandler
Returns whether the specified data flavor is supported for this object.
isDataFlavorSupported(DataFlavor) - Method in class javax.swing.TransferHandler.TransferSupport
Returns whether or not the given data flavor is supported.
isDateBased() - Method in enum java.time.temporal.ChronoField
Checks if this field represents a component of a date.
isDateBased() - Method in enum java.time.temporal.ChronoUnit
Checks if this unit is a date unit.
isDateBased() - Method in interface java.time.temporal.TemporalField
Checks if this field represents a component of a date.
isDateBased() - Method in interface java.time.temporal.TemporalUnit
Checks if this unit represents a component of a date.
isDaylightSavings(Instant) - Method in class java.time.zone.ZoneRules
Checks if the specified instant is in daylight savings.
isDecimalSeparatorAlwaysShown() - Method in class java.text.DecimalFormat
Allows you to get the behavior of the decimal separator with integers.
isDeclared(int) - Method in interface org.xml.sax.ext.Attributes2
Returns false unless the attribute was declared in the DTD.
isDeclared(String) - Method in interface org.xml.sax.ext.Attributes2
Returns false unless the attribute was declared in the DTD.
isDeclared(String, String) - Method in interface org.xml.sax.ext.Attributes2
Returns false unless the attribute was declared in the DTD.
isDeclared(int) - Method in class org.xml.sax.ext.Attributes2Impl
Returns the current value of the attribute's "declared" flag.
isDeclared(String, String) - Method in class org.xml.sax.ext.Attributes2Impl
Returns the current value of the attribute's "declared" flag.
isDeclared(String) - Method in class org.xml.sax.ext.Attributes2Impl
Returns the current value of the attribute's "declared" flag.
isDefault() - Method in class java.lang.reflect.Method
Returns true if this method is a default method; returns false otherwise.
isDefault() - Method in interface javax.lang.model.element.ExecutableElement
Returns true if this method is a default method and returns false otherwise.
isDefaultButton() - Method in class javax.swing.JButton
Gets the value of the defaultButton property, which if true means that this button is the current default button for its JRootPane.
isDefaultCapable() - Method in class javax.swing.JButton
Gets the value of the defaultCapable property.
isDefaultLookAndFeelDecorated() - Static method in class javax.swing.JDialog
Returns true if newly created JDialogs should have their Window decorations provided by the current look and feel.
isDefaultLookAndFeelDecorated() - Static method in class javax.swing.JFrame
Returns true if newly created JFrames should have their Window decorations provided by the current look and feel.
isDefaultNamespace(String) - Method in class javax.imageio.metadata.IIOMetadataNode
This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
isDefaultNamespace(String) - Method in interface org.w3c.dom.Node
This method checks if the specified namespaceURI is the default namespace or not.
isDefaultNamespaceDeclaration() - Method in interface javax.xml.stream.events.Namespace
returns true if this attribute declares the default namespace
isDefined(char) - Static method in class java.lang.Character
Determines if a character is defined in Unicode.
isDefined(int) - Static method in class java.lang.Character
Determines if a character (Unicode code point) is defined in Unicode.
isDefined(Object) - Method in class javax.swing.text.AbstractDocument.AbstractElement
Checks whether a given attribute is defined.
isDefined(Object) - Method in interface javax.swing.text.AttributeSet
Checks whether the named attribute has a value specified in the set without resolving through another attribute set.
isDefined(Object) - Method in class javax.swing.text.SimpleAttributeSet
Tells whether a given attribute is defined.
isDefined(Object) - Method in class javax.swing.text.StyleContext.NamedStyle
Checks whether a given attribute is defined.
isDefined(Object) - Method in class javax.swing.text.StyleContext.SmallAttributeSet
Checks whether a given attribute is defined.
isDefinitelyWritable(int) - Method in interface java.sql.ResultSetMetaData
Indicates whether a write on the designated column will definitely succeed.
isDefinitelyWritable(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl
Indicates whether a write operation on the designated column will definitely succeed.
isDelegated() - Method in class java.beans.beancontext.BeanContextChildSupport
Reports whether or not this class is a delegate of another.
isDeprecated(Element) - Method in interface javax.lang.model.util.Elements
Returns true if the element is deprecated, false otherwise.
isDerivedFrom(String, String, int) - Method in interface org.w3c.dom.TypeInfo
This method returns if there is a derivation between the reference type definition, i.e.
isDescendant(TreePath) - Method in class javax.swing.tree.TreePath
Returns true if aTreePath is a descendant of this TreePath.
isDescendingFrom(Component, Component) - Static method in class javax.swing.SwingUtilities
Return true if a component a descends from a component b
isDesignTime() - Method in class java.beans.beancontext.BeanContextSupport
Reports whether or not this object is in currently in design time mode.
isDesignTime() - Static method in class java.beans.Beans
Test if we are in design-mode.
isDesignTime() - Method in interface java.beans.DesignMode
A value of true denotes that JavaBeans should behave in design time mode, a value of false denotes runtime behavior.
isDesktopSupported() - Static method in class java.awt.Desktop
Tests whether this class is supported on the current platform.
isDestroyed() - Method in class java.lang.ThreadGroup
Tests if this thread group has been destroyed.
isDestroyed() - Method in class java.security.KeyStore.PasswordProtection
Determines if password has been cleared.
isDestroyed() - Method in interface javax.security.auth.Destroyable
Determine if this Object has been destroyed.
isDestroyed() - Method in class javax.security.auth.kerberos.KerberosKey
Determines if this key has been destroyed.
isDestroyed() - Method in class javax.security.auth.kerberos.KerberosTicket
Determines if this ticket has been destroyed.
isDestroyed() - Method in class javax.security.auth.x500.X500PrivateCredential
Determines if the references to the X.509 certificate and private key in this object have been cleared.
isDeviceSupported(MidiDevice.Info) - Method in class javax.sound.midi.spi.MidiDeviceProvider
Indicates whether the device provider supports the device represented by the specified device info object.
isDigit(char) - Static method in class java.lang.Character
Determines if the specified character is a digit.
isDigit(int) - Static method in class java.lang.Character
Determines if the specified character (Unicode code point) is a digit.
isDirect() - Method in class java.nio.Buffer
Tells whether or not this buffer is direct.
isDirect() - Method in class java.nio.ByteBuffer
Tells whether or not this byte buffer is direct.
isDirect() - Method in class java.nio.CharBuffer
Tells whether or not this char buffer is direct.
isDirect() - Method in class java.nio.DoubleBuffer
Tells whether or not this double buffer is direct.
isDirect() - Method in class java.nio.FloatBuffer
Tells whether or not this float buffer is direct.
isDirect() - Method in class java.nio.IntBuffer
Tells whether or not this int buffer is direct.
isDirect() - Method in class java.nio.LongBuffer
Tells whether or not this long buffer is direct.
isDirect() - Method in class java.nio.ShortBuffer
Tells whether or not this short buffer is direct.
isDirectory() - Method in class java.io.File
Tests whether the file denoted by this abstract pathname is a directory.
isDirectory() - Method in interface java.nio.file.attribute.BasicFileAttributes
Tells whether the file is a directory.
isDirectory(Path, LinkOption...) - Static method in class java.nio.file.Files
Tests whether a file is a directory.
isDirectory() - Method in class java.util.zip.ZipEntry
Returns true if this is a directory entry.
isDirectorySelected() - Method in class javax.swing.plaf.basic.BasicFileChooserUI
Property to remember whether a directory is currently selected in the UI.
isDirectorySelectionEnabled() - Method in class javax.swing.JFileChooser
Convenience call that determines if directories are selectable based on the current file selection mode.
isDispatched() - Method in class java.awt.event.InvocationEvent
Returns true if the event is dispatched or any exception is thrown while dispatching, false otherwise.
isDispatchThread() - Static method in class java.awt.EventQueue
Returns true if the calling thread is the current AWT EventQueue's dispatch thread.
isDisplayable() - Method in class java.awt.Component
Determines whether this component is displayable.
isDisplayChangeSupported() - Method in class java.awt.GraphicsDevice
Returns true if this GraphicsDevice supports low-level display changes.
isDisposed() - Method in class javax.print.StreamPrintService
Returns a boolean indicating whether or not this StreamPrintService has been disposed.
isDocFlavorSupported(DocFlavor) - Method in interface javax.print.PrintService
Determines if this print service supports a specific DocFlavor.
isDomainPattern() - Method in class javax.management.ObjectName
Checks whether the object name is a pattern on the domain part.
isDone() - Method in class java.awt.geom.FlatteningPathIterator
Tests if the iteration is complete.
isDone() - Method in interface java.awt.geom.PathIterator
Tests if the iteration is complete.
isDone() - Method in class java.util.concurrent.CompletableFuture
Returns true if completed in any fashion: normally, exceptionally, or via cancellation.
isDone() - Method in class java.util.concurrent.ForkJoinTask
isDone() - Method in interface java.util.concurrent.Future
Returns true if this task completed.
isDone() - Method in class java.util.concurrent.FutureTask
isDone() - Method in class javax.swing.SwingWorker
Returns true if this task completed.
isDoubleBuffered() - Method in class java.awt.Component
Returns true if this component is painted to an offscreen image ("buffer") that's copied to the screen later.
isDoubleBuffered() - Method in class javax.swing.JComponent
Returns whether this component should use a buffer to paint.
isDoubleBufferingEnabled() - Method in class javax.swing.RepaintManager
Returns true if this RepaintManager is double buffered.
isDragging - Variable in class javax.swing.plaf.basic.BasicScrollBarUI
isDragging() - Method in class javax.swing.plaf.basic.BasicSliderUI
Returns true if the user is dragging the slider.
isDragging - Variable in class javax.swing.plaf.basic.BasicToolBarUI.DockingListener
isDragImageSupported() - Static method in class java.awt.dnd.DragSource
Reports whether or not drag Image support is available on the underlying platform.
isDrawingBuffer() - Method in class javax.swing.DebugGraphics
Returns the drawingBuffer value.
isDrive(File) - Method in class javax.swing.filechooser.FileSystemView
Used by UI classes to decide whether to display a special icon for drives or partitions, e.g.
isDrop() - Method in class javax.swing.TransferHandler.TransferSupport
Returns whether or not this TransferSupport represents a drop operation.
isDropLine(JTree.DropLocation) - Method in class javax.swing.plaf.basic.BasicTreeUI
Tells if a DropLocation should be indicated by a line between nodes.
isDuplicateToken() - Method in class org.ietf.jgss.MessageProp
Tests if this is a duplicate of an earlier token.
isDurationEstimated() - Method in enum java.time.temporal.ChronoUnit
Checks if the duration of the unit is an estimate.
isDurationEstimated() - Method in interface java.time.temporal.TemporalUnit
Checks if the duration of the unit is an estimate.
isDynamic() - Method in interface java.awt.image.renderable.ContextualRenderedImageFactory
Returns true if successive renderings (that is, calls to create(RenderContext, ParameterBlock)) with the same arguments may produce different results.
isDynamic() - Method in interface java.awt.image.renderable.RenderableImage
Returns true if successive renderings (that is, calls to createRendering() or createScaledRendering()) with the same arguments may produce different results.
isDynamic() - Method in class java.awt.image.renderable.RenderableImageOp
Returns true if successive renderings (that is, calls to createRendering() or createScaledRendering()) with the same arguments may produce different results.
isDynamicLayoutActive() - Method in class java.awt.Toolkit
Returns whether dynamic layout of Containers on resize is currently active (both set in program ( isDynamicLayoutSet() ) , and supported by the underlying operating system and/or window manager).
isDynamicLayoutSet() - Method in class java.awt.Toolkit
Returns whether the layout of Containers is validated dynamically during resizing, or statically, after resizing is complete.
isEchoOn() - Method in class javax.security.auth.callback.PasswordCallback
Return whether the password should be displayed as it is being typed.
isEditable() - Method in class java.awt.TextComponent
Indicates whether or not this text component is editable.
isEditable - Variable in class javax.swing.JComboBox
This protected field is implementation specific.
isEditable() - Method in class javax.swing.JComboBox
Returns true if the JComboBox is editable.
isEditable() - Method in class javax.swing.JTree
Returns true if the tree is editable.
isEditable() - Method in class javax.swing.plaf.basic.BasicTreeUI
isEditable() - Method in class javax.swing.text.JTextComponent
Returns the boolean indicating whether this TextComponent is editable or not.
isEditing() - Method in class javax.swing.JTable
Returns true if a cell is being edited.
isEditing() - Method in class javax.swing.JTree
Returns true if the tree is being edited.
isEditing(JTree) - Method in class javax.swing.plaf.basic.BasicTreeUI
Returns true if the tree is being edited.
isEditing(JTree) - Method in class javax.swing.plaf.multi.MultiTreeUI
Invokes the isEditing method on each UI handled by this object.
isEditing(JTree) - Method in class javax.swing.plaf.TreeUI
Returns true if the tree is being edited.
isEditValid() - Method in class javax.swing.JFormattedTextField
Returns true if the current value being edited is valid.
isElement(Object) - Method in class javax.xml.bind.JAXBIntrospector
Return true if object represents a JAXB element.
isElementContentWhitespace() - Method in interface org.w3c.dom.Text
Returns whether this text node contains element content whitespace, often abusively called "ignorable whitespace".
isEmpty() - Method in class java.awt.geom.Arc2D.Double
Determines whether the RectangularShape is empty.
isEmpty() - Method in class java.awt.geom.Arc2D.Float
Determines whether the RectangularShape is empty.
isEmpty() - Method in class java.awt.geom.Area
Tests whether this Area object encloses any area.
isEmpty() - Method in class java.awt.geom.Ellipse2D.Double
Determines whether the RectangularShape is empty.
isEmpty() - Method in class java.awt.geom.Ellipse2D.Float
Determines whether the RectangularShape is empty.
isEmpty() - Method in class java.awt.geom.Rectangle2D.Double
Determines whether the RectangularShape is empty.
isEmpty() - Method in class java.awt.geom.Rectangle2D.Float
Determines whether the RectangularShape is empty.
isEmpty() - Method in class java.awt.geom.RectangularShape
Determines whether the RectangularShape is empty.
isEmpty() - Method in class java.awt.geom.RoundRectangle2D.Double
Determines whether the RectangularShape is empty.
isEmpty() - Method in class java.awt.geom.RoundRectangle2D.Float
Determines whether the RectangularShape is empty.
isEmpty() - Method in class java.awt.Rectangle
Determines whether the RectangularShape is empty.
isEmpty() - Method in class java.awt.RenderingHints
Returns true if this RenderingHints contains no key-value mappings.
isEmpty() - Method in class java.beans.beancontext.BeanContextSupport
Reports whether or not this BeanContext is empty.
isEmpty() - Method in class java.lang.String
Returns true if, and only if, String.length() is 0.
isEmpty() - Method in class java.util.AbstractCollection
Returns true if this collection contains no elements.
isEmpty() - Method in class java.util.AbstractMap
Returns true if this map contains no key-value mappings.
isEmpty() - Method in class java.util.ArrayDeque
Returns true if this deque contains no elements.
isEmpty() - Method in class java.util.ArrayList
Returns true if this list contains no elements.
isEmpty() - Method in class java.util.BitSet
Returns true if this BitSet contains no bits that are set to true.
isEmpty() - Method in interface java.util.Collection
Returns true if this collection contains no elements.
isEmpty() - Method in class java.util.concurrent.ConcurrentHashMap
Returns true if this map contains no key-value mappings.
isEmpty() - Method in class java.util.concurrent.ConcurrentLinkedDeque
Returns true if this collection contains no elements.
isEmpty() - Method in class java.util.concurrent.ConcurrentLinkedQueue
Returns true if this queue contains no elements.
isEmpty() - Method in class java.util.concurrent.ConcurrentSkipListMap
Returns true if this map contains no key-value mappings.
isEmpty() - Method in class java.util.concurrent.ConcurrentSkipListSet
Returns true if this set contains no elements.
isEmpty() - Method in class java.util.concurrent.CopyOnWriteArrayList
Returns true if this list contains no elements.
isEmpty() - Method in class java.util.concurrent.CopyOnWriteArraySet
Returns true if this set contains no elements.
isEmpty() - Method in class java.util.concurrent.LinkedTransferQueue
Returns true if this queue contains no elements.
isEmpty() - Method in class java.util.concurrent.SynchronousQueue
Always returns true.
isEmpty() - Method in class java.util.Dictionary
Tests if this dictionary maps no keys to value.
isEmpty() - Method in class java.util.HashMap
Returns true if this map contains no key-value mappings.
isEmpty() - Method in class java.util.HashSet
Returns true if this set contains no elements.
isEmpty() - Method in class java.util.Hashtable
Tests if this hashtable maps no keys to values.
isEmpty() - Method in class java.util.IdentityHashMap
Returns true if this identity hash map contains no key-value mappings.
isEmpty() - Method in class java.util.jar.Attributes
Returns true if this Map contains no attributes.
isEmpty() - Method in interface java.util.List
Returns true if this list contains no elements.
isEmpty() - Method in interface java.util.Map
Returns true if this map contains no key-value mappings.
isEmpty() - Method in interface java.util.Set
Returns true if this set contains no elements.
isEmpty() - Method in class java.util.TreeSet
Returns true if this set contains no elements.
isEmpty() - Method in class java.util.Vector
Tests if this vector has no components.
isEmpty() - Method in class java.util.WeakHashMap
Returns true if this map contains no key-value mappings.
isEmpty() - Method in class javax.activation.MimeTypeParameterList
Determine whether or not this list is empty.
isEmpty() - Method in interface javax.management.openmbean.TabularData
Returns true if the number of CompositeData values (ie the number of rows) contained in this TabularData instance is zero.
isEmpty() - Method in class javax.management.openmbean.TabularDataSupport
Returns true if this TabularDataSupport instance contains no rows.
isEmpty() - Method in class javax.management.timer.Timer
Tests whether the list of timer notifications is empty.
isEmpty() - Method in interface javax.management.timer.TimerMBean
Tests whether the list of timer notifications is empty.
isEmpty() - Method in class javax.naming.CompositeName
Determines whether this composite name is empty.
isEmpty() - Method in class javax.naming.CompoundName
Determines whether this compound name is empty.
isEmpty() - Method in class javax.naming.ldap.LdapName
Determines whether this LDAP name is empty.
isEmpty() - Method in interface javax.naming.Name
Determines whether this name is empty.
isEmpty() - Method in interface javax.print.attribute.AttributeSet
Returns true if this attribute set contains no attributes.
isEmpty() - Method in class javax.print.attribute.HashAttributeSet
Returns true if this attribute set contains no attributes.
isEmpty() - Method in class javax.script.SimpleBindings
Returns true if this map contains no key-value mappings.
isEmpty() - Method in class javax.swing.DefaultListModel
Tests whether this list has any components.
isEmpty() - Method in class javax.swing.text.html.parser.Element
Check if empty
isEmpty() - Method in class javax.swing.text.SimpleAttributeSet
Checks whether the set of attributes is empty.
isEnabled() - Method in class java.awt.Component.AccessibleAWTComponent
Determines if the object is enabled.
isEnabled() - Method in class java.awt.Component
Determines whether this component is enabled.
isEnabled() - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild
Determine if the object is enabled.
isEnabled() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent
Determines if the object is enabled.
isEnabled() - Method in class java.awt.MenuItem
Checks whether this menu item is enabled.
isEnabled() - Method in interface javax.accessibility.AccessibleComponent
Determines if the object is enabled.
isEnabled() - Method in class javax.swing.AbstractAction
Returns true if the action is enabled.
isEnabled() - Method in interface javax.swing.Action
Returns the enabled state of the Action.
isEnabled() - Method in interface javax.swing.ButtonModel
Indicates if the button can be selected or triggered by an input device, such as a mouse pointer.
isEnabled() - Method in class javax.swing.DefaultButtonModel
Indicates if the button can be selected or triggered by an input device, such as a mouse pointer.
isEnabled() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild
isEnabled() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell
Determines if the object is enabled.
isEnabled() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode
isEnabled() - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI.CloseAction
isEnabled() - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI.MaximizeAction
isEnabled() - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI.MinimizeAction
isEnabled() - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI.NavigateAction
isEnabled() - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI.OpenAction
isEnabled() - Method in class javax.swing.plaf.basic.BasicSliderUI.ActionScroller
isEnabled() - Method in class javax.swing.plaf.basic.BasicTreeUI.TreeCancelEditingAction
isEnabled() - Method in class javax.swing.plaf.basic.BasicTreeUI.TreeHomeAction
isEnabled() - Method in class javax.swing.plaf.basic.BasicTreeUI.TreeIncrementAction
isEnabled() - Method in class javax.swing.plaf.basic.BasicTreeUI.TreePageAction
isEnabled() - Method in class javax.swing.plaf.basic.BasicTreeUI.TreeToggleAction
isEnabled() - Method in class javax.swing.plaf.basic.BasicTreeUI.TreeTraverseAction
isEnabled() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
isEnabled() - Method in class javax.swing.ToolTipManager
Returns true if this object is enabled.
isEnabled() - Method in class javax.xml.ws.WebServiceFeature
Returns true if this feature is enabled.
isEnabledAt(int) - Method in class javax.swing.JTabbedPane
Returns whether or not the tab at index is currently enabled.
isEndDocument() - Method in interface javax.xml.stream.events.XMLEvent
A utility function to check if this event is an EndDocument.
isEndElement() - Method in interface javax.xml.stream.events.XMLEvent
A utility function to check if this event is a EndElement.
isEndElement() - Method in class javax.xml.stream.util.StreamReaderDelegate
isEndElement() - Method in interface javax.xml.stream.XMLStreamReader
Returns true if the cursor points to an end tag (otherwise false)
isEnqueued() - Method in class java.lang.ref.Reference
Tells whether or not this reference object has been enqueued, either by the program or by the garbage collector.
isEntityReference() - Method in interface javax.xml.stream.events.XMLEvent
A utility function to check if this event is an EntityReference.
isEnum() - Method in class java.lang.Class
Returns true if and only if this class was declared as an enum in the source code.
isEnumConstant() - Method in class java.lang.reflect.Field
Returns true if this field represents an element of an enumerated type; returns false otherwise.
isEqual(byte[], byte[]) - Static method in class java.security.MessageDigest
Compares two digests for equality.
isEqual(ChronoLocalDate) - Method in interface java.time.chrono.ChronoLocalDate
Checks if this date is equal to the specified date ignoring the chronology.
isEqual(ChronoLocalDateTime<?>) - Method in interface java.time.chrono.ChronoLocalDateTime
Checks if this date-time is equal to the specified date-time ignoring the chronology.
isEqual(ChronoZonedDateTime<?>) - Method in interface java.time.chrono.ChronoZonedDateTime
Checks if the instant of this date-time is equal to that of the specified date-time.
isEqual(ChronoLocalDate) - Method in class java.time.LocalDate
Checks if this date is equal to the specified date.
isEqual(ChronoLocalDateTime<?>) - Method in class java.time.LocalDateTime
Checks if this date-time is equal to the specified date-time.
isEqual(OffsetDateTime) - Method in class java.time.OffsetDateTime
Checks if the instant of this date-time is equal to that of the specified date-time.
isEqual(OffsetTime) - Method in class java.time.OffsetTime
Checks if the instant of this OffsetTime is equal to that of the specified time applying both times to a common date.
isEqual(Object) - Static method in interface java.util.function.Predicate
Returns a predicate that tests if two arguments are equal according to Objects.equals(Object, Object).
isEqual(AttributeSet) - Method in class javax.swing.text.AbstractDocument.AbstractElement
Checks whether two attribute sets are equal.
isEqual(AttributeSet) - Method in interface javax.swing.text.AttributeSet
Determines if the two attribute sets are equivalent.
isEqual(AttributeSet) - Method in class javax.swing.text.SimpleAttributeSet
Compares two attribute sets.
isEqual(AttributeSet) - Method in class javax.swing.text.StyleContext.NamedStyle
Checks whether two attribute sets are equal.
isEqual(AttributeSet) - Method in class javax.swing.text.StyleContext.SmallAttributeSet
Checks whether two attribute sets are equal.
isEqualNode(Node) - Method in class javax.imageio.metadata.IIOMetadataNode
This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
isEqualNode(Node) - Method in interface org.w3c.dom.Node
Tests whether two nodes are equal.
isError() - Method in class java.nio.charset.CoderResult
Tells whether or not this object describes an error condition.
isErrorAny() - Method in class java.awt.MediaTracker
Checks the error status of all of the images.
isErrorID(int) - Method in class java.awt.MediaTracker
Checks the error status of all of the images tracked by this media tracker with the specified identifier.
isEstablished() - Method in interface org.ietf.jgss.GSSContext
Used during context establishment to determine the state of the context.
isEventDispatchThread() - Static method in class javax.swing.SwingUtilities
Returns true if the current thread is an AWT event dispatching thread.
isExecutable(Path) - Static method in class java.nio.file.Files
Tests whether a file is executable.
isExpanded(TreePath) - Method in class javax.swing.JTree
Returns true if the node identified by the path is currently expanded,
isExpanded(int) - Method in class javax.swing.JTree
Returns true if the node at the specified display row is currently expanded.
isExpanded(TreePath) - Method in class javax.swing.tree.AbstractLayoutCache
Returns true if the value identified by row is currently expanded.
isExpanded(TreePath) - Method in class javax.swing.tree.FixedHeightLayoutCache
Returns true if the value identified by row is currently expanded.
isExpanded(TreePath) - Method in class javax.swing.tree.VariableHeightLayoutCache
Returns true if the value identified by path is currently expanded.
isExpandEntityReferences() - Method in class javax.xml.parsers.DocumentBuilderFactory
Indicates whether or not the factory is configured to produce parsers which expand entity reference nodes.
isExpert() - Method in class java.beans.FeatureDescriptor
The "expert" flag is used to distinguish between those features that are intended for expert users from those that are intended for normal users.
isExplicitPolicyRequired() - Method in class java.security.cert.PKIXParameters
Checks if explicit policy is required.
isFair() - Method in class java.util.concurrent.locks.ReentrantLock
Returns true if this lock has fairness set true.
isFair() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock
Returns true if this lock has fairness set true.
isFair() - Method in class java.util.concurrent.Semaphore
Returns true if this semaphore has fairness set true.
isFeatureSupported(String) - Method in class javax.xml.crypto.dom.DOMStructure
isFeatureSupported(String) - Method in class javax.xml.crypto.dsig.keyinfo.KeyInfoFactory
Indicates whether a specified feature is supported.
isFeatureSupported(String) - Method in class javax.xml.crypto.dsig.XMLSignatureFactory
Indicates whether a specified feature is supported.
isFeatureSupported(String) - Method in interface javax.xml.crypto.XMLStructure
Indicates whether a specified feature is supported.
isField() - Method in enum javax.lang.model.element.ElementKind
Returns true if this is a kind of field: either FIELD or ENUM_CONSTANT.
isFile() - Method in class java.io.File
Tests whether the file denoted by this abstract pathname is a normal file.
isFileHidingEnabled() - Method in class javax.swing.JFileChooser
Returns true if hidden files are not shown in the file chooser; otherwise, returns false.
isFileSelectionEnabled() - Method in class javax.swing.JFileChooser
Convenience call that determines if files are selectable based on the current file selection mode.
isFileSystem(File) - Method in class javax.swing.filechooser.FileSystemView
Checks if f represents a real directory or file as opposed to a special folder such as "Desktop".
isFileSystemRoot(File) - Method in class javax.swing.filechooser.FileSystemView
Is dir the root of a tree in the file system, such as a drive or partition.
isFileTypeSupported(int) - Static method in class javax.sound.midi.MidiSystem
Indicates whether file writing support for the specified MIDI file type is provided by the system.
isFileTypeSupported(int, Sequence) - Static method in class javax.sound.midi.MidiSystem
Indicates whether a MIDI file of the file type specified can be written from the sequence indicated.
isFileTypeSupported(int) - Method in class javax.sound.midi.spi.MidiFileWriter
Indicates whether file writing support for the specified MIDI file type is provided by this file writer.
isFileTypeSupported(int, Sequence) - Method in class javax.sound.midi.spi.MidiFileWriter
Indicates whether a MIDI file of the file type specified can be written from the sequence indicated.
isFileTypeSupported(AudioFileFormat.Type) - Static method in class javax.sound.sampled.AudioSystem
Indicates whether file writing support for the specified file type is provided by the system.
isFileTypeSupported(AudioFileFormat.Type, AudioInputStream) - Static method in class javax.sound.sampled.AudioSystem
Indicates whether an audio file of the specified file type can be written from the indicated audio input stream.
isFileTypeSupported(AudioFileFormat.Type) - Method in class javax.sound.sampled.spi.AudioFileWriter
Indicates whether file writing support for the specified file type is provided by this audio file writer.
isFileTypeSupported(AudioFileFormat.Type, AudioInputStream) - Method in class javax.sound.sampled.spi.AudioFileWriter
Indicates whether an audio file of the type specified can be written from the audio input stream indicated.
isFinal(int) - Static method in class java.lang.reflect.Modifier
Return true if the integer argument includes the final modifier, false otherwise.
isFinite(double) - Static method in class java.lang.Double
Returns true if the argument is a finite floating-point value; returns false otherwise (for NaN and infinity arguments).
isFinite(float) - Static method in class java.lang.Float
Returns true if the argument is a finite floating-point value; returns false otherwise (for NaN and infinity arguments).
isFirst() - Method in interface java.sql.ResultSet
Retrieves whether the cursor is on the first row of this ResultSet object.
isFixed() - Method in class java.time.temporal.ValueRange
Is the value range fixed and fully known.
isFixedOffset() - Method in class java.time.zone.ZoneRules
Checks of the zone rules are fixed, such that the offset never varies.
isFixedRowHeight() - Method in class javax.swing.JTree
Returns true if the height of each display row is a fixed size.
isFixedRowHeight() - Method in class javax.swing.tree.AbstractLayoutCache
Returns true if the height of each row is a fixed size.
isFlavorJavaFileListType() - Method in class java.awt.datatransfer.DataFlavor
Returns true if the DataFlavor specified represents a list of file objects.
isFlavorRemoteObjectType() - Method in class java.awt.datatransfer.DataFlavor
Returns true if the DataFlavor specified represents a remote object.
isFlavorSerializedObjectType() - Method in class java.awt.datatransfer.DataFlavor
Returns true if the DataFlavor specified represents a serialized object.
isFlavorTextType() - Method in class java.awt.datatransfer.DataFlavor
Returns whether this DataFlavor is a valid text flavor for this implementation of the Java platform.
isFloatable() - Method in class javax.swing.JToolBar
Gets the floatable property.
isFloating() - Method in class javax.swing.plaf.basic.BasicToolBarUI
isFloppyDrive(File) - Method in class javax.swing.filechooser.FileSystemView
Used by UI classes to decide whether to display a special icon for a floppy disk.
isFocusable() - Method in class java.awt.Component
Returns whether this Component can be focused.
isFocusableWindow() - Method in class java.awt.Window
Returns whether this Window can become the focused Window, that is, whether this Window or any of its subcomponents can become the focus owner.
isFocusCycleRoot(Container) - Method in class java.awt.Component
Returns whether the specified Container is the focus cycle root of this Component's focus traversal cycle.
isFocusCycleRoot(Container) - Method in class java.awt.Container
Returns whether the specified Container is the focus cycle root of this Container's focus traversal cycle.
isFocusCycleRoot() - Method in class java.awt.Container
Returns whether this Container is the root of a focus traversal cycle.
isFocusCycleRoot() - Method in class java.awt.Window
Always returns true because all Windows must be roots of a focus traversal cycle.
isFocusCycleRoot() - Method in class javax.swing.JInternalFrame
Always returns true because all JInternalFrames must be roots of a focus traversal cycle.
isFocused() - Method in class java.awt.Window
Returns whether this Window is focused.
isFocusManagerEnabled() - Static method in class javax.swing.FocusManager
Deprecated.
As of 1.4, replaced by KeyboardFocusManager.getDefaultFocusTraversalPolicy()
isFocusOwner() - Method in class java.awt.Component
Returns true if this Component is the focus owner.
isFocusPainted() - Method in class javax.swing.AbstractButton
Gets the paintFocus property.
isFocusTraversable() - Method in class java.awt.Component.AccessibleAWTComponent
Returns whether this object can accept focus or not.
isFocusTraversable() - Method in class java.awt.Component
Deprecated.
As of 1.4, replaced by isFocusable().
isFocusTraversable() - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild
Returns whether this object can accept focus or not.
isFocusTraversable() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent
Returns whether this object can accept focus or not.
isFocusTraversable() - Method in interface javax.accessibility.AccessibleComponent
Returns whether this object can accept focus or not.
isFocusTraversable() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild
isFocusTraversable() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell
isFocusTraversable() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode
isFocusTraversable() - Method in class javax.swing.plaf.basic.BasicArrowButton
Returns whether the arrow button should get the focus.
isFocusTraversable(JComboBox) - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Determines if the JComboBox is focus traversable.
isFocusTraversable() - Method in class javax.swing.plaf.basic.BasicComboPopup
Overridden to unconditionally return false.
isFocusTraversable() - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane.SystemMenuBar
isFocusTraversable(JComboBox) - Method in class javax.swing.plaf.ComboBoxUI
Determine whether or not the combo box itself is traversable
isFocusTraversable() - Method in class javax.swing.plaf.metal.MetalComboBoxButton
isFocusTraversable(JComboBox) - Method in class javax.swing.plaf.multi.MultiComboBoxUI
Invokes the isFocusTraversable method on each UI handled by this object.
isFocusTraversable() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
isFocusTraversalPolicyProvider() - Method in class java.awt.Container
Returns whether this container provides focus traversal policy.
isFocusTraversalPolicySet() - Method in class java.awt.Container
Returns whether the focus traversal policy has been explicitly set for this Container.
isFontSet() - Method in class java.awt.Component
Returns whether the font has been explicitly set for this Component.
isForegroundSet() - Method in class java.awt.Component
Returns whether the foreground color has been explicitly set for this Component.
isFormatLossless() - Method in class javax.imageio.spi.ImageWriterSpi
Returns true if the format that this writer outputs preserves pixel data bit-accurately.
isFormatSupported(AudioFormat) - Method in class javax.sound.sampled.DataLine.Info
Indicates whether this data line supports a particular audio format.
isFormattedOutput() - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl
Convenience method for getting the formatted output flag.
isForwardable() - Method in class javax.security.auth.kerberos.KerberosTicket
Determines if this ticket is forwardable.
isForwardCheckingSupported() - Method in interface java.security.cert.CertPathChecker
Indicates if forward checking is supported.
isForwardCheckingSupported() - Method in class java.security.cert.PKIXCertPathChecker
Indicates if forward checking is supported.
isForwarded() - Method in class javax.security.auth.kerberos.KerberosTicket
Determines if this ticket had been forwarded or was issued based on authentication involving a forwarded ticket-granting ticket.
isFragment() - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl
Convenience method for getting the fragment flag.
isFrameStateSupported(int) - Method in class java.awt.Toolkit
Returns whether Toolkit supports this state for Frames.
isFreeStanding - Variable in class javax.swing.plaf.metal.MetalScrollBarUI
isFullScreenRequired() - Method in class java.awt.BufferCapabilities
isFullScreenSupported() - Method in class java.awt.GraphicsDevice
Returns true if this GraphicsDevice supports full-screen exclusive mode.
isFunctionalInterface(TypeElement) - Method in interface javax.lang.model.util.Elements
Returns true if the type element is a functional interface, false otherwise.
isGap() - Method in class java.time.zone.ZoneOffsetTransition
Does this transition represent a gap in the local time-line.
isGapToken() - Method in class org.ietf.jgss.MessageProp
Tests if an expected token was not received, i.e., one or more predecessor tokens have not yet been successfully processed.
isGeneral() - Method in class javax.swing.text.html.parser.Entity
Returns true if it is a general entity.
isGlobalScope() - Method in class javax.xml.bind.JAXBElement
Returns true iff this xml element declaration is global.
isGraphicsConfigSupported(GraphicsConfiguration) - Method in class java.awt.GraphicsConfigTemplate
Returns a boolean indicating whether or not the specified GraphicsConfiguration can be used to create a drawing surface that supports the indicated features.
isGroupingUsed() - Method in class java.text.NumberFormat
Returns true if grouping is used in this format.
isGuiAvailable() - Static method in class java.beans.Beans
Determines whether beans can assume a GUI is available.
isHeadless() - Static method in class java.awt.GraphicsEnvironment
Tests whether or not a display, keyboard, and mouse can be supported in this environment.
isHeadlessInstance() - Method in class java.awt.GraphicsEnvironment
Returns whether or not a display, keyboard, and mouse can be supported in this graphics environment.
isHeldByCurrentThread() - Method in class java.util.concurrent.locks.ReentrantLock
Queries if this lock is held by the current thread.
isHeldByCurrentThread() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock
Queries if this write lock is held by the current thread.
isHeldExclusively() - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer
Returns true if synchronization is held exclusively with respect to the current (calling) thread.
isHeldExclusively() - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer
Returns true if synchronization is held exclusively with respect to the current (calling) thread.
isHidden() - Method in class java.beans.FeatureDescriptor
The "hidden" flag is used to identify features that are intended only for tool use, and which should not be exposed to humans.
isHidden() - Method in class java.io.File
Tests whether the file named by this abstract pathname is a hidden file.
isHidden() - Method in interface java.nio.file.attribute.DosFileAttributes
Returns the value of the hidden attribute.
isHidden(Path) - Static method in class java.nio.file.Files
Tells whether or not a file is considered hidden.
isHidden(Path) - Method in class java.nio.file.spi.FileSystemProvider
Tells whether or not a file is considered hidden.
isHidden(File) - Method in class javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView
isHiddenFile(File) - Method in class javax.swing.filechooser.FileSystemView
Returns whether a file is hidden or not.
isHighSurrogate(char) - Static method in class java.lang.Character
Determines if the given char value is a Unicode high-surrogate code unit (also known as leading-surrogate code unit).
isHorizontal() - Method in class java.awt.ComponentOrientation
Are lines horizontal? This will return true for horizontal, left-to-right writing systems such as Roman.
isHTMLString(String) - Static method in class javax.swing.plaf.basic.BasicHTML
Check the given string to see if it should trigger the html rendering logic in a non-text component that supports html rendering.
isHttpOnly() - Method in class java.net.HttpCookie
Returns true if this cookie contains the HttpOnly attribute.
isIcon - Variable in class javax.swing.JInternalFrame
The frame has been iconified.
isIcon() - Method in class javax.swing.JInternalFrame
Returns whether the JInternalFrame is currently iconified.
isIconifiable() - Method in class javax.swing.JInternalFrame
Gets the iconable property, which by default is false.
isIconOnly() - Method in class javax.swing.plaf.metal.MetalComboBoxButton
isId() - Method in interface org.w3c.dom.Attr
Returns whether this attribute is known to be of type ID (i.e.
isIdAttribute(int) - Method in class javax.xml.validation.TypeInfoProvider
Returns true if the specified attribute is determined to be ID.
isIdentifier(CharSequence) - Static method in enum javax.lang.model.SourceVersion
Returns whether or not name is a syntactically valid identifier (simple name) or keyword in the latest source version.
isIdentifierIgnorable(char) - Static method in class java.lang.Character
Determines if the specified character should be regarded as an ignorable character in a Java identifier or a Unicode identifier.
isIdentifierIgnorable(int) - Static method in class java.lang.Character
Determines if the specified character (Unicode code point) should be regarded as an ignorable character in a Java identifier or a Unicode identifier.
isIdentity() - Method in class java.awt.font.TransformAttribute
Returns true if the wrapped transform is an identity transform.
isIdentity() - Method in class java.awt.geom.AffineTransform
Returns true if this AffineTransform is an identity transform.
isIdeographic(int) - Static method in class java.lang.Character
Determines if the specified character (Unicode code point) is a CJKV (Chinese, Japanese, Korean and Vietnamese) ideograph, as defined by the Unicode Standard.
isIgnorableWhiteSpace() - Method in interface javax.xml.stream.events.Characters
Return true if this is ignorableWhiteSpace.
isIgnoringComments() - Method in class javax.xml.parsers.DocumentBuilderFactory
Indicates whether or not the factory is configured to produce parsers which ignores comments.
isIgnoringElementContentWhitespace() - Method in class javax.xml.parsers.DocumentBuilderFactory
Indicates whether or not the factory is configured to produce parsers which ignore ignorable whitespace in element content.
isIgnoringMetadata() - Method in class javax.imageio.ImageReader
Returns true if the current input source has been marked as allowing metadata to be ignored by passing true as the ignoreMetadata argument to the setInput method.
isImageAutoSize() - Method in class java.awt.TrayIcon
Returns the value of the auto-size property.
isImageTiled(int) - Method in class javax.imageio.ImageReader
Returns true if the image is organized into tiles, that is, equal-sized non-overlapping rectangles.
isImplicit() - Method in class java.lang.reflect.Parameter
Returns true if this parameter is implicitly declared in source code; returns false otherwise.
isInboundDone() - Method in class javax.net.ssl.SSLEngine
Returns whether SSLEngine.unwrap(ByteBuffer, ByteBuffer) will accept any more inbound data messages.
isInDefaultEventSet() - Method in class java.beans.EventSetDescriptor
Reports if an event set is in the "default" set.
isIndeterminate() - Method in class javax.swing.JProgressBar
Returns the value of the indeterminate property.
ISINDEX - Static variable in class javax.swing.text.html.HTML.Tag
isindex - Variable in class javax.swing.text.html.parser.DTD
IsindexAction() - Constructor for class javax.swing.text.html.HTMLDocument.HTMLReader.IsindexAction
isIndexSelected(int) - Method in class java.awt.List
Determines if the specified item in this scrolling list is selected.
isInfinite(double) - Static method in class java.lang.Double
Returns true if the specified number is infinitely large in magnitude, false otherwise.
isInfinite() - Method in class java.lang.Double
Returns true if this Double value is infinitely large in magnitude, false otherwise.
isInfinite(float) - Static method in class java.lang.Float
Returns true if the specified number is infinitely large in magnitude, false otherwise.
isInfinite() - Method in class java.lang.Float
Returns true if this Float value is infinitely large in magnitude, false otherwise.
isInherited() - Method in class javax.swing.text.html.CSS.Attribute
Indicates if the attribute should be inherited from the parent or not.
isInitial() - Method in class javax.security.auth.kerberos.KerberosTicket
Determines if this ticket was issued using the Kerberos AS-Exchange protocol, and not issued based on some ticket-granting ticket.
isInitialized() - Method in class javax.annotation.processing.AbstractProcessor
Returns true if this object has been initialized, false otherwise.
isInitiator() - Method in interface org.ietf.jgss.GSSContext
Determines if this is the context initiator.
isInNative() - Method in class java.lang.management.ThreadInfo
Tests if the thread associated with this ThreadInfo is executing native code via the Java Native Interface (JNI).
isInProgress() - Method in class javax.swing.undo.CompoundEdit
Returns true if this edit is in progress--that is, it has not received end.
isInputShutdown() - Method in class java.net.Socket
Returns whether the read-half of the socket connection is closed.
isInRelationService() - Method in class javax.management.relation.RelationSupport
Returns an internal flag specifying if the object is still handled by the Relation Service.
isInRelationService() - Method in interface javax.management.relation.RelationSupportMBean
Returns an internal flag specifying if the object is still handled by the Relation Service.
isInsert() - Method in class javax.swing.JList.DropLocation
Returns whether or not this location represents an insert location.
isInsertColumn() - Method in class javax.swing.JTable.DropLocation
Returns whether or not this location represents an insert of a column.
isInsertRow() - Method in class javax.swing.JTable.DropLocation
Returns whether or not this location represents an insert of a row.
isInstance(Object) - Method in class java.lang.Class
Determines if the specified Object is assignment-compatible with the object represented by this Class.
isInstanceOf(Object, Class<?>) - Static method in class java.beans.Beans
Check if a bean can be viewed as a given target type.
isInstanceOf(ObjectName, String) - Method in interface javax.management.MBeanServer
isInstanceOf(ObjectName, String) - Method in interface javax.management.MBeanServerConnection
Returns true if the MBean specified is an instance of the specified class, false otherwise.
isInstanceOf(StringValueExp) - Static method in class javax.management.Query
Returns a query expression that represents an inheritance constraint on an MBean class.
isInstanceOf(ObjectName, String, Subject) - Method in interface javax.management.remote.rmi.RMIConnection
Handles the method MBeanServerConnection.isInstanceOf(ObjectName, String).
isInstanceOf(ObjectName, String, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl
isInstanceOf(ObjectName, String, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub
isInState(T) - Method in class javax.swing.plaf.nimbus.State
Gets whether the specified JComponent is in the custom state represented by this class.
isInterface() - Method in class java.lang.Class
Determines if the specified Class object represents an interface type.
isInterface(int) - Static method in class java.lang.reflect.Modifier
Return true if the integer argument includes the interface modifier, false otherwise.
isInterface() - Method in enum javax.lang.model.element.ElementKind
Returns true if this is a kind of interface: either INTERFACE or ANNOTATION_TYPE.
isInterrupted() - Method in class java.lang.Thread
Tests whether this thread has been interrupted.
isIntValue() - Method in class java.time.temporal.ValueRange
Checks if all values in the range fit in an int.
isIPv4CompatibleAddress() - Method in class java.net.Inet6Address
Utility routine to check if the InetAddress is an IPv4 compatible IPv6 address.
isIs() - Method in class javax.management.MBeanAttributeInfo
Indicates if this attribute has an "is" getter.
isIs() - Method in interface javax.management.openmbean.OpenMBeanAttributeInfo
Returns true if the attribute described by this OpenMBeanAttributeInfo instance is accessed through a isXXX getter (applies only to boolean and Boolean values), false otherwise.
isISOControl(char) - Static method in class java.lang.Character
Determines if the specified character is an ISO control character.
isISOControl(int) - Static method in class java.lang.Character
Determines if the referenced character (Unicode code point) is an ISO control character.
isItalic() - Method in class java.awt.Font
Indicates whether or not this Font object's style is ITALIC.
isItalic(AttributeSet) - Static method in class javax.swing.text.StyleConstants
Checks whether the italic attribute is set.
isJavaIdentifierPart(char) - Static method in class java.lang.Character
Determines if the specified character may be part of a Java identifier as other than the first character.
isJavaIdentifierPart(int) - Static method in class java.lang.Character
Determines if the character (Unicode code point) may be part of a Java identifier as other than the first character.
isJavaIdentifierStart(char) - Static method in class java.lang.Character
Determines if the specified character is permissible as the first character in a Java identifier.
isJavaIdentifierStart(int) - Static method in class java.lang.Character
Determines if the character (Unicode code point) is permissible as the first character in a Java identifier.
isJavaLetter(char) - Static method in class java.lang.Character
Deprecated.
Replaced by isJavaIdentifierStart(char).
isJavaLetterOrDigit(char) - Static method in class java.lang.Character
Deprecated.
Replaced by isJavaIdentifierPart(char).
isJavaMIMEType(String) - Static method in class java.awt.datatransfer.SystemFlavorMap
Returns whether the specified String is an encoded Java MIME type.
isKeyBindingActive() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
isKeyBindingRegistered() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
isKeyDown - Variable in class javax.swing.plaf.basic.BasicTreeUI.KeyHandler
Set to true while keyPressed is active.
isKeyEntry(String) - Method in class java.security.KeyStore
Returns true if the entry identified by the given alias was created by a call to setKeyEntry, or created by a call to setEntry with a PrivateKeyEntry or a SecretKeyEntry.
isKeyword(CharSequence) - Static method in enum javax.lang.model.SourceVersion
Returns whether or not s is a keyword or literal in the latest source version.
isLargeModel() - Method in class javax.swing.JTree
Returns true if the tree is configured for a large model.
isLargeModel() - Method in class javax.swing.plaf.basic.BasicTreeUI
isLast() - Method in interface java.sql.ResultSet
Retrieves whether the cursor is on the last row of this ResultSet object.
isLayoutValid() - Method in class javax.swing.text.AsyncBoxView.ChildState
Has the child view been laid out.
isLayoutValid(int) - Method in class javax.swing.text.BoxView
Determines if the layout is valid along the given axis.
isLeadAnchorNotificationEnabled() - Method in class javax.swing.DefaultListSelectionModel
Returns the value of the leadAnchorNotificationEnabled flag.
isLeadingEdge() - Method in class java.awt.font.TextHitInfo
Returns true if the leading edge of the character was hit.
isLeaf() - Method in class javax.swing.JTree.DynamicUtilTreeNode
Returns true if this node allows children.
isLeaf(int) - Method in class javax.swing.plaf.basic.BasicTreeUI
isLeaf() - Method in class javax.swing.text.AbstractDocument.AbstractElement
Checks whether the element is a leaf.
isLeaf() - Method in class javax.swing.text.AbstractDocument.BranchElement
Checks whether the element is a leaf.
isLeaf() - Method in class javax.swing.text.AbstractDocument.LeafElement
Checks whether the element is a leaf.
isLeaf() - Method in interface javax.swing.text.Element
Is this element a leaf element? An element that may have children, even if it currently has no children, would return false.
isLeaf() - Method in class javax.swing.tree.DefaultMutableTreeNode
Returns true if this node has no children.
isLeaf(Object) - Method in class javax.swing.tree.DefaultTreeModel
Returns whether the specified node is a leaf node.
isLeaf(Object) - Method in interface javax.swing.tree.TreeModel
Returns true if node is a leaf.
isLeaf() - Method in interface javax.swing.tree.TreeNode
Returns true if the receiver is a leaf.
isLeap(long) - Static method in class java.time.Year
Checks if the year is a leap year, according to the ISO proleptic calendar system rules.
isLeap() - Method in class java.time.Year
Checks if the year is a leap year, according to the ISO proleptic calendar system rules.
isLeapYear() - Method in interface java.time.chrono.ChronoLocalDate
Checks if the year is a leap year, as defined by the calendar system.
isLeapYear(long) - Method in interface java.time.chrono.Chronology
Checks if the specified year is a leap year.
isLeapYear(long) - Method in class java.time.chrono.HijrahChronology
isLeapYear() - Method in class java.time.chrono.HijrahDate
Checks if the year is a leap year, according to the Hijrah calendar system rules.
isLeapYear(long) - Method in class java.time.chrono.IsoChronology
Checks if the year is a leap year, according to the ISO proleptic calendar system rules.
isLeapYear(long) - Method in class java.time.chrono.JapaneseChronology
Checks if the specified year is a leap year.
isLeapYear(long) - Method in class java.time.chrono.MinguoChronology
Checks if the specified year is a leap year.
isLeapYear(long) - Method in class java.time.chrono.ThaiBuddhistChronology
Checks if the specified year is a leap year.
isLeapYear() - Method in class java.time.LocalDate
Checks if the year is a leap year, according to the ISO proleptic calendar system rules.
isLeapYear() - Method in class java.time.YearMonth
Checks if the year is a leap year, according to the ISO proleptic calendar system rules.
isLeapYear(int) - Method in class java.util.GregorianCalendar
Determines if the given year is a leap year.
isLeftMouseButton(MouseEvent) - Static method in class javax.swing.SwingUtilities
Returns true if the mouse event specifies the left mouse button.
isLeftToRight() - Method in class java.awt.ComponentOrientation
HorizontalLines: Do items run left-to-right?
Vertical Lines: Do lines run left-to-right?
This will return true for horizontal, left-to-right writing systems such as Roman.
isLeftToRight() - Method in class java.awt.font.TextLayout
Returns true if this TextLayout has a left-to-right base direction or false if it has a right-to-left base direction.
isLeftToRight() - Method in class java.text.Bidi
Return true if the line is all left-to-right text and the base direction is left-to-right.
isLegalReplacement(byte[]) - Method in class java.nio.charset.CharsetEncoder
Tells whether or not the given byte array is a legal replacement value for this encoder.
isLenient() - Method in class java.text.DateFormat
Tell whether date/time parsing is to be lenient.
isLenient() - Method in class java.util.Calendar
Tells whether date/time interpretation is to be lenient.
isLetter(char) - Static method in class java.lang.Character
Determines if the specified character is a letter.
isLetter(int) - Static method in class java.lang.Character
Determines if the specified character (Unicode code point) is a letter.
isLetterOrDigit(char) - Static method in class java.lang.Character
Determines if the specified character is a letter or digit.
isLetterOrDigit(int) - Static method in class java.lang.Character
Determines if the specified character (Unicode code point) is a letter or digit.
isLigature() - Method in class java.awt.font.GlyphMetrics
Returns true if this is a ligature glyph.
isLight - Variable in class javax.swing.plaf.metal.MetalIconFactory.TreeControlIcon
isLightweight() - Method in class java.awt.Component
A lightweight component doesn't have a native toolkit peer.
isLightweightComponent(Component) - Static method in class javax.swing.JComponent
Returns true if this component is lightweight, that is, if it doesn't have a native window system peer.
isLightWeightPopupEnabled() - Method in class javax.swing.JComboBox
Gets the value of the lightWeightPopupEnabled property.
isLightWeightPopupEnabled() - Method in class javax.swing.JPopupMenu
Gets the lightWeightPopupEnabled property.
isLightWeightPopupEnabled() - Method in class javax.swing.ToolTipManager
Returns true if lightweight (all-Java) Tooltips are in use, or false if heavyweight (native peer) Tooltips are being used.
isLineEmpty() - Method in class javax.swing.text.AbstractWriter
Returns true if the current line should be considered empty.
isLineSupported(Line.Info) - Static method in class javax.sound.sampled.AudioSystem
Indicates whether the system supports any lines that match the specified Line.Info object.
isLineSupported(Line.Info) - Method in interface javax.sound.sampled.Mixer
Indicates whether the mixer supports a line (or lines) that match the specified Line.Info object.
isLinkLocalAddress() - Method in class java.net.Inet4Address
Utility routine to check if the InetAddress is an link local address.
isLinkLocalAddress() - Method in class java.net.Inet6Address
Utility routine to check if the InetAddress is an link local address.
isLinkLocalAddress() - Method in class java.net.InetAddress
Utility routine to check if the InetAddress is an link local address.
isLoaded() - Method in class java.nio.MappedByteBuffer
Tells whether or not this buffer's content is resident in physical memory.
isLocal - Variable in class java.awt.dnd.DropTargetContext.TransferableProxy
A boolean indicating if the encapsulated Transferable object represents the result of local drag-n-drop operation (within the same JVM).
isLocal(Stub) - Static method in class javax.rmi.CORBA.Util
The isLocal method has the same semantics as the ObjectImpl._is_local method, except that it can throw a RemoteException.
isLocal(Stub) - Method in interface javax.rmi.CORBA.UtilDelegate
Delegation call for Util.isLocal(javax.rmi.CORBA.Stub).
isLocalClass() - Method in class java.lang.Class
Returns true if and only if the underlying class is a local class.
isLocallyDefined(KeyStroke) - Method in interface javax.swing.text.Keymap
Determines if the given key sequence is locally defined.
isLocalTransfer() - Method in class java.awt.dnd.DropTargetDropEvent
This method returns an int indicating if the source is in the same JVM as the target.
isLocationByPlatform() - Method in class java.awt.Window
Returns true if this Window will appear at the default location for the native windowing system the next time this Window is made visible.
isLocationInExpandControl(TreePath, int, int) - Method in class javax.swing.plaf.basic.BasicTreeUI
Returns true if mouseX and mouseY fall in the area of row that is used to expand/collapse the node and the node at row does not represent a leaf.
isLocationInExpandControl(int, int, int, int) - Method in class javax.swing.plaf.metal.MetalTreeUI
isLocked() - Method in class java.util.concurrent.locks.ReentrantLock
Queries if this lock is held by any thread.
isLoggable(LogRecord) - Method in interface java.util.logging.Filter
Check if a given log record should be published.
isLoggable(LogRecord) - Method in class java.util.logging.Handler
Check if this Handler would actually log a given LogRecord.
isLoggable(Level) - Method in class java.util.logging.Logger
Check if a message of the given level would actually be logged by this logger.
isLoggable(LogRecord) - Method in class java.util.logging.MemoryHandler
Check if this Handler would actually log a given LogRecord into its internal buffer.
isLoggable(LogRecord) - Method in class java.util.logging.StreamHandler
Check if this Handler would actually log a given LogRecord.
isLongerThan(Duration) - Method in class javax.xml.datatype.Duration
Checks if this duration object is strictly longer than another Duration object.
isLoopback() - Method in class java.net.NetworkInterface
Returns whether a network interface is a loopback interface.
isLoopbackAddress() - Method in class java.net.Inet4Address
Utility routine to check if the InetAddress is a loopback address.
isLoopbackAddress() - Method in class java.net.Inet6Address
Utility routine to check if the InetAddress is a loopback address.
isLoopbackAddress() - Method in class java.net.InetAddress
Utility routine to check if the InetAddress is a loopback address.
isLowerCase(char) - Static method in class java.lang.Character
Determines if the specified character is a lowercase character.
isLowerCase(int) - Static method in class java.lang.Character
Determines if the specified character (Unicode code point) is a lowercase character.
isLowSurrogate(char) - Static method in class java.lang.Character
Determines if the given char value is a Unicode low-surrogate code unit (also known as trailing-surrogate code unit).
isMalformed() - Method in class java.nio.charset.CoderResult
Tells whether or not this object describes a malformed-input error.
isManagingFocus() - Method in class javax.swing.JComponent
Deprecated.
As of 1.4, replaced by Component.setFocusTraversalKeys(int, Set) and Container.setFocusCycleRoot(boolean).
ISMAP - Static variable in class javax.swing.text.html.HTML.Attribute
isMarked() - Method in class java.util.concurrent.atomic.AtomicMarkableReference
Returns the current value of the mark.
isMaximizable() - Method in class javax.swing.JInternalFrame
Gets the value of the maximizable property.
isMaximum - Variable in class javax.swing.JInternalFrame
The frame has been expanded to its maximum size.
isMaximum() - Method in class javax.swing.JInternalFrame
Returns whether the JInternalFrame is currently maximized.
isMaximumSizeSet() - Method in class java.awt.Component
Returns true if the maximum size has been set to a non-null value otherwise returns false.
isMCGlobal() - Method in class java.net.Inet4Address
Utility routine to check if the multicast address has global scope.
isMCGlobal() - Method in class java.net.Inet6Address
Utility routine to check if the multicast address has global scope.
isMCGlobal() - Method in class java.net.InetAddress
Utility routine to check if the multicast address has global scope.
isMCLinkLocal() - Method in class java.net.Inet4Address
Utility routine to check if the multicast address has link scope.
isMCLinkLocal() - Method in class java.net.Inet6Address
Utility routine to check if the multicast address has link scope.
isMCLinkLocal() - Method in class java.net.InetAddress
Utility routine to check if the multicast address has link scope.
isMCNodeLocal() - Method in class java.net.Inet4Address
Utility routine to check if the multicast address has node scope.
isMCNodeLocal() - Method in class java.net.Inet6Address
Utility routine to check if the multicast address has node scope.
isMCNodeLocal() - Method in class java.net.InetAddress
Utility routine to check if the multicast address has node scope.
isMCOrgLocal() - Method in class java.net.Inet4Address
Utility routine to check if the multicast address has organization scope.
isMCOrgLocal() - Method in class java.net.Inet6Address
Utility routine to check if the multicast address has organization scope.
isMCOrgLocal() - Method in class java.net.InetAddress
Utility routine to check if the multicast address has organization scope.
isMCSiteLocal() - Method in class java.net.Inet4Address
Utility routine to check if the multicast address has site scope.
isMCSiteLocal() - Method in class java.net.Inet6Address
Utility routine to check if the multicast address has site scope.
isMCSiteLocal() - Method in class java.net.InetAddress
Utility routine to check if the multicast address has site scope.
isMember(Principal) - Method in interface java.security.acl.Group
Returns true if the passed principal is a member of the group.
isMemberClass() - Method in class java.lang.Class
Returns true if and only if the underlying class is a member class.
isMenuComponent(Component) - Method in class javax.swing.JMenu
Returns true if the specified component exists in the submenu hierarchy.
isMetaDown() - Method in class java.awt.event.InputEvent
Returns whether or not the Meta modifier is down on this event.
isMiddleMouseButton(MouseEvent) - Static method in class javax.swing.SwingUtilities
Returns true if the mouse event specifies the middle mouse button.
isMidnightEndOfDay() - Method in class java.time.zone.ZoneOffsetTransitionRule
Is the transition local time midnight at the end of day.
isMimeTypeEqual(String) - Method in class java.awt.datatransfer.DataFlavor
Returns whether the string representation of the MIME type passed in is equivalent to the MIME type of this DataFlavor.
isMimeTypeEqual(DataFlavor) - Method in class java.awt.datatransfer.DataFlavor
Compares the mimeType of two DataFlavor objects.
isMimeTypeEqual(String) - Method in class javax.activation.ActivationDataFlavor
Is the string representation of the MIME type passed in equivalent to the MIME type of this DataFlavor.
isMimeTypeSerializedObject() - Method in class java.awt.datatransfer.DataFlavor
Does the DataFlavor represent a serialized object?
isMinimumSizeDirty - Variable in class javax.swing.plaf.basic.BasicComboBoxUI
isMinimumSizeSet() - Method in class java.awt.Component
Returns whether or not setMinimumSize has been invoked with a non-null value.
isMirrored(char) - Static method in class java.lang.Character
Determines whether the character is mirrored according to the Unicode specification.
isMirrored(int) - Static method in class java.lang.Character
Determines whether the specified character (Unicode code point) is mirrored according to the Unicode specification.
isMixed() - Method in class java.text.Bidi
Return true if the line is not left-to-right or right-to-left.
isMixerSupported(Mixer.Info) - Method in class javax.sound.sampled.spi.MixerProvider
Indicates whether the mixer provider supports the mixer represented by the specified mixer info object.
isMN() - Method in interface org.ietf.jgss.GSSName
Tests if this name object represents a Mechanism Name (MN).
isModal() - Method in class java.awt.Dialog
Indicates whether the dialog is modal.
isModalExclusionTypeSupported(Dialog.ModalExclusionType) - Method in class java.awt.Toolkit
Returns whether the given modal exclusion type is supported by this toolkit.
isModalityTypeSupported(Dialog.ModalityType) - Method in class java.awt.Toolkit
Returns whether the given modality type is supported by this toolkit.
isModifiableClass(Class<?>) - Method in interface java.lang.instrument.Instrumentation
Determines whether a class is modifiable by retransformation or redefinition.
isMouseOver() - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider
Returns whether or not the mouse is currently over the divider
isMTOMEnabled() - Method in interface javax.xml.ws.soap.SOAPBinding
Returns true if the use of MTOM is enabled.
isMultiBufferAvailable() - Method in class java.awt.BufferCapabilities
isMulticastAddress() - Method in class java.net.Inet4Address
Utility routine to check if the InetAddress is an IP multicast address.
isMulticastAddress() - Method in class java.net.Inet6Address
Utility routine to check if the InetAddress is an IP multicast address.
isMulticastAddress() - Method in class java.net.InetAddress
Utility routine to check if the InetAddress is an IP multicast address.
isMultipleMode() - Method in class java.awt.FileDialog
Returns whether the file dialog allows the multiple file selection.
isMultipleMode() - Method in class java.awt.List
Determines whether this list allows multiple selections.
isMultiSelectEvent(MouseEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI
Returning true signifies a mouse event on the node should select from the anchor point.
isMultiSelectionEnabled() - Method in class javax.swing.JFileChooser
Returns true if multiple files can be selected.
isMXBean() - Method in class javax.management.MBeanServerInvocationHandler
If true, the proxy is for an MXBean, and appropriate mappings are applied to method parameters and return values.
isMXBeanInterface(Class<?>) - Static method in class javax.management.JMX
Test whether an interface is an MXBean interface.
isName(CharSequence) - Static method in enum javax.lang.model.SourceVersion
Returns whether or not name is a syntactically valid qualified name in the latest source version.
isNameCompatible(String, JavaFileObject.Kind) - Method in class javax.tools.ForwardingJavaFileObject
isNameCompatible(String, JavaFileObject.Kind) - Method in interface javax.tools.JavaFileObject
Checks if this file object is compatible with the specified simple name and kind.
isNameCompatible(String, JavaFileObject.Kind) - Method in class javax.tools.SimpleJavaFileObject
This implementation compares the path of its URI to the given simple name.
isNamePresent() - Method in class java.lang.reflect.Parameter
Returns true if the parameter has a name according to the class file; returns false otherwise.
isNamespace() - Method in interface javax.xml.stream.events.XMLEvent
A utility function to check if this event is a Namespace.
isNamespaceAware() - Method in class javax.xml.parsers.DocumentBuilder
Indicates whether or not this parser is configured to understand namespaces.
isNamespaceAware() - Method in class javax.xml.parsers.DocumentBuilderFactory
Indicates whether or not the factory is configured to produce parsers which are namespace aware.
isNamespaceAware() - Method in class javax.xml.parsers.SAXParser
Indicates whether or not this parser is configured to understand namespaces.
isNamespaceAware() - Method in class javax.xml.parsers.SAXParserFactory
Indicates whether or not the factory is configured to produce parsers which are namespace aware.
isNamespaceDeclUris() - Method in class org.xml.sax.helpers.NamespaceSupport
Returns true if namespace declaration attributes are placed into a namespace.
isNaN(double) - Static method in class java.lang.Double
Returns true if the specified number is a Not-a-Number (NaN) value, false otherwise.
isNaN() - Method in class java.lang.Double
Returns true if this Double value is a Not-a-Number (NaN), false otherwise.
isNaN(float) - Static method in class java.lang.Float
Returns true if the specified number is a Not-a-Number (NaN) value, false otherwise.
isNaN() - Method in class java.lang.Float
Returns true if this Float value is a Not-a-Number (NaN), false otherwise.
isNative(int) - Static method in class java.lang.reflect.Modifier
Return true if the integer argument includes the native modifier, false otherwise.
isNativeLookAndFeel() - Method in class javax.swing.LookAndFeel
If the underlying platform has a "native" look and feel, and this is an implementation of it, return true.
isNativeLookAndFeel() - Method in class javax.swing.plaf.metal.MetalLookAndFeel
Returns false; MetalLookAndFeel is not a native look and feel.
isNativeLookAndFeel() - Method in class javax.swing.plaf.multi.MultiLookAndFeel
Returns false; this look and feel is not native to any platform.
isNativeLookAndFeel() - Method in class javax.swing.plaf.synth.SynthLookAndFeel
Returns false, SynthLookAndFeel is not a native look and feel.
isNativeMethod() - Method in class java.lang.StackTraceElement
Returns true if the method containing the execution point represented by this stack trace element is a native method.
isNativeMethodPrefixSupported() - Method in interface java.lang.instrument.Instrumentation
Returns whether the current JVM configuration supports setting a native method prefix.
isNavigationKey(int) - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Returns whether or not the supplied keyCode maps to a key that is used for navigation.
isNegative() - Method in interface java.security.acl.AclEntry
Returns true if this is a negative ACL entry (one denying the associated principal the set of permissions in the entry), false otherwise.
isNegative() - Method in interface java.time.chrono.ChronoPeriod
Checks if any of the supported units of this period are negative.
isNegative() - Method in class java.time.Duration
Checks if this duration is negative, excluding zero.
isNegative() - Method in class java.time.Period
Checks if any of the three units of this period are negative.
isNested() - Method in enum javax.lang.model.element.NestingKind
Does this constant correspond to a nested type element? A nested type element is any that is not top-level.
isNil() - Method in class javax.xml.bind.JAXBElement
Returns true iff this element instance content model is nil.
isNodeAncestor(TreeNode) - Method in class javax.swing.tree.DefaultMutableTreeNode
Returns true if anotherNode is an ancestor of this node -- if it is this node, this node's parent, or an ancestor of this node's parent.
isNodeChild(TreeNode) - Method in class javax.swing.tree.DefaultMutableTreeNode
Returns true if aNode is a child of this node.
isNodeDescendant(DefaultMutableTreeNode) - Method in class javax.swing.tree.DefaultMutableTreeNode
Returns true if anotherNode is a descendant of this node -- if it is this node, one of this node's children, or a descendant of one of this node's children.
isNodeRelated(DefaultMutableTreeNode) - Method in class javax.swing.tree.DefaultMutableTreeNode
Returns true if and only if aNode is in the same tree as this node.
isNodeSibling(TreeNode) - Method in class javax.swing.tree.DefaultMutableTreeNode
Returns true if anotherNode is a sibling of (has the same parent as) this node.
isNormalized(CharSequence, Normalizer.Form) - Static method in class java.text.Normalizer
Determines if the given sequence of char values is normalized.
isNotificationEnabled(Notification) - Method in class javax.management.AttributeChangeNotificationFilter
Invoked before sending the specified notification to the listener.
isNotificationEnabled(Notification) - Method in interface javax.management.NotificationFilter
Invoked before sending the specified notification to the listener.
isNotificationEnabled(Notification) - Method in class javax.management.NotificationFilterSupport
Invoked before sending the specified notification to the listener.
isNotificationEnabled(Notification) - Method in class javax.management.relation.MBeanServerNotificationFilter
Invoked before sending the specified notification to the listener.
isNotifyOnEDT() - Method in class javax.swing.event.SwingPropertyChangeSupport
Returns notifyOnEDT property.
isNull(Object) - Static method in class java.util.Objects
Returns true if the provided reference is null otherwise returns false.
isNullable(int) - Method in interface java.sql.ParameterMetaData
Retrieves whether null values are allowed in the designated parameter.
isNullable(int) - Method in interface java.sql.ResultSetMetaData
Indicates the nullability of values in the designated column.
isNullable(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl
Retrieves a constant indicating whether it is possible to store a NULL value in the designated column.
ISO - Static variable in class java.time.temporal.WeekFields
The ISO-8601 definition, where a week starts on Monday and the first week has a minimum of 4 days.
ISO_2A0 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN and JIS 2A0, 1189 x 1682 mm.
ISO_4A0 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN and JIS 4A0, 1682 x 2378 mm.
ISO_8859_1 - Static variable in class java.nio.charset.StandardCharsets
ISO Latin Alphabet No.
ISO_A0 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN and JIS A0, 841 x 1189 mm.
ISO_A0 - Static variable in class javax.print.attribute.standard.MediaSizeName
A0 size.
ISO_A1 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN and JIS A1, 594 x 841 mm.
ISO_A1 - Static variable in class javax.print.attribute.standard.MediaSizeName
A1 size.
ISO_A10 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN and JIS A10, 26 x 37 mm.
ISO_A10 - Static variable in class javax.print.attribute.standard.MediaSizeName
A10 size.
ISO_A2 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN and JIS A2, 420 x 594 mm.
ISO_A2 - Static variable in class javax.print.attribute.standard.MediaSizeName
A2 size.
ISO_A3 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN and JIS A3, 297 x 420 mm.
ISO_A3 - Static variable in class javax.print.attribute.standard.MediaSizeName
A3 size.
ISO_A4 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN and JIS A4, 210 x 297 mm.
ISO_A4 - Static variable in class javax.print.attribute.standard.MediaSizeName
A4 size.
ISO_A4_TRANSPARENT - Static variable in class javax.print.attribute.standard.MediaName
A4 transparency.
ISO_A4_WHITE - Static variable in class javax.print.attribute.standard.MediaName
white A4 paper.
ISO_A5 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN and JIS A5, 148 x 210 mm.
ISO_A5 - Static variable in class javax.print.attribute.standard.MediaSizeName
A5 size.
ISO_A6 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN and JIS A6, 105 x 148 mm.
ISO_A6 - Static variable in class javax.print.attribute.standard.MediaSizeName
A6 size.
ISO_A7 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN and JIS A7, 74 x 105 mm.
ISO_A7 - Static variable in class javax.print.attribute.standard.MediaSizeName
A7 size.
ISO_A8 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN and JIS A8, 52 x 74 mm.
ISO_A8 - Static variable in class javax.print.attribute.standard.MediaSizeName
A8 size.
ISO_A9 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN and JIS A9, 37 x 52 mm.
ISO_A9 - Static variable in class javax.print.attribute.standard.MediaSizeName
A9 size.
ISO_B0 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN B0, 1000 x 1414 mm.
ISO_B0 - Static variable in class javax.print.attribute.standard.MediaSizeName
ISO B0 size.
ISO_B1 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN B1, 707 x 1000 mm.
ISO_B1 - Static variable in class javax.print.attribute.standard.MediaSizeName
ISO B1 size.
ISO_B10 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN B10, 31 x 44 mm.
ISO_B10 - Static variable in class javax.print.attribute.standard.MediaSizeName
ISO B10 size.
ISO_B2 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN B2, 500 x 707 mm.
ISO_B2 - Static variable in class javax.print.attribute.standard.MediaSizeName
ISO B2 size.
ISO_B3 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN B3, 353 x 500 mm.
ISO_B3 - Static variable in class javax.print.attribute.standard.MediaSizeName
ISO B3 size.
ISO_B4 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN B4, 250 x 353 mm.
ISO_B4 - Static variable in class javax.print.attribute.standard.MediaSizeName
ISO B4 size.
ISO_B4_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_B4.
ISO_B5 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN B5, 176 x 250 mm.
ISO_B5 - Static variable in class javax.print.attribute.standard.MediaSizeName
ISO B5 size.
ISO_B5_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_B5.
ISO_B6 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN B6, 125 x 176 mm.
ISO_B6 - Static variable in class javax.print.attribute.standard.MediaSizeName
ISO B6 size.
ISO_B7 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN B7, 88 x 125 mm.
ISO_B7 - Static variable in class javax.print.attribute.standard.MediaSizeName
ISO B7 size.
ISO_B8 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN B8, 62 x 88 mm.
ISO_B8 - Static variable in class javax.print.attribute.standard.MediaSizeName
ISO B8 size.
ISO_B9 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN B9, 44 x 62 mm.
ISO_B9 - Static variable in class javax.print.attribute.standard.MediaSizeName
ISO B9 size.
ISO_C0 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN C0, 917 x 1297 mm.
ISO_C0 - Static variable in class javax.print.attribute.standard.MediaSizeName
ISO C0 size.
ISO_C0_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C0.
ISO_C1 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN C1, 648 x 917 mm.
ISO_C1 - Static variable in class javax.print.attribute.standard.MediaSizeName
ISO C1 size.
ISO_C10 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN C10, 28 x 40 mm.
ISO_C10_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C10.
ISO_C1_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C1.
ISO_C2 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN C2, 458 x 648 mm.
ISO_C2 - Static variable in class javax.print.attribute.standard.MediaSizeName
ISO C2 size.
ISO_C2_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C2.
ISO_C3 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN C3, 324 x 458 mm.
ISO_C3 - Static variable in class javax.print.attribute.standard.MediaSizeName
ISO C3 size.
ISO_C3_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C3.
ISO_C4 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN C4, 229 x 324 mm.
ISO_C4 - Static variable in class javax.print.attribute.standard.MediaSizeName
ISO C4 size.
ISO_C4_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C4.
ISO_C5 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN C5, 162 x 229 mm.
ISO_C5 - Static variable in class javax.print.attribute.standard.MediaSizeName
ISO C5 size.
ISO_C5_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C5.
ISO_C6 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN C6, 114 x 162 mm.
ISO_C6 - Static variable in class javax.print.attribute.standard.MediaSizeName
letter size.
ISO_C6_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C6.
ISO_C7 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN C7, 81 x 114 mm.
ISO_C7_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C7.
ISO_C8 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN C8, 57 x 81 mm.
ISO_C8_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C8.
ISO_C9 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO/DIN C9, 40 x 57 mm.
ISO_C9_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_C9.
ISO_DATE - Static variable in class java.time.format.DateTimeFormatter
The ISO date formatter that formats or parses a date with the offset if available, such as '2011-12-03' or '2011-12-03+01:00'.
ISO_DATE_TIME - Static variable in class java.time.format.DateTimeFormatter
The ISO-like date-time formatter that formats or parses a date-time with the offset and zone if available, such as '2011-12-03T10:15:30', '2011-12-03T10:15:30+01:00' or '2011-12-03T10:15:30+01:00[Europe/Paris]'.
ISO_DESIGNATED_LONG - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for ISO Designated Long, 110 x 220 mm.
ISO_DESIGNATED_LONG - Static variable in class javax.print.attribute.standard.MediaSizeName
ISO designated long size .
ISO_DESIGNATED_LONG_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
An alias for ISO_DESIGNATED_LONG.
ISO_INSTANT - Static variable in class java.time.format.DateTimeFormatter
The ISO instant formatter that formats or parses an instant in UTC, such as '2011-12-03T10:15:30Z'.
ISO_LOCAL_DATE - Static variable in class java.time.format.DateTimeFormatter
The ISO date formatter that formats or parses a date without an offset, such as '2011-12-03'.
ISO_LOCAL_DATE_TIME - Static variable in class java.time.format.DateTimeFormatter
The ISO date-time formatter that formats or parses a date-time without an offset, such as '2011-12-03T10:15:30'.
ISO_LOCAL_TIME - Static variable in class java.time.format.DateTimeFormatter
The ISO time formatter that formats or parses a time without an offset, such as '10:15' or '10:15:30'.
ISO_OFFSET_DATE - Static variable in class java.time.format.DateTimeFormatter
The ISO date formatter that formats or parses a date with an offset, such as '2011-12-03+01:00'.
ISO_OFFSET_DATE_TIME - Static variable in class java.time.format.DateTimeFormatter
The ISO date-time formatter that formats or parses a date-time with an offset, such as '2011-12-03T10:15:30+01:00'.
ISO_OFFSET_TIME - Static variable in class java.time.format.DateTimeFormatter
The ISO time formatter that formats or parses a time with an offset, such as '10:15+01:00' or '10:15:30+01:00'.
ISO_ORDINAL_DATE - Static variable in class java.time.format.DateTimeFormatter
The ISO date formatter that formats or parses the ordinal date without an offset, such as '2012-337'.
ISO_TIME - Static variable in class java.time.format.DateTimeFormatter
The ISO time formatter that formats or parses a time, with the offset if available, such as '10:15', '10:15:30' or '10:15:30+01:00'.
ISO_WEEK_DATE - Static variable in class java.time.format.DateTimeFormatter
The ISO date formatter that formats or parses the week-based date without an offset, such as '2012-W48-6'.
ISO_ZONED_DATE_TIME - Static variable in class java.time.format.DateTimeFormatter
The ISO-like date-time formatter that formats or parses a date-time with offset and zone, such as '2011-12-03T10:15:30+01:00[Europe/Paris]'.
isObjectModelSupported(String) - Method in class javax.xml.xpath.XPathFactory
Is specified object model supported by this XPathFactory?
isObjectMonitorUsageSupported() - Method in interface java.lang.management.ThreadMXBean
Tests if the Java virtual machine supports monitoring of object monitor usage.
IsoChronology - Class in java.time.chrono
The ISO calendar system.
IsoEra - Enum in java.time.chrono
An era in the ISO calendar system.
IsoFields - Class in java.time.temporal
Fields and units specific to the ISO-8601 calendar system, including quarter-of-year and week-based-year.
isOldToken() - Method in class org.ietf.jgss.MessageProp
Tests if this token's validity period has expired, i.e., the token is too old to be checked for duplication.
isOneTouchExpandable() - Method in class javax.swing.JSplitPane
Gets the oneTouchExpandable property.
isOnKeyRelease() - Method in class java.awt.AWTKeyStroke
Returns whether this AWTKeyStroke represents a key release.
isOpaque() - Method in class java.awt.Component
Returns true if this component is completely opaque, returns false by default.
isOpaque() - Method in class java.awt.Window
Indicates if the window is currently opaque.
isOpaque() - Method in class java.net.URI
Tells whether or not this URI is opaque.
isOpaque() - Method in class javax.swing.DefaultListCellRenderer
Overridden for performance reasons.
isOpaque() - Method in class javax.swing.JComponent
Returns true if this component is completely opaque.
isOpaque() - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane.SystemMenuBar
isOpaque(SynthContext) - Method in class javax.swing.plaf.nimbus.NimbusStyle
Returns true if the region is opaque.
isOpaque(SynthContext) - Method in class javax.swing.plaf.synth.SynthStyle
Returns true if the region is opaque.
isOpaque() - Method in class javax.swing.table.DefaultTableCellRenderer
Overridden for performance reasons.
isOpen() - Method in interface java.nio.channels.Channel
Tells whether or not this channel is open.
isOpen() - Method in class java.nio.channels.Selector
Tells whether or not this selector is open.
isOpen() - Method in class java.nio.channels.spi.AbstractInterruptibleChannel
isOpen() - Method in class java.nio.channels.spi.AbstractSelector
isOpen() - Method in class java.nio.file.FileSystem
Tells whether or not this file system is open.
isOpen() - Method in interface javax.sound.midi.MidiDevice
Reports whether the device is open.
isOpen() - Method in interface javax.sound.sampled.Line
Indicates whether the line is open, meaning that it has reserved system resources and is operational, although it might not currently be playing or capturing sound.
isOptimizedDrawingEnabled() - Method in class javax.swing.JComponent
Returns true if this component tiles its children -- that is, if it can guarantee that the children will not overlap.
isOptimizedDrawingEnabled() - Method in class javax.swing.JLayer
The JLayer overrides the default implementation of this method (in JComponent) to return false.
isOptimizedDrawingEnabled() - Method in class javax.swing.JLayeredPane
Returns false if components in the pane can overlap, which makes optimized drawing impossible.
isOptimizedDrawingEnabled() - Method in class javax.swing.JRootPane
The glassPane and contentPane have the same bounds, which means JRootPane does not tiles its children and this should return false.
isOptimizedDrawingEnabled() - Method in class javax.swing.JViewport
The JViewport overrides the default implementation of this method (in JComponent) to return false.
isOrdered() - Method in interface javax.naming.directory.Attribute
Determines whether this attribute's values are ordered.
isOrdered() - Method in class javax.naming.directory.BasicAttribute
isOther() - Method in interface java.nio.file.attribute.BasicFileAttributes
Tells whether the file is something other than a regular file, directory, or symbolic link.
isOutboundDone() - Method in class javax.net.ssl.SSLEngine
Returns whether SSLEngine.wrap(ByteBuffer, ByteBuffer) will produce any more outbound data messages.
isOutputLocation() - Method in enum javax.tools.DocumentationTool.Location
isOutputLocation() - Method in interface javax.tools.JavaFileManager.Location
Determines if this is an output location.
isOutputLocation() - Method in enum javax.tools.StandardLocation
isOutputShutdown() - Method in class java.net.Socket
Returns whether the write-half of the socket connection is closed.
isOverflow() - Method in class java.nio.charset.CoderResult
Tells whether or not this object describes an overflow condition.
isOverlap() - Method in class java.time.zone.ZoneOffsetTransition
Does this transition represent an overlap in the local time-line.
isOwner(Principal) - Method in interface java.security.acl.Owner
Returns true if the given principal is an owner of the ACL.
isOwnReader(ImageReader) - Method in class javax.imageio.spi.ImageReaderSpi
Returns true if the ImageReader object passed in is an instance of the ImageReader associated with this service provider.
isOwnWriter(ImageWriter) - Method in class javax.imageio.spi.ImageWriterSpi
Returns true if the ImageWriter object passed in is an instance of the ImageWriter associated with this service provider.
isPageFlipping() - Method in class java.awt.BufferCapabilities
isPaintable() - Method in interface java.beans.PropertyEditor
Determines whether this property editor is paintable.
isPaintable() - Method in class java.beans.PropertyEditorSupport
Determines whether the class will honor the paintValue method.
isPaintingForPrint() - Method in class javax.swing.JComponent
Returns true if the current painting operation on this component is part of a print operation.
isPaintingOrigin() - Method in class javax.swing.JComponent
Returns true if a paint triggered on a child component should cause painting to originate from this Component, or one of its ancestors.
isPaintingOrigin() - Method in class javax.swing.JLayer
Always returns true to cause painting to originate from JLayer, or one of its ancestors.
isPaintingOrigin() - Method in class javax.swing.JViewport
Returns true if scroll mode is a BACKINGSTORE_SCROLL_MODE to cause painting to originate from JViewport, or one of its ancestors.
isPaintingTile() - Method in class javax.swing.JComponent
Returns true if the component is currently painting a tile.
isPalette - Variable in class javax.swing.plaf.metal.MetalInternalFrameTitlePane
isParallel() - Method in interface java.util.stream.BaseStream
Returns whether this stream, if a terminal operation were to be executed, would execute in parallel.
isParameter() - Method in class javax.swing.text.html.parser.Entity
Returns true if it is a parameter entity.
isParent(File, File) - Method in class javax.swing.filechooser.FileSystemView
On Windows, a file can appear in multiple folders, other than its parent directory in the filesystem.
isParityAdjusted(byte[], int) - Static method in class javax.crypto.spec.DESedeKeySpec
Checks if the given DES-EDE key, starting at offset inclusive, is parity-adjusted.
isParityAdjusted(byte[], int) - Static method in class javax.crypto.spec.DESKeySpec
Checks if the given DES key material, starting at offset inclusive, is parity-adjusted.
isParseBigDecimal() - Method in class java.text.DecimalFormat
Returns whether the DecimalFormat.parse(java.lang.String, java.text.ParsePosition) method returns BigDecimal.
isParseIntegerOnly() - Method in class java.text.NumberFormat
Returns true if this format will parse numbers as integers only.
isPartialReturn() - Method in class javax.swing.text.Segment
Flag to indicate that partial returns are valid.
isPathEditable(TreePath) - Method in class javax.swing.JTree
Returns isEditable.
isPathSelected(TreePath) - Method in class javax.swing.JTree
Returns true if the item identified by the path is currently selected.
isPathSelected(TreePath) - Method in class javax.swing.tree.DefaultTreeSelectionModel
Returns true if the path, path, is in the current selection.
isPathSelected(TreePath) - Method in interface javax.swing.tree.TreeSelectionModel
Returns true if the path, path, is in the current selection.
isPattern() - Method in class javax.management.ObjectName
Checks whether the object name is a pattern.
isPeriodic() - Method in interface java.util.concurrent.RunnableScheduledFuture
Returns true if this task is periodic.
isPlain() - Method in class java.awt.Font
Indicates whether or not this Font object's style is PLAIN.
isPointToPoint() - Method in class java.net.NetworkInterface
Returns whether a network interface is a point to point interface.
isPolicyMappingInhibited() - Method in class java.security.cert.PKIXParameters
Checks if policy mapping is inhibited.
isPolygonal() - Method in class java.awt.geom.Area
Tests whether this Area consists entirely of straight edged polygonal geometry.
isPoolable() - Method in interface java.sql.Statement
Returns a value indicating whether the Statement is poolable or not.
isPopupMenuVisible() - Method in class javax.swing.JMenu
Returns true if the menu's popup window is visible.
isPopupTrigger() - Method in class java.awt.event.MouseEvent
Returns whether or not this mouse event is the popup menu trigger event for the platform.
isPopupTrigger(MouseEvent) - Method in class javax.swing.JPopupMenu
Returns true if the MouseEvent is considered a popup trigger by the JPopupMenu's currently installed UI.
isPopupTrigger(MouseEvent) - Method in class javax.swing.plaf.basic.BasicPopupMenuUI
isPopupTrigger(MouseEvent) - Method in class javax.swing.plaf.multi.MultiPopupMenuUI
Invokes the isPopupTrigger method on each UI handled by this object.
isPopupTrigger(MouseEvent) - Method in class javax.swing.plaf.PopupMenuUI
isPopupVisible() - Method in class javax.swing.JComboBox
Determines the visibility of the popup.
isPopupVisible(JComboBox) - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Tells if the popup is visible or not.
isPopupVisible(JComboBox) - Method in class javax.swing.plaf.ComboBoxUI
Determine the visibility of the popup
isPopupVisible(JComboBox) - Method in class javax.swing.plaf.multi.MultiComboBoxUI
Invokes the isPopupVisible method on each UI handled by this object.
isPostdated() - Method in class javax.security.auth.kerberos.KerberosTicket
Determines is this ticket is post-dated.
isPreferred() - Method in class java.beans.FeatureDescriptor
The "preferred" flag is used to identify features that are particularly important for presenting to humans.
isPreferredSizeSet() - Method in class java.awt.Component
Returns true if the preferred size has been set to a non-null value otherwise returns false.
isPreformatted() - Method in class javax.swing.text.html.HTML.Tag
Returns true if this tag is pre-formatted, which is true if the tag is either PRE or TEXTAREA.
isPreformatted() - Method in class javax.swing.text.html.parser.TagElement
isPresent() - Method in class java.util.Optional
Return true if there is a value present, otherwise false.
isPresent() - Method in class java.util.OptionalDouble
Return true if there is a value present, otherwise false.
isPresent() - Method in class java.util.OptionalInt
Return true if there is a value present, otherwise false.
isPresent() - Method in class java.util.OptionalLong
Return true if there is a value present, otherwise false.
isPressed() - Method in interface javax.swing.ButtonModel
Indicates if the button is pressed.
isPressed() - Method in class javax.swing.DefaultButtonModel
Indicates if the button is pressed.
isPrimitive() - Method in class java.io.ObjectStreamField
Return true if this field has a primitive type.
isPrimitive() - Method in class java.lang.Class
Determines if the specified Class object represents a primitive type.
isPrimitive() - Method in enum javax.lang.model.type.TypeKind
Returns true if this kind corresponds to a primitive type and false otherwise.
isPrimitiveArray() - Method in class javax.management.openmbean.ArrayType
Returns true if the open data values this open type describes are primitive arrays, false otherwise.
isPrivate(int) - Static method in class java.lang.reflect.Modifier
Return true if the integer argument includes the private modifier, false otherwise.
isProbablePrime(int) - Method in class java.math.BigInteger
Returns true if this BigInteger is probably prime, false if it's definitely composite.
isProcessingInstruction() - Method in interface javax.xml.stream.events.XMLEvent
A utility function to check if this event is a ProcessingInstruction.
isPropagated() - Method in class java.beans.beancontext.BeanContextEvent
Reports whether or not this event is propagated from some other BeanContext.
isPropertyListPattern() - Method in class javax.management.ObjectName
Checks whether the object name is a pattern on the key property list.
isPropertyPattern() - Method in class javax.management.ObjectName
Checks whether the object name is a pattern on the key properties.
isPropertySupported(String) - Method in class javax.xml.stream.XMLInputFactory
Query the set of properties that this factory supports.
isPropertySupported(String) - Method in class javax.xml.stream.XMLOutputFactory
Query the set of properties that this factory supports.
isPropertyValuePattern() - Method in class javax.management.ObjectName
Checks whether the object name is a pattern on the value part of at least one of the key properties.
isPropertyValuePattern(String) - Method in class javax.management.ObjectName
Checks whether the value associated with a key in a key property is a pattern.
isProtected(int) - Static method in class java.lang.reflect.Modifier
Return true if the integer argument includes the protected modifier, false otherwise.
isProtReady() - Method in interface org.ietf.jgss.GSSContext
Determines if the context is ready for per message operations to be used over it.
isProxiable() - Method in class javax.security.auth.kerberos.KerberosTicket
Determines if this ticket is proxiable.
isProxy() - Method in class javax.security.auth.kerberos.KerberosTicket
Determines is this ticket is a proxy-ticket.
isProxyClass(Class<?>) - Static method in class java.lang.reflect.Proxy
Returns true if and only if the specified class was dynamically generated to be a proxy class using the getProxyClass method or the newProxyInstance method.
isPublic(int) - Static method in class java.lang.reflect.Modifier
Return true if the integer argument includes the public modifier, false otherwise.
isPublished() - Method in class javax.xml.ws.Endpoint
Returns true if the endpoint is in the published state.
isQueued(Thread) - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer
Returns true if the given thread is currently queued.
isQueued(Thread) - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer
Returns true if the given thread is currently queued.
isQuiescent() - Method in class java.util.concurrent.ForkJoinPool
Returns true if all worker threads are currently idle.
isRandomAccessEasy(int) - Method in class javax.imageio.ImageReader
Returns true if the storage format of the given image places no inherent impediment on random access to pixels.
isReachable(int) - Method in class java.net.InetAddress
Test whether that address is reachable.
isReachable(NetworkInterface, int, int) - Method in class java.net.InetAddress
Test whether that address is reachable.
isReadable() - Method in class java.nio.channels.SelectionKey
Tests whether this key's channel is ready for reading.
isReadable(Path) - Static method in class java.nio.file.Files
Tests whether a file is readable.
isReadable() - Method in class javax.management.MBeanAttributeInfo
Whether the value of the attribute can be read.
isReadable() - Method in interface javax.management.openmbean.OpenMBeanAttributeInfo
Returns true if the attribute described by this OpenMBeanAttributeInfo instance is readable, false otherwise.
isReadable() - Method in class javax.management.relation.RoleInfo
Returns read access mode for the role (true if it is readable).
isReadLocked() - Method in class java.util.concurrent.locks.StampedLock
Returns true if the lock is currently held non-exclusively.
isReadOnly() - Method in class java.nio.Buffer
Tells whether or not this buffer is read-only.
isReadOnly() - Method in interface java.nio.file.attribute.DosFileAttributes
Returns the value of the read-only attribute.
isReadOnly() - Method in class java.nio.file.FileStore
Tells whether this file store is read-only.
isReadOnly() - Method in class java.nio.file.FileSystem
Tells whether or not this file system allows only read-only access to its file stores.
isReadOnly() - Method in class java.security.PermissionCollection
Returns true if this PermissionCollection object is marked as readonly.
isReadOnly() - Method in interface java.sql.Connection
Retrieves whether this Connection object is in read-only mode.
isReadOnly() - Method in interface java.sql.DatabaseMetaData
Retrieves whether this database is in read-only mode.
isReadOnly(int) - Method in interface java.sql.ResultSetMetaData
Indicates whether the designated column is definitely not writable.
isReadOnly() - Method in class javax.imageio.metadata.IIOMetadata
Returns true if this object does not support the mergeTree, setFromTree, and reset methods.
isReadOnly() - Method in class javax.security.auth.Subject
Query whether this Subject is read-only.
isReadOnly() - Method in class javax.sql.rowset.BaseRowSet
Returns a boolean indicating whether this RowSet object is read-only.
isReadOnly() - Method in interface javax.sql.RowSet
Retrieves whether this RowSet object is read-only.
isReadOnly(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl
Indicates whether the designated column is definitely not writable, thus readonly.
isRecording() - Method in interface javax.sound.midi.Sequencer
Indicates whether the Sequencer is currently recording.
isRectangleContainingRectangle(Rectangle, Rectangle) - Static method in class javax.swing.SwingUtilities
Return true if a contains b
isRectangular() - Method in class java.awt.geom.Area
Tests whether this Area is rectangular in shape.
isRedefineClassesSupported() - Method in interface java.lang.instrument.Instrumentation
Returns whether or not the current JVM configuration supports redefinition of classes.
isRegistered() - Method in class java.nio.channels.SelectableChannel
Tells whether or not this channel is currently registered with any selectors.
isRegistered() - Method in class java.nio.channels.spi.AbstractSelectableChannel
isRegistered() - Method in class java.nio.charset.Charset
Tells whether or not this charset is registered in the IANA Charset Registry.
isRegistered(ObjectName) - Method in interface javax.management.MBeanServer
isRegistered(ObjectName) - Method in interface javax.management.MBeanServerConnection
Checks whether an MBean, identified by its object name, is already registered with the MBean server.
isRegistered(ObjectName, Subject) - Method in interface javax.management.remote.rmi.RMIConnection
Handles the method MBeanServerConnection.isRegistered(ObjectName).
isRegistered(ObjectName, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl
isRegistered(ObjectName, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub
isRegularFile() - Method in interface java.nio.file.attribute.BasicFileAttributes
Tells whether the file is a regular file with opaque content.
isRegularFile(Path, LinkOption...) - Static method in class java.nio.file.Files
Tests whether a file is a regular file with opaque content.
isRelation(ObjectName) - Method in class javax.management.relation.RelationService
Returns the relation id associated to the given ObjectName if the MBean has been added as a relation in the Relation Service.
isRelation(ObjectName) - Method in interface javax.management.relation.RelationServiceMBean
Returns the relation id associated to the given ObjectName if the MBean has been added as a relation in the Relation Service.
isRelationMBean(String) - Method in class javax.management.relation.RelationService
If the relation is represented by an MBean (created by the user and added as a relation in the Relation Service), returns the ObjectName of the MBean.
isRelationMBean(String) - Method in interface javax.management.relation.RelationServiceMBean
If the relation is represented by an MBean (created by the user and added as a relation in the Relation Service), returns the ObjectName of the MBean.
isRelative() - Method in class javax.naming.NameClassPair
Determines whether the name of this binding is relative to the target context (which is named by the first parameter of the list() method).
isReleasable() - Method in interface java.util.concurrent.ForkJoinPool.ManagedBlocker
Returns true if blocking is unnecessary.
isRemoved() - Method in class java.util.prefs.AbstractPreferences
Returns true iff this node (or an ancestor) has been removed with the AbstractPreferences.removeNode() method.
isRenewable() - Method in class javax.security.auth.kerberos.KerberosTicket
Determines is this ticket is renewable.
isRepeats() - Method in class javax.swing.Timer
Returns true (the default) if the Timer will send an action event to its listeners multiple times.
isReplacing - Variable in class javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit
isRepresentationClassByteBuffer() - Method in class java.awt.datatransfer.DataFlavor
Returns whether the representation class for this DataFlavor is java.nio.ByteBuffer or a subclass thereof.
isRepresentationClassCharBuffer() - Method in class java.awt.datatransfer.DataFlavor
Returns whether the representation class for this DataFlavor is java.nio.CharBuffer or a subclass thereof.
isRepresentationClassInputStream() - Method in class java.awt.datatransfer.DataFlavor
Does the DataFlavor represent a java.io.InputStream?
isRepresentationClassReader() - Method in class java.awt.datatransfer.DataFlavor
Returns whether the representation class for this DataFlavor is java.io.Reader or a subclass thereof.
isRepresentationClassRemote() - Method in class java.awt.datatransfer.DataFlavor
Returns true if the representation class is Remote.
isRepresentationClassSerializable() - Method in class java.awt.datatransfer.DataFlavor
Returns true if the representation class can be serialized.
isRequestFocusEnabled() - Method in class javax.swing.JComponent
Returns true if this JComponent should get focus; otherwise returns false.
isRequired() - Method in class javax.xml.ws.soap.AddressingFeature
If addressing is enabled, this property determines whether the endpoint requires WS-Addressing.
isResizable() - Method in class java.awt.Dialog
Indicates whether this dialog is resizable by the user.
isResizable() - Method in class java.awt.Frame
Indicates whether this frame is resizable by the user.
isResizable() - Method in class javax.swing.JInternalFrame
Returns whether the JInternalFrame can be resized by some user action.
isResizable - Variable in class javax.swing.table.TableColumn
If true, the user is allowed to resize the column; the default is true.
isRetransformClassesSupported() - Method in interface java.lang.instrument.Instrumentation
Returns whether or not the current JVM configuration supports retransformation of classes.
isRevocationEnabled() - Method in class java.security.cert.PKIXParameters
Checks the RevocationEnabled flag.
isRevoked(Certificate) - Method in class java.security.cert.CRL
Checks whether the given certificate is on this CRL.
isRightMouseButton(MouseEvent) - Static method in class javax.swing.SwingUtilities
Returns true if the mouse event specifies the right mouse button.
isRightToLeft() - Method in class java.text.Bidi
Return true if the line is all right-to-left text, and the base direction is right-to-left.
isRoleStatus(int) - Static method in class javax.management.relation.RoleStatus
Returns true if given value corresponds to a known role status, false otherwise.
isRollover() - Method in interface javax.swing.ButtonModel
Indicates that the mouse is over the button.
isRollover() - Method in class javax.swing.DefaultButtonModel
Indicates that the mouse is over the button.
isRollover() - Method in class javax.swing.JToolBar
Returns the rollover state.
isRolloverBorders() - Method in class javax.swing.plaf.basic.BasicToolBarUI
Returns a flag to determine whether rollover button borders are enabled.
isRolloverEnabled() - Method in class javax.swing.AbstractButton
Gets the rolloverEnabled property.
isRoot(File) - Method in class javax.swing.filechooser.FileSystemView
Determines if the given file is a root in the navigable tree(s).
isRoot() - Method in class javax.swing.tree.DefaultMutableTreeNode
Returns true if this node is the root of the tree.
isRootPaneCheckingEnabled() - Method in class javax.swing.JApplet
Returns whether calls to add and setLayout are forwarded to the contentPane.
isRootPaneCheckingEnabled() - Method in class javax.swing.JDialog
Returns whether calls to add and setLayout are forwarded to the contentPane.
isRootPaneCheckingEnabled() - Method in class javax.swing.JFrame
Returns whether calls to add and setLayout are forwarded to the contentPane.
isRootPaneCheckingEnabled() - Method in class javax.swing.JInternalFrame
Returns whether calls to add and setLayout are forwarded to the contentPane.
isRootPaneCheckingEnabled() - Method in class javax.swing.JWindow
Returns whether calls to add and setLayout are forwarded to the contentPane.
isRootVisible() - Method in class javax.swing.JTree
Returns true if the root node of the tree is displayed.
isRootVisible() - Method in class javax.swing.plaf.basic.BasicTreeUI
isRootVisible() - Method in class javax.swing.tree.AbstractLayoutCache
Returns true if the root node of the tree is displayed.
isRowSelected(int) - Method in class javax.swing.JTable
Returns true if the specified index is in the valid range of rows, and the row at that index is selected.
isRowSelected(int) - Method in class javax.swing.JTree
Returns true if the node identified by row is selected.
isRowSelected(int) - Method in class javax.swing.tree.DefaultTreeSelectionModel
Returns true if the row identified by row is selected.
isRowSelected(int) - Method in interface javax.swing.tree.TreeSelectionModel
Returns true if the row identified by row is selected.
isRunning() - Method in interface javax.sound.midi.Sequencer
Indicates whether the Sequencer is currently running.
isRunning() - Method in interface javax.sound.sampled.DataLine
Indicates whether the line is running.
isRunning() - Method in class javax.swing.Timer
Returns true if the Timer is running.
isSameFile(Path, Path) - Static method in class java.nio.file.Files
Tests if two paths locate the same file.
isSameFile(Path, Path) - Method in class java.nio.file.spi.FileSystemProvider
Tests if two paths locate the same file.
isSameFile(FileObject, FileObject) - Method in class javax.tools.ForwardingJavaFileManager
isSameFile(FileObject, FileObject) - Method in interface javax.tools.JavaFileManager
Compares two file objects and return true if they represent the same underlying object.
isSameFile(FileObject, FileObject) - Method in interface javax.tools.StandardJavaFileManager
Compares two file objects and return true if they represent the same canonical file, zip file entry, or entry in any file system based container.
isSameNode(Node) - Method in class javax.imageio.metadata.IIOMetadataNode
This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
isSameNode(Node) - Method in interface org.w3c.dom.Node
Returns whether this node is the same node as the given one.
isSameRM(XAResource) - Method in interface javax.transaction.xa.XAResource
This method is called to determine if the resource manager instance represented by the target object is the same as the resouce manager instance represented by the parameter xares.
isSameType(TypeMirror, TypeMirror) - Method in interface javax.lang.model.util.Types
Tests whether two TypeMirror objects represent the same type.
isSchemaLanguageSupported(String) - Method in class javax.xml.validation.SchemaFactory
Is specified schema supported by this SchemaFactory?
isSealed() - Method in class java.lang.Package
Returns true if this package is sealed.
isSealed(URL) - Method in class java.lang.Package
Returns true if this package is sealed with respect to the specified code source url.
isSearchable(int) - Method in interface java.sql.ResultSetMetaData
Indicates whether the designated column can be used in a where clause.
isSearchable(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl
Indicates whether a value stored in the designated column can be used in a WHERE clause.
isSeekForwardOnly() - Method in class javax.imageio.ImageReader
Returns true if the current input source has been marked as seek forward only by passing true as the seekForwardOnly argument to the setInput method.
isSelected() - Method in class java.awt.im.InputMethodHighlight
Returns whether the text range is selected.
isSelected(int) - Method in class java.awt.List
Deprecated.
As of JDK version 1.1, replaced by isIndexSelected(int).
isSelected() - Method in class javax.swing.AbstractButton
Returns the state of the button.
isSelected(ButtonModel) - Method in class javax.swing.ButtonGroup
Returns whether a ButtonModel is selected.
isSelected() - Method in interface javax.swing.ButtonModel
Indicates if the button has been selected.
isSelected() - Method in class javax.swing.DefaultButtonModel
Indicates if the button has been selected.
isSelected() - Method in class javax.swing.DefaultSingleSelectionModel
isSelected - Variable in class javax.swing.JInternalFrame
The frame is currently selected.
isSelected() - Method in class javax.swing.JInternalFrame
Returns whether the JInternalFrame is the currently "selected" or active frame.
isSelected() - Method in class javax.swing.JMenu
Returns true if the menu is currently selected (highlighted).
isSelected() - Method in class javax.swing.JMenuBar
Returns true if the menu bar currently has a component selected.
isSelected() - Method in class javax.swing.JToggleButton.ToggleButtonModel
Checks if the button is selected.
isSelected - Variable in class javax.swing.plaf.basic.BasicMenuUI.ChangeHandler
isSelected() - Method in interface javax.swing.SingleSelectionModel
Returns true if the selection model currently has a selected value.
isSelected() - Method in class javax.swing.text.html.Option
Fetches the selection state associated with this option.
isSelectedIndex(int) - Method in class javax.swing.DefaultListSelectionModel
Returns true if the specified index is selected.
isSelectedIndex(int) - Method in class javax.swing.JList
Returns true if the specified index is selected, else false.
isSelectedIndex(int) - Method in interface javax.swing.ListSelectionModel
Returns true if the specified index is selected.
isSelectionEmpty() - Method in class javax.swing.DefaultListSelectionModel
Returns true if no indices are selected.
isSelectionEmpty() - Method in class javax.swing.JList
Returns true if nothing is selected, else false.
isSelectionEmpty() - Method in class javax.swing.JTree
Returns true if the selection is currently empty.
isSelectionEmpty() - Method in interface javax.swing.ListSelectionModel
Returns true if no indices are selected.
isSelectionEmpty() - Method in class javax.swing.tree.DefaultTreeSelectionModel
Returns true if the selection is currently empty.
isSelectionEmpty() - Method in interface javax.swing.tree.TreeSelectionModel
Returns true if the selection is currently empty.
isSelectionVisible() - Method in interface javax.swing.text.Caret
Determines if the selection is currently visible.
isSelectionVisible() - Method in class javax.swing.text.DefaultCaret
Checks whether the current selection is visible.
isSerializing() - Method in class java.beans.beancontext.BeanContextSupport
Is this BeanContext in the process of being serialized?
isServiceClass(Class) - Method in class java.beans.beancontext.BeanContextServiceRevokedEvent
Checks this event to determine whether or not the service being revoked is of a particular class.
isSet - Variable in class java.util.Calendar
The flags which tell if a specified calendar field for the calendar is set.
isSet(int) - Method in class java.util.Calendar
Determines if the given calendar field has a value set, including cases that the value has been set by internal fields calculations triggered by a get method call.
isSet(DatatypeConstants.Field) - Method in class javax.xml.datatype.Duration
Checks if a field is set.
isShared() - Method in class java.nio.channels.FileLock
Tells whether this lock is shared.
isShiftDown() - Method in class java.awt.event.InputEvent
Returns whether or not the Shift modifier is down on this event.
isShorterThan(Duration) - Method in class javax.xml.datatype.Duration
Checks if this duration object is strictly shorter than another Duration object.
isShowing() - Method in class java.awt.Component.AccessibleAWTComponent
Determines if the object is showing.
isShowing() - Method in class java.awt.Component
Determines whether this component is showing on screen.
isShowing() - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild
Determine if the object is showing.
isShowing() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent
Determines if the object is showing.
isShowing() - Method in class java.awt.Window
Checks if this Window is showing on screen.
isShowing() - Method in interface javax.accessibility.AccessibleComponent
Determines if the object is showing.
isShowing() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild
isShowing() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell
Determines if the object is showing.
isShowing() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode
isShowing() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
isShutdown() - Method in class java.nio.channels.AsynchronousChannelGroup
Tells whether or not this asynchronous channel group is shutdown.
isShutdown() - Method in interface java.util.concurrent.ExecutorService
Returns true if this executor has been shut down.
isShutdown() - Method in class java.util.concurrent.ForkJoinPool
Returns true if this pool has been shut down.
isShutdown() - Method in class java.util.concurrent.ThreadPoolExecutor
isSigned(int) - Method in interface java.sql.ParameterMetaData
Retrieves whether values for the designated parameter can be signed numbers.
isSigned(int) - Method in interface java.sql.ResultSetMetaData
Indicates whether values in the designated column are signed numbers.
isSigned(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl
Indicates whether a value stored in the designated column is a signed number.
isSignificant() - Method in class javax.swing.text.AbstractDocument.DefaultDocumentEvent
DefaultDocument events are significant.
isSignificant() - Method in class javax.swing.undo.AbstractUndoableEdit
This default implementation returns true.
isSignificant() - Method in class javax.swing.undo.CompoundEdit
Returns true if any of the UndoableEdits in edits do.
isSignificant() - Method in interface javax.swing.undo.UndoableEdit
Returns true if this edit is considered significant.
isSingular() - Method in class java.awt.geom.Area
Tests whether this Area is comprised of a single closed subpath.
isSiteLocalAddress() - Method in class java.net.Inet4Address
Utility routine to check if the InetAddress is a site local address.
isSiteLocalAddress() - Method in class java.net.Inet6Address
Utility routine to check if the InetAddress is a site local address.
isSiteLocalAddress() - Method in class java.net.InetAddress
Utility routine to check if the InetAddress is a site local address.
isSortable(int) - Method in class javax.swing.DefaultRowSorter
Returns true if the specified column is sortable; otherwise, false.
isSorted() - Method in class javax.naming.ldap.SortResponseControl
Determines if the search results have been successfully sorted.
isSoundbankSupported(Soundbank) - Method in interface javax.sound.midi.Synthesizer
Informs the caller whether this synthesizer is capable of loading instruments from the specified soundbank.
isSource() - Method in class javax.sound.sampled.Port.Info
Indicates whether the port is a source or a target for its mixer.
isSourceEncodingSupported(AudioFormat.Encoding) - Method in class javax.sound.sampled.spi.FormatConversionProvider
Indicates whether the format converter supports conversion from the specified source format encoding.
isSpace(char) - Static method in class java.lang.Character
Deprecated.
Replaced by isWhitespace(char).
isSpaceChar(char) - Static method in class java.lang.Character
Determines if the specified character is a Unicode space character.
isSpaceChar(int) - Static method in class java.lang.Character
Determines if the specified character (Unicode code point) is a Unicode space character.
isSpecified() - Method in interface javax.xml.stream.events.Attribute
A flag indicating whether this attribute was actually specified in the start-tag of its element, or was defaulted from the schema.
isSpecified(int) - Method in class javax.xml.validation.TypeInfoProvider
Returns false if the attribute was added by the validator.
isSpecified(int) - Method in interface org.xml.sax.ext.Attributes2
Returns true unless the attribute value was provided by DTD defaulting.
isSpecified(String, String) - Method in interface org.xml.sax.ext.Attributes2
Returns true unless the attribute value was provided by DTD defaulting.
isSpecified(String) - Method in interface org.xml.sax.ext.Attributes2
Returns true unless the attribute value was provided by DTD defaulting.
isSpecified(int) - Method in class org.xml.sax.ext.Attributes2Impl
Returns the current value of an attribute's "specified" flag.
isSpecified(String, String) - Method in class org.xml.sax.ext.Attributes2Impl
Returns the current value of an attribute's "specified" flag.
isSpecified(String) - Method in class org.xml.sax.ext.Attributes2Impl
Returns the current value of an attribute's "specified" flag.
isStandalone() - Method in enum java.time.format.TextStyle
Returns true if the Style is a stand-alone style.
isStandalone() - Method in interface javax.xml.stream.events.StartDocument
Returns if this XML is standalone
isStandalone() - Method in class javax.xml.stream.util.StreamReaderDelegate
isStandalone() - Method in interface javax.xml.stream.XMLStreamReader
Get the standalone declaration from the xml declaration
isStandard() - Method in class java.awt.font.GlyphMetrics
Returns true if this is a standard glyph.
isStandardImageMetadataFormatSupported() - Method in class javax.imageio.spi.ImageReaderWriterSpi
Returns true if the standard metadata format is among the document formats recognized by the getAsTree and setFromTree methods on the image metadata objects produced or consumed by this plug-in.
isStandardMetadataFormatSupported() - Method in class javax.imageio.metadata.IIOMetadata
Returns true if the standard metadata format is supported by getMetadataFormat, getAsTree, setFromTree, and mergeTree.
isStandardStreamMetadataFormatSupported() - Method in class javax.imageio.spi.ImageReaderWriterSpi
Returns true if the standard metadata format is among the document formats recognized by the getAsTree and setFromTree methods on the stream metadata objects produced or consumed by this plug-in.
isStartDocument() - Method in interface javax.xml.stream.events.XMLEvent
A utility function to check if this event is a StartDocument.
isStartElement() - Method in interface javax.xml.stream.events.XMLEvent
A utility function to check if this event is a StartElement.
isStartElement() - Method in class javax.xml.stream.util.StreamReaderDelegate
isStartElement() - Method in interface javax.xml.stream.XMLStreamReader
Returns true if the cursor points to a start tag (otherwise false)
isStatic(int) - Static method in class java.lang.reflect.Modifier
Return true if the integer argument includes the static modifier, false otherwise.
isStrict(int) - Static method in class java.lang.reflect.Modifier
Return true if the integer argument includes the strictfp modifier, false otherwise.
isStrikeThrough() - Method in class javax.swing.text.GlyphView
Determine if the glyphs should have a strikethrough line.
isStrikeThrough() - Method in class javax.swing.text.LabelView
Determines if the glyphs should have a strikethrough line.
isStrikeThrough(AttributeSet) - Static method in class javax.swing.text.StyleConstants
Checks whether the strikethrough attribute is set.
isStringPainted() - Method in class javax.swing.JProgressBar
Returns the value of the stringPainted property.
isSubregion() - Method in class javax.swing.plaf.synth.Region
Returns true if the Region is a subregion of a Component, otherwise false.
isSubscript() - Method in class javax.swing.text.GlyphView
Determine if the glyphs should be rendered as superscript.
isSubscript() - Method in class javax.swing.text.LabelView
Determines if the glyphs should be rendered as superscript.
isSubscript(AttributeSet) - Static method in class javax.swing.text.StyleConstants
Checks whether the subscript attribute is set.
isSubsignature(ExecutableType, ExecutableType) - Method in interface javax.lang.model.util.Types
Tests whether the signature of one method is a subsignature of another.
isSubtype(TypeMirror, TypeMirror) - Method in interface javax.lang.model.util.Types
Tests whether one type is a subtype of another.
isSuperscript() - Method in class javax.swing.text.GlyphView
Determine if the glyphs should be rendered as subscript.
isSuperscript() - Method in class javax.swing.text.LabelView
Determines if the glyphs should be rendered as subscript.
isSuperscript(AttributeSet) - Static method in class javax.swing.text.StyleConstants
Checks whether the superscript attribute is set.
isSupplementaryCodePoint(int) - Static method in class java.lang.Character
Determines whether the specified character (Unicode code point) is in the supplementary character range.
isSupported(Desktop.Action) - Method in class java.awt.Desktop
Tests whether an action is supported on the current platform.
isSupported() - Static method in class java.awt.SystemTray
Returns whether the system tray is supported on the current platform.
isSupported(String) - Static method in class java.nio.charset.Charset
Tells whether the named charset is supported.
isSupported(TemporalField) - Method in interface java.time.chrono.ChronoLocalDate
Checks if the specified field is supported.
isSupported(TemporalUnit) - Method in interface java.time.chrono.ChronoLocalDate
Checks if the specified unit is supported.
isSupported(TemporalField) - Method in interface java.time.chrono.ChronoLocalDateTime
Checks if the specified field is supported.
isSupported(TemporalUnit) - Method in interface java.time.chrono.ChronoLocalDateTime
Checks if the specified unit is supported.
isSupported(TemporalField) - Method in interface java.time.chrono.ChronoZonedDateTime
Checks if the specified field is supported.
isSupported(TemporalUnit) - Method in interface java.time.chrono.ChronoZonedDateTime
Checks if the specified unit is supported.
isSupported(TemporalField) - Method in interface java.time.chrono.Era
Checks if the specified field is supported.
isSupported(TemporalField) - Method in class java.time.chrono.JapaneseDate
Checks if the specified field is supported.
isSupported(TemporalField) - Method in enum java.time.DayOfWeek
Checks if the specified field is supported.
isSupported(TemporalField) - Method in class java.time.Instant
Checks if the specified field is supported.
isSupported(TemporalUnit) - Method in class java.time.Instant
Checks if the specified unit is supported.
isSupported(TemporalField) - Method in class java.time.LocalDate
Checks if the specified field is supported.
isSupported(TemporalUnit) - Method in class java.time.LocalDate
Checks if the specified unit is supported.
isSupported(TemporalField) - Method in class java.time.LocalDateTime
Checks if the specified field is supported.
isSupported(TemporalUnit) - Method in class java.time.LocalDateTime
Checks if the specified unit is supported.
isSupported(TemporalField) - Method in class java.time.LocalTime
Checks if the specified field is supported.
isSupported(TemporalUnit) - Method in class java.time.LocalTime
Checks if the specified unit is supported.
isSupported(TemporalField) - Method in enum java.time.Month
Checks if the specified field is supported.
isSupported(TemporalField) - Method in class java.time.MonthDay
Checks if the specified field is supported.
isSupported(TemporalField) - Method in class java.time.OffsetDateTime
Checks if the specified field is supported.
isSupported(TemporalUnit) - Method in class java.time.OffsetDateTime
Checks if the specified unit is supported.
isSupported(TemporalField) - Method in class java.time.OffsetTime
Checks if the specified field is supported.
isSupported(TemporalUnit) - Method in class java.time.OffsetTime
Checks if the specified unit is supported.
isSupported(TemporalUnit) - Method in interface java.time.temporal.Temporal
Checks if the specified unit is supported.
isSupported(TemporalField) - Method in interface java.time.temporal.TemporalAccessor
Checks if the specified field is supported.
isSupported(TemporalField) - Method in class java.time.Year
Checks if the specified field is supported.
isSupported(TemporalUnit) - Method in class java.time.Year
Checks if the specified unit is supported.
isSupported(TemporalField) - Method in class java.time.YearMonth
Checks if the specified field is supported.
isSupported(TemporalUnit) - Method in class java.time.YearMonth
Checks if the specified unit is supported.
isSupported(TemporalField) - Method in class java.time.ZonedDateTime
Checks if the specified field is supported.
isSupported(TemporalUnit) - Method in class java.time.ZonedDateTime
Checks if the specified unit is supported.
isSupported(TemporalField) - Method in class java.time.ZoneOffset
Checks if the specified field is supported.
isSupported(String, String) - Method in class javax.imageio.metadata.IIOMetadataNode
Returns false since DOM features are not supported.
isSupported(String, String) - Method in interface org.w3c.dom.Node
Tests whether the DOM implementation implements a specific feature and that feature is supported by this node, as specified in .
isSupportedBy(TemporalAccessor) - Method in enum java.time.temporal.ChronoField
isSupportedBy(Temporal) - Method in enum java.time.temporal.ChronoUnit
isSupportedBy(TemporalAccessor) - Method in interface java.time.temporal.TemporalField
Checks if this field is supported by the temporal object.
isSupportedBy(Temporal) - Method in interface java.time.temporal.TemporalUnit
Checks if this unit is supported by the specified temporal object.
isSupportedLocale(Locale) - Method in class java.util.spi.LocaleServiceProvider
Returns true if the given locale is supported by this locale service provider.
isSupportedLookAndFeel() - Method in class javax.swing.LookAndFeel
Return true if the underlying platform supports and or permits this look and feel.
isSupportedLookAndFeel() - Method in class javax.swing.plaf.metal.MetalLookAndFeel
Returns true; MetalLookAndFeel can be run on any platform.
isSupportedLookAndFeel() - Method in class javax.swing.plaf.multi.MultiLookAndFeel
Returns true; every platform permits this look and feel.
isSupportedLookAndFeel() - Method in class javax.swing.plaf.synth.SynthLookAndFeel
Returns true, SynthLookAndFeel is always supported.
isSupportedOption(String) - Method in class javax.tools.ForwardingJavaFileManager
isSupportedOption(String) - Method in interface javax.tools.OptionChecker
Determines if the given option is supported and if so, the number of arguments the option takes.
isSurrogate(char) - Static method in class java.lang.Character
Determines if the given char value is a Unicode surrogate code unit.
isSurrogatePair(char, char) - Static method in class java.lang.Character
Determines whether the specified pair of char values is a valid Unicode surrogate pair.
isSuspended() - Method in class java.lang.management.ThreadInfo
Tests if the thread associated with this ThreadInfo is suspended.
isSymbolicLink() - Method in interface java.nio.file.attribute.BasicFileAttributes
Tells whether the file is a symbolic link.
isSymbolicLink(Path) - Static method in class java.nio.file.Files
Tests whether a file is a symbolic link.
isSynchronizationSupported(Line[], boolean) - Method in interface javax.sound.sampled.Mixer
Reports whether this mixer supports synchronization of the specified set of lines.
isSynchronized(int) - Static method in class java.lang.reflect.Modifier
Return true if the integer argument includes the synchronized modifier, false otherwise.
isSynchronizerUsageSupported() - Method in interface java.lang.management.ThreadMXBean
Tests if the Java virtual machine supports monitoring of ownable synchronizer usage.
isSynthetic() - Method in class java.lang.Class
Returns true if this class is a synthetic class; returns false otherwise.
isSynthetic() - Method in class java.lang.reflect.Constructor
Returns true if this executable is a synthetic construct; returns false otherwise.
isSynthetic() - Method in class java.lang.reflect.Executable
Returns true if this executable is a synthetic construct; returns false otherwise.
isSynthetic() - Method in class java.lang.reflect.Field
Returns true if this field is a synthetic field; returns false otherwise.
isSynthetic() - Method in interface java.lang.reflect.Member
Returns true if this member was introduced by the compiler; returns false otherwise.
isSynthetic() - Method in class java.lang.reflect.Method
Returns true if this executable is a synthetic construct; returns false otherwise.
isSynthetic() - Method in class java.lang.reflect.Parameter
Returns true if this parameter is neither implicitly nor explicitly declared in source code; returns false otherwise.
isSystem() - Method in interface java.nio.file.attribute.DosFileAttributes
Returns the value of the system attribute.
isTargetEncodingSupported(AudioFormat.Encoding) - Method in class javax.sound.sampled.spi.FormatConversionProvider
Indicates whether the format converter supports conversion to the specified target format encoding.
isTearOff() - Method in class java.awt.Menu
Indicates whether this menu is a tear-off menu.
isTearOff() - Method in class javax.swing.JMenu
Returns true if the menu can be torn off.
isTemporary() - Method in class java.awt.event.FocusEvent
Identifies the focus change event as temporary or permanent.
isTerminated() - Method in class java.nio.channels.AsynchronousChannelGroup
Tells whether or not this group has terminated.
isTerminated() - Method in interface java.util.concurrent.ExecutorService
Returns true if all tasks have completed following shut down.
isTerminated() - Method in class java.util.concurrent.ForkJoinPool
Returns true if all tasks have completed following shut down.
isTerminated() - Method in class java.util.concurrent.Phaser
Returns true if this phaser has been terminated.
isTerminated() - Method in class java.util.concurrent.ThreadPoolExecutor
isTerminating() - Method in class java.util.concurrent.ForkJoinPool
Returns true if the process of termination has commenced but not yet completed.
isTerminating() - Method in class java.util.concurrent.ThreadPoolExecutor
Returns true if this executor is in the process of terminating after ThreadPoolExecutor.shutdown() or ThreadPoolExecutor.shutdownNow() but has not completely terminated.
isText(Element) - Method in class javax.swing.text.html.MinimalHTMLWriter
Returns true if the element is a text element.
isThreadContentionMonitoringEnabled() - Method in interface java.lang.management.ThreadMXBean
Tests if thread contention monitoring is enabled.
isThreadContentionMonitoringSupported() - Method in interface java.lang.management.ThreadMXBean
Tests if the Java virtual machine supports thread contention monitoring.
isThreadCpuTimeEnabled() - Method in interface java.lang.management.ThreadMXBean
Tests if thread CPU time measurement is enabled.
isThreadCpuTimeSupported() - Method in interface java.lang.management.ThreadMXBean
Tests if the Java virtual machine implementation supports CPU time measurement for any thread.
isThumbRollover() - Method in class javax.swing.plaf.basic.BasicScrollBarUI
Returns true if the mouse is currently over the thumb.
isTileWritable(int, int) - Method in class java.awt.image.BufferedImage
Returns whether or not a tile is currently checked out for writing.
isTileWritable(int, int) - Method in interface java.awt.image.WritableRenderedImage
Returns whether a tile is currently checked out for writing.
isTimeBased() - Method in enum java.time.temporal.ChronoField
Checks if this field represents a component of a time.
isTimeBased() - Method in enum java.time.temporal.ChronoUnit
Checks if this unit is a time unit.
isTimeBased() - Method in interface java.time.temporal.TemporalField
Checks if this field represents a component of a time.
isTimeBased() - Method in interface java.time.temporal.TemporalUnit
Checks if this unit represents a component of a time.
isTimeSet - Variable in class java.util.Calendar
True if then the value of time is valid.
isTitleCase(char) - Static method in class java.lang.Character
Determines if the specified character is a titlecase character.
isTitleCase(int) - Static method in class java.lang.Character
Determines if the specified character (Unicode code point) is a titlecase character.
isToggleEvent(MouseEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI
Returning true indicates the row under the mouse should be toggled based on the event.
isToggleSelectionEvent(MouseEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI
Returning true signifies a mouse event on the node should toggle the selection of only the row under mouse.
isTopDown() - Method in class javax.imageio.plugins.bmp.BMPImageWriteParam
Returns the value of the topDown parameter.
isTopLevelMenu() - Method in class javax.swing.JMenu
Returns true if the menu is a 'top-level menu', that is, if it is the direct child of a menubar.
isTransferable() - Method in interface org.ietf.jgss.GSSContext
Determines if the context is transferable to other processes through the use of the export method.
isTransformed() - Method in class java.awt.font.FontRenderContext
Indicates whether or not this FontRenderContext object measures text in a transformed render context.
isTransformed() - Method in class java.awt.Font
Indicates whether or not this Font object has a transform that affects its size in addition to the Size attribute.
isTransient(int) - Static method in class java.lang.reflect.Modifier
Return true if the integer argument includes the transient modifier, false otherwise.
isTranslucencyCapable() - Method in class java.awt.GraphicsConfiguration
Returns whether this GraphicsConfiguration supports the PERPIXEL_TRANSLUCENT kind of translucency.
isTraversable(File) - Method in class javax.swing.filechooser.FileSystemView
Returns true if the file (directory) can be visited.
isTraversable(File) - Method in class javax.swing.filechooser.FileView
Whether the directory is traversable or not.
isTraversable(File) - Method in class javax.swing.JFileChooser
Returns true if the file (directory) can be visited.
IstringHelper - Class in org.omg.CosNaming
org/omg/CosNaming/IstringHelper.java .
IstringHelper() - Constructor for class org.omg.CosNaming.IstringHelper
isTrueVolatile() - Method in class java.awt.ImageCapabilities
Returns true if the VolatileImage described by this ImageCapabilities can lose its surfaces.
isTypeSubstituted() - Method in class javax.xml.bind.JAXBElement
Returns true iff this xml element instance's value has a different type than xml element declaration's declared type.
isUndecorated() - Method in class java.awt.Dialog
Indicates whether this dialog is undecorated.
isUndecorated() - Method in class java.awt.Frame
Indicates whether this frame is undecorated.
isUnderflow() - Method in class java.nio.charset.CoderResult
Tells whether or not this object describes an underflow condition.
isUnderline() - Method in class javax.swing.text.GlyphView
Determine if the glyphs should be underlined.
isUnderline() - Method in class javax.swing.text.LabelView
Determines if the glyphs should be underlined.
isUnderline(AttributeSet) - Static method in class javax.swing.text.StyleConstants
Checks whether the underline attribute is set.
isUnicast() - Method in class java.beans.EventSetDescriptor
Normally event sources are multicast.
isUnicodeIdentifierPart(char) - Static method in class java.lang.Character
Determines if the specified character may be part of a Unicode identifier as other than the first character.
isUnicodeIdentifierPart(int) - Static method in class java.lang.Character
Determines if the specified character (Unicode code point) may be part of a Unicode identifier as other than the first character.
isUnicodeIdentifierStart(char) - Static method in class java.lang.Character
Determines if the specified character is permissible as the first character in a Unicode identifier.
isUnicodeIdentifierStart(int) - Static method in class java.lang.Character
Determines if the specified character (Unicode code point) is permissible as the first character in a Unicode identifier.
isUnique() - Static method in class java.rmi.dgc.VMID
Deprecated.
isUnmappable() - Method in class java.nio.charset.CoderResult
Tells whether or not this object describes an unmappable-character error.
isUnnamed() - Method in interface javax.lang.model.element.PackageElement
Returns true is this is an unnamed package and false otherwise.
isUnresolved() - Method in class java.net.InetSocketAddress
Checks whether the address has been resolved or not.
isUnseqToken() - Method in class org.ietf.jgss.MessageProp
Tests if a later token had already been processed.
isUnshared() - Method in class java.io.ObjectStreamField
Returns boolean value indicating whether or not the serializable field represented by this ObjectStreamField instance is unshared.
isUp() - Method in class java.net.NetworkInterface
Returns whether a network interface is up and running.
isUpperCase(char) - Static method in class java.lang.Character
Determines if the specified character is an uppercase character.
isUpperCase(int) - Static method in class java.lang.Character
Determines if the specified character (Unicode code point) is an uppercase character.
isUsageThresholdExceeded() - Method in interface java.lang.management.MemoryPoolMXBean
Tests if the memory usage of this memory pool reaches or exceeds its usage threshold value.
isUsageThresholdSupported() - Method in interface java.lang.management.MemoryPoolMXBean
Tests if this memory pool supports usage threshold.
isUserInRole(String) - Method in class javax.xml.ws.spi.http.HttpExchange
Indicates whether an authenticated user is included in the specified logical "role".
isUserInRole(String) - Method in interface javax.xml.ws.WebServiceContext
Returns a boolean indicating whether the authenticated user is included in the specified logical role.
isUserNode() - Method in class java.util.prefs.AbstractPreferences
Implements the isUserNode method as per the specification in Preferences.isUserNode().
isUserNode() - Method in class java.util.prefs.Preferences
Returns true if this preference node is in the user preference tree, false if it's in the system preference tree.
isValid() - Method in class java.awt.Component
Determines whether this component is valid.
isValid(int) - Method in class java.awt.image.IndexColorModel
Returns whether or not the pixel is valid.
isValid() - Method in class java.awt.image.IndexColorModel
Returns whether or not all of the pixels are valid.
isValid() - Method in interface java.lang.management.MemoryManagerMXBean
Tests if this memory manager is valid in the Java virtual machine.
isValid() - Method in interface java.lang.management.MemoryPoolMXBean
Tests if this memory pool is valid in the Java virtual machine.
isValid() - Method in class java.nio.channels.FileLock
Tells whether or not this lock is valid.
isValid() - Method in class java.nio.channels.MembershipKey
Tells whether or not this membership is valid.
isValid() - Method in class java.nio.channels.SelectionKey
Tells whether or not this key is valid.
isValid() - Method in class java.nio.channels.spi.AbstractSelectionKey
isValid() - Method in interface java.nio.file.WatchKey
Tells whether or not this watch key is valid.
isValid(int) - Method in interface java.sql.Connection
Returns true if the connection has not been closed and is still valid.
isValid() - Method in class javax.accessibility.AccessibleHyperlink
Since the document a link is associated with may have changed, this method returns whether or not this Link is still valid (with respect to the document it references).
isValid() - Method in interface javax.management.Descriptor
Returns true if all of the fields have legal values given their names.
isValid() - Method in class javax.management.ImmutableDescriptor
Returns true if all of the fields have legal values given their names.
isValid() - Method in class javax.management.modelmbean.DescriptorSupport
Returns true if all of the fields have legal values given their names.
isValid() - Method in interface javax.net.ssl.SSLSession
Returns whether this session is valid and available for resuming or joining.
isValid() - Method in class javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink
Since the document a link is associated with may have changed, this method returns whether this Link is valid anymore (with respect to the document it references).
isValid() - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider.DragController
Returns true if the dragging session is valid.
isValid() - Method in class javax.swing.text.html.HTMLDocument.Iterator
Indicates if the iterator is currently representing an occurrence of a tag.
isValid() - Method in class javax.xml.datatype.XMLGregorianCalendar
Validate instance by getXMLSchemaType() constraints.
isValidateRoot() - Method in class java.applet.Applet
Indicates if this container is a validate root.
isValidateRoot() - Method in class java.awt.Container
Indicates if this container is a validate root.
isValidateRoot() - Method in class java.awt.Window
Indicates if this container is a validate root.
isValidateRoot() - Method in class javax.swing.JComponent
If this method returns true, revalidate calls by descendants of this component will cause the entire tree beginning with this root to be validated.
isValidateRoot() - Method in class javax.swing.JRootPane
If a descendant of this JRootPane calls revalidate, validate from here on down.
isValidateRoot() - Method in class javax.swing.JScrollPane
Overridden to return true so that any calls to revalidate on any descendants of this JScrollPane will cause the entire tree beginning with this JScrollPane to be validated.
isValidateRoot() - Method in class javax.swing.JSplitPane
Returns true, so that calls to revalidate on any descendant of this JSplitPane will cause a request to be queued that will validate the JSplitPane and all its descendants.
isValidateRoot() - Method in class javax.swing.JTextField
Calls to revalidate that come from within the textfield itself will be handled by validating the textfield, unless the textfield is contained within a JViewport, in which case this returns false.
isValidating() - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl
Indicates whether or not the Unmarshaller is configured to validate during unmarshal operations.
isValidating() - Method in interface javax.xml.bind.Unmarshaller
Deprecated.
since JAXB2.0, please see Unmarshaller.getSchema()
isValidating() - Method in class javax.xml.parsers.DocumentBuilder
Indicates whether or not this parser is configured to validate XML documents.
isValidating() - Method in class javax.xml.parsers.DocumentBuilderFactory
Indicates whether or not the factory is configured to produce parsers which validate the XML content during parse.
isValidating() - Method in class javax.xml.parsers.SAXParser
Indicates whether or not this parser is configured to validate XML documents.
isValidating() - Method in class javax.xml.parsers.SAXParserFactory
Indicates whether or not the factory is configured to produce parsers which validate the XML content during parse.
isValidCodePoint(int) - Static method in class java.lang.Character
Determines whether the specified code point is a valid Unicode code point value.
isValidDay(int) - Method in class java.time.YearMonth
Checks if the day-of-month is valid for this year-month.
isValidIntValue(long) - Method in class java.time.temporal.ValueRange
Checks if the value is within the valid range and that all values in the range fit in an int.
isValidMonthDay(MonthDay) - Method in class java.time.Year
Checks if the month-day is valid for this year.
isValidOffset(ZoneOffset) - Method in class java.time.zone.ZoneOffsetTransition
Checks if the specified offset is valid during this transition.
isValidOffset(LocalDateTime, ZoneOffset) - Method in class java.time.zone.ZoneRules
Checks if the offset date-time is valid for these rules.
isValidValue(long) - Method in class java.time.temporal.ValueRange
Checks if the value is within the valid range.
isValidYear(int) - Method in class java.time.MonthDay
Checks if the year is valid for this month-day.
isValue(Object) - Method in class javax.management.openmbean.ArrayType
Tests whether obj is a value for this ArrayType instance.
isValue(Object) - Method in class javax.management.openmbean.CompositeType
Tests whether obj is a value which could be described by this CompositeType instance.
isValue(Object) - Method in class javax.management.openmbean.OpenMBeanAttributeInfoSupport
Tests whether obj is a valid value for the attribute described by this OpenMBeanAttributeInfoSupport instance.
isValue(Object) - Method in interface javax.management.openmbean.OpenMBeanParameterInfo
Tests whether obj is a valid value for the parameter described by this OpenMBeanParameterInfo instance.
isValue(Object) - Method in class javax.management.openmbean.OpenMBeanParameterInfoSupport
Tests whether obj is a valid value for the parameter described by this OpenMBeanParameterInfo instance.
isValue(Object) - Method in class javax.management.openmbean.OpenType
Tests whether obj is a value for this open type.
isValue(Object) - Method in class javax.management.openmbean.SimpleType
Tests whether obj is a value for this SimpleType instance.
isValue(Object) - Method in class javax.management.openmbean.TabularType
Tests whether obj is a value which could be described by this TabularType instance.
isVarArgs() - Method in interface java.lang.invoke.MethodHandleInfo
Determines if the underlying member was a variable arity method or constructor.
isVarArgs() - Method in class java.lang.reflect.Constructor
Returns true if this executable was declared to take a variable number of arguments; returns false otherwise.
isVarArgs() - Method in class java.lang.reflect.Executable
Returns true if this executable was declared to take a variable number of arguments; returns false otherwise.
isVarArgs() - Method in class java.lang.reflect.Method
Returns true if this executable was declared to take a variable number of arguments; returns false otherwise.
isVarArgs() - Method in class java.lang.reflect.Parameter
Returns true if this parameter represents a variable argument list; returns false otherwise.
isVarArgs() - Method in interface javax.lang.model.element.ExecutableElement
Returns true if this method or constructor accepts a variable number of arguments and returns false otherwise.
isVarargsCollector() - Method in class java.lang.invoke.MethodHandle
Determines if this method handle supports variable arity calls.
isVerbose() - Method in interface java.lang.management.ClassLoadingMXBean
Tests if the verbose output for the class loading system is enabled.
isVerbose() - Method in interface java.lang.management.MemoryMXBean
Tests if verbose output for the memory system is enabled.
isVertical() - Method in class java.awt.font.TextLayout
Returns true if this TextLayout is vertical.
isViewSizeSet - Variable in class javax.swing.JViewport
True when the viewport dimensions have been determined.
isVirtual() - Method in class java.net.NetworkInterface
Returns whether this interface is a virtual interface (also called subinterface).
isVisible() - Method in class java.awt.Component.AccessibleAWTComponent
Determines if the object is visible.
isVisible() - Method in class java.awt.Component
Determines whether this component should be visible when its parent is visible.
isVisible() - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild
Determine if the object is visible.
isVisible() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent
Determines if the object is visible.
isVisible() - Method in class java.awt.SplashScreen
Determines whether the splash screen is visible.
isVisible() - Method in interface javax.accessibility.AccessibleComponent
Determines if the object is visible.
isVisible() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild
isVisible() - Method in class javax.swing.JPopupMenu
Returns true if the popup menu is visible (currently being displayed).
isVisible() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell
Determines if this object is visible.
isVisible() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode
isVisible(TreePath) - Method in class javax.swing.JTree
Returns true if the value identified by path is currently viewable, which means it is either the root or all of its parents are expanded.
isVisible() - Method in interface javax.swing.plaf.basic.ComboPopup
Returns true if the popup is visible (currently being displayed).
isVisible() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
isVisible() - Method in interface javax.swing.text.Caret
Determines if the caret is currently visible.
isVisible() - Method in class javax.swing.text.DefaultCaret
Indicates whether or not the caret is currently visible.
isVisible() - Method in class javax.swing.text.html.ParagraphView
Indicates whether or not this view should be displayed.
isVisible() - Method in class javax.swing.text.View
Returns a boolean that indicates whether the view is visible or not.
isVolatile(int) - Static method in class java.lang.reflect.Modifier
Return true if the integer argument includes the volatile modifier, false otherwise.
isWeak(byte[], int) - Static method in class javax.crypto.spec.DESKeySpec
Checks if the given DES key material is weak or semi-weak.
isWeekDateSupported() - Method in class java.util.Calendar
Returns whether this Calendar supports week dates.
isWeekDateSupported() - Method in class java.util.GregorianCalendar
Returns true indicating this GregorianCalendar supports week dates.
isWheelScrollingEnabled() - Method in class java.awt.ScrollPane
Indicates whether or not scrolling will take place in response to the mouse wheel.
isWheelScrollingEnabled() - Method in class javax.swing.JScrollPane
Indicates whether or not scrolling will take place in response to the mouse wheel.
isWhitespace() - Method in class java.awt.font.GlyphMetrics
Returns true if this is a whitespace glyph.
isWhitespace(char) - Static method in class java.lang.Character
Determines if the specified character is white space according to Java.
isWhitespace(int) - Static method in class java.lang.Character
Determines if the specified character (Unicode code point) is white space according to Java.
isWhiteSpace(char) - Static method in class javax.xml.bind.annotation.adapters.CollapsedStringAdapter
returns true if the specified char is a white space character.
isWhiteSpace() - Method in interface javax.xml.stream.events.Characters
Returns true if this set of Characters is all whitespace.
isWhiteSpace() - Method in class javax.xml.stream.util.StreamReaderDelegate
isWhiteSpace() - Method in interface javax.xml.stream.XMLStreamReader
Returns true if the cursor points to a character data event that consists of all whitespace
isWhiteSpaceExceptSpace(char) - Static method in class javax.xml.bind.annotation.adapters.NormalizedStringAdapter
Returns true if the specified char is a white space character but not 0x20.
isWindowTranslucencySupported(GraphicsDevice.WindowTranslucency) - Method in class java.awt.GraphicsDevice
Returns whether the given level of translucency is supported by this graphics device.
isWrapperFor(Class<?>) - Method in interface java.sql.Wrapper
Returns true if this either implements the interface argument or is directly or indirectly a wrapper for an object that does.
isWrapperFor(Class<?>) - Method in class javax.sql.rowset.RowSetMetaDataImpl
Returns true if this either implements the interface argument or is directly or indirectly a wrapper for an object that does.
isWrapperInstance(Object) - Static method in class java.lang.invoke.MethodHandleProxies
Determines if the given object was produced by a call to asInterfaceInstance.
isWritable() - Method in class java.nio.channels.SelectionKey
Tests whether this key's channel is ready for writing.
isWritable(Path) - Static method in class java.nio.file.Files
Tests whether a file is writable.
isWritable(int) - Method in interface java.sql.ResultSetMetaData
Indicates whether it is possible for a write on the designated column to succeed.
isWritable() - Method in class javax.management.MBeanAttributeInfo
Whether new values can be written to the attribute.
isWritable() - Method in interface javax.management.openmbean.OpenMBeanAttributeInfo
Returns true if the attribute described by this OpenMBeanAttributeInfo instance is writable, false otherwise.
isWritable() - Method in class javax.management.relation.RoleInfo
Returns write access mode for the role (true if it is writable).
isWritable(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl
Indicates whether it is possible for a write operation on the designated column to succeed.
isWriteLocked() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock
Queries if the write lock is held by any thread.
isWriteLocked() - Method in class java.util.concurrent.locks.StampedLock
Returns true if the lock is currently held exclusively.
isWriteLockedByCurrentThread() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock
Queries if the write lock is held by the current thread.
isXIncludeAware() - Method in class javax.xml.parsers.DocumentBuilder
Get the XInclude processing mode for this parser.
isXIncludeAware() - Method in class javax.xml.parsers.DocumentBuilderFactory
Get state of XInclude processing.
isXIncludeAware() - Method in class javax.xml.parsers.SAXParser
Get the XInclude processing mode for this parser.
isXIncludeAware() - Method in class javax.xml.parsers.SAXParserFactory
Get state of XInclude processing.
isXOPPackage() - Method in class javax.xml.bind.attachment.AttachmentMarshaller
Read-only property that returns true if JAXB marshaller should enable XOP creation.
isXOPPackage() - Method in class javax.xml.bind.attachment.AttachmentUnmarshaller
Read-only property that returns true if JAXB unmarshaller needs to perform XOP processing.
isZero() - Method in interface java.time.chrono.ChronoPeriod
Checks if all the supported units of this period are zero.
isZero() - Method in class java.time.Duration
Checks if this duration is zero length.
isZero() - Method in class java.time.Period
Checks if all three units of this period are zero.
isZoneLoaded(View) - Method in class javax.swing.text.ZoneView
Determine if a zone is in the loaded state.
ITALIAN - Static variable in class java.util.Locale
Useful constant for language.
ITALIC - Static variable in class java.awt.Font
The italicized style constant.
Italic - Static variable in class javax.swing.text.StyleConstants
Name of the italic attribute.
ITALIC_ACTION - Static variable in class javax.swing.text.html.HTMLEditorKit
The italic action identifier
ItalicAction() - Constructor for class javax.swing.text.StyledEditorKit.ItalicAction
Constructs a new ItalicAction.
ITALY - Static variable in class java.awt.PageAttributes.MediaType
An alias for ITALY_ENVELOPE.
ITALY - Static variable in class java.util.Locale
Useful constant for country.
ITALY_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for Italy Envelope, 110 x 230 mm.
ITALY_ENVELOPE - Static variable in class javax.print.attribute.standard.MediaSize.Other
Specifies the Italy envelope size, 110 mm by 230 mm.
ITALY_ENVELOPE - Static variable in class javax.print.attribute.standard.MediaSizeName
Italy envelope size .
item(int) - Method in class javax.imageio.metadata.IIOMetadataNode
item(int) - Method in class org.omg.CORBA.ContextList
Returns the String object at the given index.
item(int) - Method in class org.omg.CORBA.ExceptionList
Returns the TypeCode object at the given index.
item(int) - Method in class org.omg.CORBA.NVList
Retrieves the NamedValue object at the given index.
item(int) - Method in interface org.w3c.dom.DOMImplementationList
Returns the indexth item in the collection.
item(int) - Method in interface org.w3c.dom.DOMStringList
Returns the indexth item in the collection.
item(int) - Method in interface org.w3c.dom.NamedNodeMap
Returns the indexth item in the map.
item(int) - Method in interface org.w3c.dom.NodeList
Returns the indexth item in the collection.
ITEM_EVENT_MASK - Static variable in class java.awt.AWTEvent
The event mask for selecting item events.
ITEM_FIRST - Static variable in class java.awt.event.ItemEvent
The first number in the range of ids used for item events.
ITEM_LAST - Static variable in class java.awt.event.ItemEvent
The last number in the range of ids used for item events.
ITEM_STATE_CHANGED - Static variable in class java.awt.event.ItemEvent
This event id indicates that an item's state changed.
ItemEvent - Class in java.awt.event
A semantic event which indicates that an item was selected or deselected.
ItemEvent(ItemSelectable, int, Object, int) - Constructor for class java.awt.event.ItemEvent
Constructs an ItemEvent object.
ItemHandler() - Constructor for class javax.swing.plaf.basic.BasicComboBoxUI.ItemHandler
ItemHandler() - Constructor for class javax.swing.plaf.basic.BasicComboPopup.ItemHandler
ItemListener - Interface in java.awt.event
The listener interface for receiving item events.
itemListener - Variable in class javax.swing.AbstractButton
The button model's ItemListener.
itemListener - Variable in class javax.swing.plaf.basic.BasicComboBoxUI
This protected field is implementation specific.
itemListener - Variable in class javax.swing.plaf.basic.BasicComboPopup
This protected field is implementation specific.
ItemSelectable - Interface in java.awt
The interface for objects which contain a set of items for which zero or more can be selected.
itemStateChanged(ItemEvent) - Method in class java.awt.AWTEventMulticaster
Handles the itemStateChanged event by invoking the itemStateChanged methods on listener-a and listener-b.
itemStateChanged(ItemEvent) - Method in class java.awt.Checkbox.AccessibleAWTCheckbox
Fire accessible property change events when the state of the toggle button changes.
itemStateChanged(ItemEvent) - Method in interface java.awt.event.ItemListener
Invoked when an item has been selected or deselected by the user.
itemStateChanged(ItemEvent) - Method in class java.awt.List.AccessibleAWTList
itemStateChanged(ItemEvent) - Method in class javax.swing.DefaultCellEditor.EditorDelegate
When an item's state changes, editing is ended.
itemStateChanged(ItemEvent) - Method in class javax.swing.JToggleButton.AccessibleJToggleButton
Fire accessible property change events when the state of the toggle button changes.
itemStateChanged(ItemEvent) - Method in class javax.swing.plaf.basic.BasicComboBoxUI.ItemHandler
itemStateChanged(ItemEvent) - Method in class javax.swing.plaf.basic.BasicComboPopup.ItemHandler
Iterable<T> - Interface in java.lang
Implementing this interface allows an object to be the target of the "for-each loop" statement.
iterate(double, DoubleUnaryOperator) - Static method in interface java.util.stream.DoubleStream
Returns an infinite sequential ordered DoubleStream produced by iterative application of a function f to an initial element seed, producing a Stream consisting of seed, f(seed), f(f(seed)), etc.
iterate(int, IntUnaryOperator) - Static method in interface java.util.stream.IntStream
Returns an infinite sequential ordered IntStream produced by iterative application of a function f to an initial element seed, producing a Stream consisting of seed, f(seed), f(f(seed)), etc.
iterate(long, LongUnaryOperator) - Static method in interface java.util.stream.LongStream
Returns an infinite sequential ordered LongStream produced by iterative application of a function f to an initial element seed, producing a Stream consisting of seed, f(seed), f(f(seed)), etc.
iterate(T, UnaryOperator<T>) - Static method in interface java.util.stream.Stream
Returns an infinite sequential ordered Stream produced by iterative application of a function f to an initial element seed, producing a Stream consisting of seed, f(seed), f(f(seed)), etc.
iterator() - Method in class java.awt.dnd.DragGestureEvent
Returns an Iterator for the events comprising the gesture.
iterator() - Method in class java.beans.beancontext.BeanContextMembershipEvent
Gets the array of children affected by this event.
iterator() - Method in class java.beans.beancontext.BeanContextSupport
Gets all JavaBean or BeanContext instances currently nested in this BeanContext.
iterator() - Method in interface java.lang.Iterable
Returns an iterator over elements of type T.
iterator() - Method in interface java.nio.file.DirectoryStream
Returns the iterator associated with this DirectoryStream.
iterator() - Method in interface java.nio.file.Path
Returns an iterator over the name elements of this path.
iterator() - Method in exception java.sql.SQLException
Returns an iterator over the chained SQLExceptions.
iterator() - Method in class java.util.AbstractCollection
Returns an iterator over the elements contained in this collection.
iterator() - Method in class java.util.AbstractList
Returns an iterator over the elements in this list in proper sequence.
iterator() - Method in class java.util.AbstractSequentialList
Returns an iterator over the elements in this list (in proper sequence).
iterator() - Method in class java.util.ArrayDeque
Returns an iterator over the elements in this deque.
iterator() - Method in class java.util.ArrayList
Returns an iterator over the elements in this list in proper sequence.
iterator() - Method in interface java.util.Collection
Returns an iterator over the elements in this collection.
iterator() - Method in class java.util.concurrent.ArrayBlockingQueue
Returns an iterator over the elements in this queue in proper sequence.
iterator() - Method in interface java.util.concurrent.BlockingDeque
Returns an iterator over the elements in this deque in proper sequence.
iterator() - Method in class java.util.concurrent.ConcurrentHashMap.KeySetView
iterator() - Method in class java.util.concurrent.ConcurrentLinkedDeque
Returns an iterator over the elements in this deque in proper sequence.
iterator() - Method in class java.util.concurrent.ConcurrentLinkedQueue
Returns an iterator over the elements in this queue in proper sequence.
iterator() - Method in class java.util.concurrent.ConcurrentSkipListSet
Returns an iterator over the elements in this set in ascending order.
iterator() - Method in class java.util.concurrent.CopyOnWriteArrayList
Returns an iterator over the elements in this list in proper sequence.
iterator() - Method in class java.util.concurrent.CopyOnWriteArraySet
Returns an iterator over the elements contained in this set in the order in which these elements were added.
iterator() - Method in class java.util.concurrent.DelayQueue
Returns an iterator over all the elements (both expired and unexpired) in this queue.
iterator() - Method in class java.util.concurrent.LinkedBlockingDeque
Returns an iterator over the elements in this deque in proper sequence.
iterator() - Method in class java.util.concurrent.LinkedBlockingQueue
Returns an iterator over the elements in this queue in proper sequence.
iterator() - Method in class java.util.concurrent.LinkedTransferQueue
Returns an iterator over the elements in this queue in proper sequence.
iterator() - Method in class java.util.concurrent.PriorityBlockingQueue
Returns an iterator over the elements in this queue.
iterator() - Method in class java.util.concurrent.SynchronousQueue
Returns an empty iterator in which hasNext always returns false.
iterator() - Method in interface java.util.Deque
Returns an iterator over the elements in this deque in proper sequence.
iterator() - Method in class java.util.HashSet
Returns an iterator over the elements in this set.
Iterator<E> - Interface in java.util
An iterator over a collection.
iterator() - Method in interface java.util.List
Returns an iterator over the elements in this list in proper sequence.
iterator() - Method in interface java.util.NavigableSet
Returns an iterator over the elements in this set, in ascending order.
iterator() - Method in class java.util.PriorityQueue
Returns an iterator over the elements in this queue.
iterator() - Method in class java.util.ServiceLoader
Lazily loads the available providers of this loader's service.
iterator() - Method in interface java.util.Set
Returns an iterator over the elements in this set.
iterator(Spliterator<? extends T>) - Static method in class java.util.Spliterators
Creates an Iterator from a Spliterator.
iterator(Spliterator.OfInt) - Static method in class java.util.Spliterators
Creates an PrimitiveIterator.OfInt from a Spliterator.OfInt.
iterator(Spliterator.OfLong) - Static method in class java.util.Spliterators
Creates an PrimitiveIterator.OfLong from a Spliterator.OfLong.
iterator(Spliterator.OfDouble) - Static method in class java.util.Spliterators
Creates an PrimitiveIterator.OfDouble from a Spliterator.OfDouble.
iterator() - Method in interface java.util.stream.BaseStream
Returns an iterator for the elements of this stream.
iterator() - Method in interface java.util.stream.DoubleStream
iterator() - Method in interface java.util.stream.IntStream
iterator() - Method in interface java.util.stream.LongStream
iterator() - Method in class java.util.TreeSet
Returns an iterator over the elements in this set in ascending order.
iterator() - Method in class java.util.Vector
Returns an iterator over the elements in this list in proper sequence.
Iterator() - Constructor for class javax.swing.text.html.HTMLDocument.Iterator
iterator() - Method in class javax.xml.crypto.dom.DOMCryptoContext
Returns a read-only iterator over the set of Id/Element mappings of this DOMCryptoContext.
iterator() - Method in interface javax.xml.crypto.NodeSetData
Returns a read-only iterator over the nodes contained in this NodeSetData in document order.
IvParameterSpec - Class in javax.crypto.spec
This class specifies an initialization vector (IV).
IvParameterSpec(byte[]) - Constructor for class javax.crypto.spec.IvParameterSpec
Creates an IvParameterSpec object using the bytes in iv as the IV.
IvParameterSpec(byte[], int, int) - Constructor for class javax.crypto.spec.IvParameterSpec
Creates an IvParameterSpec object using the first len bytes in iv, beginning at offset inclusive, as the IV.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames


J-Index (Java Platform SE 8 )

Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames
  • All Classes
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

J

JANUARY - Static variable in class java.util.Calendar
Value of the Calendar.MONTH field indicating the first month of the year in the Gregorian and Julian calendars.
JANUARY - Static variable in class javax.xml.datatype.DatatypeConstants
Value for first month of year.
JAPAN - Static variable in class java.util.Locale
Useful constant for country.
JAPANESE - Static variable in class java.util.Locale
Useful constant for language.
JAPANESE_DOUBLE_POSTCARD - Static variable in class javax.print.attribute.standard.MediaSize.Other
Specifies the Japanese Double postcard size, 148 mm by 200 mm.
JAPANESE_DOUBLE_POSTCARD - Static variable in class javax.print.attribute.standard.MediaSizeName
Japanese Double Postcard size.
JAPANESE_POSTCARD - Static variable in class javax.print.attribute.standard.MediaSize.Other
Specifies the Japanese postcard size, 100 mm by 148 mm.
JAPANESE_POSTCARD - Static variable in class javax.print.attribute.standard.MediaSizeName
Japanese Postcard size.
JapaneseChronology - Class in java.time.chrono
The Japanese Imperial calendar system.
JapaneseDate - Class in java.time.chrono
A date in the Japanese Imperial calendar system.
JapaneseEra - Class in java.time.chrono
An era in the Japanese Imperial calendar system.
JApplet - Class in javax.swing
An extended version of java.applet.Applet that adds support for the JFC/Swing component architecture.
JApplet() - Constructor for class javax.swing.JApplet
Creates a swing applet instance.
JApplet.AccessibleJApplet - Class in javax.swing
This class implements accessibility support for the JApplet class.
JarEntry - Class in java.util.jar
This class is used to represent a JAR file entry.
JarEntry(String) - Constructor for class java.util.jar.JarEntry
Creates a new JarEntry for the specified JAR file entry name.
JarEntry(ZipEntry) - Constructor for class java.util.jar.JarEntry
Creates a new JarEntry with fields taken from the specified ZipEntry object.
JarEntry(JarEntry) - Constructor for class java.util.jar.JarEntry
Creates a new JarEntry with fields taken from the specified JarEntry object.
JarException - Exception in java.util.jar
Signals that an error of some sort has occurred while reading from or writing to a JAR file.
JarException() - Constructor for exception java.util.jar.JarException
Constructs a JarException with no detail message.
JarException(String) - Constructor for exception java.util.jar.JarException
Constructs a JarException with the specified detail message.
JarFile - Class in java.util.jar
The JarFile class is used to read the contents of a jar file from any file that can be opened with java.io.RandomAccessFile.
JarFile(String) - Constructor for class java.util.jar.JarFile
Creates a new JarFile to read from the specified file name.
JarFile(String, boolean) - Constructor for class java.util.jar.JarFile
Creates a new JarFile to read from the specified file name.
JarFile(File) - Constructor for class java.util.jar.JarFile
Creates a new JarFile to read from the specified File object.
JarFile(File, boolean) - Constructor for class java.util.jar.JarFile
Creates a new JarFile to read from the specified File object.
JarFile(File, boolean, int) - Constructor for class java.util.jar.JarFile
Creates a new JarFile to read from the specified File object in the specified mode.
jarFileURLConnection - Variable in class java.net.JarURLConnection
The connection to the JAR file URL, if the connection has been initiated.
JarInputStream - Class in java.util.jar
The JarInputStream class is used to read the contents of a JAR file from any input stream.
JarInputStream(InputStream) - Constructor for class java.util.jar.JarInputStream
Creates a new JarInputStream and reads the optional manifest.
JarInputStream(InputStream, boolean) - Constructor for class java.util.jar.JarInputStream
Creates a new JarInputStream and reads the optional manifest.
JarOutputStream - Class in java.util.jar
The JarOutputStream class is used to write the contents of a JAR file to any output stream.
JarOutputStream(OutputStream, Manifest) - Constructor for class java.util.jar.JarOutputStream
Creates a new JarOutputStream with the specified Manifest.
JarOutputStream(OutputStream) - Constructor for class java.util.jar.JarOutputStream
Creates a new JarOutputStream with no manifest.
JarURLConnection - Class in java.net
A URL Connection to a Java ARchive (JAR) file or an entry in a JAR file.
JarURLConnection(URL) - Constructor for class java.net.JarURLConnection
Creates the new JarURLConnection to the specified URL.
java.applet - package java.applet
Provides the classes necessary to create an applet and the classes an applet uses to communicate with its applet context.
java.awt - package java.awt
Contains all of the classes for creating user interfaces and for painting graphics and images.
java.awt.color - package java.awt.color
Provides classes for color spaces.
java.awt.datatransfer - package java.awt.datatransfer
Provides interfaces and classes for transferring data between and within applications.
java.awt.dnd - package java.awt.dnd
Drag and Drop is a direct manipulation gesture found in many Graphical User Interface systems that provides a mechanism to transfer information between two entities logically associated with presentation elements in the GUI.
java.awt.event - package java.awt.event
Provides interfaces and classes for dealing with different types of events fired by AWT components.
java.awt.font - package java.awt.font
Provides classes and interface relating to fonts.
java.awt.geom - package java.awt.geom
Provides the Java 2D classes for defining and performing operations on objects related to two-dimensional geometry.
java.awt.im - package java.awt.im
Provides classes and interfaces for the input method framework.
java.awt.im.spi - package java.awt.im.spi
Provides interfaces that enable the development of input methods that can be used with any Java runtime environment.
java.awt.image - package java.awt.image
Provides classes for creating and modifying images.
java.awt.image.renderable - package java.awt.image.renderable
Provides classes and interfaces for producing rendering-independent images.
java.awt.print - package java.awt.print
Provides classes and interfaces for a general printing API.
java.beans - package java.beans
Contains classes related to developing beans -- components based on the JavaBeans™ architecture.
java.beans.beancontext - package java.beans.beancontext
Provides classes and interfaces relating to bean context.
java.io - package java.io
Provides for system input and output through data streams, serialization and the file system.
java.lang - package java.lang
Provides classes that are fundamental to the design of the Java programming language.
java.lang.annotation - package java.lang.annotation
Provides library support for the Java programming language annotation facility.
java.lang.instrument - package java.lang.instrument
Provides services that allow Java programming language agents to instrument programs running on the JVM.
java.lang.invoke - package java.lang.invoke
The java.lang.invoke package contains dynamic language support provided directly by the Java core class libraries and virtual machine.
java.lang.management - package java.lang.management
Provides the management interfaces for monitoring and management of the Java virtual machine and other components in the Java runtime.
java.lang.ref - package java.lang.ref
Provides reference-object classes, which support a limited degree of interaction with the garbage collector.
java.lang.reflect - package java.lang.reflect
Provides classes and interfaces for obtaining reflective information about classes and objects.
java.math - package java.math
Provides classes for performing arbitrary-precision integer arithmetic (BigInteger) and arbitrary-precision decimal arithmetic (BigDecimal).
java.net - package java.net
Provides the classes for implementing networking applications.
java.nio - package java.nio
Defines buffers, which are containers for data, and provides an overview of the other NIO packages.
java.nio.channels - package java.nio.channels
Defines channels, which represent connections to entities that are capable of performing I/O operations, such as files and sockets; defines selectors, for multiplexed, non-blocking I/O operations.
java.nio.channels.spi - package java.nio.channels.spi
Service-provider classes for the java.nio.channels package.
java.nio.charset - package java.nio.charset
Defines charsets, decoders, and encoders, for translating between bytes and Unicode characters.
java.nio.charset.spi - package java.nio.charset.spi
Service-provider classes for the java.nio.charset package.
java.nio.file - package java.nio.file
Defines interfaces and classes for the Java virtual machine to access files, file attributes, and file systems.
java.nio.file.attribute - package java.nio.file.attribute
Interfaces and classes providing access to file and file system attributes.
java.nio.file.spi - package java.nio.file.spi
Service-provider classes for the java.nio.file package.
java.rmi - package java.rmi
Provides the RMI package.
java.rmi.activation - package java.rmi.activation
Provides support for RMI Object Activation.
java.rmi.dgc - package java.rmi.dgc
Provides classes and interface for RMI distributed garbage-collection (DGC).
java.rmi.registry - package java.rmi.registry
Provides a class and two interfaces for the RMI registry.
java.rmi.server - package java.rmi.server
Provides classes and interfaces for supporting the server side of RMI.
java.security - package java.security
Provides the classes and interfaces for the security framework.
java.security.acl - package java.security.acl
The classes and interfaces in this package have been superseded by classes in the java.security package.
java.security.cert - package java.security.cert
Provides classes and interfaces for parsing and managing certificates, certificate revocation lists (CRLs), and certification paths.
java.security.interfaces - package java.security.interfaces
Provides interfaces for generating RSA (Rivest, Shamir and Adleman AsymmetricCipher algorithm) keys as defined in the RSA Laboratory Technical Note PKCS#1, and DSA (Digital Signature Algorithm) keys as defined in NIST's FIPS-186.
java.security.spec - package java.security.spec
Provides classes and interfaces for key specifications and algorithm parameter specifications.
java.sql - package java.sql
Provides the API for accessing and processing data stored in a data source (usually a relational database) using the JavaTM programming language.
java.text - package java.text
Provides classes and interfaces for handling text, dates, numbers, and messages in a manner independent of natural languages.
java.text.spi - package java.text.spi
Service provider classes for the classes in the java.text package.
java.time - package java.time
The main API for dates, times, instants, and durations.
java.time.chrono - package java.time.chrono
Generic API for calendar systems other than the default ISO.
java.time.format - package java.time.format
Provides classes to print and parse dates and times.
java.time.temporal - package java.time.temporal
Access to date and time using fields and units, and date time adjusters.
java.time.zone - package java.time.zone
Support for time-zones and their rules.
java.util - package java.util
Contains the collections framework, legacy collection classes, event model, date and time facilities, internationalization, and miscellaneous utility classes (a string tokenizer, a random-number generator, and a bit array).
java.util.concurrent - package java.util.concurrent
Utility classes commonly useful in concurrent programming.
java.util.concurrent.atomic - package java.util.concurrent.atomic
A small toolkit of classes that support lock-free thread-safe programming on single variables.
java.util.concurrent.locks - package java.util.concurrent.locks
Interfaces and classes providing a framework for locking and waiting for conditions that is distinct from built-in synchronization and monitors.
java.util.function - package java.util.function
Functional interfaces provide target types for lambda expressions and method references.
java.util.jar - package java.util.jar
Provides classes for reading and writing the JAR (Java ARchive) file format, which is based on the standard ZIP file format with an optional manifest file.
java.util.logging - package java.util.logging
Provides the classes and interfaces of the JavaTM 2 platform's core logging facilities.
java.util.prefs - package java.util.prefs
This package allows applications to store and retrieve user and system preference and configuration data.
java.util.regex - package java.util.regex
Classes for matching character sequences against patterns specified by regular expressions.
java.util.spi - package java.util.spi
Service provider classes for the classes in the java.util package.
java.util.stream - package java.util.stream
Classes to support functional-style operations on streams of elements, such as map-reduce transformations on collections.
java.util.zip - package java.util.zip
Provides classes for reading and writing the standard ZIP and GZIP file formats.
JAVA_OBJECT - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type JAVA_OBJECT.
JavaCompiler - Interface in javax.tools
Interface to invoke Java™ programming language compilers from programs.
JavaCompiler.CompilationTask - Interface in javax.tools
Interface representing a future for a compilation task.
javaFileListFlavor - Static variable in class java.awt.datatransfer.DataFlavor
To transfer a list of files to/from Java (and the underlying platform) a DataFlavor of this type/subtype and representation class of java.util.List is used.
JavaFileManager - Interface in javax.tools
File manager for tools operating on Java™ programming language source and class files.
JavaFileManager.Location - Interface in javax.tools
Interface for locations of file objects.
JavaFileObject - Interface in javax.tools
File abstraction for tools operating on Java™ programming language source and class files.
JavaFileObject.Kind - Enum in javax.tools
Kinds of JavaFileObjects.
javaJVMLocalObjectMimeType - Static variable in class java.awt.datatransfer.DataFlavor
To transfer a reference to an arbitrary Java object reference that has no associated MIME Content-type, across a Transferable interface WITHIN THE SAME JVM, a DataFlavor with this type/subtype is used, with a representationClass equal to the type of the class/interface being passed across the Transferable.
JAVANESE - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Javanese" Unicode character block.
javaRemoteObjectMimeType - Static variable in class java.awt.datatransfer.DataFlavor
In order to pass a live link to a Remote object via a Drag and Drop ACTION_LINK operation a Mime Content Type of application/x-java-remote-object should be used, where the representation class of the DataFlavor represents the type of the Remote interface to be transferred.
javaSerializedObjectMimeType - Static variable in class java.awt.datatransfer.DataFlavor
A MIME Content-Type of application/x-java-serialized-object represents a graph of Java object(s) that have been made persistent.
javax.accessibility - package javax.accessibility
Defines a contract between user-interface components and an assistive technology that provides access to those components.
javax.activation - package javax.activation
javax.activity - package javax.activity
Contains Activity service related exceptions thrown by the ORB machinery during unmarshalling.
javax.annotation - package javax.annotation
javax.annotation.processing - package javax.annotation.processing
Facilities for declaring annotation processors and for allowing annotation processors to communicate with an annotation processing tool environment.
javax.crypto - package javax.crypto
Provides the classes and interfaces for cryptographic operations.
javax.crypto.interfaces - package javax.crypto.interfaces
Provides interfaces for Diffie-Hellman keys as defined in RSA Laboratories' PKCS #3.
javax.crypto.spec - package javax.crypto.spec
Provides classes and interfaces for key specifications and algorithm parameter specifications.
javax.imageio - package javax.imageio
The main package of the Java Image I/O API.
javax.imageio.event - package javax.imageio.event
A package of the Java Image I/O API dealing with synchronous notification of events during the reading and writing of images.
javax.imageio.metadata - package javax.imageio.metadata
A package of the Java Image I/O API dealing with reading and writing metadata.
javax.imageio.plugins.bmp - package javax.imageio.plugins.bmp
Package containing the public classes used by the built-in BMP plug-in.
javax.imageio.plugins.jpeg - package javax.imageio.plugins.jpeg
Classes supporting the built-in JPEG plug-in.
javax.imageio.spi - package javax.imageio.spi
A package of the Java Image I/O API containing the plug-in interfaces for readers, writers, transcoders, and streams, and a runtime registry.
javax.imageio.stream - package javax.imageio.stream
A package of the Java Image I/O API dealing with low-level I/O from files and streams.
javax.jws - package javax.jws
javax.jws.soap - package javax.jws.soap
javax.lang.model - package javax.lang.model
Classes and hierarchies of packages used to model the Java programming language.
javax.lang.model.element - package javax.lang.model.element
Interfaces used to model elements of the Java programming language.
javax.lang.model.type - package javax.lang.model.type
Interfaces used to model Java programming language types.
javax.lang.model.util - package javax.lang.model.util
Utilities to assist in the processing of program elements and types.
javax.management - package javax.management
Provides the core classes for the Java Management Extensions.
javax.management.loading - package javax.management.loading
Provides the classes which implement advanced dynamic loading.
javax.management.modelmbean - package javax.management.modelmbean
Provides the definition of the ModelMBean classes.
javax.management.monitor - package javax.management.monitor
Provides the definition of the monitor classes.
javax.management.openmbean - package javax.management.openmbean
Provides the open data types and Open MBean descriptor classes.
javax.management.relation - package javax.management.relation
Provides the definition of the Relation Service.
javax.management.remote - package javax.management.remote
Interfaces for remote access to JMX MBean servers.
javax.management.remote.rmi - package javax.management.remote.rmi
The RMI connector is a connector for the JMX Remote API that uses RMI to transmit client requests to a remote MBean server.
javax.management.timer - package javax.management.timer
Provides the definition of the Timer MBean.
javax.naming - package javax.naming
Provides the classes and interfaces for accessing naming services.
javax.naming.directory - package javax.naming.directory
Extends the javax.naming package to provide functionality for accessing directory services.
javax.naming.event - package javax.naming.event
Provides support for event notification when accessing naming and directory services.
javax.naming.ldap - package javax.naming.ldap
Provides support for LDAPv3 extended operations and controls.
javax.naming.spi - package javax.naming.spi
javax.net - package javax.net
Provides classes for networking applications.
javax.net.ssl - package javax.net.ssl
Provides classes for the secure socket package.
javax.print - package javax.print
Provides the principal classes and interfaces for the JavaTM Print Service API.
javax.print.attribute - package javax.print.attribute
Provides classes and interfaces that describe the types of JavaTM Print Service attributes and how they can be collected into attribute sets.
javax.print.attribute.standard - package javax.print.attribute.standard
Package javax.print.attribute.standard contains classes for specific printing attributes.
javax.print.event - package javax.print.event
Package javax.print.event contains event classes and listener interfaces.
javax.rmi - package javax.rmi
Contains user APIs for RMI-IIOP.
javax.rmi.CORBA - package javax.rmi.CORBA
Contains portability APIs for RMI-IIOP.
javax.rmi.ssl - package javax.rmi.ssl
Provides implementations of RMIClientSocketFactory and RMIServerSocketFactory over the Secure Sockets Layer (SSL) or Transport Layer Security (TLS) protocols.
javax.script - package javax.script
The scripting API consists of interfaces and classes that define Java TM Scripting Engines and provides a framework for their use in Java applications.
javax.security.auth - package javax.security.auth
This package provides a framework for authentication and authorization.
javax.security.auth.callback - package javax.security.auth.callback
This package provides the classes necessary for services to interact with applications in order to retrieve information (authentication data including usernames or passwords, for example) or to display information (error and warning messages, for example).
javax.security.auth.kerberos - package javax.security.auth.kerberos
This package contains utility classes related to the Kerberos network authentication protocol.
javax.security.auth.login - package javax.security.auth.login
This package provides a pluggable authentication framework.
javax.security.auth.spi - package javax.security.auth.spi
This package provides the interface to be used for implementing pluggable authentication modules.
javax.security.auth.x500 - package javax.security.auth.x500
This package contains the classes that should be used to store X500 Principal and X500 Private Credentials in a Subject.
javax.security.cert - package javax.security.cert
Provides classes for public key certificates.
javax.security.sasl - package javax.security.sasl
Contains class and interfaces for supporting SASL.
javax.sound.midi - package javax.sound.midi
Provides interfaces and classes for I/O, sequencing, and synthesis of MIDI (Musical Instrument Digital Interface) data.
javax.sound.midi.spi - package javax.sound.midi.spi
Supplies interfaces for service providers to implement when offering new MIDI devices, MIDI file readers and writers, or sound bank readers.
javax.sound.sampled - package javax.sound.sampled
Provides interfaces and classes for capture, processing, and playback of sampled audio data.
javax.sound.sampled.spi - package javax.sound.sampled.spi
Supplies abstract classes for service providers to subclass when offering new audio devices, sound file readers and writers, or audio format converters.
javax.sql - package javax.sql
Provides the API for server side data source access and processing from the JavaTM programming language.
javax.sql.rowset - package javax.sql.rowset
Standard interfaces and base classes for JDBC RowSet implementations.
javax.sql.rowset.serial - package javax.sql.rowset.serial
Provides utility classes to allow serializable mappings between SQL types and data types in the Java programming language.
javax.sql.rowset.spi - package javax.sql.rowset.spi
The standard classes and interfaces that a third party vendor has to use in its implementation of a synchronization provider.
javax.swing - package javax.swing
Provides a set of "lightweight" (all-Java language) components that, to the maximum degree possible, work the same on all platforms.
javax.swing.border - package javax.swing.border
Provides classes and interface for drawing specialized borders around a Swing component.
javax.swing.colorchooser - package javax.swing.colorchooser
Contains classes and interfaces used by the JColorChooser component.
javax.swing.event - package javax.swing.event
Provides for events fired by Swing components.
javax.swing.filechooser - package javax.swing.filechooser
Contains classes and interfaces used by the JFileChooser component.
javax.swing.plaf - package javax.swing.plaf
Provides one interface and many abstract classes that Swing uses to provide its pluggable look-and-feel capabilities.
javax.swing.plaf.basic - package javax.swing.plaf.basic
Provides user interface objects built according to the Basic look and feel.
javax.swing.plaf.metal - package javax.swing.plaf.metal
Provides user interface objects built according to the Java look and feel (once codenamed Metal), which is the default look and feel.
javax.swing.plaf.multi - package javax.swing.plaf.multi
Provides user interface objects that combine two or more look and feels.
javax.swing.plaf.nimbus - package javax.swing.plaf.nimbus
Provides user interface objects built according to the cross-platform Nimbus look and feel.
javax.swing.plaf.synth - package javax.swing.plaf.synth
Synth is a skinnable look and feel in which all painting is delegated.
javax.swing.table - package javax.swing.table
Provides classes and interfaces for dealing with javax.swing.JTable.
javax.swing.text - package javax.swing.text
Provides classes and interfaces that deal with editable and noneditable text components.
javax.swing.text.html - package javax.swing.text.html
Provides the class HTMLEditorKit and supporting classes for creating HTML text editors.
javax.swing.text.html.parser - package javax.swing.text.html.parser
Provides the default HTML parser, along with support classes.
javax.swing.text.rtf - package javax.swing.text.rtf
Provides a class (RTFEditorKit) for creating Rich-Text-Format text editors.
javax.swing.tree - package javax.swing.tree
Provides classes and interfaces for dealing with javax.swing.JTree.
javax.swing.undo - package javax.swing.undo
Allows developers to provide support for undo/redo in applications such as text editors.
javax.tools - package javax.tools
Provides interfaces for tools which can be invoked from a program, for example, compilers.
javax.transaction - package javax.transaction
Contains three exceptions thrown by the ORB machinery during unmarshalling.
javax.transaction.xa - package javax.transaction.xa
Provides the API that defines the contract between the transaction manager and the resource manager, which allows the transaction manager to enlist and delist resource objects (supplied by the resource manager driver) in JTA transactions.
javax.xml - package javax.xml
javax.xml.bind - package javax.xml.bind
Provides a runtime binding framework for client applications including unmarshalling, marshalling, and validation capabilities.
javax.xml.bind.annotation - package javax.xml.bind.annotation
Defines annotations for customizing Java program elements to XML Schema mapping.
javax.xml.bind.annotation.adapters - package javax.xml.bind.annotation.adapters
XmlAdapter and its spec-defined sub-classes to allow arbitrary Java classes to be used with JAXB.
javax.xml.bind.attachment - package javax.xml.bind.attachment
This package is implemented by a MIME-based package processor that enables the interpretation and creation of optimized binary data within an MIME-based package format.
javax.xml.bind.helpers - package javax.xml.bind.helpers
JAXB Provider Use Only: Provides partial default implementations for some of the javax.xml.bind interfaces.
javax.xml.bind.util - package javax.xml.bind.util
Useful client utility classes.
javax.xml.crypto - package javax.xml.crypto
Common classes for XML cryptography.
javax.xml.crypto.dom - package javax.xml.crypto.dom
DOM-specific classes for the javax.xml.crypto package.
javax.xml.crypto.dsig - package javax.xml.crypto.dsig
Classes for generating and validating XML digital signatures.
javax.xml.crypto.dsig.dom - package javax.xml.crypto.dsig.dom
DOM-specific classes for the javax.xml.crypto.dsig package.
javax.xml.crypto.dsig.keyinfo - package javax.xml.crypto.dsig.keyinfo
Classes for parsing and processing KeyInfo elements and structures.
javax.xml.crypto.dsig.spec - package javax.xml.crypto.dsig.spec
Parameter classes for XML digital signatures.
javax.xml.datatype - package javax.xml.datatype
XML/Java Type Mappings.
javax.xml.namespace - package javax.xml.namespace
XML Namespace processing.
javax.xml.parsers - package javax.xml.parsers
Provides classes allowing the processing of XML documents.
javax.xml.soap - package javax.xml.soap
Provides the API for creating and building SOAP messages.
javax.xml.stream - package javax.xml.stream
javax.xml.stream.events - package javax.xml.stream.events
javax.xml.stream.util - package javax.xml.stream.util
javax.xml.transform - package javax.xml.transform
This package defines the generic APIs for processing transformation instructions, and performing a transformation from source to result.
javax.xml.transform.dom - package javax.xml.transform.dom
This package implements DOM-specific transformation APIs.
javax.xml.transform.sax - package javax.xml.transform.sax
This package implements SAX2-specific transformation APIs.
javax.xml.transform.stax - package javax.xml.transform.stax
Provides for StAX-specific transformation APIs.
javax.xml.transform.stream - package javax.xml.transform.stream
This package implements stream- and URI- specific transformation APIs.
javax.xml.validation - package javax.xml.validation
This package provides an API for validation of XML documents.
javax.xml.ws - package javax.xml.ws
This package contains the core JAX-WS APIs.
javax.xml.ws.handler - package javax.xml.ws.handler
This package defines APIs for message handlers.
javax.xml.ws.handler.soap - package javax.xml.ws.handler.soap
This package defines APIs for SOAP message handlers.
javax.xml.ws.http - package javax.xml.ws.http
This package defines APIs specific to the HTTP binding.
javax.xml.ws.soap - package javax.xml.ws.soap
This package defines APIs specific to the SOAP binding.
javax.xml.ws.spi - package javax.xml.ws.spi
This package defines SPIs for JAX-WS.
javax.xml.ws.spi.http - package javax.xml.ws.spi.http
Provides HTTP SPI that is used for portable deployment of JAX-WS web services in containers(for e.g.
javax.xml.ws.wsaddressing - package javax.xml.ws.wsaddressing
This package defines APIs related to WS-Addressing.
javax.xml.xpath - package javax.xml.xpath
This package provides an object-model neutral API for the evaluation of XPath expressions and access to the evaluation environment.
JAXB - Class in javax.xml.bind
Class that defines convenience methods for common, simple use of JAXB.
JAXB_CONTEXT_FACTORY - Static variable in class javax.xml.bind.JAXBContext
The name of the property that contains the name of the class capable of creating new JAXBContext objects.
JAXB_ENCODING - Static variable in interface javax.xml.bind.Marshaller
The name of the property used to specify the output encoding in the marshalled XML data.
JAXB_FORMATTED_OUTPUT - Static variable in interface javax.xml.bind.Marshaller
The name of the property used to specify whether or not the marshalled XML data is formatted with linefeeds and indentation.
JAXB_FRAGMENT - Static variable in interface javax.xml.bind.Marshaller
The name of the property used to specify whether or not the marshaller will generate document level events (ie calling startDocument or endDocument).
JAXB_NO_NAMESPACE_SCHEMA_LOCATION - Static variable in interface javax.xml.bind.Marshaller
The name of the property used to specify the xsi:noNamespaceSchemaLocation attribute value to place in the marshalled XML output.
JAXB_SCHEMA_LOCATION - Static variable in interface javax.xml.bind.Marshaller
The name of the property used to specify the xsi:schemaLocation attribute value to place in the marshalled XML output.
JAXBContext - Class in javax.xml.bind
The JAXBContext class provides the client's entry point to the JAXB API.
JAXBContext() - Constructor for class javax.xml.bind.JAXBContext
JAXBElement<T> - Class in javax.xml.bind
JAXB representation of an Xml Element.
JAXBElement(QName, Class<T>, Class, T) - Constructor for class javax.xml.bind.JAXBElement
Construct an xml element instance.
JAXBElement(QName, Class<T>, T) - Constructor for class javax.xml.bind.JAXBElement
Construct an xml element instance.
JAXBElement.GlobalScope - Class in javax.xml.bind
Designates global scope for an xml element.
JAXBException - Exception in javax.xml.bind
This is the root exception class for all JAXB exceptions.
JAXBException(String) - Constructor for exception javax.xml.bind.JAXBException
Construct a JAXBException with the specified detail message.
JAXBException(String, String) - Constructor for exception javax.xml.bind.JAXBException
Construct a JAXBException with the specified detail message and vendor specific errorCode.
JAXBException(Throwable) - Constructor for exception javax.xml.bind.JAXBException
Construct a JAXBException with a linkedException.
JAXBException(String, Throwable) - Constructor for exception javax.xml.bind.JAXBException
Construct a JAXBException with the specified detail message and linkedException.
JAXBException(String, String, Throwable) - Constructor for exception javax.xml.bind.JAXBException
Construct a JAXBException with the specified detail message, vendor specific errorCode, and linkedException.
JAXBIntrospector - Class in javax.xml.bind
Provide access to JAXB xml binding data for a JAXB object.
JAXBIntrospector() - Constructor for class javax.xml.bind.JAXBIntrospector
JAXBPermission - Class in javax.xml.bind
This class is for JAXB permissions.
JAXBPermission(String) - Constructor for class javax.xml.bind.JAXBPermission
Creates a new JAXBPermission with the specified name.
JAXBResult - Class in javax.xml.bind.util
JAXP Result implementation that unmarshals a JAXB object.
JAXBResult(JAXBContext) - Constructor for class javax.xml.bind.util.JAXBResult
Creates a new instance that uses the specified JAXBContext to unmarshal.
JAXBResult(Unmarshaller) - Constructor for class javax.xml.bind.util.JAXBResult
Creates a new instance that uses the specified Unmarshaller to unmarshal an object.
JAXBSource - Class in javax.xml.bind.util
JAXP Source implementation that marshals a JAXB-generated object.
JAXBSource(JAXBContext, Object) - Constructor for class javax.xml.bind.util.JAXBSource
Creates a new Source for the given content object.
JAXBSource(Marshaller, Object) - Constructor for class javax.xml.bind.util.JAXBSource
Creates a new Source for the given content object.
JAXWSPROVIDER_PROPERTY - Static variable in class javax.xml.ws.spi.Provider
A constant representing the property used to lookup the name of a Provider implementation class.
JButton - Class in javax.swing
An implementation of a "push" button.
JButton() - Constructor for class javax.swing.JButton
Creates a button with no set text or icon.
JButton(Icon) - Constructor for class javax.swing.JButton
Creates a button with an icon.
JButton(String) - Constructor for class javax.swing.JButton
Creates a button with text.
JButton(Action) - Constructor for class javax.swing.JButton
Creates a button where properties are taken from the Action supplied.
JButton(String, Icon) - Constructor for class javax.swing.JButton
Creates a button with initial text and an icon.
JButton.AccessibleJButton - Class in javax.swing
This class implements accessibility support for the JButton class.
JCheckBox - Class in javax.swing
An implementation of a check box -- an item that can be selected or deselected, and which displays its state to the user.
JCheckBox() - Constructor for class javax.swing.JCheckBox
Creates an initially unselected check box button with no text, no icon.
JCheckBox(Icon) - Constructor for class javax.swing.JCheckBox
Creates an initially unselected check box with an icon.
JCheckBox(Icon, boolean) - Constructor for class javax.swing.JCheckBox
Creates a check box with an icon and specifies whether or not it is initially selected.
JCheckBox(String) - Constructor for class javax.swing.JCheckBox
Creates an initially unselected check box with text.
JCheckBox(Action) - Constructor for class javax.swing.JCheckBox
Creates a check box where properties are taken from the Action supplied.
JCheckBox(String, boolean) - Constructor for class javax.swing.JCheckBox
Creates a check box with text and specifies whether or not it is initially selected.
JCheckBox(String, Icon) - Constructor for class javax.swing.JCheckBox
Creates an initially unselected check box with the specified text and icon.
JCheckBox(String, Icon, boolean) - Constructor for class javax.swing.JCheckBox
Creates a check box with text and icon, and specifies whether or not it is initially selected.
JCheckBox.AccessibleJCheckBox - Class in javax.swing
This class implements accessibility support for the JCheckBox class.
JCheckBoxMenuItem - Class in javax.swing
A menu item that can be selected or deselected.
JCheckBoxMenuItem() - Constructor for class javax.swing.JCheckBoxMenuItem
Creates an initially unselected check box menu item with no set text or icon.
JCheckBoxMenuItem(Icon) - Constructor for class javax.swing.JCheckBoxMenuItem
Creates an initially unselected check box menu item with an icon.
JCheckBoxMenuItem(String) - Constructor for class javax.swing.JCheckBoxMenuItem
Creates an initially unselected check box menu item with text.
JCheckBoxMenuItem(Action) - Constructor for class javax.swing.JCheckBoxMenuItem
Creates a menu item whose properties are taken from the Action supplied.
JCheckBoxMenuItem(String, Icon) - Constructor for class javax.swing.JCheckBoxMenuItem
Creates an initially unselected check box menu item with the specified text and icon.
JCheckBoxMenuItem(String, boolean) - Constructor for class javax.swing.JCheckBoxMenuItem
Creates a check box menu item with the specified text and selection state.
JCheckBoxMenuItem(String, Icon, boolean) - Constructor for class javax.swing.JCheckBoxMenuItem
Creates a check box menu item with the specified text, icon, and selection state.
JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem - Class in javax.swing
This class implements accessibility support for the JCheckBoxMenuItem class.
JColorChooser - Class in javax.swing
JColorChooser provides a pane of controls designed to allow a user to manipulate and select a color.
JColorChooser() - Constructor for class javax.swing.JColorChooser
Creates a color chooser pane with an initial color of white.
JColorChooser(Color) - Constructor for class javax.swing.JColorChooser
Creates a color chooser pane with the specified initial color.
JColorChooser(ColorSelectionModel) - Constructor for class javax.swing.JColorChooser
Creates a color chooser pane with the specified ColorSelectionModel.
JColorChooser.AccessibleJColorChooser - Class in javax.swing
This class implements accessibility support for the JColorChooser class.
JComboBox<E> - Class in javax.swing
A component that combines a button or editable field and a drop-down list.
JComboBox(ComboBoxModel<E>) - Constructor for class javax.swing.JComboBox
Creates a JComboBox that takes its items from an existing ComboBoxModel.
JComboBox(E[]) - Constructor for class javax.swing.JComboBox
Creates a JComboBox that contains the elements in the specified array.
JComboBox(Vector<E>) - Constructor for class javax.swing.JComboBox
Creates a JComboBox that contains the elements in the specified Vector.
JComboBox() - Constructor for class javax.swing.JComboBox
Creates a JComboBox with a default data model.
JComboBox.AccessibleJComboBox - Class in javax.swing
This class implements accessibility support for the JComboBox class.
JComboBox.KeySelectionManager - Interface in javax.swing
The interface that defines a KeySelectionManager.
JComponent - Class in javax.swing
The base class for all Swing components except top-level containers.
JComponent() - Constructor for class javax.swing.JComponent
Default JComponent constructor.
JComponent.AccessibleJComponent - Class in javax.swing
Inner class of JComponent used to provide default support for accessibility.
JComponent.AccessibleJComponent.AccessibleContainerHandler - Class in javax.swing
Fire PropertyChange listener, if one is registered, when children added/removed.
JComponent.AccessibleJComponent.AccessibleFocusHandler - Class in javax.swing
Fire PropertyChange listener, if one is registered, when focus events happen
JCOMPONENT_UI - Static variable in class javax.print.ServiceUIFactory
Denotes a UI implemented as a Swing component.
jdbcCompliant() - Method in interface java.sql.Driver
Reports whether this driver is a genuine JDBC Compliant™ driver.
JdbcRowSet - Interface in javax.sql.rowset
The standard interface that all standard implementations of JdbcRowSet must implement.
JDBCType - Enum in java.sql
Defines the constants that are used to identify generic SQL types, called JDBC types.
JDesktopIcon(JInternalFrame) - Constructor for class javax.swing.JInternalFrame.JDesktopIcon
Creates an icon for an internal frame.
JDesktopPane - Class in javax.swing
A container used to create a multiple-document interface or a virtual desktop.
JDesktopPane() - Constructor for class javax.swing.JDesktopPane
Creates a new JDesktopPane.
JDesktopPane.AccessibleJDesktopPane - Class in javax.swing
This class implements accessibility support for the JDesktopPane class.
JDialog - Class in javax.swing
The main class for creating a dialog window.
JDialog() - Constructor for class javax.swing.JDialog
Creates a modeless dialog without a title and without a specified Frame owner.
JDialog(Frame) - Constructor for class javax.swing.JDialog
Creates a modeless dialog with the specified Frame as its owner and an empty title.
JDialog(Frame, boolean) - Constructor for class javax.swing.JDialog
Creates a dialog with an empty title and the specified modality and Frame as its owner.
JDialog(Frame, String) - Constructor for class javax.swing.JDialog
Creates a modeless dialog with the specified title and with the specified owner frame.
JDialog(Frame, String, boolean) - Constructor for class javax.swing.JDialog
Creates a dialog with the specified title, owner Frame and modality.
JDialog(Frame, String, boolean, GraphicsConfiguration) - Constructor for class javax.swing.JDialog
Creates a dialog with the specified title, owner Frame, modality and GraphicsConfiguration.
JDialog(Dialog) - Constructor for class javax.swing.JDialog
Creates a modeless dialog with the specified Dialog as its owner and an empty title.
JDialog(Dialog, boolean) - Constructor for class javax.swing.JDialog
Creates a dialog with an empty title and the specified modality and Dialog as its owner.
JDialog(Dialog, String) - Constructor for class javax.swing.JDialog
Creates a modeless dialog with the specified title and with the specified owner dialog.
JDialog(Dialog, String, boolean) - Constructor for class javax.swing.JDialog
Creates a dialog with the specified title, modality and the specified owner Dialog.
JDialog(Dialog, String, boolean, GraphicsConfiguration) - Constructor for class javax.swing.JDialog
Creates a dialog with the specified title, owner Dialog, modality and GraphicsConfiguration.
JDialog(Window) - Constructor for class javax.swing.JDialog
Creates a modeless dialog with the specified Window as its owner and an empty title.
JDialog(Window, Dialog.ModalityType) - Constructor for class javax.swing.JDialog
Creates a dialog with an empty title and the specified modality and Window as its owner.
JDialog(Window, String) - Constructor for class javax.swing.JDialog
Creates a modeless dialog with the specified title and owner Window.
JDialog(Window, String, Dialog.ModalityType) - Constructor for class javax.swing.JDialog
Creates a dialog with the specified title, owner Window and modality.
JDialog(Window, String, Dialog.ModalityType, GraphicsConfiguration) - Constructor for class javax.swing.JDialog
Creates a dialog with the specified title, owner Window, modality and GraphicsConfiguration.
JDialog.AccessibleJDialog - Class in javax.swing
This class implements accessibility support for the JDialog class.
JDIALOG_UI - Static variable in class javax.print.ServiceUIFactory
Denotes a UI implemented as a Swing dialog.
JEditorPane - Class in javax.swing
A text component to edit various kinds of content.
JEditorPane() - Constructor for class javax.swing.JEditorPane
Creates a new JEditorPane.
JEditorPane(URL) - Constructor for class javax.swing.JEditorPane
Creates a JEditorPane based on a specified URL for input.
JEditorPane(String) - Constructor for class javax.swing.JEditorPane
Creates a JEditorPane based on a string containing a URL specification.
JEditorPane(String, String) - Constructor for class javax.swing.JEditorPane
Creates a JEditorPane that has been initialized to the given text.
JEditorPane.AccessibleJEditorPane - Class in javax.swing
This class implements accessibility support for the JEditorPane class.
JEditorPane.AccessibleJEditorPaneHTML - Class in javax.swing
This class provides support for AccessibleHypertext, and is used in instances where the EditorKit installed in this JEditorPane is an instance of HTMLEditorKit.
JEditorPane.JEditorPaneAccessibleHypertextSupport - Class in javax.swing
What's returned by AccessibleJEditorPaneHTML.getAccessibleText.
JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink - Class in javax.swing
JEditorPaneAccessibleHypertextSupport() - Constructor for class javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport
Make one of these puppies
JFileChooser - Class in javax.swing
JFileChooser provides a simple mechanism for the user to choose a file.
JFileChooser() - Constructor for class javax.swing.JFileChooser
Constructs a JFileChooser pointing to the user's default directory.
JFileChooser(String) - Constructor for class javax.swing.JFileChooser
Constructs a JFileChooser using the given path.
JFileChooser(File) - Constructor for class javax.swing.JFileChooser
Constructs a JFileChooser using the given File as the path.
JFileChooser(FileSystemView) - Constructor for class javax.swing.JFileChooser
Constructs a JFileChooser using the given FileSystemView.
JFileChooser(File, FileSystemView) - Constructor for class javax.swing.JFileChooser
Constructs a JFileChooser using the given current directory and FileSystemView.
JFileChooser(String, FileSystemView) - Constructor for class javax.swing.JFileChooser
Constructs a JFileChooser using the given current directory path and FileSystemView.
JFileChooser.AccessibleJFileChooser - Class in javax.swing
This class implements accessibility support for the JFileChooser class.
JFormattedTextField - Class in javax.swing
JFormattedTextField extends JTextField adding support for formatting arbitrary values, as well as retrieving a particular object once the user has edited the text.
JFormattedTextField() - Constructor for class javax.swing.JFormattedTextField
Creates a JFormattedTextField with no AbstractFormatterFactory.
JFormattedTextField(Object) - Constructor for class javax.swing.JFormattedTextField
Creates a JFormattedTextField with the specified value.
JFormattedTextField(Format) - Constructor for class javax.swing.JFormattedTextField
Creates a JFormattedTextField.
JFormattedTextField(JFormattedTextField.AbstractFormatter) - Constructor for class javax.swing.JFormattedTextField
Creates a JFormattedTextField with the specified AbstractFormatter.
JFormattedTextField(JFormattedTextField.AbstractFormatterFactory) - Constructor for class javax.swing.JFormattedTextField
Creates a JFormattedTextField with the specified AbstractFormatterFactory.
JFormattedTextField(JFormattedTextField.AbstractFormatterFactory, Object) - Constructor for class javax.swing.JFormattedTextField
Creates a JFormattedTextField with the specified AbstractFormatterFactory and initial value.
JFormattedTextField.AbstractFormatter - Class in javax.swing
Instances of AbstractFormatter are used by JFormattedTextField to handle the conversion both from an Object to a String, and back from a String to an Object.
JFormattedTextField.AbstractFormatterFactory - Class in javax.swing
Instances of AbstractFormatterFactory are used by JFormattedTextField to obtain instances of AbstractFormatter which in turn are used to format values.
JFrame - Class in javax.swing
An extended version of java.awt.Frame that adds support for the JFC/Swing component architecture.
JFrame() - Constructor for class javax.swing.JFrame
Constructs a new frame that is initially invisible.
JFrame(GraphicsConfiguration) - Constructor for class javax.swing.JFrame
Creates a Frame in the specified GraphicsConfiguration of a screen device and a blank title.
JFrame(String) - Constructor for class javax.swing.JFrame
Creates a new, initially invisible Frame with the specified title.
JFrame(String, GraphicsConfiguration) - Constructor for class javax.swing.JFrame
Creates a JFrame with the specified title and the specified GraphicsConfiguration of a screen device.
JFrame.AccessibleJFrame - Class in javax.swing
This class implements accessibility support for the JFrame class.
JInternalFrame - Class in javax.swing
A lightweight object that provides many of the features of a native frame, including dragging, closing, becoming an icon, resizing, title display, and support for a menu bar.
JInternalFrame() - Constructor for class javax.swing.JInternalFrame
Creates a non-resizable, non-closable, non-maximizable, non-iconifiable JInternalFrame with no title.
JInternalFrame(String) - Constructor for class javax.swing.JInternalFrame
Creates a non-resizable, non-closable, non-maximizable, non-iconifiable JInternalFrame with the specified title.
JInternalFrame(String, boolean) - Constructor for class javax.swing.JInternalFrame
Creates a non-closable, non-maximizable, non-iconifiable JInternalFrame with the specified title and resizability.
JInternalFrame(String, boolean, boolean) - Constructor for class javax.swing.JInternalFrame
Creates a non-maximizable, non-iconifiable JInternalFrame with the specified title, resizability, and closability.
JInternalFrame(String, boolean, boolean, boolean) - Constructor for class javax.swing.JInternalFrame
Creates a non-iconifiable JInternalFrame with the specified title, resizability, closability, and maximizability.
JInternalFrame(String, boolean, boolean, boolean, boolean) - Constructor for class javax.swing.JInternalFrame
Creates a JInternalFrame with the specified title, resizability, closability, maximizability, and iconifiability.
JInternalFrame.AccessibleJInternalFrame - Class in javax.swing
This class implements accessibility support for the JInternalFrame class.
JInternalFrame.JDesktopIcon - Class in javax.swing
This component represents an iconified version of a JInternalFrame.
JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon - Class in javax.swing
This class implements accessibility support for the JInternalFrame.JDesktopIcon class.
JIS_B0 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for JIS B0, 1030 x 1456 mm.
JIS_B0 - Static variable in class javax.print.attribute.standard.MediaSizeName
JIS B0 size.
JIS_B1 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for JIS B1, 728 x 1030 mm.
JIS_B1 - Static variable in class javax.print.attribute.standard.MediaSizeName
JIS B1 size.
JIS_B10 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for JIS B10, 32 x 45 mm.
JIS_B10 - Static variable in class javax.print.attribute.standard.MediaSizeName
JIS B10 size.
JIS_B2 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for JIS B2, 515 x 728 mm.
JIS_B2 - Static variable in class javax.print.attribute.standard.MediaSizeName
JIS B2 size.
JIS_B3 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for JIS B3, 364 x 515 mm.
JIS_B3 - Static variable in class javax.print.attribute.standard.MediaSizeName
JIS B3 size.
JIS_B4 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for JIS B4, 257 x 364 mm.
JIS_B4 - Static variable in class javax.print.attribute.standard.MediaSizeName
JIS B4 size.
JIS_B5 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for JIS B5, 182 x 257 mm.
JIS_B5 - Static variable in class javax.print.attribute.standard.MediaSizeName
JIS B5 size.
JIS_B6 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for JIS B6, 128 x 182 mm.
JIS_B6 - Static variable in class javax.print.attribute.standard.MediaSizeName
JIS B6 size.
JIS_B7 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for JIS B7, 91 x 128 mm.
JIS_B7 - Static variable in class javax.print.attribute.standard.MediaSizeName
JIS B7 size.
JIS_B8 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for JIS B8, 64 x 91 mm.
JIS_B8 - Static variable in class javax.print.attribute.standard.MediaSizeName
JIS B8 size.
JIS_B9 - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for JIS B9, 45 x 64 mm.
JIS_B9 - Static variable in class javax.print.attribute.standard.MediaSizeName
JIS B9 size.
JLabel - Class in javax.swing
A display area for a short text string or an image, or both.
JLabel(String, Icon, int) - Constructor for class javax.swing.JLabel
Creates a JLabel instance with the specified text, image, and horizontal alignment.
JLabel(String, int) - Constructor for class javax.swing.JLabel
Creates a JLabel instance with the specified text and horizontal alignment.
JLabel(String) - Constructor for class javax.swing.JLabel
Creates a JLabel instance with the specified text.
JLabel(Icon, int) - Constructor for class javax.swing.JLabel
Creates a JLabel instance with the specified image and horizontal alignment.
JLabel(Icon) - Constructor for class javax.swing.JLabel
Creates a JLabel instance with the specified image.
JLabel() - Constructor for class javax.swing.JLabel
Creates a JLabel instance with no image and with an empty string for the title.
JLabel.AccessibleJLabel - Class in javax.swing
The class used to obtain the accessible role for this object.
JLayer<V extends Component> - Class in javax.swing
JLayer is a universal decorator for Swing components which enables you to implement various advanced painting effects as well as receive notifications of all AWTEvents generated within its borders.
JLayer() - Constructor for class javax.swing.JLayer
Creates a new JLayer object with a null view component and default LayerUI.
JLayer(V) - Constructor for class javax.swing.JLayer
Creates a new JLayer object with default LayerUI.
JLayer(V, LayerUI<V>) - Constructor for class javax.swing.JLayer
Creates a new JLayer object with the specified view component and LayerUI object.
JLayeredPane - Class in javax.swing
JLayeredPane adds depth to a JFC/Swing container, allowing components to overlap each other when needed.
JLayeredPane() - Constructor for class javax.swing.JLayeredPane
Create a new JLayeredPane
JLayeredPane.AccessibleJLayeredPane - Class in javax.swing
This class implements accessibility support for the JLayeredPane class.
JList<E> - Class in javax.swing
A component that displays a list of objects and allows the user to select one or more items.
JList(ListModel<E>) - Constructor for class javax.swing.JList
Constructs a JList that displays elements from the specified, non-null, model.
JList(E[]) - Constructor for class javax.swing.JList
Constructs a JList that displays the elements in the specified array.
JList(Vector<? extends E>) - Constructor for class javax.swing.JList
Constructs a JList that displays the elements in the specified Vector.
JList() - Constructor for class javax.swing.JList
Constructs a JList with an empty, read-only, model.
JList.AccessibleJList - Class in javax.swing
This class implements accessibility support for the JList class.
JList.AccessibleJList.AccessibleJListChild - Class in javax.swing
This class implements accessibility support appropriate for list children.
JList.DropLocation - Class in javax.swing
A subclass of TransferHandler.DropLocation representing a drop location for a JList.
JMenu - Class in javax.swing
An implementation of a menu -- a popup window containing JMenuItems that is displayed when the user selects an item on the JMenuBar.
JMenu() - Constructor for class javax.swing.JMenu
Constructs a new JMenu with no text.
JMenu(String) - Constructor for class javax.swing.JMenu
Constructs a new JMenu with the supplied string as its text.
JMenu(Action) - Constructor for class javax.swing.JMenu
Constructs a menu whose properties are taken from the Action supplied.
JMenu(String, boolean) - Constructor for class javax.swing.JMenu
Constructs a new JMenu with the supplied string as its text and specified as a tear-off menu or not.
JMenu.AccessibleJMenu - Class in javax.swing
This class implements accessibility support for the JMenu class.
JMenu.WinListener - Class in javax.swing
A listener class that watches for a popup window closing.
JMenuBar - Class in javax.swing
An implementation of a menu bar.
JMenuBar() - Constructor for class javax.swing.JMenuBar
Creates a new menu bar.
JMenuBar.AccessibleJMenuBar - Class in javax.swing
This class implements accessibility support for the JMenuBar class.
JMenuItem - Class in javax.swing
An implementation of an item in a menu.
JMenuItem() - Constructor for class javax.swing.JMenuItem
Creates a JMenuItem with no set text or icon.
JMenuItem(Icon) - Constructor for class javax.swing.JMenuItem
Creates a JMenuItem with the specified icon.
JMenuItem(String) - Constructor for class javax.swing.JMenuItem
Creates a JMenuItem with the specified text.
JMenuItem(Action) - Constructor for class javax.swing.JMenuItem
Creates a menu item whose properties are taken from the specified Action.
JMenuItem(String, Icon) - Constructor for class javax.swing.JMenuItem
Creates a JMenuItem with the specified text and icon.
JMenuItem(String, int) - Constructor for class javax.swing.JMenuItem
Creates a JMenuItem with the specified text and keyboard mnemonic.
JMenuItem.AccessibleJMenuItem - Class in javax.swing
This class implements accessibility support for the JMenuItem class.
JMException - Exception in javax.management
Exceptions thrown by JMX implementations.
JMException() - Constructor for exception javax.management.JMException
Default constructor.
JMException(String) - Constructor for exception javax.management.JMException
Constructor that allows a specific error message to be specified.
JMRuntimeException - Exception in javax.management
Runtime exceptions emitted by JMX implementations.
JMRuntimeException() - Constructor for exception javax.management.JMRuntimeException
Default constructor.
JMRuntimeException(String) - Constructor for exception javax.management.JMRuntimeException
Constructor that allows a specific error message to be specified.
JMX - Class in javax.management
Static methods from the JMX API.
JMXAddressable - Interface in javax.management.remote
Implemented by objects that can have a JMXServiceURL address.
JMXAuthenticator - Interface in javax.management.remote
Interface to define how remote credentials are converted into a JAAS Subject.
JMXConnectionNotification - Class in javax.management.remote
Notification emitted when a client connection is opened or closed or when notifications are lost.
JMXConnectionNotification(String, Object, String, long, String, Object) - Constructor for class javax.management.remote.JMXConnectionNotification
Constructs a new connection notification.
JMXConnector - Interface in javax.management.remote
The client end of a JMX API connector.
JMXConnectorFactory - Class in javax.management.remote
Factory to create JMX API connector clients.
JMXConnectorProvider - Interface in javax.management.remote
A provider for creating JMX API connector clients using a given protocol.
JMXConnectorServer - Class in javax.management.remote
Superclass of every connector server.
JMXConnectorServer() - Constructor for class javax.management.remote.JMXConnectorServer
Constructs a connector server that will be registered as an MBean in the MBean server it is attached to.
JMXConnectorServer(MBeanServer) - Constructor for class javax.management.remote.JMXConnectorServer
Constructs a connector server that is attached to the given MBean server.
JMXConnectorServerFactory - Class in javax.management.remote
Factory to create JMX API connector servers.
JMXConnectorServerMBean - Interface in javax.management.remote
MBean interface for connector servers.
JMXConnectorServerProvider - Interface in javax.management.remote
A provider for creating JMX API connector servers using a given protocol.
JMXPrincipal - Class in javax.management.remote
The identity of a remote client of the JMX Remote API.
JMXPrincipal(String) - Constructor for class javax.management.remote.JMXPrincipal
Creates a JMXPrincipal for a given identity.
JMXProviderException - Exception in javax.management.remote
Exception thrown by JMXConnectorFactory and JMXConnectorServerFactory when a provider exists for the required protocol but cannot be used for some reason.
JMXProviderException() - Constructor for exception javax.management.remote.JMXProviderException
Constructs a JMXProviderException with no specified detail message.
JMXProviderException(String) - Constructor for exception javax.management.remote.JMXProviderException
Constructs a JMXProviderException with the specified detail message.
JMXProviderException(String, Throwable) - Constructor for exception javax.management.remote.JMXProviderException
Constructs a JMXProviderException with the specified detail message and nested exception.
JMXServerErrorException - Exception in javax.management.remote
Exception thrown as the result of a remote MBeanServer method invocation when an Error is thrown while processing the invocation in the remote MBean server.
JMXServerErrorException(String, Error) - Constructor for exception javax.management.remote.JMXServerErrorException
Constructs a JMXServerErrorException with the specified detail message and nested error.
JMXServiceURL - Class in javax.management.remote
The address of a JMX API connector server.
JMXServiceURL(String) - Constructor for class javax.management.remote.JMXServiceURL
Constructs a JMXServiceURL by parsing a Service URL string.
JMXServiceURL(String, String, int) - Constructor for class javax.management.remote.JMXServiceURL
Constructs a JMXServiceURL with the given protocol, host, and port.
JMXServiceURL(String, String, int, String) - Constructor for class javax.management.remote.JMXServiceURL
Constructs a JMXServiceURL with the given parts.
JNDI_REBIND_ATTRIBUTE - Static variable in class javax.management.remote.rmi.RMIConnectorServer
Name of the attribute that specifies whether the RMIServer stub that represents an RMI connector server should override an existing stub at the same address.
JOB_CANCELED - Static variable in class javax.print.event.PrintJobEvent
The job was canceled by the PrintService.
JOB_CANCELED_AT_DEVICE - Static variable in class javax.print.attribute.standard.JobStateReason
The job was canceled by an unidentified local user, i.e., a user at a console at the device.
JOB_CANCELED_BY_OPERATOR - Static variable in class javax.print.attribute.standard.JobStateReason
The job was canceled by the operator, i.e., by a user who has been authenticated as having operator privileges (whether local or remote).
JOB_CANCELED_BY_USER - Static variable in class javax.print.attribute.standard.JobStateReason
The job was canceled by the owner of the job, i.e., by a user whose authenticated identity is the same as the value of the originating user that created the Print Job, or by some other authorized end-user, such as a member of the job owner's security group.
JOB_COMPLETE - Static variable in class javax.print.event.PrintJobEvent
The document cis completely printed.
JOB_COMPLETED_SUCCESSFULLY - Static variable in class javax.print.attribute.standard.JobStateReason
The job completed successfully.
JOB_COMPLETED_WITH_ERRORS - Static variable in class javax.print.attribute.standard.JobStateReason
The job completed with errors (and possibly warnings too).
JOB_COMPLETED_WITH_WARNINGS - Static variable in class javax.print.attribute.standard.JobStateReason
The job completed with warnings.
JOB_DATA_INSUFFICIENT - Static variable in class javax.print.attribute.standard.JobStateReason
The printer has created the Print Job, but the printer is expecting additional print data before it can move the job into the PROCESSING state.
JOB_FAILED - Static variable in class javax.print.event.PrintJobEvent
The print service reports that the job cannot be completed.
JOB_HOLD_UNTIL_SPECIFIED - Static variable in class javax.print.attribute.standard.JobStateReason
The value of the job's JobHoldUntil attribute was specified with a date-time that is still in the future.
JOB_INCOMING - Static variable in class javax.print.attribute.standard.JobStateReason
The printer has created the Print Job, but the printer has not finished accessing or accepting all the print data yet.
JOB_INTERPRETING - Static variable in class javax.print.attribute.standard.JobStateReason
The job is in the PROCESSING state, but more specifically, the printer ia interpreting the document data.
JOB_OUTGOING - Static variable in class javax.print.attribute.standard.JobStateReason
The printer is transmitting the job to the output device.
JOB_PRINTING - Static variable in class javax.print.attribute.standard.JobStateReason
The output device is marking media.
JOB_QUEUED - Static variable in class javax.print.attribute.standard.JobStateReason
The job is in the PROCESSING state, but more specifically, the printer has queued the document data.
JOB_QUEUED_FOR_MARKER - Static variable in class javax.print.attribute.standard.JobStateReason
The job is in the PENDING_HELD, PENDING, or PROCESSING state, but more specifically, the printer has completed enough processing of the document to be able to start marking and the job is waiting for the marker.
JOB_RESTARTABLE - Static variable in class javax.print.attribute.standard.JobStateReason
This job is retained and is currently able to be restarted.
JOB_TRANSFORMING - Static variable in class javax.print.attribute.standard.JobStateReason
The job is in the PROCESSING state, but more specifically, the printer is interpreting document data and producing another electronic representation.
JobAttributes - Class in java.awt
A set of attributes which control a print job.
JobAttributes() - Constructor for class java.awt.JobAttributes
Constructs a JobAttributes instance with default values for every attribute.
JobAttributes(JobAttributes) - Constructor for class java.awt.JobAttributes
Constructs a JobAttributes instance which is a copy of the supplied JobAttributes.
JobAttributes(int, JobAttributes.DefaultSelectionType, JobAttributes.DestinationType, JobAttributes.DialogType, String, int, int, JobAttributes.MultipleDocumentHandlingType, int[][], String, JobAttributes.SidesType) - Constructor for class java.awt.JobAttributes
Constructs a JobAttributes instance with the specified values for every attribute.
JobAttributes.DefaultSelectionType - Class in java.awt
A type-safe enumeration of possible default selection states.
JobAttributes.DestinationType - Class in java.awt
A type-safe enumeration of possible job destinations.
JobAttributes.DialogType - Class in java.awt
A type-safe enumeration of possible dialogs to display to the user.
JobAttributes.MultipleDocumentHandlingType - Class in java.awt
A type-safe enumeration of possible multiple copy handling states.
JobAttributes.SidesType - Class in java.awt
A type-safe enumeration of possible multi-page impositions.
JobHoldUntil - Class in javax.print.attribute.standard
Class JobHoldUntil is a printing attribute class, a date-time attribute, that specifies the exact date and time at which the job must become a candidate for printing.
JobHoldUntil(Date) - Constructor for class javax.print.attribute.standard.JobHoldUntil
Construct a new job hold until date-time attribute with the given Date value.
JobImpressions - Class in javax.print.attribute.standard
Class JobImpressions is an integer valued printing attribute class that specifies the total size in number of impressions of the document(s) being submitted.
JobImpressions(int) - Constructor for class javax.print.attribute.standard.JobImpressions
Construct a new job impressions attribute with the given integer value.
JobImpressionsCompleted - Class in javax.print.attribute.standard
Class JobImpressionsCompleted is an integer valued printing attribute class that specifies the number of impressions completed for the job so far.
JobImpressionsCompleted(int) - Constructor for class javax.print.attribute.standard.JobImpressionsCompleted
Construct a new job impressions completed attribute with the given integer value.
JobImpressionsSupported - Class in javax.print.attribute.standard
Class JobImpressionsSupported is a printing attribute class, a set of integers, that gives the supported values for a JobImpressions attribute.
JobImpressionsSupported(int, int) - Constructor for class javax.print.attribute.standard.JobImpressionsSupported
Construct a new job impressions supported attribute containing a single range of integers.
JobKOctets - Class in javax.print.attribute.standard
Class JobKOctets is an integer valued printing attribute class that specifies the total size of the document(s) in K octets, i.e., in units of 1024 octets requested to be processed in the job.
JobKOctets(int) - Constructor for class javax.print.attribute.standard.JobKOctets
Construct a new job K octets attribute with the given integer value.
JobKOctetsProcessed - Class in javax.print.attribute.standard
Class JobKOctetsProcessed is an integer valued printing attribute class that specifies the total number of print data octets processed so far in K octets, i.e., in units of 1024 octets.
JobKOctetsProcessed(int) - Constructor for class javax.print.attribute.standard.JobKOctetsProcessed
Construct a new job K octets processed attribute with the given integer value.
JobKOctetsSupported - Class in javax.print.attribute.standard
Class JobKOctetsSupported is a printing attribute class, a set of integers, that gives the supported values for a JobKOctets attribute.
JobKOctetsSupported(int, int) - Constructor for class javax.print.attribute.standard.JobKOctetsSupported
Construct a new job K octets supported attribute containing a single range of integers.
JobMediaSheets - Class in javax.print.attribute.standard
Class JobMediaSheets is an integer valued printing attribute class that specifies the total number of media sheets to be produced for this job.
JobMediaSheets(int) - Constructor for class javax.print.attribute.standard.JobMediaSheets
Construct a new job media sheets attribute with the given integer value.
JobMediaSheetsCompleted - Class in javax.print.attribute.standard
Class JobMediaSheetsCompleted is an integer valued printing attribute class that specifies the number of media sheets which have completed marking and stacking for the entire job so far, whether those sheets have been processed on one side or on both.
JobMediaSheetsCompleted(int) - Constructor for class javax.print.attribute.standard.JobMediaSheetsCompleted
Construct a new job media sheets completed attribute with the given integer value.
JobMediaSheetsSupported - Class in javax.print.attribute.standard
Class JobMediaSheetsSupported is a printing attribute class, a set of integers, that gives the supported values for a JobMediaSheets attribute.
JobMediaSheetsSupported(int, int) - Constructor for class javax.print.attribute.standard.JobMediaSheetsSupported
Construct a new job media sheets supported attribute containing a single range of integers.
JobMessageFromOperator - Class in javax.print.attribute.standard
Class JobMessageFromOperator is a printing attribute class, a text attribute, that provides a message from an operator, system administrator, or "intelligent" process to indicate to the end user the reasons for modification or other management action taken on a job.
JobMessageFromOperator(String, Locale) - Constructor for class javax.print.attribute.standard.JobMessageFromOperator
Constructs a new job message from operator attribute with the given message and locale.
JobName - Class in javax.print.attribute.standard
Class JobName is a printing attribute class, a text attribute, that specifies the name of a print job.
JobName(String, Locale) - Constructor for class javax.print.attribute.standard.JobName
Constructs a new job name attribute with the given job name and locale.
JobOriginatingUserName - Class in javax.print.attribute.standard
Class JobOriginatingUserName is a printing attribute class, a text attribute, that contains the name of the end user that submitted the print job.
JobOriginatingUserName(String, Locale) - Constructor for class javax.print.attribute.standard.JobOriginatingUserName
Constructs a new job originating user name attribute with the given user name and locale.
JobPriority - Class in javax.print.attribute.standard
Class JobPriority is an integer valued printing attribute class that specifies a print job's priority.
JobPriority(int) - Constructor for class javax.print.attribute.standard.JobPriority
Construct a new job priority attribute with the given integer value.
JobPrioritySupported - Class in javax.print.attribute.standard
Class JobPrioritySupported is an integer valued printing attribute class that specifies whether a Print Service instance supports the JobPriority attribute and the number of different job priority levels supported.
JobPrioritySupported(int) - Constructor for class javax.print.attribute.standard.JobPrioritySupported
Construct a new job priority supported attribute with the given integer value.
JobSheets - Class in javax.print.attribute.standard
Class JobSheets is a printing attribute class, an enumeration, that determines which job start and end sheets, if any, must be printed with a job.
JobSheets(int) - Constructor for class javax.print.attribute.standard.JobSheets
Construct a new job sheets enumeration value with the given integer value.
JobState - Class in javax.print.attribute.standard
JobState is a printing attribute class, an enumeration, that identifies the current state of a print job.
JobState(int) - Constructor for class javax.print.attribute.standard.JobState
Construct a new job state enumeration value with the given integer value.
JobStateReason - Class in javax.print.attribute.standard
Class JobStateReason is a printing attribute class, an enumeration, that provides additional information about the job's current state, i.e., information that augments the value of the job's JobState attribute.
JobStateReason(int) - Constructor for class javax.print.attribute.standard.JobStateReason
Construct a new job state reason enumeration value with the given integer value.
JobStateReasons - Class in javax.print.attribute.standard
Class JobStateReasons is a printing attribute class, a set of enumeration values, that provides additional information about the job's current state, i.e., information that augments the value of the job's JobState attribute.
JobStateReasons() - Constructor for class javax.print.attribute.standard.JobStateReasons
Construct a new, empty job state reasons attribute; the underlying hash set has the default initial capacity and load factor.
JobStateReasons(int) - Constructor for class javax.print.attribute.standard.JobStateReasons
Construct a new, empty job state reasons attribute; the underlying hash set has the given initial capacity and the default load factor.
JobStateReasons(int, float) - Constructor for class javax.print.attribute.standard.JobStateReasons
Construct a new, empty job state reasons attribute; the underlying hash set has the given initial capacity and load factor.
JobStateReasons(Collection<JobStateReason>) - Constructor for class javax.print.attribute.standard.JobStateReasons
Construct a new job state reasons attribute that contains the same JobStateReason objects as the given collection.
join(CharSequence, CharSequence...) - Static method in class java.lang.String
Returns a new String composed of copies of the CharSequence elements joined together with a copy of the specified delimiter.
join(CharSequence, Iterable<? extends CharSequence>) - Static method in class java.lang.String
Returns a new String composed of copies of the CharSequence elements joined together with a copy of the specified delimiter.
join(long) - Method in class java.lang.Thread
Waits at most millis milliseconds for this thread to die.
join(long, int) - Method in class java.lang.Thread
Waits at most millis milliseconds plus nanos nanoseconds for this thread to die.
join() - Method in class java.lang.Thread
Waits for this thread to die.
join(InetAddress) - Method in class java.net.DatagramSocketImpl
Join the multicast group.
join(InetAddress, NetworkInterface) - Method in interface java.nio.channels.MulticastChannel
Joins a multicast group to begin receiving all datagrams sent to the group, returning a membership key.
join(InetAddress, NetworkInterface, InetAddress) - Method in interface java.nio.channels.MulticastChannel
Joins a multicast group to begin receiving datagrams sent to the group from a given source address.
join() - Method in class java.util.concurrent.CompletableFuture
Returns the result value when complete, or throws an (unchecked) exception if completed exceptionally.
join() - Method in class java.util.concurrent.ForkJoinTask
Returns the result of the computation when it is done.
JOIN_BEVEL - Static variable in class java.awt.BasicStroke
Joins path segments by connecting the outer corners of their wide outlines with a straight segment.
JOIN_MITER - Static variable in class java.awt.BasicStroke
Joins path segments by extending their outside edges until they meet.
JOIN_ROUND - Static variable in class java.awt.BasicStroke
Joins path segments by rounding off the corner at a radius of half the line width.
Joinable - Interface in javax.sql.rowset
1.0 Background
JoinFractureDirection - Static variable in class javax.swing.text.DefaultStyledDocument.ElementSpec
A possible value for getDirection.
joinGroup(SocketAddress, NetworkInterface) - Method in class java.net.DatagramSocketImpl
Join the multicast group.
joinGroup(InetAddress) - Method in class java.net.MulticastSocket
Joins a multicast group.
joinGroup(SocketAddress, NetworkInterface) - Method in class java.net.MulticastSocket
Joins the specified multicast group at the specified interface.
joining() - Static method in class java.util.stream.Collectors
Returns a Collector that concatenates the input elements into a String, in encounter order.
joining(CharSequence) - Static method in class java.util.stream.Collectors
Returns a Collector that concatenates the input elements, separated by the specified delimiter, in encounter order.
joining(CharSequence, CharSequence, CharSequence) - Static method in class java.util.stream.Collectors
Returns a Collector that concatenates the input elements, separated by the specified delimiter, with the specified prefix and suffix, in encounter order.
JoinNextDirection - Static variable in class javax.swing.text.DefaultStyledDocument.ElementSpec
A possible value for getDirection.
JoinPreviousDirection - Static variable in class javax.swing.text.DefaultStyledDocument.ElementSpec
A possible value for getDirection.
JoinRowSet - Interface in javax.sql.rowset
The JoinRowSet interface provides a mechanism for combining related data from different RowSet objects into one JoinRowSet object, which represents an SQL JOIN.
JOptionPane - Class in javax.swing
JOptionPane makes it easy to pop up a standard dialog box that prompts users for a value or informs them of something.
JOptionPane() - Constructor for class javax.swing.JOptionPane
Creates a JOptionPane with a test message.
JOptionPane(Object) - Constructor for class javax.swing.JOptionPane
Creates a instance of JOptionPane to display a message using the plain-message message type and the default options delivered by the UI.
JOptionPane(Object, int) - Constructor for class javax.swing.JOptionPane
Creates an instance of JOptionPane to display a message with the specified message type and the default options,
JOptionPane(Object, int, int) - Constructor for class javax.swing.JOptionPane
Creates an instance of JOptionPane to display a message with the specified message type and options.
JOptionPane(Object, int, int, Icon) - Constructor for class javax.swing.JOptionPane
Creates an instance of JOptionPane to display a message with the specified message type, options, and icon.
JOptionPane(Object, int, int, Icon, Object[]) - Constructor for class javax.swing.JOptionPane
Creates an instance of JOptionPane to display a message with the specified message type, icon, and options.
JOptionPane(Object, int, int, Icon, Object[], Object) - Constructor for class javax.swing.JOptionPane
Creates an instance of JOptionPane to display a message with the specified message type, icon, and options, with the initially-selected option specified.
JOptionPane.AccessibleJOptionPane - Class in javax.swing
This class implements accessibility support for the JOptionPane class.
JPanel - Class in javax.swing
JPanel is a generic lightweight container.
JPanel(LayoutManager, boolean) - Constructor for class javax.swing.JPanel
Creates a new JPanel with the specified layout manager and buffering strategy.
JPanel(LayoutManager) - Constructor for class javax.swing.JPanel
Create a new buffered JPanel with the specified layout manager
JPanel(boolean) - Constructor for class javax.swing.JPanel
Creates a new JPanel with FlowLayout and the specified buffering strategy.
JPanel() - Constructor for class javax.swing.JPanel
Creates a new JPanel with a double buffer and a flow layout.
JPanel.AccessibleJPanel - Class in javax.swing
This class implements accessibility support for the JPanel class.
JPasswordField - Class in javax.swing
JPasswordField is a lightweight component that allows the editing of a single line of text where the view indicates something was typed, but does not show the original characters.
JPasswordField() - Constructor for class javax.swing.JPasswordField
Constructs a new JPasswordField, with a default document, null starting text string, and 0 column width.
JPasswordField(String) - Constructor for class javax.swing.JPasswordField
Constructs a new JPasswordField initialized with the specified text.
JPasswordField(int) - Constructor for class javax.swing.JPasswordField
Constructs a new empty JPasswordField with the specified number of columns.
JPasswordField(String, int) - Constructor for class javax.swing.JPasswordField
Constructs a new JPasswordField initialized with the specified text and columns.
JPasswordField(Document, String, int) - Constructor for class javax.swing.JPasswordField
Constructs a new JPasswordField that uses the given text storage model and the given number of columns.
JPasswordField.AccessibleJPasswordField - Class in javax.swing
This class implements accessibility support for the JPasswordField class.
JPEG - Static variable in class javax.print.DocFlavor.BYTE_ARRAY
Doc flavor with MIME type = "image/jpeg", print data representation class name = "[B" (byte array).
JPEG - Static variable in class javax.print.DocFlavor.INPUT_STREAM
Doc flavor with MIME type = "image/jpeg", print data representation class name = "java.io.InputStream" (byte stream).
JPEG - Static variable in class javax.print.DocFlavor.URL
Doc flavor with MIME type = "image/jpeg", print data representation class name = "java.net.URL".
JPEGHuffmanTable - Class in javax.imageio.plugins.jpeg
A class encapsulating a single JPEG Huffman table.
JPEGHuffmanTable(short[], short[]) - Constructor for class javax.imageio.plugins.jpeg.JPEGHuffmanTable
Creates a Huffman table and initializes it.
JPEGImageReadParam - Class in javax.imageio.plugins.jpeg
This class adds the ability to set JPEG quantization and Huffman tables when using the built-in JPEG reader plug-in.
JPEGImageReadParam() - Constructor for class javax.imageio.plugins.jpeg.JPEGImageReadParam
Constructs a JPEGImageReadParam.
JPEGImageWriteParam - Class in javax.imageio.plugins.jpeg
This class adds the ability to set JPEG quantization and Huffman tables when using the built-in JPEG writer plug-in, and to request that optimized Huffman tables be computed for an image.
JPEGImageWriteParam(Locale) - Constructor for class javax.imageio.plugins.jpeg.JPEGImageWriteParam
Constructs a JPEGImageWriteParam.
JPEGQTable - Class in javax.imageio.plugins.jpeg
A class encapsulating a single JPEG quantization table.
JPEGQTable(int[]) - Constructor for class javax.imageio.plugins.jpeg.JPEGQTable
Constructs a quantization table from the argument, which must contain 64 elements in natural order (not zig-zag order).
JPopupMenu - Class in javax.swing
An implementation of a popup menu -- a small window that pops up and displays a series of choices.
JPopupMenu() - Constructor for class javax.swing.JPopupMenu
Constructs a JPopupMenu without an "invoker".
JPopupMenu(String) - Constructor for class javax.swing.JPopupMenu
Constructs a JPopupMenu with the specified title.
JPopupMenu.AccessibleJPopupMenu - Class in javax.swing
This class implements accessibility support for the JPopupMenu class.
JPopupMenu.Separator - Class in javax.swing
A popup menu-specific separator.
JProgressBar - Class in javax.swing
A component that visually displays the progress of some task.
JProgressBar() - Constructor for class javax.swing.JProgressBar
Creates a horizontal progress bar that displays a border but no progress string.
JProgressBar(int) - Constructor for class javax.swing.JProgressBar
Creates a progress bar with the specified orientation, which can be either SwingConstants.VERTICAL or SwingConstants.HORIZONTAL.
JProgressBar(int, int) - Constructor for class javax.swing.JProgressBar
Creates a horizontal progress bar with the specified minimum and maximum.
JProgressBar(int, int, int) - Constructor for class javax.swing.JProgressBar
Creates a progress bar using the specified orientation, minimum, and maximum.
JProgressBar(BoundedRangeModel) - Constructor for class javax.swing.JProgressBar
Creates a horizontal progress bar that uses the specified model to hold the progress bar's data.
JProgressBar.AccessibleJProgressBar - Class in javax.swing
This class implements accessibility support for the JProgressBar class.
JRadioButton - Class in javax.swing
An implementation of a radio button -- an item that can be selected or deselected, and which displays its state to the user.
JRadioButton() - Constructor for class javax.swing.JRadioButton
Creates an initially unselected radio button with no set text.
JRadioButton(Icon) - Constructor for class javax.swing.JRadioButton
Creates an initially unselected radio button with the specified image but no text.
JRadioButton(Action) - Constructor for class javax.swing.JRadioButton
Creates a radiobutton where properties are taken from the Action supplied.
JRadioButton(Icon, boolean) - Constructor for class javax.swing.JRadioButton
Creates a radio button with the specified image and selection state, but no text.
JRadioButton(String) - Constructor for class javax.swing.JRadioButton
Creates an unselected radio button with the specified text.
JRadioButton(String, boolean) - Constructor for class javax.swing.JRadioButton
Creates a radio button with the specified text and selection state.
JRadioButton(String, Icon) - Constructor for class javax.swing.JRadioButton
Creates a radio button that has the specified text and image, and that is initially unselected.
JRadioButton(String, Icon, boolean) - Constructor for class javax.swing.JRadioButton
Creates a radio button that has the specified text, image, and selection state.
JRadioButton.AccessibleJRadioButton - Class in javax.swing
This class implements accessibility support for the JRadioButton class.
JRadioButtonMenuItem - Class in javax.swing
An implementation of a radio button menu item.
JRadioButtonMenuItem() - Constructor for class javax.swing.JRadioButtonMenuItem
Creates a JRadioButtonMenuItem with no set text or icon.
JRadioButtonMenuItem(Icon) - Constructor for class javax.swing.JRadioButtonMenuItem
Creates a JRadioButtonMenuItem with an icon.
JRadioButtonMenuItem(String) - Constructor for class javax.swing.JRadioButtonMenuItem
Creates a JRadioButtonMenuItem with text.
JRadioButtonMenuItem(Action) - Constructor for class javax.swing.JRadioButtonMenuItem
Creates a radio button menu item whose properties are taken from the Action supplied.
JRadioButtonMenuItem(String, Icon) - Constructor for class javax.swing.JRadioButtonMenuItem
Creates a radio button menu item with the specified text and Icon.
JRadioButtonMenuItem(String, boolean) - Constructor for class javax.swing.JRadioButtonMenuItem
Creates a radio button menu item with the specified text and selection state.
JRadioButtonMenuItem(Icon, boolean) - Constructor for class javax.swing.JRadioButtonMenuItem
Creates a radio button menu item with the specified image and selection state, but no text.
JRadioButtonMenuItem(String, Icon, boolean) - Constructor for class javax.swing.JRadioButtonMenuItem
Creates a radio button menu item that has the specified text, image, and selection state.
JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem - Class in javax.swing
This class implements accessibility support for the JRadioButtonMenuItem class.
JRootPane - Class in javax.swing
A lightweight container used behind the scenes by JFrame, JDialog, JWindow, JApplet, and JInternalFrame.
JRootPane() - Constructor for class javax.swing.JRootPane
Creates a JRootPane, setting up its glassPane, layeredPane, and contentPane.
JRootPane.AccessibleJRootPane - Class in javax.swing
This class implements accessibility support for the JRootPane class.
JRootPane.RootLayout - Class in javax.swing
A custom layout manager that is responsible for the layout of layeredPane, glassPane, and menuBar.
JScrollBar - Class in javax.swing
An implementation of a scrollbar.
JScrollBar(int, int, int, int, int) - Constructor for class javax.swing.JScrollBar
Creates a scrollbar with the specified orientation, value, extent, minimum, and maximum.
JScrollBar(int) - Constructor for class javax.swing.JScrollBar
Creates a scrollbar with the specified orientation and the following initial values:
JScrollBar() - Constructor for class javax.swing.JScrollBar
Creates a vertical scrollbar with the following initial values:
JScrollBar.AccessibleJScrollBar - Class in javax.swing
This class implements accessibility support for the JScrollBar class.
JScrollPane - Class in javax.swing
Provides a scrollable view of a lightweight component.
JScrollPane(Component, int, int) - Constructor for class javax.swing.JScrollPane
Creates a JScrollPane that displays the view component in a viewport whose view position can be controlled with a pair of scrollbars.
JScrollPane(Component) - Constructor for class javax.swing.JScrollPane
Creates a JScrollPane that displays the contents of the specified component, where both horizontal and vertical scrollbars appear whenever the component's contents are larger than the view.
JScrollPane(int, int) - Constructor for class javax.swing.JScrollPane
Creates an empty (no viewport view) JScrollPane with specified scrollbar policies.
JScrollPane() - Constructor for class javax.swing.JScrollPane
Creates an empty (no viewport view) JScrollPane where both horizontal and vertical scrollbars appear when needed.
JScrollPane.AccessibleJScrollPane - Class in javax.swing
This class implements accessibility support for the JScrollPane class.
JScrollPane.ScrollBar - Class in javax.swing
By default JScrollPane creates scrollbars that are instances of this class.
JSeparator - Class in javax.swing
JSeparator provides a general purpose component for implementing divider lines - most commonly used as a divider between menu items that breaks them up into logical groupings.
JSeparator() - Constructor for class javax.swing.JSeparator
Creates a new horizontal separator.
JSeparator(int) - Constructor for class javax.swing.JSeparator
Creates a new separator with the specified horizontal or vertical orientation.
JSeparator.AccessibleJSeparator - Class in javax.swing
This class implements accessibility support for the JSeparator class.
JSlider - Class in javax.swing
A component that lets the user graphically select a value by sliding a knob within a bounded interval.
JSlider() - Constructor for class javax.swing.JSlider
Creates a horizontal slider with the range 0 to 100 and an initial value of 50.
JSlider(int) - Constructor for class javax.swing.JSlider
Creates a slider using the specified orientation with the range 0 to 100 and an initial value of 50.
JSlider(int, int) - Constructor for class javax.swing.JSlider
Creates a horizontal slider using the specified min and max with an initial value equal to the average of the min plus max.
JSlider(int, int, int) - Constructor for class javax.swing.JSlider
Creates a horizontal slider using the specified min, max and value.
JSlider(int, int, int, int) - Constructor for class javax.swing.JSlider
Creates a slider with the specified orientation and the specified minimum, maximum, and initial values.
JSlider(BoundedRangeModel) - Constructor for class javax.swing.JSlider
Creates a horizontal slider using the specified BoundedRangeModel.
JSlider.AccessibleJSlider - Class in javax.swing
This class implements accessibility support for the JSlider class.
JSpinner - Class in javax.swing
A single line input field that lets the user select a number or an object value from an ordered sequence.
JSpinner(SpinnerModel) - Constructor for class javax.swing.JSpinner
Constructs a spinner for the given model.
JSpinner() - Constructor for class javax.swing.JSpinner
Constructs a spinner with an Integer SpinnerNumberModel with initial value 0 and no minimum or maximum limits.
JSpinner.AccessibleJSpinner - Class in javax.swing
AccessibleJSpinner implements accessibility support for the JSpinner class.
JSpinner.DateEditor - Class in javax.swing
An editor for a JSpinner whose model is a SpinnerDateModel.
JSpinner.DefaultEditor - Class in javax.swing
A simple base class for more specialized editors that displays a read-only view of the model's current value with a JFormattedTextField.
JSpinner.ListEditor - Class in javax.swing
An editor for a JSpinner whose model is a SpinnerListModel.
JSpinner.NumberEditor - Class in javax.swing
An editor for a JSpinner whose model is a SpinnerNumberModel.
JSplitPane - Class in javax.swing
JSplitPane is used to divide two (and only two) Components.
JSplitPane() - Constructor for class javax.swing.JSplitPane
Creates a new JSplitPane configured to arrange the child components side-by-side horizontally, using two buttons for the components.
JSplitPane(int) - Constructor for class javax.swing.JSplitPane
Creates a new JSplitPane configured with the specified orientation.
JSplitPane(int, boolean) - Constructor for class javax.swing.JSplitPane
Creates a new JSplitPane with the specified orientation and redrawing style.
JSplitPane(int, Component, Component) - Constructor for class javax.swing.JSplitPane
Creates a new JSplitPane with the specified orientation and the specified components.
JSplitPane(int, boolean, Component, Component) - Constructor for class javax.swing.JSplitPane
Creates a new JSplitPane with the specified orientation and redrawing style, and with the specified components.
JSplitPane.AccessibleJSplitPane - Class in javax.swing
This class implements accessibility support for the JSplitPane class.
JTabbedPane - Class in javax.swing
A component that lets the user switch between a group of components by clicking on a tab with a given title and/or icon.
JTabbedPane() - Constructor for class javax.swing.JTabbedPane
Creates an empty TabbedPane with a default tab placement of JTabbedPane.TOP.
JTabbedPane(int) - Constructor for class javax.swing.JTabbedPane
Creates an empty TabbedPane with the specified tab placement of either: JTabbedPane.TOP, JTabbedPane.BOTTOM, JTabbedPane.LEFT, or JTabbedPane.RIGHT.
JTabbedPane(int, int) - Constructor for class javax.swing.JTabbedPane
Creates an empty TabbedPane with the specified tab placement and tab layout policy.
JTabbedPane.AccessibleJTabbedPane - Class in javax.swing
This class implements accessibility support for the JTabbedPane class.
JTabbedPane.ModelListener - Class in javax.swing
We pass ModelChanged events along to the listeners with the tabbedpane (instead of the model itself) as the event source.
JTable - Class in javax.swing
The JTable is used to display and edit regular two-dimensional tables of cells.
JTable() - Constructor for class javax.swing.JTable
Constructs a default JTable that is initialized with a default data model, a default column model, and a default selection model.
JTable(TableModel) - Constructor for class javax.swing.JTable
Constructs a JTable that is initialized with dm as the data model, a default column model, and a default selection model.
JTable(TableModel, TableColumnModel) - Constructor for class javax.swing.JTable
Constructs a JTable that is initialized with dm as the data model, cm as the column model, and a default selection model.
JTable(TableModel, TableColumnModel, ListSelectionModel) - Constructor for class javax.swing.JTable
Constructs a JTable that is initialized with dm as the data model, cm as the column model, and sm as the selection model.
JTable(int, int) - Constructor for class javax.swing.JTable
Constructs a JTable with numRows and numColumns of empty cells using DefaultTableModel.
JTable(Vector, Vector) - Constructor for class javax.swing.JTable
Constructs a JTable to display the values in the Vector of Vectors, rowData, with column names, columnNames.
JTable(Object[][], Object[]) - Constructor for class javax.swing.JTable
Constructs a JTable to display the values in the two dimensional array, rowData, with column names, columnNames.
JTable.AccessibleJTable - Class in javax.swing
This class implements accessibility support for the JTable class.
JTable.AccessibleJTable.AccessibleJTableCell - Class in javax.swing
The class provides an implementation of the Java Accessibility API appropriate to table cells.
JTable.AccessibleJTable.AccessibleJTableModelChange - Class in javax.swing
JTable.DropLocation - Class in javax.swing
A subclass of TransferHandler.DropLocation representing a drop location for a JTable.
JTable.PrintMode - Enum in javax.swing
Printing modes, used in printing JTables.
JTableHeader - Class in javax.swing.table
This is the object which manages the header of the JTable.
JTableHeader() - Constructor for class javax.swing.table.JTableHeader
Constructs a JTableHeader with a default TableColumnModel.
JTableHeader(TableColumnModel) - Constructor for class javax.swing.table.JTableHeader
Constructs a JTableHeader which is initialized with cm as the column model.
JTableHeader.AccessibleJTableHeader - Class in javax.swing.table
This class implements accessibility support for the JTableHeader class.
JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry - Class in javax.swing.table
This class provides an implementation of the Java Accessibility API appropriate for JTableHeader entries.
JTextArea - Class in javax.swing
A JTextArea is a multi-line area that displays plain text.
JTextArea() - Constructor for class javax.swing.JTextArea
Constructs a new TextArea.
JTextArea(String) - Constructor for class javax.swing.JTextArea
Constructs a new TextArea with the specified text displayed.
JTextArea(int, int) - Constructor for class javax.swing.JTextArea
Constructs a new empty TextArea with the specified number of rows and columns.
JTextArea(String, int, int) - Constructor for class javax.swing.JTextArea
Constructs a new TextArea with the specified text and number of rows and columns.
JTextArea(Document) - Constructor for class javax.swing.JTextArea
Constructs a new JTextArea with the given document model, and defaults for all of the other arguments (null, 0, 0).
JTextArea(Document, String, int, int) - Constructor for class javax.swing.JTextArea
Constructs a new JTextArea with the specified number of rows and columns, and the given model.
JTextArea.AccessibleJTextArea - Class in javax.swing
This class implements accessibility support for the JTextArea class.
JTextComponent - Class in javax.swing.text
JTextComponent is the base class for swing text components.
JTextComponent() - Constructor for class javax.swing.text.JTextComponent
Creates a new JTextComponent.
JTextComponent.AccessibleJTextComponent - Class in javax.swing.text
This class implements accessibility support for the JTextComponent class.
JTextComponent.DropLocation - Class in javax.swing.text
Represents a drop location for JTextComponents.
JTextComponent.KeyBinding - Class in javax.swing.text
Binding record for creating key bindings.
JTextField - Class in javax.swing
JTextField is a lightweight component that allows the editing of a single line of text.
JTextField() - Constructor for class javax.swing.JTextField
Constructs a new TextField.
JTextField(String) - Constructor for class javax.swing.JTextField
Constructs a new TextField initialized with the specified text.
JTextField(int) - Constructor for class javax.swing.JTextField
Constructs a new empty TextField with the specified number of columns.
JTextField(String, int) - Constructor for class javax.swing.JTextField
Constructs a new TextField initialized with the specified text and columns.
JTextField(Document, String, int) - Constructor for class javax.swing.JTextField
Constructs a new JTextField that uses the given text storage model and the given number of columns.
JTextField.AccessibleJTextField - Class in javax.swing
This class implements accessibility support for the JTextField class.
JTextPane - Class in javax.swing
A text component that can be marked up with attributes that are represented graphically.
JTextPane() - Constructor for class javax.swing.JTextPane
Creates a new JTextPane.
JTextPane(StyledDocument) - Constructor for class javax.swing.JTextPane
Creates a new JTextPane, with a specified document model.
JToggleButton - Class in javax.swing
An implementation of a two-state button.
JToggleButton() - Constructor for class javax.swing.JToggleButton
Creates an initially unselected toggle button without setting the text or image.
JToggleButton(Icon) - Constructor for class javax.swing.JToggleButton
Creates an initially unselected toggle button with the specified image but no text.
JToggleButton(Icon, boolean) - Constructor for class javax.swing.JToggleButton
Creates a toggle button with the specified image and selection state, but no text.
JToggleButton(String) - Constructor for class javax.swing.JToggleButton
Creates an unselected toggle button with the specified text.
JToggleButton(String, boolean) - Constructor for class javax.swing.JToggleButton
Creates a toggle button with the specified text and selection state.
JToggleButton(Action) - Constructor for class javax.swing.JToggleButton
Creates a toggle button where properties are taken from the Action supplied.
JToggleButton(String, Icon) - Constructor for class javax.swing.JToggleButton
Creates a toggle button that has the specified text and image, and that is initially unselected.
JToggleButton(String, Icon, boolean) - Constructor for class javax.swing.JToggleButton
Creates a toggle button with the specified text, image, and selection state.
JToggleButton.AccessibleJToggleButton - Class in javax.swing
This class implements accessibility support for the JToggleButton class.
JToggleButton.ToggleButtonModel - Class in javax.swing
The ToggleButton model
JToolBar - Class in javax.swing
JToolBar provides a component that is useful for displaying commonly used Actions or controls.
JToolBar() - Constructor for class javax.swing.JToolBar
Creates a new tool bar; orientation defaults to HORIZONTAL.
JToolBar(int) - Constructor for class javax.swing.JToolBar
Creates a new tool bar with the specified orientation.
JToolBar(String) - Constructor for class javax.swing.JToolBar
Creates a new tool bar with the specified name.
JToolBar(String, int) - Constructor for class javax.swing.JToolBar
Creates a new tool bar with a specified name and orientation.
JToolBar.AccessibleJToolBar - Class in javax.swing
This class implements accessibility support for the JToolBar class.
JToolBar.Separator - Class in javax.swing
A toolbar-specific separator.
JToolTip - Class in javax.swing
Used to display a "Tip" for a Component.
JToolTip() - Constructor for class javax.swing.JToolTip
Creates a tool tip.
JToolTip.AccessibleJToolTip - Class in javax.swing
This class implements accessibility support for the JToolTip class.
JTree - Class in javax.swing
A control that displays a set of hierarchical data as an outline.
JTree() - Constructor for class javax.swing.JTree
Returns a JTree with a sample model.
JTree(Object[]) - Constructor for class javax.swing.JTree
Returns a JTree with each element of the specified array as the child of a new root node which is not displayed.
JTree(Vector<?>) - Constructor for class javax.swing.JTree
Returns a JTree with each element of the specified Vector as the child of a new root node which is not displayed.
JTree(Hashtable<?, ?>) - Constructor for class javax.swing.JTree
Returns a JTree created from a Hashtable which does not display with root.
JTree(TreeNode) - Constructor for class javax.swing.JTree
Returns a JTree with the specified TreeNode as its root, which displays the root node.
JTree(TreeNode, boolean) - Constructor for class javax.swing.JTree
Returns a JTree with the specified TreeNode as its root, which displays the root node and which decides whether a node is a leaf node in the specified manner.
JTree(TreeModel) - Constructor for class javax.swing.JTree
Returns an instance of JTree which displays the root node -- the tree is created using the specified data model.
JTree.AccessibleJTree - Class in javax.swing
This class implements accessibility support for the JTree class.
JTree.AccessibleJTree.AccessibleJTreeNode - Class in javax.swing
This class implements accessibility support for the JTree child.
JTree.DropLocation - Class in javax.swing
A subclass of TransferHandler.DropLocation representing a drop location for a JTree.
JTree.DynamicUtilTreeNode - Class in javax.swing
DynamicUtilTreeNode can wrap vectors/hashtables/arrays/strings and create the appropriate children tree nodes as necessary.
JTree.EmptySelectionModel - Class in javax.swing
EmptySelectionModel is a TreeSelectionModel that does not allow anything to be selected.
JTree.TreeModelHandler - Class in javax.swing
Listens to the model and updates the expandedState accordingly when nodes are removed, or changed.
JTree.TreeSelectionRedirector - Class in javax.swing
Handles creating a new TreeSelectionEvent with the JTree as the source and passing it off to all the listeners.
JULIAN_DAY - Static variable in class java.time.temporal.JulianFields
Julian Day field.
JulianFields - Class in java.time.temporal
A set of date fields that provide access to Julian Days.
JULY - Static variable in class java.util.Calendar
Value of the Calendar.MONTH field indicating the seventh month of the year in the Gregorian and Julian calendars.
JULY - Static variable in class javax.xml.datatype.DatatypeConstants
Value for seventh month of year.
JUNE - Static variable in class java.util.Calendar
Value of the Calendar.MONTH field indicating the sixth month of the year in the Gregorian and Julian calendars.
JUNE - Static variable in class javax.xml.datatype.DatatypeConstants
Value for sixth month of year.
JUSTIFICATION - Static variable in class java.awt.font.TextAttribute
Attribute key for the justification of a paragraph.
JUSTIFICATION_FULL - Static variable in class java.awt.font.TextAttribute
Justify the line to the full requested width.
JUSTIFICATION_NONE - Static variable in class java.awt.font.TextAttribute
Do not allow the line to be justified.
JViewport - Class in javax.swing
The "viewport" or "porthole" through which you see the underlying information.
JViewport() - Constructor for class javax.swing.JViewport
Creates a JViewport.
JViewport.AccessibleJViewport - Class in javax.swing
This class implements accessibility support for the JViewport class.
JViewport.ViewListener - Class in javax.swing
A listener for the view.
JWindow - Class in javax.swing
A JWindow is a container that can be displayed anywhere on the user's desktop.
JWindow() - Constructor for class javax.swing.JWindow
Creates a window with no specified owner.
JWindow(GraphicsConfiguration) - Constructor for class javax.swing.JWindow
Creates a window with the specified GraphicsConfiguration of a screen device.
JWindow(Frame) - Constructor for class javax.swing.JWindow
Creates a window with the specified owner frame.
JWindow(Window) - Constructor for class javax.swing.JWindow
Creates a window with the specified owner window.
JWindow(Window, GraphicsConfiguration) - Constructor for class javax.swing.JWindow
Creates a window with the specified owner window and GraphicsConfiguration of a screen device.
JWindow.AccessibleJWindow - Class in javax.swing
This class implements accessibility support for the JWindow class.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames


K-Index (Java Platform SE 8 )

Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames
  • All Classes
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

K

K1Div2Luminance - Static variable in class javax.imageio.plugins.jpeg.JPEGQTable
The sample luminance quantization table given in the JPEG specification, table K.1, with all elements divided by 2.
K1Luminance - Static variable in class javax.imageio.plugins.jpeg.JPEGQTable
The sample luminance quantization table given in the JPEG specification, table K.1.
K2Chrominance - Static variable in class javax.imageio.plugins.jpeg.JPEGQTable
The sample chrominance quantization table given in the JPEG specification, table K.2.
K2Div2Chrominance - Static variable in class javax.imageio.plugins.jpeg.JPEGQTable
The sample chrominance quantization table given in the JPEG specification, table K.1, with all elements divided by 2.
KAITHI - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Kaithi" Unicode character block.
KAKU_0 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS Kaku ("square") #0 envelope size, 287 mm by 382 mm.
KAKU_1 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS Kaku ("square") #1 envelope size, 270 mm by 382 mm.
KAKU_2 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS Kaku ("square") #2 envelope size, 240 mm by 332 mm.
KAKU_20 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS Kaku ("square") #20 envelope size, 229 mm by 324 mm.
KAKU_3 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS Kaku ("square") #3 envelope size, 216 mm by 277 mm.
KAKU_4 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS Kaku ("square") #4 envelope size, 197 mm by 267 mm.
KAKU_5 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS Kaku ("square") #5 envelope size, 190 mm by 240 mm.
KAKU_6 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS Kaku ("square") #6 envelope size, 162 mm by 229 mm.
KAKU_7 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS Kaku ("square") #7 envelope size, 142 mm by 205 mm.
KAKU_8 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS Kaku ("square") #8 envelope size, 119 mm by 197 mm.
KAKU_A4 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS Kaku ("square") A4 envelope size, 228 mm by 312 mm.
KANA_SUPPLEMENT - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Kana Supplement" Unicode character block.
KANBUN - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Kanbun" Unicode character block.
KANGXI_RADICALS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Kangxi Radicals" Unicode character block.
KANJI - Static variable in class java.awt.im.InputSubset
Constant for all Han characters used in writing Japanese, including a subset of the CJK unified ideographs as well as Japanese Han characters that may be defined as surrogate characters.
KANNADA - Static variable in class java.awt.font.NumericShaper
Identifies the KANNADA range and decimal base.
KANNADA - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Kannada" Unicode character block.
KATAKANA - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Katakana" Unicode character block.
KATAKANA_PHONETIC_EXTENSIONS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Katakana Phonetic Extensions" Unicode character block.
KAYAH_LI - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Kayah Li" Unicode character block.
KBD - Static variable in class javax.swing.text.html.HTML.Tag
KEEP - Static variable in interface java.util.jar.Pack200.Packer
The string "keep", a possible value for certain properties.
KEEP - Static variable in interface java.util.jar.Pack200.Unpacker
The string "keep", a possible value for certain properties.
KEEP_CURRENT_RESULT - Static variable in interface java.sql.Statement
The constant indicating that the current ResultSet object should not be closed when calling getMoreResults.
KEEP_FILE_ORDER - Static variable in interface java.util.jar.Pack200.Packer
If this property is set to Pack200.Packer.TRUE, the packer will transmit all elements in their original order within the source archive.
KerberosKey - Class in javax.security.auth.kerberos
This class encapsulates a long term secret key for a Kerberos principal.
KerberosKey(KerberosPrincipal, byte[], int, int) - Constructor for class javax.security.auth.kerberos.KerberosKey
Constructs a KerberosKey from the given bytes when the key type and key version number are known.
KerberosKey(KerberosPrincipal, char[], String) - Constructor for class javax.security.auth.kerberos.KerberosKey
Constructs a KerberosKey from a principal's password.
KerberosPrincipal - Class in javax.security.auth.kerberos
This class encapsulates a Kerberos principal.
KerberosPrincipal(String) - Constructor for class javax.security.auth.kerberos.KerberosPrincipal
Constructs a KerberosPrincipal from the provided string input.
KerberosPrincipal(String, int) - Constructor for class javax.security.auth.kerberos.KerberosPrincipal
Constructs a KerberosPrincipal from the provided string and name type input.
KerberosTicket - Class in javax.security.auth.kerberos
This class encapsulates a Kerberos ticket and associated information as viewed from the client's point of view.
KerberosTicket(byte[], KerberosPrincipal, KerberosPrincipal, byte[], int, boolean[], Date, Date, Date, Date, InetAddress[]) - Constructor for class javax.security.auth.kerberos.KerberosTicket
Constructs a KerberosTicket using credentials information that a client either receives from a KDC or reads from a cache.
Kernel - Class in java.awt.image
The Kernel class defines a matrix that describes how a specified pixel and its surrounding pixels affect the value computed for the pixel's position in the output image of a filtering operation.
Kernel(int, int, float[]) - Constructor for class java.awt.image.Kernel
Constructs a Kernel object from an array of floats.
KERNING - Static variable in class java.awt.font.TextAttribute
Attribute key to request kerning.
KERNING_ON - Static variable in class java.awt.font.TextAttribute
Request standard kerning.
key - Variable in class java.awt.Event
The key code of the key that was pressed in a keyboard event.
Key(int) - Constructor for class java.awt.RenderingHints.Key
Construct a key using the indicated private key.
Key - Interface in java.security
The Key interface is the top-level interface for all keys.
key - Variable in class javax.accessibility.AccessibleBundle
The locale independent name of the state.
key - Variable in class javax.swing.text.JTextComponent.KeyBinding
The key.
KEY_ACTION - Static variable in class java.awt.Event
The user has pressed a non-ASCII action key.
KEY_ACTION_RELEASE - Static variable in class java.awt.Event
The user has released a non-ASCII action key.
KEY_ALPHA_INTERPOLATION - Static variable in class java.awt.RenderingHints
Alpha interpolation hint key.
KEY_ANTIALIASING - Static variable in class java.awt.RenderingHints
Antialiasing hint key.
KEY_COLOR_RENDERING - Static variable in class java.awt.RenderingHints
Color rendering hint key.
KEY_DITHERING - Static variable in class java.awt.RenderingHints
Dithering hint key.
KEY_EVENT_MASK - Static variable in class java.awt.AWTEvent
The event mask for selecting key events.
KEY_FIRST - Static variable in class java.awt.event.KeyEvent
The first number in the range of ids used for key events.
KEY_FRACTIONALMETRICS - Static variable in class java.awt.RenderingHints
Font fractional metrics hint key.
KEY_INTERPOLATION - Static variable in class java.awt.RenderingHints
Interpolation hint key.
KEY_LAST - Static variable in class java.awt.event.KeyEvent
The last number in the range of ids used for key events.
KEY_LOCATION_LEFT - Static variable in class java.awt.event.KeyEvent
A constant indicating that the key pressed or released is in the left key location (there is more than one possible location for this key).
KEY_LOCATION_NUMPAD - Static variable in class java.awt.event.KeyEvent
A constant indicating that the key event originated on the numeric keypad or with a virtual key corresponding to the numeric keypad.
KEY_LOCATION_RIGHT - Static variable in class java.awt.event.KeyEvent
A constant indicating that the key pressed or released is in the right key location (there is more than one possible location for this key).
KEY_LOCATION_STANDARD - Static variable in class java.awt.event.KeyEvent
A constant indicating that the key pressed or released is not distinguished as the left or right version of a key, and did not originate on the numeric keypad (or did not originate with a virtual key corresponding to the numeric keypad).
KEY_LOCATION_UNKNOWN - Static variable in class java.awt.event.KeyEvent
A constant indicating that the keyLocation is indeterminate or not relevant.
KEY_PRESS - Static variable in class java.awt.Event
The user has pressed a normal key.
KEY_PRESSED - Static variable in class java.awt.event.KeyEvent
The "key pressed" event.
KEY_RELEASE - Static variable in class java.awt.Event
The user has released a normal key.
KEY_RELEASED - Static variable in class java.awt.event.KeyEvent
The "key released" event.
KEY_RENDERING - Static variable in class java.awt.RenderingHints
Rendering hint key.
KEY_STROKE_CONTROL - Static variable in class java.awt.RenderingHints
Stroke normalization control hint key.
KEY_TEXT_ANTIALIASING - Static variable in class java.awt.RenderingHints
Text antialiasing hint key.
KEY_TEXT_LCD_CONTRAST - Static variable in class java.awt.RenderingHints
LCD text contrast rendering hint key.
KEY_TYPED - Static variable in class java.awt.event.KeyEvent
The "key typed" event.
KeyAdapter - Class in java.awt.event
An abstract adapter class for receiving keyboard events.
KeyAdapter() - Constructor for class java.awt.event.KeyAdapter
KeyAgreement - Class in javax.crypto
This class provides the functionality of a key agreement (or key exchange) protocol.
KeyAgreement(KeyAgreementSpi, Provider, String) - Constructor for class javax.crypto.KeyAgreement
Creates a KeyAgreement object.
KeyAgreementSpi - Class in javax.crypto
This class defines the Service Provider Interface (SPI) for the KeyAgreement class.
KeyAgreementSpi() - Constructor for class javax.crypto.KeyAgreementSpi
KeyAlreadyExistsException - Exception in javax.management.openmbean
This runtime exception is thrown to indicate that the index of a row to be added to a tabular data instance is already used to refer to another row in this tabular data instance.
KeyAlreadyExistsException() - Constructor for exception javax.management.openmbean.KeyAlreadyExistsException
A KeyAlreadyExistsException with no detail message.
KeyAlreadyExistsException(String) - Constructor for exception javax.management.openmbean.KeyAlreadyExistsException
A KeyAlreadyExistsException with a detail message.
KeyBinding(KeyStroke, String) - Constructor for class javax.swing.text.JTextComponent.KeyBinding
Creates a new key binding.
KEYBOARD_DIVIDER_MOVE_OFFSET - Static variable in class javax.swing.plaf.basic.BasicSplitPaneUI
How far (relative) the divider does move when it is moved around by the cursor keys on the keyboard.
KeyboardDownRightHandler() - Constructor for class javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardDownRightHandler
keyboardDownRightListener - Variable in class javax.swing.plaf.basic.BasicSplitPaneUI
Deprecated.
As of Java 2 platform v1.3.
KeyboardEndHandler() - Constructor for class javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardEndHandler
keyboardEndListener - Variable in class javax.swing.plaf.basic.BasicSplitPaneUI
Deprecated.
As of Java 2 platform v1.3.
KeyboardFocusManager - Class in java.awt
The KeyboardFocusManager is responsible for managing the active and focused Windows, and the current focus owner.
KeyboardFocusManager() - Constructor for class java.awt.KeyboardFocusManager
Initializes a KeyboardFocusManager.
KeyboardHomeHandler() - Constructor for class javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardHomeHandler
keyboardHomeListener - Variable in class javax.swing.plaf.basic.BasicSplitPaneUI
Deprecated.
As of Java 2 platform v1.3.
KeyboardResizeToggleHandler() - Constructor for class javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardResizeToggleHandler
keyboardResizeToggleListener - Variable in class javax.swing.plaf.basic.BasicSplitPaneUI
Deprecated.
As of Java 2 platform v1.3.
KeyboardUpLeftHandler() - Constructor for class javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardUpLeftHandler
keyboardUpLeftListener - Variable in class javax.swing.plaf.basic.BasicSplitPaneUI
Deprecated.
As of Java 2 platform v1.3.
keyDown(Event, int) - Method in class java.awt.Component
Deprecated.
As of JDK version 1.1, replaced by processKeyEvent(KeyEvent).
keyEqualsCharSet() - Method in exception javax.swing.text.ChangedCharSetException
KeyEvent - Class in java.awt.event
An event which indicates that a keystroke occurred in a component.
KeyEvent(Component, int, long, int, int, char, int) - Constructor for class java.awt.event.KeyEvent
Constructs a KeyEvent object.
KeyEvent(Component, int, long, int, int, char) - Constructor for class java.awt.event.KeyEvent
Constructs a KeyEvent object.
KeyEvent(Component, int, long, int, int) - Constructor for class java.awt.event.KeyEvent
Deprecated.
as of JDK1.1
KeyEventDispatcher - Interface in java.awt
A KeyEventDispatcher cooperates with the current KeyboardFocusManager in the targeting and dispatching of all KeyEvents.
KeyEventPostProcessor - Interface in java.awt
A KeyEventPostProcessor cooperates with the current KeyboardFocusManager in the final resolution of all unconsumed KeyEvents.
KeyException - Exception in java.security
This is the basic key exception.
KeyException() - Constructor for exception java.security.KeyException
Constructs a KeyException with no detail message.
KeyException(String) - Constructor for exception java.security.KeyException
Constructs a KeyException with the specified detail message.
KeyException(String, Throwable) - Constructor for exception java.security.KeyException
Creates a KeyException with the specified detail message and cause.
KeyException(Throwable) - Constructor for exception java.security.KeyException
Creates a KeyException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
KeyFactory - Class in java.security
Key factories are used to convert keys (opaque cryptographic keys of type Key) into key specifications (transparent representations of the underlying key material), and vice versa.
KeyFactory(KeyFactorySpi, Provider, String) - Constructor for class java.security.KeyFactory
Creates a KeyFactory object.
KeyFactorySpi - Class in java.security
This class defines the Service Provider Interface (SPI) for the KeyFactory class.
KeyFactorySpi() - Constructor for class java.security.KeyFactorySpi
keyFor(Selector) - Method in class java.nio.channels.SelectableChannel
Retrieves the key representing the channel's registration with the given selector.
keyFor(Selector) - Method in class java.nio.channels.spi.AbstractSelectableChannel
KeyGenerator - Class in javax.crypto
This class provides the functionality of a secret (symmetric) key generator.
KeyGenerator(KeyGeneratorSpi, Provider, String) - Constructor for class javax.crypto.KeyGenerator
Creates a KeyGenerator object.
KeyGeneratorSpi - Class in javax.crypto
This class defines the Service Provider Interface (SPI) for the KeyGenerator class.
KeyGeneratorSpi() - Constructor for class javax.crypto.KeyGeneratorSpi
KeyHandler() - Constructor for class javax.swing.plaf.basic.BasicComboBoxUI.KeyHandler
KeyHandler() - Constructor for class javax.swing.plaf.basic.BasicTableUI.KeyHandler
KeyHandler() - Constructor for class javax.swing.plaf.basic.BasicTreeUI.KeyHandler
KeyInfo - Interface in javax.xml.crypto.dsig.keyinfo
A representation of the XML KeyInfo element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
KeyInfoFactory - Class in javax.xml.crypto.dsig.keyinfo
A factory for creating KeyInfo objects from scratch or for unmarshalling a KeyInfo object from a corresponding XML representation.
KeyInfoFactory() - Constructor for class javax.xml.crypto.dsig.keyinfo.KeyInfoFactory
Default constructor, for invocation by subclasses.
KeyListener - Interface in java.awt.event
The listener interface for receiving keyboard events (keystrokes).
keyListener - Variable in class javax.swing.plaf.basic.BasicComboBoxUI
This protected field is implementation specific.
keyListener - Variable in class javax.swing.plaf.basic.BasicComboPopup
This protected field is implementation specific.
keyListener - Variable in class javax.swing.plaf.basic.BasicTableUI
KeyManagementException - Exception in java.security
This is the general key management exception for all operations dealing with key management.
KeyManagementException() - Constructor for exception java.security.KeyManagementException
Constructs a KeyManagementException with no detail message.
KeyManagementException(String) - Constructor for exception java.security.KeyManagementException
Constructs a KeyManagementException with the specified detail message.
KeyManagementException(String, Throwable) - Constructor for exception java.security.KeyManagementException
Creates a KeyManagementException with the specified detail message and cause.
KeyManagementException(Throwable) - Constructor for exception java.security.KeyManagementException
Creates a KeyManagementException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
KeyManager - Interface in javax.net.ssl
This is the base interface for JSSE key managers.
KeyManagerFactory - Class in javax.net.ssl
This class acts as a factory for key managers based on a source of key material.
KeyManagerFactory(KeyManagerFactorySpi, Provider, String) - Constructor for class javax.net.ssl.KeyManagerFactory
Creates a KeyManagerFactory object.
KeyManagerFactorySpi - Class in javax.net.ssl
This class defines the Service Provider Interface (SPI) for the KeyManagerFactory class.
KeyManagerFactorySpi() - Constructor for class javax.net.ssl.KeyManagerFactorySpi
Keymap - Interface in javax.swing.text
A collection of bindings of KeyStrokes to actions.
KeyName - Interface in javax.xml.crypto.dsig.keyinfo
A representation of the XML KeyName element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
KeyPair - Class in java.security
This class is a simple holder for a key pair (a public key and a private key).
KeyPair(PublicKey, PrivateKey) - Constructor for class java.security.KeyPair
Constructs a key pair from the given public key and private key.
KeyPairGenerator - Class in java.security
The KeyPairGenerator class is used to generate pairs of public and private keys.
KeyPairGenerator(String) - Constructor for class java.security.KeyPairGenerator
Creates a KeyPairGenerator object for the specified algorithm.
KeyPairGeneratorSpi - Class in java.security
This class defines the Service Provider Interface (SPI) for the KeyPairGenerator class, which is used to generate pairs of public and private keys.
KeyPairGeneratorSpi() - Constructor for class java.security.KeyPairGeneratorSpi
keyPress(int) - Method in class java.awt.Robot
Presses a given key.
keyPressed(KeyEvent) - Method in class java.awt.AWTEventMulticaster
Handles the keyPressed event by invoking the keyPressed methods on listener-a and listener-b.
keyPressed(KeyEvent) - Method in class java.awt.event.KeyAdapter
Invoked when a key has been pressed.
keyPressed(KeyEvent) - Method in interface java.awt.event.KeyListener
Invoked when a key has been pressed.
keyPressed(KeyEvent) - Method in class javax.swing.plaf.basic.BasicComboBoxUI.KeyHandler
keyPressed(KeyEvent) - Method in class javax.swing.plaf.basic.BasicTableUI.KeyHandler
keyPressed(KeyEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.KeyHandler
keyRelease(int) - Method in class java.awt.Robot
Releases a given key.
keyReleased(KeyEvent) - Method in class java.awt.AWTEventMulticaster
Handles the keyReleased event by invoking the keyReleased methods on listener-a and listener-b.
keyReleased(KeyEvent) - Method in class java.awt.event.KeyAdapter
Invoked when a key has been released.
keyReleased(KeyEvent) - Method in interface java.awt.event.KeyListener
Invoked when a key has been released.
keyReleased(KeyEvent) - Method in class javax.swing.plaf.basic.BasicComboPopup.InvocationKeyHandler
keyReleased(KeyEvent) - Method in class javax.swing.plaf.basic.BasicTableUI.KeyHandler
keyReleased(KeyEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.KeyHandler
KeyRep - Class in java.security
Standardized representation for serialized Key objects.
KeyRep(KeyRep.Type, String, String, byte[]) - Constructor for class java.security.KeyRep
Construct the alternate Key class.
KeyRep.Type - Enum in java.security
Key type.
keys() - Method in class java.nio.channels.Selector
Returns this selector's key set.
keys() - Method in class java.security.Provider
keys() - Method in class java.util.concurrent.ConcurrentHashMap
Returns an enumeration of the keys in this table.
keys() - Method in class java.util.Dictionary
Returns an enumeration of the keys in this dictionary.
keys() - Method in class java.util.Hashtable
Returns an enumeration of the keys in this hashtable.
keys() - Method in class java.util.prefs.AbstractPreferences
Implements the keys method as per the specification in Preferences.keys().
keys() - Method in class java.util.prefs.Preferences
Returns all of the keys that have an associated value in this preference node.
keys() - Method in class javax.swing.ActionMap
Returns the Action names that are bound in this ActionMap.
keys() - Method in class javax.swing.InputMap
Returns the KeyStrokes that are bound in this InputMap.
keySelectionManager - Variable in class javax.swing.JComboBox
This protected field is implementation specific.
KeySelector - Class in javax.xml.crypto
A selector that finds and returns a key using the data contained in a KeyInfo object.
KeySelector() - Constructor for class javax.xml.crypto.KeySelector
Default no-args constructor; intended for invocation by subclasses only.
KeySelector.Purpose - Class in javax.xml.crypto
The purpose of the key that is to be selected.
KeySelectorException - Exception in javax.xml.crypto
Indicates an exceptional condition thrown by a KeySelector.
KeySelectorException() - Constructor for exception javax.xml.crypto.KeySelectorException
Constructs a new KeySelectorException with null as its detail message.
KeySelectorException(String) - Constructor for exception javax.xml.crypto.KeySelectorException
Constructs a new KeySelectorException with the specified detail message.
KeySelectorException(String, Throwable) - Constructor for exception javax.xml.crypto.KeySelectorException
Constructs a new KeySelectorException with the specified detail message and cause.
KeySelectorException(Throwable) - Constructor for exception javax.xml.crypto.KeySelectorException
Constructs a new KeySelectorException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
KeySelectorResult - Interface in javax.xml.crypto
The result returned by the KeySelector.select method.
keySet() - Method in class java.awt.RenderingHints
Returns a Set view of the Keys contained in this RenderingHints.
keySet() - Method in class java.security.Provider
Returns an unmodifiable Set view of the property keys contained in this provider.
keySet() - Method in class java.util.AbstractMap
Returns a Set view of the keys contained in this map.
keySet() - Method in class java.util.concurrent.ConcurrentHashMap
Returns a Set view of the keys contained in this map.
keySet(V) - Method in class java.util.concurrent.ConcurrentHashMap
Returns a Set view of the keys in this map, using the given common mapped value for any additions (i.e., Collection.add(E) and Collection.addAll(Collection)).
keySet() - Method in interface java.util.concurrent.ConcurrentNavigableMap
Returns a NavigableSet view of the keys contained in this map.
keySet() - Method in class java.util.concurrent.ConcurrentSkipListMap
Returns a NavigableSet view of the keys contained in this map.
keySet() - Method in class java.util.EnumMap
Returns a Set view of the keys contained in this map.
keySet() - Method in class java.util.HashMap
Returns a Set view of the keys contained in this map.
keySet() - Method in class java.util.Hashtable
Returns a Set view of the keys contained in this map.
keySet() - Method in class java.util.IdentityHashMap
Returns an identity-based set view of the keys contained in this map.
keySet() - Method in class java.util.jar.Attributes
Returns a Set view of the attribute names (keys) contained in this Map.
keySet() - Method in class java.util.LinkedHashMap
Returns a Set view of the keys contained in this map.
keySet() - Method in interface java.util.Map
Returns a Set view of the keys contained in this map.
keySet() - Method in class java.util.ResourceBundle
Returns a Set of all keys contained in this ResourceBundle and its parent bundles.
keySet() - Method in interface java.util.SortedMap
Returns a Set view of the keys contained in this map.
keySet() - Method in class java.util.TreeMap
Returns a Set view of the keys contained in this map.
keySet() - Method in class java.util.WeakHashMap
Returns a Set view of the keys contained in this map.
keySet() - Method in class javax.management.openmbean.CompositeType
Returns an unmodifiable Set view of all the item names defined by this CompositeType instance.
keySet() - Method in interface javax.management.openmbean.TabularData
Returns a set view of the keys (ie the index values) of the CompositeData values (ie the rows) contained in this TabularData instance.
keySet() - Method in class javax.management.openmbean.TabularDataSupport
Returns a set view of the keys contained in the underlying map of this TabularDataSupport instance used to index the rows.
keySet() - Method in class javax.script.SimpleBindings
Returns a Set view of the keys contained in this map.
KeySpec - Interface in java.security.spec
A (transparent) specification of the key material that constitutes a cryptographic key.
keysSpi() - Method in class java.util.prefs.AbstractPreferences
Returns all of the keys that have an associated value in this preference node.
KeyStore - Class in java.security
This class represents a storage facility for cryptographic keys and certificates.
KeyStore(KeyStoreSpi, Provider, String) - Constructor for class java.security.KeyStore
Creates a KeyStore object of the given type, and encapsulates the given provider implementation (SPI object) in it.
KeyStore.Builder - Class in java.security
A description of a to-be-instantiated KeyStore object.
KeyStore.CallbackHandlerProtection - Class in java.security
A ProtectionParameter encapsulating a CallbackHandler.
KeyStore.Entry - Interface in java.security
A marker interface for KeyStore entry types.
KeyStore.Entry.Attribute - Interface in java.security
An attribute associated with a keystore entry.
KeyStore.LoadStoreParameter - Interface in java.security
A marker interface for KeyStore load and store parameters.
KeyStore.PasswordProtection - Class in java.security
A password-based implementation of ProtectionParameter.
KeyStore.PrivateKeyEntry - Class in java.security
A KeyStore entry that holds a PrivateKey and corresponding certificate chain.
KeyStore.ProtectionParameter - Interface in java.security
A marker interface for keystore protection parameters.
KeyStore.SecretKeyEntry - Class in java.security
A KeyStore entry that holds a SecretKey.
KeyStore.TrustedCertificateEntry - Class in java.security
A KeyStore entry that holds a trusted Certificate.
KeyStoreBuilderParameters - Class in javax.net.ssl
A parameters object for X509KeyManagers that encapsulates a List of KeyStore.Builders.
KeyStoreBuilderParameters(KeyStore.Builder) - Constructor for class javax.net.ssl.KeyStoreBuilderParameters
Construct new KeyStoreBuilderParameters from the specified KeyStore.Builder.
KeyStoreBuilderParameters(List<KeyStore.Builder>) - Constructor for class javax.net.ssl.KeyStoreBuilderParameters
Construct new KeyStoreBuilderParameters from a List of KeyStore.Builders.
KeyStoreException - Exception in java.security
This is the generic KeyStore exception.
KeyStoreException() - Constructor for exception java.security.KeyStoreException
Constructs a KeyStoreException with no detail message.
KeyStoreException(String) - Constructor for exception java.security.KeyStoreException
Constructs a KeyStoreException with the specified detail message.
KeyStoreException(String, Throwable) - Constructor for exception java.security.KeyStoreException
Creates a KeyStoreException with the specified detail message and cause.
KeyStoreException(Throwable) - Constructor for exception java.security.KeyStoreException
Creates a KeyStoreException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
KeyStoreSpi - Class in java.security
This class defines the Service Provider Interface (SPI) for the KeyStore class.
KeyStoreSpi() - Constructor for class java.security.KeyStoreSpi
KeyStroke - Class in javax.swing
A KeyStroke represents a key action on the keyboard, or equivalent input device.
KeyTab - Class in javax.security.auth.kerberos
This class encapsulates a keytab file.
keyTyped(KeyEvent) - Method in class java.awt.AWTEventMulticaster
Handles the keyTyped event by invoking the keyTyped methods on listener-a and listener-b.
keyTyped(KeyEvent) - Method in class java.awt.event.KeyAdapter
Invoked when a key has been typed.
keyTyped(KeyEvent) - Method in interface java.awt.event.KeyListener
Invoked when a key has been typed.
keyTyped(KeyEvent) - Method in class javax.swing.plaf.basic.BasicTableUI.KeyHandler
keyTyped(KeyEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.KeyHandler
Invoked when a key has been typed.
keyUp(Event, int) - Method in class java.awt.Component
Deprecated.
As of JDK version 1.1, replaced by processKeyEvent(KeyEvent).
KeyValue - Interface in javax.xml.crypto.dsig.keyinfo
A representation of the XML KeyValue element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
KHAROSHTHI - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Kharoshthi" Unicode character block.
KHMER - Static variable in class java.awt.font.NumericShaper
Identifies the KHMER range and decimal base.
KHMER - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Khmer" Unicode character block.
KHMER_SYMBOLS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Khmer Symbols" Unicode character block.
kind() - Method in interface java.nio.file.WatchEvent
Returns the event kind.
kind - Variable in class javax.tools.SimpleJavaFileObject
The kind of this file object.
kind() - Method in class org.omg.CORBA.TypeCode
Retrieves the kind of this TypeCode object.
kind - Variable in class org.omg.CosNaming.NameComponent
KOREA - Static variable in class java.util.Locale
Useful constant for country.
KOREAN - Static variable in class java.util.Locale
Useful constant for language.
KRB_NT_PRINCIPAL - Static variable in class javax.security.auth.kerberos.KerberosPrincipal
user principal name type.
KRB_NT_SRV_HST - Static variable in class javax.security.auth.kerberos.KerberosPrincipal
service with host name as instance (telnet, rcommands) name type.
KRB_NT_SRV_INST - Static variable in class javax.security.auth.kerberos.KerberosPrincipal
service and other unique instance (krbtgt) name type.
KRB_NT_SRV_XHST - Static variable in class javax.security.auth.kerberos.KerberosPrincipal
service with host as remaining components name type.
KRB_NT_UID - Static variable in class javax.security.auth.kerberos.KerberosPrincipal
unique ID name type.
KRB_NT_UNKNOWN - Static variable in class javax.security.auth.kerberos.KerberosPrincipal
unknown name type.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames


L-Index (Java Platform SE 8 )

Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames
  • All Classes
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

L

Label - Class in java.awt
A Label object is a component for placing text in a container.
Label() - Constructor for class java.awt.Label
Constructs an empty label.
Label(String) - Constructor for class java.awt.Label
Constructs a new label with the specified string of text, left justified.
Label(String, int) - Constructor for class java.awt.Label
Constructs a new label that presents the specified string of text with the specified alignment.
LABEL - Static variable in class javax.accessibility.AccessibleRole
An object used to present an icon or short string in an interface.
LABEL - Static variable in class javax.swing.plaf.synth.Region
Label region.
label - Variable in class org.omg.CORBA.UnionMember
The label of the union member described by this UnionMember object.
Label.AccessibleAWTLabel - Class in java.awt
This class implements accessibility support for the Label class.
LABEL_FOR - Static variable in class javax.accessibility.AccessibleRelation
Indicates an object is a label for one or more target objects.
LABEL_FOR_PROPERTY - Static variable in class javax.accessibility.AccessibleRelation
Identifies that the target group for a label has changed
LABELED_BY - Static variable in class javax.accessibility.AccessibleRelation
Indicates an object is labeled by one or more target objects.
LABELED_BY_PROPERTY - Static variable in class javax.accessibility.AccessibleRelation
Identifies that the objects that are doing the labeling have changed
labelFor - Variable in class javax.swing.JLabel
labelRect - Variable in class javax.swing.plaf.basic.BasicSliderUI
labelsHaveSameBaselines() - Method in class javax.swing.plaf.basic.BasicSliderUI
Returns true if all the labels from the label table have the same baseline.
labelUI - Static variable in class javax.swing.plaf.basic.BasicLabelUI
The default BasicLabelUI instance.
LabelUI - Class in javax.swing.plaf
Pluggable look and feel interface for JLabel.
LabelUI() - Constructor for class javax.swing.plaf.LabelUI
LabelView - Class in javax.swing.text
A LabelView is a styled chunk of text that represents a view mapped over an element in the text model.
LabelView(Element) - Constructor for class javax.swing.text.LabelView
Constructs a new view wrapped on an element.
LambdaConversionException - Exception in java.lang.invoke
LambdaConversionException
LambdaConversionException() - Constructor for exception java.lang.invoke.LambdaConversionException
Constructs a LambdaConversionException.
LambdaConversionException(String) - Constructor for exception java.lang.invoke.LambdaConversionException
Constructs a LambdaConversionException with a message.
LambdaConversionException(String, Throwable) - Constructor for exception java.lang.invoke.LambdaConversionException
Constructs a LambdaConversionException with a message and cause.
LambdaConversionException(Throwable) - Constructor for exception java.lang.invoke.LambdaConversionException
Constructs a LambdaConversionException with a cause.
LambdaConversionException(String, Throwable, boolean, boolean) - Constructor for exception java.lang.invoke.LambdaConversionException
Constructs a LambdaConversionException with a message, cause, and other settings.
LambdaMetafactory - Class in java.lang.invoke
Methods to facilitate the creation of simple "function objects" that implement one or more interfaces by delegation to a provided MethodHandle, possibly after type adaptation and partial evaluation of arguments.
LambdaMetafactory() - Constructor for class java.lang.invoke.LambdaMetafactory
LANDSCAPE - Static variable in class java.awt.PageAttributes.OrientationRequestedType
The OrientationRequestedType instance to use for specifying a landscape orientation.
LANDSCAPE - Static variable in class java.awt.print.PageFormat
The origin is at the bottom left of the paper with x running bottom to top and y running left to right.
LANDSCAPE - Static variable in class javax.print.attribute.standard.OrientationRequested
The content will be imaged across the long edge of the medium.
LANG - Static variable in class javax.swing.text.html.HTML.Attribute
LANGUAGE - Static variable in class java.text.AttributedCharacterIterator.Attribute
Attribute key for the language of some text.
LANGUAGE - Static variable in interface javax.naming.Context
Constant that holds the name of the environment property for specifying the preferred language to use with the service.
LANGUAGE - Static variable in interface javax.script.ScriptEngine
Reserved key for a named value that is the full name of Scripting Language supported by the implementation.
LANGUAGE - Static variable in class javax.swing.text.html.HTML.Attribute
LANGUAGE_VERSION - Static variable in interface javax.script.ScriptEngine
Reserved key for the named value that identifies the version of the scripting language supported by the implementation.
LanguageCallback - Class in javax.security.auth.callback
Underlying security services instantiate and pass a LanguageCallback to the handle method of a CallbackHandler to retrieve the Locale used for localizing text.
LanguageCallback() - Constructor for class javax.security.auth.callback.LanguageCallback
Construct a LanguageCallback.
LanguageRange(String) - Constructor for class java.util.Locale.LanguageRange
Constructs a LanguageRange using the given range.
LanguageRange(String, double) - Constructor for class java.util.Locale.LanguageRange
Constructs a LanguageRange using the given range and weight.
LAO - Static variable in class java.awt.font.NumericShaper
Identifies the LAO range and decimal base.
LAO - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Lao" Unicode character block.
LARGE_CAPACITY - Static variable in class javax.print.attribute.standard.MediaTray
The large capacity input tray in the printer.
LARGE_ICON_KEY - Static variable in interface javax.swing.Action
The key used for storing an Icon.
LARGE_KEY - Static variable in class javax.swing.plaf.nimbus.NimbusStyle
LARGE_MODEL_PROPERTY - Static variable in class javax.swing.JTree
Bound property name for largeModel.
LARGE_SCALE - Static variable in class javax.swing.plaf.nimbus.NimbusStyle
largeModel - Variable in class javax.swing.JTree
Is this tree a large model? This is a code-optimization setting.
largeModel - Variable in class javax.swing.plaf.basic.BasicTreeUI
True if doing optimizations for a largeModel.
last(Container) - Method in class java.awt.CardLayout
Flips to the last card of the container.
last() - Method in interface java.sql.ResultSet
Moves the cursor to the last row in this ResultSet object.
last() - Method in class java.text.BreakIterator
Returns the last boundary.
last() - Method in interface java.text.CharacterIterator
Sets the position to getEndIndex()-1 (getEndIndex() if the text is empty) and returns the character at that position.
last() - Method in class java.text.StringCharacterIterator
Implements CharacterIterator.last() for String.
last() - Method in class java.util.concurrent.ConcurrentSkipListSet
last() - Method in interface java.util.SortedSet
Returns the last (highest) element currently in this set.
last() - Method in class java.util.TreeSet
last() - Method in class javax.swing.text.Segment
Sets the position to getEndIndex()-1 (getEndIndex() if the text is empty) and returns the character at that position.
LAST_DIVIDER_LOCATION_PROPERTY - Static variable in class javax.swing.JSplitPane
Bound property for lastLocation.
LAST_LINE_END - Static variable in class java.awt.GridBagConstraints
Place the component in the corner of its display area where the last line of text on a page would normally end for the current ComponentOrientation.
LAST_LINE_START - Static variable in class java.awt.GridBagConstraints
Place the component in the corner of its display area where the last line of text on a page would normally start for the current ComponentOrientation.
lastAccessTime() - Method in interface java.nio.file.attribute.BasicFileAttributes
Returns the time of last access.
lastAlloc - Variable in class javax.swing.text.AsyncBoxView.ChildLocator
The last seen allocation (for repainting when changes are flushed upward).
lastColumn - Variable in class javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange
lastDayOfMonth() - Static method in class java.time.temporal.TemporalAdjusters
Returns the "last day of month" adjuster, which returns a new date set to the last day of the current month.
lastDayOfYear() - Static method in class java.time.temporal.TemporalAdjusters
Returns the "last day of year" adjuster, which returns a new date set to the last day of the current year.
lastDividerLocation - Variable in class javax.swing.JSplitPane
Previous location of the split pane.
lastEdit() - Method in class javax.swing.undo.CompoundEdit
Returns the last UndoableEdit in edits, or null if edits is empty.
lastElement() - Method in class java.util.Vector
Returns the last component of the vector.
lastElement() - Method in class javax.swing.DefaultListModel
Returns the last component of the list.
lastEntry() - Method in class java.util.concurrent.ConcurrentSkipListMap
Returns a key-value mapping associated with the greatest key in this map, or null if the map is empty.
lastEntry() - Method in interface java.util.NavigableMap
Returns a key-value mapping associated with the greatest key in this map, or null if the map is empty.
lastEntry() - Method in class java.util.TreeMap
lastIndexOf(int) - Method in class java.lang.String
Returns the index within this string of the last occurrence of the specified character.
lastIndexOf(int, int) - Method in class java.lang.String
Returns the index within this string of the last occurrence of the specified character, searching backward starting at the specified index.
lastIndexOf(String) - Method in class java.lang.String
Returns the index within this string of the last occurrence of the specified substring.
lastIndexOf(String, int) - Method in class java.lang.String
Returns the index within this string of the last occurrence of the specified substring, searching backward starting at the specified index.
lastIndexOf(String) - Method in class java.lang.StringBuffer
lastIndexOf(String, int) - Method in class java.lang.StringBuffer
lastIndexOf(String) - Method in class java.lang.StringBuilder
lastIndexOf(String, int) - Method in class java.lang.StringBuilder
lastIndexOf(Object) - Method in class java.util.AbstractList
Returns the index of the last occurrence of the specified element in this list, or -1 if this list does not contain the element.
lastIndexOf(Object) - Method in class java.util.ArrayList
Returns the index of the last occurrence of the specified element in this list, or -1 if this list does not contain the element.
lastIndexOf(Object) - Method in class java.util.concurrent.CopyOnWriteArrayList
Returns the index of the last occurrence of the specified element in this list, or -1 if this list does not contain the element.
lastIndexOf(E, int) - Method in class java.util.concurrent.CopyOnWriteArrayList
Returns the index of the last occurrence of the specified element in this list, searching backwards from index, or returns -1 if the element is not found.
lastIndexOf(Object) - Method in class java.util.LinkedList
Returns the index of the last occurrence of the specified element in this list, or -1 if this list does not contain the element.
lastIndexOf(Object) - Method in interface java.util.List
Returns the index of the last occurrence of the specified element in this list, or -1 if this list does not contain the element.
lastIndexOf(Object) - Method in class java.util.Vector
Returns the index of the last occurrence of the specified element in this vector, or -1 if this vector does not contain the element.
lastIndexOf(Object, int) - Method in class java.util.Vector
Returns the index of the last occurrence of the specified element in this vector, searching backwards from index, or returns -1 if the element is not found.
lastIndexOf(Object) - Method in class javax.swing.DefaultListModel
Returns the index of the last occurrence of elem.
lastIndexOf(Object, int) - Method in class javax.swing.DefaultListModel
Searches backwards for elem, starting from the specified index, and returns an index to it.
lastIndexOfSubList(List<?>, List<?>) - Static method in class java.util.Collections
Returns the starting position of the last occurrence of the specified target list within the specified source list, or -1 if there is no such occurrence.
lastInMonth(DayOfWeek) - Static method in class java.time.temporal.TemporalAdjusters
Returns the last in month adjuster, which returns a new date in the same month with the last matching day-of-week.
lastKey() - Method in class java.util.concurrent.ConcurrentSkipListMap
lastKey() - Method in interface java.util.SortedMap
Returns the last (highest) key currently in this map.
lastKey() - Method in class java.util.TreeMap
lastModified() - Method in class java.io.File
Returns the time that the file denoted by this abstract pathname was last modified.
lastModifiedTime() - Method in interface java.nio.file.attribute.BasicFileAttributes
Returns the time of last modification.
LastOwnerException - Exception in java.security.acl
This is an exception that is thrown whenever an attempt is made to delete the last owner of an Access Control List.
LastOwnerException() - Constructor for exception java.security.acl.LastOwnerException
Constructs a LastOwnerException.
lastPageFirst() - Method in class java.awt.PrintJob
Returns true if the last page will be printed first.
lastPaintPosition - Variable in class javax.swing.JViewport
The last viewPosition that we've painted, so we know how much of the backing store image is valid.
lastPath - Variable in class javax.swing.tree.DefaultTreeCellEditor
Last path that was selected.
lastRow - Variable in class javax.swing.event.TableModelEvent
lastRow - Variable in class javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange
lastRow - Variable in class javax.swing.tree.DefaultTreeCellEditor
Row that was last passed into getTreeCellEditorComponent.
lastSelectedRow - Variable in class javax.swing.plaf.basic.BasicTreeUI
Index of the row that was last selected.
lastTabInRun(int, int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
lastValidOffset - Variable in class javax.swing.text.AsyncBoxView.ChildLocator
The location of the last offset calculation that is valid.
LATEST - Static variable in interface java.util.jar.Pack200.Packer
The string "latest", a possible value for certain properties.
latest() - Static method in enum javax.lang.model.SourceVersion
Returns the latest source version that can be modeled.
latestSupported() - Static method in enum javax.lang.model.SourceVersion
Returns the latest source version fully supported by the current execution environment.
LATIN - Static variable in class java.awt.im.InputSubset
Constant for all Latin characters, including the characters in the BASIC_LATIN, LATIN_1_SUPPLEMENT, LATIN_EXTENDED_A, LATIN_EXTENDED_B Unicode character blocks.
LATIN_1_SUPPLEMENT - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Latin-1 Supplement" Unicode character block.
LATIN_DIGITS - Static variable in class java.awt.im.InputSubset
Constant for the digits included in the BASIC_LATIN Unicode character block.
LATIN_EXTENDED_A - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Latin Extended-A" Unicode character block.
LATIN_EXTENDED_ADDITIONAL - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Latin Extended Additional" Unicode character block.
LATIN_EXTENDED_B - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Latin Extended-B" Unicode character block.
LATIN_EXTENDED_C - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Latin Extended-C" Unicode character block.
LATIN_EXTENDED_D - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Latin Extended-D" Unicode character block.
LAYER_PROPERTY - Static variable in class javax.swing.JLayeredPane
Bound property
LAYERED_PANE - Static variable in class javax.accessibility.AccessibleRole
A specialized pane that allows its children to be drawn in layers, providing a form of stacking order.
LAYERED_PANE_PROPERTY - Static variable in class javax.swing.JInternalFrame
Bound property name.
LayeredHighlighter - Class in javax.swing.text
LayeredHighlighter() - Constructor for class javax.swing.text.LayeredHighlighter
LayeredHighlighter.LayerPainter - Class in javax.swing.text
Layered highlight renderer.
layeredPane - Variable in class javax.swing.JRootPane
The layered pane that manages the menu bar and content pane.
LayerPainter() - Constructor for class javax.swing.text.LayeredHighlighter.LayerPainter
LayerUI<V extends Component> - Class in javax.swing.plaf
The base class for all JLayer's UI delegates.
LayerUI() - Constructor for class javax.swing.plaf.LayerUI
layout() - Method in class java.awt.Component
Deprecated.
As of JDK version 1.1, replaced by doLayout().
layout() - Method in class java.awt.Container
Deprecated.
As of JDK version 1.1, replaced by doLayout().
layout() - Method in class java.awt.ScrollPane
Deprecated.
As of JDK version 1.1, replaced by doLayout().
layout() - Method in class javax.swing.plaf.synth.SynthSliderUI
Lays out the slider.
layout(int, int) - Method in class javax.swing.text.BoxView
Perform layout on the box
layout(FlowView) - Method in class javax.swing.text.FlowView.FlowStrategy
Update the flow on the given FlowView.
layout(int, int) - Method in class javax.swing.text.FlowView
Lays out the children.
LAYOUT_LEFT_TO_RIGHT - Static variable in class java.awt.Font
A flag to layoutGlyphVector indicating that text is left-to-right as determined by Bidi analysis.
LAYOUT_NO_LIMIT_CONTEXT - Static variable in class java.awt.Font
A flag to layoutGlyphVector indicating that text in the char array after the indicated limit should not be examined.
LAYOUT_NO_START_CONTEXT - Static variable in class java.awt.Font
A flag to layoutGlyphVector indicating that text in the char array before the indicated start should not be examined.
LAYOUT_RIGHT_TO_LEFT - Static variable in class java.awt.Font
A flag to layoutGlyphVector indicating that text is right-to-left as determined by Bidi analysis.
layoutChanged(int) - Method in class javax.swing.text.BoxView
Invalidates the layout along an axis.
layoutCL(JLabel, FontMetrics, String, Icon, Rectangle, Rectangle, Rectangle) - Method in class javax.swing.plaf.basic.BasicLabelUI
Forwards the call to SwingUtilities.layoutCompoundLabel().
layoutColumns(int, int[], int[], SizeRequirements[]) - Method in class javax.swing.text.TableView
Lays out the columns to fit within the given target span.
layoutComboBox(Container, MetalComboBoxUI.MetalComboBoxLayoutManager) - Method in class javax.swing.plaf.metal.MetalComboBoxUI
layoutCompoundLabel(JComponent, FontMetrics, String, Icon, int, int, int, int, Rectangle, Rectangle, Rectangle, int) - Static method in class javax.swing.SwingUtilities
Compute and return the location of the icons origin, the location of origin of the text baseline, and a possibly clipped version of the compound labels string.
layoutCompoundLabel(FontMetrics, String, Icon, int, int, int, int, Rectangle, Rectangle, Rectangle, int) - Static method in class javax.swing.SwingUtilities
Compute and return the location of the icons origin, the location of origin of the text baseline, and a possibly clipped version of the compound labels string.
layoutContainer(Container) - Method in class java.awt.BorderLayout
Lays out the container argument using this border layout.
layoutContainer(Container) - Method in class java.awt.CardLayout
Lays out the specified container using this card layout.
layoutContainer(Container) - Method in class java.awt.FlowLayout
Lays out the container.
layoutContainer(Container) - Method in class java.awt.GridBagLayout
Lays out the specified container using this grid bag layout.
layoutContainer(Container) - Method in class java.awt.GridLayout
Lays out the specified container using this layout.
layoutContainer(Container) - Method in interface java.awt.LayoutManager
Lays out the specified container.
layoutContainer(Container) - Method in class javax.swing.BoxLayout
Called by the AWT when the specified container needs to be laid out.
layoutContainer(Container) - Method in class javax.swing.GroupLayout
Lays out the specified container.
layoutContainer(Container) - Method in class javax.swing.JRootPane.RootLayout
Instructs the layout manager to perform the layout for the specified container.
layoutContainer(Container) - Method in class javax.swing.JSpinner.DefaultEditor
Resize the one (and only) child to completely fill the area within the parents insets.
layoutContainer(Container) - Method in class javax.swing.OverlayLayout
Called by the AWT when the specified container needs to be laid out.
layoutContainer(Container) - Method in class javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager
layoutContainer(Container) - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane.TitlePaneLayout
layoutContainer(Container) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.InternalFrameLayout
layoutContainer(Container) - Method in class javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout
layoutContainer(Container) - Method in class javax.swing.plaf.basic.BasicScrollBarUI
layoutContainer(Container) - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider.DividerLayout
layoutContainer(Container) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager
Does the actual layout.
layoutContainer(Container) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout
layoutContainer(Container) - Method in class javax.swing.plaf.metal.MetalComboBoxUI.MetalComboBoxLayoutManager
layoutContainer(Container) - Method in class javax.swing.ScrollPaneLayout
Lays out the scrollpane.
layoutContainer(Container) - Method in class javax.swing.SpringLayout
layoutContainer(Container) - Method in class javax.swing.ViewportLayout
Called by the AWT when the specified container needs to be laid out.
LayoutFocusTraversalPolicy - Class in javax.swing
A SortingFocusTraversalPolicy which sorts Components based on their size, position, and orientation.
LayoutFocusTraversalPolicy() - Constructor for class javax.swing.LayoutFocusTraversalPolicy
Constructs a LayoutFocusTraversalPolicy.
layoutGlyphVector(FontRenderContext, char[], int, int, int) - Method in class java.awt.Font
Returns a new GlyphVector object, performing full layout of the text if possible.
layoutHScrollbar(JScrollBar) - Method in class javax.swing.plaf.basic.BasicScrollBarUI
layoutInfo - Variable in class java.awt.GridBagLayout
This field holds the layout information for the gridbag.
layoutLabel(int, FontMetrics, int, String, Icon, Rectangle, Rectangle, Rectangle, boolean) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
layoutMajorAxis(int, int, int[], int[]) - Method in class javax.swing.text.BoxView
Performs layout for the major axis of the box (i.e.
layoutMajorAxis(int, int, int[], int[]) - Method in class javax.swing.text.TableView.TableRow
Perform layout for the major axis of the box (i.e.
LayoutManager - Interface in java.awt
Defines the interface for classes that know how to lay out Containers.
layoutManager - Variable in class javax.swing.plaf.basic.BasicSplitPaneUI
LayoutManager that is created and placed into the split pane.
LayoutManager2 - Interface in java.awt
Defines an interface for classes that know how to layout Containers based on a layout constraints object.
layoutMinorAxis(int, int, int[], int[]) - Method in class javax.swing.text.BoxView
Performs layout for the minor axis of the box (i.e.
layoutMinorAxis(int, int, int[], int[]) - Method in class javax.swing.text.html.BlockView
Performs layout for the minor axis of the box (i.e.
layoutMinorAxis(int, int, int[], int[]) - Method in class javax.swing.text.TableView
Perform layout for the minor axis of the box (i.e.
layoutMinorAxis(int, int, int[], int[]) - Method in class javax.swing.text.TableView.TableRow
Perform layout for the minor axis of the box (i.e.
LayoutPath - Class in java.awt.font
LayoutPath provides a mapping between locations relative to the baseline and points in user space.
LayoutPath() - Constructor for class java.awt.font.LayoutPath
layoutPool - Variable in class javax.swing.text.FlowView
These are the views that represent the child elements of the element this view represents (The logical view to translate to a physical view).
LayoutQueue - Class in javax.swing.text
A queue of text layout tasks.
LayoutQueue() - Constructor for class javax.swing.text.LayoutQueue
Construct a layout queue.
layoutRow(FlowView, int, int) - Method in class javax.swing.text.FlowView.FlowStrategy
Creates a row of views that will fit within the layout span of the row.
layoutSpan - Variable in class javax.swing.text.FlowView
Default constraint against which the flow is created against.
LayoutStyle - Class in javax.swing
LayoutStyle provides information about how to position components.
LayoutStyle() - Constructor for class javax.swing.LayoutStyle
Creates a new LayoutStyle.
LayoutStyle.ComponentPlacement - Enum in javax.swing
ComponentPlacement is an enumeration of the possible ways two components can be placed relative to each other.
layoutText(SynthContext, FontMetrics, String, Icon, int, int, int, int, Rectangle, Rectangle, Rectangle, int) - Method in class javax.swing.plaf.synth.SynthGraphicsUtils
Lays out text and an icon returning, by reference, the location to place the icon and text.
layoutVScrollbar(JScrollBar) - Method in class javax.swing.plaf.basic.BasicScrollBarUI
lazilyLoadDesktopProperty(String) - Method in class java.awt.Toolkit
an opportunity to lazily evaluate desktop property values.
LazyInputMap(Object[]) - Constructor for class javax.swing.UIDefaults.LazyInputMap
lazySet(boolean) - Method in class java.util.concurrent.atomic.AtomicBoolean
Eventually sets to the given value.
lazySet(int) - Method in class java.util.concurrent.atomic.AtomicInteger
Eventually sets to the given value.
lazySet(int, int) - Method in class java.util.concurrent.atomic.AtomicIntegerArray
Eventually sets the element at position i to the given value.
lazySet(T, int) - Method in class java.util.concurrent.atomic.AtomicIntegerFieldUpdater
Eventually sets the field of the given object managed by this updater to the given updated value.
lazySet(long) - Method in class java.util.concurrent.atomic.AtomicLong
Eventually sets to the given value.
lazySet(int, long) - Method in class java.util.concurrent.atomic.AtomicLongArray
Eventually sets the element at position i to the given value.
lazySet(T, long) - Method in class java.util.concurrent.atomic.AtomicLongFieldUpdater
Eventually sets the field of the given object managed by this updater to the given updated value.
lazySet(V) - Method in class java.util.concurrent.atomic.AtomicReference
Eventually sets to the given value.
lazySet(int, E) - Method in class java.util.concurrent.atomic.AtomicReferenceArray
Eventually sets the element at position i to the given value.
lazySet(T, V) - Method in class java.util.concurrent.atomic.AtomicReferenceFieldUpdater
Eventually sets the field of the given object managed by this updater to the given updated value.
LDAPCertStoreParameters - Class in java.security.cert
Parameters used as input for the LDAP CertStore algorithm.
LDAPCertStoreParameters(String, int) - Constructor for class java.security.cert.LDAPCertStoreParameters
Creates an instance of LDAPCertStoreParameters with the specified parameter values.
LDAPCertStoreParameters(String) - Constructor for class java.security.cert.LDAPCertStoreParameters
Creates an instance of LDAPCertStoreParameters with the specified server name and a default port of 389.
LDAPCertStoreParameters() - Constructor for class java.security.cert.LDAPCertStoreParameters
Creates an instance of LDAPCertStoreParameters with the default parameter values (server name "localhost", port 389).
LdapContext - Interface in javax.naming.ldap
This interface represents a context in which you can perform operations with LDAPv3-style controls and perform LDAPv3-style extended operations.
LdapName - Class in javax.naming.ldap
This class represents a distinguished name as specified by RFC 2253.
LdapName(String) - Constructor for class javax.naming.ldap.LdapName
Constructs an LDAP name from the given distinguished name.
LdapName(List<Rdn>) - Constructor for class javax.naming.ldap.LdapName
Constructs an LDAP name given its parsed RDN components.
LdapReferralException - Exception in javax.naming.ldap
This abstract class is used to represent an LDAP referral exception.
LdapReferralException(String) - Constructor for exception javax.naming.ldap.LdapReferralException
Constructs a new instance of LdapReferralException using the explanation supplied.
LdapReferralException() - Constructor for exception javax.naming.ldap.LdapReferralException
Constructs a new instance of LdapReferralException.
LE - Static variable in class javax.management.Query
A code representing the Query.leq(javax.management.ValueExp, javax.management.ValueExp) query.
LEAD_DOTS - Static variable in class javax.swing.text.TabStop
LEAD_EQUALS - Static variable in class javax.swing.text.TabStop
LEAD_HYPHENS - Static variable in class javax.swing.text.TabStop
LEAD_NONE - Static variable in class javax.swing.text.TabStop
LEAD_SELECTION_PATH_PROPERTY - Static variable in class javax.swing.JTree
Bound property name for leadSelectionPath.
LEAD_THICKLINE - Static variable in class javax.swing.text.TabStop
LEAD_UNDERLINE - Static variable in class javax.swing.text.TabStop
leadAnchorNotificationEnabled - Variable in class javax.swing.DefaultListSelectionModel
leadIndex - Variable in class javax.swing.tree.DefaultTreeSelectionModel
Index of the lead path in selection.
LEADING - Static variable in class java.awt.FlowLayout
This value indicates that each row of components should be justified to the leading edge of the container's orientation, for example, to the left in left-to-right orientations.
leading(int) - Static method in class java.awt.font.TextHitInfo
Creates a TextHitInfo on the leading edge of the character at the specified charIndex.
LEADING - Static variable in class javax.swing.border.TitledBorder
Position title text at the left side of the border line for left to right orientation, at the right side of the border line for right to left orientation.
LEADING - Static variable in interface javax.swing.SwingConstants
Identifies the leading edge of text for use with left-to-right and right-to-left languages.
leadPath - Variable in class javax.swing.tree.DefaultTreeSelectionModel
Last path that was added.
leadRow - Variable in class javax.swing.tree.DefaultTreeSelectionModel
Lead row.
LeafElement(Element, AttributeSet, int, int) - Constructor for class javax.swing.text.AbstractDocument.LeafElement
Constructs an element that represents content within the document (has no children).
leafIcon - Variable in class javax.swing.tree.DefaultTreeCellRenderer
Icon used to show leaf nodes.
Lease - Class in java.rmi.dgc
A lease contains a unique VM identifier and a lease duration.
Lease(VMID, long) - Constructor for class java.rmi.dgc.Lease
Constructs a lease with a specific VMID and lease duration.
leave(InetAddress) - Method in class java.net.DatagramSocketImpl
Leave the multicast group.
leaveGroup(SocketAddress, NetworkInterface) - Method in class java.net.DatagramSocketImpl
Leave the multicast group.
leaveGroup(InetAddress) - Method in class java.net.MulticastSocket
Leave a multicast group.
leaveGroup(SocketAddress, NetworkInterface) - Method in class java.net.MulticastSocket
Leave a multicast group on a specified local interface.
LEDGER - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for Ledger, 11 x 17 in.
LEDGER - Static variable in class javax.print.attribute.standard.MediaSize.Other
Specifies the ledger size, 11 inches by 17 inches.
LEDGER - Static variable in class javax.print.attribute.standard.MediaSizeName
ledger size .
LEFT - Static variable in class java.awt.Event
The Left Arrow key, a non-ASCII action key.
LEFT - Static variable in class java.awt.FlowLayout
This value indicates that each row of components should be left-justified.
left - Variable in class java.awt.Insets
The inset from the left.
LEFT - Static variable in class java.awt.Label
Indicates that the label should be left justified.
left - Variable in class javax.swing.border.EmptyBorder
LEFT - Static variable in class javax.swing.border.TitledBorder
Position title text at the left side of the border line.
LEFT - Static variable in class javax.swing.JSplitPane
Used to add a Component to the left of the other Component.
LEFT - Static variable in interface javax.swing.SwingConstants
Box-orientation constant used to specify the left side of a box.
LEFT_ALIGNMENT - Static variable in class java.awt.Component
Ease-of-use constant for getAlignmentX.
LEFT_JUSTIFY - Static variable in class java.util.FormattableFlags
Left-justifies the output.
LEFT_OUTER_JOIN - Static variable in interface javax.sql.rowset.JoinRowSet
An ANSI-style JOIN providing a left outer join between two tables.
LEFT_TO_RIGHT - Static variable in class java.awt.ComponentOrientation
Items run left to right and lines flow top to bottom Examples: English, French.
leftButton - Variable in class javax.swing.plaf.basic.BasicSplitPaneDivider
Button for quickly toggling the left component.
leftChildIndent - Variable in class javax.swing.plaf.basic.BasicTreeUI
Distance between left margin and where vertical dashes will be drawn.
leftComponent - Variable in class javax.swing.JSplitPane
The left or top component.
LeftIndent - Static variable in class javax.swing.text.StyleConstants
The amount to indent the left side of the paragraph.
leftKey - Variable in class javax.swing.plaf.basic.BasicSplitPaneUI
Deprecated.
As of Java 2 platform v1.3.
leftKey - Variable in class javax.swing.plaf.basic.BasicTabbedPaneUI
Deprecated.
As of Java 2 platform v1.3.
leftKey - Variable in class javax.swing.plaf.basic.BasicToolBarUI
Deprecated.
As of Java 2 platform v1.3.
leftToRightCache - Variable in class javax.swing.plaf.basic.BasicSliderUI
LEGAL - Static variable in class java.awt.PageAttributes.MediaType
An alias for NA_LEGAL.
LEGAL - Static variable in class javax.print.attribute.standard.MediaSize.NA
Specifies the North American legal size, 8.5 inches by 14 inches.
LEGAL_VALUES_FIELD - Static variable in class javax.management.JMX
The name of the legalValues field.
len - Variable in class java.util.zip.InflaterInputStream
Length of input buffer.
length() - Method in class java.io.File
Returns the length of the file denoted by this abstract pathname.
length - Variable in exception java.io.OptionalDataException
The number of bytes of primitive data available to be read in the current buffer.
length() - Method in class java.io.RandomAccessFile
Returns the length of this file.
length() - Method in interface java.lang.CharSequence
Returns the length of this character sequence.
length() - Method in class java.lang.String
Returns the length of this string.
length() - Method in class java.lang.StringBuffer
length() - Method in class java.nio.CharBuffer
Returns the length of this character buffer.
length() - Method in class java.nio.charset.CoderResult
Returns the length of the erroneous input described by this object (optional operation).
length() - Method in interface java.sql.Blob
Returns the number of bytes in the BLOB value designated by this Blob object.
length() - Method in interface java.sql.Clob
Retrieves the number of characters in the CLOB value designated by this Clob object.
length(boolean) - Method in enum java.time.Month
Gets the length of this month in days.
length() - Method in class java.time.Year
Gets the length of this year in days.
length() - Method in class java.util.BitSet
Returns the "logical size" of this BitSet: the index of the highest set bit in the BitSet plus one.
length() - Method in class java.util.concurrent.atomic.AtomicIntegerArray
Returns the length of the array.
length() - Method in class java.util.concurrent.atomic.AtomicLongArray
Returns the length of the array.
length() - Method in class java.util.concurrent.atomic.AtomicReferenceArray
Returns the length of the array.
length() - Method in class java.util.StringJoiner
Returns the length of the String representation of this StringJoiner.
length() - Method in class javax.imageio.stream.FileCacheImageOutputStream
length() - Method in class javax.imageio.stream.FileImageInputStream
Returns the length of the underlying file, or -1 if it is unknown.
length() - Method in class javax.imageio.stream.FileImageOutputStream
length() - Method in interface javax.imageio.stream.ImageInputStream
Returns the total length of the stream, if known.
length() - Method in class javax.imageio.stream.ImageInputStreamImpl
Returns -1L to indicate that the stream has unknown length.
length() - Method in class javax.imageio.stream.MemoryCacheImageOutputStream
length - Variable in class javax.sound.midi.MidiMessage
The number of bytes in the MIDI message, including the status byte and any data bytes.
length() - Method in class javax.sql.rowset.serial.SerialBlob
Retrieves the number of bytes in this SerialBlob object's array of bytes.
length() - Method in class javax.sql.rowset.serial.SerialClob
Retrieves the number of characters in this SerialClob object's array of characters.
length() - Method in interface javax.swing.text.AbstractDocument.Content
Current length of the sequence of character content.
length() - Method in class javax.swing.text.GapContent
Returns the length of the content.
length() - Method in class javax.swing.text.Segment
Returns the length of this character sequence.
length() - Method in class javax.swing.text.StringContent
Returns the length of the content.
length() - Method in interface org.omg.CORBA.DynSequence
Deprecated.
Returns the length of the sequence represented by this DynFixed object.
length(int) - Method in interface org.omg.CORBA.DynSequence
Deprecated.
Sets the length of the sequence represented by this DynFixed object to the given argument.
length() - Method in class org.omg.CORBA.TypeCode
Returns the number of elements in the type described by this TypeCode object.
lengthOfMonth() - Method in interface java.time.chrono.ChronoLocalDate
Returns the length of the month represented by this date, as defined by the calendar system.
lengthOfMonth() - Method in class java.time.chrono.HijrahDate
Returns the length of the month represented by this date.
lengthOfMonth() - Method in class java.time.chrono.JapaneseDate
Returns the length of the month represented by this date.
lengthOfMonth() - Method in class java.time.chrono.MinguoDate
Returns the length of the month represented by this date.
lengthOfMonth() - Method in class java.time.chrono.ThaiBuddhistDate
Returns the length of the month represented by this date.
lengthOfMonth() - Method in class java.time.LocalDate
Returns the length of the month represented by this date.
lengthOfMonth() - Method in class java.time.YearMonth
Returns the length of the month, taking account of the year.
lengthOfYear() - Method in interface java.time.chrono.ChronoLocalDate
Returns the length of the year represented by this date, as defined by the calendar system.
lengthOfYear() - Method in class java.time.chrono.HijrahDate
Returns the length of the year represented by this date.
lengthOfYear() - Method in class java.time.chrono.JapaneseDate
lengthOfYear() - Method in class java.time.LocalDate
Returns the length of the year represented by this date.
lengthOfYear() - Method in class java.time.YearMonth
Returns the length of the year.
LEPCHA - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Lepcha" Unicode character block.
leq(ValueExp, ValueExp) - Static method in class javax.management.Query
Returns a query expression that represents a "less than or equal to" constraint on two values.
LESS_THAN_MIN_ROLE_DEGREE - Static variable in class javax.management.relation.RoleStatus
Problem type when trying to set a role value with less ObjectNames than the minimum expected cardinality.
LESSER - Static variable in class javax.xml.datatype.DatatypeConstants
Comparison result.
lessThanOrEquals(ResolutionSyntax) - Method in class javax.print.attribute.ResolutionSyntax
Determine whether this resolution attribute's value is less than or equal to the given resolution attribute's value.
LETTER - Static variable in class java.awt.PageAttributes.MediaType
An alias for NA_LETTER.
LETTER - Static variable in class javax.print.attribute.standard.MediaSize.NA
Specifies the North American letter size, 8.5 inches by 11 inches.
LETTER_NUMBER - Static variable in class java.lang.Character
General category "Nl" in the Unicode specification.
LETTER_SPACING - Static variable in class javax.swing.text.html.CSS.Attribute
LETTERLIKE_SYMBOLS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Letterlike Symbols" Unicode character block.
Level - Class in java.util.logging
The Level class defines a set of standard logging levels that can be used to control logging output.
Level(String, int) - Constructor for class java.util.logging.Level
Create a named Level with a given integer value.
Level(String, int, String) - Constructor for class java.util.logging.Level
Create a named Level with a given integer value and a given localization resource name.
LexicalHandler - Interface in org.xml.sax.ext
SAX2 extension handler for lexical events.
LI - Static variable in class javax.swing.text.html.HTML.Tag
LIFESPAN_POLICY_ID - Interface in org.omg.PortableServer
org/omg/PortableServer/LIFESPAN_POLICY_ID.java .
LifespanPolicy - Interface in org.omg.PortableServer
The LifespanPolicy specifies the lifespan of the objects implemented in the created POA.
LifespanPolicyOperations - Interface in org.omg.PortableServer
The LifespanPolicy specifies the lifespan of the objects implemented in the created POA.
LifespanPolicyValue - Class in org.omg.PortableServer
The LifespanPolicyValue can have the following values.
LifespanPolicyValue(int) - Constructor for class org.omg.PortableServer.LifespanPolicyValue
LIGATURE - Static variable in class java.awt.font.GlyphMetrics
Indicates a glyph that represents multiple characters as a ligature, for example 'fi' or 'ffi'.
LIGATURES - Static variable in class java.awt.font.TextAttribute
Attribute key for enabling optional ligatures.
LIGATURES_ON - Static variable in class java.awt.font.TextAttribute
Request standard optional ligatures.
LIGHT - Static variable in class javax.swing.plaf.metal.MetalIconFactory
LIGHT_GRAY - Static variable in class java.awt.Color
The color light gray.
lightGray - Static variable in class java.awt.Color
The color light gray.
lightHighlight - Variable in class javax.swing.plaf.basic.BasicBorders.ButtonBorder
lightHighlight - Variable in class javax.swing.plaf.basic.BasicBorders.FieldBorder
lightHighlight - Variable in class javax.swing.plaf.basic.BasicTabbedPaneUI
lightWeightPopupEnabled - Variable in class javax.swing.JComboBox
This protected field is implementation specific.
lightWeightPopupEnabled - Variable in class javax.swing.ToolTipManager
LIMBU - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Limbu" Unicode character block.
limit() - Method in class java.nio.Buffer
Returns this buffer's limit.
limit(int) - Method in class java.nio.Buffer
Sets this buffer's limit.
limit(long) - Method in interface java.util.stream.DoubleStream
Returns a stream consisting of the elements of this stream, truncated to be no longer than maxSize in length.
limit(long) - Method in interface java.util.stream.IntStream
Returns a stream consisting of the elements of this stream, truncated to be no longer than maxSize in length.
limit(long) - Method in interface java.util.stream.LongStream
Returns a stream consisting of the elements of this stream, truncated to be no longer than maxSize in length.
limit(long) - Method in interface java.util.stream.Stream
Returns a stream consisting of the elements of this stream, truncated to be no longer than maxSize in length.
LimitExceededException - Exception in javax.naming
This exception is thrown when a method terminates abnormally due to a user or system specified limit.
LimitExceededException() - Constructor for exception javax.naming.LimitExceededException
Constructs a new instance of LimitExceededException with all name resolution fields and explanation initialized to null.
LimitExceededException(String) - Constructor for exception javax.naming.LimitExceededException
Constructs a new instance of LimitExceededException using an explanation.
LINE - Static variable in interface javax.accessibility.AccessibleExtendedText
Constant used to indicate that the part of the text that should be retrieved is a line of text.
Line - Interface in javax.sound.sampled
The Line interface represents a mono or multi-channel audio feed.
Line.Info - Class in javax.sound.sampled
A Line.Info object contains information about a line.
Line2D - Class in java.awt.geom
This Line2D represents a line segment in (x,y) coordinate space.
Line2D() - Constructor for class java.awt.geom.Line2D
This is an abstract class that cannot be instantiated directly.
Line2D.Double - Class in java.awt.geom
A line segment specified with double coordinates.
Line2D.Float - Class in java.awt.geom
A line segment specified with float coordinates.
LINE_AXIS - Static variable in class javax.swing.BoxLayout
Specifies that components should be laid out in the direction of a line of text as determined by the target container's ComponentOrientation property.
LINE_END - Static variable in class java.awt.BorderLayout
The component goes at the end of the line direction for the layout.
LINE_END - Static variable in class java.awt.GridBagConstraints
Place the component centered along the edge of its display area where lines of text would normally end for the current ComponentOrientation.
LINE_HEIGHT - Static variable in class javax.swing.text.html.CSS.Attribute
LINE_IN - Static variable in class javax.sound.sampled.Port.Info
A type of port that gets audio from a line-level audio input jack.
LINE_OUT - Static variable in class javax.sound.sampled.Port.Info
A type of port that sends audio to a line-level audio output jack.
LINE_SEPARATOR - Static variable in class java.lang.Character
General category "Zl" in the Unicode specification.
LINE_START - Static variable in class java.awt.BorderLayout
The component goes at the beginning of the line direction for the layout.
LINE_START - Static variable in class java.awt.GridBagConstraints
Place the component centered along the edge of its display area where lines of text would normally begin for the current ComponentOrientation.
LINEAR_B_IDEOGRAMS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Linear B Ideograms" Unicode character block.
LINEAR_B_SYLLABARY - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Linear B Syllabary" Unicode character block.
LinearGradientPaint - Class in java.awt
The LinearGradientPaint class provides a way to fill a Shape with a linear color gradient pattern.
LinearGradientPaint(float, float, float, float, float[], Color[]) - Constructor for class java.awt.LinearGradientPaint
Constructs a LinearGradientPaint with a default NO_CYCLE repeating method and SRGB color space.
LinearGradientPaint(float, float, float, float, float[], Color[], MultipleGradientPaint.CycleMethod) - Constructor for class java.awt.LinearGradientPaint
Constructs a LinearGradientPaint with a default SRGB color space.
LinearGradientPaint(Point2D, Point2D, float[], Color[]) - Constructor for class java.awt.LinearGradientPaint
Constructs a LinearGradientPaint with a default NO_CYCLE repeating method and SRGB color space.
LinearGradientPaint(Point2D, Point2D, float[], Color[], MultipleGradientPaint.CycleMethod) - Constructor for class java.awt.LinearGradientPaint
Constructs a LinearGradientPaint with a default SRGB color space.
LinearGradientPaint(Point2D, Point2D, float[], Color[], MultipleGradientPaint.CycleMethod, MultipleGradientPaint.ColorSpaceType, AffineTransform) - Constructor for class java.awt.LinearGradientPaint
Constructs a LinearGradientPaint.
LineBorder - Class in javax.swing.border
A class which implements a line border of arbitrary thickness and of a single color.
LineBorder(Color) - Constructor for class javax.swing.border.LineBorder
Creates a line border with the specified color and a thickness = 1.
LineBorder(Color, int) - Constructor for class javax.swing.border.LineBorder
Creates a line border with the specified color and thickness.
LineBorder(Color, int, boolean) - Constructor for class javax.swing.border.LineBorder
Creates a line border with the specified color, thickness, and corner shape.
LineBorderUIResource(Color) - Constructor for class javax.swing.plaf.BorderUIResource.LineBorderUIResource
LineBorderUIResource(Color, int) - Constructor for class javax.swing.plaf.BorderUIResource.LineBorderUIResource
LineBreakMeasurer - Class in java.awt.font
The LineBreakMeasurer class allows styled text to be broken into lines (or segments) that fit within a particular visual advance.
LineBreakMeasurer(AttributedCharacterIterator, FontRenderContext) - Constructor for class java.awt.font.LineBreakMeasurer
Constructs a LineBreakMeasurer for the specified text.
LineBreakMeasurer(AttributedCharacterIterator, BreakIterator, FontRenderContext) - Constructor for class java.awt.font.LineBreakMeasurer
Constructs a LineBreakMeasurer for the specified text.
lineColor - Variable in class javax.swing.border.LineBorder
LineEvent - Class in javax.sound.sampled
The LineEvent class encapsulates information that a line sends its listeners whenever the line opens, closes, starts, or stops.
LineEvent(Line, LineEvent.Type, long) - Constructor for class javax.sound.sampled.LineEvent
Constructs a new event of the specified type, originating from the specified line.
LineEvent.Type - Class in javax.sound.sampled
The LineEvent.Type inner class identifies what kind of event occurred on a line.
lineLimitAttribute - Static variable in class javax.swing.text.PlainDocument
Name of the attribute that specifies the maximum length of a line, if there is a maximum length.
LineListener - Interface in javax.sound.sampled
Instances of classes that implement the LineListener interface can register to receive events when a line's status changes.
LineMetrics - Class in java.awt.font
The LineMetrics class allows access to the metrics needed to layout characters along a line and to layout of a set of lines.
LineMetrics() - Constructor for class java.awt.font.LineMetrics
lineno() - Method in class java.io.StreamTokenizer
Return the current line number.
LineNumberInputStream - Class in java.io
Deprecated.
This class incorrectly assumes that bytes adequately represent characters. As of JDK 1.1, the preferred way to operate on character streams is via the new character-stream classes, which include a class for counting line numbers.
LineNumberInputStream(InputStream) - Constructor for class java.io.LineNumberInputStream
Deprecated.
Constructs a newline number input stream that reads its input from the specified input stream.
LineNumberReader - Class in java.io
A buffered character-input stream that keeps track of line numbers.
LineNumberReader(Reader) - Constructor for class java.io.LineNumberReader
Create a new line-numbering reader, using the default input-buffer size.
LineNumberReader(Reader, int) - Constructor for class java.io.LineNumberReader
Create a new line-numbering reader, reading characters into a buffer of the given size.
lines() - Method in class java.io.BufferedReader
Returns a Stream, the elements of which are lines read from this BufferedReader.
lines(Path, Charset) - Static method in class java.nio.file.Files
Read all lines from a file as a Stream.
lines(Path) - Static method in class java.nio.file.Files
Read all lines from a file as a Stream.
lineSeparator() - Static method in class java.lang.System
Returns the system-dependent line separator string.
linesIntersect(double, double, double, double, double, double, double, double) - Static method in class java.awt.geom.Line2D
Tests if the line segment from (x1,y1) to (x2,y2) intersects the line segment from (x3,y3) to (x4,y4).
LineSpacing - Static variable in class javax.swing.text.StyleConstants
The amount of space between lines of the paragraph.
lineTo(double, double) - Method in class java.awt.geom.Path2D.Double
Adds a point to the path by drawing a straight line from the current coordinates to the new specified coordinates specified in double precision.
lineTo(double, double) - Method in class java.awt.geom.Path2D.Float
Adds a point to the path by drawing a straight line from the current coordinates to the new specified coordinates specified in double precision.
lineTo(float, float) - Method in class java.awt.geom.Path2D.Float
Adds a point to the path by drawing a straight line from the current coordinates to the new specified coordinates specified in float precision.
lineTo(double, double) - Method in class java.awt.geom.Path2D
Adds a point to the path by drawing a straight line from the current coordinates to the new specified coordinates specified in double precision.
lineToRect(Shape, int) - Method in class javax.swing.text.PlainView
Determine the rectangle that represents the given line.
LineUnavailableException - Exception in javax.sound.sampled
A LineUnavailableException is an exception indicating that a line cannot be opened because it is unavailable.
LineUnavailableException() - Constructor for exception javax.sound.sampled.LineUnavailableException
Constructs a LineUnavailableException that has null as its error detail message.
LineUnavailableException(String) - Constructor for exception javax.sound.sampled.LineUnavailableException
Constructs a LineUnavailableException that has the specified detail message.
LINK - Static variable in class javax.swing.text.html.HTML.Attribute
LINK - Static variable in class javax.swing.text.html.HTML.Tag
LINK - Static variable in class javax.swing.TransferHandler
An int representing a "link" transfer action.
LinkageError - Error in java.lang
Subclasses of LinkageError indicate that a class has some dependency on another class; however, the latter class has incompatibly changed after the compilation of the former class.
LinkageError() - Constructor for error java.lang.LinkageError
Constructs a LinkageError with no detail message.
LinkageError(String) - Constructor for error java.lang.LinkageError
Constructs a LinkageError with the specified detail message.
LinkageError(String, Throwable) - Constructor for error java.lang.LinkageError
Constructs a LinkageError with the specified detail message and cause.
LinkController() - Constructor for class javax.swing.text.html.HTMLEditorKit.LinkController
LinkedBlockingDeque<E> - Class in java.util.concurrent
An optionally-bounded blocking deque based on linked nodes.
LinkedBlockingDeque() - Constructor for class java.util.concurrent.LinkedBlockingDeque
Creates a LinkedBlockingDeque with a capacity of Integer.MAX_VALUE.
LinkedBlockingDeque(int) - Constructor for class java.util.concurrent.LinkedBlockingDeque
Creates a LinkedBlockingDeque with the given (fixed) capacity.
LinkedBlockingDeque(Collection<? extends E>) - Constructor for class java.util.concurrent.LinkedBlockingDeque
Creates a LinkedBlockingDeque with a capacity of Integer.MAX_VALUE, initially containing the elements of the given collection, added in traversal order of the collection's iterator.
LinkedBlockingQueue<E> - Class in java.util.concurrent
An optionally-bounded blocking queue based on linked nodes.
LinkedBlockingQueue() - Constructor for class java.util.concurrent.LinkedBlockingQueue
Creates a LinkedBlockingQueue with a capacity of Integer.MAX_VALUE.
LinkedBlockingQueue(int) - Constructor for class java.util.concurrent.LinkedBlockingQueue
Creates a LinkedBlockingQueue with the given (fixed) capacity.
LinkedBlockingQueue(Collection<? extends E>) - Constructor for class java.util.concurrent.LinkedBlockingQueue
Creates a LinkedBlockingQueue with a capacity of Integer.MAX_VALUE, initially containing the elements of the given collection, added in traversal order of the collection's iterator.
LinkedHashMap<K,V> - Class in java.util
Hash table and linked list implementation of the Map interface, with predictable iteration order.
LinkedHashMap(int, float) - Constructor for class java.util.LinkedHashMap
Constructs an empty insertion-ordered LinkedHashMap instance with the specified initial capacity and load factor.
LinkedHashMap(int) - Constructor for class java.util.LinkedHashMap
Constructs an empty insertion-ordered LinkedHashMap instance with the specified initial capacity and a default load factor (0.75).
LinkedHashMap() - Constructor for class java.util.LinkedHashMap
Constructs an empty insertion-ordered LinkedHashMap instance with the default initial capacity (16) and load factor (0.75).
LinkedHashMap(Map<? extends K, ? extends V>) - Constructor for class java.util.LinkedHashMap
Constructs an insertion-ordered LinkedHashMap instance with the same mappings as the specified map.
LinkedHashMap(int, float, boolean) - Constructor for class java.util.LinkedHashMap
Constructs an empty LinkedHashMap instance with the specified initial capacity, load factor and ordering mode.
LinkedHashSet<E> - Class in java.util
Hash table and linked list implementation of the Set interface, with predictable iteration order.
LinkedHashSet(int, float) - Constructor for class java.util.LinkedHashSet
Constructs a new, empty linked hash set with the specified initial capacity and load factor.
LinkedHashSet(int) - Constructor for class java.util.LinkedHashSet
Constructs a new, empty linked hash set with the specified initial capacity and the default load factor (0.75).
LinkedHashSet() - Constructor for class java.util.LinkedHashSet
Constructs a new, empty linked hash set with the default initial capacity (16) and load factor (0.75).
LinkedHashSet(Collection<? extends E>) - Constructor for class java.util.LinkedHashSet
Constructs a new linked hash set with the same elements as the specified collection.
LinkedList<E> - Class in java.util
Doubly-linked list implementation of the List and Deque interfaces.
LinkedList() - Constructor for class java.util.LinkedList
Constructs an empty list.
LinkedList(Collection<? extends E>) - Constructor for class java.util.LinkedList
Constructs a list containing the elements of the specified collection, in the order they are returned by the collection's iterator.
LinkedTransferQueue<E> - Class in java.util.concurrent
An unbounded TransferQueue based on linked nodes.
LinkedTransferQueue() - Constructor for class java.util.concurrent.LinkedTransferQueue
Creates an initially empty LinkedTransferQueue.
LinkedTransferQueue(Collection<? extends E>) - Constructor for class java.util.concurrent.LinkedTransferQueue
Creates a LinkedTransferQueue initially containing the elements of the given collection, added in traversal order of the collection's iterator.
LinkException - Exception in javax.naming
This exception is used to describe problems encounter while resolving links.
LinkException(String) - Constructor for exception javax.naming.LinkException
Constructs a new instance of LinkException with an explanation All the other fields are initialized to null.
LinkException() - Constructor for exception javax.naming.LinkException
Constructs a new instance of LinkException.
linkExplanation - Variable in exception javax.naming.LinkException
Contains the exception of why resolution of the link failed.
LinkLoopException - Exception in javax.naming
This exception is thrown when a loop was detected will attempting to resolve a link, or an implementation specific limit on link counts has been reached.
LinkLoopException(String) - Constructor for exception javax.naming.LinkLoopException
Constructs a new instance of LinkLoopException with an explanation All the other fields are initialized to null.
LinkLoopException() - Constructor for exception javax.naming.LinkLoopException
Constructs a new instance of LinkLoopException.
LinkOption - Enum in java.nio.file
Defines the options as to how symbolic links are handled.
LinkPermission - Class in java.nio.file
The Permission class for link creation operations.
LinkPermission(String) - Constructor for class java.nio.file.LinkPermission
Constructs a LinkPermission with the specified name.
LinkPermission(String, String) - Constructor for class java.nio.file.LinkPermission
Constructs a LinkPermission with the specified name.
LinkRef - Class in javax.naming
This class represents a Reference whose contents is a name, called the link name, that is bound to an atomic name in a context.
LinkRef(Name) - Constructor for class javax.naming.LinkRef
Constructs a LinkRef for a name.
LinkRef(String) - Constructor for class javax.naming.LinkRef
Constructs a LinkRef for a string name.
linkRemainingName - Variable in exception javax.naming.LinkException
Contains the remaining link name that has not been resolved yet.
linkResolvedName - Variable in exception javax.naming.LinkException
Contains the part of the link that has been successfully resolved.
linkResolvedObj - Variable in exception javax.naming.LinkException
Contains the object to which resolution of the part of the link was successful.
linkSize(Component...) - Method in class javax.swing.GroupLayout
Forces the specified components to have the same size regardless of their preferred, minimum or maximum sizes.
linkSize(int, Component...) - Method in class javax.swing.GroupLayout
Forces the specified components to have the same size along the specified axis regardless of their preferred, minimum or maximum sizes.
list() - Method in class java.awt.Component
Prints a listing of this component to the standard system output stream System.out.
list(PrintStream) - Method in class java.awt.Component
Prints a listing of this component to the specified output stream.
list(PrintStream, int) - Method in class java.awt.Component
Prints out a list, starting at the specified indentation, to the specified print stream.
list(PrintWriter) - Method in class java.awt.Component
Prints a listing to the specified print writer.
list(PrintWriter, int) - Method in class java.awt.Component
Prints out a list, starting at the specified indentation, to the specified print writer.
list(PrintStream, int) - Method in class java.awt.Container
Prints a listing of this container to the specified output stream.
list(PrintWriter, int) - Method in class java.awt.Container
Prints out a list, starting at the specified indentation, to the specified print writer.
List - Class in java.awt
The List component presents the user with a scrolling list of text items.
List() - Constructor for class java.awt.List
Creates a new scrolling list.
List(int) - Constructor for class java.awt.List
Creates a new scrolling list initialized with the specified number of visible lines.
List(int, boolean) - Constructor for class java.awt.List
Creates a new scrolling list initialized to display the specified number of rows.
list() - Method in class java.io.File
Returns an array of strings naming the files and directories in the directory denoted by this abstract pathname.
list(FilenameFilter) - Method in class java.io.File
Returns an array of strings naming the files and directories in the directory denoted by this abstract pathname that satisfy the specified filter.
list() - Method in class java.lang.ThreadGroup
Prints information about this thread group to the standard output.
list() - Method in interface java.nio.file.attribute.UserDefinedFileAttributeView
Returns a list containing the names of the user-defined attributes.
list(Path) - Static method in class java.nio.file.Files
Return a lazily populated Stream, the elements of which are the entries in the directory.
list(String) - Static method in class java.rmi.Naming
Returns an array of the names bound in the registry.
list() - Method in interface java.rmi.registry.Registry
Returns an array of the names bound in this registry.
list(Enumeration<T>) - Static method in class java.util.Collections
Returns an array list containing the elements returned by the specified enumeration in the order they are returned by the enumeration.
List<E> - Interface in java.util
An ordered collection (also known as a sequence).
list(PrintStream) - Method in class java.util.Properties
Prints this property list out to the specified output stream.
list(PrintWriter) - Method in class java.util.Properties
Prints this property list out to the specified output stream.
LIST - Static variable in class javax.accessibility.AccessibleRole
An object that presents a list of objects to the user and allows the user to select one or more of them.
list(Name) - Method in interface javax.naming.Context
Enumerates the names bound in the named context, along with the class names of objects bound to them.
list(String) - Method in interface javax.naming.Context
Enumerates the names bound in the named context, along with the class names of objects bound to them.
list(String) - Method in class javax.naming.InitialContext
list(Name) - Method in class javax.naming.InitialContext
list - Variable in class javax.swing.plaf.basic.BasicComboPopup
This protected field is implementation specific.
list - Variable in class javax.swing.plaf.basic.BasicListUI
LIST - Static variable in class javax.swing.plaf.synth.Region
List region.
list(JavaFileManager.Location, String, Set<JavaFileObject.Kind>, boolean) - Method in class javax.tools.ForwardingJavaFileManager
list(JavaFileManager.Location, String, Set<JavaFileObject.Kind>, boolean) - Method in interface javax.tools.JavaFileManager
Lists all file objects matching the given criteria in the given location.
list(int, BindingListHolder, BindingIteratorHolder) - Method in class org.omg.CosNaming._NamingContextExtStub
The list operation allows a client to iterate through a set of bindings in a naming context.
list(int, BindingListHolder, BindingIteratorHolder) - Method in class org.omg.CosNaming._NamingContextStub
The list operation allows a client to iterate through a set of bindings in a naming context.
list(int, BindingListHolder, BindingIteratorHolder) - Method in interface org.omg.CosNaming.NamingContextOperations
The list operation allows a client to iterate through a set of bindings in a naming context.
List.AccessibleAWTList - Class in java.awt
This class implements accessibility support for the List class.
List.AccessibleAWTList.AccessibleAWTListChild - Class in java.awt
This class implements accessibility support for List children.
LIST_DESELECT - Static variable in class java.awt.Event
An item in a list has been deselected.
LIST_DIRECTORY - Static variable in enum java.nio.file.attribute.AclEntryPermission
Permission to list the entries of a directory (equal to AclEntryPermission.READ_DATA)
list_initial_services() - Method in class org.omg.CORBA.ORB
Returns a list of the initially available CORBA object references, such as "NameService" and "InterfaceRepository".
LIST_ITEM - Static variable in class javax.accessibility.AccessibleRole
An object that presents an element in a list.
LIST_SELECT - Static variable in class java.awt.Event
An item in a list has been selected.
LIST_STYLE - Static variable in class javax.swing.text.html.CSS.Attribute
LIST_STYLE_IMAGE - Static variable in class javax.swing.text.html.CSS.Attribute
LIST_STYLE_POSITION - Static variable in class javax.swing.text.html.CSS.Attribute
LIST_STYLE_TYPE - Static variable in class javax.swing.text.html.CSS.Attribute
listBindings(Name) - Method in interface javax.naming.Context
Enumerates the names bound in the named context, along with the objects bound to them.
listBindings(String) - Method in interface javax.naming.Context
Enumerates the names bound in the named context, along with the objects bound to them.
listBindings(String) - Method in class javax.naming.InitialContext
listBindings(Name) - Method in class javax.naming.InitialContext
listBox - Variable in class javax.swing.plaf.basic.BasicComboBoxUI
listBox - Variable in class javax.swing.plaf.metal.MetalComboBoxButton
ListCellRenderer<E> - Interface in javax.swing
Identifies components that can be used as "rubber stamps" to paint the cells in a JList.
ListDataEvent - Class in javax.swing.event
Defines an event that encapsulates changes to a list.
ListDataEvent(Object, int, int, int) - Constructor for class javax.swing.event.ListDataEvent
Constructs a ListDataEvent object.
ListDataHandler() - Constructor for class javax.swing.plaf.basic.BasicComboBoxUI.ListDataHandler
ListDataHandler() - Constructor for class javax.swing.plaf.basic.BasicComboPopup.ListDataHandler
ListDataHandler() - Constructor for class javax.swing.plaf.basic.BasicListUI.ListDataHandler
ListDataListener - Interface in javax.swing.event
ListDataListener
listDataListener - Variable in class javax.swing.plaf.basic.BasicComboBoxUI
This protected field is implementation specific.
listDataListener - Variable in class javax.swing.plaf.basic.BasicComboPopup
This protected field is implementation specific.
listDataListener - Variable in class javax.swing.plaf.basic.BasicListUI
ListEditor(JSpinner) - Constructor for class javax.swing.JSpinner.ListEditor
Construct a JSpinner editor that supports displaying and editing the value of a SpinnerListModel with a JFormattedTextField.
listen(int) - Method in class java.net.SocketImpl
Sets the maximum queue length for incoming connection indications (a request to connect) to the count argument.
Listener() - Constructor for class javax.xml.bind.Marshaller.Listener
Listener() - Constructor for class javax.xml.bind.Unmarshaller.Listener
listenerList - Variable in class javax.swing.AbstractCellEditor
listenerList - Variable in class javax.swing.AbstractListModel
listenerList - Variable in class javax.swing.AbstractSpinnerModel
The list of ChangeListeners for this model.
listenerList - Variable in class javax.swing.colorchooser.DefaultColorSelectionModel
listenerList - Variable in class javax.swing.DefaultBoundedRangeModel
The listeners waiting for model changes.
listenerList - Variable in class javax.swing.DefaultButtonModel
Stores the listeners on this model.
listenerList - Variable in class javax.swing.DefaultListSelectionModel
listenerList - Variable in class javax.swing.DefaultSingleSelectionModel
The collection of registered listeners
listenerList - Variable in class javax.swing.event.EventListenerList
listenerList - Variable in class javax.swing.JComponent
A list of event listeners for this component.
listenerList - Variable in class javax.swing.MenuSelectionManager
listenerList - Variable in class javax.swing.table.AbstractTableModel
List of listeners
listenerList - Variable in class javax.swing.table.DefaultTableColumnModel
List of TableColumnModelListener
listenerList - Variable in class javax.swing.text.AbstractDocument
The event listener list for the document.
listenerList - Variable in class javax.swing.text.DefaultCaret
The event listener list.
listenerList - Variable in class javax.swing.text.StyleContext.NamedStyle
The change listeners for the model.
listenerList - Variable in class javax.swing.Timer
listenerList - Variable in class javax.swing.tree.DefaultTreeModel
Listeners.
listenerList - Variable in class javax.swing.tree.DefaultTreeSelectionModel
Event listener list.
ListenerNotFoundException - Exception in javax.management
The specified MBean listener does not exist in the repository.
ListenerNotFoundException() - Constructor for exception javax.management.ListenerNotFoundException
Default constructor.
ListenerNotFoundException(String) - Constructor for exception javax.management.ListenerNotFoundException
Constructor that allows a specific error message to be specified.
listeners - Variable in class javax.swing.undo.UndoableEditSupport
listFiles() - Method in class java.io.File
Returns an array of abstract pathnames denoting the files in the directory denoted by this abstract pathname.
listFiles(FilenameFilter) - Method in class java.io.File
Returns an array of abstract pathnames denoting the files and directories in the directory denoted by this abstract pathname that satisfy the specified filter.
listFiles(FileFilter) - Method in class java.io.File
Returns an array of abstract pathnames denoting the files and directories in the directory denoted by this abstract pathname that satisfy the specified filter.
listIterator() - Method in class java.util.AbstractList
Returns a list iterator over the elements in this list (in proper sequence).
listIterator(int) - Method in class java.util.AbstractList
Returns a list iterator over the elements in this list (in proper sequence), starting at the specified position in the list.
listIterator(int) - Method in class java.util.AbstractSequentialList
Returns a list iterator over the elements in this list (in proper sequence).
listIterator(int) - Method in class java.util.ArrayList
Returns a list iterator over the elements in this list (in proper sequence), starting at the specified position in the list.
listIterator() - Method in class java.util.ArrayList
Returns a list iterator over the elements in this list (in proper sequence).
listIterator() - Method in class java.util.concurrent.CopyOnWriteArrayList
Returns a list iterator over the elements in this list (in proper sequence).
listIterator(int) - Method in class java.util.concurrent.CopyOnWriteArrayList
Returns a list iterator over the elements in this list (in proper sequence), starting at the specified position in the list.
listIterator(int) - Method in class java.util.LinkedList
Returns a list-iterator of the elements in this list (in proper sequence), starting at the specified position in the list.
listIterator() - Method in interface java.util.List
Returns a list iterator over the elements in this list (in proper sequence).
listIterator(int) - Method in interface java.util.List
Returns a list iterator over the elements in this list (in proper sequence), starting at the specified position in the list.
ListIterator<E> - Interface in java.util
An iterator for lists that allows the programmer to traverse the list in either direction, modify the list during iteration, and obtain the iterator's current position in the list.
listIterator(int) - Method in class java.util.Vector
Returns a list iterator over the elements in this list (in proper sequence), starting at the specified position in the list.
listIterator() - Method in class java.util.Vector
Returns a list iterator over the elements in this list (in proper sequence).
ListModel<E> - Interface in javax.swing
This interface defines the methods components like JList use to get the value of each cell in a list and the length of the list.
ListMouseHandler() - Constructor for class javax.swing.plaf.basic.BasicComboPopup.ListMouseHandler
listMouseListener - Variable in class javax.swing.plaf.basic.BasicComboPopup
This protected field is implementation specific.
ListMouseMotionHandler() - Constructor for class javax.swing.plaf.basic.BasicComboPopup.ListMouseMotionHandler
listMouseMotionListener - Variable in class javax.swing.plaf.basic.BasicComboPopup
This protected field is implementation specific.
ListResourceBundle - Class in java.util
ListResourceBundle is an abstract subclass of ResourceBundle that manages resources for a locale in a convenient and easy to use list.
ListResourceBundle() - Constructor for class java.util.ListResourceBundle
Sole constructor.
listRoots() - Static method in class java.io.File
List the available filesystem roots.
ListSelectionEvent - Class in javax.swing.event
An event that characterizes a change in selection.
ListSelectionEvent(Object, int, int, boolean) - Constructor for class javax.swing.event.ListSelectionEvent
Represents a change in selection status between firstIndex and lastIndex, inclusive.
ListSelectionHandler() - Constructor for class javax.swing.plaf.basic.BasicComboPopup.ListSelectionHandler
ListSelectionHandler() - Constructor for class javax.swing.plaf.basic.BasicListUI.ListSelectionHandler
ListSelectionListener - Interface in javax.swing.event
The listener that's notified when a lists selection value changes.
listSelectionListener - Variable in class javax.swing.plaf.basic.BasicComboPopup
This protected field is implementation specific.
listSelectionListener - Variable in class javax.swing.plaf.basic.BasicListUI
ListSelectionModel - Interface in javax.swing
This interface represents the current state of the selection for any of the components that display a list of values with stable indices.
listSelectionModel - Variable in class javax.swing.tree.DefaultTreeSelectionModel
Handles maintaining the list selection model.
ListUI - Class in javax.swing.plaf
The JList pluggable look and feel delegate.
ListUI() - Constructor for class javax.swing.plaf.ListUI
ListView - Class in javax.swing.text.html
A view implementation to display an html list
ListView(Element) - Constructor for class javax.swing.text.html.ListView
Creates a new view that represents a list element.
listViewIcon - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
LISU - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Lisu" Unicode character block.
LITERAL - Static variable in class java.util.regex.Pattern
Enables literal parsing of the pattern.
LITTLE_ENDIAN - Static variable in class java.nio.ByteOrder
Constant denoting little-endian byte order.
LIVE_DRAG_MODE - Static variable in class javax.swing.JDesktopPane
Indicates that the entire contents of the item being dragged should appear inside the desktop pane.
LOAD - Static variable in class java.awt.FileDialog
This constant value indicates that the purpose of the file dialog window is to locate a file from which to read.
load(String) - Method in class java.lang.Runtime
Loads the native library specified by the filename argument.
load(String) - Static method in class java.lang.System
Loads the native library specified by the filename argument.
load() - Method in class java.nio.MappedByteBuffer
Loads this buffer's content into physical memory.
load(InputStream, char[]) - Method in class java.security.KeyStore
Loads this KeyStore from the given input stream.
load(KeyStore.LoadStoreParameter) - Method in class java.security.KeyStore
Loads this keystore using the given LoadStoreParameter.
load(InputStream) - Method in class java.security.Provider
Reads a property list (key and element pairs) from the input stream.
load(Reader) - Method in class java.util.Properties
Reads a property list (key and element pairs) from the input character stream in a simple line-oriented format.
load(InputStream) - Method in class java.util.Properties
Reads a property list (key and element pairs) from the input byte stream.
load(Class<S>, ClassLoader) - Static method in class java.util.ServiceLoader
Creates a new service loader for the given service type and class loader.
load(Class<S>) - Static method in class java.util.ServiceLoader
Creates a new service loader for the given service type, using the current thread's context class loader.
load() - Method in class javax.management.modelmbean.RequiredModelMBean
Instantiates this MBean instance with the data found for the MBean in the persistent store.
load() - Method in interface javax.management.PersistentMBean
Instantiates thisMBean instance with the data found for the MBean in the persistent store.
load(InputStream, Class<?>) - Method in class javax.swing.plaf.synth.SynthLookAndFeel
Loads the set of SynthStyles that will be used by this SynthLookAndFeel.
load(URL) - Method in class javax.swing.plaf.synth.SynthLookAndFeel
Loads the set of SynthStyles that will be used by this SynthLookAndFeel.
LOAD_FILE - Static variable in class java.awt.Event
A file loading event.
loadAllInstruments(Soundbank) - Method in interface javax.sound.midi.Synthesizer
Loads onto the Synthesizer all instruments contained in the specified Soundbank.
loadChildren() - Method in class javax.swing.JTree.DynamicUtilTreeNode
Loads the children based on childValue.
loadChildren(ViewFactory) - Method in class javax.swing.text.AsyncBoxView
Loads all of the children to initialize the view.
loadChildren(ViewFactory) - Method in class javax.swing.text.CompositeView
Loads all of the children to initialize the view.
loadChildren(ViewFactory) - Method in class javax.swing.text.FlowView
Loads all of the children to initialize the view.
loadChildren(ViewFactory) - Method in class javax.swing.text.WrappedPlainView
Loads all of the children to initialize the view.
loadChildren(ViewFactory) - Method in class javax.swing.text.ZoneView
Loads all of the children to initialize the view.
loadClass(String) - Method in class java.lang.ClassLoader
Loads the class with the specified binary name.
loadClass(String, boolean) - Method in class java.lang.ClassLoader
Loads the class with the specified binary name.
loadClass(String) - Method in interface java.rmi.server.LoaderHandler
Deprecated.
no replacement
loadClass(URL, String) - Method in interface java.rmi.server.LoaderHandler
Deprecated.
no replacement
loadClass(String) - Static method in class java.rmi.server.RMIClassLoader
Deprecated.
replaced by loadClass(String,String) method
loadClass(URL, String) - Static method in class java.rmi.server.RMIClassLoader
Loads a class from a codebase URL.
loadClass(String, String) - Static method in class java.rmi.server.RMIClassLoader
Loads a class from a codebase URL path.
loadClass(String, String, ClassLoader) - Static method in class java.rmi.server.RMIClassLoader
Loads a class from a codebase URL path, optionally using the supplied loader.
loadClass(String, String, ClassLoader) - Method in class java.rmi.server.RMIClassLoaderSpi
Provides the implementation for
 RMIClassLoader.loadClass(URL,String),
 RMIClassLoader.loadClass(String,String), and
 RMIClassLoader.loadClass(String,String,ClassLoader).
loadClass(String) - Static method in class javax.management.DefaultLoaderRepository
Deprecated.
Go through the list of class loaders and try to load the requested class.
loadClass(String) - Method in interface javax.management.loading.ClassLoaderRepository
Load the given class name through the list of class loaders.
loadClass(String) - Static method in class javax.management.loading.DefaultLoaderRepository
Deprecated.
Go through the list of class loaders and try to load the requested class.
loadClass(String, ClassLoaderRepository) - Method in class javax.management.loading.MLet
Load a class, using the given ClassLoaderRepository if the class is not found in this MLet's URLs.
loadClass(String, String, ClassLoader) - Static method in class javax.rmi.CORBA.Util
Returns a class instance for the specified class.
loadClass(String, String, ClassLoader) - Method in interface javax.rmi.CORBA.UtilDelegate
Delegation call for Util.loadClass(java.lang.String, java.lang.String, java.lang.ClassLoader).
loadClassBefore(ClassLoader, String) - Method in interface javax.management.loading.ClassLoaderRepository
Load the given class name through the list of class loaders, stopping at the given one.
loadClassWithout(ClassLoader, String) - Static method in class javax.management.DefaultLoaderRepository
Deprecated.
Go through the list of class loaders but exclude the given class loader, then try to load the requested class.
loadClassWithout(ClassLoader, String) - Method in interface javax.management.loading.ClassLoaderRepository
Load the given class name through the list of class loaders, excluding the given one.
loadClassWithout(ClassLoader, String) - Static method in class javax.management.loading.DefaultLoaderRepository
Deprecated.
Go through the list of class loaders but exclude the given class loader, then try to load the requested class.
loadedChildren - Variable in class javax.swing.JTree.DynamicUtilTreeNode
Have the children been loaded yet?
LoaderHandler - Interface in java.rmi.server
Deprecated.
no replacement
loadFromXML(InputStream) - Method in class java.util.Properties
Loads all of the properties represented by the XML document on the specified input stream into this properties table.
loadImage(String) - Method in class java.beans.SimpleBeanInfo
This is a utility method to help in loading icon images.
loadImage(Image) - Method in class javax.swing.ImageIcon
Loads the image, returning only when the image is loaded.
LOADING - Static variable in class java.awt.MediaTracker
Flag indicating that media is currently being loaded.
loadInstalled(Class<S>) - Static method in class java.util.ServiceLoader
Creates a new service loader for the given service type, using the extension class loader.
loadInstrument(Instrument) - Method in interface javax.sound.midi.Synthesizer
Makes a particular instrument available for synthesis.
loadInstruments(Soundbank, Patch[]) - Method in interface javax.sound.midi.Synthesizer
Loads the instruments referenced by the specified patches, from the specified Soundbank.
loadKeyBindings(InputMap, Object[]) - Static method in class javax.swing.LookAndFeel
Populates an InputMap with the specified bindings.
loadKeymap(Keymap, JTextComponent.KeyBinding[], Action[]) - Static method in class javax.swing.text.JTextComponent
Loads a keymap with a bunch of bindings.
loadLibrary(String) - Method in class java.lang.Runtime
Loads the native library specified by the libname argument.
loadLibrary(String) - Static method in class java.lang.System
Loads the native library specified by the libname argument.
loadProxyClass(String, String[], ClassLoader) - Static method in class java.rmi.server.RMIClassLoader
Loads a dynamic proxy class (see Proxy) that implements a set of interfaces with the given names from a codebase URL path.
loadProxyClass(String, String[], ClassLoader) - Method in class java.rmi.server.RMIClassLoaderSpi
Provides the implementation for RMIClassLoader.loadProxyClass(String,String[],ClassLoader).
loadRules(Reader, URL) - Method in class javax.swing.text.html.StyleSheet
Loads a set of rules that have been specified in terms of CSS1 grammar.
loadSystemColors(int[]) - Method in class java.awt.Toolkit
Fills in the integer array that is supplied as an argument with the current system color values.
loadSystemColors(UIDefaults, String[], boolean) - Method in class javax.swing.plaf.basic.BasicLookAndFeel
Populates table with the name-color pairs in systemColors.
localControl(boolean) - Method in interface javax.sound.midi.MidiChannel
Turns local control on or off.
LocalDate - Class in java.time
A date without a time-zone in the ISO-8601 calendar system, such as 2007-12-03.
localDate() - Static method in class java.time.temporal.TemporalQueries
A query for LocalDate returning null if not found.
localDateTime(TemporalAccessor) - Method in interface java.time.chrono.Chronology
Obtains a local date-time in this chronology from another temporal object.
localDateTime(TemporalAccessor) - Method in class java.time.chrono.HijrahChronology
localDateTime(TemporalAccessor) - Method in class java.time.chrono.IsoChronology
Obtains an ISO local date-time from another date-time object.
localDateTime(TemporalAccessor) - Method in class java.time.chrono.JapaneseChronology
localDateTime(TemporalAccessor) - Method in class java.time.chrono.MinguoChronology
localDateTime(TemporalAccessor) - Method in class java.time.chrono.ThaiBuddhistChronology
LocalDateTime - Class in java.time
A date-time without a time-zone in the ISO-8601 calendar system, such as 2007-12-03T10:15:30.
locale - Variable in class java.beans.beancontext.BeanContextSupport
The current locale of this BeanContext.
locale() - Method in class java.util.Formatter
Returns the locale set by the construction of this formatter.
Locale - Class in java.util
A Locale object represents a specific geographical, political, or cultural region.
Locale(String, String, String) - Constructor for class java.util.Locale
Construct a locale from language, country and variant.
Locale(String, String) - Constructor for class java.util.Locale
Construct a locale from language and country.
Locale(String) - Constructor for class java.util.Locale
Construct a locale from a language code.
locale() - Method in class java.util.Scanner
Returns this scanner's locale.
locale - Variable in class javax.imageio.ImageReader
The current Locale to be used for localization, or null if none has been set.
locale - Variable in class javax.imageio.ImageWriteParam
A Locale to be used to localize compression type names and quality descriptions, or null to use a default Locale.
locale - Variable in class javax.imageio.ImageWriter
The current Locale to be used for localization, or null if none has been set.
Locale.Builder - Class in java.util
Builder is used to build instances of Locale from values configured by the setters.
Locale.Category - Enum in java.util
Enum for locale categories.
Locale.FilteringMode - Enum in java.util
This enum provides constants to select a filtering mode for locale matching.
Locale.LanguageRange - Class in java.util
This class expresses a Language Range defined in RFC 4647 Matching of Language Tags.
LocaleNameProvider - Class in java.util.spi
An abstract class for service providers that provide localized names for the Locale class.
LocaleNameProvider() - Constructor for class java.util.spi.LocaleNameProvider
Sole constructor.
LocaleServiceProvider - Class in java.util.spi
This is the super class of all the locale sensitive service provider interfaces (SPIs).
LocaleServiceProvider() - Constructor for class java.util.spi.LocaleServiceProvider
Sole constructor.
LocalObject - Class in org.omg.CORBA
Used as a base class for implementation of a local IDL interface in the Java language mapping.
LocalObject() - Constructor for class org.omg.CORBA.LocalObject
Constructs a default LocalObject instance.
localPort - Variable in class java.net.DatagramSocketImpl
The local port number.
localport - Variable in class java.net.SocketImpl
The local port number to which this socket is connected.
LocalTime - Class in java.time
A time without time-zone in the ISO-8601 calendar system, such as 10:15:30.
localTime() - Static method in class java.time.temporal.TemporalQueries
A query for LocalTime returning null if not found.
locate(int, int) - Method in class java.awt.Component
Deprecated.
As of JDK version 1.1, replaced by getComponentAt(int, int).
locate(int, int) - Method in class java.awt.Container
Deprecated.
As of JDK version 1.1, replaced by getComponentAt(int, int).
LocateRegistry - Class in java.rmi.registry
LocateRegistry is used to obtain a reference to a bootstrap remote object registry on a particular host (including the local host), or to create a remote object registry that accepts calls on a specific port.
location() - Method in class java.awt.Component
Deprecated.
As of JDK version 1.1, replaced by getLocation().
location(int, int) - Method in class java.awt.GridBagLayout
Determines which cell in the layout grid contains the point specified by (x, y).
Location - Interface in javax.xml.stream
Provides information on the location of an event.
location - Variable in exception javax.xml.stream.XMLStreamException
LOCATION_FORWARD - Interface in org.omg.PortableInterceptor
org/omg/PortableInterceptor/LOCATION_FORWARD.java .
locationFor(String) - Static method in enum javax.tools.StandardLocation
Gets a location object with the given name.
locationToIndex(Point) - Method in class javax.swing.JList
Returns the cell index closest to the given location in the list's coordinate system.
locationToIndex(JList, Point) - Method in class javax.swing.plaf.basic.BasicListUI
Returns the cell index in the specified JList closest to the given location in the list's coordinate system.
locationToIndex(JList, Point) - Method in class javax.swing.plaf.ListUI
Returns the cell index in the specified JList closest to the given location in the list's coordinate system.
locationToIndex(JList, Point) - Method in class javax.swing.plaf.multi.MultiListUI
Invokes the locationToIndex method on each UI handled by this object.
locator - Variable in class javax.swing.text.AsyncBoxView
Object that manages the offsets of the children.
Locator - Interface in org.xml.sax
Interface for associating a SAX event with a document location.
Locator2 - Interface in org.xml.sax.ext
SAX2 extension to augment the entity information provided though a Locator.
Locator2Impl - Class in org.xml.sax.ext
SAX2 extension helper for holding additional Entity information, implementing the Locator2 interface.
Locator2Impl() - Constructor for class org.xml.sax.ext.Locator2Impl
Construct a new, empty Locator2Impl object.
Locator2Impl(Locator) - Constructor for class org.xml.sax.ext.Locator2Impl
Copy an existing Locator or Locator2 object.
LocatorImpl - Class in org.xml.sax.helpers
Provide an optional convenience implementation of Locator.
LocatorImpl() - Constructor for class org.xml.sax.helpers.LocatorImpl
Zero-argument constructor.
LocatorImpl(Locator) - Constructor for class org.xml.sax.helpers.LocatorImpl
Copy constructor.
locatorsUpdateCopy() - Method in interface java.sql.DatabaseMetaData
Indicates whether updates made to a LOB are made on a copy or directly to the LOB.
lock - Variable in class java.io.Reader
The object used to synchronize operations on this stream.
lock - Variable in class java.io.Writer
The object used to synchronize operations on this stream.
lock(long, long, boolean, A, CompletionHandler<FileLock, ? super A>) - Method in class java.nio.channels.AsynchronousFileChannel
Acquires a lock on the given region of this channel's file.
lock(A, CompletionHandler<FileLock, ? super A>) - Method in class java.nio.channels.AsynchronousFileChannel
Acquires an exclusive lock on this channel's file.
lock(long, long, boolean) - Method in class java.nio.channels.AsynchronousFileChannel
Acquires a lock on the given region of this channel's file.
lock() - Method in class java.nio.channels.AsynchronousFileChannel
Acquires an exclusive lock on this channel's file.
lock(long, long, boolean) - Method in class java.nio.channels.FileChannel
Acquires a lock on the given region of this channel's file.
lock() - Method in class java.nio.channels.FileChannel
Acquires an exclusive lock on this channel's file.
Lock - Interface in java.util.concurrent.locks
Lock implementations provide more extensive locking operations than can be obtained using synchronized methods and statements.
lock() - Method in interface java.util.concurrent.locks.Lock
Acquires the lock.
lock() - Method in class java.util.concurrent.locks.ReentrantLock
Acquires the lock.
lock() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock
Acquires the read lock.
lock() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock
Acquires the write lock.
lock - Variable in class java.util.prefs.AbstractPreferences
An object whose monitor is used to lock this node.
LockInfo - Class in java.lang.management
Information about a lock.
LockInfo(String, int) - Constructor for class java.lang.management.LockInfo
Constructs a LockInfo object.
lockInterruptibly() - Method in interface java.util.concurrent.locks.Lock
Acquires the lock unless the current thread is interrupted.
lockInterruptibly() - Method in class java.util.concurrent.locks.ReentrantLock
Acquires the lock unless the current thread is interrupted.
lockInterruptibly() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock
Acquires the read lock unless the current thread is interrupted.
lockInterruptibly() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock
Acquires the write lock unless the current thread is interrupted.
LockSupport - Class in java.util.concurrent.locks
Basic thread blocking primitives for creating locks and other synchronization classes.
log(double) - Static method in class java.lang.Math
Returns the natural logarithm (base e) of a double value.
log(double) - Static method in class java.lang.StrictMath
Returns the natural logarithm (base e) of a double value.
log(String) - Static method in class java.rmi.server.LogStream
Deprecated.
no replacement
log(LogRecord) - Method in class java.util.logging.Logger
Log a LogRecord.
log(Level, String) - Method in class java.util.logging.Logger
Log a message, with no arguments.
log(Level, Supplier<String>) - Method in class java.util.logging.Logger
Log a message, which is only to be constructed if the logging level is such that the message will actually be logged.
log(Level, String, Object) - Method in class java.util.logging.Logger
Log a message, with one object parameter.
log(Level, String, Object[]) - Method in class java.util.logging.Logger
Log a message, with an array of object arguments.
log(Level, String, Throwable) - Method in class java.util.logging.Logger
Log a message, with associated Throwable information.
log(Level, Throwable, Supplier<String>) - Method in class java.util.logging.Logger
Log a lazily constructed message, with associated Throwable information.
log10(double) - Static method in class java.lang.Math
Returns the base 10 logarithm of a double value.
log10(double) - Static method in class java.lang.StrictMath
Returns the base 10 logarithm of a double value.
log1p(double) - Static method in class java.lang.Math
Returns the natural logarithm of the sum of the argument and 1.
log1p(double) - Static method in class java.lang.StrictMath
Returns the natural logarithm of the sum of the argument and 1.
LOG_OPTION - Static variable in class javax.swing.DebugGraphics
Log graphics operations.
Logger - Class in java.util.logging
A Logger object is used to log messages for a specific system or application component.
Logger(String, String) - Constructor for class java.util.logging.Logger
Protected method to construct a logger for a named subsystem.
LOGGING_MXBEAN_NAME - Static variable in class java.util.logging.LogManager
String representation of the ObjectName for the management interface for the logging facility.
LoggingMXBean - Interface in java.util.logging
The management interface for the logging facility.
LoggingPermission - Class in java.util.logging
The permission which the SecurityManager will check when code that is running with a SecurityManager calls one of the logging control methods (such as Logger.setLevel).
LoggingPermission(String, String) - Constructor for class java.util.logging.LoggingPermission
Creates a new LoggingPermission object.
LOGICAL_STYLE_ACTION - Static variable in class javax.swing.text.html.HTMLEditorKit
The logical style choice action identifier The logical style is passed in as an argument
logicalAnd(boolean, boolean) - Static method in class java.lang.Boolean
Returns the result of applying the logical AND operator to the specified boolean operands.
LogicalHandler<C extends LogicalMessageContext> - Interface in javax.xml.ws.handler
The LogicalHandler extends Handler to provide typesafety for the message context parameter.
LogicalMessage - Interface in javax.xml.ws
The LogicalMessage interface represents a protocol agnostic XML message and contains methods that provide access to the payload of the message.
LogicalMessageContext - Interface in javax.xml.ws.handler
The LogicalMessageContext interface extends MessageContext to provide access to a the contained message as a protocol neutral LogicalMessage
logicalOr(boolean, boolean) - Static method in class java.lang.Boolean
Returns the result of applying the logical OR operator to the specified boolean operands.
logicalXor(boolean, boolean) - Static method in class java.lang.Boolean
Returns the result of applying the logical XOR operator to the specified boolean operands.
login(Subject, CallbackHandler) - Method in class java.security.AuthProvider
Log in to this provider.
login() - Method in class javax.security.auth.login.LoginContext
Perform the authentication.
login() - Method in interface javax.security.auth.spi.LoginModule
Method to authenticate a Subject (phase 1).
LoginContext - Class in javax.security.auth.login
The LoginContext class describes the basic methods used to authenticate Subjects and provides a way to develop an application independent of the underlying authentication technology.
LoginContext(String) - Constructor for class javax.security.auth.login.LoginContext
Instantiate a new LoginContext object with a name.
LoginContext(String, Subject) - Constructor for class javax.security.auth.login.LoginContext
Instantiate a new LoginContext object with a name and a Subject object.
LoginContext(String, CallbackHandler) - Constructor for class javax.security.auth.login.LoginContext
Instantiate a new LoginContext object with a name and a CallbackHandler object.
LoginContext(String, Subject, CallbackHandler) - Constructor for class javax.security.auth.login.LoginContext
Instantiate a new LoginContext object with a name, a Subject to be authenticated, and a CallbackHandler object.
LoginContext(String, Subject, CallbackHandler, Configuration) - Constructor for class javax.security.auth.login.LoginContext
Instantiate a new LoginContext object with a name, a Subject to be authenticated, a CallbackHandler object, and a login Configuration.
LoginException - Exception in javax.security.auth.login
This is the basic login exception.
LoginException() - Constructor for exception javax.security.auth.login.LoginException
Constructs a LoginException with no detail message.
LoginException(String) - Constructor for exception javax.security.auth.login.LoginException
Constructs a LoginException with the specified detail message.
LoginModule - Interface in javax.security.auth.spi
LoginModule describes the interface implemented by authentication technology providers.
LogManager - Class in java.util.logging
There is a single global LogManager object that is used to maintain a set of shared state about Loggers and log services.
LogManager() - Constructor for class java.util.logging.LogManager
Protected constructor.
logout() - Method in class java.security.AuthProvider
Log out from this provider.
logout() - Method in class javax.security.auth.login.LoginContext
Logout the Subject.
logout() - Method in interface javax.security.auth.spi.LoginModule
Method which logs out a Subject.
logp(Level, String, String, String) - Method in class java.util.logging.Logger
Log a message, specifying source class and method, with no arguments.
logp(Level, String, String, Supplier<String>) - Method in class java.util.logging.Logger
Log a lazily constructed message, specifying source class and method, with no arguments.
logp(Level, String, String, String, Object) - Method in class java.util.logging.Logger
Log a message, specifying source class and method, with a single object parameter to the log message.
logp(Level, String, String, String, Object[]) - Method in class java.util.logging.Logger
Log a message, specifying source class and method, with an array of object arguments.
logp(Level, String, String, String, Throwable) - Method in class java.util.logging.Logger
Log a message, specifying source class and method, with associated Throwable information.
logp(Level, String, String, Throwable, Supplier<String>) - Method in class java.util.logging.Logger
Log a lazily constructed message, specifying source class and method, with associated Throwable information.
logrb(Level, String, String, String, String) - Method in class java.util.logging.Logger
Deprecated.
Use Logger.logrb(java.util.logging.Level, java.lang.String, java.lang.String, java.util.ResourceBundle, java.lang.String, java.lang.Object...) instead.
logrb(Level, String, String, String, String, Object) - Method in class java.util.logging.Logger
Deprecated.
Use Logger.logrb(java.util.logging.Level, java.lang.String, java.lang.String, java.util.ResourceBundle, java.lang.String, java.lang.Object...) instead
logrb(Level, String, String, String, String, Object[]) - Method in class java.util.logging.Logger
Deprecated.
Use Logger.logrb(java.util.logging.Level, java.lang.String, java.lang.String, java.util.ResourceBundle, java.lang.String, java.lang.Object...) instead.
logrb(Level, String, String, ResourceBundle, String, Object...) - Method in class java.util.logging.Logger
Log a message, specifying source class, method, and resource bundle, with an optional list of message parameters.
logrb(Level, String, String, String, String, Throwable) - Method in class java.util.logging.Logger
Deprecated.
Use Logger.logrb(java.util.logging.Level, java.lang.String, java.lang.String, java.util.ResourceBundle, java.lang.String, java.lang.Throwable) instead.
logrb(Level, String, String, ResourceBundle, String, Throwable) - Method in class java.util.logging.Logger
Log a message, specifying source class, method, and resource bundle, with associated Throwable information.
LogRecord - Class in java.util.logging
LogRecord objects are used to pass logging requests between the logging framework and individual log Handlers.
LogRecord(Level, String) - Constructor for class java.util.logging.LogRecord
Construct a LogRecord with the given level and message values.
LogStream - Class in java.rmi.server
Deprecated.
no replacement
logStream() - Static method in class javax.swing.DebugGraphics
Returns the stream to which the DebugGraphics logs drawing operations.
Long - Class in java.lang
The Long class wraps a value of the primitive type long in an object.
Long(long) - Constructor for class java.lang.Long
Constructs a newly allocated Long object that represents the specified long argument.
Long(String) - Constructor for class java.lang.Long
Constructs a newly allocated Long object that represents the long value indicated by the String parameter.
LONG - Static variable in class java.text.DateFormat
Constant for long style pattern.
LONG - Static variable in class java.util.Calendar
A style specifier for getDisplayName and getDisplayNames equivalent to Calendar.LONG_FORMAT.
LONG - Static variable in class java.util.TimeZone
A style specifier for getDisplayName() indicating a long name, such as "Pacific Standard Time."
LONG - Static variable in class javax.management.openmbean.SimpleType
The SimpleType instance describing values whose Java class name is java.lang.Long.
LONG_DESCRIPTION - Static variable in interface javax.swing.Action
The key used for storing a longer String description for the action, could be used for context-sensitive help.
LONG_FORMAT - Static variable in class java.util.Calendar
A style specifier for getDisplayName and getDisplayNames indicating a long name used for format.
LONG_STANDALONE - Static variable in class java.util.Calendar
A style specifier for getDisplayName and getDisplayNames indicating a long name used independently, such as a month name as calendar headers.
LongAccumulator - Class in java.util.concurrent.atomic
One or more variables that together maintain a running long value updated using a supplied function.
LongAccumulator(LongBinaryOperator, long) - Constructor for class java.util.concurrent.atomic.LongAccumulator
Creates a new instance using the given accumulator function and identity element.
LongAdder - Class in java.util.concurrent.atomic
One or more variables that together maintain an initially zero long sum.
LongAdder() - Constructor for class java.util.concurrent.atomic.LongAdder
Creates a new adder with initial sum of zero.
LongBinaryOperator - Interface in java.util.function
Represents an operation upon two long-valued operands and producing a long-valued result.
longBitsToDouble(long) - Static method in class java.lang.Double
Returns the double value corresponding to a given bit representation.
LongBuffer - Class in java.nio
A long buffer.
LongConsumer - Interface in java.util.function
Represents an operation that accepts a single long-valued argument and returns no result.
LongFunction<R> - Interface in java.util.function
Represents a function that accepts a long-valued argument and produces a result.
LongHolder - Class in org.omg.CORBA
The Holder for Long.
LongHolder() - Constructor for class org.omg.CORBA.LongHolder
Constructs a new LongHolder object with its value field initialized to 0.
LongHolder(long) - Constructor for class org.omg.CORBA.LongHolder
Constructs a new LongHolder object with its value field initialized to the given long.
LongLongSeqHelper - Class in org.omg.CORBA
The Helper for LongLongSeq.
LongLongSeqHelper() - Constructor for class org.omg.CORBA.LongLongSeqHelper
LongLongSeqHolder - Class in org.omg.CORBA
The Holder for LongLongSeq.
LongLongSeqHolder() - Constructor for class org.omg.CORBA.LongLongSeqHolder
LongLongSeqHolder(long[]) - Constructor for class org.omg.CORBA.LongLongSeqHolder
LONGNVARCHAR - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type LONGNVARCHAR.
LongPredicate - Interface in java.util.function
Represents a predicate (boolean-valued function) of one long-valued argument.
longs(long) - Method in class java.util.concurrent.ThreadLocalRandom
Returns a stream producing the given streamSize number of pseudorandom long values.
longs() - Method in class java.util.concurrent.ThreadLocalRandom
Returns an effectively unlimited stream of pseudorandom long values.
longs(long, long, long) - Method in class java.util.concurrent.ThreadLocalRandom
Returns a stream producing the given streamSize number of pseudorandom long, each conforming to the given origin (inclusive) and bound (exclusive).
longs(long, long) - Method in class java.util.concurrent.ThreadLocalRandom
Returns an effectively unlimited stream of pseudorandom long values, each conforming to the given origin (inclusive) and bound (exclusive).
longs(long) - Method in class java.util.Random
Returns a stream producing the given streamSize number of pseudorandom long values.
longs() - Method in class java.util.Random
Returns an effectively unlimited stream of pseudorandom long values.
longs(long, long, long) - Method in class java.util.Random
Returns a stream producing the given streamSize number of pseudorandom long, each conforming to the given origin (inclusive) and bound (exclusive).
longs(long, long) - Method in class java.util.Random
Returns an effectively unlimited stream of pseudorandom long values, each conforming to the given origin (inclusive) and bound (exclusive).
longs(long) - Method in class java.util.SplittableRandom
Returns a stream producing the given streamSize number of pseudorandom long values from this generator and/or one split from it.
longs() - Method in class java.util.SplittableRandom
Returns an effectively unlimited stream of pseudorandom long values from this generator and/or one split from it.
longs(long, long, long) - Method in class java.util.SplittableRandom
Returns a stream producing the given streamSize number of pseudorandom long values from this generator and/or one split from it; each value conforms to the given origin (inclusive) and bound (exclusive).
longs(long, long) - Method in class java.util.SplittableRandom
Returns an effectively unlimited stream of pseudorandom long values from this generator and/or one split from it; each value conforms to the given origin (inclusive) and bound (exclusive).
LongSeqHelper - Class in org.omg.CORBA
The Helper for LongSeqHelper.
LongSeqHelper() - Constructor for class org.omg.CORBA.LongSeqHelper
LongSeqHolder - Class in org.omg.CORBA
The Holder for LongSeq.
LongSeqHolder() - Constructor for class org.omg.CORBA.LongSeqHolder
LongSeqHolder(int[]) - Constructor for class org.omg.CORBA.LongSeqHolder
LongStream - Interface in java.util.stream
A sequence of primitive long-valued elements supporting sequential and parallel aggregate operations.
longStream(Spliterator.OfLong, boolean) - Static method in class java.util.stream.StreamSupport
Creates a new sequential or parallel LongStream from a Spliterator.OfLong.
longStream(Supplier<? extends Spliterator.OfLong>, int, boolean) - Static method in class java.util.stream.StreamSupport
Creates a new sequential or parallel LongStream from a Supplier of Spliterator.OfLong.
LongStream.Builder - Interface in java.util.stream
A mutable builder for a LongStream.
LongSummaryStatistics - Class in java.util
A state object for collecting statistics such as count, min, max, sum, and average.
LongSummaryStatistics() - Constructor for class java.util.LongSummaryStatistics
Construct an empty instance with zero count, zero sum, Long.MAX_VALUE min, Long.MIN_VALUE max and zero average.
LongSupplier - Interface in java.util.function
Represents a supplier of long-valued results.
LongToDoubleFunction - Interface in java.util.function
Represents a function that accepts a long-valued argument and produces a double-valued result.
LongToIntFunction - Interface in java.util.function
Represents a function that accepts a long-valued argument and produces an int-valued result.
LongUnaryOperator - Interface in java.util.function
Represents an operation on a single long-valued operand that produces a long-valued result.
longValue() - Method in class java.lang.Byte
Returns the value of this Byte as a long after a widening primitive conversion.
longValue() - Method in class java.lang.Double
Returns the value of this Double as a long after a narrowing primitive conversion.
longValue() - Method in class java.lang.Float
Returns value of this Float as a long after a narrowing primitive conversion.
longValue() - Method in class java.lang.Integer
Returns the value of this Integer as a long after a widening primitive conversion.
longValue() - Method in class java.lang.Long
Returns the value of this Long as a long value.
longValue() - Method in class java.lang.Number
Returns the value of the specified number as a long, which may involve rounding or truncation.
longValue() - Method in class java.lang.Short
Returns the value of this Short as a long after a widening primitive conversion.
longValue() - Method in class java.math.BigDecimal
Converts this BigDecimal to a long.
longValue() - Method in class java.math.BigInteger
Converts this BigInteger to a long.
longValue() - Method in class java.util.concurrent.atomic.AtomicInteger
Returns the value of this AtomicInteger as a long after a widening primitive conversion.
longValue() - Method in class java.util.concurrent.atomic.AtomicLong
Returns the value of this AtomicLong as a long.
longValue() - Method in class java.util.concurrent.atomic.DoubleAccumulator
Returns the current value as a long after a narrowing primitive conversion.
longValue() - Method in class java.util.concurrent.atomic.DoubleAdder
Returns the DoubleAdder.sum() as a long after a narrowing primitive conversion.
longValue() - Method in class java.util.concurrent.atomic.LongAccumulator
Equivalent to LongAccumulator.get().
longValue() - Method in class java.util.concurrent.atomic.LongAdder
Equivalent to LongAdder.sum().
longValueExact() - Method in class java.math.BigDecimal
Converts this BigDecimal to a long, checking for lost information.
longValueExact() - Method in class java.math.BigInteger
Converts this BigInteger to a long, checking for lost information.
LONGVARBINARY - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type LONGVARBINARY.
LONGVARCHAR - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type LONGVARCHAR.
LookAndFeel - Class in javax.swing
LookAndFeel, as the name implies, encapsulates a look and feel.
LookAndFeel() - Constructor for class javax.swing.LookAndFeel
LookAndFeelInfo(String, String) - Constructor for class javax.swing.UIManager.LookAndFeelInfo
Constructs a UIManagers LookAndFeelInfo object.
lookingAt() - Method in class java.util.regex.Matcher
Attempts to match the input sequence, starting at the beginning of the region, against the pattern.
lookup(Class<?>) - Static method in class java.io.ObjectStreamClass
Find the descriptor for a class that can be serialized.
lookup() - Static method in class java.lang.invoke.MethodHandles
Returns a lookup object with full capabilities to emulate all supported bytecode behaviors of the caller.
lookup(String) - Static method in class java.rmi.Naming
Returns a reference, a stub, for the remote object associated with the specified name.
lookup(String) - Method in interface java.rmi.registry.Registry
Returns the remote reference bound to the specified name in this registry.
lookup(List<Locale.LanguageRange>, Collection<Locale>) - Static method in class java.util.Locale
Returns a Locale instance for the best-matching language tag using the lookup mechanism defined in RFC 4647.
lookup(Name) - Method in interface javax.naming.Context
Retrieves the named object.
lookup(String) - Method in interface javax.naming.Context
Retrieves the named object.
lookup(String) - Method in class javax.naming.InitialContext
lookup(Name) - Method in class javax.naming.InitialContext
lookup_value_factory(String) - Method in class org.omg.CORBA_2_3.ORB
lookupAny(Class<?>) - Static method in class java.io.ObjectStreamClass
Returns the descriptor for any class, regardless of whether it implements Serializable.
lookupClass() - Method in class java.lang.invoke.MethodHandles.Lookup
Tells which class is performing the lookup.
lookupConstraints(Component) - Method in class java.awt.GridBagLayout
Retrieves the constraints for the specified component.
lookupDefaultPrintService() - Static method in class javax.print.PrintServiceLookup
Locates the default print service for this environment.
lookupLink(Name) - Method in interface javax.naming.Context
Retrieves the named object, following links except for the terminal atomic component of the name.
lookupLink(String) - Method in interface javax.naming.Context
Retrieves the named object, following links except for the terminal atomic component of the name.
lookupLink(String) - Method in class javax.naming.InitialContext
lookupLink(Name) - Method in class javax.naming.InitialContext
lookupModes() - Method in class java.lang.invoke.MethodHandles.Lookup
Tells which access-protection classes of members this lookup object can produce.
lookupMultiDocPrintServices(DocFlavor[], AttributeSet) - Static method in class javax.print.PrintServiceLookup
Locates MultiDoc print Services capable of printing MultiDocs containing all the specified doc flavors.
lookupNamespaceURI(String) - Method in class javax.imageio.metadata.IIOMetadataNode
This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
lookupNamespaceURI(String) - Method in interface org.w3c.dom.Node
Look up the namespace URI associated to the given prefix, starting from this node.
LookupOp - Class in java.awt.image
This class implements a lookup operation from the source to the destination.
LookupOp(LookupTable, RenderingHints) - Constructor for class java.awt.image.LookupOp
Constructs a LookupOp object given the lookup table and a RenderingHints object, which might be null.
lookupPixel(int[], int[]) - Method in class java.awt.image.ByteLookupTable
Returns an array of samples of a pixel, translated with the lookup table.
lookupPixel(byte[], byte[]) - Method in class java.awt.image.ByteLookupTable
Returns an array of samples of a pixel, translated with the lookup table.
lookupPixel(int[], int[]) - Method in class java.awt.image.LookupTable
Returns an int array of components for one pixel.
lookupPixel(int[], int[]) - Method in class java.awt.image.ShortLookupTable
Returns an array of samples of a pixel, translated with the lookup table.
lookupPixel(short[], short[]) - Method in class java.awt.image.ShortLookupTable
Returns an array of samples of a pixel, translated with the lookup table.
lookupPrefix(String) - Method in class javax.imageio.metadata.IIOMetadataNode
This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.
lookupPrefix(String) - Method in interface org.w3c.dom.Node
Look up the prefix associated to the given namespace URI, starting from this node.
lookupPrincipalByGroupName(String) - Method in class java.nio.file.attribute.UserPrincipalLookupService
Lookup a group principal by group name.
lookupPrincipalByName(String) - Method in class java.nio.file.attribute.UserPrincipalLookupService
Lookup a user principal by name.
lookupPrintServices() - Static method in class java.awt.print.PrinterJob
A convenience method which looks up 2D print services.
lookupPrintServices(DocFlavor, AttributeSet) - Static method in class javax.print.PrintServiceLookup
Locates print services capable of printing the specified DocFlavor.
lookupProviders(Class<T>, ClassLoader) - Static method in class javax.imageio.spi.ServiceRegistry
Searches for implementations of a particular service class using the given class loader.
lookupProviders(Class<T>) - Static method in class javax.imageio.spi.ServiceRegistry
Locates and incrementally instantiates the available providers of a given service using the context class loader.
lookupStreamPrintServiceFactories(DocFlavor, String) - Static method in class javax.print.StreamPrintServiceFactory
Locates factories for print services that can be used with a print job to output a stream of data in the format specified by outputMimeType.
lookupStreamPrintServices(String) - Static method in class java.awt.print.PrinterJob
A convenience method which locates factories for stream print services which can image 2D graphics.
LookupTable - Class in java.awt.image
This abstract class defines a lookup table object.
LookupTable(int, int) - Constructor for class java.awt.image.LookupTable
Constructs a new LookupTable from the number of components and an offset into the lookup table.
lookupTag(List<Locale.LanguageRange>, Collection<String>) - Static method in class java.util.Locale
Returns the best-matching language tag using the lookup mechanism defined in RFC 4647.
loop() - Method in interface java.applet.AudioClip
Starts playing this audio clip in a loop.
loop(int) - Method in interface javax.sound.sampled.Clip
Starts looping playback from the current position.
LOOP_CONTINUOUSLY - Static variable in interface javax.sound.midi.Sequencer
A value indicating that looping should continue indefinitely rather than complete after a specific number of loops.
LOOP_CONTINUOUSLY - Static variable in interface javax.sound.sampled.Clip
A value indicating that looping should continue indefinitely rather than complete after a specific number of loops.
LOST_FOCUS - Static variable in class java.awt.Event
A component lost the focus.
lostFocus(Event, Object) - Method in class java.awt.Component
Deprecated.
As of JDK version 1.1, replaced by processFocusEvent(FocusEvent).
lostOwnership(Clipboard, Transferable) - Method in interface java.awt.datatransfer.ClipboardOwner
Notifies this object that it is no longer the clipboard owner.
lostOwnership(Clipboard, Transferable) - Method in class java.awt.datatransfer.StringSelection
LOW_SURROGATES - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Low Surrogates" Unicode character block.
lower(E) - Method in class java.util.concurrent.ConcurrentSkipListSet
lower(E) - Method in interface java.util.NavigableSet
Returns the greatest element in this set strictly less than the given element, or null if there is no such element.
lower(E) - Method in class java.util.TreeSet
LOWER_LEADING_CORNER - Static variable in interface javax.swing.ScrollPaneConstants
Identifies the lower leading edge corner of the viewport.
LOWER_LEFT_CORNER - Static variable in interface javax.swing.ScrollPaneConstants
Identifies the lower left corner of the viewport.
LOWER_RIGHT_CORNER - Static variable in interface javax.swing.ScrollPaneConstants
Identifies the lower right corner of the viewport.
LOWER_TRAILING_CORNER - Static variable in interface javax.swing.ScrollPaneConstants
Identifies the lower trailing edge corner of the viewport.
LOWERCASE_LETTER - Static variable in class java.lang.Character
General category "Ll" in the Unicode specification.
lowerCaseMode(boolean) - Method in class java.io.StreamTokenizer
Determines whether or not word token are automatically lowercased.
LOWERED - Static variable in class javax.swing.border.BevelBorder
Lowered bevel type.
LOWERED - Static variable in class javax.swing.border.EtchedBorder
Lowered etched type.
lowerEntry(K) - Method in class java.util.concurrent.ConcurrentSkipListMap
Returns a key-value mapping associated with the greatest key strictly less than the given key, or null if there is no such key.
lowerEntry(K) - Method in interface java.util.NavigableMap
Returns a key-value mapping associated with the greatest key strictly less than the given key, or null if there is no such key.
lowerEntry(K) - Method in class java.util.TreeMap
lowerKey(K) - Method in class java.util.concurrent.ConcurrentSkipListMap
lowerKey(K) - Method in interface java.util.NavigableMap
Returns the greatest key strictly less than the given key, or null if there is no such key.
lowerKey(K) - Method in class java.util.TreeMap
lowerLeft - Variable in class javax.swing.JScrollPane
The component to display in the lower left corner.
lowerLeft - Variable in class javax.swing.ScrollPaneLayout
The component to display in the lower left corner.
lowerRight - Variable in class javax.swing.JScrollPane
The component to display in the lower right corner.
lowerRight - Variable in class javax.swing.ScrollPaneLayout
The component to display in the lower right corner.
lowestLayer() - Method in class javax.swing.JLayeredPane
Returns the lowest layer value from all current children.
lowestOneBit(int) - Static method in class java.lang.Integer
Returns an int value with at most a single one-bit, in the position of the lowest-order ("rightmost") one-bit in the specified int value.
lowestOneBit(long) - Static method in class java.lang.Long
Returns a long value with at most a single one-bit, in the position of the lowest-order ("rightmost") one-bit in the specified long value.
LOWSRC - Static variable in class javax.swing.text.html.HTML.Attribute
lowSurrogate(int) - Static method in class java.lang.Character
Returns the trailing surrogate (a low surrogate code unit) of the surrogate pair representing the specified supplementary character (Unicode code point) in the UTF-16 encoding.
LSException - Exception in org.w3c.dom.ls
Parser or write operations may throw an LSException if the processing is stopped.
LSException(short, String) - Constructor for exception org.w3c.dom.ls.LSException
LSInput - Interface in org.w3c.dom.ls
This interface represents an input source for data.
LSLoadEvent - Interface in org.w3c.dom.ls
This interface represents a load event object that signals the completion of a document load.
LSOutput - Interface in org.w3c.dom.ls
This interface represents an output destination for data.
LSParser - Interface in org.w3c.dom.ls
An interface to an object that is able to build, or augment, a DOM tree from various input sources.
LSParserFilter - Interface in org.w3c.dom.ls
LSParserFilters provide applications the ability to examine nodes as they are being constructed while parsing.
LSProgressEvent - Interface in org.w3c.dom.ls
This interface represents a progress event object that notifies the application about progress as a document is parsed.
LSResourceResolver - Interface in org.w3c.dom.ls
LSResourceResolver provides a way for applications to redirect references to external resources.
LSSerializer - Interface in org.w3c.dom.ls
A LSSerializer provides an API for serializing (writing) a DOM document out into XML.
LSSerializerFilter - Interface in org.w3c.dom.ls
LSSerializerFilters provide applications the ability to examine nodes as they are being serialized and decide what nodes should be serialized or not.
LT - Static variable in class javax.management.Query
A code representing the Query.lt(javax.management.ValueExp, javax.management.ValueExp) query.
lt(ValueExp, ValueExp) - Static method in class javax.management.Query
Returns a query expression that represents a "less than" constraint on two values.
lt(File, File) - Method in class javax.swing.plaf.basic.BasicDirectoryModel
LYCIAN - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Lycian" Unicode character block.
LYDIAN - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Lydian" Unicode character block.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames


M-Index (Java Platform SE 8 )

Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames
  • All Classes
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

M

Mac - Class in javax.crypto
This class provides the functionality of a "Message Authentication Code" (MAC) algorithm.
Mac(MacSpi, Provider, String) - Constructor for class javax.crypto.Mac
Creates a MAC object.
MacSpi - Class in javax.crypto
This class defines the Service Provider Interface (SPI) for the Mac class.
MacSpi() - Constructor for class javax.crypto.MacSpi
magenta - Static variable in class java.awt.Color
The color magenta.
MAGENTA - Static variable in class java.awt.Color
The color magenta.
MAHJONG_TILES - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Mahjong Tiles" Unicode character block.
mail() - Method in class java.awt.Desktop
Launches the mail composing window of the user default mail client.
mail(URI) - Method in class java.awt.Desktop
Launches the mail composing window of the user default mail client, filling the message fields specified by a mailto: URI.
MailcapCommandMap - Class in javax.activation
MailcapCommandMap extends the CommandMap abstract class.
MailcapCommandMap() - Constructor for class javax.activation.MailcapCommandMap
The default Constructor.
MailcapCommandMap(String) - Constructor for class javax.activation.MailcapCommandMap
Constructor that allows the caller to specify the path of a mailcap file.
MailcapCommandMap(InputStream) - Constructor for class javax.activation.MailcapCommandMap
Constructor that allows the caller to specify an InputStream containing a mailcap file.
MAIN - Static variable in class javax.print.attribute.standard.MediaTray
The main input tray in the printer.
MAIN_CLASS - Static variable in class java.util.jar.Attributes.Name
Name object for Main-Class manifest attribute used for launching applications packaged in JAR files.
MAIN_UIROLE - Static variable in class javax.print.ServiceUIFactory
Denotes a UI which performs the normal end user role.
major_version - Variable in class org.omg.IOP.Encoding
The major version of this Encoding format.
majorRequirementChange(AsyncBoxView.ChildState, float) - Method in class javax.swing.text.AsyncBoxView
Requirements changed along the major axis.
majorTickSpacing - Variable in class javax.swing.JSlider
The number of values between the major tick marks -- the larger marks that break up the minor tick marks.
make_object(String, byte[]) - Method in interface org.omg.PortableInterceptor.ObjectReferenceFactory
make_object creates a CORBA object reference according to the data in this template, with the given repository ID and object ID.
makeBounds(double, double, double, double) - Method in class java.awt.geom.Arc2D.Double
Constructs a Rectangle2D of the appropriate precision to hold the parameters calculated to be the framing rectangle of this arc.
makeBounds(double, double, double, double) - Method in class java.awt.geom.Arc2D.Float
Constructs a Rectangle2D of the appropriate precision to hold the parameters calculated to be the framing rectangle of this arc.
makeBounds(double, double, double, double) - Method in class java.awt.geom.Arc2D
Constructs a Rectangle2D of the appropriate precision to hold the parameters calculated to be the framing rectangle of this arc.
makeClient(String, Subject) - Method in class javax.management.remote.rmi.RMIIIOPServerImpl
Creates a new client connection as an RMI object exported through IIOP.
makeClient(String, Subject) - Method in class javax.management.remote.rmi.RMIJRMPServerImpl
Creates a new client connection as an RMI object exported through JRMP.
makeClient(String, Subject) - Method in class javax.management.remote.rmi.RMIServerImpl
Creates a new client connection.
makeComponentInputMap(JComponent, Object[]) - Static method in class javax.swing.LookAndFeel
Creates a ComponentInputMapUIResource from keys.
makeIcon(Class<?>, String) - Static method in class javax.swing.LookAndFeel
Creates and returns a UIDefault.LazyValue that loads an image.
makeInputMap(Object[]) - Static method in class javax.swing.LookAndFeel
Creates a InputMapUIResource from keys.
makeKeyBindings(Object[]) - Static method in class javax.swing.LookAndFeel
Convenience method for building an array of KeyBindings.
makeParser() - Static method in class org.xml.sax.helpers.ParserFactory
Deprecated.
Create a new SAX parser using the `org.xml.sax.parser' system property.
makeParser(String) - Static method in class org.xml.sax.helpers.ParserFactory
Deprecated.
Create a new SAX parser object using the class name provided.
makeTag(Element, boolean) - Method in class javax.swing.text.html.parser.Parser
Makes a TagElement.
makeTag(Element) - Method in class javax.swing.text.html.parser.Parser
makeVisible(int) - Method in class java.awt.List
Makes the item at the specified index visible.
makeVisible(TreePath) - Method in class javax.swing.JTree
Ensures that the node identified by path is currently viewable.
MALAYALAM - Static variable in class java.awt.font.NumericShaper
Identifies the MALAYALAM range and decimal base.
MALAYALAM - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Malayalam" Unicode character block.
malformedForLength(int) - Static method in class java.nio.charset.CoderResult
Static factory method that returns the unique object describing a malformed-input error of the given length.
malformedInputAction() - Method in class java.nio.charset.CharsetDecoder
Returns this decoder's current action for malformed-input errors.
malformedInputAction() - Method in class java.nio.charset.CharsetEncoder
Returns this encoder's current action for malformed-input errors.
MalformedInputException - Exception in java.nio.charset
Checked exception thrown when an input byte sequence is not legal for given charset, or an input character sequence is not a legal sixteen-bit Unicode sequence.
MalformedInputException(int) - Constructor for exception java.nio.charset.MalformedInputException
Constructs an MalformedInputException with the given length.
MalformedLinkException - Exception in javax.naming
This exception is thrown when a malformed link was encountered while resolving or constructing a link.
MalformedLinkException(String) - Constructor for exception javax.naming.MalformedLinkException
Constructs a new instance of MalformedLinkException with an explanation All the other fields are initialized to null.
MalformedLinkException() - Constructor for exception javax.naming.MalformedLinkException
Constructs a new instance of Malformed LinkException.
MalformedObjectNameException - Exception in javax.management
The format of the string does not correspond to a valid ObjectName.
MalformedObjectNameException() - Constructor for exception javax.management.MalformedObjectNameException
Default constructor.
MalformedObjectNameException(String) - Constructor for exception javax.management.MalformedObjectNameException
Constructor that allows a specific error message to be specified.
MalformedParameterizedTypeException - Exception in java.lang.reflect
Thrown when a semantically malformed parameterized type is encountered by a reflective method that needs to instantiate it.
MalformedParameterizedTypeException() - Constructor for exception java.lang.reflect.MalformedParameterizedTypeException
MalformedParametersException - Exception in java.lang.reflect
Thrown when the java.lang.reflect package attempts to read method parameters from a class file and determines that one or more parameters are malformed.
MalformedParametersException() - Constructor for exception java.lang.reflect.MalformedParametersException
Create a MalformedParametersException with an empty reason.
MalformedParametersException(String) - Constructor for exception java.lang.reflect.MalformedParametersException
Create a MalformedParametersException.
MalformedURLException - Exception in java.net
Thrown to indicate that a malformed URL has occurred.
MalformedURLException() - Constructor for exception java.net.MalformedURLException
Constructs a MalformedURLException with no detail message.
MalformedURLException(String) - Constructor for exception java.net.MalformedURLException
Constructs a MalformedURLException with the specified detail message.
managedBlock(ForkJoinPool.ManagedBlocker) - Static method in class java.util.concurrent.ForkJoinPool
Blocks in accord with the given blocker.
ManagementFactory - Class in java.lang.management
The ManagementFactory class is a factory class for getting managed beans for the Java platform.
ManagementPermission - Class in java.lang.management
The permission which the SecurityManager will check when code that is running with a SecurityManager calls methods defined in the management interface for the Java platform.
ManagementPermission(String) - Constructor for class java.lang.management.ManagementPermission
Constructs a ManagementPermission with the specified name.
ManagementPermission(String, String) - Constructor for class java.lang.management.ManagementPermission
Constructs a new ManagementPermission object.
manager_id() - Method in interface org.omg.PortableInterceptor.IORInfoOperations
Return the adapter manager id of the object adapter that was just created and is running IOR interceptors.
ManageReferralControl - Class in javax.naming.ldap
Requests that referral and other special LDAP objects be manipulated as normal LDAP objects.
ManageReferralControl() - Constructor for class javax.naming.ldap.ManageReferralControl
Constructs a critical ManageReferral control.
ManageReferralControl(boolean) - Constructor for class javax.naming.ldap.ManageReferralControl
Constructs a ManageReferral control.
ManagerFactoryParameters - Interface in javax.net.ssl
This class is the base interface for providing algorithm-specific information to a KeyManagerFactory or TrustManagerFactory.
MANAGES_DESCENDANTS - Static variable in class javax.accessibility.AccessibleState
Indicates this object is responsible for managing its subcomponents.
MANDAIC - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Mandaic" Unicode character block.
Manifest - Class in java.util.jar
The Manifest class is used to maintain Manifest entry names and their associated Attributes.
Manifest() - Constructor for class java.util.jar.Manifest
Constructs a new, empty Manifest.
Manifest(InputStream) - Constructor for class java.util.jar.Manifest
Constructs a new Manifest from the specified input stream.
Manifest(Manifest) - Constructor for class java.util.jar.Manifest
Constructs a new Manifest that is a copy of the specified Manifest.
Manifest - Interface in javax.xml.crypto.dsig
A representation of the XML Manifest element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
MANIFEST_NAME - Static variable in class java.util.jar.JarFile
The JAR manifest file name.
MANIFEST_VERSION - Static variable in class java.util.jar.Attributes.Name
Name object for Manifest-Version manifest attribute.
MANUAL - Static variable in class javax.print.attribute.standard.MediaTray
The manual feed input tray in the printer.
map(FileChannel.MapMode, long, long) - Method in class java.nio.channels.FileChannel
Maps a region of this channel's file directly into memory.
map - Variable in class java.util.jar.Attributes
The attribute name-value mappings.
Map<K,V> - Interface in java.util
An object that maps keys to values.
map(Function<? super T, ? extends U>) - Method in class java.util.Optional
If a value is present, apply the provided mapping function to it, and if the result is non-null, return an Optional describing the result.
map(DoubleUnaryOperator) - Method in interface java.util.stream.DoubleStream
Returns a stream consisting of the results of applying the given function to the elements of this stream.
map(IntUnaryOperator) - Method in interface java.util.stream.IntStream
Returns a stream consisting of the results of applying the given function to the elements of this stream.
map(LongUnaryOperator) - Method in interface java.util.stream.LongStream
Returns a stream consisting of the results of applying the given function to the elements of this stream.
map(Function<? super T, ? extends R>) - Method in interface java.util.stream.Stream
Returns a stream consisting of the results of applying the given function to the elements of this stream.
MAP - Static variable in class javax.swing.text.html.HTML.Tag
Map.Entry<K,V> - Interface in java.util
A map entry (key-value pair).
mapEquivalents(List<Locale.LanguageRange>, Map<String, List<String>>) - Static method in class java.util.Locale.LanguageRange
Generates a new customized Language Priority List using the given priorityList and map.
mapInputMethodHighlight(InputMethodHighlight) - Method in class java.awt.Toolkit
Returns a map of visual attributes for the abstract level description of the given input method highlight, or null if no mapping is found.
mapLibraryName(String) - Static method in class java.lang.System
Maps a library name into a platform-specific string representing a native library.
MappedByteBuffer - Class in java.nio
A direct byte buffer whose content is a memory-mapped region of a file.
mapping(Function<? super T, ? extends U>, Collector<? super U, A, R>) - Static method in class java.util.stream.Collectors
Adapts a Collector accepting elements of type U to one accepting elements of type T by applying a mapping function to each input element before accumulation.
mappingCount() - Method in class java.util.concurrent.ConcurrentHashMap
Returns the number of mappings.
mapRenderContext(int, RenderContext, ParameterBlock, RenderableImage) - Method in interface java.awt.image.renderable.ContextualRenderedImageFactory
Maps the operation's output RenderContext into a RenderContext for each of the operation's sources.
mapSystemException(SystemException) - Static method in class javax.rmi.CORBA.Util
Maps a SystemException to a RemoteException.
mapSystemException(SystemException) - Method in interface javax.rmi.CORBA.UtilDelegate
Delegation call for Util.mapSystemException(org.omg.CORBA.SystemException).
mapToDouble(IntToDoubleFunction) - Method in interface java.util.stream.IntStream
Returns a DoubleStream consisting of the results of applying the given function to the elements of this stream.
mapToDouble(LongToDoubleFunction) - Method in interface java.util.stream.LongStream
Returns a DoubleStream consisting of the results of applying the given function to the elements of this stream.
mapToDouble(ToDoubleFunction<? super T>) - Method in interface java.util.stream.Stream
Returns a DoubleStream consisting of the results of applying the given function to the elements of this stream.
mapToInt(DoubleToIntFunction) - Method in interface java.util.stream.DoubleStream
Returns an IntStream consisting of the results of applying the given function to the elements of this stream.
mapToInt(LongToIntFunction) - Method in interface java.util.stream.LongStream
Returns an IntStream consisting of the results of applying the given function to the elements of this stream.
mapToInt(ToIntFunction<? super T>) - Method in interface java.util.stream.Stream
Returns an IntStream consisting of the results of applying the given function to the elements of this stream.
mapToLong(DoubleToLongFunction) - Method in interface java.util.stream.DoubleStream
Returns a LongStream consisting of the results of applying the given function to the elements of this stream.
mapToLong(IntToLongFunction) - Method in interface java.util.stream.IntStream
Returns a LongStream consisting of the results of applying the given function to the elements of this stream.
mapToLong(ToLongFunction<? super T>) - Method in interface java.util.stream.Stream
Returns a LongStream consisting of the results of applying the given function to the elements of this stream.
mapToObj(DoubleFunction<? extends U>) - Method in interface java.util.stream.DoubleStream
Returns an object-valued Stream consisting of the results of applying the given function to the elements of this stream.
mapToObj(IntFunction<? extends U>) - Method in interface java.util.stream.IntStream
Returns an object-valued Stream consisting of the results of applying the given function to the elements of this stream.
mapToObj(LongFunction<? extends U>) - Method in interface java.util.stream.LongStream
Returns an object-valued Stream consisting of the results of applying the given function to the elements of this stream.
MARCH - Static variable in class java.util.Calendar
Value of the Calendar.MONTH field indicating the third month of the year in the Gregorian and Julian calendars.
MARCH - Static variable in class javax.xml.datatype.DatatypeConstants
Value for third month of year.
MARGIN - Static variable in class javax.swing.text.html.CSS.Attribute
MARGIN_BOTTOM - Static variable in class javax.swing.text.html.CSS.Attribute
MARGIN_CHANGED_PROPERTY - Static variable in class javax.swing.AbstractButton
Identifies a change in the button's margins.
MARGIN_LEFT - Static variable in class javax.swing.text.html.CSS.Attribute
MARGIN_RIGHT - Static variable in class javax.swing.text.html.CSS.Attribute
MARGIN_TOP - Static variable in class javax.swing.text.html.CSS.Attribute
MarginBorder() - Constructor for class javax.swing.plaf.basic.BasicBorders.MarginBorder
MARGINHEIGHT - Static variable in class javax.swing.text.html.HTML.Attribute
MARGINWIDTH - Static variable in class javax.swing.text.html.HTML.Attribute
mark(int) - Method in class java.io.BufferedInputStream
See the general contract of the mark method of InputStream.
mark(int) - Method in class java.io.BufferedReader
Marks the present position in the stream.
mark - Variable in class java.io.ByteArrayInputStream
The currently marked position in the stream.
mark(int) - Method in class java.io.ByteArrayInputStream
Set the current marked position in the stream.
mark(int) - Method in class java.io.CharArrayReader
Marks the present position in the stream.
mark(int) - Method in class java.io.FilterInputStream
Marks the current position in this input stream.
mark(int) - Method in class java.io.FilterReader
Marks the present position in the stream.
mark(int) - Method in class java.io.InputStream
Marks the current position in this input stream.
mark(int) - Method in class java.io.LineNumberInputStream
Deprecated.
Marks the current position in this input stream.
mark(int) - Method in class java.io.LineNumberReader
Mark the present position in the stream.
mark(int) - Method in class java.io.PushbackInputStream
Marks the current position in this input stream.
mark(int) - Method in class java.io.PushbackReader
Marks the present position in the stream.
mark(int) - Method in class java.io.Reader
Marks the present position in the stream.
mark(int) - Method in class java.io.StringReader
Marks the present position in the stream.
mark() - Method in class java.nio.Buffer
Sets this buffer's mark at its position.
mark(int) - Method in class java.util.zip.DeflaterInputStream
This operation is not supported.
mark(int) - Method in class java.util.zip.InflaterInputStream
Marks the current position in this input stream.
mark() - Method in interface javax.imageio.stream.ImageInputStream
Marks a position in the stream to be returned to by a subsequent call to reset.
mark() - Method in class javax.imageio.stream.ImageInputStreamImpl
Pushes the current stream position onto a stack of marked positions.
mark(int) - Method in class javax.sound.sampled.AudioInputStream
Marks the current position in this audio input stream.
markCompletelyClean(JComponent) - Method in class javax.swing.RepaintManager
Mark a component completely clean.
markCompletelyDirty(JComponent) - Method in class javax.swing.RepaintManager
Mark a component completely dirty.
markedPos - Variable in class java.io.CharArrayReader
The position of mark in buffer.
MARKER_SUPPLY_EMPTY - Static variable in class javax.print.attribute.standard.PrinterStateReason
The device is out of at least one marker supply (e.g.
MARKER_SUPPLY_LOW - Static variable in class javax.print.attribute.standard.PrinterStateReason
The device is low on at least one marker supply (e.g.
MARKER_WASTE_ALMOST_FULL - Static variable in class javax.print.attribute.standard.PrinterStateReason
The device marker supply waste receptacle is almost full.
MARKER_WASTE_FULL - Static variable in class javax.print.attribute.standard.PrinterStateReason
The device marker supply waste receptacle is full.
markFirstTime(Element) - Method in class javax.swing.text.html.parser.Parser
Marks the first time a tag has been seen in a document
marklimit - Variable in class java.io.BufferedInputStream
The maximum read ahead allowed after a call to the mark method before subsequent calls to the reset method fail.
markpos - Variable in class java.io.BufferedInputStream
The value of the pos field at the time the last mark method was called.
markSupported() - Method in class java.io.BufferedInputStream
Tests if this input stream supports the mark and reset methods.
markSupported() - Method in class java.io.BufferedReader
Tells whether this stream supports the mark() operation, which it does.
markSupported() - Method in class java.io.ByteArrayInputStream
Tests if this InputStream supports mark/reset.
markSupported() - Method in class java.io.CharArrayReader
Tells whether this stream supports the mark() operation, which it does.
markSupported() - Method in class java.io.FilterInputStream
Tests if this input stream supports the mark and reset methods.
markSupported() - Method in class java.io.FilterReader
Tells whether this stream supports the mark() operation.
markSupported() - Method in class java.io.InputStream
Tests if this input stream supports the mark and reset methods.
markSupported() - Method in class java.io.PushbackInputStream
Tests if this input stream supports the mark and reset methods, which it does not.
markSupported() - Method in class java.io.PushbackReader
Tells whether this stream supports the mark() operation, which it does not.
markSupported() - Method in class java.io.Reader
Tells whether this stream supports the mark() operation.
markSupported() - Method in class java.io.StringReader
Tells whether this stream supports the mark() operation, which it does.
markSupported() - Method in class java.util.zip.DeflaterInputStream
Always returns false because this input stream does not support the mark() and reset() methods.
markSupported() - Method in class java.util.zip.InflaterInputStream
Tests if this input stream supports the mark and reset methods.
markSupported() - Method in class javax.crypto.CipherInputStream
Tests if this input stream supports the mark and reset methods, which it does not.
markSupported() - Method in class javax.sound.sampled.AudioInputStream
Tests whether this audio input stream supports the mark and reset methods.
marshal(String) - Method in class javax.xml.bind.annotation.adapters.CollapsedStringAdapter
No-op.
marshal(byte[]) - Method in class javax.xml.bind.annotation.adapters.HexBinaryAdapter
marshal(String) - Method in class javax.xml.bind.annotation.adapters.NormalizedStringAdapter
No-op.
marshal(BoundType) - Method in class javax.xml.bind.annotation.adapters.XmlAdapter
Convert a bound type to a value type.
marshal(ElementT, ValidationEventHandler) - Method in interface javax.xml.bind.annotation.DomHandler
This method is called when a JAXB provider needs to marshal an element to XML.
marshal(Element, ValidationEventHandler) - Method in class javax.xml.bind.annotation.W3CDomHandler
marshal(Object, XmlNode) - Method in class javax.xml.bind.Binder
Marshal a JAXB object tree to a new XML document.
marshal(Object, OutputStream) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl
marshal(Object, File) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl
marshal(Object, Writer) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl
marshal(Object, ContentHandler) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl
marshal(Object, Node) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl
marshal(Object, XMLEventWriter) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl
marshal(Object, XMLStreamWriter) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl
marshal(Object, File) - Static method in class javax.xml.bind.JAXB
Writes a Java object tree to XML and store it to the specified location.
marshal(Object, URL) - Static method in class javax.xml.bind.JAXB
Writes a Java object tree to XML and store it to the specified location.
marshal(Object, URI) - Static method in class javax.xml.bind.JAXB
Writes a Java object tree to XML and store it to the specified location.
marshal(Object, String) - Static method in class javax.xml.bind.JAXB
Writes a Java object tree to XML and store it to the specified location.
marshal(Object, OutputStream) - Static method in class javax.xml.bind.JAXB
Writes a Java object tree to XML and store it to the specified location.
marshal(Object, Writer) - Static method in class javax.xml.bind.JAXB
Writes a Java object tree to XML and store it to the specified location.
marshal(Object, Result) - Static method in class javax.xml.bind.JAXB
Writes a Java object tree to XML and store it to the specified location.
marshal(Object, Result) - Method in interface javax.xml.bind.Marshaller
Marshal the content tree rooted at jaxbElement into the specified javax.xml.transform.Result.
marshal(Object, OutputStream) - Method in interface javax.xml.bind.Marshaller
Marshal the content tree rooted at jaxbElement into an output stream.
marshal(Object, File) - Method in interface javax.xml.bind.Marshaller
Marshal the content tree rooted at jaxbElement into a file.
marshal(Object, Writer) - Method in interface javax.xml.bind.Marshaller
Marshal the content tree rooted at jaxbElement into a Writer.
marshal(Object, ContentHandler) - Method in interface javax.xml.bind.Marshaller
Marshal the content tree rooted at jaxbElement into SAX2 events.
marshal(Object, Node) - Method in interface javax.xml.bind.Marshaller
Marshal the content tree rooted at jaxbElement into a DOM tree.
marshal(Object, XMLStreamWriter) - Method in interface javax.xml.bind.Marshaller
Marshal the content tree rooted at jaxbElement into a XMLStreamWriter.
marshal(Object, XMLEventWriter) - Method in interface javax.xml.bind.Marshaller
Marshal the content tree rooted at jaxbElement into a XMLEventWriter.
marshal(XMLStructure, XMLCryptoContext) - Method in interface javax.xml.crypto.dsig.keyinfo.KeyInfo
Marshals the key info to XML.
marshal(DataOutputStream) - Method in interface org.omg.CORBA.CustomMarshal
Marshal method has to be implemented by the Customized Marshal class.
MARSHAL - Exception in org.omg.CORBA
A request or reply from the network is structurally invalid.
MARSHAL() - Constructor for exception org.omg.CORBA.MARSHAL
Constructs a MARSHAL exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
MARSHAL(String) - Constructor for exception org.omg.CORBA.MARSHAL
Constructs a MARSHAL exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
MARSHAL(int, CompletionStatus) - Constructor for exception org.omg.CORBA.MARSHAL
Constructs a MARSHAL exception with the specified minor code and completion status.
MARSHAL(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.MARSHAL
Constructs a MARSHAL exception with the specified description message, minor code, and completion status.
MarshalException - Exception in java.rmi
A MarshalException is thrown if a java.io.IOException occurs while marshalling the remote call header, arguments or return value for a remote method call.
MarshalException(String) - Constructor for exception java.rmi.MarshalException
Constructs a MarshalException with the specified detail message.
MarshalException(String, Exception) - Constructor for exception java.rmi.MarshalException
Constructs a MarshalException with the specified detail message and nested exception.
MarshalException - Exception in javax.xml.bind
This exception indicates that an error has occurred while performing a marshal operation that the provider is unable to recover from.
MarshalException(String) - Constructor for exception javax.xml.bind.MarshalException
Construct a MarshalException with the specified detail message.
MarshalException(String, String) - Constructor for exception javax.xml.bind.MarshalException
Construct a MarshalException with the specified detail message and vendor specific errorCode.
MarshalException(Throwable) - Constructor for exception javax.xml.bind.MarshalException
Construct a MarshalException with a linkedException.
MarshalException(String, Throwable) - Constructor for exception javax.xml.bind.MarshalException
Construct a MarshalException with the specified detail message and linkedException.
MarshalException(String, String, Throwable) - Constructor for exception javax.xml.bind.MarshalException
Construct a MarshalException with the specified detail message, vendor specific errorCode, and linkedException.
MarshalException - Exception in javax.xml.crypto
Indicates an exceptional condition that occurred during the XML marshalling or unmarshalling process.
MarshalException() - Constructor for exception javax.xml.crypto.MarshalException
Constructs a new MarshalException with null as its detail message.
MarshalException(String) - Constructor for exception javax.xml.crypto.MarshalException
Constructs a new MarshalException with the specified detail message.
MarshalException(String, Throwable) - Constructor for exception javax.xml.crypto.MarshalException
Constructs a new MarshalException with the specified detail message and cause.
MarshalException(Throwable) - Constructor for exception javax.xml.crypto.MarshalException
Constructs a new MarshalException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
MarshalledObject<T> - Class in java.rmi
A MarshalledObject contains a byte stream with the serialized representation of an object given to its constructor.
MarshalledObject(T) - Constructor for class java.rmi.MarshalledObject
Creates a new MarshalledObject that contains the serialized representation of the current state of the supplied object.
Marshaller - Interface in javax.xml.bind
The Marshaller class is responsible for governing the process of serializing Java content trees back into XML data.
Marshaller.Listener - Class in javax.xml.bind

Register an instance of an implementation of this class with a Marshaller to externally listen for marshal events.

marshalParams(XMLStructure, XMLCryptoContext) - Method in class javax.xml.crypto.dsig.TransformService
Marshals the algorithm-specific parameters.
MaskFormatter - Class in javax.swing.text
MaskFormatter is used to format and edit strings.
MaskFormatter() - Constructor for class javax.swing.text.MaskFormatter
Creates a MaskFormatter with no mask.
MaskFormatter(String) - Constructor for class javax.swing.text.MaskFormatter
Creates a MaskFormatter with the specified mask.
MASTER_GAIN - Static variable in class javax.sound.sampled.FloatControl.Type
Represents a control for the overall gain on a line.
match(DataFlavor) - Method in class java.awt.datatransfer.DataFlavor
Identical to DataFlavor.equals(DataFlavor).
match(Certificate) - Method in interface java.security.cert.CertSelector
Decides whether a Certificate should be selected.
match(CRL) - Method in interface java.security.cert.CRLSelector
Decides whether a CRL should be selected.
match(Certificate) - Method in class java.security.cert.X509CertSelector
Decides whether a Certificate should be selected.
match(CRL) - Method in class java.security.cert.X509CRLSelector
Decides whether a CRL should be selected.
match() - Method in class java.util.Scanner
Returns the match result of the last scanning operation performed by this scanner.
match(MimeType) - Method in class javax.activation.MimeType
Determine if the primary and sub type of this object is the same as what is in the given type.
match(String) - Method in class javax.activation.MimeType
Determine if the primary and sub type of this object is the same as the content type described in rawdata.
match(AttributeValueExp, StringValueExp) - Static method in class javax.management.Query
Returns a query expression that represents a matching constraint on a string argument.
Matcher - Class in java.util.regex
An engine that performs match operations on a character sequence by interpreting a Pattern.
matcher(CharSequence) - Method in class java.util.regex.Pattern
Creates a matcher that will match the given input against this pattern.
matches(String) - Method in class java.lang.String
Tells whether or not this string matches the given regular expression.
matches(Path) - Method in interface java.nio.file.PathMatcher
Tells if given path matches this matcher's pattern.
matches() - Method in class java.util.regex.Matcher
Attempts to match the entire region against the pattern.
matches(String, CharSequence) - Static method in class java.util.regex.Pattern
Compiles the given regular expression and attempts to match the given input against it.
matches(SNIServerName) - Method in class javax.net.ssl.SNIMatcher
Attempts to match the given SNIServerName.
matches(AudioFormat) - Method in class javax.sound.sampled.AudioFormat
Indicates whether this format matches the one specified.
matches(Line.Info) - Method in class javax.sound.sampled.DataLine.Info
Determines whether the specified info object matches this one.
matches(Line.Info) - Method in class javax.sound.sampled.Line.Info
Indicates whether the specified info object matches this one.
matches(Line.Info) - Method in class javax.sound.sampled.Port.Info
Indicates whether this info object specified matches this one.
matchNameAttribute(AttributeSet, HTML.Tag) - Method in class javax.swing.text.html.HTMLWriter
Returns true if the StyleConstants.NameAttribute is equal to the tag that is passed in as a parameter.
MatchResult - Interface in java.util.regex
The result of a match operation.
Math - Class in java.lang
The class Math contains methods for performing basic numeric operations such as the elementary exponential, logarithm, square root, and trigonometric functions.
MATH_SYMBOL - Static variable in class java.lang.Character
General category "Sm" in the Unicode specification.
MathContext - Class in java.math
Immutable objects which encapsulate the context settings which describe certain rules for numerical operators, such as those implemented by the BigDecimal class.
MathContext(int) - Constructor for class java.math.MathContext
Constructs a new MathContext with the specified precision and the HALF_UP rounding mode.
MathContext(int, RoundingMode) - Constructor for class java.math.MathContext
Constructs a new MathContext with a specified precision and rounding mode.
MathContext(String) - Constructor for class java.math.MathContext
Constructs a new MathContext from a string.
MATHEMATICAL_ALPHANUMERIC_SYMBOLS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Mathematical Alphanumeric Symbols" Unicode character block.
MATHEMATICAL_OPERATORS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Mathematical Operators" Unicode character block.
MatteBorder - Class in javax.swing.border
A class which provides a matte-like border of either a solid color or a tiled icon.
MatteBorder(int, int, int, int, Color) - Constructor for class javax.swing.border.MatteBorder
Creates a matte border with the specified insets and color.
MatteBorder(Insets, Color) - Constructor for class javax.swing.border.MatteBorder
Creates a matte border with the specified insets and color.
MatteBorder(int, int, int, int, Icon) - Constructor for class javax.swing.border.MatteBorder
Creates a matte border with the specified insets and tile icon.
MatteBorder(Insets, Icon) - Constructor for class javax.swing.border.MatteBorder
Creates a matte border with the specified insets and tile icon.
MatteBorder(Icon) - Constructor for class javax.swing.border.MatteBorder
Creates a matte border with the specified tile icon.
MatteBorderUIResource(int, int, int, int, Color) - Constructor for class javax.swing.plaf.BorderUIResource.MatteBorderUIResource
MatteBorderUIResource(int, int, int, int, Icon) - Constructor for class javax.swing.plaf.BorderUIResource.MatteBorderUIResource
MatteBorderUIResource(Icon) - Constructor for class javax.swing.plaf.BorderUIResource.MatteBorderUIResource
max(double, double) - Static method in class java.lang.Double
Returns the greater of two double values as if by calling Math.max.
max(float, float) - Static method in class java.lang.Float
Returns the greater of two float values as if by calling Math.max.
max(int, int) - Static method in class java.lang.Integer
Returns the greater of two int values as if by calling Math.max.
max(long, long) - Static method in class java.lang.Long
Returns the greater of two long values as if by calling Math.max.
max(int, int) - Static method in class java.lang.Math
Returns the greater of two int values.
max(long, long) - Static method in class java.lang.Math
Returns the greater of two long values.
max(float, float) - Static method in class java.lang.Math
Returns the greater of two float values.
max(double, double) - Static method in class java.lang.Math
Returns the greater of two double values.
max(int, int) - Static method in class java.lang.StrictMath
Returns the greater of two int values.
max(long, long) - Static method in class java.lang.StrictMath
Returns the greater of two long values.
max(float, float) - Static method in class java.lang.StrictMath
Returns the greater of two float values.
max(double, double) - Static method in class java.lang.StrictMath
Returns the greater of two double values.
max(BigDecimal) - Method in class java.math.BigDecimal
Returns the maximum of this BigDecimal and val.
max(BigInteger) - Method in class java.math.BigInteger
Returns the maximum of this BigInteger and val.
MAX - Static variable in class java.time.Instant
The maximum supported Instant, '1000000000-12-31T23:59:59.999999999Z'.
MAX - Static variable in class java.time.LocalDate
The maximum supported LocalDate, '+999999999-12-31'.
MAX - Static variable in class java.time.LocalDateTime
The maximum supported LocalDateTime, '+999999999-12-31T23:59:59.999999999'.
MAX - Static variable in class java.time.LocalTime
The maximum supported LocalTime, '23:59:59.999999999'.
MAX - Static variable in class java.time.OffsetDateTime
The maximum supported OffsetDateTime, '+999999999-12-31T23:59:59.999999999-18:00'.
MAX - Static variable in class java.time.OffsetTime
The maximum supported OffsetTime, '23:59:59.999999999-18:00'.
MAX - Static variable in class java.time.ZoneOffset
Constant for the maximum supported offset.
max(Collection<? extends T>) - Static method in class java.util.Collections
Returns the maximum element of the given collection, according to the natural ordering of its elements.
max(Collection<? extends T>, Comparator<? super T>) - Static method in class java.util.Collections
Returns the maximum element of the given collection, according to the order induced by the specified comparator.
max() - Method in interface java.util.stream.DoubleStream
Returns an OptionalDouble describing the maximum element of this stream, or an empty OptionalDouble if this stream is empty.
max() - Method in interface java.util.stream.IntStream
Returns an OptionalInt describing the maximum element of this stream, or an empty optional if this stream is empty.
max() - Method in interface java.util.stream.LongStream
Returns an OptionalLong describing the maximum element of this stream, or an empty optional if this stream is empty.
max(Comparator<? super T>) - Method in interface java.util.stream.Stream
Returns the maximum element of this stream according to the provided Comparator.
max(Spring, Spring) - Static method in class javax.swing.Spring
Returns max(s1, s2): a spring whose value is always greater than (or equal to) the values of both s1 and s2.
MAX_BUFFER - Static variable in class javax.security.sasl.Sasl
The name of a property that specifies the maximum size of the receive buffer in bytes of SaslClient/SaslServer.
MAX_CODE_POINT - Static variable in class java.lang.Character
The maximum value of a Unicode code point, constant U+10FFFF.
MAX_COUNT - Static variable in class javax.swing.plaf.synth.ColorType
Maximum number of ColorTypes.
MAX_EXPONENT - Static variable in class java.lang.Double
Maximum exponent a finite double variable may have.
MAX_EXPONENT - Static variable in class java.lang.Float
Maximum exponent a finite float variable may have.
MAX_HIGH_SURROGATE - Static variable in class java.lang.Character
The maximum value of a Unicode high-surrogate code unit in the UTF-16 encoding, constant '\uDBFF'.
MAX_KEY_LENGTH - Static variable in class java.util.prefs.Preferences
Maximum length of string allowed as a key (80 characters).
MAX_LOW_SURROGATE - Static variable in class java.lang.Character
The maximum value of a Unicode low-surrogate code unit in the UTF-16 encoding, constant '\uDFFF'.
MAX_NAME_LENGTH - Static variable in class java.util.prefs.Preferences
Maximum length of a node name (80 characters).
MAX_PRIORITY - Static variable in class java.lang.Thread
The maximum priority that a thread can have.
MAX_RADIX - Static variable in class java.lang.Character
The maximum radix available for conversion to and from strings.
MAX_SCROLL - Static variable in class javax.swing.plaf.basic.BasicSliderUI
MAX_SURROGATE - Static variable in class java.lang.Character
The maximum value of a Unicode surrogate code unit in the UTF-16 encoding, constant '\uDFFF'.
MAX_TIMEZONE_OFFSET - Static variable in class javax.xml.datatype.DatatypeConstants
W3C XML Schema max timezone offset is -14:00.
MAX_VALUE - Static variable in class java.lang.Byte
A constant holding the maximum value a byte can have, 27-1.
MAX_VALUE - Static variable in class java.lang.Character
The constant value of this field is the largest value of type char, '\uFFFF'.
MAX_VALUE - Static variable in class java.lang.Double
A constant holding the largest positive finite value of type double, (2-2-52)·21023.
MAX_VALUE - Static variable in class java.lang.Float
A constant holding the largest positive finite value of type float, (2-2-23)·2127.
MAX_VALUE - Static variable in class java.lang.Integer
A constant holding the maximum value an int can have, 231-1.
MAX_VALUE - Static variable in class java.lang.Long
A constant holding the maximum value a long can have, 263-1.
MAX_VALUE - Static variable in class java.lang.Short
A constant holding the maximum value a short can have, 215-1.
MAX_VALUE - Static variable in class java.time.Year
The maximum supported year, '+999,999,999'.
MAX_VALUE_FIELD - Static variable in class javax.management.JMX
The name of the maxValue field.
MAX_VALUE_LENGTH - Static variable in class java.util.prefs.Preferences
Maximum length of string allowed as a value (8192 characters).
MAX_WEIGHT - Static variable in class java.util.Locale.LanguageRange
A constant holding the maximum value of weight, 1.0, which indicates that the language range is a good fit for the user.
MAXBQUALSIZE - Static variable in interface javax.transaction.xa.Xid
Maximum number of bytes returned by getBqual.
maxButton - Variable in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
maxBy(Comparator<? super T>) - Static method in interface java.util.function.BinaryOperator
Returns a BinaryOperator which returns the greater of two elements according to the specified Comparator.
maxBy(Comparator<? super T>) - Static method in class java.util.stream.Collectors
Returns a Collector that produces the maximal element according to a given Comparator, described as an Optional<T>.
maxBytesPerChar() - Method in class java.nio.charset.CharsetEncoder
Returns the maximum number of bytes that will be produced for each character of input.
maxCharsPerByte() - Method in class java.nio.charset.CharsetDecoder
Returns the maximum number of characters that will be produced for each byte of input.
MAXGRIDSIZE - Static variable in class java.awt.GridBagLayout
This field is no longer used to reserve arrays and kept for backward compatibility.
MAXGTRIDSIZE - Static variable in interface javax.transaction.xa.Xid
Maximum number of bytes returned by getGtrid.
maxIcon - Variable in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
maximizable - Variable in class javax.swing.JInternalFrame
The frame can be expanded to the size of the desktop pane.
MAXIMIZE_CMD - Static variable in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
MaximizeAction() - Constructor for class javax.swing.plaf.basic.BasicDesktopPaneUI.MaximizeAction
maximizeAction - Variable in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
MaximizeAction() - Constructor for class javax.swing.plaf.basic.BasicInternalFrameTitlePane.MaximizeAction
MAXIMIZED_BOTH - Static variable in class java.awt.Frame
This state bit mask indicates that frame is fully maximized (that is both horizontally and vertically).
MAXIMIZED_HORIZ - Static variable in class java.awt.Frame
This state bit indicates that frame is maximized in the horizontal direction.
MAXIMIZED_VERT - Static variable in class java.awt.Frame
This state bit indicates that frame is maximized in the vertical direction.
maximizeFrame(JInternalFrame) - Method in class javax.swing.DefaultDesktopManager
Resizes the frame to fill its parents bounds.
maximizeFrame(JInternalFrame) - Method in interface javax.swing.DesktopManager
Generally, the frame should be resized to match it's parents bounds.
maximizeFrame(JInternalFrame) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
This method is called when the user wants to maximize the frame.
maximizeKey - Variable in class javax.swing.plaf.basic.BasicDesktopPaneUI
Deprecated.
As of 1.3.
maximum - Variable in class javax.swing.SizeRequirements
The maximum size allowed.
maximumLayoutSize(Container) - Method in class java.awt.BorderLayout
Returns the maximum dimensions for this layout given the components in the specified target container.
maximumLayoutSize(Container) - Method in class java.awt.CardLayout
Returns the maximum dimensions for this layout given the components in the specified target container.
maximumLayoutSize(Container) - Method in class java.awt.GridBagLayout
Returns the maximum dimensions for this layout given the components in the specified target container.
maximumLayoutSize(Container) - Method in interface java.awt.LayoutManager2
Calculates the maximum size dimensions for the specified container, given the components it contains.
maximumLayoutSize(Container) - Method in class javax.swing.BoxLayout
Returns the maximum dimensions the target container can use to lay out the components it contains.
maximumLayoutSize(Container) - Method in class javax.swing.GroupLayout
Returns the maximum size for the specified container.
maximumLayoutSize(Container) - Method in class javax.swing.JRootPane.RootLayout
Returns the maximum amount of space the layout can use.
maximumLayoutSize(Container) - Method in class javax.swing.OverlayLayout
Returns the maximum dimensions needed to lay out the components contained in the specified target container.
maximumLayoutSize(Container) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager
Returns the maximum layout size, which is Integer.MAX_VALUE in both directions.
maximumLayoutSize(Container) - Method in class javax.swing.SpringLayout
maximumRowCount - Variable in class javax.swing.JComboBox
This protected field is implementation specific.
maximumThumbSize - Variable in class javax.swing.plaf.basic.BasicScrollBarUI
maxLength() - Method in enum java.time.Month
Gets the maximum length of this month in days.
MAXLENGTH - Static variable in class javax.swing.text.html.HTML.Attribute
maxMemory() - Method in class java.lang.Runtime
Returns the maximum amount of memory that the Java virtual machine will attempt to use.
maxTabHeight - Variable in class javax.swing.plaf.basic.BasicTabbedPaneUI
maxTabWidth - Variable in class javax.swing.plaf.basic.BasicTabbedPaneUI
maxWidth - Variable in class javax.swing.table.TableColumn
The maximum width of the column.
MAY - Static variable in class java.util.Calendar
Value of the Calendar.MONTH field indicating the fifth month of the year in the Gregorian and Julian calendars.
MAY - Static variable in class javax.xml.datatype.DatatypeConstants
Value for fifth month of year.
maybeUpdateLayoutState() - Method in class javax.swing.plaf.basic.BasicListUI
If updateLayoutStateNeeded is non zero, call updateLayoutState() and reset updateLayoutStateNeeded.
MBeanAttributeInfo - Class in javax.management
Describes an MBean attribute exposed for management.
MBeanAttributeInfo(String, String, String, boolean, boolean, boolean) - Constructor for class javax.management.MBeanAttributeInfo
Constructs an MBeanAttributeInfo object.
MBeanAttributeInfo(String, String, String, boolean, boolean, boolean, Descriptor) - Constructor for class javax.management.MBeanAttributeInfo
Constructs an MBeanAttributeInfo object.
MBeanAttributeInfo(String, String, Method, Method) - Constructor for class javax.management.MBeanAttributeInfo
This constructor takes the name of a simple attribute, and Method objects for reading and writing the attribute.
MBeanConstructorInfo - Class in javax.management
Describes a constructor exposed by an MBean.
MBeanConstructorInfo(String, Constructor<?>) - Constructor for class javax.management.MBeanConstructorInfo
Constructs an MBeanConstructorInfo object.
MBeanConstructorInfo(String, String, MBeanParameterInfo[]) - Constructor for class javax.management.MBeanConstructorInfo
Constructs an MBeanConstructorInfo object.
MBeanConstructorInfo(String, String, MBeanParameterInfo[], Descriptor) - Constructor for class javax.management.MBeanConstructorInfo
Constructs an MBeanConstructorInfo object.
MBeanException - Exception in javax.management
Represents "user defined" exceptions thrown by MBean methods in the agent.
MBeanException(Exception) - Constructor for exception javax.management.MBeanException
Creates an MBeanException that wraps the actual java.lang.Exception.
MBeanException(Exception, String) - Constructor for exception javax.management.MBeanException
Creates an MBeanException that wraps the actual java.lang.Exception with a detail message.
MBeanFeatureInfo - Class in javax.management
Provides general information for an MBean descriptor object.
MBeanFeatureInfo(String, String) - Constructor for class javax.management.MBeanFeatureInfo
Constructs an MBeanFeatureInfo object.
MBeanFeatureInfo(String, String, Descriptor) - Constructor for class javax.management.MBeanFeatureInfo
Constructs an MBeanFeatureInfo object.
MBeanInfo - Class in javax.management
Describes the management interface exposed by an MBean; that is, the set of attributes and operations which are available for management operations.
MBeanInfo(String, String, MBeanAttributeInfo[], MBeanConstructorInfo[], MBeanOperationInfo[], MBeanNotificationInfo[]) - Constructor for class javax.management.MBeanInfo
Constructs an MBeanInfo.
MBeanInfo(String, String, MBeanAttributeInfo[], MBeanConstructorInfo[], MBeanOperationInfo[], MBeanNotificationInfo[], Descriptor) - Constructor for class javax.management.MBeanInfo
Constructs an MBeanInfo.
MBeanNotificationInfo - Class in javax.management
The MBeanNotificationInfo class is used to describe the characteristics of the different notification instances emitted by an MBean, for a given Java class of notification.
MBeanNotificationInfo(String[], String, String) - Constructor for class javax.management.MBeanNotificationInfo
Constructs an MBeanNotificationInfo object.
MBeanNotificationInfo(String[], String, String, Descriptor) - Constructor for class javax.management.MBeanNotificationInfo
Constructs an MBeanNotificationInfo object.
MBeanOperationInfo - Class in javax.management
Describes a management operation exposed by an MBean.
MBeanOperationInfo(String, Method) - Constructor for class javax.management.MBeanOperationInfo
Constructs an MBeanOperationInfo object.
MBeanOperationInfo(String, String, MBeanParameterInfo[], String, int) - Constructor for class javax.management.MBeanOperationInfo
Constructs an MBeanOperationInfo object.
MBeanOperationInfo(String, String, MBeanParameterInfo[], String, int, Descriptor) - Constructor for class javax.management.MBeanOperationInfo
Constructs an MBeanOperationInfo object.
MBeanParameterInfo - Class in javax.management
Describes an argument of an operation exposed by an MBean.
MBeanParameterInfo(String, String, String) - Constructor for class javax.management.MBeanParameterInfo
Constructs an MBeanParameterInfo object.
MBeanParameterInfo(String, String, String, Descriptor) - Constructor for class javax.management.MBeanParameterInfo
Constructs an MBeanParameterInfo object.
MBeanPermission - Class in javax.management
Permission controlling access to MBeanServer operations.
MBeanPermission(String, String) - Constructor for class javax.management.MBeanPermission
Create a new MBeanPermission object with the specified target name and actions.
MBeanPermission(String, String, ObjectName, String) - Constructor for class javax.management.MBeanPermission
Create a new MBeanPermission object with the specified target name (class name, member, object name) and actions.
MBeanRegistration - Interface in javax.management
Can be implemented by an MBean in order to carry out operations before and after being registered or unregistered from the MBean Server.
MBeanRegistrationException - Exception in javax.management
Wraps exceptions thrown by the preRegister(), preDeregister() methods of the MBeanRegistration interface.
MBeanRegistrationException(Exception) - Constructor for exception javax.management.MBeanRegistrationException
Creates an MBeanRegistrationException that wraps the actual java.lang.Exception.
MBeanRegistrationException(Exception, String) - Constructor for exception javax.management.MBeanRegistrationException
Creates an MBeanRegistrationException that wraps the actual java.lang.Exception with a detailed message.
MBeanServer - Interface in javax.management
This is the interface for MBean manipulation on the agent side.
MBeanServerBuilder - Class in javax.management
This class represents a builder that creates a default MBeanServer implementation.
MBeanServerBuilder() - Constructor for class javax.management.MBeanServerBuilder
Public default constructor.
MBeanServerConnection - Interface in javax.management
This interface represents a way to talk to an MBean server, whether local or remote.
MBeanServerDelegate - Class in javax.management
Represents the MBean server from the management point of view.
MBeanServerDelegate() - Constructor for class javax.management.MBeanServerDelegate
Create a MBeanServerDelegate object.
MBeanServerDelegateMBean - Interface in javax.management
Defines the management interface of an object of class MBeanServerDelegate.
MBeanServerFactory - Class in javax.management
Provides MBean server references.
MBeanServerForwarder - Interface in javax.management.remote
An object of this class implements the MBeanServer interface and wraps another object that also implements that interface.
MBeanServerInvocationHandler - Class in javax.management
InvocationHandler that forwards methods in an MBean's management interface through the MBean server to the MBean.
MBeanServerInvocationHandler(MBeanServerConnection, ObjectName) - Constructor for class javax.management.MBeanServerInvocationHandler
Invocation handler that forwards methods through an MBean server to a Standard MBean.
MBeanServerInvocationHandler(MBeanServerConnection, ObjectName, boolean) - Constructor for class javax.management.MBeanServerInvocationHandler
Invocation handler that can forward methods through an MBean server to a Standard MBean or MXBean.
MBeanServerNotification - Class in javax.management
Represents a notification emitted by the MBean Server through the MBeanServerDelegate MBean.
MBeanServerNotification(String, Object, long, ObjectName) - Constructor for class javax.management.MBeanServerNotification
Creates an MBeanServerNotification object specifying object names of the MBeans that caused the notification and the specified notification type.
MBeanServerNotificationFilter - Class in javax.management.relation
Filter for MBeanServerNotification.
MBeanServerNotificationFilter() - Constructor for class javax.management.relation.MBeanServerNotificationFilter
Creates a filter selecting all MBeanServerNotification notifications for all ObjectNames.
MBeanServerPermission - Class in javax.management
A Permission to perform actions related to MBeanServers.
MBeanServerPermission(String) - Constructor for class javax.management.MBeanServerPermission
Create a new MBeanServerPermission with the given name.
MBeanServerPermission(String, String) - Constructor for class javax.management.MBeanServerPermission
Create a new MBeanServerPermission with the given name.
MBeanTrustPermission - Class in javax.management
This permission represents "trust" in a signer or codebase.
MBeanTrustPermission(String) - Constructor for class javax.management.MBeanTrustPermission
Create a new MBeanTrustPermission with the given name.
MBeanTrustPermission(String, String) - Constructor for class javax.management.MBeanTrustPermission
Create a new MBeanTrustPermission with the given name.
MD - Static variable in interface javax.swing.text.html.parser.DTDConstants
Media - Class in javax.print.attribute.standard
Class Media is a printing attribute class that specifies the medium on which to print.
Media(int) - Constructor for class javax.print.attribute.standard.Media
Constructs a new media attribute specified by name.
MEDIA_EMPTY - Static variable in class javax.print.attribute.standard.PrinterStateReason
At least one input tray is empty.
MEDIA_JAM - Static variable in class javax.print.attribute.standard.PrinterStateReason
The device has a media jam.
MEDIA_LOW - Static variable in class javax.print.attribute.standard.PrinterStateReason
At least one input tray is low on media.
MEDIA_NEEDED - Static variable in class javax.print.attribute.standard.PrinterStateReason
A tray has run out of media.
MEDIA_TYPE - Static variable in class javax.xml.transform.OutputKeys
media-type = string.
MediaName - Class in javax.print.attribute.standard
Class MediaName is a subclass of Media, a printing attribute class (an enumeration) that specifies the media for a print job as a name.
MediaName(int) - Constructor for class javax.print.attribute.standard.MediaName
Constructs a new media name enumeration value with the given integer value.
MediaPrintableArea - Class in javax.print.attribute.standard
Class MediaPrintableArea is a printing attribute used to distinguish the printable and non-printable areas of media.
MediaPrintableArea(float, float, float, float, int) - Constructor for class javax.print.attribute.standard.MediaPrintableArea
Constructs a MediaPrintableArea object from floating point values.
MediaPrintableArea(int, int, int, int, int) - Constructor for class javax.print.attribute.standard.MediaPrintableArea
Constructs a MediaPrintableArea object from integer values.
MediaSize - Class in javax.print.attribute.standard
Class MediaSize is a two-dimensional size valued printing attribute class that indicates the dimensions of the medium in a portrait orientation, with the X dimension running along the bottom edge and the Y dimension running along the left edge.
MediaSize(float, float, int) - Constructor for class javax.print.attribute.standard.MediaSize
Construct a new media size attribute from the given floating-point values.
MediaSize(int, int, int) - Constructor for class javax.print.attribute.standard.MediaSize
Construct a new media size attribute from the given integer values.
MediaSize(float, float, int, MediaSizeName) - Constructor for class javax.print.attribute.standard.MediaSize
Construct a new media size attribute from the given floating-point values.
MediaSize(int, int, int, MediaSizeName) - Constructor for class javax.print.attribute.standard.MediaSize
Construct a new media size attribute from the given integer values.
MediaSize.Engineering - Class in javax.print.attribute.standard
Class MediaSize.Engineering includes MediaSize values for engineering media.
MediaSize.ISO - Class in javax.print.attribute.standard
Class MediaSize.ISO includes MediaSize values for ISO media.
MediaSize.JIS - Class in javax.print.attribute.standard
Class MediaSize.JIS includes MediaSize values for JIS (Japanese) media.
MediaSize.NA - Class in javax.print.attribute.standard
Class MediaSize.NA includes MediaSize values for North American media.
MediaSize.Other - Class in javax.print.attribute.standard
Class MediaSize.Other includes MediaSize values for miscellaneous media.
MediaSizeName - Class in javax.print.attribute.standard
Class MediaSizeName is a subclass of Media.
MediaSizeName(int) - Constructor for class javax.print.attribute.standard.MediaSizeName
Construct a new media size enumeration value with the given integer value.
MediaTracker - Class in java.awt
The MediaTracker class is a utility class to track the status of a number of media objects.
MediaTracker(Component) - Constructor for class java.awt.MediaTracker
Creates a media tracker to track images for a given component.
MediaTray - Class in javax.print.attribute.standard
Class MediaTray is a subclass of Media.
MediaTray(int) - Constructor for class javax.print.attribute.standard.MediaTray
Construct a new media tray enumeration value with the given integer value.
MEDIUM - Static variable in class java.text.DateFormat
Constant for medium style pattern.
MEETEI_MAYEK - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Meetei Mayek" Unicode character block.
MEETEI_MAYEK_EXTENSIONS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Meetei Mayek Extensions" Unicode character block.
MEIJI - Static variable in class java.time.chrono.JapaneseEra
The singleton instance for the 'Meiji' era (1868-01-01 - 1912-07-29) which has the value -1.
Member - Interface in java.lang.reflect
Member is an interface that reflects identifying information about a single member (a field or a method) or a constructor.
member() - Method in interface org.omg.CORBA.DynUnion
Deprecated.
Returns a DynAny object reference that is used in order to insert/get a member of this union.
member() - Method in class org.omg.DynamicAny._DynUnionStub
Returns the currently active member.
member() - Method in interface org.omg.DynamicAny.DynUnionOperations
Returns the currently active member.
member_count() - Method in class org.omg.CORBA.TypeCode
Retrieves the number of members in the type described by this TypeCode object.
member_kind() - Method in interface org.omg.CORBA.DynUnion
Deprecated.
Returns the TCKind associated with the member of this union.
member_kind() - Method in class org.omg.DynamicAny._DynUnionStub
Returns the TCKind value of the currently active members TypeCode.
member_kind() - Method in interface org.omg.DynamicAny.DynUnionOperations
Returns the TCKind value of the currently active members TypeCode.
member_label(int) - Method in class org.omg.CORBA.TypeCode
Retrieves the label of the union member identified by the given index.
member_name() - Method in interface org.omg.CORBA.DynUnion
Deprecated.
Allows for the inspection of the name of this union member without checking the value of the discriminator.
member_name(String) - Method in interface org.omg.CORBA.DynUnion
Deprecated.
Allows for the assignment of the name of this union member.
member_name(int) - Method in class org.omg.CORBA.TypeCode
Retrieves the simple name of the member identified by the given index.
member_name() - Method in class org.omg.DynamicAny._DynUnionStub
Returns the name of the currently active member.
member_name() - Method in interface org.omg.DynamicAny.DynUnionOperations
Returns the name of the currently active member.
MEMBER_OF - Static variable in class javax.accessibility.AccessibleRelation
Indicates an object is a member of a group of one or more target objects.
MEMBER_OF_PROPERTY - Static variable in class javax.accessibility.AccessibleRelation
Identifies that group membership has changed.
member_type(int) - Method in class org.omg.CORBA.TypeCode
Retrieves the TypeCode object describing the type of the member identified by the given index.
member_visibility(int) - Method in class org.omg.CORBA.TypeCode
Returns the constant that indicates the visibility of the member at the given index.
members() - Method in interface java.security.acl.Group
Returns an enumeration of the members in the group.
MembershipKey - Class in java.nio.channels
A token representing the membership of an Internet Protocol (IP) multicast group.
MembershipKey() - Constructor for class java.nio.channels.MembershipKey
Initializes a new instance of this class.
MEMORY_COLLECTION_THRESHOLD_EXCEEDED - Static variable in class java.lang.management.MemoryNotificationInfo
Notification type denoting that the memory usage of a memory pool is greater than or equal to its collection usage threshold after the Java virtual machine has expended effort in recycling unused objects in that memory pool.
MEMORY_MANAGER_MXBEAN_DOMAIN_TYPE - Static variable in class java.lang.management.ManagementFactory
The domain name and the type key property in the ObjectName for a MemoryManagerMXBean.
MEMORY_MXBEAN_NAME - Static variable in class java.lang.management.ManagementFactory
String representation of the ObjectName for the MemoryMXBean.
MEMORY_POOL_MXBEAN_DOMAIN_TYPE - Static variable in class java.lang.management.ManagementFactory
The domain name and the type key property in the ObjectName for a MemoryPoolMXBean.
MEMORY_THRESHOLD_EXCEEDED - Static variable in class java.lang.management.MemoryNotificationInfo
Notification type denoting that the memory usage of a memory pool has reached or exceeded its usage threshold value.
MemoryCacheImageInputStream - Class in javax.imageio.stream
An implementation of ImageInputStream that gets its input from a regular InputStream.
MemoryCacheImageInputStream(InputStream) - Constructor for class javax.imageio.stream.MemoryCacheImageInputStream
Constructs a MemoryCacheImageInputStream that will read from a given InputStream.
MemoryCacheImageOutputStream - Class in javax.imageio.stream
An implementation of ImageOutputStream that writes its output to a regular OutputStream.
MemoryCacheImageOutputStream(OutputStream) - Constructor for class javax.imageio.stream.MemoryCacheImageOutputStream
Constructs a MemoryCacheImageOutputStream that will write to a given OutputStream.
MemoryHandler - Class in java.util.logging
Handler that buffers requests in a circular buffer in memory.
MemoryHandler() - Constructor for class java.util.logging.MemoryHandler
Create a MemoryHandler and configure it based on LogManager configuration properties.
MemoryHandler(Handler, int, Level) - Constructor for class java.util.logging.MemoryHandler
Create a MemoryHandler.
MemoryImageSource - Class in java.awt.image
This class is an implementation of the ImageProducer interface which uses an array to produce pixel values for an Image.
MemoryImageSource(int, int, ColorModel, byte[], int, int) - Constructor for class java.awt.image.MemoryImageSource
Constructs an ImageProducer object which uses an array of bytes to produce data for an Image object.
MemoryImageSource(int, int, ColorModel, byte[], int, int, Hashtable<?, ?>) - Constructor for class java.awt.image.MemoryImageSource
Constructs an ImageProducer object which uses an array of bytes to produce data for an Image object.
MemoryImageSource(int, int, ColorModel, int[], int, int) - Constructor for class java.awt.image.MemoryImageSource
Constructs an ImageProducer object which uses an array of integers to produce data for an Image object.
MemoryImageSource(int, int, ColorModel, int[], int, int, Hashtable<?, ?>) - Constructor for class java.awt.image.MemoryImageSource
Constructs an ImageProducer object which uses an array of integers to produce data for an Image object.
MemoryImageSource(int, int, int[], int, int) - Constructor for class java.awt.image.MemoryImageSource
Constructs an ImageProducer object which uses an array of integers in the default RGB ColorModel to produce data for an Image object.
MemoryImageSource(int, int, int[], int, int, Hashtable<?, ?>) - Constructor for class java.awt.image.MemoryImageSource
Constructs an ImageProducer object which uses an array of integers in the default RGB ColorModel to produce data for an Image object.
MemoryManagerMXBean - Interface in java.lang.management
The management interface for a memory manager.
MemoryMXBean - Interface in java.lang.management
The management interface for the memory system of the Java virtual machine.
MemoryNotificationInfo - Class in java.lang.management
The information about a memory notification.
MemoryNotificationInfo(String, MemoryUsage, long) - Constructor for class java.lang.management.MemoryNotificationInfo
Constructs a MemoryNotificationInfo object.
MemoryPoolMXBean - Interface in java.lang.management
The management interface for a memory pool.
MemoryType - Enum in java.lang.management
Types of memory pools.
MemoryUsage - Class in java.lang.management
A MemoryUsage object represents a snapshot of memory usage.
MemoryUsage(long, long, long, long) - Constructor for class java.lang.management.MemoryUsage
Constructs a MemoryUsage object.
Menu - Class in java.awt
A Menu object is a pull-down menu component that is deployed from a menu bar.
Menu() - Constructor for class java.awt.Menu
Constructs a new menu with an empty label.
Menu(String) - Constructor for class java.awt.Menu
Constructs a new menu with the specified label.
Menu(String, boolean) - Constructor for class java.awt.Menu
Constructs a new menu with the specified label, indicating whether the menu can be torn off.
MENU - Static variable in class java.awt.SystemColor
The array index for the SystemColor.menu system color.
menu - Static variable in class java.awt.SystemColor
The color rendered for the background of menus.
MENU - Static variable in class javax.accessibility.AccessibleRole
An object usually found inside a menu bar that contains a list of actions the user can choose from.
menu - Variable in class javax.swing.plaf.basic.BasicMenuUI.ChangeHandler
MENU - Static variable in class javax.swing.plaf.synth.Region
Menu region.
MENU - Static variable in class javax.swing.text.html.HTML.Tag
Menu.AccessibleAWTMenu - Class in java.awt
Inner class of Menu used to provide default support for accessibility.
MENU_BAR - Static variable in class javax.accessibility.AccessibleRole
An object usually drawn at the top of the primary dialog box of an application that contains a list of menus the user can choose from.
MENU_BAR - Static variable in class javax.swing.plaf.synth.Region
MenuBar region.
MENU_BAR_PROPERTY - Static variable in class javax.swing.JInternalFrame
Bound property name.
MENU_ITEM - Static variable in class javax.accessibility.AccessibleRole
An object usually contained in a menu that presents an action the user can choose.
MENU_ITEM - Static variable in class javax.swing.plaf.synth.Region
MenuItem region.
MENU_ITEM_ACCELERATOR - Static variable in class javax.swing.plaf.synth.Region
Accelerator region of a MenuItem.
MENU_TEXT - Static variable in class java.awt.SystemColor
The array index for the SystemColor.menuText system color.
MenuBar - Class in java.awt
The MenuBar class encapsulates the platform's concept of a menu bar bound to a frame.
MenuBar() - Constructor for class java.awt.MenuBar
Creates a new menu bar.
menuBar - Variable in class javax.swing.JRootPane
The menu bar.
menuBar - Variable in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
menuBar - Variable in class javax.swing.plaf.basic.BasicMenuBarUI
MenuBar.AccessibleAWTMenuBar - Class in java.awt
Inner class of MenuBar used to provide default support for accessibility.
MenuBarBorder(Color, Color) - Constructor for class javax.swing.plaf.basic.BasicBorders.MenuBarBorder
MenuBarBorder() - Constructor for class javax.swing.plaf.metal.MetalBorders.MenuBarBorder
MenuBarUI - Class in javax.swing.plaf
Pluggable look and feel interface for JMenuBar.
MenuBarUI() - Constructor for class javax.swing.plaf.MenuBarUI
menuCanceled(MenuEvent) - Method in interface javax.swing.event.MenuListener
Invoked when the menu is canceled.
MenuComponent - Class in java.awt
The abstract class MenuComponent is the superclass of all menu-related components.
MenuComponent() - Constructor for class java.awt.MenuComponent
Creates a MenuComponent.
MenuComponent.AccessibleAWTMenuComponent - Class in java.awt
Inner class of MenuComponent used to provide default support for accessibility.
MenuContainer - Interface in java.awt
The super class of all menu related containers.
menuDeselected(MenuEvent) - Method in interface javax.swing.event.MenuListener
Invoked when the menu is deselected.
menuDragMouseDragged(MenuDragMouseEvent) - Method in interface javax.swing.event.MenuDragMouseListener
Invoked when the mouse is being dragged in a menu component's display area.
menuDragMouseEntered(MenuDragMouseEvent) - Method in interface javax.swing.event.MenuDragMouseListener
Invoked when the dragged mouse has entered a menu component's display area.
MenuDragMouseEvent - Class in javax.swing.event
MenuDragMouseEvent is used to notify interested parties that the menu element has received a MouseEvent forwarded to it under drag conditions.
MenuDragMouseEvent(Component, int, long, int, int, int, int, boolean, MenuElement[], MenuSelectionManager) - Constructor for class javax.swing.event.MenuDragMouseEvent
Constructs a MenuDragMouseEvent object.
MenuDragMouseEvent(Component, int, long, int, int, int, int, int, int, boolean, MenuElement[], MenuSelectionManager) - Constructor for class javax.swing.event.MenuDragMouseEvent
Constructs a MenuDragMouseEvent object.
menuDragMouseExited(MenuDragMouseEvent) - Method in interface javax.swing.event.MenuDragMouseListener
Invoked when the dragged mouse has left a menu component's display area.
MenuDragMouseListener - Interface in javax.swing.event
Defines a menu mouse-drag listener.
menuDragMouseListener - Variable in class javax.swing.plaf.basic.BasicMenuItemUI
menuDragMouseReleased(MenuDragMouseEvent) - Method in interface javax.swing.event.MenuDragMouseListener
Invoked when a dragged mouse is release in a menu component's display area.
MenuElement - Interface in javax.swing
Any component that can be placed into a menu should implement this interface.
MenuEvent - Class in javax.swing.event
MenuEvent is used to notify interested parties that the menu which is the event source has been posted, selected, or canceled.
MenuEvent(Object) - Constructor for class javax.swing.event.MenuEvent
Constructs a MenuEvent object.
MenuItem - Class in java.awt
All items in a menu must belong to the class MenuItem, or one of its subclasses.
MenuItem() - Constructor for class java.awt.MenuItem
Constructs a new MenuItem with an empty label and no keyboard shortcut.
MenuItem(String) - Constructor for class java.awt.MenuItem
Constructs a new MenuItem with the specified label and no keyboard shortcut.
MenuItem(String, MenuShortcut) - Constructor for class java.awt.MenuItem
Create a menu item with an associated keyboard shortcut.
menuItem - Variable in class javax.swing.plaf.basic.BasicMenuItemUI
MenuItem.AccessibleAWTMenuItem - Class in java.awt
Inner class of MenuItem used to provide default support for accessibility.
MenuItemBorder() - Constructor for class javax.swing.plaf.metal.MetalBorders.MenuItemBorder
MenuItemUI - Class in javax.swing.plaf
Pluggable look and feel interface for JMenuItem.
MenuItemUI() - Constructor for class javax.swing.plaf.MenuItemUI
MenuKeyEvent - Class in javax.swing.event
MenuKeyEvent is used to notify interested parties that the menu element has received a KeyEvent forwarded to it in a menu tree.
MenuKeyEvent(Component, int, long, int, int, char, MenuElement[], MenuSelectionManager) - Constructor for class javax.swing.event.MenuKeyEvent
Constructs a MenuKeyEvent object.
MenuKeyListener - Interface in javax.swing.event
MenuKeyListener
menuKeyListener - Variable in class javax.swing.plaf.basic.BasicMenuItemUI
menuKeyPressed(MenuKeyEvent) - Method in interface javax.swing.event.MenuKeyListener
Invoked when a key has been pressed.
menuKeyReleased(MenuKeyEvent) - Method in interface javax.swing.event.MenuKeyListener
Invoked when a key has been released.
menuKeyTyped(MenuKeyEvent) - Method in interface javax.swing.event.MenuKeyListener
Invoked when a key has been typed.
MenuListener - Interface in javax.swing.event
Defines a listener for menu events.
menuListener - Variable in class javax.swing.plaf.basic.BasicMenuUI
menuSelected(MenuEvent) - Method in interface javax.swing.event.MenuListener
Invoked when a menu is selected.
menuSelectionChanged(boolean) - Method in class javax.swing.JMenu
Messaged when the menubar selection changes to activate or deactivate this menu.
menuSelectionChanged(boolean) - Method in class javax.swing.JMenuBar
Implemented to be a MenuElement -- does nothing.
menuSelectionChanged(boolean) - Method in class javax.swing.JMenuItem
Called by the MenuSelectionManager when the MenuElement is selected or unselected.
menuSelectionChanged(boolean) - Method in class javax.swing.JPopupMenu
Messaged when the menubar selection changes to activate or deactivate this menu.
menuSelectionChanged(boolean) - Method in interface javax.swing.MenuElement
Call by the MenuSelectionManager when the MenuElement is added or remove from the menu selection.
MenuSelectionManager - Class in javax.swing
A MenuSelectionManager owns the selection in menu hierarchy.
MenuSelectionManager() - Constructor for class javax.swing.MenuSelectionManager
MenuShortcut - Class in java.awt
The MenuShortcutclass represents a keyboard accelerator for a MenuItem.
MenuShortcut(int) - Constructor for class java.awt.MenuShortcut
Constructs a new MenuShortcut for the specified virtual keycode.
MenuShortcut(int, boolean) - Constructor for class java.awt.MenuShortcut
Constructs a new MenuShortcut for the specified virtual keycode.
menuText - Static variable in class java.awt.SystemColor
The color rendered for the text of menus.
merge(Object, Object, BiFunction<? super Object, ? super Object, ? extends Object>) - Method in class java.security.Provider
If the specified key is not already associated with a value or is associated with null, associates it with the given value.
merge(K, V, BiFunction<? super V, ? super V, ? extends V>) - Method in class java.util.concurrent.ConcurrentHashMap
If the specified key is not already associated with a (non-null) value, associates it with the given value.
merge(K, V, BiFunction<? super V, ? super V, ? extends V>) - Method in interface java.util.concurrent.ConcurrentMap
If the specified key is not already associated with a value or is associated with null, associates it with the given non-null value.
merge(K, V, BiFunction<? super V, ? super V, ? extends V>) - Method in class java.util.concurrent.ConcurrentSkipListMap
If the specified key is not already associated with a value, associates it with the given value.
merge(K, V, BiFunction<? super V, ? super V, ? extends V>) - Method in class java.util.HashMap
merge(K, V, BiFunction<? super V, ? super V, ? extends V>) - Method in class java.util.Hashtable
merge(K, V, BiFunction<? super V, ? super V, ? extends V>) - Method in interface java.util.Map
If the specified key is not already associated with a value or is associated with null, associates it with the given non-null value.
merge(StringJoiner) - Method in class java.util.StringJoiner
Adds the contents of the given StringJoiner without prefix and suffix as the next element if it is non-empty.
mergeTree(String, Node) - Method in class javax.imageio.metadata.IIOMetadata
Alters the internal state of this IIOMetadata object from a tree of XML DOM Nodes whose syntax is defined by the given metadata format.
MEROITIC_CURSIVE - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Meroitic Cursive" Unicode character block.
MEROITIC_HIEROGLYPHS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Meroitic Hieroglyphs" Unicode character block.
message - Variable in class javax.swing.JOptionPane
Message to display.
MESSAGE_OUTBOUND_PROPERTY - Static variable in interface javax.xml.ws.handler.MessageContext
Standard property: message direction, true for outbound messages, false for inbound.
MESSAGE_PROPERTY - Static variable in class javax.swing.JOptionPane
Bound property name for message.
MESSAGE_TYPE_PROPERTY - Static variable in class javax.swing.JOptionPane
Bound property name for type.
MessageContext - Interface in javax.xml.ws.handler
The interface MessageContext abstracts the message context that is processed by a handler in the handle method.
MessageContext.Scope - Enum in javax.xml.ws.handler
Property scope.
MessageDigest - Class in java.security
This MessageDigest class provides applications the functionality of a message digest algorithm, such as SHA-1 or SHA-256.
MessageDigest(String) - Constructor for class java.security.MessageDigest
Creates a message digest with the specified algorithm name.
MessageDigestSpi - Class in java.security
This class defines the Service Provider Interface (SPI) for the MessageDigest class, which provides the functionality of a message digest algorithm, such as MD5 or SHA.
MessageDigestSpi() - Constructor for class java.security.MessageDigestSpi
MessageFactory - Class in javax.xml.soap
A factory for creating SOAPMessage objects.
MessageFactory() - Constructor for class javax.xml.soap.MessageFactory
MessageFormat - Class in java.text
MessageFormat provides a means to produce concatenated messages in a language-neutral way.
MessageFormat(String) - Constructor for class java.text.MessageFormat
Constructs a MessageFormat for the default FORMAT locale and the specified pattern.
MessageFormat(String, Locale) - Constructor for class java.text.MessageFormat
Constructs a MessageFormat for the specified locale and pattern.
MessageFormat.Field - Class in java.text
Defines constants that are used as attribute keys in the AttributedCharacterIterator returned from MessageFormat.formatToCharacterIterator.
MessageProp - Class in org.ietf.jgss
This is a utility class used within the per-message GSSContext methods to convey per-message properties.
MessageProp(boolean) - Constructor for class org.ietf.jgss.MessageProp
Constructor which sets the desired privacy state.
MessageProp(int, boolean) - Constructor for class org.ietf.jgss.MessageProp
Constructor which sets the values for the qop and privacy state.
Messager - Interface in javax.annotation.processing
A Messager provides the way for an annotation processor to report error messages, warnings, and other notices.
messageType - Variable in class javax.swing.JOptionPane
Message type.
meta(MetaMessage) - Method in interface javax.sound.midi.MetaEventListener
Invoked when a Sequencer has encountered and processed a MetaMessage in the Sequence it is processing.
META - Static variable in class javax.sound.midi.MetaMessage
Status byte for MetaMessage (0xFF, or 255), which is used in MIDI files.
META - Static variable in class javax.swing.text.html.HTML.Tag
meta - Variable in class javax.swing.text.html.parser.DTD
META_DOWN_MASK - Static variable in class java.awt.event.InputEvent
The Meta key extended modifier constant.
META_MASK - Static variable in class java.awt.event.ActionEvent
The meta modifier.
META_MASK - Static variable in class java.awt.event.InputEvent
The Meta key modifier constant.
META_MASK - Static variable in class java.awt.Event
This flag indicates that the Meta key was down when the event occurred.
metadata - Variable in class javax.imageio.IIOImage
An IIOMetadata object containing metadata associated with the image.
metadata(Element) - Method in class javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder
Adds the metadataElement to the W3CEndpointReference instance's wsa:Metadata element.
metaDown() - Method in class java.awt.Event
NOTE: The Event class is obsolete and is available only for backwards compatibility.
MetaEventListener - Interface in javax.sound.midi
The MetaEventListener interface should be implemented by classes whose instances need to be notified when a Sequencer has processed a MetaMessage.
metafactory(MethodHandles.Lookup, String, MethodType, MethodType, MethodHandle, MethodType) - Static method in class java.lang.invoke.LambdaMetafactory
Facilitates the creation of simple "function objects" that implement one or more interfaces by delegation to a provided MethodHandle, after appropriate type adaptation and partial evaluation of arguments.
MetalBorders - Class in javax.swing.plaf.metal
Factory object that can vend Borders appropriate for the metal L & F.
MetalBorders() - Constructor for class javax.swing.plaf.metal.MetalBorders
MetalBorders.ButtonBorder - Class in javax.swing.plaf.metal
MetalBorders.Flush3DBorder - Class in javax.swing.plaf.metal
MetalBorders.InternalFrameBorder - Class in javax.swing.plaf.metal
MetalBorders.MenuBarBorder - Class in javax.swing.plaf.metal
MetalBorders.MenuItemBorder - Class in javax.swing.plaf.metal
MetalBorders.OptionDialogBorder - Class in javax.swing.plaf.metal
MetalBorders.PaletteBorder - Class in javax.swing.plaf.metal
Border for a Palette.
MetalBorders.PopupMenuBorder - Class in javax.swing.plaf.metal
MetalBorders.RolloverButtonBorder - Class in javax.swing.plaf.metal
MetalBorders.ScrollPaneBorder - Class in javax.swing.plaf.metal
MetalBorders.TableHeaderBorder - Class in javax.swing.plaf.metal
Border for a Table Header
MetalBorders.TextFieldBorder - Class in javax.swing.plaf.metal
MetalBorders.ToggleButtonBorder - Class in javax.swing.plaf.metal
MetalBorders.ToolBarBorder - Class in javax.swing.plaf.metal
MetalButtonUI - Class in javax.swing.plaf.metal
MetalButtonUI implementation
MetalButtonUI() - Constructor for class javax.swing.plaf.metal.MetalButtonUI
MetalCheckBoxIcon - Class in javax.swing.plaf.metal
CheckboxIcon implementation for OrganicCheckBoxUI
MetalCheckBoxIcon() - Constructor for class javax.swing.plaf.metal.MetalCheckBoxIcon
MetalCheckBoxUI - Class in javax.swing.plaf.metal
CheckboxUI implementation for MetalCheckboxUI
MetalCheckBoxUI() - Constructor for class javax.swing.plaf.metal.MetalCheckBoxUI
MetalComboBoxButton - Class in javax.swing.plaf.metal
JButton subclass to help out MetalComboBoxUI
MetalComboBoxButton(JComboBox, Icon, CellRendererPane, JList) - Constructor for class javax.swing.plaf.metal.MetalComboBoxButton
MetalComboBoxButton(JComboBox, Icon, boolean, CellRendererPane, JList) - Constructor for class javax.swing.plaf.metal.MetalComboBoxButton
MetalComboBoxEditor - Class in javax.swing.plaf.metal
The default editor for Metal editable combo boxes
MetalComboBoxEditor() - Constructor for class javax.swing.plaf.metal.MetalComboBoxEditor
MetalComboBoxEditor.UIResource - Class in javax.swing.plaf.metal
A subclass of BasicComboBoxEditor that implements UIResource.
MetalComboBoxIcon - Class in javax.swing.plaf.metal
This utility class draws the horizontal bars which indicate a MetalComboBox
MetalComboBoxIcon() - Constructor for class javax.swing.plaf.metal.MetalComboBoxIcon
MetalComboBoxLayoutManager() - Constructor for class javax.swing.plaf.metal.MetalComboBoxUI.MetalComboBoxLayoutManager
MetalComboBoxUI - Class in javax.swing.plaf.metal
Metal UI for JComboBox
MetalComboBoxUI() - Constructor for class javax.swing.plaf.metal.MetalComboBoxUI
MetalComboBoxUI.MetalComboBoxLayoutManager - Class in javax.swing.plaf.metal
This class should be treated as a "protected" inner class.
MetalComboBoxUI.MetalComboPopup - Class in javax.swing.plaf.metal
Deprecated.
As of Java 2 platform v1.4.
MetalComboBoxUI.MetalPropertyChangeListener - Class in javax.swing.plaf.metal
This class should be treated as a "protected" inner class.
MetalComboPopup(JComboBox) - Constructor for class javax.swing.plaf.metal.MetalComboBoxUI.MetalComboPopup
Deprecated.
MetalContainerListener() - Constructor for class javax.swing.plaf.metal.MetalToolBarUI.MetalContainerListener
MetalDesktopIconUI - Class in javax.swing.plaf.metal
Metal desktop icon.
MetalDesktopIconUI() - Constructor for class javax.swing.plaf.metal.MetalDesktopIconUI
MetalDockingListener(JToolBar) - Constructor for class javax.swing.plaf.metal.MetalToolBarUI.MetalDockingListener
MetalFileChooserUI - Class in javax.swing.plaf.metal
Metal L&F implementation of a FileChooser.
MetalFileChooserUI(JFileChooser) - Constructor for class javax.swing.plaf.metal.MetalFileChooserUI
MetalFileChooserUI.DirectoryComboBoxAction - Class in javax.swing.plaf.metal
Acts when DirectoryComboBox has changed the selected item.
MetalFileChooserUI.DirectoryComboBoxModel - Class in javax.swing.plaf.metal
Data model for a type-face selection combo-box.
MetalFileChooserUI.FileRenderer - Class in javax.swing.plaf.metal
MetalFileChooserUI.FilterComboBoxModel - Class in javax.swing.plaf.metal
Data model for a type-face selection combo-box.
MetalFileChooserUI.FilterComboBoxRenderer - Class in javax.swing.plaf.metal
Render different type sizes and styles.
MetalFileChooserUI.SingleClickListener - Class in javax.swing.plaf.metal
MetalIconFactory - Class in javax.swing.plaf.metal
Factory object that vends Icons for the Java™ look and feel (Metal).
MetalIconFactory() - Constructor for class javax.swing.plaf.metal.MetalIconFactory
MetalIconFactory.FileIcon16 - Class in javax.swing.plaf.metal
Warning: Serialized objects of this class will not be compatible with future Swing releases.
MetalIconFactory.FolderIcon16 - Class in javax.swing.plaf.metal
Warning: Serialized objects of this class will not be compatible with future Swing releases.
MetalIconFactory.PaletteCloseIcon - Class in javax.swing.plaf.metal
Defines an icon for Palette close
MetalIconFactory.TreeControlIcon - Class in javax.swing.plaf.metal
Warning: Serialized objects of this class will not be compatible with future Swing releases.
MetalIconFactory.TreeFolderIcon - Class in javax.swing.plaf.metal
Warning: Serialized objects of this class will not be compatible with future Swing releases.
MetalIconFactory.TreeLeafIcon - Class in javax.swing.plaf.metal
MetalInternalFrameTitlePane - Class in javax.swing.plaf.metal
Class that manages a JLF title bar
MetalInternalFrameTitlePane(JInternalFrame) - Constructor for class javax.swing.plaf.metal.MetalInternalFrameTitlePane
MetalInternalFrameUI - Class in javax.swing.plaf.metal
Metal implementation of JInternalFrame.
MetalInternalFrameUI(JInternalFrame) - Constructor for class javax.swing.plaf.metal.MetalInternalFrameUI
MetalLabelUI - Class in javax.swing.plaf.metal
A Windows L&F implementation of LabelUI.
MetalLabelUI() - Constructor for class javax.swing.plaf.metal.MetalLabelUI
metalLabelUI - Static variable in class javax.swing.plaf.metal.MetalLabelUI
The default MetalLabelUI instance.
MetalLookAndFeel - Class in javax.swing.plaf.metal
The Java Look and Feel, otherwise known as Metal.
MetalLookAndFeel() - Constructor for class javax.swing.plaf.metal.MetalLookAndFeel
MetalMenuBarUI - Class in javax.swing.plaf.metal
Metal implementation of MenuBarUI.
MetalMenuBarUI() - Constructor for class javax.swing.plaf.metal.MetalMenuBarUI
MetalPopupMenuSeparatorUI - Class in javax.swing.plaf.metal
A Metal L&F implementation of PopupMenuSeparatorUI.
MetalPopupMenuSeparatorUI() - Constructor for class javax.swing.plaf.metal.MetalPopupMenuSeparatorUI
MetalProgressBarUI - Class in javax.swing.plaf.metal
The Metal implementation of ProgressBarUI.
MetalProgressBarUI() - Constructor for class javax.swing.plaf.metal.MetalProgressBarUI
MetalPropertyChangeListener() - Constructor for class javax.swing.plaf.metal.MetalComboBoxUI.MetalPropertyChangeListener
MetalPropertyListener() - Constructor for class javax.swing.plaf.metal.MetalSliderUI.MetalPropertyListener
MetalRadioButtonUI - Class in javax.swing.plaf.metal
RadioButtonUI implementation for MetalRadioButtonUI
MetalRadioButtonUI() - Constructor for class javax.swing.plaf.metal.MetalRadioButtonUI
MetalRolloverListener() - Constructor for class javax.swing.plaf.metal.MetalToolBarUI.MetalRolloverListener
MetalRootPaneUI - Class in javax.swing.plaf.metal
Provides the metal look and feel implementation of RootPaneUI.
MetalRootPaneUI() - Constructor for class javax.swing.plaf.metal.MetalRootPaneUI
MetalScrollBarUI - Class in javax.swing.plaf.metal
Implementation of ScrollBarUI for the Metal Look and Feel
MetalScrollBarUI() - Constructor for class javax.swing.plaf.metal.MetalScrollBarUI
MetalScrollButton - Class in javax.swing.plaf.metal
JButton object for Metal scrollbar arrows.
MetalScrollButton(int, int, boolean) - Constructor for class javax.swing.plaf.metal.MetalScrollButton
MetalScrollPaneUI - Class in javax.swing.plaf.metal
A Metal L&F implementation of ScrollPaneUI.
MetalScrollPaneUI() - Constructor for class javax.swing.plaf.metal.MetalScrollPaneUI
MetalSeparatorUI - Class in javax.swing.plaf.metal
A Metal L&F implementation of SeparatorUI.
MetalSeparatorUI() - Constructor for class javax.swing.plaf.metal.MetalSeparatorUI
MetalSliderUI - Class in javax.swing.plaf.metal
A Java L&F implementation of SliderUI.
MetalSliderUI() - Constructor for class javax.swing.plaf.metal.MetalSliderUI
MetalSliderUI.MetalPropertyListener - Class in javax.swing.plaf.metal
MetalSplitPaneUI - Class in javax.swing.plaf.metal
Metal split pane.
MetalSplitPaneUI() - Constructor for class javax.swing.plaf.metal.MetalSplitPaneUI
MetalTabbedPaneUI - Class in javax.swing.plaf.metal
The Metal subclass of BasicTabbedPaneUI.
MetalTabbedPaneUI() - Constructor for class javax.swing.plaf.metal.MetalTabbedPaneUI
MetalTabbedPaneUI.TabbedPaneLayout - Class in javax.swing.plaf.metal
This class should be treated as a "protected" inner class.
MetalTextFieldUI - Class in javax.swing.plaf.metal
Basis of a look and feel for a JTextField.
MetalTextFieldUI() - Constructor for class javax.swing.plaf.metal.MetalTextFieldUI
MetalTheme - Class in javax.swing.plaf.metal
MetalTheme provides the color palette and fonts used by the Java Look and Feel.
MetalTheme() - Constructor for class javax.swing.plaf.metal.MetalTheme
MetalToggleButtonUI - Class in javax.swing.plaf.metal
MetalToggleButton implementation
MetalToggleButtonUI() - Constructor for class javax.swing.plaf.metal.MetalToggleButtonUI
MetalToolBarUI - Class in javax.swing.plaf.metal
A Metal Look and Feel implementation of ToolBarUI.
MetalToolBarUI() - Constructor for class javax.swing.plaf.metal.MetalToolBarUI
MetalToolBarUI.MetalContainerListener - Class in javax.swing.plaf.metal
MetalToolBarUI.MetalDockingListener - Class in javax.swing.plaf.metal
MetalToolBarUI.MetalRolloverListener - Class in javax.swing.plaf.metal
MetalToolTipUI - Class in javax.swing.plaf.metal
A Metal L&F extension of BasicToolTipUI.
MetalToolTipUI() - Constructor for class javax.swing.plaf.metal.MetalToolTipUI
MetalTreeUI - Class in javax.swing.plaf.metal
The metal look and feel implementation of TreeUI.
MetalTreeUI() - Constructor for class javax.swing.plaf.metal.MetalTreeUI
MetaMessage - Class in javax.sound.midi
A MetaMessage is a MidiMessage that is not meaningful to synthesizers, but that can be stored in a MIDI file and interpreted by a sequencer program.
MetaMessage() - Constructor for class javax.sound.midi.MetaMessage
Constructs a new MetaMessage.
MetaMessage(int, byte[], int) - Constructor for class javax.sound.midi.MetaMessage
Constructs a new MetaMessage and sets the message parameters.
MetaMessage(byte[]) - Constructor for class javax.sound.midi.MetaMessage
Constructs a new MetaMessage.
Method - Class in java.lang.reflect
A Method provides information about, and access to, a single method on a class or interface.
method - Variable in class java.net.HttpURLConnection
The HTTP method (GET,POST,PUT,etc.).
METHOD - Static variable in class javax.swing.text.html.HTML.Attribute
METHOD - Static variable in class javax.xml.transform.OutputKeys
method = "xml" | "html" | "text" | expanded name.
METHOD_ATTRIBUTE_PFX - Static variable in interface java.util.jar.Pack200.Packer
When concatenated with a method attribute name, indicates the format of that attribute.
MethodDescriptor - Class in java.beans
A MethodDescriptor describes a particular method that a Java Bean supports for external access from other components.
MethodDescriptor(Method) - Constructor for class java.beans.MethodDescriptor
Constructs a MethodDescriptor from a Method.
MethodDescriptor(Method, ParameterDescriptor[]) - Constructor for class java.beans.MethodDescriptor
Constructs a MethodDescriptor from a Method providing descriptive information for each of the method's parameters.
MethodHandle - Class in java.lang.invoke
A method handle is a typed, directly executable reference to an underlying method, constructor, field, or similar low-level operation, with optional transformations of arguments or return values.
MethodHandleInfo - Interface in java.lang.invoke
A symbolic reference obtained by cracking a direct method handle into its consitutent symbolic parts.
MethodHandleProxies - Class in java.lang.invoke
This class consists exclusively of static methods that help adapt method handles to other JVM types, such as interfaces.
MethodHandles - Class in java.lang.invoke
This class consists exclusively of static methods that operate on or return method handles.
MethodHandles.Lookup - Class in java.lang.invoke
A lookup object is a factory for creating method handles, when the creation requires access checking.
methodModifiers() - Static method in class java.lang.reflect.Modifier
Return an int value OR-ing together the source language modifiers that can be applied to a method.
methodsIn(Iterable<? extends Element>) - Static method in class javax.lang.model.util.ElementFilter
Returns a list of methods in elements.
methodsIn(Set<? extends Element>) - Static method in class javax.lang.model.util.ElementFilter
Returns a set of methods in elements.
MethodType - Class in java.lang.invoke
A method type represents the arguments and return type accepted and returned by a method handle, or the arguments and return type passed and expected by a method handle caller.
methodType(Class<?>, Class<?>[]) - Static method in class java.lang.invoke.MethodType
Finds or creates an instance of the given method type.
methodType(Class<?>, List<Class<?>>) - Static method in class java.lang.invoke.MethodType
Finds or creates a method type with the given components.
methodType(Class<?>, Class<?>, Class<?>...) - Static method in class java.lang.invoke.MethodType
Finds or creates a method type with the given components.
methodType(Class<?>) - Static method in class java.lang.invoke.MethodType
Finds or creates a method type with the given components.
methodType(Class<?>, Class<?>) - Static method in class java.lang.invoke.MethodType
Finds or creates a method type with the given components.
methodType(Class<?>, MethodType) - Static method in class java.lang.invoke.MethodType
Finds or creates a method type with the given components.
metrics - Variable in class javax.swing.text.PlainView
Font metrics for the current font.
MGF1ParameterSpec - Class in java.security.spec
This class specifies the set of parameters used with mask generation function MGF1 in OAEP Padding and RSA-PSS signature scheme, as defined in the PKCS #1 v2.1 standard.
MGF1ParameterSpec(String) - Constructor for class java.security.spec.MGF1ParameterSpec
Constructs a parameter set for mask generation function MGF1 as defined in the PKCS #1 standard.
MIAO - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Miao" Unicode character block.
MICROPHONE - Static variable in class javax.sound.sampled.Port.Info
A type of port that gets audio from a built-in microphone or a microphone jack.
microsecondLength - Variable in class javax.sound.midi.MidiFileFormat
The duration of the MIDI file in microseconds.
MIDDLE - Static variable in class javax.print.attribute.standard.MediaTray
The middle input tray in the printer.
MIDI_SYNC - Static variable in class javax.sound.midi.Sequencer.SyncMode
A master or slave synchronization mode that specifies the use of MIDI clock messages.
MIDI_TIME_CODE - Static variable in class javax.sound.midi.Sequencer.SyncMode
A master or slave synchronization mode that specifies the use of MIDI Time Code.
MIDI_TIME_CODE - Static variable in class javax.sound.midi.ShortMessage
Status byte for MIDI Time Code Quarter Frame message (0xF1, or 241).
MidiChannel - Interface in javax.sound.midi
A MidiChannel object represents a single MIDI channel.
MidiDevice - Interface in javax.sound.midi
MidiDevice is the base interface for all MIDI devices.
MidiDevice.Info - Class in javax.sound.midi
A MidiDevice.Info object contains assorted data about a MidiDevice, including its name, the company who created it, and descriptive text.
MidiDeviceProvider - Class in javax.sound.midi.spi
A MidiDeviceProvider is a factory or provider for a particular type of MIDI device.
MidiDeviceProvider() - Constructor for class javax.sound.midi.spi.MidiDeviceProvider
MidiDeviceReceiver - Interface in javax.sound.midi
MidiDeviceReceiver is a Receiver which represents a MIDI input connector of a MidiDevice (see MidiDevice.getReceiver()).
MidiDeviceTransmitter - Interface in javax.sound.midi
MidiDeviceTransmitter is a Transmitter which represents a MIDI input connector of a MidiDevice (see MidiDevice.getTransmitter()).
MidiEvent - Class in javax.sound.midi
MIDI events contain a MIDI message and a corresponding time-stamp expressed in ticks, and can represent the MIDI event information stored in a MIDI file or a Sequence object.
MidiEvent(MidiMessage, long) - Constructor for class javax.sound.midi.MidiEvent
Constructs a new MidiEvent.
MidiFileFormat - Class in javax.sound.midi
A MidiFileFormat object encapsulates a MIDI file's type, as well as its length and timing information.
MidiFileFormat(int, float, int, int, long) - Constructor for class javax.sound.midi.MidiFileFormat
Constructs a MidiFileFormat.
MidiFileFormat(int, float, int, int, long, Map<String, Object>) - Constructor for class javax.sound.midi.MidiFileFormat
Construct a MidiFileFormat with a set of properties.
MidiFileReader - Class in javax.sound.midi.spi
A MidiFileReader supplies MIDI file-reading services.
MidiFileReader() - Constructor for class javax.sound.midi.spi.MidiFileReader
MidiFileWriter - Class in javax.sound.midi.spi
A MidiFileWriter supplies MIDI file-writing services.
MidiFileWriter() - Constructor for class javax.sound.midi.spi.MidiFileWriter
MidiMessage - Class in javax.sound.midi
MidiMessage is the base class for MIDI messages.
MidiMessage(byte[]) - Constructor for class javax.sound.midi.MidiMessage
Constructs a new MidiMessage.
MidiSystem - Class in javax.sound.midi
The MidiSystem class provides access to the installed MIDI system resources, including devices such as synthesizers, sequencers, and MIDI input and output ports.
MidiUnavailableException - Exception in javax.sound.midi
A MidiUnavailableException is thrown when a requested MIDI component cannot be opened or created because it is unavailable.
MidiUnavailableException() - Constructor for exception javax.sound.midi.MidiUnavailableException
Constructs a MidiUnavailableException that has null as its error detail message.
MidiUnavailableException(String) - Constructor for exception javax.sound.midi.MidiUnavailableException
Constructs a MidiUnavailableException with the specified detail message.
MIDNIGHT - Static variable in class java.time.LocalTime
The time of midnight at the start of the day, '00:00'.
millis() - Method in class java.time.Clock
Gets the current millisecond instant of the clock.
MILLISECOND - Static variable in class java.text.DateFormat.Field
Constant identifying the millisecond field.
MILLISECOND - Static variable in class java.util.Calendar
Field number for get and set indicating the millisecond within the second.
MILLISECOND_FIELD - Static variable in class java.text.DateFormat
Useful constant for MILLISECOND field alignment.
MimeHeader - Class in javax.xml.soap
An object that stores a MIME header name and its value.
MimeHeader(String, String) - Constructor for class javax.xml.soap.MimeHeader
Constructs a MimeHeader object initialized with the given name and value.
MimeHeaders - Class in javax.xml.soap
A container for MimeHeader objects, which represent the MIME headers present in a MIME part of a message.
MimeHeaders() - Constructor for class javax.xml.soap.MimeHeaders
Constructs a default MimeHeaders object initialized with an empty Vector object.
MimeType - Class in javax.activation
A Multipurpose Internet Mail Extension (MIME) type, as defined in RFC 2045 and 2046.
MimeType() - Constructor for class javax.activation.MimeType
Default constructor.
MimeType(String) - Constructor for class javax.activation.MimeType
Constructor that builds a MimeType from a String.
MimeType(String, String) - Constructor for class javax.activation.MimeType
Constructor that builds a MimeType with the given primary and sub type but has an empty parameter list.
MimeTypeParameterList - Class in javax.activation
A parameter list of a MimeType as defined in RFC 2045 and 2046.
MimeTypeParameterList() - Constructor for class javax.activation.MimeTypeParameterList
Default constructor.
MimeTypeParameterList(String) - Constructor for class javax.activation.MimeTypeParameterList
Constructs a new MimeTypeParameterList with the passed in data.
MimeTypeParseException - Exception in java.awt.datatransfer
A class to encapsulate MimeType parsing related exceptions
MimeTypeParseException() - Constructor for exception java.awt.datatransfer.MimeTypeParseException
Constructs a MimeTypeParseException with no specified detail message.
MimeTypeParseException(String) - Constructor for exception java.awt.datatransfer.MimeTypeParseException
Constructs a MimeTypeParseException with the specified detail message.
MimeTypeParseException - Exception in javax.activation
A class to encapsulate MimeType parsing related exceptions.
MimeTypeParseException() - Constructor for exception javax.activation.MimeTypeParseException
Constructs a MimeTypeParseException with no specified detail message.
MimeTypeParseException(String) - Constructor for exception javax.activation.MimeTypeParseException
Constructs a MimeTypeParseException with the specified detail message.
MIMETypes - Variable in class javax.imageio.spi.ImageReaderWriterSpi
An array of strings to be returned from getMIMETypes, initially null.
MimetypesFileTypeMap - Class in javax.activation
This class extends FileTypeMap and provides data typing of files via their file extension.
MimetypesFileTypeMap() - Constructor for class javax.activation.MimetypesFileTypeMap
The default constructor.
MimetypesFileTypeMap(String) - Constructor for class javax.activation.MimetypesFileTypeMap
Construct a MimetypesFileTypeMap with programmatic entries added from the named file.
MimetypesFileTypeMap(InputStream) - Constructor for class javax.activation.MimetypesFileTypeMap
Construct a MimetypesFileTypeMap with programmatic entries added from the InputStream.
min(double, double) - Static method in class java.lang.Double
Returns the smaller of two double values as if by calling Math.min.
min(float, float) - Static method in class java.lang.Float
Returns the smaller of two float values as if by calling Math.min.
min(int, int) - Static method in class java.lang.Integer
Returns the smaller of two int values as if by calling Math.min.
min(long, long) - Static method in class java.lang.Long
Returns the smaller of two long values as if by calling Math.min.
min(int, int) - Static method in class java.lang.Math
Returns the smaller of two int values.
min(long, long) - Static method in class java.lang.Math
Returns the smaller of two long values.
min(float, float) - Static method in class java.lang.Math
Returns the smaller of two float values.
min(double, double) - Static method in class java.lang.Math
Returns the smaller of two double values.
min(int, int) - Static method in class java.lang.StrictMath
Returns the smaller of two int values.
min(long, long) - Static method in class java.lang.StrictMath
Returns the smaller of two long values.
min(float, float) - Static method in class java.lang.StrictMath
Returns the smaller of two float values.
min(double, double) - Static method in class java.lang.StrictMath
Returns the smaller of two double values.
min(BigDecimal) - Method in class java.math.BigDecimal
Returns the minimum of this BigDecimal and val.
min(BigInteger) - Method in class java.math.BigInteger
Returns the minimum of this BigInteger and val.
MIN - Static variable in class java.time.Instant
The minimum supported Instant, '-1000000000-01-01T00:00Z'.
MIN - Static variable in class java.time.LocalDate
The minimum supported LocalDate, '-999999999-01-01'.
MIN - Static variable in class java.time.LocalDateTime
The minimum supported LocalDateTime, '-999999999-01-01T00:00:00'.
MIN - Static variable in class java.time.LocalTime
The minimum supported LocalTime, '00:00'.
MIN - Static variable in class java.time.OffsetDateTime
The minimum supported OffsetDateTime, '-999999999-01-01T00:00:00+18:00'.
MIN - Static variable in class java.time.OffsetTime
The minimum supported OffsetTime, '00:00:00+18:00'.
MIN - Static variable in class java.time.ZoneOffset
Constant for the maximum supported offset.
min(Collection<? extends T>) - Static method in class java.util.Collections
Returns the minimum element of the given collection, according to the natural ordering of its elements.
min(Collection<? extends T>, Comparator<? super T>) - Static method in class java.util.Collections
Returns the minimum element of the given collection, according to the order induced by the specified comparator.
min() - Method in interface java.util.stream.DoubleStream
Returns an OptionalDouble describing the minimum element of this stream, or an empty OptionalDouble if this stream is empty.
min() - Method in interface java.util.stream.IntStream
Returns an OptionalInt describing the minimum element of this stream, or an empty optional if this stream is empty.
min() - Method in interface java.util.stream.LongStream
Returns an OptionalLong describing the minimum element of this stream, or an empty optional if this stream is empty.
min(Comparator<? super T>) - Method in interface java.util.stream.Stream
Returns the minimum element of this stream according to the provided Comparator.
MIN_CODE_POINT - Static variable in class java.lang.Character
The minimum value of a Unicode code point, constant U+0000.
MIN_EXPONENT - Static variable in class java.lang.Double
Minimum exponent a normalized double variable may have.
MIN_EXPONENT - Static variable in class java.lang.Float
Minimum exponent a normalized float variable may have.
MIN_HIGH_SURROGATE - Static variable in class java.lang.Character
The minimum value of a Unicode high-surrogate code unit in the UTF-16 encoding, constant '\uD800'.
MIN_LOW_SURROGATE - Static variable in class java.lang.Character
The minimum value of a Unicode low-surrogate code unit in the UTF-16 encoding, constant '\uDC00'.
MIN_NORMAL - Static variable in class java.lang.Double
A constant holding the smallest positive normal value of type double, 2-1022.
MIN_NORMAL - Static variable in class java.lang.Float
A constant holding the smallest positive normal value of type float, 2-126.
MIN_PRIORITY - Static variable in class java.lang.Thread
The minimum priority that a thread can have.
MIN_RADIX - Static variable in class java.lang.Character
The minimum radix available for conversion to and from strings.
MIN_SCROLL - Static variable in class javax.swing.plaf.basic.BasicSliderUI
MIN_SUPPLEMENTARY_CODE_POINT - Static variable in class java.lang.Character
The minimum value of a Unicode supplementary code point, constant U+10000.
MIN_SURROGATE - Static variable in class java.lang.Character
The minimum value of a Unicode surrogate code unit in the UTF-16 encoding, constant '\uD800'.
MIN_TIMEZONE_OFFSET - Static variable in class javax.xml.datatype.DatatypeConstants
W3C XML Schema min timezone offset is +14:00.
MIN_VALUE - Static variable in class java.lang.Byte
A constant holding the minimum value a byte can have, -27.
MIN_VALUE - Static variable in class java.lang.Character
The constant value of this field is the smallest value of type char, '\u0000'.
MIN_VALUE - Static variable in class java.lang.Double
A constant holding the smallest positive nonzero value of type double, 2-1074.
MIN_VALUE - Static variable in class java.lang.Float
A constant holding the smallest positive nonzero value of type float, 2-149.
MIN_VALUE - Static variable in class java.lang.Integer
A constant holding the minimum value an int can have, -231.
MIN_VALUE - Static variable in class java.lang.Long
A constant holding the minimum value a long can have, -263.
MIN_VALUE - Static variable in class java.lang.Short
A constant holding the minimum value a short can have, -215.
MIN_VALUE - Static variable in class java.time.Year
The minimum supported year, '-999,999,999'.
MIN_VALUE_FIELD - Static variable in class javax.management.JMX
The name of the minValue field.
MIN_WEIGHT - Static variable in class java.util.Locale.LanguageRange
A constant holding the minimum value of weight, 0.0, which indicates that the language range is not a good fit for the user.
minBy(Comparator<? super T>) - Static method in interface java.util.function.BinaryOperator
Returns a BinaryOperator which returns the lesser of two elements according to the specified Comparator.
minBy(Comparator<? super T>) - Static method in class java.util.stream.Collectors
Returns a Collector that produces the minimal element according to a given Comparator, described as an Optional<T>.
MinguoChronology - Class in java.time.chrono
The Minguo calendar system.
MinguoDate - Class in java.time.chrono
A date in the Minguo calendar system.
MinguoEra - Enum in java.time.chrono
An era in the Minguo calendar system.
MINI_KEY - Static variable in class javax.swing.plaf.nimbus.NimbusStyle
MINI_SCALE - Static variable in class javax.swing.plaf.nimbus.NimbusStyle
minIcon - Variable in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
MinimalHTMLWriter - Class in javax.swing.text.html
MinimalHTMLWriter is a fallback writer used by the HTMLEditorKit to write out HTML for a document that is a not produced by the EditorKit.
MinimalHTMLWriter(Writer, StyledDocument) - Constructor for class javax.swing.text.html.MinimalHTMLWriter
Creates a new MinimalHTMLWriter.
MinimalHTMLWriter(Writer, StyledDocument, int, int) - Constructor for class javax.swing.text.html.MinimalHTMLWriter
Creates a new MinimalHTMLWriter.
MinimizeAction() - Constructor for class javax.swing.plaf.basic.BasicDesktopPaneUI.MinimizeAction
minimizeFrame(JInternalFrame) - Method in class javax.swing.DefaultDesktopManager
Restores the frame back to its size and position prior to a maximizeFrame call.
minimizeFrame(JInternalFrame) - Method in interface javax.swing.DesktopManager
Generally, this indicates that the frame should be restored to it's size and position prior to a maximizeFrame() call.
minimizeFrame(JInternalFrame) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
This method is called when the user wants to minimize the frame.
minimizeKey - Variable in class javax.swing.plaf.basic.BasicDesktopPaneUI
Deprecated.
As of 1.3.
minimum - Variable in class javax.swing.SizeRequirements
The minimum size required.
MinimumHeight - Static variable in class javax.swing.plaf.basic.BasicOptionPaneUI
minimumLayoutSize(Container) - Method in class java.awt.BorderLayout
Determines the minimum size of the target container using this layout manager.
minimumLayoutSize(Container) - Method in class java.awt.CardLayout
Calculates the minimum size for the specified panel.
minimumLayoutSize(Container) - Method in class java.awt.FlowLayout
Returns the minimum dimensions needed to layout the visible components contained in the specified target container.
minimumLayoutSize(Container) - Method in class java.awt.GridBagLayout
Determines the minimum size of the parent container using this grid bag layout.
minimumLayoutSize(Container) - Method in class java.awt.GridLayout
Determines the minimum size of the container argument using this grid layout.
minimumLayoutSize(Container) - Method in interface java.awt.LayoutManager
Calculates the minimum size dimensions for the specified container, given the components it contains.
minimumLayoutSize(Container) - Method in class javax.swing.BoxLayout
Returns the minimum dimensions needed to lay out the components contained in the specified target container.
minimumLayoutSize(Container) - Method in class javax.swing.GroupLayout
Returns the minimum size for the specified container.
minimumLayoutSize(Container) - Method in class javax.swing.JRootPane.RootLayout
Returns the minimum amount of space the layout needs.
minimumLayoutSize(Container) - Method in class javax.swing.JSpinner.DefaultEditor
Returns the minimum size of first (and only) child plus the size of the parents insets.
minimumLayoutSize(Container) - Method in class javax.swing.OverlayLayout
Returns the minimum dimensions needed to lay out the components contained in the specified target container.
minimumLayoutSize(Container) - Method in class javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager
minimumLayoutSize(Container) - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane.TitlePaneLayout
minimumLayoutSize(Container) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.InternalFrameLayout
minimumLayoutSize(Container) - Method in class javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout
minimumLayoutSize(Container) - Method in class javax.swing.plaf.basic.BasicScrollBarUI
minimumLayoutSize(Container) - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider.DividerLayout
minimumLayoutSize(Container) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager
Returns the minimum size needed to contain the children.
minimumLayoutSize(Container) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout
minimumLayoutSize(Container) - Method in class javax.swing.ScrollPaneLayout
The minimum size of a ScrollPane is the size of the insets plus minimum size of the viewport, plus the scrollpane's viewportBorder insets, plus the minimum size of the visible headers, plus the minimum size of the scrollbars whose displayPolicy isn't NEVER.
minimumLayoutSize(Container) - Method in class javax.swing.SpringLayout
minimumLayoutSize(Container) - Method in class javax.swing.ViewportLayout
Returns the minimum dimensions needed to layout the components contained in the specified target container.
minimumSize() - Method in class java.awt.Component
Deprecated.
As of JDK version 1.1, replaced by getMinimumSize().
minimumSize() - Method in class java.awt.Container
Deprecated.
As of JDK version 1.1, replaced by getMinimumSize().
minimumSize(int) - Method in class java.awt.List
Deprecated.
As of JDK version 1.1, replaced by getMinimumSize(int).
minimumSize() - Method in class java.awt.List
Deprecated.
As of JDK version 1.1, replaced by getMinimumSize().
minimumSize(int, int) - Method in class java.awt.TextArea
Deprecated.
As of JDK version 1.1, replaced by getMinimumSize(int, int).
minimumSize() - Method in class java.awt.TextArea
Deprecated.
As of JDK version 1.1, replaced by getMinimumSize().
minimumSize(int) - Method in class java.awt.TextField
Deprecated.
As of JDK version 1.1, replaced by getMinimumSize(int).
minimumSize() - Method in class java.awt.TextField
Deprecated.
As of JDK version 1.1, replaced by getMinimumSize().
minimumSize - Variable in class javax.swing.plaf.basic.BasicOptionPaneUI
minimumThumbSize - Variable in class javax.swing.plaf.basic.BasicScrollBarUI
MinimumWidth - Static variable in class javax.swing.plaf.basic.BasicOptionPaneUI
minIndex - Variable in class javax.imageio.ImageReader
The smallest valid index for reading, initially 0.
minLength() - Method in enum java.time.Month
Gets the minimum length of this month in days.
minor - Variable in exception org.omg.CORBA.SystemException
The CORBA Exception minor code.
minor_version - Variable in class org.omg.IOP.Encoding
The minor version of this Encoding format.
minorRequirementChange(AsyncBoxView.ChildState) - Method in class javax.swing.text.AsyncBoxView
Requirements changed along the minor axis.
minorTickSpacing - Variable in class javax.swing.JSlider
The number of values between the minor tick marks -- the smaller marks that occur between the major tick marks.
minProgressivePass - Variable in class javax.imageio.ImageReadParam
The minimum index of a progressive pass to read from the source.
MINSIZE - Static variable in class java.awt.GridBagLayout
The smallest grid that can be laid out by the grid bag layout.
minTabWidth - Variable in class javax.swing.plaf.metal.MetalTabbedPaneUI
minus(TemporalAmount) - Method in interface java.time.chrono.ChronoLocalDate
Returns an object of the same type as this object with an amount subtracted.
minus(long, TemporalUnit) - Method in interface java.time.chrono.ChronoLocalDate
Returns an object of the same type as this object with the specified period subtracted.
minus(TemporalAmount) - Method in interface java.time.chrono.ChronoLocalDateTime
Returns an object of the same type as this object with an amount subtracted.
minus(long, TemporalUnit) - Method in interface java.time.chrono.ChronoLocalDateTime
Returns an object of the same type as this object with the specified period subtracted.
minus(TemporalAmount) - Method in interface java.time.chrono.ChronoPeriod
Returns a copy of this period with the specified period subtracted.
minus(TemporalAmount) - Method in interface java.time.chrono.ChronoZonedDateTime
Returns an object of the same type as this object with an amount subtracted.
minus(long, TemporalUnit) - Method in interface java.time.chrono.ChronoZonedDateTime
Returns an object of the same type as this object with the specified period subtracted.
minus(TemporalAmount) - Method in class java.time.chrono.HijrahDate
Returns an object of the same type as this object with an amount subtracted.
minus(long, TemporalUnit) - Method in class java.time.chrono.HijrahDate
minus(TemporalAmount) - Method in class java.time.chrono.JapaneseDate
Returns an object of the same type as this object with an amount subtracted.
minus(long, TemporalUnit) - Method in class java.time.chrono.JapaneseDate
minus(TemporalAmount) - Method in class java.time.chrono.MinguoDate
Returns an object of the same type as this object with an amount subtracted.
minus(long, TemporalUnit) - Method in class java.time.chrono.MinguoDate
minus(TemporalAmount) - Method in class java.time.chrono.ThaiBuddhistDate
Returns an object of the same type as this object with an amount subtracted.
minus(long, TemporalUnit) - Method in class java.time.chrono.ThaiBuddhistDate
minus(long) - Method in enum java.time.DayOfWeek
Returns the day-of-week that is the specified number of days before this one.
minus(Duration) - Method in class java.time.Duration
Returns a copy of this duration with the specified duration subtracted.
minus(long, TemporalUnit) - Method in class java.time.Duration
Returns a copy of this duration with the specified duration subtracted.
minus(TemporalAmount) - Method in class java.time.Instant
Returns a copy of this instant with the specified amount subtracted.
minus(long, TemporalUnit) - Method in class java.time.Instant
Returns a copy of this instant with the specified amount subtracted.
minus(TemporalAmount) - Method in class java.time.LocalDate
Returns a copy of this date with the specified amount subtracted.
minus(long, TemporalUnit) - Method in class java.time.LocalDate
Returns a copy of this date with the specified amount subtracted.
minus(TemporalAmount) - Method in class java.time.LocalDateTime
Returns a copy of this date-time with the specified amount subtracted.
minus(long, TemporalUnit) - Method in class java.time.LocalDateTime
Returns a copy of this date-time with the specified amount subtracted.
minus(TemporalAmount) - Method in class java.time.LocalTime
Returns a copy of this time with the specified amount subtracted.
minus(long, TemporalUnit) - Method in class java.time.LocalTime
Returns a copy of this time with the specified amount subtracted.
minus(long) - Method in enum java.time.Month
Returns the month-of-year that is the specified number of months before this one.
minus(TemporalAmount) - Method in class java.time.OffsetDateTime
Returns a copy of this date-time with the specified amount subtracted.
minus(long, TemporalUnit) - Method in class java.time.OffsetDateTime
Returns a copy of this date-time with the specified amount subtracted.
minus(TemporalAmount) - Method in class java.time.OffsetTime
Returns a copy of this time with the specified amount subtracted.
minus(long, TemporalUnit) - Method in class java.time.OffsetTime
Returns a copy of this time with the specified amount subtracted.
minus(TemporalAmount) - Method in class java.time.Period
Returns a copy of this period with the specified period subtracted.
minus(TemporalAmount) - Method in interface java.time.temporal.Temporal
Returns an object of the same type as this object with an amount subtracted.
minus(long, TemporalUnit) - Method in interface java.time.temporal.Temporal
Returns an object of the same type as this object with the specified period subtracted.
minus(TemporalAmount) - Method in class java.time.Year
Returns a copy of this year with the specified amount subtracted.
minus(long, TemporalUnit) - Method in class java.time.Year
Returns a copy of this year with the specified amount subtracted.
minus(TemporalAmount) - Method in class java.time.YearMonth
Returns a copy of this year-month with the specified amount subtracted.
minus(long, TemporalUnit) - Method in class java.time.YearMonth
Returns a copy of this year-month with the specified amount subtracted.
minus(TemporalAmount) - Method in class java.time.ZonedDateTime
Returns a copy of this date-time with the specified amount subtracted.
minus(long, TemporalUnit) - Method in class java.time.ZonedDateTime
Returns a copy of this date-time with the specified amount subtracted.
MINUS - Static variable in class javax.management.Query
A code representing the Query.minus(javax.management.ValueExp, javax.management.ValueExp) expression.
minus(ValueExp, ValueExp) - Static method in class javax.management.Query
Returns a binary expression representing the difference between two numeric values.
minus(Spring) - Static method in class javax.swing.Spring
Returns -s: a spring running in the opposite direction to s.
minusDays(long) - Method in class java.time.Duration
Returns a copy of this duration with the specified duration in standard 24 hour days subtracted.
minusDays(long) - Method in class java.time.LocalDate
Returns a copy of this LocalDate with the specified number of days subtracted.
minusDays(long) - Method in class java.time.LocalDateTime
Returns a copy of this LocalDateTime with the specified period in days subtracted.
minusDays(long) - Method in class java.time.OffsetDateTime
Returns a copy of this OffsetDateTime with the specified period in days subtracted.
minusDays(long) - Method in class java.time.Period
Returns a copy of this period with the specified days subtracted.
minusDays(long) - Method in class java.time.ZonedDateTime
Returns a copy of this ZonedDateTime with the specified period in days subtracted.
minusHours(long) - Method in class java.time.Duration
Returns a copy of this duration with the specified duration in hours subtracted.
minusHours(long) - Method in class java.time.LocalDateTime
Returns a copy of this LocalDateTime with the specified period in hours subtracted.
minusHours(long) - Method in class java.time.LocalTime
Returns a copy of this LocalTime with the specified period in hours subtracted.
minusHours(long) - Method in class java.time.OffsetDateTime
Returns a copy of this OffsetDateTime with the specified period in hours subtracted.
minusHours(long) - Method in class java.time.OffsetTime
Returns a copy of this OffsetTime with the specified period in hours subtracted.
minusHours(long) - Method in class java.time.ZonedDateTime
Returns a copy of this ZonedDateTime with the specified period in hours subtracted.
minusMillis(long) - Method in class java.time.Duration
Returns a copy of this duration with the specified duration in milliseconds subtracted.
minusMillis(long) - Method in class java.time.Instant
Returns a copy of this instant with the specified duration in milliseconds subtracted.
minusMinutes(long) - Method in class java.time.Duration
Returns a copy of this duration with the specified duration in minutes subtracted.
minusMinutes(long) - Method in class java.time.LocalDateTime
Returns a copy of this LocalDateTime with the specified period in minutes subtracted.
minusMinutes(long) - Method in class java.time.LocalTime
Returns a copy of this LocalTime with the specified period in minutes subtracted.
minusMinutes(long) - Method in class java.time.OffsetDateTime
Returns a copy of this OffsetDateTime with the specified period in minutes subtracted.
minusMinutes(long) - Method in class java.time.OffsetTime
Returns a copy of this OffsetTime with the specified period in minutes subtracted.
minusMinutes(long) - Method in class java.time.ZonedDateTime
Returns a copy of this ZonedDateTime with the specified period in minutes subtracted.
minusMonths(long) - Method in class java.time.LocalDate
Returns a copy of this LocalDate with the specified period in months subtracted.
minusMonths(long) - Method in class java.time.LocalDateTime
Returns a copy of this LocalDateTime with the specified period in months subtracted.
minusMonths(long) - Method in class java.time.OffsetDateTime
Returns a copy of this OffsetDateTime with the specified period in months subtracted.
minusMonths(long) - Method in class java.time.Period
Returns a copy of this period with the specified months subtracted.
minusMonths(long) - Method in class java.time.YearMonth
Returns a copy of this year-month with the specified period in months subtracted.
minusMonths(long) - Method in class java.time.ZonedDateTime
Returns a copy of this ZonedDateTime with the specified period in months subtracted.
minusNanos(long) - Method in class java.time.Duration
Returns a copy of this duration with the specified duration in nanoseconds subtracted.
minusNanos(long) - Method in class java.time.Instant
Returns a copy of this instant with the specified duration in nanoseconds subtracted.
minusNanos(long) - Method in class java.time.LocalDateTime
Returns a copy of this LocalDateTime with the specified period in nanoseconds subtracted.
minusNanos(long) - Method in class java.time.LocalTime
Returns a copy of this LocalTime with the specified period in nanoseconds subtracted.
minusNanos(long) - Method in class java.time.OffsetDateTime
Returns a copy of this OffsetDateTime with the specified period in nanoseconds subtracted.
minusNanos(long) - Method in class java.time.OffsetTime
Returns a copy of this OffsetTime with the specified period in nanoseconds subtracted.
minusNanos(long) - Method in class java.time.ZonedDateTime
Returns a copy of this ZonedDateTime with the specified period in nanoseconds subtracted.
minusSeconds(long) - Method in class java.time.Duration
Returns a copy of this duration with the specified duration in seconds subtracted.
minusSeconds(long) - Method in class java.time.Instant
Returns a copy of this instant with the specified duration in seconds subtracted.
minusSeconds(long) - Method in class java.time.LocalDateTime
Returns a copy of this LocalDateTime with the specified period in seconds subtracted.
minusSeconds(long) - Method in class java.time.LocalTime
Returns a copy of this LocalTime with the specified period in seconds subtracted.
minusSeconds(long) - Method in class java.time.OffsetDateTime
Returns a copy of this OffsetDateTime with the specified period in seconds subtracted.
minusSeconds(long) - Method in class java.time.OffsetTime
Returns a copy of this OffsetTime with the specified period in seconds subtracted.
minusSeconds(long) - Method in class java.time.ZonedDateTime
Returns a copy of this ZonedDateTime with the specified period in seconds subtracted.
minusWeeks(long) - Method in class java.time.LocalDate
Returns a copy of this LocalDate with the specified period in weeks subtracted.
minusWeeks(long) - Method in class java.time.LocalDateTime
Returns a copy of this LocalDateTime with the specified period in weeks subtracted.
minusWeeks(long) - Method in class java.time.OffsetDateTime
Returns a copy of this OffsetDateTime with the specified period in weeks subtracted.
minusWeeks(long) - Method in class java.time.ZonedDateTime
Returns a copy of this ZonedDateTime with the specified period in weeks subtracted.
minusYears(long) - Method in class java.time.LocalDate
Returns a copy of this LocalDate with the specified period in years subtracted.
minusYears(long) - Method in class java.time.LocalDateTime
Returns a copy of this LocalDateTime with the specified period in years subtracted.
minusYears(long) - Method in class java.time.OffsetDateTime
Returns a copy of this OffsetDateTime with the specified period in years subtracted.
minusYears(long) - Method in class java.time.Period
Returns a copy of this period with the specified years subtracted.
minusYears(long) - Method in class java.time.Year
Returns a copy of this year with the specified number of years subtracted.
minusYears(long) - Method in class java.time.YearMonth
Returns a copy of this year-month with the specified period in years subtracted.
minusYears(long) - Method in class java.time.ZonedDateTime
Returns a copy of this ZonedDateTime with the specified period in years subtracted.
MINUTE - Static variable in class java.text.DateFormat.Field
Constant identifying the minute field.
MINUTE - Static variable in class java.util.Calendar
Field number for get and set indicating the minute within the hour.
MINUTE_FIELD - Static variable in class java.text.DateFormat
Useful constant for MINUTE field alignment.
MINUTES - Static variable in class javax.xml.datatype.DatatypeConstants
A constant that represents the minutes field.
minWidth - Variable in class javax.swing.table.TableColumn
The minimum width of the column.
minX - Variable in class java.awt.image.Raster
The X coordinate of the upper-left pixel of this Raster.
minY - Variable in class java.awt.image.Raster
The Y coordinate of the upper-left pixel of this Raster.
MirroredTypeException - Exception in javax.lang.model.type
Thrown when an application attempts to access the Class object corresponding to a TypeMirror.
MirroredTypeException(TypeMirror) - Constructor for exception javax.lang.model.type.MirroredTypeException
Constructs a new MirroredTypeException for the specified type.
MirroredTypesException - Exception in javax.lang.model.type
Thrown when an application attempts to access a sequence of Class objects each corresponding to a TypeMirror.
MirroredTypesException(List<? extends TypeMirror>) - Constructor for exception javax.lang.model.type.MirroredTypesException
Constructs a new MirroredTypesException for the specified types.
MISCELLANEOUS_MATHEMATICAL_SYMBOLS_A - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Miscellaneous Mathematical Symbols-A" Unicode character block.
MISCELLANEOUS_MATHEMATICAL_SYMBOLS_B - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Miscellaneous Mathematical Symbols-B" Unicode character block.
MISCELLANEOUS_SYMBOLS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Miscellaneous Symbols" Unicode character block.
MISCELLANEOUS_SYMBOLS_AND_ARROWS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Miscellaneous Symbols and Arrows" Unicode character block.
MISCELLANEOUS_SYMBOLS_AND_PICTOGRAPHS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Miscellaneous Symbols And Pictographs" Unicode character block.
MISCELLANEOUS_TECHNICAL - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Miscellaneous Technical" Unicode character block.
missing_node - Static variable in class org.omg.CosNaming.NamingContextPackage.NotFoundReason
MissingFormatArgumentException - Exception in java.util
Unchecked exception thrown when there is a format specifier which does not have a corresponding argument or if an argument index refers to an argument that does not exist.
MissingFormatArgumentException(String) - Constructor for exception java.util.MissingFormatArgumentException
Constructs an instance of this class with the unmatched format specifier.
MissingFormatWidthException - Exception in java.util
Unchecked exception thrown when the format width is required.
MissingFormatWidthException(String) - Constructor for exception java.util.MissingFormatWidthException
Constructs an instance of this class with the specified format specifier.
MissingResourceException - Exception in java.util
Signals that a resource is missing.
MissingResourceException(String, String, String) - Constructor for exception java.util.MissingResourceException
Constructs a MissingResourceException with the specified information.
Mixer - Interface in javax.sound.sampled
A mixer is an audio device with one or more lines.
Mixer.Info - Class in javax.sound.sampled
The Mixer.Info class represents information about an audio mixer, including the product's name, version, and vendor, along with a textual description.
MixerProvider - Class in javax.sound.sampled.spi
A provider or factory for a particular mixer type.
MixerProvider() - Constructor for class javax.sound.sampled.spi.MixerProvider
mkdir() - Method in class java.io.File
Creates the directory named by this abstract pathname.
mkdirs() - Method in class java.io.File
Creates the directory named by this abstract pathname, including any necessary but nonexistent parent directories.
MLet - Class in javax.management.loading
Allows you to instantiate and register one or several MBeans in the MBean server coming from a remote URL.
MLet() - Constructor for class javax.management.loading.MLet
Constructs a new MLet using the default delegation parent ClassLoader.
MLet(URL[]) - Constructor for class javax.management.loading.MLet
Constructs a new MLet for the specified URLs using the default delegation parent ClassLoader.
MLet(URL[], ClassLoader) - Constructor for class javax.management.loading.MLet
Constructs a new MLet for the given URLs.
MLet(URL[], ClassLoader, URLStreamHandlerFactory) - Constructor for class javax.management.loading.MLet
Constructs a new MLet for the specified URLs, parent class loader, and URLStreamHandlerFactory.
MLet(URL[], boolean) - Constructor for class javax.management.loading.MLet
Constructs a new MLet for the specified URLs using the default delegation parent ClassLoader.
MLet(URL[], ClassLoader, boolean) - Constructor for class javax.management.loading.MLet
Constructs a new MLet for the given URLs.
MLet(URL[], ClassLoader, URLStreamHandlerFactory, boolean) - Constructor for class javax.management.loading.MLet
Constructs a new MLet for the specified URLs, parent class loader, and URLStreamHandlerFactory.
MLetContent - Class in javax.management.loading
This class represents the contents of the MLET tag.
MLetContent(URL, Map<String, String>, List<String>, List<String>) - Constructor for class javax.management.loading.MLetContent
Creates an MLet instance initialized with attributes read from an MLET tag in an MLet text file.
MLetMBean - Interface in javax.management.loading
Exposes the remote management interface of the MLet MBean.
MM - Static variable in class javax.print.attribute.Size2DSyntax
Value to indicate units of millimeters (mm).
MM - Static variable in class javax.print.attribute.standard.MediaPrintableArea
Value to indicate units of millimeters (mm).
mnemonic - Variable in class javax.swing.DefaultButtonModel
The button's mnemonic.
MNEMONIC_CHANGED_PROPERTY - Static variable in class javax.swing.AbstractButton
Identifies a change to the button's mnemonic.
MNEMONIC_KEY - Static variable in interface javax.swing.Action
The key used for storing an Integer that corresponds to one of the KeyEvent key codes.
mod(BigInteger) - Method in class java.math.BigInteger
Returns a BigInteger whose value is (this mod m).
MODAL - Static variable in class javax.accessibility.AccessibleState
Indicates something must be done with this object before the user can interact with an object in a different window.
MODAL_LAYER - Static variable in class javax.swing.JLayeredPane
Convenience object defining the Modal layer.
modCount - Variable in class java.util.AbstractList
The number of times this list has been structurally modified.
mode - Variable in class org.omg.Dynamic.Parameter
MODE_ASYNCHRONOUS - Static variable in interface org.w3c.dom.ls.DOMImplementationLS
Create an asynchronous LSParser.
MODE_COPY_FROM_METADATA - Static variable in class javax.imageio.ImageWriteParam
A constant value that may be passed into methods such as setTilingMode, setProgressiveMode, or setCompressionMode to enable that feature for future writes.
MODE_DEFAULT - Static variable in class javax.imageio.ImageWriteParam
A constant value that may be passed into methods such as setTilingMode, setProgressiveMode, and setCompressionMode to enable that feature for future writes.
MODE_DISABLED - Static variable in class javax.imageio.ImageWriteParam
A constant value that may be passed into methods such as setTilingMode, setProgressiveMode, and setCompressionMode to disable a feature for future writes.
MODE_EXPLICIT - Static variable in class javax.imageio.ImageWriteParam
A constant value that may be passed into methods such as setTilingMode or setCompressionMode to enable a feature for future writes.
MODE_SYNCHRONOUS - Static variable in interface org.w3c.dom.ls.DOMImplementationLS
Create a synchronous LSParser.
model - Variable in class javax.swing.AbstractButton
The data model that determines the button's state.
model - Variable in class javax.swing.JProgressBar
The object that holds the data for the progress bar.
model - Variable in class javax.swing.JScrollBar
The model that represents the scrollbar's minimum, maximum, extent (aka "visibleAmount") and current value.
model - Variable in class javax.swing.JTabbedPane
The default selection model
MODEL - Static variable in interface javax.swing.text.html.parser.DTDConstants
MODEL_CHANGED_PROPERTY - Static variable in class javax.swing.AbstractButton
Identifies a change in the button model.
ModelAttribute - Static variable in class javax.swing.text.StyleConstants
Attribute used to identify the model for embedded objects that have a model view separation.
modelChanged - Static variable in class javax.swing.plaf.basic.BasicListUI
modelChanged() - Method in class javax.swing.plaf.basic.BasicTextUI
Flags model changes.
modelIndex - Variable in class javax.swing.table.TableColumn
The index of the column in the model which is to be displayed by this TableColumn.
ModelListener() - Constructor for class javax.swing.JTabbedPane.ModelListener
modelListener - Variable in class javax.swing.plaf.basic.BasicScrollBarUI
ModelListener() - Constructor for class javax.swing.plaf.basic.BasicScrollBarUI.ModelListener
ModelMBean - Interface in javax.management.modelmbean
This interface must be implemented by the ModelMBeans.
ModelMBeanAttributeInfo - Class in javax.management.modelmbean
The ModelMBeanAttributeInfo object describes an attribute of the ModelMBean.
ModelMBeanAttributeInfo(String, String, Method, Method) - Constructor for class javax.management.modelmbean.ModelMBeanAttributeInfo
Constructs a ModelMBeanAttributeInfo object with a default descriptor.
ModelMBeanAttributeInfo(String, String, Method, Method, Descriptor) - Constructor for class javax.management.modelmbean.ModelMBeanAttributeInfo
Constructs a ModelMBeanAttributeInfo object.
ModelMBeanAttributeInfo(String, String, String, boolean, boolean, boolean) - Constructor for class javax.management.modelmbean.ModelMBeanAttributeInfo
Constructs a ModelMBeanAttributeInfo object with a default descriptor.
ModelMBeanAttributeInfo(String, String, String, boolean, boolean, boolean, Descriptor) - Constructor for class javax.management.modelmbean.ModelMBeanAttributeInfo
Constructs a ModelMBeanAttributeInfo object.
ModelMBeanAttributeInfo(ModelMBeanAttributeInfo) - Constructor for class javax.management.modelmbean.ModelMBeanAttributeInfo
Constructs a new ModelMBeanAttributeInfo object from this ModelMBeanAttributeInfo Object.
ModelMBeanConstructorInfo - Class in javax.management.modelmbean
The ModelMBeanConstructorInfo object describes a constructor of the ModelMBean.
ModelMBeanConstructorInfo(String, Constructor<?>) - Constructor for class javax.management.modelmbean.ModelMBeanConstructorInfo
Constructs a ModelMBeanConstructorInfo object with a default descriptor.
ModelMBeanConstructorInfo(String, Constructor<?>, Descriptor) - Constructor for class javax.management.modelmbean.ModelMBeanConstructorInfo
Constructs a ModelMBeanConstructorInfo object.
ModelMBeanConstructorInfo(String, String, MBeanParameterInfo[]) - Constructor for class javax.management.modelmbean.ModelMBeanConstructorInfo
Constructs a ModelMBeanConstructorInfo object with a default descriptor.
ModelMBeanConstructorInfo(String, String, MBeanParameterInfo[], Descriptor) - Constructor for class javax.management.modelmbean.ModelMBeanConstructorInfo
Constructs a ModelMBeanConstructorInfo object.
ModelMBeanInfo - Interface in javax.management.modelmbean
This interface is implemented by the ModelMBeanInfo for every ModelMBean.
ModelMBeanInfoSupport - Class in javax.management.modelmbean
This class represents the meta data for ModelMBeans.
ModelMBeanInfoSupport(ModelMBeanInfo) - Constructor for class javax.management.modelmbean.ModelMBeanInfoSupport
Constructs a ModelMBeanInfoSupport which is a duplicate of the given ModelMBeanInfo.
ModelMBeanInfoSupport(String, String, ModelMBeanAttributeInfo[], ModelMBeanConstructorInfo[], ModelMBeanOperationInfo[], ModelMBeanNotificationInfo[]) - Constructor for class javax.management.modelmbean.ModelMBeanInfoSupport
Creates a ModelMBeanInfoSupport with the provided information, but the descriptor is a default.
ModelMBeanInfoSupport(String, String, ModelMBeanAttributeInfo[], ModelMBeanConstructorInfo[], ModelMBeanOperationInfo[], ModelMBeanNotificationInfo[], Descriptor) - Constructor for class javax.management.modelmbean.ModelMBeanInfoSupport
Creates a ModelMBeanInfoSupport with the provided information and the descriptor given in parameter.
ModelMBeanNotificationBroadcaster - Interface in javax.management.modelmbean
This interface must be implemented by the ModelMBeans.
ModelMBeanNotificationInfo - Class in javax.management.modelmbean
The ModelMBeanNotificationInfo object describes a notification emitted by a ModelMBean.
ModelMBeanNotificationInfo(String[], String, String) - Constructor for class javax.management.modelmbean.ModelMBeanNotificationInfo
Constructs a ModelMBeanNotificationInfo object with a default descriptor.
ModelMBeanNotificationInfo(String[], String, String, Descriptor) - Constructor for class javax.management.modelmbean.ModelMBeanNotificationInfo
Constructs a ModelMBeanNotificationInfo object.
ModelMBeanNotificationInfo(ModelMBeanNotificationInfo) - Constructor for class javax.management.modelmbean.ModelMBeanNotificationInfo
Constructs a new ModelMBeanNotificationInfo object from this ModelMBeanNotfication Object.
ModelMBeanOperationInfo - Class in javax.management.modelmbean
The ModelMBeanOperationInfo object describes a management operation of the ModelMBean.
ModelMBeanOperationInfo(String, Method) - Constructor for class javax.management.modelmbean.ModelMBeanOperationInfo
Constructs a ModelMBeanOperationInfo object with a default descriptor.
ModelMBeanOperationInfo(String, Method, Descriptor) - Constructor for class javax.management.modelmbean.ModelMBeanOperationInfo
Constructs a ModelMBeanOperationInfo object.
ModelMBeanOperationInfo(String, String, MBeanParameterInfo[], String, int) - Constructor for class javax.management.modelmbean.ModelMBeanOperationInfo
Constructs a ModelMBeanOperationInfo object with a default descriptor.
ModelMBeanOperationInfo(String, String, MBeanParameterInfo[], String, int, Descriptor) - Constructor for class javax.management.modelmbean.ModelMBeanOperationInfo
Constructs a ModelMBeanOperationInfo object.
ModelMBeanOperationInfo(ModelMBeanOperationInfo) - Constructor for class javax.management.modelmbean.ModelMBeanOperationInfo
Constructs a new ModelMBeanOperationInfo object from this ModelMBeanOperation Object.
modelStructureChanged() - Method in class javax.swing.DefaultRowSorter
Invoked when the underlying model structure has completely changed.
modelStructureChanged() - Method in class javax.swing.RowSorter
Invoked when the underlying model structure has completely changed.
modelToView(JTextComponent, int) - Method in class javax.swing.plaf.basic.BasicTextUI
Converts the given location in the model to a place in the view coordinate system.
modelToView(JTextComponent, int, Position.Bias) - Method in class javax.swing.plaf.basic.BasicTextUI
Converts the given location in the model to a place in the view coordinate system.
modelToView(JTextComponent, int) - Method in class javax.swing.plaf.multi.MultiTextUI
Invokes the modelToView method on each UI handled by this object.
modelToView(JTextComponent, int, Position.Bias) - Method in class javax.swing.plaf.multi.MultiTextUI
Invokes the modelToView method on each UI handled by this object.
modelToView(JTextComponent, int) - Method in class javax.swing.plaf.TextUI
Converts the given location in the model to a place in the view coordinate system.
modelToView(JTextComponent, int, Position.Bias) - Method in class javax.swing.plaf.TextUI
Converts the given location in the model to a place in the view coordinate system.
modelToView(int, Shape, Position.Bias) - Method in class javax.swing.text.AsyncBoxView
Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
modelToView(int, Shape, Position.Bias) - Method in class javax.swing.text.BoxView
Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
modelToView(int, Shape, Position.Bias) - Method in class javax.swing.text.ComponentView
Provides a mapping from the coordinate space of the model to that of the view.
modelToView(int, Shape, Position.Bias) - Method in class javax.swing.text.CompositeView
Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
modelToView(int, Position.Bias, int, Position.Bias, Shape) - Method in class javax.swing.text.CompositeView
Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
modelToView(int, Shape, Position.Bias) - Method in class javax.swing.text.FieldView
Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
modelToView(GlyphView, int, Position.Bias, Shape) - Method in class javax.swing.text.GlyphView.GlyphPainter
Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
modelToView(int, Shape, Position.Bias) - Method in class javax.swing.text.GlyphView
Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
modelToView(int, Shape, Position.Bias) - Method in class javax.swing.text.html.ImageView
Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
modelToView(int, Shape, Position.Bias) - Method in class javax.swing.text.IconView
Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
modelToView(int) - Method in class javax.swing.text.JTextComponent
Converts the given location in the model to a place in the view coordinate system.
modelToView(int, Shape, Position.Bias) - Method in class javax.swing.text.PasswordView
Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
modelToView(int, Shape, Position.Bias) - Method in class javax.swing.text.PlainView
Provides a mapping from the document model coordinate space to the coordinate space of the view mapped to it.
modelToView(int, Shape, Position.Bias) - Method in class javax.swing.text.View
Provides a mapping, for a given character, from the document model coordinate space to the view coordinate space.
modelToView(int, Position.Bias, int, Position.Bias, Shape) - Method in class javax.swing.text.View
Provides a mapping, for a given region, from the document model coordinate space to the view coordinate space.
modelToView(int, Shape) - Method in class javax.swing.text.View
Deprecated.
ModelWrapper() - Constructor for class javax.swing.DefaultRowSorter.ModelWrapper
Creates a new ModelWrapper.
MODIFICATION - Static variable in interface org.w3c.dom.events.MutationEvent
The Attr was modified in place.
MODIFICATION_TIME - Static variable in interface java.util.jar.Pack200.Packer
If this property is set to the special string Pack200.Packer.LATEST, the packer will attempt to determine the latest modification time, among all the available entries in the original archive or the latest modification time of all the available entries in each segment.
ModificationItem - Class in javax.naming.directory
This class represents a modification item.
ModificationItem(int, Attribute) - Constructor for class javax.naming.directory.ModificationItem
Creates a new instance of ModificationItem.
MODIFIED_JULIAN_DAY - Static variable in class java.time.temporal.JulianFields
Modified Julian Day field.
Modifier - Class in java.lang.reflect
The Modifier class provides static methods and constants to decode class and member access modifiers.
Modifier() - Constructor for class java.lang.reflect.Modifier
Modifier - Enum in javax.lang.model.element
Represents a modifier on a program element such as a class, method, or field.
modifier - Variable in class javax.swing.text.html.parser.AttributeList
MODIFIER_LETTER - Static variable in class java.lang.Character
General category "Lm" in the Unicode specification.
MODIFIER_SYMBOL - Static variable in class java.lang.Character
General category "Sk" in the Unicode specification.
MODIFIER_TONE_LETTERS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Modifier Tone Letters" Unicode character block.
modifiers - Variable in class java.awt.Event
The state of the modifier keys.
modifyAttributes(Name, int, Attributes) - Method in interface javax.naming.directory.DirContext
Modifies the attributes associated with a named object.
modifyAttributes(String, int, Attributes) - Method in interface javax.naming.directory.DirContext
Modifies the attributes associated with a named object.
modifyAttributes(Name, ModificationItem[]) - Method in interface javax.naming.directory.DirContext
Modifies the attributes associated with a named object using an ordered list of modifications.
modifyAttributes(String, ModificationItem[]) - Method in interface javax.naming.directory.DirContext
Modifies the attributes associated with a named object using an ordered list of modifications.
modifyAttributes(String, int, Attributes) - Method in class javax.naming.directory.InitialDirContext
modifyAttributes(Name, int, Attributes) - Method in class javax.naming.directory.InitialDirContext
modifyAttributes(String, ModificationItem[]) - Method in class javax.naming.directory.InitialDirContext
modifyAttributes(Name, ModificationItem[]) - Method in class javax.naming.directory.InitialDirContext
modInverse(BigInteger) - Method in class java.math.BigInteger
Returns a BigInteger whose value is (this-1 mod m).
modPow(BigInteger, BigInteger) - Method in class java.math.BigInteger
Returns a BigInteger whose value is (thisexponent mod m).
MONARCH - Static variable in class java.awt.PageAttributes.MediaType
An alias for MONARCH_ENVELOPE.
MONARCH_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for Monarch Envelope, 3 7/8 x 7 1/2 in.
MONARCH_ENVELOPE - Static variable in class javax.print.attribute.standard.MediaSize.Other
Specifies the Monarch envelope size, 3.87 inch by 7.5 inch.
MONARCH_ENVELOPE - Static variable in class javax.print.attribute.standard.MediaSizeName
monarch envelope size .
MONDAY - Static variable in class java.util.Calendar
Value of the Calendar.DAY_OF_WEEK field indicating Monday.
MONGOLIAN - Static variable in class java.awt.font.NumericShaper
Identifies the MONGOLIAN range and decimal base.
MONGOLIAN - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Mongolian" Unicode character block.
Monitor - Class in javax.management.monitor
Defines the part common to all monitor MBeans.
Monitor() - Constructor for class javax.management.monitor.Monitor
MonitorInfo - Class in java.lang.management
Information about an object monitor lock.
MonitorInfo(String, int, int, StackTraceElement) - Constructor for class java.lang.management.MonitorInfo
Construct a MonitorInfo object.
MonitorMBean - Interface in javax.management.monitor
Exposes the remote management interface of monitor MBeans.
MonitorNotification - Class in javax.management.monitor
Provides definitions of the notifications sent by monitor MBeans.
MonitorSettingException - Exception in javax.management.monitor
Exception thrown by the monitor when a monitor setting becomes invalid while the monitor is running.
MonitorSettingException() - Constructor for exception javax.management.monitor.MonitorSettingException
Default constructor.
MonitorSettingException(String) - Constructor for exception javax.management.monitor.MonitorSettingException
Constructor that allows an error message to be specified.
MONOCHROME - Static variable in class java.awt.PageAttributes.ColorType
The ColorType instance to use for specifying monochrome printing.
MONOCHROME - Static variable in class javax.print.attribute.standard.Chromaticity
Monochrome printing.
MONOSPACED - Static variable in class java.awt.Font
A String constant for the canonical family name of the logical font "Monospaced".
MONTH - Static variable in class java.text.DateFormat.Field
Constant identifying the month field.
Month - Enum in java.time
A month-of-year, such as 'July'.
MONTH - Static variable in class java.util.Calendar
Field number for get and set indicating the month.
MONTH_FIELD - Static variable in class java.text.DateFormat
Useful constant for MONTH field alignment.
MonthDay - Class in java.time
A month-day in the ISO-8601 calendar system, such as --12-03.
MONTHS - Static variable in class javax.xml.datatype.DatatypeConstants
A constant that represents the months field.
MORE_THAN_MAX_ROLE_DEGREE - Static variable in class javax.management.relation.RoleStatus
Problem type when trying to set a role value with more ObjectNames than the maximum expected cardinality.
MOUSE_CLICKED - Static variable in class java.awt.event.MouseEvent
The "mouse clicked" event.
MOUSE_DOWN - Static variable in class java.awt.Event
The user has pressed the mouse button.
MOUSE_DRAG - Static variable in class java.awt.Event
The user has moved the mouse with a button pressed.
MOUSE_DRAGGED - Static variable in class java.awt.event.MouseEvent
The "mouse dragged" event.
MOUSE_ENTER - Static variable in class java.awt.Event
The mouse has entered a component.
MOUSE_ENTERED - Static variable in class java.awt.event.MouseEvent
The "mouse entered" event.
MOUSE_EVENT_MASK - Static variable in class java.awt.AWTEvent
The event mask for selecting mouse events.
MOUSE_EXIT - Static variable in class java.awt.Event
The mouse has exited a component.
MOUSE_EXITED - Static variable in class java.awt.event.MouseEvent
The "mouse exited" event.
MOUSE_FIRST - Static variable in class java.awt.event.MouseEvent
The first number in the range of ids used for mouse events.
MOUSE_LAST - Static variable in class java.awt.event.MouseEvent
The last number in the range of ids used for mouse events.
MOUSE_MOTION_EVENT_MASK - Static variable in class java.awt.AWTEvent
The event mask for selecting mouse motion events.
MOUSE_MOVE - Static variable in class java.awt.Event
The mouse has moved with no button pressed.
MOUSE_MOVED - Static variable in class java.awt.event.MouseEvent
The "mouse moved" event.
MOUSE_OVER - Static variable in interface javax.swing.plaf.synth.SynthConstants
Primary state indicating the mouse is over the region.
MOUSE_PRESSED - Static variable in class java.awt.event.MouseEvent
The "mouse pressed" event.
MOUSE_RELEASED - Static variable in class java.awt.event.MouseEvent
The "mouse released" event.
MOUSE_UP - Static variable in class java.awt.Event
The user has released the mouse button.
MOUSE_WHEEL - Static variable in class java.awt.event.MouseEvent
The "mouse wheel" event.
MOUSE_WHEEL_EVENT_MASK - Static variable in class java.awt.AWTEvent
The event mask for selecting mouse wheel events.
MouseAdapter - Class in java.awt.event
An abstract adapter class for receiving mouse events.
MouseAdapter() - Constructor for class java.awt.event.MouseAdapter
mouseClicked(MouseEvent) - Method in class java.awt.AWTEventMulticaster
Handles the mouseClicked event by invoking the mouseClicked methods on listener-a and listener-b.
mouseClicked(MouseEvent) - Method in class java.awt.dnd.MouseDragGestureRecognizer
Invoked when the mouse has been clicked on a component.
mouseClicked(MouseEvent) - Method in class java.awt.event.MouseAdapter
Invoked when the mouse button has been clicked (pressed and released) on a component.
mouseClicked(MouseEvent) - Method in interface java.awt.event.MouseListener
Invoked when the mouse button has been clicked (pressed and released) on a component.
mouseClicked(MouseEvent) - Method in class javax.swing.plaf.basic.BasicButtonListener
mouseClicked(MouseEvent) - Method in class javax.swing.plaf.basic.BasicFileChooserUI.DoubleClickListener
mouseClicked(MouseEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener
mouseClicked(MouseEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher
mouseClicked(MouseEvent) - Method in class javax.swing.plaf.basic.BasicListUI.MouseInputHandler
mouseClicked(MouseEvent) - Method in class javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler
mouseClicked(MouseEvent) - Method in class javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler
mouseClicked(MouseEvent) - Method in class javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler
mouseClicked(MouseEvent) - Method in class javax.swing.plaf.basic.BasicTableUI.MouseInputHandler
mouseClicked(MouseEvent) - Method in class javax.swing.plaf.basic.BasicToolBarUI.DockingListener
mouseClicked(MouseEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler
mouseClicked(MouseEvent) - Method in class javax.swing.text.DefaultCaret
Called when the mouse is clicked.
mouseClicked(MouseEvent) - Method in class javax.swing.text.html.HTMLEditorKit.LinkController
Called for a mouse click event.
mouseDown(Event, int, int) - Method in class java.awt.Component
Deprecated.
As of JDK version 1.1, replaced by processMouseEvent(MouseEvent).
mouseDrag(Event, int, int) - Method in class java.awt.Component
Deprecated.
As of JDK version 1.1, replaced by processMouseMotionEvent(MouseEvent).
mouseDragged(MouseEvent) - Method in class java.awt.AWTEventMulticaster
Handles the mouseDragged event by invoking the mouseDragged methods on listener-a and listener-b.
mouseDragged(MouseEvent) - Method in class java.awt.dnd.MouseDragGestureRecognizer
Invoked when a mouse button is pressed on a component.
mouseDragged(MouseEvent) - Method in class java.awt.event.MouseAdapter
Invoked when a mouse button is pressed on a component and then dragged.
mouseDragged(MouseEvent) - Method in class java.awt.event.MouseMotionAdapter
Invoked when a mouse button is pressed on a component and then dragged.
mouseDragged(MouseEvent) - Method in interface java.awt.event.MouseMotionListener
Invoked when a mouse button is pressed on a component and then dragged.
mouseDragged(MouseEvent) - Method in class javax.swing.plaf.basic.BasicButtonListener
mouseDragged(MouseEvent) - Method in class javax.swing.plaf.basic.BasicComboPopup.InvocationMouseMotionHandler
mouseDragged(MouseEvent) - Method in class javax.swing.plaf.basic.BasicDesktopIconUI.MouseInputHandler
mouseDragged(MouseEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener
mouseDragged(MouseEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher
mouseDragged(MouseEvent) - Method in class javax.swing.plaf.basic.BasicListUI.MouseInputHandler
mouseDragged(MouseEvent) - Method in class javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler
mouseDragged(MouseEvent) - Method in class javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler
Invoked when a mouse button is pressed on the menu and then dragged.
mouseDragged(MouseEvent) - Method in class javax.swing.plaf.basic.BasicScrollBarUI.TrackListener
Set the models value to the position of the thumb's top of Vertical scrollbar, or the left/right of Horizontal scrollbar in left-to-right/right-to-left scrollbar relative to the origin of the track.
mouseDragged(MouseEvent) - Method in class javax.swing.plaf.basic.BasicSliderUI.TrackListener
Set the models value to the position of the top/left of the thumb relative to the origin of the track.
mouseDragged(MouseEvent) - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider.MouseHandler
If dragger is not null it is messaged with continueDrag.
mouseDragged(MouseEvent) - Method in class javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler
mouseDragged(MouseEvent) - Method in class javax.swing.plaf.basic.BasicTableUI.MouseInputHandler
mouseDragged(MouseEvent) - Method in class javax.swing.plaf.basic.BasicToolBarUI.DockingListener
mouseDragged(MouseEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.MouseHandler
mouseDragged(MouseEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler
mouseDragged(MouseEvent) - Method in class javax.swing.plaf.metal.MetalToolBarUI.MetalDockingListener
mouseDragged(MouseEvent) - Method in class javax.swing.text.DefaultCaret
Moves the caret position according to the mouse pointer's current location.
mouseDragged(MouseEvent) - Method in class javax.swing.text.html.HTMLEditorKit.LinkController
mouseDragged(MouseEvent) - Method in class javax.swing.ToolTipManager
Called when the mouse is pressed and dragged.
MouseDragGestureRecognizer - Class in java.awt.dnd
This abstract subclass of DragGestureRecognizer defines a DragGestureRecognizer for mouse-based gestures.
MouseDragGestureRecognizer(DragSource, Component, int, DragGestureListener) - Constructor for class java.awt.dnd.MouseDragGestureRecognizer
Construct a new MouseDragGestureRecognizer given the DragSource for the Component c, the Component to observe, the action(s) permitted for this drag operation, and the DragGestureListener to notify when a drag gesture is detected.
MouseDragGestureRecognizer(DragSource, Component, int) - Constructor for class java.awt.dnd.MouseDragGestureRecognizer
Construct a new MouseDragGestureRecognizer given the DragSource for the Component c, the Component to observe, and the action(s) permitted for this drag operation.
MouseDragGestureRecognizer(DragSource, Component) - Constructor for class java.awt.dnd.MouseDragGestureRecognizer
Construct a new MouseDragGestureRecognizer given the DragSource for the Component c, and the Component to observe.
MouseDragGestureRecognizer(DragSource) - Constructor for class java.awt.dnd.MouseDragGestureRecognizer
Construct a new MouseDragGestureRecognizer given the DragSource for the Component.
mouseEnter(Event, int, int) - Method in class java.awt.Component
Deprecated.
As of JDK version 1.1, replaced by processMouseEvent(MouseEvent).
mouseEntered(MouseEvent) - Method in class java.awt.AWTEventMulticaster
Handles the mouseEntered event by invoking the mouseEntered methods on listener-a and listener-b.
mouseEntered(MouseEvent) - Method in class java.awt.dnd.MouseDragGestureRecognizer
Invoked when the mouse enters a component.
mouseEntered(MouseEvent) - Method in class java.awt.event.MouseAdapter
Invoked when the mouse enters a component.
mouseEntered(MouseEvent) - Method in interface java.awt.event.MouseListener
Invoked when the mouse enters a component.
mouseEntered(MouseEvent) - Method in class javax.swing.plaf.basic.BasicButtonListener
mouseEntered(MouseEvent) - Method in class javax.swing.plaf.basic.BasicFileChooserUI.DoubleClickListener
The JList used for representing the files is created by subclasses, but the selection is monitored in this class.
mouseEntered(MouseEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener
mouseEntered(MouseEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher
mouseEntered(MouseEvent) - Method in class javax.swing.plaf.basic.BasicListUI.MouseInputHandler
mouseEntered(MouseEvent) - Method in class javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler
mouseEntered(MouseEvent) - Method in class javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler
Invoked when the cursor enters the menu.
mouseEntered(MouseEvent) - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider.MouseHandler
Invoked when the mouse enters a component.
mouseEntered(MouseEvent) - Method in class javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler
mouseEntered(MouseEvent) - Method in class javax.swing.plaf.basic.BasicTableUI.MouseInputHandler
mouseEntered(MouseEvent) - Method in class javax.swing.plaf.basic.BasicToolBarUI.DockingListener
mouseEntered(MouseEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler
mouseEntered(MouseEvent) - Method in class javax.swing.text.DefaultCaret
Called when the mouse enters a region.
mouseEntered(MouseEvent) - Method in class javax.swing.ToolTipManager
Called when the mouse enters the region of a component.
MouseEvent - Class in java.awt.event
An event which indicates that a mouse action occurred in a component.
MouseEvent(Component, int, long, int, int, int, int, boolean, int) - Constructor for class java.awt.event.MouseEvent
Constructs a MouseEvent object with the specified source component, type, time, modifiers, coordinates, click count, popupTrigger flag, and button number.
MouseEvent(Component, int, long, int, int, int, int, boolean) - Constructor for class java.awt.event.MouseEvent
Constructs a MouseEvent object with the specified source component, type, modifiers, coordinates, click count, and popupTrigger flag.
MouseEvent(Component, int, long, int, int, int, int, int, int, boolean, int) - Constructor for class java.awt.event.MouseEvent
Constructs a MouseEvent object with the specified source component, type, time, modifiers, coordinates, absolute coordinates, click count, popupTrigger flag, and button number.
MouseEvent - Interface in org.w3c.dom.events
The MouseEvent interface provides specific contextual information associated with Mouse events.
MouseEventListener() - Constructor for class javax.swing.text.html.FormView.MouseEventListener
mouseExit(Event, int, int) - Method in class java.awt.Component
Deprecated.
As of JDK version 1.1, replaced by processMouseEvent(MouseEvent).
mouseExited(MouseEvent) - Method in class java.awt.AWTEventMulticaster
Handles the mouseExited event by invoking the mouseExited methods on listener-a and listener-b.
mouseExited(MouseEvent) - Method in class java.awt.dnd.MouseDragGestureRecognizer
Invoked when the mouse exits a component.
mouseExited(MouseEvent) - Method in class java.awt.event.MouseAdapter
Invoked when the mouse exits a component.
mouseExited(MouseEvent) - Method in interface java.awt.event.MouseListener
Invoked when the mouse exits a component.
mouseExited(MouseEvent) - Method in class javax.swing.plaf.basic.BasicButtonListener
mouseExited(MouseEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener
mouseExited(MouseEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher
mouseExited(MouseEvent) - Method in class javax.swing.plaf.basic.BasicListUI.MouseInputHandler
mouseExited(MouseEvent) - Method in class javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler
mouseExited(MouseEvent) - Method in class javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler
mouseExited(MouseEvent) - Method in class javax.swing.plaf.basic.BasicScrollBarUI.TrackListener
Invoked when the mouse exits the scrollbar.
mouseExited(MouseEvent) - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider.MouseHandler
Invoked when the mouse exits a component.
mouseExited(MouseEvent) - Method in class javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler
mouseExited(MouseEvent) - Method in class javax.swing.plaf.basic.BasicTableUI.MouseInputHandler
mouseExited(MouseEvent) - Method in class javax.swing.plaf.basic.BasicToolBarUI.DockingListener
mouseExited(MouseEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler
mouseExited(MouseEvent) - Method in class javax.swing.text.DefaultCaret
Called when the mouse exits a region.
mouseExited(MouseEvent) - Method in class javax.swing.ToolTipManager
Called when the mouse exits the region of a component.
mouseHandler - Variable in class javax.swing.plaf.basic.BasicSplitPaneDivider
Handles mouse events from both this class, and the split pane.
MouseHandler() - Constructor for class javax.swing.plaf.basic.BasicSplitPaneDivider.MouseHandler
MouseHandler() - Constructor for class javax.swing.plaf.basic.BasicTabbedPaneUI.MouseHandler
MouseHandler() - Constructor for class javax.swing.plaf.basic.BasicTreeUI.MouseHandler
MouseInfo - Class in java.awt
MouseInfo provides methods for getting information about the mouse, such as mouse pointer location and the number of mouse buttons.
MouseInputAdapter - Class in javax.swing.event
An empty implementation of the MouseInputListener interface, provided as a convenience to simplify the task of creating listeners, by extending and implementing only the methods of interest.
MouseInputAdapter() - Constructor for class javax.swing.event.MouseInputAdapter
MouseInputHandler() - Constructor for class javax.swing.plaf.basic.BasicDesktopIconUI.MouseInputHandler
MouseInputHandler() - Constructor for class javax.swing.plaf.basic.BasicListUI.MouseInputHandler
MouseInputHandler() - Constructor for class javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler
MouseInputHandler() - Constructor for class javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler
MouseInputHandler() - Constructor for class javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler
MouseInputHandler() - Constructor for class javax.swing.plaf.basic.BasicTableUI.MouseInputHandler
MouseInputHandler(Component, Component, MouseEvent) - Constructor for class javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler
MouseInputListener - Interface in javax.swing.event
A listener implementing all the methods in both the MouseListener and MouseMotionListener interfaces.
mouseInputListener - Variable in class javax.swing.plaf.basic.BasicListUI
mouseInputListener - Variable in class javax.swing.plaf.basic.BasicMenuItemUI
mouseInputListener - Variable in class javax.swing.plaf.basic.BasicTableHeaderUI
mouseInputListener - Variable in class javax.swing.plaf.basic.BasicTableUI
MouseListener - Interface in java.awt.event
The listener interface for receiving "interesting" mouse events (press, release, click, enter, and exit) on a component.
mouseListener - Variable in class javax.swing.plaf.basic.BasicComboPopup
This protected field is implementation specific.
mouseListener - Variable in class javax.swing.plaf.basic.BasicTabbedPaneUI
MouseMotionAdapter - Class in java.awt.event
An abstract adapter class for receiving mouse motion events.
MouseMotionAdapter() - Constructor for class java.awt.event.MouseMotionAdapter
MouseMotionListener - Interface in java.awt.event
The listener interface for receiving mouse motion events on a component.
mouseMotionListener - Variable in class javax.swing.plaf.basic.BasicComboPopup
This protected field is implementation specific.
mouseMove(Event, int, int) - Method in class java.awt.Component
Deprecated.
As of JDK version 1.1, replaced by processMouseMotionEvent(MouseEvent).
mouseMove(int, int) - Method in class java.awt.Robot
Moves mouse pointer to given screen coordinates.
mouseMoved(MouseEvent) - Method in class java.awt.AWTEventMulticaster
Handles the mouseMoved event by invoking the mouseMoved methods on listener-a and listener-b.
mouseMoved(MouseEvent) - Method in class java.awt.dnd.MouseDragGestureRecognizer
Invoked when the mouse button has been moved on a component (with no buttons no down).
mouseMoved(MouseEvent) - Method in class java.awt.event.MouseAdapter
Invoked when the mouse cursor has been moved onto a component but no buttons have been pushed.
mouseMoved(MouseEvent) - Method in class java.awt.event.MouseMotionAdapter
Invoked when the mouse button has been moved on a component (with no buttons no down).
mouseMoved(MouseEvent) - Method in interface java.awt.event.MouseMotionListener
Invoked when the mouse cursor has been moved onto a component but no buttons have been pushed.
mouseMoved(MouseEvent) - Method in class javax.swing.plaf.basic.BasicButtonListener
mouseMoved(MouseEvent) - Method in class javax.swing.plaf.basic.BasicComboPopup.ListMouseMotionHandler
mouseMoved(MouseEvent) - Method in class javax.swing.plaf.basic.BasicDesktopIconUI.MouseInputHandler
mouseMoved(MouseEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener
mouseMoved(MouseEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher
mouseMoved(MouseEvent) - Method in class javax.swing.plaf.basic.BasicListUI.MouseInputHandler
mouseMoved(MouseEvent) - Method in class javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler
mouseMoved(MouseEvent) - Method in class javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler
mouseMoved(MouseEvent) - Method in class javax.swing.plaf.basic.BasicScrollBarUI.TrackListener
mouseMoved(MouseEvent) - Method in class javax.swing.plaf.basic.BasicSliderUI.TrackListener
mouseMoved(MouseEvent) - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider.MouseHandler
Resets the cursor based on the orientation.
mouseMoved(MouseEvent) - Method in class javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler
mouseMoved(MouseEvent) - Method in class javax.swing.plaf.basic.BasicTableUI.MouseInputHandler
mouseMoved(MouseEvent) - Method in class javax.swing.plaf.basic.BasicToolBarUI.DockingListener
mouseMoved(MouseEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.MouseHandler
Invoked when the mouse button has been moved on a component (with no buttons no down).
mouseMoved(MouseEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler
mouseMoved(MouseEvent) - Method in class javax.swing.text.DefaultCaret
Called when the mouse is moved.
mouseMoved(MouseEvent) - Method in class javax.swing.text.html.HTMLEditorKit.LinkController
mouseMoved(MouseEvent) - Method in class javax.swing.ToolTipManager
Called when the mouse is moved.
mousePress(int) - Method in class java.awt.Robot
Presses one or more mouse buttons.
mousePressed(MouseEvent) - Method in class java.awt.AWTEventMulticaster
Handles the mousePressed event by invoking the mousePressed methods on listener-a and listener-b.
mousePressed(MouseEvent) - Method in class java.awt.dnd.MouseDragGestureRecognizer
Invoked when a mouse button has been pressed on a Component.
mousePressed(MouseEvent) - Method in class java.awt.event.MouseAdapter
Invoked when a mouse button has been pressed on a component.
mousePressed(MouseEvent) - Method in interface java.awt.event.MouseListener
Invoked when a mouse button has been pressed on a component.
mousePressed(MouseEvent) - Method in class javax.swing.plaf.basic.BasicButtonListener
mousePressed(MouseEvent) - Method in class javax.swing.plaf.basic.BasicComboPopup.InvocationMouseHandler
Responds to mouse-pressed events on the combo box.
mousePressed(MouseEvent) - Method in class javax.swing.plaf.basic.BasicComboPopup.ListMouseHandler
mousePressed(MouseEvent) - Method in class javax.swing.plaf.basic.BasicDesktopIconUI.MouseInputHandler
mousePressed(MouseEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener
mousePressed(MouseEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher
mousePressed(MouseEvent) - Method in class javax.swing.plaf.basic.BasicListUI.MouseInputHandler
mousePressed(MouseEvent) - Method in class javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler
mousePressed(MouseEvent) - Method in class javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler
Invoked when the mouse has been clicked on the menu.
mousePressed(MouseEvent) - Method in class javax.swing.plaf.basic.BasicScrollBarUI.ArrowButtonListener
mousePressed(MouseEvent) - Method in class javax.swing.plaf.basic.BasicScrollBarUI.TrackListener
If the mouse is pressed above the "thumb" component then reduce the scrollbars value by one page ("page up"), otherwise increase it by one page.
mousePressed(MouseEvent) - Method in class javax.swing.plaf.basic.BasicSliderUI.TrackListener
If the mouse is pressed above the "thumb" component then reduce the scrollbars value by one page ("page up"), otherwise increase it by one page.
mousePressed(MouseEvent) - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider.MouseHandler
Starts the dragging session by creating the appropriate instance of DragController.
mousePressed(MouseEvent) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI.MouseHandler
mousePressed(MouseEvent) - Method in class javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler
mousePressed(MouseEvent) - Method in class javax.swing.plaf.basic.BasicTableUI.MouseInputHandler
mousePressed(MouseEvent) - Method in class javax.swing.plaf.basic.BasicToolBarUI.DockingListener
mousePressed(MouseEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.MouseHandler
Invoked when a mouse button has been pressed on a component.
mousePressed(MouseEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler
mousePressed(MouseEvent) - Method in class javax.swing.plaf.metal.MetalToolBarUI.MetalDockingListener
mousePressed(MouseEvent) - Method in class javax.swing.text.DefaultCaret
If button 1 is pressed, this is implemented to request focus on the associated text component, and to set the caret position.
mousePressed(MouseEvent) - Method in class javax.swing.ToolTipManager
Called when the mouse is pressed.
mouseRelease(int) - Method in class java.awt.Robot
Releases one or more mouse buttons.
mouseReleased(MouseEvent) - Method in class java.awt.AWTEventMulticaster
Handles the mouseReleased event by invoking the mouseReleased methods on listener-a and listener-b.
mouseReleased(MouseEvent) - Method in class java.awt.dnd.MouseDragGestureRecognizer
Invoked when a mouse button has been released on a component.
mouseReleased(MouseEvent) - Method in class java.awt.event.MouseAdapter
Invoked when a mouse button has been released on a component.
mouseReleased(MouseEvent) - Method in interface java.awt.event.MouseListener
Invoked when a mouse button has been released on a component.
mouseReleased(MouseEvent) - Method in class javax.swing.plaf.basic.BasicButtonListener
mouseReleased(MouseEvent) - Method in class javax.swing.plaf.basic.BasicComboPopup.InvocationMouseHandler
Responds to the user terminating a click or drag that began on the combo box.
mouseReleased(MouseEvent) - Method in class javax.swing.plaf.basic.BasicComboPopup.ListMouseHandler
mouseReleased(MouseEvent) - Method in class javax.swing.plaf.basic.BasicDesktopIconUI.MouseInputHandler
mouseReleased(MouseEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener
mouseReleased(MouseEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher
mouseReleased(MouseEvent) - Method in class javax.swing.plaf.basic.BasicListUI.MouseInputHandler
mouseReleased(MouseEvent) - Method in class javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler
mouseReleased(MouseEvent) - Method in class javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler
Invoked when the mouse has been released on the menu.
mouseReleased(MouseEvent) - Method in class javax.swing.plaf.basic.BasicScrollBarUI.ArrowButtonListener
mouseReleased(MouseEvent) - Method in class javax.swing.plaf.basic.BasicScrollBarUI.TrackListener
mouseReleased(MouseEvent) - Method in class javax.swing.plaf.basic.BasicSliderUI.TrackListener
mouseReleased(MouseEvent) - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider.MouseHandler
If dragger is not null it is messaged with completeDrag.
mouseReleased(MouseEvent) - Method in class javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler
mouseReleased(MouseEvent) - Method in class javax.swing.plaf.basic.BasicTableUI.MouseInputHandler
mouseReleased(MouseEvent) - Method in class javax.swing.plaf.basic.BasicToolBarUI.DockingListener
mouseReleased(MouseEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.MouseHandler
mouseReleased(MouseEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler
mouseReleased(MouseEvent) - Method in class javax.swing.text.DefaultCaret
Called when the mouse is released.
mouseReleased(MouseEvent) - Method in class javax.swing.text.html.FormView.MouseEventListener
mouseUp(Event, int, int) - Method in class java.awt.Component
Deprecated.
As of JDK version 1.1, replaced by processMouseEvent(MouseEvent).
mouseWheel(int) - Method in class java.awt.Robot
Rotates the scroll wheel on wheel-equipped mice.
MouseWheelEvent - Class in java.awt.event
An event which indicates that the mouse wheel was rotated in a component.
MouseWheelEvent(Component, int, long, int, int, int, int, boolean, int, int, int) - Constructor for class java.awt.event.MouseWheelEvent
Constructs a MouseWheelEvent object with the specified source component, type, modifiers, coordinates, scroll type, scroll amount, and wheel rotation.
MouseWheelEvent(Component, int, long, int, int, int, int, int, int, boolean, int, int, int) - Constructor for class java.awt.event.MouseWheelEvent
Constructs a MouseWheelEvent object with the specified source component, type, modifiers, coordinates, absolute coordinates, scroll type, scroll amount, and wheel rotation.
MouseWheelEvent(Component, int, long, int, int, int, int, int, int, boolean, int, int, int, double) - Constructor for class java.awt.event.MouseWheelEvent
Constructs a MouseWheelEvent object with the specified source component, type, modifiers, coordinates, absolute coordinates, scroll type, scroll amount, and wheel rotation.
MouseWheelHandler() - Constructor for class javax.swing.plaf.basic.BasicScrollPaneUI.MouseWheelHandler
MouseWheelListener - Interface in java.awt.event
The listener interface for receiving mouse wheel events on a component.
mouseWheelMoved(MouseWheelEvent) - Method in class java.awt.AWTEventMulticaster
Handles the mouseWheelMoved event by invoking the mouseWheelMoved methods on listener-a and listener-b.
mouseWheelMoved(MouseWheelEvent) - Method in class java.awt.event.MouseAdapter
Invoked when the mouse wheel is rotated.
mouseWheelMoved(MouseWheelEvent) - Method in interface java.awt.event.MouseWheelListener
Invoked when the mouse wheel is rotated.
mouseWheelMoved(MouseWheelEvent) - Method in class javax.swing.plaf.basic.BasicScrollPaneUI.MouseWheelHandler
Called when the mouse wheel is rotated while over a JScrollPane.
move(int, int) - Method in class java.awt.Component
Deprecated.
As of JDK version 1.1, replaced by setLocation(int, int).
move(int, int) - Method in class java.awt.Point
Moves this point to the specified location in the (x,y) coordinate plane.
move(int, int) - Method in class java.awt.Rectangle
Deprecated.
As of JDK version 1.1, replaced by setLocation(int, int).
move(Path, Path, CopyOption...) - Static method in class java.nio.file.Files
Move or rename a file to a target file.
move(T, SecureDirectoryStream<T>, T) - Method in interface java.nio.file.SecureDirectoryStream
Move a file from this directory to another directory.
move(Path, Path, CopyOption...) - Method in class java.nio.file.spi.FileSystemProvider
Move or rename a file to a target file.
MOVE - Static variable in class javax.swing.TransferHandler
An int representing a "move" transfer action.
MOVE_CMD - Static variable in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
MOVE_CURSOR - Static variable in class java.awt.Cursor
The move cursor type.
MOVE_CURSOR - Static variable in class java.awt.Frame
Deprecated.
replaced by Cursor.MOVE_CURSOR.
moveAction - Variable in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
MoveAction() - Constructor for class javax.swing.plaf.basic.BasicInternalFrameTitlePane.MoveAction
moveAndRepaint(JComponent, int, int, int, int) - Method in class javax.swing.plaf.basic.BasicDesktopIconUI.MouseInputHandler
moveCaret(MouseEvent) - Method in class javax.swing.text.DefaultCaret
Tries to move the position of the caret from the coordinates of a mouse event, using viewToModel().
moveCaretPosition(int) - Method in class javax.swing.text.JTextComponent
Moves the caret to a new position, leaving behind a mark defined by the last time setCaretPosition was called.
moveColumn(int, int) - Method in class javax.swing.JTable
Moves the column column to the position currently occupied by the column targetColumn in the view.
moveColumn(int, int) - Method in class javax.swing.table.DefaultTableColumnModel
Moves the column and heading at columnIndex to newIndex.
moveColumn(int, int) - Method in interface javax.swing.table.TableColumnModel
Moves the column and its header at columnIndex to newIndex.
moveDot(int) - Method in interface javax.swing.text.Caret
Moves the caret position (dot) to some other position, leaving behind the mark.
moveDot(int) - Method in class javax.swing.text.DefaultCaret
Moves the caret position to the specified position, with a forward bias.
moveDot(int, Position.Bias) - Method in class javax.swing.text.DefaultCaret
Moves the caret position to the specified position, with the specified bias.
moveDot(int, Position.Bias) - Method in class javax.swing.text.NavigationFilter.FilterBypass
Moves the caret location, bypassing the NavigationFilter.
moveDot(NavigationFilter.FilterBypass, int, Position.Bias) - Method in class javax.swing.text.NavigationFilter
Invoked prior to the Caret moving the dot.
moveLeadSelectionIndex(int) - Method in class javax.swing.DefaultListSelectionModel
Set the lead selection index, leaving all selection values unchanged.
movePointLeft(int) - Method in class java.math.BigDecimal
Returns a BigDecimal which is equivalent to this one with the decimal point moved n places to the left.
movePointRight(int) - Method in class java.math.BigDecimal
Returns a BigDecimal which is equivalent to this one with the decimal point moved n places to the right.
moveRow(int, int, int) - Method in class javax.swing.table.DefaultTableModel
Moves one or more rows from the inclusive range start to end to the to position in the model.
moveTo(double, double) - Method in class java.awt.geom.Path2D.Double
Adds a point to the path by moving to the specified coordinates specified in double precision.
moveTo(double, double) - Method in class java.awt.geom.Path2D.Float
Adds a point to the path by moving to the specified coordinates specified in double precision.
moveTo(float, float) - Method in class java.awt.geom.Path2D.Float
Adds a point to the path by moving to the specified coordinates specified in float precision.
moveTo(double, double) - Method in class java.awt.geom.Path2D
Adds a point to the path by moving to the specified coordinates specified in double precision.
moveToBack() - Method in class javax.swing.JInternalFrame
Convenience method that moves this component to position -1 if its parent is a JLayeredPane.
moveToBack(Component) - Method in class javax.swing.JLayeredPane
Moves the component to the bottom of the components in its current layer (position -1).
moveToCurrentRow() - Method in interface java.sql.ResultSet
Moves the cursor to the remembered cursor position, usually the current row.
moveToFront() - Method in class javax.swing.JInternalFrame
Convenience method that moves this component to position 0 if its parent is a JLayeredPane.
moveToFront(Component) - Method in class javax.swing.JLayeredPane
Moves the component to the top of the components in its current layer (position 0).
moveToInsertRow() - Method in interface java.sql.ResultSet
Moves the cursor to the insert row.
MOVING_TO_PAUSED - Static variable in class javax.print.attribute.standard.PrinterStateReason
Someone has paused the printer, but the device(s) are taking an appreciable time to stop.
MS - Static variable in interface javax.swing.text.html.parser.DTDConstants
MTOM - Annotation Type in javax.xml.ws.soap
This feature represents the use of MTOM with a web service.
MTOMFeature - Class in javax.xml.ws.soap
This feature represents the use of MTOM with a web service.
MTOMFeature() - Constructor for class javax.xml.ws.soap.MTOMFeature
Create an MTOMFeature.
MTOMFeature(boolean) - Constructor for class javax.xml.ws.soap.MTOMFeature
Creates an MTOMFeature.
MTOMFeature(int) - Constructor for class javax.xml.ws.soap.MTOMFeature
Creates an MTOMFeature.
MTOMFeature(boolean, int) - Constructor for class javax.xml.ws.soap.MTOMFeature
Creates an MTOMFeature.
MULTI_LINE - Static variable in class javax.accessibility.AccessibleState
Indicates this (text) object can contain multiple lines of text
MULTI_SELECTION_ENABLED_CHANGED_PROPERTY - Static variable in class javax.swing.JFileChooser
Enables multiple-file selections.
MultiButtonUI - Class in javax.swing.plaf.multi
A multiplexing UI used to combine ButtonUIs.
MultiButtonUI() - Constructor for class javax.swing.plaf.multi.MultiButtonUI
MulticastChannel - Interface in java.nio.channels
A network channel that supports Internet Protocol (IP) multicasting.
MulticastSocket - Class in java.net
The multicast datagram socket class is useful for sending and receiving IP multicast packets.
MulticastSocket() - Constructor for class java.net.MulticastSocket
Create a multicast socket.
MulticastSocket(int) - Constructor for class java.net.MulticastSocket
Create a multicast socket and bind it to a specific port.
MulticastSocket(SocketAddress) - Constructor for class java.net.MulticastSocket
Create a MulticastSocket bound to the specified socket address.
MultiColorChooserUI - Class in javax.swing.plaf.multi
A multiplexing UI used to combine ColorChooserUIs.
MultiColorChooserUI() - Constructor for class javax.swing.plaf.multi.MultiColorChooserUI
MultiComboBoxUI - Class in javax.swing.plaf.multi
A multiplexing UI used to combine ComboBoxUIs.
MultiComboBoxUI() - Constructor for class javax.swing.plaf.multi.MultiComboBoxUI
MultiDesktopIconUI - Class in javax.swing.plaf.multi
A multiplexing UI used to combine DesktopIconUIs.
MultiDesktopIconUI() - Constructor for class javax.swing.plaf.multi.MultiDesktopIconUI
MultiDesktopPaneUI - Class in javax.swing.plaf.multi
A multiplexing UI used to combine DesktopPaneUIs.
MultiDesktopPaneUI() - Constructor for class javax.swing.plaf.multi.MultiDesktopPaneUI
MultiDoc - Interface in javax.print
Interface MultiDoc specifies the interface for an object that supplies more than one piece of print data for a Print Job.
MultiDocPrintJob - Interface in javax.print
Obtained from a MultiDocPrintService, a MultiDocPrintJob can print a specified collection of documents as a single print job with a set of job attributes.
MultiDocPrintService - Interface in javax.print
Interface MultiPrintService is the factory for a MultiDocPrintJob.
MultiFileChooserUI - Class in javax.swing.plaf.multi
A multiplexing UI used to combine FileChooserUIs.
MultiFileChooserUI() - Constructor for class javax.swing.plaf.multi.MultiFileChooserUI
MultiInternalFrameUI - Class in javax.swing.plaf.multi
A multiplexing UI used to combine InternalFrameUIs.
MultiInternalFrameUI() - Constructor for class javax.swing.plaf.multi.MultiInternalFrameUI
MultiLabelUI - Class in javax.swing.plaf.multi
A multiplexing UI used to combine LabelUIs.
MultiLabelUI() - Constructor for class javax.swing.plaf.multi.MultiLabelUI
MULTILINE - Static variable in class java.util.regex.Pattern
Enables multiline mode.
MultiListUI - Class in javax.swing.plaf.multi
A multiplexing UI used to combine ListUIs.
MultiListUI() - Constructor for class javax.swing.plaf.multi.MultiListUI
MultiLookAndFeel - Class in javax.swing.plaf.multi
A multiplexing look and feel that allows more than one UI to be associated with a component at the same time.
MultiLookAndFeel() - Constructor for class javax.swing.plaf.multi.MultiLookAndFeel
MultiMenuBarUI - Class in javax.swing.plaf.multi
A multiplexing UI used to combine MenuBarUIs.
MultiMenuBarUI() - Constructor for class javax.swing.plaf.multi.MultiMenuBarUI
MultiMenuItemUI - Class in javax.swing.plaf.multi
A multiplexing UI used to combine MenuItemUIs.
MultiMenuItemUI() - Constructor for class javax.swing.plaf.multi.MultiMenuItemUI
MultiOptionPaneUI - Class in javax.swing.plaf.multi
A multiplexing UI used to combine OptionPaneUIs.
MultiOptionPaneUI() - Constructor for class javax.swing.plaf.multi.MultiOptionPaneUI
MultiPanelUI - Class in javax.swing.plaf.multi
A multiplexing UI used to combine PanelUIs.
MultiPanelUI() - Constructor for class javax.swing.plaf.multi.MultiPanelUI
MultiPixelPackedSampleModel - Class in java.awt.image
The MultiPixelPackedSampleModel class represents one-banded images and can pack multiple one-sample pixels into one data element.
MultiPixelPackedSampleModel(int, int, int, int) - Constructor for class java.awt.image.MultiPixelPackedSampleModel
Constructs a MultiPixelPackedSampleModel with the specified data type, width, height and number of bits per pixel.
MultiPixelPackedSampleModel(int, int, int, int, int, int) - Constructor for class java.awt.image.MultiPixelPackedSampleModel
Constructs a MultiPixelPackedSampleModel with specified data type, width, height, number of bits per pixel, scanline stride and data bit offset.
MULTIPLE - Static variable in class javax.swing.text.html.HTML.Attribute
MULTIPLE_ID - Static variable in class org.omg.PortableServer.IdUniquenessPolicyValue
MULTIPLE_INTERVAL_SELECTION - Static variable in interface javax.swing.ListSelectionModel
A value for the selectionMode property: select one or more contiguous ranges of indices at a time.
MultipleComponentProfileHelper - Class in org.omg.IOP
An array of tagged components, forming a multiple component profile.
MultipleComponentProfileHelper() - Constructor for class org.omg.IOP.MultipleComponentProfileHelper
MultipleComponentProfileHolder - Class in org.omg.IOP
An array of tagged components, forming a multiple component profile.
MultipleComponentProfileHolder() - Constructor for class org.omg.IOP.MultipleComponentProfileHolder
MultipleComponentProfileHolder(TaggedComponent[]) - Constructor for class org.omg.IOP.MultipleComponentProfileHolder
MultipleDocumentHandling - Class in javax.print.attribute.standard
Class MultipleDocumentHandling is a printing attribute class, an enumeration, that controls finishing operations and the placement of one or more print-stream pages into impressions and onto media sheets.
MultipleDocumentHandling(int) - Constructor for class javax.print.attribute.standard.MultipleDocumentHandling
Construct a new multiple document handling enumeration value with the given integer value.
MultipleGradientPaint - Class in java.awt
This is the superclass for Paints which use a multiple color gradient to fill in their raster.
MultipleGradientPaint.ColorSpaceType - Enum in java.awt
The color space in which to perform the gradient interpolation.
MultipleGradientPaint.CycleMethod - Enum in java.awt
The method to use when painting outside the gradient bounds.
MultipleMaster - Interface in java.awt.font
The MultipleMaster interface represents Type 1 Multiple Master fonts.
multipliedBy(int) - Method in interface java.time.chrono.ChronoPeriod
Returns a new instance with each amount in this period in this period multiplied by the specified scalar.
multipliedBy(long) - Method in class java.time.Duration
Returns a copy of this duration multiplied by the scalar.
multipliedBy(int) - Method in class java.time.Period
Returns a new instance with each element in this period multiplied by the specified scalar.
multiply(BigDecimal) - Method in class java.math.BigDecimal
Returns a BigDecimal whose value is (this × multiplicand), and whose scale is (this.scale() + multiplicand.scale()).
multiply(BigDecimal, MathContext) - Method in class java.math.BigDecimal
Returns a BigDecimal whose value is (this × multiplicand), with rounding according to the context settings.
multiply(BigInteger) - Method in class java.math.BigInteger
Returns a BigInteger whose value is (this * val).
multiply(int) - Method in class javax.xml.datatype.Duration
Computes a new duration whose value is factor times longer than the value of this duration.
multiply(BigDecimal) - Method in class javax.xml.datatype.Duration
Computes a new duration whose value is factor times longer than the value of this duration.
multiplyExact(int, int) - Static method in class java.lang.Math
Returns the product of the arguments, throwing an exception if the result overflows an int.
multiplyExact(long, long) - Static method in class java.lang.Math
Returns the product of the arguments, throwing an exception if the result overflows a long.
multiplyExact(int, int) - Static method in class java.lang.StrictMath
Returns the product of the arguments, throwing an exception if the result overflows an int.
multiplyExact(long, long) - Static method in class java.lang.StrictMath
Returns the product of the arguments, throwing an exception if the result overflows a long.
MultiPopupMenuUI - Class in javax.swing.plaf.multi
A multiplexing UI used to combine PopupMenuUIs.
MultiPopupMenuUI() - Constructor for class javax.swing.plaf.multi.MultiPopupMenuUI
MultiProgressBarUI - Class in javax.swing.plaf.multi
A multiplexing UI used to combine ProgressBarUIs.
MultiProgressBarUI() - Constructor for class javax.swing.plaf.multi.MultiProgressBarUI
MultiRootPaneUI - Class in javax.swing.plaf.multi
A multiplexing UI used to combine RootPaneUIs.
MultiRootPaneUI() - Constructor for class javax.swing.plaf.multi.MultiRootPaneUI
MultiScrollBarUI - Class in javax.swing.plaf.multi
A multiplexing UI used to combine ScrollBarUIs.
MultiScrollBarUI() - Constructor for class javax.swing.plaf.multi.MultiScrollBarUI
MultiScrollPaneUI - Class in javax.swing.plaf.multi
A multiplexing UI used to combine ScrollPaneUIs.
MultiScrollPaneUI() - Constructor for class javax.swing.plaf.multi.MultiScrollPaneUI
MULTISELECTABLE - Static variable in class javax.accessibility.AccessibleState
Indicates this object allows more than one of its children to be selected at the same time.
MultiSeparatorUI - Class in javax.swing.plaf.multi
A multiplexing UI used to combine SeparatorUIs.
MultiSeparatorUI() - Constructor for class javax.swing.plaf.multi.MultiSeparatorUI
MultiSliderUI - Class in javax.swing.plaf.multi
A multiplexing UI used to combine SliderUIs.
MultiSliderUI() - Constructor for class javax.swing.plaf.multi.MultiSliderUI
MultiSpinnerUI - Class in javax.swing.plaf.multi
A multiplexing UI used to combine SpinnerUIs.
MultiSpinnerUI() - Constructor for class javax.swing.plaf.multi.MultiSpinnerUI
MultiSplitPaneUI - Class in javax.swing.plaf.multi
A multiplexing UI used to combine SplitPaneUIs.
MultiSplitPaneUI() - Constructor for class javax.swing.plaf.multi.MultiSplitPaneUI
MultiTabbedPaneUI - Class in javax.swing.plaf.multi
A multiplexing UI used to combine TabbedPaneUIs.
MultiTabbedPaneUI() - Constructor for class javax.swing.plaf.multi.MultiTabbedPaneUI
MultiTableHeaderUI - Class in javax.swing.plaf.multi
A multiplexing UI used to combine TableHeaderUIs.
MultiTableHeaderUI() - Constructor for class javax.swing.plaf.multi.MultiTableHeaderUI
MultiTableUI - Class in javax.swing.plaf.multi
A multiplexing UI used to combine TableUIs.
MultiTableUI() - Constructor for class javax.swing.plaf.multi.MultiTableUI
MultiTextUI - Class in javax.swing.plaf.multi
A multiplexing UI used to combine TextUIs.
MultiTextUI() - Constructor for class javax.swing.plaf.multi.MultiTextUI
MultiToolBarUI - Class in javax.swing.plaf.multi
A multiplexing UI used to combine ToolBarUIs.
MultiToolBarUI() - Constructor for class javax.swing.plaf.multi.MultiToolBarUI
MultiToolTipUI - Class in javax.swing.plaf.multi
A multiplexing UI used to combine ToolTipUIs.
MultiToolTipUI() - Constructor for class javax.swing.plaf.multi.MultiToolTipUI
MultiTreeUI - Class in javax.swing.plaf.multi
A multiplexing UI used to combine TreeUIs.
MultiTreeUI() - Constructor for class javax.swing.plaf.multi.MultiTreeUI
MultiViewportUI - Class in javax.swing.plaf.multi
A multiplexing UI used to combine ViewportUIs.
MultiViewportUI() - Constructor for class javax.swing.plaf.multi.MultiViewportUI
MUSICAL_SYMBOLS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Musical Symbols" Unicode character block.
MutableAttributeSet - Interface in javax.swing.text
A generic interface for a mutable collection of unique attributes.
MutableCallSite - Class in java.lang.invoke
A MutableCallSite is a CallSite whose target variable behaves like an ordinary field.
MutableCallSite(MethodType) - Constructor for class java.lang.invoke.MutableCallSite
Creates a blank call site object with the given method type.
MutableCallSite(MethodHandle) - Constructor for class java.lang.invoke.MutableCallSite
Creates a call site object with an initial target method handle.
MutableComboBoxModel<E> - Interface in javax.swing
A mutable version of ComboBoxModel.
MutableTreeNode - Interface in javax.swing.tree
Defines the requirements for a tree node object that can change -- by adding or removing child nodes, or by changing the contents of a user object stored in the node.
mutatesTo(Object, Object) - Method in class java.beans.DefaultPersistenceDelegate
If the number of arguments in the specified constructor is non-zero and the class of oldInstance explicitly declares an "equals" method this method returns the value of oldInstance.equals(newInstance).
mutatesTo(Object, Object) - Method in class java.beans.PersistenceDelegate
Returns true if an equivalent copy of oldInstance may be created by applying a series of statements to newInstance.
MutationEvent - Interface in org.w3c.dom.events
The MutationEvent interface provides specific contextual information associated with Mutation events.
MUTE - Static variable in class javax.sound.sampled.BooleanControl.Type
Represents a control for the mute status of a line.
MXBean - Annotation Type in javax.management
Annotation to mark an interface explicitly as being an MXBean interface, or as not being an MXBean interface.
MXBEAN_FIELD - Static variable in class javax.management.JMX
The name of the mxbean field.
MYANMAR - Static variable in class java.awt.font.NumericShaper
Identifies the MYANMAR range and decimal base.
MYANMAR - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Myanmar" Unicode character block.
MYANMAR_EXTENDED_A - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Myanmar Extended-A" Unicode character block.
myProps - Variable in class javax.naming.InitialContext
The environment associated with this InitialContext.
mySyntax - Variable in class javax.naming.CompoundName
Syntax properties for this compound name.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames


N-Index (Java Platform SE 8 )

Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames
  • All Classes
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

N

N - Static variable in class javax.swing.text.html.HTML.Attribute
N_RESIZE_CURSOR - Static variable in class java.awt.Cursor
The north-resize cursor type.
N_RESIZE_CURSOR - Static variable in class java.awt.Frame
Deprecated.
replaced by Cursor.N_RESIZE_CURSOR.
NA_10X13_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for North American 10 x 13 in.
NA_10x13_ENVELOPE - Static variable in class javax.print.attribute.standard.MediaSize.NA
Specifies the North American 10 inch by 13 inch envelope size.
NA_10X13_ENVELOPE - Static variable in class javax.print.attribute.standard.MediaSizeName
10x13 North American envelope size .
NA_10X14_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for North American 10 x 14 in.
NA_10x14_ENVELOPE - Static variable in class javax.print.attribute.standard.MediaSize.NA
Specifies the North American 10 inch by 14 inch envelope size.
NA_10X14_ENVELOPE - Static variable in class javax.print.attribute.standard.MediaSizeName
10x14North American envelope size .
NA_10X15_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for North American 10 x 15 in.
NA_10X15_ENVELOPE - Static variable in class javax.print.attribute.standard.MediaSize.NA
Specifies the North American 10 inch by 15 inch envelope size.
NA_10X15_ENVELOPE - Static variable in class javax.print.attribute.standard.MediaSizeName
10x15 North American envelope size.
NA_5X7 - Static variable in class javax.print.attribute.standard.MediaSize.NA
Specifies the North American 5 inch by 7 inch paper.
NA_5X7 - Static variable in class javax.print.attribute.standard.MediaSizeName
5x7 North American paper.
NA_6X9_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for North American 6 x 9 in.
NA_6X9_ENVELOPE - Static variable in class javax.print.attribute.standard.MediaSize.NA
Specifies the North American 6 inch by 9 inch envelope size.
NA_6X9_ENVELOPE - Static variable in class javax.print.attribute.standard.MediaSizeName
6x9 North American envelope size.
NA_7X9_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for North American 7 x 9 in.
NA_7X9_ENVELOPE - Static variable in class javax.print.attribute.standard.MediaSize.NA
Specifies the North American 7 inch by 9 inch envelope size.
NA_7X9_ENVELOPE - Static variable in class javax.print.attribute.standard.MediaSizeName
7x9 North American envelope size.
NA_8X10 - Static variable in class javax.print.attribute.standard.MediaSize.NA
Specifies the North American 8 inch by 10 inch paper.
NA_8X10 - Static variable in class javax.print.attribute.standard.MediaSizeName
8x10 North American paper.
NA_9X11_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for North American 9 x 11 in.
NA_9x11_ENVELOPE - Static variable in class javax.print.attribute.standard.MediaSize.NA
Specifies the North American 9 inch by 11 inch envelope size.
NA_9X11_ENVELOPE - Static variable in class javax.print.attribute.standard.MediaSizeName
9x11 North American envelope size.
NA_9X12_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for North American 9 x 12 in.
NA_9x12_ENVELOPE - Static variable in class javax.print.attribute.standard.MediaSize.NA
Specifies the North American 9 inch by 12 inch envelope size.
NA_9X12_ENVELOPE - Static variable in class javax.print.attribute.standard.MediaSizeName
9x12 North American envelope size.
NA_LEGAL - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for North American Legal, 8 1/2 x 14 in.
NA_LEGAL - Static variable in class javax.print.attribute.standard.MediaSizeName
legal size .
NA_LETTER - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for North American Letter, 8 1/2 x 11 in.
NA_LETTER - Static variable in class javax.print.attribute.standard.MediaSizeName
letter size.
NA_LETTER_TRANSPARENT - Static variable in class javax.print.attribute.standard.MediaName
letter transparency.
NA_LETTER_WHITE - Static variable in class javax.print.attribute.standard.MediaName
white letter paper.
NA_NUMBER_10_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for North American #10 Business Envelope, 4 1/8 x 9 1/2 in.
NA_NUMBER_10_ENVELOPE - Static variable in class javax.print.attribute.standard.MediaSize.NA
Specifies the North American Number 10 business envelope size, 4.125 inches by 9.5 inches.
NA_NUMBER_10_ENVELOPE - Static variable in class javax.print.attribute.standard.MediaSizeName
number 10 envelope size .
NA_NUMBER_11_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for North American #11 Business Envelope, 4 1/2 x 10 3/8 in.
NA_NUMBER_11_ENVELOPE - Static variable in class javax.print.attribute.standard.MediaSize.NA
Specifies the North American Number 11 business envelope size, 4.5 inches by 10.375 inches.
NA_NUMBER_11_ENVELOPE - Static variable in class javax.print.attribute.standard.MediaSizeName
number 11 envelope size .
NA_NUMBER_12_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for North American #12 Business Envelope, 4 3/4 x 11 in.
NA_NUMBER_12_ENVELOPE - Static variable in class javax.print.attribute.standard.MediaSize.NA
Specifies the North American Number 12 business envelope size, 4.75 inches by 11 inches.
NA_NUMBER_12_ENVELOPE - Static variable in class javax.print.attribute.standard.MediaSizeName
number 12 envelope size .
NA_NUMBER_14_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for North American #14 Business Envelope, 5 x 11 1/2 in.
NA_NUMBER_14_ENVELOPE - Static variable in class javax.print.attribute.standard.MediaSize.NA
Specifies the North American Number 14 business envelope size, 5 inches by 11.5 inches.
NA_NUMBER_14_ENVELOPE - Static variable in class javax.print.attribute.standard.MediaSizeName
number 14 envelope size .
NA_NUMBER_9_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for North American #9 Business Envelope, 3 7/8 x 8 7/8 in.
NA_NUMBER_9_ENVELOPE - Static variable in class javax.print.attribute.standard.MediaSize.NA
Specifies the North American Number 9 business envelope size, 3.875 inches by 8.875 inches.
NA_NUMBER_9_ENVELOPE - Static variable in class javax.print.attribute.standard.MediaSizeName
number 9 envelope size .
name - Variable in class java.awt.Cursor
The user-visible name of the cursor.
name - Variable in class java.awt.Font
The logical name of this Font, as passed to the constructor.
name() - Method in class java.lang.Enum
Returns the name of this enum constant, exactly as declared in its enum declaration.
name() - Method in interface java.net.ProtocolFamily
Returns the name of the protocol family.
name() - Method in interface java.net.SocketOption
Returns the name of the socket option.
name() - Method in class java.nio.charset.Charset
Returns this charset's canonical name.
name() - Method in interface java.nio.file.attribute.AclFileAttributeView
Returns the name of the attribute view.
name() - Method in interface java.nio.file.attribute.AttributeView
Returns the name of the attribute view.
name() - Method in interface java.nio.file.attribute.BasicFileAttributeView
Returns the name of the attribute view.
name() - Method in interface java.nio.file.attribute.DosFileAttributeView
Returns the name of the attribute view.
name() - Method in interface java.nio.file.attribute.FileAttribute
Returns the attribute name.
name() - Method in interface java.nio.file.attribute.FileOwnerAttributeView
Returns the name of the attribute view.
name() - Method in interface java.nio.file.attribute.PosixFileAttributeView
Returns the name of the attribute view.
name() - Method in interface java.nio.file.attribute.UserDefinedFileAttributeView
Returns the name of this attribute view.
name() - Method in class java.nio.file.FileStore
Returns the name of this file store.
name() - Method in interface java.nio.file.WatchEvent.Kind
Returns the name of the event kind.
name() - Method in interface java.nio.file.WatchEvent.Modifier
Returns the name of the modifier.
name - Variable in class java.sql.DriverPropertyInfo
The name of the property.
Name(String) - Constructor for class java.util.jar.Attributes.Name
Constructs a new attribute name using the given string name.
name() - Method in class java.util.prefs.AbstractPreferences
Implements the name method as per the specification in Preferences.name().
name() - Method in class java.util.prefs.Preferences
Returns this preference node's name, relative to its parent.
Name - Interface in javax.lang.model.element
An immutable sequence of characters.
name - Variable in class javax.management.MBeanFeatureInfo
The name of the feature.
Name - Interface in javax.naming
The Name interface represents a generic name -- an ordered sequence of components.
NAME - Static variable in interface javax.script.ScriptEngine
Reserved key for a named value that identifies the short name of the scripting language.
NAME - Static variable in interface javax.swing.Action
The key used for storing the String name for the action, used for a menu or button.
NAME - Static variable in class javax.swing.text.html.HTML.Attribute
name - Variable in class javax.swing.text.html.parser.AttributeList
name - Variable in class javax.swing.text.html.parser.DTD
NAME - Static variable in interface javax.swing.text.html.parser.DTDConstants
name - Variable in class javax.swing.text.html.parser.Element
name - Variable in class javax.swing.text.html.parser.Entity
name - Variable in class javax.xml.bind.JAXBElement
xml element tag name
Name - Interface in javax.xml.soap
A representation of an XML name.
name() - Method in class org.omg.CORBA.NamedValue
Retrieves the name for this NamedValue object.
name(byte[]) - Method in class org.omg.CORBA.Principal
Deprecated.
Deprecated by CORBA 2.2.
name() - Method in class org.omg.CORBA.Principal
Deprecated.
Deprecated by CORBA 2.2.
name - Variable in class org.omg.CORBA.StructMember
The name of the struct member described by this StructMember object.
name() - Method in class org.omg.CORBA.TypeCode
Retrieves the simple name identifying this TypeCode object within its enclosing scope.
name - Variable in class org.omg.CORBA.UnionMember
The name of the union member described by this UnionMember object.
name - Variable in class org.omg.CORBA.ValueMember
The name of the value member described by this ValueMember object.
name() - Method in interface org.omg.PortableInterceptor.InterceptorOperations
Returns the name of the interceptor.
name - Variable in exception org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateName
The name for which there was already an interceptor registered.
name2type(String) - Static method in class javax.swing.text.html.parser.AttributeList
name2type(String) - Static method in class javax.swing.text.html.parser.Element
name2type(String) - Static method in class javax.swing.text.html.parser.Entity
Converts nm string to the corresponding entity type.
NAME_NOT_MN - Static variable in exception org.ietf.jgss.GSSException
Name contains multi-mechanism elements.
NameAlreadyBoundException - Exception in javax.naming
This exception is thrown by methods to indicate that a binding cannot be added because the name is already bound to another object.
NameAlreadyBoundException(String) - Constructor for exception javax.naming.NameAlreadyBoundException
Constructs a new instance of NameAlreadyBoundException using the explanation supplied.
NameAlreadyBoundException() - Constructor for exception javax.naming.NameAlreadyBoundException
Constructs a new instance of NameAlreadyBoundException.
NameAttribute - Static variable in interface javax.swing.text.AttributeSet
Attribute name used to name the collection of attributes.
NameAttribute - Static variable in class javax.swing.text.StyleConstants
Attribute name used to name the collection of attributes.
NameCallback - Class in javax.security.auth.callback
Underlying security services instantiate and pass a NameCallback to the handle method of a CallbackHandler to retrieve name information.
NameCallback(String) - Constructor for class javax.security.auth.callback.NameCallback
Construct a NameCallback with a prompt.
NameCallback(String, String) - Constructor for class javax.security.auth.callback.NameCallback
Construct a NameCallback with a prompt and default name.
NameClassPair - Class in javax.naming
This class represents the object name and class name pair of a binding found in a context.
NameClassPair(String, String) - Constructor for class javax.naming.NameClassPair
Constructs an instance of a NameClassPair given its name and class name.
NameClassPair(String, String, boolean) - Constructor for class javax.naming.NameClassPair
Constructs an instance of a NameClassPair given its name, class name, and whether it is relative to the listing context.
NameComponent - Class in org.omg.CosNaming
org/omg/CosNaming/NameComponent.java .
NameComponent() - Constructor for class org.omg.CosNaming.NameComponent
NameComponent(String, String) - Constructor for class org.omg.CosNaming.NameComponent
NameComponentHelper - Class in org.omg.CosNaming
org/omg/CosNaming/NameComponentHelper.java .
NameComponentHelper() - Constructor for class org.omg.CosNaming.NameComponentHelper
NameComponentHolder - Class in org.omg.CosNaming
org/omg/CosNaming/NameComponentHolder.java .
NameComponentHolder() - Constructor for class org.omg.CosNaming.NameComponentHolder
NameComponentHolder(NameComponent) - Constructor for class org.omg.CosNaming.NameComponentHolder
NamedNodeMap - Interface in org.w3c.dom
Objects implementing the NamedNodeMap interface are used to represent collections of nodes that can be accessed by name.
NamedStyle(String, Style) - Constructor for class javax.swing.text.StyleContext.NamedStyle
Creates a new named style.
NamedStyle(Style) - Constructor for class javax.swing.text.StyleContext.NamedStyle
Creates a new named style.
NamedStyle() - Constructor for class javax.swing.text.StyleContext.NamedStyle
Creates a new named style, with a null name and parent.
NamedValue - Class in org.omg.CORBA
An object used in the DII and DSI to describe arguments and return values.
NamedValue() - Constructor for class org.omg.CORBA.NamedValue
NameDynAnyPair - Class in org.omg.DynamicAny
org/omg/DynamicAny/NameDynAnyPair.java .
NameDynAnyPair() - Constructor for class org.omg.DynamicAny.NameDynAnyPair
NameDynAnyPair(String, DynAny) - Constructor for class org.omg.DynamicAny.NameDynAnyPair
NameDynAnyPairHelper - Class in org.omg.DynamicAny
org/omg/DynamicAny/NameDynAnyPairHelper.java .
NameDynAnyPairHelper() - Constructor for class org.omg.DynamicAny.NameDynAnyPairHelper
NameDynAnyPairSeqHelper - Class in org.omg.DynamicAny
org/omg/DynamicAny/NameDynAnyPairSeqHelper.java .
NameDynAnyPairSeqHelper() - Constructor for class org.omg.DynamicAny.NameDynAnyPairSeqHelper
NameHelper - Class in org.omg.CosNaming
A name is a sequence of name components.
NameHelper() - Constructor for class org.omg.CosNaming.NameHelper
NameHolder - Class in org.omg.CosNaming
A name is a sequence of name components.
NameHolder() - Constructor for class org.omg.CosNaming.NameHolder
NameHolder(NameComponent[]) - Constructor for class org.omg.CosNaming.NameHolder
NameList - Interface in org.w3c.dom
The NameList interface provides the abstraction of an ordered collection of parallel pairs of name and namespace values (which could be null values), without defining or constraining how this collection is implemented.
NameNotFoundException - Exception in javax.naming
This exception is thrown when a component of the name cannot be resolved because it is not bound.
NameNotFoundException(String) - Constructor for exception javax.naming.NameNotFoundException
Constructs a new instance of NameNotFoundException using the explanation supplied.
NameNotFoundException() - Constructor for exception javax.naming.NameNotFoundException
Constructs a new instance of NameNotFoundException.
NameParser - Interface in javax.naming
This interface is used for parsing names from a hierarchical namespace.
names - Variable in class javax.imageio.spi.ImageReaderWriterSpi
An array of strings to be returned from getFormatNames, initially null.
NAMES - Static variable in interface javax.swing.text.html.parser.DTDConstants
Namespace - Interface in javax.xml.stream.events
An interface that contains information about a namespace.
NAMESPACE - Static variable in interface javax.xml.stream.XMLStreamConstants
Indicates the event is a namespace declaration
NAMESPACE_ERR - Static variable in exception org.w3c.dom.DOMException
If an attempt is made to create or change an object in a way which is incorrect with regard to namespaces.
NamespaceChangeListener - Interface in javax.naming.event
Specifies the methods that a listener interested in namespace changes must implement.
NamespaceContext - Interface in javax.xml.namespace
Interface for read only XML Namespace context processing.
NamespaceSupport - Class in org.xml.sax.helpers
Encapsulate Namespace logic for use by applications using SAX, or internally by SAX drivers.
NamespaceSupport() - Constructor for class org.xml.sax.helpers.NamespaceSupport
Create a new Namespace support object.
nameUUIDFromBytes(byte[]) - Static method in class java.util.UUID
Static factory to retrieve a type 3 (name based) UUID based on the specified byte array.
NameValuePair - Class in org.omg.CORBA
Associates a name with a value that is an attribute of an IDL struct, and is used in the DynStruct APIs.
NameValuePair() - Constructor for class org.omg.CORBA.NameValuePair
Constructs an empty NameValuePair object.
NameValuePair(String, Any) - Constructor for class org.omg.CORBA.NameValuePair
Constructs a NameValuePair object that associates the given name with the given org.omg.CORBA.Any object.
NameValuePair - Class in org.omg.DynamicAny
org/omg/DynamicAny/NameValuePair.java .
NameValuePair() - Constructor for class org.omg.DynamicAny.NameValuePair
NameValuePair(String, Any) - Constructor for class org.omg.DynamicAny.NameValuePair
NameValuePairHelper - Class in org.omg.CORBA
The Helper for NameValuePair.
NameValuePairHelper() - Constructor for class org.omg.CORBA.NameValuePairHelper
NameValuePairHelper - Class in org.omg.DynamicAny
org/omg/DynamicAny/NameValuePairHelper.java .
NameValuePairHelper() - Constructor for class org.omg.DynamicAny.NameValuePairHelper
NameValuePairSeqHelper - Class in org.omg.DynamicAny
org/omg/DynamicAny/NameValuePairSeqHelper.java .
NameValuePairSeqHelper() - Constructor for class org.omg.DynamicAny.NameValuePairSeqHelper
Naming - Class in java.rmi
The Naming class provides methods for storing and obtaining references to remote objects in a remote object registry.
NamingContext - Interface in org.omg.CosNaming
A naming context is an object that contains a set of name bindings in which each name is unique.
NamingContextExt - Interface in org.omg.CosNaming
NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
NamingContextExtHelper - Class in org.omg.CosNaming
NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
NamingContextExtHelper() - Constructor for class org.omg.CosNaming.NamingContextExtHelper
NamingContextExtHolder - Class in org.omg.CosNaming
NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
NamingContextExtHolder() - Constructor for class org.omg.CosNaming.NamingContextExtHolder
NamingContextExtHolder(NamingContextExt) - Constructor for class org.omg.CosNaming.NamingContextExtHolder
NamingContextExtOperations - Interface in org.omg.CosNaming
NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
NamingContextExtPOA - Class in org.omg.CosNaming
NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
NamingContextExtPOA() - Constructor for class org.omg.CosNaming.NamingContextExtPOA
NamingContextHelper - Class in org.omg.CosNaming
A naming context is an object that contains a set of name bindings in which each name is unique.
NamingContextHelper() - Constructor for class org.omg.CosNaming.NamingContextHelper
NamingContextHolder - Class in org.omg.CosNaming
A naming context is an object that contains a set of name bindings in which each name is unique.
NamingContextHolder() - Constructor for class org.omg.CosNaming.NamingContextHolder
NamingContextHolder(NamingContext) - Constructor for class org.omg.CosNaming.NamingContextHolder
NamingContextOperations - Interface in org.omg.CosNaming
A naming context is an object that contains a set of name bindings in which each name is unique.
NamingContextPOA - Class in org.omg.CosNaming
A naming context is an object that contains a set of name bindings in which each name is unique.
NamingContextPOA() - Constructor for class org.omg.CosNaming.NamingContextPOA
NamingEnumeration<T> - Interface in javax.naming
This interface is for enumerating lists returned by methods in the javax.naming and javax.naming.directory packages.
NamingEvent - Class in javax.naming.event
This class represents an event fired by a naming/directory service.
NamingEvent(EventContext, int, Binding, Binding, Object) - Constructor for class javax.naming.event.NamingEvent
Constructs an instance of NamingEvent.
NamingException - Exception in javax.naming
This is the superclass of all exceptions thrown by operations in the Context and DirContext interfaces.
NamingException(String) - Constructor for exception javax.naming.NamingException
Constructs a new NamingException with an explanation.
NamingException() - Constructor for exception javax.naming.NamingException
Constructs a new NamingException.
NamingExceptionEvent - Class in javax.naming.event
This class represents an event fired when the procedures/processes used to collect information for notifying listeners of NamingEvents threw a NamingException.
NamingExceptionEvent(EventContext, NamingException) - Constructor for class javax.naming.event.NamingExceptionEvent
Constructs an instance of NamingExceptionEvent using the context in which the NamingException was thrown and the exception that was thrown.
namingExceptionThrown(NamingExceptionEvent) - Method in interface javax.naming.event.NamingListener
Called when a naming exception is thrown while attempting to fire a NamingEvent.
NamingListener - Interface in javax.naming.event
This interface is the root of listener interfaces that handle NamingEvents.
NamingManager - Class in javax.naming.spi
This class contains methods for creating context objects and objects referred to by location information in the naming or directory service.
NamingSecurityException - Exception in javax.naming
This is the superclass of security-related exceptions thrown by operations in the Context and DirContext interfaces.
NamingSecurityException(String) - Constructor for exception javax.naming.NamingSecurityException
Constructs a new instance of NamingSecurityException using the explanation supplied.
NamingSecurityException() - Constructor for exception javax.naming.NamingSecurityException
Constructs a new instance of NamingSecurityException.
NaN - Static variable in class java.lang.Double
A constant holding a Not-a-Number (NaN) value of type double.
NaN - Static variable in class java.lang.Float
A constant holding a Not-a-Number (NaN) value of type float.
nanoTime() - Static method in class java.lang.System
Returns the current value of the running Java Virtual Machine's high-resolution time source, in nanoseconds.
narrow(Object, Class) - Method in interface javax.rmi.CORBA.PortableRemoteObjectDelegate
Delegation call for PortableRemoteObject.narrow(java.lang.Object, java.lang.Class).
narrow(Object, Class) - Static method in class javax.rmi.PortableRemoteObject
Checks to ensure that an object of a remote or abstract interface type can be cast to a desired type.
narrow(Object) - Static method in class org.omg.CORBA.CurrentHelper
narrow(Object) - Static method in class org.omg.CORBA.IDLTypeHelper
narrow(Object) - Static method in class org.omg.CORBA.PolicyHelper
narrow(Object) - Static method in class org.omg.CosNaming.BindingIteratorHelper
narrow(Object) - Static method in class org.omg.CosNaming.NamingContextExtHelper
narrow(Object) - Static method in class org.omg.CosNaming.NamingContextHelper
narrow(Object) - Static method in class org.omg.DynamicAny.DynAnyFactoryHelper
narrow(Object) - Static method in class org.omg.DynamicAny.DynAnyHelper
narrow(Object) - Static method in class org.omg.DynamicAny.DynArrayHelper
narrow(Object) - Static method in class org.omg.DynamicAny.DynEnumHelper
narrow(Object) - Static method in class org.omg.DynamicAny.DynFixedHelper
narrow(Object) - Static method in class org.omg.DynamicAny.DynSequenceHelper
narrow(Object) - Static method in class org.omg.DynamicAny.DynStructHelper
narrow(Object) - Static method in class org.omg.DynamicAny.DynUnionHelper
narrow(Object) - Static method in class org.omg.DynamicAny.DynValueHelper
narrow(Object) - Static method in class org.omg.IOP.CodecFactoryHelper
narrow(Object) - Static method in class org.omg.PortableInterceptor.CurrentHelper
narrow(Object) - Static method in class org.omg.PortableInterceptor.IORInterceptor_3_0Helper
narrow(Object) - Static method in class org.omg.PortableServer.CurrentHelper
narrow(Object) - Static method in class org.omg.PortableServer.POAHelper
narrow(Object) - Static method in class org.omg.PortableServer.ServantActivatorHelper
narrow(Object) - Static method in class org.omg.PortableServer.ServantLocatorHelper
NARROW_FORMAT - Static variable in class java.util.Calendar
A style specifier for getDisplayName and getDisplayNames indicating a narrow name used for format.
NARROW_STANDALONE - Static variable in class java.util.Calendar
A style specifier for getDisplayName and getDisplayNames indicating a narrow name independently.
NATIVE - Static variable in class java.awt.JobAttributes.DialogType
The DialogType instance to use for specifying the platform's native print dialog.
Native - Annotation Type in java.lang.annotation
Indicates that a field defining a constant value may be referenced from native code.
NATIVE - Static variable in class java.lang.reflect.Modifier
The int value representing the native modifier.
NATIVE - Static variable in class javax.print.attribute.standard.DialogTypeSelection
nativeImageMetadataFormatClassName - Variable in class javax.imageio.spi.ImageReaderWriterSpi
A String containing the class name of the native stream metadata format supported by this plug-in, initially null.
nativeImageMetadataFormatName - Variable in class javax.imageio.spi.ImageReaderWriterSpi
A String containing the name of the native stream metadata format supported by this plug-in, initially null.
nativeMetadataFormatClassName - Variable in class javax.imageio.metadata.IIOMetadata
The name of the class implementing IIOMetadataFormat and representing the native metadata format, initialized to null and set via the constructor.
nativeMetadataFormatName - Variable in class javax.imageio.metadata.IIOMetadata
The name of the native metadata format for this object, initialized to null and set via the constructor.
nativeOrder() - Static method in class java.nio.ByteOrder
Retrieves the native byte order of the underlying platform.
nativeSQL(String) - Method in interface java.sql.Connection
Converts the given SQL statement into the system's native SQL grammar.
nativeStreamMetadataFormatClassName - Variable in class javax.imageio.spi.ImageReaderWriterSpi
A String containing the class name of the native stream metadata format supported by this plug-in, initially null.
nativeStreamMetadataFormatName - Variable in class javax.imageio.spi.ImageReaderWriterSpi
A String containing the name of the native stream metadata format supported by this plug-in, initially null.
naturalOrder() - Static method in interface java.util.Comparator
Returns a comparator that compares Comparable objects in natural order.
navigableKeySet() - Method in interface java.util.concurrent.ConcurrentNavigableMap
Returns a NavigableSet view of the keys contained in this map.
navigableKeySet() - Method in class java.util.concurrent.ConcurrentSkipListMap
navigableKeySet() - Method in interface java.util.NavigableMap
Returns a NavigableSet view of the keys contained in this map.
navigableKeySet() - Method in class java.util.TreeMap
NavigableMap<K,V> - Interface in java.util
A SortedMap extended with navigation methods returning the closest matches for given search targets.
NavigableSet<E> - Interface in java.util
A SortedSet extended with navigation methods reporting closest matches for given search targets.
NavigateAction() - Constructor for class javax.swing.plaf.basic.BasicDesktopPaneUI.NavigateAction
navigateFocusedComp(int) - Method in class javax.swing.plaf.basic.BasicToolBarUI
navigateKey - Variable in class javax.swing.plaf.basic.BasicDesktopPaneUI
Deprecated.
As of 1.3.
navigateKey2 - Variable in class javax.swing.plaf.basic.BasicDesktopPaneUI
Deprecated.
As of 1.3.
navigateSelectedTab(int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
NavigationFilter - Class in javax.swing.text
NavigationFilter can be used to restrict where the cursor can be positioned.
NavigationFilter() - Constructor for class javax.swing.text.NavigationFilter
NavigationFilter.FilterBypass - Class in javax.swing.text
Used as a way to circumvent calling back into the caret to position the cursor.
NCHAR - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type NCHAR
NClob - Interface in java.sql
The mapping in the Java™ programming language for the SQL NCLOB type.
NCLOB - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type NCLOB.
ncontext - Static variable in class org.omg.CosNaming.BindingType
nCopies(int, T) - Static method in class java.util.Collections
Returns an immutable list consisting of n copies of the specified object.
NE_RESIZE_CURSOR - Static variable in class java.awt.Cursor
The north-east-resize cursor type.
NE_RESIZE_CURSOR - Static variable in class java.awt.Frame
Deprecated.
replaced by Cursor.NE_RESIZE_CURSOR.
needsCacheFile() - Method in class javax.imageio.spi.ImageInputStreamSpi
Returns true if the ImageInputStream implementation associated with this service provider requires the use of a cache File.
needsCacheFile() - Method in class javax.imageio.spi.ImageOutputStreamSpi
Returns true if the ImageOutputStream implementation associated with this service provider requires the use of a cache File.
needsDictionary() - Method in class java.util.zip.Inflater
Returns true if a preset dictionary is needed for decompression.
needsGui() - Method in class java.beans.beancontext.BeanContextSupport
This method is typically called from the environment in order to determine if the implementor "needs" a GUI.
needsGui() - Method in interface java.beans.Visibility
Determines whether this bean needs a GUI.
needsInput() - Method in class java.util.zip.Deflater
Returns true if the input data buffer is empty and setInput() should be called in order to provide more input.
needsInput() - Method in class java.util.zip.Inflater
Returns true if no data remains in the input buffer.
needsReload(String, Locale, String, ClassLoader, ResourceBundle, long) - Method in class java.util.ResourceBundle.Control
Determines if the expired bundle in the cache needs to be reloaded based on the loading time given by loadTime or some other criteria.
negate() - Method in class java.math.BigDecimal
Returns a BigDecimal whose value is (-this), and whose scale is this.scale().
negate(MathContext) - Method in class java.math.BigDecimal
Returns a BigDecimal whose value is (-this), with rounding according to the context settings.
negate() - Method in class java.math.BigInteger
Returns a BigInteger whose value is (-this).
negate() - Method in interface java.util.function.BiPredicate
Returns a predicate that represents the logical negation of this predicate.
negate() - Method in interface java.util.function.DoublePredicate
Returns a predicate that represents the logical negation of this predicate.
negate() - Method in interface java.util.function.IntPredicate
Returns a predicate that represents the logical negation of this predicate.
negate() - Method in interface java.util.function.LongPredicate
Returns a predicate that represents the logical negation of this predicate.
negate() - Method in interface java.util.function.Predicate
Returns a predicate that represents the logical negation of this predicate.
negate() - Method in class javax.xml.datatype.Duration
Returns a new Duration object whose value is -this.
negated() - Method in interface java.time.chrono.ChronoPeriod
Returns a new instance with each amount in this period negated.
negated() - Method in class java.time.Duration
Returns a copy of this duration with the length negated.
negated() - Method in class java.time.Period
Returns a new instance with each amount in this period negated.
negateExact(int) - Static method in class java.lang.Math
Returns the negation of the argument, throwing an exception if the result overflows an int.
negateExact(long) - Static method in class java.lang.Math
Returns the negation of the argument, throwing an exception if the result overflows a long.
NEGATIVE_INFINITY - Static variable in class java.lang.Double
A constant holding the negative infinity of type double.
NEGATIVE_INFINITY - Static variable in class java.lang.Float
A constant holding the negative infinity of type float.
NEGATIVE_SCROLL - Static variable in class javax.swing.plaf.basic.BasicSliderUI
NegativeArraySizeException - Exception in java.lang
Thrown if an application tries to create an array with negative size.
NegativeArraySizeException() - Constructor for exception java.lang.NegativeArraySizeException
Constructs a NegativeArraySizeException with no detail message.
NegativeArraySizeException(String) - Constructor for exception java.lang.NegativeArraySizeException
Constructs a NegativeArraySizeException with the specified detail message.
negotiate() - Method in class javax.naming.ldap.StartTlsResponse
Negotiates a TLS session using the default SSL socket factory.
negotiate(SSLSocketFactory) - Method in class javax.naming.ldap.StartTlsResponse
Negotiates a TLS session using an SSL socket factory.
nested - Variable in exception javax.xml.stream.XMLStreamException
NestingKind - Enum in javax.lang.model.element
The nesting kind of a type element.
NetPermission - Class in java.net
This class is for various network permissions.
NetPermission(String) - Constructor for class java.net.NetPermission
Creates a new NetPermission with the specified name.
NetPermission(String, String) - Constructor for class java.net.NetPermission
Creates a new NetPermission object with the specified name.
NetworkChannel - Interface in java.nio.channels
A channel to a network socket.
NetworkInterface - Class in java.net
This class represents a Network Interface made up of a name, and a list of IP addresses assigned to this interface.
networkInterface() - Method in class java.nio.channels.MembershipKey
Returns the network interface for which this membership key was created.
NEVER_UPDATE - Static variable in class javax.swing.text.DefaultCaret
Indicates that the caret should remain at the same absolute position in the document regardless of any document updates, except when the document length becomes less than the current caret position due to removal.
new_context() - Method in class org.omg.CosNaming._NamingContextExtStub
This operation returns a naming context implemented by the same naming server as the context on which the operation was invoked.
new_context() - Method in class org.omg.CosNaming._NamingContextStub
This operation returns a naming context implemented by the same naming server as the context on which the operation was invoked.
new_context() - Method in interface org.omg.CosNaming.NamingContextOperations
This operation returns a naming context implemented by the same naming server as the context on which the operation was invoked.
NEW_TAI_LUE - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "New Tai Lue" Unicode character block.
newAsynchronousFileChannel(Path, Set<? extends OpenOption>, ExecutorService, FileAttribute<?>...) - Method in class java.nio.file.spi.FileSystemProvider
Opens or creates a file for reading and/or writing, returning an asynchronous file channel to access the file.
newAttributes - Variable in class javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit
newAudioClip(URL) - Static method in class java.applet.Applet
Get an audio clip from the given URL.
newBinding - Variable in class javax.naming.event.NamingEvent
Contains information about the object after the change.
newBufferedReader(Path, Charset) - Static method in class java.nio.file.Files
Opens a file for reading, returning a BufferedReader that may be used to read text from the file in an efficient manner.
newBufferedReader(Path) - Static method in class java.nio.file.Files
Opens a file for reading, returning a BufferedReader to read text from the file in an efficient manner.
newBufferedWriter(Path, Charset, OpenOption...) - Static method in class java.nio.file.Files
Opens or creates a file for writing, returning a BufferedWriter that may be used to write text to the file in an efficient manner.
newBufferedWriter(Path, OpenOption...) - Static method in class java.nio.file.Files
Opens or creates a file for writing, returning a BufferedWriter to write text to the file in an efficient manner.
newBuilder() - Static method in class java.nio.file.attribute.AclEntry
Constructs a new builder.
newBuilder(AclEntry) - Static method in class java.nio.file.attribute.AclEntry
Constructs a new builder with the components of an existing ACL entry.
newBundle(String, Locale, String, ClassLoader, boolean) - Method in class java.util.ResourceBundle.Control
Instantiates a resource bundle for the given bundle name of the given format and locale, using the given class loader if necessary.
newByteChannel(Path, Set<? extends OpenOption>, FileAttribute<?>...) - Static method in class java.nio.file.Files
Opens or creates a file, returning a seekable byte channel to access the file.
newByteChannel(Path, OpenOption...) - Static method in class java.nio.file.Files
Opens or creates a file, returning a seekable byte channel to access the file.
newByteChannel(T, Set<? extends OpenOption>, FileAttribute<?>...) - Method in interface java.nio.file.SecureDirectoryStream
Opens or creates a file in this directory, returning a seekable byte channel to access the file.
newByteChannel(Path, Set<? extends OpenOption>, FileAttribute<?>...) - Method in class java.nio.file.spi.FileSystemProvider
Opens or creates a file, returning a seekable byte channel to access the file.
newCachedThreadPool() - Static method in class java.util.concurrent.Executors
Creates a thread pool that creates new threads as needed, but will reuse previously constructed threads when they are available.
newCachedThreadPool(ThreadFactory) - Static method in class java.util.concurrent.Executors
Creates a thread pool that creates new threads as needed, but will reuse previously constructed threads when they are available, and uses the provided ThreadFactory to create new threads when needed.
newCall(RemoteObject, Operation[], int, long) - Method in interface java.rmi.server.RemoteRef
Deprecated.
1.2 style stubs no longer use this method. Instead of using a sequence of method calls on the stub's the remote reference (newCall, invoke, and done), a stub uses a single method, invoke(Remote, Method, Object[], int), on the remote reference to carry out parameter marshalling, remote method executing and unmarshalling of the return value.
newCanonicalizationMethod(String, C14NMethodParameterSpec) - Method in class javax.xml.crypto.dsig.XMLSignatureFactory
Creates a CanonicalizationMethod for the specified algorithm URI and parameters.
newCanonicalizationMethod(String, XMLStructure) - Method in class javax.xml.crypto.dsig.XMLSignatureFactory
Creates a CanonicalizationMethod for the specified algorithm URI and parameters.
newChannel(InputStream) - Static method in class java.nio.channels.Channels
Constructs a channel that reads bytes from the given stream.
newChannel(OutputStream) - Static method in class java.nio.channels.Channels
Constructs a channel that writes bytes to the given stream.
newClient(Object) - Method in interface javax.management.remote.rmi.RMIServer
Makes a new connection through this RMI connector.
newClient(Object) - Method in class javax.management.remote.rmi.RMIServerImpl
Creates a new client connection.
newClient(Object) - Method in class javax.management.remote.rmi.RMIServerImpl_Stub
newCondition() - Method in interface java.util.concurrent.locks.Lock
Returns a new Condition instance that is bound to this Lock instance.
newCondition() - Method in class java.util.concurrent.locks.ReentrantLock
Returns a Condition instance for use with this Lock instance.
newCondition() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock
Throws UnsupportedOperationException because ReadLocks do not support conditions.
newCondition() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock
Returns a Condition instance for use with this Lock instance.
newDataAvailable(TableModelEvent) - Method in class javax.swing.table.DefaultTableModel
Equivalent to fireTableChanged.
newDecoder() - Method in class java.nio.charset.Charset
Constructs a new decoder for this charset.
newDigestMethod(String, DigestMethodParameterSpec) - Method in class javax.xml.crypto.dsig.XMLSignatureFactory
Creates a DigestMethod for the specified algorithm URI and parameters.
newDirectoryStream(Path) - Static method in class java.nio.file.Files
Opens a directory, returning a DirectoryStream to iterate over all entries in the directory.
newDirectoryStream(Path, String) - Static method in class java.nio.file.Files
Opens a directory, returning a DirectoryStream to iterate over the entries in the directory.
newDirectoryStream(Path, DirectoryStream.Filter<? super Path>) - Static method in class java.nio.file.Files
Opens a directory, returning a DirectoryStream to iterate over the entries in the directory.
newDirectoryStream(T, LinkOption...) - Method in interface java.nio.file.SecureDirectoryStream
Opens the directory identified by the given path, returning a SecureDirectoryStream to iterate over the entries in the directory.
newDirectoryStream(Path, DirectoryStream.Filter<? super Path>) - Method in class java.nio.file.spi.FileSystemProvider
Opens a directory, returning a DirectoryStream to iterate over the entries in the directory.
newDocument() - Method in class javax.xml.parsers.DocumentBuilder
Obtain a new instance of a DOM Document object to build a DOM tree with.
newDocumentBuilder() - Method in class javax.xml.parsers.DocumentBuilderFactory
Creates a new instance of a DocumentBuilder using the currently configured parameters.
newDuration(String) - Method in class javax.xml.datatype.DatatypeFactory
Obtain a new instance of a Duration specifying the Duration as its string representation, "PnYnMnDTnHnMnS", as defined in XML Schema 1.0 section 3.2.6.1.
newDuration(long) - Method in class javax.xml.datatype.DatatypeFactory
Obtain a new instance of a Duration specifying the Duration as milliseconds.
newDuration(boolean, BigInteger, BigInteger, BigInteger, BigInteger, BigInteger, BigDecimal) - Method in class javax.xml.datatype.DatatypeFactory
Obtain a new instance of a Duration specifying the Duration as isPositive, years, months, days, hours, minutes, seconds.
newDuration(boolean, int, int, int, int, int, int) - Method in class javax.xml.datatype.DatatypeFactory
Obtain a new instance of a Duration specifying the Duration as isPositive, years, months, days, hours, minutes, seconds.
newDurationDayTime(String) - Method in class javax.xml.datatype.DatatypeFactory
Create a Duration of type xdt:dayTimeDuration by parsing its String representation, "PnDTnHnMnS", XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration.
newDurationDayTime(long) - Method in class javax.xml.datatype.DatatypeFactory
Create a Duration of type xdt:dayTimeDuration using the specified milliseconds as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration.
newDurationDayTime(boolean, BigInteger, BigInteger, BigInteger, BigInteger) - Method in class javax.xml.datatype.DatatypeFactory
Create a Duration of type xdt:dayTimeDuration using the specified day, hour, minute and second as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration.
newDurationDayTime(boolean, int, int, int, int) - Method in class javax.xml.datatype.DatatypeFactory
Create a Duration of type xdt:dayTimeDuration using the specified day, hour, minute and second as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration.
newDurationYearMonth(String) - Method in class javax.xml.datatype.DatatypeFactory
Create a Duration of type xdt:yearMonthDuration by parsing its String representation, "PnYnM", XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration.
newDurationYearMonth(long) - Method in class javax.xml.datatype.DatatypeFactory
Create a Duration of type xdt:yearMonthDuration using the specified milliseconds as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration.
newDurationYearMonth(boolean, BigInteger, BigInteger) - Method in class javax.xml.datatype.DatatypeFactory
Create a Duration of type xdt:yearMonthDuration using the specified year and month as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration.
newDurationYearMonth(boolean, int, int) - Method in class javax.xml.datatype.DatatypeFactory
Create a Duration of type xdt:yearMonthDuration using the specified year and month as defined in XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration.
newEncoder() - Method in class java.nio.charset.Charset
Constructs a new encoder for this charset.
newFactory() - Static method in class javax.sql.rowset.RowSetProvider
Creates a new instance of a RowSetFactory implementation.
newFactory(String, ClassLoader) - Static method in class javax.sql.rowset.RowSetProvider
Creates a new instance of a RowSetFactory from the specified factory class name.
newFactory() - Static method in class javax.xml.stream.XMLEventFactory
Create a new instance of the factory.
newFactory(String, ClassLoader) - Static method in class javax.xml.stream.XMLEventFactory
Create a new instance of the factory.
newFactory() - Static method in class javax.xml.stream.XMLInputFactory
Create a new instance of the factory.
newFactory(String, ClassLoader) - Static method in class javax.xml.stream.XMLInputFactory
Create a new instance of the factory.
newFactory() - Static method in class javax.xml.stream.XMLOutputFactory
Create a new instance of the factory.
newFactory(String, ClassLoader) - Static method in class javax.xml.stream.XMLOutputFactory
Create a new instance of the factory.
newFactory(String) - Method in class javax.xml.validation.SchemaFactoryLoader
Creates a new SchemaFactory object for the specified schema language.
newFileChannel(Path, Set<? extends OpenOption>, FileAttribute<?>...) - Method in class java.nio.file.spi.FileSystemProvider
Opens or creates a file for reading and/or writing, returning a file channel to access the file.
newFileSystem(URI, Map<String, ?>) - Static method in class java.nio.file.FileSystems
Constructs a new file system that is identified by a URI
newFileSystem(URI, Map<String, ?>, ClassLoader) - Static method in class java.nio.file.FileSystems
Constructs a new file system that is identified by a URI
newFileSystem(Path, ClassLoader) - Static method in class java.nio.file.FileSystems
Constructs a new FileSystem to access the contents of a file as a file system.
newFileSystem(URI, Map<String, ?>) - Method in class java.nio.file.spi.FileSystemProvider
Constructs a new FileSystem object identified by a URI.
newFileSystem(Path, Map<String, ?>) - Method in class java.nio.file.spi.FileSystemProvider
Constructs a new FileSystem to access the contents of a file as a file system.
newFixedThreadPool(int) - Static method in class java.util.concurrent.Executors
Creates a thread pool that reuses a fixed number of threads operating off a shared unbounded queue.
newFixedThreadPool(int, ThreadFactory) - Static method in class java.util.concurrent.Executors
Creates a thread pool that reuses a fixed number of threads operating off a shared unbounded queue, using the provided ThreadFactory to create new threads when needed.
NewFolderAction() - Constructor for class javax.swing.plaf.basic.BasicFileChooserUI.NewFolderAction
newFolderIcon - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
newInputStream(ReadableByteChannel) - Static method in class java.nio.channels.Channels
Constructs a stream that reads bytes from the given channel.
newInputStream(AsynchronousByteChannel) - Static method in class java.nio.channels.Channels
Constructs a stream that reads bytes from the given channel.
newInputStream(Path, OpenOption...) - Static method in class java.nio.file.Files
Opens a file, returning an input stream to read from the file.
newInputStream(Path, OpenOption...) - Method in class java.nio.file.spi.FileSystemProvider
Opens a file, returning an input stream to read from the file.
newInstance() - Method in class java.lang.Class
Creates a new instance of the class represented by this Class object.
newInstance(Class<?>, int) - Static method in class java.lang.reflect.Array
Creates a new array with the specified component type and length.
newInstance(Class<?>, int...) - Static method in class java.lang.reflect.Array
Creates a new array with the specified component type and dimensions.
newInstance(Object...) - Method in class java.lang.reflect.Constructor
Uses the constructor represented by this Constructor object to create and initialize a new instance of the constructor's declaring class, with the specified initialization parameters.
newInstance(URL[], ClassLoader) - Static method in class java.net.URLClassLoader
Creates a new instance of URLClassLoader for the specified URLs and parent class loader.
newInstance(URL[]) - Static method in class java.net.URLClassLoader
Creates a new instance of URLClassLoader for the specified URLs and default parent class loader.
newInstance(ActivationID, ActivationDesc) - Method in class java.rmi.activation.ActivationGroup_Stub
Stub method for ActivationGroup.newInstance.
newInstance(ActivationID, ActivationDesc) - Method in interface java.rmi.activation.ActivationInstantiator
The activator calls an instantiator's newInstance method in order to recreate in that group an object with the activation identifier, id, and descriptor, desc.
newInstance(KeyStore, KeyStore.ProtectionParameter) - Static method in class java.security.KeyStore.Builder
Returns a new Builder that encapsulates the given KeyStore.
newInstance(String, Provider, File, KeyStore.ProtectionParameter) - Static method in class java.security.KeyStore.Builder
Returns a new Builder object.
newInstance(String, Provider, KeyStore.ProtectionParameter) - Static method in class java.security.KeyStore.Builder
Returns a new Builder object.
newInstance(Object) - Method in class java.security.Provider.Service
Return a new instance of the implementation described by this service.
newInstance(Control[]) - Method in class javax.naming.ldap.InitialLdapContext
newInstance(Control[]) - Method in interface javax.naming.ldap.LdapContext
Creates a new instance of this context initialized using request controls.
newInstance(String) - Static method in class javax.xml.bind.JAXBContext
Obtain a new instance of a JAXBContext class.
newInstance(String, ClassLoader) - Static method in class javax.xml.bind.JAXBContext
Obtain a new instance of a JAXBContext class.
newInstance(String, ClassLoader, Map<String, ?>) - Static method in class javax.xml.bind.JAXBContext
Obtain a new instance of a JAXBContext class.
newInstance(Class...) - Static method in class javax.xml.bind.JAXBContext
Obtain a new instance of a JAXBContext class.
newInstance(Class[], Map<String, ?>) - Static method in class javax.xml.bind.JAXBContext
Obtain a new instance of a JAXBContext class.
newInstance() - Static method in class javax.xml.datatype.DatatypeFactory
Obtain a new instance of a DatatypeFactory.
newInstance(String, ClassLoader) - Static method in class javax.xml.datatype.DatatypeFactory
Obtain a new instance of a DatatypeFactory from class name.
newInstance() - Static method in class javax.xml.parsers.DocumentBuilderFactory
Obtain a new instance of a DocumentBuilderFactory.
newInstance(String, ClassLoader) - Static method in class javax.xml.parsers.DocumentBuilderFactory
Obtain a new instance of a DocumentBuilderFactory from class name.
newInstance() - Static method in class javax.xml.parsers.SAXParserFactory
Obtain a new instance of a SAXParserFactory.
newInstance(String, ClassLoader) - Static method in class javax.xml.parsers.SAXParserFactory
Obtain a new instance of a SAXParserFactory from class name.
newInstance() - Static method in class javax.xml.soap.MessageFactory
Creates a new MessageFactory object that is an instance of the default implementation (SOAP 1.1), This method uses the following ordered lookup procedure to determine the MessageFactory implementation class to load: Use the javax.xml.soap.MessageFactory system property.
newInstance(String) - Static method in class javax.xml.soap.MessageFactory
Creates a new MessageFactory object that is an instance of the specified implementation.
newInstance() - Static method in class javax.xml.soap.SOAPConnectionFactory
Creates an instance of the default SOAPConnectionFactory object.
newInstance() - Static method in class javax.xml.soap.SOAPElementFactory
Deprecated.
Creates a new instance of SOAPElementFactory.
newInstance() - Static method in class javax.xml.soap.SOAPFactory
Creates a new SOAPFactory object that is an instance of the default implementation (SOAP 1.1), This method uses the following ordered lookup procedure to determine the SOAPFactory implementation class to load: Use the javax.xml.soap.SOAPFactory system property.
newInstance(String) - Static method in class javax.xml.soap.SOAPFactory
Creates a new SOAPFactory object that is an instance of the specified implementation, this method uses the SAAJMetaFactory to locate the implementation class and create the SOAPFactory instance.
newInstance() - Method in interface javax.xml.stream.util.XMLEventAllocator
This method creates an instance of the XMLEventAllocator.
newInstance() - Static method in class javax.xml.stream.XMLEventFactory
Creates a new instance of the factory in exactly the same manner as the XMLEventFactory.newFactory() method.
newInstance(String, ClassLoader) - Static method in class javax.xml.stream.XMLEventFactory
Deprecated.
This method has been deprecated to maintain API consistency. All newInstance methods have been replaced with corresponding newFactory methods. The replacement XMLEventFactory.newFactory(java.lang.String, java.lang.ClassLoader) method defines no changes in behavior.
newInstance() - Static method in class javax.xml.stream.XMLInputFactory
Creates a new instance of the factory in exactly the same manner as the XMLInputFactory.newFactory() method.
newInstance(String, ClassLoader) - Static method in class javax.xml.stream.XMLInputFactory
Deprecated.
This method has been deprecated to maintain API consistency. All newInstance methods have been replaced with corresponding newFactory methods. The replacement XMLInputFactory.newFactory(java.lang.String, java.lang.ClassLoader) method defines no changes in behavior.
newInstance() - Static method in class javax.xml.stream.XMLOutputFactory
Creates a new instance of the factory in exactly the same manner as the XMLOutputFactory.newFactory() method.
newInstance(String, ClassLoader) - Static method in class javax.xml.stream.XMLOutputFactory
Deprecated.
This method has been deprecated because it returns an instance of XMLInputFactory, which is of the wrong class. Use the new method XMLOutputFactory.newFactory(java.lang.String, java.lang.ClassLoader) instead.
newInstance() - Static method in class javax.xml.transform.TransformerFactory
Obtain a new instance of a TransformerFactory.
newInstance(String, ClassLoader) - Static method in class javax.xml.transform.TransformerFactory
Obtain a new instance of a TransformerFactory from factory class name.
newInstance(String) - Static method in class javax.xml.validation.SchemaFactory
Lookup an implementation of the SchemaFactory that supports the specified schema language and return it.
newInstance(String, String, ClassLoader) - Static method in class javax.xml.validation.SchemaFactory
Obtain a new instance of a SchemaFactory from class name.
newInstance() - Static method in class javax.xml.xpath.XPathFactory
Get a new XPathFactory instance using the default object model, XPathFactory.DEFAULT_OBJECT_MODEL_URI, the W3C DOM.
newInstance(String) - Static method in class javax.xml.xpath.XPathFactory
Get a new XPathFactory instance using the specified object model.
newInstance(String, String, ClassLoader) - Static method in class javax.xml.xpath.XPathFactory
Obtain a new instance of a XPathFactory from a factory class name.
newInstance() - Static method in class org.w3c.dom.bootstrap.DOMImplementationRegistry
Obtain a new instance of a DOMImplementationRegistry.
newJMXConnector(JMXServiceURL, Map<String, ?>) - Static method in class javax.management.remote.JMXConnectorFactory
Creates a connector client for the connector server at the given address.
newJMXConnector(JMXServiceURL, Map<String, ?>) - Method in interface javax.management.remote.JMXConnectorProvider
Creates a new connector client that is ready to connect to the connector server at the given address.
newJMXConnectorServer(JMXServiceURL, Map<String, ?>, MBeanServer) - Static method in class javax.management.remote.JMXConnectorServerFactory
Creates a connector server at the given address.
newJMXConnectorServer(JMXServiceURL, Map<String, ?>, MBeanServer) - Method in interface javax.management.remote.JMXConnectorServerProvider
Creates a new connector server at the given address.
newKeyInfo(List) - Method in class javax.xml.crypto.dsig.keyinfo.KeyInfoFactory
Creates a KeyInfo containing the specified list of key information types.
newKeyInfo(List, String) - Method in class javax.xml.crypto.dsig.keyinfo.KeyInfoFactory
Creates a KeyInfo containing the specified list of key information types and optional id.
newKeyName(String) - Method in class javax.xml.crypto.dsig.keyinfo.KeyInfoFactory
Creates a KeyName from the specified name.
newKeySet() - Static method in class java.util.concurrent.ConcurrentHashMap
Creates a new Set backed by a ConcurrentHashMap from the given type to Boolean.TRUE.
newKeySet(int) - Static method in class java.util.concurrent.ConcurrentHashMap
Creates a new Set backed by a ConcurrentHashMap from the given type to Boolean.TRUE.
newKeyValue(PublicKey) - Method in class javax.xml.crypto.dsig.keyinfo.KeyInfoFactory
Creates a KeyValue from the specified public key.
newLeadSelectionPath - Variable in class javax.swing.event.TreeSelectionEvent
leadSelectionPath after the paths changed, may be null.
newLine() - Method in class java.io.BufferedWriter
Writes a line separator.
NEWLINE - Static variable in class javax.swing.text.AbstractWriter
How the text packages models newlines.
newManifest(List) - Method in class javax.xml.crypto.dsig.XMLSignatureFactory
Creates a Manifest containing the specified list of References.
newManifest(List, String) - Method in class javax.xml.crypto.dsig.XMLSignatureFactory
Creates a Manifest containing the specified list of References and optional id.
newMBeanProxy(MBeanServerConnection, ObjectName, Class<T>) - Static method in class javax.management.JMX
Make a proxy for a Standard MBean in a local or remote MBean Server.
newMBeanProxy(MBeanServerConnection, ObjectName, Class<T>, boolean) - Static method in class javax.management.JMX
Make a proxy for a Standard MBean in a local or remote MBean Server that may also support the methods of NotificationEmitter.
newMBeanServer(String, MBeanServer, MBeanServerDelegate) - Method in class javax.management.MBeanServerBuilder
This method creates a new MBeanServer implementation object.
newMBeanServer() - Static method in class javax.management.MBeanServerFactory
Return a new object implementing the MBeanServer interface with a standard default domain name, without keeping an internal reference to this new object.
newMBeanServer(String) - Static method in class javax.management.MBeanServerFactory
Return a new object implementing the MBeanServer interface with the specified default domain name, without keeping an internal reference to this new object.
newMBeanServerDelegate() - Method in class javax.management.MBeanServerBuilder
This method creates a new MBeanServerDelegate for a new MBeanServer.
newMessageFactory(String) - Method in class javax.xml.soap.SAAJMetaFactory
Creates a MessageFactory object for the given String protocol.
newmodel - Variable in class java.awt.image.RGBImageFilter
The ColorModel with which to replace origmodel when the user calls substituteColorModel.
newMXBeanProxy(MBeanServerConnection, ObjectName, Class<T>) - Static method in class javax.management.JMX
Make a proxy for an MXBean in a local or remote MBean Server.
newMXBeanProxy(MBeanServerConnection, ObjectName, Class<T>, boolean) - Static method in class javax.management.JMX
Make a proxy for an MXBean in a local or remote MBean Server that may also support the methods of NotificationEmitter.
newNode - Variable in class java.util.prefs.AbstractPreferences
This field should be true if this node did not exist in the backing store prior to the creation of this object.
newOutputStream(WritableByteChannel) - Static method in class java.nio.channels.Channels
Constructs a stream that writes bytes to the given channel.
newOutputStream(AsynchronousByteChannel) - Static method in class java.nio.channels.Channels
Constructs a stream that writes bytes to the given channel.
newOutputStream(Path, OpenOption...) - Static method in class java.nio.file.Files
Opens or creates a file, returning an output stream that may be used to write bytes to the file.
newOutputStream(Path, OpenOption...) - Method in class java.nio.file.spi.FileSystemProvider
Opens or creates a file, returning an output stream that may be used to write bytes to the file.
newPacker() - Static method in class java.util.jar.Pack200
Obtain new instance of a class that implements Packer.
newPermissionCollection() - Method in class java.io.FilePermission
Returns a new PermissionCollection object for storing FilePermission objects.
newPermissionCollection() - Method in class java.net.SocketPermission
Returns a new PermissionCollection object for storing SocketPermission objects.
newPermissionCollection() - Method in class java.security.AllPermission
Returns a new PermissionCollection object for storing AllPermission objects.
newPermissionCollection() - Method in class java.security.BasicPermission
Returns a new PermissionCollection object for storing BasicPermission objects.
newPermissionCollection() - Method in class java.security.Permission
Returns an empty PermissionCollection for a given Permission object, or null if one is not defined.
newPermissionCollection() - Method in class java.security.UnresolvedPermission
Returns a new PermissionCollection object for storing UnresolvedPermission objects.
newPermissionCollection() - Method in class java.util.PropertyPermission
Returns a new PermissionCollection object for storing PropertyPermission objects.
newPermissionCollection() - Method in class javax.management.MBeanServerPermission
newPermissionCollection() - Method in class javax.security.auth.kerberos.DelegationPermission
Returns a PermissionCollection object for storing DelegationPermission objects.
newPermissionCollection() - Method in class javax.security.auth.kerberos.ServicePermission
Returns a PermissionCollection object for storing ServicePermission objects.
newPermissionCollection() - Method in class javax.security.auth.PrivateCredentialPermission
Return a homogeneous collection of PrivateCredentialPermissions in a PermissionCollection.
newPGPData(byte[]) - Method in class javax.xml.crypto.dsig.keyinfo.KeyInfoFactory
Creates a PGPData from the specified PGP public key identifier.
newPGPData(byte[], byte[], List) - Method in class javax.xml.crypto.dsig.keyinfo.KeyInfoFactory
Creates a PGPData from the specified PGP public key identifier, and optional key material packet and list of external elements.
newPGPData(byte[], List) - Method in class javax.xml.crypto.dsig.keyinfo.KeyInfoFactory
Creates a PGPData from the specified PGP key material packet and optional list of external elements.
newPixels() - Method in class java.awt.image.MemoryImageSource
Sends a whole new buffer of pixels to any ImageConsumers that are currently interested in the data for this image and notify them that an animation frame is complete.
newPixels(int, int, int, int) - Method in class java.awt.image.MemoryImageSource
Sends a rectangular region of the buffer of pixels to any ImageConsumers that are currently interested in the data for this image and notify them that an animation frame is complete.
newPixels(int, int, int, int, boolean) - Method in class java.awt.image.MemoryImageSource
Sends a rectangular region of the buffer of pixels to any ImageConsumers that are currently interested in the data for this image.
newPixels(byte[], ColorModel, int, int) - Method in class java.awt.image.MemoryImageSource
Changes to a new byte array to hold the pixels for this image.
newPixels(int[], ColorModel, int, int) - Method in class java.awt.image.MemoryImageSource
Changes to a new int array to hold the pixels for this image.
newPlatformMXBeanProxy(MBeanServerConnection, String, Class<T>) - Static method in class java.lang.management.ManagementFactory
Returns a proxy for a platform MXBean interface of a given MXBean name that forwards its method calls through the given MBeanServerConnection.
newProxyInstance(ClassLoader, Class<?>[], InvocationHandler) - Static method in class java.lang.reflect.Proxy
Returns an instance of a proxy class for the specified interfaces that dispatches method invocations to the specified invocation handler.
newProxyInstance(MBeanServerConnection, ObjectName, Class<T>, boolean) - Static method in class javax.management.MBeanServerInvocationHandler
Return a proxy that implements the given interface by forwarding its methods through the given MBean server to the named MBean.
newReader(ReadableByteChannel, CharsetDecoder, int) - Static method in class java.nio.channels.Channels
Constructs a reader that decodes bytes from the given channel using the given decoder.
newReader(ReadableByteChannel, String) - Static method in class java.nio.channels.Channels
Constructs a reader that decodes bytes from the given channel according to the named charset.
newReference(String, DigestMethod) - Method in class javax.xml.crypto.dsig.XMLSignatureFactory
Creates a Reference with the specified URI and digest method.
newReference(String, DigestMethod, List, String, String) - Method in class javax.xml.crypto.dsig.XMLSignatureFactory
Creates a Reference with the specified parameters.
newReference(String, DigestMethod, List, String, String, byte[]) - Method in class javax.xml.crypto.dsig.XMLSignatureFactory
Creates a Reference with the specified parameters and pre-calculated digest value.
newReference(String, DigestMethod, List, Data, List, String, String) - Method in class javax.xml.crypto.dsig.XMLSignatureFactory
Creates a Reference with the specified parameters.
newRetrievalMethod(String) - Method in class javax.xml.crypto.dsig.keyinfo.KeyInfoFactory
Creates a RetrievalMethod from the specified URI.
newRetrievalMethod(String, String, List) - Method in class javax.xml.crypto.dsig.keyinfo.KeyInfoFactory
Creates a RetrievalMethod from the specified parameters.
newRowsAdded(TableModelEvent) - Method in class javax.swing.table.DefaultTableModel
Ensures that the new rows have the correct number of columns.
NEWS - Static variable in class javax.print.attribute.standard.ReferenceUriSchemesSupported
USENET news.
newSAXParser() - Method in class javax.xml.parsers.SAXParserFactory
Creates a new instance of a SAXParser using the currently configured factory parameters.
newScheduledThreadPool(int) - Static method in class java.util.concurrent.Executors
Creates a thread pool that can schedule commands to run after a given delay, or to execute periodically.
newScheduledThreadPool(int, ThreadFactory) - Static method in class java.util.concurrent.Executors
Creates a thread pool that can schedule commands to run after a given delay, or to execute periodically.
newSchema(Source) - Method in class javax.xml.validation.SchemaFactory
Parses the specified source as a schema and returns it as a schema.
newSchema(File) - Method in class javax.xml.validation.SchemaFactory
Parses the specified File as a schema and returns it as a Schema.
newSchema(URL) - Method in class javax.xml.validation.SchemaFactory
Parses the specified URL as a schema and returns it as a Schema.
newSchema(Source[]) - Method in class javax.xml.validation.SchemaFactory
Parses the specified source(s) as a schema and returns it as a schema.
newSchema() - Method in class javax.xml.validation.SchemaFactory
Creates a special Schema object.
newSetFromMap(Map<E, Boolean>) - Static method in class java.util.Collections
Returns a set backed by the specified map.
newSignatureMethod(String, SignatureMethodParameterSpec) - Method in class javax.xml.crypto.dsig.XMLSignatureFactory
Creates a SignatureMethod for the specified algorithm URI and parameters.
newSignatureProperties(List, String) - Method in class javax.xml.crypto.dsig.XMLSignatureFactory
Creates a SignatureProperties containing the specified list of SignaturePropertys and optional id.
newSignatureProperty(List, String, String) - Method in class javax.xml.crypto.dsig.XMLSignatureFactory
Creates a SignatureProperty containing the specified list of XMLStructures, target URI and optional id.
newSignedInfo(CanonicalizationMethod, SignatureMethod, List) - Method in class javax.xml.crypto.dsig.XMLSignatureFactory
Creates a SignedInfo with the specified canonicalization and signature methods, and list of one or more references.
newSignedInfo(CanonicalizationMethod, SignatureMethod, List, String) - Method in class javax.xml.crypto.dsig.XMLSignatureFactory
Creates a SignedInfo with the specified parameters.
newSingleThreadExecutor() - Static method in class java.util.concurrent.Executors
Creates an Executor that uses a single worker thread operating off an unbounded queue.
newSingleThreadExecutor(ThreadFactory) - Static method in class java.util.concurrent.Executors
Creates an Executor that uses a single worker thread operating off an unbounded queue, and uses the provided ThreadFactory to create a new thread when needed.
newSingleThreadScheduledExecutor() - Static method in class java.util.concurrent.Executors
Creates a single-threaded executor that can schedule commands to run after a given delay, or to execute periodically.
newSingleThreadScheduledExecutor(ThreadFactory) - Static method in class java.util.concurrent.Executors
Creates a single-threaded executor that can schedule commands to run after a given delay, or to execute periodically.
newSOAPFactory(String) - Method in class javax.xml.soap.SAAJMetaFactory
Creates a SOAPFactory object for the given String protocol.
newTaskFor(Runnable, T) - Method in class java.util.concurrent.AbstractExecutorService
Returns a RunnableFuture for the given runnable and default value.
newTaskFor(Callable<T>) - Method in class java.util.concurrent.AbstractExecutorService
Returns a RunnableFuture for the given callable task.
newTaskFor(Runnable, T) - Method in class java.util.concurrent.ForkJoinPool
newTaskFor(Callable<T>) - Method in class java.util.concurrent.ForkJoinPool
newTemplates(Source) - Method in class javax.xml.transform.TransformerFactory
Process the Source into a Templates object, which is a a compiled representation of the source.
newTemplatesHandler() - Method in class javax.xml.transform.sax.SAXTransformerFactory
Get a TemplatesHandler object that can process SAX ContentHandler events into a Templates object.
newThread(ForkJoinPool) - Method in interface java.util.concurrent.ForkJoinPool.ForkJoinWorkerThreadFactory
Returns a new worker thread operating in the given pool.
newThread(Runnable) - Method in interface java.util.concurrent.ThreadFactory
Constructs a new Thread.
newTransform(String, TransformParameterSpec) - Method in class javax.xml.crypto.dsig.XMLSignatureFactory
Creates a Transform for the specified algorithm URI and parameters.
newTransform(String, XMLStructure) - Method in class javax.xml.crypto.dsig.XMLSignatureFactory
Creates a Transform for the specified algorithm URI and parameters.
newTransformer() - Method in interface javax.xml.transform.Templates
Create a new transformation context for this Templates object.
newTransformer(Source) - Method in class javax.xml.transform.TransformerFactory
Process the Source into a Transformer Object.
newTransformer() - Method in class javax.xml.transform.TransformerFactory
Create a new Transformer that performs a copy of the Source to the Result.
newTransformerHandler(Source) - Method in class javax.xml.transform.sax.SAXTransformerFactory
Get a TransformerHandler object that can process SAX ContentHandler events into a Result, based on the transformation instructions specified by the argument.
newTransformerHandler(Templates) - Method in class javax.xml.transform.sax.SAXTransformerFactory
Get a TransformerHandler object that can process SAX ContentHandler events into a Result, based on the Templates argument.
newTransformerHandler() - Method in class javax.xml.transform.sax.SAXTransformerFactory
Get a TransformerHandler object that can process SAX ContentHandler events into a Result.
newUnpacker() - Static method in class java.util.jar.Pack200
Obtain new instance of a class that implements Unpacker.
newUpdater(Class<U>, String) - Static method in class java.util.concurrent.atomic.AtomicIntegerFieldUpdater
Creates and returns an updater for objects with the given field.
newUpdater(Class<U>, String) - Static method in class java.util.concurrent.atomic.AtomicLongFieldUpdater
Creates and returns an updater for objects with the given field.
newUpdater(Class<U>, Class<W>, String) - Static method in class java.util.concurrent.atomic.AtomicReferenceFieldUpdater
Creates and returns an updater for objects with the given field.
newValidator() - Method in class javax.xml.validation.Schema
Creates a new Validator for this Schema.
newValidatorHandler() - Method in class javax.xml.validation.Schema
Creates a new ValidatorHandler for this Schema.
newWatchService() - Method in class java.nio.file.FileSystem
Constructs a new WatchService (optional operation).
newWorkStealingPool(int) - Static method in class java.util.concurrent.Executors
Creates a thread pool that maintains enough threads to support the given parallelism level, and may use multiple queues to reduce contention.
newWorkStealingPool() - Static method in class java.util.concurrent.Executors
Creates a work-stealing thread pool using all available processors as its target parallelism level.
newWriter(WritableByteChannel, CharsetEncoder, int) - Static method in class java.nio.channels.Channels
Constructs a writer that encodes characters using the given encoder and writes the resulting bytes to the given channel.
newWriter(WritableByteChannel, String) - Static method in class java.nio.channels.Channels
Constructs a writer that encodes characters according to the named charset and writes the resulting bytes to the given channel.
newX509Data(List) - Method in class javax.xml.crypto.dsig.keyinfo.KeyInfoFactory
Creates a X509Data containing the specified list of X.509 content.
newX509IssuerSerial(String, BigInteger) - Method in class javax.xml.crypto.dsig.keyinfo.KeyInfoFactory
Creates an X509IssuerSerial from the specified X.500 issuer distinguished name and serial number.
newXMLFilter(Source) - Method in class javax.xml.transform.sax.SAXTransformerFactory
Create an XMLFilter that uses the given Source as the transformation instructions.
newXMLFilter(Templates) - Method in class javax.xml.transform.sax.SAXTransformerFactory
Create an XMLFilter, based on the Templates argument..
newXMLGregorianCalendar() - Method in class javax.xml.datatype.DatatypeFactory
Create a new instance of an XMLGregorianCalendar.
newXMLGregorianCalendar(String) - Method in class javax.xml.datatype.DatatypeFactory
Create a new XMLGregorianCalendar by parsing the String as a lexical representation.
newXMLGregorianCalendar(GregorianCalendar) - Method in class javax.xml.datatype.DatatypeFactory
Create an XMLGregorianCalendar from a GregorianCalendar.
newXMLGregorianCalendar(BigInteger, int, int, int, int, int, BigDecimal, int) - Method in class javax.xml.datatype.DatatypeFactory
Constructor allowing for complete value spaces allowed by W3C XML Schema 1.0 recommendation for xsd:dateTime and related builtin datatypes.
newXMLGregorianCalendar(int, int, int, int, int, int, int, int) - Method in class javax.xml.datatype.DatatypeFactory
Constructor of value spaces that a java.util.GregorianCalendar instance would need to convert to an XMLGregorianCalendar instance.
newXMLGregorianCalendarDate(int, int, int, int) - Method in class javax.xml.datatype.DatatypeFactory
Create a Java representation of XML Schema builtin datatype date or g*.
newXMLGregorianCalendarTime(int, int, int, int) - Method in class javax.xml.datatype.DatatypeFactory
Create a Java instance of XML Schema builtin datatype time.
newXMLGregorianCalendarTime(int, int, int, BigDecimal, int) - Method in class javax.xml.datatype.DatatypeFactory
Create a Java instance of XML Schema builtin datatype time.
newXMLGregorianCalendarTime(int, int, int, int, int) - Method in class javax.xml.datatype.DatatypeFactory
Create a Java instance of XML Schema builtin datatype time.
newXMLObject(List, String, String, String) - Method in class javax.xml.crypto.dsig.XMLSignatureFactory
Creates an XMLObject from the specified parameters.
newXMLSignature(SignedInfo, KeyInfo) - Method in class javax.xml.crypto.dsig.XMLSignatureFactory
Creates an XMLSignature and initializes it with the contents of the specified SignedInfo and KeyInfo objects.
newXMLSignature(SignedInfo, KeyInfo, List, String, String) - Method in class javax.xml.crypto.dsig.XMLSignatureFactory
Creates an XMLSignature and initializes it with the specified parameters.
newXPath() - Method in class javax.xml.xpath.XPathFactory
Return a new XPath using the underlying object model determined when the XPathFactory was instantiated.
next(Container) - Method in class java.awt.CardLayout
Flips to the next card of the specified container.
next() - Method in class java.awt.geom.FlatteningPathIterator
Moves the iterator to the next segment of the path forwards along the primary direction of traversal as long as there are more points in that direction.
next() - Method in interface java.awt.geom.PathIterator
Moves the iterator to the next segment of the path forwards along the primary direction of traversal as long as there are more points in that direction.
next() - Method in class java.beans.beancontext.BeanContextSupport.BCSIterator
next(int) - Method in class java.security.SecureRandom
Generates an integer containing the user-specified number of pseudo-random bits (right justified, with leading zeros).
next() - Method in interface java.sql.ResultSet
Moves the cursor forward one row from its current position.
next(int) - Method in class java.text.BreakIterator
Returns the nth boundary from the current boundary.
next() - Method in class java.text.BreakIterator
Returns the boundary following the current boundary.
next() - Method in interface java.text.CharacterIterator
Increments the iterator's index by one and returns the character at the new index.
next() - Method in class java.text.CollationElementIterator
Get the next collation element in the string.
next() - Method in class java.text.StringCharacterIterator
Implements CharacterIterator.next() for String.
next(DayOfWeek) - Static method in class java.time.temporal.TemporalAdjusters
Returns the next day-of-week adjuster, which adjusts the date to the first occurrence of the specified day-of-week after the date being adjusted.
next(int) - Method in class java.util.concurrent.ThreadLocalRandom
next() - Method in interface java.util.Iterator
Returns the next element in the iteration.
next() - Method in interface java.util.ListIterator
Returns the next element in the list and advances the cursor position.
next() - Method in interface java.util.PrimitiveIterator.OfDouble
Returns the next element in the iteration.
next() - Method in interface java.util.PrimitiveIterator.OfInt
Returns the next element in the iteration.
next() - Method in interface java.util.PrimitiveIterator.OfLong
Returns the next element in the iteration.
next(int) - Method in class java.util.Random
Generates the next pseudorandom number.
next() - Method in class java.util.Scanner
Finds and returns the next complete token from this scanner.
next(String) - Method in class java.util.Scanner
Returns the next token if it matches the pattern constructed from the specified string.
next(Pattern) - Method in class java.util.Scanner
Returns the next token if it matches the specified pattern.
next() - Method in interface javax.naming.NamingEnumeration
Retrieves the next element in the enumeration.
next(int) - Method in class javax.print.attribute.SetOfIntegerSyntax
Determine the smallest integer in this set-of-integer attribute that is greater than the given value.
next() - Method in interface javax.print.MultiDoc
Go to the multidoc object that contains the next doc object in the sequence of doc objects.
NEXT - Static variable in interface javax.swing.SwingConstants
Identifies the next direction in a sequence.
next() - Method in class javax.swing.text.ElementIterator
Fetches the next Element.
next() - Method in class javax.swing.text.html.HTMLDocument.Iterator
Move the iterator forward to the next occurrence of the tag it represents.
next - Variable in class javax.swing.text.html.parser.AttributeList
next - Variable in class javax.swing.text.html.parser.ContentModel
The next content model (in a ',', '|' or '&' expression).
next() - Method in class javax.swing.text.Segment
Increments the iterator's index by one and returns the character at the new index.
next() - Method in class javax.xml.stream.util.EventReaderDelegate
next() - Method in class javax.xml.stream.util.StreamReaderDelegate
next() - Method in interface javax.xml.stream.XMLStreamReader
Get next parsing event - a processor may return all contiguous character data in a single chunk, or it may split it into several chunks.
next() - Method in interface org.omg.CORBA.DynAny
Deprecated.
Moves to the next component of this DynAny object.
next() - Method in class org.omg.DynamicAny._DynAnyStub
Advances the current position to the next component.
next() - Method in class org.omg.DynamicAny._DynArrayStub
Advances the current position to the next component.
next() - Method in class org.omg.DynamicAny._DynEnumStub
Advances the current position to the next component.
next() - Method in class org.omg.DynamicAny._DynFixedStub
Advances the current position to the next component.
next() - Method in class org.omg.DynamicAny._DynSequenceStub
Advances the current position to the next component.
next() - Method in class org.omg.DynamicAny._DynStructStub
Advances the current position to the next component.
next() - Method in class org.omg.DynamicAny._DynUnionStub
Advances the current position to the next component.
next() - Method in class org.omg.DynamicAny._DynValueStub
Advances the current position to the next component.
next() - Method in interface org.omg.DynamicAny.DynAnyOperations
Advances the current position to the next component.
next_n(int, BindingListHolder) - Method in class org.omg.CosNaming._BindingIteratorStub
This operation returns at most the requested number of bindings.
next_n(int, BindingListHolder) - Method in interface org.omg.CosNaming.BindingIteratorOperations
This operation returns at most the requested number of bindings.
next_one(BindingHolder) - Method in class org.omg.CosNaming._BindingIteratorStub
This operation returns the next binding.
next_one(BindingHolder) - Method in interface org.omg.CosNaming.BindingIteratorOperations
This operation returns the next binding.
nextAfter(double, double) - Static method in class java.lang.Math
Returns the floating-point number adjacent to the first argument in the direction of the second argument.
nextAfter(float, double) - Static method in class java.lang.Math
Returns the floating-point number adjacent to the first argument in the direction of the second argument.
nextAfter(double, double) - Static method in class java.lang.StrictMath
Returns the floating-point number adjacent to the first argument in the direction of the second argument.
nextAfter(float, double) - Static method in class java.lang.StrictMath
Returns the floating-point number adjacent to the first argument in the direction of the second argument.
nextBigDecimal() - Method in class java.util.Scanner
Scans the next token of the input as a BigDecimal.
nextBigInteger() - Method in class java.util.Scanner
Scans the next token of the input as a BigInteger.
nextBigInteger(int) - Method in class java.util.Scanner
Scans the next token of the input as a BigInteger.
nextBoolean() - Method in class java.util.concurrent.ThreadLocalRandom
Returns a pseudorandom boolean value.
nextBoolean() - Method in class java.util.Random
Returns the next pseudorandom, uniformly distributed boolean value from this random number generator's sequence.
nextBoolean() - Method in class java.util.Scanner
Scans the next token of the input into a boolean value and returns that value.
nextBoolean() - Method in class java.util.SplittableRandom
Returns a pseudorandom boolean value.
nextByte() - Method in class java.util.Scanner
Scans the next token of the input as a byte.
nextByte(int) - Method in class java.util.Scanner
Scans the next token of the input as a byte.
nextBytes(byte[]) - Method in class java.security.SecureRandom
Generates a user-specified number of random bytes.
nextBytes(byte[]) - Method in class java.util.Random
Generates random bytes and places them into a user-supplied byte array.
nextClearBit(int) - Method in class java.util.BitSet
Returns the index of the first bit that is set to false that occurs on or after the specified starting index.
nextComplete() - Method in class java.util.concurrent.CountedCompleter
If this task does not have a completer, invokes ForkJoinTask.quietlyComplete() and returns null.
nextConflict() - Method in interface javax.sql.rowset.spi.SyncResolver
Moves the cursor down from its current position to the next row that contains a conflict value.
nextDouble(double) - Static method in class java.text.ChoiceFormat
Finds the least double greater than d.
nextDouble(double, boolean) - Static method in class java.text.ChoiceFormat
Finds the least double greater than d (if positive is true), or the greatest double less than d (if positive is false).
nextDouble() - Method in class java.util.concurrent.ThreadLocalRandom
Returns a pseudorandom double value between zero (inclusive) and one (exclusive).
nextDouble(double) - Method in class java.util.concurrent.ThreadLocalRandom
Returns a pseudorandom double value between 0.0 (inclusive) and the specified bound (exclusive).
nextDouble(double, double) - Method in class java.util.concurrent.ThreadLocalRandom
Returns a pseudorandom double value between the specified origin (inclusive) and bound (exclusive).
nextDouble() - Method in interface java.util.PrimitiveIterator.OfDouble
Returns the next double element in the iteration.
nextDouble() - Method in class java.util.Random
Returns the next pseudorandom, uniformly distributed double value between 0.0 and 1.0 from this random number generator's sequence.
nextDouble() - Method in class java.util.Scanner
Scans the next token of the input as a double.
nextDouble() - Method in class java.util.SplittableRandom
Returns a pseudorandom double value between zero (inclusive) and one (exclusive).
nextDouble(double) - Method in class java.util.SplittableRandom
Returns a pseudorandom double value between 0.0 (inclusive) and the specified bound (exclusive).
nextDouble(double, double) - Method in class java.util.SplittableRandom
Returns a pseudorandom double value between the specified origin (inclusive) and bound (exclusive).
nextDown(double) - Static method in class java.lang.Math
Returns the floating-point value adjacent to d in the direction of negative infinity.
nextDown(float) - Static method in class java.lang.Math
Returns the floating-point value adjacent to f in the direction of negative infinity.
nextDown(double) - Static method in class java.lang.StrictMath
Returns the floating-point value adjacent to d in the direction of negative infinity.
nextDown(float) - Static method in class java.lang.StrictMath
Returns the floating-point value adjacent to f in the direction of negative infinity.
nextElement() - Method in interface java.util.Enumeration
Returns the next element of this enumeration if this enumeration object has at least one more element to provide.
nextElement() - Method in class java.util.StringTokenizer
Returns the same value as the nextToken method, except that its declared return value is Object rather than String.
nextEvent() - Method in class javax.xml.stream.util.EventReaderDelegate
nextEvent() - Method in interface javax.xml.stream.XMLEventReader
Get the next XMLEvent
nextFloat() - Method in class java.util.concurrent.ThreadLocalRandom
Returns a pseudorandom float value between zero (inclusive) and one (exclusive).
nextFloat() - Method in class java.util.Random
Returns the next pseudorandom, uniformly distributed float value between 0.0 and 1.0 from this random number generator's sequence.
nextFloat() - Method in class java.util.Scanner
Scans the next token of the input as a float.
nextFocus() - Method in class java.awt.Component
Deprecated.
As of JDK version 1.1, replaced by transferFocus().
nextGaussian() - Method in class java.util.concurrent.ThreadLocalRandom
nextGaussian() - Method in class java.util.Random
Returns the next pseudorandom, Gaussian ("normally") distributed double value with mean 0.0 and standard deviation 1.0 from this random number generator's sequence.
nextIndex() - Method in interface java.util.ListIterator
Returns the index of the element that would be returned by a subsequent call to ListIterator.next().
nextInt() - Method in class java.util.concurrent.ThreadLocalRandom
Returns a pseudorandom int value.
nextInt(int) - Method in class java.util.concurrent.ThreadLocalRandom
Returns a pseudorandom int value between zero (inclusive) and the specified bound (exclusive).
nextInt(int, int) - Method in class java.util.concurrent.ThreadLocalRandom
Returns a pseudorandom int value between the specified origin (inclusive) and the specified bound (exclusive).
nextInt() - Method in interface java.util.PrimitiveIterator.OfInt
Returns the next int element in the iteration.
nextInt() - Method in class java.util.Random
Returns the next pseudorandom, uniformly distributed int value from this random number generator's sequence.
nextInt(int) - Method in class java.util.Random
Returns a pseudorandom, uniformly distributed int value between 0 (inclusive) and the specified value (exclusive), drawn from this random number generator's sequence.
nextInt() - Method in class java.util.Scanner
Scans the next token of the input as an int.
nextInt(int) - Method in class java.util.Scanner
Scans the next token of the input as an int.
nextInt() - Method in class java.util.SplittableRandom
Returns a pseudorandom int value.
nextInt(int) - Method in class java.util.SplittableRandom
Returns a pseudorandom int value between zero (inclusive) and the specified bound (exclusive).
nextInt(int, int) - Method in class java.util.SplittableRandom
Returns a pseudorandom int value between the specified origin (inclusive) and the specified bound (exclusive).
nextLayout(float) - Method in class java.awt.font.LineBreakMeasurer
Returns the next layout, and updates the current position.
nextLayout(float, int, boolean) - Method in class java.awt.font.LineBreakMeasurer
Returns the next layout, and updates the current position.
nextLine() - Method in class java.util.Scanner
Advances this scanner past the current line and returns the input that was skipped.
nextLong() - Method in class java.util.concurrent.ThreadLocalRandom
Returns a pseudorandom long value.
nextLong(long) - Method in class java.util.concurrent.ThreadLocalRandom
Returns a pseudorandom long value between zero (inclusive) and the specified bound (exclusive).
nextLong(long, long) - Method in class java.util.concurrent.ThreadLocalRandom
Returns a pseudorandom long value between the specified origin (inclusive) and the specified bound (exclusive).
nextLong() - Method in interface java.util.PrimitiveIterator.OfLong
Returns the next long element in the iteration.
nextLong() - Method in class java.util.Random
Returns the next pseudorandom, uniformly distributed long value from this random number generator's sequence.
nextLong() - Method in class java.util.Scanner
Scans the next token of the input as a long.
nextLong(int) - Method in class java.util.Scanner
Scans the next token of the input as a long.
nextLong() - Method in class java.util.SplittableRandom
Returns a pseudorandom long value.
nextLong(long) - Method in class java.util.SplittableRandom
Returns a pseudorandom long value between zero (inclusive) and the specified bound (exclusive).
nextLong(long, long) - Method in class java.util.SplittableRandom
Returns a pseudorandom long value between the specified origin (inclusive) and the specified bound (exclusive).
nextOffset(float) - Method in class java.awt.font.LineBreakMeasurer
Returns the position at the end of the next layout.
nextOffset(float, int, boolean) - Method in class java.awt.font.LineBreakMeasurer
Returns the position at the end of the next layout.
nextOrSame(DayOfWeek) - Static method in class java.time.temporal.TemporalAdjusters
Returns the next-or-same day-of-week adjuster, which adjusts the date to the first occurrence of the specified day-of-week after the date being adjusted unless it is already on that day in which case the same object is returned.
nextPage() - Method in interface javax.sql.rowset.CachedRowSet
Increments the current page of the CachedRowSet.
nextProbablePrime() - Method in class java.math.BigInteger
Returns the first integer greater than this BigInteger that is probably prime.
nextSetBit(int) - Method in class java.util.BitSet
Returns the index of the first bit that is set to true that occurs on or after the specified starting index.
nextShort() - Method in class java.util.Scanner
Scans the next token of the input as a short.
nextShort(int) - Method in class java.util.Scanner
Scans the next token of the input as a short.
nextTabStop(float, int) - Method in class javax.swing.text.ParagraphView
Returns the next tab stop position given a reference position.
nextTabStop(float, int) - Method in class javax.swing.text.PlainView
Returns the next tab stop position after a given reference position.
nextTabStop(float, int) - Method in interface javax.swing.text.TabExpander
Returns the next tab stop position given a reference position.
nextTabStop(float, int) - Method in class javax.swing.text.WrappedPlainView
Returns the next tab stop position after a given reference position.
nextTag() - Method in class javax.xml.stream.util.EventReaderDelegate
nextTag() - Method in class javax.xml.stream.util.StreamReaderDelegate
nextTag() - Method in interface javax.xml.stream.XMLEventReader
Skips any insignificant space events until a START_ELEMENT or END_ELEMENT is reached.
nextTag() - Method in interface javax.xml.stream.XMLStreamReader
Skips any white space (isWhiteSpace() returns true), COMMENT, or PROCESSING_INSTRUCTION, until a START_ELEMENT or END_ELEMENT is reached.
nextToken() - Method in class java.io.StreamTokenizer
Parses the next token from the input stream of this tokenizer.
nextToken() - Method in class java.util.StringTokenizer
Returns the next token from this string tokenizer.
nextToken(String) - Method in class java.util.StringTokenizer
Returns the next token in this string tokenizer's string.
nextTransition(Instant) - Method in class java.time.zone.ZoneRules
Gets the next transition after the specified instant.
nextUp(double) - Static method in class java.lang.Math
Returns the floating-point value adjacent to d in the direction of positive infinity.
nextUp(float) - Static method in class java.lang.Math
Returns the floating-point value adjacent to f in the direction of positive infinity.
nextUp(double) - Static method in class java.lang.StrictMath
Returns the floating-point value adjacent to d in the direction of positive infinity.
nextUp(float) - Static method in class java.lang.StrictMath
Returns the floating-point value adjacent to f in the direction of positive infinity.
nextWordAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the Action for moving the caret to the beginning of the next word.
nil - Variable in class javax.xml.bind.JAXBElement
true iff the xml element instance has xsi:nil="true".
NimbusLookAndFeel - Class in javax.swing.plaf.nimbus
The NimbusLookAndFeel class.
NimbusLookAndFeel() - Constructor for class javax.swing.plaf.nimbus.NimbusLookAndFeel
Create a new NimbusLookAndFeel.
NimbusStyle - Class in javax.swing.plaf.nimbus
A SynthStyle implementation used by Nimbus.
NKO - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "NKo" Unicode character block.
NMTOKEN - Static variable in interface javax.swing.text.html.parser.DTDConstants
NMTOKENS - Static variable in interface javax.swing.text.html.parser.DTDConstants
NNTP - Static variable in class javax.print.attribute.standard.ReferenceUriSchemesSupported
USENET news using Network News Transfer Protocol (NNTP).
NO - Static variable in class javax.security.auth.callback.ConfirmationCallback
NO option.
NO_COMPRESSION - Static variable in class java.util.zip.Deflater
Compression level for no compression.
NO_CONTEXT - Static variable in exception org.ietf.jgss.GSSException
Invalid security context.
NO_CRED - Static variable in exception org.ietf.jgss.GSSException
Invalid credentials.
NO_DATA_ALLOWED_ERR - Static variable in exception org.w3c.dom.DOMException
If data is specified for a Node which does not support data.
NO_DECOMPOSITION - Static variable in class java.text.Collator
Decomposition mode value.
NO_FIELDS - Static variable in class java.io.ObjectStreamClass
serialPersistentFields value indicating no serializable fields
NO_FLUSH - Static variable in class java.util.zip.Deflater
Compression flush mode used to achieve best compression result.
NO_GENERATED_KEYS - Static variable in interface java.sql.Statement
The constant indicating that generated keys should not be made available for retrieval.
NO_HIGHLIGHT - Static variable in class javax.swing.plaf.basic.BasicScrollBarUI
NO_IMPLEMENT - Exception in org.omg.CORBA
This exception indicates that even though the operation that was invoked exists (it has an IDL definition), no implementation for that operation exists.
NO_IMPLEMENT() - Constructor for exception org.omg.CORBA.NO_IMPLEMENT
Constructs a NO_IMPLEMENT exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
NO_IMPLEMENT(String) - Constructor for exception org.omg.CORBA.NO_IMPLEMENT
Constructs a NO_IMPLEMENT exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
NO_IMPLEMENT(int, CompletionStatus) - Constructor for exception org.omg.CORBA.NO_IMPLEMENT
Constructs a NO_IMPLEMENT exception with the specified minor code and completion status.
NO_IMPLEMENT(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.NO_IMPLEMENT
Constructs a NO_IMPLEMENT exception with the specified description message, minor code, and completion status.
NO_IMPLICIT_ACTIVATION - Static variable in class org.omg.PortableServer.ImplicitActivationPolicyValue
NO_LOCATION - Static variable in annotation type javax.xml.bind.annotation.XmlSchema
The default value of the XmlSchema.location() attribute, which indicates that the schema generator will generate components in this namespace.
NO_MEMORY - Exception in org.omg.CORBA
Exception thrown when the ORB run time has run out of memory.
NO_MEMORY() - Constructor for exception org.omg.CORBA.NO_MEMORY
Constructs a NO_MEMORY exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
NO_MEMORY(String) - Constructor for exception org.omg.CORBA.NO_MEMORY
Constructs a NO_MEMORY exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
NO_MEMORY(int, CompletionStatus) - Constructor for exception org.omg.CORBA.NO_MEMORY
Constructs a NO_MEMORY exception with the specified minor code and completion status.
NO_MEMORY(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.NO_MEMORY
Constructs a NO_MEMORY exception with the specified description message, minor code, and completion status.
NO_MODIFICATION_ALLOWED_ERR - Static variable in exception org.w3c.dom.DOMException
If an attempt is made to modify an object where modifications are not allowed.
NO_MORE_EVENTS - Static variable in class javax.print.event.PrintJobEvent
Not all print services may be capable of delivering interesting events, or even telling when a job is complete.
NO_OPTION - Static variable in class javax.swing.JOptionPane
Return value from class method if NO is chosen.
NO_ORIENTATION - Static variable in interface java.awt.Adjustable
Indicates that the Adjustable has no orientation.
NO_PERMISSION - Exception in org.omg.CORBA
Exception thrown when an invocation failed because the caller has insufficient privileges.
NO_PERMISSION() - Constructor for exception org.omg.CORBA.NO_PERMISSION
Constructs a NO_PERMISSION exception with a default minor code of 0 and a completion state of CompletionStatus.COMPLETED_NO, and a null description.
NO_PERMISSION(String) - Constructor for exception org.omg.CORBA.NO_PERMISSION
Constructs a NO_PERMISSION exception with the specified description, a minor code of 0, and a completion state of COMPLETED_NO.
NO_PERMISSION(int, CompletionStatus) - Constructor for exception org.omg.CORBA.NO_PERMISSION
Constructs a NO_PERMISSION exception with the specified minor code and completion status.
NO_PERMISSION(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.NO_PERMISSION
Constructs a NO_PERMISSION exception with the specified description message, minor code, and completion status.
NO_PROXY - Static variable in class java.net.Proxy
A proxy setting that represents a DIRECT connection, basically telling the protocol handler not to use any proxying.
NO_RESOURCES - Exception in org.omg.CORBA
Exception thrown when the ORB has encountered some general resource limitation.
NO_RESOURCES() - Constructor for exception org.omg.CORBA.NO_RESOURCES
Constructs a NO_RESOURCES exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
NO_RESOURCES(String) - Constructor for exception org.omg.CORBA.NO_RESOURCES
Constructs a NO_RESOURCES exception with the specified description, a minor code of 0, and a completion state of COMPLETED_NO.
NO_RESOURCES(int, CompletionStatus) - Constructor for exception org.omg.CORBA.NO_RESOURCES
Constructs a NO_RESOURCES exception with the specified minor code and completion status.
NO_RESOURCES(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.NO_RESOURCES
Constructs a NO_RESOURCES exception with the specified description message, minor code, and completion status.
NO_RESPONSE - Exception in org.omg.CORBA
This exception is raised if a client attempts to retrieve the result of a deferred synchronous call, but the response for the request is not yet available.
NO_RESPONSE() - Constructor for exception org.omg.CORBA.NO_RESPONSE
Constructs a NO_RESPONSE exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
NO_RESPONSE(String) - Constructor for exception org.omg.CORBA.NO_RESPONSE
Constructs a NO_RESPONSE exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
NO_RESPONSE(int, CompletionStatus) - Constructor for exception org.omg.CORBA.NO_RESPONSE
Constructs a NO_RESPONSE exception with the specified minor code and completion status.
NO_RESPONSE(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.NO_RESPONSE
Constructs a NO_RESPONSE exception with the specified description message, minor code, and completion status.
NO_ROLE_WITH_NAME - Static variable in class javax.management.relation.RoleStatus
Problem type when trying to access an unknown role.
NO_ROW_CONFLICT - Static variable in interface javax.sql.rowset.spi.SyncResolver
Indicates that no conflict occurred while the RowSet object was attempting to update, delete or insert a row in the data source.
NO_SUCH_PAGE - Static variable in interface java.awt.print.Printable
Returned from print to signify that the pageIndex is too large and that the requested page does not exist.
NO_SYNC - Static variable in class javax.sound.midi.Sequencer.SyncMode
A slave synchronization mode indicating that no timing information should be sent to the receiver.
nobject - Static variable in class org.omg.CosNaming.BindingType
NOBUTTON - Static variable in class java.awt.event.MouseEvent
Indicates no mouse buttons; used by MouseEvent.getButton().
NoClassDefFoundError - Error in java.lang
Thrown if the Java Virtual Machine or a ClassLoader instance tries to load in the definition of a class (as part of a normal method call or as part of creating a new instance using the new expression) and no definition of the class could be found.
NoClassDefFoundError() - Constructor for error java.lang.NoClassDefFoundError
Constructs a NoClassDefFoundError with no detail message.
NoClassDefFoundError(String) - Constructor for error java.lang.NoClassDefFoundError
Constructs a NoClassDefFoundError with the specified detail message.
NoConnectionPendingException - Exception in java.nio.channels
Unchecked exception thrown when the finishConnect method of a SocketChannel is invoked without first successfully invoking its connect method.
NoConnectionPendingException() - Constructor for exception java.nio.channels.NoConnectionPendingException
Constructs an instance of this class.
NoContext - Exception in org.omg.PortableServer.CurrentPackage
org/omg/PortableServer/CurrentPackage/NoContext.java .
NoContext() - Constructor for exception org.omg.PortableServer.CurrentPackage.NoContext
NoContext(String) - Constructor for exception org.omg.PortableServer.CurrentPackage.NoContext
NoContextHelper - Class in org.omg.PortableServer.CurrentPackage
org/omg/PortableServer/CurrentPackage/NoContextHelper.java .
NoContextHelper() - Constructor for class org.omg.PortableServer.CurrentPackage.NoContextHelper
node(String) - Method in class java.util.prefs.AbstractPreferences
Implements the node method as per the specification in Preferences.node(String).
node(String) - Method in class java.util.prefs.Preferences
Returns the named preference node in the same tree as this node, creating it and any of its ancestors if they do not already exist.
node() - Method in class java.util.UUID
The node value associated with this UUID.
Node - Interface in javax.xml.soap
A representation of a node (element) in an XML document.
NODE - Static variable in class javax.xml.xpath.XPathConstants
The XPath 1.0 NodeSet data type.
Node - Interface in org.w3c.dom
The Node interface is the primary datatype for the entire Document Object Model.
NODE_ADOPTED - Static variable in interface org.w3c.dom.UserDataHandler
The node is adopted, using Document.adoptNode().
NODE_CLONED - Static variable in interface org.w3c.dom.UserDataHandler
The node is cloned, using Node.cloneNode().
NODE_DELETED - Static variable in interface org.w3c.dom.UserDataHandler
The node is deleted.
NODE_IMPORTED - Static variable in interface org.w3c.dom.UserDataHandler
The node is imported, using Document.importNode().
NODE_RENAMED - Static variable in interface org.w3c.dom.UserDataHandler
The node is renamed, using Document.renameNode().
nodeChanged(TreeNode) - Method in class javax.swing.tree.DefaultTreeModel
Invoke this method after you've changed how node is to be represented in the tree.
NodeChangeEvent - Class in java.util.prefs
An event emitted by a Preferences node to indicate that a child of that node has been added or removed.
NodeChangeEvent(Preferences, Preferences) - Constructor for class java.util.prefs.NodeChangeEvent
Constructs a new NodeChangeEvent instance.
NodeChangeListener - Interface in java.util.prefs
A listener for receiving preference node change events.
nodeDimensions - Variable in class javax.swing.plaf.basic.BasicTreeUI
Reponsible for telling the TreeState the size needed for a node.
nodeDimensions - Variable in class javax.swing.tree.AbstractLayoutCache
Object responsible for getting the size of a node.
NodeDimensions() - Constructor for class javax.swing.tree.AbstractLayoutCache.NodeDimensions
NodeDimensionsHandler() - Constructor for class javax.swing.plaf.basic.BasicTreeUI.NodeDimensionsHandler
nodeExists(String) - Method in class java.util.prefs.AbstractPreferences
Implements the nodeExists method as per the specification in Preferences.nodeExists(String).
nodeExists(String) - Method in class java.util.prefs.Preferences
Returns true if the named preference node exists in the same tree as this node.
NodeList - Interface in org.w3c.dom
The NodeList interface provides the abstraction of an ordered collection of nodes, without defining or constraining how this collection is implemented.
nodesChanged(TreeNode, int[]) - Method in class javax.swing.tree.DefaultTreeModel
Invoke this method after you've changed how the children identified by childIndicies are to be represented in the tree.
NODESET - Static variable in class javax.xml.xpath.XPathConstants
The XPath 1.0 NodeSet data type.
NodeSetData - Interface in javax.xml.crypto
An abstract representation of a Data type containing a node-set.
nodeStructureChanged(TreeNode) - Method in class javax.swing.tree.DefaultTreeModel
Invoke this method if you've totally changed the children of node and its children's children...
nodesWereInserted(TreeNode, int[]) - Method in class javax.swing.tree.DefaultTreeModel
Invoke this method after you've inserted some TreeNodes into node.
nodesWereRemoved(TreeNode, int[], Object[]) - Method in class javax.swing.tree.DefaultTreeModel
Invoke this method after you've removed some TreeNodes from node.
noFocusBorder - Static variable in class javax.swing.DefaultListCellRenderer
noFocusBorder - Static variable in class javax.swing.plaf.basic.BasicComboBoxRenderer
An empty Border.
noFocusBorder - Static variable in class javax.swing.table.DefaultTableCellRenderer
NOFRAMES - Static variable in class javax.swing.text.html.HTML.Tag
NOHREF - Static variable in class javax.swing.text.html.HTML.Attribute
NoInitialContextException - Exception in javax.naming
This exception is thrown when no initial context implementation can be created.
NoInitialContextException() - Constructor for exception javax.naming.NoInitialContextException
Constructs an instance of NoInitialContextException.
NoInitialContextException(String) - Constructor for exception javax.naming.NoInitialContextException
Constructs an instance of NoInitialContextException with an explanation.
NON_CONTINUOUS_DIVIDER - Static variable in class javax.swing.plaf.basic.BasicSplitPaneUI
The divider used for non-continuous layout is added to the split pane with this object.
non_existent(Object) - Method in class org.omg.CORBA.portable.Delegate
Determines whether the server object for the object reference has been destroyed.
NON_EXISTENT - Interface in org.omg.PortableInterceptor
org/omg/PortableInterceptor/NON_EXISTENT.java .
non_existent(Servant) - Method in interface org.omg.PortableServer.portable.Delegate
This operation is used to check for the existence of the Object.
NON_RETAIN - Static variable in class org.omg.PortableServer.ServantRetentionPolicyValue
NON_SPACING_MARK - Static variable in class java.lang.Character
General category "Mn" in the Unicode specification.
nonContinuousLayoutDivider - Variable in class javax.swing.plaf.basic.BasicSplitPaneUI
Instance for the shadow of the divider when non continuous layout is being used.
NONCRITICAL - Static variable in interface javax.naming.ldap.Control
Indicates a non-critical control.
NONE - Static variable in class java.awt.GridBagConstraints
Do not resize the component.
NONE - Static variable in class java.awt.JobAttributes.DialogType
The DialogType instance to use for specifying no print dialog.
NONE - Static variable in class javax.print.attribute.standard.Compression
No compression is used.
NONE - Static variable in class javax.print.attribute.standard.Finishings
Perform no binding.
NONE - Static variable in class javax.print.attribute.standard.JobSheets
No job sheets are printed.
NONE - Static variable in class javax.swing.JRootPane
Constant used for the windowDecorationStyle property.
NONE - Static variable in class javax.swing.TransferHandler
An int representing no transfer action.
NONE_OPTION - Static variable in class javax.swing.DebugGraphics
Don't debug graphics operations.
noneMatch(DoublePredicate) - Method in interface java.util.stream.DoubleStream
Returns whether no elements of this stream match the provided predicate.
noneMatch(IntPredicate) - Method in interface java.util.stream.IntStream
Returns whether no elements of this stream match the provided predicate.
noneMatch(LongPredicate) - Method in interface java.util.stream.LongStream
Returns whether no elements of this stream match the provided predicate.
noneMatch(Predicate<? super T>) - Method in interface java.util.stream.Stream
Returns whether no elements of this stream match the provided predicate.
noneOf(Class<E>) - Static method in class java.util.EnumSet
Creates an empty enum set with the specified element type.
NoninvertibleTransformException - Exception in java.awt.geom
The NoninvertibleTransformException class represents an exception that is thrown if an operation is performed requiring the inverse of an AffineTransform object but the AffineTransform is in a non-invertible state.
NoninvertibleTransformException(String) - Constructor for exception java.awt.geom.NoninvertibleTransformException
Constructs an instance of NoninvertibleTransformException with the specified detail message.
nonNull(Object) - Static method in class java.util.Objects
Returns true if the provided reference is non-null otherwise returns false.
NONNULL - Static variable in interface java.util.Spliterator
Characteristic value signifying that the source guarantees that encountered elements will not be null.
NonReadableChannelException - Exception in java.nio.channels
Unchecked exception thrown when an attempt is made to read from a channel that was not originally opened for reading.
NonReadableChannelException() - Constructor for exception java.nio.channels.NonReadableChannelException
Constructs an instance of this class.
NONUPDATABLE_VIEW_SYNC - Static variable in class javax.sql.rowset.spi.SyncProvider
Indicates that a SyncProvider implementation does not support synchronization between a RowSet object and the SQL VIEW used to populate it.
NonWritableChannelException - Exception in java.nio.channels
Unchecked exception thrown when an attempt is made to write to a channel that was not originally opened for writing.
NonWritableChannelException() - Constructor for exception java.nio.channels.NonWritableChannelException
Constructs an instance of this class.
NOON - Static variable in class java.time.LocalTime
The time of noon in the middle of the day, '12:00'.
NoPermissionException - Exception in javax.naming
This exception is thrown when attempting to perform an operation for which the client has no permission.
NoPermissionException(String) - Constructor for exception javax.naming.NoPermissionException
Constructs a new instance of NoPermissionException using an explanation.
NoPermissionException() - Constructor for exception javax.naming.NoPermissionException
Constructs a new instance of NoPermissionException.
NOPOS - Static variable in interface javax.tools.Diagnostic
Used to signal that no position is available.
NORESIZE - Static variable in class javax.swing.text.html.HTML.Attribute
NORM_PRIORITY - Static variable in class java.lang.Thread
The default priority that is assigned to a thread.
NORMAL - Static variable in class java.awt.Frame
Frame is in the "normal" state.
NORMAL - Static variable in class java.awt.PageAttributes.PrintQualityType
The PrintQualityType instance to use for specifying a normal print quality.
NORMAL - Static variable in class javax.print.attribute.standard.PrintQuality
Normal or intermediate quality on the printer.
normalize() - Method in class java.net.URI
Normalizes this URI's path.
normalize() - Method in interface java.nio.file.Path
Returns a path that is this path with redundant name elements eliminated.
normalize(CharSequence, Normalizer.Form) - Static method in class java.text.Normalizer
Normalize a sequence of char values.
normalize() - Method in class javax.imageio.metadata.IIOMetadataNode
Does nothing, since IIOMetadataNodes do not contain Text children.
normalize() - Method in class javax.xml.datatype.XMLGregorianCalendar
Normalize this instance to UTC.
normalize() - Method in interface org.w3c.dom.Node
Puts all Text nodes in the full depth of the sub-tree underneath this Node, including attribute nodes, into a "normal" form where only structure (e.g., elements, comments, processing instructions, CDATA sections, and entity references) separates Text nodes, i.e., there are neither adjacent Text nodes nor empty Text nodes.
normalized() - Method in interface java.time.chrono.ChronoPeriod
Returns a copy of this period with the amounts of each unit normalized.
normalized() - Method in class java.time.Period
Returns a copy of this period with the years and months normalized.
normalized() - Method in class java.time.ZoneId
Normalizes the time-zone ID, returning a ZoneOffset where possible.
normalizeDocument() - Method in interface org.w3c.dom.Document
This method acts as if the document was going through a save and load cycle, putting the document in a "normal" form.
NormalizedStringAdapter - Class in javax.xml.bind.annotation.adapters
XmlAdapter to handle xs:normalizedString.
NormalizedStringAdapter() - Constructor for class javax.xml.bind.annotation.adapters.NormalizedStringAdapter
normalizeMimeType(String) - Method in class java.awt.datatransfer.DataFlavor
Deprecated.
normalizeMimeType(String) - Method in class javax.activation.ActivationDataFlavor
Deprecated.
normalizeMimeTypeParameter(String, String) - Method in class java.awt.datatransfer.DataFlavor
Deprecated.
normalizeMimeTypeParameter(String, String) - Method in class javax.activation.ActivationDataFlavor
Deprecated.
Normalizer - Class in java.text
This class provides the method normalize which transforms Unicode text into an equivalent composed or decomposed form, allowing for easier sorting and searching of text.
Normalizer.Form - Enum in java.text
This enum provides constants of the four Unicode normalization forms that are described in Unicode Standard Annex #15 — Unicode Normalization Forms and two methods to access them.
normalizeTabRuns(int, int, int, int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout
normalizeTabRuns(int, int, int, int) - Method in class javax.swing.plaf.metal.MetalTabbedPaneUI.TabbedPaneLayout
normalizeWith(Calendar) - Method in class javax.xml.datatype.Duration
Converts the years and months fields into the days field by using a specific time instant as the reference point.
NoRouteToHostException - Exception in java.net
Signals that an error occurred while attempting to connect a socket to a remote address and port.
NoRouteToHostException(String) - Constructor for exception java.net.NoRouteToHostException
Constructs a new NoRouteToHostException with the specified detail message as to why the remote host cannot be reached.
NoRouteToHostException() - Constructor for exception java.net.NoRouteToHostException
Construct a new NoRouteToHostException with no detailed message.
NORTH - Static variable in class java.awt.BorderLayout
The north layout constraint (top of container).
NORTH - Static variable in class java.awt.GridBagConstraints
Put the component at the top of its display area, centered horizontally.
NORTH - Static variable in class javax.swing.SpringLayout
Specifies the top edge of a component's bounding rectangle.
NORTH - Static variable in interface javax.swing.SwingConstants
Compass-direction North (up).
NORTH_EAST - Static variable in interface javax.swing.SwingConstants
Compass-direction north-east (upper right).
NORTH_WEST - Static variable in interface javax.swing.SwingConstants
Compass-direction north west (upper left).
NORTHEAST - Static variable in class java.awt.GridBagConstraints
Put the component at the top-right corner of its display area.
northPane - Variable in class javax.swing.plaf.basic.BasicInternalFrameUI
NORTHWEST - Static variable in class java.awt.GridBagConstraints
Put the component at the top-left corner of its display area.
NoServant - Exception in org.omg.PortableServer.POAPackage
org/omg/PortableServer/POAPackage/NoServant.java .
NoServant() - Constructor for exception org.omg.PortableServer.POAPackage.NoServant
NoServant(String) - Constructor for exception org.omg.PortableServer.POAPackage.NoServant
NoServantHelper - Class in org.omg.PortableServer.POAPackage
org/omg/PortableServer/POAPackage/NoServantHelper.java .
NoServantHelper() - Constructor for class org.omg.PortableServer.POAPackage.NoServantHelper
NOSHADE - Static variable in class javax.swing.text.html.HTML.Attribute
NoSuchAlgorithmException - Exception in java.security
This exception is thrown when a particular cryptographic algorithm is requested but is not available in the environment.
NoSuchAlgorithmException() - Constructor for exception java.security.NoSuchAlgorithmException
Constructs a NoSuchAlgorithmException with no detail message.
NoSuchAlgorithmException(String) - Constructor for exception java.security.NoSuchAlgorithmException
Constructs a NoSuchAlgorithmException with the specified detail message.
NoSuchAlgorithmException(String, Throwable) - Constructor for exception java.security.NoSuchAlgorithmException
Creates a NoSuchAlgorithmException with the specified detail message and cause.
NoSuchAlgorithmException(Throwable) - Constructor for exception java.security.NoSuchAlgorithmException
Creates a NoSuchAlgorithmException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
NoSuchAttributeException - Exception in javax.naming.directory
This exception is thrown when attempting to access an attribute that does not exist.
NoSuchAttributeException(String) - Constructor for exception javax.naming.directory.NoSuchAttributeException
Constructs a new instance of NoSuchAttributeException using an explanation.
NoSuchAttributeException() - Constructor for exception javax.naming.directory.NoSuchAttributeException
Constructs a new instance of NoSuchAttributeException.
NoSuchElementException - Exception in java.util
Thrown by various accessor methods to indicate that the element being requested does not exist.
NoSuchElementException() - Constructor for exception java.util.NoSuchElementException
Constructs a NoSuchElementException with null as its error message string.
NoSuchElementException(String) - Constructor for exception java.util.NoSuchElementException
Constructs a NoSuchElementException, saving a reference to the error message string s for later retrieval by the getMessage method.
NoSuchFieldError - Error in java.lang
Thrown if an application tries to access or modify a specified field of an object, and that object no longer has that field.
NoSuchFieldError() - Constructor for error java.lang.NoSuchFieldError
Constructs a NoSuchFieldError with no detail message.
NoSuchFieldError(String) - Constructor for error java.lang.NoSuchFieldError
Constructs a NoSuchFieldError with the specified detail message.
NoSuchFieldException - Exception in java.lang
Signals that the class doesn't have a field of a specified name.
NoSuchFieldException() - Constructor for exception java.lang.NoSuchFieldException
Constructor.
NoSuchFieldException(String) - Constructor for exception java.lang.NoSuchFieldException
Constructor with a detail message.
NoSuchFileException - Exception in java.nio.file
Checked exception thrown when an attempt is made to access a file that does not exist.
NoSuchFileException(String) - Constructor for exception java.nio.file.NoSuchFileException
Constructs an instance of this class.
NoSuchFileException(String, String, String) - Constructor for exception java.nio.file.NoSuchFileException
Constructs an instance of this class.
NoSuchMechanismException - Exception in javax.xml.crypto
This exception is thrown when a particular XML mechanism is requested but is not available in the environment.
NoSuchMechanismException() - Constructor for exception javax.xml.crypto.NoSuchMechanismException
Constructs a new NoSuchMechanismException with null as its detail message.
NoSuchMechanismException(String) - Constructor for exception javax.xml.crypto.NoSuchMechanismException
Constructs a new NoSuchMechanismException with the specified detail message.
NoSuchMechanismException(String, Throwable) - Constructor for exception javax.xml.crypto.NoSuchMechanismException
Constructs a new NoSuchMechanismException with the specified detail message and cause.
NoSuchMechanismException(Throwable) - Constructor for exception javax.xml.crypto.NoSuchMechanismException
Constructs a new NoSuchMechanismException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
NoSuchMethodError - Error in java.lang
Thrown if an application tries to call a specified method of a class (either static or instance), and that class no longer has a definition of that method.
NoSuchMethodError() - Constructor for error java.lang.NoSuchMethodError
Constructs a NoSuchMethodError with no detail message.
NoSuchMethodError(String) - Constructor for error java.lang.NoSuchMethodError
Constructs a NoSuchMethodError with the specified detail message.
NoSuchMethodException - Exception in java.lang
Thrown when a particular method cannot be found.
NoSuchMethodException() - Constructor for exception java.lang.NoSuchMethodException
Constructs a NoSuchMethodException without a detail message.
NoSuchMethodException(String) - Constructor for exception java.lang.NoSuchMethodException
Constructs a NoSuchMethodException with a detail message.
NoSuchObjectException - Exception in java.rmi
A NoSuchObjectException is thrown if an attempt is made to invoke a method on an object that no longer exists in the remote virtual machine.
NoSuchObjectException(String) - Constructor for exception java.rmi.NoSuchObjectException
Constructs a NoSuchObjectException with the specified detail message.
NoSuchPaddingException - Exception in javax.crypto
This exception is thrown when a particular padding mechanism is requested but is not available in the environment.
NoSuchPaddingException() - Constructor for exception javax.crypto.NoSuchPaddingException
Constructs a NoSuchPaddingException with no detail message.
NoSuchPaddingException(String) - Constructor for exception javax.crypto.NoSuchPaddingException
Constructs a NoSuchPaddingException with the specified detail message.
NoSuchProviderException - Exception in java.security
This exception is thrown when a particular security provider is requested but is not available in the environment.
NoSuchProviderException() - Constructor for exception java.security.NoSuchProviderException
Constructs a NoSuchProviderException with no detail message.
NoSuchProviderException(String) - Constructor for exception java.security.NoSuchProviderException
Constructs a NoSuchProviderException with the specified detail message.
not() - Method in class java.math.BigInteger
Returns a BigInteger whose value is (~this).
not(QueryExp) - Static method in class javax.management.Query
Returns a constraint that is the negation of its argument.
NOT_ACCEPTING_JOBS - Static variable in class javax.print.attribute.standard.PrinterIsAcceptingJobs
The printer is currently rejecting any jobs sent to it.
NOT_ATTEMPTED - Static variable in class javax.print.attribute.standard.PDLOverrideSupported
The printer makes no attempt to make the external job attribute values take precedence over embedded instructions in the documents' print data.
not_context - Static variable in class org.omg.CosNaming.NamingContextPackage.NotFoundReason
NOT_FOUND_ERR - Static variable in exception org.w3c.dom.DOMException
If an attempt is made to reference a Node in a context where it does not exist.
not_object - Static variable in class org.omg.CosNaming.NamingContextPackage.NotFoundReason
NOT_SPECIFIED - Static variable in class javax.sound.sampled.AudioSystem
An integer that stands for an unknown numeric value.
NOT_SUPPORTED - Static variable in class javax.print.attribute.standard.ColorSupported
The printer is not capable of any type of color printing.
NOT_SUPPORTED_ERR - Static variable in exception org.w3c.dom.DOMException
If the implementation does not support the requested type of object or operation.
NotActiveException - Exception in java.io
Thrown when serialization or deserialization is not active.
NotActiveException(String) - Constructor for exception java.io.NotActiveException
Constructor to create a new NotActiveException with the reason given.
NotActiveException() - Constructor for exception java.io.NotActiveException
Constructor to create a new NotActiveException without a reason.
NOTATION - Static variable in interface javax.swing.text.html.parser.DTDConstants
Notation - Interface in org.w3c.dom
This interface represents a notation declared in the DTD.
NOTATION_DECLARATION - Static variable in interface javax.xml.stream.XMLStreamConstants
Indicates a Notation
NOTATION_NODE - Static variable in interface org.w3c.dom.Node
The node is a Notation.
notationDecl(String, String, String) - Method in interface org.xml.sax.DTDHandler
Receive notification of a notation declaration event.
notationDecl(String, String, String) - Method in class org.xml.sax.HandlerBase
Deprecated.
Receive notification of a notation declaration.
notationDecl(String, String, String) - Method in class org.xml.sax.helpers.DefaultHandler
Receive notification of a notation declaration.
notationDecl(String, String, String) - Method in class org.xml.sax.helpers.XMLFilterImpl
Filter a notation declaration event.
NotationDeclaration - Interface in javax.xml.stream.events
An interface for handling Notation Declarations Receive notification of a notation declaration event.
NotBoundException - Exception in java.rmi
A NotBoundException is thrown if an attempt is made to lookup or unbind in the registry a name that has no associated binding.
NotBoundException() - Constructor for exception java.rmi.NotBoundException
Constructs a NotBoundException with no specified detail message.
NotBoundException(String) - Constructor for exception java.rmi.NotBoundException
Constructs a NotBoundException with the specified detail message.
NotCompliantMBeanException - Exception in javax.management
Exception which occurs when trying to register an object in the MBean server that is not a JMX compliant MBean.
NotCompliantMBeanException() - Constructor for exception javax.management.NotCompliantMBeanException
Default constructor.
NotCompliantMBeanException(String) - Constructor for exception javax.management.NotCompliantMBeanException
Constructor that allows a specific error message to be specified.
NotContextException - Exception in javax.naming
This exception is thrown when a naming operation proceeds to a point where a context is required to continue the operation, but the resolved object is not a context.
NotContextException(String) - Constructor for exception javax.naming.NotContextException
Constructs a new instance of NotContextException using an explanation.
NotContextException() - Constructor for exception javax.naming.NotContextException
Constructs a new instance of NotContextException.
NotDirectoryException - Exception in java.nio.file
Checked exception thrown when a file system operation, intended for a directory, fails because the file is not a directory.
NotDirectoryException(String) - Constructor for exception java.nio.file.NotDirectoryException
Constructs an instance of this class.
NOTE - Static variable in class java.awt.PageAttributes.MediaType
An alias for NA_LETTER.
note - Variable in class javax.sound.midi.VoiceStatus
The MIDI note that this voice is playing.
NOTE_OFF - Static variable in class javax.sound.midi.ShortMessage
Command value for Note Off message (0x80, or 128)
NOTE_ON - Static variable in class javax.sound.midi.ShortMessage
Command value for Note On message (0x90, or 144)
NotEmpty - Exception in org.omg.CosNaming.NamingContextPackage
org/omg/CosNaming/NamingContextPackage/NotEmpty.java .
NotEmpty() - Constructor for exception org.omg.CosNaming.NamingContextPackage.NotEmpty
NotEmpty(String) - Constructor for exception org.omg.CosNaming.NamingContextPackage.NotEmpty
NotEmptyHelper - Class in org.omg.CosNaming.NamingContextPackage
org/omg/CosNaming/NamingContextPackage/NotEmptyHelper.java .
NotEmptyHelper() - Constructor for class org.omg.CosNaming.NamingContextPackage.NotEmptyHelper
NotEmptyHolder - Class in org.omg.CosNaming.NamingContextPackage
org/omg/CosNaming/NamingContextPackage/NotEmptyHolder.java .
NotEmptyHolder() - Constructor for class org.omg.CosNaming.NamingContextPackage.NotEmptyHolder
NotEmptyHolder(NotEmpty) - Constructor for class org.omg.CosNaming.NamingContextPackage.NotEmptyHolder
noteOff(int, int) - Method in interface javax.sound.midi.MidiChannel
Turns the specified note off.
noteOff(int) - Method in interface javax.sound.midi.MidiChannel
Turns the specified note off.
noteOn(int, int) - Method in interface javax.sound.midi.MidiChannel
Starts the specified note sounding.
notExists(Path, LinkOption...) - Static method in class java.nio.file.Files
Tests whether the file located by this path does not exist.
notFilter(RowFilter<M, I>) - Static method in class javax.swing.RowFilter
Returns a RowFilter that includes entries if the supplied filter does not include the entry.
NotFound - Exception in org.omg.CosNaming.NamingContextPackage
org/omg/CosNaming/NamingContextPackage/NotFound.java .
NotFound() - Constructor for exception org.omg.CosNaming.NamingContextPackage.NotFound
NotFound(NotFoundReason, NameComponent[]) - Constructor for exception org.omg.CosNaming.NamingContextPackage.NotFound
NotFound(String, NotFoundReason, NameComponent[]) - Constructor for exception org.omg.CosNaming.NamingContextPackage.NotFound
NotFoundHelper - Class in org.omg.CosNaming.NamingContextPackage
org/omg/CosNaming/NamingContextPackage/NotFoundHelper.java .
NotFoundHelper() - Constructor for class org.omg.CosNaming.NamingContextPackage.NotFoundHelper
NotFoundHolder - Class in org.omg.CosNaming.NamingContextPackage
org/omg/CosNaming/NamingContextPackage/NotFoundHolder.java .
NotFoundHolder() - Constructor for class org.omg.CosNaming.NamingContextPackage.NotFoundHolder
NotFoundHolder(NotFound) - Constructor for class org.omg.CosNaming.NamingContextPackage.NotFoundHolder
NotFoundReason - Class in org.omg.CosNaming.NamingContextPackage
Indicates the reason for not able to resolve.
NotFoundReason(int) - Constructor for class org.omg.CosNaming.NamingContextPackage.NotFoundReason
NotFoundReasonHelper - Class in org.omg.CosNaming.NamingContextPackage
Indicates the reason for not able to resolve.
NotFoundReasonHelper() - Constructor for class org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper
NotFoundReasonHolder - Class in org.omg.CosNaming.NamingContextPackage
Indicates the reason for not able to resolve.
NotFoundReasonHolder() - Constructor for class org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder
NotFoundReasonHolder(NotFoundReason) - Constructor for class org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder
NotIdentifiableEvent - Interface in javax.xml.bind
This event indicates that a problem was encountered resolving an ID/IDREF.
NotIdentifiableEventImpl - Class in javax.xml.bind.helpers
Default implementation of the NotIdentifiableEvent interface.
NotIdentifiableEventImpl(int, String, ValidationEventLocator) - Constructor for class javax.xml.bind.helpers.NotIdentifiableEventImpl
Create a new NotIdentifiableEventImpl.
NotIdentifiableEventImpl(int, String, ValidationEventLocator, Throwable) - Constructor for class javax.xml.bind.helpers.NotIdentifiableEventImpl
Create a new NotIdentifiableEventImpl.
Notification - Class in javax.management
The Notification class represents a notification emitted by an MBean.
Notification(String, Object, long) - Constructor for class javax.management.Notification
Creates a Notification object.
Notification(String, Object, long, String) - Constructor for class javax.management.Notification
Creates a Notification object.
Notification(String, Object, long, long) - Constructor for class javax.management.Notification
Creates a Notification object.
Notification(String, Object, long, long, String) - Constructor for class javax.management.Notification
Creates a Notification object.
NotificationBroadcaster - Interface in javax.management
Interface implemented by an MBean that emits Notifications.
NotificationBroadcasterSupport - Class in javax.management
Provides an implementation of NotificationEmitter interface.
NotificationBroadcasterSupport() - Constructor for class javax.management.NotificationBroadcasterSupport
Constructs a NotificationBroadcasterSupport where each listener is invoked by the thread sending the notification.
NotificationBroadcasterSupport(Executor) - Constructor for class javax.management.NotificationBroadcasterSupport
Constructs a NotificationBroadcasterSupport where each listener is invoked using the given Executor.
NotificationBroadcasterSupport(MBeanNotificationInfo...) - Constructor for class javax.management.NotificationBroadcasterSupport
Constructs a NotificationBroadcasterSupport with information about the notifications that may be sent.
NotificationBroadcasterSupport(Executor, MBeanNotificationInfo...) - Constructor for class javax.management.NotificationBroadcasterSupport
Constructs a NotificationBroadcasterSupport with information about the notifications that may be sent, and where each listener is invoked using the given Executor.
NotificationEmitter - Interface in javax.management
Interface implemented by an MBean that emits Notifications.
NotificationFilter - Interface in javax.management
To be implemented by a any class acting as a notification filter.
NotificationFilterSupport - Class in javax.management
Provides an implementation of the NotificationFilter interface.
NotificationFilterSupport() - Constructor for class javax.management.NotificationFilterSupport
NotificationListener - Interface in javax.management
Should be implemented by an object that wants to receive notifications.
notificationReceived(UnsolicitedNotificationEvent) - Method in interface javax.naming.ldap.UnsolicitedNotificationListener
Called when an unsolicited notification has been received.
NotificationResult - Class in javax.management.remote
Result of a query for buffered notifications.
NotificationResult(long, long, TargetedNotification[]) - Constructor for class javax.management.remote.NotificationResult
Constructs a notification query result.
notifier - Variable in class java.awt.event.InvocationEvent
The (potentially null) Object whose notifyAll() method will be called immediately after the Runnable.run() method has returned or thrown an exception or after the event was disposed.
NOTIFS_LOST - Static variable in class javax.management.remote.JMXConnectionNotification
Notification type string for a connection that has possibly lost notifications.
notify() - Method in class java.lang.Object
Wakes up a single thread that is waiting on this object's monitor.
notifyAction - Static variable in class javax.swing.JTextField
Name of the action to send notification that the contents of the field have been accepted.
notifyAction(Action, KeyStroke, KeyEvent, Object, int) - Static method in class javax.swing.SwingUtilities
Invokes actionPerformed on action if action is enabled (and non-null).
notifyAll() - Method in class java.lang.Object
Wakes up all threads that are waiting on this object's monitor.
notifyClientWindowChange(Rectangle) - Method in interface java.awt.im.spi.InputMethod
Notifies this input method of changes in the client window location or state.
notifyCursorMoved() - Method in class javax.sql.rowset.BaseRowSet
Notifies all of the listeners registered with this RowSet object that its cursor has moved.
notifyObservers() - Method in class java.util.Observable
If this object has changed, as indicated by the hasChanged method, then notify all of its observers and then call the clearChanged method to indicate that this object has no longer changed.
notifyObservers(Object) - Method in class java.util.Observable
If this object has changed, as indicated by the hasChanged method, then notify all of its observers and then call the clearChanged method to indicate that this object has no longer changed.
notifyPathChange(Vector<?>, TreePath) - Method in class javax.swing.tree.DefaultTreeSelectionModel
Deprecated.
As of JDK version 1.7
notifyRowChanged() - Method in class javax.sql.rowset.BaseRowSet
Notifies all of the listeners registered with this RowSet object that one of its rows has changed.
notifyRowSetChanged() - Method in class javax.sql.rowset.BaseRowSet
Notifies all of the listeners registered with this RowSet object that its entire contents have changed.
NotLinkException - Exception in java.nio.file
Checked exception thrown when a file system operation fails because a file is not a symbolic link.
NotLinkException(String) - Constructor for exception java.nio.file.NotLinkException
Constructs an instance of this class.
NotLinkException(String, String, String) - Constructor for exception java.nio.file.NotLinkException
Constructs an instance of this class.
NotOwnerException - Exception in java.security.acl
This is an exception that is thrown whenever the modification of an object (such as an Access Control List) is only allowed to be done by an owner of the object, but the Principal attempting the modification is not an owner.
NotOwnerException() - Constructor for exception java.security.acl.NotOwnerException
Constructs a NotOwnerException.
notSelectedTextColor - Variable in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
notSelectedTitleColor - Variable in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
NotSerializableException - Exception in java.io
Thrown when an instance is required to have a Serializable interface.
NotSerializableException(String) - Constructor for exception java.io.NotSerializableException
Constructs a NotSerializableException object with message string.
NotSerializableException() - Constructor for exception java.io.NotSerializableException
Constructs a NotSerializableException object.
NotYetBoundException - Exception in java.nio.channels
Unchecked exception thrown when an attempt is made to invoke an I/O operation upon a server socket channel that is not yet bound.
NotYetBoundException() - Constructor for exception java.nio.channels.NotYetBoundException
Constructs an instance of this class.
NotYetConnectedException - Exception in java.nio.channels
Unchecked exception thrown when an attempt is made to invoke an I/O operation upon a socket channel that is not yet connected.
NotYetConnectedException() - Constructor for exception java.nio.channels.NotYetConnectedException
Constructs an instance of this class.
NoType - Interface in javax.lang.model.type
A pseudo-type used where no actual type is appropriate.
NOVEMBER - Static variable in class java.util.Calendar
Value of the Calendar.MONTH field indicating the eleventh month of the year in the Gregorian and Julian calendars.
NOVEMBER - Static variable in class javax.xml.datatype.DatatypeConstants
Value for eleven month of year.
now() - Static method in class java.time.chrono.HijrahDate
Obtains the current HijrahDate of the Islamic Umm Al-Qura calendar in the default time-zone.
now(ZoneId) - Static method in class java.time.chrono.HijrahDate
Obtains the current HijrahDate of the Islamic Umm Al-Qura calendar in the specified time-zone.
now(Clock) - Static method in class java.time.chrono.HijrahDate
Obtains the current HijrahDate of the Islamic Umm Al-Qura calendar from the specified clock.
now() - Static method in class java.time.chrono.JapaneseDate
Obtains the current JapaneseDate from the system clock in the default time-zone.
now(ZoneId) - Static method in class java.time.chrono.JapaneseDate
Obtains the current JapaneseDate from the system clock in the specified time-zone.
now(Clock) - Static method in class java.time.chrono.JapaneseDate
Obtains the current JapaneseDate from the specified clock.
now() - Static method in class java.time.chrono.MinguoDate
Obtains the current MinguoDate from the system clock in the default time-zone.
now(ZoneId) - Static method in class java.time.chrono.MinguoDate
Obtains the current MinguoDate from the system clock in the specified time-zone.
now(Clock) - Static method in class java.time.chrono.MinguoDate
Obtains the current MinguoDate from the specified clock.
now() - Static method in class java.time.chrono.ThaiBuddhistDate
Obtains the current ThaiBuddhistDate from the system clock in the default time-zone.
now(ZoneId) - Static method in class java.time.chrono.ThaiBuddhistDate
Obtains the current ThaiBuddhistDate from the system clock in the specified time-zone.
now(Clock) - Static method in class java.time.chrono.ThaiBuddhistDate
Obtains the current ThaiBuddhistDate from the specified clock.
now() - Static method in class java.time.Instant
Obtains the current instant from the system clock.
now(Clock) - Static method in class java.time.Instant
Obtains the current instant from the specified clock.
now() - Static method in class java.time.LocalDate
Obtains the current date from the system clock in the default time-zone.
now(ZoneId) - Static method in class java.time.LocalDate
Obtains the current date from the system clock in the specified time-zone.
now(Clock) - Static method in class java.time.LocalDate
Obtains the current date from the specified clock.
now() - Static method in class java.time.LocalDateTime
Obtains the current date-time from the system clock in the default time-zone.
now(ZoneId) - Static method in class java.time.LocalDateTime
Obtains the current date-time from the system clock in the specified time-zone.
now(Clock) - Static method in class java.time.LocalDateTime
Obtains the current date-time from the specified clock.
now() - Static method in class java.time.LocalTime
Obtains the current time from the system clock in the default time-zone.
now(ZoneId) - Static method in class java.time.LocalTime
Obtains the current time from the system clock in the specified time-zone.
now(Clock) - Static method in class java.time.LocalTime
Obtains the current time from the specified clock.
now() - Static method in class java.time.MonthDay
Obtains the current month-day from the system clock in the default time-zone.
now(ZoneId) - Static method in class java.time.MonthDay
Obtains the current month-day from the system clock in the specified time-zone.
now(Clock) - Static method in class java.time.MonthDay
Obtains the current month-day from the specified clock.
now() - Static method in class java.time.OffsetDateTime
Obtains the current date-time from the system clock in the default time-zone.
now(ZoneId) - Static method in class java.time.OffsetDateTime
Obtains the current date-time from the system clock in the specified time-zone.
now(Clock) - Static method in class java.time.OffsetDateTime
Obtains the current date-time from the specified clock.
now() - Static method in class java.time.OffsetTime
Obtains the current time from the system clock in the default time-zone.
now(ZoneId) - Static method in class java.time.OffsetTime
Obtains the current time from the system clock in the specified time-zone.
now(Clock) - Static method in class java.time.OffsetTime
Obtains the current time from the specified clock.
now() - Static method in class java.time.Year
Obtains the current year from the system clock in the default time-zone.
now(ZoneId) - Static method in class java.time.Year
Obtains the current year from the system clock in the specified time-zone.
now(Clock) - Static method in class java.time.Year
Obtains the current year from the specified clock.
now() - Static method in class java.time.YearMonth
Obtains the current year-month from the system clock in the default time-zone.
now(ZoneId) - Static method in class java.time.YearMonth
Obtains the current year-month from the system clock in the specified time-zone.
now(Clock) - Static method in class java.time.YearMonth
Obtains the current year-month from the specified clock.
now() - Static method in class java.time.ZonedDateTime
Obtains the current date-time from the system clock in the default time-zone.
now(ZoneId) - Static method in class java.time.ZonedDateTime
Obtains the current date-time from the system clock in the specified time-zone.
now(Clock) - Static method in class java.time.ZonedDateTime
Obtains the current date-time from the specified clock.
NOWRAP - Static variable in class javax.swing.text.html.HTML.Attribute
npoints - Variable in class java.awt.Polygon
The total number of points.
NS - Static variable in class javax.xml.ws.wsaddressing.W3CEndpointReference
NSDECL - Static variable in class org.xml.sax.helpers.NamespaceSupport
The namespace declaration URI as a constant.
NT_ANONYMOUS - Static variable in interface org.ietf.jgss.GSSName
Name type for representing an anonymous entity.
NT_EXPORT_NAME - Static variable in interface org.ietf.jgss.GSSName
Name type used to indicate an exported name produced by the export method.
NT_HOSTBASED_SERVICE - Static variable in interface org.ietf.jgss.GSSName
Oid indicating a host-based service name form.
NT_MACHINE_UID_NAME - Static variable in interface org.ietf.jgss.GSSName
Name type to indicate a numeric user identifier corresponding to a user on a local system.
NT_STRING_UID_NAME - Static variable in interface org.ietf.jgss.GSSName
Name type to indicate a string of digits representing the numeric user identifier of a user on a local system.
NT_USER_NAME - Static variable in interface org.ietf.jgss.GSSName
Name type to indicate a named user on a local system.
NULL - Static variable in class java.sql.Types
The constant in the Java programming language that identifies the generic SQL value NULL.
NULL_ATTRIBUTE_VALUE - Static variable in class javax.swing.text.html.HTML
NULL_NS_URI - Static variable in class javax.xml.XMLConstants
Namespace URI to use to represent that there is no Namespace.
NullCipher - Class in javax.crypto
The NullCipher class is a class that provides an "identity cipher" -- one that does not transform the plain text.
NullCipher() - Constructor for class javax.crypto.NullCipher
Creates a NullCipher object.
NULLORDER - Static variable in class java.text.CollationElementIterator
Null order which indicates the end of string is reached by the cursor.
nullPlusNonNullIsNull() - Method in interface java.sql.DatabaseMetaData
Retrieves whether this database supports concatenations between NULL and non-NULL values being NULL.
NullPointerException - Exception in java.lang
Thrown when an application attempts to use null in a case where an object is required.
NullPointerException() - Constructor for exception java.lang.NullPointerException
Constructs a NullPointerException with no detail message.
NullPointerException(String) - Constructor for exception java.lang.NullPointerException
Constructs a NullPointerException with the specified detail message.
nullsAreSortedAtEnd() - Method in interface java.sql.DatabaseMetaData
Retrieves whether NULL values are sorted at the end regardless of sort order.
nullsAreSortedAtStart() - Method in interface java.sql.DatabaseMetaData
Retrieves whether NULL values are sorted at the start regardless of sort order.
nullsAreSortedHigh() - Method in interface java.sql.DatabaseMetaData
Retrieves whether NULL values are sorted high.
nullsAreSortedLow() - Method in interface java.sql.DatabaseMetaData
Retrieves whether NULL values are sorted low.
nullsFirst(Comparator<? super T>) - Static method in interface java.util.Comparator
Returns a null-friendly comparator that considers null to be less than non-null.
nullsLast(Comparator<? super T>) - Static method in interface java.util.Comparator
Returns a null-friendly comparator that considers null to be greater than non-null.
NullType - Interface in javax.lang.model.type
Represents the null type.
NUM_COLORS - Static variable in class java.awt.SystemColor
The number of system colors in the array.
NUM_LOCK - Static variable in class java.awt.Event
The Num Lock key, a non-ASCII action key.
numBands - Variable in class java.awt.image.ComponentSampleModel
The number of bands in this ComponentSampleModel.
numBands - Variable in class java.awt.image.Raster
The number of bands in the Raster.
numBands - Variable in class java.awt.image.SampleModel
Number of bands of the image data that this SampleModel describes.
numBanks - Variable in class java.awt.image.ComponentSampleModel
The number of banks in this ComponentSampleModel.
Number - Class in java.lang
The abstract class Number is the superclass of platform classes representing numeric values that are convertible to the primitive types byte, double, float, int, long, and short.
Number() - Constructor for class java.lang.Number
NUMBER - Static variable in interface javax.swing.text.html.parser.DTDConstants
NUMBER - Static variable in class javax.xml.xpath.XPathConstants
The XPath 1.0 number data type.
NUMBER_FORMS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Number Forms" Unicode character block.
NumberEditor(JSpinner) - Constructor for class javax.swing.JSpinner.NumberEditor
Construct a JSpinner editor that supports displaying and editing the value of a SpinnerNumberModel with a JFormattedTextField.
NumberEditor(JSpinner, String) - Constructor for class javax.swing.JSpinner.NumberEditor
Construct a JSpinner editor that supports displaying and editing the value of a SpinnerNumberModel with a JFormattedTextField.
numberFilter(RowFilter.ComparisonType, Number, int...) - Static method in class javax.swing.RowFilter
Returns a RowFilter that includes entries that have at least one Number value meeting the specified criteria.
numberFormat - Variable in class java.text.DateFormat
The number formatter that DateFormat uses to format numbers in dates and times.
NumberFormat - Class in java.text
NumberFormat is the abstract base class for all number formats.
NumberFormat() - Constructor for class java.text.NumberFormat
Sole constructor.
NumberFormat.Field - Class in java.text
Defines constants that are used as attribute keys in the AttributedCharacterIterator returned from NumberFormat.formatToCharacterIterator and as field identifiers in FieldPosition.
NumberFormatException - Exception in java.lang
Thrown to indicate that the application has attempted to convert a string to one of the numeric types, but that the string does not have the appropriate format.
NumberFormatException() - Constructor for exception java.lang.NumberFormatException
Constructs a NumberFormatException with no detail message.
NumberFormatException(String) - Constructor for exception java.lang.NumberFormatException
Constructs a NumberFormatException with the specified detail message.
NumberFormatProvider - Class in java.text.spi
An abstract class for service providers that provide concrete implementations of the NumberFormat class.
NumberFormatProvider() - Constructor for class java.text.spi.NumberFormatProvider
Sole constructor.
NumberFormatter - Class in javax.swing.text
NumberFormatter subclasses InternationalFormatter adding special behavior for numbers.
NumberFormatter() - Constructor for class javax.swing.text.NumberFormatter
Creates a NumberFormatter with the a default NumberFormat instance obtained from NumberFormat.getNumberInstance().
NumberFormatter(NumberFormat) - Constructor for class javax.swing.text.NumberFormatter
Creates a NumberFormatter with the specified Format instance.
NumberOfDocuments - Class in javax.print.attribute.standard
Class NumberOfDocuments is an integer valued printing attribute that indicates the number of individual docs the printer has accepted for this job, regardless of whether the docs' print data has reached the printer or not.
NumberOfDocuments(int) - Constructor for class javax.print.attribute.standard.NumberOfDocuments
Construct a new number of documents attribute with the given integer value.
NumberOfInterveningJobs - Class in javax.print.attribute.standard
Class NumberOfInterveningJobs is an integer valued printing attribute that indicates the number of jobs that are ahead of this job in the relative chronological order of expected time to complete (i.e., the current scheduled order).
NumberOfInterveningJobs(int) - Constructor for class javax.print.attribute.standard.NumberOfInterveningJobs
Construct a new number of intervening jobs attribute with the given integer value.
numberOfLeadingZeros(int) - Static method in class java.lang.Integer
Returns the number of zero bits preceding the highest-order ("leftmost") one-bit in the two's complement binary representation of the specified int value.
numberOfLeadingZeros(long) - Static method in class java.lang.Long
Returns the number of zero bits preceding the highest-order ("leftmost") one-bit in the two's complement binary representation of the specified long value.
numberOfTrailingZeros(int) - Static method in class java.lang.Integer
Returns the number of zero bits following the lowest-order ("rightmost") one-bit in the two's complement binary representation of the specified int value.
numberOfTrailingZeros(long) - Static method in class java.lang.Long
Returns the number of zero bits following the lowest-order ("rightmost") one-bit in the two's complement binary representation of the specified long value.
NUMBERS - Static variable in interface javax.swing.text.html.parser.DTDConstants
NumberUp - Class in javax.print.attribute.standard
Class NumberUp is an integer valued printing attribute class that specifies the number of print-stream pages to impose upon a single side of an instance of a selected medium.
NumberUp(int) - Constructor for class javax.print.attribute.standard.NumberUp
Construct a new number up attribute with the given integer value.
NumberUpSupported - Class in javax.print.attribute.standard
Class NumberUpSupported is a printing attribute class, a set of integers, that gives the supported values for a NumberUp attribute.
NumberUpSupported(int[][]) - Constructor for class javax.print.attribute.standard.NumberUpSupported
Construct a new number up supported attribute with the given members.
NumberUpSupported(int) - Constructor for class javax.print.attribute.standard.NumberUpSupported
Construct a new number up supported attribute containing a single integer.
NumberUpSupported(int, int) - Constructor for class javax.print.attribute.standard.NumberUpSupported
Construct a new number up supported attribute containing a single range of integers.
numBuffers - Variable in class java.awt.Component.FlipBufferStrategy
The number of buffers
numDataElements - Variable in class java.awt.image.Raster
The number of DataBuffer data elements per pixel.
NUMERIC - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type NUMERIC.
NUMERIC_SHAPING - Static variable in class java.awt.font.TextAttribute
Attribute key for converting ASCII decimal digits to other decimal ranges.
NumericShaper - Class in java.awt.font
The NumericShaper class is used to convert Latin-1 (European) digits to other Unicode decimal digits.
NumericShaper.Range - Enum in java.awt.font
A NumericShaper.Range represents a Unicode range of a script having its own decimal digits.
numProgressivePasses - Variable in class javax.imageio.ImageReadParam
The maximum number of progressive passes to read from the source.
NUTOKEN - Static variable in interface javax.swing.text.html.parser.DTDConstants
NUTOKENS - Static variable in interface javax.swing.text.html.parser.DTDConstants
nval - Variable in class java.io.StreamTokenizer
If the current token is a number, this field contains the value of that number.
NVARCHAR - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type NVARCHAR.
NVList - Class in org.omg.CORBA
A modifiable list containing NamedValue objects.
NVList() - Constructor for class org.omg.CORBA.NVList
NW_RESIZE_CURSOR - Static variable in class java.awt.Cursor
The north-west-resize cursor type.
NW_RESIZE_CURSOR - Static variable in class java.awt.Frame
Deprecated.
replaced by Cursor.NW_RESIZE_CURSOR.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames


O-Index (Java Platform SE 8 )

Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames
  • All Classes
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

O

OAEPParameterSpec - Class in javax.crypto.spec
This class specifies the set of parameters used with OAEP Padding, as defined in the PKCS #1 standard.
OAEPParameterSpec(String, String, AlgorithmParameterSpec, PSource) - Constructor for class javax.crypto.spec.OAEPParameterSpec
Constructs a parameter set for OAEP padding as defined in the PKCS #1 standard using the specified message digest algorithm mdName, mask generation function algorithm mgfName, parameters for the mask generation function mgfSpec, and source of the encoding input P pSrc.
OBJ_ADAPTER - Exception in org.omg.CORBA
This exception typically indicates an administrative mismatch, for example, a server may have made an attempt to register itself with an implementation repository under a name that is already in use, or is unknown to the repository.
OBJ_ADAPTER() - Constructor for exception org.omg.CORBA.OBJ_ADAPTER
Constructs an OBJ_ADAPTER exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
OBJ_ADAPTER(String) - Constructor for exception org.omg.CORBA.OBJ_ADAPTER
Constructs an OBJ_ADAPTER exception with the specified description, a minor code of 0, and a completion state of COMPLETED_NO.
OBJ_ADAPTER(int, CompletionStatus) - Constructor for exception org.omg.CORBA.OBJ_ADAPTER
Constructs an OBJ_ADAPTER exception with the specified minor code and completion status.
OBJ_ADAPTER(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.OBJ_ADAPTER
Constructs an OBJ_ADAPTER exception with the specified description message, minor code, and completion status.
ObjDoubleConsumer<T> - Interface in java.util.function
Represents an operation that accepts an object-valued and a double-valued argument, and returns no result.
Object - Class in java.lang
Class Object is the root of the class hierarchy.
Object() - Constructor for class java.lang.Object
OBJECT - Static variable in class javax.swing.text.html.HTML.Tag
object - Variable in class javax.swing.undo.StateEdit
The object being edited
Object - Interface in org.omg.CORBA
The definition for a CORBA object reference.
OBJECT_ADDED - Static variable in class javax.naming.event.NamingEvent
Naming event type for indicating that a new object has been added.
OBJECT_CHANGED - Static variable in class javax.naming.event.NamingEvent
Naming event type for indicating that an object has been changed.
OBJECT_FACTORIES - Static variable in interface javax.naming.Context
Constant that holds the name of the environment property for specifying the list of object factories to use.
object_id() - Method in interface org.omg.PortableInterceptor.ServerRequestInfoOperations
Returns the opaque object_id describing the target of the operation invocation.
object_id(Servant) - Method in interface org.omg.PortableServer.portable.Delegate
The method _object_id() is equivalent to calling PortableServer::Current::get_object_id.
OBJECT_NOT_EXIST - Exception in org.omg.CORBA
Exception raised whenever an invocation on a deleted object was performed.
OBJECT_NOT_EXIST() - Constructor for exception org.omg.CORBA.OBJECT_NOT_EXIST
Constructs an OBJECT_NOT_EXIST exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
OBJECT_NOT_EXIST(String) - Constructor for exception org.omg.CORBA.OBJECT_NOT_EXIST
Constructs an OBJECT_NOT_EXIST exception with the specified description, a minor code of 0, and a completion state of COMPLETED_NO.
OBJECT_NOT_EXIST(int, CompletionStatus) - Constructor for exception org.omg.CORBA.OBJECT_NOT_EXIST
Constructs an OBJECT_NOT_EXIST exception with the specified minor code and completion status.
OBJECT_NOT_EXIST(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.OBJECT_NOT_EXIST
Constructs an OBJECT_NOT_EXIST exception with the specified description message, minor code, and completion status.
OBJECT_REMOVED - Static variable in class javax.naming.event.NamingEvent
Naming event type for indicating that an object has been removed.
OBJECT_RENAMED - Static variable in class javax.naming.event.NamingEvent
Naming event type for indicating that an object has been renamed.
OBJECT_SCOPE - Static variable in class javax.naming.directory.SearchControls
Search the named object.
OBJECT_SCOPE - Static variable in interface javax.naming.event.EventContext
Constant for expressing interest in events concerning the object named by the target.
object_to_string(Object) - Method in class org.omg.CORBA.ORB
Converts the given CORBA object reference to a string.
objectAdded(NamingEvent) - Method in interface javax.naming.event.NamespaceChangeListener
Called when an object has been added.
ObjectAlreadyActive - Exception in org.omg.PortableServer.POAPackage
org/omg/PortableServer/POAPackage/ObjectAlreadyActive.java .
ObjectAlreadyActive() - Constructor for exception org.omg.PortableServer.POAPackage.ObjectAlreadyActive
ObjectAlreadyActive(String) - Constructor for exception org.omg.PortableServer.POAPackage.ObjectAlreadyActive
ObjectAlreadyActiveHelper - Class in org.omg.PortableServer.POAPackage
org/omg/PortableServer/POAPackage/ObjectAlreadyActiveHelper.java .
ObjectAlreadyActiveHelper() - Constructor for class org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper
objectChanged(NamingEvent) - Method in interface javax.naming.event.ObjectChangeListener
Called when an object has been changed.
ObjectChangeListener - Interface in javax.naming.event
Specifies the method that a listener of a NamingEvent with event type of OBJECT_CHANGED must implement.
ObjectFactory - Interface in javax.naming.spi
This interface represents a factory for creating an object.
ObjectFactoryBuilder - Interface in javax.naming.spi
This interface represents a builder that creates object factories.
ObjectHelper - Class in org.omg.CORBA
ObjectHelper() - Constructor for class org.omg.CORBA.ObjectHelper
ObjectHolder - Class in org.omg.CORBA
The Holder for Object.
ObjectHolder() - Constructor for class org.omg.CORBA.ObjectHolder
Constructs a new ObjectHolder object with its value field initialized to null.
ObjectHolder(Object) - Constructor for class org.omg.CORBA.ObjectHolder
Constructs a new ObjectHolder object with its value field initialized to the given Object.
ObjectIdHelper - Class in org.omg.PortableInterceptor
Type of an object id.
ObjectIdHelper() - Constructor for class org.omg.PortableInterceptor.ObjectIdHelper
ObjectIdHelper - Class in org.omg.PortableInterceptor.ORBInitInfoPackage
Object id, represented as a String
ObjectIdHelper() - Constructor for class org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper
ObjectImpl - Class in org.omg.CORBA.portable
The common base class for all stub classes; provides default implementations of the org.omg.CORBA.Object methods.
ObjectImpl() - Constructor for class org.omg.CORBA.portable.ObjectImpl
ObjectImpl - Class in org.omg.CORBA_2_3.portable
ObjectImpl class is the base class for all stubs.
ObjectImpl() - Constructor for class org.omg.CORBA_2_3.portable.ObjectImpl
ObjectInput - Interface in java.io
ObjectInput extends the DataInput interface to include the reading of objects.
ObjectInputStream - Class in java.io
An ObjectInputStream deserializes primitive data and objects previously written using an ObjectOutputStream.
ObjectInputStream(InputStream) - Constructor for class java.io.ObjectInputStream
Creates an ObjectInputStream that reads from the specified InputStream.
ObjectInputStream() - Constructor for class java.io.ObjectInputStream
Provide a way for subclasses that are completely reimplementing ObjectInputStream to not have to allocate private data just used by this implementation of ObjectInputStream.
ObjectInputStream.GetField - Class in java.io
Provide access to the persistent fields read from the input stream.
ObjectInputValidation - Interface in java.io
Callback interface to allow validation of objects within a graph.
ObjectInstance - Class in javax.management
Used to represent the object name of an MBean and its class name.
ObjectInstance(String, String) - Constructor for class javax.management.ObjectInstance
Allows an object instance to be created given a string representation of an object name and the full class name, including the package name.
ObjectInstance(ObjectName, String) - Constructor for class javax.management.ObjectInstance
Allows an object instance to be created given an object name and the full class name, including the package name.
ObjectName - Class in javax.management
Represents the object name of an MBean, or a pattern that can match the names of several MBeans.
ObjectName(String) - Constructor for class javax.management.ObjectName
Construct an object name from the given string.
ObjectName(String, String, String) - Constructor for class javax.management.ObjectName
Construct an object name with exactly one key property.
ObjectName(String, Hashtable<String, String>) - Constructor for class javax.management.ObjectName
Construct an object name with several key properties from a Hashtable.
OBJECTNAME - Static variable in class javax.management.openmbean.SimpleType
The SimpleType instance describing values whose Java class name is javax.management.ObjectName.
ObjectNotActive - Exception in org.omg.PortableServer.POAPackage
org/omg/PortableServer/POAPackage/ObjectNotActive.java .
ObjectNotActive() - Constructor for exception org.omg.PortableServer.POAPackage.ObjectNotActive
ObjectNotActive(String) - Constructor for exception org.omg.PortableServer.POAPackage.ObjectNotActive
ObjectNotActiveHelper - Class in org.omg.PortableServer.POAPackage
org/omg/PortableServer/POAPackage/ObjectNotActiveHelper.java .
ObjectNotActiveHelper() - Constructor for class org.omg.PortableServer.POAPackage.ObjectNotActiveHelper
ObjectOutput - Interface in java.io
ObjectOutput extends the DataOutput interface to include writing of objects.
ObjectOutputStream - Class in java.io
An ObjectOutputStream writes primitive data types and graphs of Java objects to an OutputStream.
ObjectOutputStream(OutputStream) - Constructor for class java.io.ObjectOutputStream
Creates an ObjectOutputStream that writes to the specified OutputStream.
ObjectOutputStream() - Constructor for class java.io.ObjectOutputStream
Provide a way for subclasses that are completely reimplementing ObjectOutputStream to not have to allocate private data just used by this implementation of ObjectOutputStream.
ObjectOutputStream.PutField - Class in java.io
Provide programmatic access to the persistent fields to be written to ObjectOutput.
ObjectReferenceFactory - Interface in org.omg.PortableInterceptor
The object reference factory.
ObjectReferenceFactoryHelper - Class in org.omg.PortableInterceptor
The object reference factory.
ObjectReferenceFactoryHelper() - Constructor for class org.omg.PortableInterceptor.ObjectReferenceFactoryHelper
ObjectReferenceFactoryHolder - Class in org.omg.PortableInterceptor
The object reference factory.
ObjectReferenceFactoryHolder() - Constructor for class org.omg.PortableInterceptor.ObjectReferenceFactoryHolder
ObjectReferenceFactoryHolder(ObjectReferenceFactory) - Constructor for class org.omg.PortableInterceptor.ObjectReferenceFactoryHolder
ObjectReferenceTemplate - Interface in org.omg.PortableInterceptor
The object reference template.
ObjectReferenceTemplateHelper - Class in org.omg.PortableInterceptor
The object reference template.
ObjectReferenceTemplateHelper() - Constructor for class org.omg.PortableInterceptor.ObjectReferenceTemplateHelper
ObjectReferenceTemplateHolder - Class in org.omg.PortableInterceptor
The object reference template.
ObjectReferenceTemplateHolder() - Constructor for class org.omg.PortableInterceptor.ObjectReferenceTemplateHolder
ObjectReferenceTemplateHolder(ObjectReferenceTemplate) - Constructor for class org.omg.PortableInterceptor.ObjectReferenceTemplateHolder
ObjectReferenceTemplateSeqHelper - Class in org.omg.PortableInterceptor
Sequence of object reference templates is used for reporting state changes that do not occur on the adapter manager.
ObjectReferenceTemplateSeqHelper() - Constructor for class org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper
ObjectReferenceTemplateSeqHolder - Class in org.omg.PortableInterceptor
Sequence of object reference templates is used for reporting state changes that do not occur on the adapter manager.
ObjectReferenceTemplateSeqHolder() - Constructor for class org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder
ObjectReferenceTemplateSeqHolder(ObjectReferenceTemplate[]) - Constructor for class org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder
objectRemoved(NamingEvent) - Method in interface javax.naming.event.NamespaceChangeListener
Called when an object has been removed.
objectRenamed(NamingEvent) - Method in interface javax.naming.event.NamespaceChangeListener
Called when an object has been renamed.
Objects - Class in java.util
This class consists of static utility methods for operating on objects.
ObjectStreamClass - Class in java.io
Serialization's descriptor for classes.
ObjectStreamConstants - Interface in java.io
Constants written into the Object Serialization Stream.
ObjectStreamException - Exception in java.io
Superclass of all exceptions specific to Object Stream classes.
ObjectStreamException(String) - Constructor for exception java.io.ObjectStreamException
Create an ObjectStreamException with the specified argument.
ObjectStreamException() - Constructor for exception java.io.ObjectStreamException
Create an ObjectStreamException.
ObjectStreamField - Class in java.io
A description of a Serializable field from a Serializable class.
ObjectStreamField(String, Class<?>) - Constructor for class java.io.ObjectStreamField
Create a Serializable field with the specified type.
ObjectStreamField(String, Class<?>, boolean) - Constructor for class java.io.ObjectStreamField
Creates an ObjectStreamField representing a serializable field with the given name and type.
ObjectView - Class in javax.swing.text.html
Component decorator that implements the view interface for <object> elements.
ObjectView(Element) - Constructor for class javax.swing.text.html.ObjectView
Creates a new ObjectView object.
ObjID - Class in java.rmi.server
An ObjID is used to identify a remote object exported to an RMI runtime.
ObjID() - Constructor for class java.rmi.server.ObjID
Generates a unique object identifier.
ObjID(int) - Constructor for class java.rmi.server.ObjID
Creates a "well-known" object identifier.
ObjIntConsumer<T> - Interface in java.util.function
Represents an operation that accepts an object-valued and a int-valued argument, and returns no result.
ObjLongConsumer<T> - Interface in java.util.function
Represents an operation that accepts an object-valued and a long-valued argument, and returns no result.
Observable - Class in java.util
This class represents an observable object, or "data" in the model-view paradigm.
Observable() - Constructor for class java.util.Observable
Construct an Observable with zero Observers.
OBSERVED_ATTRIBUTE_ERROR - Static variable in class javax.management.monitor.MonitorNotification
Notification type denoting that the observed attribute is not contained in the observed object.
OBSERVED_ATTRIBUTE_ERROR_NOTIFIED - Static variable in class javax.management.monitor.Monitor
Flag denoting that a notification has occurred after changing the observed attribute.
OBSERVED_ATTRIBUTE_TYPE_ERROR - Static variable in class javax.management.monitor.MonitorNotification
Notification type denoting that the type of the observed attribute is not correct.
OBSERVED_ATTRIBUTE_TYPE_ERROR_NOTIFIED - Static variable in class javax.management.monitor.Monitor
Flag denoting that a notification has occurred after changing the observed object or the observed attribute.
OBSERVED_OBJECT_ERROR - Static variable in class javax.management.monitor.MonitorNotification
Notification type denoting that the observed object is not registered in the MBean server.
OBSERVED_OBJECT_ERROR_NOTIFIED - Static variable in class javax.management.monitor.Monitor
Flag denoting that a notification has occurred after changing the observed object.
Observer - Interface in java.util
A class can implement the Observer interface when it wants to be informed of changes in observable objects.
observesDaylightTime() - Method in class java.util.SimpleTimeZone
Returns true if this SimpleTimeZone observes Daylight Saving Time.
observesDaylightTime() - Method in class java.util.TimeZone
Returns true if this TimeZone is currently in Daylight Saving Time, or if a transition from Standard Time to Daylight Saving Time occurs at any future time.
obtrudeException(Throwable) - Method in class java.util.concurrent.CompletableFuture
Forcibly causes subsequent invocations of method CompletableFuture.get() and related methods to throw the given exception, whether or not already completed.
obtrudeValue(T) - Method in class java.util.concurrent.CompletableFuture
Forcibly sets or resets the value subsequently returned by method CompletableFuture.get() and related methods, whether or not already completed.
OceanTheme - Class in javax.swing.plaf.metal
The default theme for the MetalLookAndFeel.
OceanTheme() - Constructor for class javax.swing.plaf.metal.OceanTheme
Creates an instance of OceanTheme
OctetSeqHelper - Class in org.omg.CORBA
The Helper for OctetSeq.
OctetSeqHelper() - Constructor for class org.omg.CORBA.OctetSeqHelper
OctetSeqHolder - Class in org.omg.CORBA
The Holder for OctetSeq.
OctetSeqHolder() - Constructor for class org.omg.CORBA.OctetSeqHolder
OctetSeqHolder(byte[]) - Constructor for class org.omg.CORBA.OctetSeqHolder
OctetStreamData - Class in javax.xml.crypto
A representation of a Data type containing an octet stream.
OctetStreamData(InputStream) - Constructor for class javax.xml.crypto.OctetStreamData
Creates a new OctetStreamData.
OctetStreamData(InputStream, String, String) - Constructor for class javax.xml.crypto.OctetStreamData
Creates a new OctetStreamData.
OCTOBER - Static variable in class java.util.Calendar
Value of the Calendar.MONTH field indicating the tenth month of the year in the Gregorian and Julian calendars.
OCTOBER - Static variable in class javax.xml.datatype.DatatypeConstants
Value for tenth month of year.
oEnd - Variable in class javax.swing.text.html.parser.Element
of(char) - Static method in class java.lang.Character.UnicodeBlock
Returns the object representing the Unicode block containing the given character, or null if the character is not a member of a defined block.
of(int) - Static method in class java.lang.Character.UnicodeBlock
Returns the object representing the Unicode block containing the given character (Unicode code point), or null if the character is not a member of a defined block.
of(int) - Static method in enum java.lang.Character.UnicodeScript
Returns the enum constant representing the Unicode script of which the given character (Unicode code point) is assigned to.
of(String) - Static method in interface java.time.chrono.Chronology
Obtains an instance of Chronology from a chronology ID or calendar system type.
of(int, int, int) - Static method in class java.time.chrono.HijrahDate
Obtains a HijrahDate of the Islamic Umm Al-Qura calendar from the proleptic-year, month-of-year and day-of-month fields.
of(int) - Static method in enum java.time.chrono.HijrahEra
Obtains an instance of HijrahEra from an int value.
of(int) - Static method in enum java.time.chrono.IsoEra
Obtains an instance of IsoEra from an int value.
of(JapaneseEra, int, int, int) - Static method in class java.time.chrono.JapaneseDate
Obtains a JapaneseDate representing a date in the Japanese calendar system from the era, year-of-era, month-of-year and day-of-month fields.
of(int, int, int) - Static method in class java.time.chrono.JapaneseDate
Obtains a JapaneseDate representing a date in the Japanese calendar system from the proleptic-year, month-of-year and day-of-month fields.
of(int) - Static method in class java.time.chrono.JapaneseEra
Obtains an instance of JapaneseEra from an int value.
of(int, int, int) - Static method in class java.time.chrono.MinguoDate
Obtains a MinguoDate representing a date in the Minguo calendar system from the proleptic-year, month-of-year and day-of-month fields.
of(int) - Static method in enum java.time.chrono.MinguoEra
Obtains an instance of MinguoEra from an int value.
of(int, int, int) - Static method in class java.time.chrono.ThaiBuddhistDate
Obtains a ThaiBuddhistDate representing a date in the Thai Buddhist calendar system from the proleptic-year, month-of-year and day-of-month fields.
of(int) - Static method in enum java.time.chrono.ThaiBuddhistEra
Obtains an instance of ThaiBuddhistEra from an int value.
of(int) - Static method in enum java.time.DayOfWeek
Obtains an instance of DayOfWeek from an int value.
of(long, TemporalUnit) - Static method in class java.time.Duration
Obtains a Duration representing an amount in the specified unit.
of(Locale) - Static method in class java.time.format.DecimalStyle
Obtains the DecimalStyle for the specified locale.
of(int, Month, int) - Static method in class java.time.LocalDate
Obtains an instance of LocalDate from a year, month and day.
of(int, int, int) - Static method in class java.time.LocalDate
Obtains an instance of LocalDate from a year, month and day.
of(int, Month, int, int, int) - Static method in class java.time.LocalDateTime
Obtains an instance of LocalDateTime from year, month, day, hour and minute, setting the second and nanosecond to zero.
of(int, Month, int, int, int, int) - Static method in class java.time.LocalDateTime
Obtains an instance of LocalDateTime from year, month, day, hour, minute and second, setting the nanosecond to zero.
of(int, Month, int, int, int, int, int) - Static method in class java.time.LocalDateTime
Obtains an instance of LocalDateTime from year, month, day, hour, minute, second and nanosecond.
of(int, int, int, int, int) - Static method in class java.time.LocalDateTime
Obtains an instance of LocalDateTime from year, month, day, hour and minute, setting the second and nanosecond to zero.
of(int, int, int, int, int, int) - Static method in class java.time.LocalDateTime
Obtains an instance of LocalDateTime from year, month, day, hour, minute and second, setting the nanosecond to zero.
of(int, int, int, int, int, int, int) - Static method in class java.time.LocalDateTime
Obtains an instance of LocalDateTime from year, month, day, hour, minute, second and nanosecond.
of(LocalDate, LocalTime) - Static method in class java.time.LocalDateTime
Obtains an instance of LocalDateTime from a date and time.
of(int, int) - Static method in class java.time.LocalTime
Obtains an instance of LocalTime from an hour and minute.
of(int, int, int) - Static method in class java.time.LocalTime
Obtains an instance of LocalTime from an hour, minute and second.
of(int, int, int, int) - Static method in class java.time.LocalTime
Obtains an instance of LocalTime from an hour, minute, second and nanosecond.
of(int) - Static method in enum java.time.Month
Obtains an instance of Month from an int value.
of(Month, int) - Static method in class java.time.MonthDay
Obtains an instance of MonthDay.
of(int, int) - Static method in class java.time.MonthDay
Obtains an instance of MonthDay.
of(LocalDate, LocalTime, ZoneOffset) - Static method in class java.time.OffsetDateTime
Obtains an instance of OffsetDateTime from a date, time and offset.
of(LocalDateTime, ZoneOffset) - Static method in class java.time.OffsetDateTime
Obtains an instance of OffsetDateTime from a date-time and offset.
of(int, int, int, int, int, int, int, ZoneOffset) - Static method in class java.time.OffsetDateTime
Obtains an instance of OffsetDateTime from a year, month, day, hour, minute, second, nanosecond and offset.
of(LocalTime, ZoneOffset) - Static method in class java.time.OffsetTime
Obtains an instance of OffsetTime from a local time and an offset.
of(int, int, int, int, ZoneOffset) - Static method in class java.time.OffsetTime
Obtains an instance of OffsetTime from an hour, minute, second and nanosecond.
of(int, int, int) - Static method in class java.time.Period
Obtains a Period representing a number of years, months and days.
of(long, long) - Static method in class java.time.temporal.ValueRange
Obtains a fixed value range.
of(long, long, long) - Static method in class java.time.temporal.ValueRange
Obtains a variable value range.
of(long, long, long, long) - Static method in class java.time.temporal.ValueRange
Obtains a fully variable value range.
of(Locale) - Static method in class java.time.temporal.WeekFields
Obtains an instance of WeekFields appropriate for a locale.
of(DayOfWeek, int) - Static method in class java.time.temporal.WeekFields
Obtains an instance of WeekFields from the first day-of-week and minimal days.
of(int) - Static method in class java.time.Year
Obtains an instance of Year.
of(int, Month) - Static method in class java.time.YearMonth
Obtains an instance of YearMonth from a year and month.
of(int, int) - Static method in class java.time.YearMonth
Obtains an instance of YearMonth from a year and month.
of(LocalDateTime, ZoneOffset, ZoneOffset) - Static method in class java.time.zone.ZoneOffsetTransition
Obtains an instance defining a transition between two offsets.
of(Month, int, DayOfWeek, LocalTime, boolean, ZoneOffsetTransitionRule.TimeDefinition, ZoneOffset, ZoneOffset, ZoneOffset) - Static method in class java.time.zone.ZoneOffsetTransitionRule
Obtains an instance defining the yearly rule to create transitions between two offsets.
of(ZoneOffset, ZoneOffset, List<ZoneOffsetTransition>, List<ZoneOffsetTransition>, List<ZoneOffsetTransitionRule>) - Static method in class java.time.zone.ZoneRules
Obtains an instance of a ZoneRules.
of(ZoneOffset) - Static method in class java.time.zone.ZoneRules
Obtains an instance of ZoneRules that has fixed zone rules.
of(LocalDate, LocalTime, ZoneId) - Static method in class java.time.ZonedDateTime
Obtains an instance of ZonedDateTime from a local date and time.
of(LocalDateTime, ZoneId) - Static method in class java.time.ZonedDateTime
Obtains an instance of ZonedDateTime from a local date-time.
of(int, int, int, int, int, int, int, ZoneId) - Static method in class java.time.ZonedDateTime
Obtains an instance of ZonedDateTime from a year, month, day, hour, minute, second, nanosecond and time-zone.
of(String, Map<String, String>) - Static method in class java.time.ZoneId
Obtains an instance of ZoneId using its ID using a map of aliases to supplement the standard zone IDs.
of(String) - Static method in class java.time.ZoneId
Obtains an instance of ZoneId from an ID ensuring that the ID is valid and available for use.
of(String) - Static method in class java.time.ZoneOffset
Obtains an instance of ZoneOffset using the ID.
of(E) - Static method in class java.util.EnumSet
Creates an enum set initially containing the specified element.
of(E, E) - Static method in class java.util.EnumSet
Creates an enum set initially containing the specified elements.
of(E, E, E) - Static method in class java.util.EnumSet
Creates an enum set initially containing the specified elements.
of(E, E, E, E) - Static method in class java.util.EnumSet
Creates an enum set initially containing the specified elements.
of(E, E, E, E, E) - Static method in class java.util.EnumSet
Creates an enum set initially containing the specified elements.
of(E, E...) - Static method in class java.util.EnumSet
Creates an enum set initially containing the specified elements.
of(T) - Static method in class java.util.Optional
Returns an Optional with the specified present non-null value.
of(double) - Static method in class java.util.OptionalDouble
Return an OptionalDouble with the specified value present.
of(int) - Static method in class java.util.OptionalInt
Return an OptionalInt with the specified value present.
of(long) - Static method in class java.util.OptionalLong
Return an OptionalLong with the specified value present.
of(Supplier<R>, BiConsumer<R, T>, BinaryOperator<R>, Collector.Characteristics...) - Static method in interface java.util.stream.Collector
Returns a new Collector described by the given supplier, accumulator, and combiner functions.
of(Supplier<A>, BiConsumer<A, T>, BinaryOperator<A>, Function<A, R>, Collector.Characteristics...) - Static method in interface java.util.stream.Collector
Returns a new Collector described by the given supplier, accumulator, combiner, and finisher functions.
of(double) - Static method in interface java.util.stream.DoubleStream
Returns a sequential DoubleStream containing a single element.
of(double...) - Static method in interface java.util.stream.DoubleStream
Returns a sequential ordered stream whose elements are the specified values.
of(int) - Static method in interface java.util.stream.IntStream
Returns a sequential IntStream containing a single element.
of(int...) - Static method in interface java.util.stream.IntStream
Returns a sequential ordered stream whose elements are the specified values.
of(long) - Static method in interface java.util.stream.LongStream
Returns a sequential LongStream containing a single element.
of(long...) - Static method in interface java.util.stream.LongStream
Returns a sequential ordered stream whose elements are the specified values.
of(T) - Static method in interface java.util.stream.Stream
Returns a sequential Stream containing a single element.
of(T...) - Static method in interface java.util.stream.Stream
Returns a sequential ordered stream whose elements are the specified values.
of(String, String) - Static method in class javax.annotation.processing.Completions
Returns a completion of the value and message.
of(String) - Static method in class javax.annotation.processing.Completions
Returns a completion of the value and an empty message
ofCalendarField(int) - Static method in class java.text.DateFormat.Field
Returns the Field constant that corresponds to the Calendar constant calendarField.
ofDateAdjuster(UnaryOperator<LocalDate>) - Static method in class java.time.temporal.TemporalAdjusters
Obtains a TemporalAdjuster that wraps a date adjuster.
ofDays(long) - Static method in class java.time.Duration
Obtains a Duration representing a number of standard 24 hour days.
ofDays(int) - Static method in class java.time.Period
Obtains a Period representing a number of days.
ofDefaultLocale() - Static method in class java.time.format.DecimalStyle
Obtains the DecimalStyle for the default FORMAT locale.
ofEpochDay(long) - Static method in class java.time.LocalDate
Obtains an instance of LocalDate from the epoch day count.
ofEpochMilli(long) - Static method in class java.time.Instant
Obtains an instance of Instant using milliseconds from the epoch of 1970-01-01T00:00:00Z.
ofEpochSecond(long) - Static method in class java.time.Instant
Obtains an instance of Instant using seconds from the epoch of 1970-01-01T00:00:00Z.
ofEpochSecond(long, long) - Static method in class java.time.Instant
Obtains an instance of Instant using seconds from the epoch of 1970-01-01T00:00:00Z and nanosecond fraction of second.
ofEpochSecond(long, int, ZoneOffset) - Static method in class java.time.LocalDateTime
Obtains an instance of LocalDateTime using seconds from the epoch of 1970-01-01T00:00:00Z.
OFF - Static variable in class java.util.logging.Level
OFF is a special level that can be used to turn off logging.
offendingNode - Variable in exception javax.imageio.metadata.IIOInvalidTreeException
The Node that led to the parsing error, or null.
offer(E) - Method in class java.util.ArrayDeque
Inserts the specified element at the end of this deque.
offer(E) - Method in class java.util.concurrent.ArrayBlockingQueue
Inserts the specified element at the tail of this queue if it is possible to do so immediately without exceeding the queue's capacity, returning true upon success and false if this queue is full.
offer(E, long, TimeUnit) - Method in class java.util.concurrent.ArrayBlockingQueue
Inserts the specified element at the tail of this queue, waiting up to the specified wait time for space to become available if the queue is full.
offer(E) - Method in interface java.util.concurrent.BlockingDeque
Inserts the specified element into the queue represented by this deque (in other words, at the tail of this deque) if it is possible to do so immediately without violating capacity restrictions, returning true upon success and false if no space is currently available.
offer(E, long, TimeUnit) - Method in interface java.util.concurrent.BlockingDeque
Inserts the specified element into the queue represented by this deque (in other words, at the tail of this deque), waiting up to the specified wait time if necessary for space to become available.
offer(E) - Method in interface java.util.concurrent.BlockingQueue
Inserts the specified element into this queue if it is possible to do so immediately without violating capacity restrictions, returning true upon success and false if no space is currently available.
offer(E, long, TimeUnit) - Method in interface java.util.concurrent.BlockingQueue
Inserts the specified element into this queue, waiting up to the specified wait time if necessary for space to become available.
offer(E) - Method in class java.util.concurrent.ConcurrentLinkedDeque
Inserts the specified element at the tail of this deque.
offer(E) - Method in class java.util.concurrent.ConcurrentLinkedQueue
Inserts the specified element at the tail of this queue.
offer(E) - Method in class java.util.concurrent.DelayQueue
Inserts the specified element into this delay queue.
offer(E, long, TimeUnit) - Method in class java.util.concurrent.DelayQueue
Inserts the specified element into this delay queue.
offer(E) - Method in class java.util.concurrent.LinkedBlockingDeque
offer(E, long, TimeUnit) - Method in class java.util.concurrent.LinkedBlockingDeque
offer(E, long, TimeUnit) - Method in class java.util.concurrent.LinkedBlockingQueue
Inserts the specified element at the tail of this queue, waiting if necessary up to the specified wait time for space to become available.
offer(E) - Method in class java.util.concurrent.LinkedBlockingQueue
Inserts the specified element at the tail of this queue if it is possible to do so immediately without exceeding the queue's capacity, returning true upon success and false if this queue is full.
offer(E, long, TimeUnit) - Method in class java.util.concurrent.LinkedTransferQueue
Inserts the specified element at the tail of this queue.
offer(E) - Method in class java.util.concurrent.LinkedTransferQueue
Inserts the specified element at the tail of this queue.
offer(E) - Method in class java.util.concurrent.PriorityBlockingQueue
Inserts the specified element into this priority queue.
offer(E, long, TimeUnit) - Method in class java.util.concurrent.PriorityBlockingQueue
Inserts the specified element into this priority queue.
offer(E, long, TimeUnit) - Method in class java.util.concurrent.SynchronousQueue
Inserts the specified element into this queue, waiting if necessary up to the specified wait time for another thread to receive it.
offer(E) - Method in class java.util.concurrent.SynchronousQueue
Inserts the specified element into this queue, if another thread is waiting to receive it.
offer(E) - Method in interface java.util.Deque
Inserts the specified element into the queue represented by this deque (in other words, at the tail of this deque) if it is possible to do so immediately without violating capacity restrictions, returning true upon success and false if no space is currently available.
offer(E) - Method in class java.util.LinkedList
Adds the specified element as the tail (last element) of this list.
offer(E) - Method in class java.util.PriorityQueue
Inserts the specified element into this priority queue.
offer(E) - Method in interface java.util.Queue
Inserts the specified element into this queue if it is possible to do so immediately without violating capacity restrictions.
offerFirst(E) - Method in class java.util.ArrayDeque
Inserts the specified element at the front of this deque.
offerFirst(E) - Method in interface java.util.concurrent.BlockingDeque
Inserts the specified element at the front of this deque if it is possible to do so immediately without violating capacity restrictions, returning true upon success and false if no space is currently available.
offerFirst(E, long, TimeUnit) - Method in interface java.util.concurrent.BlockingDeque
Inserts the specified element at the front of this deque, waiting up to the specified wait time if necessary for space to become available.
offerFirst(E) - Method in class java.util.concurrent.ConcurrentLinkedDeque
Inserts the specified element at the front of this deque.
offerFirst(E) - Method in class java.util.concurrent.LinkedBlockingDeque
offerFirst(E, long, TimeUnit) - Method in class java.util.concurrent.LinkedBlockingDeque
offerFirst(E) - Method in interface java.util.Deque
Inserts the specified element at the front of this deque unless it would violate capacity restrictions.
offerFirst(E) - Method in class java.util.LinkedList
Inserts the specified element at the front of this list.
offerLast(E) - Method in class java.util.ArrayDeque
Inserts the specified element at the end of this deque.
offerLast(E) - Method in interface java.util.concurrent.BlockingDeque
Inserts the specified element at the end of this deque if it is possible to do so immediately without violating capacity restrictions, returning true upon success and false if no space is currently available.
offerLast(E, long, TimeUnit) - Method in interface java.util.concurrent.BlockingDeque
Inserts the specified element at the end of this deque, waiting up to the specified wait time if necessary for space to become available.
offerLast(E) - Method in class java.util.concurrent.ConcurrentLinkedDeque
Inserts the specified element at the end of this deque.
offerLast(E) - Method in class java.util.concurrent.LinkedBlockingDeque
offerLast(E, long, TimeUnit) - Method in class java.util.concurrent.LinkedBlockingDeque
offerLast(E) - Method in interface java.util.Deque
Inserts the specified element at the end of this deque unless it would violate capacity restrictions.
offerLast(E) - Method in class java.util.LinkedList
Inserts the specified element at the end of this list.
offset - Variable in class java.awt.image.DataBuffer
Offset into default (first) bank from which to get the first element.
offset(Clock, Duration) - Static method in class java.time.Clock
Obtains a clock that returns instants from the specified clock with the specified duration added
offset() - Static method in class java.time.temporal.TemporalQueries
A query for ZoneOffset returning null if not found.
offset - Variable in class javax.swing.plaf.basic.BasicScrollBarUI.TrackListener
offset - Variable in class javax.swing.plaf.basic.BasicSliderUI.TrackListener
offset - Variable in class javax.swing.text.Segment
This is the offset into the array that the desired text begins.
offset - Variable in class javax.swing.tree.DefaultTreeCellEditor
Used in editing.
offset - Variable in exception org.omg.CORBA.portable.IndirectionException
Points to the stream's offset.
offsetByCodePoints(CharSequence, int, int) - Static method in class java.lang.Character
Returns the index within the given char sequence that is offset from the given index by codePointOffset code points.
offsetByCodePoints(char[], int, int, int, int) - Static method in class java.lang.Character
Returns the index within the given char subarray that is offset from the given index by codePointOffset code points.
offsetByCodePoints(int, int) - Method in class java.lang.String
Returns the index within this String that is offset from the given index by codePointOffset code points.
offsetByCodePoints(int, int) - Method in class java.lang.StringBuffer
OffsetDateTime - Class in java.time
A date-time with an offset from UTC/Greenwich in the ISO-8601 calendar system, such as 2007-12-03T10:15:30+01:00.
offsetRequested() - Method in exception javax.swing.text.BadLocationException
Returns the offset into the document that was not legal.
offsets - Variable in class java.awt.image.DataBuffer
Offsets into all banks.
OffsetTime - Class in java.time
A time with an offset from UTC/Greenwich in the ISO-8601 calendar system, such as 10:15:30+01:00.
ofHours(long) - Static method in class java.time.Duration
Obtains a Duration representing a number of standard hours.
ofHours(int) - Static method in class java.time.ZoneOffset
Obtains an instance of ZoneOffset using an offset in hours.
ofHoursMinutes(int, int) - Static method in class java.time.ZoneOffset
Obtains an instance of ZoneOffset using an offset in hours and minutes.
ofHoursMinutesSeconds(int, int, int) - Static method in class java.time.ZoneOffset
Obtains an instance of ZoneOffset using an offset in hours, minutes and seconds.
ofInstant(Instant, ZoneId) - Static method in class java.time.LocalDateTime
Obtains an instance of LocalDateTime from an Instant and zone ID.
ofInstant(Instant, ZoneId) - Static method in class java.time.OffsetDateTime
Obtains an instance of OffsetDateTime from an Instant and zone ID.
ofInstant(Instant, ZoneId) - Static method in class java.time.OffsetTime
Obtains an instance of OffsetTime from an Instant and zone ID.
ofInstant(Instant, ZoneId) - Static method in class java.time.ZonedDateTime
Obtains an instance of ZonedDateTime from an Instant.
ofInstant(LocalDateTime, ZoneOffset, ZoneId) - Static method in class java.time.ZonedDateTime
Obtains an instance of ZonedDateTime from the instant formed by combining the local date-time and offset.
ofLocal(LocalDateTime, ZoneId, ZoneOffset) - Static method in class java.time.ZonedDateTime
Obtains an instance of ZonedDateTime from a local date-time using the preferred offset if possible.
ofLocale(Locale) - Static method in interface java.time.chrono.Chronology
Obtains an instance of Chronology from a locale.
ofLocalizedDate(FormatStyle) - Static method in class java.time.format.DateTimeFormatter
Returns a locale specific date format for the ISO chronology.
ofLocalizedDateTime(FormatStyle) - Static method in class java.time.format.DateTimeFormatter
Returns a locale specific date-time formatter for the ISO chronology.
ofLocalizedDateTime(FormatStyle, FormatStyle) - Static method in class java.time.format.DateTimeFormatter
Returns a locale specific date and time format for the ISO chronology.
ofLocalizedTime(FormatStyle) - Static method in class java.time.format.DateTimeFormatter
Returns a locale specific time format for the ISO chronology.
ofMillis(long) - Static method in class java.time.Duration
Obtains a Duration representing a number of milliseconds.
ofMinutes(long) - Static method in class java.time.Duration
Obtains a Duration representing a number of standard minutes.
ofMonths(int) - Static method in class java.time.Period
Obtains a Period representing a number of months.
ofNanoOfDay(long) - Static method in class java.time.LocalTime
Obtains an instance of LocalTime from a nanos-of-day value.
ofNanos(long) - Static method in class java.time.Duration
Obtains a Duration representing a number of nanoseconds.
ofNullable(T) - Static method in class java.util.Optional
Returns an Optional describing the specified value, if non-null, otherwise returns an empty Optional.
ofOffset(String, ZoneOffset) - Static method in class java.time.ZoneId
Obtains an instance of ZoneId wrapping an offset.
ofPattern(String) - Static method in class java.time.format.DateTimeFormatter
Creates a formatter using the specified pattern.
ofPattern(String, Locale) - Static method in class java.time.format.DateTimeFormatter
Creates a formatter using the specified pattern and locale.
ofSecondOfDay(long) - Static method in class java.time.LocalTime
Obtains an instance of LocalTime from a second-of-day value.
ofSeconds(long) - Static method in class java.time.Duration
Obtains a Duration representing a number of seconds.
ofSeconds(long, long) - Static method in class java.time.Duration
Obtains a Duration representing a number of seconds and an adjustment in nanoseconds.
ofStrict(LocalDateTime, ZoneOffset, ZoneId) - Static method in class java.time.ZonedDateTime
Obtains an instance of ZonedDateTime strictly validating the combination of local date-time, offset and zone ID.
ofTotalSeconds(int) - Static method in class java.time.ZoneOffset
Obtains an instance of ZoneOffset specifying the total offset in seconds
ofWeeks(int) - Static method in class java.time.Period
Obtains a Period representing a number of weeks.
ofYearDay(int, int) - Static method in class java.time.LocalDate
Obtains an instance of LocalDate from a year and day-of-year.
ofYears(int) - Static method in class java.time.Period
Obtains a Period representing a number of years.
OGHAM - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Ogham" Unicode character block.
OID - Static variable in class javax.naming.ldap.ManageReferralControl
The ManageReferral control's assigned object identifier is 2.16.840.1.113730.3.4.2.
OID - Static variable in class javax.naming.ldap.PagedResultsControl
The paged-results control's assigned object identifier is 1.2.840.113556.1.4.319.
OID - Static variable in class javax.naming.ldap.PagedResultsResponseControl
The paged-results response control's assigned object identifier is 1.2.840.113556.1.4.319.
OID - Static variable in class javax.naming.ldap.SortControl
The server-side sort control's assigned object identifier is 1.2.840.113556.1.4.473.
OID - Static variable in class javax.naming.ldap.SortResponseControl
The server-side sort response control's assigned object identifier is 1.2.840.113556.1.4.474.
OID - Static variable in class javax.naming.ldap.StartTlsRequest
The StartTLS extended request's assigned object identifier is 1.3.6.1.4.1.1466.20037.
OID - Static variable in class javax.naming.ldap.StartTlsResponse
The StartTLS extended response's assigned object identifier is 1.3.6.1.4.1.1466.20037.
Oid - Class in org.ietf.jgss
This class represents Universal Object Identifiers (Oids) and their associated operations.
Oid(String) - Constructor for class org.ietf.jgss.Oid
Constructs an Oid object from a string representation of its integer components.
Oid(InputStream) - Constructor for class org.ietf.jgss.Oid
Creates an Oid object from its ASN.1 DER encoding.
Oid(byte[]) - Constructor for class org.ietf.jgss.Oid
Creates an Oid object from its ASN.1 DER encoding.
OK - Static variable in class javax.security.auth.callback.ConfirmationCallback
OK option.
OK_CANCEL_OPTION - Static variable in class javax.security.auth.callback.ConfirmationCallback
OK/CANCEL confirmation confirmation option.
OK_CANCEL_OPTION - Static variable in class javax.swing.JOptionPane
Type used for showConfirmDialog.
OK_OPTION - Static variable in class javax.swing.JOptionPane
Return value form class method if OK is chosen.
okToUseGui - Variable in class java.beans.beancontext.BeanContextSupport
A boolean indicating if this instance may now render a GUI.
okToUseGui() - Method in class java.beans.beancontext.BeanContextSupport
Notify this instance that it may now render a GUI
okToUseGui() - Method in interface java.beans.Visibility
This method instructs the bean that it is OK to use the Gui.
OL - Static variable in class javax.swing.text.html.HTML.Tag
OL_CHIKI - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Ol Chiki" Unicode character block.
OLD_ITALIC - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Old Italic" Unicode character block.
OLD_PERSIAN - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Old Persian" Unicode character block.
OLD_SOUTH_ARABIAN - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Old South Arabian" Unicode character block.
OLD_TOKEN - Static variable in exception org.ietf.jgss.GSSException
The token's validity period has expired.
OLD_TURKIC - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Old Turkic" Unicode character block.
oldBinding - Variable in class javax.naming.event.NamingEvent
Contains information about the object before the change.
oldBorderPainted - Variable in class javax.swing.plaf.basic.BasicMenuItemUI
oldLeadSelectionPath - Variable in class javax.swing.event.TreeSelectionEvent
leadSelectionPath before the paths changed, may be null.
OMGVMCID - Interface in org.omg.CORBA
The vendor minor code ID reserved for OMG.
OMIT_XML_DECLARATION - Static variable in class javax.xml.transform.OutputKeys
omit-xml-declaration = "yes" | "no".
omitEnd() - Method in class javax.swing.text.html.parser.Element
Return true if the end tag can be omitted.
omitStart() - Method in class javax.swing.text.html.parser.Element
Return true if the start tag can be omitted.
on(boolean) - Method in class java.security.DigestInputStream
Turns the digest function on or off.
on(boolean) - Method in class java.security.DigestOutputStream
Turns the digest function on or off.
onAdvance(int, int) - Method in class java.util.concurrent.Phaser
Overridable method to perform an action upon impending phase advance, and to control termination.
onClose(Runnable) - Method in interface java.util.stream.BaseStream
Returns an equivalent stream with an additional close handler.
onCompletion(CountedCompleter<?>) - Method in class java.util.concurrent.CountedCompleter
Performs an action when method CountedCompleter.tryComplete() is invoked and the pending count is zero, or when the unconditional method CountedCompleter.complete(T) is invoked.
onDeregistration(ServiceRegistry, Class<?>) - Method in class javax.imageio.spi.IIOServiceProvider
A callback that will be whenever the Spi class has been deregistered from a ServiceRegistry.
onDeregistration(ServiceRegistry, Class<?>) - Method in interface javax.imageio.spi.RegisterableService
Called when an object implementing this interface is removed from the given category of the given registry.
ONE - Static variable in class java.math.BigDecimal
The value 1, with a scale of 0.
ONE - Static variable in class java.math.BigInteger
The BigInteger constant one.
ONE_DAY - Static variable in class javax.management.timer.Timer
Number of milliseconds in one day.
ONE_HOUR - Static variable in class javax.management.timer.Timer
Number of milliseconds in one hour.
ONE_MINUTE - Static variable in class javax.management.timer.Timer
Number of milliseconds in one minute.
ONE_SECOND - Static variable in class javax.management.timer.Timer
Number of milliseconds in one second.
ONE_SIDED - Static variable in class java.awt.JobAttributes.SidesType
The SidesType instance to use for specifying that consecutive job pages should be printed upon the same side of consecutive media sheets.
ONE_SIDED - Static variable in class javax.print.attribute.standard.Sides
Imposes each consecutive print-stream page upon the same side of consecutive media sheets.
ONE_TOUCH_EXPANDABLE_PROPERTY - Static variable in class javax.swing.JSplitPane
Bound property for oneTouchExpandable.
ONE_TOUCH_OFFSET - Static variable in class javax.swing.plaf.basic.BasicSplitPaneDivider
ONE_TOUCH_SIZE - Static variable in class javax.swing.plaf.basic.BasicSplitPaneDivider
Width or height of the divider based on orientation BasicSplitPaneUI adds two to this.
ONE_WEEK - Static variable in class javax.management.timer.Timer
Number of milliseconds in one week.
ONELEVEL_SCOPE - Static variable in class javax.naming.directory.SearchControls
Search one level of the named context.
ONELEVEL_SCOPE - Static variable in interface javax.naming.event.EventContext
Constant for expressing interest in events concerning objects in the context named by the target, excluding the context named by the target.
oneTouchExpandable - Variable in class javax.swing.JSplitPane
Is a little widget provided to quickly expand/collapse the split pane?
oneTouchExpandableChanged() - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider
Messaged when the oneTouchExpandable value of the JSplitPane the receiver is contained in changes.
Oneway - Annotation Type in javax.jws
onExceptionalCompletion(Throwable, CountedCompleter<?>) - Method in class java.util.concurrent.CountedCompleter
Performs an action when method ForkJoinTask.completeExceptionally(Throwable) is invoked or method CountedCompleter.compute() throws an exception, and this task has not already otherwise completed normally.
onMalformedInput(CodingErrorAction) - Method in class java.nio.charset.CharsetDecoder
Changes this decoder's action for malformed-input errors.
onMalformedInput(CodingErrorAction) - Method in class java.nio.charset.CharsetEncoder
Changes this encoder's action for malformed-input errors.
onRegistration(ServiceRegistry, Class<?>) - Method in class javax.imageio.spi.IIOServiceProvider
A callback that will be called exactly once after the Spi class has been instantiated and registered in a ServiceRegistry.
onRegistration(ServiceRegistry, Class<?>) - Method in interface javax.imageio.spi.RegisterableService
Called when an object implementing this interface is added to the given category of the given registry.
onStart() - Method in class java.util.concurrent.ForkJoinWorkerThread
Initializes internal state after construction but before processing any tasks.
onTermination(Throwable) - Method in class java.util.concurrent.ForkJoinWorkerThread
Performs cleanup associated with termination of this worker thread.
onUnmappableCharacter(CodingErrorAction) - Method in class java.nio.charset.CharsetDecoder
Changes this decoder's action for unmappable-character errors.
onUnmappableCharacter(CodingErrorAction) - Method in class java.nio.charset.CharsetEncoder
Changes this encoder's action for unmappable-character errors.
OP_ACCEPT - Static variable in class java.nio.channels.SelectionKey
Operation-set bit for socket-accept operations.
OP_CONNECT - Static variable in class java.nio.channels.SelectionKey
Operation-set bit for socket-connect operations.
op_name() - Method in class org.omg.CORBA.ServerRequest
Deprecated.
use operation()
OP_READ - Static variable in class java.nio.channels.SelectionKey
Operation-set bit for read operations.
OP_WRITE - Static variable in class java.nio.channels.SelectionKey
Operation-set bit for write operations.
OPAQUE - Static variable in interface java.awt.Transparency
Represents image data that is guaranteed to be completely opaque, meaning that all pixels have an alpha value of 1.0.
OPAQUE - Static variable in class javax.accessibility.AccessibleState
Indicates this object paints every pixel within its rectangular region.
OPC_LIFE_OVER - Static variable in class javax.print.attribute.standard.PrinterStateReason
The optical photo conductor is no longer functioning.
OPC_NEAR_EOL - Static variable in class javax.print.attribute.standard.PrinterStateReason
The optical photo conductor is near end of life.
open(File) - Method in class java.awt.Desktop
Launches the associated application to open the file.
OPEN - Static variable in class java.awt.geom.Arc2D
The closure type for an open arc with no path segments connecting the two ends of the arc segment.
open(Path, Set<? extends OpenOption>, ExecutorService, FileAttribute<?>...) - Static method in class java.nio.channels.AsynchronousFileChannel
Opens or creates a file for reading and/or writing, returning an asynchronous file channel to access the file.
open(Path, OpenOption...) - Static method in class java.nio.channels.AsynchronousFileChannel
Opens or creates a file for reading and/or writing, returning an asynchronous file channel to access the file.
open(AsynchronousChannelGroup) - Static method in class java.nio.channels.AsynchronousServerSocketChannel
Opens an asynchronous server-socket channel.
open() - Static method in class java.nio.channels.AsynchronousServerSocketChannel
Opens an asynchronous server-socket channel.
open(AsynchronousChannelGroup) - Static method in class java.nio.channels.AsynchronousSocketChannel
Opens an asynchronous socket channel.
open() - Static method in class java.nio.channels.AsynchronousSocketChannel
Opens an asynchronous socket channel.
open() - Static method in class java.nio.channels.DatagramChannel
Opens a datagram channel.
open(ProtocolFamily) - Static method in class java.nio.channels.DatagramChannel
Opens a datagram channel.
open(Path, Set<? extends OpenOption>, FileAttribute<?>...) - Static method in class java.nio.channels.FileChannel
Opens or creates a file, returning a file channel to access the file.
open(Path, OpenOption...) - Static method in class java.nio.channels.FileChannel
Opens or creates a file, returning a file channel to access the file.
open() - Static method in class java.nio.channels.Pipe
Opens a pipe.
open() - Static method in class java.nio.channels.Selector
Opens a selector.
open() - Static method in class java.nio.channels.ServerSocketChannel
Opens a server-socket channel.
open() - Static method in class java.nio.channels.SocketChannel
Opens a socket channel.
open(SocketAddress) - Static method in class java.nio.channels.SocketChannel
Opens a socket channel and connects it to a remote address.
open() - Method in interface javax.sound.midi.MidiDevice
Opens the device, indicating that it should now acquire any system resources it requires and become operational.
open(AudioFormat, byte[], int, int) - Method in interface javax.sound.sampled.Clip
Opens the clip, meaning that it should acquire any required system resources and become operational.
open(AudioInputStream) - Method in interface javax.sound.sampled.Clip
Opens the clip with the format and audio data present in the provided audio input stream.
open() - Method in interface javax.sound.sampled.Line
Opens the line, indicating that it should acquire any required system resources and become operational.
OPEN - Static variable in class javax.sound.sampled.LineEvent.Type
A type of event that is sent when a line opens, reserving system resources for itself.
open(AudioFormat, int) - Method in interface javax.sound.sampled.SourceDataLine
Opens the line with the specified format and suggested buffer size, causing the line to acquire any required system resources and become operational.
open(AudioFormat) - Method in interface javax.sound.sampled.SourceDataLine
Opens the line with the specified format, causing the line to acquire any required system resources and become operational.
open(AudioFormat, int) - Method in interface javax.sound.sampled.TargetDataLine
Opens the line with the specified format and requested buffer size, causing the line to acquire any required system resources and become operational.
open(AudioFormat) - Method in interface javax.sound.sampled.TargetDataLine
Opens the line with the specified format, causing the line to acquire any required system resources and become operational.
OPEN_DELETE - Static variable in class java.util.zip.ZipFile
Mode flag to open a zip file and mark it for deletion.
OPEN_DIALOG - Static variable in class javax.swing.JFileChooser
Type value indicating that the JFileChooser supports an "Open" file operation.
OPEN_FAILURE - Static variable in class java.util.logging.ErrorManager
OPEN_FAILURE is used when an open of an output stream fails.
OPEN_READ - Static variable in class java.util.zip.ZipFile
Mode flag to open a zip file for reading.
OPEN_TYPE_FIELD - Static variable in class javax.management.JMX
The name of the openType field.
OpenAction() - Constructor for class javax.swing.plaf.basic.BasicDesktopPaneUI.OpenAction
openAsynchronousChannelGroup(int, ThreadFactory) - Method in class java.nio.channels.spi.AsynchronousChannelProvider
Constructs a new asynchronous channel group with a fixed thread pool.
openAsynchronousChannelGroup(ExecutorService, int) - Method in class java.nio.channels.spi.AsynchronousChannelProvider
Constructs a new asynchronous channel group with the given thread pool.
openAsynchronousServerSocketChannel(AsynchronousChannelGroup) - Method in class java.nio.channels.spi.AsynchronousChannelProvider
Opens an asynchronous server-socket channel.
openAsynchronousSocketChannel(AsynchronousChannelGroup) - Method in class java.nio.channels.spi.AsynchronousChannelProvider
Opens an asynchronous socket channel.
openButtonMnemonic - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
openButtonText - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
openButtonToolTipText - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
openConnection() - Method in class java.net.URL
Returns a URLConnection instance that represents a connection to the remote object referred to by the URL.
openConnection(Proxy) - Method in class java.net.URL
Same as URL.openConnection(), except that the connection will be made through the specified proxy; Protocol handlers that do not support proxing will ignore the proxy parameter and make a normal connection.
openConnection(URL) - Method in class java.net.URLStreamHandler
Opens a connection to the object referenced by the URL argument.
openConnection(URL, Proxy) - Method in class java.net.URLStreamHandler
Same as openConnection(URL), except that the connection will be made through the specified proxy; Protocol handlers that do not support proxying will ignore the proxy parameter and make a normal connection.
OpenDataException - Exception in javax.management.openmbean
This checked exception is thrown when an open type, an open data or an open MBean metadata info instance could not be constructed because one or more validity constraints were not met.
OpenDataException() - Constructor for exception javax.management.openmbean.OpenDataException
An OpenDataException with no detail message.
OpenDataException(String) - Constructor for exception javax.management.openmbean.OpenDataException
An OpenDataException with a detail message.
openDatagramChannel() - Method in class java.nio.channels.spi.SelectorProvider
Opens a datagram channel.
openDatagramChannel(ProtocolFamily) - Method in class java.nio.channels.spi.SelectorProvider
Opens a datagram channel.
OPENED - Static variable in class javax.management.remote.JMXConnectionNotification
Notification type string for a connection-opened notification.
openFrame(JInternalFrame) - Method in class javax.swing.DefaultDesktopManager
Normally this method will not be called.
openFrame(JInternalFrame) - Method in interface javax.swing.DesktopManager
If possible, display this frame in an appropriate location.
openIcon - Variable in class javax.swing.tree.DefaultTreeCellRenderer
Icon used to show non-leaf nodes that are expanded.
openInputStream() - Method in interface javax.tools.FileObject
Gets an InputStream for this file object.
openInputStream() - Method in class javax.tools.ForwardingFileObject
openInputStream() - Method in class javax.tools.SimpleJavaFileObject
This implementation always throws UnsupportedOperationException.
OpenMBeanAttributeInfo - Interface in javax.management.openmbean
Describes an attribute of an open MBean.
OpenMBeanAttributeInfoSupport - Class in javax.management.openmbean
Describes an attribute of an open MBean.
OpenMBeanAttributeInfoSupport(String, String, OpenType<?>, boolean, boolean, boolean) - Constructor for class javax.management.openmbean.OpenMBeanAttributeInfoSupport
Constructs an OpenMBeanAttributeInfoSupport instance, which describes the attribute of an open MBean with the specified name, openType and description, and the specified read/write access properties.
OpenMBeanAttributeInfoSupport(String, String, OpenType<?>, boolean, boolean, boolean, Descriptor) - Constructor for class javax.management.openmbean.OpenMBeanAttributeInfoSupport
Constructs an OpenMBeanAttributeInfoSupport instance, which describes the attribute of an open MBean with the specified name, openType, description, read/write access properties, and Descriptor.
OpenMBeanAttributeInfoSupport(String, String, OpenType<T>, boolean, boolean, boolean, T) - Constructor for class javax.management.openmbean.OpenMBeanAttributeInfoSupport
Constructs an OpenMBeanAttributeInfoSupport instance, which describes the attribute of an open MBean with the specified name, openType, description and defaultValue, and the specified read/write access properties.
OpenMBeanAttributeInfoSupport(String, String, OpenType<T>, boolean, boolean, boolean, T, T[]) - Constructor for class javax.management.openmbean.OpenMBeanAttributeInfoSupport
Constructs an OpenMBeanAttributeInfoSupport instance, which describes the attribute of an open MBean with the specified name, openType, description, defaultValue and legalValues, and the specified read/write access properties.
OpenMBeanAttributeInfoSupport(String, String, OpenType<T>, boolean, boolean, boolean, T, Comparable<T>, Comparable<T>) - Constructor for class javax.management.openmbean.OpenMBeanAttributeInfoSupport
Constructs an OpenMBeanAttributeInfoSupport instance, which describes the attribute of an open MBean, with the specified name, openType, description, defaultValue, minValue and maxValue.
OpenMBeanConstructorInfo - Interface in javax.management.openmbean
Describes a constructor of an Open MBean.
OpenMBeanConstructorInfoSupport - Class in javax.management.openmbean
Describes a constructor of an Open MBean.
OpenMBeanConstructorInfoSupport(String, String, OpenMBeanParameterInfo[]) - Constructor for class javax.management.openmbean.OpenMBeanConstructorInfoSupport
Constructs an OpenMBeanConstructorInfoSupport instance, which describes the constructor of a class of open MBeans with the specified name, description and signature.
OpenMBeanConstructorInfoSupport(String, String, OpenMBeanParameterInfo[], Descriptor) - Constructor for class javax.management.openmbean.OpenMBeanConstructorInfoSupport
Constructs an OpenMBeanConstructorInfoSupport instance, which describes the constructor of a class of open MBeans with the specified name, description, signature, and descriptor.
OpenMBeanInfo - Interface in javax.management.openmbean
Describes an Open MBean: an Open MBean is recognized as such if its getMBeanInfo() method returns an instance of a class which implements the OpenMBeanInfo interface, typically OpenMBeanInfoSupport.
OpenMBeanInfoSupport - Class in javax.management.openmbean
The OpenMBeanInfoSupport class describes the management information of an open MBean: it is a subclass of MBeanInfo, and it implements the OpenMBeanInfo interface.
OpenMBeanInfoSupport(String, String, OpenMBeanAttributeInfo[], OpenMBeanConstructorInfo[], OpenMBeanOperationInfo[], MBeanNotificationInfo[]) - Constructor for class javax.management.openmbean.OpenMBeanInfoSupport
Constructs an OpenMBeanInfoSupport instance, which describes a class of open MBeans with the specified className, description, openAttributes, openConstructors , openOperations and notifications.
OpenMBeanInfoSupport(String, String, OpenMBeanAttributeInfo[], OpenMBeanConstructorInfo[], OpenMBeanOperationInfo[], MBeanNotificationInfo[], Descriptor) - Constructor for class javax.management.openmbean.OpenMBeanInfoSupport
Constructs an OpenMBeanInfoSupport instance, which describes a class of open MBeans with the specified className, description, openAttributes, openConstructors , openOperations, notifications, and descriptor.
OpenMBeanOperationInfo - Interface in javax.management.openmbean
Describes an operation of an Open MBean.
OpenMBeanOperationInfoSupport - Class in javax.management.openmbean
Describes an operation of an Open MBean.
OpenMBeanOperationInfoSupport(String, String, OpenMBeanParameterInfo[], OpenType<?>, int) - Constructor for class javax.management.openmbean.OpenMBeanOperationInfoSupport
Constructs an OpenMBeanOperationInfoSupport instance, which describes the operation of a class of open MBeans, with the specified name, description, signature, returnOpenType and impact.
OpenMBeanOperationInfoSupport(String, String, OpenMBeanParameterInfo[], OpenType<?>, int, Descriptor) - Constructor for class javax.management.openmbean.OpenMBeanOperationInfoSupport
Constructs an OpenMBeanOperationInfoSupport instance, which describes the operation of a class of open MBeans, with the specified name, description, signature, returnOpenType, impact, and descriptor.
OpenMBeanParameterInfo - Interface in javax.management.openmbean
Describes a parameter used in one or more operations or constructors of an open MBean.
OpenMBeanParameterInfoSupport - Class in javax.management.openmbean
Describes a parameter used in one or more operations or constructors of an open MBean.
OpenMBeanParameterInfoSupport(String, String, OpenType<?>) - Constructor for class javax.management.openmbean.OpenMBeanParameterInfoSupport
Constructs an OpenMBeanParameterInfoSupport instance, which describes the parameter used in one or more operations or constructors of a class of open MBeans, with the specified name, openType and description.
OpenMBeanParameterInfoSupport(String, String, OpenType<?>, Descriptor) - Constructor for class javax.management.openmbean.OpenMBeanParameterInfoSupport
Constructs an OpenMBeanParameterInfoSupport instance, which describes the parameter used in one or more operations or constructors of a class of open MBeans, with the specified name, openType, description, and descriptor.
OpenMBeanParameterInfoSupport(String, String, OpenType<T>, T) - Constructor for class javax.management.openmbean.OpenMBeanParameterInfoSupport
Constructs an OpenMBeanParameterInfoSupport instance, which describes the parameter used in one or more operations or constructors of a class of open MBeans, with the specified name, openType, description and defaultValue.
OpenMBeanParameterInfoSupport(String, String, OpenType<T>, T, T[]) - Constructor for class javax.management.openmbean.OpenMBeanParameterInfoSupport
Constructs an OpenMBeanParameterInfoSupport instance, which describes the parameter used in one or more operations or constructors of a class of open MBeans, with the specified name, openType, description, defaultValue and legalValues.
OpenMBeanParameterInfoSupport(String, String, OpenType<T>, T, Comparable<T>, Comparable<T>) - Constructor for class javax.management.openmbean.OpenMBeanParameterInfoSupport
Constructs an OpenMBeanParameterInfoSupport instance, which describes the parameter used in one or more operations or constructors of a class of open MBeans, with the specified name, openType, description, defaultValue, minValue and maxValue.
openMenuKey - Variable in class javax.swing.plaf.basic.BasicInternalFrameUI
Deprecated.
As of Java 2 platform v1.3.
OpenOption - Interface in java.nio.file
An object that configures how to open or create a file.
openOutputStream() - Method in interface javax.tools.FileObject
Gets an OutputStream for this file object.
openOutputStream() - Method in class javax.tools.ForwardingFileObject
openOutputStream() - Method in class javax.tools.SimpleJavaFileObject
This implementation always throws UnsupportedOperationException.
openPipe() - Method in class java.nio.channels.spi.SelectorProvider
Opens a pipe.
openReader(boolean) - Method in interface javax.tools.FileObject
Gets a reader for this object.
openReader(boolean) - Method in class javax.tools.ForwardingFileObject
openReader(boolean) - Method in class javax.tools.SimpleJavaFileObject
Wraps the result of SimpleJavaFileObject.getCharContent(boolean) in a Reader.
openSelector() - Method in class java.nio.channels.spi.SelectorProvider
Opens a selector.
openServerSocketChannel() - Method in class java.nio.channels.spi.SelectorProvider
Opens a server-socket channel.
openSocketChannel() - Method in class java.nio.channels.spi.SelectorProvider
Opens a socket channel.
openStream() - Method in class java.net.URL
Opens a connection to this URL and returns an InputStream for reading from that connection.
OpenType - Interface in java.awt.font
The OpenType interface represents OpenType and TrueType fonts.
OpenType<T> - Class in javax.management.openmbean
The OpenType class is the parent abstract class of all classes which describe the actual open type of open data values.
OpenType(String, String, String) - Constructor for class javax.management.openmbean.OpenType
Constructs an OpenType instance (actually a subclass instance as OpenType is abstract), checking for the validity of the given parameters.
openWriter() - Method in interface javax.tools.FileObject
Gets a Writer for this file object.
openWriter() - Method in class javax.tools.ForwardingFileObject
openWriter() - Method in class javax.tools.SimpleJavaFileObject
Wraps the result of openOutputStream in a Writer.
OPERATING_SYSTEM_MXBEAN_NAME - Static variable in class java.lang.management.ManagementFactory
String representation of the ObjectName for the OperatingSystemMXBean.
OperatingSystemMXBean - Interface in java.lang.management
The management interface for the operating system on which the Java virtual machine is running.
Operation - Class in java.rmi.server
Deprecated.
no replacement
Operation(String) - Constructor for class java.rmi.server.Operation
Deprecated.
no replacement
operation() - Method in class org.omg.CORBA.Request
Retrieves the name of the method to be invoked.
operation() - Method in class org.omg.CORBA.ServerRequest
Throws an org.omg.CORBA.NO_IMPLEMENT exception.
operation() - Method in interface org.omg.PortableInterceptor.RequestInfoOperations
Returns the name of the operation being invoked.
operation_context() - Method in interface org.omg.PortableInterceptor.RequestInfoOperations
Returns an array of String objects containing the contexts being sent on the request.
OperationNotSupportedException - Exception in javax.naming
This exception is thrown when a context implementation does not support the operation being invoked.
OperationNotSupportedException() - Constructor for exception javax.naming.OperationNotSupportedException
Constructs a new instance of OperationNotSupportedException.
OperationNotSupportedException(String) - Constructor for exception javax.naming.OperationNotSupportedException
Constructs a new instance of OperationNotSupportedException using an explanation.
OperationsException - Exception in javax.management
Represents exceptions thrown in the MBean server when performing operations on MBeans.
OperationsException() - Constructor for exception javax.management.OperationsException
Default constructor.
OperationsException(String) - Constructor for exception javax.management.OperationsException
Constructor that allows a specific error message to be specified.
OPTICAL_CHARACTER_RECOGNITION - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Optical Character Recognition" Unicode character block.
OPTION - Static variable in class javax.swing.text.html.HTML.Tag
Option - Class in javax.swing.text.html
Value for the ListModel used to represent <option> elements.
Option(AttributeSet) - Constructor for class javax.swing.text.html.Option
Creates a new Option object.
OPTION_PANE - Static variable in class javax.accessibility.AccessibleRole
A specialized pane whose primary use is inside a DIALOG
OPTION_PANE - Static variable in class javax.swing.plaf.synth.Region
OptionPane region.
OPTION_TYPE_PROPERTY - Static variable in class javax.swing.JOptionPane
Bound property name for optionType.
Optional<T> - Class in java.util
A container object which may or may not contain a non-null value.
OPTIONAL - Static variable in class javax.security.auth.login.AppConfigurationEntry.LoginModuleControlFlag
Optional LoginModule.
OptionalDataException - Exception in java.io
Exception indicating the failure of an object read operation due to unread primitive data, or the end of data belonging to a serialized object in the stream.
OptionalDouble - Class in java.util
A container object which may or may not contain a double value.
optionalEnd() - Method in class java.time.format.DateTimeFormatterBuilder
Ends an optional section.
OptionalInt - Class in java.util
A container object which may or may not contain a int value.
OptionalLong - Class in java.util
A container object which may or may not contain a long value.
optionalStart() - Method in class java.time.format.DateTimeFormatterBuilder
Mark the start of an optional section.
OptionChecker - Interface in javax.tools
Interface for recognizing options.
OptionDialogBorder() - Constructor for class javax.swing.plaf.metal.MetalBorders.OptionDialogBorder
optionPane - Variable in class javax.swing.plaf.basic.BasicOptionPaneUI
JOptionPane that the receiver is providing the look and feel for.
OptionPaneUI - Class in javax.swing.plaf
Pluggable look and feel interface for JOptionPane.
OptionPaneUI() - Constructor for class javax.swing.plaf.OptionPaneUI
options - Variable in class javax.swing.JOptionPane
Options to display to the user.
OPTIONS_PROPERTY - Static variable in class javax.swing.JOptionPane
Bound property name for option.
optionType - Variable in class javax.swing.JOptionPane
Option type, one of DEFAULT_OPTION, YES_NO_OPTION, YES_NO_CANCEL_OPTION or OK_CANCEL_OPTION.
or(BigInteger) - Method in class java.math.BigInteger
Returns a BigInteger whose value is (this | val).
or(BitSet) - Method in class java.util.BitSet
Performs a logical OR of this bit set with the bit set argument.
or(BiPredicate<? super T, ? super U>) - Method in interface java.util.function.BiPredicate
Returns a composed predicate that represents a short-circuiting logical OR of this predicate and another.
or(DoublePredicate) - Method in interface java.util.function.DoublePredicate
Returns a composed predicate that represents a short-circuiting logical OR of this predicate and another.
or(IntPredicate) - Method in interface java.util.function.IntPredicate
Returns a composed predicate that represents a short-circuiting logical OR of this predicate and another.
or(LongPredicate) - Method in interface java.util.function.LongPredicate
Returns a composed predicate that represents a short-circuiting logical OR of this predicate and another.
or(Predicate<? super T>) - Method in interface java.util.function.Predicate
Returns a composed predicate that represents a short-circuiting logical OR of this predicate and another.
or(QueryExp, QueryExp) - Static method in class javax.management.Query
Returns a query expression that is the disjunction of two other query expressions.
orange - Static variable in class java.awt.Color
The color orange.
ORANGE - Static variable in class java.awt.Color
The color orange.
orb() - Method in interface javax.rmi.CORBA.Tie
Returns the ORB for this tie.
orb(ORB) - Method in interface javax.rmi.CORBA.Tie
Sets the ORB for this tie.
ORB - Class in org.omg.CORBA
A class providing APIs for the CORBA Object Request Broker features.
ORB() - Constructor for class org.omg.CORBA.ORB
orb(Object) - Method in class org.omg.CORBA.portable.Delegate
Provides a reference to the orb associated with its parameter.
orb() - Method in class org.omg.CORBA.portable.InputStream
Returns the ORB that created this InputStream.
orb() - Method in class org.omg.CORBA.portable.OutputStream
Returns the ORB that created this OutputStream.
ORB - Class in org.omg.CORBA_2_3
A class extending org.omg.CORBA.ORB to make the ORB portable under the OMG CORBA version 2.3 specification.
ORB() - Constructor for class org.omg.CORBA_2_3.ORB
orb(Servant) - Method in interface org.omg.PortableServer.portable.Delegate
Convenience method that returns the instance of the ORB currently associated with the Servant.
ORB_CTRL_MODEL - Static variable in class org.omg.PortableServer.ThreadPolicyValue
orb_id() - Method in interface org.omg.PortableInterceptor.ObjectReferenceTemplate
orb_id() - Method in interface org.omg.PortableInterceptor.ORBInitInfoOperations
Returns the ID of the ORB being initialized.
orb_id() - Method in interface org.omg.PortableInterceptor.ServerRequestInfoOperations
Returns the ID that was used to create the ORB.
ORBIdHelper - Class in org.omg.PortableInterceptor
org/omg/PortableInterceptor/ORBIdHelper.java .
ORBIdHelper() - Constructor for class org.omg.PortableInterceptor.ORBIdHelper
ORBInitializer - Interface in org.omg.PortableInterceptor
Facilitates interceptor registration and ORB initialization.
ORBInitializerOperations - Interface in org.omg.PortableInterceptor
Facilitates interceptor registration and ORB initialization.
ORBInitInfo - Interface in org.omg.PortableInterceptor
Passed to each ORBInitializer, allowing it to to register interceptors and perform other duties while the ORB is initializing.
ORBInitInfoOperations - Interface in org.omg.PortableInterceptor
Passed to each ORBInitializer, allowing it to to register interceptors and perform other duties while the ORB is initializing.
order() - Method in class java.nio.ByteBuffer
Retrieves this buffer's byte order.
order(ByteOrder) - Method in class java.nio.ByteBuffer
Modifies this buffer's byte order.
order() - Method in class java.nio.CharBuffer
Retrieves this buffer's byte order.
order() - Method in class java.nio.DoubleBuffer
Retrieves this buffer's byte order.
order() - Method in class java.nio.FloatBuffer
Retrieves this buffer's byte order.
order() - Method in class java.nio.IntBuffer
Retrieves this buffer's byte order.
order() - Method in class java.nio.LongBuffer
Retrieves this buffer's byte order.
order() - Method in class java.nio.ShortBuffer
Retrieves this buffer's byte order.
ORDERED - Static variable in interface java.util.Spliterator
Characteristic value signifying that an encounter order is defined for elements.
ordered - Variable in class javax.naming.directory.BasicAttribute
A flag for recording whether this attribute's values are ordered.
ordinal() - Method in class java.lang.Enum
Returns the ordinal of this enumeration constant (its position in its enum declaration, where the initial constant is assigned an ordinal of zero).
ordinaryChar(int) - Method in class java.io.StreamTokenizer
Specifies that the character argument is "ordinary" in this tokenizer.
ordinaryChars(int, int) - Method in class java.io.StreamTokenizer
Specifies that all characters c in the range low <= c <= high are "ordinary" in this tokenizer.
orElse(T) - Method in class java.util.Optional
Return the value if present, otherwise return other.
orElse(double) - Method in class java.util.OptionalDouble
Return the value if present, otherwise return other.
orElse(int) - Method in class java.util.OptionalInt
Return the value if present, otherwise return other.
orElse(long) - Method in class java.util.OptionalLong
Return the value if present, otherwise return other.
orElseGet(Supplier<? extends T>) - Method in class java.util.Optional
Return the value if present, otherwise invoke other and return the result of that invocation.
orElseGet(DoubleSupplier) - Method in class java.util.OptionalDouble
Return the value if present, otherwise invoke other and return the result of that invocation.
orElseGet(IntSupplier) - Method in class java.util.OptionalInt
Return the value if present, otherwise invoke other and return the result of that invocation.
orElseGet(LongSupplier) - Method in class java.util.OptionalLong
Return the value if present, otherwise invoke other and return the result of that invocation.
orElseThrow(Supplier<? extends X>) - Method in class java.util.Optional
Return the contained value, if present, otherwise throw an exception to be created by the provided supplier.
orElseThrow(Supplier<X>) - Method in class java.util.OptionalDouble
Return the contained value, if present, otherwise throw an exception to be created by the provided supplier.
orElseThrow(Supplier<X>) - Method in class java.util.OptionalInt
Return the contained value, if present, otherwise throw an exception to be created by the provided supplier.
orElseThrow(Supplier<X>) - Method in class java.util.OptionalLong
Return the contained value, if present, otherwise throw an exception to be created by the provided supplier.
orFilter(Iterable<? extends RowFilter<? super M, ? super I>>) - Static method in class javax.swing.RowFilter
Returns a RowFilter that includes entries if any of the supplied filters includes the entry.
org.ietf.jgss - package org.ietf.jgss
This package presents a framework that allows application developers to make use of security services like authentication, data integrity and data confidentiality from a variety of underlying security mechanisms like Kerberos, using a unified API.
org.omg.CORBA - package org.omg.CORBA
Provides the mapping of the OMG CORBA APIs to the JavaTM programming language, including the class ORB, which is implemented so that a programmer can use it as a fully-functional Object Request Broker (ORB).
org.omg.CORBA.DynAnyPackage - package org.omg.CORBA.DynAnyPackage
Provides the exceptions used with the DynAny interface (InvalidValue, Invalid, InvalidSeq, and TypeMismatch).
org.omg.CORBA.ORBPackage - package org.omg.CORBA.ORBPackage
Provides the exception InvalidName, which is thrown by the method ORB.resolve_initial_references and the exception InconsistentTypeCode, which is thrown by the Dynamic Any creation methods in the ORB class.
org.omg.CORBA.portable - package org.omg.CORBA.portable
Provides a portability layer, that is, a set of ORB APIs that makes it possible for code generated by one vendor to run on another vendor's ORB.
org.omg.CORBA.TypeCodePackage - package org.omg.CORBA.TypeCodePackage
Provides the user-defined exceptions BadKind and Bounds, which are thrown by methods in in the class TypeCode.
org.omg.CORBA_2_3 - package org.omg.CORBA_2_3
The CORBA_2_3 package defines additions to existing CORBA interfaces in the Java[tm] Standard Edition 6. These changes occurred in recent revisions to the CORBA API defined by the OMG. The new methods were added to interfaces derived from the corresponding interfaces in the CORBA package. This provides backward compatibility and avoids breaking the JCK tests.
org.omg.CORBA_2_3.portable - package org.omg.CORBA_2_3.portable
Provides methods for the input and output of value types, and contains other updates to the org/omg/CORBA/portable package.
org.omg.CosNaming - package org.omg.CosNaming
Provides a naming service for Java IDL.
org.omg.CosNaming.NamingContextExtPackage - package org.omg.CosNaming.NamingContextExtPackage
This package contains the following classes, which are used in org.omg.CosNaming.NamingContextExt:
org.omg.CosNaming.NamingContextPackage - package org.omg.CosNaming.NamingContextPackage
This package contains Exception classes for the org.omg.CosNaming package.
org.omg.Dynamic - package org.omg.Dynamic
This package contains the Dynamic module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.9.
org.omg.DynamicAny - package org.omg.DynamicAny
Provides classes and interfaces that enable traversal of the data value associated with an any at runtime, and extraction of the primitive constituents of the data value.
org.omg.DynamicAny.DynAnyFactoryPackage - package org.omg.DynamicAny.DynAnyFactoryPackage
This package contains classes and exceptions from the DynAnyFactory interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.2.
org.omg.DynamicAny.DynAnyPackage - package org.omg.DynamicAny.DynAnyPackage
This package contains classes and exceptions from the DynAny interface of the DynamicAny module specified in the OMG The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 9.2.
org.omg.IOP - package org.omg.IOP
This package contains the IOP module specified in the OMG document The Common Object Request Broker: Architecture and Specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07, section 13.6.
org.omg.IOP.CodecFactoryPackage - package org.omg.IOP.CodecFactoryPackage
This package contains the exceptions specified in the IOP::CodeFactory interface (as part of the Portable Interceptors spec).
org.omg.IOP.CodecPackage - package org.omg.IOP.CodecPackage
This package is generated from the IOP::Codec IDL interface definition.
org.omg.Messaging - package org.omg.Messaging
This package contains the Messaging module specified in the OMG CORBA Messaging specification, http://cgi.omg.org/cgi-bin/doc?formal/99-10-07.
org.omg.PortableInterceptor - package org.omg.PortableInterceptor
Provides a mechanism to register ORB hooks through which ORB services can intercept the normal flow of execution of the ORB.
org.omg.PortableInterceptor.ORBInitInfoPackage - package org.omg.PortableInterceptor.ORBInitInfoPackage
This package contains the exceptions and typedefs from the ORBInitInfo local interface of the PortableInterceptor module specified in the OMG Portable Interceptor specification, http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06, section 21.7.2.
org.omg.PortableServer - package org.omg.PortableServer
Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
org.omg.PortableServer.CurrentPackage - package org.omg.PortableServer.CurrentPackage
Provides method implementations with access to the identity of the object on which the method was invoked.
org.omg.PortableServer.POAManagerPackage - package org.omg.PortableServer.POAManagerPackage
Encapsulates the processing state of the POAs it is associated with.
org.omg.PortableServer.POAPackage - package org.omg.PortableServer.POAPackage
Allows programmers to construct object implementations that are portable between different ORB products.
org.omg.PortableServer.portable - package org.omg.PortableServer.portable
Provides classes and interfaces for making the server side of your applications portable across multivendor ORBs.
org.omg.PortableServer.ServantLocatorPackage - package org.omg.PortableServer.ServantLocatorPackage
Provides classes and interfaces for locating the servant.
org.omg.SendingContext - package org.omg.SendingContext
Provides support for the marshalling of value types.
org.omg.stub.java.rmi - package org.omg.stub.java.rmi
Contains RMI-IIOP Stubs for the Remote types that occur in the java.rmi package.
org.w3c.dom - package org.w3c.dom
Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.
org.w3c.dom.bootstrap - package org.w3c.dom.bootstrap
org.w3c.dom.events - package org.w3c.dom.events
org.w3c.dom.ls - package org.w3c.dom.ls
org.w3c.dom.views - package org.w3c.dom.views
org.xml.sax - package org.xml.sax
This package provides the core SAX APIs.
org.xml.sax.ext - package org.xml.sax.ext
This package contains interfaces to SAX2 facilities that conformant SAX drivers won't necessarily support.
org.xml.sax.helpers - package org.xml.sax.helpers
This package contains "helper" classes, including support for bootstrapping SAX-based applications.
orientation - Variable in class javax.swing.JProgressBar
Whether the progress bar is horizontal or vertical.
orientation - Variable in class javax.swing.JScrollBar
orientation - Variable in class javax.swing.JSlider
Whether the slider is horizontal or vertical The default is horizontal.
orientation - Variable in class javax.swing.JSplitPane
How the views are split.
orientation - Variable in class javax.swing.plaf.basic.BasicSplitPaneDivider
Orientation of the JSplitPane.
Orientation - Static variable in class javax.swing.text.StyleConstants
Orientation for a paragraph.
ORIENTATION_PROPERTY - Static variable in class javax.swing.JSplitPane
Bound property name for orientation (horizontal or vertical).
OrientationRequested - Class in javax.print.attribute.standard
Class OrientationRequested is a printing attribute class, an enumeration, that indicates the desired orientation for printed print-stream pages; it does not describe the orientation of the client-supplied print-stream pages.
OrientationRequested(int) - Constructor for class javax.print.attribute.standard.OrientationRequested
Construct a new orientation requested enumeration value with the given integer value.
origin - Variable in class javax.swing.plaf.basic.BasicToolBarUI.DockingListener
ORIGINAL_TYPE_FIELD - Static variable in class javax.management.JMX
The name of the originalType field.
originalEx - Variable in exception org.omg.CORBA.portable.UnknownException
A throwable--the original exception that was wrapped in a CORBA UnknownException.
OriginateDirection - Static variable in class javax.swing.text.DefaultStyledDocument.ElementSpec
A possible value for getDirection.
originatingProvider - Variable in class javax.imageio.ImageReader
The ImageReaderSpi that instantiated this object, or null if its identity is not known or none exists.
originatingProvider - Variable in class javax.imageio.ImageWriter
The ImageWriterSpi that instantiated this object, or null if its identity is not known or none exists.
origmodel - Variable in class java.awt.image.RGBImageFilter
The ColorModel to be replaced by newmodel when the user calls substituteColorModel.
ORIYA - Static variable in class java.awt.font.NumericShaper
Identifies the ORIYA range and decimal base.
ORIYA - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Oriya" Unicode character block.
OSMANYA - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Osmanya" Unicode character block.
oStart - Variable in class javax.swing.text.html.parser.Element
OTHER - Static variable in class java.sql.Types
The constant in the Java programming language that indicates that the SQL type is database-specific and gets mapped to a Java object that can be accessed via the methods getObject and setObject.
OTHER - Static variable in class javax.print.attribute.standard.PrinterStateReason
The printer has detected an error other than ones listed below.
OTHER_LETTER - Static variable in class java.lang.Character
General category "Lo" in the Unicode specification.
OTHER_NUMBER - Static variable in class java.lang.Character
General category "No" in the Unicode specification.
OTHER_PUNCTUATION - Static variable in class java.lang.Character
General category "Po" in the Unicode specification.
OTHER_SYMBOL - Static variable in class java.lang.Character
General category "So" in the Unicode specification.
othersDeletesAreVisible(int) - Method in interface java.sql.DatabaseMetaData
Retrieves whether deletes made by others are visible.
othersInsertsAreVisible(int) - Method in interface java.sql.DatabaseMetaData
Retrieves whether inserts made by others are visible.
othersUpdatesAreVisible(int) - Method in interface java.sql.DatabaseMetaData
Retrieves whether updates made by others are visible.
out - Static variable in class java.io.FileDescriptor
A handle to the standard output stream.
out - Variable in class java.io.FilterOutputStream
The underlying output stream to be filtered.
out - Variable in class java.io.FilterWriter
The underlying character-output stream.
out - Variable in class java.io.PipedInputStream
The index of the position in the circular buffer at which the next byte of data will be read by this piped input stream.
out - Variable in class java.io.PrintWriter
The underlying character-output stream of this PrintWriter.
out - Static variable in class java.lang.System
The "standard" output stream.
out() - Method in class java.util.Formatter
Returns the destination for the output.
OUT_BOTTOM - Static variable in class java.awt.geom.Rectangle2D
The bitmask that indicates that a point lies below this Rectangle2D.
OUT_LEFT - Static variable in class java.awt.geom.Rectangle2D
The bitmask that indicates that a point lies to the left of this Rectangle2D.
OUT_RIGHT - Static variable in class java.awt.geom.Rectangle2D
The bitmask that indicates that a point lies to the right of this Rectangle2D.
OUT_TOP - Static variable in class java.awt.geom.Rectangle2D
The bitmask that indicates that a point lies above this Rectangle2D.
OUTBOUND_MESSAGE_ATTACHMENTS - Static variable in interface javax.xml.ws.handler.MessageContext
Standard property: Map of attachments to a message for the outbound message, key is the MIME Content-ID, value is a DataHandler.
outcode(double, double) - Method in class java.awt.geom.Rectangle2D.Double
Determines where the specified coordinates lie with respect to this Rectangle2D.
outcode(double, double) - Method in class java.awt.geom.Rectangle2D.Float
Determines where the specified coordinates lie with respect to this Rectangle2D.
outcode(double, double) - Method in class java.awt.geom.Rectangle2D
Determines where the specified coordinates lie with respect to this Rectangle2D.
outcode(Point2D) - Method in class java.awt.geom.Rectangle2D
Determines where the specified Point2D lies with respect to this Rectangle2D.
outcode(double, double) - Method in class java.awt.Rectangle
Determines where the specified coordinates lie with respect to this Rectangle2D.
OUTLINE_DRAG_MODE - Static variable in class javax.swing.JDesktopPane
Indicates that an outline only of the item being dragged should appear inside the desktop pane.
OutOfMemoryError - Error in java.lang
Thrown when the Java Virtual Machine cannot allocate an object because it is out of memory, and no more memory could be made available by the garbage collector.
OutOfMemoryError() - Constructor for error java.lang.OutOfMemoryError
Constructs an OutOfMemoryError with no detail message.
OutOfMemoryError(String) - Constructor for error java.lang.OutOfMemoryError
Constructs an OutOfMemoryError with the specified detail message.
outpixbuf - Variable in class java.awt.image.ReplicateScaleFilter
A byte array initialized with a size of ReplicateScaleFilter.destWidth and used to deliver a row of pixel data to the ImageConsumer.
output - Variable in class javax.imageio.ImageWriter
The ImageOutputStream or other Object set by setOutput and retrieved by getOutput.
output(char[], int, int) - Method in class javax.swing.text.AbstractWriter
The last stop in writing out content.
output(char[], int, int) - Method in class javax.swing.text.html.HTMLWriter
This method is overriden to map any character entities, such as < to &lt;.
OUTPUT_AREA_ALMOST_FULL - Static variable in class javax.print.attribute.standard.PrinterStateReason
One or more output areas are almost full (e.g.
OUTPUT_AREA_FULL - Static variable in class javax.print.attribute.standard.PrinterStateReason
One or more output areas are full (e.g.
OUTPUT_TRAY_MISSING - Static variable in class javax.print.attribute.standard.PrinterStateReason
One or more output trays are not in the device.
outputClass - Variable in class javax.imageio.spi.ImageOutputStreamSpi
A Class object indicating the legal object type for use by the createInputStreamInstance method.
OutputDeviceAssigned - Class in javax.print.attribute.standard
Class OutputDeviceAssigned is a printing attribute class, a text attribute, that identifies the output device to which the service has assigned this job.
OutputDeviceAssigned(String, Locale) - Constructor for class javax.print.attribute.standard.OutputDeviceAssigned
Constructs a new output device assigned attribute with the given device name and locale.
OutputKeys - Class in javax.xml.transform
Provides string constants that can be used to set output properties for a Transformer, or to retrieve output properties from a Transformer or Templates object.
OutputStream - Class in java.io
This abstract class is the superclass of all classes representing an output stream of bytes.
OutputStream() - Constructor for class java.io.OutputStream
OutputStream - Class in org.omg.CORBA.portable
OuputStream is the Java API for writing IDL types to CDR marshal streams.
OutputStream() - Constructor for class org.omg.CORBA.portable.OutputStream
OutputStream - Class in org.omg.CORBA_2_3.portable
OutputStream provides interface for writing of all of the mapped IDL type to the stream.
OutputStream() - Constructor for class org.omg.CORBA_2_3.portable.OutputStream
Create a new instance of this class.
OutputStreamWriter - Class in java.io
An OutputStreamWriter is a bridge from character streams to byte streams: Characters written to it are encoded into bytes using a specified charset.
OutputStreamWriter(OutputStream, String) - Constructor for class java.io.OutputStreamWriter
Creates an OutputStreamWriter that uses the named charset.
OutputStreamWriter(OutputStream) - Constructor for class java.io.OutputStreamWriter
Creates an OutputStreamWriter that uses the default character encoding.
OutputStreamWriter(OutputStream, Charset) - Constructor for class java.io.OutputStreamWriter
Creates an OutputStreamWriter that uses the given charset.
OutputStreamWriter(OutputStream, CharsetEncoder) - Constructor for class java.io.OutputStreamWriter
Creates an OutputStreamWriter that uses the given charset encoder.
outputTypes - Variable in class javax.imageio.spi.ImageWriterSpi
An array of Class objects to be returned from getOutputTypes, initially null.
outsideBorder - Variable in class javax.swing.border.CompoundBorder
outsideTimerAction() - Constructor for class javax.swing.ToolTipManager.outsideTimerAction
OVER - Static variable in class java.awt.dnd.DragSourceContext
An int used by updateCurrentCursor() indicating that the Cursor is over a DropTarget.
OVERFLOW - Static variable in class java.nio.charset.CoderResult
Result object indicating overflow, meaning that there is insufficient room in the output buffer.
OVERFLOW - Static variable in class java.nio.file.StandardWatchEventKinds
A special event to indicate that events may have been lost or discarded.
OverlappingFileLockException - Exception in java.nio.channels
Unchecked exception thrown when an attempt is made to acquire a lock on a region of a file that overlaps a region already locked by the same Java virtual machine, or when another thread is already waiting to lock an overlapping region of the same file.
OverlappingFileLockException() - Constructor for exception java.nio.channels.OverlappingFileLockException
Constructs an instance of this class.
overlaps(long, long) - Method in class java.nio.channels.FileLock
Tells whether or not this lock overlaps the given lock range.
OverlayLayout - Class in javax.swing
A layout manager to arrange components over the top of each other.
OverlayLayout(Container) - Constructor for class javax.swing.OverlayLayout
Constructs a layout manager that performs overlay arrangement of the children.
Override - Annotation Type in java.lang
Indicates that a method declaration is intended to override a method declaration in a supertype.
overrides(ExecutableElement, ExecutableElement, TypeElement) - Method in interface javax.lang.model.util.Elements
Tests whether one method, as a member of a given type, overrides another method.
ownDeletesAreVisible(int) - Method in interface java.sql.DatabaseMetaData
Retrieves whether a result set's own deletes are visible.
owner - Variable in class java.awt.datatransfer.Clipboard
owner() - Method in interface java.nio.file.attribute.PosixFileAttributes
Returns the owner of the file.
Owner - Interface in java.security.acl
Interface for managing owners of Access Control Lists (ACLs) or ACL configurations.
ownInsertsAreVisible(int) - Method in interface java.sql.DatabaseMetaData
Retrieves whether a result set's own inserts are visible.
owns(AbstractQueuedLongSynchronizer.ConditionObject) - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer
Queries whether the given ConditionObject uses this synchronizer as its lock.
owns(AbstractQueuedSynchronizer.ConditionObject) - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer
Queries whether the given ConditionObject uses this synchronizer as its lock.
ownUpdatesAreVisible(int) - Method in interface java.sql.DatabaseMetaData
Retrieves whether for the given type of ResultSet object, the result set's own updates are visible.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames


P-Index (Java Platform SE 8 )

Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames
  • All Classes
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

P

P - Static variable in class javax.swing.text.html.HTML.Tag
p - Variable in class javax.swing.text.html.parser.DTD
pack() - Method in class java.awt.Window
Causes this Window to be sized to fit the preferred size and layouts of its subcomponents.
pack(JarFile, OutputStream) - Method in interface java.util.jar.Pack200.Packer
Takes a JarFile and converts it into a Pack200 archive.
pack(JarInputStream, OutputStream) - Method in interface java.util.jar.Pack200.Packer
Takes a JarInputStream and converts it into a Pack200 archive.
pack() - Method in class javax.swing.JInternalFrame
Causes subcomponents of this JInternalFrame to be laid out at their preferred size.
pack() - Method in class javax.swing.JPopupMenu
Lays out the container so that it uses the minimum space needed to display its contents.
Pack200 - Class in java.util.jar
Transforms a JAR file to or from a packed stream in Pack200 format.
Pack200.Packer - Interface in java.util.jar
The packer engine applies various transformations to the input JAR file, making the pack stream highly compressible by a compressor such as gzip or zip.
Pack200.Unpacker - Interface in java.util.jar
The unpacker engine converts the packed stream to a JAR file.
PACKAGE - Static variable in class java.lang.invoke.MethodHandles.Lookup
A single-bit mask representing package access (default access), which may contribute to the result of lookupModes.
Package - Class in java.lang
Package objects contain version information about the implementation and specification of a Java package.
PackageElement - Interface in javax.lang.model.element
Represents a package program element.
packagePrefix - Static variable in interface java.rmi.server.LoaderHandler
Deprecated.
package of system LoaderHandler implementation.
packagePrefix - Static variable in interface java.rmi.server.RemoteRef
Initialize the server package prefix: assumes that the implementation of server ref classes (e.g., UnicastRef, UnicastServerRef) are located in the package defined by the prefix.
packagesIn(Iterable<? extends Element>) - Static method in class javax.lang.model.util.ElementFilter
Returns a list of packages in elements.
packagesIn(Set<? extends Element>) - Static method in class javax.lang.model.util.ElementFilter
Returns a set of packages in elements.
PackedColorModel - Class in java.awt.image
The PackedColorModel class is an abstract ColorModel class that works with pixel values which represent color and alpha information as separate samples and which pack all samples for a single pixel into a single int, short, or byte quantity.
PackedColorModel(ColorSpace, int, int[], int, boolean, int, int) - Constructor for class java.awt.image.PackedColorModel
Constructs a PackedColorModel from a color mask array, which specifies which bits in an int pixel representation contain each of the color samples, and an alpha mask.
PackedColorModel(ColorSpace, int, int, int, int, int, boolean, int, int) - Constructor for class java.awt.image.PackedColorModel
Constructs a PackedColorModel from the specified masks which indicate which bits in an int pixel representation contain the alpha, red, green and blue color samples.
padding - Variable in class javax.swing.plaf.basic.BasicComboBoxUI
If specified, these insets act as padding around the cell renderer when laying out and painting the "selected" item in the combo box.
padding - Variable in class javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout
PADDING - Static variable in class javax.swing.text.html.CSS.Attribute
PADDING_BOTTOM - Static variable in class javax.swing.text.html.CSS.Attribute
PADDING_LEFT - Static variable in class javax.swing.text.html.CSS.Attribute
PADDING_RIGHT - Static variable in class javax.swing.text.html.CSS.Attribute
PADDING_TOP - Static variable in class javax.swing.text.html.CSS.Attribute
padNext(int) - Method in class java.time.format.DateTimeFormatterBuilder
Causes the next added printer/parser to pad to a fixed width using a space.
padNext(int, char) - Method in class java.time.format.DateTimeFormatterBuilder
Causes the next added printer/parser to pad to a fixed width.
padSelectedTab(int, int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout
padSelectedTab(int, int) - Method in class javax.swing.plaf.metal.MetalTabbedPaneUI.TabbedPaneLayout
padSpaceBetweenStrings - Static variable in class javax.swing.plaf.metal.MetalToolTipUI
padTabRun(int, int, int, int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout
PAGE_AXIS - Static variable in class javax.swing.BoxLayout
Specifies that components should be laid out in the direction that lines flow across a page as determined by the target container's ComponentOrientation property.
PAGE_END - Static variable in class java.awt.BorderLayout
The component comes after the last line of the layout's content.
PAGE_END - Static variable in class java.awt.GridBagConstraints
Place the component centered along the edge of its display area associated with the end of a page for the current ComponentOrientation.
PAGE_EXISTS - Static variable in interface java.awt.print.Printable
Returned from Printable.print(Graphics, PageFormat, int) to signify that the requested page was rendered.
PAGE_START - Static variable in class java.awt.BorderLayout
The component comes before the first line of the layout's content.
PAGE_START - Static variable in class java.awt.GridBagConstraints
Place the component centered along the edge of its display area associated with the start of a page for the current ComponentOrientation.
PAGE_TAB - Static variable in class javax.accessibility.AccessibleRole
An object that is a child of a page tab list.
PAGE_TAB_LIST - Static variable in class javax.accessibility.AccessibleRole
An object that presents a series of panels (or page tabs), one at a time, through some mechanism provided by the object.
Pageable - Interface in java.awt.print
The Pageable implementation represents a set of pages to be printed.
PAGEABLE - Static variable in class javax.print.DocFlavor.SERVICE_FORMATTED
Service formatted print data doc flavor with print data representation class name = "java.awt.print.Pageable" (pageable object).
PageAttributes - Class in java.awt
A set of attributes which control the output of a printed page.
PageAttributes() - Constructor for class java.awt.PageAttributes
Constructs a PageAttributes instance with default values for every attribute.
PageAttributes(PageAttributes) - Constructor for class java.awt.PageAttributes
Constructs a PageAttributes instance which is a copy of the supplied PageAttributes.
PageAttributes(PageAttributes.ColorType, PageAttributes.MediaType, PageAttributes.OrientationRequestedType, PageAttributes.OriginType, PageAttributes.PrintQualityType, int[]) - Constructor for class java.awt.PageAttributes
Constructs a PageAttributes instance with the specified values for every attribute.
PageAttributes.ColorType - Class in java.awt
A type-safe enumeration of possible color states.
PageAttributes.MediaType - Class in java.awt
A type-safe enumeration of possible paper sizes.
PageAttributes.OrientationRequestedType - Class in java.awt
A type-safe enumeration of possible orientations.
PageAttributes.OriginType - Class in java.awt
A type-safe enumeration of possible origins.
PageAttributes.PrintQualityType - Class in java.awt
A type-safe enumeration of possible print qualities.
pageDialog(PageFormat) - Method in class java.awt.print.PrinterJob
Displays a dialog that allows modification of a PageFormat instance.
pageDialog(PrintRequestAttributeSet) - Method in class java.awt.print.PrinterJob
A convenience method which displays a cross-platform page setup dialog.
pageDownAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the action to page down vertically.
PagedResultsControl - Class in javax.naming.ldap
Requests that the results of a search operation be returned by the LDAP server in batches of a specified size.
PagedResultsControl(int, boolean) - Constructor for class javax.naming.ldap.PagedResultsControl
Constructs a control to set the number of entries to be returned per page of results.
PagedResultsControl(int, byte[], boolean) - Constructor for class javax.naming.ldap.PagedResultsControl
Constructs a control to set the number of entries to be returned per page of results.
PagedResultsResponseControl - Class in javax.naming.ldap
Indicates the end of a batch of search results.
PagedResultsResponseControl(String, boolean, byte[]) - Constructor for class javax.naming.ldap.PagedResultsResponseControl
Constructs a paged-results response control.
PageFormat - Class in java.awt.print
The PageFormat class describes the size and orientation of a page to be printed.
PageFormat() - Constructor for class java.awt.print.PageFormat
Creates a default, portrait-oriented PageFormat.
PageRanges - Class in javax.print.attribute.standard
Class PageRanges is a printing attribute class, a set of integers, that identifies the range(s) of print-stream pages that the Printer object uses for each copy of each document which are to be printed.
PageRanges(int[][]) - Constructor for class javax.print.attribute.standard.PageRanges
Construct a new page ranges attribute with the given members.
PageRanges(String) - Constructor for class javax.print.attribute.standard.PageRanges
Construct a new page ranges attribute with the given members in string form.
PageRanges(int) - Constructor for class javax.print.attribute.standard.PageRanges
Construct a new page ranges attribute containing a single integer.
PageRanges(int, int) - Constructor for class javax.print.attribute.standard.PageRanges
Construct a new page ranges attribute containing a single range of integers.
PagesPerMinute - Class in javax.print.attribute.standard
Class PagesPerMinute is an integer valued printing attribute that indicates the nominal number of pages per minute to the nearest whole number which may be generated by this printer (e.g., simplex, black-and-white).
PagesPerMinute(int) - Constructor for class javax.print.attribute.standard.PagesPerMinute
Construct a new pages per minute attribute with the given integer value.
PagesPerMinuteColor - Class in javax.print.attribute.standard
Class PagesPerMinuteColor is an integer valued printing attribute that indicates the nominal number of pages per minute to the nearest whole number which may be generated by this printer when printing color (e.g., simplex, color).
PagesPerMinuteColor(int) - Constructor for class javax.print.attribute.standard.PagesPerMinuteColor
Construct a new pages per minute color attribute with the given integer value.
pageUpAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the action to page up vertically.
paint(Graphics) - Method in class java.awt.Canvas
Paints this canvas.
paint(Graphics) - Method in class java.awt.Component
Paints this component.
paint(Graphics) - Method in class java.awt.Container
Paints the container.
PAINT - Static variable in class java.awt.event.PaintEvent
The paint event type.
Paint - Interface in java.awt
This Paint interface defines how color patterns can be generated for Graphics2D operations.
paint(Graphics) - Method in class java.awt.Window
Paints the container.
paint(Graphics) - Method in class javax.swing.CellRendererPane
Shouldn't be called.
paint(Graphics) - Method in class javax.swing.colorchooser.AbstractColorChooserPanel
Draws the panel.
paint(Graphics) - Method in class javax.swing.JComponent
Invoked by Swing to draw components.
paint(Graphics) - Method in class javax.swing.JLayer
Delegates all painting to the LayerUI object.
paint(Graphics) - Method in class javax.swing.JLayeredPane
Paints this JLayeredPane within the specified graphics context.
paint(Graphics) - Method in class javax.swing.JViewport
Depending on whether the backingStore is enabled, either paint the image through the backing store or paint just the recently exposed part, using the backing store to "blit" the remainder.
paint(Graphics2D, T, int, int) - Method in interface javax.swing.Painter
Renders to the given Graphics2D object.
paint(Graphics) - Method in class javax.swing.plaf.basic.BasicArrowButton
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic.BasicButtonUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic.BasicComboBoxUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI
paint(Graphics) - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane.SystemMenuBar
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic.BasicLabelUI
Paints the label text with the foreground color, if the label is opaque then paints the entire background with the background color.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic.BasicListUI
Paint the rows that intersect the Graphics objects clipRect.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic.BasicMenuItemUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic.BasicPopupMenuSeparatorUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic.BasicProgressBarUI
Delegates painting to one of two methods: paintDeterminate or paintIndeterminate.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic.BasicRadioButtonUI
paint the radio button
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic.BasicScrollBarUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic.BasicScrollPaneUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic.BasicSeparatorUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic.BasicSliderUI
paint(Graphics) - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider
Paints the divider.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Paints the specified component appropriately for the look and feel.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic.BasicTableHeaderUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic.BasicTableUI
Paint a representation of the table instance that was set in installUI().
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic.BasicTextUI
Paints the interface.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic.BasicToggleButtonUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic.BasicToolBarSeparatorUI
paint(Graphics) - Method in class javax.swing.plaf.basic.BasicToolBarUI.DragWindow
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic.BasicToolTipUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.basic.BasicTreeUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.ComponentUI
Paints the specified component appropriately for the look and feel.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.LayerUI
Paints the specified component.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.metal.MetalComboBoxUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.metal.MetalPopupMenuSeparatorUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.metal.MetalRadioButtonUI
paint(Graphics) - Method in class javax.swing.plaf.metal.MetalScrollButton
paint(Graphics, JComponent) - Method in class javax.swing.plaf.metal.MetalSeparatorUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.metal.MetalTabbedPaneUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.metal.MetalToolTipUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.metal.MetalTreeUI
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiButtonUI
Invokes the paint method on each UI handled by this object.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiColorChooserUI
Invokes the paint method on each UI handled by this object.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiComboBoxUI
Invokes the paint method on each UI handled by this object.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiDesktopIconUI
Invokes the paint method on each UI handled by this object.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiDesktopPaneUI
Invokes the paint method on each UI handled by this object.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiFileChooserUI
Invokes the paint method on each UI handled by this object.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiInternalFrameUI
Invokes the paint method on each UI handled by this object.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiLabelUI
Invokes the paint method on each UI handled by this object.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiListUI
Invokes the paint method on each UI handled by this object.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiMenuBarUI
Invokes the paint method on each UI handled by this object.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiMenuItemUI
Invokes the paint method on each UI handled by this object.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiOptionPaneUI
Invokes the paint method on each UI handled by this object.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiPanelUI
Invokes the paint method on each UI handled by this object.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiPopupMenuUI
Invokes the paint method on each UI handled by this object.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiProgressBarUI
Invokes the paint method on each UI handled by this object.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiRootPaneUI
Invokes the paint method on each UI handled by this object.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiScrollBarUI
Invokes the paint method on each UI handled by this object.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiScrollPaneUI
Invokes the paint method on each UI handled by this object.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiSeparatorUI
Invokes the paint method on each UI handled by this object.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiSliderUI
Invokes the paint method on each UI handled by this object.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiSpinnerUI
Invokes the paint method on each UI handled by this object.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiSplitPaneUI
Invokes the paint method on each UI handled by this object.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiTabbedPaneUI
Invokes the paint method on each UI handled by this object.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiTableHeaderUI
Invokes the paint method on each UI handled by this object.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiTableUI
Invokes the paint method on each UI handled by this object.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiTextUI
Invokes the paint method on each UI handled by this object.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiToolBarUI
Invokes the paint method on each UI handled by this object.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiToolTipUI
Invokes the paint method on each UI handled by this object.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiTreeUI
Invokes the paint method on each UI handled by this object.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiViewportUI
Invokes the paint method on each UI handled by this object.
paint(Graphics2D, JComponent, int, int) - Method in class javax.swing.plaf.nimbus.AbstractRegionPainter
Renders to the given Graphics2D object.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthButtonUI
Paints the specified component according to the Look and Feel.
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth.SynthButtonUI
Paints the specified component.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthColorChooserUI
Paints the specified component according to the Look and Feel.
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth.SynthColorChooserUI
Paints the specified component.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthComboBoxUI
Paints the specified component according to the Look and Feel.
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth.SynthComboBoxUI
Paints the specified component.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthDesktopIconUI
Paints the specified component according to the Look and Feel.
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth.SynthDesktopIconUI
Paints the specified component.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthDesktopPaneUI
Paints the specified component according to the Look and Feel.
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth.SynthDesktopPaneUI
Paints the specified component.
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth.SynthEditorPaneUI
Paints the specified component.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthInternalFrameUI
Paints the specified component according to the Look and Feel.
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth.SynthInternalFrameUI
Paints the specified component.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthLabelUI
Paints the specified component according to the Look and Feel.
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth.SynthLabelUI
Paints the specified component.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthMenuBarUI
Paints the specified component according to the Look and Feel.
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth.SynthMenuBarUI
Paints the specified component.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthMenuItemUI
Paints the specified component according to the Look and Feel.
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth.SynthMenuItemUI
Paints the specified component.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthMenuUI
Paints the specified component according to the Look and Feel.
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth.SynthMenuUI
Paints the specified component.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthOptionPaneUI
Paints the specified component according to the Look and Feel.
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth.SynthOptionPaneUI
Paints the specified component.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthPanelUI
Paints the specified component according to the Look and Feel.
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth.SynthPanelUI
Paints the specified component.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthPopupMenuUI
Paints the specified component according to the Look and Feel.
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth.SynthPopupMenuUI
Paints the specified component.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthProgressBarUI
Paints the specified component according to the Look and Feel.
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth.SynthProgressBarUI
Paints the specified component.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthRootPaneUI
Paints the specified component according to the Look and Feel.
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth.SynthRootPaneUI
Paints the specified component.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthScrollBarUI
Paints the specified component according to the Look and Feel.
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth.SynthScrollBarUI
Paints the specified component.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthScrollPaneUI
Paints the specified component according to the Look and Feel.
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth.SynthScrollPaneUI
Paints the specified component.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthSeparatorUI
Paints the specified component according to the Look and Feel.
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth.SynthSeparatorUI
Paints the specified component.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthSliderUI
Paints the specified component according to the Look and Feel.
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth.SynthSliderUI
Paints the specified component.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthSpinnerUI
Paints the specified component according to the Look and Feel.
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth.SynthSpinnerUI
Paints the specified component.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthSplitPaneUI
Paints the specified component according to the Look and Feel.
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth.SynthSplitPaneUI
Paints the specified component.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthTabbedPaneUI
Paints the specified component according to the Look and Feel.
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth.SynthTabbedPaneUI
Paints the specified component.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthTableHeaderUI
Paints the specified component according to the Look and Feel.
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth.SynthTableHeaderUI
Paints the specified component.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthTableUI
Paints the specified component according to the Look and Feel.
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth.SynthTableUI
Paints the specified component.
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth.SynthTextAreaUI
Paints the specified component.
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth.SynthTextFieldUI
Paints the specified component.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthToolBarUI
Paints the specified component according to the Look and Feel.
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth.SynthToolBarUI
Paints the toolbar.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthToolTipUI
Paints the specified component according to the Look and Feel.
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth.SynthToolTipUI
Paints the specified component.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthTreeUI
Paints the specified component according to the Look and Feel.
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth.SynthTreeUI
Paints the specified component.
paint(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthViewportUI
Paints the specified component according to the Look and Feel.
paint(SynthContext, Graphics) - Method in class javax.swing.plaf.synth.SynthViewportUI
Paints the specified component.
paint(Graphics, Shape) - Method in class javax.swing.text.AsyncBoxView
Render the view using the given allocation and rendering surface.
paint(Graphics, Shape) - Method in class javax.swing.text.BoxView
Renders the BoxView using the given rendering surface and area on that surface.
paint(Graphics) - Method in interface javax.swing.text.Caret
Renders the caret.
paint(Graphics, Shape) - Method in class javax.swing.text.ComponentView
The real paint behavior occurs naturally from the association that the component has with its parent container (the same container hosting this view).
paint(Graphics) - Method in class javax.swing.text.DefaultCaret
Renders the caret as a vertical line.
paint(Graphics, int, int, Shape, JTextComponent) - Method in class javax.swing.text.DefaultHighlighter.DefaultHighlightPainter
Paints a highlight.
paint(Graphics) - Method in class javax.swing.text.DefaultHighlighter
Renders the highlights.
paint(Graphics, Shape) - Method in class javax.swing.text.FieldView
Renders using the given rendering surface and area on that surface.
paint(GlyphView, Graphics, Shape, int, int) - Method in class javax.swing.text.GlyphView.GlyphPainter
Paint the glyphs representing the given range.
paint(Graphics, Shape) - Method in class javax.swing.text.GlyphView
Renders a portion of a text style run.
paint(Graphics, int, int, Shape, JTextComponent) - Method in interface javax.swing.text.Highlighter.HighlightPainter
Renders the highlight.
paint(Graphics) - Method in interface javax.swing.text.Highlighter
Renders the highlights.
paint(Graphics, Shape) - Method in class javax.swing.text.html.BlockView
Renders using the given rendering surface and area on that surface.
paint(Graphics, Shape) - Method in class javax.swing.text.html.ImageView
Paints the View.
paint(Graphics, Shape) - Method in class javax.swing.text.html.ListView
Renders using the given rendering surface and area on that surface.
paint(Graphics, Shape) - Method in class javax.swing.text.html.ParagraphView
Renders using the given rendering surface and area on that surface.
paint(Graphics, float, float, float, float, View) - Method in class javax.swing.text.html.StyleSheet.BoxPainter
Paints the CSS box according to the attributes given.
paint(Graphics, float, float, float, float, View, int) - Method in class javax.swing.text.html.StyleSheet.ListPainter
Paints the CSS list decoration according to the attributes given.
paint(Graphics, Shape) - Method in class javax.swing.text.IconView
Paints the icon.
paint(Graphics, Shape) - Method in class javax.swing.text.ParagraphView
Renders using the given rendering surface and area on that surface.
paint(Graphics, Shape) - Method in class javax.swing.text.PlainView
Renders using the given rendering surface and area on that surface.
paint(Graphics, Shape) - Method in class javax.swing.text.View
Renders using the given rendering surface and area on that surface.
paint(Graphics, Shape) - Method in class javax.swing.text.WrappedPlainView
Renders using the given rendering surface and area on that surface.
paint(Graphics) - Method in class javax.swing.tree.DefaultTreeCellEditor.EditorContainer
Overrides Container.paint to paint the node's icon and use the selection color for the background.
paint(Graphics) - Method in class javax.swing.tree.DefaultTreeCellRenderer
Paints the value.
PAINT_EVENT_MASK - Static variable in class java.awt.AWTEvent
The event mask for selecting paint events.
PAINT_FIRST - Static variable in class java.awt.event.PaintEvent
Marks the first integer id for the range of paint event ids.
PAINT_LAST - Static variable in class java.awt.event.PaintEvent
Marks the last integer id for the range of paint event ids.
paintAll(Graphics) - Method in class java.awt.Component
Paints this component and all of its subcomponents.
paintArrowButtonBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of an arrow button.
paintArrowButtonBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of an arrow button.
paintArrowButtonForeground(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the foreground of an arrow button.
paintBackground(Graphics, JMenuItem, Color) - Method in class javax.swing.plaf.basic.BasicMenuItemUI
Draws the background of the menu item.
paintBackground(Graphics) - Method in class javax.swing.plaf.basic.BasicTextUI
Paints a background for the view.
paintBackground(Graphics) - Method in class javax.swing.plaf.synth.SynthEditorPaneUI
Paints a background for the view.
paintBackground(Graphics) - Method in class javax.swing.plaf.synth.SynthTextAreaUI
Paints a background for the view.
paintBackground(Graphics) - Method in class javax.swing.plaf.synth.SynthTextFieldUI
Paints a background for the view.
paintBorder(Graphics) - Method in class javax.swing.AbstractButton
Paint the button's border if BorderPainted property is true and the button has a border.
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.border.AbstractBorder
This default implementation does no painting.
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.border.BevelBorder
Paints the border for the specified component with the specified position and size.
paintBorder(Component, Graphics, int, int, int, int) - Method in interface javax.swing.border.Border
Paints the border for the specified component with the specified position and size.
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.border.CompoundBorder
Paints the compound border by painting the outside border with the specified position and size and then painting the inside border at the specified position and size offset by the insets of the outside border.
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.border.EmptyBorder
Does no drawing by default.
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.border.EtchedBorder
Paints the border for the specified component with the specified position and size.
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.border.LineBorder
Paints the border for the specified component with the specified position and size.
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.border.MatteBorder
Paints the matte border.
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.border.SoftBevelBorder
Paints the border for the specified component with the specified position and size.
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.border.StrokeBorder
Paints the border for the specified component with the specified position and size.
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.border.TitledBorder
Paints the border for the specified component with the specified position and size.
paintBorder(Graphics) - Method in class javax.swing.JComponent
Paints the component's border.
paintBorder(Graphics) - Method in class javax.swing.JMenuBar
Paints the menubar's border if BorderPainted property is true.
paintBorder(Graphics) - Method in class javax.swing.JPopupMenu
Paints the popup menu's border if the borderPainted property is true.
paintBorder - Variable in class javax.swing.JProgressBar
Whether to display a border around the progress bar.
paintBorder(Graphics) - Method in class javax.swing.JProgressBar
Paints the progress bar's border if the borderPainted property is true.
paintBorder(Graphics) - Method in class javax.swing.JToolBar
Paints the tool bar's border if the borderPainted property is true.
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.basic.BasicBorders.ButtonBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.basic.BasicBorders.FieldBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.basic.BasicBorders.MenuBarBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.basic.BasicBorders.RadioButtonBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.basic.BasicBorders.RolloverButtonBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.basic.BasicBorders.SplitPaneBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.basic.BasicBorders.ToggleButtonBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.BorderUIResource
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.metal.MetalBorders.ButtonBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.metal.MetalBorders.Flush3DBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.metal.MetalBorders.InternalFrameBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.metal.MetalBorders.MenuBarBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.metal.MetalBorders.MenuItemBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.metal.MetalBorders.OptionDialogBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.metal.MetalBorders.PaletteBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.metal.MetalBorders.PopupMenuBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.metal.MetalBorders.RolloverButtonBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.metal.MetalBorders.ScrollPaneBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.metal.MetalBorders.TableHeaderBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.metal.MetalBorders.TextFieldBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.metal.MetalBorders.ToggleButtonBorder
paintBorder(Component, Graphics, int, int, int, int) - Method in class javax.swing.plaf.metal.MetalBorders.ToolBarBorder
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthButtonUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthCheckBoxMenuItemUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthCheckBoxUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthColorChooserUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthComboBoxUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthDesktopIconUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthDesktopPaneUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthEditorPaneUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthFormattedTextFieldUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthInternalFrameUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthLabelUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthListUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthMenuBarUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthMenuItemUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthMenuUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthOptionPaneUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPanelUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPasswordFieldUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPopupMenuUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthProgressBarUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthRadioButtonMenuItemUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthRadioButtonUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthRootPaneUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthScrollBarUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthScrollPaneUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthSeparatorUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthSliderUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthSpinnerUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthSplitPaneUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthTabbedPaneUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthTableHeaderUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthTableUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthTextAreaUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthTextFieldUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthTextPaneUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthToggleButtonUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthToolBarUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthToolTipUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthTreeUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in interface javax.swing.plaf.synth.SynthUI
Paints the border.
paintBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthViewportUI
Paints the border.
paintBottomTabBorder(int, Graphics, int, int, int, int, int, int, boolean) - Method in class javax.swing.plaf.metal.MetalTabbedPaneUI
paintButtonBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a button.
paintButtonBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a button.
paintButtonPressed(Graphics, AbstractButton) - Method in class javax.swing.plaf.basic.BasicButtonUI
paintButtonPressed(Graphics, AbstractButton) - Method in class javax.swing.plaf.metal.MetalButtonUI
paintButtonPressed(Graphics, AbstractButton) - Method in class javax.swing.plaf.metal.MetalToggleButtonUI
paintCell(Graphics, int, Rectangle, ListCellRenderer, ListModel, ListSelectionModel, int) - Method in class javax.swing.plaf.basic.BasicListUI
Paint one List cell: compute the relevant state, get the "rubber stamp" cell renderer component, and then use the CellRendererPane to paint it.
paintCheckBoxBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a check box.
paintCheckBoxBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a check box.
paintCheckBoxMenuItemBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a check box menu item.
paintCheckBoxMenuItemBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a check box menu item.
paintChild(Graphics, Rectangle, int) - Method in class javax.swing.text.BoxView
Paints a child.
paintChild(Graphics, Rectangle, int) - Method in class javax.swing.text.html.ListView
Paints one of the children; called by paint().
paintChildren(Graphics) - Method in class javax.swing.JComponent
Paints this component's children.
paintChildren(Graphics) - Method in class javax.swing.JSplitPane
Subclassed to message the UI with finishedPaintingChildren after super has been messaged, as well as painting the border.
paintChildren(Graphics) - Method in class javax.swing.text.AsyncBoxView.ChildLocator
Paint the children that intersect the clip area.
paintColorChooserBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a color chooser.
paintColorChooserBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a color chooser.
paintComboBoxBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a combo box.
paintComboBoxBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a combo box.
paintComponent(Graphics) - Method in class javax.swing.Box.Filler
Paints this Filler.
paintComponent(Graphics) - Method in class javax.swing.Box
Paints this Box.
paintComponent(Graphics, Component, Container, int, int, int, int, boolean) - Method in class javax.swing.CellRendererPane
Paint a cell renderer component c on graphics object g.
paintComponent(Graphics, Component, Container, int, int, int, int) - Method in class javax.swing.CellRendererPane
Calls this.paintComponent(g, c, p, x, y, w, h, false).
paintComponent(Graphics, Component, Container, Rectangle) - Method in class javax.swing.CellRendererPane
Calls this.paintComponent() with the rectangles x,y,width,height fields.
paintComponent(Graphics) - Method in class javax.swing.JComponent
Calls the UI delegate's paint method, if the UI delegate is non-null.
paintComponent(Graphics) - Method in class javax.swing.JInternalFrame
Overridden to allow optimized painting when the internal frame is being dragged.
paintComponent(Graphics) - Method in class javax.swing.JLayer
This method is empty, because all painting is done by JLayer.paint(Graphics) and ComponentUI.update(Graphics, JComponent) methods
paintComponent(Graphics) - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
paintComponent(Graphics) - Method in class javax.swing.plaf.metal.MetalComboBoxButton
paintComponent(Graphics) - Method in class javax.swing.plaf.metal.MetalInternalFrameTitlePane
paintComponent(Graphics, Component, Container, int, int, int, int) - Static method in class javax.swing.SwingUtilities
Paints a component to the specified Graphics.
paintComponent(Graphics, Component, Container, Rectangle) - Static method in class javax.swing.SwingUtilities
Paints a component to the specified Graphics.
paintComponents(Graphics) - Method in class java.awt.Container
Paints each of the components in this container.
paintContent(SynthContext, Graphics, Rectangle) - Method in class javax.swing.plaf.synth.SynthToolBarUI
Paints the toolbar content.
paintContentBorder(Graphics, int, int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
paintContentBorderBottomEdge(Graphics, int, int, int, int, int, int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
paintContentBorderBottomEdge(Graphics, int, int, int, int, int, int) - Method in class javax.swing.plaf.metal.MetalTabbedPaneUI
paintContentBorderLeftEdge(Graphics, int, int, int, int, int, int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
paintContentBorderLeftEdge(Graphics, int, int, int, int, int, int) - Method in class javax.swing.plaf.metal.MetalTabbedPaneUI
paintContentBorderRightEdge(Graphics, int, int, int, int, int, int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
paintContentBorderRightEdge(Graphics, int, int, int, int, int, int) - Method in class javax.swing.plaf.metal.MetalTabbedPaneUI
paintContentBorderTopEdge(Graphics, int, int, int, int, int, int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
paintContentBorderTopEdge(Graphics, int, int, int, int, int, int) - Method in class javax.swing.plaf.metal.MetalTabbedPaneUI
PaintContext - Interface in java.awt
The PaintContext interface defines the encapsulated and optimized environment to generate color patterns in device space for fill or stroke operations on a Graphics2D.
PaintContext(Insets, Dimension, boolean) - Constructor for class javax.swing.plaf.nimbus.AbstractRegionPainter.PaintContext
Creates a new PaintContext which does not attempt to cache or scale any cached images.
PaintContext(Insets, Dimension, boolean, AbstractRegionPainter.PaintContext.CacheMode, double, double) - Constructor for class javax.swing.plaf.nimbus.AbstractRegionPainter.PaintContext
Creates a new PaintContext.
paintCurrentValue(Graphics, Rectangle, boolean) - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Paints the currently selected item.
paintCurrentValue(Graphics, Rectangle, boolean) - Method in class javax.swing.plaf.metal.MetalComboBoxUI
If necessary paints the currently selected item.
paintCurrentValue(Graphics, Rectangle, boolean) - Method in class javax.swing.plaf.synth.SynthComboBoxUI
Paints the currently selected item.
paintCurrentValueBackground(Graphics, Rectangle, boolean) - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Paints the background of the currently selected item.
paintCurrentValueBackground(Graphics, Rectangle, boolean) - Method in class javax.swing.plaf.metal.MetalComboBoxUI
If necessary paints the background of the currently selected item.
paintDecreaseHighlight(Graphics) - Method in class javax.swing.plaf.basic.BasicScrollBarUI
paintDesktopIconBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a desktop icon.
paintDesktopIconBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a desktop icon.
paintDesktopPaneBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a desktop pane.
paintDesktopPaneBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a desktop pane.
paintDeterminate(Graphics, JComponent) - Method in class javax.swing.plaf.basic.BasicProgressBarUI
All purpose paint method that should do the right thing for almost all linear, determinate progress bars.
paintDeterminate(Graphics, JComponent) - Method in class javax.swing.plaf.metal.MetalProgressBarUI
Draws a bit of special highlighting on the progress bar.
paintDirtyRegions() - Method in class javax.swing.RepaintManager
Paint all of the components that have been marked dirty.
paintDisabledText(JLabel, Graphics, String, int, int) - Method in class javax.swing.plaf.basic.BasicLabelUI
Paint clippedText at textX, textY with background.lighter() and then shifted down and to the right by one pixel with background.darker().
paintDisabledText(JLabel, Graphics, String, int, int) - Method in class javax.swing.plaf.metal.MetalLabelUI
Just paint the text gray (Label.disabledForeground) rather than in the labels foreground color.
paintDragWindow(Graphics) - Method in class javax.swing.plaf.basic.BasicToolBarUI
Paints the contents of the window used for dragging.
paintDragWindow(Graphics) - Method in class javax.swing.plaf.synth.SynthToolBarUI
Paints the contents of the window used for dragging.
paintDropLine(Graphics) - Method in class javax.swing.plaf.basic.BasicTreeUI
Paints the drop line.
paintDropLine(Graphics) - Method in class javax.swing.plaf.synth.SynthTreeUI
Paints the drop line.
paintEditorPaneBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of an editor pane.
paintEditorPaneBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of an editor pane.
paintEnabledText(JLabel, Graphics, String, int, int) - Method in class javax.swing.plaf.basic.BasicLabelUI
Paint clippedText at textX, textY with the labels foreground color.
Painter<T> - Interface in javax.swing
A painting delegate.
PaintEvent - Class in java.awt.event
The component-level paint event.
PaintEvent(Component, int, Rectangle) - Constructor for class java.awt.event.PaintEvent
Constructs a PaintEvent object with the specified source component and type.
paintExpandControl(Graphics, Rectangle, Insets, Rectangle, TreePath, int, boolean, boolean, boolean) - Method in class javax.swing.plaf.basic.BasicTreeUI
Paints the expand (toggle) part of a row.
paintExpandControl(Graphics, Rectangle, Insets, Rectangle, TreePath, int, boolean, boolean, boolean) - Method in class javax.swing.plaf.synth.SynthTreeUI
Paints the expand (toggle) part of a row.
paintFileChooserBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a file chooser.
paintFileChooserBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a file chooser.
paintFocus(Graphics, AbstractButton, Rectangle, Rectangle, Rectangle) - Method in class javax.swing.plaf.basic.BasicButtonUI
paintFocus(Graphics, Rectangle, Dimension) - Method in class javax.swing.plaf.basic.BasicRadioButtonUI
paintFocus(Graphics) - Method in class javax.swing.plaf.basic.BasicSliderUI
paintFocus(Graphics, AbstractButton, Rectangle, Rectangle, Rectangle) - Method in class javax.swing.plaf.metal.MetalButtonUI
paintFocus(Graphics, Rectangle, Dimension) - Method in class javax.swing.plaf.metal.MetalRadioButtonUI
paintFocus(Graphics) - Method in class javax.swing.plaf.metal.MetalSliderUI
paintFocus(Graphics, AbstractButton, Rectangle, Rectangle, Rectangle) - Method in class javax.swing.plaf.metal.MetalToggleButtonUI
paintFocusIndicator(Graphics, int, Rectangle[], int, Rectangle, Rectangle, boolean) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
paintFocusIndicator(Graphics, int, Rectangle[], int, Rectangle, Rectangle, boolean) - Method in class javax.swing.plaf.metal.MetalTabbedPaneUI
paintFormattedTextFieldBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a formatted text field.
paintFormattedTextFieldBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a formatted text field.
paintHighlightBelowTab() - Method in class javax.swing.plaf.metal.MetalTabbedPaneUI
paintHorizontalLabel(Graphics, int, Component) - Method in class javax.swing.plaf.basic.BasicSliderUI
Called for every label in the label table.
paintHorizontalLine(Graphics, JComponent, int, int, int) - Method in class javax.swing.plaf.basic.BasicTreeUI
Paints a horizontal line.
paintHorizontalLine(Graphics, JComponent, int, int, int) - Method in class javax.swing.plaf.synth.SynthTreeUI
Paints a horizontal line.
paintHorizontalPartOfLeg(Graphics, Rectangle, Insets, Rectangle, TreePath, int, boolean, boolean, boolean) - Method in class javax.swing.plaf.basic.BasicTreeUI
Paints the horizontal part of the leg.
paintHorizontalPartOfLeg(Graphics, Rectangle, Insets, Rectangle, TreePath, int, boolean, boolean, boolean) - Method in class javax.swing.plaf.metal.MetalTreeUI
paintHorizontalPartOfLeg(Graphics, Rectangle, Insets, Rectangle, TreePath, int, boolean, boolean, boolean) - Method in class javax.swing.plaf.synth.SynthTreeUI
Paints the horizontal part of the leg.
paintHorizontalSeparators(Graphics, JComponent) - Method in class javax.swing.plaf.metal.MetalTreeUI
paintIcon(Component, Graphics, int, int) - Method in interface javax.swing.Icon
Draw the icon at the specified location.
paintIcon(Component, Graphics, int, int) - Method in class javax.swing.ImageIcon
Paints the icon.
paintIcon(Graphics, JComponent, Rectangle) - Method in class javax.swing.plaf.basic.BasicButtonUI
paintIcon(Graphics, int, int, Icon, Rectangle, boolean) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
paintIcon(Graphics, AbstractButton, Rectangle) - Method in class javax.swing.plaf.basic.BasicToggleButtonUI
paintIcon(Component, Graphics, int, int) - Method in class javax.swing.plaf.IconUIResource
paintIcon(Component, Graphics, int, int) - Method in class javax.swing.plaf.metal.MetalCheckBoxIcon
paintIcon(Component, Graphics, int, int) - Method in class javax.swing.plaf.metal.MetalComboBoxIcon
Paints the horizontal bars for the
paintIcon(Component, Graphics, int, int) - Method in class javax.swing.plaf.metal.MetalIconFactory.FileIcon16
paintIcon(Component, Graphics, int, int) - Method in class javax.swing.plaf.metal.MetalIconFactory.FolderIcon16
paintIcon(Component, Graphics, int, int) - Method in class javax.swing.plaf.metal.MetalIconFactory.PaletteCloseIcon
paintIcon(Component, Graphics, int, int) - Method in class javax.swing.plaf.metal.MetalIconFactory.TreeControlIcon
paintIcon(Graphics, AbstractButton, Rectangle) - Method in class javax.swing.plaf.metal.MetalToggleButtonUI
Paints the appropriate icon of the button b in the space iconRect.
paintImmediately(int, int, int, int) - Method in class javax.swing.JComponent
Paints the specified region in this component and all of its descendants that overlap the region, immediately.
paintImmediately(Rectangle) - Method in class javax.swing.JComponent
Paints the specified region now.
paintImmediately(int, int, int, int) - Method in class javax.swing.JLayer
Delegates its functionality to the LayerUI.paintImmediately(int, int, int, int, JLayer) method, if LayerUI is set.
paintImmediately(int, int, int, int, JLayer<? extends V>) - Method in class javax.swing.plaf.LayerUI
Paints the specified region in the JLayer this LayerUI is set to, immediately.
paintIncreaseHighlight(Graphics) - Method in class javax.swing.plaf.basic.BasicScrollBarUI
paintIndeterminate(Graphics, JComponent) - Method in class javax.swing.plaf.basic.BasicProgressBarUI
All purpose paint method that should do the right thing for all linear bouncing-box progress bars.
paintIndeterminate(Graphics, JComponent) - Method in class javax.swing.plaf.metal.MetalProgressBarUI
Draws a bit of special highlighting on the progress bar and bouncing box.
paintInternalFrameBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of an internal frame.
paintInternalFrameBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of an internal frame.
paintInternalFrameTitlePaneBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of an internal frame title pane.
paintInternalFrameTitlePaneBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of an internal frame title pane.
paintLabelBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a label.
paintLabelBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a label.
paintLabels(Graphics) - Method in class javax.swing.plaf.basic.BasicSliderUI
paintLayer(Graphics, int, int, Shape, JTextComponent, View) - Method in class javax.swing.text.DefaultHighlighter.DefaultHighlightPainter
Paints a portion of a highlight.
paintLayer(Graphics, int, int, Shape, JTextComponent, View) - Method in class javax.swing.text.LayeredHighlighter.LayerPainter
paintLayeredHighlights(Graphics, int, int, Shape, JTextComponent, View) - Method in class javax.swing.text.DefaultHighlighter
When leaf Views (such as LabelView) are rendering they should call into this method.
paintLayeredHighlights(Graphics, int, int, Shape, JTextComponent, View) - Method in class javax.swing.text.LayeredHighlighter
When leaf Views (such as LabelView) are rendering they should call into this method.
paintLeftTabBorder(int, Graphics, int, int, int, int, int, int, boolean) - Method in class javax.swing.plaf.metal.MetalTabbedPaneUI
paintListBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a list.
paintListBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a list.
paintLoweredBevel(Component, Graphics, int, int, int, int) - Method in class javax.swing.border.BevelBorder
paintMajorTickForHorizSlider(Graphics, Rectangle, int) - Method in class javax.swing.plaf.basic.BasicSliderUI
paintMajorTickForHorizSlider(Graphics, Rectangle, int) - Method in class javax.swing.plaf.metal.MetalSliderUI
paintMajorTickForVertSlider(Graphics, Rectangle, int) - Method in class javax.swing.plaf.basic.BasicSliderUI
paintMajorTickForVertSlider(Graphics, Rectangle, int) - Method in class javax.swing.plaf.metal.MetalSliderUI
paintMe(Component, Graphics, int, int) - Method in class javax.swing.plaf.metal.MetalIconFactory.TreeControlIcon
paintMenuBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a menu.
paintMenuBarBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a menu bar.
paintMenuBarBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a menu bar.
paintMenuBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a menu.
paintMenuItem(Graphics, JComponent, Icon, Icon, Color, Color, int) - Method in class javax.swing.plaf.basic.BasicMenuItemUI
paintMenuItemBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a menu item.
paintMenuItemBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a menu item.
paintMinorTickForHorizSlider(Graphics, Rectangle, int) - Method in class javax.swing.plaf.basic.BasicSliderUI
paintMinorTickForHorizSlider(Graphics, Rectangle, int) - Method in class javax.swing.plaf.metal.MetalSliderUI
paintMinorTickForVertSlider(Graphics, Rectangle, int) - Method in class javax.swing.plaf.basic.BasicSliderUI
paintMinorTickForVertSlider(Graphics, Rectangle, int) - Method in class javax.swing.plaf.metal.MetalSliderUI
paintOptionPaneBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of an option pane.
paintOptionPaneBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of an option pane.
paintPalette(Graphics) - Method in class javax.swing.plaf.metal.MetalInternalFrameTitlePane
paintPanelBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a panel.
paintPanelBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a panel.
paintPasswordFieldBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a password field.
paintPasswordFieldBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a password field.
paintPopupMenuBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a popup menu.
paintPopupMenuBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a popup menu.
paintProgressBarBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a progress bar.
paintProgressBarBackground(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a progress bar.
paintProgressBarBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a progress bar.
paintProgressBarBorder(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a progress bar.
paintProgressBarForeground(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the foreground of a progress bar.
paintRadioButtonBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a radio button.
paintRadioButtonBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a radio button.
paintRadioButtonMenuItemBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a radio button menu item.
paintRadioButtonMenuItemBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a radio button menu item.
paintRaisedBevel(Component, Graphics, int, int, int, int) - Method in class javax.swing.border.BevelBorder
paintRightTabBorder(int, Graphics, int, int, int, int, int, int, boolean) - Method in class javax.swing.plaf.metal.MetalTabbedPaneUI
paintRootPaneBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a root pane.
paintRootPaneBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a root pane.
paintRow(Graphics, Rectangle, Insets, Rectangle, TreePath, int, boolean, boolean, boolean) - Method in class javax.swing.plaf.basic.BasicTreeUI
Paints the renderer part of a row.
paintSafely(Graphics) - Method in class javax.swing.plaf.basic.BasicTextUI
Paints the interface safely with a guarantee that the model won't change from the view of this thread.
paintScrollBarBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a scrollbar.
paintScrollBarBackground(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a scrollbar.
paintScrollBarBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a scrollbar.
paintScrollBarBorder(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a scrollbar.
paintScrollBarThumbBackground(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of the thumb of a scrollbar.
paintScrollBarThumbBorder(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of the thumb of a scrollbar.
paintScrollBarTrackBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of the track of a scrollbar.
paintScrollBarTrackBackground(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of the track of a scrollbar.
paintScrollBarTrackBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of the track of a scrollbar.
paintScrollBarTrackBorder(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of the track of a scrollbar.
paintScrollPaneBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a scroll pane.
paintScrollPaneBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a scroll pane.
paintSeparatorBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a separator.
paintSeparatorBackground(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a separator.
paintSeparatorBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a separator.
paintSeparatorBorder(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a separator.
paintSeparatorForeground(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the foreground of a separator.
paintSliderBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a slider.
paintSliderBackground(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a slider.
paintSliderBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a slider.
paintSliderBorder(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a slider.
paintSliderThumbBackground(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of the thumb of a slider.
paintSliderThumbBorder(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of the thumb of a slider.
paintSliderTrackBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of the track of a slider.
paintSliderTrackBackground(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of the track of a slider.
paintSliderTrackBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of the track of a slider.
paintSliderTrackBorder(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of the track of a slider.
paintSpinnerBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a spinner.
paintSpinnerBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a spinner.
paintSplitPaneBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a split pane.
paintSplitPaneBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a split pane.
paintSplitPaneDividerBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of the divider of a split pane.
paintSplitPaneDividerBackground(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of the divider of a split pane.
paintSplitPaneDividerForeground(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the foreground of the divider of a split pane.
paintSplitPaneDragDivider(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the divider, when the user is dragging the divider, of a split pane.
paintString - Variable in class javax.swing.JProgressBar
Whether to display a string of text on the progress bar.
paintString(Graphics, int, int, int, int, int, Insets) - Method in class javax.swing.plaf.basic.BasicProgressBarUI
paintTab(Graphics, int, Rectangle[], int, Rectangle, Rectangle) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
paintTabArea(Graphics, int, int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
Paints the tabs in the tab area.
paintTabArea(Graphics, int, int) - Method in class javax.swing.plaf.synth.SynthTabbedPaneUI
paintTabBackground(Graphics, int, int, int, int, int, int, boolean) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
paintTabBackground(Graphics, int, int, int, int, int, int, boolean) - Method in class javax.swing.plaf.metal.MetalTabbedPaneUI
paintTabbedPaneBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a tabbed pane.
paintTabbedPaneBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a tabbed pane.
paintTabbedPaneContentBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of the area that contains the content of the selected tab of a tabbed pane.
paintTabbedPaneContentBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of the area that contains the content of the selected tab of a tabbed pane.
paintTabbedPaneTabAreaBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of the area behind the tabs of a tabbed pane.
paintTabbedPaneTabAreaBackground(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of the area behind the tabs of a tabbed pane.
paintTabbedPaneTabAreaBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of the area behind the tabs of a tabbed pane.
paintTabbedPaneTabAreaBorder(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of the area behind the tabs of a tabbed pane.
paintTabbedPaneTabBackground(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a tab of a tabbed pane.
paintTabbedPaneTabBackground(SynthContext, Graphics, int, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a tab of a tabbed pane.
paintTabbedPaneTabBorder(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a tab of a tabbed pane.
paintTabbedPaneTabBorder(SynthContext, Graphics, int, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a tab of a tabbed pane.
paintTabBorder(Graphics, int, int, int, int, int, int, boolean) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
this function draws the border around each tab note that this function does now draw the background of the tab.
paintTabBorder(Graphics, int, int, int, int, int, int, boolean) - Method in class javax.swing.plaf.metal.MetalTabbedPaneUI
paintTableBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a table.
paintTableBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a table.
paintTableHeaderBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of the header of a table.
paintTableHeaderBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of the header of a table.
paintText(Graphics, JComponent, Rectangle, String) - Method in class javax.swing.plaf.basic.BasicButtonUI
As of Java 2 platform v 1.4 this method should not be used or overriden.
paintText(Graphics, AbstractButton, Rectangle, String) - Method in class javax.swing.plaf.basic.BasicButtonUI
Method which renders the text of the current button.
paintText(Graphics, JMenuItem, Rectangle, String) - Method in class javax.swing.plaf.basic.BasicMenuItemUI
Renders the text of the current menu item.
paintText(Graphics, int, Font, FontMetrics, int, String, Rectangle, boolean) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
paintText(Graphics, JComponent, Rectangle, String) - Method in class javax.swing.plaf.metal.MetalButtonUI
paintText(Graphics, JComponent, Rectangle, String) - Method in class javax.swing.plaf.metal.MetalToggleButtonUI
paintText(SynthContext, Graphics, String, Rectangle, int) - Method in class javax.swing.plaf.synth.SynthGraphicsUtils
Paints text at the specified location.
paintText(SynthContext, Graphics, String, int, int, int) - Method in class javax.swing.plaf.synth.SynthGraphicsUtils
Paints text at the specified location.
paintText(SynthContext, Graphics, String, Icon, int, int, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthGraphicsUtils
Paints an icon and text.
paintText(SynthContext, Graphics, String) - Method in class javax.swing.plaf.synth.SynthProgressBarUI
Paints the component's text.
paintTextAreaBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a text area.
paintTextAreaBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a text area.
paintTextFieldBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a text field.
paintTextFieldBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a text field.
paintTextPaneBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a text pane.
paintTextPaneBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a text pane.
paintThumb(Graphics, JComponent, Rectangle) - Method in class javax.swing.plaf.basic.BasicScrollBarUI
paintThumb(Graphics) - Method in class javax.swing.plaf.basic.BasicSliderUI
paintThumb(Graphics, JComponent, Rectangle) - Method in class javax.swing.plaf.metal.MetalScrollBarUI
paintThumb(Graphics) - Method in class javax.swing.plaf.metal.MetalSliderUI
paintThumb(SynthContext, Graphics, Rectangle) - Method in class javax.swing.plaf.synth.SynthScrollBarUI
Paints the scrollbar thumb.
paintThumb(SynthContext, Graphics, Rectangle) - Method in class javax.swing.plaf.synth.SynthSliderUI
Paints the slider thumb.
paintTicks(Graphics) - Method in class javax.swing.plaf.basic.BasicSliderUI
paintTitleBackground(Graphics) - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
Invoked from paintComponent.
paintToggleButtonBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a toggle button.
paintToggleButtonBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a toggle button.
paintToolBarBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a tool bar.
paintToolBarBackground(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a tool bar.
paintToolBarBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a tool bar.
paintToolBarBorder(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a tool bar.
paintToolBarContentBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of the tool bar's content area.
paintToolBarContentBackground(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of the tool bar's content area.
paintToolBarContentBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of the content area of a tool bar.
paintToolBarContentBorder(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of the content area of a tool bar.
paintToolBarDragWindowBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of the window containing the tool bar when it has been detached from its primary frame.
paintToolBarDragWindowBackground(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of the window containing the tool bar when it has been detached from its primary frame.
paintToolBarDragWindowBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of the window containing the tool bar when it has been detached from it's primary frame.
paintToolBarDragWindowBorder(SynthContext, Graphics, int, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of the window containing the tool bar when it has been detached from it's primary frame.
paintToolTipBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a tool tip.
paintToolTipBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a tool tip.
paintTopTabBorder(int, Graphics, int, int, int, int, int, int, boolean) - Method in class javax.swing.plaf.metal.MetalTabbedPaneUI
paintTrack(Graphics, JComponent, Rectangle) - Method in class javax.swing.plaf.basic.BasicScrollBarUI
paintTrack(Graphics) - Method in class javax.swing.plaf.basic.BasicSliderUI
paintTrack(Graphics, JComponent, Rectangle) - Method in class javax.swing.plaf.metal.MetalScrollBarUI
paintTrack(Graphics) - Method in class javax.swing.plaf.metal.MetalSliderUI
paintTrack(SynthContext, Graphics, Rectangle) - Method in class javax.swing.plaf.synth.SynthScrollBarUI
Paints the scrollbar track.
paintTrack(SynthContext, Graphics, Rectangle) - Method in class javax.swing.plaf.synth.SynthSliderUI
Paints the slider track.
paintTreeBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of a tree.
paintTreeBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a tree.
paintTreeCellBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of the row containing a cell in a tree.
paintTreeCellBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of the row containing a cell in a tree.
paintTreeCellFocus(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the focus indicator for a cell in a tree when it has focus.
paintTriangle(Graphics, int, int, int, int, boolean) - Method in class javax.swing.plaf.basic.BasicArrowButton
Paints a triangle.
paintValue(Graphics, Rectangle) - Method in interface java.beans.PropertyEditor
Paint a representation of the value into a given area of screen real estate.
paintValue(Graphics, Rectangle) - Method in class java.beans.PropertyEditorSupport
Paint a representation of the value into a given area of screen real estate.
paintVerticalLabel(Graphics, int, Component) - Method in class javax.swing.plaf.basic.BasicSliderUI
Called for every label in the label table.
paintVerticalLine(Graphics, JComponent, int, int, int) - Method in class javax.swing.plaf.basic.BasicTreeUI
Paints a vertical line.
paintVerticalLine(Graphics, JComponent, int, int, int) - Method in class javax.swing.plaf.synth.SynthTreeUI
Paints a vertical line.
paintVerticalPartOfLeg(Graphics, Rectangle, Insets, TreePath) - Method in class javax.swing.plaf.basic.BasicTreeUI
Paints the vertical part of the leg.
paintVerticalPartOfLeg(Graphics, Rectangle, Insets, TreePath) - Method in class javax.swing.plaf.metal.MetalTreeUI
paintVerticalPartOfLeg(Graphics, Rectangle, Insets, TreePath) - Method in class javax.swing.plaf.synth.SynthTreeUI
Paints the vertical part of the leg.
paintViewportBackground(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the background of the viewport.
paintViewportBorder(SynthContext, Graphics, int, int, int, int) - Method in class javax.swing.plaf.synth.SynthPainter
Paints the border of a viewport.
PALETTE_LAYER - Static variable in class javax.swing.JLayeredPane
Convenience object defining the Palette layer.
PaletteBorder() - Constructor for class javax.swing.plaf.metal.MetalBorders.PaletteBorder
PaletteCloseIcon() - Constructor for class javax.swing.plaf.metal.MetalIconFactory.PaletteCloseIcon
paletteCloseIcon - Variable in class javax.swing.plaf.metal.MetalInternalFrameTitlePane
paletteTitleHeight - Variable in class javax.swing.plaf.metal.MetalInternalFrameTitlePane
PAN - Static variable in class javax.sound.sampled.FloatControl.Type
Represents a control for the relative pan (left-right positioning) of the signal.
Panel - Class in java.awt
Panel is the simplest container class.
Panel() - Constructor for class java.awt.Panel
Creates a new panel using the default layout manager.
Panel(LayoutManager) - Constructor for class java.awt.Panel
Creates a new panel with the specified layout manager.
PANEL - Static variable in class javax.accessibility.AccessibleRole
A generic container that is often used to group objects.
PANEL - Static variable in class javax.swing.plaf.synth.Region
Panel region.
Panel.AccessibleAWTPanel - Class in java.awt
This class implements accessibility support for the Panel class.
PANEL_UI - Static variable in class javax.print.ServiceUIFactory
Denotes a UI implemented as an AWT panel.
PanelUI - Class in javax.swing.plaf
Pluggable look and feel interface for Panel.
PanelUI() - Constructor for class javax.swing.plaf.PanelUI
Paper - Class in java.awt.print
The Paper class describes the physical characteristics of a piece of paper.
Paper() - Constructor for class java.awt.print.Paper
Creates a letter sized piece of paper with one inch margins.
PARA_INDENT_LEFT - Static variable in class javax.swing.text.html.HTMLEditorKit
The paragraph left indent action identifier
PARA_INDENT_RIGHT - Static variable in class javax.swing.text.html.HTMLEditorKit
The paragraph right indent action identifier
PARAGRAPH - Static variable in class javax.accessibility.AccessibleRole
A text paragraph
PARAGRAPH_SEPARATOR - Static variable in class java.lang.Character
General category "Zp" in the Unicode specification.
ParagraphAction() - Constructor for class javax.swing.text.html.HTMLDocument.HTMLReader.ParagraphAction
ParagraphElementName - Static variable in class javax.swing.text.AbstractDocument
Name of elements used to represent paragraphs
ParagraphView - Class in javax.swing.text.html
Displays the a paragraph, and uses css attributes for its configuration.
ParagraphView(Element) - Constructor for class javax.swing.text.html.ParagraphView
Constructs a ParagraphView for the given element.
ParagraphView - Class in javax.swing.text
View of a simple line-wrapping paragraph that supports multiple fonts, colors, components, icons, etc.
ParagraphView(Element) - Constructor for class javax.swing.text.ParagraphView
Constructs a ParagraphView for the given element.
parallel() - Method in interface java.util.stream.BaseStream
Returns an equivalent stream that is parallel.
parallel() - Method in interface java.util.stream.DoubleStream
parallel() - Method in interface java.util.stream.IntStream
parallel() - Method in interface java.util.stream.LongStream
parallelPrefix(T[], BinaryOperator<T>) - Static method in class java.util.Arrays
Cumulates, in parallel, each element of the given array in place, using the supplied function.
parallelPrefix(T[], int, int, BinaryOperator<T>) - Static method in class java.util.Arrays
Performs Arrays.parallelPrefix(Object[], BinaryOperator) for the given subrange of the array.
parallelPrefix(long[], LongBinaryOperator) - Static method in class java.util.Arrays
Cumulates, in parallel, each element of the given array in place, using the supplied function.
parallelPrefix(long[], int, int, LongBinaryOperator) - Static method in class java.util.Arrays
Performs Arrays.parallelPrefix(long[], LongBinaryOperator) for the given subrange of the array.
parallelPrefix(double[], DoubleBinaryOperator) - Static method in class java.util.Arrays
Cumulates, in parallel, each element of the given array in place, using the supplied function.
parallelPrefix(double[], int, int, DoubleBinaryOperator) - Static method in class java.util.Arrays
Performs Arrays.parallelPrefix(double[], DoubleBinaryOperator) for the given subrange of the array.
parallelPrefix(int[], IntBinaryOperator) - Static method in class java.util.Arrays
Cumulates, in parallel, each element of the given array in place, using the supplied function.
parallelPrefix(int[], int, int, IntBinaryOperator) - Static method in class java.util.Arrays
Performs Arrays.parallelPrefix(int[], IntBinaryOperator) for the given subrange of the array.
parallelSetAll(T[], IntFunction<? extends T>) - Static method in class java.util.Arrays
Set all elements of the specified array, in parallel, using the provided generator function to compute each element.
parallelSetAll(int[], IntUnaryOperator) - Static method in class java.util.Arrays
Set all elements of the specified array, in parallel, using the provided generator function to compute each element.
parallelSetAll(long[], IntToLongFunction) - Static method in class java.util.Arrays
Set all elements of the specified array, in parallel, using the provided generator function to compute each element.
parallelSetAll(double[], IntToDoubleFunction) - Static method in class java.util.Arrays
Set all elements of the specified array, in parallel, using the provided generator function to compute each element.
parallelSort(byte[]) - Static method in class java.util.Arrays
Sorts the specified array into ascending numerical order.
parallelSort(byte[], int, int) - Static method in class java.util.Arrays
Sorts the specified range of the array into ascending numerical order.
parallelSort(char[]) - Static method in class java.util.Arrays
Sorts the specified array into ascending numerical order.
parallelSort(char[], int, int) - Static method in class java.util.Arrays
Sorts the specified range of the array into ascending numerical order.
parallelSort(short[]) - Static method in class java.util.Arrays
Sorts the specified array into ascending numerical order.
parallelSort(short[], int, int) - Static method in class java.util.Arrays
Sorts the specified range of the array into ascending numerical order.
parallelSort(int[]) - Static method in class java.util.Arrays
Sorts the specified array into ascending numerical order.
parallelSort(int[], int, int) - Static method in class java.util.Arrays
Sorts the specified range of the array into ascending numerical order.
parallelSort(long[]) - Static method in class java.util.Arrays
Sorts the specified array into ascending numerical order.
parallelSort(long[], int, int) - Static method in class java.util.Arrays
Sorts the specified range of the array into ascending numerical order.
parallelSort(float[]) - Static method in class java.util.Arrays
Sorts the specified array into ascending numerical order.
parallelSort(float[], int, int) - Static method in class java.util.Arrays
Sorts the specified range of the array into ascending numerical order.
parallelSort(double[]) - Static method in class java.util.Arrays
Sorts the specified array into ascending numerical order.
parallelSort(double[], int, int) - Static method in class java.util.Arrays
Sorts the specified range of the array into ascending numerical order.
parallelSort(T[]) - Static method in class java.util.Arrays
Sorts the specified array of objects into ascending order, according to the natural ordering of its elements.
parallelSort(T[], int, int) - Static method in class java.util.Arrays
Sorts the specified range of the specified array of objects into ascending order, according to the natural ordering of its elements.
parallelSort(T[], Comparator<? super T>) - Static method in class java.util.Arrays
Sorts the specified array of objects according to the order induced by the specified comparator.
parallelSort(T[], int, int, Comparator<? super T>) - Static method in class java.util.Arrays
Sorts the specified range of the specified array of objects according to the order induced by the specified comparator.
parallelStream() - Method in interface java.util.Collection
Returns a possibly parallel Stream with this collection as its source.
PARAM - Static variable in class javax.swing.text.html.HTML.Tag
param - Variable in class javax.swing.text.html.parser.DTD
PARAM_IN - Static variable in class org.omg.CORBA.ParameterMode
PARAM_INOUT - Static variable in class org.omg.CORBA.ParameterMode
PARAM_OUT - Static variable in class org.omg.CORBA.ParameterMode
Parameter - Class in java.lang.reflect
Information about method parameters.
PARAMETER - Static variable in interface javax.swing.text.html.parser.DTDConstants
Parameter - Class in org.omg.Dynamic
org/omg/Dynamic/Parameter.java .
Parameter() - Constructor for class org.omg.Dynamic.Parameter
Parameter(Any, ParameterMode) - Constructor for class org.omg.Dynamic.Parameter
parameterArray() - Method in class java.lang.invoke.MethodType
Presents the parameter types as an array (a convenience method).
ParameterBlock - Class in java.awt.image.renderable
A ParameterBlock encapsulates all the information about sources and parameters (Objects) required by a RenderableImageOp, or other classes that process images.
ParameterBlock() - Constructor for class java.awt.image.renderable.ParameterBlock
A dummy constructor.
ParameterBlock(Vector<Object>) - Constructor for class java.awt.image.renderable.ParameterBlock
Constructs a ParameterBlock with a given Vector of sources.
ParameterBlock(Vector<Object>, Vector<Object>) - Constructor for class java.awt.image.renderable.ParameterBlock
Constructs a ParameterBlock with a given Vector of sources and Vector of parameters.
parameterCount() - Method in class java.lang.invoke.MethodType
Returns the number of parameter types in this method type.
ParameterDescriptor - Class in java.beans
The ParameterDescriptor class allows bean implementors to provide additional information on each of their parameters, beyond the low level type information provided by the java.lang.reflect.Method class.
ParameterDescriptor() - Constructor for class java.beans.ParameterDescriptor
Public default constructor.
Parameterizable - Interface in javax.lang.model.element
A mixin interface for an element that has type parameters.
ParameterizedType - Interface in java.lang.reflect
ParameterizedType represents a parameterized type such as Collection<String>.
parameterList() - Method in class java.lang.invoke.MethodType
Presents the parameter types as a list (a convenience method).
ParameterMetaData - Interface in java.sql
An object that can be used to get information about the types and properties for each parameter marker in a PreparedStatement object.
ParameterMode - Class in org.omg.CORBA
Enumeration of parameter modes for Parameter.
ParameterMode(int) - Constructor for class org.omg.CORBA.ParameterMode
ParameterModeHelper - Class in org.omg.CORBA
Enumeration of parameter modes for Parameter.
ParameterModeHelper() - Constructor for class org.omg.CORBA.ParameterModeHelper
ParameterModeHolder - Class in org.omg.CORBA
Enumeration of parameter modes for Parameter.
ParameterModeHolder() - Constructor for class org.omg.CORBA.ParameterModeHolder
ParameterModeHolder(ParameterMode) - Constructor for class org.omg.CORBA.ParameterModeHolder
parameterModeIn - Static variable in interface java.sql.ParameterMetaData
The constant indicating that the parameter's mode is IN.
parameterModeInOut - Static variable in interface java.sql.ParameterMetaData
The constant indicating that the parameter's mode is INOUT.
parameterModeOut - Static variable in interface java.sql.ParameterMetaData
The constant indicating that the parameter's mode is OUT.
parameterModeUnknown - Static variable in interface java.sql.ParameterMetaData
The constant indicating that the mode of the parameter is unknown.
parameterModifiers() - Static method in class java.lang.reflect.Modifier
Return an int value OR-ing together the source language modifiers that can be applied to a parameter.
parameterNoNulls - Static variable in interface java.sql.ParameterMetaData
The constant indicating that a parameter will not allow NULL values.
parameterNullable - Static variable in interface java.sql.ParameterMetaData
The constant indicating that a parameter will allow NULL values.
parameterNullableUnknown - Static variable in interface java.sql.ParameterMetaData
The constant indicating that the nullability of a parameter is unknown.
parameters - Variable in class java.awt.image.renderable.ParameterBlock
A Vector of non-source parameters, stored as arbitrary Objects.
parameterType(int) - Method in class java.lang.invoke.MethodType
Returns the parameter type at the specified index, within this method type.
params(NVList) - Method in class org.omg.CORBA.ServerRequest
Deprecated.
use the method arguments
paramString() - Method in class java.awt.AWTEvent
Returns a string representing the state of this Event.
paramString() - Method in class java.awt.Button
Returns a string representing the state of this Button.
paramString() - Method in class java.awt.Checkbox
Returns a string representing the state of this Checkbox.
paramString() - Method in class java.awt.CheckboxMenuItem
Returns a string representing the state of this CheckBoxMenuItem.
paramString() - Method in class java.awt.Choice
Returns a string representing the state of this Choice menu.
paramString() - Method in class java.awt.Component
Returns a string representing the state of this component.
paramString() - Method in class java.awt.Container
Returns a string representing the state of this Container.
paramString() - Method in class java.awt.Dialog
Returns a string representing the state of this dialog.
paramString() - Method in class java.awt.event.ActionEvent
Returns a parameter string identifying this action event.
paramString() - Method in class java.awt.event.AdjustmentEvent
paramString() - Method in class java.awt.event.ComponentEvent
Returns a parameter string identifying this event.
paramString() - Method in class java.awt.event.ContainerEvent
Returns a parameter string identifying this event.
paramString() - Method in class java.awt.event.FocusEvent
Returns a parameter string identifying this event.
paramString() - Method in class java.awt.event.HierarchyEvent
Returns a parameter string identifying this event.
paramString() - Method in class java.awt.event.InputMethodEvent
Returns a parameter string identifying this event.
paramString() - Method in class java.awt.event.InvocationEvent
Returns a parameter string identifying this event.
paramString() - Method in class java.awt.event.ItemEvent
Returns a parameter string identifying this item event.
paramString() - Method in class java.awt.event.KeyEvent
Returns a parameter string identifying this event.
paramString() - Method in class java.awt.event.MouseEvent
Returns a parameter string identifying this event.
paramString() - Method in class java.awt.event.MouseWheelEvent
Returns a parameter string identifying this event.
paramString() - Method in class java.awt.event.PaintEvent
paramString() - Method in class java.awt.Event
NOTE: The Event class is obsolete and is available only for backwards compatibility.
paramString() - Method in class java.awt.event.TextEvent
Returns a parameter string identifying this text event.
paramString() - Method in class java.awt.event.WindowEvent
Returns a parameter string identifying this event.
paramString() - Method in class java.awt.FileDialog
Returns a string representing the state of this FileDialog window.
paramString() - Method in class java.awt.Frame
Returns a string representing the state of this Frame.
paramString() - Method in class java.awt.Label
Returns a string representing the state of this Label.
paramString() - Method in class java.awt.List
Returns the parameter string representing the state of this scrolling list.
paramString() - Method in class java.awt.Menu
Returns a string representing the state of this Menu.
paramString() - Method in class java.awt.MenuComponent
Returns a string representing the state of this MenuComponent.
paramString() - Method in class java.awt.MenuItem
Returns a string representing the state of this MenuItem.
paramString() - Method in class java.awt.MenuShortcut
Returns the parameter string representing the state of this MenuShortcut.
paramString() - Method in class java.awt.Scrollbar
Returns a string representing the state of this Scrollbar.
paramString() - Method in class java.awt.ScrollPane
Returns a string representing the state of this ScrollPane.
paramString() - Method in class java.awt.ScrollPaneAdjustable
Returns a string representing the state of this scrollbar.
paramString() - Method in class java.awt.TextArea
Returns a string representing the state of this TextArea.
paramString() - Method in class java.awt.TextComponent
Returns a string representing the state of this TextComponent.
paramString() - Method in class java.awt.TextField
Returns a string representing the state of this TextField.
paramString() - Method in class javax.swing.AbstractButton
Returns a string representation of this AbstractButton.
paramString() - Method in class javax.swing.event.InternalFrameEvent
Returns a parameter string identifying this event.
paramString() - Method in class javax.swing.JApplet
Returns a string representation of this JApplet.
paramString() - Method in class javax.swing.JButton
Returns a string representation of this JButton.
paramString() - Method in class javax.swing.JCheckBox
Returns a string representation of this JCheckBox.
paramString() - Method in class javax.swing.JCheckBoxMenuItem
Returns a string representation of this JCheckBoxMenuItem.
paramString() - Method in class javax.swing.JColorChooser
Returns a string representation of this JColorChooser.
paramString() - Method in class javax.swing.JComboBox
Returns a string representation of this JComboBox.
paramString() - Method in class javax.swing.JComponent
Returns a string representation of this JComponent.
paramString() - Method in class javax.swing.JDesktopPane
Returns a string representation of this JDesktopPane.
paramString() - Method in class javax.swing.JDialog
Returns a string representation of this JDialog.
paramString() - Method in class javax.swing.JEditorPane
Returns a string representation of this JEditorPane.
paramString() - Method in class javax.swing.JFileChooser
Returns a string representation of this JFileChooser.
paramString() - Method in class javax.swing.JFrame
Returns a string representation of this JFrame.
paramString() - Method in class javax.swing.JInternalFrame
Returns a string representation of this JInternalFrame.
paramString() - Method in class javax.swing.JLabel
Returns a string representation of this JLabel.
paramString() - Method in class javax.swing.JLayeredPane
Returns a string representation of this JLayeredPane.
paramString() - Method in class javax.swing.JList
Returns a String representation of this JList.
paramString() - Method in class javax.swing.JMenu
Returns a string representation of this JMenu.
paramString() - Method in class javax.swing.JMenuBar
Returns a string representation of this JMenuBar.
paramString() - Method in class javax.swing.JMenuItem
Returns a string representation of this JMenuItem.
paramString() - Method in class javax.swing.JOptionPane
Returns a string representation of this JOptionPane.
paramString() - Method in class javax.swing.JPanel
Returns a string representation of this JPanel.
paramString() - Method in class javax.swing.JPasswordField
Returns a string representation of this JPasswordField.
paramString() - Method in class javax.swing.JPopupMenu
Returns a string representation of this JPopupMenu.
paramString() - Method in class javax.swing.JProgressBar
Returns a string representation of this JProgressBar.
paramString() - Method in class javax.swing.JRadioButton
Returns a string representation of this JRadioButton.
paramString() - Method in class javax.swing.JRadioButtonMenuItem
Returns a string representation of this JRadioButtonMenuItem.
paramString() - Method in class javax.swing.JRootPane
Returns a string representation of this JRootPane.
paramString() - Method in class javax.swing.JScrollBar
Returns a string representation of this JScrollBar.
paramString() - Method in class javax.swing.JScrollPane
Returns a string representation of this JScrollPane.
paramString() - Method in class javax.swing.JSeparator
Returns a string representation of this JSeparator.
paramString() - Method in class javax.swing.JSlider
Returns a string representation of this JSlider.
paramString() - Method in class javax.swing.JSplitPane
Returns a string representation of this JSplitPane.
paramString() - Method in class javax.swing.JTabbedPane
Returns a string representation of this JTabbedPane.
paramString() - Method in class javax.swing.JTable
Returns a string representation of this table.
paramString() - Method in class javax.swing.JTextArea
Returns a string representation of this JTextArea.
paramString() - Method in class javax.swing.JTextField
Returns a string representation of this JTextField.
paramString() - Method in class javax.swing.JTextPane
Returns a string representation of this JTextPane.
paramString() - Method in class javax.swing.JToggleButton
Returns a string representation of this JToggleButton.
paramString() - Method in class javax.swing.JToolBar
Returns a string representation of this JToolBar.
paramString() - Method in class javax.swing.JToolTip
Returns a string representation of this JToolTip.
paramString() - Method in class javax.swing.JTree
Returns a string representation of this JTree.
paramString() - Method in class javax.swing.JViewport
Returns a string representation of this JViewport.
paramString() - Method in class javax.swing.JWindow
Returns a string representation of this JWindow.
paramString() - Method in class javax.swing.table.JTableHeader
Returns a string representation of this JTableHeader.
paramString() - Method in class javax.swing.text.JTextComponent
Returns a string representation of this JTextComponent.
parent - Variable in class java.awt.image.Raster
The parent of this Raster, or null.
parent() - Method in class java.util.prefs.AbstractPreferences
Implements the parent method as per the specification in Preferences.parent().
parent() - Method in class java.util.prefs.Preferences
Returns the parent of this preference node, or null if this is the root.
parent - Variable in class java.util.ResourceBundle
The parent bundle of this bundle.
parent - Variable in class javax.swing.tree.DefaultMutableTreeNode
this node's parent, or null if this node has no parent
parent() - Method in class org.omg.CORBA.Context
Retrieves the parent of this Context object.
PARENT_CHANGED - Static variable in class java.awt.event.HierarchyEvent
A change flag indicates that the HIERARCHY_CHANGED event was generated by a reparenting operation.
PARENT_WINDOW_OF - Static variable in class javax.accessibility.AccessibleRelation
Indicates that an object is a parent window of one or more objects.
PARENT_WINDOW_OF_PROPERTY - Static variable in class javax.accessibility.AccessibleRelation
Indicates the PARENT_WINDOW_OF relation between two or more objects has changed.
parentOf(ThreadGroup) - Method in class java.lang.ThreadGroup
Tests if this thread group is either the thread group argument or one of its ancestor thread groups.
parentTag - Variable in class javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction
Tag to check for in the document.
park(Object) - Static method in class java.util.concurrent.locks.LockSupport
Disables the current thread for thread scheduling purposes unless the permit is available.
park() - Static method in class java.util.concurrent.locks.LockSupport
Disables the current thread for thread scheduling purposes unless the permit is available.
parkNanos(Object, long) - Static method in class java.util.concurrent.locks.LockSupport
Disables the current thread for thread scheduling purposes, for up to the specified waiting time, unless the permit is available.
parkNanos(long) - Static method in class java.util.concurrent.locks.LockSupport
Disables the current thread for thread scheduling purposes, for up to the specified waiting time, unless the permit is available.
parkUntil(Object, long) - Static method in class java.util.concurrent.locks.LockSupport
Disables the current thread for thread scheduling purposes, until the specified deadline, unless the permit is available.
parkUntil(long) - Static method in class java.util.concurrent.locks.LockSupport
Disables the current thread for thread scheduling purposes, until the specified deadline, unless the permit is available.
parse(String) - Static method in class java.net.HttpCookie
Constructs cookies from set-cookie or set-cookie2 header string.
parse(String, ParsePosition) - Method in class java.text.ChoiceFormat
Parses a Number from the input text.
parse(String) - Method in class java.text.DateFormat
Parses text from the beginning of the given string to produce a date.
parse(String, ParsePosition) - Method in class java.text.DateFormat
Parse a date/time string according to the given parse position.
parse(String, ParsePosition) - Method in class java.text.DecimalFormat
Parses text from a string to produce a Number.
parse(String, ParsePosition) - Method in class java.text.MessageFormat
Parses the string.
parse(String) - Method in class java.text.MessageFormat
Parses text from the beginning of the given string to produce an object array.
parse(String, ParsePosition) - Method in class java.text.NumberFormat
Returns a Long if possible (e.g., within the range [Long.MIN_VALUE, Long.MAX_VALUE] and with no decimals), otherwise a Double.
parse(String) - Method in class java.text.NumberFormat
Parses text from the beginning of the given string to produce a number.
parse(String, ParsePosition) - Method in class java.text.SimpleDateFormat
Parses text from a string to produce a Date.
parse(CharSequence) - Static method in class java.time.Duration
Obtains a Duration from a text string such as PnDTnHnMn.nS.
parse(CharSequence) - Method in class java.time.format.DateTimeFormatter
Fully parses the text producing a temporal object.
parse(CharSequence, ParsePosition) - Method in class java.time.format.DateTimeFormatter
Parses the text using this formatter, providing control over the text position.
parse(CharSequence, TemporalQuery<T>) - Method in class java.time.format.DateTimeFormatter
Fully parses the text producing an object of the specified type.
parse(CharSequence) - Static method in class java.time.Instant
Obtains an instance of Instant from a text string such as 2007-12-03T10:15:30.00Z.
parse(CharSequence) - Static method in class java.time.LocalDate
Obtains an instance of LocalDate from a text string such as 2007-12-03.
parse(CharSequence, DateTimeFormatter) - Static method in class java.time.LocalDate
Obtains an instance of LocalDate from a text string using a specific formatter.
parse(CharSequence) - Static method in class java.time.LocalDateTime
Obtains an instance of LocalDateTime from a text string such as 2007-12-03T10:15:30.
parse(CharSequence, DateTimeFormatter) - Static method in class java.time.LocalDateTime
Obtains an instance of LocalDateTime from a text string using a specific formatter.
parse(CharSequence) - Static method in class java.time.LocalTime
Obtains an instance of LocalTime from a text string such as 10:15.
parse(CharSequence, DateTimeFormatter) - Static method in class java.time.LocalTime
Obtains an instance of LocalTime from a text string using a specific formatter.
parse(CharSequence) - Static method in class java.time.MonthDay
Obtains an instance of MonthDay from a text string such as --12-03.
parse(CharSequence, DateTimeFormatter) - Static method in class java.time.MonthDay
Obtains an instance of MonthDay from a text string using a specific formatter.
parse(CharSequence) - Static method in class java.time.OffsetDateTime
Obtains an instance of OffsetDateTime from a text string such as 2007-12-03T10:15:30+01:00.
parse(CharSequence, DateTimeFormatter) - Static method in class java.time.OffsetDateTime
Obtains an instance of OffsetDateTime from a text string using a specific formatter.
parse(CharSequence) - Static method in class java.time.OffsetTime
Obtains an instance of OffsetTime from a text string such as 10:15:30+01:00.
parse(CharSequence, DateTimeFormatter) - Static method in class java.time.OffsetTime
Obtains an instance of OffsetTime from a text string using a specific formatter.
parse(CharSequence) - Static method in class java.time.Period
Obtains a Period from a text string such as PnYnMnD.
parse(CharSequence) - Static method in class java.time.Year
Obtains an instance of Year from a text string such as 2007.
parse(CharSequence, DateTimeFormatter) - Static method in class java.time.Year
Obtains an instance of Year from a text string using a specific formatter.
parse(CharSequence) - Static method in class java.time.YearMonth
Obtains an instance of YearMonth from a text string such as 2007-12.
parse(CharSequence, DateTimeFormatter) - Static method in class java.time.YearMonth
Obtains an instance of YearMonth from a text string using a specific formatter.
parse(CharSequence) - Static method in class java.time.ZonedDateTime
Obtains an instance of ZonedDateTime from a text string such as 2007-12-03T10:15:30+01:00[Europe/Paris].
parse(CharSequence, DateTimeFormatter) - Static method in class java.time.ZonedDateTime
Obtains an instance of ZonedDateTime from a text string using a specific formatter.
parse(String) - Static method in class java.util.Date
Deprecated.
As of JDK version 1.1, replaced by DateFormat.parse(String s).
parse(String) - Static method in class java.util.Locale.LanguageRange
Parses the given ranges to generate a Language Priority List.
parse(String, Map<String, List<String>>) - Static method in class java.util.Locale.LanguageRange
Parses the given ranges to generate a Language Priority List, and then customizes the list using the given map.
parse(String) - Static method in class java.util.logging.Level
Parse a level name string into a Level.
parse(String) - Method in class javax.activation.MimeTypeParameterList
A routine for parsing the parameter list out of a String.
parse(String) - Method in interface javax.naming.NameParser
Parses a name into its components.
parse(Reader, HTMLEditorKit.ParserCallback, boolean) - Method in class javax.swing.text.html.HTMLEditorKit.Parser
Parse the given stream and drive the given callback with the results of the parse.
parse(Reader, HTMLEditorKit.ParserCallback, boolean) - Method in class javax.swing.text.html.parser.DocumentParser
parse(Reader) - Method in class javax.swing.text.html.parser.Parser
Parse an HTML stream, given a DTD.
parse(Reader, HTMLEditorKit.ParserCallback, boolean) - Method in class javax.swing.text.html.parser.ParserDelegator
parse(InputStream) - Method in class javax.xml.parsers.DocumentBuilder
Parse the content of the given InputStream as an XML document and return a new DOM Document object.
parse(InputStream, String) - Method in class javax.xml.parsers.DocumentBuilder
Parse the content of the given InputStream as an XML document and return a new DOM Document object.
parse(String) - Method in class javax.xml.parsers.DocumentBuilder
Parse the content of the given URI as an XML document and return a new DOM Document object.
parse(File) - Method in class javax.xml.parsers.DocumentBuilder
Parse the content of the given file as an XML document and return a new DOM Document object.
parse(InputSource) - Method in class javax.xml.parsers.DocumentBuilder
Parse the content of the given input source as an XML document and return a new DOM Document object.
parse(InputStream, HandlerBase) - Method in class javax.xml.parsers.SAXParser
Parse the content of the given InputStream instance as XML using the specified HandlerBase.
parse(InputStream, HandlerBase, String) - Method in class javax.xml.parsers.SAXParser
Parse the content of the given InputStream instance as XML using the specified HandlerBase.
parse(InputStream, DefaultHandler) - Method in class javax.xml.parsers.SAXParser
Parse the content of the given InputStream instance as XML using the specified DefaultHandler.
parse(InputStream, DefaultHandler, String) - Method in class javax.xml.parsers.SAXParser
Parse the content of the given InputStream instance as XML using the specified DefaultHandler.
parse(String, HandlerBase) - Method in class javax.xml.parsers.SAXParser
Parse the content described by the giving Uniform Resource Identifier (URI) as XML using the specified HandlerBase.
parse(String, DefaultHandler) - Method in class javax.xml.parsers.SAXParser
Parse the content described by the giving Uniform Resource Identifier (URI) as XML using the specified DefaultHandler.
parse(File, HandlerBase) - Method in class javax.xml.parsers.SAXParser
Parse the content of the file specified as XML using the specified HandlerBase.
parse(File, DefaultHandler) - Method in class javax.xml.parsers.SAXParser
Parse the content of the file specified as XML using the specified DefaultHandler.
parse(InputSource, HandlerBase) - Method in class javax.xml.parsers.SAXParser
Parse the content given InputSource as XML using the specified HandlerBase.
parse(InputSource, DefaultHandler) - Method in class javax.xml.parsers.SAXParser
Parse the content given InputSource as XML using the specified DefaultHandler.
parse(LSInput) - Method in interface org.w3c.dom.ls.LSParser
Parse an XML document from a resource identified by a LSInput.
parse(String) - Method in class org.xml.sax.helpers.ParserAdapter
Parse an XML document.
parse(InputSource) - Method in class org.xml.sax.helpers.ParserAdapter
Parse an XML document.
parse(InputSource) - Method in class org.xml.sax.helpers.XMLFilterImpl
Parse a document.
parse(String) - Method in class org.xml.sax.helpers.XMLFilterImpl
Parse a document.
parse(String) - Method in class org.xml.sax.helpers.XMLReaderAdapter
Parse the document.
parse(InputSource) - Method in class org.xml.sax.helpers.XMLReaderAdapter
Parse the document.
parse(InputSource) - Method in interface org.xml.sax.Parser
Deprecated.
Parse an XML document.
parse(String) - Method in interface org.xml.sax.Parser
Deprecated.
Parse an XML document from a system identifier (URI).
parse(InputSource) - Method in interface org.xml.sax.XMLReader
Parse an XML document.
parse(String) - Method in interface org.xml.sax.XMLReader
Parse an XML document from a system identifier (URI).
PARSE_ERR - Static variable in exception org.w3c.dom.ls.LSException
If an attempt was made to load a document, or an XML Fragment, using LSParser and the processing has been stopped.
parseAnySimpleType(String) - Static method in class javax.xml.bind.DatatypeConverter
Return a string containing the lexical representation of the simple type.
parseAnySimpleType(String) - Method in interface javax.xml.bind.DatatypeConverterInterface
Return a string containing the lexical representation of the simple type.
parseBase64Binary(String) - Static method in class javax.xml.bind.DatatypeConverter
Converts the string argument into an array of bytes.
parseBase64Binary(String) - Method in interface javax.xml.bind.DatatypeConverterInterface
Converts the string argument into an array of bytes.
parseBest(CharSequence, TemporalQuery<?>...) - Method in class java.time.format.DateTimeFormatter
Fully parses the text producing an object of one of the specified types.
parseBoolean(String) - Static method in class java.lang.Boolean
Parses the string argument as a boolean.
parseBoolean(String) - Static method in class javax.xml.bind.DatatypeConverter
Converts the string argument into a boolean value.
parseBoolean(String) - Method in interface javax.xml.bind.DatatypeConverterInterface
Converts the string argument into a boolean value.
parseBuffer - Variable in class javax.swing.text.html.HTMLDocument.HTMLReader
parseByte(String, int) - Static method in class java.lang.Byte
Parses the string argument as a signed byte in the radix specified by the second argument.
parseByte(String) - Static method in class java.lang.Byte
Parses the string argument as a signed decimal byte.
parseByte(String) - Static method in class javax.xml.bind.DatatypeConverter
Converts the string argument into a byte value.
parseByte(String) - Method in interface javax.xml.bind.DatatypeConverterInterface
Converts the string argument into a byte value.
parseCaseInsensitive() - Method in class java.time.format.DateTimeFormatterBuilder
Changes the parse style to be case insensitive for the remainder of the formatter.
parseCaseSensitive() - Method in class java.time.format.DateTimeFormatterBuilder
Changes the parse style to be case sensitive for the remainder of the formatter.
ParseConversionEvent - Interface in javax.xml.bind
This event indicates that a problem was encountered while converting a string from the XML data into a value of the target Java data type.
ParseConversionEventImpl - Class in javax.xml.bind.helpers
Default implementation of the ParseConversionEvent interface.
ParseConversionEventImpl(int, String, ValidationEventLocator) - Constructor for class javax.xml.bind.helpers.ParseConversionEventImpl
Create a new ParseConversionEventImpl.
ParseConversionEventImpl(int, String, ValidationEventLocator, Throwable) - Constructor for class javax.xml.bind.helpers.ParseConversionEventImpl
Create a new ParseConversionEventImpl.
parseDate(String) - Static method in class javax.xml.bind.DatatypeConverter
Converts the string argument into a Calendar value.
parseDate(String) - Method in interface javax.xml.bind.DatatypeConverterInterface
Converts the string argument into a Calendar value.
parseDateTime(String) - Static method in class javax.xml.bind.DatatypeConverter
Converts the string argument into a Calendar value.
parseDateTime(String) - Method in interface javax.xml.bind.DatatypeConverterInterface
Converts the string argument into a Calendar value.
parseDecimal(String) - Static method in class javax.xml.bind.DatatypeConverter
Converts the string argument into a BigDecimal value.
parseDecimal(String) - Method in interface javax.xml.bind.DatatypeConverterInterface
Converts the string argument into a BigDecimal value.
parseDefaulting(TemporalField, long) - Method in class java.time.format.DateTimeFormatterBuilder
Appends a default value for a field to the formatter for use in parsing.
parsedExcessDays() - Static method in class java.time.format.DateTimeFormatter
A query that provides access to the excess days that were parsed.
parsedLeapSecond() - Static method in class java.time.format.DateTimeFormatter
A query that provides access to whether a leap-second was parsed.
parseDouble(String) - Static method in class java.lang.Double
Returns a new double initialized to the value represented by the specified String, as performed by the valueOf method of class Double.
parseDouble(String) - Static method in class javax.xml.bind.DatatypeConverter
Converts the string argument into a double value.
parseDouble(String) - Method in interface javax.xml.bind.DatatypeConverterInterface
Converts the string argument into a double value.
parseDTDMarkup() - Method in class javax.swing.text.html.parser.Parser
Parses th Document Declaration Type markup declaration.
ParseException - Exception in java.text
Signals that an error has been reached unexpectedly while parsing.
ParseException(String, int) - Constructor for exception java.text.ParseException
Constructs a ParseException with the specified detail message and offset.
parseFloat(String) - Static method in class java.lang.Float
Returns a new float initialized to the value represented by the specified String, as performed by the valueOf method of class Float.
parseFloat(String) - Static method in class javax.xml.bind.DatatypeConverter
Converts the string argument into a float value.
parseFloat(String) - Method in interface javax.xml.bind.DatatypeConverterInterface
Converts the string argument into a float value.
parseHexBinary(String) - Static method in class javax.xml.bind.DatatypeConverter
Converts the string argument into an array of bytes.
parseHexBinary(String) - Method in interface javax.xml.bind.DatatypeConverterInterface
Converts the string argument into an array of bytes.
parseInt(String, int) - Static method in class java.lang.Integer
Parses the string argument as a signed integer in the radix specified by the second argument.
parseInt(String) - Static method in class java.lang.Integer
Parses the string argument as a signed decimal integer.
parseInt(String) - Static method in class javax.xml.bind.DatatypeConverter
Convert the string argument into an int value.
parseInt(String) - Method in interface javax.xml.bind.DatatypeConverterInterface
Convert the string argument into an int value.
parseInteger(String) - Static method in class javax.xml.bind.DatatypeConverter
Convert the string argument into a BigInteger value.
parseInteger(String) - Method in interface javax.xml.bind.DatatypeConverterInterface
Convert the string argument into a BigInteger value.
parseLenient() - Method in class java.time.format.DateTimeFormatterBuilder
Changes the parse style to be lenient for the remainder of the formatter.
parseLevel(String) - Static method in class java.rmi.server.LogStream
Deprecated.
no replacement
parseLong(String, int) - Static method in class java.lang.Long
Parses the string argument as a signed long in the radix specified by the second argument.
parseLong(String) - Static method in class java.lang.Long
Parses the string argument as a signed decimal long.
parseLong(String) - Static method in class javax.xml.bind.DatatypeConverter
Converts the string argument into a long value.
parseLong(String) - Method in interface javax.xml.bind.DatatypeConverterInterface
Converts the string argument into a long value.
parseMarkupDeclarations(StringBuffer) - Method in class javax.swing.text.html.parser.Parser
Parse markup declarations.
parseNumbers() - Method in class java.io.StreamTokenizer
Specifies that numbers should be parsed by this tokenizer.
parseObject(String, ParsePosition) - Method in class java.text.DateFormat
Parses text from a string to produce a Date.
parseObject(String, ParsePosition) - Method in class java.text.Format
Parses text from a string to produce an object.
parseObject(String) - Method in class java.text.Format
Parses text from the beginning of the given string to produce an object.
parseObject(String, ParsePosition) - Method in class java.text.MessageFormat
Parses text from a string to produce an object array.
parseObject(String, ParsePosition) - Method in class java.text.NumberFormat
Parses text from a string to produce a Number.
ParsePosition - Class in java.text
ParsePosition is a simple class used by Format and its subclasses to keep track of the current position during parsing.
ParsePosition(int) - Constructor for class java.text.ParsePosition
Create a new ParsePosition with the given initial index.
parseQName(String, NamespaceContext) - Static method in class javax.xml.bind.DatatypeConverter
Converts the string argument into a byte value.
parseQName(String, NamespaceContext) - Method in interface javax.xml.bind.DatatypeConverterInterface
Converts the string argument into a QName value.
Parser() - Constructor for class javax.swing.text.html.HTMLEditorKit.Parser
Parser - Class in javax.swing.text.html.parser
A simple DTD-driven HTML parser.
Parser(DTD) - Constructor for class javax.swing.text.html.parser.Parser
Parser - Interface in org.xml.sax
Deprecated.
This interface has been replaced by the SAX2 XMLReader interface, which includes Namespace support.
ParserAdapter - Class in org.xml.sax.helpers
Adapt a SAX1 Parser as a SAX2 XMLReader.
ParserAdapter() - Constructor for class org.xml.sax.helpers.ParserAdapter
Construct a new parser adapter.
ParserAdapter(Parser) - Constructor for class org.xml.sax.helpers.ParserAdapter
Construct a new parser adapter.
ParserCallback() - Constructor for class javax.swing.text.html.HTMLEditorKit.ParserCallback
ParserConfigurationException - Exception in javax.xml.parsers
Indicates a serious configuration error.
ParserConfigurationException() - Constructor for exception javax.xml.parsers.ParserConfigurationException
Create a new ParserConfigurationException with no detail mesage.
ParserConfigurationException(String) - Constructor for exception javax.xml.parsers.ParserConfigurationException
Create a new ParserConfigurationException with the String specified as an error message.
ParserDelegator - Class in javax.swing.text.html.parser
Responsible for starting up a new DocumentParser each time its parse method is invoked.
ParserDelegator() - Constructor for class javax.swing.text.html.parser.ParserDelegator
ParserFactory - Class in org.xml.sax.helpers
Deprecated.
This class works with the deprecated Parser interface.
parseServerAuthority() - Method in class java.net.URI
Attempts to parse this URI's authority component, if defined, into user-information, host, and port components.
parseShort(String, int) - Static method in class java.lang.Short
Parses the string argument as a signed short in the radix specified by the second argument.
parseShort(String) - Static method in class java.lang.Short
Parses the string argument as a signed decimal short.
parseShort(String) - Static method in class javax.xml.bind.DatatypeConverter
Converts the string argument into a short value.
parseShort(String) - Method in interface javax.xml.bind.DatatypeConverterInterface
Converts the string argument into a short value.
parseStrict() - Method in class java.time.format.DateTimeFormatterBuilder
Changes the parse style to be strict for the remainder of the formatter.
parseString(String) - Static method in class javax.xml.bind.DatatypeConverter
Convert the lexical XSD string argument into a String value.
parseString(String) - Method in interface javax.xml.bind.DatatypeConverterInterface
Convert the string argument into a string.
parseTime(String) - Static method in class javax.xml.bind.DatatypeConverter
Converts the string argument into a Calendar value.
parseTime(String) - Method in interface javax.xml.bind.DatatypeConverterInterface
Converts the string argument into a Calendar value.
parseUnresolved(CharSequence, ParsePosition) - Method in class java.time.format.DateTimeFormatter
Parses the text using this formatter, without resolving the result, intended for advanced use cases.
parseUnsignedInt(String, int) - Static method in class java.lang.Integer
Parses the string argument as an unsigned integer in the radix specified by the second argument.
parseUnsignedInt(String) - Static method in class java.lang.Integer
Parses the string argument as an unsigned decimal integer.
parseUnsignedInt(String) - Static method in class javax.xml.bind.DatatypeConverter
Converts the string argument into a long value.
parseUnsignedInt(String) - Method in interface javax.xml.bind.DatatypeConverterInterface
Converts the string argument into a long value.
parseUnsignedLong(String, int) - Static method in class java.lang.Long
Parses the string argument as an unsigned long in the radix specified by the second argument.
parseUnsignedLong(String) - Static method in class java.lang.Long
Parses the string argument as an unsigned decimal long.
parseUnsignedShort(String) - Static method in class javax.xml.bind.DatatypeConverter
Converts the string argument into an int value.
parseUnsignedShort(String) - Method in interface javax.xml.bind.DatatypeConverterInterface
Converts the string argument into an int value.
parseURI(String) - Method in interface org.w3c.dom.ls.LSParser
Parse an XML document from a location identified by a URI reference [IETF RFC 2396].
parseURL(URL, String, int, int) - Method in class java.net.URLStreamHandler
Parses the string representation of a URL into a URL object.
parseWithContext(LSInput, Node, short) - Method in interface org.w3c.dom.ls.LSParser
Parse an XML fragment from a resource identified by a LSInput and insert the content into an existing document at the position specified with the context and action arguments.
PartialResultException - Exception in javax.naming
This exception is thrown to indicate that the result being returned or returned so far is partial, and that the operation cannot be completed.
PartialResultException(String) - Constructor for exception javax.naming.PartialResultException
Constructs a new instance of the exception using the explanation message specified.
PartialResultException() - Constructor for exception javax.naming.PartialResultException
Constructs a new instance of PartialResultException.
partitioningBy(Predicate<? super T>) - Static method in class java.util.stream.Collectors
Returns a Collector which partitions the input elements according to a Predicate, and organizes them into a Map<Boolean, List<T>>.
partitioningBy(Predicate<? super T>, Collector<? super T, A, D>) - Static method in class java.util.stream.Collectors
Returns a Collector which partitions the input elements according to a Predicate, reduces the values in each partition according to another Collector, and organizes them into a Map<Boolean, D> whose values are the result of the downstream reduction.
PASS - Static variable in interface java.util.jar.Pack200.Packer
The string "pass", a possible value for certain properties.
PASS_FILE_PFX - Static variable in interface java.util.jar.Pack200.Packer
Indicates that a file should be passed through bytewise, with no compression.
passComplete(ImageReader, BufferedImage) - Method in interface javax.imageio.event.IIOReadUpdateListener
Reports that the current read operation has completed a progressive pass.
passStarted(ImageReader, BufferedImage, int, int, int, int, int, int, int, int[]) - Method in interface javax.imageio.event.IIOReadUpdateListener
Reports that the current read operation is about to begin a progressive pass.
PASSWORD_FIELD - Static variable in class javax.swing.plaf.synth.Region
PasswordField region.
PASSWORD_PROPERTY - Static variable in interface javax.xml.ws.BindingProvider
Standard property: Password for authentication.
PASSWORD_TEXT - Static variable in class javax.accessibility.AccessibleRole
A text object used for passwords, or other places where the text contents is not shown visibly to the user
PasswordAuthentication - Class in java.net
The class PasswordAuthentication is a data holder that is used by Authenticator.
PasswordAuthentication(String, char[]) - Constructor for class java.net.PasswordAuthentication
Creates a new PasswordAuthentication object from the given user name and password.
PasswordCallback - Class in javax.security.auth.callback
Underlying security services instantiate and pass a PasswordCallback to the handle method of a CallbackHandler to retrieve password information.
PasswordCallback(String, boolean) - Constructor for class javax.security.auth.callback.PasswordCallback
Construct a PasswordCallback with a prompt and a boolean specifying whether the password should be displayed as it is being typed.
PasswordProtection(char[]) - Constructor for class java.security.KeyStore.PasswordProtection
Creates a password parameter.
PasswordProtection(char[], String, AlgorithmParameterSpec) - Constructor for class java.security.KeyStore.PasswordProtection
Creates a password parameter and specifies the protection algorithm and associated parameters to use when encrypting a keystore entry.
PasswordView - Class in javax.swing.text
Implements a View suitable for use in JPasswordField UI implementations.
PasswordView(Element) - Constructor for class javax.swing.text.PasswordView
Constructs a new view wrapped on an element.
paste(int) - Method in interface javax.accessibility.AccessibleEditableText
Pastes the text from the system clipboard into the text starting at the specified index.
paste(int) - Method in class javax.swing.JSpinner.AccessibleJSpinner
Pastes the text from the system clipboard into the text starting at the specified index.
paste(int) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent
Pastes the text from the system clipboard into the text starting at the specified index.
paste() - Method in class javax.swing.text.JTextComponent
Transfers the contents of the system clipboard into the associated text model.
pasteAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the action to paste the contents of the system clipboard into the selected region, or before the caret if nothing is selected.
PasteAction() - Constructor for class javax.swing.text.DefaultEditorKit.PasteAction
Create this object with the appropriate identifier.
Patch - Class in javax.sound.midi
A Patch object represents a location, on a MIDI synthesizer, into which a single instrument is stored (loaded).
Patch(int, int) - Constructor for class javax.sound.midi.Patch
Constructs a new patch object from the specified bank and program numbers.
Path - Interface in java.nio.file
An object that may be used to locate a file in a file system.
path - Variable in class javax.swing.event.TreeExpansionEvent
Path to the value this event represents.
path - Variable in class javax.swing.event.TreeModelEvent
Path to the parent of the nodes that have changed.
Path2D - Class in java.awt.geom
The Path2D class provides a simple, yet flexible shape which represents an arbitrary geometric path.
Path2D.Double - Class in java.awt.geom
The Double class defines a geometric path with coordinates stored in double precision floating point.
Path2D.Float - Class in java.awt.geom
The Float class defines a geometric path with coordinates stored in single precision floating point.
PATH_INFO - Static variable in interface javax.xml.ws.handler.MessageContext
Standard property: Request Path Info
pathByAddingChild(Object) - Method in class javax.swing.tree.TreePath
Returns a new path containing all the elements of this path plus child.
pathFromAncestorEnumeration(TreeNode) - Method in class javax.swing.tree.DefaultMutableTreeNode
Creates and returns an enumeration that follows the path from ancestor to this node.
PathIterator - Interface in java.awt.geom
The PathIterator interface provides the mechanism for objects that implement the Shape interface to return the geometry of their boundary by allowing a caller to retrieve the path of that boundary a segment at a time.
PathMatcher - Interface in java.nio.file
An interface that is implemented by objects that perform match operations on paths.
Paths - Class in java.nio.file
This class consists exclusively of static methods that return a Path by converting a path string or URI.
paths - Variable in class javax.swing.event.TreeSelectionEvent
Paths this event represents.
pathSeparator - Static variable in class java.io.File
The system-dependent path-separator character, represented as a string for convenience.
pathSeparatorChar - Static variable in class java.io.File
The system-dependent path-separator character.
pathToPoint(Point2D, boolean, Point2D) - Method in class java.awt.font.LayoutPath
Convert a location relative to the path to a point in user coordinates.
pathWasCollapsed(TreePath) - Method in class javax.swing.plaf.basic.BasicTreeUI
Messaged from the VisibleTreeNode after it has collapsed.
pathWasExpanded(TreePath) - Method in class javax.swing.plaf.basic.BasicTreeUI
Messaged from the VisibleTreeNode after it has been expanded.
pattern() - Method in class java.util.regex.Matcher
Returns the pattern that is interpreted by this matcher.
Pattern - Class in java.util.regex
A compiled representation of a regular expression.
pattern() - Method in class java.util.regex.Pattern
Returns the regular expression from which this pattern was compiled.
PatternSyntaxException - Exception in java.util.regex
Unchecked exception thrown to indicate a syntax error in a regular-expression pattern.
PatternSyntaxException(String, String, int) - Constructor for exception java.util.regex.PatternSyntaxException
Constructs a new instance of this class.
PAUSE - Static variable in class java.awt.Event
The Pause key, a non-ASCII action key.
PAUSED - Static variable in class javax.print.attribute.standard.PrinterStateReason
Someone has paused the printer and the printer's PrinterState is STOPPED.
PBEKey - Interface in javax.crypto.interfaces
The interface to a PBE key.
PBEKeySpec - Class in javax.crypto.spec
A user-chosen password that can be used with password-based encryption (PBE).
PBEKeySpec(char[]) - Constructor for class javax.crypto.spec.PBEKeySpec
Constructor that takes a password.
PBEKeySpec(char[], byte[], int, int) - Constructor for class javax.crypto.spec.PBEKeySpec
Constructor that takes a password, salt, iteration count, and to-be-derived key length for generating PBEKey of variable-key-size PBE ciphers.
PBEKeySpec(char[], byte[], int) - Constructor for class javax.crypto.spec.PBEKeySpec
Constructor that takes a password, salt, iteration count for generating PBEKey of fixed-key-size PBE ciphers.
PBEParameterSpec - Class in javax.crypto.spec
This class specifies the set of parameters used with password-based encryption (PBE), as defined in the PKCS #5 standard.
PBEParameterSpec(byte[], int) - Constructor for class javax.crypto.spec.PBEParameterSpec
Constructs a parameter set for password-based encryption as defined in the PKCS #5 standard.
PBEParameterSpec(byte[], int, AlgorithmParameterSpec) - Constructor for class javax.crypto.spec.PBEParameterSpec
Constructs a parameter set for password-based encryption as defined in the PKCS #5 standard.
pcdata - Variable in class javax.swing.text.html.parser.DTD
PCL - Static variable in class javax.print.DocFlavor.BYTE_ARRAY
Doc flavor with MIME type = "application/vnd.hp-PCL", print data representation class name = "[B" (byte array).
PCL - Static variable in class javax.print.DocFlavor.INPUT_STREAM
Doc flavor with MIME type = "application/vnd.hp-PCL", print data representation class name = "java.io.InputStream" (byte stream).
PCL - Static variable in class javax.print.DocFlavor.URL
Doc flavor with MIME type = "application/vnd.hp-PCL", print data representation class name = "java.net.URL".
PCM_FLOAT - Static variable in class javax.sound.sampled.AudioFormat.Encoding
Specifies floating-point PCM data.
PCM_SIGNED - Static variable in class javax.sound.sampled.AudioFormat.Encoding
Specifies signed, linear PCM data.
PCM_UNSIGNED - Static variable in class javax.sound.sampled.AudioFormat.Encoding
Specifies unsigned, linear PCM data.
pcSupport - Variable in class java.beans.beancontext.BeanContextChildSupport
The PropertyChangeSupport associated with this BeanContextChildSupport.
PDF - Static variable in class javax.print.DocFlavor.BYTE_ARRAY
Doc flavor with MIME type = "application/pdf", print data representation class name = "[B" (byte array).
PDF - Static variable in class javax.print.DocFlavor.INPUT_STREAM
Doc flavor with MIME type = "application/pdf", print data representation class name = "java.io.InputStream" (byte stream).
PDF - Static variable in class javax.print.DocFlavor.URL
Doc flavor with MIME type = "application/pdf", print data representation class name = "java.net.URL".
PDLOverrideSupported - Class in javax.print.attribute.standard
Class PDLOverrideSupported is a printing attribute class, an enumeration, that expresses the printer's ability to attempt to override processing instructions embedded in documents' print data with processing instructions specified as attributes outside the print data.
PDLOverrideSupported(int) - Constructor for class javax.print.attribute.standard.PDLOverrideSupported
Construct a new PDL override supported enumeration value with the given integer value.
peek(InetAddress) - Method in class java.net.DatagramSocketImpl
Peek at the packet to see who it is from.
peek() - Method in class java.util.ArrayDeque
Retrieves, but does not remove, the head of the queue represented by this deque, or returns null if this deque is empty.
peek() - Method in class java.util.concurrent.ArrayBlockingQueue
peek() - Method in interface java.util.concurrent.BlockingDeque
Retrieves, but does not remove, the head of the queue represented by this deque (in other words, the first element of this deque), or returns null if this deque is empty.
peek() - Method in class java.util.concurrent.ConcurrentLinkedDeque
peek() - Method in class java.util.concurrent.ConcurrentLinkedQueue
peek() - Method in class java.util.concurrent.DelayQueue
Retrieves, but does not remove, the head of this queue, or returns null if this queue is empty.
peek() - Method in class java.util.concurrent.LinkedBlockingDeque
peek() - Method in class java.util.concurrent.LinkedBlockingQueue
peek() - Method in class java.util.concurrent.LinkedTransferQueue
peek() - Method in class java.util.concurrent.PriorityBlockingQueue
peek() - Method in class java.util.concurrent.SynchronousQueue
Always returns null.
peek() - Method in interface java.util.Deque
Retrieves, but does not remove, the head of the queue represented by this deque (in other words, the first element of this deque), or returns null if this deque is empty.
peek() - Method in class java.util.LinkedList
Retrieves, but does not remove, the head (first element) of this list.
peek() - Method in class java.util.PriorityQueue
peek() - Method in interface java.util.Queue
Retrieves, but does not remove, the head of this queue, or returns null if this queue is empty.
peek() - Method in class java.util.Stack
Looks at the object at the top of this stack without removing it from the stack.
peek(DoubleConsumer) - Method in interface java.util.stream.DoubleStream
Returns a stream consisting of the elements of this stream, additionally performing the provided action on each element as elements are consumed from the resulting stream.
peek(IntConsumer) - Method in interface java.util.stream.IntStream
Returns a stream consisting of the elements of this stream, additionally performing the provided action on each element as elements are consumed from the resulting stream.
peek(LongConsumer) - Method in interface java.util.stream.LongStream
Returns a stream consisting of the elements of this stream, additionally performing the provided action on each element as elements are consumed from the resulting stream.
peek(Consumer<? super T>) - Method in interface java.util.stream.Stream
Returns a stream consisting of the elements of this stream, additionally performing the provided action on each element as elements are consumed from the resulting stream.
peek() - Method in class javax.xml.stream.util.EventReaderDelegate
peek() - Method in interface javax.xml.stream.XMLEventReader
Check the next XMLEvent without reading it from the stream.
peekData(DatagramPacket) - Method in class java.net.DatagramSocketImpl
Peek at the packet to see who it is from.
peekEvent() - Method in class java.awt.EventQueue
Returns the first event on the EventQueue without removing it.
peekEvent(int) - Method in class java.awt.EventQueue
Returns the first event with the specified id, if any.
peekFirst() - Method in class java.util.ArrayDeque
peekFirst() - Method in class java.util.concurrent.ConcurrentLinkedDeque
peekFirst() - Method in class java.util.concurrent.LinkedBlockingDeque
peekFirst() - Method in interface java.util.Deque
Retrieves, but does not remove, the first element of this deque, or returns null if this deque is empty.
peekFirst() - Method in class java.util.LinkedList
Retrieves, but does not remove, the first element of this list, or returns null if this list is empty.
peekLast() - Method in class java.util.ArrayDeque
peekLast() - Method in class java.util.concurrent.ConcurrentLinkedDeque
peekLast() - Method in class java.util.concurrent.LinkedBlockingDeque
peekLast() - Method in interface java.util.Deque
Retrieves, but does not remove, the last element of this deque, or returns null if this deque is empty.
peekLast() - Method in class java.util.LinkedList
Retrieves, but does not remove, the last element of this list, or returns null if this list is empty.
peekNextLocalTask() - Static method in class java.util.concurrent.ForkJoinTask
Returns, but does not unschedule or execute, a task queued by the current thread but not yet executed, if one is immediately available.
PENDING - Static variable in class javax.print.attribute.standard.JobState
The job is a candidate to start processing, but is not yet processing.
PENDING_HELD - Static variable in class javax.print.attribute.standard.JobState
The job is not a candidate for processing for any number of reasons but will return to the PENDING state as soon as the reasons are no longer present.
PERCENT - Static variable in class java.text.NumberFormat.Field
Constant identifying the percent field.
perform_work() - Method in class org.omg.CORBA.ORB
Performs an implementation-dependent unit of work if called by the main thread.
performDefaultLayout() - Method in class java.awt.font.GlyphVector
Assigns default positions to each glyph in this GlyphVector.
period(int, int, int) - Method in interface java.time.chrono.Chronology
Obtains a period for this chronology based on years, months and days.
period(int, int, int) - Method in class java.time.chrono.IsoChronology
Obtains a period for this chronology based on years, months and days.
Period - Class in java.time
A date-based amount of time in the ISO-8601 calendar system, such as '2 years, 3 months and 4 days'.
PERMILLE - Static variable in class java.text.NumberFormat.Field
Constant identifying the permille field.
Permission - Interface in java.security.acl
This interface represents a permission, such as that used to grant a particular type of access to a resource.
Permission - Class in java.security
Abstract class for representing access to a system resource.
Permission(String) - Constructor for class java.security.Permission
Constructs a permission with the specified name.
PermissionCollection - Class in java.security
Abstract class representing a collection of Permission objects.
PermissionCollection() - Constructor for class java.security.PermissionCollection
permissions() - Method in class java.nio.file.attribute.AclEntry
Returns a copy of the permissions component.
permissions() - Method in interface java.nio.file.attribute.PosixFileAttributes
Returns the permissions of the file.
permissions() - Method in interface java.security.acl.AclEntry
Returns an enumeration of the permissions in this ACL entry.
Permissions - Class in java.security
This class represents a heterogeneous collection of Permissions.
Permissions() - Constructor for class java.security.Permissions
Creates a new Permissions object containing no PermissionCollections.
permits(Set<CryptoPrimitive>, String, AlgorithmParameters) - Method in interface java.security.AlgorithmConstraints
Determines whether an algorithm is granted permission for the specified cryptographic primitives.
permits(Set<CryptoPrimitive>, Key) - Method in interface java.security.AlgorithmConstraints
Determines whether a key is granted permission for the specified cryptographic primitives.
permits(Set<CryptoPrimitive>, String, Key, AlgorithmParameters) - Method in interface java.security.AlgorithmConstraints
Determines whether an algorithm and the corresponding key are granted permission for the specified cryptographic primitives.
permuteArguments(MethodHandle, MethodType, int...) - Static method in class java.lang.invoke.MethodHandles
Produces a method handle which adapts the calling sequence of the given method handle to a new type, by reordering the arguments.
PERSIST - Static variable in class javax.swing.JFormattedTextField
Constant identifying that when focus is lost, the edited value should be left.
PERSIST_STORE - Exception in org.omg.CORBA
This exception indicates a persistent storage failure, for example, failure to establish a database connection or corruption of a database.
PERSIST_STORE() - Constructor for exception org.omg.CORBA.PERSIST_STORE
Constructs a PERSIST_STORE exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
PERSIST_STORE(String) - Constructor for exception org.omg.CORBA.PERSIST_STORE
Constructs a PERSIST_STORE exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
PERSIST_STORE(int, CompletionStatus) - Constructor for exception org.omg.CORBA.PERSIST_STORE
Constructs a PERSIST_STORE exception with the specified minor code and completion status.
PERSIST_STORE(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.PERSIST_STORE
Constructs a PERSIST_STORE exception with the specified description message, minor code, and completion status.
PersistenceDelegate - Class in java.beans
The PersistenceDelegate class takes the responsibility for expressing the state of an instance of a given class in terms of the methods in the class's public API.
PersistenceDelegate() - Constructor for class java.beans.PersistenceDelegate
PERSISTENT - Static variable in class org.omg.PortableServer.LifespanPolicyValue
PersistentMBean - Interface in javax.management
This class is the interface to be implemented by MBeans that are meant to be persistent.
PERSONAL - Static variable in class java.awt.PageAttributes.MediaType
An alias for PERSONAL_ENVELOPE.
PERSONAL_ENVELOPE - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for 6 3/4 envelope, 3 5/8 x 6 1/2 in.
PERSONAL_ENVELOPE - Static variable in class javax.print.attribute.standard.MediaSize.Other
Specifies the Personal envelope size, 3.625 inch by 6.5 inch.
PERSONAL_ENVELOPE - Static variable in class javax.print.attribute.standard.MediaSizeName
personal envelope size .
PGDN - Static variable in class java.awt.Event
The Page Down key, a non-ASCII action key.
PGPData - Interface in javax.xml.crypto.dsig.keyinfo
A representation of the XML PGPData element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
PGUP - Static variable in class java.awt.Event
The Page Up key, a non-ASCII action key.
PHAGS_PA - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Phags-pa" Unicode character block.
PHAISTOS_DISC - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Phaistos Disc" Unicode character block.
PhantomReference<T> - Class in java.lang.ref
Phantom reference objects, which are enqueued after the collector determines that their referents may otherwise be reclaimed.
PhantomReference(T, ReferenceQueue<? super T>) - Constructor for class java.lang.ref.PhantomReference
Creates a new phantom reference that refers to the given object and is registered with the given queue.
Phaser - Class in java.util.concurrent
A reusable synchronization barrier, similar in functionality to CyclicBarrier and CountDownLatch but supporting more flexible usage.
Phaser() - Constructor for class java.util.concurrent.Phaser
Creates a new phaser with no initially registered parties, no parent, and initial phase number 0.
Phaser(int) - Constructor for class java.util.concurrent.Phaser
Creates a new phaser with the given number of registered unarrived parties, no parent, and initial phase number 0.
Phaser(Phaser) - Constructor for class java.util.concurrent.Phaser
Equivalent to Phaser(parent, 0).
Phaser(Phaser, int) - Constructor for class java.util.concurrent.Phaser
Creates a new phaser with the given parent and number of registered unarrived parties.
PHOENICIAN - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Phoenician" Unicode character block.
PHONETIC_EXTENSIONS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Phonetic Extensions" Unicode character block.
PHONETIC_EXTENSIONS_SUPPLEMENT - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Phonetic Extensions Supplement" Unicode character block.
PHYSICAL - Static variable in class java.awt.PageAttributes.OriginType
The OriginType instance to use for specifying a physical origin.
PI - Static variable in class java.lang.Math
The double value that is closer than any other to pi, the ratio of the circumference of a circle to its diameter.
PI - Static variable in class java.lang.StrictMath
The double value that is closer than any other to pi, the ratio of the circumference of a circle to its diameter.
PI - Static variable in interface javax.swing.text.html.parser.DTDConstants
PI_DISABLE_OUTPUT_ESCAPING - Static variable in interface javax.xml.transform.Result
The name of the processing instruction that is sent if the result tree disables output escaping.
PI_ENABLE_OUTPUT_ESCAPING - Static variable in interface javax.xml.transform.Result
The name of the processing instruction that is sent if the result tree enables output escaping at some point after having received a PI_DISABLE_OUTPUT_ESCAPING processing instruction.
PIE - Static variable in class java.awt.geom.Arc2D
The closure type for an arc closed by drawing straight line segments from the start of the arc segment to the center of the full ellipse and from that point to the end of the arc segment.
pink - Static variable in class java.awt.Color
The color pink.
PINK - Static variable in class java.awt.Color
The color pink.
PIPE - Static variable in class java.lang.ProcessBuilder.Redirect
Indicates that subprocess I/O will be connected to the current Java process over a pipe.
Pipe - Class in java.nio.channels
A pair of channels that implements a unidirectional pipe.
Pipe() - Constructor for class java.nio.channels.Pipe
Initializes a new instance of this class.
Pipe.SinkChannel - Class in java.nio.channels
A channel representing the writable end of a Pipe.
Pipe.SourceChannel - Class in java.nio.channels
A channel representing the readable end of a Pipe.
PIPE_SIZE - Static variable in class java.io.PipedInputStream
The default size of the pipe's circular input buffer.
PipedInputStream - Class in java.io
A piped input stream should be connected to a piped output stream; the piped input stream then provides whatever data bytes are written to the piped output stream.
PipedInputStream(PipedOutputStream) - Constructor for class java.io.PipedInputStream
Creates a PipedInputStream so that it is connected to the piped output stream src.
PipedInputStream(PipedOutputStream, int) - Constructor for class java.io.PipedInputStream
Creates a PipedInputStream so that it is connected to the piped output stream src and uses the specified pipe size for the pipe's buffer.
PipedInputStream() - Constructor for class java.io.PipedInputStream
Creates a PipedInputStream so that it is not yet connected.
PipedInputStream(int) - Constructor for class java.io.PipedInputStream
Creates a PipedInputStream so that it is not yet connected and uses the specified pipe size for the pipe's buffer.
PipedOutputStream - Class in java.io
A piped output stream can be connected to a piped input stream to create a communications pipe.
PipedOutputStream(PipedInputStream) - Constructor for class java.io.PipedOutputStream
Creates a piped output stream connected to the specified piped input stream.
PipedOutputStream() - Constructor for class java.io.PipedOutputStream
Creates a piped output stream that is not yet connected to a piped input stream.
PipedReader - Class in java.io
Piped character-input streams.
PipedReader(PipedWriter) - Constructor for class java.io.PipedReader
Creates a PipedReader so that it is connected to the piped writer src.
PipedReader(PipedWriter, int) - Constructor for class java.io.PipedReader
Creates a PipedReader so that it is connected to the piped writer src and uses the specified pipe size for the pipe's buffer.
PipedReader() - Constructor for class java.io.PipedReader
Creates a PipedReader so that it is not yet connected.
PipedReader(int) - Constructor for class java.io.PipedReader
Creates a PipedReader so that it is not yet connected and uses the specified pipe size for the pipe's buffer.
PipedWriter - Class in java.io
Piped character-output streams.
PipedWriter(PipedReader) - Constructor for class java.io.PipedWriter
Creates a piped writer connected to the specified piped reader.
PipedWriter() - Constructor for class java.io.PipedWriter
Creates a piped writer that is not yet connected to a piped reader.
PITCH_BEND - Static variable in class javax.sound.midi.ShortMessage
Command value for Pitch Bend message (0xE0, or 224)
pixel_bits - Variable in class java.awt.image.ColorModel
The total number of bits in the pixel.
PixelGrabber - Class in java.awt.image
The PixelGrabber class implements an ImageConsumer which can be attached to an Image or ImageProducer object to retrieve a subset of the pixels in that image.
PixelGrabber(Image, int, int, int, int, int[], int, int) - Constructor for class java.awt.image.PixelGrabber
Create a PixelGrabber object to grab the (x, y, w, h) rectangular section of pixels from the specified image into the given array.
PixelGrabber(ImageProducer, int, int, int, int, int[], int, int) - Constructor for class java.awt.image.PixelGrabber
Create a PixelGrabber object to grab the (x, y, w, h) rectangular section of pixels from the image produced by the specified ImageProducer into the given array.
PixelGrabber(Image, int, int, int, int, boolean) - Constructor for class java.awt.image.PixelGrabber
Create a PixelGrabber object to grab the (x, y, w, h) rectangular section of pixels from the specified image.
PixelInterleavedSampleModel - Class in java.awt.image
This class represents image data which is stored in a pixel interleaved fashion and for which each sample of a pixel occupies one data element of the DataBuffer.
PixelInterleavedSampleModel(int, int, int, int, int, int[]) - Constructor for class java.awt.image.PixelInterleavedSampleModel
Constructs a PixelInterleavedSampleModel with the specified parameters.
pixelStride - Variable in class java.awt.image.ComponentSampleModel
Pixel stride (in data array elements) of the region of image data described by this ComponentSampleModel.
PKCS12Attribute - Class in java.security
An attribute associated with a PKCS12 keystore entry.
PKCS12Attribute(String, String) - Constructor for class java.security.PKCS12Attribute
Constructs a PKCS12 attribute from its name and value.
PKCS12Attribute(byte[]) - Constructor for class java.security.PKCS12Attribute
Constructs a PKCS12 attribute from its ASN.1 DER encoding.
PKCS8EncodedKeySpec - Class in java.security.spec
This class represents the ASN.1 encoding of a private key, encoded according to the ASN.1 type PrivateKeyInfo.
PKCS8EncodedKeySpec(byte[]) - Constructor for class java.security.spec.PKCS8EncodedKeySpec
Creates a new PKCS8EncodedKeySpec with the given encoded key.
PKIXBuilderParameters - Class in java.security.cert
Parameters used as input for the PKIX CertPathBuilder algorithm.
PKIXBuilderParameters(Set<TrustAnchor>, CertSelector) - Constructor for class java.security.cert.PKIXBuilderParameters
Creates an instance of PKIXBuilderParameters with the specified Set of most-trusted CAs.
PKIXBuilderParameters(KeyStore, CertSelector) - Constructor for class java.security.cert.PKIXBuilderParameters
Creates an instance of PKIXBuilderParameters that populates the set of most-trusted CAs from the trusted certificate entries contained in the specified KeyStore.
PKIXCertPathBuilderResult - Class in java.security.cert
This class represents the successful result of the PKIX certification path builder algorithm.
PKIXCertPathBuilderResult(CertPath, TrustAnchor, PolicyNode, PublicKey) - Constructor for class java.security.cert.PKIXCertPathBuilderResult
Creates an instance of PKIXCertPathBuilderResult containing the specified parameters.
PKIXCertPathChecker - Class in java.security.cert
An abstract class that performs one or more checks on an X509Certificate.
PKIXCertPathChecker() - Constructor for class java.security.cert.PKIXCertPathChecker
Default constructor.
PKIXCertPathValidatorResult - Class in java.security.cert
This class represents the successful result of the PKIX certification path validation algorithm.
PKIXCertPathValidatorResult(TrustAnchor, PolicyNode, PublicKey) - Constructor for class java.security.cert.PKIXCertPathValidatorResult
Creates an instance of PKIXCertPathValidatorResult containing the specified parameters.
PKIXParameters - Class in java.security.cert
Parameters used as input for the PKIX CertPathValidator algorithm.
PKIXParameters(Set<TrustAnchor>) - Constructor for class java.security.cert.PKIXParameters
Creates an instance of PKIXParameters with the specified Set of most-trusted CAs.
PKIXParameters(KeyStore) - Constructor for class java.security.cert.PKIXParameters
Creates an instance of PKIXParameters that populates the set of most-trusted CAs from the trusted certificate entries contained in the specified KeyStore.
PKIXReason - Enum in java.security.cert
The PKIXReason enumerates the potential PKIX-specific reasons that an X.509 certification path may be invalid according to the PKIX (RFC 3280) standard.
PKIXRevocationChecker - Class in java.security.cert
A PKIXCertPathChecker for checking the revocation status of certificates with the PKIX algorithm.
PKIXRevocationChecker() - Constructor for class java.security.cert.PKIXRevocationChecker
Default constructor.
PKIXRevocationChecker.Option - Enum in java.security.cert
Various revocation options that can be specified for the revocation checking mechanism.
PLAIN - Static variable in class java.awt.Font
The plain style constant.
PLAIN_DIALOG - Static variable in class javax.swing.JRootPane
Constant used for the windowDecorationStyle property.
PLAIN_MESSAGE - Static variable in class javax.swing.JOptionPane
No icon is used.
PlainDocument - Class in javax.swing.text
A plain document that maintains no character attributes.
PlainDocument() - Constructor for class javax.swing.text.PlainDocument
Constructs a plain text document.
PlainDocument(AbstractDocument.Content) - Constructor for class javax.swing.text.PlainDocument
Constructs a plain text document.
plainTextFlavor - Static variable in class java.awt.datatransfer.DataFlavor
Deprecated.
as of 1.3. Use DataFlavor.getReaderForText(Transferable) instead of Transferable.getTransferData(DataFlavor.plainTextFlavor).
PlainView - Class in javax.swing.text
Implements View interface for a simple multi-line text view that has text in one font and color.
PlainView(Element) - Constructor for class javax.swing.text.PlainView
Constructs a new PlainView wrapped on an element.
PlatformLoggingMXBean - Interface in java.lang.management
The management interface for the logging facility.
PlatformManagedObject - Interface in java.lang.management
A platform managed object is a JMX MXBean for monitoring and managing a component in the Java platform.
play(URL) - Method in class java.applet.Applet
Plays the audio clip at the specified absolute URL.
play(URL, String) - Method in class java.applet.Applet
Plays the audio clip given the URL and a specifier that is relative to it.
play() - Method in interface java.applet.AudioClip
Starts playing this audio clip.
PLAYING_CARDS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Playing Cards" Unicode character block.
playSound(Action) - Method in class javax.swing.plaf.basic.BasicLookAndFeel
If necessary, invokes actionPerformed on audioAction to play a sound.
pluginClassName - Variable in class javax.imageio.spi.ImageReaderWriterSpi
A String containing the name of the associated plug-in class, initially null.
plus() - Method in class java.math.BigDecimal
Returns a BigDecimal whose value is (+this), and whose scale is this.scale().
plus(MathContext) - Method in class java.math.BigDecimal
Returns a BigDecimal whose value is (+this), with rounding according to the context settings.
plus(TemporalAmount) - Method in interface java.time.chrono.ChronoLocalDate
Returns an object of the same type as this object with an amount added.
plus(long, TemporalUnit) - Method in interface java.time.chrono.ChronoLocalDate
Returns an object of the same type as this object with the specified period added.
plus(TemporalAmount) - Method in interface java.time.chrono.ChronoLocalDateTime
Returns an object of the same type as this object with an amount added.
plus(long, TemporalUnit) - Method in interface java.time.chrono.ChronoLocalDateTime
Returns an object of the same type as this object with the specified period added.
plus(TemporalAmount) - Method in interface java.time.chrono.ChronoPeriod
Returns a copy of this period with the specified period added.
plus(TemporalAmount) - Method in interface java.time.chrono.ChronoZonedDateTime
Returns an object of the same type as this object with an amount added.
plus(long, TemporalUnit) - Method in interface java.time.chrono.ChronoZonedDateTime
Returns an object of the same type as this object with the specified period added.
plus(TemporalAmount) - Method in class java.time.chrono.HijrahDate
Returns an object of the same type as this object with an amount added.
plus(long, TemporalUnit) - Method in class java.time.chrono.HijrahDate
plus(TemporalAmount) - Method in class java.time.chrono.JapaneseDate
Returns an object of the same type as this object with an amount added.
plus(long, TemporalUnit) - Method in class java.time.chrono.JapaneseDate
plus(TemporalAmount) - Method in class java.time.chrono.MinguoDate
Returns an object of the same type as this object with an amount added.
plus(long, TemporalUnit) - Method in class java.time.chrono.MinguoDate
plus(TemporalAmount) - Method in class java.time.chrono.ThaiBuddhistDate
Returns an object of the same type as this object with an amount added.
plus(long, TemporalUnit) - Method in class java.time.chrono.ThaiBuddhistDate
plus(long) - Method in enum java.time.DayOfWeek
Returns the day-of-week that is the specified number of days after this one.
plus(Duration) - Method in class java.time.Duration
Returns a copy of this duration with the specified duration added.
plus(long, TemporalUnit) - Method in class java.time.Duration
Returns a copy of this duration with the specified duration added.
plus(TemporalAmount) - Method in class java.time.Instant
Returns a copy of this instant with the specified amount added.
plus(long, TemporalUnit) - Method in class java.time.Instant
Returns a copy of this instant with the specified amount added.
plus(TemporalAmount) - Method in class java.time.LocalDate
Returns a copy of this date with the specified amount added.
plus(long, TemporalUnit) - Method in class java.time.LocalDate
Returns a copy of this date with the specified amount added.
plus(TemporalAmount) - Method in class java.time.LocalDateTime
Returns a copy of this date-time with the specified amount added.
plus(long, TemporalUnit) - Method in class java.time.LocalDateTime
Returns a copy of this date-time with the specified amount added.
plus(TemporalAmount) - Method in class java.time.LocalTime
Returns a copy of this time with the specified amount added.
plus(long, TemporalUnit) - Method in class java.time.LocalTime
Returns a copy of this time with the specified amount added.
plus(long) - Method in enum java.time.Month
Returns the month-of-year that is the specified number of quarters after this one.
plus(TemporalAmount) - Method in class java.time.OffsetDateTime
Returns a copy of this date-time with the specified amount added.
plus(long, TemporalUnit) - Method in class java.time.OffsetDateTime
Returns a copy of this date-time with the specified amount added.
plus(TemporalAmount) - Method in class java.time.OffsetTime
Returns a copy of this time with the specified amount added.
plus(long, TemporalUnit) - Method in class java.time.OffsetTime
Returns a copy of this time with the specified amount added.
plus(TemporalAmount) - Method in class java.time.Period
Returns a copy of this period with the specified period added.
plus(TemporalAmount) - Method in interface java.time.temporal.Temporal
Returns an object of the same type as this object with an amount added.
plus(long, TemporalUnit) - Method in interface java.time.temporal.Temporal
Returns an object of the same type as this object with the specified period added.
plus(TemporalAmount) - Method in class java.time.Year
Returns a copy of this year with the specified amount added.
plus(long, TemporalUnit) - Method in class java.time.Year
Returns a copy of this year with the specified amount added.
plus(TemporalAmount) - Method in class java.time.YearMonth
Returns a copy of this year-month with the specified amount added.
plus(long, TemporalUnit) - Method in class java.time.YearMonth
Returns a copy of this year-month with the specified amount added.
plus(TemporalAmount) - Method in class java.time.ZonedDateTime
Returns a copy of this date-time with the specified amount added.
plus(long, TemporalUnit) - Method in class java.time.ZonedDateTime
Returns a copy of this date-time with the specified amount added.
PLUS - Static variable in class javax.management.Query
A code representing the Query.plus(javax.management.ValueExp, javax.management.ValueExp) expression.
plus(ValueExp, ValueExp) - Static method in class javax.management.Query
Returns a binary expression representing the sum of two numeric values, or the concatenation of two string values.
plusDays(long) - Method in class java.time.Duration
Returns a copy of this duration with the specified duration in standard 24 hour days added.
plusDays(long) - Method in class java.time.LocalDate
Returns a copy of this LocalDate with the specified number of days added.
plusDays(long) - Method in class java.time.LocalDateTime
Returns a copy of this LocalDateTime with the specified period in days added.
plusDays(long) - Method in class java.time.OffsetDateTime
Returns a copy of this OffsetDateTime with the specified period in days added.
plusDays(long) - Method in class java.time.Period
Returns a copy of this period with the specified days added.
plusDays(long) - Method in class java.time.ZonedDateTime
Returns a copy of this ZonedDateTime with the specified period in days added.
plusHours(long) - Method in class java.time.Duration
Returns a copy of this duration with the specified duration in hours added.
plusHours(long) - Method in class java.time.LocalDateTime
Returns a copy of this LocalDateTime with the specified period in hours added.
plusHours(long) - Method in class java.time.LocalTime
Returns a copy of this LocalTime with the specified period in hours added.
plusHours(long) - Method in class java.time.OffsetDateTime
Returns a copy of this OffsetDateTime with the specified period in hours added.
plusHours(long) - Method in class java.time.OffsetTime
Returns a copy of this OffsetTime with the specified period in hours added.
plusHours(long) - Method in class java.time.ZonedDateTime
Returns a copy of this ZonedDateTime with the specified period in hours added.
plusMillis(long) - Method in class java.time.Duration
Returns a copy of this duration with the specified duration in milliseconds added.
plusMillis(long) - Method in class java.time.Instant
Returns a copy of this instant with the specified duration in milliseconds added.
plusMinutes(long) - Method in class java.time.Duration
Returns a copy of this duration with the specified duration in minutes added.
plusMinutes(long) - Method in class java.time.LocalDateTime
Returns a copy of this LocalDateTime with the specified period in minutes added.
plusMinutes(long) - Method in class java.time.LocalTime
Returns a copy of this LocalTime with the specified period in minutes added.
plusMinutes(long) - Method in class java.time.OffsetDateTime
Returns a copy of this OffsetDateTime with the specified period in minutes added.
plusMinutes(long) - Method in class java.time.OffsetTime
Returns a copy of this OffsetTime with the specified period in minutes added.
plusMinutes(long) - Method in class java.time.ZonedDateTime
Returns a copy of this ZonedDateTime with the specified period in minutes added.
plusMonths(long) - Method in class java.time.LocalDate
Returns a copy of this LocalDate with the specified period in months added.
plusMonths(long) - Method in class java.time.LocalDateTime
Returns a copy of this LocalDateTime with the specified period in months added.
plusMonths(long) - Method in class java.time.OffsetDateTime
Returns a copy of this OffsetDateTime with the specified period in months added.
plusMonths(long) - Method in class java.time.Period
Returns a copy of this period with the specified months added.
plusMonths(long) - Method in class java.time.YearMonth
Returns a copy of this year-month with the specified period in months added.
plusMonths(long) - Method in class java.time.ZonedDateTime
Returns a copy of this ZonedDateTime with the specified period in months added.
plusNanos(long) - Method in class java.time.Duration
Returns a copy of this duration with the specified duration in nanoseconds added.
plusNanos(long) - Method in class java.time.Instant
Returns a copy of this instant with the specified duration in nanoseconds added.
plusNanos(long) - Method in class java.time.LocalDateTime
Returns a copy of this LocalDateTime with the specified period in nanoseconds added.
plusNanos(long) - Method in class java.time.LocalTime
Returns a copy of this LocalTime with the specified period in nanoseconds added.
plusNanos(long) - Method in class java.time.OffsetDateTime
Returns a copy of this OffsetDateTime with the specified period in nanoseconds added.
plusNanos(long) - Method in class java.time.OffsetTime
Returns a copy of this OffsetTime with the specified period in nanoseconds added.
plusNanos(long) - Method in class java.time.ZonedDateTime
Returns a copy of this ZonedDateTime with the specified period in nanoseconds added.
plusSeconds(long) - Method in class java.time.Duration
Returns a copy of this duration with the specified duration in seconds added.
plusSeconds(long) - Method in class java.time.Instant
Returns a copy of this instant with the specified duration in seconds added.
plusSeconds(long) - Method in class java.time.LocalDateTime
Returns a copy of this LocalDateTime with the specified period in seconds added.
plusSeconds(long) - Method in class java.time.LocalTime
Returns a copy of this LocalTime with the specified period in seconds added.
plusSeconds(long) - Method in class java.time.OffsetDateTime
Returns a copy of this OffsetDateTime with the specified period in seconds added.
plusSeconds(long) - Method in class java.time.OffsetTime
Returns a copy of this OffsetTime with the specified period in seconds added.
plusSeconds(long) - Method in class java.time.ZonedDateTime
Returns a copy of this ZonedDateTime with the specified period in seconds added.
plusWeeks(long) - Method in class java.time.LocalDate
Returns a copy of this LocalDate with the specified period in weeks added.
plusWeeks(long) - Method in class java.time.LocalDateTime
Returns a copy of this LocalDateTime with the specified period in weeks added.
plusWeeks(long) - Method in class java.time.OffsetDateTime
Returns a copy of this OffsetDateTime with the specified period in weeks added.
plusWeeks(long) - Method in class java.time.ZonedDateTime
Returns a copy of this ZonedDateTime with the specified period in weeks added.
plusYears(long) - Method in class java.time.LocalDate
Returns a copy of this LocalDate with the specified period in years added.
plusYears(long) - Method in class java.time.LocalDateTime
Returns a copy of this LocalDateTime with the specified period in years added.
plusYears(long) - Method in class java.time.OffsetDateTime
Returns a copy of this OffsetDateTime with the specified period in years added.
plusYears(long) - Method in class java.time.Period
Returns a copy of this period with the specified years added.
plusYears(long) - Method in class java.time.Year
Returns a copy of this year with the specified number of years added.
plusYears(long) - Method in class java.time.YearMonth
Returns a copy of this year-month with the specified period in years added.
plusYears(long) - Method in class java.time.ZonedDateTime
Returns a copy of this ZonedDateTime with the specified period in years added.
PM - Static variable in class java.util.Calendar
Value of the Calendar.AM_PM field indicating the period of the day from noon to just before midnight.
PNG - Static variable in class javax.print.DocFlavor.BYTE_ARRAY
Doc flavor with MIME type = "image/png", print data representation class name = "[B" (byte array).
PNG - Static variable in class javax.print.DocFlavor.INPUT_STREAM
Doc flavor with MIME type = "image/png", print data representation class name = "java.io.InputStream" (byte stream).
PNG - Static variable in class javax.print.DocFlavor.URL
Doc flavor with MIME type = "image/png", print data representation class name = "java.net.URL".
POA - Interface in org.omg.PortableServer
A POA object manages the implementation of a collection of objects.
poa(Servant) - Method in interface org.omg.PortableServer.portable.Delegate
The method _poa() is equivalent to calling PortableServer::Current:get_POA.
POAHelper - Class in org.omg.PortableServer
A POA object manages the implementation of a collection of objects.
POAHelper() - Constructor for class org.omg.PortableServer.POAHelper
POAManager - Interface in org.omg.PortableServer
Each POA object has an associated POAManager object.
POAManagerOperations - Interface in org.omg.PortableServer
Each POA object has an associated POAManager object.
POAOperations - Interface in org.omg.PortableServer
A POA object manages the implementation of a collection of objects.
Point - Class in java.awt
A point representing a location in (x,y) coordinate space, specified in integer precision.
Point() - Constructor for class java.awt.Point
Constructs and initializes a point at the origin (0, 0) of the coordinate space.
Point(Point) - Constructor for class java.awt.Point
Constructs and initializes a point with the same location as the specified Point object.
Point(int, int) - Constructor for class java.awt.Point
Constructs and initializes a point at the specified (x,y) location in the coordinate space.
Point2D - Class in java.awt.geom
The Point2D class defines a point representing a location in (x,y) coordinate space.
Point2D() - Constructor for class java.awt.geom.Point2D
This is an abstract class that cannot be instantiated directly.
Point2D.Double - Class in java.awt.geom
The Double class defines a point specified in double precision.
Point2D.Float - Class in java.awt.geom
The Float class defines a point specified in float precision.
POINT_INFINITY - Static variable in class java.security.spec.ECPoint
This defines the point at infinity.
PointerInfo - Class in java.awt
A class that describes the pointer position.
pointSize - Variable in class java.awt.Font
The point size of this Font in float.
pointToPath(Point2D, Point2D) - Method in class java.awt.font.LayoutPath
Convert a point in user space to a location relative to the path.
Policy - Class in java.security
A Policy object is responsible for determining whether code executing in the Java runtime environment has permission to perform a security-sensitive operation.
Policy() - Constructor for class java.security.Policy
Policy - Class in javax.security.auth
Deprecated.
as of JDK version 1.4 -- Replaced by java.security.Policy. java.security.Policy has a method:
      public PermissionCollection getPermissions
          (java.security.ProtectionDomain pd)
and ProtectionDomain has a constructor:
      public ProtectionDomain
          (CodeSource cs,
           PermissionCollection permissions,
           ClassLoader loader,
           Principal[] principals)
These two APIs provide callers the means to query the Policy for Principal-based Permission entries.
Policy() - Constructor for class javax.security.auth.Policy
Deprecated.
Sole constructor.
Policy - Interface in org.omg.CORBA
Interfaces derived from the Policy interface allow an ORB or CORBA service access to certain choices that affect its operation.
Policy.Parameters - Interface in java.security
This represents a marker interface for Policy parameters.
POLICY_FORWARD_SECRECY - Static variable in class javax.security.sasl.Sasl
The name of a property that specifies whether mechanisms that implement forward secrecy between sessions are required.
POLICY_NOACTIVE - Static variable in class javax.security.sasl.Sasl
The name of a property that specifies whether mechanisms susceptible to active (non-dictionary) attacks are not permitted.
POLICY_NOANONYMOUS - Static variable in class javax.security.sasl.Sasl
The name of a property that specifies whether mechanisms that accept anonymous login are not permitted.
POLICY_NODICTIONARY - Static variable in class javax.security.sasl.Sasl
The name of a property that specifies whether mechanisms susceptible to passive dictionary attacks are not permitted.
POLICY_NOPLAINTEXT - Static variable in class javax.security.sasl.Sasl
The name of a property that specifies whether mechanisms susceptible to simple plain passive attacks (e.g., "PLAIN") are not permitted.
POLICY_PASS_CREDENTIALS - Static variable in class javax.security.sasl.Sasl
The name of a property that specifies whether mechanisms that pass client credentials are required.
policy_type() - Method in class org.omg.CORBA._PolicyStub
Returns the constant value that corresponds to the type of the policy object.
policy_type() - Method in interface org.omg.CORBA.PolicyOperations
Returns the constant value that corresponds to the type of the policy object.
PolicyError - Exception in org.omg.CORBA
A user exception thrown when a policy error occurs.
PolicyError() - Constructor for exception org.omg.CORBA.PolicyError
Constructs a default PolicyError user exception with no reason code and an empty reason detail message.
PolicyError(short) - Constructor for exception org.omg.CORBA.PolicyError
Constructs a PolicyError user exception initialized with the given reason code and an empty reason detail message.
PolicyError(String, short) - Constructor for exception org.omg.CORBA.PolicyError
Constructs a PolicyError user exception initialized with the given reason detail message and reason code.
PolicyErrorCodeHelper - Class in org.omg.CORBA
Encapsulates a reason a Policy may be invalid.
PolicyErrorCodeHelper() - Constructor for class org.omg.CORBA.PolicyErrorCodeHelper
PolicyErrorHelper - Class in org.omg.CORBA
Thrown to indicate problems with parameter values passed to the ORB.create_policy operation.
PolicyErrorHelper() - Constructor for class org.omg.CORBA.PolicyErrorHelper
PolicyErrorHolder - Class in org.omg.CORBA
Thrown to indicate problems with parameter values passed to the ORB.create_policy operation.
PolicyErrorHolder() - Constructor for class org.omg.CORBA.PolicyErrorHolder
PolicyErrorHolder(PolicyError) - Constructor for class org.omg.CORBA.PolicyErrorHolder
PolicyFactory - Interface in org.omg.PortableInterceptor
Enables policy types to be constructed using CORBA.ORB.create_policy.
PolicyFactoryOperations - Interface in org.omg.PortableInterceptor
Enables policy types to be constructed using CORBA.ORB.create_policy.
PolicyHelper - Class in org.omg.CORBA
The Helper for Policy.
PolicyHelper() - Constructor for class org.omg.CORBA.PolicyHelper
PolicyHolder - Class in org.omg.CORBA
The Holder for Policy.
PolicyHolder() - Constructor for class org.omg.CORBA.PolicyHolder
PolicyHolder(Policy) - Constructor for class org.omg.CORBA.PolicyHolder
PolicyListHelper - Class in org.omg.CORBA
The Helper for PolicyList.
PolicyListHelper() - Constructor for class org.omg.CORBA.PolicyListHelper
PolicyListHolder - Class in org.omg.CORBA
The Holder for PolicyList.
PolicyListHolder() - Constructor for class org.omg.CORBA.PolicyListHolder
PolicyListHolder(Policy[]) - Constructor for class org.omg.CORBA.PolicyListHolder
PolicyNode - Interface in java.security.cert
An immutable valid policy tree node as defined by the PKIX certification path validation algorithm.
PolicyOperations - Interface in org.omg.CORBA
Provides the operations for a Policy object.
PolicyQualifierInfo - Class in java.security.cert
An immutable policy qualifier represented by the ASN.1 PolicyQualifierInfo structure.
PolicyQualifierInfo(byte[]) - Constructor for class java.security.cert.PolicyQualifierInfo
Creates an instance of PolicyQualifierInfo from the encoded bytes.
PolicySpi - Class in java.security
This class defines the Service Provider Interface (SPI) for the Policy class.
PolicySpi() - Constructor for class java.security.PolicySpi
PolicyTypeHelper - Class in org.omg.CORBA
The Helper for PolicyType.
PolicyTypeHelper() - Constructor for class org.omg.CORBA.PolicyTypeHelper
poll() - Method in class java.lang.ref.ReferenceQueue
Polls this queue to see if a reference object is available.
poll() - Method in interface java.nio.file.WatchService
Retrieves and removes the next watch key, or null if none are present.
poll(long, TimeUnit) - Method in interface java.nio.file.WatchService
Retrieves and removes the next watch key, waiting if necessary up to the specified wait time if none are yet present.
poll() - Method in class java.util.ArrayDeque
Retrieves and removes the head of the queue represented by this deque (in other words, the first element of this deque), or returns null if this deque is empty.
poll() - Method in class java.util.concurrent.ArrayBlockingQueue
poll(long, TimeUnit) - Method in class java.util.concurrent.ArrayBlockingQueue
poll() - Method in interface java.util.concurrent.BlockingDeque
Retrieves and removes the head of the queue represented by this deque (in other words, the first element of this deque), or returns null if this deque is empty.
poll(long, TimeUnit) - Method in interface java.util.concurrent.BlockingDeque
Retrieves and removes the head of the queue represented by this deque (in other words, the first element of this deque), waiting up to the specified wait time if necessary for an element to become available.
poll(long, TimeUnit) - Method in interface java.util.concurrent.BlockingQueue
Retrieves and removes the head of this queue, waiting up to the specified wait time if necessary for an element to become available.
poll() - Method in interface java.util.concurrent.CompletionService
Retrieves and removes the Future representing the next completed task, or null if none are present.
poll(long, TimeUnit) - Method in interface java.util.concurrent.CompletionService
Retrieves and removes the Future representing the next completed task, waiting if necessary up to the specified wait time if none are yet present.
poll() - Method in class java.util.concurrent.ConcurrentLinkedDeque
poll() - Method in class java.util.concurrent.ConcurrentLinkedQueue
poll() - Method in class java.util.concurrent.DelayQueue
Retrieves and removes the head of this queue, or returns null if this queue has no elements with an expired delay.
poll(long, TimeUnit) - Method in class java.util.concurrent.DelayQueue
Retrieves and removes the head of this queue, waiting if necessary until an element with an expired delay is available on this queue, or the specified wait time expires.
poll() - Method in class java.util.concurrent.ExecutorCompletionService
poll(long, TimeUnit) - Method in class java.util.concurrent.ExecutorCompletionService
poll() - Method in class java.util.concurrent.LinkedBlockingDeque
poll(long, TimeUnit) - Method in class java.util.concurrent.LinkedBlockingDeque
poll(long, TimeUnit) - Method in class java.util.concurrent.LinkedBlockingQueue
poll() - Method in class java.util.concurrent.LinkedBlockingQueue
poll(long, TimeUnit) - Method in class java.util.concurrent.LinkedTransferQueue
poll() - Method in class java.util.concurrent.LinkedTransferQueue
poll() - Method in class java.util.concurrent.PriorityBlockingQueue
poll(long, TimeUnit) - Method in class java.util.concurrent.PriorityBlockingQueue
poll(long, TimeUnit) - Method in class java.util.concurrent.SynchronousQueue
Retrieves and removes the head of this queue, waiting if necessary up to the specified wait time, for another thread to insert it.
poll() - Method in class java.util.concurrent.SynchronousQueue
Retrieves and removes the head of this queue, if another thread is currently making an element available.
poll() - Method in interface java.util.Deque
Retrieves and removes the head of the queue represented by this deque (in other words, the first element of this deque), or returns null if this deque is empty.
poll() - Method in class java.util.LinkedList
Retrieves and removes the head (first element) of this list.
poll() - Method in class java.util.PriorityQueue
poll() - Method in interface java.util.Queue
Retrieves and removes the head of this queue, or returns null if this queue is empty.
poll_next_response() - Method in class org.omg.CORBA.ORB
Finds out if any of the deferred (asynchronous) invocations have a response yet.
poll_response() - Method in class org.omg.CORBA.Request
Allows the user to determine whether a response has been received for the invocation triggered earlier with the send_deferred method.
pollEvents() - Method in interface java.nio.file.WatchKey
Retrieves and removes all pending events for this watch key, returning a List of the events that were retrieved.
pollFirst() - Method in class java.util.ArrayDeque
pollFirst(long, TimeUnit) - Method in interface java.util.concurrent.BlockingDeque
Retrieves and removes the first element of this deque, waiting up to the specified wait time if necessary for an element to become available.
pollFirst() - Method in class java.util.concurrent.ConcurrentLinkedDeque
pollFirst() - Method in class java.util.concurrent.ConcurrentSkipListSet
pollFirst() - Method in class java.util.concurrent.LinkedBlockingDeque
pollFirst(long, TimeUnit) - Method in class java.util.concurrent.LinkedBlockingDeque
pollFirst() - Method in interface java.util.Deque
Retrieves and removes the first element of this deque, or returns null if this deque is empty.
pollFirst() - Method in class java.util.LinkedList
Retrieves and removes the first element of this list, or returns null if this list is empty.
pollFirst() - Method in interface java.util.NavigableSet
Retrieves and removes the first (lowest) element, or returns null if this set is empty.
pollFirst() - Method in class java.util.TreeSet
pollFirstEntry() - Method in class java.util.concurrent.ConcurrentSkipListMap
Removes and returns a key-value mapping associated with the least key in this map, or null if the map is empty.
pollFirstEntry() - Method in interface java.util.NavigableMap
Removes and returns a key-value mapping associated with the least key in this map, or null if the map is empty.
pollFirstEntry() - Method in class java.util.TreeMap
pollLast() - Method in class java.util.ArrayDeque
pollLast(long, TimeUnit) - Method in interface java.util.concurrent.BlockingDeque
Retrieves and removes the last element of this deque, waiting up to the specified wait time if necessary for an element to become available.
pollLast() - Method in class java.util.concurrent.ConcurrentLinkedDeque
pollLast() - Method in class java.util.concurrent.ConcurrentSkipListSet
pollLast() - Method in class java.util.concurrent.LinkedBlockingDeque
pollLast(long, TimeUnit) - Method in class java.util.concurrent.LinkedBlockingDeque
pollLast() - Method in interface java.util.Deque
Retrieves and removes the last element of this deque, or returns null if this deque is empty.
pollLast() - Method in class java.util.LinkedList
Retrieves and removes the last element of this list, or returns null if this list is empty.
pollLast() - Method in interface java.util.NavigableSet
Retrieves and removes the last (highest) element, or returns null if this set is empty.
pollLast() - Method in class java.util.TreeSet
pollLastEntry() - Method in class java.util.concurrent.ConcurrentSkipListMap
Removes and returns a key-value mapping associated with the greatest key in this map, or null if the map is empty.
pollLastEntry() - Method in interface java.util.NavigableMap
Removes and returns a key-value mapping associated with the greatest key in this map, or null if the map is empty.
pollLastEntry() - Method in class java.util.TreeMap
pollNextLocalTask() - Static method in class java.util.concurrent.ForkJoinTask
Unschedules and returns, without executing, the next task queued by the current thread but not yet executed, if the current thread is operating in a ForkJoinPool.
pollSubmission() - Method in class java.util.concurrent.ForkJoinPool
Removes and returns the next unexecuted submission if one is available.
pollTask() - Static method in class java.util.concurrent.ForkJoinTask
If the current thread is operating in a ForkJoinPool, unschedules and returns, without executing, the next task queued by the current thread but not yet executed, if one is available, or if not available, a task that was forked by some other thread, if available.
POLY_PRESSURE - Static variable in class javax.sound.midi.ShortMessage
Command value for Polyphonic Key Pressure (Aftertouch) message (0xA0, or 160)
Polygon - Class in java.awt
The Polygon class encapsulates a description of a closed, two-dimensional region within a coordinate space.
Polygon() - Constructor for class java.awt.Polygon
Creates an empty polygon.
Polygon(int[], int[], int) - Constructor for class java.awt.Polygon
Constructs and initializes a Polygon from the specified parameters.
PooledConnection - Interface in javax.sql
An object that provides hooks for connection pool management.
pop() - Method in class java.awt.EventQueue
Stops dispatching events using this EventQueue.
pop() - Method in class java.util.ArrayDeque
Pops an element from the stack represented by this deque.
pop() - Method in class java.util.concurrent.ConcurrentLinkedDeque
pop() - Method in class java.util.concurrent.LinkedBlockingDeque
pop() - Method in interface java.util.Deque
Pops an element from the stack represented by this deque.
pop() - Method in class java.util.LinkedList
Pops an element from the stack represented by this list.
pop() - Method in class java.util.Stack
Removes the object at the top of this stack and returns that object as the value of this function.
popCharacterStyle() - Method in class javax.swing.text.html.HTMLDocument.HTMLReader
Pops a previously pushed character style off the stack to return to a previous style.
popContext() - Method in class org.xml.sax.helpers.NamespaceSupport
Revert to the previous Namespace context.
populate(ResultSet) - Method in interface javax.sql.rowset.CachedRowSet
Populates this CachedRowSet object with data from the given ResultSet object.
populate(ResultSet, int) - Method in interface javax.sql.rowset.CachedRowSet
Populates this CachedRowSet object with data from the given ResultSet object.
popup - Variable in class javax.swing.plaf.basic.BasicComboBoxUI
Popup - Class in javax.swing
Popups are used to display a Component to the user, typically on top of all the other Components in a particular containment hierarchy.
Popup(Component, Component, int, int) - Constructor for class javax.swing.Popup
Creates a Popup for the Component owner containing the Component contents.
Popup() - Constructor for class javax.swing.Popup
Creates a Popup.
POPUP_LAYER - Static variable in class javax.swing.JLayeredPane
Convenience object defining the Popup layer.
POPUP_MENU - Static variable in class javax.accessibility.AccessibleRole
A temporary window that is usually used to offer the user a list of choices, and then hides when the user selects one of those choices.
POPUP_MENU - Static variable in class javax.swing.plaf.synth.Region
PopupMenu region.
POPUP_MENU_SEPARATOR - Static variable in class javax.swing.plaf.synth.Region
PopupMenuSeparator region.
PopupFactory - Class in javax.swing
PopupFactory, as the name implies, is used to obtain instances of Popups.
PopupFactory() - Constructor for class javax.swing.PopupFactory
popupKeyListener - Variable in class javax.swing.plaf.basic.BasicComboBoxUI
popupListener - Variable in class javax.swing.JMenu
The window-closing listener for the popup.
PopupMenu - Class in java.awt
A class that implements a menu which can be dynamically popped up at a specified position within a component.
PopupMenu() - Constructor for class java.awt.PopupMenu
Creates a new popup menu with an empty name.
PopupMenu(String) - Constructor for class java.awt.PopupMenu
Creates a new popup menu with the specified name.
popupMenu - Variable in class javax.swing.plaf.basic.BasicPopupMenuUI
PopupMenu.AccessibleAWTPopupMenu - Class in java.awt
Inner class of PopupMenu used to provide default support for accessibility.
PopupMenuBorder() - Constructor for class javax.swing.plaf.metal.MetalBorders.PopupMenuBorder
popupMenuCanceled(PopupMenuEvent) - Method in interface javax.swing.event.PopupMenuListener
This method is called when the popup menu is canceled
PopupMenuEvent - Class in javax.swing.event
PopupMenuEvent only contains the source of the event which is the JPoupMenu sending the event
PopupMenuEvent(Object) - Constructor for class javax.swing.event.PopupMenuEvent
Constructs a PopupMenuEvent object.
PopupMenuListener - Interface in javax.swing.event
A popup menu listener
PopupMenuUI - Class in javax.swing.plaf
Pluggable look and feel interface for JPopupMenu.
PopupMenuUI() - Constructor for class javax.swing.plaf.PopupMenuUI
popupMenuWillBecomeInvisible(PopupMenuEvent) - Method in interface javax.swing.event.PopupMenuListener
This method is called before the popup menu becomes invisible Note that a JPopupMenu can become invisible any time
popupMenuWillBecomeVisible(PopupMenuEvent) - Method in interface javax.swing.event.PopupMenuListener
This method is called before the popup menu becomes visible
popupMouseListener - Variable in class javax.swing.plaf.basic.BasicComboBoxUI
popupMouseMotionListener - Variable in class javax.swing.plaf.basic.BasicComboBoxUI
port - Variable in class java.net.SocketImpl
The port number on the remote host to which this socket is connected.
Port - Interface in javax.sound.sampled
Ports are simple lines for input or output of audio to or from audio devices.
Port.Info - Class in javax.sound.sampled
The Port.Info class extends Line.Info with additional information specific to ports, including the port's name and whether it is a source or a target for its mixer.
PortableRemoteObject - Class in javax.rmi
Server implementation objects may either inherit from javax.rmi.PortableRemoteObject or they may implement a remote interface and then use the exportObject method to register themselves as a server object.
PortableRemoteObject() - Constructor for class javax.rmi.PortableRemoteObject
Initializes the object by calling exportObject(this).
PortableRemoteObjectDelegate - Interface in javax.rmi.CORBA
Supports delegation for method implementations in PortableRemoteObject.
PortInfo - Interface in javax.xml.ws.handler
The PortInfo interface is used by a HandlerResolver to query information about the port it is being asked to create a handler chain for.
PORTRAIT - Static variable in class java.awt.PageAttributes.OrientationRequestedType
The OrientationRequestedType instance to use for specifying a portrait orientation.
PORTRAIT - Static variable in class java.awt.print.PageFormat
The origin is at the top left of the paper with x running to the right and y running down the paper.
PORTRAIT - Static variable in class javax.print.attribute.standard.OrientationRequested
The content will be imaged across the short edge of the medium.
PortUnreachableException - Exception in java.net
Signals that an ICMP Port Unreachable message has been received on a connected datagram.
PortUnreachableException(String) - Constructor for exception java.net.PortUnreachableException
Constructs a new PortUnreachableException with a detail message.
PortUnreachableException() - Constructor for exception java.net.PortUnreachableException
Construct a new PortUnreachableException with no detailed message.
pos - Variable in class java.io.BufferedInputStream
The current position in the buffer.
pos - Variable in class java.io.ByteArrayInputStream
The index of the next character to read from the input stream buffer.
pos - Variable in class java.io.CharArrayReader
The current buffer position.
pos - Variable in class java.io.PushbackInputStream
The position within the pushback buffer from which the next byte will be read.
pos - Variable in class java.io.StringBufferInputStream
Deprecated.
The index of the next character to read from the input stream buffer.
position() - Method in class java.nio.Buffer
Returns this buffer's position.
position(int) - Method in class java.nio.Buffer
Sets this buffer's position.
position() - Method in class java.nio.channels.FileChannel
Returns this channel's file position.
position(long) - Method in class java.nio.channels.FileChannel
Sets this channel's file position.
position() - Method in class java.nio.channels.FileLock
Returns the position within the file of the first byte of the locked region.
position() - Method in interface java.nio.channels.SeekableByteChannel
Returns this channel's position.
position(long) - Method in interface java.nio.channels.SeekableByteChannel
Sets this channel's position.
position(byte[], long) - Method in interface java.sql.Blob
Retrieves the byte position at which the specified byte array pattern begins within the BLOB value that this Blob object represents.
position(Blob, long) - Method in interface java.sql.Blob
Retrieves the byte position in the BLOB value designated by this Blob object at which pattern begins.
position(String, long) - Method in interface java.sql.Clob
Retrieves the character position at which the specified substring searchstr appears in the SQL CLOB value represented by this Clob object.
position(Clob, long) - Method in interface java.sql.Clob
Retrieves the character position at which the specified Clob object searchstr appears in this Clob object.
position(byte[], long) - Method in class javax.sql.rowset.serial.SerialBlob
Returns the position in this SerialBlob object where the given pattern of bytes begins, starting the search at the specified position.
position(Blob, long) - Method in class javax.sql.rowset.serial.SerialBlob
Returns the position in this SerialBlob object where the given Blob object begins, starting the search at the specified position.
position(String, long) - Method in class javax.sql.rowset.serial.SerialClob
Returns the position in this SerialClob object where the given String object begins, starting the search at the specified position.
position(Clob, long) - Method in class javax.sql.rowset.serial.SerialClob
Returns the position in this SerialClob object where the given Clob signature begins, starting the search at the specified position.
Position - Interface in javax.swing.text
Represents a location within a document.
Position.Bias - Class in javax.swing.text
A typesafe enumeration to indicate bias to a position in the model.
positionCaret(MouseEvent) - Method in class javax.swing.text.DefaultCaret
Tries to set the position of the caret from the coordinates of a mouse event, using viewToModel().
positionForMouseEvent(MouseEvent) - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider.DragController
Returns the new position to put the divider at based on the passed in MouseEvent.
positionForMouseEvent(MouseEvent) - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider.VerticalDragController
Returns the new position to put the divider at based on the passed in MouseEvent.
positionToElement(int) - Method in class javax.swing.text.AbstractDocument.BranchElement
Gets the child element that contains the given model position.
POSITIVE_INFINITY - Static variable in class java.lang.Double
A constant holding the positive infinity of type double.
POSITIVE_INFINITY - Static variable in class java.lang.Float
A constant holding the positive infinity of type float.
POSITIVE_SCROLL - Static variable in class javax.swing.plaf.basic.BasicSliderUI
PosixFileAttributes - Interface in java.nio.file.attribute
File attributes associated with files on file systems used by operating systems that implement the Portable Operating System Interface (POSIX) family of standards.
PosixFileAttributeView - Interface in java.nio.file.attribute
A file attribute view that provides a view of the file attributes commonly associated with files on file systems used by operating systems that implement the Portable Operating System Interface (POSIX) family of standards.
PosixFilePermission - Enum in java.nio.file.attribute
Defines the bits for use with the permissions attribute.
PosixFilePermissions - Class in java.nio.file.attribute
This class consists exclusively of static methods that operate on sets of PosixFilePermission objects.
post_init(ORBInitInfo) - Method in interface org.omg.PortableInterceptor.ORBInitializerOperations
Called during ORB initialization.
postActionEvent() - Method in class javax.swing.JTextField
Processes action events occurring on this textfield by dispatching them to any registered ActionListener objects.
postClosingEvent(JInternalFrame) - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
Post a WINDOW_CLOSING-like event to the frame, so that it can be treated like a regular Frame.
PostConstruct - Annotation Type in javax.annotation
The PostConstruct annotation is used on a method that needs to be executed after dependency injection is done to perform any initialization.
postDeregister() - Method in class javax.management.loading.MLet
Allows the m-let to perform any operations needed after having been unregistered in the MBean server.
postDeregister() - Method in interface javax.management.MBeanRegistration
Allows the MBean to perform any operations needed after having been unregistered in the MBean server.
postDeregister() - Method in class javax.management.modelmbean.RequiredModelMBean
Allows the MBean to perform any operations needed after having been unregistered in the MBean server.
postDeregister() - Method in class javax.management.monitor.Monitor
Allows the monitor MBean to perform any operations needed after having been unregistered by the MBean server.
postDeregister() - Method in class javax.management.relation.RelationService
postDeregister() - Method in class javax.management.relation.RelationSupport
postDeregister() - Method in class javax.management.remote.JMXConnectorServer
postDeregister() - Method in class javax.management.StandardMBean
Allows the MBean to perform any operations needed after having been unregistered in the MBean server.
postDeregister() - Method in class javax.management.timer.Timer
Allows the timer MBean to perform any operations needed after having been unregistered by the MBean server.
postEdit(UndoableEdit) - Method in class javax.swing.undo.UndoableEditSupport
DEADLOCK WARNING: Calling this method may call undoableEditHappened in all listeners.
postEvent(Event) - Method in class java.awt.Component
Deprecated.
As of JDK version 1.1, replaced by dispatchEvent(AWTEvent).
postEvent(AWTEvent) - Method in class java.awt.EventQueue
Posts a 1.1-style event to the EventQueue.
postEvent(Event) - Method in class java.awt.MenuComponent
Deprecated.
As of JDK version 1.1, replaced by dispatchEvent.
postEvent(Event) - Method in interface java.awt.MenuContainer
Deprecated.
As of JDK version 1.1 replaced by dispatchEvent(AWTEvent).
postEvent(Event) - Method in class java.awt.Window
Deprecated.
As of JDK version 1.1 replaced by dispatchEvent(AWTEvent).
postinvoke(byte[], POA, String, Object, Servant) - Method in class org.omg.PortableServer._ServantLocatorStub
This operation is invoked whenener a servant completes a request.
postinvoke(byte[], POA, String, Object, Servant) - Method in interface org.omg.PortableServer.ServantLocatorOperations
This operation is invoked whenener a servant completes a request.
postorderEnumeration() - Method in class javax.swing.tree.DefaultMutableTreeNode
Creates and returns an enumeration that traverses the subtree rooted at this node in postorder.
postProcessKeyEvent(KeyEvent) - Method in class java.awt.DefaultKeyboardFocusManager
This method will be called by dispatchKeyEvent.
postProcessKeyEvent(KeyEvent) - Method in class java.awt.KeyboardFocusManager
This method will be called by dispatchKeyEvent.
postProcessKeyEvent(KeyEvent) - Method in interface java.awt.KeyEventPostProcessor
This method is called by the current KeyboardFocusManager, requesting that this KeyEventPostProcessor perform any necessary post-processing which should be part of the KeyEvent's final resolution.
postRegister(Boolean) - Method in class javax.management.loading.MLet
Allows the m-let to perform any operations needed after having been registered in the MBean server or after the registration has failed.
postRegister(Boolean) - Method in interface javax.management.MBeanRegistration
Allows the MBean to perform any operations needed after having been registered in the MBean server or after the registration has failed.
postRegister(Boolean) - Method in class javax.management.modelmbean.RequiredModelMBean
Allows the MBean to perform any operations needed after having been registered in the MBean server or after the registration has failed.
postRegister(Boolean) - Method in class javax.management.monitor.Monitor
Allows the monitor MBean to perform any operations needed after having been registered in the MBean server or after the registration has failed.
postRegister(Boolean) - Method in class javax.management.relation.RelationService
postRegister(Boolean) - Method in class javax.management.relation.RelationSupport
postRegister(Boolean) - Method in class javax.management.remote.JMXConnectorServer
postRegister(Boolean) - Method in class javax.management.StandardMBean
Allows the MBean to perform any operations needed after having been registered in the MBean server or after the registration has failed.
postRegister(Boolean) - Method in class javax.management.timer.Timer
Allows the timer MBean to perform any operations needed after having been registered in the MBean server or after the registration has failed.
postRemoveUpdate(AbstractDocument.DefaultDocumentEvent) - Method in class javax.swing.text.AbstractDocument
Updates any document structure as a result of text removal.
POSTSCRIPT - Static variable in class javax.print.DocFlavor.BYTE_ARRAY
Doc flavor with MIME type = "application/postscript", print data representation class name = "[B" (byte array).
POSTSCRIPT - Static variable in class javax.print.DocFlavor.INPUT_STREAM
Doc flavor with MIME type = "application/postscript", print data representation class name = "java.io.InputStream" (byte stream).
POSTSCRIPT - Static variable in class javax.print.DocFlavor.URL
Doc flavor with MIME type = "application/postscript", print data representation class name = "java.net.URL".
postState - Variable in class javax.swing.undo.StateEdit
The state information after the edit
POSTURE - Static variable in class java.awt.font.TextAttribute
Attribute key for the posture of a font.
POSTURE_OBLIQUE - Static variable in class java.awt.font.TextAttribute
The standard italic posture.
POSTURE_REGULAR - Static variable in class java.awt.font.TextAttribute
The standard posture, upright.
postVisitDirectory(T, IOException) - Method in interface java.nio.file.FileVisitor
Invoked for a directory after entries in the directory, and all of their descendants, have been visited.
postVisitDirectory(T, IOException) - Method in class java.nio.file.SimpleFileVisitor
Invoked for a directory after entries in the directory, and all of their descendants, have been visited.
pow(double, double) - Static method in class java.lang.Math
Returns the value of the first argument raised to the power of the second argument.
pow(double, double) - Static method in class java.lang.StrictMath
Returns the value of the first argument raised to the power of the second argument.
pow(int) - Method in class java.math.BigDecimal
Returns a BigDecimal whose value is (thisn), The power is computed exactly, to unlimited precision.
pow(int, MathContext) - Method in class java.math.BigDecimal
Returns a BigDecimal whose value is (thisn).
pow(int) - Method in class java.math.BigInteger
Returns a BigInteger whose value is (thisexponent).
PPQ - Static variable in class javax.sound.midi.Sequence
The tempo-based timing type, for which the resolution is expressed in pulses (ticks) per quarter note.
PRC - Static variable in class java.util.Locale
Useful constant for country.
PRE - Static variable in class javax.swing.text.html.HTML.Tag
pre_init(ORBInitInfo) - Method in interface org.omg.PortableInterceptor.ORBInitializerOperations
Called during ORB initialization.
PreAction() - Constructor for class javax.swing.text.html.HTMLDocument.HTMLReader.PreAction
preceding(int) - Method in class java.text.BreakIterator
Returns the last boundary preceding the specified character offset.
precision() - Method in class java.math.BigDecimal
Returns the precision of this BigDecimal.
precision() - Static method in class java.time.temporal.TemporalQueries
A query for the smallest supported unit.
preConcatenate(AffineTransform) - Method in class java.awt.geom.AffineTransform
Concatenates an AffineTransform Tx to this AffineTransform Cx in a less commonly used way such that Tx modifies the coordinate transformation relative to the absolute pixel space rather than relative to the existing user space.
preConcatenateTransform(AffineTransform) - Method in class java.awt.image.renderable.RenderContext
Modifies the current user-to-device transform by prepending another transform.
preConcetenateTransform(AffineTransform) - Method in class java.awt.image.renderable.RenderContext
Deprecated.
replaced by preConcatenateTransform(AffineTransform).
preContent(char[]) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader
Adds the given content that was encountered in a PRE element.
predefined - Static variable in class java.awt.Cursor
Deprecated.
As of JDK version 1.7, the Cursor.getPredefinedCursor(int) method should be used instead.
preDeregister() - Method in class javax.management.loading.MLet
Allows the m-let to perform any operations it needs before being unregistered by the MBean server.
preDeregister() - Method in interface javax.management.MBeanRegistration
Allows the MBean to perform any operations it needs before being unregistered by the MBean server.
preDeregister() - Method in class javax.management.modelmbean.RequiredModelMBean
Allows the MBean to perform any operations it needs before being unregistered by the MBean server.
preDeregister() - Method in class javax.management.monitor.Monitor
Allows the monitor MBean to perform any operations it needs before being unregistered by the MBean server.
preDeregister() - Method in class javax.management.relation.RelationService
preDeregister() - Method in class javax.management.relation.RelationSupport
preDeregister() - Method in class javax.management.remote.JMXConnectorServer
Called by an MBean server when this connector server is unregistered from that MBean server.
preDeregister() - Method in class javax.management.StandardMBean
Allows the MBean to perform any operations it needs before being unregistered by the MBean server.
preDeregister() - Method in class javax.management.timer.Timer
Allows the timer MBean to perform any operations it needs before being unregistered by the MBean server.
PreDestroy - Annotation Type in javax.annotation
The PreDestroy annotation is used on methods as a callback notification to signal that the instance is in the process of being removed by the container.
Predicate<T> - Interface in java.util.function
Represents a predicate (boolean-valued function) of one argument.
Predicate - Interface in javax.sql.rowset
The standard interface that provides the framework for all FilteredRowSet objects to describe their filters.
preferenceChange(PreferenceChangeEvent) - Method in interface java.util.prefs.PreferenceChangeListener
This method gets called when a preference is added, removed or when its value is changed.
preferenceChanged(boolean, boolean) - Method in class javax.swing.text.AsyncBoxView.ChildState
Mark preferences changed for this child.
preferenceChanged(View, boolean, boolean) - Method in class javax.swing.text.AsyncBoxView
Child views can call this on the parent to indicate that the preference has changed and should be reconsidered for layout.
preferenceChanged(View, boolean, boolean) - Method in class javax.swing.text.BoxView
This is called by a child to indicate its preferred span has changed.
preferenceChanged(View, boolean, boolean) - Method in class javax.swing.text.View
Child views can call this on the parent to indicate that the preference has changed and should be reconsidered for layout.
PreferenceChangeEvent - Class in java.util.prefs
An event emitted by a Preferences node to indicate that a preference has been added, removed or has had its value changed.
PreferenceChangeEvent(Preferences, String, String) - Constructor for class java.util.prefs.PreferenceChangeEvent
Constructs a new PreferenceChangeEvent instance.
PreferenceChangeListener - Interface in java.util.prefs
A listener for receiving preference change events.
Preferences - Class in java.util.prefs
A node in a hierarchical collection of preference data.
Preferences() - Constructor for class java.util.prefs.Preferences
Sole constructor.
PreferencesFactory - Interface in java.util.prefs
A factory object that generates Preferences objects.
preferLocaleFonts() - Method in class java.awt.GraphicsEnvironment
Indicates a preference for locale-specific fonts in the mapping of logical fonts to physical fonts.
preferProportionalFonts() - Method in class java.awt.GraphicsEnvironment
Indicates a preference for proportional over non-proportional (e.g.
PREFERRED - Static variable in class java.awt.GraphicsConfigTemplate
Value used for "Enum" (Integer) type.
preferred - Variable in class javax.swing.SizeRequirements
The preferred (natural) size.
PREFERRED_SIZE - Static variable in class javax.swing.GroupLayout
Indicates the preferred size from the component or gap should be used for a particular range value.
preferredLayoutSize(Container) - Method in class java.awt.BorderLayout
Determines the preferred size of the target container using this layout manager, based on the components in the container.
preferredLayoutSize(Container) - Method in class java.awt.CardLayout
Determines the preferred size of the container argument using this card layout.
preferredLayoutSize(Container) - Method in class java.awt.FlowLayout
Returns the preferred dimensions for this layout given the visible components in the specified target container.
preferredLayoutSize(Container) - Method in class java.awt.GridBagLayout
Determines the preferred size of the parent container using this grid bag layout.
preferredLayoutSize(Container) - Method in class java.awt.GridLayout
Determines the preferred size of the container argument using this grid layout.
preferredLayoutSize(Container) - Method in interface java.awt.LayoutManager
Calculates the preferred size dimensions for the specified container, given the components it contains.
preferredLayoutSize(Container) - Method in class javax.swing.BoxLayout
Returns the preferred dimensions for this layout, given the components in the specified target container.
preferredLayoutSize(Container) - Method in class javax.swing.GroupLayout
Returns the preferred size for the specified container.
preferredLayoutSize(Container) - Method in class javax.swing.JRootPane.RootLayout
Returns the amount of space the layout would like to have.
preferredLayoutSize(Container) - Method in class javax.swing.JSpinner.DefaultEditor
Returns the preferred size of first (and only) child plus the size of the parents insets.
preferredLayoutSize(Container) - Method in class javax.swing.OverlayLayout
Returns the preferred dimensions for this layout given the components in the specified target container.
preferredLayoutSize(Container) - Method in class javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager
preferredLayoutSize(Container) - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane.TitlePaneLayout
preferredLayoutSize(Container) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.InternalFrameLayout
preferredLayoutSize(Container) - Method in class javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout
preferredLayoutSize(Container) - Method in class javax.swing.plaf.basic.BasicScrollBarUI
preferredLayoutSize(Container) - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider.DividerLayout
preferredLayoutSize(Container) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager
Returns the preferred size needed to contain the children.
preferredLayoutSize(Container) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout
preferredLayoutSize(Container) - Method in class javax.swing.plaf.basic.DefaultMenuLayout
preferredLayoutSize(Container) - Method in class javax.swing.ScrollPaneLayout
The preferred size of a ScrollPane is the size of the insets, plus the preferred size of the viewport, plus the preferred size of the visible headers, plus the preferred size of the scrollbars that will appear given the current view and the current scrollbar displayPolicies.
preferredLayoutSize(Container) - Method in class javax.swing.SpringLayout
preferredLayoutSize(Container) - Method in class javax.swing.ViewportLayout
Returns the preferred dimensions for this layout given the components in the specified target container.
preferredMinSize - Variable in class javax.swing.plaf.basic.BasicTreeUI
Minimum preferred size.
preferredSize() - Method in class java.awt.Component
Deprecated.
As of JDK version 1.1, replaced by getPreferredSize().
preferredSize() - Method in class java.awt.Container
Deprecated.
As of JDK version 1.1, replaced by getPreferredSize().
PREFERREDSIZE - Static variable in class java.awt.GridBagLayout
The preferred grid size that can be laid out by the grid bag layout.
preferredSize(int) - Method in class java.awt.List
Deprecated.
As of JDK version 1.1, replaced by getPreferredSize(int).
preferredSize() - Method in class java.awt.List
Deprecated.
As of JDK version 1.1, replaced by getPreferredSize().
preferredSize(int, int) - Method in class java.awt.TextArea
Deprecated.
As of JDK version 1.1, replaced by getPreferredSize(int, int).
preferredSize() - Method in class java.awt.TextArea
Deprecated.
As of JDK version 1.1, replaced by getPreferredSize().
preferredSize(int) - Method in class java.awt.TextField
Deprecated.
As of JDK version 1.1, replaced by getPreferredSize(int).
preferredSize() - Method in class java.awt.TextField
Deprecated.
As of JDK version 1.1, replaced by getPreferredSize().
preferredSize - Variable in class javax.swing.plaf.basic.BasicTreeUI
Size needed to completely display all the nodes.
preferredTabAreaHeight(int, int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout
preferredTabAreaWidth(int, int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout
preferredTileSizes - Variable in class javax.imageio.ImageWriteParam
An array of preferred tile size range pairs.
preferredViewportSize - Variable in class javax.swing.JTable
Used by the Scrollable interface to determine the initial visible area.
preinvoke(byte[], POA, String, CookieHolder) - Method in class org.omg.PortableServer._ServantLocatorStub
This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.
preinvoke(byte[], POA, String, CookieHolder) - Method in interface org.omg.PortableServer.ServantLocatorOperations
This operations is used to get a servant that will be used to process the request that caused preinvoke to be called.
preorderEnumeration() - Method in class javax.swing.tree.DefaultMutableTreeNode
Creates and returns an enumeration that traverses the subtree rooted at this node in preorder.
prepare(Xid) - Method in interface javax.transaction.xa.XAResource
Ask the resource manager to prepare for a transaction commit of the transaction specified in xid.
prepareCall(String) - Method in interface java.sql.Connection
Creates a CallableStatement object for calling database stored procedures.
prepareCall(String, int, int) - Method in interface java.sql.Connection
Creates a CallableStatement object that will generate ResultSet objects with the given type and concurrency.
prepareCall(String, int, int, int) - Method in interface java.sql.Connection
Creates a CallableStatement object that will generate ResultSet objects with the given type and concurrency.
PreparedStatement - Interface in java.sql
An object that represents a precompiled SQL statement.
prepareEditor(TableCellEditor, int, int) - Method in class javax.swing.JTable
Prepares the editor by querying the data model for the value and selection state of the cell at row, column.
prepareForDragging() - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider
Message to prepare for dragging.
prepareForEditing() - Method in class javax.swing.tree.DefaultTreeCellEditor
Invoked just before editing is to start.
prepareForUIInstall() - Method in class javax.swing.plaf.basic.BasicTreeUI
Invoked after the tree instance variable has been set, but before any defaults/listeners have been installed.
prepareForUIUninstall() - Method in class javax.swing.plaf.basic.BasicTreeUI
prepareImage(Image, ImageObserver) - Method in class java.awt.Component
Prepares an image for rendering on this component.
prepareImage(Image, int, int, ImageObserver) - Method in class java.awt.Component
Prepares an image for rendering on this component at the specified width and height.
prepareImage(Image, int, int, ImageObserver) - Method in class java.awt.Toolkit
Prepares an image for rendering.
prepareInsertEmpty(int, ImageTypeSpecifier, int, int, IIOMetadata, List<? extends BufferedImage>, ImageWriteParam) - Method in class javax.imageio.ImageWriter
Begins the insertion of a new image with undefined pixel values into an existing image stream.
prepareRenderer(TableCellRenderer, int, int) - Method in class javax.swing.JTable
Prepares the renderer by querying the data model for the value and selection state of the cell at row, column.
prepareReplacePixels(int, Rectangle) - Method in class javax.imageio.ImageWriter
Prepares the writer to handle a series of calls to the replacePixels methods.
prepareStatement(String) - Method in interface java.sql.Connection
Creates a PreparedStatement object for sending parameterized SQL statements to the database.
prepareStatement(String, int, int) - Method in interface java.sql.Connection
Creates a PreparedStatement object that will generate ResultSet objects with the given type and concurrency.
prepareStatement(String, int, int, int) - Method in interface java.sql.Connection
Creates a PreparedStatement object that will generate ResultSet objects with the given type, concurrency, and holdability.
prepareStatement(String, int) - Method in interface java.sql.Connection
Creates a default PreparedStatement object that has the capability to retrieve auto-generated keys.
prepareStatement(String, int[]) - Method in interface java.sql.Connection
Creates a default PreparedStatement object capable of returning the auto-generated keys designated by the given array.
prepareStatement(String, String[]) - Method in interface java.sql.Connection
Creates a default PreparedStatement object capable of returning the auto-generated keys designated by the given array.
prepareWriteEmpty(IIOMetadata, ImageTypeSpecifier, int, int, IIOMetadata, List<? extends BufferedImage>, ImageWriteParam) - Method in class javax.imageio.ImageWriter
Begins the writing of a complete image stream, consisting of a single image with undefined pixel values and associated metadata and thumbnails, to the output.
prepareWriteSequence(IIOMetadata) - Method in class javax.imageio.ImageWriter
Prepares a stream to accept a series of subsequent writeToSequence calls, using the provided stream metadata object.
preRegister(MBeanServer, ObjectName) - Method in class javax.management.loading.MLet
Allows the m-let to perform any operations it needs before being registered in the MBean server.
preRegister(MBeanServer, ObjectName) - Method in interface javax.management.MBeanRegistration
Allows the MBean to perform any operations it needs before being registered in the MBean Server.
preRegister(MBeanServer, ObjectName) - Method in class javax.management.modelmbean.RequiredModelMBean
Allows the MBean to perform any operations it needs before being registered in the MBean server.
preRegister(MBeanServer, ObjectName) - Method in class javax.management.monitor.Monitor
Allows the monitor MBean to perform any operations it needs before being registered in the MBean server.
preRegister(MBeanServer, ObjectName) - Method in class javax.management.relation.RelationService
preRegister(MBeanServer, ObjectName) - Method in class javax.management.relation.RelationSupport
preRegister(MBeanServer, ObjectName) - Method in class javax.management.remote.JMXConnectorServer
Called by an MBean server when this connector server is registered in that MBean server.
preRegister(MBeanServer, ObjectName) - Method in class javax.management.StandardMBean
Allows the MBean to perform any operations it needs before being registered in the MBean server.
preRegister(MBeanServer, ObjectName) - Method in class javax.management.timer.Timer
Allows the timer MBean to perform any operations it needs before being registered in the MBean server.
PresentationDirection - Class in javax.print.attribute.standard
Class PresentationDirection is a printing attribute class, an enumeration, that is used in conjunction with the NumberUp attribute to indicate the layout of multiple print-stream pages to impose upon a single side of an instance of a selected medium.
PRESSED - Static variable in class javax.accessibility.AccessibleState
Indicates this object is currently pressed.
PRESSED - Static variable in class javax.swing.DefaultButtonModel
Identifies the "pressed" bit in the bitmask, which indicates that the button is pressed.
PRESSED - Static variable in interface javax.swing.plaf.synth.SynthConstants
Primary state indicating the region is in a pressed state.
PRESSED_ICON_CHANGED_PROPERTY - Static variable in class javax.swing.AbstractButton
Identifies a change to the icon used when the button has been pressed.
prestartAllCoreThreads() - Method in class java.util.concurrent.ThreadPoolExecutor
Starts all core threads, causing them to idly wait for work.
prestartCoreThread() - Method in class java.util.concurrent.ThreadPoolExecutor
Starts a core thread, causing it to idly wait for work.
preState - Variable in class javax.swing.undo.StateEdit
The state information prior to the edit
preventDefault() - Method in interface org.w3c.dom.events.Event
If an event is cancelable, the preventDefault method is used to signify that the event is to be canceled, meaning any default action normally taken by the implementation as a result of the event will not occur.
PREVIEW_PANEL_PROPERTY - Static variable in class javax.swing.JColorChooser
The preview panel property name.
previewListener - Variable in class javax.swing.plaf.basic.BasicColorChooserUI
previous(Container) - Method in class java.awt.CardLayout
Flips to the previous card of the specified container.
previous() - Method in interface java.sql.ResultSet
Moves the cursor to the previous row in this ResultSet object.
previous() - Method in class java.text.BreakIterator
Returns the boundary preceding the current boundary.
previous() - Method in interface java.text.CharacterIterator
Decrements the iterator's index by one and returns the character at the new index.
previous() - Method in class java.text.CollationElementIterator
Get the previous collation element in the string.
previous() - Method in class java.text.StringCharacterIterator
Implements CharacterIterator.previous() for String.
previous(DayOfWeek) - Static method in class java.time.temporal.TemporalAdjusters
Returns the previous day-of-week adjuster, which adjusts the date to the first occurrence of the specified day-of-week before the date being adjusted.
previous() - Method in interface java.util.ListIterator
Returns the previous element in the list and moves the cursor position backwards.
PREVIOUS - Static variable in interface javax.swing.SwingConstants
Identifies the previous direction in a sequence.
previous() - Method in class javax.swing.text.ElementIterator
Fetches the previous Element.
previous() - Method in class javax.swing.text.Segment
Decrements the iterator's index by one and returns the character at the new index.
previousClearBit(int) - Method in class java.util.BitSet
Returns the index of the nearest bit that is set to false that occurs on or before the specified starting index.
previousConflict() - Method in interface javax.sql.rowset.spi.SyncResolver
Moves the cursor up from its current position to the previous conflict row in this SyncResolver object.
previousDouble(double) - Static method in class java.text.ChoiceFormat
Finds the greatest double less than d.
previousIndex() - Method in interface java.util.ListIterator
Returns the index of the element that would be returned by a subsequent call to ListIterator.previous().
previousOrSame(DayOfWeek) - Static method in class java.time.temporal.TemporalAdjusters
Returns the previous-or-same day-of-week adjuster, which adjusts the date to the first occurrence of the specified day-of-week before the date being adjusted unless it is already on that day in which case the same object is returned.
previousPage() - Method in interface javax.sql.rowset.CachedRowSet
Decrements the current page of the CachedRowSet.
previousSetBit(int) - Method in class java.util.BitSet
Returns the index of the nearest bit that is set to true that occurs on or before the specified starting index.
previousTransition(Instant) - Method in class java.time.zone.ZoneRules
Gets the previous transition before the specified instant.
previousWordAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the Action for moving the caret to the beginning of the previous word.
preVisitDirectory(T, BasicFileAttributes) - Method in interface java.nio.file.FileVisitor
Invoked for a directory before entries in the directory are visited.
preVisitDirectory(T, BasicFileAttributes) - Method in class java.nio.file.SimpleFileVisitor
Invoked for a directory before entries in the directory are visited.
PRIMARY - Static variable in class java.text.Collator
Collator strength value.
primaryOrder(int) - Static method in class java.text.CollationElementIterator
Return the primary component of a collation element.
PrimitiveIterator<T,T_CONS> - Interface in java.util
A base type for primitive specializations of Iterator.
PrimitiveIterator.OfDouble - Interface in java.util
An Iterator specialized for double values.
PrimitiveIterator.OfInt - Interface in java.util
An Iterator specialized for int values.
PrimitiveIterator.OfLong - Interface in java.util
An Iterator specialized for long values.
PrimitiveType - Interface in javax.lang.model.type
Represents a primitive type.
principal() - Method in class java.nio.file.attribute.AclEntry
Returns the principal component.
Principal - Interface in java.security
This interface represents the abstract notion of a principal, which can be used to represent any entity, such as an individual, a corporation, and a login id.
Principal - Class in org.omg.CORBA
Deprecated.
Deprecated by CORBA 2.2.
Principal() - Constructor for class org.omg.CORBA.Principal
Deprecated.
PrincipalHolder - Class in org.omg.CORBA
Deprecated.
Deprecated by CORBA 2.2.
PrincipalHolder() - Constructor for class org.omg.CORBA.PrincipalHolder
Deprecated.
Constructs a new PrincipalHolder object with its value field initialized to null.
PrincipalHolder(Principal) - Constructor for class org.omg.CORBA.PrincipalHolder
Deprecated.
Constructs a new PrincipalHolder object with its value field initialized to the given Principal object.
print(Graphics) - Method in class java.awt.Component
Prints this component.
print(Graphics) - Method in class java.awt.Container
Prints the container.
print(File) - Method in class java.awt.Desktop
Prints a file with the native desktop printing facility, using the associated application's print command.
print(Graphics, PageFormat, int) - Method in interface java.awt.print.Printable
Prints the page at the specified index into the specified Graphics context in the specified format.
print() - Method in class java.awt.print.PrinterJob
Prints a set of pages.
print(PrintRequestAttributeSet) - Method in class java.awt.print.PrinterJob
Prints a set of pages using the settings in the attribute set.
print(boolean) - Method in class java.io.PrintStream
Prints a boolean value.
print(char) - Method in class java.io.PrintStream
Prints a character.
print(int) - Method in class java.io.PrintStream
Prints an integer.
print(long) - Method in class java.io.PrintStream
Prints a long integer.
print(float) - Method in class java.io.PrintStream
Prints a floating-point number.
print(double) - Method in class java.io.PrintStream
Prints a double-precision floating-point number.
print(char[]) - Method in class java.io.PrintStream
Prints an array of characters.
print(String) - Method in class java.io.PrintStream
Prints a string.
print(Object) - Method in class java.io.PrintStream
Prints an object.
print(boolean) - Method in class java.io.PrintWriter
Prints a boolean value.
print(char) - Method in class java.io.PrintWriter
Prints a character.
print(int) - Method in class java.io.PrintWriter
Prints an integer.
print(long) - Method in class java.io.PrintWriter
Prints a long integer.
print(float) - Method in class java.io.PrintWriter
Prints a floating-point number.
print(double) - Method in class java.io.PrintWriter
Prints a double-precision floating-point number.
print(char[]) - Method in class java.io.PrintWriter
Prints an array of characters.
print(String) - Method in class java.io.PrintWriter
Prints a string.
print(Object) - Method in class java.io.PrintWriter
Prints an object.
print(Doc, PrintRequestAttributeSet) - Method in interface javax.print.DocPrintJob
Prints a document with the specified job attributes.
print(MultiDoc, PrintRequestAttributeSet) - Method in interface javax.print.MultiDocPrintJob
Print a MultiDoc with the specified job attributes.
print(Graphics) - Method in class javax.swing.JComponent
Invoke this method to print the component to the specified Graphics.
print() - Method in class javax.swing.JTable
A convenience method that displays a printing dialog, and then prints this JTable in mode PrintMode.FIT_WIDTH, with no header or footer text.
print(JTable.PrintMode) - Method in class javax.swing.JTable
A convenience method that displays a printing dialog, and then prints this JTable in the given printing mode, with no header or footer text.
print(JTable.PrintMode, MessageFormat, MessageFormat) - Method in class javax.swing.JTable
A convenience method that displays a printing dialog, and then prints this JTable in the given printing mode, with the specified header and footer text.
print(JTable.PrintMode, MessageFormat, MessageFormat, boolean, PrintRequestAttributeSet, boolean) - Method in class javax.swing.JTable
Prints this table, as specified by the fully featured print method, with the default printer specified as the print service.
print(JTable.PrintMode, MessageFormat, MessageFormat, boolean, PrintRequestAttributeSet, boolean, PrintService) - Method in class javax.swing.JTable
Prints this JTable.
print() - Method in class javax.swing.text.JTextComponent
A convenience print method that displays a print dialog, and then prints this JTextComponent in interactive mode with no header or footer text.
print(MessageFormat, MessageFormat) - Method in class javax.swing.text.JTextComponent
A convenience print method that displays a print dialog, and then prints this JTextComponent in interactive mode with the specified header and footer text.
print(MessageFormat, MessageFormat, boolean, PrintService, PrintRequestAttributeSet, boolean) - Method in class javax.swing.text.JTextComponent
Prints the content of this JTextComponent.
PRINT_SCREEN - Static variable in class java.awt.Event
The Print Screen key, a non-ASCII action key.
PRINTABLE - Static variable in class java.awt.PageAttributes.OriginType
The OriginType instance to use for specifying a printable origin.
Printable - Interface in java.awt.print
The Printable interface is implemented by the print methods of the current page painter, which is called by the printing system to render a page.
PRINTABLE - Static variable in class javax.print.DocFlavor.SERVICE_FORMATTED
Service formatted print data doc flavor with print data representation class name = "java.awt.print.Printable" (printable object).
printAll(Graphics) - Method in class java.awt.Component
Prints this component and all of its subcomponents.
printAll(Graphics) - Method in class javax.swing.JComponent
Invoke this method to print the component.
printAnySimpleType(String) - Static method in class javax.xml.bind.DatatypeConverter
Converts a string value into a string.
printAnySimpleType(String) - Method in interface javax.xml.bind.DatatypeConverterInterface
Converts a string value into a string.
printBase64Binary(byte[]) - Static method in class javax.xml.bind.DatatypeConverter
Converts an array of bytes into a string.
printBase64Binary(byte[]) - Method in interface javax.xml.bind.DatatypeConverterInterface
Converts an array of bytes into a string.
printBoolean(boolean) - Static method in class javax.xml.bind.DatatypeConverter
Converts a boolean value into a string.
printBoolean(boolean) - Method in interface javax.xml.bind.DatatypeConverterInterface
Converts a boolean value into a string.
printBorder(Graphics) - Method in class javax.swing.JComponent
Prints the component's border.
printByte(byte) - Static method in class javax.xml.bind.DatatypeConverter
Converts a byte value into a string.
printByte(byte) - Method in interface javax.xml.bind.DatatypeConverterInterface
Converts a byte value into a string.
printChildren(Graphics) - Method in class javax.swing.JComponent
Prints this component's children.
printComponent(Graphics) - Method in class javax.swing.JComponent
This is invoked during a printing operation.
printComponents(Graphics) - Method in class java.awt.Container
Prints each of the components in this container.
printComponents(Graphics) - Method in class java.awt.ScrollPane
Prints the component in this scroll pane.
PrintConversionEvent - Interface in javax.xml.bind
This event indicates that a problem was encountered while converting data from the Java content tree into its lexical representation.
PrintConversionEventImpl - Class in javax.xml.bind.helpers
Default implementation of the PrintConversionEvent interface.
PrintConversionEventImpl(int, String, ValidationEventLocator) - Constructor for class javax.xml.bind.helpers.PrintConversionEventImpl
Create a new PrintConversionEventImpl.
PrintConversionEventImpl(int, String, ValidationEventLocator, Throwable) - Constructor for class javax.xml.bind.helpers.PrintConversionEventImpl
Create a new PrintConversionEventImpl.
printDataTransferCompleted(PrintJobEvent) - Method in class javax.print.event.PrintJobAdapter
Called to notify the client that data has been successfully transferred to the print service, and the client may free local resources allocated for that data.
printDataTransferCompleted(PrintJobEvent) - Method in interface javax.print.event.PrintJobListener
Called to notify the client that data has been successfully transferred to the print service, and the client may free local resources allocated for that data.
printDate(Calendar) - Static method in class javax.xml.bind.DatatypeConverter
Converts a Calendar value into a string.
printDate(Calendar) - Method in interface javax.xml.bind.DatatypeConverterInterface
Converts a Calendar value into a string.
printDateTime(Calendar) - Static method in class javax.xml.bind.DatatypeConverter
Converts a Calendar value into a string.
printDateTime(Calendar) - Method in interface javax.xml.bind.DatatypeConverterInterface
Converts a Calendar value into a string.
printDecimal(BigDecimal) - Static method in class javax.xml.bind.DatatypeConverter
Converts a BigDecimal value into a string.
printDecimal(BigDecimal) - Method in interface javax.xml.bind.DatatypeConverterInterface
Converts a BigDecimal value into a string.
printDialog() - Method in class java.awt.print.PrinterJob
Presents a dialog to the user for changing the properties of the print job.
printDialog(PrintRequestAttributeSet) - Method in class java.awt.print.PrinterJob
A convenience method which displays a cross-platform print dialog for all services which are capable of printing 2D graphics using the Pageable interface.
printDialog(GraphicsConfiguration, int, int, PrintService[], PrintService, DocFlavor, PrintRequestAttributeSet) - Static method in class javax.print.ServiceUI
Presents a dialog to the user for selecting a print service (printer).
printDouble(double) - Static method in class javax.xml.bind.DatatypeConverter
Converts a double value into a string.
printDouble(double) - Method in interface javax.xml.bind.DatatypeConverterInterface
Converts a double value into a string.
printElements(Writer, Element...) - Method in interface javax.lang.model.util.Elements
Prints a representation of the elements to the given writer in the specified order.
PRINTER - Static variable in class java.awt.JobAttributes.DestinationType
The DestinationType instance to use for specifying print to printer.
PRINTER_STOPPED - Static variable in class javax.print.attribute.standard.JobStateReason
The value of the printer's PrinterState attribute ia STOPPED.
PRINTER_STOPPED_PARTLY - Static variable in class javax.print.attribute.standard.JobStateReason
The value of the printer's PrinterStateReasons attribute contains a PrinterStateReason value of STOPPED_PARTLY.
PrinterAbortException - Exception in java.awt.print
The PrinterAbortException class is a subclass of PrinterException and is used to indicate that a user or application has terminated the print job while it was in the process of printing.
PrinterAbortException() - Constructor for exception java.awt.print.PrinterAbortException
Constructs a new PrinterAbortException with no detail message.
PrinterAbortException(String) - Constructor for exception java.awt.print.PrinterAbortException
Constructs a new PrinterAbortException with the specified detail message.
PrinterException - Exception in java.awt.print
The PrinterException class and its subclasses are used to indicate that an exceptional condition has occurred in the print system.
PrinterException() - Constructor for exception java.awt.print.PrinterException
Constructs a new PrinterException object without a detail message.
PrinterException(String) - Constructor for exception java.awt.print.PrinterException
Constructs a new PrinterException object with the specified detail message.
PrinterGraphics - Interface in java.awt.print
The PrinterGraphics interface is implemented by Graphics objects that are passed to Printable objects to render a page.
PrinterInfo - Class in javax.print.attribute.standard
Class PrinterInfo is a printing attribute class, a text attribute, that provides descriptive information about a printer.
PrinterInfo(String, Locale) - Constructor for class javax.print.attribute.standard.PrinterInfo
Constructs a new printer info attribute with the given information string and locale.
PrinterIOException - Exception in java.awt.print
The PrinterIOException class is a subclass of PrinterException and is used to indicate that an IO error of some sort has occurred while printing.
PrinterIOException(IOException) - Constructor for exception java.awt.print.PrinterIOException
Constructs a new PrinterIOException with the string representation of the specified IOException.
PrinterIsAcceptingJobs - Class in javax.print.attribute.standard
Class PrinterIsAcceptingJobs is a printing attribute class, an enumeration, that indicates whether the printer is currently able to accept jobs.
PrinterIsAcceptingJobs(int) - Constructor for class javax.print.attribute.standard.PrinterIsAcceptingJobs
Construct a new printer is accepting jobs enumeration value with the given integer value.
PrinterJob - Class in java.awt.print
The PrinterJob class is the principal class that controls printing.
PrinterJob() - Constructor for class java.awt.print.PrinterJob
A PrinterJob object should be created using the static getPrinterJob method.
PrinterLocation - Class in javax.print.attribute.standard
Class PrinterLocation is a printing attribute class, a text attribute, that identifies the location of the device.
PrinterLocation(String, Locale) - Constructor for class javax.print.attribute.standard.PrinterLocation
Constructs a new printer location attribute with the given location and locale.
PrinterMakeAndModel - Class in javax.print.attribute.standard
Class PrinterMakeAndModel is a printing attribute class, a text attribute, that the make and model of the printer.
PrinterMakeAndModel(String, Locale) - Constructor for class javax.print.attribute.standard.PrinterMakeAndModel
Constructs a new printer make and model attribute with the given make and model string and locale.
PrinterMessageFromOperator - Class in javax.print.attribute.standard
Class PrinterMessageFromOperator is a printing attribute class, a text attribute, that provides a message from an operator, system administrator, or "intelligent" process to indicate to the end user information about or status of the printer, such as why it is unavailable or when it is expected to be available.
PrinterMessageFromOperator(String, Locale) - Constructor for class javax.print.attribute.standard.PrinterMessageFromOperator
Constructs a new printer message from operator attribute with the given message and locale.
PrinterMoreInfo - Class in javax.print.attribute.standard
Class PrinterMoreInfo is a printing attribute class, a URI, that is used to obtain more information about this specific printer.
PrinterMoreInfo(URI) - Constructor for class javax.print.attribute.standard.PrinterMoreInfo
Constructs a new printer more info attribute with the specified URI.
PrinterMoreInfoManufacturer - Class in javax.print.attribute.standard
Class PrinterMoreInfoManufacturer is a printing attribute class, a URI, that is used to obtain more information about this type of device.
PrinterMoreInfoManufacturer(URI) - Constructor for class javax.print.attribute.standard.PrinterMoreInfoManufacturer
Constructs a new printer more info manufacturer attribute with the specified URI.
PrinterName - Class in javax.print.attribute.standard
Class PrinterName is a printing attribute class, a text attribute, that specifies the name of a printer.
PrinterName(String, Locale) - Constructor for class javax.print.attribute.standard.PrinterName
Constructs a new printer name attribute with the given name and locale.
PrinterResolution - Class in javax.print.attribute.standard
Class PrinterResolution is a printing attribute class that specifies an exact resolution supported by a printer or to be used for a print job.
PrinterResolution(int, int, int) - Constructor for class javax.print.attribute.standard.PrinterResolution
Construct a new printer resolution attribute from the given items.
PrinterState - Class in javax.print.attribute.standard
Class PrinterState is a printing attribute class, an enumeration, that identifies the current state of a printer.
PrinterState(int) - Constructor for class javax.print.attribute.standard.PrinterState
Construct a new printer state enumeration value with the given integer value.
PrinterStateReason - Class in javax.print.attribute.standard
Class PrinterStateReason is a printing attribute class, an enumeration, that provides additional information about the printer's current state, i.e., information that augments the value of the printer's PrinterState attribute.
PrinterStateReason(int) - Constructor for class javax.print.attribute.standard.PrinterStateReason
Construct a new printer state reason enumeration value with the given integer value.
PrinterStateReasons - Class in javax.print.attribute.standard
Class PrinterStateReasons is a printing attribute class, a set of enumeration values, that provides additional information about the printer's current state, i.e., information that augments the value of the printer's PrinterState attribute.
PrinterStateReasons() - Constructor for class javax.print.attribute.standard.PrinterStateReasons
Construct a new, empty printer state reasons attribute; the underlying hash map has the default initial capacity and load factor.
PrinterStateReasons(int) - Constructor for class javax.print.attribute.standard.PrinterStateReasons
super a new, empty printer state reasons attribute; the underlying hash map has the given initial capacity and the default load factor.
PrinterStateReasons(int, float) - Constructor for class javax.print.attribute.standard.PrinterStateReasons
Construct a new, empty printer state reasons attribute; the underlying hash map has the given initial capacity and load factor.
PrinterStateReasons(Map<PrinterStateReason, Severity>) - Constructor for class javax.print.attribute.standard.PrinterStateReasons
Construct a new printer state reasons attribute that contains the same PrinterStateReason-to-Severity mappings as the given map.
printerStateReasonSet(Severity) - Method in class javax.print.attribute.standard.PrinterStateReasons
Obtain an unmodifiable set view of the individual printer state reason attributes at the given severity level in this PrinterStateReasons attribute.
PrinterURI - Class in javax.print.attribute.standard
Class PrinterURI is a printing attribute class, a URI, that specifies the globally unique name of a printer.
PrinterURI(URI) - Constructor for class javax.print.attribute.standard.PrinterURI
Constructs a new PrinterURI attribute with the specified URI.
PrintEvent - Class in javax.print.event
Class PrintEvent is the super class of all Print Service API events.
PrintEvent(Object) - Constructor for class javax.print.event.PrintEvent
Constructs a PrintEvent object.
PrintException - Exception in javax.print
Class PrintException encapsulates a printing-related error condition that occurred while using a Print Service instance.
PrintException() - Constructor for exception javax.print.PrintException
Construct a print exception with no detail message.
PrintException(String) - Constructor for exception javax.print.PrintException
Construct a print exception with the given detail message.
PrintException(Exception) - Constructor for exception javax.print.PrintException
Construct a print exception chaining the supplied exception.
PrintException(String, Exception) - Constructor for exception javax.print.PrintException
Construct a print exception with the given detail message and chained exception.
printf(String, Object...) - Method in class java.io.Console
A convenience method to write a formatted string to this console's output stream using the specified format string and arguments.
printf(String, Object...) - Method in class java.io.PrintStream
A convenience method to write a formatted string to this output stream using the specified format string and arguments.
printf(Locale, String, Object...) - Method in class java.io.PrintStream
A convenience method to write a formatted string to this output stream using the specified format string and arguments.
printf(String, Object...) - Method in class java.io.PrintWriter
A convenience method to write a formatted string to this writer using the specified format string and arguments.
printf(Locale, String, Object...) - Method in class java.io.PrintWriter
A convenience method to write a formatted string to this writer using the specified format string and arguments.
printFloat(float) - Static method in class javax.xml.bind.DatatypeConverter
Converts a float value into a string.
printFloat(float) - Method in interface javax.xml.bind.DatatypeConverterInterface
Converts a float value into a string.
PrintGraphics - Interface in java.awt
An abstract class which provides a print graphics context for a page.
printHexBinary(byte[]) - Static method in class javax.xml.bind.DatatypeConverter
Converts an array of bytes into a string.
printHexBinary(byte[]) - Method in interface javax.xml.bind.DatatypeConverterInterface
Converts an array of bytes into a string.
printInt(int) - Static method in class javax.xml.bind.DatatypeConverter
Converts an int value into a string.
printInt(int) - Method in interface javax.xml.bind.DatatypeConverterInterface
Converts an int value into a string.
printInteger(BigInteger) - Static method in class javax.xml.bind.DatatypeConverter
Converts a BigInteger value into a string.
printInteger(BigInteger) - Method in interface javax.xml.bind.DatatypeConverterInterface
Converts a BigInteger value into a string.
PrintJob - Class in java.awt
An abstract class which initiates and executes a print job.
PrintJob() - Constructor for class java.awt.PrintJob
PrintJobAdapter - Class in javax.print.event
An abstract adapter class for receiving print job events.
PrintJobAdapter() - Constructor for class javax.print.event.PrintJobAdapter
PrintJobAttribute - Interface in javax.print.attribute
PrintJobAttribute is a tagging interface which a printing attribute class implements to indicate the attribute describes the status of a Print Job or some other characteristic of a Print Job.
PrintJobAttributeEvent - Class in javax.print.event
Class PrintJobAttributeEvent encapsulates an event a PrintService reports to let the client know that one or more printing attributes for a PrintJob have changed.
PrintJobAttributeEvent(DocPrintJob, PrintJobAttributeSet) - Constructor for class javax.print.event.PrintJobAttributeEvent
Constructs a PrintJobAttributeEvent object.
PrintJobAttributeListener - Interface in javax.print.event
Implementations of this interface are attached to a DocPrintJob to monitor the status of attribute changes associated with the print job.
PrintJobAttributeSet - Interface in javax.print.attribute
Interface PrintJobAttributeSet specifies the interface for a set of print job attributes, i.e.
printJobCanceled(PrintJobEvent) - Method in class javax.print.event.PrintJobAdapter
Called to notify the client that the job was canceled by user or program.
printJobCanceled(PrintJobEvent) - Method in interface javax.print.event.PrintJobListener
Called to notify the client that the job was canceled by a user or a program.
printJobCompleted(PrintJobEvent) - Method in class javax.print.event.PrintJobAdapter
Called to notify the client that the job completed successfully.
printJobCompleted(PrintJobEvent) - Method in interface javax.print.event.PrintJobListener
Called to notify the client that the job completed successfully.
PrintJobEvent - Class in javax.print.event
Class PrintJobEvent encapsulates common events a print job reports to let a listener know of progress in the processing of the DocPrintJob.
PrintJobEvent(DocPrintJob, int) - Constructor for class javax.print.event.PrintJobEvent
Constructs a PrintJobEvent object.
printJobFailed(PrintJobEvent) - Method in class javax.print.event.PrintJobAdapter
Called to notify the client that the job failed to complete successfully and will have to be resubmitted.
printJobFailed(PrintJobEvent) - Method in interface javax.print.event.PrintJobListener
Called to notify the client that the job failed to complete successfully and will have to be resubmitted.
PrintJobListener - Interface in javax.print.event
Implementations of this listener interface should be attached to a DocPrintJob to monitor the status of the printer job.
printJobNoMoreEvents(PrintJobEvent) - Method in class javax.print.event.PrintJobAdapter
Called to notify the client that no more events will be delivered.
printJobNoMoreEvents(PrintJobEvent) - Method in interface javax.print.event.PrintJobListener
Called to notify the client that no more events will be delivered.
printJobRequiresAttention(PrintJobEvent) - Method in class javax.print.event.PrintJobAdapter
Called to notify the client that some possibly user rectifiable problem occurs (eg printer out of paper).
printJobRequiresAttention(PrintJobEvent) - Method in interface javax.print.event.PrintJobListener
Called to notify the client that an error has occurred that the user might be able to fix.
println() - Method in class java.io.PrintStream
Terminates the current line by writing the line separator string.
println(boolean) - Method in class java.io.PrintStream
Prints a boolean and then terminate the line.
println(char) - Method in class java.io.PrintStream
Prints a character and then terminate the line.
println(int) - Method in class java.io.PrintStream
Prints an integer and then terminate the line.
println(long) - Method in class java.io.PrintStream
Prints a long and then terminate the line.
println(float) - Method in class java.io.PrintStream
Prints a float and then terminate the line.
println(double) - Method in class java.io.PrintStream
Prints a double and then terminate the line.
println(char[]) - Method in class java.io.PrintStream
Prints an array of characters and then terminate the line.
println(String) - Method in class java.io.PrintStream
Prints a String and then terminate the line.
println(Object) - Method in class java.io.PrintStream
Prints an Object and then terminate the line.
println() - Method in class java.io.PrintWriter
Terminates the current line by writing the line separator string.
println(boolean) - Method in class java.io.PrintWriter
Prints a boolean value and then terminates the line.
println(char) - Method in class java.io.PrintWriter
Prints a character and then terminates the line.
println(int) - Method in class java.io.PrintWriter
Prints an integer and then terminates the line.
println(long) - Method in class java.io.PrintWriter
Prints a long integer and then terminates the line.
println(float) - Method in class java.io.PrintWriter
Prints a floating-point number and then terminates the line.
println(double) - Method in class java.io.PrintWriter
Prints a double-precision floating-point number and then terminates the line.
println(char[]) - Method in class java.io.PrintWriter
Prints an array of characters and then terminates the line.
println(String) - Method in class java.io.PrintWriter
Prints a String and then terminates the line.
println(Object) - Method in class java.io.PrintWriter
Prints an Object and then terminates the line.
println(String) - Static method in class java.sql.DriverManager
Prints a message to the current JDBC log stream.
printLong(long) - Static method in class javax.xml.bind.DatatypeConverter
Converts A long value into a string.
printLong(long) - Method in interface javax.xml.bind.DatatypeConverterInterface
Converts a long value into a string.
printMessage(Diagnostic.Kind, CharSequence) - Method in interface javax.annotation.processing.Messager
Prints a message of the specified kind.
printMessage(Diagnostic.Kind, CharSequence, Element) - Method in interface javax.annotation.processing.Messager
Prints a message of the specified kind at the location of the element.
printMessage(Diagnostic.Kind, CharSequence, Element, AnnotationMirror) - Method in interface javax.annotation.processing.Messager
Prints a message of the specified kind at the location of the annotation mirror of the annotated element.
printMessage(Diagnostic.Kind, CharSequence, Element, AnnotationMirror, AnnotationValue) - Method in interface javax.annotation.processing.Messager
Prints a message of the specified kind at the location of the annotation value inside the annotation mirror of the annotated element.
printQName(QName, NamespaceContext) - Static method in class javax.xml.bind.DatatypeConverter
Converts a QName instance into a string.
printQName(QName, NamespaceContext) - Method in interface javax.xml.bind.DatatypeConverterInterface
Converts a QName instance into a string.
PrintQuality - Class in javax.print.attribute.standard
Class PrintQuality is a printing attribute class, an enumeration, that specifies the print quality that the printer uses for the job.
PrintQuality(int) - Constructor for class javax.print.attribute.standard.PrintQuality
Construct a new print quality enumeration value with the given integer value.
PrintRequestAttribute - Interface in javax.print.attribute
Interface PrintRequestAttribute is a tagging interface which a printing attribute class implements to indicate the attribute denotes a requested setting for a print job.
PrintRequestAttributeSet - Interface in javax.print.attribute
Interface PrintRequestAttributeSet specifies the interface for a set of print request attributes, i.e.
PrintService - Interface in javax.print
Interface PrintService is the factory for a DocPrintJob.
PrintServiceAttribute - Interface in javax.print.attribute
Interface PrintServiceAttribute is a tagging interface which a printing attribute class implements to indicate the attribute describes the status of a Print Service or some other characteristic of a Print Service.
PrintServiceAttributeEvent - Class in javax.print.event
Class PrintServiceAttributeEvent encapsulates an event a Print Service instance reports to let the client know of changes in the print service state.
PrintServiceAttributeEvent(PrintService, PrintServiceAttributeSet) - Constructor for class javax.print.event.PrintServiceAttributeEvent
Constructs a PrintServiceAttributeEvent object.
PrintServiceAttributeListener - Interface in javax.print.event
Implementations of this listener interface are attached to a PrintService to monitor the status of the print service.
PrintServiceAttributeSet - Interface in javax.print.attribute
Interface PrintServiceAttributeSet specifies the interface for a set of print job attributes, i.e.
PrintServiceLookup - Class in javax.print
Implementations of this class provide lookup services for print services (typically equivalent to printers) of a particular type.
PrintServiceLookup() - Constructor for class javax.print.PrintServiceLookup
printShort(short) - Static method in class javax.xml.bind.DatatypeConverter
Converts a short value into a string.
printShort(short) - Method in interface javax.xml.bind.DatatypeConverterInterface
Converts a short value into a string.
printStackTrace() - Method in class java.lang.Throwable
Prints this throwable and its backtrace to the standard error stream.
printStackTrace(PrintStream) - Method in class java.lang.Throwable
Prints this throwable and its backtrace to the specified print stream.
printStackTrace(PrintWriter) - Method in class java.lang.Throwable
Prints this throwable and its backtrace to the specified print writer.
printStackTrace(PrintStream) - Method in exception javax.xml.bind.JAXBException
Prints this JAXBException and its stack trace (including the stack trace of the linkedException if it is non-null) to the PrintStream.
printStackTrace() - Method in exception javax.xml.bind.JAXBException
Prints this JAXBException and its stack trace (including the stack trace of the linkedException if it is non-null) to System.err.
printStackTrace(PrintWriter) - Method in exception javax.xml.bind.JAXBException
Prints this JAXBException and its stack trace (including the stack trace of the linkedException if it is non-null) to the PrintWriter.
printStackTrace(PrintStream) - Method in exception javax.xml.bind.TypeConstraintException
Prints this TypeConstraintException and its stack trace (including the stack trace of the linkedException if it is non-null) to the PrintStream.
printStackTrace() - Method in exception javax.xml.bind.TypeConstraintException
Prints this TypeConstraintException and its stack trace (including the stack trace of the linkedException if it is non-null) to System.err.
printStackTrace() - Method in exception javax.xml.crypto.dsig.TransformException
Prints this TransformException, its backtrace and the cause's backtrace to the standard error stream.
printStackTrace(PrintStream) - Method in exception javax.xml.crypto.dsig.TransformException
Prints this TransformException, its backtrace and the cause's backtrace to the specified print stream.
printStackTrace(PrintWriter) - Method in exception javax.xml.crypto.dsig.TransformException
Prints this TransformException, its backtrace and the cause's backtrace to the specified print writer.
printStackTrace() - Method in exception javax.xml.crypto.dsig.XMLSignatureException
Prints this XMLSignatureException, its backtrace and the cause's backtrace to the standard error stream.
printStackTrace(PrintStream) - Method in exception javax.xml.crypto.dsig.XMLSignatureException
Prints this XMLSignatureException, its backtrace and the cause's backtrace to the specified print stream.
printStackTrace(PrintWriter) - Method in exception javax.xml.crypto.dsig.XMLSignatureException
Prints this XMLSignatureException, its backtrace and the cause's backtrace to the specified print writer.
printStackTrace() - Method in exception javax.xml.crypto.KeySelectorException
Prints this KeySelectorException, its backtrace and the cause's backtrace to the standard error stream.
printStackTrace(PrintStream) - Method in exception javax.xml.crypto.KeySelectorException
Prints this KeySelectorException, its backtrace and the cause's backtrace to the specified print stream.
printStackTrace(PrintWriter) - Method in exception javax.xml.crypto.KeySelectorException
Prints this KeySelectorException, its backtrace and the cause's backtrace to the specified print writer.
printStackTrace() - Method in exception javax.xml.crypto.MarshalException
Prints this MarshalException, its backtrace and the cause's backtrace to the standard error stream.
printStackTrace(PrintStream) - Method in exception javax.xml.crypto.MarshalException
Prints this MarshalException, its backtrace and the cause's backtrace to the specified print stream.
printStackTrace(PrintWriter) - Method in exception javax.xml.crypto.MarshalException
Prints this MarshalException, its backtrace and the cause's backtrace to the specified print writer.
printStackTrace() - Method in exception javax.xml.crypto.NoSuchMechanismException
Prints this NoSuchMechanismException, its backtrace and the cause's backtrace to the standard error stream.
printStackTrace(PrintStream) - Method in exception javax.xml.crypto.NoSuchMechanismException
Prints this NoSuchMechanismException, its backtrace and the cause's backtrace to the specified print stream.
printStackTrace(PrintWriter) - Method in exception javax.xml.crypto.NoSuchMechanismException
Prints this NoSuchMechanismException, its backtrace and the cause's backtrace to the specified print writer.
printStackTrace() - Method in exception javax.xml.crypto.URIReferenceException
Prints this URIReferenceException, its backtrace and the cause's backtrace to the standard error stream.
printStackTrace(PrintStream) - Method in exception javax.xml.crypto.URIReferenceException
Prints this URIReferenceException, its backtrace and the cause's backtrace to the specified print stream.
printStackTrace(PrintWriter) - Method in exception javax.xml.crypto.URIReferenceException
Prints this URIReferenceException, its backtrace and the cause's backtrace to the specified print writer.
printStackTrace() - Method in exception javax.xml.transform.TransformerException
Print the the trace of methods from where the error originated.
printStackTrace(PrintStream) - Method in exception javax.xml.transform.TransformerException
Print the the trace of methods from where the error originated.
printStackTrace(PrintWriter) - Method in exception javax.xml.transform.TransformerException
Print the the trace of methods from where the error originated.
printStackTrace(PrintStream) - Method in exception javax.xml.xpath.XPathException
Print stack trace to specified PrintStream.
printStackTrace() - Method in exception javax.xml.xpath.XPathException
Print stack trace to System.err.
printStackTrace(PrintWriter) - Method in exception javax.xml.xpath.XPathException
Print stack trace to specified PrintWriter.
PrintStream - Class in java.io
A PrintStream adds functionality to another output stream, namely the ability to print representations of various data values conveniently.
PrintStream(OutputStream) - Constructor for class java.io.PrintStream
Creates a new print stream.
PrintStream(OutputStream, boolean) - Constructor for class java.io.PrintStream
Creates a new print stream.
PrintStream(OutputStream, boolean, String) - Constructor for class java.io.PrintStream
Creates a new print stream.
PrintStream(String) - Constructor for class java.io.PrintStream
Creates a new print stream, without automatic line flushing, with the specified file name.
PrintStream(String, String) - Constructor for class java.io.PrintStream
Creates a new print stream, without automatic line flushing, with the specified file name and charset.
PrintStream(File) - Constructor for class java.io.PrintStream
Creates a new print stream, without automatic line flushing, with the specified file.
PrintStream(File, String) - Constructor for class java.io.PrintStream
Creates a new print stream, without automatic line flushing, with the specified file and charset.
printString(String) - Static method in class javax.xml.bind.DatatypeConverter
Converts the string argument into a string.
printString(String) - Method in interface javax.xml.bind.DatatypeConverterInterface
Converts the string argument into a string.
printTime(Calendar) - Static method in class javax.xml.bind.DatatypeConverter
Converts a Calendar value into a string.
printTime(Calendar) - Method in interface javax.xml.bind.DatatypeConverterInterface
Converts a Calendar value into a string.
printUnsignedInt(long) - Static method in class javax.xml.bind.DatatypeConverter
Converts a long value into a string.
printUnsignedInt(long) - Method in interface javax.xml.bind.DatatypeConverterInterface
Converts a long value into a string.
printUnsignedShort(int) - Static method in class javax.xml.bind.DatatypeConverter
Converts an int value into a string.
printUnsignedShort(int) - Method in interface javax.xml.bind.DatatypeConverterInterface
Converts an int value into a string.
PrintWriter - Class in java.io
Prints formatted representations of objects to a text-output stream.
PrintWriter(Writer) - Constructor for class java.io.PrintWriter
Creates a new PrintWriter, without automatic line flushing.
PrintWriter(Writer, boolean) - Constructor for class java.io.PrintWriter
Creates a new PrintWriter.
PrintWriter(OutputStream) - Constructor for class java.io.PrintWriter
Creates a new PrintWriter, without automatic line flushing, from an existing OutputStream.
PrintWriter(OutputStream, boolean) - Constructor for class java.io.PrintWriter
Creates a new PrintWriter from an existing OutputStream.
PrintWriter(String) - Constructor for class java.io.PrintWriter
Creates a new PrintWriter, without automatic line flushing, with the specified file name.
PrintWriter(String, String) - Constructor for class java.io.PrintWriter
Creates a new PrintWriter, without automatic line flushing, with the specified file name and charset.
PrintWriter(File) - Constructor for class java.io.PrintWriter
Creates a new PrintWriter, without automatic line flushing, with the specified file.
PrintWriter(File, String) - Constructor for class java.io.PrintWriter
Creates a new PrintWriter, without automatic line flushing, with the specified file and charset.
PRIOR - Static variable in class java.awt.BufferCapabilities.FlipContents
When flip contents are PRIOR, the contents of the back buffer are the prior contents of the front buffer (a true page flip).
PRIORITY_INTERCHAR - Static variable in class java.awt.font.GlyphJustificationInfo
The second lowest justification priority.
PRIORITY_KASHIDA - Static variable in class java.awt.font.GlyphJustificationInfo
The highest justification priority.
PRIORITY_NONE - Static variable in class java.awt.font.GlyphJustificationInfo
The lowest justification priority.
PRIORITY_WHITESPACE - Static variable in class java.awt.font.GlyphJustificationInfo
The second highest justification priority.
PriorityBlockingQueue<E> - Class in java.util.concurrent
An unbounded blocking queue that uses the same ordering rules as class PriorityQueue and supplies blocking retrieval operations.
PriorityBlockingQueue() - Constructor for class java.util.concurrent.PriorityBlockingQueue
Creates a PriorityBlockingQueue with the default initial capacity (11) that orders its elements according to their natural ordering.
PriorityBlockingQueue(int) - Constructor for class java.util.concurrent.PriorityBlockingQueue
Creates a PriorityBlockingQueue with the specified initial capacity that orders its elements according to their natural ordering.
PriorityBlockingQueue(int, Comparator<? super E>) - Constructor for class java.util.concurrent.PriorityBlockingQueue
Creates a PriorityBlockingQueue with the specified initial capacity that orders its elements according to the specified comparator.
PriorityBlockingQueue(Collection<? extends E>) - Constructor for class java.util.concurrent.PriorityBlockingQueue
Creates a PriorityBlockingQueue containing the elements in the specified collection.
PriorityQueue<E> - Class in java.util
An unbounded priority queue based on a priority heap.
PriorityQueue() - Constructor for class java.util.PriorityQueue
Creates a PriorityQueue with the default initial capacity (11) that orders its elements according to their natural ordering.
PriorityQueue(int) - Constructor for class java.util.PriorityQueue
Creates a PriorityQueue with the specified initial capacity that orders its elements according to their natural ordering.
PriorityQueue(Comparator<? super E>) - Constructor for class java.util.PriorityQueue
Creates a PriorityQueue with the default initial capacity and whose elements are ordered according to the specified comparator.
PriorityQueue(int, Comparator<? super E>) - Constructor for class java.util.PriorityQueue
Creates a PriorityQueue with the specified initial capacity that orders its elements according to the specified comparator.
PriorityQueue(Collection<? extends E>) - Constructor for class java.util.PriorityQueue
Creates a PriorityQueue containing the elements in the specified collection.
PriorityQueue(PriorityQueue<? extends E>) - Constructor for class java.util.PriorityQueue
Creates a PriorityQueue containing the elements in the specified priority queue.
PriorityQueue(SortedSet<? extends E>) - Constructor for class java.util.PriorityQueue
Creates a PriorityQueue containing the elements in the specified sorted set.
PRIVATE - Static variable in class java.lang.invoke.MethodHandles.Lookup
A single-bit mask representing private access, which may contribute to the result of lookupModes.
PRIVATE - Static variable in class java.lang.reflect.Modifier
The int value representing the private modifier.
PRIVATE - Static variable in class java.nio.channels.FileChannel.MapMode
Mode for a private (copy-on-write) mapping.
PRIVATE_KEY - Static variable in class javax.crypto.Cipher
Constant used to indicate the to-be-unwrapped key is a "private key".
PRIVATE_MEMBER - Interface in org.omg.CORBA
Constant to define a private member in the ValueMember class.
PRIVATE_USE - Static variable in class java.lang.Character
General category "Co" in the Unicode specification.
PRIVATE_USE_AREA - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Private Use Area" Unicode character block.
PRIVATE_USE_EXTENSION - Static variable in class java.util.Locale
The key for the private use extension ('x').
PrivateClassLoader - Interface in javax.management.loading
Marker interface indicating that a ClassLoader should not be added to the ClassLoaderRepository.
PrivateCredentialPermission - Class in javax.security.auth
This class is used to protect access to private Credentials belonging to a particular Subject.
PrivateCredentialPermission(String, String) - Constructor for class javax.security.auth.PrivateCredentialPermission
Creates a new PrivateCredentialPermission with the specified name.
PrivateKey - Interface in java.security
A private key.
PrivateKeyEntry(PrivateKey, Certificate[]) - Constructor for class java.security.KeyStore.PrivateKeyEntry
Constructs a PrivateKeyEntry with a PrivateKey and corresponding certificate chain.
PrivateKeyEntry(PrivateKey, Certificate[], Set<KeyStore.Entry.Attribute>) - Constructor for class java.security.KeyStore.PrivateKeyEntry
Constructs a PrivateKeyEntry with a PrivateKey and corresponding certificate chain and associated entry attributes.
PrivateMLet - Class in javax.management.loading
An MLet that is not added to the ClassLoaderRepository.
PrivateMLet(URL[], boolean) - Constructor for class javax.management.loading.PrivateMLet
Constructs a new PrivateMLet for the specified URLs using the default delegation parent ClassLoader.
PrivateMLet(URL[], ClassLoader, boolean) - Constructor for class javax.management.loading.PrivateMLet
Constructs a new PrivateMLet for the given URLs.
PrivateMLet(URL[], ClassLoader, URLStreamHandlerFactory, boolean) - Constructor for class javax.management.loading.PrivateMLet
Constructs a new PrivateMLet for the specified URLs, parent class loader, and URLStreamHandlerFactory.
PrivilegedAction<T> - Interface in java.security
A computation to be performed with privileges enabled.
PrivilegedActionException - Exception in java.security
This exception is thrown by doPrivileged(PrivilegedExceptionAction) and doPrivileged(PrivilegedExceptionAction, AccessControlContext context) to indicate that the action being performed threw a checked exception.
PrivilegedActionException(Exception) - Constructor for exception java.security.PrivilegedActionException
Constructs a new PrivilegedActionException "wrapping" the specific Exception.
privilegedCallable(Callable<T>) - Static method in class java.util.concurrent.Executors
Returns a Callable object that will, when called, execute the given callable under the current access control context.
privilegedCallableUsingCurrentClassLoader(Callable<T>) - Static method in class java.util.concurrent.Executors
Returns a Callable object that will, when called, execute the given callable under the current access control context, with the current context class loader as the context class loader.
PrivilegedExceptionAction<T> - Interface in java.security
A computation to be performed with privileges enabled, that throws one or more checked exceptions.
privilegedThreadFactory() - Static method in class java.util.concurrent.Executors
Returns a thread factory used to create new threads that have the same permissions as the current thread.
probablePrime(int, Random) - Static method in class java.math.BigInteger
Returns a positive BigInteger that is probably prime, with the specified bitLength.
probeContentType(Path) - Static method in class java.nio.file.Files
Probes the content type of a file.
probeContentType(Path) - Method in class java.nio.file.spi.FileTypeDetector
Probes the given file to guess its content type.
procedureColumnIn - Static variable in interface java.sql.DatabaseMetaData
Indicates that the column stores IN parameters.
procedureColumnInOut - Static variable in interface java.sql.DatabaseMetaData
Indicates that the column stores INOUT parameters.
procedureColumnOut - Static variable in interface java.sql.DatabaseMetaData
Indicates that the column stores OUT parameters.
procedureColumnResult - Static variable in interface java.sql.DatabaseMetaData
Indicates that the column stores results.
procedureColumnReturn - Static variable in interface java.sql.DatabaseMetaData
Indicates that the column stores return values.
procedureColumnUnknown - Static variable in interface java.sql.DatabaseMetaData
Indicates that type of the column is unknown.
procedureNoNulls - Static variable in interface java.sql.DatabaseMetaData
Indicates that NULL values are not allowed.
procedureNoResult - Static variable in interface java.sql.DatabaseMetaData
Indicates that the procedure does not return a result.
procedureNullable - Static variable in interface java.sql.DatabaseMetaData
Indicates that NULL values are allowed.
procedureNullableUnknown - Static variable in interface java.sql.DatabaseMetaData
Indicates that whether NULL values are allowed is unknown.
procedureResultUnknown - Static variable in interface java.sql.DatabaseMetaData
Indicates that it is not known whether the procedure returns a result.
procedureReturnsResult - Static variable in interface java.sql.DatabaseMetaData
Indicates that the procedure returns a result.
Process - Class in java.lang
The ProcessBuilder.start() and Runtime.exec methods create a native process and return an instance of a subclass of Process that can be used to control the process and obtain information about it.
Process() - Constructor for class java.lang.Process
process(Set<? extends TypeElement>, RoundEnvironment) - Method in class javax.annotation.processing.AbstractProcessor
Processes a set of annotation types on type elements originating from the prior round and returns whether or not these annotation types are claimed by this processor.
process(Set<? extends TypeElement>, RoundEnvironment) - Method in interface javax.annotation.processing.Processor
Processes a set of annotation types on type elements originating from the prior round and returns whether or not these annotation types are claimed by this processor.
process(List<V>) - Method in class javax.swing.SwingWorker
Receives data chunks from the publish method asynchronously on the Event Dispatch Thread.
processActionEvent(ActionEvent) - Method in class java.awt.Button
Processes action events occurring on this button by dispatching them to any registered ActionListener objects.
processActionEvent(ActionEvent) - Method in class java.awt.List
Processes action events occurring on this component by dispatching them to any registered ActionListener objects.
processActionEvent(ActionEvent) - Method in class java.awt.MenuItem
Processes action events occurring on this menu item, by dispatching them to any registered ActionListener objects.
processActionEvent(ActionEvent) - Method in class java.awt.TextField
Processes action events occurring on this text field by dispatching them to any registered ActionListener objects.
processAdjustmentEvent(AdjustmentEvent) - Method in class java.awt.Scrollbar
Processes adjustment events occurring on this scrollbar by dispatching them to any registered AdjustmentListener objects.
ProcessBuilder - Class in java.lang
This class is used to create operating system processes.
ProcessBuilder(List<String>) - Constructor for class java.lang.ProcessBuilder
Constructs a process builder with the specified operating system program and arguments.
ProcessBuilder(String...) - Constructor for class java.lang.ProcessBuilder
Constructs a process builder with the specified operating system program and arguments.
ProcessBuilder.Redirect - Class in java.lang
Represents a source of subprocess input or a destination of subprocess output.
ProcessBuilder.Redirect.Type - Enum in java.lang
The type of a ProcessBuilder.Redirect.
processComponentEvent(ComponentEvent) - Method in class java.awt.Component
Processes component events occurring on this component by dispatching them to any registered ComponentListener objects.
processComponentEvent(ComponentEvent, JLayer<? extends V>) - Method in class javax.swing.plaf.LayerUI
Processes component events occurring on the JLayer or any of its subcomponents.
processComponentKeyEvent(KeyEvent) - Method in class javax.swing.JComponent
Processes any key events that the component itself recognizes.
processContainerEvent(ContainerEvent) - Method in class java.awt.Container
Processes container events occurring on this container by dispatching them to any registered ContainerListener objects.
processEvent(AWTEvent) - Method in class java.awt.Button
Processes events on this button.
processEvent(AWTEvent) - Method in class java.awt.Checkbox
Processes events on this check box.
processEvent(AWTEvent) - Method in class java.awt.CheckboxMenuItem
Processes events on this check box menu item.
processEvent(AWTEvent) - Method in class java.awt.Choice
Processes events on this choice.
processEvent(AWTEvent) - Method in class java.awt.Component
Processes events occurring on this component.
processEvent(AWTEvent) - Method in class java.awt.Container
Processes events on this container.
processEvent(AWTEvent) - Method in class java.awt.List
Processes events on this scrolling list.
processEvent(AWTEvent) - Method in class java.awt.MenuComponent
Processes events occurring on this menu component.
processEvent(AWTEvent) - Method in class java.awt.MenuItem
Processes events on this menu item.
processEvent(AWTEvent) - Method in class java.awt.Scrollbar
Processes events on this scroll bar.
processEvent(AWTEvent) - Method in class java.awt.TextComponent
Processes events on this text component.
processEvent(AWTEvent) - Method in class java.awt.TextField
Processes events on this text field.
processEvent(AWTEvent) - Method in class java.awt.Window
Processes events on this window.
processFocusEvent(FocusEvent) - Method in class java.awt.Component
Processes focus events occurring on this component by dispatching them to any registered FocusListener objects.
processFocusEvent(FocusEvent) - Method in class javax.swing.JFormattedTextField
Processes any focus events, such as FocusEvent.FOCUS_GAINED or FocusEvent.FOCUS_LOST.
processFocusEvent(FocusEvent) - Method in class javax.swing.JPopupMenu
processFocusEvent(FocusEvent, JLayer<? extends V>) - Method in class javax.swing.plaf.LayerUI
Processes focus events occurring on the JLayer or any of its subcomponents.
processHierarchyBoundsEvent(HierarchyEvent) - Method in class java.awt.Component
Processes hierarchy bounds events occurring on this component by dispatching them to any registered HierarchyBoundsListener objects.
processHierarchyBoundsEvent(HierarchyEvent, JLayer<? extends V>) - Method in class javax.swing.plaf.LayerUI
Processes hierarchy bounds event occurring on the JLayer or any of its subcomponents.
processHierarchyEvent(HierarchyEvent) - Method in class java.awt.Component
Processes hierarchy events occurring on this component by dispatching them to any registered HierarchyListener objects.
processHierarchyEvent(HierarchyEvent, JLayer<? extends V>) - Method in class javax.swing.plaf.LayerUI
Processes hierarchy event occurring on the JLayer or any of its subcomponents.
processHTMLFrameHyperlinkEvent(HTMLFrameHyperlinkEvent) - Method in class javax.swing.text.html.HTMLDocument
Processes HyperlinkEvents that are generated by documents in an HTML frame.
processImageComplete() - Method in class javax.imageio.ImageReader
Broadcasts the completion of an image read to all registered IIOReadProgressListeners by calling their imageComplete method.
processImageComplete() - Method in class javax.imageio.ImageWriter
Broadcasts the completion of an image write to all registered IIOWriteProgressListeners by calling their imageComplete method.
processImageProgress(float) - Method in class javax.imageio.ImageReader
Broadcasts the current percentage of image completion to all registered IIOReadProgressListeners by calling their imageProgress method.
processImageProgress(float) - Method in class javax.imageio.ImageWriter
Broadcasts the current percentage of image completion to all registered IIOWriteProgressListeners by calling their imageProgress method.
processImageStarted(int) - Method in class javax.imageio.ImageReader
Broadcasts the start of an image read to all registered IIOReadProgressListeners by calling their imageStarted method.
processImageStarted(int) - Method in class javax.imageio.ImageWriter
Broadcasts the start of an image write to all registered IIOWriteProgressListeners by calling their imageStarted method.
processImageUpdate(BufferedImage, int, int, int, int, int, int, int[]) - Method in class javax.imageio.ImageReader
Broadcasts the update of a set of samples to all registered IIOReadUpdateListeners by calling their imageUpdate method.
PROCESSING - Static variable in class javax.print.attribute.standard.JobState
The job is processing.
PROCESSING - Static variable in class javax.print.attribute.standard.PrinterState
Indicates that jobs are processing; new jobs will wait before processing.
PROCESSING_INSTRUCTION - Static variable in interface javax.xml.stream.XMLStreamConstants
Indicates an event is a processing instruction
PROCESSING_INSTRUCTION_NODE - Static variable in interface org.w3c.dom.Node
The node is a ProcessingInstruction.
PROCESSING_STOPPED - Static variable in class javax.print.attribute.standard.JobState
The job has stopped while processing for any number of reasons and will return to the PROCESSING state as soon as the reasons are no longer present.
PROCESSING_TO_STOP_POINT - Static variable in class javax.print.attribute.standard.JobStateReason
The requester has canceled the job or the printer has aborted the job, but the printer is still performing some actions on the job until a specified stop point occurs or job termination/cleanup is completed.
processingEnv - Variable in class javax.annotation.processing.AbstractProcessor
Processing environment providing by the tool framework.
ProcessingEnvironment - Interface in javax.annotation.processing
An annotation processing tool framework will provide an annotation processor with an object implementing this interface so the processor can use facilities provided by the framework to write new files, report error messages, and find other utilities.
ProcessingInstruction - Interface in javax.xml.stream.events
An interface that describes the data found in processing instructions
ProcessingInstruction - Interface in org.w3c.dom
The ProcessingInstruction interface represents a "processing instruction", used in XML as a way to keep processor-specific information in the text of the document.
processingInstruction(String, String) - Method in interface org.xml.sax.ContentHandler
Receive notification of a processing instruction.
processingInstruction(String, String) - Method in interface org.xml.sax.DocumentHandler
Deprecated.
Receive notification of a processing instruction.
processingInstruction(String, String) - Method in class org.xml.sax.HandlerBase
Deprecated.
Receive notification of a processing instruction.
processingInstruction(String, String) - Method in class org.xml.sax.helpers.DefaultHandler
Receive notification of a processing instruction.
processingInstruction(String, String) - Method in class org.xml.sax.helpers.ParserAdapter
Adapter implementation method; do not call.
processingInstruction(String, String) - Method in class org.xml.sax.helpers.XMLFilterImpl
Filter a processing instruction event.
processingInstruction(String, String) - Method in class org.xml.sax.helpers.XMLReaderAdapter
Adapt a SAX2 processing instruction event.
processingOver() - Method in interface javax.annotation.processing.RoundEnvironment
Returns true if types generated by this round will not be subject to a subsequent round of annotation processing; returns false otherwise.
processInputMethodEvent(InputMethodEvent) - Method in class java.awt.Component
Processes input method events occurring on this component by dispatching them to any registered InputMethodListener objects.
processInputMethodEvent(InputMethodEvent) - Method in class javax.swing.JFormattedTextField
Processes any input method events, such as InputMethodEvent.INPUT_METHOD_TEXT_CHANGED or InputMethodEvent.CARET_POSITION_CHANGED.
processInputMethodEvent(InputMethodEvent, JLayer<? extends V>) - Method in class javax.swing.plaf.LayerUI
Processes input event occurring on the JLayer or any of its subcomponents.
processInputMethodEvent(InputMethodEvent) - Method in class javax.swing.text.JTextComponent
processItemEvent(ItemEvent) - Method in class java.awt.Checkbox
Processes item events occurring on this check box by dispatching them to any registered ItemListener objects.
processItemEvent(ItemEvent) - Method in class java.awt.CheckboxMenuItem
Processes item events occurring on this check box menu item by dispatching them to any registered ItemListener objects.
processItemEvent(ItemEvent) - Method in class java.awt.Choice
Processes item events occurring on this Choice menu by dispatching them to any registered ItemListener objects.
processItemEvent(ItemEvent) - Method in class java.awt.List
Processes item events occurring on this list by dispatching them to any registered ItemListener objects.
processKeyBinding(KeyStroke, KeyEvent, int, boolean) - Method in class javax.swing.JComponent
Invoked to process the key bindings for ks as the result of the KeyEvent e.
processKeyBinding(KeyStroke, KeyEvent, int, boolean) - Method in class javax.swing.JMenuBar
Subclassed to check all the child menus.
processKeyBinding(KeyStroke, KeyEvent, int, boolean) - Method in class javax.swing.JTable
processKeyBindings(KeyEvent) - Static method in class javax.swing.SwingUtilities
Process the key bindings for the Component associated with event.
processKeyEvent(KeyEvent) - Method in class java.awt.Component
Processes key events occurring on this component by dispatching them to any registered KeyListener objects.
processKeyEvent(Component, KeyEvent) - Method in class java.awt.DefaultKeyboardFocusManager
This method initiates a focus traversal operation if and only if the KeyEvent represents a focus traversal key for the specified focusedComponent.
processKeyEvent(Component, KeyEvent) - Method in class java.awt.KeyboardFocusManager
This method initiates a focus traversal operation if and only if the KeyEvent represents a focus traversal key for the specified focusedComponent.
processKeyEvent(KeyEvent) - Method in class javax.swing.JComboBox
Handles KeyEvents, looking for the Tab key.
processKeyEvent(KeyEvent) - Method in class javax.swing.JComponent
Overrides processKeyEvent to process events.
processKeyEvent(KeyEvent) - Method in class javax.swing.JMenu
Processes key stroke events such as mnemonics and accelerators.
processKeyEvent(KeyEvent, MenuElement[], MenuSelectionManager) - Method in class javax.swing.JMenuBar
Implemented to be a MenuElement -- does nothing.
processKeyEvent(KeyEvent, MenuElement[], MenuSelectionManager) - Method in class javax.swing.JMenuItem
Processes a key event forwarded from the MenuSelectionManager and changes the menu selection, if necessary, by using MenuSelectionManager's API.
processKeyEvent(KeyEvent) - Method in class javax.swing.JPopupMenu
Processes key stroke events such as mnemonics and accelerators.
processKeyEvent(KeyEvent, MenuElement[], MenuSelectionManager) - Method in class javax.swing.JPopupMenu
Processes a key event forwarded from the MenuSelectionManager and changes the menu selection, if necessary, by using MenuSelectionManager's API.
processKeyEvent(KeyEvent, MenuElement[], MenuSelectionManager) - Method in interface javax.swing.MenuElement
Process a key event.
processKeyEvent(KeyEvent) - Method in class javax.swing.MenuSelectionManager
When a MenuElement receives an event from a KeyListener, it should never process the event directly.
processKeyEvent(KeyEvent, JLayer<? extends V>) - Method in class javax.swing.plaf.LayerUI
Processes key events occurring on the JLayer or any of its subcomponents.
processMenuDragMouseEvent(MenuDragMouseEvent) - Method in class javax.swing.JMenuItem
Handles mouse drag in a menu.
processMenuKeyEvent(MenuKeyEvent) - Method in class javax.swing.JMenuItem
Handles a keystroke in a menu.
processMouseEvent(MouseEvent) - Method in class java.awt.Component
Processes mouse events occurring on this component by dispatching them to any registered MouseListener objects.
processMouseEvent(MouseEvent) - Method in class javax.swing.JComponent
Processes mouse events occurring on this component by dispatching them to any registered MouseListener objects, refer to Component.processMouseEvent(MouseEvent) for a complete description of this method.
processMouseEvent(MouseEvent, MenuElement[], MenuSelectionManager) - Method in class javax.swing.JMenuBar
Implemented to be a MenuElement -- does nothing.
processMouseEvent(MouseEvent, MenuElement[], MenuSelectionManager) - Method in class javax.swing.JMenuItem
Processes a mouse event forwarded from the MenuSelectionManager and changes the menu selection, if necessary, by using the MenuSelectionManager's API.
processMouseEvent(MouseEvent, MenuElement[], MenuSelectionManager) - Method in class javax.swing.JPopupMenu
This method is required to conform to the MenuElement interface, but it not implemented.
processMouseEvent(MouseEvent, MenuElement[], MenuSelectionManager) - Method in interface javax.swing.MenuElement
Processes a mouse event.
processMouseEvent(MouseEvent) - Method in class javax.swing.MenuSelectionManager
When a MenuElement receives an event from a MouseListener, it should never process the event directly.
processMouseEvent(JMenuItem, MouseEvent, MenuElement[], MenuSelectionManager) - Method in class javax.swing.plaf.basic.BasicCheckBoxMenuItemUI
processMouseEvent(JMenuItem, MouseEvent, MenuElement[], MenuSelectionManager) - Method in class javax.swing.plaf.basic.BasicRadioButtonMenuItemUI
processMouseEvent(MouseEvent, JLayer<? extends V>) - Method in class javax.swing.plaf.LayerUI
Processes mouse events occurring on the JLayer or any of its subcomponents.
processMouseMotionEvent(MouseEvent) - Method in class java.awt.Component
Processes mouse motion events occurring on this component by dispatching them to any registered MouseMotionListener objects.
processMouseMotionEvent(MouseEvent) - Method in class javax.swing.JComponent
Processes mouse motion events, such as MouseEvent.MOUSE_DRAGGED.
processMouseMotionEvent(MouseEvent, JLayer<? extends V>) - Method in class javax.swing.plaf.LayerUI
Processes mouse motion event occurring on the JLayer or any of its subcomponents.
processMouseWheelEvent(MouseWheelEvent) - Method in class java.awt.Component
Processes mouse wheel events occurring on this component by dispatching them to any registered MouseWheelListener objects.
processMouseWheelEvent(MouseWheelEvent) - Method in class java.awt.ScrollPane
Process mouse wheel events that are delivered to this ScrollPane by scrolling an appropriate amount.
processMouseWheelEvent(MouseWheelEvent, JLayer<? extends V>) - Method in class javax.swing.plaf.LayerUI
Processes mouse wheel event occurring on the JLayer or any of its subcomponents.
processName(String, String[], boolean) - Method in class org.xml.sax.helpers.NamespaceSupport
Process a raw XML qualified name, after all declarations in the current context have been handled by declarePrefix().
Processor - Interface in javax.annotation.processing
The interface for an annotation processor.
processPassComplete(BufferedImage) - Method in class javax.imageio.ImageReader
Broadcasts the end of a progressive pass to all registered IIOReadUpdateListeners by calling their passComplete method.
processPassStarted(BufferedImage, int, int, int, int, int, int, int, int[]) - Method in class javax.imageio.ImageReader
Broadcasts the beginning of a progressive pass to all registered IIOReadUpdateListeners by calling their passStarted method.
processReadAborted() - Method in class javax.imageio.ImageReader
Broadcasts that the read has been aborted to all registered IIOReadProgressListeners by calling their readAborted method.
processSequenceComplete() - Method in class javax.imageio.ImageReader
Broadcasts the completion of an sequence of image reads to all registered IIOReadProgressListeners by calling their sequenceComplete method.
processSequenceStarted(int) - Method in class javax.imageio.ImageReader
Broadcasts the start of an sequence of image reads to all registered IIOReadProgressListeners by calling their sequenceStarted method.
processTextEvent(TextEvent) - Method in class java.awt.TextComponent
Processes text events occurring on this text component by dispatching them to any registered TextListener objects.
processThumbnailComplete() - Method in class javax.imageio.ImageReader
Broadcasts the completion of a thumbnail read to all registered IIOReadProgressListeners by calling their thumbnailComplete method.
processThumbnailComplete() - Method in class javax.imageio.ImageWriter
Broadcasts the completion of a thumbnail write to all registered IIOWriteProgressListeners by calling their thumbnailComplete method.
processThumbnailPassComplete(BufferedImage) - Method in class javax.imageio.ImageReader
Broadcasts the end of a thumbnail progressive pass to all registered IIOReadUpdateListeners by calling their thumbnailPassComplete method.
processThumbnailPassStarted(BufferedImage, int, int, int, int, int, int, int, int[]) - Method in class javax.imageio.ImageReader
Broadcasts the beginning of a thumbnail progressive pass to all registered IIOReadUpdateListeners by calling their thumbnailPassStarted method.
processThumbnailProgress(float) - Method in class javax.imageio.ImageReader
Broadcasts the current percentage of thumbnail completion to all registered IIOReadProgressListeners by calling their thumbnailProgress method.
processThumbnailProgress(float) - Method in class javax.imageio.ImageWriter
Broadcasts the current percentage of thumbnail completion to all registered IIOWriteProgressListeners by calling their thumbnailProgress method.
processThumbnailStarted(int, int) - Method in class javax.imageio.ImageReader
Broadcasts the start of a thumbnail read to all registered IIOReadProgressListeners by calling their thumbnailStarted method.
processThumbnailStarted(int, int) - Method in class javax.imageio.ImageWriter
Broadcasts the start of a thumbnail write to all registered IIOWriteProgressListeners by calling their thumbnailStarted method.
processThumbnailUpdate(BufferedImage, int, int, int, int, int, int, int[]) - Method in class javax.imageio.ImageReader
Broadcasts the update of a set of samples in a thumbnail image to all registered IIOReadUpdateListeners by calling their thumbnailUpdate method.
processWarningOccurred(String) - Method in class javax.imageio.ImageReader
Broadcasts a warning message to all registered IIOReadWarningListeners by calling their warningOccurred method.
processWarningOccurred(String, String) - Method in class javax.imageio.ImageReader
Broadcasts a localized warning message to all registered IIOReadWarningListeners by calling their warningOccurred method with a string taken from a ResourceBundle.
processWarningOccurred(int, String) - Method in class javax.imageio.ImageWriter
Broadcasts a warning message to all registered IIOWriteWarningListeners by calling their warningOccurred method.
processWarningOccurred(int, String, String) - Method in class javax.imageio.ImageWriter
Broadcasts a localized warning message to all registered IIOWriteWarningListeners by calling their warningOccurred method with a string taken from a ResourceBundle.
processWindowEvent(WindowEvent) - Method in class java.awt.Window
Processes window events occurring on this window by dispatching them to any registered WindowListener objects.
processWindowEvent(WindowEvent) - Method in class javax.swing.JDialog
Handles window events depending on the state of the defaultCloseOperation property.
processWindowEvent(WindowEvent) - Method in class javax.swing.JFrame
Processes window events occurring on this component.
processWindowFocusEvent(WindowEvent) - Method in class java.awt.Window
Processes window focus event occurring on this window by dispatching them to any registered WindowFocusListener objects.
processWindowStateEvent(WindowEvent) - Method in class java.awt.Window
Processes window state event occurring on this window by dispatching them to any registered WindowStateListener objects.
processWriteAborted() - Method in class javax.imageio.ImageWriter
Broadcasts that the write has been aborted to all registered IIOWriteProgressListeners by calling their writeAborted method.
profile_data - Variable in class org.omg.IOP.TaggedProfile
The associated profile data.
ProfileDataException - Exception in java.awt.color
This exception is thrown when an error occurs in accessing or processing an ICC_Profile object.
ProfileDataException(String) - Constructor for exception java.awt.color.ProfileDataException
Constructs a ProfileDataException with the specified detail message.
ProfileIdHelper - Class in org.omg.IOP
Profile ID
ProfileIdHelper() - Constructor for class org.omg.IOP.ProfileIdHelper
profiles - Variable in class org.omg.IOP.IOR
An array of tagged profiles associated with this object reference.
program - Variable in class javax.sound.midi.VoiceStatus
The program number of the instrument that this voice is currently using.
PROGRAM_CHANGE - Static variable in class javax.sound.midi.ShortMessage
Command value for Program Change message (0xC0, or 192)
programChange(int) - Method in interface javax.sound.midi.MidiChannel
Changes a program (patch).
programChange(int, int) - Method in interface javax.sound.midi.MidiChannel
Changes the program using bank and program (patch) numbers.
PROGRESS - Static variable in interface java.util.jar.Pack200.Packer
The unpacker's progress as a percentage, as periodically updated by the unpacker.
PROGRESS - Static variable in interface java.util.jar.Pack200.Unpacker
The unpacker's progress as a percentage, as periodically updated by the unpacker.
PROGRESS_BAR - Static variable in class javax.accessibility.AccessibleRole
An object used to indicate how much of a task has been completed.
PROGRESS_BAR - Static variable in class javax.swing.plaf.synth.Region
ProgressBar region.
PROGRESS_MONITOR - Static variable in class javax.accessibility.AccessibleRole
A role indicating the object monitors the progress of some operation.
progressBar - Variable in class javax.swing.plaf.basic.BasicProgressBarUI
ProgressBarUI - Class in javax.swing.plaf
Pluggable look and feel interface for JProgressBar.
ProgressBarUI() - Constructor for class javax.swing.plaf.ProgressBarUI
progressiveMode - Variable in class javax.imageio.ImageWriteParam
The mode controlling progressive encoding, which must be set to one of the four MODE_* values, except MODE_EXPLICIT.
progressListeners - Variable in class javax.imageio.ImageReader
A List of currently registered IIOReadProgressListeners, initialized by default to null, which is synonymous with an empty List.
progressListeners - Variable in class javax.imageio.ImageWriter
A List of currently registered IIOWriteProgressListeners, initialized by default null, which is synonymous with an empty List.
ProgressMonitor - Class in javax.swing
A class to monitor the progress of some operation.
ProgressMonitor(Component, Object, String, int, int) - Constructor for class javax.swing.ProgressMonitor
Constructs a graphic object that shows progress, typically by filling in a rectangular bar as the process nears completion.
ProgressMonitor.AccessibleProgressMonitor - Class in javax.swing
AccessibleProgressMonitor implements accessibility support for the ProgressMonitor class.
ProgressMonitorInputStream - Class in javax.swing
Monitors the progress of reading from some InputStream.
ProgressMonitorInputStream(Component, Object, InputStream) - Constructor for class javax.swing.ProgressMonitorInputStream
Constructs an object to monitor the progress of an input stream.
progressString - Variable in class javax.swing.JProgressBar
An optional string that can be displayed on the progress bar.
prolepticYear(Era, int) - Method in interface java.time.chrono.Chronology
Calculates the proleptic-year given the era and year-of-era.
prolepticYear(Era, int) - Method in class java.time.chrono.HijrahChronology
prolepticYear(Era, int) - Method in class java.time.chrono.IsoChronology
prolepticYear(Era, int) - Method in class java.time.chrono.JapaneseChronology
prolepticYear(Era, int) - Method in class java.time.chrono.MinguoChronology
prolepticYear(Era, int) - Method in class java.time.chrono.ThaiBuddhistChronology
PROMPT - Static variable in class javax.swing.text.html.HTML.Attribute
propagateCompletion() - Method in class java.util.concurrent.CountedCompleter
Equivalent to CountedCompleter.tryComplete() but does not invoke CountedCompleter.onCompletion(CountedCompleter) along the completion path: If the pending count is nonzero, decrements the count; otherwise, similarly tries to complete this task's completer, if one exists, else marks this task as complete.
propagatedFrom - Variable in class java.beans.beancontext.BeanContextEvent
The BeanContext from which this event was propagated
PROPERTIES - Static variable in interface java.awt.image.ImageObserver
This flag in the infoflags argument to imageUpdate indicates that the properties of the image are now available.
properties() - Method in interface java.util.jar.Pack200.Packer
Get the set of this engine's properties.
properties() - Method in interface java.util.jar.Pack200.Unpacker
Get the set of this engine's properties.
Properties - Class in java.util
The Properties class represents a persistent set of properties.
Properties() - Constructor for class java.util.Properties
Creates an empty property list with no default values.
Properties(Properties) - Constructor for class java.util.Properties
Creates an empty property list with the specified defaults.
properties() - Method in class javax.sound.midi.MidiFileFormat
Obtain an unmodifiable map of properties.
properties() - Method in class javax.sound.sampled.AudioFileFormat
Obtain an unmodifiable map of properties.
properties() - Method in class javax.sound.sampled.AudioFormat
Obtain an unmodifiable map of properties.
PROPERTY - Static variable in class org.w3c.dom.bootstrap.DOMImplementationRegistry
The system property to specify the DOMImplementationSource class names.
propertyChange(PropertyChangeEvent) - Method in class java.beans.beancontext.BeanContextSupport
subclasses may envelope to monitor child property changes.
propertyChange(PropertyChangeEvent) - Method in interface java.beans.PropertyChangeListener
This method gets called when a bound property is changed.
propertyChange(PropertyChangeEvent) - Method in class java.beans.PropertyChangeListenerProxy
Forwards the property change event to the listener delegate.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.JLayer
This method gets called when a bound property is changed.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.JList.AccessibleJList
Property Change Listener change method.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.JPopupMenu.AccessibleJPopupMenu
This method gets called when a bound property is changed.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.JScrollPane.AccessibleJScrollPane
This method gets called when a bound property is changed.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.JSpinner.DefaultEditor
Called by the JFormattedTextField PropertyChangeListener.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.JTable.AccessibleJTable
Track changes to selection model, column model, etc.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic.BasicButtonListener
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic.BasicColorChooserUI.PropertyHandler
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic.BasicComboBoxUI.PropertyChangeHandler
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic.BasicComboPopup.PropertyChangeHandler
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic.BasicDirectoryModel
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic.BasicEditorPaneUI
This method gets called when a bound property is changed on the associated JTextComponent.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane.PropertyChangeHandler
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.InternalFramePropertyChangeListener
Detects changes in state from the JInternalFrame and handles actions.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic.BasicLabelUI
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic.BasicListUI.PropertyChangeHandler
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic.BasicOptionPaneUI.PropertyChangeHandler
If the source of the PropertyChangeEvent e equals the optionPane and is one of the ICON_PROPERTY, MESSAGE_PROPERTY, OPTIONS_PROPERTY or INITIAL_VALUE_PROPERTY, validateComponent is invoked.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic.BasicRootPaneUI
Invoked when a property changes on the root pane.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic.BasicScrollBarUI.PropertyChangeHandler
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic.BasicScrollPaneUI.PropertyChangeHandler
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic.BasicSliderUI.PropertyChangeHandler
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider
Property change event, presumably from the JSplitPane, will message updateOrientation if necessary.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.PropertyHandler
Messaged from the JSplitPane the receiver is contained in.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI.PropertyChangeHandler
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic.BasicTextAreaUI
This method gets called when a bound property is changed on the associated JTextComponent.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic.BasicTextPaneUI
This method gets called when a bound property is changed on the associated JTextComponent.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic.BasicTextUI
This method gets called when a bound property is changed on the associated JTextComponent.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic.BasicToolBarUI.PropertyListener
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.PropertyChangeHandler
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.SelectionModelPropertyChangeHandler
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.metal.MetalComboBoxUI.MetalPropertyChangeListener
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxModel
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.metal.MetalRootPaneUI
Invoked when a property changes.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.metal.MetalSliderUI.MetalPropertyListener
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.metal.MetalTextFieldUI
This method gets called when a bound property is changed on the associated JTextComponent.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth.SynthButtonUI
This method gets called when a bound property is changed.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth.SynthColorChooserUI
This method gets called when a bound property is changed.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth.SynthComboBoxUI
This method gets called when a bound property is changed.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth.SynthDesktopIconUI
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth.SynthDesktopPaneUI
This method gets called when a bound property is changed.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth.SynthEditorPaneUI
This method gets called when a bound property is changed on the associated JTextComponent.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth.SynthInternalFrameUI
This method gets called when a bound property is changed.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth.SynthLabelUI
This method gets called when a bound property is changed.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth.SynthListUI
This method gets called when a bound property is changed.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth.SynthMenuBarUI
This method gets called when a bound property is changed.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth.SynthMenuItemUI
This method gets called when a bound property is changed.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth.SynthMenuUI
This method gets called when a bound property is changed.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth.SynthOptionPaneUI
This method gets called when a bound property is changed.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth.SynthPanelUI
This method gets called when a bound property is changed.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth.SynthPopupMenuUI
This method gets called when a bound property is changed.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth.SynthProgressBarUI
This method gets called when a bound property is changed.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth.SynthRootPaneUI
Invoked when a property changes on the root pane.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth.SynthScrollBarUI
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth.SynthScrollPaneUI
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth.SynthSeparatorUI
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth.SynthSliderUI
This method gets called when a bound property is changed.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth.SynthSpinnerUI
This method gets called when a bound property is changed.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth.SynthSplitPaneUI
This method gets called when a bound property is changed.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth.SynthTabbedPaneUI
This method gets called when a bound property is changed.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth.SynthTableHeaderUI
This method gets called when a bound property is changed.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth.SynthTableUI
This method gets called when a bound property is changed.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth.SynthTextAreaUI
This method gets called when a bound property is changed on the associated JTextComponent.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth.SynthTextFieldUI
This method gets called when a bound property is changed on the associated JTextComponent.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth.SynthTextPaneUI
This method gets called when a bound property is changed on the associated JTextComponent.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth.SynthToolBarUI
This method gets called when a bound property is changed.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth.SynthToolTipUI
This method gets called when a bound property is changed.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth.SynthTreeUI
This method gets called when a bound property is changed.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.plaf.synth.SynthViewportUI
This method gets called when a bound property is changed.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor
This method gets called when a bound property is changed.
propertyChange(PropertyChangeEvent) - Method in class javax.swing.table.DefaultTableColumnModel
Property Change Listener change method.
PropertyChangeEvent - Class in java.beans
A "PropertyChange" event gets delivered whenever a bean changes a "bound" or "constrained" property.
PropertyChangeEvent(Object, String, Object, Object) - Constructor for class java.beans.PropertyChangeEvent
Constructs a new PropertyChangeEvent.
PropertyChangeHandler() - Constructor for class javax.swing.plaf.basic.BasicComboBoxUI.PropertyChangeHandler
PropertyChangeHandler() - Constructor for class javax.swing.plaf.basic.BasicComboPopup.PropertyChangeHandler
PropertyChangeHandler() - Constructor for class javax.swing.plaf.basic.BasicInternalFrameTitlePane.PropertyChangeHandler
PropertyChangeHandler() - Constructor for class javax.swing.plaf.basic.BasicListUI.PropertyChangeHandler
PropertyChangeHandler() - Constructor for class javax.swing.plaf.basic.BasicOptionPaneUI.PropertyChangeHandler
PropertyChangeHandler() - Constructor for class javax.swing.plaf.basic.BasicScrollBarUI.PropertyChangeHandler
PropertyChangeHandler() - Constructor for class javax.swing.plaf.basic.BasicScrollPaneUI.PropertyChangeHandler
PropertyChangeHandler() - Constructor for class javax.swing.plaf.basic.BasicSliderUI.PropertyChangeHandler
PropertyChangeHandler() - Constructor for class javax.swing.plaf.basic.BasicTabbedPaneUI.PropertyChangeHandler
PropertyChangeHandler() - Constructor for class javax.swing.plaf.basic.BasicTreeUI.PropertyChangeHandler
PropertyChangeListener - Interface in java.beans
A "PropertyChange" event gets fired whenever a bean changes a "bound" property.
propertyChangeListener - Variable in class javax.swing.plaf.basic.BasicColorChooserUI
propertyChangeListener - Variable in class javax.swing.plaf.basic.BasicComboBoxUI
This protected field is implementation specific.
propertyChangeListener - Variable in class javax.swing.plaf.basic.BasicComboPopup
This protected field is implementation specific.
propertyChangeListener - Variable in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
propertyChangeListener - Variable in class javax.swing.plaf.basic.BasicInternalFrameUI
propertyChangeListener - Variable in class javax.swing.plaf.basic.BasicListUI
propertyChangeListener - Variable in class javax.swing.plaf.basic.BasicMenuItemUI
PropertyChangeListener returned from createPropertyChangeListener.
propertyChangeListener - Variable in class javax.swing.plaf.basic.BasicOptionPaneUI
propertyChangeListener - Variable in class javax.swing.plaf.basic.BasicScrollBarUI
propertyChangeListener - Variable in class javax.swing.plaf.basic.BasicSliderUI
propertyChangeListener - Variable in class javax.swing.plaf.basic.BasicSplitPaneUI
Instance of the PropertyChangeListener for this JSplitPane.
propertyChangeListener - Variable in class javax.swing.plaf.basic.BasicTabbedPaneUI
PropertyChangeListenerProxy - Class in java.beans
A class which extends the EventListenerProxy specifically for adding a PropertyChangeListener with a "bound" property.
PropertyChangeListenerProxy(String, PropertyChangeListener) - Constructor for class java.beans.PropertyChangeListenerProxy
Constructor which binds the PropertyChangeListener to a specific property.
PropertyChangeSupport - Class in java.beans
This is a utility class that can be used by beans that support bound properties.
PropertyChangeSupport(Object) - Constructor for class java.beans.PropertyChangeSupport
Constructs a PropertyChangeSupport object.
PropertyDescriptor - Class in java.beans
A PropertyDescriptor describes one property that a Java Bean exports via a pair of accessor methods.
PropertyDescriptor(String, Class<?>) - Constructor for class java.beans.PropertyDescriptor
Constructs a PropertyDescriptor for a property that follows the standard Java convention by having getFoo and setFoo accessor methods.
PropertyDescriptor(String, Class<?>, String, String) - Constructor for class java.beans.PropertyDescriptor
This constructor takes the name of a simple property, and method names for reading and writing the property.
PropertyDescriptor(String, Method, Method) - Constructor for class java.beans.PropertyDescriptor
This constructor takes the name of a simple property, and Method objects for reading and writing the property.
PropertyEditor - Interface in java.beans
A PropertyEditor class provides support for GUIs that want to allow users to edit a property value of a given type.
PropertyEditorManager - Class in java.beans
The PropertyEditorManager can be used to locate a property editor for any given type name.
PropertyEditorManager() - Constructor for class java.beans.PropertyEditorManager
PropertyEditorSupport - Class in java.beans
This is a support class to help build property editors.
PropertyEditorSupport() - Constructor for class java.beans.PropertyEditorSupport
Constructs a PropertyEditorSupport object.
PropertyEditorSupport(Object) - Constructor for class java.beans.PropertyEditorSupport
Constructs a PropertyEditorSupport object.
PropertyException - Exception in javax.xml.bind
This exception indicates that an error was encountered while getting or setting a property.
PropertyException(String) - Constructor for exception javax.xml.bind.PropertyException
Construct a PropertyException with the specified detail message.
PropertyException(String, String) - Constructor for exception javax.xml.bind.PropertyException
Construct a PropertyException with the specified detail message and vendor specific errorCode.
PropertyException(Throwable) - Constructor for exception javax.xml.bind.PropertyException
Construct a PropertyException with a linkedException.
PropertyException(String, Throwable) - Constructor for exception javax.xml.bind.PropertyException
Construct a PropertyException with the specified detail message and linkedException.
PropertyException(String, String, Throwable) - Constructor for exception javax.xml.bind.PropertyException
Construct a PropertyException with the specified detail message, vendor specific errorCode, and linkedException.
PropertyException(String, Object) - Constructor for exception javax.xml.bind.PropertyException
Construct a PropertyException whose message field is set based on the name of the property and value.toString().
PropertyHandler() - Constructor for class javax.swing.plaf.basic.BasicColorChooserUI.PropertyHandler
PropertyHandler() - Constructor for class javax.swing.plaf.basic.BasicSplitPaneUI.PropertyHandler
propertyKey - Static variable in class javax.swing.plaf.basic.BasicHTML
Key to use for the html renderer when stored as a client property of a JComponent.
propertyListener - Variable in class javax.swing.plaf.basic.BasicToolBarUI
PropertyListener() - Constructor for class javax.swing.plaf.basic.BasicToolBarUI.PropertyListener
PROPERTYNAME - Static variable in interface java.beans.DesignMode
The standard value of the propertyName as fired from a BeanContext or other source of PropertyChangeEvents.
propertyNames() - Method in class java.util.Properties
Returns an enumeration of all the keys in this property list, including distinct keys in the default property list if a key of the same name has not already been found from the main properties list.
PropertyPermission - Class in java.util
This class is for property permissions.
PropertyPermission(String, String) - Constructor for class java.util.PropertyPermission
Creates a new PropertyPermission object with the specified name.
PropertyResourceBundle - Class in java.util
PropertyResourceBundle is a concrete subclass of ResourceBundle that manages resources for a locale using a set of static strings from a property file.
PropertyResourceBundle(InputStream) - Constructor for class java.util.PropertyResourceBundle
Creates a property resource bundle from an InputStream.
PropertyResourceBundle(Reader) - Constructor for class java.util.PropertyResourceBundle
Creates a property resource bundle from a Reader.
PropertyVetoException - Exception in java.beans
A PropertyVetoException is thrown when a proposed change to a property represents an unacceptable value.
PropertyVetoException(String, PropertyChangeEvent) - Constructor for exception java.beans.PropertyVetoException
Constructs a PropertyVetoException with a detailed message.
PROTECTED - Static variable in class java.lang.invoke.MethodHandles.Lookup
A single-bit mask representing protected access, which may contribute to the result of lookupModes.
PROTECTED - Static variable in class java.lang.reflect.Modifier
The int value representing the protected modifier.
ProtectionDomain - Class in java.security
This ProtectionDomain class encapsulates the characteristics of a domain, which encloses a set of classes whose instances are granted a set of permissions when being executed on behalf of a given set of Principals.
ProtectionDomain(CodeSource, PermissionCollection) - Constructor for class java.security.ProtectionDomain
Creates a new ProtectionDomain with the given CodeSource and Permissions.
ProtectionDomain(CodeSource, PermissionCollection, ClassLoader, Principal[]) - Constructor for class java.security.ProtectionDomain
Creates a new ProtectionDomain qualified by the given CodeSource, Permissions, ClassLoader and array of Principals.
PROTOCOL_PROVIDER_CLASS_LOADER - Static variable in class javax.management.remote.JMXConnectorFactory
Name of the attribute that specifies the class loader for loading protocol providers.
PROTOCOL_PROVIDER_CLASS_LOADER - Static variable in class javax.management.remote.JMXConnectorServerFactory
Name of the attribute that specifies the class loader for loading protocol providers.
PROTOCOL_PROVIDER_PACKAGES - Static variable in class javax.management.remote.JMXConnectorFactory
Name of the attribute that specifies the provider packages that are consulted when looking for the handler for a protocol.
PROTOCOL_PROVIDER_PACKAGES - Static variable in class javax.management.remote.JMXConnectorServerFactory
Name of the attribute that specifies the provider packages that are consulted when looking for the handler for a protocol.
PROTOCOL_VERSION_1 - Static variable in interface java.io.ObjectStreamConstants
A Stream Protocol Version.
PROTOCOL_VERSION_2 - Static variable in interface java.io.ObjectStreamConstants
A Stream Protocol Version.
ProtocolException - Exception in java.net
Thrown to indicate that there is an error in the underlying protocol, such as a TCP error.
ProtocolException(String) - Constructor for exception java.net.ProtocolException
Constructs a new ProtocolException with the specified detail message.
ProtocolException() - Constructor for exception java.net.ProtocolException
Constructs a new ProtocolException with no detail message.
ProtocolException - Exception in javax.xml.ws
The ProtocolException class is a base class for exceptions related to a specific protocol binding.
ProtocolException() - Constructor for exception javax.xml.ws.ProtocolException
Constructs a new protocol exception with null as its detail message.
ProtocolException(String) - Constructor for exception javax.xml.ws.ProtocolException
Constructs a new protocol exception with the specified detail message.
ProtocolException(String, Throwable) - Constructor for exception javax.xml.ws.ProtocolException
Constructs a new runtime exception with the specified detail message and cause.
ProtocolException(Throwable) - Constructor for exception javax.xml.ws.ProtocolException
Constructs a new runtime exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
ProtocolFamily - Interface in java.net
Represents a family of communication protocols.
prototypeCellValueChanged - Static variable in class javax.swing.plaf.basic.BasicListUI
provideErrorFeedback(Component) - Method in class javax.swing.LookAndFeel
Invoked when the user attempts an invalid operation, such as pasting into an uneditable JTextField that has focus.
provideErrorFeedback(Component) - Method in class javax.swing.plaf.metal.MetalLookAndFeel
Invoked when the user attempts an invalid operation, such as pasting into an uneditable JTextField that has focus.
provider() - Method in class java.nio.channels.AsynchronousChannelGroup
Returns the provider that created this channel group.
provider() - Method in class java.nio.channels.AsynchronousServerSocketChannel
Returns the provider that created this channel.
provider() - Method in class java.nio.channels.AsynchronousSocketChannel
Returns the provider that created this channel.
provider() - Method in class java.nio.channels.SelectableChannel
Returns the provider that created this channel.
provider() - Method in class java.nio.channels.Selector
Returns the provider that created this channel.
provider() - Method in class java.nio.channels.spi.AbstractSelectableChannel
Returns the provider that created this channel.
provider() - Method in class java.nio.channels.spi.AbstractSelector
Returns the provider that created this channel.
provider() - Static method in class java.nio.channels.spi.AsynchronousChannelProvider
Returns the system-wide default asynchronous channel provider for this invocation of the Java virtual machine.
provider() - Static method in class java.nio.channels.spi.SelectorProvider
Returns the system-wide default selector provider for this invocation of the Java virtual machine.
provider() - Method in class java.nio.file.FileSystem
Returns the provider that created this file system.
Provider - Class in java.security
This class represents a "provider" for the Java Security API, where a provider implements some or all parts of Java Security.
Provider(String, double, String) - Constructor for class java.security.Provider
Constructs a provider with the specified name, version number, and information.
Provider<T> - Interface in javax.xml.ws
Service endpoints may implement the Provider interface as a dynamic alternative to an SEI.
Provider - Class in javax.xml.ws.spi
Service provider for ServiceDelegate and Endpoint objects.
Provider() - Constructor for class javax.xml.ws.spi.Provider
Creates a new instance of Provider
provider() - Static method in class javax.xml.ws.spi.Provider
Creates a new provider object.
Provider.Service - Class in java.security
The description of a security service.
PROVIDER_URL - Static variable in interface javax.naming.Context
Constant that holds the name of the environment property for specifying configuration information for the service provider to use.
provideRefresh() - Method in class java.time.zone.ZoneRulesProvider
SPI method to refresh the rules from the underlying data provider.
ProviderException - Exception in java.security
A runtime exception for Provider exceptions (such as misconfiguration errors or unrecoverable internal errors), which may be subclassed by Providers to throw specialized, provider-specific runtime errors.
ProviderException() - Constructor for exception java.security.ProviderException
Constructs a ProviderException with no detail message.
ProviderException(String) - Constructor for exception java.security.ProviderException
Constructs a ProviderException with the specified detail message.
ProviderException(String, Throwable) - Constructor for exception java.security.ProviderException
Creates a ProviderException with the specified detail message and cause.
ProviderException(Throwable) - Constructor for exception java.security.ProviderException
Creates a ProviderException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
ProviderMismatchException - Exception in java.nio.file
Unchecked exception thrown when an attempt is made to invoke a method on an object created by one file system provider with a parameter created by a different file system provider.
ProviderMismatchException() - Constructor for exception java.nio.file.ProviderMismatchException
Constructs an instance of this class.
ProviderMismatchException(String) - Constructor for exception java.nio.file.ProviderMismatchException
Constructs an instance of this class.
ProviderNotFoundException - Exception in java.nio.file
Runtime exception thrown when a provider of the required type cannot be found.
ProviderNotFoundException() - Constructor for exception java.nio.file.ProviderNotFoundException
Constructs an instance of this class.
ProviderNotFoundException(String) - Constructor for exception java.nio.file.ProviderNotFoundException
Constructs an instance of this class.
provideRules(String, boolean) - Method in class java.time.zone.ZoneRulesProvider
SPI method to get the rules for the zone ID.
provideVersions(String) - Method in class java.time.zone.ZoneRulesProvider
SPI method to get the history of rules for the zone ID.
provideZoneIds() - Method in class java.time.zone.ZoneRulesProvider
SPI method to get the available zone IDs.
proxy - Variable in class java.beans.beancontext.BeanContextServicesSupport
Delegate for the BeanContextServiceProvider.
Proxy - Class in java.lang.reflect
Proxy provides static methods for creating dynamic proxy classes and instances, and it is also the superclass of all dynamic proxy classes created by those methods.
Proxy(InvocationHandler) - Constructor for class java.lang.reflect.Proxy
Constructs a new Proxy instance from a subclass (typically, a dynamic proxy class) with the specified value for its invocation handler.
Proxy - Class in java.net
This class represents a proxy setting, typically a type (http, socks) and a socket address.
Proxy(Proxy.Type, SocketAddress) - Constructor for class java.net.Proxy
Creates an entry representing a PROXY connection.
Proxy.Type - Enum in java.net
Represents the proxy type.
ProxyLazyValue(String) - Constructor for class javax.swing.UIDefaults.ProxyLazyValue
Creates a LazyValue which will construct an instance when asked.
ProxyLazyValue(String, String) - Constructor for class javax.swing.UIDefaults.ProxyLazyValue
Creates a LazyValue which will construct an instance when asked.
ProxyLazyValue(String, Object[]) - Constructor for class javax.swing.UIDefaults.ProxyLazyValue
Creates a LazyValue which will construct an instance when asked.
ProxyLazyValue(String, String, Object[]) - Constructor for class javax.swing.UIDefaults.ProxyLazyValue
Creates a LazyValue which will construct an instance when asked.
ProxySelector - Class in java.net
Selects the proxy server to use, if any, when connecting to the network resource referenced by a URL.
ProxySelector() - Constructor for class java.net.ProxySelector
PseudoColumnUsage - Enum in java.sql
Enumeration for pseudo/hidden column usage.
PSource - Class in javax.crypto.spec
This class specifies the source for encoding input P in OAEP Padding, as defined in the PKCS #1 standard.
PSource(String) - Constructor for class javax.crypto.spec.PSource
Constructs a source of the encoding input P for OAEP padding as defined in the PKCS #1 standard using the specified PSource algorithm.
PSource.PSpecified - Class in javax.crypto.spec
This class is used to explicitly specify the value for encoding input P in OAEP Padding.
PSpecified(byte[]) - Constructor for class javax.crypto.spec.PSource.PSpecified
Constructs the source explicitly with the specified value p as the encoding input P.
PSSParameterSpec - Class in java.security.spec
This class specifies a parameter spec for RSA-PSS signature scheme, as defined in the PKCS#1 v2.1 standard.
PSSParameterSpec(String, String, AlgorithmParameterSpec, int, int) - Constructor for class java.security.spec.PSSParameterSpec
Creates a new PSSParameterSpec as defined in the PKCS #1 standard using the specified message digest, mask generation function, parameters for mask generation function, salt length, and trailer field values.
PSSParameterSpec(int) - Constructor for class java.security.spec.PSSParameterSpec
Creates a new PSSParameterSpec using the specified salt length and other default values as defined in PKCS#1.
ptLineDist(double, double, double, double, double, double) - Static method in class java.awt.geom.Line2D
Returns the distance from a point to a line.
ptLineDist(double, double) - Method in class java.awt.geom.Line2D
Returns the distance from a point to this line.
ptLineDist(Point2D) - Method in class java.awt.geom.Line2D
Returns the distance from a Point2D to this line.
ptLineDistSq(double, double, double, double, double, double) - Static method in class java.awt.geom.Line2D
Returns the square of the distance from a point to a line.
ptLineDistSq(double, double) - Method in class java.awt.geom.Line2D
Returns the square of the distance from a point to this line.
ptLineDistSq(Point2D) - Method in class java.awt.geom.Line2D
Returns the square of the distance from a specified Point2D to this line.
ptSegDist(double, double, double, double, double, double) - Static method in class java.awt.geom.Line2D
Returns the distance from a point to a line segment.
ptSegDist(double, double) - Method in class java.awt.geom.Line2D
Returns the distance from a point to this line segment.
ptSegDist(Point2D) - Method in class java.awt.geom.Line2D
Returns the distance from a Point2D to this line segment.
ptSegDistSq(double, double, double, double, double, double) - Static method in class java.awt.geom.Line2D
Returns the square of the distance from a point to a line segment.
ptSegDistSq(double, double) - Method in class java.awt.geom.Line2D
Returns the square of the distance from a point to this line segment.
ptSegDistSq(Point2D) - Method in class java.awt.geom.Line2D
Returns the square of the distance from a Point2D to this line segment.
PUBLIC - Static variable in class java.lang.invoke.MethodHandles.Lookup
A single-bit mask representing public access, which may contribute to the result of lookupModes.
PUBLIC - Static variable in interface java.lang.reflect.Member
Identifies the set of all public members of a class or interface, including inherited members.
PUBLIC - Static variable in class java.lang.reflect.Modifier
The int value representing the public modifier.
PUBLIC - Static variable in interface javax.swing.text.html.parser.DTDConstants
PUBLIC_KEY - Static variable in class javax.crypto.Cipher
Constant used to indicate the to-be-unwrapped key is a "public key".
PUBLIC_MEMBER - Interface in org.omg.CORBA
Constant to define a public member in the ValueMember class.
PUBLIC_XML_SCHEMA - Static variable in interface javax.sql.rowset.WebRowSet
The public identifier for the XML Schema definition that defines the XML tags and their valid values for a WebRowSet implementation.
PublicKey - Interface in java.security
A public key.
publicLookup() - Static method in class java.lang.invoke.MethodHandles
Returns a lookup object which is trusted minimally.
publish(LogRecord) - Method in class java.util.logging.ConsoleHandler
Publish a LogRecord.
publish(LogRecord) - Method in class java.util.logging.FileHandler
Format and publish a LogRecord.
publish(LogRecord) - Method in class java.util.logging.Handler
Publish a LogRecord.
publish(LogRecord) - Method in class java.util.logging.MemoryHandler
Store a LogRecord in an internal buffer.
publish(LogRecord) - Method in class java.util.logging.SocketHandler
Format and publish a LogRecord.
publish(LogRecord) - Method in class java.util.logging.StreamHandler
Format and publish a LogRecord.
publish(V...) - Method in class javax.swing.SwingWorker
Sends data chunks to the SwingWorker.process(java.util.List<V>) method.
publish(String) - Method in class javax.xml.ws.Endpoint
Publishes this endpoint at the given address.
publish(String, Object) - Static method in class javax.xml.ws.Endpoint
Creates and publishes an endpoint for the specified implementor object at the given address.
publish(String, Object, WebServiceFeature...) - Static method in class javax.xml.ws.Endpoint
Creates and publishes an endpoint for the specified implementor object at the given address.
publish(Object) - Method in class javax.xml.ws.Endpoint
Publishes this endpoint at the provided server context.
publish(HttpContext) - Method in class javax.xml.ws.Endpoint
Publishes this endpoint at the provided server context.
purge() - Method in class java.util.concurrent.ThreadPoolExecutor
Tries to remove from the work queue all Future tasks that have been cancelled.
purge() - Method in class java.util.Timer
Removes all cancelled tasks from this timer's task queue.
purgeRelations() - Method in class javax.management.relation.RelationService
Purges the relations.
purgeRelations() - Method in interface javax.management.relation.RelationServiceMBean
Purges the relations.
push(EventQueue) - Method in class java.awt.EventQueue
Replaces the existing EventQueue with the specified one.
push(E) - Method in class java.util.ArrayDeque
Pushes an element onto the stack represented by this deque.
push(E) - Method in interface java.util.concurrent.BlockingDeque
Pushes an element onto the stack represented by this deque (in other words, at the head of this deque) if it is possible to do so immediately without violating capacity restrictions, throwing an IllegalStateException if no space is currently available.
push(E) - Method in class java.util.concurrent.ConcurrentLinkedDeque
push(E) - Method in class java.util.concurrent.LinkedBlockingDeque
push(E) - Method in interface java.util.Deque
Pushes an element onto the stack represented by this deque (in other words, at the head of this deque) if it is possible to do so immediately without violating capacity restrictions, throwing an IllegalStateException if no space is currently available.
push(E) - Method in class java.util.LinkedList
Pushes an element onto the stack represented by this list.
push() - Method in class java.util.logging.MemoryHandler
Push any buffered output to the target Handler.
push(E) - Method in class java.util.Stack
Pushes an item onto the top of this stack.
PUSH_BUTTON - Static variable in class javax.accessibility.AccessibleRole
An object the user can manipulate to tell the application to do something.
pushBack() - Method in class java.io.StreamTokenizer
Causes the next call to the nextToken method of this tokenizer to return the current value in the ttype field, and not to modify the value in the nval or sval field.
PushbackInputStream - Class in java.io
A PushbackInputStream adds functionality to another input stream, namely the ability to "push back" or "unread" one byte.
PushbackInputStream(InputStream, int) - Constructor for class java.io.PushbackInputStream
Creates a PushbackInputStream with a pushback buffer of the specified size, and saves its argument, the input stream in, for later use.
PushbackInputStream(InputStream) - Constructor for class java.io.PushbackInputStream
Creates a PushbackInputStream and saves its argument, the input stream in, for later use.
PushbackReader - Class in java.io
A character-stream reader that allows characters to be pushed back into the stream.
PushbackReader(Reader, int) - Constructor for class java.io.PushbackReader
Creates a new pushback reader with a pushback buffer of the given size.
PushbackReader(Reader) - Constructor for class java.io.PushbackReader
Creates a new pushback reader with a one-character pushback buffer.
pushCharacterStyle() - Method in class javax.swing.text.html.HTMLDocument.HTMLReader
Pushes the current character style on a stack in preparation for forming a new nested character style.
pushContext() - Method in class org.xml.sax.helpers.NamespaceSupport
Start a new Namespace context.
put(Object, Object) - Method in class java.awt.RenderingHints
Maps the specified key to the specified value in this RenderingHints object.
put(String, boolean) - Method in class java.io.ObjectOutputStream.PutField
Put the value of the named boolean field into the persistent field.
put(String, byte) - Method in class java.io.ObjectOutputStream.PutField
Put the value of the named byte field into the persistent field.
put(String, char) - Method in class java.io.ObjectOutputStream.PutField
Put the value of the named char field into the persistent field.
put(String, short) - Method in class java.io.ObjectOutputStream.PutField
Put the value of the named short field into the persistent field.
put(String, int) - Method in class java.io.ObjectOutputStream.PutField
Put the value of the named int field into the persistent field.
put(String, long) - Method in class java.io.ObjectOutputStream.PutField
Put the value of the named long field into the persistent field.
put(String, float) - Method in class java.io.ObjectOutputStream.PutField
Put the value of the named float field into the persistent field.
put(String, double) - Method in class java.io.ObjectOutputStream.PutField
Put the value of the named double field into the persistent field.
put(String, Object) - Method in class java.io.ObjectOutputStream.PutField
Put the value of the named Object field into the persistent field.
put(URI, Map<String, List<String>>) - Method in class java.net.CookieHandler
Sets all the applicable cookies, examples are response header fields that are named Set-Cookie2, present in the response headers into a cookie cache.
put(URI, Map<String, List<String>>) - Method in class java.net.CookieManager
put(URI, URLConnection) - Method in class java.net.ResponseCache
The protocol handler calls this method after a resource has been retrieved, and the ResponseCache must decide whether or not to store the resource in its cache.
put(byte) - Method in class java.nio.ByteBuffer
Relative put method (optional operation).
put(int, byte) - Method in class java.nio.ByteBuffer
Absolute put method (optional operation).
put(ByteBuffer) - Method in class java.nio.ByteBuffer
Relative bulk put method (optional operation).
put(byte[], int, int) - Method in class java.nio.ByteBuffer
Relative bulk put method (optional operation).
put(byte[]) - Method in class java.nio.ByteBuffer
Relative bulk put method (optional operation).
put(char) - Method in class java.nio.CharBuffer
Relative put method (optional operation).
put(int, char) - Method in class java.nio.CharBuffer
Absolute put method (optional operation).
put(CharBuffer) - Method in class java.nio.CharBuffer
Relative bulk put method (optional operation).
put(char[], int, int) - Method in class java.nio.CharBuffer
Relative bulk put method (optional operation).
put(char[]) - Method in class java.nio.CharBuffer
Relative bulk put method (optional operation).
put(String, int, int) - Method in class java.nio.CharBuffer
Relative bulk put method (optional operation).
put(String) - Method in class java.nio.CharBuffer
Relative bulk put method (optional operation).
put(double) - Method in class java.nio.DoubleBuffer
Relative put method (optional operation).
put(int, double) - Method in class java.nio.DoubleBuffer
Absolute put method (optional operation).
put(DoubleBuffer) - Method in class java.nio.DoubleBuffer
Relative bulk put method (optional operation).
put(double[], int, int) - Method in class java.nio.DoubleBuffer
Relative bulk put method (optional operation).
put(double[]) - Method in class java.nio.DoubleBuffer
Relative bulk put method (optional operation).
put(float) - Method in class java.nio.FloatBuffer
Relative put method (optional operation).
put(int, float) - Method in class java.nio.FloatBuffer
Absolute put method (optional operation).
put(FloatBuffer) - Method in class java.nio.FloatBuffer
Relative bulk put method (optional operation).
put(float[], int, int) - Method in class java.nio.FloatBuffer
Relative bulk put method (optional operation).
put(float[]) - Method in class java.nio.FloatBuffer
Relative bulk put method (optional operation).
put(int) - Method in class java.nio.IntBuffer
Relative put method (optional operation).
put(int, int) - Method in class java.nio.IntBuffer
Absolute put method (optional operation).
put(IntBuffer) - Method in class java.nio.IntBuffer
Relative bulk put method (optional operation).
put(int[], int, int) - Method in class java.nio.IntBuffer
Relative bulk put method (optional operation).
put(int[]) - Method in class java.nio.IntBuffer
Relative bulk put method (optional operation).
put(long) - Method in class java.nio.LongBuffer
Relative put method (optional operation).
put(int, long) - Method in class java.nio.LongBuffer
Absolute put method (optional operation).
put(LongBuffer) - Method in class java.nio.LongBuffer
Relative bulk put method (optional operation).
put(long[], int, int) - Method in class java.nio.LongBuffer
Relative bulk put method (optional operation).
put(long[]) - Method in class java.nio.LongBuffer
Relative bulk put method (optional operation).
put(short) - Method in class java.nio.ShortBuffer
Relative put method (optional operation).
put(int, short) - Method in class java.nio.ShortBuffer
Absolute put method (optional operation).
put(ShortBuffer) - Method in class java.nio.ShortBuffer
Relative bulk put method (optional operation).
put(short[], int, int) - Method in class java.nio.ShortBuffer
Relative bulk put method (optional operation).
put(short[]) - Method in class java.nio.ShortBuffer
Relative bulk put method (optional operation).
put(Object, Object) - Method in class java.security.Provider
Sets the key property to have the specified value.
put(K, V) - Method in class java.util.AbstractMap
Associates the specified value with the specified key in this map (optional operation).
put(E) - Method in class java.util.concurrent.ArrayBlockingQueue
Inserts the specified element at the tail of this queue, waiting for space to become available if the queue is full.
put(E) - Method in interface java.util.concurrent.BlockingDeque
Inserts the specified element into the queue represented by this deque (in other words, at the tail of this deque), waiting if necessary for space to become available.
put(E) - Method in interface java.util.concurrent.BlockingQueue
Inserts the specified element into this queue, waiting if necessary for space to become available.
put(K, V) - Method in class java.util.concurrent.ConcurrentHashMap
Maps the specified key to the specified value in this table.
put(K, V) - Method in class java.util.concurrent.ConcurrentSkipListMap
Associates the specified value with the specified key in this map.
put(E) - Method in class java.util.concurrent.DelayQueue
Inserts the specified element into this delay queue.
put(E) - Method in class java.util.concurrent.LinkedBlockingDeque
put(E) - Method in class java.util.concurrent.LinkedBlockingQueue
Inserts the specified element at the tail of this queue, waiting if necessary for space to become available.
put(E) - Method in class java.util.concurrent.LinkedTransferQueue
Inserts the specified element at the tail of this queue.
put(E) - Method in class java.util.concurrent.PriorityBlockingQueue
Inserts the specified element into this priority queue.
put(E) - Method in class java.util.concurrent.SynchronousQueue
Adds the specified element to this queue, waiting if necessary for another thread to receive it.
put(K, V) - Method in class java.util.Dictionary
Maps the specified key to the specified value in this dictionary.
put(K, V) - Method in class java.util.EnumMap
Associates the specified value with the specified key in this map.
put(K, V) - Method in class java.util.HashMap
Associates the specified value with the specified key in this map.
put(K, V) - Method in class java.util.Hashtable
Maps the specified key to the specified value in this hashtable.
put(K, V) - Method in class java.util.IdentityHashMap
Associates the specified value with the specified key in this identity hash map.
put(Object, Object) - Method in class java.util.jar.Attributes
Associates the specified value with the specified attribute name (key) in this Map.
put(K, V) - Method in interface java.util.Map
Associates the specified value with the specified key in this map (optional operation).
put(String, String) - Method in class java.util.prefs.AbstractPreferences
Implements the put method as per the specification in Preferences.put(String,String).
put(String, String) - Method in class java.util.prefs.Preferences
Associates the specified value with the specified key in this preference node.
put(K, V) - Method in class java.util.TreeMap
Associates the specified value with the specified key in this map.
put(K, V) - Method in class java.util.WeakHashMap
Associates the specified value with the specified key in this map.
put(CompositeData) - Method in interface javax.management.openmbean.TabularData
Adds value to this TabularData instance.
put(Object, Object) - Method in class javax.management.openmbean.TabularDataSupport
This method simply calls put((CompositeData) value) and therefore ignores its key parameter which can be null.
put(CompositeData) - Method in class javax.management.openmbean.TabularDataSupport
put(String, Object) - Method in interface javax.naming.directory.Attributes
Adds a new attribute to the attribute set.
put(Attribute) - Method in interface javax.naming.directory.Attributes
Adds a new attribute to the attribute set.
put(String, Object) - Method in class javax.naming.directory.BasicAttributes
put(Attribute) - Method in class javax.naming.directory.BasicAttributes
put(PrinterStateReason, Severity) - Method in class javax.print.attribute.standard.PrinterStateReasons
Adds the given printer state reason to this printer state reasons attribute, associating it with the given severity level.
put(String, Object) - Method in class javax.script.AbstractScriptEngine
Sets the specified value with the specified key in the ENGINE_SCOPE Bindings of the protected context field.
put(String, Object) - Method in interface javax.script.Bindings
Set a named value.
put(String, Object) - Method in interface javax.script.ScriptEngine
Sets a key/value pair in the state of the ScriptEngine that may either create a Java Language Binding to be used in the execution of scripts or be used in some other way, depending on whether the key is reserved.
put(String, Object) - Method in class javax.script.ScriptEngineManager
Sets the specified key/value pair in the Global Scope.
put(String, Object) - Method in class javax.script.SimpleBindings
Sets the specified key/value in the underlying map field.
put(Object, Action) - Method in class javax.swing.ActionMap
Adds a binding for key to action.
put(KeyStroke, Object) - Method in class javax.swing.ComponentInputMap
Adds a binding for keyStroke to actionMapKey.
put(KeyStroke, Object) - Method in class javax.swing.InputMap
Adds a binding for keyStroke to actionMapKey.
put(Object, Object) - Method in class javax.swing.UIDefaults
Sets the value of key to value for all locales.
put(Object, Object) - Static method in class javax.swing.UIManager
Stores an object in the developer defaults.
put(Object, Object) - Method in class javax.xml.crypto.dom.DOMCryptoContext
This implementation uses an internal HashMap to map the key to the specified object.
put(Object, Object) - Method in interface javax.xml.crypto.XMLCryptoContext
Associates the specified value with the specified key in this context.
putAll(Map<?, ?>) - Method in class java.awt.RenderingHints
Copies all of the mappings from the specified Map to this RenderingHints.
putAll(Map<?, ?>) - Method in class java.security.Provider
Copies all of the mappings from the specified Map to this provider.
putAll(Map<? extends K, ? extends V>) - Method in class java.util.AbstractMap
Copies all of the mappings from the specified map to this map (optional operation).
putAll(Map<? extends K, ? extends V>) - Method in class java.util.concurrent.ConcurrentHashMap
Copies all of the mappings from the specified map to this one.
putAll(Map<? extends K, ? extends V>) - Method in class java.util.EnumMap
Copies all of the mappings from the specified map to this map.
putAll(Map<? extends K, ? extends V>) - Method in class java.util.HashMap
Copies all of the mappings from the specified map to this map.
putAll(Map<? extends K, ? extends V>) - Method in class java.util.Hashtable
Copies all of the mappings from the specified map to this hashtable.
putAll(Map<? extends K, ? extends V>) - Method in class java.util.IdentityHashMap
Copies all of the mappings from the specified map to this map.
putAll(Map<?, ?>) - Method in class java.util.jar.Attributes
Copies all of the attribute name-value mappings from the specified Attributes to this Map.
putAll(Map<? extends K, ? extends V>) - Method in interface java.util.Map
Copies all of the mappings from the specified map to this map (optional operation).
putAll(Map<? extends K, ? extends V>) - Method in class java.util.TreeMap
Copies all of the mappings from the specified map to this map.
putAll(Map<? extends K, ? extends V>) - Method in class java.util.WeakHashMap
Copies all of the mappings from the specified map to this map.
putAll(CompositeData[]) - Method in interface javax.management.openmbean.TabularData
Add all the elements in values to this TabularData instance.
putAll(Map<?, ?>) - Method in class javax.management.openmbean.TabularDataSupport
Add all the values contained in the specified map t to this TabularData instance.
putAll(CompositeData[]) - Method in class javax.management.openmbean.TabularDataSupport
Add all the elements in values to this TabularData instance.
putAll(Map<? extends String, ? extends Object>) - Method in interface javax.script.Bindings
Adds all the mappings in a given Map to this Bindings.
putAll(Map<? extends String, ? extends Object>) - Method in class javax.script.SimpleBindings
putAll is implemented using Map.putAll.
putBoolean(String, boolean) - Method in class java.util.prefs.AbstractPreferences
Implements the putBoolean method as per the specification in Preferences.putBoolean(String,boolean).
putBoolean(String, boolean) - Method in class java.util.prefs.Preferences
Associates a string representing the specified boolean value with the specified key in this preference node.
putByteArray(String, byte[]) - Method in class java.util.prefs.AbstractPreferences
Implements the putByteArray method as per the specification in Preferences.putByteArray(String,byte[]).
putByteArray(String, byte[]) - Method in class java.util.prefs.Preferences
Associates a string representing the specified byte array with the specified key in this preference node.
putChar(char) - Method in class java.nio.ByteBuffer
Relative put method for writing a char value (optional operation).
putChar(int, char) - Method in class java.nio.ByteBuffer
Absolute put method for writing a char value (optional operation).
putClientProperty(Object, Object) - Method in class javax.swing.JComponent
Adds an arbitrary key/value "client property" to this component.
putConstraint(String, Component, int, String, Component) - Method in class javax.swing.SpringLayout
Links edge e1 of component c1 to edge e2 of component c2, with a fixed distance between the edges.
putConstraint(String, Component, Spring, String, Component) - Method in class javax.swing.SpringLayout
Links edge e1 of component c1 to edge e2 of component c2.
putDefaults(Object[]) - Method in class javax.swing.UIDefaults
Puts all of the key/value pairs in the database and unconditionally generates one PropertyChangeEvent.
putDouble(double) - Method in class java.nio.ByteBuffer
Relative put method for writing a double value (optional operation).
putDouble(int, double) - Method in class java.nio.ByteBuffer
Absolute put method for writing a double value (optional operation).
putDouble(String, double) - Method in class java.util.prefs.AbstractPreferences
Implements the putDouble method as per the specification in Preferences.putDouble(String,double).
putDouble(String, double) - Method in class java.util.prefs.Preferences
Associates a string representing the specified double value with the specified key in this preference node.
putDTDHash(String, DTD) - Static method in class javax.swing.text.html.parser.DTD
PutField() - Constructor for class java.io.ObjectOutputStream.PutField
putFields() - Method in class java.io.ObjectOutputStream
Retrieve the object used to buffer persistent fields to be written to the stream.
putFirst(E) - Method in interface java.util.concurrent.BlockingDeque
Inserts the specified element at the front of this deque, waiting if necessary for space to become available.
putFirst(E) - Method in class java.util.concurrent.LinkedBlockingDeque
putFloat(float) - Method in class java.nio.ByteBuffer
Relative put method for writing a float value (optional operation).
putFloat(int, float) - Method in class java.nio.ByteBuffer
Absolute put method for writing a float value (optional operation).
putFloat(String, float) - Method in class java.util.prefs.AbstractPreferences
Implements the putFloat method as per the specification in Preferences.putFloat(String,float).
putFloat(String, float) - Method in class java.util.prefs.Preferences
Associates a string representing the specified float value with the specified key in this preference node.
putIfAbsent(Object, Object) - Method in class java.security.Provider
If the specified key is not already associated with a value (or is mapped to null) associates it with the given value and returns null, else returns the current value.
putIfAbsent(K, V) - Method in class java.util.concurrent.ConcurrentHashMap
If the specified key is not already associated with a value, associate it with the given value.
putIfAbsent(K, V) - Method in interface java.util.concurrent.ConcurrentMap
If the specified key is not already associated with a value, associate it with the given value.
putIfAbsent(K, V) - Method in class java.util.concurrent.ConcurrentSkipListMap
If the specified key is not already associated with a value, associate it with the given value.
putIfAbsent(K, V) - Method in class java.util.HashMap
putIfAbsent(K, V) - Method in class java.util.Hashtable
putIfAbsent(K, V) - Method in interface java.util.Map
If the specified key is not already associated with a value (or is mapped to null) associates it with the given value and returns null, else returns the current value.
putInt(int) - Method in class java.nio.ByteBuffer
Relative put method for writing an int value (optional operation).
putInt(int, int) - Method in class java.nio.ByteBuffer
Absolute put method for writing an int value (optional operation).
putInt(String, int) - Method in class java.util.prefs.AbstractPreferences
Implements the putInt method as per the specification in Preferences.putInt(String,int).
putInt(String, int) - Method in class java.util.prefs.Preferences
Associates a string representing the specified int value with the specified key in this preference node.
putLast(E) - Method in interface java.util.concurrent.BlockingDeque
Inserts the specified element at the end of this deque, waiting if necessary for space to become available.
putLast(E) - Method in class java.util.concurrent.LinkedBlockingDeque
putLayer(JComponent, int) - Static method in class javax.swing.JLayeredPane
Sets the layer property on a JComponent.
putLong(long) - Method in class java.nio.ByteBuffer
Relative put method for writing a long value (optional operation).
putLong(int, long) - Method in class java.nio.ByteBuffer
Absolute put method for writing a long value (optional operation).
putLong(String, long) - Method in class java.util.prefs.AbstractPreferences
Implements the putLong method as per the specification in Preferences.putLong(String,long).
putLong(String, long) - Method in class java.util.prefs.Preferences
Associates a string representing the specified long value with the specified key in this preference node.
putNamespacePrefix(String, String) - Method in class javax.xml.crypto.dom.DOMCryptoContext
This implementation uses an internal HashMap to map the URI to the specified prefix.
putNamespacePrefix(String, String) - Method in interface javax.xml.crypto.XMLCryptoContext
Maps the specified namespace URI to the specified prefix.
putNextEntry(ZipEntry) - Method in class java.util.jar.JarOutputStream
Begins writing a new JAR file entry and positions the stream to the start of the entry data.
putNextEntry(ZipEntry) - Method in class java.util.zip.ZipOutputStream
Begins writing a new ZIP file entry and positions the stream to the start of the entry data.
putProperty(Object, Object) - Method in class javax.swing.text.AbstractDocument
A convenience method for storing up a property value.
putProperty(Object, Object) - Method in interface javax.swing.text.Document
Associates a property with the document.
putService(Provider.Service) - Method in class java.security.Provider
Add a service.
putShort(short) - Method in class java.nio.ByteBuffer
Relative put method for writing a short value (optional operation).
putShort(int, short) - Method in class java.nio.ByteBuffer
Absolute put method for writing a short value (optional operation).
putSpi(String, String) - Method in class java.util.prefs.AbstractPreferences
Put the given key-value association into this preference node.
putValue(String, String) - Method in class java.util.jar.Attributes
Associates the specified value with the specified attribute name, specified as a String.
putValue(String, Object) - Method in interface javax.net.ssl.SSLSession
Binds the specified value object into the session's application layer data with the given name.
putValue(String, Object) - Method in class javax.swing.AbstractAction
Sets the Value associated with the specified key.
putValue(String, Object) - Method in interface javax.swing.Action
Sets one of this object's properties using the associated key.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames


Q-Index (Java Platform SE 8 )

Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames
  • All Classes
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

Q

QName - Class in javax.xml.namespace
QName represents a qualified name as defined in the XML specifications: XML Schema Part2: Datatypes specification, Namespaces in XML, Namespaces in XML Errata.
QName(String, String) - Constructor for class javax.xml.namespace.QName
QName constructor specifying the Namespace URI and local part.
QName(String, String, String) - Constructor for class javax.xml.namespace.QName
QName constructor specifying the Namespace URI, local part and prefix.
QName(String) - Constructor for class javax.xml.namespace.QName
QName constructor specifying the local part.
QOP - Static variable in class javax.security.sasl.Sasl
The name of a property that specifies the quality-of-protection to use.
QuadCurve2D - Class in java.awt.geom
The QuadCurve2D class defines a quadratic parametric curve segment in (x,y) coordinate space.
QuadCurve2D() - Constructor for class java.awt.geom.QuadCurve2D
This is an abstract class that cannot be instantiated directly.
QuadCurve2D.Double - Class in java.awt.geom
A quadratic parametric curve segment specified with double coordinates.
QuadCurve2D.Float - Class in java.awt.geom
A quadratic parametric curve segment specified with float coordinates.
quadrantRotate(int) - Method in class java.awt.geom.AffineTransform
Concatenates this transform with a transform that rotates coordinates by the specified number of quadrants.
quadrantRotate(int, double, double) - Method in class java.awt.geom.AffineTransform
Concatenates this transform with a transform that rotates coordinates by the specified number of quadrants around the specified anchor point.
quadTo(double, double, double, double) - Method in class java.awt.geom.Path2D.Double
Adds a curved segment, defined by two new points, to the path by drawing a Quadratic curve that intersects both the current coordinates and the specified coordinates (x2,y2), using the specified point (x1,y1) as a quadratic parametric control point.
quadTo(double, double, double, double) - Method in class java.awt.geom.Path2D.Float
Adds a curved segment, defined by two new points, to the path by drawing a Quadratic curve that intersects both the current coordinates and the specified coordinates (x2,y2), using the specified point (x1,y1) as a quadratic parametric control point.
quadTo(float, float, float, float) - Method in class java.awt.geom.Path2D.Float
Adds a curved segment, defined by two new points, to the path by drawing a Quadratic curve that intersects both the current coordinates and the specified coordinates (x2,y2), using the specified point (x1,y1) as a quadratic parametric control point.
quadTo(double, double, double, double) - Method in class java.awt.geom.Path2D
Adds a curved segment, defined by two new points, to the path by drawing a Quadratic curve that intersects both the current coordinates and the specified coordinates (x2,y2), using the specified point (x1,y1) as a quadratic parametric control point.
QualifiedNameable - Interface in javax.lang.model.element
A mixin interface for an element that has a qualified name.
QUARTER_OF_YEAR - Static variable in class java.time.temporal.IsoFields
The field that represents the quarter-of-year.
QUARTER_YEARS - Static variable in class java.time.temporal.IsoFields
Unit that represents the concept of a quarter-year.
QUARTO - Static variable in class java.awt.PageAttributes.MediaType
The MediaType instance for Quarto, 215 x 275 mm.
QUARTO - Static variable in class javax.print.attribute.standard.MediaSize.Other
Specifies the quarto size, 8.5 inches by 10.83 inches.
QUARTO - Static variable in class javax.print.attribute.standard.MediaSizeName
quarto size .
query(TemporalQuery<R>) - Method in interface java.time.chrono.ChronoLocalDate
Queries this date using the specified query.
query(TemporalQuery<R>) - Method in interface java.time.chrono.ChronoLocalDateTime
Queries this date-time using the specified query.
query(TemporalQuery<R>) - Method in interface java.time.chrono.ChronoZonedDateTime
Queries this date-time using the specified query.
query(TemporalQuery<R>) - Method in interface java.time.chrono.Era
Queries this era using the specified query.
query(TemporalQuery<R>) - Method in enum java.time.DayOfWeek
Queries this day-of-week using the specified query.
query(TemporalQuery<R>) - Method in class java.time.Instant
Queries this instant using the specified query.
query(TemporalQuery<R>) - Method in class java.time.LocalDate
Queries this date using the specified query.
query(TemporalQuery<R>) - Method in class java.time.LocalDateTime
Queries this date-time using the specified query.
query(TemporalQuery<R>) - Method in class java.time.LocalTime
Queries this time using the specified query.
query(TemporalQuery<R>) - Method in enum java.time.Month
Queries this month-of-year using the specified query.
query(TemporalQuery<R>) - Method in class java.time.MonthDay
Queries this month-day using the specified query.
query(TemporalQuery<R>) - Method in class java.time.OffsetDateTime
Queries this date-time using the specified query.
query(TemporalQuery<R>) - Method in class java.time.OffsetTime
Queries this time using the specified query.
query(TemporalQuery<R>) - Method in interface java.time.temporal.TemporalAccessor
Queries this date-time.
query(TemporalQuery<R>) - Method in class java.time.Year
Queries this year using the specified query.
query(TemporalQuery<R>) - Method in class java.time.YearMonth
Queries this year-month using the specified query.
query(TemporalQuery<R>) - Method in class java.time.ZonedDateTime
Queries this date-time using the specified query.
query(TemporalQuery<R>) - Method in class java.time.ZoneOffset
Queries this offset using the specified query.
Query - Class in javax.management
Constructs query object constraints.
Query() - Constructor for class javax.management.Query
Basic constructor.
QUERY_STRING - Static variable in interface javax.xml.ws.handler.MessageContext
Standard property: Query string for request.
QueryEval - Class in javax.management
Allows a query to be performed in the context of a specific MBean server.
QueryEval() - Constructor for class javax.management.QueryEval
QueryExp - Interface in javax.management
Represents relational constraints similar to database query "where clauses".
queryFrom(TemporalAccessor) - Method in interface java.time.temporal.TemporalQuery
Queries the specified temporal object.
queryMBeans(ObjectName, QueryExp) - Method in interface javax.management.MBeanServer
Gets MBeans controlled by the MBean server.
queryMBeans(ObjectName, QueryExp) - Method in interface javax.management.MBeanServerConnection
Gets MBeans controlled by the MBean server.
queryMBeans(ObjectName, MarshalledObject, Subject) - Method in interface javax.management.remote.rmi.RMIConnection
Handles the method MBeanServerConnection.queryMBeans(ObjectName, QueryExp).
queryMBeans(ObjectName, MarshalledObject, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl
queryMBeans(ObjectName, MarshalledObject, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub
queryNames(ObjectName, QueryExp) - Method in interface javax.management.MBeanServer
Gets the names of MBeans controlled by the MBean server.
queryNames(ObjectName, QueryExp) - Method in interface javax.management.MBeanServerConnection
Gets the names of MBeans controlled by the MBean server.
queryNames(ObjectName, MarshalledObject, Subject) - Method in interface javax.management.remote.rmi.RMIConnection
Handles the method MBeanServerConnection.queryNames(ObjectName, QueryExp).
queryNames(ObjectName, MarshalledObject, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl
queryNames(ObjectName, MarshalledObject, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub
QUESTION_DIALOG - Static variable in class javax.swing.JRootPane
Constant used for the windowDecorationStyle property.
QUESTION_MESSAGE - Static variable in class javax.swing.JOptionPane
Used for questions.
Queue<E> - Interface in java.util
A collection designed for holding elements prior to processing.
QUEUED_IN_DEVICE - Static variable in class javax.print.attribute.standard.JobStateReason
The job has been forwarded to a device or print system that is unable to send back status.
QueuedJobCount - Class in javax.print.attribute.standard
Class QueuedJobCount is an integer valued printing attribute that indicates the number of jobs in the printer whose JobState is either PENDING, PENDING_HELD, PROCESSING, or PROCESSING_STOPPED.
QueuedJobCount(int) - Constructor for class javax.print.attribute.standard.QueuedJobCount
Construct a new queued job count attribute with the given integer value.
quietlyComplete() - Method in class java.util.concurrent.ForkJoinTask
Completes this task normally without setting a value.
quietlyCompleteRoot() - Method in class java.util.concurrent.CountedCompleter
Equivalent to getRoot().quietlyComplete().
quietlyInvoke() - Method in class java.util.concurrent.ForkJoinTask
Commences performing this task and awaits its completion if necessary, without returning its result or throwing its exception.
quietlyJoin() - Method in class java.util.concurrent.ForkJoinTask
Joins this task, without returning its result or throwing its exception.
quote(String) - Static method in class java.util.regex.Pattern
Returns a literal pattern String for the specified String.
quote(String) - Static method in class javax.management.ObjectName
Returns a quoted form of the given String, suitable for inclusion in an ObjectName.
quoteChar(int) - Method in class java.io.StreamTokenizer
Specifies that matching pairs of this character delimit string constants in this tokenizer.
quoteReplacement(String) - Static method in class java.util.regex.Matcher
Returns a literal replacement String for the specified String.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames


R-Index (Java Platform SE 8 )

Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames
  • All Classes
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

R

RadialGradientPaint - Class in java.awt
The RadialGradientPaint class provides a way to fill a shape with a circular radial color gradient pattern.
RadialGradientPaint(float, float, float, float[], Color[]) - Constructor for class java.awt.RadialGradientPaint
Constructs a RadialGradientPaint with a default NO_CYCLE repeating method and SRGB color space, using the center as the focus point.
RadialGradientPaint(Point2D, float, float[], Color[]) - Constructor for class java.awt.RadialGradientPaint
Constructs a RadialGradientPaint with a default NO_CYCLE repeating method and SRGB color space, using the center as the focus point.
RadialGradientPaint(float, float, float, float[], Color[], MultipleGradientPaint.CycleMethod) - Constructor for class java.awt.RadialGradientPaint
Constructs a RadialGradientPaint with a default SRGB color space, using the center as the focus point.
RadialGradientPaint(Point2D, float, float[], Color[], MultipleGradientPaint.CycleMethod) - Constructor for class java.awt.RadialGradientPaint
Constructs a RadialGradientPaint with a default SRGB color space, using the center as the focus point.
RadialGradientPaint(float, float, float, float, float, float[], Color[], MultipleGradientPaint.CycleMethod) - Constructor for class java.awt.RadialGradientPaint
Constructs a RadialGradientPaint with a default SRGB color space.
RadialGradientPaint(Point2D, float, Point2D, float[], Color[], MultipleGradientPaint.CycleMethod) - Constructor for class java.awt.RadialGradientPaint
Constructs a RadialGradientPaint with a default SRGB color space.
RadialGradientPaint(Point2D, float, Point2D, float[], Color[], MultipleGradientPaint.CycleMethod, MultipleGradientPaint.ColorSpaceType, AffineTransform) - Constructor for class java.awt.RadialGradientPaint
Constructs a RadialGradientPaint.
RadialGradientPaint(Rectangle2D, float[], Color[], MultipleGradientPaint.CycleMethod) - Constructor for class java.awt.RadialGradientPaint
Constructs a RadialGradientPaint with a default SRGB color space.
RADIO_BUTTON - Static variable in class javax.accessibility.AccessibleRole
A specialized check box that will cause other radio buttons in the same group to become unchecked when this one is checked.
RADIO_BUTTON - Static variable in class javax.swing.plaf.synth.Region
RadioButton region.
RADIO_BUTTON_MENU_ITEM - Static variable in class javax.swing.plaf.synth.Region
RegionButtonMenuItem region.
RadioButtonBorder(Color, Color, Color, Color) - Constructor for class javax.swing.plaf.basic.BasicBorders.RadioButtonBorder
radix() - Method in class java.util.Scanner
Returns this scanner's default radix.
RAISED - Static variable in class javax.swing.border.BevelBorder
Raised bevel type.
RAISED - Static variable in class javax.swing.border.EtchedBorder
Raised etched type.
random() - Static method in class java.lang.Math
Returns a double value with a positive sign, greater than or equal to 0.0 and less than 1.0.
random() - Static method in class java.lang.StrictMath
Returns a double value with a positive sign, greater than or equal to 0.0 and less than 1.0.
Random - Class in java.util
An instance of this class is used to generate a stream of pseudorandom numbers.
Random() - Constructor for class java.util.Random
Creates a new random number generator.
Random(long) - Constructor for class java.util.Random
Creates a new random number generator using a single long seed.
RandomAccess - Interface in java.util
Marker interface used by List implementations to indicate that they support fast (generally constant time) random access.
RandomAccessFile - Class in java.io
Instances of this class support both reading and writing to a random access file.
RandomAccessFile(String, String) - Constructor for class java.io.RandomAccessFile
Creates a random access file stream to read from, and optionally to write to, a file with the specified name.
RandomAccessFile(File, String) - Constructor for class java.io.RandomAccessFile
Creates a random access file stream to read from, and optionally to write to, the file specified by the File argument.
RANDOMPIXELORDER - Static variable in interface java.awt.image.ImageConsumer
The pixels will be delivered in a random order.
randomUUID() - Static method in class java.util.UUID
Static factory to retrieve a type 4 (pseudo randomly generated) UUID.
RANGE - Static variable in class java.awt.JobAttributes.DefaultSelectionType
The DefaultSelectionType instance to use for specifying that a range of pages of the job should be printed.
range(ChronoField) - Method in interface java.time.chrono.Chronology
Gets the range of valid values for the specified field.
range(TemporalField) - Method in interface java.time.chrono.ChronoZonedDateTime
range(TemporalField) - Method in interface java.time.chrono.Era
Gets the range of valid values for the specified field.
range(ChronoField) - Method in class java.time.chrono.HijrahChronology
range(TemporalField) - Method in class java.time.chrono.HijrahDate
range(TemporalField) - Method in enum java.time.chrono.HijrahEra
Gets the range of valid values for the specified field.
range(ChronoField) - Method in class java.time.chrono.IsoChronology
range(ChronoField) - Method in class java.time.chrono.JapaneseChronology
range(TemporalField) - Method in class java.time.chrono.JapaneseDate
range(TemporalField) - Method in class java.time.chrono.JapaneseEra
Gets the range of valid values for the specified field.
range(ChronoField) - Method in class java.time.chrono.MinguoChronology
range(TemporalField) - Method in class java.time.chrono.MinguoDate
range(ChronoField) - Method in class java.time.chrono.ThaiBuddhistChronology
range(TemporalField) - Method in class java.time.chrono.ThaiBuddhistDate
range(TemporalField) - Method in enum java.time.DayOfWeek
Gets the range of valid values for the specified field.
range(TemporalField) - Method in class java.time.Instant
Gets the range of valid values for the specified field.
range(TemporalField) - Method in class java.time.LocalDate
Gets the range of valid values for the specified field.
range(TemporalField) - Method in class java.time.LocalDateTime
Gets the range of valid values for the specified field.
range(TemporalField) - Method in class java.time.LocalTime
Gets the range of valid values for the specified field.
range(TemporalField) - Method in enum java.time.Month
Gets the range of valid values for the specified field.
range(TemporalField) - Method in class java.time.MonthDay
Gets the range of valid values for the specified field.
range(TemporalField) - Method in class java.time.OffsetDateTime
Gets the range of valid values for the specified field.
range(TemporalField) - Method in class java.time.OffsetTime
Gets the range of valid values for the specified field.
range() - Method in enum java.time.temporal.ChronoField
Gets the range of valid values for the field.
range(TemporalField) - Method in interface java.time.temporal.TemporalAccessor
Gets the range of valid values for the specified field.
range() - Method in interface java.time.temporal.TemporalField
Gets the range of valid values for the field.
range(TemporalField) - Method in class java.time.Year
Gets the range of valid values for the specified field.
range(TemporalField) - Method in class java.time.YearMonth
Gets the range of valid values for the specified field.
range(TemporalField) - Method in class java.time.ZonedDateTime
Gets the range of valid values for the specified field.
range(TemporalField) - Method in class java.time.ZoneOffset
Gets the range of valid values for the specified field.
range(E, E) - Static method in class java.util.EnumSet
Creates an enum set initially containing all of the elements in the range defined by the two specified endpoints.
range(int, int) - Static method in interface java.util.stream.IntStream
Returns a sequential ordered IntStream from startInclusive (inclusive) to endExclusive (exclusive) by an incremental step of 1.
range(long, long) - Static method in interface java.util.stream.LongStream
Returns a sequential ordered LongStream from startInclusive (inclusive) to endExclusive (exclusive) by an incremental step of 1.
rangeClosed(int, int) - Static method in interface java.util.stream.IntStream
Returns a sequential ordered IntStream from startInclusive (inclusive) to endInclusive (inclusive) by an incremental step of 1.
rangeClosed(long, long) - Static method in interface java.util.stream.LongStream
Returns a sequential ordered LongStream from startInclusive (inclusive) to endInclusive (inclusive) by an incremental step of 1.
rangeRefinedBy(TemporalAccessor) - Method in enum java.time.temporal.ChronoField
rangeRefinedBy(TemporalAccessor) - Method in interface java.time.temporal.TemporalField
Get the range of valid values for this field using the temporal object to refine the result.
Raster - Class in java.awt.image
A class representing a rectangular array of pixels.
Raster(SampleModel, Point) - Constructor for class java.awt.image.Raster
Constructs a Raster with the given SampleModel.
Raster(SampleModel, DataBuffer, Point) - Constructor for class java.awt.image.Raster
Constructs a Raster with the given SampleModel and DataBuffer.
Raster(SampleModel, DataBuffer, Rectangle, Point, Raster) - Constructor for class java.awt.image.Raster
Constructs a Raster with the given SampleModel, DataBuffer, and parent.
raster - Variable in class javax.imageio.IIOImage
The Raster being referenced.
RasterFormatException - Exception in java.awt.image
The RasterFormatException is thrown if there is invalid layout information in the Raster.
RasterFormatException(String) - Constructor for exception java.awt.image.RasterFormatException
Constructs a new RasterFormatException with the specified message.
RasterOp - Interface in java.awt.image
This interface describes single-input/single-output operations performed on Raster objects.
RATA_DIE - Static variable in class java.time.temporal.JulianFields
Rata Die field.
RAW_SEND_SIZE - Static variable in class javax.security.sasl.Sasl
The name of a property that specifies the maximum size of the raw send buffer in bytes of SaslClient/SaslServer.
RAW_TEXT - Static variable in class java.awt.im.InputMethodHighlight
Constant for the raw text state.
RAW_X509_CERTIFICATE_TYPE - Static variable in interface javax.xml.crypto.dsig.keyinfo.X509Data
URI identifying the binary (ASN.1 DER) X.509 Certificate KeyInfo type: http://www.w3.org/2000/09/xmldsig#rawX509Certificate.
RC2ParameterSpec - Class in javax.crypto.spec
This class specifies the parameters used with the RC2 algorithm.
RC2ParameterSpec(int) - Constructor for class javax.crypto.spec.RC2ParameterSpec
Constructs a parameter set for RC2 from the given effective key size (in bits).
RC2ParameterSpec(int, byte[]) - Constructor for class javax.crypto.spec.RC2ParameterSpec
Constructs a parameter set for RC2 from the given effective key size (in bits) and an 8-byte IV.
RC2ParameterSpec(int, byte[], int) - Constructor for class javax.crypto.spec.RC2ParameterSpec
Constructs a parameter set for RC2 from the given effective key size (in bits) and IV.
RC5ParameterSpec - Class in javax.crypto.spec
This class specifies the parameters used with the RC5 algorithm.
RC5ParameterSpec(int, int, int) - Constructor for class javax.crypto.spec.RC5ParameterSpec
Constructs a parameter set for RC5 from the given version, number of rounds and word size (in bits).
RC5ParameterSpec(int, int, int, byte[]) - Constructor for class javax.crypto.spec.RC5ParameterSpec
Constructs a parameter set for RC5 from the given version, number of rounds, word size (in bits), and IV.
RC5ParameterSpec(int, int, int, byte[], int) - Constructor for class javax.crypto.spec.RC5ParameterSpec
Constructs a parameter set for RC5 from the given version, number of rounds, word size (in bits), and IV.
RCDATA - Static variable in interface javax.swing.text.html.parser.DTDConstants
RCSID - Static variable in class javax.swing.undo.StateEdit
RCSID - Static variable in interface javax.swing.undo.StateEditable
Resource ID for this class.
Rdn - Class in javax.naming.ldap
This class represents a relative distinguished name, or RDN, which is a component of a distinguished name as specified by RFC 2253.
Rdn(Attributes) - Constructor for class javax.naming.ldap.Rdn
Constructs an Rdn from the given attribute set.
Rdn(String) - Constructor for class javax.naming.ldap.Rdn
Constructs an Rdn from the given string.
Rdn(Rdn) - Constructor for class javax.naming.ldap.Rdn
Constructs an Rdn from the given rdn.
Rdn(String, Object) - Constructor for class javax.naming.ldap.Rdn
Constructs an Rdn from the given attribute type and value.
read() - Method in class java.io.BufferedInputStream
See the general contract of the read method of InputStream.
read(byte[], int, int) - Method in class java.io.BufferedInputStream
Reads bytes from this byte-input stream into the specified byte array, starting at the given offset.
read() - Method in class java.io.BufferedReader
Reads a single character.
read(char[], int, int) - Method in class java.io.BufferedReader
Reads characters into a portion of an array.
read() - Method in class java.io.ByteArrayInputStream
Reads the next byte of data from this input stream.
read(byte[], int, int) - Method in class java.io.ByteArrayInputStream
Reads up to len bytes of data into an array of bytes from this input stream.
read() - Method in class java.io.CharArrayReader
Reads a single character.
read(char[], int, int) - Method in class java.io.CharArrayReader
Reads characters into a portion of an array.
read(byte[]) - Method in class java.io.DataInputStream
Reads some number of bytes from the contained input stream and stores them into the buffer array b.
read(byte[], int, int) - Method in class java.io.DataInputStream
Reads up to len bytes of data from the contained input stream into an array of bytes.
read() - Method in class java.io.FileInputStream
Reads a byte of data from this input stream.
read(byte[]) - Method in class java.io.FileInputStream
Reads up to b.length bytes of data from this input stream into an array of bytes.
read(byte[], int, int) - Method in class java.io.FileInputStream
Reads up to len bytes of data from this input stream into an array of bytes.
read() - Method in class java.io.FilterInputStream
Reads the next byte of data from this input stream.
read(byte[]) - Method in class java.io.FilterInputStream
Reads up to byte.length bytes of data from this input stream into an array of bytes.
read(byte[], int, int) - Method in class java.io.FilterInputStream
Reads up to len bytes of data from this input stream into an array of bytes.
read() - Method in class java.io.FilterReader
Reads a single character.
read(char[], int, int) - Method in class java.io.FilterReader
Reads characters into a portion of an array.
read() - Method in class java.io.InputStream
Reads the next byte of data from the input stream.
read(byte[]) - Method in class java.io.InputStream
Reads some number of bytes from the input stream and stores them into the buffer array b.
read(byte[], int, int) - Method in class java.io.InputStream
Reads up to len bytes of data from the input stream into an array of bytes.
read() - Method in class java.io.InputStreamReader
Reads a single character.
read(char[], int, int) - Method in class java.io.InputStreamReader
Reads characters into a portion of an array.
read() - Method in class java.io.LineNumberInputStream
Deprecated.
Reads the next byte of data from this input stream.
read(byte[], int, int) - Method in class java.io.LineNumberInputStream
Deprecated.
Reads up to len bytes of data from this input stream into an array of bytes.
read() - Method in class java.io.LineNumberReader
Read a single character.
read(char[], int, int) - Method in class java.io.LineNumberReader
Read characters into a portion of an array.
read() - Method in interface java.io.ObjectInput
Reads a byte of data.
read(byte[]) - Method in interface java.io.ObjectInput
Reads into an array of bytes.
read(byte[], int, int) - Method in interface java.io.ObjectInput
Reads into an array of bytes.
read() - Method in class java.io.ObjectInputStream
Reads a byte of data.
read(byte[], int, int) - Method in class java.io.ObjectInputStream
Reads into an array of bytes.
read() - Method in class java.io.PipedInputStream
Reads the next byte of data from this piped input stream.
read(byte[], int, int) - Method in class java.io.PipedInputStream
Reads up to len bytes of data from this piped input stream into an array of bytes.
read() - Method in class java.io.PipedReader
Reads the next character of data from this piped stream.
read(char[], int, int) - Method in class java.io.PipedReader
Reads up to len characters of data from this piped stream into an array of characters.
read() - Method in class java.io.PushbackInputStream
Reads the next byte of data from this input stream.
read(byte[], int, int) - Method in class java.io.PushbackInputStream
Reads up to len bytes of data from this input stream into an array of bytes.
read() - Method in class java.io.PushbackReader
Reads a single character.
read(char[], int, int) - Method in class java.io.PushbackReader
Reads characters into a portion of an array.
read() - Method in class java.io.RandomAccessFile
Reads a byte of data from this file.
read(byte[], int, int) - Method in class java.io.RandomAccessFile
Reads up to len bytes of data from this file into an array of bytes.
read(byte[]) - Method in class java.io.RandomAccessFile
Reads up to b.length bytes of data from this file into an array of bytes.
read(CharBuffer) - Method in class java.io.Reader
Attempts to read characters into the specified character buffer.
read() - Method in class java.io.Reader
Reads a single character.
read(char[]) - Method in class java.io.Reader
Reads characters into an array.
read(char[], int, int) - Method in class java.io.Reader
Reads characters into a portion of an array.
read() - Method in class java.io.SequenceInputStream
Reads the next byte of data from this input stream.
read(byte[], int, int) - Method in class java.io.SequenceInputStream
Reads up to len bytes of data from this input stream into an array of bytes.
read() - Method in class java.io.StringBufferInputStream
Deprecated.
Reads the next byte of data from this input stream.
read(byte[], int, int) - Method in class java.io.StringBufferInputStream
Deprecated.
Reads up to len bytes of data from this input stream into an array of bytes.
read() - Method in class java.io.StringReader
Reads a single character.
read(char[], int, int) - Method in class java.io.StringReader
Reads characters into a portion of an array.
read(CharBuffer) - Method in interface java.lang.Readable
Attempts to read characters into the specified character buffer.
read(ByteBuffer, A, CompletionHandler<Integer, ? super A>) - Method in interface java.nio.channels.AsynchronousByteChannel
Reads a sequence of bytes from this channel into the given buffer.
read(ByteBuffer) - Method in interface java.nio.channels.AsynchronousByteChannel
Reads a sequence of bytes from this channel into the given buffer.
read(ByteBuffer, long, A, CompletionHandler<Integer, ? super A>) - Method in class java.nio.channels.AsynchronousFileChannel
Reads a sequence of bytes from this channel into the given buffer, starting at the given file position.
read(ByteBuffer, long) - Method in class java.nio.channels.AsynchronousFileChannel
Reads a sequence of bytes from this channel into the given buffer, starting at the given file position.
read(ByteBuffer, long, TimeUnit, A, CompletionHandler<Integer, ? super A>) - Method in class java.nio.channels.AsynchronousSocketChannel
Reads a sequence of bytes from this channel into the given buffer.
read(ByteBuffer, A, CompletionHandler<Integer, ? super A>) - Method in class java.nio.channels.AsynchronousSocketChannel
read(ByteBuffer) - Method in class java.nio.channels.AsynchronousSocketChannel
read(ByteBuffer[], int, int, long, TimeUnit, A, CompletionHandler<Long, ? super A>) - Method in class java.nio.channels.AsynchronousSocketChannel
Reads a sequence of bytes from this channel into a subsequence of the given buffers.
read(ByteBuffer) - Method in class java.nio.channels.DatagramChannel
Reads a datagram from this channel.
read(ByteBuffer[], int, int) - Method in class java.nio.channels.DatagramChannel
Reads a datagram from this channel.
read(ByteBuffer[]) - Method in class java.nio.channels.DatagramChannel
Reads a datagram from this channel.
read(ByteBuffer) - Method in class java.nio.channels.FileChannel
Reads a sequence of bytes from this channel into the given buffer.
read(ByteBuffer[], int, int) - Method in class java.nio.channels.FileChannel
Reads a sequence of bytes from this channel into a subsequence of the given buffers.
read(ByteBuffer[]) - Method in class java.nio.channels.FileChannel
Reads a sequence of bytes from this channel into the given buffers.
read(ByteBuffer, long) - Method in class java.nio.channels.FileChannel
Reads a sequence of bytes from this channel into the given buffer, starting at the given file position.
read(ByteBuffer) - Method in interface java.nio.channels.ReadableByteChannel
Reads a sequence of bytes from this channel into the given buffer.
read(ByteBuffer[], int, int) - Method in interface java.nio.channels.ScatteringByteChannel
Reads a sequence of bytes from this channel into a subsequence of the given buffers.
read(ByteBuffer[]) - Method in interface java.nio.channels.ScatteringByteChannel
Reads a sequence of bytes from this channel into the given buffers.
read(ByteBuffer) - Method in interface java.nio.channels.SeekableByteChannel
Reads a sequence of bytes from this channel into the given buffer.
read(ByteBuffer) - Method in class java.nio.channels.SocketChannel
read(ByteBuffer[], int, int) - Method in class java.nio.channels.SocketChannel
read(ByteBuffer[]) - Method in class java.nio.channels.SocketChannel
read(CharBuffer) - Method in class java.nio.CharBuffer
Attempts to read characters into the specified character buffer.
read(String, ByteBuffer) - Method in interface java.nio.file.attribute.UserDefinedFileAttributeView
Read the value of a user-defined attribute into a buffer.
read(ObjectInput) - Static method in class java.rmi.server.ObjID
Constructs and returns a new ObjID instance by unmarshalling a binary representation from an ObjectInput instance.
read(DataInput) - Static method in class java.rmi.server.UID
Constructs and returns a new UID instance by unmarshalling a binary representation from an DataInput instance.
read() - Method in class java.security.DigestInputStream
Reads a byte, and updates the message digest (if the digest function is on).
read(byte[], int, int) - Method in class java.security.DigestInputStream
Reads into a byte array, and updates the message digest (if the digest function is on).
read(byte[], int, int) - Method in class java.util.jar.JarInputStream
Reads from the current JAR file entry into an array of bytes.
read(InputStream) - Method in class java.util.jar.Manifest
Reads the Manifest from the specified InputStream.
read() - Method in class java.util.zip.CheckedInputStream
Reads a byte.
read(byte[], int, int) - Method in class java.util.zip.CheckedInputStream
Reads into an array of bytes.
read() - Method in class java.util.zip.DeflaterInputStream
Reads a single byte of compressed data from the input stream.
read(byte[], int, int) - Method in class java.util.zip.DeflaterInputStream
Reads compressed data into a byte array.
read(byte[], int, int) - Method in class java.util.zip.GZIPInputStream
Reads uncompressed data into an array of bytes.
read() - Method in class java.util.zip.InflaterInputStream
Reads a byte of uncompressed data.
read(byte[], int, int) - Method in class java.util.zip.InflaterInputStream
Reads uncompressed data into an array of bytes.
read(byte[], int, int) - Method in class java.util.zip.ZipInputStream
Reads from the current ZIP entry into an array of bytes.
read() - Method in class javax.crypto.CipherInputStream
Reads the next byte of data from this input stream.
read(byte[]) - Method in class javax.crypto.CipherInputStream
Reads up to b.length bytes of data from this input stream into an array of bytes.
read(byte[], int, int) - Method in class javax.crypto.CipherInputStream
Reads up to len bytes of data from this input stream into an array of bytes.
read(File) - Static method in class javax.imageio.ImageIO
Returns a BufferedImage as the result of decoding a supplied File with an ImageReader chosen automatically from among those currently registered.
read(InputStream) - Static method in class javax.imageio.ImageIO
Returns a BufferedImage as the result of decoding a supplied InputStream with an ImageReader chosen automatically from among those currently registered.
read(URL) - Static method in class javax.imageio.ImageIO
Returns a BufferedImage as the result of decoding a supplied URL with an ImageReader chosen automatically from among those currently registered.
read(ImageInputStream) - Static method in class javax.imageio.ImageIO
Returns a BufferedImage as the result of decoding a supplied ImageInputStream with an ImageReader chosen automatically from among those currently registered.
read(int) - Method in class javax.imageio.ImageReader
Reads the image indexed by imageIndex and returns it as a complete BufferedImage, using a default ImageReadParam.
read(int, ImageReadParam) - Method in class javax.imageio.ImageReader
Reads the image indexed by imageIndex and returns it as a complete BufferedImage, using a supplied ImageReadParam.
read() - Method in class javax.imageio.stream.FileCacheImageInputStream
read(byte[], int, int) - Method in class javax.imageio.stream.FileCacheImageInputStream
read() - Method in class javax.imageio.stream.FileCacheImageOutputStream
read(byte[], int, int) - Method in class javax.imageio.stream.FileCacheImageOutputStream
read() - Method in class javax.imageio.stream.FileImageInputStream
read(byte[], int, int) - Method in class javax.imageio.stream.FileImageInputStream
read() - Method in class javax.imageio.stream.FileImageOutputStream
read(byte[], int, int) - Method in class javax.imageio.stream.FileImageOutputStream
read() - Method in interface javax.imageio.stream.ImageInputStream
Reads a single byte from the stream and returns it as an integer between 0 and 255.
read(byte[]) - Method in interface javax.imageio.stream.ImageInputStream
Reads up to b.length bytes from the stream, and stores them into b starting at index 0.
read(byte[], int, int) - Method in interface javax.imageio.stream.ImageInputStream
Reads up to len bytes from the stream, and stores them into b starting at index off.
read() - Method in class javax.imageio.stream.ImageInputStreamImpl
Reads a single byte from the stream and returns it as an int between 0 and 255.
read(byte[]) - Method in class javax.imageio.stream.ImageInputStreamImpl
A convenience method that calls read(b, 0, b.length).
read(byte[], int, int) - Method in class javax.imageio.stream.ImageInputStreamImpl
Reads up to len bytes from the stream, and stores them into b starting at index off.
read() - Method in class javax.imageio.stream.MemoryCacheImageInputStream
read(byte[], int, int) - Method in class javax.imageio.stream.MemoryCacheImageInputStream
read() - Method in class javax.imageio.stream.MemoryCacheImageOutputStream
read(byte[], int, int) - Method in class javax.imageio.stream.MemoryCacheImageOutputStream
read() - Method in class javax.sound.sampled.AudioInputStream
Reads the next byte of data from the audio input stream.
read(byte[]) - Method in class javax.sound.sampled.AudioInputStream
Reads some number of bytes from the audio input stream and stores them into the buffer array b.
read(byte[], int, int) - Method in class javax.sound.sampled.AudioInputStream
Reads up to a specified maximum number of bytes of data from the audio stream, putting them into the given byte array.
read(byte[], int, int) - Method in interface javax.sound.sampled.TargetDataLine
Reads audio data from the data line's input buffer.
read(InputStream, Object) - Method in class javax.swing.JEditorPane
This method initializes from a stream.
read() - Method in class javax.swing.ProgressMonitorInputStream
Overrides FilterInputStream.read to update the progress monitor after the read.
read(byte[]) - Method in class javax.swing.ProgressMonitorInputStream
Overrides FilterInputStream.read to update the progress monitor after the read.
read(byte[], int, int) - Method in class javax.swing.ProgressMonitorInputStream
Overrides FilterInputStream.read to update the progress monitor after the read.
read(InputStream, Document, int) - Method in class javax.swing.text.DefaultEditorKit
Inserts content from the given stream which is expected to be in a format appropriate for this kind of content handler.
read(Reader, Document, int) - Method in class javax.swing.text.DefaultEditorKit
Inserts content from the given stream, which will be treated as plain text.
read(InputStream, Document, int) - Method in class javax.swing.text.EditorKit
Inserts content from the given stream which is expected to be in a format appropriate for this kind of content handler.
read(Reader, Document, int) - Method in class javax.swing.text.EditorKit
Inserts content from the given stream which is expected to be in a format appropriate for this kind of content handler.
read(Reader, Document, int) - Method in class javax.swing.text.html.HTMLEditorKit
Inserts content from the given stream.
read(DataInputStream) - Method in class javax.swing.text.html.parser.DTD
Recreates a DTD from an archived format.
read(Reader, Object) - Method in class javax.swing.text.JTextComponent
Initializes from a stream.
read(InputStream, Document, int) - Method in class javax.swing.text.rtf.RTFEditorKit
Insert content from the given stream which is expected to be in a format appropriate for this kind of content handler.
read(Reader, Document, int) - Method in class javax.swing.text.rtf.RTFEditorKit
Insert content from the given stream, which will be treated as plain text.
read(InputStream) - Static method in class org.omg.CORBA.AnySeqHelper
read(InputStream) - Static method in class org.omg.CORBA.BooleanSeqHelper
read(InputStream) - Static method in class org.omg.CORBA.CharSeqHelper
read(InputStream) - Static method in class org.omg.CORBA.CompletionStatusHelper
read(InputStream) - Static method in class org.omg.CORBA.CurrentHelper
read(InputStream) - Static method in class org.omg.CORBA.DefinitionKindHelper
read(InputStream) - Static method in class org.omg.CORBA.DoubleSeqHelper
read(InputStream) - Static method in class org.omg.CORBA.FieldNameHelper
read(InputStream) - Static method in class org.omg.CORBA.FloatSeqHelper
read(InputStream) - Static method in class org.omg.CORBA.IdentifierHelper
read(InputStream) - Static method in class org.omg.CORBA.IDLTypeHelper
read(InputStream) - Static method in class org.omg.CORBA.LongLongSeqHelper
read(InputStream) - Static method in class org.omg.CORBA.LongSeqHelper
read(InputStream) - Static method in class org.omg.CORBA.NameValuePairHelper
read(InputStream) - Static method in class org.omg.CORBA.ObjectHelper
read(InputStream) - Static method in class org.omg.CORBA.OctetSeqHelper
read(InputStream) - Static method in class org.omg.CORBA.ParameterModeHelper
read(InputStream) - Static method in class org.omg.CORBA.PolicyErrorCodeHelper
read(InputStream) - Static method in class org.omg.CORBA.PolicyErrorHelper
read(InputStream) - Static method in class org.omg.CORBA.PolicyHelper
read(InputStream) - Static method in class org.omg.CORBA.PolicyListHelper
read(InputStream) - Static method in class org.omg.CORBA.PolicyTypeHelper
read() - Method in class org.omg.CORBA.portable.InputStream
read(InputStream) - Static method in class org.omg.CORBA.RepositoryIdHelper
read(InputStream) - Static method in class org.omg.CORBA.ServiceDetailHelper
read(InputStream) - Static method in class org.omg.CORBA.ServiceInformationHelper
read(InputStream) - Static method in class org.omg.CORBA.SetOverrideTypeHelper
read(InputStream) - Static method in class org.omg.CORBA.ShortSeqHelper
read(InputStream) - Static method in class org.omg.CORBA.StringSeqHelper
read(InputStream) - Static method in class org.omg.CORBA.StringValueHelper
read(InputStream) - Static method in class org.omg.CORBA.StructMemberHelper
read(InputStream) - Static method in class org.omg.CORBA.ULongLongSeqHelper
read(InputStream) - Static method in class org.omg.CORBA.ULongSeqHelper
read(InputStream) - Static method in class org.omg.CORBA.UnionMemberHelper
read(InputStream) - Static method in class org.omg.CORBA.UnknownUserExceptionHelper
read(InputStream) - Static method in class org.omg.CORBA.UShortSeqHelper
read(InputStream) - Static method in class org.omg.CORBA.ValueBaseHelper
read(InputStream) - Static method in class org.omg.CORBA.ValueMemberHelper
read(InputStream) - Static method in class org.omg.CORBA.VersionSpecHelper
read(InputStream) - Static method in class org.omg.CORBA.VisibilityHelper
read(InputStream) - Static method in class org.omg.CORBA.WCharSeqHelper
read(InputStream) - Static method in class org.omg.CORBA.WrongTransactionHelper
read(InputStream) - Static method in class org.omg.CORBA.WStringSeqHelper
read(InputStream) - Static method in class org.omg.CORBA.WStringValueHelper
read(InputStream) - Static method in class org.omg.CosNaming.BindingHelper
read(InputStream) - Static method in class org.omg.CosNaming.BindingIteratorHelper
read(InputStream) - Static method in class org.omg.CosNaming.BindingListHelper
read(InputStream) - Static method in class org.omg.CosNaming.BindingTypeHelper
read(InputStream) - Static method in class org.omg.CosNaming.IstringHelper
read(InputStream) - Static method in class org.omg.CosNaming.NameComponentHelper
read(InputStream) - Static method in class org.omg.CosNaming.NameHelper
read(InputStream) - Static method in class org.omg.CosNaming.NamingContextExtHelper
read(InputStream) - Static method in class org.omg.CosNaming.NamingContextExtPackage.AddressHelper
read(InputStream) - Static method in class org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper
read(InputStream) - Static method in class org.omg.CosNaming.NamingContextExtPackage.StringNameHelper
read(InputStream) - Static method in class org.omg.CosNaming.NamingContextExtPackage.URLStringHelper
read(InputStream) - Static method in class org.omg.CosNaming.NamingContextHelper
read(InputStream) - Static method in class org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper
read(InputStream) - Static method in class org.omg.CosNaming.NamingContextPackage.CannotProceedHelper
read(InputStream) - Static method in class org.omg.CosNaming.NamingContextPackage.InvalidNameHelper
read(InputStream) - Static method in class org.omg.CosNaming.NamingContextPackage.NotEmptyHelper
read(InputStream) - Static method in class org.omg.CosNaming.NamingContextPackage.NotFoundHelper
read(InputStream) - Static method in class org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper
read(InputStream) - Static method in class org.omg.DynamicAny.AnySeqHelper
read(InputStream) - Static method in class org.omg.DynamicAny.DynAnyFactoryHelper
read(InputStream) - Static method in class org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper
read(InputStream) - Static method in class org.omg.DynamicAny.DynAnyHelper
read(InputStream) - Static method in class org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper
read(InputStream) - Static method in class org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper
read(InputStream) - Static method in class org.omg.DynamicAny.DynAnySeqHelper
read(InputStream) - Static method in class org.omg.DynamicAny.DynArrayHelper
read(InputStream) - Static method in class org.omg.DynamicAny.DynEnumHelper
read(InputStream) - Static method in class org.omg.DynamicAny.DynFixedHelper
read(InputStream) - Static method in class org.omg.DynamicAny.DynSequenceHelper
read(InputStream) - Static method in class org.omg.DynamicAny.DynStructHelper
read(InputStream) - Static method in class org.omg.DynamicAny.DynUnionHelper
read(InputStream) - Static method in class org.omg.DynamicAny.DynValueHelper
read(InputStream) - Static method in class org.omg.DynamicAny.FieldNameHelper
read(InputStream) - Static method in class org.omg.DynamicAny.NameDynAnyPairHelper
read(InputStream) - Static method in class org.omg.DynamicAny.NameDynAnyPairSeqHelper
read(InputStream) - Static method in class org.omg.DynamicAny.NameValuePairHelper
read(InputStream) - Static method in class org.omg.DynamicAny.NameValuePairSeqHelper
read(InputStream) - Static method in class org.omg.IOP.CodecFactoryHelper
read(InputStream) - Static method in class org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper
read(InputStream) - Static method in class org.omg.IOP.CodecPackage.FormatMismatchHelper
read(InputStream) - Static method in class org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper
read(InputStream) - Static method in class org.omg.IOP.CodecPackage.TypeMismatchHelper
read(InputStream) - Static method in class org.omg.IOP.ComponentIdHelper
read(InputStream) - Static method in class org.omg.IOP.IORHelper
read(InputStream) - Static method in class org.omg.IOP.MultipleComponentProfileHelper
read(InputStream) - Static method in class org.omg.IOP.ProfileIdHelper
read(InputStream) - Static method in class org.omg.IOP.ServiceContextHelper
read(InputStream) - Static method in class org.omg.IOP.ServiceContextListHelper
read(InputStream) - Static method in class org.omg.IOP.ServiceIdHelper
read(InputStream) - Static method in class org.omg.IOP.TaggedComponentHelper
read(InputStream) - Static method in class org.omg.IOP.TaggedProfileHelper
read(InputStream) - Static method in class org.omg.Messaging.SyncScopeHelper
read(InputStream) - Static method in class org.omg.PortableInterceptor.AdapterManagerIdHelper
read(InputStream) - Static method in class org.omg.PortableInterceptor.AdapterNameHelper
read(InputStream) - Static method in class org.omg.PortableInterceptor.AdapterStateHelper
read(InputStream) - Static method in class org.omg.PortableInterceptor.CurrentHelper
read(InputStream) - Static method in class org.omg.PortableInterceptor.ForwardRequestHelper
read(InputStream) - Static method in class org.omg.PortableInterceptor.InvalidSlotHelper
read(InputStream) - Static method in class org.omg.PortableInterceptor.IORInterceptor_3_0Helper
read(InputStream) - Static method in class org.omg.PortableInterceptor.ObjectIdHelper
read(InputStream) - Static method in class org.omg.PortableInterceptor.ObjectReferenceFactoryHelper
read(InputStream) - Static method in class org.omg.PortableInterceptor.ObjectReferenceTemplateHelper
read(InputStream) - Static method in class org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper
read(InputStream) - Static method in class org.omg.PortableInterceptor.ORBIdHelper
read(InputStream) - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper
read(InputStream) - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper
read(InputStream) - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper
read(InputStream) - Static method in class org.omg.PortableInterceptor.ServerIdHelper
read(InputStream) - Static method in class org.omg.PortableServer.CurrentHelper
read(InputStream) - Static method in class org.omg.PortableServer.CurrentPackage.NoContextHelper
read(InputStream) - Static method in class org.omg.PortableServer.ForwardRequestHelper
read(InputStream) - Static method in class org.omg.PortableServer.POAHelper
read(InputStream) - Static method in class org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper
read(InputStream) - Static method in class org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper
read(InputStream) - Static method in class org.omg.PortableServer.POAPackage.AdapterNonExistentHelper
read(InputStream) - Static method in class org.omg.PortableServer.POAPackage.InvalidPolicyHelper
read(InputStream) - Static method in class org.omg.PortableServer.POAPackage.NoServantHelper
read(InputStream) - Static method in class org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper
read(InputStream) - Static method in class org.omg.PortableServer.POAPackage.ObjectNotActiveHelper
read(InputStream) - Static method in class org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper
read(InputStream) - Static method in class org.omg.PortableServer.POAPackage.ServantNotActiveHelper
read(InputStream) - Static method in class org.omg.PortableServer.POAPackage.WrongAdapterHelper
read(InputStream) - Static method in class org.omg.PortableServer.POAPackage.WrongPolicyHelper
read(InputStream) - Static method in class org.omg.PortableServer.ServantActivatorHelper
read(InputStream) - Static method in class org.omg.PortableServer.ServantLocatorHelper
read_Abstract() - Method in interface org.omg.CORBA.DataInputStream
Reads an IDL Abstract interface from the input stream.
read_abstract_interface() - Method in class org.omg.CORBA_2_3.portable.InputStream
Unmarshal the value object or a suitable stub object.
read_abstract_interface(Class) - Method in class org.omg.CORBA_2_3.portable.InputStream
Unmarshal the class object or the stub class corresponding to the passed type.
read_any() - Method in interface org.omg.CORBA.DataInputStream
Reads an IDL Any value from the input stream.
read_any() - Method in class org.omg.CORBA.portable.InputStream
Reads an Any from this input stream.
read_any_array(AnySeqHolder, int, int) - Method in interface org.omg.CORBA.DataInputStream
Reads array of IDL Anys from offset for length elements from the input stream.
read_boolean() - Method in interface org.omg.CORBA.DataInputStream
Reads an IDL boolean value from the input stream.
read_boolean() - Method in class org.omg.CORBA.portable.InputStream
Reads a boolean value from this input stream.
read_boolean_array(BooleanSeqHolder, int, int) - Method in interface org.omg.CORBA.DataInputStream
Reads array of IDL booleans from offset for length elements from the input stream.
read_boolean_array(boolean[], int, int) - Method in class org.omg.CORBA.portable.InputStream
Reads an array of booleans from this input stream.
read_char() - Method in interface org.omg.CORBA.DataInputStream
Reads an IDL character value from the input stream.
read_char() - Method in class org.omg.CORBA.portable.InputStream
Reads a char value from this input stream.
read_char_array(CharSeqHolder, int, int) - Method in interface org.omg.CORBA.DataInputStream
Reads array of IDL characters from offset for length elements from the input stream.
read_char_array(char[], int, int) - Method in class org.omg.CORBA.portable.InputStream
Reads an array of chars from this input stream.
read_Context() - Method in class org.omg.CORBA.portable.InputStream
Reads a CORBA context from the stream.
read_double() - Method in interface org.omg.CORBA.DataInputStream
Reads an IDL double from the input stream.
read_double() - Method in class org.omg.CORBA.portable.InputStream
Reads a double value from this input stream.
read_double_array(DoubleSeqHolder, int, int) - Method in interface org.omg.CORBA.DataInputStream
Reads array of IDL doubles from offset for length elements from the input stream.
read_double_array(double[], int, int) - Method in class org.omg.CORBA.portable.InputStream
Reads an array of doubles from this input stream.
read_fixed() - Method in class org.omg.CORBA.portable.InputStream
Reads a BigDecimal number.
read_float() - Method in interface org.omg.CORBA.DataInputStream
Reads an IDL float from the input stream.
read_float() - Method in class org.omg.CORBA.portable.InputStream
Reads a float value from this input stream.
read_float_array(FloatSeqHolder, int, int) - Method in interface org.omg.CORBA.DataInputStream
Reads array of IDL floats from offset for length elements from the input stream.
read_float_array(float[], int, int) - Method in class org.omg.CORBA.portable.InputStream
Reads an array of floats from this input stream.
read_long() - Method in interface org.omg.CORBA.DataInputStream
Reads an IDL long from the input stream.
read_long() - Method in class org.omg.CORBA.portable.InputStream
Reads a CORBA long (that is, Java int) value from this input stream.
read_long_array(LongSeqHolder, int, int) - Method in interface org.omg.CORBA.DataInputStream
Reads array of IDL longs from offset for length elements from the input stream.
read_long_array(int[], int, int) - Method in class org.omg.CORBA.portable.InputStream
Reads an array of CORBA longs (that is, Java ints) from this input stream.
read_longlong() - Method in interface org.omg.CORBA.DataInputStream
Reads an IDL long long from the input stream.
read_longlong() - Method in class org.omg.CORBA.portable.InputStream
Reads a CORBA longlong (that is, Java long) value from this input stream.
read_longlong_array(LongLongSeqHolder, int, int) - Method in interface org.omg.CORBA.DataInputStream
Reads array of IDL long longs from offset for length elements from the input stream.
read_longlong_array(long[], int, int) - Method in class org.omg.CORBA.portable.InputStream
Reads an array of CORBA longlongs (that is, Java longs) from this input stream.
read_Object() - Method in interface org.omg.CORBA.DataInputStream
Reads an IDL CORBA::Object from the input stream.
read_Object() - Method in class org.omg.CORBA.portable.InputStream
Reads a CORBA object from this input stream.
read_Object(Class) - Method in class org.omg.CORBA.portable.InputStream
Unmarshals an object and returns a CORBA Object, which is an instance of the class passed as its argument.
read_octet() - Method in interface org.omg.CORBA.DataInputStream
Reads an IDL octet value from the input stream.
read_octet() - Method in class org.omg.CORBA.portable.InputStream
Reads an octet (that is, a byte) value from this input stream.
read_octet_array(OctetSeqHolder, int, int) - Method in interface org.omg.CORBA.DataInputStream
Reads array of IDL octets from offset for length elements from the input stream.
read_octet_array(byte[], int, int) - Method in class org.omg.CORBA.portable.InputStream
Reads an array of octets (that is, bytes) from this input stream.
READ_ONLY - Static variable in class java.nio.channels.FileChannel.MapMode
Mode for a read-only mapping.
read_Principal() - Method in class org.omg.CORBA.portable.InputStream
Deprecated.
Deprecated by CORBA 2.2.
read_short() - Method in interface org.omg.CORBA.DataInputStream
Reads an IDL short from the input stream.
read_short() - Method in class org.omg.CORBA.portable.InputStream
Reads a short value from this input stream.
read_short_array(ShortSeqHolder, int, int) - Method in interface org.omg.CORBA.DataInputStream
Reads array of IDL shorts from offset for length elements from the input stream.
read_short_array(short[], int, int) - Method in class org.omg.CORBA.portable.InputStream
Reads an array of shorts from this input stream.
read_string() - Method in interface org.omg.CORBA.DataInputStream
Reads an IDL string from the input stream.
read_string() - Method in class org.omg.CORBA.portable.InputStream
Reads a string value from this input stream.
read_TypeCode() - Method in interface org.omg.CORBA.DataInputStream
Reads an IDL typecode from the input stream.
read_TypeCode() - Method in class org.omg.CORBA.portable.InputStream
Reads a TypeCode from this input stream.
read_ulong() - Method in interface org.omg.CORBA.DataInputStream
Reads an IDL unsigned long from the input stream.
read_ulong() - Method in class org.omg.CORBA.portable.InputStream
Reads an unsigned CORBA long (that is, Java int) value from this input stream.
read_ulong_array(ULongSeqHolder, int, int) - Method in interface org.omg.CORBA.DataInputStream
Reads array of IDL unsigned longs from offset for length elements from the input stream.
read_ulong_array(int[], int, int) - Method in class org.omg.CORBA.portable.InputStream
Reads an array of unsigned CORBA longs (that is, Java ints) from this input stream.
read_ulonglong() - Method in interface org.omg.CORBA.DataInputStream
Reads an unsigned IDL long long from the input stream.
read_ulonglong() - Method in class org.omg.CORBA.portable.InputStream
Reads a CORBA unsigned longlong (that is, Java long) value from this input stream.
read_ulonglong_array(ULongLongSeqHolder, int, int) - Method in interface org.omg.CORBA.DataInputStream
Reads array of IDL unsigned long longs from offset for length elements from the input stream.
read_ulonglong_array(long[], int, int) - Method in class org.omg.CORBA.portable.InputStream
Reads an array of unsigned CORBA longlongs (that is, Java longs) from this input stream.
read_ushort() - Method in interface org.omg.CORBA.DataInputStream
Reads an IDL unsigned short from the input stream.
read_ushort() - Method in class org.omg.CORBA.portable.InputStream
Reads a unsigned short value from this input stream.
read_ushort_array(UShortSeqHolder, int, int) - Method in interface org.omg.CORBA.DataInputStream
Reads array of IDL unsigned shorts from offset for length elements from the input stream.
read_ushort_array(short[], int, int) - Method in class org.omg.CORBA.portable.InputStream
Reads an array of unsigned shorts from this input stream.
read_value(InputStream, TypeCode) - Method in class org.omg.CORBA.Any
Reads off (unmarshals) the value of an Any object from the given input stream using the given typecode.
read_Value() - Method in interface org.omg.CORBA.DataInputStream
Reads an IDL value type from the input stream.
read_value(InputStream) - Method in interface org.omg.CORBA.portable.BoxedValueHelper
read_value(InputStream) - Method in interface org.omg.CORBA.portable.ValueFactory
Is called by the ORB runtime while in the process of unmarshaling a value type.
read_value(InputStream) - Method in class org.omg.CORBA.StringValueHelper
read_value(InputStream) - Method in class org.omg.CORBA.WStringValueHelper
read_value() - Method in class org.omg.CORBA_2_3.portable.InputStream
Unmarshalls a value type from the input stream.
read_value(Class) - Method in class org.omg.CORBA_2_3.portable.InputStream
Unmarshalls a value type from the input stream.
read_value(BoxedValueHelper) - Method in class org.omg.CORBA_2_3.portable.InputStream
Unmarshalls a value type from the input stream.
read_value(String) - Method in class org.omg.CORBA_2_3.portable.InputStream
Unmarshalls a value type from the input stream.
read_value(Serializable) - Method in class org.omg.CORBA_2_3.portable.InputStream
Unmarshalls a value type from the input stream.
read_wchar() - Method in interface org.omg.CORBA.DataInputStream
Reads an IDL wide character value from the input stream.
read_wchar() - Method in class org.omg.CORBA.portable.InputStream
Reads a wide char value from this input stream.
read_wchar_array(WCharSeqHolder, int, int) - Method in interface org.omg.CORBA.DataInputStream
Reads array of IDL wide characters from offset for length elements from the input stream.
read_wchar_array(char[], int, int) - Method in class org.omg.CORBA.portable.InputStream
Reads an array of wide chars from this input stream.
READ_WRITE - Static variable in class java.nio.channels.FileChannel.MapMode
Mode for a read/write mapping.
read_wstring() - Method in interface org.omg.CORBA.DataInputStream
Reads an IDL wide string from the input stream.
read_wstring() - Method in class org.omg.CORBA.portable.InputStream
Reads a wide string value from this input stream.
Readable - Interface in java.lang
A Readable is a source of characters.
ReadableByteChannel - Interface in java.nio.channels
A channel that can read bytes.
readAborted(ImageReader) - Method in interface javax.imageio.event.IIOReadProgressListener
Reports that a read has been aborted via the reader's abort method.
readAll(int, ImageReadParam) - Method in class javax.imageio.ImageReader
Reads the image indexed by imageIndex and returns an IIOImage containing the image, thumbnails, and associated image metadata, using a supplied ImageReadParam.
readAll(Iterator<? extends ImageReadParam>) - Method in class javax.imageio.ImageReader
Returns an Iterator containing all the images, thumbnails, and metadata, starting at the index given by getMinIndex, from the input source in the form of IIOImage objects.
readAllBytes(Path) - Static method in class java.nio.file.Files
Reads all the bytes from a file.
readAllLines(Path, Charset) - Static method in class java.nio.file.Files
Read all lines from a file.
readAllLines(Path) - Static method in class java.nio.file.Files
Read all lines from a file.
readAny(InputStream) - Static method in class javax.rmi.CORBA.Util
Reads a java.lang.Object as a CORBA any.
readAny(InputStream) - Method in interface javax.rmi.CORBA.UtilDelegate
Delegation call for Util.readAny(org.omg.CORBA.portable.InputStream).
readArray() - Method in interface java.sql.SQLInput
Reads an SQL ARRAY value from the stream and returns it as an Array object in the Java programming language.
readArray() - Method in class javax.sql.rowset.serial.SQLInputImpl
Reads an SQL ARRAY value from the stream and returns it as an Array object in the Java programming language.
readAsciiStream() - Method in interface java.sql.SQLInput
Reads the next attribute in the stream and returns it as a stream of ASCII characters.
readAsciiStream() - Method in class javax.sql.rowset.serial.SQLInputImpl
Returns the next attribute in this SQLInputImpl object as a stream of ASCII characters.
readAsRenderedImage(int, ImageReadParam) - Method in class javax.imageio.ImageReader
Returns a RenderedImage object that contains the contents of the image indexed by imageIndex.
readAttributes() - Method in interface java.nio.file.attribute.BasicFileAttributeView
Reads the basic file attributes as a bulk operation.
readAttributes() - Method in interface java.nio.file.attribute.DosFileAttributeView
readAttributes() - Method in interface java.nio.file.attribute.PosixFileAttributeView
readAttributes(Path, Class<A>, LinkOption...) - Static method in class java.nio.file.Files
Reads a file's attributes as a bulk operation.
readAttributes(Path, String, LinkOption...) - Static method in class java.nio.file.Files
Reads a set of file attributes as a bulk operation.
readAttributes(Path, Class<A>, LinkOption...) - Method in class java.nio.file.spi.FileSystemProvider
Reads a file's attributes as a bulk operation.
readAttributes(Path, String, LinkOption...) - Method in class java.nio.file.spi.FileSystemProvider
Reads a set of file attributes as a bulk operation.
readAttributes(ObjectInputStream, MutableAttributeSet) - Method in class javax.swing.text.StyleContext
Context-specific handling of reading in attributes
readAttributeSet(ObjectInputStream, MutableAttributeSet) - Static method in class javax.swing.text.StyleContext
Reads a set of attributes from the given object input stream that have been previously written out with writeAttributeSet.
readBigDecimal() - Method in interface java.sql.SQLInput
Reads the next attribute in the stream and returns it as a java.math.BigDecimal object in the Java programming language.
readBigDecimal() - Method in class javax.sql.rowset.serial.SQLInputImpl
Retrieves the next attribute in this SQLInputImpl object as a java.math.BigDecimal.
readBinaryStream() - Method in interface java.sql.SQLInput
Reads the next attribute in the stream and returns it as a stream of uninterpreted bytes.
readBinaryStream() - Method in class javax.sql.rowset.serial.SQLInputImpl
Returns the next attribute in this SQLInputImpl object as a stream of uninterpreted bytes.
readBit() - Method in interface javax.imageio.stream.ImageInputStream
Reads a single bit from the stream and returns it as an int with the value 0 or 1.
readBit() - Method in class javax.imageio.stream.ImageInputStreamImpl
readBits(int) - Method in interface javax.imageio.stream.ImageInputStream
Reads a bitstring from the stream and returns it as a long, with the first bit read becoming the most significant bit of the output.
readBits(int) - Method in class javax.imageio.stream.ImageInputStreamImpl
readBlob() - Method in interface java.sql.SQLInput
Reads an SQL BLOB value from the stream and returns it as a Blob object in the Java programming language.
readBlob() - Method in class javax.sql.rowset.serial.SQLInputImpl
Retrieves the BLOB value at the head of this SQLInputImpl object as a Blob object in the Java programming language.
readBoolean() - Method in interface java.io.DataInput
Reads one input byte and returns true if that byte is nonzero, false if that byte is zero.
readBoolean() - Method in class java.io.DataInputStream
See the general contract of the readBoolean method of DataInput.
readBoolean() - Method in class java.io.ObjectInputStream
Reads in a boolean.
readBoolean() - Method in class java.io.RandomAccessFile
Reads a boolean from this file.
readBoolean() - Method in interface java.sql.SQLInput
Reads the next attribute in the stream and returns it as a boolean in the Java programming language.
readBoolean() - Method in interface javax.imageio.stream.ImageInputStream
Reads a byte from the stream and returns a boolean value of true if it is nonzero, false if it is zero.
readBoolean() - Method in class javax.imageio.stream.ImageInputStreamImpl
readBoolean() - Method in class javax.sql.rowset.serial.SQLInputImpl
Retrieves the next attribute in this SQLInputImpl object as a boolean in the Java programming language.
readByte() - Method in interface java.io.DataInput
Reads and returns one input byte.
readByte() - Method in class java.io.DataInputStream
See the general contract of the readByte method of DataInput.
readByte() - Method in class java.io.ObjectInputStream
Reads an 8 bit byte.
readByte() - Method in class java.io.RandomAccessFile
Reads a signed eight-bit value from this file.
readByte() - Method in interface java.sql.SQLInput
Reads the next attribute in the stream and returns it as a byte in the Java programming language.
readByte() - Method in interface javax.imageio.stream.ImageInputStream
Reads a byte from the stream and returns it as a byte value.
readByte() - Method in class javax.imageio.stream.ImageInputStreamImpl
readByte() - Method in class javax.sql.rowset.serial.SQLInputImpl
Retrieves the next attribute in this SQLInputImpl object as a byte in the Java programming language.
readBytes() - Method in interface java.sql.SQLInput
Reads the next attribute in the stream and returns it as an array of bytes in the Java programming language.
readBytes(IIOByteBuffer, int) - Method in interface javax.imageio.stream.ImageInputStream
Reads up to len bytes from the stream, and modifies the supplied IIOByteBuffer to indicate the byte array, offset, and length where the data may be found.
readBytes(IIOByteBuffer, int) - Method in class javax.imageio.stream.ImageInputStreamImpl
readBytes() - Method in class javax.sql.rowset.serial.SQLInputImpl
Retrieves the next attribute in this SQLInputImpl object as an array of bytes.
readChar() - Method in interface java.io.DataInput
Reads two input bytes and returns a char value.
readChar() - Method in class java.io.DataInputStream
See the general contract of the readChar method of DataInput.
readChar() - Method in class java.io.ObjectInputStream
Reads a 16 bit char.
readChar() - Method in class java.io.RandomAccessFile
Reads a character from this file.
readChar() - Method in interface javax.imageio.stream.ImageInputStream
Equivalent to readUnsignedShort, except that the result is returned using the char datatype.
readChar() - Method in class javax.imageio.stream.ImageInputStreamImpl
readCharacterStream() - Method in interface java.sql.SQLInput
Reads the next attribute in the stream and returns it as a stream of Unicode characters.
readCharacterStream() - Method in class javax.sql.rowset.serial.SQLInputImpl
Retrieves the next attribute in this SQLInputImpl object as a stream of Unicode characters.
readChildren(ObjectInputStream) - Method in class java.beans.beancontext.BeanContextSupport
When an instance of this class is used as a delegate for the implementation of the BeanContext protocols (and its subprotocols) there exists a 'chicken and egg' problem during deserialization
readClassDescriptor() - Method in class java.io.ObjectInputStream
Read a class descriptor from the serialization stream.
readClob() - Method in interface java.sql.SQLInput
Reads an SQL CLOB value from the stream and returns it as a Clob object in the Java programming language.
readClob() - Method in class javax.sql.rowset.serial.SQLInputImpl
Retrieves the CLOB value at the head of this SQLInputImpl object as a Clob object in the Java programming language.
readConfiguration() - Method in class java.util.logging.LogManager
Reinitialize the logging properties and reread the logging configuration.
readConfiguration(InputStream) - Method in class java.util.logging.LogManager
Reinitialize the logging properties and reread the logging configuration from the given stream, which should be in java.util.Properties format.
readData(RowSetInternal) - Method in interface javax.sql.RowSetReader
Reads the new contents of the calling RowSet object.
readDate() - Method in interface java.sql.SQLInput
Reads the next attribute in the stream and returns it as a java.sql.Date object.
readDate() - Method in class javax.sql.rowset.serial.SQLInputImpl
Retrieves the next attribute in this SQLInputImpl as a java.sql.Date object.
readDouble() - Method in interface java.io.DataInput
Reads eight input bytes and returns a double value.
readDouble() - Method in class java.io.DataInputStream
See the general contract of the readDouble method of DataInput.
readDouble() - Method in class java.io.ObjectInputStream
Reads a 64 bit double.
readDouble() - Method in class java.io.RandomAccessFile
Reads a double from this file.
readDouble() - Method in interface java.sql.SQLInput
Reads the next attribute in the stream and returns it as a double in the Java programming language.
readDouble() - Method in interface javax.imageio.stream.ImageInputStream
Reads 8 bytes from the stream, and (conceptually) concatenates them according to the current byte order and returns the result as a double.
readDouble() - Method in class javax.imageio.stream.ImageInputStreamImpl
readDouble() - Method in class javax.sql.rowset.serial.SQLInputImpl
Retrieves the next attribute in this SQLInputImpl object as a double in the Java programming language.
readEndpointReference(Source) - Method in class javax.xml.ws.spi.Provider
read an EndpointReference from the infoset contained in eprInfoset.
reader() - Method in class java.io.Console
Retrieves the unique Reader object associated with this console.
Reader - Class in java.io
Abstract class for reading character streams.
Reader() - Constructor for class java.io.Reader
Creates a new character-stream reader whose critical sections will synchronize on the reader itself.
Reader(Object) - Constructor for class java.io.Reader
Creates a new character-stream reader whose critical sections will synchronize on the given object.
READER(String) - Constructor for class javax.print.DocFlavor.READER
Constructs a new doc flavor with the given MIME type and a print data representation class name of\ "java.io.Reader" (character stream).
reader - Variable in class javax.script.SimpleScriptContext
This is the reader to be used for input from scripts.
readerSpiNames - Variable in class javax.imageio.spi.ImageWriterSpi
An array of strings to be returned from getImageReaderSpiNames, initially null.
readerSupportsThumbnails() - Method in class javax.imageio.ImageReader
Returns true if the image format understood by this reader supports thumbnail preview images associated with it.
readExternal(ObjectInput) - Method in class java.awt.datatransfer.DataFlavor
Restores this DataFlavor from a Serialized state.
readExternal(ObjectInput) - Method in interface java.io.Externalizable
The object implements the readExternal method to restore its contents by calling the methods of DataInput for primitive types and readObject for objects, strings and arrays.
readExternal(ObjectInput) - Method in class javax.activation.MimeType
The object implements the readExternal method to restore its contents by calling the methods of DataInput for primitive types and readObject for objects, strings and arrays.
readExternal(ObjectInput) - Method in class javax.management.loading.MLet
Restore this MLet's contents from the given ObjectInput.
readFields() - Method in class java.io.ObjectInputStream
Reads the persistent fields from the stream and makes them available by name.
readFloat() - Method in interface java.io.DataInput
Reads four input bytes and returns a float value.
readFloat() - Method in class java.io.DataInputStream
See the general contract of the readFloat method of DataInput.
readFloat() - Method in class java.io.ObjectInputStream
Reads a 32 bit float.
readFloat() - Method in class java.io.RandomAccessFile
Reads a float from this file.
readFloat() - Method in interface java.sql.SQLInput
Reads the next attribute in the stream and returns it as a float in the Java programming language.
readFloat() - Method in interface javax.imageio.stream.ImageInputStream
Reads 4 bytes from the stream, and (conceptually) concatenates them according to the current byte order and returns the result as a float.
readFloat() - Method in class javax.imageio.stream.ImageInputStreamImpl
readFloat() - Method in class javax.sql.rowset.serial.SQLInputImpl
Retrieves the next attribute in this SQLInputImpl object as a float in the Java programming language.
readFrom(Source) - Static method in class javax.xml.ws.EndpointReference
Factory method to read an EndpointReference from the infoset contained in eprInfoset.
readFully(byte[]) - Method in interface java.io.DataInput
Reads some bytes from an input stream and stores them into the buffer array b.
readFully(byte[], int, int) - Method in interface java.io.DataInput
Reads len bytes from an input stream.
readFully(byte[]) - Method in class java.io.DataInputStream
See the general contract of the readFully method of DataInput.
readFully(byte[], int, int) - Method in class java.io.DataInputStream
See the general contract of the readFully method of DataInput.
readFully(byte[]) - Method in class java.io.ObjectInputStream
Reads bytes, blocking until all bytes are read.
readFully(byte[], int, int) - Method in class java.io.ObjectInputStream
Reads bytes, blocking until all bytes are read.
readFully(byte[]) - Method in class java.io.RandomAccessFile
Reads b.length bytes from this file into the byte array, starting at the current file pointer.
readFully(byte[], int, int) - Method in class java.io.RandomAccessFile
Reads exactly len bytes from this file into the byte array, starting at the current file pointer.
readFully(byte[], int, int) - Method in interface javax.imageio.stream.ImageInputStream
Reads len bytes from the stream, and stores them into b starting at index off.
readFully(byte[]) - Method in interface javax.imageio.stream.ImageInputStream
Reads b.length bytes from the stream, and stores them into b starting at index 0.
readFully(short[], int, int) - Method in interface javax.imageio.stream.ImageInputStream
Reads len shorts (signed 16-bit integers) from the stream according to the current byte order, and stores them into s starting at index off.
readFully(char[], int, int) - Method in interface javax.imageio.stream.ImageInputStream
Reads len chars (unsigned 16-bit integers) from the stream according to the current byte order, and stores them into c starting at index off.
readFully(int[], int, int) - Method in interface javax.imageio.stream.ImageInputStream
Reads len ints (signed 32-bit integers) from the stream according to the current byte order, and stores them into i starting at index off.
readFully(long[], int, int) - Method in interface javax.imageio.stream.ImageInputStream
Reads len longs (signed 64-bit integers) from the stream according to the current byte order, and stores them into l starting at index off.
readFully(float[], int, int) - Method in interface javax.imageio.stream.ImageInputStream
Reads len floats (32-bit IEEE single-precision floats) from the stream according to the current byte order, and stores them into f starting at index off.
readFully(double[], int, int) - Method in interface javax.imageio.stream.ImageInputStream
Reads len doubles (64-bit IEEE double-precision floats) from the stream according to the current byte order, and stores them into d starting at index off.
readFully(byte[], int, int) - Method in class javax.imageio.stream.ImageInputStreamImpl
readFully(byte[]) - Method in class javax.imageio.stream.ImageInputStreamImpl
readFully(short[], int, int) - Method in class javax.imageio.stream.ImageInputStreamImpl
readFully(char[], int, int) - Method in class javax.imageio.stream.ImageInputStreamImpl
readFully(int[], int, int) - Method in class javax.imageio.stream.ImageInputStreamImpl
readFully(long[], int, int) - Method in class javax.imageio.stream.ImageInputStreamImpl
readFully(float[], int, int) - Method in class javax.imageio.stream.ImageInputStreamImpl
readFully(double[], int, int) - Method in class javax.imageio.stream.ImageInputStreamImpl
READING - Static variable in class java.text.AttributedCharacterIterator.Attribute
Attribute key for the reading of some text.
readInt() - Method in interface java.io.DataInput
Reads four input bytes and returns an int value.
readInt() - Method in class java.io.DataInputStream
See the general contract of the readInt method of DataInput.
readInt() - Method in class java.io.ObjectInputStream
Reads a 32 bit int.
readInt() - Method in class java.io.RandomAccessFile
Reads a signed 32-bit integer from this file.
readInt() - Method in interface java.sql.SQLInput
Reads the next attribute in the stream and returns it as an int in the Java programming language.
readInt() - Method in interface javax.imageio.stream.ImageInputStream
Reads 4 bytes from the stream, and (conceptually) concatenates them according to the current byte order and returns the result as an int.
readInt() - Method in class javax.imageio.stream.ImageInputStreamImpl
readInt() - Method in class javax.sql.rowset.serial.SQLInputImpl
Retrieves the next attribute in this SQLInputImpl object as an int in the Java programming language.
readLine() - Method in class java.io.BufferedReader
Reads a line of text.
readLine(String, Object...) - Method in class java.io.Console
Provides a formatted prompt, then reads a single line of text from the console.
readLine() - Method in class java.io.Console
Reads a single line of text from the console.
readLine() - Method in interface java.io.DataInput
Reads the next line of text from the input stream.
readLine() - Method in class java.io.DataInputStream
Deprecated.
This method does not properly convert bytes to characters. As of JDK 1.1, the preferred way to read lines of text is via the BufferedReader.readLine() method. Programs that use the DataInputStream class to read lines can be converted to use the BufferedReader class by replacing code of the form:
     DataInputStream d = new DataInputStream(in);
with:
     BufferedReader d
          = new BufferedReader(new InputStreamReader(in));
readLine() - Method in class java.io.LineNumberReader
Read a line of text.
readLine() - Method in class java.io.ObjectInputStream
Deprecated.
This method does not properly convert bytes to characters. see DataInputStream for the details and alternatives.
readLine() - Method in class java.io.RandomAccessFile
Reads the next line of text from this file.
readLine() - Method in interface javax.imageio.stream.ImageInputStream
Reads the next line of text from the input stream.
readLine() - Method in class javax.imageio.stream.ImageInputStreamImpl
readLock() - Method in interface java.util.concurrent.locks.ReadWriteLock
Returns the lock used for reading.
readLock() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock
ReadLock(ReentrantReadWriteLock) - Constructor for class java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock
Constructor for use by subclasses
readLock() - Method in class java.util.concurrent.locks.StampedLock
Non-exclusively acquires the lock, blocking if necessary until available.
readLock() - Method in class javax.swing.text.AbstractDocument
Acquires a lock to begin reading some state from the document.
readLockInterruptibly() - Method in class java.util.concurrent.locks.StampedLock
Non-exclusively acquires the lock, blocking if necessary until available or the current thread is interrupted.
readLong() - Method in interface java.io.DataInput
Reads eight input bytes and returns a long value.
readLong() - Method in class java.io.DataInputStream
See the general contract of the readLong method of DataInput.
readLong() - Method in class java.io.ObjectInputStream
Reads a 64 bit long.
readLong() - Method in class java.io.RandomAccessFile
Reads a signed 64-bit integer from this file.
readLong() - Method in interface java.sql.SQLInput
Reads the next attribute in the stream and returns it as a long in the Java programming language.
readLong() - Method in interface javax.imageio.stream.ImageInputStream
Reads 8 bytes from the stream, and (conceptually) concatenates them according to the current byte order and returns the result as a long.
readLong() - Method in class javax.imageio.stream.ImageInputStreamImpl
readLong() - Method in class javax.sql.rowset.serial.SQLInputImpl
Retrieves the next attribute in this SQLInputImpl object as a long in the Java programming language.
readNClob() - Method in interface java.sql.SQLInput
Reads an SQL NCLOB value from the stream and returns it as a NClob object in the Java programming language.
readNClob() - Method in class javax.sql.rowset.serial.SQLInputImpl
Reads an SQL NCLOB value from the stream and returns it as a Clob object in the Java programming language.
readNString() - Method in interface java.sql.SQLInput
Reads the next attribute in the stream and returns it as a String in the Java programming language.
readNString() - Method in class javax.sql.rowset.serial.SQLInputImpl
Reads the next attribute in the stream and returns it as a String in the Java programming language.
readObject() - Method in class java.beans.XMLDecoder
Reads the next object from the underlying input stream.
readObject() - Method in interface java.io.ObjectInput
Read and return an object.
readObject() - Method in class java.io.ObjectInputStream
Read an object from the ObjectInputStream.
readObject() - Method in interface java.sql.SQLInput
Reads the datum at the head of the stream and returns it as an Object in the Java programming language.
readObject(Class<T>) - Method in interface java.sql.SQLInput
Reads the next attribute in the stream and returns it as an Object in the Java programming language.
readObject(Stub, ObjectInputStream) - Method in interface javax.rmi.CORBA.StubDelegate
Delegation call for Stub.readObject(java.io.ObjectInputStream).
readObject() - Method in class javax.sql.rowset.serial.SQLInputImpl
Retrieves the value at the head of this SQLInputImpl object as an Object in the Java programming language.
readObjectOverride() - Method in class java.io.ObjectInputStream
This method is called by trusted subclasses of ObjectOutputStream that constructed ObjectOutputStream using the protected no-arg constructor.
readOnlyAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the action to set the editor into read-only mode.
ReadOnlyBufferException - Exception in java.nio
Unchecked exception thrown when a content-mutation method such as put or compact is invoked upon a read-only buffer.
ReadOnlyBufferException() - Constructor for exception java.nio.ReadOnlyBufferException
Constructs an instance of this class.
ReadOnlyFileSystemException - Exception in java.nio.file
Unchecked exception thrown when an attempt is made to update an object associated with a read-only FileSystem.
ReadOnlyFileSystemException() - Constructor for exception java.nio.file.ReadOnlyFileSystemException
Constructs an instance of this class.
readPassword(String, Object...) - Method in class java.io.Console
Provides a formatted prompt, then reads a password or passphrase from the console with echoing disabled.
readPassword() - Method in class java.io.Console
Reads a password or passphrase from the console with echoing disabled
ReadPendingException - Exception in java.nio.channels
Unchecked exception thrown when an attempt is made to read from an asynchronous socket channel and a previous read has not completed.
ReadPendingException() - Constructor for exception java.nio.channels.ReadPendingException
Constructs an instance of this class.
readRaster(int, ImageReadParam) - Method in class javax.imageio.ImageReader
Returns a new Raster object containing the raw pixel data from the image stream, without any color conversion applied.
readRef() - Method in interface java.sql.SQLInput
Reads an SQL REF value from the stream and returns it as a Ref object in the Java programming language.
readRef() - Method in class javax.sql.rowset.serial.SQLInputImpl
Retrieves the value at the head of this SQLInputImpl object as a Ref object in the Java programming language.
readResolve() - Method in class java.awt.AWTKeyStroke
Returns a cached instance of AWTKeyStroke (or a subclass of AWTKeyStroke) which is equal to this instance.
readResolve() - Method in class java.awt.color.ICC_Profile
Resolves instances being deserialized into instances registered with CMM.
readResolve() - Method in class java.awt.font.TextAttribute
Resolves instances being deserialized to the predefined constants.
readResolve() - Method in class java.security.cert.Certificate.CertificateRep
Resolve the Certificate Object.
readResolve() - Method in class java.security.cert.CertPath.CertPathRep
Returns a CertPath constructed from the type and data.
readResolve() - Method in class java.security.KeyRep
Resolve the Key object.
readResolve() - Method in class java.text.AttributedCharacterIterator.Attribute
Resolves instances being deserialized to the predefined constants.
readResolve() - Method in class java.text.DateFormat.Field
Resolves instances being deserialized to the predefined constants.
readResolve() - Method in class java.text.MessageFormat.Field
Resolves instances being deserialized to the predefined constants.
readResolve() - Method in class java.text.NumberFormat.Field
Resolves instances being deserialized to the predefined constants.
readResolve() - Method in class javax.management.openmbean.SimpleType
Replace an object read from an ObjectInputStream with the unique instance for that value.
readResolve() - Method in class javax.print.attribute.EnumSyntax
During object input, convert this deserialized enumeration instance to the proper enumeration value defined in the enumeration attribute class.
readRowId() - Method in interface java.sql.SQLInput
Reads an SQL ROWID value from the stream and returns it as a RowId object in the Java programming language.
readRowId() - Method in class javax.sql.rowset.serial.SQLInputImpl
Reads an SQL ROWID value from the stream and returns it as a RowId object in the Java programming language.
readShort() - Method in interface java.io.DataInput
Reads two input bytes and returns a short value.
readShort() - Method in class java.io.DataInputStream
See the general contract of the readShort method of DataInput.
readShort() - Method in class java.io.ObjectInputStream
Reads a 16 bit short.
readShort() - Method in class java.io.RandomAccessFile
Reads a signed 16-bit number from this file.
readShort() - Method in interface java.sql.SQLInput
Reads the next attribute in the stream and returns it as a short in the Java programming language.
readShort() - Method in interface javax.imageio.stream.ImageInputStream
Reads two bytes from the stream, and (conceptually) concatenates them according to the current byte order, and returns the result as a short value.
readShort() - Method in class javax.imageio.stream.ImageInputStreamImpl
readShort() - Method in class javax.sql.rowset.serial.SQLInputImpl
Retrieves the next attribute in this SQLInputImpl object as a short in the Java programming language.
readSQL(SQLInput, String) - Method in interface java.sql.SQLData
Populates this object with data read from the database.
readSQLXML() - Method in interface java.sql.SQLInput
Reads an SQL XML value from the stream and returns it as a SQLXML object in the Java programming language.
readSQLXML() - Method in class javax.sql.rowset.serial.SQLInputImpl
Reads an SQL XML value from the stream and returns it as a SQLXML object in the Java programming language.
readStreamHeader() - Method in class java.io.ObjectInputStream
The readStreamHeader method is provided to allow subclasses to read and verify their own stream headers.
readString() - Method in interface java.sql.SQLInput
Reads the next attribute in the stream and returns it as a String in the Java programming language.
readString() - Method in class javax.sql.rowset.serial.SQLInputImpl
Retrieves the next attribute in this SQLInputImpl object as a String in the Java programming language.
readSymbolicLink(Path) - Static method in class java.nio.file.Files
Reads the target of a symbolic link (optional operation).
readSymbolicLink(Path) - Method in class java.nio.file.spi.FileSystemProvider
Reads the target of a symbolic link.
readThumbnail(int, int) - Method in class javax.imageio.ImageReader
Returns the thumbnail preview image indexed by thumbnailIndex, associated with the image indexed by ImageIndex as a BufferedImage.
readTile(int, int, int) - Method in class javax.imageio.ImageReader
Reads the tile indicated by the tileX and tileY arguments, returning it as a BufferedImage.
readTileRaster(int, int, int) - Method in class javax.imageio.ImageReader
Returns a new Raster object containing the raw pixel data from the tile, without any color conversion applied.
readTime() - Method in interface java.sql.SQLInput
Reads the next attribute in the stream and returns it as a java.sql.Time object.
readTime() - Method in class javax.sql.rowset.serial.SQLInputImpl
Retrieves the next attribute in this SQLInputImpl object as a java.sql.Time object.
readTimestamp() - Method in interface java.sql.SQLInput
Reads the next attribute in the stream and returns it as a java.sql.Timestamp object.
readTimestamp() - Method in class javax.sql.rowset.serial.SQLInputImpl
Retrieves the next attribute in this SQLInputImpl object as a java.sql.Timestamp object.
readUnlock() - Method in class javax.swing.text.AbstractDocument
Does a read unlock.
readUnshared() - Method in class java.io.ObjectInputStream
Reads an "unshared" object from the ObjectInputStream.
readUnsignedByte() - Method in interface java.io.DataInput
Reads one input byte, zero-extends it to type int, and returns the result, which is therefore in the range 0 through 255.
readUnsignedByte() - Method in class java.io.DataInputStream
See the general contract of the readUnsignedByte method of DataInput.
readUnsignedByte() - Method in class java.io.ObjectInputStream
Reads an unsigned 8 bit byte.
readUnsignedByte() - Method in class java.io.RandomAccessFile
Reads an unsigned eight-bit number from this file.
readUnsignedByte() - Method in interface javax.imageio.stream.ImageInputStream
Reads a byte from the stream, and (conceptually) converts it to an int, masks it with 0xff in order to strip off any sign-extension bits, and returns it as a byte value.
readUnsignedByte() - Method in class javax.imageio.stream.ImageInputStreamImpl
readUnsignedInt() - Method in interface javax.imageio.stream.ImageInputStream
Reads 4 bytes from the stream, and (conceptually) concatenates them according to the current byte order, converts the result to a long, masks it with 0xffffffffL in order to strip off any sign-extension bits, and returns the result as an unsigned long value.
readUnsignedInt() - Method in class javax.imageio.stream.ImageInputStreamImpl
readUnsignedShort() - Method in interface java.io.DataInput
Reads two input bytes and returns an int value in the range 0 through 65535.
readUnsignedShort() - Method in class java.io.DataInputStream
See the general contract of the readUnsignedShort method of DataInput.
readUnsignedShort() - Method in class java.io.ObjectInputStream
Reads an unsigned 16 bit short.
readUnsignedShort() - Method in class java.io.RandomAccessFile
Reads an unsigned 16-bit number from this file.
readUnsignedShort() - Method in interface javax.imageio.stream.ImageInputStream
Reads two bytes from the stream, and (conceptually) concatenates them according to the current byte order, converts the resulting value to an int, masks it with 0xffff in order to strip off any sign-extension buts, and returns the result as an unsigned int value.
readUnsignedShort() - Method in class javax.imageio.stream.ImageInputStreamImpl
readURL() - Method in interface java.sql.SQLInput
Reads an SQL DATALINK value from the stream and returns it as a java.net.URL object in the Java programming language.
readURL() - Method in class javax.sql.rowset.serial.SQLInputImpl
Reads an SQL DATALINK value from the stream and returns it as an URL object in the Java programming language.
readUTF() - Method in interface java.io.DataInput
Reads in a string that has been encoded using a modified UTF-8 format.
readUTF() - Method in class java.io.DataInputStream
See the general contract of the readUTF method of DataInput.
readUTF(DataInput) - Static method in class java.io.DataInputStream
Reads from the stream in a representation of a Unicode character string encoded in modified UTF-8 format; this string of characters is then returned as a String.
readUTF() - Method in class java.io.ObjectInputStream
Reads a String in modified UTF-8 format.
readUTF() - Method in class java.io.RandomAccessFile
Reads in a string from this file.
readUTF() - Method in interface javax.imageio.stream.ImageInputStream
Reads in a string that has been encoded using a modified UTF-8 format.
readUTF() - Method in class javax.imageio.stream.ImageInputStreamImpl
readValue(InputStream, int, Class, String, RunTime) - Method in interface javax.rmi.CORBA.ValueHandler
Reads a value from the stream using Java semantics.
ReadWriteLock - Interface in java.util.concurrent.locks
A ReadWriteLock maintains a pair of associated locks, one for read-only operations and one for writing.
readXML(WebRowSet, Reader) - Method in interface javax.sql.rowset.spi.XmlReader
Reads and parses the given WebRowSet object from the given input stream in XML format.
readXml(Reader) - Method in interface javax.sql.rowset.WebRowSet
Reads a WebRowSet object in its XML format from the given Reader object.
readXml(InputStream) - Method in interface javax.sql.rowset.WebRowSet
Reads a stream based XML input to populate this WebRowSet object.
ready() - Method in class java.io.BufferedReader
Tells whether this stream is ready to be read.
ready() - Method in class java.io.CharArrayReader
Tells whether this stream is ready to be read.
ready() - Method in class java.io.FilterReader
Tells whether this stream is ready to be read.
ready() - Method in class java.io.InputStreamReader
Tells whether this stream is ready to be read.
ready() - Method in class java.io.PipedReader
Tell whether this stream is ready to be read.
ready() - Method in class java.io.PushbackReader
Tells whether this stream is ready to be read.
ready() - Method in class java.io.Reader
Tells whether this stream is ready to be read.
ready() - Method in class java.io.StringReader
Tells whether this stream is ready to be read.
readyOps() - Method in class java.nio.channels.SelectionKey
Retrieves this key's ready-operation set.
REAL - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type REAL.
realEditor - Variable in class javax.swing.tree.DefaultTreeCellEditor
Editor handling the editing.
RealmCallback - Class in javax.security.sasl
This callback is used by SaslClient and SaslServer to retrieve realm information.
RealmCallback(String) - Constructor for class javax.security.sasl.RealmCallback
Constructs a RealmCallback with a prompt.
RealmCallback(String, String) - Constructor for class javax.security.sasl.RealmCallback
Constructs a RealmCallback with a prompt and default realm information.
RealmChoiceCallback - Class in javax.security.sasl
This callback is used by SaslClient and SaslServer to obtain a realm given a list of realm choices.
RealmChoiceCallback(String, String[], int, boolean) - Constructor for class javax.security.sasl.RealmChoiceCallback
Constructs a RealmChoiceCallback with a prompt, a list of choices and a default choice.
realSource - Variable in class javax.swing.undo.UndoableEditSupport
reason - Variable in exception org.omg.CORBA.PolicyError
The reason for the PolicyError exception being thrown.
rebind(String, Remote) - Static method in class java.rmi.Naming
Rebinds the specified name to a new remote object.
rebind(String, Remote) - Method in interface java.rmi.registry.Registry
Replaces the binding for the specified name in this registry with the supplied remote reference.
rebind(Name, Object) - Method in interface javax.naming.Context
Binds a name to an object, overwriting any existing binding.
rebind(String, Object) - Method in interface javax.naming.Context
Binds a name to an object, overwriting any existing binding.
rebind(Name, Object, Attributes) - Method in interface javax.naming.directory.DirContext
Binds a name to an object, along with associated attributes, overwriting any existing binding.
rebind(String, Object, Attributes) - Method in interface javax.naming.directory.DirContext
Binds a name to an object, along with associated attributes, overwriting any existing binding.
rebind(String, Object, Attributes) - Method in class javax.naming.directory.InitialDirContext
rebind(Name, Object, Attributes) - Method in class javax.naming.directory.InitialDirContext
rebind(String, Object) - Method in class javax.naming.InitialContext
rebind(Name, Object) - Method in class javax.naming.InitialContext
REBIND - Exception in org.omg.CORBA
REBIND is raised when the current effective RebindPolicy, has a value of NO_REBIND or NO_RECONNECT and an invocation on a bound object reference results in a LocateReply message with status OBJECT_FORWARD or a Reply message with status LOCATION_FORWARD.
REBIND() - Constructor for exception org.omg.CORBA.REBIND
Constructs an REBIND exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.
REBIND(String) - Constructor for exception org.omg.CORBA.REBIND
Constructs an REBIND exception with the specified message.
REBIND(int, CompletionStatus) - Constructor for exception org.omg.CORBA.REBIND
Constructs an REBIND exception with the specified minor code and completion status.
REBIND(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.REBIND
Constructs an REBIND exception with the specified message, minor code, and completion status.
rebind(NameComponent[], Object) - Method in class org.omg.CosNaming._NamingContextExtStub
Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
rebind(NameComponent[], Object) - Method in class org.omg.CosNaming._NamingContextStub
Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
rebind(NameComponent[], Object) - Method in interface org.omg.CosNaming.NamingContextOperations
Creates a binding of a name and an object in the naming context even if the name is already bound in the context.
rebind_context(NameComponent[], NamingContext) - Method in class org.omg.CosNaming._NamingContextExtStub
Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
rebind_context(NameComponent[], NamingContext) - Method in class org.omg.CosNaming._NamingContextStub
Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
rebind_context(NameComponent[], NamingContext) - Method in interface org.omg.CosNaming.NamingContextOperations
Creates a binding of a name and a naming context in the naming context even if the name is already bound in the context.
recalculateIfInsetsChanged() - Method in class javax.swing.plaf.basic.BasicSliderUI
recalculateIfInsetsChanged() - Method in class javax.swing.plaf.synth.SynthSliderUI
recalculateIfOrientationChanged() - Method in class javax.swing.plaf.basic.BasicSliderUI
recalcWidthCache() - Method in class javax.swing.table.DefaultTableColumnModel
Recalculates the total combined width of all columns.
receive(int) - Method in class java.io.PipedInputStream
Receives a byte of data.
receive(DatagramPacket) - Method in class java.net.DatagramSocket
Receives a datagram packet from this socket.
receive(DatagramPacket) - Method in class java.net.DatagramSocketImpl
Receive the datagram packet.
receive(ByteBuffer) - Method in class java.nio.channels.DatagramChannel
Receives a datagram via this channel.
receive_exception(ClientRequestInfo) - Method in interface org.omg.PortableInterceptor.ClientRequestInterceptorOperations
Indicates to the interceptor that an exception occurred.
receive_other(ClientRequestInfo) - Method in interface org.omg.PortableInterceptor.ClientRequestInterceptorOperations
Allows an Interceptor to query the information available when a request results in something other than a normal reply or an exception.
receive_reply(ClientRequestInfo) - Method in interface org.omg.PortableInterceptor.ClientRequestInterceptorOperations
Allows an Interceptor to query the information on a reply after it is returned from the server and before control is returned to the client.
receive_request(ServerRequestInfo) - Method in interface org.omg.PortableInterceptor.ServerRequestInterceptorOperations
Allows an Interceptor to query request information after all the information, including operation parameters, are available.
receive_request_service_contexts(ServerRequestInfo) - Method in interface org.omg.PortableInterceptor.ServerRequestInterceptorOperations
Allows the interceptor to process service context information.
received_exception() - Method in interface org.omg.PortableInterceptor.ClientRequestInfoOperations
Returns an any which contains the exception to be returned to the client.
received_exception_id() - Method in interface org.omg.PortableInterceptor.ClientRequestInfoOperations
Returns the repository id of the exception to be returned to the client.
Receiver - Interface in javax.sound.midi
A Receiver receives MidiEvent objects and typically does something useful in response, such as interpreting them to generate sound or raw MIDI output.
reclaim(AttributeSet) - Method in interface javax.swing.text.AbstractDocument.AttributeContext
Reclaims an attribute set.
reclaim(AttributeSet) - Method in class javax.swing.text.StyleContext
Returns a set no longer needed by the MutableAttributeSet implementation.
reconnect(Control[]) - Method in class javax.naming.ldap.InitialLdapContext
reconnect(Control[]) - Method in interface javax.naming.ldap.LdapContext
Reconnects to the LDAP server using the supplied controls and this context's environment.
reconvert() - Method in class java.awt.im.InputContext
Asks the current input method to reconvert text from the current client component.
reconvert() - Method in interface java.awt.im.spi.InputMethod
Starts the reconversion operation.
recordDisable(Track) - Method in interface javax.sound.midi.Sequencer
Disables recording to the specified track.
recordEnable(Track, int) - Method in interface javax.sound.midi.Sequencer
Prepares the specified track for recording events received on a particular channel.
recover(int) - Method in interface javax.transaction.xa.XAResource
Obtains a list of prepared transaction branches from a resource manager.
Rectangle - Class in java.awt
A Rectangle specifies an area in a coordinate space that is enclosed by the Rectangle object's upper-left point (x,y) in the coordinate space, its width, and its height.
Rectangle() - Constructor for class java.awt.Rectangle
Constructs a new Rectangle whose upper-left corner is at (0, 0) in the coordinate space, and whose width and height are both zero.
Rectangle(Rectangle) - Constructor for class java.awt.Rectangle
Constructs a new Rectangle, initialized to match the values of the specified Rectangle.
Rectangle(int, int, int, int) - Constructor for class java.awt.Rectangle
Constructs a new Rectangle whose upper-left corner is specified as (x,y) and whose width and height are specified by the arguments of the same name.
Rectangle(int, int) - Constructor for class java.awt.Rectangle
Constructs a new Rectangle whose upper-left corner is at (0, 0) in the coordinate space, and whose width and height are specified by the arguments of the same name.
Rectangle(Point, Dimension) - Constructor for class java.awt.Rectangle
Constructs a new Rectangle whose upper-left corner is specified by the Point argument, and whose width and height are specified by the Dimension argument.
Rectangle(Point) - Constructor for class java.awt.Rectangle
Constructs a new Rectangle whose upper-left corner is the specified Point, and whose width and height are both zero.
Rectangle(Dimension) - Constructor for class java.awt.Rectangle
Constructs a new Rectangle whose top left corner is (0, 0) and whose width and height are specified by the Dimension argument.
Rectangle2D - Class in java.awt.geom
The Rectangle2D class describes a rectangle defined by a location (x,y) and dimension (w x h).
Rectangle2D() - Constructor for class java.awt.geom.Rectangle2D
This is an abstract class that cannot be instantiated directly.
Rectangle2D.Double - Class in java.awt.geom
The Double class defines a rectangle specified in double coordinates.
Rectangle2D.Float - Class in java.awt.geom
The Float class defines a rectangle specified in float coordinates.
rectangleForCurrentValue() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Returns the area that is reserved for drawing the currently selected item.
RectangularShape - Class in java.awt.geom
RectangularShape is the base class for a number of Shape objects whose geometry is defined by a rectangular frame.
RectangularShape() - Constructor for class java.awt.geom.RectangularShape
This is an abstract class that cannot be instantiated directly.
rects - Variable in class javax.swing.plaf.basic.BasicTabbedPaneUI
RecursiveAction - Class in java.util.concurrent
A recursive resultless ForkJoinTask.
RecursiveAction() - Constructor for class java.util.concurrent.RecursiveAction
RecursiveTask<V> - Class in java.util.concurrent
A recursive result-bearing ForkJoinTask.
RecursiveTask() - Constructor for class java.util.concurrent.RecursiveTask
recycleNode() - Method in interface javax.xml.soap.Node
Notifies the implementation that this Node object is no longer being used by the application and that the implementation is free to reuse this object for nodes that may be created later.
red - Static variable in class java.awt.Color
The color red.
RED - Static variable in class java.awt.Color
The color red.
REDCOMPONENT - Static variable in class java.awt.color.ICC_ProfileRGB
Used to get a gamma value or TRC for the red component.
redefineClasses(ClassDefinition...) - Method in interface java.lang.instrument.Instrumentation
Redefine the supplied set of classes using the supplied class files.
redirectError(ProcessBuilder.Redirect) - Method in class java.lang.ProcessBuilder
Sets this process builder's standard error destination.
redirectError(File) - Method in class java.lang.ProcessBuilder
Sets this process builder's standard error destination to a file.
redirectError() - Method in class java.lang.ProcessBuilder
Returns this process builder's standard error destination.
redirectErrorStream() - Method in class java.lang.ProcessBuilder
Tells whether this process builder merges standard error and standard output.
redirectErrorStream(boolean) - Method in class java.lang.ProcessBuilder
Sets this process builder's redirectErrorStream property.
redirectInput(ProcessBuilder.Redirect) - Method in class java.lang.ProcessBuilder
Sets this process builder's standard input source.
redirectInput(File) - Method in class java.lang.ProcessBuilder
Sets this process builder's standard input source to a file.
redirectInput() - Method in class java.lang.ProcessBuilder
Returns this process builder's standard input source.
redirectOutput(ProcessBuilder.Redirect) - Method in class java.lang.ProcessBuilder
Sets this process builder's standard output destination.
redirectOutput(File) - Method in class java.lang.ProcessBuilder
Sets this process builder's standard output destination to a file.
redirectOutput() - Method in class java.lang.ProcessBuilder
Returns this process builder's standard output destination.
redispatchEvent(Component, AWTEvent) - Method in class java.awt.KeyboardFocusManager
Redispatches an AWTEvent in such a way that the AWT event dispatcher will not recursively request that the KeyboardFocusManager, or any installed KeyEventDispatchers, dispatch the event again.
redo() - Method in class javax.swing.text.AbstractDocument.DefaultDocumentEvent
Redoes a change.
redo() - Method in class javax.swing.text.AbstractDocument.ElementEdit
Redoes a change.
redo() - Method in class javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit
Redoes a change.
redo() - Method in class javax.swing.undo.AbstractUndoableEdit
Throws CannotRedoException if canRedo returns false.
redo() - Method in class javax.swing.undo.CompoundEdit
Sends redo to all contained UndoableEdits in the order in which they were added.
redo() - Method in class javax.swing.undo.StateEdit
Tells the edited object to apply the state after the edit
redo() - Method in interface javax.swing.undo.UndoableEdit
Re-applies the edit.
redo() - Method in class javax.swing.undo.UndoManager
Redoes the appropriate edits.
RedoName - Static variable in class javax.swing.undo.AbstractUndoableEdit
String returned by getRedoPresentationName; as of Java 2 platform v1.3.1 this field is no longer used.
redoTo(UndoableEdit) - Method in class javax.swing.undo.UndoManager
Redoes all changes from the index of the next edit to edit, updating the index of the next edit appropriately.
reduce(long, BiFunction<? super K, ? super V, ? extends U>, BiFunction<? super U, ? super U, ? extends U>) - Method in class java.util.concurrent.ConcurrentHashMap
Returns the result of accumulating the given transformation of all (key, value) pairs using the given reducer to combine values, or null if none.
reduce(double, DoubleBinaryOperator) - Method in interface java.util.stream.DoubleStream
Performs a reduction on the elements of this stream, using the provided identity value and an associative accumulation function, and returns the reduced value.
reduce(DoubleBinaryOperator) - Method in interface java.util.stream.DoubleStream
Performs a reduction on the elements of this stream, using an associative accumulation function, and returns an OptionalDouble describing the reduced value, if any.
reduce(int, IntBinaryOperator) - Method in interface java.util.stream.IntStream
Performs a reduction on the elements of this stream, using the provided identity value and an associative accumulation function, and returns the reduced value.
reduce(IntBinaryOperator) - Method in interface java.util.stream.IntStream
Performs a reduction on the elements of this stream, using an associative accumulation function, and returns an OptionalInt describing the reduced value, if any.
reduce(long, LongBinaryOperator) - Method in interface java.util.stream.LongStream
Performs a reduction on the elements of this stream, using the provided identity value and an associative accumulation function, and returns the reduced value.
reduce(LongBinaryOperator) - Method in interface java.util.stream.LongStream
Performs a reduction on the elements of this stream, using an associative accumulation function, and returns an OptionalLong describing the reduced value, if any.
reduce(T, BinaryOperator<T>) - Method in interface java.util.stream.Stream
Performs a reduction on the elements of this stream, using the provided identity value and an associative accumulation function, and returns the reduced value.
reduce(BinaryOperator<T>) - Method in interface java.util.stream.Stream
Performs a reduction on the elements of this stream, using an associative accumulation function, and returns an Optional describing the reduced value, if any.
reduce(U, BiFunction<U, ? super T, U>, BinaryOperator<U>) - Method in interface java.util.stream.Stream
Performs a reduction on the elements of this stream, using the provided identity, accumulation and combining functions.
reduceEntries(long, BiFunction<Map.Entry<K, V>, Map.Entry<K, V>, ? extends Map.Entry<K, V>>) - Method in class java.util.concurrent.ConcurrentHashMap
Returns the result of accumulating all entries using the given reducer to combine values, or null if none.
reduceEntries(long, Function<Map.Entry<K, V>, ? extends U>, BiFunction<? super U, ? super U, ? extends U>) - Method in class java.util.concurrent.ConcurrentHashMap
Returns the result of accumulating the given transformation of all entries using the given reducer to combine values, or null if none.
reduceEntriesToDouble(long, ToDoubleFunction<Map.Entry<K, V>>, double, DoubleBinaryOperator) - Method in class java.util.concurrent.ConcurrentHashMap
Returns the result of accumulating the given transformation of all entries using the given reducer to combine values, and the given basis as an identity value.
reduceEntriesToInt(long, ToIntFunction<Map.Entry<K, V>>, int, IntBinaryOperator) - Method in class java.util.concurrent.ConcurrentHashMap
Returns the result of accumulating the given transformation of all entries using the given reducer to combine values, and the given basis as an identity value.
reduceEntriesToLong(long, ToLongFunction<Map.Entry<K, V>>, long, LongBinaryOperator) - Method in class java.util.concurrent.ConcurrentHashMap
Returns the result of accumulating the given transformation of all entries using the given reducer to combine values, and the given basis as an identity value.
reduceKeys(long, BiFunction<? super K, ? super K, ? extends K>) - Method in class java.util.concurrent.ConcurrentHashMap
Returns the result of accumulating all keys using the given reducer to combine values, or null if none.
reduceKeys(long, Function<? super K, ? extends U>, BiFunction<? super U, ? super U, ? extends U>) - Method in class java.util.concurrent.ConcurrentHashMap
Returns the result of accumulating the given transformation of all keys using the given reducer to combine values, or null if none.
reduceKeysToDouble(long, ToDoubleFunction<? super K>, double, DoubleBinaryOperator) - Method in class java.util.concurrent.ConcurrentHashMap
Returns the result of accumulating the given transformation of all keys using the given reducer to combine values, and the given basis as an identity value.
reduceKeysToInt(long, ToIntFunction<? super K>, int, IntBinaryOperator) - Method in class java.util.concurrent.ConcurrentHashMap
Returns the result of accumulating the given transformation of all keys using the given reducer to combine values, and the given basis as an identity value.
reduceKeysToLong(long, ToLongFunction<? super K>, long, LongBinaryOperator) - Method in class java.util.concurrent.ConcurrentHashMap
Returns the result of accumulating the given transformation of all keys using the given reducer to combine values, and the given basis as an identity value.
reducePermits(int) - Method in class java.util.concurrent.Semaphore
Shrinks the number of available permits by the indicated reduction.
reduceToDouble(long, ToDoubleBiFunction<? super K, ? super V>, double, DoubleBinaryOperator) - Method in class java.util.concurrent.ConcurrentHashMap
Returns the result of accumulating the given transformation of all (key, value) pairs using the given reducer to combine values, and the given basis as an identity value.
reduceToInt(long, ToIntBiFunction<? super K, ? super V>, int, IntBinaryOperator) - Method in class java.util.concurrent.ConcurrentHashMap
Returns the result of accumulating the given transformation of all (key, value) pairs using the given reducer to combine values, and the given basis as an identity value.
reduceToLong(long, ToLongBiFunction<? super K, ? super V>, long, LongBinaryOperator) - Method in class java.util.concurrent.ConcurrentHashMap
Returns the result of accumulating the given transformation of all (key, value) pairs using the given reducer to combine values, and the given basis as an identity value.
reduceValues(long, BiFunction<? super V, ? super V, ? extends V>) - Method in class java.util.concurrent.ConcurrentHashMap
Returns the result of accumulating all values using the given reducer to combine values, or null if none.
reduceValues(long, Function<? super V, ? extends U>, BiFunction<? super U, ? super U, ? extends U>) - Method in class java.util.concurrent.ConcurrentHashMap
Returns the result of accumulating the given transformation of all values using the given reducer to combine values, or null if none.
reduceValuesToDouble(long, ToDoubleFunction<? super V>, double, DoubleBinaryOperator) - Method in class java.util.concurrent.ConcurrentHashMap
Returns the result of accumulating the given transformation of all values using the given reducer to combine values, and the given basis as an identity value.
reduceValuesToInt(long, ToIntFunction<? super V>, int, IntBinaryOperator) - Method in class java.util.concurrent.ConcurrentHashMap
Returns the result of accumulating the given transformation of all values using the given reducer to combine values, and the given basis as an identity value.
reduceValuesToLong(long, ToLongFunction<? super V>, long, LongBinaryOperator) - Method in class java.util.concurrent.ConcurrentHashMap
Returns the result of accumulating the given transformation of all values using the given reducer to combine values, and the given basis as an identity value.
reducing(T, BinaryOperator<T>) - Static method in class java.util.stream.Collectors
Returns a Collector which performs a reduction of its input elements under a specified BinaryOperator using the provided identity.
reducing(BinaryOperator<T>) - Static method in class java.util.stream.Collectors
Returns a Collector which performs a reduction of its input elements under a specified BinaryOperator.
reducing(U, Function<? super T, ? extends U>, BinaryOperator<U>) - Static method in class java.util.stream.Collectors
Returns a Collector which performs a reduction of its input elements under a specified mapping function and BinaryOperator.
ReentrantLock - Class in java.util.concurrent.locks
A reentrant mutual exclusion Lock with the same basic behavior and semantics as the implicit monitor lock accessed using synchronized methods and statements, but with extended capabilities.
ReentrantLock() - Constructor for class java.util.concurrent.locks.ReentrantLock
Creates an instance of ReentrantLock.
ReentrantLock(boolean) - Constructor for class java.util.concurrent.locks.ReentrantLock
Creates an instance of ReentrantLock with the given fairness policy.
ReentrantReadWriteLock - Class in java.util.concurrent.locks
An implementation of ReadWriteLock supporting similar semantics to ReentrantLock.
ReentrantReadWriteLock() - Constructor for class java.util.concurrent.locks.ReentrantReadWriteLock
Creates a new ReentrantReadWriteLock with default (nonfair) ordering properties.
ReentrantReadWriteLock(boolean) - Constructor for class java.util.concurrent.locks.ReentrantReadWriteLock
Creates a new ReentrantReadWriteLock with the given fairness policy.
ReentrantReadWriteLock.ReadLock - Class in java.util.concurrent.locks
The lock returned by method ReentrantReadWriteLock.readLock().
ReentrantReadWriteLock.WriteLock - Class in java.util.concurrent.locks
The lock returned by method ReentrantReadWriteLock.writeLock().
ref - Variable in class java.rmi.server.RemoteObject
The object's remote reference.
Ref - Interface in java.sql
The mapping in the Java programming language of an SQL REF value, which is a reference to an SQL structured type value in the database.
REF - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type REF.
REF_CURSOR - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type REF CURSOR.
REF_getField - Static variable in interface java.lang.invoke.MethodHandleInfo
A direct method handle reference kind, as defined in the table above.
REF_getStatic - Static variable in interface java.lang.invoke.MethodHandleInfo
A direct method handle reference kind, as defined in the table above.
REF_invokeInterface - Static variable in interface java.lang.invoke.MethodHandleInfo
A direct method handle reference kind, as defined in the table above.
REF_invokeSpecial - Static variable in interface java.lang.invoke.MethodHandleInfo
A direct method handle reference kind, as defined in the table above.
REF_invokeStatic - Static variable in interface java.lang.invoke.MethodHandleInfo
A direct method handle reference kind, as defined in the table above.
REF_invokeVirtual - Static variable in interface java.lang.invoke.MethodHandleInfo
A direct method handle reference kind, as defined in the table above.
REF_MBEAN_NOT_REGISTERED - Static variable in class javax.management.relation.RoleStatus
Problem type when trying to set a role value including the ObjectName of a MBean not registered in the MBean Server.
REF_MBEAN_OF_INCORRECT_CLASS - Static variable in class javax.management.relation.RoleStatus
Problem type when trying to set a role value including the ObjectName of a MBean not of the class expected for that role.
REF_newInvokeSpecial - Static variable in interface java.lang.invoke.MethodHandleInfo
A direct method handle reference kind, as defined in the table above.
REF_putField - Static variable in interface java.lang.invoke.MethodHandleInfo
A direct method handle reference kind, as defined in the table above.
REF_putStatic - Static variable in interface java.lang.invoke.MethodHandleInfo
A direct method handle reference kind, as defined in the table above.
RefAddr - Class in javax.naming
This class represents the address of a communications end-point.
RefAddr(String) - Constructor for class javax.naming.RefAddr
Constructs a new instance of RefAddr using its address type.
Reference<T> - Class in java.lang.ref
Abstract base class for reference objects.
Reference - Class in javax.naming
This class represents a reference to an object that is found outside of the naming/directory system.
Reference(String) - Constructor for class javax.naming.Reference
Constructs a new reference for an object with class name 'className'.
Reference(String, RefAddr) - Constructor for class javax.naming.Reference
Constructs a new reference for an object with class name 'className' and an address.
Reference(String, String, String) - Constructor for class javax.naming.Reference
Constructs a new reference for an object with class name 'className', and the class name and location of the object's factory.
Reference(String, RefAddr, String, String) - Constructor for class javax.naming.Reference
Constructs a new reference for an object with class name 'className', the class name and location of the object's factory, and the address for the object.
Reference - Interface in javax.xml.crypto.dsig
A representation of the Reference element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
REFERENCE_PARAMETERS - Static variable in interface javax.xml.ws.handler.MessageContext
Standard property: WS Addressing Reference Parameters.
reference_to_id(Object) - Method in interface org.omg.PortableServer.POAOperations
This operation returns the Object Id value encapsulated by the specified reference.
reference_to_servant(Object) - Method in interface org.omg.PortableServer.POAOperations
If the POA has the RETAIN policy and the specified object is present in the Active Object Map, this operation returns the servant associated with that object in the Active Object Map.
Referenceable - Interface in javax.naming
This interface is implemented by an object that can provide a Reference to itself.
referenceKindToString(int) - Static method in interface java.lang.invoke.MethodHandleInfo
Returns the descriptive name of the given reference kind, as defined in the table above.
referenceParameter(Element) - Method in class javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder
Adds the referenceParameter to the W3CEndpointReference instance wsa:ReferenceParameters element.
ReferenceQueue<T> - Class in java.lang.ref
Reference queues, to which registered reference objects are appended by the garbage collector after the appropriate reachability changes are detected.
ReferenceQueue() - Constructor for class java.lang.ref.ReferenceQueue
Constructs a new reference-object queue.
ReferenceType - Interface in javax.lang.model.type
Represents a reference type.
ReferenceUriSchemesSupported - Class in javax.print.attribute.standard
Class ReferenceUriSchemesSupported is a printing attribute class an enumeration, that indicates a "URI scheme," such as "http:" or "ftp:", that a printer can use to retrieve print data stored at a URI location.
ReferenceUriSchemesSupported(int) - Constructor for class javax.print.attribute.standard.ReferenceUriSchemesSupported
Construct a new reference URI scheme enumeration value with the given integer value.
REFERRAL - Static variable in interface javax.naming.Context
Constant that holds the name of the environment property for specifying how referrals encountered by the service provider are to be processed.
ReferralException - Exception in javax.naming
This abstract class is used to represent a referral exception, which is generated in response to a referral such as that returned by LDAP v3 servers.
ReferralException(String) - Constructor for exception javax.naming.ReferralException
Constructs a new instance of ReferralException using the explanation supplied.
ReferralException() - Constructor for exception javax.naming.ReferralException
Constructs a new instance of ReferralException.
reflectAs(Class<T>, MethodHandles.Lookup) - Method in interface java.lang.invoke.MethodHandleInfo
Reflects the underlying member as a method, constructor, or field object.
reflectAs(Class<T>, MethodHandle) - Static method in class java.lang.invoke.MethodHandles
Performs an unchecked "crack" of a direct method handle.
ReflectionException - Exception in javax.management
Represents exceptions thrown in the MBean server when using the java.lang.reflect classes to invoke methods on MBeans.
ReflectionException(Exception) - Constructor for exception javax.management.ReflectionException
Creates a ReflectionException that wraps the actual java.lang.Exception.
ReflectionException(Exception, String) - Constructor for exception javax.management.ReflectionException
Creates a ReflectionException that wraps the actual java.lang.Exception with a detail message.
ReflectiveOperationException - Exception in java.lang
Common superclass of exceptions thrown by reflective operations in core reflection.
ReflectiveOperationException() - Constructor for exception java.lang.ReflectiveOperationException
Constructs a new exception with null as its detail message.
ReflectiveOperationException(String) - Constructor for exception java.lang.ReflectiveOperationException
Constructs a new exception with the specified detail message.
ReflectiveOperationException(String, Throwable) - Constructor for exception java.lang.ReflectiveOperationException
Constructs a new exception with the specified detail message and cause.
ReflectiveOperationException(Throwable) - Constructor for exception java.lang.ReflectiveOperationException
Constructs a new exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
ReflectPermission - Class in java.lang.reflect
The Permission class for reflective operations.
ReflectPermission(String) - Constructor for class java.lang.reflect.ReflectPermission
Constructs a ReflectPermission with the specified name.
ReflectPermission(String, String) - Constructor for class java.lang.reflect.ReflectPermission
Constructs a ReflectPermission with the specified name and actions.
refresh() - Method in class java.security.Policy
Refreshes/reloads the policy configuration.
refresh() - Static method in class java.time.zone.ZoneRulesProvider
Refreshes the rules from the underlying data provider.
refresh() - Method in class javax.security.auth.kerberos.KerberosTicket
Extends the validity period of this ticket.
refresh() - Method in class javax.security.auth.login.Configuration
Refresh and reload the Configuration.
refresh() - Method in class javax.security.auth.Policy
Deprecated.
Refresh and reload the Policy.
refresh() - Method in interface javax.security.auth.Refreshable
Update or extend the validity period for this Object.
REFRESH_RATE_UNKNOWN - Static variable in class java.awt.DisplayMode
Value of the refresh rate if not known.
Refreshable - Interface in javax.security.auth
Objects such as credentials may optionally implement this interface to provide the capability to refresh itself.
RefreshFailedException - Exception in javax.security.auth
Signals that a refresh operation failed.
RefreshFailedException() - Constructor for exception javax.security.auth.RefreshFailedException
Constructs a RefreshFailedException with no detail message.
RefreshFailedException(String) - Constructor for exception javax.security.auth.RefreshFailedException
Constructs a RefreshFailedException with the specified detail message.
refreshRow() - Method in interface java.sql.ResultSet
Refreshes the current row with its most recent value in the database.
regexFilter(String, int...) - Static method in class javax.swing.RowFilter
Returns a RowFilter that uses a regular expression to determine which entries to include.
region(int, int) - Method in class java.util.regex.Matcher
Sets the limits of this matcher's region.
Region - Class in javax.swing.plaf.synth
A distinct rendering area of a Swing component.
Region(String, String, boolean) - Constructor for class javax.swing.plaf.synth.Region
Creates a Region with the specified name.
regionEnd() - Method in class java.util.regex.Matcher
Reports the end index (exclusive) of this matcher's region.
regionMatches(int, String, int, int) - Method in class java.lang.String
Tests if two string regions are equal.
regionMatches(boolean, int, String, int, int) - Method in class java.lang.String
Tests if two string regions are equal.
regionStart() - Method in class java.util.regex.Matcher
Reports the start index of this matcher's region.
register(Selector, int, Object) - Method in class java.nio.channels.SelectableChannel
Registers this channel with the given selector, returning a selection key.
register(Selector, int) - Method in class java.nio.channels.SelectableChannel
Registers this channel with the given selector, returning a selection key.
register(Selector, int, Object) - Method in class java.nio.channels.spi.AbstractSelectableChannel
Registers this channel with the given selector, returning a selection key.
register(AbstractSelectableChannel, int, Object) - Method in class java.nio.channels.spi.AbstractSelector
Registers the given channel with this selector.
register(WatchService, WatchEvent.Kind<?>[], WatchEvent.Modifier...) - Method in interface java.nio.file.Path
Registers the file located by this path with a watch service.
register(WatchService, WatchEvent.Kind<?>...) - Method in interface java.nio.file.Path
Registers the file located by this path with a watch service.
register(WatchService, WatchEvent.Kind<?>[], WatchEvent.Modifier...) - Method in interface java.nio.file.Watchable
Registers an object with a watch service.
register(WatchService, WatchEvent.Kind<?>...) - Method in interface java.nio.file.Watchable
Registers an object with a watch service.
register(ActivationDesc) - Static method in class java.rmi.activation.Activatable
Register an object descriptor for an activatable remote object so that is can be activated on demand.
register() - Method in class java.util.concurrent.Phaser
Adds a new unarrived party to this phaser.
register(Region, String) - Method in class javax.swing.plaf.nimbus.NimbusLookAndFeel
Registers a third party component with the NimbusLookAndFeel.
register_initial_reference(String, Object) - Method in interface org.omg.PortableInterceptor.ORBInitInfoOperations
Identical to ORB.register_initial_reference.
register_policy_factory(int, PolicyFactory) - Method in interface org.omg.PortableInterceptor.ORBInitInfoOperations
Registers a PolicyFactory for the given PolicyType.
register_value_factory(String, ValueFactory) - Method in class org.omg.CORBA_2_3.ORB
RegisterableService - Interface in javax.imageio.spi
An optional interface that may be provided by service provider objects that will be registered with a ServiceRegistry.
registerApplicationClasspathSpis() - Method in class javax.imageio.spi.IIORegistry
Registers all available service providers found on the application class path, using the default ClassLoader.
registerAsParallelCapable() - Static method in class java.lang.ClassLoader
Registers the caller as parallel capable.
registerComponent(JComponent) - Method in class javax.swing.ToolTipManager
Registers a component for tooltip management.
registerDriver(Driver) - Static method in class java.sql.DriverManager
Registers the given driver with the DriverManager.
registerDriver(Driver, DriverAction) - Static method in class java.sql.DriverManager
Registers the given driver with the DriverManager.
registerEditor(Class<?>, Class<?>) - Static method in class java.beans.PropertyEditorManager
Registers an editor class to edit values of the given target class.
registerEditorKitForContentType(String, String) - Static method in class javax.swing.JEditorPane
Establishes the default bindings of type to classname.
registerEditorKitForContentType(String, String, ClassLoader) - Static method in class javax.swing.JEditorPane
Establishes the default bindings of type to classname.
registerEngineExtension(String, ScriptEngineFactory) - Method in class javax.script.ScriptEngineManager
Registers a ScriptEngineFactory to handle an extension.
registerEngineMimeType(String, ScriptEngineFactory) - Method in class javax.script.ScriptEngineManager
Registers a ScriptEngineFactory to handle a mime type.
registerEngineName(String, ScriptEngineFactory) - Method in class javax.script.ScriptEngineManager
Registers a ScriptEngineFactory to handle a language name.
registerFont(Font) - Method in class java.awt.GraphicsEnvironment
Registers a created Fontin this GraphicsEnvironment.
registerGroup(ActivationGroupDesc) - Method in interface java.rmi.activation.ActivationSystem
Register the activation group.
registerKeyboardAction(ActionListener, String, KeyStroke, int) - Method in class javax.swing.JComponent
This method is now obsolete, please use a combination of getActionMap() and getInputMap() for similar behavior.
registerKeyboardAction(ActionListener, KeyStroke, int) - Method in class javax.swing.JComponent
This method is now obsolete, please use a combination of getActionMap() and getInputMap() for similar behavior.
registerKeyboardActions() - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI
registerListeners() - Method in class java.awt.dnd.DragGestureRecognizer
register this DragGestureRecognizer's Listeners with the Component subclasses must override this method
registerListeners() - Method in class java.awt.dnd.MouseDragGestureRecognizer
register this DragGestureRecognizer's Listeners with the Component
registerMBean(Object, ObjectName) - Method in interface javax.management.MBeanServer
Registers a pre-existing object as an MBean with the MBean server.
registerObject(ActivationDesc) - Method in interface java.rmi.activation.ActivationSystem
The registerObject method is used to register an activation descriptor, desc, and obtain an activation identifier for a activatable remote object.
registerOutParameter(int, int) - Method in interface java.sql.CallableStatement
Registers the OUT parameter in ordinal position parameterIndex to the JDBC type sqlType.
registerOutParameter(int, int, int) - Method in interface java.sql.CallableStatement
Registers the parameter in ordinal position parameterIndex to be of JDBC type sqlType.
registerOutParameter(int, int, String) - Method in interface java.sql.CallableStatement
Registers the designated output parameter.
registerOutParameter(String, int) - Method in interface java.sql.CallableStatement
Registers the OUT parameter named parameterName to the JDBC type sqlType.
registerOutParameter(String, int, int) - Method in interface java.sql.CallableStatement
Registers the parameter named parameterName to be of JDBC type sqlType.
registerOutParameter(String, int, String) - Method in interface java.sql.CallableStatement
Registers the designated output parameter.
registerOutParameter(int, SQLType) - Method in interface java.sql.CallableStatement
Registers the OUT parameter in ordinal position parameterIndex to the JDBC type sqlType.
registerOutParameter(int, SQLType, int) - Method in interface java.sql.CallableStatement
Registers the parameter in ordinal position parameterIndex to be of JDBC type sqlType.
registerOutParameter(int, SQLType, String) - Method in interface java.sql.CallableStatement
Registers the designated output parameter.
registerOutParameter(String, SQLType) - Method in interface java.sql.CallableStatement
Registers the OUT parameter named parameterName to the JDBC type sqlType.
registerOutParameter(String, SQLType, int) - Method in interface java.sql.CallableStatement
Registers the parameter named parameterName to be of JDBC type sqlType.
registerOutParameter(String, SQLType, String) - Method in interface java.sql.CallableStatement
Registers the designated output parameter.
registerProvider(ZoneRulesProvider) - Static method in class java.time.zone.ZoneRulesProvider
Registers a zone rules provider.
registerProvider(String) - Static method in class javax.sql.rowset.spi.SyncFactory
Adds the the given synchronization provider to the factory register.
registerService(PrintService) - Static method in class javax.print.PrintServiceLookup
Allows an application to directly register an instance of a class which implements a print service.
registerServiceProvider(T, Class<T>) - Method in class javax.imageio.spi.ServiceRegistry
Adds a service provider object to the registry.
registerServiceProvider(Object) - Method in class javax.imageio.spi.ServiceRegistry
Adds a service provider object to the registry.
registerServiceProvider(PrintServiceLookup) - Static method in class javax.print.PrintServiceLookup
Allows an application to explicitly register a class that implements lookup services.
registerServiceProviders(Iterator<?>) - Method in class javax.imageio.spi.ServiceRegistry
Adds a set of service provider objects, taken from an Iterator to the registry.
registerStaticAttributeKey(Object) - Static method in class javax.swing.text.StyleContext
Registers an object as a static object that is being used as a key in attribute sets.
registerSubclass(Class<?>) - Static method in class java.awt.AWTKeyStroke
Registers a new class which the factory methods in AWTKeyStroke will use when generating new instances of AWTKeyStrokes.
registerTag(HTML.Tag, HTMLDocument.HTMLReader.TagAction) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader
Registers a handler for the given tag.
registerTarget(Tie, Remote) - Static method in class javax.rmi.CORBA.Util
Registers a target for a tie.
registerTarget(Tie, Remote) - Method in interface javax.rmi.CORBA.UtilDelegate
Delegation call for Util.registerTarget(javax.rmi.CORBA.Tie, java.rmi.Remote).
registerValidation(ObjectInputValidation, int) - Method in class java.io.ObjectInputStream
Register an object to be validated before the graph is returned.
REGISTRATION_NOTIFICATION - Static variable in class javax.management.MBeanServerNotification
Notification type denoting that an MBean has been registered.
Registry - Interface in java.rmi.registry
Registry is a remote interface to a simple remote object registry that provides methods for storing and retrieving remote object references bound with arbitrary string names.
REGISTRY_ID - Static variable in class java.rmi.server.ObjID
Object number for well-known ObjID of the registry.
REGISTRY_PORT - Static variable in interface java.rmi.registry.Registry
Well known port for registry.
RegistryHandler - Interface in java.rmi.registry
Deprecated.
no replacement
registryImpl(int) - Method in interface java.rmi.registry.RegistryHandler
Deprecated.
no replacement. As of the Java 2 platform v1.2, RMI no longer uses the RegistryHandler to obtain the registry's implementation.
registryStub(String, int) - Method in interface java.rmi.registry.RegistryHandler
Deprecated.
no replacement. As of the Java 2 platform v1.2, RMI no longer uses the RegistryHandler to obtain the registry's stub.
rehash() - Method in class java.util.Hashtable
Increases the capacity of and internally reorganizes this hashtable, in order to accommodate and access its entries more efficiently.
reinitialize() - Method in class java.util.concurrent.ForkJoinTask
Resets the internal bookkeeping state of this task, allowing a subsequent fork.
REJANG - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Rejang" Unicode character block.
rejectDrag() - Method in class java.awt.dnd.DropTargetContext
reject the Drag.
rejectDrag() - Method in class java.awt.dnd.DropTargetDragEvent
Rejects the drag as a result of examining either the dropAction or the available DataFlavor types.
rejectDrop() - Method in class java.awt.dnd.DropTargetContext
called to signal that the drop is unacceptable.
rejectDrop() - Method in class java.awt.dnd.DropTargetDropEvent
reject the Drop.
rejectedExecution(Runnable, ThreadPoolExecutor) - Method in interface java.util.concurrent.RejectedExecutionHandler
Method that may be invoked by a ThreadPoolExecutor when execute cannot accept a task.
rejectedExecution(Runnable, ThreadPoolExecutor) - Method in class java.util.concurrent.ThreadPoolExecutor.AbortPolicy
Always throws RejectedExecutionException.
rejectedExecution(Runnable, ThreadPoolExecutor) - Method in class java.util.concurrent.ThreadPoolExecutor.CallerRunsPolicy
Executes task r in the caller's thread, unless the executor has been shut down, in which case the task is discarded.
rejectedExecution(Runnable, ThreadPoolExecutor) - Method in class java.util.concurrent.ThreadPoolExecutor.DiscardOldestPolicy
Obtains and ignores the next task that the executor would otherwise execute, if one is immediately available, and then retries execution of task r, unless the executor is shut down, in which case task r is instead discarded.
rejectedExecution(Runnable, ThreadPoolExecutor) - Method in class java.util.concurrent.ThreadPoolExecutor.DiscardPolicy
Does nothing, which has the effect of discarding task r.
RejectedExecutionException - Exception in java.util.concurrent
Exception thrown by an Executor when a task cannot be accepted for execution.
RejectedExecutionException() - Constructor for exception java.util.concurrent.RejectedExecutionException
Constructs a RejectedExecutionException with no detail message.
RejectedExecutionException(String) - Constructor for exception java.util.concurrent.RejectedExecutionException
Constructs a RejectedExecutionException with the specified detail message.
RejectedExecutionException(String, Throwable) - Constructor for exception java.util.concurrent.RejectedExecutionException
Constructs a RejectedExecutionException with the specified detail message and cause.
RejectedExecutionException(Throwable) - Constructor for exception java.util.concurrent.RejectedExecutionException
Constructs a RejectedExecutionException with the specified cause.
RejectedExecutionHandler - Interface in java.util.concurrent
A handler for tasks that cannot be executed by a ThreadPoolExecutor.
rejectedSetBCOnce - Variable in class java.beans.beancontext.BeanContextChildSupport
A flag indicating that there has been at least one PropertyChangeVetoException thrown for the attempted setBeanContext operation.
REL - Static variable in class javax.swing.text.html.HTML.Attribute
Relation - Interface in javax.management.relation
This interface has to be implemented by any MBean class expected to represent a relation managed using the Relation Service.
RELATION_BASIC_CREATION - Static variable in class javax.management.relation.RelationNotification
Type for the creation of an internal relation.
RELATION_BASIC_REMOVAL - Static variable in class javax.management.relation.RelationNotification
Type for the removal from the Relation Service of an internal relation.
RELATION_BASIC_UPDATE - Static variable in class javax.management.relation.RelationNotification
Type for an update of an internal relation.
RELATION_MBEAN_CREATION - Static variable in class javax.management.relation.RelationNotification
Type for the relation MBean added into the Relation Service.
RELATION_MBEAN_REMOVAL - Static variable in class javax.management.relation.RelationNotification
Type for the removal from the Relation Service of a relation MBean.
RELATION_MBEAN_UPDATE - Static variable in class javax.management.relation.RelationNotification
Type for the update of a relation MBean.
RelationException - Exception in javax.management.relation
This class is the superclass of any exception which can be raised during relation management.
RelationException() - Constructor for exception javax.management.relation.RelationException
Default constructor, no message put in exception.
RelationException(String) - Constructor for exception javax.management.relation.RelationException
Constructor with given message put in exception.
RelationNotFoundException - Exception in javax.management.relation
This exception is raised when there is no relation for a given relation id in a Relation Service.
RelationNotFoundException() - Constructor for exception javax.management.relation.RelationNotFoundException
Default constructor, no message put in exception.
RelationNotFoundException(String) - Constructor for exception javax.management.relation.RelationNotFoundException
Constructor with given message put in exception.
RelationNotification - Class in javax.management.relation
A notification of a change in the Relation Service.
RelationNotification(String, Object, long, long, String, String, String, ObjectName, List<ObjectName>) - Constructor for class javax.management.relation.RelationNotification
Creates a notification for either a relation creation (RelationSupport object created internally in the Relation Service, or an MBean added as a relation) or for a relation removal from the Relation Service.
RelationNotification(String, Object, long, long, String, String, String, ObjectName, String, List<ObjectName>, List<ObjectName>) - Constructor for class javax.management.relation.RelationNotification
Creates a notification for a role update in a relation.
relations - Variable in class javax.accessibility.AccessibleRelationSet
Each entry in the Vector represents an AccessibleRelation.
RelationService - Class in javax.management.relation
The Relation Service is in charge of creating and deleting relation types and relations, of handling the consistency and of providing query mechanisms.
RelationService(boolean) - Constructor for class javax.management.relation.RelationService
Constructor.
RelationServiceMBean - Interface in javax.management.relation
The Relation Service is in charge of creating and deleting relation types and relations, of handling the consistency and of providing query mechanisms.
RelationServiceNotRegisteredException - Exception in javax.management.relation
This exception is raised when an access is done to the Relation Service and that one is not registered.
RelationServiceNotRegisteredException() - Constructor for exception javax.management.relation.RelationServiceNotRegisteredException
Default constructor, no message put in exception.
RelationServiceNotRegisteredException(String) - Constructor for exception javax.management.relation.RelationServiceNotRegisteredException
Constructor with given message put in exception.
RelationSupport - Class in javax.management.relation
A RelationSupport object is used internally by the Relation Service to represent simple relations (only roles, no properties or methods), with an unlimited number of roles, of any relation type.
RelationSupport(String, ObjectName, String, RoleList) - Constructor for class javax.management.relation.RelationSupport
Creates a RelationSupport object.
RelationSupport(String, ObjectName, MBeanServer, String, RoleList) - Constructor for class javax.management.relation.RelationSupport
Creates a RelationSupport object.
RelationSupportMBean - Interface in javax.management.relation
A RelationSupport object is used internally by the Relation Service to represent simple relations (only roles, no properties or methods), with an unlimited number of roles, of any relation type.
RelationType - Interface in javax.management.relation
The RelationType interface has to be implemented by any class expected to represent a relation type.
RelationTypeNotFoundException - Exception in javax.management.relation
This exception is raised when there is no relation type with given name in Relation Service.
RelationTypeNotFoundException() - Constructor for exception javax.management.relation.RelationTypeNotFoundException
Default constructor, no message put in exception.
RelationTypeNotFoundException(String) - Constructor for exception javax.management.relation.RelationTypeNotFoundException
Constructor with given message put in exception.
RelationTypeSupport - Class in javax.management.relation
A RelationTypeSupport object implements the RelationType interface.
RelationTypeSupport(String, RoleInfo[]) - Constructor for class javax.management.relation.RelationTypeSupport
Constructor where all role definitions are dynamically created and passed as parameter.
RelationTypeSupport(String) - Constructor for class javax.management.relation.RelationTypeSupport
Constructor to be used for subclasses.
RELATIVE - Static variable in class java.awt.GridBagConstraints
Specifies that this component is the next-to-last component in its column or row (gridwidth, gridheight), or that this component be placed next to the previously added component (gridx, gridy).
relative(int) - Method in interface java.sql.ResultSet
Moves the cursor a relative number of rows, either positive or negative.
relativeCCW(double, double, double, double, double, double) - Static method in class java.awt.geom.Line2D
Returns an indicator of where the specified point (px,py) lies with respect to the line segment from (x1,y1) to (x2,y2).
relativeCCW(double, double) - Method in class java.awt.geom.Line2D
Returns an indicator of where the specified point (px,py) lies with respect to this line segment.
relativeCCW(Point2D) - Method in class java.awt.geom.Line2D
Returns an indicator of where the specified Point2D lies with respect to this line segment.
relativize(URI) - Method in class java.net.URI
Relativizes the given URI against this URI.
relativize(Path) - Method in interface java.nio.file.Path
Constructs a relative path between this path and a given path.
RELAXNG_NS_URI - Static variable in class javax.xml.XMLConstants
RELAX NG Namespace URI.
release() - Method in class java.nio.channels.FileLock
Releases this lock.
release(long) - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer
Releases in exclusive mode.
release(int) - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer
Releases in exclusive mode.
release() - Method in class java.util.concurrent.Semaphore
Releases a permit, returning it to the semaphore.
release(int) - Method in class java.util.concurrent.Semaphore
Releases the given number of permits, returning them to the semaphore.
release() - Method in interface javax.sql.rowset.CachedRowSet
Releases the current contents of this CachedRowSet object and sends a rowSetChanged event to all registered listeners.
release(Object) - Method in class org.omg.CORBA.portable.Delegate
Releases resources associated with the object reference provided.
releaseBeanContextResources() - Method in class java.beans.beancontext.BeanContextChildSupport
This method may be overridden by subclasses to provide their own release behaviors.
releaseBeanContextResources() - Method in class java.beans.beancontext.BeanContextServicesSupport
called from setBeanContext to notify a BeanContextChild to release resources obtained from the nesting BeanContext.
releaseInputStream() - Method in interface java.rmi.server.RemoteCall
Deprecated.
no replacement
releaseMBeanServer(MBeanServer) - Static method in class javax.management.MBeanServerFactory
Remove internal MBeanServerFactory references to a created MBeanServer.
releaseOutputStream() - Method in interface java.rmi.server.RemoteCall
Deprecated.
no replacement
releaseReply(Object, InputStream) - Method in class org.omg.CORBA.portable.Delegate
releaseReply may optionally be called by a stub to release a reply stream back to the ORB when the unmarshaling has completed.
releaseSavepoint(Savepoint) - Method in interface java.sql.Connection
Removes the specified Savepoint and subsequent Savepoint objects from the current transaction.
releaseService(BeanContextServices, Object, Object) - Method in interface java.beans.beancontext.BeanContextServiceProvider
Invoked by BeanContextServices, this method releases a nested BeanContextChild's (or any arbitrary object associated with a BeanContextChild) reference to the specified service.
releaseService(BeanContextChild, Object, Object) - Method in interface java.beans.beancontext.BeanContextServices
Releases a BeanContextChild's (or any arbitrary object associated with a BeanContextChild) reference to the specified service by calling releaseService() on the underlying BeanContextServiceProvider.
releaseService(BeanContextServices, Object, Object) - Method in class java.beans.beancontext.BeanContextServicesSupport.BCSSProxyServiceProvider
releaseService(BeanContextChild, Object, Object) - Method in class java.beans.beancontext.BeanContextServicesSupport
release a service
releaseShared(long) - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer
Releases in shared mode.
releaseShared(int) - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer
Releases in shared mode.
releaseWritableTile(int, int) - Method in class java.awt.image.BufferedImage
Relinquishes permission to write to a tile.
releaseWritableTile(int, int) - Method in interface java.awt.image.WritableRenderedImage
Relinquishes the right to write to a tile.
reload() - Method in class java.util.ServiceLoader
Clear this loader's provider cache so that all providers will be reloaded.
reload() - Method in class javax.swing.tree.DefaultTreeModel
Invoke this method if you've modified the TreeNodes upon which this model depends.
reload(TreeNode) - Method in class javax.swing.tree.DefaultTreeModel
Invoke this method if you've modified the TreeNodes upon which this model depends.
REMAINDER - Static variable in class java.awt.GridBagConstraints
Specifies that this component is the last component in its column or row.
remainder(BigDecimal) - Method in class java.math.BigDecimal
Returns a BigDecimal whose value is (this % divisor).
remainder(BigDecimal, MathContext) - Method in class java.math.BigDecimal
Returns a BigDecimal whose value is (this % divisor), with rounding according to the context settings.
remainder(BigInteger) - Method in class java.math.BigInteger
Returns a BigInteger whose value is (this % val).
remainderUnsigned(int, int) - Static method in class java.lang.Integer
Returns the unsigned remainder from dividing the first argument by the second where each argument and the result is interpreted as an unsigned value.
remainderUnsigned(long, long) - Static method in class java.lang.Long
Returns the unsigned remainder from dividing the first argument by the second where each argument and the result is interpreted as an unsigned value.
remaining() - Method in class java.nio.Buffer
Returns the number of elements between the current position and the limit.
remainingCapacity() - Method in class java.util.concurrent.ArrayBlockingQueue
Returns the number of additional elements that this queue can ideally (in the absence of memory or resource constraints) accept without blocking.
remainingCapacity() - Method in interface java.util.concurrent.BlockingQueue
Returns the number of additional elements that this queue can ideally (in the absence of memory or resource constraints) accept without blocking, or Integer.MAX_VALUE if there is no intrinsic limit.
remainingCapacity() - Method in class java.util.concurrent.DelayQueue
Always returns Integer.MAX_VALUE because a DelayQueue is not capacity constrained.
remainingCapacity() - Method in class java.util.concurrent.LinkedBlockingDeque
Returns the number of additional elements that this deque can ideally (in the absence of memory or resource constraints) accept without blocking.
remainingCapacity() - Method in class java.util.concurrent.LinkedBlockingQueue
Returns the number of additional elements that this queue can ideally (in the absence of memory or resource constraints) accept without blocking.
remainingCapacity() - Method in class java.util.concurrent.LinkedTransferQueue
Always returns Integer.MAX_VALUE because a LinkedTransferQueue is not capacity constrained.
remainingCapacity() - Method in class java.util.concurrent.PriorityBlockingQueue
Always returns Integer.MAX_VALUE because a PriorityBlockingQueue is not capacity constrained.
remainingCapacity() - Method in class java.util.concurrent.SynchronousQueue
Always returns zero.
remainingName - Variable in exception javax.naming.NamingException
Contains the remaining name that has not been resolved yet.
remainingName - Variable in class javax.naming.spi.ResolveResult
Field containing the remaining name yet to be resolved.
remainingNewName - Variable in exception javax.naming.CannotProceedException
Contains the remaining unresolved part of the second "name" argument to Context.rename().
remapInstrument(Instrument, Instrument) - Method in interface javax.sound.midi.Synthesizer
Remaps an instrument.
RemarshalException - Exception in org.omg.CORBA.portable
This class is used for reporting locate forward exceptions and object forward GIOP messages back to the ORB.
RemarshalException() - Constructor for exception org.omg.CORBA.portable.RemarshalException
Constructs a RemarshalException.
Remote - Interface in java.rmi
The Remote interface serves to identify interfaces whose methods may be invoked from a non-local virtual machine.
RemoteCall - Interface in java.rmi.server
Deprecated.
no replacement.
remoteEquals(RemoteRef) - Method in interface java.rmi.server.RemoteRef
Compares two remote objects for equality.
RemoteException - Exception in java.rmi
A RemoteException is the common superclass for a number of communication-related exceptions that may occur during the execution of a remote method call.
RemoteException() - Constructor for exception java.rmi.RemoteException
Constructs a RemoteException.
RemoteException(String) - Constructor for exception java.rmi.RemoteException
Constructs a RemoteException with the specified detail message.
RemoteException(String, Throwable) - Constructor for exception java.rmi.RemoteException
Constructs a RemoteException with the specified detail message and cause.
remoteHashCode() - Method in interface java.rmi.server.RemoteRef
Returns a hashcode for a remote object.
RemoteObject - Class in java.rmi.server
The RemoteObject class implements the java.lang.Object behavior for remote objects.
RemoteObject() - Constructor for class java.rmi.server.RemoteObject
Creates a remote object.
RemoteObject(RemoteRef) - Constructor for class java.rmi.server.RemoteObject
Creates a remote object, initialized with the specified remote reference.
RemoteObjectInvocationHandler - Class in java.rmi.server
An implementation of the InvocationHandler interface for use with Java Remote Method Invocation (Java RMI).
RemoteObjectInvocationHandler(RemoteRef) - Constructor for class java.rmi.server.RemoteObjectInvocationHandler
Creates a new RemoteObjectInvocationHandler constructed with the specified RemoteRef.
RemoteRef - Interface in java.rmi.server
RemoteRef represents the handle for a remote object.
RemoteServer - Class in java.rmi.server
The RemoteServer class is the common superclass to server implementations and provides the framework to support a wide range of remote reference semantics.
RemoteServer() - Constructor for class java.rmi.server.RemoteServer
Constructs a RemoteServer.
RemoteServer(RemoteRef) - Constructor for class java.rmi.server.RemoteServer
Constructs a RemoteServer with the given reference type.
RemoteStub - Class in java.rmi.server
Deprecated.
Statically generated stubs are deprecated, since stubs are generated dynamically. See UnicastRemoteObject for information about dynamic stub generation.
RemoteStub() - Constructor for class java.rmi.server.RemoteStub
Deprecated.
Constructs a RemoteStub.
RemoteStub(RemoteRef) - Constructor for class java.rmi.server.RemoteStub
Deprecated.
Constructs a RemoteStub with the specified remote reference.
remoteToString() - Method in interface java.rmi.server.RemoteRef
Returns a String that represents the reference of this remote object.
REMOVAL - Static variable in interface org.w3c.dom.events.MutationEvent
The Attr was just removed.
remove(EventListener) - Method in class java.awt.AWTEventMulticaster
Removes a listener from this multicaster.
remove(ComponentListener, ComponentListener) - Static method in class java.awt.AWTEventMulticaster
Removes the old component-listener from component-listener-l and returns the resulting multicast listener.
remove(ContainerListener, ContainerListener) - Static method in class java.awt.AWTEventMulticaster
Removes the old container-listener from container-listener-l and returns the resulting multicast listener.
remove(FocusListener, FocusListener) - Static method in class java.awt.AWTEventMulticaster
Removes the old focus-listener from focus-listener-l and returns the resulting multicast listener.
remove(KeyListener, KeyListener) - Static method in class java.awt.AWTEventMulticaster
Removes the old key-listener from key-listener-l and returns the resulting multicast listener.
remove(MouseListener, MouseListener) - Static method in class java.awt.AWTEventMulticaster
Removes the old mouse-listener from mouse-listener-l and returns the resulting multicast listener.
remove(MouseMotionListener, MouseMotionListener) - Static method in class java.awt.AWTEventMulticaster
Removes the old mouse-motion-listener from mouse-motion-listener-l and returns the resulting multicast listener.
remove(WindowListener, WindowListener) - Static method in class java.awt.AWTEventMulticaster
Removes the old window-listener from window-listener-l and returns the resulting multicast listener.
remove(WindowStateListener, WindowStateListener) - Static method in class java.awt.AWTEventMulticaster
Removes the old window-state-listener from window-state-listener-l and returns the resulting multicast listener.
remove(WindowFocusListener, WindowFocusListener) - Static method in class java.awt.AWTEventMulticaster
Removes the old window-focus-listener from window-focus-listener-l and returns the resulting multicast listener.
remove(ActionListener, ActionListener) - Static method in class java.awt.AWTEventMulticaster
Removes the old action-listener from action-listener-l and returns the resulting multicast listener.
remove(ItemListener, ItemListener) - Static method in class java.awt.AWTEventMulticaster
Removes the old item-listener from item-listener-l and returns the resulting multicast listener.
remove(AdjustmentListener, AdjustmentListener) - Static method in class java.awt.AWTEventMulticaster
Removes the old adjustment-listener from adjustment-listener-l and returns the resulting multicast listener.
remove(TextListener, TextListener) - Static method in class java.awt.AWTEventMulticaster
remove(InputMethodListener, InputMethodListener) - Static method in class java.awt.AWTEventMulticaster
Removes the old input-method-listener from input-method-listener-l and returns the resulting multicast listener.
remove(HierarchyListener, HierarchyListener) - Static method in class java.awt.AWTEventMulticaster
Removes the old hierarchy-listener from hierarchy-listener-l and returns the resulting multicast listener.
remove(HierarchyBoundsListener, HierarchyBoundsListener) - Static method in class java.awt.AWTEventMulticaster
Removes the old hierarchy-bounds-listener from hierarchy-bounds-listener-l and returns the resulting multicast listener.
remove(MouseWheelListener, MouseWheelListener) - Static method in class java.awt.AWTEventMulticaster
Removes the old mouse-wheel-listener from mouse-wheel-listener-l and returns the resulting multicast listener.
remove(String) - Method in class java.awt.Choice
Removes the first occurrence of item from the Choice menu.
remove(int) - Method in class java.awt.Choice
Removes an item from the choice menu at the specified position.
remove(MenuComponent) - Method in class java.awt.Component
Removes the specified popup menu from the component.
remove(int) - Method in class java.awt.Container
Removes the component, specified by index, from this container.
remove(Component) - Method in class java.awt.Container
Removes the specified component from this container.
remove(MenuComponent) - Method in class java.awt.Frame
Removes the specified menu bar from this frame.
remove(String) - Method in class java.awt.List
Removes the first occurrence of an item from the list.
remove(int) - Method in class java.awt.List
Removes the item at the specified position from this scrolling list.
remove(int) - Method in class java.awt.Menu
Removes the menu item at the specified index from this menu.
remove(MenuComponent) - Method in class java.awt.Menu
Removes the specified menu item from this menu.
remove(int) - Method in class java.awt.MenuBar
Removes the menu located at the specified index from this menu bar.
remove(MenuComponent) - Method in class java.awt.MenuBar
Removes the specified menu component from this menu bar.
remove(MenuComponent) - Method in interface java.awt.MenuContainer
remove(Object) - Method in class java.awt.RenderingHints
Removes the key and its corresponding value from this RenderingHints object.
remove(TrayIcon) - Method in class java.awt.SystemTray
Removes the specified TrayIcon from the SystemTray.
remove() - Method in class java.beans.beancontext.BeanContextSupport.BCSIterator
remove(Object) - Method in class java.beans.beancontext.BeanContextSupport
Removes a child from this BeanContext.
remove(Object, boolean) - Method in class java.beans.beancontext.BeanContextSupport
internal remove used when removal caused by unexpected setBeanContext or by remove() invocation.
remove(Object) - Method in class java.beans.Encoder
Removes the entry for this instance, returning the old entry.
remove(Class<?>) - Method in class java.lang.ClassValue
Removes the associated value for the given class.
remove(long) - Method in class java.lang.ref.ReferenceQueue
Removes the next reference object in this queue, blocking until either one becomes available or the given timeout period expires.
remove() - Method in class java.lang.ref.ReferenceQueue
Removes the next reference object in this queue, blocking until one becomes available.
remove() - Method in class java.lang.ThreadLocal
Removes the current thread's value for this thread-local variable.
remove(URI, HttpCookie) - Method in interface java.net.CookieStore
Remove a cookie from store.
remove(Object) - Method in class java.security.Provider
Removes the key property (and its corresponding value).
remove(Object, Object) - Method in class java.security.Provider
Removes the entry for the specified key only if it is currently mapped to the specified value.
remove(Object) - Method in class java.util.AbstractCollection
Removes a single instance of the specified element from this collection, if it is present (optional operation).
remove(int) - Method in class java.util.AbstractList
Removes the element at the specified position in this list (optional operation).
remove(Object) - Method in class java.util.AbstractMap
Removes the mapping for a key from this map if it is present (optional operation).
remove() - Method in class java.util.AbstractQueue
Retrieves and removes the head of this queue.
remove(int) - Method in class java.util.AbstractSequentialList
Removes the element at the specified position in this list (optional operation).
remove() - Method in class java.util.ArrayDeque
Retrieves and removes the head of the queue represented by this deque.
remove(Object) - Method in class java.util.ArrayDeque
Removes a single instance of the specified element from this deque.
remove(int) - Method in class java.util.ArrayList
Removes the element at the specified position in this list.
remove(Object) - Method in class java.util.ArrayList
Removes the first occurrence of the specified element from this list, if it is present.
remove(Object) - Method in interface java.util.Collection
Removes a single instance of the specified element from this collection, if it is present (optional operation).
remove(Object) - Method in class java.util.concurrent.ArrayBlockingQueue
Removes a single instance of the specified element from this queue, if it is present.
remove() - Method in interface java.util.concurrent.BlockingDeque
Retrieves and removes the head of the queue represented by this deque (in other words, the first element of this deque).
remove(Object) - Method in interface java.util.concurrent.BlockingDeque
Removes the first occurrence of the specified element from this deque.
remove(Object) - Method in interface java.util.concurrent.BlockingQueue
Removes a single instance of the specified element from this queue, if it is present.
remove(Object) - Method in class java.util.concurrent.ConcurrentHashMap.KeySetView
Removes the key from this map view, by removing the key (and its corresponding value) from the backing map.
remove(Object) - Method in class java.util.concurrent.ConcurrentHashMap
Removes the key (and its corresponding value) from this map.
remove(Object, Object) - Method in class java.util.concurrent.ConcurrentHashMap
Removes the entry for a key only if currently mapped to a given value.
remove() - Method in class java.util.concurrent.ConcurrentLinkedDeque
remove(Object) - Method in class java.util.concurrent.ConcurrentLinkedDeque
Removes the first element e such that o.equals(e), if such an element exists in this deque.
remove(Object) - Method in class java.util.concurrent.ConcurrentLinkedQueue
Removes a single instance of the specified element from this queue, if it is present.
remove(Object, Object) - Method in interface java.util.concurrent.ConcurrentMap
Removes the entry for a key only if currently mapped to a given value.
remove(Object) - Method in class java.util.concurrent.ConcurrentSkipListMap
Removes the mapping for the specified key from this map if present.
remove(Object, Object) - Method in class java.util.concurrent.ConcurrentSkipListMap
Removes the entry for a key only if currently mapped to a given value.
remove(Object) - Method in class java.util.concurrent.ConcurrentSkipListSet
Removes the specified element from this set if it is present.
remove(int) - Method in class java.util.concurrent.CopyOnWriteArrayList
Removes the element at the specified position in this list.
remove(Object) - Method in class java.util.concurrent.CopyOnWriteArrayList
Removes the first occurrence of the specified element from this list, if it is present.
remove(Object) - Method in class java.util.concurrent.CopyOnWriteArraySet
Removes the specified element from this set if it is present.
remove(Object) - Method in class java.util.concurrent.DelayQueue
Removes a single instance of the specified element from this queue, if it is present, whether or not it has expired.
remove() - Method in class java.util.concurrent.LinkedBlockingDeque
Retrieves and removes the head of the queue represented by this deque.
remove(Object) - Method in class java.util.concurrent.LinkedBlockingDeque
Removes the first occurrence of the specified element from this deque.
remove(Object) - Method in class java.util.concurrent.LinkedBlockingQueue
Removes a single instance of the specified element from this queue, if it is present.
remove(Object) - Method in class java.util.concurrent.LinkedTransferQueue
Removes a single instance of the specified element from this queue, if it is present.
remove(Object) - Method in class java.util.concurrent.PriorityBlockingQueue
Removes a single instance of the specified element from this queue, if it is present.
remove(Object) - Method in class java.util.concurrent.SynchronousQueue
Always returns false.
remove(Runnable) - Method in class java.util.concurrent.ThreadPoolExecutor
Removes this task from the executor's internal queue if it is present, thus causing it not to be run if it has not already started.
remove() - Method in interface java.util.Deque
Retrieves and removes the head of the queue represented by this deque (in other words, the first element of this deque).
remove(Object) - Method in interface java.util.Deque
Removes the first occurrence of the specified element from this deque.
remove(Object) - Method in class java.util.Dictionary
Removes the key (and its corresponding value) from this dictionary.
remove(Object) - Method in class java.util.EnumMap
Removes the mapping for this key from this map if present.
remove(Object) - Method in class java.util.HashMap
Removes the mapping for the specified key from this map if present.
remove(Object, Object) - Method in class java.util.HashMap
remove(Object) - Method in class java.util.HashSet
Removes the specified element from this set if it is present.
remove(Object) - Method in class java.util.Hashtable
Removes the key (and its corresponding value) from this hashtable.
remove(Object, Object) - Method in class java.util.Hashtable
remove(Object) - Method in class java.util.IdentityHashMap
Removes the mapping for this key from this map if present.
remove() - Method in interface java.util.Iterator
Removes from the underlying collection the last element returned by this iterator (optional operation).
remove(Object) - Method in class java.util.jar.Attributes
Removes the attribute with the specified name (key) from this Map.
remove(Object) - Method in class java.util.LinkedList
Removes the first occurrence of the specified element from this list, if it is present.
remove(int) - Method in class java.util.LinkedList
Removes the element at the specified position in this list.
remove() - Method in class java.util.LinkedList
Retrieves and removes the head (first element) of this list.
remove(Object) - Method in interface java.util.List
Removes the first occurrence of the specified element from this list, if it is present (optional operation).
remove(int) - Method in interface java.util.List
Removes the element at the specified position in this list (optional operation).
remove() - Method in interface java.util.ListIterator
Removes from the list the last element that was returned by ListIterator.next() or ListIterator.previous() (optional operation).
remove(Object) - Method in interface java.util.Map
Removes the mapping for a key from this map if it is present (optional operation).
remove(Object, Object) - Method in interface java.util.Map
Removes the entry for the specified key only if it is currently mapped to the specified value.
remove(String) - Method in class java.util.prefs.AbstractPreferences
Implements the remove(String) method as per the specification in Preferences.remove(String).
remove(String) - Method in class java.util.prefs.Preferences
Removes the value associated with the specified key in this preference node, if any.
remove(Object) - Method in class java.util.PriorityQueue
Removes a single instance of the specified element from this queue, if it is present.
remove() - Method in interface java.util.Queue
Retrieves and removes the head of this queue.
remove() - Method in class java.util.Scanner
The remove operation is not supported by this implementation of Iterator.
remove(Object) - Method in interface java.util.Set
Removes the specified element from this set if it is present (optional operation).
remove(Object) - Method in class java.util.TreeMap
Removes the mapping for this key from this TreeMap if present.
remove(Object) - Method in class java.util.TreeSet
Removes the specified element from this set if it is present.
remove(Object) - Method in class java.util.Vector
Removes the first occurrence of the specified element in this Vector If the Vector does not contain the element, it is unchanged.
remove(int) - Method in class java.util.Vector
Removes the element at the specified position in this Vector.
remove(Object) - Method in class java.util.WeakHashMap
Removes the mapping for a key from this weak hash map if it is present.
remove(AccessibleRelation) - Method in class javax.accessibility.AccessibleRelationSet
Removes a relation from the current relation set.
remove(AccessibleState) - Method in class javax.accessibility.AccessibleStateSet
Removes a state from the current state set.
remove(String) - Method in class javax.activation.MimeTypeParameterList
Remove any value associated with the given name.
remove(Object[]) - Method in interface javax.management.openmbean.TabularData
Removes the CompositeData value whose index is key from this TabularData instance, and returns the removed value, or returns null if there is no value whose index is key.
remove(Object) - Method in class javax.management.openmbean.TabularDataSupport
This method simply calls remove((Object[]) key).
remove(Object[]) - Method in class javax.management.openmbean.TabularDataSupport
Removes the CompositeData value whose index is key from this TabularData instance, and returns the removed value, or returns null if there is no value whose index is key.
remove(int) - Method in class javax.naming.CompositeName
Deletes a component from this composite name.
remove(int) - Method in class javax.naming.CompoundName
Deletes a component from this compound name.
remove(Object) - Method in interface javax.naming.directory.Attribute
Removes a specified value from the attribute.
remove(int) - Method in interface javax.naming.directory.Attribute
Removes an attribute value from the ordered list of attribute values.
remove(String) - Method in interface javax.naming.directory.Attributes
Removes the attribute with the attribute id 'attrID' from the attribute set.
remove(Object) - Method in class javax.naming.directory.BasicAttribute
Removes a specified value from this attribute.
remove(int) - Method in class javax.naming.directory.BasicAttribute
remove(String) - Method in class javax.naming.directory.BasicAttributes
remove(int) - Method in class javax.naming.ldap.LdapName
Removes a component from this LDAP name.
remove(int) - Method in interface javax.naming.Name
Removes a component from this name.
remove(int) - Method in class javax.naming.Reference
Deletes the address at index posn from the list of addresses.
remove(Class<?>) - Method in interface javax.print.attribute.AttributeSet
Removes any attribute for this category from this attribute set if present.
remove(Attribute) - Method in interface javax.print.attribute.AttributeSet
Removes the specified attribute from this attribute set if present.
remove(Class<?>) - Method in class javax.print.attribute.HashAttributeSet
Removes any attribute for this category from this attribute set if present.
remove(Attribute) - Method in class javax.print.attribute.HashAttributeSet
Removes the specified attribute from this attribute set if present.
remove(Object) - Method in interface javax.script.Bindings
Removes the mapping for this key from this map if it is present (optional operation).
remove(Object) - Method in class javax.script.SimpleBindings
Removes the mapping for this key from this map if it is present (optional operation).
remove(MidiEvent) - Method in class javax.sound.midi.Track
Removes the specified event from the track.
remove(Object) - Method in class javax.swing.ActionMap
Removes the binding for key from this ActionMap.
remove(AbstractButton) - Method in class javax.swing.ButtonGroup
Removes the button from the group.
remove(KeyStroke) - Method in class javax.swing.ComponentInputMap
Removes the binding for key from this object.
remove(int) - Method in class javax.swing.DefaultListModel
Removes the element at the specified position in this list.
REMOVE - Static variable in class javax.swing.event.DocumentEvent.EventType
Remove type.
remove(Class<T>, T) - Method in class javax.swing.event.EventListenerList
Removes the listener as a listener of the specified type.
remove(KeyStroke) - Method in class javax.swing.InputMap
Removes the binding for key from this InputMap.
remove(Component) - Method in class javax.swing.JApplet
Removes the specified component from the container.
remove(Component) - Method in class javax.swing.JDesktopPane
Removes the specified component from this container.
remove(int) - Method in class javax.swing.JDesktopPane
Remove the indexed component from this pane.
remove(Component) - Method in class javax.swing.JDialog
Removes the specified component from the container.
remove(Component) - Method in class javax.swing.JFrame
Removes the specified component from the container.
remove(Component) - Method in class javax.swing.JInternalFrame
Removes the specified component from the container.
remove(Component) - Method in class javax.swing.JLayer
Removes the specified component from this container.
remove(int) - Method in class javax.swing.JLayeredPane
Remove the indexed component from this pane.
remove(JMenuItem) - Method in class javax.swing.JMenu
Removes the specified menu item from this menu.
remove(int) - Method in class javax.swing.JMenu
Removes the menu item at the specified index from this menu.
remove(Component) - Method in class javax.swing.JMenu
Removes the component c from this menu.
remove(int) - Method in class javax.swing.JPopupMenu
Removes the component at the specified index from this popup menu.
remove(Component) - Method in class javax.swing.JSplitPane
Removes the child component, component from the pane.
remove(int) - Method in class javax.swing.JSplitPane
Removes the Component at the specified index.
remove(Component) - Method in class javax.swing.JTabbedPane
Removes the specified Component from the JTabbedPane.
remove(int) - Method in class javax.swing.JTabbedPane
Removes the tab and component which corresponds to the specified index.
remove(Component) - Method in class javax.swing.JViewport
Removes the Viewports one lightweight child.
remove(Component) - Method in class javax.swing.JWindow
Removes the specified component from the container.
remove(int, int) - Method in interface javax.swing.text.AbstractDocument.Content
Removes some portion of the sequence.
remove(int, int) - Method in class javax.swing.text.AbstractDocument
Removes some content from the document.
remove(int, int, AbstractDocument.DefaultDocumentEvent) - Method in class javax.swing.text.DefaultStyledDocument.ElementBuffer
Removes content.
remove(int, int) - Method in interface javax.swing.text.Document
Removes a portion of the content of the document.
remove(int, int) - Method in class javax.swing.text.DocumentFilter.FilterBypass
Removes the specified region of text, bypassing the DocumentFilter.
remove(DocumentFilter.FilterBypass, int, int) - Method in class javax.swing.text.DocumentFilter
Invoked prior to removal of the specified region in the specified Document.
remove(int, int) - Method in class javax.swing.text.GapContent
Removes part of the content.
remove(int, int) - Method in class javax.swing.text.StringContent
Removes part of the content.
remove(int) - Method in class javax.swing.text.View
Removes one of the children at the given position.
remove(int) - Method in class javax.swing.tree.DefaultMutableTreeNode
Removes the child at the specified index from this node's children and sets that node's parent to null.
remove(MutableTreeNode) - Method in class javax.swing.tree.DefaultMutableTreeNode
Removes aChild from this node's child array, giving it a null parent.
remove(int) - Method in interface javax.swing.tree.MutableTreeNode
Removes the child at index from the receiver.
remove(MutableTreeNode) - Method in interface javax.swing.tree.MutableTreeNode
Removes node from the receiver.
remove() - Method in class javax.xml.stream.util.EventReaderDelegate
remove(int) - Method in class org.omg.CORBA.ContextList
Removes the String object at the given index.
remove(int) - Method in class org.omg.CORBA.ExceptionList
Removes the TypeCode object at the given index.
remove(int) - Method in class org.omg.CORBA.NVList
Removes the NamedValue object at the given index.
REMOVE_ATTRIBUTE - Static variable in interface javax.naming.directory.DirContext
This constant specifies to delete the specified attribute values from the attribute.
removeAccessibleSelection(int) - Method in class java.awt.List.AccessibleAWTList
Removes the specified selected item in the object from the object's selection.
removeAccessibleSelection(int) - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent
Removes the specified child of the object from the object's selection.
removeAccessibleSelection(int) - Method in interface javax.accessibility.AccessibleSelection
Removes the specified child of the object from the object's selection.
removeAccessibleSelection(int) - Method in class javax.swing.JComboBox.AccessibleJComboBox
Removes the specified child of the object from the object's selection.
removeAccessibleSelection(int) - Method in class javax.swing.JList.AccessibleJList
Removes the specified selected item in the object from the object's selection.
removeAccessibleSelection(int) - Method in class javax.swing.JMenu.AccessibleJMenu
Removes the nth item from the selection.
removeAccessibleSelection(int) - Method in class javax.swing.JMenuBar.AccessibleJMenuBar
Removes the nth selected item in the object from the object's selection.
removeAccessibleSelection(int) - Method in class javax.swing.JTabbedPane.AccessibleJTabbedPane
removeAccessibleSelection(int) - Method in class javax.swing.JTable.AccessibleJTable
Removes the specified child of the object from the object's selection.
removeAccessibleSelection(int) - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode
Removes the specified selected item in the object from the object's selection.
removeAccessibleSelection(int) - Method in class javax.swing.JTree.AccessibleJTree
Removes the specified selected item in the object from the object's selection.
removeActionListener(ActionListener) - Method in class java.awt.Button
Removes the specified action listener so that it no longer receives action events from this button.
removeActionListener(ActionListener) - Method in class java.awt.List
Removes the specified action listener so that it no longer receives action events from this list.
removeActionListener(ActionListener) - Method in class java.awt.MenuItem
Removes the specified action listener so it no longer receives action events from this menu item.
removeActionListener(ActionListener) - Method in class java.awt.TextField
Removes the specified action listener so that it no longer receives action events from this text field.
removeActionListener(ActionListener) - Method in class java.awt.TrayIcon
Removes the specified action listener.
removeActionListener(ActionListener) - Method in class javax.swing.AbstractButton
Removes an ActionListener from the button.
removeActionListener(ActionListener) - Method in interface javax.swing.ButtonModel
Removes an ActionListener from the model.
removeActionListener(ActionListener) - Method in interface javax.swing.ComboBoxEditor
Remove an ActionListener
removeActionListener(ActionListener) - Method in class javax.swing.DefaultButtonModel
Removes an ActionListener from the model.
removeActionListener(ActionListener) - Method in class javax.swing.JComboBox
Removes an ActionListener.
removeActionListener(ActionListener) - Method in class javax.swing.JFileChooser
Removes an ActionListener from the file chooser.
removeActionListener(ActionListener) - Method in class javax.swing.JTextField
Removes the specified action listener so that it no longer receives action events from this textfield.
removeActionListener(ActionListener) - Method in class javax.swing.plaf.basic.BasicComboBoxEditor
removeActionListener(ActionListener) - Method in class javax.swing.Timer
Removes the specified action listener from the Timer.
removeAdjustmentListener(AdjustmentListener) - Method in interface java.awt.Adjustable
Removes an adjustment listener.
removeAdjustmentListener(AdjustmentListener) - Method in class java.awt.Scrollbar
Removes the specified adjustment listener so that it no longer receives instances of AdjustmentEvent from this scroll bar.
removeAdjustmentListener(AdjustmentListener) - Method in class java.awt.ScrollPaneAdjustable
Removes the specified adjustment listener so that it no longer receives adjustment events from this ScrollPaneAdjustable.
removeAdjustmentListener(AdjustmentListener) - Method in class javax.swing.JScrollBar
Removes an AdjustmentEvent listener.
removeAll() - Method in class java.awt.Choice
Removes all items from the choice menu.
removeAll() - Method in class java.awt.Container
Removes all the components from this container.
removeAll() - Method in class java.awt.List
Removes all items from this list.
removeAll() - Method in class java.awt.Menu
Removes all items from this menu.
removeAll(Collection) - Method in class java.beans.beancontext.BeanContextSupport
remove all specified children (Unsupported) implementations must synchronized on the hierarchy lock and "children" protected field
removeAll() - Method in interface java.net.CookieStore
Remove all cookies in this cookie store.
removeAll(Collection<?>) - Method in class java.util.AbstractCollection
Removes all of this collection's elements that are also contained in the specified collection (optional operation).
removeAll(Collection<?>) - Method in class java.util.AbstractSet
Removes from this set all of its elements that are contained in the specified collection (optional operation).
removeAll(Collection<?>) - Method in class java.util.ArrayList
Removes from this list all of its elements that are contained in the specified collection.
removeAll(Collection<?>) - Method in interface java.util.Collection
Removes all of this collection's elements that are also contained in the specified collection (optional operation).
removeAll(Collection<?>) - Method in class java.util.concurrent.ConcurrentSkipListSet
Removes from this set all of its elements that are contained in the specified collection.
removeAll(Collection<?>) - Method in class java.util.concurrent.CopyOnWriteArrayList
Removes from this list all of its elements that are contained in the specified collection.
removeAll(Collection<?>) - Method in class java.util.concurrent.CopyOnWriteArraySet
Removes from this set all of its elements that are contained in the specified collection.
removeAll(Collection<?>) - Method in class java.util.concurrent.SynchronousQueue
Always returns false.
removeAll(Collection<?>) - Method in interface java.util.List
Removes from this list all of its elements that are contained in the specified collection (optional operation).
removeAll(Collection<?>) - Method in interface java.util.Set
Removes from this set all of its elements that are contained in the specified collection (optional operation).
removeAll(Collection<?>) - Method in class java.util.Vector
Removes from this Vector all of its elements that are contained in the specified Collection.
removeAll() - Method in class javax.swing.JDesktopPane
Removes all the components from this container.
removeAll() - Method in class javax.swing.JLayer
Removes all the components from this container.
removeAll() - Method in class javax.swing.JLayeredPane
Removes all the components from this container.
removeAll() - Method in class javax.swing.JMenu
Removes all menu items from this menu.
removeAll() - Method in class javax.swing.JSplitPane
Removes all the child components from the split pane.
removeAll() - Method in class javax.swing.JTabbedPane
Removes all the tabs and their corresponding components from the tabbedpane.
removeAll() - Method in class javax.swing.text.View
Removes all of the children.
removeAllAttachments() - Method in class javax.xml.soap.SOAPMessage
Removes all AttachmentPart objects that have been added to this SOAPMessage object.
removeAllChildren() - Method in class javax.swing.tree.DefaultMutableTreeNode
Removes all of this node's children, setting their parents to null.
removeAllElements() - Method in class java.util.Vector
Removes all components from this vector and sets its size to zero.
removeAllElements() - Method in class javax.swing.DefaultComboBoxModel
Empties the list.
removeAllElements() - Method in class javax.swing.DefaultListModel
Removes all components from this list and sets its size to zero.
removeAllFaultSubcodes() - Method in interface javax.xml.soap.SOAPFault
Removes any Subcodes that may be contained by this SOAPFault.
removeAllHeaders() - Method in class javax.xml.soap.MimeHeaders
Removes all the header entries from this MimeHeaders object.
removeAllHighlights() - Method in class javax.swing.text.DefaultHighlighter
Removes all highlights.
removeAllHighlights() - Method in interface javax.swing.text.Highlighter
Removes all highlights this highlighter is responsible for.
removeAllIIOReadProgressListeners() - Method in class javax.imageio.ImageReader
Removes all currently registered IIOReadProgressListener objects.
removeAllIIOReadUpdateListeners() - Method in class javax.imageio.ImageReader
Removes all currently registered IIOReadUpdateListener objects.
removeAllIIOReadWarningListeners() - Method in class javax.imageio.ImageReader
Removes all currently registered IIOReadWarningListener objects.
removeAllIIOWriteProgressListeners() - Method in class javax.imageio.ImageWriter
Removes all currently registered IIOWriteProgressListener objects.
removeAllIIOWriteWarningListeners() - Method in class javax.imageio.ImageWriter
Removes all currently registered IIOWriteWarningListener objects.
removeAllItems() - Method in class javax.swing.JComboBox
Removes all items from the item list.
removeAllMimeHeaders() - Method in class javax.xml.soap.AttachmentPart
Removes all the MIME header entries.
removeAllMimeHeaders() - Method in class javax.xml.soap.SOAPPart
Removes all the MimeHeader objects for this SOAPEnvelope object.
removeAllNotifications() - Method in class javax.management.timer.Timer
Removes all the timer notifications from the list of notifications and resets the counter used to update the timer notification identifiers.
removeAllNotifications() - Method in interface javax.management.timer.TimerMBean
Removes all the timer notifications from the list of notifications and resets the counter used to update the timer notification identifiers.
removeAncestorListener(AncestorListener) - Method in class javax.swing.JComponent
Unregisters listener so that it will no longer receive AncestorEvents.
removeAttachments(MimeHeaders) - Method in class javax.xml.soap.SOAPMessage
Removes all the AttachmentPart objects that have header entries that match the specified headers.
removeAttribute(String, String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl
Removes an attribute from a previously defined element.
removeAttribute(String) - Method in class javax.imageio.metadata.IIOMetadataNode
removeAttribute(String, int) - Method in interface javax.script.ScriptContext
Remove an attribute in a given scope.
removeAttribute(String, int) - Method in class javax.script.SimpleScriptContext
Remove an attribute in a given scope.
removeAttribute(Object) - Method in class javax.swing.text.AbstractDocument.AbstractElement
Removes an attribute from the set.
removeAttribute(AttributeSet, Object) - Method in interface javax.swing.text.AbstractDocument.AttributeContext
Removes an attribute from the set.
removeAttribute(AttributeSet, Object) - Method in class javax.swing.text.html.StyleSheet
Removes an attribute from the set.
removeAttribute(Object) - Method in interface javax.swing.text.MutableAttributeSet
Removes an attribute with the given name.
removeAttribute(Object) - Method in class javax.swing.text.SimpleAttributeSet
Removes an attribute from the list.
removeAttribute(Object) - Method in class javax.swing.text.StyleContext.NamedStyle
Removes an attribute from the set.
removeAttribute(AttributeSet, Object) - Method in class javax.swing.text.StyleContext
Removes an attribute from the set.
removeAttribute(Name) - Method in interface javax.xml.soap.SOAPElement
Removes the attribute with the specified name.
removeAttribute(QName) - Method in interface javax.xml.soap.SOAPElement
Removes the attribute with the specified qname.
removeAttribute(String) - Method in interface org.w3c.dom.Element
Removes an attribute by name.
removeAttribute(int) - Method in class org.xml.sax.ext.Attributes2Impl
removeAttribute(String) - Method in class org.xml.sax.helpers.AttributeListImpl
Deprecated.
Remove an attribute from the list.
removeAttribute(int) - Method in class org.xml.sax.helpers.AttributesImpl
Remove an attribute from the list.
removeAttributeChangeNotificationListener(NotificationListener, String) - Method in interface javax.management.modelmbean.ModelMBeanNotificationBroadcaster
Removes a listener for attributeChangeNotifications from the RequiredModelMBean.
removeAttributeChangeNotificationListener(NotificationListener, String) - Method in class javax.management.modelmbean.RequiredModelMBean
removeAttributeNode(Attr) - Method in class javax.imageio.metadata.IIOMetadataNode
removeAttributeNode(Attr) - Method in interface org.w3c.dom.Element
Removes the specified attribute node.
removeAttributeNS(String, String) - Method in class javax.imageio.metadata.IIOMetadataNode
Equivalent to removeAttribute(localName).
removeAttributeNS(String, String) - Method in interface org.w3c.dom.Element
Removes an attribute by local name and namespace URI.
removeAttributes(Enumeration<?>) - Method in class javax.swing.text.AbstractDocument.AbstractElement
Removes a set of attributes for the element.
removeAttributes(AttributeSet) - Method in class javax.swing.text.AbstractDocument.AbstractElement
Removes a set of attributes for the element.
removeAttributes(AttributeSet, Enumeration<?>) - Method in interface javax.swing.text.AbstractDocument.AttributeContext
Removes a set of attributes for the element.
removeAttributes(AttributeSet, AttributeSet) - Method in interface javax.swing.text.AbstractDocument.AttributeContext
Removes a set of attributes for the element.
removeAttributes(AttributeSet, Enumeration<?>) - Method in class javax.swing.text.html.StyleSheet
Removes a set of attributes for the element.
removeAttributes(AttributeSet, AttributeSet) - Method in class javax.swing.text.html.StyleSheet
Removes a set of attributes.
removeAttributes(Enumeration<?>) - Method in interface javax.swing.text.MutableAttributeSet
Removes an attribute set with the given names.
removeAttributes(AttributeSet) - Method in interface javax.swing.text.MutableAttributeSet
Removes a set of attributes with the given name.
removeAttributes(Enumeration<?>) - Method in class javax.swing.text.SimpleAttributeSet
Removes a set of attributes from the list.
removeAttributes(AttributeSet) - Method in class javax.swing.text.SimpleAttributeSet
Removes a set of attributes from the list.
removeAttributes(Enumeration<?>) - Method in class javax.swing.text.StyleContext.NamedStyle
Removes a set of attributes for the element.
removeAttributes(AttributeSet) - Method in class javax.swing.text.StyleContext.NamedStyle
Removes a set of attributes for the element.
removeAttributes(AttributeSet, Enumeration<?>) - Method in class javax.swing.text.StyleContext
Removes a set of attributes for the element.
removeAttributes(AttributeSet, AttributeSet) - Method in class javax.swing.text.StyleContext
Removes a set of attributes for the element.
removeAuxiliaryLookAndFeel(LookAndFeel) - Static method in class javax.swing.UIManager
Removes a LookAndFeel from the list of auxiliary look and feels.
removeAWTEventListener(AWTEventListener) - Method in class java.awt.Toolkit
Removes an AWTEventListener from receiving dispatched AWTEvents.
removeBeanContextMembershipListener(BeanContextMembershipListener) - Method in interface java.beans.beancontext.BeanContext
Removes the specified BeanContextMembershipListener so that it no longer receives BeanContextMembershipEvents when the child Component(s) are added or removed.
removeBeanContextMembershipListener(BeanContextMembershipListener) - Method in class java.beans.beancontext.BeanContextSupport
Removes a BeanContextMembershipListener
removeBeanContextServicesListener(BeanContextServicesListener) - Method in interface java.beans.beancontext.BeanContextServices
Removes a BeanContextServicesListener from this BeanContext
removeBeanContextServicesListener(BeanContextServicesListener) - Method in class java.beans.beancontext.BeanContextServicesSupport
remove a BeanContextServicesListener
removeBindings() - Method in interface javax.swing.text.Keymap
Removes all bindings from the keymap.
removeCaretListener(CaretListener) - Method in class javax.swing.text.JTextComponent
Removes a caret listener.
removeCellEditorListener(CellEditorListener) - Method in class javax.swing.AbstractCellEditor
Removes a CellEditorListener from the listener list.
removeCellEditorListener(CellEditorListener) - Method in interface javax.swing.CellEditor
Removes a listener from the list that's notified
removeCellEditorListener(CellEditorListener) - Method in class javax.swing.tree.DefaultTreeCellEditor
Removes the previously added CellEditorListener.
removeCertificate(Certificate) - Method in class java.security.Identity
Deprecated.
Removes a certificate from this identity.
removeChangeListener(ChangeListener) - Method in class javax.swing.AbstractButton
Removes a ChangeListener from the button.
removeChangeListener(ChangeListener) - Method in class javax.swing.AbstractSpinnerModel
Removes a ChangeListener from the model's listener list.
removeChangeListener(ChangeListener) - Method in interface javax.swing.BoundedRangeModel
Removes a ChangeListener from the model's listener list.
removeChangeListener(ChangeListener) - Method in interface javax.swing.ButtonModel
Removes a ChangeListener from the model.
removeChangeListener(ChangeListener) - Method in interface javax.swing.colorchooser.ColorSelectionModel
Removes listener as a listener to changes in the model.
removeChangeListener(ChangeListener) - Method in class javax.swing.colorchooser.DefaultColorSelectionModel
Removes a ChangeListener from the model.
removeChangeListener(ChangeListener) - Method in class javax.swing.DefaultBoundedRangeModel
Removes a ChangeListener.
removeChangeListener(ChangeListener) - Method in class javax.swing.DefaultButtonModel
Removes a ChangeListener from the model.
removeChangeListener(ChangeListener) - Method in class javax.swing.DefaultSingleSelectionModel
Removes a ChangeListener from the button.
removeChangeListener(ChangeListener) - Method in class javax.swing.JProgressBar
Removes a ChangeListener from the progress bar.
removeChangeListener(ChangeListener) - Method in class javax.swing.JSlider
Removes a ChangeListener from the slider.
removeChangeListener(ChangeListener) - Method in class javax.swing.JSpinner
Removes a ChangeListener from this spinner.
removeChangeListener(ChangeListener) - Method in class javax.swing.JTabbedPane
Removes a ChangeListener from this tabbedpane.
removeChangeListener(ChangeListener) - Method in class javax.swing.JViewport
Removes a ChangeListener from the list that's notified each time the views size, position, or the viewports extent size has changed.
removeChangeListener(ChangeListener) - Method in class javax.swing.MenuSelectionManager
Removes a ChangeListener from the button.
removeChangeListener(ChangeListener) - Method in interface javax.swing.SingleSelectionModel
Removes listener as a listener to changes in the model.
removeChangeListener(ChangeListener) - Method in interface javax.swing.SpinnerModel
Removes a ChangeListener from the model's listener list.
removeChangeListener(ChangeListener) - Method in interface javax.swing.text.Caret
Removes a listener that was tracking caret position changes.
removeChangeListener(ChangeListener) - Method in class javax.swing.text.DefaultCaret
Removes a listener that was tracking caret position changes.
removeChangeListener(ChangeListener) - Method in interface javax.swing.text.Style
Removes a listener that was tracking attribute changes.
removeChangeListener(ChangeListener) - Method in class javax.swing.text.StyleContext.NamedStyle
Removes a change listener.
removeChangeListener(ChangeListener) - Method in class javax.swing.text.StyleContext
Removes a listener that was tracking styles being added or removed.
removeChild(Node) - Method in class javax.imageio.metadata.IIOMetadataNode
Removes the child node indicated by oldChild from the list of children, and returns it.
removeChild(Node) - Method in interface org.w3c.dom.Node
Removes the child node indicated by oldChild from the list of children, and returns it.
removeChoosableFileFilter(FileFilter) - Method in class javax.swing.JFileChooser
Removes a filter from the list of user choosable file filters.
removeChooserPanel(AbstractColorChooserPanel) - Method in class javax.swing.JColorChooser
Removes the Color Panel specified.
removeColumn(TableColumn) - Method in class javax.swing.JTable
Removes aColumn from this JTable's array of columns.
removeColumn(TableColumn) - Method in class javax.swing.table.DefaultTableColumnModel
Deletes the column from the tableColumns array.
removeColumn(TableColumn) - Method in interface javax.swing.table.TableColumnModel
Deletes the TableColumn column from the tableColumns array.
removeColumnModelListener(TableColumnModelListener) - Method in class javax.swing.table.DefaultTableColumnModel
Removes a listener for table column model events.
removeColumnModelListener(TableColumnModelListener) - Method in interface javax.swing.table.TableColumnModel
Removes a listener for table column model events.
removeColumnSelectionInterval(int, int) - Method in class javax.swing.JTable
Deselects the columns from index0 to index1, inclusive.
removeComponentListener(ComponentListener) - Method in class java.awt.Component
Removes the specified component listener so that it no longer receives component events from this component.
removeConnectionEventListener(ConnectionEventListener) - Method in interface javax.sql.PooledConnection
Removes the given event listener from the list of components that will be notified when an event occurs on this PooledConnection object.
removeConnectionNotificationListener(NotificationListener) - Method in interface javax.management.remote.JMXConnector
Removes a listener from the list to be informed of changes in status.
removeConnectionNotificationListener(NotificationListener, NotificationFilter, Object) - Method in interface javax.management.remote.JMXConnector
Removes a listener from the list to be informed of changes in status.
removeConnectionNotificationListener(NotificationListener) - Method in class javax.management.remote.rmi.RMIConnector
removeConnectionNotificationListener(NotificationListener, NotificationFilter, Object) - Method in class javax.management.remote.rmi.RMIConnector
removeConsumer(ImageConsumer) - Method in class java.awt.image.FilteredImageSource
Removes an ImageConsumer from the list of consumers interested in data for this image.
removeConsumer(ImageConsumer) - Method in interface java.awt.image.ImageProducer
Removes the specified ImageConsumer object from the list of consumers currently registered to receive image data.
removeConsumer(ImageConsumer) - Method in class java.awt.image.MemoryImageSource
Removes an ImageConsumer from the list of consumers interested in data for this image.
removeConsumer(ImageConsumer) - Method in class java.awt.image.renderable.RenderableImageProducer
Remove an ImageConsumer from the list of consumers interested in data for this image.
removeContainerListener(ContainerListener) - Method in class java.awt.Container
Removes the specified container listener so it no longer receives container events from this container.
removeContents() - Method in interface javax.xml.soap.SOAPElement
Detaches all children of this SOAPElement.
removeControlButtons() - Method in class javax.swing.plaf.metal.MetalFileChooserUI
removeControllerEventListener(ControllerEventListener, int[]) - Method in interface javax.sound.midi.Sequencer
Removes a controller event listener's interest in one or more types of controller event.
removeDescendantSelectedPaths(TreePath, boolean) - Method in class javax.swing.JTree
Removes any paths in the selection that are descendants of path.
removeDescendantToggledPaths(Enumeration<TreePath>) - Method in class javax.swing.JTree
Removes any descendants of the TreePaths in toRemove that have been expanded.
removeDocumentListener(DocumentListener) - Method in class javax.swing.text.AbstractDocument
Removes a document listener.
removeDocumentListener(DocumentListener) - Method in class javax.swing.text.DefaultStyledDocument
Removes a document listener.
removeDocumentListener(DocumentListener) - Method in interface javax.swing.text.Document
Unregisters the given observer from the notification list so it will no longer receive change updates.
removeDragGestureListener(DragGestureListener) - Method in class java.awt.dnd.DragGestureRecognizer
unregister the current DragGestureListener
removeDragSourceListener(DragSourceListener) - Method in class java.awt.dnd.DragSource
Removes the specified DragSourceListener from this DragSource.
removeDragSourceListener(DragSourceListener) - Method in class java.awt.dnd.DragSourceContext
Removes the specified DragSourceListener from this DragSourceContext.
removeDragSourceMotionListener(DragSourceMotionListener) - Method in class java.awt.dnd.DragSource
Removes the specified DragSourceMotionListener from this DragSource.
removeDropTargetListener(DropTargetListener) - Method in class java.awt.dnd.DropTarget
Removes the current DropTargetListener (UNICAST SOURCE).
removeEditor() - Method in class javax.swing.JTable
Discards the editor object and frees the real estate it used for cell rendering.
removeEditor() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
This public method is implementation specific and should be private.
removeEldestEntry(Map.Entry<K, V>) - Method in class java.util.LinkedHashMap
Returns true if this map should remove its eldest entry.
removeElement(Object) - Method in class java.util.Vector
Removes the first (lowest-indexed) occurrence of the argument from this vector.
removeElement(String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl
Removes an element from the format.
removeElement(Object) - Method in class javax.swing.DefaultComboBoxModel
removeElement(Object) - Method in class javax.swing.DefaultListModel
Removes the first (lowest-indexed) occurrence of the argument from this list.
removeElement(Object) - Method in interface javax.swing.MutableComboBoxModel
Removes an item from the model.
removeElement(Element) - Method in class javax.swing.text.DefaultStyledDocument
Removes an element from this document.
removeElementAt(int) - Method in class java.util.Vector
Deletes the component at the specified index.
removeElementAt(int) - Method in class javax.swing.DefaultComboBoxModel
removeElementAt(int) - Method in class javax.swing.DefaultListModel
Deletes the component at the specified index.
removeElementAt(int) - Method in interface javax.swing.MutableComboBoxModel
Removes an item at a specific index.
removeEntries(int, int) - Method in class javax.swing.SizeSequence
Removes a contiguous group of entries from this SizeSequence.
removeEntry(Principal, AclEntry) - Method in interface java.security.acl.Acl
Removes an ACL entry from this ACL.
removeEventListener(String, EventListener, boolean) - Method in interface org.w3c.dom.events.EventTarget
This method allows the removal of event listeners from the event target.
removeField(String) - Method in interface javax.management.Descriptor
Removes a field from the descriptor.
removeField(String) - Method in class javax.management.ImmutableDescriptor
Removes a field from the descriptor.
removeField(String) - Method in class javax.management.modelmbean.DescriptorSupport
removeFirst() - Method in class java.util.ArrayDeque
removeFirst() - Method in class java.util.concurrent.ConcurrentLinkedDeque
removeFirst() - Method in class java.util.concurrent.LinkedBlockingDeque
removeFirst() - Method in interface java.util.Deque
Retrieves and removes the first element of this deque.
removeFirst() - Method in class java.util.LinkedList
Removes and returns the first element from this list.
removeFirstOccurrence(Object) - Method in class java.util.ArrayDeque
Removes the first occurrence of the specified element in this deque (when traversing the deque from head to tail).
removeFirstOccurrence(Object) - Method in interface java.util.concurrent.BlockingDeque
Removes the first occurrence of the specified element from this deque.
removeFirstOccurrence(Object) - Method in class java.util.concurrent.ConcurrentLinkedDeque
Removes the first element e such that o.equals(e), if such an element exists in this deque.
removeFirstOccurrence(Object) - Method in class java.util.concurrent.LinkedBlockingDeque
removeFirstOccurrence(Object) - Method in interface java.util.Deque
Removes the first occurrence of the specified element from this deque.
removeFirstOccurrence(Object) - Method in class java.util.LinkedList
Removes the first occurrence of the specified element in this list (when traversing the list from head to tail).
removeFlavorListener(FlavorListener) - Method in class java.awt.datatransfer.Clipboard
Removes the specified FlavorListener so that it no longer receives FlavorEvents from this Clipboard.
removeFocusListener(FocusListener) - Method in class java.awt.Component.AccessibleAWTComponent
Removes the specified focus listener so it no longer receives focus events from this component.
removeFocusListener(FocusListener) - Method in class java.awt.Component
Removes the specified focus listener so that it no longer receives focus events from this component.
removeFocusListener(FocusListener) - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild
Removes the specified focus listener so it no longer receives focus events from this component.
removeFocusListener(FocusListener) - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent
Removes the specified focus listener so it no longer receives focus events from this component.
removeFocusListener(FocusListener) - Method in interface javax.accessibility.AccessibleComponent
Removes the specified focus listener so it no longer receives focus events from this component.
removeFocusListener(FocusListener) - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild
removeFocusListener(FocusListener) - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell
removeFocusListener(FocusListener) - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode
removeFocusListener(FocusListener) - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
removeFromEnvironment(String) - Method in interface javax.naming.Context
Removes an environment property from the environment of this context.
removeFromEnvironment(String) - Method in class javax.naming.InitialContext
removeFromParent() - Method in class javax.swing.tree.DefaultMutableTreeNode
Removes the subtree rooted at this node from the tree, giving this node a null parent.
removeFromParent() - Method in interface javax.swing.tree.MutableTreeNode
Removes the receiver from its parent.
removeFromSource() - Method in class javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler
removeHandler(Handler) - Method in class java.util.logging.Logger
Remove a log Handler.
removeHandshakeCompletedListener(HandshakeCompletedListener) - Method in class javax.net.ssl.SSLSocket
Removes a previously registered handshake completion listener.
removeHeader(String) - Method in class javax.xml.soap.MimeHeaders
Remove all MimeHeader objects whose name matches the given name.
removeHierarchyBoundsListener(HierarchyBoundsListener) - Method in class java.awt.Component
Removes the specified hierarchy bounds listener so that it no longer receives hierarchy bounds events from this component.
removeHierarchyListener(HierarchyListener) - Method in class java.awt.Component
Removes the specified hierarchy listener so that it no longer receives hierarchy changed events from this component.
removeHighlight(Object) - Method in class javax.swing.text.DefaultHighlighter
Removes a highlight from the view.
removeHighlight(Object) - Method in interface javax.swing.text.Highlighter
Removes a highlight from the view.
removeHyperlinkListener(HyperlinkListener) - Method in class javax.swing.JEditorPane
Removes a hyperlink listener.
removeIconFor(JInternalFrame) - Method in class javax.swing.DefaultDesktopManager
Convenience method to remove the desktopIcon of f is necessary.
removeIdentity(Identity) - Method in class java.security.IdentityScope
Deprecated.
Removes an identity from this identity scope.
removeIf(Predicate<? super E>) - Method in class java.util.ArrayList
removeIf(Predicate<? super E>) - Method in interface java.util.Collection
Removes all of the elements of this collection that satisfy the given predicate.
removeIf(Predicate<? super E>) - Method in class java.util.concurrent.CopyOnWriteArrayList
removeIf(Predicate<? super E>) - Method in class java.util.concurrent.CopyOnWriteArraySet
removeIf(Predicate<? super E>) - Method in class java.util.Vector
removeIIOReadProgressListener(IIOReadProgressListener) - Method in class javax.imageio.ImageReader
Removes an IIOReadProgressListener from the list of registered progress listeners.
removeIIOReadUpdateListener(IIOReadUpdateListener) - Method in class javax.imageio.ImageReader
Removes an IIOReadUpdateListener from the list of registered update listeners.
removeIIOReadWarningListener(IIOReadWarningListener) - Method in class javax.imageio.ImageReader
Removes an IIOReadWarningListener from the list of registered error listeners.
removeIIOWriteProgressListener(IIOWriteProgressListener) - Method in class javax.imageio.ImageWriter
Removes an IIOWriteProgressListener from the list of registered progress listeners.
removeIIOWriteWarningListener(IIOWriteWarningListener) - Method in class javax.imageio.ImageWriter
Removes an IIOWriteWarningListener from the list of registered warning listeners.
removeImage(Image) - Method in class java.awt.MediaTracker
Removes the specified image from this media tracker.
removeImage(Image, int) - Method in class java.awt.MediaTracker
Removes the specified image from the specified tracking ID of this media tracker.
removeImage(Image, int, int, int) - Method in class java.awt.MediaTracker
Removes the specified image with the specified width, height, and ID from this media tracker.
removeImage(int) - Method in class javax.imageio.ImageWriter
Removes an image from the stream.
removeIndexInterval(int, int) - Method in class javax.swing.DefaultListSelectionModel
Remove the indices in the interval index0,index1 (inclusive) from the selection model.
removeIndexInterval(int, int) - Method in interface javax.swing.ListSelectionModel
Remove the indices in the interval index0,index1 (inclusive) from the selection model.
removeInputMethodListener(InputMethodListener) - Method in class java.awt.Component
Removes the specified input method listener so that it no longer receives input method events from this component.
removeInternal(EventListener, EventListener) - Static method in class java.awt.AWTEventMulticaster
Returns the resulting multicast listener after removing the old listener from listener-l.
removeInternalFrameListener(InternalFrameListener) - Method in class javax.swing.JInternalFrame
Removes the specified internal frame listener so that it no longer receives internal frame events from this internal frame.
removeInvalidComponent(JComponent) - Method in class javax.swing.RepaintManager
Remove a component from the list of invalid components.
removeItem(Object) - Method in class javax.swing.JComboBox
Removes an item from the item list.
removeItemAt(int) - Method in class javax.swing.JComboBox
Removes the item at anIndex This method works only if the JComboBox uses a mutable data model.
removeItemListener(ItemListener) - Method in class java.awt.Checkbox
Removes the specified item listener so that the item listener no longer receives item events from this check box.
removeItemListener(ItemListener) - Method in class java.awt.CheckboxMenuItem
Removes the specified item listener so that it no longer receives item events from this check box menu item.
removeItemListener(ItemListener) - Method in class java.awt.Choice
Removes the specified item listener so that it no longer receives item events from this Choice menu.
removeItemListener(ItemListener) - Method in interface java.awt.ItemSelectable
Removes an item listener.
removeItemListener(ItemListener) - Method in class java.awt.List
Removes the specified item listener so that it no longer receives item events from this list.
removeItemListener(ItemListener) - Method in class javax.swing.AbstractButton
Removes an ItemListener from the button.
removeItemListener(ItemListener) - Method in interface javax.swing.ButtonModel
Removes an ItemListener from the model.
removeItemListener(ItemListener) - Method in class javax.swing.DefaultButtonModel
Removes an ItemListener from the model.
removeItemListener(ItemListener) - Method in class javax.swing.JComboBox
Removes an ItemListener.
removeKeyEventDispatcher(KeyEventDispatcher) - Method in class java.awt.KeyboardFocusManager
Removes a KeyEventDispatcher which was previously added to this KeyboardFocusManager's dispatcher chain.
removeKeyEventPostProcessor(KeyEventPostProcessor) - Method in class java.awt.KeyboardFocusManager
Removes a previously added KeyEventPostProcessor from this KeyboardFocusManager's post-processor chain.
removeKeyListener(KeyListener) - Method in class java.awt.Component
Removes the specified key listener so that it no longer receives key events from this component.
removeKeymap(String) - Static method in class javax.swing.text.JTextComponent
Removes a named keymap previously added to the document.
removeKeyStrokeBinding(KeyStroke) - Method in interface javax.swing.text.Keymap
Removes a binding from the keymap.
removeLast() - Method in class java.util.ArrayDeque
removeLast() - Method in class java.util.concurrent.ConcurrentLinkedDeque
removeLast() - Method in class java.util.concurrent.LinkedBlockingDeque
removeLast() - Method in interface java.util.Deque
Retrieves and removes the last element of this deque.
removeLast() - Method in class java.util.LinkedList
Removes and returns the last element from this list.
removeLastOccurrence(Object) - Method in class java.util.ArrayDeque
Removes the last occurrence of the specified element in this deque (when traversing the deque from head to tail).
removeLastOccurrence(Object) - Method in interface java.util.concurrent.BlockingDeque
Removes the last occurrence of the specified element from this deque.
removeLastOccurrence(Object) - Method in class java.util.concurrent.ConcurrentLinkedDeque
Removes the last element e such that o.equals(e), if such an element exists in this deque.
removeLastOccurrence(Object) - Method in class java.util.concurrent.LinkedBlockingDeque
removeLastOccurrence(Object) - Method in interface java.util.Deque
Removes the last occurrence of the specified element from this deque.
removeLastOccurrence(Object) - Method in class java.util.LinkedList
Removes the last occurrence of the specified element in this list (when traversing the list from head to tail).
removeLayoutComponent(Component) - Method in class java.awt.BorderLayout
Removes the specified component from this border layout.
removeLayoutComponent(Component) - Method in class java.awt.CardLayout
Removes the specified component from the layout.
removeLayoutComponent(Component) - Method in class java.awt.FlowLayout
Removes the specified component from the layout.
removeLayoutComponent(Component) - Method in class java.awt.GridBagLayout
Removes the specified component from this layout.
removeLayoutComponent(Component) - Method in class java.awt.GridLayout
Removes the specified component from the layout.
removeLayoutComponent(Component) - Method in interface java.awt.LayoutManager
Removes the specified component from the layout.
removeLayoutComponent(Component) - Method in class javax.swing.BoxLayout
Not used by this class.
removeLayoutComponent(Component) - Method in class javax.swing.GroupLayout
Notification that a Component has been removed from the parent container.
removeLayoutComponent(Component) - Method in class javax.swing.JRootPane.RootLayout
removeLayoutComponent(Component) - Method in class javax.swing.JSpinner.DefaultEditor
This LayoutManager method does nothing.
removeLayoutComponent(Component) - Method in class javax.swing.OverlayLayout
Removes the specified component from the layout.
removeLayoutComponent(Component) - Method in class javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager
removeLayoutComponent(Component) - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane.TitlePaneLayout
removeLayoutComponent(Component) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI.InternalFrameLayout
removeLayoutComponent(Component) - Method in class javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout
removeLayoutComponent(Component) - Method in class javax.swing.plaf.basic.BasicScrollBarUI
removeLayoutComponent(Component) - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider.DividerLayout
removeLayoutComponent(Component) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager
Removes the specified component from our knowledge.
removeLayoutComponent(Component) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout
removeLayoutComponent(Component) - Method in class javax.swing.ScrollPaneLayout
Removes the specified component from the layout.
removeLayoutComponent(Component) - Method in class javax.swing.SpringLayout
Removes the constraints associated with the specified component.
removeLayoutComponent(Component) - Method in class javax.swing.ViewportLayout
Removes the specified component from the layout.
removeLineListener(LineListener) - Method in interface javax.sound.sampled.Line
Removes the specified listener from this line's list of listeners.
removeListDataListener(ListDataListener) - Method in class javax.swing.AbstractListModel
Removes a listener from the list that's notified each time a change to the data model occurs.
removeListDataListener(ListDataListener) - Method in interface javax.swing.ListModel
Removes a listener from the list that's notified each time a change to the data model occurs.
removeListeners() - Method in class javax.swing.plaf.metal.MetalComboBoxUI
Deprecated.
As of Java 2 platform v1.4.
removeListSelectionListener(ListSelectionListener) - Method in class javax.swing.DefaultListSelectionModel
Remove a listener from the list that's notified each time a change to the selection occurs.
removeListSelectionListener(ListSelectionListener) - Method in class javax.swing.JList
Removes a selection listener from the list.
removeListSelectionListener(ListSelectionListener) - Method in interface javax.swing.ListSelectionModel
Remove a listener from the list that's notified each time a change to the selection occurs.
removeMember(Principal) - Method in interface java.security.acl.Group
Removes the specified member from the group.
removeMenuDragMouseListener(MenuDragMouseListener) - Method in class javax.swing.JMenuItem
Removes a MenuDragMouseListener from the menu item.
removeMenuKeyListener(MenuKeyListener) - Method in class javax.swing.JMenuItem
Removes a MenuKeyListener from the menu item.
removeMenuKeyListener(MenuKeyListener) - Method in class javax.swing.JPopupMenu
Removes a MenuKeyListener from the popup menu.
removeMenuListener(MenuListener) - Method in class javax.swing.JMenu
Removes a listener for menu events.
removeMetaEventListener(MetaEventListener) - Method in interface javax.sound.midi.Sequencer
Removes the specified meta-event listener from this sequencer's list of registered listeners, if in fact the listener is registered.
removeMimeHeader(String) - Method in class javax.xml.soap.AttachmentPart
Removes all MIME headers that match the given name.
removeMimeHeader(String) - Method in class javax.xml.soap.SOAPPart
Removes all MIME headers that match the given name.
removeMouseListener(MouseListener) - Method in class java.awt.Component
Removes the specified mouse listener so that it no longer receives mouse events from this component.
removeMouseListener(MouseListener) - Method in class java.awt.TrayIcon
Removes the specified mouse listener.
removeMouseMotionListener(MouseMotionListener) - Method in class java.awt.Component
Removes the specified mouse motion listener so that it no longer receives mouse motion events from this component.
removeMouseMotionListener(MouseMotionListener) - Method in class java.awt.TrayIcon
Removes the specified mouse-motion listener.
removeMouseWheelListener(MouseWheelListener) - Method in class java.awt.Component
Removes the specified mouse wheel listener so that it no longer receives mouse wheel events from this component.
removeNamedItem(String) - Method in interface org.w3c.dom.NamedNodeMap
Removes a node specified by name.
removeNamedItemNS(String, String) - Method in interface org.w3c.dom.NamedNodeMap
Removes a node specified by local name and namespace URI.
removeNamespaceDeclaration(String) - Method in interface javax.xml.soap.SOAPElement
Removes the namespace declaration corresponding to the given prefix.
removeNamingListener(NamingListener) - Method in interface javax.naming.event.EventContext
Removes a listener from receiving naming events fired by this EventContext.
removeNode() - Method in class java.util.prefs.AbstractPreferences
Implements the removeNode() method as per the specification in Preferences.removeNode().
removeNode() - Method in class java.util.prefs.Preferences
Removes this preference node and all of its descendants, invalidating any preferences contained in the removed nodes.
removeNodeChangeListener(NodeChangeListener) - Method in class java.util.prefs.AbstractPreferences
removeNodeChangeListener(NodeChangeListener) - Method in class java.util.prefs.Preferences
Removes the specified NodeChangeListener, so it no longer receives change events.
removeNodeFromParent(MutableTreeNode) - Method in class javax.swing.tree.DefaultTreeModel
Message this to remove node from its parent.
removeNodeSpi() - Method in class java.util.prefs.AbstractPreferences
Removes this preference node, invalidating it and any preferences that it contains.
removeNotification(Integer) - Method in class javax.management.timer.Timer
Removes the timer notification corresponding to the specified identifier from the list of notifications.
removeNotification(Integer) - Method in interface javax.management.timer.TimerMBean
Removes the timer notification corresponding to the specified identifier from the list of notifications.
removeNotificationListener(ObjectName, ObjectName) - Method in interface javax.management.MBeanServer
removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) - Method in interface javax.management.MBeanServer
removeNotificationListener(ObjectName, NotificationListener) - Method in interface javax.management.MBeanServer
removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) - Method in interface javax.management.MBeanServer
removeNotificationListener(ObjectName, ObjectName) - Method in interface javax.management.MBeanServerConnection
Removes a listener from a registered MBean.
removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) - Method in interface javax.management.MBeanServerConnection
Removes a listener from a registered MBean.
removeNotificationListener(ObjectName, NotificationListener) - Method in interface javax.management.MBeanServerConnection
Removes a listener from a registered MBean.
removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) - Method in interface javax.management.MBeanServerConnection
Removes a listener from a registered MBean.
removeNotificationListener(NotificationListener, NotificationFilter, Object) - Method in class javax.management.MBeanServerDelegate
removeNotificationListener(NotificationListener) - Method in class javax.management.MBeanServerDelegate
removeNotificationListener(NotificationListener) - Method in class javax.management.modelmbean.RequiredModelMBean
Removes a listener for Notifications from the RequiredModelMBean.
removeNotificationListener(NotificationListener, NotificationFilter, Object) - Method in class javax.management.modelmbean.RequiredModelMBean
removeNotificationListener(NotificationListener) - Method in interface javax.management.NotificationBroadcaster
Removes a listener from this MBean.
removeNotificationListener(NotificationListener) - Method in class javax.management.NotificationBroadcasterSupport
removeNotificationListener(NotificationListener, NotificationFilter, Object) - Method in class javax.management.NotificationBroadcasterSupport
removeNotificationListener(NotificationListener, NotificationFilter, Object) - Method in interface javax.management.NotificationEmitter
Removes a listener from this MBean.
removeNotificationListener(ObjectName, ObjectName, Subject) - Method in interface javax.management.remote.rmi.RMIConnection
Handles the method MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName).
removeNotificationListener(ObjectName, ObjectName, MarshalledObject, MarshalledObject, Subject) - Method in interface javax.management.remote.rmi.RMIConnection
Handles the method MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object).
removeNotificationListener(ObjectName, ObjectName, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl
removeNotificationListener(ObjectName, ObjectName, MarshalledObject, MarshalledObject, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl
removeNotificationListener(ObjectName, ObjectName, MarshalledObject, MarshalledObject, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub
removeNotificationListener(ObjectName, ObjectName, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub
removeNotificationListener(NotificationListener) - Method in class javax.management.StandardEmitterMBean
removeNotificationListener(NotificationListener, NotificationFilter, Object) - Method in class javax.management.StandardEmitterMBean
removeNotificationListeners(ObjectName, Integer[], Subject) - Method in interface javax.management.remote.rmi.RMIConnection
Handles the removeNotificationListener(ObjectName, NotificationListener) and removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) methods.
removeNotificationListeners(ObjectName, Integer[], Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl
removeNotificationListeners(ObjectName, Integer[], Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub
removeNotifications(String) - Method in class javax.management.timer.Timer
Removes all the timer notifications corresponding to the specified type from the list of notifications.
removeNotifications(String) - Method in interface javax.management.timer.TimerMBean
Removes all the timer notifications corresponding to the specified type from the list of notifications.
removeNotify() - Method in class java.awt.Component
Makes this Component undisplayable by destroying it native screen resource.
removeNotify() - Method in class java.awt.Container
Makes this Container undisplayable by removing its connection to its native screen resource.
removeNotify(ComponentPeer) - Method in class java.awt.dnd.DropTarget
Notify the DropTarget that it has been disassociated from a Component This method is usually called from java.awt.Component.removeNotify() of the Component associated with this DropTarget to notify the DropTarget that a ComponentPeer has been disassociated with that Component.
removeNotify() - Method in class java.awt.dnd.DropTargetContext
Called when disassociated with the DropTargetContextPeer.
removeNotify() - Method in class java.awt.Frame
Makes this Frame undisplayable by removing its connection to its native screen resource.
removeNotify(Component) - Method in class java.awt.im.InputContext
Notifies the input context that a client component has been removed from its containment hierarchy, or that input method support has been disabled for the component.
removeNotify() - Method in interface java.awt.im.spi.InputMethod
Notifies the input method that a client component has been removed from its containment hierarchy, or that input method support has been disabled for the component.
removeNotify() - Method in class java.awt.List
Removes the peer for this list.
removeNotify() - Method in class java.awt.Menu
Removes the menu's peer.
removeNotify() - Method in class java.awt.MenuBar
Removes the menu bar's peer.
removeNotify() - Method in class java.awt.MenuComponent
Removes the menu component's peer.
removeNotify() - Method in class java.awt.TextComponent
Removes the TextComponent's peer.
removeNotify() - Method in class java.awt.Window
Makes this Container undisplayable by removing its connection to its native screen resource.
removeNotify() - Method in class javax.swing.AbstractButton
Notifies this component that it no longer has a parent component.
removeNotify() - Method in class javax.swing.JButton
Overrides JComponent.removeNotify to check if this button is currently set as the default button on the RootPane, and if so, sets the RootPane's default button to null to ensure the RootPane doesn't hold onto an invalid button reference.
removeNotify() - Method in class javax.swing.JComponent
Notifies this component that it no longer has a parent component.
removeNotify() - Method in class javax.swing.JLayer
Notifies this component that it no longer has a parent component.
removeNotify() - Method in class javax.swing.JMenuBar
Overrides JComponent.removeNotify to unregister this menu bar with the current keyboard manager.
removeNotify() - Method in class javax.swing.JRootPane
Notifies this component that it no longer has a parent component.
removeNotify() - Method in class javax.swing.JTable
Calls the unconfigureEnclosingScrollPane method.
removeNotify() - Method in class javax.swing.text.JTextComponent
removeObjectValue(String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl
Disallows an Object reference from being stored in nodes implementing the named element.
removeObservedObject(ObjectName) - Method in class javax.management.monitor.Monitor
Removes the specified object from the set of observed MBeans.
removeObservedObject(ObjectName) - Method in interface javax.management.monitor.MonitorMBean
Removes the specified object from the set of observed MBeans.
removeParameter(String) - Method in class javax.activation.MimeType
Remove any value associated with the given name.
removeParameters() - Method in class java.awt.image.renderable.ParameterBlock
Clears the list of parameters.
removePermission(Permission) - Method in interface java.security.acl.AclEntry
Removes the specified permission from this ACL entry.
removePopupMenuListener(PopupMenuListener) - Method in class javax.swing.JComboBox
Removes a PopupMenuListener.
removePopupMenuListener(PopupMenuListener) - Method in class javax.swing.JPopupMenu
Removes a PopupMenu listener.
removePreferenceChangeListener(PreferenceChangeListener) - Method in class java.util.prefs.AbstractPreferences
removePreferenceChangeListener(PreferenceChangeListener) - Method in class java.util.prefs.Preferences
Removes the specified preference change listener, so it no longer receives preference change events.
removePrintJobAttributeListener(PrintJobAttributeListener) - Method in interface javax.print.DocPrintJob
Removes an attribute listener from this print job.
removePrintJobListener(PrintJobListener) - Method in interface javax.print.DocPrintJob
Removes a listener from this print job.
removePrintServiceAttributeListener(PrintServiceAttributeListener) - Method in interface javax.print.PrintService
Removes the print-service listener from this print service.
removePropertyChangeListener(PropertyChangeListener) - Method in class java.awt.Component.AccessibleAWTComponent
Remove a PropertyChangeListener from the listener list.
removePropertyChangeListener(PropertyChangeListener) - Method in class java.awt.Component
Removes a PropertyChangeListener from the listener list.
removePropertyChangeListener(String, PropertyChangeListener) - Method in class java.awt.Component
Removes a PropertyChangeListener from the listener list for a specific property.
removePropertyChangeListener(PropertyChangeListener) - Method in class java.awt.Container.AccessibleAWTContainer
Remove a PropertyChangeListener from the listener list.
removePropertyChangeListener(PropertyChangeListener) - Method in class java.awt.KeyboardFocusManager
Removes a PropertyChangeListener from the listener list.
removePropertyChangeListener(String, PropertyChangeListener) - Method in class java.awt.KeyboardFocusManager
Removes a PropertyChangeListener from the listener list for a specific property.
removePropertyChangeListener(String, PropertyChangeListener) - Method in class java.awt.SystemTray
Removes a PropertyChangeListener from the listener list for a specific property.
removePropertyChangeListener(String, PropertyChangeListener) - Method in class java.awt.Toolkit
Removes the specified property change listener for the named desktop property.
removePropertyChangeListener(String, PropertyChangeListener) - Method in interface java.beans.beancontext.BeanContextChild
Removes a PropertyChangeListener from this BeanContextChild so that it no longer receives PropertyChangeEvents when the specified property is changed.
removePropertyChangeListener(String, PropertyChangeListener) - Method in class java.beans.beancontext.BeanContextChildSupport
Remove a PropertyChangeListener for a specific property.
removePropertyChangeListener(PropertyChangeListener) - Method in interface java.beans.Customizer
Remove a listener for the PropertyChange event.
removePropertyChangeListener(PropertyChangeListener) - Method in class java.beans.PropertyChangeSupport
Remove a PropertyChangeListener from the listener list.
removePropertyChangeListener(String, PropertyChangeListener) - Method in class java.beans.PropertyChangeSupport
Remove a PropertyChangeListener for a specific property.
removePropertyChangeListener(PropertyChangeListener) - Method in interface java.beans.PropertyEditor
Removes a listener for the value change.
removePropertyChangeListener(PropertyChangeListener) - Method in class java.beans.PropertyEditorSupport
Removes a listener for the value change.
removePropertyChangeListener(PropertyChangeListener) - Method in interface java.util.jar.Pack200.Packer
Deprecated.
The dependency on PropertyChangeListener creates a significant impediment to future modularization of the Java platform. This method will be removed in a future release.
removePropertyChangeListener(PropertyChangeListener) - Method in interface java.util.jar.Pack200.Unpacker
Deprecated.
The dependency on PropertyChangeListener creates a significant impediment to future modularization of the Java platform. This method will be removed in a future release.
removePropertyChangeListener(PropertyChangeListener) - Method in class java.util.logging.LogManager
Deprecated.
The dependency on PropertyChangeListener creates a significant impediment to future modularization of the Java platform. This method will be removed in a future release. The global LogManager can detect changes to the logging configuration by overridding the readConfiguration method.
removePropertyChangeListener(PropertyChangeListener) - Method in class javax.accessibility.AccessibleContext
Removes a PropertyChangeListener from the listener list.
removePropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.AbstractAction
Removes a PropertyChangeListener from the listener list.
removePropertyChangeListener(PropertyChangeListener) - Method in interface javax.swing.Action
Removes a PropertyChange listener.
removePropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.JComponent.AccessibleJComponent
Removes a PropertyChangeListener from the listener list.
removePropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild
removePropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell
Removes a PropertyChangeListener from the listener list.
removePropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode
Remove a PropertyChangeListener from the listener list.
removePropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.JTree.EmptySelectionModel
This is overriden to do nothing; EmptySelectionModel does not allow a selection.
removePropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.plaf.basic.BasicDirectoryModel
Removes a PropertyChangeListener from the listener list.
removePropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.plaf.LayerUI
Removes a PropertyChangeListener from the listener list.
removePropertyChangeListener(String, PropertyChangeListener) - Method in class javax.swing.plaf.LayerUI
Removes a PropertyChangeListener from the listener list for a specific property.
removePropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.SwingWorker
Removes a PropertyChangeListener from the listener list.
removePropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
removePropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.table.TableColumn
Removes a PropertyChangeListener from the listener list.
removePropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.tree.DefaultTreeSelectionModel
Removes a PropertyChangeListener from the listener list.
removePropertyChangeListener(PropertyChangeListener) - Method in interface javax.swing.tree.TreeSelectionModel
Removes a PropertyChangeListener from the listener list.
removePropertyChangeListener(PropertyChangeListener) - Method in class javax.swing.UIDefaults
Removes a PropertyChangeListener from the listener list.
removePropertyChangeListener(PropertyChangeListener) - Static method in class javax.swing.UIManager
Removes a PropertyChangeListener from the listener list.
removeProvider(String) - Static method in class java.security.Security
Removes the provider with the specified name.
removeRange(int, int) - Method in class java.util.AbstractList
Removes from this list all of the elements whose index is between fromIndex, inclusive, and toIndex, exclusive.
removeRange(int, int) - Method in class java.util.ArrayList
Removes from this list all of the elements whose index is between fromIndex, inclusive, and toIndex, exclusive.
removeRange(int, int) - Method in class java.util.Vector
Removes from this list all of the elements whose index is between fromIndex, inclusive, and toIndex, exclusive.
removeRange(int, int) - Method in class javax.swing.DefaultListModel
Deletes the components at the specified range of indexes.
removeRedundantState() - Method in class javax.swing.undo.StateEdit
Remove redundant key/values in state hashtables.
removeRelation(String) - Method in class javax.management.relation.RelationService
Removes given relation from the Relation Service.
removeRelation(String) - Method in interface javax.management.relation.RelationServiceMBean
Removes given relation from the Relation Service.
removeRelationType(String) - Method in class javax.management.relation.RelationService
Removes given relation type from Relation Service.
removeRelationType(String) - Method in interface javax.management.relation.RelationServiceMBean
Removes given relation type from Relation Service.
removeResourceBundle(String) - Method in class javax.swing.UIDefaults
Removes a resource bundle from the list of resource bundles that are searched for localized defaults.
removeRow(int) - Method in class javax.swing.table.DefaultTableModel
Removes the row at row from the model.
removeRowSelectionInterval(int, int) - Method in class javax.swing.JTable
Deselects the rows from index0 to index1, inclusive.
removeRowSetListener(RowSetListener) - Method in class javax.sql.rowset.BaseRowSet
Removes the designated object from this RowSet object's list of listeners.
removeRowSetListener(RowSetListener) - Method in interface javax.sql.RowSet
Removes the specified listener from the list of components that will be notified when an event occurs on this RowSet object.
removeRowSorterListener(RowSorterListener) - Method in class javax.swing.RowSorter
Removes a RowSorterListener.
removeSelectionInterval(int, int) - Method in class javax.swing.DefaultListSelectionModel
Changes the selection to be the set difference of the current selection and the indices between index0 and index1 inclusive.
removeSelectionInterval(int, int) - Method in class javax.swing.JList
Sets the selection to be the set difference of the specified interval and the current selection.
removeSelectionInterval(int, int) - Method in class javax.swing.JTree
Removes the specified rows (inclusive) from the selection.
removeSelectionInterval(int, int) - Method in interface javax.swing.ListSelectionModel
Changes the selection to be the set difference of the current selection and the indices between index0 and index1 inclusive.
removeSelectionPath(TreePath) - Method in class javax.swing.JTree
Removes the node identified by the specified path from the current selection.
removeSelectionPath(TreePath) - Method in class javax.swing.tree.DefaultTreeSelectionModel
Removes path from the selection.
removeSelectionPath(TreePath) - Method in interface javax.swing.tree.TreeSelectionModel
Removes path from the selection.
removeSelectionPaths(TreePath[]) - Method in class javax.swing.JTree.EmptySelectionModel
This is overriden to do nothing; EmptySelectionModel does not allow a selection.
removeSelectionPaths(TreePath[]) - Method in class javax.swing.JTree
Removes the nodes identified by the specified paths from the current selection.
removeSelectionPaths(TreePath[]) - Method in class javax.swing.tree.DefaultTreeSelectionModel
Removes paths from the selection.
removeSelectionPaths(TreePath[]) - Method in interface javax.swing.tree.TreeSelectionModel
Removes paths from the selection.
removeSelectionRow(int) - Method in class javax.swing.JTree
Removes the row at the index row from the current selection.
removeSelectionRows(int[]) - Method in class javax.swing.JTree
Removes the rows that are selected at each of the specified rows.
removeService(Provider.Service) - Method in class java.security.Provider
Remove a service previously added using putService().
removeShutdownHook(Thread) - Method in class java.lang.Runtime
De-registers a previously-registered virtual-machine shutdown hook.
removeSources() - Method in class java.awt.image.renderable.ParameterBlock
Clears the list of source images.
removeSpi(String) - Method in class java.util.prefs.AbstractPreferences
Remove the association (if any) for the specified key at this preference node.
removeStatementEventListener(StatementEventListener) - Method in interface javax.sql.PooledConnection
Removes the specified StatementEventListener from the list of components that will be notified when the driver detects that a PreparedStatement has been closed or is invalid.
removeStyle(String) - Method in class javax.swing.JTextPane
Removes a named non-null style previously added to the document.
removeStyle(String) - Method in class javax.swing.text.DefaultStyledDocument
Removes a named style previously added to the document.
removeStyle(String) - Method in class javax.swing.text.html.StyleSheet
Removes a named style previously added to the document.
removeStyle(String) - Method in class javax.swing.text.StyleContext
Removes a named style previously added to the document.
removeStyle(String) - Method in interface javax.swing.text.StyledDocument
Removes a named style previously added to the document.
removeStyleSheet(StyleSheet) - Method in class javax.swing.text.html.StyleSheet
Removes the StyleSheet ss from those of the receiver.
removeTabAt(int) - Method in class javax.swing.JTabbedPane
Removes the tab at index.
removeTableModelListener(TableModelListener) - Method in class javax.swing.table.AbstractTableModel
Removes a listener from the list that's notified each time a change to the data model occurs.
removeTableModelListener(TableModelListener) - Method in interface javax.swing.table.TableModel
Removes a listener from the list that is notified each time a change to the data model occurs.
removeTextListener(TextListener) - Method in class java.awt.TextComponent
Removes the specified text event listener so that it no longer receives text events from this text component If l is null, no exception is thrown and no action is performed.
removeTileObserver(TileObserver) - Method in class java.awt.image.BufferedImage
Removes a tile observer.
removeTileObserver(TileObserver) - Method in interface java.awt.image.WritableRenderedImage
Removes an observer.
removeTransformer(ClassFileTransformer) - Method in interface java.lang.instrument.Instrumentation
Unregisters the supplied transformer.
removeTreeExpansionListener(TreeExpansionListener) - Method in class javax.swing.JTree
Removes a listener for TreeExpansion events.
removeTreeModelListener(TreeModelListener) - Method in class javax.swing.tree.DefaultTreeModel
Removes a listener previously added with addTreeModelListener().
removeTreeModelListener(TreeModelListener) - Method in interface javax.swing.tree.TreeModel
Removes a listener previously added with addTreeModelListener.
removeTreeSelectionListener(TreeSelectionListener) - Method in class javax.swing.JTree.EmptySelectionModel
This is overriden to do nothing; EmptySelectionModel does not allow a selection.
removeTreeSelectionListener(TreeSelectionListener) - Method in class javax.swing.JTree
Removes a TreeSelection listener.
removeTreeSelectionListener(TreeSelectionListener) - Method in class javax.swing.tree.DefaultTreeSelectionModel
Removes x from the list of listeners that are notified each time the set of selected TreePaths changes.
removeTreeSelectionListener(TreeSelectionListener) - Method in interface javax.swing.tree.TreeSelectionModel
Removes x from the list of listeners that are notified each time the set of selected TreePaths changes.
removeTreeWillExpandListener(TreeWillExpandListener) - Method in class javax.swing.JTree
Removes a listener for TreeWillExpand events.
removeUndoableEditListener(UndoableEditListener) - Method in class javax.swing.text.AbstractDocument
Removes an undo listener.
removeUndoableEditListener(UndoableEditListener) - Method in interface javax.swing.text.Document
Unregisters the given observer from the notification list so it will no longer receive updates.
removeUndoableEditListener(UndoableEditListener) - Method in class javax.swing.undo.UndoableEditSupport
Removes an UndoableEditListener.
removeUnicodeLocaleAttribute(String) - Method in class java.util.Locale.Builder
Removes a unicode locale attribute, if present, otherwise has no effect.
removeUpdate(DocumentEvent) - Method in interface javax.swing.event.DocumentListener
Gives notification that a portion of the document has been removed.
removeUpdate(AbstractDocument.DefaultDocumentEvent) - Method in class javax.swing.text.AbstractDocument
Updates any document structure as a result of text removal.
removeUpdate() - Method in class javax.swing.text.DefaultStyledDocument.ElementBuffer
Updates the element structure in response to a removal from the associated sequence in the document.
removeUpdate(AbstractDocument.DefaultDocumentEvent) - Method in class javax.swing.text.DefaultStyledDocument
Updates document structure as a result of text removal.
removeUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.FieldView
Gives notification that something was removed from the document in a location that this view is responsible for.
removeUpdate(FlowView, DocumentEvent, Rectangle) - Method in class javax.swing.text.FlowView.FlowStrategy
Gives notification that something was removed from the document in a location that the given flow view is responsible for.
removeUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.FlowView
Gives notification that something was removed from the document in a location that this view is responsible for.
removeUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.GlyphView
Gives notification that something was removed from the document in a location that this view is responsible for.
removeUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.html.InlineView
Gives notification that something was removed from the document in a location that this view is responsible for.
removeUpdate(DocumentEvent) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent
Handles document remove (fire appropriate property change event, which is AccessibleContext.ACCESSIBLE_TEXT_PROPERTY).
removeUpdate(AbstractDocument.DefaultDocumentEvent) - Method in class javax.swing.text.PlainDocument
Updates any document structure as a result of text removal.
removeUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.PlainView
Gives notification that something was removed from the document in a location that this view is responsible for.
removeUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.View
Gives notification that something was removed from the document in a location that this view is responsible for.
removeUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.WrappedPlainView
Gives notification that something was removed from the document in a location that this view is responsible for.
removeUpdate(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.ZoneView
Gives notification that something was removed from the document in a location that this view is responsible for.
removeValue(String) - Method in interface javax.net.ssl.SSLSession
Removes the object bound to the given name in the session's application layer data.
removeVetoableChangeListener(VetoableChangeListener) - Method in class java.awt.KeyboardFocusManager
Removes a VetoableChangeListener from the listener list.
removeVetoableChangeListener(String, VetoableChangeListener) - Method in class java.awt.KeyboardFocusManager
Removes a VetoableChangeListener from the listener list for a specific property.
removeVetoableChangeListener(String, VetoableChangeListener) - Method in interface java.beans.beancontext.BeanContextChild
Removes a VetoableChangeListener from this BeanContextChild so that it no longer receives events when the specified property changes.
removeVetoableChangeListener(String, VetoableChangeListener) - Method in class java.beans.beancontext.BeanContextChildSupport
Removes a VetoableChangeListener.
removeVetoableChangeListener(VetoableChangeListener) - Method in class java.beans.VetoableChangeSupport
Remove a VetoableChangeListener from the listener list.
removeVetoableChangeListener(String, VetoableChangeListener) - Method in class java.beans.VetoableChangeSupport
Remove a VetoableChangeListener for a specific property.
removeVetoableChangeListener(VetoableChangeListener) - Method in class javax.swing.JComponent
Removes a VetoableChangeListener from the listener list.
removeWindowFocusListener(WindowFocusListener) - Method in class java.awt.Window
Removes the specified window focus listener so that it no longer receives window events from this window.
removeWindowListener(WindowListener) - Method in class java.awt.Window
Removes the specified window listener so that it no longer receives window events from this window.
removeWindowStateListener(WindowStateListener) - Method in class java.awt.Window
Removes the specified window state listener so that it no longer receives window events from this window.
rename(Name, Name) - Method in interface javax.naming.Context
Binds a new name to the object bound to an old name, and unbinds the old name.
rename(String, String) - Method in interface javax.naming.Context
Binds a new name to the object bound to an old name, and unbinds the old name.
rename(String, String) - Method in class javax.naming.InitialContext
rename(Name, Name) - Method in class javax.naming.InitialContext
renameFile(File, File) - Method in class javax.swing.plaf.basic.BasicDirectoryModel
Renames a file in the underlying file system.
renameNode(Node, String, String) - Method in interface org.w3c.dom.Document
Rename an existing node of type ELEMENT_NODE or ATTRIBUTE_NODE.
renameTo(File) - Method in class java.io.File
Renames the file denoted by this abstract pathname.
render(Runnable) - Method in class javax.swing.text.AbstractDocument
This allows the model to be safely rendered in the presence of currency, if the model supports being updated asynchronously.
render(Runnable) - Method in interface javax.swing.text.Document
Allows the model to be safely rendered in the presence of concurrency, if the model supports being updated asynchronously.
RENDERABLE_IMAGE - Static variable in class javax.print.DocFlavor.SERVICE_FORMATTED
Service formatted print data doc flavor with print data representation class name = "java.awt.image.renderable.RenderableImage" (renderable image object).
RenderableImage - Interface in java.awt.image.renderable
A RenderableImage is a common interface for rendering-independent images (a notion which subsumes resolution independence).
RenderableImageOp - Class in java.awt.image.renderable
This class handles the renderable aspects of an operation with help from its associated instance of a ContextualRenderedImageFactory.
RenderableImageOp(ContextualRenderedImageFactory, ParameterBlock) - Constructor for class java.awt.image.renderable.RenderableImageOp
Constructs a RenderedImageOp given a ContextualRenderedImageFactory object, and a ParameterBlock containing RenderableImage sources and other parameters.
RenderableImageProducer - Class in java.awt.image.renderable
An adapter class that implements ImageProducer to allow the asynchronous production of a RenderableImage.
RenderableImageProducer(RenderableImage, RenderContext) - Constructor for class java.awt.image.renderable.RenderableImageProducer
Constructs a new RenderableImageProducer from a RenderableImage and a RenderContext.
RenderContext - Class in java.awt.image.renderable
A RenderContext encapsulates the information needed to produce a specific rendering from a RenderableImage.
RenderContext(AffineTransform, Shape, RenderingHints) - Constructor for class java.awt.image.renderable.RenderContext
Constructs a RenderContext with a given transform.
RenderContext(AffineTransform) - Constructor for class java.awt.image.renderable.RenderContext
Constructs a RenderContext with a given transform.
RenderContext(AffineTransform, RenderingHints) - Constructor for class java.awt.image.renderable.RenderContext
Constructs a RenderContext with a given transform and rendering hints.
RenderContext(AffineTransform, Shape) - Constructor for class java.awt.image.renderable.RenderContext
Constructs a RenderContext with a given transform and area of interest.
RenderedImage - Interface in java.awt.image
RenderedImage is a common interface for objects which contain or can produce image data in the form of Rasters.
RenderedImageFactory - Interface in java.awt.image.renderable
The RenderedImageFactory interface (often abbreviated RIF) is intended to be implemented by classes that wish to act as factories to produce different renderings, for example by executing a series of BufferedImageOps on a set of sources, depending on a specific set of parameters, properties, and rendering hints.
renderer - Variable in class javax.swing.JComboBox
This protected field is implementation specific.
Renderer - Interface in javax.swing
Defines the requirements for an object responsible for "rendering" (displaying) a value.
renderer - Variable in class javax.swing.tree.DefaultTreeCellEditor
Renderer, used to get border and offsets from.
rendererPane - Variable in class javax.swing.plaf.basic.BasicListUI
rendererPane - Variable in class javax.swing.plaf.basic.BasicTableHeaderUI
rendererPane - Variable in class javax.swing.plaf.basic.BasicTableUI
rendererPane - Variable in class javax.swing.plaf.basic.BasicTreeUI
Used to paint the TreeCellRenderer.
rendererPane - Variable in class javax.swing.plaf.metal.MetalComboBoxButton
RenderingHints - Class in java.awt
The RenderingHints class defines and manages collections of keys and associated values which allow an application to provide input into the choice of algorithms used by other classes which perform rendering and image manipulation services.
RenderingHints(Map<RenderingHints.Key, ?>) - Constructor for class java.awt.RenderingHints
Constructs a new object with keys and values initialized from the specified Map object which may be null.
RenderingHints(RenderingHints.Key, Object) - Constructor for class java.awt.RenderingHints
Constructs a new object with the specified key/value pair.
RenderingHints.Key - Class in java.awt
Defines the base type of all keys used along with the RenderingHints class to control various algorithm choices in the rendering and imaging pipelines.
reorderingAllowed - Variable in class javax.swing.table.JTableHeader
If true, reordering of columns are allowed by the user; the default is true.
reorderVisually(byte[], int, Object[], int, int) - Static method in class java.text.Bidi
Reorder the objects in the array into visual order based on their levels.
repaint() - Method in class java.awt.Component
Repaints this component.
repaint(long) - Method in class java.awt.Component
Repaints the component.
repaint(int, int, int, int) - Method in class java.awt.Component
Repaints the specified rectangle of this component.
repaint(long, int, int, int, int) - Method in class java.awt.Component
Repaints the specified rectangle of this component within tm milliseconds.
repaint() - Method in class javax.swing.DefaultListCellRenderer
Overridden for performance reasons.
repaint(long, int, int, int, int) - Method in class javax.swing.DefaultListCellRenderer
Overridden for performance reasons.
repaint(Rectangle) - Method in class javax.swing.DefaultListCellRenderer
Overridden for performance reasons.
repaint(long, int, int, int, int) - Method in class javax.swing.JApplet
Repaints the specified rectangle of this component within time milliseconds.
repaint(long, int, int, int, int) - Method in class javax.swing.JComponent
Adds the specified region to the dirty region list if the component is showing.
repaint(Rectangle) - Method in class javax.swing.JComponent
Adds the specified region to the dirty region list if the component is showing.
repaint(long, int, int, int, int) - Method in class javax.swing.JDialog
Repaints the specified rectangle of this component within time milliseconds.
repaint(long, int, int, int, int) - Method in class javax.swing.JFrame
Repaints the specified rectangle of this component within time milliseconds.
repaint(long, int, int, int, int) - Method in class javax.swing.JViewport
Always repaint in the parents coordinate system to make sure only one paint is performed by the RepaintManager.
repaint(long, int, int, int, int) - Method in class javax.swing.JWindow
Repaints the specified rectangle of this component within time milliseconds.
repaint(long, int, int, int, int) - Method in class javax.swing.table.DefaultTableCellRenderer
Overridden for performance reasons.
repaint(Rectangle) - Method in class javax.swing.table.DefaultTableCellRenderer
Overridden for performance reasons.
repaint() - Method in class javax.swing.table.DefaultTableCellRenderer
Overridden for performance reasons.
repaint() - Method in class javax.swing.text.DefaultCaret
Cause the caret to be painted.
repaint(long, int, int, int, int) - Method in class javax.swing.tree.DefaultTreeCellRenderer
Overridden for performance reasons.
repaint(Rectangle) - Method in class javax.swing.tree.DefaultTreeCellRenderer
Overridden for performance reasons.
repaint() - Method in class javax.swing.tree.DefaultTreeCellRenderer
Overridden for performance reasons.
repaintCellFocus() - Method in class javax.swing.plaf.basic.BasicListUI.FocusHandler
RepaintManager - Class in javax.swing
This class manages repaint requests, allowing the number of repaints to be minimized, for example by collapsing multiple requests into a single repaint for members of a component tree.
RepaintManager() - Constructor for class javax.swing.RepaintManager
Create a new RepaintManager instance.
Repeatable - Annotation Type in java.lang.annotation
The annotation type java.lang.annotation.Repeatable is used to indicate that the annotation type whose declaration it (meta-)annotates is repeatable.
repeatKeyAction - Variable in class javax.swing.plaf.basic.BasicTreeUI.KeyHandler
Key code that is being generated for.
replace(char, char) - Method in class java.lang.String
Returns a string resulting from replacing all occurrences of oldChar in this string with newChar.
replace(CharSequence, CharSequence) - Method in class java.lang.String
Replaces each substring of this string that matches the literal target sequence with the specified literal replacement sequence.
replace(int, int, String) - Method in class java.lang.StringBuffer
replace(int, int, String) - Method in class java.lang.StringBuilder
REPLACE - Static variable in class java.nio.charset.CodingErrorAction
Action indicating that a coding error is to be handled by dropping the erroneous input, appending the coder's replacement value to the output buffer, and resuming the coding operation.
replace(Object, Object, Object) - Method in class java.security.Provider
Replaces the entry for the specified key only if currently mapped to the specified value.
replace(Object, Object) - Method in class java.security.Provider
Replaces the entry for the specified key only if it is currently mapped to some value.
replace(K, V, V) - Method in class java.util.concurrent.ConcurrentHashMap
Replaces the entry for a key only if currently mapped to a given value.
replace(K, V) - Method in class java.util.concurrent.ConcurrentHashMap
Replaces the entry for a key only if currently mapped to some value.
replace(K, V, V) - Method in interface java.util.concurrent.ConcurrentMap
Replaces the entry for a key only if currently mapped to a given value.
replace(K, V) - Method in interface java.util.concurrent.ConcurrentMap
Replaces the entry for a key only if currently mapped to some value.
replace(K, V, V) - Method in class java.util.concurrent.ConcurrentSkipListMap
Replaces the entry for a key only if currently mapped to a given value.
replace(K, V) - Method in class java.util.concurrent.ConcurrentSkipListMap
Replaces the entry for a key only if currently mapped to some value.
replace(K, V, V) - Method in class java.util.HashMap
replace(K, V) - Method in class java.util.HashMap
replace(K, V, V) - Method in class java.util.Hashtable
replace(K, V) - Method in class java.util.Hashtable
replace(K, V, V) - Method in interface java.util.Map
Replaces the entry for the specified key only if currently mapped to the specified value.
replace(K, V) - Method in interface java.util.Map
Replaces the entry for the specified key only if it is currently mapped to some value.
replace(K, V, V) - Method in class java.util.TreeMap
replace(K, V) - Method in class java.util.TreeMap
replace(Component, Component) - Method in class javax.swing.GroupLayout
Replaces an existing component with a new one.
replace(int, int, Element[]) - Method in class javax.swing.text.AbstractDocument.BranchElement
Replaces content with a new set of elements.
replace(int, int, String, AttributeSet) - Method in class javax.swing.text.AbstractDocument
Deletes the region of text from offset to offset + length, and replaces it with text.
replace(int, int, View[]) - Method in class javax.swing.text.AsyncBoxView
Calls the superclass to update the child views, and updates the status records for the children.
replace(int, int, View[]) - Method in class javax.swing.text.BoxView
Invalidates the layout and resizes the cache of requests/allocations.
replace(int, int, View[]) - Method in class javax.swing.text.CompositeView
Replaces child views.
replace(int, int, String, AttributeSet) - Method in class javax.swing.text.DocumentFilter.FilterBypass
Deletes the region of text from offset to offset + length, and replaces it with text.
replace(DocumentFilter.FilterBypass, int, int, String, AttributeSet) - Method in class javax.swing.text.DocumentFilter
Invoked prior to replacing a region of text in the specified Document.
replace(int, int, View[]) - Method in class javax.swing.text.TableView
Change the child views.
replace(int, int, View[]) - Method in class javax.swing.text.TableView.TableRow
Change the child views.
replace(int, int, View[]) - Method in class javax.swing.text.View
Replaces child views.
REPLACE_ATTRIBUTE - Static variable in interface javax.naming.directory.DirContext
This constant specifies to replace an attribute with specified values.
replaceAll(String, String) - Method in class java.lang.String
Replaces each substring of this string that matches the given regular expression with the given replacement.
replaceAll(BiFunction<? super Object, ? super Object, ? extends Object>) - Method in class java.security.Provider
Replaces each entry's value with the result of invoking the given function on that entry, in the order entries are returned by an entry set iterator, until all entries have been processed or the function throws an exception.
replaceAll(UnaryOperator<E>) - Method in class java.util.ArrayList
replaceAll(List<T>, T, T) - Static method in class java.util.Collections
Replaces all occurrences of one specified value in a list with another.
replaceAll(BiFunction<? super K, ? super V, ? extends V>) - Method in class java.util.concurrent.ConcurrentHashMap
replaceAll(BiFunction<? super K, ? super V, ? extends V>) - Method in interface java.util.concurrent.ConcurrentMap
Replaces each entry's value with the result of invoking the given function on that entry until all entries have been processed or the function throws an exception.
replaceAll(BiFunction<? super K, ? super V, ? extends V>) - Method in class java.util.concurrent.ConcurrentSkipListMap
replaceAll(UnaryOperator<E>) - Method in class java.util.concurrent.CopyOnWriteArrayList
replaceAll(BiFunction<? super K, ? super V, ? extends V>) - Method in class java.util.HashMap
replaceAll(BiFunction<? super K, ? super V, ? extends V>) - Method in class java.util.Hashtable
replaceAll(BiFunction<? super K, ? super V, ? extends V>) - Method in class java.util.IdentityHashMap
replaceAll(BiFunction<? super K, ? super V, ? extends V>) - Method in class java.util.LinkedHashMap
replaceAll(UnaryOperator<E>) - Method in interface java.util.List
Replaces each element of this list with the result of applying the operator to that element.
replaceAll(BiFunction<? super K, ? super V, ? extends V>) - Method in interface java.util.Map
Replaces each entry's value with the result of invoking the given function on that entry until all entries have been processed or the function throws an exception.
replaceAll(String) - Method in class java.util.regex.Matcher
Replaces every subsequence of the input sequence that matches the pattern with the given replacement string.
replaceAll(BiFunction<? super K, ? super V, ? extends V>) - Method in class java.util.TreeMap
replaceAll(UnaryOperator<E>) - Method in class java.util.Vector
replaceAll(BiFunction<? super K, ? super V, ? extends V>) - Method in class java.util.WeakHashMap
replaceChild(Node, Node) - Method in class javax.imageio.metadata.IIOMetadataNode
Replaces the child node oldChild with newChild in the list of children, and returns the oldChild node.
replaceChild(Node, Node) - Method in interface org.w3c.dom.Node
Replaces the child node oldChild with newChild in the list of children, and returns the oldChild node.
replaceData(int, int, String) - Method in interface org.w3c.dom.CharacterData
Replace the characters starting at the specified 16-bit unit offset with the specified string.
replaceEdit(UndoableEdit) - Method in class javax.swing.undo.AbstractUndoableEdit
This default implementation returns false.
replaceEdit(UndoableEdit) - Method in interface javax.swing.undo.UndoableEdit
Returns true if this UndoableEdit should replace anEdit.
replaceEditor(JComponent, JComponent) - Method in class javax.swing.plaf.basic.BasicSpinnerUI
Called by the PropertyChangeListener when the JSpinner editor property changes.
replaceEditor(JComponent, JComponent) - Method in class javax.swing.plaf.synth.SynthSpinnerUI
Called by the PropertyChangeListener when the JSpinner editor property changes.
replaceFirst(String, String) - Method in class java.lang.String
Replaces the first substring of this string that matches the given regular expression with the given replacement.
replaceFirst(String) - Method in class java.util.regex.Matcher
Replaces the first subsequence of the input sequence that matches the pattern with the given replacement string.
replaceImageMetadata(int, IIOMetadata) - Method in class javax.imageio.ImageWriter
Replaces the image metadata associated with an existing image.
replaceItem(String, int) - Method in class java.awt.List
Replaces the item at the specified index in the scrolling list with the new string.
replacement() - Method in class java.nio.charset.CharsetDecoder
Returns this decoder's replacement value.
replacement() - Method in class java.nio.charset.CharsetEncoder
Returns this encoder's replacement value.
replaceObject(Object) - Method in class java.io.ObjectOutputStream
This method will allow trusted subclasses of ObjectOutputStream to substitute one object for another during serialization.
replacePane(JComponent, JComponent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
Installs necessary mouse handlers on newPane and adds it to the frame.
replacePixels(RenderedImage, ImageWriteParam) - Method in class javax.imageio.ImageWriter
Replaces a portion of an image already present in the output with a portion of the given image.
replacePixels(Raster, ImageWriteParam) - Method in class javax.imageio.ImageWriter
Replaces a portion of an image already present in the output with a portion of the given Raster.
replaceRange(String, int, int) - Method in class java.awt.TextArea
Replaces text between the indicated start and end positions with the specified replacement text.
replaceRange(String, int, int) - Method in class javax.swing.JTextArea
Replaces text from the indicated start to end position with the new text specified.
replaceSelection(String) - Method in class javax.swing.JEditorPane
Replaces the currently selected content with new content represented by the given string.
replaceSelection(String) - Method in class javax.swing.JTextPane
Replaces the currently selected content with new content represented by the given string.
replaceSelection(String) - Method in class javax.swing.text.JTextComponent
Replaces the currently selected content with new content represented by the given string.
replaceStreamMetadata(IIOMetadata) - Method in class javax.imageio.ImageWriter
Replaces the stream metadata in the output with new information.
replaceText(String, int, int) - Method in class java.awt.TextArea
Deprecated.
As of JDK version 1.1, replaced by replaceRange(String, int, int).
replaceText(int, int, String) - Method in interface javax.accessibility.AccessibleEditableText
Replaces the text between two indices with the specified string.
replaceText(int, int, String) - Method in class javax.swing.JSpinner.AccessibleJSpinner
Replaces the text between two indices with the specified string.
replaceText(int, int, String) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent
Replaces the text between two indices with the specified string.
replaceUIActionMap(JComponent, ActionMap) - Static method in class javax.swing.SwingUtilities
Convenience method to change the UI ActionMap for component to uiActionMap.
replaceUIInputMap(JComponent, int, InputMap) - Static method in class javax.swing.SwingUtilities
Convenience method to change the UI InputMap for component to uiInputMap.
replaceWholeText(String) - Method in interface org.w3c.dom.Text
Replaces the text of the current node and all logically-adjacent text nodes with the specified text.
replaceWith(String) - Method in class java.nio.charset.CharsetDecoder
Changes this decoder's replacement value.
replaceWith(byte[]) - Method in class java.nio.charset.CharsetEncoder
Changes this encoder's replacement value.
ReplicateScaleFilter - Class in java.awt.image
An ImageFilter class for scaling images using the simplest algorithm.
ReplicateScaleFilter(int, int) - Constructor for class java.awt.image.ReplicateScaleFilter
Constructs a ReplicateScaleFilter that scales the pixels from its source Image as specified by the width and height parameters.
reply_status() - Method in interface org.omg.PortableInterceptor.RequestInfoOperations
Describes the state of the result of the operation invocation.
REPORT - Static variable in class java.nio.charset.CodingErrorAction
Action indicating that a coding error is to be reported, either by returning a CoderResult object or by throwing a CharacterCodingException, whichever is appropriate for the method implementing the coding process.
REPORT - Static variable in class javax.print.attribute.standard.Severity
Indicates that the PrinterStateReason is a "report" (least severe).
report(Diagnostic<? extends S>) - Method in class javax.tools.DiagnosticCollector
report(Diagnostic<? extends S>) - Method in interface javax.tools.DiagnosticListener
Invoked when a problem is found.
report(String, String, Object, Location) - Method in interface javax.xml.stream.XMLReporter
Report the desired message in an application specific format.
REPORTER - Static variable in class javax.xml.stream.XMLInputFactory
The property used to set/get the implementation of the XMLReporter interface
reportError(String, Exception, int) - Method in class java.util.logging.Handler
Protected convenience method to report an error to this Handler's ErrorManager.
RepositoryIdHelper - Class in org.omg.CORBA
The Helper for RepositoryId.
RepositoryIdHelper() - Constructor for class org.omg.CORBA.RepositoryIdHelper
request(Object, String) - Method in class org.omg.CORBA.portable.Delegate
Creates a Request instance for use in the Dynamic Invocation Interface.
request(Object, String, boolean) - Method in class org.omg.CORBA.portable.Delegate
request is called by a stub to obtain an OutputStream for marshaling arguments.
Request - Class in org.omg.CORBA
An object containing the information necessary for invoking a method.
Request() - Constructor for class org.omg.CORBA.Request
REQUEST_CIPHER_SUITE - Static variable in class javax.xml.ws.spi.http.HttpExchange
Standard property: cipher suite value when the request is received over HTTPS
request_id() - Method in interface org.omg.PortableInterceptor.RequestInfoOperations
Returns an id that uniquely identifies an active request/reply sequence.
REQUEST_KEY_SIZE - Static variable in class javax.xml.ws.spi.http.HttpExchange
Standard property: bit size of the algorithm when the request is received over HTTPS
REQUEST_PROCESSING_POLICY_ID - Interface in org.omg.PortableServer
org/omg/PortableServer/REQUEST_PROCESSING_POLICY_ID.java .
REQUEST_X509CERTIFICATE - Static variable in class javax.xml.ws.spi.http.HttpExchange
Standard property: A SSL certificate, if any, associated with the request
requestAnonymity(boolean) - Method in interface org.ietf.jgss.GSSContext
Requests that the initiator's identity not be disclosed to the acceptor.
requestConf(boolean) - Method in interface org.ietf.jgss.GSSContext
Requests that data confidentiality be enabled for the wrap method.
requestCredDeleg(boolean) - Method in interface org.ietf.jgss.GSSContext
Requests that the initiator's credentials be delegated to the acceptor during context establishment.
requestDefaultFocus() - Method in class javax.swing.JComponent
Deprecated.
As of 1.4, replaced by FocusTraversalPolicy.getDefaultComponent(Container).requestFocus()
requestFocus() - Method in class java.awt.Component.AccessibleAWTComponent
Requests focus for this object.
requestFocus() - Method in class java.awt.Component
Requests that this Component get the input focus, and that this Component's top-level ancestor become the focused Window.
requestFocus(boolean) - Method in class java.awt.Component
Requests that this Component get the input focus, and that this Component's top-level ancestor become the focused Window.
requestFocus() - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild
Requests focus for this object.
requestFocus() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent
Requests focus for this object.
requestFocus() - Method in interface javax.accessibility.AccessibleComponent
Requests focus for this object.
requestFocus() - Method in class javax.swing.JComponent
Requests that this Component gets the input focus.
requestFocus(boolean) - Method in class javax.swing.JComponent
Requests that this Component gets the input focus.
requestFocus() - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild
requestFocus() - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell
requestFocus() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode
requestFocus() - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane.SystemMenuBar
requestFocus() - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
requestFocusInWindow() - Method in class java.awt.Component
Requests that this Component get the input focus, if this Component's top-level ancestor is already the focused Window.
requestFocusInWindow(boolean) - Method in class java.awt.Component
Requests that this Component get the input focus, if this Component's top-level ancestor is already the focused Window.
requestFocusInWindow() - Method in class javax.swing.JComponent
Requests that this Component gets the input focus.
requestFocusInWindow(boolean) - Method in class javax.swing.JComponent
Requests that this Component gets the input focus.
RequestInfo - Interface in org.omg.PortableInterceptor
Request Information, accessible to Interceptors.
RequestInfoOperations - Interface in org.omg.PortableInterceptor
Request Information, accessible to Interceptors.
RequestingUserName - Class in javax.print.attribute.standard
Class RequestingUserName is a printing attribute class, a text attribute, that specifies the name of the end user that submitted the print job.
RequestingUserName(String, Locale) - Constructor for class javax.print.attribute.standard.RequestingUserName
Constructs a new requesting user name attribute with the given user name and locale.
requestInteg(boolean) - Method in interface org.ietf.jgss.GSSContext
Requests that data integrity be enabled for the wrap and getMICmethods.
requestLifetime(int) - Method in interface org.ietf.jgss.GSSContext
Requests a lifetime in seconds for the context.
requestMutualAuth(boolean) - Method in interface org.ietf.jgss.GSSContext
Requests that mutual authentication be done during context establishment.
requestPasswordAuthentication(InetAddress, int, String, String, String) - Static method in class java.net.Authenticator
Ask the authenticator that has been registered with the system for a password.
requestPasswordAuthentication(String, InetAddress, int, String, String, String) - Static method in class java.net.Authenticator
Ask the authenticator that has been registered with the system for a password.
requestPasswordAuthentication(String, InetAddress, int, String, String, String, URL, Authenticator.RequestorType) - Static method in class java.net.Authenticator
Ask the authenticator that has been registered with the system for a password.
RequestProcessingPolicy - Interface in org.omg.PortableServer
This policy specifies how requests are processed by the created POA.
RequestProcessingPolicyOperations - Interface in org.omg.PortableServer
This policy specifies how requests are processed by the created POA.
RequestProcessingPolicyValue - Class in org.omg.PortableServer
The RequestProcessingPolicyValue can have the following values.
RequestProcessingPolicyValue(int) - Constructor for class org.omg.PortableServer.RequestProcessingPolicyValue
requestReplayDet(boolean) - Method in interface org.ietf.jgss.GSSContext
Requests that replay detection be enabled for the per-message security services after context establishment.
requestSequenceDet(boolean) - Method in interface org.ietf.jgss.GSSContext
Requests that sequence checking be enabled for the per-message security services after context establishment.
requestTopDownLeftRightResend(ImageConsumer) - Method in class java.awt.image.FilteredImageSource
Requests that a given ImageConsumer have the image data delivered one more time in top-down, left-right order.
requestTopDownLeftRightResend(ImageConsumer) - Method in interface java.awt.image.ImageProducer
Requests, on behalf of the ImageConsumer, that the ImageProducer attempt to resend the image data one more time in TOPDOWNLEFTRIGHT order so that higher quality conversion algorithms which depend on receiving pixels in order can be used to produce a better output version of the image.
requestTopDownLeftRightResend(ImageConsumer) - Method in class java.awt.image.MemoryImageSource
Requests that a given ImageConsumer have the image data delivered one more time in top-down, left-right order.
requestTopDownLeftRightResend(ImageConsumer) - Method in class java.awt.image.renderable.RenderableImageProducer
Requests that a given ImageConsumer have the image data delivered one more time in top-down, left-right order.
RequestWrapper - Annotation Type in javax.xml.ws
Used to annotate methods in the Service Endpoint Interface with the request wrapper bean to be used at runtime.
require(int, String, String) - Method in class javax.xml.stream.util.StreamReaderDelegate
require(int, String, String) - Method in interface javax.xml.stream.XMLStreamReader
Test if the current event is of the given type and if the namespace and name match the current namespace and name of the current event.
REQUIRED - Static variable in class java.awt.GraphicsConfigTemplate
Value used for "Enum" (Integer) type.
required - Variable in class java.sql.DriverPropertyInfo
The required field is true if a value must be supplied for this property during Driver.connect and false otherwise.
REQUIRED - Static variable in class javax.security.auth.login.AppConfigurationEntry.LoginModuleControlFlag
Required LoginModule.
REQUIRED - Static variable in interface javax.swing.text.html.parser.DTDConstants
required - Variable in class javax.xml.ws.soap.AddressingFeature
If addressing is enabled, this property determines whether the endpoint requires WS-Addressing.
RequiredModelMBean - Class in javax.management.modelmbean
This class is the implementation of a ModelMBean.
RequiredModelMBean() - Constructor for class javax.management.modelmbean.RequiredModelMBean
Constructs an RequiredModelMBean with an empty ModelMBeanInfo.
RequiredModelMBean(ModelMBeanInfo) - Constructor for class javax.management.modelmbean.RequiredModelMBean
Constructs a RequiredModelMBean object using ModelMBeanInfo passed in.
requireEnd() - Method in class java.util.regex.Matcher
Returns true if more input could change a positive match into a negative one.
requireNonNull(T) - Static method in class java.util.Objects
Checks that the specified object reference is not null.
requireNonNull(T, String) - Static method in class java.util.Objects
Checks that the specified object reference is not null and throws a customized NullPointerException if it is.
requireNonNull(T, Supplier<String>) - Static method in class java.util.Objects
Checks that the specified object reference is not null and throws a customized NullPointerException if it is.
REQUIRES_ATTENTION - Static variable in class javax.print.event.PrintJobEvent
The print service indicates that a - possibly transient - problem may require external intervention before the print service can continue.
requiresBidi(char[], int, int) - Static method in class java.text.Bidi
Return true if the specified text requires bidi analysis.
REQUISITE - Static variable in class javax.security.auth.login.AppConfigurationEntry.LoginModuleControlFlag
Requisite LoginModule.
RescaleOp - Class in java.awt.image
This class performs a pixel-by-pixel rescaling of the data in the source image by multiplying the sample values for each pixel by a scale factor and then adding an offset.
RescaleOp(float[], float[], RenderingHints) - Constructor for class java.awt.image.RescaleOp
Constructs a new RescaleOp with the desired scale factors and offsets.
RescaleOp(float, float, RenderingHints) - Constructor for class java.awt.image.RescaleOp
Constructs a new RescaleOp with the desired scale factor and offset.
rescanCurrentDirectory() - Method in class javax.swing.JFileChooser
Tells the UI to rescan its files list from the current directory.
rescanCurrentDirectory(JFileChooser) - Method in class javax.swing.plaf.basic.BasicFileChooserUI
rescanCurrentDirectory(JFileChooser) - Method in class javax.swing.plaf.FileChooserUI
rescanCurrentDirectory(JFileChooser) - Method in class javax.swing.plaf.metal.MetalFileChooserUI
rescanCurrentDirectory(JFileChooser) - Method in class javax.swing.plaf.multi.MultiFileChooserUI
Invokes the rescanCurrentDirectory method on each UI handled by this object.
resendTopDownLeftRight(ImageProducer) - Method in class java.awt.image.ImageFilter
Responds to a request for a TopDownLeftRight (TDLR) ordered resend of the pixel data from an ImageConsumer.
RESERVED_ID_MAX - Static variable in class java.awt.AWTEvent
The maximum value for reserved AWT event IDs.
RESERVED_UIROLE - Static variable in class javax.print.ServiceUIFactory
Not a valid role but role id's greater than this may be used for private roles supported by a service.
reset() - Method in class java.awt.geom.Area
Removes all of the geometry from this Area and restores it to an empty area.
reset() - Method in class java.awt.geom.Path2D
Resets the path to empty.
reset() - Method in class java.awt.Polygon
Resets this Polygon object to an empty polygon.
reset() - Method in class java.io.BufferedInputStream
See the general contract of the reset method of InputStream.
reset() - Method in class java.io.BufferedReader
Resets the stream to the most recent mark.
reset() - Method in class java.io.ByteArrayInputStream
Resets the buffer to the marked position.
reset() - Method in class java.io.ByteArrayOutputStream
Resets the count field of this byte array output stream to zero, so that all currently accumulated output in the output stream is discarded.
reset() - Method in class java.io.CharArrayReader
Resets the stream to the most recent mark, or to the beginning if it has never been marked.
reset() - Method in class java.io.CharArrayWriter
Resets the buffer so that you can use it again without throwing away the already allocated buffer.
reset() - Method in class java.io.FilterInputStream
Repositions this stream to the position at the time the mark method was last called on this input stream.
reset() - Method in class java.io.FilterReader
Resets the stream.
reset() - Method in class java.io.InputStream
Repositions this stream to the position at the time the mark method was last called on this input stream.
reset() - Method in class java.io.LineNumberInputStream
Deprecated.
Repositions this stream to the position at the time the mark method was last called on this input stream.
reset() - Method in class java.io.LineNumberReader
Reset the stream to the most recent mark.
reset() - Method in class java.io.ObjectOutputStream
Reset will disregard the state of any objects already written to the stream.
reset() - Method in class java.io.PushbackInputStream
Repositions this stream to the position at the time the mark method was last called on this input stream.
reset() - Method in class java.io.PushbackReader
Resets the stream.
reset() - Method in class java.io.Reader
Resets the stream.
reset() - Method in class java.io.StringBufferInputStream
Deprecated.
Resets the input stream to begin reading from the first character of this input stream's underlying buffer.
reset() - Method in class java.io.StringReader
Resets the stream to the most recent mark, or to the beginning of the string if it has never been marked.
reset() - Method in class java.nio.Buffer
Resets this buffer's position to the previously-marked position.
reset() - Method in class java.nio.charset.CharsetDecoder
Resets this decoder, clearing any internal state.
reset() - Method in class java.nio.charset.CharsetEncoder
Resets this encoder, clearing any internal state.
reset() - Method in interface java.nio.file.WatchKey
Resets this watch key.
reset() - Method in class java.security.MessageDigest
Resets the digest for further use.
reset() - Method in class java.text.CollationElementIterator
Resets the cursor to the beginning of the string.
reset() - Method in class java.util.concurrent.atomic.DoubleAccumulator
Resets variables maintaining updates to the identity value.
reset() - Method in class java.util.concurrent.atomic.DoubleAdder
Resets variables maintaining the sum to zero.
reset() - Method in class java.util.concurrent.atomic.LongAccumulator
Resets variables maintaining updates to the identity value.
reset() - Method in class java.util.concurrent.atomic.LongAdder
Resets variables maintaining the sum to zero.
reset() - Method in class java.util.concurrent.CyclicBarrier
Resets the barrier to its initial state.
reset() - Method in class java.util.logging.LogManager
Reset the logging configuration.
reset() - Method in class java.util.regex.Matcher
Resets this matcher.
reset(CharSequence) - Method in class java.util.regex.Matcher
Resets this matcher with a new input sequence.
reset() - Method in class java.util.Scanner
Resets this scanner.
reset() - Method in class java.util.zip.Adler32
Resets the checksum to initial value.
reset() - Method in interface java.util.zip.Checksum
Resets the checksum to its initial value.
reset() - Method in class java.util.zip.CRC32
Resets CRC-32 to initial value.
reset() - Method in class java.util.zip.Deflater
Resets deflater so that a new set of input data can be processed.
reset() - Method in class java.util.zip.DeflaterInputStream
This operation is not supported.
reset() - Method in class java.util.zip.Inflater
Resets inflater so that a new set of input data can be processed.
reset() - Method in class java.util.zip.InflaterInputStream
Repositions this stream to the position at the time the mark method was last called on this input stream.
reset() - Method in class javax.crypto.Mac
Resets this Mac object.
reset() - Method in class javax.imageio.ImageReader
Restores the ImageReader to its initial state.
reset() - Method in class javax.imageio.ImageWriter
Restores the ImageWriter to its initial state.
reset() - Method in class javax.imageio.metadata.IIOMetadata
Resets all the data stored in this object to default values, usually to the state this object was in immediately after construction, though the precise semantics are plug-in specific.
reset() - Method in interface javax.imageio.stream.ImageInputStream
Returns the stream pointer to its previous position, including the bit offset, at the time of the most recent unmatched call to mark.
reset() - Method in class javax.imageio.stream.ImageInputStreamImpl
Resets the current stream byte and bit positions from the stack of marked positions.
reset() - Method in class javax.sound.sampled.AudioInputStream
Repositions this audio input stream to the position it had at the time its mark method was last invoked.
reset() - Method in class javax.swing.ProgressMonitorInputStream
Overrides FilterInputStream.reset to reset the progress monitor as well as the stream.
RESET - Static variable in class javax.swing.text.html.FormView
Deprecated.
As of 1.3, value comes from UIManager UIManager property FormView.resetButtonText
reset() - Method in class javax.xml.bind.util.ValidationEventCollector
Clear all collected errors and warnings.
reset() - Method in class javax.xml.datatype.XMLGregorianCalendar
Reset this XMLGregorianCalendar to its original values.
reset() - Method in class javax.xml.parsers.DocumentBuilder
Reset this DocumentBuilder to its original configuration.
reset() - Method in class javax.xml.parsers.SAXParser
Reset this SAXParser to its original configuration.
reset() - Method in class javax.xml.transform.Transformer
Reset this Transformer to its original configuration.
reset() - Method in class javax.xml.validation.Validator
Reset this Validator to its original configuration.
reset() - Method in interface javax.xml.xpath.XPath
Reset this XPath to its original configuration.
reset() - Method in class org.xml.sax.helpers.NamespaceSupport
Reset this Namespace support object for reuse.
RESET_FLAGS_ALREADY_NOTIFIED - Static variable in class javax.management.monitor.Monitor
This flag is used to reset the alreadyNotifieds monitor attribute.
resetAllControllers() - Method in interface javax.sound.midi.MidiChannel
Resets all the implemented controllers to their default values.
resetChoosableFileFilters() - Method in class javax.swing.JFileChooser
Resets the choosable file filter list to its starting state.
resetInputValue() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI
Sets the input value in the option pane the receiver is providing the look and feel for based on the value in the inputComponent.
resetKeyboardActions() - Method in class javax.swing.JComponent
Unregisters all the bindings in the first tier InputMaps and ActionMap.
resetLayoutManager() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Resets the layout manager based on orientation and messages it with invalidateLayout to pull in appropriate Components.
resetMarksAtZero() - Method in class javax.swing.text.GapContent
Resets all the marks that have an offset of 0 to have an index of zero as well.
resetPeakThreadCount() - Method in interface java.lang.management.ThreadMXBean
Resets the peak thread count to the current number of live threads.
resetPeakUsage() - Method in interface java.lang.management.MemoryPoolMXBean
Resets the peak memory usage statistic of this memory pool to the current memory usage.
resetRecognizer() - Method in class java.awt.dnd.DragGestureRecognizer
Reset the Recognizer, if its currently recognizing a gesture, ignore it.
resetRowSelection() - Method in class javax.swing.tree.DefaultTreeSelectionModel
Updates this object's mapping from TreePath to rows.
resetRowSelection() - Method in interface javax.swing.tree.TreeSelectionModel
Updates this object's mapping from TreePaths to rows.
resetSizeAt(int) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager
Resets the size of the Component at the passed in location.
resetSyntax() - Method in class java.io.StreamTokenizer
Resets this tokenizer's syntax table so that all characters are "ordinary." See the ordinaryChar method for more information on a character being ordinary.
resetToPreferredSizes() - Method in class javax.swing.JSplitPane
Lays out the JSplitPane layout based on the preferred size of the children components.
resetToPreferredSizes() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager
Marks the receiver so that the next time this instance is laid out it'll ask for the preferred sizes.
resetToPreferredSizes(JSplitPane) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Messaged to reset the preferred sizes.
resetToPreferredSizes(JSplitPane) - Method in class javax.swing.plaf.multi.MultiSplitPaneUI
Invokes the resetToPreferredSizes method on each UI handled by this object.
resetToPreferredSizes(JSplitPane) - Method in class javax.swing.plaf.SplitPaneUI
Messaged to relayout the JSplitPane based on the preferred size of the children components.
resetViewPort() - Method in class javax.swing.JScrollPane.AccessibleJScrollPane
reshape(int, int, int, int) - Method in class java.awt.Component
Deprecated.
As of JDK version 1.1, replaced by setBounds(int, int, int, int).
reshape(int, int, int, int) - Method in class java.awt.Rectangle
Deprecated.
As of JDK version 1.1, replaced by setBounds(int, int, int, int).
reshape(int, int, int, int) - Method in class java.awt.Window
Deprecated.
As of JDK version 1.1, replaced by setBounds(int, int, int, int).
reshape(int, int, int, int) - Method in class javax.swing.JComponent
Deprecated.
As of JDK 5, replaced by Component.setBounds(int, int, int, int).

Moves and resizes this component.

reshape(int, int, int, int) - Method in class javax.swing.JInternalFrame
Moves and resizes this component.
reshape(int, int, int, int) - Method in class javax.swing.JViewport
Sets the bounds of this viewport.
RESIZABLE - Static variable in class javax.accessibility.AccessibleState
Indicates the size of this object is not fixed.
resizable - Variable in class javax.swing.JInternalFrame
The frame's size can be changed.
resize(int, int) - Method in class java.applet.Applet
Requests that this applet be resized.
resize(Dimension) - Method in class java.applet.Applet
Requests that this applet be resized.
resize(int, int) - Method in class java.awt.Component
Deprecated.
As of JDK version 1.1, replaced by setSize(int, int).
resize(Dimension) - Method in class java.awt.Component
Deprecated.
As of JDK version 1.1, replaced by setSize(Dimension).
resize(int, int) - Method in class java.awt.Rectangle
Deprecated.
As of JDK version 1.1, replaced by setSize(int, int).
RESIZE_NONE - Variable in class javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener
RESIZE_WEIGHT_PROPERTY - Static variable in class javax.swing.JSplitPane
Bound property for weight.
resizeAndRepaint() - Method in class javax.swing.JTable
Equivalent to revalidate followed by repaint.
resizeAndRepaint() - Method in class javax.swing.table.JTableHeader
Sizes the header and marks it as needing display.
resizedPostingDisableCount - Variable in class javax.swing.table.TableColumn
Deprecated.
as of Java 2 platform v1.3
resizeFrame(JComponent, int, int, int, int) - Method in class javax.swing.DefaultDesktopManager
Calls setBoundsForFrame with the new values.
resizeFrame(JComponent, int, int, int, int) - Method in interface javax.swing.DesktopManager
The user has resized the component.
resizingAllowed - Variable in class javax.swing.table.JTableHeader
If true, resizing of columns are allowed by the user; the default is true.
resizingColumn - Variable in class javax.swing.table.JTableHeader
The index of the column being resized.
resolution - Variable in class javax.sound.midi.MidiFileFormat
The timing resolution of the MIDI file.
resolution - Variable in class javax.sound.midi.Sequence
The timing resolution of the sequence.
ResolutionSyntax - Class in javax.print.attribute
Class ResolutionSyntax is an abstract base class providing the common implementation of all attributes denoting a printer resolution.
ResolutionSyntax(int, int, int) - Constructor for class javax.print.attribute.ResolutionSyntax
Construct a new resolution attribute from the given items.
resolve(URI) - Method in class java.net.URI
Resolves the given URI against this URI.
resolve(String) - Method in class java.net.URI
Constructs a new URI by parsing the given string and then resolving it against this URI.
resolve(Path) - Method in interface java.nio.file.Path
Resolve the given path against this path.
resolve(String) - Method in interface java.nio.file.Path
Converts a given path string to a Path and resolves it against this Path in exactly the manner specified by the resolve method.
resolve(Map<TemporalField, Long>, TemporalAccessor, ResolverStyle) - Method in interface java.time.temporal.TemporalField
Resolves this field to provide a simpler alternative or a date.
resolve(String, String) - Method in interface javax.xml.transform.URIResolver
Called by the processor when it encounters an xsl:include, xsl:import, or document() function.
resolve(NameComponent[]) - Method in class org.omg.CosNaming._NamingContextExtStub
The resolve operation is the process of retrieving an object bound to a name in a given context.
resolve(NameComponent[]) - Method in class org.omg.CosNaming._NamingContextStub
The resolve operation is the process of retrieving an object bound to a name in a given context.
resolve(NameComponent[]) - Method in interface org.omg.CosNaming.NamingContextOperations
The resolve operation is the process of retrieving an object bound to a name in a given context.
resolve_initial_references(String) - Method in class org.omg.CORBA.ORB
Resolves a specific object reference from the set of available initial service names.
resolve_initial_references(String) - Method in interface org.omg.PortableInterceptor.ORBInitInfoOperations
Identical to ORB.resolve_initial_references.
resolve_str(String) - Method in class org.omg.CosNaming._NamingContextExtStub
This operation resolves the Stringified name into the object reference.
resolve_str(String) - Method in interface org.omg.CosNaming.NamingContextExtOperations
This operation resolves the Stringified name into the object reference.
ResolveAttribute - Static variable in interface javax.swing.text.AttributeSet
Attribute name used to identify the resolving parent set of attributes, if one is defined.
ResolveAttribute - Static variable in class javax.swing.text.StyleConstants
Attribute name used to identify the resolving parent set of attributes, if one is defined.
resolveClass(ObjectStreamClass) - Method in class java.io.ObjectInputStream
Load the local class equivalent of the specified stream class description.
resolveClass(Class<?>) - Method in class java.lang.ClassLoader
Links the specified class.
resolveDate(Map<TemporalField, Long>, ResolverStyle) - Method in class java.time.chrono.AbstractChronology
Resolves parsed ChronoField values into a date during parsing.
resolveDate(Map<TemporalField, Long>, ResolverStyle) - Method in interface java.time.chrono.Chronology
Resolves parsed ChronoField values into a date during parsing.
resolveDate(Map<TemporalField, Long>, ResolverStyle) - Method in class java.time.chrono.HijrahChronology
resolveDate(Map<TemporalField, Long>, ResolverStyle) - Method in class java.time.chrono.IsoChronology
Resolves parsed ChronoField values into a date during parsing.
resolveDate(Map<TemporalField, Long>, ResolverStyle) - Method in class java.time.chrono.JapaneseChronology
resolveDate(Map<TemporalField, Long>, ResolverStyle) - Method in class java.time.chrono.MinguoChronology
resolveDate(Map<TemporalField, Long>, ResolverStyle) - Method in class java.time.chrono.ThaiBuddhistChronology
resolvedName - Variable in exception javax.naming.NamingException
Contains the part of the name that has been successfully resolved.
resolvedObj - Variable in exception javax.naming.NamingException
Contains the object to which resolution of the part of the name was successful.
resolvedObj - Variable in class javax.naming.spi.ResolveResult
Field containing the Object that was resolved to successfully.
resolveEntity(String, String, String, String) - Method in interface javax.xml.stream.XMLResolver
Retrieves a resource.
resolveEntity(String, String) - Method in interface org.xml.sax.EntityResolver
Allow the application to resolve external entities.
resolveEntity(String, String, String, String) - Method in class org.xml.sax.ext.DefaultHandler2
Tells the parser to resolve the systemId against the baseURI and read the entity text from that resulting absolute URI.
resolveEntity(String, String) - Method in class org.xml.sax.ext.DefaultHandler2
Invokes EntityResolver2.resolveEntity() with null entity name and base URI.
resolveEntity(String, String, String, String) - Method in interface org.xml.sax.ext.EntityResolver2
Allows applications to map references to external entities into input sources, or tell the parser it should use conventional URI resolution.
resolveEntity(String, String) - Method in class org.xml.sax.HandlerBase
Deprecated.
Resolve an external entity.
resolveEntity(String, String) - Method in class org.xml.sax.helpers.DefaultHandler
Resolve an external entity.
resolveEntity(String, String) - Method in class org.xml.sax.helpers.XMLFilterImpl
Filter an external entity resolution.
resolveFunction(QName, int) - Method in interface javax.xml.xpath.XPathFunctionResolver
Find a function in the set of available functions.
resolveObject(Object) - Method in class java.io.ObjectInputStream
This method will allow trusted subclasses of ObjectInputStream to substitute one object for another during deserialization.
resolveProxyClass(String[]) - Method in class java.io.ObjectInputStream
Returns a proxy class that implements the interfaces named in a proxy class descriptor; subclasses may implement this method to read custom data from the stream along with the descriptors for dynamic proxy classes, allowing them to use an alternate loading mechanism for the interfaces and the proxy class.
Resolver - Interface in javax.naming.spi
This interface represents an "intermediate context" for name resolution.
RESOLVER - Static variable in class javax.xml.stream.XMLInputFactory
The property used to set/get the implementation of the XMLResolver
resolveResource(String, String, String, String, String) - Method in interface org.w3c.dom.ls.LSResourceResolver
Allow the application to resolve external resources.
ResolveResult - Class in javax.naming.spi
This class represents the result of resolution of a name.
ResolveResult() - Constructor for class javax.naming.spi.ResolveResult
Constructs an instance of ResolveResult with the resolved object and remaining name both initialized to null.
ResolveResult(Object, String) - Constructor for class javax.naming.spi.ResolveResult
Constructs a new instance of ResolveResult consisting of the resolved object and the remaining unresolved component.
ResolveResult(Object, Name) - Constructor for class javax.naming.spi.ResolveResult
Constructs a new instance of ResolveResult consisting of the resolved Object and the remaining name.
ResolverStyle - Enum in java.time.format
Enumeration of different ways to resolve dates and times.
resolveSibling(Path) - Method in interface java.nio.file.Path
Resolves the given path against this path's parent path.
resolveSibling(String) - Method in interface java.nio.file.Path
Converts a given path string to a Path and resolves it against this path's parent path in exactly the manner specified by the resolveSibling method.
resolveToClass(Name, Class<? extends Context>) - Method in interface javax.naming.spi.Resolver
Partially resolves a name.
resolveToClass(String, Class<? extends Context>) - Method in interface javax.naming.spi.Resolver
Partially resolves a name.
resolveVariable(QName) - Method in interface javax.xml.xpath.XPathVariableResolver
Find a variable in the set of available variables.
Resource - Annotation Type in javax.annotation
The Resource annotation marks a resource that is needed by the application.
Resource.AuthenticationType - Enum in javax.annotation
The two possible authentication types for a resource.
ResourceBundle - Class in java.util
Resource bundles contain locale-specific objects.
ResourceBundle() - Constructor for class java.util.ResourceBundle
Sole constructor.
ResourceBundle.Control - Class in java.util
ResourceBundle.Control defines a set of callback methods that are invoked by the ResourceBundle.getBundle factory methods during the bundle loading process.
ResourceBundleControlProvider - Interface in java.util.spi
An interface for service providers that provide implementations of ResourceBundle.Control.
Resources - Annotation Type in javax.annotation
This class is used to allow multiple resources declarations.
RESOURCES_ARE_NOT_READY - Static variable in class javax.print.attribute.standard.JobStateReason
At least one of the resources needed by the job, such as media, fonts, resource objects, etc., is not ready on any of the physical printers for which the job is a candidate.
RespectBinding - Annotation Type in javax.xml.ws
This feature clarifies the use of the wsdl:binding in a JAX-WS runtime.
RespectBindingFeature - Class in javax.xml.ws
This feature clarifies the use of the wsdl:binding in a JAX-WS runtime.
RespectBindingFeature() - Constructor for class javax.xml.ws.RespectBindingFeature
Creates an RespectBindingFeature.
RespectBindingFeature(boolean) - Constructor for class javax.xml.ws.RespectBindingFeature
Creates an RespectBindingFeature
Response<T> - Interface in javax.xml.ws
The Response interface provides methods used to obtain the payload and context of a message sent in response to an operation invocation.
response_expected() - Method in interface org.omg.PortableInterceptor.RequestInfoOperations
Indicates whether a response is expected.
ResponseCache - Class in java.net
Represents implementations of URLConnection caches.
ResponseCache() - Constructor for class java.net.ResponseCache
responseCode() - Method in exception java.net.HttpRetryException
Returns the http response code
responseCode - Variable in class java.net.HttpURLConnection
An int representing the three digit HTTP Status-Code.
ResponseHandler - Interface in org.omg.CORBA.portable
This interface is supplied by an ORB to a servant at invocation time and allows the servant to later retrieve an OutputStream for returning the invocation results.
responseMessage - Variable in class java.net.HttpURLConnection
The HTTP response message.
ResponseWrapper - Annotation Type in javax.xml.ws
Used to annotate methods in the Service Endpoint Interface with the response wrapper bean to be used at runtime.
rest_of_name - Variable in exception org.omg.CosNaming.NamingContextPackage.CannotProceed
rest_of_name - Variable in exception org.omg.CosNaming.NamingContextPackage.NotFound
restart() - Method in class javax.swing.Timer
Restarts the Timer, canceling any pending firings and causing it to fire with its initial delay.
RESTORE_CMD - Static variable in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
restoreAction - Variable in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
RestoreAction() - Constructor for class javax.swing.plaf.basic.BasicInternalFrameTitlePane.RestoreAction
restoreComposedText() - Method in class javax.swing.text.JTextComponent
Restores composed text previously saved by saveComposedText.
restoreOriginal() - Method in interface javax.sql.rowset.CachedRowSet
Restores this CachedRowSet object to its original value, that is, its value before the last set of changes.
restoreState(Hashtable<?, ?>) - Method in interface javax.swing.undo.StateEditable
Upon receiving this message the receiver should extract any relevant state out of state.
restoreSubcomponentFocus() - Method in class javax.swing.JInternalFrame
Requests the internal frame to restore focus to the last subcomponent that had focus.
Result(Object, Attributes) - Constructor for class javax.naming.spi.DirStateFactory.Result
Constructs an instance of Result.
Result - Interface in javax.xml.transform
An object that implements this interface contains the information needed to build a transformation result tree.
result() - Method in class org.omg.CORBA.Request
Retrieves the NamedValue object containing the return value for the method.
result(Any) - Method in class org.omg.CORBA.ServerRequest
Deprecated.
use the method set_result
result() - Method in interface org.omg.PortableInterceptor.RequestInfoOperations
Returns an any containing the result of the operation invocation.
ResultSet - Interface in java.sql
A table of data representing a database result set, which is usually generated by executing a statement that queries the database.
ResultSetMetaData - Interface in java.sql
An object that can be used to get information about the types and properties of the columns in a ResultSet object.
resume() - Method in class java.lang.Thread
Deprecated.
This method exists solely for use with Thread.suspend(), which has been deprecated because it is deadlock-prone. For more information, see Why are Thread.stop, Thread.suspend and Thread.resume Deprecated?.
resume() - Method in class java.lang.ThreadGroup
Deprecated.
This method is used solely in conjunction with Thread.suspend and ThreadGroup.suspend, both of which have been deprecated, as they are inherently deadlock-prone. See Thread.suspend() for details.
RETAIN - Static variable in class org.omg.PortableServer.ServantRetentionPolicyValue
retainAll(Collection) - Method in class java.beans.beancontext.BeanContextSupport
retain only specified children (Unsupported) implementations must synchronized on the hierarchy lock and "children" protected field
retainAll(Collection<?>) - Method in class java.util.AbstractCollection
Retains only the elements in this collection that are contained in the specified collection (optional operation).
retainAll(Collection<?>) - Method in class java.util.ArrayList
Retains only the elements in this list that are contained in the specified collection.
retainAll(Collection<?>) - Method in interface java.util.Collection
Retains only the elements in this collection that are contained in the specified collection (optional operation).
retainAll(Collection<?>) - Method in class java.util.concurrent.CopyOnWriteArrayList
Retains only the elements in this list that are contained in the specified collection.
retainAll(Collection<?>) - Method in class java.util.concurrent.CopyOnWriteArraySet
Retains only the elements in this set that are contained in the specified collection.
retainAll(Collection<?>) - Method in class java.util.concurrent.SynchronousQueue
Always returns false.
retainAll(Collection<?>) - Method in interface java.util.List
Retains only the elements in this list that are contained in the specified collection (optional operation).
retainAll(Collection<?>) - Method in interface java.util.Set
Retains only the elements in this set that are contained in the specified collection (optional operation).
retainAll(Collection<?>) - Method in class java.util.Vector
Retains only the elements in this Vector that are contained in the specified Collection.
Retention - Annotation Type in java.lang.annotation
Indicates how long annotations with the annotated type are to be retained.
RetentionPolicy - Enum in java.lang.annotation
Annotation retention policy.
retransformClasses(Class<?>...) - Method in interface java.lang.instrument.Instrumentation
Retransform the supplied set of classes.
RetrievalMethod - Interface in javax.xml.crypto.dsig.keyinfo
A representation of the XML RetrievalMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
retrieveAllRoles() - Method in interface javax.management.relation.Relation
Returns all roles in the relation without checking read mode.
retrieveAllRoles() - Method in class javax.management.relation.RelationSupport
Returns all roles in the relation without checking read mode.
retryReferral() - Method in exception javax.naming.ReferralException
Retries the referral currently being processed.
RETURN_GENERATED_KEYS - Static variable in interface java.sql.Statement
The constant indicating that generated keys should be made available for retrieval.
return_value() - Method in class org.omg.CORBA.Request
Returns the Any object that contains the value for the result of the method.
returnType() - Method in class java.lang.invoke.MethodType
Returns the return type of this method type.
REUSE - Static variable in class javax.security.sasl.Sasl
The name of a property that specifies whether to reuse previously authenticated session information.
REV - Static variable in class javax.swing.text.html.HTML.Attribute
revalidate() - Method in class java.awt.Component.BltBufferStrategy
Restore the drawing buffer if it has been lost
revalidate() - Method in class java.awt.Component.FlipBufferStrategy
Restore the drawing buffer if it has been lost
revalidate() - Method in class java.awt.Component
Revalidates the component hierarchy up to the nearest validate root.
revalidate() - Method in class javax.swing.DefaultListCellRenderer
Overridden for performance reasons.
revalidate() - Method in class javax.swing.JComponent
Supports deferred automatic layout.
revalidate() - Method in class javax.swing.table.DefaultTableCellRenderer
Overridden for performance reasons.
revalidate() - Method in class javax.swing.tree.DefaultTreeCellRenderer
Overridden for performance reasons.
revealDirect(MethodHandle) - Method in class java.lang.invoke.MethodHandles.Lookup
Cracks a direct method handle created by this lookup object or a similar one.
REVERB - Static variable in class javax.sound.sampled.EnumControl.Type
Represents a control over a set of possible reverberation settings.
REVERB_RETURN - Static variable in class javax.sound.sampled.FloatControl.Type
Represents a control for the post-reverb gain on a line.
REVERB_SEND - Static variable in class javax.sound.sampled.FloatControl.Type
Represents a control for the pre-reverb gain on a line.
ReverbType - Class in javax.sound.sampled
The ReverbType class provides methods for accessing various reverberation settings to be applied to an audio signal.
ReverbType(String, int, float, int, float, int) - Constructor for class javax.sound.sampled.ReverbType
Constructs a new reverb type that has the specified reverberation parameter values.
reverse(int) - Static method in class java.lang.Integer
Returns the value obtained by reversing the order of the bits in the two's complement binary representation of the specified int value.
reverse(long) - Static method in class java.lang.Long
Returns the value obtained by reversing the order of the bits in the two's complement binary representation of the specified long value.
reverse() - Method in class java.lang.StringBuffer
reverse() - Method in class java.lang.StringBuilder
reverse(List<?>) - Static method in class java.util.Collections
Reverses the order of the elements in the specified list.
REVERSE_LANDSCAPE - Static variable in class java.awt.print.PageFormat
The origin is at the top right of the paper with x running top to bottom and y running right to left.
REVERSE_LANDSCAPE - Static variable in class javax.print.attribute.standard.OrientationRequested
The content will be imaged across the long edge of the medium, but in the opposite manner from landscape.
REVERSE_PORTRAIT - Static variable in class javax.print.attribute.standard.OrientationRequested
The content will be imaged across the short edge of the medium, but in the opposite manner from portrait.
reverseBytes(char) - Static method in class java.lang.Character
Returns the value obtained by reversing the order of the bytes in the specified char value.
reverseBytes(int) - Static method in class java.lang.Integer
Returns the value obtained by reversing the order of the bytes in the two's complement representation of the specified int value.
reverseBytes(long) - Static method in class java.lang.Long
Returns the value obtained by reversing the order of the bytes in the two's complement representation of the specified long value.
reverseBytes(short) - Static method in class java.lang.Short
Returns the value obtained by reversing the order of the bytes in the two's complement representation of the specified short value.
reversed() - Method in interface java.util.Comparator
Returns a comparator that imposes the reverse ordering of this comparator.
reverseOrder() - Static method in class java.util.Collections
Returns a comparator that imposes the reverse of the natural ordering on a collection of objects that implement the Comparable interface.
reverseOrder(Comparator<T>) - Static method in class java.util.Collections
Returns a comparator that imposes the reverse ordering of the specified comparator.
reverseOrder() - Static method in interface java.util.Comparator
Returns a comparator that imposes the reverse of the natural ordering.
REVERT - Static variable in class javax.swing.JFormattedTextField
Constant identifying that when focus is lost, editing value should be reverted to current value set on the JFormattedTextField.
revokeService(Class, BeanContextServiceProvider, boolean) - Method in interface java.beans.beancontext.BeanContextServices
BeanContextServiceProviders wishing to remove a currently registered service from this context may do so via invocation of this method.
revokeService(Class, BeanContextServiceProvider, boolean) - Method in class java.beans.beancontext.BeanContextServicesSupport
remove a service
rewind() - Method in class java.nio.Buffer
Rewinds this buffer.
rewind() - Method in interface org.omg.CORBA.DynAny
Deprecated.
Moves the internal pointer to the first component.
rewind() - Method in class org.omg.DynamicAny._DynAnyStub
Is equivalent to seek(0).
rewind() - Method in class org.omg.DynamicAny._DynArrayStub
Is equivalent to seek(0).
rewind() - Method in class org.omg.DynamicAny._DynEnumStub
Is equivalent to seek(0).
rewind() - Method in class org.omg.DynamicAny._DynFixedStub
Is equivalent to seek(0).
rewind() - Method in class org.omg.DynamicAny._DynSequenceStub
Is equivalent to seek(0).
rewind() - Method in class org.omg.DynamicAny._DynStructStub
Is equivalent to seek(0).
rewind() - Method in class org.omg.DynamicAny._DynUnionStub
Is equivalent to seek(0).
rewind() - Method in class org.omg.DynamicAny._DynValueStub
Is equivalent to seek(0).
rewind() - Method in interface org.omg.DynamicAny.DynAnyOperations
Is equivalent to seek(0).
RFC1779 - Static variable in class javax.security.auth.x500.X500Principal
RFC 1779 String format of Distinguished Names.
RFC2253 - Static variable in class javax.security.auth.x500.X500Principal
RFC 2253 String format of Distinguished Names.
RFC_1123_DATE_TIME - Static variable in class java.time.format.DateTimeFormatter
The RFC-1123 date-time formatter, such as 'Tue, 3 Jun 2008 11:05:30 GMT'.
RGBImageFilter - Class in java.awt.image
This class provides an easy way to create an ImageFilter which modifies the pixels of an image in the default RGB ColorModel.
RGBImageFilter() - Constructor for class java.awt.image.RGBImageFilter
RGBtoHSB(int, int, int, float[]) - Static method in class java.awt.Color
Converts the components of a color, as specified by the default RGB model, to an equivalent set of values for hue, saturation, and brightness that are the three components of the HSB model.
RIGHT - Static variable in class java.awt.Event
The Right Arrow key, a non-ASCII action key.
RIGHT - Static variable in class java.awt.FlowLayout
This value indicates that each row of components should be right-justified.
right - Variable in class java.awt.Insets
The inset from the right.
RIGHT - Static variable in class java.awt.Label
Indicates that the label should be right justified.
right - Variable in class javax.swing.border.EmptyBorder
RIGHT - Static variable in class javax.swing.border.TitledBorder
Position title text at the right side of the border line.
RIGHT - Static variable in class javax.swing.JSplitPane
Used to add a Component to the right of the other Component.
RIGHT - Static variable in interface javax.swing.SwingConstants
Box-orientation constant used to specify the right side of a box.
RIGHT_ALIGNMENT - Static variable in class java.awt.Component
Ease-of-use constant for getAlignmentX.
RIGHT_OUTER_JOIN - Static variable in interface javax.sql.rowset.JoinRowSet
An ANSI-style JOIN providing a right outer join between two tables.
RIGHT_TO_LEFT - Static variable in class java.awt.ComponentOrientation
Items run right to left and lines flow top to bottom Examples: Arabic, Hebrew.
rightButton - Variable in class javax.swing.plaf.basic.BasicSplitPaneDivider
Button for quickly toggling the right component.
rightChildIndent - Variable in class javax.swing.plaf.basic.BasicTreeUI
Distance to add to leftChildIndent to determine where cell contents will be drawn.
rightComponent - Variable in class javax.swing.JSplitPane
The right or bottom component.
RightIndent - Static variable in class javax.swing.text.StyleConstants
The amount to indent the right side of the paragraph.
rightKey - Variable in class javax.swing.plaf.basic.BasicSplitPaneUI
Deprecated.
As of Java 2 platform v1.3.
rightKey - Variable in class javax.swing.plaf.basic.BasicTabbedPaneUI
Deprecated.
As of Java 2 platform v1.3.
rightKey - Variable in class javax.swing.plaf.basic.BasicToolBarUI
Deprecated.
As of Java 2 platform v1.3.
rint(double) - Static method in class java.lang.Math
Returns the double value that is closest in value to the argument and is equal to a mathematical integer.
rint(double) - Static method in class java.lang.StrictMath
Returns the double value that is closest in value to the argument and is equal to a mathematical integer.
RIPEMD160 - Static variable in interface javax.xml.crypto.dsig.DigestMethod
The RIPEMD-160 digest method algorithm URI.
RMI_CLIENT_SOCKET_FACTORY_ATTRIBUTE - Static variable in class javax.management.remote.rmi.RMIConnectorServer
Name of the attribute that specifies the RMIClientSocketFactory for the RMI objects created in conjunction with this connector.
RMI_SERVER_SOCKET_FACTORY_ATTRIBUTE - Static variable in class javax.management.remote.rmi.RMIConnectorServer
Name of the attribute that specifies the RMIServerSocketFactory for the RMI objects created in conjunction with this connector.
RMIClassLoader - Class in java.rmi.server
RMIClassLoader comprises static methods to support dynamic class loading with RMI.
RMIClassLoaderSpi - Class in java.rmi.server
RMIClassLoaderSpi is the service provider interface for RMIClassLoader.
RMIClassLoaderSpi() - Constructor for class java.rmi.server.RMIClassLoaderSpi
RMIClientSocketFactory - Interface in java.rmi.server
An RMIClientSocketFactory instance is used by the RMI runtime in order to obtain client sockets for RMI calls.
RMIConnection - Interface in javax.management.remote.rmi
RMI object used to forward an MBeanServer request from a client to its MBeanServer implementation on the server side.
RMIConnectionImpl - Class in javax.management.remote.rmi
Implementation of the RMIConnection interface.
RMIConnectionImpl(RMIServerImpl, String, ClassLoader, Subject, Map<String, ?>) - Constructor for class javax.management.remote.rmi.RMIConnectionImpl
Constructs a new RMIConnection.
RMIConnectionImpl_Stub - Class in javax.management.remote.rmi
RMIConnectionImpl_Stub(RemoteRef) - Constructor for class javax.management.remote.rmi.RMIConnectionImpl_Stub
RMIConnector - Class in javax.management.remote.rmi
A connection to a remote RMI connector.
RMIConnector(JMXServiceURL, Map<String, ?>) - Constructor for class javax.management.remote.rmi.RMIConnector
Constructs an RMIConnector that will connect the RMI connector server with the given address.
RMIConnector(RMIServer, Map<String, ?>) - Constructor for class javax.management.remote.rmi.RMIConnector
Constructs an RMIConnector using the given RMI stub.
RMIConnectorServer - Class in javax.management.remote.rmi
A JMX API connector server that creates RMI-based connections from remote clients.
RMIConnectorServer(JMXServiceURL, Map<String, ?>) - Constructor for class javax.management.remote.rmi.RMIConnectorServer
Makes an RMIConnectorServer.
RMIConnectorServer(JMXServiceURL, Map<String, ?>, MBeanServer) - Constructor for class javax.management.remote.rmi.RMIConnectorServer
Makes an RMIConnectorServer for the given MBean server.
RMIConnectorServer(JMXServiceURL, Map<String, ?>, RMIServerImpl, MBeanServer) - Constructor for class javax.management.remote.rmi.RMIConnectorServer
Makes an RMIConnectorServer for the given MBean server.
RMICustomMaxStreamFormat - Interface in org.omg.IOP
org/omg/IOP/RMICustomMaxStreamFormat.java .
RMIFailureHandler - Interface in java.rmi.server
An RMIFailureHandler can be registered via the RMISocketFactory.setFailureHandler call.
RMIIIOPServerImpl - Class in javax.management.remote.rmi
An RMIServerImpl that is exported through IIOP and that creates client connections as RMI objects exported through IIOP.
RMIIIOPServerImpl(Map<String, ?>) - Constructor for class javax.management.remote.rmi.RMIIIOPServerImpl
Creates a new RMIServerImpl.
RMIJRMPServerImpl - Class in javax.management.remote.rmi
An RMIServer object that is exported through JRMP and that creates client connections as RMI objects exported through JRMP.
RMIJRMPServerImpl(int, RMIClientSocketFactory, RMIServerSocketFactory, Map<String, ?>) - Constructor for class javax.management.remote.rmi.RMIJRMPServerImpl
Creates a new RMIServer object that will be exported on the given port using the given socket factories.
RMISecurityException - Exception in java.rmi
Deprecated.
Use SecurityException instead. Application code should never directly reference this class, and RMISecurityManager no longer throws this subclass of java.lang.SecurityException.
RMISecurityException(String) - Constructor for exception java.rmi.RMISecurityException
Deprecated.
no replacement
RMISecurityException(String, String) - Constructor for exception java.rmi.RMISecurityException
Deprecated.
no replacement
RMISecurityManager - Class in java.rmi
Deprecated.
Use SecurityManager instead.
RMISecurityManager() - Constructor for class java.rmi.RMISecurityManager
Deprecated.
Constructs a new RMISecurityManager.
RMIServer - Interface in javax.management.remote.rmi
RMI object used to establish connections to an RMI connector.
RMIServerImpl - Class in javax.management.remote.rmi
An RMI object representing a connector server.
RMIServerImpl(Map<String, ?>) - Constructor for class javax.management.remote.rmi.RMIServerImpl
Constructs a new RMIServerImpl.
RMIServerImpl_Stub - Class in javax.management.remote.rmi
RMIServerImpl_Stub(RemoteRef) - Constructor for class javax.management.remote.rmi.RMIServerImpl_Stub
RMIServerSocketFactory - Interface in java.rmi.server
An RMIServerSocketFactory instance is used by the RMI runtime in order to obtain server sockets for RMI calls.
RMISocketFactory - Class in java.rmi.server
An RMISocketFactory instance is used by the RMI runtime in order to obtain client and server sockets for RMI calls.
RMISocketFactory() - Constructor for class java.rmi.server.RMISocketFactory
Constructs an RMISocketFactory.
Robot - Class in java.awt
This class is used to generate native system input events for the purposes of test automation, self-running demos, and other applications where control of the mouse and keyboard is needed.
Robot() - Constructor for class java.awt.Robot
Constructs a Robot object in the coordinate system of the primary screen.
Robot(GraphicsDevice) - Constructor for class java.awt.Robot
Creates a Robot for the given screen device.
Role - Class in javax.management.relation
Represents a role: includes a role name and referenced MBeans (via their ObjectNames).
Role(String, List<ObjectName>) - Constructor for class javax.management.relation.Role
Make a new Role object.
ROLE_CARDINALITY_INFINITY - Static variable in class javax.management.relation.RoleInfo
To specify an unlimited cardinality.
ROLE_NOT_READABLE - Static variable in class javax.management.relation.RoleStatus
Problem type when trying to read a non-readable attribute.
ROLE_NOT_WRITABLE - Static variable in class javax.management.relation.RoleStatus
Problem type when trying to update a non-writable attribute.
RoleInfo - Class in javax.management.relation
A RoleInfo object summarises a role in a relation type.
RoleInfo(String, String, boolean, boolean, int, int, String) - Constructor for class javax.management.relation.RoleInfo
Constructor.
RoleInfo(String, String, boolean, boolean) - Constructor for class javax.management.relation.RoleInfo
Constructor.
RoleInfo(String, String) - Constructor for class javax.management.relation.RoleInfo
Constructor.
RoleInfo(RoleInfo) - Constructor for class javax.management.relation.RoleInfo
Copy constructor.
RoleInfoNotFoundException - Exception in javax.management.relation
This exception is raised when there is no role info with given name in a given relation type.
RoleInfoNotFoundException() - Constructor for exception javax.management.relation.RoleInfoNotFoundException
Default constructor, no message put in exception.
RoleInfoNotFoundException(String) - Constructor for exception javax.management.relation.RoleInfoNotFoundException
Constructor with given message put in exception.
RoleList - Class in javax.management.relation
A RoleList represents a list of roles (Role objects).
RoleList() - Constructor for class javax.management.relation.RoleList
Constructs an empty RoleList.
RoleList(int) - Constructor for class javax.management.relation.RoleList
Constructs an empty RoleList with the initial capacity specified.
RoleList(List<Role>) - Constructor for class javax.management.relation.RoleList
Constructs a RoleList containing the elements of the List specified, in the order in which they are returned by the List's iterator.
RoleNotFoundException - Exception in javax.management.relation
This exception is raised when a role in a relation does not exist, or is not readable, or is not settable.
RoleNotFoundException() - Constructor for exception javax.management.relation.RoleNotFoundException
Default constructor, no message put in exception.
RoleNotFoundException(String) - Constructor for exception javax.management.relation.RoleNotFoundException
Constructor with given message put in exception.
RoleResult - Class in javax.management.relation
Represents the result of a multiple access to several roles of a relation (either for reading or writing).
RoleResult(RoleList, RoleUnresolvedList) - Constructor for class javax.management.relation.RoleResult
Constructor.
RoleStatus - Class in javax.management.relation
This class describes the various problems which can be encountered when accessing a role.
RoleStatus() - Constructor for class javax.management.relation.RoleStatus
RoleUnresolved - Class in javax.management.relation
Represents an unresolved role: a role not retrieved from a relation due to a problem.
RoleUnresolved(String, List<ObjectName>, int) - Constructor for class javax.management.relation.RoleUnresolved
Constructor.
RoleUnresolvedList - Class in javax.management.relation
A RoleUnresolvedList represents a list of RoleUnresolved objects, representing roles not retrieved from a relation due to a problem encountered when trying to access (read or write) the roles.
RoleUnresolvedList() - Constructor for class javax.management.relation.RoleUnresolvedList
Constructs an empty RoleUnresolvedList.
RoleUnresolvedList(int) - Constructor for class javax.management.relation.RoleUnresolvedList
Constructs an empty RoleUnresolvedList with the initial capacity specified.
RoleUnresolvedList(List<RoleUnresolved>) - Constructor for class javax.management.relation.RoleUnresolvedList
Constructs a RoleUnresolvedList containing the elements of the List specified, in the order in which they are returned by the List's iterator.
roleValueToString(List<ObjectName>) - Static method in class javax.management.relation.Role
Returns a string for the given role value.
roll(int, boolean) - Method in class java.util.Calendar
Adds or subtracts (up/down) a single unit of time on the given time field without changing larger fields.
roll(int, int) - Method in class java.util.Calendar
Adds the specified (signed) amount to the specified calendar field without changing larger fields.
roll(int, boolean) - Method in class java.util.GregorianCalendar
Adds or subtracts (up/down) a single unit of time on the given time field without changing larger fields.
roll(int, int) - Method in class java.util.GregorianCalendar
Adds a signed amount to the specified calendar field without changing larger fields.
rollback() - Method in interface java.sql.Connection
Undoes all changes made in the current transaction and releases any database locks currently held by this Connection object.
rollback(Savepoint) - Method in interface java.sql.Connection
Undoes all changes made after the given Savepoint object was set.
rollback() - Method in interface javax.sql.rowset.CachedRowSet
Each CachedRowSet object's SyncProvider contains a Connection object from the original ResultSet or JDBC properties passed to it.
rollback(Savepoint) - Method in interface javax.sql.rowset.CachedRowSet
Each CachedRowSet object's SyncProvider contains a Connection object from the original ResultSet or JDBC properties passed to it.
rollback() - Method in interface javax.sql.rowset.JdbcRowSet
Each JdbcRowSet contains a Connection object from the original ResultSet or JDBC properties passed to it.
rollback(Savepoint) - Method in interface javax.sql.rowset.JdbcRowSet
Each JdbcRowSet contains a Connection object from the original ResultSet or JDBC properties passed to it.
rollback() - Method in interface javax.sql.rowset.spi.TransactionalWriter
Undoes all changes made in the current transaction.
rollback(Savepoint) - Method in interface javax.sql.rowset.spi.TransactionalWriter
Undoes all changes made in the current transaction made prior to the given Savepoint object.
rollback(Xid) - Method in interface javax.transaction.xa.XAResource
Informs the resource manager to roll back work done on behalf of a transaction branch.
ROLLOVER - Static variable in class javax.swing.DefaultButtonModel
Identifies the "rollover" bit in the bitmask, which indicates that the mouse is over the button.
ROLLOVER_ENABLED_CHANGED_PROPERTY - Static variable in class javax.swing.AbstractButton
Identifies a change from rollover enabled to disabled or back to enabled.
ROLLOVER_ICON_CHANGED_PROPERTY - Static variable in class javax.swing.AbstractButton
Identifies a change to the icon used when the cursor is over the button.
ROLLOVER_SELECTED_ICON_CHANGED_PROPERTY - Static variable in class javax.swing.AbstractButton
Identifies a change to the icon used when the cursor is over the button and it has been selected.
RolloverButtonBorder(Color, Color, Color, Color) - Constructor for class javax.swing.plaf.basic.BasicBorders.RolloverButtonBorder
RolloverButtonBorder() - Constructor for class javax.swing.plaf.metal.MetalBorders.RolloverButtonBorder
rolloverColumnUpdated(int, int) - Method in class javax.swing.plaf.basic.BasicTableHeaderUI
This method gets called every time when a rollover column in the table header is updated.
rolloverColumnUpdated(int, int) - Method in class javax.swing.plaf.synth.SynthTableHeaderUI
This method gets called every time when a rollover column in the table header is updated.
rolloverListener - Variable in class javax.swing.plaf.metal.MetalToolBarUI
This protected field is implementation specific.
ROMAN_BASELINE - Static variable in class java.awt.font.GraphicAttribute
Aligns origin of graphic to roman baseline of line.
ROMAN_BASELINE - Static variable in class java.awt.Font
The baseline used in most Roman scripts when laying out text.
ROOT - Static variable in class java.util.Locale
Useful constant for the root locale.
root - Variable in class javax.swing.tree.DefaultTreeModel
Root of the tree.
ROOT_PANE - Static variable in class javax.accessibility.AccessibleRole
A specialized pane that has a glass pane and a layered pane as its children.
ROOT_PANE - Static variable in class javax.swing.plaf.synth.Region
RootPane region.
ROOT_PANE_PROPERTY - Static variable in class javax.swing.JInternalFrame
Bound property name.
ROOT_VISIBLE_PROPERTY - Static variable in class javax.swing.JTree
Bound property name for rootVisible.
rootException - Variable in exception javax.naming.NamingException
Contains the original exception that caused this NamingException to be thrown.
RootLayout() - Constructor for class javax.swing.JRootPane.RootLayout
rootPane - Variable in class javax.swing.JApplet
rootPane - Variable in class javax.swing.JDialog
rootPane - Variable in class javax.swing.JFrame
The JRootPane instance that manages the contentPane and optional menuBar for this frame, as well as the glassPane.
rootPane - Variable in class javax.swing.JInternalFrame
The JRootPane instance that manages the content pane and optional menu bar for this internal frame, as well as the glass pane.
rootPane - Variable in class javax.swing.JWindow
The JRootPane instance that manages the contentPane and optional menuBar for this frame, as well as the glassPane.
rootPaneCheckingEnabled - Variable in class javax.swing.JApplet
If true then calls to add and setLayout will be forwarded to the contentPane.
rootPaneCheckingEnabled - Variable in class javax.swing.JDialog
If true then calls to add and setLayout will be forwarded to the contentPane.
rootPaneCheckingEnabled - Variable in class javax.swing.JFrame
If true then calls to add and setLayout will be forwarded to the contentPane.
rootPaneCheckingEnabled - Variable in class javax.swing.JInternalFrame
If true then calls to add and setLayout will be forwarded to the contentPane.
rootPaneCheckingEnabled - Variable in class javax.swing.JWindow
If true then calls to add and setLayout will be forwarded to the contentPane.
RootPaneContainer - Interface in javax.swing
This interface is implemented by components that have a single JRootPane child: JDialog, JFrame, JWindow, JApplet, JInternalFrame.
RootPaneUI - Class in javax.swing.plaf
Pluggable look and feel interface for JRootPane.
RootPaneUI() - Constructor for class javax.swing.plaf.RootPaneUI
rootVisible - Variable in class javax.swing.JTree
True if the root node is displayed, false if its children are the highest visible nodes.
rootVisible - Variable in class javax.swing.tree.AbstractLayoutCache
True if the root node is displayed, false if its children are the highest visible nodes.
rotate(double) - Method in class java.awt.geom.AffineTransform
Concatenates this transform with a rotation transformation.
rotate(double, double, double) - Method in class java.awt.geom.AffineTransform
Concatenates this transform with a transform that rotates coordinates around an anchor point.
rotate(double, double) - Method in class java.awt.geom.AffineTransform
Concatenates this transform with a transform that rotates coordinates according to a rotation vector.
rotate(double, double, double, double) - Method in class java.awt.geom.AffineTransform
Concatenates this transform with a transform that rotates coordinates around an anchor point according to a rotation vector.
rotate(double) - Method in class java.awt.Graphics2D
Concatenates the current Graphics2D Transform with a rotation transform.
rotate(double, double, double) - Method in class java.awt.Graphics2D
Concatenates the current Graphics2D Transform with a translated rotation transform.
rotate(List<?>, int) - Static method in class java.util.Collections
Rotates the elements in the specified list by the specified distance.
rotateInsets(Insets, Insets, int) - Static method in class javax.swing.plaf.basic.BasicTabbedPaneUI
rotateLeft(int, int) - Static method in class java.lang.Integer
Returns the value obtained by rotating the two's complement binary representation of the specified int value left by the specified number of bits.
rotateLeft(long, int) - Static method in class java.lang.Long
Returns the value obtained by rotating the two's complement binary representation of the specified long value left by the specified number of bits.
rotateRight(int, int) - Static method in class java.lang.Integer
Returns the value obtained by rotating the two's complement binary representation of the specified int value right by the specified number of bits.
rotateRight(long, int) - Static method in class java.lang.Long
Returns the value obtained by rotating the two's complement binary representation of the specified long value right by the specified number of bits.
rotateTabRuns(int, int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout
rotateTabRuns(int, int) - Method in class javax.swing.plaf.metal.MetalTabbedPaneUI.TabbedPaneLayout
round(float) - Static method in class java.lang.Math
Returns the closest int to the argument, with ties rounding to positive infinity.
round(double) - Static method in class java.lang.Math
Returns the closest long to the argument, with ties rounding to positive infinity.
round(float) - Static method in class java.lang.StrictMath
Returns the closest int to the argument, with ties rounding to positive infinity.
round(double) - Static method in class java.lang.StrictMath
Returns the closest long to the argument, with ties rounding to positive infinity.
round(MathContext) - Method in class java.math.BigDecimal
Returns a BigDecimal rounded according to the MathContext settings.
ROUND_CEILING - Static variable in class java.math.BigDecimal
Rounding mode to round towards positive infinity.
ROUND_DOWN - Static variable in class java.math.BigDecimal
Rounding mode to round towards zero.
ROUND_FLOOR - Static variable in class java.math.BigDecimal
Rounding mode to round towards negative infinity.
ROUND_HALF_DOWN - Static variable in class java.math.BigDecimal
Rounding mode to round towards "nearest neighbor" unless both neighbors are equidistant, in which case round down.
ROUND_HALF_EVEN - Static variable in class java.math.BigDecimal
Rounding mode to round towards the "nearest neighbor" unless both neighbors are equidistant, in which case, round towards the even neighbor.
ROUND_HALF_UP - Static variable in class java.math.BigDecimal
Rounding mode to round towards "nearest neighbor" unless both neighbors are equidistant, in which case round up.
ROUND_UNNECESSARY - Static variable in class java.math.BigDecimal
Rounding mode to assert that the requested operation has an exact result, hence no rounding is necessary.
ROUND_UP - Static variable in class java.math.BigDecimal
Rounding mode to round away from zero.
roundedCorners - Variable in class javax.swing.border.LineBorder
RoundEnvironment - Interface in javax.annotation.processing
An annotation processing tool framework will provide an annotation processor with an object implementing this interface so that the processor can query for information about a round of annotation processing.
RoundingMode - Enum in java.math
Specifies a rounding behavior for numerical operations capable of discarding precision.
RoundRectangle2D - Class in java.awt.geom
The RoundRectangle2D class defines a rectangle with rounded corners defined by a location (x,y), a dimension (w x h), and the width and height of an arc with which to round the corners.
RoundRectangle2D() - Constructor for class java.awt.geom.RoundRectangle2D
This is an abstract class that cannot be instantiated directly.
RoundRectangle2D.Double - Class in java.awt.geom
The Double class defines a rectangle with rounded corners all specified in double coordinates.
RoundRectangle2D.Float - Class in java.awt.geom
The Float class defines a rectangle with rounded corners all specified in float coordinates.
ROW_HEADER - Static variable in class javax.accessibility.AccessibleRole
The header for a row of data.
ROW_HEADER - Static variable in interface javax.swing.ScrollPaneConstants
Identifies the area along the left side of the viewport between the upper left corner and the lower left corner.
ROW_HEIGHT_PROPERTY - Static variable in class javax.swing.JTree
Bound property name for rowHeight.
rowAtPoint(Point) - Method in class javax.swing.JTable
Returns the index of the row that point lies in, or -1 if the result is not in the range [0, getRowCount()-1].
rowChanged(RowSetEvent) - Method in interface javax.sql.RowSetListener
Notifies registered listeners that a RowSet object has had a change in one of its rows.
rowDeleted() - Method in interface java.sql.ResultSet
Retrieves whether a row has been deleted.
RowFilter<M,I> - Class in javax.swing
RowFilter is used to filter out entries from the model so that they are not shown in the view.
RowFilter() - Constructor for class javax.swing.RowFilter
RowFilter.ComparisonType - Enum in javax.swing
Enumeration of the possible comparison values supported by some of the default RowFilters.
RowFilter.Entry<M,I> - Class in javax.swing
An Entry object is passed to instances of RowFilter, allowing the filter to get the value of the entry's data, and thus to determine whether the entry should be shown.
rowHead - Variable in class javax.swing.ScrollPaneLayout
The row header child.
rowHeader - Variable in class javax.swing.JScrollPane
The row header child.
rowHeight - Variable in class javax.swing.JTable
The height in pixels of each row in the table.
rowHeight - Variable in class javax.swing.JTree
Height to use for each display row.
rowHeight - Variable in class javax.swing.tree.AbstractLayoutCache
Height to use for each row.
rowHeights - Variable in class java.awt.GridBagLayout
This field holds the overrides to the row minimum heights.
RowId - Interface in java.sql
The representation (mapping) in the Java programming language of an SQL ROWID value.
ROWID - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type ROWID
RowIdLifetime - Enum in java.sql
Enumeration for RowId life-time values.
rowInserted() - Method in interface java.sql.ResultSet
Retrieves whether the current row has had an insertion.
rowMapper - Variable in class javax.swing.tree.DefaultTreeSelectionModel
Provides a row for a given path.
RowMapper - Interface in javax.swing.tree
Defines the requirements for an object that translates paths in the tree into display rows.
rowMargin - Variable in class javax.swing.JTable
The height in pixels of the margin between the cells in each row.
ROWS - Static variable in class javax.swing.text.html.HTML.Attribute
rowsDeleted(int, int) - Method in class javax.swing.DefaultRowSorter
Invoked when rows have been deleted from the underlying model in the specified range (inclusive).
rowsDeleted(int, int) - Method in class javax.swing.RowSorter
Invoked when rows have been deleted from the underlying model in the specified range (inclusive).
rowSelectionAllowed - Variable in class javax.swing.JTable
True if row selection is allowed in this table.
RowSet - Interface in javax.sql
The interface that adds support to the JDBC API for the JavaBeans™ component model.
ROWSET_SYNC_PROVIDER - Static variable in class javax.sql.rowset.spi.SyncFactory
The standard property-id for a synchronization provider implementation name.
ROWSET_SYNC_PROVIDER_VERSION - Static variable in class javax.sql.rowset.spi.SyncFactory
The standard property-id for a synchronization provider implementation version tag.
ROWSET_SYNC_VENDOR - Static variable in class javax.sql.rowset.spi.SyncFactory
The standard property-id for a synchronization provider implementation vendor name.
rowSetChanged(RowSetEvent) - Method in interface javax.sql.RowSetListener
Notifies registered listeners that a RowSet object in the given RowSetEvent object has changed its entire contents.
RowSetEvent - Class in javax.sql
An Event object generated when an event occurs to a RowSet object.
RowSetEvent(RowSet) - Constructor for class javax.sql.RowSetEvent
Constructs a RowSetEvent object initialized with the given RowSet object.
RowSetFactory - Interface in javax.sql.rowset
An interface that defines the implementation of a factory that is used to obtain different types of RowSet implementations.
RowSetInternal - Interface in javax.sql
The interface that a RowSet object implements in order to present itself to a RowSetReader or RowSetWriter object.
RowSetListener - Interface in javax.sql
An interface that must be implemented by a component that wants to be notified when a significant event happens in the life of a RowSet object.
RowSetMetaData - Interface in javax.sql
An object that contains information about the columns in a RowSet object.
RowSetMetaDataImpl - Class in javax.sql.rowset
Provides implementations for the methods that set and get metadata information about a RowSet object's columns.
RowSetMetaDataImpl() - Constructor for class javax.sql.rowset.RowSetMetaDataImpl
rowSetPopulated(RowSetEvent, int) - Method in interface javax.sql.rowset.CachedRowSet
Notifies registered listeners that a RowSet object in the given RowSetEvent object has populated a number of additional rows.
RowSetProvider - Class in javax.sql.rowset
A factory API that enables applications to obtain a RowSetFactory implementation that can be used to create different types of RowSet implementations.
RowSetProvider() - Constructor for class javax.sql.rowset.RowSetProvider
RowSetProvider constructor
RowSetReader - Interface in javax.sql
The facility that a disconnected RowSet object calls on to populate itself with rows of data.
RowSetWarning - Exception in javax.sql.rowset
An extension of SQLException that provides information about database warnings set on RowSet objects.
RowSetWarning(String) - Constructor for exception javax.sql.rowset.RowSetWarning
Constructs a RowSetWarning object with the given value for the reason; SQLState defaults to null, and vendorCode defaults to 0.
RowSetWarning() - Constructor for exception javax.sql.rowset.RowSetWarning
Constructs a default RowSetWarning object.
RowSetWarning(String, String) - Constructor for exception javax.sql.rowset.RowSetWarning
Constructs a RowSetWarning object initialized with the given values for the reason and SQLState.
RowSetWarning(String, String, int) - Constructor for exception javax.sql.rowset.RowSetWarning
Constructs a fully specified RowSetWarning object initialized with the given values for the reason, SQLState and vendorCode.
RowSetWriter - Interface in javax.sql
An object that implements the RowSetWriter interface, called a writer.
rowsInserted(int, int) - Method in class javax.swing.DefaultRowSorter
Invoked when rows have been inserted into the underlying model in the specified range (inclusive).
rowsInserted(int, int) - Method in class javax.swing.RowSorter
Invoked when rows have been inserted into the underlying model in the specified range (inclusive).
RowSorter<M> - Class in javax.swing
RowSorter provides the basis for sorting and filtering.
RowSorter() - Constructor for class javax.swing.RowSorter
Creates a RowSorter.
RowSorter.SortKey - Class in javax.swing
SortKey describes the sort order for a particular column.
RowSorterEvent - Class in javax.swing.event
RowSorterEvent provides notification of changes to a RowSorter.
RowSorterEvent(RowSorter) - Constructor for class javax.swing.event.RowSorterEvent
Creates a RowSorterEvent of type SORT_ORDER_CHANGED.
RowSorterEvent(RowSorter, RowSorterEvent.Type, int[]) - Constructor for class javax.swing.event.RowSorterEvent
Creates a RowSorterEvent.
RowSorterEvent.Type - Enum in javax.swing.event
Enumeration of the types of RowSorterEvents.
RowSorterListener - Interface in javax.swing.event
RowSorterListeners are notified of changes to a RowSorter.
ROWSPAN - Static variable in class javax.swing.text.html.HTML.Attribute
rowsRemoved(TableModelEvent) - Method in class javax.swing.table.DefaultTableModel
Equivalent to fireTableChanged.
rowsUpdated(int, int) - Method in class javax.swing.DefaultRowSorter
Invoked when rows have been changed in the underlying model between the specified range (inclusive).
rowsUpdated(int, int, int) - Method in class javax.swing.DefaultRowSorter
Invoked when the column in the rows have been updated in the underlying model between the specified range.
rowsUpdated(int, int) - Method in class javax.swing.RowSorter
Invoked when rows have been changed in the underlying model between the specified range (inclusive).
rowsUpdated(int, int, int) - Method in class javax.swing.RowSorter
Invoked when the column in the rows have been updated in the underlying model between the specified range.
rowUpdated() - Method in interface java.sql.ResultSet
Retrieves whether the current row has been updated.
rowWeights - Variable in class java.awt.GridBagLayout
This field holds the overrides to the row weights.
RSA_SHA1 - Static variable in interface javax.xml.crypto.dsig.SignatureMethod
The RSAwithSHA1 (PKCS #1) signature method algorithm URI.
RSA_TYPE - Static variable in interface javax.xml.crypto.dsig.keyinfo.KeyValue
URI identifying the RSA KeyValue KeyInfo type: http://www.w3.org/2000/09/xmldsig#RSAKeyValue.
RSAKey - Interface in java.security.interfaces
The interface to an RSA public or private key.
RSAKeyGenParameterSpec - Class in java.security.spec
This class specifies the set of parameters used to generate an RSA key pair.
RSAKeyGenParameterSpec(int, BigInteger) - Constructor for class java.security.spec.RSAKeyGenParameterSpec
Constructs a new RSAParameterSpec object from the given keysize and public-exponent value.
RSAMultiPrimePrivateCrtKey - Interface in java.security.interfaces
The interface to an RSA multi-prime private key, as defined in the PKCS#1 v2.1, using the Chinese Remainder Theorem (CRT) information values.
RSAMultiPrimePrivateCrtKeySpec - Class in java.security.spec
This class specifies an RSA multi-prime private key, as defined in the PKCS#1 v2.1, using the Chinese Remainder Theorem (CRT) information values for efficiency.
RSAMultiPrimePrivateCrtKeySpec(BigInteger, BigInteger, BigInteger, BigInteger, BigInteger, BigInteger, BigInteger, BigInteger, RSAOtherPrimeInfo[]) - Constructor for class java.security.spec.RSAMultiPrimePrivateCrtKeySpec
Creates a new RSAMultiPrimePrivateCrtKeySpec given the modulus, publicExponent, privateExponent, primeP, primeQ, primeExponentP, primeExponentQ, crtCoefficient, and otherPrimeInfo as defined in PKCS#1 v2.1.
RSAOtherPrimeInfo - Class in java.security.spec
This class represents the triplet (prime, exponent, and coefficient) inside RSA's OtherPrimeInfo structure, as defined in the PKCS#1 v2.1.
RSAOtherPrimeInfo(BigInteger, BigInteger, BigInteger) - Constructor for class java.security.spec.RSAOtherPrimeInfo
Creates a new RSAOtherPrimeInfo given the prime, primeExponent, and crtCoefficient as defined in PKCS#1.
RSAPrivateCrtKey - Interface in java.security.interfaces
The interface to an RSA private key, as defined in the PKCS#1 standard, using the Chinese Remainder Theorem (CRT) information values.
RSAPrivateCrtKeySpec - Class in java.security.spec
This class specifies an RSA private key, as defined in the PKCS#1 standard, using the Chinese Remainder Theorem (CRT) information values for efficiency.
RSAPrivateCrtKeySpec(BigInteger, BigInteger, BigInteger, BigInteger, BigInteger, BigInteger, BigInteger, BigInteger) - Constructor for class java.security.spec.RSAPrivateCrtKeySpec
Creates a new RSAPrivateCrtKeySpec given the modulus, publicExponent, privateExponent, primeP, primeQ, primeExponentP, primeExponentQ, and crtCoefficient as defined in PKCS#1.
RSAPrivateKey - Interface in java.security.interfaces
The interface to an RSA private key.
RSAPrivateKeySpec - Class in java.security.spec
This class specifies an RSA private key.
RSAPrivateKeySpec(BigInteger, BigInteger) - Constructor for class java.security.spec.RSAPrivateKeySpec
Creates a new RSAPrivateKeySpec.
RSAPublicKey - Interface in java.security.interfaces
The interface to an RSA public key.
RSAPublicKeySpec - Class in java.security.spec
This class specifies an RSA public key.
RSAPublicKeySpec(BigInteger, BigInteger) - Constructor for class java.security.spec.RSAPublicKeySpec
Creates a new RSAPublicKeySpec.
RTFEditorKit - Class in javax.swing.text.rtf
This is the default implementation of RTF editing functionality.
RTFEditorKit() - Constructor for class javax.swing.text.rtf.RTFEditorKit
Constructs an RTFEditorKit.
RuleBasedCollator - Class in java.text
The RuleBasedCollator class is a concrete subclass of Collator that provides a simple, data-driven, table collator.
RuleBasedCollator(String) - Constructor for class java.text.RuleBasedCollator
RuleBasedCollator constructor.
RULER - Static variable in class javax.accessibility.AccessibleRole
A ruler is an object used to measure distance
RUMI_NUMERAL_SYMBOLS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Rumi Numeral Symbols" Unicode character block.
run() - Method in class java.awt.image.renderable.RenderableImageProducer
The runnable method for this class.
run() - Method in interface java.lang.Runnable
When an object implementing interface Runnable is used to create a thread, starting the thread causes the object's run method to be called in that separately executing thread.
run() - Method in class java.lang.Thread
If this thread was constructed using a separate Runnable run object, then that Runnable object's run method is called; otherwise, this method does nothing and returns.
run() - Method in interface java.security.PrivilegedAction
Performs the computation.
run() - Method in interface java.security.PrivilegedExceptionAction
Performs the computation.
run() - Method in class java.util.concurrent.ForkJoinWorkerThread
This method is required to be public, but should never be called explicitly.
run() - Method in class java.util.concurrent.FutureTask
run() - Method in interface java.util.concurrent.RunnableFuture
Sets this Future to the result of its computation unless it has been cancelled.
run() - Method in class java.util.TimerTask
The action to be performed by this timer task.
run() - Method in class javax.swing.SwingWorker
Sets this Future to the result of computation unless it has been cancelled.
run() - Method in class javax.swing.text.AsyncBoxView.ChildState
Update the child state.
run(InputStream, OutputStream, OutputStream, String...) - Method in interface javax.tools.Tool
Run the tool with the given I/O channels and arguments.
run() - Method in class org.omg.CORBA.ORB
This operation blocks the current thread until the ORB has completed the shutdown process, initiated when some thread calls shutdown.
RUN_DIRECTION - Static variable in class java.awt.font.TextAttribute
Attribute key for the run direction of the line.
RUN_DIRECTION_LTR - Static variable in class java.awt.font.TextAttribute
Left-to-right run direction.
RUN_DIRECTION_RTL - Static variable in class java.awt.font.TextAttribute
Right-to-left run direction.
runAfterBoth(CompletionStage<?>, Runnable) - Method in class java.util.concurrent.CompletableFuture
runAfterBoth(CompletionStage<?>, Runnable) - Method in interface java.util.concurrent.CompletionStage
Returns a new CompletionStage that, when this and the other given stage both complete normally, executes the given action.
runAfterBothAsync(CompletionStage<?>, Runnable) - Method in class java.util.concurrent.CompletableFuture
runAfterBothAsync(CompletionStage<?>, Runnable, Executor) - Method in class java.util.concurrent.CompletableFuture
runAfterBothAsync(CompletionStage<?>, Runnable) - Method in interface java.util.concurrent.CompletionStage
Returns a new CompletionStage that, when this and the other given stage complete normally, executes the given action using this stage's default asynchronous execution facility.
runAfterBothAsync(CompletionStage<?>, Runnable, Executor) - Method in interface java.util.concurrent.CompletionStage
Returns a new CompletionStage that, when this and the other given stage complete normally, executes the given action using the supplied executor See the CompletionStage documentation for rules covering exceptional completion.
runAfterEither(CompletionStage<?>, Runnable) - Method in class java.util.concurrent.CompletableFuture
runAfterEither(CompletionStage<?>, Runnable) - Method in interface java.util.concurrent.CompletionStage
Returns a new CompletionStage that, when either this or the other given stage complete normally, executes the given action.
runAfterEitherAsync(CompletionStage<?>, Runnable) - Method in class java.util.concurrent.CompletableFuture
runAfterEitherAsync(CompletionStage<?>, Runnable, Executor) - Method in class java.util.concurrent.CompletableFuture
runAfterEitherAsync(CompletionStage<?>, Runnable) - Method in interface java.util.concurrent.CompletionStage
Returns a new CompletionStage that, when either this or the other given stage complete normally, executes the given action using this stage's default asynchronous execution facility.
runAfterEitherAsync(CompletionStage<?>, Runnable, Executor) - Method in interface java.util.concurrent.CompletionStage
Returns a new CompletionStage that, when either this or the other given stage complete normally, executes the given action using supplied executor.
runAndReset() - Method in class java.util.concurrent.FutureTask
Executes the computation without setting its result, and then resets this future to initial state, failing to do so if the computation encounters an exception or is cancelled.
runAsync(Runnable) - Static method in class java.util.concurrent.CompletableFuture
Returns a new CompletableFuture that is asynchronously completed by a task running in the ForkJoinPool.commonPool() after it runs the given action.
runAsync(Runnable, Executor) - Static method in class java.util.concurrent.CompletableFuture
Returns a new CompletableFuture that is asynchronously completed by a task running in the given executor after it runs the given action.
runCount - Variable in class javax.swing.plaf.basic.BasicTabbedPaneUI
RunElement(Element, AttributeSet, int, int) - Constructor for class javax.swing.text.html.HTMLDocument.RunElement
Constructs an element that represents content within the document (has no children).
runFinalization() - Method in class java.lang.Runtime
Runs the finalization methods of any objects pending finalization.
runFinalization() - Static method in class java.lang.System
Runs the finalization methods of any objects pending finalization.
runFinalizersOnExit(boolean) - Static method in class java.lang.Runtime
Deprecated.
This method is inherently unsafe. It may result in finalizers being called on live objects while other threads are concurrently manipulating those objects, resulting in erratic behavior or deadlock.
runFinalizersOnExit(boolean) - Static method in class java.lang.System
Deprecated.
This method is inherently unsafe. It may result in finalizers being called on live objects while other threads are concurrently manipulating those objects, resulting in erratic behavior or deadlock.
RUNIC - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Runic" Unicode character block.
runnable - Variable in class java.awt.event.InvocationEvent
The Runnable whose run() method will be called.
Runnable - Interface in java.lang
The Runnable interface should be implemented by any class whose instances are intended to be executed by a thread.
RunnableFuture<V> - Interface in java.util.concurrent
A Future that is Runnable.
RunnableScheduledFuture<V> - Interface in java.util.concurrent
A ScheduledFuture that is Runnable.
Runtime - Class in java.lang
Every Java application has a single instance of class Runtime that allows the application to interface with the environment in which the application is running.
RunTime - Interface in org.omg.SendingContext
Defines the base class that represents the Sending Context of a request.
RUNTIME_ERROR - Static variable in class javax.management.monitor.MonitorNotification
Notification type denoting that a non-predefined error type has occurred when trying to get the value of the observed attribute.
RUNTIME_ERROR_NOTIFIED - Static variable in class javax.management.monitor.Monitor
Flag denoting that a notification has occurred after changing the observed object or the observed attribute.
RUNTIME_MXBEAN_NAME - Static variable in class java.lang.management.ManagementFactory
String representation of the ObjectName for the RuntimeMXBean.
RuntimeErrorException - Exception in javax.management
When a java.lang.Error occurs in the agent it should be caught and re-thrown as a RuntimeErrorException.
RuntimeErrorException(Error) - Constructor for exception javax.management.RuntimeErrorException
Default constructor.
RuntimeErrorException(Error, String) - Constructor for exception javax.management.RuntimeErrorException
Constructor that allows a specific error message to be specified.
RuntimeException - Exception in java.lang
RuntimeException is the superclass of those exceptions that can be thrown during the normal operation of the Java Virtual Machine.
RuntimeException() - Constructor for exception java.lang.RuntimeException
Constructs a new runtime exception with null as its detail message.
RuntimeException(String) - Constructor for exception java.lang.RuntimeException
Constructs a new runtime exception with the specified detail message.
RuntimeException(String, Throwable) - Constructor for exception java.lang.RuntimeException
Constructs a new runtime exception with the specified detail message and cause.
RuntimeException(Throwable) - Constructor for exception java.lang.RuntimeException
Constructs a new runtime exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
RuntimeException(String, Throwable, boolean, boolean) - Constructor for exception java.lang.RuntimeException
Constructs a new runtime exception with the specified detail message, cause, suppression enabled or disabled, and writable stack trace enabled or disabled.
RuntimeMBeanException - Exception in javax.management
Represents runtime exceptions thrown by MBean methods in the agent.
RuntimeMBeanException(RuntimeException) - Constructor for exception javax.management.RuntimeMBeanException
Creates a RuntimeMBeanException that wraps the actual java.lang.RuntimeException.
RuntimeMBeanException(RuntimeException, String) - Constructor for exception javax.management.RuntimeMBeanException
Creates a RuntimeMBeanException that wraps the actual java.lang.RuntimeException with a detailed message.
RuntimeMXBean - Interface in java.lang.management
The management interface for the runtime system of the Java virtual machine.
RunTimeOperations - Interface in org.omg.SendingContext
Defines operations on the base class that represents the Sending Context of a request.
RuntimeOperationsException - Exception in javax.management
Represents runtime exceptions thrown in the agent when performing operations on MBeans.
RuntimeOperationsException(RuntimeException) - Constructor for exception javax.management.RuntimeOperationsException
Creates a RuntimeOperationsException that wraps the actual java.lang.RuntimeException.
RuntimeOperationsException(RuntimeException, String) - Constructor for exception javax.management.RuntimeOperationsException
Creates a RuntimeOperationsException that wraps the actual java.lang.RuntimeException with a detailed message.
RuntimePermission - Class in java.lang
This class is for runtime permissions.
RuntimePermission(String) - Constructor for class java.lang.RuntimePermission
Creates a new RuntimePermission with the specified name.
RuntimePermission(String, String) - Constructor for class java.lang.RuntimePermission
Creates a new RuntimePermission object with the specified name.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames


S-Index (Java Platform SE 8 )

Overview

Package

Class

Use

Tree

Deprecated

Index

Help

Java™ Platform
Standard Ed. 8

Prev Letter

Next Letter

Frames

No Frames

All Classes

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
S

S - Static variable in class javax.swing.text.html.HTML.Tag

S_RESIZE_CURSOR - Static variable in class java.awt.Cursor

The south-resize cursor type.

S_RESIZE_CURSOR - Static variable in class java.awt.Frame

Deprecated.
replaced by Cursor.S_RESIZE_CURSOR.

SAAJMetaFactory - Class in javax.xml.soap

The access point for the implementation classes of the factories defined in the SAAJ API.

SAAJMetaFactory() - Constructor for class javax.xml.soap.SAAJMetaFactory

SAAJResult - Class in javax.xml.soap

Acts as a holder for the results of a JAXP transformation or a JAXB marshalling, in the form of a SAAJ tree.

SAAJResult() - Constructor for class javax.xml.soap.SAAJResult

Creates a SAAJResult that will present results in the form of a SAAJ tree that supports the default (SOAP 1.1) protocol.

SAAJResult(String) - Constructor for class javax.xml.soap.SAAJResult

Creates a SAAJResult that will present results in the form of a SAAJ tree that supports the specified protocol.

SAAJResult(SOAPMessage) - Constructor for class javax.xml.soap.SAAJResult

Creates a SAAJResult that will write the results into the SOAPPart of the supplied SOAPMessage.

SAAJResult(SOAPElement) - Constructor for class javax.xml.soap.SAAJResult

Creates a SAAJResult that will write the results as a child node of the SOAPElement specified.

SADDLE_STITCH - Static variable in class javax.print.attribute.standard.Finishings

Bind the document(s) with one or more staples (wire stitches) along the middle fold.

SafeVarargs - Annotation Type in java.lang

A programmer assertion that the body of the annotated method or constructor does not perform potentially unsafe operations on its varargs parameter.

SAMARITAN - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "Samaritan" Unicode character block.

sameFile(URL) - Method in class java.net.URL

Compares two URLs, excluding the fragment component.

sameFile(URL, URL) - Method in class java.net.URLStreamHandler

Compare two urls to see whether they refer to the same file, i.e., having the same protocol, host, port, and path.

SAMP - Static variable in class javax.swing.text.html.HTML.Tag

SAMPLE_RATE - Static variable in class javax.sound.sampled.FloatControl.Type

Represents a control that changes the sample rate of audio playback.

sampleModel - Variable in class java.awt.image.Raster

The SampleModel that describes how pixels from this Raster are stored in the DataBuffer.

SampleModel - Class in java.awt.image

This abstract class defines an interface for extracting samples of pixels in an image.

SampleModel(int, int, int, int) - Constructor for class java.awt.image.SampleModel

Constructs a SampleModel with the specified parameters.

sampleModel - Variable in class javax.imageio.ImageTypeSpecifier

A SampleModel to be used as a prototype.

sampleModelTranslateX - Variable in class java.awt.image.Raster

The X translation from the coordinate space of the Raster's SampleModel to that of the Raster.

sampleModelTranslateY - Variable in class java.awt.image.Raster

The Y translation from the coordinate space of the Raster's SampleModel to that of the Raster.

sampleRate - Variable in class javax.sound.sampled.AudioFormat

The number of samples played or recorded per second, for sounds that have this format.

sampleSizeInBits - Variable in class javax.sound.sampled.AudioFormat

The number of bits in each sample of a sound that has this format.

SANS_SERIF - Static variable in class java.awt.Font

A String constant for the canonical family name of the logical font "SansSerif".

Sasl - Class in javax.security.sasl

A static class for creating SASL clients and servers.

SaslClient - Interface in javax.security.sasl

Performs SASL authentication as a client.

SaslClientFactory - Interface in javax.security.sasl

An interface for creating instances of SaslClient.

SaslException - Exception in javax.security.sasl

This class represents an error that has occurred when using SASL.

SaslException() - Constructor for exception javax.security.sasl.SaslException

Constructs a new instance of SaslException.

SaslException(String) - Constructor for exception javax.security.sasl.SaslException

Constructs a new instance of SaslException with a detailed message.

SaslException(String, Throwable) - Constructor for exception javax.security.sasl.SaslException

Constructs a new instance of SaslException with a detailed message and a root exception.

SaslServer - Interface in javax.security.sasl

Performs SASL authentication as a server.

SaslServerFactory - Interface in javax.security.sasl

An interface for creating instances of SaslServer.

SATURDAY - Static variable in class java.util.Calendar

Value of the Calendar.DAY_OF_WEEK field indicating Saturday.

SAURASHTRA - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "Saurashtra" Unicode character block.

save(ObjectOutputStream, String, EventListener) - Static method in class java.awt.AWTEventMulticaster

SAVE - Static variable in class java.awt.FileDialog

This constant value indicates that the purpose of the file dialog window is to locate a file to which to write.

save(OutputStream, String) - Method in class java.util.Properties

Deprecated.
This method does not throw an IOException if an I/O error occurs while saving the property list. The preferred way to save a properties list is via the store(OutputStream out, String comments) method or the storeToXML(OutputStream os, String comment) method.

SAVE_DIALOG - Static variable in class javax.swing.JFileChooser

Type value indicating that the JFileChooser supports a "Save" file operation.

SAVE_FILE - Static variable in class java.awt.Event

A file saving event.

saveButtonMnemonic - Variable in class javax.swing.plaf.basic.BasicFileChooserUI

saveButtonText - Variable in class javax.swing.plaf.basic.BasicFileChooserUI

saveButtonToolTipText - Variable in class javax.swing.plaf.basic.BasicFileChooserUI

saveChanges() - Method in class javax.xml.soap.SOAPMessage

Updates this SOAPMessage object with all the changes that have been made to it.

saveComposedText(int) - Method in class javax.swing.text.JTextComponent

Saves composed text around the specified position.

saveInternal(ObjectOutputStream, String) - Method in class java.awt.AWTEventMulticaster

Savepoint - Interface in java.sql

The representation of a savepoint, which is a point within the current transaction that can be referenced from the Connection.rollback method.

saveRequired() - Method in class javax.xml.soap.SOAPMessage

Indicates whether this SOAPMessage object needs to have the method saveChanges called on it.

SAXException - Exception in org.xml.sax

Encapsulate a general SAX error or warning.

SAXException() - Constructor for exception org.xml.sax.SAXException

Create a new SAXException.

SAXException(String) - Constructor for exception org.xml.sax.SAXException

Create a new SAXException.

SAXException(Exception) - Constructor for exception org.xml.sax.SAXException

Create a new SAXException wrapping an existing exception.

SAXException(String, Exception) - Constructor for exception org.xml.sax.SAXException

Create a new SAXException from an existing exception.

SAXNotRecognizedException - Exception in org.xml.sax

Exception class for an unrecognized identifier.

SAXNotRecognizedException() - Constructor for exception org.xml.sax.SAXNotRecognizedException

Default constructor.

SAXNotRecognizedException(String) - Constructor for exception org.xml.sax.SAXNotRecognizedException

Construct a new exception with the given message.

SAXNotSupportedException - Exception in org.xml.sax

Exception class for an unsupported operation.

SAXNotSupportedException() - Constructor for exception org.xml.sax.SAXNotSupportedException

Construct a new exception with no message.

SAXNotSupportedException(String) - Constructor for exception org.xml.sax.SAXNotSupportedException

Construct a new exception with the given message.

SAXParseException - Exception in org.xml.sax

Encapsulate an XML parse error or warning.

SAXParseException(String, Locator) - Constructor for exception org.xml.sax.SAXParseException

Create a new SAXParseException from a message and a Locator.

SAXParseException(String, Locator, Exception) - Constructor for exception org.xml.sax.SAXParseException

Wrap an existing exception in a SAXParseException.

SAXParseException(String, String, String, int, int) - Constructor for exception org.xml.sax.SAXParseException

Create a new SAXParseException.

SAXParseException(String, String, String, int, int, Exception) - Constructor for exception org.xml.sax.SAXParseException

Create a new SAXParseException with an embedded exception.

SAXParser - Class in javax.xml.parsers

Defines the API that wraps an XMLReader implementation class.

SAXParser() - Constructor for class javax.xml.parsers.SAXParser

Protected constructor to prevent instaniation.

SAXParserFactory - Class in javax.xml.parsers

Defines a factory API that enables applications to configure and obtain a SAX based parser to parse XML documents.

SAXParserFactory() - Constructor for class javax.xml.parsers.SAXParserFactory

Protected constructor to force use of SAXParserFactory.newInstance().

SAXResult - Class in javax.xml.transform.sax

Acts as an holder for a transformation Result.

SAXResult() - Constructor for class javax.xml.transform.sax.SAXResult

Zero-argument default constructor.

SAXResult(ContentHandler) - Constructor for class javax.xml.transform.sax.SAXResult

Create a SAXResult that targets a SAX2 ContentHandler.

SAXSource - Class in javax.xml.transform.sax

Acts as an holder for SAX-style Source.

SAXSource() - Constructor for class javax.xml.transform.sax.SAXSource

Zero-argument default constructor.

SAXSource(XMLReader, InputSource) - Constructor for class javax.xml.transform.sax.SAXSource

Create a SAXSource, using an XMLReader and a SAX InputSource.

SAXSource(InputSource) - Constructor for class javax.xml.transform.sax.SAXSource

Create a SAXSource, using a SAX InputSource.

SAXTransformerFactory - Class in javax.xml.transform.sax

This class extends TransformerFactory to provide SAX-specific factory methods.

SAXTransformerFactory() - Constructor for class javax.xml.transform.sax.SAXTransformerFactory

The default constructor is protected on purpose.

SC_BLOCK_DATA - Static variable in interface java.io.ObjectStreamConstants

Bit mask for ObjectStreamClass flag.

SC_ENUM - Static variable in interface java.io.ObjectStreamConstants

Bit mask for ObjectStreamClass flag.

SC_EXTERNALIZABLE - Static variable in interface java.io.ObjectStreamConstants

Bit mask for ObjectStreamClass flag.

SC_SERIALIZABLE - Static variable in interface java.io.ObjectStreamConstants

Bit mask for ObjectStreamClass flag.

SC_WRITE_METHOD - Static variable in interface java.io.ObjectStreamConstants

Bit mask for ObjectStreamClass flag.

scalb(double, int) - Static method in class java.lang.Math

Returns d × 2scaleFactor rounded as if performed by a single correctly rounded floating-point multiply to a member of the double value set.

scalb(float, int) - Static method in class java.lang.Math

Returns f × 2scaleFactor rounded as if performed by a single correctly rounded floating-point multiply to a member of the float value set.

scalb(double, int) - Static method in class java.lang.StrictMath

Returns d × 2scaleFactor rounded as if performed by a single correctly rounded floating-point multiply to a member of the double value set.

scalb(float, int) - Static method in class java.lang.StrictMath

Returns f × 2scaleFactor rounded as if performed by a single correctly rounded floating-point multiply to a member of the float value set.

scale(double, double) - Method in class java.awt.geom.AffineTransform

Concatenates this transform with a scaling transformation.

scale(double, double) - Method in class java.awt.Graphics2D

Concatenates the current Graphics2D Transform with a scaling transformation Subsequent rendering is resized according to the specified scaling factors relative to the previous scaling.

scale() - Method in class java.math.BigDecimal

Returns the scale of this BigDecimal.

scale(Spring, float) - Static method in class javax.swing.Spring

Returns a spring whose minimum, preferred, maximum and value properties are each multiples of the properties of the argument spring, s.

SCALE_AREA_AVERAGING - Static variable in class java.awt.Image

Use the Area Averaging image scaling algorithm.

SCALE_DEFAULT - Static variable in class java.awt.Image

Use the default image-scaling algorithm.

SCALE_FAST - Static variable in class java.awt.Image

Choose an image-scaling algorithm that gives higher priority to scaling speed than smoothness of the scaled image.

SCALE_REPLICATE - Static variable in class java.awt.Image

Use the image scaling algorithm embodied in the ReplicateScaleFilter class.

SCALE_SMOOTH - Static variable in class java.awt.Image

Choose an image-scaling algorithm that gives higher priority to image smoothness than scaling speed.

scaleByPowerOfTen(int) - Method in class java.math.BigDecimal

Returns a BigDecimal whose numerical value is equal to (this * 10n).

scan(Iterable<? extends Element>, P) - Method in class javax.lang.model.util.ElementScanner6

Iterates over the given elements and calls scan(Element, P) on each one.

scan(Element, P) - Method in class javax.lang.model.util.ElementScanner6

Processes an element by calling e.accept(this, p); this method may be overridden by subclasses.

scan(Element) - Method in class javax.lang.model.util.ElementScanner6

Convenience method equivalent to v.scan(e, null).

scanForPlugins() - Static method in class javax.imageio.ImageIO

Scans for plug-ins on the application class path, loads their service provider classes, and registers a service provider instance for each one found with the IIORegistry.

scanlineStride - Variable in class java.awt.image.ComponentSampleModel

Line stride (in data array elements) of the region of image data described by this ComponentSampleModel.

Scanner - Class in java.util

A simple text scanner which can parse primitive types and strings using regular expressions.

Scanner(Readable) - Constructor for class java.util.Scanner

Constructs a new Scanner that produces values scanned from the specified source.

Scanner(InputStream) - Constructor for class java.util.Scanner

Constructs a new Scanner that produces values scanned from the specified input stream.

Scanner(InputStream, String) - Constructor for class java.util.Scanner

Constructs a new Scanner that produces values scanned from the specified input stream.

Scanner(File) - Constructor for class java.util.Scanner

Constructs a new Scanner that produces values scanned from the specified file.

Scanner(File, String) - Constructor for class java.util.Scanner

Constructs a new Scanner that produces values scanned from the specified file.

Scanner(Path) - Constructor for class java.util.Scanner

Constructs a new Scanner that produces values scanned from the specified file.

Scanner(Path, String) - Constructor for class java.util.Scanner

Constructs a new Scanner that produces values scanned from the specified file.

Scanner(String) - Constructor for class java.util.Scanner

Constructs a new Scanner that produces values scanned from the specified string.

Scanner(ReadableByteChannel) - Constructor for class java.util.Scanner

Constructs a new Scanner that produces values scanned from the specified channel.

Scanner(ReadableByteChannel, String) - Constructor for class java.util.Scanner

Constructs a new Scanner that produces values scanned from the specified channel.

ScatteringByteChannel - Interface in java.nio.channels

A channel that can read bytes into a sequence of buffers.

schedule(Runnable, long, TimeUnit) - Method in interface java.util.concurrent.ScheduledExecutorService

Creates and executes a one-shot action that becomes enabled after the given delay.

schedule(Callable<V>, long, TimeUnit) - Method in interface java.util.concurrent.ScheduledExecutorService

Creates and executes a ScheduledFuture that becomes enabled after the given delay.

schedule(Runnable, long, TimeUnit) - Method in class java.util.concurrent.ScheduledThreadPoolExecutor

schedule(Callable<V>, long, TimeUnit) - Method in class java.util.concurrent.ScheduledThreadPoolExecutor

schedule(TimerTask, long) - Method in class java.util.Timer

Schedules the specified task for execution after the specified delay.

schedule(TimerTask, Date) - Method in class java.util.Timer

Schedules the specified task for execution at the specified time.

schedule(TimerTask, long, long) - Method in class java.util.Timer

Schedules the specified task for repeated fixed-delay execution, beginning after the specified delay.

schedule(TimerTask, Date, long) - Method in class java.util.Timer

Schedules the specified task for repeated fixed-delay execution, beginning at the specified time.

scheduleAtFixedRate(Runnable, long, long, TimeUnit) - Method in interface java.util.concurrent.ScheduledExecutorService

Creates and executes a periodic action that becomes enabled first after the given initial delay, and subsequently with the given period; that is executions will commence after initialDelay then initialDelay+period, then initialDelay + 2 * period, and so on.

scheduleAtFixedRate(Runnable, long, long, TimeUnit) - Method in class java.util.concurrent.ScheduledThreadPoolExecutor

scheduleAtFixedRate(TimerTask, long, long) - Method in class java.util.Timer

Schedules the specified task for repeated fixed-rate execution, beginning after the specified delay.

scheduleAtFixedRate(TimerTask, Date, long) - Method in class java.util.Timer

Schedules the specified task for repeated fixed-rate execution, beginning at the specified time.

scheduledExecutionTime() - Method in class java.util.TimerTask

Returns the scheduled execution time of the most recent actual execution of this task.

ScheduledExecutorService - Interface in java.util.concurrent

An ExecutorService that can schedule commands to run after a given delay, or to execute periodically.

ScheduledFuture<V> - Interface in java.util.concurrent

A delayed result-bearing action that can be cancelled.

ScheduledThreadPoolExecutor - Class in java.util.concurrent

A ThreadPoolExecutor that can additionally schedule commands to run after a given delay, or to execute periodically.

ScheduledThreadPoolExecutor(int) - Constructor for class java.util.concurrent.ScheduledThreadPoolExecutor

Creates a new ScheduledThreadPoolExecutor with the given core pool size.

ScheduledThreadPoolExecutor(int, ThreadFactory) - Constructor for class java.util.concurrent.ScheduledThreadPoolExecutor

Creates a new ScheduledThreadPoolExecutor with the given initial parameters.

ScheduledThreadPoolExecutor(int, RejectedExecutionHandler) - Constructor for class java.util.concurrent.ScheduledThreadPoolExecutor

Creates a new ScheduledThreadPoolExecutor with the given initial parameters.

ScheduledThreadPoolExecutor(int, ThreadFactory, RejectedExecutionHandler) - Constructor for class java.util.concurrent.ScheduledThreadPoolExecutor

Creates a new ScheduledThreadPoolExecutor with the given initial parameters.

scheduleWithFixedDelay(Runnable, long, long, TimeUnit) - Method in interface java.util.concurrent.ScheduledExecutorService

Creates and executes a periodic action that becomes enabled first after the given initial delay, and subsequently with the given delay between the termination of one execution and the commencement of the next.

scheduleWithFixedDelay(Runnable, long, long, TimeUnit) - Method in class java.util.concurrent.ScheduledThreadPoolExecutor

Schema - Class in javax.xml.validation

Immutable in-memory representation of grammar.

Schema() - Constructor for class javax.xml.validation.Schema

Constructor for the derived class.

SCHEMA_SYSTEM_ID - Static variable in interface javax.sql.rowset.WebRowSet

The URL for the XML Schema definition file that defines the XML tags and their valid values for a WebRowSet implementation.

SchemaFactory - Class in javax.xml.validation

Factory that creates Schema objects. Entry-point to the validation API.

SchemaFactory() - Constructor for class javax.xml.validation.SchemaFactory

Constructor for derived classes.

SchemaFactoryConfigurationError - Error in javax.xml.validation

Thrown when a problem with configuration with the Schema Factories exists.

SchemaFactoryConfigurationError() - Constructor for error javax.xml.validation.SchemaFactoryConfigurationError

Create a new SchemaFactoryConfigurationError with no detail message.

SchemaFactoryConfigurationError(String) - Constructor for error javax.xml.validation.SchemaFactoryConfigurationError

Create a new SchemaFactoryConfigurationError with the String specified as an error message.

SchemaFactoryConfigurationError(Throwable) - Constructor for error javax.xml.validation.SchemaFactoryConfigurationError

Create a new SchemaFactoryConfigurationError with the given Throwable base cause.

SchemaFactoryConfigurationError(String, Throwable) - Constructor for error javax.xml.validation.SchemaFactoryConfigurationError

Create a new SchemaFactoryConfigurationError with the given Throwable base cause and detail message.

SchemaFactoryLoader - Class in javax.xml.validation

Factory that creates SchemaFactory.

SchemaFactoryLoader() - Constructor for class javax.xml.validation.SchemaFactoryLoader

A do-nothing constructor.

SchemaOutputResolver - Class in javax.xml.bind

Controls where a JAXB implementation puts the generates schema files.

SchemaOutputResolver() - Constructor for class javax.xml.bind.SchemaOutputResolver

SchemaViolationException - Exception in javax.naming.directory

This exception is thrown when a method in some ways violates the schema.

SchemaViolationException() - Constructor for exception javax.naming.directory.SchemaViolationException

Constructs a new instance of SchemaViolationException.

SchemaViolationException(String) - Constructor for exception javax.naming.directory.SchemaViolationException

Constructs a new instance of SchemaViolationException using the explanation supplied.

scope - Variable in class javax.xml.bind.JAXBElement

Scope of xml element declaration representing this xml element instance.

SCRIPT - Static variable in class javax.swing.text.html.HTML.Tag

ScriptContext - Interface in javax.script

The interface whose implementing classes are used to connect Script Engines with objects, such as scoped Bindings, in hosting applications.

ScriptEngine - Interface in javax.script

ScriptEngine is the fundamental interface whose methods must be fully functional in every implementation of this specification.

ScriptEngineFactory - Interface in javax.script

ScriptEngineFactory is used to describe and instantiate ScriptEngines.

ScriptEngineManager - Class in javax.script

The ScriptEngineManager implements a discovery and instantiation mechanism for ScriptEngine classes and also maintains a collection of key/value pairs storing state shared by all engines created by the Manager.

ScriptEngineManager() - Constructor for class javax.script.ScriptEngineManager

The effect of calling this constructor is the same as calling ScriptEngineManager(Thread.currentThread().getContextClassLoader()).

ScriptEngineManager(ClassLoader) - Constructor for class javax.script.ScriptEngineManager

This constructor loads the implementations of ScriptEngineFactory visible to the given ClassLoader using the service provider mechanism.

If loader is null, the script engine factories that are bundled with the platform and that are in the usual extension directories (installed extensions) are loaded.

ScriptException - Exception in javax.script

The generic Exception class for the Scripting APIs.

ScriptException(String) - Constructor for exception javax.script.ScriptException

Creates a ScriptException with a String to be used in its message.

ScriptException(Exception) - Constructor for exception javax.script.ScriptException

Creates a ScriptException wrapping an Exception thrown by an underlying interpreter.

ScriptException(String, String, int) - Constructor for exception javax.script.ScriptException

Creates a ScriptException with message, filename and linenumber to be used in error messages.

ScriptException(String, String, int, int) - Constructor for exception javax.script.ScriptException

ScriptException constructor specifying message, filename, line number and column number.

SCROLL_ABSOLUTE - Static variable in class java.awt.Event

The user has moved the bubble (thumb) in a scroll bar, moving to an "absolute" position, rather than to an offset from the last position.

SCROLL_BAR - Static variable in class javax.accessibility.AccessibleRole

An object usually used to allow a user to incrementally view a large amount of data.

SCROLL_BAR - Static variable in class javax.swing.plaf.synth.Region

ScrollBar region.

SCROLL_BAR_THUMB - Static variable in class javax.swing.plaf.synth.Region

Thumb of the ScrollBar.

SCROLL_BAR_TRACK - Static variable in class javax.swing.plaf.synth.Region

Track of the ScrollBar.

SCROLL_BEGIN - Static variable in class java.awt.Event

The scroll begin event.

SCROLL_DOWN - Static variable in class javax.swing.plaf.basic.BasicComboPopup

SCROLL_END - Static variable in class java.awt.Event

The scroll end event.

SCROLL_LINE_DOWN - Static variable in class java.awt.Event

The user has activated the line down area of a scroll bar.

SCROLL_LINE_UP - Static variable in class java.awt.Event

The user has activated the line up area of a scroll bar.

SCROLL_LOCK - Static variable in class java.awt.Event

The Scroll Lock key, a non-ASCII action key.

SCROLL_PAGE_DOWN - Static variable in class java.awt.Event

The user has activated the page down area of a scroll bar.

SCROLL_PAGE_UP - Static variable in class java.awt.Event

The user has activated the page up area of a scroll bar.

SCROLL_PANE - Static variable in class javax.accessibility.AccessibleRole

An object that allows a user to incrementally view a large amount of information.

SCROLL_PANE - Static variable in class javax.swing.plaf.synth.Region

ScrollPane region.

SCROLL_TAB_LAYOUT - Static variable in class javax.swing.JTabbedPane

Tab layout policy for providing a subset of available tabs when all the tabs will not fit within a single run.

SCROLL_UP - Static variable in class javax.swing.plaf.basic.BasicComboPopup

Scrollable - Interface in javax.swing

An interface that provides information to a scrolling container like JScrollPane.

Scrollbar - Class in java.awt

The Scrollbar class embodies a scroll bar, a familiar user-interface object.

Scrollbar() - Constructor for class java.awt.Scrollbar

Constructs a new vertical scroll bar.

Scrollbar(int) - Constructor for class java.awt.Scrollbar

Constructs a new scroll bar with the specified orientation.

Scrollbar(int, int, int, int, int) - Constructor for class java.awt.Scrollbar

Constructs a new scroll bar with the specified orientation, initial value, visible amount, and minimum and maximum values.

SCROLLBAR - Static variable in class java.awt.SystemColor

The array index for the SystemColor.scrollbar system color.

scrollbar - Static variable in class java.awt.SystemColor

The color rendered for the background of scrollbars.

ScrollBar(int) - Constructor for class javax.swing.JScrollPane.ScrollBar

Creates a scrollbar with the specified orientation.

scrollbar - Variable in class javax.swing.plaf.basic.BasicScrollBarUI

scrollBar - Variable in class javax.swing.plaf.basic.BasicTreeUI.ComponentHandler

ScrollBar that is being adjusted.

Scrollbar.AccessibleAWTScrollBar - Class in java.awt

This class implements accessibility support for the Scrollbar class.

SCROLLBARS_ALWAYS - Static variable in class java.awt.ScrollPane

Specifies that horizontal/vertical scrollbars should always be shown regardless of the respective sizes of the scrollpane and child.

SCROLLBARS_AS_NEEDED - Static variable in class java.awt.ScrollPane

Specifies that horizontal/vertical scrollbar should be shown only when the size of the child exceeds the size of the scrollpane in the horizontal/vertical dimension.

SCROLLBARS_BOTH - Static variable in class java.awt.TextArea

Create and display both vertical and horizontal scrollbars.

SCROLLBARS_HORIZONTAL_ONLY - Static variable in class java.awt.TextArea

Create and display horizontal scrollbar only.

SCROLLBARS_NEVER - Static variable in class java.awt.ScrollPane

Specifies that horizontal/vertical scrollbars should never be shown regardless of the respective sizes of the scrollpane and child.

SCROLLBARS_NONE - Static variable in class java.awt.TextArea

Do not create or display any scrollbars for the text area.

SCROLLBARS_VERTICAL_ONLY - Static variable in class java.awt.TextArea

Create and display vertical scrollbar only.

ScrollBarUI - Class in javax.swing.plaf

Pluggable look and feel interface for JScrollBar.

ScrollBarUI() - Constructor for class javax.swing.plaf.ScrollBarUI

scrollBarWidth - Variable in class javax.swing.plaf.basic.BasicScrollBarUI

Hint as to what width (when vertical) or height (when horizontal) should be.

scrollBarWidth - Variable in class javax.swing.plaf.metal.MetalScrollBarUI

scrollByBlock(int) - Method in class javax.swing.plaf.basic.BasicScrollBarUI

scrollByBlock(int) - Method in class javax.swing.plaf.basic.BasicSliderUI

scrollByUnit(int) - Method in class javax.swing.plaf.basic.BasicScrollBarUI

scrollByUnit(int) - Method in class javax.swing.plaf.basic.BasicSliderUI

scrollDirection - Variable in class javax.swing.plaf.basic.BasicComboPopup

scrollDueToClickInTrack(int) - Method in class javax.swing.plaf.basic.BasicSliderUI

This function is called when a mousePressed was detected in the track, not in the thumb.

scrollDueToClickInTrack(int) - Method in class javax.swing.plaf.metal.MetalSliderUI

scroller - Variable in class javax.swing.plaf.basic.BasicComboPopup

This protected field is implementation specific.

SCROLLING - Static variable in class javax.swing.text.html.HTML.Attribute

scrollListener - Variable in class javax.swing.plaf.basic.BasicScrollBarUI

ScrollListener() - Constructor for class javax.swing.plaf.basic.BasicScrollBarUI.ScrollListener

ScrollListener(int, boolean) - Constructor for class javax.swing.plaf.basic.BasicScrollBarUI.ScrollListener

scrollListener - Variable in class javax.swing.plaf.basic.BasicSliderUI

ScrollListener() - Constructor for class javax.swing.plaf.basic.BasicSliderUI.ScrollListener

ScrollListener(int, boolean) - Constructor for class javax.swing.plaf.basic.BasicSliderUI.ScrollListener

ScrollPane - Class in java.awt

A container class which implements automatic horizontal and/or vertical scrolling for a single child component.

ScrollPane() - Constructor for class java.awt.ScrollPane

Create a new scrollpane container with a scrollbar display policy of "as needed".

ScrollPane(int) - Constructor for class java.awt.ScrollPane

Create a new scrollpane container.

scrollpane - Variable in class javax.swing.plaf.basic.BasicScrollPaneUI

ScrollPane.AccessibleAWTScrollPane - Class in java.awt

This class implements accessibility support for the ScrollPane class.

ScrollPaneAdjustable - Class in java.awt

This class represents the state of a horizontal or vertical scrollbar of a ScrollPane.

ScrollPaneBorder() - Constructor for class javax.swing.plaf.metal.MetalBorders.ScrollPaneBorder

ScrollPaneConstants - Interface in javax.swing

Constants used with the JScrollPane component.

ScrollPaneLayout - Class in javax.swing

The layout manager used by JScrollPane.

ScrollPaneLayout() - Constructor for class javax.swing.ScrollPaneLayout

ScrollPaneLayout.UIResource - Class in javax.swing

The UI resource version of ScrollPaneLayout.

ScrollPaneUI - Class in javax.swing.plaf

Pluggable look and feel interface for JScrollPane.

ScrollPaneUI() - Constructor for class javax.swing.plaf.ScrollPaneUI

scrollPathToVisible(TreePath) - Method in class javax.swing.JTree

Makes sure all the path components in path are expanded (except for the last path component) and scrolls so that the node identified by the path is displayed.

scrollRectToVisible(Rectangle) - Method in class javax.swing.JComponent

Forwards the scrollRectToVisible() message to the JComponent's parent.

scrollRectToVisible(Rectangle) - Method in class javax.swing.JTextField

Scrolls the field left or right.

scrollRectToVisible(Rectangle) - Method in class javax.swing.JViewport

Scrolls the view so that Rectangle within the view becomes visible.

scrollRowToVisible(int) - Method in class javax.swing.JTree

Scrolls the item identified by row until it is displayed.

SCROLLS_ON_EXPAND_PROPERTY - Static variable in class javax.swing.JTree

Bound property name for scrollsOnExpand.

scrollsOnExpand - Variable in class javax.swing.JTree

If true, when a node is expanded, as many of the descendants are scrolled to be visible.

scrollTimer - Variable in class javax.swing.plaf.basic.BasicScrollBarUI

scrollTimer - Variable in class javax.swing.plaf.basic.BasicSliderUI

scrollToReference(String) - Method in class javax.swing.JEditorPane

Scrolls the view to the given reference location (that is, the value returned by the UL.getRef method for the URL being displayed).

scrollUnderway - Variable in class javax.swing.JViewport

The scrollUnderway flag is used for components like JList.

SDATA - Static variable in interface javax.swing.text.html.parser.DTDConstants

SE_RESIZE_CURSOR - Static variable in class java.awt.Cursor

The south-east-resize cursor type.

SE_RESIZE_CURSOR - Static variable in class java.awt.Frame

Deprecated.
replaced by Cursor.SE_RESIZE_CURSOR.

SEALED - Static variable in class java.util.jar.Attributes.Name

Name object for Sealed manifest attribute used for sealing.

SealedObject - Class in javax.crypto

This class enables a programmer to create an object and protect its confidentiality with a cryptographic algorithm.

SealedObject(Serializable, Cipher) - Constructor for class javax.crypto.SealedObject

Constructs a SealedObject from any Serializable object.

SealedObject(SealedObject) - Constructor for class javax.crypto.SealedObject

Constructs a SealedObject object from the passed-in SealedObject.

search(long, BiFunction<? super K, ? super V, ? extends U>) - Method in class java.util.concurrent.ConcurrentHashMap

Returns a non-null result from applying the given search function on each (key, value), or null if none.

search(Object) - Method in class java.util.Stack

Returns the 1-based position where an object is on this stack.

search(Name, Attributes, String[]) - Method in interface javax.naming.directory.DirContext

Searches in a single context for objects that contain a specified set of attributes, and retrieves selected attributes.

search(String, Attributes, String[]) - Method in interface javax.naming.directory.DirContext

Searches in a single context for objects that contain a specified set of attributes, and retrieves selected attributes.

search(Name, Attributes) - Method in interface javax.naming.directory.DirContext

Searches in a single context for objects that contain a specified set of attributes.

search(String, Attributes) - Method in interface javax.naming.directory.DirContext

Searches in a single context for objects that contain a specified set of attributes.

search(Name, String, SearchControls) - Method in interface javax.naming.directory.DirContext

Searches in the named context or object for entries that satisfy the given search filter.

search(String, String, SearchControls) - Method in interface javax.naming.directory.DirContext

Searches in the named context or object for entries that satisfy the given search filter.

search(Name, String, Object[], SearchControls) - Method in interface javax.naming.directory.DirContext

Searches in the named context or object for entries that satisfy the given search filter.

search(String, String, Object[], SearchControls) - Method in interface javax.naming.directory.DirContext

Searches in the named context or object for entries that satisfy the given search filter.

search(String, Attributes) - Method in class javax.naming.directory.InitialDirContext

search(Name, Attributes) - Method in class javax.naming.directory.InitialDirContext

search(String, Attributes, String[]) - Method in class javax.naming.directory.InitialDirContext

search(Name, Attributes, String[]) - Method in class javax.naming.directory.InitialDirContext

search(String, String, SearchControls) - Method in class javax.naming.directory.InitialDirContext

search(Name, String, SearchControls) - Method in class javax.naming.directory.InitialDirContext

search(String, String, Object[], SearchControls) - Method in class javax.naming.directory.InitialDirContext

search(Name, String, Object[], SearchControls) - Method in class javax.naming.directory.InitialDirContext

SearchControls - Class in javax.naming.directory

This class encapsulates factors that determine scope of search and what gets returned as a result of the search.

SearchControls() - Constructor for class javax.naming.directory.SearchControls

Constructs a search constraints using defaults.

SearchControls(int, long, int, String[], boolean, boolean) - Constructor for class javax.naming.directory.SearchControls

Constructs a search constraints using arguments.

searchEntries(long, Function<Map.Entry<K, V>, ? extends U>) - Method in class java.util.concurrent.ConcurrentHashMap

Returns a non-null result from applying the given search function on each entry, or null if none.

searchKeys(long, Function<? super K, ? extends U>) - Method in class java.util.concurrent.ConcurrentHashMap

Returns a non-null result from applying the given search function on each key, or null if none.

SearchResult - Class in javax.naming.directory

This class represents an item in the NamingEnumeration returned as a result of the DirContext.search() methods.

SearchResult(String, Object, Attributes) - Constructor for class javax.naming.directory.SearchResult

Constructs a search result using the result's name, its bound object, and its attributes.

SearchResult(String, Object, Attributes, boolean) - Constructor for class javax.naming.directory.SearchResult

Constructs a search result using the result's name, its bound object, and its attributes, and whether the name is relative.

SearchResult(String, String, Object, Attributes) - Constructor for class javax.naming.directory.SearchResult

Constructs a search result using the result's name, its class name, its bound object, and its attributes.

SearchResult(String, String, Object, Attributes, boolean) - Constructor for class javax.naming.directory.SearchResult

Constructs a search result using the result's name, its class name, its bound object, its attributes, and whether the name is relative.

searchValues(long, Function<? super V, ? extends U>) - Method in class java.util.concurrent.ConcurrentHashMap

Returns a non-null result from applying the given search function on each value, or null if none.

SECOND - Static variable in class java.text.DateFormat.Field

Constant identifying the second field.

SECOND - Static variable in class java.util.Calendar

Field number for get and set indicating the second within the minute.

SECOND_FIELD - Static variable in class java.text.DateFormat

Useful constant for SECOND field alignment.

SECONDARY - Static variable in class java.text.Collator

Collator strength value.

SecondaryLoop - Interface in java.awt

A helper interface to run the nested event loop.

secondaryOrder(int) - Static method in class java.text.CollationElementIterator

Return the secondary component of a collation element.

SECONDS - Static variable in class javax.xml.datatype.DatatypeConstants

A constant that represents the seconds field.

SECRET_KEY - Static variable in class javax.crypto.Cipher

Constant used to indicate the to-be-unwrapped key is a "secret key".

SecretKey - Interface in javax.crypto

A secret (symmetric) key.

SecretKeyEntry(SecretKey) - Constructor for class java.security.KeyStore.SecretKeyEntry

Constructs a SecretKeyEntry with a SecretKey.

SecretKeyEntry(SecretKey, Set<KeyStore.Entry.Attribute>) - Constructor for class java.security.KeyStore.SecretKeyEntry

Constructs a SecretKeyEntry with a SecretKey and associated entry attributes.

SecretKeyFactory - Class in javax.crypto

This class represents a factory for secret keys.

SecretKeyFactory(SecretKeyFactorySpi, Provider, String) - Constructor for class javax.crypto.SecretKeyFactory

Creates a SecretKeyFactory object.

SecretKeyFactorySpi - Class in javax.crypto

This class defines the Service Provider Interface (SPI) for the SecretKeyFactory class.

SecretKeyFactorySpi() - Constructor for class javax.crypto.SecretKeyFactorySpi

SecretKeySpec - Class in javax.crypto.spec

This class specifies a secret key in a provider-independent fashion.

SecretKeySpec(byte[], String) - Constructor for class javax.crypto.spec.SecretKeySpec

Constructs a secret key from the given byte array.

SecretKeySpec(byte[], int, int, String) - Constructor for class javax.crypto.spec.SecretKeySpec

Constructs a secret key from the given byte array, using the first len bytes of key, starting at offset inclusive.

SectionElement() - Constructor for class javax.swing.text.DefaultStyledDocument.SectionElement

Creates a new SectionElement.

SectionElementName - Static variable in class javax.swing.text.AbstractDocument

Name of elements used to hold sections (lines/paragraphs).

SecureCacheResponse - Class in java.net

Represents a cache response originally retrieved through secure means, such as TLS.

SecureCacheResponse() - Constructor for class java.net.SecureCacheResponse

SecureClassLoader - Class in java.security

This class extends ClassLoader with additional support for defining classes with an associated code source and permissions which are retrieved by the system policy by default.

SecureClassLoader(ClassLoader) - Constructor for class java.security.SecureClassLoader

Creates a new SecureClassLoader using the specified parent class loader for delegation.

SecureClassLoader() - Constructor for class java.security.SecureClassLoader

Creates a new SecureClassLoader using the default parent class loader for delegation.

SecureDirectoryStream<T> - Interface in java.nio.file

A DirectoryStream that defines operations on files that are located relative to an open directory.

SecureRandom - Class in java.security

This class provides a cryptographically strong random number generator (RNG).

SecureRandom() - Constructor for class java.security.SecureRandom

Constructs a secure random number generator (RNG) implementing the default random number algorithm.

SecureRandom(byte[]) - Constructor for class java.security.SecureRandom

Constructs a secure random number generator (RNG) implementing the default random number algorithm.

SecureRandom(SecureRandomSpi, Provider) - Constructor for class java.security.SecureRandom

Creates a SecureRandom object.

SecureRandomSpi - Class in java.security

This class defines the Service Provider Interface (SPI) for the SecureRandom class.

SecureRandomSpi() - Constructor for class java.security.SecureRandomSpi

Security - Class in java.security

This class centralizes all security properties and common security methods.

SECURITY_AUTHENTICATION - Static variable in interface javax.naming.Context

Constant that holds the name of the environment property for specifying the security level to use.

SECURITY_CREDENTIALS - Static variable in interface javax.naming.Context

Constant that holds the name of the environment property for specifying the credentials of the principal for authenticating the caller to the service.

SECURITY_PRINCIPAL - Static variable in interface javax.naming.Context

Constant that holds the name of the environment property for specifying the identity of the principal for authenticating the caller to the service.

SECURITY_PROTOCOL - Static variable in interface javax.naming.Context

Constant that holds the name of the environment property for specifying the security protocol to use.

SecurityException - Exception in java.lang

Thrown by the security manager to indicate a security violation.

SecurityException() - Constructor for exception java.lang.SecurityException

Constructs a SecurityException with no detail message.

SecurityException(String) - Constructor for exception java.lang.SecurityException

Constructs a SecurityException with the specified detail message.

SecurityException(String, Throwable) - Constructor for exception java.lang.SecurityException

Creates a SecurityException with the specified detail message and cause.

SecurityException(Throwable) - Constructor for exception java.lang.SecurityException

Creates a SecurityException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

SecurityManager - Class in java.lang

The security manager is a class that allows applications to implement a security policy.

SecurityManager() - Constructor for class java.lang.SecurityManager

Constructs a new SecurityManager.

SecurityPermission - Class in java.security

This class is for security permissions.

SecurityPermission(String) - Constructor for class java.security.SecurityPermission

Creates a new SecurityPermission with the specified name.

SecurityPermission(String, String) - Constructor for class java.security.SecurityPermission

Creates a new SecurityPermission object with the specified name.

seek(long) - Method in class java.io.RandomAccessFile

Sets the file-pointer offset, measured from the beginning of this file, at which the next read or write occurs.

seek(long) - Method in class javax.imageio.stream.FileCacheImageOutputStream

Sets the current stream position and resets the bit offset to 0.

seek(long) - Method in class javax.imageio.stream.FileImageInputStream

seek(long) - Method in class javax.imageio.stream.FileImageOutputStream

Sets the current stream position and resets the bit offset to 0.

seek(long) - Method in interface javax.imageio.stream.ImageInputStream

Sets the current stream position to the desired location.

seek(long) - Method in class javax.imageio.stream.ImageInputStreamImpl

seek(int) - Method in interface org.omg.CORBA.DynAny

Deprecated.

Moves the internal pointer to the given index.

seek(int) - Method in class org.omg.DynamicAny._DynAnyStub

Sets the current position to index.

seek(int) - Method in class org.omg.DynamicAny._DynArrayStub

Sets the current position to index.

seek(int) - Method in class org.omg.DynamicAny._DynEnumStub

Sets the current position to index.

seek(int) - Method in class org.omg.DynamicAny._DynFixedStub

Sets the current position to index.

seek(int) - Method in class org.omg.DynamicAny._DynSequenceStub

Sets the current position to index.

seek(int) - Method in class org.omg.DynamicAny._DynStructStub

Sets the current position to index.

seek(int) - Method in class org.omg.DynamicAny._DynUnionStub

Sets the current position to index.

seek(int) - Method in class org.omg.DynamicAny._DynValueStub

Sets the current position to index.

seek(int) - Method in interface org.omg.DynamicAny.DynAnyOperations

Sets the current position to index.

SeekableByteChannel - Interface in java.nio.channels

A byte channel that maintains a current position and allows the position to be changed.

seekForwardOnly - Variable in class javax.imageio.ImageReader

true if the current input source has been marked as allowing only forward seeking by setInput.

SEG_CLOSE - Static variable in interface java.awt.geom.PathIterator

The segment type constant that specifies that the preceding subpath should be closed by appending a line segment back to the point corresponding to the most recent SEG_MOVETO.

SEG_CUBICTO - Static variable in interface java.awt.geom.PathIterator

The segment type constant for the set of 3 points that specify a cubic parametric curve to be drawn from the most recently specified point.

SEG_LINETO - Static variable in interface java.awt.geom.PathIterator

The segment type constant for a point that specifies the end point of a line to be drawn from the most recently specified point.

SEG_MOVETO - Static variable in interface java.awt.geom.PathIterator

The segment type constant for a point that specifies the starting location for a new subpath.

SEG_QUADTO - Static variable in interface java.awt.geom.PathIterator

The segment type constant for the pair of points that specify a quadratic parametric curve to be drawn from the most recently specified point.

Segment - Class in javax.swing.text

A segment of a character array representing a fragment of text.

Segment() - Constructor for class javax.swing.text.Segment

Creates a new segment.

Segment(char[], int, int) - Constructor for class javax.swing.text.Segment

Creates a new segment referring to an existing array.

SEGMENT_LIMIT - Static variable in interface java.util.jar.Pack200.Packer

This property is a numeral giving the estimated target size N (in bytes) of each archive segment.

select(int) - Method in class java.awt.Choice

Sets the selected item in this Choice menu to be the item at the specified position.

select(String) - Method in class java.awt.Choice

Sets the selected item in this Choice menu to be the item whose name is equal to the specified string.

select(int) - Method in class java.awt.List

Selects the item at the specified index in the scrolling list.

select(int, int) - Method in class java.awt.TextComponent

Selects the text between the specified start and end positions.

select(URI) - Method in class java.net.ProxySelector

Selects all the applicable proxies based on the protocol to access the resource with and a destination address to access the resource at.

select(long) - Method in class java.nio.channels.Selector

Selects a set of keys whose corresponding channels are ready for I/O operations.

select() - Method in class java.nio.channels.Selector

Selects a set of keys whose corresponding channels are ready for I/O operations.

SELECT - Static variable in class javax.swing.text.html.HTML.Tag

select(int, int) - Method in class javax.swing.text.JTextComponent

Selects the text between the specified start and end positions.

select(KeyInfo, KeySelector.Purpose, AlgorithmMethod, XMLCryptoContext) - Method in class javax.xml.crypto.KeySelector

Attempts to find a key that satisfies the specified constraints.

SELECTABLE - Static variable in class javax.accessibility.AccessibleState

Indicates this object is the child of an object that allows its children to be selected, and that this child is one of those children that can be selected.

SelectableChannel - Class in java.nio.channels

A channel that can be multiplexed via a Selector.

SelectableChannel() - Constructor for class java.nio.channels.SelectableChannel

Initializes a new instance of this class.

selectAdjacentRunTab(int, int, int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

selectAll() - Method in class java.awt.TextComponent

Selects all the text in this text component.

selectAll() - Method in interface javax.swing.ComboBoxEditor

Ask the editor to start editing and to select everything

selectAll() - Method in class javax.swing.JTable

Selects all rows, columns, and cells in the table.

selectAll() - Method in class javax.swing.plaf.basic.BasicComboBoxEditor

selectAll() - Method in class javax.swing.text.JTextComponent

Selects all the text in the TextComponent.

selectAllAccessibleSelection() - Method in class java.awt.List.AccessibleAWTList

Causes every selected item in the object to be selected if the object supports multiple selections.

selectAllAccessibleSelection() - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Causes every child of the object to be selected if the object supports multiple selections.

selectAllAccessibleSelection() - Method in interface javax.accessibility.AccessibleSelection

Causes every child of the object to be selected if the object supports multiple selections.

selectAllAccessibleSelection() - Method in class javax.swing.JComboBox.AccessibleJComboBox

Causes every child of the object to be selected if the object supports multiple selections.

selectAllAccessibleSelection() - Method in class javax.swing.JList.AccessibleJList

Causes every selected item in the object to be selected if the object supports multiple selections.

selectAllAccessibleSelection() - Method in class javax.swing.JMenu.AccessibleJMenu

Normally causes every selected item in the object to be selected if the object supports multiple selections.

selectAllAccessibleSelection() - Method in class javax.swing.JMenuBar.AccessibleJMenuBar

Normally causes every selected item in the object to be selected if the object supports multiple selections.

selectAllAccessibleSelection() - Method in class javax.swing.JTabbedPane.AccessibleJTabbedPane

selectAllAccessibleSelection() - Method in class javax.swing.JTable.AccessibleJTable

Causes every child of the object to be selected, but only if the JTable supports multiple selections, and if individual cell selection is enabled.

selectAllAccessibleSelection() - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Causes every selected item in the object to be selected if the object supports multiple selections.

selectAllAccessibleSelection() - Method in class javax.swing.JTree.AccessibleJTree

Causes every selected item in the object to be selected if the object supports multiple selections.

selectAllAction - Static variable in class javax.swing.text.DefaultEditorKit

Name of the Action for selecting the entire document

selectBestTextFlavor(DataFlavor[]) - Static method in class java.awt.datatransfer.DataFlavor

Selects the best text DataFlavor from an array of DataFlavors.

selectColor - Variable in class javax.swing.plaf.metal.MetalButtonUI

selectColor - Variable in class javax.swing.plaf.metal.MetalRadioButtonUI

selectColor - Variable in class javax.swing.plaf.metal.MetalTabbedPaneUI

selectColor - Variable in class javax.swing.plaf.metal.MetalToggleButtonUI

selectContent(AttributeSet) - Method in class javax.swing.text.html.HTMLWriter

Writes out the content of the SELECT form element.

SELECTED - Static variable in class java.awt.event.ItemEvent

This state-change value indicates that an item was selected.

SELECTED - Static variable in class javax.accessibility.AccessibleState

Indicates this object is the child of an object that allows its children to be selected, and that this child is one of those children that has been selected.

SELECTED - Static variable in class javax.swing.DefaultButtonModel

Identifies the "selected" bit in the bitmask, which indicates that the button has been selected.

SELECTED - Static variable in interface javax.swing.plaf.synth.SynthConstants

Indicates the region is selected.

SELECTED - Static variable in class javax.swing.text.html.HTML.Attribute

selected - Variable in class javax.swing.tree.DefaultTreeCellRenderer

Is the value currently selected.

SELECTED_CONVERTED_TEXT_HIGHLIGHT - Static variable in class java.awt.im.InputMethodHighlight

Constant for the default highlight for selected converted text.

SELECTED_FILE_CHANGED_PROPERTY - Static variable in class javax.swing.JFileChooser

Identifies change in user's single-file selection.

SELECTED_FILES_CHANGED_PROPERTY - Static variable in class javax.swing.JFileChooser

Identifies change in user's multiple-file selection.

SELECTED_ICON_CHANGED_PROPERTY - Static variable in class javax.swing.AbstractButton

Identifies a change to the icon used when the button has been selected.

SELECTED_KEY - Static variable in interface javax.swing.Action

The key used for storing a Boolean that corresponds to the selected state.

SELECTED_RAW_TEXT_HIGHLIGHT - Static variable in class java.awt.im.InputMethodHighlight

Constant for the default highlight for selected raw text.

selectedItemChanged() - Method in class javax.swing.JComboBox

This protected method is implementation specific.

selectedItemReminder - Variable in class javax.swing.JComboBox

This protected field is implementation specific.

selectedKeys() - Method in class java.nio.channels.Selector

Returns this selector's selected-key set.

selectedRun - Variable in class javax.swing.plaf.basic.BasicTabbedPaneUI

selectedTabPadInsets - Variable in class javax.swing.plaf.basic.BasicTabbedPaneUI

selectedTextColor - Variable in class javax.swing.plaf.basic.BasicInternalFrameTitlePane

selectedTitleColor - Variable in class javax.swing.plaf.basic.BasicInternalFrameTitlePane

selectFrame(boolean) - Method in class javax.swing.JDesktopPane

Selects the next JInternalFrame in this desktop pane.

selectHighlight - Variable in class javax.swing.plaf.metal.MetalTabbedPaneUI

selectInitialValue() - Method in class javax.swing.JOptionPane

Requests that the initial value be selected, which will set focus to the initial value.

selectInitialValue(JOptionPane) - Method in class javax.swing.plaf.basic.BasicOptionPaneUI

If inputComponent is non-null, the focus is requested on that, otherwise request focus on the default value

selectInitialValue(JOptionPane) - Method in class javax.swing.plaf.multi.MultiOptionPaneUI

Invokes the selectInitialValue method on each UI handled by this object.

selectInitialValue(JOptionPane) - Method in class javax.swing.plaf.OptionPaneUI

Requests the component representing the default value to have focus.

selectInputMethod(Locale) - Method in class java.awt.im.InputContext

Attempts to select an input method or keyboard layout that supports the given locale, and returns a value indicating whether such an input method or keyboard layout has been successfully selected.

SELECTION - Static variable in class java.awt.JobAttributes.DefaultSelectionType

The DefaultSelectionType instance to use for specifying that the current selection should be printed.

selection - Variable in class javax.swing.tree.DefaultTreeSelectionModel

Paths that are currently selected.

SELECTION_MODE_PROPERTY - Static variable in class javax.swing.tree.DefaultTreeSelectionModel

Property name for selectionMode.

SELECTION_MODEL_PROPERTY - Static variable in class javax.swing.JColorChooser

The selection model property name.

SELECTION_MODEL_PROPERTY - Static variable in class javax.swing.JTree

Bound property name for selectionModel.

SELECTION_VALUES_PROPERTY - Static variable in class javax.swing.JOptionPane

Bound property name for selectionValues.

selectionBackground - Variable in class javax.swing.JTable

The background color of selected cells.

selectionBackground - Variable in class javax.swing.plaf.basic.BasicMenuItemUI

selectionBackwardAction - Static variable in class javax.swing.text.DefaultEditorKit

Name of the Action for extending the selection by moving the caret logically backward one position.

selectionBeginAction - Static variable in class javax.swing.text.DefaultEditorKit

Name of the Action for moving the caret to the beginning of the document.

selectionBeginLineAction - Static variable in class javax.swing.text.DefaultEditorKit

Name of the Action for moving the caret to the beginning of a line, extending the selection.

selectionBeginParagraphAction - Static variable in class javax.swing.text.DefaultEditorKit

Name of the Action for moving the caret to the beginning of a paragraph, extending the selection.

selectionBeginWordAction - Static variable in class javax.swing.text.DefaultEditorKit

Name of the Action for moving the caret to the beginning of a word, extending the selection.

selectionDownAction - Static variable in class javax.swing.text.DefaultEditorKit

Name of the Action for moving the caret logically downward one position, extending the selection.

selectionEndAction - Static variable in class javax.swing.text.DefaultEditorKit

Name of the Action for moving the caret to the end of the document.

selectionEndLineAction - Static variable in class javax.swing.text.DefaultEditorKit

Name of the Action for moving the caret to the end of a line, extending the selection.

selectionEndParagraphAction - Static variable in class javax.swing.text.DefaultEditorKit

Name of the Action for moving the caret to the end of a paragraph, extending the selection.

selectionEndWordAction - Static variable in class javax.swing.text.DefaultEditorKit

Name of the Action for moving the caret to the end of a word, extending the selection.

selectionForeground - Variable in class javax.swing.JTable

The foreground color of selected cells.

selectionForeground - Variable in class javax.swing.plaf.basic.BasicMenuItemUI

selectionForKey(char, ComboBoxModel) - Method in interface javax.swing.JComboBox.KeySelectionManager

Given aKey and the model, returns the row that should become selected.

selectionForwardAction - Static variable in class javax.swing.text.DefaultEditorKit

Name of the Action for extending the selection by moving the caret logically forward one position.

selectionHtmlFlavor - Static variable in class java.awt.datatransfer.DataFlavor

Represents a piece of an HTML markup.

SelectionKey - Class in java.nio.channels

A token representing the registration of a SelectableChannel with a Selector.

SelectionKey() - Constructor for class java.nio.channels.SelectionKey

Constructs an instance of this class.

SelectionListener() - Constructor for class javax.swing.plaf.basic.BasicFileChooserUI.SelectionListener

selectionMode - Variable in class javax.swing.tree.DefaultTreeSelectionModel

Mode for the selection, will be either SINGLE_TREE_SELECTION, CONTIGUOUS_TREE_SELECTION or DISCONTIGUOUS_TREE_SELECTION.

selectionModel - Variable in class javax.swing.JTable

The ListSelectionModel of the table, used to keep track of row selections.

selectionModel - Variable in class javax.swing.JTree

Models the set of selected nodes in this tree.

selectionModel - Variable in class javax.swing.table.DefaultTableColumnModel

Model for keeping track of column selections

selectionModelChanged - Static variable in class javax.swing.plaf.basic.BasicListUI

SelectionModelPropertyChangeHandler() - Constructor for class javax.swing.plaf.basic.BasicTreeUI.SelectionModelPropertyChangeHandler

selectionNextWordAction - Static variable in class javax.swing.text.DefaultEditorKit

Name of the Action for moving the selection to the beginning of the next word, extending the selection.

selectionPreviousWordAction - Static variable in class javax.swing.text.DefaultEditorKit

Name of the Action for moving the selection to the beginning of the previous word, extending the selection.

selectionRedirector - Variable in class javax.swing.JTree

Creates a new event and passed it off the selectionListeners.

selectionUpAction - Static variable in class javax.swing.text.DefaultEditorKit

Name of the Action for moving the caret logically upward one position, extending the selection.

selectionValues - Variable in class javax.swing.JOptionPane

Array of values the user can choose from.

selectLineAction - Static variable in class javax.swing.text.DefaultEditorKit

Name of the Action for selecting a line around the caret.

selectNextIndex() - Method in class javax.swing.plaf.basic.BasicListUI

Selected the previous row and force it to be visible.

selectNextPossibleValue() - Method in class javax.swing.plaf.basic.BasicComboBoxUI

Selects the next item in the list.

selectNextTab(int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

selectNextTabInRun(int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

selectNow() - Method in class java.nio.channels.Selector

Selects a set of keys whose corresponding channels are ready for I/O operations.

selector() - Method in class java.nio.channels.SelectionKey

Returns the selector for which this key was created.

Selector - Class in java.nio.channels

A multiplexor of SelectableChannel objects.

Selector() - Constructor for class java.nio.channels.Selector

Initializes a new instance of this class.

SelectorProvider - Class in java.nio.channels.spi

Service-provider class for selectors and selectable channels.

SelectorProvider() - Constructor for class java.nio.channels.spi.SelectorProvider

Initializes a new instance of this class.

selectParagraphAction - Static variable in class javax.swing.text.DefaultEditorKit

Name of the Action for selecting a paragraph around the caret.

selectPathForEvent(TreePath, MouseEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI

Messaged to update the selection based on a MouseEvent over a particular row.

selectPreviousIndex() - Method in class javax.swing.plaf.basic.BasicListUI

Selected the previous row and force it to be visible.

selectPreviousPossibleValue() - Method in class javax.swing.plaf.basic.BasicComboBoxUI

Selects the previous item in the list.

selectPreviousTab(int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

selectPreviousTabInRun(int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

selectText(int, int) - Method in interface javax.accessibility.AccessibleEditableText

Selects the text between two indices.

selectText(int, int) - Method in class javax.swing.JSpinner.AccessibleJSpinner

Selects the text between two indices.

selectText(int, int) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Selects the text between two indices.

selectWithKeyChar(char) - Method in class javax.swing.JComboBox

Selects the list item that corresponds to the specified keyboard character and returns true, if there is an item corresponding to that character.

selectWordAction - Static variable in class javax.swing.text.DefaultEditorKit

Name of the Action for selecting a word around the caret.

Semaphore - Class in java.util.concurrent

A counting semaphore.

Semaphore(int) - Constructor for class java.util.concurrent.Semaphore

Creates a Semaphore with the given number of permits and nonfair fairness setting.

Semaphore(int, boolean) - Constructor for class java.util.concurrent.Semaphore

Creates a Semaphore with the given number of permits and the given fairness setting.

send(DatagramPacket) - Method in class java.net.DatagramSocket

Sends a datagram packet from this socket.

send(DatagramPacket) - Method in class java.net.DatagramSocketImpl

Sends a datagram packet.

send(DatagramPacket, byte) - Method in class java.net.MulticastSocket

Deprecated.
Use the following code or its equivalent instead: ...... int ttl = mcastSocket.getTimeToLive(); mcastSocket.setTimeToLive(newttl); mcastSocket.send(p); mcastSocket.setTimeToLive(ttl); ......

send(ByteBuffer, SocketAddress) - Method in class java.nio.channels.DatagramChannel

Sends a datagram via this channel.

send(MidiMessage, long) - Method in interface javax.sound.midi.Receiver

Sends a MIDI message and time-stamp to this receiver.

send_deferred() - Method in class org.omg.CORBA.Request

Makes an asynchronous invocation on the request.

send_exception(ServerRequestInfo) - Method in interface org.omg.PortableInterceptor.ServerRequestInterceptorOperations

Allows an Interceptor to query the exception information and modify the reply service context before the exception is thrown to the client.

send_multiple_requests_deferred(Request[]) - Method in class org.omg.CORBA.ORB

Sends multiple dynamic (DII) requests asynchronously.

send_multiple_requests_oneway(Request[]) - Method in class org.omg.CORBA.ORB

Sends multiple dynamic (DII) requests asynchronously without expecting any responses.

send_oneway() - Method in class org.omg.CORBA.Request

Makes a oneway invocation on the request.

send_other(ServerRequestInfo) - Method in interface org.omg.PortableInterceptor.ServerRequestInterceptorOperations

Allows an Interceptor to query the information available when a request results in something other than a normal reply or an exception.

send_poll(ClientRequestInfo) - Method in interface org.omg.PortableInterceptor.ClientRequestInterceptorOperations

Allows an Interceptor to query information during a Time-Independent Invocation (TII) polling get reply sequence.

send_reply(ServerRequestInfo) - Method in interface org.omg.PortableInterceptor.ServerRequestInterceptorOperations

Allows an Interceptor to query reply information and modify the reply service context after the target operation has been invoked and before the reply is returned to the client.

send_request(ClientRequestInfo) - Method in interface org.omg.PortableInterceptor.ClientRequestInterceptorOperations

Allows an Interceptor to query request information and modify the service context before the request is sent to the server.

sendAttributeChangeNotification(AttributeChangeNotification) - Method in interface javax.management.modelmbean.ModelMBeanNotificationBroadcaster

Sends an attributeChangeNotification which is passed in to the registered attributeChangeNotification listeners on the ModelMBean.

sendAttributeChangeNotification(Attribute, Attribute) - Method in interface javax.management.modelmbean.ModelMBeanNotificationBroadcaster

Sends an attributeChangeNotification which contains the old value and new value for the attribute to the registered AttributeChangeNotification listeners on the ModelMBean.

sendAttributeChangeNotification(AttributeChangeNotification) - Method in class javax.management.modelmbean.RequiredModelMBean

sendAttributeChangeNotification(Attribute, Attribute) - Method in class javax.management.modelmbean.RequiredModelMBean

sending_exception() - Method in interface org.omg.PortableInterceptor.ServerRequestInfoOperations

Returns an any which contains the exception to be returned to the client.

sendNotification(Notification) - Method in class javax.management.MBeanServerDelegate

Enables the MBean server to send a notification.

sendNotification(Notification) - Method in interface javax.management.modelmbean.ModelMBeanNotificationBroadcaster

Sends a Notification which is passed in to the registered Notification listeners on the ModelMBean as a jmx.modelmbean.generic notification.

sendNotification(String) - Method in interface javax.management.modelmbean.ModelMBeanNotificationBroadcaster

Sends a Notification which contains the text string that is passed in to the registered Notification listeners on the ModelMBean.

sendNotification(Notification) - Method in class javax.management.modelmbean.RequiredModelMBean

sendNotification(String) - Method in class javax.management.modelmbean.RequiredModelMBean

sendNotification(Notification) - Method in class javax.management.NotificationBroadcasterSupport

Sends a notification.

sendNotification(Notification) - Method in class javax.management.StandardEmitterMBean

Sends a notification.

sendRelationCreationNotification(String) - Method in class javax.management.relation.RelationService

Sends a notification (RelationNotification) for a relation creation.

sendRelationCreationNotification(String) - Method in interface javax.management.relation.RelationServiceMBean

Sends a notification (RelationNotification) for a relation creation.

sendRelationRemovalNotification(String, List<ObjectName>) - Method in class javax.management.relation.RelationService

Sends a notification (RelationNotification) for a relation removal.

sendRelationRemovalNotification(String, List<ObjectName>) - Method in interface javax.management.relation.RelationServiceMBean

Sends a notification (RelationNotification) for a relation removal.

sendRoleUpdateNotification(String, Role, List<ObjectName>) - Method in class javax.management.relation.RelationService

Sends a notification (RelationNotification) for a role update in the given relation.

sendRoleUpdateNotification(String, Role, List<ObjectName>) - Method in interface javax.management.relation.RelationServiceMBean

Sends a notification (RelationNotification) for a role update in the given relation.

sendUrgentData(int) - Method in class java.net.Socket

Send one byte of urgent data on the socket.

sendUrgentData(int) - Method in class java.net.SocketImpl

Send one byte of urgent data on the socket.

SENTENCE - Static variable in interface javax.accessibility.AccessibleText

Constant used to indicate that the part of the text that should be retrieved is a sentence.

SEPARATE_DOCUMENTS_COLLATED_COPIES - Static variable in class java.awt.JobAttributes.MultipleDocumentHandlingType

The MultipleDocumentHandlingType instance to use for specifying that the job should be divided into separate, collated copies.

SEPARATE_DOCUMENTS_COLLATED_COPIES - Static variable in class javax.print.attribute.standard.MultipleDocumentHandling

Separate documents collated copies -- see above for further information.

SEPARATE_DOCUMENTS_UNCOLLATED_COPIES - Static variable in class java.awt.JobAttributes.MultipleDocumentHandlingType

The MultipleDocumentHandlingType instance to use for specifying that the job should be divided into separate, uncollated copies.

SEPARATE_DOCUMENTS_UNCOLLATED_COPIES - Static variable in class javax.print.attribute.standard.MultipleDocumentHandling

Separate documents uncollated copies -- see above for further information.

separator - Static variable in class java.io.File

The system-dependent default name-separator character, represented as a string for convenience.

SEPARATOR - Static variable in class javax.accessibility.AccessibleRole

An object usually contained in a menu to provide a visual and logical separation of the contents in a menu.

Separator() - Constructor for class javax.swing.JPopupMenu.Separator

Separator() - Constructor for class javax.swing.JToolBar.Separator

Creates a new toolbar separator with the default size as defined by the current look and feel.

Separator(Dimension) - Constructor for class javax.swing.JToolBar.Separator

Creates a new toolbar separator with the specified size.

SEPARATOR - Static variable in class javax.swing.plaf.synth.Region

Separator region.

separatorChar - Static variable in class java.io.File

The system-dependent default name-separator character.

SeparatorUI - Class in javax.swing.plaf

Pluggable look and feel interface for JSeparator.

SeparatorUI() - Constructor for class javax.swing.plaf.SeparatorUI

SEPTEMBER - Static variable in class java.util.Calendar

Value of the Calendar.MONTH field indicating the ninth month of the year in the Gregorian and Julian calendars.

SEPTEMBER - Static variable in class javax.xml.datatype.DatatypeConstants

Value for ninth month of year.

Sequence - Class in javax.sound.midi

A Sequence is a data structure containing musical information (often an entire song or composition) that can be played back by a Sequencer object.

Sequence(float, int) - Constructor for class javax.sound.midi.Sequence

Constructs a new MIDI sequence with the specified timing division type and timing resolution.

Sequence(float, int, int) - Constructor for class javax.sound.midi.Sequence

Constructs a new MIDI sequence with the specified timing division type, timing resolution, and number of tracks.

sequenceComplete(ImageReader) - Method in interface javax.imageio.event.IIOReadProgressListener

Reports that a sequence of read operations has completed.

SequenceInputStream - Class in java.io

A SequenceInputStream represents the logical concatenation of other input streams.

SequenceInputStream(Enumeration<? extends InputStream>) - Constructor for class java.io.SequenceInputStream

Initializes a newly created SequenceInputStream by remembering the argument, which must be an Enumeration that produces objects whose run-time type is InputStream.

SequenceInputStream(InputStream, InputStream) - Constructor for class java.io.SequenceInputStream

Initializes a newly created SequenceInputStream by remembering the two arguments, which will be read in order, first s1 and then s2, to provide the bytes to be read from this SequenceInputStream.

Sequencer - Interface in javax.sound.midi

A hardware or software device that plays back a MIDI sequence is known as a sequencer.

Sequencer.SyncMode - Class in javax.sound.midi

A SyncMode object represents one of the ways in which a MIDI sequencer's notion of time can be synchronized with a master or slave device.

sequenceStarted(ImageReader, int) - Method in interface javax.imageio.event.IIOReadProgressListener

Reports that a sequence of read operations is beginning.

sequential() - Method in interface java.util.stream.BaseStream

Returns an equivalent stream that is sequential.

sequential() - Method in interface java.util.stream.DoubleStream

sequential() - Method in interface java.util.stream.IntStream

sequential() - Method in interface java.util.stream.LongStream

SerialArray - Class in javax.sql.rowset.serial

A serialized version of an Array object, which is the mapping in the Java programming language of an SQL ARRAY value.

SerialArray(Array, Map<String, Class<?>>) - Constructor for class javax.sql.rowset.serial.SerialArray

Constructs a new SerialArray object from the given Array object, using the given type map for the custom mapping of each element when the elements are SQL UDTs.

SerialArray(Array) - Constructor for class javax.sql.rowset.serial.SerialArray

Constructs a new SerialArray object from the given Array object.

SerialBlob - Class in javax.sql.rowset.serial

A serialized mapping in the Java programming language of an SQL BLOB value.

SerialBlob(byte[]) - Constructor for class javax.sql.rowset.serial.SerialBlob

Constructs a SerialBlob object that is a serialized version of the given byte array.

SerialBlob(Blob) - Constructor for class javax.sql.rowset.serial.SerialBlob

Constructs a SerialBlob object that is a serialized version of the given Blob object.

SerialClob - Class in javax.sql.rowset.serial

A serialized mapping in the Java programming language of an SQL CLOB value.

SerialClob(char[]) - Constructor for class javax.sql.rowset.serial.SerialClob

Constructs a SerialClob object that is a serialized version of the given char array.

SerialClob(Clob) - Constructor for class javax.sql.rowset.serial.SerialClob

Constructs a SerialClob object that is a serialized version of the given Clob object.

SerialDatalink - Class in javax.sql.rowset.serial

A serialized mapping in the Java programming language of an SQL DATALINK value.

SerialDatalink(URL) - Constructor for class javax.sql.rowset.serial.SerialDatalink

Constructs a new SerialDatalink object from the given java.net.URL object.

SerialException - Exception in javax.sql.rowset.serial

Indicates and an error with the serialization or de-serialization of SQL types such as BLOB, CLOB, STRUCT or ARRAY in addition to SQL types such as DATALINK and JAVAOBJECT

SerialException() - Constructor for exception javax.sql.rowset.serial.SerialException

Creates a new SerialException without a message.

SerialException(String) - Constructor for exception javax.sql.rowset.serial.SerialException

Creates a new SerialException with the specified message.

serializable - Variable in class java.beans.beancontext.BeanContextServicesSupport

The number of instances of a serializable BeanContextServceProvider.

Serializable - Interface in java.io

Serializability of a class is enabled by the class implementing the java.io.Serializable interface.

SerializablePermission - Class in java.io

This class is for Serializable permissions.

SerializablePermission(String) - Constructor for class java.io.SerializablePermission

Creates a new SerializablePermission with the specified name.

SerializablePermission(String, String) - Constructor for class java.io.SerializablePermission

Creates a new SerializablePermission object with the specified name.

serialize(ObjectOutputStream, Collection) - Method in class java.beans.beancontext.BeanContextSupport

Used by writeObject to serialize a Collection.

SERIALIZE_ERR - Static variable in exception org.w3c.dom.ls.LSException

If an attempt was made to serialize a Node using LSSerializer and the processing has been stopped.

SerializedLambda - Class in java.lang.invoke

Serialized form of a lambda expression.

SerializedLambda(Class<?>, String, String, String, int, String, String, String, String, Object[]) - Constructor for class java.lang.invoke.SerializedLambda

Create a SerializedLambda from the low-level information present at the lambda factory site.

SerialJavaObject - Class in javax.sql.rowset.serial

A serializable mapping in the Java programming language of an SQL JAVA_OBJECT value.

SerialJavaObject(Object) - Constructor for class javax.sql.rowset.serial.SerialJavaObject

Constructor for SerialJavaObject helper class.

SerialRef - Class in javax.sql.rowset.serial

A serialized mapping of a Ref object, which is the mapping in the Java programming language of an SQL REF value.

SerialRef(Ref) - Constructor for class javax.sql.rowset.serial.SerialRef

Constructs a SerialRef object from the given Ref object.

SerialStruct - Class in javax.sql.rowset.serial

A serialized mapping in the Java programming language of an SQL structured type.

SerialStruct(Struct, Map<String, Class<?>>) - Constructor for class javax.sql.rowset.serial.SerialStruct

Constructs a SerialStruct object from the given Struct object, using the given java.util.Map object for custom mapping the SQL structured type or any of its attributes that are SQL structured types.

SerialStruct(SQLData, Map<String, Class<?>>) - Constructor for class javax.sql.rowset.serial.SerialStruct

Constructs a SerialStruct object from the given SQLData object, using the given type map to custom map it to a class in the Java programming language.

serialVersionUID - Static variable in interface java.rmi.server.RemoteRef

indicate compatibility with JDK 1.1.x version of class.

serialVersionUID - Static variable in interface java.rmi.server.ServerRef

Deprecated.

indicate compatibility with JDK 1.1.x version of class.

serialVersionUID - Static variable in interface java.security.interfaces.DSAPrivateKey

The class fingerprint that is set to indicate serialization compatibility with a previous version of the class.

serialVersionUID - Static variable in interface java.security.interfaces.DSAPublicKey

The class fingerprint that is set to indicate serialization compatibility with a previous version of the class.

serialVersionUID - Static variable in interface java.security.interfaces.ECPrivateKey

The class fingerprint that is set to indicate serialization compatibility.

serialVersionUID - Static variable in interface java.security.interfaces.ECPublicKey

The class fingerprint that is set to indicate serialization compatibility.

serialVersionUID - Static variable in interface java.security.interfaces.RSAMultiPrimePrivateCrtKey

The type fingerprint that is set to indicate serialization compatibility with a previous version of the type.

serialVersionUID - Static variable in interface java.security.interfaces.RSAPrivateCrtKey

The type fingerprint that is set to indicate serialization compatibility with a previous version of the type.

serialVersionUID - Static variable in interface java.security.interfaces.RSAPrivateKey

The type fingerprint that is set to indicate serialization compatibility with a previous version of the type.

serialVersionUID - Static variable in interface java.security.interfaces.RSAPublicKey

The type fingerprint that is set to indicate serialization compatibility with a previous version of the type.

serialVersionUID - Static variable in interface java.security.Key

The class fingerprint that is set to indicate serialization compatibility with a previous version of the class.

serialVersionUID - Static variable in interface java.security.PrivateKey

The class fingerprint that is set to indicate serialization compatibility with a previous version of the class.

serialVersionUID - Static variable in interface java.security.PublicKey

The class fingerprint that is set to indicate serialization compatibility with a previous version of the class.

serialVersionUID - Static variable in interface javax.crypto.interfaces.DHPrivateKey

The class fingerprint that is set to indicate serialization compatibility since J2SE 1.4.

serialVersionUID - Static variable in interface javax.crypto.interfaces.DHPublicKey

The class fingerprint that is set to indicate serialization compatibility since J2SE 1.4.

serialVersionUID - Static variable in interface javax.crypto.interfaces.PBEKey

The class fingerprint that is set to indicate serialization compatibility since J2SE 1.4.

serialVersionUID - Static variable in interface javax.crypto.SecretKey

The class fingerprint that is set to indicate serialization compatibility since J2SE 1.4.

serialVersionUID - Static variable in interface javax.naming.directory.Attribute

Use serialVersionUID from JNDI 1.1.1 for interoperability.

serialVersionUID - Static variable in interface javax.naming.Name

The class fingerprint that is set to indicate serialization compatibility with a previous version of the class.

SERIF - Static variable in class java.awt.Font

A String constant for the canonical family name of the logical font "Serif".

servant - Variable in class org.omg.CORBA.portable.ServantObject

The real servant.

Servant - Class in org.omg.PortableServer

Defines the native Servant type.

Servant() - Constructor for class org.omg.PortableServer.Servant

servant_postinvoke(Object, ServantObject) - Method in class org.omg.CORBA.portable.Delegate

servant_postinvoke() is invoked by the local stub after the operation has been invoked on the local servant.

servant_preinvoke(Object, String, Class) - Method in class org.omg.CORBA.portable.Delegate

Returns a Java reference to the servant which should be used for this request.

SERVANT_RETENTION_POLICY_ID - Interface in org.omg.PortableServer

org/omg/PortableServer/SERVANT_RETENTION_POLICY_ID.java .

servant_to_id(Servant) - Method in interface org.omg.PortableServer.POAOperations

This operation has four possible behaviors.

servant_to_reference(Servant) - Method in interface org.omg.PortableServer.POAOperations

This operation requires the RETAIN policy and either the UNIQUE_ID or IMPLICIT_ACTIVATION policies if invoked outside the context of an operation dispatched by this POA.

ServantActivator - Interface in org.omg.PortableServer

When the POA has the RETAIN policy it uses servant managers that are ServantActivators.

ServantActivatorHelper - Class in org.omg.PortableServer

When the POA has the RETAIN policy it uses servant managers that are ServantActivators.

ServantActivatorHelper() - Constructor for class org.omg.PortableServer.ServantActivatorHelper

ServantActivatorOperations - Interface in org.omg.PortableServer

When the POA has the RETAIN policy it uses servant managers that are ServantActivators.

ServantActivatorPOA - Class in org.omg.PortableServer

When the POA has the RETAIN policy it uses servant managers that are ServantActivators.

ServantActivatorPOA() - Constructor for class org.omg.PortableServer.ServantActivatorPOA

ServantAlreadyActive - Exception in org.omg.PortableServer.POAPackage

org/omg/PortableServer/POAPackage/ServantAlreadyActive.java .

ServantAlreadyActive() - Constructor for exception org.omg.PortableServer.POAPackage.ServantAlreadyActive

ServantAlreadyActive(String) - Constructor for exception org.omg.PortableServer.POAPackage.ServantAlreadyActive

ServantAlreadyActiveHelper - Class in org.omg.PortableServer.POAPackage

org/omg/PortableServer/POAPackage/ServantAlreadyActiveHelper.java .

ServantAlreadyActiveHelper() - Constructor for class org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper

ServantLocator - Interface in org.omg.PortableServer

When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.

ServantLocatorHelper - Class in org.omg.PortableServer

When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.

ServantLocatorHelper() - Constructor for class org.omg.PortableServer.ServantLocatorHelper

ServantLocatorOperations - Interface in org.omg.PortableServer

When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.

ServantLocatorPOA - Class in org.omg.PortableServer

When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.

ServantLocatorPOA() - Constructor for class org.omg.PortableServer.ServantLocatorPOA

ServantManager - Interface in org.omg.PortableServer

A servant manager supplies a POA with the ability to activate objects on demand when the POA receives a request targeted at an inactive object.

ServantManagerOperations - Interface in org.omg.PortableServer

A servant manager supplies a POA with the ability to activate objects on demand when the POA receives a request targeted at an inactive object.

ServantNotActive - Exception in org.omg.PortableServer.POAPackage

org/omg/PortableServer/POAPackage/ServantNotActive.java .

ServantNotActive() - Constructor for exception org.omg.PortableServer.POAPackage.ServantNotActive

ServantNotActive(String) - Constructor for exception org.omg.PortableServer.POAPackage.ServantNotActive

ServantNotActiveHelper - Class in org.omg.PortableServer.POAPackage

org/omg/PortableServer/POAPackage/ServantNotActiveHelper.java .

ServantNotActiveHelper() - Constructor for class org.omg.PortableServer.POAPackage.ServantNotActiveHelper

ServantObject - Class in org.omg.CORBA.portable

This class is part of the local stub API, the purpose of which is to provide high performance calls for collocated clients and servers (i.e.

ServantObject() - Constructor for class org.omg.CORBA.portable.ServantObject

ServantRetentionPolicy - Interface in org.omg.PortableServer

This policy specifies whether the created POA retains active servants in an Active Object Map.

ServantRetentionPolicyOperations - Interface in org.omg.PortableServer

This policy specifies whether the created POA retains active servants in an Active Object Map.

ServantRetentionPolicyValue - Class in org.omg.PortableServer

ServantRetentionPolicyValue can have the following values.

ServantRetentionPolicyValue(int) - Constructor for class org.omg.PortableServer.ServantRetentionPolicyValue

server - Variable in class javax.management.monitor.Monitor

Reference to the MBean server.

SERVER_AUTH - Static variable in class javax.security.sasl.Sasl

The name of a property that specifies whether the server must authenticate to the client.

server_id() - Method in interface org.omg.PortableInterceptor.ObjectReferenceTemplate

server_id() - Method in interface org.omg.PortableInterceptor.ServerRequestInfoOperations

Returns the server ID that was specified on ORB::init using the -ORBServerId argument.

ServerCloneException - Exception in java.rmi.server

A ServerCloneException is thrown if a remote exception occurs during the cloning of a UnicastRemoteObject.

ServerCloneException(String) - Constructor for exception java.rmi.server.ServerCloneException

Constructs a ServerCloneException with the specified detail message.

ServerCloneException(String, Exception) - Constructor for exception java.rmi.server.ServerCloneException

Constructs a ServerCloneException with the specified detail message and cause.

ServerError - Exception in java.rmi

A ServerError is thrown as a result of a remote method invocation when an Error is thrown while processing the invocation on the server, either while unmarshalling the arguments, executing the remote method itself, or marshalling the return value.

ServerError(String, Error) - Constructor for exception java.rmi.ServerError

Constructs a ServerError with the specified detail message and nested error.

ServerException - Exception in java.rmi

A ServerException is thrown as a result of a remote method invocation when a RemoteException is thrown while processing the invocation on the server, either while unmarshalling the arguments or executing the remote method itself.

ServerException(String) - Constructor for exception java.rmi.ServerException

Constructs a ServerException with the specified detail message.

ServerException(String, Exception) - Constructor for exception java.rmi.ServerException

Constructs a ServerException with the specified detail message and nested exception.

ServerIdHelper - Class in org.omg.PortableInterceptor

org/omg/PortableInterceptor/ServerIdHelper.java .

ServerIdHelper() - Constructor for class org.omg.PortableInterceptor.ServerIdHelper

ServerNotActiveException - Exception in java.rmi.server

An ServerNotActiveException is an Exception thrown during a call to RemoteServer.getClientHost if the getClientHost method is called outside of servicing a remote method call.

ServerNotActiveException() - Constructor for exception java.rmi.server.ServerNotActiveException

Constructs an ServerNotActiveException with no specified detail message.

ServerNotActiveException(String) - Constructor for exception java.rmi.server.ServerNotActiveException

Constructs an ServerNotActiveException with the specified detail message.

ServerRef - Interface in java.rmi.server

Deprecated.
No replacement. This interface is unused and is obsolete.

ServerRequest - Class in org.omg.CORBA

An object that captures the explicit state of a request for the Dynamic Skeleton Interface (DSI).

ServerRequest() - Constructor for class org.omg.CORBA.ServerRequest

ServerRequestInfo - Interface in org.omg.PortableInterceptor

Request Information, accessible to server-side request interceptors.

ServerRequestInfoOperations - Interface in org.omg.PortableInterceptor

Request Information, accessible to server-side request interceptors.

ServerRequestInterceptor - Interface in org.omg.PortableInterceptor

Server-side request interceptor.

ServerRequestInterceptorOperations - Interface in org.omg.PortableInterceptor

Server-side request interceptor.

ServerRuntimeException - Exception in java.rmi

Deprecated.
no replacement

ServerRuntimeException(String, Exception) - Constructor for exception java.rmi.ServerRuntimeException

Deprecated.
no replacement

ServerSocket - Class in java.net

This class implements server sockets.

ServerSocket() - Constructor for class java.net.ServerSocket

Creates an unbound server socket.

ServerSocket(int) - Constructor for class java.net.ServerSocket

Creates a server socket, bound to the specified port.

ServerSocket(int, int) - Constructor for class java.net.ServerSocket

Creates a server socket and binds it to the specified local port number, with the specified backlog.

ServerSocket(int, int, InetAddress) - Constructor for class java.net.ServerSocket

Create a server with the specified port, listen backlog, and local IP address to bind to.

ServerSocketChannel - Class in java.nio.channels

A selectable channel for stream-oriented listening sockets.

ServerSocketChannel(SelectorProvider) - Constructor for class java.nio.channels.ServerSocketChannel

Initializes a new instance of this class.

ServerSocketFactory - Class in javax.net

This class creates server sockets.

ServerSocketFactory() - Constructor for class javax.net.ServerSocketFactory

Creates a server socket factory.

Service(Provider, String, String, String, List<String>, Map<String, String>) - Constructor for class java.security.Provider.Service

Construct a new service.

Service - Class in javax.xml.ws

Service objects provide the client view of a Web service.

Service(URL, QName) - Constructor for class javax.xml.ws.Service

Service(URL, QName, WebServiceFeature...) - Constructor for class javax.xml.ws.Service

Service.Mode - Enum in javax.xml.ws

The orientation of a dynamic client or service.

service_detail - Variable in class org.omg.CORBA.ServiceDetail

The data describing the ORB service that this ServiceDetail object represents.

service_detail_type - Variable in class org.omg.CORBA.ServiceDetail

The type of the ORB service that this ServiceDetail object represents.

service_details - Variable in class org.omg.CORBA.ServiceInformation

Array of ServiceDetails giving more details about the service.

SERVICE_FORMATTED(String) - Constructor for class javax.print.DocFlavor.SERVICE_FORMATTED

Constructs a new doc flavor with a MIME type of "application/x-java-jvm-local-objectref" indicating service formatted print data and the given print data representation class name.

SERVICE_OFF_LINE - Static variable in class javax.print.attribute.standard.JobStateReason

The printer is off-line and accepting no jobs.

service_options - Variable in class org.omg.CORBA.ServiceInformation

Array of ints representing service options.

serviceAvailable(BeanContextServiceAvailableEvent) - Method in class java.beans.beancontext.BeanContextChildSupport

A new service is available from the nesting BeanContext.

serviceAvailable(BeanContextServiceAvailableEvent) - Method in interface java.beans.beancontext.BeanContextServicesListener

The service named has been registered.

serviceAvailable(BeanContextServiceAvailableEvent) - Method in class java.beans.beancontext.BeanContextServicesSupport

BeanContextServicesListener callback, propagates event to all currently registered listeners and BeanContextServices children, if this BeanContextService does not already implement this service itself.

serviceClass - Variable in class java.beans.beancontext.BeanContextServiceAvailableEvent

A Class reference to the newly available service

serviceClass - Variable in class java.beans.beancontext.BeanContextServiceRevokedEvent

A Class reference to the service that is being revoked.

ServiceConfigurationError - Error in java.util

Error thrown when something goes wrong while loading a service provider.

ServiceConfigurationError(String) - Constructor for error java.util.ServiceConfigurationError

Constructs a new instance with the specified message.

ServiceConfigurationError(String, Throwable) - Constructor for error java.util.ServiceConfigurationError

Constructs a new instance with the specified message and cause.

ServiceContext - Class in org.omg.IOP

org/omg/IOP/ServiceContext.java .

ServiceContext() - Constructor for class org.omg.IOP.ServiceContext

ServiceContext(int, byte[]) - Constructor for class org.omg.IOP.ServiceContext

ServiceContextHelper - Class in org.omg.IOP

org/omg/IOP/ServiceContextHelper.java .

ServiceContextHelper() - Constructor for class org.omg.IOP.ServiceContextHelper

ServiceContextHolder - Class in org.omg.IOP

org/omg/IOP/ServiceContextHolder.java .

ServiceContextHolder() - Constructor for class org.omg.IOP.ServiceContextHolder

ServiceContextHolder(ServiceContext) - Constructor for class org.omg.IOP.ServiceContextHolder

ServiceContextListHelper - Class in org.omg.IOP

An array of service contexts, forming a service context list.

ServiceContextListHelper() - Constructor for class org.omg.IOP.ServiceContextListHelper

ServiceContextListHolder - Class in org.omg.IOP

An array of service contexts, forming a service context list.

ServiceContextListHolder() - Constructor for class org.omg.IOP.ServiceContextListHolder

ServiceContextListHolder(ServiceContext[]) - Constructor for class org.omg.IOP.ServiceContextListHolder

ServiceDelegate - Class in javax.xml.ws.spi

Service delegates are used internally by Service objects to allow pluggability of JAX-WS implementations.

ServiceDelegate() - Constructor for class javax.xml.ws.spi.ServiceDelegate

ServiceDetail - Class in org.omg.CORBA

An object that represents an ORB service: its service_detail_type field contains the type of the ORB service, and its service_detail field contains a description of the ORB service.

ServiceDetail() - Constructor for class org.omg.CORBA.ServiceDetail

Constructs a ServiceDetail object with 0 for the type of ORB service and an empty description.

ServiceDetail(int, byte[]) - Constructor for class org.omg.CORBA.ServiceDetail

Constructs a ServiceDetail object with the given ORB service type and the given description.

ServiceDetailHelper - Class in org.omg.CORBA

ServiceDetailHelper() - Constructor for class org.omg.CORBA.ServiceDetailHelper

ServiceIdHelper - Class in org.omg.IOP

A service id, represented as an int

ServiceIdHelper() - Constructor for class org.omg.IOP.ServiceIdHelper

ServiceInformation - Class in org.omg.CORBA

An IDL struct in the CORBA module that stores information about a CORBA service available in the ORB implementation and is obtained from the ORB.get_service_information method.

ServiceInformation() - Constructor for class org.omg.CORBA.ServiceInformation

Constructs a ServiceInformation object with empty service_options and service_details.

ServiceInformation(int[], ServiceDetail[]) - Constructor for class org.omg.CORBA.ServiceInformation

Constructs a ServiceInformation object with the given service_options and service_details.

ServiceInformationHelper - Class in org.omg.CORBA

ServiceInformationHelper() - Constructor for class org.omg.CORBA.ServiceInformationHelper

ServiceInformationHolder - Class in org.omg.CORBA

The Holder for ServiceInformation.

ServiceInformationHolder() - Constructor for class org.omg.CORBA.ServiceInformationHolder

Constructs a new ServiceInformationHolder object with its value field initialized to null.

ServiceInformationHolder(ServiceInformation) - Constructor for class org.omg.CORBA.ServiceInformationHolder

Constructs a new ServiceInformationHolder object with its value field initialized to the given ServiceInformation object.

ServiceLoader<S> - Class in java.util

A simple service-provider loading facility.

ServiceMode - Annotation Type in javax.xml.ws

Used to indicate whether a Provider implementation wishes to work with entire protocol messages or just with protocol message payloads.

serviceName(QName) - Method in class javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder

Sets the serviceName as the wsam:ServiceName element in the wsa:Metadata element.

ServiceNotFoundException - Exception in javax.management

Represents exceptions raised when a requested service is not supported.

ServiceNotFoundException() - Constructor for exception javax.management.ServiceNotFoundException

Default constructor.

ServiceNotFoundException(String) - Constructor for exception javax.management.ServiceNotFoundException

Constructor that allows a specific error message to be specified.

ServicePermission - Class in javax.security.auth.kerberos

This class is used to protect Kerberos services and the credentials necessary to access those services.

ServicePermission(String, String) - Constructor for class javax.security.auth.kerberos.ServicePermission

Create a new ServicePermission with the specified servicePrincipal and action.

serviceProvider - Variable in class java.beans.beancontext.BeanContextServicesSupport.BCSSServiceProvider

The service provider.

ServiceRegistry - Class in javax.imageio.spi

A registry for service provider instances.

ServiceRegistry(Iterator<Class<?>>) - Constructor for class javax.imageio.spi.ServiceRegistry

Constructs a ServiceRegistry instance with a set of categories taken from the categories argument.

ServiceRegistry.Filter - Interface in javax.imageio.spi

A simple filter interface used by ServiceRegistry.getServiceProviders to select providers matching an arbitrary criterion.

serviceRevoked(BeanContextServiceRevokedEvent) - Method in class java.beans.beancontext.BeanContextChildSupport

A service provided by the nesting BeanContext has been revoked.

serviceRevoked(BeanContextServiceRevokedEvent) - Method in interface java.beans.beancontext.BeanContextServiceRevokedListener

The service named has been revoked.

serviceRevoked(BeanContextServiceRevokedEvent) - Method in class java.beans.beancontext.BeanContextServicesSupport.BCSSProxyServiceProvider

serviceRevoked(BeanContextServiceRevokedEvent) - Method in class java.beans.beancontext.BeanContextServicesSupport

BeanContextServicesListener callback, propagates event to all currently registered listeners and BeanContextServices children, if this BeanContextService does not already implement this service itself.

services - Variable in class java.beans.beancontext.BeanContextServicesSupport

all accesses to the protected transient HashMap services field should be synchronized on that object

ServiceUI - Class in javax.print

This class is a collection of UI convenience methods which provide a graphical user dialog for browsing print services looked up through the Java Print Service API.

ServiceUI() - Constructor for class javax.print.ServiceUI

ServiceUIFactory - Class in javax.print

Services may optionally provide UIs which allow different styles of interaction in different roles.

ServiceUIFactory() - Constructor for class javax.print.ServiceUIFactory

ServiceUnavailableException - Exception in javax.naming

This exception is thrown when attempting to communicate with a directory or naming service and that service is not available.

ServiceUnavailableException(String) - Constructor for exception javax.naming.ServiceUnavailableException

Constructs a new instance of ServiceUnavailableException using an explanation.

ServiceUnavailableException() - Constructor for exception javax.naming.ServiceUnavailableException

Constructs a new instance of ServiceUnavailableException.

SERVLET_CONTEXT - Static variable in interface javax.xml.ws.handler.MessageContext

Standard property: servlet context object.

SERVLET_REQUEST - Static variable in interface javax.xml.ws.handler.MessageContext

Standard property: servlet request object.

SERVLET_RESPONSE - Static variable in interface javax.xml.ws.handler.MessageContext

Standard property: servlet response object.

SESSION_MAINTAIN_PROPERTY - Static variable in interface javax.xml.ws.BindingProvider

Standard property: This boolean property is used by a service client to indicate whether or not it wants to participate in a session with a service endpoint.

set(Object, int) - Method in class java.awt.image.renderable.ParameterBlock

Replaces an Object in the list of parameters.

set(byte, int) - Method in class java.awt.image.renderable.ParameterBlock

Replaces an Object in the list of parameters with a Byte.

set(char, int) - Method in class java.awt.image.renderable.ParameterBlock

Replaces an Object in the list of parameters with a Character.

set(short, int) - Method in class java.awt.image.renderable.ParameterBlock

Replaces an Object in the list of parameters with a Short.

set(int, int) - Method in class java.awt.image.renderable.ParameterBlock

Replaces an Object in the list of parameters with an Integer.

set(long, int) - Method in class java.awt.image.renderable.ParameterBlock

Replaces an Object in the list of parameters with a Long.

set(float, int) - Method in class java.awt.image.renderable.ParameterBlock

Replaces an Object in the list of parameters with a Float.

set(double, int) - Method in class java.awt.image.renderable.ParameterBlock

Replaces an Object in the list of parameters with a Double.

set(int, int, int, int) - Method in class java.awt.Insets

Set top, left, bottom, and right to the specified values

set(JobAttributes) - Method in class java.awt.JobAttributes

Sets all of the attributes of this JobAttributes to the same values as the attributes of obj.

set(PageAttributes) - Method in class java.awt.PageAttributes

Sets all of the attributes of this PageAttributes to the same values as the attributes of obj.

set(Object, int, Object) - Static method in class java.lang.reflect.Array

Sets the value of the indexed component of the specified array object to the specified new value.

set(Object, Object) - Method in class java.lang.reflect.Field

Sets the field represented by this Field object on the specified object argument to the specified new value.

set(T) - Method in class java.lang.ThreadLocal

Sets the current thread's copy of this thread-local variable to the specified value.

set(int, E) - Method in class java.util.AbstractList

Replaces the element at the specified position in this list with the specified element (optional operation).

set(int, E) - Method in class java.util.AbstractSequentialList

Replaces the element at the specified position in this list with the specified element (optional operation).

set(int, E) - Method in class java.util.ArrayList

Replaces the element at the specified position in this list with the specified element.

set(int) - Method in class java.util.BitSet

Sets the bit at the specified index to true.

set(int, boolean) - Method in class java.util.BitSet

Sets the bit at the specified index to the specified value.

set(int, int) - Method in class java.util.BitSet

Sets the bits from the specified fromIndex (inclusive) to the specified toIndex (exclusive) to true.

set(int, int, boolean) - Method in class java.util.BitSet

Sets the bits from the specified fromIndex (inclusive) to the specified toIndex (exclusive) to the specified value.

set(int, int) - Method in class java.util.Calendar.Builder

Sets the field parameter to the given value.

set(int, int) - Method in class java.util.Calendar

Sets the given calendar field to the given value.

set(int, int, int) - Method in class java.util.Calendar

Sets the values for the calendar fields YEAR, MONTH, and DAY_OF_MONTH.

set(int, int, int, int, int) - Method in class java.util.Calendar

Sets the values for the calendar fields YEAR, MONTH, DAY_OF_MONTH, HOUR_OF_DAY, and MINUTE.

set(int, int, int, int, int, int) - Method in class java.util.Calendar

Sets the values for the fields YEAR, MONTH, DAY_OF_MONTH, HOUR_OF_DAY, MINUTE, and SECOND.

set(boolean) - Method in class java.util.concurrent.atomic.AtomicBoolean

Unconditionally sets to the given value.

set(int) - Method in class java.util.concurrent.atomic.AtomicInteger

Sets to the given value.

set(int, int) - Method in class java.util.concurrent.atomic.AtomicIntegerArray

Sets the element at position i to the given value.

set(T, int) - Method in class java.util.concurrent.atomic.AtomicIntegerFieldUpdater

Sets the field of the given object managed by this updater to the given updated value.

set(long) - Method in class java.util.concurrent.atomic.AtomicLong

Sets to the given value.

set(int, long) - Method in class java.util.concurrent.atomic.AtomicLongArray

Sets the element at position i to the given value.

set(T, long) - Method in class java.util.concurrent.atomic.AtomicLongFieldUpdater

Sets the field of the given object managed by this updater to the given updated value.

set(V, boolean) - Method in class java.util.concurrent.atomic.AtomicMarkableReference

Unconditionally sets the value of both the reference and mark.

set(V) - Method in class java.util.concurrent.atomic.AtomicReference

Sets to the given value.

set(int, E) - Method in class java.util.concurrent.atomic.AtomicReferenceArray

Sets the element at position i to the given value.

set(T, V) - Method in class java.util.concurrent.atomic.AtomicReferenceFieldUpdater

Sets the field of the given object managed by this updater to the given updated value.

set(V, int) - Method in class java.util.concurrent.atomic.AtomicStampedReference

Unconditionally sets the value of both the reference and stamp.

set(int, E) - Method in class java.util.concurrent.CopyOnWriteArrayList

Replaces the element at the specified position in this list with the specified element.

set(V) - Method in class java.util.concurrent.FutureTask

Sets the result of this future to the given value unless this future has already been set or has been cancelled.

set(int, E) - Method in class java.util.LinkedList

Replaces the element at the specified position in this list with the specified element.

set(int, E) - Method in interface java.util.List

Replaces the element at the specified position in this list with the specified element (optional operation).

set(E) - Method in interface java.util.ListIterator

Replaces the last element returned by ListIterator.next() or ListIterator.previous() with the specified element (optional operation).

Set<E> - Interface in java.util

A collection that contains no duplicate elements.

set(int, E) - Method in class java.util.Vector

Replaces the element at the specified position in this Vector with the specified element.

set(String, String) - Method in class javax.activation.MimeTypeParameterList

Set the value to be associated with the given name, replacing any previous association.

set(int, Attribute) - Method in class javax.management.AttributeList

Sets the element at the position specified to be the attribute specified.

set(int, Object) - Method in class javax.management.AttributeList

Replaces the element at the specified position in this list with the specified element.

set(int, Role) - Method in class javax.management.relation.RoleList

Sets the element at the position specified to be the role specified.

set(int, Object) - Method in class javax.management.relation.RoleList

set(int, RoleUnresolved) - Method in class javax.management.relation.RoleUnresolvedList

Sets the element at the position specified to be the unresolved role specified.

set(int, Object) - Method in class javax.management.relation.RoleUnresolvedList

set(int, Object) - Method in interface javax.naming.directory.Attribute

Sets an attribute value in the ordered list of attribute values.

set(int, Object) - Method in class javax.naming.directory.BasicAttribute

set(int, E) - Method in class javax.swing.DefaultListModel

Replaces the element at the specified position in this list with the specified element.

set2DigitYearStart(Date) - Method in class java.text.SimpleDateFormat

Sets the 100-year period 2-digit years will be interpreted as being in to begin on the date the user specifies.

set_as_default() - Method in interface org.omg.CORBA.DynUnion

Deprecated.

Determines whether the discriminator associated with this union has been assigned a valid default value.

set_as_default(boolean) - Method in interface org.omg.CORBA.DynUnion

Deprecated.

Determines whether the discriminator associated with this union gets assigned a valid default value.

set_as_string(String) - Method in class org.omg.DynamicAny._DynEnumStub

Sets the value of the DynEnum to the enumerated value whose IDL identifier is passed in the value parameter.

set_as_string(String) - Method in interface org.omg.DynamicAny.DynEnumOperations

Sets the value of the DynEnum to the enumerated value whose IDL identifier is passed in the value parameter.

set_as_ulong(int) - Method in class org.omg.DynamicAny._DynEnumStub

Sets the value of the DynEnum as the enumerated value's ordinal value.

set_as_ulong(int) - Method in interface org.omg.DynamicAny.DynEnumOperations

Sets the value of the DynEnum as the enumerated value's ordinal value.

set_boxed_value(Any) - Method in interface org.omg.DynamicAny.DynValueBoxOperations

Replaces the boxed value with the specified value.

set_boxed_value_as_dyn_any(DynAny) - Method in interface org.omg.DynamicAny.DynValueBoxOperations

Replaces the boxed value with the value contained in the parameter.

set_delegate(Object) - Method in class org.omg.CORBA_2_3.ORB

set_discriminator(DynAny) - Method in class org.omg.DynamicAny._DynUnionStub

Sets the discriminator of the DynUnion to the specified value.

set_discriminator(DynAny) - Method in interface org.omg.DynamicAny.DynUnionOperations

Sets the discriminator of the DynUnion to the specified value.

set_elements(Any[]) - Method in interface org.omg.CORBA.DynArray

Deprecated.

Sets the value of this DynArray object to the given array.

set_elements(Any[]) - Method in interface org.omg.CORBA.DynSequence

Deprecated.

Sets the values of all elements in this sequence with the given array.

set_elements(Any[]) - Method in class org.omg.DynamicAny._DynArrayStub

Sets the DynArray to contain the passed elements.

set_elements(Any[]) - Method in class org.omg.DynamicAny._DynSequenceStub

Sets the elements of a sequence.

set_elements(Any[]) - Method in interface org.omg.DynamicAny.DynArrayOperations

Sets the DynArray to contain the passed elements.

set_elements(Any[]) - Method in interface org.omg.DynamicAny.DynSequenceOperations

Sets the elements of a sequence.

set_elements_as_dyn_any(DynAny[]) - Method in class org.omg.DynamicAny._DynArrayStub

Sets the DynArray to contain the passed elements.

set_elements_as_dyn_any(DynAny[]) - Method in class org.omg.DynamicAny._DynSequenceStub

Sets the elements of a sequence using DynAnys.

set_elements_as_dyn_any(DynAny[]) - Method in interface org.omg.DynamicAny.DynArrayOperations

Sets the DynArray to contain the passed elements.

set_elements_as_dyn_any(DynAny[]) - Method in interface org.omg.DynamicAny.DynSequenceOperations

Sets the elements of a sequence using DynAnys.

set_exception(Any) - Method in class org.omg.CORBA.ServerRequest

Throws an org.omg.CORBA.NO_IMPLEMENT exception.

set_length(int) - Method in class org.omg.DynamicAny._DynSequenceStub

Sets the length of the sequence.

set_length(int) - Method in interface org.omg.DynamicAny.DynSequenceOperations

Sets the length of the sequence.

set_members(NameValuePair[]) - Method in interface org.omg.CORBA.DynStruct

Deprecated.

Set the members of the struct.

set_members(NameValuePair[]) - Method in interface org.omg.CORBA.DynValue

Deprecated.

Sets the members of the value object this DynValue object represents to the given array of NameValuePair objects.

set_members(NameValuePair[]) - Method in class org.omg.DynamicAny._DynStructStub

Initializes the struct data value associated with a DynStruct object from a sequence of NameValuePairs.

set_members(NameValuePair[]) - Method in class org.omg.DynamicAny._DynValueStub

Initializes the value type's members from a sequence of NameValuePairs.

set_members(NameValuePair[]) - Method in interface org.omg.DynamicAny.DynStructOperations

Initializes the struct data value associated with a DynStruct object from a sequence of NameValuePairs.

set_members(NameValuePair[]) - Method in interface org.omg.DynamicAny.DynValueOperations

Initializes the value type's members from a sequence of NameValuePairs.

set_members_as_dyn_any(NameDynAnyPair[]) - Method in class org.omg.DynamicAny._DynStructStub

Initializes the struct data value associated with a DynStruct object from a sequence of NameDynAnyPairs.

set_members_as_dyn_any(NameDynAnyPair[]) - Method in class org.omg.DynamicAny._DynValueStub

Initializes the value type's members from a sequence of NameDynAnyPairs.

set_members_as_dyn_any(NameDynAnyPair[]) - Method in interface org.omg.DynamicAny.DynStructOperations

Initializes the struct data value associated with a DynStruct object from a sequence of NameDynAnyPairs.

set_members_as_dyn_any(NameDynAnyPair[]) - Method in interface org.omg.DynamicAny.DynValueOperations

Initializes the value type's members from a sequence of NameDynAnyPairs.

set_one_value(String, Any) - Method in class org.omg.CORBA.Context

Creates a NamedValue object and adds it to this Context object.

SET_OVERRIDE - Static variable in class org.omg.CORBA.SetOverrideType

The SetOverrideType constant for the enum value SET_OVERRIDE.

set_parameters(String[], Properties) - Method in class org.omg.CORBA.ORB

Allows the ORB implementation to be initialized with the given parameters and properties.

set_parameters(Applet, Properties) - Method in class org.omg.CORBA.ORB

Allows the ORB implementation to be initialized with the given applet and parameters.

set_policy_override(Object, Policy[], SetOverrideType) - Method in class org.omg.CORBA.portable.Delegate

Associates the policies passed in with a newly created object reference that it returns.

set_result(Any) - Method in class org.omg.CORBA.ServerRequest

Throws an org.omg.CORBA.NO_IMPLEMENT exception.

set_return_type(TypeCode) - Method in class org.omg.CORBA.Request

Sets the typecode for the return value of the method.

set_servant(Servant) - Method in interface org.omg.PortableServer.POAOperations

This operation registers the specified servant with the POA as the default servant.

set_servant_manager(ServantManager) - Method in interface org.omg.PortableServer.POAOperations

This operation sets the default servant manager associated with the POA.

set_slot(int, Any) - Method in interface org.omg.PortableInterceptor.CurrentOperations

Sets data in a slot.

set_slot(int, Any) - Method in interface org.omg.PortableInterceptor.ServerRequestInfoOperations

Allows an Interceptor to set a slot in the PortableInterceptor.Current that is in the scope of the request.

set_to_default_member() - Method in class org.omg.DynamicAny._DynUnionStub

Sets the discriminator to a value that is consistent with the value of the default case of a union.

set_to_default_member() - Method in interface org.omg.DynamicAny.DynUnionOperations

Sets the discriminator to a value that is consistent with the value of the default case of a union.

set_to_no_active_member() - Method in class org.omg.DynamicAny._DynUnionStub

Sets the discriminator to a value that does not correspond to any of the unions case labels.

set_to_no_active_member() - Method in interface org.omg.DynamicAny.DynUnionOperations

Sets the discriminator to a value that does not correspond to any of the unions case labels.

set_to_null() - Method in class org.omg.DynamicAny._DynValueStub

Changes the representation of a DynValueCommon to a null value type.

set_to_null() - Method in interface org.omg.DynamicAny.DynValueCommonOperations

Changes the representation of a DynValueCommon to a null value type.

set_to_value() - Method in class org.omg.DynamicAny._DynValueStub

Replaces a null value type with a newly constructed value.

set_to_value() - Method in interface org.omg.DynamicAny.DynValueCommonOperations

Replaces a null value type with a newly constructed value.

set_value(byte[]) - Method in interface org.omg.CORBA.DynFixed

Deprecated.

Sets the given fixed type instance as the value for this DynFixed object.

set_value(String) - Method in class org.omg.DynamicAny._DynFixedStub

Sets the value of the DynFixed.

set_value(String) - Method in interface org.omg.DynamicAny.DynFixedOperations

Sets the value of the DynFixed.

set_values(NVList) - Method in class org.omg.CORBA.Context

I Sets one or more property values in this Context object.

setAccelerationPriority(float) - Method in class java.awt.Image

Sets a hint for this image about how important acceleration is.

setAccelerator(KeyStroke) - Method in class javax.swing.JMenu

setAccelerator is not defined for JMenu.

setAccelerator(KeyStroke) - Method in class javax.swing.JMenuItem

Sets the key combination which invokes the menu item's action listeners without navigating the menu hierarchy.

setAcceptAllFileFilterUsed(boolean) - Method in class javax.swing.JFileChooser

Determines whether the AcceptAll FileFilter is used as an available choice in the choosable filter list.

setAccessible(AccessibleObject[], boolean) - Static method in class java.lang.reflect.AccessibleObject

Convenience method to set the accessible flag for an array of objects with a single security check (for efficiency).

setAccessible(boolean) - Method in class java.lang.reflect.AccessibleObject

Set the accessible flag for this object to the indicated boolean value.

setAccessibleCaption(Accessible) - Method in interface javax.accessibility.AccessibleTable

Sets the caption for the table.

setAccessibleCaption(Accessible) - Method in class javax.swing.JTable.AccessibleJTable

Sets the caption for the table.

setAccessibleColumnDescription(int, Accessible) - Method in interface javax.accessibility.AccessibleTable

Sets the description text of the specified column in the table.

setAccessibleColumnDescription(int, Accessible) - Method in class javax.swing.JTable.AccessibleJTable

Sets the description text of the specified column of the table.

setAccessibleColumnHeader(AccessibleTable) - Method in interface javax.accessibility.AccessibleTable

Sets the column headers.

setAccessibleColumnHeader(AccessibleTable) - Method in class javax.swing.JTable.AccessibleJTable

Sets the column headers as an AccessibleTable.

setAccessibleDescription(String) - Method in class javax.accessibility.AccessibleContext

Sets the accessible description of this object.

setAccessibleDescription(String) - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

setAccessibleDescription(String) - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Sets the accessible description of this object.

setAccessibleDescription(String) - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Set the accessible description of this object.

setAccessibleDescription(String) - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

setAccessibleIconDescription(String) - Method in interface javax.accessibility.AccessibleIcon

Sets the description of the icon.

setAccessibleIconDescription(String) - Method in class javax.swing.ImageIcon.AccessibleImageIcon

Sets the description of the icon.

setAccessibleName(String) - Method in class javax.accessibility.AccessibleContext

Sets the localized accessible name of this object.

setAccessibleName(String) - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

setAccessibleName(String) - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Sets the localized accessible name of this object.

setAccessibleName(String) - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Set the localized accessible name of this object.

setAccessibleName(String) - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

setAccessibleParent(Accessible) - Method in class javax.accessibility.AccessibleContext

Sets the Accessible parent of this object.

setAccessibleRowDescription(int, Accessible) - Method in interface javax.accessibility.AccessibleTable

Sets the description text of the specified row of the table.

setAccessibleRowDescription(int, Accessible) - Method in class javax.swing.JTable.AccessibleJTable

Sets the description text of the specified row of the table.

setAccessibleRowHeader(AccessibleTable) - Method in interface javax.accessibility.AccessibleTable

Sets the row headers.

setAccessibleRowHeader(AccessibleTable) - Method in class javax.swing.JTable.AccessibleJTable

Sets the row headers as an AccessibleTable.

setAccessibleSummary(Accessible) - Method in interface javax.accessibility.AccessibleTable

Sets the summary description of the table

setAccessibleSummary(Accessible) - Method in class javax.swing.JTable.AccessibleJTable

Sets the summary description of the table.

setAccessory(JComponent) - Method in class javax.swing.JFileChooser

Sets the accessory component.

setAcl(List<AclEntry>) - Method in interface java.nio.file.attribute.AclFileAttributeView

Updates (replace) the access control list.

setAction(Action) - Method in class javax.swing.AbstractButton

Sets the Action.

setAction(Action) - Method in class javax.swing.JComboBox

Sets the Action for the ActionEvent source.

setAction(Action) - Method in class javax.swing.JTextField

Sets the Action for the ActionEvent source.

setActionCommand(String) - Method in class java.awt.Button

Sets the command name for the action event fired by this button.

setActionCommand(String) - Method in class java.awt.MenuItem

Sets the command name of the action event that is fired by this menu item.

setActionCommand(String) - Method in class java.awt.TrayIcon

Sets the command name for the action event fired by this tray icon.

setActionCommand(String) - Method in class javax.swing.AbstractButton

Sets the action command for this button.

setActionCommand(String) - Method in interface javax.swing.ButtonModel

Sets the action command string that gets sent as part of the ActionEvent when the button is triggered.

setActionCommand(String) - Method in class javax.swing.DefaultButtonModel

Sets the action command string that gets sent as part of the ActionEvent when the button is triggered.

setActionCommand(String) - Method in class javax.swing.JComboBox

Sets the action command that should be included in the event sent to action listeners.

setActionCommand(String) - Method in class javax.swing.JTextField

Sets the command string used for action events.

setActionCommand(String) - Method in class javax.swing.Timer

Sets the string that will be delivered as the action command in ActionEvents fired by this timer.

setActionMap(ActionMap) - Method in class javax.swing.JComponent

Sets the ActionMap to am.

setActivationDesc(ActivationID, ActivationDesc) - Method in interface java.rmi.activation.ActivationSystem

Set the activation descriptor, desc for the object with the activation identifier, id.

setActivationGroupDesc(ActivationGroupID, ActivationGroupDesc) - Method in interface java.rmi.activation.ActivationSystem

Set the activation group descriptor, desc for the object with the activation group identifier, id.

setActive(boolean) - Method in class java.awt.dnd.DropTarget

Sets the DropTarget active if true, inactive if false.

setActor(String) - Method in interface javax.xml.soap.SOAPHeaderElement

Sets the actor associated with this SOAPHeaderElement object to the specified actor.

setAdapter(XmlAdapter) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

setAdapter(Class<A>, A) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

setAdapter(XmlAdapter) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

setAdapter(Class<A>, A) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

setAdapter(XmlAdapter) - Method in interface javax.xml.bind.Marshaller

Associates a configured instance of XmlAdapter with this marshaller.

setAdapter(Class<A>, A) - Method in interface javax.xml.bind.Marshaller

Associates a configured instance of XmlAdapter with this marshaller.

setAdapter(XmlAdapter) - Method in interface javax.xml.bind.Unmarshaller

Associates a configured instance of XmlAdapter with this unmarshaller.

setAdapter(Class<A>, A) - Method in interface javax.xml.bind.Unmarshaller

Associates a configured instance of XmlAdapter with this unmarshaller.

setAddress(InetAddress) - Method in class java.net.DatagramPacket

Sets the IP address of the machine to which this datagram is being sent.

setAlgorithmConstraints(AlgorithmConstraints) - Method in class javax.net.ssl.SSLParameters

Sets the cryptographic algorithm constraints, which will be used in addition to any configured by the runtime environment.

setAlignment(int) - Method in class java.awt.FlowLayout

Sets the alignment for this layout.

setAlignment(int) - Method in class java.awt.Label

Sets the alignment for this label to the specified alignment.

setAlignment(MutableAttributeSet, int) - Static method in class javax.swing.text.StyleConstants

Sets alignment.

setAlignmentX(float) - Method in class javax.swing.JComponent

Sets the the vertical alignment.

setAlignmentY(float) - Method in class javax.swing.JComponent

Sets the the horizontal alignment.

setAlignOnBaseline(boolean) - Method in class java.awt.FlowLayout

Sets whether or not components should be vertically aligned along their baseline.

setAll(T[], IntFunction<? extends T>) - Static method in class java.util.Arrays

Set all elements of the specified array, using the provided generator function to compute each element.

setAll(int[], IntUnaryOperator) - Static method in class java.util.Arrays

Set all elements of the specified array, using the provided generator function to compute each element.

setAll(long[], IntToLongFunction) - Static method in class java.util.Arrays

Set all elements of the specified array, using the provided generator function to compute each element.

setAll(double[], IntToDoubleFunction) - Static method in class java.util.Arrays

Set all elements of the specified array, using the provided generator function to compute each element.

setAllocation(Shape) - Method in class javax.swing.text.AsyncBoxView.ChildLocator

Copy the currently allocated shape into the Rectangle used to store the current allocation.

setAllowsChildren(boolean) - Method in class javax.swing.tree.DefaultMutableTreeNode

Determines whether or not this node is allowed to have children.

setAllowsInvalid(boolean) - Method in class javax.swing.text.DefaultFormatter

Sets whether or not the value being edited is allowed to be invalid for a length of time (that is, stringToValue throws a ParseException).

setAllowUserInteraction(boolean) - Method in class java.net.URLConnection

Set the value of the allowUserInteraction field of this URLConnection.

setAltName(Name) - Method in exception javax.naming.CannotProceedException

Sets the altName field of this exception.

setAltNameCtx(Context) - Method in exception javax.naming.CannotProceedException

Sets the altNameCtx field of this exception.

setAlwaysOnTop(boolean) - Method in class java.awt.Window

Sets whether this window should always be above other windows.

setAmPmStrings(String[]) - Method in class java.text.DateFormatSymbols

Sets ampm strings.

setAnchorSelectionIndex(int) - Method in class javax.swing.DefaultListSelectionModel

Set the anchor selection index, leaving all selection values unchanged.

setAnchorSelectionIndex(int) - Method in interface javax.swing.ListSelectionModel

Set the anchor selection index.

setAnchorSelectionPath(TreePath) - Method in class javax.swing.JTree

Sets the path identified as the anchor.

setAngleExtent(double) - Method in class java.awt.geom.Arc2D.Double

Sets the angular extent of this arc to the specified double value.

setAngleExtent(double) - Method in class java.awt.geom.Arc2D.Float

Sets the angular extent of this arc to the specified double value.

setAngleExtent(double) - Method in class java.awt.geom.Arc2D

Sets the angular extent of this arc to the specified double value.

setAngles(double, double, double, double) - Method in class java.awt.geom.Arc2D

Sets the starting angle and angular extent of this arc using two sets of coordinates.

setAngles(Point2D, Point2D) - Method in class java.awt.geom.Arc2D

Sets the starting angle and angular extent of this arc using two points.

setAngleStart(double) - Method in class java.awt.geom.Arc2D.Double

Sets the starting angle of this arc to the specified double value.

setAngleStart(double) - Method in class java.awt.geom.Arc2D.Float

Sets the starting angle of this arc to the specified double value.

setAngleStart(double) - Method in class java.awt.geom.Arc2D

Sets the starting angle of this arc to the specified double value.

setAngleStart(Point2D) - Method in class java.awt.geom.Arc2D

Sets the starting angle of this arc to the angle that the specified point defines relative to the center of this arc.

setAnimated(boolean) - Method in class java.awt.image.MemoryImageSource

Changes this memory image into a multi-frame animation or a single-frame static image depending on the animated parameter.

setAnimationIndex(int) - Method in class javax.swing.plaf.basic.BasicProgressBarUI

Sets the index of the current animation frame to the specified value and requests that the progress bar be repainted.

setAnimationIndex(int) - Method in class javax.swing.plaf.synth.SynthProgressBarUI

Sets the index of the current animation frame to the specified value and requests that the progress bar be repainted.

setAnyPolicyInhibited(boolean) - Method in class java.security.cert.PKIXParameters

Sets state to determine if the any policy OID should be processed if it is included in a certificate.

setApproveButtonMnemonic(int) - Method in class javax.swing.JFileChooser

Sets the approve button's mnemonic using a numeric keycode.

setApproveButtonMnemonic(char) - Method in class javax.swing.JFileChooser

Sets the approve button's mnemonic using a character.

setApproveButtonText(String) - Method in class javax.swing.JFileChooser

Sets the text used in the ApproveButton in the FileChooserUI.

setApproveButtonToolTipText(String) - Method in class javax.swing.JFileChooser

Sets the tooltip text used in the ApproveButton.

setArc(double, double, double, double, double, double, int) - Method in class java.awt.geom.Arc2D.Double

Sets the location, size, angular extents, and closure type of this arc to the specified double values.

setArc(double, double, double, double, double, double, int) - Method in class java.awt.geom.Arc2D.Float

Sets the location, size, angular extents, and closure type of this arc to the specified double values.

setArc(double, double, double, double, double, double, int) - Method in class java.awt.geom.Arc2D

Sets the location, size, angular extents, and closure type of this arc to the specified double values.

setArc(Point2D, Dimension2D, double, double, int) - Method in class java.awt.geom.Arc2D

Sets the location, size, angular extents, and closure type of this arc to the specified values.

setArc(Rectangle2D, double, double, int) - Method in class java.awt.geom.Arc2D

Sets the location, size, angular extents, and closure type of this arc to the specified values.

setArc(Arc2D) - Method in class java.awt.geom.Arc2D

Sets this arc to be the same as the specified arc.

setArcByCenter(double, double, double, double, double, int) - Method in class java.awt.geom.Arc2D

Sets the position, bounds, angular extents, and closure type of this arc to the specified values.

setArcByTangent(Point2D, Point2D, Point2D, double) - Method in class java.awt.geom.Arc2D

Sets the position, bounds, and angular extents of this arc to the specified value.

setArchive(boolean) - Method in interface java.nio.file.attribute.DosFileAttributeView

Updates the value of the archive attribute.

setArcType(int) - Method in class java.awt.geom.Arc2D

Sets the closure type of this arc to the specified value: OPEN, CHORD, or PIE.

setAreaOfInterest(Shape) - Method in class java.awt.image.renderable.RenderContext

Sets the current area of interest.

setArmed(boolean) - Method in interface javax.swing.ButtonModel

Marks the button as armed or unarmed.

setArmed(boolean) - Method in class javax.swing.DefaultButtonModel

Marks the button as armed or unarmed.

setArmed(boolean) - Method in class javax.swing.JMenuItem

Identifies the menu item as "armed".

setArray(int, Array) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to the given java.sql.Array object.

setArray(int, Array) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to an Array object in the Java programming language.

setArray(int, Array) - Method in interface javax.sql.RowSet

Sets the designated parameter in this RowSet object's command with the given Array value.

setAsciiStream(String, InputStream, int) - Method in interface java.sql.CallableStatement

Sets the designated parameter to the given input stream, which will have the specified number of bytes.

setAsciiStream(String, InputStream, long) - Method in interface java.sql.CallableStatement

Sets the designated parameter to the given input stream, which will have the specified number of bytes.

setAsciiStream(String, InputStream) - Method in interface java.sql.CallableStatement

Sets the designated parameter to the given input stream.

setAsciiStream(long) - Method in interface java.sql.Clob

Retrieves a stream to be used to write Ascii characters to the CLOB value that this Clob object represents, starting at position pos.

setAsciiStream(int, InputStream, int) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to the given input stream, which will have the specified number of bytes.

setAsciiStream(int, InputStream, long) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to the given input stream, which will have the specified number of bytes.

setAsciiStream(int, InputStream) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to the given input stream.

setAsciiStream(int, InputStream, int) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given java.io.InputStream object, which will have the specified number of bytes.

setAsciiStream(int, InputStream) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter in this RowSet object's command to the given input stream.

setAsciiStream(String, InputStream, int) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given input stream, which will have the specified number of bytes.

setAsciiStream(String, InputStream) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given input stream.

setAsciiStream(long) - Method in class javax.sql.rowset.serial.SerialClob

Retrieves a stream to be used to write Ascii characters to the CLOB value that this SerialClob object represents, starting at position pos.

setAsciiStream(int, InputStream, int) - Method in interface javax.sql.RowSet

Sets the designated parameter in this RowSet object's command to the given java.io.InputStream value.

setAsciiStream(String, InputStream, int) - Method in interface javax.sql.RowSet

Sets the designated parameter to the given input stream, which will have the specified number of bytes.

setAsciiStream(int, InputStream) - Method in interface javax.sql.RowSet

Sets the designated parameter in this RowSet object's command to the given input stream.

setAsciiStream(String, InputStream) - Method in interface javax.sql.RowSet

Sets the designated parameter to the given input stream.

setAsksAllowsChildren(boolean) - Method in class javax.swing.tree.DefaultTreeModel

Sets whether or not to test leafness by asking getAllowsChildren() or isLeaf() to the TreeNodes.

setAsText(String) - Method in interface java.beans.PropertyEditor

Set the property value by parsing a given String.

setAsText(String) - Method in class java.beans.PropertyEditorSupport

Sets the property value by parsing a given String.

setAsynchronousLoadPriority(int) - Method in class javax.swing.text.AbstractDocument

Sets the asynchronous loading priority.

setAttachmentMarshaller(AttachmentMarshaller) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

setAttachmentMarshaller(AttachmentMarshaller) - Method in interface javax.xml.bind.Marshaller

Associate a context that enables binary data within an XML document to be transmitted as XML-binary optimized attachment.

setAttachmentUnmarshaller(AttachmentUnmarshaller) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

setAttachmentUnmarshaller(AttachmentUnmarshaller) - Method in interface javax.xml.bind.Unmarshaller

Associate a context that resolves cid's, content-id URIs, to binary data passed as attachments.

setAttribute(Path, String, Object, LinkOption...) - Static method in class java.nio.file.Files

Sets the value of a file attribute.

setAttribute(Path, String, Object, LinkOption...) - Method in class java.nio.file.spi.FileSystemProvider

Sets the value of a file attribute.

setAttribute(String, String) - Method in class javax.imageio.metadata.IIOMetadataNode

setAttribute(Attribute) - Method in interface javax.management.DynamicMBean

Set the value of a specific attribute of the Dynamic MBean.

setAttribute(ObjectName, Attribute) - Method in interface javax.management.MBeanServer

setAttribute(ObjectName, Attribute) - Method in interface javax.management.MBeanServerConnection

Sets the value of a specific attribute of a named MBean.

setAttribute(Attribute) - Method in class javax.management.modelmbean.RequiredModelMBean

Sets the value of a specific attribute of a named ModelMBean.

setAttribute(ObjectName, MarshalledObject, Subject) - Method in interface javax.management.remote.rmi.RMIConnection

Handles the method MBeanServerConnection.setAttribute(ObjectName, Attribute).

setAttribute(ObjectName, MarshalledObject, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl

setAttribute(ObjectName, MarshalledObject, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub

setAttribute(Attribute) - Method in class javax.management.StandardMBean

setAttribute(String, Object, int) - Method in interface javax.script.ScriptContext

Sets the value of an attribute in a given scope.

setAttribute(String, Object, int) - Method in class javax.script.SimpleScriptContext

Sets the value of an attribute in a given scope.

setAttribute(String, Object) - Method in class javax.xml.parsers.DocumentBuilderFactory

Allows the user to set specific attributes on the underlying implementation.

setAttribute(String, Object) - Method in class javax.xml.transform.TransformerFactory

Allows the user to set specific attributes on the underlying implementation.

setAttribute(String, String) - Method in interface org.w3c.dom.Element

Adds a new attribute.

setAttribute(int, String, String, String, String, String) - Method in class org.xml.sax.helpers.AttributesImpl

Set an attribute in the list.

setAttributeList(AttributeList) - Method in class org.xml.sax.helpers.AttributeListImpl

Deprecated.

Set the attribute list, discarding previous contents.

setAttributeNode(Attr) - Method in class javax.imageio.metadata.IIOMetadataNode

setAttributeNode(Attr) - Method in interface org.w3c.dom.Element

Adds a new attribute node.

setAttributeNodeNS(Attr) - Method in class javax.imageio.metadata.IIOMetadataNode

Equivalent to setAttributeNode(newAttr).

setAttributeNodeNS(Attr) - Method in interface org.w3c.dom.Element

Adds a new attribute.

setAttributeNS(String, String, String) - Method in class javax.imageio.metadata.IIOMetadataNode

Equivalent to setAttribute(qualifiedName, value).

setAttributeNS(String, String, String) - Method in interface org.w3c.dom.Element

Adds a new attribute.

setAttributes(int, int, AttributeSet) - Method in interface javax.accessibility.AccessibleEditableText

Sets attributes for the text between two indices.

setAttributes(AttributeList) - Method in interface javax.management.DynamicMBean

Sets the values of several attributes of the Dynamic MBean.

setAttributes(ObjectName, AttributeList) - Method in interface javax.management.MBeanServer

setAttributes(ObjectName, AttributeList) - Method in interface javax.management.MBeanServerConnection

Sets the values of several attributes of a named MBean.

setAttributes(AttributeList) - Method in class javax.management.modelmbean.RequiredModelMBean

Sets the values of an array of attributes of this ModelMBean.

setAttributes(ObjectName, MarshalledObject, Subject) - Method in interface javax.management.remote.rmi.RMIConnection

Handles the method MBeanServerConnection.setAttributes(ObjectName, AttributeList).

setAttributes(ObjectName, MarshalledObject, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl

setAttributes(ObjectName, MarshalledObject, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub

setAttributes(AttributeList) - Method in class javax.management.StandardMBean

setAttributes(Attributes) - Method in class javax.naming.directory.SearchResult

Sets the attributes of this search result to attrs.

setAttributes(int, int, AttributeSet) - Method in class javax.swing.JSpinner.AccessibleJSpinner

Sets attributes for the text between two indices.

setAttributes(int, int, AttributeSet) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Sets attributes for the text between two indices.

setAttributes(Attributes) - Method in class org.xml.sax.ext.Attributes2Impl

Copy an entire Attributes object.

setAttributes(Attributes) - Method in class org.xml.sax.helpers.AttributesImpl

Copy an entire Attributes object.

setAuthorityKeyIdentifier(byte[]) - Method in class java.security.cert.X509CertSelector

Sets the authorityKeyIdentifier criterion.

setAuthorized(boolean) - Method in class javax.security.sasl.AuthorizeCallback

Sets whether the authorization is allowed.

setAuthorizedID(String) - Method in class javax.security.sasl.AuthorizeCallback

Sets the id of the authorized entity.

setAutoCommit(boolean) - Method in interface java.sql.Connection

Sets this connection's auto-commit mode to the given state.

setAutoCommit(boolean) - Method in interface javax.sql.rowset.JdbcRowSet

Each JdbcRowSet contains a Connection object from the original ResultSet or JDBC properties passed to it.

setAutoCreateColumnsFromModel(boolean) - Method in class javax.swing.JTable

Sets this table's autoCreateColumnsFromModel flag.

setAutoCreateContainerGaps(boolean) - Method in class javax.swing.GroupLayout

Sets whether a gap between the container and components that touch the border of the container should automatically be created.

setAutoCreateGaps(boolean) - Method in class javax.swing.GroupLayout

Sets whether a gap between components should automatically be created.

setAutoCreateRowSorter(boolean) - Method in class javax.swing.JTable

Specifies whether a RowSorter should be created for the table whenever its model changes.

setAutoDelay(int) - Method in class java.awt.Robot

Sets the number of milliseconds this Robot sleeps after generating an event.

setAutoFormSubmission(boolean) - Method in class javax.swing.text.html.HTMLEditorKit

Specifies if an html form submission is processed automatically or only FormSubmitEvent is fired.

setAutoIncrement(int, boolean) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Sets whether the designated column is automatically numbered, thus read-only, to the given boolean value.

setAutoIncrement(int, boolean) - Method in interface javax.sql.RowSetMetaData

Sets whether the designated column is automatically numbered, The default is for a RowSet object's columns not to be automatically numbered.

setAutoRequestFocus(boolean) - Method in class java.awt.Window

Sets whether this window should receive focus on subsequently being shown (with a call to setVisible(true)), or being moved to the front (with a call to Window.toFront()).

setAutoResizeMode(int) - Method in class javax.swing.JTable

Sets the table's auto resize mode when the table is resized.

setAutoscrolls(boolean) - Method in class javax.swing.JComponent

Sets the autoscrolls property.

setAutoWaitForIdle(boolean) - Method in class java.awt.Robot

Sets whether this Robot automatically invokes waitForIdle after generating an event.

setAxis(int) - Method in class javax.swing.text.BoxView

Sets the tile axis property.

setBackground(Color) - Method in class java.awt.Component.AccessibleAWTComponent

Sets the background color of this object.

setBackground(Color) - Method in class java.awt.Component

Sets the background color of this component.

setBackground(Color) - Method in class java.awt.Dialog

Sets the background color of this window.

setBackground(Color) - Method in class java.awt.Frame

Sets the background color of this window.

setBackground(Color) - Method in class java.awt.Graphics2D

Sets the background color for the Graphics2D context.

setBackground(Color) - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Set the background color of this object.

setBackground(Color) - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Sets the background color of this object.

setBackground(Color) - Method in class java.awt.TextComponent

Sets the background color of this text component.

setBackground(Color) - Method in class java.awt.Window

Sets the background color of this window.

setBackground(Color) - Method in interface javax.accessibility.AccessibleComponent

Sets the background color of this object.

setBackground(Color) - Method in class javax.swing.JComponent

Sets the background color of this component.

setBackground(Color) - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

setBackground(Color) - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Sets the background color of this object.

setBackground(Color) - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

Set the background color of this object.

setBackground(Color) - Method in class javax.swing.table.DefaultTableCellRenderer

Overrides JComponent.setBackground to assign the unselected-background color to the specified color.

setBackground(Color) - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

setBackground(Color) - Method in class javax.swing.text.LabelView

Sets the background color for the view.

setBackground(MutableAttributeSet, Color) - Static method in class javax.swing.text.StyleConstants

Sets the background color.

setBackground(Color) - Method in class javax.swing.tree.DefaultTreeCellRenderer

Subclassed to map ColorUIResources to null.

setBackgroundAt(int, Color) - Method in class javax.swing.JTabbedPane

Sets the background color at index to background which can be null, in which case the tab's background color will default to the background color of the tabbedpane.

setBackgroundNonSelectionColor(Color) - Method in class javax.swing.tree.DefaultTreeCellRenderer

Sets the background color to be used for non selected nodes.

setBackgroundSelectionColor(Color) - Method in class javax.swing.tree.DefaultTreeCellRenderer

Sets the color to use for the background if node is selected.

setBackingStoreEnabled(boolean) - Method in class javax.swing.JViewport

Deprecated.
As of Java 2 platform v1.3, replaced by setScrollMode().

setBase(URL) - Method in class javax.swing.text.html.HTMLDocument

Sets the location to resolve relative URLs against.

setBase(URL) - Method in class javax.swing.text.html.StyleSheet

Sets the base.

setBase64Content(InputStream, String) - Method in class javax.xml.soap.AttachmentPart

Sets the content of this attachment part from the Base64 source InputStream and sets the value of the Content-Type header to the value contained in contentType, This method would first decode the base64 input and write the resulting raw bytes to the attachment.

setBaseFontSize(int) - Method in class javax.swing.text.html.StyleSheet

Sets the base font size, with valid values between 1 and 7.

setBaseFontSize(String) - Method in class javax.swing.text.html.StyleSheet

Sets the base font size from the passed in String.

setBaseURI(String) - Method in class javax.xml.crypto.dom.DOMCryptoContext

setBaseURI(String) - Method in interface javax.xml.crypto.XMLCryptoContext

Sets the base URI.

setBaseURI(String) - Method in interface org.w3c.dom.ls.LSInput

The base URI to be used (see section 5.1.4 in [IETF RFC 2396]) for resolving a relative systemId to an absolute URI.

setBasicConstraints(int) - Method in class java.security.cert.X509CertSelector

Sets the basic constraints constraint.

setBasicSplitPaneUI(BasicSplitPaneUI) - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider

Sets the SplitPaneUI that is using the receiver.

setBeanContext(BeanContext) - Method in interface java.beans.beancontext.BeanContextChild

Objects that implement this interface, shall fire a java.beans.PropertyChangeEvent, with parameters: propertyName "beanContext", oldValue (the previous nesting BeanContext instance, or null), newValue (the current nesting BeanContext instance, or null).

setBeanContext(BeanContext) - Method in class java.beans.beancontext.BeanContextChildSupport

Sets the BeanContext for this BeanContextChildSupport.

setBeanInfoSearchPath(String[]) - Static method in class java.beans.Introspector

Change the list of package names that will be used for finding BeanInfo classes.

setBeginIndex(int) - Method in class java.text.FieldPosition

Sets the begin index.

setBidiLevel(MutableAttributeSet, int) - Static method in class javax.swing.text.StyleConstants

Sets the BidiLevel.

setBigDecimal(String, BigDecimal) - Method in interface java.sql.CallableStatement

Sets the designated parameter to the given java.math.BigDecimal value.

setBigDecimal(int, BigDecimal) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to the given java.math.BigDecimal value.

setBigDecimal(int, BigDecimal) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given java.lang.BigDecimal value.

setBigDecimal(String, BigDecimal) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given java.math.BigDecimal value.

setBigDecimal(int, BigDecimal) - Method in interface javax.sql.RowSet

Sets the designated parameter in this RowSet object's command to the given java.math.BigDeciaml value.

setBigDecimal(String, BigDecimal) - Method in interface javax.sql.RowSet

Sets the designated parameter to the given java.math.BigDecimal value.

setBinaryStream(long) - Method in interface java.sql.Blob

Retrieves a stream that can be used to write to the BLOB value that this Blob object represents.

setBinaryStream(String, InputStream, int) - Method in interface java.sql.CallableStatement

Sets the designated parameter to the given input stream, which will have the specified number of bytes.

setBinaryStream(String, InputStream, long) - Method in interface java.sql.CallableStatement

Sets the designated parameter to the given input stream, which will have the specified number of bytes.

setBinaryStream(String, InputStream) - Method in interface java.sql.CallableStatement

Sets the designated parameter to the given input stream.

setBinaryStream(int, InputStream, int) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to the given input stream, which will have the specified number of bytes.

setBinaryStream(int, InputStream, long) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to the given input stream, which will have the specified number of bytes.

setBinaryStream(int, InputStream) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to the given input stream.

setBinaryStream() - Method in interface java.sql.SQLXML

Retrieves a stream that can be used to write the XML value that this SQLXML instance represents.

setBinaryStream(int, InputStream, int) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given java.io.InputStream object, which will have the specified number of bytes.

setBinaryStream(int, InputStream) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter in this RowSet object's command to the given input stream.

setBinaryStream(String, InputStream, int) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given input stream, which will have the specified number of bytes.

setBinaryStream(String, InputStream) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given input stream.

setBinaryStream(long) - Method in class javax.sql.rowset.serial.SerialBlob

Retrieves a stream that can be used to write to the BLOB value that this Blob object represents.

setBinaryStream(int, InputStream, int) - Method in interface javax.sql.RowSet

Sets the designated parameter in this RowSet object's command to the given java.io.InputStream value.

setBinaryStream(String, InputStream, int) - Method in interface javax.sql.RowSet

Sets the designated parameter to the given input stream, which will have the specified number of bytes.

setBinaryStream(int, InputStream) - Method in interface javax.sql.RowSet

Sets the designated parameter in this RowSet object's command to the given input stream.

setBinaryStream(String, InputStream) - Method in interface javax.sql.RowSet

Sets the designated parameter to the given input stream.

setBindings(Bindings, int) - Method in class javax.script.AbstractScriptEngine

Sets the Bindings with the corresponding scope value in the context field.

setBindings(Bindings, int) - Method in interface javax.script.ScriptContext

Associates a Bindings instance with a particular scope in this ScriptContext.

setBindings(Bindings, int) - Method in interface javax.script.ScriptEngine

Sets a scope of named values to be used by scripts.

setBindings(Bindings) - Method in class javax.script.ScriptEngineManager

setBindings stores the specified Bindings in the globalScope field.

setBindings(Bindings, int) - Method in class javax.script.SimpleScriptContext

Sets a Bindings of attributes for the given scope.

setBit(int) - Method in class java.math.BigInteger

Returns a BigInteger whose value is equivalent to this BigInteger with the designated bit set.

setBitOffset(int) - Method in interface javax.imageio.stream.ImageInputStream

Sets the bit offset to an integer between 0 and 7, inclusive.

setBitOffset(int) - Method in class javax.imageio.stream.ImageInputStreamImpl

setBlinkRate(int) - Method in interface javax.swing.text.Caret

Sets the blink rate of the caret.

setBlinkRate(int) - Method in class javax.swing.text.DefaultCaret

Sets the caret blink rate.

setBlob(String, InputStream, long) - Method in interface java.sql.CallableStatement

Sets the designated parameter to a InputStream object.

setBlob(String, Blob) - Method in interface java.sql.CallableStatement

Sets the designated parameter to the given java.sql.Blob object.

setBlob(String, InputStream) - Method in interface java.sql.CallableStatement

Sets the designated parameter to a InputStream object.

setBlob(int, Blob) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to the given java.sql.Blob object.

setBlob(int, InputStream, long) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to a InputStream object.

setBlob(int, InputStream) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to a InputStream object.

setBlob(int, Blob) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given Blob object in the Java programming language.

setBlob(int, InputStream, long) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to a InputStream object.

setBlob(int, InputStream) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to a InputStream object.

setBlob(String, InputStream, long) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to a InputStream object.

setBlob(String, Blob) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given java.sql.Blob object.

setBlob(String, InputStream) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to a InputStream object.

setBlob(int, Blob) - Method in interface javax.sql.RowSet

Sets the designated parameter in this RowSet object's command with the given Blob value.

setBlob(int, InputStream, long) - Method in interface javax.sql.RowSet

Sets the designated parameter to a InputStream object.

setBlob(int, InputStream) - Method in interface javax.sql.RowSet

Sets the designated parameter to a InputStream object.

setBlob(String, InputStream, long) - Method in interface javax.sql.RowSet

Sets the designated parameter to a InputStream object.

setBlob(String, Blob) - Method in interface javax.sql.RowSet

Sets the designated parameter to the given java.sql.Blob object.

setBlob(String, InputStream) - Method in interface javax.sql.RowSet

Sets the designated parameter to a InputStream object.

setBlockIncrement(int) - Method in interface java.awt.Adjustable

Sets the block value increment for the adjustable object.

setBlockIncrement(int) - Method in class java.awt.Scrollbar

Sets the block increment for this scroll bar.

setBlockIncrement(int) - Method in class java.awt.ScrollPaneAdjustable

setBlockIncrement(int) - Method in class javax.swing.JScrollBar

Sets the blockIncrement property.

setBlockIncrement(int) - Method in class javax.swing.JScrollPane.ScrollBar

Messages super to set the value, and resets the blockIncrementSet instance variable to true.

setBold(MutableAttributeSet, boolean) - Static method in class javax.swing.text.StyleConstants

Sets the bold attribute.

setBoolean(Object, int, boolean) - Static method in class java.lang.reflect.Array

Sets the value of the indexed component of the specified array object to the specified boolean value.

setBoolean(Object, boolean) - Method in class java.lang.reflect.Field

Sets the value of a field as a boolean on the specified object.

setBoolean(String, boolean) - Method in interface java.sql.CallableStatement

Sets the designated parameter to the given Java boolean value.

setBoolean(int, boolean) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to the given Java boolean value.

setBoolean(int, boolean) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given boolean in the Java programming language.

setBoolean(String, boolean) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given Java boolean value.

setBoolean(int, boolean) - Method in interface javax.sql.RowSet

Sets the designated parameter in this RowSet object's command to the given Java boolean value.

setBoolean(String, boolean) - Method in interface javax.sql.RowSet

Sets the designated parameter to the given Java boolean value.

setBorder(Border) - Method in class javax.swing.border.TitledBorder

Sets the border of the titled border.

setBorder(Border) - Method in class javax.swing.JComponent

Sets the border of this component.

setBorder(Border) - Method in class javax.swing.JLayer

A non-null border, or non-zero insets, isn't supported, to prevent the geometry of this component from becoming complex enough to inhibit subclassing of LayerUI class.

setBorder(Border) - Method in class javax.swing.JViewport

The viewport "scrolls" its child (called the "view") by the normal parent/child clipping (typically the view is moved in the opposite direction of the scroll).

setBorder(Border) - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider

Sets the border of this component.

setBorder(Border) - Method in class javax.swing.tree.DefaultTreeCellEditor.DefaultTextField

Sets the border of this component.

setBorderColor(Color) - Method in class javax.swing.plaf.basic.BasicToolBarUI.DragWindow

setBorderPainted(boolean) - Method in class javax.swing.AbstractButton

Sets the borderPainted property.

setBorderPainted(boolean) - Method in class javax.swing.JMenuBar

Sets whether the border should be painted.

setBorderPainted(boolean) - Method in class javax.swing.JPopupMenu

Sets whether the border should be painted.

setBorderPainted(boolean) - Method in class javax.swing.JProgressBar

Sets the borderPainted property, which is true if the progress bar should paint its border.

setBorderPainted(boolean) - Method in class javax.swing.JToolBar

Sets the borderPainted property, which is true if the border should be painted.

setBorderPaintedFlat(boolean) - Method in class javax.swing.JCheckBox

Sets the borderPaintedFlat property, which gives a hint to the look and feel as to the appearance of the check box border.

setBorderSelectionColor(Color) - Method in class javax.swing.tree.DefaultTreeCellEditor

Sets the color to use for the border.

setBorderSelectionColor(Color) - Method in class javax.swing.tree.DefaultTreeCellRenderer

Sets the color to use for the border.

setBorderToNonRollover(Component) - Method in class javax.swing.plaf.basic.BasicToolBarUI

Sets the border of the component to have a non-rollover border which was created by the BasicToolBarUI.createNonRolloverBorder() method.

setBorderToNonRollover(Component) - Method in class javax.swing.plaf.metal.MetalToolBarUI

setBorderToNonRollover(Component) - Method in class javax.swing.plaf.synth.SynthToolBarUI

This implementation does nothing, because the rollover property of the JToolBar class is not used in the Synth Look and Feel.

setBorderToNormal(Component) - Method in class javax.swing.plaf.basic.BasicToolBarUI

Sets the border of the component to have a normal border.

setBorderToNormal(Component) - Method in class javax.swing.plaf.synth.SynthToolBarUI

This implementation does nothing, because the rollover property of the JToolBar class is not used in the Synth Look and Feel.

setBorderToRollover(Component) - Method in class javax.swing.plaf.basic.BasicToolBarUI

Sets the border of the component to have a rollover border which was created by the BasicToolBarUI.createRolloverBorder() method.

setBorderToRollover(Component) - Method in class javax.swing.plaf.synth.SynthToolBarUI

This implementation does nothing, because the rollover property of the JToolBar class is not used in the Synth Look and Feel.

setBottomComponent(Component) - Method in class javax.swing.JSplitPane

Sets the component below, or to the right of the divider.

setBottomInset(float) - Method in class javax.swing.text.AsyncBoxView

Set the bottom part of the margin around the view.

setBound(boolean) - Method in class java.beans.PropertyDescriptor

Updates to "bound" properties will cause a "PropertyChange" event to get fired when the property is changed.

setBounds(Rectangle) - Method in class java.awt.Component.AccessibleAWTComponent

Sets the bounds of this object in the form of a Rectangle object.

setBounds(int, int, int, int) - Method in class java.awt.Component

Moves and resizes this component.

setBounds(Rectangle) - Method in class java.awt.Component

Moves and resizes this component to conform to the new bounding rectangle r.

setBounds(Rectangle) - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Sets the bounds of this object in the form of a Rectangle object.

setBounds(Rectangle) - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Sets the bounds of this object in the form of a Rectangle object.

setBounds(Rectangle) - Method in class java.awt.Rectangle

Sets the bounding Rectangle of this Rectangle to match the specified Rectangle.

setBounds(int, int, int, int) - Method in class java.awt.Rectangle

Sets the bounding Rectangle of this Rectangle to the specified x, y, width, and height.

setBounds(int, int, int, int) - Method in class java.awt.Window

Moves and resizes this component.

setBounds(Rectangle) - Method in class java.awt.Window

Moves and resizes this component to conform to the new bounding rectangle r.

setBounds(Rectangle) - Method in interface javax.accessibility.AccessibleComponent

Sets the bounds of this object in the form of a Rectangle object.

setBounds(Rectangle) - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

setBounds(Rectangle) - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

setBounds(Rectangle) - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

setBounds(Rectangle) - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

setBoundsForFrame(JComponent, int, int, int, int) - Method in class javax.swing.DefaultDesktopManager

This moves the JComponent and repaints the damaged areas.

setBoundsForFrame(JComponent, int, int, int, int) - Method in interface javax.swing.DesktopManager

This is a primitive reshape method.

setBroadcast(boolean) - Method in class java.net.DatagramSocket

Enable/disable SO_BROADCAST.

setBuilder(DocumentBuilder) - Method in class javax.xml.bind.annotation.W3CDomHandler

setButtonIcons() - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane

setByte(Object, int, byte) - Static method in class java.lang.reflect.Array

Sets the value of the indexed component of the specified array object to the specified byte value.

setByte(Object, byte) - Method in class java.lang.reflect.Field

Sets the value of a field as a byte on the specified object.

setByte(String, byte) - Method in interface java.sql.CallableStatement

Sets the designated parameter to the given Java byte value.

setByte(int, byte) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to the given Java byte value.

setByte(int, byte) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given byte in the Java programming language.

setByte(String, byte) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given Java byte value.

setByte(int, byte) - Method in interface javax.sql.RowSet

Sets the designated parameter in this RowSet object's command to the given Java byte value.

setByte(String, byte) - Method in interface javax.sql.RowSet

Sets the designated parameter to the given Java byte value.

setByteOrder(ByteOrder) - Method in interface javax.imageio.stream.ImageInputStream

Sets the desired byte order for future reads of data values from this stream.

setByteOrder(ByteOrder) - Method in class javax.imageio.stream.ImageInputStreamImpl

setBytes(long, byte[]) - Method in interface java.sql.Blob

Writes the given array of bytes to the BLOB value that this Blob object represents, starting at position pos, and returns the number of bytes written.

setBytes(long, byte[], int, int) - Method in interface java.sql.Blob

Writes all or part of the given byte array to the BLOB value that this Blob object represents and returns the number of bytes written.

setBytes(String, byte[]) - Method in interface java.sql.CallableStatement

Sets the designated parameter to the given Java array of bytes.

setBytes(int, byte[]) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to the given Java array of bytes.

setBytes(int, byte[]) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given array of bytes.

setBytes(String, byte[]) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given Java array of bytes.

setBytes(long, byte[]) - Method in class javax.sql.rowset.serial.SerialBlob

Writes the given array of bytes to the BLOB value that this Blob object represents, starting at position pos, and returns the number of bytes written.

setBytes(long, byte[], int, int) - Method in class javax.sql.rowset.serial.SerialBlob

Writes all or part of the given byte array to the BLOB value that this Blob object represents and returns the number of bytes written.

setBytes(int, byte[]) - Method in interface javax.sql.RowSet

Sets the designated parameter in this RowSet object's command to the given Java array of byte values.

setBytes(String, byte[]) - Method in interface javax.sql.RowSet

Sets the designated parameter to the given Java array of bytes.

setByteStream(InputStream) - Method in interface org.w3c.dom.ls.LSInput

An attribute of a language and binding dependent type that represents a stream of bytes.

setByteStream(OutputStream) - Method in interface org.w3c.dom.ls.LSOutput

An attribute of a language and binding dependent type that represents a writable stream of bytes.

setByteStream(InputStream) - Method in class org.xml.sax.InputSource

Set the byte stream for this input source.

setCacheDirectory(File) - Static method in class javax.imageio.ImageIO

Sets the directory where cache files are to be created.

setCalendar(Calendar) - Method in class java.text.DateFormat

Set the calendar to be used by this date format.

setCalendarField(int) - Method in class javax.swing.SpinnerDateModel

Changes the size of the date value change computed by the nextValue and previousValue methods.

setCalendarType(String) - Method in class java.util.Calendar.Builder

Sets the calendar type parameter to the given type.

setCallbackHandler(CallbackHandler) - Method in class java.security.AuthProvider

Set a CallbackHandler.

setCanWrapLines(boolean) - Method in class javax.swing.text.AbstractWriter

Sets whether or not lines can be wrapped.

setCaret(Caret) - Method in class javax.swing.text.JTextComponent

Sets the caret to be used.

setCaretColor(Color) - Method in class javax.swing.text.JTextComponent

Sets the current color used to render the caret.

setCaretPosition(int) - Method in class java.awt.TextComponent

Sets the position of the text insertion caret.

setCaretPosition(int) - Method in class javax.swing.text.JTextComponent

Sets the position of the text insertion caret for the TextComponent.

setCaseSensitive(int, boolean) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Sets whether the name of the designated column is case sensitive to the given boolean.

setCaseSensitive(int, boolean) - Method in interface javax.sql.RowSetMetaData

Sets whether the designated column is case sensitive.

setCatalog(String) - Method in interface java.sql.Connection

Sets the given catalog name in order to select a subspace of this Connection object's database in which to work.

setCatalogName(int, String) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Sets the catalog name of the table from which the designated column was derived to catalogName.

setCatalogName(int, String) - Method in interface javax.sql.RowSetMetaData

Sets the designated column's table's catalog name, if any, to the given String.

setCellEditor(TableCellEditor) - Method in class javax.swing.JTable

Sets the active cell editor.

setCellEditor(TreeCellEditor) - Method in class javax.swing.JTree

Sets the cell editor.

setCellEditor(TreeCellEditor) - Method in class javax.swing.plaf.basic.BasicTreeUI

Sets the cell editor.

setCellEditor(TableCellEditor) - Method in class javax.swing.table.TableColumn

Sets the editor to used by when a cell in this column is edited.

setCellLength(int) - Method in class javax.swing.plaf.basic.BasicProgressBarUI

setCellRenderer(ListCellRenderer<? super E>) - Method in class javax.swing.JList

Sets the delegate that is used to paint each cell in the list.

setCellRenderer(TreeCellRenderer) - Method in class javax.swing.JTree

Sets the TreeCellRenderer that will be used to draw each cell.

setCellRenderer(TreeCellRenderer) - Method in class javax.swing.plaf.basic.BasicTreeUI

Sets the TreeCellRenderer to tcr.

setCellRenderer(TableCellRenderer) - Method in class javax.swing.table.TableColumn

Sets the TableCellRenderer used by JTable to draw individual values for this column.

setCellSelectionEnabled(boolean) - Method in class javax.swing.JTable

Sets whether this table allows both a column selection and a row selection to exist simultaneously.

setCellSpacing(int) - Method in class javax.swing.plaf.basic.BasicProgressBarUI

setCentersChildren(boolean) - Method in class javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout

setCertificate(X509Certificate) - Method in class java.security.cert.X509CertSelector

Sets the certificateEquals criterion.

setCertificateChecking(X509Certificate) - Method in class java.security.cert.X509CRLSelector

Sets the certificate being checked.

setCertificateEntry(String, Certificate) - Method in class java.security.KeyStore

Assigns the given trusted certificate to the given alias.

setCertificateValid(Date) - Method in class java.security.cert.X509CertSelector

Sets the certificateValid criterion.

setCertifiedText(boolean) - Method in interface org.w3c.dom.ls.LSInput

If set to true, assume that the input is certified (see section 2.13 in [XML 1.1]) when parsing [XML 1.1].

setCertPathCheckers(List<PKIXCertPathChecker>) - Method in class java.security.cert.PKIXParameters

Sets a List of additional certification path checkers.

setCertStores(List<CertStore>) - Method in class java.security.cert.PKIXParameters

Sets the list of CertStores to be used in finding certificates and CRLs.

setChanged() - Method in class java.util.Observable

Marks this Observable object as having been changed; the hasChanged method will now return true.

setChannelBinding(ChannelBinding) - Method in interface org.ietf.jgss.GSSContext

Sets the channel bindings to be used during context establishment.

setChannelPressure(int) - Method in interface javax.sound.midi.MidiChannel

Reacts to a change in the keyboard pressure.

setChar(Object, int, char) - Static method in class java.lang.reflect.Array

Sets the value of the indexed component of the specified array object to the specified char value.

setChar(Object, char) - Method in class java.lang.reflect.Field

Sets the value of a field as a char on the specified object.

setCharacterAttributes(AttributeSet, boolean) - Method in class javax.swing.JTextPane

Applies the given attributes to character content.

setCharacterAttributes(int, int, AttributeSet, boolean) - Method in class javax.swing.text.DefaultStyledDocument

Sets attributes for some part of the document.

setCharacterAttributes(int, int, AttributeSet, boolean) - Method in interface javax.swing.text.StyledDocument

Changes the content element attributes used for the given range of existing content in the document.

setCharacterAttributes(JEditorPane, AttributeSet, boolean) - Method in class javax.swing.text.StyledEditorKit.StyledTextAction

Applies the given attributes to character content.

setCharacterStream(String, Reader, int) - Method in interface java.sql.CallableStatement

Sets the designated parameter to the given Reader object, which is the given number of characters long.

setCharacterStream(String, Reader, long) - Method in interface java.sql.CallableStatement

Sets the designated parameter to the given Reader object, which is the given number of characters long.

setCharacterStream(String, Reader) - Method in interface java.sql.CallableStatement

Sets the designated parameter to the given Reader object.

setCharacterStream(long) - Method in interface java.sql.Clob

Retrieves a stream to be used to write a stream of Unicode characters to the CLOB value that this Clob object represents, at position pos.

setCharacterStream(int, Reader, int) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to the given Reader object, which is the given number of characters long.

setCharacterStream(int, Reader, long) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to the given Reader object, which is the given number of characters long.

setCharacterStream(int, Reader) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to the given Reader object.

setCharacterStream() - Method in interface java.sql.SQLXML

Retrieves a stream to be used to write the XML value that this SQLXML instance represents.

setCharacterStream(int, Reader, int) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given java.io.Reader object, which will have the specified number of characters.

setCharacterStream(int, Reader) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter in this RowSet object's command to the given Reader object.

setCharacterStream(String, Reader, int) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given Reader object, which is the given number of characters long.

setCharacterStream(String, Reader) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given Reader object.

setCharacterStream(long) - Method in class javax.sql.rowset.serial.SerialClob

Retrieves a stream to be used to write a stream of Unicode characters to the CLOB value that this SerialClob object represents, at position pos.

setCharacterStream(int, Reader, int) - Method in interface javax.sql.RowSet

Sets the designated parameter in this RowSet object's command to the given java.io.Reader value.

setCharacterStream(String, Reader, int) - Method in interface javax.sql.RowSet

Sets the designated parameter to the given Reader object, which is the given number of characters long.

setCharacterStream(int, Reader) - Method in interface javax.sql.RowSet

Sets the designated parameter in this RowSet object's command to the given Reader object.

setCharacterStream(String, Reader) - Method in interface javax.sql.RowSet

Sets the designated parameter to the given Reader object.

setCharacterStream(Reader) - Method in interface org.w3c.dom.ls.LSInput

An attribute of a language and binding dependent type that represents a stream of 16-bit units.

setCharacterStream(Writer) - Method in interface org.w3c.dom.ls.LSOutput

An attribute of a language and binding dependent type that represents a writable stream to which 16-bit units can be output.

setCharacterStream(Reader) - Method in class org.xml.sax.InputSource

Set the character stream for this input source.

setCharacterSubsets(Character.Subset[]) - Method in class java.awt.im.InputContext

Sets the subsets of the Unicode character set that input methods of this input context should be allowed to input.

setCharacterSubsets(Character.Subset[]) - Method in interface java.awt.im.spi.InputMethod

Sets the subsets of the Unicode character set that this input method is allowed to input.

setCharAt(int, char) - Method in class java.lang.StringBuffer

setCheckboxGroup(CheckboxGroup) - Method in class java.awt.Checkbox

Sets this check box's group to the specified check box group.

setChoices(double[], String[]) - Method in class java.text.ChoiceFormat

Set the choices to be used in formatting.

setChooserPanels(AbstractColorChooserPanel[]) - Method in class javax.swing.JColorChooser

Specifies the Color Panels used to choose a color value.

setChunkedStreamingMode(int) - Method in class java.net.HttpURLConnection

This method is used to enable streaming of a HTTP request body without internal buffering, when the content length is not known in advance.

setCipherSuites(String[]) - Method in class javax.net.ssl.SSLParameters

Sets the array of ciphersuites.

setClassAssertionStatus(String, boolean) - Method in class java.lang.ClassLoader

Sets the desired assertion status for the named top-level class in this class loader and any nested classes contained therein.

setClassName(String) - Method in class javax.naming.NameClassPair

Sets the class name of this binding.

setClickCountToStart(int) - Method in class javax.swing.DefaultCellEditor

Specifies the number of clicks needed to start editing.

setClientInfo(String, String) - Method in interface java.sql.Connection

Sets the value of the client info property specified by name to the value specified by value.

setClientInfo(Properties) - Method in interface java.sql.Connection

Sets the value of the connection's client info properties.

setClip(int, int, int, int) - Method in class java.awt.Graphics

Sets the current clip to the rectangle specified by the given coordinates.

setClip(Shape) - Method in class java.awt.Graphics

Sets the current clipping area to an arbitrary clip shape.

setClip(int, int, int, int) - Method in class javax.swing.DebugGraphics

Overrides Graphics.setClip.

setClip(Shape) - Method in class javax.swing.DebugGraphics

Overrides Graphics.setClip.

setClob(String, Reader, long) - Method in interface java.sql.CallableStatement

Sets the designated parameter to a Reader object.

setClob(String, Clob) - Method in interface java.sql.CallableStatement

Sets the designated parameter to the given java.sql.Clob object.

setClob(String, Reader) - Method in interface java.sql.CallableStatement

Sets the designated parameter to a Reader object.

setClob(int, Clob) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to the given java.sql.Clob object.

setClob(int, Reader, long) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to a Reader object.

setClob(int, Reader) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to a Reader object.

setClob(int, Clob) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given Clob object in the Java programming language.

setClob(int, Reader, long) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to a Reader object.

setClob(int, Reader) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to a Reader object.

setClob(String, Reader, long) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to a Reader object.

setClob(String, Clob) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given java.sql.Clob object.

setClob(String, Reader) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to a Reader object.

setClob(int, Clob) - Method in interface javax.sql.RowSet

Sets the designated parameter in this RowSet object's command with the given Clob value.

setClob(int, Reader, long) - Method in interface javax.sql.RowSet

Sets the designated parameter to a Reader object.

setClob(int, Reader) - Method in interface javax.sql.RowSet

Sets the designated parameter to a Reader object.

setClob(String, Reader, long) - Method in interface javax.sql.RowSet

Sets the designated parameter to a Reader object.

setClob(String, Clob) - Method in interface javax.sql.RowSet

Sets the designated parameter to the given java.sql.Clob object.

setClob(String, Reader) - Method in interface javax.sql.RowSet

Sets the designated parameter to a Reader object.

setClosable(boolean) - Method in class javax.swing.JInternalFrame

Sets whether this JInternalFrame can be closed by some user action.

setClosed(boolean) - Method in class javax.swing.JInternalFrame

Closes this internal frame if the argument is true.

setClosedIcon(Icon) - Method in class javax.swing.tree.DefaultTreeCellRenderer

Sets the icon used to represent non-leaf nodes that are not expanded.

setCoalesce(boolean) - Method in class javax.swing.Timer

Sets whether the Timer coalesces multiple pending ActionEvent firings.

setCoalescing(boolean) - Method in class javax.xml.parsers.DocumentBuilderFactory

Specifies that the parser produced by this code will convert CDATA nodes to Text nodes and append it to the adjacent (if any) text node.

setCollapsedIcon(Icon) - Method in class javax.swing.plaf.basic.BasicTreeUI

setCollectionUsageThreshold(long) - Method in interface java.lang.management.MemoryPoolMXBean

Sets the collection usage threshold of this memory pool to the given threshold value.

setColor(Color) - Method in class java.awt.Graphics

Sets this graphics context's current color to the specified color.

setColor(PageAttributes.ColorType) - Method in class java.awt.PageAttributes

Specifies whether pages using these attributes will be rendered in color or monochrome.

setColor(Color) - Method in class javax.swing.DebugGraphics

Sets the color to be used for drawing and filling lines and shapes.

setColor(Color) - Method in class javax.swing.JColorChooser

Sets the current color of the color chooser to the specified color.

setColor(int, int, int) - Method in class javax.swing.JColorChooser

Sets the current color of the color chooser to the specified RGB color.

setColor(int) - Method in class javax.swing.JColorChooser

Sets the current color of the color chooser to the specified color.

setColorModel(ColorModel) - Method in class java.awt.image.BufferedImageFilter

Filters the information provided in the setColorModel method of the ImageConsumer interface.

setColorModel(ColorModel) - Method in interface java.awt.image.ImageConsumer

Sets the ColorModel object used for the majority of the pixels reported using the setPixels method calls.

setColorModel(ColorModel) - Method in class java.awt.image.ImageFilter

Filter the information provided in the setColorModel method of the ImageConsumer interface.

setColorModel(ColorModel) - Method in class java.awt.image.PixelGrabber

The setColorModel method is part of the ImageConsumer API which this class must implement to retrieve the pixels.

setColorModel(ColorModel) - Method in class java.awt.image.RGBImageFilter

If the ColorModel is an IndexColorModel and the subclass has set the canFilterIndexColorModel flag to true, we substitute a filtered version of the color model here and wherever that original ColorModel object appears in the setPixels methods.

setColumnCount(int) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Sets to the given number the number of columns in the RowSet object for which this RowSetMetaDataImpl object was created.

setColumnCount(int) - Method in interface javax.sql.RowSetMetaData

Sets the number of columns in the RowSet object to the given number.

setColumnCount(int) - Method in class javax.swing.table.DefaultTableModel

Sets the number of columns in the model.

setColumnDisplaySize(int, int) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Sets the normal maximum number of chars in the designated column to the given number.

setColumnDisplaySize(int, int) - Method in interface javax.sql.RowSetMetaData

Sets the designated column's normal maximum width in chars to the given int.

setColumnHeader(JViewport) - Method in class javax.swing.JScrollPane

Removes the old columnHeader, if it exists; if the new columnHeader isn't null, syncs the x coordinate of its viewPosition with the viewport (if there is one) and then adds it to the scroll pane.

setColumnHeaderView(Component) - Method in class javax.swing.JScrollPane

Creates a column-header viewport if necessary, sets its view, and then adds the column-header viewport to the scrollpane.

setColumnIdentifiers(Vector) - Method in class javax.swing.table.DefaultTableModel

Replaces the column identifiers in the model.

setColumnIdentifiers(Object[]) - Method in class javax.swing.table.DefaultTableModel

Replaces the column identifiers in the model.

setColumnLabel(int, String) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Sets the suggested column label for use in printouts and displays, if any, to label.

setColumnLabel(int, String) - Method in interface javax.sql.RowSetMetaData

Sets the suggested column title for use in printouts and displays, if any, to the given String.

setColumnMargin(int) - Method in class javax.swing.table.DefaultTableColumnModel

Sets the column margin to newMargin.

setColumnMargin(int) - Method in interface javax.swing.table.TableColumnModel

Sets the TableColumn's column margin to newMargin.

setColumnModel(TableColumnModel) - Method in class javax.swing.JTable

Sets the column model for this table to newModel and registers for listener notifications from the new column model.

setColumnModel(TableColumnModel) - Method in class javax.swing.table.JTableHeader

Sets the column model for this table to newModel and registers for listener notifications from the new column model.

setColumnName(int, String) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Sets the column name of the designated column to the given name.

setColumnName(int, String) - Method in interface javax.sql.RowSetMetaData

Sets the name of the designated column to the given String.

setColumnNumber(int) - Method in class javax.xml.bind.helpers.ValidationEventLocatorImpl

Set the columnNumber field on this event locator.

setColumnNumber(int) - Method in class org.xml.sax.helpers.LocatorImpl

Set the column number for this locator (1-based).

setColumns(int) - Method in class java.awt.GridLayout

Sets the number of columns in this layout to the specified value.

setColumns(int) - Method in class java.awt.TextArea

Sets the number of columns for this text area.

setColumns(int) - Method in class java.awt.TextField

Sets the number of columns in this text field.

setColumns(int) - Method in class javax.swing.JTextArea

Sets the number of columns for this TextArea.

setColumns(int) - Method in class javax.swing.JTextField

Sets the number of columns in this TextField, and then invalidate the layout.

setColumnSelectionAllowed(boolean) - Method in class javax.swing.JTable

Sets whether the columns in this model can be selected.

setColumnSelectionAllowed(boolean) - Method in class javax.swing.table.DefaultTableColumnModel

Sets whether column selection is allowed.

setColumnSelectionAllowed(boolean) - Method in interface javax.swing.table.TableColumnModel

Sets whether the columns in this model may be selected.

setColumnSelectionInterval(int, int) - Method in class javax.swing.JTable

Selects the columns from index0 to index1, inclusive.

setColumnType(int, int) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Sets the SQL type code for values stored in the designated column to the given type code from the class java.sql.Types.

setColumnType(int, int) - Method in interface javax.sql.RowSetMetaData

Sets the designated column's SQL type to the one given.

setColumnTypeName(int, String) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Sets the type name used by the data source for values stored in the designated column to the given type name.

setColumnTypeName(int, String) - Method in interface javax.sql.RowSetMetaData

Sets the designated column's type name that is specific to the data source, if any, to the given String.

setComboBox(JComboBox) - Method in class javax.swing.plaf.metal.MetalComboBoxButton

setComboIcon(Icon) - Method in class javax.swing.plaf.metal.MetalComboBoxButton

setCommand(String) - Method in class javax.sql.rowset.BaseRowSet

Sets this RowSet object's command property to the given String object and clears the parameters, if any, that were set for the previous command.

setCommand(String) - Method in interface javax.sql.RowSet

Sets this RowSet object's command property to the given SQL query.

setCommandContext(String, DataHandler) - Method in interface javax.activation.CommandObject

Initialize the Command with the verb it is requested to handle and the DataHandler that describes the data it will operate on.

setCommandMap(CommandMap) - Method in class javax.activation.DataHandler

Set the CommandMap for use by this DataHandler.

setComment(String) - Method in class java.net.HttpCookie

Specifies a comment that describes a cookie's purpose.

setComment(String) - Method in class java.util.zip.ZipEntry

Sets the optional comment string for the entry.

setComment(String) - Method in class java.util.zip.ZipOutputStream

Sets the ZIP file comment.

setCommentURL(String) - Method in class java.net.HttpCookie

Specifies a comment URL that describes a cookie's purpose.

setCommitsOnValidEdit(boolean) - Method in class javax.swing.text.DefaultFormatter

Sets when edits are published back to the JFormattedTextField.

setComparator(int, Comparator<?>) - Method in class javax.swing.DefaultRowSorter

Sets the Comparator to use when sorting the specified column.

setComparator(Comparator<? super Component>) - Method in class javax.swing.SortingFocusTraversalPolicy

Sets the Comparator which will be used to sort the Components in a focus traversal cycle.

setComponent(Component) - Method in class java.awt.dnd.DragGestureRecognizer

set the Component that the DragGestureRecognizer is associated with registerListeners() and unregisterListeners() are called as a side effect as appropriate.

setComponent(Component) - Method in class java.awt.dnd.DropTarget

Note: this interface is required to permit the safe association of a DropTarget with a Component in one of two ways, either: component.setDropTarget(droptarget); or droptarget.setComponent(component);

setComponent(JComponent) - Method in class javax.swing.JToolTip

Specifies the component that the tooltip describes.

setComponent(MutableAttributeSet, Component) - Static method in class javax.swing.text.StyleConstants

Sets the component attribute.

setComponentAt(int, Component) - Method in class javax.swing.JTabbedPane

Sets the component at index to component.

setComponentOrientation(ComponentOrientation) - Method in class java.awt.Component

Sets the language-sensitive orientation that is to be used to order the elements or text within this component.

setComponentOrientation(ComponentOrientation) - Method in class javax.swing.JMenu

setComponentOrientation(ComponentOrientation) - Method in class javax.swing.JScrollPane

Sets the orientation for the vertical and horizontal scrollbars as determined by the ComponentOrientation argument.

setComponentOrientation(ComponentOrientation) - Method in class javax.swing.text.JTextComponent

setComponentPopupMenu(JPopupMenu) - Method in class javax.swing.JComponent

Sets the JPopupMenu for this JComponent.

setComponentToSize(Component, int, int, Insets, Dimension) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager

Sets the width of the component c to be size, placing its x location at location, y to the insets.top and height to the containersize.height less the top and bottom insets.

setComponentZOrder(Component, int) - Method in class java.awt.Container

Moves the specified component to the specified z-order index in the container.

setComponentZOrder(Component, int) - Method in class javax.swing.JDesktopPane

Moves the specified component to the specified z-order index in the container.

setComposite(Composite) - Method in class java.awt.Graphics2D

Sets the Composite for the Graphics2D context.

setCompositionEnabled(boolean) - Method in class java.awt.im.InputContext

Enables or disables the current input method for composition, depending on the value of the parameter enable.

setCompositionEnabled(boolean) - Method in interface java.awt.im.spi.InputMethod

Enables or disables this input method for composition, depending on the value of the parameter enable.

setCompressedSize(long) - Method in class java.util.zip.ZipEntry

Sets the size of the compressed entry data.

setCompressionMode(int) - Method in class javax.imageio.ImageWriteParam

Specifies whether compression is to be performed, and if so how compression parameters are to be determined.

setCompressionQuality(float) - Method in class javax.imageio.ImageWriteParam

Sets the compression quality to a value between 0 and 1.

setCompressionType(String) - Method in class javax.imageio.ImageWriteParam

Sets the compression type to one of the values indicated by getCompressionTypes.

setConcurrency(int) - Method in class javax.sql.rowset.BaseRowSet

Sets the concurrency for this RowSet object to the specified concurrency.

setConcurrency(int) - Method in interface javax.sql.RowSet

Sets the concurrency of this RowSet object to the given concurrency level.

setConfiguration(Configuration) - Static method in class javax.security.auth.login.Configuration

Set the login Configuration.

setConnectTimeout(int) - Method in class java.net.URLConnection

Sets a specified timeout value, in milliseconds, to be used when opening a communications link to the resource referenced by this URLConnection.

setConstrained(boolean) - Method in class java.beans.PropertyDescriptor

Attempted updates to "Constrained" properties will cause a "VetoableChange" event to get fired when the property is changed.

setConstraint(String, Spring) - Method in class javax.swing.SpringLayout.Constraints

Sets the spring controlling the specified edge.

setConstraints(Component, GridBagConstraints) - Method in class java.awt.GridBagLayout

Sets the constraints for the specified component in this layout.

setContent(Object, String) - Method in class javax.xml.soap.AttachmentPart

Sets the content of this attachment part to that of the given Object and sets the value of the Content-Type header to the given type.

setContent(Source) - Method in class javax.xml.soap.SOAPPart

Sets the content of the SOAPEnvelope object with the data from the given Source object.

setContentAreaFilled(boolean) - Method in class javax.swing.AbstractButton

Sets the contentAreaFilled property.

setContentDescription(String) - Method in class javax.xml.soap.SOAPMessage

Sets the description of this SOAPMessage object's content with the given description.

setContentHandler(ContentHandler) - Method in class javax.xml.validation.ValidatorHandler

Sets the ContentHandler which receives the augmented validation result.

setContentHandler(ContentHandler) - Method in class org.xml.sax.helpers.ParserAdapter

Set the content handler.

setContentHandler(ContentHandler) - Method in class org.xml.sax.helpers.XMLFilterImpl

Set the content event handler.

setContentHandler(ContentHandler) - Method in interface org.xml.sax.XMLReader

Allow an application to register a content event handler.

setContentHandlerFactory(ContentHandlerFactory) - Static method in class java.net.URLConnection

Sets the ContentHandlerFactory of an application.

setContentId(String) - Method in class javax.xml.soap.AttachmentPart

Sets the MIME header whose name is "Content-ID" with the given value.

setContentId(String) - Method in class javax.xml.soap.SOAPPart

Sets the value of the MIME header named "Content-Id" to the given String.

setContentLocation(String) - Method in class javax.xml.soap.AttachmentPart

Sets the MIME header whose name is "Content-Location" with the given value.

setContentLocation(String) - Method in class javax.xml.soap.SOAPPart

Sets the value of the MIME header "Content-Location" to the given String.

setContentPane(Container) - Method in class javax.swing.JApplet

Sets the contentPane property.

setContentPane(Container) - Method in class javax.swing.JDialog

Sets the contentPane property.

setContentPane(Container) - Method in class javax.swing.JFrame

Sets the contentPane property.

setContentPane(Container) - Method in class javax.swing.JInternalFrame

Sets this JInternalFrame's contentPane property.

setContentPane(Container) - Method in class javax.swing.JRootPane

Sets the content pane -- the container that holds the components parented by the root pane.

setContentPane(Container) - Method in class javax.swing.JWindow

Sets the contentPane property for this window.

setContentPane(Container) - Method in interface javax.swing.RootPaneContainer

The "contentPane" is the primary container for application specific components.

setContents(Transferable, ClipboardOwner) - Method in class java.awt.datatransfer.Clipboard

Sets the current contents of the clipboard to the specified transferable object and registers the specified clipboard owner as the owner of the new contents.

setContentType(String) - Method in class javax.swing.JEditorPane

Sets the type of content that this editor handles.

setContentType(String) - Method in class javax.xml.soap.AttachmentPart

Sets the MIME header whose name is "Content-Type" with the given value.

setContext(ScriptContext) - Method in class javax.script.AbstractScriptEngine

Sets the value of the protected context field to the specified ScriptContext.

setContext(ScriptContext) - Method in interface javax.script.ScriptEngine

Sets the default ScriptContext of the ScriptEngine whose Bindings, Reader and Writers are used for script executions when no ScriptContext is specified.

setContextClassLoader(ClassLoader) - Method in class java.lang.Thread

Sets the context ClassLoader for this Thread.

setContinueExistingPeriodicTasksAfterShutdownPolicy(boolean) - Method in class java.util.concurrent.ScheduledThreadPoolExecutor

Sets the policy on whether to continue executing existing periodic tasks even when this executor has been shutdown.

setContinuousLayout(boolean) - Method in class javax.swing.JSplitPane

Sets the value of the continuousLayout property, which must be true for the child components to be continuously redisplayed and laid out during user intervention.

setContinuousLayout(boolean) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI

Turn continuous layout on/off.

setControlButtonsAreShown(boolean) - Method in class javax.swing.JFileChooser

Sets the property that indicates whether the approve and cancel buttons are shown in the file chooser.

setController(IIOParamController) - Method in class javax.imageio.IIOParam

Sets the IIOParamController to be used to provide settings for this IIOParam object when the activateController method is called, overriding any default controller.

setController(IIOMetadataController) - Method in class javax.imageio.metadata.IIOMetadata

Sets the IIOMetadataController to be used to provide settings for this IIOMetadata object when the activateController method is called, overriding any default controller.

setCookiePolicy(CookiePolicy) - Method in class java.net.CookieManager

To set the cookie policy of this cookie manager.

setCopies(int) - Method in class java.awt.JobAttributes

Specifies the number of copies the application should render for jobs using these attributes.

setCopies(int) - Method in class java.awt.print.PrinterJob

Sets the number of copies to be printed.

setCopiesToDefault() - Method in class java.awt.JobAttributes

Sets the number of copies the application should render for jobs using these attributes to the default.

setCorePoolSize(int) - Method in class java.util.concurrent.ThreadPoolExecutor

Sets the core number of threads.

setCorner(String, Component) - Method in class javax.swing.JScrollPane

Adds a child that will appear in one of the scroll panes corners, if there's room.

setCountLimit(long) - Method in class javax.naming.directory.SearchControls

Sets the maximum number of entries to be returned as a result of the search.

setCrc(long) - Method in class java.util.zip.ZipEntry

Sets the CRC-32 checksum of the uncompressed entry data.

setCreationTime(FileTime) - Method in class java.util.zip.ZipEntry

Sets the creation time of the entry.

setCurrency(Currency) - Method in class java.text.DecimalFormat

Sets the currency used by this number format when formatting currency values.

setCurrency(Currency) - Method in class java.text.DecimalFormatSymbols

Sets the currency of these DecimalFormatSymbols.

setCurrency(Currency) - Method in class java.text.NumberFormat

Sets the currency used by this number format when formatting currency values.

setCurrency(int, boolean) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Sets whether a value stored in the designated column is a cash value to the given boolean.

setCurrency(int, boolean) - Method in interface javax.sql.RowSetMetaData

Sets whether the designated column is a cash value.

setCurrencySymbol(String) - Method in class java.text.DecimalFormatSymbols

Sets the currency symbol for the currency of these DecimalFormatSymbols in their locale.

setCurrent(Checkbox) - Method in class java.awt.CheckboxGroup

Deprecated.
As of JDK version 1.1, replaced by setSelectedCheckbox(Checkbox).

setCurrentAccessibleValue(Number) - Method in class java.awt.Button.AccessibleAWTButton

Set the value of this object as a Number.

setCurrentAccessibleValue(Number) - Method in class java.awt.Checkbox.AccessibleAWTCheckbox

Set the value of this object as a Number.

setCurrentAccessibleValue(Number) - Method in class java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem

Set the value of this object as a Number.

setCurrentAccessibleValue(Number) - Method in class java.awt.MenuItem.AccessibleAWTMenuItem

Set the value of this object as a Number.

setCurrentAccessibleValue(Number) - Method in class java.awt.Scrollbar.AccessibleAWTScrollBar

Set the value of this object as a Number.

setCurrentAccessibleValue(Number) - Method in interface javax.accessibility.AccessibleValue

Set the value of this object as a Number.

setCurrentAccessibleValue(Number) - Method in class javax.swing.AbstractButton.AccessibleAbstractButton

Set the value of this object as a Number.

setCurrentAccessibleValue(Number) - Method in class javax.swing.JInternalFrame.AccessibleJInternalFrame

Set the value of this object as a Number.

setCurrentAccessibleValue(Number) - Method in class javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon

Sets the value of this object as a Number.

setCurrentAccessibleValue(Number) - Method in class javax.swing.JProgressBar.AccessibleJProgressBar

Sets the value of this object as a Number.

setCurrentAccessibleValue(Number) - Method in class javax.swing.JScrollBar.AccessibleJScrollBar

Set the value of this object as a Number.

setCurrentAccessibleValue(Number) - Method in class javax.swing.JSlider.AccessibleJSlider

Set the value of this object as a Number.

setCurrentAccessibleValue(Number) - Method in class javax.swing.JSpinner.AccessibleJSpinner

Set the value of this object as a Number.

setCurrentAccessibleValue(Number) - Method in class javax.swing.JSplitPane.AccessibleJSplitPane

Sets the value of this object as a Number.

setCurrentDirectory(File) - Method in class javax.swing.JFileChooser

Sets the current directory.

setCurrentKeyboardFocusManager(KeyboardFocusManager) - Static method in class java.awt.KeyboardFocusManager

Sets the current KeyboardFocusManager instance for the calling thread's context.

setCurrentLineLength(int) - Method in class javax.swing.text.AbstractWriter

Sets the current line length.

setCurrentManager(FocusManager) - Static method in class javax.swing.FocusManager

Sets the current KeyboardFocusManager instance for the calling thread's context.

setCurrentManager(RepaintManager) - Static method in class javax.swing.RepaintManager

Set the RepaintManager that should be used for the calling thread.

setCurrentTheme(MetalTheme) - Static method in class javax.swing.plaf.metal.MetalLookAndFeel

Set the theme used by MetalLookAndFeel.

setCursor(Cursor) - Method in class java.awt.Component.AccessibleAWTComponent

Sets the Cursor of this object.

setCursor(Cursor) - Method in class java.awt.Component

Sets the cursor image to the specified cursor.

setCursor(Cursor) - Method in class java.awt.dnd.DragSourceContext

Sets the cursor for this drag operation to the specified Cursor.

setCursor(int) - Method in class java.awt.Frame

Deprecated.
As of JDK version 1.1, replaced by Component.setCursor(Cursor).

setCursor(Cursor) - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Set the Cursor of this object.

setCursor(Cursor) - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Sets the Cursor of this object.

setCursor(Cursor) - Method in class java.awt.Window

Set the cursor image to a specified cursor.

setCursor(Cursor) - Method in interface javax.accessibility.AccessibleComponent

Sets the Cursor of this object.

setCursor(Cursor) - Method in class javax.swing.JInternalFrame

Sets the cursor image to the specified cursor.

setCursor(Cursor) - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

setCursor(Cursor) - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Sets the Cursor of this object.

setCursor(Cursor) - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

setCursor(Cursor) - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

setCursorName(String) - Method in interface java.sql.Statement

Sets the SQL cursor name to the given String, which will be used by subsequent Statement object execute methods.

setCurve(double, double, double, double, double, double, double, double) - Method in class java.awt.geom.CubicCurve2D.Double

Sets the location of the end points and control points of this curve to the specified double coordinates.

setCurve(double, double, double, double, double, double, double, double) - Method in class java.awt.geom.CubicCurve2D.Float

Sets the location of the end points and control points of this curve to the specified double coordinates.

setCurve(float, float, float, float, float, float, float, float) - Method in class java.awt.geom.CubicCurve2D.Float

Sets the location of the end points and control points of this curve to the specified float coordinates.

setCurve(double, double, double, double, double, double, double, double) - Method in class java.awt.geom.CubicCurve2D

Sets the location of the end points and control points of this curve to the specified double coordinates.

setCurve(double[], int) - Method in class java.awt.geom.CubicCurve2D

Sets the location of the end points and control points of this curve to the double coordinates at the specified offset in the specified array.

setCurve(Point2D, Point2D, Point2D, Point2D) - Method in class java.awt.geom.CubicCurve2D

Sets the location of the end points and control points of this curve to the specified Point2D coordinates.

setCurve(Point2D[], int) - Method in class java.awt.geom.CubicCurve2D

Sets the location of the end points and control points of this curve to the coordinates of the Point2D objects at the specified offset in the specified array.

setCurve(CubicCurve2D) - Method in class java.awt.geom.CubicCurve2D

Sets the location of the end points and control points of this curve to the same as those in the specified CubicCurve2D.

setCurve(double, double, double, double, double, double) - Method in class java.awt.geom.QuadCurve2D.Double

Sets the location of the end points and control point of this curve to the specified double coordinates.

setCurve(double, double, double, double, double, double) - Method in class java.awt.geom.QuadCurve2D.Float

Sets the location of the end points and control point of this curve to the specified double coordinates.

setCurve(float, float, float, float, float, float) - Method in class java.awt.geom.QuadCurve2D.Float

Sets the location of the end points and control point of this curve to the specified float coordinates.

setCurve(double, double, double, double, double, double) - Method in class java.awt.geom.QuadCurve2D

Sets the location of the end points and control point of this curve to the specified double coordinates.

setCurve(double[], int) - Method in class java.awt.geom.QuadCurve2D

Sets the location of the end points and control points of this QuadCurve2D to the double coordinates at the specified offset in the specified array.

setCurve(Point2D, Point2D, Point2D) - Method in class java.awt.geom.QuadCurve2D

Sets the location of the end points and control point of this QuadCurve2D to the specified Point2D coordinates.

setCurve(Point2D[], int) - Method in class java.awt.geom.QuadCurve2D

Sets the location of the end points and control points of this QuadCurve2D to the coordinates of the Point2D objects at the specified offset in the specified array.

setCurve(QuadCurve2D) - Method in class java.awt.geom.QuadCurve2D

Sets the location of the end points and control point of this QuadCurve2D to the same as those in the specified QuadCurve2D.

setDaemon(boolean) - Method in class java.lang.Thread

Marks this thread as either a daemon thread or a user thread.

setDaemon(boolean) - Method in class java.lang.ThreadGroup

Changes the daemon status of this thread group.

setData(int, byte[]) - Method in class java.awt.color.ICC_Profile

Sets a particular tagged data element in the profile from a byte array.

setData(Raster) - Method in class java.awt.image.BufferedImage

Sets a rectangular region of the image to the contents of the specified Raster r, which is assumed to be in the same coordinate space as the BufferedImage.

setData(Raster) - Method in interface java.awt.image.WritableRenderedImage

Sets a rect of the image to the contents of the Raster r, which is assumed to be in the same coordinate space as the WritableRenderedImage.

setData(byte[], int, int) - Method in class java.net.DatagramPacket

Set the data buffer for this packet.

setData(byte[]) - Method in class java.net.DatagramPacket

Set the data buffer for this packet.

setData(byte[]) - Method in class javax.imageio.stream.IIOByteBuffer

Updates the array reference that will be returned by subsequent calls to the getData method.

setData(String) - Method in interface org.w3c.dom.CharacterData

The character data of the node that implements this interface.

setData(String) - Method in interface org.w3c.dom.ProcessingInstruction

The content of this processing instruction.

setDataContentHandlerFactory(DataContentHandlerFactory) - Static method in class javax.activation.DataHandler

Sets the DataContentHandlerFactory.

setDataElements(int, int, Object, DataBuffer) - Method in class java.awt.image.BandedSampleModel

Sets the data for a single pixel in the specified DataBuffer from a primitive array of type TransferType.

setDataElements(int, int, Object, DataBuffer) - Method in class java.awt.image.ComponentSampleModel

Sets the data for a single pixel in the specified DataBuffer from a primitive array of type TransferType.

setDataElements(int, int, Object, DataBuffer) - Method in class java.awt.image.MultiPixelPackedSampleModel

Sets the data for a single pixel in the specified DataBuffer from a primitive array of type TransferType.

setDataElements(int, int, Object, DataBuffer) - Method in class java.awt.image.SampleModel

Sets the data for a single pixel in the specified DataBuffer from a primitive array of type TransferType.

setDataElements(int, int, int, int, Object, DataBuffer) - Method in class java.awt.image.SampleModel

Sets the data for a rectangle of pixels in the specified DataBuffer from a primitive array of type TransferType.

setDataElements(int, int, Object, DataBuffer) - Method in class java.awt.image.SinglePixelPackedSampleModel

Sets the data for a single pixel in the specified DataBuffer from a primitive array of type TransferType.

setDataElements(int, int, Object) - Method in class java.awt.image.WritableRaster

Sets the data for a single pixel from a primitive array of type TransferType.

setDataElements(int, int, Raster) - Method in class java.awt.image.WritableRaster

Sets the data for a rectangle of pixels from an input Raster.

setDataElements(int, int, int, int, Object) - Method in class java.awt.image.WritableRaster

Sets the data for a rectangle of pixels from a primitive array of type TransferType.

setDatagramSocketImplFactory(DatagramSocketImplFactory) - Static method in class java.net.DatagramSocket

Sets the datagram socket implementation factory for the application.

setDataHandler(DataHandler) - Method in class javax.xml.soap.AttachmentPart

Sets the given DataHandler object as the data handler for this AttachmentPart object.

setDataSourceLock(int) - Method in class javax.sql.rowset.spi.SyncProvider

Sets a lock on the underlying data source at the level indicated by datasource_lock.

setDataSourceName(String) - Method in class javax.sql.rowset.BaseRowSet

Sets the DataSource name property for this RowSet object to the given logical name and sets this RowSet object's Url property to null.

setDataSourceName(String) - Method in interface javax.sql.RowSet

Sets the data source name property for this RowSet object to the given String.

setDatatypeConverter(DatatypeConverterInterface) - Static method in class javax.xml.bind.DatatypeConverter

This method is for JAXB provider use only.

setDataVector(Vector, Vector) - Method in class javax.swing.table.DefaultTableModel

Replaces the current dataVector instance variable with the new Vector of rows, dataVector.

setDataVector(Object[][], Object[]) - Method in class javax.swing.table.DefaultTableModel

Replaces the value in the dataVector instance variable with the values in the array dataVector.

setDate(Date) - Method in class java.security.cert.PKIXParameters

Sets the time for which the validity of the certification path should be determined.

setDate(String, Date) - Method in interface java.sql.CallableStatement

Sets the designated parameter to the given java.sql.Date value using the default time zone of the virtual machine that is running the application.

setDate(String, Date, Calendar) - Method in interface java.sql.CallableStatement

Sets the designated parameter to the given java.sql.Date value, using the given Calendar object.

setDate(int, Date) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to the given java.sql.Date value using the default time zone of the virtual machine that is running the application.

setDate(int, Date, Calendar) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to the given java.sql.Date value, using the given Calendar object.

setDate(int) - Method in class java.sql.Time

Deprecated.

setDate(int, int, int) - Method in class java.util.Calendar.Builder

Sets the date field parameters to the values given by year, month, and dayOfMonth.

setDate(int) - Method in class java.util.Date

Deprecated.
As of JDK version 1.1, replaced by Calendar.set(Calendar.DAY_OF_MONTH, int date).

setDate(int, Date) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given java.sql.Date value.

setDate(int, Date, Calendar) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given java.sql.Date object.

setDate(String, Date) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given java.sql.Date value using the default time zone of the virtual machine that is running the application.

setDate(String, Date, Calendar) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given java.sql.Date value, using the given Calendar object.

setDate(int, Date) - Method in interface javax.sql.RowSet

Sets the designated parameter in this RowSet object's command to the given java.sql.Date value.

setDate(int, Date, Calendar) - Method in interface javax.sql.RowSet

Sets the designated parameter in this RowSet object's command with the given java.sql.Date value.

setDate(String, Date) - Method in interface javax.sql.RowSet

Sets the designated parameter to the given java.sql.Date value using the default time zone of the virtual machine that is running the application.

setDate(String, Date, Calendar) - Method in interface javax.sql.RowSet

Sets the designated parameter to the given java.sql.Date value, using the given Calendar object.

setDateAndTime(Date) - Method in class java.security.cert.X509CRLSelector

Sets the dateAndTime criterion.

setDateFormatSymbols(DateFormatSymbols) - Method in class java.text.SimpleDateFormat

Sets the date and time format symbols of this date format.

setDay(int) - Method in class javax.xml.datatype.XMLGregorianCalendar

Set days in month.

setDebugGraphicsOptions(int) - Method in class javax.swing.JComponent

Enables or disables diagnostic information about every graphics operation performed within the component or one of its children.

setDebugOptions(int) - Method in class javax.swing.DebugGraphics

Enables/disables diagnostic information about every graphics operation.

setDecimalFormatSymbols(DecimalFormatSymbols) - Method in class java.text.DecimalFormat

Sets the decimal format symbols, which is generally not changed by the programmer or user.

setDecimalSeparator(char) - Method in class java.text.DecimalFormatSymbols

Sets the character used for decimal sign.

setDecimalSeparatorAlwaysShown(boolean) - Method in class java.text.DecimalFormat

Allows you to set the behavior of the decimal separator with integers.

setDeclared(int, boolean) - Method in class org.xml.sax.ext.Attributes2Impl

Assign a value to the "declared" flag of a specific attribute.

setDecodeTables(JPEGQTable[], JPEGHuffmanTable[], JPEGHuffmanTable[]) - Method in class javax.imageio.plugins.jpeg.JPEGImageReadParam

Sets the quantization and Huffman tables to use in decoding abbreviated streams.

setDecomposition(int) - Method in class java.text.Collator

Set the decomposition mode of this Collator.

setDefault(Authenticator) - Static method in class java.net.Authenticator

Sets the authenticator that will be used by the networking code when a proxy or an HTTP server asks for authentication.

setDefault(CookieHandler) - Static method in class java.net.CookieHandler

Sets (or unsets) the system-wide cookie handler.

setDefault(ProxySelector) - Static method in class java.net.ProxySelector

Sets (or unsets) the system-wide proxy selector.

setDefault(ResponseCache) - Static method in class java.net.ResponseCache

Sets (or unsets) the system-wide cache.

setDefault(Locale) - Static method in class java.util.Locale

Sets the default locale for this instance of the Java Virtual Machine.

setDefault(Locale.Category, Locale) - Static method in class java.util.Locale

Sets the default locale for the specified Category for this instance of the Java Virtual Machine.

setDefault(TimeZone) - Static method in class java.util.TimeZone

Sets the TimeZone that is returned by the getDefault method.

setDefault(SSLContext) - Static method in class javax.net.ssl.SSLContext

Sets the default SSL context.

setDefaultAction(Action) - Method in interface javax.swing.text.Keymap

Set the default action to fire if a key is typed.

setDefaultActions(int) - Method in class java.awt.dnd.DropTarget

Sets the default acceptable actions for this DropTarget

setDefaultAllowUserInteraction(boolean) - Static method in class java.net.URLConnection

Sets the default value of the allowUserInteraction field for all future URLConnection objects to the specified value.

setDefaultAssertionStatus(boolean) - Method in class java.lang.ClassLoader

Sets the default assertion status for this class loader.

setDefaultButton(JButton) - Method in class javax.swing.JRootPane

Sets the defaultButton property, which determines the current default button for this JRootPane.

setDefaultCapable(boolean) - Method in class javax.swing.JButton

Sets the defaultCapable property, which determines whether this button can be made the default button for its root pane.

setDefaultClassLoader(ClassLoader) - Method in class javax.management.remote.rmi.RMIServerImpl

Sets the default ClassLoader for this connector server.

setDefaultCloseOperation(int) - Method in class javax.swing.JDialog

Sets the operation that will happen by default when the user initiates a "close" on this dialog.

setDefaultCloseOperation(int) - Method in class javax.swing.JFrame

Sets the operation that will happen by default when the user initiates a "close" on this frame.

setDefaultCloseOperation(int) - Method in class javax.swing.JInternalFrame

Sets the operation that will happen by default when the user initiates a "close" on this internal frame.

setDefaultCommandMap(CommandMap) - Static method in class javax.activation.CommandMap

Set the default CommandMap.

setDefaultCursor(Cursor) - Method in class javax.swing.text.html.HTMLEditorKit

Sets the default cursor.

setDefaultDTD() - Static method in class javax.swing.text.html.parser.ParserDelegator

setDefaultEditor(Class<?>, TableCellEditor) - Method in class javax.swing.JTable

Sets a default cell editor to be used if no editor has been set in a TableColumn.

setDefaultFileTypeMap(FileTypeMap) - Static method in class javax.activation.FileTypeMap

Sets the default FileTypeMap for the system.

setDefaultFocusTraversalKeys(int, Set<? extends AWTKeyStroke>) - Method in class java.awt.KeyboardFocusManager

Sets the default focus traversal keys for a given traversal operation.

setDefaultFocusTraversalPolicy(FocusTraversalPolicy) - Method in class java.awt.KeyboardFocusManager

Sets the default FocusTraversalPolicy.

setDefaultFormatter(JFormattedTextField.AbstractFormatter) - Method in class javax.swing.text.DefaultFormatterFactory

Sets the JFormattedTextField.AbstractFormatter to use as a last resort, eg in case a display, edit or null JFormattedTextField.AbstractFormatter has not been specified.

setDefaultHostnameVerifier(HostnameVerifier) - Static method in class javax.net.ssl.HttpsURLConnection

Sets the default HostnameVerifier inherited by a new instance of this class.

setDefaultLightWeightPopupEnabled(boolean) - Static method in class javax.swing.JPopupMenu

Sets the default value of the lightWeightPopupEnabled property.

setDefaultLocale(Locale) - Static method in class javax.swing.JComponent

Sets the default locale used to initialize each JComponent's locale property upon creation.

setDefaultLocale(Locale) - Method in class javax.swing.UIDefaults

Sets the default locale.

setDefaultLookAndFeelDecorated(boolean) - Static method in class javax.swing.JDialog

Provides a hint as to whether or not newly created JDialogs should have their Window decorations (such as borders, widgets to close the window, title...) provided by the current look and feel.

setDefaultLookAndFeelDecorated(boolean) - Static method in class javax.swing.JFrame

Provides a hint as to whether or not newly created JFrames should have their Window decorations (such as borders, widgets to close the window, title...) provided by the current look and feel.

setDefaultNamespace(String) - Method in interface javax.xml.stream.XMLEventWriter

Binds a URI to the default namespace This URI is bound in the scope of the current START_ELEMENT / END_ELEMENT pair.

setDefaultNamespace(String) - Method in interface javax.xml.stream.XMLStreamWriter

Binds a URI to the default namespace This URI is bound in the scope of the current START_ELEMENT / END_ELEMENT pair.

setDefaultNamespacePrefix(String) - Method in class javax.xml.crypto.dom.DOMCryptoContext

setDefaultNamespacePrefix(String) - Method in interface javax.xml.crypto.XMLCryptoContext

Sets the default namespace prefix.

setDefaultQueue(LayoutQueue) - Static method in class javax.swing.text.LayoutQueue

Set the default layout queue.

setDefaultRenderer(Class<?>, TableCellRenderer) - Method in class javax.swing.JTable

Sets a default cell renderer to be used if no renderer has been set in a TableColumn.

setDefaultRenderer(TableCellRenderer) - Method in class javax.swing.table.JTableHeader

Sets the default renderer to be used when no headerRenderer is defined by a TableColumn.

setDefaultRequestProperty(String, String) - Static method in class java.net.URLConnection

Deprecated.
The instance specific setRequestProperty method should be used after an appropriate instance of URLConnection is obtained. Invoking this method will have no effect.

setDefaultSelection(JobAttributes.DefaultSelectionType) - Method in class java.awt.JobAttributes

Specifies whether, for jobs using these attributes, the application should print all pages, the range specified by the return value of getPageRanges, or the current selection.

setDefaultSSLSocketFactory(SSLSocketFactory) - Static method in class javax.net.ssl.HttpsURLConnection

Sets the default SSLSocketFactory inherited by new instances of this class.

setDefaultStream(PrintStream) - Static method in class java.rmi.server.LogStream

Deprecated.
no replacement

setDefaultUncaughtExceptionHandler(Thread.UncaughtExceptionHandler) - Static method in class java.lang.Thread

Set the default handler invoked when a thread abruptly terminates due to an uncaught exception, and no other handler has been defined for that thread.

setDefaultUseCaches(boolean) - Method in class java.net.URLConnection

Sets the default value of the useCaches field to the specified value.

setDelay(int) - Method in class javax.swing.JMenu

Sets the suggested delay before the menu's PopupMenu is popped up or down.

setDelay(int) - Method in class javax.swing.Timer

Sets the Timer's between-event delay, the number of milliseconds between successive action events.

setDerefLinkFlag(boolean) - Method in class javax.naming.directory.SearchControls

Enables/disables link dereferencing during the search.

setDescription(String) - Method in class javax.swing.ImageIcon

Sets the description of the image.

setDescriptor(Descriptor) - Method in interface javax.management.DescriptorAccess

Sets Descriptor (full replace).

setDescriptor(Descriptor) - Method in class javax.management.modelmbean.ModelMBeanAttributeInfo

Sets associated Descriptor (full replace) for the ModelMBeanAttributeDescriptor.

setDescriptor(Descriptor) - Method in class javax.management.modelmbean.ModelMBeanConstructorInfo

Sets associated Descriptor (full replace) of ModelMBeanConstructorInfo.

setDescriptor(Descriptor, String) - Method in interface javax.management.modelmbean.ModelMBeanInfo

Sets descriptors in the info array of type inDescriptorType for the ModelMBean.

setDescriptor(Descriptor, String) - Method in class javax.management.modelmbean.ModelMBeanInfoSupport

setDescriptor(Descriptor) - Method in class javax.management.modelmbean.ModelMBeanNotificationInfo

Sets associated Descriptor (full replace) for the ModelMBeanNotificationInfo If the new Descriptor is null, then the associated Descriptor reverts to a default descriptor.

setDescriptor(Descriptor) - Method in class javax.management.modelmbean.ModelMBeanOperationInfo

Sets associated Descriptor (full replace) for the ModelMBeanOperationInfo If the new Descriptor is null, then the associated Descriptor reverts to a default descriptor.

setDescriptors(Descriptor[]) - Method in interface javax.management.modelmbean.ModelMBeanInfo

Adds or replaces descriptors in the ModelMBeanInfo.

setDescriptors(Descriptor[]) - Method in class javax.management.modelmbean.ModelMBeanInfoSupport

setDesignTime(boolean) - Method in class java.beans.beancontext.BeanContextSupport

Sets the new design time value for this BeanContext.

setDesignTime(boolean) - Static method in class java.beans.Beans

Used to indicate whether of not we are running in an application builder environment.

setDesignTime(boolean) - Method in interface java.beans.DesignMode

Sets the "value" of the "designTime" property.

setDesktopIcon(JInternalFrame.JDesktopIcon) - Method in class javax.swing.JInternalFrame

Sets the JDesktopIcon associated with this JInternalFrame.

setDesktopManager(DesktopManager) - Method in class javax.swing.JDesktopPane

Sets the DesktopManger that will handle desktop-specific UI actions.

setDesktopProperty(String, Object) - Method in class java.awt.Toolkit

Sets the named desktop property to the specified value and fires a property change event to notify any listeners that the value has changed.

setDestination(JobAttributes.DestinationType) - Method in class java.awt.JobAttributes

Specifies whether output will be to a printer or a file for jobs using these attributes.

setDestination(BufferedImage) - Method in class javax.imageio.ImageReadParam

Supplies a BufferedImage to be used as the destination for decoded pixel data.

setDestinationBands(int[]) - Method in class javax.imageio.ImageReadParam

Sets the indices of the destination bands where data will be placed.

setDestinationOffset(Point) - Method in class javax.imageio.IIOParam

Specifies the offset in the destination image at which future decoded pixels are to be placed, when reading, or where a region will be written, when writing.

setDestinationType(ImageTypeSpecifier) - Method in class javax.imageio.IIOParam

Sets the desired image type for the destination image, using an ImageTypeSpecifier.

setDestinationType(ImageTypeSpecifier) - Method in class javax.imageio.ImageReadParam

setDialog(JobAttributes.DialogType) - Method in class java.awt.JobAttributes

Specifies whether, for jobs using these attributes, the user should see a print dialog in which to modify the print settings, and which type of print dialog should be displayed.

setDialogTitle(String) - Method in class javax.swing.JFileChooser

Sets the string that goes in the JFileChooser window's title bar.

setDialogType(int) - Method in class javax.swing.JFileChooser

Sets the type of this dialog.

setDictionary(byte[], int, int) - Method in class java.util.zip.Deflater

Sets preset dictionary for compression.

setDictionary(byte[]) - Method in class java.util.zip.Deflater

Sets preset dictionary for compression.

setDictionary(byte[], int, int) - Method in class java.util.zip.Inflater

Sets the preset dictionary to the given array of bytes.

setDictionary(byte[]) - Method in class java.util.zip.Inflater

Sets the preset dictionary to the given array of bytes.

setDifferenceMode(boolean) - Method in class javax.management.monitor.CounterMonitor

Sets the difference mode flag value common to all observed MBeans.

setDifferenceMode(boolean) - Method in interface javax.management.monitor.CounterMonitorMBean

Sets the difference mode flag value.

setDifferenceMode(boolean) - Method in class javax.management.monitor.GaugeMonitor

Sets the difference mode flag value common to all observed MBeans.

setDifferenceMode(boolean) - Method in interface javax.management.monitor.GaugeMonitorMBean

Sets the difference mode flag value.

setDigit(char) - Method in class java.text.DecimalFormatSymbols

Sets the character used for a digit in a pattern.

setDimensions(int, int) - Method in class java.awt.image.BufferedImageFilter

Filters the information provided in the setDimensions method of the ImageConsumer interface.

setDimensions(int, int) - Method in class java.awt.image.CropImageFilter

Override the source image's dimensions and pass the dimensions of the rectangular cropped region to the ImageConsumer.

setDimensions(int, int) - Method in interface java.awt.image.ImageConsumer

The dimensions of the source image are reported using the setDimensions method call.

setDimensions(int, int) - Method in class java.awt.image.ImageFilter

Filters the information provided in the setDimensions method of the ImageConsumer interface.

setDimensions(int, int) - Method in class java.awt.image.PixelGrabber

The setDimensions method is part of the ImageConsumer API which this class must implement to retrieve the pixels.

setDimensions(int, int) - Method in class java.awt.image.ReplicateScaleFilter

Override the dimensions of the source image and pass the dimensions of the new scaled size to the ImageConsumer.

setDirection(int) - Method in class javax.swing.plaf.basic.BasicArrowButton

Sets the direction of the arrow.

setDirection(int) - Method in class javax.swing.plaf.basic.BasicScrollBarUI.ScrollListener

setDirection(int) - Method in class javax.swing.plaf.basic.BasicSliderUI.ScrollListener

setDirection(short) - Method in class javax.swing.text.DefaultStyledDocument.ElementSpec

Sets the direction.

setDirectory(String) - Method in class java.awt.FileDialog

Sets the directory of this file dialog window to be the specified directory.

setDirectory(File) - Method in class javax.swing.plaf.basic.BasicFileChooserUI

Property to remember the directory that is currently selected in the UI.

setDirectoryName(String) - Method in class javax.swing.plaf.basic.BasicFileChooserUI

setDirectoryName(String) - Method in class javax.swing.plaf.metal.MetalFileChooserUI

setDirectorySelected(boolean) - Method in class javax.swing.plaf.basic.BasicFileChooserUI

Property to remember whether a directory is currently selected in the UI.

setDirectorySelected(boolean) - Method in class javax.swing.plaf.metal.MetalFileChooserUI

Property to remember whether a directory is currently selected in the UI.

setDisabledIcon(Icon) - Method in class javax.swing.AbstractButton

Sets the disabled icon for the button.

setDisabledIcon(Icon) - Method in class javax.swing.JLabel

Set the icon to be displayed if this JLabel is "disabled" (JLabel.setEnabled(false)).

setDisabledIconAt(int, Icon) - Method in class javax.swing.JTabbedPane

Sets the disabled icon at index to icon which can be null.

setDisabledSelectedIcon(Icon) - Method in class javax.swing.AbstractButton

Sets the disabled selection icon for the button.

setDisabledTextColor(Color) - Method in class javax.swing.text.JTextComponent

Sets the current color used to render the disabled text.

setDiscard(boolean) - Method in class java.net.HttpCookie

Specify whether user agent should discard the cookie unconditionally.

setDismissDelay(int) - Method in class javax.swing.ToolTipManager

Specifies the dismissal delay value.

setDisplayedMnemonic(int) - Method in class javax.swing.JLabel

Specify a keycode that indicates a mnemonic key.

setDisplayedMnemonic(char) - Method in class javax.swing.JLabel

Specifies the displayedMnemonic as a char value.

setDisplayedMnemonicIndex(int) - Method in class javax.swing.AbstractButton

Provides a hint to the look and feel as to which character in the text should be decorated to represent the mnemonic.

setDisplayedMnemonicIndex(int) - Method in class javax.swing.JLabel

Provides a hint to the look and feel as to which character in the text should be decorated to represent the mnemonic.

setDisplayedMnemonicIndexAt(int, int) - Method in class javax.swing.JTabbedPane

Provides a hint to the look and feel as to which character in the text should be decorated to represent the mnemonic.

setDisplayFormatter(JFormattedTextField.AbstractFormatter) - Method in class javax.swing.text.DefaultFormatterFactory

Sets the JFormattedTextField.AbstractFormatter to use if the JFormattedTextField is not being edited and either the value is not-null, or the value is null and a null formatter has has not been specified.

setDisplayMode(DisplayMode) - Method in class java.awt.GraphicsDevice

Sets the display mode of this graphics device.

setDisplayName(String) - Method in class java.beans.FeatureDescriptor

Sets the localized display name of this feature.

setDividerLocation(double) - Method in class javax.swing.JSplitPane

Sets the divider location as a percentage of the JSplitPane's size.

setDividerLocation(int) - Method in class javax.swing.JSplitPane

Sets the location of the divider.

setDividerLocation(JSplitPane, int) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI

Sets the location of the divider to location.

setDividerLocation(JSplitPane, int) - Method in class javax.swing.plaf.multi.MultiSplitPaneUI

Invokes the setDividerLocation method on each UI handled by this object.

setDividerLocation(JSplitPane, int) - Method in class javax.swing.plaf.SplitPaneUI

Sets the location of the divider to location.

setDividerSize(int) - Method in class javax.swing.JSplitPane

Sets the size of the divider.

setDividerSize(int) - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider

Sets the size of the divider to newSize.

setDockingColor(Color) - Method in class javax.swing.plaf.basic.BasicToolBarUI

Sets the color displayed when over a docking area

setDocument(Document) - Method in class javax.swing.JFormattedTextField

Associates the editor with a text document.

setDocument(Document) - Method in class javax.swing.JTextField

Associates the editor with a text document.

setDocument(Document) - Method in class javax.swing.JTextPane

Associates the editor with a text document.

setDocument(Document) - Method in class javax.swing.text.JTextComponent

Associates the editor with a text document.

setDocumentFilter(DocumentFilter) - Method in class javax.swing.text.AbstractDocument

Sets the DocumentFilter.

setDocumentHandler(DocumentHandler) - Method in class org.xml.sax.helpers.XMLReaderAdapter

Register the SAX1 document event handler.

setDocumentHandler(DocumentHandler) - Method in interface org.xml.sax.Parser

Deprecated.

Allow an application to register a document event handler.

setDocumentLocator(Locator) - Method in interface org.xml.sax.ContentHandler

Receive an object for locating the origin of SAX document events.

setDocumentLocator(Locator) - Method in interface org.xml.sax.DocumentHandler

Deprecated.

Receive an object for locating the origin of SAX document events.

setDocumentLocator(Locator) - Method in class org.xml.sax.HandlerBase

Deprecated.

Receive a Locator object for document events.

setDocumentLocator(Locator) - Method in class org.xml.sax.helpers.DefaultHandler

Receive a Locator object for document events.

setDocumentLocator(Locator) - Method in class org.xml.sax.helpers.ParserAdapter

Adapter implementation method; do not call.

setDocumentLocator(Locator) - Method in class org.xml.sax.helpers.XMLFilterImpl

Filter a new document locator event.

setDocumentLocator(Locator) - Method in class org.xml.sax.helpers.XMLReaderAdapter

Set a document locator.

setDocumentProperties(Dictionary<Object, Object>) - Method in class javax.swing.text.AbstractDocument

Replaces the document properties dictionary for this document.

setDocumentURI(String) - Method in interface org.w3c.dom.Document

The location of the document or null if undefined or if the Document was created using DOMImplementation.createDocument.

setDoInput(boolean) - Method in class java.net.URLConnection

Sets the value of the doInput field for this URLConnection to the specified value.

setDomain(String) - Method in class java.net.HttpCookie

Specifies the domain within which this cookie should be presented.

setDoOutput(boolean) - Method in class java.net.URLConnection

Sets the value of the doOutput field for this URLConnection to the specified value.

setDot(int) - Method in interface javax.swing.text.Caret

Sets the caret position to some position.

setDot(int) - Method in class javax.swing.text.DefaultCaret

Sets the caret position and mark to the specified position, with a forward bias.

setDot(int, Position.Bias) - Method in class javax.swing.text.DefaultCaret

Sets the caret position and mark to the specified position, with the specified bias.

setDot(int, Position.Bias) - Method in class javax.swing.text.NavigationFilter.FilterBypass

Sets the caret location, bypassing the NavigationFilter.

setDot(NavigationFilter.FilterBypass, int, Position.Bias) - Method in class javax.swing.text.NavigationFilter

Invoked prior to the Caret setting the dot.

setDouble(Object, int, double) - Static method in class java.lang.reflect.Array

Sets the value of the indexed component of the specified array object to the specified double value.

setDouble(Object, double) - Method in class java.lang.reflect.Field

Sets the value of a field as a double on the specified object.

setDouble(String, double) - Method in interface java.sql.CallableStatement

Sets the designated parameter to the given Java double value.

setDouble(int, double) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to the given Java double value.

setDouble(int, double) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given double in the Java programming language.

setDouble(String, double) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given Java double value.

setDouble(int, double) - Method in interface javax.sql.RowSet

Sets the designated parameter in this RowSet object's command to the given Java double value.

setDouble(String, double) - Method in interface javax.sql.RowSet

Sets the designated parameter to the given Java double value.

setDoubleBuffered(boolean) - Method in class javax.swing.JComponent

Sets whether this component should use a buffer to paint.

setDoubleBuffered(boolean) - Method in class javax.swing.JRootPane

Sets whether this component should use a buffer to paint.

setDoubleBufferingEnabled(boolean) - Method in class javax.swing.RepaintManager

Enables or disables double buffering in this RepaintManager.

setDoubleBufferMaximumSize(Dimension) - Method in class javax.swing.RepaintManager

Set the maximum double buffer size.

setDragEnabled(boolean) - Method in class javax.swing.JColorChooser

Sets the dragEnabled property, which must be true to enable automatic drag handling (the first part of drag and drop) on this component.

setDragEnabled(boolean) - Method in class javax.swing.JFileChooser

Sets the dragEnabled property, which must be true to enable automatic drag handling (the first part of drag and drop) on this component.

setDragEnabled(boolean) - Method in class javax.swing.JList

Turns on or off automatic drag handling.

setDragEnabled(boolean) - Method in class javax.swing.JTable

Turns on or off automatic drag handling.

setDragEnabled(boolean) - Method in class javax.swing.JTree

Turns on or off automatic drag handling.

setDragEnabled(boolean) - Method in class javax.swing.text.JTextComponent

Turns on or off automatic drag handling.

setDraggedColumn(TableColumn) - Method in class javax.swing.table.JTableHeader

Sets the header's draggedColumn to aColumn.

setDraggedDistance(int) - Method in class javax.swing.table.JTableHeader

Sets the header's draggedDistance to distance.

setDragImage(Image) - Method in class javax.swing.TransferHandler

Sets the drag image parameter.

setDragImageOffset(Point) - Method in class javax.swing.TransferHandler

Sets an anchor offset for the image to drag.

setDragMode(int) - Method in class javax.swing.JDesktopPane

Sets the "dragging style" used by the desktop pane.

setDragOffset(Point) - Method in class javax.swing.plaf.metal.MetalToolBarUI

setDrawsLayeredHighlights(boolean) - Method in class javax.swing.text.DefaultHighlighter

If true, highlights are drawn as the Views draw the text.

setDropAction(int) - Method in class javax.swing.TransferHandler.TransferSupport

Sets the drop action for the transfer - which must represent a drop - to the given action, instead of the default user drop action.

setDropMode(DropMode) - Method in class javax.swing.JList

Sets the drop mode for this component.

setDropMode(DropMode) - Method in class javax.swing.JTable

Sets the drop mode for this component.

setDropMode(DropMode) - Method in class javax.swing.JTree

Sets the drop mode for this component.

setDropMode(DropMode) - Method in class javax.swing.text.JTextComponent

Sets the drop mode for this component.

setDropTarget(DropTarget) - Method in class java.awt.Component

Associate a DropTarget with this component.

setDSTSavings(int) - Method in class java.util.SimpleTimeZone

Sets the amount of time in milliseconds that the clock is advanced during daylight saving time.

setDTDHandler(DTDHandler) - Method in class org.xml.sax.helpers.ParserAdapter

Set the DTD handler.

setDTDHandler(DTDHandler) - Method in class org.xml.sax.helpers.XMLFilterImpl

Set the DTD event handler.

setDTDHandler(DTDHandler) - Method in class org.xml.sax.helpers.XMLReaderAdapter

Register the DTD event handler.

setDTDHandler(DTDHandler) - Method in interface org.xml.sax.Parser

Deprecated.

Allow an application to register a DTD event handler.

setDTDHandler(DTDHandler) - Method in interface org.xml.sax.XMLReader

Allow an application to register a DTD event handler.

setDynamicLayout(boolean) - Method in class java.awt.Toolkit

Controls whether the layout of Containers is validated dynamically during resizing, or statically, after resizing is complete.

setEastPane(JComponent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI

setEchoChar(char) - Method in class java.awt.TextField

Sets the echo character for this text field.

setEchoChar(char) - Method in class javax.swing.JPasswordField

Sets the echo character for this JPasswordField.

setEchoCharacter(char) - Method in class java.awt.TextField

Deprecated.
As of JDK version 1.1, replaced by setEchoChar(char).

setEditable(boolean) - Method in class java.awt.TextComponent

Sets the flag that determines whether or not this text component is editable.

setEditable(boolean) - Method in class javax.swing.JComboBox

Determines whether the JComboBox field is editable.

setEditable(boolean) - Method in class javax.swing.JTree

Determines whether the tree is editable.

setEditable(boolean) - Method in class javax.swing.plaf.basic.BasicTreeUI

Configures the receiver to allow, or not allow, editing.

setEditable(boolean) - Method in class javax.swing.text.JTextComponent

Sets the specified boolean to indicate whether or not this TextComponent should be editable.

setEditFormatter(JFormattedTextField.AbstractFormatter) - Method in class javax.swing.text.DefaultFormatterFactory

Sets the JFormattedTextField.AbstractFormatter to use if the JFormattedTextField is being edited and either the value is not-null, or the value is null and a null formatter has has not been specified.

setEditingColumn(int) - Method in class javax.swing.JTable

Sets the editingColumn variable.

setEditingRow(int) - Method in class javax.swing.JTable

Sets the editingRow variable.

setEditor(ComboBoxEditor) - Method in class javax.swing.JComboBox

Sets the editor used to paint and edit the selected item in the JComboBox field.

setEditor(JComponent) - Method in class javax.swing.JSpinner

Changes the JComponent that displays the current value of the SpinnerModel.

setEditorKit(EditorKit) - Method in class javax.swing.JEditorPane

Sets the currently installed kit for handling content.

setEditorKit(EditorKit) - Method in class javax.swing.JTextPane

Sets the currently installed kit for handling content.

setEditorKitForContentType(String, EditorKit) - Method in class javax.swing.JEditorPane

Directly sets the editor kit to use for the given type.

setEditorSearchPath(String[]) - Static method in class java.beans.PropertyEditorManager

Change the list of package names that will be used for finding property editors.

setEditValid(boolean) - Method in class javax.swing.JFormattedTextField.AbstractFormatter

Invoke this to update the editValid property of the JFormattedTextField.

setElem(int, int) - Method in class java.awt.image.DataBuffer

Sets the requested data array element in the first (default) bank from the given integer.

setElem(int, int, int) - Method in class java.awt.image.DataBuffer

Sets the requested data array element in the specified bank from the given integer.

setElem(int, int) - Method in class java.awt.image.DataBufferByte

Sets the requested data array element in the first (default) bank to the specified value.

setElem(int, int, int) - Method in class java.awt.image.DataBufferByte

Sets the requested data array element in the specified bank from the given integer.

setElem(int, int) - Method in class java.awt.image.DataBufferDouble

Sets the requested data array element in the first (default) bank to the given int.

setElem(int, int, int) - Method in class java.awt.image.DataBufferDouble

Sets the requested data array element in the specified bank to the given int.

setElem(int, int) - Method in class java.awt.image.DataBufferFloat

Sets the requested data array element in the first (default) bank to the given int.

setElem(int, int, int) - Method in class java.awt.image.DataBufferFloat

Sets the requested data array element in the specified bank to the given int.

setElem(int, int) - Method in class java.awt.image.DataBufferInt

Sets the requested data array element in the first (default) bank to the specified value.

setElem(int, int, int) - Method in class java.awt.image.DataBufferInt

Sets the requested data array element in the specified bank to the integer value i.

setElem(int, int) - Method in class java.awt.image.DataBufferShort

Sets the requested data array element in the first (default) bank to the specified value.

setElem(int, int, int) - Method in class java.awt.image.DataBufferShort

Sets the requested data array element in the specified bank from the given integer.

setElem(int, int) - Method in class java.awt.image.DataBufferUShort

Sets the requested data array element in the first (default) bank to the specified value.

setElem(int, int, int) - Method in class java.awt.image.DataBufferUShort

Sets the requested data array element in the specified bank from the given integer.

setElemDouble(int, double) - Method in class java.awt.image.DataBuffer

Sets the requested data array element in the first (default) bank from the given double.

setElemDouble(int, int, double) - Method in class java.awt.image.DataBuffer

Sets the requested data array element in the specified bank from the given double.

setElemDouble(int, double) - Method in class java.awt.image.DataBufferDouble

Sets the requested data array element in the first (default) bank to the given double.

setElemDouble(int, int, double) - Method in class java.awt.image.DataBufferDouble

Sets the requested data array element in the specified bank to the given double.

setElemDouble(int, double) - Method in class java.awt.image.DataBufferFloat

Sets the requested data array element in the first (default) bank to the given double.

setElemDouble(int, int, double) - Method in class java.awt.image.DataBufferFloat

Sets the requested data array element in the specified bank to the given double.

setElementAt(E, int) - Method in class java.util.Vector

Sets the component at the specified index of this vector to be the specified object.

setElementAt(E, int) - Method in class javax.swing.DefaultListModel

Sets the component at the specified index of this list to be the specified element.

setElementQName(QName) - Method in interface javax.xml.soap.SOAPElement

Changes the name of this Element to newName if possible.

setElemFloat(int, float) - Method in class java.awt.image.DataBuffer

Sets the requested data array element in the first (default) bank from the given float.

setElemFloat(int, int, float) - Method in class java.awt.image.DataBuffer

Sets the requested data array element in the specified bank from the given float.

setElemFloat(int, float) - Method in class java.awt.image.DataBufferDouble

Sets the requested data array element in the first (default) bank to the given float.

setElemFloat(int, int, float) - Method in class java.awt.image.DataBufferDouble

Sets the requested data array element in the specified bank to the given float.

setElemFloat(int, float) - Method in class java.awt.image.DataBufferFloat

Sets the requested data array element in the first (default) bank to the given float.

setElemFloat(int, int, float) - Method in class java.awt.image.DataBufferFloat

Sets the requested data array element in the specified bank to the given float.

setEmptyValue(CharSequence) - Method in class java.util.StringJoiner

Sets the sequence of characters to be used when determining the string representation of this StringJoiner and no elements have been added yet, that is, when it is empty.

setEnabled(boolean) - Method in class java.awt.Component.AccessibleAWTComponent

Sets the enabled state of the object.

setEnabled(boolean) - Method in class java.awt.Component

Enables or disables this component, depending on the value of the parameter b.

setEnabled(boolean) - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Set the enabled state of the object.

setEnabled(boolean) - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Sets the enabled state of the object.

setEnabled(boolean) - Method in class java.awt.MenuItem

Sets whether or not this menu item can be chosen.

setEnabled(boolean) - Method in interface javax.accessibility.AccessibleComponent

Sets the enabled state of the object.

setEnabled(boolean) - Method in class javax.swing.AbstractAction

Sets whether the Action is enabled.

setEnabled(boolean) - Method in class javax.swing.AbstractButton

Enables (or disables) the button.

setEnabled(boolean) - Method in interface javax.swing.Action

Sets the enabled state of the Action.

setEnabled(boolean) - Method in interface javax.swing.ButtonModel

Enables or disables the button.

setEnabled(boolean) - Method in class javax.swing.DefaultButtonModel

Enables or disables the button.

setEnabled(boolean) - Method in class javax.swing.JComboBox

Enables the combo box so that items can be selected.

setEnabled(boolean) - Method in class javax.swing.JComponent

Sets whether or not this component is enabled.

setEnabled(boolean) - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

setEnabled(boolean) - Method in class javax.swing.JMenuItem

Enables or disables the menu item.

setEnabled(boolean) - Method in class javax.swing.JScrollBar

Enables the component so that the knob position can be changed.

setEnabled(boolean) - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Sets the enabled state of the object.

setEnabled(boolean) - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

setEnabled(boolean) - Method in class javax.swing.plaf.metal.MetalComboBoxButton

setEnabled(boolean) - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

setEnabled(boolean) - Method in class javax.swing.ToolTipManager

Enables or disables the tooltip.

setEnabledAt(int, boolean) - Method in class javax.swing.JTabbedPane

Sets whether or not the tab at index is enabled.

setEnabledCipherSuites(String[]) - Method in class javax.naming.ldap.StartTlsResponse

Overrides the default list of cipher suites enabled for use on the TLS connection.

setEnabledCipherSuites(String[]) - Method in class javax.net.ssl.SSLEngine

Sets the cipher suites enabled for use on this engine.

setEnabledCipherSuites(String[]) - Method in class javax.net.ssl.SSLServerSocket

Sets the cipher suites enabled for use by accepted connections.

setEnabledCipherSuites(String[]) - Method in class javax.net.ssl.SSLSocket

Sets the cipher suites enabled for use on this connection.

setEnabledProtocols(String[]) - Method in class javax.net.ssl.SSLEngine

Set the protocol versions enabled for use on this engine.

setEnabledProtocols(String[]) - Method in class javax.net.ssl.SSLServerSocket

Controls which particular protocols are enabled for use by accepted connections.

setEnabledProtocols(String[]) - Method in class javax.net.ssl.SSLSocket

Sets the protocol versions enabled for use on this connection.

setEnableSessionCreation(boolean) - Method in class javax.net.ssl.SSLEngine

Controls whether new SSL sessions may be established by this engine.

setEnableSessionCreation(boolean) - Method in class javax.net.ssl.SSLServerSocket

Controls whether new SSL sessions may be established by the sockets which are created from this server socket.

setEnableSessionCreation(boolean) - Method in class javax.net.ssl.SSLSocket

Controls whether new SSL sessions may be established by this socket.

setEncodeTables(JPEGQTable[], JPEGHuffmanTable[], JPEGHuffmanTable[]) - Method in class javax.imageio.plugins.jpeg.JPEGImageWriteParam

Sets the quantization and Huffman tables to use in encoding abbreviated streams.

setEncoding(String) - Method in class java.util.logging.Handler

Set the character encoding used by this Handler.

setEncoding(String) - Method in class java.util.logging.StreamHandler

Set (or change) the character encoding used by this Handler.

setEncoding(String) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

Convenience method for setting the output encoding.

setEncoding(String) - Method in interface org.w3c.dom.ls.LSInput

The character encoding, if known.

setEncoding(String) - Method in interface org.w3c.dom.ls.LSOutput

The character encoding to use for the output.

setEncoding(String) - Method in class org.xml.sax.ext.Locator2Impl

Assigns the current value of the encoding property.

setEncoding(String) - Method in class org.xml.sax.InputSource

Set the character encoding, if known.

setEncodingStyle(String) - Method in interface javax.xml.soap.SOAPElement

Sets the encoding style for this SOAPElement object to one specified.

setEnd(Comparable) - Method in class javax.swing.SpinnerDateModel

Changes the upper limit for Dates in this sequence.

setEndIndex(int) - Method in class java.text.FieldPosition

Sets the end index.

setEndpointContext(EndpointContext) - Method in class javax.xml.ws.Endpoint

By settng a EndpointContext, JAX-WS runtime knows about addresses of other endpoints in an application.

setEndpointIdentificationAlgorithm(String) - Method in class javax.net.ssl.SSLParameters

Sets the endpoint identification algorithm.

setEndRule(int, int, int, int) - Method in class java.util.SimpleTimeZone

Sets the daylight saving time end rule.

setEndRule(int, int, int) - Method in class java.util.SimpleTimeZone

Sets the daylight saving time end rule to a fixed date within a month.

setEndRule(int, int, int, int, boolean) - Method in class java.util.SimpleTimeZone

Sets the daylight saving time end rule to a weekday before or after the given date within a month, e.g., the first Monday on or after the 8th.

setEntityResolver(EntityResolver) - Method in class javax.xml.parsers.DocumentBuilder

Specify the EntityResolver to be used to resolve entities present in the XML document to be parsed.

setEntityResolver(EntityResolver) - Method in class org.xml.sax.helpers.ParserAdapter

Set the entity resolver.

setEntityResolver(EntityResolver) - Method in class org.xml.sax.helpers.XMLFilterImpl

Set the entity resolver.

setEntityResolver(EntityResolver) - Method in class org.xml.sax.helpers.XMLReaderAdapter

Register the entity resolver.

setEntityResolver(EntityResolver) - Method in interface org.xml.sax.Parser

Deprecated.

Allow an application to register a custom entity resolver.

setEntityResolver(EntityResolver) - Method in interface org.xml.sax.XMLReader

Allow an application to register an entity resolver.

setEntry(String, KeyStore.Entry, KeyStore.ProtectionParameter) - Method in class java.security.KeyStore

Saves a keystore Entry under the specified alias.

setEnvironment(Hashtable<?, ?>) - Method in exception javax.naming.CannotProceedException

Sets the environment that will be returned when getEnvironment() is called.

setEras(String[]) - Method in class java.text.DateFormatSymbols

Sets era strings.

setErr(PrintStream) - Static method in class java.lang.System

Reassigns the "standard" error output stream.

setError() - Method in class java.io.PrintStream

Sets the error state of the stream to true.

setError() - Method in class java.io.PrintWriter

Indicates that an error has occurred.

setErrorHandler(ErrorHandler) - Method in class javax.xml.parsers.DocumentBuilder

Specify the ErrorHandler to be used by the parser.

setErrorHandler(ErrorHandler) - Method in class javax.xml.validation.SchemaFactory

Sets the ErrorHandler to receive errors encountered during the newSchema method invocation.

setErrorHandler(ErrorHandler) - Method in class javax.xml.validation.Validator

Sets the ErrorHandler to receive errors encountered during the validate method invocation.

setErrorHandler(ErrorHandler) - Method in class javax.xml.validation.ValidatorHandler

Sets the ErrorHandler to receive errors encountered during the validation.

setErrorHandler(ErrorHandler) - Method in class org.xml.sax.helpers.ParserAdapter

Set the error handler.

setErrorHandler(ErrorHandler) - Method in class org.xml.sax.helpers.XMLFilterImpl

Set the error event handler.

setErrorHandler(ErrorHandler) - Method in class org.xml.sax.helpers.XMLReaderAdapter

Register the error event handler.

setErrorHandler(ErrorHandler) - Method in interface org.xml.sax.Parser

Deprecated.

Allow an application to register an error event handler.

setErrorHandler(ErrorHandler) - Method in interface org.xml.sax.XMLReader

Allow an application to register an error event handler.

setErrorIndex(int) - Method in class java.text.ParsePosition

Set the index at which a parse error occurred.

setErrorListener(ErrorListener) - Method in class javax.xml.transform.Transformer

Set the error event listener in effect for the transformation.

setErrorListener(ErrorListener) - Method in class javax.xml.transform.TransformerFactory

Set the error event listener for the TransformerFactory, which is used for the processing of transformation instructions, and not for the transformation itself.

setErrorManager(ErrorManager) - Method in class java.util.logging.Handler

Define an ErrorManager for this Handler.

setErrorWriter(Writer) - Method in interface javax.script.ScriptContext

Sets the Writer used to display error output.

setErrorWriter(Writer) - Method in class javax.script.SimpleScriptContext

Sets the Writer used to display error output.

setEscapeProcessing(boolean) - Method in interface java.sql.Statement

Sets escape processing on or off.

setEscapeProcessing(boolean) - Method in class javax.sql.rowset.BaseRowSet

Sets to the given boolean whether or not the driver will scan for escape syntax and do escape substitution before sending SQL statements to the database.

setEscapeProcessing(boolean) - Method in interface javax.sql.RowSet

Sets escape processing for this RowSet object on or off.

setEstimatedMajorSpan(boolean) - Method in class javax.swing.text.AsyncBoxView

Set the estimatedMajorSpan property that determines if the major span should be treated as being estimated.

setEventAllocator(XMLEventAllocator) - Method in class javax.xml.stream.XMLInputFactory

Set a user defined event allocator for events

setEventHandler(ValidationEventHandler) - Method in class javax.xml.bind.Binder

Allow an application to register a ValidationEventHandler.

setEventHandler(ValidationEventHandler) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

setEventHandler(ValidationEventHandler) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

Allow an application to register a validation event handler.

setEventHandler(ValidationEventHandler) - Method in interface javax.xml.bind.Marshaller

Allow an application to register a validation event handler.

setEventHandler(ValidationEventHandler) - Method in interface javax.xml.bind.Unmarshaller

Allow an application to register a ValidationEventHandler.

setEventHandler(ValidationEventHandler) - Method in interface javax.xml.bind.Validator

Deprecated.
since JAXB2.0

setException(Throwable) - Method in class java.util.concurrent.FutureTask

Causes this future to report an ExecutionException with the given throwable as its cause, unless this future has already been set or has been cancelled.

setExceptionListener(ExceptionListener) - Method in class java.beans.Encoder

Sets the exception handler for this stream to exceptionListener.

setExceptionListener(ExceptionListener) - Method in class java.beans.XMLDecoder

Sets the exception handler for this stream to exceptionListener.

setExclusiveOwnerThread(Thread) - Method in class java.util.concurrent.locks.AbstractOwnableSynchronizer

Sets the thread that currently owns exclusive access.

setExecutable(boolean, boolean) - Method in class java.io.File

Sets the owner's or everybody's execute permission for this abstract pathname.

setExecutable(boolean) - Method in class java.io.File

A convenience method to set the owner's execute permission for this abstract pathname.

setExecuteExistingDelayedTasksAfterShutdownPolicy(boolean) - Method in class java.util.concurrent.ScheduledThreadPoolExecutor

Sets the policy on whether to execute existing delayed tasks even when this executor has been shutdown.

setExecutor(Executor) - Method in class javax.xml.ws.Endpoint

Sets the executor for this Endpoint instance.

setExecutor(Executor) - Method in class javax.xml.ws.Service

Sets the executor for this Service instance.

setExecutor(Executor) - Method in class javax.xml.ws.spi.ServiceDelegate

Sets the executor for this Service instance.

setExpandedIcon(Icon) - Method in class javax.swing.plaf.basic.BasicTreeUI

setExpandedState(TreePath, boolean) - Method in class javax.swing.JTree

Sets the expanded state of this JTree.

setExpandedState(TreePath, boolean) - Method in class javax.swing.tree.AbstractLayoutCache

Marks the path path expanded state to isExpanded.

setExpandedState(TreePath, boolean) - Method in class javax.swing.tree.FixedHeightLayoutCache

Marks the path path expanded state to isExpanded.

setExpandedState(TreePath, boolean) - Method in class javax.swing.tree.VariableHeightLayoutCache

Marks the path path expanded state to isExpanded.

setExpandEntityReferences(boolean) - Method in class javax.xml.parsers.DocumentBuilderFactory

Specifies that the parser produced by this code will expand entity reference nodes.

setExpandsSelectedPaths(boolean) - Method in class javax.swing.JTree

Configures the expandsSelectedPaths property.

setExpert(boolean) - Method in class java.beans.FeatureDescriptor

The "expert" flag is used to distinguish between features that are intended for expert users from those that are intended for normal users.

setExplicitPolicyRequired(boolean) - Method in class java.security.cert.PKIXParameters

Sets the ExplicitPolicyRequired flag.

setExponentSeparator(String) - Method in class java.text.DecimalFormatSymbols

Sets the string used to separate the mantissa from the exponent.

setExtendedKeyUsage(Set<String>) - Method in class java.security.cert.X509CertSelector

Sets the extendedKeyUsage criterion.

setExtendedState(int) - Method in class java.awt.Frame

Sets the state of this frame.

setExtension(char, String) - Method in class java.util.Locale.Builder

Sets the extension for the given key.

setExtent(int) - Method in interface javax.swing.BoundedRangeModel

Sets the model's extent.

setExtent(int) - Method in class javax.swing.DefaultBoundedRangeModel

Sets the extent to n after ensuring that n is greater than or equal to zero and falls within the model's constraints:

setExtent(int) - Method in class javax.swing.JSlider

Sets the size of the range "covered" by the knob.

setExtentSize(Dimension) - Method in class javax.swing.JViewport

Sets the size of the visible part of the view using view coordinates.

setExtra(byte[]) - Method in class java.util.zip.ZipEntry

Sets the optional extra field data for the entry.

setFailureHandler(RMIFailureHandler) - Static method in class java.rmi.server.RMISocketFactory

Sets the failure handler to be called by the RMI runtime if server socket creation fails.

setFaultActor(String) - Method in interface javax.xml.soap.SOAPFault

Sets this SOAPFault object with the given fault actor.

setFaultCode(Name) - Method in interface javax.xml.soap.SOAPFault

Sets this SOAPFault object with the given fault code.

setFaultCode(QName) - Method in interface javax.xml.soap.SOAPFault

Sets this SOAPFault object with the given fault code.

setFaultCode(String) - Method in interface javax.xml.soap.SOAPFault

Sets this SOAPFault object with the give fault code.

setFaultNode(String) - Method in interface javax.xml.soap.SOAPFault

Creates or replaces any existing Node element value for this SOAPFault object.

setFaultRole(String) - Method in interface javax.xml.soap.SOAPFault

Creates or replaces any existing Role element value for this SOAPFault object.

setFaultString(String) - Method in interface javax.xml.soap.SOAPFault

Sets the fault string for this SOAPFault object to the given string.

setFaultString(String, Locale) - Method in interface javax.xml.soap.SOAPFault

Sets the fault string for this SOAPFault object to the given string and localized to the given locale.

setFeature(String, boolean) - Method in class javax.xml.parsers.DocumentBuilderFactory

Set a feature for this DocumentBuilderFactory and DocumentBuilders created by this factory.

setFeature(String, boolean) - Method in class javax.xml.parsers.SAXParserFactory

Sets the particular feature in the underlying implementation of org.xml.sax.XMLReader.

setFeature(String, boolean) - Method in class javax.xml.transform.TransformerFactory

Set a feature for this TransformerFactory and Transformers or Templates created by this factory.

setFeature(String, boolean) - Method in class javax.xml.validation.SchemaFactory

Set a feature for this SchemaFactory, Schemas created by this factory, and by extension, Validators and ValidatorHandlers created by those Schemas.

setFeature(String, boolean) - Method in class javax.xml.validation.Validator

Set the value of a feature flag.

setFeature(String, boolean) - Method in class javax.xml.validation.ValidatorHandler

Set a feature for this ValidatorHandler.

setFeature(String, boolean) - Method in class javax.xml.xpath.XPathFactory

Set a feature for this XPathFactory and XPaths created by this factory.

setFeature(String, boolean) - Method in class org.xml.sax.helpers.ParserAdapter

Set a feature flag for the parser.

setFeature(String, boolean) - Method in class org.xml.sax.helpers.XMLFilterImpl

Set the value of a feature.

setFeature(String, boolean) - Method in interface org.xml.sax.XMLReader

Set the value of a feature flag.

setFetchDirection(int) - Method in interface java.sql.ResultSet

Gives a hint as to the direction in which the rows in this ResultSet object will be processed.

setFetchDirection(int) - Method in interface java.sql.Statement

Gives the driver a hint as to the direction in which rows will be processed in ResultSet objects created using this Statement object.

setFetchDirection(int) - Method in class javax.sql.rowset.BaseRowSet

Gives the driver a performance hint as to the direction in which the rows in this RowSet object will be processed.

setFetchSize(int) - Method in interface java.sql.ResultSet

Gives the JDBC driver a hint as to the number of rows that should be fetched from the database when more rows are needed for this ResultSet object.

setFetchSize(int) - Method in interface java.sql.Statement

Gives the JDBC driver a hint as to the number of rows that should be fetched from the database when more rows are needed for ResultSet objects generated by this Statement.

setFetchSize(int) - Method in class javax.sql.rowset.BaseRowSet

Sets the fetch size for this RowSet object to the given number of rows.

setField(String, Object) - Method in interface javax.management.Descriptor

Sets the value for a specific field name.

setField(String, Object) - Method in class javax.management.ImmutableDescriptor

This operation is unsupported since this class is immutable.

setField(String, Object) - Method in class javax.management.modelmbean.DescriptorSupport

setFields(int...) - Method in class java.util.Calendar.Builder

Sets field parameters to their values given by fieldValuePairs that are pairs of a field and its value.

setFields(String[], Object[]) - Method in interface javax.management.Descriptor

Sets all fields in the field names array to the new value with the same index in the field values array.

setFields(String[], Object[]) - Method in class javax.management.ImmutableDescriptor

This operation is unsupported since this class is immutable.

setFields(String[], Object[]) - Method in class javax.management.modelmbean.DescriptorSupport

setFile(String) - Method in class java.awt.FileDialog

Sets the selected file for this file dialog window to be the specified file.

setFileFilter(FileFilter) - Method in class javax.swing.JFileChooser

Sets the current file filter.

setFileHidingEnabled(boolean) - Method in class javax.swing.JFileChooser

Sets file hiding on or off.

setFileName(String) - Method in class java.awt.JobAttributes

Specifies the file name for the output file for jobs using these attributes.

setFileName(String) - Method in class javax.swing.plaf.basic.BasicFileChooserUI

setFileName(String) - Method in class javax.swing.plaf.metal.MetalFileChooserUI

setFilenameFilter(FilenameFilter) - Method in class java.awt.FileDialog

Sets the filename filter for this file dialog window to the specified filter.

setFileNameMap(FileNameMap) - Static method in class java.net.URLConnection

Sets the FileNameMap.

setFileSelectionMode(int) - Method in class javax.swing.JFileChooser

Sets the JFileChooser to allow the user to just select files, just select directories, or select both files and directories.

setFileSystemView(FileSystemView) - Method in class javax.swing.JFileChooser

Sets the file system view that the JFileChooser uses for accessing and creating file system resources, such as finding the floppy drive and getting a list of root drives.

setFileTypeMap(FileTypeMap) - Method in class javax.activation.FileDataSource

Set the FileTypeMap to use with this FileDataSource

setFileView(FileView) - Method in class javax.swing.JFileChooser

Sets the file view to used to retrieve UI information, such as the icon that represents a file or the type description of a file.

setFillsViewportHeight(boolean) - Method in class javax.swing.JTable

Sets whether or not this table is always made large enough to fill the height of an enclosing viewport.

setFilter(Filter) - Method in class java.util.logging.Handler

Set a Filter to control output on this Handler.

setFilter(Filter) - Method in class java.util.logging.Logger

Set a filter to control output on this Logger.

setFilter(Predicate) - Method in interface javax.sql.rowset.FilteredRowSet

Applies the given Predicate object to this FilteredRowSet object.

setFilter(LSParserFilter) - Method in interface org.w3c.dom.ls.LSParser

When a filter is provided, the implementation will call out to the filter as it is constructing the DOM tree structure.

setFilter(LSSerializerFilter) - Method in interface org.w3c.dom.ls.LSSerializer

When the application provides a filter, the serializer will call out to the filter before serializing each Node.

setFirstDayOfWeek(int) - Method in class java.util.Calendar

Sets what the first day of the week is; e.g., SUNDAY in the U.S., MONDAY in France.

setFirstLineIndent(float) - Method in class javax.swing.text.ParagraphView

Sets the indent on the first line.

setFirstLineIndent(MutableAttributeSet, float) - Static method in class javax.swing.text.StyleConstants

Sets the first line indent.

setFixedCellHeight(int) - Method in class javax.swing.JList

Sets a fixed value to be used for the height of every cell in the list.

setFixedCellWidth(int) - Method in class javax.swing.JList

Sets a fixed value to be used for the width of every cell in the list.

setFixedLengthStreamingMode(int) - Method in class java.net.HttpURLConnection

This method is used to enable streaming of a HTTP request body without internal buffering, when the content length is known in advance.

setFixedLengthStreamingMode(long) - Method in class java.net.HttpURLConnection

This method is used to enable streaming of a HTTP request body without internal buffering, when the content length is known in advance.

setFlags(Set<AclEntryFlag>) - Method in class java.nio.file.attribute.AclEntry.Builder

Sets the flags component of this builder.

setFlags(AclEntryFlag...) - Method in class java.nio.file.attribute.AclEntry.Builder

Sets the flags component of this builder.

setFlashColor(Color) - Static method in class javax.swing.DebugGraphics

Sets the Color used to flash drawing operations.

setFlashCount(int) - Static method in class javax.swing.DebugGraphics

Sets the number of times that drawing operations will flash.

setFlashTime(int) - Static method in class javax.swing.DebugGraphics

Sets the time delay of drawing operation flashing.

setFlavorMap(FlavorMap) - Method in class java.awt.dnd.DropTarget

Sets the FlavorMap associated with this DropTarget.

setFlavorsForNative(String, DataFlavor[]) - Method in class java.awt.datatransfer.SystemFlavorMap

Discards the current mappings for the specified String native, and creates new mappings to the specified DataFlavors.

setFloat(Object, int, float) - Static method in class java.lang.reflect.Array

Sets the value of the indexed component of the specified array object to the specified float value.

setFloat(Object, float) - Method in class java.lang.reflect.Field

Sets the value of a field as a float on the specified object.

setFloat(String, float) - Method in interface java.sql.CallableStatement

Sets the designated parameter to the given Java float value.

setFloat(int, float) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to the given Java float value.

setFloat(int, float) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given float in the Java programming language.

setFloat(String, float) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given Java float value.

setFloat(int, float) - Method in interface javax.sql.RowSet

Sets the designated parameter in this RowSet object's command to the given Java float value.

setFloat(String, float) - Method in interface javax.sql.RowSet

Sets the designated parameter to the given Java float value.

setFloatable(boolean) - Method in class javax.swing.JToolBar

Sets the floatable property, which must be true for the user to move the tool bar.

setFloating(boolean, Point) - Method in class javax.swing.plaf.basic.BasicToolBarUI

setFloatingColor(Color) - Method in class javax.swing.plaf.basic.BasicToolBarUI

Sets the color displayed when over a floating area

setFloatingLocation(int, int) - Method in class javax.swing.plaf.basic.BasicToolBarUI

setFocusable(boolean) - Method in class java.awt.Component

Sets the focusable state of this Component to the specified value.

setFocusableWindowState(boolean) - Method in class java.awt.Window

Sets whether this Window can become the focused Window if it meets the other requirements outlined in isFocusableWindow.

setFocusAccelerator(char) - Method in class javax.swing.text.JTextComponent

Sets the key accelerator that will cause the receiving text component to get the focus.

setFocusCycleRoot(boolean) - Method in class java.awt.Container

Sets whether this Container is the root of a focus traversal cycle.

setFocusCycleRoot(boolean) - Method in class java.awt.Window

Does nothing because Windows must always be roots of a focus traversal cycle.

setFocusCycleRoot(boolean) - Method in class javax.swing.JInternalFrame

Does nothing because JInternalFrames must always be roots of a focus traversal cycle.

setFocusLostBehavior(int) - Method in class javax.swing.JFormattedTextField

Sets the behavior when focus is lost.

setFocusPainted(boolean) - Method in class javax.swing.AbstractButton

Sets the paintFocus property, which must be true for the focus state to be painted.

setFocusTraversalKeys(int, Set<? extends AWTKeyStroke>) - Method in class java.awt.Component

Sets the focus traversal keys for a given traversal operation for this Component.

setFocusTraversalKeys(int, Set<? extends AWTKeyStroke>) - Method in class java.awt.Container

Sets the focus traversal keys for a given traversal operation for this Container.

setFocusTraversalKeys(int, Set<? extends AWTKeyStroke>) - Method in class javax.swing.JComponent

Sets the focus traversal keys for a given traversal operation for this Component.

setFocusTraversalKeysEnabled(boolean) - Method in class java.awt.Component

Sets whether focus traversal keys are enabled for this Component.

setFocusTraversalPolicy(FocusTraversalPolicy) - Method in class java.awt.Container

Sets the focus traversal policy that will manage keyboard traversal of this Container's children, if this Container is a focus cycle root.

setFocusTraversalPolicyProvider(boolean) - Method in class java.awt.Container

Sets whether this container will be used to provide focus traversal policy.

setFollowRedirects(boolean) - Static method in class java.net.HttpURLConnection

Sets whether HTTP redirects (requests with response code 3xx) should be automatically followed by this class.

setFont(Font) - Method in class java.awt.Component.AccessibleAWTComponent

Sets the Font of this object.

setFont(Font) - Method in class java.awt.Component

Sets the font of this component.

setFont(Font) - Method in class java.awt.Container

Sets the font of this container.

setFont(Font) - Method in class java.awt.Graphics

Sets this graphics context's font to the specified font.

setFont(Font) - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Set the Font of this object.

setFont(Font) - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Sets the Font of this object.

setFont(Font) - Method in class java.awt.MenuComponent

Sets the font to be used for this menu component to the specified font.

setFont(Font) - Method in interface javax.accessibility.AccessibleComponent

Sets the Font of this object.

setFont(Font) - Method in class javax.swing.DebugGraphics

Sets the Font used for text drawing operations.

setFont(Font) - Method in class javax.swing.JComponent

Sets the font for this component.

setFont(Font) - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

setFont(Font) - Method in class javax.swing.JSlider

Sets the font for this component.

setFont(Font) - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Sets the Font of this object.

setFont(Font) - Method in class javax.swing.JTextArea

Sets the current font.

setFont(Font) - Method in class javax.swing.JTextField

Sets the current font.

setFont(Font) - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

setFont(Font) - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

setFont(Font) - Method in class javax.swing.tree.DefaultTreeCellEditor

Sets the font to edit with.

setFont(Font) - Method in class javax.swing.tree.DefaultTreeCellRenderer

Subclassed to map FontUIResources to null.

setFontFamily(MutableAttributeSet, String) - Static method in class javax.swing.text.StyleConstants

Sets the font attribute.

setFontSize(MutableAttributeSet, int) - Static method in class javax.swing.text.StyleConstants

Sets the font size attribute.

setForeground(Color) - Method in class java.awt.Component.AccessibleAWTComponent

Sets the foreground color of this object.

setForeground(Color) - Method in class java.awt.Component

Sets the foreground color of this component.

setForeground(Color) - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Set the foreground color of this object.

setForeground(Color) - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Sets the foreground color of this object.

setForeground(Color) - Method in interface javax.accessibility.AccessibleComponent

Sets the foreground color of this object.

setForeground(Color) - Method in class javax.swing.JComponent

Sets the foreground color of this component.

setForeground(Color) - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

setForeground(Color) - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Sets the foreground color of this object.

setForeground(Color) - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

setForeground(Color) - Method in class javax.swing.table.DefaultTableCellRenderer

Overrides JComponent.setForeground to assign the unselected-foreground color to the specified color.

setForeground(Color) - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

setForeground(MutableAttributeSet, Color) - Static method in class javax.swing.text.StyleConstants

Sets the foreground color.

setForegroundAt(int, Color) - Method in class javax.swing.JTabbedPane

Sets the foreground color at index to foreground which can be null, in which case the tab's foreground color will default to the foreground color of this tabbedpane.

setForkJoinTaskTag(short) - Method in class java.util.concurrent.ForkJoinTask

Atomically sets the tag value for this task.

setFormat(int, Format) - Method in class java.text.MessageFormat

Sets the format to use for the format element with the given format element index within the previously set pattern string.

setFormat(DateFormat) - Method in class javax.swing.text.DateFormatter

Sets the format that dictates the legal values that can be edited and displayed.

setFormat(Format) - Method in class javax.swing.text.InternationalFormatter

Sets the format that dictates the legal values that can be edited and displayed.

setFormat(Format) - Method in class javax.swing.text.NumberFormatter

Sets the format that dictates the legal values that can be edited and displayed.

setFormatByArgumentIndex(int, Format) - Method in class java.text.MessageFormat

Sets the format to use for the format elements within the previously set pattern string that use the given argument index.

setFormats(Format[]) - Method in class java.text.MessageFormat

Sets the formats to use for the format elements in the previously set pattern string.

setFormatsByArgumentIndex(Format[]) - Method in class java.text.MessageFormat

Sets the formats to use for the values passed into format methods or returned from parse methods.

setFormattedOutput(boolean) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

Convenience method for setting the formatted output flag.

setFormatter(Formatter) - Method in class java.util.logging.Handler

Set a Formatter.

setFormatter(JFormattedTextField.AbstractFormatter) - Method in class javax.swing.JFormattedTextField

Sets the current AbstractFormatter.

setFormatterFactory(JFormattedTextField.AbstractFormatterFactory) - Method in class javax.swing.JFormattedTextField

Sets the AbstractFormatterFactory.

setFractionalSecond(BigDecimal) - Method in class javax.xml.datatype.XMLGregorianCalendar

Set fractional seconds.

setFragment(boolean) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

Convenience method for setting the fragment flag.

setFrame(double, double, double, double) - Method in class java.awt.geom.Arc2D

Sets the location and size of the framing rectangle of this Shape to the specified rectangular values.

setFrame(double, double, double, double) - Method in class java.awt.geom.Ellipse2D.Double

Sets the location and size of the framing rectangle of this Shape to the specified rectangular values.

setFrame(float, float, float, float) - Method in class java.awt.geom.Ellipse2D.Float

Sets the location and size of the framing rectangle of this Shape to the specified rectangular values.

setFrame(double, double, double, double) - Method in class java.awt.geom.Ellipse2D.Float

Sets the location and size of the framing rectangle of this Shape to the specified rectangular values.

setFrame(double, double, double, double) - Method in class java.awt.geom.Rectangle2D

Sets the location and size of the outer bounds of this Rectangle2D to the specified rectangular values.

setFrame(double, double, double, double) - Method in class java.awt.geom.RectangularShape

Sets the location and size of the framing rectangle of this Shape to the specified rectangular values.

setFrame(Point2D, Dimension2D) - Method in class java.awt.geom.RectangularShape

Sets the location and size of the framing rectangle of this Shape to the specified Point2D and Dimension2D, respectively.

setFrame(Rectangle2D) - Method in class java.awt.geom.RectangularShape

Sets the framing rectangle of this Shape to be the specified Rectangle2D.

setFrame(double, double, double, double) - Method in class java.awt.geom.RoundRectangle2D

Sets the location and size of the framing rectangle of this Shape to the specified rectangular values.

setFrameFromCenter(double, double, double, double) - Method in class java.awt.geom.RectangularShape

Sets the framing rectangle of this Shape based on the specified center point coordinates and corner point coordinates.

setFrameFromCenter(Point2D, Point2D) - Method in class java.awt.geom.RectangularShape

Sets the framing rectangle of this Shape based on a specified center Point2D and corner Point2D.

setFrameFromDiagonal(double, double, double, double) - Method in class java.awt.geom.RectangularShape

Sets the diagonal of the framing rectangle of this Shape based on the two specified coordinates.

setFrameFromDiagonal(Point2D, Point2D) - Method in class java.awt.geom.RectangularShape

Sets the diagonal of the framing rectangle of this Shape based on two specified Point2D objects.

setFrameIcon(Icon) - Method in class javax.swing.JInternalFrame

Sets an image to be displayed in the titlebar of this internal frame (usually in the top-left corner).

setFramePosition(int) - Method in interface javax.sound.sampled.Clip

Sets the media position in sample frames.

setFreeStanding(boolean) - Method in class javax.swing.plaf.metal.MetalScrollButton

setFromPage(int) - Method in class java.awt.JobAttributes

Specifies, for jobs using these attributes, the first page to be printed, if a range of pages is to be printed.

setFromTree(String, Node) - Method in class javax.imageio.metadata.IIOMetadata

Sets the internal state of this IIOMetadata object from a tree of XML DOM Nodes whose syntax is defined by the given metadata format.

setFullBufferUpdates(boolean) - Method in class java.awt.image.MemoryImageSource

Specifies whether this animated memory image should always be updated by sending the complete buffer of pixels whenever there is a change.

setFullScreenWindow(Window) - Method in class java.awt.GraphicsDevice

Enter full-screen mode, or return to windowed mode.

setGlassPane(Component) - Method in class javax.swing.JApplet

Sets the glassPane property.

setGlassPane(Component) - Method in class javax.swing.JDialog

Sets the glassPane property.

setGlassPane(Component) - Method in class javax.swing.JFrame

Sets the glassPane property.

setGlassPane(Component) - Method in class javax.swing.JInternalFrame

Sets this JInternalFrame's glassPane property.

setGlassPane(JPanel) - Method in class javax.swing.JLayer

Sets the JLayer's glassPane component, which can be null.

setGlassPane(Component) - Method in class javax.swing.JRootPane

Sets a specified Component to be the glass pane for this root pane.

setGlassPane(Component) - Method in class javax.swing.JWindow

Sets the glassPane property.

setGlassPane(Component) - Method in interface javax.swing.RootPaneContainer

The glassPane is always the first child of the rootPane and the rootPanes layout manager ensures that it's always as big as the rootPane.

setGlobalActiveWindow(Window) - Method in class java.awt.KeyboardFocusManager

Sets the active Window.

setGlobalCurrentFocusCycleRoot(Container) - Method in class java.awt.KeyboardFocusManager

Sets the current focus cycle root.

setGlobalFocusedWindow(Window) - Method in class java.awt.KeyboardFocusManager

Sets the focused Window.

setGlobalFocusOwner(Component) - Method in class java.awt.KeyboardFocusManager

Sets the focus owner.

setGlobalPermanentFocusOwner(Component) - Method in class java.awt.KeyboardFocusManager

Sets the permanent focus owner.

setGlyphPainter(GlyphView.GlyphPainter) - Method in class javax.swing.text.GlyphView

Sets the painter to use for rendering glyphs.

setGlyphPosition(int, Point2D) - Method in class java.awt.font.GlyphVector

Sets the position of the specified glyph within this GlyphVector.

setGlyphTransform(int, AffineTransform) - Method in class java.awt.font.GlyphVector

Sets the transform of the specified glyph within this GlyphVector.

setGranularityPeriod(long) - Method in class javax.management.monitor.Monitor

Sets the granularity period (in milliseconds).

setGranularityPeriod(long) - Method in interface javax.management.monitor.MonitorMBean

Sets the granularity period (in milliseconds).

setGregorianChange(Date) - Method in class java.util.GregorianCalendar

Sets the GregorianCalendar change date.

setGridColor(Color) - Method in class javax.swing.JTable

Sets the color used to draw grid lines to gridColor and redisplays.

setGridLocation(int, int) - Method in class javax.swing.text.TableView.TableCell

Deprecated.

Sets the grid location.

setGroup(GroupPrincipal) - Method in interface java.nio.file.attribute.PosixFileAttributeView

Updates the file group-owner.

setGroup(ButtonGroup) - Method in interface javax.swing.ButtonModel

Identifies the group the button belongs to -- needed for radio buttons, which are mutually exclusive within their group.

setGroup(ButtonGroup) - Method in class javax.swing.DefaultButtonModel

Identifies the group the button belongs to -- needed for radio buttons, which are mutually exclusive within their group.

setGroupingSeparator(char) - Method in class java.text.DecimalFormatSymbols

Sets the character used for thousands separator.

setGroupingSize(int) - Method in class java.text.DecimalFormat

Set the grouping size.

setGroupingUsed(boolean) - Method in class java.text.DecimalFormat

Set whether or not grouping will be used in this format.

setGroupingUsed(boolean) - Method in class java.text.NumberFormat

Set whether or not grouping will be used in this format.

setGuiAvailable(boolean) - Static method in class java.beans.Beans

Used to indicate whether of not we are running in an environment where GUI interaction is available.

setHandler(ContentHandler) - Method in class javax.xml.transform.sax.SAXResult

Set the target to be a SAX2 ContentHandler.

setHandler(HttpHandler) - Method in class javax.xml.ws.spi.http.HttpContext

JAX-WS runtime sets its handler during Endpoint.publish(HttpContext) to handle HTTP requests for this context.

setHandlerChain(List<Handler>) - Method in interface javax.xml.ws.Binding

Sets the handler chain for the protocol binding instance.

setHandlerResolver(HandlerResolver) - Method in class javax.xml.ws.Service

Sets the HandlerResolver for this Service instance.

setHandlerResolver(HandlerResolver) - Method in class javax.xml.ws.spi.ServiceDelegate

Sets the HandlerResolver for this Service instance.

setHashColor(Color) - Method in class javax.swing.plaf.basic.BasicTreeUI

setHeader(String, String) - Method in class javax.xml.soap.MimeHeaders

Replaces the current value of the first header entry whose name matches the given name with the given value, adding a new header if no existing header name matches.

setHeaderRenderer(TableCellRenderer) - Method in class javax.swing.table.TableColumn

Sets the TableCellRenderer used to draw the TableColumn's header to headerRenderer.

setHeaderValue(Object) - Method in class javax.swing.table.TableColumn

Sets the Object whose string representation will be used as the value for the headerRenderer.

setHeight(Spring) - Method in class javax.swing.SpringLayout.Constraints

Sets the height property, which controls the height of a component.

setHelpMenu(Menu) - Method in class java.awt.MenuBar

Sets the specified menu to be this menu bar's help menu.

setHelpMenu(JMenu) - Method in class javax.swing.JMenuBar

Sets the help menu that appears when the user selects the "help" option in the menu bar.

setHgap(int) - Method in class java.awt.BorderLayout

Sets the horizontal gap between components.

setHgap(int) - Method in class java.awt.CardLayout

Sets the horizontal gap between components.

setHgap(int) - Method in class java.awt.FlowLayout

Sets the horizontal gap between components and between the components and the borders of the Container.

setHgap(int) - Method in class java.awt.GridLayout

Sets the horizontal gap between components to the specified value.

setHidden(boolean) - Method in class java.beans.FeatureDescriptor

The "hidden" flag is used to identify features that are intended only for tool use, and which should not be exposed to humans.

setHidden(boolean) - Method in interface java.nio.file.attribute.DosFileAttributeView

Updates the value of the hidden attribute.

setHideActionText(boolean) - Method in class javax.swing.AbstractButton

Sets the hideActionText property, which determines whether the button displays text from the Action.

setHighlighter(Highlighter) - Method in class javax.swing.text.JTextComponent

Sets the highlighter to be used.

setHints(int) - Method in class java.awt.image.AreaAveragingScaleFilter

Detect if the data is being delivered with the necessary hints to allow the averaging algorithm to do its work.

setHints(int) - Method in interface java.awt.image.ImageConsumer

Sets the hints that the ImageConsumer uses to process the pixels delivered by the ImageProducer.

setHints(int) - Method in class java.awt.image.ImageFilter

Filters the information provided in the setHints method of the ImageConsumer interface.

setHints(int) - Method in class java.awt.image.PixelGrabber

The setHints method is part of the ImageConsumer API which this class must implement to retrieve the pixels.

setHoldability(int) - Method in interface java.sql.Connection

Changes the default holdability of ResultSet objects created using this Connection object to the given holdability.

setHonorsVisibility(boolean) - Method in class javax.swing.GroupLayout

Sets whether component visibility is considered when sizing and positioning components.

setHonorsVisibility(Component, Boolean) - Method in class javax.swing.GroupLayout

Sets whether the component's visibility is considered for sizing and positioning.

setHorizontalAlignment(int) - Method in class javax.swing.AbstractButton

Sets the horizontal alignment of the icon and text.

setHorizontalAlignment(int) - Method in class javax.swing.JLabel

Sets the alignment of the label's contents along the X axis.

setHorizontalAlignment(int) - Method in class javax.swing.JTextField

Sets the horizontal alignment of the text.

setHorizontalGroup(GroupLayout.Group) - Method in class javax.swing.GroupLayout

Sets the Group that positions and sizes components along the horizontal axis.

setHorizontalScrollBar(JScrollBar) - Method in class javax.swing.JScrollPane

Adds the scrollbar that controls the viewport's horizontal view position to the scrollpane.

setHorizontalScrollBarPolicy(int) - Method in class javax.swing.JScrollPane

Determines when the horizontal scrollbar appears in the scrollpane.

setHorizontalScrollBarPolicy(int) - Method in class javax.swing.ScrollPaneLayout

Sets the horizontal scrollbar-display policy.

setHorizontalTextPosition(int) - Method in class javax.swing.AbstractButton

Sets the horizontal position of the text relative to the icon.

setHorizontalTextPosition(int) - Method in class javax.swing.JLabel

Sets the horizontal position of the label's text, relative to its image.

setHostnameVerifier(HostnameVerifier) - Method in class javax.naming.ldap.StartTlsResponse

Sets the hostname verifier used by negotiate() after the TLS handshake has completed and the default hostname verification has failed.

setHostnameVerifier(HostnameVerifier) - Method in class javax.net.ssl.HttpsURLConnection

Sets the HostnameVerifier for this instance.

setHour(int) - Method in class javax.xml.datatype.XMLGregorianCalendar

Set hours.

setHours(int) - Method in class java.sql.Date

Deprecated.

setHours(int) - Method in class java.util.Date

Deprecated.
As of JDK version 1.1, replaced by Calendar.set(Calendar.HOUR_OF_DAY, int hours).

setHttpOnly(boolean) - Method in class java.net.HttpCookie

Indicates whether the cookie should be considered HTTP Only.

setHumanPresentableName(String) - Method in class java.awt.datatransfer.DataFlavor

Sets the human presentable name for the data format that this DataFlavor represents.

setHumanPresentableName(String) - Method in class javax.activation.ActivationDataFlavor

Set the human presentable name.

setIcon(Icon) - Method in class javax.swing.AbstractButton

Sets the button's default icon.

setIcon(boolean) - Method in class javax.swing.JInternalFrame

Iconifies or de-iconifies this internal frame, if the look and feel supports iconification.

setIcon(Icon) - Method in class javax.swing.JLabel

Defines the icon this component will display.

setIcon(Icon) - Method in class javax.swing.JOptionPane

Sets the icon to display.

setIcon(MutableAttributeSet, Icon) - Static method in class javax.swing.text.StyleConstants

Sets the icon attribute.

setIconAt(int, Icon) - Method in class javax.swing.JTabbedPane

Sets the icon at index to icon which can be null.

setIconifiable(boolean) - Method in class javax.swing.JInternalFrame

Sets the iconable property, which must be true for the user to be able to make the JInternalFrame an icon.

setIconImage(Image) - Method in class java.awt.Frame

Sets the image to be displayed as the icon for this window.

setIconImage(Image) - Method in class java.awt.Window

Sets the image to be displayed as the icon for this window.

setIconImage(Image) - Method in class javax.swing.JFrame

Sets the image to be displayed as the icon for this window.

setIconImages(List<? extends Image>) - Method in class java.awt.Window

Sets the sequence of images to be displayed as the icon for this window.

setIconOnly(boolean) - Method in class javax.swing.plaf.metal.MetalComboBoxButton

setIconTextGap(int) - Method in class javax.swing.AbstractButton

If both the icon and text properties are set, this property defines the space between them.

setIconTextGap(int) - Method in class javax.swing.JLabel

If both the icon and text properties are set, this property defines the space between them.

setID(String) - Method in class java.util.TimeZone

Sets the time zone ID.

setIdAttribute(String, boolean) - Method in class javax.imageio.metadata.IIOMetadataNode

This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.

setIdAttribute(String, boolean) - Method in interface org.w3c.dom.Element

If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute .

setIdAttributeNode(Attr, boolean) - Method in class javax.imageio.metadata.IIOMetadataNode

This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.

setIdAttributeNode(Attr, boolean) - Method in interface org.w3c.dom.Element

If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute .

setIdAttributeNS(String, String, boolean) - Method in class javax.imageio.metadata.IIOMetadataNode

This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.

setIdAttributeNS(Element, String, String) - Method in class javax.xml.crypto.dom.DOMCryptoContext

Registers the element's attribute specified by the namespace URI and local name to be of type ID.

setIdAttributeNS(String, String, boolean) - Method in interface org.w3c.dom.Element

If the parameter isId is true, this method declares the specified attribute to be a user-determined ID attribute .

setIdentifier(Object) - Method in class javax.swing.table.TableColumn

Sets the TableColumn's identifier to anIdentifier.

setIfModifiedSince(long) - Method in class java.net.URLConnection

Sets the value of the ifModifiedSince field of this URLConnection to the specified value.

setIgnoreRepaint(boolean) - Method in class java.awt.Component

Sets whether or not paint messages received from the operating system should be ignored.

setIgnoringComments(boolean) - Method in class javax.xml.parsers.DocumentBuilderFactory

Specifies that the parser produced by this code will ignore comments.

setIgnoringElementContentWhitespace(boolean) - Method in class javax.xml.parsers.DocumentBuilderFactory

Specifies that the parsers created by this factory must eliminate whitespace in element content (sometimes known loosely as 'ignorable whitespace') when parsing XML documents (see XML Rec 2.10).

setImage(Image) - Method in class java.awt.TrayIcon

Sets the image for this TrayIcon.

setImage(Image) - Method in class javax.swing.ImageIcon

Sets the image displayed by this icon.

setImageableArea(double, double, double, double) - Method in class java.awt.print.Paper

Sets the imageable area of this Paper.

setImageAutoSize(boolean) - Method in class java.awt.TrayIcon

Sets the auto-size property.

setImageObserver(ImageObserver) - Method in class javax.swing.ImageIcon

Sets the image observer for the image.

setImageURL(URL) - Method in class java.awt.SplashScreen

Changes the splash screen image.

setImplementation(Object) - Method in class javax.management.StandardMBean

Replace the implementation object wrapped in this object.

setImplicitDownCycleTraversal(boolean) - Method in class java.awt.ContainerOrderFocusTraversalPolicy

Sets whether this ContainerOrderFocusTraversalPolicy transfers focus down-cycle implicitly.

setImplicitDownCycleTraversal(boolean) - Method in class javax.swing.SortingFocusTraversalPolicy

Sets whether this SortingFocusTraversalPolicy transfers focus down-cycle implicitly.

setIn(InputStream) - Static method in class java.lang.System

Reassigns the "standard" input stream.

setInDefaultEventSet(boolean) - Method in class java.beans.EventSetDescriptor

Marks an event set as being in the "default" set (or not).

setIndentSpace(int) - Method in class javax.swing.text.AbstractWriter

Enables subclasses to specify how many spaces an indent maps to.

setIndeterminate(boolean) - Method in class javax.swing.JProgressBar

Sets the indeterminate property of the progress bar, which determines whether the progress bar is in determinate or indeterminate mode.

setIndex(int) - Method in interface java.text.CharacterIterator

Sets the position to the specified position in the text and returns that character.

setIndex(int) - Method in class java.text.ParsePosition

Set the current parse position.

setIndex(int) - Method in class java.text.StringCharacterIterator

Implements CharacterIterator.setIndex() for String.

setIndex(int) - Method in class javax.swing.text.Segment

Sets the position to the specified position in the text and returns that character.

setIndexedReadMethod(Method) - Method in class java.beans.IndexedPropertyDescriptor

Sets the method that should be used to read an indexed property value.

setIndexedWriteMethod(Method) - Method in class java.beans.IndexedPropertyDescriptor

Sets the method that should be used to write an indexed property value.

setInfinity(String) - Method in class java.text.DecimalFormatSymbols

Sets the string used to represent infinity.

setInfo(String) - Method in class java.security.Identity

Deprecated.

Specifies a general information string for this identity.

setInheritsPopupMenu(boolean) - Method in class javax.swing.JComponent

Sets whether or not getComponentPopupMenu should delegate to the parent if this component does not have a JPopupMenu assigned to it.

setInitialContextFactoryBuilder(InitialContextFactoryBuilder) - Static method in class javax.naming.spi.NamingManager

Sets the InitialContextFactory builder to be builder.

setInitialDelay(int) - Method in class javax.swing.Timer

Sets the Timer's initial delay, the time in milliseconds to wait after the timer is started before firing the first event.

setInitialDelay(int) - Method in class javax.swing.ToolTipManager

Specifies the initial delay value.

setInitialPolicies(Set<String>) - Method in class java.security.cert.PKIXParameters

Sets the Set of initial policy identifiers (OID strings), indicating that any one of these policies would be acceptable to the certificate user for the purposes of certification path processing.

setInitialSelectionValue(Object) - Method in class javax.swing.JOptionPane

Sets the input value that is initially displayed as selected to the user.

setInitialValue(Object) - Method in class javax.swing.JOptionPane

Sets the initial value that is to be enabled -- the Component that has the focus when the pane is initially displayed.

setInitThreshold(Number) - Method in class javax.management.monitor.CounterMonitor

Sets the initial threshold value common to all observed objects.

setInitThreshold(Number) - Method in interface javax.management.monitor.CounterMonitorMBean

Sets the initial threshold value common to all observed MBeans.

setInnerHTML(Element, String) - Method in class javax.swing.text.html.HTMLDocument

Replaces the children of the given element with the contents specified as an HTML string.

setInput(byte[], int, int) - Method in class java.util.zip.Deflater

Sets input data for compression.

setInput(byte[]) - Method in class java.util.zip.Deflater

Sets input data for compression.

setInput(byte[], int, int) - Method in class java.util.zip.Inflater

Sets input data for decompression.

setInput(byte[]) - Method in class java.util.zip.Inflater

Sets input data for decompression.

setInput(Object, boolean, boolean) - Method in class javax.imageio.ImageReader

Sets the input source to use to the given ImageInputStream or other Object.

setInput(Object, boolean) - Method in class javax.imageio.ImageReader

Sets the input source to use to the given ImageInputStream or other Object.

setInput(Object) - Method in class javax.imageio.ImageReader

Sets the input source to use to the given ImageInputStream or other Object.

setInputMap(int, InputMap) - Method in class javax.swing.JComponent

Sets the InputMap to use under the condition condition to map.

setInputMethodContext(InputMethodContext) - Method in interface java.awt.im.spi.InputMethod

Sets the input method context, which is used to dispatch input method events to the client component and to request information from the client component.

setInputSource(InputSource) - Method in class javax.xml.transform.sax.SAXSource

Set the SAX InputSource to be used for the Source.

setInputStream(InputStream) - Method in class javax.xml.transform.stream.StreamSource

Set the byte stream to be used as input.

setInputValue(Object) - Method in class javax.swing.JOptionPane

Sets the input value that was selected or input by the user.

setInputVerifier(InputVerifier) - Method in class javax.swing.JComponent

Sets the input verifier for this component.

setInsets(short, short, short, short) - Method in class javax.swing.text.CompositeView

Sets the insets for the view.

setInstalledLookAndFeels(UIManager.LookAndFeelInfo[]) - Static method in class javax.swing.UIManager

Sets the set of available look and feels.

setInstance(LayoutStyle) - Static method in class javax.swing.LayoutStyle

Sets the shared instance of LayoutStyle.

setInstanceFollowRedirects(boolean) - Method in class java.net.HttpURLConnection

Sets whether HTTP redirects (requests with response code 3xx) should be automatically followed by this HttpURLConnection instance.

setInstant(long) - Method in class java.util.Calendar.Builder

Sets the instant parameter to the given instant value that is a millisecond offset from the Epoch.

setInstant(Date) - Method in class java.util.Calendar.Builder

Sets the instant parameter to the instant value given by a Date.

setInt(Object, int, int) - Static method in class java.lang.reflect.Array

Sets the value of the indexed component of the specified array object to the specified int value.

setInt(Object, int) - Method in class java.lang.reflect.Field

Sets the value of a field as an int on the specified object.

setInt(String, int) - Method in interface java.sql.CallableStatement

Sets the designated parameter to the given Java int value.

setInt(int, int) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to the given Java int value.

setInt(int, int) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to an int in the Java programming language.

setInt(String, int) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given Java int value.

setInt(int, int) - Method in interface javax.sql.RowSet

Sets the designated parameter in this RowSet object's command to the given Java int value.

setInt(String, int) - Method in interface javax.sql.RowSet

Sets the designated parameter to the given Java int value.

setIntercellSpacing(Dimension) - Method in class javax.swing.JTable

Sets the rowMargin and the columnMargin -- the height and width of the space between cells -- to intercellSpacing.

setInterface(InetAddress) - Method in class java.net.MulticastSocket

Set the multicast network interface used by methods whose behavior would be affected by the value of the network interface.

setInternalFrame(JInternalFrame) - Method in class javax.swing.JInternalFrame.JDesktopIcon

Sets the JInternalFrame with which this DesktopIcon is associated.

setInternationalCurrencySymbol(String) - Method in class java.text.DecimalFormatSymbols

Sets the ISO 4217 currency code of the currency of these DecimalFormatSymbols.

setInvalidCharacters(String) - Method in class javax.swing.text.MaskFormatter

Allows for further restricting of the characters that can be input.

setInverted(boolean) - Method in class javax.swing.JSlider

Specify true to reverse the value-range shown for the slider and false to put the value range in the normal order.

setInvoker(Component) - Method in class javax.swing.JPopupMenu

Sets the invoker of this popup menu -- the component in which the popup menu menu is to be displayed.

setInvokesStopCellEditing(boolean) - Method in class javax.swing.JTree

Determines what happens when editing is interrupted by selecting another node in the tree, a change in the tree's data, or by some other means.

setIssuer(X500Principal) - Method in class java.security.cert.X509CertSelector

Sets the issuer criterion.

setIssuer(String) - Method in class java.security.cert.X509CertSelector

Denigrated, use X509CertSelector.setIssuer(X500Principal) or X509CertSelector.setIssuer(byte[]) instead.

setIssuer(byte[]) - Method in class java.security.cert.X509CertSelector

Sets the issuer criterion.

setIssuerNames(Collection<?>) - Method in class java.security.cert.X509CRLSelector

Note: use X509CRLSelector.setIssuers(Collection) instead or only specify the byte array form of distinguished names when using this method.

setIssuers(Collection<X500Principal>) - Method in class java.security.cert.X509CRLSelector

Sets the issuerNames criterion.

setItalic(MutableAttributeSet, boolean) - Static method in class javax.swing.text.StyleConstants

Sets the italic attribute.

setItem(Object) - Method in interface javax.swing.ComboBoxEditor

Set the item that should be edited.

setItem(Object) - Method in class javax.swing.plaf.basic.BasicComboBoxEditor

Sets the item that should be edited.

setJMenuBar(JMenuBar) - Method in class javax.swing.JApplet

Sets the menubar for this applet.

setJMenuBar(JMenuBar) - Method in class javax.swing.JDialog

Sets the menubar for this dialog.

setJMenuBar(JMenuBar) - Method in class javax.swing.JFrame

Sets the menubar for this frame.

setJMenuBar(JMenuBar) - Method in class javax.swing.JInternalFrame

Sets the menuBar property for this JInternalFrame.

setJMenuBar(JMenuBar) - Method in class javax.swing.JRootPane

Adds or changes the menu bar used in the layered pane.

setJNDIContext(Context) - Static method in class javax.sql.rowset.spi.SyncFactory

Sets the initial JNDI context from which SyncProvider implementations can be retrieved from a JNDI namespace

setJobName(String) - Method in class java.awt.print.PrinterJob

Sets the name of the document to be printed.

setJoinType(int) - Method in interface javax.sql.rowset.JoinRowSet

Allow the application to adjust the type of JOIN imposed on tables contained within the JoinRowSet object instance.

setJustification(int) - Method in class javax.swing.text.ParagraphView

Sets the type of justification.

setKeepAlive(boolean) - Method in class java.net.Socket

Enable/disable SO_KEEPALIVE.

setKeepAliveTime(long, TimeUnit) - Method in class java.util.concurrent.ThreadPoolExecutor

Sets the time limit for which threads may remain idle before being terminated.

setKeyBindingActive(boolean) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI

setKeyBindingRegistered(boolean) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI

setKeyChar(char) - Method in class java.awt.event.KeyEvent

Set the keyChar value to indicate a logical character.

setKeyCode(int) - Method in class java.awt.event.KeyEvent

Set the keyCode value to indicate a physical key.

setKeyColumns(int[]) - Method in interface javax.sql.rowset.CachedRowSet

Sets this CachedRowSet object's keyCols field with the given array of column numbers, which forms a key for uniquely identifying a row in this CachedRowSet object.

setKeyEntry(String, Key, char[], Certificate[]) - Method in class java.security.KeyStore

Assigns the given key to the given alias, protecting it with the given password.

setKeyEntry(String, byte[], Certificate[]) - Method in class java.security.KeyStore

Assigns the given key (that has already been protected) to the given alias.

setKeymap(Keymap) - Method in class javax.swing.text.JTextComponent

Sets the keymap to use for binding events to actions.

setKeyPair(KeyPair) - Method in class java.security.Signer

Deprecated.

Sets the key pair (public key and private key) for this signer.

setKeySelectionManager(JComboBox.KeySelectionManager) - Method in class javax.swing.JComboBox

Sets the object that translates a keyboard character into a list selection.

setKeySelector(KeySelector) - Method in class javax.xml.crypto.dom.DOMCryptoContext

setKeySelector(KeySelector) - Method in interface javax.xml.crypto.XMLCryptoContext

Sets the key selector for finding a key.

setKeyUsage(boolean[]) - Method in class java.security.cert.X509CertSelector

Sets the keyUsage criterion.

setLabel(String) - Method in class java.awt.Button

Sets the button's label to be the specified string.

setLabel(String) - Method in class java.awt.Checkbox

Sets this check box's label to be the string argument.

setLabel(String) - Method in class java.awt.MenuItem

Sets the label for this menu item to the specified label.

setLabel(String) - Method in class javax.swing.AbstractButton

Deprecated.
- Replaced by setText(text)

setLabel(String) - Method in class javax.swing.JPopupMenu

Sets the popup menu's label.

setLabel(String) - Method in class javax.swing.text.html.Option

Sets the label to be used for the option.

setLabelFor(Component) - Method in class javax.swing.JLabel

Set the component this is labelling.

setLabelTable(Dictionary) - Method in class javax.swing.JSlider

Used to specify what label will be drawn at any given value.

setLanguage(String) - Method in class java.util.Locale.Builder

Sets the language.

setLanguageTag(String) - Method in class java.util.Locale.Builder

Resets the Builder to match the provided IETF BCP 47 language tag.

setLargeMaxRows(long) - Method in interface java.sql.Statement

Sets the limit for the maximum number of rows that any ResultSet object generated by this Statement object can contain to the given number.

setLargeModel(boolean) - Method in class javax.swing.JTree

Specifies whether the UI should use a large model.

setLargeModel(boolean) - Method in class javax.swing.plaf.basic.BasicTreeUI

Updates the componentListener, if necessary.

setLastAccessTime(FileTime) - Method in class java.util.zip.ZipEntry

Sets the last access time of the entry.

setLastDividerLocation(int) - Method in class javax.swing.JSplitPane

Sets the last location the divider was at to newLastLocation.

setLastDragLocation(int) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI

Set the last drag location of the JSplitPane.

setLastModified(long) - Method in class java.io.File

Sets the last-modified time of the file or directory named by this abstract pathname.

setLastModifiedTime(Path, FileTime) - Static method in class java.nio.file.Files

Updates a file's last modified time attribute.

setLastModifiedTime(FileTime) - Method in class java.util.zip.ZipEntry

Sets the last modification time of the entry.

setLayer(Integer) - Method in class javax.swing.JInternalFrame

Convenience method for setting the layer attribute of this component.

setLayer(int) - Method in class javax.swing.JInternalFrame

Convenience method for setting the layer attribute of this component.

setLayer(Component, int) - Method in class javax.swing.JLayeredPane

Sets the layer attribute on the specified component, making it the bottommost component in that layer.

setLayer(Component, int, int) - Method in class javax.swing.JLayeredPane

Sets the layer attribute for the specified component and also sets its position within that layer.

setLayeredPane(JLayeredPane) - Method in class javax.swing.JApplet

Sets the layeredPane property.

setLayeredPane(JLayeredPane) - Method in class javax.swing.JDialog

Sets the layeredPane property.

setLayeredPane(JLayeredPane) - Method in class javax.swing.JFrame

Sets the layeredPane property.

setLayeredPane(JLayeredPane) - Method in class javax.swing.JInternalFrame

Sets this JInternalFrame's layeredPane property.

setLayeredPane(JLayeredPane) - Method in class javax.swing.JRootPane

Sets the layered pane for the root pane.

setLayeredPane(JLayeredPane) - Method in class javax.swing.JWindow

Sets the layeredPane property.

setLayeredPane(JLayeredPane) - Method in interface javax.swing.RootPaneContainer

A Container that manages the contentPane and in some cases a menu bar.

setLayerEventMask(long) - Method in class javax.swing.JLayer

Enables the events from JLayer and all its descendants defined by the specified event mask parameter to be delivered to the LayerUI.eventDispatched(AWTEvent, JLayer) method.

setLayout(LayoutManager) - Method in class java.awt.Container

Sets the layout manager for this container.

setLayout(LayoutManager) - Method in class java.awt.ScrollPane

Sets the layout manager for this container.

setLayout(LayoutManager) - Method in class javax.swing.AbstractButton

Sets the layout manager for this container, refer to Container.setLayout(LayoutManager) for a complete description of this method.

setLayout(LayoutManager) - Method in class javax.swing.Box

Throws an AWTError, since a Box can use only a BoxLayout.

setLayout(LayoutManager) - Method in class javax.swing.JApplet

Sets the LayoutManager.

setLayout(LayoutManager) - Method in class javax.swing.JDialog

Sets the LayoutManager.

setLayout(LayoutManager) - Method in class javax.swing.JFrame

Sets the LayoutManager.

setLayout(LayoutManager) - Method in class javax.swing.JInternalFrame

Ensures that, by default, the layout of this component cannot be set.

setLayout(LayoutManager) - Method in class javax.swing.JLayer

Sets the layout manager for this container.

setLayout(LayoutManager) - Method in class javax.swing.JScrollPane

Sets the layout manager for this JScrollPane.

setLayout(LayoutManager) - Method in class javax.swing.JToolBar

setLayout(LayoutManager) - Method in class javax.swing.JWindow

Sets the LayoutManager.

setLayoutOrientation(int) - Method in class javax.swing.JList

Defines the way list cells are layed out.

setLayoutStyle(LayoutStyle) - Method in class javax.swing.GroupLayout

Sets the LayoutStyle used to calculate the preferred gaps between components.

setLeadAnchorNotificationEnabled(boolean) - Method in class javax.swing.DefaultListSelectionModel

Sets the value of the leadAnchorNotificationEnabled flag.

setLeadSelectionIndex(int) - Method in class javax.swing.DefaultListSelectionModel

Sets the lead selection index, ensuring that values between the anchor and the new lead are either all selected or all deselected.

setLeadSelectionIndex(int) - Method in interface javax.swing.ListSelectionModel

Set the lead selection index.

setLeadSelectionPath(TreePath) - Method in class javax.swing.JTree

Sets the path identifies as the lead.

setLeafIcon(Icon) - Method in class javax.swing.tree.DefaultTreeCellRenderer

Sets the icon used to represent leaf nodes.

setLeftChildIndent(int) - Method in class javax.swing.plaf.basic.BasicTreeUI

setLeftComponent(Component) - Method in class javax.swing.JSplitPane

Sets the component to the left (or above) the divider.

setLeftIndent(MutableAttributeSet, float) - Static method in class javax.swing.text.StyleConstants

Sets left indent.

setLeftInset(float) - Method in class javax.swing.text.AsyncBoxView

Set the left part of the margin around the view.

setLength(long) - Method in class java.io.RandomAccessFile

Sets the length of this file.

setLength(int) - Method in class java.lang.StringBuffer

setLength(int) - Method in class java.net.DatagramPacket

Set the length for this packet.

setLength(int) - Method in class javax.imageio.stream.IIOByteBuffer

Updates the value that will be returned by subsequent calls to the getLength method.

setLenient(boolean) - Method in class java.text.DateFormat

Specify whether or not date/time parsing is to be lenient.

setLenient(boolean) - Method in class java.util.Calendar.Builder

Sets the lenient mode parameter to the value given by lenient.

setLenient(boolean) - Method in class java.util.Calendar

Specifies whether or not date/time interpretation is to be lenient.

setLevel(Level) - Method in class java.util.logging.Handler

Set the log level specifying which message levels will be logged by this Handler.

setLevel(Level) - Method in class java.util.logging.Logger

Set the log level specifying which message levels will be logged by this logger.

setLevel(Level) - Method in class java.util.logging.LogRecord

Set the logging message level, for example Level.SEVERE.

setLevel(int) - Method in class java.util.zip.Deflater

Sets the compression level to the specified value.

setLevel(int) - Method in class java.util.zip.ZipOutputStream

Sets the compression level for subsequent entries which are DEFLATED.

setLexicalHandler(LexicalHandler) - Method in class javax.xml.transform.sax.SAXResult

Set the SAX2 LexicalHandler for the output.

setLibraryDirectory(String) - Method in class javax.management.loading.MLet

Sets the directory used by the library loader for storing native libraries before they are loaded into memory.

setLibraryDirectory(String) - Method in interface javax.management.loading.MLetMBean

Sets the directory used by the library loader for storing native libraries before they are loaded into memory.

setLightWeightPopupEnabled(boolean) - Method in class javax.swing.JComboBox

Sets the lightWeightPopupEnabled property, which provides a hint as to whether or not a lightweight Component should be used to contain the JComboBox, versus a heavyweight Component such as a Panel or a Window.

setLightWeightPopupEnabled(boolean) - Method in class javax.swing.JPopupMenu

Sets the value of the lightWeightPopupEnabled property, which by default is true.

setLightWeightPopupEnabled(boolean) - Method in class javax.swing.ToolTipManager

When displaying the JToolTip, the ToolTipManager chooses to use a lightweight JPanel if it fits.

setLimit(int) - Method in class javax.swing.undo.UndoManager

Sets the maximum number of edits this UndoManager holds.

setLine(double, double, double, double) - Method in class java.awt.geom.Line2D.Double

Sets the location of the end points of this Line2D to the specified double coordinates.

setLine(double, double, double, double) - Method in class java.awt.geom.Line2D.Float

Sets the location of the end points of this Line2D to the specified double coordinates.

setLine(float, float, float, float) - Method in class java.awt.geom.Line2D.Float

Sets the location of the end points of this Line2D to the specified float coordinates.

setLine(double, double, double, double) - Method in class java.awt.geom.Line2D

Sets the location of the end points of this Line2D to the specified double coordinates.

setLine(Point2D, Point2D) - Method in class java.awt.geom.Line2D

Sets the location of the end points of this Line2D to the specified Point2D coordinates.

setLine(Line2D) - Method in class java.awt.geom.Line2D

Sets the location of the end points of this Line2D to the same as those end points of the specified Line2D.

setLineIncrement(int) - Method in class java.awt.Scrollbar

Deprecated.
As of JDK version 1.1, replaced by setUnitIncrement(int).

setLineLength(int) - Method in class javax.swing.text.AbstractWriter

Enables subclasses to set the number of characters they want written per line.

setLineNumber(int) - Method in class java.io.LineNumberInputStream

Deprecated.

Sets the line number to the specified argument.

setLineNumber(int) - Method in class java.io.LineNumberReader

Set the current line number.

setLineNumber(int) - Method in class javax.xml.bind.helpers.ValidationEventLocatorImpl

Set the lineNumber field on this event locator.

setLineNumber(int) - Method in class org.xml.sax.helpers.LocatorImpl

Set the line number for this locator (1-based).

setLineSeparator(String) - Method in class javax.swing.text.AbstractWriter

Sets the String used to represent newlines.

setLineSpacing(float) - Method in class javax.swing.text.ParagraphView

Sets the line spacing.

setLineSpacing(MutableAttributeSet, float) - Static method in class javax.swing.text.StyleConstants

Sets line spacing.

setLineWrap(boolean) - Method in class javax.swing.JTextArea

Sets the line-wrapping policy of the text area.

setLinkCursor(Cursor) - Method in class javax.swing.text.html.HTMLEditorKit

Sets the cursor to use over links.

setLinkedException(Throwable) - Method in class javax.xml.bind.helpers.ValidationEventImpl

Set the linked exception field of this event.

setLinkedException(Throwable) - Method in exception javax.xml.bind.JAXBException

Add a linked Exception.

setLinkedException(Throwable) - Method in exception javax.xml.bind.TypeConstraintException

Add a linked Exception.

setLinkExplanation(String) - Method in exception javax.naming.LinkException

Sets the explanation associated with the problem encounter when resolving a link.

setLinkRemainingName(Name) - Method in exception javax.naming.LinkException

Sets the remaining link name field of this exception.

setLinkResolvedName(Name) - Method in exception javax.naming.LinkException

Sets the resolved link name field of this exception.

setLinkResolvedObj(Object) - Method in exception javax.naming.LinkException

Sets the link resolved object field of this exception.

setList(List<?>) - Method in class javax.swing.SpinnerListModel

Changes the list that defines this sequence and resets the index of the models value to zero.

setListData(E[]) - Method in class javax.swing.JList

Constructs a read-only ListModel from an array of items, and calls setModel with this model.

setListData(Vector<? extends E>) - Method in class javax.swing.JList

Constructs a read-only ListModel from a Vector and calls setModel with this model.

setListener(Marshaller.Listener) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

setListener(Unmarshaller.Listener) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

setListener(Marshaller.Listener) - Method in interface javax.xml.bind.Marshaller

Register marshal event callback Marshaller.Listener with this Marshaller.

setListener(Unmarshaller.Listener) - Method in interface javax.xml.bind.Unmarshaller

Register unmarshal event callback Unmarshaller.Listener with this Unmarshaller.

setLoadsSynchronously(boolean) - Method in class javax.swing.text.html.ImageView

Sets how the image is loaded.

setLocale(Locale) - Method in class java.awt.Component

Sets the locale of this component.

setLocale(Locale) - Method in interface java.awt.im.spi.InputMethod

Attempts to set the input locale.

setLocale(Locale) - Method in class java.beans.beancontext.BeanContextSupport

Sets the locale of this BeanContext.

setLocale(Locale) - Method in class java.text.MessageFormat

Sets the locale to be used when creating or comparing subformats.

setLocale(Locale) - Method in class java.util.Calendar.Builder

Sets the locale parameter to the given locale.

setLocale(Locale) - Method in class java.util.Locale.Builder

Resets the Builder to match the provided locale.

setLocale(Locale) - Method in class javax.imageio.ImageReader

Sets the current Locale of this ImageReader to the given value.

setLocale(Locale) - Method in class javax.imageio.ImageWriter

Sets the current Locale of this ImageWriter to the given value.

setLocale(Locale) - Method in class javax.security.auth.callback.LanguageCallback

Set the retrieved Locale.

setLocale(Locale) - Method in interface javax.tools.DocumentationTool.DocumentationTask

Set the locale to be applied when formatting diagnostics and other localized data.

setLocale(Locale) - Method in interface javax.tools.JavaCompiler.CompilationTask

Set the locale to be applied when formatting diagnostics and other localized data.

setLocale(Locale) - Method in class org.xml.sax.helpers.XMLReaderAdapter

Set the locale for error reporting.

setLocale(Locale) - Method in interface org.xml.sax.Parser

Deprecated.

Allow an application to request a locale for errors and warnings.

setLocalName(int, String) - Method in class org.xml.sax.helpers.AttributesImpl

Set the local name of a specific attribute.

setLocalPatternChars(String) - Method in class java.text.DateFormatSymbols

Sets localized date-time pattern characters.

setLocation(Point) - Method in class java.awt.Component.AccessibleAWTComponent

Sets the location of the object relative to the parent.

setLocation(int, int) - Method in class java.awt.Component

Moves this component to a new location.

setLocation(Point) - Method in class java.awt.Component

Moves this component to a new location.

setLocation(double, double) - Method in class java.awt.geom.Point2D.Double

Sets the location of this Point2D to the specified double coordinates.

setLocation(double, double) - Method in class java.awt.geom.Point2D.Float

Sets the location of this Point2D to the specified double coordinates.

setLocation(float, float) - Method in class java.awt.geom.Point2D.Float

Sets the location of this Point2D to the specified float coordinates.

setLocation(double, double) - Method in class java.awt.geom.Point2D

Sets the location of this Point2D to the specified double coordinates.

setLocation(Point2D) - Method in class java.awt.geom.Point2D

Sets the location of this Point2D to the same coordinates as the specified Point2D object.

setLocation(Point) - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Sets the location of the object relative to the parent.

setLocation(Point) - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Sets the location of the object relative to the parent.

setLocation(Point) - Method in class java.awt.Point

Sets the location of the point to the specified location.

setLocation(int, int) - Method in class java.awt.Point

Changes the point to have the specified location.

setLocation(double, double) - Method in class java.awt.Point

Sets the location of this point to the specified double coordinates.

setLocation(Point) - Method in class java.awt.Rectangle

Moves this Rectangle to the specified location.

setLocation(int, int) - Method in class java.awt.Rectangle

Moves this Rectangle to the specified location.

setLocation(int, int) - Method in class java.awt.Window

Moves this component to a new location.

setLocation(Point) - Method in class java.awt.Window

Moves this component to a new location.

setLocation(Point) - Method in interface javax.accessibility.AccessibleComponent

Sets the location of the object relative to the parent.

setLocation(Point) - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

setLocation(int, int) - Method in class javax.swing.JPopupMenu

Sets the location of the upper left corner of the popup menu using x, y coordinates.

setLocation(Point) - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Sets the location of the object relative to the parent.

setLocation(Point) - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

setLocation(Point) - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

setLocation(JavaFileManager.Location, Iterable<? extends File>) - Method in interface javax.tools.StandardJavaFileManager

Associates the given path with the given location.

setLocation(Location) - Method in class javax.xml.stream.XMLEventFactory

This method allows setting of the Location on each event that is created by this factory.

setLocationByPlatform(boolean) - Method in class java.awt.Window

Sets whether this Window should appear at the default location for the native windowing system or at the current location (returned by getLocation) the next time the Window is made visible.

setLocationRelativeTo(Component) - Method in class java.awt.Window

Sets the location of the window relative to the specified component according to the following scenarios.

setLocator(ValidationEventLocator) - Method in class javax.xml.bind.helpers.ValidationEventImpl

Set the locator object for this event.

setLocator(SourceLocator) - Method in exception javax.xml.transform.TransformerException

Method setLocator sets an instance of a SourceLocator object that specifies where an error occured.

setLockingKeyState(int, boolean) - Method in class java.awt.Toolkit

Sets the state of the given locking key on the keyboard.

setLog(OutputStream) - Static method in class java.rmi.server.RemoteServer

Log RMI calls to the output stream out.

setLogger(Logger) - Static method in class javax.sql.rowset.spi.SyncFactory

Sets the logging object to be used by the SyncProvider implementation provided by the SyncFactory.

setLogger(Logger, Level) - Static method in class javax.sql.rowset.spi.SyncFactory

Sets the logging object that is used by SyncProvider implementations provided by the SyncFactory SPI.

setLoggerLevel(String, String) - Method in interface java.lang.management.PlatformLoggingMXBean

Sets the specified logger to the specified new level.

setLoggerLevel(String, String) - Method in interface java.util.logging.LoggingMXBean

Sets the specified logger to the specified new level.

setLoggerName(String) - Method in class java.util.logging.LogRecord

Set the source Logger's name.

setLogicalStyle(Style) - Method in class javax.swing.JTextPane

Sets the logical style to use for the paragraph at the current caret position.

setLogicalStyle(int, Style) - Method in class javax.swing.text.DefaultStyledDocument

Sets the logical style to use for the paragraph at the given position.

setLogicalStyle(int, Style) - Method in interface javax.swing.text.StyledDocument

Sets the logical style to use for the paragraph at the given position.

setLoginTimeout(int) - Static method in class java.sql.DriverManager

Sets the maximum time in seconds that a driver will wait while attempting to connect to a database once the driver has been identified.

setLoginTimeout(int) - Method in interface javax.sql.CommonDataSource

Sets the maximum time in seconds that this data source will wait while attempting to connect to a database.

setLogStream(PrintStream) - Static method in class java.sql.DriverManager

Deprecated.
Use setLogWriter

setLogStream(PrintStream) - Static method in class javax.swing.DebugGraphics

Sets the stream to which the DebugGraphics logs drawing operations.

setLogTimers(boolean) - Static method in class javax.swing.Timer

Enables or disables the timer log.

setLogWriter(PrintWriter) - Static method in class java.sql.DriverManager

Sets the logging/tracing PrintWriter object that is used by the DriverManager and all drivers.

setLogWriter(PrintWriter) - Method in interface javax.sql.CommonDataSource

Sets the log writer for this DataSource object to the given java.io.PrintWriter object.

setLong(Object, int, long) - Static method in class java.lang.reflect.Array

Sets the value of the indexed component of the specified array object to the specified long value.

setLong(Object, long) - Method in class java.lang.reflect.Field

Sets the value of a field as a long on the specified object.

setLong(String, long) - Method in interface java.sql.CallableStatement

Sets the designated parameter to the given Java long value.

setLong(int, long) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to the given Java long value.

setLong(int, long) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given long in the Java programming language.

setLong(String, long) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given Java long value.

setLong(int, long) - Method in interface javax.sql.RowSet

Sets the designated parameter in this RowSet object's command to the given Java long value.

setLong(String, long) - Method in interface javax.sql.RowSet

Sets the designated parameter to the given Java long value.

setLookAndFeel(LookAndFeel) - Static method in class javax.swing.UIManager

Sets the current look and feel to newLookAndFeel.

setLookAndFeel(String) - Static method in class javax.swing.UIManager

Loads the LookAndFeel specified by the given class name, using the current thread's context class loader, and passes it to setLookAndFeel(LookAndFeel).

setLoopbackMode(boolean) - Method in class java.net.MulticastSocket

Disable/Enable local loopback of multicast datagrams The option is used by the platform's networking code as a hint for setting whether multicast data will be looped back to the local socket.

setLoopCount(int) - Method in interface javax.sound.midi.Sequencer

Sets the number of repetitions of the loop for playback.

setLoopEndPoint(long) - Method in interface javax.sound.midi.Sequencer

Sets the last MIDI tick that will be played in the loop.

setLoopPoints(int, int) - Method in interface javax.sound.sampled.Clip

Sets the first and last sample frames that will be played in the loop.

setLoopStartPoint(long) - Method in interface javax.sound.midi.Sequencer

Sets the first MIDI tick that will be played in the loop.

setMagicCaretPosition(Point) - Method in interface javax.swing.text.Caret

Set the current caret visual location.

setMagicCaretPosition(Point) - Method in class javax.swing.text.DefaultCaret

Saves the current caret position.

setMajorOffset(float) - Method in class javax.swing.text.AsyncBoxView.ChildState

This method should only be called by the ChildLocator, it is simply a convenient place to hold the cached location.

setMajorTickSpacing(int) - Method in class javax.swing.JSlider

This method sets the major tick spacing.

setManagedResource(Object, String) - Method in interface javax.management.modelmbean.ModelMBean

Sets the instance handle of the object against which to execute all methods in this ModelMBean management interface (MBeanInfo and Descriptors).

setManagedResource(Object, String) - Method in class javax.management.modelmbean.RequiredModelMBean

Sets the instance handle of the object against which to execute all methods in this ModelMBean management interface (MBeanInfo and Descriptors).

setMargin(Insets) - Method in class javax.swing.AbstractButton

Sets space for margin between the button's border and the label.

setMargin(Insets) - Method in class javax.swing.JMenuBar

Sets the margin between the menubar's border and its menus.

setMargin(Insets) - Method in class javax.swing.JToolBar

Sets the margin between the tool bar's border and its buttons.

setMargin(Insets) - Method in class javax.swing.text.JTextComponent

Sets margin space between the text component's border and its text.

setMask(String) - Method in class javax.swing.text.MaskFormatter

Sets the mask dictating the legal characters.

setMasterSyncMode(Sequencer.SyncMode) - Method in interface javax.sound.midi.Sequencer

Sets the source of timing information used by this sequencer.

setMatchAllSubjectAltNames(boolean) - Method in class java.security.cert.X509CertSelector

Enables/disables matching all of the subjectAlternativeNames specified in the setSubjectAlternativeNames or addSubjectAlternativeName methods.

setMatchColumn(int) - Method in interface javax.sql.rowset.Joinable

Sets the designated column as the match column for this RowSet object.

setMatchColumn(int[]) - Method in interface javax.sql.rowset.Joinable

Sets the designated columns as the match column for this RowSet object.

setMatchColumn(String) - Method in interface javax.sql.rowset.Joinable

Sets the designated column as the match column for this RowSet object.

setMatchColumn(String[]) - Method in interface javax.sql.rowset.Joinable

Sets the designated columns as the match column for this RowSet object.

setMaxAge(long) - Method in class java.net.HttpCookie

Sets the maximum age of the cookie in seconds.

setMaxCRLNumber(BigInteger) - Method in class java.security.cert.X509CRLSelector

Sets the maxCRLNumber criterion.

setMaxFieldSize(int) - Method in interface java.sql.Statement

Sets the limit for the maximum number of bytes that can be returned for character and binary column values in a ResultSet object produced by this Statement object.

setMaxFieldSize(int) - Method in class javax.sql.rowset.BaseRowSet

Sets the maximum number of bytes that can be used for a column value in this RowSet object to the given number.

setMaxFieldSize(int) - Method in interface javax.sql.RowSet

Sets the maximum number of bytes that can be returned for a column value to the given number of bytes.

setMaximizable(boolean) - Method in class javax.swing.JInternalFrame

Sets the maximizable property, which determines whether the JInternalFrame can be maximized by some user action.

setMaximizedBounds(Rectangle) - Method in class java.awt.Frame

Sets the maximized bounds for this frame.

setMaximum(int) - Method in interface java.awt.Adjustable

Sets the maximum value of the adjustable object.

setMaximum(int) - Method in class java.awt.Scrollbar

Sets the maximum value of this scroll bar.

setMaximum(int) - Method in class java.awt.ScrollPaneAdjustable

This method should NOT be called by user code.

setMaximum(int) - Method in interface javax.swing.BoundedRangeModel

Sets the model's maximum to newMaximum.

setMaximum(int) - Method in class javax.swing.DefaultBoundedRangeModel

Sets the maximum to n after ensuring that n that the other three properties obey the model's constraints:

setMaximum(boolean) - Method in class javax.swing.JInternalFrame

Maximizes and restores this internal frame.

setMaximum(int) - Method in class javax.swing.JProgressBar

Sets the progress bar's maximum value (stored in the progress bar's data model) to n.

setMaximum(int) - Method in class javax.swing.JScrollBar

Sets the model's maximum property.

setMaximum(int) - Method in class javax.swing.JSlider

Sets the slider's maximum value to maximum.

setMaximum(int) - Method in class javax.swing.ProgressMonitor

Specifies the maximum value.

setMaximum(Comparable) - Method in class javax.swing.SpinnerNumberModel

Changes the upper bound for numbers in this sequence.

setMaximum(Comparable) - Method in class javax.swing.text.InternationalFormatter

Sets the maximum permissible value.

setMaximumFractionDigits(int) - Method in class java.text.DecimalFormat

Sets the maximum number of digits allowed in the fraction portion of a number.

setMaximumFractionDigits(int) - Method in class java.text.NumberFormat

Sets the maximum number of digits allowed in the fraction portion of a number.

setMaximumIntegerDigits(int) - Method in class java.text.DecimalFormat

Sets the maximum number of digits allowed in the integer portion of a number.

setMaximumIntegerDigits(int) - Method in class java.text.NumberFormat

Sets the maximum number of digits allowed in the integer portion of a number.

setMaximumPoolSize(int) - Method in class java.util.concurrent.ThreadPoolExecutor

Sets the maximum allowed number of threads.

setMaximumRowCount(int) - Method in class javax.swing.JComboBox

Sets the maximum number of rows the JComboBox displays.

setMaximumSize(Dimension) - Method in class java.awt.Component

Sets the maximum size of this component to a constant value.

setMaximumSize(Dimension) - Method in class javax.swing.JComponent

Sets the maximum size of this component to a constant value.

setMaximumZoneSize(int) - Method in class javax.swing.text.ZoneView

Set the desired maximum zone size.

setMaxPage(int) - Method in class java.awt.JobAttributes

Specifies the maximum value the user can specify as the last page to be printed for jobs using these attributes.

setMaxPathLength(int) - Method in class java.security.cert.PKIXBuilderParameters

Sets the value of the maximum number of non-self-issued intermediate certificates that may exist in a certification path.

setMaxPriority(int) - Method in class java.lang.ThreadGroup

Sets the maximum priority of the group.

setMaxRows(int) - Method in interface java.sql.Statement

Sets the limit for the maximum number of rows that any ResultSet object generated by this Statement object can contain to the given number.

setMaxRows(int) - Method in class javax.sql.rowset.BaseRowSet

Sets the maximum number of rows that this RowSet object may contain to the given number.

setMaxRows(int) - Method in interface javax.sql.RowSet

Sets the maximum number of rows that this RowSet object can contain to the specified number.

setMaxSortKeys(int) - Method in class javax.swing.DefaultRowSorter

Sets the maximum number of sort keys.

setMaxWidth(int) - Method in class javax.swing.table.TableColumn

Sets the TableColumn's maximum width to maxWidth or, if maxWidth is less than the minimum width, to the minimum width.

setMaxZonesLoaded(int) - Method in class javax.swing.text.ZoneView

Sets the current setting of the number of zones allowed to be loaded at the same time.

setMBeanDescriptor(Descriptor) - Method in interface javax.management.modelmbean.ModelMBeanInfo

Sets the ModelMBean's descriptor.

setMBeanDescriptor(Descriptor) - Method in class javax.management.modelmbean.ModelMBeanInfoSupport

setMBeanServer(MBeanServer) - Method in class javax.management.AttributeValueExp

Deprecated.
This method has no effect. The MBean Server used to obtain an attribute value is QueryEval.getMBeanServer().

setMBeanServer(MBeanServer) - Method in class javax.management.ObjectName

setMBeanServer(MBeanServer) - Method in class javax.management.QueryEval

Sets the MBean server on which the query is to be performed.

setMBeanServer(MBeanServer) - Method in interface javax.management.QueryExp

Sets the MBean server on which the query is to be performed.

setMBeanServer(MBeanServer) - Method in interface javax.management.remote.MBeanServerForwarder

Sets the MBeanServer object to which requests will be forwarded after treatment by this object.

setMBeanServer(MBeanServer) - Method in class javax.management.remote.rmi.RMIServerImpl

Sets the MBeanServer to which this connector server is attached.

setMBeanServer(MBeanServer) - Method in class javax.management.StringValueExp

Deprecated.

setMBeanServer(MBeanServer) - Method in interface javax.management.ValueExp

Deprecated.
This method is not needed because a ValueExp can access the MBean server in which it is being evaluated by using QueryEval.getMBeanServer().

setMBeanServerForwarder(MBeanServerForwarder) - Method in class javax.management.remote.JMXConnectorServer

setMBeanServerForwarder(MBeanServerForwarder) - Method in interface javax.management.remote.JMXConnectorServerMBean

Inserts an object that intercepts requests for the MBean server that arrive through this connector server.

setMBeanServerForwarder(MBeanServerForwarder) - Method in class javax.management.remote.rmi.RMIConnectorServer

setMedia(PageAttributes.MediaType) - Method in class java.awt.PageAttributes

Specifies the desired paper size for pages using these attributes.

setMediaToDefault() - Method in class java.awt.PageAttributes

Sets the paper size for pages using these attributes to the default size for the default locale.

setMenuBar(MenuBar) - Method in class java.awt.Frame

Sets the menu bar for this frame to the specified menu bar.

setMenuBar(JMenuBar) - Method in class javax.swing.JInternalFrame

Deprecated.
As of Swing version 1.0.3 replaced by setJMenuBar(JMenuBar m).

setMenuBar(JMenuBar) - Method in class javax.swing.JRootPane

Deprecated.
As of Swing version 1.0.3 replaced by setJMenuBar(JMenuBar menu).

setMenuLocation(int, int) - Method in class javax.swing.JMenu

Sets the location of the popup component.

setMessage(String) - Method in class java.util.logging.LogRecord

Set the "raw" log message, before localization or formatting.

setMessage(int, byte[], int) - Method in class javax.sound.midi.MetaMessage

Sets the message parameters for a MetaMessage.

setMessage(byte[], int) - Method in class javax.sound.midi.MidiMessage

Sets the data for the MIDI message.

setMessage(int) - Method in class javax.sound.midi.ShortMessage

Sets the parameters for a MIDI message that takes no data bytes.

setMessage(int, int, int) - Method in class javax.sound.midi.ShortMessage

Sets the parameters for a MIDI message that takes one or two data bytes.

setMessage(int, int, int, int) - Method in class javax.sound.midi.ShortMessage

Sets the short message parameters for a channel message which takes up to two data bytes.

setMessage(byte[], int) - Method in class javax.sound.midi.SysexMessage

Sets the data for the system exclusive message.

setMessage(int, byte[], int) - Method in class javax.sound.midi.SysexMessage

Sets the data for the system exclusive message.

setMessage(Object) - Method in class javax.swing.JOptionPane

Sets the option pane's message-object.

setMessage(String) - Method in class javax.xml.bind.helpers.ValidationEventImpl

Set the message field of this event.

setMessage(SOAPMessage) - Method in interface javax.xml.ws.handler.soap.SOAPMessageContext

Sets the SOAPMessage in this message context

setMessageDigest(MessageDigest) - Method in class java.security.DigestInputStream

Associates the specified message digest with this stream.

setMessageDigest(MessageDigest) - Method in class java.security.DigestOutputStream

Associates the specified message digest with this stream.

setMessageType(int) - Method in class javax.swing.JOptionPane

Sets the option pane's message type.

setMetadata(IIOMetadata) - Method in class javax.imageio.IIOImage

Sets the IIOMetadata to a new object, or null.

setMetaData(RowSetMetaData) - Method in interface javax.sql.rowset.CachedRowSet

Sets the metadata for this CachedRowSet object with the given RowSetMetaData object.

setMetaData(RowSetMetaData) - Method in interface javax.sql.RowSetInternal

Sets the given RowSetMetaData object as the RowSetMetaData object for this RowSet object.

setMetadata(List<Source>) - Method in class javax.xml.ws.Endpoint

Sets the metadata for this endpoint.

setMethod(int) - Method in class java.util.zip.ZipEntry

Sets the compression method for the entry.

setMethod(int) - Method in class java.util.zip.ZipOutputStream

Sets the default compression method for subsequent entries.

setMicrosecondPosition(long) - Method in interface javax.sound.midi.Sequencer

Sets the current position in the sequence, expressed in microseconds

setMicrosecondPosition(long) - Method in interface javax.sound.sampled.Clip

Sets the media position in microseconds.

setMillis(long) - Method in class java.util.logging.LogRecord

Set event time.

setMillisecond(int) - Method in class javax.xml.datatype.XMLGregorianCalendar

Set milliseconds.

setMillisToDecideToPopup(int) - Method in class javax.swing.ProgressMonitor

Specifies the amount of time to wait before deciding whether or not to popup a progress monitor.

setMillisToPopup(int) - Method in class javax.swing.ProgressMonitor

Specifies the amount of time it will take for the popup to appear.

setMimeHeader(String, String) - Method in class javax.xml.soap.AttachmentPart

Changes the first header entry that matches the given name to the given value, adding a new header if no existing header matches.

setMimeHeader(String, String) - Method in class javax.xml.soap.SOAPPart

Changes the first header entry that matches the given header name so that its value is the given value, adding a new header with the given name and value if no existing header is a match.

setMinCRLNumber(BigInteger) - Method in class java.security.cert.X509CRLSelector

Sets the minCRLNumber criterion.

setMinimalDaysInFirstWeek(int) - Method in class java.util.Calendar

Sets what the minimal days required in the first week of the year are; For example, if the first week is defined as one that contains the first day of the first month of a year, call this method with value 1.

setMinimum(int) - Method in interface java.awt.Adjustable

Sets the minimum value of the adjustable object.

setMinimum(int) - Method in class java.awt.Scrollbar

Sets the minimum value of this scroll bar.

setMinimum(int) - Method in class java.awt.ScrollPaneAdjustable

This method should NOT be called by user code.

setMinimum(int) - Method in interface javax.swing.BoundedRangeModel

Sets the model's minimum to newMinimum.

setMinimum(int) - Method in class javax.swing.DefaultBoundedRangeModel

Sets the minimum to n after ensuring that n that the other three properties obey the model's constraints:

setMinimum(int) - Method in class javax.swing.JProgressBar

Sets the progress bar's minimum value (stored in the progress bar's data model) to n.

setMinimum(int) - Method in class javax.swing.JScrollBar

Sets the model's minimum property.

setMinimum(int) - Method in class javax.swing.JSlider

Sets the slider's minimum value to minimum.

setMinimum(int) - Method in class javax.swing.ProgressMonitor

Specifies the minimum value.

setMinimum(Comparable) - Method in class javax.swing.SpinnerNumberModel

Changes the lower bound for numbers in this sequence.

setMinimum(Comparable) - Method in class javax.swing.text.InternationalFormatter

Sets the minimum permissible value.

setMinimumFractionDigits(int) - Method in class java.text.DecimalFormat

Sets the minimum number of digits allowed in the fraction portion of a number.

setMinimumFractionDigits(int) - Method in class java.text.NumberFormat

Sets the minimum number of digits allowed in the fraction portion of a number.

setMinimumIntegerDigits(int) - Method in class java.text.DecimalFormat

Sets the minimum number of digits allowed in the integer portion of a number.

setMinimumIntegerDigits(int) - Method in class java.text.NumberFormat

Sets the minimum number of digits allowed in the integer portion of a number.

setMinimumSize(Dimension) - Method in class java.awt.Component

Sets the minimum size of this component to a constant value.

setMinimumSize(Dimension) - Method in class java.awt.Window

Sets the minimum size of this window to a constant value.

setMinimumSize(Dimension) - Method in class javax.swing.JComponent

Sets the minimum size of this component to a constant value.

setMinor(int, String) - Method in exception org.ietf.jgss.GSSException

Used by the exception thrower to set the mechanism level minor error code and its string explanation.

setMinorTickSpacing(int) - Method in class javax.swing.JSlider

This method sets the minor tick spacing.

setMinPage(int) - Method in class java.awt.JobAttributes

Specifies the minimum value the user can specify as the first page to be printed for jobs using these attributes.

setMinusSign(char) - Method in class java.text.DecimalFormatSymbols

Sets the character used to represent minus sign.

setMinute(int) - Method in class javax.xml.datatype.XMLGregorianCalendar

Set minutes.

setMinutes(int) - Method in class java.sql.Date

Deprecated.

setMinutes(int) - Method in class java.util.Date

Deprecated.
As of JDK version 1.1, replaced by Calendar.set(Calendar.MINUTE, int minutes).

setMinWidth(int) - Method in class javax.swing.table.TableColumn

Sets the TableColumn's minimum width to minWidth, adjusting the new minimum width if necessary to ensure that 0 <= minWidth <= maxWidth.

setMnemonic(int) - Method in class javax.swing.AbstractButton

Sets the keyboard mnemonic on the current model.

setMnemonic(char) - Method in class javax.swing.AbstractButton

This method is now obsolete, please use setMnemonic(int) to set the mnemonic for a button.

setMnemonic(int) - Method in interface javax.swing.ButtonModel

Sets the keyboard mnemonic (shortcut key or accelerator key) for the button.

setMnemonic(int) - Method in class javax.swing.DefaultButtonModel

Sets the keyboard mnemonic (shortcut key or accelerator key) for the button.

setMnemonicAt(int, int) - Method in class javax.swing.JTabbedPane

Sets the keyboard mnemonic for accessing the specified tab.

setModal(boolean) - Method in class java.awt.Dialog

Specifies whether this dialog should be modal.

setModalExclusionType(Dialog.ModalExclusionType) - Method in class java.awt.Window

Specifies the modal exclusion type for this window.

setModalityType(Dialog.ModalityType) - Method in class java.awt.Dialog

Sets the modality type for this dialog.

setMode(int) - Method in class java.awt.FileDialog

Sets the mode of the file dialog.

setModel(ButtonModel) - Method in class javax.swing.AbstractButton

Sets the model that this button represents.

setModel(ComboBoxModel<E>) - Method in class javax.swing.JComboBox

Sets the data model that the JComboBox uses to obtain the list of items.

setModel(ListModel<E>) - Method in class javax.swing.JList

Sets the model that represents the contents or "value" of the list, notifies property change listeners, and then clears the list's selection.

setModel(ButtonModel) - Method in class javax.swing.JMenu

Sets the data model for the "menu button" -- the label that the user clicks to open or close the menu.

setModel(ButtonModel) - Method in class javax.swing.JMenuItem

Sets the model that this button represents.

setModel(BoundedRangeModel) - Method in class javax.swing.JProgressBar

Sets the data model used by the JProgressBar.

setModel(BoundedRangeModel) - Method in class javax.swing.JScrollBar

Sets the model that handles the scrollbar's four fundamental properties: minimum, maximum, value, extent.

setModel(BoundedRangeModel) - Method in class javax.swing.JSlider

Sets the BoundedRangeModel that handles the slider's three fundamental properties: minimum, maximum, value.

setModel(SpinnerModel) - Method in class javax.swing.JSpinner

Changes the model that represents the value of this spinner.

setModel(SingleSelectionModel) - Method in class javax.swing.JTabbedPane

Sets the model to be used with this tabbedpane.

setModel(TableModel) - Method in class javax.swing.JTable

Sets the data model for this table to newModel and registers with it for listener notifications from the new data model.

setModel(TreeModel) - Method in class javax.swing.JTree

Sets the TreeModel that will provide the data.

setModel(TreeModel) - Method in class javax.swing.plaf.basic.BasicTreeUI

Sets the TreeModel.

setModel(M) - Method in class javax.swing.table.TableRowSorter

Sets the TableModel to use as the underlying model for this TableRowSorter.

setModel(TreeModel) - Method in class javax.swing.tree.AbstractLayoutCache

Sets the TreeModel that will provide the data.

setModel(TreeModel) - Method in class javax.swing.tree.FixedHeightLayoutCache

Sets the TreeModel that will provide the data.

setModel(TreeModel) - Method in class javax.swing.tree.VariableHeightLayoutCache

Sets the TreeModel that will provide the data.

setModelIndex(int) - Method in class javax.swing.table.TableColumn

Sets the model index for this column.

setModelMBeanInfo(ModelMBeanInfo) - Method in interface javax.management.modelmbean.ModelMBean

Initializes a ModelMBean object using ModelMBeanInfo passed in.

setModelMBeanInfo(ModelMBeanInfo) - Method in class javax.management.modelmbean.RequiredModelMBean

Initializes a ModelMBean object using ModelMBeanInfo passed in.

setModelWrapper(DefaultRowSorter.ModelWrapper<M, I>) - Method in class javax.swing.DefaultRowSorter

Sets the model wrapper providing the data that is being sorted and filtered.

setModifiers(int) - Method in class java.awt.event.KeyEvent

Deprecated.
as of JDK1.1.4

setModulus(Number) - Method in class javax.management.monitor.CounterMonitor

Sets the modulus value common to all observed MBeans.

setModulus(Number) - Method in interface javax.management.monitor.CounterMonitorMBean

Sets the modulus value.

setMonetaryDecimalSeparator(char) - Method in class java.text.DecimalFormatSymbols

Sets the monetary decimal separator.

setMono(boolean) - Method in interface javax.sound.midi.MidiChannel

Turns mono mode on or off.

setMonth(int) - Method in class java.sql.Time

Deprecated.

setMonth(int) - Method in class java.util.Date

Deprecated.
As of JDK version 1.1, replaced by Calendar.set(Calendar.MONTH, int month).

setMonth(int) - Method in class javax.xml.datatype.XMLGregorianCalendar

Set month.

setMonths(String[]) - Method in class java.text.DateFormatSymbols

Sets month strings.

setMouseOver(boolean) - Method in class javax.swing.plaf.basic.BasicSplitPaneDivider

Sets whether or not the mouse is currently over the divider.

setMTOMEnabled(boolean) - Method in interface javax.xml.ws.soap.SOAPBinding

Enables or disables use of MTOM.

setMultiClickThreshhold(long) - Method in class javax.swing.AbstractButton

Sets the amount of time (in milliseconds) required between mouse press events for the button to generate the corresponding action events.

setMultipleDocumentHandling(JobAttributes.MultipleDocumentHandlingType) - Method in class java.awt.JobAttributes

Specifies the handling of multiple copies, including collation, for jobs using these attributes.

setMultipleDocumentHandlingToDefault() - Method in class java.awt.JobAttributes

Sets the handling of multiple copies, including collation, for jobs using these attributes to the default.

setMultipleMode(boolean) - Method in class java.awt.FileDialog

Enables or disables multiple file selection for the file dialog.

setMultipleMode(boolean) - Method in class java.awt.List

Sets the flag that determines whether this list allows multiple selections.

setMultipleSelections(boolean) - Method in class java.awt.List

Deprecated.
As of JDK version 1.1, replaced by setMultipleMode(boolean).

setMultiplier(int) - Method in class java.text.DecimalFormat

Sets the multiplier for use in percent, per mille, and similar formats.

setMultiSelectionEnabled(boolean) - Method in class javax.swing.JFileChooser

Sets the file chooser to allow multiple file selections.

setMustUnderstand(boolean) - Method in interface javax.xml.soap.SOAPHeaderElement

Sets the mustUnderstand attribute for this SOAPHeaderElement object to be either true or false.

setMute(boolean) - Method in interface javax.sound.midi.MidiChannel

Sets the mute state for this channel.

setName(String) - Method in class java.awt.Component

Sets the name of the component to the specified string.

setName(String) - Method in class java.awt.MenuComponent

Sets the name of the component to the specified string.

setName(String) - Method in class java.beans.FeatureDescriptor

Sets the programmatic name of this feature.

setName(String) - Method in class java.lang.Thread

Changes the name of this thread to be equal to the argument name.

setName(Principal, String) - Method in interface java.security.acl.Acl

Sets the name of this ACL.

setName(String) - Method in class javax.naming.NameClassPair

Sets the name of this binding.

setName(String) - Method in class javax.security.auth.callback.NameCallback

Set the retrieved name.

setName(String) - Method in class javax.swing.text.StyleContext.NamedStyle

Changes the name of the style.

setNameConstraints(byte[]) - Method in class java.security.cert.X509CertSelector

Sets the name constraints criterion.

setNamedItem(Node) - Method in interface org.w3c.dom.NamedNodeMap

Adds a node using its nodeName attribute.

setNamedItemNS(Node) - Method in interface org.w3c.dom.NamedNodeMap

Adds a node using its namespaceURI and localName.

setNameInNamespace(String) - Method in class javax.naming.NameClassPair

Sets the full name of this binding.

setNamespaceAware(boolean) - Method in class javax.xml.parsers.DocumentBuilderFactory

Specifies that the parser produced by this code will provide support for XML namespaces.

setNamespaceAware(boolean) - Method in class javax.xml.parsers.SAXParserFactory

Specifies that the parser produced by this code will provide support for XML namespaces.

setNamespaceContext(NamespaceContext) - Method in interface javax.xml.stream.XMLEventWriter

Sets the current namespace context for prefix and uri bindings.

setNamespaceContext(NamespaceContext) - Method in interface javax.xml.stream.XMLStreamWriter

Sets the current namespace context for prefix and uri bindings.

setNamespaceContext(NamespaceContext) - Method in interface javax.xml.xpath.XPath

Establish a namespace context.

setNamespaceDeclUris(boolean) - Method in class org.xml.sax.helpers.NamespaceSupport

Controls whether namespace declaration attributes are placed into the NSDECL namespace by processName().

setNaN(String) - Method in class java.text.DecimalFormatSymbols

Sets the string used to represent "not a number".

setNanos(int) - Method in class java.sql.Timestamp

Sets this Timestamp object's nanos field to the given value.

setNativeMethodPrefix(ClassFileTransformer, String) - Method in interface java.lang.instrument.Instrumentation

This method modifies the failure handling of native method resolution by allowing retry with a prefix applied to the name.

setNativesForFlavor(DataFlavor, String[]) - Method in class java.awt.datatransfer.SystemFlavorMap

Discards the current mappings for the specified DataFlavor and all DataFlavors equal to the specified DataFlavor, and creates new mappings to the specified String natives.

setNavigationFilter(NavigationFilter) - Method in class javax.swing.text.JTextComponent

Sets the NavigationFilter.

setNCharacterStream(String, Reader, long) - Method in interface java.sql.CallableStatement

Sets the designated parameter to a Reader object.

setNCharacterStream(String, Reader) - Method in interface java.sql.CallableStatement

Sets the designated parameter to a Reader object.

setNCharacterStream(int, Reader, long) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to a Reader object.

setNCharacterStream(int, Reader) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to a Reader object.

setNCharacterStream(int, Reader) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter in this RowSet object's command to a Reader object.

setNCharacterStream(int, Reader, long) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to a Reader object.

setNCharacterStream(String, Reader, long) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to a Reader object.

setNCharacterStream(String, Reader) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to a Reader object.

setNCharacterStream(int, Reader) - Method in interface javax.sql.RowSet

Sets the designated parameter in this RowSet object's command to a Reader object.

setNCharacterStream(int, Reader, long) - Method in interface javax.sql.RowSet

Sets the designated parameter to a Reader object.

setNCharacterStream(String, Reader, long) - Method in interface javax.sql.RowSet

Sets the designated parameter to a Reader object.

setNCharacterStream(String, Reader) - Method in interface javax.sql.RowSet

Sets the designated parameter to a Reader object.

setNClob(String, NClob) - Method in interface java.sql.CallableStatement

Sets the designated parameter to a java.sql.NClob object.

setNClob(String, Reader, long) - Method in interface java.sql.CallableStatement

Sets the designated parameter to a Reader object.

setNClob(String, Reader) - Method in interface java.sql.CallableStatement

Sets the designated parameter to a Reader object.

setNClob(int, NClob) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to a java.sql.NClob object.

setNClob(int, Reader, long) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to a Reader object.

setNClob(int, Reader) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to a Reader object.

setNClob(String, NClob) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to a java.sql.NClob object.

setNClob(String, Reader, long) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to a Reader object.

setNClob(String, Reader) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to a Reader object.

setNClob(int, Reader, long) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to a Reader object.

setNClob(int, NClob) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to a java.sql.NClob object.

setNClob(int, Reader) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to a Reader object.

setNClob(String, NClob) - Method in interface javax.sql.RowSet

Sets the designated parameter to a java.sql.NClob object.

setNClob(String, Reader, long) - Method in interface javax.sql.RowSet

Sets the designated parameter to a Reader object.

setNClob(String, Reader) - Method in interface javax.sql.RowSet

Sets the designated parameter to a Reader object.

setNClob(int, Reader, long) - Method in interface javax.sql.RowSet

Sets the designated parameter to a Reader object.

setNClob(int, NClob) - Method in interface javax.sql.RowSet

Sets the designated parameter to a java.sql.NClob object.

setNClob(int, Reader) - Method in interface javax.sql.RowSet

Sets the designated parameter to a Reader object.

setNeedClientAuth(boolean) - Method in class javax.net.ssl.SSLEngine

Configures the engine to require client authentication.

setNeedClientAuth(boolean) - Method in class javax.net.ssl.SSLParameters

Sets whether client authentication should be required.

setNeedClientAuth(boolean) - Method in class javax.net.ssl.SSLServerSocket

Controls whether accepted server-mode SSLSockets will be initially configured to require client authentication.

setNeedClientAuth(boolean) - Method in class javax.net.ssl.SSLSocket

Configures the socket to require client authentication.

setNegativePermissions() - Method in interface java.security.acl.AclEntry

Sets this ACL entry to be a negative one.

setNegativePrefix(String) - Method in class java.text.DecimalFormat

Set the negative prefix.

setNegativeSuffix(String) - Method in class java.text.DecimalFormat

Set the negative suffix.

setNetworkInterface(NetworkInterface) - Method in class java.net.MulticastSocket

Specify the network interface for outgoing multicast datagrams sent on this socket.

setNetworkTimeout(Executor, int) - Method in interface java.sql.Connection

Sets the maximum period a Connection or objects created from the Connection will wait for the database to reply to any one request.

setNewLine(String) - Method in interface org.w3c.dom.ls.LSSerializer

The end-of-line sequence of characters to be used in the XML being written out.

setNextException(SQLException) - Method in exception java.sql.SQLException

Adds an SQLException object to the end of the chain.

setNextFocusableComponent(Component) - Method in class javax.swing.JComponent

Deprecated.
As of 1.4, replaced by FocusTraversalPolicy

setNextSibling(Node) - Method in class javax.xml.crypto.dsig.dom.DOMSignContext

Sets the next sibling node.

setNextSibling(Node) - Method in class javax.xml.transform.dom.DOMResult

Set the child node before which the result nodes will be inserted.

setNextWarning(SQLWarning) - Method in exception java.sql.SQLWarning

Adds a SQLWarning object to the end of the chain.

setNextWarning(RowSetWarning) - Method in exception javax.sql.rowset.RowSetWarning

Sets warning as the next warning, that is, the warning chained to this RowSetWarning object.

setNil(boolean) - Method in class javax.xml.bind.JAXBElement

Set whether this element has nil content.

setNode(Node) - Method in class javax.xml.bind.helpers.ValidationEventLocatorImpl

Set the Node field on this event locator.

setNode(Node) - Method in class javax.xml.crypto.dsig.dom.DOMValidateContext

Sets the node.

setNode(Node) - Method in class javax.xml.transform.dom.DOMResult

Set the node that will contain the result DOM tree.

setNode(Node) - Method in class javax.xml.transform.dom.DOMSource

Set the node that will represents a Source DOM tree.

setNodeDimensions(AbstractLayoutCache.NodeDimensions) - Method in class javax.swing.tree.AbstractLayoutCache

Sets the renderer that is responsible for drawing nodes in the tree and which is therefore responsible for calculating the dimensions of individual nodes.

setNodeDimensions(AbstractLayoutCache.NodeDimensions) - Method in class javax.swing.tree.VariableHeightLayoutCache

Sets the renderer that is responsible for drawing nodes in the tree.

setNodeValue(String) - Method in class javax.imageio.metadata.IIOMetadataNode

Sets the String value associated with this node.

setNodeValue(String) - Method in interface org.w3c.dom.Node

The value of this node, depending on its type; see the table above.

setNonContinuousLayoutDivider(Component) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI

Sets the divider to use when the splitPane is configured to not continuously layout.

setNonContinuousLayoutDivider(Component, boolean) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI

Sets the divider to use.

setNoNSSchemaLocation(String) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

Convenience method for setting the noNamespaceSchemaLocation.

setNormalBounds(Rectangle) - Method in class javax.swing.JInternalFrame

Sets the normal bounds for this internal frame, the bounds that this internal frame would be restored to from its maximized state.

setNorthPane(JComponent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI

setNote(String) - Method in class javax.swing.ProgressMonitor

Specifies the additional note that is displayed along with the progress message.

setNotify(boolean) - Method in class javax.management.monitor.CounterMonitor

Sets the notification's on/off switch value common to all observed MBeans.

setNotify(boolean) - Method in interface javax.management.monitor.CounterMonitorMBean

Sets the notification's on/off switch value.

setNotifyDiffer(boolean) - Method in class javax.management.monitor.StringMonitor

Sets the differing notification's on/off switch value common to all observed MBeans.

setNotifyDiffer(boolean) - Method in interface javax.management.monitor.StringMonitorMBean

Sets the differing notification's on/off switch value.

setNotifyHigh(boolean) - Method in class javax.management.monitor.GaugeMonitor

Sets the high notification's on/off switch value common to all observed MBeans.

setNotifyHigh(boolean) - Method in interface javax.management.monitor.GaugeMonitorMBean

Sets the high notification's on/off switch value.

setNotifyLow(boolean) - Method in class javax.management.monitor.GaugeMonitor

Sets the low notification's on/off switch value common to all observed MBeans.

setNotifyLow(boolean) - Method in interface javax.management.monitor.GaugeMonitorMBean

Sets the low notification's on/off switch value.

setNotifyMatch(boolean) - Method in class javax.management.monitor.StringMonitor

Sets the matching notification's on/off switch value common to all observed MBeans.

setNotifyMatch(boolean) - Method in interface javax.management.monitor.StringMonitorMBean

Sets the matching notification's on/off switch value.

setNString(String, String) - Method in interface java.sql.CallableStatement

Sets the designated parameter to the given String object.

setNString(int, String) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to the given String object.

setNString(int, String) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given String object.

setNString(String, String) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given String object.

setNString(int, String) - Method in interface javax.sql.RowSet

Sets the designated parameter to the given String object.

setNString(String, String) - Method in interface javax.sql.RowSet

Sets the designated parameter to the given String object.

setNull(String, int) - Method in interface java.sql.CallableStatement

Sets the designated parameter to SQL NULL.

setNull(String, int, String) - Method in interface java.sql.CallableStatement

Sets the designated parameter to SQL NULL.

setNull(int, int) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to SQL NULL.

setNull(int, int, String) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to SQL NULL.

setNull(int, int) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to SQL NULL.

setNull(int, int, String) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to SQL NULL.

setNull(String, int) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to SQL NULL.

setNull(String, int, String) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to SQL NULL.

setNull(int, int) - Method in interface javax.sql.RowSet

Sets the designated parameter in this RowSet object's SQL command to SQL NULL.

setNull(String, int) - Method in interface javax.sql.RowSet

Sets the designated parameter to SQL NULL.

setNull(int, int, String) - Method in interface javax.sql.RowSet

Sets the designated parameter in this RowSet object's SQL command to SQL NULL.

setNull(String, int, String) - Method in interface javax.sql.RowSet

Sets the designated parameter to SQL NULL.

setNullable(int, int) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Sets whether a value stored in the designated column can be set to NULL to the given constant from the interface ResultSetMetaData.

setNullable(int, int) - Method in interface javax.sql.RowSetMetaData

Sets whether the designated column's value can be set to NULL.

setNullFormatter(JFormattedTextField.AbstractFormatter) - Method in class javax.swing.text.DefaultFormatterFactory

Sets the formatter to use if the value of the JFormattedTextField is null.

setNumberFormat(NumberFormat) - Method in class java.text.DateFormat

Allows you to set the number formatter.

setNumRows(int) - Method in class javax.swing.table.DefaultTableModel

Obsolete as of Java 2 platform v1.3.

setObject(Object) - Method in interface java.beans.Customizer

Set the object to be customized.

setObject(String, Object, int, int) - Method in interface java.sql.CallableStatement

Sets the value of the designated parameter with the given object.

setObject(String, Object, int) - Method in interface java.sql.CallableStatement

Sets the value of the designated parameter with the given object.

setObject(String, Object) - Method in interface java.sql.CallableStatement

Sets the value of the designated parameter with the given object.

setObject(String, Object, SQLType, int) - Method in interface java.sql.CallableStatement

Sets the value of the designated parameter with the given object.

setObject(String, Object, SQLType) - Method in interface java.sql.CallableStatement

Sets the value of the designated parameter with the given object.

setObject(int, Object, int) - Method in interface java.sql.PreparedStatement

Sets the value of the designated parameter with the given object.

setObject(int, Object) - Method in interface java.sql.PreparedStatement

Sets the value of the designated parameter using the given object.

setObject(int, Object, int, int) - Method in interface java.sql.PreparedStatement

Sets the value of the designated parameter with the given object.

setObject(int, Object, SQLType, int) - Method in interface java.sql.PreparedStatement

Sets the value of the designated parameter with the given object.

setObject(int, Object, SQLType) - Method in interface java.sql.PreparedStatement

Sets the value of the designated parameter with the given object.

setObject(Object) - Method in interface java.sql.Ref

Sets the structured type value that this Ref object references to the given instance of Object.

setObject(Object) - Method in class javax.naming.Binding

Sets the object associated with this binding.

setObject(int, Object, int, int) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to an Object in the Java programming language.

setObject(int, Object, int) - Method in class javax.sql.rowset.BaseRowSet

Sets the value of the designated parameter with the given Object value.

setObject(int, Object) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to an Object in the Java programming language.

setObject(String, Object, int, int) - Method in class javax.sql.rowset.BaseRowSet

Sets the value of the designated parameter with the given object.

setObject(String, Object, int) - Method in class javax.sql.rowset.BaseRowSet

Sets the value of the designated parameter with the given object.

setObject(String, Object) - Method in class javax.sql.rowset.BaseRowSet

Sets the value of the designated parameter with the given object.

setObject(Object) - Method in class javax.sql.rowset.serial.SerialRef

Sets the SQL structured type that this SerialRef object references to the given Object object.

setObject(int, Object, int, int) - Method in interface javax.sql.RowSet

Sets the designated parameter in this RowSet object's command with the given Java Object.

setObject(String, Object, int, int) - Method in interface javax.sql.RowSet

Sets the value of the designated parameter with the given object.

setObject(int, Object, int) - Method in interface javax.sql.RowSet

Sets the designated parameter in this RowSet object's command with a Java Object.

setObject(String, Object, int) - Method in interface javax.sql.RowSet

Sets the value of the designated parameter with the given object.

setObject(String, Object) - Method in interface javax.sql.RowSet

Sets the value of the designated parameter with the given object.

setObject(int, Object) - Method in interface javax.sql.RowSet

Sets the designated parameter in this RowSet object's command with a Java Object.

setObject(Object) - Method in class javax.xml.bind.helpers.ValidationEventLocatorImpl

Set the Object field on this event locator.

setObjectFactoryBuilder(ObjectFactoryBuilder) - Static method in class javax.naming.spi.NamingManager

The ObjectFactoryBuilder determines the policy used when trying to load object factories.

setObservedAttribute(String) - Method in class javax.management.monitor.Monitor

Sets the attribute to observe.

setObservedAttribute(String) - Method in interface javax.management.monitor.MonitorMBean

Sets the attribute to observe.

setObservedObject(ObjectName) - Method in class javax.management.monitor.Monitor

Deprecated.
As of JMX 1.2, replaced by Monitor.addObservedObject(javax.management.ObjectName)

setObservedObject(ObjectName) - Method in interface javax.management.monitor.MonitorMBean

Deprecated.
As of JMX 1.2, replaced by MonitorMBean.addObservedObject(javax.management.ObjectName)

setOcspExtensions(List<Extension>) - Method in class java.security.cert.PKIXRevocationChecker

Sets the optional OCSP request extensions.

setOcspResponder(URI) - Method in class java.security.cert.PKIXRevocationChecker

Sets the URI that identifies the location of the OCSP responder.

setOcspResponderCert(X509Certificate) - Method in class java.security.cert.PKIXRevocationChecker

Sets the OCSP responder's certificate.

setOcspResponses(Map<X509Certificate, byte[]>) - Method in class java.security.cert.PKIXRevocationChecker

Sets the OCSP responses.

setOffset(int) - Method in class java.io.ObjectStreamField

Offset within instance data.

setOffset(int) - Method in class java.text.CollationElementIterator

Sets the iterator to point to the collation element corresponding to the specified character (the parameter is a CHARACTER offset in the original string, not an offset into its corresponding sequence of collation elements).

setOffset(int) - Method in class javax.imageio.stream.IIOByteBuffer

Updates the value that will be returned by subsequent calls to the getOffset method.

setOffset(Number) - Method in class javax.management.monitor.CounterMonitor

Sets the offset value common to all observed MBeans.

setOffset(Number) - Method in interface javax.management.monitor.CounterMonitorMBean

Sets the offset value.

setOffset(Point) - Method in class javax.swing.plaf.basic.BasicToolBarUI.DragWindow

setOffset(int) - Method in class javax.xml.bind.helpers.ValidationEventLocatorImpl

Set the offset field on this event locator.

SetOfIntegerSyntax - Class in javax.print.attribute

Class SetOfIntegerSyntax is an abstract base class providing the common implementation of all attributes whose value is a set of nonnegative integers.

SetOfIntegerSyntax(String) - Constructor for class javax.print.attribute.SetOfIntegerSyntax

Construct a new set-of-integer attribute with the given members in string form.

SetOfIntegerSyntax(int[][]) - Constructor for class javax.print.attribute.SetOfIntegerSyntax

Construct a new set-of-integer attribute with the given members in array form.

SetOfIntegerSyntax(int) - Constructor for class javax.print.attribute.SetOfIntegerSyntax

Construct a new set-of-integer attribute containing a single integer.

SetOfIntegerSyntax(int, int) - Constructor for class javax.print.attribute.SetOfIntegerSyntax

Construct a new set-of-integer attribute containing a single range of integers.

setOmni(boolean) - Method in interface javax.sound.midi.MidiChannel

Turns omni mode on or off.

setOneTouchExpandable(boolean) - Method in class javax.swing.JSplitPane

Sets the value of the oneTouchExpandable property, which must be true for the JSplitPane to provide a UI widget on the divider to quickly expand/collapse the divider.

setOOBInline(boolean) - Method in class java.net.Socket

Enable/disable SO_OOBINLINE (receipt of TCP urgent data) By default, this option is disabled and TCP urgent data received on a socket is silently discarded.

setOpacity(float) - Method in class java.awt.Dialog

Sets the opacity of the window.

setOpacity(float) - Method in class java.awt.Frame

Sets the opacity of the window.

setOpacity(float) - Method in class java.awt.Window

Sets the opacity of the window.

setOpaque(boolean) - Method in class javax.swing.JComponent

If true the component paints every pixel within its bounds.

setOpenIcon(Icon) - Method in class javax.swing.tree.DefaultTreeCellRenderer

Sets the icon used to represent non-leaf nodes that are expanded.

setOptimizeHuffmanTables(boolean) - Method in class javax.imageio.plugins.jpeg.JPEGImageWriteParam

Tells the writer to generate optimized Huffman tables for the image as part of the writing process.

setOption(int, Object) - Method in interface java.net.SocketOptions

Enable/disable the option specified by optID.

setOption(SocketOption<T>, T) - Method in class java.nio.channels.AsynchronousServerSocketChannel

setOption(SocketOption<T>, T) - Method in class java.nio.channels.AsynchronousSocketChannel

setOption(SocketOption<T>, T) - Method in class java.nio.channels.DatagramChannel

setOption(SocketOption<T>, T) - Method in interface java.nio.channels.NetworkChannel

Sets the value of a socket option.

setOption(SocketOption<T>, T) - Method in class java.nio.channels.ServerSocketChannel

setOption(SocketOption<T>, T) - Method in class java.nio.channels.SocketChannel

setOptions(Set<PKIXRevocationChecker.Option>) - Method in class java.security.cert.PKIXRevocationChecker

Sets the revocation options.

setOptions(Object[]) - Method in class javax.swing.JOptionPane

Sets the options this pane displays.

setOptionType(int) - Method in class javax.swing.JOptionPane

Sets the options to display.

setOrdering(Class<T>, T, T) - Method in class javax.imageio.spi.ServiceRegistry

Sets a pairwise ordering between two service provider objects within a given category.

setOrientation(int) - Method in class java.awt.print.PageFormat

Sets the page orientation.

setOrientation(int) - Method in class java.awt.Scrollbar

Sets the orientation for this scroll bar.

setOrientation(int) - Method in class javax.swing.JProgressBar

Sets the progress bar's orientation to newOrientation, which must be SwingConstants.VERTICAL or SwingConstants.HORIZONTAL.

setOrientation(int) - Method in class javax.swing.JScrollBar

Set the scrollbar's orientation to either VERTICAL or HORIZONTAL.

setOrientation(int) - Method in class javax.swing.JSeparator

Sets the orientation of the separator.

setOrientation(int) - Method in class javax.swing.JSlider

Set the slider's orientation to either SwingConstants.VERTICAL or SwingConstants.HORIZONTAL.

setOrientation(int) - Method in class javax.swing.JSplitPane

Sets the orientation, or how the splitter is divided.

setOrientation(int) - Method in class javax.swing.JToolBar

Sets the orientation of the tool bar.

setOrientation(int) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI

Set the orientation for the JSplitPane.

setOrientation(int) - Method in class javax.swing.plaf.basic.BasicToolBarUI.DragWindow

setOrientation(int) - Method in class javax.swing.plaf.basic.BasicToolBarUI

setOrientationRequested(PageAttributes.OrientationRequestedType) - Method in class java.awt.PageAttributes

Specifies the print orientation for pages using these attributes.

setOrientationRequested(int) - Method in class java.awt.PageAttributes

Specifies the print orientation for pages using these attributes.

setOrientationRequestedToDefault() - Method in class java.awt.PageAttributes

Sets the print orientation for pages using these attributes to the default.

setOrigin(PageAttributes.OriginType) - Method in class java.awt.PageAttributes

Specifies whether drawing at (0, 0) to pages using these attributes draws at the upper-left corner of the physical page, or at the upper-left corner of the printable area.

setOriginalRow() - Method in interface javax.sql.rowset.CachedRowSet

Sets the current row in this CachedRowSet object as the original row.

setOut(PrintStream) - Static method in class java.lang.System

Reassigns the "standard" output stream.

setOuterHTML(Element, String) - Method in class javax.swing.text.html.HTMLDocument

Replaces the given element in the parent with the contents specified as an HTML string.

setOutput(Object) - Method in class javax.imageio.ImageWriter

Sets the destination to the given ImageOutputStream or other Object.

setOutputProperties(Properties) - Method in class javax.xml.transform.Transformer

Set the output properties for the transformation.

setOutputProperty(String, String) - Method in class javax.xml.transform.Transformer

Set an output property that will be in effect for the transformation.

setOutputStream(OutputStream) - Method in class java.rmi.server.LogStream

Deprecated.
no replacement

setOutputStream(OutputStream) - Method in class java.util.logging.StreamHandler

Change the output stream.

setOutputStream(OutputStream) - Method in class javax.xml.transform.stream.StreamResult

Set the ByteStream that is to be written to.

SetOverrideType - Class in org.omg.CORBA

The mapping of a CORBA enum tagging SET_OVERRIDE and ADD_OVERRIDE, which indicate whether policies should replace the existing policies of an Object or be added to them.

SetOverrideType(int) - Constructor for class org.omg.CORBA.SetOverrideType

Constructs a SetOverrideType instance from an int.

SetOverrideTypeHelper - Class in org.omg.CORBA

The Helper for SetOverrideType.

SetOverrideTypeHelper() - Constructor for class org.omg.CORBA.SetOverrideTypeHelper

setOverwriteMode(boolean) - Method in class javax.swing.text.DefaultFormatter

Configures the behavior when inserting characters.

setOwner(Object) - Method in class java.beans.XMLDecoder

Sets the owner of this decoder to owner.

setOwner(Object) - Method in class java.beans.XMLEncoder

Sets the owner of this encoder to owner.

setOwner(UserPrincipal) - Method in interface java.nio.file.attribute.FileOwnerAttributeView

Updates the file owner.

setOwner(Path, UserPrincipal) - Static method in class java.nio.file.Files

Updates the file owner.

setPackageAssertionStatus(String, boolean) - Method in class java.lang.ClassLoader

Sets the package default assertion status for the named package.

setPadding(int) - Method in class javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout

setPage(int, Printable, PageFormat) - Method in class java.awt.print.Book

Sets the PageFormat and the Painter for a specified page number.

setPage(URL) - Method in class javax.swing.JEditorPane

Sets the current URL being displayed.

setPage(String) - Method in class javax.swing.JEditorPane

Sets the current URL being displayed.

setPageable(Pageable) - Method in class java.awt.print.PrinterJob

Queries document for the number of pages and the PageFormat and Printable for each page held in the Pageable instance, document.

setPageIncrement(int) - Method in class java.awt.Scrollbar

Deprecated.
As of JDK version 1.1, replaced by setBlockIncrement().

setPageRanges(int[][]) - Method in class java.awt.JobAttributes

Specifies, for jobs using these attributes, the ranges of pages to be printed, if a range of pages is to be printed.

setPageSize(int) - Method in interface javax.sql.rowset.CachedRowSet

Sets the CachedRowSet object's page-size.

setPaint(Paint) - Method in class java.awt.Graphics2D

Sets the Paint attribute for the Graphics2D context.

setPaintLabels(boolean) - Method in class javax.swing.JSlider

Determines whether labels are painted on the slider.

setPaintMode() - Method in class java.awt.Graphics

Sets the paint mode of this graphics context to overwrite the destination with this graphics context's current color.

setPaintMode() - Method in class javax.swing.DebugGraphics

Overrides Graphics.setPaintMode.

setPaintTicks(boolean) - Method in class javax.swing.JSlider

Determines whether tick marks are painted on the slider.

setPaintTrack(boolean) - Method in class javax.swing.JSlider

Determines whether the track is painted on the slider.

setPalette(boolean) - Method in class javax.swing.plaf.metal.MetalInternalFrameTitlePane

setPalette(boolean) - Method in class javax.swing.plaf.metal.MetalInternalFrameUI

setPaper(Paper) - Method in class java.awt.print.PageFormat

Sets the Paper object for this PageFormat.

setParagraphAttributes(AttributeSet, boolean) - Method in class javax.swing.JTextPane

Applies the given attributes to paragraphs.

setParagraphAttributes(int, int, AttributeSet, boolean) - Method in class javax.swing.text.DefaultStyledDocument

Sets attributes for a paragraph.

setParagraphAttributes(int, int, AttributeSet, boolean) - Method in class javax.swing.text.html.HTMLDocument

Sets attributes for a paragraph.

setParagraphAttributes(int, int, AttributeSet, boolean) - Method in interface javax.swing.text.StyledDocument

Sets paragraph attributes.

setParagraphAttributes(JEditorPane, AttributeSet, boolean) - Method in class javax.swing.text.StyledEditorKit.StyledTextAction

Applies the given attributes to paragraphs.

setParagraphInsets(AttributeSet) - Method in class javax.swing.text.CompositeView

Sets the insets from the paragraph attributes specified in the given attributes.

setParameter(String, Object) - Method in class java.security.Signature

Deprecated.
Use setParameter.

setParameter(AlgorithmParameterSpec) - Method in class java.security.Signature

Initializes this signature engine with the specified parameter set.

setParameter(String, String) - Method in class javax.activation.MimeType

Set the value to be associated with the given name, replacing any previous association.

setParameter(String, Object) - Method in class javax.xml.transform.Transformer

Add a parameter for the transformation.

setParameter(String, Object) - Method in interface org.w3c.dom.DOMConfiguration

Set the value of a parameter.

setParameterBlock(ParameterBlock) - Method in class java.awt.image.renderable.RenderableImageOp

Change the current ParameterBlock of the operation, allowing editing of image rendering chains.

setParameters(Vector<Object>) - Method in class java.awt.image.renderable.ParameterBlock

Sets the entire Vector of parameters to a given Vector.

setParameters(Object[]) - Method in class java.util.logging.LogRecord

Set the parameters to the log message.

setParent(Logger) - Method in class java.util.logging.Logger

Set the parent for this Logger.

setParent(ResourceBundle) - Method in class java.util.ResourceBundle

Sets the parent bundle of this bundle.

setParent(ActionMap) - Method in class javax.swing.ActionMap

Sets this ActionMap's parent.

setParent(InputMap) - Method in class javax.swing.ComponentInputMap

Sets the parent, which must be a ComponentInputMap associated with the same component as this ComponentInputMap.

setParent(InputMap) - Method in class javax.swing.InputMap

Sets this InputMap's parent.

setParent(View) - Method in class javax.swing.text.AsyncBoxView

Sets the parent of the view.

setParent(View) - Method in class javax.swing.text.ComponentView

Sets the parent for a child view.

setParent(View) - Method in class javax.swing.text.CompositeView

Sets the parent of the view.

setParent(View) - Method in class javax.swing.text.FlowView

Sets the parent of the view.

setParent(View) - Method in class javax.swing.text.html.BlockView

Establishes the parent view for this view.

setParent(View) - Method in class javax.swing.text.html.ImageView

Establishes the parent view for this view.

setParent(View) - Method in class javax.swing.text.html.ParagraphView

Establishes the parent view for this view.

setParent(View) - Method in class javax.swing.text.View

Establishes the parent view for this view.

setParent(MutableTreeNode) - Method in class javax.swing.tree.DefaultMutableTreeNode

Sets this node's parent to newParent but does not change the parent's child array.

setParent(MutableTreeNode) - Method in interface javax.swing.tree.MutableTreeNode

Sets the parent of the receiver to newParent.

setParent(Node) - Method in class javax.xml.crypto.dsig.dom.DOMSignContext

Sets the parent node.

setParent(XMLEventReader) - Method in class javax.xml.stream.util.EventReaderDelegate

Set the parent of this instance.

setParent(XMLStreamReader) - Method in class javax.xml.stream.util.StreamReaderDelegate

Set the parent of this instance.

setParent(XMLReader) - Method in class org.xml.sax.helpers.XMLFilterImpl

Set the parent reader.

setParent(XMLReader) - Method in interface org.xml.sax.XMLFilter

Set the parent reader.

setParentElement(SOAPElement) - Method in interface javax.xml.soap.Node

Sets the parent of this Node object to the given SOAPElement object.

setParseBigDecimal(boolean) - Method in class java.text.DecimalFormat

Sets whether the DecimalFormat.parse(java.lang.String, java.text.ParsePosition) method returns BigDecimal.

setParseIntegerOnly(boolean) - Method in class java.text.NumberFormat

Sets whether or not numbers should be parsed as integers only.

setParser(HTMLEditorKit.Parser) - Method in class javax.swing.text.html.HTMLDocument

Sets the parser that is used by the methods that insert html into the existing document, such as setInnerHTML, and setOuterHTML.

setPartialReturn(boolean) - Method in class javax.swing.text.Segment

Flag to indicate that partial returns are valid.

setPassword(char[]) - Method in class javax.security.auth.callback.PasswordCallback

Set the retrieved password.

setPassword(String) - Method in class javax.sql.rowset.BaseRowSet

Sets the password used to create a database connection for this RowSet object to the given String object.

setPassword(String) - Method in interface javax.sql.RowSet

Sets the database password for this RowSet object to the given String.

setPath(String) - Method in class java.net.HttpCookie

Specifies a path for the cookie to which the client should return the cookie.

setPathToNames(Collection<List<?>>) - Method in class java.security.cert.X509CertSelector

Sets the pathToNames criterion.

setPatternSeparator(char) - Method in class java.text.DecimalFormatSymbols

Sets the character used to separate positive and negative subpatterns in a pattern.

setPayload(Source) - Method in interface javax.xml.ws.LogicalMessage

Sets the message payload

setPayload(Object, JAXBContext) - Method in interface javax.xml.ws.LogicalMessage

Sets the message payload

setPendingCount(int) - Method in class java.util.concurrent.CountedCompleter

Sets the pending count to the given value.

setPercent(char) - Method in class java.text.DecimalFormatSymbols

Sets the character used for percent sign.

setPerformancePreferences(int, int, int) - Method in class java.net.ServerSocket

Sets performance preferences for this ServerSocket.

setPerformancePreferences(int, int, int) - Method in class java.net.Socket

Sets performance preferences for this socket.

setPerformancePreferences(int, int, int) - Method in class java.net.SocketImpl

Sets performance preferences for this socket.

setPerMill(char) - Method in class java.text.DecimalFormatSymbols

Sets the character used for per mille sign.

setPermissions(Set<AclEntryPermission>) - Method in class java.nio.file.attribute.AclEntry.Builder

Sets the permissions component of this builder.

setPermissions(AclEntryPermission...) - Method in class java.nio.file.attribute.AclEntry.Builder

Sets the permissions component of this builder.

setPermissions(Set<PosixFilePermission>) - Method in interface java.nio.file.attribute.PosixFileAttributeView

Updates the file permissions.

setPersistenceDelegate(Class<?>, PersistenceDelegate) - Method in class java.beans.Encoder

Associates the specified persistence delegate with the given type.

setPitchBend(int) - Method in interface javax.sound.midi.MidiChannel

Changes the pitch offset for all notes on this channel.

setPixel(int, int, int[], DataBuffer) - Method in class java.awt.image.BandedSampleModel

Sets a pixel in the DataBuffer using an int array of samples for input.

setPixel(int, int, int[], DataBuffer) - Method in class java.awt.image.ComponentSampleModel

Sets a pixel in the DataBuffer using an int array of samples for input.

setPixel(int, int, int[], DataBuffer) - Method in class java.awt.image.MultiPixelPackedSampleModel

Sets a pixel in the DataBuffer using an int array for input.

setPixel(int, int, int[], DataBuffer) - Method in class java.awt.image.SampleModel

Sets a pixel in the DataBuffer using an int array of samples for input.

setPixel(int, int, float[], DataBuffer) - Method in class java.awt.image.SampleModel

Sets a pixel in the DataBuffer using a float array of samples for input.

setPixel(int, int, double[], DataBuffer) - Method in class java.awt.image.SampleModel

Sets a pixel in the DataBuffer using a double array of samples for input.

setPixel(int, int, int[], DataBuffer) - Method in class java.awt.image.SinglePixelPackedSampleModel

Sets a pixel in the DataBuffer using an int array of samples for input.

setPixel(int, int, int[]) - Method in class java.awt.image.WritableRaster

Sets a pixel in the DataBuffer using an int array of samples for input.

setPixel(int, int, float[]) - Method in class java.awt.image.WritableRaster

Sets a pixel in the DataBuffer using a float array of samples for input.

setPixel(int, int, double[]) - Method in class java.awt.image.WritableRaster

Sets a pixel in the DataBuffer using a double array of samples for input.

setPixels(int, int, int, int, ColorModel, byte[], int, int) - Method in class java.awt.image.AreaAveragingScaleFilter

Combine the components for the delivered byte pixels into the accumulation arrays and send on any averaged data for rows of pixels that are complete.

setPixels(int, int, int, int, ColorModel, int[], int, int) - Method in class java.awt.image.AreaAveragingScaleFilter

Combine the components for the delivered int pixels into the accumulation arrays and send on any averaged data for rows of pixels that are complete.

setPixels(int, int, int, int, int[], DataBuffer) - Method in class java.awt.image.BandedSampleModel

Sets all samples for a rectangle of pixels from an int array containing one sample per array element.

setPixels(int, int, int, int, ColorModel, byte[], int, int) - Method in class java.awt.image.BufferedImageFilter

Filters the information provided in the setPixels method of the ImageConsumer interface which takes an array of bytes.

setPixels(int, int, int, int, ColorModel, int[], int, int) - Method in class java.awt.image.BufferedImageFilter

Filters the information provided in the setPixels method of the ImageConsumer interface which takes an array of integers.

setPixels(int, int, int, int, int[], DataBuffer) - Method in class java.awt.image.ComponentSampleModel

Sets all samples for a rectangle of pixels from an int array containing one sample per array element.

setPixels(int, int, int, int, ColorModel, byte[], int, int) - Method in class java.awt.image.CropImageFilter

Determine whether the delivered byte pixels intersect the region to be extracted and passes through only that subset of pixels that appear in the output region.

setPixels(int, int, int, int, ColorModel, int[], int, int) - Method in class java.awt.image.CropImageFilter

Determine if the delivered int pixels intersect the region to be extracted and pass through only that subset of pixels that appear in the output region.

setPixels(int, int, int, int, ColorModel, byte[], int, int) - Method in interface java.awt.image.ImageConsumer

Delivers the pixels of the image with one or more calls to this method.

setPixels(int, int, int, int, ColorModel, int[], int, int) - Method in interface java.awt.image.ImageConsumer

The pixels of the image are delivered using one or more calls to the setPixels method.

setPixels(int, int, int, int, ColorModel, byte[], int, int) - Method in class java.awt.image.ImageFilter

Filters the information provided in the setPixels method of the ImageConsumer interface which takes an array of bytes.

setPixels(int, int, int, int, ColorModel, int[], int, int) - Method in class java.awt.image.ImageFilter

Filters the information provided in the setPixels method of the ImageConsumer interface which takes an array of integers.

setPixels(int, int, int, int, ColorModel, byte[], int, int) - Method in class java.awt.image.PixelGrabber

The setPixels method is part of the ImageConsumer API which this class must implement to retrieve the pixels.

setPixels(int, int, int, int, ColorModel, int[], int, int) - Method in class java.awt.image.PixelGrabber

The setPixels method is part of the ImageConsumer API which this class must implement to retrieve the pixels.

setPixels(int, int, int, int, ColorModel, byte[], int, int) - Method in class java.awt.image.ReplicateScaleFilter

Choose which rows and columns of the delivered byte pixels are needed for the destination scaled image and pass through just those rows and columns that are needed, replicated as necessary.

setPixels(int, int, int, int, ColorModel, int[], int, int) - Method in class java.awt.image.ReplicateScaleFilter

Choose which rows and columns of the delivered int pixels are needed for the destination scaled image and pass through just those rows and columns that are needed, replicated as necessary.

setPixels(int, int, int, int, ColorModel, byte[], int, int) - Method in class java.awt.image.RGBImageFilter

If the ColorModel object is the same one that has already been converted, then simply passes the pixels through with the converted ColorModel.

setPixels(int, int, int, int, ColorModel, int[], int, int) - Method in class java.awt.image.RGBImageFilter

If the ColorModel object is the same one that has already been converted, then simply passes the pixels through with the converted ColorModel, otherwise converts the buffer of integer pixels to the default RGB ColorModel and passes the converted buffer to the filterRGBPixels method to be converted one by one.

setPixels(int, int, int, int, int[], DataBuffer) - Method in class java.awt.image.SampleModel

Sets all samples for a rectangle of pixels from an int array containing one sample per array element.

setPixels(int, int, int, int, float[], DataBuffer) - Method in class java.awt.image.SampleModel

Sets all samples for a rectangle of pixels from a float array containing one sample per array element.

setPixels(int, int, int, int, double[], DataBuffer) - Method in class java.awt.image.SampleModel

Sets all samples for a rectangle of pixels from a double array containing one sample per array element.

setPixels(int, int, int, int, int[], DataBuffer) - Method in class java.awt.image.SinglePixelPackedSampleModel

Sets all samples for a rectangle of pixels from an int array containing one sample per array element.

setPixels(int, int, int, int, int[]) - Method in class java.awt.image.WritableRaster

Sets all samples for a rectangle of pixels from an int array containing one sample per array element.

setPixels(int, int, int, int, float[]) - Method in class java.awt.image.WritableRaster

Sets all samples for a rectangle of pixels from a float array containing one sample per array element.

setPixels(int, int, int, int, double[]) - Method in class java.awt.image.WritableRaster

Sets all samples for a rectangle of pixels from a double array containing one sample per array element.

setPlaceholder(String) - Method in class javax.swing.text.MaskFormatter

Sets the string to use if the value does not completely fill in the mask.

setPlaceholderCharacter(char) - Method in class javax.swing.text.MaskFormatter

Sets the character to use in place of characters that are not present in the value, ie the user must fill them in.

setPolicy(Set<String>) - Method in class java.security.cert.X509CertSelector

Sets the policy constraint.

setPolicy(Policy) - Static method in class java.security.Policy

Sets the system-wide Policy object.

setPolicy(Policy) - Static method in class javax.security.auth.Policy

Deprecated.

Sets the system-wide Policy object.

setPolicyMappingInhibited(boolean) - Method in class java.security.cert.PKIXParameters

Sets the PolicyMappingInhibited flag.

setPolicyQualifiersRejected(boolean) - Method in class java.security.cert.PKIXParameters

Sets the PolicyQualifiersRejected flag.

setPolyPressure(int, int) - Method in interface javax.sound.midi.MidiChannel

Reacts to a change in the specified note's key pressure.

setPoolable(boolean) - Method in interface java.sql.Statement

Requests that a Statement be pooled or not pooled.

setPopupMenu(PopupMenu) - Method in class java.awt.TrayIcon

Sets the popup menu for this TrayIcon.

setPopupMenuVisible(boolean) - Method in class javax.swing.JMenu

Sets the visibility of the menu's popup.

setPopupSize(Dimension) - Method in class javax.swing.JPopupMenu

Sets the size of the Popup window using a Dimension object.

setPopupSize(int, int) - Method in class javax.swing.JPopupMenu

Sets the size of the Popup window to the specified width and height.

setPopupVisible(boolean) - Method in class javax.swing.JComboBox

Sets the visibility of the popup.

setPopupVisible(JComboBox, boolean) - Method in class javax.swing.plaf.basic.BasicComboBoxUI

Hides the popup.

setPopupVisible(JComboBox, boolean) - Method in class javax.swing.plaf.ComboBoxUI

Set the visibility of the popup

setPopupVisible(JComboBox, boolean) - Method in class javax.swing.plaf.multi.MultiComboBoxUI

Invokes the setPopupVisible method on each UI handled by this object.

setPort(int) - Method in class java.net.DatagramPacket

Sets the port number on the remote host to which this datagram is being sent.

setPortlist(String) - Method in class java.net.HttpCookie

Specify the portlist of the cookie, which restricts the port(s) to which a cookie may be sent back in a Cookie header.

setPosition(int) - Method in class java.awt.font.LineBreakMeasurer

Sets the current position of this LineBreakMeasurer.

setPosition(Component, int) - Method in class javax.swing.JLayeredPane

Moves the component to position within its current layer, where 0 is the topmost position within the layer and -1 is the bottommost position.

setPositivePrefix(String) - Method in class java.text.DecimalFormat

Set the positive prefix.

setPositiveSuffix(String) - Method in class java.text.DecimalFormat

Set the positive suffix.

setPosixFilePermissions(Path, Set<PosixFilePermission>) - Static method in class java.nio.file.Files

Sets a file's POSIX permissions.

setPrecision(int, int) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Sets the total number of decimal digits in a value stored in the designated column to the given number.

setPrecision(int, int) - Method in interface javax.sql.RowSetMetaData

Sets the designated column's number of decimal digits to the given int.

setPreferred(boolean) - Method in class java.beans.FeatureDescriptor

The "preferred" flag is used to identify features that are particularly important for presenting to humans.

setPreferredMinSize(Dimension) - Method in class javax.swing.plaf.basic.BasicTreeUI

Sets the preferred minimum size.

setPreferredScrollableViewportSize(Dimension) - Method in class javax.swing.JTable

Sets the preferred size of the viewport for this table.

setPreferredSize(Dimension) - Method in class java.awt.Component

Sets the preferred size of this component to a constant value.

setPreferredSize(Dimension) - Method in class javax.swing.JComponent

Sets the preferred size of this component.

setPreferredWidth(int) - Method in class javax.swing.table.TableColumn

Sets this column's preferred width to preferredWidth.

setPrefix(String) - Method in class javax.imageio.metadata.IIOMetadataNode

Does nothing, since namespaces are not supported.

setPrefix(String, String) - Method in interface javax.xml.stream.XMLEventWriter

Sets the prefix the uri is bound to.

setPrefix(String, String) - Method in interface javax.xml.stream.XMLStreamWriter

Sets the prefix the uri is bound to.

setPrefix(String) - Method in interface org.w3c.dom.Node

The namespace prefix of this node, or null if it is unspecified.

setPreservesUnknownTags(boolean) - Method in class javax.swing.text.html.HTMLDocument

Determines how unknown tags are handled by the parser.

setPressed(boolean) - Method in interface javax.swing.ButtonModel

Sets the button to pressed or unpressed.

setPressed(boolean) - Method in class javax.swing.DefaultButtonModel

Sets the button to pressed or unpressed.

setPressed(boolean) - Method in class javax.swing.JToggleButton.ToggleButtonModel

Sets the pressed state of the toggle button.

setPressedIcon(Icon) - Method in class javax.swing.AbstractButton

Sets the pressed icon for the button.

setPreviewPanel(JComponent) - Method in class javax.swing.JColorChooser

Sets the current preview panel.

setPreviousBounds(JInternalFrame, Rectangle) - Method in class javax.swing.DefaultDesktopManager

Stores the bounds of the component just before a maximize call.

setPrimaryType(String) - Method in class javax.activation.MimeType

Set the primary type for this object to the given String.

setPrincipal(UserPrincipal) - Method in class java.nio.file.attribute.AclEntry.Builder

Sets the principal component of this builder.

setPrincipal(Principal) - Method in interface java.security.acl.AclEntry

Specifies the principal for which permissions are granted or denied by this ACL entry.

setPrintable(Printable) - Method in class java.awt.print.PrinterJob

Calls painter to render the pages.

setPrintable(Printable, PageFormat) - Method in class java.awt.print.PrinterJob

Calls painter to render the pages in the specified format.

setPrinter(String) - Method in class java.awt.JobAttributes

Specifies the destination printer for jobs using these attributes.

setPrinterResolution(int[]) - Method in class java.awt.PageAttributes

Specifies the desired print resolution for pages using these attributes.

setPrinterResolution(int) - Method in class java.awt.PageAttributes

Specifies the desired cross feed and feed print resolutions in dots per inch for pages using these attributes.

setPrinterResolutionToDefault() - Method in class java.awt.PageAttributes

Sets the printer resolution for pages using these attributes to the default.

setPrintQuality(PageAttributes.PrintQualityType) - Method in class java.awt.PageAttributes

Specifies the print quality for pages using these attributes.

setPrintQuality(int) - Method in class java.awt.PageAttributes

Specifies the print quality for pages using these attributes.

setPrintQualityToDefault() - Method in class java.awt.PageAttributes

Sets the print quality for pages using these attributes to the default.

setPrintService(PrintService) - Method in class java.awt.print.PrinterJob

Associate this PrinterJob with a new PrintService.

setPriority(int) - Method in class java.lang.Thread

Changes the priority of this thread.

setPrivacy(boolean) - Method in class org.ietf.jgss.MessageProp

Sets the privacy state.

setPrivateKeyValid(Date) - Method in class java.security.cert.X509CertSelector

Sets the privateKeyValid criterion.

setProblemType(int) - Method in class javax.management.relation.RoleUnresolved

Sets problem type.

setProcessors(Iterable<? extends Processor>) - Method in interface javax.tools.JavaCompiler.CompilationTask

Sets processors (for annotation processing).

setProgress(int) - Method in class javax.swing.ProgressMonitor

Indicate the progress of the operation being monitored.

setProgress(int) - Method in class javax.swing.SwingWorker

Sets the progress bound property.

setProgressiveMode(int) - Method in class javax.imageio.ImageWriteParam

Specifies that the writer is to write the image out in a progressive mode such that the stream will contain a series of scans of increasing quality.

setPropagatedFrom(BeanContext) - Method in class java.beans.beancontext.BeanContextEvent

Sets the BeanContext from which this event was propagated.

setPropagationId(Object) - Method in class java.beans.PropertyChangeEvent

Sets the propagationId object for the event.

setProperties(Hashtable<?, ?>) - Method in class java.awt.image.CropImageFilter

Passes along the properties from the source object after adding a property indicating the cropped region.

setProperties(Hashtable<?, ?>) - Method in interface java.awt.image.ImageConsumer

Sets the extensible list of properties associated with this image.

setProperties(Hashtable<?, ?>) - Method in class java.awt.image.ImageFilter

Passes the properties from the source object along after adding a property indicating the stream of filters it has been run through.

setProperties(Hashtable<?, ?>) - Method in class java.awt.image.PixelGrabber

The setProperties method is part of the ImageConsumer API which this class must implement to retrieve the pixels.

setProperties(Hashtable<?, ?>) - Method in class java.awt.image.ReplicateScaleFilter

Passes along the properties from the source object after adding a property indicating the scale applied.

setProperties(Properties) - Static method in class java.lang.System

Sets the system properties to the Properties argument.

setProperties(Map<String, Object>) - Method in class javax.xml.ws.Endpoint

Sets the property bag for this Endpoint instance.

setPropertiesFromAttributes() - Method in class javax.swing.text.html.BlockView

Update any cached values that come from attributes.

setPropertiesFromAttributes() - Method in class javax.swing.text.html.ImageView

Update any cached values that come from attributes.

setPropertiesFromAttributes() - Method in class javax.swing.text.html.InlineView

Set the cached properties from the attributes.

setPropertiesFromAttributes() - Method in class javax.swing.text.html.ListView

setPropertiesFromAttributes() - Method in class javax.swing.text.html.ParagraphView

Sets up the paragraph from css attributes instead of the values found in StyleConstants (i.e.

setPropertiesFromAttributes() - Method in class javax.swing.text.LabelView

Sets the cached properties from the attributes.

setPropertiesFromAttributes() - Method in class javax.swing.text.ParagraphView

Set the cached properties from the attributes.

setProperty(String, String) - Static method in class java.lang.System

Sets the system property indicated by the specified key.

setProperty(String, String) - Static method in class java.security.Security

Sets a security property value.

setProperty(String, String) - Method in class java.util.Properties

Calls the Hashtable method put.

setProperty(String, Object) - Method in class javax.xml.bind.Binder

Set the particular property in the underlying implementation of Binder.

setProperty(String, Object) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

Default implementation of the setProperty method handles the four defined properties in Marshaller.

setProperty(String, Object) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

Default implementation of the setProperty method always throws PropertyException since there are no required properties.

setProperty(String, Object) - Method in interface javax.xml.bind.Marshaller

Set the particular property in the underlying implementation of Marshaller.

setProperty(String, Object) - Method in interface javax.xml.bind.Unmarshaller

Set the particular property in the underlying implementation of Unmarshaller.

setProperty(String, Object) - Method in interface javax.xml.bind.Validator

Deprecated.
since JAXB2.0

setProperty(String, Object) - Method in class javax.xml.crypto.dom.DOMCryptoContext

This implementation uses an internal HashMap to map the name to the specified object.

setProperty(String, Object) - Method in interface javax.xml.crypto.XMLCryptoContext

Sets the specified property.

setProperty(String, Object) - Method in class javax.xml.parsers.SAXParser

Sets the particular property in the underlying implementation of XMLReader.

setProperty(String, Object) - Method in class javax.xml.soap.SOAPMessage

Associates the specified value with the specified property.

setProperty(String, Object) - Method in class javax.xml.stream.XMLInputFactory

Allows the user to set specific feature/property on the underlying implementation.

setProperty(String, Object) - Method in class javax.xml.stream.XMLOutputFactory

Allows the user to set specific features/properties on the underlying implementation.

setProperty(String, Object) - Method in class javax.xml.validation.SchemaFactory

Set the value of a property.

setProperty(String, Object) - Method in class javax.xml.validation.Validator

Set the value of a property.

setProperty(String, Object) - Method in class javax.xml.validation.ValidatorHandler

Set the value of a property.

setProperty(String, Object) - Method in class org.xml.sax.helpers.ParserAdapter

Set a parser property.

setProperty(String, Object) - Method in class org.xml.sax.helpers.XMLFilterImpl

Set the value of a property.

setProperty(String, Object) - Method in interface org.xml.sax.XMLReader

Set the value of a property.

setPropertyEditorClass(Class<?>) - Method in class java.beans.PropertyDescriptor

Normally PropertyEditors will be found using the PropertyEditorManager.

setProtocols(String[]) - Method in class javax.net.ssl.SSLParameters

Sets the array of protocols.

setPrototypeCellValue(E) - Method in class javax.swing.JList

Sets the prototypeCellValue property, and then (if the new value is non-null), computes the fixedCellWidth and fixedCellHeight properties by requesting the cell renderer component for the given value (and index 0) from the cell renderer, and using that component's preferred size.

setPrototypeDisplayValue(E) - Method in class javax.swing.JComboBox

Sets the prototype display value used to calculate the size of the display for the UI portion.

setPublicId(String) - Method in class javax.xml.transform.stream.StreamSource

Set the public identifier for this Source.

setPublicId(String) - Method in interface org.w3c.dom.ls.LSInput

The public identifier for this input source.

setPublicId(String) - Method in class org.xml.sax.helpers.LocatorImpl

Set the public identifier for this locator.

setPublicId(String) - Method in class org.xml.sax.InputSource

Set the public identifier for this input source.

setPublicKey(PublicKey) - Method in class java.security.Identity

Deprecated.

Sets this identity's public key.

setPurgeFlag(boolean) - Method in class javax.management.relation.RelationService

Sets the flag to indicate if when a notification is received for the unregistration of an MBean referenced in a relation, if an immediate "purge" of the relations (look for the relations no longer valid) has to be performed , or if that will be performed only when the purgeRelations method will be explicitly called.

setPurgeFlag(boolean) - Method in interface javax.management.relation.RelationServiceMBean

Sets the flag to indicate if when a notification is received for the unregistration of an MBean referenced in a relation, if an immediate "purge" of the relations (look for the relations no longer valid) has to be performed, or if that will be performed only when the purgeRelations method is explicitly called.

setPushLevel(Level) - Method in class java.util.logging.MemoryHandler

Set the pushLevel.

setQName(int, String) - Method in class org.xml.sax.helpers.AttributesImpl

Set the qualified name of a specific attribute.

setQOP(int) - Method in class org.ietf.jgss.MessageProp

Sets the QOP value.

setQueryTimeout(int) - Method in interface java.sql.Statement

Sets the number of seconds the driver will wait for a Statement object to execute to the given number of seconds.

setQueryTimeout(int) - Method in class javax.sql.rowset.BaseRowSet

Sets to the given number the maximum number of seconds the driver will wait for a query to execute.

setQueryTimeout(int) - Method in interface javax.sql.RowSet

Sets the maximum time the driver will wait for a statement to execute to the given number of seconds.

setRangeProperties(int, int, int, int, boolean) - Method in interface javax.swing.BoundedRangeModel

This method sets all of the model's data with a single method call.

setRangeProperties(int, int, int, int, boolean) - Method in class javax.swing.DefaultBoundedRangeModel

Sets all of the BoundedRangeModel properties after forcing the arguments to obey the usual constraints:

setRaster(Raster) - Method in class javax.imageio.IIOImage

Sets the current Raster.

setRawContent(InputStream, String) - Method in class javax.xml.soap.AttachmentPart

Sets the content of this attachment part to that contained by the InputStream content and sets the value of the Content-Type header to the value contained in contentType.

setRawContentBytes(byte[], int, int, String) - Method in class javax.xml.soap.AttachmentPart

Sets the content of this attachment part to that contained by the byte[] array content and sets the value of the Content-Type header to the value contained in contentType.

setRawOffset(int) - Method in class java.util.SimpleTimeZone

Sets the base time zone offset to GMT.

setRawOffset(int) - Method in class java.util.TimeZone

Sets the base time zone offset to GMT.

setRawResult(T) - Method in class java.util.concurrent.CountedCompleter

A method that result-bearing CountedCompleters may optionally use to help maintain result data.

setRawResult(V) - Method in class java.util.concurrent.ForkJoinTask

Forces the given value to be returned as a result.

setRawResult(Void) - Method in class java.util.concurrent.RecursiveAction

Requires null completion value.

setRawResult(V) - Method in class java.util.concurrent.RecursiveTask

setReadable(boolean, boolean) - Method in class java.io.File

Sets the owner's or everybody's read permission for this abstract pathname.

setReadable(boolean) - Method in class java.io.File

A convenience method to set the owner's read permission for this abstract pathname.

setReader(Reader) - Method in interface javax.script.ScriptContext

Sets the Reader for scripts to read input .

setReader(Reader) - Method in class javax.script.SimpleScriptContext

Sets the Reader for scripts to read input .

setReader(Reader) - Method in class javax.xml.transform.stream.StreamSource

Set the input to be a character reader.

setReadMethod(Method) - Method in class java.beans.PropertyDescriptor

Sets the method that should be used to read the property value.

setReadOnly() - Method in class java.io.File

Marks the file or directory named by this abstract pathname so that only read operations are allowed.

setReadOnly(boolean) - Method in interface java.nio.file.attribute.DosFileAttributeView

Updates the value of the read-only attribute.

setReadOnly() - Method in class java.security.PermissionCollection

Marks this PermissionCollection object as "readonly".

setReadOnly(boolean) - Method in interface java.sql.Connection

Puts this connection in read-only mode as a hint to the driver to enable database optimizations.

setReadOnly() - Method in class javax.security.auth.Subject

Set this Subject to be read-only.

setReadOnly(boolean) - Method in class javax.sql.rowset.BaseRowSet

Sets this RowSet object's readOnly property to the given boolean.

setReadOnly(boolean) - Method in interface javax.sql.RowSet

Sets whether this RowSet object is read-only to the given boolean.

setReadTimeout(int) - Method in class java.net.URLConnection

Sets the read timeout to a specified timeout, in milliseconds.

setReceiveBufferSize(int) - Method in class java.net.DatagramSocket

Sets the SO_RCVBUF option to the specified value for this DatagramSocket.

setReceiveBufferSize(int) - Method in class java.net.ServerSocket

Sets a default proposed value for the SO_RCVBUF option for sockets accepted from this ServerSocket.

setReceiveBufferSize(int) - Method in class java.net.Socket

Sets the SO_RCVBUF option to the specified value for this Socket.

setReceiver(Receiver) - Method in interface javax.sound.midi.Transmitter

Sets the receiver to which this transmitter will deliver MIDI messages.

setRect(double, double, double, double) - Method in class java.awt.geom.Rectangle2D.Double

Sets the location and size of this Rectangle2D to the specified double values.

setRect(Rectangle2D) - Method in class java.awt.geom.Rectangle2D.Double

Sets this Rectangle2D to be the same as the specified Rectangle2D.

setRect(float, float, float, float) - Method in class java.awt.geom.Rectangle2D.Float

Sets the location and size of this Rectangle2D to the specified float values.

setRect(double, double, double, double) - Method in class java.awt.geom.Rectangle2D.Float

Sets the location and size of this Rectangle2D to the specified double values.

setRect(Rectangle2D) - Method in class java.awt.geom.Rectangle2D.Float

Sets this Rectangle2D to be the same as the specified Rectangle2D.

setRect(double, double, double, double) - Method in class java.awt.geom.Rectangle2D

Sets the location and size of this Rectangle2D to the specified double values.

setRect(Rectangle2D) - Method in class java.awt.geom.Rectangle2D

Sets this Rectangle2D to be the same as the specified Rectangle2D.

setRect(Raster) - Method in class java.awt.image.WritableRaster

Copies pixels from Raster srcRaster to this WritableRaster.

setRect(int, int, Raster) - Method in class java.awt.image.WritableRaster

Copies pixels from Raster srcRaster to this WritableRaster.

setRect(double, double, double, double) - Method in class java.awt.Rectangle

Sets the bounds of this Rectangle to the integer bounds which encompass the specified x, y, width, and height.

setRef(RemoteStub, RemoteRef) - Static method in class java.rmi.server.RemoteStub

Deprecated.
No replacement. The setRef method was intended for setting the remote reference of a remote stub. This is unnecessary, since RemoteStubs can be created and initialized with a remote reference through use of the RemoteStub.RemoteStub(RemoteRef) constructor.

setRef(int, Ref) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to the given REF(<structured-type>) value.

setRef(int, Ref) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given Ref object in the Java programming language.

setRef(int, Ref) - Method in interface javax.sql.RowSet

Sets the designated parameter in this RowSet object's command with the given Ref value.

setRegion(String) - Method in class java.util.Locale.Builder

Sets the region.

setRejectedExecutionHandler(RejectedExecutionHandler) - Method in class java.util.concurrent.ThreadPoolExecutor

Sets a new handler for unexecutable tasks.

setRelationServiceManagementFlag(Boolean) - Method in class javax.management.relation.RelationSupport

setRelationServiceManagementFlag(Boolean) - Method in interface javax.management.relation.RelationSupportMBean

Specifies whether this relation is handled by the Relation Service.

setRelative(boolean) - Method in class javax.naming.NameClassPair

Sets whether the name of this binding is relative to the target context (which is named by the first parameter of the list() method).

setRelay(boolean) - Method in interface javax.xml.soap.SOAPHeaderElement

Sets the relay attribute for this SOAPHeaderElement to be either true or false.

setRemainingName(Name) - Method in exception javax.naming.NamingException

Sets the remaining name field of this exception.

setRemainingName(Name) - Method in class javax.naming.spi.ResolveResult

Sets the remaining name field of this result to name.

setRemainingNewName(Name) - Method in exception javax.naming.CannotProceedException

Sets the "remaining new name" field of this exception.

setRemoveOnCancelPolicy(boolean) - Method in class java.util.concurrent.ScheduledThreadPoolExecutor

Sets the policy on whether cancelled tasks should be immediately removed from the work queue at time of cancellation.

setRenderContext(RenderContext) - Method in class java.awt.image.renderable.RenderableImageProducer

Sets a new RenderContext to use for the next startProduction() call.

setRenderedImage(RenderedImage) - Method in class javax.imageio.IIOImage

Sets the current RenderedImage.

setRenderer(ListCellRenderer<? super E>) - Method in class javax.swing.JComboBox

Sets the renderer that paints the list items and the item selected from the list in the JComboBox field.

setRenderingHint(RenderingHints.Key, Object) - Method in class java.awt.Graphics2D

Sets the value of a single preference for the rendering algorithms.

setRenderingHints(Map<?, ?>) - Method in class java.awt.Graphics2D

Replaces the values of all preferences for the rendering algorithms with the specified hints.

setRenderingHints(RenderingHints) - Method in class java.awt.image.renderable.RenderContext

Sets the rendering hints of this RenderContext.

setReorderingAllowed(boolean) - Method in class javax.swing.table.JTableHeader

Sets whether the user can drag column headers to reorder columns.

setRepeats(boolean) - Method in class javax.swing.Timer

If flag is false, instructs the Timer to send only one action event to its listeners.

setRequestControls(Control[]) - Method in class javax.naming.ldap.InitialLdapContext

setRequestControls(Control[]) - Method in interface javax.naming.ldap.LdapContext

Sets the request controls for methods subsequently invoked on this context.

setRequestFocusEnabled(boolean) - Method in class javax.swing.JComponent

Provides a hint as to whether or not this JComponent should get focus.

setRequestMethod(String) - Method in class java.net.HttpURLConnection

Set the method for the URL request, one of: GET POST HEAD OPTIONS PUT DELETE TRACE are legal, subject to protocol restrictions.

setRequestProperty(String, String) - Method in class java.net.URLConnection

Sets the general request property.

setReshowDelay(int) - Method in class javax.swing.ToolTipManager

Used to specify the amount of time before the user has to wait initialDelay milliseconds before a tooltip will be shown.

setResizable(boolean) - Method in class java.awt.Dialog

Sets whether this dialog is resizable by the user.

setResizable(boolean) - Method in class java.awt.Frame

Sets whether this frame is resizable by the user.

setResizable(boolean) - Method in class javax.swing.JInternalFrame

Sets whether the JInternalFrame can be resized by some user action.

setResizable(boolean) - Method in class javax.swing.table.TableColumn

Sets whether this column can be resized.

setResizeWeight(double) - Method in class javax.swing.JSplitPane

Specifies how to distribute extra space when the size of the split pane changes.

setResizingAllowed(boolean) - Method in class javax.swing.table.JTableHeader

Sets whether the user can resize columns by dragging between headers.

setResizingColumn(TableColumn) - Method in class javax.swing.table.JTableHeader

Sets the header's resizingColumn to aColumn.

setResolvedName(Name) - Method in exception javax.naming.NamingException

Sets the resolved name field of this exception.

setResolvedObj(Object) - Method in exception javax.naming.NamingException

Sets the resolved object field of this exception.

setResolvedObj(Object) - Method in class javax.naming.spi.ResolveResult

Sets the resolved Object field of this result to obj.

setResolvedValue(int, Object) - Method in interface javax.sql.rowset.spi.SyncResolver

Sets obj as the value in column index in the current row of the RowSet object that is being synchronized.

setResolvedValue(String, Object) - Method in interface javax.sql.rowset.spi.SyncResolver

Sets obj as the value in column columnName in the current row of the RowSet object that is being synchronized.

setResolveParent(AttributeSet) - Method in class javax.swing.text.AbstractDocument.AbstractElement

Sets the resolving parent.

setResolveParent(Keymap) - Method in interface javax.swing.text.Keymap

Sets the parent keymap, which will be used to resolve key-bindings.

setResolveParent(AttributeSet) - Method in interface javax.swing.text.MutableAttributeSet

Sets the resolving parent.

setResolveParent(AttributeSet) - Method in class javax.swing.text.SimpleAttributeSet

Sets the resolving parent.

setResolveParent(AttributeSet) - Method in class javax.swing.text.StyleContext.NamedStyle

Sets the resolving parent.

setResourceBaseName(String) - Method in class javax.imageio.metadata.IIOMetadataFormatImpl

Sets a new base name for locating ResourceBundles containing descriptions of elements and attributes for this format.

setResourceBundle(ResourceBundle) - Method in class java.util.logging.Logger

Sets a resource bundle on this logger.

setResourceBundle(ResourceBundle) - Method in class java.util.logging.LogRecord

Set the localization resource bundle.

setResourceBundleName(String) - Method in class java.util.logging.LogRecord

Set the localization resource bundle name.

setResourceResolver(LSResourceResolver) - Method in class javax.xml.validation.SchemaFactory

Sets the LSResourceResolver to customize resource resolution when parsing schemas.

setResourceResolver(LSResourceResolver) - Method in class javax.xml.validation.Validator

Sets the LSResourceResolver to customize resource resolution while in a validation episode.

setResourceResolver(LSResourceResolver) - Method in class javax.xml.validation.ValidatorHandler

Sets the LSResourceResolver to customize resource resolution while in a validation episode.

setResult(Class<T>) - Method in interface java.sql.SQLXML

Returns a Result for setting the XML value designated by this SQLXML instance.

setResult(Result) - Method in interface javax.xml.transform.sax.TransformerHandler

Set the Result associated with this TransformerHandler to be used for the transformation.

setReturningAttributes(String[]) - Method in class javax.naming.directory.SearchControls

Specifies the attributes that will be returned as part of the search.

setReturningObjFlag(boolean) - Method in class javax.naming.directory.SearchControls

Enables/disables returning objects returned as part of the result.

setReuseAddress(boolean) - Method in class java.net.DatagramSocket

Enable/disable the SO_REUSEADDR socket option.

setReuseAddress(boolean) - Method in class java.net.ServerSocket

Enable/disable the SO_REUSEADDR socket option.

setReuseAddress(boolean) - Method in class java.net.Socket

Enable/disable the SO_REUSEADDR socket option.

setRevocationEnabled(boolean) - Method in class java.security.cert.PKIXParameters

Sets the RevocationEnabled flag.

setRGB(int, int, int) - Method in class java.awt.image.BufferedImage

Sets a pixel in this BufferedImage to the specified RGB value.

setRGB(int, int, int, int, int[], int, int) - Method in class java.awt.image.BufferedImage

Sets an array of integer pixels in the default RGB color model (TYPE_INT_ARGB) and default sRGB color space, into a portion of the image data.

setRightChildIndent(int) - Method in class javax.swing.plaf.basic.BasicTreeUI

setRightComponent(Component) - Method in class javax.swing.JSplitPane

Sets the component to the right (or below) the divider.

setRightIndent(MutableAttributeSet, float) - Static method in class javax.swing.text.StyleConstants

Sets right indent.

setRightInset(float) - Method in class javax.swing.text.AsyncBoxView

Set the right part of the margin around the view.

setRole(Role) - Method in interface javax.management.relation.Relation

Sets the given role.

setRole(String, Role) - Method in class javax.management.relation.RelationService

Sets the given role in given relation.

setRole(String, Role) - Method in interface javax.management.relation.RelationServiceMBean

Sets the given role in given relation.

setRole(Role) - Method in class javax.management.relation.RelationSupport

Sets the given role.

setRole(String) - Method in interface javax.xml.soap.SOAPHeaderElement

Sets the Role associated with this SOAPHeaderElement object to the specified Role.

setRoleName(String) - Method in class javax.management.relation.Role

Sets role name.

setRoleName(String) - Method in class javax.management.relation.RoleUnresolved

Sets role name.

setRoles(RoleList) - Method in interface javax.management.relation.Relation

Sets the given roles.

setRoles(String, RoleList) - Method in class javax.management.relation.RelationService

Sets the given roles in given relation.

setRoles(String, RoleList) - Method in interface javax.management.relation.RelationServiceMBean

Sets the given roles in given relation.

setRoles(RoleList) - Method in class javax.management.relation.RelationSupport

Sets the given roles.

setRoles(RoleList) - Method in class javax.management.relation.RoleResult

Sets list of roles successfully accessed.

setRoles(Set<String>) - Method in interface javax.xml.ws.soap.SOAPBinding

Sets the roles played by the SOAP binding instance.

setRolesUnresolved(RoleUnresolvedList) - Method in class javax.management.relation.RoleResult

Sets list of roles unsuccessfully accessed.

setRoleValue(List<ObjectName>) - Method in class javax.management.relation.Role

Sets role value.

setRoleValue(List<ObjectName>) - Method in class javax.management.relation.RoleUnresolved

Sets role value.

setRollover(boolean) - Method in interface javax.swing.ButtonModel

Sets or clears the button's rollover state

setRollover(boolean) - Method in class javax.swing.DefaultButtonModel

Sets or clears the button's rollover state

setRollover(boolean) - Method in class javax.swing.JToolBar

Sets the rollover state of this toolbar.

setRolloverBorders(boolean) - Method in class javax.swing.plaf.basic.BasicToolBarUI

Sets the flag for enabling rollover borders on the toolbar and it will also install the appropriate border depending on the state of the flag.

setRolloverEnabled(boolean) - Method in class javax.swing.AbstractButton

Sets the rolloverEnabled property, which must be true for rollover effects to occur.

setRolloverIcon(Icon) - Method in class javax.swing.AbstractButton

Sets the rollover icon for the button.

setRolloverSelectedIcon(Icon) - Method in class javax.swing.AbstractButton

Sets the rollover selected icon for the button.

setRolloverTab(int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

Sets the tab the mouse is currently over to index.

setRolloverTab(int) - Method in class javax.swing.plaf.synth.SynthTabbedPaneUI

Sets the tab the mouse is currently over to index.

setRoot(TreeNode) - Method in class javax.swing.tree.DefaultTreeModel

Sets the root to root.

setRootCause(Throwable) - Method in exception javax.naming.NamingException

Records the root cause of this NamingException.

setRootFrame(Frame) - Static method in class javax.swing.JOptionPane

Sets the frame to use for class methods in which a frame is not provided.

setRootPane(JRootPane) - Method in class javax.swing.JApplet

Sets the rootPane property.

setRootPane(JRootPane) - Method in class javax.swing.JDialog

Sets the rootPane property.

setRootPane(JRootPane) - Method in class javax.swing.JFrame

Sets the rootPane property.

setRootPane(JRootPane) - Method in class javax.swing.JInternalFrame

Sets the rootPane property for this JInternalFrame.

setRootPane(JRootPane) - Method in class javax.swing.JWindow

Sets the new rootPane object for this window.

setRootPaneCheckingEnabled(boolean) - Method in class javax.swing.JApplet

Sets whether calls to add and setLayout are forwarded to the contentPane.

setRootPaneCheckingEnabled(boolean) - Method in class javax.swing.JDialog

Sets whether calls to add and setLayout are forwarded to the contentPane.

setRootPaneCheckingEnabled(boolean) - Method in class javax.swing.JFrame

Sets whether calls to add and setLayout are forwarded to the contentPane.

setRootPaneCheckingEnabled(boolean) - Method in class javax.swing.JInternalFrame

Sets whether calls to add and setLayout are forwarded to the contentPane.

setRootPaneCheckingEnabled(boolean) - Method in class javax.swing.JWindow

Sets whether calls to add and setLayout are forwarded to the contentPane.

setRootVisible(boolean) - Method in class javax.swing.JTree

Determines whether or not the root node from the TreeModel is visible.

setRootVisible(boolean) - Method in class javax.swing.plaf.basic.BasicTreeUI

Sets the root to being visible.

setRootVisible(boolean) - Method in class javax.swing.tree.AbstractLayoutCache

Determines whether or not the root node from the TreeModel is visible.

setRootVisible(boolean) - Method in class javax.swing.tree.FixedHeightLayoutCache

Determines whether or not the root node from the TreeModel is visible.

setRootVisible(boolean) - Method in class javax.swing.tree.VariableHeightLayoutCache

Determines whether or not the root node from the TreeModel is visible.

setRoundingMode(RoundingMode) - Method in class java.text.DecimalFormat

Sets the RoundingMode used in this DecimalFormat.

setRoundingMode(RoundingMode) - Method in class java.text.NumberFormat

Sets the RoundingMode used in this NumberFormat.

setRoundRect(double, double, double, double, double, double) - Method in class java.awt.geom.RoundRectangle2D.Double

Sets the location, size, and corner radii of this RoundRectangle2D to the specified double values.

setRoundRect(RoundRectangle2D) - Method in class java.awt.geom.RoundRectangle2D.Double

Sets this RoundRectangle2D to be the same as the specified RoundRectangle2D.

setRoundRect(float, float, float, float, float, float) - Method in class java.awt.geom.RoundRectangle2D.Float

Sets the location, size, and corner radii of this RoundRectangle2D to the specified float values.

setRoundRect(double, double, double, double, double, double) - Method in class java.awt.geom.RoundRectangle2D.Float

Sets the location, size, and corner radii of this RoundRectangle2D to the specified double values.

setRoundRect(RoundRectangle2D) - Method in class java.awt.geom.RoundRectangle2D.Float

Sets this RoundRectangle2D to be the same as the specified RoundRectangle2D.

setRoundRect(double, double, double, double, double, double) - Method in class java.awt.geom.RoundRectangle2D

Sets the location, size, and corner radii of this RoundRectangle2D to the specified double values.

setRoundRect(RoundRectangle2D) - Method in class java.awt.geom.RoundRectangle2D

Sets this RoundRectangle2D to be the same as the specified RoundRectangle2D.

setRowCount(int) - Method in class javax.swing.table.DefaultTableModel

Sets the number of rows in the model.

setRowFilter(RowFilter<? super M, ? super I>) - Method in class javax.swing.DefaultRowSorter

Sets the filter that determines which rows, if any, should be hidden from the view.

setRowHeader(JViewport) - Method in class javax.swing.JScrollPane

Removes the old rowHeader, if it exists; if the new rowHeader isn't null, syncs the y coordinate of its viewPosition with the viewport (if there is one) and then adds it to the scroll pane.

setRowHeaderView(Component) - Method in class javax.swing.JScrollPane

Creates a row-header viewport if necessary, sets its view and then adds the row-header viewport to the scrollpane.

setRowHeight(int) - Method in class javax.swing.JTable

Sets the height, in pixels, of all cells to rowHeight, revalidates, and repaints.

setRowHeight(int, int) - Method in class javax.swing.JTable

Sets the height for row to rowHeight, revalidates, and repaints.

setRowHeight(int) - Method in class javax.swing.JTree

Sets the height of each cell, in pixels.

setRowHeight(int) - Method in class javax.swing.plaf.basic.BasicTreeUI

Sets the row height, this is forwarded to the treeState.

setRowHeight(int) - Method in class javax.swing.tree.AbstractLayoutCache

Sets the height of each cell.

setRowHeight(int) - Method in class javax.swing.tree.FixedHeightLayoutCache

Sets the height of each cell.

setRowHeight(int) - Method in class javax.swing.tree.VariableHeightLayoutCache

Sets the height of each cell.

setRowId(String, RowId) - Method in interface java.sql.CallableStatement

Sets the designated parameter to the given java.sql.RowId object.

setRowId(int, RowId) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to the given java.sql.RowId object.

setRowId(int, RowId) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given java.sql.RowId object.

setRowId(String, RowId) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given java.sql.RowId object.

setRowId(int, RowId) - Method in interface javax.sql.RowSet

Sets the designated parameter to the given java.sql.RowId object.

setRowId(String, RowId) - Method in interface javax.sql.RowSet

Sets the designated parameter to the given java.sql.RowId object.

setRowMapper(RowMapper) - Method in class javax.swing.JTree.EmptySelectionModel

This is overriden to do nothing; EmptySelectionModel does not allow a selection.

setRowMapper(RowMapper) - Method in class javax.swing.tree.DefaultTreeSelectionModel

Sets the RowMapper instance.

setRowMapper(RowMapper) - Method in interface javax.swing.tree.TreeSelectionModel

Sets the RowMapper instance.

setRowMargin(int) - Method in class javax.swing.JTable

Sets the amount of empty space between cells in adjacent rows.

setRows(int) - Method in class java.awt.GridLayout

Sets the number of rows in this layout to the specified value.

setRows(int) - Method in class java.awt.TextArea

Sets the number of rows for this text area.

setRows(int) - Method in class javax.swing.JTextArea

Sets the number of rows for this TextArea.

setRowSelectionAllowed(boolean) - Method in class javax.swing.JTable

Sets whether the rows in this model can be selected.

setRowSelectionInterval(int, int) - Method in class javax.swing.JTable

Selects the rows from index0 to index1, inclusive.

setRowSorter(RowSorter<? extends TableModel>) - Method in class javax.swing.JTable

Sets the RowSorter.

setSample(int, int, int, int, DataBuffer) - Method in class java.awt.image.BandedSampleModel

Sets a sample in the specified band for the pixel located at (x,y) in the DataBuffer using an int for input.

setSample(int, int, int, float, DataBuffer) - Method in class java.awt.image.BandedSampleModel

Sets a sample in the specified band for the pixel located at (x,y) in the DataBuffer using a float for input.

setSample(int, int, int, double, DataBuffer) - Method in class java.awt.image.BandedSampleModel

Sets a sample in the specified band for the pixel located at (x,y) in the DataBuffer using a double for input.

setSample(int, int, int, int, DataBuffer) - Method in class java.awt.image.ComponentSampleModel

Sets a sample in the specified band for the pixel located at (x,y) in the DataBuffer using an int for input.

setSample(int, int, int, float, DataBuffer) - Method in class java.awt.image.ComponentSampleModel

Sets a sample in the specified band for the pixel located at (x,y) in the DataBuffer using a float for input.

setSample(int, int, int, double, DataBuffer) - Method in class java.awt.image.ComponentSampleModel

Sets a sample in the specified band for the pixel located at (x,y) in the DataBuffer using a double for input.

setSample(int, int, int, int, DataBuffer) - Method in class java.awt.image.MultiPixelPackedSampleModel

Sets a sample in the specified band for the pixel located at (x, y) in the DataBuffer using an int for input.

setSample(int, int, int, int, DataBuffer) - Method in class java.awt.image.SampleModel

Sets a sample in the specified band for the pixel located at (x,y) in the DataBuffer using an int for input.

setSample(int, int, int, float, DataBuffer) - Method in class java.awt.image.SampleModel

Sets a sample in the specified band for the pixel located at (x,y) in the DataBuffer using a float for input.

setSample(int, int, int, double, DataBuffer) - Method in class java.awt.image.SampleModel

Sets a sample in the specified band for the pixel located at (x,y) in the DataBuffer using a double for input.

setSample(int, int, int, int, DataBuffer) - Method in class java.awt.image.SinglePixelPackedSampleModel

Sets a sample in the specified band for the pixel located at (x,y) in the DataBuffer using an int for input.

setSample(int, int, int, int) - Method in class java.awt.image.WritableRaster

Sets a sample in the specified band for the pixel located at (x,y) in the DataBuffer using an int for input.

setSample(int, int, int, float) - Method in class java.awt.image.WritableRaster

Sets a sample in the specified band for the pixel located at (x,y) in the DataBuffer using a float for input.

setSample(int, int, int, double) - Method in class java.awt.image.WritableRaster

Sets a sample in the specified band for the pixel located at (x,y) in the DataBuffer using a double for input.

setSamples(int, int, int, int, int, int[], DataBuffer) - Method in class java.awt.image.BandedSampleModel

Sets the samples in the specified band for the specified rectangle of pixels from an int array containing one sample per data array element.

setSamples(int, int, int, int, int, int[], DataBuffer) - Method in class java.awt.image.ComponentSampleModel

Sets the samples in the specified band for the specified rectangle of pixels from an int array containing one sample per data array element.

setSamples(int, int, int, int, int, int[], DataBuffer) - Method in class java.awt.image.SampleModel

Sets the samples in the specified band for the specified rectangle of pixels from an int array containing one sample per array element.

setSamples(int, int, int, int, int, float[], DataBuffer) - Method in class java.awt.image.SampleModel

Sets the samples in the specified band for the specified rectangle of pixels from a float array containing one sample per array element.

setSamples(int, int, int, int, int, double[], DataBuffer) - Method in class java.awt.image.SampleModel

Sets the samples in the specified band for the specified rectangle of pixels from a double array containing one sample per array element.

setSamples(int, int, int, int, int, int[], DataBuffer) - Method in class java.awt.image.SinglePixelPackedSampleModel

Sets the samples in the specified band for the specified rectangle of pixels from an int array containing one sample per array element.

setSamples(int, int, int, int, int, int[]) - Method in class java.awt.image.WritableRaster

Sets the samples in the specified band for the specified rectangle of pixels from an int array containing one sample per array element.

setSamples(int, int, int, int, int, float[]) - Method in class java.awt.image.WritableRaster

Sets the samples in the specified band for the specified rectangle of pixels from a float array containing one sample per array element.

setSamples(int, int, int, int, int, double[]) - Method in class java.awt.image.WritableRaster

Sets the samples in the specified band for the specified rectangle of pixels from a double array containing one sample per array element.

setSavepoint() - Method in interface java.sql.Connection

Creates an unnamed savepoint in the current transaction and returns the new Savepoint object that represents it.

setSavepoint(String) - Method in interface java.sql.Connection

Creates a savepoint with the given name in the current transaction and returns the new Savepoint object that represents it.

setScale(int, RoundingMode) - Method in class java.math.BigDecimal

Returns a BigDecimal whose scale is the specified value, and whose unscaled value is determined by multiplying or dividing this BigDecimal's unscaled value by the appropriate power of ten to maintain its overall value.

setScale(int, int) - Method in class java.math.BigDecimal

Returns a BigDecimal whose scale is the specified value, and whose unscaled value is determined by multiplying or dividing this BigDecimal's unscaled value by the appropriate power of ten to maintain its overall value.

setScale(int) - Method in class java.math.BigDecimal

Returns a BigDecimal whose scale is the specified value, and whose value is numerically equal to this BigDecimal's.

setScale(int, int) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Sets the number of digits to the right of the decimal point in a value stored in the designated column to the given number.

setScale(int, int) - Method in interface javax.sql.RowSetMetaData

Sets the designated column's number of digits to the right of the decimal point to the given int.

setSchema(String) - Method in interface java.sql.Connection

Sets the given schema name to access.

setSchema(Schema) - Method in class javax.xml.bind.Binder

Specifies whether marshal, unmarshal and update methods performs validation on their XML content.

setSchema(Schema) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

setSchema(Schema) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

setSchema(Schema) - Method in interface javax.xml.bind.Marshaller

Specify the JAXP 1.3 Schema object that should be used to validate subsequent marshal operations against.

setSchema(Schema) - Method in interface javax.xml.bind.Unmarshaller

Specify the JAXP 1.3 Schema object that should be used to validate subsequent unmarshal operations against.

setSchema(Schema) - Method in class javax.xml.parsers.DocumentBuilderFactory

Set the Schema to be used by parsers created from this factory.

setSchema(Schema) - Method in class javax.xml.parsers.SAXParserFactory

Set the Schema to be used by parsers created from this factory.

setSchemaLocation(String) - Method in class javax.xml.bind.helpers.AbstractMarshallerImpl

Convenience method for setting the schemaLocation.

setSchemaName(int, String) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Sets the designated column's table's schema name, if any, to schemaName.

setSchemaName(int, String) - Method in interface javax.sql.RowSetMetaData

Sets the name of the designated column's table's schema, if any, to the given String.

setScope(String, MessageContext.Scope) - Method in interface javax.xml.ws.handler.MessageContext

Sets the scope of a property.

setScript(String) - Method in class java.util.Locale.Builder

Sets the script.

setScrollByBlock(boolean) - Method in class javax.swing.plaf.basic.BasicScrollBarUI.ScrollListener

setScrollByBlock(boolean) - Method in class javax.swing.plaf.basic.BasicSliderUI.ScrollListener

setScrollMode(int) - Method in class javax.swing.JViewport

Used to control the method of scrolling the viewport contents.

setScrollOffset(int) - Method in class javax.swing.JTextField

Sets the scroll offset, in pixels.

setScrollPosition(int, int) - Method in class java.awt.ScrollPane

Scrolls to the specified position within the child component.

setScrollPosition(Point) - Method in class java.awt.ScrollPane

Scrolls to the specified position within the child component.

setScrollsOnExpand(boolean) - Method in class javax.swing.JTree

Sets the scrollsOnExpand property, which determines whether the tree might scroll to show previously hidden children.

setSearchable(int, boolean) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Sets whether a value stored in the designated column can be used in a WHERE clause to the given boolean value.

setSearchable(int, boolean) - Method in interface javax.sql.RowSetMetaData

Sets whether the designated column can be used in a where clause.

setSearchScope(int) - Method in class javax.naming.directory.SearchControls

Sets the search scope to one of: OBJECT_SCOPE, ONELEVEL_SCOPE, SUBTREE_SCOPE.

setSecond(int) - Method in class javax.xml.datatype.XMLGregorianCalendar

Set seconds.

setSeconds(int) - Method in class java.sql.Date

Deprecated.

setSeconds(int) - Method in class java.util.Date

Deprecated.
As of JDK version 1.1, replaced by Calendar.set(Calendar.SECOND, int seconds).

setSecure(boolean) - Method in class java.net.HttpCookie

Indicates whether the cookie should only be sent using a secure protocol, such as HTTPS or SSL.

setSecurityManager(SecurityManager) - Static method in class java.lang.System

Sets the System security.

setSeed(byte[]) - Method in class java.security.SecureRandom

Reseeds this random object.

setSeed(long) - Method in class java.security.SecureRandom

Reseeds this random object, using the eight bytes contained in the given long seed.

setSeed(long) - Method in class java.util.concurrent.ThreadLocalRandom

Throws UnsupportedOperationException.

setSeed(long) - Method in class java.util.Random

Sets the seed of this random number generator using a single long seed.

setSelected(boolean) - Method in class javax.swing.AbstractButton

Sets the state of the button.

setSelected(ButtonModel, boolean) - Method in class javax.swing.ButtonGroup

Sets the selected value for the ButtonModel.

setSelected(boolean) - Method in interface javax.swing.ButtonModel

Selects or deselects the button.

setSelected(boolean) - Method in class javax.swing.DefaultButtonModel

Selects or deselects the button.

setSelected(boolean) - Method in class javax.swing.JInternalFrame

Selects or deselects the internal frame if it's showing.

setSelected(boolean) - Method in class javax.swing.JMenu

Sets the selection status of the menu.

setSelected(Component) - Method in class javax.swing.JMenuBar

Sets the currently selected component, producing a a change to the selection model.

setSelected(Component) - Method in class javax.swing.JPopupMenu

Sets the currently selected component, This will result in a change to the selection model.

setSelected(boolean) - Method in class javax.swing.JToggleButton.ToggleButtonModel

Sets the selected state of the button.

setSelectedCheckbox(Checkbox) - Method in class java.awt.CheckboxGroup

Sets the currently selected check box in this group to be the specified check box.

setSelectedColor(Color) - Method in interface javax.swing.colorchooser.ColorSelectionModel

Sets the selected color to color.

setSelectedColor(Color) - Method in class javax.swing.colorchooser.DefaultColorSelectionModel

Sets the selected color to color.

setSelectedComponent(Component) - Method in class javax.swing.JTabbedPane

Sets the selected component for this tabbedpane.

setSelectedFile(File) - Method in class javax.swing.JFileChooser

Sets the selected file.

setSelectedFiles(File[]) - Method in class javax.swing.JFileChooser

Sets the list of selected files if the file chooser is set to allow multiple selection.

setSelectedFrame(JInternalFrame) - Method in class javax.swing.JDesktopPane

Sets the currently active JInternalFrame in this JDesktopPane.

setSelectedIcon(Icon) - Method in class javax.swing.AbstractButton

Sets the selected icon for the button.

setSelectedIndex(int) - Method in class javax.security.auth.callback.ChoiceCallback

Set the selected choice.

setSelectedIndex(int) - Method in class javax.security.auth.callback.ConfirmationCallback

Set the selected confirmation option.

setSelectedIndex(int) - Method in class javax.swing.DefaultSingleSelectionModel

setSelectedIndex(int) - Method in class javax.swing.JComboBox

Selects the item at index anIndex.

setSelectedIndex(int) - Method in class javax.swing.JList

Selects a single cell.

setSelectedIndex(int) - Method in class javax.swing.JTabbedPane

Sets the selected index for this tabbedpane.

setSelectedIndex(int) - Method in interface javax.swing.SingleSelectionModel

Sets the model's selected index to index.

setSelectedIndexes(int[]) - Method in class javax.security.auth.callback.ChoiceCallback

Set the selected choices.

setSelectedIndices(int[]) - Method in class javax.swing.JList

Changes the selection to be the set of indices specified by the given array.

setSelectedItem(Object) - Method in interface javax.swing.ComboBoxModel

Set the selected item.

setSelectedItem(Object) - Method in class javax.swing.DefaultComboBoxModel

Set the value of the selected item.

setSelectedItem(Object) - Method in class javax.swing.JComboBox

Sets the selected item in the combo box display area to the object in the argument.

setSelectedItem(Object) - Method in class javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxModel

setSelectedItem(Object) - Method in class javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxModel

setSelectedPath(MenuElement[]) - Method in class javax.swing.MenuSelectionManager

Changes the selection in the menu hierarchy.

setSelectedTextColor(Color) - Method in class javax.swing.text.JTextComponent

Sets the current color used to render the selected text.

setSelectedValue(Object, boolean) - Method in class javax.swing.JList

Selects the specified object from the list.

setSelection(boolean) - Method in class javax.swing.text.html.Option

Sets the selected state.

setSelectionBackground(Color) - Method in class javax.swing.JList

Sets the color used to draw the background of selected items, which cell renderers can use fill selected cells.

setSelectionBackground(Color) - Method in class javax.swing.JTable

Sets the background color for selected cells.

setSelectionColor(Color) - Method in class javax.swing.text.JTextComponent

Sets the current color used to render the selection.

setSelectionEnd(int) - Method in class java.awt.TextComponent

Sets the selection end for this text component to the specified position.

setSelectionEnd(int) - Method in class javax.swing.text.JTextComponent

Sets the selection end to the specified position.

setSelectionForeground(Color) - Method in class javax.swing.JList

Sets the color used to draw the foreground of selected items, which cell renderers can use to render text and graphics.

setSelectionForeground(Color) - Method in class javax.swing.JTable

Sets the foreground color for selected cells.

setSelectionInterval(int, int) - Method in class javax.swing.DefaultListSelectionModel

Changes the selection to be between index0 and index1 inclusive.

setSelectionInterval(int, int) - Method in class javax.swing.JList

Selects the specified interval.

setSelectionInterval(int, int) - Method in class javax.swing.JTree

Selects the rows in the specified interval (inclusive).

setSelectionInterval(int, int) - Method in interface javax.swing.ListSelectionModel

Changes the selection to be between index0 and index1 inclusive.

setSelectionMode(int) - Method in class javax.swing.DefaultListSelectionModel

Sets the selection mode.

setSelectionMode(int) - Method in class javax.swing.JList

Sets the selection mode for the list.

setSelectionMode(int) - Method in class javax.swing.JTable

Sets the table's selection mode to allow only single selections, a single contiguous interval, or multiple intervals.

setSelectionMode(int) - Method in class javax.swing.JTree.EmptySelectionModel

This is overriden to do nothing; EmptySelectionModel does not allow a selection.

setSelectionMode(int) - Method in interface javax.swing.ListSelectionModel

Sets the selection mode.

setSelectionMode(int) - Method in class javax.swing.tree.DefaultTreeSelectionModel

Sets the selection model, which must be one of SINGLE_TREE_SELECTION, CONTIGUOUS_TREE_SELECTION or DISCONTIGUOUS_TREE_SELECTION.

setSelectionMode(int) - Method in interface javax.swing.tree.TreeSelectionModel

Sets the selection model, which must be one of SINGLE_TREE_SELECTION, CONTIGUOUS_TREE_SELECTION or DISCONTIGUOUS_TREE_SELECTION.

setSelectionModel(ColorSelectionModel) - Method in class javax.swing.JColorChooser

Sets the model containing the selected color.

setSelectionModel(ListSelectionModel) - Method in class javax.swing.JList

Sets the selectionModel for the list to a non-null ListSelectionModel implementation.

setSelectionModel(SingleSelectionModel) - Method in class javax.swing.JMenuBar

Sets the model object to handle single selections.

setSelectionModel(SingleSelectionModel) - Method in class javax.swing.JPopupMenu

Sets the model object to handle single selections.

setSelectionModel(ListSelectionModel) - Method in class javax.swing.JTable

Sets the row selection model for this table to newModel and registers for listener notifications from the new selection model.

setSelectionModel(TreeSelectionModel) - Method in class javax.swing.JTree

Sets the tree's selection model.

setSelectionModel(TreeSelectionModel) - Method in class javax.swing.plaf.basic.BasicTreeUI

Resets the selection model.

setSelectionModel(ListSelectionModel) - Method in class javax.swing.table.DefaultTableColumnModel

Sets the selection model for this TableColumnModel to newModel and registers for listener notifications from the new selection model.

setSelectionModel(ListSelectionModel) - Method in interface javax.swing.table.TableColumnModel

Sets the selection model.

setSelectionModel(TreeSelectionModel) - Method in class javax.swing.tree.AbstractLayoutCache

Sets the TreeSelectionModel used to manage the selection to new LSM.

setSelectionPath(TreePath) - Method in class javax.swing.JTree

Selects the node identified by the specified path.

setSelectionPath(TreePath) - Method in class javax.swing.tree.DefaultTreeSelectionModel

Sets the selection to path.

setSelectionPath(TreePath) - Method in interface javax.swing.tree.TreeSelectionModel

Sets the selection to path.

setSelectionPaths(TreePath[]) - Method in class javax.swing.JTree.EmptySelectionModel

This is overriden to do nothing; EmptySelectionModel does not allow a selection.

setSelectionPaths(TreePath[]) - Method in class javax.swing.JTree

Selects the nodes identified by the specified array of paths.

setSelectionPaths(TreePath[]) - Method in class javax.swing.tree.DefaultTreeSelectionModel

Sets the selection.

setSelectionPaths(TreePath[]) - Method in interface javax.swing.tree.TreeSelectionModel

Sets the selection to path.

setSelectionRow(int) - Method in class javax.swing.JTree

Selects the node at the specified row in the display.

setSelectionRows(int[]) - Method in class javax.swing.JTree

Selects the nodes corresponding to each of the specified rows in the display.

setSelectionStart(int) - Method in class java.awt.TextComponent

Sets the selection start for this text component to the specified position.

setSelectionStart(int) - Method in class javax.swing.text.JTextComponent

Sets the selection start to the specified position.

setSelectionValues(Object[]) - Method in class javax.swing.JOptionPane

Sets the input selection values for a pane that provides the user with a list of items to choose from.

setSelectionVisible(boolean) - Method in interface javax.swing.text.Caret

Sets the visibility of the selection

setSelectionVisible(boolean) - Method in class javax.swing.text.DefaultCaret

Changes the selection visibility.

setSendBufferSize(int) - Method in class java.net.DatagramSocket

Sets the SO_SNDBUF option to the specified value for this DatagramSocket.

setSendBufferSize(int) - Method in class java.net.Socket

Sets the SO_SNDBUF option to the specified value for this Socket.

setSendPastNotifications(boolean) - Method in class javax.management.timer.Timer

Sets the flag indicating whether the timer sends past notifications or not.

setSendPastNotifications(boolean) - Method in interface javax.management.timer.TimerMBean

Sets the flag indicating whether the timer sends past notifications or not.

setSeparatorSize(Dimension) - Method in class javax.swing.JToolBar.Separator

Sets the size of the separator.

setSequence(Sequence) - Method in interface javax.sound.midi.Sequencer

Sets the current sequence on which the sequencer operates.

setSequence(InputStream) - Method in interface javax.sound.midi.Sequencer

Sets the current sequence on which the sequencer operates.

setSequenceNumber(long) - Method in class java.util.logging.LogRecord

Set the sequence number.

setSequenceNumber(long) - Method in class javax.management.Notification

Set the notification sequence number.

setSerialNumber(BigInteger) - Method in class java.security.cert.X509CertSelector

Sets the serialNumber criterion.

setServerNames(List<SNIServerName>) - Method in class javax.net.ssl.SSLParameters

Sets the desired SNIServerNames of the Server Name Indication (SNI) parameter.

setSessionCacheSize(int) - Method in interface javax.net.ssl.SSLSessionContext

Sets the size of the cache used for storing SSLSession objects grouped under this SSLSessionContext.

setSessionTimeout(int) - Method in interface javax.net.ssl.SSLSessionContext

Sets the timeout limit for SSLSession objects grouped under this SSLSessionContext.

setSeverity(int) - Method in class javax.xml.bind.helpers.ValidationEventImpl

Set the severity field of this event.

setShape(Shape) - Method in class java.awt.Dialog

Sets the shape of the window.

setShape(Shape) - Method in class java.awt.Frame

Sets the shape of the window.

setShape(Shape) - Method in class java.awt.Window

Sets the shape of the window.

setSharedInstance(PopupFactory) - Static method in class javax.swing.PopupFactory

Sets the PopupFactory that will be used to obtain Popups.

setShort(Object, int, short) - Static method in class java.lang.reflect.Array

Sets the value of the indexed component of the specified array object to the specified short value.

setShort(Object, short) - Method in class java.lang.reflect.Field

Sets the value of a field as a short on the specified object.

setShort(String, short) - Method in interface java.sql.CallableStatement

Sets the designated parameter to the given Java short value.

setShort(int, short) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to the given Java short value.

setShort(int, short) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given short in the Java programming language.

setShort(String, short) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given Java short value.

setShort(int, short) - Method in interface javax.sql.RowSet

Sets the designated parameter in this RowSet object's command to the given Java short value.

setShort(String, short) - Method in interface javax.sql.RowSet

Sets the designated parameter to the given Java short value.

setShortcut(MenuShortcut) - Method in class java.awt.MenuItem

Set the MenuShortcut object associated with this menu item.

setShortDescription(String) - Method in class java.beans.FeatureDescriptor

You can associate a short descriptive string with a feature.

setShortMonths(String[]) - Method in class java.text.DateFormatSymbols

Sets short month strings.

setShortWeekdays(String[]) - Method in class java.text.DateFormatSymbols

Sets short weekday strings.

setShowDeleted(boolean) - Method in class javax.sql.rowset.BaseRowSet

Sets the property showDeleted to the given boolean value, which determines whether rows marked for deletion appear in the set of current rows.

setShowDeleted(boolean) - Method in interface javax.sql.rowset.CachedRowSet

Sets the property showDeleted to the given boolean value, which determines whether rows marked for deletion appear in the set of current rows.

setShowDeleted(boolean) - Method in interface javax.sql.rowset.JdbcRowSet

Sets the property showDeleted to the given boolean value.

setShowDropLocation(boolean) - Method in class javax.swing.TransferHandler.TransferSupport

Sets whether or not the drop location should be visually indicated for the transfer - which must represent a drop.

setShowGrid(boolean) - Method in class javax.swing.JTable

Sets whether the table draws grid lines around cells.

setShowHorizontalLines(boolean) - Method in class javax.swing.JTable

Sets whether the table draws horizontal lines between cells.

setShowsRootHandles(boolean) - Method in class javax.swing.JTree

Sets the value of the showsRootHandles property, which specifies whether the node handles should be displayed.

setShowsRootHandles(boolean) - Method in class javax.swing.plaf.basic.BasicTreeUI

Determines whether the node handles are to be displayed.

setShowVerticalLines(boolean) - Method in class javax.swing.JTable

Sets whether the table draws vertical lines between cells.

setSides(JobAttributes.SidesType) - Method in class java.awt.JobAttributes

Specifies how consecutive pages should be imposed upon the sides of the print medium for jobs using these attributes.

setSidesToDefault() - Method in class java.awt.JobAttributes

Sets how consecutive pages should be imposed upon the sides of the print medium for jobs using these attributes to the default.

setSigned(int, boolean) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Sets whether a value stored in the designated column is a signed number to the given boolean.

setSigned(int, boolean) - Method in interface javax.sql.RowSetMetaData

Sets whether the designated column is a signed number.

setSigners(Class<?>, Object[]) - Method in class java.lang.ClassLoader

Sets the signers of a class.

setSigProvider(String) - Method in class java.security.cert.PKIXParameters

Sets the signature provider's name.

setSize(Dimension) - Method in class java.awt.Component.AccessibleAWTComponent

Resizes this object so that it has width and height.

setSize(int, int) - Method in class java.awt.Component

Resizes this component so that it has width width and height height.

setSize(Dimension) - Method in class java.awt.Component

Resizes this component so that it has width d.width and height d.height.

setSize(double, double) - Method in class java.awt.Dimension

Sets the size of this Dimension object to the specified width and height in double precision.

setSize(Dimension) - Method in class java.awt.Dimension

Sets the size of this Dimension object to the specified size.

setSize(int, int) - Method in class java.awt.Dimension

Sets the size of this Dimension object to the specified width and height.

setSize(double, double) - Method in class java.awt.geom.Dimension2D

Sets the size of this Dimension object to the specified width and height.

setSize(Dimension2D) - Method in class java.awt.geom.Dimension2D

Sets the size of this Dimension2D object to match the specified size.

setSize(Dimension) - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Resizes this object so that it has width and height.

setSize(Dimension) - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Resizes this object.

setSize(double, double) - Method in class java.awt.print.Paper

Sets the width and height of this Paper object, which represents the properties of the page onto which printing occurs.

setSize(Dimension) - Method in class java.awt.Rectangle

Sets the size of this Rectangle to match the specified Dimension.

setSize(int, int) - Method in class java.awt.Rectangle

Sets the size of this Rectangle to the specified width and height.

setSize(Dimension) - Method in class java.awt.Window

Resizes this component so that it has width d.width and height d.height.

setSize(int, int) - Method in class java.awt.Window

Resizes this component so that it has width width and height height.

setSize(int) - Method in class java.util.Vector

Sets the size of this vector.

setSize(long) - Method in class java.util.zip.ZipEntry

Sets the uncompressed size of the entry data.

setSize(Dimension) - Method in interface javax.accessibility.AccessibleComponent

Resizes this object so that it has width and height.

setSize(int) - Method in class javax.swing.DefaultListModel

Sets the size of this list.

setSize(Dimension) - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

setSize(Dimension) - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

setSize(Dimension) - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

setSize(int, int) - Method in class javax.swing.SizeSequence

Sets the size of the specified entry.

setSize(Dimension) - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

setSize(float, float) - Method in class javax.swing.text.AsyncBoxView

Sets the size of the view.

setSize(float, float) - Method in class javax.swing.text.BoxView

Sets the size of the view.

setSize(float, float) - Method in class javax.swing.text.html.ImageView

Sets the size of the view.

setSize(float, float) - Method in class javax.swing.text.PlainView

Sets the size of the view.

setSize(float, float) - Method in class javax.swing.text.View

Sets the size of the view.

setSize(float, float) - Method in class javax.swing.text.WrappedPlainView

Sets the size of the view.

setSizes(int[]) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager

Sets the sizes to newSizes.

setSizes(int[]) - Method in class javax.swing.SizeSequence

Resets this SizeSequence object, using the data in the sizes argument.

setSlaveSyncMode(Sequencer.SyncMode) - Method in interface javax.sound.midi.Sequencer

Sets the slave synchronization mode for the sequencer.

setSnapToTicks(boolean) - Method in class javax.swing.JSlider

Specifying true makes the knob (and the data value it represents) resolve to the closest tick mark next to where the user positioned the knob.

setSNIMatchers(Collection<SNIMatcher>) - Method in class javax.net.ssl.SSLParameters

Sets the SNIMatchers of the Server Name Indication (SNI) parameter.

setSocketAddress(SocketAddress) - Method in class java.net.DatagramPacket

Sets the SocketAddress (usually IP address + port number) of the remote host to which this datagram is being sent.

setSocketFactory(SocketImplFactory) - Static method in class java.net.ServerSocket

Sets the server socket implementation factory for the application.

setSocketFactory(RMISocketFactory) - Static method in class java.rmi.server.RMISocketFactory

Set the global socket factory from which RMI gets sockets (if the remote object is not associated with a specific client and/or server socket factory).

setSocketImplFactory(SocketImplFactory) - Static method in class java.net.Socket

Sets the client socket implementation factory for the application.

setSoLinger(boolean, int) - Method in class java.net.Socket

Enable/disable SO_LINGER with the specified linger time in seconds.

setSolo(boolean) - Method in interface javax.sound.midi.MidiChannel

Sets the solo state for this channel.

setSortable(int, boolean) - Method in class javax.swing.DefaultRowSorter

Sets whether or not the specified column is sortable.

setSortKeys(List<? extends RowSorter.SortKey>) - Method in class javax.swing.DefaultRowSorter

Sets the sort keys.

setSortKeys(List<? extends RowSorter.SortKey>) - Method in class javax.swing.RowSorter

Sets the current sort keys.

setSortsOnUpdates(boolean) - Method in class javax.swing.DefaultRowSorter

If true, specifies that a sort should happen when the underlying model is updated (rowsUpdated is invoked).

setSoTimeout(int) - Method in class java.net.DatagramSocket

Enable/disable SO_TIMEOUT with the specified timeout, in milliseconds.

setSoTimeout(int) - Method in class java.net.ServerSocket

Enable/disable SO_TIMEOUT with the specified timeout, in milliseconds.

setSoTimeout(int) - Method in class java.net.Socket

Enable/disable SO_TIMEOUT with the specified timeout, in milliseconds.

setSource(Object) - Method in class java.awt.AWTEvent

Retargets an event to a new source.

setSource(Object, int) - Method in class java.awt.image.renderable.ParameterBlock

Replaces an entry in the list of source with a new source.

setSource(Object) - Method in class java.beans.PropertyEditorSupport

Sets the source bean.

setSource(Object) - Method in class javax.management.Notification

Sets the source.

setSourceActions(int) - Method in class java.awt.dnd.DragGestureRecognizer

This method sets the permitted source drag action(s) for this Drag and Drop operation.

setSourceBands(int[]) - Method in class javax.imageio.IIOParam

Sets the indices of the source bands to be used.

setSourceClassName(String) - Method in class java.util.logging.LogRecord

Set the name of the class that (allegedly) issued the logging request.

setSourceMethodName(String) - Method in class java.util.logging.LogRecord

Set the name of the method that (allegedly) issued the logging request.

setSourceProgressivePasses(int, int) - Method in class javax.imageio.ImageReadParam

Sets the range of progressive passes that will be decoded.

setSourceRegion(Rectangle) - Method in class javax.imageio.IIOParam

Sets the source region of interest.

setSourceRenderSize(Dimension) - Method in class javax.imageio.ImageReadParam

If the image is able to be rendered at an arbitrary size, sets the source width and height to the supplied values.

setSources(Vector<Object>) - Method in class java.awt.image.renderable.ParameterBlock

Sets the entire Vector of sources to a given Vector.

setSourceSubsampling(int, int, int, int) - Method in class javax.imageio.IIOParam

Specifies a decimation subsampling to apply on I/O.

setSouthPane(JComponent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI

setSpaceAbove(MutableAttributeSet, float) - Static method in class javax.swing.text.StyleConstants

Sets space above.

setSpaceBelow(MutableAttributeSet, float) - Static method in class javax.swing.text.StyleConstants

Sets space below.

setSpecified(int, boolean) - Method in class org.xml.sax.ext.Attributes2Impl

Assign a value to the "specified" flag of a specific attribute.

setSQLXML(String, SQLXML) - Method in interface java.sql.CallableStatement

Sets the designated parameter to the given java.sql.SQLXML object.

setSQLXML(int, SQLXML) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to the given java.sql.SQLXML object.

setSQLXML(int, SQLXML) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given java.sql.SQLXML object.

setSQLXML(String, SQLXML) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given java.sql.SQLXML object.

setSQLXML(int, SQLXML) - Method in interface javax.sql.RowSet

Sets the designated parameter to the given java.sql.SQLXML object.

setSQLXML(String, SQLXML) - Method in interface javax.sql.RowSet

Sets the designated parameter to the given java.sql.SQLXML object.

setSSLParameters(SSLParameters) - Method in class javax.net.ssl.SSLEngine

Applies SSLParameters to this engine.

setSSLParameters(SSLParameters) - Method in class javax.net.ssl.SSLServerSocket

Applies SSLParameters to newly accepted connections.

setSSLParameters(SSLParameters) - Method in class javax.net.ssl.SSLSocket

Applies SSLParameters to this socket.

setSSLSocketFactory(SSLSocketFactory) - Method in class javax.net.ssl.HttpsURLConnection

Sets the SSLSocketFactory to be used when this instance creates sockets for secure https URL connections.

setStackTrace(StackTraceElement[]) - Method in class java.lang.Throwable

Sets the stack trace elements that will be returned by Throwable.getStackTrace() and printed by Throwable.printStackTrace() and related methods.

setStart(Comparable) - Method in class javax.swing.SpinnerDateModel

Changes the lower limit for Dates in this sequence.

setStartRule(int, int, int, int) - Method in class java.util.SimpleTimeZone

Sets the daylight saving time start rule.

setStartRule(int, int, int) - Method in class java.util.SimpleTimeZone

Sets the daylight saving time start rule to a fixed date within a month.

setStartRule(int, int, int, int, boolean) - Method in class java.util.SimpleTimeZone

Sets the daylight saving time start rule to a weekday before or after the given date within a month, e.g., the first Monday on or after the 8th.

setStartYear(int) - Method in class java.util.SimpleTimeZone

Sets the daylight saving time starting year.

setState(boolean) - Method in class java.awt.Checkbox

Sets the state of this check box to the specified state.

setState(boolean) - Method in class java.awt.CheckboxMenuItem

Sets this check box menu item to the specified state.

setState(int) - Method in class java.awt.Frame

Sets the state of this frame (obsolete).

setState(long) - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer

Sets the value of synchronization state.

setState(int) - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer

Sets the value of synchronization state.

setState(boolean) - Method in class javax.swing.JCheckBoxMenuItem

Sets the selected-state of the item.

setStatus(int) - Method in class javax.xml.ws.spi.http.HttpExchange

Sets the HTTP status code for the response.

setStepSize(Number) - Method in class javax.swing.SpinnerNumberModel

Changes the size of the value change computed by the getNextValue and getPreviousValue methods.

setStrategy(int) - Method in class java.util.zip.Deflater

Sets the compression strategy to the specified value.

setStream(String, InputStream) - Method in interface java.applet.AppletContext

Associates the specified stream with the specified key in this applet context.

setStrength(int) - Method in class java.text.Collator

Sets this Collator's strength property.

setStrictErrorChecking(boolean) - Method in interface org.w3c.dom.Document

An attribute specifying whether error checking is enforced or not.

setStrikeThrough(boolean) - Method in class javax.swing.text.LabelView

Sets whether or not the view has a strike/line through it.

setStrikeThrough(MutableAttributeSet, boolean) - Static method in class javax.swing.text.StyleConstants

Sets the strikethrough attribute.

setString(String, String) - Method in interface java.sql.CallableStatement

Sets the designated parameter to the given Java String value.

setString(long, String) - Method in interface java.sql.Clob

Writes the given Java String to the CLOB value that this Clob object designates at the position pos.

setString(long, String, int, int) - Method in interface java.sql.Clob

Writes len characters of str, starting at character offset, to the CLOB value that this Clob represents.

setString(int, String) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to the given Java String value.

setString(String) - Method in interface java.sql.SQLXML

Sets the XML value designated by this SQLXML instance to the given String representation.

setString(int, String) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given String value.

setString(String, String) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given Java String value.

setString(long, String) - Method in class javax.sql.rowset.serial.SerialClob

Writes the given Java String to the CLOB value that this SerialClob object represents, at the position pos.

setString(long, String, int, int) - Method in class javax.sql.rowset.serial.SerialClob

Writes len characters of str, starting at character offset, to the CLOB value that this Clob represents.

setString(int, String) - Method in interface javax.sql.RowSet

Sets the designated parameter in this RowSet object's command to the given Java String value.

setString(String, String) - Method in interface javax.sql.RowSet

Sets the designated parameter to the given Java String value.

setString(String) - Method in class javax.swing.JProgressBar

Sets the value of the progress string.

setStringConverter(TableStringConverter) - Method in class javax.swing.table.TableRowSorter

Sets the object responsible for converting values from the model to strings.

setStringData(String) - Method in interface org.w3c.dom.ls.LSInput

String data to parse.

setStringPainted(boolean) - Method in class javax.swing.JProgressBar

Sets the value of the stringPainted property, which determines whether the progress bar should render a progress string.

setStringToCompare(String) - Method in class javax.management.monitor.StringMonitor

Sets the string to compare with the observed attribute common to all observed MBeans.

setStringToCompare(String) - Method in interface javax.management.monitor.StringMonitorMBean

Sets the string to compare with the observed attribute.

setStroke(Stroke) - Method in class java.awt.Graphics2D

Sets the Stroke for the Graphics2D context.

setStub(AppletStub) - Method in class java.applet.Applet

Sets this applet's stub.

setStyledDocument(StyledDocument) - Method in class javax.swing.JTextPane

Associates the editor with a text document.

setStyleFactory(SynthStyleFactory) - Static method in class javax.swing.plaf.synth.SynthLookAndFeel

Sets the SynthStyleFactory that the UI classes provided by synth will use to obtain a SynthStyle.

setStyleSheet(StyleSheet) - Method in class javax.swing.text.html.HTMLEditorKit

Set the set of styles to be used to render the various HTML elements.

setSubject(X500Principal) - Method in class java.security.cert.X509CertSelector

Sets the subject criterion.

setSubject(String) - Method in class java.security.cert.X509CertSelector

Denigrated, use X509CertSelector.setSubject(X500Principal) or X509CertSelector.setSubject(byte[]) instead.

setSubject(byte[]) - Method in class java.security.cert.X509CertSelector

Sets the subject criterion.

setSubjectAlternativeNames(Collection<List<?>>) - Method in class java.security.cert.X509CertSelector

Sets the subjectAlternativeNames criterion.

setSubjectKeyIdentifier(byte[]) - Method in class java.security.cert.X509CertSelector

Sets the subjectKeyIdentifier criterion.

setSubjectPublicKey(PublicKey) - Method in class java.security.cert.X509CertSelector

Sets the subjectPublicKey criterion.

setSubjectPublicKey(byte[]) - Method in class java.security.cert.X509CertSelector

Sets the subjectPublicKey criterion.

setSubjectPublicKeyAlgID(String) - Method in class java.security.cert.X509CertSelector

Sets the subjectPublicKeyAlgID criterion.

setSubscript(boolean) - Method in class javax.swing.text.LabelView

Sets whether or not the view represents a subscript.

setSubscript(MutableAttributeSet, boolean) - Static method in class javax.swing.text.StyleConstants

Sets the subscript attribute.

setSubType(String) - Method in class javax.activation.MimeType

Set the subtype for this object to the given String.

setSuperscript(boolean) - Method in class javax.swing.text.LabelView

Sets whether or not the view represents a superscript.

setSuperscript(MutableAttributeSet, boolean) - Static method in class javax.swing.text.StyleConstants

Sets the superscript attribute.

setSupplementaryStates(boolean, boolean, boolean, boolean, int, String) - Method in class org.ietf.jgss.MessageProp

This method sets the state for the supplementary information flags and the minor status in MessageProp.

setSurrendersFocusOnKeystroke(boolean) - Method in class javax.swing.JTable

Sets whether editors in this JTable get the keyboard focus when an editor is activated as a result of the JTable forwarding keyboard events for a cell.

setSyncAllWidths(boolean) - Method in class javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout

setSyncProvider(String) - Method in interface javax.sql.rowset.CachedRowSet

Sets the SyncProvider object for this CachedRowSet object to the one specified.

setSyncResolver(SyncResolver) - Method in exception javax.sql.rowset.spi.SyncProviderException

Sets the SyncResolver object for this SyncProviderException object to the one supplied.

setSystem(boolean) - Method in interface java.nio.file.attribute.DosFileAttributeView

Updates the value of the system attribute.

setSystem(ActivationSystem) - Static method in class java.rmi.activation.ActivationGroup

Set the activation system for the VM.

setSystemId(String) - Method in class javax.xml.transform.dom.DOMResult

Set the systemId that may be used in association with the node.

setSystemId(String) - Method in class javax.xml.transform.dom.DOMSource

Set the base ID (URL or system ID) from where URLs will be resolved.

setSystemId(String) - Method in interface javax.xml.transform.Result

Set the system identifier for this Result.

setSystemId(String) - Method in class javax.xml.transform.sax.SAXResult

Method setSystemId Set the systemID that may be used in association with the ContentHandler.

setSystemId(String) - Method in class javax.xml.transform.sax.SAXSource

Set the system identifier for this Source.

setSystemId(String) - Method in interface javax.xml.transform.sax.TemplatesHandler

Set the base ID (URI or system ID) for the Templates object created by this builder.

setSystemId(String) - Method in interface javax.xml.transform.sax.TransformerHandler

Set the base ID (URI or system ID) from where relative URLs will be resolved.

setSystemId(String) - Method in interface javax.xml.transform.Source

Set the system identifier for this Source.

setSystemId(String) - Method in class javax.xml.transform.stax.StAXResult

In the context of a StAXResult, it is not appropriate to explicitly set the system identifier.

setSystemId(String) - Method in class javax.xml.transform.stax.StAXSource

In the context of a StAXSource, it is not appropriate to explicitly set the system identifier.

setSystemId(String) - Method in class javax.xml.transform.stream.StreamResult

Set the systemID that may be used in association with the byte or character stream, or, if neither is set, use this value as a writeable URI (probably a file name).

setSystemId(File) - Method in class javax.xml.transform.stream.StreamResult

Set the system ID from a File reference.

setSystemId(String) - Method in class javax.xml.transform.stream.StreamSource

Set the system identifier for this Source.

setSystemId(File) - Method in class javax.xml.transform.stream.StreamSource

Set the system ID from a File reference.

setSystemId(String) - Method in interface org.w3c.dom.ls.LSInput

The system identifier, a URI reference [IETF RFC 2396], for this input source.

setSystemId(String) - Method in interface org.w3c.dom.ls.LSOutput

The system identifier, a URI reference [IETF RFC 2396], for this output destination.

setSystemId(String) - Method in class org.xml.sax.helpers.LocatorImpl

Set the system identifier for this locator.

setSystemId(String) - Method in class org.xml.sax.InputSource

Set the system identifier for this input source.

setSystemScope(IdentityScope) - Static method in class java.security.IdentityScope

Deprecated.

Sets the system's identity scope.

setTabComponentAt(int, Component) - Method in class javax.swing.JTabbedPane

Sets the component that is responsible for rendering the title for the specified tab.

setTabLayoutPolicy(int) - Method in class javax.swing.JTabbedPane

Sets the policy which the tabbedpane will use in laying out the tabs when all the tabs will not fit within a single run.

setTable(JTable) - Method in class javax.swing.table.JTableHeader

Sets the table associated with this header.

setTableHeader(JTableHeader) - Method in class javax.swing.JTable

Sets the tableHeader working with this JTable to newHeader.

setTableName(String) - Method in interface javax.sql.rowset.CachedRowSet

Sets the identifier for the table from which this CachedRowSet object was derived to the given table name.

setTableName(int, String) - Method in class javax.sql.rowset.RowSetMetaDataImpl

Sets the name of the table from which the designated column was derived to the given table name.

setTableName(int, String) - Method in interface javax.sql.RowSetMetaData

Sets the designated column's table name, if any, to the given String.

setTabPlacement(int) - Method in class javax.swing.JTabbedPane

Sets the tab placement for this tabbedpane.

setTabSet(MutableAttributeSet, TabSet) - Static method in class javax.swing.text.StyleConstants

Sets the TabSet.

setTabSize(int) - Method in class javax.swing.JTextArea

Sets the number of characters to expand tabs to.

setTarget(MethodHandle) - Method in class java.lang.invoke.CallSite

Updates the target method of this call site, according to the behavior defined by this call site's specific class.

setTarget(MethodHandle) - Method in class java.lang.invoke.ConstantCallSite

Always throws an UnsupportedOperationException.

setTarget(MethodHandle) - Method in class java.lang.invoke.MutableCallSite

Updates the target method of this call site, as a normal variable.

setTarget(MethodHandle) - Method in class java.lang.invoke.VolatileCallSite

Updates the target method of this call site, as a volatile variable.

setTarget(Object) - Method in class javax.accessibility.AccessibleRelation

Sets the target object for this relation

setTarget(Object[]) - Method in class javax.accessibility.AccessibleRelation

Sets the target objects for this relation

setTarget(Remote) - Method in interface javax.rmi.CORBA.Tie

Called by Util.registerTarget(javax.rmi.CORBA.Tie, java.rmi.Remote) to set the target for this tie.

setTargetActions(int) - Method in class java.awt.dnd.DropTargetContext

This method sets the current actions acceptable to this DropTarget.

setTargetCertConstraints(CertSelector) - Method in class java.security.cert.PKIXParameters

Sets the required constraints on the target certificate.

setTcpNoDelay(boolean) - Method in class java.net.Socket

Enable/disable TCP_NODELAY (disable/enable Nagle's algorithm).

setTempoFactor(float) - Method in interface javax.sound.midi.Sequencer

Scales the sequencer's actual playback tempo by the factor provided.

setTempoInBPM(float) - Method in interface javax.sound.midi.Sequencer

Sets the tempo in beats per minute.

setTempoInMPQ(float) - Method in interface javax.sound.midi.Sequencer

Sets the tempo in microseconds per quarter note.

setText(String) - Method in class java.awt.Label

Sets the text for this label to the specified text.

setText(String) - Method in class java.awt.TextComponent

Sets the text that is presented by this text component to be the specified text.

setText(String) - Method in class java.awt.TextField

Sets the text that is presented by this text component to be the specified text.

setText(String) - Method in class java.text.BreakIterator

Set a new text string to be scanned.

setText(CharacterIterator) - Method in class java.text.BreakIterator

Set a new text for scanning.

setText(String) - Method in class java.text.CollationElementIterator

Set a new string over which to iterate.

setText(CharacterIterator) - Method in class java.text.CollationElementIterator

Set a new string over which to iterate.

setText(String) - Method in class java.text.StringCharacterIterator

Reset this iterator to point to a new string.

setText(String) - Method in class javax.security.auth.callback.TextInputCallback

Set the retrieved text.

setText(String) - Method in class javax.swing.AbstractButton

Sets the button's text.

setText(String) - Method in class javax.swing.JEditorPane

Sets the text of this TextComponent to the specified content, which is expected to be in the format of the content type of this editor.

setText(String) - Method in class javax.swing.JLabel

Defines the single line of text this component will display.

setText(String) - Method in class javax.swing.text.JTextComponent

Sets the text of this TextComponent to the specified text.

setTextContent(String) - Method in class javax.imageio.metadata.IIOMetadataNode

This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.

setTextContent(String) - Method in interface org.w3c.dom.Node

This attribute returns the text content of this node and its descendants.

setTextContents(String) - Method in interface javax.accessibility.AccessibleEditableText

Sets the text contents to the specified string.

setTextContents(String) - Method in class javax.swing.JSpinner.AccessibleJSpinner

Sets the text contents to the specified string.

setTextContents(String) - Method in class javax.swing.text.JTextComponent.AccessibleJTextComponent

Sets the text contents to the specified string.

setTextNonSelectionColor(Color) - Method in class javax.swing.tree.DefaultTreeCellRenderer

Sets the color the text is drawn with when the node isn't selected.

setTextSelectionColor(Color) - Method in class javax.swing.tree.DefaultTreeCellRenderer

Sets the color the text is drawn with when the node is selected.

setTextShiftOffset() - Method in class javax.swing.plaf.basic.BasicButtonUI

setThreadContentionMonitoringEnabled(boolean) - Method in interface java.lang.management.ThreadMXBean

Enables or disables thread contention monitoring.

setThreadCpuTimeEnabled(boolean) - Method in interface java.lang.management.ThreadMXBean

Enables or disables thread CPU time measurement.

setThreadFactory(ThreadFactory) - Method in class java.util.concurrent.ThreadPoolExecutor

Sets the thread factory used to create new threads.

setThreadID(int) - Method in class java.util.logging.LogRecord

Set an identifier for the thread where the message originated.

setThreshold(Number) - Method in class javax.management.monitor.CounterMonitor

Deprecated.
As of JMX 1.2, replaced by CounterMonitor.setInitThreshold(java.lang.Number)

setThreshold(Number) - Method in interface javax.management.monitor.CounterMonitorMBean

Deprecated.
As of JMX 1.2, replaced by CounterMonitorMBean.setInitThreshold(java.lang.Number)

setThresholds(Number, Number) - Method in class javax.management.monitor.GaugeMonitor

Sets the high and the low threshold values common to all observed MBeans.

setThresholds(Number, Number) - Method in interface javax.management.monitor.GaugeMonitorMBean

Sets the high and the low threshold values.

setThrown(Throwable) - Method in class java.util.logging.LogRecord

Set a throwable associated with the log event.

setThumbBounds(int, int, int, int) - Method in class javax.swing.plaf.basic.BasicScrollBarUI

Set the bounds of the thumb and force a repaint that includes the old thumbBounds and the new one.

setThumbBounds(int, int, int, int) - Method in class javax.swing.plaf.metal.MetalScrollBarUI

This is overridden only to increase the invalid area.

setThumbLocation(int, int) - Method in class javax.swing.plaf.basic.BasicSliderUI

setThumbLocation(int, int) - Method in class javax.swing.plaf.synth.SynthSliderUI

setThumbnails(List<? extends BufferedImage>) - Method in class javax.imageio.IIOImage

Sets the list of thumbnails to a new List of BufferedImages, or to null.

setThumbRollover(boolean) - Method in class javax.swing.plaf.basic.BasicScrollBarUI

Sets whether or not the mouse is currently over the thumb.

setThumbRollover(boolean) - Method in class javax.swing.plaf.synth.SynthScrollBarUI

Sets whether or not the mouse is currently over the thumb.

setTick(long) - Method in class javax.sound.midi.MidiEvent

Sets the time-stamp for the event, in MIDI ticks

setTickPosition(long) - Method in interface javax.sound.midi.Sequencer

Sets the current sequencer position in MIDI ticks

setTiling(int, int, int, int) - Method in class javax.imageio.ImageWriteParam

Specifies that the image should be tiled in the output stream.

setTilingMode(int) - Method in class javax.imageio.ImageWriteParam

Determines whether the image will be tiled in the output stream and, if it will, how the tiling parameters will be determined.

setTime(String, Time) - Method in interface java.sql.CallableStatement

Sets the designated parameter to the given java.sql.Time value.

setTime(String, Time, Calendar) - Method in interface java.sql.CallableStatement

Sets the designated parameter to the given java.sql.Time value, using the given Calendar object.

setTime(long) - Method in class java.sql.Date

Sets an existing Date object using the given milliseconds time value.

setTime(int, Time) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to the given java.sql.Time value.

setTime(int, Time, Calendar) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to the given java.sql.Time value, using the given Calendar object.

setTime(long) - Method in class java.sql.Time

Sets a Time object using a milliseconds time value.

setTime(long) - Method in class java.sql.Timestamp

Sets this Timestamp object to represent a point in time that is time milliseconds after January 1, 1970 00:00:00 GMT.

setTime(Date) - Method in class java.util.Calendar

Sets this Calendar's time with the given Date.

setTime(long) - Method in class java.util.Date

Sets this Date object to represent a point in time that is time milliseconds after January 1, 1970 00:00:00 GMT.

setTime(long) - Method in class java.util.zip.ZipEntry

Sets the last modification time of the entry.

setTime(int, Time) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given java.sql.Time value.

setTime(int, Time, Calendar) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given java.sql.Time object.

setTime(String, Time) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given java.sql.Time value.

setTime(String, Time, Calendar) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given java.sql.Time value, using the given Calendar object.

setTime(int, Time) - Method in interface javax.sql.RowSet

Sets the designated parameter in this RowSet object's command to the given java.sql.Time value.

setTime(int, Time, Calendar) - Method in interface javax.sql.RowSet

Sets the designated parameter in this RowSet object's command with the given java.sql.Time value.

setTime(String, Time) - Method in interface javax.sql.RowSet

Sets the designated parameter to the given java.sql.Time value.

setTime(String, Time, Calendar) - Method in interface javax.sql.RowSet

Sets the designated parameter to the given java.sql.Time value, using the given Calendar object.

setTime(int, int, int) - Method in class javax.xml.datatype.XMLGregorianCalendar

Set time as one unit.

setTime(int, int, int, BigDecimal) - Method in class javax.xml.datatype.XMLGregorianCalendar

Set time as one unit, including the optional infinite precision fractional seconds.

setTime(int, int, int, int) - Method in class javax.xml.datatype.XMLGregorianCalendar

Set time as one unit, including optional milliseconds.

setTimeInMillis(long) - Method in class java.util.Calendar

Sets this Calendar's current time from the given long value.

setTimeLimit(int) - Method in class javax.naming.directory.SearchControls

Sets the time limit of these SearchControls in milliseconds.

setTimeOfDay(int, int, int) - Method in class java.util.Calendar.Builder

Sets the time of day field parameters to the values given by hourOfDay, minute, and second.

setTimeOfDay(int, int, int, int) - Method in class java.util.Calendar.Builder

Sets the time of day field parameters to the values given by hourOfDay, minute, second, and millis.

setTimes(FileTime, FileTime, FileTime) - Method in interface java.nio.file.attribute.BasicFileAttributeView

Updates any or all of the file's last modified time, last access time, and create time attributes.

setTimestamp(String, Timestamp) - Method in interface java.sql.CallableStatement

Sets the designated parameter to the given java.sql.Timestamp value.

setTimestamp(String, Timestamp, Calendar) - Method in interface java.sql.CallableStatement

Sets the designated parameter to the given java.sql.Timestamp value, using the given Calendar object.

setTimestamp(int, Timestamp) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to the given java.sql.Timestamp value.

setTimestamp(int, Timestamp, Calendar) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to the given java.sql.Timestamp value, using the given Calendar object.

setTimeStamp(long) - Method in class javax.management.Notification

Set the notification timestamp.

setTimestamp(int, Timestamp) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given java.sql.Timestamp value.

setTimestamp(int, Timestamp, Calendar) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given java.sql.Timestamp object.

setTimestamp(String, Timestamp) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given java.sql.Timestamp value.

setTimestamp(String, Timestamp, Calendar) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given java.sql.Timestamp value, using the given Calendar object.

setTimestamp(int, Timestamp) - Method in interface javax.sql.RowSet

Sets the designated parameter in this RowSet object's command to the given java.sql.Timestamp value.

setTimestamp(String, Timestamp) - Method in interface javax.sql.RowSet

Sets the designated parameter to the given java.sql.Timestamp value.

setTimestamp(int, Timestamp, Calendar) - Method in interface javax.sql.RowSet

Sets the designated parameter in this RowSet object's command with the given java.sql.Timestamp value.

setTimestamp(String, Timestamp, Calendar) - Method in interface javax.sql.RowSet

Sets the designated parameter to the given java.sql.Timestamp value, using the given Calendar object.

setTimeToLive(int) - Method in class java.net.DatagramSocketImpl

Set the TTL (time-to-live) option.

setTimeToLive(int) - Method in class java.net.MulticastSocket

Set the default time-to-live for multicast packets sent out on this MulticastSocket in order to control the scope of the multicasts.

setTimeZone(TimeZone) - Method in class java.text.DateFormat

Sets the time zone for the calendar of this DateFormat object.

setTimeZone(TimeZone) - Method in class java.util.Calendar.Builder

Sets the time zone parameter to the given zone.

setTimeZone(TimeZone) - Method in class java.util.Calendar

Sets the time zone with the given time zone value.

setTimeZone(TimeZone) - Method in class java.util.GregorianCalendar

setTimezone(int) - Method in class javax.xml.datatype.XMLGregorianCalendar

Set the number of minutes in the timezone offset.

setTipText(String) - Method in class javax.swing.JToolTip

Sets the text to show when the tool tip is displayed.

setTitle(String) - Method in class java.awt.Dialog

Sets the title of the Dialog.

setTitle(String) - Method in class java.awt.Frame

Sets the title for this frame to the specified string.

setTitle(String) - Method in class javax.swing.border.TitledBorder

Sets the title of the titled border.

setTitle(String) - Method in class javax.swing.JInternalFrame

Sets the JInternalFrame title.

setTitleAt(int, String) - Method in class javax.swing.JTabbedPane

Sets the title at index to title which can be null.

setTitleColor(Color) - Method in class javax.swing.border.TitledBorder

Sets the title-color of the titled border.

setTitleFont(Font) - Method in class javax.swing.border.TitledBorder

Sets the title-font of the titled border.

setTitleJustification(int) - Method in class javax.swing.border.TitledBorder

Sets the title-justification of the titled border.

setTitlePosition(int) - Method in class javax.swing.border.TitledBorder

Sets the title-position of the titled border.

setToggleClickCount(int) - Method in class javax.swing.JTree

Sets the number of mouse clicks before a node will expand or close.

setToIdentity() - Method in class java.awt.geom.AffineTransform

Resets this transform to the Identity transform.

setTokenThreshold(int) - Method in class javax.swing.text.html.HTMLDocument

Sets the number of tokens to buffer before trying to update the documents element structure.

setToolTip(String) - Method in class java.awt.TrayIcon

Sets the tooltip string for this TrayIcon.

setToolTipText(String) - Method in class javax.swing.JComponent

Registers the text to display in a tool tip.

setToolTipTextAt(int, String) - Method in class javax.swing.JTabbedPane

Sets the tooltip text at index to toolTipText which can be null.

setToPage(int) - Method in class java.awt.JobAttributes

Specifies, for jobs using these attributes, the last page (inclusive) to be printed, if a range of pages is to be printed.

setTopComponent(Component) - Method in class javax.swing.JSplitPane

Sets the component above, or to the left of the divider.

setTopDown(boolean) - Method in class javax.imageio.plugins.bmp.BMPImageWriteParam

If set, the data will be written out in a top-down manner, the first scanline being written first.

setTopInset(float) - Method in class javax.swing.text.AsyncBoxView

Set the top part of the margin around the view.

setToQuadrantRotation(int) - Method in class java.awt.geom.AffineTransform

Sets this transform to a rotation transformation that rotates coordinates by the specified number of quadrants.

setToQuadrantRotation(int, double, double) - Method in class java.awt.geom.AffineTransform

Sets this transform to a translated rotation transformation that rotates coordinates by the specified number of quadrants around the specified anchor point.

setToRotation(double) - Method in class java.awt.geom.AffineTransform

Sets this transform to a rotation transformation.

setToRotation(double, double, double) - Method in class java.awt.geom.AffineTransform

Sets this transform to a translated rotation transformation.

setToRotation(double, double) - Method in class java.awt.geom.AffineTransform

Sets this transform to a rotation transformation that rotates coordinates according to a rotation vector.

setToRotation(double, double, double, double) - Method in class java.awt.geom.AffineTransform

Sets this transform to a rotation transformation that rotates coordinates around an anchor point according to a rotation vector.

setToScale(double, double) - Method in class java.awt.geom.AffineTransform

Sets this transform to a scaling transformation.

setToShear(double, double) - Method in class java.awt.geom.AffineTransform

Sets this transform to a shearing transformation.

setToTranslation(double, double) - Method in class java.awt.geom.AffineTransform

Sets this transform to a translation transformation.

setTrackMute(int, boolean) - Method in interface javax.sound.midi.Sequencer

Sets the mute state for a track.

setTrackSolo(int, boolean) - Method in interface javax.sound.midi.Sequencer

Sets the solo state for a track.

setTrafficClass(int) - Method in class java.net.DatagramSocket

Sets traffic class or type-of-service octet in the IP datagram header for datagrams sent from this DatagramSocket.

setTrafficClass(int) - Method in class java.net.Socket

Sets traffic class or type-of-service octet in the IP header for packets sent from this Socket.

setTransactionIsolation(int) - Method in interface java.sql.Connection

Attempts to change the transaction isolation level for this Connection object to the one given.

setTransactionIsolation(int) - Method in class javax.sql.rowset.BaseRowSet

Sets the transaction isolation property for this JDBC RowSet object to the given constant.

setTransactionIsolation(int) - Method in interface javax.sql.RowSet

Sets the transaction isolation level for this RowSet object.

setTransactionTimeout(int) - Method in interface javax.transaction.xa.XAResource

Sets the current transaction timeout value for this XAResource instance.

setTransferHandler(TransferHandler) - Method in class javax.swing.JApplet

Sets the transferHandler property, which is a mechanism to support transfer of data into this component.

setTransferHandler(TransferHandler) - Method in class javax.swing.JComponent

Sets the TransferHandler, which provides support for transfer of data into and out of this component via cut/copy/paste and drag and drop.

setTransferHandler(TransferHandler) - Method in class javax.swing.JDialog

Sets the transferHandler property, which is a mechanism to support transfer of data into this component.

setTransferHandler(TransferHandler) - Method in class javax.swing.JFrame

Sets the transferHandler property, which is a mechanism to support transfer of data into this component.

setTransferHandler(TransferHandler) - Method in class javax.swing.JWindow

Sets the transferHandler property, which is a mechanism to support transfer of data into this component.

setTransform(AffineTransform) - Method in class java.awt.geom.AffineTransform

Sets this transform to a copy of the transform in the specified AffineTransform object.

setTransform(double, double, double, double, double, double) - Method in class java.awt.geom.AffineTransform

Sets this transform to the matrix specified by the 6 double precision values.

setTransform(AffineTransform) - Method in class java.awt.Graphics2D

Overwrites the Transform in the Graphics2D context.

setTransform(AffineTransform) - Method in class java.awt.image.renderable.RenderContext

Sets the current user-to-device AffineTransform contained in the RenderContext to a given transform.

setTree(JTree) - Method in class javax.swing.tree.DefaultTreeCellEditor

Sets the tree currently editing for.

setTrustAnchors(Set<TrustAnchor>) - Method in class java.security.cert.PKIXParameters

Sets the Set of most-trusted CAs.

setTTL(byte) - Method in class java.net.DatagramSocketImpl

Deprecated.
use setTimeToLive instead.

setTTL(byte) - Method in class java.net.MulticastSocket

Deprecated.
use the setTimeToLive method instead, which uses int instead of byte as the type for ttl.

setType(Window.Type) - Method in class java.awt.Window

Sets the type of the window.

setType(AclEntryType) - Method in class java.nio.file.attribute.AclEntry.Builder

Sets the type component of this builder.

setType(int) - Method in class javax.sql.rowset.BaseRowSet

Sets the type for this RowSet object to the specified type.

setType(int) - Method in interface javax.sql.RowSet

Sets the type of this RowSet object to the given type.

setType(short) - Method in class javax.swing.text.DefaultStyledDocument.ElementSpec

Sets the element type.

setType(int, String) - Method in class org.xml.sax.helpers.AttributesImpl

Set the type of a specific attribute.

setTypeMap(Map<String, Class<?>>) - Method in interface java.sql.Connection

Installs the given TypeMap object as the type map for this Connection object.

setTypeMap(Map<String, Class<?>>) - Method in class javax.sql.rowset.BaseRowSet

Installs the given java.util.Map object as the type map associated with the Connection object for this RowSet object.

setTypeMap(Map<String, Class<?>>) - Method in interface javax.sql.RowSet

Installs the given java.util.Map object as the default type map for this RowSet object.

setUI(ButtonUI) - Method in class javax.swing.AbstractButton

Sets the L&F object that renders this component.

setUI(ColorChooserUI) - Method in class javax.swing.JColorChooser

Sets the L&F object that renders this component.

setUI(ComboBoxUI) - Method in class javax.swing.JComboBox

Sets the L&F object that renders this component.

setUI(ComponentUI) - Method in class javax.swing.JComponent

Sets the look and feel delegate for this component.

setUI(DesktopPaneUI) - Method in class javax.swing.JDesktopPane

Sets the L&F object that renders this component.

setUI(DesktopIconUI) - Method in class javax.swing.JInternalFrame.JDesktopIcon

Sets the look-and-feel object that renders this component.

setUI(InternalFrameUI) - Method in class javax.swing.JInternalFrame

Sets the UI delegate for this JInternalFrame.

setUI(LabelUI) - Method in class javax.swing.JLabel

Sets the L&F object that renders this component.

setUI(LayerUI<? super V>) - Method in class javax.swing.JLayer

Sets the LayerUI which will perform painting and receive input events for this JLayer.

setUI(ListUI) - Method in class javax.swing.JList

Sets the ListUI, the look and feel object that renders this component.

setUI(MenuBarUI) - Method in class javax.swing.JMenuBar

Sets the L&F object that renders this component.

setUI(MenuItemUI) - Method in class javax.swing.JMenuItem

Sets the look and feel object that renders this component.

setUI(OptionPaneUI) - Method in class javax.swing.JOptionPane

Sets the UI object which implements the L&F for this component.

setUI(PanelUI) - Method in class javax.swing.JPanel

Sets the look and feel (L&F) object that renders this component.

setUI(PopupMenuUI) - Method in class javax.swing.JPopupMenu

Sets the L&F object that renders this component.

setUI(ProgressBarUI) - Method in class javax.swing.JProgressBar

Sets the look-and-feel object that renders this component.

setUI(RootPaneUI) - Method in class javax.swing.JRootPane

Sets the L&F object that renders this component.

setUI(ScrollBarUI) - Method in class javax.swing.JScrollBar

Sets the L&F object that renders this component.

setUI(ScrollPaneUI) - Method in class javax.swing.JScrollPane

Sets the ScrollPaneUI object that provides the look and feel (L&F) for this component.

setUI(SeparatorUI) - Method in class javax.swing.JSeparator

Sets the L&F object that renders this component.

setUI(SliderUI) - Method in class javax.swing.JSlider

Sets the UI object which implements the L&F for this component.

setUI(SpinnerUI) - Method in class javax.swing.JSpinner

Sets the look and feel (L&F) object that renders this component.

setUI(SplitPaneUI) - Method in class javax.swing.JSplitPane

Sets the L&F object that renders this component.

setUI(TabbedPaneUI) - Method in class javax.swing.JTabbedPane

Sets the UI object which implements the L&F for this component.

setUI(TableUI) - Method in class javax.swing.JTable

Sets the L&F object that renders this component and repaints.

setUI(ToolBarUI) - Method in class javax.swing.JToolBar

Sets the L&F object that renders this component.

setUI(TreeUI) - Method in class javax.swing.JTree

Sets the L&F object that renders this component.

setUI(ViewportUI) - Method in class javax.swing.JViewport

Sets the L&F object that renders this component.

setUI(TableHeaderUI) - Method in class javax.swing.table.JTableHeader

Sets the look and feel (L&F) object that renders this component.

setUI(TextUI) - Method in class javax.swing.text.JTextComponent

Sets the user-interface factory for this text-oriented editor.

setUncaughtExceptionHandler(Thread.UncaughtExceptionHandler) - Method in class java.lang.Thread

Set the handler invoked when this thread abruptly terminates due to an uncaught exception.

setUndecorated(boolean) - Method in class java.awt.Dialog

Disables or enables decorations for this dialog.

setUndecorated(boolean) - Method in class java.awt.Frame

Disables or enables decorations for this frame.

setUnderline(boolean) - Method in class javax.swing.text.LabelView

Sets whether or not the view is underlined.

setUnderline(MutableAttributeSet, boolean) - Static method in class javax.swing.text.StyleConstants

Sets the underline attribute.

setUnexecutedModifications(ModificationItem[]) - Method in exception javax.naming.directory.AttributeModificationException

Sets the unexecuted modification list to be e.

setUnicast(boolean) - Method in class java.beans.EventSetDescriptor

Mark an event set as unicast (or not).

setUnicodeLocaleKeyword(String, String) - Method in class java.util.Locale.Builder

Sets the Unicode locale keyword type for the given key.

setUnicodeStream(int, InputStream, int) - Method in interface java.sql.PreparedStatement

Deprecated.
Use setCharacterStream

setUnicodeStream(int, InputStream, int) - Method in class javax.sql.rowset.BaseRowSet

Deprecated.
getCharacterStream should be used in its place

setUnitIncrement(int) - Method in interface java.awt.Adjustable

Sets the unit value increment for the adjustable object.

setUnitIncrement(int) - Method in class java.awt.Scrollbar

Sets the unit increment for this scroll bar.

setUnitIncrement(int) - Method in class java.awt.ScrollPaneAdjustable

setUnitIncrement(int) - Method in class javax.swing.JScrollBar

Sets the unitIncrement property.

setUnitIncrement(int) - Method in class javax.swing.JScrollPane.ScrollBar

Messages super to set the value, and resets the unitIncrementSet instance variable to true.

setup(FileSystemView) - Method in class javax.swing.JFileChooser

Performs common constructor initialization and setup.

setUpdatePolicy(int) - Method in class javax.swing.text.DefaultCaret

Sets the caret movement policy on the document updates.

setUpdateRect(Rectangle) - Method in class java.awt.event.PaintEvent

Sets the rectangle representing the area which needs to be repainted in response to this event.

setUpdateSelectionOnSort(boolean) - Method in class javax.swing.JTable

Specifies whether the selection should be updated after sorting.

setUpdateTableInRealTime(boolean) - Method in class javax.swing.table.JTableHeader

Obsolete as of Java 2 platform v1.3.

setupMenuCloseKey() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI

setupMenuOpenKey() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI

setupPostTimer(JMenu) - Method in class javax.swing.plaf.basic.BasicMenuUI

setURI(int, String) - Method in class org.xml.sax.helpers.AttributesImpl

Set the Namespace URI of a specific attribute.

setURIDereferencer(URIDereferencer) - Method in class javax.xml.crypto.dom.DOMCryptoContext

setURIDereferencer(URIDereferencer) - Method in interface javax.xml.crypto.XMLCryptoContext

Sets a URIDereferencer that is used to dereference URIReferences.

setURIResolver(URIResolver) - Method in class javax.xml.transform.Transformer

Set an object that will be used to resolve URIs used in document().

setURIResolver(URIResolver) - Method in class javax.xml.transform.TransformerFactory

Set an object that is used by default during the transformation to resolve URIs used in document(), xsl:import, or xsl:include.

setURL(URL, String, String, int, String, String, String, String, String) - Method in class java.net.URLStreamHandler

Sets the fields of the URL argument to the indicated values.

setURL(URL, String, String, int, String, String) - Method in class java.net.URLStreamHandler

Deprecated.
Use setURL(URL, String, String, int, String, String, String, String);

setURL(String, URL) - Method in interface java.sql.CallableStatement

Sets the designated parameter to the given java.net.URL object.

setURL(int, URL) - Method in interface java.sql.PreparedStatement

Sets the designated parameter to the given java.net.URL value.

setUrl(String) - Method in class javax.sql.rowset.BaseRowSet

Sets the Url property for this RowSet object to the given String object and sets the dataSource name property to null.

setURL(int, URL) - Method in class javax.sql.rowset.BaseRowSet

Sets the designated parameter to the given java.net.URL value.

setUrl(String) - Method in interface javax.sql.RowSet

Sets the URL this RowSet object will use when it uses the DriverManager to create a connection.

setURL(int, URL) - Method in interface javax.sql.RowSet

Sets the designated parameter to the given java.net.URL value.

setURL(URL) - Method in class javax.xml.bind.helpers.ValidationEventLocatorImpl

Set the URL field on this event locator.

setURLStreamHandlerFactory(URLStreamHandlerFactory) - Static method in class java.net.URL

Sets an application's URLStreamHandlerFactory.

setUsageThreshold(long) - Method in interface java.lang.management.MemoryPoolMXBean

Sets the threshold of this memory pool to the given threshold value if this memory pool supports the usage threshold.

setUseCache(boolean) - Static method in class javax.imageio.ImageIO

Sets a flag indicating whether a disk-based cache file should be used when creating ImageInputStreams and ImageOutputStreams.

setUseCaches(boolean) - Method in class java.net.URLConnection

Sets the value of the useCaches field of this URLConnection to the specified value.

setUseCipherSuitesOrder(boolean) - Method in class javax.net.ssl.SSLParameters

Sets whether the local cipher suites preference should be honored.

setUseClientMode(boolean) - Method in class javax.net.ssl.SSLEngine

Configures the engine to use client (or server) mode when handshaking.

setUseClientMode(boolean) - Method in class javax.net.ssl.SSLServerSocket

Controls whether accepted connections are in the (default) SSL server mode, or the SSL client mode.

setUseClientMode(boolean) - Method in class javax.net.ssl.SSLSocket

Configures the socket to use client (or server) mode when handshaking.

setUseParentHandlers(boolean) - Method in class java.util.logging.Logger

Specify whether or not this logger should send its output to its parent Logger.

setUserData(String, Object, UserDataHandler) - Method in class javax.imageio.metadata.IIOMetadataNode

This DOM Level 3 method is not supported for IIOMetadataNode and will throw a DOMException.

setUserData(Object) - Method in class javax.management.Notification

Set the user data.

setUserData(String, Object, UserDataHandler) - Method in interface org.w3c.dom.Node

Associate an object to a key on this node.

setUsername(String) - Method in class javax.sql.rowset.BaseRowSet

Sets the username property for this RowSet object to the given user name.

setUsername(String) - Method in interface javax.sql.RowSet

Sets the username property for this RowSet object to the given String.

setUserObject(Object) - Method in class javax.imageio.metadata.IIOMetadataNode

Sets the value associated with this node.

setUserObject(Object) - Method in class javax.swing.tree.DefaultMutableTreeNode

Sets the user object for this node to userObject.

setUserObject(Object) - Method in interface javax.swing.tree.MutableTreeNode

Resets the user object of the receiver to object.

setValidating(boolean) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl

Specifies whether or not the Unmarshaller should validate during unmarshal operations.

setValidating(boolean) - Method in interface javax.xml.bind.Unmarshaller

Deprecated.
since JAXB2.0, please see Unmarshaller.setSchema(javax.xml.validation.Schema)

setValidating(boolean) - Method in class javax.xml.parsers.DocumentBuilderFactory

Specifies that the parser produced by this code will validate documents as they are parsed.

setValidating(boolean) - Method in class javax.xml.parsers.SAXParserFactory

Specifies that the parser produced by this code will validate documents as they are parsed.

setValidCharacters(String) - Method in class javax.swing.text.MaskFormatter

Allows for further restricting of the characters that can be input.

setValue(int) - Method in interface java.awt.Adjustable

Sets the current value of the adjustable object.

setValue(int) - Method in class java.awt.Scrollbar

Sets the value of this scroll bar to the specified value.

setValue(int) - Method in class java.awt.ScrollPaneAdjustable

Sets the value of this scrollbar to the specified value.

setValue(Object) - Method in class java.beans.Expression

Sets the value of this expression to value.

setValue(String, Object) - Method in class java.beans.FeatureDescriptor

Associate a named attribute with this feature.

setValue(Object) - Method in interface java.beans.PropertyEditor

Set (or change) the object that is to be edited.

setValue(Object) - Method in class java.beans.PropertyEditorSupport

Set (or change) the object that is to be edited.

setValue(String) - Method in class java.net.HttpCookie

Assigns a new value to a cookie after the cookie is created.

setValue(V) - Method in class java.util.AbstractMap.SimpleEntry

Replaces the value corresponding to this entry with the specified value.

setValue(V) - Method in class java.util.AbstractMap.SimpleImmutableEntry

Replaces the value corresponding to this entry with the specified value (optional operation).

setValue(V) - Method in interface java.util.Map.Entry

Replaces the value corresponding to this entry with the specified value (optional operation).

setValue(boolean) - Method in class javax.sound.sampled.BooleanControl

Sets the current value for the control.

setValue(Object) - Method in class javax.sound.sampled.EnumControl

Sets the current value for the control.

setValue(float) - Method in class javax.sound.sampled.FloatControl

Sets the current value for the control.

setValue(int) - Method in interface javax.swing.BoundedRangeModel

Sets the model's current value to newValue if newValue satisfies the model's constraints.

setValue(int) - Method in class javax.swing.DefaultBoundedRangeModel

Sets the current value of the model.

setValue(Object) - Method in class javax.swing.DefaultCellEditor.EditorDelegate

Sets the value of this cell.

setValue(Object) - Method in class javax.swing.JFormattedTextField

Sets the value that will be formatted by an AbstractFormatter obtained from the current AbstractFormatterFactory.

setValue(Object) - Method in class javax.swing.JOptionPane

Sets the value the user has chosen.

setValue(int) - Method in class javax.swing.JProgressBar

Sets the progress bar's current value to n.

setValue(int) - Method in class javax.swing.JScrollBar

Sets the scrollbar's value.

setValue(int) - Method in class javax.swing.JSlider

Sets the slider's current value to n.

setValue(Object) - Method in class javax.swing.JSpinner

Changes current value of the model, typically this value is displayed by the editor.

setValue(Object, boolean) - Method in interface javax.swing.Renderer

Specifies the value to display and whether or not the value should be portrayed as "currently selected".

setValue(Object) - Method in class javax.swing.SpinnerDateModel

Sets the current Date for this sequence.

setValue(Object) - Method in class javax.swing.SpinnerListModel

Changes the current element of the sequence and notifies ChangeListeners.

setValue(Object) - Method in interface javax.swing.SpinnerModel

Changes current value of the model, typically this value is displayed by the editor part of a JSpinner.

setValue(Object) - Method in class javax.swing.SpinnerNumberModel

Sets the current value for this sequence.

setValue(int) - Method in class javax.swing.Spring

Sets the current value of this Spring to value.

setValue(Object) - Method in class javax.swing.table.DefaultTableCellRenderer

Sets the String object for the cell being rendered to value.

setValue(T) - Method in class javax.xml.bind.JAXBElement

Set the content model and attributes of this xml element.

setValue(String) - Method in interface javax.xml.soap.Node

If this is a Text node then this method will set its value, otherwise it sets the value of the immediate (Text) child of this node.

setValue(String) - Method in interface org.w3c.dom.Attr

On retrieval, the value of the attribute is returned as a string.

setValue(int, String) - Method in class org.xml.sax.helpers.AttributesImpl

Set the value of a specific attribute.

setValueAt(Object, int, int) - Method in class javax.swing.JTable

Sets the value for the cell in the table model at row and column.

setValueAt(Object, int, int) - Method in class javax.swing.table.AbstractTableModel

This empty implementation is provided so users don't have to implement this method if their data model is not editable.

setValueAt(Object, int, int) - Method in class javax.swing.table.DefaultTableModel

Sets the object value for the cell at column and row.

setValueAt(Object, int, int) - Method in interface javax.swing.table.TableModel

Sets the value in the cell at columnIndex and rowIndex to aValue.

setValueClass(Class<?>) - Method in class javax.swing.text.DefaultFormatter

Sets that class that is used to create new Objects.

setValueContainsLiteralCharacters(boolean) - Method in class javax.swing.text.MaskFormatter

If true, the returned value and set value will also contain the literal characters in mask.

setValueIsAdjusting(boolean) - Method in class java.awt.Scrollbar

Sets the valueIsAdjusting property.

setValueIsAdjusting(boolean) - Method in class java.awt.ScrollPaneAdjustable

Sets the valueIsAdjusting property.

setValueIsAdjusting(boolean) - Method in interface javax.swing.BoundedRangeModel

This attribute indicates that any upcoming changes to the value of the model should be considered a single event.

setValueIsAdjusting(boolean) - Method in class javax.swing.DefaultBoundedRangeModel

Sets the valueIsAdjusting property.

setValueIsAdjusting(boolean) - Method in class javax.swing.DefaultListSelectionModel

Sets the valueIsAdjusting property, which indicates whether or not upcoming selection changes should be considered part of a single change.

setValueIsAdjusting(boolean) - Method in class javax.swing.JList

Sets the selection model's valueIsAdjusting property.

setValueIsAdjusting(boolean) - Method in class javax.swing.JScrollBar

Sets the model's valueIsAdjusting property.

setValueIsAdjusting(boolean) - Method in class javax.swing.JSlider

Sets the model's valueIsAdjusting property.

setValueIsAdjusting(boolean) - Method in interface javax.swing.ListSelectionModel

Sets the valueIsAdjusting property, which indicates whether or not upcoming selection changes should be considered part of a single change.

setValues(int, int, int, int) - Method in class java.awt.Scrollbar

Sets the values of four properties for this scroll bar: value, visibleAmount, minimum, and maximum.

setValues(int, int, int, int) - Method in class javax.swing.JScrollBar

Sets the four BoundedRangeModel properties after forcing the arguments to obey the usual constraints:

setVariant(String) - Method in class java.util.Locale.Builder

Sets the variant.

setVerbose(boolean) - Method in interface java.lang.management.ClassLoadingMXBean

Enables or disables the verbose output for the class loading system.

setVerbose(boolean) - Method in interface java.lang.management.MemoryMXBean

Enables or disables verbose output for the memory system.

setVerifyInputWhenFocusTarget(boolean) - Method in class javax.swing.JComponent

Sets the value to indicate whether input verifier for the current focus owner will be called before this component requests focus.

setVersion(int) - Method in class java.net.HttpCookie

Sets the version of the cookie protocol this cookie complies with.

setVerticalAlignment(int) - Method in class javax.swing.AbstractButton

Sets the vertical alignment of the icon and text.

setVerticalAlignment(int) - Method in class javax.swing.JLabel

Sets the alignment of the label's contents along the Y axis.

setVerticalGroup(GroupLayout.Group) - Method in class javax.swing.GroupLayout

Sets the Group that positions and sizes components along the vertical axis.

setVerticalScrollBar(JScrollBar) - Method in class javax.swing.JScrollPane

Adds the scrollbar that controls the viewports vertical view position to the scrollpane.

setVerticalScrollBarPolicy(int) - Method in class javax.swing.JScrollPane

Determines when the vertical scrollbar appears in the scrollpane.

setVerticalScrollBarPolicy(int) - Method in class javax.swing.ScrollPaneLayout

Sets the vertical scrollbar-display policy.

setVerticalTextPosition(int) - Method in class javax.swing.AbstractButton

Sets the vertical position of the text relative to the icon.

setVerticalTextPosition(int) - Method in class javax.swing.JLabel

Sets the vertical position of the label's text, relative to its image.

setVgap(int) - Method in class java.awt.BorderLayout

Sets the vertical gap between components.

setVgap(int) - Method in class java.awt.CardLayout

Sets the vertical gap between components.

setVgap(int) - Method in class java.awt.FlowLayout

Sets the vertical gap between components and between the components and the borders of the Container.

setVgap(int) - Method in class java.awt.GridLayout

Sets the vertical gap between components to the specified value.

setView(V) - Method in class javax.swing.JLayer

Sets the JLayer's view component, which can be null.

setView(Component) - Method in class javax.swing.JViewport

Sets the JViewport's one lightweight child (view), which can be null.

setView(View) - Method in class javax.swing.plaf.basic.BasicTextUI

Sets the current root of the view hierarchy and calls invalidate().

setViewport(JViewport) - Method in class javax.swing.JScrollPane

Removes the old viewport (if there is one); forces the viewPosition of the new viewport to be in the +x,+y quadrant; syncs up the row and column headers (if there are any) with the new viewport; and finally syncs the scrollbars and headers with the new viewport.

setViewportBorder(Border) - Method in class javax.swing.JScrollPane

Adds a border around the viewport.

setViewportView(Component) - Method in class javax.swing.JScrollPane

Creates a viewport if necessary and then sets its view.

setViewPosition(Point) - Method in class javax.swing.JViewport

Sets the view coordinates that appear in the upper left hand corner of the viewport, does nothing if there's no view.

setViewSize(Dimension) - Method in class javax.swing.JViewport

Sets the size of the view.

setVisible(boolean) - Method in class java.awt.Component.AccessibleAWTComponent

Sets the visible state of the object.

setVisible(boolean) - Method in class java.awt.Component

Shows or hides this component depending on the value of parameter b.

setVisible(boolean) - Method in class java.awt.Dialog

Shows or hides this Dialog depending on the value of parameter b.

setVisible(boolean) - Method in class java.awt.List.AccessibleAWTList.AccessibleAWTListChild

Set the visible state of the object.

setVisible(boolean) - Method in class java.awt.MenuComponent.AccessibleAWTMenuComponent

Sets the visible state of the object.

setVisible(boolean) - Method in class java.awt.Window

Shows or hides this Window depending on the value of parameter b.

setVisible(boolean) - Method in interface javax.accessibility.AccessibleComponent

Sets the visible state of the object.

setVisible(boolean) - Method in class javax.swing.JComponent

Makes the component visible or invisible.

setVisible(boolean) - Method in class javax.swing.JList.AccessibleJList.AccessibleJListChild

setVisible(boolean) - Method in class javax.swing.JPopupMenu

Sets the visibility of the popup menu.

setVisible(boolean) - Method in class javax.swing.JTable.AccessibleJTable.AccessibleJTableCell

Sets the visible state of the object.

setVisible(boolean) - Method in class javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode

setVisible(boolean) - Method in class javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry

setVisible(boolean) - Method in interface javax.swing.text.Caret

Sets the visibility of the caret.

setVisible(boolean) - Method in class javax.swing.text.DefaultCaret

Sets the caret visibility, and repaints the caret.

setVisibleAmount(int) - Method in interface java.awt.Adjustable

Sets the length of the proportional indicator of the adjustable object.

setVisibleAmount(int) - Method in class java.awt.Scrollbar

Sets the visible amount of this scroll bar.

setVisibleAmount(int) - Method in class java.awt.ScrollPaneAdjustable

This method should NOT be called by user code.

setVisibleAmount(int) - Method in class javax.swing.JScrollBar

Set the model's extent property.

setVisibleComponent(Component) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

setVisibleRowCount(int) - Method in class javax.swing.JList

Sets the visibleRowCount property, which has different meanings depending on the layout orientation: For a VERTICAL layout orientation, this sets the preferred number of rows to display without requiring scrolling; for other orientations, it affects the wrapping of cells.

setVisibleRowCount(int) - Method in class javax.swing.JTree

Sets the number of rows that are to be displayed.

setWantClientAuth(boolean) - Method in class javax.net.ssl.SSLEngine

Configures the engine to request client authentication.

setWantClientAuth(boolean) - Method in class javax.net.ssl.SSLParameters

Sets whether client authentication should be requested.

setWantClientAuth(boolean) - Method in class javax.net.ssl.SSLServerSocket

Controls whether accepted server-mode SSLSockets will be initially configured to request client authentication.

setWantClientAuth(boolean) - Method in class javax.net.ssl.SSLSocket

Configures the socket to request client authentication.

setWantsInput(boolean) - Method in class javax.swing.JOptionPane

Sets the wantsInput property.

setWasIcon(JInternalFrame, Boolean) - Method in class javax.swing.DefaultDesktopManager

Sets that the component has been iconized and the bounds of the desktopIcon are valid.

setWeekDate(int, int, int) - Method in class java.util.Calendar.Builder

Sets the week-based date parameters to the values with the given date specifiers - week year, week of year, and day of week.

setWeekDate(int, int, int) - Method in class java.util.Calendar

Sets the date of this Calendar with the the given date specifiers - week year, week of year, and day of week.

setWeekDate(int, int, int) - Method in class java.util.GregorianCalendar

Sets this GregorianCalendar to the date given by the date specifiers - weekYear, weekOfYear, and dayOfWeek.

setWeekdays(String[]) - Method in class java.text.DateFormatSymbols

Sets weekday strings.

setWeekDefinition(int, int) - Method in class java.util.Calendar.Builder

Sets the week definition parameters to the values given by firstDayOfWeek and minimalDaysInFirstWeek that are used to determine the first week of a year.

setWestPane(JComponent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI

setWheelScrollingEnabled(boolean) - Method in class java.awt.ScrollPane

Enables/disables scrolling in response to movement of the mouse wheel.

setWheelScrollingEnabled(boolean) - Method in class javax.swing.JScrollPane

Enables/disables scrolling in response to movement of the mouse wheel.

setWidth(Spring) - Method in class javax.swing.SpringLayout.Constraints

Sets the width property, which controls the width of a component.

setWidth(int) - Method in class javax.swing.table.TableColumn

This method should not be used to set the widths of columns in the JTable, use setPreferredWidth instead.

setWindingRule(int) - Method in class java.awt.geom.Path2D

Sets the winding rule for this path to the specified value.

setWindowDecorationStyle(int) - Method in class javax.swing.JRootPane

Sets the type of Window decorations (such as borders, widgets for closing a Window, title ...) the JRootPane should provide.

setWrapStyleWord(boolean) - Method in class javax.swing.JTextArea

Sets the style of wrapping used if the text area is wrapping lines.

setWritable(boolean, boolean) - Method in class java.io.File

Sets the owner's or everybody's write permission for this abstract pathname.

setWritable(boolean) - Method in class java.io.File

A convenience method to set the owner's write permission for this abstract pathname.

setWriteMethod(Method) - Method in class java.beans.PropertyDescriptor

Sets the method that should be used to write the property value.

setWriter(Writer) - Method in interface javax.script.ScriptContext

Sets the Writer for scripts to use when displaying output.

setWriter(Writer) - Method in class javax.script.SimpleScriptContext

Sets the Writer for scripts to use when displaying output.

setWriter(Writer) - Method in class javax.xml.transform.stream.StreamResult

Set the writer that is to receive the result.

setX(Spring) - Method in class javax.swing.SpringLayout.Constraints

Sets the x property, which controls the x value of a component's location.

setXIncludeAware(boolean) - Method in class javax.xml.parsers.DocumentBuilderFactory

Set state of XInclude processing.

setXIncludeAware(boolean) - Method in class javax.xml.parsers.SAXParserFactory

Set state of XInclude processing.

setXMLReader(XMLReader) - Method in class javax.xml.transform.sax.SAXSource

Set the XMLReader to be used for the Source.

setXMLReporter(XMLReporter) - Method in class javax.xml.stream.XMLInputFactory

The reporter that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.

setXMLResolver(XMLResolver) - Method in class javax.xml.stream.XMLInputFactory

The resolver that will be set on any XMLStreamReader or XMLEventReader created by this factory instance.

setXmlStandalone(boolean) - Method in interface org.w3c.dom.Document

An attribute specifying, as part of the XML declaration, whether this document is standalone.

setXmlVersion(String) - Method in interface org.w3c.dom.Document

An attribute specifying, as part of the XML declaration, the version number of this document.

setXMLVersion(String) - Method in class org.xml.sax.ext.Locator2Impl

Assigns the current value of the version property.

setXORMode(Color) - Method in class java.awt.Graphics

Sets the paint mode of this graphics context to alternate between this graphics context's current color and the new specified color.

setXORMode(Color) - Method in class javax.swing.DebugGraphics

Overrides Graphics.setXORMode.

setXPathFunctionResolver(XPathFunctionResolver) - Method in interface javax.xml.xpath.XPath

Establish a function resolver.

setXPathFunctionResolver(XPathFunctionResolver) - Method in class javax.xml.xpath.XPathFactory

Establish a default function resolver.

setXPathVariableResolver(XPathVariableResolver) - Method in interface javax.xml.xpath.XPath

Establish a variable resolver.

setXPathVariableResolver(XPathVariableResolver) - Method in class javax.xml.xpath.XPathFactory

Establish a default variable resolver.

setY(Spring) - Method in class javax.swing.SpringLayout.Constraints

Sets the y property, which controls the y value of a component's location.

setYear(int) - Method in class java.sql.Time

Deprecated.

setYear(int) - Method in class java.util.Date

Deprecated.
As of JDK version 1.1, replaced by Calendar.set(Calendar.YEAR, year + 1900).

setYear(BigInteger) - Method in class javax.xml.datatype.XMLGregorianCalendar

Set low and high order component of XSD dateTime year field.

setYear(int) - Method in class javax.xml.datatype.XMLGregorianCalendar

Set year of XSD dateTime year field.

setZeroDigit(char) - Method in class java.text.DecimalFormatSymbols

Sets the character used for zero.

setZoneStrings(String[][]) - Method in class java.text.DateFormatSymbols

Sets time zone strings.

SEVERE - Static variable in class java.util.logging.Level

SEVERE is a message level indicating a serious failure.

severe(String) - Method in class java.util.logging.Logger

Log a SEVERE message.

severe(Supplier<String>) - Method in class java.util.logging.Logger

Log a SEVERE message, which is only to be constructed if the logging level is such that the message will actually be logged.

Severity - Class in javax.print.attribute.standard

Class Severity is a printing attribute class, an enumeration, that denotes the severity of a PrinterStateReason attribute.

Severity(int) - Constructor for class javax.print.attribute.standard.Severity

Construct a new severity enumeration value with the given integer value.

SEVERITY_ERROR - Static variable in interface org.w3c.dom.DOMError

The severity of the error described by the DOMError is error.

SEVERITY_FATAL_ERROR - Static variable in interface org.w3c.dom.DOMError

The severity of the error described by the DOMError is fatal error.

SEVERITY_WARNING - Static variable in interface org.w3c.dom.DOMError

The severity of the error described by the DOMError is warning.

SHA1 - Static variable in class java.security.spec.MGF1ParameterSpec

The MGF1ParameterSpec which uses "SHA-1" message digest.

SHA1 - Static variable in interface javax.xml.crypto.dsig.DigestMethod

The SHA1 digest method algorithm URI.

SHA224 - Static variable in class java.security.spec.MGF1ParameterSpec

The MGF1ParameterSpec which uses "SHA-224" message digest.

SHA256 - Static variable in class java.security.spec.MGF1ParameterSpec

The MGF1ParameterSpec which uses "SHA-256" message digest.

SHA256 - Static variable in interface javax.xml.crypto.dsig.DigestMethod

The SHA256 digest method algorithm URI.

SHA384 - Static variable in class java.security.spec.MGF1ParameterSpec

The MGF1ParameterSpec which uses "SHA-384" message digest.

SHA512 - Static variable in class java.security.spec.MGF1ParameterSpec

The MGF1ParameterSpec which uses SHA-512 message digest.

SHA512 - Static variable in interface javax.xml.crypto.dsig.DigestMethod

The SHA512 digest method algorithm URI.

shadow - Variable in class javax.swing.border.EtchedBorder

shadow - Variable in class javax.swing.plaf.basic.BasicBorders.ButtonBorder

shadow - Variable in class javax.swing.plaf.basic.BasicBorders.FieldBorder

shadow - Variable in class javax.swing.plaf.basic.BasicBorders.SplitPaneBorder

shadow - Variable in class javax.swing.plaf.basic.BasicSeparatorUI

shadow - Variable in class javax.swing.plaf.basic.BasicTabbedPaneUI

shadowInner - Variable in class javax.swing.border.BevelBorder

shadowOuter - Variable in class javax.swing.border.BevelBorder

shallowClone() - Method in class java.awt.image.renderable.ParameterBlock

Creates a shallow copy of a ParameterBlock.

shape(char[], int, int) - Method in class java.awt.font.NumericShaper

Converts the digits in the text that occur between start and start + count.

shape(char[], int, int, int) - Method in class java.awt.font.NumericShaper

Converts the digits in the text that occur between start and start + count, using the provided context.

shape(char[], int, int, NumericShaper.Range) - Method in class java.awt.font.NumericShaper

Converts the digits in the text that occur between start and start + count, using the provided context.

Shape - Interface in java.awt

The Shape interface provides definitions for objects that represent some form of geometric shape.

SHAPE - Static variable in class javax.swing.text.html.HTML.Attribute

ShapeGraphicAttribute - Class in java.awt.font

The ShapeGraphicAttribute class is an implementation of GraphicAttribute that draws shapes in a TextLayout.

ShapeGraphicAttribute(Shape, int, boolean) - Constructor for class java.awt.font.ShapeGraphicAttribute

Constructs a ShapeGraphicAttribute for the specified Shape.

SHAPES - Static variable in class javax.swing.text.html.HTML.Attribute

SHARADA - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "Sharada" Unicode character block.

sharedInstance - Static variable in class javax.swing.JTree.EmptySelectionModel

The single instance of EmptySelectionModel.

sharedInstance() - Static method in class javax.swing.JTree.EmptySelectionModel

Returns the single instance of EmptySelectionModel.

sharedInstance() - Static method in class javax.swing.ToolTipManager

Returns a shared ToolTipManager instance.

SHAVIAN - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "Shavian" Unicode character block.

shear(double, double) - Method in class java.awt.geom.AffineTransform

Concatenates this transform with a shearing transformation.

shear(double, double) - Method in class java.awt.Graphics2D

Concatenates the current Graphics2D Transform with a shearing transform.

SheetCollate - Class in javax.print.attribute.standard

Class SheetCollate is a printing attribute class, an enumeration, that specifies whether or not the media sheets of each copy of each printed document in a job are to be in sequence, when multiple copies of the document are specified by the Copies attribute.

SheetCollate(int) - Constructor for class javax.print.attribute.standard.SheetCollate

Construct a new sheet collate enumeration value with the given integer value.

shift(float, float, int) - Method in class javax.sound.sampled.FloatControl

Changes the control value from the initial value to the final value linearly over the specified time period, specified in microseconds.

SHIFT_DOWN_MASK - Static variable in class java.awt.event.InputEvent

The Shift key extended modifier constant.

SHIFT_MASK - Static variable in class java.awt.event.ActionEvent

The shift modifier.

SHIFT_MASK - Static variable in class java.awt.event.InputEvent

The Shift key modifier constant.

SHIFT_MASK - Static variable in class java.awt.Event

This flag indicates that the Shift key was down when the event occurred.

shiftDown() - Method in class java.awt.Event

NOTE: The Event class is obsolete and is available only for backwards compatibility.

shiftEnd(int) - Method in class javax.swing.text.GapContent

Make the gap bigger, moving any necessary data and updating the appropriate marks

shiftGap(int) - Method in class javax.swing.text.GapContent

Move the start of the gap to a new location, without changing the size of the gap.

shiftGapEndUp(int) - Method in class javax.swing.text.GapContent

Adjust the gap end upward.

shiftGapStartDown(int) - Method in class javax.swing.text.GapContent

Adjust the gap end downward.

shiftLeft(int) - Method in class java.math.BigInteger

Returns a BigInteger whose value is (this << n).

shiftRight(int) - Method in class java.math.BigInteger

Returns a BigInteger whose value is (this >> n).

Short - Class in java.lang

The Short class wraps a value of primitive type short in an object.

Short(short) - Constructor for class java.lang.Short

Constructs a newly allocated Short object that represents the specified short value.

Short(String) - Constructor for class java.lang.Short

Constructs a newly allocated Short object that represents the short value indicated by the String parameter.

SHORT - Static variable in class java.text.DateFormat

Constant for short style pattern.

SHORT - Static variable in class java.util.Calendar

A style specifier for getDisplayName and getDisplayNames equivalent to Calendar.SHORT_FORMAT.

SHORT - Static variable in class java.util.TimeZone

A style specifier for getDisplayName() indicating a short name, such as "PST."

SHORT - Static variable in class javax.management.openmbean.SimpleType

The SimpleType instance describing values whose Java class name is java.lang.Short.

SHORT_DESCRIPTION - Static variable in interface javax.swing.Action

The key used for storing a short String description for the action, used for tooltip text.

SHORT_FORMAT - Static variable in class java.util.Calendar

A style specifier for getDisplayName and getDisplayNames indicating a short name used for format.

SHORT_IDS - Static variable in class java.time.ZoneId

A map of zone overrides to enable the short time-zone names to be used.

SHORT_STANDALONE - Static variable in class java.util.Calendar

A style specifier for getDisplayName and getDisplayNames indicating a short name used independently, such as a month abbreviation as calendar headers.

ShortBuffer - Class in java.nio

A short buffer.

ShortBufferException - Exception in javax.crypto

This exception is thrown when an output buffer provided by the user is too short to hold the operation result.

ShortBufferException() - Constructor for exception javax.crypto.ShortBufferException

Constructs a ShortBufferException with no detail message.

ShortBufferException(String) - Constructor for exception javax.crypto.ShortBufferException

Constructs a ShortBufferException with the specified detail message.

shortcuts() - Method in class java.awt.MenuBar

Gets an enumeration of all menu shortcuts this menu bar is managing.

ShortHolder - Class in org.omg.CORBA

The Holder for Short.

ShortHolder() - Constructor for class org.omg.CORBA.ShortHolder

Constructs a new ShortHolder object with its value field initialized to 0.

ShortHolder(short) - Constructor for class org.omg.CORBA.ShortHolder

Constructs a new ShortHolder object with its value field initialized to the given short.

ShortLookupTable - Class in java.awt.image

This class defines a lookup table object.

ShortLookupTable(int, short[][]) - Constructor for class java.awt.image.ShortLookupTable

Constructs a ShortLookupTable object from an array of short arrays representing a lookup table for each band.

ShortLookupTable(int, short[]) - Constructor for class java.awt.image.ShortLookupTable

Constructs a ShortLookupTable object from an array of shorts representing a lookup table for each band.

ShortMessage - Class in javax.sound.midi

A ShortMessage contains a MIDI message that has at most two data bytes following its status byte.

ShortMessage() - Constructor for class javax.sound.midi.ShortMessage

Constructs a new ShortMessage.

ShortMessage(int) - Constructor for class javax.sound.midi.ShortMessage

Constructs a new ShortMessage which represents a MIDI message that takes no data bytes.

ShortMessage(int, int, int) - Constructor for class javax.sound.midi.ShortMessage

Constructs a new ShortMessage which represents a MIDI message that takes up to two data bytes.

ShortMessage(int, int, int, int) - Constructor for class javax.sound.midi.ShortMessage

Constructs a new ShortMessage which represents a channel MIDI message that takes up to two data bytes.

ShortMessage(byte[]) - Constructor for class javax.sound.midi.ShortMessage

Constructs a new ShortMessage.

ShortSeqHelper - Class in org.omg.CORBA

The Helper for ShortSeqHelper.

ShortSeqHelper() - Constructor for class org.omg.CORBA.ShortSeqHelper

ShortSeqHolder - Class in org.omg.CORBA

The Holder for ShortSeq.

ShortSeqHolder() - Constructor for class org.omg.CORBA.ShortSeqHolder

ShortSeqHolder(short[]) - Constructor for class org.omg.CORBA.ShortSeqHolder

shortValue() - Method in class java.lang.Byte

Returns the value of this Byte as a short after a widening primitive conversion.

shortValue() - Method in class java.lang.Double

Returns the value of this Double as a short after a narrowing primitive conversion.

shortValue() - Method in class java.lang.Float

Returns the value of this Float as a short after a narrowing primitive conversion.

shortValue() - Method in class java.lang.Integer

Returns the value of this Integer as a short after a narrowing primitive conversion.

shortValue() - Method in class java.lang.Long

Returns the value of this Long as a short after a narrowing primitive conversion.

shortValue() - Method in class java.lang.Number

Returns the value of the specified number as a short, which may involve rounding or truncation.

shortValue() - Method in class java.lang.Short

Returns the value of this Short as a short.

shortValueExact() - Method in class java.math.BigDecimal

Converts this BigDecimal to a short, checking for lost information.

shortValueExact() - Method in class java.math.BigInteger

Converts this BigInteger to a short, checking for lost information.

shouldAccept(URI, HttpCookie) - Method in interface java.net.CookiePolicy

Will be called to see whether or not this cookie should be accepted.

shouldFillGap(int, int, int, int) - Method in class javax.swing.plaf.metal.MetalTabbedPaneUI

shouldPadTabRun(int, int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

shouldPadTabRun(int, int) - Method in class javax.swing.plaf.metal.MetalTabbedPaneUI

shouldPaintExpandControl(TreePath, int, boolean, boolean, boolean) - Method in class javax.swing.plaf.basic.BasicTreeUI

Returns true if the expand (toggle) control should be drawn for the specified row.

shouldRotateTabRuns(int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI

shouldRotateTabRuns(int, int) - Method in class javax.swing.plaf.metal.MetalTabbedPaneUI

shouldScroll(int) - Method in class javax.swing.plaf.basic.BasicSliderUI.TrackListener

shouldSelectCell(EventObject) - Method in class javax.swing.AbstractCellEditor

Returns true.

shouldSelectCell(EventObject) - Method in interface javax.swing.CellEditor

Returns true if the editing cell should be selected, false otherwise.

shouldSelectCell(EventObject) - Method in class javax.swing.DefaultCellEditor.EditorDelegate

Returns true to indicate that the editing cell may be selected.

shouldSelectCell(EventObject) - Method in class javax.swing.DefaultCellEditor

Forwards the message from the CellEditor to the delegate.

shouldSelectCell(EventObject) - Method in class javax.swing.tree.DefaultTreeCellEditor

Messages the realEditor for the return value.

shouldStartEditingTimer(EventObject) - Method in class javax.swing.tree.DefaultTreeCellEditor

Returns true if event is a MouseEvent and the click count is 1.

shouldUpdateStyleOnAncestorChanged() - Method in class javax.swing.plaf.nimbus.NimbusLookAndFeel

Returns whether or not the UIs should update their SynthStyles from the SynthStyleFactory when the ancestor of the JComponent changes.

shouldUpdateStyleOnAncestorChanged() - Method in class javax.swing.plaf.synth.SynthLookAndFeel

Returns whether or not the UIs should update their SynthStyles from the SynthStyleFactory when the ancestor of the JComponent changes.

shouldUpdateStyleOnEvent(PropertyChangeEvent) - Method in class javax.swing.plaf.nimbus.NimbusLookAndFeel

Returns whether or not the UIs should update their styles when a particular event occurs.

shouldUpdateStyleOnEvent(PropertyChangeEvent) - Method in class javax.swing.plaf.synth.SynthLookAndFeel

Returns whether or not the UIs should update their styles when a particular event occurs.

shouldYieldFocus(JComponent) - Method in class javax.swing.InputVerifier

Calls verify(input) to ensure that the input is valid.

show(Container, String) - Method in class java.awt.CardLayout

Flips to the component that was added to this layout with the specified name, using addLayoutComponent.

show() - Method in class java.awt.Component.BltBufferStrategy

Makes the next available buffer visible.

show() - Method in class java.awt.Component.FlipBufferStrategy

Makes the next available buffer visible by either blitting or flipping.

show() - Method in class java.awt.Component

Deprecated.
As of JDK version 1.1, replaced by setVisible(boolean).

show(boolean) - Method in class java.awt.Component

Deprecated.
As of JDK version 1.1, replaced by setVisible(boolean).

show() - Method in class java.awt.Dialog

Deprecated.
As of JDK version 1.5, replaced by setVisible(boolean).

show() - Method in class java.awt.image.BufferStrategy

Makes the next available buffer visible by either copying the memory (blitting) or changing the display pointer (flipping).

show(Component, int, int) - Method in class java.awt.PopupMenu

Shows the popup menu at the x, y position relative to an origin component.

show() - Method in class java.awt.Window

Deprecated.
As of JDK version 1.5, replaced by Window.setVisible(boolean).

show() - Method in class javax.swing.JInternalFrame

If the internal frame is not visible, brings the internal frame to the front, makes it visible, and attempts to select it.

show(Component, int, int) - Method in class javax.swing.JPopupMenu

Displays the popup menu at the position x,y in the coordinate space of the component invoker.

show() - Method in class javax.swing.plaf.basic.BasicComboPopup

Implementation of ComboPopup.show().

show() - Method in interface javax.swing.plaf.basic.ComboPopup

Shows the popup

show() - Method in class javax.swing.Popup

Makes the Popup visible.

SHOWA - Static variable in class java.time.chrono.JapaneseEra

The singleton instance for the 'Showa' era (1926-12-25 - 1989-01-07) which has the value 1.

showConfirmDialog(Component, Object) - Static method in class javax.swing.JOptionPane

Brings up a dialog with the options Yes, No and Cancel; with the title, Select an Option.

showConfirmDialog(Component, Object, String, int) - Static method in class javax.swing.JOptionPane

Brings up a dialog where the number of choices is determined by the optionType parameter.

showConfirmDialog(Component, Object, String, int, int) - Static method in class javax.swing.JOptionPane

Brings up a dialog where the number of choices is determined by the optionType parameter, where the messageType parameter determines the icon to display.

showConfirmDialog(Component, Object, String, int, int, Icon) - Static method in class javax.swing.JOptionPane

Brings up a dialog with a specified icon, where the number of choices is determined by the optionType parameter.

showDialog(Component, String, Color) - Static method in class javax.swing.JColorChooser

Shows a modal color-chooser dialog and blocks until the dialog is hidden.

showDialog(Component, String) - Method in class javax.swing.JFileChooser

Pops a custom file chooser dialog with a custom approve button.

showDocument(URL) - Method in interface java.applet.AppletContext

Requests that the browser or applet viewer show the Web page indicated by the url argument.

showDocument(URL, String) - Method in interface java.applet.AppletContext

Requests that the browser or applet viewer show the Web page indicated by the url argument.

showHorizontalLines - Variable in class javax.swing.JTable

The table draws horizontal lines between cells if showHorizontalLines is true.

SHOWING - Static variable in class javax.accessibility.AccessibleState

Indicates this object, the object's parent, the object's parent's parent, and so on, are all visible.

SHOWING_CHANGED - Static variable in class java.awt.event.HierarchyEvent

A change flag indicates that the HIERARCHY_CHANGED event was generated due to the changing of the hierarchy showing state.

showInputDialog(Object) - Static method in class javax.swing.JOptionPane

Shows a question-message dialog requesting input from the user.

showInputDialog(Object, Object) - Static method in class javax.swing.JOptionPane

Shows a question-message dialog requesting input from the user, with the input value initialized to initialSelectionValue.

showInputDialog(Component, Object) - Static method in class javax.swing.JOptionPane

Shows a question-message dialog requesting input from the user parented to parentComponent.

showInputDialog(Component, Object, Object) - Static method in class javax.swing.JOptionPane

Shows a question-message dialog requesting input from the user and parented to parentComponent.

showInputDialog(Component, Object, String, int) - Static method in class javax.swing.JOptionPane

Shows a dialog requesting input from the user parented to parentComponent with the dialog having the title title and message type messageType.

showInputDialog(Component, Object, String, int, Icon, Object[], Object) - Static method in class javax.swing.JOptionPane

Prompts the user for input in a blocking dialog where the initial selection, possible selections, and all other options can be specified.

showInternalConfirmDialog(Component, Object) - Static method in class javax.swing.JOptionPane

Brings up an internal dialog panel with the options Yes, No and Cancel; with the title, Select an Option.

showInternalConfirmDialog(Component, Object, String, int) - Static method in class javax.swing.JOptionPane

Brings up a internal dialog panel where the number of choices is determined by the optionType parameter.

showInternalConfirmDialog(Component, Object, String, int, int) - Static method in class javax.swing.JOptionPane

Brings up an internal dialog panel where the number of choices is determined by the optionType parameter, where the messageType parameter determines the icon to display.

showInternalConfirmDialog(Component, Object, String, int, int, Icon) - Static method in class javax.swing.JOptionPane

Brings up an internal dialog panel with a specified icon, where the number of choices is determined by the optionType parameter.

showInternalInputDialog(Component, Object) - Static method in class javax.swing.JOptionPane

Shows an internal question-message dialog requesting input from the user parented to parentComponent.

showInternalInputDialog(Component, Object, String, int) - Static method in class javax.swing.JOptionPane

Shows an internal dialog requesting input from the user parented to parentComponent with the dialog having the title title and message type messageType.

showInternalInputDialog(Component, Object, String, int, Icon, Object[], Object) - Static method in class javax.swing.JOptionPane

Prompts the user for input in a blocking internal dialog where the initial selection, possible selections, and all other options can be specified.

showInternalMessageDialog(Component, Object) - Static method in class javax.swing.JOptionPane

Brings up an internal confirmation dialog panel.

showInternalMessageDialog(Component, Object, String, int) - Static method in class javax.swing.JOptionPane

Brings up an internal dialog panel that displays a message using a default icon determined by the messageType parameter.

showInternalMessageDialog(Component, Object, String, int, Icon) - Static method in class javax.swing.JOptionPane

Brings up an internal dialog panel displaying a message, specifying all parameters.

showInternalOptionDialog(Component, Object, String, int, int, Icon, Object[], Object) - Static method in class javax.swing.JOptionPane

Brings up an internal dialog panel with a specified icon, where the initial choice is determined by the initialValue parameter and the number of choices is determined by the optionType parameter.

showMessageDialog(Component, Object) - Static method in class javax.swing.JOptionPane

Brings up an information-message dialog titled "Message".

showMessageDialog(Component, Object, String, int) - Static method in class javax.swing.JOptionPane

Brings up a dialog that displays a message using a default icon determined by the messageType parameter.

showMessageDialog(Component, Object, String, int, Icon) - Static method in class javax.swing.JOptionPane

Brings up a dialog displaying a message, specifying all parameters.

showOpenDialog(Component) - Method in class javax.swing.JFileChooser

Pops up an "Open File" file chooser dialog.

showOptionDialog(Component, Object, String, int, int, Icon, Object[], Object) - Static method in class javax.swing.JOptionPane

Brings up a dialog with a specified icon, where the initial choice is determined by the initialValue parameter and the number of choices is determined by the optionType parameter.

showPopup() - Method in class javax.swing.JComboBox

Causes the combo box to display its popup window.

SHOWS_ROOT_HANDLES_PROPERTY - Static variable in class javax.swing.JTree

Bound property name for showsRootHandles.

showSaveDialog(Component) - Method in class javax.swing.JFileChooser

Pops up a "Save File" file chooser dialog.

showsRootHandles - Variable in class javax.swing.JTree

True if handles are displayed at the topmost level of the tree.

showStatus(String) - Method in class java.applet.Applet

Requests that the argument string be displayed in the "status window".

showStatus(String) - Method in interface java.applet.AppletContext

Requests that the argument string be displayed in the "status window".

showSystemMenu() - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane

showSystemMenu() - Method in class javax.swing.plaf.metal.MetalInternalFrameTitlePane

Override the parent's method to do nothing.

showVerticalLines - Variable in class javax.swing.JTable

The table draws vertical lines between cells if showVerticalLines is true.

shrinkAbsorb - Variable in class java.awt.font.GlyphJustificationInfo

If true,this glyph absorbs all remaining shrinkage at this and lower priority levels as it shrinks.

shrinkLeftLimit - Variable in class java.awt.font.GlyphJustificationInfo

The maximum amount by which the left side of this glyph can shrink (a positive number).

shrinkPriority - Variable in class java.awt.font.GlyphJustificationInfo

The priority level of this glyph as it is shrinking.

shrinkRightLimit - Variable in class java.awt.font.GlyphJustificationInfo

The maximum amount by which the right side of this glyph can shrink (a positive number).

shuffle(List<?>) - Static method in class java.util.Collections

Randomly permutes the specified list using a default source of randomness.

shuffle(List<?>, Random) - Static method in class java.util.Collections

Randomly permute the specified list using the specified source of randomness.

shutdown() - Method in class java.nio.channels.AsynchronousChannelGroup

Initiates an orderly shutdown of the group.

shutdown() - Method in interface java.rmi.activation.ActivationSystem

Shutdown the activation system.

shutdown() - Method in interface java.util.concurrent.ExecutorService

Initiates an orderly shutdown in which previously submitted tasks are executed, but no new tasks will be accepted.

shutdown() - Method in class java.util.concurrent.ForkJoinPool

Possibly initiates an orderly shutdown in which previously submitted tasks are executed, but no new tasks will be accepted.

shutdown() - Method in class java.util.concurrent.ScheduledThreadPoolExecutor

Initiates an orderly shutdown in which previously submitted tasks are executed, but no new tasks will be accepted.

shutdown() - Method in class java.util.concurrent.ThreadPoolExecutor

Initiates an orderly shutdown in which previously submitted tasks are executed, but no new tasks will be accepted.

SHUTDOWN - Static variable in class javax.print.attribute.standard.PrinterStateReason

Someone has removed a printer from service, and the device may be powered down or physically removed.

shutdown(boolean) - Method in class org.omg.CORBA.ORB

Instructs the ORB to shut down, which causes all object adapters to shut down, in preparation for destruction.
If the wait_for_completion parameter is true, this operation blocks until all ORB processing (including processing of currently executing requests, object deactivation, and other object adapter operations) has completed.

ShutdownChannelGroupException - Exception in java.nio.channels

Unchecked exception thrown when an attempt is made to construct a channel in a group that is shutdown or the completion handler for an I/O operation cannot be invoked because the channel group has terminated.

ShutdownChannelGroupException() - Constructor for exception java.nio.channels.ShutdownChannelGroupException

Constructs an instance of this class.

shutdownInput() - Method in class java.net.Socket

Places the input stream for this socket at "end of stream".

shutdownInput() - Method in class java.net.SocketImpl

Places the input stream for this socket at "end of stream".

shutdownInput() - Method in class java.nio.channels.AsynchronousSocketChannel

Shutdown the connection for reading without closing the channel.

shutdownInput() - Method in class java.nio.channels.SocketChannel

Shutdown the connection for reading without closing the channel.

shutdownNow() - Method in class java.nio.channels.AsynchronousChannelGroup

Shuts down the group and closes all open channels in the group.

shutdownNow() - Method in interface java.util.concurrent.ExecutorService

Attempts to stop all actively executing tasks, halts the processing of waiting tasks, and returns a list of the tasks that were awaiting execution.

shutdownNow() - Method in class java.util.concurrent.ForkJoinPool

Possibly attempts to cancel and/or stop all tasks, and reject all subsequently submitted tasks.

shutdownNow() - Method in class java.util.concurrent.ScheduledThreadPoolExecutor

Attempts to stop all actively executing tasks, halts the processing of waiting tasks, and returns a list of the tasks that were awaiting execution.

shutdownNow() - Method in class java.util.concurrent.ThreadPoolExecutor

Attempts to stop all actively executing tasks, halts the processing of waiting tasks, and returns a list of the tasks that were awaiting execution.

shutdownOutput() - Method in class java.net.Socket

Disables the output stream for this socket.

shutdownOutput() - Method in class java.net.SocketImpl

Disables the output stream for this socket.

shutdownOutput() - Method in class java.nio.channels.AsynchronousSocketChannel

Shutdown the connection for writing without closing the channel.

shutdownOutput() - Method in class java.nio.channels.SocketChannel

Shutdown the connection for writing without closing the channel.

SIDE - Static variable in class javax.print.attribute.standard.MediaTray

The side input tray.

Sides - Class in javax.print.attribute.standard

Class Sides is a printing attribute class, an enumeration, that specifies how print-stream pages are to be imposed upon the sides of an instance of a selected medium, i.e., an impression.

Sides(int) - Constructor for class javax.print.attribute.standard.Sides

Construct a new sides enumeration value with the given integer value.

SIGN - Static variable in class java.security.Signature

Possible Signature.state value, signifying that this signature object has been initialized for signing.

sign() - Method in class java.security.Signature

Returns the signature bytes of all the data updated.

sign(byte[], int, int) - Method in class java.security.Signature

Finishes the signature operation and stores the resulting signature bytes in the provided buffer outbuf, starting at offset.

SIGN - Static variable in class java.text.NumberFormat.Field

Constant identifying the sign field.

sign(XMLSignContext) - Method in interface javax.xml.crypto.dsig.XMLSignature

Signs this XMLSignature.

SIGN - Static variable in class javax.xml.crypto.KeySelector.Purpose

A key for signing.

signal() - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject

Moves the longest-waiting thread, if one exists, from the wait queue for this condition to the wait queue for the owning lock.

signal() - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject

Moves the longest-waiting thread, if one exists, from the wait queue for this condition to the wait queue for the owning lock.

signal() - Method in interface java.util.concurrent.locks.Condition

Wakes up one waiting thread.

signalAll() - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject

Moves all threads from the wait queue for this condition to the wait queue for the owning lock.

signalAll() - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject

Moves all threads from the wait queue for this condition to the wait queue for the owning lock.

signalAll() - Method in interface java.util.concurrent.locks.Condition

Wakes up all waiting threads.

Signature - Class in java.security

The Signature class is used to provide applications the functionality of a digital signature algorithm.

Signature(String) - Constructor for class java.security.Signature

Creates a Signature object for the specified algorithm.

SIGNATURE_VERSION - Static variable in class java.util.jar.Attributes.Name

Name object for Signature-Version manifest attribute used when signing JAR files.

SignatureException - Exception in java.security

This is the generic Signature exception.

SignatureException() - Constructor for exception java.security.SignatureException

Constructs a SignatureException with no detail message.

SignatureException(String) - Constructor for exception java.security.SignatureException

Constructs a SignatureException with the specified detail message.

SignatureException(String, Throwable) - Constructor for exception java.security.SignatureException

Creates a SignatureException with the specified detail message and cause.

SignatureException(Throwable) - Constructor for exception java.security.SignatureException

Creates a SignatureException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

SignatureMethod - Interface in javax.xml.crypto.dsig

A representation of the XML SignatureMethod element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.

SignatureMethodParameterSpec - Interface in javax.xml.crypto.dsig.spec

A specification of algorithm parameters for an XML SignatureMethod algorithm.

SignatureProperties - Interface in javax.xml.crypto.dsig

A representation of the XML SignatureProperties element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.

SignatureProperty - Interface in javax.xml.crypto.dsig

A representation of the XML SignatureProperty element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.

SignatureSpi - Class in java.security

This class defines the Service Provider Interface (SPI) for the Signature class, which is used to provide the functionality of a digital signature algorithm.

SignatureSpi() - Constructor for class java.security.SignatureSpi

SignedInfo - Interface in javax.xml.crypto.dsig

An representation of the XML SignedInfo element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.

SignedObject - Class in java.security

SignedObject is a class for the purpose of creating authentic runtime objects whose integrity cannot be compromised without being detected.

SignedObject(Serializable, PrivateKey, Signature) - Constructor for class java.security.SignedObject

Constructs a SignedObject from any Serializable object.

Signer - Class in java.security

Deprecated.
This class is no longer used. Its functionality has been replaced by java.security.KeyStore, the java.security.cert package, and java.security.Principal.

Signer() - Constructor for class java.security.Signer

Deprecated.

Creates a signer.

Signer(String) - Constructor for class java.security.Signer

Deprecated.

Creates a signer with the specified identity name.

Signer(String, IdentityScope) - Constructor for class java.security.Signer

Deprecated.

Creates a signer with the specified identity name and scope.

SignStyle - Enum in java.time.format

Enumeration of ways to handle the positive/negative sign.

signum(int) - Static method in class java.lang.Integer

Returns the signum function of the specified int value.

signum(long) - Static method in class java.lang.Long

Returns the signum function of the specified long value.

signum(double) - Static method in class java.lang.Math

Returns the signum function of the argument; zero if the argument is zero, 1.0 if the argument is greater than zero, -1.0 if the argument is less than zero.

signum(float) - Static method in class java.lang.Math

Returns the signum function of the argument; zero if the argument is zero, 1.0f if the argument is greater than zero, -1.0f if the argument is less than zero.

signum(double) - Static method in class java.lang.StrictMath

Returns the signum function of the argument; zero if the argument is zero, 1.0 if the argument is greater than zero, -1.0 if the argument is less than zero.

signum(float) - Static method in class java.lang.StrictMath

Returns the signum function of the argument; zero if the argument is zero, 1.0f if the argument is greater than zero, -1.0f if the argument is less than zero.

signum() - Method in class java.math.BigDecimal

Returns the signum function of this BigDecimal.

signum() - Method in class java.math.BigInteger

Returns the signum function of this BigInteger.

SILENT - Static variable in class java.rmi.server.LogStream

Deprecated.

log level constant (no logging).

SIMPLE_SCROLL_MODE - Static variable in class javax.swing.JViewport

This mode uses the very simple method of redrawing the entire contents of the scrollpane each time it is scrolled.

SimpleAnnotationValueVisitor6<R,P> - Class in javax.lang.model.util

A simple visitor for annotation values with default behavior appropriate for the RELEASE_6 source version.

SimpleAnnotationValueVisitor6() - Constructor for class javax.lang.model.util.SimpleAnnotationValueVisitor6

Constructor for concrete subclasses; uses null for the default value.

SimpleAnnotationValueVisitor6(R) - Constructor for class javax.lang.model.util.SimpleAnnotationValueVisitor6

Constructor for concrete subclasses; uses the argument for the default value.

SimpleAnnotationValueVisitor7<R,P> - Class in javax.lang.model.util

A simple visitor for annotation values with default behavior appropriate for the RELEASE_7 source version.

SimpleAnnotationValueVisitor7() - Constructor for class javax.lang.model.util.SimpleAnnotationValueVisitor7

Constructor for concrete subclasses; uses null for the default value.

SimpleAnnotationValueVisitor7(R) - Constructor for class javax.lang.model.util.SimpleAnnotationValueVisitor7

Constructor for concrete subclasses; uses the argument for the default value.

SimpleAnnotationValueVisitor8<R,P> - Class in javax.lang.model.util

A simple visitor for annotation values with default behavior appropriate for the RELEASE_8 source version.

SimpleAnnotationValueVisitor8() - Constructor for class javax.lang.model.util.SimpleAnnotationValueVisitor8

Constructor for concrete subclasses; uses null for the default value.

SimpleAnnotationValueVisitor8(R) - Constructor for class javax.lang.model.util.SimpleAnnotationValueVisitor8

Constructor for concrete subclasses; uses the argument for the default value.

SimpleAttributeSet - Class in javax.swing.text

A straightforward implementation of MutableAttributeSet using a hash table.

SimpleAttributeSet() - Constructor for class javax.swing.text.SimpleAttributeSet

Creates a new attribute set.

SimpleAttributeSet(AttributeSet) - Constructor for class javax.swing.text.SimpleAttributeSet

Creates a new attribute set based on a supplied set of attributes.

SimpleBeanInfo - Class in java.beans

This is a support class to make it easier for people to provide BeanInfo classes.

SimpleBeanInfo() - Constructor for class java.beans.SimpleBeanInfo

SimpleBindings - Class in javax.script

A simple implementation of Bindings backed by a HashMap or some other specified Map.

SimpleBindings(Map<String, Object>) - Constructor for class javax.script.SimpleBindings

Constructor uses an existing Map to store the values.

SimpleBindings() - Constructor for class javax.script.SimpleBindings

Default constructor uses a HashMap.

SimpleDateFormat - Class in java.text

SimpleDateFormat is a concrete class for formatting and parsing dates in a locale-sensitive manner.

SimpleDateFormat() - Constructor for class java.text.SimpleDateFormat

Constructs a SimpleDateFormat using the default pattern and date format symbols for the default FORMAT locale.

SimpleDateFormat(String) - Constructor for class java.text.SimpleDateFormat

Constructs a SimpleDateFormat using the given pattern and the default date format symbols for the default FORMAT locale.

SimpleDateFormat(String, Locale) - Constructor for class java.text.SimpleDateFormat

Constructs a SimpleDateFormat using the given pattern and the default date format symbols for the given locale.

SimpleDateFormat(String, DateFormatSymbols) - Constructor for class java.text.SimpleDateFormat

Constructs a SimpleDateFormat using the given pattern and date format symbols.

SimpleDoc - Class in javax.print

This class is an implementation of interface Doc that can be used in many common printing requests.

SimpleDoc(Object, DocFlavor, DocAttributeSet) - Constructor for class javax.print.SimpleDoc

Constructs a SimpleDoc with the specified print data, doc flavor and doc attribute set.

SimpleElementVisitor6<R,P> - Class in javax.lang.model.util

A simple visitor of program elements with default behavior appropriate for the RELEASE_6 source version.

SimpleElementVisitor6() - Constructor for class javax.lang.model.util.SimpleElementVisitor6

Constructor for concrete subclasses; uses null for the default value.

SimpleElementVisitor6(R) - Constructor for class javax.lang.model.util.SimpleElementVisitor6

Constructor for concrete subclasses; uses the argument for the default value.

SimpleElementVisitor7<R,P> - Class in javax.lang.model.util

A simple visitor of program elements with default behavior appropriate for the RELEASE_7 source version.

SimpleElementVisitor7() - Constructor for class javax.lang.model.util.SimpleElementVisitor7

Constructor for concrete subclasses; uses null for the default value.

SimpleElementVisitor7(R) - Constructor for class javax.lang.model.util.SimpleElementVisitor7

Constructor for concrete subclasses; uses the argument for the default value.

SimpleElementVisitor8<R,P> - Class in javax.lang.model.util

A simple visitor of program elements with default behavior appropriate for the RELEASE_8 source version.

SimpleElementVisitor8() - Constructor for class javax.lang.model.util.SimpleElementVisitor8

Constructor for concrete subclasses; uses null for the default value.

SimpleElementVisitor8(R) - Constructor for class javax.lang.model.util.SimpleElementVisitor8

Constructor for concrete subclasses; uses the argument for the default value.

SimpleEntry(K, V) - Constructor for class java.util.AbstractMap.SimpleEntry

Creates an entry representing a mapping from the specified key to the specified value.

SimpleEntry(Map.Entry<? extends K, ? extends V>) - Constructor for class java.util.AbstractMap.SimpleEntry

Creates an entry representing the same mapping as the specified entry.

SimpleFileVisitor<T> - Class in java.nio.file

A simple visitor of files with default behavior to visit all files and to re-throw I/O errors.

SimpleFileVisitor() - Constructor for class java.nio.file.SimpleFileVisitor

Initializes a new instance of this class.

SimpleFormatter - Class in java.util.logging

Print a brief summary of the LogRecord in a human readable format.

SimpleFormatter() - Constructor for class java.util.logging.SimpleFormatter

SimpleImmutableEntry(K, V) - Constructor for class java.util.AbstractMap.SimpleImmutableEntry

Creates an entry representing a mapping from the specified key to the specified value.

SimpleImmutableEntry(Map.Entry<? extends K, ? extends V>) - Constructor for class java.util.AbstractMap.SimpleImmutableEntry

Creates an entry representing the same mapping as the specified entry.

SimpleJavaFileObject - Class in javax.tools

Provides simple implementations for most methods in JavaFileObject.

SimpleJavaFileObject(URI, JavaFileObject.Kind) - Constructor for class javax.tools.SimpleJavaFileObject

Construct a SimpleJavaFileObject of the given kind and with the given URI.

SimpleScriptContext - Class in javax.script

Simple implementation of ScriptContext.

SimpleScriptContext() - Constructor for class javax.script.SimpleScriptContext

Create a SimpleScriptContext.

SimpleTimeZone - Class in java.util

SimpleTimeZone is a concrete subclass of TimeZone that represents a time zone for use with a Gregorian calendar.

SimpleTimeZone(int, String) - Constructor for class java.util.SimpleTimeZone

Constructs a SimpleTimeZone with the given base time zone offset from GMT and time zone ID with no daylight saving time schedule.

SimpleTimeZone(int, String, int, int, int, int, int, int, int, int) - Constructor for class java.util.SimpleTimeZone

Constructs a SimpleTimeZone with the given base time zone offset from GMT, time zone ID, and rules for starting and ending the daylight time.

SimpleTimeZone(int, String, int, int, int, int, int, int, int, int, int) - Constructor for class java.util.SimpleTimeZone

Constructs a SimpleTimeZone with the given base time zone offset from GMT, time zone ID, and rules for starting and ending the daylight time.

SimpleTimeZone(int, String, int, int, int, int, int, int, int, int, int, int, int) - Constructor for class java.util.SimpleTimeZone

Constructs a SimpleTimeZone with the given base time zone offset from GMT, time zone ID, and rules for starting and ending the daylight time.

SimpleType<T> - Class in javax.management.openmbean

The SimpleType class is the open type class whose instances describe all open data values which are neither arrays, nor CompositeData values, nor TabularData values.

SimpleTypeVisitor6<R,P> - Class in javax.lang.model.util

A simple visitor of types with default behavior appropriate for the RELEASE_6 source version.

SimpleTypeVisitor6() - Constructor for class javax.lang.model.util.SimpleTypeVisitor6

Constructor for concrete subclasses; uses null for the default value.

SimpleTypeVisitor6(R) - Constructor for class javax.lang.model.util.SimpleTypeVisitor6

Constructor for concrete subclasses; uses the argument for the default value.

SimpleTypeVisitor7<R,P> - Class in javax.lang.model.util

A simple visitor of types with default behavior appropriate for the RELEASE_7 source version.

SimpleTypeVisitor7() - Constructor for class javax.lang.model.util.SimpleTypeVisitor7

Constructor for concrete subclasses; uses null for the default value.

SimpleTypeVisitor7(R) - Constructor for class javax.lang.model.util.SimpleTypeVisitor7

Constructor for concrete subclasses; uses the argument for the default value.

SimpleTypeVisitor8<R,P> - Class in javax.lang.model.util

A simple visitor of types with default behavior appropriate for the RELEASE_7 source version.

SimpleTypeVisitor8() - Constructor for class javax.lang.model.util.SimpleTypeVisitor8

Constructor for concrete subclasses; uses null for the default value.

SimpleTypeVisitor8(R) - Constructor for class javax.lang.model.util.SimpleTypeVisitor8

Constructor for concrete subclasses; uses the argument for the default value.

SIMPLIFIED_CHINESE - Static variable in class java.util.Locale

Useful constant for language.

SIMPLIFIED_HANZI - Static variable in class java.awt.im.InputSubset

Constant for all Han characters used in writing Simplified Chinese, including a subset of the CJK unified ideographs as well as Simplified Chinese Han characters that may be defined as surrogate characters.

sin(double) - Static method in class java.lang.Math

Returns the trigonometric sine of an angle.

sin(double) - Static method in class java.lang.StrictMath

Returns the trigonometric sine of an angle.

SINGLE_DOCUMENT - Static variable in class javax.print.attribute.standard.MultipleDocumentHandling

Single document -- see above for further information.

SINGLE_DOCUMENT_NEW_SHEET - Static variable in class javax.print.attribute.standard.MultipleDocumentHandling

Single document new sheet -- see above for further information.

SINGLE_INTERVAL_SELECTION - Static variable in interface javax.swing.ListSelectionModel

A value for the selectionMode property: select one contiguous range of indices at a time.

SINGLE_LINE - Static variable in class javax.accessibility.AccessibleState

Indicates this (text) object can contain only a single line of text

SINGLE_SELECTION - Static variable in interface javax.swing.ListSelectionModel

A value for the selectionMode property: select one list index at a time.

SINGLE_THREAD_MODEL - Static variable in class org.omg.PortableServer.ThreadPolicyValue

SINGLE_TREE_SELECTION - Static variable in interface javax.swing.tree.TreeSelectionModel

Selection can only contain one path at a time.

SingleClickListener(JList) - Constructor for class javax.swing.plaf.metal.MetalFileChooserUI.SingleClickListener

SINGLEFRAME - Static variable in interface java.awt.image.ImageConsumer

The image contain a single static image.

SINGLEFRAMEDONE - Static variable in interface java.awt.image.ImageConsumer

One frame of the image is complete but there are more frames to be delivered.

SINGLEPASS - Static variable in interface java.awt.image.ImageConsumer

The pixels will be delivered in a single pass.

SinglePixelPackedSampleModel - Class in java.awt.image

This class represents pixel data packed such that the N samples which make up a single pixel are stored in a single data array element, and each data data array element holds samples for only one pixel.

SinglePixelPackedSampleModel(int, int, int, int[]) - Constructor for class java.awt.image.SinglePixelPackedSampleModel

Constructs a SinglePixelPackedSampleModel with bitMasks.length bands.

SinglePixelPackedSampleModel(int, int, int, int, int[]) - Constructor for class java.awt.image.SinglePixelPackedSampleModel

Constructs a SinglePixelPackedSampleModel with bitMasks.length bands and a scanline stride equal to scanlineStride data array elements.

SingleSelectionModel - Interface in javax.swing

A model that supports at most one indexed selection.

singleton(T) - Static method in class java.util.Collections

Returns an immutable set containing only the specified object.

singletonKeySelector(Key) - Static method in class javax.xml.crypto.KeySelector

Returns a KeySelector that always selects the specified key, regardless of the KeyInfo passed to it.

singletonList(T) - Static method in class java.util.Collections

Returns an immutable list containing only the specified object.

singletonMap(K, V) - Static method in class java.util.Collections

Returns an immutable map, mapping only the specified key to the specified value.

sinh(double) - Static method in class java.lang.Math

Returns the hyperbolic sine of a double value.

sinh(double) - Static method in class java.lang.StrictMath

Returns the hyperbolic sine of a double value.

SINHALA - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "Sinhala" Unicode character block.

sink() - Method in class java.nio.channels.Pipe

Returns this pipe's sink channel.

SinkChannel(SelectorProvider) - Constructor for class java.nio.channels.Pipe.SinkChannel

Initializes a new instance of this class.

size() - Method in class java.awt.Component

Deprecated.
As of JDK version 1.1, replaced by getSize().

size - Variable in class java.awt.Font

The point size of this Font, rounded to integer.

SIZE - Static variable in class java.awt.font.TextAttribute

Attribute key for the font size.

size - Variable in class java.awt.image.DataBuffer

Usable size of all banks.

size() - Method in class java.awt.RenderingHints

Returns the number of key-value mappings in this RenderingHints.

size() - Method in class java.beans.beancontext.BeanContextMembershipEvent

Gets the number of children affected by the notification.

size() - Method in class java.beans.beancontext.BeanContextSupport

Gets the number of children currently nested in this BeanContext.

size() - Method in class java.io.ByteArrayOutputStream

Returns the current size of the buffer.

size() - Method in class java.io.CharArrayWriter

Returns the current size of the buffer.

size() - Method in class java.io.DataOutputStream

Returns the current value of the counter written, the number of bytes written to this data output stream so far.

SIZE - Static variable in class java.lang.Byte

The number of bits used to represent a byte value in two's complement binary form.

SIZE - Static variable in class java.lang.Character

The number of bits used to represent a char value in unsigned binary form, constant 16.

SIZE - Static variable in class java.lang.Double

The number of bits used to represent a double value.

SIZE - Static variable in class java.lang.Float

The number of bits used to represent a float value.

SIZE - Static variable in class java.lang.Integer

The number of bits used to represent an int value in two's complement binary form.

SIZE - Static variable in class java.lang.Long

The number of bits used to represent a long value in two's complement binary form.

SIZE - Static variable in class java.lang.Short

The number of bits used to represent a short value in two's complement binary form.

size() - Method in class java.nio.channels.AsynchronousFileChannel

Returns the current size of this channel's file.

size() - Method in class java.nio.channels.FileChannel

Returns the current size of this channel's file.

size() - Method in class java.nio.channels.FileLock

Returns the size of the locked region in bytes.

size() - Method in interface java.nio.channels.SeekableByteChannel

Returns the current size of entity to which this channel is connected.

size() - Method in interface java.nio.file.attribute.BasicFileAttributes

Returns the size of the file (in bytes).

size(String) - Method in interface java.nio.file.attribute.UserDefinedFileAttributeView

Returns the size of the value of a user-defined attribute.

size(Path) - Static method in class java.nio.file.Files

Returns the size of a file (in bytes).

size() - Method in class java.security.IdentityScope

Deprecated.

Returns the number of identities within this identity scope.

size() - Method in class java.security.KeyStore

Retrieves the number of entries in this keystore.

size() - Method in class java.util.AbstractCollection

size() - Method in class java.util.AbstractMap

Returns the number of key-value mappings in this map.

size() - Method in class java.util.ArrayDeque

Returns the number of elements in this deque.

size() - Method in class java.util.ArrayList

Returns the number of elements in this list.

size() - Method in class java.util.BitSet

Returns the number of bits of space actually in use by this BitSet to represent bit values.

size() - Method in interface java.util.Collection

Returns the number of elements in this collection.

size() - Method in class java.util.concurrent.ArrayBlockingQueue

Returns the number of elements in this queue.

size() - Method in interface java.util.concurrent.BlockingDeque

Returns the number of elements in this deque.

size() - Method in class java.util.concurrent.ConcurrentHashMap

Returns the number of key-value mappings in this map.

size() - Method in class java.util.concurrent.ConcurrentLinkedDeque

Returns the number of elements in this deque.

size() - Method in class java.util.concurrent.ConcurrentLinkedQueue

Returns the number of elements in this queue.

size() - Method in class java.util.concurrent.ConcurrentSkipListMap

Returns the number of key-value mappings in this map.

size() - Method in class java.util.concurrent.ConcurrentSkipListSet

Returns the number of elements in this set.

size() - Method in class java.util.concurrent.CopyOnWriteArrayList

Returns the number of elements in this list.

size() - Method in class java.util.concurrent.CopyOnWriteArraySet

Returns the number of elements in this set.

size() - Method in class java.util.concurrent.DelayQueue

size() - Method in class java.util.concurrent.LinkedBlockingDeque

Returns the number of elements in this deque.

size() - Method in class java.util.concurrent.LinkedBlockingQueue

Returns the number of elements in this queue.

size() - Method in class java.util.concurrent.LinkedTransferQueue

Returns the number of elements in this queue.

size() - Method in class java.util.concurrent.PriorityBlockingQueue

size() - Method in class java.util.concurrent.SynchronousQueue

Always returns zero.

size() - Method in interface java.util.Deque

Returns the number of elements in this deque.

size() - Method in class java.util.Dictionary

Returns the number of entries (distinct keys) in this dictionary.

size() - Method in class java.util.EnumMap

Returns the number of key-value mappings in this map.

size() - Method in class java.util.HashMap

Returns the number of key-value mappings in this map.

size() - Method in class java.util.HashSet

Returns the number of elements in this set (its cardinality).

size() - Method in class java.util.Hashtable

Returns the number of keys in this hashtable.

size() - Method in class java.util.IdentityHashMap

Returns the number of key-value mappings in this identity hash map.

size() - Method in class java.util.jar.Attributes

Returns the number of attributes in this Map.

size() - Method in class java.util.LinkedList

Returns the number of elements in this list.

size() - Method in interface java.util.List

Returns the number of elements in this list.

size() - Method in interface java.util.Map

Returns the number of key-value mappings in this map.

size() - Method in class java.util.PriorityQueue

size() - Method in interface java.util.Set

Returns the number of elements in this set (its cardinality).

size() - Method in class java.util.TreeMap

Returns the number of key-value mappings in this map.

size() - Method in class java.util.TreeSet

Returns the number of elements in this set (its cardinality).

size() - Method in class java.util.Vector

Returns the number of components in this vector.

size() - Method in class java.util.WeakHashMap

Returns the number of key-value mappings in this map.

size() - Method in class java.util.zip.ZipFile

Returns the number of entries in the ZIP file.

size() - Method in class javax.accessibility.AccessibleRelationSet

Returns the number of relations in the relation set.

size() - Method in class javax.activation.MimeTypeParameterList

Return the number of name-value pairs in this list.

size() - Method in interface javax.management.openmbean.TabularData

Returns the number of CompositeData values (ie the number of rows) contained in this TabularData instance.

size() - Method in class javax.management.openmbean.TabularDataSupport

Returns the number of rows in this TabularDataSupport instance.

size() - Method in class javax.naming.CompositeName

Retrieves the number of components in this composite name.

size() - Method in class javax.naming.CompoundName

Retrieves the number of components in this compound name.

size() - Method in interface javax.naming.directory.Attribute

Retrieves the number of values in this attribute.

size() - Method in interface javax.naming.directory.Attributes

Retrieves the number of attributes in the attribute set.

size() - Method in class javax.naming.directory.BasicAttribute

size() - Method in class javax.naming.directory.BasicAttributes

size() - Method in class javax.naming.ldap.LdapName

Retrieves the number of components in this LDAP name.

size() - Method in class javax.naming.ldap.Rdn

Retrieves the number of attribute type/value pairs in this Rdn.

size() - Method in interface javax.naming.Name

Returns the number of components in this name.

size() - Method in class javax.naming.Reference

Retrieves the number of addresses in this reference.

size() - Method in interface javax.print.attribute.AttributeSet

Returns the number of attributes in this attribute set.

size() - Method in class javax.print.attribute.HashAttributeSet

Returns the number of attributes in this attribute set.

size() - Method in class javax.script.SimpleBindings

Returns the number of key-value mappings in this map.

size() - Method in class javax.sound.midi.Track

Obtains the number of events in this track.

size() - Method in interface javax.sql.rowset.CachedRowSet

Returns the number of rows in this CachedRowSet object.

size() - Method in class javax.swing.ActionMap

Returns the number of bindings in this ActionMap.

size() - Method in class javax.swing.DefaultListModel

Returns the number of components in this list.

size() - Method in class javax.swing.InputMap

Returns the number of KeyStroke bindings.

SIZE - Static variable in class javax.swing.text.html.HTML.Attribute

Size - Static variable in class javax.swing.text.StyleConstants

Name of the font size.

Size2DSyntax - Class in javax.print.attribute

Class Size2DSyntax is an abstract base class providing the common implementation of all attributes denoting a size in two dimensions.

Size2DSyntax(float, float, int) - Constructor for class javax.print.attribute.Size2DSyntax

Construct a new two-dimensional size attribute from the given floating-point values.

Size2DSyntax(int, int, int) - Constructor for class javax.print.attribute.Size2DSyntax

Construct a new two-dimensional size attribute from the given integer values.

SIZE_CMD - Static variable in class javax.swing.plaf.basic.BasicInternalFrameTitlePane

sizeAction - Variable in class javax.swing.plaf.basic.BasicInternalFrameTitlePane

SizeAction() - Constructor for class javax.swing.plaf.basic.BasicInternalFrameTitlePane.SizeAction

sizeColumnsToFit(boolean) - Method in class javax.swing.JTable

Deprecated.
As of Swing version 1.0.3, replaced by doLayout().

sizeColumnsToFit(int) - Method in class javax.swing.JTable

Obsolete as of Java 2 platform v1.4.

SIZED - Static variable in interface java.util.Spliterator

Characteristic value signifying that the value returned from estimateSize() prior to traversal or splitting represents a finite size that, in the absence of structural source modification, represents an exact count of the number of elements that would be encountered by a complete traversal.

SizeLimitExceededException - Exception in javax.naming

This exception is thrown when a method produces a result that exceeds a size-related limit.

SizeLimitExceededException() - Constructor for exception javax.naming.SizeLimitExceededException

Constructs a new instance of SizeLimitExceededException.

SizeLimitExceededException(String) - Constructor for exception javax.naming.SizeLimitExceededException

Constructs a new instance of SizeLimitExceededException using an explanation.

SizeRequirements - Class in javax.swing

For the convenience of layout managers, calculates information about the size and position of components.

SizeRequirements() - Constructor for class javax.swing.SizeRequirements

Creates a SizeRequirements object with the minimum, preferred, and maximum sizes set to zero and an alignment value of 0.5 (centered).

SizeRequirements(int, int, int, float) - Constructor for class javax.swing.SizeRequirements

Creates a SizeRequirements object with the specified minimum, preferred, and maximum sizes and the specified alignment.

sizes - Variable in class javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager

SizeSequence - Class in javax.swing

A SizeSequence object efficiently maintains an ordered list of sizes and corresponding positions.

SizeSequence() - Constructor for class javax.swing.SizeSequence

Creates a new SizeSequence object that contains no entries.

SizeSequence(int) - Constructor for class javax.swing.SizeSequence

Creates a new SizeSequence object that contains the specified number of entries, all initialized to have size 0.

SizeSequence(int, int) - Constructor for class javax.swing.SizeSequence

Creates a new SizeSequence object that contains the specified number of entries, all initialized to have size value.

SizeSequence(int[]) - Constructor for class javax.swing.SizeSequence

Creates a new SizeSequence object that contains the specified sizes.

sizeWidthToFit() - Method in class javax.swing.table.TableColumn

Resizes the TableColumn to fit the width of its header cell.

Skeleton - Interface in java.rmi.server

Deprecated.
no replacement. Skeletons are no longer required for remote method calls in the Java 2 platform v1.2 and greater.

SkeletonMismatchException - Exception in java.rmi.server

Deprecated.
no replacement. Skeletons are no longer required for remote method calls in the Java 2 platform v1.2 and greater.

SkeletonMismatchException(String) - Constructor for exception java.rmi.server.SkeletonMismatchException

Deprecated.
no replacement

SkeletonNotFoundException - Exception in java.rmi.server

Deprecated.
no replacement. Skeletons are no longer required for remote method calls in the Java 2 platform v1.2 and greater.

SkeletonNotFoundException(String) - Constructor for exception java.rmi.server.SkeletonNotFoundException

Deprecated.

Constructs a SkeletonNotFoundException with the specified detail message.

SkeletonNotFoundException(String, Exception) - Constructor for exception java.rmi.server.SkeletonNotFoundException

Deprecated.

Constructs a SkeletonNotFoundException with the specified detail message and nested exception.

skip(long) - Method in class java.io.BufferedInputStream

See the general contract of the skip method of InputStream.

skip(long) - Method in class java.io.BufferedReader

Skips characters.

skip(long) - Method in class java.io.ByteArrayInputStream

Skips n bytes of input from this input stream.

skip(long) - Method in class java.io.CharArrayReader

Skips characters.

skip(long) - Method in class java.io.FileInputStream

Skips over and discards n bytes of data from the input stream.

skip(long) - Method in class java.io.FilterInputStream

Skips over and discards n bytes of data from the input stream.

skip(long) - Method in class java.io.FilterReader

Skips characters.

skip(long) - Method in class java.io.InputStream

Skips over and discards n bytes of data from this input stream.

skip(long) - Method in class java.io.LineNumberInputStream

Deprecated.

Skips over and discards n bytes of data from this input stream.

skip(long) - Method in class java.io.LineNumberReader

Skip characters.

skip(long) - Method in interface java.io.ObjectInput

Skips n bytes of input.

skip(long) - Method in class java.io.PushbackInputStream

Skips over and discards n bytes of data from this input stream.

skip(long) - Method in class java.io.PushbackReader

Skips characters.

skip(long) - Method in class java.io.Reader

Skips characters.

skip(long) - Method in class java.io.StringBufferInputStream

Deprecated.

Skips n bytes of input from this input stream.

skip(long) - Method in class java.io.StringReader

Skips the specified number of characters in the stream.

skip(Pattern) - Method in class java.util.Scanner

Skips input that matches the specified pattern, ignoring delimiters.

skip(String) - Method in class java.util.Scanner

Skips input that matches a pattern constructed from the specified string.

skip(long) - Method in interface java.util.stream.DoubleStream

Returns a stream consisting of the remaining elements of this stream after discarding the first n elements of the stream.

skip(long) - Method in interface java.util.stream.IntStream

Returns a stream consisting of the remaining elements of this stream after discarding the first n elements of the stream.

skip(long) - Method in interface java.util.stream.LongStream

Returns a stream consisting of the remaining elements of this stream after discarding the first n elements of the stream.

skip(long) - Method in interface java.util.stream.Stream

Returns a stream consisting of the remaining elements of this stream after discarding the first n elements of the stream.

skip(long) - Method in class java.util.zip.CheckedInputStream

Skips specified number of bytes of input.

skip(long) - Method in class java.util.zip.DeflaterInputStream

Skips over and discards data from the input stream.

skip(long) - Method in class java.util.zip.InflaterInputStream

Skips specified number of bytes of uncompressed data.

skip(long) - Method in class java.util.zip.ZipInputStream

Skips specified number of bytes in the current ZIP entry.

skip(long) - Method in class javax.crypto.CipherInputStream

Skips n bytes of input from the bytes that can be read from this input stream without blocking.

skip(long) - Method in class javax.sound.sampled.AudioInputStream

Skips over and discards a specified number of bytes from this audio input stream.

skip(long) - Method in class javax.swing.ProgressMonitorInputStream

Overrides FilterInputStream.skip to update the progress monitor after the skip.

skipBytes(int) - Method in interface java.io.DataInput

Makes an attempt to skip over n bytes of data from the input stream, discarding the skipped bytes.

skipBytes(int) - Method in class java.io.DataInputStream

See the general contract of the skipBytes method of DataInput.

skipBytes(int) - Method in class java.io.ObjectInputStream

Skips bytes.

skipBytes(int) - Method in class java.io.RandomAccessFile

Attempts to skip over n bytes of input discarding the skipped bytes.

skipBytes(int) - Method in interface javax.imageio.stream.ImageInputStream

Moves the stream position forward by a given number of bytes.

skipBytes(long) - Method in interface javax.imageio.stream.ImageInputStream

Moves the stream position forward by a given number of bytes.

skipBytes(int) - Method in class javax.imageio.stream.ImageInputStreamImpl

Advances the current stream position by calling seek(getStreamPosition() + n).

skipBytes(long) - Method in class javax.imageio.stream.ImageInputStreamImpl

Advances the current stream position by calling seek(getStreamPosition() + n).

skippedEntity(String) - Method in interface org.xml.sax.ContentHandler

Receive notification of a skipped entity.

skippedEntity(String) - Method in class org.xml.sax.helpers.DefaultHandler

Receive notification of a skipped entity.

skippedEntity(String) - Method in class org.xml.sax.helpers.XMLFilterImpl

Filter a skipped entity event.

skippedEntity(String) - Method in class org.xml.sax.helpers.XMLReaderAdapter

Adapt a SAX2 skipped entity event.

skipReferral() - Method in exception javax.naming.ReferralException

Discards the referral about to be processed.

slashSlashComments(boolean) - Method in class java.io.StreamTokenizer

Determines whether or not the tokenizer recognizes C++-style comments.

slashStarComments(boolean) - Method in class java.io.StreamTokenizer

Determines whether or not the tokenizer recognizes C-style comments.

sleep(long) - Static method in class java.lang.Thread

Causes the currently executing thread to sleep (temporarily cease execution) for the specified number of milliseconds, subject to the precision and accuracy of system timers and schedulers.

sleep(long, int) - Static method in class java.lang.Thread

Causes the currently executing thread to sleep (temporarily cease execution) for the specified number of milliseconds plus the specified number of nanoseconds, subject to the precision and accuracy of system timers and schedulers.

sleep(long) - Method in enum java.util.concurrent.TimeUnit

Performs a Thread.sleep using this time unit.

slice() - Method in class java.nio.ByteBuffer

Creates a new byte buffer whose content is a shared subsequence of this buffer's content.

slice() - Method in class java.nio.CharBuffer

Creates a new char buffer whose content is a shared subsequence of this buffer's content.

slice() - Method in class java.nio.DoubleBuffer

Creates a new double buffer whose content is a shared subsequence of this buffer's content.

slice() - Method in class java.nio.FloatBuffer

Creates a new float buffer whose content is a shared subsequence of this buffer's content.

slice() - Method in class java.nio.IntBuffer

Creates a new int buffer whose content is a shared subsequence of this buffer's content.

slice() - Method in class java.nio.LongBuffer

Creates a new long buffer whose content is a shared subsequence of this buffer's content.

slice() - Method in class java.nio.ShortBuffer

Creates a new short buffer whose content is a shared subsequence of this buffer's content.

SLIDER - Static variable in class javax.accessibility.AccessibleRole

An object that allows the user to select from a bounded range.

slider - Variable in class javax.swing.plaf.basic.BasicSliderUI

SLIDER - Static variable in class javax.swing.plaf.synth.Region

Slider region.

SLIDER_FILL - Variable in class javax.swing.plaf.metal.MetalSliderUI

SLIDER_THUMB - Static variable in class javax.swing.plaf.synth.Region

Thumb of the Slider.

SLIDER_TRACK - Static variable in class javax.swing.plaf.synth.Region

Track of the Slider.

sliderModel - Variable in class javax.swing.JSlider

The data model that handles the numeric maximum value, minimum value, and current-position value for the slider.

SliderUI - Class in javax.swing.plaf

Pluggable look and feel interface for JSlider.

SliderUI() - Constructor for class javax.swing.plaf.SliderUI

SMALL - Static variable in class javax.swing.text.html.HTML.Tag

SMALL_FORM_VARIANTS - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "Small Form Variants" Unicode character block.

SMALL_ICON - Static variable in interface javax.swing.Action

The key used for storing a small Icon, such as ImageIcon.

SMALL_KEY - Static variable in class javax.swing.plaf.nimbus.NimbusStyle

SMALL_SCALE - Static variable in class javax.swing.plaf.nimbus.NimbusStyle

SmallAttributeSet(Object[]) - Constructor for class javax.swing.text.StyleContext.SmallAttributeSet

SmallAttributeSet(AttributeSet) - Constructor for class javax.swing.text.StyleContext.SmallAttributeSet

SMALLINT - Static variable in class java.sql.Types

The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type SMALLINT.

SMPTE_24 - Static variable in class javax.sound.midi.Sequence

The SMPTE-based timing type with 24 frames per second (resolution is expressed in ticks per frame).

SMPTE_25 - Static variable in class javax.sound.midi.Sequence

The SMPTE-based timing type with 25 frames per second (resolution is expressed in ticks per frame).

SMPTE_30 - Static variable in class javax.sound.midi.Sequence

The SMPTE-based timing type with 30 frames per second (resolution is expressed in ticks per frame).

SMPTE_30DROP - Static variable in class javax.sound.midi.Sequence

The SMPTE-based timing type with 29.97 frames per second (resolution is expressed in ticks per frame).

snapToTicks - Variable in class javax.swing.JSlider

If true, the knob (and the data value it represents) resolve to the closest tick mark next to where the user positioned the knob.

SND - Static variable in class javax.sound.sampled.AudioFileFormat.Type

Specifies a SND file.

SNI_HOST_NAME - Static variable in class javax.net.ssl.StandardConstants

The "host_name" type representing of a DNS hostname (see SNIHostName) in a Server Name Indication (SNI) extension.

SNIHostName - Class in javax.net.ssl

Instances of this class represent a server name of type host_name in a Server Name Indication (SNI) extension.

SNIHostName(String) - Constructor for class javax.net.ssl.SNIHostName

Creates an SNIHostName using the specified hostname.

SNIHostName(byte[]) - Constructor for class javax.net.ssl.SNIHostName

Creates an SNIHostName using the specified encoded value.

SNIMatcher - Class in javax.net.ssl

Instances of this class represent a matcher that performs match operations on an SNIServerName instance.

SNIMatcher(int) - Constructor for class javax.net.ssl.SNIMatcher

Creates an SNIMatcher using the specified server name type.

SNIServerName - Class in javax.net.ssl

Instances of this class represent a server name in a Server Name Indication (SNI) extension.

SNIServerName(int, byte[]) - Constructor for class javax.net.ssl.SNIServerName

Creates an SNIServerName using the specified name type and encoded value.

SO_BINDADDR - Static variable in interface java.net.SocketOptions

Fetch the local address binding of a socket (this option cannot be "set" only "gotten", since sockets are bound at creation time, and so the locally bound address cannot be changed).

SO_BROADCAST - Static variable in interface java.net.SocketOptions

Sets SO_BROADCAST for a socket.

SO_BROADCAST - Static variable in class java.net.StandardSocketOptions

Allow transmission of broadcast datagrams.

SO_KEEPALIVE - Static variable in interface java.net.SocketOptions

When the keepalive option is set for a TCP socket and no data has been exchanged across the socket in either direction for 2 hours (NOTE: the actual value is implementation dependent), TCP automatically sends a keepalive probe to the peer.

SO_KEEPALIVE - Static variable in class java.net.StandardSocketOptions

Keep connection alive.

SO_LINGER - Static variable in interface java.net.SocketOptions

Specify a linger-on-close timeout.

SO_LINGER - Static variable in class java.net.StandardSocketOptions

Linger on close if data is present.

SO_OOBINLINE - Static variable in interface java.net.SocketOptions

When the OOBINLINE option is set, any TCP urgent data received on the socket will be received through the socket input stream.

SO_RCVBUF - Static variable in interface java.net.SocketOptions

Set a hint the size of the underlying buffers used by the platform for incoming network I/O.

SO_RCVBUF - Static variable in class java.net.StandardSocketOptions

The size of the socket receive buffer.

SO_REUSEADDR - Static variable in interface java.net.SocketOptions

Sets SO_REUSEADDR for a socket.

SO_REUSEADDR - Static variable in class java.net.StandardSocketOptions

Re-use address.

SO_SNDBUF - Static variable in interface java.net.SocketOptions

Set a hint the size of the underlying buffers used by the platform for outgoing network I/O.

SO_SNDBUF - Static variable in class java.net.StandardSocketOptions

The size of the socket send buffer.

SO_TIMEOUT - Static variable in interface java.net.SocketOptions

Set a timeout on blocking Socket operations:

SOAP11HTTP_BINDING - Static variable in interface javax.xml.ws.soap.SOAPBinding

A constant representing the identity of the SOAP 1.1 over HTTP binding.

SOAP11HTTP_MTOM_BINDING - Static variable in interface javax.xml.ws.soap.SOAPBinding

A constant representing the identity of the SOAP 1.1 over HTTP binding with MTOM enabled by default.

SOAP12HTTP_BINDING - Static variable in interface javax.xml.ws.soap.SOAPBinding

A constant representing the identity of the SOAP 1.2 over HTTP binding.

SOAP12HTTP_MTOM_BINDING - Static variable in interface javax.xml.ws.soap.SOAPBinding

A constant representing the identity of the SOAP 1.2 over HTTP binding with MTOM enabled by default.

SOAP_1_1_CONTENT_TYPE - Static variable in interface javax.xml.soap.SOAPConstants

The media type of the Content-Type MIME header in SOAP 1.1.

SOAP_1_1_PROTOCOL - Static variable in interface javax.xml.soap.SOAPConstants

Used to create MessageFactory instances that create SOAPMessages whose behavior supports the SOAP 1.1 specification.

SOAP_1_2_CONTENT_TYPE - Static variable in interface javax.xml.soap.SOAPConstants

The media type of the Content-Type MIME header in SOAP 1.2.

SOAP_1_2_PROTOCOL - Static variable in interface javax.xml.soap.SOAPConstants

Used to create MessageFactory instances that create SOAPMessages whose behavior supports the SOAP 1.2 specification

SOAP_DATAENCODINGUNKNOWN_FAULT - Static variable in interface javax.xml.soap.SOAPConstants

SOAP 1.2 DataEncodingUnknown Fault

SOAP_ENV_PREFIX - Static variable in interface javax.xml.soap.SOAPConstants

The default namespace prefix for http://www.w3.org/2003/05/soap-envelope

SOAP_MUSTUNDERSTAND_FAULT - Static variable in interface javax.xml.soap.SOAPConstants

SOAP 1.2 MustUnderstand Fault

SOAP_RECEIVER_FAULT - Static variable in interface javax.xml.soap.SOAPConstants

SOAP 1.2 Receiver Fault

SOAP_SENDER_FAULT - Static variable in interface javax.xml.soap.SOAPConstants

SOAP 1.2 Sender Fault

SOAP_VERSIONMISMATCH_FAULT - Static variable in interface javax.xml.soap.SOAPConstants

SOAP 1.2 VersionMismatch Fault

SOAPACTION_URI_PROPERTY - Static variable in interface javax.xml.ws.BindingProvider

Standard property for SOAPAction.

SOAPACTION_USE_PROPERTY - Static variable in interface javax.xml.ws.BindingProvider

Standard property for SOAPAction.

SOAPBinding - Annotation Type in javax.jws.soap

SOAPBinding - Interface in javax.xml.ws.soap

The SOAPBinding interface is an abstraction for the SOAP binding.

SOAPBinding.ParameterStyle - Enum in javax.jws.soap

SOAPBinding.Style - Enum in javax.jws.soap

SOAPBinding.Use - Enum in javax.jws.soap

SOAPBody - Interface in javax.xml.soap

An object that represents the contents of the SOAP body element in a SOAP message.

SOAPBodyElement - Interface in javax.xml.soap

A SOAPBodyElement object represents the contents in a SOAPBody object.

SOAPConnection - Class in javax.xml.soap

A point-to-point connection that a client can use for sending messages directly to a remote party (represented by a URL, for instance).

SOAPConnection() - Constructor for class javax.xml.soap.SOAPConnection

SOAPConnectionFactory - Class in javax.xml.soap

A factory for creating SOAPConnection objects.

SOAPConnectionFactory() - Constructor for class javax.xml.soap.SOAPConnectionFactory

SOAPConstants - Interface in javax.xml.soap

The definition of constants pertaining to the SOAP protocol.

SOAPElement - Interface in javax.xml.soap

An object representing an element of a SOAP message that is allowed but not specifically prescribed by a SOAP specification.

SOAPElementFactory - Class in javax.xml.soap

Deprecated.
- Use javax.xml.soap.SOAPFactory for creating SOAPElements.

SOAPEnvelope - Interface in javax.xml.soap

The container for the SOAPHeader and SOAPBody portions of a SOAPPart object.

SOAPException - Exception in javax.xml.soap

An exception that signals that a SOAP exception has occurred.

SOAPException() - Constructor for exception javax.xml.soap.SOAPException

Constructs a SOAPException object with no reason or embedded Throwable object.

SOAPException(String) - Constructor for exception javax.xml.soap.SOAPException

Constructs a SOAPException object with the given String as the reason for the exception being thrown.

SOAPException(String, Throwable) - Constructor for exception javax.xml.soap.SOAPException

Constructs a SOAPException object with the given String as the reason for the exception being thrown and the given Throwable object as an embedded exception.

SOAPException(Throwable) - Constructor for exception javax.xml.soap.SOAPException

Constructs a SOAPException object initialized with the given Throwable object.

SOAPFactory - Class in javax.xml.soap

SOAPFactory is a factory for creating various objects that exist in the SOAP XML tree.

SOAPFactory() - Constructor for class javax.xml.soap.SOAPFactory

SOAPFault - Interface in javax.xml.soap

An element in the SOAPBody object that contains error and/or status information.

SOAPFaultElement - Interface in javax.xml.soap

A representation of the contents in a SOAPFault object.

SOAPFaultException - Exception in javax.xml.ws.soap

The SOAPFaultException exception represents a SOAP 1.1 or 1.2 fault.

SOAPFaultException(SOAPFault) - Constructor for exception javax.xml.ws.soap.SOAPFaultException

Constructor for SOAPFaultException

SOAPHandler<T extends SOAPMessageContext> - Interface in javax.xml.ws.handler.soap

The SOAPHandler class extends Handler to provide typesafety for the message context parameter and add a method to obtain access to the headers that may be processed by the handler.

SOAPHeader - Interface in javax.xml.soap

A representation of the SOAP header element.

SOAPHeaderElement - Interface in javax.xml.soap

An object representing the contents in the SOAP header part of the SOAP envelope.

SOAPMessage - Class in javax.xml.soap

The root class for all SOAP messages.

SOAPMessage() - Constructor for class javax.xml.soap.SOAPMessage

SOAPMessageContext - Interface in javax.xml.ws.handler.soap

The interface SOAPMessageContext provides access to the SOAP message for either RPC request or response.

SOAPMessageHandler - Annotation Type in javax.jws.soap

Deprecated.

SOAPMessageHandlers - Annotation Type in javax.jws.soap

Deprecated.

SOAPPart - Class in javax.xml.soap

The container for the SOAP-specific portion of a SOAPMessage object.

SOAPPart() - Constructor for class javax.xml.soap.SOAPPart

Socket - Class in java.net

This class implements client sockets (also called just "sockets").

Socket() - Constructor for class java.net.Socket

Creates an unconnected socket, with the system-default type of SocketImpl.

Socket(Proxy) - Constructor for class java.net.Socket

Creates an unconnected socket, specifying the type of proxy, if any, that should be used regardless of any other settings.

Socket(SocketImpl) - Constructor for class java.net.Socket

Creates an unconnected Socket with a user-specified SocketImpl.

Socket(String, int) - Constructor for class java.net.Socket

Creates a stream socket and connects it to the specified port number on the named host.

Socket(InetAddress, int) - Constructor for class java.net.Socket

Creates a stream socket and connects it to the specified port number at the specified IP address.

Socket(String, int, InetAddress, int) - Constructor for class java.net.Socket

Creates a socket and connects it to the specified remote host on the specified remote port.

Socket(InetAddress, int, InetAddress, int) - Constructor for class java.net.Socket

Creates a socket and connects it to the specified remote address on the specified remote port.

Socket(String, int, boolean) - Constructor for class java.net.Socket

Deprecated.
Use DatagramSocket instead for UDP transport.

Socket(InetAddress, int, boolean) - Constructor for class java.net.Socket

Deprecated.
Use DatagramSocket instead for UDP transport.

socket() - Method in class java.nio.channels.DatagramChannel

Retrieves a datagram socket associated with this channel.

socket() - Method in class java.nio.channels.ServerSocketChannel

Retrieves a server socket associated with this channel.

socket() - Method in class java.nio.channels.SocketChannel

Retrieves a socket associated with this channel.

SocketAddress - Class in java.net

This class represents a Socket Address with no protocol attachment.

SocketAddress() - Constructor for class java.net.SocketAddress

SocketChannel - Class in java.nio.channels

A selectable channel for stream-oriented connecting sockets.

SocketChannel(SelectorProvider) - Constructor for class java.nio.channels.SocketChannel

Initializes a new instance of this class.

SocketException - Exception in java.net

Thrown to indicate that there is an error creating or accessing a Socket.

SocketException(String) - Constructor for exception java.net.SocketException

Constructs a new SocketException with the specified detail message.

SocketException() - Constructor for exception java.net.SocketException

Constructs a new SocketException with no detail message.

SocketFactory - Class in javax.net

This class creates sockets.

SocketFactory() - Constructor for class javax.net.SocketFactory

Creates a SocketFactory.

SocketHandler - Class in java.util.logging

Simple network logging Handler.

SocketHandler() - Constructor for class java.util.logging.SocketHandler

Create a SocketHandler, using only LogManager properties (or their defaults).

SocketHandler(String, int) - Constructor for class java.util.logging.SocketHandler

Construct a SocketHandler using a specified host and port.

SocketImpl - Class in java.net

The abstract class SocketImpl is a common superclass of all classes that actually implement sockets.

SocketImpl() - Constructor for class java.net.SocketImpl

SocketImplFactory - Interface in java.net

This interface defines a factory for socket implementations.

SocketOption<T> - Interface in java.net

A socket option associated with a socket.

SocketOptions - Interface in java.net

Interface of methods to get/set socket options.

SocketPermission - Class in java.net

This class represents access to a network via sockets.

SocketPermission(String, String) - Constructor for class java.net.SocketPermission

Creates a new SocketPermission object with the specified actions.

SocketSecurityException - Exception in java.rmi.server

Deprecated.
This class is obsolete. Use ExportException instead.

SocketSecurityException(String) - Constructor for exception java.rmi.server.SocketSecurityException

Deprecated.

Constructs an SocketSecurityException with the specified detail message.

SocketSecurityException(String, Exception) - Constructor for exception java.rmi.server.SocketSecurityException

Deprecated.

Constructs an SocketSecurityException with the specified detail message and nested exception.

SocketTimeoutException - Exception in java.net

Signals that a timeout has occurred on a socket read or accept.

SocketTimeoutException(String) - Constructor for exception java.net.SocketTimeoutException

Constructs a new SocketTimeoutException with a detail message.

SocketTimeoutException() - Constructor for exception java.net.SocketTimeoutException

Construct a new SocketTimeoutException with no detailed message.

SoftBevelBorder - Class in javax.swing.border

A class which implements a raised or lowered bevel with softened corners.

SoftBevelBorder(int) - Constructor for class javax.swing.border.SoftBevelBorder

Creates a bevel border with the specified type and whose colors will be derived from the background color of the component passed into the paintBorder method.

SoftBevelBorder(int, Color, Color) - Constructor for class javax.swing.border.SoftBevelBorder

Creates a bevel border with the specified type, highlight and shadow colors.

SoftBevelBorder(int, Color, Color, Color, Color) - Constructor for class javax.swing.border.SoftBevelBorder

Creates a bevel border with the specified type, highlight shadow colors.

SoftReference<T> - Class in java.lang.ref

Soft reference objects, which are cleared at the discretion of the garbage collector in response to memory demand.

SoftReference(T) - Constructor for class java.lang.ref.SoftReference

Creates a new soft reference that refers to the given object.

SoftReference(T, ReferenceQueue<? super T>) - Constructor for class java.lang.ref.SoftReference

Creates a new soft reference that refers to the given object and is registered with the given queue.

solveCubic(double[]) - Static method in class java.awt.geom.CubicCurve2D

Solves the cubic whose coefficients are in the eqn array and places the non-complex roots back into the same array, returning the number of roots.

solveCubic(double[], double[]) - Static method in class java.awt.geom.CubicCurve2D

Solve the cubic whose coefficients are in the eqn array and place the non-complex roots into the res array, returning the number of roots.

solveQuadratic(double[]) - Static method in class java.awt.geom.QuadCurve2D

Solves the quadratic whose coefficients are in the eqn array and places the non-complex roots back into the same array, returning the number of roots.

solveQuadratic(double[], double[]) - Static method in class java.awt.geom.QuadCurve2D

Solves the quadratic whose coefficients are in the eqn array and places the non-complex roots into the res array, returning the number of roots.

SOMEBITS - Static variable in interface java.awt.image.ImageObserver

This flag in the infoflags argument to imageUpdate indicates that more pixels needed for drawing a scaled variation of the image are available.

SONG_POSITION_POINTER - Static variable in class javax.sound.midi.ShortMessage

Status byte for Song Position Pointer message (0xF2, or 242).

SONG_SELECT - Static variable in class javax.sound.midi.ShortMessage

Status byte for MIDI Song Select message (0xF3, or 243).

SORA_SOMPENG - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "Sora Sompeng" Unicode character block.

sort(Comparator<? super E>) - Method in class java.util.ArrayList

sort(int[]) - Static method in class java.util.Arrays

Sorts the specified array into ascending numerical order.

sort(int[], int, int) - Static method in class java.util.Arrays

Sorts the specified range of the array into ascending order.

sort(long[]) - Static method in class java.util.Arrays

Sorts the specified array into ascending numerical order.

sort(long[], int, int) - Static method in class java.util.Arrays

Sorts the specified range of the array into ascending order.

sort(short[]) - Static method in class java.util.Arrays

Sorts the specified array into ascending numerical order.

sort(short[], int, int) - Static method in class java.util.Arrays

Sorts the specified range of the array into ascending order.

sort(char[]) - Static method in class java.util.Arrays

Sorts the specified array into ascending numerical order.

sort(char[], int, int) - Static method in class java.util.Arrays

Sorts the specified range of the array into ascending order.

sort(byte[]) - Static method in class java.util.Arrays

Sorts the specified array into ascending numerical order.

sort(byte[], int, int) - Static method in class java.util.Arrays

Sorts the specified range of the array into ascending order.

sort(float[]) - Static method in class java.util.Arrays

Sorts the specified array into ascending numerical order.

sort(float[], int, int) - Static method in class java.util.Arrays

Sorts the specified range of the array into ascending order.

sort(double[]) - Static method in class java.util.Arrays

Sorts the specified array into ascending numerical order.

sort(double[], int, int) - Static method in class java.util.Arrays

Sorts the specified range of the array into ascending order.

sort(Object[]) - Static method in class java.util.Arrays

Sorts the specified array of objects into ascending order, according to the natural ordering of its elements.

sort(Object[], int, int) - Static method in class java.util.Arrays

Sorts the specified range of the specified array of objects into ascending order, according to the natural ordering of its elements.

sort(T[], Comparator<? super T>) - Static method in class java.util.Arrays

Sorts the specified array of objects according to the order induced by the specified comparator.

sort(T[], int, int, Comparator<? super T>) - Static method in class java.util.Arrays

Sorts the specified range of the specified array of objects according to the order induced by the specified comparator.

sort(List<T>) - Static method in class java.util.Collections

Sorts the specified list into ascending order, according to the natural ordering of its elements.

sort(List<T>, Comparator<? super T>) - Static method in class java.util.Collections

Sorts the specified list according to the order induced by the specified comparator.

sort(Comparator<? super E>) - Method in class java.util.concurrent.CopyOnWriteArrayList

sort(Comparator<? super E>) - Method in interface java.util.List

Sorts this list using the supplied Comparator to compare elements.

sort(Comparator<? super E>) - Method in class java.util.Vector

sort() - Method in class javax.swing.DefaultRowSorter

Sorts and filters the rows in the view based on the sort keys of the columns currently being sorted and the filter, if any, associated with this sorter.

sort(Vector<? extends File>) - Method in class javax.swing.plaf.basic.BasicDirectoryModel

SortControl - Class in javax.naming.ldap

Requests that the results of a search operation be sorted by the LDAP server before being returned.

SortControl(String, boolean) - Constructor for class javax.naming.ldap.SortControl

Constructs a control to sort on a single attribute in ascending order.

SortControl(String[], boolean) - Constructor for class javax.naming.ldap.SortControl

Constructs a control to sort on a list of attributes in ascending order.

SortControl(SortKey[], boolean) - Constructor for class javax.naming.ldap.SortControl

Constructs a control to sort on a list of sort keys.

SORTED - Static variable in interface java.util.Spliterator

Characteristic value signifying that encounter order follows a defined sort order.

sorted() - Method in interface java.util.stream.DoubleStream

Returns a stream consisting of the elements of this stream in sorted order.

sorted() - Method in interface java.util.stream.IntStream

Returns a stream consisting of the elements of this stream in sorted order.

sorted() - Method in interface java.util.stream.LongStream

Returns a stream consisting of the elements of this stream in sorted order.

sorted() - Method in interface java.util.stream.Stream

Returns a stream consisting of the elements of this stream, sorted according to natural order.

sorted(Comparator<? super T>) - Method in interface java.util.stream.Stream

Returns a stream consisting of the elements of this stream, sorted according to the provided Comparator.

SortedMap<K,V> - Interface in java.util

A Map that further provides a total ordering on its keys.

SortedSet<E> - Interface in java.util

A Set that further provides a total ordering on its elements.

sorterChanged(RowSorterEvent) - Method in interface javax.swing.event.RowSorterListener

Notification that the RowSorter has changed.

sorterChanged(RowSorterEvent) - Method in class javax.swing.JTable

RowSorterListener notification that the RowSorter has changed in some way.

SortingFocusTraversalPolicy - Class in javax.swing

A FocusTraversalPolicy that determines traversal order by sorting the Components of a focus traversal cycle based on a given Comparator.

SortingFocusTraversalPolicy() - Constructor for class javax.swing.SortingFocusTraversalPolicy

Constructs a SortingFocusTraversalPolicy without a Comparator.

SortingFocusTraversalPolicy(Comparator<? super Component>) - Constructor for class javax.swing.SortingFocusTraversalPolicy

Constructs a SortingFocusTraversalPolicy with the specified Comparator.

SortKey - Class in javax.naming.ldap

A sort key and its associated sort parameters.

SortKey(String) - Constructor for class javax.naming.ldap.SortKey

Creates the default sort key for an attribute.

SortKey(String, boolean, String) - Constructor for class javax.naming.ldap.SortKey

Creates a sort key for an attribute.

SortKey(int, SortOrder) - Constructor for class javax.swing.RowSorter.SortKey

Creates a SortKey for the specified column with the specified sort order.

SortOrder - Enum in javax.swing

SortOrder is an enumeration of the possible sort orderings.

SortResponseControl - Class in javax.naming.ldap

Indicates whether the requested sort of search results was successful or not.

SortResponseControl(String, boolean, byte[]) - Constructor for class javax.naming.ldap.SortResponseControl

Constructs a control to indicate the outcome of a sort request.

Soundbank - Interface in javax.sound.midi

A Soundbank contains a set of Instruments that can be loaded into a Synthesizer.

SoundbankReader - Class in javax.sound.midi.spi

A SoundbankReader supplies soundbank file-reading services.

SoundbankReader() - Constructor for class javax.sound.midi.spi.SoundbankReader

SoundbankResource - Class in javax.sound.midi

A SoundbankResource represents any audio resource stored in a Soundbank.

SoundbankResource(Soundbank, String, Class<?>) - Constructor for class javax.sound.midi.SoundbankResource

Constructs a new SoundbankResource from the given sound bank and wavetable index.

source() - Method in class java.nio.channels.Pipe

Returns this pipe's source channel.

source - Variable in class java.util.EventObject

The object on which the Event initially occurred.

source - Variable in class javax.management.Notification

This field hides the EventObject.source field in the parent class to make it non-transient and therefore part of the serialized form.

source - Variable in class javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler

Source that events are coming from.

Source - Interface in javax.xml.transform

An object that implements this interface contains the information needed to act as source input (XML source or transformation instructions).

sourceActions - Variable in class java.awt.dnd.DragGestureRecognizer

An int representing the type(s) of action(s) used in this Drag and Drop operation.

sourceAddress() - Method in class java.nio.channels.MembershipKey

Returns the source address if this membership key is source-specific, or null if this membership is not source-specific.

sourceBands - Variable in class javax.imageio.IIOParam

An array of ints indicating which source bands will be used, or null.

SourceChannel(SelectorProvider) - Constructor for class java.nio.channels.Pipe.SourceChannel

Constructs a new instance of this class.

SourceDataLine - Interface in javax.sound.sampled

A source data line is a data line to which data may be written.

SourceLocator - Interface in javax.xml.transform

This interface is primarily for the purposes of reporting where an error occurred in the XML source or transformation instructions.

sourceRegion - Variable in class javax.imageio.IIOParam

The source region, on null if none is set.

sourceRenderSize - Variable in class javax.imageio.ImageReadParam

The desired rendering width and height of the source, if canSetSourceRenderSize is true, or null.

sources - Variable in class java.awt.image.renderable.ParameterBlock

A Vector of sources, stored as arbitrary Objects.

sourceToInputSource(Source) - Static method in class javax.xml.transform.sax.SAXSource

Attempt to obtain a SAX InputSource object from a Source object.

SourceVersion - Enum in javax.lang.model

Source versions of the Java™ programming language.

sourceXSubsampling - Variable in class javax.imageio.IIOParam

The decimation subsampling to be applied in the horizontal direction.

sourceYSubsampling - Variable in class javax.imageio.IIOParam

The decimation subsampling to be applied in the vertical direction.

SOUTH - Static variable in class java.awt.BorderLayout

The south layout constraint (bottom of container).

SOUTH - Static variable in class java.awt.GridBagConstraints

Put the component at the bottom of its display area, centered horizontally.

SOUTH - Static variable in class javax.swing.SpringLayout

Specifies the bottom edge of a component's bounding rectangle.

SOUTH - Static variable in interface javax.swing.SwingConstants

Compass-direction south (down).

SOUTH_EAST - Static variable in interface javax.swing.SwingConstants

Compass-direction south-east (lower right).

SOUTH_WEST - Static variable in interface javax.swing.SwingConstants

Compass-direction south-west (lower left).

SOUTHEAST - Static variable in class java.awt.GridBagConstraints

Put the component at the bottom-right corner of its display area.

southPane - Variable in class javax.swing.plaf.basic.BasicInternalFrameUI

SOUTHWEST - Static variable in class java.awt.GridBagConstraints

Put the component at the bottom-left corner of its display area.

SPACE - Static variable in interface javax.xml.stream.XMLStreamConstants

The characters are white space (see [XML], 2.10 "White Space Handling").

SPACE_SEPARATOR - Static variable in class java.lang.Character

General category "Zs" in the Unicode specification.

SpaceAbove - Static variable in class javax.swing.text.StyleConstants

The amount of space above the paragraph.

SpaceBelow - Static variable in class javax.swing.text.StyleConstants

The amount of space below the paragraph.

SPACING_MODIFIER_LETTERS - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "Spacing Modifier Letters" Unicode character block.

SPAN - Static variable in class javax.swing.text.html.HTML.Tag

SPEAKER - Static variable in class javax.sound.sampled.Port.Info

A type of port that sends audio to a built-in speaker or a speaker jack.

SPECIAL_SYSTEM_EXCLUSIVE - Static variable in class javax.sound.midi.SysexMessage

Status byte for Special System Exclusive message (0xF7, or 247), which is used in MIDI files.

SpecialAction() - Constructor for class javax.swing.text.html.HTMLDocument.HTMLReader.SpecialAction

SPECIALS - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "Specials" Unicode character block.

SPECIFICATION_TITLE - Static variable in class java.util.jar.Attributes.Name

Name object for Specification-Title manifest attribute used for package versioning.

SPECIFICATION_VENDOR - Static variable in class java.util.jar.Attributes.Name

Name object for Specification-Vendor manifest attribute used for package versioning.

SPECIFICATION_VERSION - Static variable in class java.util.jar.Attributes.Name

Name object for Specification-Version manifest attribute used for package versioning.

SPIN_BOX - Static variable in class javax.accessibility.AccessibleRole

A SPIN_BOX is a simple spinner component and its main use is for simple numbers.

spinner - Variable in class javax.swing.plaf.basic.BasicSpinnerUI

The spinner that we're a UI delegate for.

SPINNER - Static variable in class javax.swing.plaf.synth.Region

Spinner region.

SpinnerDateModel - Class in javax.swing

A SpinnerModel for sequences of Dates.

SpinnerDateModel(Date, Comparable, Comparable, int) - Constructor for class javax.swing.SpinnerDateModel

Creates a SpinnerDateModel that represents a sequence of dates between start and end.

SpinnerDateModel() - Constructor for class javax.swing.SpinnerDateModel

Constructs a SpinnerDateModel whose initial value is the current date, calendarField is equal to Calendar.DAY_OF_MONTH, and for which there are no start/end limits.

SpinnerListModel - Class in javax.swing

A simple implementation of SpinnerModel whose values are defined by an array or a List.

SpinnerListModel(List<?>) - Constructor for class javax.swing.SpinnerListModel

Constructs a SpinnerModel whose sequence of values is defined by the specified List.

SpinnerListModel(Object[]) - Constructor for class javax.swing.SpinnerListModel

Constructs a SpinnerModel whose sequence of values is defined by the specified array.

SpinnerListModel() - Constructor for class javax.swing.SpinnerListModel

Constructs an effectively empty SpinnerListModel.

SpinnerModel - Interface in javax.swing

A model for a potentially unbounded sequence of object values.

SpinnerNumberModel - Class in javax.swing

A SpinnerModel for sequences of numbers.

SpinnerNumberModel(Number, Comparable, Comparable, Number) - Constructor for class javax.swing.SpinnerNumberModel

Constructs a SpinnerModel that represents a closed sequence of numbers from minimum to maximum.

SpinnerNumberModel(int, int, int, int) - Constructor for class javax.swing.SpinnerNumberModel

Constructs a SpinnerNumberModel with the specified value, minimum/maximum bounds, and stepSize.

SpinnerNumberModel(double, double, double, double) - Constructor for class javax.swing.SpinnerNumberModel

Constructs a SpinnerNumberModel with the specified value, minimum/maximum bounds, and stepSize.

SpinnerNumberModel() - Constructor for class javax.swing.SpinnerNumberModel

Constructs a SpinnerNumberModel with no minimum or maximum value, stepSize equal to one, and an initial value of zero.

SpinnerUI - Class in javax.swing.plaf

Pluggable look and feel interface for JSpinner

SpinnerUI() - Constructor for class javax.swing.plaf.SpinnerUI

SplashScreen - Class in java.awt

The splash screen can be displayed at application startup, before the Java Virtual Machine (JVM) starts.

split(String, int) - Method in class java.lang.String

Splits this string around matches of the given regular expression.

split(String) - Method in class java.lang.String

Splits this string around matches of the given regular expression.

split(CharSequence, int) - Method in class java.util.regex.Pattern

Splits the given input sequence around matches of this pattern.

split(CharSequence) - Method in class java.util.regex.Pattern

Splits the given input sequence around matches of this pattern.

split() - Method in class java.util.SplittableRandom

Constructs and returns a new SplittableRandom instance that shares no mutable state with this instance.

SPLIT_PANE - Static variable in class javax.accessibility.AccessibleRole

A specialized panel that presents two other panels at the same time.

SPLIT_PANE - Static variable in class javax.swing.plaf.synth.Region

SplitPane region.

SPLIT_PANE_DIVIDER - Static variable in class javax.swing.plaf.synth.Region

Divider of the SplitPane.

splitAsStream(CharSequence) - Method in class java.util.regex.Pattern

Creates a stream from the given input sequence around matches of this pattern.

spliterator() - Method in interface java.lang.Iterable

Creates a Spliterator over the elements described by this Iterable.

spliterator() - Method in class java.util.ArrayDeque

Creates a late-binding and fail-fast Spliterator over the elements in this deque.

spliterator() - Method in class java.util.ArrayList

Creates a late-binding and fail-fast Spliterator over the elements in this list.

spliterator(T[]) - Static method in class java.util.Arrays

Returns a Spliterator covering all of the specified array.

spliterator(T[], int, int) - Static method in class java.util.Arrays

Returns a Spliterator covering the specified range of the specified array.

spliterator(int[]) - Static method in class java.util.Arrays

Returns a Spliterator.OfInt covering all of the specified array.

spliterator(int[], int, int) - Static method in class java.util.Arrays

Returns a Spliterator.OfInt covering the specified range of the specified array.

spliterator(long[]) - Static method in class java.util.Arrays

Returns a Spliterator.OfLong covering all of the specified array.

spliterator(long[], int, int) - Static method in class java.util.Arrays

Returns a Spliterator.OfLong covering the specified range of the specified array.

spliterator(double[]) - Static method in class java.util.Arrays

Returns a Spliterator.OfDouble covering all of the specified array.

spliterator(double[], int, int) - Static method in class java.util.Arrays

Returns a Spliterator.OfDouble covering the specified range of the specified array.

spliterator() - Method in interface java.util.Collection

Creates a Spliterator over the elements in this collection.

spliterator() - Method in class java.util.concurrent.ArrayBlockingQueue

Returns a Spliterator over the elements in this queue.

spliterator() - Method in class java.util.concurrent.ConcurrentHashMap.KeySetView

spliterator() - Method in class java.util.concurrent.ConcurrentLinkedDeque

Returns a Spliterator over the elements in this deque.

spliterator() - Method in class java.util.concurrent.ConcurrentLinkedQueue

Returns a Spliterator over the elements in this queue.

spliterator() - Method in class java.util.concurrent.ConcurrentSkipListSet

Returns a Spliterator over the elements in this set.

spliterator() - Method in class java.util.concurrent.CopyOnWriteArrayList

Returns a Spliterator over the elements in this list.

spliterator() - Method in class java.util.concurrent.CopyOnWriteArraySet

Returns a Spliterator over the elements in this set in the order in which these elements were added.

spliterator() - Method in class java.util.concurrent.LinkedBlockingDeque

Returns a Spliterator over the elements in this deque.

spliterator() - Method in class java.util.concurrent.LinkedBlockingQueue

Returns a Spliterator over the elements in this queue.

spliterator() - Method in class java.util.concurrent.LinkedTransferQueue

Returns a Spliterator over the elements in this queue.

spliterator() - Method in class java.util.concurrent.PriorityBlockingQueue

Returns a Spliterator over the elements in this queue.

spliterator() - Method in class java.util.concurrent.SynchronousQueue

Returns an empty spliterator in which calls to Spliterator.trySplit() always return null.

spliterator() - Method in class java.util.HashSet

Creates a late-binding and fail-fast Spliterator over the elements in this set.

spliterator() - Method in class java.util.LinkedHashSet

Creates a late-binding and fail-fast Spliterator over the elements in this set.

spliterator() - Method in class java.util.LinkedList

Creates a late-binding and fail-fast Spliterator over the elements in this list.

spliterator() - Method in interface java.util.List

Creates a Spliterator over the elements in this list.

spliterator() - Method in class java.util.PriorityQueue

Creates a late-binding and fail-fast Spliterator over the elements in this queue.

spliterator() - Method in interface java.util.Set

Creates a Spliterator over the elements in this set.

spliterator() - Method in interface java.util.SortedSet

Creates a Spliterator over the elements in this sorted set.

Spliterator<T> - Interface in java.util

An object for traversing and partitioning elements of a source.

spliterator(Object[], int) - Static method in class java.util.Spliterators

Creates a Spliterator covering the elements of a given array, using a customized set of spliterator characteristics.

spliterator(Object[], int, int, int) - Static method in class java.util.Spliterators

Creates a Spliterator covering a range of elements of a given array, using a customized set of spliterator characteristics.

spliterator(int[], int) - Static method in class java.util.Spliterators

Creates a Spliterator.OfInt covering the elements of a given array, using a customized set of spliterator characteristics.

spliterator(int[], int, int, int) - Static method in class java.util.Spliterators

Creates a Spliterator.OfInt covering a range of elements of a given array, using a customized set of spliterator characteristics.

spliterator(long[], int) - Static method in class java.util.Spliterators

Creates a Spliterator.OfLong covering the elements of a given array, using a customized set of spliterator characteristics.

spliterator(long[], int, int, int) - Static method in class java.util.Spliterators

Creates a Spliterator.OfLong covering a range of elements of a given array, using a customized set of spliterator characteristics.

spliterator(double[], int) - Static method in class java.util.Spliterators

Creates a Spliterator.OfDouble covering the elements of a given array, using a customized set of spliterator characteristics.

spliterator(double[], int, int, int) - Static method in class java.util.Spliterators

Creates a Spliterator.OfDouble covering a range of elements of a given array, using a customized set of spliterator characteristics.

spliterator(Collection<? extends T>, int) - Static method in class java.util.Spliterators

Creates a Spliterator using the given collection's Collection.iterator() as the source of elements, and reporting its Collection.size() as its initial size.

spliterator(Iterator<? extends T>, long, int) - Static method in class java.util.Spliterators

Creates a Spliterator using a given Iterator as the source of elements, and with a given initially reported size.

spliterator(PrimitiveIterator.OfInt, long, int) - Static method in class java.util.Spliterators

Creates a Spliterator.OfInt using a given IntStream.IntIterator as the source of elements, and with a given initially reported size.

spliterator(PrimitiveIterator.OfLong, long, int) - Static method in class java.util.Spliterators

Creates a Spliterator.OfLong using a given LongStream.LongIterator as the source of elements, and with a given initially reported size.

spliterator(PrimitiveIterator.OfDouble, long, int) - Static method in class java.util.Spliterators

Creates a Spliterator.OfDouble using a given DoubleStream.DoubleIterator as the source of elements, and with a given initially reported size.

spliterator() - Method in interface java.util.stream.BaseStream

Returns a spliterator for the elements of this stream.

spliterator() - Method in interface java.util.stream.DoubleStream

spliterator() - Method in interface java.util.stream.IntStream

spliterator() - Method in interface java.util.stream.LongStream

spliterator() - Method in class java.util.TreeSet

Creates a late-binding and fail-fast Spliterator over the elements in this set.

spliterator() - Method in class java.util.Vector

Creates a late-binding and fail-fast Spliterator over the elements in this list.

Spliterator.OfDouble - Interface in java.util

A Spliterator specialized for double values.

Spliterator.OfInt - Interface in java.util

A Spliterator specialized for int values.

Spliterator.OfLong - Interface in java.util

A Spliterator specialized for long values.

Spliterator.OfPrimitive<T,T_CONS,T_SPLITR extends Spliterator.OfPrimitive<T,T_CONS,T_SPLITR>> - Interface in java.util

A Spliterator specialized for primitive values.

Spliterators - Class in java.util

Static classes and methods for operating on or creating instances of Spliterator and its primitive specializations Spliterator.OfInt, Spliterator.OfLong, and Spliterator.OfDouble.

Spliterators.AbstractDoubleSpliterator - Class in java.util

An abstract Spliterator.OfDouble that implements trySplit to permit limited parallelism.

Spliterators.AbstractIntSpliterator - Class in java.util

An abstract Spliterator.OfInt that implements trySplit to permit limited parallelism.

Spliterators.AbstractLongSpliterator - Class in java.util

An abstract Spliterator.OfLong that implements trySplit to permit limited parallelism.

Spliterators.AbstractSpliterator<T> - Class in java.util

An abstract Spliterator that implements trySplit to permit limited parallelism.

spliteratorUnknownSize(Iterator<? extends T>, int) - Static method in class java.util.Spliterators

Creates a Spliterator using a given Iterator as the source of elements, with no initial size estimate.

spliteratorUnknownSize(PrimitiveIterator.OfInt, int) - Static method in class java.util.Spliterators

Creates a Spliterator.OfInt using a given IntStream.IntIterator as the source of elements, with no initial size estimate.

spliteratorUnknownSize(PrimitiveIterator.OfLong, int) - Static method in class java.util.Spliterators

Creates a Spliterator.OfLong using a given LongStream.LongIterator as the source of elements, with no initial size estimate.

spliteratorUnknownSize(PrimitiveIterator.OfDouble, int) - Static method in class java.util.Spliterators

Creates a Spliterator.OfDouble using a given DoubleStream.DoubleIterator as the source of elements, with no initial size estimate.

splitPane - Variable in class javax.swing.plaf.basic.BasicSplitPaneDivider

JSplitPane the receiver is contained in.

splitPane - Variable in class javax.swing.plaf.basic.BasicSplitPaneUI

JSplitPane instance this instance is providing the look and feel for.

SplitPaneBorder(Color, Color) - Constructor for class javax.swing.plaf.basic.BasicBorders.SplitPaneBorder

splitPaneUI - Variable in class javax.swing.plaf.basic.BasicSplitPaneDivider

UI this instance was created from.

SplitPaneUI - Class in javax.swing.plaf

Pluggable look and feel interface for JSplitPane.

SplitPaneUI() - Constructor for class javax.swing.plaf.SplitPaneUI

SplittableRandom - Class in java.util

A generator of uniform pseudorandom values applicable for use in (among other contexts) isolated parallel computations that may generate subtasks.

SplittableRandom(long) - Constructor for class java.util.SplittableRandom

Creates a new SplittableRandom instance using the specified initial seed.

SplittableRandom() - Constructor for class java.util.SplittableRandom

Creates a new SplittableRandom instance that is likely to generate sequences of values that are statistically independent of those of any other instances in the current program; and may, and typically does, vary across program invocations.

splitText(int) - Method in interface org.w3c.dom.Text

Breaks this node into two nodes at the specified offset, keeping both in the tree as siblings.

SPOOL_AREA_FULL - Static variable in class javax.print.attribute.standard.PrinterStateReason

The limit of persistent storage allocated for spooling has been reached.

spPropertyChangeListener - Variable in class javax.swing.plaf.basic.BasicScrollPaneUI

spreadInvoker(MethodType, int) - Static method in class java.lang.invoke.MethodHandles

Produces a method handle which will invoke any method handle of the given type, with a given number of trailing arguments replaced by a single trailing Object[] array.

Spring - Class in javax.swing

An instance of the Spring class holds three properties that characterize its behavior: the minimum, preferred, and maximum values.

Spring() - Constructor for class javax.swing.Spring

Used by factory methods to create a Spring.

SpringLayout - Class in javax.swing

A SpringLayout lays out the children of its associated container according to a set of constraints.

SpringLayout() - Constructor for class javax.swing.SpringLayout

Constructs a new SpringLayout.

SpringLayout.Constraints - Class in javax.swing

A Constraints object holds the constraints that govern the way a component's size and position change in a container controlled by a SpringLayout.

SQLClientInfoException - Exception in java.sql

The subclass of SQLException is thrown when one or more client info properties could not be set on a Connection.

SQLClientInfoException() - Constructor for exception java.sql.SQLClientInfoException

Constructs a SQLClientInfoException Object.

SQLClientInfoException(Map<String, ClientInfoStatus>) - Constructor for exception java.sql.SQLClientInfoException

Constructs a SQLClientInfoException object initialized with a given failedProperties.

SQLClientInfoException(Map<String, ClientInfoStatus>, Throwable) - Constructor for exception java.sql.SQLClientInfoException

Constructs a SQLClientInfoException object initialized with a given cause and failedProperties.

SQLClientInfoException(String, Map<String, ClientInfoStatus>) - Constructor for exception java.sql.SQLClientInfoException

Constructs a SQLClientInfoException object initialized with a given reason and failedProperties.

SQLClientInfoException(String, Map<String, ClientInfoStatus>, Throwable) - Constructor for exception java.sql.SQLClientInfoException

Constructs a SQLClientInfoException object initialized with a given reason, cause and failedProperties.

SQLClientInfoException(String, String, Map<String, ClientInfoStatus>) - Constructor for exception java.sql.SQLClientInfoException

Constructs a SQLClientInfoException object initialized with a given reason, SQLState and failedProperties.

SQLClientInfoException(String, String, Map<String, ClientInfoStatus>, Throwable) - Constructor for exception java.sql.SQLClientInfoException

Constructs a SQLClientInfoException object initialized with a given reason, SQLState, cause and failedProperties.

SQLClientInfoException(String, String, int, Map<String, ClientInfoStatus>) - Constructor for exception java.sql.SQLClientInfoException

Constructs a SQLClientInfoException object initialized with a given reason, SQLState, vendorCode and failedProperties.

SQLClientInfoException(String, String, int, Map<String, ClientInfoStatus>, Throwable) - Constructor for exception java.sql.SQLClientInfoException

Constructs a SQLClientInfoException object initialized with a given reason, SQLState, cause, vendorCode and failedProperties.

SQLData - Interface in java.sql

The interface used for the custom mapping of an SQL user-defined type (UDT) to a class in the Java programming language.

SQLDataException - Exception in java.sql

The subclass of SQLException thrown when the SQLState class value is '22', or under vendor-specified conditions.

SQLDataException() - Constructor for exception java.sql.SQLDataException

Constructs a SQLDataException object.

SQLDataException(String) - Constructor for exception java.sql.SQLDataException

Constructs a SQLDataException object with a given reason.

SQLDataException(String, String) - Constructor for exception java.sql.SQLDataException

Constructs a SQLDataException object with a given reason and SQLState.

SQLDataException(String, String, int) - Constructor for exception java.sql.SQLDataException

Constructs a SQLDataException object with a given reason, SQLState and vendorCode.

SQLDataException(Throwable) - Constructor for exception java.sql.SQLDataException

Constructs a SQLDataException object with a given cause.

SQLDataException(String, Throwable) - Constructor for exception java.sql.SQLDataException

Constructs a SQLDataException object with a given reason and cause.

SQLDataException(String, String, Throwable) - Constructor for exception java.sql.SQLDataException

Constructs a SQLDataException object with a given reason, SQLState and cause.

SQLDataException(String, String, int, Throwable) - Constructor for exception java.sql.SQLDataException

Constructs a SQLDataException object with a given reason, SQLState, vendorCode and cause.

SQLException - Exception in java.sql

An exception that provides information on a database access error or other errors.

SQLException(String, String, int) - Constructor for exception java.sql.SQLException

Constructs a SQLException object with a given reason, SQLState and vendorCode.

SQLException(String, String) - Constructor for exception java.sql.SQLException

Constructs a SQLException object with a given reason and SQLState.

SQLException(String) - Constructor for exception java.sql.SQLException

Constructs a SQLException object with a given reason.

SQLException() - Constructor for exception java.sql.SQLException

Constructs a SQLException object.

SQLException(Throwable) - Constructor for exception java.sql.SQLException

Constructs a SQLException object with a given cause.

SQLException(String, Throwable) - Constructor for exception java.sql.SQLException

Constructs a SQLException object with a given reason and cause.

SQLException(String, String, Throwable) - Constructor for exception java.sql.SQLException

Constructs a SQLException object with a given reason, SQLState and cause.

SQLException(String, String, int, Throwable) - Constructor for exception java.sql.SQLException

Constructs a SQLException object with a given reason, SQLState, vendorCode and cause.

SQLFeatureNotSupportedException - Exception in java.sql

The subclass of SQLException thrown when the SQLState class value is '0A' ( the value is 'zero' A).

SQLFeatureNotSupportedException() - Constructor for exception java.sql.SQLFeatureNotSupportedException

Constructs a SQLFeatureNotSupportedException object.

SQLFeatureNotSupportedException(String) - Constructor for exception java.sql.SQLFeatureNotSupportedException

Constructs a SQLFeatureNotSupportedException object with a given reason.

SQLFeatureNotSupportedException(String, String) - Constructor for exception java.sql.SQLFeatureNotSupportedException

Constructs a SQLFeatureNotSupportedException object with a given reason and SQLState.

SQLFeatureNotSupportedException(String, String, int) - Constructor for exception java.sql.SQLFeatureNotSupportedException

Constructs a SQLFeatureNotSupportedException object with a given reason, SQLState and vendorCode.

SQLFeatureNotSupportedException(Throwable) - Constructor for exception java.sql.SQLFeatureNotSupportedException

Constructs a SQLFeatureNotSupportedException object with a given cause.

SQLFeatureNotSupportedException(String, Throwable) - Constructor for exception java.sql.SQLFeatureNotSupportedException

Constructs a SQLFeatureNotSupportedException object with a given reason and cause.

SQLFeatureNotSupportedException(String, String, Throwable) - Constructor for exception java.sql.SQLFeatureNotSupportedException

Constructs a SQLFeatureNotSupportedException object with a given reason, SQLState and cause.

SQLFeatureNotSupportedException(String, String, int, Throwable) - Constructor for exception java.sql.SQLFeatureNotSupportedException

Constructs a SQLFeatureNotSupportedException object with a given reason, SQLState, vendorCode and cause.

SQLInput - Interface in java.sql

An input stream that contains a stream of values representing an instance of an SQL structured type or an SQL distinct type.

SQLInputImpl - Class in javax.sql.rowset.serial

An input stream used for custom mapping user-defined types (UDTs).

SQLInputImpl(Object[], Map<String, Class<?>>) - Constructor for class javax.sql.rowset.serial.SQLInputImpl

Creates an SQLInputImpl object initialized with the given array of attributes and the given type map.

SQLIntegrityConstraintViolationException - Exception in java.sql

The subclass of SQLException thrown when the SQLState class value is '23', or under vendor-specified conditions.

SQLIntegrityConstraintViolationException() - Constructor for exception java.sql.SQLIntegrityConstraintViolationException

Constructs a SQLIntegrityConstraintViolationException object.

SQLIntegrityConstraintViolationException(String) - Constructor for exception java.sql.SQLIntegrityConstraintViolationException

Constructs a SQLIntegrityConstraintViolationException with a given reason.

SQLIntegrityConstraintViolationException(String, String) - Constructor for exception java.sql.SQLIntegrityConstraintViolationException

Constructs a SQLIntegrityConstraintViolationException object with a given reason and SQLState.

SQLIntegrityConstraintViolationException(String, String, int) - Constructor for exception java.sql.SQLIntegrityConstraintViolationException

Constructs a SQLIntegrityConstraintViolationException object with a given reason, SQLState and vendorCode.

SQLIntegrityConstraintViolationException(Throwable) - Constructor for exception java.sql.SQLIntegrityConstraintViolationException

Constructs an SQLIntegrityConstraintViolationException object with a given cause.

SQLIntegrityConstraintViolationException(String, Throwable) - Constructor for exception java.sql.SQLIntegrityConstraintViolationException

Constructs a SQLIntegrityConstraintViolationException object with a given reason and cause.

SQLIntegrityConstraintViolationException(String, String, Throwable) - Constructor for exception java.sql.SQLIntegrityConstraintViolationException

Constructs a SQLIntegrityConstraintViolationException object with a given reason, SQLState and cause.

SQLIntegrityConstraintViolationException(String, String, int, Throwable) - Constructor for exception java.sql.SQLIntegrityConstraintViolationException

Constructs a SQLIntegrityConstraintViolationException object with a given reason, SQLState, vendorCode and cause.

SQLInvalidAuthorizationSpecException - Exception in java.sql

The subclass of SQLException thrown when the SQLState class value is '28', or under vendor-specified conditions.

SQLInvalidAuthorizationSpecException() - Constructor for exception java.sql.SQLInvalidAuthorizationSpecException

Constructs a SQLInvalidAuthorizationSpecException object.

SQLInvalidAuthorizationSpecException(String) - Constructor for exception java.sql.SQLInvalidAuthorizationSpecException

Constructs a SQLInvalidAuthorizationSpecException object with a given reason.

SQLInvalidAuthorizationSpecException(String, String) - Constructor for exception java.sql.SQLInvalidAuthorizationSpecException

Constructs a SQLInvalidAuthorizationSpecException object with a given reason and SQLState.

SQLInvalidAuthorizationSpecException(String, String, int) - Constructor for exception java.sql.SQLInvalidAuthorizationSpecException

Constructs a SQLInvalidAuthorizationSpecException object with a given reason, SQLState and vendorCode.

SQLInvalidAuthorizationSpecException(Throwable) - Constructor for exception java.sql.SQLInvalidAuthorizationSpecException

Constructs a SQLInvalidAuthorizationSpecException object with a given cause.

SQLInvalidAuthorizationSpecException(String, Throwable) - Constructor for exception java.sql.SQLInvalidAuthorizationSpecException

Constructs a SQLInvalidAuthorizationSpecException object with a given reason and cause.

SQLInvalidAuthorizationSpecException(String, String, Throwable) - Constructor for exception java.sql.SQLInvalidAuthorizationSpecException

Constructs a SQLInvalidAuthorizationSpecException object with a given reason, SQLState and cause.

SQLInvalidAuthorizationSpecException(String, String, int, Throwable) - Constructor for exception java.sql.SQLInvalidAuthorizationSpecException

Constructs a SQLInvalidAuthorizationSpecException object with a given reason, SQLState, vendorCode and cause.

SQLNonTransientConnectionException - Exception in java.sql

The subclass of SQLException thrown for the SQLState class value '08', or under vendor-specified conditions.

SQLNonTransientConnectionException() - Constructor for exception java.sql.SQLNonTransientConnectionException

Constructs a SQLNonTransientConnectionException object.

SQLNonTransientConnectionException(String) - Constructor for exception java.sql.SQLNonTransientConnectionException

Constructs a SQLNonTransientConnectionException object with a given reason.

SQLNonTransientConnectionException(String, String) - Constructor for exception java.sql.SQLNonTransientConnectionException

Constructs a SQLNonTransientConnectionException object with a given reason and SQLState.

SQLNonTransientConnectionException(String, String, int) - Constructor for exception java.sql.SQLNonTransientConnectionException

Constructs a SQLNonTransientConnectionException object with a given reason, SQLState and vendorCode.

SQLNonTransientConnectionException(Throwable) - Constructor for exception java.sql.SQLNonTransientConnectionException

Constructs a SQLNonTransientConnectionException object with a given cause.

SQLNonTransientConnectionException(String, Throwable) - Constructor for exception java.sql.SQLNonTransientConnectionException

Constructs a SQLTransientException object with a given reason and cause.

SQLNonTransientConnectionException(String, String, Throwable) - Constructor for exception java.sql.SQLNonTransientConnectionException

Constructs a SQLNonTransientConnectionException object with a given reason, SQLState and cause.

SQLNonTransientConnectionException(String, String, int, Throwable) - Constructor for exception java.sql.SQLNonTransientConnectionException

Constructs a SQLNonTransientConnectionException object with a given reason, SQLState, vendorCode and cause.

SQLNonTransientException - Exception in java.sql

The subclass of SQLException thrown when an instance where a retry of the same operation would fail unless the cause of the SQLException is corrected.

SQLNonTransientException() - Constructor for exception java.sql.SQLNonTransientException

Constructs a SQLNonTransientException object.

SQLNonTransientException(String) - Constructor for exception java.sql.SQLNonTransientException

Constructs a SQLNonTransientException object with a given reason.

SQLNonTransientException(String, String) - Constructor for exception java.sql.SQLNonTransientException

Constructs a SQLNonTransientException object with a given reason and SQLState.

SQLNonTransientException(String, String, int) - Constructor for exception java.sql.SQLNonTransientException

Constructs a SQLNonTransientException object with a given reason, SQLState and vendorCode.

SQLNonTransientException(Throwable) - Constructor for exception java.sql.SQLNonTransientException

Constructs a SQLNonTransientException object with a given cause.

SQLNonTransientException(String, Throwable) - Constructor for exception java.sql.SQLNonTransientException

Constructs a SQLTransientException object with a given reason and cause.

SQLNonTransientException(String, String, Throwable) - Constructor for exception java.sql.SQLNonTransientException

Constructs a SQLNonTransientException object with a given reason, SQLState and cause.

SQLNonTransientException(String, String, int, Throwable) - Constructor for exception java.sql.SQLNonTransientException

Constructs a SQLNonTransientException object with a given reason, SQLState, vendorCode and cause.

SQLOutput - Interface in java.sql

The output stream for writing the attributes of a user-defined type back to the database.

SQLOutputImpl - Class in javax.sql.rowset.serial

The output stream for writing the attributes of a custom-mapped user-defined type (UDT) back to the database.

SQLOutputImpl(Vector<?>, Map<String, ?>) - Constructor for class javax.sql.rowset.serial.SQLOutputImpl

Creates a new SQLOutputImpl object initialized with the given vector of attributes and type map.

SQLPermission - Class in java.sql

The permission for which the SecurityManager will check when code that is running an application with a SecurityManager enabled, calls the DriverManager.deregisterDriver method, DriverManager.setLogWriter method, DriverManager.setLogStream (deprecated) method, SyncFactory.setJNDIContext method, SyncFactory.setLogger method, Connection.setNetworktimeout method, or the Connection.abort method.

SQLPermission(String) - Constructor for class java.sql.SQLPermission

Creates a new SQLPermission object with the specified name.

SQLPermission(String, String) - Constructor for class java.sql.SQLPermission

Creates a new SQLPermission object with the specified name.

SQLRecoverableException - Exception in java.sql

The subclass of SQLException thrown in situations where a previously failed operation might be able to succeed if the application performs some recovery steps and retries the entire transaction or in the case of a distributed transaction, the transaction branch.

SQLRecoverableException() - Constructor for exception java.sql.SQLRecoverableException

Constructs a SQLRecoverableException object.

SQLRecoverableException(String) - Constructor for exception java.sql.SQLRecoverableException

Constructs a SQLRecoverableException object with a given reason.

SQLRecoverableException(String, String) - Constructor for exception java.sql.SQLRecoverableException

Constructs a SQLRecoverableException object with a given reason and SQLState.

SQLRecoverableException(String, String, int) - Constructor for exception java.sql.SQLRecoverableException

Constructs a SQLRecoverableException object with a given reason, SQLState and vendorCode.

SQLRecoverableException(Throwable) - Constructor for exception java.sql.SQLRecoverableException

Constructs a SQLRecoverableException object with a given cause.

SQLRecoverableException(String, Throwable) - Constructor for exception java.sql.SQLRecoverableException

Constructs a SQLRecoverableException object with a given reason and cause.

SQLRecoverableException(String, String, Throwable) - Constructor for exception java.sql.SQLRecoverableException

Constructs a SQLRecoverableException object with a given reason, SQLState and cause.

SQLRecoverableException(String, String, int, Throwable) - Constructor for exception java.sql.SQLRecoverableException

Constructs a SQLRecoverableException object with a given reason, SQLState, vendorCode and cause.

sqlStateSQL - Static variable in interface java.sql.DatabaseMetaData

A possible return value for the method DatabaseMetaData.getSQLStateType which is used to indicate whether the value returned by the method SQLException.getSQLState is an SQLSTATE value.

sqlStateSQL99 - Static variable in interface java.sql.DatabaseMetaData

A possible return value for the method DatabaseMetaData.getSQLStateType which is used to indicate whether the value returned by the method SQLException.getSQLState is an SQL99 SQLSTATE value.

sqlStateXOpen - Static variable in interface java.sql.DatabaseMetaData

A possible return value for the method DatabaseMetaData.getSQLStateType which is used to indicate whether the value returned by the method SQLException.getSQLState is an X/Open (now know as Open Group) SQL CLI SQLSTATE value.

SQLSyntaxErrorException - Exception in java.sql

The subclass of SQLException thrown when the SQLState class value is '42', or under vendor-specified conditions.

SQLSyntaxErrorException() - Constructor for exception java.sql.SQLSyntaxErrorException

Constructs a SQLSyntaxErrorException object.

SQLSyntaxErrorException(String) - Constructor for exception java.sql.SQLSyntaxErrorException

Constructs a SQLSyntaxErrorException object with a given reason.

SQLSyntaxErrorException(String, String) - Constructor for exception java.sql.SQLSyntaxErrorException

Constructs a SQLSyntaxErrorException object with a given reason and SQLState.

SQLSyntaxErrorException(String, String, int) - Constructor for exception java.sql.SQLSyntaxErrorException

Constructs a SQLSyntaxErrorException object with a given reason, SQLState and vendorCode.

SQLSyntaxErrorException(Throwable) - Constructor for exception java.sql.SQLSyntaxErrorException

Constructs a SQLSyntaxErrorException object with a given cause.

SQLSyntaxErrorException(String, Throwable) - Constructor for exception java.sql.SQLSyntaxErrorException

Constructs a SQLSyntaxErrorException object with a given reason and cause.

SQLSyntaxErrorException(String, String, Throwable) - Constructor for exception java.sql.SQLSyntaxErrorException

Constructs a SQLSyntaxErrorException object with a given reason, SQLState and cause.

SQLSyntaxErrorException(String, String, int, Throwable) - Constructor for exception java.sql.SQLSyntaxErrorException

Constructs a SQLSyntaxErrorException object with a given reason, SQLState, vendorCode and cause.

SQLTimeoutException - Exception in java.sql

The subclass of SQLException thrown when the timeout specified by Statement.setQueryTimeout, DriverManager.setLoginTimeout, DataSource.setLoginTimeout,XADataSource.setLoginTimeout has expired.

SQLTimeoutException() - Constructor for exception java.sql.SQLTimeoutException

Constructs a SQLTimeoutException object.

SQLTimeoutException(String) - Constructor for exception java.sql.SQLTimeoutException

Constructs a SQLTimeoutException object with a given reason.

SQLTimeoutException(String, String) - Constructor for exception java.sql.SQLTimeoutException

Constructs a SQLTimeoutException object with a given reason and SQLState.

SQLTimeoutException(String, String, int) - Constructor for exception java.sql.SQLTimeoutException

Constructs a SQLTimeoutException object with a given reason, SQLState and vendorCode.

SQLTimeoutException(Throwable) - Constructor for exception java.sql.SQLTimeoutException

Constructs a SQLTimeoutException object with a given cause.

SQLTimeoutException(String, Throwable) - Constructor for exception java.sql.SQLTimeoutException

Constructs a SQLTimeoutException object with a given reason and cause.

SQLTimeoutException(String, String, Throwable) - Constructor for exception java.sql.SQLTimeoutException

Constructs a SQLTimeoutException object with a given reason, SQLState and cause.

SQLTimeoutException(String, String, int, Throwable) - Constructor for exception java.sql.SQLTimeoutException

Constructs a SQLTimeoutException object with a given reason, SQLState, vendorCode and cause.

SQLTransactionRollbackException - Exception in java.sql

The subclass of SQLException thrown when the SQLState class value is '40', or under vendor-specified conditions.

SQLTransactionRollbackException() - Constructor for exception java.sql.SQLTransactionRollbackException

Constructs a SQLTransactionRollbackException object.

SQLTransactionRollbackException(String) - Constructor for exception java.sql.SQLTransactionRollbackException

Constructs a SQLTransactionRollbackException object with a given reason.

SQLTransactionRollbackException(String, String) - Constructor for exception java.sql.SQLTransactionRollbackException

Constructs a SQLTransactionRollbackException object with a given reason and SQLState.

SQLTransactionRollbackException(String, String, int) - Constructor for exception java.sql.SQLTransactionRollbackException

Constructs a SQLTransactionRollbackException object with a given reason, SQLState and vendorCode.

SQLTransactionRollbackException(Throwable) - Constructor for exception java.sql.SQLTransactionRollbackException

Constructs a SQLTransactionRollbackException object with a given cause.

SQLTransactionRollbackException(String, Throwable) - Constructor for exception java.sql.SQLTransactionRollbackException

Constructs a SQLTransactionRollbackException object with a given reason and cause.

SQLTransactionRollbackException(String, String, Throwable) - Constructor for exception java.sql.SQLTransactionRollbackException

Constructs a SQLTransactionRollbackException object with a given reason, SQLState and cause.

SQLTransactionRollbackException(String, String, int, Throwable) - Constructor for exception java.sql.SQLTransactionRollbackException

Constructs a SQLTransactionRollbackException object with a given reason, SQLState, vendorCode and cause.

SQLTransientConnectionException - Exception in java.sql

The subclass of SQLException for the SQLState class value '08', or under vendor-specified conditions.

SQLTransientConnectionException() - Constructor for exception java.sql.SQLTransientConnectionException

Constructs a SQLTransientConnectionException object.

SQLTransientConnectionException(String) - Constructor for exception java.sql.SQLTransientConnectionException

Constructs a SQLTransientConnectionException object with a given reason.

SQLTransientConnectionException(String, String) - Constructor for exception java.sql.SQLTransientConnectionException

Constructs a SQLTransientConnectionException object with a given reason and SQLState.

SQLTransientConnectionException(String, String, int) - Constructor for exception java.sql.SQLTransientConnectionException

Constructs a SQLTransientConnectionException object with a given reason, SQLState and vendorCode.

SQLTransientConnectionException(Throwable) - Constructor for exception java.sql.SQLTransientConnectionException

Constructs a SQLTransientConnectionException object with a given cause.

SQLTransientConnectionException(String, Throwable) - Constructor for exception java.sql.SQLTransientConnectionException

Constructs a SQLTransientConnectionException object with a given reason and cause.

SQLTransientConnectionException(String, String, Throwable) - Constructor for exception java.sql.SQLTransientConnectionException

Constructs a SQLTransientConnectionException object with a given reason, SQLState and cause.

SQLTransientConnectionException(String, String, int, Throwable) - Constructor for exception java.sql.SQLTransientConnectionException

Constructs a SQLTransientConnectionException object with a given reason, SQLState, vendorCode and cause.

SQLTransientException - Exception in java.sql

The subclass of SQLException is thrown in situations where a previously failed operation might be able to succeed when the operation is retried without any intervention by application-level functionality.

SQLTransientException() - Constructor for exception java.sql.SQLTransientException

Constructs a SQLTransientException object.

SQLTransientException(String) - Constructor for exception java.sql.SQLTransientException

Constructs a SQLTransientException object with a given reason.

SQLTransientException(String, String) - Constructor for exception java.sql.SQLTransientException

Constructs a SQLTransientException object with a given reason and SQLState.

SQLTransientException(String, String, int) - Constructor for exception java.sql.SQLTransientException

Constructs a SQLTransientException object with a given reason, SQLState and vendorCode.

SQLTransientException(Throwable) - Constructor for exception java.sql.SQLTransientException

Constructs a SQLTransientException object with a given cause.

SQLTransientException(String, Throwable) - Constructor for exception java.sql.SQLTransientException

Constructs a SQLTransientException object with a given reason and cause.

SQLTransientException(String, String, Throwable) - Constructor for exception java.sql.SQLTransientException

Constructs a SQLTransientException object with a given reason, SQLState and cause.

SQLTransientException(String, String, int, Throwable) - Constructor for exception java.sql.SQLTransientException

Constructs a SQLTransientException object with a given reason, SQLState, vendorCode and cause.

SQLType - Interface in java.sql

An object that is used to identify a generic SQL type, called a JDBC type or a vendor specific data type.

SQLWarning - Exception in java.sql

An exception that provides information on database access warnings.

SQLWarning(String, String, int) - Constructor for exception java.sql.SQLWarning

Constructs a SQLWarning object with a given reason, SQLState and vendorCode.

SQLWarning(String, String) - Constructor for exception java.sql.SQLWarning

Constructs a SQLWarning object with a given reason and SQLState.

SQLWarning(String) - Constructor for exception java.sql.SQLWarning

Constructs a SQLWarning object with a given reason.

SQLWarning() - Constructor for exception java.sql.SQLWarning

Constructs a SQLWarning object.

SQLWarning(Throwable) - Constructor for exception java.sql.SQLWarning

Constructs a SQLWarning object with a given cause.

SQLWarning(String, Throwable) - Constructor for exception java.sql.SQLWarning

Constructs a SQLWarning object with a given reason and cause.

SQLWarning(String, String, Throwable) - Constructor for exception java.sql.SQLWarning

Constructs a SQLWarning object with a given reason, SQLState and cause.

SQLWarning(String, String, int, Throwable) - Constructor for exception java.sql.SQLWarning

Constructs aSQLWarning object with a given reason, SQLState, vendorCode and cause.

SQLXML - Interface in java.sql

The mapping in the JavaTM programming language for the SQL XML type.

SQLXML - Static variable in class java.sql.Types

The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type XML.

sqrt(double) - Static method in class java.lang.Math

Returns the correctly rounded positive square root of a double value.

sqrt(double) - Static method in class java.lang.StrictMath

Returns the correctly rounded positive square root of a double value.

squareButton - Variable in class javax.swing.plaf.basic.BasicComboBoxUI

Indicates whether or not the combo box button should be square.

SRC - Static variable in class java.awt.AlphaComposite

The source is copied to the destination (Porter-Duff Source rule).

Src - Static variable in class java.awt.AlphaComposite

AlphaComposite object that implements the opaque SRC rule with an alpha of 1.0f.

SRC - Static variable in class javax.swing.text.html.HTML.Attribute

SRC_ATOP - Static variable in class java.awt.AlphaComposite

The part of the source lying inside of the destination is composited onto the destination (Porter-Duff Source Atop Destination rule).

SRC_IN - Static variable in class java.awt.AlphaComposite

The part of the source lying inside of the destination replaces the destination (Porter-Duff Source In Destination rule).

SRC_OUT - Static variable in class java.awt.AlphaComposite

The part of the source lying outside of the destination replaces the destination (Porter-Duff Source Held Out By Destination rule).

SRC_OVER - Static variable in class java.awt.AlphaComposite

The source is composited over the destination (Porter-Duff Source Over Destination rule).

SrcAtop - Static variable in class java.awt.AlphaComposite

AlphaComposite object that implements the opaque SRC_ATOP rule with an alpha of 1.0f.

srccols - Variable in class java.awt.image.ReplicateScaleFilter

An int array containing information about a column of pixels.

srcHeight - Variable in class java.awt.image.ReplicateScaleFilter

The height of the source image.

SrcIn - Static variable in class java.awt.AlphaComposite

AlphaComposite object that implements the opaque SRC_IN rule with an alpha of 1.0f.

SrcOut - Static variable in class java.awt.AlphaComposite

AlphaComposite object that implements the opaque SRC_OUT rule with an alpha of 1.0f.

SrcOver - Static variable in class java.awt.AlphaComposite

AlphaComposite object that implements the opaque SRC_OVER rule with an alpha of 1.0f.

srcrows - Variable in class java.awt.image.ReplicateScaleFilter

An int array containing information about a row of pixels.

srcWidth - Variable in class java.awt.image.ReplicateScaleFilter

The width of the source image.

SSLContext - Class in javax.net.ssl

Instances of this class represent a secure socket protocol implementation which acts as a factory for secure socket factories or SSLEngines.

SSLContext(SSLContextSpi, Provider, String) - Constructor for class javax.net.ssl.SSLContext

Creates an SSLContext object.

SSLContextSpi - Class in javax.net.ssl

This class defines the Service Provider Interface (SPI) for the SSLContext class.

SSLContextSpi() - Constructor for class javax.net.ssl.SSLContextSpi

SSLEngine - Class in javax.net.ssl

A class which enables secure communications using protocols such as the Secure Sockets Layer (SSL) or IETF RFC 2246 "Transport Layer Security" (TLS) protocols, but is transport independent.

SSLEngine() - Constructor for class javax.net.ssl.SSLEngine

Constructor for an SSLEngine providing no hints for an internal session reuse strategy.

SSLEngine(String, int) - Constructor for class javax.net.ssl.SSLEngine

Constructor for an SSLEngine.

SSLEngineResult - Class in javax.net.ssl

An encapsulation of the result state produced by SSLEngine I/O calls.

SSLEngineResult(SSLEngineResult.Status, SSLEngineResult.HandshakeStatus, int, int) - Constructor for class javax.net.ssl.SSLEngineResult

Initializes a new instance of this class.

SSLEngineResult.HandshakeStatus - Enum in javax.net.ssl

An SSLEngineResult enum describing the current handshaking state of this SSLEngine.

SSLEngineResult.Status - Enum in javax.net.ssl

An SSLEngineResult enum describing the overall result of the SSLEngine operation.

SSLException - Exception in javax.net.ssl

Indicates some kind of error detected by an SSL subsystem.

SSLException(String) - Constructor for exception javax.net.ssl.SSLException

Constructs an exception reporting an error found by an SSL subsystem.

SSLException(String, Throwable) - Constructor for exception javax.net.ssl.SSLException

Creates a SSLException with the specified detail message and cause.

SSLException(Throwable) - Constructor for exception javax.net.ssl.SSLException

Creates a SSLException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).

SSLHandshakeException - Exception in javax.net.ssl

Indicates that the client and server could not negotiate the desired level of security.

SSLHandshakeException(String) - Constructor for exception javax.net.ssl.SSLHandshakeException

Constructs an exception reporting an error found by an SSL subsystem during handshaking.

SSLKeyException - Exception in javax.net.ssl

Reports a bad SSL key.

SSLKeyException(String) - Constructor for exception javax.net.ssl.SSLKeyException

Constructs an exception reporting a key management error found by an SSL subsystem.

SSLParameters - Class in javax.net.ssl

Encapsulates parameters for an SSL/TLS connection.

SSLParameters() - Constructor for class javax.net.ssl.SSLParameters

Constructs SSLParameters.

SSLParameters(String[]) - Constructor for class javax.net.ssl.SSLParameters

Constructs SSLParameters from the specified array of ciphersuites.

SSLParameters(String[], String[]) - Constructor for class javax.net.ssl.SSLParameters

Constructs SSLParameters from the specified array of ciphersuites and protocols.

SSLPeerUnverifiedException - Exception in javax.net.ssl

Indicates that the peer's identity has not been verified.

SSLPeerUnverifiedException(String) - Constructor for exception javax.net.ssl.SSLPeerUnverifiedException

Constructs an exception reporting that the SSL peer's identity has not been verified.

SSLPermission - Class in javax.net.ssl

This class is for various network permissions.

SSLPermission(String) - Constructor for class javax.net.ssl.SSLPermission

Creates a new SSLPermission with the specified name.

SSLPermission(String, String) - Constructor for class javax.net.ssl.SSLPermission

Creates a new SSLPermission object with the specified name.

SSLProtocolException - Exception in javax.net.ssl

Reports an error in the operation of the SSL protocol.

SSLProtocolException(String) - Constructor for exception javax.net.ssl.SSLProtocolException

Constructs an exception reporting an SSL protocol error detected by an SSL subsystem.

SslRMIClientSocketFactory - Class in javax.rmi.ssl

An SslRMIClientSocketFactory instance is used by the RMI runtime in order to obtain client sockets for RMI calls via SSL.

SslRMIClientSocketFactory() - Constructor for class javax.rmi.ssl.SslRMIClientSocketFactory

Creates a new SslRMIClientSocketFactory.

SslRMIServerSocketFactory - Class in javax.rmi.ssl

An SslRMIServerSocketFactory instance is used by the RMI runtime in order to obtain server sockets for RMI calls via SSL.

SslRMIServerSocketFactory() - Constructor for class javax.rmi.ssl.SslRMIServerSocketFactory

Creates a new SslRMIServerSocketFactory with the default SSL socket configuration.

SslRMIServerSocketFactory(String[], String[], boolean) - Constructor for class javax.rmi.ssl.SslRMIServerSocketFactory

Creates a new SslRMIServerSocketFactory with the specified SSL socket configuration.

SslRMIServerSocketFactory(SSLContext, String[], String[], boolean) - Constructor for class javax.rmi.ssl.SslRMIServerSocketFactory

Creates a new SslRMIServerSocketFactory with the specified SSLContext and SSL socket configuration.

SSLServerSocket - Class in javax.net.ssl

This class extends ServerSockets and provides secure server sockets using protocols such as the Secure Sockets Layer (SSL) or Transport Layer Security (TLS) protocols.

SSLServerSocket() - Constructor for class javax.net.ssl.SSLServerSocket

Used only by subclasses.

SSLServerSocket(int) - Constructor for class javax.net.ssl.SSLServerSocket

Used only by subclasses.

SSLServerSocket(int, int) - Constructor for class javax.net.ssl.SSLServerSocket

Used only by subclasses.

SSLServerSocket(int, int, InetAddress) - Constructor for class javax.net.ssl.SSLServerSocket

Used only by subclasses.

SSLServerSocketFactory - Class in javax.net.ssl

SSLServerSocketFactorys create SSLServerSockets.

SSLServerSocketFactory() - Constructor for class javax.net.ssl.SSLServerSocketFactory

Constructor is used only by subclasses.

SSLSession - Interface in javax.net.ssl

In SSL, sessions are used to describe an ongoing relationship between two entities.

SSLSessionBindingEvent - Class in javax.net.ssl

This event is propagated to a SSLSessionBindingListener.

SSLSessionBindingEvent(SSLSession, String) - Constructor for class javax.net.ssl.SSLSessionBindingEvent

Constructs a new SSLSessionBindingEvent.

SSLSessionBindingListener - Interface in javax.net.ssl

This interface is implemented by objects which want to know when they are being bound or unbound from a SSLSession.

SSLSessionContext - Interface in javax.net.ssl

A SSLSessionContext represents a set of SSLSessions associated with a single entity.

SSLSocket - Class in javax.net.ssl

This class extends Sockets and provides secure socket using protocols such as the "Secure Sockets Layer" (SSL) or IETF "Transport Layer Security" (TLS) protocols.

SSLSocket() - Constructor for class javax.net.ssl.SSLSocket

Used only by subclasses.

SSLSocket(String, int) - Constructor for class javax.net.ssl.SSLSocket

Used only by subclasses.

SSLSocket(InetAddress, int) - Constructor for class javax.net.ssl.SSLSocket

Used only by subclasses.

SSLSocket(String, int, InetAddress, int) - Constructor for class javax.net.ssl.SSLSocket

Used only by subclasses.

SSLSocket(InetAddress, int, InetAddress, int) - Constructor for class javax.net.ssl.SSLSocket

Used only by subclasses.

SSLSocketFactory - Class in javax.net.ssl

SSLSocketFactorys create SSLSockets.

SSLSocketFactory() - Constructor for class javax.net.ssl.SSLSocketFactory

Constructor is used only by subclasses.

Stack<E> - Class in java.util

The Stack class represents a last-in-first-out (LIFO) stack of objects.

Stack() - Constructor for class java.util.Stack

Creates an empty Stack.

StackOverflowError - Error in java.lang

Thrown when a stack overflow occurs because an application recurses too deeply.

StackOverflowError() - Constructor for error java.lang.StackOverflowError

Constructs a StackOverflowError with no detail message.

StackOverflowError(String) - Constructor for error java.lang.StackOverflowError

Constructs a StackOverflowError with the specified detail message.

StackTraceElement - Class in java.lang

An element in a stack trace, as returned by Throwable.getStackTrace().

StackTraceElement(String, String, String, int) - Constructor for class java.lang.StackTraceElement

Creates a stack trace element representing the specified execution point.

StampedLock - Class in java.util.concurrent.locks

A capability-based lock with three modes for controlling read/write access.

StampedLock() - Constructor for class java.util.concurrent.locks.StampedLock

Creates a new lock, initially in unlocked state.

STANDALONE - Static variable in class javax.xml.transform.OutputKeys

standalone = "yes" | "no".

standaloneSet() - Method in interface javax.xml.stream.events.StartDocument

Returns true if the standalone attribute was set in the encoding declaration of the document.

standaloneSet() - Method in class javax.xml.stream.util.StreamReaderDelegate

standaloneSet() - Method in interface javax.xml.stream.XMLStreamReader

Checks if standalone was set in the document

STANDARD - Static variable in class java.awt.font.GlyphMetrics

Indicates a glyph that represents a single standard character.

STANDARD - Static variable in class java.time.format.DecimalStyle

The standard set of non-localized decimal style symbols.

STANDARD - Static variable in class javax.print.attribute.standard.JobSheets

One or more site specific standard job sheets are printed.

STANDARD_INPUT_TYPE - Static variable in class javax.imageio.spi.ImageReaderSpi

Deprecated.
Instead of using this field, directly create the equivalent array { ImageInputStream.class }.

STANDARD_OUTPUT_TYPE - Static variable in class javax.imageio.spi.ImageWriterSpi

Deprecated.
Instead of using this field, directly create the equivalent array { ImageOutputStream.class }.

STANDARD_TIME - Static variable in class java.util.SimpleTimeZone

Constant for a mode of start or end time specified as standard time.

StandardCharsets - Class in java.nio.charset

Constant definitions for the standard Charsets.

StandardConstants - Class in javax.net.ssl

Standard constants definitions

StandardCopyOption - Enum in java.nio.file

Defines the standard copy options.

StandardEmitterMBean - Class in javax.management

An MBean whose management interface is determined by reflection on a Java interface, and that emits notifications.

StandardEmitterMBean(T, Class<T>, NotificationEmitter) - Constructor for class javax.management.StandardEmitterMBean

Make an MBean whose management interface is specified by mbeanInterface, with the given implementation and where notifications are handled by the given NotificationEmitter.

StandardEmitterMBean(T, Class<T>, boolean, NotificationEmitter) - Constructor for class javax.management.StandardEmitterMBean

Make an MBean whose management interface is specified by mbeanInterface, with the given implementation and where notifications are handled by the given NotificationEmitter.

StandardEmitterMBean(Class<?>, NotificationEmitter) - Constructor for class javax.management.StandardEmitterMBean

Make an MBean whose management interface is specified by mbeanInterface, and where notifications are handled by the given NotificationEmitter.

StandardEmitterMBean(Class<?>, boolean, NotificationEmitter) - Constructor for class javax.management.StandardEmitterMBean

Make an MBean whose management interface is specified by mbeanInterface, and where notifications are handled by the given NotificationEmitter.

standardFormatSupported - Variable in class javax.imageio.metadata.IIOMetadata

A boolean indicating whether the concrete subclass supports the standard metadata format, set via the constructor.

StandardJavaFileManager - Interface in javax.tools

File manager based on java.io.File.

StandardLocation - Enum in javax.tools

Standard locations of file objects.

StandardMBean - Class in javax.management

An MBean whose management interface is determined by reflection on a Java interface.

StandardMBean(T, Class<T>) - Constructor for class javax.management.StandardMBean

Make a DynamicMBean out of the object implementation, using the specified mbeanInterface class.

StandardMBean(Class<?>) - Constructor for class javax.management.StandardMBean

Make a DynamicMBean out of this, using the specified mbeanInterface class.

StandardMBean(T, Class<T>, boolean) - Constructor for class javax.management.StandardMBean

Make a DynamicMBean out of the object implementation, using the specified mbeanInterface class, and choosing whether the resultant MBean is an MXBean.

StandardMBean(Class<?>, boolean) - Constructor for class javax.management.StandardMBean

Make a DynamicMBean out of this, using the specified mbeanInterface class, and choosing whether the resulting MBean is an MXBean.

standardMetadataFormatName - Static variable in class javax.imageio.metadata.IIOMetadataFormatImpl

A String constant containing the standard format name, "javax_imageio_1.0".

StandardOpenOption - Enum in java.nio.file

Defines the standard open options.

StandardProtocolFamily - Enum in java.net

Defines the standard families of communication protocols.

StandardSocketOptions - Class in java.net

Defines the standard socket options.

StandardWatchEventKinds - Class in java.nio.file

Defines the standard event kinds.

STANDBY - Static variable in class javax.swing.text.html.HTML.Attribute

STAPLE - Static variable in class javax.print.attribute.standard.Finishings

Bind the document(s) with one or more staples.

STAPLE_BOTTOM_LEFT - Static variable in class javax.print.attribute.standard.Finishings

Bind the document(s) with one or more staples in the bottom left corner.

STAPLE_BOTTOM_RIGHT - Static variable in class javax.print.attribute.standard.Finishings

Bind the document(s) with one or more staples in the bottom right corner.

STAPLE_DUAL_BOTTOM - Static variable in class javax.print.attribute.standard.Finishings

Bind the document(s) with two staples (wire stitches) along the bottom edge assuming a portrait document (see above).

STAPLE_DUAL_LEFT - Static variable in class javax.print.attribute.standard.Finishings

Bind the document(s) with two staples (wire stitches) along the left edge assuming a portrait document (see above).

STAPLE_DUAL_RIGHT - Static variable in class javax.print.attribute.standard.Finishings

Bind the document(s) with two staples (wire stitches) along the right edge assuming a portrait document (see above).

STAPLE_DUAL_TOP - Static variable in class javax.print.attribute.standard.Finishings

Bind the document(s) with two staples (wire stitches) along the top edge assuming a portrait document (see above).

STAPLE_TOP_LEFT - Static variable in class javax.print.attribute.standard.Finishings

Bind the document(s) with one or more staples in the top left corner.

STAPLE_TOP_RIGHT - Static variable in class javax.print.attribute.standard.Finishings

Bind the document(s) with one or more staples in the top right corner.

start() - Method in class java.applet.Applet

Called by the browser or applet viewer to inform this applet that it should start its execution.

start - Variable in class java.awt.geom.Arc2D.Double

The starting angle of the arc in degrees.

start - Variable in class java.awt.geom.Arc2D.Float

The starting angle of the arc in degrees.

start() - Method in class java.lang.ProcessBuilder

Starts a new process using the attributes of this process builder.

start() - Method in class java.lang.Thread

Causes this thread to begin execution; the Java Virtual Machine calls the run method of this thread.

start() - Method in class java.util.regex.Matcher

Returns the start index of the previous match.

start(int) - Method in class java.util.regex.Matcher

Returns the start index of the subsequence captured by the given group during the previous match operation.

start(String) - Method in class java.util.regex.Matcher

Returns the start index of the subsequence captured by the given named-capturing group during the previous match operation.

start() - Method in interface java.util.regex.MatchResult

Returns the start index of the match.

start(int) - Method in interface java.util.regex.MatchResult

Returns the start index of the subsequence captured by the given group during this match.

start() - Method in class javax.management.monitor.CounterMonitor

Starts the counter monitor.

start() - Method in class javax.management.monitor.GaugeMonitor

Starts the gauge monitor.

start() - Method in class javax.management.monitor.Monitor

Starts the monitor.

start() - Method in interface javax.management.monitor.MonitorMBean

Starts the monitor.

start() - Method in class javax.management.monitor.StringMonitor

Starts the string monitor.

start() - Method in interface javax.management.remote.JMXConnectorServerMBean

Activates the connector server, that is, starts listening for client connections.

start() - Method in class javax.management.remote.rmi.RMIConnectorServer

Activates the connector server, that is starts listening for client connections.

start() - Method in class javax.management.timer.Timer

Starts the timer.

start() - Method in interface javax.management.timer.TimerMBean

Starts the timer.

start() - Method in interface javax.sound.midi.Sequencer

Starts playback of the MIDI data in the currently loaded sequence.

START - Static variable in class javax.sound.midi.ShortMessage

Status byte for Start message (0xFA, or 250).

start() - Method in interface javax.sound.sampled.DataLine

Allows a line to engage in data I/O.

START - Static variable in class javax.sound.sampled.LineEvent.Type

A type of event that is sent when a line begins to engage in active input or output of audio data in response to a start request.

START - Static variable in class javax.swing.text.html.HTML.Attribute

start(HTML.Tag, MutableAttributeSet) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader.BlockAction

start(HTML.Tag, MutableAttributeSet) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader.CharacterAction

start(HTML.Tag, MutableAttributeSet) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader.FormAction

start(HTML.Tag, MutableAttributeSet) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader.HiddenAction

start(HTML.Tag, MutableAttributeSet) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader.IsindexAction

start(HTML.Tag, MutableAttributeSet) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader.ParagraphAction

start(HTML.Tag, MutableAttributeSet) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader.PreAction

start(HTML.Tag, MutableAttributeSet) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader.SpecialAction

start(HTML.Tag, MutableAttributeSet) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader.TagAction

Called when a start tag is seen for the type of tag this action was registered to.

start() - Method in class javax.swing.Timer

Starts the Timer, causing it to start sending action events to its listeners.

start(Xid, int) - Method in interface javax.transaction.xa.XAResource

Starts work on behalf of a transaction branch specified in xid.

START_DOCUMENT - Static variable in interface javax.xml.stream.XMLStreamConstants

Indicates an event is a start document

START_ELEMENT - Static variable in interface javax.xml.stream.XMLStreamConstants

Indicates an event is a start element

START_PUNCTUATION - Static variable in class java.lang.Character

General category "Ps" in the Unicode specification.

start_value() - Method in interface org.omg.CORBA.portable.ValueInputStream

The start_value method reads a valuetype header for a nested custom valuetype and increments the valuetype nesting depth.

start_value(String) - Method in interface org.omg.CORBA.portable.ValueOutputStream

The start_value method ends any currently open chunk, writes a valuetype header for a nested custom valuetype (with a null codebase and the specified repository ID), and increments the valuetype nesting depth.

startAnimationTimer() - Method in class javax.swing.plaf.basic.BasicProgressBarUI

Starts the animation thread, creating and initializing it if necessary.

startAutoScrolling(int) - Method in class javax.swing.plaf.basic.BasicComboPopup

This protected method is implementation specific and should be private.

startCDATA() - Method in class org.xml.sax.ext.DefaultHandler2

startCDATA() - Method in interface org.xml.sax.ext.LexicalHandler

Report the start of a CDATA section.

startCellEditing(EventObject) - Method in class javax.swing.DefaultCellEditor.EditorDelegate

Returns true to indicate that editing has begun.

StartDocument - Interface in javax.xml.stream.events

An interface for the start document event

startDocument() - Method in interface org.xml.sax.ContentHandler

Receive notification of the beginning of a document.

startDocument() - Method in interface org.xml.sax.DocumentHandler

Deprecated.

Receive notification of the beginning of a document.

startDocument() - Method in class org.xml.sax.HandlerBase

Deprecated.

Receive notification of the beginning of the document.

startDocument() - Method in class org.xml.sax.helpers.DefaultHandler

Receive notification of the beginning of the document.

startDocument() - Method in class org.xml.sax.helpers.ParserAdapter

Adapter implementation method; do not call.

startDocument() - Method in class org.xml.sax.helpers.XMLFilterImpl

Filter a start document event.

startDocument() - Method in class org.xml.sax.helpers.XMLReaderAdapter

Start document event.

startDrag(Cursor, Transferable) - Method in class java.awt.dnd.DragGestureEvent

Starts the drag operation given the Cursor for this drag operation and the Transferable representing the source data for this drag operation.

startDrag(Cursor, Transferable, DragSourceListener) - Method in class java.awt.dnd.DragGestureEvent

Starts the drag given the initial Cursor to display, the Transferable object, and the DragSourceListener to use.

startDrag(Cursor, Image, Point, Transferable, DragSourceListener) - Method in class java.awt.dnd.DragGestureEvent

Start the drag given the initial Cursor to display, a drag Image, the offset of the Image, the Transferable object, and the DragSourceListener to use.

startDrag(DragGestureEvent, Cursor, Image, Point, Transferable, DragSourceListener, FlavorMap) - Method in class java.awt.dnd.DragSource

Start a drag, given the DragGestureEvent that initiated the drag, the initial Cursor to use, the Image to drag, the offset of the Image origin from the hotspot of the Cursor at the instant of the trigger, the Transferable subject data of the drag, the DragSourceListener, and the FlavorMap.

startDrag(DragGestureEvent, Cursor, Transferable, DragSourceListener, FlavorMap) - Method in class java.awt.dnd.DragSource

Start a drag, given the DragGestureEvent that initiated the drag, the initial Cursor to use, the Transferable subject data of the drag, the DragSourceListener, and the FlavorMap.

startDrag(DragGestureEvent, Cursor, Image, Point, Transferable, DragSourceListener) - Method in class java.awt.dnd.DragSource

Start a drag, given the DragGestureEvent that initiated the drag, the initial Cursor to use, the Image to drag, the offset of the Image origin from the hotspot of the Cursor at the instant of the trigger, the subject data of the drag, and the DragSourceListener.

startDrag(DragGestureEvent, Cursor, Transferable, DragSourceListener) - Method in class java.awt.dnd.DragSource

Start a drag, given the DragGestureEvent that initiated the drag, the initial Cursor to use, the Transferable subject data of the drag, and the DragSourceListener.

startDragging() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI

Should be messaged before the dragging session starts, resets lastDragLocation and dividerSize.

startDTD(String, String, String) - Method in class org.xml.sax.ext.DefaultHandler2

startDTD(String, String, String) - Method in interface org.xml.sax.ext.LexicalHandler

Report the start of DTD declarations, if any.

startEditing(TreePath, MouseEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI

Will start editing for node if there is a cellEditor and shouldSelectCell returns true.

startEditingAtPath(TreePath) - Method in class javax.swing.JTree

Selects the node identified by the specified path and initiates editing.

startEditingAtPath(JTree, TreePath) - Method in class javax.swing.plaf.basic.BasicTreeUI

Selects the last item in path and tries to edit it.

startEditingAtPath(JTree, TreePath) - Method in class javax.swing.plaf.multi.MultiTreeUI

Invokes the startEditingAtPath method on each UI handled by this object.

startEditingAtPath(JTree, TreePath) - Method in class javax.swing.plaf.TreeUI

Selects the last item in path and tries to edit it.

startEditingTimer() - Method in class javax.swing.tree.DefaultTreeCellEditor

Starts the editing timer.

StartElement - Interface in javax.xml.stream.events

The StartElement interface provides access to information about start elements.

startElement(Element) - Method in interface org.w3c.dom.ls.LSParserFilter

The parser will call this method after each Element start tag has been scanned, but before the remainder of the Element is processed.

startElement(String, String, String, Attributes) - Method in interface org.xml.sax.ContentHandler

Receive notification of the beginning of an element.

startElement(String, AttributeList) - Method in interface org.xml.sax.DocumentHandler

Deprecated.

Receive notification of the beginning of an element.

startElement(String, AttributeList) - Method in class org.xml.sax.HandlerBase

Deprecated.

Receive notification of the start of an element.

startElement(String, String, String, Attributes) - Method in class org.xml.sax.helpers.DefaultHandler

Receive notification of the start of an element.

startElement(String, AttributeList) - Method in class org.xml.sax.helpers.ParserAdapter

Adapter implementation method; do not call.

startElement(String, String, String, Attributes) - Method in class org.xml.sax.helpers.XMLFilterImpl

Filter a start element event.

startElement(String, String, String, Attributes) - Method in class org.xml.sax.helpers.XMLReaderAdapter

Adapt a SAX2 start element event.

startEntity(String) - Method in class org.xml.sax.ext.DefaultHandler2

startEntity(String) - Method in interface org.xml.sax.ext.LexicalHandler

Report the beginning of some internal and external XML entities.

startFontTag(String) - Method in class javax.swing.text.html.MinimalHTMLWriter

This is no longer used, instead <span> will be written out.

startGrabbing() - Method in class java.awt.image.PixelGrabber

Request the PixelGrabber to start fetching the pixels.

startHandshake() - Method in class javax.net.ssl.SSLSocket

Starts an SSL handshake on this connection.

startIndex - Variable in class javax.accessibility.AccessibleAttributeSequence

The start index of the text sequence

startIndex - Variable in class javax.accessibility.AccessibleTextSequence

The start index of the text sequence

startPrefixMapping(String, String) - Method in interface org.xml.sax.ContentHandler

Begin the scope of a prefix-URI Namespace mapping.

startPrefixMapping(String, String) - Method in class org.xml.sax.helpers.DefaultHandler

Receive notification of the start of a Namespace mapping.

startPrefixMapping(String, String) - Method in class org.xml.sax.helpers.XMLFilterImpl

Filter a start Namespace prefix mapping event.

startPrefixMapping(String, String) - Method in class org.xml.sax.helpers.XMLReaderAdapter

Adapt a SAX2 start prefix mapping event.

startProduction(ImageConsumer) - Method in class java.awt.image.FilteredImageSource

Starts production of the filtered image.

startProduction(ImageConsumer) - Method in interface java.awt.image.ImageProducer

Registers the specified ImageConsumer object as a consumer and starts an immediate reconstruction of the image data which will then be delivered to this consumer and any other consumer which might have already been registered with the producer.

startProduction(ImageConsumer) - Method in class java.awt.image.MemoryImageSource

Adds an ImageConsumer to the list of consumers interested in data for this image and immediately starts delivery of the image data through the ImageConsumer interface.

startProduction(ImageConsumer) - Method in class java.awt.image.renderable.RenderableImageProducer

Adds an ImageConsumer to the list of consumers interested in data for this image, and immediately starts delivery of the image data through the ImageConsumer interface.

startRecording() - Method in interface javax.sound.midi.Sequencer

Starts recording and playback of MIDI data.

startsWith(String, int) - Method in class java.lang.String

Tests if the substring of this string beginning at the specified index starts with the specified prefix.

startsWith(String) - Method in class java.lang.String

Tests if this string starts with the specified prefix.

startsWith(Path) - Method in interface java.nio.file.Path

Tests if this path starts with the given path.

startsWith(String) - Method in interface java.nio.file.Path

Tests if this path starts with a Path, constructed by converting the given path string, in exactly the manner specified by the startsWith(Path) method.

startsWith(Name) - Method in class javax.naming.CompositeName

Determines whether a composite name is a prefix of this composite name.

startsWith(Name) - Method in class javax.naming.CompoundName

Determines whether a compound name is a prefix of this compound name.

startsWith(Name) - Method in class javax.naming.ldap.LdapName

Determines whether this LDAP name starts with a specified LDAP name prefix.

startsWith(List<Rdn>) - Method in class javax.naming.ldap.LdapName

Determines whether the specified RDN sequence forms a prefix of this LDAP name.

startsWith(Name) - Method in interface javax.naming.Name

Determines whether this name starts with a specified prefix.

startTag(Element) - Method in class javax.swing.text.html.HTMLWriter

Writes out a start tag for the element.

STARTTAG - Static variable in interface javax.swing.text.html.parser.DTDConstants

startTag(TagElement) - Method in class javax.swing.text.html.parser.Parser

Handle a start tag.

StartTagType - Static variable in class javax.swing.text.DefaultStyledDocument.ElementSpec

A possible value for getType.

startTimer() - Method in class javax.swing.plaf.basic.BasicTreeUI.ComponentHandler

Creates, if necessary, and starts a Timer to check if need to resize the bounds.

StartTlsRequest - Class in javax.naming.ldap

This class implements the LDAPv3 Extended Request for StartTLS as defined in Lightweight Directory Access Protocol (v3): Extension for Transport Layer Security The object identifier for StartTLS is 1.3.6.1.4.1.1466.20037 and no extended request value is defined.

StartTlsRequest() - Constructor for class javax.naming.ldap.StartTlsRequest

Constructs a StartTLS extended request.

StartTlsResponse - Class in javax.naming.ldap

This class implements the LDAPv3 Extended Response for StartTLS as defined in Lightweight Directory Access Protocol (v3): Extension for Transport Layer Security The object identifier for StartTLS is 1.3.6.1.4.1.1466.20037 and no extended response value is defined.

StartTlsResponse() - Constructor for class javax.naming.ldap.StartTlsResponse

Constructs a StartTLS extended response.

state - Variable in class java.security.Signature

Current state of this signature object.

State<T extends JComponent> - Class in javax.swing.plaf.nimbus

Represents a built in, or custom, state in Nimbus.

State(String) - Constructor for class javax.swing.plaf.nimbus.State

Create a new custom State.

state() - Method in interface org.omg.PortableInterceptor.IORInfoOperations

Return the adapter state of the object adapter that was just created and is running IOR interceptors.

State - Class in org.omg.PortableServer.POAManagerPackage

Specifies the states for the POAManager

State(int) - Constructor for class org.omg.PortableServer.POAManagerPackage.State

STATE_FACTORIES - Static variable in interface javax.naming.Context

Constant that holds the name of the environment property for specifying the list of state factories to use.

stateChanged(ChangeEvent) - Method in class javax.swing.AbstractButton.ButtonChangeListener

stateChanged(ChangeEvent) - Method in interface javax.swing.event.ChangeListener

Invoked when the target of the listener has changed its state.

stateChanged(ChangeEvent) - Method in class javax.swing.JMenuItem.AccessibleJMenuItem

Supports the change listener interface and fires property changes.

stateChanged(ChangeEvent) - Method in class javax.swing.JScrollPane.AccessibleJScrollPane

Invoked when the target of the listener has changed its state.

stateChanged(ChangeEvent) - Method in class javax.swing.JSpinner.AccessibleJSpinner

Invoked when the target of the listener has changed its state.

stateChanged(ChangeEvent) - Method in class javax.swing.JSpinner.DefaultEditor

This method is called when the spinner's model's state changes.

stateChanged(ChangeEvent) - Method in class javax.swing.JTabbedPane.AccessibleJTabbedPane

stateChanged(ChangeEvent) - Method in class javax.swing.JTabbedPane.ModelListener

stateChanged(ChangeEvent) - Method in class javax.swing.plaf.basic.BasicButtonListener

stateChanged(ChangeEvent) - Method in class javax.swing.plaf.basic.BasicMenuUI.ChangeHandler

stateChanged(ChangeEvent) - Method in class javax.swing.plaf.basic.BasicProgressBarUI.ChangeHandler

stateChanged(ChangeEvent) - Method in class javax.swing.plaf.basic.BasicScrollBarUI.ModelListener

stateChanged(ChangeEvent) - Method in class javax.swing.plaf.basic.BasicScrollPaneUI.HSBChangeListener

stateChanged(ChangeEvent) - Method in class javax.swing.plaf.basic.BasicScrollPaneUI.ViewportChangeHandler

stateChanged(ChangeEvent) - Method in class javax.swing.plaf.basic.BasicScrollPaneUI.VSBChangeListener

stateChanged(ChangeEvent) - Method in class javax.swing.plaf.basic.BasicSliderUI.ChangeHandler

stateChanged(ChangeEvent) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI.TabSelectionHandler

stateChanged(ChangeEvent) - Method in class javax.swing.ProgressMonitor.AccessibleProgressMonitor

Invoked when the target of the listener has changed its state.

StateEdit - Class in javax.swing.undo

StateEdit is a general edit for objects that change state.

StateEdit(StateEditable) - Constructor for class javax.swing.undo.StateEdit

Create and return a new StateEdit.

StateEdit(StateEditable, String) - Constructor for class javax.swing.undo.StateEdit

Create and return a new StateEdit with a presentation name.

StateEditable - Interface in javax.swing.undo

StateEditable defines the interface for objects that can have their state undone/redone by a StateEdit.

StateFactory - Interface in javax.naming.spi

This interface represents a factory for obtaining the state of an object for binding.

stateMask - Variable in class javax.swing.DefaultButtonModel

The bitmask used to store the state of the button.

STATEMENT - Static variable in class java.awt.PageAttributes.MediaType

An alias for INVOICE.

Statement - Class in java.beans

A Statement object represents a primitive statement in which a single method is applied to a target and a set of arguments - as in "a.setFoo(b)".

Statement(Object, String, Object[]) - Constructor for class java.beans.Statement

Creates a new Statement object for the specified target object to invoke the method specified by the name and by the array of arguments.

Statement - Interface in java.sql

The object used for executing a static SQL statement and returning the results it produces.

statementClosed(StatementEvent) - Method in interface javax.sql.StatementEventListener

The driver calls this method on all StatementEventListeners registered on the connection when it detects that a PreparedStatement is closed.

statementErrorOccurred(StatementEvent) - Method in interface javax.sql.StatementEventListener

The driver calls this method on all StatementEventListeners registered on the connection when it detects that a PreparedStatement is invalid.

StatementEvent - Class in javax.sql

A StatementEvent is sent to all StatementEventListeners which were registered with a PooledConnection.

StatementEvent(PooledConnection, PreparedStatement) - Constructor for class javax.sql.StatementEvent

Constructs a StatementEvent with the specified PooledConnection and PreparedStatement.

StatementEvent(PooledConnection, PreparedStatement, SQLException) - Constructor for class javax.sql.StatementEvent

Constructs a StatementEvent with the specified PooledConnection, PreparedStatement and SQLException

StatementEventListener - Interface in javax.sql

An object that registers to be notified of events that occur on PreparedStatements that are in the Statement pool.

states - Variable in class javax.accessibility.AccessibleStateSet

Each entry in the Vector represents an AccessibleState.

STATIC - Static variable in class java.lang.reflect.Modifier

The int value representing the static modifier.

STATICIMAGEDONE - Static variable in interface java.awt.image.ImageConsumer

The image is complete and there are no more pixels or frames to be delivered.

status() - Method in class java.awt.image.PixelGrabber

Returns the status of the pixels.

STATUS_BAR - Static variable in class javax.accessibility.AccessibleRole

A STATUS_BAR is an simple component that can contain multiple labels of status information to the user.

statusAll(boolean) - Method in class java.awt.MediaTracker

Calculates and returns the bitwise inclusive OR of the status of all media that are tracked by this media tracker.

statusID(int, boolean) - Method in class java.awt.MediaTracker

Calculates and returns the bitwise inclusive OR of the status of all media with the specified identifier that are tracked by this media tracker.

StAXResult - Class in javax.xml.transform.stax

Acts as a holder for an XML Result in the form of a StAX writer,i.e.

StAXResult(XMLEventWriter) - Constructor for class javax.xml.transform.stax.StAXResult

Creates a new instance of a StAXResult by supplying an XMLEventWriter.

StAXResult(XMLStreamWriter) - Constructor for class javax.xml.transform.stax.StAXResult

Creates a new instance of a StAXResult by supplying an XMLStreamWriter.

StAXSource - Class in javax.xml.transform.stax

Acts as a holder for an XML Source in the form of a StAX reader,i.e.

StAXSource(XMLEventReader) - Constructor for class javax.xml.transform.stax.StAXSource

Creates a new instance of a StAXSource by supplying an XMLEventReader.

StAXSource(XMLStreamReader) - Constructor for class javax.xml.transform.stax.StAXSource

Creates a new instance of a StAXSource by supplying an XMLStreamReader.

StdACChrominance - Static variable in class javax.imageio.plugins.jpeg.JPEGHuffmanTable

The standard AC chrominance Huffman table.

StdACLuminance - Static variable in class javax.imageio.plugins.jpeg.JPEGHuffmanTable

The standard AC luminance Huffman table.

StdDCChrominance - Static variable in class javax.imageio.plugins.jpeg.JPEGHuffmanTable

The standard DC chrominance Huffman table.

StdDCLuminance - Static variable in class javax.imageio.plugins.jpeg.JPEGHuffmanTable

The standard DC luminance Huffman table.

stillInsideTimerAction() - Constructor for class javax.swing.ToolTipManager.stillInsideTimerAction

stop() - Method in class java.applet.Applet

Called by the browser or applet viewer to inform this applet that it should stop its execution.

stop() - Method in interface java.applet.AudioClip

Stops playing this audio clip.

stop() - Method in class java.awt.dnd.DropTarget.DropTargetAutoScroller

cause autoscrolling to stop

stop() - Method in class java.lang.Thread

Deprecated.
This method is inherently unsafe. Stopping a thread with Thread.stop causes it to unlock all of the monitors that it has locked (as a natural consequence of the unchecked ThreadDeath exception propagating up the stack). If any of the objects previously protected by these monitors were in an inconsistent state, the damaged objects become visible to other threads, potentially resulting in arbitrary behavior. Many uses of stop should be replaced by code that simply modifies some variable to indicate that the target thread should stop running. The target thread should check this variable regularly, and return from its run method in an orderly fashion if the variable indicates that it is to stop running. If the target thread waits for long periods (on a condition variable, for example), the interrupt method should be used to interrupt the wait. For more information, see Why are Thread.stop, Thread.suspend and Thread.resume Deprecated?.

stop(Throwable) - Method in class java.lang.Thread

Deprecated.
This method was originally designed to force a thread to stop and throw a given Throwable as an exception. It was inherently unsafe (see Thread.stop() for details), and furthermore could be used to generate exceptions that the target thread was not prepared to handle. For more information, see Why are Thread.stop, Thread.suspend and Thread.resume Deprecated?.

stop() - Method in class java.lang.ThreadGroup

Deprecated.
This method is inherently unsafe. See Thread.stop() for details.

stop() - Method in class javax.management.monitor.CounterMonitor

Stops the counter monitor.

stop() - Method in class javax.management.monitor.GaugeMonitor

Stops the gauge monitor.

stop() - Method in class javax.management.monitor.Monitor

Stops the monitor.

stop() - Method in interface javax.management.monitor.MonitorMBean

Stops the monitor.

stop() - Method in class javax.management.monitor.StringMonitor

Stops the string monitor.

stop() - Method in interface javax.management.remote.JMXConnectorServerMBean

Deactivates the connector server, that is, stops listening for client connections.

stop() - Method in class javax.management.remote.rmi.RMIConnectorServer

Deactivates the connector server, that is, stops listening for client connections.

stop() - Method in class javax.management.timer.Timer

Stops the timer.

stop() - Method in interface javax.management.timer.TimerMBean

Stops the timer.

stop() - Method in interface javax.sound.midi.Sequencer

Stops recording, if active, and playback of the currently loaded sequence, if any.

STOP - Static variable in class javax.sound.midi.ShortMessage

Status byte for Stop message (0xFC, or 252).

stop() - Method in interface javax.sound.sampled.DataLine

Stops the line.

STOP - Static variable in class javax.sound.sampled.LineEvent.Type

A type of event that is sent when a line ceases active input or output of audio data in response to a stop request, or because the end of media has been reached.

stop() - Method in class javax.swing.Timer

Stops the Timer, causing it to stop sending action events to its listeners.

stop() - Method in class javax.xml.ws.Endpoint

Stops publishing this endpoint.

stopAnimationTimer() - Method in class javax.swing.plaf.basic.BasicProgressBarUI

Stops the animation thread.

stopAutoScrolling() - Method in class javax.swing.plaf.basic.BasicComboPopup

This protected method is implementation specific and should be private.

stopCellEditing() - Method in class javax.swing.AbstractCellEditor

Calls fireEditingStopped and returns true.

stopCellEditing() - Method in interface javax.swing.CellEditor

Tells the editor to stop editing and accept any partially edited value as the value of the editor.

stopCellEditing() - Method in class javax.swing.DefaultCellEditor.EditorDelegate

Stops editing and returns true to indicate that editing has stopped.

stopCellEditing() - Method in class javax.swing.DefaultCellEditor

Forwards the message from the CellEditor to the delegate.

stopCellEditing() - Method in class javax.swing.tree.DefaultTreeCellEditor

If the realEditor will allow editing to stop, the realEditor is removed and true is returned, otherwise false is returned.

stopEditing() - Method in class javax.swing.JTree

Ends the current editing session.

stopEditing(JTree) - Method in class javax.swing.plaf.basic.BasicTreeUI

Stops the current editing session.

stopEditing(JTree) - Method in class javax.swing.plaf.multi.MultiTreeUI

Invokes the stopEditing method on each UI handled by this object.

stopEditing(JTree) - Method in class javax.swing.plaf.TreeUI

Stops the current editing session.

stopEditingInCompleteEditing - Variable in class javax.swing.plaf.basic.BasicTreeUI

Set to false when editing and shouldSelectCell() returns true meaning the node should be selected before editing, used in completeEditing.

STOPPED - Static variable in class javax.print.attribute.standard.PrinterState

Indicates that no jobs can be processed and intervention is required.

STOPPED_PARTLY - Static variable in class javax.print.attribute.standard.PrinterStateReason

When a printer controls more than one output device, this reason indicates that one or more output devices are stopped.

STOPPING - Static variable in class javax.print.attribute.standard.PrinterStateReason

The printer is in the process of stopping the device and will be stopped in a while.

stopPropagation() - Method in interface org.w3c.dom.events.Event

The stopPropagation method is used prevent further propagation of an event during event flow.

stopRecording() - Method in interface javax.sound.midi.Sequencer

Stops recording, if active.

store(OutputStream, char[]) - Method in class java.security.KeyStore

Stores this keystore to the given output stream, and protects its integrity with the given password.

store(KeyStore.LoadStoreParameter) - Method in class java.security.KeyStore

Stores this keystore using the given LoadStoreParameter.

store(Writer, String) - Method in class java.util.Properties

Writes this property list (key and element pairs) in this Properties table to the output character stream in a format suitable for using the load(Reader) method.

store(OutputStream, String) - Method in class java.util.Properties

Writes this property list (key and element pairs) in this Properties table to the output stream in a format suitable for loading into a Properties table using the load(InputStream) method.

store() - Method in class javax.management.modelmbean.RequiredModelMBean

Captures the current state of this MBean instance and writes it out to the persistent store.

store() - Method in interface javax.management.PersistentMBean

Captures the current state of this MBean instance and writes it out to the persistent store.

STORED - Static variable in class java.util.zip.ZipEntry

Compression method for uncompressed entries.

STORED - Static variable in class java.util.zip.ZipOutputStream

Compression method for uncompressed (STORED) entries.

storesLowerCaseIdentifiers() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database treats mixed case unquoted SQL identifiers as case insensitive and stores them in lower case.

storesLowerCaseQuotedIdentifiers() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database treats mixed case quoted SQL identifiers as case insensitive and stores them in lower case.

storesMixedCaseIdentifiers() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database treats mixed case unquoted SQL identifiers as case insensitive and stores them in mixed case.

storesMixedCaseQuotedIdentifiers() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database treats mixed case quoted SQL identifiers as case insensitive and stores them in mixed case.

storeState(Hashtable<Object, Object>) - Method in interface javax.swing.undo.StateEditable

Upon receiving this message the receiver should place any relevant state into state.

storesUpperCaseIdentifiers() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database treats mixed case unquoted SQL identifiers as case insensitive and stores them in upper case.

storesUpperCaseQuotedIdentifiers() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database treats mixed case quoted SQL identifiers as case insensitive and stores them in upper case.

storeToXML(OutputStream, String) - Method in class java.util.Properties

Emits an XML document representing all of the properties contained in this table.

storeToXML(OutputStream, String, String) - Method in class java.util.Properties

Emits an XML document representing all of the properties contained in this table, using the specified encoding.

strategy - Variable in class javax.swing.text.FlowView

The behavior for keeping the flow updated.

stream(T[]) - Static method in class java.util.Arrays

Returns a sequential Stream with the specified array as its source.

stream(T[], int, int) - Static method in class java.util.Arrays

Returns a sequential Stream with the specified range of the specified array as its source.

stream(int[]) - Static method in class java.util.Arrays

Returns a sequential IntStream with the specified array as its source.

stream(int[], int, int) - Static method in class java.util.Arrays

Returns a sequential IntStream with the specified range of the specified array as its source.

stream(long[]) - Static method in class java.util.Arrays

Returns a sequential LongStream with the specified array as its source.

stream(long[], int, int) - Static method in class java.util.Arrays

Returns a sequential LongStream with the specified range of the specified array as its source.

stream(double[]) - Static method in class java.util.Arrays

Returns a sequential DoubleStream with the specified array as its source.

stream(double[], int, int) - Static method in class java.util.Arrays

Returns a sequential DoubleStream with the specified range of the specified array as its source.

stream() - Method in class java.util.BitSet

Returns a stream of indices for which this BitSet contains a bit in the set state.

stream() - Method in interface java.util.Collection

Returns a sequential Stream with this collection as its source.

stream() - Method in class java.util.jar.JarFile

Stream<T> - Interface in java.util.stream

A sequence of elements supporting sequential and parallel aggregate operations.

stream(Spliterator<T>, boolean) - Static method in class java.util.stream.StreamSupport

Creates a new sequential or parallel Stream from a Spliterator.

stream(Supplier<? extends Spliterator<T>>, int, boolean) - Static method in class java.util.stream.StreamSupport

Creates a new sequential or parallel Stream from a Supplier of Spliterator.

stream() - Method in class java.util.zip.ZipFile

Return an ordered Stream over the ZIP file entries.

Stream.Builder<T> - Interface in java.util.stream

A mutable builder for a Stream.

STREAM_MAGIC - Static variable in interface java.io.ObjectStreamConstants

Magic number that is written to the stream header.

STREAM_VERSION - Static variable in interface java.io.ObjectStreamConstants

Version number that is written to the stream header.

Streamable - Interface in org.omg.CORBA.portable

The base class for the Holder classess of all complex IDL types.

StreamableValue - Interface in org.omg.CORBA.portable

Defines the base type for all non-boxed IDL valuetypes that are not custom marshaled.

StreamCorruptedException - Exception in java.io

Thrown when control information that was read from an object stream violates internal consistency checks.

StreamCorruptedException(String) - Constructor for exception java.io.StreamCorruptedException

Create a StreamCorruptedException and list a reason why thrown.

StreamCorruptedException() - Constructor for exception java.io.StreamCorruptedException

Create a StreamCorruptedException and list no reason why thrown.

StreamDescriptionProperty - Static variable in interface javax.swing.text.Document

The property name for the description of the stream used to initialize the document.

StreamFilter - Interface in javax.xml.stream

This interface declares a simple filter interface that one can create to filter XMLStreamReaders

StreamHandler - Class in java.util.logging

Stream based logging Handler.

StreamHandler() - Constructor for class java.util.logging.StreamHandler

Create a StreamHandler, with no current output stream.

StreamHandler(OutputStream, Formatter) - Constructor for class java.util.logging.StreamHandler

Create a StreamHandler with a given Formatter and output stream.

streamPos - Variable in class javax.imageio.stream.ImageInputStreamImpl

The current read position within the stream.

StreamPrintService - Class in javax.print

This class extends PrintService and represents a print service that prints data in different formats to a client-provided output stream.

StreamPrintService(OutputStream) - Constructor for class javax.print.StreamPrintService

Constructs a StreamPrintService object.

StreamPrintServiceFactory - Class in javax.print

A StreamPrintServiceFactory is the factory for StreamPrintService instances, which can print to an output stream in a particular document format described as a mime type.

StreamPrintServiceFactory() - Constructor for class javax.print.StreamPrintServiceFactory

StreamReaderDelegate - Class in javax.xml.stream.util

This is the base class for deriving an XMLStreamReader filter This class is designed to sit between an XMLStreamReader and an application's XMLStreamReader.

StreamReaderDelegate() - Constructor for class javax.xml.stream.util.StreamReaderDelegate

Construct an empty filter with no parent.

StreamReaderDelegate(XMLStreamReader) - Constructor for class javax.xml.stream.util.StreamReaderDelegate

Construct an filter with the specified parent.

StreamResult - Class in javax.xml.transform.stream

Acts as an holder for a transformation result, which may be XML, plain Text, HTML, or some other form of markup.

StreamResult() - Constructor for class javax.xml.transform.stream.StreamResult

Zero-argument default constructor.

StreamResult(OutputStream) - Constructor for class javax.xml.transform.stream.StreamResult

Construct a StreamResult from a byte stream.

StreamResult(Writer) - Constructor for class javax.xml.transform.stream.StreamResult

Construct a StreamResult from a character stream.

StreamResult(String) - Constructor for class javax.xml.transform.stream.StreamResult

Construct a StreamResult from a URL.

StreamResult(File) - Constructor for class javax.xml.transform.stream.StreamResult

Construct a StreamResult from a File.

StreamSource - Class in javax.xml.transform.stream

Acts as an holder for a transformation Source in the form of a stream of XML markup.

StreamSource() - Constructor for class javax.xml.transform.stream.StreamSource

Zero-argument default constructor.

StreamSource(InputStream) - Constructor for class javax.xml.transform.stream.StreamSource

Construct a StreamSource from a byte stream.

StreamSource(InputStream, String) - Constructor for class javax.xml.transform.stream.StreamSource

Construct a StreamSource from a byte stream.

StreamSource(Reader) - Constructor for class javax.xml.transform.stream.StreamSource

Construct a StreamSource from a character reader.

StreamSource(Reader, String) - Constructor for class javax.xml.transform.stream.StreamSource

Construct a StreamSource from a character reader.

StreamSource(String) - Constructor for class javax.xml.transform.stream.StreamSource

Construct a StreamSource from a URL.

StreamSource(File) - Constructor for class javax.xml.transform.stream.StreamSource

Construct a StreamSource from a File.

StreamSupport - Class in java.util.stream

Low-level utility methods for creating and manipulating streams.

StreamTokenizer - Class in java.io

The StreamTokenizer class takes an input stream and parses it into "tokens", allowing the tokens to be read one at a time.

StreamTokenizer(InputStream) - Constructor for class java.io.StreamTokenizer

Deprecated.
As of JDK version 1.1, the preferred way to tokenize an input stream is to convert it into a character stream, for example:
   Reader r = new BufferedReader(new InputStreamReader(is));
   StreamTokenizer st = new StreamTokenizer(r);
StreamTokenizer(Reader) - Constructor for class java.io.StreamTokenizer

Create a tokenizer that parses the given character stream.

STRENGTH - Static variable in class javax.security.sasl.Sasl

The name of a property that specifies the cipher strength to use.

STRICT - Static variable in class java.lang.reflect.Modifier

The int value representing the strictfp modifier.

strict - Variable in class javax.swing.text.html.parser.Parser

This flag determines whether or not the Parser will be strict in enforcing SGML compatibility.

StrictMath - Class in java.lang

The class StrictMath contains methods for performing basic numeric operations such as the elementary exponential, logarithm, square root, and trigonometric functions.

STRIKE - Static variable in class javax.swing.text.html.HTML.Tag

STRIKETHROUGH - Static variable in class java.awt.font.TextAttribute

Attribute key for strikethrough.

StrikeThrough - Static variable in class javax.swing.text.StyleConstants

Name of the Strikethrough attribute.

STRIKETHROUGH_ON - Static variable in class java.awt.font.TextAttribute

A single strikethrough.

String - Class in java.lang

The String class represents character strings.

String() - Constructor for class java.lang.String

Initializes a newly created String object so that it represents an empty character sequence.

String(String) - Constructor for class java.lang.String

Initializes a newly created String object so that it represents the same sequence of characters as the argument; in other words, the newly created string is a copy of the argument string.

String(char[]) - Constructor for class java.lang.String

Allocates a new String so that it represents the sequence of characters currently contained in the character array argument.

String(char[], int, int) - Constructor for class java.lang.String

Allocates a new String that contains characters from a subarray of the character array argument.

String(int[], int, int) - Constructor for class java.lang.String

Allocates a new String that contains characters from a subarray of the Unicode code point array argument.

String(byte[], int, int, int) - Constructor for class java.lang.String

Deprecated.
This method does not properly convert bytes into characters. As of JDK 1.1, the preferred way to do this is via the String constructors that take a Charset, charset name, or that use the platform's default charset.

String(byte[], int) - Constructor for class java.lang.String

Deprecated.
This method does not properly convert bytes into characters. As of JDK 1.1, the preferred way to do this is via the String constructors that take a Charset, charset name, or that use the platform's default charset.

String(byte[], int, int, String) - Constructor for class java.lang.String

Constructs a new String by decoding the specified subarray of bytes using the specified charset.

String(byte[], int, int, Charset) - Constructor for class java.lang.String

Constructs a new String by decoding the specified subarray of bytes using the specified charset.

String(byte[], String) - Constructor for class java.lang.String

Constructs a new String by decoding the specified array of bytes using the specified charset.

String(byte[], Charset) - Constructor for class java.lang.String

Constructs a new String by decoding the specified array of bytes using the specified charset.

String(byte[], int, int) - Constructor for class java.lang.String

Constructs a new String by decoding the specified subarray of bytes using the platform's default charset.

String(byte[]) - Constructor for class java.lang.String

Constructs a new String by decoding the specified array of bytes using the platform's default charset.

String(StringBuffer) - Constructor for class java.lang.String

Allocates a new string that contains the sequence of characters currently contained in the string buffer argument.

String(StringBuilder) - Constructor for class java.lang.String

Allocates a new string that contains the sequence of characters currently contained in the string builder argument.

STRING - Static variable in class javax.management.openmbean.SimpleType

The SimpleType instance describing values whose Java class name is java.lang.String.

STRING(String) - Constructor for class javax.print.DocFlavor.STRING

Constructs a new doc flavor with the given MIME type and a print data representation class name of "java.lang.String".

STRING - Static variable in class javax.xml.xpath.XPathConstants

The XPath 1.0 string data type.

STRING_TO_COMPARE_VALUE_DIFFERED - Static variable in class javax.management.monitor.MonitorNotification

Notification type denoting that the observed attribute has differed from the "string to compare" value.

STRING_TO_COMPARE_VALUE_MATCHED - Static variable in class javax.management.monitor.MonitorNotification

Notification type denoting that the observed attribute has matched the "string to compare" value.

string_to_object(String) - Method in class org.omg.CORBA.ORB

Converts a string produced by the method object_to_string back to a CORBA object reference.

StringBuffer - Class in java.lang

A thread-safe, mutable sequence of characters.

StringBuffer() - Constructor for class java.lang.StringBuffer

Constructs a string buffer with no characters in it and an initial capacity of 16 characters.

StringBuffer(int) - Constructor for class java.lang.StringBuffer

Constructs a string buffer with no characters in it and the specified initial capacity.

StringBuffer(String) - Constructor for class java.lang.StringBuffer

Constructs a string buffer initialized to the contents of the specified string.

StringBuffer(CharSequence) - Constructor for class java.lang.StringBuffer

Constructs a string buffer that contains the same characters as the specified CharSequence.

StringBufferInputStream - Class in java.io

Deprecated.
This class does not properly convert characters into bytes. As of JDK 1.1, the preferred way to create a stream from a string is via the StringReader class.

StringBufferInputStream(String) - Constructor for class java.io.StringBufferInputStream

Deprecated.

Creates a string input stream to read data from the specified string.

StringBuilder - Class in java.lang

A mutable sequence of characters.

StringBuilder() - Constructor for class java.lang.StringBuilder

Constructs a string builder with no characters in it and an initial capacity of 16 characters.

StringBuilder(int) - Constructor for class java.lang.StringBuilder

Constructs a string builder with no characters in it and an initial capacity specified by the capacity argument.

StringBuilder(String) - Constructor for class java.lang.StringBuilder

Constructs a string builder initialized to the contents of the specified string.

StringBuilder(CharSequence) - Constructor for class java.lang.StringBuilder

Constructs a string builder that contains the same characters as the specified CharSequence.

StringCharacterIterator - Class in java.text

StringCharacterIterator implements the CharacterIterator protocol for a String.

StringCharacterIterator(String) - Constructor for class java.text.StringCharacterIterator

Constructs an iterator with an initial index of 0.

StringCharacterIterator(String, int) - Constructor for class java.text.StringCharacterIterator

Constructs an iterator with the specified initial index.

StringCharacterIterator(String, int, int, int) - Constructor for class java.text.StringCharacterIterator

Constructs an iterator over the given range of the given string, with the index set at the specified position.

StringContent - Class in javax.swing.text

An implementation of the AbstractDocument.Content interface that is a brute force implementation that is useful for relatively small documents and/or debugging.

StringContent() - Constructor for class javax.swing.text.StringContent

Creates a new StringContent object.

StringContent(int) - Constructor for class javax.swing.text.StringContent

Creates a new StringContent object, with the initial size specified.

stringFlavor - Static variable in class java.awt.datatransfer.DataFlavor

The DataFlavor representing a Java Unicode String class, where:

StringHolder - Class in org.omg.CORBA

The Holder for String.

StringHolder() - Constructor for class org.omg.CORBA.StringHolder

Constructs a new StringHolder object with its value field initialized to null.

StringHolder(String) - Constructor for class org.omg.CORBA.StringHolder

Constructs a new StringHolder object with its value field initialized to the given String.

StringIndexOutOfBoundsException - Exception in java.lang

Thrown by String methods to indicate that an index is either negative or greater than the size of the string.

StringIndexOutOfBoundsException() - Constructor for exception java.lang.StringIndexOutOfBoundsException

Constructs a StringIndexOutOfBoundsException with no detail message.

StringIndexOutOfBoundsException(String) - Constructor for exception java.lang.StringIndexOutOfBoundsException

Constructs a StringIndexOutOfBoundsException with the specified detail message.

StringIndexOutOfBoundsException(int) - Constructor for exception java.lang.StringIndexOutOfBoundsException

Constructs a new StringIndexOutOfBoundsException class with an argument indicating the illegal index.

StringJoiner - Class in java.util

StringJoiner is used to construct a sequence of characters separated by a delimiter and optionally starting with a supplied prefix and ending with a supplied suffix.

StringJoiner(CharSequence) - Constructor for class java.util.StringJoiner

Constructs a StringJoiner with no characters in it, with no prefix or suffix, and a copy of the supplied delimiter.

StringJoiner(CharSequence, CharSequence, CharSequence) - Constructor for class java.util.StringJoiner

Constructs a StringJoiner with no characters in it using copies of the supplied prefix, delimiter and suffix.

StringMonitor - Class in javax.management.monitor

Defines a monitor MBean designed to observe the values of a string attribute.

StringMonitor() - Constructor for class javax.management.monitor.StringMonitor

Default constructor.

StringMonitorMBean - Interface in javax.management.monitor

Exposes the remote management interface of the string monitor MBean.

StringNameHelper - Class in org.omg.CosNaming.NamingContextExtPackage

StringName is the Stringified Name, Array of Name Components represented as a String.

StringNameHelper() - Constructor for class org.omg.CosNaming.NamingContextExtPackage.StringNameHelper

stringPropertyNames() - Method in class java.util.Properties

Returns a set of keys in this property list where the key and its corresponding value are strings, including distinct keys in the default property list if a key of the same name has not already been found from the main properties list.

StringReader - Class in java.io

A character stream whose source is a string.

StringReader(String) - Constructor for class java.io.StringReader

Creates a new string reader.

StringRefAddr - Class in javax.naming

This class represents the string form of the address of a communications end-point.

StringRefAddr(String, String) - Constructor for class javax.naming.StringRefAddr

Constructs a new instance of StringRefAddr using its address type and contents.

StringSelection - Class in java.awt.datatransfer

A Transferable which implements the capability required to transfer a String.

StringSelection(String) - Constructor for class java.awt.datatransfer.StringSelection

Creates a Transferable capable of transferring the specified String.

StringSeqHelper - Class in org.omg.CORBA

An array of Strings

StringSeqHelper() - Constructor for class org.omg.CORBA.StringSeqHelper

StringSeqHolder - Class in org.omg.CORBA

An array of Strings

StringSeqHolder() - Constructor for class org.omg.CORBA.StringSeqHolder

StringSeqHolder(String[]) - Constructor for class org.omg.CORBA.StringSeqHolder

stringToColor(String) - Method in class javax.swing.text.html.StyleSheet

Converts a color string such as "RED" or "#NNNNNN" to a Color.

StringTokenizer - Class in java.util

The string tokenizer class allows an application to break a string into tokens.

StringTokenizer(String, String, boolean) - Constructor for class java.util.StringTokenizer

Constructs a string tokenizer for the specified string.

StringTokenizer(String, String) - Constructor for class java.util.StringTokenizer

Constructs a string tokenizer for the specified string.

StringTokenizer(String) - Constructor for class java.util.StringTokenizer

Constructs a string tokenizer for the specified string.

stringToValue(String) - Method in class javax.swing.JFormattedTextField.AbstractFormatter

Parses text returning an arbitrary Object.

stringToValue(String) - Method in class javax.swing.text.DefaultFormatter

Converts the passed in String into an instance of getValueClass by way of the constructor that takes a String argument.

stringToValue(String) - Method in class javax.swing.text.InternationalFormatter

Returns the Object representation of the String text.

stringToValue(String) - Method in class javax.swing.text.MaskFormatter

Parses the text, returning the appropriate Object representation of the String value.

StringValueExp - Class in javax.management

Represents strings that are arguments to relational constraints.

StringValueExp() - Constructor for class javax.management.StringValueExp

Basic constructor.

StringValueExp(String) - Constructor for class javax.management.StringValueExp

Creates a new StringValueExp representing the given string.

StringValueHelper - Class in org.omg.CORBA

The Helper for StringValue.

StringValueHelper() - Constructor for class org.omg.CORBA.StringValueHelper

stringWidth(String) - Method in class java.awt.FontMetrics

Returns the total advance width for showing the specified String in this Font.

StringWriter - Class in java.io

A character stream that collects its output in a string buffer, which can then be used to construct a string.

StringWriter() - Constructor for class java.io.StringWriter

Create a new string writer using the default initial string-buffer size.

StringWriter(int) - Constructor for class java.io.StringWriter

Create a new string writer using the specified initial string-buffer size.

STRIP - Static variable in interface java.util.jar.Pack200.Packer

The string "strip", a possible value for certain properties.

stripExtensions() - Method in class java.util.Locale

Returns a copy of this Locale with no extensions.

stripTrailingZeros() - Method in class java.math.BigDecimal

Returns a BigDecimal which is numerically equal to this one but with any trailing zeros removed from the representation.

STROKE - Static variable in class java.awt.font.ShapeGraphicAttribute

A key indicating the shape should be stroked with a 1-pixel wide stroke.

Stroke - Interface in java.awt

The Stroke interface allows a Graphics2D object to obtain a Shape that is the decorated outline, or stylistic representation of the outline, of the specified Shape.

StrokeBorder - Class in javax.swing.border

A class which implements a border of an arbitrary stroke.

StrokeBorder(BasicStroke) - Constructor for class javax.swing.border.StrokeBorder

Creates a border of the specified stroke.

StrokeBorder(BasicStroke, Paint) - Constructor for class javax.swing.border.StrokeBorder

Creates a border of the specified stroke and paint.

STRONG - Static variable in class javax.swing.text.html.HTML.Tag

Struct - Interface in java.sql

The standard mapping in the Java programming language for an SQL structured type.

STRUCT - Static variable in class java.sql.Types

The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type STRUCT.

StructMember - Class in org.omg.CORBA

Describes a member of an IDL struct in the Interface Repository, including the name of the struct member, the type of the struct member, and the typedef that represents the IDL type of the struct member described the struct member object.

StructMember() - Constructor for class org.omg.CORBA.StructMember

Constructs a default StructMember object.

StructMember(String, TypeCode, IDLType) - Constructor for class org.omg.CORBA.StructMember

Constructs a StructMember object initialized with the given values.

StructMemberHelper - Class in org.omg.CORBA

The Helper for StructMember.

StructMemberHelper() - Constructor for class org.omg.CORBA.StructMemberHelper

Stub - Class in javax.rmi.CORBA

Base class from which all RMI-IIOP stubs must inherit.

Stub() - Constructor for class javax.rmi.CORBA.Stub

StubDelegate - Interface in javax.rmi.CORBA

Supports delegation for method implementations in Stub.

StubNotFoundException - Exception in java.rmi

A StubNotFoundException is thrown if a valid stub class could not be found for a remote object when it is exported.

StubNotFoundException(String) - Constructor for exception java.rmi.StubNotFoundException

Constructs a StubNotFoundException with the specified detail message.

StubNotFoundException(String, Exception) - Constructor for exception java.rmi.StubNotFoundException

Constructs a StubNotFoundException with the specified detail message and nested exception.

style - Variable in class java.awt.Font

The style of this Font, as passed to the constructor.

STYLE - Static variable in class javax.swing.text.html.HTML.Attribute

STYLE - Static variable in class javax.swing.text.html.HTML.Tag

Style - Interface in javax.swing.text

A collection of attributes to associate with an element in a document.

styleChanged(Style) - Method in class javax.swing.text.DefaultStyledDocument

Called when any of this document's styles have changed.

StyleConstants - Class in javax.swing.text

A collection of well known or common attribute keys and methods to apply to an AttributeSet or MutableAttributeSet to get/set the properties in a typesafe manner.

StyleConstants.CharacterConstants - Class in javax.swing.text

This is a typesafe enumeration of the well-known attributes that contribute to a character style.

StyleConstants.ColorConstants - Class in javax.swing.text

This is a typesafe enumeration of the well-known attributes that contribute to a color.

StyleConstants.FontConstants - Class in javax.swing.text

This is a typesafe enumeration of the well-known attributes that contribute to a font.

StyleConstants.ParagraphConstants - Class in javax.swing.text

This is a typesafe enumeration of the well-known attributes that contribute to a paragraph style.

StyleContext - Class in javax.swing.text

A pool of styles and their associated resources.

StyleContext() - Constructor for class javax.swing.text.StyleContext

Creates a new StyleContext object.

StyleContext.NamedStyle - Class in javax.swing.text

A collection of attributes, typically used to represent character and paragraph styles.

StyleContext.SmallAttributeSet - Class in javax.swing.text

This class holds a small number of attributes in an array.

StyledDocument - Interface in javax.swing.text

Interface for a generic styled document.

StyledEditorKit - Class in javax.swing.text

This is the set of things needed by a text component to be a reasonably functioning editor for some type of text document.

StyledEditorKit() - Constructor for class javax.swing.text.StyledEditorKit

Creates a new EditorKit used for styled documents.

StyledEditorKit.AlignmentAction - Class in javax.swing.text

An action to set paragraph alignment.

StyledEditorKit.BoldAction - Class in javax.swing.text

An action to toggle the bold attribute.

StyledEditorKit.FontFamilyAction - Class in javax.swing.text

An action to set the font family in the associated JEditorPane.

StyledEditorKit.FontSizeAction - Class in javax.swing.text

An action to set the font size in the associated JEditorPane.

StyledEditorKit.ForegroundAction - Class in javax.swing.text

An action to set foreground color.

StyledEditorKit.ItalicAction - Class in javax.swing.text

An action to toggle the italic attribute.

StyledEditorKit.StyledTextAction - Class in javax.swing.text

An action that assumes it's being fired on a JEditorPane with a StyledEditorKit (or subclass) installed.

StyledEditorKit.UnderlineAction - Class in javax.swing.text

An action to toggle the underline attribute.

StyledTextAction(String) - Constructor for class javax.swing.text.StyledEditorKit.StyledTextAction

Creates a new StyledTextAction from a string action name.

StyleSheet - Class in javax.swing.text.html

Support for defining the visual characteristics of HTML views being rendered.

StyleSheet() - Constructor for class javax.swing.text.html.StyleSheet

Construct a StyleSheet

StyleSheet.BoxPainter - Class in javax.swing.text.html

Class to carry out some of the duties of CSS formatting.

StyleSheet.ListPainter - Class in javax.swing.text.html

Class to carry out some of the duties of CSS list formatting.

SUB - Static variable in class javax.swing.text.html.HTML.Tag

SUBCLASS_IMPLEMENTATION_PERMISSION - Static variable in interface java.io.ObjectStreamConstants

Enable overriding of readObject and writeObject.

subdivide(CubicCurve2D, CubicCurve2D) - Method in class java.awt.geom.CubicCurve2D

Subdivides this cubic curve and stores the resulting two subdivided curves into the left and right curve parameters.

subdivide(CubicCurve2D, CubicCurve2D, CubicCurve2D) - Static method in class java.awt.geom.CubicCurve2D

Subdivides the cubic curve specified by the src parameter and stores the resulting two subdivided curves into the left and right curve parameters.

subdivide(double[], int, double[], int, double[], int) - Static method in class java.awt.geom.CubicCurve2D

Subdivides the cubic curve specified by the coordinates stored in the src array at indices srcoff through (srcoff + 7) and stores the resulting two subdivided curves into the two result arrays at the corresponding indices.

subdivide(QuadCurve2D, QuadCurve2D) - Method in class java.awt.geom.QuadCurve2D

Subdivides this QuadCurve2D and stores the resulting two subdivided curves into the left and right curve parameters.

subdivide(QuadCurve2D, QuadCurve2D, QuadCurve2D) - Static method in class java.awt.geom.QuadCurve2D

Subdivides the quadratic curve specified by the src parameter and stores the resulting two subdivided curves into the left and right curve parameters.

subdivide(double[], int, double[], int, double[], int) - Static method in class java.awt.geom.QuadCurve2D

Subdivides the quadratic curve specified by the coordinates stored in the src array at indices srcoff through srcoff + 5 and stores the resulting two subdivided curves into the two result arrays at the corresponding indices.

Subject - Class in javax.security.auth

A Subject represents a grouping of related information for a single entity, such as a person.

Subject() - Constructor for class javax.security.auth.Subject

Create an instance of a Subject with an empty Set of Principals and empty Sets of public and private credentials.

Subject(boolean, Set<? extends Principal>, Set<?>, Set<?>) - Constructor for class javax.security.auth.Subject

Create an instance of a Subject with Principals and credentials.

SubjectDelegationPermission - Class in javax.management.remote

Permission required by an authentication identity to perform operations on behalf of an authorization identity.

SubjectDelegationPermission(String) - Constructor for class javax.management.remote.SubjectDelegationPermission

Creates a new SubjectDelegationPermission with the specified name.

SubjectDelegationPermission(String, String) - Constructor for class javax.management.remote.SubjectDelegationPermission

Creates a new SubjectDelegationPermission object with the specified name.

SubjectDomainCombiner - Class in javax.security.auth

A SubjectDomainCombiner updates ProtectionDomains with Principals from the Subject associated with this SubjectDomainCombiner.

SubjectDomainCombiner(Subject) - Constructor for class javax.security.auth.SubjectDomainCombiner

Associate the provided Subject with this SubjectDomainCombiner.

subList(int, int) - Method in class java.util.AbstractList

Returns a view of the portion of this list between the specified fromIndex, inclusive, and toIndex, exclusive.

subList(int, int) - Method in class java.util.ArrayList

Returns a view of the portion of this list between the specified fromIndex, inclusive, and toIndex, exclusive.

subList(int, int) - Method in class java.util.concurrent.CopyOnWriteArrayList

Returns a view of the portion of this list between fromIndex, inclusive, and toIndex, exclusive.

subList(int, int) - Method in interface java.util.List

Returns a view of the portion of this list between the specified fromIndex, inclusive, and toIndex, exclusive.

subList(int, int) - Method in class java.util.Vector

Returns a view of the portion of this List between fromIndex, inclusive, and toIndex, exclusive.

subMap(K, boolean, K, boolean) - Method in interface java.util.concurrent.ConcurrentNavigableMap

subMap(K, K) - Method in interface java.util.concurrent.ConcurrentNavigableMap

subMap(K, boolean, K, boolean) - Method in class java.util.concurrent.ConcurrentSkipListMap

subMap(K, K) - Method in class java.util.concurrent.ConcurrentSkipListMap

subMap(K, boolean, K, boolean) - Method in interface java.util.NavigableMap

Returns a view of the portion of this map whose keys range from fromKey to toKey.

subMap(K, K) - Method in interface java.util.NavigableMap

Returns a view of the portion of this map whose keys range from fromKey, inclusive, to toKey, exclusive.

subMap(K, K) - Method in interface java.util.SortedMap

Returns a view of the portion of this map whose keys range from fromKey, inclusive, to toKey, exclusive.

subMap(K, boolean, K, boolean) - Method in class java.util.TreeMap

subMap(K, K) - Method in class java.util.TreeMap

SUBMISSION_INTERRUPTED - Static variable in class javax.print.attribute.standard.JobStateReason

The job was not completely submitted for some unforeseen reason.

submit(Runnable) - Method in class java.util.concurrent.AbstractExecutorService

submit(Runnable, T) - Method in class java.util.concurrent.AbstractExecutorService

submit(Callable<T>) - Method in class java.util.concurrent.AbstractExecutorService

submit(Callable<V>) - Method in interface java.util.concurrent.CompletionService

Submits a value-returning task for execution and returns a Future representing the pending results of the task.

submit(Runnable, V) - Method in interface java.util.concurrent.CompletionService

Submits a Runnable task for execution and returns a Future representing that task.

submit(Callable<V>) - Method in class java.util.concurrent.ExecutorCompletionService

submit(Runnable, V) - Method in class java.util.concurrent.ExecutorCompletionService

submit(Callable<T>) - Method in interface java.util.concurrent.ExecutorService

Submits a value-returning task for execution and returns a Future representing the pending results of the task.

submit(Runnable, T) - Method in interface java.util.concurrent.ExecutorService

Submits a Runnable task for execution and returns a Future representing that task.

submit(Runnable) - Method in interface java.util.concurrent.ExecutorService

Submits a Runnable task for execution and returns a Future representing that task.

submit(ForkJoinTask<T>) - Method in class java.util.concurrent.ForkJoinPool

Submits a ForkJoinTask for execution.

submit(Callable<T>) - Method in class java.util.concurrent.ForkJoinPool

submit(Runnable, T) - Method in class java.util.concurrent.ForkJoinPool

submit(Runnable) - Method in class java.util.concurrent.ForkJoinPool

submit(Runnable) - Method in class java.util.concurrent.ScheduledThreadPoolExecutor

submit(Runnable, T) - Method in class java.util.concurrent.ScheduledThreadPoolExecutor

submit(Callable<T>) - Method in class java.util.concurrent.ScheduledThreadPoolExecutor

SUBMIT - Static variable in class javax.swing.text.html.FormView

Deprecated.
As of 1.3, value now comes from UIManager property FormView.submitButtonText

submitData(String) - Method in class javax.swing.text.html.FormView

This method is responsible for submitting the form data.

subpath(int, int) - Method in interface java.nio.file.Path

Returns a relative Path that is a subsequence of the name elements of this path.

subsamplingXOffset - Variable in class javax.imageio.IIOParam

A horizontal offset to be applied to the subsampling grid before subsampling.

subsamplingYOffset - Variable in class javax.imageio.IIOParam

A vertical offset to be applied to the subsampling grid before subsampling.

Subscript - Static variable in class javax.swing.text.StyleConstants

Name of the Subscript attribute.

subSequence(int, int) - Method in interface java.lang.CharSequence

Returns a CharSequence that is a subsequence of this sequence.

subSequence(int, int) - Method in class java.lang.String

Returns a character sequence that is a subsequence of this sequence.

subSequence(int, int) - Method in class java.lang.StringBuffer

subSequence(int, int) - Method in class java.nio.CharBuffer

Creates a new character buffer that represents the specified subsequence of this buffer, relative to the current position.

subSequence(int, int) - Method in class javax.swing.text.Segment

Returns a CharSequence that is a subsequence of this sequence.

Subset(String) - Constructor for class java.lang.Character.Subset

Constructs a new Subset instance.

subSet(E, boolean, E, boolean) - Method in class java.util.concurrent.ConcurrentSkipListSet

subSet(E, E) - Method in class java.util.concurrent.ConcurrentSkipListSet

subSet(E, boolean, E, boolean) - Method in interface java.util.NavigableSet

Returns a view of the portion of this set whose elements range from fromElement to toElement.

subSet(E, E) - Method in interface java.util.NavigableSet

Returns a view of the portion of this set whose elements range from fromElement, inclusive, to toElement, exclusive.

subSet(E, E) - Method in interface java.util.SortedSet

Returns a view of the portion of this set whose elements range from fromElement, inclusive, to toElement, exclusive.

subSet(E, boolean, E, boolean) - Method in class java.util.TreeSet

subSet(E, E) - Method in class java.util.TreeSet

SUBSIZED - Static variable in interface java.util.Spliterator

Characteristic value signifying that all Spliterators resulting from trySplit() will be both Spliterator.SIZED and Spliterator.SUBSIZED.

substituteColorModel(ColorModel, ColorModel) - Method in class java.awt.image.RGBImageFilter

Registers two ColorModel objects for substitution.

SUBSTITUTION_PERMISSION - Static variable in interface java.io.ObjectStreamConstants

Enable substitution of one object for another during serialization/deserialization.

substring(int) - Method in class java.lang.String

Returns a string that is a substring of this string.

substring(int, int) - Method in class java.lang.String

Returns a string that is a substring of this string.

substring(int) - Method in class java.lang.StringBuffer

substring(int, int) - Method in class java.lang.StringBuffer

substringData(int, int) - Method in interface org.w3c.dom.CharacterData

Extracts a range of data from the node.

subtract(Area) - Method in class java.awt.geom.Area

Subtracts the shape of the specified Area from the shape of this Area.

subtract(BigDecimal) - Method in class java.math.BigDecimal

Returns a BigDecimal whose value is (this - subtrahend), and whose scale is max(this.scale(), subtrahend.scale()).

subtract(BigDecimal, MathContext) - Method in class java.math.BigDecimal

Returns a BigDecimal whose value is (this - subtrahend), with rounding according to the context settings.

subtract(BigInteger) - Method in class java.math.BigInteger

Returns a BigInteger whose value is (this - val).

SUBTRACT - Static variable in class javax.xml.crypto.dsig.spec.XPathType.Filter

The subtract filter operation.

subtract(Duration) - Method in class javax.xml.datatype.Duration

Computes a new duration whose value is this-rhs.

subtractExact(int, int) - Static method in class java.lang.Math

Returns the difference of the arguments, throwing an exception if the result overflows an int.

subtractExact(long, long) - Static method in class java.lang.Math

Returns the difference of the arguments, throwing an exception if the result overflows a long.

subtractExact(int, int) - Static method in class java.lang.StrictMath

Returns the difference of the arguments, throwing an exception if the result overflows an int.

subtractExact(long, long) - Static method in class java.lang.StrictMath

Returns the difference of the arguments, throwing an exception if the result overflows a long.

subtractFrom(Temporal) - Method in interface java.time.chrono.ChronoPeriod

Subtracts this period from the specified temporal object.

subtractFrom(Temporal) - Method in class java.time.Duration

Subtracts this duration from the specified temporal object.

subtractFrom(Temporal) - Method in class java.time.Period

Subtracts this period from the specified temporal object.

subtractFrom(Temporal) - Method in interface java.time.temporal.TemporalAmount

Subtracts this object from the specified temporal object.

SUBTREE_SCOPE - Static variable in class javax.naming.directory.SearchControls

Search the entire subtree rooted at the named object.

SUBTREE_SCOPE - Static variable in interface javax.naming.event.EventContext

Constant for expressing interest in events concerning objects in the subtree of the object named by the target, including the object named by the target.

SUBWINDOW_OF - Static variable in class javax.accessibility.AccessibleRelation

Indicates that an object is a subwindow of one or more objects.

SUBWINDOW_OF_PROPERTY - Static variable in class javax.accessibility.AccessibleRelation

Indicates the SUBWINDOW_OF relation between two or more objects has changed.

SUCCESS_NO_INFO - Static variable in interface java.sql.Statement

The constant indicating that a batch statement executed successfully but that no count of the number of rows it affected is available.

SUCCESSFUL - Interface in org.omg.PortableInterceptor

org/omg/PortableInterceptor/SUCCESSFUL.java .

SUFFICIENT - Static variable in class javax.security.auth.login.AppConfigurationEntry.LoginModuleControlFlag

Sufficient LoginModule.

suffixes - Variable in class javax.imageio.spi.ImageReaderWriterSpi

An array of strings to be returned from getFileSuffixes, initially null.

sum(double, double) - Static method in class java.lang.Double

Adds two double values together as per the + operator.

sum(float, float) - Static method in class java.lang.Float

Adds two float values together as per the + operator.

sum(int, int) - Static method in class java.lang.Integer

Adds two integers together as per the + operator.

sum(long, long) - Static method in class java.lang.Long

Adds two long values together as per the + operator.

sum() - Method in class java.util.concurrent.atomic.DoubleAdder

Returns the current sum.

sum() - Method in class java.util.concurrent.atomic.LongAdder

Returns the current sum.

sum() - Method in interface java.util.stream.DoubleStream

Returns the sum of elements in this stream.

sum() - Method in interface java.util.stream.IntStream

Returns the sum of elements in this stream.

sum() - Method in interface java.util.stream.LongStream

Returns the sum of elements in this stream.

sum(Spring, Spring) - Static method in class javax.swing.Spring

Returns s1+s2: a spring representing s1 and s2 in series.

summarizingDouble(ToDoubleFunction<? super T>) - Static method in class java.util.stream.Collectors

Returns a Collector which applies an double-producing mapping function to each input element, and returns summary statistics for the resulting values.

summarizingInt(ToIntFunction<? super T>) - Static method in class java.util.stream.Collectors

Returns a Collector which applies an int-producing mapping function to each input element, and returns summary statistics for the resulting values.

summarizingLong(ToLongFunction<? super T>) - Static method in class java.util.stream.Collectors

Returns a Collector which applies an long-producing mapping function to each input element, and returns summary statistics for the resulting values.

summaryStatistics() - Method in interface java.util.stream.DoubleStream

Returns a DoubleSummaryStatistics describing various summary data about the elements of this stream.

summaryStatistics() - Method in interface java.util.stream.IntStream

Returns an IntSummaryStatistics describing various summary data about the elements of this stream.

summaryStatistics() - Method in interface java.util.stream.LongStream

Returns a LongSummaryStatistics describing various summary data about the elements of this stream.

summingDouble(ToDoubleFunction<? super T>) - Static method in class java.util.stream.Collectors

Returns a Collector that produces the sum of a double-valued function applied to the input elements.

summingInt(ToIntFunction<? super T>) - Static method in class java.util.stream.Collectors

Returns a Collector that produces the sum of a integer-valued function applied to the input elements.

summingLong(ToLongFunction<? super T>) - Static method in class java.util.stream.Collectors

Returns a Collector that produces the sum of a long-valued function applied to the input elements.

sumThenReset() - Method in class java.util.concurrent.atomic.DoubleAdder

Equivalent in effect to DoubleAdder.sum() followed by DoubleAdder.reset().

sumThenReset() - Method in class java.util.concurrent.atomic.LongAdder

Equivalent in effect to LongAdder.sum() followed by LongAdder.reset().

SUNDANESE - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "Sundanese" Unicode character block.

SUNDANESE_SUPPLEMENT - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "Sundanese Supplement" Unicode character block.

SUNDAY - Static variable in class java.util.Calendar

Value of the Calendar.DAY_OF_WEEK field indicating Sunday.

SUNDAY_START - Static variable in class java.time.temporal.WeekFields

The common definition of a week that starts on Sunday and the first week has a minimum of 1 day.

SUP - Static variable in class javax.swing.text.html.HTML.Tag

superLayout(Container) - Method in class javax.swing.plaf.metal.MetalComboBoxUI.MetalComboBoxLayoutManager

SUPERSCRIPT - Static variable in class java.awt.font.TextAttribute

Attribute key for superscripting and subscripting.

Superscript - Static variable in class javax.swing.text.StyleConstants

Name of the Superscript attribute.

SUPERSCRIPT_SUB - Static variable in class java.awt.font.TextAttribute

Standard subscript.

SUPERSCRIPT_SUPER - Static variable in class java.awt.font.TextAttribute

Standard superscript.

SUPERSCRIPTS_AND_SUBSCRIPTS - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "Superscripts and Subscripts" Unicode character block.

SUPPLEMENTAL_ARROWS_A - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "Supplemental Arrows-A" Unicode character block.

SUPPLEMENTAL_ARROWS_B - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "Supplemental Arrows-B" Unicode character block.

SUPPLEMENTAL_MATHEMATICAL_OPERATORS - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "Supplemental Mathematical Operators" Unicode character block.

SUPPLEMENTAL_PUNCTUATION - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "Supplemental Punctuation" Unicode character block.

SUPPLEMENTARY_PRIVATE_USE_AREA_A - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "Supplementary Private Use Area-A" Unicode character block.

SUPPLEMENTARY_PRIVATE_USE_AREA_B - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "Supplementary Private Use Area-B" Unicode character block.

Supplier<T> - Interface in java.util.function

Represents a supplier of results.

supplier() - Method in interface java.util.stream.Collector

A function that creates and returns a new mutable result container.

supplyAsync(Supplier<U>) - Static method in class java.util.concurrent.CompletableFuture

Returns a new CompletableFuture that is asynchronously completed by a task running in the ForkJoinPool.commonPool() with the value obtained by calling the given Supplier.

supplyAsync(Supplier<U>, Executor) - Static method in class java.util.concurrent.CompletableFuture

Returns a new CompletableFuture that is asynchronously completed by a task running in the given executor with the value obtained by calling the given Supplier.

SUPPORT_DTD - Static variable in class javax.xml.stream.XMLInputFactory

The property that requires the parser to support DTDs

SUPPORTED - Static variable in class javax.print.attribute.standard.ColorSupported

The printer is capable of some type of color printing, such as highlight color or full process color.

SupportedAnnotationTypes - Annotation Type in javax.annotation.processing

An annotation used to indicate what annotation types an annotation processor supports.

supportedFileAttributeViews() - Method in class java.nio.file.FileSystem

Returns the set of the names of the file attribute views supported by this FileSystem.

supportedOptions() - Method in interface java.nio.channels.NetworkChannel

Returns a set of the socket options supported by this channel.

SupportedOptions - Annotation Type in javax.annotation.processing

An annotation used to indicate what options an annotation processor supports.

SupportedSourceVersion - Annotation Type in javax.annotation.processing

An annotation used to indicate the latest source version an annotation processor supports.

SupportedValuesAttribute - Interface in javax.print.attribute

Interface SupportedValuesAttribute is a tagging interface which a printing attribute class implements to indicate the attribute describes the supported values for another attribute.

supportsAlterTableWithAddColumn() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports ALTER TABLE with add column.

supportsAlterTableWithDropColumn() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports ALTER TABLE with drop column.

supportsANSI92EntryLevelSQL() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports the ANSI92 entry level SQL grammar.

supportsANSI92FullSQL() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports the ANSI92 full SQL grammar supported.

supportsANSI92IntermediateSQL() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports the ANSI92 intermediate SQL grammar supported.

supportsBatchUpdates() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports batch updates.

supportsCatalogsInDataManipulation() - Method in interface java.sql.DatabaseMetaData

Retrieves whether a catalog name can be used in a data manipulation statement.

supportsCatalogsInIndexDefinitions() - Method in interface java.sql.DatabaseMetaData

Retrieves whether a catalog name can be used in an index definition statement.

supportsCatalogsInPrivilegeDefinitions() - Method in interface java.sql.DatabaseMetaData

Retrieves whether a catalog name can be used in a privilege definition statement.

supportsCatalogsInProcedureCalls() - Method in interface java.sql.DatabaseMetaData

Retrieves whether a catalog name can be used in a procedure call statement.

supportsCatalogsInTableDefinitions() - Method in interface java.sql.DatabaseMetaData

Retrieves whether a catalog name can be used in a table definition statement.

supportsColumnAliasing() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports column aliasing.

supportsConvert() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports the JDBC scalar function CONVERT for the conversion of one JDBC type to another.

supportsConvert(int, int) - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports the JDBC scalar function CONVERT for conversions between the JDBC types fromType and toType.

supportsCoreSQLGrammar() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports the ODBC Core SQL grammar.

supportsCorrelatedSubqueries() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports correlated subqueries.

supportsCrossJoin() - Method in interface javax.sql.rowset.JoinRowSet

Indicates if CROSS_JOIN is supported by a JoinRowSet implementation

supportsCustomEditor() - Method in interface java.beans.PropertyEditor

Determines whether this property editor supports a custom editor.

supportsCustomEditor() - Method in class java.beans.PropertyEditorSupport

Determines whether the propertyEditor can provide a custom editor.

supportsDataDefinitionAndDataManipulationTransactions() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports both data definition and data manipulation statements within a transaction.

supportsDataManipulationTransactionsOnly() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports only data manipulation statements within a transaction.

supportsDifferentTableCorrelationNames() - Method in interface java.sql.DatabaseMetaData

Retrieves whether, when table correlation names are supported, they are restricted to being different from the names of the tables.

supportsExpressionsInOrderBy() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports expressions in ORDER BY lists.

supportsExtendedSQLGrammar() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports the ODBC Extended SQL grammar.

supportsFileAttributeView(Class<? extends FileAttributeView>) - Method in class java.nio.file.FileStore

Tells whether or not this file store supports the file attributes identified by the given file attribute view.

supportsFileAttributeView(String) - Method in class java.nio.file.FileStore

Tells whether or not this file store supports the file attributes identified by the given file attribute view.

supportsFullJoin() - Method in interface javax.sql.rowset.JoinRowSet

Indicates if FULL_JOIN is supported by a JoinRowSet implementation

supportsFullOuterJoins() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports full nested outer joins.

supportsGetGeneratedKeys() - Method in interface java.sql.DatabaseMetaData

Retrieves whether auto-generated keys can be retrieved after a statement has been executed

supportsGroupBy() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports some form of GROUP BY clause.

supportsGroupByBeyondSelect() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports using columns not included in the SELECT statement in a GROUP BY clause provided that all of the columns in the SELECT statement are included in the GROUP BY clause.

supportsGroupByUnrelated() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports using a column that is not in the SELECT statement in a GROUP BY clause.

supportsInnerJoin() - Method in interface javax.sql.rowset.JoinRowSet

Indicates if INNER_JOIN is supported by a JoinRowSet implementation

supportsIntegrityEnhancementFacility() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports the SQL Integrity Enhancement Facility.

supportsLeftOuterJoin() - Method in interface javax.sql.rowset.JoinRowSet

Indicates if LEFT_OUTER_JOIN is supported by a JoinRowSet implementation

supportsLikeEscapeClause() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports specifying a LIKE escape clause.

supportsLimitedOuterJoins() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database provides limited support for outer joins.

supportsMinimumSQLGrammar() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports the ODBC Minimum SQL grammar.

supportsMixedCaseIdentifiers() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database treats mixed case unquoted SQL identifiers as case sensitive and as a result stores them in mixed case.

supportsMixedCaseQuotedIdentifiers() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database treats mixed case quoted SQL identifiers as case sensitive and as a result stores them in mixed case.

supportsMulticast() - Method in class java.net.NetworkInterface

Returns whether a network interface supports multicasting or not.

supportsMultipleOpenResults() - Method in interface java.sql.DatabaseMetaData

Retrieves whether it is possible to have multiple ResultSet objects returned from a CallableStatement object simultaneously.

supportsMultipleResultSets() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports getting multiple ResultSet objects from a single call to the method execute.

supportsMultipleTransactions() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database allows having multiple transactions open at once (on different connections).

supportsNamedParameters() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports named parameters to callable statements.

supportsNonNullableColumns() - Method in interface java.sql.DatabaseMetaData

Retrieves whether columns in this database may be defined as non-nullable.

supportsOpenCursorsAcrossCommit() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports keeping cursors open across commits.

supportsOpenCursorsAcrossRollback() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports keeping cursors open across rollbacks.

supportsOpenStatementsAcrossCommit() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports keeping statements open across commits.

supportsOpenStatementsAcrossRollback() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports keeping statements open across rollbacks.

supportsOrderByUnrelated() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports using a column that is not in the SELECT statement in an ORDER BY clause.

supportsOuterJoins() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports some form of outer join.

supportsParameter(Object) - Method in class java.security.Provider.Service

Test whether this Service can use the specified parameter.

supportsPositionedDelete() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports positioned DELETE statements.

supportsPositionedUpdate() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports positioned UPDATE statements.

supportsRefCursors() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports REF CURSOR.

supportsResultSetConcurrency(int, int) - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports the given concurrency type in combination with the given result set type.

supportsResultSetHoldability(int) - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports the given result set holdability.

supportsResultSetType(int) - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports the given result set type.

supportsRightOuterJoin() - Method in interface javax.sql.rowset.JoinRowSet

Indicates if RIGHT_OUTER_JOIN is supported by a JoinRowSet implementation

supportsSavepoints() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports savepoints.

supportsSchemasInDataManipulation() - Method in interface java.sql.DatabaseMetaData

Retrieves whether a schema name can be used in a data manipulation statement.

supportsSchemasInIndexDefinitions() - Method in interface java.sql.DatabaseMetaData

Retrieves whether a schema name can be used in an index definition statement.

supportsSchemasInPrivilegeDefinitions() - Method in interface java.sql.DatabaseMetaData

Retrieves whether a schema name can be used in a privilege definition statement.

supportsSchemasInProcedureCalls() - Method in interface java.sql.DatabaseMetaData

Retrieves whether a schema name can be used in a procedure call statement.

supportsSchemasInTableDefinitions() - Method in interface java.sql.DatabaseMetaData

Retrieves whether a schema name can be used in a table definition statement.

supportsSelectForUpdate() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports SELECT FOR UPDATE statements.

supportsStandardImageMetadataFormat - Variable in class javax.imageio.spi.ImageReaderWriterSpi

A boolean indicating whether this plug-in supports the standard metadata format for image metadata, initially false.

supportsStandardStreamMetadataFormat - Variable in class javax.imageio.spi.ImageReaderWriterSpi

A boolean indicating whether this plug-in supports the standard metadata format for stream metadata, initially false.

supportsStatementPooling() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports statement pooling.

supportsStoredFunctionsUsingCallSyntax() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports invoking user-defined or vendor functions using the stored procedure escape syntax.

supportsStoredProcedures() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports stored procedure calls that use the stored procedure escape syntax.

supportsSubqueriesInComparisons() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports subqueries in comparison expressions.

supportsSubqueriesInExists() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports subqueries in EXISTS expressions.

supportsSubqueriesInIns() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports subqueries in IN expressions.

supportsSubqueriesInQuantifieds() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports subqueries in quantified expressions.

supportsTableCorrelationNames() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports table correlation names.

supportsTransactionIsolationLevel(int) - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports the given transaction isolation level.

supportsTransactions() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports transactions.

supportsUnion() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports SQL UNION.

supportsUnionAll() - Method in interface java.sql.DatabaseMetaData

Retrieves whether this database supports SQL UNION ALL.

supportsUpdatableView() - Method in class javax.sql.rowset.spi.SyncProvider

Returns whether this SyncProvider implementation can perform synchronization between a RowSet object and the SQL VIEW in the data source from which the RowSet object got its data.

supportsUrgentData() - Method in class java.net.SocketImpl

Returns whether or not this SocketImpl supports sending urgent data.

SuppressWarnings - Annotation Type in java.lang

Indicates that the named compiler warnings should be suppressed in the annotated element (and in all program elements contained in the annotated element).

SURROGATE - Static variable in class java.lang.Character

General category "Cs" in the Unicode specification.

SURROGATES_AREA - Static variable in class java.lang.Character.UnicodeBlock

Deprecated.
As of J2SE 5, use Character.UnicodeBlock.HIGH_SURROGATES, Character.UnicodeBlock.HIGH_PRIVATE_USE_SURROGATES, and Character.UnicodeBlock.LOW_SURROGATES. These new constants match the block definitions of the Unicode Standard. The Character.UnicodeBlock.of(char) and Character.UnicodeBlock.of(int) methods return the new constants, not SURROGATES_AREA.

suspend() - Method in class java.lang.Thread

Deprecated.
This method has been deprecated, as it is inherently deadlock-prone. If the target thread holds a lock on the monitor protecting a critical system resource when it is suspended, no thread can access this resource until the target thread is resumed. If the thread that would resume the target thread attempts to lock this monitor prior to calling resume, deadlock results. Such deadlocks typically manifest themselves as "frozen" processes. For more information, see Why are Thread.stop, Thread.suspend and Thread.resume Deprecated?.

suspend() - Method in class java.lang.ThreadGroup

Deprecated.
This method is inherently deadlock-prone. See Thread.suspend() for details.

sval - Variable in class java.io.StreamTokenizer

If the current token is a word token, this field contains a string giving the characters of the word token.

SW_RESIZE_CURSOR - Static variable in class java.awt.Cursor

The south-west-resize cursor type.

SW_RESIZE_CURSOR - Static variable in class java.awt.Frame

Deprecated.
replaced by Cursor.SW_RESIZE_CURSOR.

swap(List<?>, int, int) - Static method in class java.util.Collections

Swaps the elements at the specified positions in the specified list.

SWAP_COLORS - Static variable in class java.awt.font.TextAttribute

Attribute key for swapping foreground and background Paints.

SWAP_COLORS_ON - Static variable in class java.awt.font.TextAttribute

Swap foreground and background.

SWING_COMPONENT - Static variable in class javax.accessibility.AccessibleRole

A Swing component, but nothing else is known about it.

SwingConstants - Interface in javax.swing

A collection of constants generally used for positioning and orienting components on the screen.

SwingPropertyChangeSupport - Class in javax.swing.event

This subclass of java.beans.PropertyChangeSupport is almost identical in functionality.

SwingPropertyChangeSupport(Object) - Constructor for class javax.swing.event.SwingPropertyChangeSupport

Constructs a SwingPropertyChangeSupport object.

SwingPropertyChangeSupport(Object, boolean) - Constructor for class javax.swing.event.SwingPropertyChangeSupport

Constructs a SwingPropertyChangeSupport object.

SwingUtilities - Class in javax.swing

A collection of utility methods for Swing.

SwingWorker<T,V> - Class in javax.swing

An abstract class to perform lengthy GUI-interaction tasks in a background thread.

SwingWorker() - Constructor for class javax.swing.SwingWorker

Constructs this SwingWorker.

SwingWorker.StateValue - Enum in javax.swing

Values for the state bound property.

SwitchPoint - Class in java.lang.invoke

A SwitchPoint is an object which can publish state transitions to other threads.

SwitchPoint() - Constructor for class java.lang.invoke.SwitchPoint

Creates a new switch point.

SYLOTI_NAGRI - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "Syloti Nagri" Unicode character block.

sync() - Method in class java.awt.Toolkit

Synchronizes this toolkit's graphics state.

sync() - Method in class java.io.FileDescriptor

Force all system buffers to synchronize with the underlying device.

sync() - Method in class java.util.prefs.AbstractPreferences

Implements the sync method as per the specification in Preferences.sync().

sync() - Method in class java.util.prefs.Preferences

Ensures that future reads from this preference node and its descendants reflect any changes that were committed to the persistent store (from any VM) prior to the sync invocation.

SYNC_FLUSH - Static variable in class java.util.zip.Deflater

Compression flush mode used to flush out all pending output; may degrade compression for some compression algorithms.

sync_scope() - Method in interface org.omg.PortableInterceptor.RequestInfoOperations

Defines how far the request shall progress before control is returned to the client.

SYNC_WITH_TRANSPORT - Interface in org.omg.Messaging

org/omg/Messaging/SYNC_WITH_TRANSPORT.java .

syncAll(MutableCallSite[]) - Static method in class java.lang.invoke.MutableCallSite

Performs a synchronization operation on each call site in the given array, forcing all other threads to throw away any cached values previously loaded from the target of any of the call sites.

syncAllWidths - Variable in class javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout

SyncFactory - Class in javax.sql.rowset.spi

The Service Provider Interface (SPI) mechanism that generates SyncProvider instances to be used by disconnected RowSet objects.

SyncFactoryException - Exception in javax.sql.rowset.spi

Indicates an error with SyncFactory mechanism.

SyncFactoryException() - Constructor for exception javax.sql.rowset.spi.SyncFactoryException

Creates new SyncFactoryException without detail message.

SyncFactoryException(String) - Constructor for exception javax.sql.rowset.spi.SyncFactoryException

Constructs an SyncFactoryException with the specified detail message.

SyncFailedException - Exception in java.io

Signals that a sync operation has failed.

SyncFailedException(String) - Constructor for exception java.io.SyncFailedException

Constructs an SyncFailedException with a detail message.

synchronize(Line[], boolean) - Method in interface javax.sound.sampled.Mixer

Synchronizes two or more lines.

SYNCHRONIZED - Static variable in class java.lang.reflect.Modifier

The int value representing the synchronized modifier.

synchronizedCollection(Collection<T>) - Static method in class java.util.Collections

Returns a synchronized (thread-safe) collection backed by the specified collection.

synchronizedList(List<T>) - Static method in class java.util.Collections

Returns a synchronized (thread-safe) list backed by the specified list.

synchronizedMap(Map<K, V>) - Static method in class java.util.Collections

Returns a synchronized (thread-safe) map backed by the specified map.

synchronizedNavigableMap(NavigableMap<K, V>) - Static method in class java.util.Collections

Returns a synchronized (thread-safe) navigable map backed by the specified navigable map.

synchronizedNavigableSet(NavigableSet<T>) - Static method in class java.util.Collections

Returns a synchronized (thread-safe) navigable set backed by the specified navigable set.

synchronizedSet(Set<T>) - Static method in class java.util.Collections

Returns a synchronized (thread-safe) set backed by the specified set.

synchronizedSortedMap(SortedMap<K, V>) - Static method in class java.util.Collections

Returns a synchronized (thread-safe) sorted map backed by the specified sorted map.

synchronizedSortedSet(SortedSet<T>) - Static method in class java.util.Collections

Returns a synchronized (thread-safe) sorted set backed by the specified sorted set.

synchronizedView(AttributeSet) - Static method in class javax.print.attribute.AttributeSetUtilities

Creates a synchronized view of the given attribute set.

synchronizedView(DocAttributeSet) - Static method in class javax.print.attribute.AttributeSetUtilities

Creates a synchronized view of the given doc attribute set.

synchronizedView(PrintRequestAttributeSet) - Static method in class javax.print.attribute.AttributeSetUtilities

Creates a synchronized view of the given print request attribute set.

synchronizedView(PrintJobAttributeSet) - Static method in class javax.print.attribute.AttributeSetUtilities

Creates a synchronized view of the given print job attribute set.

synchronizedView(PrintServiceAttributeSet) - Static method in class javax.print.attribute.AttributeSetUtilities

Creates a synchronized view of the given print service attribute set.

SynchronousQueue<E> - Class in java.util.concurrent

A blocking queue in which each insert operation must wait for a corresponding remove operation by another thread, and vice versa.

SynchronousQueue() - Constructor for class java.util.concurrent.SynchronousQueue

Creates a SynchronousQueue with nonfair access policy.

SynchronousQueue(boolean) - Constructor for class java.util.concurrent.SynchronousQueue

Creates a SynchronousQueue with the specified fairness policy.

SyncMode(String) - Constructor for class javax.sound.midi.Sequencer.SyncMode

Constructs a synchronization mode.

SyncProvider - Class in javax.sql.rowset.spi

The synchronization mechanism that provides reader/writer capabilities for disconnected RowSet objects.

SyncProvider() - Constructor for class javax.sql.rowset.spi.SyncProvider

Creates a default SyncProvider object.

SyncProviderException - Exception in javax.sql.rowset.spi

Indicates an error with the SyncProvider mechanism.

SyncProviderException() - Constructor for exception javax.sql.rowset.spi.SyncProviderException

Creates a new SyncProviderException object without a detail message.

SyncProviderException(String) - Constructor for exception javax.sql.rowset.spi.SyncProviderException

Constructs a SyncProviderException object with the specified detail message.

SyncProviderException(SyncResolver) - Constructor for exception javax.sql.rowset.spi.SyncProviderException

Constructs a SyncProviderException object with the specified SyncResolver instance.

SyncResolver - Interface in javax.sql.rowset.spi

Defines a framework that allows applications to use a manual decision tree to decide what should be done when a synchronization conflict occurs.

SyncScopeHelper - Class in org.omg.Messaging

Synchronization scope

SyncScopeHelper() - Constructor for class org.omg.Messaging.SyncScopeHelper

syncScrollPaneWithViewport() - Method in class javax.swing.plaf.basic.BasicScrollPaneUI

syncSpi() - Method in class java.util.prefs.AbstractPreferences

This method is invoked with this node locked.

syncWithScrollPane(JScrollPane) - Method in class javax.swing.ScrollPaneLayout

This method is invoked after the ScrollPaneLayout is set as the LayoutManager of a JScrollPane.

SYNTAX_ERR - Static variable in exception org.w3c.dom.DOMException

If an invalid or illegal string is specified.

SynthButtonUI - Class in javax.swing.plaf.synth

Provides the Synth L&F UI delegate for JButton.

SynthButtonUI() - Constructor for class javax.swing.plaf.synth.SynthButtonUI

SynthCheckBoxMenuItemUI - Class in javax.swing.plaf.synth

Provides the Synth L&F UI delegate for JCheckBoxMenuItem.

SynthCheckBoxMenuItemUI() - Constructor for class javax.swing.plaf.synth.SynthCheckBoxMenuItemUI

SynthCheckBoxUI - Class in javax.swing.plaf.synth

Provides the Synth L&F UI delegate for JCheckBox.

SynthCheckBoxUI() - Constructor for class javax.swing.plaf.synth.SynthCheckBoxUI

SynthColorChooserUI - Class in javax.swing.plaf.synth

Provides the Synth L&F UI delegate for JColorChooser.

SynthColorChooserUI() - Constructor for class javax.swing.plaf.synth.SynthColorChooserUI

SynthComboBoxUI - Class in javax.swing.plaf.synth

Provides the Synth L&F UI delegate for JComboBox.

SynthComboBoxUI() - Constructor for class javax.swing.plaf.synth.SynthComboBoxUI

SynthConstants - Interface in javax.swing.plaf.synth

Constants used by Synth.

SynthContext - Class in javax.swing.plaf.synth

An immutable transient object containing contextual information about a Region.

SynthContext(JComponent, Region, SynthStyle, int) - Constructor for class javax.swing.plaf.synth.SynthContext

Creates a SynthContext with the specified values.

SynthDesktopIconUI - Class in javax.swing.plaf.synth

Provides the Synth L&F UI delegate for a minimized internal frame on a desktop.

SynthDesktopIconUI() - Constructor for class javax.swing.plaf.synth.SynthDesktopIconUI

SynthDesktopPaneUI - Class in javax.swing.plaf.synth

Provides the Synth L&F UI delegate for JDesktopPane.

SynthDesktopPaneUI() - Constructor for class javax.swing.plaf.synth.SynthDesktopPaneUI

SynthEditorPaneUI - Class in javax.swing.plaf.synth

Provides the Synth L&F UI delegate for JEditorPane.

SynthEditorPaneUI() - Constructor for class javax.swing.plaf.synth.SynthEditorPaneUI

synthesizedElement(Element) - Method in class javax.swing.text.html.HTMLWriter

Returns true if the element is a synthesized element.

Synthesizer - Interface in javax.sound.midi

A Synthesizer generates sound.

SynthFormattedTextFieldUI - Class in javax.swing.plaf.synth

Provides the Synth L&F UI delegate for JFormattedTextField.

SynthFormattedTextFieldUI() - Constructor for class javax.swing.plaf.synth.SynthFormattedTextFieldUI

SynthGraphicsUtils - Class in javax.swing.plaf.synth

Wrapper for primitive graphics calls.

SynthGraphicsUtils() - Constructor for class javax.swing.plaf.synth.SynthGraphicsUtils

Creates a SynthGraphicsUtils.

SynthInternalFrameUI - Class in javax.swing.plaf.synth

Provides the Synth L&F UI delegate for JInternalFrame.

SynthInternalFrameUI(JInternalFrame) - Constructor for class javax.swing.plaf.synth.SynthInternalFrameUI

SynthLabelUI - Class in javax.swing.plaf.synth

Provides the Synth L&F UI delegate for JLabel.

SynthLabelUI() - Constructor for class javax.swing.plaf.synth.SynthLabelUI

SynthListUI - Class in javax.swing.plaf.synth

Provides the Synth L&F UI delegate for JList.

SynthListUI() - Constructor for class javax.swing.plaf.synth.SynthListUI

SynthLookAndFeel - Class in javax.swing.plaf.synth

SynthLookAndFeel provides the basis for creating a customized look and feel.

SynthLookAndFeel() - Constructor for class javax.swing.plaf.synth.SynthLookAndFeel

Creates a SynthLookAndFeel.

SynthMenuBarUI - Class in javax.swing.plaf.synth

Provides the Synth L&F UI delegate for JMenuBar.

SynthMenuBarUI() - Constructor for class javax.swing.plaf.synth.SynthMenuBarUI

SynthMenuItemUI - Class in javax.swing.plaf.synth

Provides the Synth L&F UI delegate for JMenuItem.

SynthMenuItemUI() - Constructor for class javax.swing.plaf.synth.SynthMenuItemUI

SynthMenuUI - Class in javax.swing.plaf.synth

Provides the Synth L&F UI delegate for JMenu.

SynthMenuUI() - Constructor for class javax.swing.plaf.synth.SynthMenuUI

SynthOptionPaneUI - Class in javax.swing.plaf.synth

Provides the Synth L&F UI delegate for JOptionPane.

SynthOptionPaneUI() - Constructor for class javax.swing.plaf.synth.SynthOptionPaneUI

SynthPainter - Class in javax.swing.plaf.synth

SynthPainter is used for painting portions of JComponents.

SynthPainter() - Constructor for class javax.swing.plaf.synth.SynthPainter

SynthPanelUI - Class in javax.swing.plaf.synth

Provides the Synth L&F UI delegate for JPanel.

SynthPanelUI() - Constructor for class javax.swing.plaf.synth.SynthPanelUI

SynthPasswordFieldUI - Class in javax.swing.plaf.synth

Provides the Synth L&F UI delegate for JPasswordField.

SynthPasswordFieldUI() - Constructor for class javax.swing.plaf.synth.SynthPasswordFieldUI

SynthPopupMenuUI - Class in javax.swing.plaf.synth

Provides the Synth L&F UI delegate for JPopupMenu.

SynthPopupMenuUI() - Constructor for class javax.swing.plaf.synth.SynthPopupMenuUI

SynthProgressBarUI - Class in javax.swing.plaf.synth

Provides the Synth L&F UI delegate for JProgressBar.

SynthProgressBarUI() - Constructor for class javax.swing.plaf.synth.SynthProgressBarUI

SynthRadioButtonMenuItemUI - Class in javax.swing.plaf.synth

Provides the Synth L&F UI delegate for JRadioButtonMenuItem.

SynthRadioButtonMenuItemUI() - Constructor for class javax.swing.plaf.synth.SynthRadioButtonMenuItemUI

SynthRadioButtonUI - Class in javax.swing.plaf.synth

Provides the Synth L&F UI delegate for JRadioButton.

SynthRadioButtonUI() - Constructor for class javax.swing.plaf.synth.SynthRadioButtonUI

SynthRootPaneUI - Class in javax.swing.plaf.synth

Provides the Synth L&F UI delegate for JRootPane.

SynthRootPaneUI() - Constructor for class javax.swing.plaf.synth.SynthRootPaneUI

SynthScrollBarUI - Class in javax.swing.plaf.synth

Provides the Synth L&F UI delegate for JScrollBar.

SynthScrollBarUI() - Constructor for class javax.swing.plaf.synth.SynthScrollBarUI

SynthScrollPaneUI - Class in javax.swing.plaf.synth

Provides the Synth L&F UI delegate for JScrollPane.

SynthScrollPaneUI() - Constructor for class javax.swing.plaf.synth.SynthScrollPaneUI

SynthSeparatorUI - Class in javax.swing.plaf.synth

Provides the Synth L&F UI delegate for JSeparator.

SynthSeparatorUI() - Constructor for class javax.swing.plaf.synth.SynthSeparatorUI

SynthSliderUI - Class in javax.swing.plaf.synth

Provides the Synth L&F UI delegate for JSlider.

SynthSliderUI(JSlider) - Constructor for class javax.swing.plaf.synth.SynthSliderUI

SynthSpinnerUI - Class in javax.swing.plaf.synth

Provides the Synth L&F UI delegate for JSpinner.

SynthSpinnerUI() - Constructor for class javax.swing.plaf.synth.SynthSpinnerUI

SynthSplitPaneUI - Class in javax.swing.plaf.synth

Provides the Synth L&F UI delegate for JSplitPane.

SynthSplitPaneUI() - Constructor for class javax.swing.plaf.synth.SynthSplitPaneUI

SynthStyle - Class in javax.swing.plaf.synth

SynthStyle is a set of style properties.

SynthStyle() - Constructor for class javax.swing.plaf.synth.SynthStyle

Constructs a SynthStyle.

SynthStyleFactory - Class in javax.swing.plaf.synth

Factory used for obtaining SynthStyles.

SynthStyleFactory() - Constructor for class javax.swing.plaf.synth.SynthStyleFactory

Creates a SynthStyleFactory.

SynthTabbedPaneUI - Class in javax.swing.plaf.synth

Provides the Synth L&F UI delegate for JTabbedPane.

SynthTabbedPaneUI() - Constructor for class javax.swing.plaf.synth.SynthTabbedPaneUI

SynthTableHeaderUI - Class in javax.swing.plaf.synth

Provides the Synth L&F UI delegate for JTableHeader.

SynthTableHeaderUI() - Constructor for class javax.swing.plaf.synth.SynthTableHeaderUI

SynthTableUI - Class in javax.swing.plaf.synth

Provides the Synth L&F UI delegate for JTable.

SynthTableUI() - Constructor for class javax.swing.plaf.synth.SynthTableUI

SynthTextAreaUI - Class in javax.swing.plaf.synth

Provides the look and feel for a plain text editor in the Synth look and feel.

SynthTextAreaUI() - Constructor for class javax.swing.plaf.synth.SynthTextAreaUI

SynthTextFieldUI - Class in javax.swing.plaf.synth

Provides the Synth L&F UI delegate for JTextField.

SynthTextFieldUI() - Constructor for class javax.swing.plaf.synth.SynthTextFieldUI

SynthTextPaneUI - Class in javax.swing.plaf.synth

Provides the look and feel for a styled text editor in the Synth look and feel.

SynthTextPaneUI() - Constructor for class javax.swing.plaf.synth.SynthTextPaneUI

SynthToggleButtonUI - Class in javax.swing.plaf.synth

Provides the Synth L&F UI delegate for JToggleButton.

SynthToggleButtonUI() - Constructor for class javax.swing.plaf.synth.SynthToggleButtonUI

SynthToolBarUI - Class in javax.swing.plaf.synth

Provides the Synth L&F UI delegate for JToolBar.

SynthToolBarUI() - Constructor for class javax.swing.plaf.synth.SynthToolBarUI

SynthToolTipUI - Class in javax.swing.plaf.synth

Provides the Synth L&F UI delegate for JToolTip.

SynthToolTipUI() - Constructor for class javax.swing.plaf.synth.SynthToolTipUI

SynthTreeUI - Class in javax.swing.plaf.synth

Provides the Synth L&F UI delegate for JTree.

SynthTreeUI() - Constructor for class javax.swing.plaf.synth.SynthTreeUI

SynthUI - Interface in javax.swing.plaf.synth

SynthUI is used to fetch the SynthContext for a particular Component.

SynthViewportUI - Class in javax.swing.plaf.synth

Provides the Synth L&F UI delegate for JViewport.

SynthViewportUI() - Constructor for class javax.swing.plaf.synth.SynthViewportUI

SYRIAC - Static variable in class java.lang.Character.UnicodeBlock

Constant for the "Syriac" Unicode character block.

SysexMessage - Class in javax.sound.midi

A SysexMessage object represents a MIDI system exclusive message.

SysexMessage() - Constructor for class javax.sound.midi.SysexMessage

Constructs a new SysexMessage.

SysexMessage(byte[], int) - Constructor for class javax.sound.midi.SysexMessage

Constructs a new SysexMessage and sets the data for the message.

SysexMessage(int, byte[], int) - Constructor for class javax.sound.midi.SysexMessage

Constructs a new SysexMessage and sets the data for the message.

SysexMessage(byte[]) - Constructor for class javax.sound.midi.SysexMessage

Constructs a new SysexMessage.

System - Class in java.lang

The System class contains several useful class fields and methods.

system(ZoneId) - Static method in class java.time.Clock

Obtains a clock that returns the current instant using best available system clock.

SYSTEM - Static variable in interface javax.swing.text.html.parser.DTDConstants

SYSTEM_EXCEPTION - Interface in org.omg.PortableInterceptor

org/omg/PortableInterceptor/SYSTEM_EXCEPTION.java .

SYSTEM_EXCLUSIVE - Static variable in class javax.sound.midi.SysexMessage

Status byte for System Exclusive message (0xF0, or 240).

SYSTEM_ID - Static variable in class org.omg.PortableServer.IdAssignmentPolicyValue

SYSTEM_PORT - Static variable in interface java.rmi.activation.ActivationSystem

The port to lookup the activation system.

SYSTEM_RESET - Static variable in class javax.sound.midi.ShortMessage

Status byte for System Reset message (0xFF, or 255).

SystemColor - Class in java.awt

A class to encapsulate symbolic colors representing the color of native GUI objects on a system.

systemDefault() - Static method in class java.time.ZoneId

Gets the system default time-zone.

systemDefaultZone() - Static method in class java.time.Clock

Obtains a clock that returns the current instant using the best available system clock, converting to date and time using the default time-zone.

SystemException - Exception in org.omg.CORBA

The root class for all CORBA standard exceptions.

SystemException(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.SystemException

Constructs a SystemException exception with the specified detail message, minor code, and completion status.

SystemFlavorMap - Class in java.awt.datatransfer

The SystemFlavorMap is a configurable map between "natives" (Strings), which correspond to platform-specific data formats, and "flavors" (DataFlavors), which correspond to platform-independent MIME types.

SystemMenuBar() - Constructor for class javax.swing.plaf.basic.BasicInternalFrameTitlePane.SystemMenuBar

systemNodeForPackage(Class<?>) - Static method in class java.util.prefs.Preferences

Returns the preference node from the system preference tree that is associated (by convention) with the specified class's package.

systemRoot() - Static method in class java.util.prefs.Preferences

Returns the root preference node for the system.

systemRoot() - Method in interface java.util.prefs.PreferencesFactory

Returns the system root preference node.

SystemTray - Class in java.awt

The SystemTray class represents the system tray for a desktop.

systemUTC() - Static method in class java.time.Clock

Obtains a clock that returns the current instant using the best available system clock, converting to date and time using the UTC time-zone.

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

Skip navigation links

Overview

Package

Class

Use

Tree

Deprecated

Index

Help

Java™ Platform
Standard Ed. 8

Prev Letter

Next Letter

Frames

No Frames

All Classes


T-Index (Java Platform SE 8 )

Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames
  • All Classes
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

T

TAB - Static variable in class java.awt.Event
The Tab key.
TabableView - Interface in javax.swing.text
Interface for Views that have size dependent upon tabs.
tabAreaBackground - Variable in class javax.swing.plaf.metal.MetalTabbedPaneUI
tabAreaInsets - Variable in class javax.swing.plaf.basic.BasicTabbedPaneUI
TABBED_PANE - Static variable in class javax.swing.plaf.synth.Region
TabbedPane region.
TABBED_PANE_CONTENT - Static variable in class javax.swing.plaf.synth.Region
Region of a TabbedPane containing the content.
TABBED_PANE_TAB - Static variable in class javax.swing.plaf.synth.Region
Region of a TabbedPane for one tab.
TABBED_PANE_TAB_AREA - Static variable in class javax.swing.plaf.synth.Region
Region of a TabbedPane containing the tabs.
TabbedPaneLayout() - Constructor for class javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout
TabbedPaneLayout() - Constructor for class javax.swing.plaf.metal.MetalTabbedPaneUI.TabbedPaneLayout
TabbedPaneUI - Class in javax.swing.plaf
Pluggable look and feel interface for JTabbedPane.
TabbedPaneUI() - Constructor for class javax.swing.plaf.TabbedPaneUI
tabChangeListener - Variable in class javax.swing.plaf.basic.BasicTabbedPaneUI
TabExpander - Interface in javax.swing.text
Simple interface to allow for different types of implementations of tab expansion.
tabForCoordinate(JTabbedPane, int, int) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
Returns the tab index which intersects the specified point in the JTabbedPane's coordinate space.
tabForCoordinate(JTabbedPane, int, int) - Method in class javax.swing.plaf.multi.MultiTabbedPaneUI
Invokes the tabForCoordinate method on each UI handled by this object.
tabForCoordinate(JTabbedPane, int, int) - Method in class javax.swing.plaf.TabbedPaneUI
tabInsets - Variable in class javax.swing.plaf.basic.BasicTabbedPaneUI
TABLE - Static variable in class javax.accessibility.AccessibleRole
An object used to present information in terms of rows and columns.
table - Variable in class javax.swing.plaf.basic.BasicTableUI
TABLE - Static variable in class javax.swing.plaf.synth.Region
Table region.
table - Variable in class javax.swing.table.JTableHeader
The table for which this object is the header; the default is null.
TABLE - Static variable in class javax.swing.text.html.HTML.Tag
TABLE_HEADER - Static variable in class javax.swing.plaf.synth.Region
TableHeader region.
TableCell(Element) - Constructor for class javax.swing.text.TableView.TableCell
Deprecated.
Constructs a TableCell for the given element.
TableCellEditor - Interface in javax.swing.table
This interface defines the method any object that would like to be an editor of values for components such as JListBox, JComboBox, JTree, or JTable needs to implement.
TableCellRenderer - Interface in javax.swing.table
This interface defines the method required by any object that would like to be a renderer for cells in a JTable.
tableChanged(TableModelEvent) - Method in interface javax.swing.event.TableModelListener
This fine grain notification tells listeners the exact range of cells, rows, or columns that changed.
tableChanged(TableModelEvent) - Method in class javax.swing.JTable.AccessibleJTable
Track changes to the table contents
tableChanged(TableModelEvent) - Method in class javax.swing.JTable
Invoked when this table's TableModel generates a TableModelEvent.
TableColumn - Class in javax.swing.table
A TableColumn represents all the attributes of a column in a JTable, such as width, resizability, minimum and maximum width.
TableColumn() - Constructor for class javax.swing.table.TableColumn
Cover method, using a default model index of 0, default width of 75, a null renderer and a null editor.
TableColumn(int) - Constructor for class javax.swing.table.TableColumn
Cover method, using a default width of 75, a null renderer and a null editor.
TableColumn(int, int) - Constructor for class javax.swing.table.TableColumn
Cover method, using a null renderer and a null editor.
TableColumn(int, int, TableCellRenderer, TableCellEditor) - Constructor for class javax.swing.table.TableColumn
Creates and initializes an instance of TableColumn with the specified model index, width, cell renderer, and cell editor; all TableColumn constructors delegate to this one.
TableColumnModel - Interface in javax.swing.table
Defines the requirements for a table column model object suitable for use with JTable.
TableColumnModelEvent - Class in javax.swing.event
TableColumnModelEvent is used to notify listeners that a table column model has changed, such as a column was added, removed, or moved.
TableColumnModelEvent(TableColumnModel, int, int) - Constructor for class javax.swing.event.TableColumnModelEvent
Constructs a TableColumnModelEvent object.
TableColumnModelListener - Interface in javax.swing.event
TableColumnModelListener defines the interface for an object that listens to changes in a TableColumnModel.
tableColumns - Variable in class javax.swing.table.DefaultTableColumnModel
Array of TableColumn objects in this model
tableHeader - Variable in class javax.swing.JTable
The TableHeader working with the table.
TableHeaderBorder() - Constructor for class javax.swing.plaf.metal.MetalBorders.TableHeaderBorder
TableHeaderUI - Class in javax.swing.plaf
Pluggable look and feel interface for JTableHeader.
TableHeaderUI() - Constructor for class javax.swing.plaf.TableHeaderUI
tableIndexClustered - Static variable in interface java.sql.DatabaseMetaData
Indicates that this table index is a clustered index.
tableIndexHashed - Static variable in interface java.sql.DatabaseMetaData
Indicates that this table index is a hashed index.
tableIndexOther - Static variable in interface java.sql.DatabaseMetaData
Indicates that this table index is not a clustered index, a hashed index, or table statistics; it is something other than these.
tableIndexStatistic - Static variable in interface java.sql.DatabaseMetaData
Indicates that this column contains table statistics that are returned in conjunction with a table's index descriptions.
TableModel - Interface in javax.swing.table
The TableModel interface specifies the methods the JTable will use to interrogate a tabular data model.
TableModelEvent - Class in javax.swing.event
TableModelEvent is used to notify listeners that a table model has changed.
TableModelEvent(TableModel) - Constructor for class javax.swing.event.TableModelEvent
All row data in the table has changed, listeners should discard any state that was based on the rows and requery the TableModel to get the new row count and all the appropriate values.
TableModelEvent(TableModel, int) - Constructor for class javax.swing.event.TableModelEvent
This row of data has been updated.
TableModelEvent(TableModel, int, int) - Constructor for class javax.swing.event.TableModelEvent
The data in rows [firstRow, lastRow] have been updated.
TableModelEvent(TableModel, int, int, int) - Constructor for class javax.swing.event.TableModelEvent
The cells in column column in the range [firstRow, lastRow] have been updated.
TableModelEvent(TableModel, int, int, int, int) - Constructor for class javax.swing.event.TableModelEvent
The cells from (firstRow, column) to (lastRow, column) have been changed.
TableModelListener - Interface in javax.swing.event
TableModelListener defines the interface for an object that listens to changes in a TableModel.
TableRow(Element) - Constructor for class javax.swing.text.TableView.TableRow
Constructs a TableView for the given element.
tableRowsDeleted(TableModelEvent) - Method in class javax.swing.JTable.AccessibleJTable
Track changes to the table contents (row deletions)
tableRowsInserted(TableModelEvent) - Method in class javax.swing.JTable.AccessibleJTable
Track changes to the table contents (row insertions)
TableRowSorter<M extends TableModel> - Class in javax.swing.table
An implementation of RowSorter that provides sorting and filtering using a TableModel.
TableRowSorter() - Constructor for class javax.swing.table.TableRowSorter
Creates a TableRowSorter with an empty model.
TableRowSorter(M) - Constructor for class javax.swing.table.TableRowSorter
Creates a TableRowSorter using model as the underlying TableModel.
TableStringConverter - Class in javax.swing.table
TableStringConverter is used to convert objects from the model into strings.
TableStringConverter() - Constructor for class javax.swing.table.TableStringConverter
TableUI - Class in javax.swing.plaf
Pluggable look and feel interface for JTable.
TableUI() - Constructor for class javax.swing.plaf.TableUI
TableView - Class in javax.swing.text
Implements View interface for a table, that is composed of an element structure where the child elements of the element this view is responsible for represent rows and the child elements of the row elements are cells.
TableView(Element) - Constructor for class javax.swing.text.TableView
Constructs a TableView for the given element.
TableView.TableCell - Class in javax.swing.text
Deprecated.
A table cell can now be any View implementation.
TableView.TableRow - Class in javax.swing.text
View of a row in a row-centric table.
TABLOID - Static variable in class java.awt.PageAttributes.MediaType
An alias for LEDGER.
TABLOID - Static variable in class javax.print.attribute.standard.MediaSize.Other
Specifies the tabloid size, 11 inches by 17 inches.
TABLOID - Static variable in class javax.print.attribute.standard.MediaSizeName
tabloid size .
tabPane - Variable in class javax.swing.plaf.basic.BasicTabbedPaneUI
tabPlacement - Variable in class javax.swing.JTabbedPane
Where the tabs are placed.
tabRunOverlay - Variable in class javax.swing.plaf.basic.BasicTabbedPaneUI
tabRuns - Variable in class javax.swing.plaf.basic.BasicTabbedPaneUI
TabSelectionHandler() - Constructor for class javax.swing.plaf.basic.BasicTabbedPaneUI.TabSelectionHandler
TabSet - Static variable in class javax.swing.text.StyleConstants
TabSet for the paragraph, type is a TabSet containing TabStops.
TabSet - Class in javax.swing.text
A TabSet is comprised of many TabStops.
TabSet(TabStop[]) - Constructor for class javax.swing.text.TabSet
Creates and returns an instance of TabSet.
tabSizeAttribute - Static variable in class javax.swing.text.PlainDocument
Name of the attribute that specifies the tab size for tabs contained in the content.
TabStop - Class in javax.swing.text
This class encapsulates a single tab stop (basically as tab stops are thought of by RTF).
TabStop(float) - Constructor for class javax.swing.text.TabStop
Creates a tab at position pos with a default alignment and default leader.
TabStop(float, int, int) - Constructor for class javax.swing.text.TabStop
Creates a tab with the specified position pos, alignment align and leader leader.
TabularData - Interface in javax.management.openmbean
The TabularData interface specifies the behavior of a specific type of complex open data objects which represent tabular data structures.
TabularDataSupport - Class in javax.management.openmbean
The TabularDataSupport class is the open data class which implements the TabularData and the Map interfaces, and which is internally based on a hash map data structure.
TabularDataSupport(TabularType) - Constructor for class javax.management.openmbean.TabularDataSupport
Creates an empty TabularDataSupport instance whose open-type is tabularType, and whose underlying HashMap has a default initial capacity (101) and default load factor (0.75).
TabularDataSupport(TabularType, int, float) - Constructor for class javax.management.openmbean.TabularDataSupport
Creates an empty TabularDataSupport instance whose open-type is tabularType, and whose underlying HashMap has the specified initial capacity and load factor.
TabularType - Class in javax.management.openmbean
The TabularType class is the open type class whose instances describe the types of TabularData values.
TabularType(String, String, CompositeType, String[]) - Constructor for class javax.management.openmbean.TabularType
Constructs a TabularType instance, checking for the validity of the given parameters.
Tag() - Constructor for class javax.swing.text.html.HTML.Tag
Tag(String) - Constructor for class javax.swing.text.html.HTML.Tag
Creates a new Tag with the specified id, and with causesBreak and isBlock set to false.
Tag(String, boolean, boolean) - Constructor for class javax.swing.text.html.HTML.Tag
Creates a new Tag with the specified id; causesBreak and isBlock are defined by the user.
tag - Variable in class org.omg.IOP.TaggedComponent
The tag, represented as a component id.
tag - Variable in class org.omg.IOP.TaggedProfile
The tag, represented as a profile id.
TAG_ACNT - Static variable in interface java.awt.font.OpenType
Accent attachment.
TAG_ALTERNATE_IIOP_ADDRESS - Interface in org.omg.IOP
org/omg/IOP/TAG_ALTERNATE_IIOP_ADDRESS.java .
TAG_AVAR - Static variable in interface java.awt.font.OpenType
Axis variation.
TAG_BASE - Static variable in interface java.awt.font.OpenType
Baseline data.
TAG_BDAT - Static variable in interface java.awt.font.OpenType
Bitmap data.
TAG_BLOC - Static variable in interface java.awt.font.OpenType
Bitmap location.
TAG_BSLN - Static variable in interface java.awt.font.OpenType
Baseline table.
TAG_CFF - Static variable in interface java.awt.font.OpenType
Compact font format (Type1 font).
TAG_CMAP - Static variable in interface java.awt.font.OpenType
Character to glyph mapping.
TAG_CODE_SETS - Interface in org.omg.IOP
org/omg/IOP/TAG_CODE_SETS.java .
TAG_CVAR - Static variable in interface java.awt.font.OpenType
CVT variation.
TAG_CVT - Static variable in interface java.awt.font.OpenType
Control value table.
TAG_DSIG - Static variable in interface java.awt.font.OpenType
Digital signature.
TAG_EBDT - Static variable in interface java.awt.font.OpenType
Embedded bitmap data.
TAG_EBLC - Static variable in interface java.awt.font.OpenType
Embedded bitmap location.
TAG_EBSC - Static variable in interface java.awt.font.OpenType
Embedded bitmap scaling.
TAG_FDSC - Static variable in interface java.awt.font.OpenType
Font descriptors.
TAG_FEAT - Static variable in interface java.awt.font.OpenType
Feature name.
TAG_FMTX - Static variable in interface java.awt.font.OpenType
Font metrics.
TAG_FPGM - Static variable in interface java.awt.font.OpenType
Font program.
TAG_FVAR - Static variable in interface java.awt.font.OpenType
Font variation.
TAG_GASP - Static variable in interface java.awt.font.OpenType
Grid-fitting and scan conversion procedure.
TAG_GDEF - Static variable in interface java.awt.font.OpenType
Glyph definition.
TAG_GLYF - Static variable in interface java.awt.font.OpenType
Glyph data.
TAG_GPOS - Static variable in interface java.awt.font.OpenType
Glyph positioning.
TAG_GSUB - Static variable in interface java.awt.font.OpenType
Glyph substitution.
TAG_GVAR - Static variable in interface java.awt.font.OpenType
Glyph variation.
TAG_HDMX - Static variable in interface java.awt.font.OpenType
Horizontal device metrics.
TAG_HEAD - Static variable in interface java.awt.font.OpenType
Font header.
TAG_HHEA - Static variable in interface java.awt.font.OpenType
Horizontal metrics header.
TAG_HMTX - Static variable in interface java.awt.font.OpenType
Horizontal metrics.
TAG_INTERNET_IOP - Interface in org.omg.IOP
org/omg/IOP/TAG_INTERNET_IOP.java .
TAG_JAVA_CODEBASE - Interface in org.omg.IOP
org/omg/IOP/TAG_JAVA_CODEBASE.java .
TAG_JSTF - Static variable in interface java.awt.font.OpenType
Justification.
TAG_JUST - Static variable in interface java.awt.font.OpenType
Justification.
TAG_KERN - Static variable in interface java.awt.font.OpenType
Kerning.
TAG_LCAR - Static variable in interface java.awt.font.OpenType
Ligature caret.
TAG_LOCA - Static variable in interface java.awt.font.OpenType
Index to location.
TAG_LTSH - Static variable in interface java.awt.font.OpenType
Linear threshold.
TAG_MAXP - Static variable in interface java.awt.font.OpenType
Maximum profile.
TAG_MMFX - Static variable in interface java.awt.font.OpenType
Multiple master font metrics.
TAG_MMSD - Static variable in interface java.awt.font.OpenType
Multiple master supplementary data.
TAG_MORT - Static variable in interface java.awt.font.OpenType
Glyph metamorphosis.
TAG_MULTIPLE_COMPONENTS - Interface in org.omg.IOP
org/omg/IOP/TAG_MULTIPLE_COMPONENTS.java .
TAG_NAME - Static variable in interface java.awt.font.OpenType
Naming table.
TAG_OPBD - Static variable in interface java.awt.font.OpenType
Optical bounds.
TAG_ORB_TYPE - Interface in org.omg.IOP
org/omg/IOP/TAG_ORB_TYPE.java .
TAG_OS2 - Static variable in interface java.awt.font.OpenType
OS/2 and Windows specific metrics.
TAG_PCLT - Static variable in interface java.awt.font.OpenType
PCL 5 data.
TAG_POLICIES - Interface in org.omg.IOP
org/omg/IOP/TAG_POLICIES.java .
TAG_POST - Static variable in interface java.awt.font.OpenType
PostScript Information.
TAG_PREP - Static variable in interface java.awt.font.OpenType
CVT preprogram.
TAG_PROP - Static variable in interface java.awt.font.OpenType
Glyph properties.
TAG_RMI_CUSTOM_MAX_STREAM_FORMAT - Interface in org.omg.IOP
org/omg/IOP/TAG_RMI_CUSTOM_MAX_STREAM_FORMAT.java .
TAG_TRAK - Static variable in interface java.awt.font.OpenType
Tracking.
TAG_TYP1 - Static variable in interface java.awt.font.OpenType
Adobe Type 1 font data.
TAG_VDMX - Static variable in interface java.awt.font.OpenType
Vertical device metrics.
TAG_VHEA - Static variable in interface java.awt.font.OpenType
Vertical metrics header.
TAG_VMTX - Static variable in interface java.awt.font.OpenType
Vertical metrics.
TagAction() - Constructor for class javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
TAGALOG - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Tagalog" Unicode character block.
TAGBANWA - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Tagbanwa" Unicode character block.
TagElement - Class in javax.swing.text.html.parser
A generic HTML TagElement class.
TagElement(Element) - Constructor for class javax.swing.text.html.parser.TagElement
TagElement(Element, boolean) - Constructor for class javax.swing.text.html.parser.TagElement
TaggedComponent - Class in org.omg.IOP
org/omg/IOP/TaggedComponent.java .
TaggedComponent() - Constructor for class org.omg.IOP.TaggedComponent
TaggedComponent(int, byte[]) - Constructor for class org.omg.IOP.TaggedComponent
TaggedComponentHelper - Class in org.omg.IOP
org/omg/IOP/TaggedComponentHelper.java .
TaggedComponentHelper() - Constructor for class org.omg.IOP.TaggedComponentHelper
TaggedComponentHolder - Class in org.omg.IOP
org/omg/IOP/TaggedComponentHolder.java .
TaggedComponentHolder() - Constructor for class org.omg.IOP.TaggedComponentHolder
TaggedComponentHolder(TaggedComponent) - Constructor for class org.omg.IOP.TaggedComponentHolder
TaggedProfile - Class in org.omg.IOP
org/omg/IOP/TaggedProfile.java .
TaggedProfile() - Constructor for class org.omg.IOP.TaggedProfile
TaggedProfile(int, byte[]) - Constructor for class org.omg.IOP.TaggedProfile
TaggedProfileHelper - Class in org.omg.IOP
org/omg/IOP/TaggedProfileHelper.java .
TaggedProfileHelper() - Constructor for class org.omg.IOP.TaggedProfileHelper
TaggedProfileHolder - Class in org.omg.IOP
org/omg/IOP/TaggedProfileHolder.java .
TaggedProfileHolder() - Constructor for class org.omg.IOP.TaggedProfileHolder
TaggedProfileHolder(TaggedProfile) - Constructor for class org.omg.IOP.TaggedProfileHolder
TAGS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Tags" Unicode character block.
TAI_LE - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Tai Le" Unicode character block.
TAI_THAM - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Tai Tham" Unicode character block.
TAI_VIET - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Tai Viet" Unicode character block.
TAI_XUAN_JING_SYMBOLS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Tai Xuan Jing Symbols" Unicode character block.
tailMap(K, boolean) - Method in interface java.util.concurrent.ConcurrentNavigableMap
tailMap(K) - Method in interface java.util.concurrent.ConcurrentNavigableMap
tailMap(K, boolean) - Method in class java.util.concurrent.ConcurrentSkipListMap
tailMap(K) - Method in class java.util.concurrent.ConcurrentSkipListMap
tailMap(K, boolean) - Method in interface java.util.NavigableMap
Returns a view of the portion of this map whose keys are greater than (or equal to, if inclusive is true) fromKey.
tailMap(K) - Method in interface java.util.NavigableMap
Returns a view of the portion of this map whose keys are greater than or equal to fromKey.
tailMap(K) - Method in interface java.util.SortedMap
Returns a view of the portion of this map whose keys are greater than or equal to fromKey.
tailMap(K, boolean) - Method in class java.util.TreeMap
tailMap(K) - Method in class java.util.TreeMap
tailSet(E, boolean) - Method in class java.util.concurrent.ConcurrentSkipListSet
tailSet(E) - Method in class java.util.concurrent.ConcurrentSkipListSet
tailSet(E, boolean) - Method in interface java.util.NavigableSet
Returns a view of the portion of this set whose elements are greater than (or equal to, if inclusive is true) fromElement.
tailSet(E) - Method in interface java.util.NavigableSet
Returns a view of the portion of this set whose elements are greater than or equal to fromElement.
tailSet(E) - Method in interface java.util.SortedSet
Returns a view of the portion of this set whose elements are greater than or equal to fromElement.
tailSet(E, boolean) - Method in class java.util.TreeSet
tailSet(E) - Method in class java.util.TreeSet
TAISHO - Static variable in class java.time.chrono.JapaneseEra
The singleton instance for the 'Taisho' era (1912-07-30 - 1926-12-24) which has the value 0.
TAIWAN - Static variable in class java.util.Locale
Useful constant for country.
take() - Method in interface java.nio.file.WatchService
Retrieves and removes next watch key, waiting if none are yet present.
take() - Method in class java.util.concurrent.ArrayBlockingQueue
take() - Method in interface java.util.concurrent.BlockingDeque
Retrieves and removes the head of the queue represented by this deque (in other words, the first element of this deque), waiting if necessary until an element becomes available.
take() - Method in interface java.util.concurrent.BlockingQueue
Retrieves and removes the head of this queue, waiting if necessary until an element becomes available.
take() - Method in interface java.util.concurrent.CompletionService
Retrieves and removes the Future representing the next completed task, waiting if none are yet present.
take() - Method in class java.util.concurrent.DelayQueue
Retrieves and removes the head of this queue, waiting if necessary until an element with an expired delay is available on this queue.
take() - Method in class java.util.concurrent.ExecutorCompletionService
take() - Method in class java.util.concurrent.LinkedBlockingDeque
take() - Method in class java.util.concurrent.LinkedBlockingQueue
take() - Method in class java.util.concurrent.LinkedTransferQueue
take() - Method in class java.util.concurrent.PriorityBlockingQueue
take() - Method in class java.util.concurrent.SynchronousQueue
Retrieves and removes the head of this queue, waiting if necessary for another thread to insert it.
takeFirst() - Method in interface java.util.concurrent.BlockingDeque
Retrieves and removes the first element of this deque, waiting if necessary until an element becomes available.
takeFirst() - Method in class java.util.concurrent.LinkedBlockingDeque
takeLast() - Method in interface java.util.concurrent.BlockingDeque
Retrieves and removes the last element of this deque, waiting if necessary until an element becomes available.
takeLast() - Method in class java.util.concurrent.LinkedBlockingDeque
TAKRI - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Takri" Unicode character block.
TAMIL - Static variable in class java.awt.font.NumericShaper
Identifies the TAMIL range and decimal base.
TAMIL - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Tamil" Unicode character block.
tan(double) - Static method in class java.lang.Math
Returns the trigonometric tangent of an angle.
tan(double) - Static method in class java.lang.StrictMath
Returns the trigonometric tangent of an angle.
tanh(double) - Static method in class java.lang.Math
Returns the hyperbolic tangent of a double value.
tanh(double) - Static method in class java.lang.StrictMath
Returns the hyperbolic tangent of a double value.
target - Variable in class java.awt.Event
The target component.
Target - Annotation Type in java.lang.annotation
Indicates the contexts in which an annotation type is applicable.
TARGET - Static variable in class javax.swing.text.html.HTML.Attribute
target() - Method in class org.omg.CORBA.Request
Retrieves the the target object reference.
target() - Method in interface org.omg.PortableInterceptor.ClientRequestInfoOperations
Returns the object which the client called to perform the operation.
target_is_a(String) - Method in interface org.omg.PortableInterceptor.ServerRequestInfoOperations
Returns true if the servant is the given repository id, false if it is not.
target_most_derived_interface() - Method in interface org.omg.PortableInterceptor.ServerRequestInfoOperations
Returns the repository id for the most derived interface of the servant.
TargetDataLine - Interface in javax.sound.sampled
A target data line is a type of DataLine from which audio data can be read.
TargetedNotification - Class in javax.management.remote
A (Notification, Listener ID) pair.
TargetedNotification(Notification, Integer) - Constructor for class javax.management.remote.TargetedNotification
Constructs a TargetedNotification object.
targetMustExist() - Method in interface javax.naming.event.EventContext
Determines whether a listener can register interest in a target that does not exist.
TC_ARRAY - Static variable in interface java.io.ObjectStreamConstants
new Array.
TC_BASE - Static variable in interface java.io.ObjectStreamConstants
First tag value.
TC_BLOCKDATA - Static variable in interface java.io.ObjectStreamConstants
Block of optional data.
TC_BLOCKDATALONG - Static variable in interface java.io.ObjectStreamConstants
long Block data.
TC_CLASS - Static variable in interface java.io.ObjectStreamConstants
Reference to Class.
TC_CLASSDESC - Static variable in interface java.io.ObjectStreamConstants
new Class Descriptor.
TC_ENDBLOCKDATA - Static variable in interface java.io.ObjectStreamConstants
End of optional block data blocks for an object.
TC_ENUM - Static variable in interface java.io.ObjectStreamConstants
new Enum constant.
TC_EXCEPTION - Static variable in interface java.io.ObjectStreamConstants
Exception during write.
TC_LONGSTRING - Static variable in interface java.io.ObjectStreamConstants
Long string.
TC_MAX - Static variable in interface java.io.ObjectStreamConstants
Last tag value.
TC_NULL - Static variable in interface java.io.ObjectStreamConstants
Null object reference.
TC_OBJECT - Static variable in interface java.io.ObjectStreamConstants
new Object.
TC_PROXYCLASSDESC - Static variable in interface java.io.ObjectStreamConstants
new Proxy Class Descriptor.
TC_REFERENCE - Static variable in interface java.io.ObjectStreamConstants
Reference to an object already written into the stream.
TC_RESET - Static variable in interface java.io.ObjectStreamConstants
Reset stream context.
TC_STRING - Static variable in interface java.io.ObjectStreamConstants
new String.
TCKind - Class in org.omg.CORBA
The Java mapping of the IDL enum TCKind, which specifies the kind of a TypeCode object.
TCKind(int) - Constructor for class org.omg.CORBA.TCKind
Deprecated.
Do not use this constructor as this method should be private according to the OMG specification. Use TCKind.from_int(int) instead.
TCP_NODELAY - Static variable in interface java.net.SocketOptions
Disable Nagle's algorithm for this connection.
TCP_NODELAY - Static variable in class java.net.StandardSocketOptions
Disable the Nagle algorithm.
TD - Static variable in class javax.swing.text.html.HTML.Tag
TELUGU - Static variable in class java.awt.font.NumericShaper
Identifies the TELUGU range and decimal base.
TELUGU - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Telugu" Unicode character block.
Templates - Interface in javax.xml.transform
An object that implements this interface is the runtime representation of processed transformation instructions.
TemplatesHandler - Interface in javax.xml.transform.sax
A SAX ContentHandler that may be used to process SAX parse events (parsing transformation instructions) into a Templates object.
Temporal - Interface in java.time.temporal
Framework-level interface defining read-write access to a temporal object, such as a date, time, offset or some combination of these.
TemporalAccessor - Interface in java.time.temporal
Framework-level interface defining read-only access to a temporal object, such as a date, time, offset or some combination of these.
TemporalAdjuster - Interface in java.time.temporal
Strategy for adjusting a temporal object.
TemporalAdjusters - Class in java.time.temporal
Common and useful TemporalAdjusters.
TemporalAmount - Interface in java.time.temporal
Framework-level interface defining an amount of time, such as "6 hours", "8 days" or "2 years and 3 months".
TemporalField - Interface in java.time.temporal
A field of date-time, such as month-of-year or hour-of-minute.
TemporalQueries - Class in java.time.temporal
Common implementations of TemporalQuery.
TemporalQuery<R> - Interface in java.time.temporal
Strategy for querying a temporal object.
TemporalUnit - Interface in java.time.temporal
A unit of date-time, such as Days or Hours.
TEN - Static variable in class java.math.BigDecimal
The value 10, with a scale of 0.
TEN - Static variable in class java.math.BigInteger
The BigInteger constant ten.
terminated() - Method in class java.util.concurrent.ThreadPoolExecutor
Method invoked when the Executor has terminated.
TERTIARY - Static variable in class java.text.Collator
Collator strength value.
tertiaryOrder(int) - Static method in class java.text.CollationElementIterator
Return the tertiary component of a collation element.
test(T, U) - Method in interface java.util.function.BiPredicate
Evaluates this predicate on the given arguments.
test(double) - Method in interface java.util.function.DoublePredicate
Evaluates this predicate on the given argument.
test(int) - Method in interface java.util.function.IntPredicate
Evaluates this predicate on the given argument.
test(long) - Method in interface java.util.function.LongPredicate
Evaluates this predicate on the given argument.
test(T) - Method in interface java.util.function.Predicate
Evaluates this predicate on the given argument.
testBit(int) - Method in class java.math.BigInteger
Returns true if and only if the designated bit is set.
TEXT - Static variable in class java.awt.SystemColor
The array index for the SystemColor.text system color.
text - Static variable in class java.awt.SystemColor
The color rendered for the background of text control objects, such as textfields and comboboxes.
TEXT - Static variable in class javax.accessibility.AccessibleRole
An object that presents text to the user.
text - Variable in class javax.accessibility.AccessibleTextSequence
The text
text(Element) - Method in class javax.swing.text.AbstractWriter
Writes out text.
TEXT - Static variable in class javax.swing.text.html.HTML.Attribute
text(Element) - Method in class javax.swing.text.html.HTMLWriter
Writes out text.
text(Element) - Method in class javax.swing.text.html.MinimalHTMLWriter
Writes out text.
Text - Interface in javax.xml.soap
A representation of a node whose value is text.
Text - Interface in org.w3c.dom
The Text interface inherits from CharacterData and represents the textual content (termed character data in XML) of an Element or Attr.
TEXT_ALIGN - Static variable in class javax.swing.text.html.CSS.Attribute
TEXT_AREA - Static variable in class javax.swing.plaf.synth.Region
TextArea region.
TEXT_BACKGROUND - Static variable in class javax.swing.plaf.synth.ColorType
ColorType for the background of a region.
TEXT_CHANGED_PROPERTY - Static variable in class javax.swing.AbstractButton
Identifies a change in the button's text.
TEXT_CURSOR - Static variable in class java.awt.Cursor
The text cursor type.
TEXT_CURSOR - Static variable in class java.awt.Frame
Deprecated.
replaced by Cursor.TEXT_CURSOR.
TEXT_DECORATION - Static variable in class javax.swing.text.html.CSS.Attribute
TEXT_EVENT_MASK - Static variable in class java.awt.AWTEvent
The event mask for selecting text events.
TEXT_FIELD - Static variable in class javax.swing.plaf.synth.Region
TextField region.
TEXT_FIRST - Static variable in class java.awt.event.TextEvent
The first number in the range of ids used for text events.
TEXT_FOREGROUND - Static variable in class javax.swing.plaf.synth.ColorType
ColorType for the foreground of a region.
TEXT_HIGHLIGHT - Static variable in class java.awt.SystemColor
The array index for the SystemColor.textHighlight system color.
TEXT_HIGHLIGHT_TEXT - Static variable in class java.awt.SystemColor
The array index for the SystemColor.textHighlightText system color.
TEXT_HTML - Static variable in class javax.print.DocFlavor.CHAR_ARRAY
Doc flavor with MIME type = "text/html; charset=utf-16", print data representation class name = "[C" (character array).
TEXT_HTML - Static variable in class javax.print.DocFlavor.READER
Doc flavor with MIME type = "text/html; charset=utf-16", print data representation class name = "java.io.Reader" (character stream).
TEXT_HTML - Static variable in class javax.print.DocFlavor.STRING
Doc flavor with MIME type = "text/html; charset=utf-16", print data representation class name = "java.lang.String".
TEXT_HTML_HOST - Static variable in class javax.print.DocFlavor.BYTE_ARRAY
Doc flavor with MIME type = "text/html", encoded in the host platform encoding.
TEXT_HTML_HOST - Static variable in class javax.print.DocFlavor.INPUT_STREAM
Doc flavor with MIME type = "text/html", encoded in the host platform encoding.
TEXT_HTML_HOST - Static variable in class javax.print.DocFlavor.URL
Doc flavor with MIME type = "text/html", encoded in the host platform encoding.
TEXT_HTML_US_ASCII - Static variable in class javax.print.DocFlavor.BYTE_ARRAY
Doc flavor with MIME type = "text/html; charset=us-ascii", print data representation class name = "[B" (byte array).
TEXT_HTML_US_ASCII - Static variable in class javax.print.DocFlavor.INPUT_STREAM
Doc flavor with MIME type = "text/html; charset=us-ascii", print data representation class name = "java.io.InputStream" (byte stream).
TEXT_HTML_US_ASCII - Static variable in class javax.print.DocFlavor.URL
Doc flavor with MIME type = "text/html; charset=us-ascii", print data representation class name = "java.net.URL" (byte stream).
TEXT_HTML_UTF_16 - Static variable in class javax.print.DocFlavor.BYTE_ARRAY
Doc flavor with MIME type = "text/html; charset=utf-16", print data representation class name = "[B" (byte array).
TEXT_HTML_UTF_16 - Static variable in class javax.print.DocFlavor.INPUT_STREAM
Doc flavor with MIME type = "text/html; charset=utf-16", print data representation class name = "java.io.InputStream" (byte stream).
TEXT_HTML_UTF_16 - Static variable in class javax.print.DocFlavor.URL
Doc flavor with MIME type = "text/html; charset=utf-16", print data representation class name = "java.net.URL" (byte stream).
TEXT_HTML_UTF_16BE - Static variable in class javax.print.DocFlavor.BYTE_ARRAY
Doc flavor with MIME type = "text/html; charset=utf-16be" (big-endian byte ordering), print data representation class name = "[B" (byte array).
TEXT_HTML_UTF_16BE - Static variable in class javax.print.DocFlavor.INPUT_STREAM
Doc flavor with MIME type = "text/html; charset=utf-16be" (big-endian byte ordering), print data representation class name = "java.io.InputStream" (byte stream).
TEXT_HTML_UTF_16BE - Static variable in class javax.print.DocFlavor.URL
Doc flavor with MIME type = "text/html; charset=utf-16be" (big-endian byte ordering), print data representation class name = "java.net.URL" (byte stream).
TEXT_HTML_UTF_16LE - Static variable in class javax.print.DocFlavor.BYTE_ARRAY
Doc flavor with MIME type = "text/html; charset=utf-16le" (little-endian byte ordering), print data representation class name = "[B" (byte array).
TEXT_HTML_UTF_16LE - Static variable in class javax.print.DocFlavor.INPUT_STREAM
Doc flavor with MIME type = "text/html; charset=utf-16le" (little-endian byte ordering), print data representation class name = "java.io.InputStream" (byte stream).
TEXT_HTML_UTF_16LE - Static variable in class javax.print.DocFlavor.URL
Doc flavor with MIME type = "text/html; charset=utf-16le" (little-endian byte ordering), print data representation class name = "java.net.URL" (byte stream).
TEXT_HTML_UTF_8 - Static variable in class javax.print.DocFlavor.BYTE_ARRAY
Doc flavor with MIME type = "text/html; charset=utf-8", print data representation class name = "[B" (byte array).
TEXT_HTML_UTF_8 - Static variable in class javax.print.DocFlavor.INPUT_STREAM
Doc flavor with MIME type = "text/html; charset=utf-8", print data representation class name = "java.io.InputStream" (byte stream).
TEXT_HTML_UTF_8 - Static variable in class javax.print.DocFlavor.URL
Doc flavor with MIME type = "text/html; charset=utf-8", print data representation class name = "java.net.URL" (byte stream).
TEXT_INACTIVE_TEXT - Static variable in class java.awt.SystemColor
The array index for the SystemColor.textInactiveText system color.
TEXT_INDENT - Static variable in class javax.swing.text.html.CSS.Attribute
TEXT_INSET_H - Static variable in class javax.swing.border.TitledBorder
TEXT_LAST - Static variable in class java.awt.event.TextEvent
The last number in the range of ids used for text events.
TEXT_NODE - Static variable in interface org.w3c.dom.Node
The node is a Text node.
TEXT_PANE - Static variable in class javax.swing.plaf.synth.Region
TextPane region.
TEXT_PLAIN - Static variable in class javax.print.DocFlavor.CHAR_ARRAY
Doc flavor with MIME type = "text/plain; charset=utf-16", print data representation class name = "[C" (character array).
TEXT_PLAIN - Static variable in class javax.print.DocFlavor.READER
Doc flavor with MIME type = "text/plain; charset=utf-16", print data representation class name = "java.io.Reader" (character stream).
TEXT_PLAIN - Static variable in class javax.print.DocFlavor.STRING
Doc flavor with MIME type = "text/plain; charset=utf-16", print data representation class name = "java.lang.String".
TEXT_PLAIN_HOST - Static variable in class javax.print.DocFlavor.BYTE_ARRAY
Doc flavor with MIME type = "text/plain", encoded in the host platform encoding.
TEXT_PLAIN_HOST - Static variable in class javax.print.DocFlavor.INPUT_STREAM
Doc flavor with MIME type = "text/plain", encoded in the host platform encoding.
TEXT_PLAIN_HOST - Static variable in class javax.print.DocFlavor.URL
Doc flavor with MIME type = "text/plain", encoded in the host platform encoding.
TEXT_PLAIN_US_ASCII - Static variable in class javax.print.DocFlavor.BYTE_ARRAY
Doc flavor with MIME type = "text/plain; charset=us-ascii", print data representation class name = "[B" (byte array).
TEXT_PLAIN_US_ASCII - Static variable in class javax.print.DocFlavor.INPUT_STREAM
Doc flavor with MIME type = "text/plain; charset=us-ascii", print data representation class name = "java.io.InputStream" (byte stream).
TEXT_PLAIN_US_ASCII - Static variable in class javax.print.DocFlavor.URL
Doc flavor with MIME type = "text/plain; charset=us-ascii", print data representation class name = "java.net.URL" (byte stream).
TEXT_PLAIN_UTF_16 - Static variable in class javax.print.DocFlavor.BYTE_ARRAY
Doc flavor with MIME type = "text/plain; charset=utf-16", print data representation class name = "[B" (byte array).
TEXT_PLAIN_UTF_16 - Static variable in class javax.print.DocFlavor.INPUT_STREAM
Doc flavor with MIME type = "text/plain; charset=utf-16", print data representation class name = "java.io.InputStream" (byte stream).
TEXT_PLAIN_UTF_16 - Static variable in class javax.print.DocFlavor.URL
Doc flavor with MIME type = "text/plain; charset=utf-16", print data representation class name = java.net.URL"" (byte stream).
TEXT_PLAIN_UTF_16BE - Static variable in class javax.print.DocFlavor.BYTE_ARRAY
Doc flavor with MIME type = "text/plain; charset=utf-16be" (big-endian byte ordering), print data representation class name = "[B" (byte array).
TEXT_PLAIN_UTF_16BE - Static variable in class javax.print.DocFlavor.INPUT_STREAM
Doc flavor with MIME type = "text/plain; charset=utf-16be" (big-endian byte ordering), print data representation class name = "java.io.InputStream" (byte stream).
TEXT_PLAIN_UTF_16BE - Static variable in class javax.print.DocFlavor.URL
Doc flavor with MIME type = "text/plain; charset=utf-16be" (big-endian byte ordering), print data representation class name = "java.net.URL" (byte stream).
TEXT_PLAIN_UTF_16LE - Static variable in class javax.print.DocFlavor.BYTE_ARRAY
Doc flavor with MIME type = "text/plain; charset=utf-16le" (little-endian byte ordering), print data representation class name = "[B" (byte array).
TEXT_PLAIN_UTF_16LE - Static variable in class javax.print.DocFlavor.INPUT_STREAM
Doc flavor with MIME type = "text/plain; charset=utf-16le" (little-endian byte ordering), print data representation class name = "java.io.InputStream" (byte stream).
TEXT_PLAIN_UTF_16LE - Static variable in class javax.print.DocFlavor.URL
Doc flavor with MIME type = "text/plain; charset=utf-16le" (little-endian byte ordering), print data representation class name = "java.net.URL" (byte stream).
TEXT_PLAIN_UTF_8 - Static variable in class javax.print.DocFlavor.BYTE_ARRAY
Doc flavor with MIME type = "text/plain; charset=utf-8", print data representation class name = "[B" (byte array).
TEXT_PLAIN_UTF_8 - Static variable in class javax.print.DocFlavor.INPUT_STREAM
Doc flavor with MIME type = "text/plain; charset=utf-8", print data representation class name = "java.io.InputStream" (byte stream).
TEXT_PLAIN_UTF_8 - Static variable in class javax.print.DocFlavor.URL
Doc flavor with MIME type = "text/plain; charset=utf-8", print data representation class name = "java.net.URL" (byte stream).
TEXT_SPACING - Static variable in class javax.swing.border.TitledBorder
TEXT_TEXT - Static variable in class java.awt.SystemColor
The array index for the SystemColor.textText system color.
TEXT_TRANSFORM - Static variable in class javax.swing.text.html.CSS.Attribute
TEXT_VALUE_CHANGED - Static variable in class java.awt.event.TextEvent
This event id indicates that object's text changed.
TextAction - Class in javax.swing.text
An Action implementation useful for key bindings that are shared across a number of different text components.
TextAction(String) - Constructor for class javax.swing.text.TextAction
Creates a new JTextAction object.
TextArea - Class in java.awt
A TextArea object is a multi-line region that displays text.
TextArea() - Constructor for class java.awt.TextArea
Constructs a new text area with the empty string as text.
TextArea(String) - Constructor for class java.awt.TextArea
Constructs a new text area with the specified text.
TextArea(int, int) - Constructor for class java.awt.TextArea
Constructs a new text area with the specified number of rows and columns and the empty string as text.
TextArea(String, int, int) - Constructor for class java.awt.TextArea
Constructs a new text area with the specified text, and with the specified number of rows and columns.
TextArea(String, int, int, int) - Constructor for class java.awt.TextArea
Constructs a new text area with the specified text, and with the rows, columns, and scroll bar visibility as specified.
TEXTAREA - Static variable in class javax.swing.text.html.HTML.Tag
TextArea.AccessibleAWTTextArea - Class in java.awt
This class implements accessibility support for the TextArea class.
textAreaContent(char[]) - Method in class javax.swing.text.html.HTMLDocument.HTMLReader
Adds the given content to the textarea document.
textAreaContent(AttributeSet) - Method in class javax.swing.text.html.HTMLWriter
Writes out text that is contained in a TEXTAREA form element.
TextAttribute - Class in java.awt.font
The TextAttribute class defines attribute keys and attribute values used for text rendering.
TextAttribute(String) - Constructor for class java.awt.font.TextAttribute
Constructs a TextAttribute with the specified name.
TextComponent - Class in java.awt
The TextComponent class is the superclass of any component that allows the editing of some text.
TextComponent.AccessibleAWTTextComponent - Class in java.awt
This class implements accessibility support for the TextComponent class.
TextEvent - Class in java.awt.event
A semantic event which indicates that an object's text changed.
TextEvent(Object, int) - Constructor for class java.awt.event.TextEvent
Constructs a TextEvent object.
TextField - Class in java.awt
A TextField object is a text component that allows for the editing of a single line of text.
TextField() - Constructor for class java.awt.TextField
Constructs a new text field.
TextField(String) - Constructor for class java.awt.TextField
Constructs a new text field initialized with the specified text.
TextField(int) - Constructor for class java.awt.TextField
Constructs a new empty text field with the specified number of columns.
TextField(String, int) - Constructor for class java.awt.TextField
Constructs a new text field initialized with the specified text to be displayed, and wide enough to hold the specified number of columns.
TextField.AccessibleAWTTextField - Class in java.awt
This class implements accessibility support for the TextField class.
TextFieldBorder() - Constructor for class javax.swing.plaf.metal.MetalBorders.TextFieldBorder
textHighlight - Static variable in class java.awt.SystemColor
The color rendered for the background of selected items, such as in menus, comboboxes, and text.
textHighlightText - Static variable in class java.awt.SystemColor
The color rendered for the text of selected items, such as in menus, comboboxes, and text.
TextHitInfo - Class in java.awt.font
The TextHitInfo class represents a character position in a text model, and a bias, or "side," of the character.
textIconGap - Variable in class javax.swing.plaf.basic.BasicTabbedPaneUI
textInactiveText - Static variable in class java.awt.SystemColor
The color rendered for the text of inactive items, such as in menus.
TextInputCallback - Class in javax.security.auth.callback
Underlying security services instantiate and pass a TextInputCallback to the handle method of a CallbackHandler to retrieve generic text information.
TextInputCallback(String) - Constructor for class javax.security.auth.callback.TextInputCallback
Construct a TextInputCallback with a prompt.
TextInputCallback(String, String) - Constructor for class javax.security.auth.callback.TextInputCallback
Construct a TextInputCallback with a prompt and default input value.
TextLayout - Class in java.awt.font
TextLayout is an immutable graphical representation of styled character data.
TextLayout(String, Font, FontRenderContext) - Constructor for class java.awt.font.TextLayout
Constructs a TextLayout from a String and a Font.
TextLayout(String, Map<? extends AttributedCharacterIterator.Attribute, ?>, FontRenderContext) - Constructor for class java.awt.font.TextLayout
Constructs a TextLayout from a String and an attribute set.
TextLayout(AttributedCharacterIterator, FontRenderContext) - Constructor for class java.awt.font.TextLayout
Constructs a TextLayout from an iterator over styled text.
TextLayout.CaretPolicy - Class in java.awt.font
Defines a policy for determining the strong caret location.
TextListener - Interface in java.awt.event
The listener interface for receiving text events.
textListener - Variable in class java.awt.TextComponent
TextMeasurer - Class in java.awt.font
The TextMeasurer class provides the primitive operations needed for line break: measuring up to a given advance, determining the advance of a range of characters, and generating a TextLayout for a range of characters.
TextMeasurer(AttributedCharacterIterator, FontRenderContext) - Constructor for class java.awt.font.TextMeasurer
Constructs a TextMeasurer from the source text.
textNonSelectionColor - Variable in class javax.swing.tree.DefaultTreeCellRenderer
Color to use for the foreground for non-selected nodes.
TextOutputCallback - Class in javax.security.auth.callback
Underlying security services instantiate and pass a TextOutputCallback to the handle method of a CallbackHandler to display information messages, warning messages and error messages.
TextOutputCallback(int, String) - Constructor for class javax.security.auth.callback.TextOutputCallback
Construct a TextOutputCallback with a message type and message to be displayed.
textSelectionColor - Variable in class javax.swing.tree.DefaultTreeCellRenderer
Color to use for the foreground for selected nodes.
TextStyle - Enum in java.time.format
Enumeration of the style of text formatting and parsing.
TextSyntax - Class in javax.print.attribute
Class TextSyntax is an abstract base class providing the common implementation of all attributes whose value is a string.
TextSyntax(String, Locale) - Constructor for class javax.print.attribute.TextSyntax
Constructs a TextAttribute with the specified string and locale.
textText - Static variable in class java.awt.SystemColor
The color rendered for the text of text control objects, such as textfields and comboboxes.
TextUI - Class in javax.swing.plaf
Text editor user interface
TextUI() - Constructor for class javax.swing.plaf.TextUI
TexturePaint - Class in java.awt
The TexturePaint class provides a way to fill a Shape with a texture that is specified as a BufferedImage.
TexturePaint(BufferedImage, Rectangle2D) - Constructor for class java.awt.TexturePaint
Constructs a TexturePaint object.
textValueChanged(TextEvent) - Method in class java.awt.AWTEventMulticaster
textValueChanged(TextEvent) - Method in interface java.awt.event.TextListener
Invoked when the value of the text has changed.
textValueChanged(TextEvent) - Method in class java.awt.TextComponent.AccessibleAWTTextComponent
TextListener notification of a text value change.
TH - Static variable in class javax.swing.text.html.HTML.Tag
THAANA - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Thaana" Unicode character block.
THAI - Static variable in class java.awt.font.NumericShaper
Identifies the THAI range and decimal base.
THAI - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Thai" Unicode character block.
ThaiBuddhistChronology - Class in java.time.chrono
The Thai Buddhist calendar system.
ThaiBuddhistDate - Class in java.time.chrono
A date in the Thai Buddhist calendar system.
ThaiBuddhistEra - Enum in java.time.chrono
An era in the Thai Buddhist calendar system.
the_activator() - Method in interface org.omg.PortableServer.POAOperations
This attribute identifies the adapter activator associated with the POA.
the_activator(AdapterActivator) - Method in interface org.omg.PortableServer.POAOperations
This attribute identifies the adapter activator associated with the POA.
the_children() - Method in interface org.omg.PortableServer.POAOperations
This attribute identifies the current set of all child POAs of the POA.
the_name() - Method in interface org.omg.PortableServer.POAOperations
This attribute identifies the POA relative to its parent.
the_parent() - Method in interface org.omg.PortableServer.POAOperations
This attribute identifies the parent of the POA.
the_POAManager() - Method in interface org.omg.PortableServer.POAOperations
This attribute identifies the POA manager associated with the POA.
thenAccept(Consumer<? super T>) - Method in class java.util.concurrent.CompletableFuture
thenAccept(Consumer<? super T>) - Method in interface java.util.concurrent.CompletionStage
Returns a new CompletionStage that, when this stage completes normally, is executed with this stage's result as the argument to the supplied action.
thenAcceptAsync(Consumer<? super T>) - Method in class java.util.concurrent.CompletableFuture
thenAcceptAsync(Consumer<? super T>, Executor) - Method in class java.util.concurrent.CompletableFuture
thenAcceptAsync(Consumer<? super T>) - Method in interface java.util.concurrent.CompletionStage
Returns a new CompletionStage that, when this stage completes normally, is executed using this stage's default asynchronous execution facility, with this stage's result as the argument to the supplied action.
thenAcceptAsync(Consumer<? super T>, Executor) - Method in interface java.util.concurrent.CompletionStage
Returns a new CompletionStage that, when this stage completes normally, is executed using the supplied Executor, with this stage's result as the argument to the supplied action.
thenAcceptBoth(CompletionStage<? extends U>, BiConsumer<? super T, ? super U>) - Method in class java.util.concurrent.CompletableFuture
thenAcceptBoth(CompletionStage<? extends U>, BiConsumer<? super T, ? super U>) - Method in interface java.util.concurrent.CompletionStage
Returns a new CompletionStage that, when this and the other given stage both complete normally, is executed with the two results as arguments to the supplied action.
thenAcceptBothAsync(CompletionStage<? extends U>, BiConsumer<? super T, ? super U>) - Method in class java.util.concurrent.CompletableFuture
thenAcceptBothAsync(CompletionStage<? extends U>, BiConsumer<? super T, ? super U>, Executor) - Method in class java.util.concurrent.CompletableFuture
thenAcceptBothAsync(CompletionStage<? extends U>, BiConsumer<? super T, ? super U>) - Method in interface java.util.concurrent.CompletionStage
Returns a new CompletionStage that, when this and the other given stage complete normally, is executed using this stage's default asynchronous execution facility, with the two results as arguments to the supplied action.
thenAcceptBothAsync(CompletionStage<? extends U>, BiConsumer<? super T, ? super U>, Executor) - Method in interface java.util.concurrent.CompletionStage
Returns a new CompletionStage that, when this and the other given stage complete normally, is executed using the supplied executor, with the two results as arguments to the supplied function.
thenApply(Function<? super T, ? extends U>) - Method in class java.util.concurrent.CompletableFuture
thenApply(Function<? super T, ? extends U>) - Method in interface java.util.concurrent.CompletionStage
Returns a new CompletionStage that, when this stage completes normally, is executed with this stage's result as the argument to the supplied function.
thenApplyAsync(Function<? super T, ? extends U>) - Method in class java.util.concurrent.CompletableFuture
thenApplyAsync(Function<? super T, ? extends U>, Executor) - Method in class java.util.concurrent.CompletableFuture
thenApplyAsync(Function<? super T, ? extends U>) - Method in interface java.util.concurrent.CompletionStage
Returns a new CompletionStage that, when this stage completes normally, is executed using this stage's default asynchronous execution facility, with this stage's result as the argument to the supplied function.
thenApplyAsync(Function<? super T, ? extends U>, Executor) - Method in interface java.util.concurrent.CompletionStage
Returns a new CompletionStage that, when this stage completes normally, is executed using the supplied Executor, with this stage's result as the argument to the supplied function.
thenCombine(CompletionStage<? extends U>, BiFunction<? super T, ? super U, ? extends V>) - Method in class java.util.concurrent.CompletableFuture
thenCombine(CompletionStage<? extends U>, BiFunction<? super T, ? super U, ? extends V>) - Method in interface java.util.concurrent.CompletionStage
Returns a new CompletionStage that, when this and the other given stage both complete normally, is executed with the two results as arguments to the supplied function.
thenCombineAsync(CompletionStage<? extends U>, BiFunction<? super T, ? super U, ? extends V>) - Method in class java.util.concurrent.CompletableFuture
thenCombineAsync(CompletionStage<? extends U>, BiFunction<? super T, ? super U, ? extends V>, Executor) - Method in class java.util.concurrent.CompletableFuture
thenCombineAsync(CompletionStage<? extends U>, BiFunction<? super T, ? super U, ? extends V>) - Method in interface java.util.concurrent.CompletionStage
Returns a new CompletionStage that, when this and the other given stage complete normally, is executed using this stage's default asynchronous execution facility, with the two results as arguments to the supplied function.
thenCombineAsync(CompletionStage<? extends U>, BiFunction<? super T, ? super U, ? extends V>, Executor) - Method in interface java.util.concurrent.CompletionStage
Returns a new CompletionStage that, when this and the other given stage complete normally, is executed using the supplied executor, with the two results as arguments to the supplied function.
thenComparing(Comparator<? super T>) - Method in interface java.util.Comparator
Returns a lexicographic-order comparator with another comparator.
thenComparing(Function<? super T, ? extends U>, Comparator<? super U>) - Method in interface java.util.Comparator
Returns a lexicographic-order comparator with a function that extracts a key to be compared with the given Comparator.
thenComparing(Function<? super T, ? extends U>) - Method in interface java.util.Comparator
Returns a lexicographic-order comparator with a function that extracts a Comparable sort key.
thenComparingDouble(ToDoubleFunction<? super T>) - Method in interface java.util.Comparator
Returns a lexicographic-order comparator with a function that extracts a double sort key.
thenComparingInt(ToIntFunction<? super T>) - Method in interface java.util.Comparator
Returns a lexicographic-order comparator with a function that extracts a int sort key.
thenComparingLong(ToLongFunction<? super T>) - Method in interface java.util.Comparator
Returns a lexicographic-order comparator with a function that extracts a long sort key.
thenCompose(Function<? super T, ? extends CompletionStage<U>>) - Method in class java.util.concurrent.CompletableFuture
thenCompose(Function<? super T, ? extends CompletionStage<U>>) - Method in interface java.util.concurrent.CompletionStage
Returns a new CompletionStage that, when this stage completes normally, is executed with this stage as the argument to the supplied function.
thenComposeAsync(Function<? super T, ? extends CompletionStage<U>>) - Method in class java.util.concurrent.CompletableFuture
thenComposeAsync(Function<? super T, ? extends CompletionStage<U>>, Executor) - Method in class java.util.concurrent.CompletableFuture
thenComposeAsync(Function<? super T, ? extends CompletionStage<U>>) - Method in interface java.util.concurrent.CompletionStage
Returns a new CompletionStage that, when this stage completes normally, is executed using this stage's default asynchronous execution facility, with this stage as the argument to the supplied function.
thenComposeAsync(Function<? super T, ? extends CompletionStage<U>>, Executor) - Method in interface java.util.concurrent.CompletionStage
Returns a new CompletionStage that, when this stage completes normally, is executed using the supplied Executor, with this stage's result as the argument to the supplied function.
thenRun(Runnable) - Method in class java.util.concurrent.CompletableFuture
thenRun(Runnable) - Method in interface java.util.concurrent.CompletionStage
Returns a new CompletionStage that, when this stage completes normally, executes the given action.
thenRunAsync(Runnable) - Method in class java.util.concurrent.CompletableFuture
thenRunAsync(Runnable, Executor) - Method in class java.util.concurrent.CompletableFuture
thenRunAsync(Runnable) - Method in interface java.util.concurrent.CompletionStage
Returns a new CompletionStage that, when this stage completes normally, executes the given action using this stage's default asynchronous execution facility.
thenRunAsync(Runnable, Executor) - Method in interface java.util.concurrent.CompletionStage
Returns a new CompletionStage that, when this stage completes normally, executes the given action using the supplied Executor.
thickness - Variable in class javax.swing.border.LineBorder
this_object(Servant) - Method in interface org.omg.PortableServer.portable.Delegate
This allows the servant to obtain the object reference for the target CORBA Object it is incarnating for that request.
thisObject() - Method in interface javax.rmi.CORBA.Tie
Returns an object reference for the target object represented by this tie.
Thread - Class in java.lang
A thread is a thread of execution in a program.
Thread() - Constructor for class java.lang.Thread
Allocates a new Thread object.
Thread(Runnable) - Constructor for class java.lang.Thread
Allocates a new Thread object.
Thread(ThreadGroup, Runnable) - Constructor for class java.lang.Thread
Allocates a new Thread object.
Thread(String) - Constructor for class java.lang.Thread
Allocates a new Thread object.
Thread(ThreadGroup, String) - Constructor for class java.lang.Thread
Allocates a new Thread object.
Thread(Runnable, String) - Constructor for class java.lang.Thread
Allocates a new Thread object.
Thread(ThreadGroup, Runnable, String) - Constructor for class java.lang.Thread
Allocates a new Thread object so that it has target as its run object, has the specified name as its name, and belongs to the thread group referred to by group.
Thread(ThreadGroup, Runnable, String, long) - Constructor for class java.lang.Thread
Allocates a new Thread object so that it has target as its run object, has the specified name as its name, and belongs to the thread group referred to by group, and has the specified stack size.
Thread.State - Enum in java.lang
A thread state.
Thread.UncaughtExceptionHandler - Interface in java.lang
Interface for handlers invoked when a Thread abruptly terminates due to an uncaught exception.
THREAD_MXBEAN_NAME - Static variable in class java.lang.management.ManagementFactory
String representation of the ObjectName for the ThreadMXBean.
THREAD_POLICY_ID - Interface in org.omg.PortableServer
org/omg/PortableServer/THREAD_POLICY_ID.java .
ThreadDeath - Error in java.lang
An instance of ThreadDeath is thrown in the victim thread when the (deprecated) Thread.stop() method is invoked.
ThreadDeath() - Constructor for error java.lang.ThreadDeath
ThreadFactory - Interface in java.util.concurrent
An object that creates new threads on demand.
ThreadGroup - Class in java.lang
A thread group represents a set of threads.
ThreadGroup(String) - Constructor for class java.lang.ThreadGroup
Constructs a new thread group.
ThreadGroup(ThreadGroup, String) - Constructor for class java.lang.ThreadGroup
Creates a new thread group.
ThreadInfo - Class in java.lang.management
Thread information.
ThreadLocal<T> - Class in java.lang
This class provides thread-local variables.
ThreadLocal() - Constructor for class java.lang.ThreadLocal
Creates a thread local variable.
ThreadLocalRandom - Class in java.util.concurrent
A random number generator isolated to the current thread.
ThreadMXBean - Interface in java.lang.management
The management interface for the thread system of the Java virtual machine.
ThreadPolicy - Interface in org.omg.PortableServer
The ThreadPolicy specifies the threading model used with the created POA.
ThreadPolicyOperations - Interface in org.omg.PortableServer
The ThreadPolicy specifies the threading model used with the created POA.
ThreadPolicyValue - Class in org.omg.PortableServer
The ThreadPolicyValue can have the following values.
ThreadPolicyValue(int) - Constructor for class org.omg.PortableServer.ThreadPolicyValue
ThreadPoolExecutor - Class in java.util.concurrent
An ExecutorService that executes each submitted task using one of possibly several pooled threads, normally configured using Executors factory methods.
ThreadPoolExecutor(int, int, long, TimeUnit, BlockingQueue<Runnable>) - Constructor for class java.util.concurrent.ThreadPoolExecutor
Creates a new ThreadPoolExecutor with the given initial parameters and default thread factory and rejected execution handler.
ThreadPoolExecutor(int, int, long, TimeUnit, BlockingQueue<Runnable>, ThreadFactory) - Constructor for class java.util.concurrent.ThreadPoolExecutor
Creates a new ThreadPoolExecutor with the given initial parameters and default rejected execution handler.
ThreadPoolExecutor(int, int, long, TimeUnit, BlockingQueue<Runnable>, RejectedExecutionHandler) - Constructor for class java.util.concurrent.ThreadPoolExecutor
Creates a new ThreadPoolExecutor with the given initial parameters and default thread factory.
ThreadPoolExecutor(int, int, long, TimeUnit, BlockingQueue<Runnable>, ThreadFactory, RejectedExecutionHandler) - Constructor for class java.util.concurrent.ThreadPoolExecutor
Creates a new ThreadPoolExecutor with the given initial parameters.
ThreadPoolExecutor.AbortPolicy - Class in java.util.concurrent
A handler for rejected tasks that throws a RejectedExecutionException.
ThreadPoolExecutor.CallerRunsPolicy - Class in java.util.concurrent
A handler for rejected tasks that runs the rejected task directly in the calling thread of the execute method, unless the executor has been shut down, in which case the task is discarded.
ThreadPoolExecutor.DiscardOldestPolicy - Class in java.util.concurrent
A handler for rejected tasks that discards the oldest unhandled request and then retries execute, unless the executor is shut down, in which case the task is discarded.
ThreadPoolExecutor.DiscardPolicy - Class in java.util.concurrent
A handler for rejected tasks that silently discards the rejected task.
threshold - Variable in class javax.xml.ws.soap.MTOMFeature
Property for MTOM threshold value.
THRESHOLD_ERROR - Static variable in class javax.management.monitor.MonitorNotification
Notification type denoting that the type of the thresholds, offset or modulus is not correct.
THRESHOLD_HIGH_VALUE_EXCEEDED - Static variable in class javax.management.monitor.MonitorNotification
Notification type denoting that the observed attribute has exceeded the threshold high value.
THRESHOLD_LOW_VALUE_EXCEEDED - Static variable in class javax.management.monitor.MonitorNotification
Notification type denoting that the observed attribute has exceeded the threshold low value.
THRESHOLD_VALUE_EXCEEDED - Static variable in class javax.management.monitor.MonitorNotification
Notification type denoting that the observed attribute has reached the threshold value.
Throwable - Class in java.lang
The Throwable class is the superclass of all errors and exceptions in the Java language.
Throwable() - Constructor for class java.lang.Throwable
Constructs a new throwable with null as its detail message.
Throwable(String) - Constructor for class java.lang.Throwable
Constructs a new throwable with the specified detail message.
Throwable(String, Throwable) - Constructor for class java.lang.Throwable
Constructs a new throwable with the specified detail message and cause.
Throwable(Throwable) - Constructor for class java.lang.Throwable
Constructs a new throwable with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
Throwable(String, Throwable, boolean, boolean) - Constructor for class java.lang.Throwable
Constructs a new throwable with the specified detail message, cause, suppression enabled or disabled, and writable stack trace enabled or disabled.
throwException(Class<?>, Class<? extends Throwable>) - Static method in class java.lang.invoke.MethodHandles
Produces a method handle which will throw exceptions of the given exType.
throwException() - Method in class java.nio.charset.CoderResult
Throws an exception appropriate to the result described by this object.
throwing(String, String, Throwable) - Method in class java.util.logging.Logger
Log throwing an exception.
thumbColor - Variable in class javax.swing.plaf.basic.BasicScrollBarUI
thumbColor - Static variable in class javax.swing.plaf.metal.MetalSliderUI
thumbDarkShadowColor - Variable in class javax.swing.plaf.basic.BasicScrollBarUI
thumbHighlightColor - Variable in class javax.swing.plaf.basic.BasicScrollBarUI
thumbLightShadowColor - Variable in class javax.swing.plaf.basic.BasicScrollBarUI
thumbnailComplete(ImageReader) - Method in interface javax.imageio.event.IIOReadProgressListener
Reports that a thumbnail read operation has completed.
thumbnailComplete(ImageWriter) - Method in interface javax.imageio.event.IIOWriteProgressListener
Reports that a thumbnail write operation has completed.
thumbnailPassComplete(ImageReader, BufferedImage) - Method in interface javax.imageio.event.IIOReadUpdateListener
Reports that the current thumbnail read operation has completed a progressive pass.
thumbnailPassStarted(ImageReader, BufferedImage, int, int, int, int, int, int, int, int[]) - Method in interface javax.imageio.event.IIOReadUpdateListener
Reports that the current thumbnail read operation is about to begin a progressive pass.
thumbnailProgress(ImageReader, float) - Method in interface javax.imageio.event.IIOReadProgressListener
Reports the approximate degree of completion of the current getThumbnail call within the associated ImageReader.
thumbnailProgress(ImageWriter, float) - Method in interface javax.imageio.event.IIOWriteProgressListener
Reports the approximate degree of completion of the current thumbnail write within the associated ImageWriter.
thumbnails - Variable in class javax.imageio.IIOImage
A List of BufferedImage thumbnails, or null.
thumbnailStarted(ImageReader, int, int) - Method in interface javax.imageio.event.IIOReadProgressListener
Reports that a thumbnail read operation is beginning.
thumbnailStarted(ImageWriter, int, int) - Method in interface javax.imageio.event.IIOWriteProgressListener
Reports that a thumbnail write operation is beginning.
thumbnailUpdate(ImageReader, BufferedImage, int, int, int, int, int, int, int[]) - Method in interface javax.imageio.event.IIOReadUpdateListener
Reports that a given region of a thumbnail image has been updated.
thumbRect - Variable in class javax.swing.plaf.basic.BasicScrollBarUI
thumbRect - Variable in class javax.swing.plaf.basic.BasicSliderUI
THURSDAY - Static variable in class java.util.Calendar
Value of the Calendar.DAY_OF_WEEK field indicating Thursday.
TIBETAN - Static variable in class java.awt.font.NumericShaper
Identifies the TIBETAN range and decimal base.
TIBETAN - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Tibetan" Unicode character block.
tick(Clock, Duration) - Static method in class java.time.Clock
Obtains a clock that returns instants from the specified clock truncated to the nearest occurrence of the specified duration.
TICK_BUFFER - Variable in class javax.swing.plaf.metal.MetalSliderUI
tickLength - Static variable in class javax.swing.plaf.metal.MetalSliderUI
tickMinutes(ZoneId) - Static method in class java.time.Clock
Obtains a clock that returns the current instant ticking in whole minutes using best available system clock.
tickRect - Variable in class javax.swing.plaf.basic.BasicSliderUI
ticks() - Method in class javax.sound.midi.Track
Obtains the length of the track, expressed in MIDI ticks.
tickSeconds(ZoneId) - Static method in class java.time.Clock
Obtains a clock that returns the current instant ticking in whole seconds using best available system clock.
Tie - Interface in javax.rmi.CORBA
Defines methods which all RMI-IIOP server side ties must implement.
TIFINAGH - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Tifinagh" Unicode character block.
tileGridXOffset - Variable in class javax.imageio.ImageWriteParam
The amount by which the tile grid origin should be offset horizontally from the image origin if tiling has been set, or 0 otherwise.
tileGridYOffset - Variable in class javax.imageio.ImageWriteParam
The amount by which the tile grid origin should be offset vertically from the image origin if tiling has been set, or 0 otherwise.
tileHeight - Variable in class javax.imageio.ImageWriteParam
The height of each tile if tiling has been set, or 0 otherwise.
tileIcon - Variable in class javax.swing.border.MatteBorder
TileObserver - Interface in java.awt.image
An interface for objects that wish to be informed when tiles of a WritableRenderedImage become modifiable by some writer via a call to getWritableTile, and when they become unmodifiable via the last call to releaseWritableTile.
tileUpdate(WritableRenderedImage, int, int, boolean) - Method in interface java.awt.image.TileObserver
A tile is about to be updated (it is either about to be grabbed for writing, or it is being released from writing).
tileWidth - Variable in class javax.imageio.ImageWriteParam
The width of each tile if tiling has been set, or 0 otherwise.
tilingMode - Variable in class javax.imageio.ImageWriteParam
The mode controlling tiling settings, which Must be set to one of the four MODE_* values.
tilingSet - Variable in class javax.imageio.ImageWriteParam
A boolean that is true if tiling parameters have been specified.
Time - Class in java.sql
A thin wrapper around the java.util.Date class that allows the JDBC API to identify this as an SQL TIME value.
Time(int, int, int) - Constructor for class java.sql.Time
Deprecated.
Use the constructor that takes a milliseconds value in place of this constructor
Time(long) - Constructor for class java.sql.Time
Constructs a Time object using a milliseconds time value.
TIME - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type TIME.
time - Variable in class java.util.Calendar
The currently set time for this calendar, expressed in milliseconds after January 1, 1970, 0:00:00 GMT.
TIME - Static variable in class javax.xml.datatype.DatatypeConstants
Fully qualified name for W3C XML Schema 1.0 datatype time.
TIME_WITH_TIMEZONE - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type TIME WITH TIMEZONE.
TIME_ZONE - Static variable in class java.text.DateFormat.Field
Constant identifying the time zone field.
TIMED_OUT - Static variable in class javax.print.attribute.standard.PrinterStateReason
The server was able to connect to the output device (or is always connected), but was unable to get a response from the output device.
timedJoin(Thread, long) - Method in enum java.util.concurrent.TimeUnit
Performs a timed Thread.join using this time unit.
timedWait(Object, long) - Method in enum java.util.concurrent.TimeUnit
Performs a timed Object.wait using this time unit.
TimeLimitExceededException - Exception in javax.naming
This exception is thrown when a method does not terminate within the specified time limit.
TimeLimitExceededException() - Constructor for exception javax.naming.TimeLimitExceededException
Constructs a new instance of TimeLimitExceededException.
TimeLimitExceededException(String) - Constructor for exception javax.naming.TimeLimitExceededException
Constructs a new instance of TimeLimitExceededException using the argument supplied.
timeLineOrder() - Static method in interface java.time.chrono.ChronoLocalDate
Gets a comparator that compares ChronoLocalDate in time-line order ignoring the chronology.
timeLineOrder() - Static method in interface java.time.chrono.ChronoLocalDateTime
Gets a comparator that compares ChronoLocalDateTime in time-line order ignoring the chronology.
timeLineOrder() - Static method in interface java.time.chrono.ChronoZonedDateTime
Gets a comparator that compares ChronoZonedDateTime in time-line order ignoring the chronology.
timeLineOrder() - Static method in class java.time.OffsetDateTime
Gets a comparator that compares two OffsetDateTime instances based solely on the instant.
TIMEOUT - Exception in org.omg.CORBA
TIMEOUT is raised when no delivery has been made and the specified time-to-live period has been exceeded.
TIMEOUT() - Constructor for exception org.omg.CORBA.TIMEOUT
Constructs an TIMEOUT exception with minor code set to 0 and CompletionStatus set to COMPLETED_NO.
TIMEOUT(String) - Constructor for exception org.omg.CORBA.TIMEOUT
Constructs an TIMEOUT exception with the specified message.
TIMEOUT(int, CompletionStatus) - Constructor for exception org.omg.CORBA.TIMEOUT
Constructs an TIMEOUT exception with the specified minor code and completion status.
TIMEOUT(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.TIMEOUT
Constructs an TIMEOUT exception with the specified message, minor code, and completion status.
TimeoutException - Exception in java.util.concurrent
Exception thrown when a blocking operation times out.
TimeoutException() - Constructor for exception java.util.concurrent.TimeoutException
Constructs a TimeoutException with no specified detail message.
TimeoutException(String) - Constructor for exception java.util.concurrent.TimeoutException
Constructs a TimeoutException with the specified detail message.
Timer - Class in java.util
A facility for threads to schedule tasks for future execution in a background thread.
Timer() - Constructor for class java.util.Timer
Creates a new timer.
Timer(boolean) - Constructor for class java.util.Timer
Creates a new timer whose associated thread may be specified to run as a daemon.
Timer(String) - Constructor for class java.util.Timer
Creates a new timer whose associated thread has the specified name.
Timer(String, boolean) - Constructor for class java.util.Timer
Creates a new timer whose associated thread has the specified name, and may be specified to run as a daemon.
Timer - Class in javax.management.timer
Provides the implementation of the timer MBean.
Timer() - Constructor for class javax.management.timer.Timer
Default constructor.
timer - Variable in class javax.swing.plaf.basic.BasicTreeUI.ComponentHandler
Timer used when inside a scrollpane and the scrollbar is adjusting.
Timer - Class in javax.swing
Fires one or more ActionEvents at specified intervals.
Timer(int, ActionListener) - Constructor for class javax.swing.Timer
Creates a Timer and initializes both the initial delay and between-event delay to delay milliseconds.
timer - Variable in class javax.swing.tree.DefaultTreeCellEditor
Used before starting the editing session.
TimerMBean - Interface in javax.management.timer
Exposes the management interface of the timer MBean.
TimerNotification - Class in javax.management.timer
This class provides definitions of the notifications sent by timer MBeans.
TimerNotification(String, Object, long, long, String, Integer) - Constructor for class javax.management.timer.TimerNotification
Creates a timer notification object.
TimerTask - Class in java.util
A task that can be scheduled for one-time or repeated execution by a Timer.
TimerTask() - Constructor for class java.util.TimerTask
Creates a new timer task.
TIMES - Static variable in class javax.management.Query
A code representing the Query.times(javax.management.ValueExp, javax.management.ValueExp) expression.
times(ValueExp, ValueExp) - Static method in class javax.management.Query
Returns a binary expression representing the product of two numeric values.
Timestamp - Class in java.security
This class encapsulates information about a signed timestamp.
Timestamp(Date, CertPath) - Constructor for class java.security.Timestamp
Constructs a Timestamp.
Timestamp - Class in java.sql
A thin wrapper around java.util.Date that allows the JDBC API to identify this as an SQL TIMESTAMP value.
Timestamp(int, int, int, int, int, int, int) - Constructor for class java.sql.Timestamp
Deprecated.
instead use the constructor Timestamp(long millis)
Timestamp(long) - Constructor for class java.sql.Timestamp
Constructs a Timestamp object using a milliseconds time value.
TIMESTAMP - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type TIMESTAMP.
timestamp() - Method in class java.util.UUID
The timestamp value associated with this UUID.
TIMESTAMP_WITH_TIMEZONE - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type TIMESTAMP WITH TIMEZONE.
TimeUnit - Enum in java.util.concurrent
A TimeUnit represents time durations at a given unit of granularity and provides utility methods to convert across units, and to perform timing and delay operations in these units.
TimeZone - Class in java.util
TimeZone represents a time zone offset, and also figures out daylight savings.
TimeZone() - Constructor for class java.util.TimeZone
Sole constructor.
TIMEZONE_FIELD - Static variable in class java.text.DateFormat
Useful constant for TIMEZONE field alignment.
TimeZoneNameProvider - Class in java.util.spi
An abstract class for service providers that provide localized time zone names for the TimeZone class.
TimeZoneNameProvider() - Constructor for class java.util.spi.TimeZoneNameProvider
Sole constructor.
TIMING_CLOCK - Static variable in class javax.sound.midi.ShortMessage
Status byte for Timing Clock message (0xF8, or 248).
TINYINT - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type TINYINT.
title - Variable in class javax.swing.border.TitledBorder
title - Variable in class javax.swing.JInternalFrame
The title displayed in this internal frame's title bar.
TITLE - Static variable in class javax.swing.text.html.HTML.Attribute
TITLE - Static variable in class javax.swing.text.html.HTML.Tag
title - Variable in class javax.swing.text.html.parser.DTD
TITLE_PROPERTY - Static variable in class javax.swing.JInternalFrame
Bound property name.
TITLECASE_LETTER - Static variable in class java.lang.Character
General category "Lt" in the Unicode specification.
titleColor - Variable in class javax.swing.border.TitledBorder
TitledBorder - Class in javax.swing.border
A class which implements an arbitrary border with the addition of a String title in a specified position and justification.
TitledBorder(String) - Constructor for class javax.swing.border.TitledBorder
Creates a TitledBorder instance.
TitledBorder(Border) - Constructor for class javax.swing.border.TitledBorder
Creates a TitledBorder instance with the specified border and an empty title.
TitledBorder(Border, String) - Constructor for class javax.swing.border.TitledBorder
Creates a TitledBorder instance with the specified border and title.
TitledBorder(Border, String, int, int) - Constructor for class javax.swing.border.TitledBorder
Creates a TitledBorder instance with the specified border, title, title-justification, and title-position.
TitledBorder(Border, String, int, int, Font) - Constructor for class javax.swing.border.TitledBorder
Creates a TitledBorder instance with the specified border, title, title-justification, title-position, and title-font.
TitledBorder(Border, String, int, int, Font, Color) - Constructor for class javax.swing.border.TitledBorder
Creates a TitledBorder instance with the specified border, title, title-justification, title-position, title-font, and title-color.
TitledBorderUIResource(String) - Constructor for class javax.swing.plaf.BorderUIResource.TitledBorderUIResource
TitledBorderUIResource(Border) - Constructor for class javax.swing.plaf.BorderUIResource.TitledBorderUIResource
TitledBorderUIResource(Border, String) - Constructor for class javax.swing.plaf.BorderUIResource.TitledBorderUIResource
TitledBorderUIResource(Border, String, int, int) - Constructor for class javax.swing.plaf.BorderUIResource.TitledBorderUIResource
TitledBorderUIResource(Border, String, int, int, Font) - Constructor for class javax.swing.plaf.BorderUIResource.TitledBorderUIResource
TitledBorderUIResource(Border, String, int, int, Font, Color) - Constructor for class javax.swing.plaf.BorderUIResource.TitledBorderUIResource
titleFont - Variable in class javax.swing.border.TitledBorder
titleJustification - Variable in class javax.swing.border.TitledBorder
titlePane - Variable in class javax.swing.plaf.basic.BasicInternalFrameUI
TitlePaneLayout() - Constructor for class javax.swing.plaf.basic.BasicInternalFrameTitlePane.TitlePaneLayout
titlePosition - Variable in class javax.swing.border.TitledBorder
TitleProperty - Static variable in interface javax.swing.text.Document
The property name for the title of the document, if there is one.
tk_abstract_interface - Static variable in class org.omg.CORBA.TCKind
The TCKind constant whose value field is initialized with TCKind._tk_abstract_interface.
tk_alias - Static variable in class org.omg.CORBA.TCKind
The TCKind constant whose value field is initialized with TCKind._tk_alias.
tk_any - Static variable in class org.omg.CORBA.TCKind
The TCKind constant whose value field is initialized with TCKind._tk_any.
tk_array - Static variable in class org.omg.CORBA.TCKind
The TCKind constant whose value field is initialized with TCKind._tk_array.
tk_boolean - Static variable in class org.omg.CORBA.TCKind
The TCKind constant whose value field is initialized with TCKind._tk_boolean.
tk_char - Static variable in class org.omg.CORBA.TCKind
The TCKind constant whose value field is initialized with TCKind._tk_char.
tk_double - Static variable in class org.omg.CORBA.TCKind
The TCKind constant whose value field is initialized with TCKind._tk_double.
tk_enum - Static variable in class org.omg.CORBA.TCKind
The TCKind constant whose value field is initialized with TCKind._tk_enum.
tk_except - Static variable in class org.omg.CORBA.TCKind
The TCKind constant whose value field is initialized with TCKind._tk_except.
tk_fixed - Static variable in class org.omg.CORBA.TCKind
The TCKind constant whose value field is initialized with TCKind._tk_fixed.
tk_float - Static variable in class org.omg.CORBA.TCKind
The TCKind constant whose value field is initialized with TCKind._tk_float.
tk_long - Static variable in class org.omg.CORBA.TCKind
The TCKind constant whose value field is initialized with TCKind._tk_long.
tk_longdouble - Static variable in class org.omg.CORBA.TCKind
The TCKind constant whose value field is initialized with TCKind._tk_longdouble.
tk_longlong - Static variable in class org.omg.CORBA.TCKind
The TCKind constant whose value field is initialized with TCKind._tk_longlong.
tk_native - Static variable in class org.omg.CORBA.TCKind
The TCKind constant whose value field is initialized with TCKind._tk_native.
tk_null - Static variable in class org.omg.CORBA.TCKind
The TCKind constant whose value field is initialized with TCKind._tk_null.
tk_objref - Static variable in class org.omg.CORBA.TCKind
The TCKind constant whose value field is initialized with TCKind._tk_objref.
tk_octet - Static variable in class org.omg.CORBA.TCKind
The TCKind constant whose value field is initialized with TCKind._tk_octet.
tk_Principal - Static variable in class org.omg.CORBA.TCKind
The TCKind constant whose value field is initialized with TCKind._tk_Principal.
tk_sequence - Static variable in class org.omg.CORBA.TCKind
The TCKind constant whose value field is initialized with TCKind._tk_sequence.
tk_short - Static variable in class org.omg.CORBA.TCKind
The TCKind constant whose value field is initialized with TCKind._tk_short.
tk_string - Static variable in class org.omg.CORBA.TCKind
The TCKind constant whose value field is initialized with TCKind._tk_string.
tk_struct - Static variable in class org.omg.CORBA.TCKind
The TCKind constant whose value field is initialized with TCKind._tk_struct.
tk_TypeCode - Static variable in class org.omg.CORBA.TCKind
The TCKind constant whose value field is initialized with TCKind._tk_TypeCode.
tk_ulong - Static variable in class org.omg.CORBA.TCKind
The TCKind constant whose value field is initialized with TCKind._tk_ulong.
tk_ulonglong - Static variable in class org.omg.CORBA.TCKind
The TCKind constant whose value field is initialized with TCKind._tk_ulonglong.
tk_union - Static variable in class org.omg.CORBA.TCKind
The TCKind constant whose value field is initialized with TCKind._tk_union.
tk_ushort - Static variable in class org.omg.CORBA.TCKind
The TCKind constant whose value field is initialized with TCKind._tk_ushort.
tk_value - Static variable in class org.omg.CORBA.TCKind
The TCKind constant whose value field is initialized with TCKind._tk_value.
tk_value_box - Static variable in class org.omg.CORBA.TCKind
The TCKind constant whose value field is initialized with TCKind._tk_value_box.
tk_void - Static variable in class org.omg.CORBA.TCKind
The TCKind constant whose value field is initialized with TCKind._tk_void.
tk_wchar - Static variable in class org.omg.CORBA.TCKind
The TCKind constant whose value field is initialized with TCKind._tk_wchar.
tk_wstring - Static variable in class org.omg.CORBA.TCKind
The TCKind constant whose value field is initialized with TCKind._tk_wstring.
TMENDRSCAN - Static variable in interface javax.transaction.xa.XAResource
Ends a recovery scan.
TMFAIL - Static variable in interface javax.transaction.xa.XAResource
Disassociates the caller and marks the transaction branch rollback-only.
TMJOIN - Static variable in interface javax.transaction.xa.XAResource
Caller is joining existing transaction branch.
TMNOFLAGS - Static variable in interface javax.transaction.xa.XAResource
Use TMNOFLAGS to indicate no flags value is selected.
TMONEPHASE - Static variable in interface javax.transaction.xa.XAResource
Caller is using one-phase optimization.
TMRESUME - Static variable in interface javax.transaction.xa.XAResource
Caller is resuming association with a suspended transaction branch.
TMSTARTRSCAN - Static variable in interface javax.transaction.xa.XAResource
Starts a recovery scan.
TMSUCCESS - Static variable in interface javax.transaction.xa.XAResource
Disassociates caller from a transaction branch.
TMSUSPEND - Static variable in interface javax.transaction.xa.XAResource
Caller is suspending (not ending) its association with a transaction branch.
to(File) - Static method in class java.lang.ProcessBuilder.Redirect
Returns a redirect to write to the specified file.
to(TimeUnit) - Method in class java.nio.file.attribute.FileTime
Returns the value at the given unit of granularity.
to_any() - Method in interface org.omg.CORBA.DynAny
Deprecated.
Convert a DynAny object to an Any object.
to_any() - Method in class org.omg.DynamicAny._DynAnyStub
Creates an any value from a DynAny object.
to_any() - Method in class org.omg.DynamicAny._DynArrayStub
Creates an any value from a DynAny object.
to_any() - Method in class org.omg.DynamicAny._DynEnumStub
Creates an any value from a DynAny object.
to_any() - Method in class org.omg.DynamicAny._DynFixedStub
Creates an any value from a DynAny object.
to_any() - Method in class org.omg.DynamicAny._DynSequenceStub
Creates an any value from a DynAny object.
to_any() - Method in class org.omg.DynamicAny._DynStructStub
Creates an any value from a DynAny object.
to_any() - Method in class org.omg.DynamicAny._DynUnionStub
Creates an any value from a DynAny object.
to_any() - Method in class org.omg.DynamicAny._DynValueStub
Creates an any value from a DynAny object.
to_any() - Method in interface org.omg.DynamicAny.DynAnyOperations
Creates an any value from a DynAny object.
to_name(String) - Method in class org.omg.CosNaming._NamingContextExtStub
This operation converts a Stringified Name into an equivalent array of Name Components.
to_name(String) - Method in interface org.omg.CosNaming.NamingContextExtOperations
This operation converts a Stringified Name into an equivalent array of Name Components.
to_string(NameComponent[]) - Method in class org.omg.CosNaming._NamingContextExtStub
This operation creates a stringified name from the array of Name components.
to_string(NameComponent[]) - Method in interface org.omg.CosNaming.NamingContextExtOperations
This operation creates a stringified name from the array of Name components.
to_url(String, String) - Method in class org.omg.CosNaming._NamingContextExtStub
This operation creates a URL based "iiopname://" format name from the Stringified Name of the object.
to_url(String, String) - Method in interface org.omg.CosNaming.NamingContextExtOperations
This operation creates a URL based "iiopname://" format name from the Stringified Name of the object.
toAbsolutePath() - Method in interface java.nio.file.Path
Returns a Path object representing the absolute path of this path.
toArray() - Method in class java.awt.dnd.DragGestureEvent
Returns an Object array of the events comprising the drag gesture.
toArray(Object[]) - Method in class java.awt.dnd.DragGestureEvent
Returns an array of the events comprising the drag gesture.
toArray() - Method in class java.beans.beancontext.BeanContextMembershipEvent
Gets the array of children affected by this event.
toArray() - Method in class java.beans.beancontext.BeanContextSupport
Gets all JavaBean or BeanContext instances currently nested in this BeanContext.
toArray(Object[]) - Method in class java.beans.beancontext.BeanContextSupport
Gets an array containing all children of this BeanContext that match the types contained in arry.
toArray() - Method in class java.util.AbstractCollection
Returns an array containing all of the elements in this collection.
toArray(T[]) - Method in class java.util.AbstractCollection
Returns an array containing all of the elements in this collection; the runtime type of the returned array is that of the specified array.
toArray() - Method in class java.util.ArrayDeque
Returns an array containing all of the elements in this deque in proper sequence (from first to last element).
toArray(T[]) - Method in class java.util.ArrayDeque
Returns an array containing all of the elements in this deque in proper sequence (from first to last element); the runtime type of the returned array is that of the specified array.
toArray() - Method in class java.util.ArrayList
Returns an array containing all of the elements in this list in proper sequence (from first to last element).
toArray(T[]) - Method in class java.util.ArrayList
Returns an array containing all of the elements in this list in proper sequence (from first to last element); the runtime type of the returned array is that of the specified array.
toArray() - Method in interface java.util.Collection
Returns an array containing all of the elements in this collection.
toArray(T[]) - Method in interface java.util.Collection
Returns an array containing all of the elements in this collection; the runtime type of the returned array is that of the specified array.
toArray() - Method in class java.util.concurrent.ArrayBlockingQueue
Returns an array containing all of the elements in this queue, in proper sequence.
toArray(T[]) - Method in class java.util.concurrent.ArrayBlockingQueue
Returns an array containing all of the elements in this queue, in proper sequence; the runtime type of the returned array is that of the specified array.
toArray() - Method in class java.util.concurrent.ConcurrentLinkedDeque
Returns an array containing all of the elements in this deque, in proper sequence (from first to last element).
toArray(T[]) - Method in class java.util.concurrent.ConcurrentLinkedDeque
Returns an array containing all of the elements in this deque, in proper sequence (from first to last element); the runtime type of the returned array is that of the specified array.
toArray() - Method in class java.util.concurrent.ConcurrentLinkedQueue
Returns an array containing all of the elements in this queue, in proper sequence.
toArray(T[]) - Method in class java.util.concurrent.ConcurrentLinkedQueue
Returns an array containing all of the elements in this queue, in proper sequence; the runtime type of the returned array is that of the specified array.
toArray() - Method in class java.util.concurrent.CopyOnWriteArrayList
Returns an array containing all of the elements in this list in proper sequence (from first to last element).
toArray(T[]) - Method in class java.util.concurrent.CopyOnWriteArrayList
Returns an array containing all of the elements in this list in proper sequence (from first to last element); the runtime type of the returned array is that of the specified array.
toArray() - Method in class java.util.concurrent.CopyOnWriteArraySet
Returns an array containing all of the elements in this set.
toArray(T[]) - Method in class java.util.concurrent.CopyOnWriteArraySet
Returns an array containing all of the elements in this set; the runtime type of the returned array is that of the specified array.
toArray() - Method in class java.util.concurrent.DelayQueue
Returns an array containing all of the elements in this queue.
toArray(T[]) - Method in class java.util.concurrent.DelayQueue
Returns an array containing all of the elements in this queue; the runtime type of the returned array is that of the specified array.
toArray() - Method in class java.util.concurrent.LinkedBlockingDeque
Returns an array containing all of the elements in this deque, in proper sequence (from first to last element).
toArray(T[]) - Method in class java.util.concurrent.LinkedBlockingDeque
Returns an array containing all of the elements in this deque, in proper sequence; the runtime type of the returned array is that of the specified array.
toArray() - Method in class java.util.concurrent.LinkedBlockingQueue
Returns an array containing all of the elements in this queue, in proper sequence.
toArray(T[]) - Method in class java.util.concurrent.LinkedBlockingQueue
Returns an array containing all of the elements in this queue, in proper sequence; the runtime type of the returned array is that of the specified array.
toArray() - Method in class java.util.concurrent.PriorityBlockingQueue
Returns an array containing all of the elements in this queue.
toArray(T[]) - Method in class java.util.concurrent.PriorityBlockingQueue
Returns an array containing all of the elements in this queue; the runtime type of the returned array is that of the specified array.
toArray() - Method in class java.util.concurrent.SynchronousQueue
Returns a zero-length array.
toArray(T[]) - Method in class java.util.concurrent.SynchronousQueue
Sets the zeroeth element of the specified array to null (if the array has non-zero length) and returns it.
toArray() - Method in class java.util.LinkedList
Returns an array containing all of the elements in this list in proper sequence (from first to last element).
toArray(T[]) - Method in class java.util.LinkedList
Returns an array containing all of the elements in this list in proper sequence (from first to last element); the runtime type of the returned array is that of the specified array.
toArray() - Method in interface java.util.List
Returns an array containing all of the elements in this list in proper sequence (from first to last element).
toArray(T[]) - Method in interface java.util.List
Returns an array containing all of the elements in this list in proper sequence (from first to last element); the runtime type of the returned array is that of the specified array.
toArray() - Method in class java.util.PriorityQueue
Returns an array containing all of the elements in this queue.
toArray(T[]) - Method in class java.util.PriorityQueue
Returns an array containing all of the elements in this queue; the runtime type of the returned array is that of the specified array.
toArray() - Method in interface java.util.Set
Returns an array containing all of the elements in this set.
toArray(T[]) - Method in interface java.util.Set
Returns an array containing all of the elements in this set; the runtime type of the returned array is that of the specified array.
toArray() - Method in interface java.util.stream.DoubleStream
Returns an array containing the elements of this stream.
toArray() - Method in interface java.util.stream.IntStream
Returns an array containing the elements of this stream.
toArray() - Method in interface java.util.stream.LongStream
Returns an array containing the elements of this stream.
toArray() - Method in interface java.util.stream.Stream
Returns an array containing the elements of this stream.
toArray(IntFunction<A[]>) - Method in interface java.util.stream.Stream
Returns an array containing the elements of this stream, using the provided generator function to allocate the returned array, as well as any additional arrays that might be required for a partitioned execution or for resizing.
toArray() - Method in class java.util.Vector
Returns an array containing all of the elements in this Vector in the correct order.
toArray(T[]) - Method in class java.util.Vector
Returns an array containing all of the elements in this Vector in the correct order; the runtime type of the returned array is that of the specified array.
toArray() - Method in class javax.accessibility.AccessibleRelationSet
Returns the current relation set as an array of AccessibleRelation
toArray() - Method in class javax.accessibility.AccessibleStateSet
Returns the current state set as an array of AccessibleState
toArray() - Method in interface javax.print.attribute.AttributeSet
Returns an array of the attributes contained in this set.
toArray() - Method in class javax.print.attribute.HashAttributeSet
toArray() - Method in class javax.swing.DefaultListModel
Returns an array containing all of the elements in this list in the correct order.
toASCII(String, int) - Static method in class java.net.IDN
Translates a string from Unicode to ASCII Compatible Encoding (ACE), as defined by the ToASCII operation of RFC 3490.
toASCII(String) - Static method in class java.net.IDN
Translates a string from Unicode to ASCII Compatible Encoding (ACE), as defined by the ToASCII operation of RFC 3490.
toASCIIString() - Method in class java.net.URI
Returns the content of this URI as a US-ASCII string.
toAttributes() - Method in class javax.naming.ldap.Rdn
Retrieves the Attributes view of the type/value mappings contained in this Rdn.
toBack() - Method in class java.awt.Dialog
If this Window is visible, sends this Window to the back and may cause it to lose focus or activation if it is the focused or active Window.
toBack() - Method in class java.awt.Window
If this Window is visible, sends this Window to the back and may cause it to lose focus or activation if it is the focused or active Window.
toBack() - Method in class javax.swing.JInternalFrame
Sends this internal frame to the back.
toBigInteger() - Method in class java.math.BigDecimal
Converts this BigDecimal to a BigInteger.
toBigIntegerExact() - Method in class java.math.BigDecimal
Converts this BigDecimal to a BigInteger, checking for lost information.
toBinaryString(int) - Static method in class java.lang.Integer
Returns a string representation of the integer argument as an unsigned integer in base 2.
toBinaryString(long) - Static method in class java.lang.Long
Returns a string representation of the long argument as an unsigned integer in base 2.
TOBOTTOM_TOLEFT - Static variable in class javax.print.attribute.standard.PresentationDirection
Pages are laid out in columns starting at the top right, proceeding towards the bottom & left.
TOBOTTOM_TORIGHT - Static variable in class javax.print.attribute.standard.PresentationDirection
Pages are laid out in columns starting at the top left, proceeding towards the bottom & right.
toBundleName(String, Locale) - Method in class java.util.ResourceBundle.Control
Converts the given baseName and locale to the bundle name.
toByteArray() - Method in class java.io.ByteArrayOutputStream
Creates a newly allocated byte array.
toByteArray() - Method in class java.math.BigInteger
Returns a byte array containing the two's-complement representation of this BigInteger.
toByteArray() - Method in class java.text.CollationKey
Converts the CollationKey to a sequence of bits.
toByteArray() - Method in class java.util.BitSet
Returns a new byte array containing all the bits in this bit set.
toCachedRowSet() - Method in interface javax.sql.rowset.JoinRowSet
Creates a new CachedRowSet object containing the data in this JoinRowSet object, which can be saved to a data source using the SyncProvider object for the CachedRowSet object.
toCharArray() - Method in class java.io.CharArrayWriter
Returns a copy of the input data.
toCharArray() - Method in class java.lang.String
Converts this string to a new character array.
toChars(int, char[], int) - Static method in class java.lang.Character
Converts the specified character (Unicode code point) to its UTF-16 representation.
toChars(int) - Static method in class java.lang.Character
Converts the specified character (Unicode code point) to its UTF-16 representation stored in a char array.
toCIEXYZ(float[]) - Method in class java.awt.color.ColorSpace
Transforms a color value assumed to be in this ColorSpace into the CS_CIEXYZ conversion color space.
toCIEXYZ(float[]) - Method in class java.awt.color.ICC_ColorSpace
Transforms a color value assumed to be in this ColorSpace into the CS_CIEXYZ conversion color space.
toCodePoint(char, char) - Static method in class java.lang.Character
Converts the specified surrogate pair to its supplementary code point value.
toCollection(Supplier<C>) - Static method in class java.util.stream.Collectors
Returns a Collector that accumulates the input elements into a new Collection, in encounter order.
toCollection() - Method in interface javax.sql.rowset.CachedRowSet
Converts this CachedRowSet object to a Collection object that contains all of this CachedRowSet object's data.
toCollection(int) - Method in interface javax.sql.rowset.CachedRowSet
Converts the designated column in this CachedRowSet object to a Collection object.
toCollection(String) - Method in interface javax.sql.rowset.CachedRowSet
Converts the designated column in this CachedRowSet object to a Collection object.
toCompletableFuture() - Method in class java.util.concurrent.CompletableFuture
Returns this CompletableFuture
toCompletableFuture() - Method in interface java.util.concurrent.CompletionStage
Returns a CompletableFuture maintaining the same completion properties as this stage.
toCompositeData(CompositeType) - Method in interface javax.management.openmbean.CompositeDataView
Return a CompositeData corresponding to the values in this object.
toConcurrentMap(Function<? super T, ? extends K>, Function<? super T, ? extends U>) - Static method in class java.util.stream.Collectors
Returns a concurrent Collector that accumulates elements into a ConcurrentMap whose keys and values are the result of applying the provided mapping functions to the input elements.
toConcurrentMap(Function<? super T, ? extends K>, Function<? super T, ? extends U>, BinaryOperator<U>) - Static method in class java.util.stream.Collectors
Returns a concurrent Collector that accumulates elements into a ConcurrentMap whose keys and values are the result of applying the provided mapping functions to the input elements.
toConcurrentMap(Function<? super T, ? extends K>, Function<? super T, ? extends U>, BinaryOperator<U>, Supplier<M>) - Static method in class java.util.stream.Collectors
Returns a concurrent Collector that accumulates elements into a ConcurrentMap whose keys and values are the result of applying the provided mapping functions to the input elements.
toDays() - Method in class java.time.Duration
Gets the number of days in this duration.
toDays(long) - Method in enum java.util.concurrent.TimeUnit
Equivalent to DAYS.convert(duration, this).
toDegrees(double) - Static method in class java.lang.Math
Converts an angle measured in radians to an approximately equivalent angle measured in degrees.
toDegrees(double) - Static method in class java.lang.StrictMath
Converts an angle measured in radians to an approximately equivalent angle measured in degrees.
toDisplayString(String, Locale) - Method in class javax.accessibility.AccessibleBundle
Obtains the key as a localized string.
toDisplayString(Locale) - Method in class javax.accessibility.AccessibleBundle
Obtains the key as a localized string.
toDisplayString() - Method in class javax.accessibility.AccessibleBundle
Gets localized string describing the key using the default locale.
ToDoubleBiFunction<T,U> - Interface in java.util.function
Represents a function that accepts two arguments and produces a double-valued result.
ToDoubleFunction<T> - Interface in java.util.function
Represents a function that produces a double-valued result.
toEngineeringString() - Method in class java.math.BigDecimal
Returns a string representation of this BigDecimal, using engineering notation if an exponent is needed.
toEpochDay() - Method in interface java.time.chrono.ChronoLocalDate
Converts this date to the Epoch Day.
toEpochDay() - Method in class java.time.chrono.HijrahDate
toEpochDay() - Method in class java.time.chrono.JapaneseDate
toEpochDay() - Method in class java.time.chrono.MinguoDate
toEpochDay() - Method in class java.time.chrono.ThaiBuddhistDate
toEpochDay() - Method in class java.time.LocalDate
toEpochMilli() - Method in class java.time.Instant
Converts this instant to the number of milliseconds from the epoch of 1970-01-01T00:00:00Z.
toEpochSecond(ZoneOffset) - Method in interface java.time.chrono.ChronoLocalDateTime
Converts this date-time to the number of seconds from the epoch of 1970-01-01T00:00:00Z.
toEpochSecond() - Method in interface java.time.chrono.ChronoZonedDateTime
Converts this date-time to the number of seconds from the epoch of 1970-01-01T00:00:00Z.
toEpochSecond() - Method in class java.time.OffsetDateTime
Converts this date-time to the number of seconds from the epoch of 1970-01-01T00:00:00Z.
toEpochSecond() - Method in class java.time.zone.ZoneOffsetTransition
Gets the transition instant as an epoch second.
toExternalForm() - Method in class java.net.URL
Constructs a string representation of this URL.
toExternalForm(URL) - Method in class java.net.URLStreamHandler
Converts a URL of a specific protocol to a String.
toFile() - Method in interface java.nio.file.Path
Returns a File object representing this path.
toFormat() - Method in class java.time.format.DateTimeFormatter
Returns this formatter as a java.text.Format instance.
toFormat(TemporalQuery<?>) - Method in class java.time.format.DateTimeFormatter
Returns this formatter as a java.text.Format instance that will parse using the specified query.
toFormatter() - Method in class java.time.format.DateTimeFormatterBuilder
Completes this builder by creating the DateTimeFormatter using the default locale.
toFormatter(Locale) - Method in class java.time.format.DateTimeFormatterBuilder
Completes this builder by creating the DateTimeFormatter using the specified locale.
toFront() - Method in class java.awt.Window
If this Window is visible, brings this Window to the front and may make it the focused Window.
toFront() - Method in class javax.swing.JInternalFrame
Brings this internal frame to the front.
toGenericString() - Method in class java.lang.Class
Returns a string describing this Class, including information about modifiers and type parameters.
toGenericString() - Method in class java.lang.reflect.Constructor
Returns a string describing this Constructor, including type parameters.
toGenericString() - Method in class java.lang.reflect.Executable
Returns a string describing this Executable, including any type parameters.
toGenericString() - Method in class java.lang.reflect.Field
Returns a string describing this Field, including its generic type.
toGenericString() - Method in class java.lang.reflect.Method
Returns a string describing this Method, including type parameters.
TOGGLE_BUTTON - Static variable in class javax.accessibility.AccessibleRole
A specialized push button that can be checked or unchecked, but does not provide a separate indicator for the current state.
TOGGLE_BUTTON - Static variable in class javax.swing.plaf.synth.Region
ToggleButton region.
TOGGLE_CLICK_COUNT_PROPERTY - Static variable in class javax.swing.JTree
Bound property name for toggleClickCount.
TOGGLE_EXPAND - Static variable in interface javax.accessibility.AccessibleAction
An action which causes a tree node to collapse if expanded and expand if collapsed.
TOGGLE_POPUP - Static variable in interface javax.accessibility.AccessibleAction
An action which causes a popup to become visible if it is hidden and hidden if it is visible.
ToggleButtonBorder(Color, Color, Color, Color) - Constructor for class javax.swing.plaf.basic.BasicBorders.ToggleButtonBorder
ToggleButtonBorder() - Constructor for class javax.swing.plaf.metal.MetalBorders.ToggleButtonBorder
ToggleButtonModel() - Constructor for class javax.swing.JToggleButton.ToggleButtonModel
Creates a new ToggleButton Model
toggleClickCount - Variable in class javax.swing.JTree
Number of mouse clicks before a node is expanded.
toggleExpandState(TreePath) - Method in class javax.swing.plaf.basic.BasicTreeUI
Expands path if it is not expanded, or collapses row if it is expanded.
toggleOpenClose() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Hides the popup if it is showing and shows the popup if it is hidden.
togglePopup() - Method in class javax.swing.plaf.basic.BasicComboPopup
Makes the popup visible if it is hidden and makes it hidden if it is visible.
toggleSortOrder(int) - Method in class javax.swing.DefaultRowSorter
Reverses the sort order from ascending to descending (or descending to ascending) if the specified column is already the primary sorted column; otherwise, makes the specified column the primary sorted column, with an ascending sort order.
toggleSortOrder(int) - Method in class javax.swing.RowSorter
Reverses the sort order of the specified column.
toGMTString() - Method in class java.util.Date
Deprecated.
As of JDK version 1.1, replaced by DateFormat.format(Date date), using a GMT TimeZone.
toGregorianCalendar() - Method in class javax.xml.datatype.XMLGregorianCalendar
Convert this XMLGregorianCalendar to a GregorianCalendar.
toGregorianCalendar(TimeZone, Locale, XMLGregorianCalendar) - Method in class javax.xml.datatype.XMLGregorianCalendar
Convert this XMLGregorianCalendar along with provided parameters to a GregorianCalendar instance.
toHexString(double) - Static method in class java.lang.Double
Returns a hexadecimal string representation of the double argument.
toHexString(float) - Static method in class java.lang.Float
Returns a hexadecimal string representation of the float argument.
toHexString(int) - Static method in class java.lang.Integer
Returns a string representation of the integer argument as an unsigned integer in base 16.
toHexString(long) - Static method in class java.lang.Long
Returns a string representation of the long argument as an unsigned integer in base 16.
toHours() - Method in class java.time.Duration
Gets the number of hours in this duration.
toHours(long) - Method in enum java.util.concurrent.TimeUnit
Equivalent to HOURS.convert(duration, this).
toIndex - Variable in class javax.swing.event.TableColumnModelEvent
The index of the column to where it was moved or added
toInstant() - Method in class java.nio.file.attribute.FileTime
Converts this FileTime object to an Instant.
toInstant() - Method in class java.sql.Date
This method always throws an UnsupportedOperationException and should not be used because SQL Date values do not have a time component.
toInstant() - Method in class java.sql.Time
This method always throws an UnsupportedOperationException and should not be used because SQL Time values do not have a date component.
toInstant() - Method in class java.sql.Timestamp
Converts this Timestamp object to an Instant.
toInstant(ZoneOffset) - Method in interface java.time.chrono.ChronoLocalDateTime
Converts this date-time to an Instant.
toInstant() - Method in interface java.time.chrono.ChronoZonedDateTime
Converts this date-time to an Instant.
toInstant() - Method in class java.time.OffsetDateTime
Converts this date-time to an Instant.
toInstant() - Method in class java.util.Calendar
Converts this object to an Instant.
toInstant() - Method in class java.util.Date
Converts this Date object to an Instant.
ToIntBiFunction<T,U> - Interface in java.util.function
Represents a function that accepts two arguments and produces an int-valued result.
toIntExact(long) - Static method in class java.lang.Math
Returns the value of the long argument; throwing an exception if the value overflows an int.
toIntExact(long) - Static method in class java.lang.StrictMath
Returns the value of the long argument; throwing an exception if the value overflows an int.
ToIntFunction<T> - Interface in java.util.function
Represents a function that produces an int-valued result.
toJMXConnector(Map<String, ?>) - Method in class javax.management.remote.JMXConnectorServer
Returns a client stub for this connector server.
toJMXConnector(Map<String, ?>) - Method in interface javax.management.remote.JMXConnectorServerMBean
Returns a client stub for this connector server.
toJMXConnector(Map<String, ?>) - Method in class javax.management.remote.rmi.RMIConnectorServer
Returns a client stub for this connector server.
toLanguageTag() - Method in class java.util.Locale
Returns a well-formed IETF BCP 47 language tag representing this locale.
TOLEFT_TOBOTTOM - Static variable in class javax.print.attribute.standard.PresentationDirection
Pages are laid out in rows starting at the top right, proceeding towards the left & bottom.
TOLEFT_TOTOP - Static variable in class javax.print.attribute.standard.PresentationDirection
Pages are laid out in rows starting at the bottom right, proceeding towards the left & top.
toList() - Static method in class java.util.stream.Collectors
Returns a Collector that accumulates the input elements into a new List.
toLocalDate() - Method in class java.sql.Date
Converts this Date object to a LocalDate
toLocalDate() - Method in interface java.time.chrono.ChronoLocalDateTime
Gets the local date part of this date-time.
toLocalDate() - Method in interface java.time.chrono.ChronoZonedDateTime
Gets the local date part of this date-time.
toLocalDate() - Method in class java.time.LocalDateTime
Gets the LocalDate part of this date-time.
toLocalDate() - Method in class java.time.OffsetDateTime
Gets the LocalDate part of this date-time.
toLocalDate() - Method in class java.time.ZonedDateTime
Gets the LocalDate part of this date-time.
toLocalDateTime() - Method in class java.sql.Timestamp
Converts this Timestamp object to a LocalDateTime.
toLocalDateTime() - Method in interface java.time.chrono.ChronoZonedDateTime
Gets the local date-time part of this date-time.
toLocalDateTime() - Method in class java.time.OffsetDateTime
Gets the LocalDateTime part of this offset date-time.
toLocalDateTime() - Method in class java.time.ZonedDateTime
Gets the LocalDateTime part of this date-time.
toLocaleString() - Method in class java.util.Date
Deprecated.
As of JDK version 1.1, replaced by DateFormat.format(Date date).
toLocalizedPattern() - Method in class java.text.DecimalFormat
Synthesizes a localized pattern string that represents the current state of this Format object.
toLocalizedPattern() - Method in class java.text.SimpleDateFormat
Returns a localized pattern string describing this date format.
toLocalTime() - Method in class java.sql.Time
Converts this Time object to a LocalTime.
toLocalTime() - Method in interface java.time.chrono.ChronoLocalDateTime
Gets the local time part of this date-time.
toLocalTime() - Method in interface java.time.chrono.ChronoZonedDateTime
Gets the local time part of this date-time.
toLocalTime() - Method in class java.time.LocalDateTime
Gets the LocalTime part of this date-time.
toLocalTime() - Method in class java.time.OffsetDateTime
Gets the LocalTime part of this date-time.
toLocalTime() - Method in class java.time.OffsetTime
Gets the LocalTime part of this date-time.
toLocalTime() - Method in class java.time.ZonedDateTime
Gets the LocalTime part of this date-time.
toLongArray() - Method in class java.util.BitSet
Returns a new long array containing all the bits in this bit set.
ToLongBiFunction<T,U> - Interface in java.util.function
Represents a function that accepts two arguments and produces a long-valued result.
ToLongFunction<T> - Interface in java.util.function
Represents a function that produces a long-valued result.
toLowerCase(char) - Static method in class java.lang.Character
Converts the character argument to lowercase using case mapping information from the UnicodeData file.
toLowerCase(int) - Static method in class java.lang.Character
Converts the character (Unicode code point) argument to lowercase using case mapping information from the UnicodeData file.
toLowerCase(Locale) - Method in class java.lang.String
Converts all of the characters in this String to lower case using the rules of the given Locale.
toLowerCase() - Method in class java.lang.String
Converts all of the characters in this String to lower case using the rules of the default locale.
toMap(Function<? super T, ? extends K>, Function<? super T, ? extends U>) - Static method in class java.util.stream.Collectors
Returns a Collector that accumulates elements into a Map whose keys and values are the result of applying the provided mapping functions to the input elements.
toMap(Function<? super T, ? extends K>, Function<? super T, ? extends U>, BinaryOperator<U>) - Static method in class java.util.stream.Collectors
Returns a Collector that accumulates elements into a Map whose keys and values are the result of applying the provided mapping functions to the input elements.
toMap(Function<? super T, ? extends K>, Function<? super T, ? extends U>, BinaryOperator<U>, Supplier<M>) - Static method in class java.util.stream.Collectors
Returns a Collector that accumulates elements into a Map whose keys and values are the result of applying the provided mapping functions to the input elements.
toMatchResult() - Method in class java.util.regex.Matcher
Returns the match state of this matcher as a MatchResult.
toMethodDescriptorString() - Method in class java.lang.invoke.MethodType
Produces a bytecode descriptor representation of the method type.
toMicros(long) - Method in enum java.util.concurrent.TimeUnit
Equivalent to MICROSECONDS.convert(duration, this).
toMillis() - Method in class java.nio.file.attribute.FileTime
Returns the value in milliseconds.
toMillis() - Method in class java.time.Duration
Converts this duration to the total length in milliseconds.
toMillis(long) - Method in enum java.util.concurrent.TimeUnit
Equivalent to MILLISECONDS.convert(duration, this).
toMinutes() - Method in class java.time.Duration
Gets the number of minutes in this duration.
toMinutes(long) - Method in enum java.util.concurrent.TimeUnit
Equivalent to MINUTES.convert(duration, this).
toNanoOfDay() - Method in class java.time.LocalTime
Extracts the time as nanos of day, from 0 to 24 * 60 * 60 * 1,000,000,000 - 1.
toNanos() - Method in class java.time.Duration
Converts this duration to the total length in nanoseconds expressed as a long.
toNanos(long) - Method in enum java.util.concurrent.TimeUnit
Equivalent to NANOSECONDS.convert(duration, this).
TONER_EMPTY - Static variable in class javax.print.attribute.standard.PrinterStateReason
The device is out of toner.
TONER_LOW - Static variable in class javax.print.attribute.standard.PrinterStateReason
The device is low on toner.
toOctalString(int) - Static method in class java.lang.Integer
Returns a string representation of the integer argument as an unsigned integer in base 8.
toOctalString(long) - Static method in class java.lang.Long
Returns a string representation of the long argument as an unsigned integer in base 8.
toOffsetDateTime() - Method in class java.time.ZonedDateTime
Converts this date-time to an OffsetDateTime.
toOffsetTime() - Method in class java.time.OffsetDateTime
Converts this date-time to an OffsetTime.
Tool - Interface in javax.tools
Common interface for tools that can be invoked from a program.
TOOL_BAR - Static variable in class javax.accessibility.AccessibleRole
A bar or palette usually composed of push buttons or toggle buttons.
TOOL_BAR - Static variable in class javax.swing.plaf.synth.Region
ToolBar region.
TOOL_BAR_CONTENT - Static variable in class javax.swing.plaf.synth.Region
Region of the ToolBar containing the content.
TOOL_BAR_DRAG_WINDOW - Static variable in class javax.swing.plaf.synth.Region
Region for the Window containing the ToolBar.
TOOL_BAR_SEPARATOR - Static variable in class javax.swing.plaf.synth.Region
ToolBar separator region.
TOOL_TIP - Static variable in class javax.accessibility.AccessibleRole
An object that provides information about another object.
TOOL_TIP - Static variable in class javax.swing.plaf.synth.Region
ToolTip region.
TOOL_TIP_TEXT_KEY - Static variable in class javax.swing.JComponent
The comment to display when the cursor is over the component, also known as a "value tip", "flyover help", or "flyover label".
toolBar - Variable in class javax.swing.plaf.basic.BasicToolBarUI.DockingListener
toolBar - Variable in class javax.swing.plaf.basic.BasicToolBarUI
ToolBarBorder() - Constructor for class javax.swing.plaf.metal.MetalBorders.ToolBarBorder
toolBarContListener - Variable in class javax.swing.plaf.basic.BasicToolBarUI
ToolBarContListener() - Constructor for class javax.swing.plaf.basic.BasicToolBarUI.ToolBarContListener
toolBarFocusListener - Variable in class javax.swing.plaf.basic.BasicToolBarUI
ToolBarFocusListener() - Constructor for class javax.swing.plaf.basic.BasicToolBarUI.ToolBarFocusListener
ToolBarUI - Class in javax.swing.plaf
Pluggable look and feel interface for JToolBar.
ToolBarUI() - Constructor for class javax.swing.plaf.ToolBarUI
Toolkit - Class in java.awt
This class is the abstract superclass of all actual implementations of the Abstract Window Toolkit.
Toolkit() - Constructor for class java.awt.Toolkit
ToolProvider - Class in javax.tools
Provides methods for locating tool providers, for example, providers of compilers.
ToolTipManager - Class in javax.swing
Manages all the ToolTips in the system.
ToolTipManager.insideTimerAction - Class in javax.swing
ToolTipManager.outsideTimerAction - Class in javax.swing
ToolTipManager.stillInsideTimerAction - Class in javax.swing
ToolTipUI - Class in javax.swing.plaf
Pluggable look and feel interface for JToolTip.
ToolTipUI() - Constructor for class javax.swing.plaf.ToolTipUI
TooManyListenersException - Exception in java.util
The TooManyListenersException Exception is used as part of the Java Event model to annotate and implement a unicast special case of a multicast Event Source.
TooManyListenersException() - Constructor for exception java.util.TooManyListenersException
Constructs a TooManyListenersException with no detail message.
TooManyListenersException(String) - Constructor for exception java.util.TooManyListenersException
Constructs a TooManyListenersException with the specified detail message.
top - Variable in class java.awt.Insets
The inset from the top.
TOP - Static variable in class javax.print.attribute.standard.MediaTray
The top input tray in the printer.
top - Variable in class javax.swing.border.EmptyBorder
TOP - Static variable in class javax.swing.border.TitledBorder
Position the title in the middle of the border's top line.
TOP - Static variable in class javax.swing.JSplitPane
Used to add a Component above the other Component.
TOP - Static variable in interface javax.swing.SwingConstants
Box-orientation constant used to specify the top of a box.
TOP_ALIGNMENT - Static variable in class java.awt.Component
Ease-of-use constant for getAlignmentY().
TOP_ALIGNMENT - Static variable in class java.awt.font.GraphicAttribute
Aligns top of graphic to top of line.
toPath() - Method in class java.io.File
Returns a java.nio.file.Path object constructed from the this abstract path.
toPattern() - Method in class java.text.ChoiceFormat
Gets the pattern.
toPattern() - Method in class java.text.DecimalFormat
Synthesizes a pattern string that represents the current state of this Format object.
toPattern() - Method in class java.text.MessageFormat
Returns a pattern representing the current state of the message format.
toPattern() - Method in class java.text.SimpleDateFormat
Returns a pattern string describing this date format.
TOPDOWNLEFTRIGHT - Static variable in interface java.awt.image.ImageConsumer
The pixels will be delivered in top-down, left-to-right order.
toPlainString() - Method in class java.math.BigDecimal
Returns a string representation of this BigDecimal without an exponent field.
toRadians(double) - Static method in class java.lang.Math
Converts an angle measured in degrees to an approximately equivalent angle measured in radians.
toRadians(double) - Static method in class java.lang.StrictMath
Converts an angle measured in degrees to an approximately equivalent angle measured in radians.
toRealPath(LinkOption...) - Method in interface java.nio.file.Path
Returns the real path of an existing file.
toResourceName(String, String) - Method in class java.util.ResourceBundle.Control
Converts the given bundleName to the form required by the ClassLoader.getResource method by replacing all occurrences of '.' in bundleName with '/' and appending a '.' and the given file suffix.
toRGB(float[]) - Method in class java.awt.color.ColorSpace
Transforms a color value assumed to be in this ColorSpace into a value in the default CS_sRGB color space.
toRGB(float[]) - Method in class java.awt.color.ICC_ColorSpace
Transforms a color value assumed to be in this ColorSpace into a value in the default CS_sRGB color space.
TORIGHT_TOBOTTOM - Static variable in class javax.print.attribute.standard.PresentationDirection
Pages are laid out in rows starting at the top left, proceeding towards the right & bottom.
TORIGHT_TOTOP - Static variable in class javax.print.attribute.standard.PresentationDirection
Pages are laid out in rows starting at the bottom left, proceeding towards the right & top.
toSecondOfDay() - Method in class java.time.LocalTime
Extracts the time as seconds of day, from 0 to 24 * 60 * 60 - 1.
toSeconds(long) - Method in enum java.util.concurrent.TimeUnit
Equivalent to SECONDS.convert(duration, this).
toSet() - Static method in class java.util.stream.Collectors
Returns a Collector that accumulates the input elements into a new Set.
toString() - Method in class java.awt.AWTEvent
Returns a String representation of this object.
toString() - Method in class java.awt.AWTKeyStroke
Returns a string that displays and identifies this object's properties.
toString() - Method in class java.awt.BorderLayout
Returns a string representation of the state of this border layout.
toString() - Method in class java.awt.CardLayout
Returns a string representation of the state of this card layout.
toString() - Method in class java.awt.CheckboxGroup
Returns a string representation of this check box group, including the value of its current selection.
toString() - Method in class java.awt.Color
Returns a string representation of this Color.
toString() - Method in class java.awt.Component
Returns a string representation of this component and its values.
toString() - Method in class java.awt.Cursor
Returns a string representation of this cursor.
toString() - Method in class java.awt.datatransfer.DataFlavor
String representation of this DataFlavor and its parameters.
toString() - Method in class java.awt.Dimension
Returns a string representation of the values of this Dimension object's height and width fields.
toString() - Method in class java.awt.Event
NOTE: The Event class is obsolete and is available only for backwards compatibility.
toString() - Method in class java.awt.FlowLayout
Returns a string representation of this FlowLayout object and its values.
toString() - Method in class java.awt.font.NumericShaper
Returns a String that describes this shaper.
toString() - Method in class java.awt.font.TextHitInfo
Returns a String representing the hit for debugging use only.
toString() - Method in class java.awt.font.TextLayout
Returns debugging information for this TextLayout.
toString() - Method in class java.awt.Font
Converts this Font object to a String representation.
toString() - Method in class java.awt.FontMetrics
Returns a representation of this FontMetrics object's values as a String.
toString() - Method in class java.awt.geom.AffineTransform
Returns a String that represents the value of this Object.
toString() - Method in class java.awt.geom.Point2D.Double
Returns a String that represents the value of this Point2D.
toString() - Method in class java.awt.geom.Point2D.Float
Returns a String that represents the value of this Point2D.
toString() - Method in class java.awt.geom.Rectangle2D.Double
Returns the String representation of this Rectangle2D.
toString() - Method in class java.awt.geom.Rectangle2D.Float
Returns the String representation of this Rectangle2D.
toString() - Method in class java.awt.Graphics
Returns a String object representing this Graphics object's value.
toString() - Method in class java.awt.GridBagLayout
Returns a string representation of this grid bag layout's values.
toString() - Method in class java.awt.GridLayout
Returns the string representation of this grid layout's values.
toString() - Method in class java.awt.image.BufferedImage
Returns a String representation of this BufferedImage object and its values.
toString() - Method in class java.awt.image.ColorModel
Returns the String representation of the contents of this ColorModelobject.
toString() - Method in class java.awt.image.DirectColorModel
Returns a String that represents this DirectColorModel.
toString() - Method in class java.awt.image.IndexColorModel
Returns the String representation of the contents of this ColorModelobject.
toString() - Method in class java.awt.Insets
Returns a string representation of this Insets object.
toString() - Method in class java.awt.JobAttributes
Returns a string representation of this JobAttributes.
toString() - Method in class java.awt.MenuComponent
Returns a representation of this menu component as a string.
toString() - Method in class java.awt.MenuShortcut
Returns an internationalized description of the MenuShortcut.
toString() - Method in class java.awt.PageAttributes
Returns a string representation of this PageAttributes.
toString() - Method in class java.awt.Point
Returns a string representation of this point and its location in the (x,y) coordinate space.
toString() - Method in class java.awt.Rectangle
Returns a String representing this Rectangle and its values.
toString() - Method in class java.awt.RenderingHints
Returns a rather long string representation of the hashmap which contains the mappings of keys to values for this RenderingHints object.
toString() - Method in class java.awt.Robot
Returns a string representation of this Robot.
toString() - Method in class java.awt.ScrollPaneAdjustable
Returns a string representation of this scrollbar and its values.
toString() - Method in class java.awt.SystemColor
Returns a string representation of this Color's values.
toString() - Method in class java.beans.Expression
Prints the value of this expression using a Java-style syntax.
toString() - Method in class java.beans.FeatureDescriptor
Returns a string representation of the object.
toString() - Method in class java.beans.PropertyChangeEvent
Returns a string representation of the object.
toString() - Method in class java.beans.Statement
Prints the value of this statement using a Java-style syntax.
toString() - Method in class java.io.ByteArrayOutputStream
Converts the buffer's contents into a string decoding bytes using the platform's default character set.
toString(String) - Method in class java.io.ByteArrayOutputStream
Converts the buffer's contents into a string by decoding the bytes using the named charset.
toString(int) - Method in class java.io.ByteArrayOutputStream
Deprecated.
This method does not properly convert bytes into characters. As of JDK 1.1, the preferred way to do this is via the toString(String enc) method, which takes an encoding-name argument, or the toString() method, which uses the platform's default character encoding.
toString() - Method in class java.io.CharArrayWriter
Converts input data to a string.
toString() - Method in class java.io.File
Returns the pathname string of this abstract pathname.
toString() - Method in class java.io.ObjectStreamClass
Return a string describing this ObjectStreamClass.
toString() - Method in class java.io.ObjectStreamField
Return a string that describes this field.
toString() - Method in class java.io.StreamTokenizer
Returns the string representation of the current stream token and the line number it occurs on.
toString() - Method in class java.io.StringWriter
Return the buffer's current value as a string.
toString() - Method in interface java.lang.annotation.Annotation
Returns a string representation of this annotation.
toString(boolean) - Static method in class java.lang.Boolean
Returns a String object representing the specified boolean.
toString() - Method in class java.lang.Boolean
Returns a String object representing this Boolean's value.
toString(byte) - Static method in class java.lang.Byte
Returns a new String object representing the specified byte.
toString() - Method in class java.lang.Byte
Returns a String object representing this Byte's value.
toString() - Method in class java.lang.Character.Subset
Returns the name of this subset.
toString() - Method in class java.lang.Character
Returns a String object representing this Character's value.
toString(char) - Static method in class java.lang.Character
Returns a String object representing the specified char.
toString() - Method in interface java.lang.CharSequence
Returns a string containing the characters in this sequence in the same order as this sequence.
toString() - Method in class java.lang.Class
Converts the object to a string.
toString(double) - Static method in class java.lang.Double
Returns a string representation of the double argument.
toString() - Method in class java.lang.Double
Returns a string representation of this Double object.
toString() - Method in class java.lang.Enum
Returns the name of this enum constant, as contained in the declaration.
toString(float) - Static method in class java.lang.Float
Returns a string representation of the float argument.
toString() - Method in class java.lang.Float
Returns a string representation of this Float object.
toString(int, int) - Static method in class java.lang.Integer
Returns a string representation of the first argument in the radix specified by the second argument.
toString(int) - Static method in class java.lang.Integer
Returns a String object representing the specified integer.
toString() - Method in class java.lang.Integer
Returns a String object representing this Integer's value.
toString() - Method in class java.lang.invoke.MethodHandle
Returns a string representation of the method handle, starting with the string "MethodHandle" and ending with the string representation of the method handle's type.
toString(int, Class<?>, String, MethodType) - Static method in interface java.lang.invoke.MethodHandleInfo
Returns a string representation for a MethodHandleInfo, given the four parts of its symbolic reference.
toString() - Method in class java.lang.invoke.MethodHandles.Lookup
Displays the name of the class from which lookups are to be made.
toString() - Method in class java.lang.invoke.MethodType
Returns a string representation of the method type, of the form "(PT0,PT1...)RT".
toString() - Method in class java.lang.invoke.SerializedLambda
toString(long, int) - Static method in class java.lang.Long
Returns a string representation of the first argument in the radix specified by the second argument.
toString(long) - Static method in class java.lang.Long
Returns a String object representing the specified long.
toString() - Method in class java.lang.Long
Returns a String object representing this Long's value.
toString() - Method in class java.lang.management.LockInfo
Returns a string representation of a lock.
toString() - Method in enum java.lang.management.MemoryType
Returns the string representation of this MemoryType.
toString() - Method in class java.lang.management.MemoryUsage
Returns a descriptive representation of this memory usage.
toString() - Method in class java.lang.management.ThreadInfo
Returns a string representation of this thread info.
toString() - Method in class java.lang.Object
Returns a string representation of the object.
toString() - Method in class java.lang.Package
Returns the string representation of this Package.
toString() - Method in class java.lang.reflect.Constructor
Returns a string describing this Constructor.
toString() - Method in class java.lang.reflect.Field
Returns a string describing this Field.
toString() - Method in class java.lang.reflect.Method
Returns a string describing this Method.
toString(int) - Static method in class java.lang.reflect.Modifier
Return a string describing the access modifier flags in the specified modifier.
toString() - Method in class java.lang.reflect.Parameter
Returns a string describing this parameter.
toString(short) - Static method in class java.lang.Short
Returns a new String object representing the specified short.
toString() - Method in class java.lang.Short
Returns a String object representing this Short's value.
toString() - Method in class java.lang.StackTraceElement
Returns a string representation of this stack trace element.
toString() - Method in class java.lang.String
This object (which is already a string!) is itself returned.
toString() - Method in class java.lang.StringBuffer
toString() - Method in class java.lang.StringBuilder
toString() - Method in class java.lang.Thread
Returns a string representation of this thread, including the thread's name, priority, and thread group.
toString() - Method in class java.lang.ThreadGroup
Returns a string representation of this Thread group.
toString() - Method in class java.lang.Throwable
Returns a short description of this throwable.
toString() - Method in class java.math.BigDecimal
Returns the string representation of this BigDecimal, using scientific notation if an exponent is needed.
toString(int) - Method in class java.math.BigInteger
Returns the String representation of this BigInteger in the given radix.
toString() - Method in class java.math.BigInteger
Returns the decimal String representation of this BigInteger.
toString() - Method in class java.math.MathContext
Returns the string representation of this MathContext.
toString() - Method in class java.net.HttpCookie
Constructs a cookie header string representation of this cookie, which is in the format defined by corresponding cookie specification, but without the leading "Cookie:" token.
toString() - Method in class java.net.InetAddress
Converts this IP address to a String.
toString() - Method in class java.net.InetSocketAddress
Constructs a string representation of this InetSocketAddress.
toString() - Method in class java.net.InterfaceAddress
Converts this Interface address to a String.
toString() - Method in class java.net.NetworkInterface
toString() - Method in class java.net.Proxy
Constructs a string representation of this Proxy.
toString() - Method in class java.net.ServerSocket
Returns the implementation address and implementation port of this socket as a String.
toString() - Method in class java.net.Socket
Converts this socket to a String.
toString() - Method in class java.net.SocketImpl
Returns the address and port of this socket as a String.
toString() - Method in class java.net.URI
Returns the content of this URI as a string.
toString() - Method in class java.net.URL
Constructs a string representation of this URL.
toString() - Method in class java.net.URLConnection
Returns a String representation of this URL connection.
toString() - Method in class java.nio.ByteBuffer
Returns a string summarizing the state of this buffer.
toString() - Method in class java.nio.ByteOrder
Constructs a string describing this object.
toString() - Method in class java.nio.channels.FileChannel.MapMode
Returns a string describing this file-mapping mode.
toString() - Method in class java.nio.channels.FileLock
Returns a string describing the range, type, and validity of this lock.
toString() - Method in class java.nio.CharBuffer
Returns a string containing the characters in this buffer.
toString() - Method in class java.nio.charset.Charset
Returns a string describing this charset.
toString() - Method in class java.nio.charset.CoderResult
Returns a string describing this coder result.
toString() - Method in class java.nio.charset.CodingErrorAction
Returns a string describing this action.
toString() - Method in class java.nio.DoubleBuffer
Returns a string summarizing the state of this buffer.
toString() - Method in class java.nio.file.attribute.AclEntry
Returns the string representation of this ACL entry.
toString() - Method in class java.nio.file.attribute.FileTime
Returns the string representation of this FileTime.
toString(Set<PosixFilePermission>) - Static method in class java.nio.file.attribute.PosixFilePermissions
Returns the String representation of a set of permissions.
toString() - Method in interface java.nio.file.Path
Returns the string representation of this path.
toString() - Method in class java.nio.FloatBuffer
Returns a string summarizing the state of this buffer.
toString() - Method in class java.nio.IntBuffer
Returns a string summarizing the state of this buffer.
toString() - Method in class java.nio.LongBuffer
Returns a string summarizing the state of this buffer.
toString() - Method in class java.nio.ShortBuffer
Returns a string summarizing the state of this buffer.
toString() - Method in class java.rmi.dgc.VMID
Return string representation of this VMID.
toString() - Method in class java.rmi.server.LogStream
Deprecated.
no replacement
toString() - Method in class java.rmi.server.ObjID
Returns a string representation of this object identifier.
toString() - Method in class java.rmi.server.Operation
Deprecated.
no replacement
toString() - Method in class java.rmi.server.RemoteObject
Returns a String that represents the value of this remote object.
toString() - Method in class java.rmi.server.UID
Returns a string representation of this UID.
toString() - Method in interface java.security.acl.Acl
Returns a string representation of the ACL contents.
toString() - Method in interface java.security.acl.AclEntry
Returns a string representation of the contents of this ACL entry.
toString() - Method in interface java.security.acl.Permission
Prints a string representation of this permission.
toString() - Method in class java.security.AlgorithmParameters
Returns a formatted string describing the parameters.
toString() - Method in class java.security.cert.Certificate
Returns a string representation of this certificate.
toString() - Method in class java.security.cert.CertPath
Returns a string representation of this certification path.
toString() - Method in class java.security.cert.CollectionCertStoreParameters
Returns a formatted string describing the parameters.
toString() - Method in class java.security.cert.CRL
Returns a string representation of this CRL.
toString() - Method in class java.security.cert.LDAPCertStoreParameters
Returns a formatted string describing the parameters.
toString() - Method in class java.security.cert.PKIXBuilderParameters
Returns a formatted string describing the parameters.
toString() - Method in class java.security.cert.PKIXCertPathBuilderResult
Return a printable representation of this PKIXCertPathBuilderResult.
toString() - Method in class java.security.cert.PKIXCertPathValidatorResult
Return a printable representation of this PKIXCertPathValidatorResult.
toString() - Method in class java.security.cert.PKIXParameters
Returns a formatted string describing the parameters.
toString() - Method in class java.security.cert.PolicyQualifierInfo
Return a printable representation of this PolicyQualifierInfo.
toString() - Method in class java.security.cert.TrustAnchor
Returns a formatted string describing the TrustAnchor.
toString() - Method in class java.security.cert.X509CertSelector
Return a printable representation of the CertSelector.
toString() - Method in class java.security.cert.X509CRLEntry
Returns a string representation of this CRL entry.
toString() - Method in class java.security.cert.X509CRLSelector
Returns a printable representation of the X509CRLSelector.
toString(boolean) - Method in interface java.security.Certificate
Deprecated.
Returns a string that represents the contents of the certificate.
toString() - Method in class java.security.CodeSigner
Returns a string describing this code signer.
toString() - Method in class java.security.CodeSource
Returns a string describing this CodeSource, telling its URL and certificates.
toString() - Method in class java.security.DigestInputStream
Prints a string representation of this digest input stream and its associated message digest object.
toString() - Method in class java.security.DigestOutputStream
Prints a string representation of this digest output stream and its associated message digest object.
toString() - Method in class java.security.Identity
Deprecated.
Returns a short string describing this identity, telling its name and its scope (if any).
toString(boolean) - Method in class java.security.Identity
Deprecated.
Returns a string representation of this identity, with optionally more details than that provided by the toString method without any arguments.
toString() - Method in class java.security.IdentityScope
Deprecated.
Returns a string representation of this identity scope, including its name, its scope name, and the number of identities in this identity scope.
toString() - Method in class java.security.KeyStore.PrivateKeyEntry
Returns a string representation of this PrivateKeyEntry.
toString() - Method in class java.security.KeyStore.SecretKeyEntry
Returns a string representation of this SecretKeyEntry.
toString() - Method in class java.security.KeyStore.TrustedCertificateEntry
Returns a string representation of this TrustedCertificateEntry.
toString() - Method in class java.security.MessageDigest
Returns a string representation of this message digest object.
toString() - Method in class java.security.Permission
Returns a string describing this Permission.
toString() - Method in class java.security.PermissionCollection
Returns a string describing this PermissionCollection object, providing information about all the permissions it contains.
toString() - Method in class java.security.PKCS12Attribute
Returns a string representation of this PKCS12Attribute.
toString() - Method in interface java.security.Principal
Returns a string representation of this principal.
toString() - Method in exception java.security.PrivilegedActionException
toString() - Method in class java.security.ProtectionDomain
Convert a ProtectionDomain to a String.
toString() - Method in class java.security.Provider.Service
Return a String representation of this service.
toString() - Method in class java.security.Provider
Returns a string with the name and the version number of this provider.
toString() - Method in class java.security.Signature
Returns a string representation of this signature object, providing information that includes the state of the object and the name of the algorithm used.
toString() - Method in class java.security.Signer
Deprecated.
Returns a string of information about the signer.
toString() - Method in class java.security.Timestamp
Returns a string describing this timestamp.
toString() - Method in class java.security.UnresolvedPermission
Returns a string describing this UnresolvedPermission.
toString() - Method in class java.sql.Date
Formats a date in the date escape format yyyy-mm-dd.
toString() - Method in interface java.sql.RowId
Returns a String representing the value of the SQL ROWID designated by this java.sql.RowId object.
toString() - Method in class java.sql.Time
Formats a time in JDBC time escape format.
toString() - Method in class java.sql.Timestamp
Formats a timestamp in JDBC timestamp escape format.
toString() - Method in class java.text.Annotation
Returns the String representation of this Annotation.
toString() - Method in class java.text.AttributedCharacterIterator.Attribute
Returns a string representation of the object.
toString() - Method in class java.text.Bidi
Display the bidi internal state, used in debugging.
toString() - Method in class java.text.FieldPosition
Return a string representation of this FieldPosition.
toString() - Method in class java.text.ParsePosition
Return a string representation of this ParsePosition.
toString() - Method in class java.time.chrono.AbstractChronology
Outputs this chronology as a String, using the chronology ID.
toString() - Method in interface java.time.chrono.ChronoLocalDate
Outputs this date as a String.
toString() - Method in interface java.time.chrono.ChronoLocalDateTime
Outputs this date-time as a String.
toString() - Method in interface java.time.chrono.Chronology
Outputs this chronology as a String.
toString() - Method in interface java.time.chrono.ChronoPeriod
Outputs this period as a String.
toString() - Method in interface java.time.chrono.ChronoZonedDateTime
Outputs this date-time as a String.
toString() - Method in class java.time.chrono.JapaneseEra
toString() - Method in class java.time.Duration
A string representation of this duration using ISO-8601 seconds based representation, such as PT8H6M12.345S.
toString() - Method in class java.time.format.DateTimeFormatter
Returns a description of the underlying formatters.
toString() - Method in class java.time.format.DecimalStyle
Returns a string describing this DecimalStyle.
toString() - Method in class java.time.Instant
A string representation of this instant using ISO-8601 representation.
toString() - Method in class java.time.LocalDate
Outputs this date as a String, such as 2007-12-03.
toString() - Method in class java.time.LocalDateTime
Outputs this date-time as a String, such as 2007-12-03T10:15:30.
toString() - Method in class java.time.LocalTime
Outputs this time as a String, such as 10:15.
toString() - Method in class java.time.MonthDay
Outputs this month-day as a String, such as --12-03.
toString() - Method in class java.time.OffsetDateTime
Outputs this date-time as a String, such as 2007-12-03T10:15:30+01:00.
toString() - Method in class java.time.OffsetTime
Outputs this time as a String, such as 10:15:30+01:00.
toString() - Method in class java.time.Period
Outputs this period as a String, such as P6Y3M1D.
toString() - Method in enum java.time.temporal.ChronoField
toString() - Method in enum java.time.temporal.ChronoUnit
toString() - Method in interface java.time.temporal.TemporalField
Gets a descriptive name for the field.
toString() - Method in interface java.time.temporal.TemporalUnit
Gets a descriptive name for the unit.
toString() - Method in class java.time.temporal.ValueRange
Outputs this range as a String.
toString() - Method in class java.time.temporal.WeekFields
A string representation of this WeekFields instance.
toString() - Method in class java.time.Year
Outputs this year as a String.
toString() - Method in class java.time.YearMonth
Outputs this year-month as a String, such as 2007-12.
toString() - Method in class java.time.zone.ZoneOffsetTransition
Returns a string describing this object.
toString() - Method in class java.time.zone.ZoneOffsetTransitionRule
Returns a string describing this object.
toString() - Method in class java.time.zone.ZoneRules
Returns a string describing this object.
toString() - Method in class java.time.ZonedDateTime
Outputs this date-time as a String, such as 2007-12-03T10:15:30+01:00[Europe/Paris].
toString() - Method in class java.time.ZoneId
Outputs this zone as a String, using the ID.
toString() - Method in class java.time.ZoneOffset
Outputs this offset as a String, using the normalized ID.
toString() - Method in class java.util.AbstractCollection
Returns a string representation of this collection.
toString() - Method in class java.util.AbstractMap.SimpleEntry
Returns a String representation of this map entry.
toString() - Method in class java.util.AbstractMap.SimpleImmutableEntry
Returns a String representation of this map entry.
toString() - Method in class java.util.AbstractMap
Returns a string representation of this map.
toString(long[]) - Static method in class java.util.Arrays
Returns a string representation of the contents of the specified array.
toString(int[]) - Static method in class java.util.Arrays
Returns a string representation of the contents of the specified array.
toString(short[]) - Static method in class java.util.Arrays
Returns a string representation of the contents of the specified array.
toString(char[]) - Static method in class java.util.Arrays
Returns a string representation of the contents of the specified array.
toString(byte[]) - Static method in class java.util.Arrays
Returns a string representation of the contents of the specified array.
toString(boolean[]) - Static method in class java.util.Arrays
Returns a string representation of the contents of the specified array.
toString(float[]) - Static method in class java.util.Arrays
Returns a string representation of the contents of the specified array.
toString(double[]) - Static method in class java.util.Arrays
Returns a string representation of the contents of the specified array.
toString(Object[]) - Static method in class java.util.Arrays
Returns a string representation of the contents of the specified array.
toString() - Method in class java.util.BitSet
Returns a string representation of this bit set.
toString() - Method in class java.util.Calendar
Return a string representation of this calendar.
toString() - Method in class java.util.concurrent.ArrayBlockingQueue
toString() - Method in class java.util.concurrent.atomic.AtomicBoolean
Returns the String representation of the current value.
toString() - Method in class java.util.concurrent.atomic.AtomicInteger
Returns the String representation of the current value.
toString() - Method in class java.util.concurrent.atomic.AtomicIntegerArray
Returns the String representation of the current values of array.
toString() - Method in class java.util.concurrent.atomic.AtomicLong
Returns the String representation of the current value.
toString() - Method in class java.util.concurrent.atomic.AtomicLongArray
Returns the String representation of the current values of array.
toString() - Method in class java.util.concurrent.atomic.AtomicReference
Returns the String representation of the current value.
toString() - Method in class java.util.concurrent.atomic.AtomicReferenceArray
Returns the String representation of the current values of array.
toString() - Method in class java.util.concurrent.atomic.DoubleAccumulator
Returns the String representation of the current value.
toString() - Method in class java.util.concurrent.atomic.DoubleAdder
Returns the String representation of the DoubleAdder.sum().
toString() - Method in class java.util.concurrent.atomic.LongAccumulator
Returns the String representation of the current value.
toString() - Method in class java.util.concurrent.atomic.LongAdder
Returns the String representation of the LongAdder.sum().
toString() - Method in class java.util.concurrent.CompletableFuture
Returns a string identifying this CompletableFuture, as well as its completion state.
toString() - Method in class java.util.concurrent.ConcurrentHashMap
Returns a string representation of this map.
toString() - Method in class java.util.concurrent.CopyOnWriteArrayList
Returns a string representation of this list.
toString() - Method in class java.util.concurrent.CountDownLatch
Returns a string identifying this latch, as well as its state.
toString() - Method in class java.util.concurrent.ForkJoinPool
Returns a string identifying this pool, as well as its state, including indications of run state, parallelism level, and worker and task counts.
toString() - Method in class java.util.concurrent.LinkedBlockingDeque
toString() - Method in class java.util.concurrent.LinkedBlockingQueue
toString() - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer
Returns a string identifying this synchronizer, as well as its state.
toString() - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer
Returns a string identifying this synchronizer, as well as its state.
toString() - Method in class java.util.concurrent.locks.ReentrantLock
Returns a string identifying this lock, as well as its lock state.
toString() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock
Returns a string identifying this lock, as well as its lock state.
toString() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock
Returns a string identifying this lock, as well as its lock state.
toString() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock
Returns a string identifying this lock, as well as its lock state.
toString() - Method in class java.util.concurrent.locks.StampedLock
Returns a string identifying this lock, as well as its lock state.
toString() - Method in class java.util.concurrent.Phaser
Returns a string identifying this phaser, as well as its state.
toString() - Method in class java.util.concurrent.PriorityBlockingQueue
toString() - Method in class java.util.concurrent.Semaphore
Returns a string identifying this semaphore, as well as its state.
toString() - Method in class java.util.concurrent.ThreadPoolExecutor
Returns a string identifying this pool, as well as its state, including indications of run state and estimated worker and task counts.
toString() - Method in class java.util.Currency
Returns the ISO 4217 currency code of this currency.
toString() - Method in class java.util.Date
Converts this Date object to a String of the form:
toString() - Method in class java.util.DoubleSummaryStatistics
Returns a string representation of the object.
toString() - Method in class java.util.EventObject
Returns a String representation of this EventObject.
toString() - Method in class java.util.Formatter
Returns the result of invoking toString() on the destination for the output.
toString() - Method in class java.util.Hashtable
Returns a string representation of this Hashtable object in the form of a set of entries, enclosed in braces and separated by the ASCII characters ", " (comma and space).
toString() - Method in class java.util.IntSummaryStatistics
toString() - Method in class java.util.jar.Attributes.Name
Returns the attribute name as a String.
toString() - Method in class java.util.Locale
Returns a string representation of this Locale object, consisting of language, country, variant, script, and extensions as below: language + "_" + country + "_" + (variant + "_#" | "#") + script + "-" + extensions Language is always lower case, country is always upper case, script is always title case, and extensions are always lower case.
toString() - Method in class java.util.logging.Level
Returns a string representation of this Level.
toString() - Method in class java.util.LongSummaryStatistics
toString(Object) - Static method in class java.util.Objects
Returns the result of calling toString for a non-null argument and "null" for a null argument.
toString(Object, String) - Static method in class java.util.Objects
Returns the result of calling toString on the first argument if the first argument is not null and returns the second argument otherwise.
toString() - Method in class java.util.Optional
Returns a non-empty string representation of this Optional suitable for debugging.
toString() - Method in class java.util.OptionalDouble
Returns a string representation of the object.
toString() - Method in class java.util.OptionalInt
Returns a string representation of the object.
toString() - Method in class java.util.OptionalLong
Returns a string representation of the object.
toString() - Method in class java.util.prefs.AbstractPreferences
Returns the absolute path name of this preferences node.
toString() - Method in class java.util.prefs.Preferences
Returns a string representation of this preferences node, as if computed by the expression:(this.isUserNode() ? "User" : "System") + " Preference Node: " + this.absolutePath().
toString() - Method in class java.util.regex.Matcher
Returns the string representation of this matcher.
toString() - Method in class java.util.regex.Pattern
Returns the string representation of this pattern.
toString() - Method in class java.util.Scanner
Returns the string representation of this Scanner.
toString() - Method in class java.util.ServiceLoader
Returns a string describing this service.
toString() - Method in class java.util.SimpleTimeZone
Returns a string representation of this time zone.
toString() - Method in class java.util.StringJoiner
Returns the current value, consisting of the prefix, the values added so far separated by the delimiter, and the suffix, unless no elements have been added in which case, the prefix + suffix or the emptyValue characters are returned
toString() - Method in class java.util.UUID
Returns a String object representing this UUID.
toString() - Method in class java.util.Vector
Returns a string representation of this Vector, containing the String representation of each element.
toString() - Method in class java.util.zip.ZipEntry
Returns a string representation of the ZIP entry.
toString() - Method in class javax.accessibility.AccessibleBundle
Gets localized string describing the key using the default locale.
toString() - Method in class javax.accessibility.AccessibleRelationSet
Creates a localized String representing all the relations in the set using the default locale.
toString() - Method in class javax.accessibility.AccessibleStateSet
Creates a localized String representing all the states in the set using the default locale.
toString() - Method in class javax.activation.MimeType
Return the String representation of this object.
toString() - Method in class javax.activation.MimeTypeParameterList
Return a string representation of this object.
toString() - Method in class javax.imageio.plugins.jpeg.JPEGHuffmanTable
Returns a String representing this Huffman table.
toString() - Method in class javax.imageio.plugins.jpeg.JPEGQTable
Returns a String representing this quantization table.
toString() - Method in interface javax.lang.model.element.AnnotationValue
Returns a string representation of this value.
toString() - Method in enum javax.lang.model.element.Modifier
Returns this modifier's name in lowercase.
toString() - Method in interface javax.lang.model.type.TypeMirror
Returns an informative string representation of this type.
toString() - Method in class javax.management.Attribute
Returns a String object representing this Attribute's value.
toString() - Method in class javax.management.AttributeValueExp
Returns the string representing its value.
toString() - Method in exception javax.management.BadAttributeValueExpException
Returns the string representing the object.
toString() - Method in exception javax.management.BadBinaryOpValueExpException
Returns the string representing the object.
toString() - Method in exception javax.management.BadStringOperationException
Returns the string representing the object.
toString() - Method in class javax.management.ImmutableDescriptor
toString() - Method in class javax.management.MBeanAttributeInfo
toString() - Method in class javax.management.MBeanConstructorInfo
toString() - Method in class javax.management.MBeanInfo
toString() - Method in class javax.management.MBeanNotificationInfo
toString() - Method in class javax.management.MBeanOperationInfo
toString() - Method in class javax.management.MBeanParameterInfo
toString() - Method in class javax.management.MBeanServerNotification
toString() - Method in class javax.management.modelmbean.DescriptorSupport
Returns a human readable string representing the descriptor.
toString() - Method in class javax.management.modelmbean.ModelMBeanAttributeInfo
Returns a human-readable version of the ModelMBeanAttributeInfo instance.
toString() - Method in class javax.management.modelmbean.ModelMBeanConstructorInfo
Returns a string containing the entire contents of the ModelMBeanConstructorInfo in human readable form.
toString() - Method in class javax.management.modelmbean.ModelMBeanNotificationInfo
Returns a human readable string containing ModelMBeanNotificationInfo.
toString() - Method in class javax.management.modelmbean.ModelMBeanOperationInfo
Returns a string containing the entire contents of the ModelMBeanOperationInfo in human readable form.
toString() - Method in class javax.management.Notification
Returns a String representation of this notification.
toString() - Method in class javax.management.ObjectInstance
Returns a string representing this ObjectInstance object.
toString() - Method in class javax.management.ObjectName
Returns a string representation of the object name.
toString() - Method in class javax.management.openmbean.ArrayType
Returns a string representation of this ArrayType instance.
toString() - Method in interface javax.management.openmbean.CompositeData
Returns a string representation of this CompositeData instance.
toString() - Method in class javax.management.openmbean.CompositeDataSupport
Returns a string representation of this CompositeDataSupport instance.
toString() - Method in class javax.management.openmbean.CompositeType
Returns a string representation of this CompositeType instance.
toString() - Method in interface javax.management.openmbean.OpenMBeanAttributeInfo
Returns a string representation of this OpenMBeanAttributeInfo instance.
toString() - Method in class javax.management.openmbean.OpenMBeanAttributeInfoSupport
Returns a string representation of this OpenMBeanAttributeInfoSupport instance.
toString() - Method in interface javax.management.openmbean.OpenMBeanConstructorInfo
Returns a string representation of this OpenMBeanConstructorInfo instance.
toString() - Method in class javax.management.openmbean.OpenMBeanConstructorInfoSupport
Returns a string representation of this OpenMBeanConstructorInfoSupport instance.
toString() - Method in interface javax.management.openmbean.OpenMBeanInfo
Returns a string representation of this OpenMBeanInfo instance.
toString() - Method in class javax.management.openmbean.OpenMBeanInfoSupport
Returns a string representation of this OpenMBeanInfoSupport instance.
toString() - Method in interface javax.management.openmbean.OpenMBeanOperationInfo
Returns a string representation of this OpenMBeanOperationInfo instance.
toString() - Method in class javax.management.openmbean.OpenMBeanOperationInfoSupport
Returns a string representation of this OpenMBeanOperationInfoSupport instance.
toString() - Method in interface javax.management.openmbean.OpenMBeanParameterInfo
Returns a string representation of this OpenMBeanParameterInfo instance.
toString() - Method in class javax.management.openmbean.OpenMBeanParameterInfoSupport
Returns a string representation of this OpenMBeanParameterInfoSupport instance.
toString() - Method in class javax.management.openmbean.OpenType
Returns a string representation of this open type instance.
toString() - Method in class javax.management.openmbean.SimpleType
Returns a string representation of this SimpleType instance.
toString() - Method in interface javax.management.openmbean.TabularData
Returns a string representation of this TabularData instance.
toString() - Method in class javax.management.openmbean.TabularDataSupport
Returns a string representation of this TabularDataSupport instance.
toString() - Method in class javax.management.openmbean.TabularType
Returns a string representation of this TabularType instance.
toString() - Method in class javax.management.relation.Role
Returns a string describing the role.
toString() - Method in class javax.management.relation.RoleInfo
Returns a string describing the role info.
toString() - Method in class javax.management.relation.RoleUnresolved
Return a string describing this object.
toString() - Method in class javax.management.remote.JMXPrincipal
Returns a string representation of this JMXPrincipal.
toString() - Method in class javax.management.remote.JMXServiceURL
The string representation of this Service URL.
toString() - Method in class javax.management.remote.NotificationResult
Returns a string representation of the object.
toString() - Method in class javax.management.remote.rmi.RMIConnectionImpl
Returns a string representation of this object.
toString() - Method in class javax.management.remote.rmi.RMIConnector
Returns a string representation of this object.
toString() - Method in class javax.management.remote.TargetedNotification
Returns a textual representation of this Targeted Notification.
toString() - Method in class javax.management.StringValueExp
Returns the string representing the object.
toString() - Method in class javax.naming.BinaryRefAddr
Generates the string representation of this address.
toString() - Method in class javax.naming.Binding
Generates the string representation of this binding.
toString() - Method in class javax.naming.CompositeName
Generates the string representation of this composite name.
toString() - Method in class javax.naming.CompoundName
Generates the string representation of this compound name, using the syntax rules of the compound name.
toString() - Method in exception javax.naming.directory.AttributeModificationException
The string representation of this exception consists of information about where the error occurred, and the first unexecuted modification.
toString() - Method in class javax.naming.directory.BasicAttribute
Generates the string representation of this attribute.
toString() - Method in class javax.naming.directory.BasicAttributes
Generates the string representation of this attribute set.
toString() - Method in class javax.naming.directory.ModificationItem
Generates the string representation of this modification item, which consists of the modification operation and its related attribute.
toString() - Method in class javax.naming.directory.SearchResult
Generates the string representation of this SearchResult.
toString() - Method in class javax.naming.ldap.LdapName
Returns a string representation of this LDAP name in a format defined by RFC 2253 and described in the class description.
toString() - Method in class javax.naming.ldap.Rdn
Returns this Rdn as a string represented in a format defined by RFC 2253 and described in the class description for LdapName.
toString() - Method in exception javax.naming.LinkException
Generates the string representation of this exception.
toString(boolean) - Method in exception javax.naming.LinkException
Generates the string representation of this exception.
toString() - Method in class javax.naming.NameClassPair
Generates the string representation of this name/class pair.
toString() - Method in exception javax.naming.NamingException
Generates the string representation of this exception.
toString(boolean) - Method in exception javax.naming.NamingException
Generates the string representation in more detail.
toString() - Method in class javax.naming.RefAddr
Generates the string representation of this address.
toString() - Method in class javax.naming.Reference
Generates the string representation of this reference.
toString() - Method in class javax.net.ssl.SNIHostName
Returns a string representation of the object, including the DNS hostname in this SNIHostName object.
toString() - Method in class javax.net.ssl.SNIServerName
Returns a string representation of this server name, including the server name type and the encoded server name value in this SNIServerName object.
toString() - Method in class javax.net.ssl.SSLEngineResult
Returns a String representation of this object.
toString() - Method in class javax.print.attribute.DateTimeSyntax
Returns a string value corresponding to this date-time attribute.
toString() - Method in class javax.print.attribute.EnumSyntax
Returns a string value corresponding to this enumeration value.
toString() - Method in class javax.print.attribute.IntegerSyntax
Returns a string value corresponding to this integer attribute.
toString(int, String) - Method in class javax.print.attribute.ResolutionSyntax
Returns a string version of this resolution attribute in the given units.
toString() - Method in class javax.print.attribute.ResolutionSyntax
Returns a string version of this resolution attribute.
toString() - Method in class javax.print.attribute.SetOfIntegerSyntax
Returns a string value corresponding to this set-of-integer attribute.
toString(int, String) - Method in class javax.print.attribute.Size2DSyntax
Returns a string version of this two-dimensional size attribute in the given units.
toString() - Method in class javax.print.attribute.Size2DSyntax
Returns a string version of this two-dimensional size attribute.
toString(int, String) - Method in class javax.print.attribute.standard.MediaPrintableArea
Returns a string version of this rectangular size attribute in the given units.
toString() - Method in class javax.print.attribute.standard.MediaPrintableArea
Returns a string version of this rectangular size attribute in mm.
toString() - Method in class javax.print.attribute.TextSyntax
Returns a String identifying this text attribute.
toString() - Method in class javax.print.attribute.URISyntax
Returns a String identifying this URI attribute.
toString() - Method in class javax.print.DocFlavor
Converts this DocFlavor to a string.
toString() - Method in class javax.print.event.PrintEvent
toString() - Method in class javax.rmi.CORBA.Stub
Returns a string representation of this stub.
toString(Stub) - Method in interface javax.rmi.CORBA.StubDelegate
Delegation call for Stub.toString().
toString() - Method in class javax.security.auth.kerberos.KerberosKey
toString() - Method in class javax.security.auth.kerberos.KerberosPrincipal
toString() - Method in class javax.security.auth.kerberos.KerberosTicket
toString() - Method in class javax.security.auth.kerberos.KeyTab
toString() - Method in class javax.security.auth.login.AppConfigurationEntry.LoginModuleControlFlag
Return a String representation of this controlFlag.
toString() - Method in class javax.security.auth.Subject
Return the String representation of this Subject.
toString() - Method in class javax.security.auth.x500.X500Principal
Return a user-friendly string representation of this X500Principal.
toString() - Method in class javax.security.cert.Certificate
Returns a string representation of this certificate.
toString() - Method in exception javax.security.sasl.SaslException
Returns the string representation of this exception.
toString() - Method in class javax.sound.midi.MidiDevice.Info
Provides a string representation of the device information.
toString() - Method in class javax.sound.midi.Sequencer.SyncMode
Provides this synchronization mode's name as the string representation of the mode.
toString() - Method in class javax.sound.sampled.AudioFileFormat
Provides a string representation of the file format.
toString() - Method in class javax.sound.sampled.AudioFileFormat.Type
Provides the file type's name as the String representation of the file type.
toString() - Method in class javax.sound.sampled.AudioFormat.Encoding
Provides the String representation of the encoding.
toString() - Method in class javax.sound.sampled.AudioFormat
Returns a string that describes the format, such as: "PCM SIGNED 22050 Hz 16 bit mono big-endian".
toString() - Method in class javax.sound.sampled.BooleanControl
Provides a string representation of the control
toString() - Method in class javax.sound.sampled.CompoundControl
Provides a string representation of the control
toString() - Method in class javax.sound.sampled.Control
Obtains a String describing the control type and its current state.
toString() - Method in class javax.sound.sampled.Control.Type
Provides the String representation of the control type.
toString() - Method in class javax.sound.sampled.DataLine.Info
Obtains a textual description of the data line info.
toString() - Method in class javax.sound.sampled.EnumControl
Provides a string representation of the control.
toString() - Method in class javax.sound.sampled.FloatControl
Provides a string representation of the control
toString() - Method in class javax.sound.sampled.Line.Info
Obtains a textual description of the line info.
toString() - Method in class javax.sound.sampled.LineEvent
Obtains a string representation of the event.
toString() - Method in class javax.sound.sampled.LineEvent.Type
Returns the type name as the string representation.
toString() - Method in class javax.sound.sampled.Mixer.Info
Provides a string representation of the mixer info.
toString() - Method in class javax.sound.sampled.Port.Info
Provides a String representation of the port.
toString() - Method in class javax.sound.sampled.ReverbType
Provides a String representation of the reverb type, including its name and its parameter settings.
toString() - Method in class javax.swing.DefaultBoundedRangeModel
Returns a string that displays all of the BoundedRangeModel properties.
toString() - Method in class javax.swing.DefaultListModel
Returns a string that displays and identifies this object's properties.
toString() - Method in class javax.swing.DefaultListSelectionModel
Returns a string that displays and identifies this object's properties.
toString() - Method in class javax.swing.event.DocumentEvent.EventType
Converts the type to a string.
toString() - Method in class javax.swing.event.EventListenerList
Returns a string representation of the EventListenerList.
toString() - Method in class javax.swing.event.HyperlinkEvent.EventType
Converts the type to a string.
toString() - Method in class javax.swing.event.ListDataEvent
Returns a string representation of this ListDataEvent.
toString() - Method in class javax.swing.event.ListSelectionEvent
Returns a String that displays and identifies this object's properties.
toString() - Method in class javax.swing.event.TreeModelEvent
Returns a string that displays and identifies this object's properties.
toString() - Method in class javax.swing.filechooser.FileNameExtensionFilter
Returns a string representation of the FileNameExtensionFilter.
toString() - Method in class javax.swing.GroupLayout
Returns a string representation of this GroupLayout.
toString() - Method in class javax.swing.ImageIcon
Returns a string representation of this image.
toString() - Method in class javax.swing.JList.DropLocation
Returns a string representation of this drop location.
toString() - Method in class javax.swing.JTable.DropLocation
Returns a string representation of this drop location.
toString() - Method in class javax.swing.JTree.DropLocation
Returns a string representation of this drop location.
toString() - Method in class javax.swing.LookAndFeel
Returns a string that displays and identifies this object's properties.
toString() - Method in class javax.swing.plaf.nimbus.State
toString() - Method in class javax.swing.plaf.synth.ColorType
Returns the textual description of this ColorType.
toString() - Method in class javax.swing.plaf.synth.Region
Returns the name of the Region.
toString() - Method in class javax.swing.RepaintManager
Returns a string that displays and identifies this object's properties.
toString() - Method in class javax.swing.SizeRequirements
Returns a string describing the minimum, preferred, and maximum size requirements, along with the alignment.
toString(TableModel, int, int) - Method in class javax.swing.table.TableStringConverter
Returns the string representation of the value at the specified location.
toString() - Method in class javax.swing.text.AbstractDocument.BranchElement
Converts the element to a string.
toString() - Method in class javax.swing.text.AbstractDocument.DefaultDocumentEvent
Returns a string description of the change event.
toString() - Method in class javax.swing.text.AbstractDocument.LeafElement
Converts the element to a string.
toString() - Method in class javax.swing.text.DefaultCaret
toString() - Method in class javax.swing.text.DefaultStyledDocument.ElementSpec
Converts the element to a string.
toString() - Method in class javax.swing.text.html.CSS.Attribute
The string representation of the attribute.
toString() - Method in class javax.swing.text.html.HTML.Attribute
Returns the string representation of this attribute.
toString() - Method in class javax.swing.text.html.HTML.Tag
Returns the string representation of the tag.
toString() - Method in class javax.swing.text.html.Option
String representation is the label.
toString() - Method in class javax.swing.text.html.parser.AttributeList
toString() - Method in class javax.swing.text.html.parser.ContentModel
Convert to a string.
toString() - Method in class javax.swing.text.html.parser.DTD
Returns a string representation of this DTD.
toString() - Method in class javax.swing.text.html.parser.Element
Convert to a string.
toString() - Method in class javax.swing.text.JTextComponent.DropLocation
Returns a string representation of this drop location.
toString() - Method in class javax.swing.text.Position.Bias
string representation
toString() - Method in class javax.swing.text.Segment
Converts a segment into a String.
toString() - Method in class javax.swing.text.SimpleAttributeSet
Converts the attribute set to a String.
toString() - Method in class javax.swing.text.StyleConstants
Returns the string representation.
toString() - Method in class javax.swing.text.StyleContext.NamedStyle
Converts the style to a string.
toString() - Method in class javax.swing.text.StyleContext.SmallAttributeSet
Returns a string showing the key/value pairs
toString() - Method in class javax.swing.text.StyleContext
Converts a StyleContext to a String.
toString() - Method in class javax.swing.text.TabSet
Returns the string representation of the set of tabs.
toString() - Method in class javax.swing.text.TabStop
toString() - Method in class javax.swing.TransferHandler.DropLocation
Returns a string representation of this drop location.
toString() - Method in class javax.swing.tree.DefaultMutableTreeNode
Returns the result of sending toString() to this node's user object, or the empty string if the node has no user object.
toString() - Method in class javax.swing.tree.DefaultTreeSelectionModel
Returns a string that displays and identifies this object's properties.
toString() - Method in class javax.swing.tree.TreePath
Returns a string that displays and identifies this object's properties.
toString() - Method in class javax.swing.UIManager.LookAndFeelInfo
Returns a string that displays and identifies this object's properties.
toString() - Method in class javax.swing.undo.AbstractUndoableEdit
Returns a string that displays and identifies this object's properties.
toString() - Method in class javax.swing.undo.CompoundEdit
Returns a string that displays and identifies this object's properties.
toString() - Method in class javax.swing.undo.UndoableEditSupport
Returns a string that displays and identifies this object's properties.
toString() - Method in class javax.swing.undo.UndoManager
Returns a string that displays and identifies this object's properties.
toString() - Method in class javax.tools.SimpleJavaFileObject
toString() - Method in class javax.xml.bind.helpers.ValidationEventImpl
Returns a string representation of this object in a format helpful to debugging.
toString() - Method in class javax.xml.bind.helpers.ValidationEventLocatorImpl
Returns a string representation of this object in a format helpful to debugging.
toString() - Method in exception javax.xml.bind.JAXBException
Returns a short description of this JAXBException.
toString() - Method in exception javax.xml.bind.TypeConstraintException
Returns a short description of this TypeConstraintException.
toString() - Method in class javax.xml.crypto.dsig.spec.XPathType.Filter
Returns the string form of the operation.
toString() - Method in class javax.xml.crypto.KeySelector.Purpose
Returns a string representation of this purpose ("sign", "verify", "encrypt", or "decrypt").
toString() - Method in class javax.xml.datatype.DatatypeConstants.Field
Returns a field name in English.
toString() - Method in class javax.xml.datatype.Duration
Returns a String representation of this Duration Object.
toString() - Method in class javax.xml.datatype.XMLGregorianCalendar
Returns a String representation of this XMLGregorianCalendar Object.
toString() - Method in class javax.xml.namespace.QName
String representation of this QName.
toString() - Method in class javax.xml.ws.EndpointReference
Displays EPR infoset for debugging convenience.
toString() - Method in exception org.ietf.jgss.GSSException
Returns a textual representation of both the major and the minor status codes.
toString() - Method in interface org.ietf.jgss.GSSName
Returns a textual representation of the GSSName object.
toString() - Method in class org.ietf.jgss.Oid
Returns a string representation of the oid's integer components in dot separated notation.
toString(Object) - Method in class org.omg.CORBA.portable.Delegate
Provides the implementation to override the toString() method of the delegating CORBA object.
toString() - Method in class org.omg.CORBA.portable.ObjectImpl
Returns a String object that represents this ObjectImpl object.
toString() - Method in exception org.omg.CORBA.SystemException
Converts this exception to a representative string.
toString() - Method in exception org.xml.sax.SAXException
Override toString to pick up any embedded exception.
toString() - Method in exception org.xml.sax.SAXParseException
Override toString to provide more detailed error message.
toStub(Remote) - Static method in class java.rmi.server.RemoteObject
Returns the stub for the remote object obj passed as a parameter.
toStub() - Method in class javax.management.remote.rmi.RMIIIOPServerImpl
Returns an IIOP stub.
toStub() - Method in class javax.management.remote.rmi.RMIJRMPServerImpl
Returns a serializable stub for this RMIServer object.
toStub() - Method in class javax.management.remote.rmi.RMIServerImpl
Returns a remotable stub for this server object.
toStub(Remote) - Method in interface javax.rmi.CORBA.PortableRemoteObjectDelegate
Delegation call for PortableRemoteObject.toStub(java.rmi.Remote).
toStub(Remote) - Static method in class javax.rmi.PortableRemoteObject
Returns a stub for the given server object.
totalChildIndent - Variable in class javax.swing.plaf.basic.BasicTreeUI
Total distance that will be indented.
totalColumnWidth - Variable in class javax.swing.table.DefaultTableColumnModel
A local cache of the combined width of all columns
totalMemory() - Method in class java.lang.Runtime
Returns the total amount of memory in the Java virtual machine.
toTitleCase(char) - Static method in class java.lang.Character
Converts the character argument to titlecase using case mapping information from the UnicodeData file.
toTitleCase(int) - Static method in class java.lang.Character
Converts the character (Unicode code point) argument to titlecase using case mapping information from the UnicodeData file.
TOTOP_TOLEFT - Static variable in class javax.print.attribute.standard.PresentationDirection
Pages are laid out in columns starting at the bottom right, proceeding towards the top & left.
TOTOP_TORIGHT - Static variable in class javax.print.attribute.standard.PresentationDirection
Pages are laid out in columns starting at the bottom left, proceeding towards the top & right.
toTotalMonths() - Method in class java.time.Period
Gets the total number of months in this period.
toUnicode(String, int) - Static method in class java.net.IDN
Translates a string from ASCII Compatible Encoding (ACE) to Unicode, as defined by the ToUnicode operation of RFC 3490.
toUnicode(String) - Static method in class java.net.IDN
Translates a string from ASCII Compatible Encoding (ACE) to Unicode, as defined by the ToUnicode operation of RFC 3490.
toUnsignedInt(byte) - Static method in class java.lang.Byte
Converts the argument to an int by an unsigned conversion.
toUnsignedInt(short) - Static method in class java.lang.Short
Converts the argument to an int by an unsigned conversion.
toUnsignedLong(byte) - Static method in class java.lang.Byte
Converts the argument to a long by an unsigned conversion.
toUnsignedLong(int) - Static method in class java.lang.Integer
Converts the argument to a long by an unsigned conversion.
toUnsignedLong(short) - Static method in class java.lang.Short
Converts the argument to a long by an unsigned conversion.
toUnsignedString(int, int) - Static method in class java.lang.Integer
Returns a string representation of the first argument as an unsigned integer value in the radix specified by the second argument.
toUnsignedString(int) - Static method in class java.lang.Integer
Returns a string representation of the argument as an unsigned decimal value.
toUnsignedString(long, int) - Static method in class java.lang.Long
Returns a string representation of the first argument as an unsigned integer value in the radix specified by the second argument.
toUnsignedString(long) - Static method in class java.lang.Long
Returns a string representation of the argument as an unsigned decimal value.
toUpperCase(char) - Static method in class java.lang.Character
Converts the character argument to uppercase using case mapping information from the UnicodeData file.
toUpperCase(int) - Static method in class java.lang.Character
Converts the character (Unicode code point) argument to uppercase using case mapping information from the UnicodeData file.
toUpperCase(Locale) - Method in class java.lang.String
Converts all of the characters in this String to upper case using the rules of the given Locale.
toUpperCase() - Method in class java.lang.String
Converts all of the characters in this String to upper case using the rules of the default locale.
toURI() - Method in class java.io.File
Constructs a file: URI that represents this abstract pathname.
toURI() - Method in class java.net.URL
Returns a URI equivalent to this URL.
toUri() - Method in interface java.nio.file.Path
Returns a URI to represent this path.
toUri() - Method in interface javax.tools.FileObject
Returns a URI identifying this file object.
toUri() - Method in class javax.tools.ForwardingFileObject
toUri() - Method in class javax.tools.SimpleJavaFileObject
toURL() - Method in class java.io.File
Deprecated.
This method does not automatically escape characters that are illegal in URLs. It is recommended that new code convert an abstract pathname into a URL by first converting it into a URI, via the toURI method, and then converting the URI into a URL via the URI.toURL method.
toURL() - Method in class java.net.URI
Constructs a URL from this URI.
toViewCoordinates(Dimension) - Method in class javax.swing.JViewport
Converts a size in pixel coordinates to view coordinates.
toViewCoordinates(Point) - Method in class javax.swing.JViewport
Converts a point in pixel coordinates to view coordinates.
toXMLFormat() - Method in class javax.xml.datatype.XMLGregorianCalendar
Return the lexical representation of this instance.
toXMLString() - Method in class javax.management.modelmbean.DescriptorSupport
Returns an XML String representing the descriptor.
toZonedDateTime() - Method in class java.time.OffsetDateTime
Converts this date-time to a ZonedDateTime using the offset as the zone ID.
toZonedDateTime() - Method in class java.util.GregorianCalendar
Converts this object to a ZonedDateTime that represents the same point on the time-line as this GregorianCalendar.
toZoneId() - Method in class java.util.TimeZone
Converts this TimeZone object to a ZoneId.
TR - Static variable in class javax.swing.text.html.HTML.Tag
traceInstructions(boolean) - Method in class java.lang.Runtime
Enables/Disables tracing of instructions.
traceMethodCalls(boolean) - Method in class java.lang.Runtime
Enables/Disables tracing of method calls.
TRACK - Static variable in class java.awt.event.AdjustmentEvent
The absolute tracking adjustment type.
Track - Class in javax.sound.midi
A MIDI track is an independent stream of MIDI events (time-stamped MIDI data) that can be stored along with other tracks in a standard MIDI file.
trackBuffer - Variable in class javax.swing.plaf.basic.BasicSliderUI
trackColor - Variable in class javax.swing.plaf.basic.BasicScrollBarUI
tracker - Static variable in class javax.swing.ImageIcon
Deprecated.
since 1.8
trackHighlight - Variable in class javax.swing.plaf.basic.BasicScrollBarUI
trackHighlightColor - Variable in class javax.swing.plaf.basic.BasicScrollBarUI
TRACKING - Static variable in class java.awt.font.TextAttribute
Attribute key to control tracking.
TRACKING_LOOSE - Static variable in class java.awt.font.TextAttribute
Perform loose tracking.
TRACKING_TIGHT - Static variable in class java.awt.font.TextAttribute
Perform tight tracking.
trackListener - Variable in class javax.swing.plaf.basic.BasicScrollBarUI
TrackListener() - Constructor for class javax.swing.plaf.basic.BasicScrollBarUI.TrackListener
trackListener - Variable in class javax.swing.plaf.basic.BasicSliderUI
TrackListener() - Constructor for class javax.swing.plaf.basic.BasicSliderUI.TrackListener
trackRect - Variable in class javax.swing.plaf.basic.BasicScrollBarUI
trackRect - Variable in class javax.swing.plaf.basic.BasicSliderUI
tracks - Variable in class javax.sound.midi.Sequence
The MIDI tracks in this sequence.
trackWidth - Static variable in class javax.swing.plaf.metal.MetalSliderUI
TRADITIONAL_CHINESE - Static variable in class java.util.Locale
Useful constant for language.
TRADITIONAL_HANZI - Static variable in class java.awt.im.InputSubset
Constant for all Han characters used in writing Traditional Chinese, including a subset of the CJK unified ideographs as well as Traditional Chinese Han characters that may be defined as surrogate characters.
TRAILING - Static variable in class java.awt.FlowLayout
This value indicates that each row of components should be justified to the trailing edge of the container's orientation, for example, to the right in left-to-right orientations.
trailing(int) - Static method in class java.awt.font.TextHitInfo
Creates a hit on the trailing edge of the character at the specified charIndex.
TRAILING - Static variable in class javax.swing.border.TitledBorder
Position title text at the right side of the border line for left to right orientation, at the left side of the border line for right to left orientation.
TRAILING - Static variable in interface javax.swing.SwingConstants
Identifies the trailing edge of text for use with left-to-right and right-to-left languages.
TRANSACTION_MODE - Exception in org.omg.CORBA
The CORBA TRANSACTION_MODE exception is thrown by the client ORB if it detects a mismatch between the InvocationPolicy in the IOR and the chosen invocation path (i.e, direct or routed invocation).
TRANSACTION_MODE() - Constructor for exception org.omg.CORBA.TRANSACTION_MODE
Constructs a TRANSACTION_MODE exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
TRANSACTION_MODE(String) - Constructor for exception org.omg.CORBA.TRANSACTION_MODE
Constructs a TRANSACTION_MODE exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
TRANSACTION_MODE(int, CompletionStatus) - Constructor for exception org.omg.CORBA.TRANSACTION_MODE
Constructs a TRANSACTION_MODE exception with the specified minor code and completion status.
TRANSACTION_MODE(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.TRANSACTION_MODE
Constructs a TRANSACTION_MODE exception with the specified description message, minor code, and completion status.
TRANSACTION_NONE - Static variable in interface java.sql.Connection
A constant indicating that transactions are not supported.
TRANSACTION_READ_COMMITTED - Static variable in interface java.sql.Connection
A constant indicating that dirty reads are prevented; non-repeatable reads and phantom reads can occur.
TRANSACTION_READ_UNCOMMITTED - Static variable in interface java.sql.Connection
A constant indicating that dirty reads, non-repeatable reads and phantom reads can occur.
TRANSACTION_REPEATABLE_READ - Static variable in interface java.sql.Connection
A constant indicating that dirty reads and non-repeatable reads are prevented; phantom reads can occur.
TRANSACTION_REQUIRED - Exception in org.omg.CORBA
Exception indicates that the request carried a null transaction context, but an active transaction is required.
TRANSACTION_REQUIRED() - Constructor for exception org.omg.CORBA.TRANSACTION_REQUIRED
Constructs a TRANSACTION_REQUIRED exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
TRANSACTION_REQUIRED(String) - Constructor for exception org.omg.CORBA.TRANSACTION_REQUIRED
Constructs a TRANSACTION_REQUIRED exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
TRANSACTION_REQUIRED(int, CompletionStatus) - Constructor for exception org.omg.CORBA.TRANSACTION_REQUIRED
Constructs a TRANSACTION_REQUIRED exception with the specified minor code and completion status.
TRANSACTION_REQUIRED(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.TRANSACTION_REQUIRED
Constructs a TRANSACTION_REQUIRED exception with the specified description message, minor code, and completion status.
TRANSACTION_ROLLEDBACK - Exception in org.omg.CORBA
Exception thrown when the transaction associated with the request has already been rolled back or marked to roll back.
TRANSACTION_ROLLEDBACK() - Constructor for exception org.omg.CORBA.TRANSACTION_ROLLEDBACK
Constructs a TRANSACTION_ROLLEDBACK exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
TRANSACTION_ROLLEDBACK(String) - Constructor for exception org.omg.CORBA.TRANSACTION_ROLLEDBACK
Constructs a TRANSACTION_ROLLEDBACK exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
TRANSACTION_ROLLEDBACK(int, CompletionStatus) - Constructor for exception org.omg.CORBA.TRANSACTION_ROLLEDBACK
Constructs a TRANSACTION_ROLLEDBACK exception with the specified minor code and completion status.
TRANSACTION_ROLLEDBACK(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.TRANSACTION_ROLLEDBACK
Constructs a TRANSACTION_ROLLEDBACK exception with the specified description message, minor code, and completion status.
TRANSACTION_SERIALIZABLE - Static variable in interface java.sql.Connection
A constant indicating that dirty reads, non-repeatable reads and phantom reads are prevented.
TRANSACTION_UNAVAILABLE - Exception in org.omg.CORBA
The CORBA TRANSACTION_UNAVAILABLE exception is thrown by the ORB when it cannot process a transaction service context because its connection to the Transaction Service has been abnormally terminated.
TRANSACTION_UNAVAILABLE() - Constructor for exception org.omg.CORBA.TRANSACTION_UNAVAILABLE
Constructs a TRANSACTION_UNAVAILABLE exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
TRANSACTION_UNAVAILABLE(String) - Constructor for exception org.omg.CORBA.TRANSACTION_UNAVAILABLE
Constructs a TRANSACTION_UNAVAILABLE exception with the specifieddescription message, a minor code of 0, and a completion state of COMPLETED_NO.
TRANSACTION_UNAVAILABLE(int, CompletionStatus) - Constructor for exception org.omg.CORBA.TRANSACTION_UNAVAILABLE
Constructs a TRANSACTION_UNAVAILABLE exception with the specified minor code and completion status.
TRANSACTION_UNAVAILABLE(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.TRANSACTION_UNAVAILABLE
Constructs a TRANSACTION_UNAVAILABLE exception with the specified description message, minor code, and completion status.
TransactionalWriter - Interface in javax.sql.rowset.spi
A specialized interface that facilitates an extension of the standard SyncProvider abstract class so that it has finer grained transaction control.
TransactionRequiredException - Exception in javax.transaction
This exception indicates that a request carried a null transaction context, but the target object requires an activate transaction.
TransactionRequiredException() - Constructor for exception javax.transaction.TransactionRequiredException
TransactionRequiredException(String) - Constructor for exception javax.transaction.TransactionRequiredException
TransactionRolledbackException - Exception in javax.transaction
This exception indicates that the transaction associated with processing of the request has been rolled back, or marked to roll back.
TransactionRolledbackException() - Constructor for exception javax.transaction.TransactionRolledbackException
TransactionRolledbackException(String) - Constructor for exception javax.transaction.TransactionRolledbackException
TransactionService - Interface in org.omg.IOP
org/omg/IOP/TransactionService.java .
transfer(E) - Method in class java.util.concurrent.LinkedTransferQueue
Transfers the element to a consumer, waiting if necessary to do so.
transfer(E) - Method in interface java.util.concurrent.TransferQueue
Transfers the element to a consumer, waiting if necessary to do so.
Transferable - Interface in java.awt.datatransfer
Defines the interface for classes that can be used to provide data for a transfer operation.
transferable - Variable in class java.awt.dnd.DropTargetContext.TransferableProxy
The encapsulated Transferable object.
transferablesFlavorsChanged() - Method in class java.awt.dnd.DragSourceContext
Notifies the peer that the Transferable's DataFlavors have changed.
transferFocus() - Method in class java.awt.Component
Transfers the focus to the next component, as though this Component were the focus owner.
transferFocusBackward() - Method in class java.awt.Component
Transfers the focus to the previous component, as though this Component were the focus owner.
transferFocusDownCycle() - Method in class java.awt.Container
Transfers the focus down one focus traversal cycle.
transferFocusUpCycle() - Method in class java.awt.Component
Transfers the focus up one focus traversal cycle.
transferFrom(ReadableByteChannel, long, long) - Method in class java.nio.channels.FileChannel
Transfers bytes into this channel's file from the given readable byte channel.
TransferHandler - Class in javax.swing
This class is used to handle the transfer of a Transferable to and from Swing components.
TransferHandler(String) - Constructor for class javax.swing.TransferHandler
Constructs a transfer handler that can transfer a Java Bean property from one component to another via the clipboard or a drag and drop operation.
TransferHandler() - Constructor for class javax.swing.TransferHandler
Convenience constructor for subclasses.
TransferHandler.DropLocation - Class in javax.swing
Represents a location where dropped data should be inserted.
TransferHandler.TransferSupport - Class in javax.swing
This class encapsulates all relevant details of a clipboard or drag and drop transfer, and also allows for customizing aspects of the drag and drop experience.
TransferQueue<E> - Interface in java.util.concurrent
A BlockingQueue in which producers may wait for consumers to receive elements.
TransferSupport(Component, Transferable) - Constructor for class javax.swing.TransferHandler.TransferSupport
Create a TransferSupport with isDrop() false for the given component and Transferable.
transferTo(long, long, WritableByteChannel) - Method in class java.nio.channels.FileChannel
Transfers bytes from this channel's file to the given writable byte channel.
transferType - Variable in class java.awt.image.ColorModel
Data type of the array used to represent pixel values.
TRANSFORM - Static variable in class java.awt.font.TextAttribute
Attribute key for the transform of a font.
transform(Point2D, Point2D) - Method in class java.awt.geom.AffineTransform
Transforms the specified ptSrc and stores the result in ptDst.
transform(Point2D[], int, Point2D[], int, int) - Method in class java.awt.geom.AffineTransform
Transforms an array of point objects by this transform.
transform(float[], int, float[], int, int) - Method in class java.awt.geom.AffineTransform
Transforms an array of floating point coordinates by this transform.
transform(double[], int, double[], int, int) - Method in class java.awt.geom.AffineTransform
Transforms an array of double precision coordinates by this transform.
transform(float[], int, double[], int, int) - Method in class java.awt.geom.AffineTransform
Transforms an array of floating point coordinates by this transform and stores the results into an array of doubles.
transform(double[], int, float[], int, int) - Method in class java.awt.geom.AffineTransform
Transforms an array of double precision coordinates by this transform and stores the results into an array of floats.
transform(AffineTransform) - Method in class java.awt.geom.Area
Transforms the geometry of this Area using the specified AffineTransform.
transform(AffineTransform) - Method in class java.awt.geom.Path2D.Double
Transforms the geometry of this path using the specified AffineTransform.
transform(AffineTransform) - Method in class java.awt.geom.Path2D.Float
Transforms the geometry of this path using the specified AffineTransform.
transform(AffineTransform) - Method in class java.awt.geom.Path2D
Transforms the geometry of this path using the specified AffineTransform.
transform(AffineTransform) - Method in class java.awt.Graphics2D
Composes an AffineTransform object with the Transform in this Graphics2D according to the rule last-specified-first-applied.
transform(ClassLoader, String, Class<?>, ProtectionDomain, byte[]) - Method in interface java.lang.instrument.ClassFileTransformer
The implementation of this method may transform the supplied class file and return a new replacement class file.
Transform - Interface in javax.xml.crypto.dsig
A representation of the XML Transform element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
transform(Data, XMLCryptoContext) - Method in interface javax.xml.crypto.dsig.Transform
Transforms the specified data using the underlying transform algorithm.
transform(Data, XMLCryptoContext, OutputStream) - Method in interface javax.xml.crypto.dsig.Transform
Transforms the specified data using the underlying transform algorithm.
transform(Source, Result) - Method in class javax.xml.transform.Transformer
Transform the XML Source to a Result.
TransformAttribute - Class in java.awt.font
The TransformAttribute class provides an immutable wrapper for a transform so that it is safe to use as an attribute.
TransformAttribute(AffineTransform) - Constructor for class java.awt.font.TransformAttribute
Wraps the specified transform.
Transformer - Class in javax.xml.transform
An instance of this abstract class can transform a source tree into a result tree.
Transformer() - Constructor for class javax.xml.transform.Transformer
Default constructor is protected on purpose.
TransformerConfigurationException - Exception in javax.xml.transform
Indicates a serious configuration error.
TransformerConfigurationException() - Constructor for exception javax.xml.transform.TransformerConfigurationException
Create a new TransformerConfigurationException with no detail mesage.
TransformerConfigurationException(String) - Constructor for exception javax.xml.transform.TransformerConfigurationException
Create a new TransformerConfigurationException with the String specified as an error message.
TransformerConfigurationException(Throwable) - Constructor for exception javax.xml.transform.TransformerConfigurationException
Create a new TransformerConfigurationException with a given Exception base cause of the error.
TransformerConfigurationException(String, Throwable) - Constructor for exception javax.xml.transform.TransformerConfigurationException
Create a new TransformerConfigurationException with the given Exception base cause and detail message.
TransformerConfigurationException(String, SourceLocator) - Constructor for exception javax.xml.transform.TransformerConfigurationException
Create a new TransformerConfigurationException from a message and a Locator.
TransformerConfigurationException(String, SourceLocator, Throwable) - Constructor for exception javax.xml.transform.TransformerConfigurationException
Wrap an existing exception in a TransformerConfigurationException.
TransformerException - Exception in javax.xml.transform
This class specifies an exceptional condition that occured during the transformation process.
TransformerException(String) - Constructor for exception javax.xml.transform.TransformerException
Create a new TransformerException.
TransformerException(Throwable) - Constructor for exception javax.xml.transform.TransformerException
Create a new TransformerException wrapping an existing exception.
TransformerException(String, Throwable) - Constructor for exception javax.xml.transform.TransformerException
Wrap an existing exception in a TransformerException.
TransformerException(String, SourceLocator) - Constructor for exception javax.xml.transform.TransformerException
Create a new TransformerException from a message and a Locator.
TransformerException(String, SourceLocator, Throwable) - Constructor for exception javax.xml.transform.TransformerException
Wrap an existing exception in a TransformerException.
TransformerFactory - Class in javax.xml.transform
A TransformerFactory instance can be used to create Transformer and Templates objects.
TransformerFactory() - Constructor for class javax.xml.transform.TransformerFactory
Default constructor is protected on purpose.
TransformerFactoryConfigurationError - Error in javax.xml.transform
Thrown when a problem with configuration with the Transformer Factories exists.
TransformerFactoryConfigurationError() - Constructor for error javax.xml.transform.TransformerFactoryConfigurationError
Create a new TransformerFactoryConfigurationError with no detail mesage.
TransformerFactoryConfigurationError(String) - Constructor for error javax.xml.transform.TransformerFactoryConfigurationError
Create a new TransformerFactoryConfigurationError with the String specified as an error message.
TransformerFactoryConfigurationError(Exception) - Constructor for error javax.xml.transform.TransformerFactoryConfigurationError
Create a new TransformerFactoryConfigurationError with a given Exception base cause of the error.
TransformerFactoryConfigurationError(Exception, String) - Constructor for error javax.xml.transform.TransformerFactoryConfigurationError
Create a new TransformerFactoryConfigurationError with the given Exception base cause and detail message.
TransformerHandler - Interface in javax.xml.transform.sax
A TransformerHandler listens for SAX ContentHandler parse events and transforms them to a Result.
TransformException - Exception in javax.xml.crypto.dsig
Indicates an exceptional condition that occurred while executing a transform algorithm.
TransformException() - Constructor for exception javax.xml.crypto.dsig.TransformException
Constructs a new TransformException with null as its detail message.
TransformException(String) - Constructor for exception javax.xml.crypto.dsig.TransformException
Constructs a new TransformException with the specified detail message.
TransformException(String, Throwable) - Constructor for exception javax.xml.crypto.dsig.TransformException
Constructs a new TransformException with the specified detail message and cause.
TransformException(Throwable) - Constructor for exception javax.xml.crypto.dsig.TransformException
Constructs a new TransformException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
TransformParameterSpec - Interface in javax.xml.crypto.dsig.spec
A specification of algorithm parameters for a Transform algorithm.
TransformService - Class in javax.xml.crypto.dsig
A Service Provider Interface for transform and canonicalization algorithms.
TransformService() - Constructor for class javax.xml.crypto.dsig.TransformService
Default constructor, for invocation by subclasses.
Transient - Annotation Type in java.beans
Indicates that an attribute called "transient" should be declared with the given value when the Introspector constructs a PropertyDescriptor or EventSetDescriptor classes associated with the annotated code element.
TRANSIENT - Static variable in class java.lang.reflect.Modifier
The int value representing the transient modifier.
TRANSIENT - Static variable in class javax.accessibility.AccessibleState
Indicates this object is transient.
TRANSIENT - Exception in org.omg.CORBA
Exception thrown when the ORB attempted to reach an object and failed.
TRANSIENT() - Constructor for exception org.omg.CORBA.TRANSIENT
Constructs a TRANSIENT exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
TRANSIENT(String) - Constructor for exception org.omg.CORBA.TRANSIENT
Constructs a TRANSIENT exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
TRANSIENT(int, CompletionStatus) - Constructor for exception org.omg.CORBA.TRANSIENT
Constructs a TRANSIENT exception with the specified minor code and completion status.
TRANSIENT(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.TRANSIENT
Constructs a TRANSIENT exception with the specified description message, minor code, and completion status.
TRANSIENT - Static variable in class org.omg.PortableServer.LifespanPolicyValue
translate(int, int) - Method in class java.awt.Event
NOTE: The Event class is obsolete and is available only for backwards compatibility.
translate(double, double) - Method in class java.awt.geom.AffineTransform
Concatenates this transform with a translation transformation.
translate(int, int) - Method in class java.awt.Graphics
Translates the origin of the graphics context to the point (x, y) in the current coordinate system.
translate(int, int) - Method in class java.awt.Graphics2D
Translates the origin of the Graphics2D context to the point (x, y) in the current coordinate system.
translate(double, double) - Method in class java.awt.Graphics2D
Concatenates the current Graphics2D Transform with a translation transform.
translate(int, int) - Method in class java.awt.Point
Translates this point, at location (x,y), by dx along the x axis and dy along the y axis so that it now represents the point (x+dx,y+dy).
translate(int, int) - Method in class java.awt.Polygon
Translates the vertices of the Polygon by deltaX along the x axis and by deltaY along the y axis.
translate(int, int) - Method in class java.awt.Rectangle
Translates this Rectangle the indicated distance, to the right along the X coordinate axis, and downward along the Y coordinate axis.
translate(int, int) - Method in class javax.swing.DebugGraphics
Overrides Graphics.translate.
translateHTMLToCSS(AttributeSet) - Method in class javax.swing.text.html.StyleSheet
Converts a set of HTML attributes to an equivalent set of CSS attributes.
translateKey(Key) - Method in class java.security.KeyFactory
Translates a key object, whose provider may be unknown or potentially untrusted, into a corresponding key object of this key factory.
translateKey(SecretKey) - Method in class javax.crypto.SecretKeyFactory
Translates a key object, whose provider may be unknown or potentially untrusted, into a corresponding key object of this secret-key factory.
translatePoint(int, int) - Method in class java.awt.event.MouseEvent
Translates the event's coordinates to a new position by adding specified x (horizontal) and y (vertical) offsets.
TRANSLUCENT - Static variable in interface java.awt.Transparency
Represents image data that contains or might contain arbitrary alpha values between and including 0.0 and 1.0.
Transmitter - Interface in javax.sound.midi
A Transmitter sends MidiEvent objects to one or more Receivers.
transparency - Variable in class java.awt.image.VolatileImage
The transparency value with which this image was created.
Transparency - Interface in java.awt
The Transparency interface defines the common transparency modes for implementing classes.
TRANSPORT_AND_MAP_SYMBOLS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Transport And Map Symbols" Unicode character block.
TRANSPORT_RETRY - Interface in org.omg.PortableInterceptor
org/omg/PortableInterceptor/TRANSPORT_RETRY.java .
TrayIcon - Class in java.awt
A TrayIcon object represents a tray icon that can be added to the system tray.
TrayIcon(Image) - Constructor for class java.awt.TrayIcon
Creates a TrayIcon with the specified image.
TrayIcon(Image, String) - Constructor for class java.awt.TrayIcon
Creates a TrayIcon with the specified image and tooltip text.
TrayIcon(Image, String, PopupMenu) - Constructor for class java.awt.TrayIcon
Creates a TrayIcon with the specified image, tooltip and popup menu.
TrayIcon.MessageType - Enum in java.awt
The message type determines which icon will be displayed in the caption of the message, and a possible system sound a message may generate upon showing.
TREE - Static variable in class javax.accessibility.AccessibleRole
An object used to present hierarchical information to the user.
tree - Variable in class javax.swing.plaf.basic.BasicTreeUI
Component that we're going to be drawing into.
TREE - Static variable in class javax.swing.plaf.synth.Region
Tree region.
tree - Variable in class javax.swing.tree.DefaultTreeCellEditor
JTree instance listening too.
TREE_CELL - Static variable in class javax.swing.plaf.synth.Region
Region of the Tree for one cell.
TREE_MODEL_PROPERTY - Static variable in class javax.swing.JTree
Bound property name for treeModel.
TreeCancelEditingAction(String) - Constructor for class javax.swing.plaf.basic.BasicTreeUI.TreeCancelEditingAction
TreeCellEditor - Interface in javax.swing.tree
Adds to CellEditor the extensions necessary to configure an editor in a tree.
TreeCellRenderer - Interface in javax.swing.tree
Defines the requirements for an object that displays a tree node.
treeCollapsed(TreeExpansionEvent) - Method in interface javax.swing.event.TreeExpansionListener
Called whenever an item in the tree has been collapsed.
treeCollapsed(TreeExpansionEvent) - Method in class javax.swing.JTree.AccessibleJTree
Tree Collapsed notification.
treeCollapsed(TreeExpansionEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.TreeExpansionHandler
Called whenever an item in the tree has been collapsed.
TreeControlIcon(boolean) - Constructor for class javax.swing.plaf.metal.MetalIconFactory.TreeControlIcon
treeDidChange() - Method in class javax.swing.JTree
Sent when the tree has changed enough that we need to resize the bounds, but not enough that we need to remove the expanded node set (e.g nodes were expanded or collapsed, or nodes were inserted into the tree).
treeExpanded(TreeExpansionEvent) - Method in interface javax.swing.event.TreeExpansionListener
Called whenever an item in the tree has been expanded.
treeExpanded(TreeExpansionEvent) - Method in class javax.swing.JTree.AccessibleJTree
Tree Model Expansion notification.
treeExpanded(TreeExpansionEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.TreeExpansionHandler
Called whenever an item in the tree has been expanded.
TreeExpansionEvent - Class in javax.swing.event
An event used to identify a single path in a tree.
TreeExpansionEvent(Object, TreePath) - Constructor for class javax.swing.event.TreeExpansionEvent
Constructs a TreeExpansionEvent object.
TreeExpansionHandler() - Constructor for class javax.swing.plaf.basic.BasicTreeUI.TreeExpansionHandler
TreeExpansionListener - Interface in javax.swing.event
The listener that's notified when a tree expands or collapses a node.
TreeFolderIcon() - Constructor for class javax.swing.plaf.metal.MetalIconFactory.TreeFolderIcon
TreeHomeAction(int, String) - Constructor for class javax.swing.plaf.basic.BasicTreeUI.TreeHomeAction
TreeIncrementAction(int, String) - Constructor for class javax.swing.plaf.basic.BasicTreeUI.TreeIncrementAction
TreeLeafIcon() - Constructor for class javax.swing.plaf.metal.MetalIconFactory.TreeLeafIcon
TreeMap<K,V> - Class in java.util
A Red-Black tree based NavigableMap implementation.
TreeMap() - Constructor for class java.util.TreeMap
Constructs a new, empty tree map, using the natural ordering of its keys.
TreeMap(Comparator<? super K>) - Constructor for class java.util.TreeMap
Constructs a new, empty tree map, ordered according to the given comparator.
TreeMap(Map<? extends K, ? extends V>) - Constructor for class java.util.TreeMap
Constructs a new tree map containing the same mappings as the given map, ordered according to the natural ordering of its keys.
TreeMap(SortedMap<K, ? extends V>) - Constructor for class java.util.TreeMap
Constructs a new tree map containing the same mappings and using the same ordering as the specified sorted map.
treeModel - Variable in class javax.swing.JTree
The model that defines the tree displayed by this object.
treeModel - Variable in class javax.swing.plaf.basic.BasicTreeUI
Used to determine what to display.
treeModel - Variable in class javax.swing.tree.AbstractLayoutCache
Model providing information.
TreeModel - Interface in javax.swing.tree
The model used by JTree.
TreeModelEvent - Class in javax.swing.event
Encapsulates information describing changes to a tree model, and used to notify tree model listeners of the change.
TreeModelEvent(Object, Object[], int[], Object[]) - Constructor for class javax.swing.event.TreeModelEvent
Used to create an event when nodes have been changed, inserted, or removed, identifying the path to the parent of the modified items as an array of Objects.
TreeModelEvent(Object, TreePath, int[], Object[]) - Constructor for class javax.swing.event.TreeModelEvent
Used to create an event when nodes have been changed, inserted, or removed, identifying the path to the parent of the modified items as a TreePath object.
TreeModelEvent(Object, Object[]) - Constructor for class javax.swing.event.TreeModelEvent
Used to create an event when the node structure has changed in some way, identifying the path to the root of a modified subtree as an array of Objects.
TreeModelEvent(Object, TreePath) - Constructor for class javax.swing.event.TreeModelEvent
Used to create an event when the node structure has changed in some way, identifying the path to the root of the modified subtree as a TreePath object.
TreeModelHandler() - Constructor for class javax.swing.JTree.TreeModelHandler
TreeModelHandler() - Constructor for class javax.swing.plaf.basic.BasicTreeUI.TreeModelHandler
TreeModelListener - Interface in javax.swing.event
Defines the interface for an object that listens to changes in a TreeModel.
treeModelListener - Variable in class javax.swing.JTree
Updates the expandedState.
TreeNode - Interface in javax.swing.tree
Defines the requirements for an object that can be used as a tree node in a JTree.
treeNodesChanged(TreeModelEvent) - Method in interface javax.swing.event.TreeModelListener
Invoked after a node (or a set of siblings) has changed in some way.
treeNodesChanged(TreeModelEvent) - Method in class javax.swing.JTree.AccessibleJTree
Tree Model Node change notification.
treeNodesChanged(TreeModelEvent) - Method in class javax.swing.JTree.TreeModelHandler
treeNodesChanged(TreeModelEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.TreeModelHandler
treeNodesChanged(TreeModelEvent) - Method in class javax.swing.tree.AbstractLayoutCache
Invoked after a node (or a set of siblings) has changed in some way.
treeNodesChanged(TreeModelEvent) - Method in class javax.swing.tree.FixedHeightLayoutCache
Invoked after a node (or a set of siblings) has changed in some way.
treeNodesChanged(TreeModelEvent) - Method in class javax.swing.tree.VariableHeightLayoutCache
Invoked after a node (or a set of siblings) has changed in some way.
treeNodesInserted(TreeModelEvent) - Method in interface javax.swing.event.TreeModelListener
Invoked after nodes have been inserted into the tree.
treeNodesInserted(TreeModelEvent) - Method in class javax.swing.JTree.AccessibleJTree
Tree Model Node change notification.
treeNodesInserted(TreeModelEvent) - Method in class javax.swing.JTree.TreeModelHandler
treeNodesInserted(TreeModelEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.TreeModelHandler
treeNodesInserted(TreeModelEvent) - Method in class javax.swing.tree.AbstractLayoutCache
Invoked after nodes have been inserted into the tree.
treeNodesInserted(TreeModelEvent) - Method in class javax.swing.tree.FixedHeightLayoutCache
Invoked after nodes have been inserted into the tree.
treeNodesInserted(TreeModelEvent) - Method in class javax.swing.tree.VariableHeightLayoutCache
Invoked after nodes have been inserted into the tree.
treeNodesRemoved(TreeModelEvent) - Method in interface javax.swing.event.TreeModelListener
Invoked after nodes have been removed from the tree.
treeNodesRemoved(TreeModelEvent) - Method in class javax.swing.JTree.AccessibleJTree
Tree Model Node change notification.
treeNodesRemoved(TreeModelEvent) - Method in class javax.swing.JTree.TreeModelHandler
treeNodesRemoved(TreeModelEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.TreeModelHandler
treeNodesRemoved(TreeModelEvent) - Method in class javax.swing.tree.AbstractLayoutCache
Invoked after nodes have been removed from the tree.
treeNodesRemoved(TreeModelEvent) - Method in class javax.swing.tree.FixedHeightLayoutCache
Invoked after nodes have been removed from the tree.
treeNodesRemoved(TreeModelEvent) - Method in class javax.swing.tree.VariableHeightLayoutCache
Invoked after nodes have been removed from the tree.
TreePageAction(int, String) - Constructor for class javax.swing.plaf.basic.BasicTreeUI.TreePageAction
TreePath - Class in javax.swing.tree
TreePath represents an array of objects that uniquely identify the path to a node in a tree.
TreePath(Object[]) - Constructor for class javax.swing.tree.TreePath
Creates a TreePath from an array.
TreePath(Object) - Constructor for class javax.swing.tree.TreePath
Creates a TreePath containing a single element.
TreePath(TreePath, Object) - Constructor for class javax.swing.tree.TreePath
Creates a TreePath with the specified parent and element.
TreePath(Object[], int) - Constructor for class javax.swing.tree.TreePath
Creates a TreePath from an array.
TreePath() - Constructor for class javax.swing.tree.TreePath
Creates an empty TreePath.
TreeSelectionEvent - Class in javax.swing.event
An event that characterizes a change in the current selection.
TreeSelectionEvent(Object, TreePath[], boolean[], TreePath, TreePath) - Constructor for class javax.swing.event.TreeSelectionEvent
Represents a change in the selection of a TreeSelectionModel.
TreeSelectionEvent(Object, TreePath, boolean, TreePath, TreePath) - Constructor for class javax.swing.event.TreeSelectionEvent
Represents a change in the selection of a TreeSelectionModel.
TreeSelectionHandler() - Constructor for class javax.swing.plaf.basic.BasicTreeUI.TreeSelectionHandler
TreeSelectionListener - Interface in javax.swing.event
The listener that's notified when the selection in a TreeSelectionModel changes.
treeSelectionModel - Variable in class javax.swing.plaf.basic.BasicTreeUI
Model maintaining the selection.
treeSelectionModel - Variable in class javax.swing.tree.AbstractLayoutCache
Selection model.
TreeSelectionModel - Interface in javax.swing.tree
This interface represents the current state of the selection for the tree component.
TreeSelectionRedirector() - Constructor for class javax.swing.JTree.TreeSelectionRedirector
TreeSet<E> - Class in java.util
A NavigableSet implementation based on a TreeMap.
TreeSet() - Constructor for class java.util.TreeSet
Constructs a new, empty tree set, sorted according to the natural ordering of its elements.
TreeSet(Comparator<? super E>) - Constructor for class java.util.TreeSet
Constructs a new, empty tree set, sorted according to the specified comparator.
TreeSet(Collection<? extends E>) - Constructor for class java.util.TreeSet
Constructs a new tree set containing the elements in the specified collection, sorted according to the natural ordering of its elements.
TreeSet(SortedSet<E>) - Constructor for class java.util.TreeSet
Constructs a new tree set containing the same elements and using the same ordering as the specified sorted set.
treeState - Variable in class javax.swing.plaf.basic.BasicTreeUI
Object responsible for handling sizing and expanded issues.
treeStructureChanged(TreeModelEvent) - Method in interface javax.swing.event.TreeModelListener
Invoked after the tree has drastically changed structure from a given node down.
treeStructureChanged(TreeModelEvent) - Method in class javax.swing.JTree.AccessibleJTree
Tree Model structure change change notification.
treeStructureChanged(TreeModelEvent) - Method in class javax.swing.JTree.TreeModelHandler
treeStructureChanged(TreeModelEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.TreeModelHandler
treeStructureChanged(TreeModelEvent) - Method in class javax.swing.tree.AbstractLayoutCache
Invoked after the tree has drastically changed structure from a given node down.
treeStructureChanged(TreeModelEvent) - Method in class javax.swing.tree.FixedHeightLayoutCache
Invoked after the tree has drastically changed structure from a given node down.
treeStructureChanged(TreeModelEvent) - Method in class javax.swing.tree.VariableHeightLayoutCache
Invoked after the tree has drastically changed structure from a given node down.
TreeToggleAction(String) - Constructor for class javax.swing.plaf.basic.BasicTreeUI.TreeToggleAction
TreeTraverseAction(int, String) - Constructor for class javax.swing.plaf.basic.BasicTreeUI.TreeTraverseAction
TreeUI - Class in javax.swing.plaf
Pluggable look and feel interface for JTree.
TreeUI() - Constructor for class javax.swing.plaf.TreeUI
treeWillCollapse(TreeExpansionEvent) - Method in interface javax.swing.event.TreeWillExpandListener
Invoked whenever a node in the tree is about to be collapsed.
treeWillExpand(TreeExpansionEvent) - Method in interface javax.swing.event.TreeWillExpandListener
Invoked whenever a node in the tree is about to be expanded.
TreeWillExpandListener - Interface in javax.swing.event
The listener that's notified when a tree expands or collapses a node.
trim() - Method in class java.lang.String
Returns a string whose value is this string, with any leading and trailing whitespace removed.
trimEdits(int, int) - Method in class javax.swing.undo.UndoManager
Removes edits in the specified range.
trimForLimit() - Method in class javax.swing.undo.UndoManager
Reduces the number of queued edits to a range of size limit, centered on the index of the next edit.
trimToSize() - Method in class java.lang.StringBuffer
trimToSize() - Method in class java.util.ArrayList
Trims the capacity of this ArrayList instance to be the list's current size.
trimToSize() - Method in class java.util.Vector
Trims the capacity of this vector to be the vector's current size.
trimToSize() - Method in class javax.swing.DefaultListModel
Trims the capacity of this list to be the list's current size.
TRUE - Static variable in class java.lang.Boolean
The Boolean object corresponding to the primitive value true.
TRUE - Static variable in interface java.util.jar.Pack200.Packer
The string "true", a possible value for certain properties.
TRUE - Static variable in interface java.util.jar.Pack200.Unpacker
The string "true", a possible value for certain properties.
TRUETYPE_FONT - Static variable in class java.awt.Font
Identify a font resource of type TRUETYPE.
truncate(long) - Method in class java.nio.channels.AsynchronousFileChannel
Truncates this channel's file to the given size.
truncate(long) - Method in class java.nio.channels.FileChannel
Truncates this channel's file to the given size.
truncate(long) - Method in interface java.nio.channels.SeekableByteChannel
Truncates the entity, to which this channel is connected, to the given size.
truncate(long) - Method in interface java.sql.Blob
Truncates the BLOB value that this Blob object represents to be len bytes in length.
truncate(long) - Method in interface java.sql.Clob
Truncates the CLOB value that this Clob designates to have a length of len characters.
truncate(long) - Method in class javax.sql.rowset.serial.SerialBlob
Truncates the BLOB value that this Blob object represents to be len bytes in length.
truncate(long) - Method in class javax.sql.rowset.serial.SerialClob
Truncates the CLOB value that this SerialClob object represents so that it has a length of len characters.
TRUNCATED - Static variable in class javax.accessibility.AccessibleState
A state indicating that text is truncated by a bounding rectangle and that some of the text is not displayed on the screen.
truncatedTo(TemporalUnit) - Method in class java.time.Instant
Returns a copy of this Instant truncated to the specified unit.
truncatedTo(TemporalUnit) - Method in class java.time.LocalDateTime
Returns a copy of this LocalDateTime with the time truncated.
truncatedTo(TemporalUnit) - Method in class java.time.LocalTime
Returns a copy of this LocalTime with the time truncated.
truncatedTo(TemporalUnit) - Method in class java.time.OffsetDateTime
Returns a copy of this OffsetDateTime with the time truncated.
truncatedTo(TemporalUnit) - Method in class java.time.OffsetTime
Returns a copy of this OffsetTime with the time truncated.
truncatedTo(TemporalUnit) - Method in class java.time.ZonedDateTime
Returns a copy of this ZonedDateTime with the time truncated.
TrustAnchor - Class in java.security.cert
A trust anchor or most-trusted Certification Authority (CA).
TrustAnchor(X509Certificate, byte[]) - Constructor for class java.security.cert.TrustAnchor
Creates an instance of TrustAnchor with the specified X509Certificate and optional name constraints, which are intended to be used as additional constraints when validating an X.509 certification path.
TrustAnchor(X500Principal, PublicKey, byte[]) - Constructor for class java.security.cert.TrustAnchor
Creates an instance of TrustAnchor where the most-trusted CA is specified as an X500Principal and public key.
TrustAnchor(String, PublicKey, byte[]) - Constructor for class java.security.cert.TrustAnchor
Creates an instance of TrustAnchor where the most-trusted CA is specified as a distinguished name and public key.
TrustedCertificateEntry(Certificate) - Constructor for class java.security.KeyStore.TrustedCertificateEntry
Constructs a TrustedCertificateEntry with a trusted Certificate.
TrustedCertificateEntry(Certificate, Set<KeyStore.Entry.Attribute>) - Constructor for class java.security.KeyStore.TrustedCertificateEntry
Constructs a TrustedCertificateEntry with a trusted Certificate and associated entry attributes.
TrustManager - Interface in javax.net.ssl
This is the base interface for JSSE trust managers.
TrustManagerFactory - Class in javax.net.ssl
This class acts as a factory for trust managers based on a source of trust material.
TrustManagerFactory(TrustManagerFactorySpi, Provider, String) - Constructor for class javax.net.ssl.TrustManagerFactory
Creates a TrustManagerFactory object.
TrustManagerFactorySpi - Class in javax.net.ssl
This class defines the Service Provider Interface (SPI) for the TrustManagerFactory class.
TrustManagerFactorySpi() - Constructor for class javax.net.ssl.TrustManagerFactorySpi
tryAcquire(long) - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer
Attempts to acquire in exclusive mode.
tryAcquire(int) - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer
Attempts to acquire in exclusive mode.
tryAcquire() - Method in class java.util.concurrent.Semaphore
Acquires a permit from this semaphore, only if one is available at the time of invocation.
tryAcquire(long, TimeUnit) - Method in class java.util.concurrent.Semaphore
Acquires a permit from this semaphore, if one becomes available within the given waiting time and the current thread has not been interrupted.
tryAcquire(int) - Method in class java.util.concurrent.Semaphore
Acquires the given number of permits from this semaphore, only if all are available at the time of invocation.
tryAcquire(int, long, TimeUnit) - Method in class java.util.concurrent.Semaphore
Acquires the given number of permits from this semaphore, if all become available within the given waiting time and the current thread has not been interrupted.
tryAcquireNanos(long, long) - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer
Attempts to acquire in exclusive mode, aborting if interrupted, and failing if the given timeout elapses.
tryAcquireNanos(int, long) - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer
Attempts to acquire in exclusive mode, aborting if interrupted, and failing if the given timeout elapses.
tryAcquireShared(long) - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer
Attempts to acquire in shared mode.
tryAcquireShared(int) - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer
Attempts to acquire in shared mode.
tryAcquireSharedNanos(long, long) - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer
Attempts to acquire in shared mode, aborting if interrupted, and failing if the given timeout elapses.
tryAcquireSharedNanos(int, long) - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer
Attempts to acquire in shared mode, aborting if interrupted, and failing if the given timeout elapses.
tryAdvance(DoubleConsumer) - Method in interface java.util.Spliterator.OfDouble
tryAdvance(Consumer<? super Double>) - Method in interface java.util.Spliterator.OfDouble
If a remaining element exists, performs the given action on it, returning true; else returns false.
tryAdvance(IntConsumer) - Method in interface java.util.Spliterator.OfInt
tryAdvance(Consumer<? super Integer>) - Method in interface java.util.Spliterator.OfInt
If a remaining element exists, performs the given action on it, returning true; else returns false.
tryAdvance(LongConsumer) - Method in interface java.util.Spliterator.OfLong
tryAdvance(Consumer<? super Long>) - Method in interface java.util.Spliterator.OfLong
If a remaining element exists, performs the given action on it, returning true; else returns false.
tryAdvance(T_CONS) - Method in interface java.util.Spliterator.OfPrimitive
If a remaining element exists, performs the given action on it, returning true; else returns false.
tryAdvance(Consumer<? super T>) - Method in interface java.util.Spliterator
If a remaining element exists, performs the given action on it, returning true; else returns false.
tryComplete() - Method in class java.util.concurrent.CountedCompleter
If the pending count is nonzero, decrements the count; otherwise invokes CountedCompleter.onCompletion(CountedCompleter) and then similarly tries to complete this task's completer, if one exists, else marks this task as complete.
tryConvertToOptimisticRead(long) - Method in class java.util.concurrent.locks.StampedLock
If the lock state matches the given stamp then, if the stamp represents holding a lock, releases it and returns an observation stamp.
tryConvertToReadLock(long) - Method in class java.util.concurrent.locks.StampedLock
If the lock state matches the given stamp, performs one of the following actions.
tryConvertToWriteLock(long) - Method in class java.util.concurrent.locks.StampedLock
If the lock state matches the given stamp, performs one of the following actions.
tryLock(long, long, boolean) - Method in class java.nio.channels.AsynchronousFileChannel
Attempts to acquire a lock on the given region of this channel's file.
tryLock() - Method in class java.nio.channels.AsynchronousFileChannel
Attempts to acquire an exclusive lock on this channel's file.
tryLock(long, long, boolean) - Method in class java.nio.channels.FileChannel
Attempts to acquire a lock on the given region of this channel's file.
tryLock() - Method in class java.nio.channels.FileChannel
Attempts to acquire an exclusive lock on this channel's file.
tryLock() - Method in interface java.util.concurrent.locks.Lock
Acquires the lock only if it is free at the time of invocation.
tryLock(long, TimeUnit) - Method in interface java.util.concurrent.locks.Lock
Acquires the lock if it is free within the given waiting time and the current thread has not been interrupted.
tryLock() - Method in class java.util.concurrent.locks.ReentrantLock
Acquires the lock only if it is not held by another thread at the time of invocation.
tryLock(long, TimeUnit) - Method in class java.util.concurrent.locks.ReentrantLock
Acquires the lock if it is not held by another thread within the given waiting time and the current thread has not been interrupted.
tryLock() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock
Acquires the read lock only if the write lock is not held by another thread at the time of invocation.
tryLock(long, TimeUnit) - Method in class java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock
Acquires the read lock if the write lock is not held by another thread within the given waiting time and the current thread has not been interrupted.
tryLock() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock
Acquires the write lock only if it is not held by another thread at the time of invocation.
tryLock(long, TimeUnit) - Method in class java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock
Acquires the write lock if it is not held by another thread within the given waiting time and the current thread has not been interrupted.
tryOptimisticRead() - Method in class java.util.concurrent.locks.StampedLock
Returns a stamp that can later be validated, or zero if exclusively locked.
tryReadLock() - Method in class java.util.concurrent.locks.StampedLock
Non-exclusively acquires the lock if it is immediately available.
tryReadLock(long, TimeUnit) - Method in class java.util.concurrent.locks.StampedLock
Non-exclusively acquires the lock if it is available within the given time and the current thread has not been interrupted.
tryRelease(long) - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer
Attempts to set the state to reflect a release in exclusive mode.
tryRelease(int) - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer
Attempts to set the state to reflect a release in exclusive mode.
tryReleaseShared(long) - Method in class java.util.concurrent.locks.AbstractQueuedLongSynchronizer
Attempts to set the state to reflect a release in shared mode.
tryReleaseShared(int) - Method in class java.util.concurrent.locks.AbstractQueuedSynchronizer
Attempts to set the state to reflect a release in shared mode.
trySplit() - Method in interface java.util.Spliterator.OfDouble
trySplit() - Method in interface java.util.Spliterator.OfInt
trySplit() - Method in interface java.util.Spliterator.OfLong
trySplit() - Method in interface java.util.Spliterator.OfPrimitive
trySplit() - Method in interface java.util.Spliterator
If this spliterator can be partitioned, returns a Spliterator covering elements, that will, upon return from this method, not be covered by this Spliterator.
trySplit() - Method in class java.util.Spliterators.AbstractDoubleSpliterator
If this spliterator can be partitioned, returns a Spliterator covering elements, that will, upon return from this method, not be covered by this Spliterator.
trySplit() - Method in class java.util.Spliterators.AbstractIntSpliterator
If this spliterator can be partitioned, returns a Spliterator covering elements, that will, upon return from this method, not be covered by this Spliterator.
trySplit() - Method in class java.util.Spliterators.AbstractLongSpliterator
If this spliterator can be partitioned, returns a Spliterator covering elements, that will, upon return from this method, not be covered by this Spliterator.
trySplit() - Method in class java.util.Spliterators.AbstractSpliterator
If this spliterator can be partitioned, returns a Spliterator covering elements, that will, upon return from this method, not be covered by this Spliterator.
tryToLoadClass(String, ClassLoader) - Static method in class java.awt.datatransfer.DataFlavor
Tries to load a class from: the bootstrap loader, the system loader, the context loader (if one is present) and finally the loader specified.
tryTransfer(E) - Method in class java.util.concurrent.LinkedTransferQueue
Transfers the element to a waiting consumer immediately, if possible.
tryTransfer(E, long, TimeUnit) - Method in class java.util.concurrent.LinkedTransferQueue
Transfers the element to a consumer if it is possible to do so before the timeout elapses.
tryTransfer(E) - Method in interface java.util.concurrent.TransferQueue
Transfers the element to a waiting consumer immediately, if possible.
tryTransfer(E, long, TimeUnit) - Method in interface java.util.concurrent.TransferQueue
Transfers the element to a consumer if it is possible to do so before the timeout elapses.
tryUnfork() - Method in class java.util.concurrent.ForkJoinTask
Tries to unschedule this task for execution.
tryUnlockRead() - Method in class java.util.concurrent.locks.StampedLock
Releases one hold of the read lock if it is held, without requiring a stamp value.
tryUnlockWrite() - Method in class java.util.concurrent.locks.StampedLock
Releases the write lock if it is held, without requiring a stamp value.
tryWriteLock() - Method in class java.util.concurrent.locks.StampedLock
Exclusively acquires the lock if it is immediately available.
tryWriteLock(long, TimeUnit) - Method in class java.util.concurrent.locks.StampedLock
Exclusively acquires the lock if it is available within the given time and the current thread has not been interrupted.
TT - Static variable in class javax.swing.text.html.HTML.Tag
TT_EOF - Static variable in class java.io.StreamTokenizer
A constant indicating that the end of the stream has been read.
TT_EOL - Static variable in class java.io.StreamTokenizer
A constant indicating that the end of the line has been read.
TT_NUMBER - Static variable in class java.io.StreamTokenizer
A constant indicating that a number token has been read.
TT_WORD - Static variable in class java.io.StreamTokenizer
A constant indicating that a word token has been read.
TTL_DONT_CACHE - Static variable in class java.util.ResourceBundle.Control
The time-to-live constant for not caching loaded resource bundle instances.
TTL_NO_EXPIRATION_CONTROL - Static variable in class java.util.ResourceBundle.Control
The time-to-live constant for disabling the expiration control for loaded resource bundle instances in the cache.
ttype - Variable in class java.io.StreamTokenizer
After a call to the nextToken method, this field contains the type of the token just read.
TUESDAY - Static variable in class java.util.Calendar
Value of the Calendar.DAY_OF_WEEK field indicating Tuesday.
TUMBLE - Static variable in class javax.print.attribute.standard.Sides
An alias for "two sided short edge" (see TWO_SIDED_SHORT_EDGE).
TUNE_REQUEST - Static variable in class javax.sound.midi.ShortMessage
Status byte for Tune Request message (0xF6, or 246).
TWO_SIDED_LONG_EDGE - Static variable in class java.awt.JobAttributes.SidesType
The SidesType instance to use for specifying that consecutive job pages should be printed upon front and back sides of consecutive media sheets, such that the orientation of each pair of pages on the medium would be correct for the reader as if for binding on the long edge.
TWO_SIDED_LONG_EDGE - Static variable in class javax.print.attribute.standard.Sides
Imposes each consecutive pair of print-stream pages upon front and back sides of consecutive media sheets, such that the orientation of each pair of print-stream pages on the medium would be correct for the reader as if for binding on the long edge.
TWO_SIDED_SHORT_EDGE - Static variable in class java.awt.JobAttributes.SidesType
The SidesType instance to use for specifying that consecutive job pages should be printed upon front and back sides of consecutive media sheets, such that the orientation of each pair of pages on the medium would be correct for the reader as if for binding on the short edge.
TWO_SIDED_SHORT_EDGE - Static variable in class javax.print.attribute.standard.Sides
Imposes each consecutive pair of print-stream pages upon front and back sides of consecutive media sheets, such that the orientation of each pair of print-stream pages on the medium would be correct for the reader as if for binding on the short edge.
TYPE - Static variable in class java.lang.Boolean
The Class object representing the primitive type boolean.
TYPE - Static variable in class java.lang.Byte
The Class instance representing the primitive type byte.
TYPE - Static variable in class java.lang.Character
The Class instance representing the primitive type char.
TYPE - Static variable in class java.lang.Double
The Class instance representing the primitive type double.
TYPE - Static variable in class java.lang.Float
The Class instance representing the primitive type float.
TYPE - Static variable in class java.lang.Integer
The Class instance representing the primitive type int.
type() - Method in class java.lang.invoke.CallSite
Returns the type of this call site's target.
type() - Method in class java.lang.invoke.MethodHandle
Reports the type of this method handle.
TYPE - Static variable in class java.lang.Long
The Class instance representing the primitive type long.
type() - Method in class java.lang.ProcessBuilder.Redirect
Returns the type of this Redirect.
Type - Interface in java.lang.reflect
Type is the common superinterface for all types in the Java programming language.
TYPE - Static variable in class java.lang.Short
The Class instance representing the primitive type short.
TYPE - Static variable in class java.lang.Void
The Class object representing the pseudo-type corresponding to the keyword void.
type() - Method in class java.net.Proxy
Returns the proxy type.
type() - Method in interface java.net.SocketOption
Returns the type of the socket option value.
type() - Method in class java.nio.file.attribute.AclEntry
Returns the ACL entry type.
type() - Method in class java.nio.file.FileStore
Returns the type of this file store.
type() - Method in interface java.nio.file.WatchEvent.Kind
Returns the type of the context value.
type - Variable in class javax.naming.event.NamingEvent
Contains the type of this event.
type - Variable in class javax.sound.midi.MidiFileFormat
The type of MIDI file.
Type(String, String) - Constructor for class javax.sound.sampled.AudioFileFormat.Type
Constructs a file type.
Type(String) - Constructor for class javax.sound.sampled.BooleanControl.Type
Constructs a new boolean control type.
Type(String) - Constructor for class javax.sound.sampled.CompoundControl.Type
Constructs a new compound control type.
Type(String) - Constructor for class javax.sound.sampled.Control.Type
Constructs a new control type with the name specified.
Type(String) - Constructor for class javax.sound.sampled.EnumControl.Type
Constructs a new enumerated control type.
Type(String) - Constructor for class javax.sound.sampled.FloatControl.Type
Constructs a new float control type.
Type(String) - Constructor for class javax.sound.sampled.LineEvent.Type
Constructs a new event type.
type - Variable in class javax.swing.event.TableModelEvent
type - Variable in class javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange
TYPE - Static variable in class javax.swing.text.html.HTML.Attribute
type - Variable in class javax.swing.text.html.parser.AttributeList
type - Variable in class javax.swing.text.html.parser.ContentModel
Type.
type - Variable in class javax.swing.text.html.parser.Element
type - Variable in class javax.swing.text.html.parser.Entity
TYPE - Static variable in interface javax.xml.crypto.dsig.keyinfo.PGPData
URI identifying the PGPData KeyInfo type: http://www.w3.org/2000/09/xmldsig#PGPData.
TYPE - Static variable in interface javax.xml.crypto.dsig.keyinfo.X509Data
URI identifying the X509Data KeyInfo type: http://www.w3.org/2000/09/xmldsig#X509Data.
TYPE - Static variable in interface javax.xml.crypto.dsig.Manifest
URI that identifies the Manifest element (this can be specified as the value of the type parameter of the Reference class to identify the referent's type).
TYPE - Static variable in interface javax.xml.crypto.dsig.SignatureProperties
URI that identifies the SignatureProperties element (this can be specified as the value of the type parameter of the Reference class to identify the referent's type).
TYPE - Static variable in interface javax.xml.crypto.dsig.XMLObject
URI that identifies the Object element (this can be specified as the value of the type parameter of the Reference class to identify the referent's type).
type() - Method in class org.omg.CORBA._IDLTypeStub
type() - Method in class org.omg.CORBA.Any
Returns type information for the element contained in this Any object.
type(TypeCode) - Method in class org.omg.CORBA.Any
Sets this Any object's type field to the given TypeCode object and clears its value.
type() - Static method in class org.omg.CORBA.AnySeqHelper
type() - Static method in class org.omg.CORBA.BooleanSeqHelper
type() - Static method in class org.omg.CORBA.CharSeqHelper
type() - Static method in class org.omg.CORBA.CompletionStatusHelper
type() - Static method in class org.omg.CORBA.CurrentHelper
type() - Static method in class org.omg.CORBA.DefinitionKindHelper
type() - Static method in class org.omg.CORBA.DoubleSeqHelper
type() - Method in interface org.omg.CORBA.DynAny
Deprecated.
Returns the TypeCode of the object inserted into this DynAny.
type() - Static method in class org.omg.CORBA.FieldNameHelper
type() - Static method in class org.omg.CORBA.FloatSeqHelper
type() - Static method in class org.omg.CORBA.IdentifierHelper
type() - Static method in class org.omg.CORBA.IDLTypeHelper
type() - Method in interface org.omg.CORBA.IDLTypeOperations
The type attribute describes the type defined by an object derived from IDLType.
type() - Static method in class org.omg.CORBA.LongLongSeqHelper
type() - Static method in class org.omg.CORBA.LongSeqHelper
type() - Static method in class org.omg.CORBA.NameValuePairHelper
type() - Static method in class org.omg.CORBA.ObjectHelper
type() - Static method in class org.omg.CORBA.OctetSeqHelper
type() - Static method in class org.omg.CORBA.ParameterModeHelper
type() - Static method in class org.omg.CORBA.PolicyErrorCodeHelper
type() - Static method in class org.omg.CORBA.PolicyErrorHelper
type() - Static method in class org.omg.CORBA.PolicyHelper
type() - Static method in class org.omg.CORBA.PolicyListHelper
type() - Static method in class org.omg.CORBA.PolicyTypeHelper
type() - Static method in class org.omg.CORBA.RepositoryIdHelper
type() - Static method in class org.omg.CORBA.ServiceDetailHelper
type() - Static method in class org.omg.CORBA.ServiceInformationHelper
type() - Static method in class org.omg.CORBA.SetOverrideTypeHelper
type() - Static method in class org.omg.CORBA.ShortSeqHelper
type() - Static method in class org.omg.CORBA.StringSeqHelper
type() - Static method in class org.omg.CORBA.StringValueHelper
type - Variable in class org.omg.CORBA.StructMember
The type of the struct member described by this StructMember object.
type() - Static method in class org.omg.CORBA.StructMemberHelper
type() - Static method in class org.omg.CORBA.ULongLongSeqHelper
type() - Static method in class org.omg.CORBA.ULongSeqHelper
type - Variable in class org.omg.CORBA.UnionMember
The type of the union member described by this UnionMember object.
type() - Static method in class org.omg.CORBA.UnionMemberHelper
type() - Static method in class org.omg.CORBA.UnknownUserExceptionHelper
type() - Static method in class org.omg.CORBA.UShortSeqHelper
type() - Static method in class org.omg.CORBA.ValueBaseHelper
type - Variable in class org.omg.CORBA.ValueMember
The type of of this value member.
type() - Static method in class org.omg.CORBA.ValueMemberHelper
type() - Static method in class org.omg.CORBA.VersionSpecHelper
type() - Static method in class org.omg.CORBA.VisibilityHelper
type() - Static method in class org.omg.CORBA.WCharSeqHelper
type() - Static method in class org.omg.CORBA.WrongTransactionHelper
type() - Static method in class org.omg.CORBA.WStringSeqHelper
type() - Static method in class org.omg.CORBA.WStringValueHelper
type() - Static method in class org.omg.CosNaming.BindingHelper
type() - Static method in class org.omg.CosNaming.BindingIteratorHelper
type() - Static method in class org.omg.CosNaming.BindingListHelper
type() - Static method in class org.omg.CosNaming.BindingTypeHelper
type() - Static method in class org.omg.CosNaming.IstringHelper
type() - Static method in class org.omg.CosNaming.NameComponentHelper
type() - Static method in class org.omg.CosNaming.NameHelper
type() - Static method in class org.omg.CosNaming.NamingContextExtHelper
type() - Static method in class org.omg.CosNaming.NamingContextExtPackage.AddressHelper
type() - Static method in class org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper
type() - Static method in class org.omg.CosNaming.NamingContextExtPackage.StringNameHelper
type() - Static method in class org.omg.CosNaming.NamingContextExtPackage.URLStringHelper
type() - Static method in class org.omg.CosNaming.NamingContextHelper
type() - Static method in class org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper
type() - Static method in class org.omg.CosNaming.NamingContextPackage.CannotProceedHelper
type() - Static method in class org.omg.CosNaming.NamingContextPackage.InvalidNameHelper
type() - Static method in class org.omg.CosNaming.NamingContextPackage.NotEmptyHelper
type() - Static method in class org.omg.CosNaming.NamingContextPackage.NotFoundHelper
type() - Static method in class org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper
type() - Method in class org.omg.DynamicAny._DynAnyStub
Returns the TypeCode associated with this DynAny object.
type() - Method in class org.omg.DynamicAny._DynArrayStub
Returns the TypeCode associated with this DynAny object.
type() - Method in class org.omg.DynamicAny._DynEnumStub
Returns the TypeCode associated with this DynAny object.
type() - Method in class org.omg.DynamicAny._DynFixedStub
Returns the TypeCode associated with this DynAny object.
type() - Method in class org.omg.DynamicAny._DynSequenceStub
Returns the TypeCode associated with this DynAny object.
type() - Method in class org.omg.DynamicAny._DynStructStub
Returns the TypeCode associated with this DynAny object.
type() - Method in class org.omg.DynamicAny._DynUnionStub
Returns the TypeCode associated with this DynAny object.
type() - Method in class org.omg.DynamicAny._DynValueStub
Returns the TypeCode associated with this DynAny object.
type() - Static method in class org.omg.DynamicAny.AnySeqHelper
type() - Static method in class org.omg.DynamicAny.DynAnyFactoryHelper
type() - Static method in class org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper
type() - Static method in class org.omg.DynamicAny.DynAnyHelper
type() - Method in interface org.omg.DynamicAny.DynAnyOperations
Returns the TypeCode associated with this DynAny object.
type() - Static method in class org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper
type() - Static method in class org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper
type() - Static method in class org.omg.DynamicAny.DynAnySeqHelper
type() - Static method in class org.omg.DynamicAny.DynArrayHelper
type() - Static method in class org.omg.DynamicAny.DynEnumHelper
type() - Static method in class org.omg.DynamicAny.DynFixedHelper
type() - Static method in class org.omg.DynamicAny.DynSequenceHelper
type() - Static method in class org.omg.DynamicAny.DynStructHelper
type() - Static method in class org.omg.DynamicAny.DynUnionHelper
type() - Static method in class org.omg.DynamicAny.DynValueHelper
type() - Static method in class org.omg.DynamicAny.FieldNameHelper
type() - Static method in class org.omg.DynamicAny.NameDynAnyPairHelper
type() - Static method in class org.omg.DynamicAny.NameDynAnyPairSeqHelper
type() - Static method in class org.omg.DynamicAny.NameValuePairHelper
type() - Static method in class org.omg.DynamicAny.NameValuePairSeqHelper
type() - Static method in class org.omg.IOP.CodecFactoryHelper
type() - Static method in class org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper
type() - Static method in class org.omg.IOP.CodecPackage.FormatMismatchHelper
type() - Static method in class org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper
type() - Static method in class org.omg.IOP.CodecPackage.TypeMismatchHelper
type() - Static method in class org.omg.IOP.ComponentIdHelper
type() - Static method in class org.omg.IOP.IORHelper
type() - Static method in class org.omg.IOP.MultipleComponentProfileHelper
type() - Static method in class org.omg.IOP.ProfileIdHelper
type() - Static method in class org.omg.IOP.ServiceContextHelper
type() - Static method in class org.omg.IOP.ServiceContextListHelper
type() - Static method in class org.omg.IOP.ServiceIdHelper
type() - Static method in class org.omg.IOP.TaggedComponentHelper
type() - Static method in class org.omg.IOP.TaggedProfileHelper
type() - Static method in class org.omg.Messaging.SyncScopeHelper
type() - Static method in class org.omg.PortableInterceptor.AdapterManagerIdHelper
type() - Static method in class org.omg.PortableInterceptor.AdapterNameHelper
type() - Static method in class org.omg.PortableInterceptor.AdapterStateHelper
type() - Static method in class org.omg.PortableInterceptor.CurrentHelper
type() - Static method in class org.omg.PortableInterceptor.ForwardRequestHelper
type() - Static method in class org.omg.PortableInterceptor.InvalidSlotHelper
type() - Static method in class org.omg.PortableInterceptor.IORInterceptor_3_0Helper
type() - Static method in class org.omg.PortableInterceptor.ObjectIdHelper
type() - Static method in class org.omg.PortableInterceptor.ObjectReferenceFactoryHelper
type() - Static method in class org.omg.PortableInterceptor.ObjectReferenceTemplateHelper
type() - Static method in class org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper
type() - Static method in class org.omg.PortableInterceptor.ORBIdHelper
type() - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper
type() - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper
type() - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper
type() - Static method in class org.omg.PortableInterceptor.ServerIdHelper
type() - Static method in class org.omg.PortableServer.CurrentHelper
type() - Static method in class org.omg.PortableServer.CurrentPackage.NoContextHelper
type() - Static method in class org.omg.PortableServer.ForwardRequestHelper
type() - Static method in class org.omg.PortableServer.POAHelper
type() - Static method in class org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper
type() - Static method in class org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper
type() - Static method in class org.omg.PortableServer.POAPackage.AdapterNonExistentHelper
type() - Static method in class org.omg.PortableServer.POAPackage.InvalidPolicyHelper
type() - Static method in class org.omg.PortableServer.POAPackage.NoServantHelper
type() - Static method in class org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper
type() - Static method in class org.omg.PortableServer.POAPackage.ObjectNotActiveHelper
type() - Static method in class org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper
type() - Static method in class org.omg.PortableServer.POAPackage.ServantNotActiveHelper
type() - Static method in class org.omg.PortableServer.POAPackage.WrongAdapterHelper
type() - Static method in class org.omg.PortableServer.POAPackage.WrongPolicyHelper
type() - Static method in class org.omg.PortableServer.ServantActivatorHelper
type() - Static method in class org.omg.PortableServer.ServantLocatorHelper
TYPE1_FONT - Static variable in class java.awt.Font
Identify a font resource of type TYPE1.
type2name(int) - Static method in class javax.swing.text.html.parser.AttributeList
TYPE_2CLR - Static variable in class java.awt.color.ColorSpace
Generic 2 component color spaces.
TYPE_3BYTE_BGR - Static variable in class java.awt.image.BufferedImage
Represents an image with 8-bit RGB color components, corresponding to a Windows-style BGR color model) with the colors Blue, Green, and Red stored in 3 bytes.
TYPE_3CLR - Static variable in class java.awt.color.ColorSpace
Generic 3 component color spaces.
TYPE_4BYTE_ABGR - Static variable in class java.awt.image.BufferedImage
Represents an image with 8-bit RGBA color components with the colors Blue, Green, and Red stored in 3 bytes and 1 byte of alpha.
TYPE_4BYTE_ABGR_PRE - Static variable in class java.awt.image.BufferedImage
Represents an image with 8-bit RGBA color components with the colors Blue, Green, and Red stored in 3 bytes and 1 byte of alpha.
TYPE_4CLR - Static variable in class java.awt.color.ColorSpace
Generic 4 component color spaces.
TYPE_5CLR - Static variable in class java.awt.color.ColorSpace
Generic 5 component color spaces.
TYPE_6CLR - Static variable in class java.awt.color.ColorSpace
Generic 6 component color spaces.
TYPE_7CLR - Static variable in class java.awt.color.ColorSpace
Generic 7 component color spaces.
TYPE_8CLR - Static variable in class java.awt.color.ColorSpace
Generic 8 component color spaces.
TYPE_9CLR - Static variable in class java.awt.color.ColorSpace
Generic 9 component color spaces.
TYPE_ACLR - Static variable in class java.awt.color.ColorSpace
Generic 10 component color spaces.
TYPE_BCLR - Static variable in class java.awt.color.ColorSpace
Generic 11 component color spaces.
TYPE_BICUBIC - Static variable in class java.awt.image.AffineTransformOp
Bicubic interpolation type.
TYPE_BILINEAR - Static variable in class java.awt.image.AffineTransformOp
Bilinear interpolation type.
TYPE_BYTE - Static variable in class java.awt.image.DataBuffer
Tag for unsigned byte data.
TYPE_BYTE_BINARY - Static variable in class java.awt.image.BufferedImage
Represents an opaque byte-packed 1, 2, or 4 bit image.
TYPE_BYTE_GRAY - Static variable in class java.awt.image.BufferedImage
Represents a unsigned byte grayscale image, non-indexed.
TYPE_BYTE_INDEXED - Static variable in class java.awt.image.BufferedImage
Represents an indexed byte image.
TYPE_CCLR - Static variable in class java.awt.color.ColorSpace
Generic 12 component color spaces.
TYPE_CMY - Static variable in class java.awt.color.ColorSpace
Any of the family of CMY color spaces.
TYPE_CMYK - Static variable in class java.awt.color.ColorSpace
Any of the family of CMYK color spaces.
TYPE_CUSTOM - Static variable in class java.awt.image.BufferedImage
Image type is not recognized so it must be a customized image.
TYPE_DCLR - Static variable in class java.awt.color.ColorSpace
Generic 13 component color spaces.
type_def - Variable in class org.omg.CORBA.StructMember
The typedef that represents the IDL type of the struct member described by this StructMember object.
type_def - Variable in class org.omg.CORBA.UnionMember
The typedef that represents the IDL type of the union member described by this UnionMember object.
type_def - Variable in class org.omg.CORBA.ValueMember
The typedef that represents the IDL type of the value member described by this ValueMember object.
TYPE_DOUBLE - Static variable in class java.awt.image.DataBuffer
Tag for double data.
TYPE_ECLR - Static variable in class java.awt.color.ColorSpace
Generic 14 component color spaces.
TYPE_FCLR - Static variable in class java.awt.color.ColorSpace
Generic 15 component color spaces.
TYPE_FLIP - Static variable in class java.awt.geom.AffineTransform
This flag bit indicates that the transform defined by this object performs a mirror image flip about some axis which changes the normally right handed coordinate system into a left handed system in addition to the conversions indicated by other flag bits.
TYPE_FLOAT - Static variable in class java.awt.image.DataBuffer
Tag for float data.
TYPE_FORWARD_ONLY - Static variable in interface java.sql.ResultSet
The constant indicating the type for a ResultSet object whose cursor may move only forward.
TYPE_GENERAL_ROTATION - Static variable in class java.awt.geom.AffineTransform
This flag bit indicates that the transform defined by this object performs a rotation by an arbitrary angle in addition to the conversions indicated by other flag bits.
TYPE_GENERAL_SCALE - Static variable in class java.awt.geom.AffineTransform
This flag bit indicates that the transform defined by this object performs a general scale in addition to the conversions indicated by other flag bits.
TYPE_GENERAL_TRANSFORM - Static variable in class java.awt.geom.AffineTransform
This constant indicates that the transform defined by this object performs an arbitrary conversion of the input coordinates.
TYPE_GRAY - Static variable in class java.awt.color.ColorSpace
Any of the family of GRAY color spaces.
TYPE_HLS - Static variable in class java.awt.color.ColorSpace
Any of the family of HLS color spaces.
TYPE_HSV - Static variable in class java.awt.color.ColorSpace
Any of the family of HSV color spaces.
type_id - Variable in class org.omg.IOP.IOR
The type id, represented as a String.
TYPE_IDENTITY - Static variable in class java.awt.geom.AffineTransform
This constant indicates that the transform defined by this object is an identity transform.
TYPE_IMAGE_BUFFER - Static variable in class java.awt.GraphicsDevice
Device is an image buffer.
TYPE_INT - Static variable in class java.awt.image.DataBuffer
Tag for int data.
TYPE_INT_ARGB - Static variable in class java.awt.image.BufferedImage
Represents an image with 8-bit RGBA color components packed into integer pixels.
TYPE_INT_ARGB_PRE - Static variable in class java.awt.image.BufferedImage
Represents an image with 8-bit RGBA color components packed into integer pixels.
TYPE_INT_BGR - Static variable in class java.awt.image.BufferedImage
Represents an image with 8-bit RGB color components, corresponding to a Windows- or Solaris- style BGR color model, with the colors Blue, Green, and Red packed into integer pixels.
TYPE_INT_RGB - Static variable in class java.awt.image.BufferedImage
Represents an image with 8-bit RGB color components packed into integer pixels.
TYPE_Lab - Static variable in class java.awt.color.ColorSpace
Any of the family of Lab color spaces.
TYPE_Luv - Static variable in class java.awt.color.ColorSpace
Any of the family of Luv color spaces.
TYPE_MASK_ROTATION - Static variable in class java.awt.geom.AffineTransform
This constant is a bit mask for any of the rotation flag bits.
TYPE_MASK_SCALE - Static variable in class java.awt.geom.AffineTransform
This constant is a bit mask for any of the scale flag bits.
TYPE_MISMATCH_ERR - Static variable in exception org.w3c.dom.DOMException
If the type of an object is incompatible with the expected type of the parameter associated to the object.
type_modifier() - Method in class org.omg.CORBA.TypeCode
Returns a constant indicating the modifier of the value type that this TypeCode object describes.
TYPE_NEAREST_NEIGHBOR - Static variable in class java.awt.image.AffineTransformOp
Nearest-neighbor interpolation type.
TYPE_PRINTER - Static variable in class java.awt.GraphicsDevice
Device is a printer.
TYPE_QUADRANT_ROTATION - Static variable in class java.awt.geom.AffineTransform
This flag bit indicates that the transform defined by this object performs a quadrant rotation by some multiple of 90 degrees in addition to the conversions indicated by other flag bits.
TYPE_RASTER_SCREEN - Static variable in class java.awt.GraphicsDevice
Device is a raster screen.
TYPE_RGB - Static variable in class java.awt.color.ColorSpace
Any of the family of RGB color spaces.
TYPE_SCROLL_INSENSITIVE - Static variable in interface java.sql.ResultSet
The constant indicating the type for a ResultSet object that is scrollable but generally not sensitive to changes to the data that underlies the ResultSet.
TYPE_SCROLL_SENSITIVE - Static variable in interface java.sql.ResultSet
The constant indicating the type for a ResultSet object that is scrollable and generally sensitive to changes to the data that underlies the ResultSet.
TYPE_SHORT - Static variable in class java.awt.image.DataBuffer
Tag for signed short data.
TYPE_TRANSLATION - Static variable in class java.awt.geom.AffineTransform
This flag bit indicates that the transform defined by this object performs a translation in addition to the conversions indicated by other flag bits.
TYPE_UNDEFINED - Static variable in class java.awt.image.DataBuffer
Tag for undefined data.
TYPE_UNIFORM_SCALE - Static variable in class java.awt.geom.AffineTransform
This flag bit indicates that the transform defined by this object performs a uniform scale in addition to the conversions indicated by other flag bits.
TYPE_USHORT - Static variable in class java.awt.image.DataBuffer
Tag for unsigned short data.
TYPE_USHORT_555_RGB - Static variable in class java.awt.image.BufferedImage
Represents an image with 5-5-5 RGB color components (5-bits red, 5-bits green, 5-bits blue) with no alpha.
TYPE_USHORT_565_RGB - Static variable in class java.awt.image.BufferedImage
Represents an image with 5-6-5 RGB color components (5-bits red, 6-bits green, 5-bits blue) with no alpha.
TYPE_USHORT_GRAY - Static variable in class java.awt.image.BufferedImage
Represents an unsigned short grayscale image, non-indexed).
TYPE_XYZ - Static variable in class java.awt.color.ColorSpace
Any of the family of XYZ color spaces.
TYPE_YCbCr - Static variable in class java.awt.color.ColorSpace
Any of the family of YCbCr color spaces.
TYPE_Yxy - Static variable in class java.awt.color.ColorSpace
Any of the family of Yxy color spaces.
TypeCode - Class in org.omg.CORBA
A container for information about a specific CORBA data type.
TypeCode() - Constructor for class org.omg.CORBA.TypeCode
TypeCodeHolder - Class in org.omg.CORBA
The Holder for TypeCode.
TypeCodeHolder() - Constructor for class org.omg.CORBA.TypeCodeHolder
Constructs a new TypeCodeHolder object with its value field initialized to null.
TypeCodeHolder(TypeCode) - Constructor for class org.omg.CORBA.TypeCodeHolder
Constructs a new TypeCodeHolder object with its value field initialized to the given TypeCode object.
TypeConstraintException - Exception in javax.xml.bind
This exception indicates that a violation of a dynamically checked type constraint was detected.
TypeConstraintException(String) - Constructor for exception javax.xml.bind.TypeConstraintException
Construct a TypeConstraintException with the specified detail message.
TypeConstraintException(String, String) - Constructor for exception javax.xml.bind.TypeConstraintException
Construct a TypeConstraintException with the specified detail message and vendor specific errorCode.
TypeConstraintException(Throwable) - Constructor for exception javax.xml.bind.TypeConstraintException
Construct a TypeConstraintException with a linkedException.
TypeConstraintException(String, Throwable) - Constructor for exception javax.xml.bind.TypeConstraintException
Construct a TypeConstraintException with the specified detail message and linkedException.
TypeConstraintException(String, String, Throwable) - Constructor for exception javax.xml.bind.TypeConstraintException
Construct a TypeConstraintException with the specified detail message, vendor specific errorCode, and linkedException.
TypeElement - Interface in javax.lang.model.element
Represents a class or interface program element.
TypeInfo - Interface in org.w3c.dom
The TypeInfo interface represents a type referenced from Element or Attr nodes, specified in the schemas associated with the document.
TypeInfoProvider - Class in javax.xml.validation
This class provides access to the type information determined by ValidatorHandler.
TypeInfoProvider() - Constructor for class javax.xml.validation.TypeInfoProvider
Constructor for the derived class.
TypeKind - Enum in javax.lang.model.type
The kind of a type mirror.
TypeKindVisitor6<R,P> - Class in javax.lang.model.util
A visitor of types based on their kind with default behavior appropriate for the RELEASE_6 source version.
TypeKindVisitor6() - Constructor for class javax.lang.model.util.TypeKindVisitor6
Constructor for concrete subclasses to call; uses null for the default value.
TypeKindVisitor6(R) - Constructor for class javax.lang.model.util.TypeKindVisitor6
Constructor for concrete subclasses to call; uses the argument for the default value.
TypeKindVisitor7<R,P> - Class in javax.lang.model.util
A visitor of types based on their kind with default behavior appropriate for the RELEASE_7 source version.
TypeKindVisitor7() - Constructor for class javax.lang.model.util.TypeKindVisitor7
Constructor for concrete subclasses to call; uses null for the default value.
TypeKindVisitor7(R) - Constructor for class javax.lang.model.util.TypeKindVisitor7
Constructor for concrete subclasses to call; uses the argument for the default value.
TypeKindVisitor8<R,P> - Class in javax.lang.model.util
A visitor of types based on their kind with default behavior appropriate for the RELEASE_8 source version.
TypeKindVisitor8() - Constructor for class javax.lang.model.util.TypeKindVisitor8
Constructor for concrete subclasses to call; uses null for the default value.
TypeKindVisitor8(R) - Constructor for class javax.lang.model.util.TypeKindVisitor8
Constructor for concrete subclasses to call; uses the argument for the default value.
TypeMirror - Interface in javax.lang.model.type
Represents a type in the Java programming language.
TypeMismatch - Exception in org.omg.CORBA.DynAnyPackage
TypeMismatch is thrown by dynamic any accessor methods when type of the actual contents do not match what is trying to be accessed.
TypeMismatch() - Constructor for exception org.omg.CORBA.DynAnyPackage.TypeMismatch
Constructs a TypeMismatch object.
TypeMismatch(String) - Constructor for exception org.omg.CORBA.DynAnyPackage.TypeMismatch
Constructs a TypeMismatch object.
TypeMismatch - Exception in org.omg.DynamicAny.DynAnyPackage
org/omg/DynamicAny/DynAnyPackage/TypeMismatch.java .
TypeMismatch() - Constructor for exception org.omg.DynamicAny.DynAnyPackage.TypeMismatch
TypeMismatch(String) - Constructor for exception org.omg.DynamicAny.DynAnyPackage.TypeMismatch
TypeMismatch - Exception in org.omg.IOP.CodecPackage
org/omg/IOP/CodecPackage/TypeMismatch.java .
TypeMismatch() - Constructor for exception org.omg.IOP.CodecPackage.TypeMismatch
TypeMismatch(String) - Constructor for exception org.omg.IOP.CodecPackage.TypeMismatch
TypeMismatchHelper - Class in org.omg.DynamicAny.DynAnyPackage
org/omg/DynamicAny/DynAnyPackage/TypeMismatchHelper.java .
TypeMismatchHelper() - Constructor for class org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper
TypeMismatchHelper - Class in org.omg.IOP.CodecPackage
org/omg/IOP/CodecPackage/TypeMismatchHelper.java .
TypeMismatchHelper() - Constructor for class org.omg.IOP.CodecPackage.TypeMismatchHelper
typeName() - Method in exception java.lang.TypeNotPresentException
Returns the fully qualified name of the unavailable type.
typeNoNulls - Static variable in interface java.sql.DatabaseMetaData
Indicates that a NULL value is NOT allowed for this data type.
TypeNotPresentException - Exception in java.lang
Thrown when an application tries to access a type using a string representing the type's name, but no definition for the type with the specified name can be found.
TypeNotPresentException(String, Throwable) - Constructor for exception java.lang.TypeNotPresentException
Constructs a TypeNotPresentException for the named type with the specified cause.
typeNullable - Static variable in interface java.sql.DatabaseMetaData
Indicates that a NULL value is allowed for this data type.
typeNullableUnknown - Static variable in interface java.sql.DatabaseMetaData
Indicates that it is not known whether a NULL value is allowed for this data type.
TypeParameterElement - Interface in javax.lang.model.element
Represents a formal type parameter of a generic class, interface, method, or constructor element.
typePredBasic - Static variable in interface java.sql.DatabaseMetaData
Indicates that the data type can be only be used in WHERE search clauses that do not use LIKE predicates.
typePredChar - Static variable in interface java.sql.DatabaseMetaData
Indicates that the data type can be only be used in WHERE search clauses that use LIKE predicates.
typePredNone - Static variable in interface java.sql.DatabaseMetaData
Indicates that WHERE search clauses are not supported for this type.
Types - Class in java.sql
The class that defines the constants that are used to identify generic SQL types, called JDBC types.
Types - Interface in javax.lang.model.util
Utility methods for operating on types.
typeSearchable - Static variable in interface java.sql.DatabaseMetaData
Indicates that all WHERE search clauses can be based on this type.
typesIn(Iterable<? extends Element>) - Static method in class javax.lang.model.util.ElementFilter
Returns a list of types in elements.
typesIn(Set<? extends Element>) - Static method in class javax.lang.model.util.ElementFilter
Returns a set of types in elements.
TypeVariable<D extends GenericDeclaration> - Interface in java.lang.reflect
TypeVariable is the common superinterface for type variables of kinds.
TypeVariable - Interface in javax.lang.model.type
Represents a type variable.
TypeVisitor<R,P> - Interface in javax.lang.model.type
A visitor of types, in the style of the visitor design pattern.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames


U-Index (Java Platform SE 8 )

Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames
  • All Classes
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

U

U - Static variable in class javax.swing.text.html.HTML.Tag
UGARITIC - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Ugaritic" Unicode character block.
ui - Variable in class javax.swing.JComponent
The look and feel delegate for this component.
ui - Variable in class javax.swing.plaf.basic.BasicMenuUI.ChangeHandler
UID - Class in java.rmi.server
A UID represents an identifier that is unique over time with respect to the host it is generated on, or one of 216 "well-known" identifiers.
UID() - Constructor for class java.rmi.server.UID
Generates a UID that is unique over time with respect to the host that it was generated on.
UID(short) - Constructor for class java.rmi.server.UID
Creates a "well-known" UID.
UIDefaults - Class in javax.swing
A table of defaults for Swing components.
UIDefaults() - Constructor for class javax.swing.UIDefaults
Creates an empty defaults table.
UIDefaults(int, float) - Constructor for class javax.swing.UIDefaults
Creates an empty defaults table with the specified initial capacity and load factor.
UIDefaults(Object[]) - Constructor for class javax.swing.UIDefaults
Creates a defaults table initialized with the specified key/value pairs.
UIDefaults.ActiveValue - Interface in javax.swing
This class enables one to store an entry in the defaults table that's constructed each time it's looked up with one of the getXXX(key) methods.
UIDefaults.LazyInputMap - Class in javax.swing
LazyInputMap will create a InputMap in its createValue method.
UIDefaults.LazyValue - Interface in javax.swing
This class enables one to store an entry in the defaults table that isn't constructed until the first time it's looked up with one of the getXXX(key) methods.
UIDefaults.ProxyLazyValue - Class in javax.swing
This class provides an implementation of LazyValue which can be used to delay loading of the Class for the instance to be created.
UIEvent - Interface in org.w3c.dom.events
The UIEvent interface provides specific contextual information associated with User Interface events.
UIManager - Class in javax.swing
UIManager manages the current look and feel, the set of available look and feels, PropertyChangeListeners that are notified when the look and feel changes, look and feel defaults, and convenience methods for obtaining various default values.
UIManager() - Constructor for class javax.swing.UIManager
UIManager.LookAndFeelInfo - Class in javax.swing
Provides a little information about an installed LookAndFeel for the sake of configuring a menu or for initial application set up.
UIResource() - Constructor for class javax.swing.DefaultListCellRenderer.UIResource
UIResource() - Constructor for class javax.swing.plaf.basic.BasicComboBoxEditor.UIResource
UIResource() - Constructor for class javax.swing.plaf.basic.BasicComboBoxRenderer.UIResource
UIResource() - Constructor for class javax.swing.plaf.metal.MetalComboBoxEditor.UIResource
UIResource - Interface in javax.swing.plaf
This interface is used to mark objects created by ComponentUI delegates.
UIResource() - Constructor for class javax.swing.ScrollPaneLayout.UIResource
UIResource() - Constructor for class javax.swing.table.DefaultTableCellRenderer.UIResource
uis - Variable in class javax.swing.plaf.multi.MultiButtonUI
The vector containing the real UIs.
uis - Variable in class javax.swing.plaf.multi.MultiColorChooserUI
The vector containing the real UIs.
uis - Variable in class javax.swing.plaf.multi.MultiComboBoxUI
The vector containing the real UIs.
uis - Variable in class javax.swing.plaf.multi.MultiDesktopIconUI
The vector containing the real UIs.
uis - Variable in class javax.swing.plaf.multi.MultiDesktopPaneUI
The vector containing the real UIs.
uis - Variable in class javax.swing.plaf.multi.MultiFileChooserUI
The vector containing the real UIs.
uis - Variable in class javax.swing.plaf.multi.MultiInternalFrameUI
The vector containing the real UIs.
uis - Variable in class javax.swing.plaf.multi.MultiLabelUI
The vector containing the real UIs.
uis - Variable in class javax.swing.plaf.multi.MultiListUI
The vector containing the real UIs.
uis - Variable in class javax.swing.plaf.multi.MultiMenuBarUI
The vector containing the real UIs.
uis - Variable in class javax.swing.plaf.multi.MultiMenuItemUI
The vector containing the real UIs.
uis - Variable in class javax.swing.plaf.multi.MultiOptionPaneUI
The vector containing the real UIs.
uis - Variable in class javax.swing.plaf.multi.MultiPanelUI
The vector containing the real UIs.
uis - Variable in class javax.swing.plaf.multi.MultiPopupMenuUI
The vector containing the real UIs.
uis - Variable in class javax.swing.plaf.multi.MultiProgressBarUI
The vector containing the real UIs.
uis - Variable in class javax.swing.plaf.multi.MultiRootPaneUI
The vector containing the real UIs.
uis - Variable in class javax.swing.plaf.multi.MultiScrollBarUI
The vector containing the real UIs.
uis - Variable in class javax.swing.plaf.multi.MultiScrollPaneUI
The vector containing the real UIs.
uis - Variable in class javax.swing.plaf.multi.MultiSeparatorUI
The vector containing the real UIs.
uis - Variable in class javax.swing.plaf.multi.MultiSliderUI
The vector containing the real UIs.
uis - Variable in class javax.swing.plaf.multi.MultiSpinnerUI
The vector containing the real UIs.
uis - Variable in class javax.swing.plaf.multi.MultiSplitPaneUI
The vector containing the real UIs.
uis - Variable in class javax.swing.plaf.multi.MultiTabbedPaneUI
The vector containing the real UIs.
uis - Variable in class javax.swing.plaf.multi.MultiTableHeaderUI
The vector containing the real UIs.
uis - Variable in class javax.swing.plaf.multi.MultiTableUI
The vector containing the real UIs.
uis - Variable in class javax.swing.plaf.multi.MultiTextUI
The vector containing the real UIs.
uis - Variable in class javax.swing.plaf.multi.MultiToolBarUI
The vector containing the real UIs.
uis - Variable in class javax.swing.plaf.multi.MultiToolTipUI
The vector containing the real UIs.
uis - Variable in class javax.swing.plaf.multi.MultiTreeUI
The vector containing the real UIs.
uis - Variable in class javax.swing.plaf.multi.MultiViewportUI
The vector containing the real UIs.
uisToArray(Vector) - Static method in class javax.swing.plaf.multi.MultiLookAndFeel
Creates an array, populates it with UI objects from the passed-in vector, and returns the array.
UK - Static variable in class java.util.Locale
Useful constant for country.
UL - Static variable in class javax.swing.text.html.HTML.Tag
ULAW - Static variable in class javax.sound.sampled.AudioFormat.Encoding
Specifies u-law encoded data.
ULongLongSeqHelper - Class in org.omg.CORBA
The Helper for ULongLongSeq.
ULongLongSeqHelper() - Constructor for class org.omg.CORBA.ULongLongSeqHelper
ULongLongSeqHolder - Class in org.omg.CORBA
The Holder for ULongLongSeq.
ULongLongSeqHolder() - Constructor for class org.omg.CORBA.ULongLongSeqHolder
ULongLongSeqHolder(long[]) - Constructor for class org.omg.CORBA.ULongLongSeqHolder
ULongSeqHelper - Class in org.omg.CORBA
The Helper for ULongSeq.
ULongSeqHelper() - Constructor for class org.omg.CORBA.ULongSeqHelper
ULongSeqHolder - Class in org.omg.CORBA
The Holder for ULongSeq.
ULongSeqHolder() - Constructor for class org.omg.CORBA.ULongSeqHolder
ULongSeqHolder(int[]) - Constructor for class org.omg.CORBA.ULongSeqHolder
ulp(double) - Static method in class java.lang.Math
Returns the size of an ulp of the argument.
ulp(float) - Static method in class java.lang.Math
Returns the size of an ulp of the argument.
ulp(double) - Static method in class java.lang.StrictMath
Returns the size of an ulp of the argument.
ulp(float) - Static method in class java.lang.StrictMath
Returns the size of an ulp of the argument.
ulp() - Method in class java.math.BigDecimal
Returns the size of an ulp, a unit in the last place, of this BigDecimal.
UnaryOperator<T> - Interface in java.util.function
Represents an operation on a single operand that produces a result of the same type as its operand.
UNASSIGNED - Static variable in class java.lang.Character
General category "Cn" in the Unicode specification.
UNAUTHORIZED - Static variable in exception org.ietf.jgss.GSSException
Operation unauthorized.
UNAVAILABLE - Static variable in exception org.ietf.jgss.GSSException
Operation unavailable.
unbind(String) - Static method in class java.rmi.Naming
Destroys the binding for the specified name that is associated with a remote object.
unbind(String) - Method in interface java.rmi.registry.Registry
Removes the binding for the specified name in this registry.
unbind(Name) - Method in interface javax.naming.Context
Unbinds the named object.
unbind(String) - Method in interface javax.naming.Context
Unbinds the named object.
unbind(String) - Method in class javax.naming.InitialContext
unbind(Name) - Method in class javax.naming.InitialContext
unbind(NameComponent[]) - Method in class org.omg.CosNaming._NamingContextExtStub
The unbind operation removes a name binding from a context.
unbind(NameComponent[]) - Method in class org.omg.CosNaming._NamingContextStub
The unbind operation removes a name binding from a context.
unbind(NameComponent[]) - Method in interface org.omg.CosNaming.NamingContextOperations
The unbind operation removes a name binding from a context.
unblock(InetAddress) - Method in class java.nio.channels.MembershipKey
Unblock multicast datagrams from the given source address that was previously blocked using the block method.
unboxedType(TypeMirror) - Method in interface javax.lang.model.util.Types
Returns the type (a primitive type) of unboxed values of a given type.
uncaughtException(Thread, Throwable) - Method in interface java.lang.Thread.UncaughtExceptionHandler
Method invoked when the given thread terminates due to the given uncaught exception.
uncaughtException(Thread, Throwable) - Method in class java.lang.ThreadGroup
Called by the Java Virtual Machine when a thread in this thread group stops because of an uncaught exception, and the thread does not have a specific Thread.UncaughtExceptionHandler installed.
unchecked_narrow(Object) - Static method in class org.omg.CosNaming.BindingIteratorHelper
unchecked_narrow(Object) - Static method in class org.omg.CosNaming.NamingContextExtHelper
unchecked_narrow(Object) - Static method in class org.omg.CosNaming.NamingContextHelper
unchecked_narrow(Object) - Static method in class org.omg.DynamicAny.DynAnyFactoryHelper
unchecked_narrow(Object) - Static method in class org.omg.DynamicAny.DynAnyHelper
unchecked_narrow(Object) - Static method in class org.omg.DynamicAny.DynArrayHelper
unchecked_narrow(Object) - Static method in class org.omg.DynamicAny.DynEnumHelper
unchecked_narrow(Object) - Static method in class org.omg.DynamicAny.DynFixedHelper
unchecked_narrow(Object) - Static method in class org.omg.DynamicAny.DynSequenceHelper
unchecked_narrow(Object) - Static method in class org.omg.DynamicAny.DynStructHelper
unchecked_narrow(Object) - Static method in class org.omg.DynamicAny.DynUnionHelper
unchecked_narrow(Object) - Static method in class org.omg.DynamicAny.DynValueHelper
unchecked_narrow(Object) - Static method in class org.omg.IOP.CodecFactoryHelper
unchecked_narrow(Object) - Static method in class org.omg.PortableInterceptor.CurrentHelper
unchecked_narrow(Object) - Static method in class org.omg.PortableInterceptor.IORInterceptor_3_0Helper
unchecked_narrow(Object) - Static method in class org.omg.PortableServer.ServantActivatorHelper
unchecked_narrow(Object) - Static method in class org.omg.PortableServer.ServantLocatorHelper
UncheckedIOException - Exception in java.io
Wraps an IOException with an unchecked exception.
UncheckedIOException(String, IOException) - Constructor for exception java.io.UncheckedIOException
Constructs an instance of this class.
UncheckedIOException(IOException) - Constructor for exception java.io.UncheckedIOException
Constructs an instance of this class.
UNCOLLATED - Static variable in class javax.print.attribute.standard.SheetCollate
Sheets within a document appear in uncollated order when multiple copies are printed.
unconfigurableExecutorService(ExecutorService) - Static method in class java.util.concurrent.Executors
Returns an object that delegates all defined ExecutorService methods to the given executor, but not any other methods that might otherwise be accessible using casts.
unconfigurableScheduledExecutorService(ScheduledExecutorService) - Static method in class java.util.concurrent.Executors
Returns an object that delegates all defined ScheduledExecutorService methods to the given executor, but not any other methods that might otherwise be accessible using casts.
unconfigureArrowButton() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
This public method is implementation specific and should be private.
unconfigureEditor() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
This protected method is implementation specific and should be private.
unconfigureEditor() - Method in class javax.swing.plaf.metal.MetalComboBoxUI
unconfigureEnclosingScrollPane() - Method in class javax.swing.JTable
Reverses the effect of configureEnclosingScrollPane by replacing the columnHeaderView of the enclosing scroll pane with null.
UNDECIMBER - Static variable in class java.util.Calendar
Value of the Calendar.MONTH field indicating the thirteenth month of the year.
UndeclaredThrowableException - Exception in java.lang.reflect
Thrown by a method invocation on a proxy instance if its invocation handler's invoke method throws a checked exception (a Throwable that is not assignable to RuntimeException or Error) that is not assignable to any of the exception types declared in the throws clause of the method that was invoked on the proxy instance and dispatched to the invocation handler.
UndeclaredThrowableException(Throwable) - Constructor for exception java.lang.reflect.UndeclaredThrowableException
Constructs an UndeclaredThrowableException with the specified Throwable.
UndeclaredThrowableException(Throwable, String) - Constructor for exception java.lang.reflect.UndeclaredThrowableException
Constructs an UndeclaredThrowableException with the specified Throwable and a detail message.
UNDEFINED - Static variable in class java.awt.BufferCapabilities.FlipContents
When flip contents are UNDEFINED, the contents of the back buffer are undefined after flipping.
UNDEFINED_CONDITION - Static variable in class javax.swing.JComponent
Constant used by some of the APIs to mean that no condition is defined.
UndefinedProperty - Static variable in class java.awt.Image
The UndefinedProperty object should be returned whenever a property which was not defined for a particular image is fetched.
UNDERFLOW - Static variable in class java.nio.charset.CoderResult
Result object indicating underflow, meaning that either the input buffer has been completely consumed or, if the input buffer is not yet empty, that additional input is required.
UNDERLINE - Static variable in class java.awt.font.TextAttribute
Attribute key for underline.
Underline - Static variable in class javax.swing.text.StyleConstants
Name of the underline attribute.
UNDERLINE_LOW_DASHED - Static variable in class java.awt.font.TextAttribute
Single pixel dashed low underline.
UNDERLINE_LOW_DOTTED - Static variable in class java.awt.font.TextAttribute
Single pixel dotted low underline.
UNDERLINE_LOW_GRAY - Static variable in class java.awt.font.TextAttribute
Double pixel gray low underline.
UNDERLINE_LOW_ONE_PIXEL - Static variable in class java.awt.font.TextAttribute
Single pixel solid low underline.
UNDERLINE_LOW_TWO_PIXEL - Static variable in class java.awt.font.TextAttribute
Double pixel solid low underline.
UNDERLINE_ON - Static variable in class java.awt.font.TextAttribute
Standard underline.
UnderlineAction() - Constructor for class javax.swing.text.StyledEditorKit.UnderlineAction
Constructs a new UnderlineAction.
undo() - Method in class javax.swing.text.AbstractDocument.DefaultDocumentEvent
Undoes a change.
undo() - Method in class javax.swing.text.AbstractDocument.ElementEdit
Undoes a change.
undo() - Method in class javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit
Undoes a change.
undo() - Method in class javax.swing.undo.AbstractUndoableEdit
Throws CannotUndoException if canUndo returns false.
undo() - Method in class javax.swing.undo.CompoundEdit
Sends undo to all contained UndoableEdits in the reverse of the order in which they were added.
undo() - Method in class javax.swing.undo.StateEdit
Tells the edited object to apply the state prior to the edit
undo() - Method in interface javax.swing.undo.UndoableEdit
Undo the edit.
undo() - Method in class javax.swing.undo.UndoManager
Undoes the appropriate edits.
UndoableEdit - Interface in javax.swing.undo
An UndoableEdit represents an edit.
UndoableEditEvent - Class in javax.swing.event
An event indicating that an operation which can be undone has occurred.
UndoableEditEvent(Object, UndoableEdit) - Constructor for class javax.swing.event.UndoableEditEvent
Constructs an UndoableEditEvent object.
undoableEditHappened(UndoableEditEvent) - Method in interface javax.swing.event.UndoableEditListener
An undoable edit happened
undoableEditHappened(UndoableEditEvent) - Method in class javax.swing.undo.UndoManager
An UndoableEditListener method.
UndoableEditListener - Interface in javax.swing.event
Interface implemented by a class interested in hearing about undoable operations.
UndoableEditSupport - Class in javax.swing.undo
A support class used for managing UndoableEdit listeners.
UndoableEditSupport() - Constructor for class javax.swing.undo.UndoableEditSupport
Constructs an UndoableEditSupport object.
UndoableEditSupport(Object) - Constructor for class javax.swing.undo.UndoableEditSupport
Constructs an UndoableEditSupport object.
undoDelete() - Method in interface javax.sql.rowset.CachedRowSet
Cancels the deletion of the current row and notifies listeners that a row has changed.
undoInsert() - Method in interface javax.sql.rowset.CachedRowSet
Immediately removes the current row from this CachedRowSet object if the row has been inserted, and also notifies listeners that a row has changed.
UndoManager - Class in javax.swing.undo
UndoManager manages a list of UndoableEdits, providing a way to undo or redo the appropriate edits.
UndoManager() - Constructor for class javax.swing.undo.UndoManager
Creates a new UndoManager.
UndoName - Static variable in class javax.swing.undo.AbstractUndoableEdit
String returned by getUndoPresentationName; as of Java 2 platform v1.3.1 this field is no longer used.
undoOrRedo() - Method in class javax.swing.undo.UndoManager
Convenience method that invokes one of undo or redo.
undoRedoName - Variable in class javax.swing.undo.StateEdit
The undo/redo presentation name
undoTo(UndoableEdit) - Method in class javax.swing.undo.UndoManager
Undoes all changes from the index of the next edit to edit, updating the index of the next edit appropriately.
undoUpdate() - Method in interface javax.sql.rowset.CachedRowSet
Immediately reverses the last update operation if the row has been modified.
unescapeValue(String) - Static method in class javax.naming.ldap.Rdn
Given an attribute value string formated according to the rules specified in RFC 2253, returns the unformated value.
UnexpectedException - Exception in java.rmi
An UnexpectedException is thrown if the client of a remote method call receives, as a result of the call, a checked exception that is not among the checked exception types declared in the throws clause of the method in the remote interface.
UnexpectedException(String) - Constructor for exception java.rmi.UnexpectedException
Constructs an UnexpectedException with the specified detail message.
UnexpectedException(String, Exception) - Constructor for exception java.rmi.UnexpectedException
Constructs a UnexpectedException with the specified detail message and nested exception.
unexportObject(Remote, boolean) - Static method in class java.rmi.activation.Activatable
Remove the remote object, obj, from the RMI runtime.
unexportObject(Remote, boolean) - Static method in class java.rmi.server.UnicastRemoteObject
Removes the remote object, obj, from the RMI runtime.
unexportObject(Remote) - Method in interface javax.rmi.CORBA.PortableRemoteObjectDelegate
Delegation call for PortableRemoteObject.unexportObject(java.rmi.Remote).
unexportObject(Remote) - Static method in class javax.rmi.CORBA.Util
Removes the associated tie from an internal table and calls Tie.deactivate() to deactivate the object.
unexportObject(Remote) - Method in interface javax.rmi.CORBA.UtilDelegate
Delegation call for Util.unexportObject(java.rmi.Remote).
unexportObject(Remote) - Static method in class javax.rmi.PortableRemoteObject
Deregisters a server object from the runtime, allowing the object to become available for garbage collection.
UnicastRemoteObject - Class in java.rmi.server
Used for exporting a remote object with JRMP and obtaining a stub that communicates to the remote object.
UnicastRemoteObject() - Constructor for class java.rmi.server.UnicastRemoteObject
Creates and exports a new UnicastRemoteObject object using an anonymous port.
UnicastRemoteObject(int) - Constructor for class java.rmi.server.UnicastRemoteObject
Creates and exports a new UnicastRemoteObject object using the particular supplied port.
UnicastRemoteObject(int, RMIClientSocketFactory, RMIServerSocketFactory) - Constructor for class java.rmi.server.UnicastRemoteObject
Creates and exports a new UnicastRemoteObject object using the particular supplied port and socket factories.
UNICODE_CASE - Static variable in class java.util.regex.Pattern
Enables Unicode-aware case folding.
UNICODE_CHARACTER_CLASS - Static variable in class java.util.regex.Pattern
Enables the Unicode version of Predefined character classes and POSIX character classes.
UNICODE_LOCALE_EXTENSION - Static variable in class java.util.Locale
The key for Unicode locale extension ('u').
UNICODE_STREAM_PARAM - Static variable in class javax.sql.rowset.BaseRowSet
A constant indicating to a RowSetReaderImpl object that a given parameter is a Unicode stream.
unicodeStream - Variable in class javax.sql.rowset.BaseRowSet
The InputStream object that will be returned by the method getUnicodeStream, which is specified in the ResultSet interface.
UNIFIED_CANADIAN_ABORIGINAL_SYLLABICS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Unified Canadian Aboriginal Syllabics" Unicode character block.
UNIFIED_CANADIAN_ABORIGINAL_SYLLABICS_EXTENDED - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Unified Canadian Aboriginal Syllabics Extended" Unicode character block.
uninitialize() - Method in class javax.swing.LookAndFeel
Uninitializes the look and feel.
uninitialize() - Method in class javax.swing.plaf.basic.BasicLookAndFeel
Uninitializes the look and feel.
uninitialize() - Method in class javax.swing.plaf.nimbus.NimbusLookAndFeel
Called by UIManager when this look and feel is uninstalled.
uninitialize() - Method in class javax.swing.plaf.synth.SynthLookAndFeel
Called by UIManager when this look and feel is uninstalled.
UNINITIALIZED - Static variable in class java.security.Signature
Possible Signature.state value, signifying that this signature object has not yet been initialized.
UNINITIALIZED_VALUE - Static variable in class javax.swing.JOptionPane
Indicates that the user has not yet selected a value.
uninstall() - Method in class javax.swing.JFormattedTextField.AbstractFormatter
Uninstalls any state the AbstractFormatter may have installed on the JFormattedTextField.
uninstallBorder(JComponent) - Static method in class javax.swing.LookAndFeel
Convenience method for uninstalling a border.
uninstallChooserPanel(JColorChooser) - Method in class javax.swing.colorchooser.AbstractColorChooserPanel
Invoked when the panel is removed from the chooser.
uninstallComboBoxModelListeners(ComboBoxModel) - Method in class javax.swing.plaf.basic.BasicComboPopup
Removes the listeners from the combo box model
uninstallComponents() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
The aggregate components which comprise the combo box are unregistered and uninitialized.
uninstallComponents() - Method in class javax.swing.plaf.basic.BasicDesktopIconUI
uninstallComponents(JFileChooser) - Method in class javax.swing.plaf.basic.BasicFileChooserUI
uninstallComponents() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
uninstallComponents(JLabel) - Method in class javax.swing.plaf.basic.BasicLabelUI
uninstallComponents(JMenuItem) - Method in class javax.swing.plaf.basic.BasicMenuItemUI
uninstallComponents() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI
uninstallComponents(JRootPane) - Method in class javax.swing.plaf.basic.BasicRootPaneUI
uninstallComponents() - Method in class javax.swing.plaf.basic.BasicScrollBarUI
uninstallComponents() - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
Removes any installed subcomponents from the JTabbedPane.
uninstallComponents() - Method in class javax.swing.plaf.basic.BasicToolBarUI
uninstallComponents() - Method in class javax.swing.plaf.basic.BasicTreeUI
Uninstalls the renderer pane.
uninstallComponents() - Method in class javax.swing.plaf.metal.MetalDesktopIconUI
uninstallComponents(JFileChooser) - Method in class javax.swing.plaf.metal.MetalFileChooserUI
uninstallComponents() - Method in class javax.swing.plaf.metal.MetalInternalFrameUI
uninstallComponents() - Method in class javax.swing.plaf.synth.SynthInternalFrameUI
uninstallComponents() - Method in class javax.swing.plaf.synth.SynthToolBarUI
uninstallDefaultChoosers() - Method in class javax.swing.plaf.basic.BasicColorChooserUI
uninstallDefaults(AbstractButton) - Method in class javax.swing.plaf.basic.BasicButtonUI
uninstallDefaults() - Method in class javax.swing.plaf.basic.BasicColorChooserUI
uninstallDefaults() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Uninstalls the default colors, default font, default renderer, and default editor from the combo box.
uninstallDefaults() - Method in class javax.swing.plaf.basic.BasicDesktopIconUI
uninstallDefaults() - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI
uninstallDefaults(JFileChooser) - Method in class javax.swing.plaf.basic.BasicFileChooserUI
uninstallDefaults() - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
uninstallDefaults() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
uninstallDefaults(JLabel) - Method in class javax.swing.plaf.basic.BasicLabelUI
uninstallDefaults() - Method in class javax.swing.plaf.basic.BasicListUI
Sets the list properties that have not been explicitly overridden to null.
uninstallDefaults() - Method in class javax.swing.plaf.basic.BasicMenuBarUI
uninstallDefaults() - Method in class javax.swing.plaf.basic.BasicMenuItemUI
uninstallDefaults() - Method in class javax.swing.plaf.basic.BasicMenuUI
uninstallDefaults() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI
uninstallDefaults(JPanel) - Method in class javax.swing.plaf.basic.BasicPanelUI
uninstallDefaults() - Method in class javax.swing.plaf.basic.BasicPopupMenuUI
uninstallDefaults() - Method in class javax.swing.plaf.basic.BasicProgressBarUI
uninstallDefaults(AbstractButton) - Method in class javax.swing.plaf.basic.BasicRadioButtonUI
uninstallDefaults(JRootPane) - Method in class javax.swing.plaf.basic.BasicRootPaneUI
uninstallDefaults() - Method in class javax.swing.plaf.basic.BasicScrollBarUI
uninstallDefaults(JScrollPane) - Method in class javax.swing.plaf.basic.BasicScrollPaneUI
uninstallDefaults(JSeparator) - Method in class javax.swing.plaf.basic.BasicSeparatorUI
uninstallDefaults(JSlider) - Method in class javax.swing.plaf.basic.BasicSliderUI
uninstallDefaults() - Method in class javax.swing.plaf.basic.BasicSpinnerUI
Sets the JSpinner's layout manager to null.
uninstallDefaults() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Uninstalls the UI defaults.
uninstallDefaults() - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
uninstallDefaults() - Method in class javax.swing.plaf.basic.BasicTableHeaderUI
uninstallDefaults() - Method in class javax.swing.plaf.basic.BasicTableUI
uninstallDefaults() - Method in class javax.swing.plaf.basic.BasicTextUI
Sets the component properties that have not been explicitly overridden to null.
uninstallDefaults() - Method in class javax.swing.plaf.basic.BasicToolBarUI
uninstallDefaults(JComponent) - Method in class javax.swing.plaf.basic.BasicToolTipUI
uninstallDefaults() - Method in class javax.swing.plaf.basic.BasicTreeUI
uninstallDefaults(JComponent) - Method in class javax.swing.plaf.basic.BasicViewportUI
uninstallDefaults(AbstractButton) - Method in class javax.swing.plaf.metal.MetalButtonUI
uninstallDefaults(AbstractButton) - Method in class javax.swing.plaf.metal.MetalCheckBoxUI
uninstallDefaults() - Method in class javax.swing.plaf.metal.MetalInternalFrameTitlePane
uninstallDefaults(AbstractButton) - Method in class javax.swing.plaf.metal.MetalRadioButtonUI
uninstallDefaults(AbstractButton) - Method in class javax.swing.plaf.metal.MetalToggleButtonUI
uninstallDefaults(AbstractButton) - Method in class javax.swing.plaf.synth.SynthButtonUI
uninstallDefaults() - Method in class javax.swing.plaf.synth.SynthColorChooserUI
uninstallDefaults() - Method in class javax.swing.plaf.synth.SynthComboBoxUI
Uninstalls the default colors, default font, default renderer, and default editor from the combo box.
uninstallDefaults() - Method in class javax.swing.plaf.synth.SynthDesktopIconUI
uninstallDefaults() - Method in class javax.swing.plaf.synth.SynthDesktopPaneUI
uninstallDefaults() - Method in class javax.swing.plaf.synth.SynthEditorPaneUI
Sets the component properties that have not been explicitly overridden to null.
uninstallDefaults() - Method in class javax.swing.plaf.synth.SynthInternalFrameUI
uninstallDefaults(JLabel) - Method in class javax.swing.plaf.synth.SynthLabelUI
uninstallDefaults() - Method in class javax.swing.plaf.synth.SynthListUI
Sets the list properties that have not been explicitly overridden to null.
uninstallDefaults() - Method in class javax.swing.plaf.synth.SynthMenuBarUI
uninstallDefaults() - Method in class javax.swing.plaf.synth.SynthMenuItemUI
uninstallDefaults() - Method in class javax.swing.plaf.synth.SynthMenuUI
uninstallDefaults() - Method in class javax.swing.plaf.synth.SynthOptionPaneUI
uninstallDefaults(JPanel) - Method in class javax.swing.plaf.synth.SynthPanelUI
uninstallDefaults() - Method in class javax.swing.plaf.synth.SynthPopupMenuUI
uninstallDefaults() - Method in class javax.swing.plaf.synth.SynthProgressBarUI
uninstallDefaults(JRootPane) - Method in class javax.swing.plaf.synth.SynthRootPaneUI
uninstallDefaults() - Method in class javax.swing.plaf.synth.SynthScrollBarUI
uninstallDefaults(JScrollPane) - Method in class javax.swing.plaf.synth.SynthScrollPaneUI
uninstallDefaults(JSeparator) - Method in class javax.swing.plaf.synth.SynthSeparatorUI
Uninstalls default setting.
uninstallDefaults(JSlider) - Method in class javax.swing.plaf.synth.SynthSliderUI
Uninstalls default setting.
uninstallDefaults() - Method in class javax.swing.plaf.synth.SynthSpinnerUI
Sets the JSpinner's layout manager to null.
uninstallDefaults() - Method in class javax.swing.plaf.synth.SynthSplitPaneUI
Uninstalls the UI defaults.
uninstallDefaults(SynthContext) - Method in class javax.swing.plaf.synth.SynthStyle
Uninstalls any state that this style installed on the JComponent from context.
uninstallDefaults() - Method in class javax.swing.plaf.synth.SynthTabbedPaneUI
uninstallDefaults() - Method in class javax.swing.plaf.synth.SynthTableHeaderUI
uninstallDefaults() - Method in class javax.swing.plaf.synth.SynthTableUI
uninstallDefaults() - Method in class javax.swing.plaf.synth.SynthTextAreaUI
Sets the component properties that have not been explicitly overridden to null.
uninstallDefaults() - Method in class javax.swing.plaf.synth.SynthTextFieldUI
Sets the component properties that have not been explicitly overridden to null.
uninstallDefaults() - Method in class javax.swing.plaf.synth.SynthToolBarUI
uninstallDefaults(JComponent) - Method in class javax.swing.plaf.synth.SynthToolTipUI
uninstallDefaults() - Method in class javax.swing.plaf.synth.SynthTreeUI
uninstallDefaults(JComponent) - Method in class javax.swing.plaf.synth.SynthViewportUI
Uninstalls defaults from a viewport.
uninstallDesktopManager() - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI
uninstallDesktopManager() - Method in class javax.swing.plaf.synth.SynthDesktopPaneUI
uninstallIcons(JFileChooser) - Method in class javax.swing.plaf.basic.BasicFileChooserUI
uninstallingUI() - Method in class javax.swing.plaf.basic.BasicComboPopup
Called when the UI is uninstalling.
uninstallingUI() - Method in interface javax.swing.plaf.basic.ComboPopup
Called to inform the ComboPopup that the UI is uninstalling.
uninstallKeyboardActions(JComponent) - Method in class javax.swing.plaf.basic.BasicButtonListener
Unregister's default key actions
uninstallKeyboardActions(AbstractButton) - Method in class javax.swing.plaf.basic.BasicButtonUI
uninstallKeyboardActions() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Removes the focus InputMap and ActionMap.
uninstallKeyboardActions() - Method in class javax.swing.plaf.basic.BasicComboPopup
uninstallKeyboardActions() - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI
uninstallKeyboardActions() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
uninstallKeyboardActions(JLabel) - Method in class javax.swing.plaf.basic.BasicLabelUI
uninstallKeyboardActions() - Method in class javax.swing.plaf.basic.BasicListUI
Unregisters keyboard actions installed from installKeyboardActions.
uninstallKeyboardActions() - Method in class javax.swing.plaf.basic.BasicMenuBarUI
uninstallKeyboardActions() - Method in class javax.swing.plaf.basic.BasicMenuItemUI
uninstallKeyboardActions() - Method in class javax.swing.plaf.basic.BasicMenuUI
uninstallKeyboardActions() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI
uninstallKeyboardActions() - Method in class javax.swing.plaf.basic.BasicPopupMenuUI
uninstallKeyboardActions(JRootPane) - Method in class javax.swing.plaf.basic.BasicRootPaneUI
uninstallKeyboardActions() - Method in class javax.swing.plaf.basic.BasicScrollBarUI
uninstallKeyboardActions(JScrollPane) - Method in class javax.swing.plaf.basic.BasicScrollPaneUI
uninstallKeyboardActions(JSlider) - Method in class javax.swing.plaf.basic.BasicSliderUI
uninstallKeyboardActions() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Uninstalls the keyboard actions for the UI.
uninstallKeyboardActions() - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
uninstallKeyboardActions() - Method in class javax.swing.plaf.basic.BasicTableHeaderUI
Unregisters default key actions.
uninstallKeyboardActions() - Method in class javax.swing.plaf.basic.BasicTableUI
uninstallKeyboardActions() - Method in class javax.swing.plaf.basic.BasicTextUI
uninstallKeyboardActions() - Method in class javax.swing.plaf.basic.BasicToolBarUI
uninstallKeyboardActions() - Method in class javax.swing.plaf.basic.BasicTreeUI
uninstallKeyboardActions() - Method in class javax.swing.plaf.metal.MetalInternalFrameUI
uninstallListeners(AbstractButton) - Method in class javax.swing.plaf.basic.BasicButtonUI
uninstallListeners() - Method in class javax.swing.plaf.basic.BasicColorChooserUI
uninstallListeners() - Method in class javax.swing.plaf.basic.BasicComboBoxUI
Removes the installed listeners from the combo box and its model.
uninstallListeners() - Method in class javax.swing.plaf.basic.BasicDesktopIconUI
uninstallListeners() - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI
Uninstalls the PropertyChangeListener returned from createPropertyChangeListener from the JDesktopPane.
uninstallListeners(JFileChooser) - Method in class javax.swing.plaf.basic.BasicFileChooserUI
uninstallListeners() - Method in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
uninstallListeners() - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
uninstallListeners(JLabel) - Method in class javax.swing.plaf.basic.BasicLabelUI
uninstallListeners() - Method in class javax.swing.plaf.basic.BasicListUI
Removes the listeners from the JList, its model, and its selectionModel.
uninstallListeners() - Method in class javax.swing.plaf.basic.BasicMenuBarUI
uninstallListeners() - Method in class javax.swing.plaf.basic.BasicMenuItemUI
uninstallListeners() - Method in class javax.swing.plaf.basic.BasicMenuUI
uninstallListeners() - Method in class javax.swing.plaf.basic.BasicOptionPaneUI
uninstallListeners() - Method in class javax.swing.plaf.basic.BasicPopupMenuUI
uninstallListeners() - Method in class javax.swing.plaf.basic.BasicProgressBarUI
Removes all listeners installed by this object.
uninstallListeners(JRootPane) - Method in class javax.swing.plaf.basic.BasicRootPaneUI
uninstallListeners() - Method in class javax.swing.plaf.basic.BasicScrollBarUI
uninstallListeners(JComponent) - Method in class javax.swing.plaf.basic.BasicScrollPaneUI
uninstallListeners(JSeparator) - Method in class javax.swing.plaf.basic.BasicSeparatorUI
uninstallListeners(JSlider) - Method in class javax.swing.plaf.basic.BasicSliderUI
uninstallListeners() - Method in class javax.swing.plaf.basic.BasicSpinnerUI
Removes the PropertyChangeListener added by installListeners.
uninstallListeners() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Uninstalls the event listeners for the UI.
uninstallListeners() - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
uninstallListeners() - Method in class javax.swing.plaf.basic.BasicTableHeaderUI
uninstallListeners() - Method in class javax.swing.plaf.basic.BasicTableUI
uninstallListeners() - Method in class javax.swing.plaf.basic.BasicTextUI
Uninstalls listeners for the UI.
uninstallListeners() - Method in class javax.swing.plaf.basic.BasicToolBarUI
uninstallListeners(JComponent) - Method in class javax.swing.plaf.basic.BasicToolTipUI
uninstallListeners() - Method in class javax.swing.plaf.basic.BasicTreeUI
uninstallListeners() - Method in class javax.swing.plaf.metal.MetalDesktopIconUI
uninstallListeners() - Method in class javax.swing.plaf.metal.MetalInternalFrameUI
uninstallListeners(JComponent) - Method in class javax.swing.plaf.metal.MetalScrollPaneUI
uninstallListeners(JScrollPane) - Method in class javax.swing.plaf.metal.MetalScrollPaneUI
Deprecated.
- Replaced by MetalScrollPaneUI.uninstallListeners(JComponent)
uninstallListeners() - Method in class javax.swing.plaf.metal.MetalToolBarUI
uninstallListeners(AbstractButton) - Method in class javax.swing.plaf.synth.SynthButtonUI
uninstallListeners() - Method in class javax.swing.plaf.synth.SynthColorChooserUI
uninstallListeners() - Method in class javax.swing.plaf.synth.SynthComboBoxUI
Removes the installed listeners from the combo box and its model.
uninstallListeners() - Method in class javax.swing.plaf.synth.SynthDesktopIconUI
uninstallListeners() - Method in class javax.swing.plaf.synth.SynthDesktopPaneUI
Uninstalls the PropertyChangeListener returned from createPropertyChangeListener from the JDesktopPane.
uninstallListeners() - Method in class javax.swing.plaf.synth.SynthInternalFrameUI
uninstallListeners() - Method in class javax.swing.plaf.synth.SynthListUI
Removes the listeners from the JList, its model, and its selectionModel.
uninstallListeners() - Method in class javax.swing.plaf.synth.SynthMenuBarUI
uninstallListeners() - Method in class javax.swing.plaf.synth.SynthMenuItemUI
uninstallListeners() - Method in class javax.swing.plaf.synth.SynthMenuUI
uninstallListeners() - Method in class javax.swing.plaf.synth.SynthOptionPaneUI
uninstallListeners(JPanel) - Method in class javax.swing.plaf.synth.SynthPanelUI
Uninstalls listeners from the panel.
uninstallListeners() - Method in class javax.swing.plaf.synth.SynthPopupMenuUI
uninstallListeners() - Method in class javax.swing.plaf.synth.SynthProgressBarUI
Removes all listeners installed by this object.
uninstallListeners() - Method in class javax.swing.plaf.synth.SynthScrollBarUI
uninstallListeners(JComponent) - Method in class javax.swing.plaf.synth.SynthScrollPaneUI
uninstallListeners(JSeparator) - Method in class javax.swing.plaf.synth.SynthSeparatorUI
Uninstalls listeners.
uninstallListeners(JSlider) - Method in class javax.swing.plaf.synth.SynthSliderUI
uninstallListeners() - Method in class javax.swing.plaf.synth.SynthSpinnerUI
Removes the PropertyChangeListener added by installListeners.
uninstallListeners() - Method in class javax.swing.plaf.synth.SynthSplitPaneUI
Uninstalls the event listeners from the UI.
uninstallListeners() - Method in class javax.swing.plaf.synth.SynthTabbedPaneUI
uninstallListeners() - Method in class javax.swing.plaf.synth.SynthTableHeaderUI
uninstallListeners() - Method in class javax.swing.plaf.synth.SynthTableUI
uninstallListeners() - Method in class javax.swing.plaf.synth.SynthToolBarUI
uninstallListeners(JComponent) - Method in class javax.swing.plaf.synth.SynthToolTipUI
uninstallListeners() - Method in class javax.swing.plaf.synth.SynthTreeUI
uninstallListeners(JComponent) - Method in class javax.swing.plaf.synth.SynthViewportUI
Uninstalls listeners from the viewport.
uninstallPreviewPanel() - Method in class javax.swing.plaf.basic.BasicColorChooserUI
Removes installed preview panel from the UI delegate.
uninstallStrings(JFileChooser) - Method in class javax.swing.plaf.basic.BasicFileChooserUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic.BasicButtonUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic.BasicColorChooserUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic.BasicComboBoxUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic.BasicDesktopIconUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic.BasicEditorPaneUI
Deinstalls the UI for a component.
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic.BasicFileChooserUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic.BasicInternalFrameUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic.BasicLabelUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic.BasicListUI
Uninitializes this.list by calling uninstallListeners(), uninstallKeyboardActions(), and uninstallDefaults() in order.
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic.BasicMenuBarUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic.BasicMenuItemUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic.BasicOptionPaneUI
Removes the receiver from the L&F controller of the passed in split pane.
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic.BasicPanelUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic.BasicPopupMenuUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic.BasicProgressBarUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic.BasicRootPaneUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic.BasicScrollBarUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic.BasicScrollPaneUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic.BasicSeparatorUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic.BasicSliderUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic.BasicSpinnerUI
Calls uninstallDefaults, uninstallListeners, and then removes all of the spinners children.
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic.BasicSplitPaneUI
Uninstalls the UI.
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic.BasicTabbedPaneUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic.BasicTableHeaderUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic.BasicTableUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic.BasicTextUI
Deinstalls the UI for a component.
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic.BasicToolBarUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic.BasicToolTipUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic.BasicTreeUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.basic.BasicViewportUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.ComponentUI
Reverses configuration which was done on the specified component during installUI.
uninstallUI(JComponent) - Method in class javax.swing.plaf.LayerUI
Reverses the configuration which was previously set in the LayerUI.installUI(JComponent) method.
uninstallUI(JComponent) - Method in class javax.swing.plaf.metal.MetalFileChooserUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.metal.MetalInternalFrameUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.metal.MetalMenuBarUI
Reverses configuration which was done on the specified component during installUI.
uninstallUI(JComponent) - Method in class javax.swing.plaf.metal.MetalRootPaneUI
Invokes supers implementation to uninstall any of its state.
uninstallUI(JComponent) - Method in class javax.swing.plaf.metal.MetalScrollPaneUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.metal.MetalToolBarUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.metal.MetalToolTipUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.metal.MetalTreeUI
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi.MultiButtonUI
Invokes the uninstallUI method on each UI handled by this object.
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi.MultiColorChooserUI
Invokes the uninstallUI method on each UI handled by this object.
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi.MultiComboBoxUI
Invokes the uninstallUI method on each UI handled by this object.
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi.MultiDesktopIconUI
Invokes the uninstallUI method on each UI handled by this object.
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi.MultiDesktopPaneUI
Invokes the uninstallUI method on each UI handled by this object.
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi.MultiFileChooserUI
Invokes the uninstallUI method on each UI handled by this object.
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi.MultiInternalFrameUI
Invokes the uninstallUI method on each UI handled by this object.
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi.MultiLabelUI
Invokes the uninstallUI method on each UI handled by this object.
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi.MultiListUI
Invokes the uninstallUI method on each UI handled by this object.
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi.MultiMenuBarUI
Invokes the uninstallUI method on each UI handled by this object.
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi.MultiMenuItemUI
Invokes the uninstallUI method on each UI handled by this object.
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi.MultiOptionPaneUI
Invokes the uninstallUI method on each UI handled by this object.
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi.MultiPanelUI
Invokes the uninstallUI method on each UI handled by this object.
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi.MultiPopupMenuUI
Invokes the uninstallUI method on each UI handled by this object.
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi.MultiProgressBarUI
Invokes the uninstallUI method on each UI handled by this object.
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi.MultiRootPaneUI
Invokes the uninstallUI method on each UI handled by this object.
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi.MultiScrollBarUI
Invokes the uninstallUI method on each UI handled by this object.
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi.MultiScrollPaneUI
Invokes the uninstallUI method on each UI handled by this object.
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi.MultiSeparatorUI
Invokes the uninstallUI method on each UI handled by this object.
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi.MultiSliderUI
Invokes the uninstallUI method on each UI handled by this object.
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi.MultiSpinnerUI
Invokes the uninstallUI method on each UI handled by this object.
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi.MultiSplitPaneUI
Invokes the uninstallUI method on each UI handled by this object.
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi.MultiTabbedPaneUI
Invokes the uninstallUI method on each UI handled by this object.
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi.MultiTableHeaderUI
Invokes the uninstallUI method on each UI handled by this object.
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi.MultiTableUI
Invokes the uninstallUI method on each UI handled by this object.
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi.MultiTextUI
Invokes the uninstallUI method on each UI handled by this object.
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi.MultiToolBarUI
Invokes the uninstallUI method on each UI handled by this object.
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi.MultiToolTipUI
Invokes the uninstallUI method on each UI handled by this object.
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi.MultiTreeUI
Invokes the uninstallUI method on each UI handled by this object.
uninstallUI(JComponent) - Method in class javax.swing.plaf.multi.MultiViewportUI
Invokes the uninstallUI method on each UI handled by this object.
uninstallUI(JComponent) - Method in class javax.swing.plaf.synth.SynthComboBoxUI
Reverses configuration which was done on the specified component during installUI.
uninstallUI(JComponent) - Method in class javax.swing.plaf.synth.SynthMenuItemUI
Reverses configuration which was done on the specified component during installUI.
uninstallUI(JComponent) - Method in class javax.swing.plaf.synth.SynthMenuUI
Reverses configuration which was done on the specified component during installUI.
uninstallUI(JComponent) - Method in class javax.swing.plaf.synth.SynthPanelUI
Reverses configuration which was done on the specified component during installUI.
uninstallUI(JComponent) - Method in class javax.swing.plaf.synth.SynthSeparatorUI
Reverses configuration which was done on the specified component during installUI.
uninstallUI(JComponent) - Method in class javax.swing.plaf.synth.SynthViewportUI
Reverses configuration which was done on the specified component during installUI.
union(Rectangle2D, Rectangle2D, Rectangle2D) - Static method in class java.awt.geom.Rectangle2D
Unions the pair of source Rectangle2D objects and puts the result into the specified destination Rectangle2D object.
union(Rectangle) - Method in class java.awt.Rectangle
Computes the union of this Rectangle with the specified Rectangle.
union(Descriptor...) - Static method in class javax.management.ImmutableDescriptor
Return an ImmutableDescriptor whose contents are the union of the given descriptors.
UNION - Static variable in class javax.xml.crypto.dsig.spec.XPathType.Filter
The union filter operation.
UnionMember - Class in org.omg.CORBA
A description in the Interface Repository of a member of an IDL union.
UnionMember() - Constructor for class org.omg.CORBA.UnionMember
Constructs a new UnionMember object with its fields initialized to null.
UnionMember(String, Any, TypeCode, IDLType) - Constructor for class org.omg.CORBA.UnionMember
Constructs a new UnionMember object with its fields initialized to the given values.
UnionMemberHelper - Class in org.omg.CORBA
The Helper for UnionMember.
UnionMemberHelper() - Constructor for class org.omg.CORBA.UnionMemberHelper
UnionType - Interface in javax.lang.model.type
Represents a union type.
UNIQUE_ID - Static variable in class org.omg.PortableServer.IdUniquenessPolicyValue
UNIT_DECREMENT - Static variable in class java.awt.event.AdjustmentEvent
The unit decrement adjustment type.
UNIT_INCREMENT - Static variable in class java.awt.event.AdjustmentEvent
The unit increment adjustment type.
unitIncrement - Variable in class javax.swing.JScrollBar
UNIX_LINES - Static variable in class java.util.regex.Pattern
Enables Unix lines mode.
UNKNOWN - Static variable in class java.awt.ComponentOrientation
Indicates that a component's orientation has not been set.
UNKNOWN - Static variable in class javax.accessibility.AccessibleRole
The object contains some Accessible information, but its role is not known.
UNKNOWN - Static variable in class javax.management.MBeanOperationInfo
Indicates that the impact of the operation is unknown or cannot be expressed using one of the other values.
UNKNOWN - Static variable in class javax.print.attribute.standard.JobState
The job state is unknown.
UNKNOWN - Static variable in class javax.print.attribute.standard.PrinterState
The printer state is unknown.
UNKNOWN - Exception in org.omg.CORBA
This exception is raised if an operation implementation throws a non-CORBA exception (such as an exception specific to the implementation's programming language), or if an operation raises a user exception that does not appear in the operation's raises expression.
UNKNOWN() - Constructor for exception org.omg.CORBA.UNKNOWN
Constructs an UNKNOWN exception with a default minor code of 0, a completion state of CompletionStatus.COMPLETED_NO, and a null description.
UNKNOWN(String) - Constructor for exception org.omg.CORBA.UNKNOWN
Constructs an UNKNOWN exception with the specified description message, a minor code of 0, and a completion state of COMPLETED_NO.
UNKNOWN(int, CompletionStatus) - Constructor for exception org.omg.CORBA.UNKNOWN
Constructs an UNKNOWN exception with the specified minor code and completion status.
UNKNOWN(String, int, CompletionStatus) - Constructor for exception org.omg.CORBA.UNKNOWN
Constructs an UNKNOWN exception with the specified description message, minor code, and completion status.
UNKNOWN - Interface in org.omg.PortableInterceptor
org/omg/PortableInterceptor/UNKNOWN.java .
unknown_adapter(POA, String) - Method in interface org.omg.PortableServer.AdapterActivatorOperations
This operation is invoked when the ORB receives a request for an object reference that identifies a target POA that does not exist.
UNKNOWN_ATTRIBUTE - Static variable in interface java.util.jar.Pack200.Packer
Indicates the action to take when a class-file containing an unknown attribute is encountered.
UNKNOWN_LENGTH - Static variable in class javax.sound.midi.MidiFileFormat
Represents unknown length.
UNKNOWN_NUMBER_OF_PAGES - Static variable in interface java.awt.print.Pageable
This constant is returned from the getNumberOfPages method if a Pageable implementation does not know the number of pages in its set.
UnknownAnnotationValueException - Exception in javax.lang.model.element
Indicates that an unknown kind of annotation value was encountered.
UnknownAnnotationValueException(AnnotationValue, Object) - Constructor for exception javax.lang.model.element.UnknownAnnotationValueException
Creates a new UnknownAnnotationValueException.
UnknownElementException - Exception in javax.lang.model.element
Indicates that an unknown kind of element was encountered.
UnknownElementException(Element, Object) - Constructor for exception javax.lang.model.element.UnknownElementException
Creates a new UnknownElementException.
UnknownEncoding - Exception in org.omg.IOP.CodecFactoryPackage
org/omg/IOP/CodecFactoryPackage/UnknownEncoding.java .
UnknownEncoding() - Constructor for exception org.omg.IOP.CodecFactoryPackage.UnknownEncoding
UnknownEncoding(String) - Constructor for exception org.omg.IOP.CodecFactoryPackage.UnknownEncoding
UnknownEncodingHelper - Class in org.omg.IOP.CodecFactoryPackage
org/omg/IOP/CodecFactoryPackage/UnknownEncodingHelper.java .
UnknownEncodingHelper() - Constructor for class org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper
UnknownEntityException - Exception in javax.lang.model
Superclass of exceptions which indicate that an unknown kind of entity was encountered.
UnknownEntityException(String) - Constructor for exception javax.lang.model.UnknownEntityException
Creates a new UnknownEntityException with the specified detail message.
UnknownError - Error in java.lang
Thrown when an unknown but serious exception has occurred in the Java Virtual Machine.
UnknownError() - Constructor for error java.lang.UnknownError
Constructs an UnknownError with no detail message.
UnknownError(String) - Constructor for error java.lang.UnknownError
Constructs an UnknownError with the specified detail message.
UnknownException - Exception in org.omg.CORBA.portable
The org.omg.CORBA.portable.UnknownException is used for reporting unknown exceptions between ties and ORBs and between ORBs and stubs.
UnknownException(Throwable) - Constructor for exception org.omg.CORBA.portable.UnknownException
Constructs an UnknownException object.
UnknownFormatConversionException - Exception in java.util
Unchecked exception thrown when an unknown conversion is given.
UnknownFormatConversionException(String) - Constructor for exception java.util.UnknownFormatConversionException
Constructs an instance of this class with the unknown conversion.
UnknownFormatFlagsException - Exception in java.util
Unchecked exception thrown when an unknown flag is given.
UnknownFormatFlagsException(String) - Constructor for exception java.util.UnknownFormatFlagsException
Constructs an instance of this class with the specified flags.
UnknownGroupException - Exception in java.rmi.activation
An UnknownGroupException is thrown by methods of classes and interfaces in the java.rmi.activation package when the ActivationGroupID parameter to the method is determined to be invalid, i.e., not known by the ActivationSystem.
UnknownGroupException(String) - Constructor for exception java.rmi.activation.UnknownGroupException
Constructs an UnknownGroupException with the specified detail message.
UnknownHostException - Exception in java.net
Thrown to indicate that the IP address of a host could not be determined.
UnknownHostException(String) - Constructor for exception java.net.UnknownHostException
Constructs a new UnknownHostException with the specified detail message.
UnknownHostException() - Constructor for exception java.net.UnknownHostException
Constructs a new UnknownHostException with no detail message.
UnknownHostException - Exception in java.rmi
An UnknownHostException is thrown if a java.net.UnknownHostException occurs while creating a connection to the remote host for a remote method call.
UnknownHostException(String) - Constructor for exception java.rmi.UnknownHostException
Constructs an UnknownHostException with the specified detail message.
UnknownHostException(String, Exception) - Constructor for exception java.rmi.UnknownHostException
Constructs an UnknownHostException with the specified detail message and nested exception.
UnknownObjectException - Exception in java.rmi.activation
An UnknownObjectException is thrown by methods of classes and interfaces in the java.rmi.activation package when the ActivationID parameter to the method is determined to be invalid.
UnknownObjectException(String) - Constructor for exception java.rmi.activation.UnknownObjectException
Constructs an UnknownObjectException with the specified detail message.
UnknownServiceException - Exception in java.net
Thrown to indicate that an unknown service exception has occurred.
UnknownServiceException() - Constructor for exception java.net.UnknownServiceException
Constructs a new UnknownServiceException with no detail message.
UnknownServiceException(String) - Constructor for exception java.net.UnknownServiceException
Constructs a new UnknownServiceException with the specified detail message.
UnknownTag(String) - Constructor for class javax.swing.text.html.HTML.UnknownTag
Creates a new UnknownTag with the specified id.
UnknownTypeException - Exception in javax.lang.model.type
Indicates that an unknown kind of type was encountered.
UnknownTypeException(TypeMirror, Object) - Constructor for exception javax.lang.model.type.UnknownTypeException
Creates a new UnknownTypeException.The p parameter may be used to pass in an additional argument with information about the context in which the unknown type was encountered; for example, the visit methods of TypeVisitor may pass in their additional parameter.
UnknownUserException - Exception in org.omg.CORBA
A class that contains user exceptions returned by the server.
UnknownUserException() - Constructor for exception org.omg.CORBA.UnknownUserException
Constructs an UnknownUserException object.
UnknownUserException(Any) - Constructor for exception org.omg.CORBA.UnknownUserException
Constructs an UnknownUserException object that contains the given Any object.
UnknownUserExceptionHelper - Class in org.omg.CORBA
The Helper for UnknownUserException.
UnknownUserExceptionHelper() - Constructor for class org.omg.CORBA.UnknownUserExceptionHelper
UnknownUserExceptionHolder - Class in org.omg.CORBA
The Holder for UnknownUserException.
UnknownUserExceptionHolder() - Constructor for class org.omg.CORBA.UnknownUserExceptionHolder
UnknownUserExceptionHolder(UnknownUserException) - Constructor for class org.omg.CORBA.UnknownUserExceptionHolder
UNLIMITED - Static variable in class java.math.MathContext
A MathContext object whose settings have the values required for unlimited precision arithmetic.
unloadAllInstruments(Soundbank) - Method in interface javax.sound.midi.Synthesizer
Unloads all instruments contained in the specified Soundbank.
unloadInstrument(Instrument) - Method in interface javax.sound.midi.Synthesizer
Unloads a particular instrument.
unloadInstruments(Soundbank, Patch[]) - Method in interface javax.sound.midi.Synthesizer
Unloads the instruments referenced by the specified patches, from the MIDI sound bank specified.
unloadZone(View) - Method in class javax.swing.text.ZoneView
Unload a zone (Convert the zone to its memory saving state).
unlock() - Method in interface java.util.concurrent.locks.Lock
Releases the lock.
unlock() - Method in class java.util.concurrent.locks.ReentrantLock
Attempts to release this lock.
unlock() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock
Attempts to release this lock.
unlock() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock
Attempts to release this lock.
unlock(long) - Method in class java.util.concurrent.locks.StampedLock
If the lock state matches the given stamp, releases the corresponding mode of the lock.
unlockRead(long) - Method in class java.util.concurrent.locks.StampedLock
If the lock state matches the given stamp, releases the non-exclusive lock.
unlockWrite(long) - Method in class java.util.concurrent.locks.StampedLock
If the lock state matches the given stamp, releases the exclusive lock.
unmappableCharacterAction() - Method in class java.nio.charset.CharsetDecoder
Returns this decoder's current action for unmappable-character errors.
unmappableCharacterAction() - Method in class java.nio.charset.CharsetEncoder
Returns this encoder's current action for unmappable-character errors.
UnmappableCharacterException - Exception in java.nio.charset
Checked exception thrown when an input character (or byte) sequence is valid but cannot be mapped to an output byte (or character) sequence.
UnmappableCharacterException(int) - Constructor for exception java.nio.charset.UnmappableCharacterException
Constructs an UnmappableCharacterException with the given length.
unmappableForLength(int) - Static method in class java.nio.charset.CoderResult
Static factory method that returns the unique result object describing an unmappable-character error of the given length.
unmarshal(String) - Method in class javax.xml.bind.annotation.adapters.CollapsedStringAdapter
Removes leading and trailing whitespaces of the string given as the parameter, then truncate any sequnce of tab, CR, LF, and SP by a single whitespace character ' '.
unmarshal(String) - Method in class javax.xml.bind.annotation.adapters.HexBinaryAdapter
unmarshal(String) - Method in class javax.xml.bind.annotation.adapters.NormalizedStringAdapter
Replace any tab, CR, and LF by a whitespace character ' ', as specified in the whitespace facet 'replace'
unmarshal(ValueType) - Method in class javax.xml.bind.annotation.adapters.XmlAdapter
Convert a value type to a bound type.
unmarshal(XmlNode) - Method in class javax.xml.bind.Binder
Unmarshal XML infoset view to a JAXB object tree.
unmarshal(XmlNode, Class<T>) - Method in class javax.xml.bind.Binder
Unmarshal XML root element by provided declaredType to a JAXB object tree.
unmarshal(Source) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl
unmarshal(XMLReader, InputSource) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl
Unmarshals an object by using the specified XMLReader and the InputSource.
unmarshal(InputSource) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl
unmarshal(URL) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl
unmarshal(File) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl
unmarshal(InputStream) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl
unmarshal(Reader) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl
unmarshal(XMLEventReader) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl
unmarshal(XMLStreamReader) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl
unmarshal(Node, Class<T>) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl
unmarshal(Source, Class<T>) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl
unmarshal(XMLStreamReader, Class<T>) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl
unmarshal(XMLEventReader, Class<T>) - Method in class javax.xml.bind.helpers.AbstractUnmarshallerImpl
unmarshal(File, Class<T>) - Static method in class javax.xml.bind.JAXB
Reads in a Java object tree from the given XML input.
unmarshal(URL, Class<T>) - Static method in class javax.xml.bind.JAXB
Reads in a Java object tree from the given XML input.
unmarshal(URI, Class<T>) - Static method in class javax.xml.bind.JAXB
Reads in a Java object tree from the given XML input.
unmarshal(String, Class<T>) - Static method in class javax.xml.bind.JAXB
Reads in a Java object tree from the given XML input.
unmarshal(InputStream, Class<T>) - Static method in class javax.xml.bind.JAXB
Reads in a Java object tree from the given XML input.
unmarshal(Reader, Class<T>) - Static method in class javax.xml.bind.JAXB
Reads in a Java object tree from the given XML input.
unmarshal(Source, Class<T>) - Static method in class javax.xml.bind.JAXB
Reads in a Java object tree from the given XML input.
unmarshal(File) - Method in interface javax.xml.bind.Unmarshaller
Unmarshal XML data from the specified file and return the resulting content tree.
unmarshal(InputStream) - Method in interface javax.xml.bind.Unmarshaller
Unmarshal XML data from the specified InputStream and return the resulting content tree.
unmarshal(Reader) - Method in interface javax.xml.bind.Unmarshaller
Unmarshal XML data from the specified Reader and return the resulting content tree.
unmarshal(URL) - Method in interface javax.xml.bind.Unmarshaller
Unmarshal XML data from the specified URL and return the resulting content tree.
unmarshal(InputSource) - Method in interface javax.xml.bind.Unmarshaller
Unmarshal XML data from the specified SAX InputSource and return the resulting content tree.
unmarshal(Node) - Method in interface javax.xml.bind.Unmarshaller
Unmarshal global XML data from the specified DOM tree and return the resulting content tree.
unmarshal(Node, Class<T>) - Method in interface javax.xml.bind.Unmarshaller
Unmarshal XML data by JAXB mapped declaredType and return the resulting content tree.
unmarshal(Source) - Method in interface javax.xml.bind.Unmarshaller
Unmarshal XML data from the specified XML Source and return the resulting content tree.
unmarshal(Source, Class<T>) - Method in interface javax.xml.bind.Unmarshaller
Unmarshal XML data from the specified XML Source by declaredType and return the resulting content tree.
unmarshal(XMLStreamReader) - Method in interface javax.xml.bind.Unmarshaller
Unmarshal XML data from the specified pull parser and return the resulting content tree.
unmarshal(XMLStreamReader, Class<T>) - Method in interface javax.xml.bind.Unmarshaller
Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.
unmarshal(XMLEventReader) - Method in interface javax.xml.bind.Unmarshaller
Unmarshal XML data from the specified pull parser and return the resulting content tree.
unmarshal(XMLEventReader, Class<T>) - Method in interface javax.xml.bind.Unmarshaller
Unmarshal root element to JAXB mapped declaredType and return the resulting content tree.
unmarshal(DataInputStream) - Method in interface org.omg.CORBA.CustomMarshal
Unmarshal method has to be implemented by the Customized Marshal class.
UnmarshalException - Exception in java.rmi
An UnmarshalException can be thrown while unmarshalling the parameters or results of a remote method call if any of the following conditions occur: if an exception occurs while unmarshalling the call header if the protocol for the return value is invalid if a java.io.IOException occurs unmarshalling parameters (on the server side) or the return value (on the client side).
UnmarshalException(String) - Constructor for exception java.rmi.UnmarshalException
Constructs an UnmarshalException with the specified detail message.
UnmarshalException(String, Exception) - Constructor for exception java.rmi.UnmarshalException
Constructs an UnmarshalException with the specified detail message and nested exception.
UnmarshalException - Exception in javax.xml.bind
This exception indicates that an error has occurred while performing an unmarshal operation that prevents the JAXB Provider from completing the operation.
UnmarshalException(String) - Constructor for exception javax.xml.bind.UnmarshalException
Construct an UnmarshalException with the specified detail message.
UnmarshalException(String, String) - Constructor for exception javax.xml.bind.UnmarshalException
Construct an UnmarshalException with the specified detail message and vendor specific errorCode.
UnmarshalException(Throwable) - Constructor for exception javax.xml.bind.UnmarshalException
Construct an UnmarshalException with a linkedException.
UnmarshalException(String, Throwable) - Constructor for exception javax.xml.bind.UnmarshalException
Construct an UnmarshalException with the specified detail message and linkedException.
UnmarshalException(String, String, Throwable) - Constructor for exception javax.xml.bind.UnmarshalException
Construct an UnmarshalException with the specified detail message, vendor specific errorCode, and linkedException.
unmarshalKeyInfo(XMLStructure) - Method in class javax.xml.crypto.dsig.keyinfo.KeyInfoFactory
Unmarshals a new KeyInfo instance from a mechanism-specific XMLStructure (ex: DOMStructure) instance.
Unmarshaller - Interface in javax.xml.bind
The Unmarshaller class governs the process of deserializing XML data into newly created Java content trees, optionally validating the XML data as it is unmarshalled.
Unmarshaller.Listener - Class in javax.xml.bind

Register an instance of an implementation of this class with Unmarshaller to externally listen for unmarshal events.

UnmarshallerHandler - Interface in javax.xml.bind
Unmarshaller implemented as SAX ContentHandler.
unmarshalXMLSignature(XMLValidateContext) - Method in class javax.xml.crypto.dsig.XMLSignatureFactory
Unmarshals a new XMLSignature instance from a mechanism-specific XMLValidateContext instance.
unmarshalXMLSignature(XMLStructure) - Method in class javax.xml.crypto.dsig.XMLSignatureFactory
Unmarshals a new XMLSignature instance from a mechanism-specific XMLStructure instance.
UnmodifiableClassException - Exception in java.lang.instrument
Thrown by an implementation of Instrumentation.redefineClasses when one of the specified classes cannot be modified.
UnmodifiableClassException() - Constructor for exception java.lang.instrument.UnmodifiableClassException
Constructs an UnmodifiableClassException with no detail message.
UnmodifiableClassException(String) - Constructor for exception java.lang.instrument.UnmodifiableClassException
Constructs an UnmodifiableClassException with the specified detail message.
unmodifiableCollection(Collection<? extends T>) - Static method in class java.util.Collections
Returns an unmodifiable view of the specified collection.
unmodifiableList(List<? extends T>) - Static method in class java.util.Collections
Returns an unmodifiable view of the specified list.
unmodifiableMap(Map<? extends K, ? extends V>) - Static method in class java.util.Collections
Returns an unmodifiable view of the specified map.
unmodifiableNavigableMap(NavigableMap<K, ? extends V>) - Static method in class java.util.Collections
Returns an unmodifiable view of the specified navigable map.
unmodifiableNavigableSet(NavigableSet<T>) - Static method in class java.util.Collections
Returns an unmodifiable view of the specified navigable set.
unmodifiableSet(Set<? extends T>) - Static method in class java.util.Collections
Returns an unmodifiable view of the specified set.
UnmodifiableSetException - Exception in javax.print.attribute
Thrown to indicate that the requested operation cannot be performed because the set is unmodifiable.
UnmodifiableSetException() - Constructor for exception javax.print.attribute.UnmodifiableSetException
Constructs an UnsupportedOperationException with no detail message.
UnmodifiableSetException(String) - Constructor for exception javax.print.attribute.UnmodifiableSetException
Constructs an UnmodifiableSetException with the specified detail message.
unmodifiableSortedMap(SortedMap<K, ? extends V>) - Static method in class java.util.Collections
Returns an unmodifiable view of the specified sorted map.
unmodifiableSortedSet(SortedSet<T>) - Static method in class java.util.Collections
Returns an unmodifiable view of the specified sorted set.
unmodifiableView(AttributeSet) - Static method in class javax.print.attribute.AttributeSetUtilities
Creates an unmodifiable view of the given attribute set.
unmodifiableView(DocAttributeSet) - Static method in class javax.print.attribute.AttributeSetUtilities
Creates an unmodifiable view of the given doc attribute set.
unmodifiableView(PrintRequestAttributeSet) - Static method in class javax.print.attribute.AttributeSetUtilities
Creates an unmodifiable view of the given print request attribute set.
unmodifiableView(PrintJobAttributeSet) - Static method in class javax.print.attribute.AttributeSetUtilities
Creates an unmodifiable view of the given print job attribute set.
unmodifiableView(PrintServiceAttributeSet) - Static method in class javax.print.attribute.AttributeSetUtilities
Creates an unmodifiable view of the given print service attribute set.
UNNECESSARY - Static variable in class java.awt.GraphicsConfigTemplate
Value used for "Enum" (Integer) type.
unordered() - Method in interface java.util.stream.BaseStream
Returns an equivalent stream that is unordered.
unpack(InputStream, JarOutputStream) - Method in interface java.util.jar.Pack200.Unpacker
Read a Pack200 archive, and write the encoded JAR to a JarOutputStream.
unpack(File, JarOutputStream) - Method in interface java.util.jar.Pack200.Unpacker
Read a Pack200 archive, and write the encoded JAR to a JarOutputStream.
unpark(Thread) - Static method in class java.util.concurrent.locks.LockSupport
Makes available the permit for the given thread, if it was not already available.
unparsedEntityDecl(String, String, String, String) - Method in interface org.xml.sax.DTDHandler
Receive notification of an unparsed entity declaration event.
unparsedEntityDecl(String, String, String, String) - Method in class org.xml.sax.HandlerBase
Deprecated.
Receive notification of an unparsed entity declaration.
unparsedEntityDecl(String, String, String, String) - Method in class org.xml.sax.helpers.DefaultHandler
Receive notification of an unparsed entity declaration.
unparsedEntityDecl(String, String, String, String) - Method in class org.xml.sax.helpers.XMLFilterImpl
Filter an unparsed entity declaration event.
unquote(String) - Static method in class javax.management.ObjectName
Returns an unquoted form of the given String.
unread(int) - Method in class java.io.PushbackInputStream
Pushes back a byte by copying it to the front of the pushback buffer.
unread(byte[], int, int) - Method in class java.io.PushbackInputStream
Pushes back a portion of an array of bytes by copying it to the front of the pushback buffer.
unread(byte[]) - Method in class java.io.PushbackInputStream
Pushes back an array of bytes by copying it to the front of the pushback buffer.
unread(int) - Method in class java.io.PushbackReader
Pushes back a single character by copying it to the front of the pushback buffer.
unread(char[], int, int) - Method in class java.io.PushbackReader
Pushes back a portion of an array of characters by copying it to the front of the pushback buffer.
unread(char[]) - Method in class java.io.PushbackReader
Pushes back an array of characters by copying it to the front of the pushback buffer.
UnrecoverableEntryException - Exception in java.security
This exception is thrown if an entry in the keystore cannot be recovered.
UnrecoverableEntryException() - Constructor for exception java.security.UnrecoverableEntryException
Constructs an UnrecoverableEntryException with no detail message.
UnrecoverableEntryException(String) - Constructor for exception java.security.UnrecoverableEntryException
Constructs an UnrecoverableEntryException with the specified detail message, which provides more information about why this exception has been thrown.
UnrecoverableKeyException - Exception in java.security
This exception is thrown if a key in the keystore cannot be recovered.
UnrecoverableKeyException() - Constructor for exception java.security.UnrecoverableKeyException
Constructs an UnrecoverableKeyException with no detail message.
UnrecoverableKeyException(String) - Constructor for exception java.security.UnrecoverableKeyException
Constructs an UnrecoverableKeyException with the specified detail message, which provides more information about why this exception has been thrown.
Unreferenced - Interface in java.rmi.server
A remote object implementation should implement the Unreferenced interface to receive notification when there are no more clients that reference that remote object.
unreferenced() - Method in interface java.rmi.server.Unreferenced
Called by the RMI runtime sometime after the runtime determines that the reference list, the list of clients referencing the remote object, becomes empty.
unreferenced() - Method in class javax.management.remote.rmi.RMIConnectionImpl
unreflect(Method) - Method in class java.lang.invoke.MethodHandles.Lookup
Makes a direct method handle to m, if the lookup class has permission.
unreflectConstructor(Constructor<?>) - Method in class java.lang.invoke.MethodHandles.Lookup
Produces a method handle for a reflected constructor.
unreflectGetter(Field) - Method in class java.lang.invoke.MethodHandles.Lookup
Produces a method handle giving read access to a reflected field.
unreflectSetter(Field) - Method in class java.lang.invoke.MethodHandles.Lookup
Produces a method handle giving write access to a reflected field.
unreflectSpecial(Method, Class<?>) - Method in class java.lang.invoke.MethodHandles.Lookup
Produces a method handle for a reflected method.
unregister(ActivationID) - Static method in class java.rmi.activation.Activatable
Revokes previous registration for the activation descriptor associated with id.
unregister_value_factory(String) - Method in class org.omg.CORBA_2_3.ORB
unregisterComponent(JComponent) - Method in class javax.swing.ToolTipManager
Removes a component from tooltip control.
unregisterGroup(ActivationGroupID) - Method in interface java.rmi.activation.ActivationSystem
Remove the activation group.
unregisterKeyboardAction(KeyStroke) - Method in class javax.swing.JComponent
This method is now obsolete.
unregisterKeyboardActions() - Method in class javax.swing.plaf.basic.BasicDesktopPaneUI
unregisterListeners() - Method in class java.awt.dnd.DragGestureRecognizer
unregister this DragGestureRecognizer's Listeners with the Component subclasses must override this method
unregisterListeners() - Method in class java.awt.dnd.MouseDragGestureRecognizer
unregister this DragGestureRecognizer's Listeners with the Component subclasses must override this method
unregisterMBean(ObjectName) - Method in interface javax.management.MBeanServer
Unregisters an MBean from the MBean server.
unregisterMBean(ObjectName) - Method in interface javax.management.MBeanServerConnection
Unregisters an MBean from the MBean server.
unregisterMBean(ObjectName, Subject) - Method in interface javax.management.remote.rmi.RMIConnection
Handles the method MBeanServerConnection.unregisterMBean(ObjectName).
unregisterMBean(ObjectName, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl
unregisterMBean(ObjectName, Subject) - Method in class javax.management.remote.rmi.RMIConnectionImpl_Stub
unregisterObject(ActivationID) - Method in interface java.rmi.activation.ActivationSystem
Remove the activation id and associated descriptor previously registered with the ActivationSystem; the object can no longer be activated via the object's activation id.
unregisterProvider(String) - Static method in class javax.sql.rowset.spi.SyncFactory
Removes the designated currently registered synchronization provider from the Factory SPI register.
UNREGISTRATION_NOTIFICATION - Static variable in class javax.management.MBeanServerNotification
Notification type denoting that an MBean has been unregistered.
UnresolvedAddressException - Exception in java.nio.channels
Unchecked exception thrown when an attempt is made to invoke a network operation upon an unresolved socket address.
UnresolvedAddressException() - Constructor for exception java.nio.channels.UnresolvedAddressException
Constructs an instance of this class.
UnresolvedPermission - Class in java.security
The UnresolvedPermission class is used to hold Permissions that were "unresolved" when the Policy was initialized.
UnresolvedPermission(String, String, String, Certificate[]) - Constructor for class java.security.UnresolvedPermission
Creates a new UnresolvedPermission containing the permission information needed later to actually create a Permission of the specified class, when the permission is resolved.
UnsatisfiedLinkError - Error in java.lang
Thrown if the Java Virtual Machine cannot find an appropriate native-language definition of a method declared native.
UnsatisfiedLinkError() - Constructor for error java.lang.UnsatisfiedLinkError
Constructs an UnsatisfiedLinkError with no detail message.
UnsatisfiedLinkError(String) - Constructor for error java.lang.UnsatisfiedLinkError
Constructs an UnsatisfiedLinkError with the specified detail message.
unscaledValue() - Method in class java.math.BigDecimal
Returns a BigInteger whose value is the unscaled value of this BigDecimal.
UNSELECTED_CONVERTED_TEXT_HIGHLIGHT - Static variable in class java.awt.im.InputMethodHighlight
Constant for the default highlight for unselected converted text.
UNSELECTED_RAW_TEXT_HIGHLIGHT - Static variable in class java.awt.im.InputMethodHighlight
Constant for the default highlight for unselected raw text.
UNSEQ_TOKEN - Static variable in exception org.ietf.jgss.GSSException
A later token has already been processed.
UNSET - Static variable in class javax.swing.Spring
An integer value signifying that a property value has not yet been calculated.
unsetCompression() - Method in class javax.imageio.ImageWriteParam
Removes any previous compression type and quality settings.
unsetCompression() - Method in class javax.imageio.plugins.jpeg.JPEGImageWriteParam
Removes any previous compression quality setting.
unsetDecodeTables() - Method in class javax.imageio.plugins.jpeg.JPEGImageReadParam
Removes any quantization and Huffman tables that are currently set.
unsetEncodeTables() - Method in class javax.imageio.plugins.jpeg.JPEGImageWriteParam
Removes any quantization and Huffman tables that are currently set.
unsetMatchColumn(int) - Method in interface javax.sql.rowset.Joinable
Unsets the designated column as the match column for this RowSet object.
unsetMatchColumn(int[]) - Method in interface javax.sql.rowset.Joinable
Unsets the designated columns as the match column for this RowSet object.
unsetMatchColumn(String) - Method in interface javax.sql.rowset.Joinable
Unsets the designated column as the match column for this RowSet object.
unsetMatchColumn(String[]) - Method in interface javax.sql.rowset.Joinable
Unsets the designated columns as the match columns for this RowSet object.
unsetOrdering(Class<T>, T, T) - Method in class javax.imageio.spi.ServiceRegistry
Sets a pairwise ordering between two service provider objects within a given category.
unsetTiling() - Method in class javax.imageio.ImageWriteParam
Removes any previous tile grid parameters specified by calls to setTiling.
UnsolicitedNotification - Interface in javax.naming.ldap
This interface represents an unsolicited notification as defined in RFC 2251.
UnsolicitedNotificationEvent - Class in javax.naming.ldap
This class represents an event fired in response to an unsolicited notification sent by the LDAP server.
UnsolicitedNotificationEvent(Object, UnsolicitedNotification) - Constructor for class javax.naming.ldap.UnsolicitedNotificationEvent
Constructs a new instance of UnsolicitedNotificationEvent.
UnsolicitedNotificationListener - Interface in javax.naming.ldap
This interface is for handling UnsolicitedNotificationEvent.
UNSPECIFIED_EVENT_TYPE_ERR - Static variable in exception org.w3c.dom.events.EventException
If the Event's type was not specified by initializing the event before the method was called.
UNSPECIFIED_OPTION - Static variable in class javax.security.auth.callback.ConfirmationCallback
Unspecified option type.
UNSUPPORTED_COMPRESSION - Static variable in class javax.print.attribute.standard.JobStateReason
The job was aborted by the system because the printer determined while attempting to decompress the document's data that the compression is actually not among those supported by the printer.
UNSUPPORTED_DOCUMENT_FORMAT - Static variable in class javax.print.attribute.standard.JobStateReason
The job was aborted by the system because the document data's document format (doc flavor) is not among those supported by the printer.
UNSUPPORTED_EMPTY_COLLECTION - Static variable in class java.security.Policy
A read-only empty PermissionCollection instance.
UNSUPPORTED_POLICY - Interface in org.omg.CORBA
One of the PolicyErrorCodes which would be filled if the requested Policy is understood to be valid by the ORB, but is not currently supported.
UNSUPPORTED_POLICY_VALUE - Interface in org.omg.CORBA
A PolicyErrorCode which would be filled if the value requested for the Policy is of a valid type and within the valid range for that type, but this valid value is not currently supported.
UnsupportedAddressTypeException - Exception in java.nio.channels
Unchecked exception thrown when an attempt is made to bind or connect to a socket address of a type that is not supported.
UnsupportedAddressTypeException() - Constructor for exception java.nio.channels.UnsupportedAddressTypeException
Constructs an instance of this class.
UnsupportedAudioFileException - Exception in javax.sound.sampled
An UnsupportedAudioFileException is an exception indicating that an operation failed because a file did not contain valid data of a recognized file type and format.
UnsupportedAudioFileException() - Constructor for exception javax.sound.sampled.UnsupportedAudioFileException
Constructs a UnsupportedAudioFileException that has null as its error detail message.
UnsupportedAudioFileException(String) - Constructor for exception javax.sound.sampled.UnsupportedAudioFileException
Constructs a UnsupportedAudioFileException that has the specified detail message.
UnsupportedCallbackException - Exception in javax.security.auth.callback
Signals that a CallbackHandler does not recognize a particular Callback.
UnsupportedCallbackException(Callback) - Constructor for exception javax.security.auth.callback.UnsupportedCallbackException
Constructs a UnsupportedCallbackException with no detail message.
UnsupportedCallbackException(Callback, String) - Constructor for exception javax.security.auth.callback.UnsupportedCallbackException
Constructs a UnsupportedCallbackException with the specified detail message.
UnsupportedCharsetException - Exception in java.nio.charset
Unchecked exception thrown when no support is available for a requested charset.
UnsupportedCharsetException(String) - Constructor for exception java.nio.charset.UnsupportedCharsetException
Constructs an instance of this class.
UnsupportedClassVersionError - Error in java.lang
Thrown when the Java Virtual Machine attempts to read a class file and determines that the major and minor version numbers in the file are not supported.
UnsupportedClassVersionError() - Constructor for error java.lang.UnsupportedClassVersionError
Constructs a UnsupportedClassVersionError with no detail message.
UnsupportedClassVersionError(String) - Constructor for error java.lang.UnsupportedClassVersionError
Constructs a UnsupportedClassVersionError with the specified detail message.
UnsupportedDataTypeException - Exception in javax.activation
Signals that the requested operation does not support the requested data type.
UnsupportedDataTypeException() - Constructor for exception javax.activation.UnsupportedDataTypeException
Constructs an UnsupportedDataTypeException with no detail message.
UnsupportedDataTypeException(String) - Constructor for exception javax.activation.UnsupportedDataTypeException
Constructs an UnsupportedDataTypeException with the specified message.
UnsupportedEncodingException - Exception in java.io
The Character Encoding is not supported.
UnsupportedEncodingException() - Constructor for exception java.io.UnsupportedEncodingException
Constructs an UnsupportedEncodingException without a detail message.
UnsupportedEncodingException(String) - Constructor for exception java.io.UnsupportedEncodingException
Constructs an UnsupportedEncodingException with a detail message.
UnsupportedFlavorException - Exception in java.awt.datatransfer
Signals that the requested data is not supported in this flavor.
UnsupportedFlavorException(DataFlavor) - Constructor for exception java.awt.datatransfer.UnsupportedFlavorException
Constructs an UnsupportedFlavorException.
UnsupportedLookAndFeelException - Exception in javax.swing
An exception that indicates the requested look & feel management classes are not present on the user's system.
UnsupportedLookAndFeelException(String) - Constructor for exception javax.swing.UnsupportedLookAndFeelException
Constructs an UnsupportedLookAndFeelException object.
UnsupportedOperationException - Exception in java.lang
Thrown to indicate that the requested operation is not supported.
UnsupportedOperationException() - Constructor for exception java.lang.UnsupportedOperationException
Constructs an UnsupportedOperationException with no detail message.
UnsupportedOperationException(String) - Constructor for exception java.lang.UnsupportedOperationException
Constructs an UnsupportedOperationException with the specified detail message.
UnsupportedOperationException(String, Throwable) - Constructor for exception java.lang.UnsupportedOperationException
Constructs a new exception with the specified detail message and cause.
UnsupportedOperationException(Throwable) - Constructor for exception java.lang.UnsupportedOperationException
Constructs a new exception with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
UnsupportedTemporalTypeException - Exception in java.time.temporal
UnsupportedTemporalTypeException indicates that a ChronoField or ChronoUnit is not supported for a Temporal class.
UnsupportedTemporalTypeException(String) - Constructor for exception java.time.temporal.UnsupportedTemporalTypeException
Constructs a new UnsupportedTemporalTypeException with the specified message.
UnsupportedTemporalTypeException(String, Throwable) - Constructor for exception java.time.temporal.UnsupportedTemporalTypeException
Constructs a new UnsupportedTemporalTypeException with the specified message and cause.
unsynchronize(Line[]) - Method in interface javax.sound.sampled.Mixer
Releases synchronization for the specified lines.
until(Temporal, TemporalUnit) - Method in interface java.time.chrono.ChronoLocalDate
Calculates the amount of time until another date in terms of the specified unit.
until(ChronoLocalDate) - Method in interface java.time.chrono.ChronoLocalDate
Calculates the period between this date and another date as a ChronoPeriod.
until(ChronoLocalDate) - Method in class java.time.chrono.HijrahDate
until(ChronoLocalDate) - Method in class java.time.chrono.JapaneseDate
until(ChronoLocalDate) - Method in class java.time.chrono.MinguoDate
until(ChronoLocalDate) - Method in class java.time.chrono.ThaiBuddhistDate
until(Temporal, TemporalUnit) - Method in class java.time.Instant
Calculates the amount of time until another instant in terms of the specified unit.
until(Temporal, TemporalUnit) - Method in class java.time.LocalDate
Calculates the amount of time until another date in terms of the specified unit.
until(ChronoLocalDate) - Method in class java.time.LocalDate
Calculates the period between this date and another date as a Period.
until(Temporal, TemporalUnit) - Method in class java.time.LocalDateTime
Calculates the amount of time until another date-time in terms of the specified unit.
until(Temporal, TemporalUnit) - Method in class java.time.LocalTime
Calculates the amount of time until another time in terms of the specified unit.
until(Temporal, TemporalUnit) - Method in class java.time.OffsetDateTime
Calculates the amount of time until another date-time in terms of the specified unit.
until(Temporal, TemporalUnit) - Method in class java.time.OffsetTime
Calculates the amount of time until another time in terms of the specified unit.
until(Temporal, TemporalUnit) - Method in interface java.time.temporal.Temporal
Calculates the amount of time until another temporal in terms of the specified unit.
until(Temporal, TemporalUnit) - Method in class java.time.Year
Calculates the amount of time until another year in terms of the specified unit.
until(Temporal, TemporalUnit) - Method in class java.time.YearMonth
Calculates the amount of time until another year-month in terms of the specified unit.
until(Temporal, TemporalUnit) - Method in class java.time.ZonedDateTime
Calculates the amount of time until another date-time in terms of the specified unit.
unwrap() - Method in class java.lang.invoke.MethodType
Converts all wrapper types to their corresponding primitive types.
unwrap(Class<T>) - Method in interface java.sql.Wrapper
Returns an object that implements the given interface to allow access to non-standard methods, or standard methods not exposed by the proxy.
unwrap(byte[], String, int) - Method in class javax.crypto.Cipher
Unwrap a previously wrapped key.
unwrap(ByteBuffer, ByteBuffer) - Method in class javax.net.ssl.SSLEngine
Attempts to decode SSL/TLS network data into a plaintext application data buffer.
unwrap(ByteBuffer, ByteBuffer[]) - Method in class javax.net.ssl.SSLEngine
Attempts to decode SSL/TLS network data into a sequence of plaintext application data buffers.
unwrap(ByteBuffer, ByteBuffer[], int, int) - Method in class javax.net.ssl.SSLEngine
Attempts to decode SSL/TLS network data into a subsequence of plaintext application data buffers.
unwrap(byte[], int, int) - Method in interface javax.security.sasl.SaslClient
Unwraps a byte array received from the server.
unwrap(byte[], int, int) - Method in interface javax.security.sasl.SaslServer
Unwraps a byte array received from the client.
unwrap(Class<T>) - Method in class javax.sql.rowset.RowSetMetaDataImpl
Returns an object that implements the given interface to allow access to non-standard methods, or standard methods not exposed by the proxy.
unwrap(byte[], int, int, MessageProp) - Method in interface org.ietf.jgss.GSSContext
Used to process tokens generated by the wrap method on the other side of the context.
unwrap(InputStream, OutputStream, MessageProp) - Method in interface org.ietf.jgss.GSSContext
Uses streams to process tokens generated by the wrap method on the other side of the context.
UNWRAP_MODE - Static variable in class javax.crypto.Cipher
Constant used to initialize cipher to key-unwrapping mode.
UP - Static variable in class java.awt.Event
The Up Arrow key, a non-ASCII action key.
UP_CYCLE_TRAVERSAL_KEYS - Static variable in class java.awt.KeyboardFocusManager
The identifier for the Up Cycle focus traversal keys.
upAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the Action for moving the caret logically upward one position.
UPDATABLE_VIEW_SYNC - Static variable in class javax.sql.rowset.spi.SyncProvider
Indicates that a SyncProvider implementation supports synchronization between a RowSet object and the SQL VIEW used to populate it.
update(Graphics) - Method in class java.awt.Canvas
Updates this canvas.
update(Graphics) - Method in class java.awt.Component
Updates this component.
update(Graphics) - Method in class java.awt.Container
Updates the container.
UPDATE - Static variable in class java.awt.event.PaintEvent
The update event type.
update() - Method in class java.awt.SplashScreen
Updates the splash window with current contents of the overlay image.
update(byte) - Method in class java.security.MessageDigest
Updates the digest using the specified byte.
update(byte[], int, int) - Method in class java.security.MessageDigest
Updates the digest using the specified array of bytes, starting at the specified offset.
update(byte[]) - Method in class java.security.MessageDigest
Updates the digest using the specified array of bytes.
update(ByteBuffer) - Method in class java.security.MessageDigest
Update the digest using the specified ByteBuffer.
update(byte) - Method in class java.security.Signature
Updates the data to be signed or verified by a byte.
update(byte[]) - Method in class java.security.Signature
Updates the data to be signed or verified, using the specified array of bytes.
update(byte[], int, int) - Method in class java.security.Signature
Updates the data to be signed or verified, using the specified array of bytes, starting at the specified offset.
update(ByteBuffer) - Method in class java.security.Signature
Updates the data to be signed or verified using the specified ByteBuffer.
update(Observable, Object) - Method in interface java.util.Observer
This method is called whenever the observed object is changed.
update(int) - Method in class java.util.zip.Adler32
Updates the checksum with the specified byte (the low eight bits of the argument b).
update(byte[], int, int) - Method in class java.util.zip.Adler32
Updates the checksum with the specified array of bytes.
update(byte[]) - Method in class java.util.zip.Adler32
Updates the checksum with the specified array of bytes.
update(ByteBuffer) - Method in class java.util.zip.Adler32
Updates the checksum with the bytes from the specified buffer.
update(int) - Method in interface java.util.zip.Checksum
Updates the current checksum with the specified byte.
update(byte[], int, int) - Method in interface java.util.zip.Checksum
Updates the current checksum with the specified array of bytes.
update(int) - Method in class java.util.zip.CRC32
Updates the CRC-32 checksum with the specified byte (the low eight bits of the argument b).
update(byte[], int, int) - Method in class java.util.zip.CRC32
Updates the CRC-32 checksum with the specified array of bytes.
update(byte[]) - Method in class java.util.zip.CRC32
Updates the CRC-32 checksum with the specified array of bytes.
update(ByteBuffer) - Method in class java.util.zip.CRC32
Updates the checksum with the bytes from the specified buffer.
UPDATE - Static variable in interface javax.accessibility.AccessibleTableModelChange
Identifies a change to existing data.
update(byte[]) - Method in class javax.crypto.Cipher
Continues a multiple-part encryption or decryption operation (depending on how this cipher was initialized), processing another data part.
update(byte[], int, int) - Method in class javax.crypto.Cipher
Continues a multiple-part encryption or decryption operation (depending on how this cipher was initialized), processing another data part.
update(byte[], int, int, byte[]) - Method in class javax.crypto.Cipher
Continues a multiple-part encryption or decryption operation (depending on how this cipher was initialized), processing another data part.
update(byte[], int, int, byte[], int) - Method in class javax.crypto.Cipher
Continues a multiple-part encryption or decryption operation (depending on how this cipher was initialized), processing another data part.
update(ByteBuffer, ByteBuffer) - Method in class javax.crypto.Cipher
Continues a multiple-part encryption or decryption operation (depending on how this cipher was initialized), processing another data part.
update(byte) - Method in class javax.crypto.Mac
Processes the given byte.
update(byte[]) - Method in class javax.crypto.Mac
Processes the given array of bytes.
update(byte[], int, int) - Method in class javax.crypto.Mac
Processes the first len bytes in input, starting at offset inclusive.
update(ByteBuffer) - Method in class javax.crypto.Mac
Processes input.remaining() bytes in the ByteBuffer input, starting at input.position().
update(LineEvent) - Method in interface javax.sound.sampled.LineListener
Informs the listener that a line's state has changed.
update(Graphics) - Method in class javax.swing.CellRendererPane
Shouldn't be called.
UPDATE - Static variable in class javax.swing.event.TableModelEvent
Identifies a change to existing data.
update(Graphics) - Method in class javax.swing.JApplet
Just calls paint(g).
update(Graphics) - Method in class javax.swing.JComponent
Calls paint.
update(Graphics) - Method in class javax.swing.JDialog
Calls paint(g).
update(Graphics) - Method in class javax.swing.JFrame
Just calls paint(g).
update(Graphics) - Method in class javax.swing.JWindow
Calls paint(g).
update(Graphics, JComponent) - Method in class javax.swing.plaf.basic.BasicMenuItemUI
We draw the background in paintMenuItem() so override update (which fills the background of opaque components by default) to just call paint().
update(Graphics, JComponent) - Method in class javax.swing.plaf.basic.BasicTextUI
Superclass paints background in an uncontrollable way (i.e.
update(Graphics, JComponent) - Method in class javax.swing.plaf.ComponentUI
Notifies this UI delegate that it is time to paint the specified component.
update(Graphics, JComponent) - Method in class javax.swing.plaf.metal.MetalButtonUI
If necessary paints the background of the component, then invokes paint.
update(Graphics, JComponent) - Method in class javax.swing.plaf.metal.MetalMenuBarUI
If necessary paints the background of the component, then invokes paint.
update(Graphics, JComponent) - Method in class javax.swing.plaf.metal.MetalTabbedPaneUI
update(Graphics, JComponent) - Method in class javax.swing.plaf.metal.MetalToggleButtonUI
If necessary paints the background of the component, then invokes paint.
update(Graphics, JComponent) - Method in class javax.swing.plaf.metal.MetalToolBarUI
If necessary paints the background of the component, then invokes paint.
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiButtonUI
Invokes the update method on each UI handled by this object.
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiColorChooserUI
Invokes the update method on each UI handled by this object.
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiComboBoxUI
Invokes the update method on each UI handled by this object.
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiDesktopIconUI
Invokes the update method on each UI handled by this object.
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiDesktopPaneUI
Invokes the update method on each UI handled by this object.
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiFileChooserUI
Invokes the update method on each UI handled by this object.
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiInternalFrameUI
Invokes the update method on each UI handled by this object.
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiLabelUI
Invokes the update method on each UI handled by this object.
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiListUI
Invokes the update method on each UI handled by this object.
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiMenuBarUI
Invokes the update method on each UI handled by this object.
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiMenuItemUI
Invokes the update method on each UI handled by this object.
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiOptionPaneUI
Invokes the update method on each UI handled by this object.
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiPanelUI
Invokes the update method on each UI handled by this object.
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiPopupMenuUI
Invokes the update method on each UI handled by this object.
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiProgressBarUI
Invokes the update method on each UI handled by this object.
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiRootPaneUI
Invokes the update method on each UI handled by this object.
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiScrollBarUI
Invokes the update method on each UI handled by this object.
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiScrollPaneUI
Invokes the update method on each UI handled by this object.
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiSeparatorUI
Invokes the update method on each UI handled by this object.
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiSliderUI
Invokes the update method on each UI handled by this object.
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiSpinnerUI
Invokes the update method on each UI handled by this object.
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiSplitPaneUI
Invokes the update method on each UI handled by this object.
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiTabbedPaneUI
Invokes the update method on each UI handled by this object.
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiTableHeaderUI
Invokes the update method on each UI handled by this object.
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiTableUI
Invokes the update method on each UI handled by this object.
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiTextUI
Invokes the update method on each UI handled by this object.
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiToolBarUI
Invokes the update method on each UI handled by this object.
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiToolTipUI
Invokes the update method on each UI handled by this object.
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiTreeUI
Invokes the update method on each UI handled by this object.
update(Graphics, JComponent) - Method in class javax.swing.plaf.multi.MultiViewportUI
Invokes the update method on each UI handled by this object.
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthButtonUI
Notifies this UI delegate to repaint the specified component.
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthColorChooserUI
Notifies this UI delegate to repaint the specified component.
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthComboBoxUI
Notifies this UI delegate to repaint the specified component.
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthDesktopIconUI
Notifies this UI delegate to repaint the specified component.
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthDesktopPaneUI
Notifies this UI delegate to repaint the specified component.
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthEditorPaneUI
Notifies this UI delegate to repaint the specified component.
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthInternalFrameUI
Notifies this UI delegate to repaint the specified component.
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthLabelUI
Notifies this UI delegate to repaint the specified component.
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthListUI
Notifies this UI delegate to repaint the specified component.
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthMenuBarUI
Notifies this UI delegate to repaint the specified component.
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthMenuItemUI
Notifies this UI delegate to repaint the specified component.
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthMenuUI
Notifies this UI delegate to repaint the specified component.
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthOptionPaneUI
Notifies this UI delegate to repaint the specified component.
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthPanelUI
Notifies this UI delegate to repaint the specified component.
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthPopupMenuUI
Notifies this UI delegate to repaint the specified component.
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthProgressBarUI
Notifies this UI delegate to repaint the specified component.
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthRootPaneUI
Notifies this UI delegate to repaint the specified component.
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthScrollBarUI
Notifies this UI delegate to repaint the specified component.
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthScrollPaneUI
Notifies this UI delegate to repaint the specified component.
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthSeparatorUI
Notifies this UI delegate to repaint the specified component.
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthSliderUI
Notifies this UI delegate to repaint the specified component.
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthSpinnerUI
Notifies this UI delegate to repaint the specified component.
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthSplitPaneUI
Notifies this UI delegate to repaint the specified component.
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthTabbedPaneUI
Notifies this UI delegate to repaint the specified component.
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthTableHeaderUI
Notifies this UI delegate to repaint the specified component.
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthTableUI
Notifies this UI delegate to repaint the specified component.
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthTextAreaUI
Notifies this UI delegate to repaint the specified component.
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthTextFieldUI
Notifies this UI delegate to repaint the specified component.
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthToolBarUI
Notifies this UI delegate to repaint the specified component.
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthToolTipUI
Notifies this UI delegate to repaint the specified component.
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthTreeUI
Notifies this UI delegate to repaint the specified component.
update(Graphics, JComponent) - Method in class javax.swing.plaf.synth.SynthViewportUI
Notifies this UI delegate to repaint the specified component.
UPDATE_ROW_CONFLICT - Static variable in interface javax.sql.rowset.spi.SyncResolver
Indicates that a conflict occurred while the RowSet object was attempting to update a row in the data source.
UPDATE_WHEN_ON_EDT - Static variable in class javax.swing.text.DefaultCaret
Indicates that the caret position is to be updated only when document changes are performed on the Event Dispatching Thread.
updateAAD(byte[]) - Method in class javax.crypto.Cipher
Continues a multi-part update of the Additional Authentication Data (AAD).
updateAAD(byte[], int, int) - Method in class javax.crypto.Cipher
Continues a multi-part update of the Additional Authentication Data (AAD), using a subset of the provided buffer.
updateAAD(ByteBuffer) - Method in class javax.crypto.Cipher
Continues a multi-part update of the Additional Authentication Data (AAD).
UpdateAction() - Constructor for class javax.swing.plaf.basic.BasicFileChooserUI.UpdateAction
updateAndGet(IntUnaryOperator) - Method in class java.util.concurrent.atomic.AtomicInteger
Atomically updates the current value with the results of applying the given function, returning the updated value.
updateAndGet(int, IntUnaryOperator) - Method in class java.util.concurrent.atomic.AtomicIntegerArray
Atomically updates the element at index i with the results of applying the given function, returning the updated value.
updateAndGet(T, IntUnaryOperator) - Method in class java.util.concurrent.atomic.AtomicIntegerFieldUpdater
Atomically updates the field of the given object managed by this updater with the results of applying the given function, returning the updated value.
updateAndGet(LongUnaryOperator) - Method in class java.util.concurrent.atomic.AtomicLong
Atomically updates the current value with the results of applying the given function, returning the updated value.
updateAndGet(int, LongUnaryOperator) - Method in class java.util.concurrent.atomic.AtomicLongArray
Atomically updates the element at index i with the results of applying the given function, returning the updated value.
updateAndGet(T, LongUnaryOperator) - Method in class java.util.concurrent.atomic.AtomicLongFieldUpdater
Atomically updates the field of the given object managed by this updater with the results of applying the given function, returning the updated value.
updateAndGet(UnaryOperator<V>) - Method in class java.util.concurrent.atomic.AtomicReference
Atomically updates the current value with the results of applying the given function, returning the updated value.
updateAndGet(int, UnaryOperator<E>) - Method in class java.util.concurrent.atomic.AtomicReferenceArray
Atomically updates the element at index i with the results of applying the given function, returning the updated value.
updateAndGet(T, UnaryOperator<V>) - Method in class java.util.concurrent.atomic.AtomicReferenceFieldUpdater
Atomically updates the field of the given object managed by this updater with the results of applying the given function, returning the updated value.
updateArray(int, Array) - Method in interface java.sql.ResultSet
Updates the designated column with a java.sql.Array value.
updateArray(String, Array) - Method in interface java.sql.ResultSet
Updates the designated column with a java.sql.Array value.
updateAsciiStream(int, InputStream, int) - Method in interface java.sql.ResultSet
Updates the designated column with an ascii stream value, which will have the specified number of bytes.
updateAsciiStream(String, InputStream, int) - Method in interface java.sql.ResultSet
Updates the designated column with an ascii stream value, which will have the specified number of bytes.
updateAsciiStream(int, InputStream, long) - Method in interface java.sql.ResultSet
Updates the designated column with an ascii stream value, which will have the specified number of bytes.
updateAsciiStream(String, InputStream, long) - Method in interface java.sql.ResultSet
Updates the designated column with an ascii stream value, which will have the specified number of bytes.
updateAsciiStream(int, InputStream) - Method in interface java.sql.ResultSet
Updates the designated column with an ascii stream value.
updateAsciiStream(String, InputStream) - Method in interface java.sql.ResultSet
Updates the designated column with an ascii stream value.
updateAutoscroll(Point) - Method in class java.awt.dnd.DropTarget
update autoscrolling with current cursor location
updateBigDecimal(int, BigDecimal) - Method in interface java.sql.ResultSet
Updates the designated column with a java.math.BigDecimal value.
updateBigDecimal(String, BigDecimal) - Method in interface java.sql.ResultSet
Updates the designated column with a java.sql.BigDecimal value.
updateBinaryStream(int, InputStream, int) - Method in interface java.sql.ResultSet
Updates the designated column with a binary stream value, which will have the specified number of bytes.
updateBinaryStream(String, InputStream, int) - Method in interface java.sql.ResultSet
Updates the designated column with a binary stream value, which will have the specified number of bytes.
updateBinaryStream(int, InputStream, long) - Method in interface java.sql.ResultSet
Updates the designated column with a binary stream value, which will have the specified number of bytes.
updateBinaryStream(String, InputStream, long) - Method in interface java.sql.ResultSet
Updates the designated column with a binary stream value, which will have the specified number of bytes.
updateBinaryStream(int, InputStream) - Method in interface java.sql.ResultSet
Updates the designated column with a binary stream value.
updateBinaryStream(String, InputStream) - Method in interface java.sql.ResultSet
Updates the designated column with a binary stream value.
updateBlob(int, Blob) - Method in interface java.sql.ResultSet
Updates the designated column with a java.sql.Blob value.
updateBlob(String, Blob) - Method in interface java.sql.ResultSet
Updates the designated column with a java.sql.Blob value.
updateBlob(int, InputStream, long) - Method in interface java.sql.ResultSet
Updates the designated column using the given input stream, which will have the specified number of bytes.
updateBlob(String, InputStream, long) - Method in interface java.sql.ResultSet
Updates the designated column using the given input stream, which will have the specified number of bytes.
updateBlob(int, InputStream) - Method in interface java.sql.ResultSet
Updates the designated column using the given input stream.
updateBlob(String, InputStream) - Method in interface java.sql.ResultSet
Updates the designated column using the given input stream.
updateBoolean(int, boolean) - Method in interface java.sql.ResultSet
Updates the designated column with a boolean value.
updateBoolean(String, boolean) - Method in interface java.sql.ResultSet
Updates the designated column with a boolean value.
updateButtonMnemonic - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
updateButtonText - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
updateButtonToolTipText - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
updateByte(int, byte) - Method in interface java.sql.ResultSet
Updates the designated column with a byte value.
updateByte(String, byte) - Method in interface java.sql.ResultSet
Updates the designated column with a byte value.
updateBytes(int, byte[]) - Method in interface java.sql.ResultSet
Updates the designated column with a byte array value.
updateBytes(String, byte[]) - Method in interface java.sql.ResultSet
Updates the designated column with a byte array value.
updateCachedPreferredSize() - Method in class javax.swing.plaf.basic.BasicTreeUI
Updates the preferredSize instance variable, which is returned from getPreferredSize().
updateCellEditor() - Method in class javax.swing.plaf.basic.BasicTreeUI
Updates the cellEditor based on the editability of the JTree that we're contained in.
updateCharacterStream(int, Reader, int) - Method in interface java.sql.ResultSet
Updates the designated column with a character stream value, which will have the specified number of bytes.
updateCharacterStream(String, Reader, int) - Method in interface java.sql.ResultSet
Updates the designated column with a character stream value, which will have the specified number of bytes.
updateCharacterStream(int, Reader, long) - Method in interface java.sql.ResultSet
Updates the designated column with a character stream value, which will have the specified number of bytes.
updateCharacterStream(String, Reader, long) - Method in interface java.sql.ResultSet
Updates the designated column with a character stream value, which will have the specified number of bytes.
updateCharacterStream(int, Reader) - Method in interface java.sql.ResultSet
Updates the designated column with a character stream value.
updateCharacterStream(String, Reader) - Method in interface java.sql.ResultSet
Updates the designated column with a character stream value.
updateChildren(DocumentEvent.ElementChange, DocumentEvent, ViewFactory) - Method in class javax.swing.text.View
Updates the child views in response to receiving notification that the model changed, and there is change record for the element this view is responsible for.
updateChildren(DocumentEvent.ElementChange, DocumentEvent, ViewFactory) - Method in class javax.swing.text.ZoneView
The superclass behavior will try to update the child views which is not desired in this case, since the children are zones and not directly effected by the changes to the associated element.
updateChooser() - Method in class javax.swing.colorchooser.AbstractColorChooserPanel
Invoked automatically when the model's state changes.
updateClob(int, Clob) - Method in interface java.sql.ResultSet
Updates the designated column with a java.sql.Clob value.
updateClob(String, Clob) - Method in interface java.sql.ResultSet
Updates the designated column with a java.sql.Clob value.
updateClob(int, Reader, long) - Method in interface java.sql.ResultSet
Updates the designated column using the given Reader object, which is the given number of characters long.
updateClob(String, Reader, long) - Method in interface java.sql.ResultSet
Updates the designated column using the given Reader object, which is the given number of characters long.
updateClob(int, Reader) - Method in interface java.sql.ResultSet
Updates the designated column using the given Reader object.
updateClob(String, Reader) - Method in interface java.sql.ResultSet
Updates the designated column using the given Reader object.
updateColumnHeader(PropertyChangeEvent) - Method in class javax.swing.plaf.basic.BasicScrollPaneUI
updateComponents() - Method in class javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager
Determines the components.
updateComponentTreeUI(Component) - Static method in class javax.swing.SwingUtilities
A simple minded look and feel change: ask each node in the tree to updateUI() -- that is, to initialize its UI property with the current look and feel.
updateCurrentCursor(int, int, int) - Method in class java.awt.dnd.DragSourceContext
If the default drag cursor behavior is active, this method sets the default drag cursor for the specified actions supported by the drag source, the drop target action, and status, otherwise this method does nothing.
updateDamage(DocumentEvent, Shape, ViewFactory) - Method in class javax.swing.text.PlainView
Repaint the region of change covered by the given document event.
updateDate(int, Date) - Method in interface java.sql.ResultSet
Updates the designated column with a java.sql.Date value.
updateDate(String, Date) - Method in interface java.sql.ResultSet
Updates the designated column with a java.sql.Date value.
updateDepthOffset() - Method in class javax.swing.plaf.basic.BasicTreeUI
Updates how much each depth should be offset by.
updateDouble(int, double) - Method in interface java.sql.ResultSet
Updates the designated column with a double value.
updateDouble(String, double) - Method in interface java.sql.ResultSet
Updates the designated column with a double value.
updateExpandedDescendants(TreePath) - Method in class javax.swing.plaf.basic.BasicTreeUI
Updates the expanded state of all the descendants of path by getting the expanded descendants from the tree and forwarding to the tree state.
updateFloat(int, float) - Method in interface java.sql.ResultSet
Updates the designated column with a float value.
updateFloat(String, float) - Method in interface java.sql.ResultSet
Updates the designated column with a float value.
updateInt(int, int) - Method in interface java.sql.ResultSet
Updates the designated column with an int value.
updateInt(String, int) - Method in interface java.sql.ResultSet
Updates the designated column with an int value.
updateJAXB(XmlNode) - Method in class javax.xml.bind.Binder
Takes an XML node and updates its associated JAXB object and its descendants.
updateLabelUIs() - Method in class javax.swing.JSlider
Updates the UIs for the labels in the label table by calling updateUI on each label.
updateLayout(DocumentEvent.ElementChange, DocumentEvent, Shape) - Method in class javax.swing.text.AsyncBoxView
Update the layout in response to receiving notification of change from the model.
updateLayout(DocumentEvent.ElementChange, DocumentEvent, Shape) - Method in class javax.swing.text.View
Updates the layout in response to receiving notification of change from the model.
updateLayoutCacheExpandedNodes() - Method in class javax.swing.plaf.basic.BasicTreeUI
Makes all the nodes that are expanded in JTree expanded in LayoutCache.
updateLayoutState() - Method in class javax.swing.plaf.basic.BasicListUI
Recompute the value of cellHeight or cellHeights based and cellWidth, based on the current font and the current values of fixedCellWidth, fixedCellHeight, and prototypeCellValue.
updateLayoutStateNeeded - Variable in class javax.swing.plaf.basic.BasicListUI
updateLeadIndex() - Method in class javax.swing.tree.DefaultTreeSelectionModel
Updates the leadIndex instance variable.
updateLeadSelectionRow() - Method in class javax.swing.plaf.basic.BasicTreeUI
Updates the lead row of the selection.
updateLevel - Variable in class javax.swing.undo.UndoableEditSupport
updateListBoxSelectionForEvent(MouseEvent, boolean) - Method in class javax.swing.plaf.basic.BasicComboPopup
A utility method used by the event listeners.
updateListeners - Variable in class javax.imageio.ImageReader
A List of currently registered IIOReadUpdateListeners, initialized by default to null, which is synonymous with an empty List.
updateLocation(Point) - Method in class java.awt.dnd.DropTarget.DropTargetAutoScroller
cause autoscroll to occur
updateLong(int, long) - Method in interface java.sql.ResultSet
Updates the designated column with a long value.
updateLong(String, long) - Method in interface java.sql.ResultSet
Updates the designated column with a long value.
updateMetrics() - Method in class javax.swing.text.PlainView
Checks to see if the font metrics and longest line are up-to-date.
updateNCharacterStream(int, Reader, long) - Method in interface java.sql.ResultSet
Updates the designated column with a character stream value, which will have the specified number of bytes.
updateNCharacterStream(String, Reader, long) - Method in interface java.sql.ResultSet
Updates the designated column with a character stream value, which will have the specified number of bytes.
updateNCharacterStream(int, Reader) - Method in interface java.sql.ResultSet
Updates the designated column with a character stream value.
updateNCharacterStream(String, Reader) - Method in interface java.sql.ResultSet
Updates the designated column with a character stream value.
updateNClob(int, NClob) - Method in interface java.sql.ResultSet
Updates the designated column with a java.sql.NClob value.
updateNClob(String, NClob) - Method in interface java.sql.ResultSet
Updates the designated column with a java.sql.NClob value.
updateNClob(int, Reader, long) - Method in interface java.sql.ResultSet
Updates the designated column using the given Reader object, which is the given number of characters long.
updateNClob(String, Reader, long) - Method in interface java.sql.ResultSet
Updates the designated column using the given Reader object, which is the given number of characters long.
updateNClob(int, Reader) - Method in interface java.sql.ResultSet
Updates the designated column using the given Reader The data will be read from the stream as needed until end-of-stream is reached.
updateNClob(String, Reader) - Method in interface java.sql.ResultSet
Updates the designated column using the given Reader object.
updateNString(int, String) - Method in interface java.sql.ResultSet
Updates the designated column with a String value.
updateNString(String, String) - Method in interface java.sql.ResultSet
Updates the designated column with a String value.
updateNull(int) - Method in interface java.sql.ResultSet
Updates the designated column with a null value.
updateNull(String) - Method in interface java.sql.ResultSet
Updates the designated column with a null value.
updateObject(int, Object, int) - Method in interface java.sql.ResultSet
Updates the designated column with an Object value.
updateObject(int, Object) - Method in interface java.sql.ResultSet
Updates the designated column with an Object value.
updateObject(String, Object, int) - Method in interface java.sql.ResultSet
Updates the designated column with an Object value.
updateObject(String, Object) - Method in interface java.sql.ResultSet
Updates the designated column with an Object value.
updateObject(int, Object, SQLType, int) - Method in interface java.sql.ResultSet
Updates the designated column with an Object value.
updateObject(String, Object, SQLType, int) - Method in interface java.sql.ResultSet
Updates the designated column with an Object value.
updateObject(int, Object, SQLType) - Method in interface java.sql.ResultSet
Updates the designated column with an Object value.
updateObject(String, Object, SQLType) - Method in interface java.sql.ResultSet
Updates the designated column with an Object value.
updateRef(int, Ref) - Method in interface java.sql.ResultSet
Updates the designated column with a java.sql.Ref value.
updateRef(String, Ref) - Method in interface java.sql.ResultSet
Updates the designated column with a java.sql.Ref value.
updateRenderer(JComponent, String) - Static method in class javax.swing.plaf.basic.BasicHTML
Stash the HTML render for the given text into the client properties of the given JComponent.
updateRenderer() - Method in class javax.swing.plaf.basic.BasicTreeUI
Messaged from the tree we're in when the renderer has changed.
updateRoleMap(String, Role, List<ObjectName>) - Method in class javax.management.relation.RelationService
Handles update of the Relation Service role map for the update of given role in given relation.
updateRoleMap(String, Role, List<ObjectName>) - Method in interface javax.management.relation.RelationServiceMBean
Handles update of the Relation Service role map for the update of given role in given relation.
updateRow() - Method in interface java.sql.ResultSet
Updates the underlying database with the new contents of the current row of this ResultSet object.
updateRowHeader(PropertyChangeEvent) - Method in class javax.swing.plaf.basic.BasicScrollPaneUI
updateRowId(int, RowId) - Method in interface java.sql.ResultSet
Updates the designated column with a RowId value.
updateRowId(String, RowId) - Method in interface java.sql.ResultSet
Updates the designated column with a RowId value.
updatesAreDetected(int) - Method in interface java.sql.DatabaseMetaData
Retrieves whether or not a visible row update can be detected by calling the method ResultSet.rowUpdated.
updateScrollBarDisplayPolicy(PropertyChangeEvent) - Method in class javax.swing.plaf.basic.BasicScrollPaneUI
updateShort(int, short) - Method in interface java.sql.ResultSet
Updates the designated column with a short value.
updateShort(String, short) - Method in interface java.sql.ResultSet
Updates the designated column with a short value.
updateSize() - Method in class javax.swing.plaf.basic.BasicTreeUI
Marks the cached size as being invalid, and messages the tree with treeDidChange.
updateSQLXML(int, SQLXML) - Method in interface java.sql.ResultSet
Updates the designated column with a java.sql.SQLXML value.
updateSQLXML(String, SQLXML) - Method in interface java.sql.ResultSet
Updates the designated column with a java.sql.SQLXML value.
updateString(int, String) - Method in interface java.sql.ResultSet
Updates the designated column with a String value.
updateString(String, String) - Method in interface java.sql.ResultSet
Updates the designated column with a String value.
updateStyles(Component) - Static method in class javax.swing.plaf.synth.SynthLookAndFeel
Updates the style associated with c, and all its children.
updateTableInRealTime - Variable in class javax.swing.table.JTableHeader
Obsolete as of Java 2 platform v1.3.
updateTime(int, Time) - Method in interface java.sql.ResultSet
Updates the designated column with a java.sql.Time value.
updateTime(String, Time) - Method in interface java.sql.ResultSet
Updates the designated column with a java.sql.Time value.
updateTimestamp(int, Timestamp) - Method in interface java.sql.ResultSet
Updates the designated column with a java.sql.Timestamp value.
updateTimestamp(String, Timestamp) - Method in interface java.sql.ResultSet
Updates the designated column with a java.sql.Timestamp value.
updateUI() - Method in class javax.swing.AbstractButton
Resets the UI property to a value from the current look and feel.
updateUI() - Method in class javax.swing.JButton
Resets the UI property to a value from the current look and feel.
updateUI() - Method in class javax.swing.JCheckBox
Resets the UI property to a value from the current look and feel.
updateUI() - Method in class javax.swing.JColorChooser
Notification from the UIManager that the L&F has changed.
updateUI() - Method in class javax.swing.JComboBox
Resets the UI property to a value from the current look and feel.
updateUI() - Method in class javax.swing.JComponent
Resets the UI property to a value from the current look and feel.
updateUI() - Method in class javax.swing.JDesktopPane
Notification from the UIManager that the L&F has changed.
updateUI() - Method in class javax.swing.JFileChooser
Resets the UI property to a value from the current look and feel.
updateUI() - Method in class javax.swing.JInternalFrame.JDesktopIcon
Notification from the UIManager that the look and feel has changed.
updateUI() - Method in class javax.swing.JInternalFrame
Notification from the UIManager that the look and feel has changed.
updateUI() - Method in class javax.swing.JLabel
Resets the UI property to a value from the current look and feel.
updateUI() - Method in class javax.swing.JLayer
Delegates its functionality to the LayerUI.updateUI(JLayer) method, if LayerUI is set.
updateUI() - Method in class javax.swing.JList
Resets the ListUI property by setting it to the value provided by the current look and feel.
updateUI() - Method in class javax.swing.JMenu
Resets the UI property with a value from the current look and feel.
updateUI() - Method in class javax.swing.JMenuBar
Resets the UI property with a value from the current look and feel.
updateUI() - Method in class javax.swing.JMenuItem
Resets the UI property with a value from the current look and feel.
updateUI() - Method in class javax.swing.JOptionPane
Notification from the UIManager that the L&F has changed.
updateUI() - Method in class javax.swing.JPanel
Resets the UI property with a value from the current look and feel.
updateUI() - Method in class javax.swing.JPasswordField
Reloads the pluggable UI.
updateUI() - Method in class javax.swing.JPopupMenu
Resets the UI property to a value from the current look and feel.
updateUI() - Method in class javax.swing.JProgressBar
Resets the UI property to a value from the current look and feel.
updateUI() - Method in class javax.swing.JRadioButton
Resets the UI property to a value from the current look and feel.
updateUI() - Method in class javax.swing.JRootPane
Resets the UI property to a value from the current look and feel.
updateUI() - Method in class javax.swing.JScrollBar
Overrides JComponent.updateUI.
updateUI() - Method in class javax.swing.JScrollPane
Replaces the current ScrollPaneUI object with a version from the current default look and feel.
updateUI() - Method in class javax.swing.JSeparator
Resets the UI property to a value from the current look and feel.
updateUI() - Method in class javax.swing.JSlider
Resets the UI property to a value from the current look and feel.
updateUI() - Method in class javax.swing.JSpinner
Resets the UI property with the value from the current look and feel.
updateUI() - Method in class javax.swing.JSplitPane
Notification from the UIManager that the L&F has changed.
updateUI() - Method in class javax.swing.JTabbedPane
Resets the UI property to a value from the current look and feel.
updateUI() - Method in class javax.swing.JTable
Notification from the UIManager that the L&F has changed.
updateUI() - Method in class javax.swing.JToggleButton
Resets the UI property to a value from the current look and feel.
updateUI() - Method in class javax.swing.JToolBar
Notification from the UIFactory that the L&F has changed.
updateUI() - Method in class javax.swing.JToolTip
Resets the UI property to a value from the current look and feel.
updateUI() - Method in class javax.swing.JTree
Notification from the UIManager that the L&F has changed.
updateUI() - Method in class javax.swing.JViewport
Resets the UI property to a value from the current look and feel.
updateUI(JLayer<? extends V>) - Method in class javax.swing.plaf.LayerUI
Invoked when JLayer.updateUI() is called by the JLayer this LayerUI is set to.
updateUI() - Method in class javax.swing.table.DefaultTableCellRenderer
Notification from the UIManager that the look and feel [L&F] has changed.
updateUI() - Method in class javax.swing.table.JTableHeader
Notification from the UIManager that the look and feel (L&F) has changed.
updateUI() - Method in class javax.swing.text.JTextComponent
Reloads the pluggable UI.
updateUI() - Method in class javax.swing.tree.DefaultTreeCellRenderer
Resets the UI property to a value from the current look and feel.
updateUndoPositions(Vector, int, int) - Method in class javax.swing.text.GapContent
Resets the location for all the UndoPosRef instances in positions.
updateUndoPositions(Vector) - Method in class javax.swing.text.StringContent
Resets the location for all the UndoPosRef instances in positions.
updateViewport(PropertyChangeEvent) - Method in class javax.swing.plaf.basic.BasicScrollPaneUI
updateXML(Object) - Method in class javax.xml.bind.Binder
Takes an JAXB object and updates its associated XML node and its descendants.
updateXML(Object, XmlNode) - Method in class javax.xml.bind.Binder
Changes in JAXB object tree are updated in its associated XML parse tree.
upFocusCycle(Component) - Method in class java.awt.DefaultKeyboardFocusManager
Moves the focus up one focus traversal cycle.
upFocusCycle(Component) - Method in class java.awt.KeyboardFocusManager
Moves the focus up one focus traversal cycle.
upFocusCycle() - Method in class java.awt.KeyboardFocusManager
Moves the focus up one focus traversal cycle from the current focus owner.
upFolderIcon - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
upKey - Variable in class javax.swing.plaf.basic.BasicSplitPaneUI
Deprecated.
As of Java 2 platform v1.3.
upKey - Variable in class javax.swing.plaf.basic.BasicTabbedPaneUI
Deprecated.
As of Java 2 platform v1.3.
upKey - Variable in class javax.swing.plaf.basic.BasicToolBarUI
Deprecated.
As of Java 2 platform v1.3.
UPPER_LEADING_CORNER - Static variable in interface javax.swing.ScrollPaneConstants
Identifies the upper leading edge corner of the viewport.
UPPER_LEFT_CORNER - Static variable in interface javax.swing.ScrollPaneConstants
Identifies the upper left corner of the viewport.
UPPER_RIGHT_CORNER - Static variable in interface javax.swing.ScrollPaneConstants
Identifies the upper right corner of the viewport.
UPPER_TRAILING_CORNER - Static variable in interface javax.swing.ScrollPaneConstants
Identifies the upper trailing edge corner of the viewport.
UPPERCASE - Static variable in class java.util.FormattableFlags
Converts the output to upper case according to the rules of the locale given during creation of the formatter argument of the formatTo() method.
UPPERCASE_LETTER - Static variable in class java.lang.Character
General category "Lu" in the Unicode specification.
upperLeft - Variable in class javax.swing.JScrollPane
The component to display in the upper left corner.
upperLeft - Variable in class javax.swing.ScrollPaneLayout
The component to display in the upper left corner.
upperRight - Variable in class javax.swing.JScrollPane
The component to display in the upper right corner.
upperRight - Variable in class javax.swing.ScrollPaneLayout
The component to display in the upper right corner.
URI - Class in java.net
Represents a Uniform Resource Identifier (URI) reference.
URI(String) - Constructor for class java.net.URI
Constructs a URI by parsing the given string.
URI(String, String, String, int, String, String, String) - Constructor for class java.net.URI
Constructs a hierarchical URI from the given components.
URI(String, String, String, String, String) - Constructor for class java.net.URI
Constructs a hierarchical URI from the given components.
URI(String, String, String, String) - Constructor for class java.net.URI
Constructs a hierarchical URI from the given components.
URI(String, String, String) - Constructor for class java.net.URI
Constructs a URI from the given components.
uri - Variable in class javax.tools.SimpleJavaFileObject
A URI for this file object.
URI_NS_SOAP_1_1_ENVELOPE - Static variable in interface javax.xml.soap.SOAPConstants
The namespace identifier for the SOAP 1.1 envelope.
URI_NS_SOAP_1_2_ENCODING - Static variable in interface javax.xml.soap.SOAPConstants
The namespace identifier for the SOAP 1.2 encoding.
URI_NS_SOAP_1_2_ENVELOPE - Static variable in interface javax.xml.soap.SOAPConstants
The namespace identifier for the SOAP 1.2 envelope.
URI_NS_SOAP_ENCODING - Static variable in interface javax.xml.soap.SOAPConstants
The namespace identifier for the SOAP 1.1 encoding.
URI_NS_SOAP_ENVELOPE - Static variable in interface javax.xml.soap.SOAPConstants
The namespace identifier for the SOAP 1.1 envelope, All SOAPElements in this namespace are defined by the SOAP 1.1 specification.
URI_SOAP_1_2_ROLE_NEXT - Static variable in interface javax.xml.soap.SOAPConstants
The URI identifying the next application processing a SOAP request as the intended role for a SOAP 1.2 header entry (see section 2.2 of part 1 of the SOAP 1.2 specification).
URI_SOAP_1_2_ROLE_NONE - Static variable in interface javax.xml.soap.SOAPConstants
The URI specifying the role None in SOAP 1.2.
URI_SOAP_1_2_ROLE_ULTIMATE_RECEIVER - Static variable in interface javax.xml.soap.SOAPConstants
The URI identifying the ultimate receiver of the SOAP 1.2 message.
URI_SOAP_ACTOR_NEXT - Static variable in interface javax.xml.soap.SOAPConstants
The URI identifying the next application processing a SOAP request as the intended actor for a SOAP 1.1 header entry (see section 4.2.2 of the SOAP 1.1 specification).
URIDereferencer - Interface in javax.xml.crypto
A dereferencer of URIReferences.
URIException - Interface in javax.print
Interface URIException is a mixin interface which a subclass of PrintException can implement to report an error condition involving a URI address.
URIInaccessible - Static variable in interface javax.print.URIException
Indicates that the printer cannot access the URI address.
URIOtherProblem - Static variable in interface javax.print.URIException
Indicates any kind of problem not specifically identified by the other reasons.
URIParameter - Class in java.security
A parameter that contains a URI pointing to data intended for a PolicySpi or ConfigurationSpi implementation.
URIParameter(URI) - Constructor for class java.security.URIParameter
Constructs a URIParameter with the URI pointing to data intended for an SPI implementation.
URIReference - Interface in javax.xml.crypto
Identifies a data object via a URI-Reference, as specified by RFC 2396.
URIReferenceException - Exception in javax.xml.crypto
Indicates an exceptional condition thrown while dereferencing a URIReference.
URIReferenceException() - Constructor for exception javax.xml.crypto.URIReferenceException
Constructs a new URIReferenceException with null as its detail message.
URIReferenceException(String) - Constructor for exception javax.xml.crypto.URIReferenceException
Constructs a new URIReferenceException with the specified detail message.
URIReferenceException(String, Throwable) - Constructor for exception javax.xml.crypto.URIReferenceException
Constructs a new URIReferenceException with the specified detail message and cause.
URIReferenceException(String, Throwable, URIReference) - Constructor for exception javax.xml.crypto.URIReferenceException
Constructs a new URIReferenceException with the specified detail message, cause and URIReference.
URIReferenceException(Throwable) - Constructor for exception javax.xml.crypto.URIReferenceException
Constructs a new URIReferenceException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
URIResolver - Interface in javax.xml.transform
An object that implements this interface that can be called by the processor to turn a URI used in document(), xsl:import, or xsl:include into a Source object.
URISchemeNotSupported - Static variable in interface javax.print.URIException
Indicates that the printer does not support the URI scheme ("http", "ftp", etc.) in the URI address.
URISyntax - Class in javax.print.attribute
Class URISyntax is an abstract base class providing the common implementation of all attributes whose value is a Uniform Resource Identifier (URI).
URISyntax(URI) - Constructor for class javax.print.attribute.URISyntax
Constructs a URI attribute with the specified URI.
URISyntaxException - Exception in java.net
Checked exception thrown to indicate that a string could not be parsed as a URI reference.
URISyntaxException(String, String, int) - Constructor for exception java.net.URISyntaxException
Constructs an instance from the given input string, reason, and error index.
URISyntaxException(String, String) - Constructor for exception java.net.URISyntaxException
Constructs an instance from the given input string and reason.
URL - Class in java.net
Class URL represents a Uniform Resource Locator, a pointer to a "resource" on the World Wide Web.
URL(String, String, int, String) - Constructor for class java.net.URL
Creates a URL object from the specified protocol, host, port number, and file.
URL(String, String, String) - Constructor for class java.net.URL
Creates a URL from the specified protocol name, host name, and file name.
URL(String, String, int, String, URLStreamHandler) - Constructor for class java.net.URL
Creates a URL object from the specified protocol, host, port number, file, and handler.
URL(String) - Constructor for class java.net.URL
Creates a URL object from the String representation.
URL(URL, String) - Constructor for class java.net.URL
Creates a URL by parsing the given spec within a specified context.
URL(URL, String, URLStreamHandler) - Constructor for class java.net.URL
Creates a URL by parsing the given spec with the specified handler within a specified context.
url - Variable in class java.net.URLConnection
The URL represents the remote object on the World Wide Web to which this connection is opened.
URL(String) - Constructor for class javax.print.DocFlavor.URL
Constructs a new doc flavor with the given MIME type and a print data representation class name of "java.net.URL".
URL_PKG_PREFIXES - Static variable in interface javax.naming.Context
Constant that holds the name of the environment property for specifying the list of package prefixes to use when loading in URL context factories.
URLClassLoader - Class in java.net
This class loader is used to load classes and resources from a search path of URLs referring to both JAR files and directories.
URLClassLoader(URL[], ClassLoader) - Constructor for class java.net.URLClassLoader
Constructs a new URLClassLoader for the given URLs.
URLClassLoader(URL[]) - Constructor for class java.net.URLClassLoader
Constructs a new URLClassLoader for the specified URLs using the default delegation parent ClassLoader.
URLClassLoader(URL[], ClassLoader, URLStreamHandlerFactory) - Constructor for class java.net.URLClassLoader
Constructs a new URLClassLoader for the specified URLs, parent class loader, and URLStreamHandlerFactory.
URLConnection - Class in java.net
The abstract class URLConnection is the superclass of all classes that represent a communications link between the application and a URL.
URLConnection(URL) - Constructor for class java.net.URLConnection
Constructs a URL connection to the specified URL.
URLDataSource - Class in javax.activation
The URLDataSource class provides an object that wraps a URL object in a DataSource interface.
URLDataSource(URL) - Constructor for class javax.activation.URLDataSource
URLDataSource constructor.
URLDecoder - Class in java.net
Utility class for HTML form decoding.
URLDecoder() - Constructor for class java.net.URLDecoder
URLEncoder - Class in java.net
Utility class for HTML form encoding.
URLPermission - Class in java.net
Represents permission to access a resource or set of resources defined by a given url, and for a given set of user-settable request methods and request headers.
URLPermission(String, String) - Constructor for class java.net.URLPermission
Creates a new URLPermission from a url string and which permits the given request methods and user-settable request headers.
URLPermission(String) - Constructor for class java.net.URLPermission
Creates a URLPermission with the given url string and unrestricted methods and request headers by invoking the two argument constructor as follows: URLPermission(url, "*:*")
URLStreamHandler - Class in java.net
The abstract class URLStreamHandler is the common superclass for all stream protocol handlers.
URLStreamHandler() - Constructor for class java.net.URLStreamHandler
URLStreamHandlerFactory - Interface in java.net
This interface defines a factory for URL stream protocol handlers.
URLStringHelper - Class in org.omg.CosNaming.NamingContextExtPackage
URLString is the URL address (corbaloc: or corbaname:) represented as a String.
URLStringHelper() - Constructor for class org.omg.CosNaming.NamingContextExtPackage.URLStringHelper
US - Static variable in class java.util.Locale
Useful constant for country.
US_ASCII - Static variable in class java.nio.charset.StandardCharsets
Seven-bit ASCII, a.k.a.
USE_ACTIVE_OBJECT_MAP_ONLY - Static variable in class org.omg.PortableServer.RequestProcessingPolicyValue
USE_ALL_BEANINFO - Static variable in class java.beans.Introspector
Flag to indicate to use of all beaninfo.
USE_DEFAULT_SERVANT - Static variable in class org.omg.PortableServer.RequestProcessingPolicyValue
USE_SERVANT_MANAGER - Static variable in class org.omg.PortableServer.RequestProcessingPolicyValue
USE_STD3_ASCII_RULES - Static variable in class java.net.IDN
Flag to turn on the check against STD-3 ASCII rules
useAnchoringBounds(boolean) - Method in class java.util.regex.Matcher
Sets the anchoring of region bounds for this matcher.
useCaches - Variable in class java.net.URLConnection
If true, the protocol is allowed to use caching whenever it can.
useDaylightTime() - Method in class java.util.SimpleTimeZone
Queries if this time zone uses daylight saving time.
useDaylightTime() - Method in class java.util.TimeZone
Queries if this TimeZone uses Daylight Saving Time.
useDelimiter(Pattern) - Method in class java.util.Scanner
Sets this scanner's delimiting pattern to the specified pattern.
useDelimiter(String) - Method in class java.util.Scanner
Sets this scanner's delimiting pattern to a pattern constructed from the specified String.
useLocale(Locale) - Method in class java.util.Scanner
Sets this scanner's locale to the specified locale.
USEMAP - Static variable in class javax.swing.text.html.HTML.Attribute
usePattern(Pattern) - Method in class java.util.regex.Matcher
Changes the Pattern that this Matcher uses to find matches with.
useProtocolVersion(int) - Method in class java.io.ObjectOutputStream
Specify stream protocol version to use when writing the stream.
USER_EXCEPTION - Interface in org.omg.PortableInterceptor
org/omg/PortableInterceptor/USER_EXCEPTION.java .
USER_ID - Static variable in class org.omg.PortableServer.IdAssignmentPolicyValue
useRadix(int) - Method in class java.util.Scanner
Sets this scanner's default radix to the specified radix.
UserDataHandler - Interface in org.w3c.dom
When associating an object to a key on a node using Node.setUserData() the application can provide a handler that gets called when the node the object is associated to is being cloned, imported, or renamed.
UserDefinedFileAttributeView - Interface in java.nio.file.attribute
A file attribute view that provides a view of a file's user-defined attributes, sometimes known as extended attributes.
UserException - Exception in org.omg.CORBA
The root class for CORBA IDL-defined user exceptions.
UserException() - Constructor for exception org.omg.CORBA.UserException
Constructs a UserException object.
UserException(String) - Constructor for exception org.omg.CORBA.UserException
Constructs a UserException object with a detail message.
USERNAME_PROPERTY - Static variable in interface javax.xml.ws.BindingProvider
Standard property: User name for authentication.
userNodeForPackage(Class<?>) - Static method in class java.util.prefs.Preferences
Returns the preference node from the calling user's preference tree that is associated (by convention) with the specified class's package.
userObject - Variable in class javax.swing.tree.DefaultMutableTreeNode
optional user object
UserPrincipal - Interface in java.nio.file.attribute
A Principal representing an identity used to determine access rights to objects in a file system.
UserPrincipalLookupService - Class in java.nio.file.attribute
An object to lookup user and group principals by name.
UserPrincipalLookupService() - Constructor for class java.nio.file.attribute.UserPrincipalLookupService
Initializes a new instance of this class.
UserPrincipalNotFoundException - Exception in java.nio.file.attribute
Checked exception thrown when a lookup of UserPrincipal fails because the principal does not exist.
UserPrincipalNotFoundException(String) - Constructor for exception java.nio.file.attribute.UserPrincipalNotFoundException
Constructs an instance of this class.
userRoot() - Static method in class java.util.prefs.Preferences
Returns the root preference node for the calling user.
userRoot() - Method in interface java.util.prefs.PreferencesFactory
Returns the user root preference node corresponding to the calling user.
usesFractionalMetrics() - Method in class java.awt.font.FontRenderContext
Returns a boolean which whether text fractional metrics mode is used in this FontRenderContext.
usesLocalFilePerTable() - Method in interface java.sql.DatabaseMetaData
Retrieves whether this database uses a file for each table.
usesLocalFiles() - Method in interface java.sql.DatabaseMetaData
Retrieves whether this database stores tables in a local file.
usesShiftModifier() - Method in class java.awt.MenuShortcut
Returns whether this MenuShortcut must be invoked using the SHIFT key.
useToString(int) - Method in class javax.swing.DefaultRowSorter
Returns whether or not to convert the value to a string before doing comparisons when sorting.
useToString(int) - Method in class javax.swing.table.TableRowSorter
Returns whether or not to convert the value to a string before doing comparisons when sorting.
useTransparentBounds(boolean) - Method in class java.util.regex.Matcher
Sets the transparency of region bounds for this matcher.
UShortSeqHelper - Class in org.omg.CORBA
The Helper for UShortSeq.
UShortSeqHelper() - Constructor for class org.omg.CORBA.UShortSeqHelper
UShortSeqHolder - Class in org.omg.CORBA
The Holder for UShortSeq.
UShortSeqHolder() - Constructor for class org.omg.CORBA.UShortSeqHolder
UShortSeqHolder(short[]) - Constructor for class org.omg.CORBA.UShortSeqHolder
usingProxy() - Method in class java.net.HttpURLConnection
Indicates if the connection is going through a proxy.
UTC - Static variable in class java.time.ZoneOffset
The time-zone offset for UTC, with an ID of 'Z'.
UTC(int, int, int, int, int, int) - Static method in class java.util.Date
Deprecated.
As of JDK version 1.1, replaced by Calendar.set(year + 1900, month, date, hrs, min, sec) or GregorianCalendar(year + 1900, month, date, hrs, min, sec), using a UTC TimeZone, followed by Calendar.getTime().getTime().
UTC_TIME - Static variable in class java.util.SimpleTimeZone
Constant for a mode of start or end time specified as UTC.
UTF_16 - Static variable in class java.nio.charset.StandardCharsets
Sixteen-bit UCS Transformation Format, byte order identified by an optional byte-order mark
UTF_16BE - Static variable in class java.nio.charset.StandardCharsets
Sixteen-bit UCS Transformation Format, big-endian byte order
UTF_16LE - Static variable in class java.nio.charset.StandardCharsets
Sixteen-bit UCS Transformation Format, little-endian byte order
UTF_8 - Static variable in class java.nio.charset.StandardCharsets
Eight-bit UCS Transformation Format
UTFDataFormatException - Exception in java.io
Signals that a malformed string in modified UTF-8 format has been read in a data input stream or by any class that implements the data input interface.
UTFDataFormatException() - Constructor for exception java.io.UTFDataFormatException
Constructs a UTFDataFormatException with null as its error detail message.
UTFDataFormatException(String) - Constructor for exception java.io.UTFDataFormatException
Constructs a UTFDataFormatException with the specified detail message.
Util - Class in javax.rmi.CORBA
Provides utility methods that can be used by stubs and ties to perform common operations.
UtilDelegate - Interface in javax.rmi.CORBA
Supports delegation for method implementations in Util.
Utilities - Class in javax.swing.text
A collection of methods to deal with various text related activities.
Utilities() - Constructor for class javax.swing.text.Utilities
UUID - Class in java.util
A class that represents an immutable universally unique identifier (UUID).
UUID(long, long) - Constructor for class java.util.UUID
Constructs a new UUID using the specified data.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames


V-Index (Java Platform SE 8 )

Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames
  • All Classes
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

V

VAI - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Vai" Unicode character block.
valid() - Method in class java.io.FileDescriptor
Tests if this file descriptor object is valid.
validate() - Method in class java.awt.Component
Validates this component.
validate() - Method in class java.awt.Container
Validates this container and all of its subcomponents.
validate(GraphicsConfiguration) - Method in class java.awt.image.VolatileImage
Attempts to restore the drawing surface of the image if the surface had been lost since the last validate call.
validate(CertPath, CertPathParameters) - Method in class java.security.cert.CertPathValidator
Validates the specified certification path using the specified algorithm parameter set.
validate(long) - Method in class java.util.concurrent.locks.StampedLock
Returns true if the lock has not been exclusively acquired since issuance of the given stamp.
validate() - Method in class javax.swing.DefaultListCellRenderer
Overridden for performance reasons.
validate() - Method in class javax.swing.table.DefaultTableCellRenderer
Overridden for performance reasons.
validate() - Method in class javax.swing.tree.DefaultTreeCellRenderer
Overridden for performance reasons.
validate(Object) - Method in interface javax.xml.bind.Validator
Deprecated.
since JAXB2.0
validate(XMLValidateContext) - Method in interface javax.xml.crypto.dsig.Reference
Validates this reference.
validate(XMLValidateContext) - Method in interface javax.xml.crypto.dsig.XMLSignature.SignatureValue
Validates the signature value.
validate(XMLValidateContext) - Method in interface javax.xml.crypto.dsig.XMLSignature
Validates the signature according to the core validation processing rules.
validate(Source) - Method in class javax.xml.validation.Validator
Validates the specified input.
validate(Source, Result) - Method in class javax.xml.validation.Validator
Validates the specified input and send the augmented validation result to the specified output.
validate_connection() - Method in class org.omg.CORBA.LocalObject
Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented.
validatedContents - Variable in class java.awt.Component.BltBufferStrategy
Whether or not the drawing buffer has been recently restored from a lost state.
validatedContents - Variable in class java.awt.Component.FlipBufferStrategy
Whether or not the drawing buffer has been recently restored from a lost state.
validateFileCache() - Method in class javax.swing.plaf.basic.BasicDirectoryModel
validateInvalidComponents() - Method in class javax.swing.RepaintManager
Validate all of the components that have been marked invalid.
validateObject() - Method in interface java.io.ObjectInputValidation
Validates the object.
validatePage(PageFormat) - Method in class java.awt.print.PrinterJob
Returns the clone of page with its settings adjusted to be compatible with the current printer of this PrinterJob.
validatePendingAdd(Object) - Method in class java.beans.beancontext.BeanContextSupport
Subclasses of this class may override, or envelope, this method to add validation behavior for the BeanContext to examine child objects immediately prior to their being added to the BeanContext.
validatePendingRemove(Object) - Method in class java.beans.beancontext.BeanContextSupport
Subclasses of this class may override, or envelope, this method to add validation behavior for the BeanContext to examine child objects immediately prior to their being removed from the BeanContext.
validatePendingSetBeanContext(BeanContext) - Method in class java.beans.beancontext.BeanContextChildSupport
Called from setBeanContext to validate (or otherwise) the pending change in the nesting BeanContext property value.
validateRoot(Object) - Method in interface javax.xml.bind.Validator
Deprecated.
since JAXB2.0
validateTree() - Method in class java.awt.Container
Recursively descends the container tree and recomputes the layout for any subtrees marked as needing it (those marked as invalid).
validating - Variable in class javax.xml.bind.helpers.AbstractUnmarshallerImpl
whether or not the unmarshaller will validate
VALIDATION_ERR - Static variable in exception org.w3c.dom.DOMException
If a call to a method such as insertBefore or removeChild would make the Node invalid with respect to "partial validity", this exception would be raised and the operation would not be done.
ValidationEvent - Interface in javax.xml.bind
This event indicates that a problem was encountered while validating the incoming XML data during an unmarshal operation, while performing on-demand validation of the Java content tree, or while marshalling the Java content tree back to XML data.
ValidationEventCollector - Class in javax.xml.bind.util
ValidationEventHandler implementation that collects all events.
ValidationEventCollector() - Constructor for class javax.xml.bind.util.ValidationEventCollector
ValidationEventHandler - Interface in javax.xml.bind
A basic event handler interface for validation errors.
ValidationEventImpl - Class in javax.xml.bind.helpers
Default implementation of the ValidationEvent interface.
ValidationEventImpl(int, String, ValidationEventLocator) - Constructor for class javax.xml.bind.helpers.ValidationEventImpl
Create a new ValidationEventImpl.
ValidationEventImpl(int, String, ValidationEventLocator, Throwable) - Constructor for class javax.xml.bind.helpers.ValidationEventImpl
Create a new ValidationEventImpl.
ValidationEventLocator - Interface in javax.xml.bind
Encapsulate the location of a ValidationEvent.
ValidationEventLocatorImpl - Class in javax.xml.bind.helpers
Default implementation of the ValidationEventLocator interface.
ValidationEventLocatorImpl() - Constructor for class javax.xml.bind.helpers.ValidationEventLocatorImpl
Creates an object with all fields unavailable.
ValidationEventLocatorImpl(Locator) - Constructor for class javax.xml.bind.helpers.ValidationEventLocatorImpl
Constructs an object from an org.xml.sax.Locator.
ValidationEventLocatorImpl(SAXParseException) - Constructor for class javax.xml.bind.helpers.ValidationEventLocatorImpl
Constructs an object from the location information of a SAXParseException.
ValidationEventLocatorImpl(Node) - Constructor for class javax.xml.bind.helpers.ValidationEventLocatorImpl
Constructs an object that points to a DOM Node.
ValidationEventLocatorImpl(Object) - Constructor for class javax.xml.bind.helpers.ValidationEventLocatorImpl
Constructs an object that points to a JAXB content object.
ValidationException - Exception in javax.xml.bind
This exception indicates that an error has occurred while performing a validate operation.
ValidationException(String) - Constructor for exception javax.xml.bind.ValidationException
Construct an ValidationException with the specified detail message.
ValidationException(String, String) - Constructor for exception javax.xml.bind.ValidationException
Construct an ValidationException with the specified detail message and vendor specific errorCode.
ValidationException(Throwable) - Constructor for exception javax.xml.bind.ValidationException
Construct an ValidationException with a linkedException.
ValidationException(String, Throwable) - Constructor for exception javax.xml.bind.ValidationException
Construct an ValidationException with the specified detail message and linkedException.
ValidationException(String, String, Throwable) - Constructor for exception javax.xml.bind.ValidationException
Construct an ValidationException with the specified detail message, vendor specific errorCode, and linkedException.
Validator - Interface in javax.xml.bind
Deprecated.
since JAXB 2.0
Validator - Class in javax.xml.validation
A processor that checks an XML document against Schema.
Validator() - Constructor for class javax.xml.validation.Validator
Constructor for derived classes.
ValidatorHandler - Class in javax.xml.validation
Streaming validator that works on SAX stream.
ValidatorHandler() - Constructor for class javax.xml.validation.ValidatorHandler
Constructor for derived classes.
validCachedPreferredSize - Variable in class javax.swing.plaf.basic.BasicTreeUI
Is the preferredSize valid?
validOps() - Method in class java.nio.channels.DatagramChannel
Returns an operation set identifying this channel's supported operations.
validOps() - Method in class java.nio.channels.Pipe.SinkChannel
Returns an operation set identifying this channel's supported operations.
validOps() - Method in class java.nio.channels.Pipe.SourceChannel
Returns an operation set identifying this channel's supported operations.
validOps() - Method in class java.nio.channels.SelectableChannel
Returns an operation set identifying this channel's supported operations.
validOps() - Method in class java.nio.channels.ServerSocketChannel
Returns an operation set identifying this channel's supported operations.
validOps() - Method in class java.nio.channels.SocketChannel
Returns an operation set identifying this channel's supported operations.
VALIGN - Static variable in class javax.swing.text.html.HTML.Attribute
value() - Method in interface java.nio.file.attribute.FileAttribute
Returns the attribute value.
value - Variable in class java.sql.DriverPropertyInfo
The value field specifies the current value of the property, based on a combination of the information supplied to the method getPropertyInfo, the Java environment, and the driver-supplied default values.
value(String) - Static method in class javax.management.Query
Returns a new string expression.
value(Number) - Static method in class javax.management.Query
Returns a numeric value expression that can be used in any Query call that expects a ValueExp.
value(int) - Static method in class javax.management.Query
Returns a numeric value expression that can be used in any Query call that expects a ValueExp.
value(long) - Static method in class javax.management.Query
Returns a numeric value expression that can be used in any Query call that expects a ValueExp.
value(float) - Static method in class javax.management.Query
Returns a numeric value expression that can be used in any Query call that expects a ValueExp.
value(double) - Static method in class javax.management.Query
Returns a numeric value expression that can be used in any Query call that expects a ValueExp.
value(boolean) - Static method in class javax.management.Query
Returns a boolean value expression that can be used in any Query call that expects a ValueExp.
value - Variable in class javax.naming.ldap.BasicControl
The control's ASN.1 BER encoded value.
value - Variable in class javax.swing.DefaultCellEditor.EditorDelegate
The value of this cell.
value - Variable in class javax.swing.JOptionPane
Currently selected value, will be a valid option, or UNINITIALIZED_VALUE or null.
VALUE - Static variable in class javax.swing.text.html.HTML.Attribute
value - Variable in class javax.swing.text.html.parser.AttributeList
value - Variable in class javax.xml.bind.JAXBElement
xml element value.
value - Variable in class javax.xml.ws.Holder
The value contained in the holder.
value - Variable in class org.omg.CORBA.AnyHolder
The Any value held by this AnyHolder object.
value - Variable in class org.omg.CORBA.AnySeqHolder
value - Static variable in interface org.omg.CORBA.ARG_IN
The value indicating an input argument.
value - Static variable in interface org.omg.CORBA.ARG_INOUT
The constant value indicating an argument used for both input and output.
value - Static variable in interface org.omg.CORBA.ARG_OUT
The constant value indicating an output argument.
value - Static variable in interface org.omg.CORBA.BAD_POLICY
The Error code in PolicyError exception.
value - Static variable in interface org.omg.CORBA.BAD_POLICY_TYPE
The Error code in PolicyError exception.
value - Static variable in interface org.omg.CORBA.BAD_POLICY_VALUE
The value used to represent a bad policy value error in a PolicyError exception.
value - Variable in class org.omg.CORBA.BooleanHolder
The boolean value held by this BooleanHolder object.
value - Variable in class org.omg.CORBA.BooleanSeqHolder
value - Variable in class org.omg.CORBA.ByteHolder
The byte value held by this ByteHolder object.
value - Variable in class org.omg.CORBA.CharHolder
The char value held by this CharHolder object.
value - Variable in class org.omg.CORBA.CharSeqHolder
value() - Method in class org.omg.CORBA.CompletionStatus
Retrieves the value of this CompletionStatus object.
value - Static variable in interface org.omg.CORBA.CTX_RESTRICT_SCOPE
The field containing the int value of a CTX_RESTRICT_SCOPE flag.
value - Variable in class org.omg.CORBA.CurrentHolder
value() - Method in class org.omg.CORBA.DefinitionKind
Returns the int constant identifying the type of an IR object.
value - Variable in class org.omg.CORBA.DoubleHolder
The double value held by this DoubleHolder object.
value - Variable in class org.omg.CORBA.DoubleSeqHolder
value - Variable in class org.omg.CORBA.FixedHolder
The value held by the FixedHolder
value - Variable in class org.omg.CORBA.FloatHolder
The float value held by this FloatHolder object.
value - Variable in class org.omg.CORBA.FloatSeqHolder
value - Variable in class org.omg.CORBA.IntHolder
The int value held by this IntHolder object in its value field.
value - Variable in class org.omg.CORBA.LongHolder
The long value held by this LongHolder object.
value - Variable in class org.omg.CORBA.LongLongSeqHolder
value - Variable in class org.omg.CORBA.LongSeqHolder
value() - Method in class org.omg.CORBA.NamedValue
Retrieves the value for this NamedValue object.
value - Variable in class org.omg.CORBA.NameValuePair
The value to be associated with a name by this NameValuePair object.
value - Variable in class org.omg.CORBA.ObjectHolder
The Object value held by this ObjectHolder object.
value - Variable in class org.omg.CORBA.OctetSeqHolder
value - Static variable in interface org.omg.CORBA.OMGVMCID
The vendor minor code ID reserved for OMG.
value() - Method in class org.omg.CORBA.ParameterMode
value - Variable in class org.omg.CORBA.ParameterModeHolder
value - Variable in class org.omg.CORBA.PolicyErrorHolder
value - Variable in class org.omg.CORBA.PolicyHolder
value - Variable in class org.omg.CORBA.PolicyListHolder
value - Variable in class org.omg.CORBA.PrincipalHolder
Deprecated.
The Principal value held by this PrincipalHolder object.
value - Static variable in interface org.omg.CORBA.PRIVATE_MEMBER
value - Static variable in interface org.omg.CORBA.PUBLIC_MEMBER
value - Variable in class org.omg.CORBA.ServiceInformationHolder
The ServiceInformation value held by this ServiceInformationHolder object in its value field.
value() - Method in class org.omg.CORBA.SetOverrideType
Retrieves the value of this SetOverrideType instance.
value - Variable in class org.omg.CORBA.ShortHolder
The short value held by this ShortHolder object.
value - Variable in class org.omg.CORBA.ShortSeqHolder
value - Variable in class org.omg.CORBA.StringHolder
The String value held by this StringHolder object.
value - Variable in class org.omg.CORBA.StringSeqHolder
value() - Method in class org.omg.CORBA.TCKind
Retrieves the value of this TCKind instance.
value - Variable in class org.omg.CORBA.TypeCodeHolder
The TypeCode value held by this TypeCodeHolder object.
value - Variable in class org.omg.CORBA.ULongLongSeqHolder
value - Variable in class org.omg.CORBA.ULongSeqHolder
value - Variable in class org.omg.CORBA.UnknownUserExceptionHolder
value - Static variable in interface org.omg.CORBA.UNSUPPORTED_POLICY
The Error code for PolicyError exception.
value - Static variable in interface org.omg.CORBA.UNSUPPORTED_POLICY_VALUE
The Error code for PolicyError exception.
value - Variable in class org.omg.CORBA.UShortSeqHolder
value - Variable in class org.omg.CORBA.ValueBaseHolder
The java.io.Serializable value held by this ValueBaseHolder object.
value - Static variable in interface org.omg.CORBA.VM_ABSTRACT
The value representing an abstract interface value type in a typecode.
value - Static variable in interface org.omg.CORBA.VM_CUSTOM
The value representing a custom marshalled value type in a typecode.
value - Static variable in interface org.omg.CORBA.VM_NONE
The value representing the value type in a typecode as per CORBA 2.3 spec.
value - Static variable in interface org.omg.CORBA.VM_TRUNCATABLE
The value representing a truncatable value type in a typecode.
value - Variable in class org.omg.CORBA.WCharSeqHolder
value - Variable in class org.omg.CORBA.WrongTransactionHolder
value - Variable in class org.omg.CORBA.WStringSeqHolder
value - Variable in class org.omg.CosNaming.BindingHolder
value - Variable in class org.omg.CosNaming.BindingIteratorHolder
value - Variable in class org.omg.CosNaming.BindingListHolder
value() - Method in class org.omg.CosNaming.BindingType
value - Variable in class org.omg.CosNaming.BindingTypeHolder
value - Variable in class org.omg.CosNaming.NameComponentHolder
value - Variable in class org.omg.CosNaming.NameHolder
value - Variable in class org.omg.CosNaming.NamingContextExtHolder
value - Variable in class org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder
value - Variable in class org.omg.CosNaming.NamingContextHolder
value - Variable in class org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder
value - Variable in class org.omg.CosNaming.NamingContextPackage.CannotProceedHolder
value - Variable in class org.omg.CosNaming.NamingContextPackage.InvalidNameHolder
value - Variable in class org.omg.CosNaming.NamingContextPackage.NotEmptyHolder
value - Variable in class org.omg.CosNaming.NamingContextPackage.NotFoundHolder
value() - Method in class org.omg.CosNaming.NamingContextPackage.NotFoundReason
value - Variable in class org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder
value - Variable in class org.omg.DynamicAny.NameDynAnyPair
The DynAny value associated with the name.
value - Variable in class org.omg.DynamicAny.NameValuePair
The Any value associated with the name.
value - Static variable in interface org.omg.IOP.CodeSets
Identifies a CDR encapsulation of the CONV_FRAME.CodeSetContext defined in Section 13.10.2.5, "GIOP Code Set Service Context," on page 13-43.
value - Static variable in interface org.omg.IOP.ENCODING_CDR_ENCAPS
The CDR Encapsulation encoding.
value - Static variable in interface org.omg.IOP.ExceptionDetailMessage
CORBA formal/02-06-01: 13.7.1: ExceptionDetailMessage identifies a CDR encapsulation of a wstring, encoded using GIOP 1.2 with a TCS-W of UTF-16.
value - Variable in class org.omg.IOP.IORHolder
value - Variable in class org.omg.IOP.MultipleComponentProfileHolder
value - Static variable in interface org.omg.IOP.RMICustomMaxStreamFormat
Identifies a CDR encapsulation of the RMICustomMaxStreamFormat service context which contains a single byte specifying the client's maximum RMI-IIOP stream format version.
value - Variable in class org.omg.IOP.ServiceContextHolder
value - Variable in class org.omg.IOP.ServiceContextListHolder
value - Static variable in interface org.omg.IOP.TAG_ALTERNATE_IIOP_ADDRESS
In cases where the same object key is used for more than one internet location, the following standard IOR Component is defined for support in IIOP version 1.2.
value - Static variable in interface org.omg.IOP.TAG_CODE_SETS
The code set component of the IOR multi-component profile structure contains: server's native char code set and conversion code sets, and server's native wchar code set and conversion code sets. Both char and wchar conversion code sets are listed in order of preference.
value - Static variable in interface org.omg.IOP.TAG_INTERNET_IOP
Identifies profiles that support the Internet Inter-ORB Protocol.
value - Static variable in interface org.omg.IOP.TAG_JAVA_CODEBASE
Class downloading is supported for stubs, ties, values, and value helpers.
value - Static variable in interface org.omg.IOP.TAG_MULTIPLE_COMPONENTS
Indicates that the value encapsulated is of type MultipleComponentProfile.
value - Static variable in interface org.omg.IOP.TAG_ORB_TYPE
It is often useful in the real world to be able to identify the particular kind of ORB an object reference is coming from, to work around problems with that particular ORB, or exploit shared efficiencies.
value - Static variable in interface org.omg.IOP.TAG_POLICIES
A profile component containing the sequence of QoS policies exported with the object reference by an object adapter.
value - Static variable in interface org.omg.IOP.TAG_RMI_CUSTOM_MAX_STREAM_FORMAT
RMI-IIOP has multiple stream format versions.
value - Variable in class org.omg.IOP.TaggedComponentHolder
value - Variable in class org.omg.IOP.TaggedProfileHolder
value - Static variable in interface org.omg.IOP.TransactionService
Identifies a CDR encapsulation of the CosTSInteroperation.PropogationContext defined in CORBAservices: Common Object Services Specifications.
value - Static variable in interface org.omg.Messaging.SYNC_WITH_TRANSPORT
Constant, defined in the Messaging spec, to define how far the request shall progress before control is returned to the client.
value - Static variable in interface org.omg.PortableInterceptor.ACTIVE
Object adapter state that indicates normal request processing.
value - Static variable in interface org.omg.PortableInterceptor.DISCARDING
Object adapter state that causes all requests to be discarded.
value - Static variable in interface org.omg.PortableInterceptor.HOLDING
Object adapter state that holds requests temporarily until the state is changed.
value - Static variable in interface org.omg.PortableInterceptor.INACTIVE
Object adapter state that causes all requests to be discarded.
value - Variable in class org.omg.PortableInterceptor.IORInterceptor_3_0Holder
value - Static variable in interface org.omg.PortableInterceptor.LOCATION_FORWARD
Indicates a LocationForward reply status.
value - Static variable in interface org.omg.PortableInterceptor.NON_EXISTENT
Object adapter state indicating that the adapter has been destroyed.
value - Variable in class org.omg.PortableInterceptor.ObjectReferenceFactoryHolder
value - Variable in class org.omg.PortableInterceptor.ObjectReferenceTemplateHolder
value - Variable in class org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder
value - Static variable in interface org.omg.PortableInterceptor.SUCCESSFUL
Indicates a successful Reply Status.
value - Static variable in interface org.omg.PortableInterceptor.SYSTEM_EXCEPTION
Indicates a SystemException reply status.
value - Static variable in interface org.omg.PortableInterceptor.TRANSPORT_RETRY
Indicates a Transport Retry reply status.
value - Static variable in interface org.omg.PortableInterceptor.UNKNOWN
XXX
value - Static variable in interface org.omg.PortableInterceptor.USER_EXCEPTION
Indicates a UserException reply status.
value - Static variable in interface org.omg.PortableServer.ID_ASSIGNMENT_POLICY_ID
The value representing ID_ASSIGNMENT_POLICY_ID.
value - Static variable in interface org.omg.PortableServer.ID_UNIQUENESS_POLICY_ID
The value representing ID_UNIQUENESS_POLICY_ID.
value() - Method in interface org.omg.PortableServer.IdAssignmentPolicyOperations
specifies the policy value
value() - Method in class org.omg.PortableServer.IdAssignmentPolicyValue
value() - Method in interface org.omg.PortableServer.IdUniquenessPolicyOperations
specifies the policy value
value() - Method in class org.omg.PortableServer.IdUniquenessPolicyValue
value - Static variable in interface org.omg.PortableServer.IMPLICIT_ACTIVATION_POLICY_ID
The value representing IMPLICIT_ACTIVATION_POLICY_ID.
value() - Method in interface org.omg.PortableServer.ImplicitActivationPolicyOperations
specifies the policy value
value() - Method in class org.omg.PortableServer.ImplicitActivationPolicyValue
value - Static variable in interface org.omg.PortableServer.LIFESPAN_POLICY_ID
The value representing LIFESPAN_POLICY_ID.
value() - Method in interface org.omg.PortableServer.LifespanPolicyOperations
specifies the policy value
value() - Method in class org.omg.PortableServer.LifespanPolicyValue
value() - Method in class org.omg.PortableServer.POAManagerPackage.State
value - Static variable in interface org.omg.PortableServer.REQUEST_PROCESSING_POLICY_ID
The value representing REQUEST_PROCESSING_POLICY_ID.
value() - Method in interface org.omg.PortableServer.RequestProcessingPolicyOperations
specifies the policy value
value() - Method in class org.omg.PortableServer.RequestProcessingPolicyValue
value - Static variable in interface org.omg.PortableServer.SERVANT_RETENTION_POLICY_ID
The value representing SERVANT_RETENTION_POLICY_ID.
value - Variable in class org.omg.PortableServer.ServantLocatorPackage.CookieHolder
value() - Method in interface org.omg.PortableServer.ServantRetentionPolicyOperations
specifies the policy value
value() - Method in class org.omg.PortableServer.ServantRetentionPolicyValue
value - Static variable in interface org.omg.PortableServer.THREAD_POLICY_ID
The value representing THREAD_POLICY_ID.
value() - Method in interface org.omg.PortableServer.ThreadPolicyOperations
specifies the policy value
value() - Method in class org.omg.PortableServer.ThreadPolicyValue
VALUE_ALPHA_INTERPOLATION_DEFAULT - Static variable in class java.awt.RenderingHints
Alpha interpolation hint value -- alpha blending algorithms are chosen by the implementation for a good tradeoff of performance vs.
VALUE_ALPHA_INTERPOLATION_QUALITY - Static variable in class java.awt.RenderingHints
Alpha interpolation hint value -- alpha blending algorithms are chosen with a preference for precision and visual quality.
VALUE_ALPHA_INTERPOLATION_SPEED - Static variable in class java.awt.RenderingHints
Alpha interpolation hint value -- alpha blending algorithms are chosen with a preference for calculation speed.
VALUE_ANTIALIAS_DEFAULT - Static variable in class java.awt.RenderingHints
Antialiasing hint value -- rendering is done with a default antialiasing mode chosen by the implementation.
VALUE_ANTIALIAS_OFF - Static variable in class java.awt.RenderingHints
Antialiasing hint value -- rendering is done without antialiasing.
VALUE_ANTIALIAS_ON - Static variable in class java.awt.RenderingHints
Antialiasing hint value -- rendering is done with antialiasing.
VALUE_ARBITRARY - Static variable in interface javax.imageio.metadata.IIOMetadataFormat
A constant returned by getAttributeValueType and getObjectValueType to indicate that the attribute or user object may be set a single, arbitrary value.
value_as_string() - Method in interface org.omg.CORBA.DynEnum
Deprecated.
Return the value of the IDL enum stored in this DynEnum as a string.
value_as_string(String) - Method in interface org.omg.CORBA.DynEnum
Deprecated.
Set a particular enum in this DynEnum.
value_as_ulong() - Method in interface org.omg.CORBA.DynEnum
Deprecated.
Return the value of the IDL enum as a Java int.
value_as_ulong(int) - Method in interface org.omg.CORBA.DynEnum
Deprecated.
Set the value of the IDL enum.
VALUE_COLOR_RENDER_DEFAULT - Static variable in class java.awt.RenderingHints
Color rendering hint value -- perform color conversion calculations as chosen by the implementation to represent the best available tradeoff between performance and accuracy.
VALUE_COLOR_RENDER_QUALITY - Static variable in class java.awt.RenderingHints
Color rendering hint value -- perform the color conversion calculations with the highest accuracy and visual quality.
VALUE_COLOR_RENDER_SPEED - Static variable in class java.awt.RenderingHints
Color rendering hint value -- perform the fastest color conversion to the format of the output device.
VALUE_DITHER_DEFAULT - Static variable in class java.awt.RenderingHints
Dithering hint value -- use a default for dithering chosen by the implementation.
VALUE_DITHER_DISABLE - Static variable in class java.awt.RenderingHints
Dithering hint value -- do not dither when rendering geometry.
VALUE_DITHER_ENABLE - Static variable in class java.awt.RenderingHints
Dithering hint value -- dither when rendering geometry, if needed.
VALUE_ENUMERATION - Static variable in interface javax.imageio.metadata.IIOMetadataFormat
A constant returned by getAttributeValueType and getObjectValueType to indicate that the attribute or user object may be set one of a number of enumerated values.
VALUE_FRACTIONALMETRICS_DEFAULT - Static variable in class java.awt.RenderingHints
Font fractional metrics hint value -- character glyphs are positioned with accuracy chosen by the implementation.
VALUE_FRACTIONALMETRICS_OFF - Static variable in class java.awt.RenderingHints
Font fractional metrics hint value -- character glyphs are positioned with advance widths rounded to pixel boundaries.
VALUE_FRACTIONALMETRICS_ON - Static variable in class java.awt.RenderingHints
Font fractional metrics hint value -- character glyphs are positioned with sub-pixel accuracy.
VALUE_INTERPOLATION_BICUBIC - Static variable in class java.awt.RenderingHints
Interpolation hint value -- the color samples of 9 nearby integer coordinate samples in the image are interpolated using a cubic function in both X and Y to produce a color sample.
VALUE_INTERPOLATION_BILINEAR - Static variable in class java.awt.RenderingHints
Interpolation hint value -- the color samples of the 4 nearest neighboring integer coordinate samples in the image are interpolated linearly to produce a color sample.
VALUE_INTERPOLATION_NEAREST_NEIGHBOR - Static variable in class java.awt.RenderingHints
Interpolation hint value -- the color sample of the nearest neighboring integer coordinate sample in the image is used.
VALUE_LIST - Static variable in interface javax.imageio.metadata.IIOMetadataFormat
A constant returned by getAttributeValueType and getObjectValueType to indicate that the attribute or user object may be set to a list or array of values.
VALUE_NONE - Static variable in interface javax.imageio.metadata.IIOMetadataFormat
A constant returned by getObjectValueType to indicate the absence of a user object.
VALUE_PROPERTY - Static variable in class javax.swing.JOptionPane
Bound property name for value.
VALUE_RANGE - Static variable in interface javax.imageio.metadata.IIOMetadataFormat
A constant returned by getAttributeValueType and getObjectValueType to indicate that the attribute or user object may be set a range of values.
VALUE_RANGE_MAX_INCLUSIVE - Static variable in interface javax.imageio.metadata.IIOMetadataFormat
A constant returned by getAttributeValueType and getObjectValueType to indicate that the attribute or user object may be set to a range of values.
VALUE_RANGE_MAX_INCLUSIVE_MASK - Static variable in interface javax.imageio.metadata.IIOMetadataFormat
A value that may be or'ed with VALUE_RANGE to obtain VALUE_RANGE_MAX_INCLUSIVE, and with VALUE_RANGE_MIN_INCLUSIVE to obtain VALUE_RANGE_MIN_MAX_INCLUSIVE.
VALUE_RANGE_MIN_INCLUSIVE - Static variable in interface javax.imageio.metadata.IIOMetadataFormat
A constant returned by getAttributeValueType and getObjectValueType to indicate that the attribute or user object may be set to a range of values.
VALUE_RANGE_MIN_INCLUSIVE_MASK - Static variable in interface javax.imageio.metadata.IIOMetadataFormat
A value that may be or'ed with VALUE_RANGE to obtain VALUE_RANGE_MIN_INCLUSIVE, and with VALUE_RANGE_MAX_INCLUSIVE to obtain VALUE_RANGE_MIN_MAX_INCLUSIVE.
VALUE_RANGE_MIN_MAX_INCLUSIVE - Static variable in interface javax.imageio.metadata.IIOMetadataFormat
A constant returned by getAttributeValueType and getObjectValueType to indicate that the attribute or user object may be set a range of values.
VALUE_RENDER_DEFAULT - Static variable in class java.awt.RenderingHints
Rendering hint value -- rendering algorithms are chosen by the implementation for a good tradeoff of performance vs.
VALUE_RENDER_QUALITY - Static variable in class java.awt.RenderingHints
Rendering hint value -- rendering algorithms are chosen with a preference for output quality.
VALUE_RENDER_SPEED - Static variable in class java.awt.RenderingHints
Rendering hint value -- rendering algorithms are chosen with a preference for output speed.
VALUE_STROKE_DEFAULT - Static variable in class java.awt.RenderingHints
Stroke normalization control hint value -- geometry may be modified or left pure depending on the tradeoffs in a given implementation.
VALUE_STROKE_NORMALIZE - Static variable in class java.awt.RenderingHints
Stroke normalization control hint value -- geometry should be normalized to improve uniformity or spacing of lines and overall aesthetics.
VALUE_STROKE_PURE - Static variable in class java.awt.RenderingHints
Stroke normalization control hint value -- geometry should be left unmodified and rendered with sub-pixel accuracy.
VALUE_TEXT_ANTIALIAS_DEFAULT - Static variable in class java.awt.RenderingHints
Text antialiasing hint value -- text rendering is done according to the RenderingHints.KEY_ANTIALIASING hint or a default chosen by the implementation.
VALUE_TEXT_ANTIALIAS_GASP - Static variable in class java.awt.RenderingHints
Text antialiasing hint value -- text rendering is requested to use information in the font resource which specifies for each point size whether to apply RenderingHints.VALUE_TEXT_ANTIALIAS_ON or RenderingHints.VALUE_TEXT_ANTIALIAS_OFF.
VALUE_TEXT_ANTIALIAS_LCD_HBGR - Static variable in class java.awt.RenderingHints
Text antialiasing hint value -- request that text be displayed optimised for an LCD display with subpixels in order from display left to right of B,G,R such that the horizontal subpixel resolution is three times that of the full pixel horizontal resolution (HBGR).
VALUE_TEXT_ANTIALIAS_LCD_HRGB - Static variable in class java.awt.RenderingHints
Text antialiasing hint value -- request that text be displayed optimised for an LCD display with subpixels in order from display left to right of R,G,B such that the horizontal subpixel resolution is three times that of the full pixel horizontal resolution (HRGB).
VALUE_TEXT_ANTIALIAS_LCD_VBGR - Static variable in class java.awt.RenderingHints
Text antialiasing hint value -- request that text be displayed optimised for an LCD display with subpixel organisation from display top to bottom of B,G,R such that the vertical subpixel resolution is three times that of the full pixel vertical resolution (VBGR).
VALUE_TEXT_ANTIALIAS_LCD_VRGB - Static variable in class java.awt.RenderingHints
Text antialiasing hint value -- request that text be displayed optimised for an LCD display with subpixel organisation from display top to bottom of R,G,B such that the vertical subpixel resolution is three times that of the full pixel vertical resolution (VRGB).
VALUE_TEXT_ANTIALIAS_OFF - Static variable in class java.awt.RenderingHints
Text antialiasing hint value -- text rendering is done without any form of antialiasing.
VALUE_TEXT_ANTIALIAS_ON - Static variable in class java.awt.RenderingHints
Text antialiasing hint value -- text rendering is done with some form of antialiasing.
ValueBase - Interface in org.omg.CORBA.portable
The generated Java classes corresponding to valuetype IDL types implement this interface.
ValueBaseHelper - Class in org.omg.CORBA
ValueBaseHelper() - Constructor for class org.omg.CORBA.ValueBaseHelper
ValueBaseHolder - Class in org.omg.CORBA
The Holder for ValueBase.
ValueBaseHolder() - Constructor for class org.omg.CORBA.ValueBaseHolder
Constructs a new ValueBaseHolder object with its value field initialized to 0.
ValueBaseHolder(Serializable) - Constructor for class org.omg.CORBA.ValueBaseHolder
Constructs a new ValueBaseHolder object with its value field initialized to the given java.io.Serializable.
valueBound(SSLSessionBindingEvent) - Method in interface javax.net.ssl.SSLSessionBindingListener
This is called to notify the listener that it is being bound into an SSLSession.
valueChanged(ListSelectionEvent) - Method in interface javax.swing.event.ListSelectionListener
Called whenever the value of the selection changes.
valueChanged(TreeSelectionEvent) - Method in interface javax.swing.event.TreeSelectionListener
Called whenever the value of the selection changes.
valueChanged(ListSelectionEvent) - Method in class javax.swing.JList.AccessibleJList
List Selection Listener value change method.
valueChanged(ListSelectionEvent) - Method in class javax.swing.JTable.AccessibleJTable
Track changes to table cell selections
valueChanged(ListSelectionEvent) - Method in class javax.swing.JTable
Invoked when the row selection changes -- repaints to show the new selection.
valueChanged(TreeSelectionEvent) - Method in class javax.swing.JTree.AccessibleJTree
Tree Selection Listener value change method.
valueChanged(TreeSelectionEvent) - Method in class javax.swing.JTree.TreeSelectionRedirector
Invoked by the TreeSelectionModel when the selection changes.
valueChanged(ListSelectionEvent) - Method in class javax.swing.plaf.basic.BasicComboPopup.ListSelectionHandler
valueChanged(ListSelectionEvent) - Method in class javax.swing.plaf.basic.BasicFileChooserUI.SelectionListener
valueChanged(ListSelectionEvent) - Method in class javax.swing.plaf.basic.BasicListUI.ListSelectionHandler
valueChanged(TreeSelectionEvent) - Method in class javax.swing.plaf.basic.BasicTreeUI.TreeSelectionHandler
Messaged when the selection changes in the tree we're displaying for.
valueChanged(ListSelectionEvent) - Method in class javax.swing.plaf.metal.MetalFileChooserUI
valueChanged(ListSelectionEvent) - Method in class javax.swing.table.DefaultTableColumnModel
A ListSelectionListener that forwards ListSelectionEvents when there is a column selection change.
valueChanged(TreeSelectionEvent) - Method in class javax.swing.tree.DefaultTreeCellEditor
Resets lastPath.
ValueExp - Interface in javax.management
Represents values that can be passed as arguments to relational expressions.
ValueFactory - Interface in org.omg.CORBA.portable
The ValueFactory interface is the native mapping for the IDL type CORBA::ValueFactory.
valueForPathChanged(TreePath, Object) - Method in class javax.swing.tree.DefaultTreeModel
This sets the user object of the TreeNode identified by path and posts a node changed.
valueForPathChanged(TreePath, Object) - Method in interface javax.swing.tree.TreeModel
Messaged when the user has altered the value for the item identified by path to newValue.
valueForXPosition(int) - Method in class javax.swing.plaf.basic.BasicSliderUI
Returns the value at the x position.
valueForXPosition(int) - Method in class javax.swing.plaf.synth.SynthSliderUI
Returns the value at the x position.
valueForYPosition(int) - Method in class javax.swing.plaf.basic.BasicSliderUI
Returns the value at the y position.
valueForYPosition(int) - Method in class javax.swing.plaf.synth.SynthSliderUI
Returns the value at the y position.
ValueHandler - Interface in javax.rmi.CORBA
Defines methods which allow serialization of Java objects to and from GIOP streams.
ValueHandlerMultiFormat - Interface in javax.rmi.CORBA
Java to IDL ptc 02-01-12 1.5.1.5
ValueInputStream - Interface in org.omg.CORBA.portable
Java to IDL ptc 02-01-12 1.5.1.4 ValueInputStream is used for implementing RMI-IIOP stream format version 2.
valueIsAdjusting - Variable in class javax.swing.plaf.basic.BasicComboPopup
As of Java 2 platform v1.4 this previously undocumented field is no longer used.
ValueMember - Class in org.omg.CORBA
A description in the Interface Repository of a member of a value object.
ValueMember() - Constructor for class org.omg.CORBA.ValueMember
Constructs a default ValueMember object.
ValueMember(String, String, String, String, TypeCode, IDLType, short) - Constructor for class org.omg.CORBA.ValueMember
Constructs a ValueMember object initialized with the given values.
ValueMemberHelper - Class in org.omg.CORBA
The Helper for ValueMember.
ValueMemberHelper() - Constructor for class org.omg.CORBA.ValueMemberHelper
valueOf(String) - Static method in enum java.awt.Component.BaselineResizeBehavior
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.awt.Desktop.Action
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.awt.Dialog.ModalExclusionType
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.awt.Dialog.ModalityType
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.awt.font.NumericShaper.Range
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.awt.GraphicsDevice.WindowTranslucency
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.awt.MultipleGradientPaint.ColorSpaceType
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.awt.MultipleGradientPaint.CycleMethod
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.awt.TrayIcon.MessageType
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.awt.Window.Type
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.lang.annotation.ElementType
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.lang.annotation.RetentionPolicy
Returns the enum constant of this type with the specified name.
valueOf(boolean) - Static method in class java.lang.Boolean
Returns a Boolean instance representing the specified boolean value.
valueOf(String) - Static method in class java.lang.Boolean
Returns a Boolean with a value represented by the specified string.
valueOf(byte) - Static method in class java.lang.Byte
Returns a Byte instance representing the specified byte value.
valueOf(String, int) - Static method in class java.lang.Byte
Returns a Byte object holding the value extracted from the specified String when parsed with the radix given by the second argument.
valueOf(String) - Static method in class java.lang.Byte
Returns a Byte object holding the value given by the specified String.
valueOf(String) - Static method in enum java.lang.Character.UnicodeScript
Returns the enum constant of this type with the specified name.
valueOf(char) - Static method in class java.lang.Character
Returns a Character instance representing the specified char value.
valueOf(String) - Static method in class java.lang.Double
Returns a Double object holding the double value represented by the argument string s.
valueOf(double) - Static method in class java.lang.Double
Returns a Double instance representing the specified double value.
valueOf(Class<T>, String) - Static method in class java.lang.Enum
Returns the enum constant of the specified enum type with the specified name.
valueOf(String) - Static method in class java.lang.Float
Returns a Float object holding the float value represented by the argument string s.
valueOf(float) - Static method in class java.lang.Float
Returns a Float instance representing the specified float value.
valueOf(String, int) - Static method in class java.lang.Integer
Returns an Integer object holding the value extracted from the specified String when parsed with the radix given by the second argument.
valueOf(String) - Static method in class java.lang.Integer
Returns an Integer object holding the value of the specified String.
valueOf(int) - Static method in class java.lang.Integer
Returns an Integer instance representing the specified int value.
valueOf(String, int) - Static method in class java.lang.Long
Returns a Long object holding the value extracted from the specified String when parsed with the radix given by the second argument.
valueOf(String) - Static method in class java.lang.Long
Returns a Long object holding the value of the specified String.
valueOf(long) - Static method in class java.lang.Long
Returns a Long instance representing the specified long value.
valueOf(String) - Static method in enum java.lang.management.MemoryType
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.lang.ProcessBuilder.Redirect.Type
Returns the enum constant of this type with the specified name.
valueOf(String, int) - Static method in class java.lang.Short
Returns a Short object holding the value extracted from the specified String when parsed with the radix given by the second argument.
valueOf(String) - Static method in class java.lang.Short
Returns a Short object holding the value given by the specified String.
valueOf(short) - Static method in class java.lang.Short
Returns a Short instance representing the specified short value.
valueOf(Object) - Static method in class java.lang.String
Returns the string representation of the Object argument.
valueOf(char[]) - Static method in class java.lang.String
Returns the string representation of the char array argument.
valueOf(char[], int, int) - Static method in class java.lang.String
Returns the string representation of a specific subarray of the char array argument.
valueOf(boolean) - Static method in class java.lang.String
Returns the string representation of the boolean argument.
valueOf(char) - Static method in class java.lang.String
Returns the string representation of the char argument.
valueOf(int) - Static method in class java.lang.String
Returns the string representation of the int argument.
valueOf(long) - Static method in class java.lang.String
Returns the string representation of the long argument.
valueOf(float) - Static method in class java.lang.String
Returns the string representation of the float argument.
valueOf(double) - Static method in class java.lang.String
Returns the string representation of the double argument.
valueOf(String) - Static method in enum java.lang.Thread.State
Returns the enum constant of this type with the specified name.
valueOf(long, int) - Static method in class java.math.BigDecimal
Translates a long unscaled value and an int scale into a BigDecimal.
valueOf(long) - Static method in class java.math.BigDecimal
Translates a long value into a BigDecimal with a scale of zero.
valueOf(double) - Static method in class java.math.BigDecimal
Translates a double into a BigDecimal, using the double's canonical string representation provided by the Double.toString(double) method.
valueOf(long) - Static method in class java.math.BigInteger
Returns a BigInteger whose value is equal to that of the specified long.
valueOf(String) - Static method in enum java.math.RoundingMode
Returns the enum constant of this type with the specified name.
valueOf(int) - Static method in enum java.math.RoundingMode
Returns the RoundingMode object corresponding to a legacy integer rounding mode constant in BigDecimal.
valueOf(String) - Static method in enum java.net.Authenticator.RequestorType
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.net.Proxy.Type
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.net.StandardProtocolFamily
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.nio.file.AccessMode
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.nio.file.attribute.AclEntryFlag
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.nio.file.attribute.AclEntryPermission
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.nio.file.attribute.AclEntryType
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.nio.file.attribute.PosixFilePermission
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.nio.file.FileVisitOption
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.nio.file.FileVisitResult
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.nio.file.LinkOption
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.nio.file.StandardCopyOption
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.nio.file.StandardOpenOption
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.security.cert.CertPathValidatorException.BasicReason
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.security.cert.CRLReason
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.security.cert.PKIXReason
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.security.cert.PKIXRevocationChecker.Option
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.security.CryptoPrimitive
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.security.KeyRep.Type
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.sql.ClientInfoStatus
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in class java.sql.Date
Converts a string in JDBC date escape format to a Date value.
valueOf(LocalDate) - Static method in class java.sql.Date
Obtains an instance of Date from a LocalDate object with the same year, month and day of month value as the given LocalDate.
valueOf(String) - Static method in enum java.sql.JDBCType
Returns the enum constant of this type with the specified name.
valueOf(int) - Static method in enum java.sql.JDBCType
Returns the JDBCType that corresponds to the specified Types value
valueOf(String) - Static method in enum java.sql.PseudoColumnUsage
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.sql.RowIdLifetime
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in class java.sql.Time
Converts a string in JDBC time escape format to a Time value.
valueOf(LocalTime) - Static method in class java.sql.Time
Obtains an instance of Time from a LocalTime object with the same hour, minute and second time value as the given LocalTime.
valueOf(String) - Static method in class java.sql.Timestamp
Converts a String object in JDBC timestamp escape format to a Timestamp value.
valueOf(LocalDateTime) - Static method in class java.sql.Timestamp
Obtains an instance of Timestamp from a LocalDateTime object, with the same year, month, day of month, hours, minutes, seconds and nanos date-time value as the provided LocalDateTime.
valueOf(String) - Static method in enum java.text.Normalizer.Form
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.time.chrono.HijrahEra
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.time.chrono.IsoEra
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in class java.time.chrono.JapaneseEra
Returns the JapaneseEra with the name.
valueOf(String) - Static method in enum java.time.chrono.MinguoEra
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.time.chrono.ThaiBuddhistEra
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.time.DayOfWeek
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.time.format.FormatStyle
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.time.format.ResolverStyle
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.time.format.SignStyle
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.time.format.TextStyle
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.time.Month
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.time.temporal.ChronoField
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.time.temporal.ChronoUnit
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.time.zone.ZoneOffsetTransitionRule.TimeDefinition
Returns the enum constant of this type with the specified name.
valueOf(long[]) - Static method in class java.util.BitSet
Returns a new bit set containing all the bits in the given long array.
valueOf(LongBuffer) - Static method in class java.util.BitSet
Returns a new bit set containing all the bits in the given long buffer between its position and limit.
valueOf(byte[]) - Static method in class java.util.BitSet
Returns a new bit set containing all the bits in the given byte array.
valueOf(ByteBuffer) - Static method in class java.util.BitSet
Returns a new bit set containing all the bits in the given byte buffer between its position and limit.
valueOf(String) - Static method in enum java.util.concurrent.TimeUnit
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.util.Formatter.BigDecimalLayoutForm
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.util.Locale.Category
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.util.Locale.FilteringMode
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum java.util.stream.Collector.Characteristics
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum javax.annotation.Resource.AuthenticationType
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum javax.jws.soap.SOAPBinding.ParameterStyle
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum javax.jws.soap.SOAPBinding.Style
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum javax.jws.soap.SOAPBinding.Use
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum javax.jws.WebParam.Mode
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum javax.lang.model.element.ElementKind
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum javax.lang.model.element.Modifier
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum javax.lang.model.element.NestingKind
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum javax.lang.model.SourceVersion
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum javax.lang.model.type.TypeKind
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum javax.net.ssl.SSLEngineResult.HandshakeStatus
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum javax.net.ssl.SSLEngineResult.Status
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum javax.swing.DropMode
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum javax.swing.event.RowSorterEvent.Type
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum javax.swing.GroupLayout.Alignment
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum javax.swing.JTable.PrintMode
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum javax.swing.LayoutStyle.ComponentPlacement
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum javax.swing.plaf.nimbus.AbstractRegionPainter.PaintContext.CacheMode
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum javax.swing.RowFilter.ComparisonType
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum javax.swing.SortOrder
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum javax.swing.SwingWorker.StateValue
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum javax.swing.text.html.FormSubmitEvent.MethodType
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum javax.tools.Diagnostic.Kind
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum javax.tools.DocumentationTool.Location
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum javax.tools.JavaFileObject.Kind
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum javax.tools.StandardLocation
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum javax.xml.bind.annotation.XmlAccessOrder
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum javax.xml.bind.annotation.XmlAccessType
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum javax.xml.bind.annotation.XmlNsForm
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in class javax.xml.namespace.QName
QName derived from parsing the formatted String.
valueOf(String) - Static method in enum javax.xml.ws.handler.MessageContext.Scope
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum javax.xml.ws.Service.Mode
Returns the enum constant of this type with the specified name.
valueOf(String) - Static method in enum javax.xml.ws.soap.AddressingFeature.Responses
Returns the enum constant of this type with the specified name.
ValueOutputStream - Interface in org.omg.CORBA.portable
Java to IDL ptc 02-01-12 1.5.1.3 ValueOutputStream is used for implementing RMI-IIOP stream format version 2.
ValueRange - Class in java.time.temporal
The range of valid values for a date-time field.
values() - Static method in enum java.awt.Component.BaselineResizeBehavior
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.awt.Desktop.Action
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.awt.Dialog.ModalExclusionType
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.awt.Dialog.ModalityType
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.awt.font.NumericShaper.Range
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.awt.GraphicsDevice.WindowTranslucency
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.awt.MultipleGradientPaint.ColorSpaceType
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.awt.MultipleGradientPaint.CycleMethod
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Method in class java.awt.RenderingHints
Returns a Collection view of the values contained in this RenderinHints.
values() - Static method in enum java.awt.TrayIcon.MessageType
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.awt.Window.Type
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.lang.annotation.ElementType
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.lang.annotation.RetentionPolicy
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.lang.Character.UnicodeScript
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.lang.management.MemoryType
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.lang.ProcessBuilder.Redirect.Type
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.lang.Thread.State
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.math.RoundingMode
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.net.Authenticator.RequestorType
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.net.Proxy.Type
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.net.StandardProtocolFamily
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.nio.file.AccessMode
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.nio.file.attribute.AclEntryFlag
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.nio.file.attribute.AclEntryPermission
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.nio.file.attribute.AclEntryType
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.nio.file.attribute.PosixFilePermission
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.nio.file.FileVisitOption
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.nio.file.FileVisitResult
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.nio.file.LinkOption
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.nio.file.StandardCopyOption
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.nio.file.StandardOpenOption
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.security.cert.CertPathValidatorException.BasicReason
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.security.cert.CRLReason
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.security.cert.PKIXReason
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.security.cert.PKIXRevocationChecker.Option
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.security.CryptoPrimitive
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.security.KeyRep.Type
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Method in class java.security.Provider
Returns an unmodifiable Collection view of the property values contained in this provider.
values() - Static method in enum java.sql.ClientInfoStatus
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.sql.JDBCType
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.sql.PseudoColumnUsage
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.sql.RowIdLifetime
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.text.Normalizer.Form
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.time.chrono.HijrahEra
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.time.chrono.IsoEra
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in class java.time.chrono.JapaneseEra
Returns an array of JapaneseEras.
values() - Static method in enum java.time.chrono.MinguoEra
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.time.chrono.ThaiBuddhistEra
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.time.DayOfWeek
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.time.format.FormatStyle
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.time.format.ResolverStyle
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.time.format.SignStyle
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.time.format.TextStyle
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.time.Month
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.time.temporal.ChronoField
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.time.temporal.ChronoUnit
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.time.zone.ZoneOffsetTransitionRule.TimeDefinition
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Method in class java.util.AbstractMap
Returns a Collection view of the values contained in this map.
values() - Method in class java.util.concurrent.ConcurrentHashMap
Returns a Collection view of the values contained in this map.
values() - Method in class java.util.concurrent.ConcurrentSkipListMap
Returns a Collection view of the values contained in this map.
values() - Static method in enum java.util.concurrent.TimeUnit
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Method in class java.util.EnumMap
Returns a Collection view of the values contained in this map.
values() - Static method in enum java.util.Formatter.BigDecimalLayoutForm
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Method in class java.util.HashMap
Returns a Collection view of the values contained in this map.
values() - Method in class java.util.Hashtable
Returns a Collection view of the values contained in this map.
values() - Method in class java.util.IdentityHashMap
Returns a Collection view of the values contained in this map.
values() - Method in class java.util.jar.Attributes
Returns a Collection view of the attribute values contained in this Map.
values() - Method in class java.util.LinkedHashMap
Returns a Collection view of the values contained in this map.
values() - Static method in enum java.util.Locale.Category
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum java.util.Locale.FilteringMode
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Method in interface java.util.Map
Returns a Collection view of the values contained in this map.
values() - Method in interface java.util.SortedMap
Returns a Collection view of the values contained in this map.
values() - Static method in enum java.util.stream.Collector.Characteristics
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Method in class java.util.TreeMap
Returns a Collection view of the values contained in this map.
values() - Method in class java.util.WeakHashMap
Returns a Collection view of the values contained in this map.
values() - Static method in enum javax.annotation.Resource.AuthenticationType
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum javax.jws.soap.SOAPBinding.ParameterStyle
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum javax.jws.soap.SOAPBinding.Style
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum javax.jws.soap.SOAPBinding.Use
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum javax.jws.WebParam.Mode
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum javax.lang.model.element.ElementKind
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum javax.lang.model.element.Modifier
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum javax.lang.model.element.NestingKind
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum javax.lang.model.SourceVersion
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum javax.lang.model.type.TypeKind
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Method in interface javax.management.openmbean.CompositeData
Returns an unmodifiable Collection view of the item values contained in this CompositeData instance.
values() - Method in class javax.management.openmbean.CompositeDataSupport
Returns an unmodifiable Collection view of the item values contained in this CompositeData instance.
values() - Method in interface javax.management.openmbean.TabularData
Returns a collection view of the CompositeData values (ie the rows) contained in this TabularData instance.
values() - Method in class javax.management.openmbean.TabularDataSupport
Returns a collection view of the rows contained in this TabularDataSupport instance.
values - Variable in class javax.naming.directory.BasicAttribute
Holds the attribute's values.
values() - Static method in enum javax.net.ssl.SSLEngineResult.HandshakeStatus
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum javax.net.ssl.SSLEngineResult.Status
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Method in class javax.script.SimpleBindings
Returns a Collection view of the values contained in this map.
values() - Static method in enum javax.swing.DropMode
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum javax.swing.event.RowSorterEvent.Type
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum javax.swing.GroupLayout.Alignment
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum javax.swing.JTable.PrintMode
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum javax.swing.LayoutStyle.ComponentPlacement
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum javax.swing.plaf.nimbus.AbstractRegionPainter.PaintContext.CacheMode
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum javax.swing.RowFilter.ComparisonType
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum javax.swing.SortOrder
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum javax.swing.SwingWorker.StateValue
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum javax.swing.text.html.FormSubmitEvent.MethodType
Returns an array containing the constants of this enum type, in the order they are declared.
values - Variable in class javax.swing.text.html.parser.AttributeList
values() - Static method in enum javax.tools.Diagnostic.Kind
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum javax.tools.DocumentationTool.Location
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum javax.tools.JavaFileObject.Kind
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum javax.tools.StandardLocation
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum javax.xml.bind.annotation.XmlAccessOrder
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum javax.xml.bind.annotation.XmlAccessType
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum javax.xml.bind.annotation.XmlNsForm
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum javax.xml.ws.handler.MessageContext.Scope
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum javax.xml.ws.Service.Mode
Returns an array containing the constants of this enum type, in the order they are declared.
values() - Static method in enum javax.xml.ws.soap.AddressingFeature.Responses
Returns an array containing the constants of this enum type, in the order they are declared.
valueToString(Object) - Method in class javax.swing.JFormattedTextField.AbstractFormatter
Returns the string value to display for value.
valueToString(Object) - Method in class javax.swing.text.DefaultFormatter
Converts the passed in Object into a String by way of the toString method.
valueToString(Object) - Method in class javax.swing.text.InternationalFormatter
Returns a String representation of the Object value.
valueToString(Object) - Method in class javax.swing.text.MaskFormatter
Returns a String representation of the Object value based on the mask.
VALUETYPE - Static variable in class javax.swing.text.html.HTML.Attribute
valueUnbound(SSLSessionBindingEvent) - Method in interface javax.net.ssl.SSLSessionBindingListener
This is called to notify the listener that it is being unbound from a SSLSession.
VAR - Static variable in class javax.swing.text.html.HTML.Tag
VARBINARY - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type VARBINARY.
VARCHAR - Static variable in class java.sql.Types
The constant in the Java programming language, sometimes referred to as a type code, that identifies the generic SQL type VARCHAR.
VariableElement - Interface in javax.lang.model.element
Represents a field, enum constant, method or constructor parameter, local variable, resource variable, or exception parameter.
VariableHeightLayoutCache - Class in javax.swing.tree
NOTE: This will become more open in a future release.
VariableHeightLayoutCache() - Constructor for class javax.swing.tree.VariableHeightLayoutCache
variant() - Method in class java.util.UUID
The variant number associated with this UUID.
VARIATION_SELECTORS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Variation Selectors" Unicode character block.
VARIATION_SELECTORS_SUPPLEMENT - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Variation Selectors Supplement" Unicode character block.
vcSupport - Variable in class java.beans.beancontext.BeanContextChildSupport
The VetoableChangeSupport associated with this BeanContextChildSupport.
Vector<E> - Class in java.util
The Vector class implements a growable array of objects.
Vector(int, int) - Constructor for class java.util.Vector
Constructs an empty vector with the specified initial capacity and capacity increment.
Vector(int) - Constructor for class java.util.Vector
Constructs an empty vector with the specified initial capacity and with its capacity increment equal to zero.
Vector() - Constructor for class java.util.Vector
Constructs an empty vector so that its internal data array has size 10 and its standard capacity increment is zero.
Vector(Collection<? extends E>) - Constructor for class java.util.Vector
Constructs a vector containing the elements of the specified collection, in the order they are returned by the collection's iterator.
VEDIC_EXTENSIONS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Vedic Extensions" Unicode character block.
vendorName - Variable in class javax.imageio.spi.IIOServiceProvider
A String to be returned from getVendorName, initially null.
VERBOSE - Static variable in class java.rmi.server.LogStream
Deprecated.
log level constant (verbose logging).
verify(PublicKey) - Method in class java.security.cert.Certificate
Verifies that this certificate was signed using the private key that corresponds to the specified public key.
verify(PublicKey, String) - Method in class java.security.cert.Certificate
Verifies that this certificate was signed using the private key that corresponds to the specified public key.
verify(PublicKey, Provider) - Method in class java.security.cert.Certificate
Verifies that this certificate was signed using the private key that corresponds to the specified public key.
verify(PublicKey, Provider) - Method in class java.security.cert.X509Certificate
Verifies that this certificate was signed using the private key that corresponds to the specified public key.
verify(PublicKey) - Method in class java.security.cert.X509CRL
Verifies that this CRL was signed using the private key that corresponds to the given public key.
verify(PublicKey, String) - Method in class java.security.cert.X509CRL
Verifies that this CRL was signed using the private key that corresponds to the given public key.
verify(PublicKey, Provider) - Method in class java.security.cert.X509CRL
Verifies that this CRL was signed using the private key that corresponds to the given public key.
VERIFY - Static variable in class java.security.Signature
Possible Signature.state value, signifying that this signature object has been initialized for verification.
verify(byte[]) - Method in class java.security.Signature
Verifies the passed-in signature.
verify(byte[], int, int) - Method in class java.security.Signature
Verifies the passed-in signature in the specified array of bytes, starting at the specified offset.
verify(PublicKey, Signature) - Method in class java.security.SignedObject
Verifies that the signature in this SignedObject is the valid signature for the object stored inside, with the given verification key, using the designated verification engine.
verify(String, SSLSession) - Method in interface javax.net.ssl.HostnameVerifier
Verify that the host name is an acceptable match with the server's authentication scheme.
verify(PublicKey) - Method in class javax.security.cert.Certificate
Verifies that this certificate was signed using the private key that corresponds to the specified public key.
verify(PublicKey, String) - Method in class javax.security.cert.Certificate
Verifies that this certificate was signed using the private key that corresponds to the specified public key.
verify(JComponent) - Method in class javax.swing.InputVerifier
Checks whether the JComponent's input is valid.
VERIFY - Static variable in class javax.xml.crypto.KeySelector.Purpose
A key for verifying.
verifyAttributeCategory(Object, Class<?>) - Static method in class javax.print.attribute.AttributeSetUtilities
Verify that the given object is a Class that implements the given interface, which is assumed to be interface Attribute or a subinterface thereof.
verifyAttributeValue(Object, Class<?>) - Static method in class javax.print.attribute.AttributeSetUtilities
Verify that the given object is an instance of the given interface, which is assumed to be interface Attribute or a subinterface thereof.
verifyCategoryForValue(Class<?>, Attribute) - Static method in class javax.print.attribute.AttributeSetUtilities
Verify that the given attribute category object is equal to the category of the given attribute value object.
VerifyError - Error in java.lang
Thrown when the "verifier" detects that a class file, though well formed, contains some sort of internal inconsistency or security problem.
VerifyError() - Constructor for error java.lang.VerifyError
Constructs an VerifyError with no detail message.
VerifyError(String) - Constructor for error java.lang.VerifyError
Constructs an VerifyError with the specified detail message.
verifyMIC(byte[], int, int, byte[], int, int, MessageProp) - Method in interface org.ietf.jgss.GSSContext
Verifies the cryptographic MIC, contained in the token parameter, over the supplied message.
verifyMIC(InputStream, InputStream, MessageProp) - Method in interface org.ietf.jgss.GSSContext
Uses streams to verify the cryptographic MIC, contained in the token parameter, over the supplied message.
version() - Method in class java.util.UUID
The version number associated with this UUID.
version - Variable in class javax.imageio.spi.IIOServiceProvider
A String to be returned from getVersion, initially null.
VERSION - Static variable in class javax.swing.text.html.HTML.Attribute
VERSION - Static variable in class javax.xml.transform.OutputKeys
version = nmtoken.
version - Variable in class org.omg.CORBA.ValueMember
The version of the value in which this member is defined.
versionColumnNotPseudo - Static variable in interface java.sql.DatabaseMetaData
Indicates that this version column is NOT a pseudo column.
versionColumnPseudo - Static variable in interface java.sql.DatabaseMetaData
Indicates that this version column is a pseudo column.
versionColumnUnknown - Static variable in interface java.sql.DatabaseMetaData
Indicates that this version column may or may not be a pseudo column.
VersionSpecHelper - Class in org.omg.CORBA
The Helper for VersionSpec.
VersionSpecHelper() - Constructor for class org.omg.CORBA.VersionSpecHelper
VERTICAL - Static variable in interface java.awt.Adjustable
Indicates that the Adjustable has vertical orientation.
VERTICAL - Static variable in class java.awt.GridBagConstraints
Resize the component vertically but not horizontally.
VERTICAL - Static variable in class java.awt.Scrollbar
A constant that indicates a vertical scroll bar.
VERTICAL - Static variable in class javax.accessibility.AccessibleState
Indicates the orientation of this object is vertical.
VERTICAL - Static variable in class javax.swing.JList
Indicates a vertical layout of cells, in a single column; the default layout.
VERTICAL - Static variable in interface javax.swing.SwingConstants
Vertical orientation.
VERTICAL_ALIGN - Static variable in class javax.swing.text.html.CSS.Attribute
VERTICAL_ALIGNMENT_CHANGED_PROPERTY - Static variable in class javax.swing.AbstractButton
Identifies a change in the button's vertical alignment.
VERTICAL_CENTER - Static variable in class javax.swing.SpringLayout
Specifies the vertical center of a component's bounding rectangle.
VERTICAL_FORMS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Vertical Forms" Unicode character block.
VERTICAL_SCROLLBAR - Static variable in interface javax.swing.ScrollPaneConstants
Identifies a vertical scrollbar.
VERTICAL_SCROLLBAR_ALWAYS - Static variable in interface javax.swing.ScrollPaneConstants
Used to set the vertical scroll bar policy so that vertical scrollbars are always displayed.
VERTICAL_SCROLLBAR_AS_NEEDED - Static variable in interface javax.swing.ScrollPaneConstants
Used to set the vertical scroll bar policy so that vertical scrollbars are displayed only when needed.
VERTICAL_SCROLLBAR_NEVER - Static variable in interface javax.swing.ScrollPaneConstants
Used to set the vertical scroll bar policy so that vertical scrollbars are never displayed.
VERTICAL_SCROLLBAR_POLICY - Static variable in interface javax.swing.ScrollPaneConstants
Identifies the vertical scroll bar policy property.
VERTICAL_SPLIT - Static variable in class javax.swing.JSplitPane
Vertical split indicates the Components are split along the y axis.
VERTICAL_TEXT_POSITION_CHANGED_PROPERTY - Static variable in class javax.swing.AbstractButton
Identifies a change in the button's vertical text position.
VERTICAL_WRAP - Static variable in class javax.swing.JList
Indicates a "newspaper style" layout with cells flowing vertically then horizontally.
VerticalDragController(MouseEvent) - Constructor for class javax.swing.plaf.basic.BasicSplitPaneDivider.VerticalDragController
verticalScrollBar - Variable in class javax.swing.JScrollPane
The scrollpane's vertical scrollbar child.
verticalScrollBarPolicy - Variable in class javax.swing.JScrollPane
The display policy for the vertical scrollbar.
vertThumbIcon - Static variable in class javax.swing.plaf.metal.MetalSliderUI
A default vertical thumb Icon.
vetoableChange(PropertyChangeEvent) - Method in class java.beans.beancontext.BeanContextSupport
subclasses may envelope to monitor veto child property changes.
vetoableChange(PropertyChangeEvent) - Method in interface java.beans.VetoableChangeListener
This method gets called when a constrained property is changed.
vetoableChange(PropertyChangeEvent) - Method in class java.beans.VetoableChangeListenerProxy
Forwards the property change event to the listener delegate.
VetoableChangeListener - Interface in java.beans
A VetoableChange event gets fired whenever a bean changes a "constrained" property.
VetoableChangeListenerProxy - Class in java.beans
A class which extends the EventListenerProxy specifically for adding a VetoableChangeListener with a "constrained" property.
VetoableChangeListenerProxy(String, VetoableChangeListener) - Constructor for class java.beans.VetoableChangeListenerProxy
Constructor which binds the VetoableChangeListener to a specific property.
VetoableChangeSupport - Class in java.beans
This is a utility class that can be used by beans that support constrained properties.
VetoableChangeSupport(Object) - Constructor for class java.beans.VetoableChangeSupport
Constructs a VetoableChangeSupport object.
View - Class in javax.swing.text
A very important part of the text package is the View class.
View(Element) - Constructor for class javax.swing.text.View
Creates a new View object.
ViewFactory - Interface in javax.swing.text
A factory to create a view of some portion of document subject.
ViewListener() - Constructor for class javax.swing.JViewport.ViewListener
viewMenuIcon - Variable in class javax.swing.plaf.basic.BasicFileChooserUI
VIEWPORT - Static variable in class javax.accessibility.AccessibleRole
An object usually used in a scroll pane.
viewPort - Variable in class javax.swing.JScrollPane.AccessibleJScrollPane
viewport - Variable in class javax.swing.JScrollPane
The scrollpane's viewport child.
VIEWPORT - Static variable in class javax.swing.plaf.synth.Region
Viewport region.
VIEWPORT - Static variable in interface javax.swing.ScrollPaneConstants
Identifies a "viewport" or display area, within which scrolled contents are visible.
viewport - Variable in class javax.swing.ScrollPaneLayout
The scrollpane's viewport child.
ViewportChangeHandler() - Constructor for class javax.swing.plaf.basic.BasicScrollPaneUI.ViewportChangeHandler
viewportChangeListener - Variable in class javax.swing.plaf.basic.BasicScrollPaneUI
ViewportLayout - Class in javax.swing
The default layout manager for JViewport.
ViewportLayout() - Constructor for class javax.swing.ViewportLayout
ViewportUI - Class in javax.swing.plaf
Pluggable look and feel interface for JViewport.
ViewportUI() - Constructor for class javax.swing.plaf.ViewportUI
viewToModel(JTextComponent, Point) - Method in class javax.swing.plaf.basic.BasicTextUI
Converts the given place in the view coordinate system to the nearest representative location in the model.
viewToModel(JTextComponent, Point, Position.Bias[]) - Method in class javax.swing.plaf.basic.BasicTextUI
Converts the given place in the view coordinate system to the nearest representative location in the model.
viewToModel(JTextComponent, Point) - Method in class javax.swing.plaf.multi.MultiTextUI
Invokes the viewToModel method on each UI handled by this object.
viewToModel(JTextComponent, Point, Position.Bias[]) - Method in class javax.swing.plaf.multi.MultiTextUI
Invokes the viewToModel method on each UI handled by this object.
viewToModel(JTextComponent, Point) - Method in class javax.swing.plaf.TextUI
Converts the given place in the view coordinate system to the nearest representative location in the model.
viewToModel(JTextComponent, Point, Position.Bias[]) - Method in class javax.swing.plaf.TextUI
Provides a mapping from the view coordinate space to the logical coordinate space of the model.
viewToModel(float, float, Shape, Position.Bias[]) - Method in class javax.swing.text.AsyncBoxView
Provides a mapping from the view coordinate space to the logical coordinate space of the model.
viewToModel(float, float, Shape, Position.Bias[]) - Method in class javax.swing.text.BoxView
Provides a mapping from the view coordinate space to the logical coordinate space of the model.
viewToModel(float, float, Shape, Position.Bias[]) - Method in class javax.swing.text.ComponentView
Provides a mapping from the view coordinate space to the logical coordinate space of the model.
viewToModel(float, float, Shape, Position.Bias[]) - Method in class javax.swing.text.CompositeView
Provides a mapping from the view coordinate space to the logical coordinate space of the model.
viewToModel(float, float, Shape, Position.Bias[]) - Method in class javax.swing.text.FieldView
Provides a mapping from the view coordinate space to the logical coordinate space of the model.
viewToModel(GlyphView, float, float, Shape, Position.Bias[]) - Method in class javax.swing.text.GlyphView.GlyphPainter
Provides a mapping from the view coordinate space to the logical coordinate space of the model.
viewToModel(float, float, Shape, Position.Bias[]) - Method in class javax.swing.text.GlyphView
Provides a mapping from the view coordinate space to the logical coordinate space of the model.
viewToModel(float, float, Shape, Position.Bias[]) - Method in class javax.swing.text.html.ImageView
Provides a mapping from the view coordinate space to the logical coordinate space of the model.
viewToModel(float, float, Shape, Position.Bias[]) - Method in class javax.swing.text.IconView
Provides a mapping from the view coordinate space to the logical coordinate space of the model.
viewToModel(Point) - Method in class javax.swing.text.JTextComponent
Converts the given place in the view coordinate system to the nearest representative location in the model.
viewToModel(float, float, Shape, Position.Bias[]) - Method in class javax.swing.text.PasswordView
Provides a mapping from the view coordinate space to the logical coordinate space of the model.
viewToModel(float, float, Shape, Position.Bias[]) - Method in class javax.swing.text.PlainView
Provides a mapping from the view coordinate space to the logical coordinate space of the model.
viewToModel(float, float, Shape, Position.Bias[]) - Method in class javax.swing.text.View
Provides a mapping from the view coordinate space to the logical coordinate space of the model.
viewToModel(float, float, Shape) - Method in class javax.swing.text.View
Deprecated.
VirtualMachineError - Error in java.lang
Thrown to indicate that the Java Virtual Machine is broken or has run out of resources necessary for it to continue operating.
VirtualMachineError() - Constructor for error java.lang.VirtualMachineError
Constructs a VirtualMachineError with no detail message.
VirtualMachineError(String) - Constructor for error java.lang.VirtualMachineError
Constructs a VirtualMachineError with the specified detail message.
VirtualMachineError(String, Throwable) - Constructor for error java.lang.VirtualMachineError
Constructs a VirtualMachineError with the specified detail message and cause.
VirtualMachineError(Throwable) - Constructor for error java.lang.VirtualMachineError
Constructs an a VirtualMachineError with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
Visibility - Interface in java.beans
Under some circumstances a bean may be run on servers where a GUI is not available.
VisibilityHelper - Class in org.omg.CORBA
The Helper for Visibility.
VisibilityHelper() - Constructor for class org.omg.CORBA.VisibilityHelper
VISIBLE - Static variable in class javax.accessibility.AccessibleState
Indicates this object is visible.
VISIBLE_ROW_COUNT_PROPERTY - Static variable in class javax.swing.JTree
Bound property name for visibleRowCount.
visibleRowCount - Variable in class javax.swing.JTree
Number of rows to make visible at one time.
visit(AnnotationValue, P) - Method in interface javax.lang.model.element.AnnotationValueVisitor
Visits an annotation value.
visit(AnnotationValue) - Method in interface javax.lang.model.element.AnnotationValueVisitor
A convenience method equivalent to v.visit(av, null).
visit(Element, P) - Method in interface javax.lang.model.element.ElementVisitor
Visits an element.
visit(Element) - Method in interface javax.lang.model.element.ElementVisitor
A convenience method equivalent to v.visit(e, null).
visit(TypeMirror, P) - Method in interface javax.lang.model.type.TypeVisitor
Visits a type.
visit(TypeMirror) - Method in interface javax.lang.model.type.TypeVisitor
A convenience method equivalent to v.visit(t, null).
visit(AnnotationValue, P) - Method in class javax.lang.model.util.AbstractAnnotationValueVisitor6
Visits an annotation value as if by passing itself to that value's accept.
visit(AnnotationValue) - Method in class javax.lang.model.util.AbstractAnnotationValueVisitor6
Visits an annotation value as if by passing itself to that value's accept method passing null for the additional parameter.
visit(Element, P) - Method in class javax.lang.model.util.AbstractElementVisitor6
Visits any program element as if by passing itself to that element's accept method.
visit(Element) - Method in class javax.lang.model.util.AbstractElementVisitor6
Visits any program element as if by passing itself to that element's accept method and passing null for the additional parameter.
visit(TypeMirror, P) - Method in class javax.lang.model.util.AbstractTypeVisitor6
Visits any type mirror as if by passing itself to that type mirror's accept method.
visit(TypeMirror) - Method in class javax.lang.model.util.AbstractTypeVisitor6
Visits any type mirror as if by passing itself to that type mirror's accept method and passing null for the additional parameter.
visitAnnotation(AnnotationMirror, P) - Method in interface javax.lang.model.element.AnnotationValueVisitor
Visits an annotation value in an annotation.
visitAnnotation(AnnotationMirror, P) - Method in class javax.lang.model.util.SimpleAnnotationValueVisitor6
Visits an annotation value in an annotation.
visitArray(List<? extends AnnotationValue>, P) - Method in interface javax.lang.model.element.AnnotationValueVisitor
Visits an array value in an annotation.
visitArray(ArrayType, P) - Method in interface javax.lang.model.type.TypeVisitor
Visits an array type.
visitArray(List<? extends AnnotationValue>, P) - Method in class javax.lang.model.util.SimpleAnnotationValueVisitor6
Visits an array value in an annotation.
visitArray(ArrayType, P) - Method in class javax.lang.model.util.SimpleTypeVisitor6
Visits an array type.
visitBoolean(boolean, P) - Method in interface javax.lang.model.element.AnnotationValueVisitor
Visits a boolean value in an annotation.
visitBoolean(boolean, P) - Method in class javax.lang.model.util.SimpleAnnotationValueVisitor6
Visits a boolean value in an annotation.
visitByte(byte, P) - Method in interface javax.lang.model.element.AnnotationValueVisitor
Visits a byte value in an annotation.
visitByte(byte, P) - Method in class javax.lang.model.util.SimpleAnnotationValueVisitor6
Visits a byte value in an annotation.
visitChar(char, P) - Method in interface javax.lang.model.element.AnnotationValueVisitor
Visits a char value in an annotation.
visitChar(char, P) - Method in class javax.lang.model.util.SimpleAnnotationValueVisitor6
Visits a char value in an annotation.
visitDeclared(DeclaredType, P) - Method in interface javax.lang.model.type.TypeVisitor
Visits a declared type.
visitDeclared(DeclaredType, P) - Method in class javax.lang.model.util.SimpleTypeVisitor6
Visits a declared type.
visitDouble(double, P) - Method in interface javax.lang.model.element.AnnotationValueVisitor
Visits a double value in an annotation.
visitDouble(double, P) - Method in class javax.lang.model.util.SimpleAnnotationValueVisitor6
Visits a double value in an annotation.
visitEnumConstant(VariableElement, P) - Method in interface javax.lang.model.element.AnnotationValueVisitor
Visits an enum value in an annotation.
visitEnumConstant(VariableElement, P) - Method in class javax.lang.model.util.SimpleAnnotationValueVisitor6
Visits an enum value in an annotation.
visitError(ErrorType, P) - Method in interface javax.lang.model.type.TypeVisitor
Visits an error type.
visitError(ErrorType, P) - Method in class javax.lang.model.util.SimpleTypeVisitor6
Visits an error type.
visitExecutable(ExecutableElement, P) - Method in interface javax.lang.model.element.ElementVisitor
Visits an executable element.
visitExecutable(ExecutableType, P) - Method in interface javax.lang.model.type.TypeVisitor
Visits an executable type.
visitExecutable(ExecutableElement, P) - Method in class javax.lang.model.util.ElementKindVisitor6
Visits an executable element, dispatching to the visit method for the specific kind of executable, CONSTRUCTOR, INSTANCE_INIT, METHOD, or STATIC_INIT.
visitExecutable(ExecutableElement, P) - Method in class javax.lang.model.util.ElementScanner6
Visits an executable element.
visitExecutable(ExecutableElement, P) - Method in class javax.lang.model.util.SimpleElementVisitor6
Visits an executable element.
visitExecutable(ExecutableType, P) - Method in class javax.lang.model.util.SimpleTypeVisitor6
Visits an executable type.
visitExecutableAsConstructor(ExecutableElement, P) - Method in class javax.lang.model.util.ElementKindVisitor6
Visits a CONSTRUCTOR executable element by calling defaultAction.
visitExecutableAsInstanceInit(ExecutableElement, P) - Method in class javax.lang.model.util.ElementKindVisitor6
Visits an INSTANCE_INIT executable element by calling defaultAction.
visitExecutableAsMethod(ExecutableElement, P) - Method in class javax.lang.model.util.ElementKindVisitor6
Visits a METHOD executable element by calling defaultAction.
visitExecutableAsStaticInit(ExecutableElement, P) - Method in class javax.lang.model.util.ElementKindVisitor6
Visits a STATIC_INIT executable element by calling defaultAction.
visitFile(T, BasicFileAttributes) - Method in interface java.nio.file.FileVisitor
Invoked for a file in a directory.
visitFile(T, BasicFileAttributes) - Method in class java.nio.file.SimpleFileVisitor
Invoked for a file in a directory.
visitFileFailed(T, IOException) - Method in interface java.nio.file.FileVisitor
Invoked for a file that could not be visited.
visitFileFailed(T, IOException) - Method in class java.nio.file.SimpleFileVisitor
Invoked for a file that could not be visited.
visitFloat(float, P) - Method in interface javax.lang.model.element.AnnotationValueVisitor
Visits a float value in an annotation.
visitFloat(float, P) - Method in class javax.lang.model.util.SimpleAnnotationValueVisitor6
Visits a float value in an annotation.
visitInt(int, P) - Method in interface javax.lang.model.element.AnnotationValueVisitor
Visits an int value in an annotation.
visitInt(int, P) - Method in class javax.lang.model.util.SimpleAnnotationValueVisitor6
Visits an int value in an annotation.
visitIntersection(IntersectionType, P) - Method in interface javax.lang.model.type.TypeVisitor
Visits an intersection type.
visitIntersection(IntersectionType, P) - Method in class javax.lang.model.util.AbstractTypeVisitor6
Visits an IntersectionType element by calling visitUnknown.
visitIntersection(IntersectionType, P) - Method in class javax.lang.model.util.AbstractTypeVisitor8
Visits an IntersectionType in a manner defined by a subclass.
visitIntersection(IntersectionType, P) - Method in class javax.lang.model.util.SimpleTypeVisitor8
This implementation visits an IntersectionType by calling defaultAction.
visitIntersection(IntersectionType, P) - Method in class javax.lang.model.util.TypeKindVisitor8
This implementation visits an IntersectionType by calling defaultAction.
visitLong(long, P) - Method in interface javax.lang.model.element.AnnotationValueVisitor
Visits a long value in an annotation.
visitLong(long, P) - Method in class javax.lang.model.util.SimpleAnnotationValueVisitor6
Visits a long value in an annotation.
visitNoType(NoType, P) - Method in interface javax.lang.model.type.TypeVisitor
Visits a NoType instance.
visitNoType(NoType, P) - Method in class javax.lang.model.util.SimpleTypeVisitor6
Visits a NoType instance.
visitNoType(NoType, P) - Method in class javax.lang.model.util.TypeKindVisitor6
Visits a NoType instance, dispatching to the visit method for the specific kind of pseudo-type: VOID, PACKAGE, or NONE.
visitNoTypeAsNone(NoType, P) - Method in class javax.lang.model.util.TypeKindVisitor6
Visits a NONE pseudo-type by calling defaultAction.
visitNoTypeAsPackage(NoType, P) - Method in class javax.lang.model.util.TypeKindVisitor6
Visits a PACKAGE pseudo-type by calling defaultAction.
visitNoTypeAsVoid(NoType, P) - Method in class javax.lang.model.util.TypeKindVisitor6
Visits a VOID pseudo-type by calling defaultAction.
visitNull(NullType, P) - Method in interface javax.lang.model.type.TypeVisitor
Visits the null type.
visitNull(NullType, P) - Method in class javax.lang.model.util.SimpleTypeVisitor6
Visits the null type.
visitPackage(PackageElement, P) - Method in interface javax.lang.model.element.ElementVisitor
Visits a package element.
visitPackage(PackageElement, P) - Method in class javax.lang.model.util.ElementKindVisitor6
Visits a package element.
visitPackage(PackageElement, P) - Method in class javax.lang.model.util.ElementScanner6
Visits a package element.
visitPackage(PackageElement, P) - Method in class javax.lang.model.util.SimpleElementVisitor6
Visits a package element.
visitPrimitive(PrimitiveType, P) - Method in interface javax.lang.model.type.TypeVisitor
Visits a primitive type.
visitPrimitive(PrimitiveType, P) - Method in class javax.lang.model.util.SimpleTypeVisitor6
Visits a primitive type.
visitPrimitive(PrimitiveType, P) - Method in class javax.lang.model.util.TypeKindVisitor6
Visits a primitive type, dispatching to the visit method for the specific kind of primitive type: BOOLEAN, BYTE, etc.
visitPrimitiveAsBoolean(PrimitiveType, P) - Method in class javax.lang.model.util.TypeKindVisitor6
Visits a BOOLEAN primitive type by calling defaultAction.
visitPrimitiveAsByte(PrimitiveType, P) - Method in class javax.lang.model.util.TypeKindVisitor6
Visits a BYTE primitive type by calling defaultAction.
visitPrimitiveAsChar(PrimitiveType, P) - Method in class javax.lang.model.util.TypeKindVisitor6
Visits a CHAR primitive type by calling defaultAction.
visitPrimitiveAsDouble(PrimitiveType, P) - Method in class javax.lang.model.util.TypeKindVisitor6
Visits a DOUBLE primitive type by calling defaultAction.
visitPrimitiveAsFloat(PrimitiveType, P) - Method in class javax.lang.model.util.TypeKindVisitor6
Visits a FLOAT primitive type by calling defaultAction.
visitPrimitiveAsInt(PrimitiveType, P) - Method in class javax.lang.model.util.TypeKindVisitor6
Visits an INT primitive type by calling defaultAction.
visitPrimitiveAsLong(PrimitiveType, P) - Method in class javax.lang.model.util.TypeKindVisitor6
Visits a LONG primitive type by calling defaultAction.
visitPrimitiveAsShort(PrimitiveType, P) - Method in class javax.lang.model.util.TypeKindVisitor6
Visits a SHORT primitive type by calling defaultAction.
visitShort(short, P) - Method in interface javax.lang.model.element.AnnotationValueVisitor
Visits a short value in an annotation.
visitShort(short, P) - Method in class javax.lang.model.util.SimpleAnnotationValueVisitor6
Visits a short value in an annotation.
visitString(String, P) - Method in interface javax.lang.model.element.AnnotationValueVisitor
Visits a string value in an annotation.
visitString(String, P) - Method in class javax.lang.model.util.SimpleAnnotationValueVisitor6
Visits a string value in an annotation.
visitType(TypeMirror, P) - Method in interface javax.lang.model.element.AnnotationValueVisitor
Visits a type value in an annotation.
visitType(TypeElement, P) - Method in interface javax.lang.model.element.ElementVisitor
Visits a type element.
visitType(TypeElement, P) - Method in class javax.lang.model.util.ElementKindVisitor6
Visits a type element, dispatching to the visit method for the specific kind of type, ANNOTATION_TYPE, CLASS, ENUM, or INTERFACE.
visitType(TypeElement, P) - Method in class javax.lang.model.util.ElementScanner6
Visits a type element.
visitType(TypeMirror, P) - Method in class javax.lang.model.util.SimpleAnnotationValueVisitor6
Visits a type value in an annotation.
visitType(TypeElement, P) - Method in class javax.lang.model.util.SimpleElementVisitor6
Visits a type element.
visitTypeAsAnnotationType(TypeElement, P) - Method in class javax.lang.model.util.ElementKindVisitor6
Visits an ANNOTATION_TYPE type element by calling defaultAction.
visitTypeAsClass(TypeElement, P) - Method in class javax.lang.model.util.ElementKindVisitor6
Visits a CLASS type element by calling defaultAction.
visitTypeAsEnum(TypeElement, P) - Method in class javax.lang.model.util.ElementKindVisitor6
Visits an ENUM type element by calling defaultAction.
visitTypeAsInterface(TypeElement, P) - Method in class javax.lang.model.util.ElementKindVisitor6
Visits an INTERFACE type element by calling defaultAction.
visitTypeParameter(TypeParameterElement, P) - Method in interface javax.lang.model.element.ElementVisitor
Visits a type parameter element.
visitTypeParameter(TypeParameterElement, P) - Method in class javax.lang.model.util.ElementKindVisitor6
Visits a type parameter element.
visitTypeParameter(TypeParameterElement, P) - Method in class javax.lang.model.util.ElementScanner6
Visits a type parameter element.
visitTypeParameter(TypeParameterElement, P) - Method in class javax.lang.model.util.SimpleElementVisitor6
Visits a type parameter element.
visitTypeVariable(TypeVariable, P) - Method in interface javax.lang.model.type.TypeVisitor
Visits a type variable.
visitTypeVariable(TypeVariable, P) - Method in class javax.lang.model.util.SimpleTypeVisitor6
Visits a type variable.
visitUnion(UnionType, P) - Method in interface javax.lang.model.type.TypeVisitor
Visits a union type.
visitUnion(UnionType, P) - Method in class javax.lang.model.util.AbstractTypeVisitor6
Visits a UnionType element by calling visitUnknown.
visitUnion(UnionType, P) - Method in class javax.lang.model.util.AbstractTypeVisitor7
Visits a UnionType in a manner defined by a subclass.
visitUnion(UnionType, P) - Method in class javax.lang.model.util.SimpleTypeVisitor7
This implementation visits a UnionType by calling defaultAction.
visitUnion(UnionType, P) - Method in class javax.lang.model.util.TypeKindVisitor7
This implementation visits a UnionType by calling defaultAction.
visitUnknown(AnnotationValue, P) - Method in interface javax.lang.model.element.AnnotationValueVisitor
Visits an unknown kind of annotation value.
visitUnknown(Element, P) - Method in interface javax.lang.model.element.ElementVisitor
Visits an unknown kind of element.
visitUnknown(TypeMirror, P) - Method in interface javax.lang.model.type.TypeVisitor
Visits an unknown kind of type.
visitUnknown(AnnotationValue, P) - Method in class javax.lang.model.util.AbstractAnnotationValueVisitor6
Visits an unknown kind of annotation value.
visitUnknown(Element, P) - Method in class javax.lang.model.util.AbstractElementVisitor6
Visits an unknown kind of element.
visitUnknown(TypeMirror, P) - Method in class javax.lang.model.util.AbstractTypeVisitor6
Visits an unknown kind of type.
visitVariable(VariableElement, P) - Method in interface javax.lang.model.element.ElementVisitor
Visits a variable element.
visitVariable(VariableElement, P) - Method in class javax.lang.model.util.ElementKindVisitor6
Visits a variable element, dispatching to the visit method for the specific kind of variable, ENUM_CONSTANT, EXCEPTION_PARAMETER, FIELD, LOCAL_VARIABLE, PARAMETER, or RESOURCE_VARIABLE.
visitVariable(VariableElement, P) - Method in class javax.lang.model.util.ElementScanner6
Visits a variable element.
visitVariable(VariableElement, P) - Method in class javax.lang.model.util.ElementScanner7
This implementation scans the enclosed elements.
visitVariable(VariableElement, P) - Method in class javax.lang.model.util.SimpleElementVisitor6
Visits a variable element.
visitVariable(VariableElement, P) - Method in class javax.lang.model.util.SimpleElementVisitor7
This implementation calls defaultAction.
visitVariableAsEnumConstant(VariableElement, P) - Method in class javax.lang.model.util.ElementKindVisitor6
Visits an ENUM_CONSTANT variable element by calling defaultAction.
visitVariableAsExceptionParameter(VariableElement, P) - Method in class javax.lang.model.util.ElementKindVisitor6
Visits an EXCEPTION_PARAMETER variable element by calling defaultAction.
visitVariableAsField(VariableElement, P) - Method in class javax.lang.model.util.ElementKindVisitor6
Visits a FIELD variable element by calling defaultAction.
visitVariableAsLocalVariable(VariableElement, P) - Method in class javax.lang.model.util.ElementKindVisitor6
Visits a LOCAL_VARIABLE variable element by calling defaultAction.
visitVariableAsParameter(VariableElement, P) - Method in class javax.lang.model.util.ElementKindVisitor6
Visits a PARAMETER variable element by calling defaultAction.
visitVariableAsResourceVariable(VariableElement, P) - Method in class javax.lang.model.util.ElementKindVisitor6
Visits a RESOURCE_VARIABLE variable element by calling visitUnknown.
visitVariableAsResourceVariable(VariableElement, P) - Method in class javax.lang.model.util.ElementKindVisitor7
Visits a RESOURCE_VARIABLE variable element by calling defaultAction.
visitWildcard(WildcardType, P) - Method in interface javax.lang.model.type.TypeVisitor
Visits a wildcard type.
visitWildcard(WildcardType, P) - Method in class javax.lang.model.util.SimpleTypeVisitor6
Visits a wildcard type.
VK_0 - Static variable in class java.awt.event.KeyEvent
VK_0 thru VK_9 are the same as ASCII '0' thru '9' (0x30 - 0x39)
VK_1 - Static variable in class java.awt.event.KeyEvent
VK_2 - Static variable in class java.awt.event.KeyEvent
VK_3 - Static variable in class java.awt.event.KeyEvent
VK_4 - Static variable in class java.awt.event.KeyEvent
VK_5 - Static variable in class java.awt.event.KeyEvent
VK_6 - Static variable in class java.awt.event.KeyEvent
VK_7 - Static variable in class java.awt.event.KeyEvent
VK_8 - Static variable in class java.awt.event.KeyEvent
VK_9 - Static variable in class java.awt.event.KeyEvent
VK_A - Static variable in class java.awt.event.KeyEvent
VK_A thru VK_Z are the same as ASCII 'A' thru 'Z' (0x41 - 0x5A)
VK_ACCEPT - Static variable in class java.awt.event.KeyEvent
Constant for the Accept or Commit function key.
VK_ADD - Static variable in class java.awt.event.KeyEvent
VK_AGAIN - Static variable in class java.awt.event.KeyEvent
VK_ALL_CANDIDATES - Static variable in class java.awt.event.KeyEvent
Constant for the All Candidates function key.
VK_ALPHANUMERIC - Static variable in class java.awt.event.KeyEvent
Constant for the Alphanumeric function key.
VK_ALT - Static variable in class java.awt.event.KeyEvent
VK_ALT_GRAPH - Static variable in class java.awt.event.KeyEvent
Constant for the AltGraph function key.
VK_AMPERSAND - Static variable in class java.awt.event.KeyEvent
VK_ASTERISK - Static variable in class java.awt.event.KeyEvent
VK_AT - Static variable in class java.awt.event.KeyEvent
Constant for the "@" key.
VK_B - Static variable in class java.awt.event.KeyEvent
VK_BACK_QUOTE - Static variable in class java.awt.event.KeyEvent
VK_BACK_SLASH - Static variable in class java.awt.event.KeyEvent
Constant for the back slash key, "\"
VK_BACK_SPACE - Static variable in class java.awt.event.KeyEvent
VK_BEGIN - Static variable in class java.awt.event.KeyEvent
Constant for the Begin key.
VK_BRACELEFT - Static variable in class java.awt.event.KeyEvent
VK_BRACERIGHT - Static variable in class java.awt.event.KeyEvent
VK_C - Static variable in class java.awt.event.KeyEvent
VK_CANCEL - Static variable in class java.awt.event.KeyEvent
VK_CAPS_LOCK - Static variable in class java.awt.event.KeyEvent
VK_CIRCUMFLEX - Static variable in class java.awt.event.KeyEvent
Constant for the "^" key.
VK_CLEAR - Static variable in class java.awt.event.KeyEvent
VK_CLOSE_BRACKET - Static variable in class java.awt.event.KeyEvent
Constant for the close bracket key, "]"
VK_CODE_INPUT - Static variable in class java.awt.event.KeyEvent
Constant for the Code Input function key.
VK_COLON - Static variable in class java.awt.event.KeyEvent
Constant for the ":" key.
VK_COMMA - Static variable in class java.awt.event.KeyEvent
Constant for the comma key, ","
VK_COMPOSE - Static variable in class java.awt.event.KeyEvent
Constant for the Compose function key.
VK_CONTEXT_MENU - Static variable in class java.awt.event.KeyEvent
Constant for the Microsoft Windows Context Menu key.
VK_CONTROL - Static variable in class java.awt.event.KeyEvent
VK_CONVERT - Static variable in class java.awt.event.KeyEvent
Constant for the Convert function key.
VK_COPY - Static variable in class java.awt.event.KeyEvent
VK_CUT - Static variable in class java.awt.event.KeyEvent
VK_D - Static variable in class java.awt.event.KeyEvent
VK_DEAD_ABOVEDOT - Static variable in class java.awt.event.KeyEvent
VK_DEAD_ABOVERING - Static variable in class java.awt.event.KeyEvent
VK_DEAD_ACUTE - Static variable in class java.awt.event.KeyEvent
VK_DEAD_BREVE - Static variable in class java.awt.event.KeyEvent
VK_DEAD_CARON - Static variable in class java.awt.event.KeyEvent
VK_DEAD_CEDILLA - Static variable in class java.awt.event.KeyEvent
VK_DEAD_CIRCUMFLEX - Static variable in class java.awt.event.KeyEvent
VK_DEAD_DIAERESIS - Static variable in class java.awt.event.KeyEvent
VK_DEAD_DOUBLEACUTE - Static variable in class java.awt.event.KeyEvent
VK_DEAD_GRAVE - Static variable in class java.awt.event.KeyEvent
VK_DEAD_IOTA - Static variable in class java.awt.event.KeyEvent
VK_DEAD_MACRON - Static variable in class java.awt.event.KeyEvent
VK_DEAD_OGONEK - Static variable in class java.awt.event.KeyEvent
VK_DEAD_SEMIVOICED_SOUND - Static variable in class java.awt.event.KeyEvent
VK_DEAD_TILDE - Static variable in class java.awt.event.KeyEvent
VK_DEAD_VOICED_SOUND - Static variable in class java.awt.event.KeyEvent
VK_DECIMAL - Static variable in class java.awt.event.KeyEvent
VK_DELETE - Static variable in class java.awt.event.KeyEvent
VK_DIVIDE - Static variable in class java.awt.event.KeyEvent
VK_DOLLAR - Static variable in class java.awt.event.KeyEvent
Constant for the "$" key.
VK_DOWN - Static variable in class java.awt.event.KeyEvent
Constant for the non-numpad down arrow key.
VK_E - Static variable in class java.awt.event.KeyEvent
VK_END - Static variable in class java.awt.event.KeyEvent
VK_ENTER - Static variable in class java.awt.event.KeyEvent
VK_EQUALS - Static variable in class java.awt.event.KeyEvent
Constant for the equals key, "="
VK_ESCAPE - Static variable in class java.awt.event.KeyEvent
VK_EURO_SIGN - Static variable in class java.awt.event.KeyEvent
Constant for the Euro currency sign key.
VK_EXCLAMATION_MARK - Static variable in class java.awt.event.KeyEvent
Constant for the "!" key.
VK_F - Static variable in class java.awt.event.KeyEvent
VK_F1 - Static variable in class java.awt.event.KeyEvent
Constant for the F1 function key.
VK_F10 - Static variable in class java.awt.event.KeyEvent
Constant for the F10 function key.
VK_F11 - Static variable in class java.awt.event.KeyEvent
Constant for the F11 function key.
VK_F12 - Static variable in class java.awt.event.KeyEvent
Constant for the F12 function key.
VK_F13 - Static variable in class java.awt.event.KeyEvent
Constant for the F13 function key.
VK_F14 - Static variable in class java.awt.event.KeyEvent
Constant for the F14 function key.
VK_F15 - Static variable in class java.awt.event.KeyEvent
Constant for the F15 function key.
VK_F16 - Static variable in class java.awt.event.KeyEvent
Constant for the F16 function key.
VK_F17 - Static variable in class java.awt.event.KeyEvent
Constant for the F17 function key.
VK_F18 - Static variable in class java.awt.event.KeyEvent
Constant for the F18 function key.
VK_F19 - Static variable in class java.awt.event.KeyEvent
Constant for the F19 function key.
VK_F2 - Static variable in class java.awt.event.KeyEvent
Constant for the F2 function key.
VK_F20 - Static variable in class java.awt.event.KeyEvent
Constant for the F20 function key.
VK_F21 - Static variable in class java.awt.event.KeyEvent
Constant for the F21 function key.
VK_F22 - Static variable in class java.awt.event.KeyEvent
Constant for the F22 function key.
VK_F23 - Static variable in class java.awt.event.KeyEvent
Constant for the F23 function key.
VK_F24 - Static variable in class java.awt.event.KeyEvent
Constant for the F24 function key.
VK_F3 - Static variable in class java.awt.event.KeyEvent
Constant for the F3 function key.
VK_F4 - Static variable in class java.awt.event.KeyEvent
Constant for the F4 function key.
VK_F5 - Static variable in class java.awt.event.KeyEvent
Constant for the F5 function key.
VK_F6 - Static variable in class java.awt.event.KeyEvent
Constant for the F6 function key.
VK_F7 - Static variable in class java.awt.event.KeyEvent
Constant for the F7 function key.
VK_F8 - Static variable in class java.awt.event.KeyEvent
Constant for the F8 function key.
VK_F9 - Static variable in class java.awt.event.KeyEvent
Constant for the F9 function key.
VK_FINAL - Static variable in class java.awt.event.KeyEvent
VK_FIND - Static variable in class java.awt.event.KeyEvent
VK_FULL_WIDTH - Static variable in class java.awt.event.KeyEvent
Constant for the Full-Width Characters function key.
VK_G - Static variable in class java.awt.event.KeyEvent
VK_GREATER - Static variable in class java.awt.event.KeyEvent
VK_H - Static variable in class java.awt.event.KeyEvent
VK_HALF_WIDTH - Static variable in class java.awt.event.KeyEvent
Constant for the Half-Width Characters function key.
VK_HELP - Static variable in class java.awt.event.KeyEvent
VK_HIRAGANA - Static variable in class java.awt.event.KeyEvent
Constant for the Hiragana function key.
VK_HOME - Static variable in class java.awt.event.KeyEvent
VK_I - Static variable in class java.awt.event.KeyEvent
VK_INPUT_METHOD_ON_OFF - Static variable in class java.awt.event.KeyEvent
Constant for the input method on/off key.
VK_INSERT - Static variable in class java.awt.event.KeyEvent
VK_INVERTED_EXCLAMATION_MARK - Static variable in class java.awt.event.KeyEvent
Constant for the inverted exclamation mark key.
VK_J - Static variable in class java.awt.event.KeyEvent
VK_JAPANESE_HIRAGANA - Static variable in class java.awt.event.KeyEvent
Constant for the Japanese-Hiragana function key.
VK_JAPANESE_KATAKANA - Static variable in class java.awt.event.KeyEvent
Constant for the Japanese-Katakana function key.
VK_JAPANESE_ROMAN - Static variable in class java.awt.event.KeyEvent
Constant for the Japanese-Roman function key.
VK_K - Static variable in class java.awt.event.KeyEvent
VK_KANA - Static variable in class java.awt.event.KeyEvent
VK_KANA_LOCK - Static variable in class java.awt.event.KeyEvent
Constant for the locking Kana function key.
VK_KANJI - Static variable in class java.awt.event.KeyEvent
VK_KATAKANA - Static variable in class java.awt.event.KeyEvent
Constant for the Katakana function key.
VK_KP_DOWN - Static variable in class java.awt.event.KeyEvent
Constant for the numeric keypad down arrow key.
VK_KP_LEFT - Static variable in class java.awt.event.KeyEvent
Constant for the numeric keypad left arrow key.
VK_KP_RIGHT - Static variable in class java.awt.event.KeyEvent
Constant for the numeric keypad right arrow key.
VK_KP_UP - Static variable in class java.awt.event.KeyEvent
Constant for the numeric keypad up arrow key.
VK_L - Static variable in class java.awt.event.KeyEvent
VK_LEFT - Static variable in class java.awt.event.KeyEvent
Constant for the non-numpad left arrow key.
VK_LEFT_PARENTHESIS - Static variable in class java.awt.event.KeyEvent
Constant for the "(" key.
VK_LESS - Static variable in class java.awt.event.KeyEvent
VK_M - Static variable in class java.awt.event.KeyEvent
VK_META - Static variable in class java.awt.event.KeyEvent
VK_MINUS - Static variable in class java.awt.event.KeyEvent
Constant for the minus key, "-"
VK_MODECHANGE - Static variable in class java.awt.event.KeyEvent
VK_MULTIPLY - Static variable in class java.awt.event.KeyEvent
VK_N - Static variable in class java.awt.event.KeyEvent
VK_NONCONVERT - Static variable in class java.awt.event.KeyEvent
Constant for the Don't Convert function key.
VK_NUM_LOCK - Static variable in class java.awt.event.KeyEvent
VK_NUMBER_SIGN - Static variable in class java.awt.event.KeyEvent
Constant for the "#" key.
VK_NUMPAD0 - Static variable in class java.awt.event.KeyEvent
VK_NUMPAD1 - Static variable in class java.awt.event.KeyEvent
VK_NUMPAD2 - Static variable in class java.awt.event.KeyEvent
VK_NUMPAD3 - Static variable in class java.awt.event.KeyEvent
VK_NUMPAD4 - Static variable in class java.awt.event.KeyEvent
VK_NUMPAD5 - Static variable in class java.awt.event.KeyEvent
VK_NUMPAD6 - Static variable in class java.awt.event.KeyEvent
VK_NUMPAD7 - Static variable in class java.awt.event.KeyEvent
VK_NUMPAD8 - Static variable in class java.awt.event.KeyEvent
VK_NUMPAD9 - Static variable in class java.awt.event.KeyEvent
VK_O - Static variable in class java.awt.event.KeyEvent
VK_OPEN_BRACKET - Static variable in class java.awt.event.KeyEvent
Constant for the open bracket key, "["
VK_P - Static variable in class java.awt.event.KeyEvent
VK_PAGE_DOWN - Static variable in class java.awt.event.KeyEvent
VK_PAGE_UP - Static variable in class java.awt.event.KeyEvent
VK_PASTE - Static variable in class java.awt.event.KeyEvent
VK_PAUSE - Static variable in class java.awt.event.KeyEvent
VK_PERIOD - Static variable in class java.awt.event.KeyEvent
Constant for the period key, "."
VK_PLUS - Static variable in class java.awt.event.KeyEvent
Constant for the "+" key.
VK_PREVIOUS_CANDIDATE - Static variable in class java.awt.event.KeyEvent
Constant for the Previous Candidate function key.
VK_PRINTSCREEN - Static variable in class java.awt.event.KeyEvent
VK_PROPS - Static variable in class java.awt.event.KeyEvent
VK_Q - Static variable in class java.awt.event.KeyEvent
VK_QUOTE - Static variable in class java.awt.event.KeyEvent
VK_QUOTEDBL - Static variable in class java.awt.event.KeyEvent
VK_R - Static variable in class java.awt.event.KeyEvent
VK_RIGHT - Static variable in class java.awt.event.KeyEvent
Constant for the non-numpad right arrow key.
VK_RIGHT_PARENTHESIS - Static variable in class java.awt.event.KeyEvent
Constant for the ")" key.
VK_ROMAN_CHARACTERS - Static variable in class java.awt.event.KeyEvent
Constant for the Roman Characters function key.
VK_S - Static variable in class java.awt.event.KeyEvent
VK_SCROLL_LOCK - Static variable in class java.awt.event.KeyEvent
VK_SEMICOLON - Static variable in class java.awt.event.KeyEvent
Constant for the semicolon key, ";"
VK_SEPARATER - Static variable in class java.awt.event.KeyEvent
This constant is obsolete, and is included only for backwards compatibility.
VK_SEPARATOR - Static variable in class java.awt.event.KeyEvent
Constant for the Numpad Separator key.
VK_SHIFT - Static variable in class java.awt.event.KeyEvent
VK_SLASH - Static variable in class java.awt.event.KeyEvent
Constant for the forward slash key, "/"
VK_SPACE - Static variable in class java.awt.event.KeyEvent
VK_STOP - Static variable in class java.awt.event.KeyEvent
VK_SUBTRACT - Static variable in class java.awt.event.KeyEvent
VK_T - Static variable in class java.awt.event.KeyEvent
VK_TAB - Static variable in class java.awt.event.KeyEvent
VK_U - Static variable in class java.awt.event.KeyEvent
VK_UNDEFINED - Static variable in class java.awt.event.KeyEvent
This value is used to indicate that the keyCode is unknown.
VK_UNDERSCORE - Static variable in class java.awt.event.KeyEvent
Constant for the "_" key.
VK_UNDO - Static variable in class java.awt.event.KeyEvent
VK_UP - Static variable in class java.awt.event.KeyEvent
Constant for the non-numpad up arrow key.
VK_V - Static variable in class java.awt.event.KeyEvent
VK_W - Static variable in class java.awt.event.KeyEvent
VK_WINDOWS - Static variable in class java.awt.event.KeyEvent
Constant for the Microsoft Windows "Windows" key.
VK_X - Static variable in class java.awt.event.KeyEvent
VK_Y - Static variable in class java.awt.event.KeyEvent
VK_Z - Static variable in class java.awt.event.KeyEvent
VLINK - Static variable in class javax.swing.text.html.HTML.Attribute
VM_ABSTRACT - Interface in org.omg.CORBA
Defines the code used to represent an Abstract interface in a typecode.
VM_CUSTOM - Interface in org.omg.CORBA
Defines the code used to represent a custom marshalled value type in a typecode.
VM_NONE - Interface in org.omg.CORBA
Defines the code used to represent the one of the values of a value type in a typecode.
VM_TRUNCATABLE - Interface in org.omg.CORBA
Defines the code used to represent a truncatable value type in a typecode.
VMID - Class in java.rmi.dgc
A VMID is a identifier that is unique across all Java virtual machines.
VMID() - Constructor for class java.rmi.dgc.VMID
Create a new VMID.
VoiceStatus - Class in javax.sound.midi
A VoiceStatus object contains information about the current status of one of the voices produced by a Synthesizer.
VoiceStatus() - Constructor for class javax.sound.midi.VoiceStatus
Void - Class in java.lang
The Void class is an uninstantiable placeholder class to hold a reference to the Class object representing the Java keyword void.
VOID - Static variable in class javax.management.openmbean.SimpleType
The SimpleType instance describing values whose Java class name is java.lang.Void.
VOLATILE - Static variable in class java.lang.reflect.Modifier
The int value representing the volatile modifier.
VolatileCallSite - Class in java.lang.invoke
A VolatileCallSite is a CallSite whose target acts like a volatile variable.
VolatileCallSite(MethodType) - Constructor for class java.lang.invoke.VolatileCallSite
Creates a call site with a volatile binding to its target.
VolatileCallSite(MethodHandle) - Constructor for class java.lang.invoke.VolatileCallSite
Creates a call site with a volatile binding to its target.
VolatileImage - Class in java.awt.image
VolatileImage is an image which can lose its contents at any time due to circumstances beyond the control of the application (e.g., situations caused by the operating system or by other applications).
VolatileImage() - Constructor for class java.awt.image.VolatileImage
volume - Variable in class javax.sound.midi.VoiceStatus
The current MIDI volume level for the voice.
VOLUME - Static variable in class javax.sound.sampled.FloatControl.Type
Represents a control for the volume on a line.
vsb - Variable in class javax.swing.ScrollPaneLayout
The scrollpane's vertical scrollbar child.
vsbChangeListener - Variable in class javax.swing.plaf.basic.BasicScrollPaneUI
VSBChangeListener() - Constructor for class javax.swing.plaf.basic.BasicScrollPaneUI.VSBChangeListener
vsbPolicy - Variable in class javax.swing.ScrollPaneLayout
The display policy for the vertical scrollbar.
VSPACE - Static variable in class javax.swing.text.html.HTML.Attribute
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames


W-Index (Java Platform SE 8 )

Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames
  • All Classes
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

W

W3C_LENGTH_UNITS - Static variable in class javax.swing.JEditorPane
Key for a client property used to indicate whether w3c compliant length units are used for html rendering.
W3C_XML_SCHEMA_INSTANCE_NS_URI - Static variable in class javax.xml.XMLConstants
W3C XML Schema Instance Namespace URI.
W3C_XML_SCHEMA_NS_URI - Static variable in class javax.xml.XMLConstants
W3C XML Schema Namespace URI.
W3C_XPATH_DATATYPE_NS_URI - Static variable in class javax.xml.XMLConstants
W3C XPath Datatype Namespace URI.
W3CDomHandler - Class in javax.xml.bind.annotation
DomHandler implementation for W3C DOM (org.w3c.dom package.)
W3CDomHandler() - Constructor for class javax.xml.bind.annotation.W3CDomHandler
Default constructor.
W3CDomHandler(DocumentBuilder) - Constructor for class javax.xml.bind.annotation.W3CDomHandler
Constructor that allows applications to specify which DOM implementation to be used.
W3CEndpointReference - Class in javax.xml.ws.wsaddressing
This class represents a W3C Addressing EndpointReferece which is a remote reference to a web service endpoint that supports the W3C WS-Addressing 1.0 - Core Recommendation.
W3CEndpointReference() - Constructor for class javax.xml.ws.wsaddressing.W3CEndpointReference
W3CEndpointReference(Source) - Constructor for class javax.xml.ws.wsaddressing.W3CEndpointReference
Creates an EPR from infoset representation
W3CEndpointReferenceBuilder - Class in javax.xml.ws.wsaddressing
This class is used to build W3CEndpointReference instances.
W3CEndpointReferenceBuilder() - Constructor for class javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder
Creates a new W3CEndpointReferenceBuilder instance.
W_RESIZE_CURSOR - Static variable in class java.awt.Cursor
The west-resize cursor type.
W_RESIZE_CURSOR - Static variable in class java.awt.Frame
Deprecated.
replaced by Cursor.W_RESIZE_CURSOR.
WAIS - Static variable in class javax.print.attribute.standard.ReferenceUriSchemesSupported
Wide Area Information Server (WAIS) protocol.
wait(long) - Method in class java.lang.Object
Causes the current thread to wait until either another thread invokes the Object.notify() method or the Object.notifyAll() method for this object, or a specified amount of time has elapsed.
wait(long, int) - Method in class java.lang.Object
Causes the current thread to wait until another thread invokes the Object.notify() method or the Object.notifyAll() method for this object, or some other thread interrupts the current thread, or a certain amount of real time has elapsed.
wait() - Method in class java.lang.Object
Causes the current thread to wait until another thread invokes the Object.notify() method or the Object.notifyAll() method for this object.
WAIT_CURSOR - Static variable in class java.awt.Cursor
The wait cursor type.
WAIT_CURSOR - Static variable in class java.awt.Frame
Deprecated.
replaced by Cursor.WAIT_CURSOR.
waitFor() - Method in class java.lang.Process
Causes the current thread to wait, if necessary, until the process represented by this Process object has terminated.
waitFor(long, TimeUnit) - Method in class java.lang.Process
Causes the current thread to wait, if necessary, until the subprocess represented by this Process object has terminated, or the specified waiting time elapses.
waitForAll() - Method in class java.awt.MediaTracker
Starts loading all images tracked by this media tracker.
waitForAll(long) - Method in class java.awt.MediaTracker
Starts loading all images tracked by this media tracker.
waitForID(int) - Method in class java.awt.MediaTracker
Starts loading all images tracked by this media tracker with the specified identifier.
waitForID(int, long) - Method in class java.awt.MediaTracker
Starts loading all images tracked by this media tracker with the specified identifier.
waitForIdle() - Method in class java.awt.Robot
Waits until all events currently on the event queue have been processed.
waitForWork() - Method in class javax.swing.text.LayoutQueue
Used by the worker thread to get a new task to execute
wakeup() - Method in class java.nio.channels.Selector
Causes the first selection operation that has not yet returned to return immediately.
walk(Path, int, FileVisitOption...) - Static method in class java.nio.file.Files
Return a Stream that is lazily populated with Path by walking the file tree rooted at a given starting file.
walk(Path, FileVisitOption...) - Static method in class java.nio.file.Files
Return a Stream that is lazily populated with Path by walking the file tree rooted at a given starting file.
walkFileTree(Path, Set<FileVisitOption>, int, FileVisitor<? super Path>) - Static method in class java.nio.file.Files
Walks a file tree.
walkFileTree(Path, FileVisitor<? super Path>) - Static method in class java.nio.file.Files
Walks a file tree.
WALL_TIME - Static variable in class java.util.SimpleTimeZone
Constant for a mode of start or end time specified as wall clock time.
WANTS_INPUT_PROPERTY - Static variable in class javax.swing.JOptionPane
Bound property name for wantsInput.
wantsInput - Variable in class javax.swing.JOptionPane
If true, a UI widget will be provided to the user to get input.
WARNING - Static variable in class java.util.logging.Level
WARNING is a message level indicating a potential problem.
warning(String) - Method in class java.util.logging.Logger
Log a WARNING message.
warning(Supplier<String>) - Method in class java.util.logging.Logger
Log a WARNING message, which is only to be constructed if the logging level is such that the message will actually be logged.
WARNING - Static variable in class javax.print.attribute.standard.Severity
Indicates that the PrinterStateReason is a "warning." An implementation may choose to omit some or all warnings.
WARNING - Static variable in class javax.security.auth.callback.ConfirmationCallback
WARNING message type.
WARNING - Static variable in class javax.security.auth.callback.TextOutputCallback
Warning message.
WARNING - Static variable in interface javax.xml.bind.ValidationEvent
Conditions that are not errors or fatal errors as defined by the XML 1.0 recommendation
warning(TransformerException) - Method in interface javax.xml.transform.ErrorListener
Receive notification of a warning.
warning(SAXParseException) - Method in interface org.xml.sax.ErrorHandler
Receive notification of a warning.
warning(SAXParseException) - Method in class org.xml.sax.HandlerBase
Deprecated.
Receive notification of a parser warning.
warning(SAXParseException) - Method in class org.xml.sax.helpers.DefaultHandler
Receive notification of a parser warning.
warning(SAXParseException) - Method in class org.xml.sax.helpers.XMLFilterImpl
Filter a warning event.
WARNING_DIALOG - Static variable in class javax.swing.JRootPane
Constant used for the windowDecorationStyle property.
WARNING_MESSAGE - Static variable in class javax.swing.JOptionPane
Used for warning messages.
warningListeners - Variable in class javax.imageio.ImageReader
A List of currently registered IIOReadWarningListeners, initialized by default to null, which is synonymous with an empty List.
warningListeners - Variable in class javax.imageio.ImageWriter
A List of currently registered IIOWriteWarningListeners, initialized by default to null, which is synonymous with an empty List.
warningLocales - Variable in class javax.imageio.ImageReader
A List of the Locales associated with each currently registered IIOReadWarningListener, initialized by default to null, which is synonymous with an empty List.
warningLocales - Variable in class javax.imageio.ImageWriter
A List of Locales, one for each element of warningListeners, initialized by default null, which is synonymous with an empty List.
warningOccurred(ImageReader, String) - Method in interface javax.imageio.event.IIOReadWarningListener
Reports the occurrence of a non-fatal error in decoding.
warningOccurred(ImageWriter, int, String) - Method in interface javax.imageio.event.IIOWriteWarningListener
Reports the occurrence of a non-fatal error in encoding.
wasFocused - Variable in class javax.swing.plaf.basic.BasicMenuUI.ChangeHandler
wasIcon(JInternalFrame) - Method in class javax.swing.DefaultDesktopManager
Returns true if the component has been iconized and the bounds of the desktopIcon are valid, otherwise returns false.
wasNull() - Method in interface java.sql.CallableStatement
Retrieves whether the last OUT parameter read had the value of SQL NULL.
wasNull() - Method in interface java.sql.ResultSet
Reports whether the last column read had a value of SQL NULL.
wasNull() - Method in interface java.sql.SQLInput
Retrieves whether the last value read was SQL NULL.
wasNull() - Method in class javax.sql.rowset.serial.SQLInputImpl
Ascertains whether the last value read from this SQLInputImpl object was null.
Watchable - Interface in java.nio.file
An object that may be registered with a watch service so that it can be watched for changes and events.
watchable() - Method in interface java.nio.file.WatchKey
Returns the object for which this watch key was created.
WatchEvent<T> - Interface in java.nio.file
An event or a repeated event for an object that is registered with a WatchService.
WatchEvent.Kind<T> - Interface in java.nio.file
An event kind, for the purposes of identification.
WatchEvent.Modifier - Interface in java.nio.file
An event modifier that qualifies how a Watchable is registered with a WatchService.
WatchKey - Interface in java.nio.file
A token representing the registration of a watchable object with a WatchService.
WatchService - Interface in java.nio.file
A watch service that watches registered objects for changes and events.
WAVE - Static variable in class javax.sound.sampled.AudioFileFormat.Type
Specifies a WAVE file.
WCharSeqHelper - Class in org.omg.CORBA
The Helper for WCharSeq.
WCharSeqHelper() - Constructor for class org.omg.CORBA.WCharSeqHelper
WCharSeqHolder - Class in org.omg.CORBA
The Holder for WCharSeq.
WCharSeqHolder() - Constructor for class org.omg.CORBA.WCharSeqHolder
WCharSeqHolder(char[]) - Constructor for class org.omg.CORBA.WCharSeqHolder
weakCompareAndSet(boolean, boolean) - Method in class java.util.concurrent.atomic.AtomicBoolean
Atomically sets the value to the given updated value if the current value == the expected value.
weakCompareAndSet(int, int) - Method in class java.util.concurrent.atomic.AtomicInteger
Atomically sets the value to the given updated value if the current value == the expected value.
weakCompareAndSet(int, int, int) - Method in class java.util.concurrent.atomic.AtomicIntegerArray
Atomically sets the element at position i to the given updated value if the current value == the expected value.
weakCompareAndSet(T, int, int) - Method in class java.util.concurrent.atomic.AtomicIntegerFieldUpdater
Atomically sets the field of the given object managed by this updater to the given updated value if the current value == the expected value.
weakCompareAndSet(long, long) - Method in class java.util.concurrent.atomic.AtomicLong
Atomically sets the value to the given updated value if the current value == the expected value.
weakCompareAndSet(int, long, long) - Method in class java.util.concurrent.atomic.AtomicLongArray
Atomically sets the element at position i to the given updated value if the current value == the expected value.
weakCompareAndSet(T, long, long) - Method in class java.util.concurrent.atomic.AtomicLongFieldUpdater
Atomically sets the field of the given object managed by this updater to the given updated value if the current value == the expected value.
weakCompareAndSet(V, V, boolean, boolean) - Method in class java.util.concurrent.atomic.AtomicMarkableReference
Atomically sets the value of both the reference and mark to the given update values if the current reference is == to the expected reference and the current mark is equal to the expected mark.
weakCompareAndSet(V, V) - Method in class java.util.concurrent.atomic.AtomicReference
Atomically sets the value to the given updated value if the current value == the expected value.
weakCompareAndSet(int, E, E) - Method in class java.util.concurrent.atomic.AtomicReferenceArray
Atomically sets the element at position i to the given updated value if the current value == the expected value.
weakCompareAndSet(T, V, V) - Method in class java.util.concurrent.atomic.AtomicReferenceFieldUpdater
Atomically sets the field of the given object managed by this updater to the given updated value if the current value == the expected value.
weakCompareAndSet(V, V, int, int) - Method in class java.util.concurrent.atomic.AtomicStampedReference
Atomically sets the value of both the reference and stamp to the given update values if the current reference is == to the expected reference and the current stamp is equal to the expected stamp.
WeakHashMap<K,V> - Class in java.util
Hash table based implementation of the Map interface, with weak keys.
WeakHashMap(int, float) - Constructor for class java.util.WeakHashMap
Constructs a new, empty WeakHashMap with the given initial capacity and the given load factor.
WeakHashMap(int) - Constructor for class java.util.WeakHashMap
Constructs a new, empty WeakHashMap with the given initial capacity and the default load factor (0.75).
WeakHashMap() - Constructor for class java.util.WeakHashMap
Constructs a new, empty WeakHashMap with the default initial capacity (16) and load factor (0.75).
WeakHashMap(Map<? extends K, ? extends V>) - Constructor for class java.util.WeakHashMap
Constructs a new WeakHashMap with the same mappings as the specified map.
WeakReference<T> - Class in java.lang.ref
Weak reference objects, which do not prevent their referents from being made finalizable, finalized, and then reclaimed.
WeakReference(T) - Constructor for class java.lang.ref.WeakReference
Creates a new weak reference that refers to the given object.
WeakReference(T, ReferenceQueue<? super T>) - Constructor for class java.lang.ref.WeakReference
Creates a new weak reference that refers to the given object and is registered with the given queue.
WebEndpoint - Annotation Type in javax.xml.ws
Used to annotate the getPortName() methods of a generated service interface.
WebFault - Annotation Type in javax.xml.ws
Used to annotate service specific exception classes to customize to the local and namespace name of the fault element and the name of the fault bean.
WebMethod - Annotation Type in javax.jws
WebParam - Annotation Type in javax.jws
WebParam.Mode - Enum in javax.jws
WebResult - Annotation Type in javax.jws
WebRowSet - Interface in javax.sql.rowset
The standard interface that all implementations of a WebRowSet must implement.
WebService - Annotation Type in javax.jws
WebServiceClient - Annotation Type in javax.xml.ws
Used to annotate a generated service interface.
WebServiceContext - Interface in javax.xml.ws
A WebServiceContext makes it possible for a web service endpoint implementation class to access message context and security information relative to a request being served.
WebServiceException - Exception in javax.xml.ws
The WebServiceException class is the base exception class for all JAX-WS API runtime exceptions.
WebServiceException() - Constructor for exception javax.xml.ws.WebServiceException
Constructs a new exception with null as its detail message.
WebServiceException(String) - Constructor for exception javax.xml.ws.WebServiceException
Constructs a new exception with the specified detail message.
WebServiceException(String, Throwable) - Constructor for exception javax.xml.ws.WebServiceException
Constructs a new exception with the specified detail message and cause.
WebServiceException(Throwable) - Constructor for exception javax.xml.ws.WebServiceException
Constructs a new WebServiceException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
WebServiceFeature - Class in javax.xml.ws
A WebServiceFeature is used to represent a feature that can be enabled or disabled for a web service.
WebServiceFeature() - Constructor for class javax.xml.ws.WebServiceFeature
WebServiceFeatureAnnotation - Annotation Type in javax.xml.ws.spi
Annotation used to identify other annotations as a WebServiceFeature.
WebServicePermission - Class in javax.xml.ws
This class defines web service permissions.
WebServicePermission(String) - Constructor for class javax.xml.ws.WebServicePermission
Creates a new permission with the specified name.
WebServicePermission(String, String) - Constructor for class javax.xml.ws.WebServicePermission
Creates a new permission with the specified name and actions.
WebServiceProvider - Annotation Type in javax.xml.ws
Used to annotate a Provider implementation class.
WebServiceRef - Annotation Type in javax.xml.ws
The WebServiceRef annotation is used to define a reference to a web service and (optionally) an injection target for it.
WebServiceRefs - Annotation Type in javax.xml.ws
The WebServiceRefs annotation allows multiple web service references to be declared at the class level.
WEDNESDAY - Static variable in class java.util.Calendar
Value of the Calendar.DAY_OF_WEEK field indicating Wednesday.
WEEK_BASED_YEAR - Static variable in class java.time.temporal.IsoFields
The field that represents the week-based-year.
WEEK_BASED_YEARS - Static variable in class java.time.temporal.IsoFields
The unit that represents week-based-years for the purpose of addition and subtraction.
WEEK_BASED_YEARS - Static variable in class java.time.temporal.WeekFields
The unit that represents week-based-years for the purpose of addition and subtraction.
WEEK_OF_MONTH - Static variable in class java.text.DateFormat.Field
Constant identifying the week of month field.
WEEK_OF_MONTH - Static variable in class java.util.Calendar
Field number for get and set indicating the week number within the current month.
WEEK_OF_MONTH_FIELD - Static variable in class java.text.DateFormat
Useful constant for WEEK_OF_MONTH field alignment.
WEEK_OF_WEEK_BASED_YEAR - Static variable in class java.time.temporal.IsoFields
The field that represents the week-of-week-based-year.
WEEK_OF_YEAR - Static variable in class java.text.DateFormat.Field
Constant identifying the week of year field.
WEEK_OF_YEAR - Static variable in class java.util.Calendar
Field number for get and set indicating the week number within the current year.
WEEK_OF_YEAR_FIELD - Static variable in class java.text.DateFormat
Useful constant for WEEK_OF_YEAR field alignment.
weekBasedYear() - Method in class java.time.temporal.WeekFields
Returns a field to access the year of a week-based-year based on this WeekFields.
WeekFields - Class in java.time.temporal
Localized definitions of the day-of-week, week-of-month and week-of-year fields.
weekOfMonth() - Method in class java.time.temporal.WeekFields
Returns a field to access the week of month based on this WeekFields.
weekOfWeekBasedYear() - Method in class java.time.temporal.WeekFields
Returns a field to access the week of a week-based-year based on this WeekFields.
weekOfYear() - Method in class java.time.temporal.WeekFields
Returns a field to access the week of year based on this WeekFields.
weight - Variable in class java.awt.font.GlyphJustificationInfo
The weight of this glyph.
WEIGHT - Static variable in class java.awt.font.TextAttribute
Attribute key for the weight of a font.
WEIGHT_BOLD - Static variable in class java.awt.font.TextAttribute
The standard bold weight.
WEIGHT_DEMIBOLD - Static variable in class java.awt.font.TextAttribute
A moderately lighter weight than WEIGHT_BOLD.
WEIGHT_DEMILIGHT - Static variable in class java.awt.font.TextAttribute
An intermediate weight between WEIGHT_LIGHT and WEIGHT_STANDARD.
WEIGHT_EXTRA_LIGHT - Static variable in class java.awt.font.TextAttribute
The lightest predefined weight.
WEIGHT_EXTRABOLD - Static variable in class java.awt.font.TextAttribute
An extra heavy weight.
WEIGHT_HEAVY - Static variable in class java.awt.font.TextAttribute
A moderately heavier weight than WEIGHT_BOLD.
WEIGHT_LIGHT - Static variable in class java.awt.font.TextAttribute
The standard light weight.
WEIGHT_MEDIUM - Static variable in class java.awt.font.TextAttribute
An intermediate weight between WEIGHT_REGULAR and WEIGHT_BOLD.
WEIGHT_REGULAR - Static variable in class java.awt.font.TextAttribute
The standard weight.
WEIGHT_SEMIBOLD - Static variable in class java.awt.font.TextAttribute
A moderately heavier weight than WEIGHT_REGULAR.
WEIGHT_ULTRABOLD - Static variable in class java.awt.font.TextAttribute
The heaviest predefined weight.
weightx - Variable in class java.awt.GridBagConstraints
Specifies how to distribute extra horizontal space.
weighty - Variable in class java.awt.GridBagConstraints
Specifies how to distribute extra vertical space.
WEST - Static variable in class java.awt.BorderLayout
The west layout constraint (left side of container).
WEST - Static variable in class java.awt.GridBagConstraints
Put the component on the left side of its display area, centered vertically.
WEST - Static variable in class javax.swing.SpringLayout
Specifies the left edge of a component's bounding rectangle.
WEST - Static variable in interface javax.swing.SwingConstants
Compass-direction west (left).
westPane - Variable in class javax.swing.plaf.basic.BasicInternalFrameUI
WHEEL_BLOCK_SCROLL - Static variable in class java.awt.event.MouseWheelEvent
Constant representing scrolling by a "block" (like scrolling with page-up, page-down keys)
WHEEL_UNIT_SCROLL - Static variable in class java.awt.event.MouseWheelEvent
Constant representing scrolling by "units" (like scrolling with the arrow keys)
when - Variable in class java.awt.Event
The time stamp.
WHEN_ANCESTOR_OF_FOCUSED_COMPONENT - Static variable in class javax.swing.JComponent
Constant used for registerKeyboardAction that means that the command should be invoked when the receiving component is an ancestor of the focused component or is itself the focused component.
WHEN_FOCUSED - Static variable in class javax.swing.JComponent
Constant used for registerKeyboardAction that means that the command should be invoked when the component has the focus.
WHEN_IN_FOCUSED_WINDOW - Static variable in class javax.swing.JComponent
Constant used for registerKeyboardAction that means that the command should be invoked when the receiving component is in the window that has the focus or is itself the focused component.
whenComplete(BiConsumer<? super T, ? super Throwable>) - Method in class java.util.concurrent.CompletableFuture
whenComplete(BiConsumer<? super T, ? super Throwable>) - Method in interface java.util.concurrent.CompletionStage
Returns a new CompletionStage with the same result or exception as this stage, and when this stage completes, executes the given action with the result (or null if none) and the exception (or null if none) of this stage.
whenCompleteAsync(BiConsumer<? super T, ? super Throwable>) - Method in class java.util.concurrent.CompletableFuture
whenCompleteAsync(BiConsumer<? super T, ? super Throwable>, Executor) - Method in class java.util.concurrent.CompletableFuture
whenCompleteAsync(BiConsumer<? super T, ? super Throwable>) - Method in interface java.util.concurrent.CompletionStage
Returns a new CompletionStage with the same result or exception as this stage, and when this stage completes, executes the given action executes the given action using this stage's default asynchronous execution facility, with the result (or null if none) and the exception (or null if none) of this stage as arguments.
whenCompleteAsync(BiConsumer<? super T, ? super Throwable>, Executor) - Method in interface java.util.concurrent.CompletionStage
Returns a new CompletionStage with the same result or exception as this stage, and when this stage completes, executes using the supplied Executor, the given action with the result (or null if none) and the exception (or null if none) of this stage as arguments.
white - Static variable in class java.awt.Color
The color white.
WHITE - Static variable in class java.awt.Color
The color white.
WHITE_SPACE - Static variable in class javax.swing.text.html.CSS.Attribute
WHITESPACE - Static variable in class java.awt.font.GlyphMetrics
Indicates a glyph with no visual representation.
whitespaceChars(int, int) - Method in class java.io.StreamTokenizer
Specifies that all characters c in the range low <= c <= high are white space characters.
why - Variable in exception org.omg.CosNaming.NamingContextPackage.NotFound
width - Variable in class java.awt.Component.BltBufferStrategy
Size of the back buffers
width - Variable in class java.awt.Dimension
The width dimension; negative values can be used.
WIDTH - Static variable in class java.awt.font.TextAttribute
Attribute key for the width of a font.
width - Variable in class java.awt.geom.Arc2D.Double
The overall width of the full ellipse of which this arc is a partial section (not considering the angular extents).
width - Variable in class java.awt.geom.Arc2D.Float
The overall width of the full ellipse of which this arc is a partial section (not considering the angular extents).
width - Variable in class java.awt.geom.Ellipse2D.Double
The overall width of this Ellipse2D.
width - Variable in class java.awt.geom.Ellipse2D.Float
The overall width of this Ellipse2D.
width - Variable in class java.awt.geom.Rectangle2D.Double
The width of this Rectangle2D.
width - Variable in class java.awt.geom.Rectangle2D.Float
The width of this Rectangle2D.
width - Variable in class java.awt.geom.RoundRectangle2D.Double
The width of this RoundRectangle2D.
width - Variable in class java.awt.geom.RoundRectangle2D.Float
The width of this RoundRectangle2D.
WIDTH - Static variable in interface java.awt.image.ImageObserver
This flag in the infoflags argument to imageUpdate indicates that the width of the base image is now available and can be taken from the width argument to the imageUpdate callback method.
width - Variable in class java.awt.image.Raster
The width of this Raster.
width - Variable in class java.awt.image.SampleModel
Width in pixels of the region of image data that this SampleModel describes.
width - Variable in class java.awt.Rectangle
The width of the Rectangle.
width(Component) - Static method in class javax.swing.Spring
Returns a spring whose minimum, preferred, maximum and value properties are defined by the widths of the minimumSize, preferredSize, maximumSize and size properties of the supplied component.
WIDTH - Static variable in class javax.swing.SpringLayout
Specifies the width of a component's bounding rectangle.
width - Variable in class javax.swing.table.TableColumn
The width of the column.
WIDTH - Static variable in class javax.swing.text.html.CSS.Attribute
WIDTH - Static variable in class javax.swing.text.html.HTML.Attribute
WIDTH_CONDENSED - Static variable in class java.awt.font.TextAttribute
The most condensed predefined width.
WIDTH_EXTENDED - Static variable in class java.awt.font.TextAttribute
The most extended predefined width.
WIDTH_REGULAR - Static variable in class java.awt.font.TextAttribute
The standard width.
WIDTH_SEMI_CONDENSED - Static variable in class java.awt.font.TextAttribute
A moderately condensed width.
WIDTH_SEMI_EXTENDED - Static variable in class java.awt.font.TextAttribute
A moderately extended width.
WILDCARD - Static variable in class javax.management.ObjectName
Defines the wildcard "*:*" ObjectName.
WildcardType - Interface in java.lang.reflect
WildcardType represents a wildcard type expression, such as ?, ? extends Number, or ? super Integer.
WildcardType - Interface in javax.lang.model.type
Represents a wildcard type argument.
WIND_EVEN_ODD - Static variable in class java.awt.geom.Path2D
An even-odd winding rule for determining the interior of a path.
WIND_EVEN_ODD - Static variable in interface java.awt.geom.PathIterator
The winding rule constant for specifying an even-odd rule for determining the interior of a path.
WIND_NON_ZERO - Static variable in class java.awt.geom.Path2D
A non-zero winding rule for determining the interior of a path.
WIND_NON_ZERO - Static variable in interface java.awt.geom.PathIterator
The winding rule constant for specifying a non-zero rule for determining the interior of a path.
WINDOW - Static variable in class java.awt.SystemColor
The array index for the SystemColor.window system color.
window - Static variable in class java.awt.SystemColor
The color rendered for the background of interior regions inside windows.
Window - Class in java.awt
A Window object is a top-level window with no borders and no menubar.
Window(Frame) - Constructor for class java.awt.Window
Constructs a new, initially invisible window with the specified Frame as its owner.
Window(Window) - Constructor for class java.awt.Window
Constructs a new, initially invisible window with the specified Window as its owner.
Window(Window, GraphicsConfiguration) - Constructor for class java.awt.Window
Constructs a new, initially invisible window with the specified owner Window and a GraphicsConfiguration of a screen device.
WINDOW - Static variable in class javax.accessibility.AccessibleRole
A top level window with no title or border.
Window.AccessibleAWTWindow - Class in java.awt
This class implements accessibility support for the Window class.
Window.Type - Enum in java.awt
Enumeration of available window types.
WINDOW_ACTIVATED - Static variable in class java.awt.event.WindowEvent
The window-activated event type.
WINDOW_BORDER - Static variable in class java.awt.SystemColor
The array index for the SystemColor.windowBorder system color.
WINDOW_CLOSED - Static variable in class java.awt.event.WindowEvent
The window closed event.
WINDOW_CLOSING - Static variable in class java.awt.event.WindowEvent
The "window is closing" event.
WINDOW_DEACTIVATED - Static variable in class java.awt.event.WindowEvent
The window-deactivated event type.
WINDOW_DEICONIFIED - Static variable in class java.awt.event.WindowEvent
The window deiconified event type.
WINDOW_DEICONIFY - Static variable in class java.awt.Event
The user has asked the window manager to de-iconify the window.
WINDOW_DESTROY - Static variable in class java.awt.Event
The user has asked the window manager to kill the window.
WINDOW_EVENT_MASK - Static variable in class java.awt.AWTEvent
The event mask for selecting window events.
WINDOW_EXPOSE - Static variable in class java.awt.Event
The user has asked the window manager to expose the window.
WINDOW_FIRST - Static variable in class java.awt.event.WindowEvent
The first number in the range of ids used for window events.
WINDOW_FOCUS_EVENT_MASK - Static variable in class java.awt.AWTEvent
The event mask for selecting window focus events.
WINDOW_GAINED_FOCUS - Static variable in class java.awt.event.WindowEvent
The window-gained-focus event type.
WINDOW_ICONIFIED - Static variable in class java.awt.event.WindowEvent
The window iconified event.
WINDOW_ICONIFY - Static variable in class java.awt.Event
The user has asked the window manager to iconify the window.
WINDOW_LAST - Static variable in class java.awt.event.WindowEvent
The last number in the range of ids used for window events.
WINDOW_LOST_FOCUS - Static variable in class java.awt.event.WindowEvent
The window-lost-focus event type.
WINDOW_MOVED - Static variable in class java.awt.Event
The user has asked the window manager to move the window.
WINDOW_OPENED - Static variable in class java.awt.event.WindowEvent
The window opened event.
WINDOW_STATE_CHANGED - Static variable in class java.awt.event.WindowEvent
The window-state-changed event type.
WINDOW_STATE_EVENT_MASK - Static variable in class java.awt.AWTEvent
The event mask for selecting window state events.
WINDOW_TEXT - Static variable in class java.awt.SystemColor
The array index for the SystemColor.windowText system color.
windowActivated(WindowEvent) - Method in class java.awt.AWTEventMulticaster
Handles the windowActivated event by invoking the windowActivated methods on listener-a and listener-b.
windowActivated(WindowEvent) - Method in class java.awt.event.WindowAdapter
Invoked when a window is activated.
windowActivated(WindowEvent) - Method in interface java.awt.event.WindowListener
Invoked when the Window is set to be the active Window.
WindowAdapter - Class in java.awt.event
An abstract adapter class for receiving window events.
WindowAdapter() - Constructor for class java.awt.event.WindowAdapter
windowBorder - Static variable in class java.awt.SystemColor
The color rendered for the border around interior regions inside windows.
windowClosed(WindowEvent) - Method in class java.awt.AWTEventMulticaster
Handles the windowClosed event by invoking the windowClosed methods on listener-a and listener-b.
windowClosed(WindowEvent) - Method in class java.awt.event.WindowAdapter
Invoked when a window has been closed.
windowClosed(WindowEvent) - Method in interface java.awt.event.WindowListener
Invoked when a window has been closed as the result of calling dispose on the window.
windowClosing(WindowEvent) - Method in class java.awt.AWTEventMulticaster
Handles the windowClosing event by invoking the windowClosing methods on listener-a and listener-b.
windowClosing(WindowEvent) - Method in class java.awt.event.WindowAdapter
Invoked when a window is in the process of being closed.
windowClosing(WindowEvent) - Method in interface java.awt.event.WindowListener
Invoked when the user attempts to close the window from the window's system menu.
windowClosing(WindowEvent) - Method in class javax.swing.JMenu.WinListener
Deselect the menu when the popup is closed from outside.
windowClosing(WindowEvent) - Method in class javax.swing.plaf.basic.BasicToolBarUI.FrameListener
WindowConstants - Interface in javax.swing
Constants used to control the window-closing operation.
windowDeactivated(WindowEvent) - Method in class java.awt.AWTEventMulticaster
Handles the windowDeactivated event by invoking the windowDeactivated methods on listener-a and listener-b.
windowDeactivated(WindowEvent) - Method in class java.awt.event.WindowAdapter
Invoked when a window is de-activated.
windowDeactivated(WindowEvent) - Method in interface java.awt.event.WindowListener
Invoked when a Window is no longer the active Window.
windowDeiconified(WindowEvent) - Method in class java.awt.AWTEventMulticaster
Handles the windowDeiconfied event by invoking the windowDeiconified methods on listener-a and listener-b.
windowDeiconified(WindowEvent) - Method in class java.awt.event.WindowAdapter
Invoked when a window is de-iconified.
windowDeiconified(WindowEvent) - Method in interface java.awt.event.WindowListener
Invoked when a window is changed from a minimized to a normal state.
WindowEvent - Class in java.awt.event
A low-level event that indicates that a window has changed its status.
WindowEvent(Window, int, Window, int, int) - Constructor for class java.awt.event.WindowEvent
Constructs a WindowEvent object.
WindowEvent(Window, int, Window) - Constructor for class java.awt.event.WindowEvent
Constructs a WindowEvent object with the specified opposite Window.
WindowEvent(Window, int, int, int) - Constructor for class java.awt.event.WindowEvent
Constructs a WindowEvent object with the specified previous and new window states.
WindowEvent(Window, int) - Constructor for class java.awt.event.WindowEvent
Constructs a WindowEvent object.
WindowFocusListener - Interface in java.awt.event
The listener interface for receiving WindowEvents, including WINDOW_GAINED_FOCUS and WINDOW_LOST_FOCUS events.
windowForComponent(Component) - Static method in class javax.swing.SwingUtilities
Returns the first Window ancestor of c, or null if c is not contained inside a Window.
windowGainedFocus(WindowEvent) - Method in class java.awt.AWTEventMulticaster
Handles the windowGainedFocus event by invoking the windowGainedFocus methods on listener-a and listener-b.
windowGainedFocus(WindowEvent) - Method in class java.awt.event.WindowAdapter
Invoked when the Window is set to be the focused Window, which means that the Window, or one of its subcomponents, will receive keyboard events.
windowGainedFocus(WindowEvent) - Method in interface java.awt.event.WindowFocusListener
Invoked when the Window is set to be the focused Window, which means that the Window, or one of its subcomponents, will receive keyboard events.
windowIconified(WindowEvent) - Method in class java.awt.AWTEventMulticaster
Handles the windowIconified event by invoking the windowIconified methods on listener-a and listener-b.
windowIconified(WindowEvent) - Method in class java.awt.event.WindowAdapter
Invoked when a window is iconified.
windowIconified(WindowEvent) - Method in interface java.awt.event.WindowListener
Invoked when a window is changed from a normal to a minimized state.
windowInit() - Method in class javax.swing.JWindow
Called by the constructors to init the JWindow properly.
WindowListener - Interface in java.awt.event
The listener interface for receiving window events.
windowLostFocus(WindowEvent) - Method in class java.awt.AWTEventMulticaster
Handles the windowLostFocus event by invoking the windowLostFocus methods on listener-a and listener-b.
windowLostFocus(WindowEvent) - Method in class java.awt.event.WindowAdapter
Invoked when the Window is no longer the focused Window, which means that keyboard events will no longer be delivered to the Window or any of its subcomponents.
windowLostFocus(WindowEvent) - Method in interface java.awt.event.WindowFocusListener
Invoked when the Window is no longer the focused Window, which means that keyboard events will no longer be delivered to the Window or any of its subcomponents.
windowMenu - Variable in class javax.swing.plaf.basic.BasicInternalFrameTitlePane
windowOpened(WindowEvent) - Method in class java.awt.AWTEventMulticaster
Handles the windowOpened event by invoking the windowOpened methods on listener-a and listener-b.
windowOpened(WindowEvent) - Method in class java.awt.event.WindowAdapter
Invoked when a window has been opened.
windowOpened(WindowEvent) - Method in interface java.awt.event.WindowListener
Invoked the first time a window is made visible.
windowStateChanged(WindowEvent) - Method in class java.awt.AWTEventMulticaster
Handles the windowStateChanged event by invoking the windowStateChanged methods on listener-a and listener-b.
windowStateChanged(WindowEvent) - Method in class java.awt.event.WindowAdapter
Invoked when a window state is changed.
windowStateChanged(WindowEvent) - Method in interface java.awt.event.WindowStateListener
Invoked when window state is changed.
WindowStateListener - Interface in java.awt.event
The listener interface for receiving window state events.
windowText - Static variable in class java.awt.SystemColor
The color rendered for text of interior regions inside windows.
WinListener(JPopupMenu) - Constructor for class javax.swing.JMenu.WinListener
Create the window listener for the specified popup.
with(TemporalAdjuster) - Method in interface java.time.chrono.ChronoLocalDate
Returns an adjusted object of the same type as this object with the adjustment made.
with(TemporalField, long) - Method in interface java.time.chrono.ChronoLocalDate
Returns an object of the same type as this object with the specified field altered.
with(TemporalAdjuster) - Method in interface java.time.chrono.ChronoLocalDateTime
Returns an adjusted object of the same type as this object with the adjustment made.
with(TemporalField, long) - Method in interface java.time.chrono.ChronoLocalDateTime
Returns an object of the same type as this object with the specified field altered.
with(TemporalAdjuster) - Method in interface java.time.chrono.ChronoZonedDateTime
Returns an adjusted object of the same type as this object with the adjustment made.
with(TemporalField, long) - Method in interface java.time.chrono.ChronoZonedDateTime
Returns an object of the same type as this object with the specified field altered.
with(TemporalField, long) - Method in class java.time.chrono.HijrahDate
with(TemporalAdjuster) - Method in class java.time.chrono.HijrahDate
Returns an adjusted object of the same type as this object with the adjustment made.
with(TemporalField, long) - Method in class java.time.chrono.JapaneseDate
with(TemporalAdjuster) - Method in class java.time.chrono.JapaneseDate
Returns an adjusted object of the same type as this object with the adjustment made.
with(TemporalField, long) - Method in class java.time.chrono.MinguoDate
with(TemporalAdjuster) - Method in class java.time.chrono.MinguoDate
Returns an adjusted object of the same type as this object with the adjustment made.
with(TemporalField, long) - Method in class java.time.chrono.ThaiBuddhistDate
with(TemporalAdjuster) - Method in class java.time.chrono.ThaiBuddhistDate
Returns an adjusted object of the same type as this object with the adjustment made.
with(TemporalAdjuster) - Method in class java.time.Instant
Returns an adjusted copy of this instant.
with(TemporalField, long) - Method in class java.time.Instant
Returns a copy of this instant with the specified field set to a new value.
with(TemporalAdjuster) - Method in class java.time.LocalDate
Returns an adjusted copy of this date.
with(TemporalField, long) - Method in class java.time.LocalDate
Returns a copy of this date with the specified field set to a new value.
with(TemporalAdjuster) - Method in class java.time.LocalDateTime
Returns an adjusted copy of this date-time.
with(TemporalField, long) - Method in class java.time.LocalDateTime
Returns a copy of this date-time with the specified field set to a new value.
with(TemporalAdjuster) - Method in class java.time.LocalTime
Returns an adjusted copy of this time.
with(TemporalField, long) - Method in class java.time.LocalTime
Returns a copy of this time with the specified field set to a new value.
with(Month) - Method in class java.time.MonthDay
Returns a copy of this MonthDay with the month-of-year altered.
with(TemporalAdjuster) - Method in class java.time.OffsetDateTime
Returns an adjusted copy of this date-time.
with(TemporalField, long) - Method in class java.time.OffsetDateTime
Returns a copy of this date-time with the specified field set to a new value.
with(TemporalAdjuster) - Method in class java.time.OffsetTime
Returns an adjusted copy of this time.
with(TemporalField, long) - Method in class java.time.OffsetTime
Returns a copy of this time with the specified field set to a new value.
with(TemporalAdjuster) - Method in interface java.time.temporal.Temporal
Returns an adjusted object of the same type as this object with the adjustment made.
with(TemporalField, long) - Method in interface java.time.temporal.Temporal
Returns an object of the same type as this object with the specified field altered.
with(TemporalAdjuster) - Method in class java.time.Year
Returns an adjusted copy of this year.
with(TemporalField, long) - Method in class java.time.Year
Returns a copy of this year with the specified field set to a new value.
with(TemporalAdjuster) - Method in class java.time.YearMonth
Returns an adjusted copy of this year-month.
with(TemporalField, long) - Method in class java.time.YearMonth
Returns a copy of this year-month with the specified field set to a new value.
with(TemporalAdjuster) - Method in class java.time.ZonedDateTime
Returns an adjusted copy of this date-time.
with(TemporalField, long) - Method in class java.time.ZonedDateTime
Returns a copy of this date-time with the specified field set to a new value.
withCachedThreadPool(ExecutorService, int) - Static method in class java.nio.channels.AsynchronousChannelGroup
Creates an asynchronous channel group with a given thread pool that creates new threads as needed.
withChronology(Chronology) - Method in class java.time.format.DateTimeFormatter
Returns a copy of this formatter with a new override chronology.
withDayOfMonth(int) - Method in class java.time.LocalDate
Returns a copy of this date with the day-of-month altered.
withDayOfMonth(int) - Method in class java.time.LocalDateTime
Returns a copy of this LocalDateTime with the day-of-month altered.
withDayOfMonth(int) - Method in class java.time.MonthDay
Returns a copy of this MonthDay with the day-of-month altered.
withDayOfMonth(int) - Method in class java.time.OffsetDateTime
Returns a copy of this OffsetDateTime with the day-of-month altered.
withDayOfMonth(int) - Method in class java.time.ZonedDateTime
Returns a copy of this ZonedDateTime with the day-of-month value altered.
withDayOfYear(int) - Method in class java.time.LocalDate
Returns a copy of this date with the day-of-year altered.
withDayOfYear(int) - Method in class java.time.LocalDateTime
Returns a copy of this LocalDateTime with the day-of-year altered.
withDayOfYear(int) - Method in class java.time.OffsetDateTime
Returns a copy of this OffsetDateTime with the day-of-year altered.
withDayOfYear(int) - Method in class java.time.ZonedDateTime
Returns a copy of this ZonedDateTime with the day-of-year altered.
withDays(int) - Method in class java.time.Period
Returns a copy of this period with the specified amount of days.
withDecimalSeparator(char) - Method in class java.time.format.DecimalStyle
Returns a copy of the info with a new character that represents the decimal point.
withDecimalStyle(DecimalStyle) - Method in class java.time.format.DateTimeFormatter
Returns a copy of this formatter with a new DecimalStyle.
withEarlierOffsetAtOverlap() - Method in interface java.time.chrono.ChronoZonedDateTime
Returns a copy of this date-time changing the zone offset to the earlier of the two valid offsets at a local time-line overlap.
withEarlierOffsetAtOverlap() - Method in class java.time.ZonedDateTime
Returns a copy of this date-time changing the zone offset to the earlier of the two valid offsets at a local time-line overlap.
withFixedOffsetZone() - Method in class java.time.ZonedDateTime
Returns a copy of this date-time with the zone ID set to the offset.
withFixedThreadPool(int, ThreadFactory) - Static method in class java.nio.channels.AsynchronousChannelGroup
Creates an asynchronous channel group with a fixed thread pool.
withHour(int) - Method in class java.time.LocalDateTime
Returns a copy of this LocalDateTime with the hour-of-day value altered.
withHour(int) - Method in class java.time.LocalTime
Returns a copy of this LocalTime with the hour-of-day value altered.
withHour(int) - Method in class java.time.OffsetDateTime
Returns a copy of this OffsetDateTime with the hour-of-day value altered.
withHour(int) - Method in class java.time.OffsetTime
Returns a copy of this OffsetTime with the hour-of-day value altered.
withHour(int) - Method in class java.time.ZonedDateTime
Returns a copy of this ZonedDateTime with the hour-of-day value altered.
withInitial(Supplier<? extends S>) - Static method in class java.lang.ThreadLocal
Creates a thread local variable.
withLaterOffsetAtOverlap() - Method in interface java.time.chrono.ChronoZonedDateTime
Returns a copy of this date-time changing the zone offset to the later of the two valid offsets at a local time-line overlap.
withLaterOffsetAtOverlap() - Method in class java.time.ZonedDateTime
Returns a copy of this date-time changing the zone offset to the later of the two valid offsets at a local time-line overlap.
withLocale(Locale) - Method in class java.time.format.DateTimeFormatter
Returns a copy of this formatter with a new locale.
withMinute(int) - Method in class java.time.LocalDateTime
Returns a copy of this LocalDateTime with the minute-of-hour value altered.
withMinute(int) - Method in class java.time.LocalTime
Returns a copy of this LocalTime with the minute-of-hour value altered.
withMinute(int) - Method in class java.time.OffsetDateTime
Returns a copy of this OffsetDateTime with the minute-of-hour value altered.
withMinute(int) - Method in class java.time.OffsetTime
Returns a copy of this OffsetTime with the minute-of-hour value altered.
withMinute(int) - Method in class java.time.ZonedDateTime
Returns a copy of this ZonedDateTime with the minute-of-hour value altered.
withMonth(int) - Method in class java.time.LocalDate
Returns a copy of this date with the month-of-year altered.
withMonth(int) - Method in class java.time.LocalDateTime
Returns a copy of this LocalDateTime with the month-of-year altered.
withMonth(int) - Method in class java.time.MonthDay
Returns a copy of this MonthDay with the month-of-year altered.
withMonth(int) - Method in class java.time.OffsetDateTime
Returns a copy of this OffsetDateTime with the month-of-year altered.
withMonth(int) - Method in class java.time.YearMonth
Returns a copy of this YearMonth with the month-of-year altered.
withMonth(int) - Method in class java.time.ZonedDateTime
Returns a copy of this ZonedDateTime with the month-of-year value altered.
withMonths(int) - Method in class java.time.Period
Returns a copy of this period with the specified amount of months.
withNano(int) - Method in class java.time.LocalDateTime
Returns a copy of this LocalDateTime with the nano-of-second value altered.
withNano(int) - Method in class java.time.LocalTime
Returns a copy of this LocalTime with the nano-of-second value altered.
withNano(int) - Method in class java.time.OffsetDateTime
Returns a copy of this OffsetDateTime with the nano-of-second value altered.
withNano(int) - Method in class java.time.OffsetTime
Returns a copy of this OffsetTime with the nano-of-second value altered.
withNano(int) - Method in class java.time.ZonedDateTime
Returns a copy of this ZonedDateTime with the nano-of-second value altered.
withNanos(int) - Method in class java.time.Duration
Returns a copy of this duration with the specified nano-of-second.
withNegativeSign(char) - Method in class java.time.format.DecimalStyle
Returns a copy of the info with a new character that represents the negative sign.
withOffsetSameInstant(ZoneOffset) - Method in class java.time.OffsetDateTime
Returns a copy of this OffsetDateTime with the specified offset ensuring that the result is at the same instant.
withOffsetSameInstant(ZoneOffset) - Method in class java.time.OffsetTime
Returns a copy of this OffsetTime with the specified offset ensuring that the result is at the same instant on an implied day.
withOffsetSameLocal(ZoneOffset) - Method in class java.time.OffsetDateTime
Returns a copy of this OffsetDateTime with the specified offset ensuring that the result has the same local date-time.
withOffsetSameLocal(ZoneOffset) - Method in class java.time.OffsetTime
Returns a copy of this OffsetTime with the specified offset ensuring that the result has the same local time.
withoutPadding() - Method in class java.util.Base64.Encoder
Returns an encoder instance that encodes equivalently to this one, but without adding any padding character at the end of the encoded byte data.
withPositiveSign(char) - Method in class java.time.format.DecimalStyle
Returns a copy of the info with a new character that represents the positive sign.
withResolverFields(TemporalField...) - Method in class java.time.format.DateTimeFormatter
Returns a copy of this formatter with a new set of resolver fields.
withResolverFields(Set<TemporalField>) - Method in class java.time.format.DateTimeFormatter
Returns a copy of this formatter with a new set of resolver fields.
withResolverStyle(ResolverStyle) - Method in class java.time.format.DateTimeFormatter
Returns a copy of this formatter with a new resolver style.
withSecond(int) - Method in class java.time.LocalDateTime
Returns a copy of this LocalDateTime with the second-of-minute value altered.
withSecond(int) - Method in class java.time.LocalTime
Returns a copy of this LocalTime with the second-of-minute value altered.
withSecond(int) - Method in class java.time.OffsetDateTime
Returns a copy of this OffsetDateTime with the second-of-minute value altered.
withSecond(int) - Method in class java.time.OffsetTime
Returns a copy of this OffsetTime with the second-of-minute value altered.
withSecond(int) - Method in class java.time.ZonedDateTime
Returns a copy of this ZonedDateTime with the second-of-minute value altered.
withSeconds(long) - Method in class java.time.Duration
Returns a copy of this duration with the specified amount of seconds.
withThreadPool(ExecutorService) - Static method in class java.nio.channels.AsynchronousChannelGroup
Creates an asynchronous channel group with a given thread pool.
withVariant(HijrahChronology) - Method in class java.time.chrono.HijrahDate
Returns a HijrahDate with the Chronology requested.
withYear(int) - Method in class java.time.LocalDate
Returns a copy of this date with the year altered.
withYear(int) - Method in class java.time.LocalDateTime
Returns a copy of this LocalDateTime with the year altered.
withYear(int) - Method in class java.time.OffsetDateTime
Returns a copy of this OffsetDateTime with the year altered.
withYear(int) - Method in class java.time.YearMonth
Returns a copy of this YearMonth with the year altered.
withYear(int) - Method in class java.time.ZonedDateTime
Returns a copy of this ZonedDateTime with the year value altered.
withYears(int) - Method in class java.time.Period
Returns a copy of this period with the specified amount of years.
withZeroDigit(char) - Method in class java.time.format.DecimalStyle
Returns a copy of the info with a new character that represents zero.
withZone(ZoneId) - Method in class java.time.Clock
Returns a copy of this clock with a different time-zone.
withZone(ZoneId) - Method in class java.time.format.DateTimeFormatter
Returns a copy of this formatter with a new override zone.
withZoneSameInstant(ZoneId) - Method in interface java.time.chrono.ChronoZonedDateTime
Returns a copy of this date-time with a different time-zone, retaining the instant.
withZoneSameInstant(ZoneId) - Method in class java.time.ZonedDateTime
Returns a copy of this date-time with a different time-zone, retaining the instant.
withZoneSameLocal(ZoneId) - Method in interface java.time.chrono.ChronoZonedDateTime
Returns a copy of this ZonedDateTime with a different time-zone, retaining the local date-time if possible.
withZoneSameLocal(ZoneId) - Method in class java.time.ZonedDateTime
Returns a copy of this date-time with a different time-zone, retaining the local date-time if possible.
WORD - Static variable in interface javax.accessibility.AccessibleText
Constant used to indicate that the part of the text that should be retrieved is a word.
WORD_SPACING - Static variable in class javax.swing.text.html.CSS.Attribute
wordChars(int, int) - Method in class java.io.StreamTokenizer
Specifies that all characters c in the range low <= c <= high are word constituents.
work_pending() - Method in class org.omg.CORBA.ORB
Returns true if the ORB needs the main thread to perform some work, and false if the ORB does not need the main thread.
wrap() - Method in class java.lang.invoke.MethodType
Converts all primitive types to their corresponding wrapper types.
wrap(byte[], int, int) - Static method in class java.nio.ByteBuffer
Wraps a byte array into a buffer.
wrap(byte[]) - Static method in class java.nio.ByteBuffer
Wraps a byte array into a buffer.
wrap(char[], int, int) - Static method in class java.nio.CharBuffer
Wraps a char array into a buffer.
wrap(char[]) - Static method in class java.nio.CharBuffer
Wraps a char array into a buffer.
wrap(CharSequence, int, int) - Static method in class java.nio.CharBuffer
Wraps a character sequence into a buffer.
wrap(CharSequence) - Static method in class java.nio.CharBuffer
Wraps a character sequence into a buffer.
wrap(double[], int, int) - Static method in class java.nio.DoubleBuffer
Wraps a double array into a buffer.
wrap(double[]) - Static method in class java.nio.DoubleBuffer
Wraps a double array into a buffer.
wrap(float[], int, int) - Static method in class java.nio.FloatBuffer
Wraps a float array into a buffer.
wrap(float[]) - Static method in class java.nio.FloatBuffer
Wraps a float array into a buffer.
wrap(int[], int, int) - Static method in class java.nio.IntBuffer
Wraps an int array into a buffer.
wrap(int[]) - Static method in class java.nio.IntBuffer
Wraps an int array into a buffer.
wrap(long[], int, int) - Static method in class java.nio.LongBuffer
Wraps a long array into a buffer.
wrap(long[]) - Static method in class java.nio.LongBuffer
Wraps a long array into a buffer.
wrap(short[], int, int) - Static method in class java.nio.ShortBuffer
Wraps a short array into a buffer.
wrap(short[]) - Static method in class java.nio.ShortBuffer
Wraps a short array into a buffer.
wrap(InputStream) - Method in class java.util.Base64.Decoder
Returns an input stream for decoding Base64 encoded byte stream.
wrap(OutputStream) - Method in class java.util.Base64.Encoder
Wraps an output stream for encoding byte data using the Base64 encoding scheme.
wrap(Key) - Method in class javax.crypto.Cipher
Wrap a key.
wrap(ByteBuffer, ByteBuffer) - Method in class javax.net.ssl.SSLEngine
Attempts to encode a buffer of plaintext application data into SSL/TLS network data.
wrap(ByteBuffer[], ByteBuffer) - Method in class javax.net.ssl.SSLEngine
Attempts to encode plaintext bytes from a sequence of data buffers into SSL/TLS network data.
wrap(ByteBuffer[], int, int, ByteBuffer) - Method in class javax.net.ssl.SSLEngine
Attempts to encode plaintext bytes from a subsequence of data buffers into SSL/TLS network data.
wrap(byte[], int, int) - Method in interface javax.security.sasl.SaslClient
Wraps a byte array to be sent to the server.
wrap(byte[], int, int) - Method in interface javax.security.sasl.SaslServer
Wraps a byte array to be sent to the client.
wrap(byte[], int, int, MessageProp) - Method in interface org.ietf.jgss.GSSContext
Applies per-message security services over the established security context.
wrap(InputStream, OutputStream, MessageProp) - Method in interface org.ietf.jgss.GSSContext
Applies per-message security services over the established security context using streams.
WRAP_MODE - Static variable in class javax.crypto.Cipher
Constant used to initialize cipher to key-wrapping mode.
WRAP_TAB_LAYOUT - Static variable in class javax.swing.JTabbedPane
The tab layout policy for wrapping tabs in multiple runs when all tabs will not fit within a single run.
wrapException(Throwable) - Static method in class javax.rmi.CORBA.Util
Wraps an exception thrown by an implementation method.
wrapException(Throwable) - Method in interface javax.rmi.CORBA.UtilDelegate
Delegation call for Util.wrapException(java.lang.Throwable).
WrappedPlainView - Class in javax.swing.text
View of plain text (text with only one font and color) that does line-wrapping.
WrappedPlainView(Element) - Constructor for class javax.swing.text.WrappedPlainView
Creates a new WrappedPlainView.
WrappedPlainView(Element, boolean) - Constructor for class javax.swing.text.WrappedPlainView
Creates a new WrappedPlainView.
Wrapper - Interface in java.sql
Interface for JDBC classes which provide the ability to retrieve the delegate instance when the instance in question is in fact a proxy class.
wrapperInstanceTarget(Object) - Static method in class java.lang.invoke.MethodHandleProxies
Produces or recovers a target method handle which is behaviorally equivalent to the unique method of this wrapper instance.
wrapperInstanceType(Object) - Static method in class java.lang.invoke.MethodHandleProxies
Recovers the unique single-method interface type for which this wrapper instance was created.
writableAction - Static variable in class javax.swing.text.DefaultEditorKit
Name of the action to set the editor into writeable mode.
WritableByteChannel - Interface in java.nio.channels
A channel that can write bytes.
WritableRaster - Class in java.awt.image
This class extends Raster to provide pixel writing capabilities.
WritableRaster(SampleModel, Point) - Constructor for class java.awt.image.WritableRaster
Constructs a WritableRaster with the given SampleModel.
WritableRaster(SampleModel, DataBuffer, Point) - Constructor for class java.awt.image.WritableRaster
Constructs a WritableRaster with the given SampleModel and DataBuffer.
WritableRaster(SampleModel, DataBuffer, Rectangle, Point, WritableRaster) - Constructor for class java.awt.image.WritableRaster
Constructs a WritableRaster with the given SampleModel, DataBuffer, and parent.
WritableRenderedImage - Interface in java.awt.image
WriteableRenderedImage is a common interface for objects which contain or can produce image data in the form of Rasters and which can be modified and/or written over.
write(String) - Method in class java.awt.color.ICC_Profile
Write this ICC_Profile to a file.
write(OutputStream) - Method in class java.awt.color.ICC_Profile
Write this ICC_Profile to an OutputStream.
write(int) - Method in class java.io.BufferedOutputStream
Writes the specified byte to this buffered output stream.
write(byte[], int, int) - Method in class java.io.BufferedOutputStream
Writes len bytes from the specified byte array starting at offset off to this buffered output stream.
write(int) - Method in class java.io.BufferedWriter
Writes a single character.
write(char[], int, int) - Method in class java.io.BufferedWriter
Writes a portion of an array of characters.
write(String, int, int) - Method in class java.io.BufferedWriter
Writes a portion of a String.
write(int) - Method in class java.io.ByteArrayOutputStream
Writes the specified byte to this byte array output stream.
write(byte[], int, int) - Method in class java.io.ByteArrayOutputStream
Writes len bytes from the specified byte array starting at offset off to this byte array output stream.
write(int) - Method in class java.io.CharArrayWriter
Writes a character to the buffer.
write(char[], int, int) - Method in class java.io.CharArrayWriter
Writes characters to the buffer.
write(String, int, int) - Method in class java.io.CharArrayWriter
Write a portion of a string to the buffer.
write(int) - Method in interface java.io.DataOutput
Writes to the output stream the eight low-order bits of the argument b.
write(byte[]) - Method in interface java.io.DataOutput
Writes to the output stream all the bytes in array b.
write(byte[], int, int) - Method in interface java.io.DataOutput
Writes len bytes from array b, in order, to the output stream.
write(int) - Method in class java.io.DataOutputStream
Writes the specified byte (the low eight bits of the argument b) to the underlying output stream.
write(byte[], int, int) - Method in class java.io.DataOutputStream
Writes len bytes from the specified byte array starting at offset off to the underlying output stream.
write(int) - Method in class java.io.FileOutputStream
Writes the specified byte to this file output stream.
write(byte[]) - Method in class java.io.FileOutputStream
Writes b.length bytes from the specified byte array to this file output stream.
write(byte[], int, int) - Method in class java.io.FileOutputStream
Writes len bytes from the specified byte array starting at offset off to this file output stream.
write(int) - Method in class java.io.FilterOutputStream
Writes the specified byte to this output stream.
write(byte[]) - Method in class java.io.FilterOutputStream
Writes b.length bytes to this output stream.
write(byte[], int, int) - Method in class java.io.FilterOutputStream
Writes len bytes from the specified byte array starting at offset off to this output stream.
write(int) - Method in class java.io.FilterWriter
Writes a single character.
write(char[], int, int) - Method in class java.io.FilterWriter
Writes a portion of an array of characters.
write(String, int, int) - Method in class java.io.FilterWriter
Writes a portion of a string.
write(int) - Method in interface java.io.ObjectOutput
Writes a byte.
write(byte[]) - Method in interface java.io.ObjectOutput
Writes an array of bytes.
write(byte[], int, int) - Method in interface java.io.ObjectOutput
Writes a sub array of bytes.
write(ObjectOutput) - Method in class java.io.ObjectOutputStream.PutField
Deprecated.
This method does not write the values contained by this PutField object in a proper format, and may result in corruption of the serialization stream. The correct way to write PutField data is by calling the ObjectOutputStream.writeFields() method.
write(int) - Method in class java.io.ObjectOutputStream
Writes a byte.
write(byte[]) - Method in class java.io.ObjectOutputStream
Writes an array of bytes.
write(byte[], int, int) - Method in class java.io.ObjectOutputStream
Writes a sub array of bytes.
write(int) - Method in class java.io.OutputStream
Writes the specified byte to this output stream.
write(byte[]) - Method in class java.io.OutputStream
Writes b.length bytes from the specified byte array to this output stream.
write(byte[], int, int) - Method in class java.io.OutputStream
Writes len bytes from the specified byte array starting at offset off to this output stream.
write(int) - Method in class java.io.OutputStreamWriter
Writes a single character.
write(char[], int, int) - Method in class java.io.OutputStreamWriter
Writes a portion of an array of characters.
write(String, int, int) - Method in class java.io.OutputStreamWriter
Writes a portion of a string.
write(int) - Method in class java.io.PipedOutputStream
Writes the specified byte to the piped output stream.
write(byte[], int, int) - Method in class java.io.PipedOutputStream
Writes len bytes from the specified byte array starting at offset off to this piped output stream.
write(int) - Method in class java.io.PipedWriter
Writes the specified char to the piped output stream.
write(char[], int, int) - Method in class java.io.PipedWriter
Writes len characters from the specified character array starting at offset off to this piped output stream.
write(int) - Method in class java.io.PrintStream
Writes the specified byte to this stream.
write(byte[], int, int) - Method in class java.io.PrintStream
Writes len bytes from the specified byte array starting at offset off to this stream.
write(int) - Method in class java.io.PrintWriter
Writes a single character.
write(char[], int, int) - Method in class java.io.PrintWriter
Writes A Portion of an array of characters.
write(char[]) - Method in class java.io.PrintWriter
Writes an array of characters.
write(String, int, int) - Method in class java.io.PrintWriter
Writes a portion of a string.
write(String) - Method in class java.io.PrintWriter
Writes a string.
write(int) - Method in class java.io.RandomAccessFile
Writes the specified byte to this file.
write(byte[]) - Method in class java.io.RandomAccessFile
Writes b.length bytes from the specified byte array to this file, starting at the current file pointer.
write(byte[], int, int) - Method in class java.io.RandomAccessFile
Writes len bytes from the specified byte array starting at offset off to this file.
write(int) - Method in class java.io.StringWriter
Write a single character.
write(char[], int, int) - Method in class java.io.StringWriter
Write a portion of an array of characters.
write(String) - Method in class java.io.StringWriter
Write a string.
write(String, int, int) - Method in class java.io.StringWriter
Write a portion of a string.
write(int) - Method in class java.io.Writer
Writes a single character.
write(char[]) - Method in class java.io.Writer
Writes an array of characters.
write(char[], int, int) - Method in class java.io.Writer
Writes a portion of an array of characters.
write(String) - Method in class java.io.Writer
Writes a string.
write(String, int, int) - Method in class java.io.Writer
Writes a portion of a string.
write(ByteBuffer, A, CompletionHandler<Integer, ? super A>) - Method in interface java.nio.channels.AsynchronousByteChannel
Writes a sequence of bytes to this channel from the given buffer.
write(ByteBuffer) - Method in interface java.nio.channels.AsynchronousByteChannel
Writes a sequence of bytes to this channel from the given buffer.
write(ByteBuffer, long, A, CompletionHandler<Integer, ? super A>) - Method in class java.nio.channels.AsynchronousFileChannel
Writes a sequence of bytes to this channel from the given buffer, starting at the given file position.
write(ByteBuffer, long) - Method in class java.nio.channels.AsynchronousFileChannel
Writes a sequence of bytes to this channel from the given buffer, starting at the given file position.
write(ByteBuffer, long, TimeUnit, A, CompletionHandler<Integer, ? super A>) - Method in class java.nio.channels.AsynchronousSocketChannel
Writes a sequence of bytes to this channel from the given buffer.
write(ByteBuffer, A, CompletionHandler<Integer, ? super A>) - Method in class java.nio.channels.AsynchronousSocketChannel
write(ByteBuffer) - Method in class java.nio.channels.AsynchronousSocketChannel
write(ByteBuffer[], int, int, long, TimeUnit, A, CompletionHandler<Long, ? super A>) - Method in class java.nio.channels.AsynchronousSocketChannel
Writes a sequence of bytes to this channel from a subsequence of the given buffers.
write(ByteBuffer) - Method in class java.nio.channels.DatagramChannel
Writes a datagram to this channel.
write(ByteBuffer[], int, int) - Method in class java.nio.channels.DatagramChannel
Writes a datagram to this channel.
write(ByteBuffer[]) - Method in class java.nio.channels.DatagramChannel
Writes a datagram to this channel.
write(ByteBuffer) - Method in class java.nio.channels.FileChannel
Writes a sequence of bytes to this channel from the given buffer.
write(ByteBuffer[], int, int) - Method in class java.nio.channels.FileChannel
Writes a sequence of bytes to this channel from a subsequence of the given buffers.
write(ByteBuffer[]) - Method in class java.nio.channels.FileChannel
Writes a sequence of bytes to this channel from the given buffers.
write(ByteBuffer, long) - Method in class java.nio.channels.FileChannel
Writes a sequence of bytes to this channel from the given buffer, starting at the given file position.
write(ByteBuffer[], int, int) - Method in interface java.nio.channels.GatheringByteChannel
Writes a sequence of bytes to this channel from a subsequence of the given buffers.
write(ByteBuffer[]) - Method in interface java.nio.channels.GatheringByteChannel
Writes a sequence of bytes to this channel from the given buffers.
write(ByteBuffer) - Method in interface java.nio.channels.SeekableByteChannel
Writes a sequence of bytes to this channel from the given buffer.
write(ByteBuffer) - Method in class java.nio.channels.SocketChannel
write(ByteBuffer[], int, int) - Method in class java.nio.channels.SocketChannel
write(ByteBuffer[]) - Method in class java.nio.channels.SocketChannel
write(ByteBuffer) - Method in interface java.nio.channels.WritableByteChannel
Writes a sequence of bytes to this channel from the given buffer.
write(String, ByteBuffer) - Method in interface java.nio.file.attribute.UserDefinedFileAttributeView
Writes the value of a user-defined attribute from a buffer.
write(Path, byte[], OpenOption...) - Static method in class java.nio.file.Files
Writes bytes to a file.
write(Path, Iterable<? extends CharSequence>, Charset, OpenOption...) - Static method in class java.nio.file.Files
Write lines of text to a file.
write(Path, Iterable<? extends CharSequence>, OpenOption...) - Static method in class java.nio.file.Files
Write lines of text to a file.
write(int) - Method in class java.rmi.server.LogStream
Deprecated.
no replacement
write(byte[], int, int) - Method in class java.rmi.server.LogStream
Deprecated.
no replacement
write(ObjectOutput) - Method in class java.rmi.server.ObjID
Marshals a binary representation of this ObjID to an ObjectOutput instance.
write(DataOutput) - Method in class java.rmi.server.UID
Marshals a binary representation of this UID to a DataOutput instance.
write(int) - Method in class java.security.DigestOutputStream
Updates the message digest (if the digest function is on) using the specified byte, and in any case writes the byte to the output stream.
write(byte[], int, int) - Method in class java.security.DigestOutputStream
Updates the message digest (if the digest function is on) using the specified subarray, and in any case writes the subarray to the output stream.
write(OutputStream) - Method in class java.util.jar.Manifest
Writes the Manifest to the specified OutputStream.
write(int) - Method in class java.util.zip.CheckedOutputStream
Writes a byte.
write(byte[], int, int) - Method in class java.util.zip.CheckedOutputStream
Writes an array of bytes.
write(int) - Method in class java.util.zip.DeflaterOutputStream
Writes a byte to the compressed output stream.
write(byte[], int, int) - Method in class java.util.zip.DeflaterOutputStream
Writes an array of bytes to the compressed output stream.
write(byte[], int, int) - Method in class java.util.zip.GZIPOutputStream
Writes array of bytes to the compressed output stream.
write(int) - Method in class java.util.zip.InflaterOutputStream
Writes a byte to the uncompressed output stream.
write(byte[], int, int) - Method in class java.util.zip.InflaterOutputStream
Writes an array of bytes to the uncompressed output stream.
write(byte[], int, int) - Method in class java.util.zip.ZipOutputStream
Writes an array of bytes to the current ZIP entry data.
write(int) - Method in class javax.crypto.CipherOutputStream
Writes the specified byte to this output stream.
write(byte[]) - Method in class javax.crypto.CipherOutputStream
Writes b.length bytes from the specified byte array to this output stream.
write(byte[], int, int) - Method in class javax.crypto.CipherOutputStream
Writes len bytes from the specified byte array starting at offset off to this output stream.
write(RenderedImage, String, ImageOutputStream) - Static method in class javax.imageio.ImageIO
Writes an image using the an arbitrary ImageWriter that supports the given format to an ImageOutputStream.
write(RenderedImage, String, File) - Static method in class javax.imageio.ImageIO
Writes an image using an arbitrary ImageWriter that supports the given format to a File.
write(RenderedImage, String, OutputStream) - Static method in class javax.imageio.ImageIO
Writes an image using an arbitrary ImageWriter that supports the given format to an OutputStream.
write(IIOMetadata, IIOImage, ImageWriteParam) - Method in class javax.imageio.ImageWriter
Appends a complete image stream containing a single image and associated stream and image metadata and thumbnails to the output.
write(IIOImage) - Method in class javax.imageio.ImageWriter
Appends a complete image stream containing a single image with default metadata and thumbnails to the output.
write(RenderedImage) - Method in class javax.imageio.ImageWriter
Appends a complete image stream consisting of a single image with default metadata and thumbnails to the output.
write(int) - Method in class javax.imageio.stream.FileCacheImageOutputStream
write(byte[], int, int) - Method in class javax.imageio.stream.FileCacheImageOutputStream
write(int) - Method in class javax.imageio.stream.FileImageOutputStream
write(byte[], int, int) - Method in class javax.imageio.stream.FileImageOutputStream
write(int) - Method in interface javax.imageio.stream.ImageOutputStream
Writes a single byte to the stream at the current position.
write(byte[]) - Method in interface javax.imageio.stream.ImageOutputStream
Writes a sequence of bytes to the stream at the current position.
write(byte[], int, int) - Method in interface javax.imageio.stream.ImageOutputStream
Writes a sequence of bytes to the stream at the current position.
write(int) - Method in class javax.imageio.stream.ImageOutputStreamImpl
write(byte[]) - Method in class javax.imageio.stream.ImageOutputStreamImpl
write(byte[], int, int) - Method in class javax.imageio.stream.ImageOutputStreamImpl
write(int) - Method in class javax.imageio.stream.MemoryCacheImageOutputStream
write(byte[], int, int) - Method in class javax.imageio.stream.MemoryCacheImageOutputStream
write(Sequence, int, OutputStream) - Static method in class javax.sound.midi.MidiSystem
Writes a stream of bytes representing a file of the MIDI file type indicated to the output stream provided.
write(Sequence, int, File) - Static method in class javax.sound.midi.MidiSystem
Writes a stream of bytes representing a file of the MIDI file type indicated to the external file provided.
write(Sequence, int, OutputStream) - Method in class javax.sound.midi.spi.MidiFileWriter
Writes a stream of bytes representing a MIDI file of the file type indicated to the output stream provided.
write(Sequence, int, File) - Method in class javax.sound.midi.spi.MidiFileWriter
Writes a stream of bytes representing a MIDI file of the file type indicated to the external file provided.
write(AudioInputStream, AudioFileFormat.Type, OutputStream) - Static method in class javax.sound.sampled.AudioSystem
Writes a stream of bytes representing an audio file of the specified file type to the output stream provided.
write(AudioInputStream, AudioFileFormat.Type, File) - Static method in class javax.sound.sampled.AudioSystem
Writes a stream of bytes representing an audio file of the specified file type to the external file provided.
write(byte[], int, int) - Method in interface javax.sound.sampled.SourceDataLine
Writes audio data to the mixer via this source data line.
write(AudioInputStream, AudioFileFormat.Type, OutputStream) - Method in class javax.sound.sampled.spi.AudioFileWriter
Writes a stream of bytes representing an audio file of the file type indicated to the output stream provided.
write(AudioInputStream, AudioFileFormat.Type, File) - Method in class javax.sound.sampled.spi.AudioFileWriter
Writes a stream of bytes representing an audio file of the file format indicated to the external file provided.
write() - Method in class javax.swing.text.AbstractWriter
This abstract method needs to be implemented by subclasses.
write(char) - Method in class javax.swing.text.AbstractWriter
Writes out a character.
write(String) - Method in class javax.swing.text.AbstractWriter
Writes out a string.
write(char[], int, int) - Method in class javax.swing.text.AbstractWriter
All write methods call into this one.
write(OutputStream, Document, int, int) - Method in class javax.swing.text.DefaultEditorKit
Writes content from a document to the given stream in a format appropriate for this kind of content handler.
write(Writer, Document, int, int) - Method in class javax.swing.text.DefaultEditorKit
Writes content from a document to the given stream as plain text.
write(OutputStream, Document, int, int) - Method in class javax.swing.text.EditorKit
Writes content from a document to the given stream in a format appropriate for this kind of content handler.
write(Writer, Document, int, int) - Method in class javax.swing.text.EditorKit
Writes content from a document to the given stream in a format appropriate for this kind of content handler.
write(Writer, Document, int, int) - Method in class javax.swing.text.html.HTMLEditorKit
Write content from a document to the given stream in a format appropriate for this kind of content handler.
write() - Method in class javax.swing.text.html.HTMLWriter
Iterates over the Element tree and controls the writing out of all the tags and its attributes.
write() - Method in class javax.swing.text.html.MinimalHTMLWriter
Generates HTML output from a StyledDocument.
write(Writer) - Method in class javax.swing.text.JTextComponent
Stores the contents of the model into the given stream.
write(OutputStream, Document, int, int) - Method in class javax.swing.text.rtf.RTFEditorKit
Write content from a document to the given stream in a format appropriate for this kind of content handler.
write(Writer, Document, int, int) - Method in class javax.swing.text.rtf.RTFEditorKit
Write content from a document to the given stream as plain text.
write(OutputStream, Any[]) - Static method in class org.omg.CORBA.AnySeqHelper
write(OutputStream, boolean[]) - Static method in class org.omg.CORBA.BooleanSeqHelper
write(OutputStream, char[]) - Static method in class org.omg.CORBA.CharSeqHelper
write(OutputStream, CompletionStatus) - Static method in class org.omg.CORBA.CompletionStatusHelper
write(OutputStream, Current) - Static method in class org.omg.CORBA.CurrentHelper
write(OutputStream, DefinitionKind) - Static method in class org.omg.CORBA.DefinitionKindHelper
write(OutputStream, double[]) - Static method in class org.omg.CORBA.DoubleSeqHelper
write(OutputStream, String) - Static method in class org.omg.CORBA.FieldNameHelper
write(OutputStream, float[]) - Static method in class org.omg.CORBA.FloatSeqHelper
write(OutputStream, String) - Static method in class org.omg.CORBA.IdentifierHelper
write(OutputStream, IDLType) - Static method in class org.omg.CORBA.IDLTypeHelper
write(OutputStream, long[]) - Static method in class org.omg.CORBA.LongLongSeqHelper
write(OutputStream, int[]) - Static method in class org.omg.CORBA.LongSeqHelper
write(OutputStream, NameValuePair) - Static method in class org.omg.CORBA.NameValuePairHelper
write(OutputStream, Object) - Static method in class org.omg.CORBA.ObjectHelper
write(OutputStream, byte[]) - Static method in class org.omg.CORBA.OctetSeqHelper
write(OutputStream, ParameterMode) - Static method in class org.omg.CORBA.ParameterModeHelper
write(OutputStream, short) - Static method in class org.omg.CORBA.PolicyErrorCodeHelper
write(OutputStream, PolicyError) - Static method in class org.omg.CORBA.PolicyErrorHelper
write(OutputStream, Policy) - Static method in class org.omg.CORBA.PolicyHelper
write(OutputStream, Policy[]) - Static method in class org.omg.CORBA.PolicyListHelper
write(OutputStream, int) - Static method in class org.omg.CORBA.PolicyTypeHelper
write(int) - Method in class org.omg.CORBA.portable.OutputStream
Writes an integer (length of arrays) onto this stream.
write(OutputStream, String) - Static method in class org.omg.CORBA.RepositoryIdHelper
write(OutputStream, ServiceDetail) - Static method in class org.omg.CORBA.ServiceDetailHelper
write(OutputStream, ServiceInformation) - Static method in class org.omg.CORBA.ServiceInformationHelper
write(OutputStream, SetOverrideType) - Static method in class org.omg.CORBA.SetOverrideTypeHelper
write(OutputStream, short[]) - Static method in class org.omg.CORBA.ShortSeqHelper
write(OutputStream, String[]) - Static method in class org.omg.CORBA.StringSeqHelper
write(OutputStream, String) - Static method in class org.omg.CORBA.StringValueHelper
write(OutputStream, StructMember) - Static method in class org.omg.CORBA.StructMemberHelper
write(OutputStream, long[]) - Static method in class org.omg.CORBA.ULongLongSeqHelper
write(OutputStream, int[]) - Static method in class org.omg.CORBA.ULongSeqHelper
write(OutputStream, UnionMember) - Static method in class org.omg.CORBA.UnionMemberHelper
write(OutputStream, UnknownUserException) - Static method in class org.omg.CORBA.UnknownUserExceptionHelper
write(OutputStream, short[]) - Static method in class org.omg.CORBA.UShortSeqHelper
write(OutputStream, Serializable) - Static method in class org.omg.CORBA.ValueBaseHelper
write(OutputStream, ValueMember) - Static method in class org.omg.CORBA.ValueMemberHelper
write(OutputStream, String) - Static method in class org.omg.CORBA.VersionSpecHelper
write(OutputStream, short) - Static method in class org.omg.CORBA.VisibilityHelper
write(OutputStream, char[]) - Static method in class org.omg.CORBA.WCharSeqHelper
write(OutputStream, WrongTransaction) - Static method in class org.omg.CORBA.WrongTransactionHelper
write(OutputStream, String[]) - Static method in class org.omg.CORBA.WStringSeqHelper
write(OutputStream, String) - Static method in class org.omg.CORBA.WStringValueHelper
write(OutputStream, Binding) - Static method in class org.omg.CosNaming.BindingHelper
write(OutputStream, BindingIterator) - Static method in class org.omg.CosNaming.BindingIteratorHelper
write(OutputStream, Binding[]) - Static method in class org.omg.CosNaming.BindingListHelper
write(OutputStream, BindingType) - Static method in class org.omg.CosNaming.BindingTypeHelper
write(OutputStream, String) - Static method in class org.omg.CosNaming.IstringHelper
write(OutputStream, NameComponent) - Static method in class org.omg.CosNaming.NameComponentHelper
write(OutputStream, NameComponent[]) - Static method in class org.omg.CosNaming.NameHelper
write(OutputStream, NamingContextExt) - Static method in class org.omg.CosNaming.NamingContextExtHelper
write(OutputStream, String) - Static method in class org.omg.CosNaming.NamingContextExtPackage.AddressHelper
write(OutputStream, InvalidAddress) - Static method in class org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper
write(OutputStream, String) - Static method in class org.omg.CosNaming.NamingContextExtPackage.StringNameHelper
write(OutputStream, String) - Static method in class org.omg.CosNaming.NamingContextExtPackage.URLStringHelper
write(OutputStream, NamingContext) - Static method in class org.omg.CosNaming.NamingContextHelper
write(OutputStream, AlreadyBound) - Static method in class org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper
write(OutputStream, CannotProceed) - Static method in class org.omg.CosNaming.NamingContextPackage.CannotProceedHelper
write(OutputStream, InvalidName) - Static method in class org.omg.CosNaming.NamingContextPackage.InvalidNameHelper
write(OutputStream, NotEmpty) - Static method in class org.omg.CosNaming.NamingContextPackage.NotEmptyHelper
write(OutputStream, NotFound) - Static method in class org.omg.CosNaming.NamingContextPackage.NotFoundHelper
write(OutputStream, NotFoundReason) - Static method in class org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper
write(OutputStream, Any[]) - Static method in class org.omg.DynamicAny.AnySeqHelper
write(OutputStream, DynAnyFactory) - Static method in class org.omg.DynamicAny.DynAnyFactoryHelper
write(OutputStream, InconsistentTypeCode) - Static method in class org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper
write(OutputStream, DynAny) - Static method in class org.omg.DynamicAny.DynAnyHelper
write(OutputStream, InvalidValue) - Static method in class org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper
write(OutputStream, TypeMismatch) - Static method in class org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper
write(OutputStream, DynAny[]) - Static method in class org.omg.DynamicAny.DynAnySeqHelper
write(OutputStream, DynArray) - Static method in class org.omg.DynamicAny.DynArrayHelper
write(OutputStream, DynEnum) - Static method in class org.omg.DynamicAny.DynEnumHelper
write(OutputStream, DynFixed) - Static method in class org.omg.DynamicAny.DynFixedHelper
write(OutputStream, DynSequence) - Static method in class org.omg.DynamicAny.DynSequenceHelper
write(OutputStream, DynStruct) - Static method in class org.omg.DynamicAny.DynStructHelper
write(OutputStream, DynUnion) - Static method in class org.omg.DynamicAny.DynUnionHelper
write(OutputStream, DynValue) - Static method in class org.omg.DynamicAny.DynValueHelper
write(OutputStream, String) - Static method in class org.omg.DynamicAny.FieldNameHelper
write(OutputStream, NameDynAnyPair) - Static method in class org.omg.DynamicAny.NameDynAnyPairHelper
write(OutputStream, NameDynAnyPair[]) - Static method in class org.omg.DynamicAny.NameDynAnyPairSeqHelper
write(OutputStream, NameValuePair) - Static method in class org.omg.DynamicAny.NameValuePairHelper
write(OutputStream, NameValuePair[]) - Static method in class org.omg.DynamicAny.NameValuePairSeqHelper
write(OutputStream, CodecFactory) - Static method in class org.omg.IOP.CodecFactoryHelper
write(OutputStream, UnknownEncoding) - Static method in class org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper
write(OutputStream, FormatMismatch) - Static method in class org.omg.IOP.CodecPackage.FormatMismatchHelper
write(OutputStream, InvalidTypeForEncoding) - Static method in class org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper
write(OutputStream, TypeMismatch) - Static method in class org.omg.IOP.CodecPackage.TypeMismatchHelper
write(OutputStream, int) - Static method in class org.omg.IOP.ComponentIdHelper
write(OutputStream, IOR) - Static method in class org.omg.IOP.IORHelper
write(OutputStream, TaggedComponent[]) - Static method in class org.omg.IOP.MultipleComponentProfileHelper
write(OutputStream, int) - Static method in class org.omg.IOP.ProfileIdHelper
write(OutputStream, ServiceContext) - Static method in class org.omg.IOP.ServiceContextHelper
write(OutputStream, ServiceContext[]) - Static method in class org.omg.IOP.ServiceContextListHelper
write(OutputStream, int) - Static method in class org.omg.IOP.ServiceIdHelper
write(OutputStream, TaggedComponent) - Static method in class org.omg.IOP.TaggedComponentHelper
write(OutputStream, TaggedProfile) - Static method in class org.omg.IOP.TaggedProfileHelper
write(OutputStream, short) - Static method in class org.omg.Messaging.SyncScopeHelper
write(OutputStream, int) - Static method in class org.omg.PortableInterceptor.AdapterManagerIdHelper
write(OutputStream, String[]) - Static method in class org.omg.PortableInterceptor.AdapterNameHelper
write(OutputStream, short) - Static method in class org.omg.PortableInterceptor.AdapterStateHelper
write(OutputStream, Current) - Static method in class org.omg.PortableInterceptor.CurrentHelper
write(OutputStream, ForwardRequest) - Static method in class org.omg.PortableInterceptor.ForwardRequestHelper
write(OutputStream, InvalidSlot) - Static method in class org.omg.PortableInterceptor.InvalidSlotHelper
write(OutputStream, IORInterceptor_3_0) - Static method in class org.omg.PortableInterceptor.IORInterceptor_3_0Helper
write(OutputStream, byte[]) - Static method in class org.omg.PortableInterceptor.ObjectIdHelper
write(OutputStream, ObjectReferenceFactory) - Static method in class org.omg.PortableInterceptor.ObjectReferenceFactoryHelper
write(OutputStream, ObjectReferenceTemplate) - Static method in class org.omg.PortableInterceptor.ObjectReferenceTemplateHelper
write(OutputStream, ObjectReferenceTemplate[]) - Static method in class org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper
write(OutputStream, String) - Static method in class org.omg.PortableInterceptor.ORBIdHelper
write(OutputStream, DuplicateName) - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper
write(OutputStream, InvalidName) - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper
write(OutputStream, String) - Static method in class org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper
write(OutputStream, String) - Static method in class org.omg.PortableInterceptor.ServerIdHelper
write(OutputStream, Current) - Static method in class org.omg.PortableServer.CurrentHelper
write(OutputStream, NoContext) - Static method in class org.omg.PortableServer.CurrentPackage.NoContextHelper
write(OutputStream, ForwardRequest) - Static method in class org.omg.PortableServer.ForwardRequestHelper
write(OutputStream, POA) - Static method in class org.omg.PortableServer.POAHelper
write(OutputStream, AdapterInactive) - Static method in class org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper
write(OutputStream, AdapterAlreadyExists) - Static method in class org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper
write(OutputStream, AdapterNonExistent) - Static method in class org.omg.PortableServer.POAPackage.AdapterNonExistentHelper
write(OutputStream, InvalidPolicy) - Static method in class org.omg.PortableServer.POAPackage.InvalidPolicyHelper
write(OutputStream, NoServant) - Static method in class org.omg.PortableServer.POAPackage.NoServantHelper
write(OutputStream, ObjectAlreadyActive) - Static method in class org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper
write(OutputStream, ObjectNotActive) - Static method in class org.omg.PortableServer.POAPackage.ObjectNotActiveHelper
write(OutputStream, ServantAlreadyActive) - Static method in class org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper
write(OutputStream, ServantNotActive) - Static method in class org.omg.PortableServer.POAPackage.ServantNotActiveHelper
write(OutputStream, WrongAdapter) - Static method in class org.omg.PortableServer.POAPackage.WrongAdapterHelper
write(OutputStream, WrongPolicy) - Static method in class org.omg.PortableServer.POAPackage.WrongPolicyHelper
write(OutputStream, ServantActivator) - Static method in class org.omg.PortableServer.ServantActivatorHelper
write(OutputStream, ServantLocator) - Static method in class org.omg.PortableServer.ServantLocatorHelper
write(Node, LSOutput) - Method in interface org.w3c.dom.ls.LSSerializer
Serialize the specified node as described above in the general description of the LSSerializer interface.
write_Abstract(Object) - Method in interface org.omg.CORBA.DataOutputStream
Writes the IDL Abstract interface type to the output stream.
write_abstract_interface(Object) - Method in class org.omg.CORBA_2_3.portable.OutputStream
Marshals a value object or a stub object.
write_any(Any) - Method in interface org.omg.CORBA.DataOutputStream
Writes the Any value to the output stream.
write_any(Any) - Method in class org.omg.CORBA.portable.OutputStream
Writes an Any on this output stream.
write_any_array(Any[], int, int) - Method in interface org.omg.CORBA.DataOutputStream
Writes the array of IDL Anys from offset for length elements to the output stream.
write_boolean(boolean) - Method in interface org.omg.CORBA.DataOutputStream
Writes the boolean value to the output stream.
write_boolean(boolean) - Method in class org.omg.CORBA.portable.OutputStream
Writes a boolean value to this stream.
write_boolean_array(boolean[], int, int) - Method in interface org.omg.CORBA.DataOutputStream
Writes the array of IDL booleans from offset for length elements to the output stream.
write_boolean_array(boolean[], int, int) - Method in class org.omg.CORBA.portable.OutputStream
Writes an array of booleans on this output stream.
write_char(char) - Method in interface org.omg.CORBA.DataOutputStream
Writes the IDL character value to the output stream.
write_char(char) - Method in class org.omg.CORBA.portable.OutputStream
Writes a char value to this stream.
write_char_array(char[], int, int) - Method in interface org.omg.CORBA.DataOutputStream
Writes the array of IDL characters from offset for length elements to the output stream.
write_char_array(char[], int, int) - Method in class org.omg.CORBA.portable.OutputStream
Writes an array of chars on this output stream.
write_Context(Context, ContextList) - Method in class org.omg.CORBA.portable.OutputStream
Writes a CORBA context on this stream.
write_double(double) - Method in interface org.omg.CORBA.DataOutputStream
Writes the IDL double value to the output stream.
write_double(double) - Method in class org.omg.CORBA.portable.OutputStream
Writes a double value to this stream.
write_double_array(double[], int, int) - Method in interface org.omg.CORBA.DataOutputStream
Writes the array of IDL doubles from offset for length elements to the output stream.
write_double_array(double[], int, int) - Method in class org.omg.CORBA.portable.OutputStream
Writes an array of doubles on this output stream.
WRITE_FAILURE - Static variable in class java.util.logging.ErrorManager
WRITE_FAILURE is used when a write to an output stream fails.
write_fixed(BigDecimal) - Method in class org.omg.CORBA.portable.OutputStream
Writes a BigDecimal number.
write_float(float) - Method in interface org.omg.CORBA.DataOutputStream
Writes the IDL float value to the output stream.
write_float(float) - Method in class org.omg.CORBA.portable.OutputStream
Writes a float value to this stream.
write_float_array(float[], int, int) - Method in interface org.omg.CORBA.DataOutputStream
Writes the array of IDL floats from offset for length elements to the output stream.
write_float_array(float[], int, int) - Method in class org.omg.CORBA.portable.OutputStream
Writes an array of floats on this output stream.
write_long(int) - Method in interface org.omg.CORBA.DataOutputStream
Writes the IDL long value (represented as a Java int) to the output stream.
write_long(int) - Method in class org.omg.CORBA.portable.OutputStream
Writes a CORBA long (i.e.
write_long_array(int[], int, int) - Method in interface org.omg.CORBA.DataOutputStream
Writes the array of IDL longs from offset for length elements to the output stream.
write_long_array(int[], int, int) - Method in class org.omg.CORBA.portable.OutputStream
Writes an array of CORBA longs (i.e.
write_longlong(long) - Method in interface org.omg.CORBA.DataOutputStream
Writes the IDL long long value (represented as a Java long) to the output stream.
write_longlong(long) - Method in class org.omg.CORBA.portable.OutputStream
Writes a CORBA longlong (i.e.
write_longlong_array(long[], int, int) - Method in interface org.omg.CORBA.DataOutputStream
Writes the array of IDL long longs from offset for length elements to the output stream.
write_longlong_array(long[], int, int) - Method in class org.omg.CORBA.portable.OutputStream
Writes an array of CORBA longlongs (i.e.
write_Object(Object) - Method in interface org.omg.CORBA.DataOutputStream
Writes the IDL CORBA::Object value to the output stream.
write_Object(Object) - Method in class org.omg.CORBA.portable.OutputStream
Writes a CORBA Object on this output stream.
write_octet(byte) - Method in interface org.omg.CORBA.DataOutputStream
Writes the IDL octet value (represented as a Java byte) to the output stream.
write_octet(byte) - Method in class org.omg.CORBA.portable.OutputStream
Writes a CORBA octet (i.e.
write_octet_array(byte[], int, int) - Method in interface org.omg.CORBA.DataOutputStream
Writes the array of IDL octets from offset for length elements to the output stream.
write_octet_array(byte[], int, int) - Method in class org.omg.CORBA.portable.OutputStream
Writes an array of CORBA octets (bytes) on this output stream.
write_Principal(Principal) - Method in class org.omg.CORBA.portable.OutputStream
Deprecated.
Deprecated by CORBA 2.2.
write_short(short) - Method in interface org.omg.CORBA.DataOutputStream
Writes the IDL short value to the output stream.
write_short(short) - Method in class org.omg.CORBA.portable.OutputStream
Writes a short value to this stream.
write_short_array(short[], int, int) - Method in interface org.omg.CORBA.DataOutputStream
Writes the array of IDL shorts from offset for length elements to the output stream.
write_short_array(short[], int, int) - Method in class org.omg.CORBA.portable.OutputStream
Writes an array of shorts on this output stream.
write_string(String) - Method in interface org.omg.CORBA.DataOutputStream
Writes the IDL string value to the output stream.
write_string(String) - Method in class org.omg.CORBA.portable.OutputStream
Writes a string value to this stream.
write_TypeCode(TypeCode) - Method in interface org.omg.CORBA.DataOutputStream
Writes the typecode to the output stream.
write_TypeCode(TypeCode) - Method in class org.omg.CORBA.portable.OutputStream
Writes a TypeCode on this output stream.
write_ulong(int) - Method in interface org.omg.CORBA.DataOutputStream
Writes the IDL unsigned long value (represented as a Java int) to the output stream.
write_ulong(int) - Method in class org.omg.CORBA.portable.OutputStream
Writes an unsigned CORBA long (i.e.
write_ulong_array(int[], int, int) - Method in interface org.omg.CORBA.DataOutputStream
Writes the array of IDL unsigned longs (represented as Java ints) from offset for length elements to the output stream.
write_ulong_array(int[], int, int) - Method in class org.omg.CORBA.portable.OutputStream
Writes an array of unsigned CORBA longs (i.e.
write_ulonglong(long) - Method in interface org.omg.CORBA.DataOutputStream
Writes the IDL unsigned long long value (represented as a Java long) to the output stream.
write_ulonglong(long) - Method in class org.omg.CORBA.portable.OutputStream
Writes an unsigned CORBA longlong (i.e.
write_ulonglong_array(long[], int, int) - Method in interface org.omg.CORBA.DataOutputStream
Writes the array of IDL unsigned long longs (represented as Java longs) from offset for length elements to the output stream.
write_ulonglong_array(long[], int, int) - Method in class org.omg.CORBA.portable.OutputStream
Writes an array of unsigned CORBA longlongs (i.e.
write_ushort(short) - Method in interface org.omg.CORBA.DataOutputStream
Writes the IDL unsigned short value (represented as a Java short value) to the output stream.
write_ushort(short) - Method in class org.omg.CORBA.portable.OutputStream
Writes an unsigned short value to this stream.
write_ushort_array(short[], int, int) - Method in interface org.omg.CORBA.DataOutputStream
Writes the array of IDL unsigned shorts (represented as Java shorts) from offset for length elements to the output stream.
write_ushort_array(short[], int, int) - Method in class org.omg.CORBA.portable.OutputStream
Writes an array of unsigned shorts on this output stream.
write_value(OutputStream) - Method in class org.omg.CORBA.Any
Writes out the value of this Any object to the given output stream.
write_Value(Serializable) - Method in interface org.omg.CORBA.DataOutputStream
Writes the IDL value type value to the output stream.
write_value(OutputStream, Serializable) - Method in interface org.omg.CORBA.portable.BoxedValueHelper
write_value(OutputStream, Serializable) - Method in class org.omg.CORBA.StringValueHelper
write_value(OutputStream, Serializable) - Method in class org.omg.CORBA.WStringValueHelper
write_value(Serializable) - Method in class org.omg.CORBA_2_3.portable.OutputStream
Marshals a value type to the output stream.
write_value(Serializable, Class) - Method in class org.omg.CORBA_2_3.portable.OutputStream
Marshals a value type to the output stream.
write_value(Serializable, String) - Method in class org.omg.CORBA_2_3.portable.OutputStream
Marshals a value type to the output stream.
write_value(Serializable, BoxedValueHelper) - Method in class org.omg.CORBA_2_3.portable.OutputStream
Marshals a value type to the output stream.
write_wchar(char) - Method in interface org.omg.CORBA.DataOutputStream
Writes the IDL wide character value to the output stream.
write_wchar(char) - Method in class org.omg.CORBA.portable.OutputStream
Writes a wide char value to this stream.
write_wchar_array(char[], int, int) - Method in interface org.omg.CORBA.DataOutputStream
Writes the array of IDL wide characters from offset for length elements to the output stream.
write_wchar_array(char[], int, int) - Method in class org.omg.CORBA.portable.OutputStream
Writes an array of wide chars on this output stream.
write_wstring(String) - Method in interface org.omg.CORBA.DataOutputStream
Writes the IDL wide string value (represented as a Java String) to the output stream.
write_wstring(String) - Method in class org.omg.CORBA.portable.OutputStream
Writes a wide string value to this stream.
WRITE_XML_DECLARATION - Static variable in class javax.xml.soap.SOAPMessage
Specifies whether the SOAP Message will contain an XML declaration when it is sent.
writeAborted(ImageWriter) - Method in interface javax.imageio.event.IIOWriteProgressListener
Reports that a write has been aborted via the writer's abort method.
WriteAbortedException - Exception in java.io
Signals that one of the ObjectStreamExceptions was thrown during a write operation.
WriteAbortedException(String, Exception) - Constructor for exception java.io.WriteAbortedException
Constructs a WriteAbortedException with a string describing the exception and the exception causing the abort.
writeAbstractObject(OutputStream, Object) - Static method in class javax.rmi.CORBA.Util
Writes a java.lang.Object as either a value or a CORBA Object.
writeAbstractObject(OutputStream, Object) - Method in interface javax.rmi.CORBA.UtilDelegate
Delegation call for Util.writeAbstractObject(org.omg.CORBA.portable.OutputStream, java.lang.Object).
writeAny(OutputStream, Object) - Static method in class javax.rmi.CORBA.Util
Writes any java.lang.Object as a CORBA any.
writeAny(OutputStream, Object) - Method in interface javax.rmi.CORBA.UtilDelegate
Delegation call for Util.writeAny(org.omg.CORBA.portable.OutputStream, java.lang.Object).
writeArray(Array) - Method in interface java.sql.SQLOutput
Writes an SQL ARRAY value to the stream.
writeArray(Array) - Method in class javax.sql.rowset.serial.SQLOutputImpl
Writes an Array object in the Java programming language to this SQLOutputImpl object.
writeAsciiStream(InputStream) - Method in interface java.sql.SQLOutput
Writes the next attribute to the stream as a stream of ASCII characters.
writeAsciiStream(InputStream) - Method in class javax.sql.rowset.serial.SQLOutputImpl
Writes a stream of ASCII characters to this SQLOutputImpl object.
writeAsEncodedUnicode(Writer) - Method in interface javax.xml.stream.events.XMLEvent
This method will write the XMLEvent as per the XML 1.0 specification as Unicode characters.
writeAttribute(String, String) - Method in interface javax.xml.stream.XMLStreamWriter
Writes an attribute to the output stream without a prefix.
writeAttribute(String, String, String, String) - Method in interface javax.xml.stream.XMLStreamWriter
Writes an attribute to the output stream
writeAttribute(String, String, String) - Method in interface javax.xml.stream.XMLStreamWriter
Writes an attribute to the output stream
writeAttributes(AttributeSet) - Method in class javax.swing.text.AbstractWriter
Writes out the set of attributes as " <name>=<value>" pairs.
writeAttributes(AttributeSet) - Method in class javax.swing.text.html.HTMLWriter
Writes out the attribute set.
writeAttributes(AttributeSet) - Method in class javax.swing.text.html.MinimalHTMLWriter
Writes out all the attributes for the following types: StyleConstants.ParagraphConstants, StyleConstants.CharacterConstants, StyleConstants.FontConstants, StyleConstants.ColorConstants.
writeAttributes(ObjectOutputStream, AttributeSet) - Method in class javax.swing.text.StyleContext
Context-specific handling of writing out attributes
writeAttributeSet(ObjectOutputStream, AttributeSet) - Static method in class javax.swing.text.StyleContext
Writes a set of attributes to the given object stream for the purpose of serialization.
writeBigDecimal(BigDecimal) - Method in interface java.sql.SQLOutput
Writes the next attribute to the stream as a java.math.BigDecimal object.
writeBigDecimal(BigDecimal) - Method in class javax.sql.rowset.serial.SQLOutputImpl
Writes a java.math.BigDecimal object in the Java programming language to this SQLOutputImpl object.
writeBinaryStream(InputStream) - Method in interface java.sql.SQLOutput
Writes the next attribute to the stream as a stream of uninterpreted bytes.
writeBinaryStream(InputStream) - Method in class javax.sql.rowset.serial.SQLOutputImpl
Writes a stream of uninterpreted bytes to this SQLOutputImpl object.
writeBit(int) - Method in interface javax.imageio.stream.ImageOutputStream
Writes a single bit, given by the least significant bit of the argument, to the stream at the current bit offset within the current byte position.
writeBit(int) - Method in class javax.imageio.stream.ImageOutputStreamImpl
writeBits(long, int) - Method in interface javax.imageio.stream.ImageOutputStream
Writes a sequence of bits, given by the numBits least significant bits of the bits argument in left-to-right order, to the stream at the current bit offset within the current byte position.
writeBits(long, int) - Method in class javax.imageio.stream.ImageOutputStreamImpl
writeBlob(Blob) - Method in interface java.sql.SQLOutput
Writes an SQL BLOB value to the stream.
writeBlob(Blob) - Method in class javax.sql.rowset.serial.SQLOutputImpl
Writes a Blob object in the Java programming language to this SQLOutputImpl object.
writeBody() - Method in class javax.swing.text.html.MinimalHTMLWriter
Iterates over the elements in the document and processes elements based on whether they are branch elements or leaf elements.
writeBoolean(boolean) - Method in interface java.io.DataOutput
Writes a boolean value to this output stream.
writeBoolean(boolean) - Method in class java.io.DataOutputStream
Writes a boolean to the underlying output stream as a 1-byte value.
writeBoolean(boolean) - Method in class java.io.ObjectOutputStream
Writes a boolean.
writeBoolean(boolean) - Method in class java.io.RandomAccessFile
Writes a boolean to the file as a one-byte value.
writeBoolean(boolean) - Method in interface java.sql.SQLOutput
Writes the next attribute to the stream as a Java boolean.
writeBoolean(boolean) - Method in interface javax.imageio.stream.ImageOutputStream
Writes a boolean value to the stream.
writeBoolean(boolean) - Method in class javax.imageio.stream.ImageOutputStreamImpl
writeBoolean(boolean) - Method in class javax.sql.rowset.serial.SQLOutputImpl
Writes a boolean in the Java programming language to this SQLOutputImpl object.
writeByte(int) - Method in interface java.io.DataOutput
Writes to the output stream the eight low- order bits of the argument v.
writeByte(int) - Method in class java.io.DataOutputStream
Writes out a byte to the underlying output stream as a 1-byte value.
writeByte(int) - Method in class java.io.ObjectOutputStream
Writes an 8 bit byte.
writeByte(int) - Method in class java.io.RandomAccessFile
Writes a byte to the file as a one-byte value.
writeByte(byte) - Method in interface java.sql.SQLOutput
Writes the next attribute to the stream as a Java byte.
writeByte(int) - Method in interface javax.imageio.stream.ImageOutputStream
Writes the 8 low-order bits of v to the stream.
writeByte(int) - Method in class javax.imageio.stream.ImageOutputStreamImpl
writeByte(byte) - Method in class javax.sql.rowset.serial.SQLOutputImpl
Writes a byte in the Java programming language to this SQLOutputImpl object.
writeBytes(String) - Method in interface java.io.DataOutput
Writes a string to the output stream.
writeBytes(String) - Method in class java.io.DataOutputStream
Writes out the string to the underlying output stream as a sequence of bytes.
writeBytes(String) - Method in class java.io.ObjectOutputStream
Writes a String as a sequence of bytes.
writeBytes(String) - Method in class java.io.RandomAccessFile
Writes the string to the file as a sequence of bytes.
writeBytes(byte[]) - Method in interface java.sql.SQLOutput
Writes the next attribute to the stream as an array of bytes.
writeBytes(String) - Method in interface javax.imageio.stream.ImageOutputStream
Writes a string to the output stream.
writeBytes(String) - Method in class javax.imageio.stream.ImageOutputStreamImpl
writeBytes(byte[]) - Method in class javax.sql.rowset.serial.SQLOutputImpl
Writes an array of bytes in the Java programming language to this SQLOutputImpl object.
writeCData(String) - Method in interface javax.xml.stream.XMLStreamWriter
Writes a CData section
writeChar(int) - Method in interface java.io.DataOutput
Writes a char value, which is comprised of two bytes, to the output stream.
writeChar(int) - Method in class java.io.DataOutputStream
Writes a char to the underlying output stream as a 2-byte value, high byte first.
writeChar(int) - Method in class java.io.ObjectOutputStream
Writes a 16 bit char.
writeChar(int) - Method in class java.io.RandomAccessFile
Writes a char to the file as a two-byte value, high byte first.
writeChar(int) - Method in interface javax.imageio.stream.ImageOutputStream
This method is a synonym for writeShort.
writeChar(int) - Method in class javax.imageio.stream.ImageOutputStreamImpl
writeCharacters(String) - Method in interface javax.xml.stream.XMLStreamWriter
Write text to the output
writeCharacters(char[], int, int) - Method in interface javax.xml.stream.XMLStreamWriter
Write text to the output
writeCharacterStream(Reader) - Method in interface java.sql.SQLOutput
Writes the next attribute to the stream as a stream of Unicode characters.
writeCharacterStream(Reader) - Method in class javax.sql.rowset.serial.SQLOutputImpl
Writes a stream of Unicode characters to this SQLOutputImpl object.
writeChars(String) - Method in interface java.io.DataOutput
Writes every character in the string s, to the output stream, in order, two bytes per character.
writeChars(String) - Method in class java.io.DataOutputStream
Writes a string to the underlying output stream as a sequence of characters.
writeChars(String) - Method in class java.io.ObjectOutputStream
Writes a String as a sequence of chars.
writeChars(String) - Method in class java.io.RandomAccessFile
Writes a string to the file as a sequence of characters.
writeChars(String) - Method in interface javax.imageio.stream.ImageOutputStream
Writes a string to the output stream.
writeChars(char[], int, int) - Method in interface javax.imageio.stream.ImageOutputStream
Writes a sequence of chars to the stream at the current position.
writeChars(String) - Method in class javax.imageio.stream.ImageOutputStreamImpl
writeChars(char[], int, int) - Method in class javax.imageio.stream.ImageOutputStreamImpl
writeChildren(ObjectOutputStream) - Method in class java.beans.beancontext.BeanContextSupport
Used to serialize all children of this BeanContext.
writeClassDescriptor(ObjectStreamClass) - Method in class java.io.ObjectOutputStream
Write the specified class descriptor to the ObjectOutputStream.
writeClob(Clob) - Method in interface java.sql.SQLOutput
Writes an SQL CLOB value to the stream.
writeClob(Clob) - Method in class javax.sql.rowset.serial.SQLOutputImpl
Writes a Clob object in the Java programming language to this SQLOutputImpl object.
writeComment(String) - Method in interface javax.xml.stream.XMLStreamWriter
Writes an xml comment with the data enclosed
writeComponent(Element) - Method in class javax.swing.text.html.MinimalHTMLWriter
Responsible for handling Component Elements; deliberately unimplemented.
writeContent(Element, boolean) - Method in class javax.swing.text.html.MinimalHTMLWriter
Writes out the attribute set in an HTML-compliant manner.
writeData(RowSetInternal) - Method in interface javax.sql.RowSetWriter
Writes the changes in this RowSetWriter object's rowset back to the data source from which it got its data.
writeDate(Date) - Method in interface java.sql.SQLOutput
Writes the next attribute to the stream as a java.sql.Date object.
writeDate(Date) - Method in class javax.sql.rowset.serial.SQLOutputImpl
Writes a java.sql.Date object in the Java programming language to this SQLOutputImpl object.
writeDefaultNamespace(String) - Method in interface javax.xml.stream.XMLStreamWriter
Writes the default namespace to the stream
writeDouble(double) - Method in interface java.io.DataOutput
Writes a double value, which is comprised of eight bytes, to the output stream.
writeDouble(double) - Method in class java.io.DataOutputStream
Converts the double argument to a long using the doubleToLongBits method in class Double, and then writes that long value to the underlying output stream as an 8-byte quantity, high byte first.
writeDouble(double) - Method in class java.io.ObjectOutputStream
Writes a 64 bit double.
writeDouble(double) - Method in class java.io.RandomAccessFile
Converts the double argument to a long using the doubleToLongBits method in class Double, and then writes that long value to the file as an eight-byte quantity, high byte first.
writeDouble(double) - Method in interface java.sql.SQLOutput
Writes the next attribute to the stream as a Java double.
writeDouble(double) - Method in interface javax.imageio.stream.ImageOutputStream
Writes a double value, which is comprised of four bytes, to the output stream.
writeDouble(double) - Method in class javax.imageio.stream.ImageOutputStreamImpl
writeDouble(double) - Method in class javax.sql.rowset.serial.SQLOutputImpl
Writes a double in the Java programming language to this SQLOutputImpl object.
writeDoubles(double[], int, int) - Method in interface javax.imageio.stream.ImageOutputStream
Writes a sequence of doubles to the stream at the current position.
writeDoubles(double[], int, int) - Method in class javax.imageio.stream.ImageOutputStreamImpl
writeDTD(String) - Method in interface javax.xml.stream.XMLStreamWriter
Write a DTD section.
writeEmbeddedTags(AttributeSet) - Method in class javax.swing.text.html.HTMLWriter
Searches for embedded tags in the AttributeSet and writes them out.
writeEmptyElement(String, String) - Method in interface javax.xml.stream.XMLStreamWriter
Writes an empty element tag to the output
writeEmptyElement(String, String, String) - Method in interface javax.xml.stream.XMLStreamWriter
Writes an empty element tag to the output
writeEmptyElement(String) - Method in interface javax.xml.stream.XMLStreamWriter
Writes an empty element tag to the output
writeEndDocument() - Method in interface javax.xml.stream.XMLStreamWriter
Closes any start tags and writes corresponding end tags.
writeEndElement() - Method in interface javax.xml.stream.XMLStreamWriter
Writes an end tag to the output relying on the internal state of the writer to determine the prefix and local name of the event.
writeEndParagraph() - Method in class javax.swing.text.html.MinimalHTMLWriter
Emits an end tag for a <p> tag.
writeEndTag(String) - Method in class javax.swing.text.html.MinimalHTMLWriter
Writes out an end tag appropriately indented.
writeEntityRef(String) - Method in interface javax.xml.stream.XMLStreamWriter
Writes an entity reference
writeExpression(Expression) - Method in class java.beans.Encoder
The implementation first checks to see if an expression with this value has already been written.
writeExpression(Expression) - Method in class java.beans.XMLEncoder
Records the Expression so that the Encoder will produce the actual output when the stream is flushed.
writeExternal(ObjectOutput) - Method in class java.awt.datatransfer.DataFlavor
Serializes this DataFlavor.
writeExternal(ObjectOutput) - Method in interface java.io.Externalizable
The object implements the writeExternal method to save its contents by calling the methods of DataOutput for its primitive values or calling the writeObject method of ObjectOutput for objects, strings, and arrays.
writeExternal(ObjectOutput) - Method in class javax.activation.MimeType
The object implements the writeExternal method to save its contents by calling the methods of DataOutput for its primitive values or calling the writeObject method of ObjectOutput for objects, strings and arrays.
writeExternal(ObjectOutput) - Method in class javax.management.loading.MLet
Save this MLet's contents to the given ObjectOutput.
writeFields() - Method in class java.io.ObjectOutputStream
Write the buffered fields to the stream.
writeFloat(float) - Method in interface java.io.DataOutput
Writes a float value, which is comprised of four bytes, to the output stream.
writeFloat(float) - Method in class java.io.DataOutputStream
Converts the float argument to an int using the floatToIntBits method in class Float, and then writes that int value to the underlying output stream as a 4-byte quantity, high byte first.
writeFloat(float) - Method in class java.io.ObjectOutputStream
Writes a 32 bit float.
writeFloat(float) - Method in class java.io.RandomAccessFile
Converts the float argument to an int using the floatToIntBits method in class Float, and then writes that int value to the file as a four-byte quantity, high byte first.
writeFloat(float) - Method in interface java.sql.SQLOutput
Writes the next attribute to the stream as a Java float.
writeFloat(float) - Method in interface javax.imageio.stream.ImageOutputStream
Writes a float value, which is comprised of four bytes, to the output stream.
writeFloat(float) - Method in class javax.imageio.stream.ImageOutputStreamImpl
writeFloat(float) - Method in class javax.sql.rowset.serial.SQLOutputImpl
Writes a float in the Java programming language to this SQLOutputImpl object.
writeFloats(float[], int, int) - Method in interface javax.imageio.stream.ImageOutputStream
Writes a sequence of floats to the stream at the current position.
writeFloats(float[], int, int) - Method in class javax.imageio.stream.ImageOutputStreamImpl
writeHeader() - Method in class javax.swing.text.html.MinimalHTMLWriter
Writes out the <head> and <style> tags, and then invokes writeStyles() to write out all the named styles as the content of the <style> tag.
writeHTMLTags(AttributeSet) - Method in class javax.swing.text.html.MinimalHTMLWriter
Generates bold <b>, italic <i>, and <u> tags for the text based on its attribute settings.
writeImage(Element) - Method in class javax.swing.text.html.MinimalHTMLWriter
Responsible for handling Icon Elements; deliberately unimplemented.
writeInsert(int, IIOImage, ImageWriteParam) - Method in class javax.imageio.ImageWriter
Inserts a new image into an existing image stream.
writeInt(int) - Method in interface java.io.DataOutput
Writes an int value, which is comprised of four bytes, to the output stream.
writeInt(int) - Method in class java.io.DataOutputStream
Writes an int to the underlying output stream as four bytes, high byte first.
writeInt(int) - Method in class java.io.ObjectOutputStream
Writes a 32 bit int.
writeInt(int) - Method in class java.io.RandomAccessFile
Writes an int to the file as four bytes, high byte first.
writeInt(int) - Method in interface java.sql.SQLOutput
Writes the next attribute to the stream as a Java int.
writeInt(int) - Method in interface javax.imageio.stream.ImageOutputStream
Writes the 32 bits of v to the stream.
writeInt(int) - Method in class javax.imageio.stream.ImageOutputStreamImpl
writeInt(int) - Method in class javax.sql.rowset.serial.SQLOutputImpl
Writes an int in the Java programming language to this SQLOutputImpl object.
writeInts(int[], int, int) - Method in interface javax.imageio.stream.ImageOutputStream
Writes a sequence of ints to the stream at the current position.
writeInts(int[], int, int) - Method in class javax.imageio.stream.ImageOutputStreamImpl
writeLeaf(Element) - Method in class javax.swing.text.html.MinimalHTMLWriter
Responsible for writing out other non-text leaf elements.
writeLineSeparator() - Method in class javax.swing.text.AbstractWriter
Writes the line separator.
writeLineSeparator() - Method in class javax.swing.text.html.HTMLWriter
Writes the line separator.
writeLock() - Method in interface java.util.concurrent.locks.ReadWriteLock
Returns the lock used for writing.
writeLock() - Method in class java.util.concurrent.locks.ReentrantReadWriteLock
WriteLock(ReentrantReadWriteLock) - Constructor for class java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock
Constructor for use by subclasses
writeLock() - Method in class java.util.concurrent.locks.StampedLock
Exclusively acquires the lock, blocking if necessary until available.
writeLock() - Method in class javax.swing.text.AbstractDocument
Acquires a lock to begin mutating the document this lock protects.
writeLockInterruptibly() - Method in class java.util.concurrent.locks.StampedLock
Exclusively acquires the lock, blocking if necessary until available or the current thread is interrupted.
writeLong(long) - Method in interface java.io.DataOutput
Writes a long value, which is comprised of eight bytes, to the output stream.
writeLong(long) - Method in class java.io.DataOutputStream
Writes a long to the underlying output stream as eight bytes, high byte first.
writeLong(long) - Method in class java.io.ObjectOutputStream
Writes a 64 bit long.
writeLong(long) - Method in class java.io.RandomAccessFile
Writes a long to the file as eight bytes, high byte first.
writeLong(long) - Method in interface java.sql.SQLOutput
Writes the next attribute to the stream as a Java long.
writeLong(long) - Method in interface javax.imageio.stream.ImageOutputStream
Writes the 64 bits of v to the stream.
writeLong(long) - Method in class javax.imageio.stream.ImageOutputStreamImpl
writeLong(long) - Method in class javax.sql.rowset.serial.SQLOutputImpl
Writes a long in the Java programming language to this SQLOutputImpl object.
writeLongs(long[], int, int) - Method in interface javax.imageio.stream.ImageOutputStream
Writes a sequence of longs to the stream at the current position.
writeLongs(long[], int, int) - Method in class javax.imageio.stream.ImageOutputStreamImpl
writeNamespace(String, String) - Method in interface javax.xml.stream.XMLStreamWriter
Writes a namespace to the output stream If the prefix argument to this method is the empty string, "xmlns", or null this method will delegate to writeDefaultNamespace
writeNClob(NClob) - Method in interface java.sql.SQLOutput
Writes an SQL NCLOB value to the stream.
writeNClob(NClob) - Method in class javax.sql.rowset.serial.SQLOutputImpl
Writes an SQL NCLOB value to the stream.
writeNonHTMLAttributes(AttributeSet) - Method in class javax.swing.text.html.MinimalHTMLWriter
Writes out the remaining character-level attributes (attributes other than bold, italic, and underline) in an HTML-compliant way.
writeNString(String) - Method in interface java.sql.SQLOutput
Writes the next attribute to the stream as a String in the Java programming language.
writeNString(String) - Method in class javax.sql.rowset.serial.SQLOutputImpl
Writes the next attribute to the stream as a String in the Java programming language.
writeObject(Object) - Method in class java.beans.Encoder
Write the specified object to the output stream.
writeObject(Object, Encoder) - Method in class java.beans.PersistenceDelegate
The writeObject is a single entry point to the persistence and is used by a Encoder in the traditional mode of delegation.
writeObject(Object) - Method in class java.beans.XMLEncoder
Write an XML representation of the specified object to the output.
writeObject(Object) - Method in interface java.io.ObjectOutput
Write an object to the underlying storage or stream.
writeObject(Object) - Method in class java.io.ObjectOutputStream
Write the specified object to the ObjectOutputStream.
writeObject(SQLData) - Method in interface java.sql.SQLOutput
Writes to the stream the data contained in the given SQLData object.
writeObject(Object, SQLType) - Method in interface java.sql.SQLOutput
Writes to the stream the data contained in the given object.
writeObject(Stub, ObjectOutputStream) - Method in interface javax.rmi.CORBA.StubDelegate
Delegation call for Stub.writeObject(java.io.ObjectOutputStream).
writeObject(SQLData) - Method in class javax.sql.rowset.serial.SQLOutputImpl
Writes to the stream the data contained in the given SQLData object.
writeObjectOverride(Object) - Method in class java.io.ObjectOutputStream
Method used by subclasses to override the default writeObject method.
writeOption(Option) - Method in class javax.swing.text.html.HTMLWriter
Writes out the content of the Option form element.
WritePendingException - Exception in java.nio.channels
Unchecked exception thrown when an attempt is made to write to an asynchronous socket channel and a previous write has not completed.
WritePendingException() - Constructor for exception java.nio.channels.WritePendingException
Constructs an instance of this class.
writeProcessingInstruction(String) - Method in interface javax.xml.stream.XMLStreamWriter
Writes a processing instruction
writeProcessingInstruction(String, String) - Method in interface javax.xml.stream.XMLStreamWriter
Writes a processing instruction
writer() - Method in class java.io.Console
Retrieves the unique PrintWriter object associated with this console.
Writer - Class in java.io
Abstract class for writing to character streams.
Writer() - Constructor for class java.io.Writer
Creates a new character-stream writer whose critical sections will synchronize on the writer itself.
Writer(Object) - Constructor for class java.io.Writer
Creates a new character-stream writer whose critical sections will synchronize on the given object.
writer - Variable in class javax.script.SimpleScriptContext
This is the writer to be used to output from scripts.
writeRef(Ref) - Method in interface java.sql.SQLOutput
Writes an SQL REF value to the stream.
writeRef(Ref) - Method in class javax.sql.rowset.serial.SQLOutputImpl
Writes a Ref object in the Java programming language to this SQLOutputImpl object.
writeRemoteObject(OutputStream, Object) - Static method in class javax.rmi.CORBA.Util
Writes a java.lang.Object as a CORBA Object.
writeRemoteObject(OutputStream, Object) - Method in interface javax.rmi.CORBA.UtilDelegate
Delegation call for Util.writeRemoteObject(org.omg.CORBA.portable.OutputStream, java.lang.Object).
writeReplace() - Method in class java.security.cert.Certificate
Replace the Certificate to be serialized.
writeReplace() - Method in class java.security.cert.CertPath
Replaces the CertPath to be serialized with a CertPathRep object.
writeReplace(Serializable) - Method in interface javax.rmi.CORBA.ValueHandler
If the value contains a writeReplace method then the result is returned.
writeRowId(RowId) - Method in interface java.sql.SQLOutput
Writes an SQL ROWID value to the stream.
writeRowId(RowId) - Method in class javax.sql.rowset.serial.SQLOutputImpl
Writes an SQL ROWID value to the stream.
writerSpiNames - Variable in class javax.imageio.spi.ImageReaderSpi
An array of strings to be returned from getImageWriterSpiNames, initially null.
writeShort(int) - Method in interface java.io.DataOutput
Writes two bytes to the output stream to represent the value of the argument.
writeShort(int) - Method in class java.io.DataOutputStream
Writes a short to the underlying output stream as two bytes, high byte first.
writeShort(int) - Method in class java.io.ObjectOutputStream
Writes a 16 bit short.
writeShort(int) - Method in class java.io.RandomAccessFile
Writes a short to the file as two bytes, high byte first.
writeShort(short) - Method in interface java.sql.SQLOutput
Writes the next attribute to the stream as a Java short.
writeShort(int) - Method in interface javax.imageio.stream.ImageOutputStream
Writes the 16 low-order bits of v to the stream.
writeShort(int) - Method in class javax.imageio.stream.ImageOutputStreamImpl
writeShort(short) - Method in class javax.sql.rowset.serial.SQLOutputImpl
Writes a short in the Java programming language to this SQLOutputImpl object.
writeShorts(short[], int, int) - Method in interface javax.imageio.stream.ImageOutputStream
Writes a sequence of shorts to the stream at the current position.
writeShorts(short[], int, int) - Method in class javax.imageio.stream.ImageOutputStreamImpl
writeSQL(SQLOutput) - Method in interface java.sql.SQLData
Writes this object to the given SQL data stream, converting it back to its SQL value in the data source.
writeSQLXML(SQLXML) - Method in interface java.sql.SQLOutput
Writes an SQL XML value to the stream.
writeSQLXML(SQLXML) - Method in class javax.sql.rowset.serial.SQLOutputImpl
Writes an SQL XML value to the stream.
writeStartDocument() - Method in interface javax.xml.stream.XMLStreamWriter
Write the XML Declaration.
writeStartDocument(String) - Method in interface javax.xml.stream.XMLStreamWriter
Write the XML Declaration.
writeStartDocument(String, String) - Method in interface javax.xml.stream.XMLStreamWriter
Write the XML Declaration.
writeStartElement(String) - Method in interface javax.xml.stream.XMLStreamWriter
Writes a start tag to the output.
writeStartElement(String, String) - Method in interface javax.xml.stream.XMLStreamWriter
Writes a start tag to the output
writeStartElement(String, String, String) - Method in interface javax.xml.stream.XMLStreamWriter
Writes a start tag to the output
writeStartParagraph(Element) - Method in class javax.swing.text.html.MinimalHTMLWriter
Emits the start tag for a paragraph.
writeStartTag(String) - Method in class javax.swing.text.html.MinimalHTMLWriter
Writes out a start tag appropriately indented.
writeStatement(Statement) - Method in class java.beans.Encoder
Writes statement oldStm to the stream.
writeStatement(Statement) - Method in class java.beans.XMLEncoder
Records the Statement so that the Encoder will produce the actual output when the stream is flushed.
writeStreamHeader() - Method in class java.io.ObjectOutputStream
The writeStreamHeader method is provided so subclasses can append or prepend their own header to the stream.
writeString(String) - Method in interface java.sql.SQLOutput
Writes the next attribute to the stream as a String in the Java programming language.
writeString(String) - Method in class javax.sql.rowset.serial.SQLOutputImpl
Writes a String in the Java programming language to this SQLOutputImpl object.
writeStruct(Struct) - Method in interface java.sql.SQLOutput
Writes an SQL structured type value to the stream.
writeStruct(Struct) - Method in class javax.sql.rowset.serial.SQLOutputImpl
Writes a Struct object in the Java programming language to this SQLOutputImpl object.
writeStyles() - Method in class javax.swing.text.html.MinimalHTMLWriter
Writes out all the named styles as the content of the <style> tag.
writeTime(Time) - Method in interface java.sql.SQLOutput
Writes the next attribute to the stream as a java.sql.Time object.
writeTime(Time) - Method in class javax.sql.rowset.serial.SQLOutputImpl
Writes a java.sql.Time object in the Java programming language to this SQLOutputImpl object.
writeTimestamp(Timestamp) - Method in interface java.sql.SQLOutput
Writes the next attribute to the stream as a java.sql.Timestamp object.
writeTimestamp(Timestamp) - Method in class javax.sql.rowset.serial.SQLOutputImpl
Writes a java.sql.Timestamp object in the Java programming language to this SQLOutputImpl object.
writeTo(OutputStream) - Method in class java.io.ByteArrayOutputStream
Writes the complete contents of this byte array output stream to the specified output stream argument, as if by calling the output stream's write method using out.write(buf, 0, count).
writeTo(Writer) - Method in class java.io.CharArrayWriter
Writes the contents of the buffer to another character stream.
writeTo(Object, String, OutputStream) - Method in interface javax.activation.DataContentHandler
Convert the object to a byte stream of the specified MIME type and write it to the output stream.
writeTo(OutputStream) - Method in class javax.activation.DataHandler
Write the data to an OutputStream.
writeTo(OutputStream) - Method in class javax.xml.soap.SOAPMessage
Writes this SOAPMessage object to the given output stream.
writeTo(Result) - Method in class javax.xml.ws.EndpointReference
write this EndpointReference to the specified infoset format
writeTo(Result) - Method in class javax.xml.ws.wsaddressing.W3CEndpointReference
write this EndpointReference to the specified infoset format
writeToSequence(IIOImage, ImageWriteParam) - Method in class javax.imageio.ImageWriter
Appends a single image and possibly associated metadata and thumbnails, to the output.
writeToString(Node) - Method in interface org.w3c.dom.ls.LSSerializer
Serialize the specified node as described above in the general description of the LSSerializer interface.
writeToURI(Node, String) - Method in interface org.w3c.dom.ls.LSSerializer
A convenience method that acts as if LSSerializer.write was called with a LSOutput with no encoding specified and LSOutput.systemId set to the uri argument.
writeUnlock() - Method in class javax.swing.text.AbstractDocument
Releases a write lock previously obtained via writeLock.
writeUnshared(Object) - Method in class java.io.ObjectOutputStream
Writes an "unshared" object to the ObjectOutputStream.
writeURL(URL) - Method in interface java.sql.SQLOutput
Writes a SQL DATALINK value to the stream.
writeURL(URL) - Method in class javax.sql.rowset.serial.SQLOutputImpl
Writes an java.sql.Type.DATALINK object in the Java programming language to this SQLOutputImpl object.
writeUTF(String) - Method in interface java.io.DataOutput
Writes two bytes of length information to the output stream, followed by the modified UTF-8 representation of every character in the string s.
writeUTF(String) - Method in class java.io.DataOutputStream
Writes a string to the underlying output stream using modified UTF-8 encoding in a machine-independent manner.
writeUTF(String) - Method in class java.io.ObjectOutputStream
Primitive data write of this String in modified UTF-8 format.
writeUTF(String) - Method in class java.io.RandomAccessFile
Writes a string to the file using modified UTF-8 encoding in a machine-independent manner.
writeUTF(String) - Method in interface javax.imageio.stream.ImageOutputStream
Writes two bytes of length information to the output stream in network byte order, followed by the modified UTF-8 representation of every character in the string s.
writeUTF(String) - Method in class javax.imageio.stream.ImageOutputStreamImpl
writeValue(OutputStream, Serializable) - Method in interface javax.rmi.CORBA.ValueHandler
Writes a value to the stream using Java semantics.
writeValue(OutputStream, Serializable, byte) - Method in interface javax.rmi.CORBA.ValueHandlerMultiFormat
Allows the ORB to pass the stream format version for RMI/IDL custom value types.
writeXML(WebRowSet, Writer) - Method in interface javax.sql.rowset.spi.XmlWriter
Writes the given WebRowSet object to the specified java.io.Writer output stream as an XML document.
writeXml(ResultSet, Writer) - Method in interface javax.sql.rowset.WebRowSet
Populates this WebRowSet object with the contents of the given ResultSet object and writes its data, properties, and metadata to the given Writer object in XML format.
writeXml(ResultSet, OutputStream) - Method in interface javax.sql.rowset.WebRowSet
Populates this WebRowSet object with the contents of the given ResultSet object and writes its data, properties, and metadata to the given OutputStream object in XML format.
writeXml(Writer) - Method in interface javax.sql.rowset.WebRowSet
Writes the data, properties, and metadata for this WebRowSet object to the given Writer object in XML format.
writeXml(OutputStream) - Method in interface javax.sql.rowset.WebRowSet
Writes the data, properties, and metadata for this WebRowSet object to the given OutputStream object in XML format.
written - Variable in class java.io.DataOutputStream
The number of bytes written to the data output stream so far.
WRONG_DOCUMENT_ERR - Static variable in exception org.w3c.dom.DOMException
If a Node is used in a different document than the one that created it (that doesn't support it).
WrongAdapter - Exception in org.omg.PortableServer.POAPackage
org/omg/PortableServer/POAPackage/WrongAdapter.java .
WrongAdapter() - Constructor for exception org.omg.PortableServer.POAPackage.WrongAdapter
WrongAdapter(String) - Constructor for exception org.omg.PortableServer.POAPackage.WrongAdapter
WrongAdapterHelper - Class in org.omg.PortableServer.POAPackage
org/omg/PortableServer/POAPackage/WrongAdapterHelper.java .
WrongAdapterHelper() - Constructor for class org.omg.PortableServer.POAPackage.WrongAdapterHelper
WrongMethodTypeException - Exception in java.lang.invoke
Thrown to indicate that code has attempted to call a method handle via the wrong method type.
WrongMethodTypeException() - Constructor for exception java.lang.invoke.WrongMethodTypeException
Constructs a WrongMethodTypeException with no detail message.
WrongMethodTypeException(String) - Constructor for exception java.lang.invoke.WrongMethodTypeException
Constructs a WrongMethodTypeException with the specified detail message.
WrongPolicy - Exception in org.omg.PortableServer.POAPackage
org/omg/PortableServer/POAPackage/WrongPolicy.java .
WrongPolicy() - Constructor for exception org.omg.PortableServer.POAPackage.WrongPolicy
WrongPolicy(String) - Constructor for exception org.omg.PortableServer.POAPackage.WrongPolicy
WrongPolicyHelper - Class in org.omg.PortableServer.POAPackage
org/omg/PortableServer/POAPackage/WrongPolicyHelper.java .
WrongPolicyHelper() - Constructor for class org.omg.PortableServer.POAPackage.WrongPolicyHelper
WrongTransaction - Exception in org.omg.CORBA
The CORBA WrongTransaction user-defined exception.
WrongTransaction() - Constructor for exception org.omg.CORBA.WrongTransaction
Constructs a WrongTransaction object with an empty detail message.
WrongTransaction(String) - Constructor for exception org.omg.CORBA.WrongTransaction
Constructs a WrongTransaction object with the given detail message.
WrongTransactionHelper - Class in org.omg.CORBA
The Helper for WrongTransaction.
WrongTransactionHelper() - Constructor for class org.omg.CORBA.WrongTransactionHelper
WrongTransactionHolder - Class in org.omg.CORBA
The Holder for WrongTransaction.
WrongTransactionHolder() - Constructor for class org.omg.CORBA.WrongTransactionHolder
WrongTransactionHolder(WrongTransaction) - Constructor for class org.omg.CORBA.WrongTransactionHolder
WSDL_DESCRIPTION - Static variable in interface javax.xml.ws.handler.MessageContext
Standard property: input source for WSDL document.
WSDL_INTERFACE - Static variable in interface javax.xml.ws.handler.MessageContext
Standard property: name of wsdl interface (2.0) or port type (1.1).
WSDL_OPERATION - Static variable in interface javax.xml.ws.handler.MessageContext
Standard property: name of WSDL operation.
WSDL_PORT - Static variable in class javax.xml.ws.Endpoint
Standard property: name of WSDL port.
WSDL_PORT - Static variable in interface javax.xml.ws.handler.MessageContext
Standard property: name of WSDL port.
WSDL_SERVICE - Static variable in class javax.xml.ws.Endpoint
Standard property: name of WSDL service.
WSDL_SERVICE - Static variable in interface javax.xml.ws.handler.MessageContext
Standard property: name of WSDL service.
wsdlDocumentLocation(String) - Method in class javax.xml.ws.wsaddressing.W3CEndpointReferenceBuilder
Sets the wsdlDocumentLocation that will be referenced as wsa:Metadata/@wsdli:wsdlLocation.
WStringSeqHelper - Class in org.omg.CORBA
An array of WStrings
WStringSeqHelper() - Constructor for class org.omg.CORBA.WStringSeqHelper
WStringSeqHolder - Class in org.omg.CORBA
An array of WStrings
WStringSeqHolder() - Constructor for class org.omg.CORBA.WStringSeqHolder
WStringSeqHolder(String[]) - Constructor for class org.omg.CORBA.WStringSeqHolder
WStringValueHelper - Class in org.omg.CORBA
org/omg/CORBA/WStringValueHelper.java Generated by the IDL-to-Java compiler (portable), version "3.0" from orb.idl 31 May 1999 22:27:30 o'clock GMT+00:00 The class definition has been modified to conform to the following OMG specifications : ORB core as defined by CORBA 2.3.1 (formal/99-10-07) IDL/Java Language Mapping as defined in ptc/00-01-08
WStringValueHelper() - Constructor for class org.omg.CORBA.WStringValueHelper
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames


X-Index (Java Platform SE 8 )

Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames
  • All Classes
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

X

x - Variable in class java.awt.Event
The x coordinate of the event.
x - Variable in class java.awt.geom.Arc2D.Double
The X coordinate of the upper-left corner of the framing rectangle of the arc.
x - Variable in class java.awt.geom.Arc2D.Float
The X coordinate of the upper-left corner of the framing rectangle of the arc.
x - Variable in class java.awt.geom.Ellipse2D.Double
The X coordinate of the upper-left corner of the framing rectangle of this Ellipse2D.
x - Variable in class java.awt.geom.Ellipse2D.Float
The X coordinate of the upper-left corner of the framing rectangle of this Ellipse2D.
x - Variable in class java.awt.geom.Point2D.Double
The X coordinate of this Point2D.
x - Variable in class java.awt.geom.Point2D.Float
The X coordinate of this Point2D.
x - Variable in class java.awt.geom.Rectangle2D.Double
The X coordinate of this Rectangle2D.
x - Variable in class java.awt.geom.Rectangle2D.Float
The X coordinate of this Rectangle2D.
x - Variable in class java.awt.geom.RoundRectangle2D.Double
The X coordinate of this RoundRectangle2D.
x - Variable in class java.awt.geom.RoundRectangle2D.Float
The X coordinate of this RoundRectangle2D.
x - Variable in class java.awt.Point
The X coordinate of this Point.
x - Variable in class java.awt.Rectangle
The X coordinate of the upper-left corner of the Rectangle.
x1 - Variable in class java.awt.geom.CubicCurve2D.Double
The X coordinate of the start point of the cubic curve segment.
x1 - Variable in class java.awt.geom.CubicCurve2D.Float
The X coordinate of the start point of the cubic curve segment.
x1 - Variable in class java.awt.geom.Line2D.Double
The X coordinate of the start point of the line segment.
x1 - Variable in class java.awt.geom.Line2D.Float
The X coordinate of the start point of the line segment.
x1 - Variable in class java.awt.geom.QuadCurve2D.Double
The X coordinate of the start point of the quadratic curve segment.
x1 - Variable in class java.awt.geom.QuadCurve2D.Float
The X coordinate of the start point of the quadratic curve segment.
x2 - Variable in class java.awt.geom.CubicCurve2D.Double
The X coordinate of the end point of the cubic curve segment.
x2 - Variable in class java.awt.geom.CubicCurve2D.Float
The X coordinate of the end point of the cubic curve segment.
x2 - Variable in class java.awt.geom.Line2D.Double
The X coordinate of the end point of the line segment.
x2 - Variable in class java.awt.geom.Line2D.Float
The X coordinate of the end point of the line segment.
x2 - Variable in class java.awt.geom.QuadCurve2D.Double
The X coordinate of the end point of the quadratic curve segment.
x2 - Variable in class java.awt.geom.QuadCurve2D.Float
The X coordinate of the end point of the quadratic curve segment.
X500Principal - Class in javax.security.auth.x500
This class represents an X.500 Principal.
X500Principal(String) - Constructor for class javax.security.auth.x500.X500Principal
Creates an X500Principal from a string representation of an X.500 distinguished name (ex: "CN=Duke, OU=JavaSoft, O=Sun Microsystems, C=US").
X500Principal(String, Map<String, String>) - Constructor for class javax.security.auth.x500.X500Principal
Creates an X500Principal from a string representation of an X.500 distinguished name (ex: "CN=Duke, OU=JavaSoft, O=Sun Microsystems, C=US").
X500Principal(byte[]) - Constructor for class javax.security.auth.x500.X500Principal
Creates an X500Principal from a distinguished name in ASN.1 DER encoded form.
X500Principal(InputStream) - Constructor for class javax.security.auth.x500.X500Principal
Creates an X500Principal from an InputStream containing the distinguished name in ASN.1 DER encoded form.
X500PrivateCredential - Class in javax.security.auth.x500
This class represents an X500PrivateCredential.
X500PrivateCredential(X509Certificate, PrivateKey) - Constructor for class javax.security.auth.x500.X500PrivateCredential
Creates an X500PrivateCredential that associates an X.509 certificate, a private key and the KeyStore alias.
X500PrivateCredential(X509Certificate, PrivateKey, String) - Constructor for class javax.security.auth.x500.X500PrivateCredential
Creates an X500PrivateCredential that associates an X.509 certificate, a private key and the KeyStore alias.
X509Certificate - Class in java.security.cert
Abstract class for X.509 certificates.
X509Certificate() - Constructor for class java.security.cert.X509Certificate
Constructor for X.509 certificates.
X509Certificate - Class in javax.security.cert
Abstract class for X.509 v1 certificates.
X509Certificate() - Constructor for class javax.security.cert.X509Certificate
X509CertSelector - Class in java.security.cert
A CertSelector that selects X509Certificates that match all specified criteria.
X509CertSelector() - Constructor for class java.security.cert.X509CertSelector
Creates an X509CertSelector.
X509CRL - Class in java.security.cert
Abstract class for an X.509 Certificate Revocation List (CRL).
X509CRL() - Constructor for class java.security.cert.X509CRL
Constructor for X.509 CRLs.
X509CRLEntry - Class in java.security.cert
Abstract class for a revoked certificate in a CRL (Certificate Revocation List).
X509CRLEntry() - Constructor for class java.security.cert.X509CRLEntry
X509CRLSelector - Class in java.security.cert
A CRLSelector that selects X509CRLs that match all specified criteria.
X509CRLSelector() - Constructor for class java.security.cert.X509CRLSelector
Creates an X509CRLSelector.
X509Data - Interface in javax.xml.crypto.dsig.keyinfo
A representation of the XML X509Data element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
X509EncodedKeySpec - Class in java.security.spec
This class represents the ASN.1 encoding of a public key, encoded according to the ASN.1 type SubjectPublicKeyInfo.
X509EncodedKeySpec(byte[]) - Constructor for class java.security.spec.X509EncodedKeySpec
Creates a new X509EncodedKeySpec with the given encoded key.
X509ExtendedKeyManager - Class in javax.net.ssl
Abstract class that provides for extension of the X509KeyManager interface.
X509ExtendedKeyManager() - Constructor for class javax.net.ssl.X509ExtendedKeyManager
Constructor used by subclasses only.
X509ExtendedTrustManager - Class in javax.net.ssl
Extensions to the X509TrustManager interface to support SSL/TLS connection sensitive trust management.
X509ExtendedTrustManager() - Constructor for class javax.net.ssl.X509ExtendedTrustManager
X509Extension - Interface in java.security.cert
Interface for an X.509 extension.
X509IssuerSerial - Interface in javax.xml.crypto.dsig.keyinfo
A representation of the XML X509IssuerSerial element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
X509KeyManager - Interface in javax.net.ssl
Instances of this interface manage which X509 certificate-based key pairs are used to authenticate the local side of a secure socket.
X509TrustManager - Interface in javax.net.ssl
Instance of this interface manage which X509 certificates may be used to authenticate the remote side of a secure socket.
X_AXIS - Static variable in class javax.swing.BoxLayout
Specifies that components should be laid out left to right.
X_AXIS - Static variable in class javax.swing.text.View
Axis for format/break operations.
XA_HEURCOM - Static variable in exception javax.transaction.xa.XAException
The transaction branch has been heuristically committed.
XA_HEURHAZ - Static variable in exception javax.transaction.xa.XAException
The transaction branch may have been heuristically completed.
XA_HEURMIX - Static variable in exception javax.transaction.xa.XAException
The transaction branch has been heuristically committed and rolled back.
XA_HEURRB - Static variable in exception javax.transaction.xa.XAException
The transaction branch has been heuristically rolled back.
XA_NOMIGRATE - Static variable in exception javax.transaction.xa.XAException
Resumption must occur where the suspension occurred.
XA_OK - Static variable in interface javax.transaction.xa.XAResource
The transaction work has been prepared normally.
XA_RBBASE - Static variable in exception javax.transaction.xa.XAException
The inclusive lower bound of the rollback codes.
XA_RBCOMMFAIL - Static variable in exception javax.transaction.xa.XAException
Indicates that the rollback was caused by a communication failure.
XA_RBDEADLOCK - Static variable in exception javax.transaction.xa.XAException
A deadlock was detected.
XA_RBEND - Static variable in exception javax.transaction.xa.XAException
The inclusive upper bound of the rollback error code.
XA_RBINTEGRITY - Static variable in exception javax.transaction.xa.XAException
A condition that violates the integrity of the resource was detected.
XA_RBOTHER - Static variable in exception javax.transaction.xa.XAException
The resource manager rolled back the transaction branch for a reason not on this list.
XA_RBPROTO - Static variable in exception javax.transaction.xa.XAException
A protocol error occurred in the resource manager.
XA_RBROLLBACK - Static variable in exception javax.transaction.xa.XAException
Indicates that the rollback was caused by an unspecified reason.
XA_RBTIMEOUT - Static variable in exception javax.transaction.xa.XAException
A transaction branch took too long.
XA_RBTRANSIENT - Static variable in exception javax.transaction.xa.XAException
May retry the transaction branch.
XA_RDONLY - Static variable in exception javax.transaction.xa.XAException
The transaction branch was read-only and has been committed.
XA_RDONLY - Static variable in interface javax.transaction.xa.XAResource
The transaction branch has been read-only and has been committed.
XA_RETRY - Static variable in exception javax.transaction.xa.XAException
Routine returned with no effect and may be reissued.
XAConnection - Interface in javax.sql
An object that provides support for distributed transactions.
XADataSource - Interface in javax.sql
A factory for XAConnection objects that is used internally.
XAER_ASYNC - Static variable in exception javax.transaction.xa.XAException
There is an asynchronous operation already outstanding.
XAER_DUPID - Static variable in exception javax.transaction.xa.XAException
The XID already exists.
XAER_INVAL - Static variable in exception javax.transaction.xa.XAException
Invalid arguments were given.
XAER_NOTA - Static variable in exception javax.transaction.xa.XAException
The XID is not valid.
XAER_OUTSIDE - Static variable in exception javax.transaction.xa.XAException
The resource manager is doing work outside a global transaction.
XAER_PROTO - Static variable in exception javax.transaction.xa.XAException
Routine was invoked in an inproper context.
XAER_RMERR - Static variable in exception javax.transaction.xa.XAException
A resource manager error has occurred in the transaction branch.
XAER_RMFAIL - Static variable in exception javax.transaction.xa.XAException
Resource manager is unavailable.
XAException - Exception in javax.transaction.xa
The XAException is thrown by the Resource Manager (RM) to inform the Transaction Manager of an error encountered by the involved transaction.
XAException() - Constructor for exception javax.transaction.xa.XAException
Create an XAException.
XAException(String) - Constructor for exception javax.transaction.xa.XAException
Create an XAException with a given string.
XAException(int) - Constructor for exception javax.transaction.xa.XAException
Create an XAException with a given error code.
XAResource - Interface in javax.transaction.xa
The XAResource interface is a Java mapping of the industry standard XA interface based on the X/Open CAE Specification (Distributed Transaction Processing: The XA Specification).
Xid - Interface in javax.transaction.xa
The Xid interface is a Java mapping of the X/Open transaction identifier XID structure.
XML_DTD_NS_URI - Static variable in class javax.xml.XMLConstants
XML Document Type Declaration Namespace URI as an arbitrary value.
XML_NS_PREFIX - Static variable in class javax.xml.XMLConstants
The official XML Namespace prefix.
XML_NS_URI - Static variable in class javax.xml.XMLConstants
The official XML Namespace name URI.
XmlAccessOrder - Enum in javax.xml.bind.annotation
Used by XmlAccessorOrder to control the ordering of properties and fields in a JAXB bound class.
XmlAccessorOrder - Annotation Type in javax.xml.bind.annotation
Controls the ordering of fields and properties in a class.
XmlAccessorType - Annotation Type in javax.xml.bind.annotation
Controls whether fields or Javabean properties are serialized by default.
XmlAccessType - Enum in javax.xml.bind.annotation
Used by XmlAccessorType to control serialization of fields or properties.
XmlAdapter<ValueType,BoundType> - Class in javax.xml.bind.annotation.adapters
Adapts a Java type for custom marshaling.
XmlAdapter() - Constructor for class javax.xml.bind.annotation.adapters.XmlAdapter
Do-nothing constructor for the derived classes.
XmlAnyAttribute - Annotation Type in javax.xml.bind.annotation
Maps a JavaBean property to a map of wildcard attributes.
XmlAnyElement - Annotation Type in javax.xml.bind.annotation
Maps a JavaBean property to XML infoset representation and/or JAXB element.
XmlAttachmentRef - Annotation Type in javax.xml.bind.annotation
Marks a field/property that its XML form is a uri reference to mime content.
XmlAttribute - Annotation Type in javax.xml.bind.annotation
Maps a JavaBean property to a XML attribute.
XMLConstants - Class in javax.xml
Utility class to contain basic XML values as constants.
XMLCryptoContext - Interface in javax.xml.crypto
Contains common context information for XML cryptographic operations.
XMLDecoder - Class in java.beans
The XMLDecoder class is used to read XML documents created using the XMLEncoder and is used just like the ObjectInputStream.
XMLDecoder(InputStream) - Constructor for class java.beans.XMLDecoder
Creates a new input stream for reading archives created by the XMLEncoder class.
XMLDecoder(InputStream, Object) - Constructor for class java.beans.XMLDecoder
Creates a new input stream for reading archives created by the XMLEncoder class.
XMLDecoder(InputStream, Object, ExceptionListener) - Constructor for class java.beans.XMLDecoder
Creates a new input stream for reading archives created by the XMLEncoder class.
XMLDecoder(InputStream, Object, ExceptionListener, ClassLoader) - Constructor for class java.beans.XMLDecoder
Creates a new input stream for reading archives created by the XMLEncoder class.
XMLDecoder(InputSource) - Constructor for class java.beans.XMLDecoder
Creates a new decoder to parse XML archives created by the XMLEncoder class.
XmlElement - Annotation Type in javax.xml.bind.annotation
Maps a JavaBean property to a XML element derived from property name.
XmlElement.DEFAULT - Class in javax.xml.bind.annotation
Used in XmlElement.type() to signal that the type be inferred from the signature of the property.
XmlElementDecl - Annotation Type in javax.xml.bind.annotation
Maps a factory method to a XML element.
XmlElementDecl.GLOBAL - Class in javax.xml.bind.annotation
Used in XmlElementDecl.scope() to signal that the declaration is in the global scope.
XmlElementRef - Annotation Type in javax.xml.bind.annotation
Maps a JavaBean property to a XML element derived from property's type.
XmlElementRef.DEFAULT - Class in javax.xml.bind.annotation
Used in XmlElementRef.type() to signal that the type be inferred from the signature of the property.
XmlElementRefs - Annotation Type in javax.xml.bind.annotation
Marks a property that refers to classes with XmlElement or JAXBElement.
XmlElements - Annotation Type in javax.xml.bind.annotation
A container for multiple @XmlElement annotations.
XmlElementWrapper - Annotation Type in javax.xml.bind.annotation
Generates a wrapper element around XML representation.
XMLEncoder - Class in java.beans
The XMLEncoder class is a complementary alternative to the ObjectOutputStream and can used to generate a textual representation of a JavaBean in the same way that the ObjectOutputStream can be used to create binary representation of Serializable objects.
XMLEncoder(OutputStream) - Constructor for class java.beans.XMLEncoder
Creates a new XML encoder to write out JavaBeans to the stream out using an XML encoding.
XMLEncoder(OutputStream, String, boolean, int) - Constructor for class java.beans.XMLEncoder
Creates a new XML encoder to write out JavaBeans to the stream out using the given charset starting from the given indentation.
XmlEnum - Annotation Type in javax.xml.bind.annotation
Maps an enum type Enum to XML representation.
XmlEnumValue - Annotation Type in javax.xml.bind.annotation
Maps an enum constant in Enum type to XML representation.
XMLEvent - Interface in javax.xml.stream.events
This is the base event interface for handling markup events.
XMLEventAllocator - Interface in javax.xml.stream.util
This interface defines a class that allows a user to register a way to allocate events given an XMLStreamReader.
XMLEventConsumer - Interface in javax.xml.stream.util
This interface defines an event consumer interface.
XMLEventFactory - Class in javax.xml.stream
This interface defines a utility class for creating instances of XMLEvents
XMLEventFactory() - Constructor for class javax.xml.stream.XMLEventFactory
XMLEventReader - Interface in javax.xml.stream
This is the top level interface for parsing XML Events.
XMLEventWriter - Interface in javax.xml.stream
This is the top level interface for writing XML documents.
XMLFilter - Interface in org.xml.sax
Interface for an XML filter.
XMLFilterImpl - Class in org.xml.sax.helpers
Base class for deriving an XML filter.
XMLFilterImpl() - Constructor for class org.xml.sax.helpers.XMLFilterImpl
Construct an empty XML filter, with no parent.
XMLFilterImpl(XMLReader) - Constructor for class org.xml.sax.helpers.XMLFilterImpl
Construct an XML filter with the specified parent.
XMLFormatter - Class in java.util.logging
Format a LogRecord into a standard XML format.
XMLFormatter() - Constructor for class java.util.logging.XMLFormatter
XMLGregorianCalendar - Class in javax.xml.datatype
Representation for W3C XML Schema 1.0 date/time datatypes.
XMLGregorianCalendar() - Constructor for class javax.xml.datatype.XMLGregorianCalendar
Default no-arg constructor.
XmlID - Annotation Type in javax.xml.bind.annotation
Maps a JavaBean property to XML ID.
XmlIDREF - Annotation Type in javax.xml.bind.annotation
Maps a JavaBean property to XML IDREF.
XmlInlineBinaryData - Annotation Type in javax.xml.bind.annotation
Disable consideration of XOP encoding for datatypes that are bound to base64-encoded binary data in XML.
XMLInputFactory - Class in javax.xml.stream
Defines an abstract implementation of a factory for getting streams.
XMLInputFactory() - Constructor for class javax.xml.stream.XMLInputFactory
XmlJavaTypeAdapter - Annotation Type in javax.xml.bind.annotation.adapters
Use an adapter that implements XmlAdapter for custom marshaling.
XmlJavaTypeAdapter.DEFAULT - Class in javax.xml.bind.annotation.adapters
Used in XmlJavaTypeAdapter.type() to signal that the type be inferred from the signature of the field, property, parameter or the class.
XmlJavaTypeAdapters - Annotation Type in javax.xml.bind.annotation.adapters
A container for multiple @XmlJavaTypeAdapter annotations.
XmlList - Annotation Type in javax.xml.bind.annotation
Used to map a property to a list simple type.
XmlMimeType - Annotation Type in javax.xml.bind.annotation
Associates the MIME type that controls the XML representation of the property.
XmlMixed - Annotation Type in javax.xml.bind.annotation
Annotate a JavaBean multi-valued property to support mixed content.
XmlNs - Annotation Type in javax.xml.bind.annotation
Associates a namespace prefix with a XML namespace URI.
XMLNS - Static variable in interface javax.xml.crypto.dsig.XMLSignature
The XML Namespace URI of the W3C Recommendation for XML-Signature Syntax and Processing.
XMLNS - Static variable in class org.xml.sax.helpers.NamespaceSupport
The XML Namespace URI as a constant.
XMLNS_ATTRIBUTE - Static variable in class javax.xml.XMLConstants
The official XML attribute used for specifying XML Namespace declarations.
XMLNS_ATTRIBUTE_NS_URI - Static variable in class javax.xml.XMLConstants
The official XML attribute used for specifying XML Namespace declarations, XMLConstants.XMLNS_ATTRIBUTE, Namespace name URI.
XmlNsForm - Enum in javax.xml.bind.annotation
Enumeration of XML Schema namespace qualifications.
XMLObject - Interface in javax.xml.crypto.dsig
A representation of the XML Object element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
XMLOutputFactory - Class in javax.xml.stream
Defines an abstract implementation of a factory for getting XMLEventWriters and XMLStreamWriters.
XMLOutputFactory() - Constructor for class javax.xml.stream.XMLOutputFactory
XMLParseException - Exception in javax.management.modelmbean
This exception is thrown when an XML formatted string is being parsed into ModelMBean objects or when XML formatted strings are being created from ModelMBean objects.
XMLParseException() - Constructor for exception javax.management.modelmbean.XMLParseException
Default constructor .
XMLParseException(String) - Constructor for exception javax.management.modelmbean.XMLParseException
Constructor taking a string.
XMLParseException(Exception, String) - Constructor for exception javax.management.modelmbean.XMLParseException
Constructor taking a string and an exception.
XmlReader - Interface in javax.sql.rowset.spi
A specialized interface that facilitates an extension of the SyncProvider abstract class for XML orientated synchronization providers.
XMLReader - Interface in org.xml.sax
Interface for reading an XML document using callbacks.
XMLReaderAdapter - Class in org.xml.sax.helpers
Adapt a SAX2 XMLReader as a SAX1 Parser.
XMLReaderAdapter() - Constructor for class org.xml.sax.helpers.XMLReaderAdapter
Create a new adapter.
XMLReaderAdapter(XMLReader) - Constructor for class org.xml.sax.helpers.XMLReaderAdapter
Create a new adapter.
XMLReaderFactory - Class in org.xml.sax.helpers
Factory for creating an XML reader.
XmlRegistry - Annotation Type in javax.xml.bind.annotation
Marks a class that has XmlElementDecls.
XMLReporter - Interface in javax.xml.stream
This interface is used to report non-fatal errors.
XMLResolver - Interface in javax.xml.stream
This interface is used to resolve resources during an XML parse.
XmlRootElement - Annotation Type in javax.xml.bind.annotation
Maps a class or an enum type to an XML element.
XmlSchema - Annotation Type in javax.xml.bind.annotation
Maps a package name to a XML namespace.
XmlSchemaType - Annotation Type in javax.xml.bind.annotation
Maps a Java type to a simple schema built-in type.
XmlSchemaType.DEFAULT - Class in javax.xml.bind.annotation
Used in XmlSchemaType.type() to signal that the type be inferred from the signature of the property.
XmlSchemaTypes - Annotation Type in javax.xml.bind.annotation
A container for multiple @XmlSchemaType annotations.
XmlSeeAlso - Annotation Type in javax.xml.bind.annotation
Instructs JAXB to also bind other classes when binding this class.
XMLSignature - Interface in javax.xml.crypto.dsig
A representation of the XML Signature element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
XMLSignature.SignatureValue - Interface in javax.xml.crypto.dsig
A representation of the XML SignatureValue element as defined in the W3C Recommendation for XML-Signature Syntax and Processing.
XMLSignatureException - Exception in javax.xml.crypto.dsig
Indicates an exceptional condition that occurred during the XML signature generation or validation process.
XMLSignatureException() - Constructor for exception javax.xml.crypto.dsig.XMLSignatureException
Constructs a new XMLSignatureException with null as its detail message.
XMLSignatureException(String) - Constructor for exception javax.xml.crypto.dsig.XMLSignatureException
Constructs a new XMLSignatureException with the specified detail message.
XMLSignatureException(String, Throwable) - Constructor for exception javax.xml.crypto.dsig.XMLSignatureException
Constructs a new XMLSignatureException with the specified detail message and cause.
XMLSignatureException(Throwable) - Constructor for exception javax.xml.crypto.dsig.XMLSignatureException
Constructs a new XMLSignatureException with the specified cause and a detail message of (cause==null ? null : cause.toString()) (which typically contains the class and detail message of cause).
XMLSignatureFactory - Class in javax.xml.crypto.dsig
A factory for creating XMLSignature objects from scratch or for unmarshalling an XMLSignature object from a corresponding XML representation.
XMLSignatureFactory() - Constructor for class javax.xml.crypto.dsig.XMLSignatureFactory
Default constructor, for invocation by subclasses.
XMLSignContext - Interface in javax.xml.crypto.dsig
Contains context information for generating XML Signatures.
XMLStreamConstants - Interface in javax.xml.stream
This interface declares the constants used in this API.
XMLStreamException - Exception in javax.xml.stream
The base exception for unexpected processing errors.
XMLStreamException() - Constructor for exception javax.xml.stream.XMLStreamException
Default constructor
XMLStreamException(String) - Constructor for exception javax.xml.stream.XMLStreamException
Construct an exception with the assocated message.
XMLStreamException(Throwable) - Constructor for exception javax.xml.stream.XMLStreamException
Construct an exception with the assocated exception
XMLStreamException(String, Throwable) - Constructor for exception javax.xml.stream.XMLStreamException
Construct an exception with the assocated message and exception
XMLStreamException(String, Location, Throwable) - Constructor for exception javax.xml.stream.XMLStreamException
Construct an exception with the assocated message, exception and location.
XMLStreamException(String, Location) - Constructor for exception javax.xml.stream.XMLStreamException
Construct an exception with the assocated message, exception and location.
XMLStreamReader - Interface in javax.xml.stream
The XMLStreamReader interface allows forward, read-only access to XML.
XMLStreamWriter - Interface in javax.xml.stream
The XMLStreamWriter interface specifies how to write XML.
XMLStructure - Interface in javax.xml.crypto
A representation of an XML structure from any namespace.
XmlTransient - Annotation Type in javax.xml.bind.annotation
Prevents the mapping of a JavaBean property/type to XML representation.
XmlType - Annotation Type in javax.xml.bind.annotation
Maps a class or an enum type to a XML Schema type.
XmlType.DEFAULT - Class in javax.xml.bind.annotation
Used in XmlType.factoryClass() to signal that either factory mehod is not used or that it's in the class with this XmlType itself.
XMLValidateContext - Interface in javax.xml.crypto.dsig
Contains context information for validating XML Signatures.
XmlValue - Annotation Type in javax.xml.bind.annotation
Enables mapping a class to a XML Schema complex type with a simpleContent or a XML Schema simple type.
XmlWriter - Interface in javax.sql.rowset.spi
A specialized interface that facilitates an extension of the SyncProvider abstract class for XML orientated synchronization providers.
XOR - Static variable in class java.awt.AlphaComposite
The part of the source that lies outside of the destination is combined with the part of the destination that lies outside of the source (Porter-Duff Source Xor Destination rule).
Xor - Static variable in class java.awt.AlphaComposite
AlphaComposite object that implements the opaque XOR rule with an alpha of 1.0f.
xor(BigInteger) - Method in class java.math.BigInteger
Returns a BigInteger whose value is (this ^ val).
xor(BitSet) - Method in class java.util.BitSet
Performs a logical XOR of this bit set with the bit set argument.
XPATH - Static variable in interface javax.xml.crypto.dsig.Transform
The XPath transform algorithm URI.
XPath - Interface in javax.xml.xpath
XPath provides access to the XPath evaluation environment and expressions.
XPATH2 - Static variable in interface javax.xml.crypto.dsig.Transform
The XPath Filter 2 transform algorithm URI.
XPathConstants - Class in javax.xml.xpath
XPath constants.
XPathException - Exception in javax.xml.xpath
XPathException represents a generic XPath exception.
XPathException(String) - Constructor for exception javax.xml.xpath.XPathException
Constructs a new XPathException with the specified detail message.
XPathException(Throwable) - Constructor for exception javax.xml.xpath.XPathException
Constructs a new XPathException with the specified cause.
XPathExpression - Interface in javax.xml.xpath
XPathExpression provides access to compiled XPath expressions.
XPathExpressionException - Exception in javax.xml.xpath
XPathExpressionException represents an error in an XPath expression.
XPathExpressionException(String) - Constructor for exception javax.xml.xpath.XPathExpressionException
Constructs a new XPathExpressionException with the specified detail message.
XPathExpressionException(Throwable) - Constructor for exception javax.xml.xpath.XPathExpressionException
Constructs a new XPathExpressionException with the specified cause.
XPathFactory - Class in javax.xml.xpath
An XPathFactory instance can be used to create XPath objects.
XPathFactory() - Constructor for class javax.xml.xpath.XPathFactory
Protected constructor as XPathFactory.newInstance() or XPathFactory.newInstance(String uri) or XPathFactory.newInstance(String uri, String factoryClassName, ClassLoader classLoader) should be used to create a new instance of an XPathFactory.
XPathFactoryConfigurationException - Exception in javax.xml.xpath
XPathFactoryConfigurationException represents a configuration error in a XPathFactory environment.
XPathFactoryConfigurationException(String) - Constructor for exception javax.xml.xpath.XPathFactoryConfigurationException
Constructs a new XPathFactoryConfigurationException with the specified detail message.
XPathFactoryConfigurationException(Throwable) - Constructor for exception javax.xml.xpath.XPathFactoryConfigurationException
Constructs a new XPathFactoryConfigurationException with the specified cause.
XPathFilter2ParameterSpec - Class in javax.xml.crypto.dsig.spec
Parameters for the W3C Recommendation XPath Filter 2.0 Transform Algorithm.
XPathFilter2ParameterSpec(List) - Constructor for class javax.xml.crypto.dsig.spec.XPathFilter2ParameterSpec
Creates an XPathFilter2ParameterSpec.
XPathFilterParameterSpec - Class in javax.xml.crypto.dsig.spec
Parameters for the XPath Filtering Transform Algorithm.
XPathFilterParameterSpec(String) - Constructor for class javax.xml.crypto.dsig.spec.XPathFilterParameterSpec
Creates an XPathFilterParameterSpec with the specified XPath expression.
XPathFilterParameterSpec(String, Map) - Constructor for class javax.xml.crypto.dsig.spec.XPathFilterParameterSpec
Creates an XPathFilterParameterSpec with the specified XPath expression and namespace map.
XPathFunction - Interface in javax.xml.xpath
XPathFunction provides access to XPath functions.
XPathFunctionException - Exception in javax.xml.xpath
XPathFunctionException represents an error with an XPath function.
XPathFunctionException(String) - Constructor for exception javax.xml.xpath.XPathFunctionException
Constructs a new XPathFunctionException with the specified detail message.
XPathFunctionException(Throwable) - Constructor for exception javax.xml.xpath.XPathFunctionException
Constructs a new XPathFunctionException with the specified cause.
XPathFunctionResolver - Interface in javax.xml.xpath
XPathFunctionResolver provides access to the set of user defined XPathFunctions.
XPathType - Class in javax.xml.crypto.dsig.spec
The XML Schema Definition of the XPath element as defined in the W3C Recommendation for XML-Signature XPath Filter 2.0:
XPathType(String, XPathType.Filter) - Constructor for class javax.xml.crypto.dsig.spec.XPathType
Creates an XPathType instance with the specified XPath expression and filter.
XPathType(String, XPathType.Filter, Map) - Constructor for class javax.xml.crypto.dsig.spec.XPathType
Creates an XPathType instance with the specified XPath expression, filter, and namespace map.
XPathType.Filter - Class in javax.xml.crypto.dsig.spec
Represents the filter set operation.
XPathVariableResolver - Interface in javax.xml.xpath
XPathVariableResolver provides access to the set of user defined XPath variables.
xpoints - Variable in class java.awt.Polygon
The array of X coordinates.
xPositionForValue(int) - Method in class javax.swing.plaf.basic.BasicSliderUI
xPositionForValue(int) - Method in class javax.swing.plaf.synth.SynthSliderUI
XSLT - Static variable in interface javax.xml.crypto.dsig.Transform
The XSLT transform algorithm URI.
XSLTTransformParameterSpec - Class in javax.xml.crypto.dsig.spec
Parameters for the XSLT Transform Algorithm.
XSLTTransformParameterSpec(XMLStructure) - Constructor for class javax.xml.crypto.dsig.spec.XSLTTransformParameterSpec
Creates an XSLTTransformParameterSpec with the specified stylesheet.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames


Y-Index (Java Platform SE 8 )

Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames
  • All Classes
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

Y

y - Variable in class java.awt.Event
The y coordinate of the event.
y - Variable in class java.awt.geom.Arc2D.Double
The Y coordinate of the upper-left corner of the framing rectangle of the arc.
y - Variable in class java.awt.geom.Arc2D.Float
The Y coordinate of the upper-left corner of the framing rectangle of the arc.
y - Variable in class java.awt.geom.Ellipse2D.Double
The Y coordinate of the upper-left corner of the framing rectangle of this Ellipse2D.
y - Variable in class java.awt.geom.Ellipse2D.Float
The Y coordinate of the upper-left corner of the framing rectangle of this Ellipse2D.
y - Variable in class java.awt.geom.Point2D.Double
The Y coordinate of this Point2D.
y - Variable in class java.awt.geom.Point2D.Float
The Y coordinate of this Point2D.
y - Variable in class java.awt.geom.Rectangle2D.Double
The Y coordinate of this Rectangle2D.
y - Variable in class java.awt.geom.Rectangle2D.Float
The Y coordinate of this Rectangle2D.
y - Variable in class java.awt.geom.RoundRectangle2D.Double
The Y coordinate of this RoundRectangle2D.
y - Variable in class java.awt.geom.RoundRectangle2D.Float
The Y coordinate of this RoundRectangle2D.
y - Variable in class java.awt.Point
The Y coordinate of this Point.
y - Variable in class java.awt.Rectangle
The Y coordinate of the upper-left corner of the Rectangle.
y1 - Variable in class java.awt.geom.CubicCurve2D.Double
The Y coordinate of the start point of the cubic curve segment.
y1 - Variable in class java.awt.geom.CubicCurve2D.Float
The Y coordinate of the start point of the cubic curve segment.
y1 - Variable in class java.awt.geom.Line2D.Double
The Y coordinate of the start point of the line segment.
y1 - Variable in class java.awt.geom.Line2D.Float
The Y coordinate of the start point of the line segment.
y1 - Variable in class java.awt.geom.QuadCurve2D.Double
The Y coordinate of the start point of the quadratic curve segment.
y1 - Variable in class java.awt.geom.QuadCurve2D.Float
The Y coordinate of the start point of the quadratic curve segment.
y2 - Variable in class java.awt.geom.CubicCurve2D.Double
The Y coordinate of the end point of the cubic curve segment.
y2 - Variable in class java.awt.geom.CubicCurve2D.Float
The Y coordinate of the end point of the cubic curve segment.
y2 - Variable in class java.awt.geom.Line2D.Double
The Y coordinate of the end point of the line segment.
y2 - Variable in class java.awt.geom.Line2D.Float
The Y coordinate of the end point of the line segment.
y2 - Variable in class java.awt.geom.QuadCurve2D.Double
The Y coordinate of the end point of the quadratic curve segment.
y2 - Variable in class java.awt.geom.QuadCurve2D.Float
The Y coordinate of the end point of the quadratic curve segment.
Y_AXIS - Static variable in class javax.swing.BoxLayout
Specifies that components should be laid out top to bottom.
Y_AXIS - Static variable in class javax.swing.text.View
Axis for format/break operations.
YEAR - Static variable in class java.text.DateFormat.Field
Constant identifying the year field.
Year - Class in java.time
A year in the ISO-8601 calendar system, such as 2007.
YEAR - Static variable in class java.util.Calendar
Field number for get and set indicating the year.
YEAR_FIELD - Static variable in class java.text.DateFormat
Useful constant for YEAR field alignment.
YearMonth - Class in java.time
A year-month in the ISO-8601 calendar system, such as 2007-12.
YEARS - Static variable in class javax.xml.datatype.DatatypeConstants
A constant that represents the years field.
yellow - Static variable in class java.awt.Color
The color yellow.
YELLOW - Static variable in class java.awt.Color
The color yellow.
YES - Static variable in class javax.security.auth.callback.ConfirmationCallback
YES option.
YES_NO_CANCEL_OPTION - Static variable in class javax.security.auth.callback.ConfirmationCallback
YES/NO/CANCEL confirmation confirmation option.
YES_NO_CANCEL_OPTION - Static variable in class javax.swing.JOptionPane
Type used for showConfirmDialog.
YES_NO_OPTION - Static variable in class javax.security.auth.callback.ConfirmationCallback
YES/NO confirmation option.
YES_NO_OPTION - Static variable in class javax.swing.JOptionPane
Type used for showConfirmDialog.
YES_OPTION - Static variable in class javax.swing.JOptionPane
Return value from class method if YES is chosen.
YI_RADICALS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Yi Radicals" Unicode character block.
YI_SYLLABLES - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Yi Syllables" Unicode character block.
yield() - Static method in class java.lang.Thread
A hint to the scheduler that the current thread is willing to yield its current use of a processor.
YIJING_HEXAGRAM_SYMBOLS - Static variable in class java.lang.Character.UnicodeBlock
Constant for the "Yijing Hexagram Symbols" Unicode character block.
YOU_1 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS You ("Western") #1 envelope size, 120 mm by 176 mm.
YOU_2 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS You ("Western") #2 envelope size, 114 mm by 162 mm.
YOU_3 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS You ("Western") #3 envelope size, 98 mm by 148 mm.
YOU_4 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS You ("Western") #4 envelope size, 105 mm by 235 mm.
YOU_5 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS You ("Western") #5 envelope size, 95 mm by 217 mm.
YOU_6 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS You ("Western") #6 envelope size, 98 mm by 190 mm.
YOU_7 - Static variable in class javax.print.attribute.standard.MediaSize.JIS
Specifies the JIS You ("Western") #7 envelope size, 92 mm by 165 mm.
ypoints - Variable in class java.awt.Polygon
The array of Y coordinates.
yPositionForValue(int) - Method in class javax.swing.plaf.basic.BasicSliderUI
yPositionForValue(int, int, int) - Method in class javax.swing.plaf.basic.BasicSliderUI
Returns the y location for the specified value.
yPositionForValue(int, int, int) - Method in class javax.swing.plaf.synth.SynthSliderUI
Returns the y location for the specified value.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames


Z-Index (Java Platform SE 8 )

Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames
  • All Classes
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

Z

ZERO - Static variable in class java.math.BigDecimal
The value 0, with a scale of 0.
ZERO - Static variable in class java.math.BigInteger
The BigInteger constant zero.
ZERO - Static variable in class java.time.Duration
Constant for a duration of zero.
ZERO - Static variable in class java.time.Period
A constant for a period of zero.
ZipEntry - Class in java.util.zip
This class is used to represent a ZIP file entry.
ZipEntry(String) - Constructor for class java.util.zip.ZipEntry
Creates a new zip entry with the specified name.
ZipEntry(ZipEntry) - Constructor for class java.util.zip.ZipEntry
Creates a new zip entry with fields taken from the specified zip entry.
ZipError - Error in java.util.zip
Signals that an unrecoverable error has occurred.
ZipError(String) - Constructor for error java.util.zip.ZipError
Constructs a ZipError with the given detail message.
ZipException - Exception in java.util.zip
Signals that a Zip exception of some sort has occurred.
ZipException() - Constructor for exception java.util.zip.ZipException
Constructs a ZipException with null as its error detail message.
ZipException(String) - Constructor for exception java.util.zip.ZipException
Constructs a ZipException with the specified detail message.
ZipFile - Class in java.util.zip
This class is used to read entries from a zip file.
ZipFile(String) - Constructor for class java.util.zip.ZipFile
Opens a zip file for reading.
ZipFile(File, int) - Constructor for class java.util.zip.ZipFile
Opens a new ZipFile to read from the specified File object in the specified mode.
ZipFile(File) - Constructor for class java.util.zip.ZipFile
Opens a ZIP file for reading given the specified File object.
ZipFile(File, int, Charset) - Constructor for class java.util.zip.ZipFile
Opens a new ZipFile to read from the specified File object in the specified mode.
ZipFile(String, Charset) - Constructor for class java.util.zip.ZipFile
Opens a zip file for reading.
ZipFile(File, Charset) - Constructor for class java.util.zip.ZipFile
Opens a ZIP file for reading given the specified File object.
ZipInputStream - Class in java.util.zip
This class implements an input stream filter for reading files in the ZIP file format.
ZipInputStream(InputStream) - Constructor for class java.util.zip.ZipInputStream
Creates a new ZIP input stream.
ZipInputStream(InputStream, Charset) - Constructor for class java.util.zip.ZipInputStream
Creates a new ZIP input stream.
ZipOutputStream - Class in java.util.zip
This class implements an output stream filter for writing files in the ZIP file format.
ZipOutputStream(OutputStream) - Constructor for class java.util.zip.ZipOutputStream
Creates a new ZIP output stream.
ZipOutputStream(OutputStream, Charset) - Constructor for class java.util.zip.ZipOutputStream
Creates a new ZIP output stream.
zone() - Static method in class java.time.temporal.TemporalQueries
A lenient query for the ZoneId, falling back to the ZoneOffset.
ZONE_OFFSET - Static variable in class java.util.Calendar
Field number for get and set indicating the raw offset from GMT in milliseconds.
zonedDateTime(TemporalAccessor) - Method in interface java.time.chrono.Chronology
Obtains a ChronoZonedDateTime in this chronology from another temporal object.
zonedDateTime(Instant, ZoneId) - Method in interface java.time.chrono.Chronology
Obtains a ChronoZonedDateTime in this chronology from an Instant.
zonedDateTime(TemporalAccessor) - Method in class java.time.chrono.HijrahChronology
zonedDateTime(Instant, ZoneId) - Method in class java.time.chrono.HijrahChronology
zonedDateTime(TemporalAccessor) - Method in class java.time.chrono.IsoChronology
Obtains an ISO zoned date-time from another date-time object.
zonedDateTime(Instant, ZoneId) - Method in class java.time.chrono.IsoChronology
Obtains an ISO zoned date-time in this chronology from an Instant.
zonedDateTime(TemporalAccessor) - Method in class java.time.chrono.JapaneseChronology
zonedDateTime(Instant, ZoneId) - Method in class java.time.chrono.JapaneseChronology
zonedDateTime(TemporalAccessor) - Method in class java.time.chrono.MinguoChronology
zonedDateTime(Instant, ZoneId) - Method in class java.time.chrono.MinguoChronology
zonedDateTime(TemporalAccessor) - Method in class java.time.chrono.ThaiBuddhistChronology
zonedDateTime(Instant, ZoneId) - Method in class java.time.chrono.ThaiBuddhistChronology
ZonedDateTime - Class in java.time
A date-time with a time-zone in the ISO-8601 calendar system, such as 2007-12-03T10:15:30+01:00 Europe/Paris.
zoneId() - Static method in class java.time.temporal.TemporalQueries
A strict query for the ZoneId.
ZoneId - Class in java.time
A time-zone ID, such as Europe/Paris.
ZoneOffset - Class in java.time
A time-zone offset from Greenwich/UTC, such as +02:00.
ZoneOffsetTransition - Class in java.time.zone
A transition between two offsets caused by a discontinuity in the local time-line.
ZoneOffsetTransitionRule - Class in java.time.zone
A rule expressing how to create a transition.
ZoneOffsetTransitionRule.TimeDefinition - Enum in java.time.zone
A definition of the way a local time can be converted to the actual transition date-time.
ZoneRules - Class in java.time.zone
The rules defining how the zone offset varies for a single time-zone.
ZoneRulesException - Exception in java.time.zone
Thrown to indicate a problem with time-zone configuration.
ZoneRulesException(String) - Constructor for exception java.time.zone.ZoneRulesException
Constructs a new date-time exception with the specified message.
ZoneRulesException(String, Throwable) - Constructor for exception java.time.zone.ZoneRulesException
Constructs a new date-time exception with the specified message and cause.
ZoneRulesProvider - Class in java.time.zone
Provider of time-zone rules to the system.
ZoneRulesProvider() - Constructor for class java.time.zone.ZoneRulesProvider
Constructor.
ZoneView - Class in javax.swing.text
ZoneView is a View implementation that creates zones for which the child views are not created or stored until they are needed for display or model/view translations.
ZoneView(Element, int) - Constructor for class javax.swing.text.ZoneView
Constructs a ZoneView.
zoneWasLoaded(View) - Method in class javax.swing.text.ZoneView
Called by a zone when it gets loaded.
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames


_-Index (Java Platform SE 8 )

Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames
  • All Classes
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _

_

_ACTIVE - Static variable in class org.omg.PortableServer.POAManagerPackage.State
_ADD_OVERRIDE - Static variable in class org.omg.CORBA.SetOverrideType
The int constant for the enum value ADD_OVERRIDE.
_all_interfaces(POA, byte[]) - Method in class org.omg.CosNaming.BindingIteratorPOA
_all_interfaces(POA, byte[]) - Method in class org.omg.CosNaming.NamingContextExtPOA
_all_interfaces(POA, byte[]) - Method in class org.omg.CosNaming.NamingContextPOA
_all_interfaces(POA, byte[]) - Method in class org.omg.PortableServer.Servant
Used by the ORB to obtain complete type information from the servant.
_all_interfaces(POA, byte[]) - Method in class org.omg.PortableServer.ServantActivatorPOA
_all_interfaces(POA, byte[]) - Method in class org.omg.PortableServer.ServantLocatorPOA
_BindingIteratorImplBase - Class in org.omg.CosNaming
_BindingIteratorImplBase() - Constructor for class org.omg.CosNaming._BindingIteratorImplBase
_BindingIteratorStub - Class in org.omg.CosNaming
The BindingIterator interface allows a client to iterate through the bindings using the next_one or next_n operations.
_BindingIteratorStub() - Constructor for class org.omg.CosNaming._BindingIteratorStub
_COMPLETED_MAYBE - Static variable in class org.omg.CORBA.CompletionStatus
The constant indicating that a method completed running before a SystemException was thrown.
_COMPLETED_NO - Static variable in class org.omg.CORBA.CompletionStatus
The constant indicating that a method completed running before a SystemException was thrown.
_COMPLETED_YES - Static variable in class org.omg.CORBA.CompletionStatus
The constant indicating that a method completed running before a SystemException was thrown.
_create_request(Context, String, NVList, NamedValue) - Method in class org.omg.CORBA.LocalObject
Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
_create_request(Context, String, NVList, NamedValue, ExceptionList, ContextList) - Method in class org.omg.CORBA.LocalObject
Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
_create_request(Context, String, NVList, NamedValue) - Method in interface org.omg.CORBA.Object
Creates a Request instance initialized with the given context, method name, list of arguments, and container for the method's return value.
_create_request(Context, String, NVList, NamedValue, ExceptionList, ContextList) - Method in interface org.omg.CORBA.Object
Creates a Request instance initialized with the given context, method name, list of arguments, container for the method's return value, list of possible exceptions, and list of context strings needing to be resolved.
_create_request(Context, String, NVList, NamedValue) - Method in class org.omg.CORBA.portable.ObjectImpl
Creates a Request object that contains the given context, method, argument list, and container for the result.
_create_request(Context, String, NVList, NamedValue, ExceptionList, ContextList) - Method in class org.omg.CORBA.portable.ObjectImpl
Creates a Request object that contains the given context, method, argument list, container for the result, exceptions, and list of property names to be used in resolving the context strings.
_default_POA() - Method in class org.omg.PortableServer.Servant
Returns the root POA from the ORB instance associated with the servant.
_DISCARDING - Static variable in class org.omg.PortableServer.POAManagerPackage.State
_dk_AbstractInterface - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_Alias - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_all - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_Array - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_Attribute - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_Constant - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_Enum - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_Exception - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_Fixed - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_Interface - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_Module - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_Native - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_none - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_Operation - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_Primitive - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_Repository - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_Sequence - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_String - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_Struct - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_Typedef - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_Union - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_Value - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_ValueBox - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_ValueMember - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_dk_Wstring - Static variable in class org.omg.CORBA.DefinitionKind
The constant that indicates that an Interface Repository object does not have a definition kind.
_duplicate() - Method in class org.omg.CORBA.LocalObject
Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
_duplicate() - Method in interface org.omg.CORBA.Object
Returns a duplicate of this CORBA object reference.
_duplicate() - Method in class org.omg.CORBA.portable.ObjectImpl
Returns a duplicate of this ObjectImpl object.
_DynAnyFactoryStub - Class in org.omg.DynamicAny
DynAny objects can be created by invoking operations on the DynAnyFactory object.
_DynAnyFactoryStub() - Constructor for class org.omg.DynamicAny._DynAnyFactoryStub
_DynAnyStub - Class in org.omg.DynamicAny
Any values can be dynamically interpreted (traversed) and constructed through DynAny objects.
_DynAnyStub() - Constructor for class org.omg.DynamicAny._DynAnyStub
_DynArrayStub - Class in org.omg.DynamicAny
DynArray objects support the manipulation of IDL arrays.
_DynArrayStub() - Constructor for class org.omg.DynamicAny._DynArrayStub
_DynEnumStub - Class in org.omg.DynamicAny
DynEnum objects support the manipulation of IDL enumerated values.
_DynEnumStub() - Constructor for class org.omg.DynamicAny._DynEnumStub
_DynFixedStub - Class in org.omg.DynamicAny
DynFixed objects support the manipulation of IDL fixed values.
_DynFixedStub() - Constructor for class org.omg.DynamicAny._DynFixedStub
_DynSequenceStub - Class in org.omg.DynamicAny
DynSequence objects support the manipulation of IDL sequences.
_DynSequenceStub() - Constructor for class org.omg.DynamicAny._DynSequenceStub
_DynStructStub - Class in org.omg.DynamicAny
DynStruct objects support the manipulation of IDL struct and exception values.
_DynStructStub() - Constructor for class org.omg.DynamicAny._DynStructStub
_DynUnionStub - Class in org.omg.DynamicAny
DynUnion objects support the manipulation of IDL unions.
_DynUnionStub() - Constructor for class org.omg.DynamicAny._DynUnionStub
_DynValueStub - Class in org.omg.DynamicAny
DynValue objects support the manipulation of IDL non-boxed value types.
_DynValueStub() - Constructor for class org.omg.DynamicAny._DynValueStub
_get_codebase() - Method in class org.omg.CORBA_2_3.portable.ObjectImpl
Returns the codebase for this object reference.
_get_delegate() - Method in class org.omg.CORBA.portable.ObjectImpl
Retrieves the reference to the vendor-specific Delegate object to which this ObjectImpl object delegates all methods invoked on it.
_get_delegate() - Method in class org.omg.PortableServer.Servant
Gets the ORB vendor-specific implementation of PortableServer::Servant.
_get_domain_managers() - Method in class org.omg.CORBA.LocalObject
Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented.
_get_domain_managers() - Method in interface org.omg.CORBA.Object
Retrieves the DomainManagers of this object.
_get_domain_managers() - Method in class org.omg.CORBA.portable.ObjectImpl
Retrieves a list of the domain managers for this ObjectImpl object.
_get_interface() - Method in class org.omg.CORBA.LocalObject
Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented.
_get_interface_def() - Method in class org.omg.CORBA.LocalObject
Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
_get_interface_def() - Method in interface org.omg.CORBA.Object
Obtains an InterfaceDef for the object implementation referenced by this object reference.
_get_interface_def() - Method in class org.omg.CORBA.portable.ObjectImpl
Retrieves the interface definition for this ObjectImpl object.
_get_interface_def() - Method in class org.omg.PortableServer.Servant
Returns an InterfaceDef object as a CORBA::Object that defines the runtime type of the CORBA::Object implemented by the Servant.
_get_policy(int) - Method in class org.omg.CORBA.LocalObject
Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented.
_get_policy(int) - Method in interface org.omg.CORBA.Object
Returns the Policy object of the specified type which applies to this object.
_get_policy(int) - Method in class org.omg.CORBA.portable.ObjectImpl
Retrieves the Policy object for this ObjectImpl object that has the given policy type.
_hash(int) - Method in class org.omg.CORBA.LocalObject
Returns a hash value that is consistent for the lifetime of the object, using the given number as the maximum.
_hash(int) - Method in interface org.omg.CORBA.Object
Returns an ORB-internal identifier for this object reference.
_hash(int) - Method in class org.omg.CORBA.portable.ObjectImpl
Retrieves the hash code that serves as an ORB-internal identifier for this ObjectImpl object.
_HOLDING - Static variable in class org.omg.PortableServer.POAManagerPackage.State
_IDLTypeStub - Class in org.omg.CORBA
The Stub for IDLType.
_IDLTypeStub() - Constructor for class org.omg.CORBA._IDLTypeStub
Constructs a default _IDLTypeStub object.
_IDLTypeStub(Delegate) - Constructor for class org.omg.CORBA._IDLTypeStub
Constructs an _IDLTypeStub object initialized with the given Delegate object.
_ids() - Method in class org.omg.CORBA._IDLTypeStub
_ids() - Method in class org.omg.CORBA._PolicyStub
_ids() - Method in class org.omg.CORBA.DynamicImplementation
Deprecated.
_ids() - Method in class org.omg.CORBA.portable.ObjectImpl
Retrieves a string array containing the repository identifiers supported by this ObjectImpl object.
_ids() - Method in class org.omg.CosNaming._BindingIteratorImplBase
_ids() - Method in class org.omg.CosNaming._BindingIteratorStub
_ids() - Method in class org.omg.CosNaming._NamingContextExtStub
_ids() - Method in class org.omg.CosNaming._NamingContextImplBase
_ids() - Method in class org.omg.CosNaming._NamingContextStub
_ids() - Method in class org.omg.DynamicAny._DynAnyFactoryStub
_ids() - Method in class org.omg.DynamicAny._DynAnyStub
_ids() - Method in class org.omg.DynamicAny._DynArrayStub
_ids() - Method in class org.omg.DynamicAny._DynEnumStub
_ids() - Method in class org.omg.DynamicAny._DynFixedStub
_ids() - Method in class org.omg.DynamicAny._DynSequenceStub
_ids() - Method in class org.omg.DynamicAny._DynStructStub
_ids() - Method in class org.omg.DynamicAny._DynUnionStub
_ids() - Method in class org.omg.DynamicAny._DynValueStub
_ids() - Method in class org.omg.PortableServer._ServantActivatorStub
_ids() - Method in class org.omg.PortableServer._ServantLocatorStub
_ids() - Method in class org.omg.stub.java.rmi._Remote_Stub
Returns an array of repository ids that an object implements.
_IMPLICIT_ACTIVATION - Static variable in class org.omg.PortableServer.ImplicitActivationPolicyValue
_INACTIVE - Static variable in class org.omg.PortableServer.POAManagerPackage.State
_invoke(OutputStream) - Method in class org.omg.CORBA.LocalObject
Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
_invoke(String, InputStream, ResponseHandler) - Method in interface org.omg.CORBA.portable.InvokeHandler
Invoked by the ORB to dispatch a request to the servant.
_invoke(OutputStream) - Method in class org.omg.CORBA.portable.ObjectImpl
Invokes an operation and returns an InputStream object for reading the response.
_invoke(String, InputStream, ResponseHandler) - Method in class org.omg.CosNaming.BindingIteratorPOA
_invoke(String, InputStream, ResponseHandler) - Method in class org.omg.CosNaming.NamingContextExtPOA
_invoke(String, InputStream, ResponseHandler) - Method in class org.omg.CosNaming.NamingContextPOA
_invoke(String, InputStream, ResponseHandler) - Method in class org.omg.PortableServer.ServantActivatorPOA
_invoke(String, InputStream, ResponseHandler) - Method in class org.omg.PortableServer.ServantLocatorPOA
_is_a(String) - Method in class org.omg.CORBA.LocalObject
Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented.
_is_a(String) - Method in interface org.omg.CORBA.Object
Checks whether this object is an instance of a class that implements the given interface.
_is_a(String) - Method in class org.omg.CORBA.portable.ObjectImpl
Checks whether the object identified by the given repository identifier is an ObjectImpl object.
_is_a(String) - Method in class org.omg.PortableServer.Servant
Checks to see if the specified repository_id is present on the list returned by _all_interfaces() or is the repository_id for the generic CORBA Object.
_is_equivalent(Object) - Method in class org.omg.CORBA.LocalObject
Determines whether the two object references are equivalent, so far as the ORB can easily determine.
_is_equivalent(Object) - Method in interface org.omg.CORBA.Object
Determines whether the two object references are equivalent, so far as the ORB can easily determine.
_is_equivalent(Object) - Method in class org.omg.CORBA.portable.ObjectImpl
Checks whether the the given ObjectImpl object is equivalent to this ObjectImpl object.
_is_local() - Method in class org.omg.CORBA.LocalObject
Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
_is_local() - Method in class org.omg.CORBA.portable.ObjectImpl
Checks whether this ObjectImpl object is implemented by a local servant.
_missing_node - Static variable in class org.omg.CosNaming.NamingContextPackage.NotFoundReason
_MULTIPLE_ID - Static variable in class org.omg.PortableServer.IdUniquenessPolicyValue
_NamingContextExtStub - Class in org.omg.CosNaming
NamingContextExt is the extension of NamingContext which contains a set of name bindings in which each name is unique and is part of Interoperable Naming Service.
_NamingContextExtStub() - Constructor for class org.omg.CosNaming._NamingContextExtStub
_NamingContextImplBase - Class in org.omg.CosNaming
_NamingContextImplBase() - Constructor for class org.omg.CosNaming._NamingContextImplBase
_NamingContextStub - Class in org.omg.CosNaming
A naming context is an object that contains a set of name bindings in which each name is unique.
_NamingContextStub() - Constructor for class org.omg.CosNaming._NamingContextStub
_ncontext - Static variable in class org.omg.CosNaming.BindingType
_NO_IMPLICIT_ACTIVATION - Static variable in class org.omg.PortableServer.ImplicitActivationPolicyValue
_nobject - Static variable in class org.omg.CosNaming.BindingType
_non_existent() - Method in class org.omg.CORBA.LocalObject
Always returns false.
_non_existent() - Method in interface org.omg.CORBA.Object
Determines whether the server object for this object reference has been destroyed.
_non_existent() - Method in class org.omg.CORBA.portable.ObjectImpl
Checks whether the server object for this ObjectImpl object has been destroyed.
_non_existent() - Method in class org.omg.PortableServer.Servant
Checks for the existence of an Object.
_NON_RETAIN - Static variable in class org.omg.PortableServer.ServantRetentionPolicyValue
_not_context - Static variable in class org.omg.CosNaming.NamingContextPackage.NotFoundReason
_not_object - Static variable in class org.omg.CosNaming.NamingContextPackage.NotFoundReason
_object_id() - Method in class org.omg.PortableServer.Servant
Allows easy execution of common methods, equivalent to calling PortableServer::Current::get_object_id.
_opsClass - Static variable in class org.omg.DynamicAny._DynAnyFactoryStub
_opsClass - Static variable in class org.omg.DynamicAny._DynAnyStub
_opsClass - Static variable in class org.omg.DynamicAny._DynArrayStub
_opsClass - Static variable in class org.omg.DynamicAny._DynEnumStub
_opsClass - Static variable in class org.omg.DynamicAny._DynFixedStub
_opsClass - Static variable in class org.omg.DynamicAny._DynSequenceStub
_opsClass - Static variable in class org.omg.DynamicAny._DynStructStub
_opsClass - Static variable in class org.omg.DynamicAny._DynUnionStub
_opsClass - Static variable in class org.omg.DynamicAny._DynValueStub
_opsClass - Static variable in class org.omg.PortableServer._ServantActivatorStub
_opsClass - Static variable in class org.omg.PortableServer._ServantLocatorStub
_orb() - Method in class org.omg.CORBA.LocalObject
Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
_orb() - Method in class org.omg.CORBA.portable.ObjectImpl
Returns a reference to the ORB associated with this object and its delegate.
_orb() - Method in class org.omg.PortableServer.Servant
Returns the instance of the ORB currently associated with the Servant (convenience method).
_ORB_CTRL_MODEL - Static variable in class org.omg.PortableServer.ThreadPolicyValue
_PARAM_IN - Static variable in class org.omg.CORBA.ParameterMode
_PARAM_INOUT - Static variable in class org.omg.CORBA.ParameterMode
_PARAM_OUT - Static variable in class org.omg.CORBA.ParameterMode
_PERSISTENT - Static variable in class org.omg.PortableServer.LifespanPolicyValue
_poa() - Method in class org.omg.PortableServer.Servant
Allows easy execution of common methods, equivalent to PortableServer::Current:get_POA.
_PolicyStub - Class in org.omg.CORBA
The Stub for Policy.
_PolicyStub() - Constructor for class org.omg.CORBA._PolicyStub
Constructors NOTE: If the default constructor is used, the object is useless until _set_delegate (...) is called.
_PolicyStub(Delegate) - Constructor for class org.omg.CORBA._PolicyStub
Constructs a _PolicyStub object initialized with the given Delegate object.
_postEdit(UndoableEdit) - Method in class javax.swing.undo.UndoableEditSupport
Called only from postEdit and endUpdate.
_read(InputStream) - Method in class org.omg.CORBA.AnyHolder
Reads from input and initalizes the value in the Holder with the unmarshalled data.
_read(InputStream) - Method in class org.omg.CORBA.AnySeqHolder
_read(InputStream) - Method in class org.omg.CORBA.BooleanHolder
Reads unmarshalled data from input and assigns it to this BooleanHolder object's value field.
_read(InputStream) - Method in class org.omg.CORBA.BooleanSeqHolder
_read(InputStream) - Method in class org.omg.CORBA.ByteHolder
Reads from input and initalizes the value in this ByteHolder object with the unmarshalled data.
_read(InputStream) - Method in class org.omg.CORBA.CharHolder
Reads from input and initalizes the value in this CharHolder object with the unmarshalled data.
_read(InputStream) - Method in class org.omg.CORBA.CharSeqHolder
_read(InputStream) - Method in class org.omg.CORBA.CurrentHolder
_read(InputStream) - Method in class org.omg.CORBA.DoubleHolder
Read a double value from the input stream and store it in the value member.
_read(InputStream) - Method in class org.omg.CORBA.DoubleSeqHolder
_read(InputStream) - Method in class org.omg.CORBA.FixedHolder
Read a fixed point value from the input stream and store it in the value member.
_read(InputStream) - Method in class org.omg.CORBA.FloatHolder
Read a float from an input stream and initialize the value member with the float value.
_read(InputStream) - Method in class org.omg.CORBA.FloatSeqHolder
_read(InputStream) - Method in class org.omg.CORBA.IntHolder
Reads unmarshalled data from input and assigns it to the value field in this IntHolder object.
_read(InputStream) - Method in class org.omg.CORBA.LongHolder
Reads from input and initalizes the value in the Holder with the unmarshalled data.
_read(InputStream) - Method in class org.omg.CORBA.LongLongSeqHolder
_read(InputStream) - Method in class org.omg.CORBA.LongSeqHolder
_read(InputStream) - Method in class org.omg.CORBA.ObjectHolder
Reads from input and initalizes the value in this ObjectHolder object with the unmarshalled data.
_read(InputStream) - Method in class org.omg.CORBA.OctetSeqHolder
_read(InputStream) - Method in class org.omg.CORBA.ParameterModeHolder
_read(InputStream) - Method in class org.omg.CORBA.PolicyErrorHolder
_read(InputStream) - Method in class org.omg.CORBA.PolicyHolder
_read(InputStream) - Method in class org.omg.CORBA.PolicyListHolder
_read(InputStream) - Method in interface org.omg.CORBA.portable.Streamable
Reads data from istream and initalizes the value field of the Holder with the unmarshalled data.
_read(InputStream) - Method in class org.omg.CORBA.PrincipalHolder
Deprecated.
_read(InputStream) - Method in class org.omg.CORBA.ServiceInformationHolder
Reads unmarshalled data from the input stream in and assigns it to the value field in this ServiceInformationHolder object.
_read(InputStream) - Method in class org.omg.CORBA.ShortHolder
Reads from input and initalizes the value in this ShortHolder object with the unmarshalled data.
_read(InputStream) - Method in class org.omg.CORBA.ShortSeqHolder
_read(InputStream) - Method in class org.omg.CORBA.StringHolder
Reads the unmarshalled data from input and assigns it to the value field of this StringHolder object.
_read(InputStream) - Method in class org.omg.CORBA.StringSeqHolder
_read(InputStream) - Method in class org.omg.CORBA.TypeCodeHolder
Reads from input and initalizes the value in this TypeCodeHolder object with the unmarshalled data.
_read(InputStream) - Method in class org.omg.CORBA.ULongLongSeqHolder
_read(InputStream) - Method in class org.omg.CORBA.ULongSeqHolder
_read(InputStream) - Method in class org.omg.CORBA.UnknownUserExceptionHolder
_read(InputStream) - Method in class org.omg.CORBA.UShortSeqHolder
_read(InputStream) - Method in class org.omg.CORBA.ValueBaseHolder
Reads from input and initalizes the value in the Holder with the unmarshalled data.
_read(InputStream) - Method in class org.omg.CORBA.WCharSeqHolder
_read(InputStream) - Method in class org.omg.CORBA.WrongTransactionHolder
_read(InputStream) - Method in class org.omg.CORBA.WStringSeqHolder
_read(InputStream) - Method in class org.omg.CosNaming.BindingHolder
_read(InputStream) - Method in class org.omg.CosNaming.BindingIteratorHolder
_read(InputStream) - Method in class org.omg.CosNaming.BindingListHolder
_read(InputStream) - Method in class org.omg.CosNaming.BindingTypeHolder
_read(InputStream) - Method in class org.omg.CosNaming.NameComponentHolder
_read(InputStream) - Method in class org.omg.CosNaming.NameHolder
_read(InputStream) - Method in class org.omg.CosNaming.NamingContextExtHolder
_read(InputStream) - Method in class org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder
_read(InputStream) - Method in class org.omg.CosNaming.NamingContextHolder
_read(InputStream) - Method in class org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder
_read(InputStream) - Method in class org.omg.CosNaming.NamingContextPackage.CannotProceedHolder
_read(InputStream) - Method in class org.omg.CosNaming.NamingContextPackage.InvalidNameHolder
_read(InputStream) - Method in class org.omg.CosNaming.NamingContextPackage.NotEmptyHolder
_read(InputStream) - Method in class org.omg.CosNaming.NamingContextPackage.NotFoundHolder
_read(InputStream) - Method in class org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder
_read(InputStream) - Method in class org.omg.IOP.IORHolder
_read(InputStream) - Method in class org.omg.IOP.MultipleComponentProfileHolder
_read(InputStream) - Method in class org.omg.IOP.ServiceContextHolder
_read(InputStream) - Method in class org.omg.IOP.ServiceContextListHolder
_read(InputStream) - Method in class org.omg.IOP.TaggedComponentHolder
_read(InputStream) - Method in class org.omg.IOP.TaggedProfileHolder
_read(InputStream) - Method in class org.omg.PortableInterceptor.IORInterceptor_3_0Holder
_read(InputStream) - Method in class org.omg.PortableInterceptor.ObjectReferenceFactoryHolder
_read(InputStream) - Method in class org.omg.PortableInterceptor.ObjectReferenceTemplateHolder
_read(InputStream) - Method in class org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder
_read(InputStream) - Method in class org.omg.PortableServer.ServantLocatorPackage.CookieHolder
_release() - Method in class org.omg.CORBA.LocalObject
Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
_release() - Method in interface org.omg.CORBA.Object
Signals that the caller is done using this object reference, so internal ORB resources associated with this object reference can be released.
_release() - Method in class org.omg.CORBA.portable.ObjectImpl
Releases the resources associated with this ObjectImpl object.
_releaseReply(InputStream) - Method in class org.omg.CORBA.LocalObject
Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
_releaseReply(InputStream) - Method in class org.omg.CORBA.portable.ObjectImpl
Releases the given reply stream back to the ORB when unmarshalling has completed after a call to the method _invoke.
_Remote_Stub - Class in org.omg.stub.java.rmi
This class provides the Stub for the Remote Type.
_Remote_Stub() - Constructor for class org.omg.stub.java.rmi._Remote_Stub
_request(String) - Method in class org.omg.CORBA.LocalObject
Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
_request(String, boolean) - Method in class org.omg.CORBA.LocalObject
Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
_request(String) - Method in interface org.omg.CORBA.Object
Creates a Request instance for use in the Dynamic Invocation Interface.
_request(String) - Method in class org.omg.CORBA.portable.ObjectImpl
Creates a Request object containing the given method that can be used with the Dynamic Invocation Interface.
_request(String, boolean) - Method in class org.omg.CORBA.portable.ObjectImpl
Returns an OutputStream object to use for marshalling the arguments of the given method.
_RETAIN - Static variable in class org.omg.PortableServer.ServantRetentionPolicyValue
_servant_postinvoke(ServantObject) - Method in class org.omg.CORBA.LocalObject
Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
_servant_postinvoke(ServantObject) - Method in class org.omg.CORBA.portable.ObjectImpl
Is called by the local stub after it has invoked an operation on the local servant that was previously retrieved from a call to the method _servant_preinvoke.
_servant_preinvoke(String, Class) - Method in class org.omg.CORBA.LocalObject
Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method is the default implementation of the org.omg.CORBA.Object method.
_servant_preinvoke(String, Class) - Method in class org.omg.CORBA.portable.ObjectImpl
Returns a Java reference to the local servant that should be used for sending a request for the method specified.
_ServantActivatorStub - Class in org.omg.PortableServer
When the POA has the RETAIN policy it uses servant managers that are ServantActivators.
_ServantActivatorStub() - Constructor for class org.omg.PortableServer._ServantActivatorStub
_ServantLocatorStub - Class in org.omg.PortableServer
When the POA has the NON_RETAIN policy it uses servant managers that are ServantLocators.
_ServantLocatorStub() - Constructor for class org.omg.PortableServer._ServantLocatorStub
_set_delegate(Delegate) - Method in class org.omg.CORBA.portable.ObjectImpl
Sets the Delegate for this ObjectImpl instance to the given Delegate object.
_set_delegate(Delegate) - Method in class org.omg.PortableServer.Servant
Supports the Java ORB portability interfaces by providing a method for classes that support ORB portability through delegation to set their delegate.
_SET_OVERRIDE - Static variable in class org.omg.CORBA.SetOverrideType
The int constant for the enum value SET_OVERRIDE.
_set_policy_override(Policy[], SetOverrideType) - Method in class org.omg.CORBA.LocalObject
Throws an org.omg.CORBA.NO_IMPLEMENT exception with the message "This is a locally constrained object." This method does not apply to local objects and is therefore not implemented.
_set_policy_override(Policy[], SetOverrideType) - Method in interface org.omg.CORBA.Object
Returns a new Object with the given policies either replacing any existing policies in this Object or with the given policies added to the existing ones, depending on the value of the given SetOverrideType object.
_set_policy_override(Policy[], SetOverrideType) - Method in class org.omg.CORBA.portable.ObjectImpl
Sets this ObjectImpl object's override type for the given policies to the given instance of SetOverrideType.
_SINGLE_THREAD_MODEL - Static variable in class org.omg.PortableServer.ThreadPolicyValue
_SYSTEM_ID - Static variable in class org.omg.PortableServer.IdAssignmentPolicyValue
_this() - Method in class org.omg.CosNaming.BindingIteratorPOA
_this(ORB) - Method in class org.omg.CosNaming.BindingIteratorPOA
_this() - Method in class org.omg.CosNaming.NamingContextExtPOA
_this(ORB) - Method in class org.omg.CosNaming.NamingContextExtPOA
_this() - Method in class org.omg.CosNaming.NamingContextPOA
_this(ORB) - Method in class org.omg.CosNaming.NamingContextPOA
_this() - Method in class org.omg.PortableServer.ServantActivatorPOA
_this(ORB) - Method in class org.omg.PortableServer.ServantActivatorPOA
_this() - Method in class org.omg.PortableServer.ServantLocatorPOA
_this(ORB) - Method in class org.omg.PortableServer.ServantLocatorPOA
_this_object() - Method in class org.omg.PortableServer.Servant
Allows the servant to obtain the object reference for the target CORBA object it is incarnating for that request.
_this_object(ORB) - Method in class org.omg.PortableServer.Servant
Allows the servant to obtain the object reference for the target CORBA Object it is incarnating for that request.
_tk_abstract_interface - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type abstract interface.
_tk_alias - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type alias.
_tk_any - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type any.
_tk_array - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type array.
_tk_boolean - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type boolean.
_tk_char - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type char.
_tk_double - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type double.
_tk_enum - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type enum.
_tk_except - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type except.
_tk_fixed - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type fixed.
_tk_float - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type float.
_tk_long - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type long.
_tk_longdouble - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type longdouble.
_tk_longlong - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type longlong.
_tk_native - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type native.
_tk_null - Static variable in class org.omg.CORBA.TCKind
The int constant for a null IDL data type.
_tk_objref - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type objref.
_tk_octet - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type octet.
_tk_Principal - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type Principal.
_tk_sequence - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type sequence.
_tk_short - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type short.
_tk_string - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type string.
_tk_struct - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type struct.
_tk_TypeCode - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type TypeCode.
_tk_ulong - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type ulong.
_tk_ulonglong - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type ulonglong.
_tk_union - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type union.
_tk_ushort - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type ushort.
_tk_value - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type value.
_tk_value_box - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type value_box.
_tk_void - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type void.
_tk_wchar - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type wchar.
_tk_wstring - Static variable in class org.omg.CORBA.TCKind
The int constant for the IDL data type wstring.
_TRANSIENT - Static variable in class org.omg.PortableServer.LifespanPolicyValue
_truncatable_ids() - Method in interface org.omg.CORBA.portable.ValueBase
Provides truncatable repository ids.
_type() - Method in class org.omg.CORBA.AnyHolder
Returns the TypeCode object corresponding to the value held in this AnyHolder object.
_type() - Method in class org.omg.CORBA.AnySeqHolder
_type() - Method in class org.omg.CORBA.BooleanHolder
Retrieves the TypeCode object that corresponds to the value held in this BooleanHolder object.
_type() - Method in class org.omg.CORBA.BooleanSeqHolder
_type() - Method in class org.omg.CORBA.ByteHolder
Returns the TypeCode corresponding to the value held in this ByteHolder object.
_type() - Method in class org.omg.CORBA.CharHolder
Returns the TypeCode object corresponding to the value held in this CharHolder object.
_type() - Method in class org.omg.CORBA.CharSeqHolder
_type() - Method in class org.omg.CORBA.CurrentHolder
_type() - Method in class org.omg.CORBA.DoubleHolder
Return the TypeCode of this holder object.
_type() - Method in class org.omg.CORBA.DoubleSeqHolder
_type() - Method in class org.omg.CORBA.FixedHolder
Return the TypeCode of this holder object.
_type() - Method in class org.omg.CORBA.FloatHolder
Return the TypeCode of this Streamable.
_type() - Method in class org.omg.CORBA.FloatSeqHolder
_type() - Method in class org.omg.CORBA.IntHolder
Retrieves the TypeCode object that corresponds to the value held in this IntHolder object's value field.
_type() - Method in class org.omg.CORBA.LongHolder
Returns the TypeCode object corresponding to the value held in the Holder.
_type() - Method in class org.omg.CORBA.LongLongSeqHolder
_type() - Method in class org.omg.CORBA.LongSeqHolder
_type() - Method in class org.omg.CORBA.ObjectHolder
Returns the TypeCode corresponding to the value held in this ObjectHolder object
_type() - Method in class org.omg.CORBA.OctetSeqHolder
_type() - Method in class org.omg.CORBA.ParameterModeHolder
_type() - Method in class org.omg.CORBA.PolicyErrorHolder
_type() - Method in class org.omg.CORBA.PolicyHolder
_type() - Method in class org.omg.CORBA.PolicyListHolder
_type() - Method in interface org.omg.CORBA.portable.Streamable
Retrieves the TypeCode object corresponding to the value in the value field of the Holder.
_type() - Method in class org.omg.CORBA.PrincipalHolder
Deprecated.
_type() - Method in class org.omg.CORBA.ServiceInformationHolder
Retrieves the TypeCode object that corresponds to the value held in this ServiceInformationHolder object's value field.
_type() - Method in class org.omg.CORBA.ShortHolder
Returns the TypeCode corresponding to the value held in this ShortHolder object.
_type() - Method in class org.omg.CORBA.ShortSeqHolder
_type() - Method in class org.omg.CORBA.StringHolder
Retrieves the TypeCode object that corresponds to the value held in this StringHolder object.
_type() - Method in class org.omg.CORBA.StringSeqHolder
_type() - Method in class org.omg.CORBA.TypeCodeHolder
Returns the TypeCode corresponding to the value held in this TypeCodeHolder object.
_type() - Method in class org.omg.CORBA.ULongLongSeqHolder
_type() - Method in class org.omg.CORBA.ULongSeqHolder
_type() - Method in class org.omg.CORBA.UnknownUserExceptionHolder
_type() - Method in class org.omg.CORBA.UShortSeqHolder
_type() - Method in class org.omg.CORBA.ValueBaseHolder
Returns the TypeCode object corresponding to the value held in the Holder.
_type() - Method in class org.omg.CORBA.WCharSeqHolder
_type() - Method in class org.omg.CORBA.WrongTransactionHolder
_type() - Method in class org.omg.CORBA.WStringSeqHolder
_type() - Method in class org.omg.CosNaming.BindingHolder
_type() - Method in class org.omg.CosNaming.BindingIteratorHolder
_type() - Method in class org.omg.CosNaming.BindingListHolder
_type() - Method in class org.omg.CosNaming.BindingTypeHolder
_type() - Method in class org.omg.CosNaming.NameComponentHolder
_type() - Method in class org.omg.CosNaming.NameHolder
_type() - Method in class org.omg.CosNaming.NamingContextExtHolder
_type() - Method in class org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder
_type() - Method in class org.omg.CosNaming.NamingContextHolder
_type() - Method in class org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder
_type() - Method in class org.omg.CosNaming.NamingContextPackage.CannotProceedHolder
_type() - Method in class org.omg.CosNaming.NamingContextPackage.InvalidNameHolder
_type() - Method in class org.omg.CosNaming.NamingContextPackage.NotEmptyHolder
_type() - Method in class org.omg.CosNaming.NamingContextPackage.NotFoundHolder
_type() - Method in class org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder
_type() - Method in class org.omg.IOP.IORHolder
_type() - Method in class org.omg.IOP.MultipleComponentProfileHolder
_type() - Method in class org.omg.IOP.ServiceContextHolder
_type() - Method in class org.omg.IOP.ServiceContextListHolder
_type() - Method in class org.omg.IOP.TaggedComponentHolder
_type() - Method in class org.omg.IOP.TaggedProfileHolder
_type() - Method in class org.omg.PortableInterceptor.IORInterceptor_3_0Holder
_type() - Method in class org.omg.PortableInterceptor.ObjectReferenceFactoryHolder
_type() - Method in class org.omg.PortableInterceptor.ObjectReferenceTemplateHolder
_type() - Method in class org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder
_type() - Method in class org.omg.PortableServer.ServantLocatorPackage.CookieHolder
_UNIQUE_ID - Static variable in class org.omg.PortableServer.IdUniquenessPolicyValue
_USE_ACTIVE_OBJECT_MAP_ONLY - Static variable in class org.omg.PortableServer.RequestProcessingPolicyValue
_USE_DEFAULT_SERVANT - Static variable in class org.omg.PortableServer.RequestProcessingPolicyValue
_USE_SERVANT_MANAGER - Static variable in class org.omg.PortableServer.RequestProcessingPolicyValue
_USER_ID - Static variable in class org.omg.PortableServer.IdAssignmentPolicyValue
_write(OutputStream) - Method in class org.omg.CORBA.AnyHolder
Marshals to output the value in this AnyHolder object.
_write(OutputStream) - Method in class org.omg.CORBA.AnySeqHolder
_write(OutputStream) - Method in class org.omg.CORBA.BooleanHolder
Marshals the value in this BooleanHolder object's value field to the output stream output.
_write(OutputStream) - Method in class org.omg.CORBA.BooleanSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA.ByteHolder
Marshals to output the value in this ByteHolder object.
_write(OutputStream) - Method in class org.omg.CORBA.CharHolder
Marshals to output the value in this CharHolder object.
_write(OutputStream) - Method in class org.omg.CORBA.CharSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA.CurrentHolder
_write(OutputStream) - Method in class org.omg.CORBA.DoubleHolder
Write the double value stored in this holder to an OutputStream.
_write(OutputStream) - Method in class org.omg.CORBA.DoubleSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA.FixedHolder
Write the fixed point value stored in this holder to an OutputStream.
_write(OutputStream) - Method in class org.omg.CORBA.FloatHolder
Write the float value into an output stream.
_write(OutputStream) - Method in class org.omg.CORBA.FloatSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA.IntHolder
Marshals the value in this IntHolder object's value field to the output stream output.
_write(OutputStream) - Method in class org.omg.CORBA.LongHolder
Marshals to output the value in the Holder.
_write(OutputStream) - Method in class org.omg.CORBA.LongLongSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA.LongSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA.ObjectHolder
Marshals to output the value in this ObjectHolder object.
_write(OutputStream) - Method in class org.omg.CORBA.OctetSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA.ParameterModeHolder
_write(OutputStream) - Method in class org.omg.CORBA.PolicyErrorHolder
_write(OutputStream) - Method in class org.omg.CORBA.PolicyHolder
_write(OutputStream) - Method in class org.omg.CORBA.PolicyListHolder
_write(OutputStream) - Method in interface org.omg.CORBA.portable.Streamable
Marshals to ostream the value in the value field of the Holder.
_write(OutputStream) - Method in class org.omg.CORBA.PrincipalHolder
Deprecated.
_write(OutputStream) - Method in class org.omg.CORBA.ServiceInformationHolder
Marshals the value in this ServiceInformationHolder object's value field to the output stream out.
_write(OutputStream) - Method in class org.omg.CORBA.ShortHolder
Marshals to output the value in this ShortHolder object.
_write(OutputStream) - Method in class org.omg.CORBA.ShortSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA.StringHolder
Marshals the value held by this StringHolder object to the output stream output.
_write(OutputStream) - Method in class org.omg.CORBA.StringSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA.TypeCodeHolder
Marshals to output the value in this TypeCodeHolder object.
_write(OutputStream) - Method in class org.omg.CORBA.ULongLongSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA.ULongSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA.UnknownUserExceptionHolder
_write(OutputStream) - Method in class org.omg.CORBA.UShortSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA.ValueBaseHolder
Marshals to output the value in the Holder.
_write(OutputStream) - Method in class org.omg.CORBA.WCharSeqHolder
_write(OutputStream) - Method in class org.omg.CORBA.WrongTransactionHolder
_write(OutputStream) - Method in class org.omg.CORBA.WStringSeqHolder
_write(OutputStream) - Method in class org.omg.CosNaming.BindingHolder
_write(OutputStream) - Method in class org.omg.CosNaming.BindingIteratorHolder
_write(OutputStream) - Method in class org.omg.CosNaming.BindingListHolder
_write(OutputStream) - Method in class org.omg.CosNaming.BindingTypeHolder
_write(OutputStream) - Method in class org.omg.CosNaming.NameComponentHolder
_write(OutputStream) - Method in class org.omg.CosNaming.NameHolder
_write(OutputStream) - Method in class org.omg.CosNaming.NamingContextExtHolder
_write(OutputStream) - Method in class org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder
_write(OutputStream) - Method in class org.omg.CosNaming.NamingContextHolder
_write(OutputStream) - Method in class org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder
_write(OutputStream) - Method in class org.omg.CosNaming.NamingContextPackage.CannotProceedHolder
_write(OutputStream) - Method in class org.omg.CosNaming.NamingContextPackage.InvalidNameHolder
_write(OutputStream) - Method in class org.omg.CosNaming.NamingContextPackage.NotEmptyHolder
_write(OutputStream) - Method in class org.omg.CosNaming.NamingContextPackage.NotFoundHolder
_write(OutputStream) - Method in class org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder
_write(OutputStream) - Method in class org.omg.IOP.IORHolder
_write(OutputStream) - Method in class org.omg.IOP.MultipleComponentProfileHolder
_write(OutputStream) - Method in class org.omg.IOP.ServiceContextHolder
_write(OutputStream) - Method in class org.omg.IOP.ServiceContextListHolder
_write(OutputStream) - Method in class org.omg.IOP.TaggedComponentHolder
_write(OutputStream) - Method in class org.omg.IOP.TaggedProfileHolder
_write(OutputStream) - Method in class org.omg.PortableInterceptor.IORInterceptor_3_0Holder
_write(OutputStream) - Method in class org.omg.PortableInterceptor.ObjectReferenceFactoryHolder
_write(OutputStream) - Method in class org.omg.PortableInterceptor.ObjectReferenceTemplateHolder
_write(OutputStream) - Method in class org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder
_write(OutputStream) - Method in class org.omg.PortableServer.ServantLocatorPackage.CookieHolder
A B C D E F G H I J K L M N O P Q R S T U V W X Y Z _
Skip navigation links
  • Overview
  • Package
  • Class
  • Use
  • Tree
  • Deprecated
  • Index
  • Help
Java™ Platform
Standard Ed. 8
  • Prev Letter
  • Next Letter
  • Frames
  • No Frames